尊婆须蜜菩萨所集论

    No. 1549

    尊婆须蜜菩萨所集论序

婆须蜜菩萨大士。次继弥勒作佛。名师子如来也。从释迦文降生鞞提国。为大婆罗门梵摩渝子。厥名郁多罗。父命观佛。寻侍四月具睹相表威变容止。还白所见。父得不还。已出家学。改字婆须蜜。佛般涅槃后。游教周妒国槃奈园。高才盖世。奔逸绝尘。撰集斯经焉。别七品为一揵度。尽十二揵度。其所集也。后四品一揵度。训释佛偈也。凡十一品十四揵度也。该罗深广。与阿毗昙并兴外国。傍通大乘。持明尽漏博涉十法百行之能事毕矣。寻之[漭-廾+卉]然。犹沧海之无崖。可不谓之广乎。陟之瞠尔。犹昆岳之无顶。可不谓之高乎。宝渚极目。厌夜光之珍。岩岫举睫。厌天智之玉。懿乎富也。何过此经。外国升高座者。未坠于地也。集斯经已入三昧定。如弹指顷神升兜术。弥妒路弥妒路刀利。及僧迦罗刹。适彼天宫。斯二三君子。皆次补处人也。弥妒路刀利者。光炎如来也。僧伽罗刹者。柔仁佛也。兹四大士。集乎一堂。对扬权智。贤圣默然。洋洋盈耳。不亦乐乎。罽宾沙门僧伽跋澄。以秦建元二十年。持此经一部来诣长安。武威太守赵政文业者。学不厌士也。求令出之。佛念译传。跋澄难陀禘婆三人执胡文。慧嵩笔受。以三月五日出。至七月十三日乃讫。胡本十二千首卢也。余与法和对校修饰。武威少多润色。此经说三乘为九品。持善修行。以正观迳。十六最悉。每寻上人之高韵。未尝不忘意味也。恨窥数仞之门晚。惧不悉其宗庙之美。百官之富矣

尊婆须蜜菩萨所集论卷第一

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    聚揵度首第一(秦言地亲也自品首尽七品名聚揵度)

  十力哀出世　　觉知一切法
  我今礼如来　　法及诸圣众
  最胜之善句　　诸贤圣听闻
  瞿昙大众中　　有益众生类

云何为色相。问色相云何。答曰。如觉知诸法。云何觉知诸法。答曰。为有界想为有胜耶。答曰。彼有一想。问一想为有胜耶。答曰。一想之中着欲诸垢诸界所缚。终不缚者是故诸结则衰。问如中诸结为有胜耶。答曰。当有还甘露。问如中当还甘露为有胜耶。答曰。依生身意受诸苦恼缘亦不起。是故身意诸苦恼已过去。问如中无色相。问设无色相色亦无相。答曰。若无色相亦无彼色。色相亦无相亦无淫色相。问犹如汝无色相有色。如是我无色相亦无相。亦有色相耶。或作是说。渐渐兴色相。问一色中或兴或不兴。此义云何。或作是说。若色一时渐积彼无色相。或作是说。渐渐分别色相此亦如本所说。或作是说。摄统色相。问过去未来色最别无教便有无色。或作是说。摄系色相。或作是说。及诸盖色相。或作是说。坏败色相。此亦过去未来所说。或作是说。色相有三种。可见有对。不可见有对。不可见无对。问若诸色不可见无对。欲使彼无色相耶。或作是说。色相往来是谓色相。问过去未来义不有异。或作是说。色相为色。或作是说。因四大义为色。世尊亦说四大。缘彼四大生色阴受盛问取要言之。彼则不说缘诸所有色。彼一切是四大。四大所造。答曰。此非取要。又作是说。缘更生诸痛阴或作是说。汝问何色相。设青青为色相。设黄即彼色相也。问我问一切色相。设彼是色相相无胜。答曰。色不同一相。此中有何咎。设相相不同。此义不然。犹若地为坚相。如今地异坚异。问一切色同一相。犹如无常。问自相无相地为自相。是故不应作是说。问我无自相我问一切诸相。或作是说。有对色相是色。为色相有对相者。犹如捻箭笞。是谓有色。如种谷子在地。随时溉灌彼便有色。云何非色相。答曰。反上所说义。尊昙摩多罗说。诸物无对彼非色。是谓非色相。无对之物彼亦不生。是谓无对。犹如无对是对迹。彼便是无对。如是非色相。四大所造色。有何等异。或作是说。无有异也。诸四大即是造色。问如世尊言。诸所有色彼一切是四大四大所造耶。于此经有违。答曰。非所造声。更有余根。如说六更乐愚人所贪忍苦乐行从此所兴乐以来于其中间不出六更乐外更有七更乐也。亦无造者。问若无造声者。亦不变易欲色。是我所色。亦是我有耶。或作是说。坚濡热动是四大相。犹如非地色从色造色。问四大转转优劣色不常作。欲使彼有造色耶。答曰。虽彼四大转转优劣得四大相。四大所兴色。非得四大相。彼非所兴色。或作是说。诸缘彼四大四大所兴色。问四大亦因四大。欲使是兴色耶。答曰。彼虽因四大。有若干所因。四大是兴色相。问色缘色相色转生色。答曰。云何得知色转生色。复不缘四大耶。或作是说有漏四大所兴色。亦有漏亦无漏。问诸有漏所造兴色被四大有何差降。诸无漏所兴色何等四大造耶。或作是说。无记四大所兴。复次所造色者。善不善无记。此亦如上所说。或作是说。依彼四大得兴色。问心心念法亦依四大。欲使彼是兴色耶。答曰。依四大诸根。诸根亦依心心念法。是故彼不依四大。问名色者展转不相依。或作是说。增上四大四大增上兴色。问是谓衰耗增上。是谓增上不生犹如一切法展转增上相生。是故彼不生。尊僧伽多罗说。四大大事兴因缘生色。问四大各各不相离。亦非大事兴。此义云何。答曰。若得不离。或四大非色。如风种空流离色种无香味。四大非色入色造。尊婆须蜜说。更乐亦是四大所兴色也。如地色地香地味。尊昙摩多罗说。犹如微妙色四大得解。亦及余色。是谓兴色也。以何等故身识入细滑入。或是四大或非四大。或作是说。彼无因缘。如明识色。或青或非青。是谓身识入细滑入或是四大或非四大。或作是说。谓四大相。彼非一切从细滑得。四大相不同。濡坚相亦不同。粗细轻重寒饥渴。于彼细滑粗地所生。轻者火风所造。重者地所生。寒者水所造。饥渴火风所造。问无有出地坚者。细滑粗是地处所。是谓有增。如地平正故曰细滑。如地不平正故曰坚粗也。是故无粗细滑。设粗细滑当成就者。一切常可得。如青色不可得。是故不成就。彼或有轻因。彼复有重。是故轻重不得成就。若成寒者。云何得生青莲华。不于彼四大得。是故寒不成就。若火盛则饥。风为渴本。或作是说。一切身识细滑入。当言四大也。不离四大有身识也。四大转增各各说。云何无明。或作是说。无智是无明也。问云何无智言非智耶。设是非智彼是无明。草木墙壁皆不智。欲使彼是无明耶。答曰。心念法与法相应。问心所念法众名心法相无智。云何弥沙塞作是说。未辩无明修行无明。彼不有明时彼谓无明。如不有盐彼谓之无盐。问若彼无有明时彼便起明则有无明。犹如彼器无盐彼器谓之无盐。若不有明彼无明。空便有无明。若是明物是无明者。云何行有缘。或作是说。五盖是无明。世尊亦说。世间愚人无明所覆。问结无有要处。或作是说。思惟不净是谓无明。世尊亦说。比丘当思惟不净。未生欲漏便生。已生欲漏倍增广。有漏无明漏亦复如是。亦言。无明习即是有漏习。是故思惟不净。是谓无明也。问非思惟不净是无明耶。彼缘思惟不净亦是无明

又世尊言。如是比丘思惟不净。缘是无明无明缘爱。是故无此思惟不净是无明也。问若无明缘无明意有何违。如所说无明缘痴。或作是说。四颠倒是无明。问苦见断颠倒是故无明。见苦断见结无明结亦如是。无有要处。或作是说。一切结是无明。智者是明。一切结不觉知。是故一切结是无明。问使无有要处。答曰。若有十现色入要处。如是有使要处。或作是说。实不生也邪生无明。或作是说。无明名者无智疑顺邪也。或作是说。无明有六相痴顺邪疑悕望欲得无要处。或作是说。无明于圣谛不作无智也。顺邪是谓无智。或作是说。自造有众生。是我所无明。我造非有也。无明相云何。如上所说。复作是说。于此众生愚痴无明相。云何无明有缘。如上所说。复次有我物有无明无。明四颠倒有何差别。或作是说。见是颠倒无常有常苦有乐不净有净无我有我。有彼相应及余结使相应无智是无明。问彼所相应无智无常有常苦有乐乃至无我有我。一处颠倒见此无智是颠倒。此义云何。或作是说。见谛所断颠倒。见谛思惟所断无明。问若无明见所断彼颠倒有何差别。或作是说。无有差别。颠倒者是无明也。问若当尔者。须陀洹亦无有无明也。或作是说。无明无有坏败。坏败者是颠倒也。问相应者。或有坏败或无败坏。此义云何。或作是说。无道者谓无明。邪道者谓之颠倒。或作是说。无要者谓之无明。要者谓之颠倒。或作是说。一切结使是无明也。无明微者谓之颠倒。复次一切结是颠倒。颠倒微者亦是无明。云何内相。云何外相。答曰。诸法自相。坏者外相。内相外相有何差别。或作是说。不普遍是内相。普遍者是外相。问设当普者。虚空亦复普。设内相摄持。非内相还外相。是故有内相有外相。或作是说。不坏外相。坏者内相问普者亦坏。余者无常苦亦无常。答曰。五阴已坏一不坏无常普遍。问如坏自相。不坏普遍相。如是不坏自相。坏者外相。或作是说。其不相类。问青象青。黄者不相象。欲使彼是内相是外相。答曰。青黄不同。欲使青是内相非外相。或作是说。现者是内相。未知智是外相。问彼或有未知智。欲使彼是内相是外相。乃至未知智究竟自相。或作是说。依是自相依者外相。问名色各各相依。亦是内相外相耶。若依外相彼自相外相依外相无无常依无常。或作是说。不共自相。共者外相。问外亦是不共。无常苦别答曰。五阴中云何无常外不共。问如彼无常色无常痛想行识。如实思惟乃至识无常。或作是说。与自然相应是内相。不相应是外相。问若外无实者。今亦无也。若外相有者。彼亦有自相。或作是说。无有外相。一切自相。问若无外相者。诸法亦无外。或作是说。已辩自相不辩外相。或作是说。觉是自相。不觉者外相。遍有不坏象。未知智所依。不共不自有。无有不辩造(偈也)。犹如有此三有为有为相。余者亦有为。摩诃僧耆说。当说此无常的异相异无为相。今亦当有为相。作是说当说无量逮有为法。问一一诸相与三相相应。问有何等异。答曰。展转相生。生者已灭。亦复不住。问我有二起等生展转相生。是故于中不异。或作是说。说已当复说。问有为相无为相当有为耶。或作是说。非此非彼逮有为法。亦当说余此非相视有为法。此生此灭常住不变易。是故不说。彼当说有常当说无常。或作是说。当说有常。问有常相者是为有为。或作是说。当说无常。逮有为法。此亦如上所说。或作是说。当说有常当说无常。起常住及彼当言无常。问有无为相今当有为。或作是说。不得说有常无常。以何等故。诸法行成故彼无常。彼法行成是故非无常数。诸法缚着是故非有常非无常

初偈品竟

    尊婆须蜜菩萨所集偈品首(聚揵度之二)

口口行有何等异。或作是说。无有异。口者即口行也。问设口是口行者。身非身行耶。问若口与口行无异者。身与身行亦无有异。此义云何。少不属身或是身行。或作是说。文字说文字所载是口行。问若一一字非口行者。非与口行相应耶。答曰。一一诸字非口行非相应。如一一字有诸义音响相应。或作是说。有所言是口所作。如口行中从口行者。是口语言。他有喜有乐有愁忧。当言是口行耶。答曰。非口语使彼有喜有乐。复次但作余义。义有所思惟。则生喜相。或作是说。口有所说。口思惟行。出口者皆是口行。问若思惟是身行者。思惟是口行。思惟是意行。是故三行无有定处。答曰。我身行异。心行异。口行异。意行异。问所作行不定处者。复次声是口行。字数亦是口行也。口字数有何等异。或作是说。口是善不善无记。字数者无记。问若口无记语者。彼字数有何等异。或作是说。字数断是口非是字数。问云何喑哑人与畜生有何等异。欲使彼无口行耶。或作是说。言是口义非字数。问如彼字数亦是义。犹如自然物。如风吹铃鸣。非口行耶。本入三昧。或作是说。口造众行非字数亦造行。尊作是说。二声无有差别。二事相行别念知善字数断是口。敷演深义亦是口亦是口行。二声俱不异(尊昙摩多罗入三昧乃知)。以何等故。口善不善无记。字数者唯无记。或作是说。口发由心。然非字数也。问字数发亦由心非不用。心或作是说。妙无妙口所造。然非字数。问字数妙非妙所造。犹如梦中觉及从三昧起。或作是说。口指授教戒。然非字数也。问如无记口言非指授教戒。我为所造。是故彼善不善无记。然非字数也。或作是说。口身行集然非字数。问字数者亦集身行。尊作是说。当量此二事。不见彼不自相。亦不见其功口意等起。生妙无指授。受报两相须(偈也)。想与识有何差别。或作是说。无有差别。此二俱发出由心。问设发出由心者。必有定处。若无差别者。阴亦定处。答曰。若如汝有三心意时则有阴处。或作是说。此是差别是谓想是识。问名有定处当说自相。或作是说。想为想识为识知。问此何义为所作。或作是说。想为想识为识。问此亦是我疑想自知想识自知识有何等异。或作是说。心即是想心亦是识。问设心当尔者。则无有异想痛心有何差别。或作是说。想忆所作识能自识问彼想为忆何等。若忆何者是故想自忆想。若忆余者。彼则有一缘。或作是说。名忆是想自相是识。问一法俱有二名字及自相。问设一法俱有二名字者。彼名亦异自想亦异。设名不与相同者。是故想亦自亦有相。识者忆名。或作是说。外忆为想自相是识。如此本已说。尊作是说。分别名自想。自想忆识不惟此所作意名是外。乃至眼更痛及想及心及识。有何等差别。当以此七方便说之。尊作是说。眼缘色生眼识自相受识。识流驰此诸法。还更以此差降。意有三法。识别与识共。俱彼所得苦乐。造诸想追本所作。亦是想心所行法。是心此法当言一相。当言若干想。或作是说。当言一相若识缘青意亦当尔。若不尔者。正有一缘一缘相应法。答曰。一相无有自相。问忍痛识想分别心能思惟想亦相知。问一切别。青实其青。想亦相知。心亦心知。识亦识知。此义云何。或作是说。此无量相。妙非妙痛。名为想所作自识所作自识自相。问无有一缘。尊作是说。当言无量相。设一相者。法则有坏。法则有乱。此无有定处。如此诸法而有自相。犹如此有为法不可得作无为法。无为法亦不可得作有为法。若尔者。世尊出世为何所为。答曰。不以此义佛世尊出。言或使有为作无为。无为作有为。譬如珍宝不可言非珍宝非珍宝不可言是珍宝。但分别者知。譬如导方师。非道不可言道。道不可言非道。但导者能知。譬如然灯。下不可言高。高不可言下。但照明其高下。譬如医师。药不可言苦。苦不可言药。苦药各异。上亦复如是。复次世尊为众生故说此法义。犹如此有为法于三世各有自相得知外相。以何等故。或起或不起。此之谓也。或作是说。相有若干。问彼相本无住。是故彼有相生。答曰。本有此相未生。问设本有相相无若干。答曰。如彼不种自生相者。则秽相各各异生。不与同相各未生。是谓相若干。问设彼相已生。若未生者。是故彼各有增减。是故彼本无有而有生。答曰。如如来言相无若干。彼则秽相生有异。或不生以此生有异。譬如青异无常苦异各无胜如此亦如是。或作是说。事有若干。此亦如本所说。或作是说。因缘或生或不生也。问或无有缘。答曰。别无有缘。此二不等等生。问初无等语耶。答曰。非不有语。或作是说。三世处或生或不生。此之谓也。未来处是谓未来。过去世是谓过去。现在世是谓现在。问世与行有异耶。设当世别行别者世常住。若世即是行者。是故彼行或聚或移。或作是说。一一事不同。或生或不生。过去行者知过去行。未来行知未来行。是谓未来。现在行知现在行。是谓现在。问如彼未来非现在。设非现在常住也。若现在是故彼未来知有现在则有现在。若彼未来知现在者则无现在。现在者便知现在知有现在。如彼现在移者则有过去。设无过去者则有常有过去。是故汝现在知过去则有过去。设当如现在知过去无有过去也。汝过去知有过去则无则无过去。或作是说。此为何作是说。此为何作自相相应。答曰。是谓住常已作自相。若常不与自相相应者。则无有世自相生世。问若自相生世者。即彼相生过去。是故世无有常处。答曰。我相未生。未来世未生。不坏现在世。不以生无生为异。是故世有常处也。问若彼相不生亦生非今有。答曰。若今不生亦不生无为。复次常自相相应此亦当无。或生或不生。是谓若无常者彼亦不生今亦无相应

  相作若干种　　因缘世如是
  一一共相生　　本相为所作

犹如此有为法非不无非为不有。无为法非不无非为不有。以何等故。有为法谓之无常。无为谓之有常。或作是说。有为法相有若干。不有无为法。或作是说。有为法作若干种。不有无为法。或作是说。有为法有因缘。不有无为法。或作是说。有为法有世处所。不有无为法。或作是说。有为法种种别异。不有无为法。尊作是说。有为法所作相因缘。则因缘相生。因与缘有何差别。或作是说。无有差别。合会所有无。合会则无。即是因与缘。如所说因即是缘者。是谓生老病死。问设合会有者。彼即是缘。因眼有眼识。欲使彼是因非缘耶。答曰。非眼合会生眼识。有对则有眼识。是故合会亦是因亦是缘。或作是说。合会是因。所作是缘。问若合会作合会者。因非缘乎。答曰。一一所作缘。合会有因。问若一一所作非因者。合会亦非因耶。答曰。一一所作非因合会有。如一一所作非合会。合会有合会亦复如是。或作是说。自然是因。非自然是缘。问麦所生牙。牙与麦相类耶。设与麦相类者。欲使四大同因业耶。或作是说。次第是因。在远者是缘。问因缘及次第缘。因缘及次第缘无有差别。若善次第起不善心是因非缘耶。或作是说。不共是因共是缘。问眼不共生眼识。欲使此是因非缘。麦与根牙共生茎。此是缘非因。或作是说。生者是因。更生是缘。问今生无缘。麦更生无因。或作是说。自长养是因。养他是缘。问若自心生善即为自养。欲使此是因非缘耶。尊作是说。回转是说回转是因。不回转是缘

  无有合会　　自然次第　　诸共所生
  自身回转

云何次第缘耶。或作是说。过去心所念法次第缘也。问未来心心法中间生次第缘。或作是说。过去现在心心法次第缘。问未来心心法若久生中间彼次第缘生。或作是说。一切心心法。谓之次第缘。问如今阿罗汉后心次第更生余心。或作是说。除阿罗汉后心。余心心法谓之次第缘。问灭尽三昧后心复生余心。答曰。起心中间次第缘也。尊作是说。若心次第生心者。即次第缘也。何以故。非色心心法有次第缘也。从何法出。何以故。次第少者生多。多者生少。次第缘相云何。或作是说。行施所避是次第缘相。或作是说。照其心是次第缘相。或作是说。次第心性回转是次第缘相。或作是说。次第心性益次第缘相。次第缘当言定当言非定。当言常定。或作是说。当言常定。问如阿罗汉于今后心次第更生余心。答曰。阿罗汉非有后心次第缘。或作是说。当言非常定。问则无次第缘。答曰。犹如因缘无有常定必有因缘亦复如是。尊作是说。以观现在次第缘。彼当言常定。观现在相次第缘自有常。当言已果。云何得知有无教。或作是说。从所生知。亦作是说。有色不可见无对。问云何审从所生知此非现在。若色不可见无对。无色亦不可见无对。是故汝色无色无有差别。或作是说。常住余得知见有无教戒。成就彼所作供养。我观有无教戒。观彼所作相。问彼非观所作无教。彼观所作智教。若作有无教者。诸所有无教。彼一切当观所作。彼所有教最是妙行。或作是说。事事相观照。戒律不戒律灭尽。戒有不见戒律灭。见有戒律不戒律灭尽。问非戒律灭尽道亦非戒律灭尽。或作是说。由堕罪知说禁戒时。知有堕不堕者犯无量罪。观彼有此无教诸犯罪者。问彼非无教忆本所犯。设无教犯相者乃至无教。彼一切犯罪。或作是说。知有胜不胜者。不观教则有无教。如观有为则有无为。虽有此教我观彼无教。问彼不尽有胜无胜。若观一切无胜者。欲使彼有胜耶。设有者则无有胜。若一切妙有胜者彼则无也。或作是说。生天上然后能知习行不犯然后生天上。问云何习行不犯。为数数不犯。能知心不犯。从彼修行心。然后得生天上。或作是说。不知。何以故。彼非智章。彼有教义。住与共相应。况无教者。彼依经生天。如彼智章无教身。身痛有何差别。或作是说。无教身缚身痛心缚。问彼为身根所缚。或作是说。无教戒数色阴所摄。又身痛者是意法。痛阴所摄。或作是说。二俱无对。增减难说。无教心心不相应行有何种别。或作是说。无教是色。心不相应行非色。或作是说。无教者是物。心不相应行非物。或作是说。无教非智观物各各成。心不相应行不自然法所造

第二偈品竟(胡本题在此理应题于偈后也)

  口识有三种　　犹如三有为
  因缘有四种　　无教有三业

    尊婆须蜜菩萨所集偈品首(聚揵度之三)

  苦由因意得　　无智亦有五
  色根悉具足　　各各有七苦

得心心法因缘。不思惟缘。心心法缘自相欲使作缘。或作是说。无也。何以故。因缘心心法之所摄持。不可使青国觉缘也(外国见闻皆曰国)。问设当觉者。青国有缘。如彼觉青国则有觉。若青有国作缘。因缘自相则有二觉。若觉若余觉。缘青国摄余青国。若觉缘青国。彼亦不敢青国摄觉作缘。或作是说。得如所说。如恐怖人。不知为谁所恐心。自相作缘。缘亦不自知。问彼非自相作缘耶。设作缘者自知有缘。自相性自尔。或作是说。得如所说。有是想有是心。答曰。是谁想是谁心。若作是说。彼即是缘。若不作是说。是为想是为心。如是心不合不相应。或作是说。得若未来心心法。作缘缘彼即是缘。当熟思惟。彼心心法自相作缘。彼不知有缘。何以故。不以未来缘造有缘。答曰。彼不自相作缘。若作自相缘者。缘亦有智生自相自识。或作是说。得如头腹胸有痛痛自缘相。而造缘缘不自知。问彼痛自相。而造缘不作缘。痛无处所。痛自相生。现其实头复有痛。或作是说。得设当不得者则有二。知他人心。心心各各作缘已。心自作缘。是故自然不知此非是妙。是故已得。或作是说。得设当不得者。心缘心无有究竟。则有因缘。此非是妙。是故已得。尊作是说。得痛相心有何差别。此意识境界不从中得得识。若不得识受自相。此谓究竟。于中有余意识入。则有坏败

  不还心恐怖　　未来想亦尔
  痛及他人心　　心缘痛此彼

还心心法。设心心缘。此二俱前后而自作相。或作是说。得如觉青国一时作缘。问此非譬喻。设当作缘者。则有二自觉。或作是说。不可得也。设作缘者。青与觉等无有异也。觉亦复无异。是故是等是耶。是故不得此非如。或作是说。不可得。何以故。非以此转而受诸法。非一转非再转故曰为一。是故可得。以何等故眼识不知眼根。或作是说。可见缘眼识。不可见缘眼根。问耳识今知耳根。彼缘不可见。或作是说。摄境界是眼。近者是眼根。是故不知。问鼻识今知鼻根。彼还境界。或作是说。四大是眼。非四大境界。是故不知。问身识今知身根。彼是四大境界。或作是说。依眼根识非心心法自依是故不知。问意识今不知意根。彼即是依。问不可知。无有一切诸法境界。或作是说。若眼坏败是眼识。眼不掩眼。是故彼不知。问此亦是我疑。何故眼不掩眼。答曰。此中无物自然自然所坏。或作是说。不可知。设当知者。诸入则有坏败。六识未坏时。或作是说。彼非此境界。问此亦是我疑。何以故。彼非境界。或作是说。色自相摄受诸眼识。非色自然非眼根。是故彼不知

  可见以近坐　　我依彼四大
  掩眼而有坏　　境界是色相

耳根可见亦复如是。鼻根可见。当言非近坐。舌根身根可见。彼是四大我所造。当作是说。如此五根色。一切四大所造。以何等故若干相有若干貌。或作是说。无有相貌。犹如眼识。诸所有色一切四大之所造。有若干相有若干貌。无所有故。亦复如是。或作是说处有胜故。及余处眼根。乃至身发。是故种种根所。以种种相故。是故种种貌。问余处有一貌。或复有二。欲使彼眼根有若干相有若干貌。一切处尽是身根。欲使身根作若干相若干貌。或作是说。四大所造色欢喜根。及余四大欢喜眼根。余乃至身根。于中种种相。问余四大欢喜一眼。或有余二眼。欲使。眼所视处有种种相耶。或作是说。我作四大眼根及余四大眼。余乃至身根。于中种种相。广说如上。问余四大一眼。或余有二。欲使眼根有种种貌或作是说。行垢所造根。因缘行垢得眼根。余乃至身根。于中种种相种种貌。广说如上答曰。余因行垢而成一眼根。或复成二根。欲使眼根作种种相耶。或作是说。四大之中相应行。所以有种种相者。以其作种种貌。问或一四大。或二或四。答曰。一切少通有四大。少多共合。或作是说。四大境界有增减。是故妙四大所造色亦妙。问颇或时地有坚相无坚相。答曰。一切坚相但坚相。但坚相有增减。譬如铁铅锡下至金首。尊作是说。始生百物有种种相。所以种种相者。以其有种种貌

  色处诸胜者　　欢喜及我造
  速疾行相应　　自兴病生老

眼根相作此等者。有何差别。或作是说。以眼见色见已见当见。是谓眼见。问此亦是我疑。云何以眼见色见已见当见。终不起法眼。不见色不已见不当见。欲使彼是眼耶。答曰。我已说是。设如此像亦是自然。问云何不见是见自然耶。答曰。眼是其貌或作是说。黑瞳子是眼所照者作者

问云何得知黑瞳子是眼。答曰。黑瞳子是本。问黑瞳子非其本。答曰。及余事无所摄。欲使彼是眼。是故此事不然。彼亦当异。是故彼事无所摄。欲使彼非眼耶。或作是说。四大所造色眼根欢喜。因有眼识境界。是谓指授教戒。是谓彼作。问一切五根所造色欢喜。是故彼非眼根自相。或作是说。依眼识。根有眼根依眼识。是谓其事。问诸不起法。是眼识异。不等依彼眼识。欲使彼非眼耶。或作是说。四大是眼根眼识相依。是谓其事。问四大相自坏。是谓四大相自坏。眼根相不坏。一相依眼识造众事。问如四大自相坏一相眼根。如是我相眼根不坏。一相眼识相依而成。或作是说。色香味细滑所缠。眼根眼识增益作众事。问今五识身各知眼根。或作是说。此非境界。问此亦是我疑。何以故。或作是说。彼非境界。眼根无自相无有数。然后成眼根。问若眼根无自相者。眼无有觉。答曰。知眼数之物。是谓觉知。眼如身数之物。谓之厌足。身厌足者。非四大身有一自相。或作是说。所造色自然。眼识增上现有增减。是谓其事。算数彼时渐渐知性自然尔。于中诸入亦复当尔

  观眼黑瞳子　　欢喜各相依
  四大皆集聚　　无造无狐疑

五根亦复如是。意根自相依有何差别。或作是说。意知诸法知已知当知。眼根亦复如是。意识造增上。是谓其事。或作是说。意识相依相意根依意识。是谓其事。或作是说。或出或没。五识身意根依识。是谓其事。问无色界不生意识。于彼无五识身。或作是说。六识身意识身增上。从增上诸所生识。是谓其事。问名色展转不相依。复次彼识自相意根作增上。是谓其事。算数彼时。乃至究竟彼性自然。于中意识则有坏。云何为意云何为意识。前说四事。六识身相应意。增上识所生智。心缘彼是意识也

第三偈品竟

    尊婆须蜜菩萨所集偈品首(聚揵度之四)

如现在痛自身不更。过去未来痛。亦不乐亦不苦。云何得知我苦我乐。尊摩诃僧耆作是说。彼痛自然自身更自然识知。问此非譬喻。不见有物自然所回转。如有断绝之物。能不自相断。戟不自割。指头自不相触。此亦如是。尊昙摩崛作是说。心相应智慧而得知。问设当尔者。自然知自然。一缘相应法。尊弥沙塞作是说。以心不相应智知之。问若当尔者。则有二智。言有人者(一部僧名)作是说。人知问人亦用智知。设不用智知者。初不知尽当有所知。或作是说。第一义无有知。若苦若乐。言知众生者。亦是邪慢。言有苦有乐。问阿罗汉如今不知者。彼有邪慢耶。或作是说。痛为意转中间。中间我自生识。彼境界于中得知。问如意识性。彼非意境界。意识者及意识识境界彼非痛性。云何得知。或作是说。见乐见苦然后得知。问愚人今亦知。复不有是是苦是乐。或作是说。依身苦乐然后得知。问如彼依痛已灭。云何得知。是谓依乐痛。是谓依苦痛。犹如彼痛身不自更。云何摄意。或作是说。心已生时缘现在痛。问心欲生时。未来彼非缘未来。是故彼是境界。或作是说。现在心次第以没缘彼痛。问次第痛没。亦不知苦亦不知乐。云何得知。或作是说。苦乐相凭。无复有余有苦有乐。彼生意中间。境界生意识境界。彼乘识处自性。作识相有苦有乐。况复众生随痛志乱

  自然智慧者　　人最第一义
  志所造痛身　　已生苦乐行

犹如此心心法内依外生诸入。以何等故。依内生不依外。或作是说。依内生。问等无碍中依彼生内。然不依外。此义云何答曰。犹如等无碍。是谓内是谓外。问云何此非颠倒耶。如等无碍是谓内是谓外。如是等无碍已生内非外。或作是说。内有妙事外无也。此亦是我疑。或作是说。内自性成就然非外。问外性亦自成就。如自身色香味。或作是说。内亲近非外也。问无处所则无近远。已还境界二俱相近。二俱相依生。或作是说。内生然非外。问外亦复生。如自身中色香味。或作是说。内造苦乐。问外亦造苦乐。如自身中色香味细滑。或作是说。内有上中下。上中下者。从心心法生。问外亦有上中下。上中下者从心心法生。复有异蝇声兴起耳识。复有异大力鼓声。或作是说。内不牢固。问次第因缘亦不牢固。欲使彼相依生。或作是说。内是增上。问外亦是增上。等无碍中内增上非是外增上。此义云何。一切诸有为法。各各有增上。或作是说。以内故造苦然非外。如画眉点眼而见色。问如所说倍画使大而视之。高声语我当谛听。或作是说。依内诸入。此师意所造与心俱有识依四大。彼各各有胜诸根充足

  自性依微妙　　远近及取舍
  下无牢增上　　师意识在后

犹如此心心法。内依外缘入因缘生。以何等故。内有坏败然非外。或作是说。此现在事犹如观彼日影。眼则有败。然日无咎。问此亦是我疑。以何等故。眼有败坏非日之咎。或作是说。内诸根缚然非外也。问外亦诸根缚。如自身中色香味或作是说。内有吾我想。问外亦有吾我想。阿罗汉无有吾我想。欲使彼不坏败耶。或作是说。依内生诸入。然非外也如上所说。或作是说。内得亲近然非外。问此无人处不有入处。安有近远。已还境界二俱亲近。欲使依二生耶。或作是说。内已生然非外。问外亦复生。如自身中色香味。或作是说。自性住者然非外也。问外亦自性住。如自身中色香味。尊作是说。若自依物转心心法。居彼住者外内诸入。彼诸法展转生诸根坏败也

  现在缚诸根　　依造有吾我
  亲近诸所造　　自性是我有

如尊者舍利弗说。彼诸贤眼内入无有坏败。见其色光不谛思惟。亦无眼识深思惟者何者是。或作是说。次第缘是其思惟。问颇次第缘无耶。答曰。无有不有时。一切识身有现在也。设有现在彼则生。或作是说。自然因彼是思惟。问曰。颇有时无自然因耶。答曰。无不无时不常有等。问曰。颇有不等耶。答曰。非不有等。或作是说。大义思惟。问设无大义者。云何不生识耶。答曰。不生。问若鞭杖捶打彼不起识耶。答曰。以境界力彼识则起。或有不起。如入无想三昧灭尽三昧。及余定心者此亦如上所说。或作是说。发起心者先已说竟。或作是说。心所忆识则其思惟。此亦是我疑。或作是说。语思惟是其相。问志思惟无有差别。或作是说。心心法与心相应。是其思惟。问诸相应法是其思惟。生诸识然识非思惟。此义云何。或作是说。思惟众生缘生。识性起诸缚。此之谓也

  次第有彼缘　　因大义照明
  希望作众生　　相应及诸智

生彼有思惟有何差别。或作是说。次第缘是彼思惟生者为生。问彼不生思惟。设当生者无有差别。若不生者。所说非是思惟。非彼眼识得生。此则相违。五事亦复如是。或作是说。彼思惟心法心相应行生。彼思惟生。非心相应行。尊作是说。彼生心心转法彼思惟。复次生者自然造法。譬如炎光前后相因生。云何得知炎因光。或作是说。有炎便有光。无光则无炎。于中得知炎因有光。问若二俱起者。云何得知炎因有光无光则无炎。答曰。炎所生貌然非光。问云何得知炎生光然非光。答曰。炎所缠缚。问炎所缠缚。或作是语。若有炎时光随时应。此亦如上所说。或作是说。炎坏则光坏。是故得知炎因光。问二俱坏者。云何得知。炎坏则光坏。光坏炎不坏。或作是说。炎炽盛则有光。此亦是我疑。或作是说。合会而有。此亦是我疑。或作是说。炎大光大炎短光短炎。此亦前已说。或作是说。炎不净时光则不净。净则光净。此亦是我疑。或作是说。以见光炎是其本。由是得知炎因光。问是光义故求索油炷。欲使油炷因光耶。答曰。不以光故求索油炷。但以光故求索炎也。以炎故求索油炷。或作是说。非炎故有其光也。相应有光。炎与光最是妙事。问设二俱生。是谓妙是谓非妙。此义云何。或作是说。本兴炎生光。由是知之炎因光也。问此非譬喻。不见炎无光者。答曰。此亦非譬喻。如觉彼炎。更相缘时。时无有光。如其光非其炎回转。希望觉亦不相生。则有慢意

  各各坏败相　　希望相应行
  达清净义者　　合会如前说

犹如六识身。必依过去自然因。志不错异缘亦不误。以何等故。一人非前非后。六识身二俱起。或作是说。一次第缘一识住。问一者识相应一一识相依。或作是说。一者彼思惟一识则相应住。问设一识相应。此是一识。或作是说。一相依一识相应住者。一识相应一一识住

如一切众生。必有所趣受报。自作当受。彼有未来现在所造。以何等故。一人不前不后。五有不转。或作是说。一趣结使炽盛。或作是说。一趣受诸报。尊作是说。识共相应。然后转一一识。诸转所造报行皆应识种。以是知之。如无有众生未曾有而生有。便般泥洹。以何等故。众生无有减。或作是说。汝莫计尔所数耶。有尔所众生不知减。若不能计者。何以故不知减。或作是说。众生无有穷。是故不知减。譬如大海水无限量。千瓶往取亦无减。此亦如是。问大海江河及余泉源皆往趣。欲使众生本无今有耶。答曰。于异方刹土众生来到此间。尊作是说。于彼刹众生无有减。此义云何。有众生游异方界。执贤圣道出界到界。志性云何。有何等希望。当作是观。犹如此三聚众生有损无益。以何等故。三聚众生不知有减。或作是说。汝为计算尔所数耶。尔所众生无有减。若不数者谁知有减。或作是说。无量所造众生。此亦如上所说。尊作是说。在处在处无有灭。此事云何。如阿毗昙说。必有世不疑。有邪聚当言灭尽。设尔者此义不然。如今有此尽

如此三世一世中未来有损无益。一世中过去有增无损。以何等故未来世无减。过去有满。或作是说。汝计尔所数耶。过去未来有尔所数耶。知有减若不算计者。谁知有减。或作是说。过去已坏未来未生。或作是说。过去未来无有处所。或作是说。过去未来无有限量。世尊作是说。若二法照明。何以故。世无处所。事相应缘生。已生当坏。是其事(众生增减。乃是圣人存而不论者也。故曰。谁计豆而不说也。本无今有。若有斯言。则亦有咎。故皆抑之耳。佛止梵志。亦其事也。圣人之教。进觉号也。众生无弃形而上事也)。如入寂静三昧。无量无边福。彼非尽净。彼三昧为缘何等。或作是说。无量边福是其缘。问今不尽净。答曰。彼不自知。问设自知者。彼缘何等。若净无量彼非邪智耶。或作是说。不净谓之净。训心是义。问若净言净者训心不常无常。解说训心是义。或作是说。一切寂静此之谓也。彼亦如是。问如今入第二禅。是时眼尽见黄。是故一时自相坏败。或作是说。净是彼缘。问谁无此三昧。答曰。思惟无空缺处。有是三昧。问一切三昧亦无空缺处处。欲使一切三昧作寂静三昧耶。答曰。非一切自相相受。非一切造无量相。若自相受无量相者。彼是行人三昧。尊作是说。净是其缘。彼以此相应。如缘然薪起烟。及诸因缘各相依而生净。如是起诸相应及诸因缘。当作是观。彼三昧当言不顺当言顺。如上五事无异。尊作是说。当言非不顺渐渐近顺

食谓观人。然食非人。彼愚观者为缘何等。或作是说。食是其缘。问彼非愚观非思惟食。设余思惟食者。复有余缘。欲使寂静无寂静缘耶。或作是说。人是其缘。问食非是人。答曰。如彼不自知。问设自知者吾我是缘耶。复次彼愚观者。食此处所希望求索。彼愚观当言顺当言不顺。如上二事说。尊作是说。当言顺味爱是对。若依骨琐起若干想。自知我身骨琐。亦复如是。彼想为缘何等。或作是说。骨琐即是其缘。问身非骨琐。答曰。此亦骨琐皮肉所缠。或作是说。自身是缘。此骨琐皮肉所缠。问彼想非身。若观骨琐想则缘自身。欲使青缘黄色耶。复次义想缘彼自身。分别希望彼相当言顺当言不顺。如上二事说。尊作是说。当言顺欲使有对

第四偈品竟

  痛及二心　　炎影光减　　未曾有聚
  青食骨琐

尊婆须蜜论卷第一尊婆须蜜菩萨所集论卷第二

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    偈品首(聚揵度之五)

又世尊言。四事摄人。摄人者其义云何。或作是说。众生性坏。如彼洿沙。彼以此四事更相共摄。故曰其义。如彼沙为水所浸。各相粘着。亦复如是。或作是说。众生性自坏。以此四事相摄各成办。是故摄人。犹是作盖升。升摄诸子此亦如是。或作是说。集聚法众生方便故曰摄人。以何等故共义谓之摄人。或作是说。俱有戒行。或作是说。俱同境界。或作是说。俱同所见。复次劝助义谓之摄人。又世尊言。无常是无常法。云何无常云何无常法。或作是说。过去行无常。未来现在行是无常法。亦当求法亦当次住。或作是说。过去未来现在行无常。未来行是无常法。亦当往求彼法。或作是说。过去现在行无常。未来生法不生法是无常法。彼亦与法相应。或作是说。一切诸行亦是无常。亦是无常法。如所说如因是无常。如果是无常法。问因亦缘余果。果亦缘余因。岂彼不是无常无常法耶。答曰。惟因缘余果。果缘余因。如因是无常。如果是无常法。问如今因非无常。如今果非无常法。是故彼即无常即无常法。复次诸行回转彼无常。是法是无常法

又世尊言。诸有尘垢是尘垢法。云何名尘垢。云何名尘垢法。或作是说。尘垢展转相缘。是谓尘垢法。或作是说。彼尘垢相应法。谓之尘垢法也。或作是说。尘垢杂尘垢。彼回转法。是谓尘垢法也。或作是说。尘垢杂尘垢。彼所起身行口行。是谓尘垢法。或作是说。一切有漏行尘垢是尘垢法。如其因是尘垢。如其果是尘垢法。尊作是说。众生不坏造五阴行众恼见逼。是谓尘垢法

又世尊言。汝今比丘生老病死。终更受形。生更受形。逝死有何差别。或作是说。中阴诸形此是生。更转阴往生此是生。中阴坏败谓之逝。初死阴坏败此是死。或作是说。出母胞胎此是生。始入母胎此是更生。形展转增此是逝。初死阴坏败此是死。或作是说。卵[革*莫]合会生。此事云何。此诸根渐渐熟。受生化生合会。彼诸根不渐渐熟(软生赖成)。化生者。若彼命终时。不见其身卵[革*莫]合会。死已见其身。或作是说。无有差别。当说须臾顷。复次趣往生时。最初受阴生造阴住超越。超越造阴受生处所。是谓尔时命终。住超越造阴受生处所。阴更移转。是谓终命断绝。诸阴散落是谓死

又世尊言。诸比丘结常随从。彼时有死。诸有死是故有数。说是语时此义云何。或作是说。爱随从彼命终时习行。彼谓死受诸有。欲爱欲受欲阴。色爱色受。无色爱无色受无色阴。已得彼阴。是谓有数。若欲界色无色界。故曰彼有数。或作是说。使所缠诸使缠。受阴受诸有。已得此有。是谓有数。故曰彼有数。或作是说。一切结所使若力胜者。当命终时便自忆彼谓死。故曰彼有数染怒愚。或作是说。软色因缘起诸垢。垢色所使中色起。缘色所使起增上结。故曰有数。或作是说。色着色所使。色着色死。为色所持因生色。故曰有数。或作是说。诸欲有所须。为彼所使。方便求索已得竟。是故有数。如是诸有所须便求索。已得彼物彼便死。彼便有数。泥黎中若。余恶趣。或作是说。爱所使造有。持往生老病死。彼有数。或作是说。垢所使结起行。持往有悔意恶趣中。彼有数。若死时不悔便生天上。或作是说。敷演四谛世尊说法。若比丘使所使。是谓死为现习谛。彼有数。为现苦谛。于是比丘不使所使。则不死。为现道谛。彼有数。为现尽谛。尊作是说。五盛阴非使。唯无明有爱。彼相应五阴缠裹。已缠裹则有数。泥黎若余恶趣

  一切诸爱使　　软色自缠裹
  若复有余爱　　行谛后有五

又世尊言。于是比丘色无常过去未来。况复现在。以何等故世尊说。况复现在。或作是说。过去色坏败。未来色未生。现在色生不坏。彼名无常。若坏若生及未生。况复生法有坏败。故曰况复现在。或作是说。过去未来色无处所。现在有处所。故曰无常。如其无处所无常。况无处所。故曰况复现在。或作是说。过去未来色不可坏。现在可坏。彼名无常。能使坏者可坏。况复能坏。故曰况复现在。或作是说。未来色未来久远住。过去色过去久远住。现在色现在久远一时住。故曰无常。若久远住者。若当久远住。况复一时住。故曰况复现在。或作是说。寿欲终时。世尊故说。过去久远人寿命长寿八十四千岁。亦有阿僧祇岁者。未来久远人亦当寿极长寿八十四千岁。亦有阿僧祇岁。如今寿者。极寿百岁。出百岁者少少。故曰况复现在。或作是说。此世尊教戒语。况复众生现在色。言是我所意染着。过去未来未必染着。于中淫意偏多。现无常故。曰况复现在。尊作是说。现在暂现。过去未来不常住展转往来。按契经句说。又世尊言。比丘当取冢间五纳衣。少易得人无贪爱。云何冢间衣易得。云何少。云何易得。云何不贪爱。或作是说。人著者少故曰少。处处易得故曰易得。是佛所许。人无贪者。价数甚少故曰少。不从人求亦复无主

又世尊言。比丘行道甚苦。比丘乞求苦。共居苦。彼云何行道。云何乞求。云何共居。或作是说。五盛阴是行道爱身是乞求。结使是共居。尊作是说。如向者语比丘行道苦乞求苦共居苦。众生于彼流转生死苦。于此义故说行道苦。于三苦甚苦。身苦行苦变易苦。希望他乐亦是苦。是苦一切乞求。无方便共居苦

  处无常法界　　生诸着尘垢
  使况复现在　　补纳衣甚苦

第五偈品竟

    尊婆须蜜菩萨所集偈品首(聚揵度之六)

又世尊言。如彼偈所说。不可食彼食。以何等故。佛世尊说偈不可食。或作是说。世尊不以食故往。但欲教化彼婆罗门。是故不受。问不以偈故说不可食。食非其义故曰不可食。或作是说。彼婆罗门(耕田净意)悭贪嫉妒。受彼食时。彼便作是念。沙门瞿昙以食故而说法。如采合诗颂以钱财故叹誉乞者。如彼良医叹誉药草无病不疗。或作是说。欲现神足变化彼婆罗门。佛为现三变化而教戒之。尊作是说以二事故。佛世尊说偈不受取。自现其义。现众生应受化故。使起护心

又世尊言。断栅断堑而住门阃。门阃者义云何。或作是说。于此慢怠依彼门阃。吾我所造。如婆嵯种说。如是瞿昙沙门于法化中无有枝叶茎节皮牙雹净。牢固不可移动。云何于法化中枝叶茎节皮牙雹净。言牢固者。其义云何。或作是说。戒于此法化中枝叶茎。利养是皮。三昧是雹。解脱是牢固。问云何于法化中无有戒。无有业。无有利养。无有三昧。或作是说。戒牢固。是故枝叶茎利养。利养是牢固。皮雹者三昧。现其少相。解脱牢固。或作是说。有诸邪见。于此经中枝叶茎皮雹作是说。如是现其义。此非瞿昙世尊法化见牢固解脱牢固。或作是说。戒成就叶茎现其相类。三昧成就皮雹现其相类。智慧成就现其堑。如是瞿昙世尊非以是故修梵行。余解脱牢固神通之德也

又世尊偈言。本所更历。云何色处不相类失本所更历起慈悲。或作是说。自然。或作是说。威仪自然。或作是说。以二事故。因本所迳历而起慈悲。自识宿命。或有来告语者。或作是说。如彼事说本因缘也

又世尊言。矜(居进反)叔躯树喻。尔时二使者。如其实事往语国主已。复道而还。彼云何如其实事。云何复道而还。或作是说。四贤圣谛如其实事。八贤圣道是复道而还。问设道谛中云何有定处。云有何别名。答曰。无虚伪者出要为道。或作是说。如其章如其实语如其所知。复道而还。或作是说如见谛道。实语亦复如。是如思惟。道复道而还亦复如是。尊作是说。四贤圣谛如其实语。八圣道复道而还。此谛相语劝无相物。契经中清净说是语。案经说

又世尊言。着冢间五纳衣。有五事则不应法。臭色坏脆饶虱婆罗夜叉所居处。云何冢间。云何臭云何色坏。云何饶虱。云何婆罗夜叉。答曰。衣死所缠用裹死人。若卧若被在身故。曰冢间衣。被尘垢污无色阴。虽染不成色。不净臭处热暑暴。如此衣有希望。乃至虮为首置彼已。天神不往诣。恶鬼近故。曰婆罗夜叉

又世尊言爱尽欲尽欲尽爱尽。爱与欲有何差别。或作是说。无有差别。爱即是欲。问今无爱尽欲尽。当作是说。欲尽欲尽故曰爱尽欲尽。或作是说。爱少欲多。问欲有上中下爱有中下。或作是说。念食为欲。于彼遂染着。彼是爱故曰爱。问如所说。如痛贪欲爱彼便灭。如是彼痛当灭彼有违。或作是说。得欲未得爱时得便是欲。问今已得无有染。未得无有欲。或作是说。爱取为欲。不爱取为爱。问爱取无有欲不爱取无有爱。或作是说。意地是爱。六身识是欲。问若意地爱。彼欲有何差别。或作是说。内是欲外是爱。问今内无染外无有欲。或作是说。敬是欲造者是爱。问如所说。痛中欲者。彼所造是爱则有差违。或作是说。未得已得诸生欢喜。是谓欲已得食欲诸贪着。是谓爱也。尊作是说。和颜悦色是欲。娱乐志悦意回转是谓爱

  无有柔软念　　已得而染着
  意及内诸爱　　悦色所娱乐

又世尊言。因是有便有是不。因是有非为不有。说此语时此义云何。或作是说。现在无明生诸行生过去未来。问犹如此现在无有。或作是说。无明依吾我生诸行。不依则无。故因依此吾我无有。或作是说。不尽有余无明生诸行。已尽无余则不生行。故曰此不尽有余无有。或作是说。一切众具。生无明行。无众具则不生。故曰因此具无有。尊作是说。自凭仰依意增益。故依此说。今非有无有苦谛。当言过去耶。当言未来耶。当言现在耶。或作是说。当言现在。不以过去未来觉苦。问过去已缚。未来当缚。现在或有不缚。欲使彼非苦谛耶。复次五盛阴中起苦谛想。无数世时敷演智慧。苦谛习谛亦复如是。或作是说。当言现在。非以过去未来爱而受有。问过去已辩未来当辩。现在爱非一切辩耶。欲使彼非习谛耶。复次有漏行中起习谛想。无数世中敷演习谛。道谛亦复如是。或作是说。当言现在。非以过去未来道断结。问过去已灭。未来当灭。现在或有不灭。欲使彼非道谛耶。复次无漏行中已起道谛想。无数世时敷演道谛

  偈诗颂门阈　　婆嵯喜矜叔
  冢间衣及欲　　因谛各有三

第六偈品竟

    尊婆须蜜菩萨所集(聚揵度偈品之七)

  佛有五眼　　及三种生　　有为相实
  不生有空

又世尊言。比丘我以佛眼观彼众生。利根钝根可化易教。少诸尘垢。不闻退法者。犹如此三眼。云何眼。谓之佛眼肉眼天眼慧眼。或作是说。如来三眼者。当言一切佛眼耶。何以故。一切是如来智慧眼。问如今不观一切众生。诸所观者幽冥处悉遍。尊作是说。如来圣智常住不变移。一切众生蠕动之类。谓之佛眼。佛眼者。当言善耶。当言无记耶。或作是说。当言善亦是无记。何以故。一切三眼是佛眼。尊作是说。当言善无有错乱志。佛眼者。当言有漏。当言无漏耶。或作是说。当言有漏。当言无漏。当言无漏。何以故。三眼是佛眼。尊作是说。当言无漏。何以故。不以有漏中间生有漏。犹如此如来十智。何等智是佛眼。或作是说。诸如来十智。彼一切当言是佛眼也。何以故。一切如来是智慧眼。或作是说。法智未知智是如来常住。不起不移不共。一切众生蠕动之类。当言佛眼也。犹如此十力。何等力是佛眼。或作是说。根智者当言佛眼也。以此知之。或有众生利根钝根中根。或作是说。是一切十力当言佛眼。此非如来智乃至十力。犹如此诸行无数缘生。以何等故。生者言生。或作是说。生者最妙。譬如以众多事染衣裳。染者是人。问等无碍中是妙是非妙。此义云何。有染青衣。是故不定。或作是说。虽有此缘生不缚。是故生者生。问缘有此生缘所缚生。是故不定。或作是说。初无有实不生。问初无有生及彼缘。是故此非缘。或作是说。非生行生今合会行生。是故合会行生。或作是说。若生行生如是。彼缘无有方便。等无碍中生所生非缘生则有差违。如彼缘法生诸法。无缘则不生。如是不异。是故当舍此然生非自然造起诸法。此事不然。犹如此诸行二生等生。何以故言一生。或作是说。一者生行。余生者亦是生。问此亦是我疑。何以故。一者非生余行亦是生。或作是说。彼有一因。余者是果。问虽有各各生此二非二因。彼亦是果。或作是说。行无二生。问此众事不相应行多。云何有一生。或作是说。此二俱不生相应则生行。复次此有欲意生自然生。以何等故。生者言生。彼非有等法。或作是说。生者已生行。或作是说。此非生余者生。乃生若生有生者。则有流转生不绝。若行自生。行已自生此是自生。彼云何无生者生。是故此义不然。犹如此三者有为有为相。起尽住无变易。云何住者有变易。或作是说。起者名生。尽者无常住。老者变易。是谓变易。问设彼老有胜者。胜者变易。若无变易则无有异。或作是说。未来久远住。过去现在则有变易。如是住便有变易。问若起未起变易有胜者。设无有胜则无变易。复次无有一物住有变易。意住有变易。起最初生死者。灭所生处。各各相凭。身住转。转移住则有变易。此事当言等耶。当言渐渐等。或作是说。当言适等一时俱起。问一时老变易则有坏败。或作是说。当言渐渐等起。所作于彼住便有变易。渐至尽俱生渐渐生。复次作众行有为相。更不造行。若得造行者。则有等则俱生。是故一时。生老变易坏败。是故此非义。云何为苦谛相习谛相尽谛相道谛相。或作是说。众恼苦谛相。转移习谛相。休息为尽谛相。出要为道谛相。或作是说。成就为苦谛相。回转为习谛相。转住为尽谛相。能回还为道谛相

复次章义作实谛相。于五阴聚中洋铜铁丸。受如此三苦。染着忧恼如吞热丸。苦苦行苦变易苦。如彼烧铁丸入火与火无异。如是当观苦苦知其恼相。于此苦爱转行变易。恶趣之处奔走驰向。是谓等有。观其习谛相。行垢造行不缚等有是谓非等有。当观尽谛相。修戒休息智慧生相应因灭。如是修行观道谛相。以何等故。过去行不复生。或作是说。谁见更生者。若疑过去行。或作是说已灭不生。问现在复生耶。或作是说。若不相应彼不生也。问如彼过去相应有。复次一相应成一果。非一相应成二果。是故不生。云何得知言有虚空。或作是说。此现事。问谓增上慢空无根本。现在事得知。亦有不可知。或作是说。无著无生。问有著者生。则可知无彼着则无生。或作是说。设无空者物无分齐。虽有分齐。是故有虚空。问梦中所见一切物尽住。若物所容受。容受增容受彼展转。彼展转是故不定。亦不可究竟。是故无虚空。或作是说。以世俗故。故说此耳。如众生号萨唾那罗未[口*柔]阇摩纳婆埵(睹过反)[口*柔](奴流反)。或作是说。不可究知。何以故。此智所知。何以故。色与空不相应。无色不与空相应。于此至彼无所有言空。是世俗言数

  佛有五眼　　及三种生　　二有为谛
  不生有空

世间八法摄几阴几持几入。如章所说。有利无利粟利财利衣裳利摄四持四入。色阴所摄。象利马利男女利摄十七持十一入。五阴已获所得利。摄法持法入。行阴所摄。有名称无名称誉摄声持声入。色阴苦乐摄法持法入。痛阴所摄一切世间八法。摄十八持十二入。五阴五欲若苦若乐。当言成就。当言不成就。或作是说。乐当言成就。因彼缘生欲乐问因缘生苦欲使成就苦耶。或作是说。苦当言成就。世尊亦说。如是摩檀提(婆罗门名)。众生欲未尽。于欲苦中起娱乐。乐相得诸颠倒。乃至契经说。问如今无有生欲乐想。答曰颠倒起乐想。或作是说。无有苦无有成就乐。假号言有苦乐慢生。如种种趣。或有一趣。方俗殊异思惟生苦乐慢。阿毗昙者。其义云何。或作是说。契经偈决生诸法义。理深邃故曰阿毗昙。或作是说。四贤圣谛法能专修行故。曰阿毗昙。或作是说。泥洹是法修行受证故。曰阿毗昙。或作是说。十二因缘十二缘法。能自觉寤故。曰阿毗昙。或作是说。八贤圣道敷演彼义故。曰阿毗昙。复次诸缚着解脱永尽无余。于此义中分别诸法因。有名身句身味身。渐渐着渐渐住渐渐等相应。是谓阿毗昙。诸神形人形而作人声。当言是人。当言非人声或作是说。当言此非人声。昔见揵陀越国鬼。着摩竭国人语。作揵陀越声音。语摩竭国鬼。捉揵陀越国人。作摩竭国音声。或作是说。此是人声非鬼(夜叉罗刹)音响是人音响。遥知声响。此某甲音响。问非人着人形语。是故有音声。复次当言此非人声。见过去人。见未来人。亦见方俗。神着人语实无虚神(阿鞞扇提)。离不忆所说。世尊亦说。此非阿拘婆罗天子。阿拘婆罗天子说此偈言。魔天波旬着阿拘婆罗天子。说此偈言。此魔所说非其天子。以何等故天谓之鬼。或作是说。居住天上故曰天。如生水中谓之水种。生山泽中谓之山泽种。或作是说。生至天上故曰天。如其乘车谓乘车人。或作是说。宿止天上谓之天。如住城墎是城墎人。若比丘着衣食。起欲想嗔恚想。起杀害想。彼檀越主颇有罪无耶。或作是说。彼檀越无有罪。何以故。彼人作罪已不受。问如世尊言。若比丘彼比丘身着衣裳。入无量念三昧专志不移。彼檀越主得无量善业功德。如是契经各相违。答曰彼不作是心我作欲想。问不作是念。彼受我物。入无量念三昧专志不移。问彼不作是心。施此人食。食入无量三昧。着檀越衣。答曰。若着檀越衣食。彼使获福。问不应作是说。自身有患余人受疼痛。不于中间思惟不净。有非罪咎。应惭不惭。应羞不羞。彼惭愧羞。当言善耶。当言不善耶。当言无记耶。或作是说。当言善与法相应。问彼不与法相应。可惭便惭。彼当言法相应。或作是说。当不善有颠倒想为好。复次当言不善。如是彼说增益魔界。如所说命异身异。诸所生是命。作是说。此义云何。问生者即命耶。命非生是故命非命。命非命余命余身。此事不然。身亦不得异。或作是说。若生是命者。又身非命。是故身非生。身不生时命异身异身与命各各异。或作是说。生者是命。身者即生。是故身是命。身与命异。对异无有此。若诸法因对生者。此法当言。与法相应生。或作是说。当言生。曾一时见炎光同出。问此非譬喻。如意炎者非光。如光非炎。若俱取者则有二情。或作是说。当言俱相应生。若只生者无初火自然。犹如彼有薪然无火。设复有火然复无薪。是故当言相应生。问如彼初火自然。火当生时谓之然。如生无薪。或作是说。此当言生。设彼只生者。十二因缘则不顺。如彼有无明无有行。如无明灭时彼便有行。问彼十二因缘则不有顺。如有无明彼行不生。行生无有无明。或作是说。此等俱相应生。设只生者。相应无有果。果无有因。如俱生无有果。如有果无有俱相应生。问彼俱相应生。彼俱无有果。果无有因。如俱相应生果不生。若果不生。无有俱相应生。或作是说。当言俱相应生。若只者本亦当只生。是故当言。本生若不只生。亦复不俱相应生。亦当只生。是故当言本生若不只生。亦复不俱相应生。永不复生。问非境界因有果。彼相应生只生。先亦当只生。是故本当坏。若本不坏俱相应生。亦复不坏是故永不坏。问已生我有坏。是故本不坏。问若只不生。相应亦不生是故永不生相应俱生。或作是说。当言相应生。先有谷种后有萌牙。问中间谷子尽。若种子时时则有生。答曰。此非譬喻。谷子腐则无。或作是说。当言相应生。若俱起相应与果二俱起。此非方便言果证。犹如牛角。问俱有炎光炎因有光。此亦当尔。问此非譬喻。二炎光二俱不可得。或作是说。当言俱相应生。设俱生者。因与果则齐等。问此义云何。答曰。若心因心彼则有齐等。问我心已尽。俱相应在内。或作是说。若一时俱相应果心。彼亦展转相因。不一时俱生。是故一时尽相应。问或以我过去俱相应在内。或时现在。是故非我过去。或作是说。当言相应生。设有相应生者。如俱相应在内彼无也。俱相应生是果。果亦俱相应在内。彼无相应俱有果。是故俱应生

又世尊言。如是相像邪命咒术畜生虫螺。畜生咒者。此义云何。或作是说。蛇虺厉毒唐畜生。是故畜生咒。或作是说。诸畜生趣相应咒。亦是咒如鹿乌鹫咒降象出蟠龙。或作是说。一切邪命是畜咒。复次畜生之趣常有余希望。是畜生咒。解脱名者是义云何。或作是说。解脱缚着净无染污解脱。或作是说。心得解脱故曰解脱。复次增上离三界有。故曰解脱

  法欲阿毗昙　　二鬼及衣裳
  惭愧命相应　　邪命诸解脱

又世尊言。痛缘有爱。云何痛缘有爱。或作是说。乐痛起爱。如是痛缘有爱。问云何非求起爱。答曰。彼亦求乐痛有乐痛求是谓乐痛求。问今云何苦痛求起爱着。答曰。彼亦名起。苦缘起乐痛求爱

又世尊言。彼为苦痛所逼娱乐欲想。问云何今不苦不乐痛是爱因缘。答曰。不苦不乐痛息想不复兴盛。自知息想不复更求。或作是说。五爱。独处爱。不独处爱复求他爱。不求他爱。愚爱。于彼乐痛现在起不独处爱。未起求他爱。苦痛起不求他爱。已起独处爱。不苦不乐痛便休息想。未起求他爱。已起不独处爱。复起愚爱。或作是说。苦痛起三恶道上。彼众生有爱自患。是故身自有爱。以是爱身缘乐痛人所造。是故苦痛爱是缘乐痛。从人乃至遍净天。生彼众生于彼已趣我想。是故乐痛是爱缘。不苦不乐痛至果实天。乃至摄有想无想天。生彼众生于己自起爱。是故不苦不乐痛是爱缘。或作是说。爱乐报处当知痛。如是爱缘此法当言相应起。当言一一起。或作是说。当说相应起。如缘细滑起爱。与细滑相应。如痛缘爱与爱相应。问欲使六入缘细滑耶。与六入相应。或作是说。当言相应起。何以故。亦作是言说。眼更痛眼更爱。问眼更苦痛。眼更乐痛。欲使苦痛乐痛与共相应。或作是说。当言一一生。以何故痛缘爱生。非相应法各各相缘。或作是说。当言一一生。世尊亦说。眼更痛缘起眼更爱。然不眼更爱缘眼更生痛。或作是说。当言相应生。有伴侣一一生爱乐报

又世尊言。如婆阇(清明)国人。如彼男女强相劫夺。云何他男他女。答曰。妻人自守。若为人所守下至淫。女华饰香丸。此当言他女。或女未出门嫁。或复出门嫁。有曰期数。当出门嫁当言他女。成就者其义云何。或作是说。一切法空则不成就。问如所说人成就善法。此契经有违。或作是说。诸有所生是成就义。问学法无学法。欲使彼成就耶。或作是说。不灭尽者是成就义。问凡夫人一切法在未尽欲。使彼成就耶。或作是说。形有所得是成就义。问无垢人已得学法。欲使彼得阿罗汉成就耶。或作是说。无弃舍法是成就义。问学人不弃舍无学法。欲使成就耶。答曰。彼已不得。问汝所说无弃舍法是成就义。是义不然。或作是说。设俱得者彼则成就。是谓成就。复次不相应众生法。渐渐有碍缚彼成就。犹如此人能有所忍。寒热地狱众生复有冬夏不。或作是说。受地狱苦。彼亦受寒热自然所逼。如苦酒中虫在蜜则死。问如是行成此事不虚。答曰。何以故彼行受此罪苦。问彼身无有苦。何以故。所作因缘不堪忍展转生苦。以此因缘亦生乐亦生微苦。或作是说。彼不俱有身体疮痍。有千苦生懊恼啼哭苦。问彼不命过耶。答曰。行报未尽是故不死。如众生处胎。以何等故。泥黎畜生饿鬼及天自识宿命然非人。或作是说。彼道自尔。以是自识宿命受阴入。是故彼自识问若彼已得生。余者何以不自识。或作是说。诸化生者自识。人处胎是故不识。问设化生自识者。余者一切不自识耶。答曰。一切生时皆自识。诸天染着亦不自识。三恶趣中苦痛切身。意忘自识。问此不相类。何以故。亦说化生天子展转告化生天子所从来生。复次一切无边亦无定处。或有众生自识不自识者。或以三昧力自识宿命。或以智现在前彼当言自识宿命

又世尊言。若有作是想思惟不净。未生欲漏便生。已生欲漏便增。设尔思惟者。欲漏为增耶。或作是说。若未生便生。已生不复生。于中便增多。问前生不住。或作是说。彼不为多。复次如未生前境界彼最初生。如是未生便生。如奔走境界。如是增多。或作是说。彼不为多。但依少有中便增是增多。复次得一物修行。断诸着人。不相应缚。选择结使

  爱着相应行　　希望取他妻
  二俱忆宿命　　无漏有四种

云何种种论。云何畜生论。或作是说。种种论者。复种种论。是故种种论。如王论。下至贼论畜生论造畜生论。如所说如论如象广说或作是说。无因缘论种种论。无仪论畜生论。复次诸论者。无端绪无因缘无所应无有处。是谓种种论诸所论者。趣畜生及依余。是谓畜生论。种种论者谓畜生论者有何差别。如前所说。复次诸种种论者。及畜生论。非种种论诸所论。昔所更历生死。亦是畜生论诸所论。是谓畜生论。以何等故。等越次取证。先从法得喜。然后佛僧。或作是说。先修行法。修行法已。是微妙法得法喜。叹一切智。乃说此微妙法。然后得佛喜。彼善住。住此法者。彼更得僧喜。复次等生法智忍。当言法喜不可坏。如彼法喜。彼得佛喜。如所说于苦无恨。于佛法僧是等得喜

又世尊言。若比丘观十二缘起彼则观法。云何观十二缘起彼则观法耶。或作是说。观十二缘起。亦观法时不观人。或作是说。观十二缘起。如实观之。如人见谛此谓之法。复次观十二缘起等越次取证。彼已越次取证。则见贤圣法。证见十二缘起。彼一切观法耶。设观法。彼一切观十二缘起耶。或作是说。诸观十二缘起。彼一切观法也。设观诸法。彼一切观十二缘起。观十二缘起时。彼亦观法。观法时彼亦观十二缘起。或作是说。颇观十二缘起。不观法耶。以世间智观。不等越次取证。颇观法不观十二缘起耶。空解脱门等越次取证。颇观法及十二缘起。以是缘观。无愿解脱门等越次取证。颇不观法不观十二缘。除上尔取事则其义也。复次诸观十二缘起。彼一切观诸法也。颇观法非十二缘起耶。及诸方便行

又世尊言。诸比丘我不与世俗诤。世与我诤。云何世俗与世尊诤。或作是说。世尊愍俗。是故世尊不与世俗诤。俗无此心我护世尊。或作是说。以二事故有诤讼。起贪欲受。意不肯离。邪见取缠甚着爱欲。如此法世尊以尽。是故世尊不与世俗诤。世俗未尽。是故世俗诤。或作是说。犹如恶马不随正路行。如是世俗与世尊诤

又世尊现其义渐渐教化。是故世尊不与世俗诤。以何等故名阿掘摩。是贼尽其力后逐世尊。然不能还。或作是说。世尊前地卷后舒。或作是说。世尊威神使彼身重。或作是说。诸天使彼身重。或作是说。神足境界不可思议。复次世尊于地上化使无色。肉眼所不见。是故世尊行疾自在解脱。如是行时非人能测。如尊者罗吒婆罗。说彼微法言非法。云何为微法。或作是说。如王法输财。或作是说。如诸长者升斛称宝。复次如法难违甚微。如贪利强言。作想希望利。不亲强亲。托病求物。比丘佐助众事。诈病所须取服胡麻子。或诈言狂痴。求索无厌足。及诸非法现在前者。诸病皆求利。是谓微法

又世尊言。诸比丘此八部众。刹利众婆罗门众长者众沙门众四大天众三十三天众魔众梵众。以何等故。余诸天不言是众。或作是说。一切是众。世尊但说此世间不可思议。或作是说。是世尊劝化语。然此诸众数数来会尽流。诸天至世尊所。或作是说。此众则尽说八。复次方便集会皆成众事。于彼众皆有数。皆成众事故曰八部众。以何等故。物近眼不见远则见。然耳则闻声。或作是说。此非方喻境界法尔。或作是说。无所到是眼境界。是故不与耳同。复次明是眼伴晓了诸色。近眼失明。境界不复得明

  种种论欢喜　　观彼彼观我
  无诤世自诤　　八部众观色

得等谛第一义谛。定无有疑不可沮坏。或作是说。得是世俗义。故曰等谛。不晓了世俗。是谓第一义谛。或作是说。名等谛说义。名第一义谛。复次晓了众生心意故是等谛。有此因缘晓了心意。是谓第一义谛。得名苦谛习谛。定无有疑不可破坏。或作是说。得五盛阴是苦谛。爱习谛。问爱亦是阴中。或作是说。五盛阴是苦谛。行垢是习谛。问行垢亦在阴中。或作是说。果是苦谛。因缘是习谛。问果缘他果。缘他果此非是苦是习耶。答曰。苦即是习习即是苦。如果是苦如缘是习。问如果非习如缘非苦。是故苦即是习。习即是苦。复次得五阴有漏苦习。问修行苦时。亦有修行习耶。答曰。修习时不修行苦。唯修行习得智通达。定无有疑不可破坏。或作是说。得诸智耶。知彼是智一一分别是通达相。问智由他知智。彼即是智耶。通达亦复如是。或作是说。智即是通达耶。或有通达非智知解脱物。复次若智耶。知及余自然。即是其事。此无定义。得味。定无有疑不可破坏。或作是说。得味即是义味。诸法是谓味。问味味非其义。云何义非其味。或作是说。一义之中有若干味。是故味异义异。问一味之中有若干义。义非味乎。或作是说。味即是义。或义非味味解脱物。复次味即是义。或处处有味。如彼所说。缘无定处自相相应。相如上说。因与缘如前所说。得十二缘起。十二缘起法。定无有疑不可沮坏。或作是说。得如契经所说。此十二缘起。如性法法常住。广说十二缘起法无明行。问十二缘起诸缘起法。或作是说。十二缘起因。十二缘起法是果。问因非果果非因。十二缘起非十二缘起法耶。或作是说。十二缘起十二缘起法起。问起亦是十二缘起。或作是说。若十二缘起。是十二缘起法耶。或十二缘起法。彼非十二缘起诸起空寂法。或作是说。诸法生时。是十二缘起诸法。已生十二缘起法。问如是者义无有定。十二缘起即是十二缘起法。或作是说。与十二缘起相应果。实是十二缘起法。或作是说。已生诸行是十二缘起。彼诸法生由十二缘起。问彼所生不由十二缘起耶。复次诸法自应尔。十二缘起不造自相。味相应法微妙法。成就授决有何差别。或作是说。平等说如实无虚。或作是说。十二缘起是平等法。成就十二缘起相。是授决法。或作是说。说四圣谛是平等法。顺从四谛是授法决。或作是说。最胜功德是平等法。弟子功德成就是授决法。复次语不粗犷是平等法。语无狐疑成就是受决法。慈孝于父慈孝于母有何差别。或作是说。恩慈于母孝养于父。故无差别

  等智苦谛　　智义自相　　缘起十二
  慈孝父母

云何眼识意识分别。或作是说。以是因缘。彼境界如是。眼识意识分别。问不坏意识耶。答曰。如倒彼眼识界有意识界。然界不坏。如是倒彼色入法入不坏。或作是说。有眼识意识分别。彼相类造。是故造境界是意识。问云何造相类。设更眼识忆不忘失。彼即不分别耶。设不忆者。云何不忆造色相类。或作是说。非更眼识意分别。设当分别识入则坏。问境界坏。答曰。亦说境界坏。或作是说。非更眼识意识分别。何以故。世尊亦说。以二缘故。生识意缘生法。设彼更眼识意识分别者。则增诸入。意色意声亦复如是。问多有诸入。或生一或生二识。虽有一物。意识缘相多痛生识。是故彼有多。或作是说。若眼识定青。意识亦定青。相类识是眼识。此意识此是眼识义云何。答曰。若眼增上者彼是眼识。若意识增上者彼是意识。或作是说。设眼增上不相应。缘青起识。意增上彼不相应。缘青起识。是故相应坏果无有坏。问如彼眼增上及相应。或起诸识。或黄相应坏果坏。如是眼增上及相应。意增上定青起识。有相应坏有果坏也。云何世尊知彼众生宿命。或作是说。劫烧流转众多众生。生果实天。于彼各各自相告语本宿命。以是得知。问若众生不生彼。不自识宿命。从此已来经历皆不知。或作是说。众生之类曾止住。自识彼宿命。余不止宿者观察便知。问一切不共行。或作是说。自校计思惟则知。彼意上已说。或作是说。佛境界不可思议。或作是说。十二缘起善分别说。或作是说。自识宿命智知其力势。或作是说。微妙智得其力势。复次各各别异于彼。如来神智便生。得阿惟三佛。故曰常住。如所说难陀摩陀优波夷说。尊者我夫无常。犯戒恶法生饿鬼中。其妇人梦见夫主。云我生饿鬼中。云何饿鬼梦中作是语。或作是说。化作人形不作本象。造如是貌。问如今云何造。或作是说。饿鬼梦中不作本形。昔造因缘有其力势。又尽思想梦转见形。言睹形象。复次睡眠志不如本狂有所见。或闻恶声响诸法定有。彼一切法等定耶定。设诸法等定耶定。彼一切法定有耶。或作是说。诸法等定耶定。彼一切法定有耶。颇彼法定有。彼非等定耶定。自相定有。复次当言非诸法等定耶定。余人当言。等定耶定。达嚫名者何等法。或作是说。报施之法名曰达嚫。导引福地亦是达嚫。问非以所施而生上界。如所说生上界者。善功德报。是达嚫业。或作是说。施法果报是达嚫法。故曰说檀嚫法。问非以施法果处所。复次割意所爱。成彼施处。于今所养义是檀嚫(秦言财施)法。如饿鬼檀嚫。以何等故。佛世尊是大法主。或作是说。如王摄统国界诛断刑罚。如是世尊为诸声闻断疑网结。故曰法主。或作是说。如王典国民无不顺。如是世尊一切善法无不成办。故曰法主。或作是说。如王典国所作自在。刑罚榜笞皆悉自在。如是世尊于声闻中法得自在疗诸恶趣。故曰法主。或作是说。如转轮圣王施贫穷人衣裳宝物。如是世尊无财众生施以七宝。故曰法主。或作是说。正法之主故曰法主。或作是说。如所说梵相应契经。我所觉寤法善讽诵念供养承事依彼住。如所说云何如来至真等正觉王法比丘。世尊告曰。以此契经义故。曰世尊法主十六婆罗门(阿逸弥勒是其二)。云何得知。世尊有方齿四十味味皆别。或作是说。或观一切种好三十二相。尽知一切相。然后得知。复次算数者。如观掌器无不分别。观方颊车师子臆。知方齿四十味味分别。如二因缘摄生死受诸行报。无色界众生。以此因缘与欲界相应。不成就行垢。云何彼没生此间。或作是说。过去行垢来生此间。如彼不成就。云何来生。答曰。若退转时便得成就。如阿罗汉不成就一切结。从阿罗汉退转时。复得成就诸结。问阿罗汉云何成就诸结。或作是说。善根功德空无有不解脱。不善根无所还。问如欲界中余善根灭尽。以何因缘彼善根灭。何等故复还善根。或作是说。欲爱未尽便生彼界。问如所说外神仙异学欲爱尽。说欲爱已尽。问爱未尽苦当言尽。如所说。在尘土戏童女厌之便弃去。后爱未尽便有尽名。如所说。乃至死便尽。如人言有吾我。或作是说。处处有一切结。于彼亦有欲界结。问若处处有一切结者。界有坏败。答曰。犹如此间有无色界结界不有坏。如是彼间有欲界结界不有坏。或作是说。如于此间渐渐增益。彼间渐渐减。如于此间亲近界便与彼合。问设往彼起欲界结不为终耶。答曰。如住此间起无色界结。彼则不终也。如是彼间起欲界结。则不终也。问住此间起无色界结。欲界中色则不灭尽。则于彼间终也。问我喜言无色界有色。是故彼间起欲界结。无色界色不尽。彼便终。如阿罗汉。于色界化形往至色界。欲界形体都在不除。欲使作彼形取阿那含。生有想无想天。入不用定。贤圣道现在前。欲作是言彼终耶。复次彼行阴所缠欲界使炽盛。依彼行阴。于我爱未永尽愚痴不除。是故生此间甚着不离。非过去行而辩众事

  相有二貌行　　四行亦有二
  四无明爱使　　相应及有弟

是谓初偈(第一品始撮以结揵度)

  识是世尊母　　邪聚及檀嚫
  十六婆罗门　　生死是因缘(此举七品终结揵度)

尊婆须蜜菩萨所集揵度初竟

尊婆须蜜论卷第二尊婆须蜜菩萨所集论卷第三

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    心揵度首

又世尊言。彼心意执持不去乎手。非二心齐等。云何心意执持不去乎手。摩诃僧耆作是说。心自然持。问摄不善心非善摄不善。昙摩啒作是说。心相应智慧摄。问不善心善智慧摄。非善智慧摄不善心相应。尊弥沙塞作是说。心不相应智慧而摄。问心不相应智慧非心非意。如所说心意所摄。持跋次子作是说。执持人心。问人无心意。如所说摄心意。或作是说。修不善心时。善心因缘便断。如是彼心乃至不生。如是彼心则有所摄。问不善心修不善心时。善心缘断绝。欲使善心成不善心耶。答曰。非不善心知善心因缘。或作是说。思惟增益心不净。犹如为欲所缚。思惟欲欲不净。彼欲渐少。问欲与不净二事不异。或作是说。思惟校计心有乱。思惟心不有乱。如是彼心则摄。问非思惟不净。及心有乱则等清净。或作是说。心意生时缘现在心。如是当言心有摄持。问心已生未生不缘未生。或作是说。不善心意作大方便。不顺住不善心取其一缘。如是摄持彼心。问如不善心不作方便。如其方便无不善心。是故方便无有定处。或作是说。过去不善心意有处所。秽恶厌不用心常避如是彼心则有摄持。问此义不然。如二人相倚人人执持。复次然二心俱等不有疑错。如灯燃见明。复次当亲近善知识。众生类闻正法思惟校计。善心因缘转增益。缚着展转相依渐渐多。如是等相应力有增益。彼力利不善心不普广修行。修行善心遂有增益。如是彼心则有执持。如所说心广有觉心微有观。云何心广。或作是说。有觉心盛心盛则广。是故心广有觉。或作是说。五识身广。意识身微。或作是说。不善心广善有漏微。或作是说。不修行心广修行心微。或作是说。见谛所断心广思惟所断心微。或作是说。造彼造广便有微。欲界相应心大色界相应心微。色界相应广无色界相应微。或作是说。泥黎心广畜生心微。畜生心广饿鬼心微。如是相像。乃至有想无想天当是说。复次阿毗昙说。选择三界心展转生造广。照明有觉与梵天相应。更不出梵天上。齐是说何。以等故。五识身有欲爱。然非无欲。或作是说。如契经所说。眼见色爱着好色。问眼见色意识地爱着。当如所见。说彼契经。眼见色眼根成就见。不净思惟校计。欲使五识身无有欲耶。或作是说。如所说此六爱身及眼更爱乃至意。问眼更因缘起意地爱。彼有眼更爱。如所见说思惟六识行。欲使五识身有欢喜耶。或作是说。五识身无三昧。心无三昧。心中结则炽盛。三昧心不解脱。是故五识身有欲。非不无故。问不一切等有欲爱。设当一切有者。阿罗汉亦当有爱生。彼阿罗汉于五识身中无有三昧。修行心意便生欲爱。如色爱无色爱。如所喜一切十大地相应。非五识身中有三昧耶。或作是说。不方便求。五识身便有结使。不方便求使欲不生。是故五识身有爱非为无爱。问若我等不勤求者。是故有欲。一切尽相近有方便求。是故一切尽成就欲。或作是说。无有处所便有。五识身生。结使亦生。非不欲有欲便有欲尽。是故五识身有欲非为无欲。此亦如上所说。或作是说。观色欲便缚眼识回转。不于中间广出义。方便修七觉意住求无欲。是故五识身欲非为无欲。或作是说。五识身中不越次。亲近共住中间。中间生意识。彼则有爱。彼一切是五识身全越次。彼五识身休息。五识身观不净欲使无欲。是故五识身有欲。非为无欲或作是说。身亦不有爱。亦不无爱。何以故。世尊亦说

  典六增上王　　于染甚染着
  不染便无染　　染者谓之愚

问我受此语。思惟染便有染。思惟不染便无染。以此契经五识身亦不有欲。亦不无欲。此义云何。答曰。若无护喜五识身。思惟染便有染。思惟无染便无染。是故以此契经五识身亦不有欲亦不无欲。或作是说。五识身不错乱。设不错乱。若有欲若无欲。是故五识身亦不有欲亦不无欲。问彼相应法有错乱。无色界无有错乱。欲使彼亦不有欲亦不无欲耶。答曰。诸相应法或有乱或无乱。此义云何。无色界计有吾我便有爱。复次自相所摄五识身。不言自相欲无欲。是故五识身亦不有欲亦不无欲。犹若此心所念法俱相应生。云何相应义。故作是说乘载义是相应义。问眼识招致意识。欲使眼识与意识相应耶。答曰。此依余不与同。问如所说乘载义是相应义。此事不然。或作是说。不移动义是相应义。问四大不移动。欲使彼各相应耶。答曰。此非因缘。问如所说。不移动义是相应义。此事不然。或作是说。有因缘是相应义。问眼识缘意识有因缘。欲使彼相应耶。答曰。彼依余。问如所说。不移动义是相应义。此事不然。或作是说。有因缘是相应义。问眼识缘意识有因缘。欲使彼相应耶。答曰。彼依余。问如所说。不移动义是相应义。此事不然。或作是说。一因缘义是相应义。问有众多众生。观月初出。欲使同一缘相应耶。答曰。彼依余。问如所说。一因缘义是相应义。此事不然。或作是说。所有希望义是相应义。问寿命暖气生。欲使彼相应耶。答曰。此无因缘。问如所说。寿命暖气是相应义。是事不然。或作是说。俱生义是相应义。问心不相应行等生。欲使彼相应耶。答曰。此非因缘。问如所说。等生义是相应义。是事不然。或作是说。一起一住一尽彼相应。此亦如上所说。或作是说。一希望一因缘一时造。是谓相应。问此义云何。答云。依一缘一时造。或作是说。一事所须义是相应义。问忍智是一。欲使彼相应耶。答曰。彼非一时造。问如所说。一事义者是相应义。是事不然。或作是说。千义是相应义。识所适处各相开避。心所念法则有选数。或作是说。无有相应。何以故。彼非一切不俱生。问如所说心所念法。与心相应。与心缚着。依心回转彼有违。亦说俱生痛想念。彼所说不与相应。亦不俱生。如是彼无惟说无相应。亦说见谛信不坏智相应。问若相相应声。二比丘亦说。小有诤讼与共相应。欲使彼共相应耶。若已念闻声是念者。亦说眼色以二因缘生。念法识更乐痛行及因缘。欲使识是念耶。若与声俱生者。亦说比丘心俱生。毗摩质阿须伦颈有五缚。而自观见。欲使彼心俱生耶。谁依意识。或作是说。五识身已生依尽。问无色界中不生意识。彼无五识身。或作是说。依六识身。问色有增减则不可知。或作是说。心左右四大依意识。问彼视色无有增减。或作是说。一切身四大依意识。问所造色无有增减。答曰。以彼四大便有依名字。尊僧迦蜜作如是说。自根依身意识见一一心一切自根。身心所作处处有胜。复次心俱有四大。当言依识。识与彼四大各各相依。如索绳綖

如菩萨梦见五事。如彼识为依何等。或作是说。见闻念知是其缘。问彼初不作如是大梦。梦见缇丽木在脐中生。问我闻阿须伦作如是大卧具。我亦闻婆修提婆脐中生大莲花。或作是说。曩昔三耶三佛作如是大梦。彼闻某甲授决时。彼是识因缘。或作是说。彼识见闻念知本亦经历。彼非不有缘。昼想夜梦。是故彼梦彼识。当言颠倒当言非颠倒耶。或作是说。当言颠倒。本无今造。复次当言非颠倒等正觉果。如菩萨所说。安详降母胎。安详止住。安详出母胎。云何菩萨降母胎。云何止住。云何出母胎。或作是说。彼降神时便自知我处母胎。止住时便自知我止住母胎。后出胎时便自知我出母胎。次降时亦自知是我最后处。母胎住亦自知最后住更不复处。出母胎亦自知更不复入母胎。彼安详心。当言相应当言不相应。或作是说。当言相应。如所说。我安详降神。问着所生心不着是安详。云何着与不着相应。或作是说。当言不相应。何以故。生心染着不染着心是安详。是故着不与无著相应。问云何今安详降神。答曰。自知身意。如所说。先起安详心。后生染着心。复次本亦有安详。与中阴心相应。观身渐厚

生心。与何等着相应。或作是说与欲相应。问若尔者无入地狱。或作是说。或与欲相应。或与嗔恚相应。或作是说。生恶趣中者。彼与欲嗔恚相应。生善趣中者。彼不与染着垢相应。善心便生天上。复次不与诸垢着相应。生心与本行相应。如瓦陶轮。当作是观。以何等故。身根言是身识缘非因。或作是说。有嗔恚身根。无嗔恚身识。非嗔恚无嗔恚缘。问有嗔恚是四大。无嗔恚无教戒缘俱。或作是说。集聚是身根。不集聚是身识。非集聚无集聚缘。问无集聚甚微。欲使微因心耶。或作是说。色是身根。无色是身识。色非无色缘。问设当有色便有因。善不善心无色。欲使善是不善因耶。或作是说。处所是身根。无处所是身识。非处所无处所缘。或作是说。无境界是身根。有境界是身识。非无境界是境界缘。或作是说。若身根是身识缘者。乃至身根彼便有身识。是故有一根。或作是说。若身根是身识缘者。身根生身识。是故身根有差违。或作是说。若身根是身识缘者。则有因缘处所。不有因缘有增上缘。或作是说。自然因无自然身根身识。复次彼非自性亦非回转。及他众生回转。如一切心四因缘生。有阿罗汉最后缘心。以何等故。阿罗汉最后心不还。或作是说。次第中间希望因缘。彼非后心次第缘。或作是说。有希望。或作是说。所生因希望。复次于彼后心。有四因缘果于彼数。当作是说。不于中间当有无明。有爱当来受此非缘。言阿罗汉有如所见法。心意所回如是身坏。以何等故。阿罗汉善无记心终不还。或作是说。中间缘有希望。或作是说。希望有违。或作是说。因希望。复次以二事故。于现法中心性得还。或以本行。或现在造。当来亦有。以三事故得还。行垢得还。行垢自然。阿罗汉无有行垢。是故阿罗汉不回转

  心定觉观法　　无欲相应意
  睡眠诸义起　　造生四因缘

颇五识身有颠倒行耶。或作是说有。如旋杖轮。眼识谓是轮。问非眼识谓是轮。色自相境界眼识意识谓是轮。或作是说。五识身有欲。颠倒性有欲。是故五识身颠倒。问当言非颠倒。如乐痛言有乐。或作是说。非移动五识身非以移动。当言有颠倒见。问不移动亦是颠倒。如于色生邪见。复次自相摄五识身。不颠倒摄自相。是故颠倒移动

如非一心。选择有胜作是得是。云何不善心心避不亲近者。善威仪一心者(一部僧名)。作是说曰。若心意空转转有实。虚空一心彼便有选择。问一心无有选择。此事不异便有增益。以选择无增益。或作是说。非一心选择有胜意有选择。问如一一心不选择胜意不有选择耶。答曰。如一一心意有多。如是一一心无众多。有选择众多。或作是说。第一义无有心。选择行亦无不善。便生善心于中游。复次善心以生则无有不善心。问作是不得是。复次心有选择。不应作是说。吾我自性自累。教化众生便有和合。以作选择见功德。彼避不善缘妙行。善威仪与仪相应。颇有一心不在。此彼自相不前不后作缘也。或作是说。有譬如五欲发意相缘。欲使一时周遍耶。答曰。无有自然五欲一时周遍。设当缘者便有三痛生。或作是说。譬如青青谓青国。意一时作缘。问此非譬喻。若当作缘。如青则等如觉则有耶。是故彼有等是故彼有耶。复次作识想心当言无也。非以本作。有余识非一回有二转。惟有一我。是故无也

如一切众生。一一心回转一自相境界。过去未来心不忆不知。云何得知种种二自相。或作是说。由义说得知。问设复说义。云何得知。或作是说。余各各心空彼无所有。便得知一心。忆本所更由是得知。问若一心忆彼便忆青非黄一誓愿。或作是说。一一取自相。和合取二相。由是得知。复次我自性意所一一相方便回转。如青发黄色。有种种二相非所。自相方便无。色界没生色界时。云何欲界相应心。所念法得成就。或作是说。希望得不疑希望。是吾我欲界心所念法。问无漏心所念法有希望。欲使无漏心所念法得成就耶。或作是说。得生便有彼生。解脱欲界心所念法。问彼无漏心所念法亦复解脱。欲使得欲界成就无漏耶。或作是说。得生有有是欲界心所念法。亦生欲界。问生欲界中起无漏心所念法。欲使彼得无漏成就耶。复次必化作欲界形。欲界心所念法回转。无色界没生色界时。诸欲界心所念法得成就。当言彼心无威仪耶。当言伎术。答曰。当言彼伎术当言威仪。诸化化形彼是伎术。处化住处心非有移动。当言威仪无色界欲没时。来生色界诸得善根。彼善根与谁相应。云何得彼善根。或作是说。彼善根色界相应。便得希望已得生必得生。不疑定生得。复次当言欲界相应当言色界相应。得色有有本所观观。近生不得过去。当观亦还时。云何得知。一切心与十大地相应。或作是说。若彼无痛者。则无痛界。亦无想者则无心。若无念者便无心。无更乐者则无此三法。无思惟者则不生识。若无欲者一切心所念法不生。若无解脱者则无解脱。若无念者则无境界。若无三昧者心则有乱。若无智慧者境界不可分别。复次阿毗昙必有实相。依因缘等生诸法相应。一一相应不一相应。观心果也。以何等故。生心不得报。或作是说。设生心有报者。便回转非以报有报。余者有还是彼非报。问报有福报如所说不住。乃至智知有福报有所照。或作是说。染着生心。不染着是报。是故非报。问染著有报如所说。修行无明思惟广说等住。如是众生淫意偏多。复次行垢彼心有炽盛。云何彼报行。颇一心乱一定。或作是说。或乱相应心心乱。三昧相应心三昧思惟。一乱相应心。一三昧相应。是故一心乱一心三昧。问若乱相应乱。三昧相应思惟。彼乱相应。彼三昧相应。是故彼有乱彼有三昧。或作是说。不善心乱善心三昧。一善一不善。是故一乱一三昧。问不善不得言三昧。或作是说。一心之中无有乱无有三昧。意有乱有三昧。无所因缘。是心意是谓乱心意。一缘是谓三昧。惟一一心意乱三昧。一切有一一分别。是故一切心无乱无三昧。彼非微妙不可究竟。是故此非缘。问若一心乱一心三昧。彼一切一一分别。是故一切心有乱有三昧。此非微妙。是故不缘

颇彼心乱是三昧耶。或作是说。有乱相应心。乱三昧相应心。及乱相应。彼与三昧相应一切心十大地法。是故彼有乱有三昧。问三昧无乱相应。乱亦与三昧相应。欲使三昧与乱相应乱与三昧相应耶。此非微妙是故非缘。或作是说无也。不善心乱。善心是三昧。善与不善异。是故乱异三昧异。问不善不得言三昧。答曰无有不善三昧。如所说三昧何者是。谓善心独处。复次无有一心有乱有三昧。此亦如上所说

灭尽三昧起心缘何等。或作是说。本末是缘如所说本心成具有所兴起。作如是心者无有兴起。问云何断灭心所念作缘。答曰。如断灭不善意。善意中间复起不善。问彼不断灭心意。便有缚着心意。复次诸有此处不可思义。灭尽三昧若本心本意有断灭缘。彼则有也。心非为无因。是故缘起。复次若心次第起心。于彼次第缘欲起。当言因本缘。以何等故。心所念法不知自然灭。或作是说。若自然灭者。三等相应无有更乐。或作是说。若自知者。无有二。亦说二缘生识。如偈所说。亲近自然断灭邪见。有胜摄他不异于我。如余方便苦则有等。以何等故。心所念法自不知相应法。或作是说不知二俱生。设当知者生缘无生。无生缘生。生缘无作。或作是说。空一聚畜。设当知者则不空。则有无数聚摄一时顷。二分相应法。如有余缘。如有余相应法。复次不知一缘。设当知者亦知自然。设当知者识缘痛痛亦缘自然。如所说智者。彼即是痛也。以何等故。心所念法不知等有法。或作是说。此非等有。或作是说。等有不自知。复次若还迹者。云何有因缘彼有摄持

以何等故。相应法谓之心内入。然不余相应法。或作是说。一切是内心亦是外心。是一切心差降。问无入处所。或作是说。内根及意根。非余相应法。问意念心所念根。如彼乐根乃至慧根。或作是说。由心故念回转。犹如心流驰不住心所念法。问二俱并生。为由何等生。若一一续生者。由痛识念生想亦生智慧。或作是说。心所念法如彼境界。心生彼亦生念。问二俱并生为去何所。若一一续生者。痛识相念亦复生。或作是说。意心所依有识法。问心亦依心。欲使心非内耶。答曰。虽复心依心。依心有识法。念非依心。或作是说。心增益上此心念法。此亦如上所说。或作是说。心意不自灭念便有灭。如灭尽三昧。问想痛于彼尽。然非有心。答曰。心于彼灭。何以故。心行所念彼非有。行已得休息。世尊亦说。谁当有人说有有想。而无此言亦无是念。此事不然。复次想识灭有所选择。当言内入及余相应法。意识入持常住不移。复次识依众生不牢固。牢固与余法相应。于中得知过去识。当言内入不与余法相应

又世尊言。无常是苦。云何苦痛无常苦。或作是说。若有常彼是苦。如无常彼是涅槃。问如自知苦痛。彼自以苦若有常。彼不自知者。非有常苦耶。或作是说。苦痛尽时余苦则避。无常灭尽时。欲使无常是乐耶。或作是说。苦痛生时便有苦。苦痛灭时便是无常生无常。是故无常苦。问乐痛生时便有乐便生无常。欲使无常是乐耶。或作是说。彼非无常苦所摄。彼苦自然彼无常。非自然苦。问如所说若无常是苦者。此事不然。答曰。诸无常者彼一切是苦少有自然。苦少有无常。苦少有种苦。复次彼非无常苦。无常义异苦义异。复次苦痛生时无常所逼。自然苦各各自聚集

又世尊言。受乐痛时彼便自知受乐痛。云何受乐痛时彼便自知受乐痛。如上初揵度说。云何自知有苦。复次乐痛放逸彼境界生意识念。彼识与意共同作吾我想。便自知我受乐痛。况复众生以痛见逼心便愦乱。以何等故。心所念法不自依处所。或作是说。颇有见自依处所耶。如心所念法。问有色之物各自亲近。答曰。有色之物极微亦极微。各各不相触是故此非问。或作是说。无色亦不相触。问色识有教戒不自亲近。或作是说。选择不触。问选择非教戒不自亲近。是故此非义。或作是说。无对不可触。复次设当受触者。则有细滑入。问如触身根此非更乐。如是彼触者非有更入也。颇缘不愁忧生乐痛耶。或作是说。有如人见怨家死便生乐痛。问彼乐痛非缘怨家。怨家缘彼乐痛。是故彼愁忧。或作是说。无也。此事不定。定缘不愁忧不生苦痛。问以彼因缘或生乐痛。或生苦痛。或缘二生。不以因缘俱知二事。复次无有因缘有愁忧无愁忧成就。如彼或有愁忧或无愁忧。或彼亦不有愁忧。亦不无愁忧。彼或有愁忧。或无愁忧。或亦不有愁忧。亦不无愁忧。因缘合会或生乐痛。或生苦痛。或生不乐痛。或生不苦痛

颇缘愁忧生苦痛耶。或作是说。有如见母死便生苦痛。问彼痛不缘母。母缘彼痛。是故彼愁忧。或作是说。无也。定缘不愁忧生乐痛。闻以彼因缘或生乐痛或生苦痛。复次无有因缘。成就有愁忧无愁忧。或有愁忧或无愁忧。或亦不有愁忧亦不无愁忧。彼因缘合会或生乐痛。或生苦痛。或生不苦不乐痛。二牢固及一灭尽。自然增上慢苦痛意不相触。无愁忧有愁忧。以他人为父起乐痛。彼痛缘何等。或作是说。父是其缘。问彼非亲父。答曰。起如是思想。问如有言是我痛我是其缘。或作是说。怨家缘。问彼痛非怨。若彼不造诸痛与因缘。欲使造青耶。若痛不缘青。复次痛义父相是其缘。怨是处所也。诸身中痛彼是心痛耶。设是心痛。彼是身痛耶。或作是说。诸身中所有痛。彼一切痛与心相应也。问如所说有此二痛。身痛心痛则有相违。或作是说。一切痛是心痛。乃至五根增上。是谓身也。色增上者乃至意根增上。彼是心痛心增上也。或作是说。诸到境界摄诸根生。是谓身也。无有思想诸不到境界。摄由三根生。彼是心有思想也。或作是说。诸痛依身根摄内更乐缘生。是谓身痛。于中有余痛生者。是谓心痛。复次诸身痛与心相应。颇有心痛非身痛耶。诸所痛外所造痛。若知长短。短亦知长。彼识为缘何等。或作是说。若知长短彼缘短。若短知长彼缘长也。问长非短短非长。答曰。以此得知。问若知有我。我是缘耶。或作是说。若知长短彼则缘长。若知长彼则缘短。问如今不知如所造若知余者识则有余缘。欲使青非缘青色耶。或作是说。无有不知长短短知长。彼识不得言住。不观香味更乐造长短也。颇有盲人不得天眼以眼识见诸色耶。或作是说。有若曾与相应后获果。彼生眼识眼便坏败。是故盲人生眼识眼腐败。是故盲人眼识知色。问彼眼有余生。是故不得言盲。答曰。非以彼眼观。若观眼者眼则不盲。从生盲者。是故不盲。问非以从生盲此眼识观。若观眼不盲者。觉诸识相相应有诸觉。或作是说。若眼没时生眼识。彼眼识坏败。彼时生眼识。是故盲人摄色问不等有。是故彼生眼识。若尽灭生眼识。若一切灭尽生眼识者。彼生眼不起眼识。欲使盲人生眼识耶。起眼生眼识。复次不断眼有彼回转。亦有开避处。便生眼识。已得因缘迹则有相应。若实相应不得言是眼识

又世尊言。六尘界比丘。以何等故意识言有漏耶。或作是说。彼界有漏所生。是故言有漏也。或作是说。有漏生彼界故曰有漏也。或作是说。彼界行报故曰有漏。或作是说。彼界是人算数。然人非无漏。故曰有漏。或作是说。流转生死无有穷极。故曰有漏。或作是说。缘彼界降母胎中。不缘无漏法降母胎中。是故彼界言有漏也。复次彼界言有吾我。此非无漏实生有漏。是故彼界曰有漏也

又世尊言。摄诸相比丘识所摄。尔时命过处所趣三恶趣。展转不止。泥犁饿鬼畜生生不染污心。云何生天上。或作是说。由诸结使生天上。亦由结使或入地狱。问云何造不善行耶。或作是说。由结使故便生天上。以嗔恚故入地狱。嗔恚之相当尔时。或作是说。以小染着亦得生天。增上结使生三恶趣。增上嗔恚尔时命过。或作是说。行相重累生诸结使。如行造不善便生恶趣。如结使所缠作诸善行便生天上。起不善行有诸衰耗尔时命过也。或作是说。一切结使拔诸善根。随行善恶各趣其道。复次从上来生。契经句则有违。今当说要。如船度彼此。报行生行则受其果。当于尔时。无力之人。不造善本。是故有处所。不得言最是后识合会有是死。复次识与本行相应

又世尊言。长夜依心思惟修行善讽诵读。云何心长夜修行。一心者一部僧名作是说。一心长夜修行。不得众多心修行。修行得生。问一心如是长夜修行。则不有生亦无差降。思惟差降无有异。展转生思惟则有思惟。展转心意则有长益。是故生意长夜思惟。复次心有三行不有时乃至命终。从此发意菩萨求道。从是思惟乃至得无学术得利。展转心取相彼有思惟。一时惟心所念善法当观意思惟。以何等故。诸相应法想及识不谓是食。或作是说。彼一切是食。世尊教语说一切则说一切。问非以说识则说一切。或作是说。彼一切是食。是世尊劝教语。问诸相应法等有生。或作是说二于中还食识意心。有二方便揣食乐食。问诸相应法或受有或不受。此义云何。复次相应法或有食相或无食相。如色香味声更乐。欲使二生色是眼识境界耶。余者亦尔。但欲自养。是食义揣食差违。诸根四大得长益软美饱。彼以食想则生彼界。思惟相应意所念。如彼有痛。彼生无有量如心有痛。若此诸法以乐为食想。彼生受诸身根痛。亦得将行想亦得行。彼则生受诸识将去识。乃至识意相应身根缚着。及心所念法。当言回转而有开避处痛食想。复次合会造相是其相

  供养及身名　　长短盲意界
  取非以相着　　有漏意在后

以何故诸相应法想痛是意行耶。非余相应法法。或作是说。此一切由意行兴。是世尊劝教语。说此为首则说一切意。问说一则说一切。或作是说。此世尊劝教语。问诸相应法等生力势。或作是说。由意而生是故谓意行。问诸相应法法。或随意生或不随意生。此义云何。或作是说。此意所作故曰意行。问诸相应法。或意所作或非意所作。此义云何。复次意所缠。如是诸法不于中间有回转。意识展转回转无有休止

又世尊言。更乐习痛习想习行习名习色习识习。以何等故诸相应法。更乐习痛习想习行习名色习识习。或作是说。一切相应法更乐习名色习。复次更乐胜意中名色识更乐增。乃至痛有增名色增识有增。问等中间此妙此非妙。此义云何。以一更乐非相由心生。是故彼无也。更乐增意便有增。或作是说。眼缘色因缘等中间缘。缘名色生识。此三集聚故。曰更乐缘更乐。更乐便生痛或想或意。问惟由更乐生痛。复由余更乐生想。世尊亦说。有彼痛不言有彼痛。便言有想。此事不然。此契经有违。非以心所念法展转相应。或作是说。眼缘色生眼识。此三集聚有更乐。彼识等有便生痛。由痛便生想。缘想便生意。复次诸相应法方便便胜。如二人共行一道所至必到。色声香味细滑萌牙。欲使二俱生耶。有增减如实

又世尊言。毗罽罗多鲁奚帝婆罗门。如一人色住百岁。及余行痛起便尽不生色展转不相应。说此义云何。或作是说。色色展转。此世尊教戒语。世作是相。彼色是我所。我着色住。或作是说。色亦展转生死。无记意自回转。心所念法亦有善亦有不善。或作是说。色亦展转。复次色以人回转。心所念法有实。复有余趣。复次色亦展转。然色自然乃至住不死。如作智他自作方便。求色亦住百岁

又世尊言。此四颠倒想颠倒心颠倒见颠倒。以何等故。诸相应法不谓痛颠倒。或作是说。此世尊教戒语。说此则尽说痛。问说一则说一切。或作是说。此世尊劝助语。如上所说。结善有定。问诸相应法无有劝助。或作是说。此世尊教戒语。此教戒与世尊教戒语。此教戒与世颠倒想颠倒心颠倒见颠倒。然痛非颠倒。或作是说。此一切颠倒也。复次微想颠倒中。心颠倒增上见颠倒。复次一颠倒心所作无常想见有常想。得诸相应法。或说言不颠倒。或作是说。不可得也。如识境界回转心亦回转。问设一切有常者。我一定自相无境界。答曰。有常是识有常。有常知痛相知想心知心。问若一切常者非一切痛耶。一切智。或作是说。得识自相摄。是故彼非颠倒心。心亦颠倒亦非颠倒问善不颠倒。然善不与不善相应。是故此非义。复次处所相缘无由业相应。是故彼有生。一切颠倒一切不颠倒。一无有胜自造我

又世尊言。三集聚更乐。云何意地有三集聚更乐。意界(一部僧名)作是说。意持意境界等乐。问二心俱等。亦说心意识。一心作是说。若展转心。彼无有三集聚。复次依一心境界等有更乐。问亦说意缘生诸法。意识三集聚更乐。彼不依心意。是故无三集聚。若彼依心则有三心。心性(一部僧名)作是说。心灭尽时生心境界。此三集聚。问心生时未来未生心。是故无三集聚。复次过去有得意根。现在得意识境界。普照意识所更如是。意地三集聚有更乐。问云何过去现在有集聚。答曰。此非等集聚事集聚。如是得彼事亦相应。云何眼识缘善。或作是说。以眼识善心等起缘身教。是谓眼识缘善。问若彼身教自然善。云何彼等起不观身。身有教色。无彼轮无有眼。唯色相现故曰轮转。此谓身教。若身乱是善者。云何读颂不如是耶。此非故当熟观。复次非自相境界眼识。非色自相境界善。是故无有眼识缘善也。云何眼识缘无记耶。或作是说。所可用眼识善不善心起。除其身教及余色处因缘。是谓眼识缘无记。问一一无有处所。住色声香味细滑。观其所生处。复次色自相境界。眼识非色自相善不善也。是故一切眼识缘无记也。善缘眼识。不善缘无记。缘有何差别。此亦如上所说。问若不善无记心起身教相类。是故眼识无有差降。非以所爱造有识自相。缘青心心所念法青为意喜所更。有何差别。或作是说。识青喜识痛青喜痛想知心念。问一二共相应。或作是说。非一识与二相应。复次眼识青自相回转痛痛喜忍。此名数等所作。心亦如是。复次如是所说。一识与二相应。是故如是非识自性。我一性自性非我自性。是故无我。此二有秽。是故一识。青善成就心造意造。是故此事不相应。彼或有喜。或亦不有喜。亦不无喜。是故或有喜或无喜。或亦不有喜亦不无喜。是故此事不相应

颇心三时住耶。答曰。无也。何以故。心无有坏。是故初时不坏永不复坏。是故心空。若心有增住者。因缘有若干相。彼上更三缘。若心第三时住者。青黄赤无有色相。有色相亦无增减亦无希望。是故心虚空。或作是说。若心增上住者。或时欢喜而修行道。此非微妙。是故心虚空。或作是说。若心三时作者。或遭恶时希望境界便生希望境界。过去希望境界。二希望境界不可究竟。是故心虚空。或作是说。若心自然彼三时住。初第二过时则有增减。增减有余。是故心虚空。若无增减中究竟亦虚空。是故永不复坏。若彼不自觉知彼三时坏。何以故。彼自觉知初时则坏是故心虚空。复次若心住三昧中间心。中间心中间相应。心住相应。心住相应。亦虚空。不于中间相应住。中间不为不空。是故心虚空。以何等故言心虚空。然不及色。此亦所说。上偈亦说。声是色因。不有命等有回转。或作是说。若色空者住无住。所生之处即于彼坏败。彼不有妙。是故上色住。或作是说。色亦虚空如心。何以故。若色不虚空者。爱生色住恚生恚生色。是故一时空则不有色。此非微妙。是故色虚空。或作是说。若色增上住者。命过时心生色中阴。心则有回转。此非微妙。是故色虚空。或作是说。若色自然三时。或第二时。时有增上转有增上。若初第二增时转住。若无增空。是故永不有坏。若彼自觉三时坏败。何以故。即彼自觉初时坏败。是故色虚空。复次若色增上住者。中间相应住。若中间相应住者。初时亦当中间相应住。若中间不相应住者。相应则不虚空。不于中间相应住。相应非不虚空。是故色空

  想痛二字在　　梵志秽意行
  眼觉境界青　　慢性亦虚空

如所说所观见彼是眼所知者。是识云何眼所观识所知。或作是说。眼观视色摄境界。或作是说。依眼生识。如眼观色识为因缘。如是所知。或作是说。无有眼观视。设当观视者。乃至有眼则观。如识等有生。如是识知。是故眼不观视。或作是说。眼无所观。设当观者乃至色有二相。眼有所照。一切观视非一切观缘。是故眼不观视。或作是说。眼无所观识无所知。复次眼缘色生眼识。彼作观想观识所知。世尊亦作是说。复次眼无所观。设眼观者。耳所当闻鼻闻香。是故二根义则有所摄。是故眼无所观

观识有何差别。或作是说。眼有所观识有所知。或作是说。所观照是眼摄。境界是识。或作是说无有差别。观识而无有异。此是一义。是世尊教戒语。复次有此处所。观异识异二俱不同。观他识识他。设当如观余识同者。是眼是识无有差别。设眼境界识亦是境界。眼观色识无巧便摄取境界。此事不然也。是故当舍此

如眼缘色生眼识。以彼眼识知有色。然非眼也。以何等故。彼眼谓之识耶。非色识。当方便说。如聚揵度依诸内入。或作是说。眼识知眼谓之眼识。或作是说。彼无有识。复次眼缘色生眼识。于彼作十世俗想。谓眼识也。世尊亦作是说。或作是说。修诸根身识。由根有识也。如种种趣一趣之中。由食思惟随时自性造诸根。当言身识。如无色界相应诸心所念法。色界为妙。高下粗细思惟此已。云何彼作坏败色想。或作是说。彼无有坏败想。然彼色未尽。设色尽者。彼谓坏败想也。或作是说。彼有坏败想。彼不修色想。若以离色想。以离谓之坏败色想。复次彼非坏败色想。彼不入无色界定。若入无色界定成就彼定。彼谓坏败色想。如此五识身不知各自相依。云何意识不自知相依耶。或作是说。知意依意识设意不知意识者。则心心不相观也。或作是说。知自身诸根依彼意识。彼是意识境界。一切诸法境界是意识也。或作是说。知一切身体周遍四大比依意识。彼是意识境界。设不知者。此亦无痛有也。依意识。或作是说。不知若以意识知者。则无三聚此非微妙。是故不知。或作是说。不知。设当知者。则有二世尊。亦说二因缘生诸识。是故不知。复次诸根则依识。设意识自知相依者。如是意识则有坏败。复次心俱生。如是四大当言依识身。彼非意识境界。未坏六识身。入无记心心所念法。根得增益四大增益。当言未得。或作是说。当言未得。不以无记心心所念法生诸希望。问无记心性回转希望则坏败。或作是说。当言得也。观见诸根。欢喜心者。弊恶心者。无记心者。是故当言得也。或作是说。如此处所有隐没无记心。彼则成就。有无记心心所念法。诸根四大增益。欲使我等说隐没无记心耶。复次一切心色增益一切心依色而有展转相生。乃至眼识生诸行。此不微细若超越彼念。识身起眼识。亦无法不转。诸根四大如种子。复次伎术诸艺成就威仪礼节皆以成办。威仪心无记。如是伎术此则得知。无记心所念法。诸根四大得增益。若心卒乱。彼一切心解散耶。设心解散。彼一切心卒乱耶。或作是说。若心卒乱彼一切心解散。设心解散彼一切心卒乱。一切心染着。亦卒乱亦解散。彼与卒乱相应彼是解散。问无有愁心不善无有三昧。或作是说。无有一心若乱若散。意亦无有乱散。颇心卒乱非解散耶。心有一因缘。意有所摄持。颇心解散非乱耶。意识无数因缘亦无所摄。颇心有乱有解散耶。意性无数因缘。亦有所摄持。颇心不卒乱不解散。一缘意识无所摄持。问如一一心不卒乱不解散。彼不一切解散耶。答曰。如一一心不在意有众多意。如是一一心嗔恚无有解散。亦无众多。复次若心解散。彼一切心有乱也。颇心乱非解散一缘回转。譬如士夫从一路走。如缘五识身自相回转。如是想像意识。或作是说。如彼回转彼不想像。或作是说。若眼识青有定意识。意识亦青想像识。是谓眼识。是谓意识者。此事不然。问想像意识。若眼增上彼是眼识。颇意增上彼是意识耶。答曰有。如汝眼增上。诸相应青黄白黑。生识诸着亦有胜。如是我眼增上。诸生相应眼识。如意增上相应生者。彼是意识。或作是说。若眼增上。及相应青黄白黑生识着。是意增上。诸相应青黄白黑生识着。是故相应果坏。问眼增上果。乃至诸生相应意增上果。于中则果坏。若眼青黄白黑果不坏。汝眼增上诸相应青黄白黑生诸识欲。使眼增上相应不耶。相应不增。是故此非义。或作是说。不如彼造彼相像。问为谁造相像。若忆彼境界则彼是缘。若不忆者为谁造想像。若忆彼境界彼即是因缘。若不忆者或作是说。不如彼回转。设如彼回转者。则二众多。世尊亦说。以二因缘生诸识。问众多生二识。或一二生诸识。如汝有众多二也。汝意缘生想痛识。是故汝众多二。或作是说。不如彼回转。设如彼回转者。则不有坏诸入已定。是故不如彼回转。问已逮中间无有色入法入。如还中间眼识持意识。持不坏败。如是有诸入。中阴中初心为依何处色。或中阴或初死。或作是说。初死不生作众事。问非现中阴依心而住耶。答曰。心无有住处。心生便灭。灭无所作。是故彼无所依灭不生。复次中阴依色心耶。念法亦是依色展转相生。如大箂阿罗汉。最后心为缘何等或作是说。自缘意命等命想。空解脱门而现在前取般涅槃。或作是说。一切诸行是其缘。作一切诸行作不净想。无愿解脱门而现在前。取般涅槃。或作是说。涅槃是其缘。涅槃灭想无想。解脱门而现在前取。般涅槃。复次见闻念知是其缘。彼心无记。自无吾我想。取般涅槃。本行已弃永灭不起

  诸根因缘本　　依意增益生
  心广意游行　　中阴罗汉心

尊婆须蜜菩萨所集心揵度第二竟

尊婆须蜜论卷第三尊婆须蜜菩萨所集论卷第四

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    三昧揵度首

又世尊言。诸比丘集聚来会有二因缘。若当论经深义。若当贤圣默然口不出言。云何论经深义。云何贤圣默然口不出言。或作是说。于欲不着。观欲恶露不净是谓论经深义。于第二禅贤圣默然思惟。尊者大目揵连亦作是说。于是比丘思惟第二禅。是谓贤圣默然。或作是说。十二因缘。是谓论经深义思惟十二因缘。是谓贤圣默然。或作是说。契经偈决广布是深经义。心专一不乱而听法。是谓贤圣默然。或作是说。弃一切恶行。是深经义。念弃一切行而思惟之。是谓贤圣默然。或作是说。空无想愿分别广布。是深经义。思惟空无想愿。是谓贤圣默然。或作是说。分别四贤圣谛。是深经义。善思惟四贤圣谛。是贤圣默然。或作是说。法论者。合集人民布现等法。贤圣默然者。思惟不净观。法起则起法灭则灭。或作是说。说法声远闻。是谓法论。思惟内事。是谓贤圣默然。复次集聚来会。亦是其事。当说诸法。已说当善听之。于彼法论亲近贤圣。譬如戒轮定轮智慧轮解脱轮解脱智慧见智慧轮。乃至十二因缘轮。闻此轮已持讽诵读。意不染着不厌。心不乱善思惟。是谓贤圣默然。如所说尊大目揵连贤圣默然。此是其义。昙摩提那比丘尼作是说。彼比丘从灭尽三昧起。近三更乐寂更乐不用定更乐。无想更乐。云何寂更乐。云何不用定更乐。云何无想更乐。或作是说。空解脱门是寂更乐。无愿解脱门不用定更乐。无想解脱门是无想更乐。或作是说。彼从灭尽三昧起缘涅槃无漏故。不用定现在前。即当言不用定。彼不用定彼无想定。无漏不用定。不用定缘涅槃无想也。复次彼从灭尽三昧起。住有想无想。起若干心。当言近无想更乐。彼住时入不用定起若干心。当言近不用定更乐。若住彼时起识处起若干心。当言近寂更乐。是谓其义。于五三昧彼起若干心。当言起心。犹如渐渐睡眠觉便速起疾。如是渐渐入灭尽三昧不渐渐起。当言是观。颇有二斯陀含成就无漏一禅现在前第二禅不现在前耶。或作是说有。若应空者则现在前。若应无愿者不现在前。或作是说。若所依有力者。则现在前。若所依力少则不现在前。或作是说。若利根者则现在前。若钝根者不现在前。或作是说。若厌欲界弃欲界行则现在前。若厌三界弃三界行则不现在前。复次未曾有所造行入无漏。三昧观应无漏。颇初禅中间近灭尽三昧耶。或作是说。有若得骠骞度三昧。则于禅中间入灭尽三昧也。或作是说。若依初禅等越次取证。则于初禅中间四谛所断结使。则近灭尽三昧。问彼非近初禅中间。入三昧彼便得近。或作是说。初禅中间入第二禅时。梵天上诸相应结。则得灭尽。问必起禅中间。是故不近禅中间。或作是说。若依初禅中间等越次取证。彼于初禅中间四谛所断结。近灭尽三昧。问此非初禅中间。何以故。必起世俗禅中间。贤圣道而现在前。复次非入初禅中间近灭尽三昧。结使未尽。外观尽彼智种俱住之法。当无觉有观即起不灭尽。如乐众生入慈三昧。非一切众生有乐。彼三昧为缘何等。或作是说。诸乐众生即彼因缘。问不缘一切众生有其慈。或作是说。一切众生有其乐根彼即缘。问非一切众生有乐根现在前。亦有现在众生有乐根。或作是说。若自更乐彼一切众生解脱。问非以此乐使众生乐。或作是说。非以慈堂一切众生有乐。复次以此方便坚住其心灭诸嗔恚成就诸法。问以颠倒故灭诸嗔恚。复次觉诸众生有其乐根。求众乐解脱。施恩众生皆成就之。如本所说。彼三昧当言颠倒。当言不颠倒。或作是说。当言非颠倒。诸乐众生是其因缘。或作是说。当言非颠倒。一切众生皆乐根。此是慈因缘。如本所说。复次当言非颠倒。嗔恚灭尽。如苦众生入慈三昧。非一切众生有苦。彼三昧为缘何等。或作是说。诸苦众生彼即其因缘。或作是说。一切众生有苦根。彼悲是其缘。或作是说。非以悲堂故一切众生有苦。复次以此方便而坚住其心。灭其害心。复次觉诸众生有苦相苦解脱。并及悲一切众生。皆求使安。如本所说。彼三昧当言颠倒。当言非颠倒。或作是说。言非颠倒。诸苦众生即是其缘。或作是说。当言非颠倒。灭其害心。如喜众生入喜三昧。非一切众生喜。彼三昧为缘何等。或作是说。诸喜众生是其缘。或作是说。一切众生有喜根。是喜其缘。或作是说。自得欢喜。欲使一切众生同。或作是说。非以喜堂故一切众生有喜。复次以此方便坚住其心。灭诸愁忧。复次觉诸众生欢喜相喜解脱。于一切众生同喜。如本所说。彼三昧当言颠倒。当言非颠倒。或作是说。当言非颠倒。诸喜众生即是因缘。或作是说。当言非颠倒。一切众生有喜根。是故是喜因缘。如本所说。复次当言非颠倒。愁有差违。又世尊言。于是比丘当修安般守意断诸观想。云何当修安般守意断诸观想。或作是说。修安般守意入第二禅。已入第二禅观已越过。问亦有余方便入第二禅。是故余方便断诸观想。或作是说。修安般守意依色界回转。不依观想断诸观想。此亦如上所说。或作是说。计出入息。有一缘于中无观无觉。如是断诸观。此亦如上所说。复次安般守意缘近不缘为若干缘无众生。彼少生业断诸观想。又世尊言。遍观诸身觉出息。遍观诸身觉入息。云何遍观诸身出息。云何遍观诸身入息。或作是说。观身尽无常觉出入息。问不从三昧起耶。答曰。三昧不起。彼方便必作不疑。或作是说。观身一切不净。出息入息。俱不染着亦不舍。或作是说。一切身中出息入息皆悉觉知。或作是说。一切身中观色界观回转时。出息入息不摄其想亦不舍。复次以此方便坚住其心。以此事广思惟之。云何入第四禅尽出入息。或作是说。计出入息时。即彼觉知入第四禅。于中出入息能悉灭之。问以余方便入第四禅。彼出入息灭耶。或作是说。入第四禅时。于四禅地息有回转。壅诸毛孔无出入息。问不从起三昧。出入息不回转耶。答曰。起更依余息回转。或作是说。如入初禅遂便增长。第二禅微第三亦微。如是渐渐息时第四禅无有。复次捐弃觉彼时禅出入息不回转。以何等故。生欲界众生得禅。于禅不退。命终时便生色界。已生色界得一切禅。于禅不退。便命终还生色界。或作是说。此间行对地。此间起禅而生彼间。设彼入三昧。设生彼间者有报。不以报有报。问如今无有彼没还生彼间耶。或作是说。入第三禅净气味相应。无漏禅净得生彼间。于气味相应。退以无漏般涅槃。如是生彼间。若净禅三昧即生彼间。若入气味相应禅。于彼间退。若入无漏禅。即于彼间而般涅槃。或作是说。此间入四种禅。渐渐退住退增上退。渐渐退住退生彼间。增上退越彼间。厌退般涅槃。如是生彼间。若入渐渐退三昧。便于彼间退。若入住退三昧即生彼间。若入增退三昧超越彼地。以无漏道于彼间般涅槃。或作是说。非以禅得生彼间。行垢染着得生彼间。若已行对死者。若复住彼间。以行对不死即生彼间。若不以禅生彼间者。非中间禅生彼间。答曰。无苦。若依未来禅还欲爱尽。于中间禅得生彼间。复次此二俱非妙。众生生欲界得诸禅。色爱未尽便命终生色界。色爱尽无色爱未尽。命终不生色无色界。无色界爱尽。便命终生无处耶。问云何受报耶。答曰。若爱尽报相应则无也。如彼前则随后。中间相应报果生色界。众生得禅色爱未尽。便命终不作方便求生欲界。若不厌弃方便不增。方便求者便生。生色界爱尽。无色爱未尽。便命终不生无色界。无色界爱尽。命终生无处所。问云何今受报耶。答曰。无有定受相应行报。于色界行禅甚难得。况无色界三昧也

  更乐斯陀含　　有灭尽无量
  念说一切身　　云何灭欲界

若一切超越识。入处无有。不用定云何彼无耶。少有思惟。或作是说。彼无猗处。有所恃怙无有思惟。问一切三昧思惟此事。或作是说。彼无有乐无有常。亦有不思惟。此亦如上所说。或作是说。彼无有吾我。亦不思惟。此亦如上所说。复次如若干种相貌。便离想解脱。以何等故不用定谓之护耶。或作是说。彼三昧无有定无有。当有以有。是故不用定谓之护也。或作是说。道护越彼道。是故不用定谓之护也。或作是说。护是果。世尊亦说。修护广布越不用定。复次无量定不选择。不造利养住也。云何净是不净义。或作是说。诸不净相则是净义。问无有不净相。彼或有净或不净。答曰。所谓净者彼是颠倒。彼或有常或无常。欲使言无无常相耶。或作是说。净相者言无净。问设彼无净相者则不染着。非以净相彼染着。答曰。不净作净相则染着。设彼有净相者。如彼观之彼则染着。若不如实观者。是故彼无净相。或作是说。专意心念如是不净。问彼或终成或不终成。欲使彼是净。欲使彼不净耶。复次色无有净无有不净也。如彼所趣贪着不离。颇舍修四禅不用定生净居天耶。或作是说。无也。舍修四禅得生彼间。问诸有修第四禅生净居天。彼一切生净居天耶。答曰。以事行故不生。叙子生萌芽。行事故不生。复次颇依未来禅修无漏道。彼灭诸结生净居天。诸修分别禅入第四禅。彼一切生净居天耶。设生净居天。彼一切修分别禅。入第四禅耶。或作是说。诸生净居天。彼一切修分别禅入第四禅。颇修分别禅入第四禅。不生净居天耶。阿罗汉若无色界阿那含。或作是说。颇修分别禅入第四禅。彼不生净居天。得修分别入第四禅。净居天上爱尽也。颇生净居天。不修分别入第四禅耶。依未来修无漏道。彼灭诸结使也。颇修分别入第四禅。亦生净居天耶。得修分别入第四禅。净居天上爱未尽。颇不修分别入第四禅。亦不生净居天上耶。除上尔所事。则其义也。云何修分别入第四禅耶。或作是说。入净禅三昧。以无漏思惟分别。问净禅彼非无漏思惟。如无漏思惟者。彼不净禅。复次无漏禅于其中间入净禅。净禅中间入无漏禅。不以无漏长养净禅。彼长养净居禅。云何知有净居天耶。或作是说。修分别第四禅生净居天。如此间见修分别第四禅。无色爱未尽命终。然后得知有净居天。如此禅因缘。复次由阿那含知。世尊亦说。此趣不易得。犹如我凡夫人长处生死。除净居天。如初第二第三禅修分别禅。以何等故。初第二第三禅不生净居天耶。或作是说。最初得顶。第四禅复能分别禅。及欲爱尽不生余地。问如不观入思惟三昧分别四禅。何故不观入第四禅分别八地。或作是说。诸得利根便能分别四禅。恃怙利根复越余地。问越第四禅。是故不生第四禅地。复次天地变易时。乃至第三禅地坏。然非贤地变易。世尊变易时。此有诸贤。以行报对故。得生净居天。若得第四禅。依初禅等越次取证。诸结不相应。于四禅退。当言得彼诸结。彼成就耶。或作是说。当言得。问如所说以外道灭。便得贤圣道。乃至究竟尽彼无。或作是说。当言不得。以作彼贤圣道。乃至究竟。问不于中间生四禅地。答曰。此事无苦复越第四禅。或作是说。思惟所断非四禅所断。何以故。四谛所断是贤圣道。非思惟所断。复次依彼念复更造念。复次于第四禅退。何以故。彼等越次取证忍智回转。然彼等方便力。不于等方便力退。是故不于四禅退。若得想三昧。依第三禅等越次取证。无想三昧不退。命终后生无想众生。或作是说。生果实天。此三昧是彼间地。问如彼越地。云何复言彼地等越次取证。或作是说。不得无想三昧等越次取证。彼意迟钝彼三昧永寂。问入第三禅意耶无疑。复次等越次生第四禅。越次取证。想三昧不广布。亦不亲近。复次生第四禅中

  无有净不净　　云何知方便
  如得三四禅　　无想名不终

如一切第四禅得念待喜。以何等故谓三禅非余禅耶。或作是说。此世尊教戒语也。问此义云何。谓第三观禅念待喜。非第四禅。或作是说。世尊劝助语。说此则说余。问说初禅则说余禅耶。或作是说。三禅中乐彼是最妙。是故念待护于中不退。问当护一切禅。或作是说。三禅中乐是妙者。念待是其事。如气味者。问此非第三禅念待。所以着乐。第四禅亦当有念造无教。如是我有禅。复次彼事有胜。云何第二禅相应念心不断喜处所也。如一切第四禅得护念净。以何等故得护念净。谓之四禅非余禅耶。或作是说。是世尊教戒语。问于中念护有净相。则一切护。或作是说。于中有净护念求护喜根。或作是说。威力初禅回转是其缘。亦依第四禅得念处所护。若苦若乐有觉有观。及出入息以离诸恶。或作是说。于彼众生多结尽。尔时护念亦护诸禅。复次于中行有增心不移动。乐所造念息而护三昧。颇凡夫人及灭尽三昧耶。或作是说。凡夫人不及彼三昧。此非凡夫人三昧也。或作是说。凡夫人缘上界得灭上界。至有想无想。有生入处。如所缘灭有想无想处。是故不入彼三昧。或作是说。凡夫人亦有三昧。入三昧时心初得休止想心得定。复次想界彼是因缘。捐弃彼缘不欲三昧。如忧持迦罗那子入无想定。便恐惧生有想无想天。是故不入三昧。复次不入定也。何以故如如凡夫人入三昧。渐渐有力势乃至究竟。凡夫人恐惧。自见吾我灭尽想。是故不入彼三昧。颇有菩萨入灭尽三昧耶。或作是说。入彼三昧也。菩萨发大弘誓。求索一切处所。若不入此三昧者。则不能一切众生处所。或作是说。不入彼三昧。何以故。彼非凡夫三昧。此凡夫人菩萨。或作是说。不入彼三昧也。菩萨以世俗道。缘上地灭下分结。有想无想尽无所有有缘。灭有想无想处。是故不入三昧。世尊昙摩多罗作是说。虽菩萨自观羸劣不究竟恐惧。复次菩萨以智慧越彼嗔恚。竟无有限。非不有三昧方便。无想三昧灭尽三昧有何差别。或作是说。无想三昧是凡夫人三昧。灭尽三昧。非凡夫人三昧。问我不论此事为谁三昧。复次当说三昧相貌。或作是说。此无想三昧广大无边。灭尽三昧休止不起。问若此俱无心所念法。此二俱非广大休止耶。或作是说。无想三昧与色相应。灭尽三昧与无色相应。问我亦不论此三昧处所。但当说三昧自相。或作是说。无想三昧无想众生果。灭尽三昧有想无想果。问我亦不论为谁果。但当说三昧自相。或作是说。无想三昧自知入有想三昧。灭尽三昧想痛自知入三昧。此如上所说。复次如所欲二俱心所念法。则有是想无相。如所说有想三昧心得觉知。于心三昧广大休止。色无色界相应果。方便则有胜。若依不用定。得阿罗汉。为思惟何等相应心所念法得阿罗汉。或作是说。不用定相应。世尊亦说。如彼所有痛想行识法。思惟彼法。如契经本说。或作是说。有想无想相应。自知有想无想。远有想无想。不远不用定也。得有想无想欲尽。或作是说。若不用定爱未尽。依不用定逮阿罗汉果。彼与不用定相应。有想无想相应心所念法。思惟得阿罗汉果。若得有想无想三昧。依不用定逮阿罗汉果。彼与有想无想心所念法相应。逮阿罗汉果。复次如自思惟吾我无。吾我所缠已得断。智便得爱尽。思惟何等苦阴行而得尽余苦。如自田业作。余者不获此。此亦当如是。以何等故。无漏三昧谓之余缘非净三昧耶。或作是说。无漏三昧缘三界。以无漏初禅觉知三界。然净初禅无巧便觉知梵天。是故若有因缘然非净。或作是说。无漏三昧者。一一相生。是故以此初禅得无常想。则获一切也。然净初禅不以此同。或作是说。无漏三昧者。断诸一切结使永尽无余。依无漏初禅灭三界结。如是一切以净初禅无巧便灭梵天上。或作是说。以得无漏初禅。得已无漏色。然不以净初禅而现在前。亦不得第二禅。复次非以净三昧展转而得。修行增上禅净现在前。复以余方便第二净禅而现在前。无漏初禅现在前时。得增上无漏无色。是故无漏三昧展转有因缘。然非净。以何等故。诸三昧上气味相应。三昧与下气味相应。三昧中间因缘。谓之因缘。然非下上缘。或作是说。入三昧时起禅中间。彼退不回。如欲上梯。从一一桄始。若从梯下亦由一一下。复次入第二禅。气味相应退。复有入初禅然非初禅。气味相应入第二禅。慈大慈有何差别。或作是说。微谓之慈。广谓之大慈。或作是说。少所入为慈。一切遍入为大慈。或作是说。慈缘身苦。大慈缘身意。或作是说。慈缘众生苦。大慈缘救众生苦苦。复次大慈广无有边。遍至一切众生无不蒙赖。复次如来世尊护一切众生。然非声闻。有近有远。一切众生有所愍念。欲使声闻愍有色无色众生。若净解脱门。如自因缘八现色入。及自因缘十二入此有何差别。或作是说。微解脱门中。八现色入。增上十二入。或作是说。少有三昧解脱门大三昧。谓之现色入无量三昧十二入。或作是说。净相谓之解脱门。结尽八现色入无有思惟十二入。复次增上是解脱门。因缘十二入。长诸结亦是十二入

  一切苦凡夫　　或菩萨威胜
  无漏上下界　　胜行解脱门

又世尊言。无禅不智。无智不禅。有禅有智。是谓涅槃。说此语其义云何。或作是说。以此契经得须陀洹。得诸禅故。说无智不禅。须陀洹亦有斯智慧。是故禅亦依彼。问平等觉观于中有禅。若如契经者。外亦有禅。是故彼有智。故说无禅不智。问外亦有世俗智慧。答曰。若彼外有智慧者。亦外涅槃。故说有禅有智。是谓涅槃。或作是说。若智慧是心地者。亦无智慧。彼无有一心禅。故说无禅不智。若无一心禅。彼亦无有思惟智慧。故曰无智不禅。若有一心禅思惟智慧。彼灭诸结使。故曰有禅有智。是谓依涅槃。复次若有无生智得等禅法。便有休止。况成果实。故曰无禅不智。若缚着心意得便变易。况当有果实。故曰无智不禅。彼若有止观。彼止观观外时时修行。解脱牢固不有灭尽。故曰有禅有智。是谓涅槃。三昧义云何。或作是说。缘一心所念法。是谓三昧。问无想三昧灭尽三昧。无有心所念法等生。欲使彼非三昧耶。或作是说。众多心缘一处所。是谓三昧。此亦如上所说

复次三昧有若干相。善法三昧雄雌三昧。九次第禅护。诸义与心等者。是谓三昧。颇因苦相应禅。禅现在前耶。或作是说。无也。与苦相应便有念待念待禅。是故不现在前。或作是说。或现在前与苦相应。如实知之便起念。于中禅现在前。复次不戏笑时。依苦禅现在前。此大嗔恚四等。梵堂何者最胜。或作是说。慈最是胜。慈愍众生皆令安隐慈。彼而已入慈三昧无有狐疑。或作是说。悲最是胜。以大悲故来出世说法。亦不见有大慈大悲大护。或作是说。护最是胜。为良果实修护。则修不用定。复次护最是胜。众事休息是护筋力。欲嗔恚灭。以众生故。是故护胜。以何等故初禅曰寂。第二禅曰三昧。或作是说。斯二俱寂三昧。初禅休息众多。是故第二禅寂。复次如其地种水种。如是空寂不善法由初禅生。故曰空寂。是故意定由二禅生。故曰三昧。内喜者此义云何。或作是说。有觉有观生心离缘。有觉有观生心便欢喜。如去污泥水渐渐清。或作是说。调戏心息便清净。如水踊使缓流涓涓澄清。或作是说。彼心缘一住彼谓等清净。如所说去浊复清。复次入二禅意得清净。有此彼处得初禅也。喜乐有差别。或作是说。下为喜。增上为乐。或作是说。心所念乐痛为喜。身乐痛为乐。或作是说。踊跃生喜猗生乐。复次彼方便心喜。无有挂碍。于中相应喜。身心不乱谓之乐。诸有不废禅者。彼一切成就禅耶。设成就禅。彼一切不废禅耶。或作是说。诸成就禅。彼一切不废禅也。颇不废禅彼不成就禅耶。若无垢人生无色界。复次颇不废禅不成就禅耶。诸有渐渐稍稍弹指之顷思惟眼无常也。颇成就禅非有不废禅耶。阿罗汉智慧解脱也。颇不废禅亦成就禅耶。诸得禅不失。颇不成就禅亦废禅耶。除上尔所事。则其义也。以何等故。世尊于四禅起于四禅涅槃。然不用余耶。或作是说。愍后众生故。故现照明。以斯后众生知佛世尊常不离四禅。况当我等能离禅耶。或作是说。如檀尼宝客时欲命终。以珍奇宝物最后妙宝。施彼贫穷。如是四禅众禅中妙。是故留在后。然非如来世尊有诸垢着。或作是说。彼有自在非有巧便。初死时入第一禅尚难。况第四禅。复次诸入一切佛。如转轮圣王所欲便至。佛世尊亦复如是。自在诸法王所欲便至。当作是观。以何等故佛世尊般涅槃时。一切禅解脱。入三昧正受而现在前。或作是说。自将养身。或作是说。身体羸弱养得筋力。或作是说。众荼(人也)名全师子。报其施福。或作是说。为后众生故现照明。或作是说。现有自在不有自在。命终时入第一禅尚难。况入一切禅解脱正受。复次现法不尽。如来世尊一切功德成就。以得自在所欲便至。禅三昧苦乐

  堂寂及心意　　欢喜念不废
  四禅最在后

如所说十八缠。安般守意。贪欲恚嗔睡眠调戏疑无想摄。不思惟止。不端思惟。方便求少有方便多语。无益希望。念着多行。贪宝怨恨。从此以起集聚意。此有何差别。答曰。欲有义是谓贪欲。众生心嗔恚是谓嗔恚。心有烦闷是谓睡。睡重谓之眠。心未休止谓之调戏。心不专定谓之疑。心不究竟。流驰万端亦疑。出息入息观不离意。摄无想。思惟处所。安般守意。于中作方便。安般守意少方便。不思惟不专意。思惟增上方便安般守意。意少方便。不作增上方便。算数多语有觉有观力所逼。以此方便不乐怨恨增上。希望思想万端喜爱。安般守意得他处意。方便起意有所摄。二月专成行经。如经所说。说此语其义云何。以何等故世尊二月专成行经。或作是说。此非问也。是佛世尊威仪化导。缘大慈悲故说此法。或作是说。当言于尔时无有佛事。诸淳熟根便得度脱。诸不淳熟根。彼得闻法。或作是说。彼比丘数往亲近于如来所。彼时世尊入三昧定。渴善易化。或作是说。彼比丘听深妙法。数往承受不入正受。是故世尊常三昧定。我若入此定。彼诸比丘亦当入此定。或作是说。以后沉溺众生故现照明。或作是说。于现法中自在所欲。如所说郁多罗摩纳。或作是说。此是要言。义使诸比丘无有异行。世尊说入定福。然不自入定。或作是说。一切智长养。如种树随时溉灌因缘相成。或作是说。有异学梵志。备作是说。瞿昙沙门无有禅定。但说法耳。是故世尊入定坐禅。如所化耶见众生而摄取之。是故世尊入定坐禅。复次以二因缘故。世尊入定三昧。自所见法而游戏其中。复以众生故现其照明。当于尔时我比丘专念入息。专念出息。现四意止。观入息短自知息短。观入息长自知息长。入定不久息出入速。如入定三昧。亦堪任久住。一切身毛孔悉皆知之。此亦如上所说。猗身行观身行相。广布渐渐至于其中间住出入息。依欢喜喜。若初禅地。若观第二禅地。常作是观地。亦依其事乐初禅地。若第二若第三禅地。皆观其地。心行所由亦观想痛。或作是说。观心意行猗心意行。意行渐薄。是谓由心观识心遂欢喜。如来无有忧喜心等。若当解脱。所以菩萨心常欢喜。若三昧若解脱。起若干相观无常想。观出入息常观灭尽除爱结使永尽无余。观无欲观爱尽观诸使尽。复作是说。观无常观身无常。观尽观无明尽。观无欲观有爱尽。观尽观有余。有余无余涅槃果尽。复作是说。观无常观五阴无常。观五阴空无我。观无欲观无阴苦。观尽观五阴无生法。复以微妙无欲入第四禅。彼有天曰。呜呼哀哉。如来命过无出入息。虽诸根未错命终不久。时诸贤圣堂相。诸贤圣人。持以此得贤圣道神通堂净天堂净天处。梵天堂佛堂。是佛行不还者还。阿罗汉于现法乐四禅贤圣乐行。复次专念入息有入息想。观出息有出息想。不离方便有出入息。行如是垢除。思惟念出入息想。有觉有观渐渐薄。广大休息。彼复作是念。身意连属自知息短。便自知之不舍本相。如复有余。世尊思惟。思惟渐休息。作无觉心休息。彼身心无有是念。身心有移动。身住心住。无愿息长观出息长。观出息长亦知之不离本相。于中世尊出入息。一切身体皆悉观之不离本相。复次世尊转修行倍得休息心。出入息薄皆悉观之不离本相。是谓世尊四种思惟出入息。是其事无量因缘自然气味。复次世尊作是象。彼心不移动。心如金刚。回转欢喜和颜悦色。皆悉观之不离本相。复次世尊实生身心。皆悉观之不离本相。复次世尊观彼喜乐。无命有无命想。心行得解脱。皆悉观之不离本相。复次世尊彼欢喜乐。有旷大想心得解脱。彼心休息。行渐薄休息。皆悉观之不离本相。是谓如来四种痛思惟彼痛。分别解脱无量因缘。所由除其自相。复次世尊彼受化人无命有命。想心得解脱。皆悉观之不离本相。彼心得欢喜。思惟欢喜倍甚欢喜。皆悉观之不离本相。彼心欢喜为一水味起方便。皆悉观之不离本相。彼心缘三昧定。方便解脱如实无异。皆悉观之不离本相。是谓如来四种思惟心。分别解脱无量因缘。所由除其自相。复次世尊广解脱心。如实观之无异。以作劳勤。当于尔时出息入息展转观之。是谓观安般守意。亦观其缘。观次第缚。观罪行报。观遍一切心所行。展转观之。是谓观安般守意。次第缚罪福行报。彼如此法无常心解脱。皆悉观之不离本相。彼如是十事住诸法意。法想诸盛阴皆悉捐弃思惟休息。皆悉观之不离本相。无相无常想者。爱永尽无欲。思惟休息。皆悉观之不离本相。彼心所作降伏修行。作我断想思惟休息。皆悉观之不离本相。是谓如来四种思惟法。分别解脱无量因缘。所由除其自相。如是十六事者。以更历广大安般守意堂。世尊思惟未曾离。彼则有相与共应。亦与行相应。以微妙行起第四禅。乃至灭尽三昧。彼有一无观。此无出息入息。亦不摇动。亦无所觉知。亦无本心。呜呼哀哉。瞿昙沙门命过。有第二天。观如来身颜色未变。便作是语。此未命过。今命过亦当不久。有第三天。曾观世尊及弟子入三昧正受时。亦见从三昧起。便作是语。此非命过。亦当不命过。所入堂作如是形象。当成阿罗汉。问云何今世尊知从三昧起本所回转。答曰。听时清净诸根清净。是故彼大因缘清净意识生从彼起。复作是语。自觉知无数之念修自在智。是谓贤圣堂。无垢贤圣清净天也。神通不乱乃至梵天所觉。断结学阿罗汉无学。如来堂诸学比丘不还者。还无学果实。于现法中善讲堂得无疑法

如尊者舍利弗说。善乐休息。谓之涅槃。尊者摩诃拘絺罗问尊者舍利弗。彼云何乐无有痛痒。广说如契经。彼无痛痒故曰乐。说此语时其义云何。或作是说。尊者拘絺罗痛乐为彼说。然乐痛不究竟。尊者舍利弗说休止乐。乃至究竟乐有常乐。或作是说。观痛乐彼少有痛乐少有苦乐。无观乐是涅槃。故曰所以乐者彼无痛。或作是说。痛乐为苦所缚。休息乐者不与苦相应。故曰彼乐。或作是说。痛乐无有定实乐。休息乐有定实乐。故曰彼乐。复次如性行回转得。彼入初禅时欲界相应。遂便有增。若彼与欲缚见思惟想行嗔恚便盛。如乐众生必当受苦。是故生死垢外唯涅槃乐。是谓尊者说此义。故曰无痛痒故乐。又世尊汝有吒婆罗色。四大人自言。是我所者则当久住。若更生余想者。亦有灭尽。说此语时此义云何。问世尊所许汝学布。吒披罗。彼想起便灭欲使移转。问云何瞿昙沙门。我者即是想耶。想颇有所见耶。设当见者。是我想者便知想若干种。如上所说。便知想非类。彼时世尊逆质其义。云何汝有吒婆罗人有吾我也。彼曰。实尔瞿昙。有色四天人有吾我。彼时世尊欲生其言。汝有吒婆罗言。色妙及四天身。人有吾我住者是我所。若生余想想生便灭。如来性行志不可移动。又世尊言。如是阿难。想三昧者。教戒成就。又生有想无想天。若比丘入彼禅一一分别。说此语时其义云何。或作是说。此七三昧志如金刚众事悉备。是故教戒成就。无想三昧及有想无想三昧灭尽三昧。心不相应休息不起。是故彼无教戒成就。或作是说。此七三昧亦有漏亦无漏。以无漏道教成就。是故彼贤圣教戒成就。无想三昧及有想无想三昧灭尽三昧尽有漏。非以有漏道得成就教戒。是故彼无教戒成就也。或作是说。无常想苦想无我想。灭尽休息想。道出要想。便教戒成就。无想三昧。及有想无想三昧想。游出三昧想。是故彼无教戒成就。复次智慧照明与身相应。等观身中。彼无想三昧灭尽三昧相应行。以得休息。犹如禅人从禅中起能有所说。若亲近住入禅中。余时不能有所说。有想无。世尊故说此耳。又世尊言。五法成就。常处闲居山顶丛林。衣裳粗弊不以为丑。不择饮食床卧病瘦医药。常作去欲之想。观如是色法成就诸义。常处闲居山顶丛林。说此诸语时其义云何。或作是说。犹如有人淫意偏多。欲爱未尽有此诸病。或作是说。是世尊劝教语。况成就五法。不乐闲居常作城傍行。虽处闲居亦少少耳。复次如山泽法。不肯修行不能至闲居所树闲空处。不修变易想。是故彼人不处闲居山顶丛林。自计吾我彼处闲居。复有是妄自计吾我者。常处人间。又世尊言。于彼比丘内起无色想外观色。乃至观白有白想。如契经说。以何等故。白像色色便有鲜。最众行中妙。或作是说。此为上色。是故彼缘色为上。或作是说。缘白思惟生心白。复次亦天眼与诸行。以是故白色为上。又世尊言。有此三乐。无诤讼乐。居独处乐。无欲于人乐。云何无诤讼乐。云何独处乐。云何无欲于人乐。或作是说。戒无诤讼。是故常学禁戒。无欲于人乐者。思惟三昧定。居独处者。降伏其心。居独处乐智无有乱。是故当学智慧无诤讼乐。当学智慧身意无怒乐。或作是说。一切生死为苦。无生死为乐。彼禁戒尽无诤讼乐。诸乱永尽居独处乐。无有戒禁尽居闲处乐。复次戒禁清净去苦行意。无过行痛乐。便生念与相应。无欲于人乐。念禁戒者。身有喜恼。于此禁戒常意修行。生诸乐痛。念相应者。居闲处乐。如尊者舍利弗说。诸贤。半月说戒。不起法现在前作证。不起法观者何等是。或作是说。所可用道得须陀洹果。常亲近彼道。半月说戒成阿罗汉果。或作是说。彼诸贤。半月说戒以无常智。苦谛未生便见习谛。习谛中间便见尽谛。尽谛中便见道谛。或作是说。半月说戒。与长抓梵志说法时。即思惟十二事。所遭众相分别无数。乃不起法观

  垢着念身乐　　色劣想想至
  闲居分别行　　三乐及止观

尊婆须蜜菩萨集之三昧揵度第三竟

    尊婆须蜜菩萨所集天揵度首

又世尊言。汝等比丘。如人三十三天快哉往生善处。以何等故。如人相三十三天言快哉往生善处。或作是说。于此间造行。使人天所生。或作是说。于此间诸佛兴出世。复作是说。于此间说等法故此间得信。于此间修梵行于此间受具足。于此间等越次取证于此间得阿罗汉果。复次一切诸趣唯天人。彼如人天善处。如是天人善处。以何故光音天身一形像有若干想耶。或作是说。彼一切自有得禅报。是故有若干想。彼一切天皆乐想苦想故曰若干想。问梵伽夷天光音天得禅报。彼一切天有乐想有苦想。欲使彼一身一形像有若干想耶。复次有觉有观三昧心便炽盛便得因缘。此心算数入第二禅有觉有观休息。若光音天颜色暐暐。彼同一形此之谓也。念者生高下。是故彼有若干想。以何等故色界天眼观色耳闻声。然鼻不闻香舌不知味耶。或作是说。彼不有香味处所。问色界之中无香味耶。答曰。得境界诸根。以远离香味故也。问如来欲界不远离则知。答曰。彼根不错乱。欲界香味错乱。彼以行故来。云何欲界之中无错乱缚。问或以欲界香味缚着方便求灭。若未曾更者欲使缘报。此事不然。若使苦复加苦者。色声亦复当尔。是故色声而不可得。答曰。眼非境界。耳者色声不缚着。问色声在远亦缚着。日月在远遥曜目睛。若击大鼓而耳闻声。设得色声。香味更乐。身根亦当缚着。是故身更乐不缚着。或作是说。彼无苦根鼻根则有乱。亦诸根成就。是故彼一切诸根。答曰。彼所问者是故彼根成就也。问彼诸所有者。即是诸根成就耶。生丧目者根亦当具足。答曰。人事生丧目者亦不同其相。根不有具。问无色界中根不具足此非妙是故无。或作是说。彼无有鼻识舌识。问光音相应无五识身。彼彼使不见不闻。答曰。梵天上念相应生眼识。耳识亦见亦闻。何以故。不与欲界相应生鼻识。舌识知有香味。答曰。彼不因香味。是故彼不生识。彼亦用色声。是故生眼识耳识。或作是说。彼根钝彼境界钝。是故不回转。问眼耳不回转耶。答曰。眼耳捷疾不摄境界。亦能起神通。复次亦闻香味知于少少不明设彼本不得香味。是故彼根成就。得自在境界已得根境界便生秽根。如色界未来至欲界眼见色耳声。彼眼识耳识当言欲界相应耶。当言色界相应耶。或作是说。当言欲界相应。亦当言色界相应。化作是欲界形来彼当言欲界相应。还作欲界形来者彼当言梵天上相应。次诸相应彼自然当言彼相应。彼便作是念。如有觉有观五识身云何。彼光音天相应三昧亦有觉。然非三昧心。乃至有想无想。以何等故色界天有鼻根舌根。然无男根女根耶。或作是说。彼说无男女用也。问鼻根舌根彼亦当无用。或作是说。彼不习欲。问不于香味无欲耶。鼻根舌根亦无欲。或作是说。男根女根亦无欲。或作是说。彼生入处自尔。复次已除淫根彼行不住。彼有男根女根。彼便作是念。云何于此间有不成男。阿罗汉亦有此。亦复如是。欲界之中无女根不成男处恶胎。欲使知识爱欲更乐。彼阿罗汉识本所更至死不起心。以何等故色界天起寿行。谓之住耶。或作是说。净无有乱。问入欲界禅三昧。欲使彼各各无寿行耶。或作是说。彼自然意尔。此亦如上所说。彼亦各各寿。世尊亦说。阇婆那天子寿命速疾寿不常住无处所。复次无有寿命生死有住者。彼相应生自然缚着。若作是说。诸有怨家。彼则有害意也。又世尊言。比丘。阎浮利人三处胜郁单越人。此间揵勇猛亦修梵行住。其义云何。答曰。此胜于彼。勇健亦不畏死。一切生死方便求天无有境界着。有胜志忆本所说造诗颂。天无有境界缚胜。于此间修梵行而不远离于此间出家。于此间修行道。然天无有境界胜。以何等故。诸天子丧逝便怀愁忧。或作是说。身爱未尽也。问色界之中身爱未尽。彼使彼丧逝时生愁忧耶。答不以色界相应有根也。问如今爱未尽生欲界中。复次彼境界净甚深着。彼不相应便生愁忧。诸有命观六爱身愚騃力行。何以故。彼命过时不生愁忧依彼胜。亦作是说。欲界之中有愁忧。云何天子知丧逝法。或作是说。亦自知我久生我寿命尽不久。问彼不定寿命。复次本有相应相。彼即知亦当闻。云何天子知于此没生彼间。或作是说。于彼道受报行。欲使宿命所更则有果报。果报未熟彼自忆知我当生彼间。或作是说。彼丧逝时彼行相应。以此行故以此法当生彼处。复次闻须谁能分别知生因缘自知所趣。云何天子知于彼间逝生此间。或作是说。彼生自然。或作是说。忆彼化生。复次彼不一切忆诸不捷疾根者。彼不忆捷疾根者。忆如所说。彼化天子诸使忆乃至契经意

  善趣各各观　　此间无有根
  生忧无所摄　　自知此间没

彼天子丧逝法便五相。此义云何。或作是说。本所造缘善报不善报。善报行者。得天眼自然福。不善报者。则生五相。或作是说。愁忧因缘则是彼缘。若已生愁忧彼则有生。是故愁忧中间当言愁忧因缘。或作是说。自依因缘则生彼行报因缘。愁忧因缘如因缘淳熟。自依因缘则有行报坏缘无常心。天子丧逝法生五相时。当言等生。当言渐渐生。或作是说。当言等生也。彼一切缘愁忧生故。愁忧生此五相起。或作是说。当言渐生。已生愁忧便顺热。使彼华饰枯。见已倍怀愁忧。色变憔悴便自惊愕。使彼流污盈面已有流污衣裳。自见衣裳污。便自不乐坐。复次当言渐生。如莲华欲熟时叶稍稍落。如是彼天行果熟时。此相渐渐生。以何等故日天子住一劫。或作是说。众生行果使日往行增上则有此报。问众生行无有经劫者。或作是说。天地融烂时行报便灭。问前造行后受报。彼无有力势尽坏败烂。复次曾闻此非劫之数。以何等故月住一劫。答曰。如日无异。以何等故梵天言住一劫。或作是说。天地融烂便有此生。天地不融烂便断。问此非劫数。或作是说。二十中劫四劫劫大劫住二十中劫是谓作劫。问契经则有违如所说。天地反覆梵天宫室便生彼间。若天地不反覆生光音天宫。复次此曾闻不有生处寿住劫也。又世尊言。于是比丘有六更乐地狱。云何六更乐地狱。或作是说。阿鼻名六更乐地狱。于彼众多。复次一切地狱皆六更乐。于彼众多苦毒愁忧。又世尊言。于是比丘有六更乐天。云何六更乐天。或作是说。他化自在天彼宫众多。复次一切天皆更乐。共相娱乐而受其福。以何等故七神止处是恶趣。果实有想无想天非所摄。或作是说。此如来劝教语人欲界天说欲界已初第二第三禅地分别则分别无色界说三无色界则说色界。问如所说二入处彼则有违。或作是说。是如来劝教语于中识捷疾。如诸恶趣果实有想无想。问此亦不生。亦说二入处。净居天捷疾。识处亦不住。或作是说。诸有六识处相。彼是识处住。恶趣有想无想天无断灭无识。净居天是谛所断无识。无想众生尽无有识。是故彼识无住处。问彼不生也。云何阿那毗天(净居天也)弗楼天果实天彼有识处。有捷疾识。亦不识彼处相应。复次所乐处识住处。不乐恶趣苦恼众多。果实天或与相应学余灭有或求无想睡眠时住。或无想众生。是故彼不乐处所更增生有想无想天。复次天心得休息彼少所乐。是故不得言彼识摄处。所以何等故无众生居。谓恶趣然果实天所以摄。或作是说。是如来教戒语。说人则说恶趣余残。说色界则说果实。或作是说。是如来教戒语。此众生居众多众生娱乐其中。复次恶趣苦多不乐。其中果实天。或摄住处所。或不摄住处所。何以等故。无想众生自生寿命行住。然比丘不入有相三昧。或作是说。彼志寂静。问于此比丘入相三昧。志意寂静。欲使彼不各各有寿命行耶。或作是说。彼无有坏败。无刀火毒害。或作是说。于彼心意则有回转亦不死。或作是说。彼常入三昧。此亦如上所说。或作是说。彼亦各各有寿命行。世尊亦说。如住牢固契经所说。复次或有寿命行自说生。或皆相应生。然于此间多有怨家。此不究竟入三昧。若作是说。则无坏败。如无想众生修道想尽。云何彼间。终来生此间。或作是说。如想中间入无想三昧。于无想三昧退还彼想。则作因缘。或作是说。非彼三昧想有灭尽。于此间起复修行想。如久处闲居造诸愚冥。上亦有增。复次行因缘故。受诸想着。以彼行故。猗着爱染自愚等。彼愚如所堕处则堕其中。如以谷子散虚空中即还堕地

  命终上日月　　梵天劫数限
  泥黎趣七处　　九神有想天

尊婆须蜜菩萨所集天揵度第四竟

尊婆须蜜论卷第四尊婆须蜜菩萨所集论卷第五

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    四大揵度首

又世尊言。比丘色无断智亦无所知。无断灭欲爱未尽不断苦原。云何色无断智。云何亦无所知。云何无断灭。云何爱未尽灭。或作是说。自相断智智相应。观彼自相诸结使尽永断无余。从此以来常怀和合。自断智拔诸结。使彼无欲爱。色拔诸结使更不复染。或作是说。以世俗道断智。以第一道。知彼世俗道者。结使得断。彼已尽。谓第一道拔诸结使彼欲爱尽。或作是说。以四谛道知。以思惟道断。知四谛道灭尽。思惟所断道欲爱尽。或作是说。身谛处所是知智慧处所。是断智施处所。欲爱尽休息处所不起。复次于是此色分别知色。彼色亦无常。知苦空无我。彼空无我色恒随愚痴。彼灭无常苦无复爱着。彼欲爱尽。如是自随愚痴不除己爱。无明断爱尽无余。身坏命尽身名识除。如是不有等苦尽。以何等故。地种为坚相。或作是说。于中无有事法性自尔。问设地坚无缘者。水亦当无缘。如水无有坚。如是因无地也。或时为水。是故当说地有缘。或作是说。有不坚缘。不以财果相应有其缘也。问财无有因缘则有常。一切相应相类异流转诸行。或时有或时无。复次地是其事。坚有坚报。问亦曾见软成坚。是故坚无有缘。答曰。一切诸四大。或时有坚有实有软因缘成坚。是故软与坚地为因缘。火种风种亦复如是。如地种坚相可使不坚相耶。或作是说。不可得也。独自思惟自相不知思惟。思惟无量断思。水种火种亦如是。可得四大一时俱生。有多少数也。答曰。可得也。忧钵花以风相知。有一四大处。彼有四四大耶。或作是说。有一大则有四大。不得分离。问有一则有四大者。终不有一欲使无四。或作是说。有一则有四大。世尊亦说。诸所有色彼则有四大。由四大生。问此但说色是谓为色。若如汝经说。则无有四大。或作是说。曾见如石在火精练然后乃软。故彼无者亦不成软。是故一切是也。或作是说。有一则有四。设地无水者则有坏败。问欲使坏败在处处耶。或作是说。不遍有一切。若当遍有一切者。石无有水风不可得。问便有增益。答曰。于中长者则在处处。复次此不有定。不遍有一切所。可无处彼不可得。以何等故。四大谓暖法非冷法耶。或作是说。若四大是冷法者。则在处处。一时有暖有冷。问此所造色则无处处。是故一时有寒暑。或作是说。若四大是冷法者。此非四大。当言五大。问此亦是我疑。何以故无五大。或作是说。暖法冷法大事兴。是故四大当言非冷法。复次此四大亦暖法亦冷法。若无暖法者。但当言冷法。初新眼识当言是微非眼识知。答曰。当言非眼识知。无有根微妙未知智知。问如彼色新者一切无见。答曰。一一不可见。合集然后可见。如身中垢一一不可见。垢尽然后可见。复次色最鲜明。当言造眼识。不习余色有鲜明。如是不可沮坏。得余四大所造色耶。或作是说。不可得也。此在处处。问如色处所。如瞻卜花香甚香好。云何无处所。或作是说。不可得四大增益。四大因缘依彼四大。复次不可得。四大中间。说可得者。则彼无有造色。彼则有非不有。瞻卜花香瞻服当观。如是此身非以瞻卜花香从彼生少有回转。又世尊言。如火焚烧野泽。当言火烧耶。不烧当言烧耶。或作是说。不烧当言烧。如依造色火生当言烧。或作是说。无有不烧而烧。设烧而烧者则无有烧。此变易义。世俗之数所造。火烧者是谓野泽。复作是说。火无所烧到便烧。若未到无因。若起当言烧。若灭当言烧。或作是说。灭当烧彼有此想。火烧野泽当烧。问彼生则有想火烧火。或作是说。火无所烧。此亦如上所说

  色所知相者　　坚并及多少
  如有一暖色　　色住二相烧

诸所有火尽有所烧耶。说有所烧。尽是火耶。答曰。或是火非有烧。过去未来火在木。钻火在舍。火神祠火也。颇有所烧彼非火耶。答曰。汝为寒耶。烧彼非火耶。如所说炎暑繁炽生老病死。颇有火有烧耶。答曰。依彼所造火现在欲怒痴也。颇有非火非烧耶。答曰。除上尔所事则其义也。以何等故。弊恶四大生微妙色。或作是说。缘所造色。依彼四大便有色生。色缘彼色。香缘彼香。味缘彼味。是故展转增。或作是说。四大增上所生色。复以余事彼则有胜。或作是说。缘四大生色。非一因缘想应彼则有胜。如一弦琴高下随曲声与歌同。如众人有咽喉声各有异字亦复异。复次四大境界各有异。是故四大与色不同。问有一人见色。非与色声香味同。答曰。彼非一色。彼或有好丑。依彼色或依香或依味。亦见多少色声香味。如琉璃云母方盐苦摩利瞻卜花自然。自然者当言减当言增。答曰。当言有增有减。或作是说。不增不减。非有增非有减。复次若观彼事。亦不有增亦不有减。是故不作是说。等生四大展转相触。当言不触耶。或作是说。当言触也。各各集聚。或作是说。当言不触。空无所有。初各各不相触。复次当言触三昧中色。彼有触想根依四大。当言根转有下。当言根转有上。或作是说。当言不高不下亦不移动。或作是说。设当有下有高者。则有移动。或作是说。此则散乱。如车轮转转不常住。义无有处彼亦如是。复次观有住相。于中有高下未知根。是故根力四大。于此间是苦法。色声香味依四大色声香味。当言下当言上耶。或作是说。亦不下亦不上。此皆集聚。设有下有上者。则当有散。复次当言杂裸。如车轮转转不常住。若一色可得者。于彼中间色复有色耶。或作是说。可得若亦无边。亦无有中间。尽无所有。问设彼有中间者。则非第一义有余中间。复次不可得空无所有。最细微色者得声香味。或作是说。得皆为集聚。问今非有细微色耶。彼则为微。或作是说。色最细微。彼色声香味不住独处。设当有者。一一不别。复次更有异刹土想。设当少所有者。一切无吾我。我亦如是。色不去离色习不可称。问若四大若小若大者。彼所有色声香味。当言触彼色耶。或作是说。亦离彼色色则有坏。问四大坏色亦有坏。问云何得知四大坏色坏四大亦坏。问亦见希望坏所依亦坏然希望不坏。复次彼不触。设当触者则为细滑更乐。问如触身根。彼非细滑更乐。答曰。非以触身根有细滑更乐也。彼处以何识知。或作是说。用二识知。眼识意识。复次或不以识知。何以故。彼非识处住色声香味细滑法本所造处。声当言耳根来耶。当言于彼间闻。或作是说。当言来。顺风闻声。逆不大闻。问设顺风来者。逆风何以不闻。或作是说。当言彼间闻。如大市中声甚高远四方皆闻。问回转速疾则无方。有方便憍慢。如旋无枝轮其像如轮。若闻其声周遍四面。如以一滴油着水器中皆悉周遍。答曰。观无枝轮人向不同。非以声速疾得住义也。设当声灭者则少有所摄。当言彼相依来。当言彼不相依来。问如人来者彼则有声也。相依来不是其声。若声从耳根来。当言依相依来。当言不相依来。或作是说。当言相依来。问彼则有是各相依来。不以声故而耳根

  若有少胜者　　不触根一色
  一微依更乐　　依住声相应

香鼻根当言来。为于彼间闻香耶。答曰。当言来香无处所。鼻闻香鼻根来者。当言彼相依来。不相依往。问依痛作诸想。当言相依来。如藏罗萨罗花逆风闻香。当言香近鼻根不近鼻根耶。或作是说。当言不近。设当近者则为细滑更乐。复次当言近也。不以不触彼闻香也。味当言舌根来耶。当言于彼知味。答曰。当言来。非以舌根无处所知味。诸味从舌根来者。彼当言相依来。当言不相依来。答曰。当相依来非不相依知有味。味舌根当言近当言不近。或作是说。当言不近。设当近者则为细滑更乐。复次当言近。非以不近彼有所摄。更乐身根当言来耶。当言于彼住。答曰。当言来。彼不以身根触无处所。诸更乐与身来者。当言相依来。当言不相依来。或作是说。当言相依来。各各相依。复次当言不相依来。彼相依则所造色。可见者其义云何。或作是说。自现故曰可见。或作是说。从眼中得故曰可见。复次可现示人故曰可见。不可见者其义云何。如上义无异。有对法其义云何。或作是说。对住故曰有对。或作是说。选择故曰有对。复次觉知空义故曰有对。法者其义云何。如上义无异。可得余色处所。或作是说。不可得此集聚义。或作是说。不可得色处想着。复次住三世知有处所。如彼处所。是故不余无对。有对造作处所空空处有何差别。或作是说。空无有形可数处。是故空识色空界。或作是说。空不可见色不可见识处可见。或作是说。空无有对。有对是空识。复次不可移动谓虚空。造色本末是空。识相亦微妙。可住无住得无住住。得青无青得无青青。如此四义前已说。以何等故。树若干种荫影不异。或作是说。是树荫因缘。或作是说。缘四大有其荫。复次荫无有义。在在处处冥去无处所。彼彼常住不移处。自作识想

  香味现更乐　　有对住不移
  因缘境界尽　　二情树及影

以何等故。大海水同一碱味。或作是说。昔仙圣咒术使然耳。或作是说。海中众生大小便使然耳。或作是说。彼有大盐山使然耳。或作是说。潮波水激波。犹如此间见水涝为盐。复次彼器自然使水成碱。如此间见器净水净器。不净水如四大相触各各闻声。彼义云何。或作是说。缘四大是其义。实相触其故各各闻声。问此间作声彼间响应声连属。答曰。本行报故。如埏埴器轮。或作是说。前已生响声各各相应。非以中间更有声异。闻初声然后有中间声。欲使彼非声因缘耶。复次彼声展转有其谛故。如盆器声拷便出声展转闻声。如有神通地壁皆过空亦无碍。彼云何知此是地此是空。或作是说。若最有方方便者此是地此是空。如所说入地踊出其犹能浮入出水也。水中常可用力空不用力。或作是说。空无所著不入三昧。亦复自知空去地远地亦是空。复次意性回转名色有胜。有染着处所。如地不可见空亦如是。空无有义。如所说染着众生。空为地想地为空想。欲使彼想获果实耶。或作是说。由想故彼获果实。问彼则自想。坏耶。或作是说。彼不以想故得获果实。彼想颠倒。问空为地想则有坏。地为空想亦作坏。不以想故戒有颠倒。设当以想戒颠倒者。一家同相。然后众生空为地想地为空想。此不相应。齿者当言根相应。当言非根相应。答曰。诸血肉相着。彼根当言着。彼便有痛。若肉血不着齿。彼非根所缚。设彼无有痛。当言无苦不净。当言非根缚。答曰。当言非根缚。不以捐弃不净时有苦痛也。不净当与欲俱起数数畜积。答曰。当言与欲俱起。彼生有长益。空为何相。或作是说。空相不可数。或作是说。容受为空相。复次空无有义。是故彼无有相。观在物言有空耳。又世尊言。无边无际。去此东刹土流转反覆时。世尊亦说。世无限数此不可记。说是语时其义云何。或作是说。此不可记。断灭有常。刹土无有边无有限。现其有多。复次众生境界世尊不然。彼生死方便无有众生边际。如无数集聚有二果。如两石相磨便有火出。或作是说。彼不一集会火因大声因声有声。二事合会成火因缘。或作是说。彼或有集会便有声出。或有火出。是故彼不与相应。复以因缘力便有色色非因缘。当观如是。如心彼或有色习。或声或为相应

  一味两相触　　无想及神通
  齿泽有二相　　无边无有限

微当空当言不空。或作是说。当言不空。设当空者则有往来。以生胜故则有往来。或作是说。当言空。何以故。彼无有坏败。设不空者亦有坏败。或作是说。微妙自然空。初第二处。则当有胜各各有异。若无胜者彼故空。是故究竟不坏败。彼自觉知时。彼三昧坏。是故彼不自觉初时则坏。是故当言虚空。复次当言空何以故。相应无有空。设此微妙当住者。彼非相应住。是故住相应。初时则住胜。若不住中间相应者则不空。设中间相住。相应亦不空相应亦空。是故当言相应空。微妙者当言有方当言无方。如所说彼集微妙方便成就。如所说当亦有方当言亦无方。设微妙者集无有限量。于彼有减。复次无有方不有无方。空无所有不可具说。若于此若于彼。以何等故。内六入三入谓之死。或作是说。此缘无记。或作是说。此是死根。复次此还境界还有死想。与一色声香味细滑。彼当言一因。当言无数因。或作是说。当言一因一相应生。问云何果不坏有相应果。相自然坏得无果报。问不以自然得果报。证我相应便有果报。是故相应不坏。答曰。虽相应无记。是故相应无因相应作因。彼亦复无也。或作是说。当言一因为四大因。问云何四大不坏有坏果报。答曰。事相应故。或作是说。当言无数因。色为色因。香为香因。味为味因。复次当言无所因。相应坏则果坏。是色相应异香亦异。问有众多相应。一微妙耶。答曰。一微妙众多色声香味之数有。其微妙想得六大胜。知色所由各有上中下。或作是说。得如薪出火如牛屎火。观事增减自相亦有增减。答曰。上中下各有胜。或作是说。火亦增火。若钻火时若见日光出光皆是因缘果有坏败。可得火自相。或无自相。或作是说。不可得也。何以故。非以热知热上中下。彼各有宜声。当言空当言不空。或作是说。当言不空。设声空者声无所摄。不以事故。心持心俱有坏。亦见声自作。是故彼不究竟。彼心不生。问以本故心声出响应。若二俱事者此理不然。是故此无苦。或作是说。当言空。设声有住处者。彼则当久住。何以故。声无有坏此非妙。是故声空。或作是说。当言空。设声有住处者。则当数数闻。若不数数闻者。是故当言空。或作是说。若声自然空者。初第二第三处。则有胜无有异。复次声当言空。设声有住处者。中间相应亦当住。此亦如上所说。声当言有方。寻声当言无方。或作是说。当言有方。寻声知有人。亦知一切东方有声。非余方声。问不取彼声。或有须声处所。彼则有声。如言头有痛不知所在。痛所生处彼亦当见。如是声有处所。彼声亦当现。复次不当言有方。声等俱生不当言无方。俱当观声。若此若彼方。当言成就。当言不成就。或作是说。当言成就。如日初出光从东方。所没处从西方。问若阎浮利日出。郁单越日没。若阎浮利日没。郁单越出。是故不成就。问一切四方中央有须弥山。是郁单越成就。问此亦不同。须弥山在一边。一北一南。东西方亦如是。北方从北方。或东或南。是故郁单越不得成就。复次当言不成就。何以故。此非义以生思惟观便有智慧。彼亦不住性成就。色或无也。或作是说。当有过去亦尔未来现在亦尔。问此因缘无辩何事。答曰。因缘有碍。复次观彼住。物等行其业空无所有。亦不造新。能说等业。以何等故。暖水之时先从上热非下热。或作是说。枪粗更缘先热。冷气下流。复次先从下热。反由火炎多少炎先至上。冷气下住

  二微妙入　　水大诸根　　二声东方
  水热在后

颇有一色不前不后四方尽现耶。或作是说。无也。一色微妙彼不可见。方不成就。是故无也。复次作四角想掷鞠空中。此鞠或堕东边。或堕西边。或堕南边。或堕北边。以何等故。彼烧丸铁既软且轻。或作是说。是火木荕力亦用风力。彼风力轻。水力使软。火力使净。或作是说。不独彼铁余有轻者相则自坏。彼性自尔必熟不疑。复次自然观。轻重自然。于其中间或时观轻或时观重。彼则软细地种等。生彼鲜明者。由地种生。当言与火相应。应如四大所造青色四大所造黄色耶。或作是说。青色微妙。或作黄色。非青色如青黄石。复次余四大所造青色。余四大所造黄色。或依微妙或依黄。非以一色微妙相依。如是青赤。如是青白。如是黄赤。如是黄白。如是赤白是谓六。问如四大所造酢味。彼四大所造碱味也。或作是说。或四大所造酢味。则四大所造碱味。亦见其义酢碱。复次余四大所造酢味。余四大所造碱味。或有微妙依酢或依碱味。如是碱苦。如是酢辛。如是酢甜。如是酢秽。如是盐苦。如是盐辛。如是盐甜。如是盐秽。如是辛苦。如是辛甜。如是辛秽。如是甜苦。如义所说。颇地种因水种耶。或作是说。无也。无有四大。复因四大各各别异。复次有曾见地种有软时。如刚物融消。颇地种因火种耶。或作是说。有如钻木得火。颇地种因风种耶。答曰。有耶。如扇则有风。颇水种因地种耶。或作是说。无也。如种无有余因此各别异。复次有如刚融消。颇水种因水种耶。答曰。有如水杇故。颇水种因火种耶。答曰。无耶。非以中间有热气。颇水种因风种。答曰。无也。不以中间风生风。颇火种因地种耶。答曰。无不以中间软坚生火也。颇火种因水种耶。答曰。无也。不以中间软坚火生水。颇火种因火种耶。答曰有。亦见火还生火。颇火种因风种耶。答曰。无也。不以中间风坚火生风也。颇风种因地种耶。答曰。无也。非以余种。复因余种此变易法。复次有。亦见虚空中风集云雨。颇风种因水种耶。答曰。无也。不以中间软坚生风也。颇风种因火种耶。答曰。无也。不以中间热坚风生火。颇风种因风种耶。答曰有。亦见虚空中风渐渐速疾。颇泥黎中阴还因泥黎阴耶。答曰。有如从泥黎中死。泥黎中阴现在前生泥黎。中受泥黎形。颇泥黎中阴因畜生阴耶。或作是说无也。非以余趣。复次有如从泥黎中死受畜生阴。如是一切诸趣。一一诸趣各各有五义。一切四大觉别所知。问欲使住有开辟耶。复次说世俗相。众生四大一切有对一切四大依色。或作是说。一切四大依一切色四大所造。或作是说。三大依色一。风不依色。非以依风得色。复次地种水种依色非以中间此四大依火依风而得色也。云何得知。余四大余所造色。答曰。非一切色有牢固。非一切色中间知四大当说如聚揵度中。而无有异

  一切方铁丸　　色味及持阴
  摄彼诸知法　　知有若干想

身几阴几持几入所摄。当随象根。答曰。身根身持身入色阴所摄。四大身四持四入色阴所摄。色身九持九入色阴所摄。痛身法持法入痛阴所摄。想身法持法入想阴所摄。意身法持法入行阴所摄。受身法持法入行阴所摄。名身句身法持法入行阴所摄。象身马身车身辇身。十七持十一入五阴所摄。色阴几阴几持几入一切所摄界。若干种色阴色持。彼色持色入色阴所摄。弃捐色持十四持十入五阴所摄神山处。色阴十八持十二入五阴所摄。如尊者舍利弗说。有炎则有火有火则有炎。然见炎各异处。说是时其义云何。或作是说。此等生语。或作是说。展转无中间故说此义复次欲解缚故。故说此义。如尊者舍利弗说。汝诸贤。如寿如盛暖此法成办。非为不为。不辨色不因色习。说是语时其义云何。或作是说。欲界色界性所造此方便说。或作是说。欲界色界性造展转无碍。亦方便说。复次三界所造展转相依。日当言因日光。当言因四大。或作是说。当言因日光色因有色。或作是说。若覆盖色便生暖气。影者是光因缘。当言无缘色则不生。复次当言因四大。暖气为光净。当言因声。当言因四大。或作是说。声亦因四大亦因自然。或作是说。当言因四大。四大相因便有声出响。应当言因声。当言因四大。或作是说。当言因声。前已生声彼因自然。复次当言因四大。由四大有声。彼于中间生不触。自鸣者当言因声。当言因四大。或作是说。当言因声。当言因四大或作是说。于其中间本声不自鸣。复次当言因四大。四大不自鸣。诸所有圆色者。彼所有色声香味亦圆耶或作是说彼不于中圆。彼有一处圆。问设有圆者色声香味亦当圆。云何彼不圆。答曰。如有白色鞠色。如是彼有一白无色声香味。如是当有圆。彼有一处圆。或作是说。彼一色圆非以色故有色处所。复次观住有对则知有圆。不以住故便有色也。以何等故。色法不谓之中间次第耶。或作是说。色不有坏。复更生余色。是故彼无中间次第。复次以少中间生众多色。众多中间生少色。云何得知性明各各别异。或作是说。所造永尽所生即灭。复次因缘集聚。展转有生微者。即生便住与身缠缚。或作是说当言与身俱缚。如心意回色亦如是。复次微色不可限量。色习者或心意俱生。彼回转时知有心意。性无有色。何以故。识少中间有众多色生。是故色性无也。无所造。是故俱生当言住也。如不见麦一萌牙阴有回转。云何得知。一麦牙缘彼影耶。影亦缘牙。或作是说。自然得知彼自然回转。复次彼身有自然后得知。亦见麦阴。牙生诸茎。亦见麦种因缘生萌牙。于中得知。设本麦因缘。缘生则有所得。有诸萌牙生。设后缘麦等生得者。影亦当回转。于中得知是二因缘麦也

  身界光炎寿　　影响静圆色
  因缘光性缚　　亦不见一麦

尊婆须蜜菩萨所集四大揵度第五竟

    尊婆须蜜菩萨所集契经揵度首

又世尊言。我弟子中第一比丘。居处岩峻游止山泽。名婆那伽婆蹉居处岩峻。其义云何。或作是说。三昧得自在。舍前三昧更入余三昧。复舍此三昧复游余三昧。如是居处岩峻。或作是说。入逆顺三昧。如是居处岩峻。或作是说。入檦褰度三昧。是故居处岩峻复次诸隐处岩峻。于无数中解脱。是故处岩峻。又世尊言。于是比丘有四人。或有人利己不利彼。或有人利彼不利己。或有人利己亦利彼。或有人亦不利己亦不利彼。此有何等别异。答曰。利己不利彼者。自居平等欲使彼不平等。虽依彼有居平等。彼不于中得平等意。利彼不利己者。欲使彼发平等意。自不居平等。虽与彼说法有法想。少有平等不应与彼说。利己利彼者。自处平等。亦教余人使处平等。虽彼不得教者。彼二因缘说平等得。不利己亦不利彼者。自不处平等。亦不教人使处平等。又世尊言。于是比丘有四人。或有人所生结尽不更受余结。或有人不受余结尽非所生结。或有人所生结尽不受余结亦尽。或有人所生亦不尽不受余结亦不尽。说是语其义云何。答曰。所生结尽不受余结者。中般涅槃。不受余结尽非所生结。生无色界中阿那含。所生结尽不受余结尽者。阿罗汉。亦不受所生结尽。亦不受余结尽者。彼是余学人亦是凡夫人

又世尊言。于是比丘有四人。或有人受身痛不受命痛。或有人受命痛不受身痛。或有人亦受身痛亦受命痛。或有人不受身痛亦不受命痛。说是语言其义云何。答曰。受身痛不受命痛者。欲界色界命终无色界阿那含者也。受命痛不受身痛者。无色界命终便般涅槃也。受身痛亦受命痛者。欲界色界命终若阿罗汉也。亦不受身痛亦不受命痛者。除上尔所事则其义也

又世尊言。于是比丘有四人。或有人于现法中行般涅槃及身坏。非不般涅槃也。或有无行般涅槃非行般涅槃。或有行般涅槃无行般涅槃。或有人无行般涅槃。亦无行般涅槃。说是语时其义云何。或作是说。犹如有一人。以众多行。以大方便。以大殷勤。灭五下分结。于此间命终生色界中。众行少少方便少少。殷勤灭上分五结。是谓此人于法中行般涅槃及身坏无行般涅槃。第二于此间少彼多者。第三二俱不大者。第四或作是说。犹如此人缘行依三昧。灭五下分结。于此间终生色无色界。依般涅槃三昧。灭上分五结。是谓此人行般涅槃及身坏无行般涅槃。第二于现法中缘般涅槃身坏缘行。第三第二俱者缘行。第四二俱缘涅槃。或作是说。犹如人于此间为苦灭五下分结。生色无色界中受乐。灭上分五结。是谓此人行般涅槃无行般涅槃者。若人于此间受乐。灭五下分结。生彼受苦灭上分五结。是谓此人无行般涅槃。云何此人现法中行般涅槃及身坏。无行般涅槃。第三二俱苦。第四二俱乐。复次此人愚戆。凡夫人灭下分结。生彼得捷疾智。灭上分结。是谓此人于现法中行般涅槃。第二于此间捷疾智故彼间愚戆。第三二俱愚戆故。第四二俱捷疾。以何等故。阿罗汉成就世间第一法。然非苦法忍。或作是说。不舍苦法忍。得须陀洹果时。然不灭世间第一法。问此亦是我疑。何以故。舍苦法忍。然非世间第一法。答曰。由死处所。世间第一法果果游。灭苦法忍。阿罗汉果果游者。是故世间第一法不灭也

或作是说。禅摄世间第一法。学摄苦法忍。阿罗汉禅成就者非学法。是故世间第一法成就阿罗汉。非苦法忍。问若依禅等越次取证。彼禅摄苦法忍。欲使禅成就苦法忍耶。答曰。学摄禅苦法忍不学亦不不学。禅摄世间第一法。以舍此学。此学禅然非不学亦非不学也。问如所说若禅摄世间第一法者。是故禅成就世间第一法。是事不然。或作是说。得微妙无漏法。或有不成就。非世间第一法。是故不成就苦法忍。问得增上世间第一法。微不成就

复次作默然想。复次诸善根。缘增上中下法。当言成就。若凡夫人五下分结尽。彼当言一处阿那含耶。或作是说。不得作是语。如阿罗汉一切结使尽。阿那含不一处所尽趣处尽。阿罗汉一处尽不。复次若彼贤圣道一处。五下分结尽斯陀含。亦当复说一处阿那含。况当凡夫人。若欲界结使于中间少。有不尽也

又世尊言。人有五恚诽谤诸贤。口出恶言嗔怒无常。作不倩罪人所憎嫉。说是语时其义云何。或作是说。若人与不相得不观行作意。怀犹预诽谤诸贤。是谓此人诽谤愁恼彼人。怀颠倒意丑恶喜诤。除四所犯。诸犯罪业身怀犹预。于中复犯余事。是谓人所憎嫉。或作是说。淫欲偏多嗔怒无常。不避尊卑为人憎嫉。而前欺诈幻惑。谗人无实常习非法。复次彼人以精进意。去欲戢悉欲行头陀。威仪礼节常不失时人所信乐。叹誉彼人不还使还。是谓此人当言犯法。此人不顺戒律。意常亲近。于其中间所得利养。亦叹誉说。常威仪礼节得不喜。亦不修行不知恩养。是谓此人当言不存。设有人增上戒不成就戒。喜斗诤讼诽谤诸贤。是谓此人喜怒无常。若人微妙行行中。分别戒律讽诵禁戒。事事学知。无戒无智慧者。是谓此人常怀犹预。复次有人微妙行中。分别戒律讽诵禁戒。是谓此人人所憎嫉。如忧陀那耶婆嵯罗耶说。云何尊者婆罗堕阇。以何因缘此诸比丘年少端正。出家未久修善功德。于深法中娱乐顺教。诸根柔和颜色晖晖。皮体软细乐静知足。如野鹿象。尽形寿清净修梵行知足。如野鹿象。其义云何。答曰。坐禅讽经而不顺从不着事务。是谓知足。随法乞求亦不染着。是谓如野鹿象

又世尊言。我见调达无有毫厘之善。我不记之。调达入地狱更历劫数不可疗救。所以然者。如调达入骨彻髓三归命佛。当言彼调达此非善法耶。或作是说。此非善法。此亦非归命三尊。嗔恚盛故说此语。设当入地狱者。如所说。若归命佛者。彼不堕恶趣。设当实者。若不向三恶趣。如所说。调达入地狱经历一劫。是故彼调达无有善法。或作是说。调达亦有善法。犹不能拔调达还。是故彼不可疗救。调达有三不倩罪。复次彼有顶法调达。由此方便故曰有善法

又世尊言。我弟子中第一比丘游四空定。名跋陀婆梨。四等力成就名僧迦摩寺。此二人有何差别。或作是说。尊跋陀婆梨得软身护。以自多娱乐。彼以此娱乐先得护堂。尊者僧迦摩寺得增上护。然不多调习。于中先见护力成就。复次尊跋陀婆梨得四禅四等心。恒讽诵习。于中得自在先见护堂。尊者僧迦摩寺游六善来堂。是谓先发意得护力成就。云何知阿罗汉而不复更生。或作是说。以舍诸结使。有诸结使便生。阿罗汉无有结使便不生。亦未曾见无结有生者。于中知阿罗汉不复更生。复次身爱诸垢永尽。故曰阿罗汉。不于中间无明有爱更染着身。以是之故。阿罗汉不复更生中阴之中。当言如所趣。当言往不如所趣。或作是说。当言往如所趣中阴。是山神之处。如世尊言。彼有如是慢。譬如极黑羊毛。亦如冥室无明。复次是中阴之傍。复次当言往如所趣。如死欲至时善恶俱至中阴。亦如是随行善恶。各趣其所中阴。当言住过七日。当言住不过七日。或作是说当言。住过七日。何以故如。随行善恶亦无方便有。过七日者。问如七日中间未得处胎。便当断灭耶。答曰。不断灭故。度中阴形。复次乃至因缘集聚俱住不断。若不得生因缘者。是故久住

  步游四句中　　世俗凡夫人
  王婆利毫厘　　护阿罗汉阴

又世尊言。于是比丘有四人。强记智慧。宣布智慧。顺从顽卤齐一句。说是语时其义云何。或作是说。强记智慧人者。发语便知义如易化者。若比丘如彼法便灭。世尊亦知。宣布智慧说即解。如所说。比丘非汝色非汝。痛想行识非汝。世尊亦说。顺从顽卤人者。以若干行诱进便顺从。云何比丘为色。诸所有色彼尽四大。四大所造广说。顽卤齐一句人者。亦不解义。或作是说。强记智慧人者利根。心心相知。分别智慧人中根。顺从人者软根。顽卤人齐一句者无有根。或作是说。强记智慧人者。宿命求解脱力。宣布智慧人者。宿命求软解脱。顽卤齐一句人。宿命之中不求解脱。复次强记智慧人设便知。如尊者舍利弗质便默然。分布智慧人者。分别晓了然后能知。如尊者弗迦罗婆梨审明义理。顺从人者。随时学增上戒律。随时降伏心意。随时学增上智慧。此之谓也。本性所习渐学戒律。渐受训诲承受奉行。如尊者罗云渐渐至道。顽卤齐一句人者。受句义。亦不解义理。亦不解深法。以何等菩萨本宿命时。不等越次取证。或作是说。以盟誓故。以此誓愿当出世作佛未度当度。未解脱当使解脱。或作是说。菩萨思念观。彼以智慧意常发愿言。度诸众生。或作是说。菩萨逮一切智以自具足。以众生故不等越次取证。复次诸根未熟故。不等越次取证。以何等故。阿那邠堤长者。供养四如来不于彼佛出家学道。或作是说。此盟誓因缘。以愿誓故当供养余如来。或作是说。亲族力势不能去恩爱意。或作是说。彼长者意常乐寂静。好施钝根。以寂静故。不趣恶趣之功德处处获大报。钝根者不见。家累之慈。以是故不出家作沙门。复次彼长者淫意偏多。常乐婇女之间作方便。一切诸佛如所造事得贤圣道。以何等故。不成男不应法义。或作是说。诸情阙少。是故不应法义。或作是说。心驰万端不得三昧。是故不应法义。或作是说。障诸报实宿所作缘。得受此形不依智慧。复次遂障结使彼结所盖。不得休止心无惭愧。又世尊言。作偷婆有三事。多萨阿竭阿罗诃三耶三佛。比丘漏尽者。转轮圣王。以何等故。学辟支佛不入此三事。或作是说。是如来劝教语。说佛则说辟支佛。说比丘漏尽者则说学。彼或有漏尽者。复次彼亦是数。以此众生故现其深义。此劝教语如上所说

又世尊言。于是比丘有六阿罗汉。退法阿罗汉。念法护法住法分别法无疑法。此有何差别。或作是说。种种无学根。上上中上下中中上中下下上下中于彼下下中成就。谓退法阿罗汉也。下上成就者。谓念法阿罗汉也。中下成就者。谓护法阿罗汉也。中中成就者。谓住劫阿罗汉也。中上成就者。谓分别法阿罗汉也。三上成就者。谓无疑阿罗汉也。彼声闻增上下成就。辟支佛者上中成就。多萨阿竭上上成就。或作是说。犹如一人方便造业。有不殷勤者。亦有钝根。彼以方便业不殷勤。钝根求等心解脱受证。彼复以方便不殷勤。钝根于等心解脱便退转。是谓退法阿罗汉。犹如一人方便求甚殷勤。钝根彼以方便甚殷勤。钝根得等心解脱受证。彼以方便殷勤。钝根护等心解脱。是谓护法阿罗汉也。犹如一人常方便求甚殷勤。然钝根彼以常方便求甚殷勤。然钝根得等心解脱证。彼以常方便求甚殷勤。然钝根等心解脱。亦不增亦不减。是谓住劫阿罗汉也。犹如一人常方便求甚殷勤。然利根彼以常方便求甚殷勤。然根利得等心解脱证。彼以常方便求甚殷勤。然利根方便得无疑。是谓分别法阿罗汉也。犹如一人常方便求甚殷勤。然利根彼以常方便求甚殷勤。然利根得无疑等心解脱证。是谓无疑法阿罗汉也。复次若人恃怙他力。寻生得等心解脱证。是故等心解脱。犹如羸病人寻起无持扶人便还卧床。是谓退法阿罗汉也。若复有人等心解脱不牢固。但恐失意欲求死以刀自害。是谓念法阿罗汉也。若复有人等心解脱。护等心解脱。我能护此尽形寿守持。随时育养。是谓护法阿罗汉也。若复有人等心解脱。超越钝根住中根。是故等心解脱不退转。亦不增不死。是谓住劫阿罗汉也。若复有人等心解脱。初始有益得诸根。彼恃怙外。力得无疑。是谓分别法阿罗汉也。若复有人自以己力初始得增上根。住等解脱自知时节。是谓无疑法阿罗汉也

又世尊言。阿难鞞舍离甚乐无极。跋阇复弥亦甚快乐。遮波罗寺亦甚快乐。瞿昙弥那拘驴亦甚快乐。阎浮利有若干种快乐。无比人民茂盛。以何等故世尊作是说。或作是说。正坐入定使诸比丘生乐希望。或作是说。鞞舍离城甚乐无极。谷食丰贱乞求易得。跋阇复弥甚乐无极。人民和顺不遭苦厄。遮波罗寺(转法轮处)瞿昙弥尼拘陀。种种座具少事寂静。阎浮利地有若干种园果。种种人民茂盛智慧业明。复次世尊亦复现去诸缚着。灭若干彼无欲永息

  初发意菩萨　　出家不成男
  三塔六罗汉　　鞞舍离在后

又世尊言。游鞞舍离从今以后。不复更见鞞舍离更无三佛来鞞舍离。何以故。尊作是说。或作是说。更不复受胎。复次等智灭彼死迹。欲鞞舍离城乐法众生报诸狐疑。是谓彼时。以何等世尊请摩诃迦叶与半座坐。或作是说。时诸比丘轻易迦叶起染污心。不知迦叶入大法要。以是故世尊与半座坐。欲使比丘心开意解。惧获不善报。或作是说。彼尊者有种种功德。世尊先所化。恐诸比丘犯禁戒罪。或作是说。第一尊重尊者阿那律。世尊往视依衣。更请摩诃迦叶与半座。或作是说。世尊欲付授戒律。后来众生信受其言。复次未曾有与弟子半座者。复次世尊欲布现大德。又世尊言。诸比丘等。若沙门婆罗门昼有夜想。夜有昼想。彼心意颠倒。比丘如我昼有昼想。夜有夜想。于我心无有颠倒。说是语时其义云何。或作是说。彼起天眼除外想修向明想。观昼如观夜无异。彼或无异。彼或时昼有夜想。夜有昼想。然世尊不尔。或作是说。彼沙门婆罗门。于眠寐中夜有昼想。昼有夜想。是彼颠倒。复次闲居右胁倚卧。观如是色入禅中。然世尊若行若坐常如一定

又世尊言。于是比丘有三如来。于是比丘于现法中实有无疑。自得智慧亦教他人入智慧。云何自得智慧。或作是说。彼不可得虚无有实。况当得实。复次是世尊劝教语也。作是语。我觉此。或作是说。若彼着色心所念法。自誉戒盗自凭仰作。以实为虚。世尊观彼见盗。复次是彼邪见。五阴之中是我所实住。佛所语亦如是。不有余阴言我所以何等故。以外道尽欲爱等越次取证。相应不退转法此之谓也。或作是说。彼以二道灭诸结使。或以世俗道。或以无漏道断诸结使。或作是说。若依禅等越次取证。彼观禅便有道生。彼不见谛所断。是故不退转。复次彼等越次取证时。修行忍智得等方便力势寻益。若力势无益者。不于力势中退转。是故不退转

又世尊言。四双八辈几果成就几无果成就。或作是说。五果成就。须陀洹斯陀含阿那含趣阿罗汉及阿罗汉。一非果成就。趣须陀洹果证。二人或果成就。或果不成就。趣斯陀含果证。趣阿那含果证。彼趣斯陀含果证者。方便欲爱未尽等越次取证。当言非果成就。有得须陀洹果。求趣斯陀含证。当言彼果成就也。以无为须陀洹果。趣阿那含果证。彼欲爱尽等越次取证。当言非果成就。彼复得斯陀含果。求趣阿那含果。当言彼果成就。无为斯陀含果彼果有为。当言诸根坏败。是谓知有八人

又世尊言。四沙门无有五。说是语时其义云何。答曰。道智为如来自得证果。无著说道清净说法而转法轮。彼故敷演道命。为学诸智慧。断诸疑网诽谤道者。无究竟行。无戒律威仪犯诸戒。为沙门服皆悉觉知。彼第二沙门当言摄辟支佛。第三沙门当言摄凡夫人。第四沙门当言摄外道。异一切假沙门被服。计吾我着命计众生。彼一切于道退转

又世尊言。无染着谓戒

  无染着袈裟　　袈裟被服始
  意已得所欲　　袈裟非无著

说是语其义云何。答曰。有三种。浊身口意秽浊。彼若思惟校计。是谓无秽。袈裟服虚称诈逸。非神仙所学。彼非其宜。此谓之忍。亦非移动。如实而对意常审谛。彼若不得忍。被骂便报骂。被打便报打。此非沙门法。况当作如此行。是故不应袈裟。故彼袈裟无著。又世尊言。若已生刈断更不种。说是语时其义云何。答识对生受。于四禅止处生行垢因缘。所造之义便有断绝。来无有对亦不受生。四禅止住处亦复不生。选择取要。设与四神止处因本行缘。彼亦不受。已除弃爱已尽受。第二人驰走。当言此无学亦无威仪。亦不观于无上智慧涅槃灭尽。得仙人法是谓大仙人

  初迦叶睡眠　　最胜无有欲
  已说四袈裟　　断灭不复生

又世尊言

  习智至无智　　降伏作牢固
  有漏尽无余　　是谓为梵志

说是语其义云何。尊者大迦叶契经是说也。自持法比丘习智智者。学虽诸梵行人住彼业者获法养生之具。彼亦是法戒律之义。故曰。智者知不于中间住已修行心得观觉照住二解脱。彼已思惟无明爱尽。欲说眼根此沙门法。故曰有漏尽无欲。故曰为梵志者。世尊即是大梵志。心垢已尽

又世尊言

  比丘无有欲　　有欲见大惧
  于欲不退转　　是谓为涅槃

说是语其义云何。答曰。智慧相应寂静。以自娱乐无有忧戚。是谓比丘无有欲。无事清净静事。为苦恼有欲。彼见法者乃能觉知。是谓有欲。见大惧于欲不退转。捐弃诸垢善渐渐益等相应。是谓三昧。一切结使尽觉贤圣道。是谓涅槃。以何等故。入慈三昧不可伤害。或作是说。诸天卫侍而护其身。或作是说。彼三昧者闲静无事。害不加身身不有坏。复次受色界四大身

又世尊言

  麑鹿归野　　鸟归虚空　　法归分别
  罗汉归灭

分别人者何者是。答曰。学谓之分。能分别色痛想行识贤圣之道。皆悉分别

又世尊言

  无想有思想　　思想不有想
  如是变易色　　缘想有其数

变易色人何者是。或作是说。生无色界阿那含。当言变易色想。彼则色想变易。复次阿罗汉。于中亦变易想。阿罗汉不于五阴有所变易。修行究竟。以何等故。世尊谓调达食唾子。或作是说。尔时调达方便欲坏众僧。以是之故。世尊呵之。恐诸比丘意有移动。或作是说。淳恶之人以染和诲之。数数住求欲坏圣躬。尔时世尊逆其意利语诲。或作是说。若于佛得供养具。调达欲使入已。故曰食唾子。复次调达本有大神足。化作小儿形。金缕带腰住阿阇世太子抱上。宛转戏笑。彼时阿阇世太子抱弄呜口与唾使吮。彼时调达亦复食唾。太子亦复知此尊调达。尔时世尊以沙门息心意。呵曰。食唾子也。云何调达先善根断坏众。坏众僧仁后善根断。或作是说。调达本善根断后坏众僧。亦告人民善恶无果报。以是誓故。发意坏众僧。问非以今坏众僧有非法想或作是说。调达先坏众僧。后善根断。非以善根断坏众僧。有劫数偿罪。设当彼告语者。善恶无果报。不以坏有非法相也。问若坏众僧非已善根。欲使向恶趣耶。世尊亦说。我不见调达毫厘之善。契经句广说。复次调达从坏僧以来。齐是以来善根本断。如彼告语。我坏瞿昙沙门。众僧。断转法轮。便欢喜踊跃。彼当言善根本断。从是以来作众恶事无变悔心。是故坏众僧善根本寻断。云何善根本断得善根本。或作是说。设生泥梨中者。知受泥梨苦痛。我作是罪今受此报。此当言得善根本或作是说。如此受泥梨中阴。便有观心有是果实。当言得善根本。复次于现法中或有得者。于彼有善知识者。便起悔心。渐渐教至道。鹿[跳-兆+專]肠者其义云何。渐渐佣髀故曰鹿[跳-兆+專]肠。七合满盈其义云何。肉脉平正钩锁骨。七处满足平住色不变移。是谓七合满盈。师子臆其义云何。身无高下不前却。是谓师子臆。味味知者其义云何。轻软微妙皆悉能知。是为味味晓了

  不养贤恐惧　　慈及诸所趣
  无想有想唾　　曩昔云何相

以何等故。鸟畜生昔日皆能语。今不能语。或作是说。尔时从人中终生畜生中。以前所习故能语也。问如今从人中终生畜生者。亦复能语。或作是说。所可食啖与人无异。如今无有此食四大改异。以是之故不能语也。问如今与微妙食使啖者。能语不乎。或作是语。昔日时人无斗诤讼无杀害心。尔时畜生见人亦不恐惧。与共止住闻其音响。故能知语。问如今生畜生人无有恐惧。复能语耶。或作是说。今亦能语。但不可解。若得音响辩才便能解语。如夷狄语语不可解。若俱解二语者彼则能知。问昔时之人得音响辩才。便能知乎。复次不见畜生知文字者。或闻欲音响者。鹦鹉鸳鸯此便可解。然世尊喻无有差违。智者所说欲使人解。是事不然精进者云何自知不堕恶趣。或作是说。知无解者不堕恶趣。我无此犯戒意。是故不堕恶趣。或作是说。得功德力。如寤寐中善意不变。彼便作是念。我命终时有不善报不堕恶趣。或作是说。不诚之思堕恶趣中。亦不生恶念。彼有炽盛众生。我不堕恶趣。或作是说。彼无有此方便能自觉了。世尊亦说。如是精进者觉知。亦自知所趣。我生彼间。如我亦知精进所趣。以刀自害若饮毒药。问精进虽知故不如佛究竟。复次若有教戒者。不恃怙戒。我不生恶趣。亦不得第四禅。心发涅槃想有趣三恶道也。远离七处。亦作是说。大行分别契经。以心秽浊众生趣恶道。世尊亦说。如寿百岁奉具足戒。然戒羸不舍能拔恶趣邪。欲使六师逼迫众。将拘利人入恶道中。此之谓之恶。彼得第一精进。彼亦好信世尊者。有恶趣法智慧自在也。诸邪定者彼一切成就邪见耶。设成就邪见者。彼一切成就邪定耶。或作是说。诸定邪见者。彼一切成就邪见。设成就邪见。彼一切成就邪定。五逆为邪见成就邪定。或作是说。诸成就邪见者。彼一切成就邪定。颇成就邪定非成就邪见也。断善根本不成就五逆。复次诸定邪见者。彼一切成就邪见也。颇成就邪见彼非邪定耶。想心成就邪见。诸定等见者彼一切成就等见耶。设成就等见。彼一切定等见耶。或作是说。诸定等见彼一切成就等见也。设成就等见彼一切定等见。贤圣之道是等见。彼定成就等见。复次诸定等见者。彼一切成就等见也。颇成就等见非定等见耶。等心想心一切成就等见。诸上流者彼一切阿迦尼吒。设阿迦尼吒处。彼一切是上流耶。答曰。或有上流。非阿迦尼吒处。或有阿迦尼吒处非上流也。或有上流及阿迦尼吒。或非上流非阿迦尼吒处。云何上流非阿迦尼吒处。若阿那含生色界中。然忆上事不定阿迦尼吒也。若欲界中生若阿那含。生无色界然忆上事。若欲界所生。是谓上流非阿迦尼吒处。最初阿迦尼吒处。是谓阿迦尼吒非上流。若阿那含生色界中。然忆上事定在阿迦尼吒。是谓上流及阿迦尼吒。云何非上流非阿迦尼吒

答曰。除上尔所事则其义。以何等故。阿那含阿罗汉住劫不移动。或作是说。住劫者不为世所回转也。复次得等解脱。柔软下根超越住上。是故等解脱亦不增亦不减。故曰。住不移动。然阿那含当言住已得誓愿。凡夫人者当言善心命终。当言不善心命终。当言无记心命终。或作是说。当言不善心念。非以善心有所住处。问如世尊言。临欲终时得善心。所念已还等见。是谓契经有相违。或作是说。若生恶趣中者。彼不善心命终也。若生天上者。彼善心命终。如最后心。住受生亦复如是。或作是说。当言无记心命终也。以无记心自住身中有报数望终。复次若不修善。不修善法。不住后心亦不灭。是故当言无记心命终。若作是说。必死无疑。是时当言命终有所避处。以何等故。阿罗汉不得最后善心。或作是说。自住心受报望终。然尔时无善。是故不得善。复次若修善终时亦不住。复次彼心无记本行休息。又世尊言。与共止住然后得知。或有不知颜色和悦。其义云何。答曰。若闻彼毁誉轻举。信用乐受他语。虽颜色悦。弹指顷信乐忍受。有威仪礼节身乐静寂得欢喜。外如不密内怀诈伪。若复说法之时。无义辩才无法辩才。如是不如至实。是谓愚痴。又二等信等戒等闻等智慧等施。现在前时何者最是大果。二俱清净。一俱清净。或作是说。二分别俱清净。世尊亦说。于彼比丘布施之家。二分俱清净。是谓檀越亲。第一之德。问云何两意。或作是大果。或非大果。答曰。田业良如良谷子。犹田业良彼谷子好。问犹田犹谷子。然不随时。是故难可齐。或作是说。二分俱清净。已得清净。作如是施。心所有因缘得诸报实。问若施胜者则施无有等。当说等施。复次量二果平等思念所行。是故彼施二俱清净。有诸果实。问如向者世尊言。于彼比丘二分俱清净。檀嚫者第一之施。如是则差违。答曰。多二分俱清净。意所念行亦清净。心意平等果亦平等。云何杀害之虫有净法生。或作是说。邦国时俗使亲友明党意所思惟。复次如水波动。世俗等者。彼有净行者。或以行报故便有。止净行者。堕杀害中于彼生。中间行报因缘便受其殃。亲近善知识而听受法。思恶露不净。如是杀害之人也。云何清净之人而生黑法。或作是说。邻国时俗使尔亲友朋党意所思惟。复次如水波动。彼不善等者。清净行者。或以行报闭塞不善行已。得净彼生中间便受行报。彼亲近不善知识。听不善法。亦不思惟恶露之行。如是清净便生黑法。

又世尊言。二法成就。若不有善自不精进。若他精进牢固不移。云何他精进牢固不移。或作是说。以五法内自省察。教他精进牢固不移。若一切违与共相应者。则有坏败。复次学他非法不应法而犯。未曾有如义法不尔。以何等故。世尊言声闻第一耶。或作是说。现微妙法。或作是说。现声闻威仪。或作是说。拥护法故。或作是说。为诸比丘发勇猛意等行具足。复次以二因缘故。世尊言声闻第一弟子。现授决义故。于彼解脱现变化故

  畜生语精进　　上流住不移
  凡夫人止住　　施之所供养
  黑白无戒人　　此弟子第一

尊婆须蜜菩萨所集契经揵度第六竟

尊婆须蜜论卷第五尊婆须蜜菩萨所集论卷第六

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    更乐揵度首

又世尊言有二乐。出家者所不应学。若于欲中染着乐。现世无事乐。云何于欲中而染着欲乐。云何现在无事乐。或作是说。忆过去欲所生乐者。是谓于欲中染着欲者乐。忆现在欲诸所生乐。是谓现在无事乐。或作是说。结使欲相诸所生乐。是谓欲中染着欲乐。欲相诸所生乐。是谓现在无事乐。或作是说。贪欲相诸所生乐。是谓于欲中染着欲乐。意喜想欲便睡眠乐得利养乐。是谓现在欲乐。复次习着向欲。已得先足身意所生乐。是谓于欲中染着欲乐。已得等意诸所生乐由身意兴。是谓现在无事乐也。又尊者舍利弗言。诸贤。此十二行法集聚。得贤圣法。说是语时其义云何。答曰。处处止住造处住。住智慧处住应适处。是谓己身威仪。若偏授决则着一事。分别义理则演分别。问疑论者则演其疑。安处论者则论其安。是谓彼身威仪。或有观见。无奸诈无幻惑。性质朴是谓己威仪。分别根义是他威仪。已得人身生中国。得贤圣体。眼耳根意根。诸清净现其实事。秽行诸使意不染着。以智顺从无有过失。得十力尊。佛出世得三喜入本无。如来乐深妙法。如来弟子善成就者。缘彼意无有谬乱。得贤圣法广分布。智慧所摄说微妙法无有狐疑。奉持讽诵初不远离。诸法注者。展转流布。于等法中以法食施于彼。以因缘故。以己威仪施彼人。作诸梵行。四无空处现有长益。得贤圣人。生彼善处。现五无空处。皆使远离。诸根具足现六无空处。皆使远离。所未曾行现七无空处。皆使远离。六住处现八无处。皆使远离。复次以人贤圣诸入因缘生者。现仁良义他威仪。佛兴出世说微妙法。以因缘故。故丈夫力已威仪者诸入欢喜。现回转说诸法已住。便求演说。诸根具足现曩昔所作功德

又尊者大遍者延说

  信欢喜念者　　不遍佛境界
  最胜所至处　　意常连属喜

说是语。其义云何。答曰。智慧成就信坚固。喜乐佛法志性不乱。受持智法意常专精。如是诸法无有差违。顺从法教于中入定。故曰信欢喜念。瞿昙翼从初无空缺。所至到处意常连属还微妙义。莫作是观此非妙法

又世尊言。信为第一财。说是语时其义云何。答曰。智者所用故曰信为第一财。钱财之业。贤圣财非贤圣财已得不失心。便作是念。彼非贤圣财。摩尼宝器自然成物。及余杂宝错厕其间。复有异宝。车磲码瑙为人所贪。常当拥护。亦无厌足不可藏匿。贤圣财者。各有七相。如信财乃至智慧财。于此间各自娱乐心踊跃喜。然不殷勤自住平等。贪着他财心不坚固。所欲便造不守智慧。除贪爱欲智慧充足。以智胜彼。复次非贤圣财者。邪志业相应。然贤圣财等志业相应。故曰信财第一。复次信名者。信着外财。意无有乱。成就家法善知止足。善有田业善意娱乐。犹如此间沙门法出要为乐。乐静处休息乐道场处乐。故曰择法善为乐。先服甘露言无有虚语。甚吉祥功德成就。故曰味味吉祥。缘此因缘知智慧为明。无有愚意不与颠倒相应。故曰最为明

又世尊言。如阿难比丘。于六更乐无余已离。皆使灭尽。亦无有身诸所生苦乐而受其报。亦无心亦无形体亦无诸入。亦无作所生苦乐而受其报。亦无空缺处。此是苦际。说是语时其义云何。答曰。此六更乐内六更乐永尽无余。舍诸欲着更不复习。欲尽爱使永除。灭尽见结不起。复作是说。无欲思惟恶露诸欲已尽修行止观。复作是说。无欲得无愿解脱门。尽成就空解脱门。彼无有身亦无有至智。亦无语亦无彼心。亦无智亦无彼体。及外诸入未尽者则无。有诸入亦无内入。及余未尽者亦复无也。亦无所依亦不永尽。复作是说。彼无有身除去结使。如是一切彼无有身身之相貌。如是一切彼无有身。亦无身行口行。亦无心意行。亦无彼体。境界行报亦不回转。彼诸入亦无邪见。内诸入便具足。依彼诤讼。无有苦乐之报。尊昙摩多罗作是说。六更乐相应之时。则六细滑入也。于彼细滑则有累。彼无有余全具无欲。爱着未尽。于彼性相应便观苦根本。如是无余亦无有欲。如是相应去离爱着。便住无欲。如彼苦相应性。住无我想示现智慧。如是无余尽修行灭尽。如是修行已。去离愚痴住黠慧中。无明无欲便起有明想。故曰住无余灭尽。彼无有身亦不得四大身。如处所缚己心无有苦乐。无有恶流转生死。四神止处。入生入诤讼者。或着己或不着己。如其处所。四神止处意回转开避处此尽炽然。又世尊言。眼悕望意欲见色。诸不善色眼不乐。云何眼悕望意欲见色不善色眼不乐。或作是说。悕望由眼门。爱嗔恚现其所由。复次云何眼悕望非境界所摄。复次心相应便有所照生便有益。如尊者舍利弗说。诸所有色见是我所等自观知已。远离分别肢节。云何知色止住不移动。已舍离观肢节想。答曰。如是便有更乐集聚。彼则还境界。或有是或非彼。如长抓梵志作是语。瞿昙一切我不忍。如是经句。说是语时其义云何。或作是说。见尊者舍利弗出家便起是念。我一切不忍。彼二人者。皆出家一切如我所愿。故语世尊。如是见不忍耶。复作是说。一切观皆有疑

尔时世尊便作语。汝疑复有疑耶。复作是语。现一切非观一切非

尔时世尊复作是语。此复是汝非见

又世尊言。闲居乐静意常娱乐。亲近思惟观净乐。思惟与思惟相应。闲居乐静思惟乐静。此有何差别。或作是说。闲居乐静以休息意。思惟乐静已得止观。或作是说。闲居乐静者。现涅槃休息。思惟乐静者。现道出要。或作是说。闲居乐静者。现初第二意断。思惟乐静者。第三第四意断。复次有二想。诸结使断。拔诸染着。娱乐彼初不远离。是谓闲居乐静。当观有三思惟。善法住处所。谓相应住。有所益止观相应。故曰娱乐。是为思惟乐静

又世尊言。于是比丘当身身相观。莫起身想。亦莫作观想。说是语时其义云何。或作是说。观身不净莫味着。身亦莫起净想。或作是说。身无常空无我。当作是观。莫起身常想乐想是我想。当作是观。复作是说。思惟身身观。莫计身出由。复次净除行地观辩大事。挍计恶露方便思惟。悉了知已尽不生。智慧眼所照分别悉了

又世尊言。有四法句。不可俎法句。不乱法句。等念法句。等定法句。句义为何等。或作是说。诸法句断故曰法句。不可坏善根无嗔恚善根。等念等定无痴善根。或作是说。修行诸法故曰法句。不起贪欲贪欲尽无。无嗔恚恚尽。等念睡眠等念。等定调戏疑尽。复次沙门法句不可俎坏。无嗔恚戒。等念求定威仪。等定求智慧威仪。如昙摩提比丘尼说乐痛是苦痛分。分者其义云何。答曰。有对则有分。于彼乐痛便有苦痛自然之对。苦痛有乐痛分自然之分。苦乐痛有不苦不乐痛之分。除去不苦不乐痛。有无明分。明相应无明是明分。展转相尽。因明是行分。行垢是无明分断灭。作如是行是涅槃分。无余涅槃界。灭一切诸行已。作是涅槃无分

尔时世尊叹誉谓甚戒梵行。又世尊言。尊者魔楼子说。是命是身见谛是我所修梵行。云何身异命异耶。于是比丘见谛是我所不修梵行。说是语时其义云何。答曰。虽记别一见。不记别余见。尊昙摩多罗作是说。如是是命是身。于是比丘见谛不修梵行。知见之所趣彼所依处。见便往照不依处所。二俱有累。最胜如是说

  有十二聚事　　有身有我见
  一切忍思惟　　法句比丘命

又世尊言。云何汝摩罗大子。有异梵志年少端政。当作如是行。说是语时其义云何。或作是说。尊者摩罗大子志乐十想而作是说。亦世尊欲拔诸结使。复作是说。如是彼人欲使贪欲结使灭尽。尊作是说。如契经句语然。与异学梵志论结使集聚由思想得。汝端政摩罗大子。甚幼少而卧抱辱。未有色欲。况当有贪欲系着心意。结使者贪欲爱使。云何世尊观犯诸过罪。如贪欲使知有力劣受教戒所摄持。若彼有力语无有违。若贪下中者不化。则无有五上分结。如是当察此事此无有异。是故世尊知

又世尊言。于是跋陀婆梨比丘有具足行。彼戒不具足。闲居静处岩峻坐禅。以此闲居静处岩峻坐禅。世尊作是诲。天亦复诲。智者梵行亦复训诲。亦自训诲。训诲之义为何等。或作是说。被责之人是最胜教戒语。亦训诲天。亦训诲智者梵行。亦自训诲。或作是说。当言责数。世尊亦责数此非我弟子诸天亦责数此沙门非释子。智者梵行亦责数此非平等之法。复自责诲。我非沙门。复次如是叹誉世尊平等教戒故。如是世尊义责数。如世尊说。成就五法闲居静处岩峻坐禅。以朽弊衣而知止足。以饭食病瘦医药之具。知足作欲爱想。尔时世尊以义责诲天亦训诲。如所说世间增上智及梵行者亦复训诲。如所说世间增上法增上我增上

又世尊言。是谓苦。是谓苦习。是谓一观。是谓苦尽。是谓苦尽出要。是谓第二观。说是语时其义云何。或作是说。是谓苦。是谓苦习观因缘果实。是谓苦尽。是谓苦尽出要观因缘果实。或作是说。一观结使第二观净。复作是说。一观本所造。第二观己过。复作是说一观。苦第二观无苦。复次一观有漏。第二观无漏。如摩竭檀提梵志作是说。我见色好。汝簸罗堕逝。我见瞿昙沙门坐辱色坏者其义云何。或作是说。诸根谓坏。彼以无生法眼者。尊作是说。诸根眼亦是异。异学书籍。彼以此回转于泥游行不见染污

又世尊言。观其力势亦观训诲。无力势无训诲。当为说法。云何有力势有训诲。非为说法。或作是说。以人根故。善行之名。说不善行之时。亦叹誉训诲。若于彼人叹誉善行。去不善行说平等法。问又世尊为人说。叹誉善行去不善行。欲使世尊叹誉教戒耶。答曰。世尊亦知此戒律。世尊不作是言。彼有教戒。或作是说。无有功德力势教戒功德。有教戒各叹誉其名。若不叹誉其名。实无有疑随时说法。复次亦无巧便。虽指授亦不教戒。若有方便。于彼躇步而教诲之。不观方便而观不方便。欲使彼当言说法分别。随时作观至使得望

又世尊言。以女人八事系缚男子。歌舞谈笑颜色细滑姿态。恩爱义者为何等。或作是说。身体疮痍是恩爱义。复作是语。身体疮痍身体平政是恩爱。或作是说。诸根疮根相根义是恩爱义。尊作是说。爱女人相是恩爱义。又世尊言。汝复波伽(梵志也)。如来有四说法。彼有无量功德无量法句。无量法句味广说。说是语时其义云何。或作是说。此是不善。是谓第二意断。彼复灭不善。是谓初意断是谓善。此谓第三意断。彼复思惟此谓四意断。彼有无量功德。文字无量谓之法句。文字次第是谓法句味。或作是说。是谓不善。苦谛所断。是谓习谛。善思惟尽谛。是谓道谛。彼有无有量功德。是谓法句。名身味为味身。复次如来说法有尽。应一切说法。由二迹平等身习出要迹。得平等身尽出要迹。彼无颠倒。无有忍无有善。有是颠倒有退转。忍善之中有无量功德。所以作是说。谓法句语法句味灭身字。如优婆梨长者说。如来世尊于彼愚痴异学不善之中。说是语时其义云何。或作是说。不可使无信人火能烧也。复次彼无信者。现无有义。或作是说。现彼无信者尽。复次或于彼时尼揵荼(优波离字)无信于此法中现其有信。如尊者阿难说。尊者舍利弗已般涅槃。我今世尊精神闭塞。不知四方。亦不思惟法。说是语时其义云何。答曰。身无所觉现身行恶。不识四方者。现心无行。不思惟法者。现不讽诵。复作是语。身无所觉者。现身说重。不识四方者。现心有愚。不思惟法者。现不说法。复作是语。身无所觉者。现身无行。不识四方者。现心有乱。不思惟法者。亦不闻往古。又世尊言

  识法如幻　　最胜故说

说是语时其义云何。答曰。色是我所。彼若聚沫因缘合会。无数物成就渐渐集聚。所持不牢性劣弱不得久住。饶诸怨家亲近怨家。作如是色爱着。色欲因缘合会。更乐色味香根。如是无数物色之根本。处母胞胎。处胎长大。年寿时过。当于尔时渐渐前进。集聚一处。有男女伤。知有众生处所众生不牢固形。牢固相应因缘性弱。造作诸行。化若干种怨家集聚。必当坏败。有力怨家常被系缚。必当坏败。自性住亲近怨家。故曰色如聚沫。痛如水泡者。彼如水中泡润雨与风合成。如是吾我痛者。诸根境界与识等生。故曰痛如水泡。想如野马者。彼如野马。盛夏炎暑无有云蔽。亦无风尘。无有浆水便起水想。如是作吾我想者。皆是幻惑众生悉是颠倒。故曰想如野马。行如芭蕉者。彼如芭蕉树极峻高大。皮皮相缠中无有实。如是吾我者不得久住。作若干种行。然无有实皆不牢固。故曰行如芭蕉。识法如幻者。彼如幻师。无众生谓有众生想。吾我识如是。故曰识如幻法。最胜为释种。故曰最胜说

又世尊言。学者生三刺。三刺义者其义云何。答曰。此三集聚知有不净。谓淫怒痴。又世尊言。王波斯匿。云何大王。于草竹丛或大[葶-丁+呆]积。而以火炷烧彼诸草木。颇有种种异形不乎。答曰。义各各异。声音不同

  端政住闲居　　愚痴无教戒
  优波离所说　　色幻及三刺

又世尊言。有四舍法。云何为舍法。如所说非句味义。复次契经有成言。如所说即是其六果。说此契经是弃舍法。如所说即是其义

又世尊言。若比丘供养病者。则供养我身无异。云何供养病者供养世尊无异。或作是说。供养病者脱于困厄。复作是语。佛世尊常法。供养病者长益诸法。复作是语。彼不供养供养佛世尊。复次世尊愍诸病者。犹如有人。语看病者曰。汝供养此人。则供养我无异

复次如来常自悲众生。供养世尊拥护众生。世尊言。比丘。我当说法。义理深邃。是诸法味。云何为义。云何为味。或作是说。名为味相。分别名者是为义。复作是语。敷演为义。意娱乐为味。复作是语。一切名为味。微妙为义。复次义依彼契经章句分断。渐相应为味。如所说。婆罗门言人依何所。说是语时其义云何。答曰。若有相应选择长益。即是彼所依。便有人名生等方便。亦依谷米有人名生。谷米依地。地为水所漂。风持水。当于是时风寒虚空。风为空所摄。空为明所摄。然后知有虚空。照明为日月所摄。于中三界回转时。乃至梵天各各相谓言。梵天梵迦高天大梵忍成就忍灭诸结。复作是语。依涅槃依涅槃住。云何得知。世尊戒成就三昧成就智慧成就。或作是说由阿含得知。世尊亦说。迦叶我亦不见天人及魔梵天沙门婆罗门众。有异沙门婆罗门自言。我戒成就定成就胜我者。智慧成就胜我者。解脱成就胜我者。解脱见慧成就胜我者。或作是说。如来藏身。复次记授决。于法身中智慧成就者则知三昧成就。三昧成就者则知戒成就。戒成就则知有涅槃。教意不能。犹如三昧住。意亦不乱亦不犯戒。是故世尊戒成就胜。三昧成就胜。智慧成就胜。以何等故。无常谓心不相应行。然无苦空无我。或作是说。无常非心意法。苦空无我者。是心意法也。问此皆心所念法。亦是心不相应法。若作空观思惟空者。彼则是空。若思惟无常非无常观。彼是无常。若不作无常观。无常异空异。复次集聚智有苦患。忍知为空。无我是无常。复次无常者无相之物

又世尊言。此不可造作。处所在居家。螺文梵行尽形寿修清净行。螺文义者其事云何。或作是说。昔有仙人名螺文。精进纯备而处居家不有梵行。或作是说。如彼螺文有清净行。然居家不清净不清净善。复次螺文造书文。风雨不能俎坏。处俗修梵行此非为清净。如阿那含在家眷属围绕。此非为善清净行耶。云何以神足能隐形不现。或作是说。自化形极细。或作是说。化无色四大。或作是说。思惟轻举使形升虚空。肉眼见广大。复次神足境界不可思议。云何神足化形极细。或作是说。化无色四大。复作是语。以大入小重垂于轻。如所从生。大火炎中取萤火光。复次神足境界不可思议。如所说仙人有五复曰六。其义云何。或作是说。仙人五世尊为上。此之谓也。复次五比丘中世尊为六。此之谓也。如尊者朋耆说。汝选择念见闻念知。见闻者其义云何。或作是说。谓结使也。不尽谓之流结。尽谓之漏尽也。复次诸所闻者方便所摄。一切彼闻菩萨时。谓见闻念知。如尊者宾头卢说。如大王所说。揭陀婆梨梵志千千不觉不可计数。如彼愚人。无明不善非良福田。彼非良福田其义云何。或作是说。如耕田人不别良田。彼谓非良田人。彼亦不知有此良田。亦不染着。是谓非良田。彼亦不知有此无是。亦不染着。是谓非良田。复次谷子所生处别其好丑。则知有良田。是故彼不知。是谓非良田。诸所诤讼尽欲界相应耶。设欲界相应尽是诤讼耶。或作是说。诸有诤讼者。彼一切欲界相应也。或欲界相应彼非诤讼。行垢相应解无著法。复作是语。或有诤讼彼非欲界相应也。答曰。色无色界相应染污法。或欲界相应彼非诤讼耶。欲界相应不染污法。及诤讼欲界相应染污法。或非欲界相应。亦非诤讼。色无色界相应不染污法。及无漏法也。诸不诤讼。彼一切色无色界相应耶。设色无色界相应。彼一切是不诤讼耶。或作是说。诸色无色界相应。彼一切是不诤讼。颇不诤讼彼非色无色界相应耶。欲界相应不染污法及无漏法。复次或不诤讼。彼非色无色界相应。欲界相应不染污法及无漏法。或不相应不诤讼。色无色界相应不染污法。或不诤讼亦不色无色界欲界相应染污法。色无色界相应染污法观现在事。其义云何。或作是说。现在所作目悉览见。是谓现在事。复作是语。得诸色根是谓现在事。复作是说。有二种现在。根现在。意现在。于彼根现在中。若得色根。意现在者若悉意不观。复作是语。如彼眼识相。当言有三种更苦乐。有其痛痒意便有想。色声香味细滑法中。思惟自相便有识生。是谓现在。自境界外。彼亦不空有境界也。我者其义云何。或作是说。我者爱己着形也。复作是语。内是我所。复次自性诸入彼是我所。余不牢固。现在及我此二事有何等异。或作是说。缘前有物。是谓现在。着己是谓我所也。复作是语。摄持诸根是谓现在。内为我所。复次露现缘前眼。若有我所者彼则自违

又世尊言。萨毗梵志

  造作诸业事　　往涅槃无疑
  无有有灭尽　　比丘不处胎

说是语时其义云何。答曰。解道彼以此道自竖立处。等以此道一切结使尽。故曰造作诸业事。往涅槃无疑者。闇冥得除究竟得智。无有有灭尽者。生有死无。彼度此生老病死。以现其妙。自竖立者。以修梵行。以倚住诸道梵行求以倚更无有如是有处胎彼灭。谓之胎尽。彼比丘者。于乞法中现其灭尽。如所说虽多婆罗门

  我见天人世　　无秽净行除
  故我礼大仙　　脱我无明疑

说是语其义云何。答曰。如我见寻原本。故曰我见天人世。无秽者。现无所摄。云何得知。以一切去离爱欲渐去除无秽。一切婆罗门行净。彼志成就无有诤讼。故曰婆罗门。习业之时观其所求。故曰礼大仙。所求以此然大法我如来以此大法。故曰大也。以得智当言见三昧。解脱我疑刺。以究竟授我三昧

  我不堪解脱　　洗除头多胡
  法为微妙智　　如是能度流

说是语其义云何。我不堪解脱者。洗除头多胡(梵志)自现体中。现着净法为微妙智。如是能度流。缘二等见有愚因净因观也

  住义将养病　　敷演无常理
  六闻田难沮　　现露净不堪

又世尊言

  究竟不惊惧　　无缚亦无疑
  已断诸有刺　　此最是后体

说是语其义云何。答曰。有二究竟。欲究竟已辨事究竟。修梵行以此度。究竟缘此因善智修定理。亦不惊惧。于无记体中亦不恐畏。亦不惊怖老病死。故曰不惊惧。如有异梵志。不以实智。不以真威仪。便作是说。叹誉彼此叹誉己身。此究竟智不如彼说究竟智成就。故曰不毁。彼戒盗尽者便尽生。故曰此最是后体。三界爱尽亦无缚着。是观谓其缘。故曰离三有刺。因缘尽永无有余

又世尊言

  此最为究竟　　迹灭为最上
  灭一切诸相　　净迹永常存

说是语其义云何。答曰。此最为究竟。现事究竟休息者。现三火息。现有余涅槃。迹者现智作处。尽一切诸相者。众生相众生所作方便。初中竟之貌也。作是观一切结

又世尊言

  最后爱念语　　托情亲朋友
  不应作便说　　智者皆分别

说是语其义云何。答曰。藏匿之语与众生相应。故曰意念语也。于中所有亲友有二益。彼不益彼此。二亲友指授彼时。智者皆别知。以彼结此彼此共同。又世尊言。当于尔时谷贵饥馑。生苗不生实。苗义云何。或作是说。以食故授筹。故曰苗。复作是语。以筹选择故曰苗。种种子生一茎。故曰茎也。复以种种谷子亦不生苗。故曰苗也

又世尊言。比丘当学自然自归法然法归不异归。我然法然法归有何等异。或作是说。我然者我好也。自辨其事。法然者欢喜踊跃。或作是说。我然者内身身观痛心法。法然者外身身观痛心法。复作是语。我然者思惟恶露。于法顺法者是法然也。复次亲近善知识及听正法我然也。思惟恶露欲辨彼事者。是法然也。教诲欲辨彼事者。欲为如是诸事则其事

又世尊言。若阿难生是意。我有是比丘僧缘。我有是比丘僧。我当护比丘僧。世尊复作是语。舍利弗目揵连求索比丘僧。我常不收况当汝。汝钝愚食唾之人。说是语其义云何。或作是语。如彼世尊如彼世尊。舍利弗目揵连求索比丘僧。我常不收。或作是说。从慈定起调达求索。从定三昧起。尊者阿难作是问。复次现依我尽以前契句。我当护弟子以二契句。非我因缘慈悲于彼

又世尊言。有是十法爱。愍念润情世间惊惧。以何等故。戒多闻梵行爱愍见喜娱乐。或作是说。作其善果。复次作众多想

又世尊言。那迦频颜婆罗门长者。彼作如是眼见色便娱乐。说是语其义云何。或作是说。如此形彼无歌舞香薰涂身香价甚贵。或作是语。妓乐戏笑因是故说。复次缘女欲故说是语。非不闲居境界。能作欲爱刺利衰毁誉。以利养故居处山泽。如昙摩尘那比丘尼说。乐痛淫所使。苦痛嗔恚所使。不苦不乐痛无明所使。说是语其义云何。或作是说。是如来教戒之语。复作是语。是如来劝戒之教义。当言可说。当言不可说。或作是说。当言可说。何以故。如世尊言。我当说法。有义有味味可演说。是故义亦可说。若义不可说者。说法则无有义。问说义为说味。二俱说义味之时。有义有味。若所说欲使义味与法异耶。设义理与法异者。是故不如契经文。或作是说。义可说名义展转是谓名。于义当言不可说。复次想所作语。无想所作义。是故义不可说

又世尊言。我当说法。初善中善竟善。云何于此法化中。云何为初云何为中云何为竟。或作是说。戒为首思惟恶露为中涅槃为竟。复作是语。初学大戒中学增心竟。学增智慧。复次说法之时缘初现初受化。受化回转为中后为究竟。彼于此初为结原中为结原竟为结原故曰初善中善竟善。又世尊言。如所说以三事不忘而忆。取本相自缘已初不失其旨。说是语其义云何。答曰。昔本境界取持守护。为想所受持。故曰本相所摄。自然于己回转因缘。自然者。方便自然亲近自然。故曰自然。于己数数降伏心。便有识护持。故曰志强记不忘也。如所说如是于中法法住法空法如实缘。是因缘是谓因缘生。说是语其义云何。答曰。如是于中诸法者。彼修行法。法住者。不有变易。法空者因缘果实。如是知修行不异因缘者。观所作行。又世尊言。更乐为一隅。更乐习为二隅。痛痒处中。说是语其义云何。或作是说。更乐为一隅。所作为习想。更乐习为二隅者。痛处中者异也。复次更乐无明更乐六入为习。无明生更乐。痛处其中

又世尊言。是故比丘当如是学。如出家想降伏其心。说是语其义云何。或作是语。是世尊劝教语。当于尔时求解脱故。出家学道。复次等出家故。故说此语

又世尊言。于中摩罗童子余比丘当何所为。年在幼少。出家未久学道日浅。来入此法亦复未久。云何汝今年老形熟长老。欲与我速疾求教戒。说是语其义云何。或作是说。年少比丘更作是念。此亦年老方欲习学。我等亦当在后习学所作自恣。复作是语。年少比丘便作是念。此如是年老亦无所逮。况当我等有所获乎。无勇猛志。复作是语。彼年少比丘当作是知。彼求教训。况当彼求道。复作是语。众多见闻年少比丘况我等。彼求教训。况当年少比丘不求耶。复次是世尊属累之语。各莫作疲惓意。以何等故。曩昔如来等正觉闲居山泽。岩峻坐具叹誉尔所事。然不处其中。然世尊叹誉其德亦处其中。或作是说。昔日之时无有闲处山泽丛林。村落相连鸡皆飞过。问设无闲居以何等故今叹誉之。答曰。叹过去闲居之德。复作是语。彼时佛教化众生。尔时不以闲居作教化事。恐不入彼教律中。复作是语。尔时众生贵重思惟定。不许彼闲居静处。村落之中应受化众生起恶露观。复作是语。尔时众生意多着乐。皆不许闲处。恐意厌不堪闲处

又世尊言。是语此契经句之语谁能堪。调达于世尊前有所论。世尊亦不于中住。诸于坏增中叹其快者。世尊亦当尔。彼人无缘。亦不有彼人不逆。亦不能有如是善比丘于如来前从彼恶语。何以故。世尊功德相应无能知者。诸闲居者礼敬承事便知彼人。是故世尊不许。以何等故。本世尊等正觉乃至证弟子等法住。然后复世尊久般涅槃。尔时复住。或作是说。彼众生是佛所化。是故声闻不能教化。复作是语。尔时众生贵重止观。彼时说法。复次是时如来极长寿。彼亦如今阎浮利地。然后世尊处短寿中。为诸受化众生及余趣。我观去来契经所说教戒语敕声闻

  语竟世明我众僧　　受无有痛不可说
  善说三法及更乐　　年少端正叹誉本

尊婆须蜜菩萨所集更乐揵度第七竟

尊婆须蜜论卷第六尊婆须蜜菩萨所集论卷第七

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    结使揵度第八

垢秽当言随颠倒。当言不随颠倒。或作是说。或随颠倒或不随颠倒。四颠倒当言随颠倒。欲慢嗔恚邪见当言不随颠倒。问云何不如实染耶。亦说如实观彼便知。是故不与相应。答曰。集聚便可知亦非自相。若观自相知者。皆有厌患意。无有自相意不回转。问如集聚可知。是集聚则有欲也。观彼颠倒如自相观。便染着无有不染着。无有自相意不回转。或作是说。当言随颠倒与痴相应。问愚痴不与愚痴相应。欲使愚痴随颠倒耶。或作是说。当言不随颠倒。颠倒设当随颠倒者。彼则不断灭。非以颠倒还灭颠倒。问如善无记心心法不随颠倒。彼亦可灭。垢亦如是。答曰。善无记心心法。还续如故。结可使永无。是故彼当言颠倒。复次当言不随颠倒。与邪志与使相应。不与相顺生不成就。彼不净成就。以何等故。谓身见是颠倒不净无能有害者。无有实我身见回转。或作是说。意有净相不净回转。答曰。无有净相。彼或有净或不净。问若有净彼有颠倒。彼或曰有常或曰常。欲使无常相不成就耶。答曰。无常相不成就。设常无常相不成就者。彼亦当有相。然非相。是故无常相不成就。或作是说。见颠倒与愚痴相应。不净非颠倒与智相应。问愚痴不与愚痴相应。欲使愚痴非颠倒耶。智不与智相应。欲使智颠倒耶。或作是说。身见是垢。垢与颠倒相随。是故身见颠倒不净。由智之功。智不智不随颠倒。是故不净非颠倒。问垢相应心心法。然非垢着。欲使彼随颠倒耶。智相应心心法然非智。欲使彼随颠倒耶。复次如其种类。不净相共染着。不可使诸阴自相有所染着。如阴无我成就。如其种类净成就也。是故身见颠倒然非不净。一切诸见摄六十二见。为六十二见摄一切诸见。或作是说。一切诸见摄六十二见。为六十二见摄一切诸见。或作是说。一切诸见摄六十二见。六十二见亦摄一切诸见。问如所说萨毗梵志。三乃至三十六种种异。云何彼非诸见耶。答曰。此事如是。二及六十亦复如是。或作是说。一切诸见摄六十二见。非六十二见摄一切诸见。不摄何等。彼涅槃言无涅槃俱生者。至五邪见无一邪见。复次六十二见所生见。当言所摄也

如萨毗所说。三乃至六十。沙门依智慧依智慧相依字想诸垢尽。云何六十三见。或作是说。无有六十三见。正有此二见。或作是说。言无涅槃者是邪见。是谓六十三见。或作是说。言无道者是邪见。是谓六十三见。复次所见是谓六十三见。如是五邪见身犹豫见邪见见盗戒盗。无因所生见。为何等见所摄。至死不舍见。为何等见所摄。或作是说。无因所生见。言有所因。是邪见习谛所断。复有至死不舍见。无作言有作。此是戒盗苦谛所断。复次无因所生见。无有见有见所摄也。至死不舍见者。当言有见所摄。以何等见使已尽心相应使更生耶。然无有因缘。或作是说。因缘者结使便尽因缘。未尽有余。尽不复生。问如是谛无漏缘。结使有尽不尽者。缘尽因缘。答曰。缘已尽无余。是谓灭也。问此缘不同诸使。未尽缘便尽。是故非缘。是故结使便尽也。或作是说。常相应无有不相应时。问非因缘。复次或有彼不缘。或作是说。未尽彼即是缘。复以此缘更不复生。复次尽不复生。问若缘有漏诸结使尽。数数彼缘不复更生。不灭亦不生。欲使无漏心是彼缘耶。结使转生结使。或作是说。彼相应一生一住一灭不如其缘。已尽各散不一处。彼心有使不如其缘。问彼心未尽。诸相应使一起一住一尽不如其缘。欲使不断者是其缘耶。结使非结使缘也。或作是说。诸相应使与心共。住不如其缘。是故已尽。是相应使。彼心有使不如其缘。此亦如上所说。或作是说。诸相应使染着于心不如其缘。是故已尽相应结使。彼心有使不如其缘。此亦如上所说。或作是说。相应使者。彼心染污不如其缘。是故已尽诸相应使。彼心有使不如其缘。此亦如上说。复次设当如彼缘者。彼心有使。亦见无漏心缘使。彼则有使。复次诸相应使当言彼心有使也。若尽若不尽。如力势王所欲自至。以何等故。欲界相应邪见。谓色无色界苦。然非于彼界所使。或作是说。自界所使不干余界。问此亦是我疑。何以故不干余界。设于欲界造余界者。欲使有漏界造自有界。邪见故彼界亦使所使或作是说。彼界少慢渐去离。是故彼界非使所使。问若去离者。在自界中亦当去离。是故自界亦为使所使。或作是说。非以彼见有所疑。亦不缘彼界。问云何彼有无此说法耶。答曰有。彼若以此说使说者。此非其义无长益。问无有苦恼。彼亦不作是念有所说。或作是说。知而言无。设当知而言无者。此非苦智耶。云何言无苦。若不知无知。云何言无。是故尽无尔所事。问知而言无。不知而言无。设无知知而言无者。若不知云何言无。是故无也。复次缘使所使。何以故。彼不为使所使。复次彼见界无定处。一切有苦而言无。欲使欲界越次彼谓不尽。然后与欲界相应。以何等故。缘涅槃邪见言无涅槃。然不于彼使所使。或作是说。彼不有此使问无能诽谤彼者。欲使诽谤缘涅槃耶。或作是说。诽谤之言去涅槃远。是故不于彼所使。问有漏之法亦去离诽谤。是故有漏亦为使所使。此亦如上所说。诽谤所说。亦如本无异。有是诽谤。复次若缘使不为使所使。阴持入中。彼见无生处所。已有所生。何以不为涅槃所使。以何等故。涅槃中无有嗔恚。或作是说。此非嗔恚境界。问彼诽谤境界。欲使诽谤非缘涅槃耶。或作是说。有漏之法。便有嗔恚无是涅槃。是故缘涅槃无有嗔恚。问有漏之法便有嗔恚。无漏是涅槃。欲使嗔恚非涅槃缘耶。或作是说。以方便舍众生。便有嗔恚起。然涅槃非众生之教。是故缘涅槃无有嗔恚。问有漏之法众数中便有名生。复次无造之相。速有嗔恚起。然涅槃无造之事。是故涅槃中无有嗔恚。若作是说。我必堕泥犁中不须涅槃。彼心与何结相应。或作是说。与嗔恚相应。问缘涅槃有嗔恚耶。或作是说。彼染相应无明之数。彼不知涅槃。复次彼心当言与爱相应

又世尊言。于是比丘欲界之中有欢喜乐天。契经句广说。彼云何命终更受形。便自忆我本为欢喜乐天。便作是念。我本为欢喜天。或作是说。于彼退转。复作是念。彼不于欲界起吾我想。问生欲界中怀宿命所更。我本某甲身。如是起吾我想。欲使彼谓退转耶。复次诸所有名色相应结使欲界因缘。彼则有强记。复作是念。寻生之时审有誓愿。复次我见之想不观断灭。复作是念。等故凡夫本为欢乐天。以何等故。凡夫人不于苦观苦。欲界相应身见犹豫见。谓之断灭耶。或作是说。不净灭贪欲。现拔一苦。亦用思惟断。问四谛所断非思惟耶。此二种所断一种乎。四谛所断以尽。若思惟所断不尽不舍。或作是说。种种结已尽永尽渐渐尽。于彼身见已尽不究竟尽。问若渐渐结尽者。更亦当不生。亦说有三种身见。结生身见。使尽身见处所之法。便有所照。于彼作恶露观。如是身见使便生。复次生十想法所种。便作是语。如是意所断。不于中间贤圣道能断结使

  颠倒不净见　　萨毗五见戒
  二种及嗔恚　　泥梨德本苦

以何等故。欲界相应身见犹豫见。谓之无记。然非不善耶。或作是说。彼非大身口意行所能造作。问亦有余见谛所断结。由身口生欲。使彼言无记耶。或作是说。彼身有优劣。问云何得知有优劣。或作是说。彼结长益时不生恶趣。问彼未必不善。乃至入恶趣。或作是说。不善有报结无有报。是故此无记。问如彼见受形时。云何无有报。复次设彼作是颠倒见。无有安处。云何无有不善。彼便当有彼见无有报。是故不善。云何有垢受不善报。是故无记。是事不然。世尊亦说。如是比丘。愚痴者即不善根。若当言无记者。此事不然。以何等故。色无色界相应使。谓之无记。然非不善。或作是说。彼非造身口行。或作是说。彼受形时无优劣。或作是说。彼不受果报。或作是说。彼无有报。此亦如上所说。复次诸欲著者彼不善耶。彼则有是意不受恶报。彼不受颠倒。彼不回转。彼不安隐。彼亦不然。是故当离。若结非非善者。云何今不善耶。结亦由行增。是故言无记者。是事不然。所可用心诽谤四贤圣谛者。云何彼心因染义耶。或作是说。非可以一心能使四谛有若干相。复次彼心因缘集聚。问若四谛异因缘亦异者。则不诽谤四谛也。若四谛因缘同。心则缘四谛也。此亦如上答无异。所说不顺其理。复次非心诽谤。用邪见诽谤也。一步始苦谛处所。非因苦谛无有尽谛。尽无有道。各自求苦谛处所。此之谓也。彼无有义可从得者。以何等故。无垢人遂进断结。欲界相应结使。及思惟所断先尽。然后色无色界相应。或作是说。此渐生贤圣道。先辨欲界事。后色无色界。问欲使贤圣道生。先辨欲界事。后色界后无色。或作是说。欲界结使粗。色界相应使细。是故先断欲界相应结。后色界相应。后无色界相应。或作是说。欲界相应近。色界相应远。无色界相应转远。或作是说。有对之处即前灭结。欲界相应先在前。后色无色界相应也。是故欲界相应结先灭。后色界相应。后无色界相应。此亦如上所说。复次彼道渐渐益有对即灭。后则有是也。何以故思惟所断结不渐渐断耶。当作是观。未知智观色无色界。彼不有长益齐限。亦有展转持信奉法。以未知忍知。是故彼无苦以方便观。以何等故。欲界相应行。思惟苦等越次取证。然非色界相应无色界相应。或作是说。此渐生贤圣道。先辨欲界事。后色无色界同。问彼欲思惟道生。先辨欲界事。后色无色界等。此亦如上所说。此苦粗以是缚着。此亦如上所说。复次此劝教方便。诸耆年虽能逆是者。于此造事一切诸行。捐弃已尽苦根本。以何等故。色界相应行于苦思苦。不还阿罗汉果。然非欲界相应色界相应。此亦如上所说。此苦粗亲近此间以是缚着。复次作无吾我想。所可缚着当言尽无欲也。欲使苦行不思惟更思惟余苦耶。如自舍田除他田中草秽。观彼亦如是。颇有一心诸法灭尽还智慧然身不受证耶。或身受证不还智慧耶。或还智慧身亦受证耶。或不还智慧身亦不受证耶。或作是说。若得尽法忍时。欲界相应尽谛道谛思惟所断结尽。尔时还智慧。然身不受证。色无色界相应苦谛习谛所断结尽。尔时身受证不还智慧。欲界相应苦谛习谛所断结尽。尔时还智慧身亦受证。色无色相应尽谛道谛所断结尽。思惟所断结尽。亦不还智慧亦不身证。问若尽法忍生尽谛所断结未尽亦非其类。答曰。生者便灭。已灭不生。若生者不灭则非其类。问欲使便观生尽者已尽。当作是观。或作是说。尽法忍起时。欲界相应道谛相应所断结尽。还智慧身不受证。色无色界相应苦谛习谛所断结尽。身受证不还智慧。欲界相应苦谛习谛尽谛所断结尽。尔时还智慧身亦受证。色无色相应尽谛道谛所断结尽。亦不还智慧身亦不受证。复次得尽法智时。亦如是无异。二分俱不尽。颇见相应痛爱结相应非见结相应耶。或作是说。或于欲倍爱尽等越次取证。习已生尽智未生。欲界相应尽谛道谛所断。上中下见相应痛。下爱结相应非见结相应。问世尊亦说。若比丘于痛贪欲而灭尽时。贪欲尽痛便尽也。云何贪欲尽痛便尽耶。或作是说。见谛人与世俗等。见相应痛与爱结相应。不与见结相应。非见结尽彼见结

复次习智已生。无色界爱尽。与世俗等。见相应痛与爱结相应。非见结相应。云何缘涅槃无明而随涅槃耶。或作是说。彼无智愚痴所缠。问彼作是念无智是愚痴耶。或作是说。有二种痴随涅槃也。与邪见相应。无明言无涅槃。疑相应无明者。犹豫不定一法相应。问邪见无明各不异耶。如是疑无明。此诸法各异。复次无明随涅槃耶。复次如是五盛阴言是我所。如闭两目。一切智有目者少。如身缘有漏生诸结使。如所缘结彼身有漏。或作是说。诸身有漏。如彼缘生结使。彼身非有漏。如缘尽缘道有诸结使。问又世尊言。于是比丘诸所有色。过去未来现在。贪欲生便生淫怒痴。其余心所念结使。是谓在漏泡。此契经则有违。或作是说。诸身有漏缘彼生诸结。如缘生结彼身有漏。生无漏义。有漏义。结有漏义。复次若身不中间生见。彼身有漏。不如彼缘生诸结也。彼造结时染着身处所

  二种说不善　　诽谤舍离去
  阿罗汉一忍　　冥有漏在后

以何等故。调戏有思惟断。或作是说。见谛者有调戏。故曰用思惟断。问见谛者亦有无明。彼见谛思惟所断。或作是说。二俱调戏。见谛所断亦思惟。复次此见谛所生调戏见谛所断。如彼调戏少所说。不顺此所作不辨。若越境界彼思惟所断。若少有辨逼迫碍持。是故二俱调戏。或作是说。凡夫人调戏炽盛。见谛者调戏微。是二俱调戏见谛所断。复次无恐惧有秽污意。何以故不见谛所断。若见迹者。或有随从。彼调戏思惟所断。从无色界终生欲界。云何欲相应结而现在前。如上聚揵度所说。复次若作是意。生无色界欲界相应使永断。然非无色界相应使。是欲界相应使缘彼则有是耶。彼则不生欲界。设生时中间不生。结使亦不现在前。无因缘现在前。复次凡夫人无有结尽。作不善行。彼欲界相应结谓之尽也。如世尊言。于是比丘。汝等不思惟。亦不作方便。则是结因缘。神识所止处。彼于此间当作方便。从无色界终生色界时。云何色界结使而现在前。答曰。不拔诸结使。譬如火炎缘炎有。如是明所缠。作不善行者。便受色有。此亦如上聚揵度所说。色界终生欲界时。云何欲界相应使而现在前。如上聚揵度所说。复次渐渐欲爱增有力势。因本彼欲爱尽此三灾变。风灾水灾火灾。此由众生垢生此三灾。为此三灾众生有垢。或作是说。由众生垢著有此灾变。犹如众生罪有刀剑劫。或作是说。由灾变故众生有垢着。犹如狗犬阴阳有时。或作是说。由垢着故有灾变生。彼彼众生有欲界结。彼彼有灾变起。如彼彼有灾变。结使使增益。复次众生善法常修习行。便游余国土。彼因行增上。众生有坏败学本所习。云何缘使便有所使。云何相应所使。或作是说。贪欲使甚爱着。是谓所使。嗔恚使不爱着意不染着。是谓所使。有爱使甚爱着。是谓所使。憍慢使炽盛极炽盛心勇悍。是谓所使。见使五见。于彼身见使自依所使。犹豫见者断灭有常。是谓所使。邪见使无因诽谤无作。是谓所使。见盗使不可护持。极微妙好最为上。是谓所使。戒盗使净解脱上出要。是谓所使。无明使无智盲冥愚惑。是谓所使。疑使悕望犹豫为是。为非意不审实。是谓所使。如是缘使所使也。未曾更与相应所使。问无漏亦缘使。如是彼所使欲使。彼缘亦是所使耶。或作是说。如彼彼有诸使缘。彼彼有使缘时。各各相牵引。为是使所使。如是如是使缘所使。彼使染着。如是使相应所使。问无漏使如其缘。转转有增益。故使无漏缘是使耶。缘是所使。或作是说。缘相应不得解脱。是谓所使。问无漏缘亦是使缘亦是使。无有余缘所使

复次虽使所使者。所回转处彼则有使。若相应使所使者。余亦相应。复次众生使因缘所使也。贪欲缘法为有几使所使。或作是说。欲界相应一切有漏缘也。复次三界有漏缘退时。而生欲界得三界结。得是时三界结有漏缘所使使。名者其义云何。或作是说。次第所使使。亦所使缘亦是使。使为着义亦是生义。使为持义亦是使义。复次当说等智是彼所使。以彼使若有漏所使也。或用或不用。垢者为何义。或作是说。垢着人体。受诸爱亦是垢缘。苦亦是垢。复次二种垢心相应垢众生垢。彼心垢着。染着心意如垢污衣。众生垢有或随他。如负重担。以此因缘。以此事计挍。彼时便有心垢生。世尊亦说。为心垢所惑。心净行则净。合会成众生。世尊故说。此善根者其义云何。害不善根是谓善根义。起诸善行是善根义。复次于神种善原顺从受报。是善根义。不善根者其义云何。无记为谷子义。无记为根义。无记为因缘义。无记为根。复次形体色无记法顺从受持。是谓无记义。以何等故。身见谓之苦谛所断耶。或作是说。缘彼苦如是知苦便灭已灭。缘便尽诸结使尽。或作是说。有常想我想。身是我所。身见作无常想。苦我想已尽。是故谓之苦谛所断。复次见身见身彼身受苦恼。是故彼身现说苦恼是故灭。当作是观

  调戏不复生　　如有三结使
  身及诸结使　　三种根所断

以何等故。习智生尽道见盗谓之尽耶。或作是说。始初有见盗染缚彼见。彼灭尽时此亦灭也。问结使便有见盗。是故亦是思惟所断。或作苦谛。有违见盗及疑。是故四谛所断。问苦缘结最在前为上为妙。盗云何与苦有差违。复次云何度苦结前为盗耶。若苦不能在前导者。是故见盗苦谛所断断。如所说谛无住处言是我所。以何等故彼谓邪见。或作是说。由此因缘故说之耳。是故谓邪见。或作是说。若此谛实作盗。复次彼非缘空

复次有我所便有是见。云何是上分结。或作是说。五下分结者。贪欲嗔恚身见戒盗疑。此不尽有欲界苦。上界三结不尽。受色无色界阴。欲使是上界病耶。答曰。不由此有病彼已尽。阿那含受色无色界有。是故无病。问若彼三结已尽。受色无色界有。是故彼不生欲界无垢人已尽。复受三结有。欲使界有不回转耶。或作是说。二结属下分。贪欲嗔恚也。若不尽受欲界有。已尽不复更受。问一切欲界结未尽受欲界有。欲使是欲界结尽耶。是上分结。或作是说。当言一切是上分结。若不尽受欲界有问如所说五上分结则无其名。或作是说。二结未尽贪欲嗔恚。不出欲界。三结未尽复还来欲界。是故五上分结未尽。复次诸结使。从欲界灭不在余处。彼当言上分。云何是上五分结。或作是说。五上分结。色爱无色爱调戏憍慢无明。以何等故。此未尽受色无色有。三结未尽修行彼时。受色无色有。欲使上是五上分结耶。答曰。彼不由受有色无色界有。是故不受彼有。问三结已尽。此无垢人受欲界。欲使是五上分结耶。或作是说。若诸结未尽离欲界。受色无色界有。彼谓五上分结。或作是说。二是五上分结。色爱无色爱。于中修行受色无色界有。或作是说。一切色无色界有。一切未尽。受色无色界有。复次诸结使。可使色无色界结尽。彼是五上分结

云何缘嗔恚。或作是说。非妙非上有愁忧苦恼。或作是说。愁忧渐去离远。或作是说。以众生之故有其嗔恚。复次永离去如去恶草。欲与念有何差别。或作是说。欲是垢着。念非垢着。或作是说。欲是不善。念是善无记。或作是说。欲受有念不受有。或作是说。欲与念当相应者。或有欲有念。如有人欲受尽。有念于师。复次欲以方便生。念悕望生。是故欲亦是悕望。嗔恚秽污。此二有何差别。或作是说。嗔恚是结秽污非结。复次嗔恚是不善秽污是善无记。复作是语。嗔恚受有秽污不受有。复作是语。嗔恚彼是秽污耶。或是秽污彼非嗔恚。如修不净时是其义

复次嗔恚受诸有。秽污不受有。于彼嗔恚亦不受有。懈怠睡眠有何差别。或作是说。懈怠是身睡眠属心。或作是说。世俗义为懈怠。出世俗义为睡眠。复次初为懈怠。疲倦为睡眠。邪解脱四颠倒有何差别。或作是说。见谛所断是为颠倒。见谛思所断是谓邪解脱。或作是说。能为人敷演是为颠倒。不能为人说是为邪解脱。或作是说。诸颠倒者是邪解脱。或是邪解脱彼非颠倒。解脱结使。复次邪解脱者。当言是心颠倒耶。亦不离四颠倒有意颠倒耶。调戏疑有何差别。或作是说。调戏思惟所断。疑见谛所断。复次心染污有悔恨心。是为调戏。心不究竟犹豫不定。是谓疑也。以何等故。凡夫人退时见谛思惟所断结便有增益。然世尊弟子退时。思惟所断结便增益。然非见谛所断结。或作是说。以一思惟道。凡夫人断诸结。彼思惟道退时。一切增益。然世尊弟子或以思惟道断。非见谛所断。彼一切无有增益。或作是说。凡夫人以智灭诸结使。彼智退时一切增益。言世尊弟子以忍智灭诸结使。然不于忍退。亦不大增益。或作是说。凡夫人于中间灭诸结使。彼退转时一切有增益。然世尊弟子于中间少有灭尽。不究竟尽。彼退转时于其中间。彼退转时彼便有增益。复次凡夫人以行。缘有诸使。彼尽形寿而为覆蔽。彼行缘所系故便增益。然世尊弟子以见等越次取证。诸结使尽便增益。是故彼增益不可移动。等见想心等彼护守。彼或时退持。以何等色无色界相应结使谓之无报耶。或作是说。彼不长身口意行有所补。或作是说。彼虽有身口意行。彼不有增益。或作是说。不有好丑之报。或作是说。无记无有报也。复次若结使有报者。云何有违。如彼有缘。若彼诽谤者。不受色无色界报。如是有缘亦复无也。彼不受有。是故无结亦复不定。是故舍离

  不度不败坏　　嗔恚欲嗔恚
  增上解脱戏　　退转无果报

若五欲有欲无染污心。此二有何差别。或作是语。五欲有爱使。不染污心者。而不受有爱。复作是语。五欲之中有爱不善。不染污心是善。复作是语。五欲之中有爱受有。不染污心者而不受有。复作是语。五欲之中有爱有诸善想。不染污心者不断诸苦原。复次五欲之中有爱者。言有我缘便欢喜踊跃。不染污心者。第一义谛不移动。起众生想以得等智。真是不染污心。彼则当有。云何彼凡夫人谓非染污心。我可所缘彼非凡夫人有所造。诸神仙人于外以巧方便。谓无染污心。若苦谛所断见盗。及习谛所断。此二有何差别。或作是说。苦谛所断见盗者。彼则苦谛所断。见盗者彼则习谛所断也。问此二俱是见盗遍在二谛。或作是说。若与苦谛不相应。则彼苦谛所断也。若习谛不相应。彼则习谛所断。问如苦结现在前。最妙最上为最第一。盗云于苦谛不相应。复次苦谛所断结使。以苦谛拔则有妙想。当作是观。与化有何差别。答曰。内心所摄心佞为奸诈。外不与心同。是多化有差别。以何等故。心非贤圣道耶。或作是说。是世尊教化之语。说此则说心无异。彼则心相应。问何以故说心之时。不尽说心所念法。或作是说。是如来教诫之语。有是教诫而有智慧。如捣香末以香为首。色声香味亦复如是。问造一事所生之处。诸相应法无有力势。或作是说。自相所摄心集聚心。是贤圣道。是故心非贤圣道。或作是说。心亦是贤圣道。等三昧有众多心共。一缘三昧者。心有增减无有异三昧也

复次道心遂盛。志意所造心有所说也。欲界相应身见犹豫。除彼相应无明。及得余法可说隐没乎。或作是说。可得诸法相应及余心所念法心解脱行。以何等故。须陀洹不净谓净灭耶。或作是说。不净有净想有颠倒。须陀洹已尽也。问若颠倒须陀洹已尽者。彼则不染着也。苦想无我想不净想。彼当染着。复次然须陀洹不净有净想已尽也。见中邪见。当知已尽。何等盖中疑结耶。云何非盖中疑结耶。或作是说。若欲界相应。彼是疑出要也。若色无色界相应。彼非疑盖也。或作是说。若入三昧内者。彼是疑盖。若真果者。彼非疑盖也。复次一切调戏是疑盖甚增多。欲界相应非疑盖也。若自计吾我者。彼一切是身见。设是身见。彼一切自计吾我耶。或作是说。诸所有法自计吾我者。彼一切是身见也。颇是身见彼法非自计吾我。自依我见。或作是说。颇有法自计吾我彼不身见耶。我见相应心所念法。颇有身见彼不自计吾我耶。自依我见。颇有身见及自吾我见是也。颇非身见亦非自计吾我。除上尔所事则有义。复次彼有法自计吾我。彼非身见耶。又世尊言。我今当说彼说我当说。或有身见。彼不自计吾我我见。或非身见亦非自计吾我。除上尔所事则其义也。诸有见生。无病自言乐。云何生此见。或作是说。以三昧力自识宿命。初第二第三禅地。皆悉识知于此间乐故使尔耳。知有乐。复次贪嫉见身观上方便。有寒热观诸苦。言于中便作是念。我有是乐然苦趣。其恶道诸所生见。偏有一苦无病当死。云何生此见。或作是说。此是三昧力。自识宿命。堕恶道中亦自识宿命。于此间忧苦。于中便作是念。我已甚苦。复次自计吾我。以善方便观其所造作。如食想。偏见一苦乐亦是苦。诸所生见自计苦。乐有安隐想。此是何结。或作是说。三昧力自识宿命。人天之中及欲界自识宿命。于此间自识苦乐。于中便作是念。我有是苦乐。复次自计吾我。观其方便受其苦乐。于中便作是念。苦乐是我所。安隐处起死想。诸所生见。自计不苦不乐安隐处所。作如是想。云何生此见。或作是说。此是三昧自识宿命。四禅地自悉了知。于此间受其苦乐。彼便作是念。无苦乐想。复次作我想见堕恶趣受苦乐。或时无乐。彼则有是想也。彼复作是念。无苦无乐无我见。亦作死想。诸所生见。所谓我色起者。四大所造坏败至死。如是我见趣彼等见。此是何见。答曰。或有时见行以天眼知欲界便有生。彼不作是观。便作是念。不堕恶趣。诸所生见言有我者。断欲界痛坏败至死。如是我者等断绝。此是何见生。答曰。或有时见行以天眼见色界形。彼不作是观。复作是念。堕恶趣中诸所生见言我。无色空处断绝坏败不成。至死不舍。如是等断绝。云何生此见。答曰。或有时见行知有色界形。彼不观余轨。复作是念。堕恶趣中诸所生见所谓我者。无色空处坏败不成。至死不舍。是谓等我见断绝。云何生此见。答曰。等入三昧不观所生。彼作念已断坏也。识处不用处有想无想处亦复如是。如所说命异身异乃至死。以何等故彼无见生。或作是说。自计我常住有净果实。亦不见果。此无见生复次心所念法言有常。因彼因缘便诽谤言。彼则生无。如体中有现在无明使相应。于彼体现在无明使相应。若体中与现在爱使相应。或作是说。如体中有现在爱使相应。于彼体中有现在无明使相应也。颇体中与现在无明使相应。彼不与现在爱使相应也。及有余结而现在前。复次二结俱不有一时而现在前。何以故。用思惟诸结使。不一时二俱生也。是思惟譬喻有四颠倒。当言缘谛。当言不缘谛。五阴颠倒是其缘。阴中无有常无我。设当缘彼者。此事不然。答曰。无常阴者。而缘有常。设当不缘谛者。则是颠倒无常有常。谓颠倒无者则非无常

复次义无有颠倒。亦不缘谛。彼亦不有相诸所因缘。以何等故。色界相应使空处相应。谓识处相应耶。或作是说。彼不可知。问一切结使可知。又世尊言。于是比丘有着耶。我及彼亦着。或作是说。三昧无常彼相应结使。谓之无常相应。问此亦是我疑。何以故。彼三昧谓之无常。答曰。此已休息。问上三昧已休。欲使彼亦是无常耶。或作是说。彼地有常。然相应结使谓之无常。此亦如上所说。又世尊言。味欲秽露犯诸结使亦不舍离。云何味欲。云何有犯。云何秽露。云何有结。云何为舍。答曰。于欲染着起欲想意想乐想。是谓味欲。于欲染着起欲想。是谓味欲。于欲染着起欲想有苦乐想。是谓秽露。于欲染着欲想多习爱著有众多方便。是谓犯欲。有众多缚着心染污。是谓欲结使。欲结使者。欲有若干想观知所生。是谓舍欲也

  意盗邪奸伪　　清净我苦乐
  及体颠倒者　　结使贪欲慢

尊婆须蜜菩萨所集结使揵度第八竟

尊婆须蜜论卷第七尊婆须蜜论卷第八

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    菩萨所集行揵度首

阿罗汉于欲界般涅槃。云何受色无色界相应报。或作是说。速疾受报故。受色无色界行受闲静身。问若能受阴者。何以故。不究竟尽诸行。不得阿罗汉。受色无色界报。设逮阿罗汉。于现法中受报界。是故后世受报缘。则有微妙报。若彼行还阿罗汉不舍因缘。以杂行还阿罗汉。则有其缘相应之行。是行果未熟受妙报。或作是说。初第二第三禅地。缘彼行受苦乐报。第四禅地及无色界相应受不苦不乐报。此亦如上所说。复次阿罗汉若般涅槃受善报。拔诸苦原不善善者缘。云何般涅槃有其处所。彼作是念。云何彼无所有耶。当作是观。设彼行无报者。彼行则无所有。亦无果实。行亦无所有。如仓谷欲使不得成就不生萌牙。彼则无所有。若阿罗汉行果已坏。是谓报果。阿罗汉亦无所有。是故此不尔行所有。颇有人自害身命。非阿罗汉父母。受五逆罪耶。或作是说。有也。作父想往杀人者受五逆罪。复次母化为男子。彼人作母想往杀人者。则受五逆罪。颇杀女人。非母非阿罗汉受五逆罪耶。或作是说。有也。作母想杀他女人者。则受五逆罪。复次母化为女人。彼女人作父想杀人者。则受五逆罪也。不成男杀父母。当言受五逆罪。当言不受五逆罪。或作是说。不受五逆。何以故。不成男愚痴不能起上结使。不于中间有上结。有不情罪。或作是说。上结不成男。于中方便必受五逆。如是出要是五逆。彼不有五逆。是故不受。当作是观。或作是说。当言不受报。何以故。彼不有恩慈。向于父母心不一定。设当受报者。受五逆罪。或作是师想。当作是论。世间纯是五逆罪。若畜生还自害父母。当言受五逆罪。当言不受五逆罪。或作是说。当言不受五逆罪。何以故。畜生无有是智。有尊卑想。于其间有是五逆罪。或作是说。有智众生便受五逆罪。有智能造结使。犹如御马师。以衣缠头合马牡者。便知是我母。还自啮根断。或作是说。彼法自尔。有智众生无有限量。畜生之类如闻音响。千秋(人面鸟身)生子还害其母。后逮阿罗汉果。复次当言无五逆罪。彼无有恩慈于二父母。设有慈心日日衰耗受五逆罪。当以师想作是论。设当尔者。一切世间皆是五逆。凡夫人住杀害心。当言成就善心。当言不成就善心耶。或作是说。当言不成就。彼无此智慧能悉分别。彼无禁戒。问今凡夫人不生天上。唯闻戒生天上。或作是说。当言或成就或不成就。若生天上彼则成就。若入地狱者彼不成就。问此义不然。云何亦闻大行。分别契经说。于七处犯则入地狱。不犯则生天上。复次或有成就或不成就。谁成就。于三昧戒具足。不犯戒律。禅不退转命终后。是谓成就。谁不成就。三昧戒不具足。犯戒律。于禅退转便命终者。是谓不成就。阿罗汉最住后心有漏界。当言成就当言不成就。或作是说。当言成就不舍戒律。问云何受果报。于彼后心而受果报。问行与报等无有异此非论。是故无此。或作是说。当言不成就。彼三昧戒不受其报。问尽形寿三昧戒不具足。复次阿罗汉遍满世界。复次当言成就。尽形寿彼便作是念。云何今受报。彼言前若后。云何于其中间而受果实耶。若作讲堂房舍。当言身行当言意行。或作是说。当言身行。身求方便勤劳有功。问是何等身善行所摄。答曰。非尽身行。是身三善行所摄。或作是说。当言口行。口有所陈。我施众僧房舍。口行所作。当问是何等口善行所摄。答曰。至诚语知时语不粗犷语。或作是说。当言意行意有决了以物施彼。意已施了后发口言。我今施至诚不妄语。问是何等善行所摄。答曰。意三善行。不起贪嫉无嗔恚等见。复次若身教戒我有所施。彼身有教戒我有所施。彼当言身行意行。若口有教戒我有所施。彼当言口教意教。若身口有教我有所施。彼当言身教口意教。不于中间起房舍福念。诸善根成就。于此间设复还生为人。若出家若处俗修法。彼以何故不于现法中不出家修行法。或作是说。彼善根未熟已。更生诸善根便成熟。或作是说。彼以善因缘有碍不得出家。复以此因缘得豪贵家。复次于此间或有凭依外力。而有成就所依者。强诸结已尽。诸善行。具足。若无方便诸善法。衰耗。彼于此间终更生复得出家。当作是观。有尔所事。以何等故。结有果实行无果实。或作是说。行报是其对已受此报。诸结使尽道是其对。道未生而有果实。问行亦是道对。道生结则灭。复次有报受其教一切消灭。或作是说。若行数数有果实。则上亦无果实。是故不断绝。问欲使不断绝耶。复次此俱有二果共一法。何以故。无果复言有果。若彼有自然行

  受报教男女　　不成男亦尔
  凡夫人后心　　施讲堂房舍

如此地须弥大山王。众生受行教众生般涅槃。彼渐微小耶。答曰。不微小也。何以故。一切众生缘其行报。若不受报者。彼或有众生受报不受报者。此非彼过。有其微小谷子芩鬼芩药草树木。当言自受行报。当言受增上报。或作是说。当言受行报。问则无有不与取。答曰。他所受则无有不与取。问为受谁物。或作是说。若有所受彼是行报。若无所受彼亦是行报。问彼亦是受报。彼亦是不受报。欲使彼是行报。复次受行增上。何以故。不以行报故受其果实。不断苦原乐原。如草木园果。以何等故。往昔人修十善行时。延命长寿田业丰熟。如今日之人修十善行时。亦不长寿亦无田业。或作是说。往昔人长夜修十善。如今日人不长夜修十善。问如今不长夜修十善。彼则得长寿也。亦得好田业。或作是说。彼往昔修十善。如今日人不修十善。问无始之人修清净之行。今可得受长寿耶。及大田业。或作是说。彼非现在受行报。余处受行报。彼时长寿及大田业。于彼行果余处受。如今日修行十善。彼时余处受报。问如今亦不观。或余处受行报。亦得长寿有大田业。复次无量众事延众生命。亦由田业。不独此行行。亦无量众事。如今可观。或有方俗诸趣。或有众行延命长寿。以何等故。持戒人教他不持戒便自堕罪。或不持戒人教他持戒使有戒律。或作是说。持戒人教他不持戒。是故犯戒若犯威仪。然精进人不精进人不得威仪。若持戒人教他不持教使不持戒。然不持戒人不教使。持戒人教使持戒。或作是说。精进人教他不持戒。处在悕望。悕望以坏教戒。不持戒人教他持戒。不起悕望。悕望坏则戒坏。复次持戒人教他不持戒人。若起想念则曰不持戒。有持戒力而不退转。不持戒人教他不持戒。若起想念。当言持戒人以精进力游。颇有一口行。有福无福报耶。或作是说有。爱此教彼有是二心。口有一教。本起想念作是语。收某甲缚某甲。问发善心有教有功德生。善法具足起诸教戒。若不善心有教。则有不善福生。心所念有善不善生。复次教戒有众想生。或作是说。口无善行善心有教。不善口行。不善心口行。不以一教有善心生。是故无也。复次口教相类。亦有虚亦有实。善心生不善心亦生。无记心亦生。复次一切属心行。亦有善亦有不善亦有无记。是心所念口行处所。当言行口一心亦善亦不善。是故无也。以何等故。身行亦善亦不善。或作是说。有作杀害想。一处有教身本起念。当杀某甲当赏某甲。问设善心有教。则有福生善心已生。若不善心有教。则无有善福生。不善心有教心是身本。若心所念有福无福然教戒者有二杀害心。或作是说。善身行善身。口教不善身行不善。身心有教不以一教。当言善当言不善是故无也。复次教相类亦见礼敬。兴起善心。兴起不善心。兴起无记心。复次一切心所念有是教善不善无记。是故心所念不以念有善有不善。是故无也。云何得知阿罗汉有漏戒成就。或作是说。彼非具足有尽威仪。犹如是威仪。不还阿罗汉。如还阿罗汉无异。或作是说。设阿罗汉有漏戒不成就者。彼无有罪犯。已复还悔。或有漏戒成就阿罗汉。复次若阿罗汉不起有漏戒。亦不量有漏此是世俗。是谓因缘。亦不藏匿起众生想。以等圣谛方便之心贤圣妙法。于此戒而随空性。当作是观。又世尊言。于是阿难大爱道比丘尼。若受八重法。则是出家之要。亦是禁戒。亦是比丘尼行。云何出家要。云何禁戒。云何比丘尼行。或作是说。承受重法。亦是出家禁戒。亦是比丘尼行。亦作是说。彼则是禁戒比丘尼行。或作是说。捐弃家业。是谓出家。承受重法。谓是禁戒。到时乞食不失威仪。是谓比丘尼行。复次于现法中习学威仪被沙门服。出家学道得具足戒。以方便得此禁戒。顺从不失时节。是谓比丘尼行。云何学增上戒。云何学增上心。云何学增上智慧。或作是说。身威仪口威仪众行清净。是谓增上戒。四禅。是谓学增上心。分别四谛。是谓学增上智慧。或作是说。等语等行业等方便。是谓学增上智慧。是谓学增上智慧。等念等定。是谓学增上心。等见等志等治。是谓学增上智慧。或作是说。若戒依思惟。是谓学增上戒。若依止观。是谓学增上心。若以止观断诸结使。是谓学增上智慧。或作是说。见不持戒志为秽能去离彼者志在禁戒。彼一一学。是谓学增上戒。见去离秽意不染着。习学三昧。于彼一一学。是谓增上心。无有方便见诸秽露能舍去离。以方便智慧亲近善友。于彼一一学。是谓学增上智慧。复次顺近贤圣八道分别威仪。是谓增上戒。尽寿奉戒当去恶就善贤圣道起诸三昧。以智慧学增上心。于此三昧有方便遂增益。于其中间诸贤圣道智慧。是谓增上智慧。于此智慧方便修行。以何等故。舒尼二十亿(沙门名也)以一房施之。得九十一劫不堕恶趣。菩萨于此中间作无数功德而入地狱。或作是说。舒尼二十亿心偏在施众生。以此好施功德。所生之处常好惠施。意续不断。以是不堕恶趣。然菩萨者意偏在智慧。意甚勇猛不堕恶趣。或作是说。舒尼二十亿意在闲居。有信解脱。以此闲居之德不堕恶趣。然菩萨者修行道业。彼或时不堕恶趣。若失志便堕恶趣。若不失志不堕恶趣。便生天上。或作是说。菩萨者九十一劫不入恶趣。古昔经历出九十一劫无数生死也。尊昙摩多罗作是说。此诽谤语。菩萨方便不堕恶趣。菩萨发心以来求坐道场。从此以来不入泥犁。不入畜生饿鬼。不生贫穷处裸跣中。何以故。修行智慧不可沮坏。复次菩萨发意还三不退转法。勇猛好施智慧遂增益顺从。是故菩萨当知不堕恶法

  大王曩昔时　　持戒身口行
  罗汉瞿昙弥　　学不堕恶趣

以何等故。阿罗汉谓之福田耶。或作是说。心无垢着能供事彼者便获大福。如田除去恶草谷好滋茂。问于彼不敬当获大罪。此当言不善福田。答曰。不有福也。如稻田中善理恶草。设有一日种异草。故名稻田如实无疑。或作是说。心修行根力觉意。便缘善心生诸福业。是故阿罗汉谓之福田也。问不善心亦生欲使非福田耶。答曰。阿罗汉无有不善念缘其德业。何以故。恶缘不善念。然阿罗汉无有是恶。缘是非缘。或作是说。阿罗汉能使他有信。是故阿罗汉谓之福田。虽于彼生恶念者。意亦不移动。复次心当惠施诸法之本。是谓福田。彼生便长益广布在大果。是故阿罗汉谓之福田。于彼便作是念。彼非实福田。然实福田。虽复于彼造邪业事。不于中住随他邪事。若一揣施之福生善乐天处。于彼得种种宫殿屋舍。当一揣之施获尔所福耶。当非独一揣之施获尔所福。或作是说。当言一揣之施获尔所福也。何以故。所可由行生彼间者。此行种种宫殿屋舍。问云何一行得种种宫殿屋舍。答曰。众行集聚。或作是说。非一揣之施获尔所福。可缘善心所念法。以是之故而生彼间。彼行亦种种得彼宫殿屋舍。或作是说。非一揣之施得生彼间。持戒得生。亦作是说。施获大福。持戒生天。问如宫者说。缘一揣施之福。七生天上人间受福自然。答曰。以此因缘彼戒成就。是故彼间受福。设作是说。是揣施之报。七生天上人间受福自然。不以一行七反受福也。是故彼自然。如是不以揣施之报生彼间。此事如审一揣之施。复次揣施相应。彼亦在外无身根生。颇彼行是身根。展转相因增上生。因缘行相应。受种种果报。如一种行有增益。有种种藕华报。如彼画师作种种图像如实。以何等故。声无有报。或作是说。声有响报。报中间无有报。是故声无报。问心心中间生报。欲使心非报耶。或作是说。声现在合会而有声。然报不尔。是故声非报。问境界现在合会而有欲。使彼非报也。或作是说。声亦是报。世尊亦说。欢喜欲闻声便有是。答曰。彼声或欢喜或非欢喜。如今无有报。如二俱当有报。闻声亦当有报。问闻或时欢喜或时非欢喜。欲使闻非是报耶。或作是说。声亦是报。菩萨梵音大人之相。受诸行报实。问咽喉四大此是行报。以有梵音彼非受报。答曰。金色四大所造。欲使彼非报耶。复次声非报亦不非报。何以故。声是巧匠。有一心还贪欲所造生喜生忧。然报不尔。是故声非报。颇有杀生口行所摄耶。或作是说。如大王所说敕彼杀生。问身行口行则无有定。复次因缘口行而造杀生。杀害不得言口行所摄。于彼便作是念。云何今敕使杀人。彼有口恶行。若杀生者则有杀妒不尽。以杀害意便堕恶趣。颇有妄语身行所摄耶。或作是说有。犹如手印。口不发言有种种教引证时人。问亦无身行口行。复次无也。无有身行。彼便作是念。今云何手印及身行。当作是观。相行不等也。若于梦中修行十善。当言是身行耶。当言是口行耶。当言是意行耶。或作是说。当言三种。以三种行摄十善行。问若于梦中害众生。当言犯杀戒耶。复次当言是意行。意之所念于中便有是。如梦中见身行口行。此非为喻。若非法作法想坏乱众僧。若法作非想。何者罪最重。答曰。坏非法想斗乱众僧者。彼罪最重。问设俱作二法想。斗乱众僧者。二罪俱等。复次若嗔恚炽盛心发恶念。彼罪最重。又世尊言。三种德业施戒思惟。于彼比丘施者。戒为微妙。戒思惟为妙。以何等故。施戒为妙。戒思惟为妙。或作是说。施得大福。戒生天上。思惟离恶趣。微妙彼便生天。以生天离恶趣。复次以施恭敬相应获施之德。若施少与心有违。能使众生而使住戒。可使不可使众生自心解脱。是故施戒为妙。戒思惟为妙。如所说二种德业能所施。能食人信施。彼云何有所施。云何能食人信施。或作是说。若割己惠施是谓为施。若受施能消是谓食人信施。问云何得知有福德耶。或作是说。若缘施心是谓为施。若缘食施心。是谓受人信施。或作是说。若割己惠施心是谓为施。若缘尊心是谓食人信施。复次长诸功德。如随种福德种所缠络。或作彼福德增益。若施无厌足。数求方便。又世尊言

  种园果茂盛　　或作桥度人
  病则医药救　　昼夜获大福

云何彼获大福。或作是说。受施者得福。问云何知得大福。或作是说。由施得福于彼思惟。是故得大福。如前说

  善觉能觉者　　是瞿昙弟子
  昼夜勤苦行　　念常不离佛

彼不作余念。常思惟念佛。或作是说。如种谷子。或时茂好或时不茂好。福亦如是。一切作善福随时茂好。或作是说。如所说获大福。或作是说。如所说念获大福。复次于彼身得福。或时彼身于彼福渐渐以方便得福

  田业善处生　　二聚梦威仪
  何者最福重　　福谓之园观

若从果实天众生何塔(多廅反)鞞(净尼)天。彼当言与行缘故生彼天。当言以结彼生彼。或作是说。当言以行缘生彼。四禅微妙思惟得生彼。修行四禅而生彼间。是故当言以行因缘生彼。或作是说。俱以二事生彼受结使对。是故有结使名。便有行名。复次以行因生。世尊亦说。是故当言缘行生。又世尊言。于是不那(沙门)或有一人造恶续造身诸行。云何彼造诸身行。或作是说。身行有三种。下中上。于下为造恶。续造为上。造恶续造为中。观彼上者造恶续造。观下谓之造恶续造。若下者二俱观。谓之造恶续造。是故中有下也。造恶作身行。或作是说。趣三恶道。是谓造恶。生色无色界。是谓续造。欲界天人造恶续造恶也。处无定要造恶续造。作诸众行。或作是说。三种无明缘行。有福者无福者无漏福者。于彼无福行是谓造恶。无漏福者续造也。有福者造恶续造也。作诸福行是谓造恶续造也。复次人作种种行。无数处解脱。此不可一时而办一心所为。如一切恶趣而有三痛。以何等故。一切造恶续造耶。或作是说。不以恶趣生诸行报。或作是说。不于彼中间生诸行报。或作是说。不以积行而生彼间

复次诸等识盛而有定处。不更处有苦乐行。以何等故。天人之中作诸善行。谓之受报耶。或作是说。彼境界自尔。问或有恶微妙数。或作是说。善微妙数者言是我所。问恶趣之中亦有善言是我所。欲使彼善生耶。或作是说。若能拔济。彼无有恶结行由结生。是故不善遍在一切。问如所说戒生天上者此事不然。答曰。戒拔恶趣不善行结而生彼间。是谓戒生天。如所说五下分结尽。谓之生上。无有尽而生者。复次无有报生无记报。复次缘禅行而生。生因缘便有名兴。如此而生彼间。如方俗处所不得处所。于彼意而生心。以此而生彼。如是善报因缘生因缘。而有名兴则生天上。云何障行。或作是说。生诸悔心。以彼诲心而不障道。复次有贪欲处所。田业坏败。于彼所须田业尽为障蔽。如所说有五罪行。或有人无惭愧不耻众人。揵妄无志情意迷惑。此有何差别。或作是说。于此间或有人。作彼色像而思惟。一切无有惭愧。永住不惭愧心。已有不惭愧心加犯诸恶。于此间或有人无有尊卑。教授戒律亦不肯受。不润渍其心。重复更犯余罪。于此间或有人如其色像而思惟一切惭愧尽灭。住无有愧心。复以无愧心犯诸恶行。当于此间学。彼不复忆更犯余罪。于此间或有人不知当作是学。彼后不知更犯余恶。是其同异。又世尊言。不知迹解脱。不知迹解脱说。云何迹解脱。云何为迹解脱说。答曰。有二迹解脱。比丘僧目前。而说比丘戒清净与相应。是谓比丘迹解脱。比丘尼僧在目前。而说与共相应。是谓比丘尼迹解脱。此迹解脱有五相。于异僧前而说。而诵习读敷演使人奉行。是谓迹解脱。又世尊言。不解戒不解说戒

云何为戒。云何为说戒。问戒清净是谓戒。五种贤圣聚。是谓戒行。又世尊言。还众行比丘。便运集聚。属授人往行属授。云何为属授。云何为属授行人。或作是说。四部所行得四行。余残属授往行人。十部所行而十行。余残属授往行人。二十部所行得二十行。余残属授往人行。众所行事得众行。与戒属授往行人。复次若比丘德行成就。彼曰得行。病不堪任入众。彼谓属授人往行

又世尊言。于是目揵连深妙法中。渐渐布行渐渐学渐渐迹渐渐受诲。云何于深法中渐渐布行渐渐学渐渐迹惭渐受诲。或作是说。马师满宿之徒。于此间得信而修行之。听微妙法。闻法而奉行。观察诸法量诸法。应适不违身便受证。智慧分别以禅而观。或作是说。如所说揵那目揵连契经。身威仪口威仪。等命清净渐渐而学。根威仪念威仪。渐渐布行四禅。谓渐渐迹也。如是如来之教化。如是受训诲。或作是说。初将至戒场。再唱三唱四唱四行具足。是谓渐渐行。如是受具足。如是学增上戒。于彼增上心后。学增上智慧。如是渐渐学戒若学。是时初四谛所断结尽。便建道迹。后思惟所断欲界相应色界相应无色界相应。如是渐渐而知。此一切渐渐而知。如是渐渐受训诲。复次以色身说法。比丘叹佛叹法叹比丘僧。意堪忍心好喜。常不远离。不以口所陈。心净为净。当受归命。亦说初出家人戒律具足。本所造行去离非行。亦不及此。亦不及彼。如是渐渐布教。如是渐渐而作。渐渐佐助众事。增上律增上迹。解脱而说戒。如是渐渐布教。于彼学时随时学增上戒。随时学增上心。随时学增上智慧。如是布具足迹随行。彼时渐渐受训诲。是谓断灭。是谓受证。是谓住入。要如是受训诲

又世尊言。备十功德如来为沙门结戒。欲使增聚使增。善住不移。欲使增安隐。不信者令信。信者重令信。降伏恶人为惭愧。作导师于现法中教尽。尽有教未生众生。使尽有漏梵行之住。此有何等异。答曰。当学此戒本。无如来声闻众。便有所摄而不坏。与共相应等学诸戒说。当等说得等解脱同其一类。此何集聚义。当言有胜。故曰增集聚。作是学时。欲降众分别义分别法。欲使成就善住沙门妙法。故曰摄取增。学如是戒时。降伏众分别义分别法。欲使成就善住沙门法。故曰欲使增善住也

学如是戒时。降沙门展转无欲展转无怨展转不相恼。故曰欲使增安隐。学如是戒时。化自相未曾得喜今便得之。故曰不信者令信。学如是戒时。化自相已。得信重令增益。界不相干。故曰信者重令信。如不信者已生信重令修行。于中邪路众生导示大道。不越戒次。故曰降伏恶人。已降伏恶人。于中惭愧众生得恶伴侣无有苦恼。恶人何等异。以第三训诲第三。一切众生皆作是观。七事自相自相已。故曰欲使惭愧者安隐降伏。如是戒者于现法中于恶行中已自修行。故曰于现法中尽有漏教降伏。此戒便生善处。闭恶趣门戒律成就。故曰未生众生使尽有漏有漏。当言当作是观不。作如是学戒者。增上戒增上心增上智慧而不断绝。如是深法得久住。故曰梵行久住

  种种业所作　　如三善所障
  不惭现在戒　　嘱授及训诲

又世尊言。阿难今是汝过。汝作不善。云何三告汝而不答。吾使如来住劫。设当答者。如来为住劫耶。或作是说。如来住劫。然如来无处所。问今何故作是语。诸修行四神足。意欲住劫。亦能尽其劫数。答曰。现神足威力。问世尊若善修行而不住。云何现其威力。答曰。声闻住劫便能住劫。问若为声闻说。溺者则无有相根。或作是说。亦能住劫。复次为侍卫人能久住。亦不求索。设当请使住便住。至阿难得阿罗汉果。或作是说。若缘前请若缘后请。求世尊住者。然世尊不作是说。今云何作是说。先何以不说。譬如有人过他邦土。人便作是念。不请使住。设请使住者便住也。乃至尊者阿难得阿罗汉果。或作是说。若前请若后请。然世尊不住也。云何今作是说。犹如有人适他邦土。还时便有人告。若前请若后请而不住。设当语何以先不告语。或作是说。不住也。何以无处所。二阿惟三佛俱出世。于此劫中弥勒世尊当出现世。是故不住。此尔所事前以叹说竟。复次设尊者阿难不闻如来告。为魔所厌。世尊知魔厌。云何告语。乃至二三于中有何过。厌不能应答。彼便作是念。虽世尊告时未疲厌。于其中间魔便起厌意。是故不能应答。尔时告语无有力势。能后便作是语。我目前闻如来语承受奉行。云何疲厌而忆本所作。若世尊欲住者。是故修其悕望。欲化导众生故。如所闻阿罗诃弥勒授决。亦闻无有二三三耶三菩阿惟三佛而出现世也。以何故。当言使世尊住劫。此至三事。当作是观。以何等故十二入四善不善无记八无记。或作是说。四行报八是报非行。问意入非行。欲使彼是无记耶。或作是说。四与心相应与心俱起。问设今自然善不善。彼云何有起有方便或作是说。心自然善不善。彼相应心所念法及心不相应行俱起身口行。问彼如上所说涅槃无有善。复次色入者色不可坏。声入声不可坏。此因缘集聚如是便有善不善所作意相应。不住色声中。独无有侣。是故当观。若觉犯罪睡眠清净耶。或作是说。有如草五体布地而悔便睡眠。复次求请悔过。请众人解过作三行。便睡眠故眠不觉。颇有持戒不梵行。或作是说。有五戒优婆塞。以己妻为足。及余优婆塞奉贤圣戒。以己妻不净行。比丘者持戒精进。身威仪具足。然有淫意不尽而共相应。当言非梵行。及余比丘于贤圣戒精进。淫意未尽与共相应。当言非梵行。若阿罗汉已般涅槃而供养。当言彼得行报耶。当言现在有其功力。或作是说。当言得行报。若先已作福德。彼便得供养。若本不作福德。彼生存在世求食难得。说当获供养。问云何今受报。复次现在方便所造。诸于彼功德具足者。彼方便所造。如空中不可受报。如世尊言。犹如有人。于此间不承受请问已。此因缘报故作如是行。作如此事。生恶趣入地狱中。若还生人间无有智慧。此是何行报。或作是说。已愚痴故。彼不请问事事不明。便堕恶趣。复作是说。不请问时意谓清净。此是戒盗苦谛所断。复次如此坚信常奉持法。于中生诸方便。是伴非伴而示现道。以此深法中信契经阿含深语。不于中忍有诸方便。如是阿毗昙阿含微妙三语身证之教。不于中而作方便。如是禁律阿含微妙之语而信趣向。不于中作方便。复以此法疑无智慧。此是智慧之路。设不请问趣恶道者。彼便住世满此众生。又世尊言。彼身恶行口意恶行各相牵速。云何行相牵速。或作是说。见有恶行亦见瑞应。命过时便作是语。见火炎起见狗犬。若善行命过时便作是语。我见天宝宫殿屋舍。见诸园果。或作是说。有诸缘报。有此瑞应行。是谓恶是谓善。或作是说。报渐观近怀诸悕望。如观近无善觉知成败。是谓缘无义行牵速。或作是说。于恶趣沉没。设心亦覆蔽。是谓牵速。复次云何缘过去行。复次如此恶行意便好喜。当于尔时便有证有验。亦见诸疮痍结使遂增恶行

又世尊言。于现法中便有悔意。彼悔意当言善耶。不善耶。当言无记耶。或作是说。当言善。恶自见恶于彼作恶行念。问不于今堕恶趣中。答曰。彼善少不善力大。复作是语。与少善生于善处。如所说得善心念法与等见俱。或作是说。当言不善。与邪见相应。虽复忆念后更忘失。所不应忆者后便忆之。是故当言不善。复次云何世尊说。譬喻与不相应自不相应。此非譬喻也。一切作恶行者。则有悔意也。能自修已则生天上。世尊亦说。设彼悔者亦是善心。云何善心无善命过。若悔是不善者。云何不善心多彼智相应。若悔是无记者。云何无记心无善命过。是故此非佛语。以何等故。未来教不得成就。或作是说。不以未来教而有教耶。问过去教者亦无教。欲使不成就过去教耶。答曰。教已过去。问未来亦当有教。复次虽不作行便有所获。如是无行而有果实。于彼便作是念。云何今不思惟。亦有福德。彼当作是观。又世尊言有缘生。云何有缘生。或作是说。中阴中五阴是谓有缘生。或作是说。所生五阴是谓有缘生。或作是说。已处母胎是谓有缘生。或作是说。所生五阴诸得行缘而受报数。是心将从受诸色报。命根心不相应行。是谓有缘生。复次趣恶生者最初得有。是谓有缘生有。有则有生

  礼彼诸眠觉　　供养或罗汉
  不问魔所厌　　告语不还缘

以何等故。本所作行谓之一结缘。如今无明为所作行。是一切行缘。或作是说。如今过去一切缘。过去亦是一切结缘。复次过去最要言之。现在广说现其善教。问不如彼一切结缘。或作是说。本所作行一切结是缘。过去无明声。已说与无明相应。现在所造声与无明相应。现在所造声。已说无明造声相应。问不以现在无明声。作是说与无明相应。或作是说。生无智力少足故。譬喻众生示现。若行无明于此生是缘。由结故生诸行。是故譬喻众生现在若行。问彼回转譬喻众生现其善行。过去之时一切结是缘。复次结结相生行。缘其根生彼结。彼结彼各相应。结由行生。行由结生。行由行生。谓无明缘行生。结缘行生。复作是说。爱缘有行已。炽然作诸行。当作是观。以何等故。色界无垢人。谓之成就无漏戒。然非有漏。答曰。此不舍贤圣道。便成就戒。界界游已灭世俗事。界界游行。无有无色界无色界定戒。是故不得名成就。以何等故。行报故生无色界天。或作是说。以无想三昧众生报故也。问无想三昧亦非心亦非心所。念法云何。由是报故生。答曰。无想三昧有漏善心不相应行有报。问设彼三昧有报。彼不与行相应。世尊亦说由行而生。或作是说。若于心中间入无想三昧。缘彼心报生无色界天。问云何若于心中间入第二禅。缘彼报生光音天耶。或作是说。无想三昧无心。无想三昧相应心报而生彼间。无有无想三昧相应心。何以故彼无有想。世尊亦说。彼想有教无教有心教耶此无处所。复次无想三昧彼则有。是不由行而生彼心。亦无行方便。世尊亦说。由行报而有生。复次无想三昧心相应心所生报是缘。能作是住。如生无想界天。如善御车人所向无疑。如报缘除其报则受其有。颇缘灭尽三昧报生有想无想天耶。或作是说。彼三昧有漏之有报。非有想无想天。更受生缘。是报而生。问灭尽三昧亦不与行相应。世尊亦说。由行而生。或作是说。灭尽三昧有心。是故灭尽三昧相应心报故。生有想无想天。问无有灭尽三昧心相应痛。何以故彼无想世尊亦说。彼有想无想心觉当有觉。亦无处所。或作是说。不生也。何以故。已越有想无想天。以灭尽三昧。不以妙三昧报故生九地也。问彼地灭尽三缘是果报而生彼间。问如所说越有想无想天。入想忍三昧则有彼地。亦说尽越不用定处。修有想无想定。彼亦是不用定地。问灭尽三昧入是三昧。不以贪欲故。欲爱未尽。入有想无想三昧。非不欲尽。不用入处有想无想定。复次如所说灭尽三昧无有心。彼则有是也。彼无有报无有心。复次有想无想天灭尽三。昧报而受。彼三昧非报缘。又世尊言。欢喜施者。便得欢喜。从心所好。施真正处(偈也)。云何观是欢喜。为观受者。为观施者。或作是说。当观施者。从物因缘若施彼时。彼则受报也。问设彼受者有福欢喜。答曰。彼非真正处。亦说从心所好施真正处。或作是说。从檀越心如郁伽长者说。是谓如来二端[疊*毛]我所爱者。愿世尊纳受。以大慈故而不见逆。我从如来闻。欢喜施者。便得欢喜。复次当观施者意。从施[疊*毛]时便作是念。我今割意施。作是心已受大报。如尊者舍利弗说。若行后世受报者。彼不可得现世受报。设行现世受报。彼不可得后世受报。世尊亦说。或有尼揵子。若行现世受报。彼不可得后世受报耶。设行后受报。彼不可得现世受报。如是尼揵子辈愚痴尽无果实。说是语。其义云何。或作是说。尼揵子作是见。行尽苦尽行尽。谓一意识。不可得后世受报。行现世受报痛。若彼愚痴尽无有果实。于此法中垢尽苦尽。若道生时灭诸结使。若无愚痴无有果实。问若于此法中不尽行本。不得般涅槃。亦无有上。答曰。如阿罗汉速疾受报。问如所说契经则有违。或有阿罗汉。行报渐薄。不相应果便灭。若阿罗汉能行报者。亦能广博诸行。或作是说。犹如彼行实在者。彼行道亦复实在。或作是说。诸行实在便有集聚。设行不实在者。可使作集聚。复次此非行报义也。于深法中不失深法。如其义理游戏。其彼义无有疑。彼作是念。如今云何后身受报。当作是观。如是阿罗汉不得众行而受报也。以何等故。祭祠饿鬼得然不及余趣。或作是说。此生趣自尔。问此是我疑。何以故生趣自尔耶。或作是说。饿鬼嫉妒心意便颠倒。河无河想。见水不净及诸饮食浆水。若饿鬼祭祀饮食。便发欢喜意心不颠倒。若彼饿鬼得增上行时彼受食。或作是说。饿鬼以嫉妒意。彼不能作好境界。若彼饿鬼有所祭祀发欢喜意。于彼得好心游好境界。或作是说。饿鬼以嫉妒意身体长大心常懈疲。以懈疲心不至神妙饿鬼所。若彼饿鬼而祭祀食于施发欢喜心。便得身大心广。以彼心广大故。得游诸大饿鬼所。彼亦归伏礼跪。以身大故。彼饿鬼得增上行。于彼受食。复次与人作福彼人不得如饿鬼与彼施食者。饿鬼善心好施。彼便受行若彼饮食。是故非余趣。诸心与身行俱起。口行俱起。当与心共同耶。当言不与心共同。或作是说。当言与心共同与心俱起。问云何心不与行同耶。或作是说。当言不与心共同。本所生心与行俱起。若不生则不有起。是故当言不与心共同。或作是说。或与心共同。或不与心共同。诸与心回转则与心共同。诸不与心回转则不与心共同。复次缘彼有心行有回转。亦各相摄。先有回转便有所摄。行与结有何差别。或作是说。行是身是口是意。然结是意。问若行是意。与彼结有何差别。或作是说。行是善不善无记。结是不善。问若行不善。与彼结有何差别。或作是说。意行意行。结亦不意亦不不意。问云何意无有报耶。复次一切心所念。当言皆是行。然世尊视若干种行渐渐有疑。云何无虫便有杀意。或作是说。如无有虫便有杀虫之想。如无虫便有杀害意。若有虫处彼无有杀意。何以故。彼虫或有常或无常。设有常者。亦不能堕此无有相。设有常者。如是得断灭。复次所造五阴作虫思想。便言我尽形寿不杀。若越彼意者行各散一处。是故彼便有害想。若于彼虫便有杀意。何以故。由彼虫故。因缘合会则有差违。设不差违则不能有所起。若有差违则有所起。云何不有所起则有所起。若有违不得无违者不得。无有力能起。若得有所起。云何起无差违或不能起。又世尊言。有四不可思议。世间不可思议。众生行报不可思议。及佛境界不可思议。以何等故。此谓之不可思议。或作是说。方便力少不足思议。或作是说。无有余方便作如是知。如佛世尊或作是说。不可思议深妙难究是故不可思议。复次作我思议者成狂。愚痴思惟心亦乱。众生行报及佛境界。非己心所了。亦不可观

  无明无色界　　及彼无垢人
  无想及灭尽　　舍利弗饿鬼
  种种诸根相　　众生难思议

诸入不善三昧。彼尽犯二罪耶。或作是说。诸犯不善者。彼尽犯二罪。犯彼罪时成五逆。问云何犯五逆时不犯二罪耶。复次唯犯一罪。何以故。世尊说有五罪。若犯不善罪时而犯二罪。作是广说而思惟说。一时彼无罪。是故犯一罪。若转轮圣王女宝得色声香味。当言由行报得。当言不由行报增上得。或作是说。当言由行报得。问云何余行报余者受报。答曰。女宝者由行报故彼便得。若彼得彼王得是报。复次由行增上得。若由行报得。不作行而受报。女宝则有坏败。转轮圣王不由他行受报。斗乱僧若斗乱僧。当言一劫入泥梨耶。当言中劫受泥梨罪。或作是说。当言一劫受泥梨罪。世尊亦说。斗乱僧经历一劫。问已过半劫。云何全受一劫罪。答曰。余方刹土至彼泥梨。如犯罪重之人。数移徙入深狱。然后脱其罪过。若复受劫罪。一劫泥梨中受罪。问泥梨受罪之人无有此理。至他方泥梨受罪。命未尽便死。或作是说。二十劫中及四劫劫大劫。二十中劫受罪。是谓一劫受罪。若劫融烧时。便生二十中劫。云何彼经历尔所时。复次当中劫受泥犁罪。无有欲界众生受一劫之寿。诸斗乱僧彼一切住一劫受罪耶。设住一劫受罪者。彼一切斗乱僧耶。或作是说。诸乱僧彼一切一劫受罪。破坏僧者最重之罪。或作是说。斗乱僧非住一劫受罪耶。若坏乱意而斗僧者受五逆罪。复次或住一劫受罪。彼非斗乱僧现其报。或斗乱僧及一劫受罪耶。若非法坏斗乱意而坏僧者。或不斗乱僧。亦不一劫受罪耶。除上尔所事也。斗乱僧当言性受罪。当言非性受罪。或作是说。当言性受罪。何以故。斗乱僧最重之罪。若此非受罪者。云何今性受罪。问诸斗乱僧彼一切受无救之罪。问如杀生者性受罪。诸不杀害受罪。害罪如是。斗乱僧性自受罪。诸不斗乱僧。彼一切受无救之罪。复次当言非性受罪。何以故。僧成就斗乱罪。然非无救罪。诸恶行斗僧。彼性当言受罪也

又世尊言。意行者最是重。如法慧契经言。一行最是重罪斗乱僧。非意行斗乱僧也。说是语其义云何。或作是说。一切行最是重罪。除其五逆。及余行意行最是重罪。或作是说。意口行思惟。彼行已口行。彼最第一。意行意行最是重罪。思惟行斗乱僧最是重罪。复次不于中间意行有斗乱僧。非彼思惟而斗僧。诸恶行斗乱僧者。当言彼最是重罪。以何故。非灭五人不得斗乱僧。答曰。必当有二部僧。敕使如调达斗世尊声闻众。彼坏凡夫僧。不能坏贤圣之人。问今不受五逆罪。答曰。作僧想而坏凡夫众受五逆罪。如父作父想而杀害其命。受五逆罪。问若今世尊说斗乱僧受一劫罪。答曰。此世尊教戒语。调达作是想我坏僧。或作是说。比丘众谓之比丘僧。于彼凡夫人敕使斗乱。或复贤圣人在世尊侧而不能坏乱。或作是说。有十四事斗乱之章。无垢人不可坏败。不能坏世尊。是故世尊不可坏。复次世尊声闻众内无垢人。外凡夫人于彼坏外凡夫人众。内无垢人不可沮坏。是世尊众不可沮坏。以何等故记之。结言无报耶。或作是说。无记者即无报也。或作是说。彼不于身体有所长益。或作是说。不化身口意行。复作是说。无记心所念法。自凭依有是苦恼。摄持诸法而有报也。复次无记无报法亦是有报也。如所说我今不行。乃至不知为趣何所。而见光明。云何是报。复次诸善不善法。或有因或有缘。有诸果实。于彼作报想。无记之法或有因或有缘有诸果实。是故无记法而有报也。须陀洹性有瑕罪。当言性无瑕秽。或作是说。无有瑕罪。瑕罪者现诸秽病。或作是说。无有瑕罪。瑕罪者现诸秽病。或作是说。无瑕罪依善不诤。复次当言有瑕秽想。心邪见未灭

  犯罪乐斗乱　　住劫及性罪
  不灭五坏众　　无记性净行

酒浆者。当言性罪。当言非性罪。答曰。当言非性罪。何以故。若饮酒者。淳酒有余教以入腹。若服咒术饮食术。当作是观非梵行。当言性罪。当言非性罪。或作是说。当言性受罪。不于中间结秽有其梵行。复次当言非梵行。心是其罪。性染污观。复结兴起当言有罪。性罪者其义云何。或作是说。性染污是谓性罪。复作是说。性不善是谓性罪。复次性有瑕秽是谓性罪。非性罪者其义云何。答曰。不染污是谓非性罪。复作是说。性常不善是谓非性罪。复次非性有瑕是谓非性罪。颇有比丘。四事之中各无所犯。然不舍戒而就白衣。当言非比丘。或作是说。有人根变易根已变易。当言非比丘。或作是说。因缘果实邪见而现在前。若布现示人。是谓当言非比丘。或作是说。若自长养此比丘非比丘也。彼若勤修戒行于中移转。云何当舍戒而越戒律。复次有所悕望。悕望者流转生死。当言于比丘法退转。若无教诲也。又世尊言。若比丘于比丘受衣裳。入无量心三昧而思惟之。彼果报无量。施主檀越福增益善增益。善食无病。是谓自作。余者不受耶。答曰。非自作余者受报。复次施主檀越所受之德。问云何不成就而受其福。答曰。由田业润厚。于彼种谷子。若种人忆田好不好。必获好谷。问此亦不相应。云何于田种子不于三昧檀越有其德。复次有彼人受彼信施。施主檀越得其处所。便有福德长益。是故不可沮坏。无嗔恚之体。彼便有休息根心意欢喜。受施之人不堪任施。施者自受福。又作是说。以此法施彼彼为谁得。或作是说。无有得者。是谓不与取。复次受施主之语。此何由施。若依比丘者彼则有所还。若于道果。道果受其教诲无有所还。又世尊言。摩纳众生行。由与由行所造。由行因缘。由行施为众生。由行成若好若丑。说是语其义云何。答曰。自所造行受其果报。众人不牢固。如所作行便受其报。是谓行因缘受其生报。行若处处生。在在受其报。是谓行胎生。若舍其行有若干相。若舍其行此众生如上所说。众生有上下。是故行众生有所演说。若其有好有丑。有何行故。若本劫众生自然食身能飞行。或作是说。于欲界爱尽。诸欲界炽盛善根。由其果报也。问今亦不有所现耶。或于彼种善根之中。果报有自然身能飞行。答曰。众行备具彼果不得生实。复次由生因缘行报因缘。有如是对。于彼自在施所造得。彼则身能飞行。由彼施主之德方便。彼则有头光明。诸尊重梵行者。病痛遭困厄车马施。彼则身能飞行

  饮酒其犯邪　　性犯最重罪
  飞比丘游行　　行自造人后

尊婆须蜜菩萨所集行揵度第九竟

    尊婆须蜜菩萨所集智揵度首

又世尊言。彼于不净修念觉意。云何于不净修念觉意。或作是说。计意作不净想。挍计身中而修念觉意。如是于不净修念觉意。或作是说。觉意分别不净。觉意中间入不三昧。不三昧中间修念觉意。复次相各自有义。当作是观。然不与不净念觉意相应

又世尊言。比丘汝等当修护。比丘若修护已尽断除欲界爱。尽色界爱。尽无色界爱。尽于此憍慢尽无明。云何修护。或作是说。诸觉意四禅四等。或作是说。修无漏四禅。或作是说。护觉意不忘失。复次修道得诸果实故。于此说诸所生即灭常得护也。于欲界爱尽等。越次取证时。云何修断欲界相应结。思惟所断而修行道。或作是说。彼不尽便修行道。彼本以尽已世俗道。问四谛所断结已尽。世俗道欲使彼尽不修道耶。修道法忍。是故思惟所断尽而修行道。答曰。彼非四谛也。断修法忍也。以贤圣谛起此道。问若四谛所断已尽不修行道者。不以彼结世俗道永断结使。是故见谛人不究竟尽。或作是说。彼灭未来结。问欲界爱尽等越次取证。以未来所修以思惟断。答曰。彼不得思惟断道。设得是时世间思道。若知彼力契经者。或作是说。未知智中间起思惟道。问彼不实有阿那含须陀洹得禅。答曰。进前取阿那含。是故修行道谛。便得阿那含。然须陀洹不得禅。复次二种结已尽。思惟彼二种事。修行二事。有二智修行。于彼爱尽等越次取证。无量之事皆悉具。净修其心。作如是行道。以三界结四谛断欲界相应。用思惟断修行谛圣。住阿那含处。彼时亦作是观。欲界相应结使用思惟断修行道时。诸得未来善根。当言灭诸结使也。或作是说。当言断灭。问云何以未来道灭。答曰。未来之道便有力势。现在不灭也。诸有力势生彼则能灭。如是未来之道。有力势生彼则能灭。复次当言彼不能灭也。以未知智所领。当言用思惟所断以世俗之数。彼非身所习出要。以何等故五盛之阴。不言是想意止。或作是说。法意止所摄。当言想身意止色阴所摄。痛意止者。痛阴所摄也。法意止者。想阴所摄也。行阴者此无为也。复次心意止所摄。当言是想也。身身相观痛痛相观。于痛思惟一切心处。所作如是。观法意止者。合数之义。于阴垢着染污。当作如是观。须陀洹住果实心。于三界中当言成就等智。当言不成就等智。或作是说。当言成就。何以故。善根者。以二事灭不相应果灭缚着。于彼若去离界。然须陀洹不退转越彼界。是故当言成就。复次觉知三界时以舍等智。复次空于空。无愿于无愿。无想于无想。当言成就也。彼不舍意也。又世尊言

  法园观浴池　　婆罗门异学
  闲靖无垢浊　　与诸真人俱
  我浴神诤讼　　不渍体灭恶

说是语是义云何。答曰。贤圣沙门津。于此义中法园观浴池也。彼不颠倒结已尽。心枝叶诸垢永尽。谓之法也。不顺从戒是谓戒。梵志未越不善根。观彼不善是谓闲静。无秽无浊。于佛声闻发欢喜心。是谓与诸真人俱。成就等智分别等智。觉知深义而入其中。是谓浴神心。无有垢秽。亦不作是想。或作是说。灭本恶心。不作是想。是谓不渍身灭恶也。以何等故空缘有漏耶。无愿者亦缘有漏亦缘无漏。或作是说。空者缘苦谛缘有漏。无愿者亦缘苦谛。亦缘习谛。亦缘道谛。是故无愿亦缘有漏亦缘无漏。复次各自凭已。亦不自觉。亦不得无漏法。是故空缘有漏也。现有所失能知弃舍。尔时无复有愿田业之想。如群鹿惊四面无有障碍。于中无愿亦缘有漏亦缘无漏。世俗上无我智有何差别。或作是说。世俗为下增上为世俗上。或作是说。一切无我智是谓世俗上。一切顺越世俗。复次诸分别晓了是谓世俗。诸不晓了彼谓之世俗上。复次世俗无我智。作识别观方便。非方便有如斯事。作是思惟。彼自相彼无巧便。无我自度视世俗上。以何等故未知智非缘欲界。或作是说。法智已作缘。问忍已作缘法智不作缘。或作是说。现有法智悬思未知智现有欲界。是故而不作缘。问欲界之中或有现或无有现。色无色界或有现欲界爱。复次此不相应。世尊亦说。彼以此法见知自过去未来。将往是谓往。是谓当言未知智。是故有未知智缘欲界

  觉意而敷演　　欲界根上阴
  须陀洹法空　　差别若干界

以何等故。生终世俗智便忘失。然非世俗上。或作是说。世俗智富足。以智相佐世俗上智者。亦富足以彼相佐而不修行。或作是说。垢力势大非世俗智。以垢所缠。然后世俗力大非结。不为结所缠。复次作世俗智想作等想。现有所说。世俗上智者。作无想与相应如实义。因长益处所缘得其章义。依彼有功德不可沮坏。以何等故。阿罗汉谓之不成就学法耶。或作是说。此已舍学法游果果行。或作是说。得无学法则不成就学法。此之谓也。或作是说。若成就学法者则是其学。若成就无学法则无学法也。复次根度无极则有缘果。度无极果度无极缘入度无极。于中阿罗汉当言不成就学法。彼则有此不如意。亦不学亦不不学。法不成就也。当作是观。当作限量世俗之法学无学法也。以何等故。四辩才二界有漏二于三界无漏。或作是说。不于此色界中名身句身有所系。有所敷演所有无漏智。是故二界有漏也。复有无色界第一义不回转智三昧。入彼三昧不回转智。若无漏智回转者。然此三界皆悉无漏。复次无色界无有辩才。然辩才非有漏亦不生有漏中间有漏以何等故。六通三有明三非有明。或作是说。一第一义明尽有漏二。便招来得其明声。或作是说。阿罗汉因果报智明。自识宿命知。我从某处终。缘此因缘而生是间。因果报者。微视通我某处终。由此因缘当生彼间。因果智而知。尽有漏智者。我已此道而尽有漏诸因果报智。复次第四通自知所从来。第五通知始生智者。第六通与共相应。是谓智尽有漏。若相应智者。彼第一义明初通者。知诸伎术。第二通者摄持诸声。第三通者而观自相。如此三解脱门空无愿无想。以何等解脱门等越次取证。答曰。空无愿生便能越已生。当言等越次取证。如得分别智。以何等故。未知智不与同缘色无色界。或作是说。一时敷演见谛所断结。问此亦是我疑。何以故。二界见谛所断一敷演。然非三界二界有何差别。一见谛所断。然非思惟所断。或作是说无常苦空无我。问三界集聚是谓无常。或作是说。不现未知智。彼可量现在前。问欲界少有现色。无色界不现。是故现非义。复次是谓三界等越次取证。是谓当言未知智。此是其道等越次取证。忍与智有何差别。或作是说。忍能忍事智能知物。问无智者能忍乎。忍时有智耶。或作是说。忍为下智为上或作是说。尽道为忍道果为智。复作是说。断道为忍解脱道为智。复作是说。断道为忍无所挂碍为智。复次如行道人不能前进。便自劝勉安隐到处所。如是等越次取证。先得智慧眼导引为忍。越彼岸为智。忍为下

  诸不忘学法　　分别觉意门
  来生及分别　　忍法是十经

用何等故以忍断结。然不用智或作是说。道已生便断。是故忍断结。忍已能舍。是智不能断。忍无不断结。或作是说。尽道为忍。道果为智。然非以道果断结。是故不以智断。或作是说。尽道为忍。解脱道为智。非以解脱道断也。是故智不断。复次见地见谛所断结。尽道障道不等道断也。此相应是故忍断。以智覆不生。当作是观。以何等故。尽时忍断结断。结非生时。或作是说。尽时忍现在道断结。是故尽时忍断结。若忍生时道未生则不能断。是故生时不断。问若生时忍不断结者。彼不有违耶。答曰。然生时忍不断者。如是彼则不有违。所以生断。是故彼相佐助。问若自观者忍已生。彼便自灭无生无复闇冥。复次若所生忍灭结已生。当言便尽。犹如然明闇冥悉除。问若所生忍灭当言是结耶。已生道未知忍。一切见谛所断结尽。是故忍成就须陀洹。答曰。一切见谛所断结尽。不以智集聚名须陀洹。何以故。不以此有为得须陀洹果。如世尊说。于是比丘诸观五盛阴如实而知。是谓须陀洹。不以见苦名须陀洹。亦作是说。三结尽名须陀洹。不以忍集聚名须陀洹

又世尊言。比丘说一切结时。四意止等说而说。世尊亦说。说善聚比丘时。四意止等说而说。然一切诸法非善说。是语其义云何。或作是说说一切法时。四意止等说而说道有缘。以是故说善说善聚时。四意止等说而说。亦由道说。复次说一切法时四意止等说而说。由八正道三十七品。以是故说。说善聚时。四意止等说而说。第一义聚善聚。由是故说。诸如来相义起微妙智。诸声闻亦有此微妙智耶。设声闻有此微妙智。彼是如来相义起微妙智耶。或作是说。诸如来相义起微妙智。彼相义声闻有也。起微妙智。诸众生类。于彼如来声闻起微妙智。如彼智境界回转时。复次不应作是说。众生微妙智心智慧欢喜。有其誓愿微妙智者。彼声闻渐渐而智现在前。如来者于智得自在心思惟心。三昧清净。于欲便能无有挂碍起微妙智。以何等故。四意止无身意止生耶。或作是说。意止无有思惟渐渐而至。复次渐渐有益。如来之教渐渐讽诵承受者。复次身身相观作诸意。痛痛相观流行。痛痛相观作诸意。心心相观有流行。心心相观作诸意。法法相观有流行。如是渐渐修意止。以何等故。七觉意中谓先谓念觉意耶。或作是说。次第言之。复次如来次第所说。为诵者所说。复次念觉意先现在前。为人次第说修说觉意。如所说如彼所念法选择诸法。亦复观知味诸法。于彼法选择。亦复觉知诸法之时。便有勇猛发欢喜意。意盛不少无有异身。心有所猗受乐使。三昧观其心意。以何等故八贤圣道。先谓之等见。或作是说。贤圣道不审修行。复次如来次第说。为诵者所说。复次等见为人次第行道。犹如一切四神足中。以得自在精进心定。以何等故。一切自在三昧尽行成就是谓四神足精进三昧心三昧。三昧尽行成就。是谓神足。或作是说。诸增上起诸三昧。彼彼所说。如所说比丘自在增上得诸三昧。彼有自在三昧精进心比丘增上得诸三昧。彼则谓三昧。复次如此诸事转增。以三昧定。或时禅三昧增得自在。起诸自在自在回转。或时精进增起诸精进精进回转。或时心增起心心心回转。或时味增起味味回转。于中说四神足便有增上。五根五力有差别。或作是说。增上为根义。不可沮坏为力义。复次外种力当观修根。内种力当观修力。于彼修行人诸根不牢固谓之根。不可沮坏谓之力

又世尊言。犹言一信。余或从余处闻。或觉诸种以见观人。复次有智不可坏智。此处不然。说是语其义云何。或作是说。须陀洹种于彼心。欲亲近善知识。何以故。由信生欲礼拜承事。从彼闻现说法言得知诸种。思惟恶露。见诸禅现法法相生义。复次先有所闻。如一切诸行无常也。于彼智得诸信。由有信便有智慧。善亦智慧如其实义。彼谓之欲。欲义者已智摄。彼好丑观诸行挍计算数。如其实义起智慧眼。如忆彼诸法见诸忍

  二忍一切法　　诸种身为初
  觉意见所堕　　种种及余处

以何等故。以苦种等越次取证。然不由恼疮痍。或作是说。疮痍有漏。然非有漏道等越次取证。苦种无漏。以无漏道等越次取证。复次疮痍种者。界柔差集聚渐渐兴起。苦种者。以苦阴相应。作如是观。苦种疮种痍种有何差别。或作是说。苦种疮种痍种有漏。苦种无漏。复次苦种切身之相。痍种疫疾之相。疮种起漏之相。以何等故眼根谓之见耶。或作是说。是世俗所见语。如有见净有见不净。复次还眼便有所见。世间契经是谓眼根谓见。以何等故忍不谓智。或作是说智能知事忍不能知。是故忍不谓之智。复次已得见是谓有智。非以忍有智。是故忍非智。以何等故。尽智无生智不谓之见。或作是说。若尽智无生智是见者。则九种成就阿罗汉。亦说十种成就阿罗汉。是故彼智不谓之见。问如无学等见谓之智。有其定处。云何彼非智是见耶。彼亦有行处。复次智当见度彼岸。为见彼所度。便有是。云何不十种有定。当言是观八种为地。如此智当言无学法。犹如此三解脱门。空无愿无想。等越次取证当言得已。起等越次取证当言得。答曰。空无愿等越次取证当言得。以越次取证当言得。无想者已越次取证当言得。若空三昧时彼修无愿三昧耶。设修无愿三昧。彼修空三昧耶。或作是说。或空非无愿。云何空非无愿。已得空三昧现在前。是谓空非无愿。云何无愿非空。已得无愿三昧现在前。不得无愿三昧现在前。不得是时修空三昧。是谓无愿非空。云何修空无愿。不得空三昧而现在前。得是时修无愿三昧。不得无愿三昧而现在前。得是时修空三昧。不得无想。不得世俗智而现在前。得是时修空无愿三昧。是谓修空无愿三昧。云何不修空非无愿。本得无想三昧而现在前。若本不得无想三昧而现在前。不得是时修空无愿三昧。本得世俗智而现在前。若本不得世俗智而现在前。不得是时修空无愿三昧。一切凡夫人染污心无记心。灭尽三昧无想三昧无想天。是谓非空非无愿。复次或空非无愿。学见迹若阿罗汉。得空而现在前。或无愿非空。修行习忍智回转时。道法忍回转时。道法智修行回转时。道未知忍回转时。学见迹若阿罗汉。得无愿三昧而现在前。或空无愿修行苦时。忍智回转修行法时。道未知智回转时。学见迹若阿罗汉。不得空无愿无想而现在前。或非空非无愿。三昧修行尽时忍智回转。学见迹若阿罗汉。本得无想三昧而现在前。一切世间心思惟。不修空不修无愿三昧。于中亦有降伏想。若修空三昧。彼修无想三昧耶。设修无想三昧。彼修空三昧耶。或作是说空非无想。云何空非无想。得空三昧而现在前。若不得空三昧而现在前。不得是时修无想三昧。不得无愿三昧而现在前。得是时修空三昧。云何无想非空。得无想三昧而现在前。若不得无想三昧而现在前。不得是时修空三昧。云何修空无想。不得空三昧而现在前。得是时修无想。若本不得无想三昧而现在前。得是时修空三昧。不得无想三昧而现在前。得是时修空三昧。不得世俗智而现在前。得是时有空无想三昧。云何非空非无想。得无愿三昧而现在前。不得无愿三昧而现在前。得世俗智而现在前。不得世俗智而现在前。是时不得修空无想三昧而现在前。一切染污心无记心。入无想三昧灭尽三昧。不修空三昧非无想。是谓非空非无想。复次或空非无想。修行苦时忍智回转。学见迹若阿罗汉。得空三昧而现在前。或无想非空。修行尽时忍智回转。学见迹若阿罗汉。得无想三昧而现在前。或空无想。修行道时未知智回转。学见迹若阿罗汉。不得空无愿无想三昧而现在前。云何非空非无想。修行习时忍智回转。道未知智周回修行道法智。道未知忍回转时。学见迹若阿罗汉本得无愿三昧。一切世间心思惟不修空无想三昧。不于其有降伏。若修无愿三昧。彼修无想三昧耶。设修无想三昧。彼修无愿三昧耶。或作是说。或无愿非无想。云何无愿非无想。得无愿三昧而现在前。不得无愿三昧而现在前。是时不得空三昧而现在前。是时不得修无想三昧。不得空三昧而现在前。三昧而现在前。不得无想三昧而现在前。是时不得修无愿三昧。云何修无愿无想三昧。不得无想三昧而现在前。得是时修无想三昧。不得无想三昧而现在前。得是时修无愿三昧。不得空三昧而现在前。得是时修无愿无想三昧。不得世俗智而现在前。是时修无愿无想三昧。云何非修无愿无想三昧。得空三昧而现在前。得世俗智而现在前。不得世俗智而现在前。是时不得修无愿无想三昧。一切染心无记心。无想三昧灭尽三昧无想天。修无愿无想三昧。是时谓不修无愿无想三昧

复次或无愿非无想。修行习时忍智回转。道未知忍回转时。修行道未知智。道未知忍回转时。学见迹若阿罗汉。得无愿三昧而现在前。或无想非无愿。修行尽前忍智回转。学见迹若阿罗汉。得无想三昧而现在前。云何无愿无想。修行道未知智回转时。学见迹若阿罗汉。不得空无愿三昧而现在前。或非无愿非无想三昧。学见迹若阿罗汉得空三昧而现在前。一切世俗心思惟不修无愿无想三昧。于其中有降想。若应时修空三昧。彼时修无愿三昧耶。设应时修无愿三昧。彼时修空三昧耶。当作是说。如上所得然不及现在前。复次若应时修空三昧。彼时不修无愿三昧。设便应时修无愿三昧。彼时不修空三昧。何以故。时节回转。当作是观。空无想亦复如是。无愿无想亦复如是。以何等故。三界修行等智谓之有漏耶。或作是说。即彼三界所有。彼是有漏也。或作是说。所谓等智是以有漏也。或作是说。如彼智谛得不如彼谛此。当修行。复次三界所修等智。师意作是想。譬如空无愿无想。于无想故。曰修于彼作是想。当作是观。以何等故。色界不等越次取证。或作是说。彼无有此厌患之法犹如欲界也。问不以此患等越次取证。设有患者。恶趣中亦等越次取证。或作是说。欲界有是行报。问若于欲界取般涅槃。云何有色无色界行报耶。答曰。欲界受报。问有何因缘。色界无色界行报。非欲界受色无色界行报。或作是说。以其软根不等越次取证。问犹如此间利根而生彼间。云何彼间有软根。答曰。彼生自尔。问非色界无垢人起贤圣道耶。答曰。已得能起。问不得无学道能起。复次便有降伏想。复次于此间作行。命终生色界。因相有力故。彼不等越次取证。若最初起无生智。为几智中间起。或作是说。或尽智中间起。我已知苦尽智。然不知无生智起一切诸谛。复次三尽智中间起。我生死尽是谓尽智。我梵行立是谓尽智。所作已办是谓尽智。更不受后身是谓无生智

  已说二苦相　　眼忍智越次
  思惟观三界　　有生犹如本

以何等故。苦智知苦智。习智知习智。道智者唯道智耶。或作是说。苦谛有漏五阴。于彼苦智回转。因智亦回转。道者无漏五阴。彼出要智便回转。于彼有道智。复次于苦思苦与回转有顺。是故谓习智道智。复次苦与回转有顺。于彼有习智道智。一思惟相。若缘是说者。于中不可沮坏。世尊界根智为缘何等。或作是说。因智道智界根智也。彼因道是其缘。或作是说。诸根展转界根智是其智也。复次最第一义善缘界根。恐畏厌患有何差别。或作是说。欲界相应为恐畏。三界为厌患。或作是说。有己为恐畏。彼我为厌患。问结中间为畏。善根中间为厌患。复次觉知怨敌欲住障者。是为恐畏。心驰逸为厌患。强颜无畏有何差别。或作是说。结中间为强颜。善根中间为无畏。复次意所入余处为强颜。意刚强为无畏。捷疾智速智有何差别。答曰。捷疾义实晓了。速对以彼渐渐方便义。次第捷疾智。利智无碍智有何差别。答曰。断诸结为利智。分别谛为无碍智。甚深智慧普遍智慧有何差别。答曰。觉知此缘是甚深智慧。长益众多普遍智慧。别智慧广智慧有何差别。答曰。种种相觉知诸义。是谓别智慧。一处普遍智。是谓广智慧。所可用智逮须陀洹果。彼智慧当言已知根所摄未知根所摄。答曰。所可用知无为逮须陀洹果。彼智当言已知根未知根所摄。犹如一切结见四谛悉断。以何等故。或见谛断或思惟断此之谓也。或作是说。见谛道断者。彼见谛所断也。思惟道断者。彼思惟断也。问彼有长益现一长益。或有余思惟。答曰。如齐眼所见。彼齐眼思惟。如齐眼思惟。彼眼所见。是故无力势。或作是说。彼最初见谛断者。彼见谛所断也。见谛者已见谛住断。或习而断彼思惟断。或作是说。诸忍所断彼见谛断也。诸智所断彼思惟断也。或作是说。有前敌彼思惟断。诸无前敌彼见谛断也。复次诸等智历非因缘。犹如以木钻火。彼见谛断。彼见长益断。如想心耶。彼钻彼思惟断

  苦世尊厌患　　强颜捷疾利
  甚深别智慧　　须陀洹及谛

尊婆须蜜菩萨所集知揵度第十竟

尊婆须蜜论卷第八尊婆须蜜论卷第九

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    菩萨所集见揵度第十一

若诸法是彼法因缘。颇有时彼法当言非彼法因缘耶。或作是说。犹如彼法未生。尔时彼法非因缘。或作是说。以事因缘故。因及余因缘非因缘。次定一切诸行。各各自因自果。及获余果报永不复生。设当尔者界有差违。最有吉法

阿罗汉从阿罗汉退。还复得阿罗汉果。诸得根力觉道意。当言本得得。当言本不得得。或作是说。若得等解脱。当言本得得。若得无碍解脱。当言本不得得。复次阿罗汉有六种根而有增减。诸阿罗汉分别其义。彼于此相应时。彼本不于他得道迹。有益思惟有益断。有益思惟当言本得得。是谓有道思惟断。有长益当言本不得得。若阿罗汉作阿罗汉想布施。假使非阿罗汉。而作阿罗汉想布施。何者最得福多。或作是说。若阿罗汉作阿罗汉想布施者。彼最得福多也。何以故。田业有增益妄处良田。问如心意行如念所起。云何作是说受福最多。若由良田得福多者。诸有施一阿罗汉。彼尽得平等福。是故此事不然。或作是说。二俱受福等。何以故。一以良田第二由心故。问若以良田心有益者。非由心故。云何得平等福。复次若非阿罗汉作阿罗汉想布施者。彼最得福多。何以故。彼阿罗汉功德心最微妙。问若尼揵子外道异学。作阿罗汉想布施者。彼最得福多耶。答曰。彼不知阿罗汉功德也。若复彼是阿罗汉。作阿罗汉想布施者。如是彼最得福多。彼无是力缘阿罗汉功德。若得知阿罗汉功德。彼不与外道异学尼揵子施。复次取要言之。犹如枯朽燋柱。作阿罗汉想而惠施者。于彼亦大得功德

不得何等。须陀洹果。设得便失。或作是说。如彼须陀洹。七反往来有信解脱。彼见谛果所摄。不得须陀洹果。彼若得见谛。彼信解脱果所摄。便弃须陀洹果。复次彼须陀洹七反周旋。彼渜须陀洹所摄。诸钝根不得中上。如须陀洹家家游者。若二若三。于彼游行尽其苦本。彼须陀洹下根所摄便次之。已得中上。若须陀洹家家游者。二家周旋尽其苦原。彼下中须陀洹果所摄便弃之。非以无为须陀洹果若得若弃

若诸法成就。彼法相成就耶。假使诸法相成就者。彼法成就耶。答曰。若诸法成就者。彼法相成就也。外众相不成就。若诸法自相成就。彼法成就也。若诸法不成就。彼诸法相不成就耶。或法相不成就。彼法非为不成就。外众相不成就。彼法自相成就

成就者其义云何。自相相应。是谓成就。不成就者其义云何。不自相相应。是谓不成就。又世尊言。是谓生此生。作如是说。命异身异。设作如是说彼二同一义。分别有若干。云何同一义。答曰。若自依己得彼缘义。作如是说当亲近尊

诸作此见彼命彼身。云何生此见。或作是说。生身便生此见。乃至有根身与相应。今亦复然。于中复有命复有身。或作是说。观众生根众生相。众生者众生根众生性众生类众生种。于中便有彼命彼身。如是所说。女身有力。于中不有短。有大身不觉更乐苦者。意根断绝

诸所生见命异身异。云何生此见。或作是说。展转观身心心者。亦展转相观彼心心法作我想。命异身异而有此见。或作是说。诸有禅者。观其威仪作因缘。观彼因缘。彼便作是意身异命异。身所为行回转时。或作是说。身不坏败便命终。便作是念。身异命异。若身未住便命终。或作是说。睡眠之中梦见身游行。于是有身。彼便作是念。命异身异。若梦中有所游行。或作是说。以三昧自忆宿命。于彼彼终生是间。彼见身住于中。便作是说。身异命异。或作是说。彻听以天眼观众生类。众生生时众生死时。身在中阴缚而见彼。便作是念。是命身俱游。复次身中间忆本所更巧便回转。彼便作是念。命异身异。若后他人曰命异身异

诸所生见无因无缘。众生垢着。非有因非有缘。众生染着。云何生此见。或作是说。若处闲居。或作是说。观诸垢起。观处宫中或见清净。彼便作是念。无因起诸垢着。复次以二力故生诸垢着。若因力若境界力。由是因缘而不知无因无缘。众生染着得诸见。若他人说。诸所生见。无因无缘众生清净。非有因非有缘众生清净。云何生此见。或作是说。于此观至空闲处而不清净。处深宫中或有清净。于中便作是念。无因而有清净。复次以三力故清净。因力境界力方便力。彼相应时因力境界力。善法如回转有清净生。由是故不知无因无缘。众生清净得此见。若以他说

诸所生见。无因无缘众生无智无见。非有因非有缘众生无智无见。云何生此见。或作是说。彼便有无殷勤者。云何起无智无见。若复生者。如是无智于中便作是念。无因无缘众生无智无见也。复次生死行因缘无方便行亦不勤求。住无智无见中。不思惟彼因与余相应无智无见相应。有不相应时智相应时。无因无缘众生无智无见得诸见。若由他说。诸所生见。无因无缘。众生智见。非有因非有缘。众生智见云何此见。或作是说。观殷勤者不起智见。以少殷勤或起智见。于中便作是念。彼以无因众生有智见。复次有五事智见回转。名所摄义所摄奸伪。知彼因与余相应智见相应不相应。知是时无因无缘。众生智见得诸见。若由他说

诸所生见无力无精进。云何生此见。或作是说。或见人貌有得田业。有不得田业。或复有人貌少有田业。于中无果人貌无力无精进得诸见。复次有众多相应。于今世后世或有得果报。于彼或以事而不得果报。殷勤人于中不得果时。无力无精进得诸见。若由他说

  因他本所缘　　须陀洹成就
  四种及二种　　因命四种力

诸所生见无施无受者。契经云何生此见。答曰。善行恶行果所生。若亲近时。于中不可知果实无善行恶行得诸见。或由他说。无今世无后世。亦无众生类。有生者如是有彼观无。有父因事而有。世无阿罗汉修行道人。而无有道

诸所生见。于此间有命活。后世更不复死。云何生此见。或作是说。是谓人有吾我身。彼若命终时。地身还归地。水归水火归火风归风。诸根归虚空。或作是说。度世阴时不见归来。于此间命活得诸见。复次处胎中。若胎中终。而观其命彼亦见终始。于此间命活得诸见。或由他说

又世尊言有六生。云何有六生。或作是说。如契经所称。黑生之人于黑法生。复次异学言有六生。黑生青生黄生白生赤生微妙白生。于彼黑生屠猪鱼捕鹿放鹰杀牛及余恶行。青生者尼揵子学道者。黄生者处在居家禀受于梵志。赤生者如沙门释子及诸修梵行者。白生者裸形学道。微妙白生者难陀婆磋讫梨舍僧讫栗姤瞿舍卢味迦梨子

诸所生见实有。此七大身。不作不应作。不化不应化。寡聚离甚深住。云何生此见。或作是说。四大性苦乐性。展转回转不观有胜。彼依识命相。此七身不作不应作得诸见。或作是说。四大苦乐。四大以生观。彼时有七身不作不应作。如是得诸见。复次心之与色选择所见。于中不怀自觉七身不作不应作。如是得诸见。或复有时由他说

诸所生见无有风。云何生此见。或作是说。风有命想。彼复作是念。无有风此是众生类。复次有常想坏败想。依彼无有风得诸见。若由他说

云何得知。此非富贵所造。或作是说。设当自富者彼则富。一切诸物俱有回转也。续生不断。是故富贵非其因。复作是说。若富是因者。一切诸物则相类也。与前是因展转妙物。是故富贵因。复次若富是因者。内无物事不集聚。不于中间事。不集聚不有物。是故富非因。云何得知此非因。答曰。设非因作者。集聚当有一切物续生不断。观彼因缚续不复生。复作是说。若无因物回转者。一切诸物皆当相类。因有增便果有增。是果非因。复次若物无因回转者。不于中间有进有集聚也。不于中间事不集聚。于中得知。非有因物回转。云何得知彼非命彼非身。答曰。身若干种自相坏败。无坏之相命所爱也。于中得知彼非命非身也。或作是说。身因缘所缚展转而生。非命展转爱。于中得知彼非命非身也。复次身所造若自为若他为。如是不爱命。于中得知于非命非身也

云何得知非余命余身。答曰。余命身不可得。亦不有可得时亦不可说。于中得知非余命余身。复作是说。身义异无数。自然无所为。然无数爱。于中得知非余命身也。义所造我事往有展转。命非展转爱。于中得知非余命身也

又世尊言。彼作彼自得。无记不可说。余作余自得。此不可言说。是语其义云何。或作是说。彼作彼自得者。此顺从有常。余作余自得者。此顺从断灭。此二物而求。如来处中而说法。于中不记。或作是说。彼作彼自得。此无记最第一义觉知诸行。余作余自得。此无记得等谛。是故现行不可坏。非由而受行报。复次彼作彼自得。己作己自得。世尊说空。于中不说。余作余受报者富。所作余者受。如是世尊说因缘。是故不记。云何得智余行事所造。或作是说。设有行事造者。彼事一切行行。二俱所作行续生。是故事不造行。复作是说。设事造行者。一切行则非妙。一事之中展转行妙。于中得知非事造行

复次设事造行者。于中间有集聚行。不于中间行集聚回转。于中得知非事造行。云何得知有余处终。或作是说。见心被柔心回转。于中便见终心被柔心回转也。如是于中得知余处终。后作说本所生根所依根。便有旷大根意因观彼若处母胎中。不于中间本根意。彼亦不于中间本根。是故宿命。彼于此至彼中。得知余处终。复次不于中间心心有所为。见心色依彼色有其心。垢相为心见色回转。于中得知见有余处。诸有物步步生者。以何等故本时不生。或作是说。事不充足。问或无二事。答曰。无不有时得有果实。问颇不有二时耶。答曰。无不有时现在因。问此亦是我疑。何以故不生。或作是说。诸物本时生彼现在因。复次在未来因。犹如无因。若彼本时不生。复次诸物本生今尽因生。然本不尽本时果不生。于中便当有。况复行本时不尽耶。当作是观。论中间非以尽事故说

如学学。作是说。物有坏败然不尽。云何得知物尽而不坏败。或作是说。设物坏败者。于彼亦有来。若子处母胎一时来。若步步知。于中得知物有尽而不坏败。或作是说。若物坏败者。彼亦当来。子处母胎形现断绝常回转。于中得知物有尽而不坏败。复次见是其事相应相思惟而生。是故集聚物。尽坏败方便。嗔恚有增所可得往。于中知物有尽而不坏败

  若有于此生　　富贵亦无因
  命作余处终　　物尽及坏败

见揵度第十一竟

    尊婆须蜜菩萨所集根揵度第十二

郁陀罗耶契经广说是语。其义云何。或作是说。五识身境界意有回转于中。便作是说。此意游行境界意有捐弃。问如六虫契经说。种种若干种。问一切境界是意。彼五识身见境界便有威仪。或作是说。五识身根声所说。意识为意声。五识身各各相持彼义。是意识一切境界所持强记不忘。犹如五匠师各有伎艺往咨受一人。或作是说。五识身境界现在。五识身威仪。过去未来意。此契经之要。复作是说。五识身境界五识身自相。现意识集聚而更之。复作是说。五识身境界。摄五识身与余相类。复作是说。五识身持意识身来。彼相似因果种法。是意识也。五识身便有境界此之谓也。复作是说。意识身有二种。有敷演有不敷演。有敷演谓之意境界

复次此是世尊教诫之语。若说因缘。优陀罗耶那五识身。于此种义而敷演。是故当知根。欲知根者当忆身。云何界。诸根故曰意。威仪境界意有尽意有念意本忆事意本忆事往。欲知意方便者。当忆所念。云何彼意。周流悕望。本四意止而回转。是故念方便。欲知意方便者。当忆四意止。云何彼有念。故曰念婆罗门当忆四意止。四意止为本七觉意回转。是故欲知意止方便。当忆七觉意。云何有此意止。是故婆罗门四意止。当忆七觉意。修七觉意住明解脱。是故欲知觉意方便者。当忆明解脱。云何有是七觉意。是故婆罗门七觉意。忆明解脱也。犹如作明解脱。彼彼得二根结断。是故欲知明解脱。无明有爱爱断。当作是忆。云何住明解脱。是故婆罗门。无明解脱。忆涅槃郁陀罗耶。忆久远论以越此论。世尊亦说是谓贤圣禁戒回转。或有所觉少有所忆。彼无明断爱尽所作事办。故曰往至涅槃我梵行立

未知根其义云何。或作是说。未越次之人。不修行诸学智慧智慧根。诸所有根坚法。未修行四谛而修行之。是谓未知根也。何以故。彼不一切觉智。问须陀洹一切不觉知。亦复以此一切觉知。见谛之人便知诸根。复次未知根者。有如是相。犹如眼根。此人无有是相。是故当观阿毗昙相。已知根者其义云何。或作是说。见谛之人诸学智慧智慧根。及余根信解脱。见谛身证修行上四谛。是谓是谛已知根。何以故。无知之人。问彼人向便知欲使。彼是智慧根耶。复次我已知是谓已知根。犹如眼根。眼根是谓已知根。犹如王臣。如依贤圣。是已知根。如依果树有果。无一切相。是故当观阿毗昙相

无知根者其义云何。答曰。漏尽阿罗汉诸无学智慧智慧根。及根已办解脱智慧解脱。若阿罗汉见法善居处。是谓无知根。何以故。以作众事此诸根也

以何等故涅槃谓之无漏。或作是说。彼不生有漏。复作是说。不能生有漏。复作是说。彼不起有漏。复作是说。彼不与有漏相应。复次彼不造有漏。亦不希有漏。是故涅槃谓之无漏。以何等故。涅槃谓之无智。或作是说。云第一义无智阿罗汉问此亦我疑。何以故作是说。无智果谓之无智。犹如行果。六情谓之本行。尊作是说。诸有敬此。无智是涅槃。彼便有无智自然涅槃。是故当舍此非论也

以何等故想不谓之根耶。或作是说。增上义是根义。然想非增上类。问如所说。一切诸法各各增上。是故想亦当有增上。复作是说。想不能断除结。问如所说。修无常想尽断欲爱。是故想亦断结。复作是说。想不为根所摄。如所说修无常想。断一切欲爱。尊作是说。造想相者摄持自相。如观所持

诸有苦者。彼一切成就苦根耶。设成就苦根。彼一切尽苦耶。答曰。诸苦者。彼一切成就苦根。或成就苦根彼非苦也。得苦根而不失。及余根而现在前

诸乐者。彼一切成就乐根耶。设成就乐根。彼一切乐耶。答曰。诸乐者。彼一切成就乐根也。或成就乐根非乐。得乐根而不失。及余根而现在前

未知根者。为摄几根。复有几根摄未知根。答曰。未知根一根少入所摄。智慧根一根摄。未知根智慧根。或作是说。未知根者九根少入。五善意根乐根喜根护根。九根摄未知根。此亦尊昙摩多罗作是说。未知根一根所摄。未知根也。复次一根摄未知根。即未知根也。已知根无知根亦复如是。未知根与几根相应。几根与未知根相应。或作是说。未知根与八根相应。五善乐根喜根护。八根与未知根相应。如上无异。或作是说。未知根者与九根相应。如上义。九根与未知根相应。尊亦作是说。未知根不与诸根相应。诸根不与未知根相应。已知根无知根亦复如是。颇依坏败已。依坏诸爱着先集聚然后果。作是说。颇眼根坏眼识不坏。问云何不依眼识耶。答曰。生者不有依诸欲一时集集聚果实。彼作是说。无也。眼根眼识俱生四大。俱有色声香味四大。依色声香味四大。此之谓也。问此亦于中有疑。颇依坏依不坏。诸爱上爱色住。彼作是说有也。若眼识坏眼根不坏。问若眼根有眼识者。彼则今无。云何今十二因缘而有违耶。亦因彼而有。无彼则无有。若欲空色者。彼作是说无也。所依坏彼所依尽坏也

颇眼根与眼识俱生耶。如上义所说。以何等故五根尽善耶。然后三根善。不善无记。或作是说。五根是无漏。三根亦是有漏亦是无漏。尊作是说。五根偏等相应办大事。三根者无有定理

以何等故忧根报不可得。答曰。现在殷勤便有忧根。此不可得已亦失。是故彼非报。尊作是说。忧根偏染着不类其报。是故彼非报也。以何等故。欲界疑与二根相应。忧根护根。色界相应疑与三根相应。乐根喜根护根。或作是说。色界无有忧根。是故不与彼相应。问欲界中亦有乐根喜根。欲界与彼相应耶。尊作是说。疑无有难与忧根相应。忧根左侧。便有护根忧根之数。无有疑有乐有喜

颇世间第一法。不于苦法忍中间缘缘。或作是说。有除其智慧。及余世间第一法智慧。智慧中间缘。尊作是说。识识中间缘心心法者。于彼性回转少。中间有多多中间有少。是故不于中间有缘。颇世间第一法。不与乐根喜根护根相应。答曰。有如上三根。如此间第一法相应。问如所说。依第三禅等越次取证。若世间第一法而现在前。是谓世间第一法与乐根相应。如是彼有违。以何等故。男根女根谓之有形耶。答曰。于中有名是男是女。问若俱有二形。亦名有二形。诸女人彼一切成就女根耶。设成就女根彼一切是女人耶。答曰。诸女人尽成就女根也。颇成就女根彼非女人耶。犹如有二形成就二根。犹如熊罴及余生种。诸男人彼一切成就男根耶。设成就男根彼一切是男人耶。或作是说。诸男人彼一切成就男根。颇成就男根彼非男人耶。犹如有二形

复次或是男人彼不成就男根耶。犹如色无色界天。颇成就男根彼非男人耶。犹如有二形成就二根。犹如熊罴及余生种。亦如上半月易形。嫉妒希望。外形或男人成就男根。若人生欲界中。或非男不成就男根。女生而寡作病寡处。卵[革*莫]众生及余生。或时渐厚诸非男非女。彼一切不成就男女根耶。设不成就男根女根。彼一切非男根非女根耶。或作是说。诸不成就男根女根。彼一切非男非女。颇非男非女。彼成就男根女根。犹如有二形。复次或不成就男根女根。非为非男也。犹如色无色天界。颇成就男根女根。非为男非为女。犹如有二形成就二根。犹如熊罴及余生种。颇成就男根非女根。然非为女非男根。犹如半月易形。嫉妒病。颇不成就男根女根。彼不得言是男根是女根。犹如生肿病处胎众生。卵[革*莫]渐厚。及余种不乱众生

  五三无漏智　　想苦乐方便
  不坏有二意　　疑世间男女

根揵度第十二竟

    尊婆须蜜菩萨所集一切有揵度第十三

当言一切皆有耶。答曰。当言一切皆有。何以故。犹若十二入有此十二因缘。是故一切皆有。问若一切皆有者。云何无者亦当有。无物者亦皆悉有。答曰。云何于无言无复有耶。若言有一切者。一切言无亦有。云何得知。犹如无者亦有。欲使现在亦有无。为现在有为中有无耶。设一切一切有者。亦当有此无。云何得一切有。若无一切有亦当虚无。无者无物一切皆有。复作是说。当言一切有。如此一切乃至有为无为彼则有。是故一切有。问计校一切吉(相应)因无。是故不吉一切有。答曰。如现在有为现在计校。现在无有吉因。欲使现在有为耶。若有一切者。一切办无因。云何还一切有。不有一切吉因若实。一切无吉因。如所说有。一切无一切因彼无。复作是说。当言有一切。何以故。说无一切者。亦无一切所持摄持三一切是故。一切有。问云何不一切持还自然持一切内有。答曰。若一切持还自然持一切内有欲使有现在持耶。还自然持现在内有。若有一切持还持还自然持。云何还一切持。云何还一切持不有自然持。若审有一切持有自然持。如所说有一切持。有自然持。彼亦无也。复作是说当言一切有。何以故。如尔所觉。不如彼有。不有彼彼无也。是故一切有。一切遍有一切耶。答曰。不得言有。何以故。犹如有青色彼无黄色。尊作是说。不当言。何以故。不以物有胜有余也。不以住胜有余。若彼有者此非好。不等威仪。当言有一切耶。答曰。不得作是说。何以故。不以无常言有常。亦不有常言无常。尊作是说。一切名者。此相无处所。是故尽不得言有。一切尽当有一切耶。答曰。不得言无也。尽有一切。何以故。不以无常言有常有常言无常。尊作是说。不应作是语。何以故。缘是有诸法界德。诸法耗乱。诸法耗乱。诸法无有定处。是故不应作是说。一当言一切有耶。答曰。不应作是说。何以故。凡夫人亦不还学无学法。学无学法。无学学无学法。是故不应作是说。尊作是说。不应作是说。若成就者彼则有也。然无有一切成就也。是故不应作是说。一当言一切成就耶。或作是说。不应作是说。凡夫人不成就学无学无学法。是故不应作是说。复次不应作是说。何以故。若有所得而不忘失。彼当成就彼亦不尽得不失。是故不应作是说也。一切智者其义云何。或作是说。觉知一切是谓萨芸然。犹如明书则名书师。复次于一切事知自在。是谓萨芸然。诸萨芸然。后悉知一切。假使悉知一切。彼悉萨芸然耶。答曰。如是悉知一切。是谓萨芸然。复次不得作是语。悉知一切言萨芸然。犹如书师明其书疏。然一切智不尔。普知一切有常无常。然非一切智

一切有一切。一切根一切。一切一一切。一切智而智。云何有有相。答曰。智是其相。法是其相。有是其相。无是其相。实是其相。复次有三有。观有如所有珍宝如所有是谓有。此间有彼间有实有如所有恚是谓有。云何无是无相。无智相无有相。无物相无有相。无法相无有相。复作是说。如彼无者即是其相。复次有二无。二观如所有是谓无。无珍宝如所有。此间无彼间无。云何有漏是有漏相耶。答曰。无漏所生生是有漏相。复作是说。无漏所生是有漏相。复作是说。有有漏所起是有漏相。复作是说。无漏相应是有漏相。复次不于中间有有漏者。是故无漏。是故当观有漏相。彼便有是。云何今不起园林。彼众生行报因缘。彼行当观有漏所起。云何无漏是无漏相。答曰。如上所说。复次或中间有漏整行为无也。彼当观无漏。云何有为是有为相。三是有为相。起灭作变易。复作是说。无常相是有为相。复作是说。因缘灭相是有为相。复作是说。所作相是有为相。复作是说。久远堕相是有为相。复次若有众生集聚是有为相。云何无为是无为相。当说如上无异。云何过去过去相答曰。坏败相是过去相。灭尽相为过去相。复次回转意所越是过去相。当作是观。云何未来是未来相。答曰。未生相是未来相。未起相是未来相。复次意回转不还是未来相。当作是观。云何现在是现在相。答曰。生不坏败是现在相。复作是说。生不尽是现在相。复次意回转时。当观现在彼今生

若相及有为。有漏并无漏。有为无为。过未生及现在三世。当言过去。当言未来。当言现在。答曰。过去世当言过去。未来世当言未来。现在世当言现在世。久远行炽然。此三论议章。五阴当言过去。当言未来。当言现在。答曰。五阴当言过去未来现在。所要言之。五盛阴亦如是。十二入十八持亦如是。意身所有诸过去者。彼一切有。设有彼一切过去。或作是说。诸过去者彼一切有。颇有彼非过去。如所说。尊者曩昔阐头比丘。从施家亲属家知识家。然彼家非过去

复次或过去彼非有。如所说。一切结使过去。彼不结使起而灭。或有彼非过去。如所说。尊者曩昔阐头比丘从施家。当于尔时等行。或有亦过去。诸众行出世而灭度。或非有非过去。除上尔所事则其义。诸未来彼一切必当有耶。假使有者。彼一切未来耶。或作是说。诸有者。彼一切未来也。颇未来彼不有耶。未生法行。复次或有未来彼非有。未生法行或有。彼非未来。如世尊言。彼阿难当作比丘。若大若小意不聪明。不善年少意无智。当于尔时等俱行或未来。及有诸行未生必当生。或非未来非有。除上尔所事则其义也。诸现在者彼一切有耶。设有彼一切现在耶。或作是说。诸现在一切有也。颇有一切彼非现在耶。过去未来。行及无为。复次或现在非有。如所说

  我无有家长　　亦复无亲属
  无妻子仆从　　已得离解脱

或有众生。家数尔时等俱行亦如是。于此间无余处无。或有或无。彼非现在过去未来行。无为或现在。及有诸色生。便灭亦不有。亦不现在也。若色过去。如彼色所有彼色过去耶。设有过去彼色有耶。或作是说。诸过去物。问如所说。诸过去彼一切色。或作是说。诸色物彼过去物。问诸所有色彼一切过去也。或作是说。色物异过去物异。问一则有二。复次色过去物。所生色亦自然。亦复所生如是有也。未来现在物。亦复如是

  世章二阴　　诸持二入　　过去来物
  色有及三

犹如色无常。如彼色物亦复无常。若无常者尽无所有。彼所有如上无异。苦空无常亦复如是。犹如青色用眼识知。云何彼青彼识无异耶。设如彼知彼是青色耶。或作是说。犹如青色彼是智也。问过去是青色。是故过去亦知。作是说。彼知即是青色。问过去不知。是故过去非有青。或作是说。青异知异。问眼识则颠倒。或作是说。彼青异知异。问眼识则有颠倒。复次智者是等谛。复次自然物所事办。又世尊言。识用知物。是故谓之识也。说是语其义云何。或作是说。此是识相。用知物故谓识。问无过去未来识彼非识。尊作是说。久远契经句。复次取要言之。当作是说。若知众生当观彼识。犹如彼识彼是知耶。或作是说。犹如彼识彼是知耶。问过去未来识知。或作是说。犹如彼识彼是知。问过去未来不知。是故彼非识。复次识不知。缘所因识所生知。有众生便有等谛。诸所识彼一切知耶。设知彼一切识耶。或作是说。诸有识彼一切知也。问过去未来识知。或作是说。诸所识彼一切是知。颇有识彼非知耶。过去未来识。问如所说。识者是知是谓识。是谓契经有迷。复次识知缘所作识所生知。众生便有等谛巧便。云何知一切心是缘。或作是说。一切心缘四因缘生。或作是说。境界心有所摄。或作是说。世尊亦说。缘二因缘识便生。或作是说。若心无缘者。彼则是识。知者是识也。尊作是说。所为性说心回转缘回转。此知识于中得知。一切心有缘

  无常苦空　　无我知识　　诸所为知
  彼因缘心

一切有揵度第十三竟

    尊婆须蜜菩萨所集偈揵度首

  等二不等远　　如来无量智
  不染守内外　　如实敬供养

等二者。是等觉一切智十力四无所畏等。辟支佛自寤等。阿罗汉解脱等。一切趣向等所见。故曰等等不等远。或作是说。此事等于等中等。犹如罗云调达。本无如来如如。不如如道来。是谓如来。言无有异故曰如来。成就大智慧无量智。成就无限智慧。是谓无量智慧。无量境界智慧成就。是谓无量智慧。无量涅槃。是谓无量智慧。复次无量智慧成就无量大智慧。世尊除彼觉智慧智句。是谓无量智慧。不染污者。于此间内受有外是余物。复作是说。于此间内受有外趣善处。复作是说。于此化说法爱。不起外者。于彼说法爱不起诸结。如实敬供养。如是应供养

  于着不著者　　于慢不着慢
  知苦自田业　　如实敬供养

于着不著者。诸见是着。若于三界见尽。彼谓过去。若于慢不着慢者。三种慢世俗着而不着。知苦自田业者。忍彼苦外诸入。复作是说。于着不著者。已越慢着是谓不着。于慢不着慢者。于七慢种中于彼染着而不染着。知苦自田业者。苦识受识住处田业染着。复作是说。于着不著者。现见谛所断结尽。于慢不着慢者。现思惟所断结尽。知苦自田业者。苦五盛阴田业行是结。复次一切结着彼越一切着。是谓无著也。于慢不着慢者。染着诸慢染不着诸慢。知苦自田业。于彼苦苦谛知者知道谛。彼田业者。是习谛本所有结尽。是谓尽谛

  不依望厌观　　相佐起诸见
  因缘无所有　　如实敬供养

不依望厌观者。贪望命望不应依。彼有二种。爱见者。诸佐彼爱命爱佐见厌观。有二种道道果也。得起他诸见。他厌观有二断灭见。有常见己越彼。因缘无所有者。有二因缘。爱见是也。彼灭尽。复作是说。不依望者有爱见。望厌观者。于彼现出要起他诸见。于一切诸见中。亦知他出要已越彼已。因缘无所有者。识识处住尽。复作是说。不依望者。现爱结尽起他诸见。现诸结尽。因缘无所有者。若爱结缘结尽彼无所缘。复次不依望厌观。思惟所断结尽起他诸见。起他诸见现谛所断结尽。因缘无所有者。已越一切诸结。思惟见谛所断结尽。彼无所缘也

  于家能灭意　　他家无染着
  不起此彼患　　如实敬供养

于家能灭意者。有三家爱见是也。灭意者。以此家依依意。若欢喜已依彼二便依意相应。此断若意相应道。于断他家无所染着。有二他家。爱家见家。于彼不染着。不起此彼患者。爱所起由见故。诸此爱见尽。彼无所起。复作是说。不起此彼患者。亦如上得无异。复作是说。于家能灭意者。一切结是行一切结尽。他家不染著者。于妻子男女不染着。若爱若见不起者。于四受起中现其灭尽复作是说。于家能灭意者结欲。于他家意不染著者。不起者不爱。不起者于欲不起欲爱尽。复作是说。家者是习谛。意者是道谛。于他家不染者是苦谛也。不起者是尽谛。复作是说。于家能灭意者。现见结断。于他家不染著者。现爱结尽。不起者诸爱结见结尽。彼无所造。复次于家不染著者。现见谛所断结尽。于他家无染著者。现思惟所断结尽。不起者。诸见谛思惟所断结尽。彼无所造

  多望口文字　　捐弃灭无有
  觉一切解脱　　如实敬供养

多望口文字者。多望者修望。口文字亦修。作是说。多望者多望是爱。口文字者口所陈说。复作是说。多望者是诸见。文字者爱。复次多望者思惟所断。文字者见谛所断。捐弃者已灭尽。无有所著者。是谓不起法。能觉者觉知一切诸法是谓觉。觉知三痛是谓觉。通达诸智皆悉成就。是谓觉也。于一切解脱者。于三界解脱也。于三缚解脱。爱缚垢缚见缚也

  痴无得其便　　一切法照明
  由身而扶持　　逮觉最上等
  此最净鬼语

痴无得其便者。痴者是无明。缘内无明愚中间愚相应。复作是说。愚是无明。诸见愚中间与愚相应。复作是说。无明是愚。结愚中间与愚相应。复次无明是愚。无明缘行愚中间与愚相应。无有此尽。于一切法现诸智。现其因缘现其方便。现其道迹。由身而扶持者。住有余涅槃界。逮阿惟三佛。以此忍觉知无觉时。十力一切智四无所畏。最上过者休息安隐处。此净鬼(夜叉)语此最妙鬼。清净此无学门

  偈说不应食　　等观于彼法
  偈说诸佛喜　　诸法本梵志

偈说不应食者。作是说。世尊不为食故往。尔时世尊。欲教化婆罗门故是住也。后作是说。或不承受我语。复恐婆罗门作是念。沙门瞿昙为食故说法。复作是说。欲现其神足故不受食。彼婆罗门应受佛化。若观彼法时。以是故观。及声闻及大丈夫。是彼威仪行。说得诸佛喜者。断灭而不取。诸法本梵志。于中有贤圣沙门法。如是贤圣教

  诸余大神仙　　尽漏观惭愧
  以甘馔供养　　种德最福田

诸余者。诸杂秽饮食现受请供养。大神仙者。还大法是谓大神仙。尽漏者。诸有无明爱在身中能除去。是谓尽漏。惭愧休息。若戒盗尽。彼惭愧休息。以甘馔供养。种德是福田。是何谓德田是福田。于中专精意着。萌身长益。是谓福田。或作是说。便有偈。以此事余造。彼大神仙。尽漏惭愧休息。以甘馔供养。种德是福田。或作是说。彼婆罗门作是说偈。诸余大神仙。尽漏惭愧休息。以甘馔供养。种德者福田

  教化沉没人　　越生老病死
  能仁漏具足　　诸愿悉普至

教化沉没者。沉没诸见结以彼捐弃。越生老病死者。越度生老病死。能仁者。谓无学断诸结使。漏具足者。诸智漏具足成就。是谓解脱。成就智无限。是谓能仁成就漏成就。诸愿悉普至者。有如是功德。越生老病死。越诸果愿。复作是说。一切沉没结使。彼能舍离。度生老病死。谓之涅槃。此亦悉逮知。是谓度生老病死。作是说。教化沉没人。见其垢染着。度生老病死者。现爱结尽。复次若教化沉没人者。现诸见谛所断结尽。度生老病死者。现思惟所断结尽。余残亦如是

  能仁行无淫　　不为壮所缠
  于欲身解脱　　彼牢固能仁

能仁行无淫者。于尊者大迦叶授决广说。能仁者是无学也。行者往就行无有淫。去离非梵行。不为壮所缠者。或复有时。若少壮不与贪欲。况当老迈。于慢得解脱者。于四慢不造意不贪。是故当远离。彼牢固者。咄弃诸恶法。牢固智慧成就。是谓牢固。能仁者是无学也。觉知所为。复作是说。能仁行无淫者。现安隐处。不为壮所缠者。现少壮当尽。于欲永解脱者。现业当尽。余残亦如是

  不二倍越岸　　亦不一倍终
  高下语句义　　是沙门所传

不二倍越岸者。有诸疑网。不越无量生死岸。疑网未尽不能越生死。二倍者奸伪幻惑也。复作是说。诸有二倍者。彼不能越不越。彼二倍者。行垢成就一倍丧终。高语句义者。高者现身出要。不高者现身习出要。复作是说。高者是谓生天。不高者趣恶道中。是沙门所传。世尊敷演

  或有不着裳　　亦不乐挍饰
  或有持戒香　　语直不卒暴

或有不卒暴者。或有不着衣故犯诸禁限。亦不乐挍饰者。不作是意庄严身口。亦不听伎乐。或有持戒香者。或有学士游行四方。称扬其名常无倦心。或修梵行者。不说戒有亏

  归命佛最胜　　一切皆解脱
  是尊最勇猛　　游至无为中

佛者。觉知一切诸法。最胜者。具足诸力。归命者。恭敬义。一切皆解脱者。于三界解脱。于二缚解脱。爱缚见缚也。复有三缚。欲怒痴缚也。是尊最勇猛者。受尊教所说法语。游至无为中者。亦无精进现有精进。非为不精进。不还悉获现所作事办。非为不有精进意。当作是守护。犹如不退现不退法。尊者婆那伽婆蹉居止深山。与郁头罗摩子自说偈。执鼻执婆鼻那提帝(详人不解)比比罽赖楼多弥遮。我意不染着。心常[火*霍]然寤。执鼻执婆鼻那提帝者。飞鸟之音响。比比罽赖楼多弥遮者。麑鹿之音响。我意不染著者。不退亦不起诸欲。心常[火*霍]然寤者。乐诸道乐涅槃。是谓比比罽赖(勺桂反)

  五塔庙乐处　　枝叶不坏败
  彼见生诸枝　　能仁以慧断

五塔庙乐处者。于五阴有中。枝叶不坏者。爱枝也。三界生诸见枝无常苦。能仁以慧断者。学人智住断。复作是说。五塔庙乐处者是苦谛。枝叶不坏败者是习谛。彼见生诸枝者是道谛。能仁以慧断者是尽。复作是说。五塔庙乐处枝叶不败坏。是谓垢着。彼见生诸枝能仁以慧断。除结净相。尊者婆那婆蹉居在深山。天降雨时心怀欢喜。便说偈曰

  岩峻善茂生　　伏流水浴身
  离欲处闲居　　智者倍生善

岩峻善茂生者。山泽树下。伏流水浴身者。以雨水浴身。离欲处闲居者。居远处乐闲静。生诸不贪欲不处众。智者倍生善者。生诸喜及善增益。居喜觉意

  愚者造生死　　数数入胞胎
  故智者不造　　头破亦不眠

愚者造生死。无智成就无明。造生死者。行有漏一切成就乐欲。数数入胞胎者。处母胎中。是故智成就。故智者不造。行有漏受诸有。于中亦不为。头破亦不眠者。犹如此人。或作是说。愚者造生死是习谛。数数入胞胎者是苦谛。故智者不造是道谛。头破亦不眠者是尽谛。犹如此人也

等数望有愚偈义胎不度意常佛执鼻执婆耶庶。及五愚惑不聪明

尊婆须蜜菩萨所集偈揵度初品竟

尊婆须蜜论卷第九尊婆须蜜论卷第十

        尊婆须蜜造

        符秦罽宾三藏僧伽跋澄等译

    菩萨所集偈品首

尊者优婆夷。谟以水道步。寻往作尺蠖行。乃至入有想三昧。更不复见缘能因缘灭有想无想。彼问世尊曰

  我独流无量　　不依不能度
  与我说其缘　　所依度彼岸

我独流无量者。独一者谓不二。无缘生死流不能得度。复作是说。不能度此有想无想。复作是说。一无明流不能得度。与我说其缘者。普眼遍彼缘无眼。度生死流。此谓有想无想度无明流

  观不用念定　　依彼而度流
  云何断欲爱　　爱尽于彼观

观不用念定者。起无漏不用定。无常苦空无我。作如是观念者。专精其神足住止处所。是谓休息。复作是说。观不用定时观涅槃休息。如是汝度流。于彼而灭爱。犹如彼爱先尽。问三界诸爱染着于欲。复作是说。住爱而使尽。亦当使求尽。复作是说。彼爱未尽诸缠着住。非以外道而灭。去离非论。彼听善论爱数数使退。以是故世尊使告离非论爱尽。于彼观者彼于涅槃有堕想。彼自守持。于是世尊说不涅槃休息。一切欲无爱。依不用定。寂寂想解脱最胜。住彼而不起。一切欲无爱者。于三界欲尽。欲界结永尽。以贤圣道尽爱。依不用寂定者。不依不用定三昧周有想无想及余三。若依涅槃想。解脱最胜者。想解脱有想无想。若住涅槃休息者。彼住不起于彼退。亦无所起。世尊说曰

  彼住而不起　　无数劫净眼
  于彼两解脱　　识誓知所传

彼住而不起无数劫净眼者。答曰。亦当久住于彼两解脱。于彼般涅槃。识誓知所传。我于彼退转。亦复不生。不于生入而入誓

  犹火风所吹　　没灭不可数
  仁能名色脱　　没灭不可数

犹火风所吹没灭不可数者。如彼火不于空中灭。亦不可称数。若往东方西方。能仁名色脱者。名四无色阴色身身。彼俱曰名色

  没冥必还明　　若没如今无
  作有常之想　　净眼与我说

没冥必还明。问云何为明。犹如日明照。若没如今无者。若有常若断灭。还处入净聚。净眼与我说与我布现。尊无所不知

  没灭不可数　　愿说所无者
  散离一切爱　　亦散一切义

没灭不可数者。有限之法彼则无也。愿说所无者。诸爱尽者诸爱限数。彼无有此爱诸阴。由行生者诸阴限数。彼无此阴。散离一切爱者。亦散一切义。三界爱尽

  二问释种子　　净眼不授决
  乃至三大仙　　授决我欲闻

二问释种子净眼不授决。彼尔时作二问。云何观世间。亦不见死生。世尊不与授决。何以故。欲教训之。彼亦闻三语而授决。于中作是说。乃至三大仙授决我欲闻

  今世及后世　　梵天上诸天
  见亦无所知　　瞿昙者德至

今世者是人世。后世谓恶趣。梵天者谓梵迦夷天。诸天者谓欲界天。见亦无所知者云何见。瞿昙普德至者。世尊声振四方。如是世谛一切智。犹如转法轮。说声闻乃至梵天

  若欲如是见　　义论之所归
  云何观世间　　而不见死生

若欲如是见者。如是成就妙智。世间及天梵天而不知见。义论之所归者。欲闻受决之所归。云何观世间而不见死生者。云何观六入。不生余境界

  观世皆悉空　　愚王亦专念
  以能拔我见　　如是越生处

观世皆悉空亦自见愚王。尔时世尊为说空常。专不移动念者。不念邪事游意止中。我见者。是愚身见而灭之。如是度死处。亦不生阎浮境界。尊者拔苏卢作是说。闻断灭有常。尔时世尊不与授决。彼亦闻第三句迹而授决。于中作是说。二问释种子。今世后世者是欲界天。梵天者梵迦夷天。及天者及余色界天。见亦不知者。住中迹中而不知。如是越所见者。成就如此妙智。世及天者不能解知。如此中亦断灭有常。观世断灭有常。而不见死生。云何除断灭有常。而住中迹越生死岸。观世皆悉空者。自还所觉。若断灭有常。彼观皆悉空。住其边际。如是观六入。则能越生死岸

  天女众所围　　亦亲近妖魅
  彼园名愚惑　　云何获安处

天女众所围。彼修行人。闻三十三天天女众所围者。以天音乐亦亲近妖魅。三十三天在街巷头。门阈左右园果浴池。四天王有诸女鬼。颜色弊恶声响粗犷。喜恐怖人。彼园名愚惑者。杂园果甚乐无极。天五乐自娱园能惑人。云何获安处者。云何得出要

  彼道名曰等　　彼方名不恐
  事亦名无声　　觉法名具足

彼道名曰等者。无曀亦不曲。彼方名不恐者。涅槃名曰方。于彼无生病老死之恐。事亦名无声者。止观是名事。无有结着故曰无声若。贤圣无漏三昧。觉法之具足者。觉出要与共相应

  惭亦不有缘　　念者将从人
  智慧能御车　　等见先导前

惭亦不有缘者。惭诸结秽恶。彼犹如船车。如是缘惭而起道意。不复思惟。念者将从人。犹如车以虎皮覆上。若豹皮缠恐不得其便不可亲近。若怨家盗贼不得其便。如是念。将从不得亲近诸恶行。智慧能御车者。犹如侍车人如好车。如是道智慧最。是道犹如御车者。知道非道犹如御车者。侍车而行应进则进。如是智慧欲退时。便起勇猛意。意若炽盛便使休息。犹如御车者。知进便进。如是智慧思惟方便。等见先导前者。等见先在前而修行道。世尊亦说。等见生等志。复作是说。如彼贤圣人。八种道本亦说故曰惭。亦是彼缘行学增上戒。念者将从人也。学增上心说智慧御车也。等见先导前者。复作是说。彼车是其处众行具足惭。是其缘者有三种。道等语业等命。念者将从人等念也。智慧能御车者。等志等方便也。等见先导前者。即等见也。复作是说。诸止观是食者。如本车所说。惭亦是缘者。戒是其食。念将从人者。止是其食。智慧能御车者。观是其食

  诸有如此乘　　众萌男女类
  彼乘如此车　　往至无住方

诸有如此乘众萌男女类者。彼已修行道。以乘往至无住方。彼已修行道。未至涅槃。便使至涅槃也

  五断五已灭　　修行五上者
  五数比丘过　　是谓已度流

五断者。五盖也。五已灭者。五下分结也。修行五上者是五根也。五数比丘过者。已越五上分结。是谓度流者。已度生死流也。复作是说。五断者。五邪见也。五已灭是五身结也。修行五上者。五禅种。五数比丘过者。已度彼欲数。如所说着欲是谓欲数。是谓度流者。已度欲流。复作是说。五断者。五趣中结也。已灭五者。是五道也。修行五上者。五解脱入也。五数比丘过者。即越彼五趣。是谓度流者。度生死流也。复作是说。五断者。五心缚也。已灭五者。心五秽也。修行五上者。五念结也。五数比丘过者。已度心五缚也。是谓是度流者。度生死流也

  五觉及眠寐　　五眠寐及觉
  有五受尘垢　　五是清净行

五觉及眠寐者。五邪见睡眠五根兴寐。五睡眠及觉者。五根睡眠五邪见觉寐。有五受尘垢者。五见也。是五清净行者。五根也。如是五身结力结念处所。下分中禅数。上分中解脱。入阿那含凡夫人

  奔走不乐中　　养新新缚着
  犹奔冥灯火　　见闻一所作

奔走不乐中者。已断解脱奔有常不乐断灭。复离断灭有常不乐有常。养新新缚著者。谓所生见增益诸缚。犹奔冥灯火者。犹如钵胜伽虫(飞蛾)。油灯休息想非舍离堕。作如是邪见有休息想。作舍离想堕。见闻一所作者。见净有净缘。闻净有净缘。如是一切诸见。复作是说。奔走不乐中者。不乐五欲中不乐一欲。养新新缚著者。欲爱缚堕。见闻一所作者。住五欲中。复作是说。奔走不乐中者。不乐欲界奔走色无色界中。余亦如是。如奔所趣如今所觉。或作是说。亦复此事不乐奔结。走解脱牢固。向新解脱牢固

  老覆盖世间　　为死所围绕
  众生患爱病　　法住于世间

老覆盖世间者。所覆不得解脱。为死所围绕者。亦不得走避。如所说

  非空非海中　　非入山石间
  无有地方所　　脱止不受死

众生患爱病者。爱缚所缠不能度三界。法住于世间者。住世八法。十善行迹。或善或不善。复作是说。住十二因缘。或作是说。为苦所害。使住道也。或作是说。住于七法。或作是说。其事云何住世间

  偈颂缘为事　　文字为甘味
  依名而有偈　　造者偈之身

偈颂缘为事者。意欲便造偈敷演讽诵。文字为甘味者。分有文字次第分间布行。依名而有偈者。依名造作犹如十句偈。造者偈之身。造偈颂为首

  以六兴起世　　六已成就业
  六造世间法　　有六受苦恼

以六兴起世者。六爱身也。六已成就业者。六病身也。六造世间法者。造内六入也。有六受苦恼者。外六入也复作是说。以六兴起世者。六爱身也。六已成就业者。外六入也。六造世间法者。造六尘也有六受苦恼者。六痛身也

  四方非四方　　上下最胜界
  不闻不觉知　　说法使我寤

四方非四方上下最胜界者。当言结声响。不闻不觉知者。集聚之相故。曰无所无不知。说法使我寤者。说道审谛出要之业。世尊知根说法之义。使我时得寤

  本尽不造新　　于有无爱着
  种尽法不生　　涅槃犹灯灭

本尽不造新者。过去贪欲尽。更不造新者。未来贪欲尽也。于有无爱著者。现在贪欲尽也。种尽者。识种及所生有种尽也。法不生者。彼识处不生除去行垢。涅槃犹灯灭者。不起便涅槃。犹如灯灭者。不可限量。住至东方若后南方。如是阿罗汉般涅槃不可限量。复作是说。本尽者。过去结灭。不造新者。未来垢尽。于有无爱著者。现在垢尽。种尽者此垢。种尽不生法者。更不受住。涅槃者。[火*霍]然无垢。犹灯灭者。不为造有所缚。复作是说。本尽者。过去行尽所可受报者也。不造新者。新垢不造。于有无爱著者。行有余。复作是说。本尽者。因尽也。不造新者。于彼因无有果实。于无爱著者。于彼有余。复作是说。本尽者。六入尽及本行空。不造新者。不造新行。余亦如是

  此王车朽败　　身亦如是朽
  真法不朽败　　于己而平均

此王车朽败者。王波斯匿车在。深朽故无有光色。身亦如是朽者。如是身在隐匿处。为老病所逼无有光颜。真法不朽败者。亦不羸弱。何以故。于己平均。平均法何者是。道谛是也。诸佛说法是平均法

  道为八等妙　　圣谛有四句
  无欲法为上　　与二足作眼

道为八等妙者。一切诸道贤圣八道为上。圣谛有四句者。一切诸谛贤圣谛为上。一切诸法涅槃息为妙。与二足作眼者。一切众生佛最为圣。一切悉知。问犹如实有涅槃道。何以故双出二事。于尊因陀摩罗沙门名作是说。求为道出要为涅槃。不空为谛义。毗舒佉作是说。犹如智于境界回转。道亦如是。犹如智有境界。如是谛涅槃。犹如断结。犹如智有境界。谛亦如是也

  觉粗亦觉细　　意盛慢所畏
  此非智所觉　　意或奔诸趣

觉粗者不善也。觉细善有漏受诸有也。复作是说。觉粗者见谛所断。觉细者思惟所断。复作是说。觉粗者与欲界相应。觉细者与色界相应。复作是说。觉粗觉欲也。觉细者觉智也。意盛慢所畏者。自意所生意流驰意。流驰与相应觉知。如是与无明智彼有觉也。各各驰走展转觉知心意常乱

  如是意觉知　　无恼威仪念
  在心意炽盛　　无余诸佛灭

如是意觉知者。等住觉知渐为方便。无恼威仪念者。威仪者亦不觉。念者专其念。心不移动住者。如念无异。炽盛者。无余之所灭。佛能永灭。问疑无有疑身绝欲使。彼亦是佛耶。答曰。诸佛是法。亲近诸佛于此契经。复次诸界佛所灭。声闻不能灭诸界。复作是说。无余诸佛境界灭

  天远地无边　　大海亦无际
  日月降光处　　及其灭处所
  有实无实法　　是谓四极远

天远地无边者。偈广说。乃至灭处方远俱越。有实无实法者。是四极远自极远此法道。无实法是垢。复作是说。有实法十善。无实法十不善法。复作是说。实法是涅槃。无实法是生死。复作是说。实法是谛。无实法是诸见。复作是说。实法是七法。无实法是七非法。复作是说。实法诸佛之要。敷演法教。无法不阐等法印法教也。彼于是不久自然之理

  优婆尼摩王　　既觉寤驰走
  偈缘世灭尽　　生老道二远

偈揵度第二品竟

    尊婆须蜜菩萨所集偈品首

  尽形寿愚痴　　亲近诸智者
  彼不识了法　　犹杓不别味

尽形寿愚痴。愚痴者。谓之无此力势。知善语恶语义。彼尽形寿亲近诸知识。亦不解了法。智在须臾间。亲近诸智。彼能识了法。犹舌尽别味。智在须臾间。亲近诸智者。智者谓之诸阴善持善入善。又此力势成诸器教。愚痴者。谓之无此力势。不能解十二因缘。智者谓之有此力势说十二因缘。愚痴者不成圣谛之器。智者谓之数四。四演谛故。曰智在须臾间亲近诸智者

  彼于死不死　　住者亦不住
  于穷亦好施　　此法非无义

彼于死不死者。于嫉妒中于妒死而死。好施者于妒着不死。以智慧命为活。住者亦不住。犹如逐商人失道。为恶狩盗贼所害。犹不失道人。不为恶兽盗贼所害。此最是施。于贫能施者。彼愍孤穷。此久远常法。或作是说。于彼死不死者。悭嫉于恶趣中死。好施者生天上储粮在前。犹如商人粮食乏少便遭困厄。于少能施者。此法是孤穷。是为孤穷之法

  本乐得存命　　此瞿昙弟子
  保命自知短　　无常求所施
  坐具亦无常　　觉知世无常
  命知足易满　　本尽苦原本

本乐得存命者。尔时诸天为诸懈惓比丘。说佛语本乐得存命。知足易满易养。禅乐三昧善居止。无常求所施者。亦不留遗余。以乞求为命。坐具无常者。在树下空处。游戏其中意不专一处。知世无常者。本尽苦原本。知六入无常度生死流。复作是说。本乐得存命者。此瞿昙弟子。本以智慧为命无常求所施。坐具亦无常者。以无常想乞求。复以无常想处彼坐具。觉世无常本尽苦原本者。修无愿解脱。觉无所造而般涅槃

  以何智慧知　　慧必不有难
  以何智慧知　　是谓名为慧

以何智慧知慧必不有难。是何智。如想无有异。以何智慧知是谓名慧者。以何等智慧知。已知而知者。若法无有难诸法无有二想。于中以何智慧知。是谓名为智慧。诸法无有二想。无有二种生。以何智慧知。是谓名为智慧。此智慧智已知。便是其知此是何智。犹如一切无常智智亦无常。一切无我智智亦无我。犹如有一切智亦有知

  有寡有生者　　出牛入牛者
  亦有牛长大　　欲者天便雨

有寡有生。檀尼所由原寡不生牸牛。忆来导引前在。后驱牛者。牛长者。大牛长无寡。无有生者。出牛入牛者亦复无也。亦无有牛长大。欲者天便雨无寡。世尊作是说。一切无现无所取。复作是说。色无色界结无有不尽者。无生者欲界无有结不尽者也。忆牛者无明也。入者彼相应心心法。与彼回转心不相应行。牛长大者。于此慢尽所作事办

  无怒除去秽　　流水侧一宿
  庐露我大覆　　若欲天便雨

无怒除去秽流水侧一宿者。现无怒。除秽者现嗔恚尽大秽除尽。流水侧一宿者。涉道于彼宿也。欲化牧牛者。种种奸伪尽身奸。彼不净见根。奸是识身彼。亦尽也。我已除火三火息

  我已见屋室　　更不起爱着
  汝尽胁勒摧　　屋舍皆坏败

我已见屋者。爱受诸有是屋舍。复作是说。屋舍者此间慢也。复作是说。屋舍是有漏行。复作是说。屋舍者起诸识更不起爱著者。更不复受有。汝尽胁勒摧者。爱欲已尽。复作是说。胁勒者。于此慢相应法彼永尽。复作是说。胁者起诸行结彼尽也。复作是说。胁者是爱彼尽。屋舍坏败者。五盛阴彼尽无余。复作是说。屋舍皆坏败者。身见彼尽无余。复作是说。屋舍是无明彼尽无余。复作是说。屋舍是识处住。彼尽无余

  人能善眠寐　　亦复忧所护
  心常乐禅中　　欲使坏娱乐

人能善眠寐者。阿吒罗婆尸佉法授决中广说也。阿吒罗婆作是说。彼亦不作忧如我所忧。世尊说彼不作忧如我所忧

  彼不为比丘　　从彼乞求者
  受取屋舍法　　如是非比丘

比丘契经彼非为比丘。不作比丘作比丘行法。家法者。受取屋舍作诸屋舍行。非以乞食为比丘也

  若有福有恶　　除去修梵行
  练灭受不起　　彼谓之比丘

若有福有恶者。福者是善有漏行阴。恶者不善。除去者谓已断也。梵行者修行其道。练灭不受起者。降伏一切魔众。降伏一切诸结。行者是住也。彼谓之比丘成就比丘行法。复作是说。福者不用定行。恶者无福行。已断灭彼而修梵行。二二三昧二二共会。练灭不起者。背彼彼道意止。彼谓之比丘断诸结

  青数白所覆　　一辐车而行
  不胜观此边　　断诸流结缚

广说如杂阿含

  二十九修跋陀人　　我出家行学道
  我已知五十岁　　于中学修跋陀
  戒定修行术　　独步思惟念
  敷演说法智　　于此无沙门

戒者身律口命清净。三昧者诸善心。独步行者是其事。术者是智。独步心思惟三昧敷演说法智。于彼此无沙门者。智法是道。彼入内外无沙门。问戒行有何差别。答曰。戒是有漏行是无漏。复作是说。戒是学行是无学。三昧心独处有何差别。答曰。三昧是有漏。一心独处是无漏。三昧是学。一心独处是无学。复作是说。戒是增上戒三昧是增上心行术。增上智慧是谓见谛道。一心思惟道。是谓见谛道思惟道。甚深法此少入无外沙门也。复作是说。戒行是增上戒。三昧独处学增上心术者。学增上智慧此是智法如少所入无外沙门也。复作是说。戒三昧如所说。于戒是修行。谓学增上行。行术者是增上智慧。是谓学增上智慧。独处心思惟者。是谓学增上心。是谓知法少所入外无沙门也

  有量无量集　　能仁舍诸行
  自谨慎内情　　无明卵自坏

有量无量集者。有量是行报生有。诸行者是寿行舍之。能仁者是无学。能仁内乐者禅解脱三昧乐。三昧中自谨慎以空为首。三谨慎自谨慎成就。无明卵自坏者。犹如坏卵[革*莫]也。不复观卵[革*莫]如是世尊。舍寿命不观寿命行。或作是说。量者是人。无量者是余行也。行者受诸有行。内自乐者乐诸道也。余亦如是

  若爱无住处　　意渐得开解
  彼爱能仁除　　不知天及人

若爱无住处者。情放逸流驰。彼有二种爱见也。无住处若由爱若由是。意有二种。意爱意见也。渐者俱越二三爱尽。能仁行天及人所不知。能仁行天及人所不能知。复作是说。若爱无住处。爱是欲爱也。住处诸见也。意渐得开解者。意是有爱。渐是无明。有二爱尽。天及人所不能知。诸见无明尽

  若内无嗔怒　　有有获种稷
  彼无恐畏恼　　诸天不往见

若内无嗔怒者。自喜无嗔恚。有有获种稷者。中有有是谓有。于此间有。彼无恐畏恼者。善修空善明十二因缘。乐者四出要乐而成就。无恼者无有遗余也。财物之忧设有遗余。财物之中若得若失亦无愁恼。诸天不往见者。已取涅槃不见五趣。复作是说。若内无嗔恚者。现嗔恚尽。有有获种稷者。现其欲尽。彼无恐畏恼者。善无有忧现愚痴尽。诸天不往见者。无欲无嗔恚亦无愚痴。已所涅槃不见涅槃

  人中等正觉　　自训专正志
  游行梵迹中　　常乐心灭息

人中者。生于人中。等正觉者。尽觉知诸法。自训者。自然具。专正志者。得三三昧。游行梵迹者。敬尊法中心。常乐灭息者。诸三昧心得休息。害诸结心得休息。而乐其中

  众人所敬仰　　尽超一切法
  诸天亦归命　　是谓闻无著

众人所敬仰者。承事归命。尽超一切法者。越诸善法。犹如超诸偈颂。亦度诸不善法。诸天亦归命者。诸天亦承事归命。是谓闻无著者。彼从世尊闻。佛天人所供养也

  一切结过去　　于园越园果
  于欲出要乐　　犹如炼真金

一切结过去者。度九结是谓一切结过去。复作是说。度于三结过去也。于园越园果者。五欲为园。于彼爱尽越诸爱患。越诸结越有乐。于欲出要者。于欲解脱乐初禅。复次欲中出要乐净处乐。等乐其中。是谓于欲出要乐。犹如炼真金者。如金被炼无有秽垢极妙。如是如来已越于欲尽无诸漏

  三佛名流布　　犹如日除冥
  于世第一尊　　亦如安明山

三佛名流布者。功德声闻世尊四方上下。乃至阿迦尼吒天皆闻其声。犹如日除冥者。如日出时普照世间。冥皆为明无不蒙其恩。如是世尊已逮正觉。以光明普照三界。于世第一尊者。以此名为尊。彼一切为现照明。亦如安明者。如须弥山王于众山中极高最大。世尊亦如是。于一切众生中而作偈导

  我当说其义　　亦不作悕望
  一切名龙者　　实名为如来

我当说其义者。当龙功德。亦不作悕望。尊因陀摩那作是说。是无义语。尊摩醯罗作是说。不作诸众行。或作是说。不作怨仇。如所说亦无嗔恚而有所作。复作是说。亦不造恶行。一切名龙者。实名为如来。诸有名龙者。于一切中如来最妙龙

  能忍不嫉彼　　如龙有二足
  殷勤修梵行　　所行龙余迹

能忍不嫉彼如龙有二足者。彼犹龙象前脚已得隐。然后身得回。如是如来以牢固法身得回转。殷勤修梵行所行龙余迹者。犹如龙象后脚以得隐。然后身得回转。如来亦如是。贤圣法服。曩昔诸如来。已得牢固法身得回转

  信为大龙象　　护为白双牙
  念颈智慧头　　威仪用法观

信为大龙象者。犹如龙象受取皆由鼻。如来如是。以信弃不善法而摄善法。犹如龙象鼻最为要。尊昙摩多罗作是颂契经者之重过。不得言如来之信。更自有因缘。一切诸智算数。象为大龙。犹如龙象受取皆由鼻。如来亦如是。亲近诸法数。亦复分别观有色身。清净行如来护亦复如是。贤圣八品道清净无尘垢。复作是说。犹如龙象牙不可移动。如来亦如是。于四等中受取诸气味。便得自在。如来牙亦如是。勇猛有众相。如来亦如是。于六善来。当有众相好丈夫之才。念颈者犹如龙象颈尽取一切诸味。如来神足亦复如是。一切诸法皆悉普具。复作是说。犹如龙象颈而扶持头。如来亦如是。念最为上头为智者。犹如龙象以头为命。如来亦如是。以智慧为命。复作是说。犹如龙象色身之中头最为上。如来亦如是。法身之中三耶三佛最为上。威仪用法观者。或作是说。此事亦如是二眼用法观。犹如龙象左右有两肩。如来亦如是。有二种。等身习出要。等身尽出要。迹灭不复起。复作是说。犹如龙象。有诸法观速疾而知。如来亦如是。有众相知众生。或作是说。犹如龙象心意有众相。若步若行皆悉知之。如来亦如是。于色身中头最为上。如来亦如是。阿耨多罗三藐三菩提法身中最为上。或作是说。此亦是其事。有入法观。犹如龙象左右有二肩。如来亦如是。有二种。等习身出要。等尽身出要。复作是说。犹如龙象法观作众相。御象知其相。如来亦如是。亦知其相解众生。或作是说。犹如龙象意之所念悉能成办。若行若住皆悉知之。本无如来亦复如是。知众生根本。或作是说。犹如龙象意之所念。若行若住皆悉知之。本无如来亦如是。知众生根相。或作是说。犹如是知众生根。或作是说。犹如龙象意之所念。若住若行皆悉知之。如来亦如是。知诸根相。亲近诸行。于众生中敷演法。默然承受奉行。展转相应

  法藏皆满具　　照明除拂去
  乐禅出入息　　内自善谨慎

法藏皆满具者。犹如龙象腹入若干种食。皆依仰之。如来亦如是。法等诸藏依法食。照明除拂去者。犹如龙象尾拂蚊虻蝇蚤皆能拂去。如来亦如是。身中敷演教乐禅。出入息内自善谨慎。犹如龙象以出入息而养其形常以为乐。如来亦如是。常以四禅而养其形。内方便具足

  龙行求茂草　　龙住威仪盛
  龙卧威仪具　　坐亦威仪成
  一切龙威成　　是谓龙威仪

龙行求茂草者。乃至是谓龙威仪者。世尊于一切威仪中戒三昧成就。得三昧亦成就。若威仪成就。意食不秽处而不食。龙食而量腹命亦不贪。意食不秽处秽处而不食者。秽处食者何等是。有贪意起与邪命俱。彼是秽处。无秽处者。反上事也。彼如来除去秽食。择无秽食使根充足而无众病。犹如膏拊创。亦如膏车。服众药草无有贪着。故曰不贪

  以得食断饥　　不畜积遗余
  受彼信施食　　除彼不与取

以得食断饥者。草为食覆为衣。不畜积遗余。不得畜积。不露形体。得施食才欲存形。受彼信施食。除彼不与取者。以法求取。复次当说其要。若得遗长复次藏贮以为家业。彼如来皆悉知除去非行。故曰断诸饥渴者也

  断诸一切结　　亦断诸缚着
  彼行在在处　　亦无忧畏患

断一切诸结者。灭七结也。亦断诸缚著者。灭三缚也。复次本无如来结根。使根永尽无缚着。起诸照明故。曰断诸一切结也。如来见诸秽心不染着。故曰彼行在在处处也

  愚死命有二数　　有无怒见家业
  善眠寐二比丘　　草覆衣一切使

偈揵度第三品竟

    尊婆须蜜菩萨所集偈品首

  见色无娱娱　　无欲及诸贪
  况革囊盛粪　　使五意移动

见色无娱娱者。何以故。世尊作是说。况革囊盛粪者。或作是说。现其爱尽。天乐天女。常无欲于彼。况革囊盛粪。复次欲断摩诃檀提(梵志)缚。不欲使频至佛所

  梵志慢满担　　怒烟害为灰
  口净心如火　　心者火坑藏

梵志慢满者。犹如负重担不畏惧于人。如是慢所缚不畏惧。怒烟者。犹如先有烟然后火乃然。如是失有怒然后方有教。犹如烟乱一切色。怒亦如是而乱众色。害为灰者。犹如灰无用于物。如是害亦无用于物也。口净者犹如净投火。如是舌长益于诸法。心者火坑藏者。犹如祠火处所。如是心为智火所然。自动人中明者。犹如自第一火

  信种自暴露　　智慧为耕犁
  惭愧心所缚　　心手之执杖

信种自暴露者。犹如先有萌牙。如是信为道然后行道。暴露者暴为闲居。犹如茎生得雨润泽。如是生善功德以暴润泽。智慧为耕犁者。犹如集聚耕地。如是信成众善功德。如是智慧成众善功德。耕者结使。惭愧者犹如犁轹。如是惭愧住智慧。心缚者三三昧是。意缚犹如辐。如是三昧犹如不移动。手执杖者。犹如耕地杖用驱行。如是念耕结得善驱

  身整口亦整　　犹如往求食
  实作择去秽　　受语而解脱

身整身律仪也。口整者口律仪。犹如往求食者。命命清净也。实作择去秽者。以智谛耕除诸。受语而解脱者。犹如耕犁。人事办则舍。如是等与相应而舍其行。诸已灭便有勇猛意

  勇猛共二轭　　方便获安处
  已往不复还　　所至无忧畏

勇猛共二轭者。犹如牛有力势不舍其轭。如是勇猛之力。亦不舍其轭。方便获安处者。有四方便已尽是谓涅槃。亦是安隐处勇猛志。彼已往不复还者。有力势不复还。所至无忧畏者。已到涅槃诸忧畏患永尽无余

  如是耕田作　　彼曰甘露果
  能忍如是业　　一切苦解脱

如是耕田作者。作如是修行道也。彼曰甘露果涅槃为果。能忍如是业者。修行此道。一切苦解脱者。于三界苦而得解脱。或作是说。道教于彼智慧断诸结使。身整口亦整。犹如往求食者。等语等业等命。勇猛共二轭者等方便也。念为杖者等念也。意缚者等三昧也。已说五根彼信种信根也。勇猛共二轭精进根也。念为杖者念根也意缚者定。根也智慧唱导是慧根也

  专念巧便求　　亦不乐在家
  群雁往奔池　　尽流除嗔恚

专念巧便求者。出家学道。专念者系念不移。亦不乐在家者。不乐处家恩爱之中。群雁往奔池尽流除嗔恚者。犹如群雁舍大山林无恋慕情。如是彼灭于五欲无恋慕情。所可用道灭于五欲。如所说法之所除。况非法也。复作是说。专念求巧便者。常乐闲居坐禅。亦不乐在家者。不乐于三界众生。群雁往奔池尽嗔恚者。流为无明。所可用道除无明。彼道亦除。复作是说。专念巧便求者。而修行道游居意山中。亦不乐在家者。远离爱着。如所说诸痛中爱此是爱也。已能舍彼亦不乐爱着。群雁往奔池尽流嗔恚者。流为六入。如所说长者眼为识流源。彼能灭六入所可用道。灭六入者。彼道亦灭

  诸度江海者　　作桥度彼岸
  有缚我求度　　智者先达岸

诸度江者。如所说如瞿昙世尊。由异学故往受恒水。水神作是说偈。彼河恒萨牢频闹作诸桥诸不得神足。或作是说。诸受频闹者。结为频生。死为萨牢。如所说由萨罗有是池。作诸桥修行道也。舍山者灭于五欲。缚拔求度者。外道求道。智者先达岸者。说度生死岸。复作是说。诸度频闹者。见谛所断结灭也。萨罗者思惟所断结灭也。作桥者兴起道也。舍山者灭诸盖。缚拔者修学道。智者先达岸。罗汉度生死岸

  不于见健疾　　是我之齐限
  非行能除往　　不染于家累

不于见健疾者。等智成就健疾。彼不净之见不闻健疾。非健疾者。能净其边。彼亦欲净于欲殷勤。界亦不闻将往。何以故。不染于家累者。彼不随此见

  若林柱牢固　　于他尽其语
  若无欲善根　　能仁亦牢固

若林柱牢固者。尊者阿那律授决中广说。犹如林柱不可移动。如是彼尊者。若毁骂若叹誉不可移动。于他尽其语者。语在内若毁骂复有叹誉者。善无欲者诸结使尽。善根者于三三昧。是三昧根。能仁亦复牢固者。佛声无学智

  不二行作讲堂　　养妻子非比丘
  于众生不改嗔　　能仁常护众生

不二行作讲堂者。猎师喻中已说。不二行作讲堂者。猎师所行闲居聚中。比丘行聚中聚。闲居猎师所为非行。比丘护贤行。养妻子非比丘。猎师及妻子比丘非其行。唯自养以法聚。彼于众生不改嗔者。猎师不改于杀生能仁常护众生者。比丘无有杀意

  于前中间后　　从他受信施
  亦无怨恨心　　能仁亦护彼

于前者不食。中间者半食。后者余食未尽。从他受信施。比丘得食。亦无怨恨心者。亦不骂亦不能伤其形。不作强颜。不是语我不得物。终不离此法。复作是说。于前者好微妙食。中者中食。后者下食。从他得信施者。从他受信施。不说恶语。所得恶食处亦不避。亦不执语所得恶食处。亦不频往彼乞求皆悉遍。复作是说。恶不能坏其意好不起爱着

  有说第一者　　夜叉净非净
  何为此解脱　　无余名曰善

有说第一者。此夜叉净说。犹如此有想无想天。何为此解脱者。如是无余智者方便说净

  饥渴第一病　　行为第一苦
  如实知是者　　涅槃第一乐

饥渴第一病者。断手授决中已说。彼断手不大苦。如饥渴者。行为第一苦者。彼行有若干种。若如实知此者。涅槃第一乐。能知如是行。不成就所作行口。彼便有乐。复作是说。饥渴第一病者。常为所缚乃至不可治。行为第一苦者。如实知之能知此诸行。诸行涅槃第一乐者。休息为乐。无所观为乐永乐。复作是说。饥渴为第一病者。是苦谛也。行为第一苦者。无明缘行也。受诸患是谓习谛也。如是实知者是道谛也。涅槃第一乐者是尽谛也

  惭愧梵志衣　　梵志手为净
  水常流不住　　舌陈为澡盥

惭愧梵志衣者。尊者大目揵连授决中已说。犹如衣裳用覆盖隐处。惭愧亦如是。盖覆隐处。梵志手净者。犹如已净祀火。我亦如是。而修净行去离行。水常流不住舌陈为澡盥者。犹如以澡盥荡涤不净器。我舌亦如是。除去秽行昼夜不休息

  祀火有常想　　以依内心意
  昼夜勤祠祀　　律仪不失节

祀火有常想者。止观彼然智火。以依内心意者。自依猗心彼能灭。昼夜修行律仪。不失节诸根。在内彼能思惟心被教训。是谓藏匿。复作是说。隐处者身口意。律仪训者诸戒具足。复作是说。惭愧梵志衣者。现善行起。梵志手净者。水常流不住。舌陈为澡盥。舌善行第二偈谓心善行。于三善行名婆罗门

  度惭常呵彼　　我与况汝要
  亦不作非行　　当知此非我

度惭者。可惭而不惭。彼当知不自亲。况当亲余者。常呵彼者非亲者。当知是怨仇而住我所。我与汝说要者。诸有杂秽。虽慎从众生。当知此奸秽。亦不作非行者。诸有亲厚事彼不起恼。所作方便当知慎怨家

  于欲意不离　　念亦无厌足
  观彼能离者　　彼具智慧足

于欲意不离者。菩萨授决中已说。乃至意念欲心亦无厌足。不能去离彼爱。能离者现欲想尽。于中次第观彼尽时。是说曰彼能离者。彼具慧乃足者。诸观欲不净彼着爱欲也

  谛谛而善见　　尊者转叹天

谛谛而善见者。谛是苦谛也。习谛增上谛是道谛也。尽谛复作是说。有三谛苦谛习谛道谛。增上是尽谛。复作是说。谛是等谛。增上第一义谛

  解脱彼此脱　　解脱复见缚
  贤圣不见脱　　解脱于愚惑

一子授决中已说。解脱彼此脱者。于妄语中解脱。为杀所染。解脱复见缚者。于一害得脱。复为他所染也。贤圣不得脱者。见谛而得解脱于愚惑。于缚系彼不得解脱。如是断灭见得解脱。有常见所缚。如是闻念中得解脱。如是身见中得解脱。为犹豫取缚。于贪欲得解脱。为色爱所缚。于色爱得解脱。为无色爱所缚

  若于长短中　　粗细好恶行
  于世不与取　　故曰名梵志

若于长短中者。答曰。长短不成就。于彼少有所观便有长也。少有所观便有短也。此如来教诫语也。又粗者亦不成就。问云何量亦不成就耶。答曰。于中不说量不可持亦无来者。若受不与取。彼则粗亦不成就。于彼亦不尽有量。有清净行亦有少成就。问诸有清净行成就。答曰。非以行不与取色。于中净不净行彼则成就。是广舌教诫之语。故曰梵志者。具足众行是谓梵志。或作是说。起诸不与取结诸结尽。是婆罗门

  不善而有善　　当依三佛家
  不住益众生　　彼曰而依有

不善而有善者。于不善中终便生余处。彼先灭本想。而更得余想。常依三佛家者。不依母胎。不住益众生者。于他家命终在母胎长大。彼曰而依有。意生有是善行

  若数于世易　　无胜况当世
  永灭无烟曀　　于中乐不害

满愿子于其中求数者。知而灭世者。诸入异于彼外。不异者是内。复作是说。异者是天。不异者是地狱。复作是说。异者色无色界相应。不异者欲界相应。此数是无常苦空无我。因果自相遍相。无胜况当世者。无明见所知。如说染着魔所缚息者。三火息灭休息。常永寂有灭息永烟曀灭现嗔恚所缠尽。复作是说。现内缘诸结尽无烟曀。如所说爱所行也。有觉息亦无烟曀。如所说有觉亦烟。无害者现三害尽。无望者现利望命望尽。复次现有爱尽。能有所越

  解脱堕复堕　　贪着复来还
  已还欢乐处　　于善住善处

解脱复堕者。解脱者于欲界脱。亦脱欲界结使。色无色界爱未尽。于彼堕堕便生。贪着复来还者。彼不能展转除尽欲界相应结来住彼。于彼方便染着。欲界诸结使不能拔离。复起欲界结使。来至欲界。已还欢乐处者。谓佛声闻彼已还安隐处。无生无病死之患。欢乐处者贤圣八品道。于善住善乐三昧乐于中游行。永还安乐处者。复作是说。解脱堕复堕者。于须陀洹得解脱堕地狱。彼堕天贪着复来还。欲界爱未尽。还来人间。还欢乐处者。无有恐惧入地狱之忧。乐者贤圣之道。于善住善者。越一切诸结还于涅槃。复作说。堕复堕者断灭见。解脱有常见。堕贪着复来还者。地狱饿鬼畜生。于有常断灭解脱而修行道。余者亦如是

  见慢起信意　　见偈等前后
  饥依欲及谛　　解脱满愿子

尊婆须蜜菩萨所集偈揵度第四竟

尊婆须蜜论卷第十


1578

    No. 1578

大乘掌珍论卷上

        清辩菩萨造

        大唐三藏法师玄奘奉　诏译

普为饶益一切有情。正发无上菩提大愿。等观世间。常为种种不正寻伺。纷扰暴风乱心相续。邪见罥网之所罥网。生死樊笼之所樊笼。无量忧苦毒箭所射。诸有所行皆离明慧。故我依止如净虚空。绝诸戏论寂静安乐。胜义谛理悲愿缠心。不忍见彼众苦所集。为欲解脱自他相续烦恼固缚住无退坏。踰于金刚坚固轮围。增上意乐誓处无边。生死大海不惮其中。所受无量众苦灾横。发金刚喻不坏精进。为正开觉如是观察。要证出世无分别智。方能正知先所未了。一切有情聚根胜解界行差别。及能破裂自他相续所起一切有习无习众苦根本烦恼罗网。亦能为他起真誓愿。坚固受持大士戒行。然证出世无分别智。要须积习能坏一切邪见眼瞙无倒观空安膳那药。如是积习无倒观空安膳那药。要藉能遣一切所缘自性闻慧。由是或有依广文义正决择门。已入法性数复勤修胜进加行。于广文义决择现前。甚大劬劳心生懈倦。或有虽复未入法性而是利根。为欲令彼易证真空速入法性故。略制此掌珍论

  真性有为空　　如幻缘生故
  无为无有实　　不起似空华

于自他宗计度差别虽有众多遍计所执。然所知境略有二种。一者有为。二者无为。以诸愚夫不正觉了胜义谛理有为无为无颠倒性。妄执诸法自性差别。增益种种邪见罥网。如世有一无智画师画作可畏药叉鬼像。或女人像。眩目乱意谓为实有。执实有故自起惊怖。或生贪染。于彼境界众多计度。增长分别诸见罥网。若正觉知胜义谛理有为无为无颠倒性。尔时如世有智画师。不执彼有真实自性。非如前说。有为无为境界差别邪见罥网。以自缠裹如蚕处茧。彼非有故。无分别慧趣入行成

为显斯义先辩有为。以诸世间于此境上多起分别故说是言。真性有为空如幻缘生故。此中世间同许有者。自亦许为世俗有故。世俗现量生起因缘亦许有故。眼等有为世俗谛摄。牧牛人等皆共了知。眼等有为是实有故。勿违如是自宗所许。现量共知。故以真性简别立宗。真义自体说名真性。即胜义谛。就胜义谛立有为空。非就世俗众缘合成。有所造作故名有为。即十二处。唯除法处一分虚空。择非择灭及真如性。此中复除他宗所许虚妄显现。幻等有为若立彼为空立已成过故。若他遍计所执有为。就胜义谛实有自性。今立为空。且如眼处。一种有为就胜义谛辩其体空。空与无性虚妄显现门之差别。是名立宗。众缘所起男女羊鹿诸幻事等。自性实无显现似有。所立能立法皆通有。为同法喻故说如幻。随其所应假说所立能立法同。假说同故。不可一切同喻上法皆难令有。如说女面端严如月。不可难令一切月法皆面上有。随结颂法说此同喻。如是次第由此半颂。是略本处故无有失。所立有法皆从缘生。为立此因说缘生故。因等众缘共所生故。说名缘生。即缘所起缘所现义。为遮异品立异法喻。异品无故遮义已成。是故不说于辩释时。假说异品建立比量亦无有过

云何此中建立比量。谓就真性眼处性空。众缘生故。诸缘生者。皆就真性其自性空。牧牛女等尚所共了。如有威神咒术药力。加彼草木块塼等物。众缘所现男女象马宫殿园林水火等相。诳惑愚夫种种幻事。若彼自性少有实者应非颠倒

故世尊言。一切法性非眼所见。诸缘生法皆无自性。诸有智者。若知缘生即知法性。若知法性即知空性。若知空性即见智者。又作是言。诸缘生者皆是无生。由彼都无生自性故。若说缘生即说空性。知空性者即无放逸。此中一切不空论者。皆设难言。若立一切有为皆空。便无色等如缘兔角。现量智生理不成就。似色等缘诸现量觉亦应不生。然彼实有各别内证。是故汝宗憎背法性。便有违害现量过失。及有违害共知过失。拨无一切牧牛人等同所了知眼等体故。诸有智者。今当遣除朋党执毒。住处中慧应共思议。我所立宗。为当违害自相续中所生现量。为当违害他相续中所生现量。若言违害自相续中所生现量。诸现量觉就胜义谛自性皆空。众缘生故。如睡梦中诸现量觉非实现量。是故我宗且不违害自相续中所生现量。若言违害他相续中所生现量。非净眼者显彼众多。眼翳眩者所见不实。发蝇月等是虚妄现。违害现量应正道理。是故我宗亦不违害他相续中所生现量。若总相说如愚夫等一切世俗所生现量。今此不遮世俗有故无容违害。言有违害共知过失。此亦不然。若言违害自论共知不应道理。自论许故。设违自论是违自宗。非是违害共知过失。若言违害他论共知亦不应理。一切论兴皆为破遣他共知故。若言违害牧牛人等共所了知亦不应理。诸佛弟子立一切行皆刹那灭。诸法无我亦无有情。诸胜论者。实异色等有异实等。诸数论者。觉体非思已灭未生皆是实有。如是等类广显自宗所有道理。皆应说名违害共知然不应许。以于此中就胜义谛观察诸法非关牧牛人等共知。又立宗中以胜义谛简别所立故定无容。如说违害由此亦无违自宗过

有余复言。性空论者。就胜义谛眼等处空。便有有法不成宗过。亦有所依不成因过。此不应理。牧牛人等共所了知。极成眼等总为宗故。即说彼法以为因故。此似有法不成宗过。亦似所依不成因过

有诸不善正理论者。作是难言。若就真性眼等皆空。众缘生故。眼等既空云何缘生。若缘生者云何体空。如是宗因更相违故。便成与宗相违过失。此若矫举立宗过失。方便显因无同法喻。或不成过。如说声是常一切无常故。此方便显非一切故。不明了因有不成过。以声摄在一切中故亦无同喻。如何是常而非一切。此不应理。缘生故。因及如幻喻皆共知故因喻并成。是故汝难终不能令智者意悦。有性论者复作是言。汝应信受眼根有性有所作故。诸无性者非有所作。如石女儿。眼有所作谓生眼识。如所说因有势用故。眼定有性。此若就彼非学所成。牧牛等慧所知自性。依世俗说。成立眼等有为有性。便立已成。若就胜义无同法喻。唯遮异品。所爱义成。不应道理。如计音声常住论者。说声是常所闻性故。瓶等无常非所闻性。声既所闻是故性常。又依世间共知同喻有所作故成相违因。能立眼等皆是世俗言说所摄。自性有故

余复难言。有为空者。若因若喻皆摄在中。种类同故阙比量过。今此颂中总说量果。于观察时及立量时。眼等一一别立为宗。故无此过。总立一切有为为宗亦无此过。缘生故因二宗皆许。非不成故。若说眼空其性空故。此所说因可有是过。亦非无喻幻等有故。若立所说喻中幻等以为宗者。便有重立。已成过故。有少智者作是难言。若立一切有为性空。因有为故其性亦空。是则此因有不成过。此似不成非真不成。如佛弟子立一切行皆无有我。由有因故。有难此因诸行中摄。亦无我故有不成过。又数论者立诸显事以苦乐痴为其自性。与思别故。有难此因显事中摄。亦以乐等为其性故有不成过。又胜论者立声无常。所作性故。有难此因用声为体亦无常故有不成过。如是等类诸敌论者。虽广勤求立论者过。如所说理毕竟无能破坏他论。若有此理。何处谁能建立比量。坏我所乐所说道理

复有难言。缘生故因终不能立。所应立义以性空故。如石女儿所发音声。此因于自有不成过。若说他宗所许为因亦不应理。以就他宗说性空故。其义未了。若非有义。是因义者。此因不成非非有故。若是虚妄显现有义。是因义者。石女儿声毕竟无故。此喻则无能立之法。又由化声有不定过。彼能成办无量有情。利乐事故。又非他宗独不许因。能立所立一不成故。犹如他宗所不成因。相违比量所损害故。有太过失所随逐故。如立慧等非心相应。行蕴摄故。如名身等立虚空等皆非是常。德所依故。犹如地等立我非思。非显事故。犹如最胜。如是等类坏一切宗。过失随逐故。定应信二宗共许。方名为因。由此道理如所说过无容得有

有余不善正理论者。为显宗过复作是言。若自性空所立能立皆不成就。如石女儿所发音声。能立摄在有为中故同彼所立。其性亦空。以俱空故。所立能立并不成就。彼遣所立。能立法体。即是遣于有法自相显立宗过。彼因自他互不成故。不决定故。喻有过故。如次前说亦不应理。虽设异端终不能掩自宗过失。有余复设别异方便掩自宗过。作如是言。所说真性有为空者。此立宗言其义未了。若就真性一切有为皆无有实。是立宗义。此所说言亦复摄在有为中故。同诸有为亦应无实。若所说言非无实者。有为亦应皆非无实。此言破自所立义故名违自言立宗过失。如立一切言说皆妄。若就真性一切有为都无所有。是立宗义。即谤一切皆无所有。如是所立便堕邪见。此中如说。我定依于我。谁言他是依。智者我善调。故得升天乐。彼就世俗说心为我。就胜义谛立为非我。无违自言。立宗过失此亦如是。此是就世俗性说有眼等。就胜义谛立彼皆空故无过失。复如有说。一切生法皆归于死。牟尼所言定无虚妄。自身既生亦应归死。不相离故。彼所立宗虽能证自亦归于死。是所许故无违自言。立宗过失此亦如是。说就真性有为皆空。众缘生故。所立宗言既众缘生亦应性空。不相离故。此立宗言虽能证自言说性空是所许故。无有自破所立义失。如梵志言。世尊。一切我皆不忍。佛言。梵志忍此事不。此中梵志固忍此事。而言一切我皆不忍。彼言违自所许事故。可有违害。自所言过。非一切处皆有此失。世尊余处说。一切行皆无有我。又余处说。诸行无常有生灭法。若不尔者。既说诸行无我无常。佛亦应有如所说过。然无彼失。如遮诸行我性常性。此立宗言。亦许同彼无我常故。此亦如是说有为空。所立宗言。亦许性空。此则顺成自所许义。是故汝说。此言破自所立义故。此因不成。又如数论立诸显事乐等为性。虽有难言显事。若以乐等为性。所立宗言。亦应用彼乐等为性。所立宗言。若非彼性显事亦应非彼为性。然所立宗无如是过。如立有为无常无我。亦无如彼所说宗失。此亦如是无所说过。意所许故。又彼论者不救所立。而返难言。若就真性有为无实。所说有为无实之言。亦应无实。此难不能免自宗过。妄说他宗同彼有失。如世痴贼既被推征不能自雪而立道理诬誷他言。汝亦是贼此非审察。所出言词又彼所言。若就真性一切有为都无所有。是立宗义。即谤一切皆无所有。如是所立堕邪见者。此中宗义如前广说谓空无性虚妄显现门之差别。非一切种皆谤为无。故汝不应作如是难

复有余师怀聪睿慢作是难言。若诸有为就胜义谛犹如幻等空无自性。即是非有。执非有故便为无见。彼欲覆障自宗过难。矫设谤言。宁俱有过勿空论者。所立量成。谤胜义谛过失大故。此非有言。是遮诠义。汝执此言表彰为胜。我说此言遮止为胜。此非有言。唯遮有性。功能斯尽无有势力。更诠余义。如世间说。非白绢言。不可即执。此言诠黑。与能说者作立宗过。非白绢言。唯遮白绢。功能斯尽更无余力。诠表黑绢赤绢黄绢。今此论中就胜义谛于有为境避常见边。且遮有性。如是余处避断见边遮于无性双避二边遮有无性。为避所余妄执过失。乃至一切心之所行悉皆遮止。所行若灭心正随灭。又于余处说阿难陀。若执有性即堕常边。若执无性即堕断边。如是余处说迦叶波。有是一边无是第二。由如是等阿笈摩故。及当所说诸道理故。我所立宗无触如粪无见过失

有不忍见自宗道理过难所集为欲隐映复作是言。性空论者虽常欣求无分别慧。而恒分别一切有为无为空性。即是成立遍计所执虚妄分别失自乐宗。如是亦遮故无此过。有余复言。所说空因若就世俗。或就胜义。于自于他因义不成。二宗共许。不显差别。总相法门明正理者。许为因故。汝所立难。似不成过非真不成。如胜论者立声无常所作性故。声常论者说彼过言。分别因义咽喉等作。或杖等作。如是分别因义不成。如数论者立能闻等五有情根非所造色。是根性故。犹如意根眼等五根。造色论者说彼过言。根性故因。若大造性。或乐等性。于自于他如是分别因义不成。彼二种说。似不成过非真不成。故不应理。此亦如是。复有余师。以聪明慢贪自宗爱眯乱慧目。不能观察善说珍宝自论鄙秽得失差别。妄显所立譬喻过言。咒术药力加被华果块塼等物。令其种种象马兔等色相显现。我宗不许。彼自性空。同喻便阙。所立无故。若言如幻象马等相。无有他实象马等性。说名为空。眼等亦尔。无他性故。立为空者便有宗过。立已成故。彼难不然。咒术药力加被华果块塼等物。众缘所生象马等相。象等性空。说为喻故。所立义成。若汝复谓。幻术所作象马等事。虽无他实象马等性。然不可说彼性空故此性亦空。岂非如彼相状显现即有如是诸物自性。如汝所许华果等物。若尔即应幻术所作象马等事实有如是象马等性。然实无有。故知一切幻术所作象马等事自性皆空。是故实有。如所说喻。所立义成。亦无成立。已成过失。就自性空成立眼等有为空故

复有诸余异空慧者。别显喻过。虽诸幻士非实士故说名为空。然彼幻士。自性不空。有虚妄现士相体故。由此道理。如先所立句义不成。喻不成故。今应诘彼。此虚妄现幻士相体从缘生不。彼作是答。此从缘生。若尔何故复名虚妄。以如所显现不如是有故。岂非眼等亦从缘生。如所显现不如是有。同喻成故。性空义成。汝应信受。彼作是言。不应信受。以诸幻士非如实士。堪审观察待彼实士。此虚妄故说名为空。非汝等立离前所说眼等有为别有眼等。堪审观察待彼说此。眼等性空可令信受。虽无离此所说眼等别有眼等。然有如是性空缘生。所立能立二法成就。但由此喻足能证成所喻义故。汝今分别法喻别故。便成分别相似过类。显敌论者自慧轻微。如胜论者说声无常所作性故。譬如瓶等。不应难言。瓶等泥团轮等所成。可烧可见棒所击破。可是无常。声既不尔。应非无常。此亦分别法喻别故。故成分别相似过类故应信受。眼等性空。性空不离缘生因故。又如相现即有。自性先已破故。此亦应尔。故汝等言。不能解雪自宗过难

有数论师作如是难。我立大等诸转变聚。是所显性缘生故因。有不成过。一切皆有。一切体故。诸根遍在一切处故。彼幻士中亦有此体。立此性空无同法喻。此中且依色觉观察。谓诸色觉非缘所显。随彼别缘有转异故。如随泥团轮杖陶师心欲乐等差别众缘有瓶盆等。或大或小。如是眼等众缘差别色觉。随彼种种转异。随眼明昧觉利钝故。随青等色境界差别。觉似青等显现异故。世间现见是所显物。不随彼缘差别转变。犹如明灯药珠日等。所显种种环钏等物。色觉不尔。如观色觉眼等亦然。此义成实世间共了。故所说因无不成过。又汝所言一切皆有一切体等为据显事为据隐用。若据显事执一切有一切体者。如于瓶处有瓶显事。于盆等处亦应遍有。此瓶显事遍有体故。如是一瓶即应遍满无量百千踰膳那处。于瓶等处亦应具有。盆等显事非瓶显事。被隐映故。盆等显事。亦被隐映。形量大故。形量大者应为转大形量隐映。瓶等显事盆等显事所隐映故。一切处时应不可得。是故汝宗据其显事一切皆有一切体者不应道理。若据隐用执一切有一切体者。如是所执要广观察。方可正知。是实非实。恐文烦过不广观察。汝宗亦许。幻士显处实士显空。我所立喻无不成过。是故所立性空义成。汝数论师非处投寄。亦非诸根遍一切处。有所因故。如根依处。如是能为乐苦痴觉生因故等。多种证因亦应广说。由破诸根遍一切处故。幻士中无诸根体。非所立空。无同法喻。是故汝成虚妄分别。魍魉所魅作如是计

相应论师有作是说。汝就真性立有为空缘生故者。若此义言。诸有为法从众缘生非自然有。就生无性立彼为空。是则述成相应师义符会正理。又如是说。由彼故空彼实是无。依此故空此实是有。如是空性是天人师如实所说。此教意言。遍计所执依他起上。自性本无非彼性故。以非如能诠有所诠性。亦非如所诠有能诠性故。依他起自性有上遍计所执自性本无。由彼故空即妄计事。彼自性无。依此故空。即缘生事此自性有。此若无者则为断灭。于何事上说谁为空。此缘生事即说名为依他起性。依此得有色受想等自性差别假立性转。此若无者假法亦无。便成无见。不应与言。不应共住。自堕恶趣亦令他堕。如是成立遍计所执。自性为空。及依他起自性为有。契当正理。若此义言。依他起性亦无所有故立为空。汝便堕落如上所说。过失深坑亦复成就诽谤世尊圣教过失。此中尚与发趣余乘及诸外道。欣求善说离悭嫉者。广兴诤论。何况同趣一乘诸师。论时至故少共决择此事。广如入真甘露已具分别。故不重辩。怖广文者不欣乐故。言有为法从众缘生非自然有。就生无性说彼为空。此有何义。若此义言。眼等有为依他起上不从因生常无灭坏。眼等自性毕竟无故。说名为空。便立已成。同类数论胜论等宗。皆共许故。然说眼等非所作宗。自性空故。应言无生。无性故空。不应说言就生无性说彼为空。若彼起时就胜义谛有自性生。云何说为生无自性。若实无生此体无故。不应说有唯识实性。若尔则有违自宗过。若依他起自然生性。空无有故说之为空。是则还有立已成过。既许依他众缘而生。实不空故应不名空。我则不尔。云何迷成相应师义。又如所说。由彼故空彼实是无。依此故空此实有等。若因缘力所生眼等一切世间共许实有。是诸愚夫觉慧所行。世俗似有自性显现。以胜义谛觉慧寻求。犹如幻士都无实性。是故说言。由彼故空彼实是无。为欲遮堕常边过故。如为弃舍堕常边过说彼为无。亦为弃舍堕断边过。说此为有。谓因缘力所生眼等世俗谛摄。自性是有。不同空华全无有物。但就真性立之为空。是故说言。依此故空此实是有。如是空性是天人师。如实所说。若就此义说依他起自性是有则为善说。如是自性我亦许故。随顺世间言说所摄。福德智慧二资粮故。世俗假立所依有故。假法亦有。然复说言。此若无者假法亦无。便成无见。不应与语。如是等过皆不成就。又若建立依他起性世俗故有。便立已成。若立此性胜义谛有。无同法喻。如已遮遣执定有性。亦当遮遣执定无性。是故不应谤言增益损减所说依他起性。若言我宗立有幻等离言实性。同喻无故非能立者。离言实性道理不成。故无有过。若尔外道所执离言实性。我等谁能遮破。彼亦说有实性。我等非慧非言之所行故。若众缘力所生一切依他起性就胜义谛有自性者。幻士应有实士自性。若有他性亦不应理。牛上不应有驴性故。作非作性实有实无。有性无性二俱摄受。如此所立无同法喻。或立已成二过所染。故不应理。又从缘生诸有为法。就胜义谛若许有性。所作故因。证彼性空遣彼性有。故所立宗违比量过。诸从缘生皆共了知。世俗有性若有定执。胜义谛有应以此理遮破彼宗。又彼不应摄受此论。就胜义谛二种分别不应理故。又如所说非如能诠有所诠性非如所诠有能诠性。诸敌论者于此无疑。故遮止言。立已成过。又如所说。故依他起自性有上。遍计所执自性本无此亦他论。于是无疑。故遮止言。立已成过。若言由执能诠所诠遍计所执自性有力生诸烦恼故须遮止。此亦不然。诸禽兽等不了能诠所诠相应。亦于境界不如理执生烦恼故。具有种种堪能意乐。亦有种种微妙圣言。遍计所执自性空教。唯益少分不遍一切故。我不独立之为空。且止傍论应辩正论

如是如前所说道理已具成立眼自性空。复有余师作如是难此能遮破有自性言。若是实有失所立宗。因成不定。若非实有即无自性不成能破。此亦不然。如世尊说。梵志当知。一切所说实非实言。我皆说为非实非妄。由此圣教及诸已说。当说道理。就胜义谛实与不实皆不建立。是故无有如所说过。又如汝意。所说道理所遮无故能遮亦无。非能遮无所遮便有。但由所遮本性无故能遮亦无。能遮唯能辩了所遮。本无自性。非能破坏所遮自性。如说菩萨不能以空空一切法。然一切法本性自空。乃至广说。又如能照照所照时。不应说言。瓶衣等物所照无故能照亦无。亦不应言所照物性本无今有。又我所立能遮所遮能立能破有倒无倒皆世俗有。若汝遮破所立能立即违自宗。此能遮言应非能立。性非实故。如石女儿所发音声。汝既许有。能立比量。我亦应尔。世俗有故。如前已说。但止广诤诸有厌怖。广文义者难受持故。如是如前所说比量无诸障难故所立宗。谓就真性眼处性空道理成就。又所立因缘生故者。略举名相。为遮所说眼等自性。复有余因。谓可坏故。随缘别故。可生起故。有时能起邪正智故。由此等因如其所应。随所对治应正遮破。复有说言。眼实有性。彼相因果皆现有故。非实性空现有相等现见眼等相等现有。是故眼等非实性空

此就胜义无同喻故。有性不成。若就世俗共知实性。便立已成。又依同喻因成相违。同喻唯有世俗性故

如就真性眼处性空。如是耳鼻舌身与意色声香味触处法处性空亦尔。修观行者。亦应如是悟入性空。又应总别就其真性成立蕴界。缘起念住正断神足根力觉支波罗蜜多诸三摩地陀罗尼门诸无碍解十力无畏不共法等一切智智皆自性空。修观行者。亦应如是悟入性空。又诸外道遍计所执大及我执。唯量根大。实德业等有为句义。悉皆摄在十二处中。是彼相故。修观行者。亦应如是悟入性空

如是虽由思择力故悟入性空阙修习力。譬如众鸟翅羽初生未能作用。故复精勤习修习力。如眩翳者饵能遣除眩翳药故眼得清净。离诸粗大。发蚊蝇等明见境界。如是勤习修习力故除遣执取。有为相垢疑惑邪智。修真观行初现前时。不由他缘受妙喜乐。不取一切有为相故。不取一切施物施者及受者故。不取一切施者受者及施果故。二种三轮皆得清净。乃能正勤摄受无量福智资粮。二种重担终不贪求。现非现果亦不爱乐。现事当果亲近供养。所爱有德种种天神。亦不妄执。德为作者我为作者。大自在天极微性等。常修大舍。如是等事皆由已说当说正理证得一切有为无为所破能破。法性空故。如世尊言。菩萨不应安住诸事行于布施。都无所住应行布施。乃至广说。又世尊言。若诸菩萨有情想转。不应说名真实菩萨。又世尊言。无有少法名能发趣菩萨乘者。是诸菩萨尚不希求般涅槃故勤修梵行。况复欣乐三界生死。如是正修一切有为性空观已。复应正观若自性空即无有生。若无有生即无过去未来现在。于其三世无有挂碍。正观三世皆清净相。依前所说无颠倒理。三轮清净趣大菩提。如有问言。曼殊室利云何菩萨趣大菩提。答言。梵志。应如菩提。复问。云何名为菩提。答曰。梵志。此非过去亦非未来及以现在。是故菩萨应观三世皆清净相。三轮清净趣大菩提

大乘掌珍论卷上大乘掌珍论卷下

        清辩菩萨造

        大唐三藏法师玄奘奉　诏译

如是已说修观行者总相悟入。有为性空。而未悟入无为性空。若不开示无由悟入。若不悟入无分别慧。谓趣入行终不得成。为开示故复说是言。无为无有实不起似空花。此中简别立宗言词。即上真性须简别意。如前应知。就真性故立无为空。非就世俗。非有为故说名无为。翻对有为是无为义。即是虚空择非择灭及真如性。谓前所除法处一分先显悟入。虚空性空易开示故。唯就空无有质碍物。世间共立名虚空故。由此为门悟入所余无为空性。即此世间所知虚空。就真性故空无有实。是名立宗。即此所立就真性故无实虚空。二宗皆许为不起故。或假立为不起法故。说名为因。空花无实亦不起故。立为同喻。不说遮止异品立为不同法喻。如前应知。云何此中建立比量。谓就真性虚空无实以不起故。诸不起者愚智同知。其性无实犹如空花。此所立因不起故者。略举名相。复有余因。非所作故。非能作故。无灭坏故。如是等因能遮所说无为空性。是故如应皆得为因。如说汝当守掌此酥勿令乌近。为令所守无损污故。亦应遮彼猫鼠等类

毗婆沙师咸作是难。若所立宗无为无实。是无有义。空处等至即无所缘。云何得有。然无障碍是虚空相。此若方便立比量言。空处等至实有所缘。或境实有。是等至故。如是等至所缘境故。如余等至。或如彼缘。其余等至及彼所缘。是有为故。已辩性空则无同喻。此就胜义辩虚空相。若就世俗所立虚空亦非实有。以不起故。犹如空花。由此比量彼所建立实有不成。又即由此我所说因。汝言等至所缘境故。因有决定相违过失。是故我先所立义成无障难故

自部他部有作是言。若就真性虚空无实。以不起故。此言义准。起者皆实。若言起者。亦无有实是则此因。不遍同品因性不成。此是义准。相似过类似不成过。此审定言。诸不起者皆无有实。非审定言。诸无实者悉皆不起。虽复勤勇无间所发。不遍同品亦许为因。故此无过

有余难言。虚空有性世共知故。花亦有性。嗢钵罗等世现见故。空花二种虽不相应非无自性。故空花喻所立不成。此难不然。此空花喻就第六转依士训释。空之花故说名空花。此既非有故喻非无

由此道理修观行者应正悟入虚空性空。于择灭等三种无为性空道理亦当悟入

毗婆沙师不忍遮破择灭无为。复作是难。佛说择灭对治有为故名出离。若谤言无。汝等便有违宗过失。又世尊说。喜贪俱行诸受尽灭。名为涅槃寂静微妙。云何言无。此中世尊欲令所化于有为境勤修厌离于无为境随顺欣乐故。就世俗说有择灭出离涅槃寂静微妙。如佛说有化生有情。说有无为涅槃亦尔。许此有故无违宗过。但就真性遮破择灭。故世尊言。诸有寻求涅槃有性。我说痴人外道弟子。乃至广说。又言。如来不见生死及以涅槃。言涅槃者如来假立。此中都无涅槃自性。乃至广说。亦无诽谤圣谛过失。以就世俗说有爱苦毕竟不生出离涅槃寂静微妙无颠倒故。非就胜义说有爱苦毕竟不生本性寂灭名为灭谛。由此圣教及所说理。就真性故说无择灭无此过失

有余不善正理论者作如是难。所立宗言无为无实。无为既无。所立不成。所依不成。空花无故有法不成。立宗因喻皆有过失。此难不然。想施设力于唯无有有质碍物。立为虚空。由慧简择于唯无有烦恼生起。立为择灭。由阙众缘于唯无有诸法生起。立非择灭。于唯无有一切所执。立为真如。想施设力许有假立。虚空等故不显差别。由共许力总立有法。差别遮遣非所共知。立为宗法。彼不起等共所了知。立为因法。是故无有立宗因过。所说空花虽无有事。是不起等法之有法无性性故。由是能成所成立义。故无有法不成过失

毗婆沙师复作是说。此亦不然。择灭实有。道所缘故。违烦恼故。非无实法可有是事。此言唯有遮异品故。如遮虚空实有性故。前已具破不应重执

经部诸师咸作是说。立虚空等皆非实有。如是比量立已成过。若此义言。有碍色等无性为体。非立已成辩彼无故。所立宗言。无为无实。此言正遣执实有性。亦复傍遣执实无性。铜鐷部师复作是说。诸间隙色说名虚空。我宗立彼是有为故。汝遣无为立已成过。有为自性如前已遣。故亦不然。毗婆沙师与犊子部。所执多同。应如彼破

相应论师有作是说。于胜义上更无胜义。真如即是诸法胜义。故就胜义说真如空。此言称理。而言真如非实有者。此不称理。云何出世无分别智及此后得清净世智。缘无为境是应正理。实不应理。如说世智缘无为境。不应正理。如是此智缘有为境亦不应理。非执真如实有应理。此实有性难成立故。缘真如智非真出世无分别智。有所缘故及有为故。如世缘智。是故经言。曼殊室利。慧眼何见。答言。慧眼都无所见。又说。云何名胜义谛。答言。此中智尚不行。况诸名字。又说。梵志。如来菩提非能现观。又契经言。曼殊室利。云何见谛。答言。此中无法可见忆持。此等诸契经者。不应许此无分别智是能现观及缘真如。又彼真如非真胜义。是所缘故。犹如色等。又汝所说于胜义上更无胜义。如是等言。若于此上空无此故说名为空。诸衣绢上更无衣绢。牧羊人等亦共了知。彼亦应名见真理者。又为对治诸恶见故说如是空。于胜义上更有胜义。此类恶见曾未有故。不应遮彼说如是空。又彼真如非实有性。违如前说。比量理故。如说如来不见生死及以涅槃。已正了知。非有颠倒所起烦恼。本性毕竟无生自性。如是正知本性毕竟。非是正知非不正知。由此圣教应知真如唯是一切分别永灭。非实有性非离非有。实性真如转依为相。法身成就。由得观空真对治道。一切分别遍计所执种子所依异熟识中分别等种无余永断。因缘无故毕竟不生。本性无生本性常住。是名如来转依法身。如契经说。曼殊室利。言如来者即是毕竟本无生句。常无生法是名如来。乃至广说。若言真如虽离言说而是实有。即外道我名想差别说为真如。如彼真如虽是实有。而就胜义有非有等分别不成。我亦如是彼亦计我。虽是实有周遍常住。作者受者而离分别。以非语言所行处故。分别觉慧所不缘故名离分别。彼教中说。言说不行心意不证。故名为我。我相既尔。而复说言。缘真如智能得解脱。非缘我智。此有何别。并无言说。有实性故。唯执朋党。说如是言。故我不能信受如是似我真如实有非有。且止广诤诸有厌怖。广文义者难受持故。入真甘露已具分别。复有同类乘劣乘者。作如是言。十二处摄有为无为定有自性。以有苦等十六圣行观四圣谛。精勤修习见修二道。能灭见修所断一切三界所摄烦恼炽火。及令三界众苦息故。若不开示诸法性空。谁当能舍如是过失。谁复能修如是功德。三乘虽有资粮根性胜解差别。现观圣道应无差别。如是一切我皆信受。为欲断除烦恼障故。依世俗理彼道差别。若离证入法无我性。不能永断所知障故。大师应成少分解脱。为不说言解脱解脱无差别耶。实有此说。皆同解脱烦恼障故。作如是言。非一切种。譬如毛孔与其太虚空性虽同非无差别。若不尔者。应不能发胜果作用如意神通。所证应非真实究竟。且止傍论应辩正论

修观行者。如已悟入自宗所计虚空等空。亦当悟入他宗所计自性士夫极微自在时方命等诸句义空

此中自性士夫论者作是难言。我宗三界一切皆似空花转变非无空花。由彼是有同喻不成违所立故。今应诘问。汝言三界一切皆似空花转变。如是三界为是空花为非空花。若言三界皆是空花。违害自宗及共知故不应道理。若言三界非是空花。是则为无同喻成就失汝本宗。若言不失空花无声所说三界有性故者。且应审察。汝为谓我说空花无为同法喻为说空花为同法喻。若汝谓我说空花无为同法喻。是恶审察。我说空花为同法喻故。若说空花为同法喻。即非三界。不应说言。三界有故彼亦是有。此言显汝自慧轻微。又遮诠言。遮止为胜。遮所遮已。功能即尽。无能更表所遮差别。如是难辞前已具释。故非智者心所信受

诸数论师复作是说。我虽不能亲现成立最胜士夫。然就共知诸变异聚方便成立。彼体实有。谓诸显事。有性为因。有种类故。诸有种类一切皆见。有性为因。如檀片等。显事既是有种类故。有性为因。如是显事有能受者。所受用故。诸所受用一切皆见有能受者。如婆罗门所受饮食。显事既是所受用故有能受者。前说比量便为敌量之所违害。此就世俗。若以总相立诸显事。有性为因。不辩差别便立已成。若立显事乐等为因。即无同喻因亦不成。乐等种类非共许故。若以比量成立因言。四蕴皆是苦乐痴性。是蕴性故。如受蕴者此所说痴。非受蕴摄。同喻不成。又汝士夫多体相遍有积聚义。即是蕴义。由此士夫因成不定。又汝乐等各别无能一一立宗。是蕴性故因义不成。若就胜义有实檀片。有性为因。非共许故同喻不成。又就世俗。若以总相立诸显事。有能受者。不辩差别。便立已成。世所共知。受者有故。若立显事有实受者常住周遍。思为自性同喻不成。如是体相诸婆罗门非共许故。若就胜义同喻不成。受者饮食皆实有性。非共许故。前说比量。无有敌量能为违害

诸胜论师复作是说。诸入出息闭目开目。令意行动。根变等相定有所相。是能相故。如见烟等。此就世俗。若以总相立彼诸相定有所相不辩差别便立已成。世俗共知我非无故。若立彼相有所相我常住周遍。乐等所依便无同喻。违所立故。若就胜义亦有如是喻不成过。时方空等由此道理亦应遮破

诸胜论师复作是难。极微与意我立无为成立空因不起故者。自不成因。若谓此二是有为摄成立空因缘生故者。他不成因。应成少分悟入空性。若意极微世俗亦许是无为者。可有此难。然所立意且非无为智生因故。犹如色等。如是句义同异性故。念生因故。此等余因如应当说。又诸极微亦非无为。能成因故。犹如缕等。如是其余有合离数同异等因。随应当说。或二极微所成粗物。非常为因。是所成故。犹如瓶等。如是其余是所作故。可灭坏故。是有因故。此等诸因。随应当说。由此道理他所妄执。意与极微皆自性空。是故无有如所说过

如上所说遮破数论胜论句义种种道理。无衣等论所执句义。亦随所应当立为空

如是遣除诸过难已。修观行者。正比量力悟入自他二宗所执无为性空。虽闻所成智阶梯力已入性空。阙胜修力未能永断所应除障。故复精勤习胜修力。若于此中随有一种为无为相有间无间。复现行时即应如理观彼性空。遣除彼相令不显现悟入诸法。离自性故。其性本空。由性空故相不成实。则是无相。由无相故无所愿求。则是无愿。由离相垢故成远离。又离性故缘彼烦恼毕竟不生。故成寂静。自性无起故成无生。由无生故则无无常。亦无有苦。亦无无我。又无生故则无有相。由无相故能以无相一相之行。观一切法悟入无二。由此行相勤习胜修。增长如是胜修力故。遣除粗相令不显现。由此令无所行行相。谓取有为无为行相。如眩翳者离粗眩翳眼得清净。不见先来所取诸相。虽于此中已得无住。然由空等分别现行。有功用心犹相续住。未得无动了知空等分别现行。障碍出世无分别慧。为欲弃舍勇猛正勤如是观察。就胜义故空性境上空等分别亦非实有。从缘生故。犹如幻等。如是勤修复能除遣空等分别。除遣彼故空不空等二边远离。不更以其空等行相观察诸法。如说般若波罗蜜多。正现行时于其色上不观为常不为无常不观为乐亦不为苦。不观为我亦非无我。不观寂静非不寂静。不观为空亦非不空。不观为相亦非无相。不观为愿亦非无愿。不观远离非不远离。如是于其受想行识一切色声香味触法所有眼耳鼻舌身意布施持戒忍辱精进静虑般若波罗蜜多念住正断。神足根力觉支道支静虑无色等至神通十力无畏诸无碍解不共佛法诸三摩地陀罗尼门一切智上。不观为常亦非无常。乃至广说

既能如是远离二边。即能生长处中妙行。此离二边处中道理。由如上说二种比量有为无为色类无故说名无色。由无色故。亦无有等诸分别故。无有少法可相表示。言彼既然此亦如是。故名无示。由无性故所依能依皆不成就。无有住持。故名无住。若有为相或无为相。若所分别非所分别。若能分别非能分别。如是等相觉慧不行。故名无现。远离一切有相无相。此境界识皆不生故。名无了别。由无色故。无形质故。方维幖帜皆无有故。名无幖帜。如世尊告迦叶波言。常为一边无常第二。此二中间无色无示无住无现无所了别无有幖帜。是则名为处中妙行。如实观察一切法性。广说乃至有为一边无为第二。乃至广说。又如佛告迦叶波言。明与无明皆无有二无二差别。此中正智是则名为处中妙行。既能如是远离二边。于能安住无二想上所起分别无二之想。亦能了知障碍出世无分别慧寂静安住。如所说因速能永断。永断彼故即无如是如是分别。语意二言并皆止息。证得无动无现无相。离诸戏论。诸法实性于其所缘无动证入。自相妙智相续安住。虽勤修习无倒空观。而于空性终不作证。如是名为胜义静虑。如世尊言。虽修静虑然不依色而修静虑。如是不依受想行识而修静虑。不依眼耳鼻舌身意而修静虑。不依色声香味触法而修静虑。不依于身分别安住而修静虑。不依于心分别安住而修静虑。不依于地水火与风而修静虑。不依于空日月星宿而修静虑。不依帝释梵王世主而修静虑。不依欲界色无色界而修静虑。不依此世及以他世而修静虑。不高不下证住无动而修静虑。不依我见而修静虑。如是不依有情命者养育士夫补特伽罗及以意生摩纳婆见而修静虑。不依断常有无有见而修静虑。不为漏尽而修静虑。不为趣入正性离生而修静虑。不为证果而修静虑。不为毕竟无所造作而修静虑。虽为修习无倒空观而修静虑。然于空性不为作证而修静虑

相应论者有定执言。一切所取能取分别悉皆远离是出世间无分别智。即于其中起坚实想精勤修习。有余于此正审察言如是智生。虽无如上所说分别。而随无相境相起故。自性分别所随逐故。是有为故。如余现量有分别觉。不成出世无分别智。又彼所计离相离言真如胜义。是所缘故。如余所缘不成胜义。即由此因俱非最胜。如契经言。云何此中名胜义谛。谓于其中智亦不行。又如问言曼殊室利。言慧眼者当何所观。答言。若有少所观者即非慧眼。由此慧眼无分别故不观有为。亦复不能观于无为。以诸无为非此慧眼所应行故。由此理教彼亦应断于此定执。复审察言。就胜义谛如是出世无分别智亦非实有。从缘生故。犹如幻士。于有所有妨难过失。如理观见当正遣除。若智能断如是定执。此亦如彼有过失故。不复精勤审察开示。如是等执既灭除已。于所应知无相境性亦无行解。因缘阙故。余智不生由无行解。是故说名真实行解。如世尊言。云何名为真实行解。谓于诸法都无行解。是则名为真实行解。又如经言。如来菩提都无现观。又如问言曼殊室利。诸见谛者当何所见。答言。无有少法可见。所以者何。凡有所见皆是虚妄。若无所见乃名见谛。又如问言。云何精勤应修现观。答言。若知无有少法思惟分别。如是精勤应修现观。复问云何已证现观。答言。若能观一切法皆平等性。复问。有能见一切法平等性耶。答言。无能见平等性。若有所见是则应成不平等见。真实行解见谛现观皆同一义。修观行者。尔时心意识智不行。说名正行无分别慧。若能如是行无所行。则得如来应正等觉真实授记。如契经言。世尊。菩萨云何修行于其无上正等菩提得诸如来应正等觉真实授记。梵志。菩萨若于是时不行于生不行于灭。不行于善不行不善。不行世间不行出世。不行有漏。不行无漏。不行有罪不行无罪。不行有为不行无为。不行相应及不相应。不行于断及以不断。不行生死及以涅槃。不行于见及闻觉知。不行于施及以弃舍。不行于戒及以律仪。不行于忍不行精进。不行静虑不行等持。不行于慧不行于解。不行于智不行于证。菩萨如是行无所行。于其无上正等菩提得诸如来应正等觉真实授记

如是慧行名圣默然。如契经言。于三十七菩提分法。如佛所说如实开示。是名说法。复于是法虽以身证而不观察离身有法。亦不观察离法有身。如是观察。谓观无二亦无不二。如是观时不随观察现量智见。不观察故名圣默然

由是理教审观察时。一切有为无为自性。无有能为若心若慧若有分别若无分别境界自性。如是知已。明慧日光能除一切愚痴黑闇

  诸心慧境现　　智者由不取
  慧行无分别　　无所行而行

此中能集诸行种子。或为诸行种子所集。故名为心。能持胜德或由彼持令不流散。故名为慧。心慧所行名心慧境。境地所行是名差别。心境即是有为无为所有诸相。慧境即是有为无为所有空性。如契经言。无相分别慧终不转。现谓显现。即似心慧。所行境界性相现义。诸谓地等。随其一类或总或别。如是眼等及以色等。随其一类或总或别。如是色受想行与识。随其一类或总或别。如是念住及以正断神足根力觉支道支。波罗蜜多一切神通。十力无畏不共佛法。诸三摩地陀罗尼门。预流一来及以不还。若阿罗汉所有道果。随其一类或总或别。广说乃至一切智智。于一切法能正了知无颠倒性。故名智者。由者谓说舍相因缘。言不取者无执无见。即是觉慧不计度义。由不取因为何所证。慧行无分别。无所行而行慧者即是无分别智。虽复永离一切分别觉慧增益。假名为智。以无影像无相无言境界起相自性分别亦无有故名无分别。虽无住者而就异位假名建立。如言灯灭阿罗汉灭。觉慧增益依俗言。说于此相续名无分别。如分别智名有分别。此中意取智无生行。说名为行。由此智行自他法性一切种相非所见故不名能见。即非能见说名真见。如所证故。非非所见作所见相。或有分别或无分别。真见得成。真如若是所见性者。不应说为非可见性。虽依世俗有平等见说名真见。不应执此不平等见。说名真见。诸可见者皆非真实。起解因故。如阳焰水一切可见皆非真实。真如若是可见性者。可见相取不成真见。若非可见不应说言证见真如。见非可见岂名平等。又智有为真如无为性不平等。若见应成不平等见。又诸法性皆非能见。见亦应尔。俱以无生为自性故。如是非见假名为见。非不平等。又一刹那证一切法。皆无现观名真现观。不应难言。返照自体难成立故。智应不证智之实性。二种俱非可见境性。无差别故同时俱证。若就胜义。似境相智。本性无生。故无现观亦无证得。如契经言。汝不应以现观证得。观于如来体是无为。出过一切眼所行故。如是梵志。如来安坐菩提座时。证一切法皆无所得。永断一切虚妄颠倒所起烦恼。如是等经悉皆随顺。且止傍论应辩正论。游履名行。无游履故名无所行。是无行解无生起义无分别慧。以不行相而为行故。即无所行说名为行。此则略说。如前正勤所成立果

修观行者。如是慧行无分别故。不行而行行即不行。远离一切所缘作意。于一切法都无所住。犹如虚空。弃舍一切遍计分别。淡泊寂然如入灭定观诸法性。诸佛法身不可思议不可了别。无二无藏无相无见。不可表示。无生无灭无有起尽。淡泊寂然无有差别。无相无影离诸瑕秽。超过一切觉慧语言境界道路。虽如是观而无所见。不见而见见即不见。如是妙见所摄受故。能正增长无量福聚。能感无边微妙乐果。清净一味能灭他苦。如药树王饶益一切正所求愿。如是正观如来法身。不见诸法有无相故名为正见。以息一切遍计分别名正思惟。由证诸法离诸戏论一切语言悉皆静息名为正语。由一切法非所作性不造彼因身语意业名为正业。以一切法皆是无增无减法性所有增减皆永不生名为正命。以一切法皆无发起无有造作勇猛方便名正精进。以于诸法毕竟不证境性有无无有忆念无所思惟名为正念。以一切种不取诸法无所依住名为正定。如是正观能修如此八支圣道。此义广如菩萨藏中处处宣说

如是正观非但能修八支圣道。亦能圆满略说六种波罗蜜多。虽无加行而有是事。其义云何。谓能弃舍一切种相。及能弃舍一切烦恼。是名为施波罗蜜多。能息一切所缘作意修无所得。是名为戒波罗蜜多。于诸所缘能不忍受。是名为忍波罗蜜多。无取无舍离一切行。是名精进波罗蜜多。一切作意皆不现行都无所作。是名静虑波罗蜜多。于一切法不起戏论远离二相。是名般若波罗蜜多。此义广如梵问经等处处宣说

如是妙住有无量门。无量经中世尊广说。有大义利多所饶益。诸有智者。应如实知离诸放逸当勤修学

大乘掌珍论卷下


百论

    No. 1569 [cf. Nos. 1570, 1571]

    百论序

        释僧肇作

百论者。盖是通圣心之津涂。开真谛之要论也。佛泥曰后八百余年。有出家大士。厥名提婆。玄心独悟俊气高朗。道映当时。神超世表。故能辟三藏之重关。坦十二之幽路。擅步迦夷。为法城堑。于时外道纷然。异端竞起。邪辩逼真。殆乱正道。乃仰慨圣教之陵迟。俯悼群迷之纵惑。将远拯沉沦。故作斯论。所以防正闲邪。大明于宗极者矣。是以正化以之而隆。邪道以之而替。非夫领括众妙。孰能若斯。论有百偈。故以百为名。理致渊玄。统群籍之要。文旨婉约。穷制作之美。然至趣幽简。鲜得其门。有婆薮开士者。明慧内融。妙思奇拔。远契玄踪。为之训释。使沉隐之义。彰于徽翰。风味宣流。被于来叶。文藻焕然。宗涂易晓。其为论也。言而无当。破而无执。傥然靡据。而事不失真。萧焉无寄。而理自玄会。返本之道。着乎兹矣。有天竺沙门鸠摩罗什。器量渊弘。俊神超邈。钻仰累年。转不可测。常味咏斯论。以为心要。先虽亲译。而方言未融。至令思寻者。踌躇于谬文。摽位者。乖迕于归致。大秦司隶校尉安成侯姚嵩。风韵清舒。冲心简胜。博涉内外。理思兼通。少好大道。长而弥笃。虽复形羁时务。而法言不辍。每抚兹文。所慨良多。以弘始六年岁次寿星。集理味沙门。与什考挍正本。陶练覆疏。务存论旨。使质而不野。简而必诣。宗致尽尔。无间然矣。论凡二十品。品各五偈。后十品。其人以为无益此土。故阙而不传。冀明识君子。详而揽焉

百论卷上

        提婆菩萨造　婆薮开士释

        姚秦三藏鸠摩罗什译

    舍罪福品第一

  顶礼佛足哀世尊　　于无量劫荷众苦
  烦恼已尽习亦除　　梵释龙神咸恭敬
  亦礼无上照世法　　能净瑕秽止戏论
  诸佛世尊之所说　　并及八辈应真僧

外曰。偈言世尊之所说。何等是世尊。内曰。汝何故生如是疑。外曰种种说世尊相故生疑。有人言。苇纽天(秦言遍胜天)名世尊。又言。摩醯首罗天(秦言大自在天)名世尊。又言。迦毗罗。优楼迦。勒沙婆等仙人皆名世尊。汝何以独言佛为世尊。是故生疑。内曰。佛知诸法实相。明了无碍。又能说深净法。是故独称佛为世尊。外曰。诸余导师亦能明了诸法相。亦能说深净法。如迦毗罗弟子。诵僧佉经。说诸善法总相别相。于二十五谛中。净觉分。是名善法。优楼迦弟子。诵卫世师经。言于六谛。求那谛中。日三洗。再供养火等和合。生神分善法。勒沙婆弟子。诵尼干子经言。五热炙身。拔发等受苦法。是名善法。又有诸师。行自饿法。投渊赴火。自坠高岩。寂默常立。持牛戒等。是名善法。如是等皆是深净法。何以言独佛能说耶。内曰。是皆邪见。覆正见故。不能说深净法。是事后当广说。外曰。佛说何等善法相。内曰。恶止善行法(修妒路)。佛略说善法二种。止相行相。息一切恶。是名止相。修一切善。是名行相。何等为恶。身邪行。口邪行。意邪行。身杀盗淫。口妄言两舌恶口绮语。意贪嗔恼邪见。复有十不善道。所不摄鞭杖系闭等。及十不善道前后种种罪。是名为恶。何等为止。息恶不作。若心生。若口语。若受戒。从今日终不复作。是名为止。何等为善。身正行。口正行。意正行。身迎送合掌。礼敬等。口实语。和合语。柔软语。利益语。意慈悲正见等。如是种种清净法。是名善法。何等为行。于是善法中。信受修习。是名为行。外曰。汝经有过。初不吉故(修妒路)。诸师作经法。初说吉故。义味易解。法音流布。若智人读诵念知。便得增寿威德尊重。如有经名婆罗呵波帝(秦言广主经)。如是经等。初皆言吉。以初吉故。中后亦吉。汝经初说恶故是不吉。是以言汝经有过。内曰。不然。断邪见故说是经(修妒路)。是吉。是不吉。此是邪见气。是故无过。复次无吉故(修妒路)。若少有吉。经初应言吉。此实无吉。何以故。是一事。此以为吉。彼以为不吉。或以为非吉非不吉。不定故无吉。汝愚人无方便。强欲求乐。妄生忆想。言是事吉。是事不吉。复次自他共不可得故(修妒路)。是吉法不自生。何以故。无有一法从自己生故。亦二相过故。一者生。二者能生。亦不从他生。自相无故。他相亦无。复次无穷故。以生更有生故。亦不共生。二俱过故。凡生法有三种。自他共。是三种中。求不可得。是故无吉事。外曰。是吉自生故如盐(修妒路)。譬如盐自性碱。能使余物碱。吉亦如是。自性吉。能使余物吉。内曰。前已破故。亦盐相盐中住故(修妒路)。我先破无有法自性生。复次汝意谓盐从因缘出。是故盐不自性碱。我不受汝语。今当还以汝语破汝所说。盐虽他物合。物不为盐。盐相盐中住故。譬如牛相不为马相。外曰。如灯(修妒路)。譬如灯既自照。亦能照他。吉亦如是。自吉亦能令不吉者吉。内曰。灯自他无闇故(修妒路)。灯自无闇。何以故。明闇不并故。灯亦无能照。不能照故。亦二相过故。一能照。二受照。是故灯不自照。所照之处亦无闇。是故不能照他。以破闇故名照。无闇可破故非照。外曰。初生时二俱照故(修妒路)。我不言灯先生而后照。初生时自照。亦能照他。内曰。不然。一法有无相不可得故(修妒路)。初生时名半生。半未生。生不能照。如前说。何况未生能有所照。复次一法云何亦有相亦无相。复次不到闇故(修妒路)。灯若已生。若未生。俱不到闇。性相违故。灯若不到闇。云何能破闇。外曰。如咒星故(修妒路)。若遥咒远人能令恼。亦如星变在天。令人不吉。灯亦如是。虽不到闇。而能破闇。内曰。太过实故(修妒路)。若灯有力不到闇。而能破闇者。何不天竺然灯。破振旦闇。如咒星力能及远。而灯事不尔。是故汝喻非也。复次若初吉余不吉(修妒路)。若经初言吉。余应不吉。若余亦吉。汝言初吉者。是为妄语。外曰。初吉故余亦吉(修妒路)。初吉力故余亦吉。内曰。不吉多故。吉为不吉(修妒路)。汝经初言吉。则多不吉。以不吉多故。应吉为不吉。外曰。如象手(修妒路)。譬如象有手故名有手。不以有眼耳头等。名为有眼耳头。如是以少吉力故。令多不吉为吉。内曰。不然无象过故(修妒路)。若象与手异。头足等亦异。如是则无别象。若分中有分具者。何不头中有足。如破异中说。若象与手不异者。亦无别象。若有分与分不异者。头应是足。二事与象不异故。如破一中说。如是吉事。种种因缘求不可得。云何言初吉故中后亦吉。外曰。恶止止妙。何不在初。内曰。行者要先知恶。然后能止。是故先恶后止。外曰。善行应在初。有妙果故(修妒路)。诸善法有妙果。行者欲得妙果故止恶。如是应先说善行。后说恶止。内曰。次第法故。先除粗垢。次除细垢。若行者不止恶。不能修善。是故先除粗垢。后染善法。譬如浣衣。先去垢然后可染。外曰。已说恶止。不应复言善行。内曰。布施等善行故(修妒路)。布施是善行。非是恶止。复次如大菩萨。恶已先止。行四无量心。怜愍众生。守护他命。是则善行非止恶。外曰。布施是止悭法。是故布施应是止恶。内曰。不然。若不布施便是恶者。诸不布施悉应有罪。复次诸漏尽人悭贪已尽。布施时止何恶。或有人虽行布施。悭心不止。纵复能止。然以善行为本。是故布施是善行。外曰。已说善行。不应说恶止。何以故。恶止即是善行故。内曰。止相息。行相作。性相违故。是故说善行。不摄恶止。外曰。是事实尔。我不言恶止善行是一相。但恶止则是善法。是故若言善行。不应复言恶止。内曰。应说恶止善行。何以故。恶止名受戒时息诸恶。善行名修习善法。若但说善行福。不说恶止者。有人受戒恶止。若心不善。若心无记。是时不行善故。不应有福。是时恶止故亦有福。是故应说恶止。亦应说善行。是恶止善行法。随众生意故。佛三种分别。下中上人施戒智(修妒路)。行者有三种。下智人教布施。中智人教持戒。上智人教智慧。布施名利益他舍财相应思。及起身口业持戒名若口语。若心生。若受戒。从今日不复作三种身邪行。四种口邪行。智慧名诸法相中。心定不动。何以说下中上。利益差降故。布施者少利益。是名下智。持戒者中利益。是名中智。智慧者上利益。是名上智。复次施报下。戒报中。智报上。是故说下中上智。外曰。布施者皆是下智不。内曰。不然。何以故。施有二种。一者不净。二者净行。不净施是名下智人。外曰。何等名不净施。内曰。为报施是不净。如市易故(修妒路)。报有二种。现报后报。现报者。名称敬爱等。后报者。后世富贵等。是名不净施。所以者何。还欲得故。譬如贾客远到他方。虽持杂物。多所饶益。然非怜愍众生。以自求利故。是业不净。布施求报亦复如是。外曰。何等名净施。内曰。若人爱敬利益他故。不求今世后世报。如众菩萨。及诸上人行清净施。是名净施。外曰。持戒皆是中智人不。内曰。不然。何以故。持戒有二种。一者不净。二者净。不净持戒者。名中智人。外曰。何等不净持戒。内曰。持戒求乐报。为淫欲故。如覆相(修妒路)。乐报有二种。一者生天。二者人中富贵。若持戒求天上。与天女娱乐。若人中受五欲乐。所以者何。为淫欲故。如覆相者。内欲他色。外诈亲善。是名不净持戒。如阿难语难陀

  如羝羊相触　　将前而更却
  汝为欲持戒　　其事亦如是
  身虽能持戒　　心为欲所牵
  斯业不清净　　何用是戒为

外曰。何等名净持戒。内曰。行者作是念。一切善法。戒为根本。持戒之人。则心不悔。不悔则欢喜。欢喜则心乐。心乐得一心一心则生实智。实智生则得厌。得厌则离欲。离欲得解脱。解脱得涅槃。是名净持戒。外曰。若上智者。郁陀罗伽等为上(修妒路)。若行智人。是名上智。今郁陀罗伽。阿罗逻外道等。应为上智人。内曰。不然。何以故。智亦有二种。一者不净。二者净。外曰。何等名不净智。内曰。为世界系缚故不净。如怨来亲(修妒路)。世界智能增长生死。所以者何。此智还系缚故。譬如怨家。初诈亲附。久则生害。世界智亦如是。外曰。但是智能增长生死。施戒亦尔耶。内曰。取福舍恶是行法(修妒路)。福名福报。外曰。若福名福报者。何以修妒路中但言福。内曰。福名因。福报名果。或说因为果。或说果为因。此中说因为果。譬如食千两金。金不可食。因金得食。故名食金。又如见画言是好手。因手得画故名好手。取名著。着福报恶先已说。行名将人常行生死中。外曰。何等是不行法。内曰。俱舍(修妒路)俱名福报罪报。舍名心不着。心不着福不复往来五道。是名不行法。外曰。福不应舍。以果报妙故。亦不说因缘故(修妒路)。诸福果报妙。一切众生常求妙果。云何可舍。又如佛言。诸比丘。于福莫畏。汝今又不说因缘。是故不应舍福。内曰。福灭时苦(修妒路)。福名福报。灭名失坏。福报灭时。离所乐事。生大忧苦。如佛说。乐受生时乐。住时乐。灭时苦。是故应舍福。又如佛言于福莫畏者。助道应行故。如佛说。福尚应舍。何况罪。外曰。罪福相违故。汝言福灭时苦者。罪生住时应乐。内曰。罪住时苦(修妒路)。罪名罪报。罪报生时苦。何况住时。如佛说。苦受生时苦。住时苦。灭时乐。汝言罪福相违故。罪生时应乐者。今当答汝何不言福罪相违故。罪灭时乐。生住时苦。外曰。常福无舍因缘故不应舍(修妒路)。汝说舍福因缘灭时苦。今常福报中。无灭苦故不应舍。如经说。能作马祀。是人度衰老死。福报常生处常。是福不应舍。内曰。福应舍。二相故(修妒路)。是福有二相。能与乐。能与苦。如杂毒饭食时。美欲消时苦。福亦如是。复次有福报是乐因。多受则苦因。譬如近火。止寒则乐。转近烧身则苦。是故福二相。二相故无常。是以应舍。又汝言马祀福报常者。但有言说。无因缘故(修妒路)。马祀福报实无常。何以故。马祀业因缘有量故世间因若有量。果亦有量。如泥团小。瓶亦小。是故马祀业有量故无常。复次闻汝天有嗔恚。共斗相恼故不应常。又汝马祀等业。从因缘生故皆无常。复次有漏净福无常故尚应舍。何况杂罪福(修妒路)。如马祀业中。有杀等罪故。复次如僧佉经言。祀法不净．无常．胜负相故。是以应舍。外曰。若舍福不应作(修妒路)。若福必舍。本不应作。何有智人空为苦事。譬如陶家作器还破。内曰。生道次第法。如垢衣浣染(修妒路)。如垢衣先浣后净乃染浣净不虚也。所以者何。染法次第故。以垢衣不受染故。如是先除罪垢。次以福德熏心。然后受涅槃道染。外曰。舍福依何等(修妒路)。依福舍恶。依何舍福。内曰。无相最上(修妒路)。取福人天中生。取罪三恶道生。是故无相智慧最第一。无相名一切相不忆念。离一切受。过去未来现在法心无所著。一切法自性无故。则无所依。是名无相。以是方便故能舍福。何以故。除三种解脱门。第一利不可得。如佛语诸比丘。若有人言我不用空无相无作。欲得若知若见。无增上慢者。是人空言无实

    破神品第二

外曰。不应言一切法空无相。神等诸法有故(修妒路)。迦毗罗。优楼迦等言。神及诸法有。迦毗罗言。从冥初生觉。从觉生我心。从我心。生五微尘。从五微尘生五大。从五大生十一根。神为主常。觉相。处中。常住不坏不败。摄受诸法。能知此二十五谛。即得解脱。不知此者。不离生死。优楼迦言。实有神常。以出入息视眴寿命等相故。则知有神。复次以欲恚苦乐智慧等所依处故。则知有神。是故神是实有。云何言无。若有而言无。则为恶邪人。恶邪人无解脱。是故不应言一切法空无相。内曰。若有神而言无。是为恶邪。若无而言无。此有何过。谛观察之。实无有神。外曰。实有神。如僧佉经中说。觉相是神。内曰。神觉为一耶。为异耶。外曰。神觉一也。内曰。觉若神相。神无常(修妒路)。若觉是神相者。觉无常故。神应无常。譬如热是火相。热无常故。火亦无常。今觉实无常。所以者何。相各异故。属因缘故。本无今有故。已有还无故。外曰。不生故常(修妒路)。生相法无常。神非生相故常。内曰。若尔觉非神相(修妒路)。觉是无常。汝说神常。神应与觉异。若神觉不异者。觉无常故。神亦应无常。复次若觉是神相。无有是处。所以者何。觉行一处故(修妒路)。若觉是神相者。汝法中神遍一切处。觉亦应一时遍行五道。而觉行一处不能周遍。是故觉非神相。复次若尔神与觉等(修妒路)。汝以觉为神相者。神应与觉等。神则不遍。譬如火无热不热相。神亦如是。不应有遍不遍相。复次若以为遍。则有觉不觉相(修妒路)。汝欲令神遍。神则二相。觉不觉相。何以故。觉不遍故。神若堕觉处是则觉。若堕不觉处是则不觉。外曰。力遍故无过(修妒路)。有处觉虽无用。此中亦有觉力。是故无无觉过。内曰。不然。力有力不异故(修妒路)。若有觉力处是中觉应有用而无用。是故汝语非也。若如是说。觉无用处。亦有觉力者。但有是语。外曰。因缘合故。觉力有用(修妒路)。神虽有觉力。要待因缘合故。乃能有用。内曰。堕生相故(修妒路)。若因缘合时觉有用者。是觉属因缘故。则堕生相。若觉神不异。神亦是生相。外曰。如灯(修妒路)。譬如灯能照物不能作物。因缘亦如是。能令觉有用。不能生觉。内曰。不然。灯虽不照瓶等。而瓶等可得。亦可持用。若因缘不合时。觉不可得。神亦不能觉苦乐。是故汝喻非也。外曰。如色(修妒路)。譬如色。虽先有灯。不照则不了。如是觉虽先有。因缘未合故亦不了。内曰。不然。自相不了故(修妒路)。若未有照。人虽不了色相自了。汝觉相自不了。是故汝喻非也。复次以无相故。色相不以人知故为色相。是故若不见时常有色。汝知是神相。不应以无知处为知。无知处为知。是事不然。汝法中知觉一义。外曰。优楼迦弟子。诵卫世师经。言知与神异。是故神不堕无常中。亦不无知。何以故。神知合故。如有牛(修妒路)。譬如人与牛合故人名有牛。如是神情意尘合故。神有知生。以神合知故。神名有知。内曰。牛相牛中住。非有牛中(修妒路)。牛相牛中住。不在有牛中。是故虽人牛合有牛不作牛。但牛为牛。如是虽神知合。知相知中住。神不为知。汝言神情意尘合故知生。是知知色尘等。是故但知能知非神知。譬如火能烧。非有火人烧。外曰。能用法故(修妒路)。人虽有见相用灯则见离灯则不见。神虽有能知用知则知离知则不知。内曰。不然。知即能知故(修妒路)。以情意尘合故知生。是知能知色等诸尘。是故知即能知非是所用。若知即能知。神复何用。灯喻非也。何以故。灯不知色等故(修妒路)。灯虽先有。不能知色等。非知法故。是故但知能知色。若不能知。不名为知。是故纵有能知。彼能何用。外曰。马身合故神为马(修妒路)。譬如神与马身合故。神名为马。神虽异身。亦名神为马。如是神知合故神名为知。内曰。不然。身中神非马(修妒路)。马身即马也。汝谓身与神异。则神与马异。云何以神为马。是故此喻非也。以神喻神。则堕负处。外曰。如黑叠(修妒路)。譬如黑叠。黑虽异叠。叠与黑合故名为黑叠。如是知虽异神神与知合故神名为知。内曰。若尔无神(修妒路)。若神与知合故神名为知。神应非神。何以故。我先说知即是能知。若知不名神。神亦不名能知。若他合故以他为名者。知与神合何不名知为神。又如先说黑叠喻者。自违汝经。汝经黑是求那。叠是陀罗骠。陀罗骠不作求那。求那不作陀罗骠。外曰。如有杖(修妒路)。譬如人与杖合故人名有杖。不但名杖。杖虽与人合。杖不名有人。亦不名人。如是神与知合故神名能知。不但名知。亦非是知。与神合故。知名为神。内曰。不然。有杖非杖(修妒路)。虽杖与有杖合有杖不为杖。如是知相知中非神中。是故神非能知。外曰。僧佉人复言。若知与神异。有如上过。我经中无如是过。所以者何。觉即神相故。我以觉相为神。是故常觉无不觉。内曰。虽已先破。今当更说。若觉相神不一(修妒路)。觉有种种苦乐觉等。若觉是神相。神应种种。外曰。不然。一为种种相。如颇梨(修妒路)。如一颇梨珠随色而变。或青黄赤白等。如是一觉。随尘别异。或觉苦或觉乐等觉虽种种相。实是一觉。内曰。若尔罪福一相(修妒路)。若益他觉是名福。若损他觉是名罪。一切慧人心信是法。若益他觉损他觉是一者。应罪福一相。如施盗等亦应一。复次如珠。先有随色而变。然觉共缘生。是故汝喻非也。复次珠新新生灭故。相则不一。汝言珠一者。是亦非也。外曰。不然。果虽多作者一。如陶师(修妒路)。如一陶师作瓶盆等。非作者一故果便一也。如是一觉能作损益等业。内曰。陶师无别异(修妒路)。譬如陶师身一无异相。而与瓶盆等异。然益他觉损他觉。实有异相。又损益等与觉不异。是故汝喻非也。外曰。实有神。比知相故(修妒路)。有物虽不可现知。以比相故知。如见人先去然后到彼。日月东出西没。虽不见去。以到彼故知去。如是见诸求那依陀罗骠。以比知相故知有神。神知合故。神名能知。内曰。是事先已破。今当更说。不知非神(修妒路)。汝法神遍广大而知少。若神知者。有处有时不知。是则非神。有处名身外。有时名身内。睡眠闷等是时不知。若神知相有处有时不知。是则非神。何以故。无知相故。汝以知相有神者。空无实也。外曰。行无故知无如烟(修妒路)。如烟是火相。炭时无烟。是时虽无烟而有火。如是知虽神相。若有知。若无知。神应常有。内曰。不然。神能知故(修妒路)。若不知时。欲令有神者。神则不能知。亦无知相。所以者何。汝神无知时亦有神故。复次若无烟时。现见有火知有火。神若有知。若无知无能见者。是故汝喻非也。复次汝说见共相比知故有神。此亦非也。所以者何。见去者去法到彼故(修妒路)。若离去者无去法。离去法无去者。到彼如是见去者曰到彼必知有去法。若离神无知。是事不然。是故不应以知故知有神。不可见龟而有毛想。不可见石女而有儿想。如是不应见知便有神想。外曰。如手取(修妒路)。如手有时取。有时不取。不可以不取时不名为手。手常名手。神亦如是。有时知。有时不知。不可以不知时不名为神。神常名神。内曰。取非手相(修妒路)。取是手业非手相。何以故。不以取故知为手。汝以知即神相。此喻非也。外曰。定有神。觉苦乐故(修妒路)。若无觉者。则无觉身独。不能觉苦乐。何以故。死人有身。不能觉苦乐。如是知有身者。能觉苦乐。此则为神。是故定有神。内曰。若恼亦断(修妒路)。如刀害身。是时生恼。若刀害神。神亦有恼者。神亦应断。外曰。不然。无触故如空(修妒路)。神无触故不可断。如烧舍时。内空无触故不可烧但有热。如是断身时。内神无触故不可断。但有恼。内曰。若尔无去(修妒路)。若神无触。身不应到余处。何以故。去法从思惟生。从身动生。身无思惟。非觉法故。神无动力。非身法故。如是身不应到余处。外曰。如盲跛(修妒路)。譬如盲跛相假能去。如是神有思惟。身有动力。和合而去。内曰。异相故(修妒路)。如盲跛。二触二思惟故法应能去。身神无二事故不应去。是故无去法。若不尔有如上断过。复次汝谓空热。此事不然。何以故。空无触故。微热遍空。身触觉热非空热也。但假言空热。外曰。如舍主恼(修妒路)。如烧舍时。舍主恼而不烧。如是身断时。神但恼而不断。内曰。不然。无常故烧(修妒路)。舍烧时。草木等无常故。亦烧亦热。空常故不烧不热。如是身无常故。亦恼亦断。神常故不恼不断。复次舍主远火故不应烧。汝经言。神遍满故。亦应断坏。外曰。必有神取色等故(修妒路)。五情不能知五尘。非知法故。是故知神能知。神用眼等。知色等诸尘。如人以镰收刈五谷。内曰。何不用耳见(修妒路)。若神见有力。何不用耳见色。如火能烧。处处皆烧。又如人或时无镰手亦能断。又如舍有六向。人居其内所在能见。神亦如是。处处应见。外曰。不然。所用定故。如陶师(修妒路)。神虽有见力。然眼等所伺不同。于尘各定故。不能用耳见色。如陶师虽能作瓶。离泥不能作。如是神虽有见力。非眼不能见。内曰。若尔盲(修妒路)。若神用眼见。则神与眼异。神与眼异。则神无眼。神无眼云何见。汝陶师喻者。是亦不然。所以者何。离泥更无有瓶。泥即为瓶。而眼色异故。外曰。有神异情动故(修妒路)。若无神者。何故见他食果。口中生涎。如是不应以眼知味。有眼者能知。复次一物眼身知故(修妒路)。如人眼先识瓶等。闇中虽不用眼。身触亦知。是故知有神。内曰。如盲。修妒路中已破。复次若眼见他食果。而口生涎者。余情何以不动。身亦如是。外曰。如人烧(修妒路)。譬如人虽能烧。离火不能烧。神亦如是。用眼能见。离眼不能见。内曰。火烧(修妒路)。言人烧者。是则妄语。何以故。人无烧相。火自能烧。如风动木。相揩生火。焚烧山泽。无有作者。是故火自能烧。非人烧也。外曰。如意(修妒路)。如死人虽有眼无意故。神则不见。若有意神则见。如是神用眼见。离眼不见。内曰。若有意能知。无意不能知者。但意行眼等门中便知。神复何用。外曰。意不自知。若意意相知。此则无穷。我神一故。以神知意非无穷也。内曰。神亦神(修妒路)。若神知意。谁复知神。若神知神。是亦无穷。我法以现在意知过去意。意法无常故无咎。外曰。云何除神(修妒路)。若除神云何但意知诸尘。内曰。如火热相(修妒路)。譬如火热。无有作者。火性自热。无有不热之火。如是意是知相。虽复离神性知故能知。神知异故神不应知。外曰。应有神宿习念相续故。生时忧喜行(修妒路)。如小儿生。便知行忧喜等事。无有教者。以先世宿习忆念相续故。今世还为种种业。是故知有神亦常相。内曰。遍云何念(修妒路)。神常遍诸尘。无不念时。念从何生。复次若念一切处生。念亦应遍一切处。如是一切处应一时念。若念分分处生。神则有分。有分故无常。复次若神无知。若知非神。此事先已破。外曰。合故念生(修妒路)。若神意合。以势发故念生。何以故。神意虽合。势不发者。则念不生。内曰。虽先已破。今当重说。神若知相。不应生念。若非知相。亦不应生念。复次若念知(修妒路)。若念生是时知。若念不生。是时不知。应念即是知。神复何用。外曰。应有神。左见右识故(修妒路)。如人先左眼见。后右眼识。不应彼见此识。以内有神故。左见右识。内曰。共答二眼(修妒路)。分知不名知。复次若尔无知。复次遍云何念。复次若念知。复次何不用耳见。复次若尔盲。复次如左眼见。不应右眼识。神亦不应此分见彼分识。是故不应以左眼见。右眼识故。便有神。外曰。念属神故神知(修妒路)。念名神法。是念神中生。是故神用念知。内曰。不然。分知不名知(修妒路)。若神一分处知生。神则分知。若神分知。神不名知。外曰。神知非分知。何以故。神虽分知。神名知。如身业(修妒路)。譬如身分手有所作名为身作。如是神虽分知。神名知。内曰。若尔无知(修妒路)。汝法神遍意少。神意合故神知生。是知与意等少。若以少知神名知者。汝何不言以多不知故神名不知。又汝身业喻者。此事不然。何以故。分有分一异不可得故。外曰。如衣分烧(修妒路)。譬如衣一分烧名为烧衣。如是神虽一分知。名为神知。内曰。烧亦如是(修妒路)。若衣一分烧。不名为烧。应名分烧。汝以一分烧故衣名烧者。今多不烧应名不烧。何以故。是衣多不烧。实有用故。是以莫着语言

    破一品第三

外曰。应有神。有一瓶等。神所有故(修妒路)。若有神则有神所有。若无神则无神所有。有一瓶等是神所有故有神。内曰。不然。何以故。神已不可得故。今思惟有一瓶等。若以一有。若以异有。二俱有过。外曰。有一瓶等。若以一有。有何过。内曰。若有一瓶一。如一一切成。若不成。若颠倒(修妒路)。若有一瓶一者。如因陀罗释迦憍尸迦。其有因陀罗处。则有释迦憍尸迦。如是随有处则有一瓶。随一处则有有瓶。随瓶处则有有一。若尔衣等诸物亦应是瓶。有一瓶一故。如是其有一物皆应是瓶。今瓶衣等物悉应是一。复次有常故一瓶亦应常。复次若说有则说一瓶。复次一是数。有瓶。亦应是数。复次若瓶五身。有一亦应五身。若瓶有形有对。有一亦应有形有对。若瓶无常。有一亦应无常。是名如一一切成。若处处有。是中无瓶。今处处瓶是亦无瓶。有不异故。复次事事有。不是瓶。今瓶则非瓶。有不异故。复次若说有。不摄一瓶。今说一瓶。亦不应摄一瓶。有不异故。复次若有非瓶。瓶亦非瓶。有不异故。是名如一一切不成。若欲说瓶应说有。欲说有应说瓶。复次汝瓶成故。有一亦成。若有一成故瓶亦应成。以一故是名如一一切颠倒(此中四纸辩名字无可传译)。外曰。物有一故无过(修妒路)。物是有。亦是一。是故若有瓶处必有有一。非有一处皆是瓶。复次若说瓶。当知已摄有一。非说有一必摄瓶。内曰。瓶有二。何故二无瓶(修妒路)。若有一瓶一。何故有一处无瓶。复次云何说有一不摄瓶。外曰。瓶中瓶有定故(修妒路)。瓶中瓶有与瓶不异。而异于衣物等。是故在在处瓶。是中有瓶有。亦在在处瓶有。是中有瓶非在在有处有瓶。内曰。不然。瓶有不异故(修妒路)。有是总相。何以故。若说有则信瓶等诸物。若说瓶不信衣等诸物。是故瓶是别相。有是总相。云何为一。外曰。如父子(修妒路)。譬如一人亦子亦父。如是总相亦是别相。别相亦是总相。内曰。不然。子故父(修妒路)。若未生子不名为父。子生然后为父。复次是喻同我。汝则非也。外曰。应有瓶。皆信故(修妒路)。世人眼见信有瓶用。是故应有瓶。内曰。有不异故一切无(修妒路)。若瓶与有不异者。瓶应是总相非别相。别相无故。总相亦无。因有别相故有总相。若无别相则无总相。是二无故。一切皆无。外曰。如足分等名身(修妒路)。如头足分等。虽不异身。非但足为身。如是瓶与有虽不异。而瓶非总相。内曰。若足与身不异。何故足不为头(修妒路)。若头足分等。与身不异者。足应是头。是二与身不异故。如因陀罗释迦不异故。因陀罗即释迦。外曰。诸分异故无过(修妒路)。分有分不异。非分分不异。是故头足不一。内曰。若尔无身(修妒路)。若足与头异。头与足分等异。如是。但有诸分。更无有分。名之为身。外曰。不然。多因一果现故。如色等是瓶(修妒路)。如色分等多因现一瓶果。此中非但色为瓶。亦不离色为瓶。是故色分等不为一。足分等与身亦如是。内曰。如色等瓶亦不一(修妒路)。若瓶与色声香味触五分不异者。不应言一瓶。若言一瓶。色分等亦应一。色等与瓶不异故。外曰。如军林(修妒路)。若象马车步。多众合故名为军。又松柏等。多树合故名为林。非独松为林。亦不离松为林。军亦尔。如是非一色名为瓶。亦不离色为瓶。内曰。众亦如瓶(修妒路)。若松柏等。与林不异者。不应言一林。若言一林者。松柏等亦应一。与林不异故。如松树根茎。枝节华叶。亦应如是破。如军等一切物。尽应如是破。外曰。受多瓶故(修妒路)。汝说色分等多(修妒路)。瓶亦应多。是故欲破一瓶而受多瓶。内曰。非色等多故瓶多(修妒路)。我说汝过非受多瓶。汝自言色分等多。无别瓶法为色等果。外曰。有果。以不破因。有因故果成(修妒路)。汝破瓶果。不破色等瓶因。若有因必有果。无无果因。复次色等瓶因。是微尘果。汝受色等故。因果俱成。内曰。如果无因亦无(修妒路)。如瓶与色等多分不异故。瓶不应一。今色等多分与瓶不异故。色等不应多。又如汝言。无无果因。今果破故。因亦自破。汝法因果一故。复次三世为一(修妒路)。泥团时现在。瓶时未来。土时过去。若因果一。泥团中应有瓶土。是故三世时为一。已作今作当作者。如是语坏。外曰。不然。因果相待成故。如长短(修妒路)。如因长见短。因短见长。如是泥团观瓶则是因。观土则是果。内曰。因他相违共过故。非长中长相。亦非短中及共中(修妒路)。若实有长相。若长中有。若短中有。若共中有。是不可得。何以故。长中无长相。以因他故。因短故为长短中亦无长性。相违故。若短中有长。不名为短。长短共中亦无长。二俱过故。若长中有。若短中有。先说有过。短相亦如是。若无长短。云何相待

百论卷上百论卷下

        提婆菩萨造　婆薮开士释

        姚秦三藏鸠摩罗什译

    破异品第四

外曰。汝先言。有一瓶异。是亦有过。有何等过。内曰。若有等异一一无(修妒路)。若有一瓶异各各无。瓶与有一异者。此瓶非有非一。有与一瓶异者。非瓶非一。一与有瓶异者。非瓶非有。如是各各失。复次若瓶失有一不应失。有失一瓶不应失。一失有瓶不应失。以异故。譬如此人灭。彼人不应灭。外曰。不然。有一合故。有一瓶成(修妒路)。有一瓶虽异瓶与有合故瓶名有。瓶与一合故瓶名一。汝言瓶失有一不应失者。是语非也。何以故。异合故。异有三种。一合异。二别异。三变异。合异者。如陀罗骠求那。别异者。如此人彼人。变异者。如牛粪团变为灰团。以异合故。瓶失一亦失。一失瓶亦失。有常故不失。内曰。若尔多瓶(修妒路)。瓶与有合故有瓶。瓶与一合故一瓶。又瓶亦瓶。是故多瓶。汝言陀罗骠求那合异故瓶失一亦失一失瓶亦失者。我欲破汝异。云何以异证异。应更说因。外曰。总相故。求那故。有一非瓶(修妒路)。有是总相故非瓶。一是求那故非瓶。瓶是陀罗骠。内曰。若尔无瓶(修妒路)。若有是总相故非瓶。一是求那故非瓶。瓶是陀罗骠故。非有非一。是则无瓶。外曰。受多瓶(修妒路)。汝先说多瓶。欲破一瓶。更受多瓶。内曰。一无故多亦无(修妒路)。汝言瓶与有合故有瓶。瓶与一合故一瓶。又瓶亦瓶。若尔世界言一瓶。而汝以为多瓶。是故一瓶为多瓶。一为多故。则无一瓶。一瓶无故多亦无。先一后多故。复次初数无故(修妒路)。数法初一。若一与瓶异。则瓶不为一。一无故多亦无。外曰。瓶与有合故(修妒路)。瓶与有合故瓶名有。非尽有。如是瓶与一合故瓶名一。非尽一。内曰。但有是语。此事先已破。若有非瓶则无瓶。今当更说瓶应非瓶(修妒路)。若瓶与有合故瓶有。是有非瓶。若瓶与非瓶合者。瓶何以不作非瓶。外曰。无无合故非非瓶(修妒路)。非瓶名无瓶。无则无合。是故瓶不作非瓶。今有有故应有合。有合故瓶有。内曰。今有合瓶故(修妒路)。若非瓶则无有。无有则无合。今有合瓶故有应为瓶。若汝谓瓶未与有合故无。无故无合。如先说。无法故无合。如是未与有合时瓶则无法。无法故不应与有合。外曰。不然。有了瓶等故如灯(修妒路)。有非但瓶等诸物因。亦能了瓶等诸物。譬如灯能照诸物。如是有能了瓶故。则知有瓶。内曰。若有法能了如灯。瓶应先有(修妒路)。今先有诸物然后以灯照了。有若如是者。有未合时。瓶等诸物应先有。若先有者。后有何用若有未合时。无瓶等诸物。有合故有者。有是作因。非了因。复次若以相可相成。何故一不作二(修妒路)。若汝以有为瓶相故。知有瓶者。若离相可相之物则不成。是故有亦变更有相。若更无相知有法为有者。瓶等亦应尔。灯喻先已破。复次如灯自照。不假外照。瓶亦自有。不待外有。外曰。如身相(修妒路)。如以足分知有分为身足更不求相。如是以有为瓶相故知有瓶有更不求相。内曰。若分中有分具者。何故头中无足(修妒路)。若有身法。于足分等中。为具有耶。为分有耶。若具有者。头中应有足。身法一故。若分有者。亦不然。何以故。有分如分(修妒路)。若足中有分与足分等。余分中亦尔者。则有分与分为一。是故无有有分名为身。如是足分等自有有分亦同破。有分无故。诸分亦无。外曰。不然。微尘在故(修妒路)。诸分不无。何以故。微尘无分。不在分中。微尘集故。能生瓶等果。是故应有有分。内曰。若集为瓶一切瓶(修妒路)。汝言微尘无分。但有是语。后当破。今当略说。微尘集为瓶时。若都集为瓶。一切微尘尽应为瓶。若不都集为瓶。一切非瓶。外曰。如缕渧集力。微尘亦尔(修妒路)。如一一缕。不能制象。一一水渧。不能满瓶。多集则能。如是。微尘集故。力能为瓶。内曰。不然。不定故(修妒路)。譬如一一石女。不能有子。一一盲人。不能见色。一一沙。不能出油。多集亦不能。如是微尘。一一不能。多亦不能。外曰。分分有力。故非不定(修妒路)。缕渧分分有力能制象。满瓶。石女盲沙。分分无力故。多亦无力。是故非不定。不应以石女盲沙为喻。内曰。分有分一异过故(修妒路)。分有分。若一若异。是过先已破。复次有分无故分亦无。若有分未有时。分不可得。云何有作力。若有分已有者。分力何用。外曰。汝是破法人(修妒路)。世人尽见瓶等诸物。汝种种因缘破。是故汝为破法人。内曰。不然。汝言有与瓶异。我说若有与瓶异。是则无瓶。复次无见有有见无等(修妒路)。汝与破法人同。乃复过甚。何以故。头足分等和合现是身。汝言非身离是已别有有分为身。复次轮轴等和合现为车。汝言离是已别有车。是故汝为妄语人

    破情品第五

外曰。定有我所有法现前有故(修妒路)。情尘意合故知生。此知是现前知。是知实有故。情尘意有。内曰。见色已。知生何用(修妒路)。若眼先见色。然后知生者。知复何用。若先知生。然后眼见色者。是亦不然。何以故。若不见色因缘无故生亦无(修妒路)。若眼先不见色。则因缘不合。不合故知不应生。汝言情尘意合故知生。若不合时知生者。是则不然。外曰。若一时生有何过。内曰。若一时生。是事不然。生无生共不一时生。有故无故。先已破故(修妒路)。若见知先有。相待一时生。若先无。若先半有半无。于三中。一时生者。是则不然。何以故。若先有见知者。不应更生。以有故。若先无者。亦不应生。以无故。若无者。则无相待。亦无生。若半有半无者。前二修妒路各已破故。复次一法云何亦有亦无。复次若一时生。知不待见。见不待知。复次眼为到色见耶。为不到色见耶若眼去。远迟见(修妒路)。若眼去到色乃见者。远色应迟见。近色应速见。何以故去法尔故。而今近瓶远月一时见。是故知眼不去。若不去则无和合。复次若眼力不到色。而见色者。何故见近不见远远近应一时见。复次眼设去者。为见已去耶。为不见去耶。若见已去。复何用(修妒路)。若眼先见色。事已辨去。复何用。若不见去。不如意所取(修妒路)。若眼先不见色而去者。如意所取则不能取。眼无知故。趣东则西。复次无眼处亦不取(修妒路)。若眼去到色而取色者。身则无眼。身无眼故。此则无取。若眼不去。而取色者。色则无眼。色无眼故。彼亦无取。复次若眼不去。而取色者。应见天上色。及障外色。然不见。是故此事非也。外曰。眼相见故(修妒路)。见是眼相。于缘中有力能取。性自尔故。内曰。若眼见相自见眼(修妒路)。若眼见相。如火热相。自热能令他热。如是眼若见相应自见眼。然不见。是故眼非见相。外曰。如指(修妒路)。眼虽见相。不自见眼。如指端不能自触。如是眼虽见相。不能自见。内曰。不然。触指业故(修妒路)。触是指业非指相。汝言见是眼相者。何不自见眼。是故指喻非也。外曰。光意去故见色(修妒路)。眼光及意去故。到彼能取色。内曰。若意去到色。此无觉(修妒路)。意若到色者。意则在彼。意若在彼。身则无意。犹如死人。然意实不去。远近一时取故。虽念过去未来。念不在过去未来。念时不去故。外曰意在身(修妒路)。意虽在身。而能远知。内曰。若尔不合(修妒路)。若意在身。而色在彼。色在彼故。则无和合。若无和合。不能取色。外曰。不然。意光色合故见(修妒路)。眼意在身和合。以意力故。令眼光与色合。如是见色。是故不失和合。内曰。若和合故见生无见者(修妒路)。汝谓和合故见色。若言但眼见色。但意取色者。是事不然。外曰。受和合故取色成(修妒路)。汝受和合。则有和合。若有和合。应有取色。内曰。意非见。眼非知。色非见知。云何见(修妒路)。意异眼故。意非见相。非见相故。不能见眼。四大造故。非知相。非知相故。不能知色。亦非见相。亦非知相。如是虽复和合。云何取色。耳鼻舌身亦如是破

    破尘品第六

外曰。应有情瓶等可取故(修妒路)。今现见瓶等诸物可取故。若诸情不能取诸尘。当用何等取。是故知有情能取瓶等诸物。内曰。非独色是瓶。是故瓶非现见(修妒路)。瓶中色现可见。香等不可见。不独色为瓶。香等合为瓶。瓶若现可见者。香等亦应现可见。而不可见。是故瓶非现见。外曰。取分故一切取信故(修妒路)。瓶一分可见故瓶名现见。何以故。人见瓶已信知我见是瓶。内曰。若取分不一切取(修妒路)。瓶一分色可见。香分等不可见今分不作有分。若分作有分者。香等诸分亦应可见。是故瓶非尽可见。是事如破一破异中说。外曰。有瓶可见。受色现可见故(修妒路)。汝受色现见故。瓶亦应现见。内曰。若此分现见。彼分不现见(修妒路)。汝谓色现见。是事不然。色有形故。彼分中分不现见。以此分障故。彼分亦如是复次如前若收分不一切取彼应答此。外曰。微尘无分故不尽破(修妒路)。微尘无分故。一切现见。有何过。内曰。微尘非现见(修妒路)。汝经言。微尘非现见。是故不能成现见法。若微尘亦现见。与色同破。外曰。瓶应现见。世人信故(修妒路)。世人尽信瓶是现见有用故。内曰。现见无非瓶无(修妒路)。汝谓若不现见瓶。是时无瓶者。是事不然。瓶虽不现见非无瓶。是故瓶非现见外曰。眼合故无过(修妒路)。瓶虽现见相眼未会时人自不见。是瓶非不现见相。内曰。如现见生无有亦非实(修妒路)。若瓶未与眼合时未有异相。后见时有少异相生者。当知此瓶现见相生今实无异相生。是故现见相不生。如现见相生无瓶有亦无。外曰。五身一分破。余分有(修妒路)。五身是瓶。汝破一色。不破香等。今香等不破故应有尘。内曰。若不一切触云何色等合(修妒路)。汝言。五身为瓶。是语不然。何以故。色等一分是触。余分非触。云何触不触合。是故非五身为瓶。外曰。瓶合故(修妒路)。色分等各各不合。而色分等与瓶合。内曰。异除云何瓶触合(修妒路)。若瓶与触异者。瓶则非触。非触云何与触合。若除色等。更无瓶法。若无瓶法。云何触与瓶合。外曰。色应现见信经故(修妒路)。汝经言。色名四大。及四大造。造色分中。色入所摄。是现见。汝云何言无现见色。内曰。四大非眼见。云何生现见(修妒路)。地坚相。水湿相。火热相。风动相。是四大非眼见者。此所造色应非现见。外曰。身根取故四大有(修妒路)。今身根取四大故四大有。是故火等诸物四大所造亦应有。内曰。火中一切热故(修妒路)。四大中但火是热相。余非热相。今火中四大都是热相。是故火不为四身。若余不热不名为火。是故火不为四身。地坚相。水湿相。风动相亦如是。外曰。色应可见。现在时有故(修妒路)。以眼情等现在时取尘故。是名现在时。若眼情等不能取色尘等则无现在时。今实有现在时。是故色可见。内曰。若法后故初亦故(修妒路)。若法后故相现。是相非故时生。初生时已随有。微故不知。故相转现。是时可知。如人着屐。初已微故随之。不觉不知。久则相现。若初无故后亦无。是应常新。若然者故相不应生。是以初微故随之后则相现。今诸法不住故。则无住时。若无住时。无取尘处。外曰。受新故故。有现在时(修妒路)。汝受新相故相。观生时名为新。观异时名为故。是二相非过去时可取。亦非未来时可取。以现在时故。新故相可取。内曰。不然。生故新。异故故(修妒路)。若法久生新相已过是新相。异新则名故。若故相生故则为新。是新是故但有言说。第一义中无新无中无故。外曰。若尔得何利。内曰。得永离(修妒路)。若新不作中。中不作故。如种子芽茎节坏华实等各不合。各不合故诸法不住。不住故远离。远离故不可得取

    破因中有果品第七

外曰。诸法非不住。有不失故。无不生故(修妒路)。有相诸法如泥团。从团底。从底腹。从腹咽。从咽口。前后为因果。种种果生时。种种因不失。若因中无果。果则不生。但因变为果。是故有诸法。内曰。若果生故有不失。因失故有失(修妒路)。汝言瓶果生时泥团不失。瓶即是泥团。若瓶果生。是时失泥团因故。是则无因。若泥团不失。不应分别泥团瓶有异。今实见形．时．力．知．名等有异故有应失。外曰。如指屈申(修妒路)。指虽屈申形异。实是一指。如是泥团形瓶形虽异。而泥不异。内曰。不然业能异故(修妒路)。屈申是指业。指是能。若业即是能者。屈时应失指。复次屈申应是一。如汝经泥团即是瓶故。指喻非也。外曰。如少壮老(修妒路)。如一人身亦少亦壮亦老。因果亦如是。内曰。不一故(修妒路)。少不作壮。壮不作老。是故汝喻非也。复次若有不失。无失(修妒路)。若有不失者。泥团不应变为瓶。是则无瓶。若有不失者。无无故亦不应失。然则都无失。外曰。无失有何咎(修妒路)。若常故无失。泥团不应变为瓶。无无常有何过。内曰。若无无常。无罪福等(修妒路)。若无无常。罪福等悉亦当无。何以故。罪人常为罪人。不应为福。福人常无福人。不应为罪。罪福等者。布施窃盗。持戒犯戒等。如是皆无。外曰。因中先有果。因有故(修妒路)。若泥中先无瓶。泥不应为瓶因。内曰。若因先有果故有果。果无故因无果(修妒路)。若泥团作瓶。泥不失故。因中有果。是瓶若破。应因中无果。外曰。因果一故(修妒路)。如土因泥果。泥因瓶果。因变为果。更无异法。是故不应因中无果。内曰。若因果一。无未来(修妒路)。如泥团现在。瓶为未来。若因果一。则无未来。无未来故。亦无现在。无现在故亦无过去。如是三世乱。外曰。名等失名等生故(修妒路)。更无新法。而故法不失。但名随时异。如一泥团为瓶。瓶破为盆盆破还为泥。如是都无去来。瓶盆安在。但随时得名。其实无异。内曰。若尔因无果(修妒路)。若名失名生者。此名先无后有故因中无果。若名先有泥即是瓶。是故知非先有果。外曰。不定故(修妒路)。泥团中不定出一器。是故泥中不定有名。内曰若泥不定果亦不定(修妒路)。若泥团中瓶不定。汝言因中先有果亦不定。外曰。微形有故(修妒路)。泥团中瓶形微故难知。陶师力故。是时明了。泥中瓶虽不可知。当知泥中必有微形。有二种不可知。或无故不知。或有以因缘故不知。因缘有八。何等八。远故不知。如远国土。近故不知。如眼睫。根坏故不知。如聋盲。心不住故不知。如人意乱。细故不知。如微尘。障故不知。如壁外事。胜故不知。如大水少盐。相似故不知。如一粒米投大聚中。如是泥团中瓶。眼虽不见。要不从蒲出。是故微瓶定在泥中。内曰。若先有微形因无果(修妒路)。若瓶未生时。泥中有微形。后粗时可知者。是则因中无果。何以故。本无粗相后乃生故。是以因中无果。外曰。因中应有果。各取因故(修妒路)。因中应先有果。何以故。作瓶取泥不取蒲。若因中无果者。亦可取蒲。而人定知泥能生瓶。埏埴成器。堪受烧故。是以因中有果。内曰。若当有有。若当无无(修妒路)。汝言。泥中当出瓶故。因中先有果。今瓶破故应当无果。是以因中无果。外曰。生住坏次第有故无过(修妒路)。瓶中虽有破相。要先生次住后破。何以故。未生无破故。内曰。若先生非后无果同(修妒路)。若泥中有瓶生便坏者。何故要先生后坏。不先坏后生。汝言。未生故无破。如是瓶未生时。无住无坏。此二先无后有故。因中无果。外曰。汝破有果故。有断过(修妒路)。若因中有果为非者。应因中无果。若因中无果。则堕断灭。内曰。续故不断。坏故不常(修妒路)。汝不知耶。从谷子牙等相续故不断。谷子等因坏故不常。如是诸佛说十二分因缘生法。离因中有果。无果故不着断常。行中道入涅槃

    破因中无果品第八

外曰。生有故一当成(修妒路)。汝言因缘故诸法生。是生若因中先有。若因中先无。此生有故。必当有一。内曰。生无生不生(修妒路)。若有生。因中先有。因中先无。如是思惟不可得。何况无生。汝若有瓶生。为瓶初瓶时有耶。为泥团后非瓶时有耶。若瓶初瓶时有瓶生者。是事不然何以故。瓶已有故。是初中后共相因待。若无中后则无初。若有瓶初。必有中后。是故瓶已先有。生复何用。若泥团后非瓶时瓶生者。是亦不然。何以故。未有故。若瓶无初中后。是则无瓶。若无瓶云何有瓶生。复次若有瓶生。若泥团后瓶时应有。若瓶初泥团时应有。泥团后瓶时无瓶生。何以故。已有故亦非瓶初泥团时有瓶生。何以故。未有故。外曰。生时生故无咎(修妒路)。我不言若已生。若未生有瓶生。第二法生时是生。内曰。生时亦如是(修妒路)。生时如先说。若生是则生已若未生。云何有生。生时名半生半未生。二俱过。亦如前破。是故无生。外曰。生成一义故(修妒路)。我不言瓶生已有生。亦不言未生有生。今瓶现成。是即瓶生。内曰。若尔生后(修妒路)。成名生已。若无生无初无中。若无初亦无中无成。是故不应以成为生。生在后故。外曰。初中后次第生故无咎(修妒路)。泥团次第生瓶底腹咽口等。初中后次第生。非泥团次有成瓶。是故非泥团时有瓶生。亦非瓶时有瓶生。亦非无瓶生。内曰。初中后非次第生(修妒路)。初名无前有后。中名有前有后。后名有前无后。如是初中后共相因待。若离云何有。是故初中后不应次第生。一时生亦不然(修妒路)。若一时生。不应言是初是中是后。亦不相因待。是故不然。外曰。如生住坏(修妒路)。如有为相。生住坏次第有。初中后亦如是。内曰。生住坏亦如是(修妒路)。若次第有。若一时有。是二不然。何以故。无住则无生。若无住有生者。亦应无生有住坏亦如是。若一时。不应分别是生是住是坏。复次一切处有一切(修妒路)。一切处名三有为相。若生住坏亦有为相者。今生中应有三相。是有为法故。一一中复有三相。然则无穷。住坏亦如是。若生住坏中更无三相。今生住坏不名有为相。若汝谓生生共生如父子。是事不然。如是生生若因中先有相待。若因中先无相待。若因中先少有。少无相待。是三种破情中已说。复次如父先有然后生子。是父更有父。是故此喻非也。外曰。定有生。可生法有故(修妒路)。若有生有可生若无生则无可生。今瓶等可生法现有故必有生。内曰。若有生无可生(修妒路)。若瓶有生瓶则已生不名可生。何以故。若无瓶亦无瓶生。是故若有生则无可生。何况无生。复次自他共亦如是(修妒路)。若生可生是二。若自生若他生。若共生。破吉中已说。外曰。定有。生可生共成故(修妒路)。非先有生后有可生。一时共成。内曰。生可生不能生(修妒路)。若可生能成生者。则生是可生。不名能生。若无生何有可生。是故二事皆无。复次有无相待不然(修妒路)。今可生未有故。无生则是有。有无何得相待。是故皆无。外曰。生可生相待故诸法成(修妒路)。非但生可生相待成。是二相待故。瓶等诸物成。内曰。若从二生。何以无三(修妒路)。汝言生可生相待故诸法成。若从二生果者。何不有第三法。如父母生子。今离生可生。更无有瓶等第三法。是故不然。外曰。应有生因坏故(修妒路)。若果不生因不应坏。今见瓶因坏故应有生。内曰。因坏故生亦灭(修妒路)。若果生者。是果为因坏时有耶。为坏后有耶。若因坏时有者。与坏不异故生亦灭。若坏后有者。因已坏故无因。无因故果不应生。复次因中果定故(修妒路)。若因中先有果先无果。二俱无生。何以故。若因中无果者。何以但泥中有瓶。缕中有布。若其俱无。泥应有布。缕应有瓶。若因中先有果者。是因中是果生。是事不然。何以故。是因即是果。汝法因果不异故。是故因中若先有果。若先无果。是皆不生。复次因果多故(修妒路)。若因中先有果者。则乳中有酪酥等。亦酥中有酪乳等。若乳中有酪酥等。则一因中多果。若酥中有酪乳等。则一果中多因。如是先后因果一时俱有过。若因中无果亦如是过。是故因中有果无果。是皆无生。外曰。因果不破故。生可生成(修妒路)。汝言因中多果。果中多因。为过不言无因果。是故生可生成。内曰。物物。非物非物互不生(修妒路)。物不生物。非物不生非物。物不生非物。非物不生物。若物生物。如母生子者。是则不然。何以故。母实不生子。子先有从母出故。若谓从母血分生。以为物生物者。是亦不然。何以故。离血分等母不可得故。若谓如变生。以为物生物者。是亦不然。何以故。壮即变为老。非壮生老故。若谓如镜中像。以为物生物者。是亦不然。何以故。镜中像无所从来故。复次如镜中像与面相似。余果亦应与因相似。而不然。是故物不生物。非物不生非物者。如兔角不生兔角。物不生非物者。如石女不生子。非物不生物者。如龟毛不生蒲。是故无有生法。复次若物生物者。是应二种法生。若因中有果。若因中无果。是则不然。何以故。若因中先无果者。因不应生果。因边异果不可得故。若因中先有果。云何生灭。不异故(修妒路)。若瓶与泥团不异者。瓶生时泥团不应灭。泥团亦不应为瓶因。若泥团与瓶不异者。瓶不应生瓶。亦不应为泥团果。是故若因中有果。若因中无果。物不生物

    破常品第九

外曰。应有诸法。无因。常法不破故(修妒路)。汝虽破有因法。不破无因常法。如虚空时方微尘涅槃是无因法不破故应有诸法。内曰。若强以为常。无常同(修妒路)。汝有因故说常耶。无因故说常耶。若常法有因。有因则无常。若无因说常者。亦可说无常。外曰。了因故无过(修妒路)。有二种因。一作因。二了因。若以作因。是则无常。我虚空等常法。以了因故说常。非无因故说常。亦非有因故说无常。是故非强为常。内曰。是因不然(修妒路)。汝虽说常法有因。是因不然。神先已破。余常法后当破。外曰。应有常法。作法无常故。不作法是常(修妒路)。眼见瓶等诸物无常。若异此法应是常。内曰。无亦共有(修妒路)。汝以作法相违故。名不作法。今见作法中有相故。应无不作法。复次汝以作法相违故。不作法为常者。今与作法不相违故。是应无常。所以者何。不作法作法同无触故。不作法应无常。如是遍常不遍常。悉已总破。今当别破。外曰。定有虚空法。常亦遍亦无分。一切处一切时。信有故(修妒路)。世人信一切处有虚空。是故遍信过去未来现在一切时有虚空。是故常。内曰。分中分合故分不异(修妒路)。若瓶中向中虚空。是中虚空为都有耶。为分有耶。若都有者。则不遍。若是为遍。瓶亦应遍。若分有者。虚空但是分无有。有分名为虚空。是故虚空非遍。亦非常。外曰。定有虚空。遍相亦常。有作故(修妒路)。若无虚空者。则无举无下。无去来等。所以者何。无容受处故。今实有所作。是以有虚空。亦遍亦常。内曰。不然。虚空处虚空(修妒路)。若有虚空法。应有住处。若无住处。是则无法。若虚空孔穴中住者。是则虚空住处空中。有容受处故。而不然。是以虚空不住孔穴中。亦不实中住。何以故。实无空故(修妒路)。是实不名空。若无空则无住处。以无容受处故。复次汝言作处是虚空者。实中无作处故。则无虚空。是故虚空亦非遍亦非常。复次无相故无虚空。诸法各各有相。以有相故知有诸法。如地坚相。水湿相。火热相。风动相。识知相。而虚空无相。是故无。外曰。虚空有相。汝不知故无。无色是虚空相。内曰。不然。无色名破色。非更有法。犹如断树。更无有法。是故无有虚空相。复次虚空无相。何以故。汝说无色。是虚空相者。若色未生。是时无虚空相。复次色是无常法。虚空是有常法。若色未有时。应先有虚空法。若未有色无所灭。虚空则无相。若无相则无法。是故非无色是虚空相。但有名而无实。诸遍常亦如是总破。外曰。有时法。常相有故(修妒路)。有法虽不可现见。以共相比知故信有。如是时。虽微细不可见。以节气花实等故知有时。此则见果知因。复次以一时不一时。久近等相故。可知有时。无不有时。是故常。内曰。过去未来中无。是故无未来(修妒路)。如泥团时现在。土时过去。瓶时未来。此则时相常故。过去时不作未来时。汝经言。时是一法。是故过去时终不作未来时。亦不作现在时。若过去作未来者。则有杂过。又过去中无未来时。是故无未来。现在亦如是破。外曰。受过去故有时(修妒路)。汝受过去时故。必有未来时。是故实有时法。内曰。非未来相过去(修妒路)。汝不闻我先说过去土不作未来瓶。若堕未来相中。是为未来相。云何名过去。是故无过去。外曰。应有时。自相别故(修妒路)。若现在有现在相。若过去有过去相。若未来有未来相。是故有时。内曰。若尔一切现在(修妒路)。若三时自相有者。今尽应现在。若未来是为无。若有不名未来应名已来。是故此义不然。外曰。过去未来行自相故无咎(修妒路)。过去时。未来时。不行现在相。过去时行过去相。未来时行未来相。是各各行自相故无过。内曰。过去非过去(修妒路)。若过去过去者。不名为过去。何以故。离自相故。如火舍热。不名为火。离自相故。若过去不过去者。今不应说过去时行过去相。未来亦如是破。是故时法无实。但有言说。外曰。实有方。常相有故(修妒路)。日合处是方相。如我经说。若过去。若未来。若现在。日初合处。是名东方。如是余方随日为名。内曰。不然。东方无初故(修妒路)。日行四天下。绕须弥山。郁单越日中。弗于逮日出。弗于逮人以为东方。弗于逮日中。阎浮提日出。阎浮提人以为东方。阎浮提日中。拘耶尼日出。拘耶尼人以为东方。拘耶尼日中。郁单越日出。郁单越人以为东方。如是悉是东方南方。西方北方。复次日不合处。是中无方。以无相故。复次不定故。此以为东方。彼以为西方。是故无实方。外曰。不然。是方相一天下说故(修妒路)。是方相因一天下说。非为都说。是故东方非无初过。内曰。若尔有边(修妒路)。若日先合处。是名东方者。则诸方有边。有边故有分。有分故无常。是故言说有方。实为无方。外曰。虽无遍常有不遍常微尘。是果相有故(修妒路)。世人或见果知有因。或见因知有果。如见芽等知有种子。世界法。见诸生物。先细后粗故。可知二微尘为初果。以一微尘为因。是故有微尘。圆而常。以无因故。内曰。二微尘非一切身合。果不圆故(修妒路)。诸微尘果生时。非一切身合。何以故。二微尘等果。眼见不圆故。若微尘身一切合者。二微尘等果亦应圆。复次若身一切合。二亦同坏。若微尘重合则果高。若多合则果大。以一分合故微尘有分。有分故无常。复次微尘无常。以虚空别故(修妒路)。若有微尘。应当与虚空别。是故微尘有分。有分故无常。复次以色味等别故(修妒路)。若微尘是有。应有色味等分。是故微尘有分。有分故无常。复次有形法有相故。若微尘有形。应有长短方圆等。是故微尘有分。有分故无常。无常故无微尘。外曰。有涅槃法。常。无烦恼。涅槃不异故(修妒路)。爱等诸烦恼永尽。是名涅槃。有烦恼者。则有生死。无烦恼故。永不复生死。是故涅槃为常。内曰。不然。涅槃作法故(修妒路)。因修道故。无诸烦恼。若无烦恼。是即涅槃者。涅槃则是作法。作法故无常。复次若无烦恼。是名无所有。若涅槃与无烦恼不异者。则无涅槃。外曰。作因故(修妒路)。涅槃为无烦恼作因。内曰。不然。能破非破(修妒路)。若涅槃能为解脱者。则非解脱。复次未尽烦恼时。应无涅槃。所以者何。无果故无因。外曰。无烦恼果(修妒路)。此涅槃非是无烦恼。亦非无烦恼因是无烦恼果。是故非无涅槃。内曰。缚可缚方便异此无用(修妒路)。缚名烦恼及业。可缚名众生。方便名八圣道。以道解缚故。众生得解脱。若有涅槃。异此三法。则无所用。复次无烦恼。是名无所有。无所有不应为因。外曰。有涅槃。是若无(修妒路)。若缚可缚方便三事无处。是名涅槃。内曰。畏处云何可染(修妒路)。以无常过患故。智者于有为法。弃捐离欲。若涅槃无有诸情及所欲事者。则涅槃于有为法甚大畏处。汝何故心染。涅槃名离一切着。灭一切忆想。非有非无。非物非非物。譬如灯灭不可论说。外曰。谁得涅槃(修妒路)。是涅槃何人得。内曰。无得涅槃(修妒路)。我先说如灯灭。不可言东去南西北方四维上下去。涅槃亦如是。一切语灭。无可论说。是无所有。谁当得者。设有涅槃。亦无。得者。若神得涅槃。神是常是遍故。不应得涅槃。五阴亦不得涅槃。何以故。五阴无常故。五阴生灭故。如是涅槃当属谁。若言得涅槃。是世界中说

    破空品第十

外曰。应有诸法破有故。若无破余法有故(修妒路)。汝破一切法相是破若有。不应言一切法空。以破有故。是破有故。不名破一切法。若无破一切法有。内曰。破如可破(修妒路)。汝着破故。以有无法欲破是破。汝不知耶。破成故。一切法空无所有是破若有。已堕可破中空无所有。是破若无。汝何所破。如说无第二头。不以破故便有。如人言无。不以言无故有。破可破亦如是。外曰。应有诸法。执此彼故(修妒路)。汝执异法故说一法过。执一法故说异法过。是二执成故有一切法。内曰。一非所执。异亦尔(修妒路)。一异不可得。先已破。先已破故无所执。复次若有人言。汝无所执。我执一异法。若有此问。应如是破。外曰。破他法故。汝是破法人(修妒路)。汝好破他法。强为生过。自无所执。是故汝是破人。内曰。汝是破人(修妒路)。说空人无所执无所执故。非破人汝执自法破他执故汝是破人。外曰。破他法故自法成(修妒路)。汝破他法时自法即成。何以故。他法若负。自法胜故。是以我非破人。内曰。不然。成破非一故(修妒路)。成名称叹功德。破名出其过罪。叹德出罪不名为一。复次成名有畏(修妒路)。畏名无力。若人自于法畏故。不能成于他法。不畏故好破。是故成破不一。若破他法是即自成法者。汝何故先言。说空人。但破他法。自无所执。外曰。说他执过自执成(修妒路)。汝何以不自执成法。但破他法。破他法故。即是自成法。内曰。破他法自法成故。一切不成(修妒路)。破他法故自法成。自法成故一切不成。一切不成故。我无所成。外曰。不然。世间相违故(修妒路)。若诸法空无相者。世间人尽不信受。内曰。是法世间信(修妒路)。是因缘法世间信受。所以者何。因缘生法是即无相。汝谓乳中有酪酥等。童女已妊。诸子食中已有粪。又除梁椽等别更有屋。除缕别有布。或言因中有果。或言因中无果。或言离因缘诸法生。其实空不应言说世事。是人所执谁当信受。我法不尔。与世人同故。一切信受。外曰。汝无所执是法成(修妒路)。汝言无执是即执。又言我法与世人同。是则自执。内曰。无执不名执如无(修妒路)。我先说因缘生诸法是即无相。是故我无所执。无所执不名为执。譬如言无。是实无。不以言无故便有无。无执亦如是。外曰。汝说无相法故。是灭法人(修妒路)。若诸法空无相。此执亦无。是则无一切法。无一切法故。是名灭法人。内曰。破灭法人。是名灭法人(修妒路)。我自无法。则无所破。汝谓我灭法。而欲破者。是则灭法人。外曰。应有法。相待有故(修妒路)。若有长必有短。若有高必有下。有空必有实。内曰。何有相待。一破故(修妒路)。若无一。则无相待。若少有不空。应有相待。若无不空则无空。云何相待。外曰。汝无成是成(修妒路)。如言室空无马则有无马。如是汝虽言诸法空无相。而能生种种心故。应有无。是则无成是成。内曰。不然。有无一切无故(修妒路)。我实相中。种种法门。说有无皆空。何以故。若无有亦无无。是故有无一切无。外曰。破不然。自空故(修妒路)。诸法自性空。无有作者。以无作故。不应有破。如愚痴人。欲破虚空。徒自疲劳。内曰。虽自性空。取相故缚(修妒路)。一切法虽自性空。但为邪想分别故缚。为破是颠倒故。言破。实无所破。譬如愚人见热时焰。妄生水想。逐之疲劳。智者告。言此非水也。为断彼想。不为破水。如是诸法性空。众生取相故着。为破是颠倒故。言破实无所破。外曰。无说法。大经无故(修妒路)。汝破有破无。破有无。今堕非有非无。是非有非无不可说。何以故。有无相不可得故。是名无说法。是无说法。卫世师经。僧佉经。尼干法等大经中。皆无故不可信。内曰。有第四(修妒路)。汝大经中。亦有无说法。如卫世师经。声不名大。不名小。僧佉经。泥团非瓶非非瓶。尼干法。光非明非闇。如是诸经。有第四无说法。汝何言无。外曰。若空不应有说(修妒路)。若都空以无说法为是今者何以说善恶法教化耶。内曰。随俗语故无过(修妒路)。诸佛说法。常依俗谛。第一义谛。是二皆实。非妄语也。如佛虽知诸法无相。然告阿难。入舍卫城乞食。若除土木等。城不可得。而随俗语故。不堕妄语。我亦随佛学故无过。外曰。俗谛无不实故(修妒路)。俗谛若实。则入第一义谛。若不实。何以言谛。内曰。不然。相待故。如大小(修妒路)。俗谛于世人为实。于圣人为不实。譬如一柰。于枣为大。于瓜为小。此二皆实。若于枣言小。于瓜言大者。是则妄语。如是随俗语故无过。外曰。知是过得何等利(修妒路)。如初舍罪福乃至破空。如是诸法皆见有过得何等利。内曰。如是舍我。名得解脱(修妒路)。如是三种破诸法。初舍罪福中破神。后破一切法。是名无我无我所。又于诸法。不受不着。闻有不喜。闻无不忧。是名解脱。外曰。何以言名得解脱。不实得解脱耶。内曰。毕竟清净故。破神故。无人破涅槃故。无解脱。云何言人得解脱。于俗谛故。说名解脱

百论卷下


百字论

    No. 1572

百字论一卷

        提婆菩萨造

        后魏北印度三藏菩提流支译

  我今归依聪睿师　　厥名提婆有大智
  能以百字演实法　　除诸邪见向实相

说曰。何故造论。为破我见等。一切诸法。各有自相

僧佉曰。一切法一相。是我要誓说。以何因缘。立一切法一相。以尽同共有一故。喻如瓶衣等。物体各有一。以是义故。常知一切法名为一相。是故一义成。内曰。非一。何以故。汝要誓言。立一相义。为一为二。若是一者。唯有要誓。不应有一。以是因缘。汝所立一。此义即破。毗舍师曰。汝言一破。我今立异。舍一过故。内曰。汝若立异。我还立一。何以故。汝若离因立异。我亦离因立一。毗舍师曰。我要立异。所以者何。诸法差别。各异相故。喻如象驼鹿马。如是等类。其相各异。以是故。诸法相异。一切法皆异。是故异义成。内曰。汝以此彼相不同故。言异义成者。以相别故。法各是一。汝所立异。要言则坏。要言坏故。则知异相不立。外曰。以一异相不成故。我今立有相。以法各有相故。当知有相义成。有相成故。当知一异亦成。内曰。汝今立有。必应有因。若无因。而立有我。亦无因而立无。外曰。我要言立一切法有。何以故。现见诸法。各有相故。喻如虚空中花。无有体相故。不可得瓶衣等物现有用故。当知一切法。皆是有相。以是因缘故。有义得成。内曰。汝立有者。因有相故。有因无相故。有此二俱有过。若以现相故。成有义者。现相是有。有亦是有。二有理不相成。若言因无。要誓则坏。有无俱非因故。有义则破。外曰。若破我有。汝则立无。无义得成。有还得立。喻如世人饮食。先因粗涩。故有美好。以是故。汝破我有。当知是无。内曰。汝立无者。因何而成。汝若无因。而成无我。亦无因而成有。外曰。云何而知。以无体相故。喻如热时炎。自无体相。何况而有。少水可得。以是因缘故。一切法无一尘相可得。是故我立无义成。内曰。汝所立无。为有因。为无因。若言无因。空有要誓。若言有因。要誓则坏。汝若无无亦不成。外曰。一切法有因。汝破有无者。此义则不然。何以故。如有埿缕蒲苇等故。知一切法皆有因。内曰。无因汝。言有因故有。有因则是无。若埿中先有瓶泥蒲缕等。皆非是因。何以故。因中先有故。若因中先无。亦非是因喻。如沙中无油。沙非油因。若言亦有亦无。义亦不成。何以故。有二过故。复次有亦不生。无亦不生。若从无因生。因复何用。为若从有因生。要誓言则坏。汝先言一切法。皆有因生者。此事则不然。外曰。现有瓶衣等用故。则知一切法皆从因生。不相形故成。内曰。汝言有果故有因。此义不成。何以故。相形有故。若以见果有用故。言有因者。果亦是因。果若是因。则无果。无果故则无因。是故因果俱坏。若言从意自在时方。如是等因生。则是相形因。便是有为法。有为则无常。自在时方。相形而有。则不因成。外曰。我所言真实。先旧诸仙。作如是说。此法决定。终无有异。内曰。汝言法尔。此非正说。如我所说。与汝法异。汝法中所有。我法中则无。我法中所有。汝法中则无。何以故。汝言我法尔故。汝法若尔。则但自是。自是而说。则无理趣。若无理趣。则无所知。若有所知。更说胜因。若无胜因。而言法尔。则无道理。外曰。此是我家法。内曰。汝言我家法。其法则不成。汝法不自成。云何能成法。若当离因者。终无有所成。自是其法者。此则非正理。外曰。无法非因生。如兔角。龟毛。石女儿。虚空花等。如是无法。终不可得。以因缘生。如见压油求麻。作瓶求埿。非以一法为因。能生多法。而物各有因。如埿能成瓶。不为叠因。缕能成叠。不为瓶因。以此类求余法亦尔。内曰。汝言因能生者。因不能生。此因为有所成。为有所坏。若因有所成。成汝亦成我。若因有所坏。坏我亦坏汝。以何为喻。如火能烧物。烧汝亦烧我。若于彼处热。在此亦复然。复次更明此义。若言有因而成。成汝亦成我。因虽有所生。因法不俱成。汝立声法是常。作要誓说。以何为因。无身是因。以何为喻。虚空为喻。虚空者。无身而常。以是故名声作常。复有异说。名声无常。以何故。声是作法故无常。以何为喻。如瓶因埿轮绳人功水等而成瓶。以作因生故。瓶无常如声从唇齿喉舌众缘生故。声亦无常。非此二因能有所成。汝言真实。其义有成。妄说虚因。理则不立。汝说要誓。有要时无誓。有誓时无要。二字不俱要誓则坏。如因法未生非为因。以灭亦非因。如子未生不名为生。以灭亦非生。以是故无因。外曰。汝虽破因果。我说有我法故。因果则还成。内曰。汝言有我法。以何为体。若以知识为我。知识则无常。知瓶智以灭知叠智始生。若知识非我。我则无知。我若无知。则无苦乐。如是之我。则无体相。若言我与知合故我有知。知与我合故。知亦非知。外曰。有我。所以者何。瓶衣等物。是我所故。当知有我。内曰。有一过故。瓶与有一。不异故有一。若瓶非瓶有一亦应是瓶。是则多瓶。若有一非瓶。是则无瓶。外曰。有一瓶。一故有过。我今立异。舍一过故。内曰。汝说异则无。瓶有无故无瓶喻。如异比丘异婆罗门。当知无比丘婆罗门。若瓶异有则是无。如刀与鞘。有异可见。瓶有一异。亦应可见。今有一异。不可见故。异义不成。外曰。一异虽坏。现见有瓶。喻如虚空中花。无故不可见。瓶现见故。当知有瓶。内曰。不见。何故不见。汝言现见。为眼见。为识见。若眼见者。死人有眼。亦应见。若识见者。盲人有识。亦应见。若根识一一别不见。和合亦不见。喻如一盲不能见。众盲亦不见。外曰。有瓶有色故有瓶。内曰。汝言有色故有瓶。色与瓶为一为异。瓶色若一。见余色时。亦应见瓶。若色异瓶。瓶非可见。则无瓶。若以见为瓶。瓶在障处。眼不见时。瓶应非瓶若色与瓶一。瓶坏时余色亦应坏。外曰。我法不生不灭。见亦不坏。不见亦不坏。何以故。我法常有故。因中有果。微细不现。以先有故。后得成大。以是故知有因果。内曰。先有不须作。如埿有瓶不须陶师。如缕有叠不须织师。以瓶叠待功匠成故知因中无果。若因中已有果者。则无未来法。若无未来法。则无生灭。无生灭亦无善恶。无善恶亦无作业罪福果报。如是则一切法无。复次若因中先有微细果。而无粗者。是粗便先无而后有。是则生灭。违汝先说。又若微细先有。则非生法。非生法故。则坏三世。三世若无。当知一切法亦无。若因中先有果。乳中已有酪。若言先无而后有者。当知是作法。以是故一切法因中先有。更不须作。外曰。若因中先有果是过者今说因中先无。而后果生。离无生灭。是故无过。有生灭故。亦有亦无。内曰。无生有生非一时故。若瓶埿中已有。不须轮绳人功等成。若无如龟毛不可纺织令使有用。以是故。有亦不生。无亦不生。又受身为自生从他生。二俱有过。若自生更何用生。以是故自生无身。若不从自生云何而从他生。若言自他生。是亦俱有过。以是故一切法无生。外曰。若无身。不应有生住灭有为三相。若有有为。则有无为。有为无为成故。一切法亦成。内曰。无有为法。汝言三相。为次第生。为一时生。次第亦有过。一时亦有过。若次第生。生时无住灭。住时无生灭。灭时无生住。以是故不得次第生。又若生有住。生自无体。住何所住。生体自无。住云何有。无生无住。如石女儿。是则无法。若有生住为灭所灭。生住既无。灭何能灭。如坏兔角空有坏名。外曰。汝言生住灭次第不可得。有为相如二头三手不可得。三相亦不可得。若三相一时亦不可得。何以故。若生中有灭。生则非生。若灭中有生。灭则非灭。住中生灭。破亦如是。生灭相违。云何一时。以是故三相次第生不可得。一时生亦不可得。又汝言三相。为与有为作相。为与无为作相。若与有为作相。生是有为。应有三相。住灭亦尔。如是之相。则为无穷。相若无穷。汝不应说有为法但有三相。要誓则坏。若相相无为。云何有为相而能相无为。外曰。汝若不欲令作有为相应作无为相。何以故。无为遍一切处。无方所故。是故应与无为作相。内曰。无为有方所。我今问汝。虚空为有方所。为无方所。虚空若有方所。应在汝身边。亦在彼身边。若尔便是有分。有分则有边。若言虚空无方所。为汝身遍虚空。虚空遍汝身。若虚空遍汝身。汝身遍虚空。是则有边际。如瓶衣叠等。有边故无常。虚空尔者。亦是无常。又复常因能生常果。因若无常。果云何常。如因埿生瓶。埿无常故。瓶亦无常。有方所故。名为无常。又复汝所言常。有因故常。无因故常。二俱有过。若言从因生是常者。如瓶衣等物。从因生故。皆亦无常。汝若以离因生法是常。我亦以离因生法是无常。若必有离因生法而常者。为是称理言。为是偏党说。今应分明更说其因。外曰。因有二种。作因了因。从作因生是无常。如瓶衣等物。作因生故无常。从了因生法是常。如灯能照闇中众物。闇去物现。非作法故是常。以是故。从作因生者是无常。从了因生者是常。内曰。如瓶等物。现见故是有。无为非现见故是无。何以故。无为无体相故无法。舍有舍无。二俱舍故。能断我见。及我所见。便得涅槃。如经中说。如智境见一切法空。识无所取故心识灭。种子灭。外曰。若有为法无体相。云何而有实。内曰。如梦。世谛法皆如梦。梦非实有。又非是无。亦非无因。如世谛法。非有相。非无相。非无因。如似屋宅。若有体相。未作时应见。若言无。不应得见。假梁椽基壁故。而有成用。非是无因。以是故。一切法非是有。非是无。亦非无因。是故如梦。外曰。若一切法如梦。老少中年取瓶时何故不取叠等。取叠时何不亦取瓶等。今见取瓶不取余物。以名有定故。当知一切法不如梦。内曰。名非是体。若名是体。如有瓶名。即应便有盛乳酪等用。如世智人言但瓶。空名已有用者。不应复须陶师造作。山价市瓶。如身有三名。若男若女。非男非女。以身取名。则统于三。若以名求名。则三不相摄。是故名体有异。复次如瓶有声可闻。有色可见。瓶嗅触亦得如是。则有多瓶。又瓶有口咽底腹。是名非一。复应多瓶。以此观察。名字虚假。当知无实。如佛所说偈

  世间有假名　　相如热时炎
  音声犹如响　　世间相如梦

外曰。汝虽种种破法是有。若言有法。则坏汝说。若言是无。无何所破。内曰。汝法有体相。我则有所破。若本无体者。则我无所破。说曰

  大人平等相　　心无有染着
  亦无有不染　　都无有止住
  诸有体相者　　有欲及断欲
  成就不坏信　　而舍诸邪见
  蠲除邪见网　　众秽悉灭尽
  能弃三毒刺　　勤行修正道
  善察如是法　　深生信敬心
  信心求实法　　不趣向三有
  不取于无有　　得证寂灭道
  一切法无一　　如是法无异
  云何是有相　　因法则无体
  非相形而有　　自是法不然
  汝法则不成　　如此不用因
  汝当说体相　　一则是有过
  若尔则无体　　五情不取尘
  色法有名字　　所见亦无体
  以有不须作　　彼法无有生
  有为法无体　　如此亦有方
  等如梦无异　　相亦无有异
  此是百字论　　提婆之所说

百字论一卷


般若灯论释

    No. 1566 [cf. Nos. 1564, 1565, 1567]

    般若灯论释序

        释慧赜述

般若灯论者。一名中论。本有五百偈。龙树菩萨之所作也。借灯为名者。无分别智。有寂照之功也。举中标目者。鉴亡缘观。等离二边也。然则灯本无心。智也亡照。法性平等。中义在斯。故寄论以明之也。若夫寻诠滞旨。执俗迷真。颠沛断常之间。造次有无之内。守名丧实。攀叶亡根者。岂欲尔哉。盖有由矣。请试陈之。若乃构分别之因。招虚妄之果。惑业熏其内识。恶友结其外缘。致令慢耸崇山。见深沧海。恚火难触。词锋罕当。闻说有而快心。听谈空而起谤。六种偏执。各谓非偏五百论师。争兴异论。或将邪乱正。或以伪齐真。识似悟而翻迷。教虽通而更壅。可谓捐珠玩石。弃宝负薪。观画怖龙。寻迹怯象。爱好如此。良可悲夫。龙树菩萨救世挺生。呵嗜欲而发心。阅深经而自鄙。蒙独尊之悬记。燃法炬于阎浮。且其地越初依。功超伏位。既穷一实。且究二能。佩两印而定百家。混三空而齐万物。点尘劫数。历试诸难。悼彼群迷。故作斯论。文玄旨妙。破巧申工。被之钝根。多生怯退。有分别明菩萨者。大乘法将。体道居衷。遐览真言。为其释论。开秘密藏。赐如意珠。略广相成。师资互显。至若自乘异执。郁起千端。外道殊计。纷然万绪。驴乘竞驰于驾驷。萤火争耀于龙烛。莫不标其品类。显厥师宗。玉石既分。玄黄已判。西域染翰。乃有数家。考实析微。此为精诣。若含通本末。有六千偈。梵文如此。翻则减之。我

皇帝神道迈于羲农。陶铸侔于造化。一六合而贯三才。摄四生而弘十善。崇本息末。无为太平。守母存子。不言而治。偏复留心释典。遐想至真。以为圣教东流。年淹数百。而亿象所负。阙者犹多。希闻未闻劳于寤寐。中天竺国三藏法师波罗颇蜜多罗。唐言明友。学兼半满。博综群诠。丧我怡神。搜玄养性。游方在念。利物为怀。故能附杙传身。举烟召伴。冒冰霜而越葱岭。犯风热而渡沙河。时积五年。涂经四万以大唐贞观元年岁次娵觜十一月二十日。顶戴梵文。至止京辇。昔秦征童寿。苦用戎兵。汉请摩腾。远劳蕃使。讵可方兹感应。道契冥符。家国休祥。德人爰降。有司奏见。殊悦帝心。其年有敕安置大兴善寺。仍请译出宝星经一部。四年六月。移住胜光。乃召义学沙门慧乘。慧朗。法常。昙藏。智首。慧明。道岳。僧辩。僧珍。智解。文顺。法琳。灵佳。慧赜。慧净等传译。沙门玄谟。僧伽。及三藏同学崛多律师等。同作证明。对翻此论。尚书左仆射邠国公房玄龄。太子詹事杜正伦。礼部尚书赵郡王李孝恭等。并是翊圣贤臣。佐时匡济。尽忠贞而事主。外形骸以求法。自圣君肇虑。竟此弘宣。利深益厚。寔资开发。监译

敕使右光禄大夫太府卿兰陵箫璟。信根笃始。慧力要终。寂虑寻真。虚心慕道。赞扬影响。劝助无辍。其诸德僧。夙兴匪懈。研核幽旨。去华存实。目击则欣其会理。函丈则究其是非。文虽定而覆详。义乃明而重审。岁次寿星十月十七日。捡勘毕了。其为论也。观明中道而存中失观。空显第一。而得一乖空。然则司南之车。本示迷者。照胆之镜。为鉴邪人。无邪则镜无所施。不迷则车不为用。斯论破申。其由此矣。虽复斥内遮外。尽妄穷真。而存乎妙存。破如可破。荡荡焉。恢恢焉。迎之靡测其源。顺之罔知其末。信是莹心神之砥砺。越溟崄之舟舆。骇昏识之雷霆。照幽涂之日月者矣。此土先有中论四卷。本偈大同。宾头卢伽为其注解。晦其部执。学者昧焉。此论既兴。可为明镜。庶悟玄君子。详而味之也

    般若灯论释观缘品第一之一(卷一)

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

  普断诸分别　　灭一切戏论
  能拔除有根　　巧说真实法
  于非言语境　　善安立文字
  破恶慧妄心　　是故稽首礼

释曰。如是等偈。其义云何。我师圣者。如自所证。于深般若波罗蜜中。审验真理。开显实义。为断诸恶邪慧网故。彼恶见者。虽修梵行。以迷惑故。皆成不善。今欲令彼悟解正道。依净阿含。作此中论。宣通佛语。论所为者。其相云何。谓婆伽婆见彼无明众生。世间起灭断常一异来去等诸戏论网稠林所坏。起第一悲。发勇猛慧。于无量亿百千俱胝那由他劫。为利益他。捐舍身命。无厌倦心。能担无量福慧聚担。钻般若境界海。断一切戏论网。非他缘无分别。得一切法真实甘露。于彼趣寿分齐。性处时等。摄受利益。不共一切声闻缘觉。及诸外道唯为进趣第一乘者。依彼世谛。第一义谛。施设不起等诸名字句。此缘起实说中最胜。我阿阇梨亦于不起等文句。开示如来如实道理。得如实解。生极勇猛。如所通达。赞叹婆伽婆。故造此论。又悲水适心。验已所解。令彼世间同已得解故出此言。如偈曰

  不灭亦不起　　不断亦不常
  非一非种种　　不来亦不去
  缘起戏论息　　说者善灭故
  礼彼婆伽婆　　诸说中最上

释曰。彼句义次第。解无间故解此论义。是故初说。如是句义。破坏故灭。出生故起。相续死故断。一切时住故常。无别不异义故一。差别异义故种种。向此义故来。向彼义故去。无此灭故不灭。乃至无此去故不去。彼起灭一异。第一义遮。彼断常者。世俗中遮。彼来去者。或言俱遮。或有说言。如是一切第一义遮。以彼为故。彼者佛婆伽婆。缘起者。种种因缘和合得起。故名缘起。语自性执。永不行故。名戏论息。一切灾障无故。或时自性空。故名善灭。说者开演义故。正不颠倒。通达人法二种无我。是故名为佛婆伽婆。由如此义故我作礼。诸说中最上者。此言何谓。彼不颠倒缘起。开示天人涅槃信乐道故。教授声闻独觉菩萨最胜故。如所演说。正不颠倒。缘起胜故。问曰。汝向自言。说缘起法。若言缘起。云何不起。若言不起。云何缘起此语自相违。又生解退故。语义俱坏。如云一切言语皆是妄者。答曰。若一切缘起。皆不起者。彼当作解。我得此过。我未曾说一切缘起。皆不起故。无如上过。此义云何。彼世谛中。有缘起故。非第一义亦有缘起。彼说因者。此义不成。犹如檀等。第一义中。不说为善。摄生死故。说之为善。又如说识为我。第一义中。识实非我。如此解知。是故无过。又如化丈夫起。丈夫自性。实无所起。亦如幻焰内入起等。世俗故说。非第一义。是故无咎。问曰。起后遮灭。法相应尔。以彼先故。如不断者。答曰。生死无始故。先灭后起。此亦同遮。非一向因过。观义次第不观异。文若先遮。起与灭同过。复次昙无德人言。汝论初言。不起灭等。此无为法。别缘起者。是义不然。何以故。我法中有故。汝论初言。非声闻等共缘起者。义不相应。论者言。遮自性故。说不起等。别缘起法。令汝得解。若言有彼无为缘起。令他信者。是义不然。验无体故。若汝意谓。缘起决定。名缘起无为者。此解有过。何以故。由遮起故。彼起无体。不应名共。以无为无起有因故。譬如住

复次经部师言不起等义。非声闻不共。此义云何。彼异起无体。名为不起。如不自在。彼外道解灭。此灭无体。名为不灭。譬如无我。藉因果起故不断。果起因坏故不常。彼摩尼珠。干牛粪末。日光和合。如是起火。不可说彼体故不一。不可说异体故不种种。如是起时坏故。不来不去义正如此。汝论初言。不共声闻。别缘起者。是义不然。论者言。汝虽有此语。违正道理。此义云何。彼起者不起故。我欲令人解不起等。别缘起义。以是不共别缘起故。在初赞叹佛婆伽婆。方作此论。先令了知起者不起。余不灭等。则易可思。云何令解彼不起等。谓诸分别起者。现前知故。诸如是说。或言自起体。或言他起体。或言共起体。或言无因起体。此诸说皆不然。由依阿含及正道理。如实谛观。起即无义。故造论者。自在决定。说此偈曰

  无时亦无处　　随有一物体
  从自他及共　　无因而起者

释曰。非自者。彼聚安立诸起法者。竟无体故。如一一次第。应知自者我义故。彼一切体。何义故遮。所谓遮者最胜义故。又无余分别网遮故。无余分别网者。谓无余所识境界故。无境界者。欲成立无分别智故。复次遮者遮有余受故。彼异方便说诸法不起。方便不起。令他解故。此非大乘悉檀。云何知耶。如阿含说。色不起行。不行般若波罗蜜故。复次不自起者。谓不自起如是体故。此正领解。若异此领解。而言不从自体起者。此义有过。有何等过。谓他起过故。复次汝言不从自体起者。非唯有他起过。及有自他共起过故。此非我欲。以违悉檀多故。此方便语。第一义中。诸内入等。无自起义。世所不行以有故。譬如思异部回转。不令解故。有故因者。同非因那。以譬喻无体。如是彼因回转非一切处。无譬过故

复次僧佉人言。汝所立者。立何等义。为果名自耶。为因名自耶。此有何过。若立果体为自者。我悉檀成。若立因体为自者。与义相违。以因中体有故。如是一切有起。应名为起。汝言不起者。义岂然耶。论者言。此语无义。汝不知耶。起分遮故。谓因自性起。及他性起。此等悉遮。汝不正思惟。出此言者惑故。无过有异。释曰。诸法无有从自体起。彼起无义故。又生无穷故。彼不相应。此义云何。以不说因及譬喻故。又不能避他说过故。此破显示颠倒成就过。云何颠倒。谓从他起体过。及生有果过。又生有穷过故。违悉檀多故。复次有异僧佉。作如是言诸体不自起者。此不应尔。何以故。自欲作起还自除故。如说三界有兔角起。复欲屏除汝义如此我所成立因果能了无异体故。犹如自我从彼因体果法自起。是故义成。论者言。邪分别说。不应道理。先遮彼义。是故无过。如是诸法。体不自起。从他起者。义亦不然。何以故。无时无处。随有一体。从他起故。此义云何。他者异义。此方便语。第一义中。内入不从彼诸缘生。何以故。以他故。譬如瓶等。复次第一义中。他缘不能起眼等入。何以故。以他故。譬如经等。问曰。汝言他者。因义不成。何以故。立义一分故。譬如无常声。声故。答曰。汝不善说。无常声者。是韦陀声。声故者。如鼓声故。以见立义一分出因成故。非谓一边

复次鞞世师人言。微尘为因。生诸法果。彼二微尘为初。次第如是地水火风聚实起成。汝言他者。为分别我求那因义耶。为分别异义耶。若分别我求那为因者。则因义不成。何以故。若离我体无别求那故。若彼异义分别者。即为世间解所破故。论者言。彼说不善总说因故。以彼法聚集能生他觉。如是觉因。总说为他非彼我及求那。异思惟故。世间所解。亦不破坏。立义别故。第一义中。地微尘初起。不名地实。以微尘故。譬如火尘。如是第一义中。火微尘初起。不名火实。以微尘故。譬如水尘。如是等次第应说

复次阿毗昙人言。汝言他者。为以果功能空。说为他耶。为当彼能不空说为他耶。二俱有过。何以故。若以果功能空。说为他者。因义不成故。若彼能不空者。彼能成法空。譬喻坏故。论者言。总说聚法故。物边观故。生他觉故。汝言因义不成。及能成法空。譬喻坏者。无此过失。似光影耳复次有自部言。若第一义中。彼内外入皆不起者。法体不成。能依止坏。汝得因义不成过故。论者言。世俗言说实故。瓶眼入等内外可得故。汝说过者。此不相应。复次佛护论师释曰。他作。亦不然。何以故。遍一切处。一切起过故。论者言。彼若如此说过。即所成能成颠倒故。谓自俱因起体过故。或时有处随一物起故先语相违。又若异此。遍一切处。一切起过。此语能成他起过者。此不相应。如偈曰

  香附子苦蔘　　庵摩罗除热
  石女无有儿　　竹笋重有苦
  兔印记月光　　阳春时作乐

复次异僧佉人言。彼别不别。地等种子。生芽等果。由如此义。说俱起体。彼说不然。何以故。不共者。非自他义。无时无处有一物体。从共起故。彼说有过。此复云何。若谓俱起。令他信者。验无体故。此义不成。复次此中又遮裸形部义。说不共起。此义云何。彼谓金与非金。人功火等。自他力故。环钏等起。彼如是说。为遮彼故。说不共起。应如此知。复次不无因者。此义云何。无时无处。有一物体。无因起故。何故无因。验无体故。若说有验。即为世间。所验解破。有此过故。世间验者。其相云何。世俗欲令内入体生。何以故。总别有故。譬如芽等。复次世间所解过者。于彼世间。若有此物。知从因生。如丝成绢。如篾成筐。如泥成瓶等。为彼过故。复次彼恶因者。亦名无因。如无妇等。何等恶因。所谓自性及自在天。丈夫藏时。那罗延等不真实故。是故此等无因。不能起体。若谓从彼自性等起。令人解者。验不尔故。若说有验。此亦有过。复次执自性者。说如是言。我立此义。自性有彼。内入等生。何以故。庄严我体故。如水生花根须茎叶好色形相。如大青珠因陀罗尼罗阿毗尼罗宝等。又如孔雀项边种种缬目光明可爱。皆自性尔。论者言。彼立此义。自性作者。不观业因。无有作者。若尔彼内入生因缘决定世智所行等。共言说成。已复成过。若第一义。譬喻无体。何以故。第一义中。莲花宝等。本无生故。复次汝欲共。我立无因义。一切法成。我今示汝以无因故。一切不成。又彼立无因。若说因者。先执破故。复次若谓我立无因。不能令彼说因者解故。须出因今解无因。譬如共夷狄人。还行彼语。为此义故。方便说因。亦非先语破者。是义不然。何以故。语边转者。亦如所得相。以此相义。令彼得解。如语夷狄。彼处有烟。则知有火。令彼了知相觉起故。此彼语异。是故不成。复次有异僧佉。婆胄罗人言。彼歌罗罗。及以芽等。无缘故起。若瓶衣等。有缘故起。非一切体。自性起故。成我所成。论者言。彼一切时。一切物起。皆悉遮故。汝所说者。此不相应。由如是义。无自性起。复次外人有执自在为因者。说如是言。众生无智。于苦乐中。不得自在。善道恶道。皆是自在之所使故。论者言。彼立是义。自在令为世间起因。于世俗中。亦不应尔。何以故。或有忧喜因故。如牧牛者。若执自在名一切因作世间者。此义不然。当如是知。由所量故譬如自在。是故当知。于彼世俗。亦非自在。能起诸法。若汝定谓自在为因。生诸法者。是因与果。为自性。为他性。为俱性。此异分别。先已遮故。有起无起。后当广破。第一义中。自在不能起诸法故。或有说言。众生世间。及器世间。种种业因。为自在故。彼住起坏。苦乐增减。通为依止。作是说者。成我所成。世俗言说。非第一义。以第一义中业不起故

复次彼执丈夫为生因者。说如是言。一切世间丈夫为因故。是义云何。如糸齐织网。如月珠出水。如树生枝叶等。一切众生。以彼为因。亦复如是。所谓彼过去未来。动不动等。远近内外。如是一切。皆丈夫为因。论者言。前执自在为因。中已遮此计。今当复说。如调达我。不作调达身根聚因。何以故。由我故。譬如耶若达多自我。复次耶若达多身根等聚。非耶若达多我之所作。何以故。由彼乐苦智起因故。譬如提婆达多身根等聚。若谓彼系缚我为三界因非一切者。此义不然。何以故。由我故如解脱我。彼执不成。立义过故。问曰。汝言我故因者。此自立义中。是一分故。汝出因者。是义不成。有过失故。答曰。无过失义。先已说故。何故无过。如上云。无常声声故。譬如鼓声。若有说言。我所立义。唯是一我。如一虚空瓶等分别。皆是其假假故无量。为此义故。譬喻无体。验破不成。立义无过故。论者言。彼不善说。此义云何。以虚空无生故。如虚空花。体不可得。如是而言。一虚空者。此义不成。但有言说。世俗法中。总说我者。示假令识故。汝立一我。令他信者。验无体故。此义不成。问曰。缚我脱我。更无异体。何以故。由我故如解脱我。答曰。无余涅槃界中。一解脱我。此有不成。如先说过。不能避故。如观我品。当广解说

复次僧佉人言。如我立义。彼自性为因。谓梵摩为初。下至住持际。诸法果生。皆因自性。如彼内入。为苦乐痴因。决定作因。彼具有故。若世间物。彼具有者。我知为因。如栴檀札。如瓦器片。金庄严具。如是等总别因故。由彼内入具有乐苦痴等故。说内入为彼乐苦痴因。如是应知。色想行识诸阴。皆是乐苦痴等自性。何以故。由阴故。譬如受阴。是故因及譬喻义皆得成。论者言。为此故。第一义中。栴檀等譬不成。以无体故。于世俗中。痴者行阴摄故。譬喻不成。彼乐苦等二。异外诸法。非乐苦自性。应如是知。何以故。所量故。譬如觉验不相应。问曰。汝第一义中。无譬喻故。答曰。总说觉故。世间共解。取为譬喻。亦非譬喻无体。以是义故。彼藏不为大等谛因。由不了故。譬如丈夫。汝若欲说自性为因者。自验破故。外人言。我立丈夫。与思相应。则得明了而言由不了故者。此因不成。又能成法。不具故。亦譬喻过故。论者言。彼语无义。此复云何。总说因故。立别义故。处处不了。总一不成。或有说言。亦不无因。能起诸法。彼性时那罗延等为因故者。如遮自在中说。应知

复次僧佉人言。汝说不自。不他。不共。不无因。有处有体。能起一物者。诚如所言。彼实不起。虽实无起。以了作故。论者问言。是何等物。云何了作。僧佉人言。如灯瓶等。论者言。灯瓶二物。本自不生。云何以不生灯。欲了作。彼不生瓶等。如无马角。岂能了耶。以第一义中诸法不生故。依于世谛。作如是问。彼灯于瓶。何所作用。外人言。受作故。论者言。受本先无。于后始有。先无后有。受即是作。若言暗中眼识尔时无受。由有灯明暗障等破者。如前已遮。是作法故。又暗障破者。岂非作耶。若汝执言。受见先有。若先有者。灯复何用。复次云何名瓶。如我法中。四大及所造和合故名瓶。彼灯在时。与明俱起。以是义故。世谛法中。有所作因。一一物体。各从自因相续而起。所以者何。如明与物体俱起。是为了因。第一义中起法皆无。亦无有了。非大等诸谛。不了之物。能令其了。何以故。由不了故。譬如空花。是故汝言未了者了。此语非也。复次佛护论师释此句云。亦非无因起彼物体。何以故。若无因者。应于一切处一切物常起。有如是过。此义不然。何以故。汝此语义。能成所成。分明颠倒。是义云何。谓彼物体从因起故。或有时有体起。或有处一物起有初起故。与先语相违。如是不相应者。先已说过故。若彼有异不相应义者。亦如先说。复次此中亦不无因起者。一切诸论。无如是说。有时有处。若自宗。若他宗。无有一物。若染若净。从无因起者。一一应如是说。以是故不共外道等。别缘起不起等义得成。复次阿毗昙人言。有四种缘。能生诸法。云何而言缘起不起如我。偈曰

  因缘及缘缘　　次第增上缘
  四缘生诸法　　更无第五缘

释曰。因缘者。谓共有自分相应遍报等。五因缘缘者。谓一切法。次第缘者。除阿罗汉最后所起心心数法。增上缘者。谓所作因。无第五者。若自宗他宗。若天上人间。若修多罗。若阿毗昙。及余诸论。佛未曾说有第五缘。复次如大众部。亦作是言。先生无有等诸缘。皆于四缘中摄。以是义故。此四种缘。能生诸法。汝言物体不从他起者。是义不然。论者偈曰

  所有诸物体　　及以外众缘
  言说音声等　　是皆无自性

释曰。诸物体者。谓彼眼等。外众缘者。谓歌罗逻等。言说声者。谓和合时。无自性者遮彼自体。是义云何。彼诸体等。皆无自性。亦非异处。及自在等有也。是故说言。彼他无体。复次何等为自体而言众缘为他体彼有者。如先不起义中已说验破。以是故汝于此中。不能破我。复次或有自心虚妄分别者。作是说言。若有能起诸法体者。说为他起。非是自体。若无他缘。则不能生。有他缘故。诸法得起。缘决定故。我作是解者。是义不然。何以故。若作是语。遮自起者。助成我义。若诸体未起。他能令起。是语不善。同前遮故。复次若言体不从他起。遮彼体外有异起者。助成我喻。以是义故。赤白缘中。无有眼等。以众缘中眼法空故。所以者何。众缘无自体。以无他故。复次是中有二种语。第一义中。彼眼入等。不从赤白众缘而起。何以故。眼等无故。如瓶。第一义中。赤白众缘。无其功能。生眼入等。何以故。彼眼空故。譬如织刀。是故佛说。第一义中。因及众缘不能生眼。如是应知。佛为怜愍世间住于乱慧无因恶因诸诤论者。于世谛中。说有因缘。次第缘。缘缘增上缘。以是缘故。我义不破。应如是知。复有异分别者。言体从他起。论者言。彼共于此。复应思量。是四缘中。云何能生眼等诸体。复有异名差别。如大众部。及鞞世师等。所分别者。彼亦随相。于此中摄。是故决定无第五缘如是。第一义中眼等及他。皆不应尔。云何不然。如偈曰

  自我等诸体　　内入等众缘
  一一皆不有　　以无自性故

释曰。诸缘中。若总若别。彼眼等体。皆不可得。此等声者。别因中无。和合中亦无。异中亦无。若世谛。若第一义谛。未曾有时。有无自性。物体先起。亦未曾有无自性物。诸缘他体。未来欲起。诸他义者。云何得成。一向无他。以他因无体故

复次若汝自心妄置诸法有体未来当起待此体故。彼缘为他相待力故说缘为他者。但有是语。何以故。彼等众缘无他性故。是故不应于此生着。于世谛中假说有他。第一义中。彼他不起。先已说故。僧佉人言。如我意谓有微细我体。彼于后时作令明了。即以不了果缘而为他义。是故得成。汝何能破。论者言。汝语非也。世间愚人不作此解。瓶等细我。其义难成。汝言了者。先已破故

般若灯论释卷第一般若灯论释卷第二

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观缘品之二

复次余僧佉言。若诸果功能缘中空故。缘不生果。如是义者。成我所成。何以故。汝谓果体不起。是则名常。汝先立义。则为自破。论者言。汝语非也。一切时起。悉皆遮故。不生之物。亦不说常。何以故。不生之物。于世谛中。不欲有故。复有僧佉。说如是言。虽彼众缘。不能起果。由有眼色空明。及作意等。诸缘有作故识得生。是故欲令有生有作。彼作及生。我今当说。第一义中。有彼生识自果之作。何以故。以有缘故。譬如甑鬵(集心反)水米及薪火等。诸缘具已。作能成饭。以是验故。我立义成。论者偈曰

  缘中无作者

释曰。我不欲令第一义中作能熟饭。以无作故。譬喻不成。譬不成故。汝则有过。何以故。能成立法无故。由成立无故。缘中定无生识之作。若有若无。果皆不起如后当遮作者不起故。因义不成。第一义中。应如是说。复次若汝执言。总说作者。则与义相违。彼缘有者。世智境界。生识之作。与彼众缘。体不相离。佛护问中。复有外人。作是释言。若自起。若他起者。是言何谓。此义于我无所用为。虽然眼等诸缘。作眼识生。如甑鬵等。作饭熟故。而彼外人。作是成立。言有体起佛护论师为遮彼故。引偈本云。作者缘中无。何以故。已生未生生时。识有作者。是亦不然。论者言。彼不相应。汝等前后二语。唯有立义故。复有异僧佉言。汝将此过。安置与我。遮我缘中。无其作义。作不起故。譬喻不成者。是义不然。今有作在。云何验知。有作生彼识等自果。由其作故。如作能熟饭。论者偈曰

  离缘亦无作

释曰。缘无故亦不与缘合而独有作者无也。如先缘中有作次第说其过故。复有论师释此偈言。识自体生。即是作也。论者言。如前偈说缘中无有作离缘亦无作。若言有彼生识作者。是义不然。何以故。如识无故。彼作亦无。若言无其别作。但缘是作者。是亦不然。若言缘无自体作有自体者。佛护论师言。彼亦无缘。有作过故。论者言。若谓无缘得有作者。是义不然。何以故。若无彼缘自然有作。无此义故。佛护言。于世谛中。云何有作自他众缘相因待故。有作如无间。刹那能起果体。是名为作。如彼未来欲起法体由作。得生于世谛中。非无有作。不同汝执缘中有作。是语无咎。论者言。汝今不说因缘譬喻。但有立义与他过者。此释不成。复次经部师言。有异法起。如眼识等。何以故。由有作故。譬如种子。地水火风。因缘和合。得有芽出。以此答故。汝先验破。论者言。如先偈说。缘中无有作。此义云何。第一义中。遮彼起故。彼作无体。种子等缘和合有作者。此不应尔。汝言缘中定有作者。是义不成。譬喻无故。汝先答者。不能破我。复次有外人言。如稻谷等。真实是有。何以故。由作有故。于世谛中。欲令如是随顺世谛。如其所欲。第一义中。亦复如是。譬如兔角。由譬成故。所欲义立。论者言。汝等如是安立作义。如稻谷等。于世谛中。言有作者。是义不然。何以故。如偈曰

  若有若无作　　诸缘作不成

释曰。于世谛中。兔角无故。第一义中。有亦不成。作亦如是。以无体故。汝言由譬成故。所欲义立者。翻此二过。还在于汝。复次僧佉人言。兔角无体。即是其体。云何知耶。如毗伽罗论第六门中。作如是说。有别异故。譬如青优钵罗华。与色为异。论者言。汝说不善。何以故。华色等二体别异者。第一义中。此皆不成。无譬喻故。若汝意谓如我立色等有体故。不能令汝解。如是汝立色等无体。亦不能令我解。以彼此同过故。今当答汝。无同过义。何以故。起法有体。如是已遮。况不起者。欲令有体而当不遮。有体无体。是汝意欲显示异相。我今遮汝。作如此解。有体无体。堕在二边。我不同汝执有无故。不堕二边。此义云何。汝立有体无体。令他信受。验无体故。非我所欲。是故汝执无道理故。我立义成。汝言同过者。此复非也

复次或有诸说起者。应如是问。果先未起。彼诸缘等。为无作耶。为有作耶。若诸缘无作。不能起果者。云何名无作起果。功能缘中空故。说名无作。若功能空者。则非彼缘能起彼果。譬如麦种无稻谷芽。此不应尔。若有作者。验此作有。缘中无故。由果起故。说彼有作。果未起时。彼无所作。由此验故因义不成

复次经部师言。彼果起时。诸缘有作。以是缘故。互相随摄。资益果起。非因不成。答验亦立。论者言。汝经部师。欲令第一义中。谷等诸缘。和合聚集。果得起耶。若定尔者。是诸因缘。乃至未能起果。自此已前。此稻谷等。云何不名为非缘耶。无有此事。如是缘故。譬如乃至未从他受学。云何不名无智人耶。此义不成。问曰。若如是者。果先未起。则诸缘非缘。我欲如此。是故无过。答曰。汝甚有过。何以故。汝意唯解。果先未起。诸缘非缘。而不知彼。果正起时。缘亦非缘。为此义故。云何芽起时。彼稻谷等。非缘自性。以第一义中。若一若异。不可说故。如彼谷等。先刹那时。若有说言。非自非他非俱起体者。此是成我所成。何以故。因果二法不可说一异故。虽不可说。要待彼缘。方能生果。如是说者。并同前破谓云何芽起乃至先刹那时。复次说有起者言。第一义中。彼入等缘。能起内入。何以故。以缘故。如谷等芽。若不能起。彼则非缘譬如兔角。论者言。如汝所说。第一义中。彼缘有者。此缘于果为有为无。为有无俱。皆不应尔。如偈曰

  非定有定无　　诸缘义应尔

释曰。此缘非有。如其所执。不应尔者。今当显示此义。偈言缘非有者。是何等耶。此非有者。如空华等。何等是。彼摩娄多缘故可知。如是彼无一物。为虚空花。为兔角缘耶。此释非有缘者。是何语义。此验稻谷等缘。第一义中。非自性有。何以故果非有故。如空花非有。虚空无体。如是芽等非有。以稻谷等诸缘非有故。如虚空花。或有人言。我不欲令彼有法起意。欲令彼可起法起。先无体故。论者言。汝谓缘非有者。是何等耶。如彼瓶等。先未起时。则无体相。既无自体。更有何等为彼瓶衣。稻谷等缘。欲令可起法起。如是则无一缘。应知此义。以第一义中。验稻谷等。非芽等缘。何以故。由先未起。无其体故。譬如瓶等。复次法若已有。缘亦无用。何以故。有自体故。如是于世谛中。彼稻谷等。亦非芽等缘。何以故。以生作不观故。如彼已生芽者。及余瓶衣等。以是验故。因义不成。僧佉人言。实有物体。藉缘了作。或时缘中先有细果。后时待缘。令细为粗。汝言已有。缘何用者。此语不然。论者言。彼了作者。先已遮故。复次先细后粗。若有非有。如前说过。汝语非也。复次经部师言。理实诸缘非有非无。言有无者。义不应尔。此复云何。谓第一义中。果起现前。诸缘和合。互相资摄。能得自体。以有缘故。尔时彼果不得言无。以其起故。不得言有。以未现起故。我欲如此以是因缘。无如前过。论者言。此亦自分别耳。非有非无。缘义应尔有及非有。二种无故。皆不可说。譬如余物。若有不有。二俱非缘。论者意尔。复次此中但是有及非有俱不可说。何以故。有非有故。非非有故。如是物者。此是无物。谓眼识或芽彼缘即眼等。诸种子等。不可说实。何以故以彼等果。有及非有。不可说故。譬如余物。修多罗人。不能避过。复次有等自性体空。于世谛中。生义成故。复有俱说尼犍子言。彼果者亦有非有以缘故。我意欲尔。是故无前所说过失。论者言。彼诸尼犍子等。有无二语。方便俱说者。此非安隐处。立义不成。如是已说总破诸缘。今当别破。此中总观因缘故。若能生异缘。彼名为因。如是和合自在所生法起非一能生故。又遮彼起故。我欲如此。于世谛中。建立因义。第一义中。因非因故。应如是说。若汝意谓。此因有物。若不有物。及有无物。能起果者。此义不然。偈曰

  非有非非有　　非有无法起

释曰。第一义中。法相如是。云何说言。因能起耶。故彼非因。如是。彼不能起。有故无故。犹如自他。先已验破。若有无俱。则有二过。是故因体不成。若谓所生法起应说因故者。此亦不然。以有等相不起故。于世谛中。由因有果因亦如是果起因成故。复次自部人言。有因能起彼内入等。此缘起义。是如来说。如如来说。不可变异。譬如寂灭涅槃。此能起因。是因缘义。心心数法所缘。是缘缘义。彼次第灭心心数法除阿罗汉最后心。是次第缘义。若此法有。彼法得起。生增上缘义。由佛说故。有因缘等。为缘自体。汝言无者。此因不成。立义破故。论者言。汝所立义。于世谛中。可得如是。以譬喻过故。所说不然。云何汝等立此因义。为世谛中。佛如是说。为第一义中。佛如是说。若世谛中。如是说者。汝义自坏。若第一义中。如是说者。彼第一义中。非有非不有非有无法起故。彼有非有亦有非有自性果缘不可得故。因不能起。若其如是。云何定言彼因能起。以是义故。汝因不成。以相违故复有人言。受遮方便。此中论中。明法无性法。无性者。二俱遮故。二谓名著。及所名著。所名著者。如前已破。其名著者。今当次遮。若总说义。非有非不有。亦非非有非非不有等世人尽欲因能起果。彼因若有非有。有非有俱。自性果生。皆不应尔。因语转故。识彼因体。因如是因。故不相应。或有人言。第一义中。有诸体起。何以故。有因故者。如先说破。彼因不成。复次有异。论师言。若有若非有。若有无俱。自体不起故。非是因相。因义不成。如是释者。是义不然。复次今当观察彼缘缘义。如其缘缘。亦不如彼忆想分别。如偈曰

  婆伽婆所说　　真实无缘法
  此法体如是　　何处有缘缘

释曰。彼眼识等。不名为缘。何以故。无缘缘故。但是自心虚妄分别。第一义中。遮彼法起。彼欲起时。亦非能缘。何以故。由欲起故。譬如色法。以是义故。缘缘无体。但于世谛。建立眼等因相持故。名之为法。如识因光。然后得起。故名缘缘。不如财与主俱。若尔者无能缘法。第一义中。能缘识不成。如所分别。能缘无故。所缘亦无。以所缘无物故。其义如是。譬如造五逆者。终不见谛。是故彼因不成。亦与缘义相违故。复有异人言。若色阴所摄。色不能缘者。是义相应。诸部论师亦作是说。何等无所缘法。谓色及涅槃。若汝意谓。心心数法。无所缘者。汝先所欲。则为自破。何等有所缘法。谓心及心数法。论者言。汝语不善。我所立喻。今更明显。外人言。心心数法。定有所缘。非如造色者。无譬喻故。复次所取者为所缘。论者言。如彼分别心心数法。有所取者。后当更破。如第一义道理所说。我不欲令识有能缘。如佛说。复次勇猛菩萨摩诃萨应如是行。色非所缘。何以故。一切法无所缘。无有少法可取故。彼若是可取此则是所缘。如是勇猛非色行色。乃至非识行识。勇猛一切法不行故。非色见。亦非识见。乃至非识知。亦非可见。若色至识。非知非见。是名般若波罗蜜。观所缘竟。复次如汝分别。次第缘者。此应谛观其相云何。第一义中。彼一切种。及一切法。皆遮无起。以是缘故。如偈曰

  不起诸法灭　　是义则不然
  灭法则非缘　　及何等次第

释曰。此义云何。以无起故。如第二头。不可言灭。是故第一义中次第缘者此不相应。如是彼义不成。以相违故。顺彼说者。若汝欲得此次第灭心心数法。为次第缘者。是义不然。何以故。彼体灭故。如久灭识。亦如色法。以非缘故。此将欲起心心数法。彼物灭故。何者为缘。以非此缘故。以彼灭者。及欲起法。不能随摄故。此意如是。非次第缘。亦非总缘故。或有如是心起所有决定因缘。各各自在与欲起体处故。缘欲灭时作饶益故。彼余过去刹那。以无间故。次第缘成。是故无过者。此义不然。以非色法无住处故六识次第灭。此名为意。如是灭意。为次第缘者。不免过故。若汝意谓彼欲灭者。为次第缘。汝立此缘。但有是语。何以故。以其同时非次第缘故。复次灭法则非缘及何等次第者。有异释云。此及声者。及未起果。应如是知。其义云何。彼灭未起种子芽等二皆无体俱是无因种子及芽灭起等二堕此过中。论者言。彼立此义。所谓灭者。因灭无体及无住当起作起分别以无因故灭起等二得如是过。此说不然。以无过故。所成能成。语义显了。以颠倒故。得何过失。今当立验。彼灭非缘。何以故。以因有故。譬如未灭心心数聚。又无因起。以因有故。说此二语。彼不相应。是义云何。先语者。因义不成。后语者。自义相违。以一切法起者遮故。此偈亦遮。次第缘故。彼得二过。谓因义不成过自义相违过。如是分别次第缘已。复次增上缘者。其相云何。若有此法。彼法得起故。名增上缘。汝义如是。今第一义中。缘法不起。令他解了诸法如幻。自体本空不可得故。如偈曰

  诸法无自体　　自相非有故

释曰。以是义故。自大乘中。非独第一义谛。诸法无起。于世谛中。因有果起。亦不可得。偈曰

  此有彼法起　　是义则不然

释曰。以是义故。彼因过失。汝不得离。复次佛婆伽婆无分别智。善巧安置。教化世间不信深法者。为安慰故。种种称扬涅槃寂灭等诸胜功德。世谛法故。非第一义。以第一义中彼涅槃等自体空故。譬喻无体。因不成故。或有欲令于世谛中诸法有体。譬如涅槃寂灭故者。此等如先譬喻过失。说无常等诸过患者。毁呰有为法。不令乐着故。诱引彼故。为说涅槃寂灭功德。世谛摄故。说彼有体。第一义中。彼实无体。汝意所欲。义不成故。如是诸缘遮已。复有外人言。第一义中。有缘能起眼等内入。何以故。彼果得起故。如谷等芽。若是无者。果不得起。譬如龟毛不可为衣。论者言。汝谓有者。为一一缘中有果自体。为和合诸缘有果自体。为一一中无和合亦无。应如是问。外人言。汝何故作此问。论者言。若是有者。如前已遮。果若是有。缘复何用。若是无者。亦先已遮。果若是无。缘复何用。如偈曰

  非一一和合　　诸缘中有果
  如是则非缘　　云何果得起

释曰。第一义中。如是如是果等不起。诸缘中无故。此义如是。如泥中无酪。不可生酪。以非因故。若稻等中。无其芽体。如是得生。于世谛分中。凡夫智慧同行见故。欲令第一义中。有彼眼等内入生者。此义不然。如偈曰

  若果缘中无　　彼果从缘起
  非缘中亦无　　云何果不起

释曰。彼如是说。过失起故。如非缘中无果。诸缘中亦无。譬如彼声。作故无常。有何所以。瓶是作故。而非无常。如先已说。声是无常。何以故。由作故。譬如瓶。此义应知。若以此方便。第一义中芽等现空而从谷等生。彼芽等义不应尔。何以故。以果故。譬如酪。是故非有。以不免先所说过故。复有人言。第一义中。有彼内入我。如是受缘转异故。如泥为瓶。论者偈曰

  缘及果自性

释曰。此谓彼缘转异故。偈曰

  诸缘无自体

释曰。此谓缘无自性。偈义如是。譬如生酥。转为婆罗门心。彼缘自体不可得故。如先已说。偈曰

  若缘无自体　　云何转成果

释曰。此明第一义中缘不转变。为彼果体。偈义如是。譬如提婆达多童子梵行。云何耶若达多为彼儿耶。又如幻主化作泥团。彼自体空。能生瓶等。如彼转变。于世谛中。一切智者。皆不能信。是故非缘转变为果。如是譬喻无体。所成能成法无故。如先因义不成。亦相违过故。外人言。若缘自体不转为果者。缘体可无而果者不。失以彼不遮果自体故。如我立义。第一义中。有诸内入。何以故。以果故。譬如芽等。论者偈曰

  非无缘有果

释曰。无缘转变而有果者。于世谛中。亦不能信。何况于彼第一义中。而可信耶。此义不成。外人言。若第一义中。缘体空者。然彼非缘。自体不空。而此非缘。是我所欲。是故非缘义成。论者言。但遮缘体。则无非缘。岂以非缘令汝解耶。复次开合偈曰

  何有缘非缘

释曰。诸缘非缘。自体不有。偈义如是。复次我已先遮有及非有。皆无果起。以是义故果无自体。果既无体。缘则非缘。何处有彼缘体可得。如是语义。本无所有。但彼心声相因起。说果无自性。缘体空故。复次从上已来。外人所说四种缘起。所谓因缘。缘缘。次第。增上等。自体差别。遮彼所立。明无起义。是故此品观诸缘起。无起义成。如诸大乘经中说。偈曰

  若诸缘起彼无起　　彼起自体不可得
  若缘自在说彼空　　解空名为不放逸
  若人知无一物起　　亦复知无一物灭
  彼非有故亦非无　　见彼世间悉空寂
  本来寂静无诸起　　自性如是已涅槃
  能为依怙转法轮　　说诸法空开示彼
  有无不起俱亦非　　非有非无无起处
  世间因缘悉如是　　但彼凡夫妄分别
  常无起法是如来　　彼一切法如善逝

复次如般若波罗蜜经中说。文殊师利如是应知。彼一切法不起不灭。名为如来。又如梵王问经中说。彼处一切爱灭尽故彼名无起。彼若无起。彼即菩提。世间颠倒。虚妄起着。第一义中。佛不出世。亦不涅槃。从本已来。无起灭故。又如梵王问经。偈曰

  已解彼诸阴　　无起亦无灭
  虽行彼世间　　世法不能染

如是等诸修多罗此中应广说

释观缘品竟

般若灯论释卷第二般若灯论释卷第三

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观去来品第二

复次初品已说一切法体无起对治。令人信解。今复次明不来不去缘起差别。使物识知。遮彼义故。第二品起。此义云何。世间法中。言说自在。于所作事。深起爱染。今欲拔彼执着箭故。遮一行相。此外施为。即易可破。彼所谓者。外人言。应有如是内入体起。何以故。彼境界差别可言说故。若无此起彼境界差别。则不可言说。如石女儿不可说。彼有来有去。若提婆达多耶若达多则不如是。由此譬喻。自他诸法起义得成。论者言。若施戒禅等。多修习故。自性起成。或行及住。世间所解此成。已复成过。如在定者。以慧眼观。彼施戒等。行及不行。第一义中。体不可得。彼境界差别可言说。因义不成故。如遮行起行亦同破。复次若谓我立因种共汝同解分别俱成者。此义不然。何以故。彼俱成因。验无体故。如是异执有验。违彼因义故。复次若第一义中。谓有去者。彼已去未去去处三应可得。如偈曰

  已去不应受

释曰。谓去法已谢故。此义自他俱解。不须成立。偈曰

  未去亦不受

释曰。由去者故。如已去者。义意如此。复次云何未去。谓彼去者。未有起作。以彼法未去故。能成所成法自在俱得成。以法体法相欲去者。譬喻验故。此复云何。以未去亦不受。此义成立。何以故。以未去故。譬如余欲去者。复次优楼佉弟子言。何等未去。为如提婆达多未去为去如是不受耶。为如提婆达多去作不去令他解耶。论者言。何因缘故。作如此问。外人言。若汝意欲受先分别则成我义。若汝意欲受后分别则违汝因义。是故非先因义不成。复次我立实外别有去法。汝言非者。是语不然。实外有去。云何成立。谓自体外句义和合调达境界有去。调达我意如是以缘随转故如和合调达应如是知。论者言。若世谛中有去和合。提婆达多显自体外有句义和合。彼境界故生其去觉。令他解者。于世谛中成已复成过。何以故。但有处边刹那刹那前后差别。名为和合。调达名者。唯是行聚。自既无体。何有别去。与彼合耶。如是慧者。我意所欲。复次去名句义与调达合。第一义中。无譬喻故。体不可得。如是彼世谛中。亦违道理。何况第一义谛中耶。此等过失。汝不得离。复次经部师言。因欲起动生彼风界及四大造。名为身聚。处边无间。前后起灭。说名为去。若谓别有外去法者。是义不然。何以故。随所起处起者即灭故。譬如火焰惑者谓去。其实非也。第一义中。亦无去时。汝于第一义中。遮彼去者。成所成过。论者言。以遮起故。汝说方便。此义不成。何以故。焰等去迷智同迷故彼去者去异亦欲遮故。又世间智人。于汝所执。不欢喜故。复次僧佉人言。如我法中。动尘偏增。果则转了。彼未去者说为去故。论者言彼执了等。先已遮故。去义不成。此唯分别。复次诸说去者。闻前过失。心生怖畏。共立义言。去时去故。无前过失。此义决定。论者偈曰

  离已去未去　　去时亦不受

释曰。此义云何。彼去时不可得故。若有去时。为已去耶。为未去耶。若半去半未去。二俱有过。外人言。汝言去时亦不受者。是义不然。何以故。此应受故。云何知耶。彼处举足下足相貌。名为去时。如偈曰

  非已去未去　　彼处去时去

释曰。我所欲者。去时有故。去义得成。复次有人言。若有去处。彼可说有去。如是言说。音声有体。以作与依止。不相离故。已去未去者。不说遮去。此不相应。汝说去时不受。义既不成。已去未去。此亦不破。论者偈曰

  若去时去者　　云何有是义

释曰。如汝所欲。去时去者。此义不成。何以故。以去者故。如已去者。先已破故。复次若定分别去时去者。为已去中有去。为未去中有去。为异此二有去处耶。如先说过。复次第一义中。去时去者验无体故。此义云何。偈曰

  去时去空故　　去时去不然

释曰。如问马枥。是谁马枥。答彼有马者。又问谁马。答彼有枥者。如是问何等为去时。答彼处去。问何处去。答彼去时。俱不明了。或谓无始世谛所解去时。于彼第一义中。欲成立去。是义不然。何以故。此一去业属彼去时此外何处更别有去而言于彼去时去耶。是故汝说第一义中诸内入起及彼境界差别言说。又引提婆达等为喻。立义因譬三皆不成。第一义中以无体故。或谓如是去业。不属去时。以不属故。安置去名。彼有体故。非因不成者。如偈曰

  说去时去者

释曰。去时兼去。此义应尔。而言无去者。此执有过。是故偈曰

  去时中无去

释曰。于去时中。若无去者。则不可说。以为去时。去时无去者。世间不信受。是故去业摄属去时。与时和合义必定尔。汝言无去有异去者。是义不然。有过失故。若汝欲避如前过咎。执言去与去时。和合复如是行去者。此义不然。如偈曰

  去和合去时　　去者唯分别

释曰。第一义中。去和合等。皆不可得。但忆想分别故。若定如此。得何等过。偈曰

  若去时中去　　复及此行去
  则堕二去过　　此义则不然

释曰。此谓于世谛中。义不然故。复次偈曰

  若有二去法　　则有二去者

释曰。何因缘故。作如此遮。若有二法。则有二者。偈曰

  离去者有去　　是义则不然

释曰。为是义故。此不应尔。如前过咎。应清净故。此复云何。如是一去。于世谛中。观彼去者。去时得成。第一义中。与此相违。如是彼境界差别言说。及譬喻等。验无体故。内入不起。无来无去。缘起得成。复次毗伽罗论者言。我所立义。无前过失。何以故。唯有一行。自体去故。彼处行时。即名为去。彼行作者。名为去者。是故汝言。有二去者。及二去法。此过不然。论者言。第一义中。遮彼去故。时则无体。时无体故。去亦不成。于世谛中。处边无间。行聚续起。名为去者。观察去时。实无自体。此不相应。复有人言。决定有去。如是应知。此义云何。彼依止有故。若此依止无。彼则不有。如石女儿。倒行等事。去依去者。相貌云何。谓提婆达多。是故若依止有。彼去则有。以因得成故。如是诸内入起。及去未去等。亦皆得成。论者偈曰

  离去者无去

释曰。汝言去者。为去依止。以此依止有故。为去因者。是义不然。何以故。若未说因时。去则不成。此之过失。汝不得离。如偈曰

  离去者有去　　是义则不然

释曰。若离去者。去则不成。如此句义。先已分别。是故偈曰

  若其无彼去　　何处有去者

释曰。彼去者因。验无体故。此意如是。何处声者。谓不信去者。语义得成。先已广说。去者无体故。如是依止因不成过。及与彼义相违过故。复有人言。去有验故。无前执咎。汝应谛听。我决定立有如是去。此义云何。此若有合。彼则可指示故。此若无合。彼则不可指示。如兔无角。不可指示言有角也。今有去与合可指示言彼调达去以去有故。我立义成。论者言。汝若定谓有调达去可指示者。为欲令于第一义中。有去者耶。无去者耶。如偈曰

  彼去者不去

释曰。今当安立此义。以方便说。所谓第一义中。彼去者不去。何以故。以作有故。譬如住者。是故应知。去者不去。复有人言。我今成立未去者去。以此方便。不能破我。论者言。如与去合。于世谛中。说去者。去义已不成。今云何言未去者去。如偈曰

  未去者不去

释曰。彼未去者。以无去故。义意如此。复次若未去者。云何是去。若或时去。云何名未去者。此自相违。复次方便说者。第一义中。彼未去者。不名为去。何以故。以去空故。如彼异者。前来遮句。应为自部诸师。及食糠外道等。作如是说。复次僧佉人言。如汝所说。彼未去者。名为不去。汝立此义。成我所成。论者言。云何名未去者。外人言。去未了故。名未去者。若去已了。名为去者。论者言。汝所说了。有过失故。如先已遮。复次若汝言先未作去。名未去者。是义不然。何以故。汝自破故。谓彼去者。先未去时。去有自体。汝义如是。复次汝谓住等。为未去者故。去者无体。如是意欲者。是义不然。何以故。汝自立义。还自破故。谓未作去声。彼去者。体不可得故。复有人言。有异门故。名为去者。有异门故。名未去者。由此义成。无如上过。论者言。汝谓去者。未去者。外别有异者。与彼去合。是义不然。何以故。如偈曰

  异去及未去　　无第三去者

释曰。此明何义。谓离去者。及未去者。无彼第三。此是去者。未去者故。有如此人难令他解。复次去未去者。先已破故。汝言有异门故。名为去者。有异门故。名未去者。此义不成。若谓去者有作故。此作不遍。汝立因义不成。以彼无作故者。是义不然。何以故。汝言去者。与去作合。如是去作。是我所遮。譬如功用作声。是其无常。作虽不遍。而作故无常。因义得成。如是去者。与去作合。我遮此故。非因不成。若有成立。未去义者。亦应以此未去因。答若谓有去者。无去者住者。住者立义。譬喻无体。以所成之法一分不具者。是义不然。何以故。所成分者。彼此俱解。我引住者。为譬喻故。竟有何咎。如是一人。说为去者。此义不然。如先说因有去合故。彼可指示以此为因者。因义不成。亦譬喻无体。以所成之法具故。违于因义故。外人言。世间眼见彼去者去。见已起说。虽有闻等。不胜眼见。以是义故。非因等不成

论者言。彼如是见世谛中慧。以此为实。第一义中。如理谛观。何等名见。若以世谛所见。为第一义者。彼不可信。此云何知。如偈曰

  若谓去者去　　此义云何成

释曰。彼去者去。去义不成。譬如有人自言勇健。将临战阵。望风退走。此勇若成。汝义则立。云何不成。如偈曰

  去者无去故　　不成义如是

释曰。如去无体。我先已说。令他解故。何处令解。如上偈言。已去者不去故。及彼去起亦先已遮。已去不去者。此是立义。令他得解。云何令解。如上偈言。若谓去者去。此义云何。成等如先分别。如是第一义中。无去无去者。以去不实故。但彼妄置去者。名去彼诤论者。如是立义得此过失。云何过失。偈曰

  去者去既空　　何有去者去

释曰。若谓去成去者。与彼去合。是义不然。何以故。若汝欲避如前过失。第一义中。成立一去与去者。合彼名为去。此执则堕二去过中。如偈曰

  去者与去合　　则堕二去咎

云何如此。偈曰

  一去了去者　　二谓去者去

释曰。以是义故。别有过失。谓堕二去者。此复云何。偈曰

  离去者有去　　是义则不然

释曰。所依若无。能依不有。义意如此。必欲无去。有去者故。及有二去。二去者故。理应有去。名为去者。又欲去与去者一故。世谛成立。非第一义。以第一义中譬喻无体。如彼所说。验不成故。外人言。定有去。何以故。彼初发足有故。若世间无物。则无初起。如虚空花。由世间有物。彼处转离。即名初发。说为行相。是故有去。论者言。譬如染鸡。后色虽异。鸡体是一。汝亦如此。语虽异前。义更无别。如先所问。今还问汝。为已行名初发。为未行名初发。为行时名初发耶。三皆不然。如偈曰

  已去中无发　　未去亦无发
  去时中无发　　何处当有发

释曰。已去中无发者。谓去作用。于彼已谢故。未去亦无发者。谓未行无去。去则不然。去时中无发者。谓已去未去等。皆无去义。云何可说去时有去。如是三种。俱无初发。是故偈言。何处当有发。以是义故。汝因不成。立义亦坏。如是已去未去去时。初发不成。令人信解。语义如此。云何验耶。所谓已去无初发。以去者故。譬如去者。去已未去亦无发。以未去故。譬如欲去者。未去去时中无发。以去者故。譬如已去未去者。如是初发无体。因义不成。自谓为因有过失故。外人言。我有异义。所谓有彼去言说故。以此方便。去有自体。自位别故。又和合句义起别语言因故。此若无者。彼自位差别和合句义起别语因则不得有如生盲人。眼识毕竟无和合故。不可说言彼生盲者。已见现见及以当见。今有去法及自位等。和合句义起别语因。故得说言。彼行止息名为已去。行法正起名为去时。行作未发名为未去。是故我说。因有力故。去法不空。所欲义成。无前过失。论者言。若有去法可说去时。已去未去是义应尔。彼去无体先已广说。汝复执有。今当更破。如偈曰

  未发无去时　　亦复无已去
  彼初起去空　　未去何处发

释曰。前无去合彼去不起故。偈意如此。先说去空。令他得解。验破外人所立义故。复次未去何处发者。此明去无故。如是第一义中。分别不起。此义云何。偈曰

  无已去未去　　亦无彼去时
  于无去法中　　何故妄分别

释曰。妄分别者。如翳目人。于虚空中。或见毛发蚊蚋蝇等。皆无体故。如偈曰

  如是一切时　　未曾见初发
  而言有去等　　过失则甚多

释曰。譬如那罗延[矛*(替-曰+貝)]逐彼竭株嗢羯遮阿修罗王。彼亦如是。去等过失。常随逐汝。复次有人言。第一义中。去法是有。何以故。以相违故。谓处处相违。相待可得。譬如明暗如是与住相违有去可得而言无去者。是义不然。论者言。立此义者。是亦应问。汝意为欲令谁住耶。为是去者。为未去者。若去者住。义不应然。如偈曰

  去者则不住

释曰。此谓第一义中。立去者住。验不可得。何以故。以去者动作故。譬如调达。正行未息。若谓未去者住。是亦不然。如偈曰

  未去者不住

释曰。彼未去者。以无去故。于世谛中。彼去息故。名之为住。此义不成。以去无体故。复次恶见所持。邪执自在。作如是说。欲得异住。如偈曰

  异去未去者　　谁为第三住

释曰。无一住者。说之为住。此义可得。偈意如是。复次偈曰

  去者若当住　　此义云何成
  去者去空故　　去住不可得

释曰。去住相违。于一时中。不得并故。偈意如此。彼去空者。令人得解。以去者住。无体可示故。外人言。譬如窑师。于三时中。能作不失故。如是去者。虽复不去。亦名去者。此义成故无过。论者言。汝受假法。先所成立。第一义者。今并失坏。由如此义。前所出因。及譬喻者。有过失故。复次有别道理。显彼过失。汝立此住。其义云何。为当去者已去止息名为住耶。为彼去者未去若去时息名为住耶。三皆不然。何以故。偈曰

  去时则无住

释曰。若去与去者合。名此为住。义则不然。外人言。我先所说。已去名住。此义得成。可信验故。论者偈曰

  无彼已去故

释曰。已去住者。是义不然。何以故。彼已去者。去已谢故。言其住者。无所除故。若汝意谓。彼未去时。名之为住。是亦不然。何以故。未去而息。义不然故。以是因缘。彼未去者。亦不名住。如是因义不成。验亦无体。此义云何。彼明暗等。第一义中。不可成立。以相违故。亦乖汝立义故。复有人言。我立住义。以相违故。有初发故。又彼可除。体有起故。是义不然。彼有过失。如偈曰

  去起作及息　　其过同去说

释曰。如去者去。未去者去。异彼二去。义皆不然。及已去未去去时去初发者。是亦不然。如是已去未去去时。及彼去息。皆不成故。如是住者未住者。及异彼二住皆不然。住不然故。已住未住住时。及住初发。亦不可得。初发无故。已住未住住时住息。义皆不成。如上广说。以文烦故。今略显示。此义云何。彼住者不住。何以故。以去空故。如彼已住。住未谢者。久已住者。无住初发。何以故。彼已住故。譬如已久住者。又已住者。无住可除。何以故。去无体故。譬如住未谢者。如已住中。三句显示。未住住时。亦复如是。以前方便。应当验破。如是住义不成。有过失故。外人言。汝言无去。及无去者。是义不然。何以故。破坏世法故。世人咸谓。彼提婆达多去。或耶若达多去。汝言不尔。与世相违。如世皆知彼月是月。复有人云。是兔非月。汝亦如是。论者言。汝立此因。复有何义。为与世间所解相违。为与自论所解相违。若尔有何过。若世间所解相违者。因义不成。何以故。彼去去者。第一义中。不可得故。如是世间所解有去去者。于世谛中。我不遮故。若言与自论所解相违者。即所解破如是意耶。汝作此说。不解义理。应如是说。汝所受破。得此过失。是义不然。何以故。自论所解。我亦不着。以第一义中。去及去者。此二自体皆不受故。如先已遮。复次若第一义中。去及去者。此二定有。或一或异。求应可得。如是观察。二俱不然。如偈曰

  去法即去者　　如是则不然
  去法异去者　　是义亦不然

此二种义。云何不然。偈曰

  若谓彼去法　　即是于去者
  作者及作业　　则为一体过

释曰。如是语义。颠倒过咎。如声是常。瓶亦是常。以其作故。此义不成。何以故。若瓶是作。则不名常。以是义故。声是无常。以其作故。譬如彼瓶。此言可信。如是第一义中。去及去者。此二不一。何以故。以作者作业故。如能斫所斫。此二显现。亦不得异。何以故。以去去者。更互俱空故。譬如余物。或有难言。若去及去者。更互俱空。空无异相。体不可得。汝引能斫所斫。为譬喻者。此义不成。论者言。汝不善说。唯遮一故。彼二相差别。世间悉解。如是能斫所斫。更互俱空。此义成立。如能觉所觉。二更互空。于世谛中。二相异故。引为譬喻非喻不成。若谓能斫所斫。第一义中。二体无异。何以故。以其量故。譬如所斫自体。彼立一者。是义不然。何以故。所斫自体不异者不成故。何故不成。以第一义中。一异二边。不取受故。于世谛中。能所各异。而言一者。破世间解。复次若汝意谓。我遮去者。及去不一故。而受异边者。是亦不然。如先已说。第一义中。一异二边。我皆不取故。无受异过。复有人言。如我立义。无前过失。谓无始已来。名言戏论。熏习种子。以为因故。决定因缘。各各果起。虚妄分别。自在力故。此执欲令去及去者。决定有异。为遮彼故。如偈曰

  若谓彼去法　　定异于去者

释曰。世俗分别。无有遮者。如实观察。义则不然。云何不然。如偈曰

  离去有去者　　离去者有去

释曰。此二云何相离而有。以其异故。如瓶衣等。彼说异者。亦不欲令离去有去者。离去者有去。以能依所依相观有故。方便说者。第一义中。不欲令彼去及去者。有差别故。以差别语起有待对故。如去自体。如是第一义中。不欲分别离去者外。别有去法。何以故。以差别语起有待对故。譬如去者自体。外人言。异部回转。不令他解。汝得此过。论者言。彼异部无体。回转义成。外人言。世间自有能依所依。未必和合。汝言有待对者。此因义不成。何以故。于所验中。一分不遍故。论者言。彼诸物等。亦有此彼。相观异故。待对无过。非因不成。汝说验者。终是立异。异先遮故。不异得成。异部无体。亦非二边。世间所解。亦不破坏。云何不破。今此论中。真实观察。能依所依。相应和合者。非无漏慧。所观境界。如先所说。复次或有人言。我异于去有彼去者。可指示故。譬如提婆达多。及彼马等。能依所依二相异故。论者言。汝不善说去者。自体义不成故。提婆达多马等异故。此义不成。以第一义中。譬喻无体故。若有邪慧。分别诸因差别等相。亦以此义答。复次鞞世师言。聪明智人。作如是解。谓去者之声。此自体外有去。句义相应和合。如提婆达多。为所知境界。转不转故。如言青衣。余则非分。若不如是。彼去者声。应无转不转异。譬如大有。论者言。汝立此异。以为验者。是义不然。何以故。所依能依。相应无体。去与去者。此二和合。先已遮故。验亦不成。云何知耶。谓多同名人。彼自体外。句义不合。谓若二若三。乃至无量调达等也。以此验知转不转声。因非一向故。外人言。有简别故。虽同一名。而彼黑长调达者。去声于此转。余则不转。以是义故。我因得成。非非一向。论者言。如汝所言。黑长调达。第一义中。以无体故。因义不成。如青衣喻。及境界者。第一义中。皆不可得。若有说言。去异去者。觉差别故。如此立验者。同前因喻破。复次若汝谓。我立一遮异。立异遮一。终不离异故。遮异不成者。是义不然。何以故。一异俱遮。先已说故。以此验力。破着二边。彼境界觉。何因得起。智人已解。故我无过。是故汝言我遮去者。与去不异。立义分别。受不异者。我无此过。复次汝若细心观察。取我上言。譬如去者。自体不异故。立义不成。以譬喻无体。与我过失者。是说不然。何以故。去者体外。更无异法。无异法故。去者体成。以体成故。譬喻无过。如是鞞世师人。诸食糠等。覆藏己过。欲坏正理。如先所说。验皆不成。复有人云。汝先遮去。今则弃舍。乃更论余。若一若异。去及去者。二皆不成。此非善说者不然。如偈曰

  去者及去二　　为一异故成

释曰。去者去二。为一为异。有彼二故。可领受耶。若方便说。或一或异者。如偈曰

  彼二无有成　　云何当有去

释曰。彼去已遮。非欲舍故。由如此义。一等分别。亦如是遮。于世谛中。彼二有故。应知如汝意谓。第一义中。若一若异。去者去成。无如此义。一异体无。而执为有。令人解者。是义不然。或有聪明慢人。作如是说。汝言第一义中。无去者去。以作动故。如彼余物。如是住者无住。以作动故。如彼调达。去未谢者。此前二验。为何所显。作动作者。为当外动作者。此作不作耶。为当身动作者。此作不作耶。若言外作不作者。则譬喻不成。以彼异作作故。若言身作不作者。则与义相违。以语者语故。斫者斫故。彼去亦然。身既动作。何名不作。如是先所说验。此义不成。有过失故。论者言。彼异作者不作去作。以是义故。彼作者等。譬喻得成。如所说过。今还在汝。譬喻既成。亦不违义。云何不违。如偈曰

  因去了去者　　彼去则不去

释曰。彼去不去者。谓第一义中。不作彼去。何以故。以无异故。如去自体。此谓说无异者。自验破故。亦破世间所共解故。何以故。如偈曰

  如见有是人　　往村等去故

释曰。彼人体外。别有村等。世间悉解。复次因去了去者。彼去则不去。此义云何为此故。如偈曰

  先无有去法　　故无去者去

释曰。如住者自体得为去因而作于去。无此去者故。虽无去者。而世谛中。意欲为因。次生功用。风界自在。处边无间。诸行聚起。时节差别。刹那刹那。前后相异。此等起故。名为去者。于世谛中。实不欲令如是作者。为作者因。是故偈言。如见有是人往村等去故。非以自体为自体因。如是诸自部辈因去了去者。彼去则不去。此义应知。复次僧佉人言。由地等聚集别名身种。彼尘增长故称为去。如是去果依止聚因。去和合人。名为去者。此执不然。何以故。彼未去时无去者故。若未去时。名为去者。如是住者。亦应名去。而实不然。若谓彼已去者。为彼去因。是亦不然。何以故。如先偈言。如见有是人往彼村等故。此义云何。如是彼去不能作去应如此知有。外人言。有生作故。说为芽生。犹如智人自生智慧。此执不然。但妄分别。以芽未生时。生无所作。而言生作。此义不然。如是去者自体去。说者自言说。斫者自斫作。此皆不然。何以故。自体自作。义不然故。由彼意欲为因。次起功用处作等因。生彼字句音声行聚。名为语者。而执有别语。言自体者。此则不然。如是语先名为语者。无如此义。复次。鞞世师言。如先所说。因去知去者。彼去则不去。汝虽已破。义又不然。何以故。彼去者外。别有去法。以是义故无前过失。别义云何。谓实觉业觉。此二不同。境界别故。譬如牛与水牛。二觉相异。若不异者。彼二境界。则无差别。譬如牛觉自体。论者言。因去了去者。彼去则不去。此过如前说。今遮彼异。如偈曰

  因去了去者　　异去亦不去

释曰。彼立异者。令他得解。验无体故。如偈曰

  此物与彼物　　有异者不成

释曰。第一义中。法性如是故。我譬喻得成。复次因去了去者。异去亦不去。此义云何。偈曰

  去者是一故　　去有二不然

释曰。何故不然。立验知故。以第一义中去者。体外无异去去。何以故。以不合二去故。譬如住者。复次食糠者言。如我立义。唯有一去。去与者合。名为去者。由此异故。能为去因。以作彼去故。如有人言。彼调达去。又如彼灯与明为因。名曰灯明。如汝先说。去者一故。去二不然。义不应尔。论者言。汝非善说。如前所说。诸因力等。第一义中。去及未起。皆已遮故。复次去者。不为去和合因。以起声觉别因故。譬如彼业。以此验知。汝言去与去者和合。虚妄说耳。何以故。若人未与去和合时。则非去者。譬如住者。而言与彼去者和合。是义不然。复次如理谛观。去及去者。不可得故。如偈曰

  有实无有实　　亦有实无实
  如是三去者　　各不用三去

释曰。有实去者。谓与去和合故。名为有去。此义云何。若有实去者。不用三去。谓有实去不去。无实去不去。亦俱去不去。以作动故。譬如余物。若无实去者。亦无三去。以去空故。譬如住者。彼俱去去者。同前验破。如破去者。去法亦然。立义出因。引譬方便。应如此知。由依道理阿含二种观察。于一切时。三去不成故。如偈曰

  是故去无性　　去者亦复然
  去时及诸法　　一切无所有

释曰。如先立验。破去去者。诸余作法。亦应例遮。此品中明去无自性者。欲令信解无来无去别缘起义。是故得成。如无尽慧经中说。无去无来者。名为圣去来。又如金刚般若经说。善男子。如来者。无所从来。亦无所去。故名如来。又如无言说经曰。来去无有实。诸法如虚空。又如般若波罗蜜经说。彼微尘等。亦无所从来。亦无所去。以彼去来不可见故。又如佛告极勇猛菩萨言。善男子。色法去来不可见故。受想行识亦复如是。五阴去来不可见者。是名般若波罗蜜。如是等诸修多罗。此中应广说

释观去来品竟

般若灯论释卷第三般若灯论释卷第四

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观六根品第三

复次。成立此品。其相云何。为遮起故。令人识知内六入等无自性义。故说此品。又遮去执。欲令通达入等空义。此品次生。初分别者。外人言。有内入起。第一义中。如是应受。何以故。境界定故。此起若无。彼定境界。则不得有。如石女儿。以是故知。有内入起。彼境定故。如偈曰

  眼耳及鼻舌　　身意等六根
  彼色等六尘　　如其数境界

释曰。以是义故。所说因成。入起义立。次分别者。外人定说。有如是去。何以故。以作果故。如见色等。论者言。此二分别。今次第遮。彼眼等根。各各增上。聚集有作。能取色等。是故名根。于世谛中。根外亦有色等可得。以作者自体可显示故。谓见故名眼。乃至知故名意。复次此诸根等。显示可见可闻嗅尝触知诸境界故。境界义云何。谓根于尘。有能取力。故名境界。有境及境。世谛中有。第一义中根尘定有者。此执不然。以违义故。云何开示。令彼解耶。如观眼根。偈曰

  如是彼眼根　　不能见自体
  自体既不见　　云何得见他

释曰。何故不见。如是眼根。第一义中。能取不成。何以故。偈言不见自体故。又有碍故。亦造色故。譬如耳等。又第一义中眼不见色。何以故。以彼色法从因起故。譬如鼻等。又色阴所摄故。譬如舌等。如是第一义中。色非眼境。何以故。以积聚故。如眼自体。又第一义中色非眼境。何以故。以有碍故。亦造色故。譬如耳等。又第一义中色非眼境。何以故。从因起故。譬如鼻等。又色阴所摄故。譬如舌等。复有人言。眼不见者。谓不见自体。以色可见。是故眼能见色。论者言。如汝所说。眼不见者。助我出因。及譬喻力。岂能破我所立义耶。复次阿毗昙人言。若无简别。如是说言眼不见色者。此成我义。何以故。得一门故。我立义中。彼无分眼不见色故。若有分眼不见色者。汝之所受阿含义破。如我俱舍论。偈曰

  有分眼见色　　非彼能依识

阿毗昙中。作如此说。岂非所受阿含义破耶。论者言。如汝立义。此有分眼欲令见色者。是义不然。何以故。无二过故。谓非成已。复成及非所欲义破。云何不破。如经偈曰

  眼不见色尘　　意不知诸法
  此名最上实　　世人不能度

释曰。第一义中不欲令彼眼见色故。如先广破。此义得成。又第一义中彼有分眼不能见色。何以故。以眼根故。如无分眼。又第一义中彼有分眼不能见色。何以故。以色根故。譬如耳等。又亦不破世间所解。何以故。立义别故。谓第一义中无与过者。复次迦叶弥罗毗婆沙中如是立义。谓彼眼见诸色。以能作见业故。论者言。汝出因者。立义一分故。验无体故。已说遮故。此义不成。复次若有作者。则与立刹那者。义相违故。又与无刹那者异故。此皆不然。是故迦叶弥所执义不相应。复次经部师言。诸行无作故。眼不能见。异亦不见。而彼眼色为缘。眼识得起。修多罗中。作如此说。汝言眼不见者是为成已复成过。论者言。先已遮起故。眼识不可得无成已复成过。又所受义亦不破故。谓如是领受修多罗义。随顺世谛故。第一义中验则无体。已遮眼色二见可见等。彼差别者。义皆不然。如是欲令学人生诸觉意。作少分说。如先偈言。如是彼眼根。不能见自体。若不见自体。云何得见他。以第一义中眼不见色。何以故。不见自体故。譬如耳等。或有人言。眼不到境。而能取色。何以故。以彼眼根可得义故。譬如使人见事。名为王见。论者言。第一义中眼不到境。能取色尘。无如此义。何以故。以眼不能取自体故。譬如耳等。如是第一义中。所取色尘。非彼不到眼根境界。何以故。以所造色故。譬如香等。如是有碍故。从因起故。色阴所摄故。又积聚故。此等诸因。并遮眼。不到境。色非所取。立义举喻。如前广说。二门僻执应当验知。复次第一义中。眼非不到境界。何以故。现在境界故。譬如鼻等。或有人言。眼不到境。何以故。有间取色故。譬如意也。又无功用。时节差别。能取色故。又过量取故。立义譬喻。如前应知。论者言。此说不尔。汝言不到境者。即是有间取色。有间取色者。即是立义一分。更无别义故。此说不然。又时无差别。取者义坏。纵实因成。验无体故。彼第一义中意亦不到。而能取者。此执不成。以违义故。复次僧佉人言。汝言眼非不到境取者。此成我所成。何以故。我欲令眼到境取故。论者言。不到取者。欲令信知眼法空故。眼法既空。岂复成立到境取耶。汝于非处。妄生欢喜。复次眼到境取。云何不然。以根故。譬如意。亦不取鼻等诸根。非一向过。何故不非一向过耶。彼鼻根等。亦如是故。如后当说。复次眼到境者。此有何义。为当依止所取境界如是意耶。是义不然。何以故。彼眼识依止实不外去。何以故。以识故。如鼻等识。第一义中眼识不能取彼境界。何以故。以因有故。譬如声等。外人言。汝依二门。更互相破。依此遮彼。二俱不成。论者言。二俱无体故。我不取。以不取故。所欲义成。复次僧佉人言。眼光到境。故能取色。如是意者。此亦不然。彼眼根光。于世谛中。亦不得有。何以故。色识因故。譬如彼色。复次僧佉人言。眼根有光。以眼根故。譬如伏翼猫狸等眼。论者言。眼根色者。不可见故。纵彼依止。实有光者。则譬喻不成。复有人言。如前所说。如是彼眼根。不能见自体者。此有何义。诸法若有自体可见。彼和合时。他亦可见。譬如花香。由如此义。眼不自见。亦不见他。如提婆菩萨百论偈曰

  彼一切诸法　　若先有自体
  如是有眼根　　云何不自见

论者言。见者何义。谓色可得。彼色可得。若如眼不有色亦无者成已复成过。如偈曰

  识不在眼色　　不住二中间
  非有亦非无　　彼识住何处

复次若言彼眼根中。无见种子。是故不见者。须曼那花譬喻不然。何故不然。彼花因缘和合自在。故有香起。如俱苏摩和合麻故。油则有香。无人立色。有见作义。彼遮不成。复次若谓自不见故。亦不见他者。火花譬喻二皆无力。以火花等自他不取故。此不相应。如是眼见义不成故。彼起及去亦皆不成。以譬喻无体故。亦违因义故。外人言。汝言眼不见色者。由不见自体故。此义所明。若于自体无力。于他亦然。如是义者非一向故。如火自体。无其烧力。于他则能。眼亦如是。论者偈曰

  火喻则不能　　成彼眼见义

释曰。第一义中。烧者不成。于世谛中。火非见性。又彼火自体。于世谛中。烧义不成。云何名烧。谓薪火变异。是故知火自体非烧。复次火喻不成。眼见义者。彼眼见火喻。如前已说。云何已说。偈曰

  去未去去时　　已总说遮故

释曰。第一义中。已去未去。去时无去。如先已说。如是第一义中。已烧未烧烧时无烧。何以故。烧时故。已烧故。未烧故。譬如烧时。已烧未烧彼烧时者。有二过故。彼已烧者。如久已烧讫。彼未烧者。本无烧故。如是已见未见见时不见。何以故。已见故。未见故。见时故。譬如已见未见见时。随其次第。应当验破。有人言。眼有见作。何以故。诸部论中。皆作此说故。譬如眼见诸色。论者言。此眼见者。于世谛中。以方便说。非第一义。云何知耶。今此论中遮眼见故。亦遮起故。彼眼则空。如偈曰

  眼若未见时　　不得说为见
  而言眼能见　　是义则不然

释曰。见义不然。偈意如此。以是义故。如偈曰

  见则无彼见　　非见亦无见

释曰。能见空故。如土石等。偈意如此。如是二种。有见作者。此义不然是故偈言。见则无彼见。非见亦无见。二种俱遮。譬如若有非有。缘皆无用。如是若有非有。因亦类遮。复次僧佉鞞世师等言。以此眼见所作具故。彼所有眼彼名见者。以彼见者。自眼见故。如所斫木。斫者能斫。非斧能斫。是故非眼见者。此则成我所成。谓彼作者。有诸作具。以作具故。譬如斧等。必有斫者。论者言。彼邪分别。谓有见者。此执不然。如偈曰

  若已遮于见　　应知遮见者

释曰。如眼不自见。彼亦复尔。丈夫自体。见丈夫者。此义不然。以与世间所作相违故。如刀不自割等。云何验知。谓第一义中。彼丈夫者。无能见义。何以故。不见自体故。譬如耳等。亦非因义不成。彼经中说。我还见我者。但于心上。施设我名世谛故说。非第一义。如是物故。所识境故。量故。如声及耳。是等诸因。及彼譬喻。应当广说。复次第一义中。色非我见。何以故。以物故。如我自体。不能自见。如是所识境等。应当广说

外人言。佛法无我。汝言。如我自体。不能见者。与教相违。论者言。于世谛中。假说我喻。不违于教。第一义中。斧等及譬。皆无体故。非成已复成。有人言。汝说见者不见。语自相违。何以故。若言见者。云何言不见。若言不见。云何名见者。此是立义过。论者言。缘起法不起。如先已答。不复更说。复次汝言见者。为是见自体耶。为不见耶。若见自体者。如僧佉言。思是丈夫自体。若彼见者。是见自体。自体非作离。彼眼根亦应得见。复次斫者离斧。则不能斫。丈夫离眼。岂能见耶。我为见者。及彼斫者。世谛中说。非第一义。为此分别故。偈曰

  离眼不离眼　　见者不可得

释曰。眼等诸具。先未有时。及彼舍时。即是无眼。若无眼者。则能所见空。离能所见。执有见者。此则不然。见无自体。见者亦无。义意如此。复次若言如火自性。见者亦尔。此义不然。何以故。若无薪时。火无体故。复次僧佉人言。若不离眼此色可得验知有彼见者能见。此执不然。何以故。无见者故彼色可得者。谓眼色空明及以作意此等有故有色可得。又此等诸缘具足聚集说彼调达名为见者无。如僧佉所计。丈夫名为见者。何以故。无有盲人能见色故。彼眼能见说为见者。如灯无思。亦为明因。眼见亦尔。以是义故。于世谛中。亦无见者。复次鞞世师言。见者无体。由四种和合色识起故。名见者见。论者言。彼同前过四种和合别有见者世皆不知而言有者。此义不然。是故偈言。离眼无见者。无彼自体故。以离眼见则无见能总名见者。此是随汝意说。复次鞞世师所立。第一义中。见者见色。是义不然。何以故。异眼故。如瓶等。以前二门。见者不成故。复次分别丈夫以为见者。无自体故。如偈言。离眼不离眼见者。不可得彼见者。自体有眼无眼不可见故。若谓见者有眼能见。此亦不然。何以故。由眼有体。见色得成。如火能烧。眼见亦尔。世谛中说。如此应知。若离彼眼。别有见者。盲人无眼。亦应能见。此义不然。复次鞞世师云。见者合作。能见于色。如是应知。彼具业有故。此若无作。彼业具则无。譬如虚空。由有眼具见色为业。知有见者。及彼见作。论者言。第一义中。于一切时。眼无有故。而立见者。是则不然。如偈曰

  见者无有故　　能所二皆空

释曰。见者无体。则无所取。而言眼为彼具。以此眼见者。是义不然。是故汝言具业有故者。彼因不成。亦违义故。过失如是。复次自乘人言。诸行因缘。依他故空。眼及彼我。俱不能见。是义应尔。而言所见能见都无体者。此义不然。何以故。彼识等果。四种有故。此若无者。彼识触受爱。不名为果。如生盲人。论者言。所见及见。此义不成。如先已破。今所谓者。如偈曰

  见所见无故　　识等四种无

释曰。何故无。缘无故。以是义故。识等不成。能所既不成。譬喻亦无体。有人言。第一义中。有是识等。以彼取等果有体故。论者言。此应如是答。偈曰

  彼取缘等果　　何处当可得

释曰。识等无故。取亦不成。偈义如此。摄受是取义。彼有几种。谓欲取戒取我语取见取彼取缘有及生老死。如是过失。常随逐汝。外人品初。举譬喻等。成立眼见。如先已遮。彼耳声等。例同前破。如偈曰

  耳鼻舌身意　　闻者所闻等
  应知如是义　　皆同眼见遮

复次外人品初。说有是去。以作果者。是亦不然。如先偈说。是故去无性。去者亦复然。去时及诸法。一切无所有。以是义故。外人分别。有彼入起及去义者。此皆不成。如先说过。以入等体空令生信解。品义如此。是故得成。如无言说经。偈曰

  内外地界无二义　　如来智慧能觉了
  彼无二相及不二　　一相无相如是知

又如金光女经言。文殊师利语彼童女。应观诸界。童女答言。文殊师利。譬如劫烧时。三界等亦尔。又说偈曰

  眼不能见色　　意不知诸法
  此是无上谛　　世间不能了

又如般若波罗蜜经说。彼一切法。无知者。无见者。彼说法师。亦不可得。不可以心分别。不可以意能知。又如佛母经说。阿姊。眼不见色。乃至意不知法。如是菩提离故。眼色离。乃至菩提离故。意法离等。又如佛告极勇猛菩萨言。善男子。色不为色境界。受想行识不为识等境。以境界无故。极勇猛。色不知色。色不见色。若色不知不见。是为般若波罗蜜。乃至受想行识不知不见亦复如是

释观根品竟

    般若灯论释观五阴品第四

复次欲令识知阴无性义。故有此品。有人言。第一义中。有诸入等。何以故。以阴摄故。若其无者。彼色入等。则非阴摄。如处空花。由有诸入彼阴摄故。如十种色入。一色阴摄。法入三阴。谓受想行。及彼一分色阴所摄。彼意入识阴摄。以是因故。第一义中。有诸入等。论者言谓色阴者。略说二种。四大及所造。若三世等一切差别总说色阴。彼眼等阴摄。外人欲为因者。色粗易解。先分别说。如偈曰

  若离于色因　　色则不可得

释曰。何等是彼色因。谓地等四种大。第一义中。若离此等。色不可得。而于世谛。依四大因。假施设色。第一义中。验色无实。自因不受故。彼觉无体故。若自因不受。觉无体者。彼实非有。如军众等。色因不可取。色觉无自体。亦复如是。复次第一义中。色觉境界。体非实有。何以故。以觉故。譬如林等觉。复次第一义中。色声句义。境界无实。何以故。以闻故。譬如军等声。若言受等诸阴非一向者。此义不然。何以故。识等心数。亦同遮故。非非一向。或谓第一义中。有彼实色。何以故。彼色变异。觉无别故。若物变异。觉亦别者。此世俗有。譬如瓶等。如青色别时。彼觉无异。以是义故。知有实色。论者言。第一义中。验无体故。已观因色。次遮四大。如偈曰

  若当离于色　　色因亦不见

释曰。色声香味触等。此诸因色皆相离故。彼色因地等。不可见取。为此义故。今造论者。初遮彼地。遮彼地等。有何所以。有大义故。云何大义。如世谛中。从因起者。第一义中。体实无生。此无自体。如楞伽经偈曰

  离积聚无体　　彼觉无可取
  故知缘起空　　我说无自性
  无物从缘起　　无物从缘灭
  起唯诸缘起　　灭唯诸缘灭

释曰。以此方便。第一义中。地非实有。如是决定。彼因不可见。不见彼故。若不可见故。不见彼者。第一义中。彼不实有。如军众等。复次第一义中。地觉境界。体非实有。何以故。以觉故。如林等觉。复次第一义中。地声句义境界无实。何以故。以闻故。譬如军众等声。复次第一义中。自和合分。无彼异色。何以故。彼不可取。彼觉无体故。譬如地等自体。复次僧佉人言。汝言色等不异地等者。此成我所成。论者言。遮异故。非以不异令汝得解。汝邪分别言不异者我不受故。复次鞞世师言。汝出因者。非一向过。何以故。如不取灯。则无瓶觉。彼亦异故。论者言。汝不善说。我但遮彼。自和合支。不可取故。彼觉无体。不论余事。灯虽无体。而有宝珠药草日月等光。彼瓶觉起。自和合支已外。更无异色可得。以是义故。汝喻非也。灯非彼瓶自和合支故。异门无体。非非一向过。如偈曰

  此物与彼物　　异者则不然

释曰。此义如后当说。复次第一义中。灯与瓶异。此亦不成。以是义故。非非一向过。复次鞞世师言。彼军众等总实。以初起有故。汝言地等无实。立验令解者。譬喻不成。论者言。军众诸枝。非彼军众总实初起之因。何以故。以总故。如树根茎枝叶等诸分。彼军众象等诸分。非彼军众初起之因。何以故。彼非分故。譬如经等。亦非譬喻无体。如偈言。若当离于色。色因亦不见。如前立义出因譬喻。验彼色等。无异地等。及彼地等。无异色等。异如前遮。不异后破。若不异者。乳即是酪。酪亦为乳。以不异故。以是义故。此证得成。如楞伽经偈曰

  不异无有体　　束芦及别处
  若一若异等　　凡夫妄分别

释曰。如色入等。彼欲成立。说因有故。以为因者。此因不成。亦违义故。复次若汝分别离彼色因而有色者。此亦不然。何以故。有过失故。如偈曰

  离色因有色　　色则堕无因

释曰。诸说无因者。言欲令无因有色彼应如是问纵令汝说与理相应。随何等物。是汝所说无因种耶。不欲令尔。如偈曰

  无因而有物　　终无有是处

释曰。此义云何。以无譬喻。显彼体故。若拨无因。有大过失。此执不成。如观缘品中已破。僧佉言。第一义中。实有地等。色等无异故。如色自体。论者言。汝因不成。喻亦无体。色等无异。及色自体。前已遮故。复有人言。第一义中。有彼地等。何以故。彼果有故。此若无者。彼果不有。如虚空花。今有果色故。地等不无。此执不然。如偈曰

  若离色有因　　此因则无果
  无果而有因　　云何有是义

释曰。若离色等果。有色因者。即是无果有因。何以故。以其异故。如竹篾等。又彼因者。亦色等聚故。由如此义。因果不成。如汝所说果有故。为因违于义故。此执不成。复次分别此色。若有若无。二俱不然。因无用故。如偈曰

  色若已有者　　则不待色因
  色若先无者　　亦不待色因

释曰。色若先有。则不须因。何以故。以其有故。如彼瓶衣。色若先无。即是未有。如彼余物。义意如是。复次执无因者。谓因无体。是义不然。如偈曰

  无因而有色　　是义则不然

释曰。于世谛中。色无因者。义亦不尔。复次毗婆沙师言。未来色有者。同前偈答。复次于世谛中因未取果。色则无体。而言有者。是义不然。以是因故。于一切时。执有四大及造色者。与义相违。如偈曰

  是故于色境　　不应生分别

释曰。云何分别。谓有实色。或因不异。及果不异地等色因如是色等形相差别。于此境界。不应分别。以不免前所说过故。欲得真实无分别智。聪慧眼者应善谛观。如梦所见觉则不然。彼智亦尔。复有人言。先因功能次第相续后果起时。彼因功力相亦可见。如紫矿汁染白叠子。以熏习故次第相续。至后果时彼色可得。为遮此执。故如偈曰

  若果似因者　　此义则不然

释曰。此验彼非果因。语义如是。何以故。第一义中。不欲令彼青等色经为青等叠因以相似故。如余青叠等。僧佉人言。汝说彼余青叠因亦无者不然。何以故。汝立譬喻以无体故。论者言。汝不善说。彼叠起时。此因非分。以不成彼叠故。如是譬喻得成。复次自部人言。有相似因果。不相似因果。彼前后刹那。世虽有异。于物类中。如风灯焰。刹那起灭。此名相似因果。如烧木成灰。变乳为酪等。此名不相似因果。论者言。彼相似因果。如先已遮。不相似者。此如今破。偈曰

  若果不似因　　义亦不应尔

释曰。第一义中。验此谷子。不为芽因。何以故。不相似故。譬如碎瓦。或谓稻谷。是彼芽因。以谷有体。彼芽得有。可指示故。如大鼓声。及麦芽等。论者言。汝不善说。诸有起者。一切遮故。以譬喻无体能成不足。有此过故。若谓彼眼等根生识等果。此不相似。非一向故者。是亦不然。何以故。如破诸法。彼眼识等亦如是遮。更无异门故。非非一向过。如前所说有实地等彼果有故者。二皆不成。以违义故。复次毗婆沙者言。所作因有故。谓有为法起时。一切相似不相似法。为彼因故。譬喻无体。论者言。汝不善说。有简别故。彼自分生不共等所作因能起者已遮故。品初已来此诸文句已遮四大及彼因色。令他解知色阴无体。余受阴等者。如偈曰

  受阴及心阴　　想行一切种
  如是等诸法　　皆同色阴遮

释曰。如遮色阴。受等亦尔。已说第一义中色非实有。自因不取故。彼觉无体故。如军众等。如是第一义中受心想触。及作意等皆非实有。自因不取故。彼亦不取。如军众等。一切亦应如此类知。复次受等诸因所谓触也及色明虚空作意等如其所应。当如是遮。复次如色等诸因不别。已令他解如是第一义中受等诸因亦无别异。自和合支不可取故。彼不应取如自因自体此亦与过应如先说。若外人与过者。应如先避。复次如是等诸法者。谓彼阴外有为诸法所有分别如瓶衣等。实有故异故者。如其所应同彼色遮如色等阴摄故为因者。此因不成。譬亦无体。阴义坏故。彼阴摄者。世谛中摄非第一义。以违因义故。此诸道理应如是知。或复有人妄想分别第一义中随何等物自体不空及起灭等。此诸诤论义皆不然。何以故。如实谛观彼相空故。以第一义中诸入不起体非实有如是观察令人识知。若执不空与空作过者。此亦不然。何以故。同前遮故。一切不能与空作过。如偈曰

  若观一物体　　则见一切体
  如是一物空　　一切皆空故

释曰。自前文句遮诸入起。以阴无自性。晓示行人。品义如此。是故得成。如佛告极勇猛菩萨言。善男子。色无起灭故。受想行识亦无起灭。若彼五阴无起无灭。此是般若波罗蜜。善男子。色离色自性。如是受想行识离识自性。若色至识诸性离者。此是般若波罗蜜。善男子。色无自性故。受想行识亦无自性。若色至识无自性者。是为般若波罗蜜。又如胜思惟梵天所问经偈曰

  我为世间说诸阴　　彼阴为彼世间依
  能于彼阴不作依　　世间诸法得解脱
  世间如彼虚空相　　彼虚空相亦自无
  由如是解无所依　　世间八法不能染

又如金刚般若经中说。须菩提。菩萨不住色布施。不住声香味触法而行布施。又如楞伽经偈曰

  三有假施设　　物无自体故
  但于假设中　　妄想作分别
  以觉分别时　　自体不可得
  以无自体故　　彼言说亦无

如是等诸修多罗。此中应广说

释观五阴品竟

    般若灯论释观六界品第五

复次诸法无体。由空所对治故。今复欲明地等诸界无自性义。有此品起。此义云何。观阴中说。若离于色则无色因。此中自部复引佛语为证。如经言。佛告大王。界有六种。地水火风及空识等彼各有相。谓坚湿暖动容受了别。此六种界说名丈夫。如无空花施设为有取名丈夫者。此义不然。是故论者先所立义地等色因体非有者。彼所立义则为破坏。亦与阿含相违故。论者言。为世谛故。如来说此地等六界以为丈夫。非第一义。复次毗婆沙师言。第一义中有地等界。何以故。彼相有故。此地等界若实无者。如来不应说有彼相。如虚空花。今有坚等为地等相。以相有故。地等非无。论者言。虚空无自体少功用生他解彼无物故。解空界已。自余诸界即易可遮。如偈曰

  先虚空无有　　毫末虚空相

释曰。虚空与彼无障碍相此二无别偈意如是。复次毗婆沙师言。我立此义。无障碍者。是虚空相。彼相有故。论者言。此无障碍立为有者。他不能解。此义云何。如无常声是其立义。以无常故将为出因。如是有此虚空。以虚空有故。此则唯有立义。无因及喻义则不成。若汝意谓无障碍相为虚空者。于世谛中随人悉解不须说彼令他解因者。以于第一义中此不成故。决须说彼令他解因。彼若说者。则有因及譬喻过失。以唯有立义故。复次毗婆沙师言。实有虚空。是无为法。为答彼故。如偈曰

  此中验虚空　　无毫厘实体

释曰。第一义中虚空无实。何以故。以无生故。譬如兔角。如是因无体故。无果故。无有故等诸因。应如是广说。复次鞞世师言。所相能相二法异故。论者言。若尔彼等则有先后。如瓶衣等。为答彼故。如偈曰

  若先有虚空　　空则是无相

释曰。虚空无相。偈意如是。此中说验。虚空非彼相之所相。何以故。先已有故。如随一物。复次无障碍者。非虚空相。何以故。以彼异故。如随一物。复次若谓所相能相无相者。是亦不然。何以故。异分别者。我亦舍故。复次若汝言世谛说因非因不成者违义过失汝不能避。是故别不别相二皆不成故。知虚空定是无相。若言无相有体者。人不能知。为是故如偈曰

  无处有一物　　无相而有体

释曰。第一义中若自分若他分此体成者。义则不然。或有人言。所相虚空如是有体。于彼有能相转者。此亦不然。如偈曰

  无相体既无　　相于何处转

释曰。所依无体故。能依亦无体。义不成故。复是因过。复次所相能相若不异者。岂以所相还相所相彼异相无体故。以是义故。无异门中虚空无相。若异门说相者。彼亦非相。所相异故。譬如随一物等。如是相既无体。空亦无相故。偈言无有无相体者。谓虚空也。相于何处转者。以不于彼转故。此义应知。复次偈曰

  无相相不转　　有相相不转

释曰。如汝所说。能相所相义皆不然。何以故。无彼物体而有相者。此则不成。有体亦尔。偈曰

  离有相无相　　异处亦不转

释曰。第一义中有一物体相于中转。此皆不然。何以故。以譬喻无体。外人所欲义不成故。复次如虚空花等。以无相故。彼相亦尔。以无体故。不可说转世间悉解。是故偈言有相相不转。以第一义中如实验。彼无障碍者。非虚空相。何以故。以相故如坚等相。复次有人言。有相无相物相于中转。此无过咎。为遮彼故。如偈言离有相无相。异处亦不转。此二俱不然。彼定观者然可然品后当广遮先令他解二分过者。今还属汝此不相应。以有二过故。复次有人言。第一义中虚空是有。以彼相故。此若无者。不说彼相。如虚空花。如经言。佛告大王。此六种界名为丈夫。是故彼有及为相故。论者言。所相不成。我先已破。如偈曰

  所相不成故　　能相亦不成

释曰。能相亦堕所相中故。相亦不成。譬喻无体。为是义故。以慧谛观所相能相二皆不立。如偈曰

  是故无所相　　亦无有能相

释曰。彼令他解。无体可验故。以是验知。彼实无体。此义得成。复次毗婆沙师言。如我立义。虚空有体。何以故。彼为境界欲染断故。譬如色。又三摩钵提所缘故。譬如识。亦无为故。譬如涅槃。论者言。汝若欲令第一义中有此虚空者。为是所相。为是能相。二皆不然。如先已说。令人得解。是故偈曰

  离所相能相　　是体亦不有

释曰。自部义如是。余涅槃等随一物体能成。譬喻皆不成故。复次别部人言。虚空是有。领受自体故。亦有为故。此义及因二皆不成。如前验过。应如是说。复次经部人言。如我立义。实碍无处说为虚空。虚空无体。唯是假名。我义如此。论者言。如毗婆沙师所说。三摩钵提所缘故。彼为境界欲染断故。立空有体。欲令人解。今经部执言。实碍无处说为虚空。唯是假名。遮前有体。如是计者。令我譬喻转更明显。今说此义。如偈曰

  离色因有色　　是义则不然
  色本无体故　　无体云何成

释曰。如先观阴品说。第一义中有碍名色者。无此道理。如经部分别虚空无体验令解者。此义不成。有人言。虚空有体。不令人解。无譬喻者。我今立义。令人易解。应如是说。色等有体。观彼无体有故。此若是有。观彼体无。譬如色味二无体故。法若无体。无则不观。譬如马角。论者言。色法有体。我先已遮。不欲令汝受彼无体。如偈曰

  无有体

释曰。色名。偈曰

  何处

释曰。味故。偈曰

  无体当可得

释曰。彼色无故。譬喻无体。所欲义坏。应知。外人言。有体无体二皆是有彼解者有故。若解者有彼物则有。论者言。汝谓解者解体无体。此之解者为是有体为是无体。俱亦已遮解者有体此义不成。又与有体无体不相似故。异此之外分别解者。此义不然。如偈曰

  与体无体异　　何处有解者

释曰。解者无体。偈义如是。外人复言。我有异门作此分别如是解者。与彼有体无体不相似故。论者言。彼不相似体是一物有二分者。是义不然。以相违故。观亦不立。彼无可验令人信知。如是虚空谛观察时不应道理。如偈曰

  是故知虚空　　非体非无体
  非所相能相　　余五同虚空

释曰。如遮虚空无有毫末令人信受。余五亦然。如偈曰

  先地等无有　　微毫相可得

释曰。彼地水等亦应如是广分别说。乃至偈言非体非无体非所相能相应当同作如虚空遮。云何名界。藏义是界义。如彼金界。彼虚空等能为忧苦等藏义故。复次无功用自相持义是界义。说彼界者。为教化众生怜愍故。说彼佛语者。世谛所摄。第一义中界无体也。入亦不成。以界有故。所欲不破。复有人言。若第一义中一切句义皆拨无者。此是路伽耶陀法邪见所说。与佛语相似。此应弃舍。以非佛语故。论者言。汝起过增翳不真发毛蚊蚋蝇等妄作遮故。是义云何。我说遮入有者。遮有自体。不说无体。如楞伽经中偈曰

  有无俱是边　　乃至心所行
  彼心行灭已　　名为正心灭

释曰。如是不著有体。不着无体。若法无体。则无一可作故。又如偈曰

  遮有言非有　　不取非有故
  如遮青非青　　不欲说为白

释曰。此二种见名为不善。是故有智慧者。欲息戏论得无余乐者。应须遮此二种恶见。此复云何。若三界所摄。若出世间。若善不善及无记等。如世谛种诸所营作。彼于第一义中。若有自体者。起勤方便作善不善此诸作业应空无果。何以故。以先有故。譬如先有。若瓶衣等如是乐者常乐。苦者常苦。如壁上彩画形量威仪相貌不变。一切众生亦应如是。复次若无自体者。彼三界所摄。若出世间善不善法起勤方便则空无果以无有故。如是世间则堕断灭。譬如磨莹兔角。令其铦利终不可得。是故偈曰

  少慧见诸法　　若有若无等
  彼人则不见　　灭见第一义

复次如宝聚经中。佛告迦叶。有者是一边。无者是一边。如是等。彼内地界及外地界皆无二义。诸佛如来实慧证知得成正觉无二一相。所谓无相。又如上金光明女经。文殊师利问善女人言。姊云何观界。女人答言。文殊师利如劫烧时世界空虚无一可见。又如偈曰

  世间如空相　　虚空亦无相
  若能如是知　　于世得解脱

如是等诸修多罗此中应广说

释观六界品竟

般若灯论释卷第四般若灯论释卷第五

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观染染者品第六

复次一切法空。何以故。彼染染者。嗔嗔者等。本无自性。欲使了知无自性义。有此品起。有人言。第一义中有阴入界。何以故。婆伽婆说彼为染污过恶因故。若此非有。佛则不说彼为染因。譬如龟毛。云何验知。经中偈曰

  染者不知法　　染者不见法
  若人安受此　　名为极盲暗

释曰。如染染者。乃至痴等盲暗亦然。是故当知。有彼阴等。论者言。彼阴等行聚增长染因过恶显现。如是染者及彼染等。于世谛中如幻焰梦乾闼婆城。非第一义。如是谛观汝此分别为欲染。先有染者为染者。先有染为染及染者。此二俱时三皆不然。如偈曰

  若先有染者　　离染染者成

释曰。染是爱着异名。若染者离染彼名染者。此则不然。何以故。如熟无果。云何名熟。如偈曰

  因染得染者　　染者染不然

释曰。若各别异此是染法。此是染者。是则离染。亦名染者。又染者起染终无得义。云何验知。非无染体得名染者。以有观故如染自体。复次阿毗昙人言。如我偈曰。染污名遍因自地中先起。是故染者得为染因。阿毗达磨相义如是。论者偈曰

  染者先有故　　何处复起染

释曰。如无染人后时起染乃名染者。若彼染者。先已得名说此染者复起于染无如此义验无体故。义意如是。复次犹如调达相续中染彼调达染者不作证因。何以故。以染者故譬如耶若达多。外人言。别不别相续染非因故染者门作成已复成过。亦譬喻无体。及违义故。论者言。彼说不善不别相续染非因故。染者门作非成已复成过。彼别相续染及染者亦应同遮。亦非譬喻无体所成相似及遮异门非违义故。外人言。有所作因。谓他相续染者。亦为染因故。譬喻无体。论者言。此不相应遮不共因故。此过非实。复次若汝定谓染者之先有染法者。是亦不然。如偈曰

  若有若无染　　染者亦同过
  染者先有染　　离染者染成

释曰。此复云何。若染者先有彼染法。此则有过。谓此是染此是染者。故有所染。故名之为染。非所依。先有。譬如饭熟故。若汝欲得不观染者。而有染法。此亦不然。如偈曰

  离染者染成　　不欲得如是

释曰。如熟不观熟物起故此云何验非染者无体而有染法。何以故。以有观故。如染者自体。外人言。如父子二体。非一向故。此义得成。论者言。彼亦如是遮故无过。外人言。如先刹那起染已离而为当起染刹那因是故无过。论者偈曰

  有染复染者　　何处当可得

释曰。如是别时起染刹那无间次生染者刹那此不可得。以染者不成故。如彼异熟是异熟。是异熟者。事则不然。如是过去起染刹那。立为现在染者之因。义亦不尔。云何不尔。如调达染不为调达染者之因。何以故。以其染故。譬如别相续染。复次鞞婆沙师言。我所立义无如上过。所以者何。彼染及染者同时起故无咎。论者言。此亦有过。汝今当听。如偈曰

  染及染者二　　同时起不然
  如是染染者　　则不相观故

释曰。何因缘故起此分别。以观无故而可分别。此是染者。彼为染法此是染法。彼为染者而不欲尔。此复云何。欲有观故。此中立验。彼染与染者无同起义。何以故。以有观故。譬如子芽。复次鞞婆沙师言。汝出此因。有何等义。为观生故。名为有观。为观别语名为有观。若观生故名有观者。心心数法此恒相随。亦同时起。共有因故。又如灯炷光明亦同时起。非一向故。若观别语名有观者。如牛二角亦同时起。一左一右。有别语故。现见如此亦非一向。论者言。是心心数及灯光等和合自在同时共起彼二牛角观别语等。于世谛中欲令如此。第一义中皆不成故。汝所说过。我无此咎。复次染及染者。若一若异。同时分别。二皆不然。如偈曰

  染及染者一　　一则无同时

释曰。若言同时。即有二体。偈意如是。此中立验。染及染者。不同时起。何以故。以一体故。如染者自体。若汝意欲染及染者。一体同时义则不可。以相违故。我今染与染者。别体同时。无如上过者。此亦不然。如偈曰

  染及染者异　　同时亦叵得

释曰。别体同时。无有此义。以验破故。复次彼立别体而欲同时令他解者。验无体故。此中立验。染染者二不得同时。何以故。以有观故。如染自体。复次今当更破别体同时。如偈曰

  若别同时者　　离伴亦应同

释曰。若汝意谓染及染者。此二同时而不欲令随一离伴者。此中立验。第一义中不欲令彼染及染者别体同时以有观故。如因果二。复次余论师言。若汝别体欲得同时今处处别体彼彼同时。如马边有牛说为同时。如是独牛无伴。亦得同时。此如先答。义无少异。复次偈曰

  若别同时起　　何用染染者

释曰。染及染者。若同时起。是义不然。以其别故。譬如染及离染。复次偈曰

  若染染者二　　各各自体成
  何义强分别　　此二同时起

释曰。若染及染者。我体各别。以体别故。则不相观。复次若有所用此是染者染。此是染染者。有观相貌说同时起。汝意尔耶。此说有过。何以故。如偈言。染及染者二。同时起不然。如是等同时起不应尔。有观故。不即此法说同时起。以不异故若欲别体。同时起者。此亦不然。如偈曰

  如是别不成　　求欲同时起
  成立同时起　　复欲别体耶

释曰。如是义者。长老应说。如偈曰

  有何等别体　　欲同时起耶

释曰。同时起者。有何等义。为有别体。次第起故说同时起。为无别体同时起耶。若言次第同时起者。是则不然。如染及离染。先已说过。若同时起者。此亦不然。以有观故。如因果二。亦先已说。是故偈曰

  由染染者二　　同不同不成
  诸法亦如染　　同不同不成

释曰。彼嗔痴等。若内若外。同以不同亦皆不成。如是第一义中彼染等不成故。如外人品初作如是。说阴等是有。以染污过患故者。彼因不成。又世谛说因及违义故。如先所说因过失故。品内所明染及染者无其自体。令他得解。此义得成。如般若波罗蜜经。佛告极勇猛菩萨言。善男子。色非染体。非离染体。如是受想行识非染体。非离染体。复次色受想行识非染体空。非离染体空。此是般若波罗蜜如是。色非嗔体。非非嗔体。亦非痴体。非非痴体。受想行识亦复如是。此名般若波罗蜜。极勇猛色非染非净。受想行识非染非净。复次色非染法性。非净法性。受想行识亦复如是。此名般若波罗蜜。如是等诸修多罗。此中应广说

释观染染者品竟

    般若灯论释观有为相品第七

复次成立此品。其相云何。阴等诸法本无自性。惑者未知取相分别。今欲显示令彼识知无自性义。有此品起。外人言。第一义中有是阴等有为自体。何以故。以彼起等诸有为相共相扶故。此若无者。彼有为相无相扶义。譬如兔角。由起等诸相与阴等相扶因有力故。彼法不无。所谓有为诸阴等也。论者言。汝说起等有为相者。彼起等相为是有为。为是无为。外人言。是有为也。论者言。今当次第分别此义。先验起者。如偈曰

  若起是有为　　亦应有三相

释曰。第一义中不欲令彼起等诸相是有为相。何以故。以有为故。譬如法体。外人言。起住灭体各有作用。是故欲令起等诸相是有为相。论者言。此验无体。唯有立义。故外人言。起住灭等各有功能。汝拨无者。义则不然。论者言。起等作相不可得故。又世谛中起亦非彼有为法相。何以故。以起作故。如父生子。住亦非彼有为法相。何以故。以住作故。如食持身。又有为相非彼住作。何以故。以住作故。譬如女人。置瓶于地。灭亦非彼有为法相。何以故。以破坏故。如棒破物。如是彼立起等有为相者。此义不成。以因不成及与义相违有此过故。起非有为。是故说起有为相者。义则不然。复次若汝欲避先所说过成立起等是无为者义亦不然。如偈曰

  若起是无为　　何名有为相

释曰。若起是无为。而为有为相者。无如此义。以无为自体无所有故。义意如此。复次第一义中起是无为。而作有为诸法相者。是义不然。何以故。以无为故。譬如虚空。住灭亦尔。不复广遮。复次若汝分别起住灭等是有为相有所作者。为是次第。为复同时。二俱有过。何以故。若次第者。如偈曰

  起等三次第　　无力作业相

释曰。于谁无力。谓于有为。复次欲得起等随次第者。如法体未起。住灭二种。则无力为相。以法体无故。又已灭之法灭则无体。起住二种。则于灭无力。又已起之法起则无力。又法体若住灭复无力。若谓住时无常随逐者。是义不然。如百论偈曰

  离住无法体　　无常何有住
  若初有住者　　后时不应故
  若常有无常　　一切时无住
  若先是常者　　复不得无常
  若无常与住　　共法体同时
  有住无无常　　有无常无住

复次若谓起等诸有为相同时有者。是亦不然。如偈曰

  云何于一物　　同时有三相

释曰。此相如是不同时有。语义如此。云何不有。谓彼一物于一时中有起住灭。义则不然。以毕竟相违故。复次经部师言。诸法各别有定因缘自在相续。于一时中当可起者。得自体时此名为起。初刹那相续位此名为住。先刹那不相似此名为老。已起者坏此名为灭。如是等决定有观于一刹那同时有故。汝作方便与我作过者。我无此咎。论者言。是相续者。亦非实有。又有观故。住分别者。是世谛三相。非第一义。汝言住时违住灭者。此不应然。以不免先所说过故。复次鞞婆沙师言。如先体未起者。于后得自体时。此名为起。起者树立。此名为住。住者朽故。此名为老。老者灭故。此名为坏。由起等次第得不离有为体。以是义故。彼相体成。如先所说。起等三次第无力作业相者。此为不善。论者言。汝语非也。云何名相。谓与所相未曾相离。譬如坚相不离于地。及大人诸相不离大人。若言起等第一义中是彼有为诸法相者。此义不然。何以故。有次第故。次第云何。如以泥团置于轮上。运手旋已如小塔形。次拍令平。次转如盖。后拢如圌。此诸位别。非彼瓶家有为体相。起等诸相亦不离彼。有为法者。假施设耳。真实起者。此中遮故。以云何遮。彼未起者。住灭无体故。若谓当来起时应有住灭。作此分别者。唯世谛言说不免。如先所说。过咎如是。起等诸有为相次第同时彼体不成。因有过故。复次偈曰

  若诸起住坏　　有异有为相
  有则为无穷

释曰。若彼有异彼亦有异者。如是则无穷而不欲尔。复次若起等诸相更无相者。复得如先所说过失。如偈曰

  无则非有为

释曰。此义云何。如汝意欲有为诸法非有为相。以有为故。如是起等。亦非有为相。以是义故。第一义中不应分别起等诸相。若是有为。若是无为。如所说过。今还属汝。复次犊子部言。起是有为而非无穷。云何知耶。由此自体和合有十五法。总共起故何等十五。一此法体。二谓彼起。三住异。四灭相。五若是白法则有正解脱起。六若是黑法则有邪解脱起。七若是出离法则出离体起。八若非出离法则有非出离体起。此前七种是法体眷属。七眷属中皆有一随眷属。谓有起起乃至非出离。非出离体此是眷属。眷属法如是。法体和合总有十五法。起。彼根本起。除其自体能起作十四法。起起。能起。彼根本起。住等亦然。以是义故无无穷过。如我偈曰

  彼起起起时　　独起根本根
  根本起起时　　还起于起起

阿阇梨言。汝虽种种多语。而于义不然。云何不然。如偈曰

  若谓起起时　　能起根本起
  汝从本起生　　何能起本起

释曰。不如是生。以未起故。如前都未起时。外人言。根本起者。能起起起。如是起起能起本起。义正如此。论者偈曰

  若谓根本起　　能起彼起起
  彼从起起生　　何能起起起

释曰。不如是生。以未起故。义意如是。外人言。彼根本起及以起起。此二起时。各自作业。是故无过。论者偈曰

  汝谓此起时　　随所欲作起
  若此起未生　　未生何能起

释曰。第一句谓根本起。第二句谓起起。第三句谓起时未起。第四句谓根本起无起功能。何以故。以未生故。亦起时故。譬如前未生时。又如当起法体。外人言。如共有因于法起时。及已起者。共起诸法有起功能故。非谓一向汝言起时故。因及未生故。因者此义不成。论者言。前染染者。中已遮。共起亦遮。彼因汝言非一向者说我有过。又言。无有无穷过者。此不能避。复有人言。有别道理。避无穷过。道理云何。如偈曰

  如灯照自体　　亦能照于他
  起法亦复然　　自起亦起彼

释曰。以是义故。无无穷过。论者偈曰

  灯中自无暗　　住处亦无暗
  彼灯何所照　　而言照自他

释曰。如是灯无毫末照用。因语意尔。复次此中立验灯体。于彼第一义中不能自照。亦不照他。何以故。以暗无故。譬如猛炽日光。复次第一义中灯不破暗。何以故。以其大故。譬如彼地。以是义故。譬喻无体。外人言。灯初起时即能破暗。如偈言。如灯能破暗。谓自体作明能除外暗。义意如是。如先所说暗无故者。此因不成。亦譬喻无体。以灯及光义可得故。论者偈曰

  云何灯起时　　而能破于暗

释曰。云何破者。谓不能破故。语义如是。偈曰

  此灯初起时　　不到彼暗故

释曰。以起时故。譬如暗灯。外人言。智非智等。非一向故。论者言。汝执此义堕前成立分中摄故。如是亦遮。非非一向也。复次起时未生故。如未生子无所作业。灯亦如是。不能作明。复次如前偈说。云何灯起时而能破于暗。此灯初起时不到彼暗故者此中立验。第一义中彼灯起时不能破暗。何以故。以不到故。譬如无明世界中间黑暗。复次第一义中灯不破暗。何以故。以不得所对治故。譬如彼暗。外人言。现见灯不到暗而能作明故。论者言。汝立此门增我破力。令我譬喻转更明显。故我无过。彼若如是今当观察。为如所见。为复异耶。我亦不见灯不到暗而能除暗。若灯不到暗而能除暗者。是义不然。如偈曰

  若灯不到暗　　而破彼暗者
  灯住于此中　　应破一切暗

释曰。灯破远暗。汝既不许。近亦如是。云何能破。复次如偈曰

  若灯能自照　　亦能照他者
  暗亦应如是　　自障亦障他

释曰。暗自他二不欲尔者。灯自他二岂欲得耶。复次此中立验。第一义中灯于自他不坏所治。何以故。有能治故。譬如彼闇。如是灯体。自照照他。先已遮故。譬喻无体。是故外人引彼灯喻。成立起义。能起自他者。是则不然。以不免前无穷过故。复次若谓自起亦起他者。云何能起。为已起起。为未起起。若尔有何过。若未起起者。如偈曰

  此起若未起　　云何生自他

释曰。未起无生。以未生故。如前未生时。如是意者。先已分别。复次偈曰

  此起若已起　　起复何所起

释曰。由已起故。生于彼起。则无功用。如是观察。汝言起者。能起自他义则不尔。以不免前无穷过故。又彼起等成其无为。以无为故。彼诸起等非有为相。汝言相故者。因义不成。又复当问。说有起者。云何起耶。为起时起。为已起起。是皆不然。如偈曰

  起时及已起　　未起皆无起
  去未去去时　　于彼已解释

释曰。如彼已验。此中亦应如是广说。以第一义中起时不起。何以故。异世向前故。如欲灭时。复次若谓彼法少起少未起说为起时者。是亦不然。何以故。若少起者。彼更不起。起无用故。若未起者。起亦不起。以未起故。譬如未来。外人言决定起者。来向现在。此名起时。论者言。如是义者。亦应观察。如偈曰

  由起时名起　　此义则不然
  云何彼起时　　而说为缘起

释曰。彼起时者。为有为无为。亦有亦无。此等过失。如上已遮。外人言。譬如有人善解剑术。起不善心行恶逆行。自害其母以为随顺。汝亦如是。何以故。大仙为彼声闻独觉说深缘起。以汝久习妄想行非法行。自破所欲害正道理。此执不然。论者言。汝不知耶。有恶见人拨无因果。破坏白法不肯信受。为欲教化彼恶见人。洗濯不善垢秽义故。佛婆伽婆作如此说此有故彼有。此生故彼生。所谓无明缘行。诸如是等。为世谛故。非第一义。如是意者。是我所欲。汝言自破所欲害正理者。此语不然。如偈曰

  由诸法无性　　自体非有故
  此有彼得者　　如是则不然

复次如佛说偈。若从缘生则不生。彼缘起者。体非有。若属因缘此则空。解空者名不放逸。如是等诸经此中应广说。由如是观。若生未生。悉皆如幻。是故起时寂灭则无起相。如彼外人所说起时以为缘起者。第一义中验不成故。彼为不善。复有人言。世间现见种种因缘各各果起。谓瓶衣等。更无异验。胜现见者。如前偈说。起时及已起未起皆无起者。此不相应。以戒等起故。论者言。彼戒等聚随顺功德。谁能违者。而是世谛非第一义。彼如是等。为舍执着。为实义故。有此论起。是故无过。若汝意谓瓶衣有起者。亦是世谛非第一义。我所欲者。若瓶若衣现起可得。非彼未起。若已起者。有起不然。瓶衣等起。未起起故。如此执者。是义不然。何以故。若瓶未起安立妄觉。缘彼瓶名谓有瓶起。如是意者此但世谛安置妄觉。以瓶未生不可得故。复次鞞婆沙师言。三世有故。彼瓶等起。我义如此。论者言。此亦不然。如偈曰

  随处若一物　　未起而有体

释曰。一物者。或瓶衣等。若于诸缘。若和合中。及于余处。体先有者。偈曰

  已有何须起

释曰。彼若已有起。则无用故。为是因缘。偈曰

  体有起无故

释曰。以此义故。先起有体者验起。则无有体起者立义有过。复次执时异者。说如是言。诸法有体。云何验知。来现世故此执不然。何以故。若来现在则破现在。如是体异相异及位异者。如先过失。皆以此答。复次僧佉人言。诸法体有。可显了故。我无过失。论者言可显了者。先已遮故。此不相应。复次未起有体。云何可信。僧佉复言。以世摄故。如现在物。论者言现在物者。第一义中无自体故。汝譬不成。所欲义坏。复次虽无自体亦不坏世谛。以现在时色等诸法。犹如幻等。亦可得故。彼世谛中色等诸法但假施设。应如是知。偈言起时及已起未起皆无起。如是等。先虽已答。今当更说。如偈曰

  若谓起起时　　此起有所起

释曰。彼意若谓起于起时能有所起。此执不然。有过失故。如偈曰

  彼起能起作　　何等复起是

释曰。彼起不然。以起作故。譬如父子起无自体。偈义如是。复次若如是说。更有异起能起。此起是亦有过。得何等过。偈曰

  若起更有起　　此起无穷过

外人言。不起起故。无无穷过。我欲如是。论者偈曰

  若起无起起　　法皆如是起

释曰。法既不尔。起亦应然。是故不应强作分别。复次此有起者。若有体若无体。若有无体。起悉有过。如偈曰

  有体起无用　　无体起无依
  有无体亦然　　此义先已说

释曰。何处先说。如观缘品中偈说。非有亦非无。诸缘义应尔。又如偈言。非有非不有。非有无法起。如先已遮。不复更释。复次如偈曰

  若灭时有起　　此义则不然

释曰。以灭时故。譬如死时。外人言。未灭时起。是故无过。论者偈曰

  法若无灭时　　彼体不可得

释曰。以彼体相不相应故。如虚空花。偈意如是。外人言。住非一向故。论者言。彼亦无常随故。未灭时不成。我无过咎。如前广说。外人言。有如是起。彼所起法有故。此若无者。彼所起法则不得有。如用龟毛为衣。二皆无体以起成故。住法则有。是故如所说。因起非无体。论者言。起无体故所起不成。虽世谛中说有此起。第一义中则无住相。今问此体。为未住体住。为已住体住。为住时体住。第一义中。三皆不然。如偈曰

  未住体不住　　住体亦不住
  住时亦不住　　无起谁当住

释曰。第一句者。由非住故。譬如灭。第二句者。以现在世及过去世二世一时不可得故。住义则空。第三句者。离住未住更无住时。有者不然。广如前破。第四句者。无一物起无一物住。偈意如是。复次第一义中无一物体起相可得。从前已来广引道理。令人解了起既不成。谁为住者。由此义故。汝先说言所起之法起有因者。此皆不成。复次如偈曰

  灭时有住者　　是义则不然

释曰。以相违故。若相违法。则不同时。如烈日光。不与暗并。偈意如是。外人言。彼未灭时。体可得故。论者偈曰

  若法无灭时　　彼体不可得

释曰。以诸有为法无常随逐故。复次彼体不可得。何以故。无灭时故。如虚空花。偈意如是。复次若汝意谓已起刹那住相有力。当于尔时法体不灭。亦不是常。以住无间次即有老无常随逐故。此执不然。何以故。若此色等住相用时无无常者。后时亦无。无常随逐。如火处无水。火于后时亦不作水。住义亦然。外人言。世间现见法体灭尽。云何言无。论者言此应观察。汝见灭者。是灭与体。为恒相随。为各别处。若与相随即无住义。若在别处。体无灭时。既无灭时。体不可得。二俱不然。复次有聪慢者。或如是言。譬如有人先无佛体后时得佛。住亦如是。先虽无灭后时灭者。竟有何咎。此执不然。何以故。无佛体者。谓无一切智相用。凡夫智后时得佛者。无如此义。于世谛中此方便语。亦不成立。如是断烦恼障及彼境障。最后刹那智相起时。说名得佛。彼智与佛体无差别。如汝所言。无实道理。如是老住。若一若异者。亦同此过。由此不成故。阿阇梨偈曰

  彼一切诸法　　恒时有老死
  何等是住法　　而无老死相

释曰。若有起者。随是体处。有住可见。起可得成。今则不尔。是故彼立因义不成。复次汝等欲得彼住住者。为住能自住。为假异住住。二俱不然。如偈曰

  住异住未住　　此义则不然
  如起不自起　　亦不从他起

释曰。云何起者。自起不然。如前说偈。此起若未起。云何得自生。若已起能生。生复何所起故。云何不从他生。如先偈言。若起更有起。此起无穷过故。住亦如此。偈曰

  此住若未住　　自体云何住
  此住若已住　　住已何须住
  住若异住住　　此住则无穷
  住若无住住　　法皆如是住

释曰。此二偈是释义偈。非论本偈。前遮自住住。如遮自体起。后遮他住住。如遮从他起。应如此知。是故当知。住无自体。如汝先说。有如是起。彼有体故。法有体者。此因不成。外人言。第一义中有此起住。何以故。共行诸法彼体有故。此若无者。彼共行法体应不有。譬如马角由起住有故。彼共行灭有。是故第一义中说因力故。起住是有。论者言。灭亦如是。谓此体已灭未灭灭时。欲令有灭者。一切不然。如偈曰

  未灭法不灭　　已灭法不灭
  灭时亦不灭　　无生何等灭

释曰。第一句者。以灭空故。譬如住。第二句者。如人已死。不复更死。第三句者。离彼已灭及未灭。法更无灭时。有俱过故。是故定知灭时不灭。复次第一义中灭时不灭。以世传流故。如当起法来现在者。第四句者。其义云何。一切诸法皆不生故。言无生者。生相无故。无生有灭。义则不然。如石女儿。如是彼欲起者及不起者。于一切时有灭不然。复次法住无住彼分别灭。二俱不然。如偈曰

  法体若住者　　灭相不可得

释曰。以住故无灭世间悉解。若汝言无住有灭无过失者。是亦不然。如偈曰

  法体若无住　　灭亦不可得

释曰。以无住故如彼灭相。复次此法为当即住此位灭耶。为住异位灭耶。外人言。此言何谓。论者偈曰

  彼于此位时　　不即此位灭
  彼于异位时　　亦非异位灭

释曰。不即此位灭者。以不舍自体故。譬如乳住乳位亦不于彼异位时灭。何以故。此中说验。第一义中乳不于彼酪位时灭。以彼异故。如异瓶等。复有人言。有如是灭。依止体故。譬如彼熟。论者偈曰

  若一切诸法　　起相不可得
  以无起相故　　有灭亦不然

释曰。诸法不起如前已说。未熟已熟此执不成。譬喻无体。复次汝言灭者为有体灭耶。为无体灭耶。二俱不然。如偈曰

  法若有体者　　有则无灭相

释曰。以相违故。譬如水火。由如是故。偈曰

  一法有有无　　于义不应尔

复次偈曰

  法若无体者　　有灭亦不然
  如无第二头　　不可言其断

释曰。偈譬喻者。以其无故。以此无体验有灭者。是义不然。法体坏故。复次汝等若言第一义中有彼灭相及随灭者。为是自灭。为是他灭。二俱不然。如偈曰

  法不自体灭　　他体亦不灭
  如自体不起　　他体亦不起

释曰。自体起者。此不相应。如前已说。此起若未起。云何能自生。此起若已生。生复何所起。他体起者。如偈言。此起若异起。起则无穷过故。起既如此。灭亦类然。灭类偈者。此灭若未灭。云何能自灭。此灭若已坏。灭复何所坏。此灭若异灭。灭则无穷过。灭若无灭。灭法皆如是坏。此释义偈应知。如自他起前已广遮。自他灭者。类同起破。有人言。得坏因时坏法方坏者。应如是答汝立坏因。是义不然。何以故。彼法非是。此法坏因。以彼异故。譬如余物。品初已来。广遮彼说。如是起住。以第一义中起因不成。譬亦无体。若世谛中说因譬喻者。违汝义故。如前立验。已广分别道理自在故。如偈曰

  起住坏不成　　故无有有为

释曰。如外人所说。有彼阴等诸有为法。以有为相和合故者。彼为已破。复有人言。第一义中有彼牛等诸有为法。何以故。以角犎垂[古*頁]等相有故。此亦应遮。汝立此等有为相者。为更有相。为更无相。若更有相。此角犎等则非牛体有为相也。何以故。以有相故。譬如牛实。广如前破。若更无相者。以无相故。此等诸相自然不成。以能相无力故。所相亦无。又有相者。相无穷过。此等一切如先广遮。复有人言。第一义中有是有为。何以故。有待对故。此若无者。应无待对。如石女儿。以彼有为无为二法相待由此因故。第一义中有是有为。论者言。若有为法得成立者。除有为故。可说无为。彼有为法。如理谛观体不可得。是故偈曰

  有为不成故　　云何有无为

释曰。如兔角无生。于世谛中亦不作实解。应知此意。以是义故。因等无体。若尔云何分别有诸相等。为世谛故。如偈曰

  如梦亦如幻　　如乾闼婆城
  说有起住坏　　其相亦如是

释曰。诸仙知彼有为起等。能生觉因。开实知见。如彼智人所说起等。是我所欲。由无智者覆慧眼故。于无实境起增上慢。如梦中语说彼诸法起住灭等。此由染污熏习。各执异因分别三种。谓有实义。为示彼故。说梦幻等三种譬喻应知。有人言。起等是有。何以故。现前觉取故。譬如色。又作者有故。亦相续同取故。如是说者。此执不然。何以故。非一向故。为开示彼。如其数量说梦等譬喻应知。复次佛婆伽婆。见真实者为声闻乘对治惑障故。作如是说。色如聚沫受喻水泡。想同阳焰。行似芭蕉。识譬幻事。此意欲令知我我所本无自性。犹如光影。亦为大乘对治惑障及智障故。说有为法本无自体。如金刚般若经说。一切有为法。如星翳灯幻。露泡梦电云。应作如是观。欲令他解有为无体。是此品义。是故得成。如般若波罗蜜经中说。佛告极勇猛菩萨言。善男子。色非有为非无为。受想行识亦复如是。若色受想行识非有为非无为者。此是般若波罗蜜。又如楞伽经说。有为无为无自体相。但彼凡夫愚痴妄执分别有异。犹如石女梦见抱儿又如金刚般若经说。须菩提。凡所有相皆是虚妄。若见诸相非相。则见如来。如是等诸修多罗此中应广说

释观有为相品竟

般若灯论释卷第五般若灯论释卷第六

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观作者业品第八

复次空所对治。欲令验知阴无体义。有此品起。有人言。第一义中有阴入界。婆伽婆说。以此为因。起作者作业故。此若无者。佛不应说与彼为因有作者及业。譬如马角。由有作者及作业故。修多罗中说是偈曰

  应行善法行　　恶法不应行
  此世及后生　　行者得安乐

释曰。如此经中说有作者及以作业。彼业有三种。善不善无记。彼善业者。分别有四。一自性。二相应。三发起。四第一义。不善亦尔。无记四种。谓报生。威仪。工巧。变化。是故如所说因有势力故。第一义中阴等是有。论者言。若汝欲得第一义中以彼为因。知有作者及以作业。说此为因者。此义不成。若世谛中欲得尔者。则譬喻无体。如此无体。第一义中婆伽婆说。以彼为因有实作者及有作业。如此解者。于义不然。如其不然。应如是观。今此作者为有实无实。亦有无实。能作业耶。业亦如是。有实无实。亦有无实。为作者所作耶。此皆不然。如偈曰

  若有实作者　　不作有实业

释曰。若彼作有。则作者有实与作相应。业亦有实。由翻此义二皆无实。彼无实者亦不能作。如偈曰

  若无实作者　　不作无实业

释曰。所作名业。能作名者。此中先观立有实者。如偈曰

  有实者无作

释曰。若汝意欲不观作业有作者体。若定如此则无作业。作既无体。则作者不成。复次有实无作者。此言何谓。立喻验释有实作者。彼五取阴但假施设。又如外道所计。提婆达多名若善业。若不善业。复次第一义中调达相续不能作业。何以故。以作者故。譬如耶若达多。复次若有实作者。非假施设。如食糠外道我为作者。如彼意欲。此义不然。为彼执故。此中立验。第一义中彼调达我不能作业。何以故。以物故。譬如业。复次第一义中彼业亦非提婆达多相续我作。何以故。以业故。譬如余物。复次若彼外人作如是意。汝此立义有何所以。如提婆达多彼相续业为是他作耶。为当无作耶。二俱不然。何以故。若他作者。汝立义破。若无作者。则譬喻无体。论者言。彼执不然。何以故。耶若达多彼相续业。提婆达多我不作故。由如是义。立譬得成。彼如是说。不观作业有实作者虚妄分别。于义不然。以作者无体故。如偈曰

  业是无作者

释曰。业亦如是。不观作者自然而有。由无作者。作是业故。若彼分别业有实者。业即无作。有此过失。又作者及业互不相观。世无能信。是故彼二必相因待。应如是知。此中立验。第一义中提婆达多相续作者不作提婆达多定业。何以故。以有观故。譬如耶若达多。复次第一义中提婆达多相续作者不作调达定受报业。何以故。观作者故。譬如耶若达多相续作业。复次今更立义。遮前所说。如偈曰

  业及彼作者　　则堕于无因

释曰。此后半偈欲显业及作者堕无因过。此义云何。谓业离作者故。作者离业故。互不相待故堕无因。以无因义开示他者。一切世间所不能信。复次第一义中提婆达多相续不作提婆达多业因。何以故。以有观故。譬如耶若达多。复次第一义中调达相续不作调达定报业因。何以故。观作者故。譬如耶若达多相续作业。是故偈曰

  无因义不然　　无因无果故

释曰。云何名果。谓为各各决定因缘力起。故名为果。云何名因。谓近远和合同有所作。由此有故彼法得起。是名为因。如汝分别因则无因。果亦无果。观无体故。是义不然。应知此意。复次若不相观则无彼体。此执不然。无何等体。如偈曰

  作及彼作者　　作用具皆无

释曰。于世间中瓶衣等物亦有作者欲作彼业。若谓作者不观业。业不观作者。彼瓶衣等则不藉人工。善巧方便自然成就。又彼瓶等种种技因之所成就。彼胜分具。若不观者具等亦无如是一切斫者斫具及所斫物亦皆无体。又如偈曰

  法非法亦无　　作等无体故

释曰。何故无有法非法二。彼法非法作者作具所成就故。又彼作者作具了故。法与非法二亦无体。复次或有自部生如是心。诸行空故作者无体。彼作者空于我无咎。何以故。胜身口意自体能作。法与非法由如此义故我无咎。论者言。汝立因者。但有聚集饶益。于世谛中彼名作者。以观法非法故。若无作者则无所观业不成故。法等无体。汝不免过。以无相观道理故。道理云何。如偈曰

  若无法非法　　从生果亦无

释曰。彼二为因。从生为果。人天等善道为可爱。地狱等恶道为不可爱。彼身根受用皆无自体。复次于善道中彼修行者。受戒习禅。三摩钵底。八圣道支正见为首。离诸烦恼此义悉空。如是分别无实作者。无实作业。此诸过聚皆属于汝。难可疗治。知过失已应信作者及彼作业相观道理。以是义故所说无过。以因有故。无实作者。无实作业。此执不然。此不然义。如先已说。复次或有人言。我立异门如是作者。亦有非有彼所作业。亦有非有。由此异门无如上过。论者偈曰

  有无互相违　　一法处无二

释曰。于一物体一刹那中。有及非有互相违故。二不可得。云何相违法。若是有云何非有法。若非有云何言有。犹如一火冷暖同时。世所不信。若汝意谓有实体故名之为实。无所作故名为不实。一物一时观自在故。二义俱立无过失者。是义不然。何以故。彼二门者。前已遮故无过。相观道理如后当遮。外人言。如耶若达多。亦有作者。亦无作者。汝立譬喻无体验不能破。论者言。彼耶若达多自相续中无提婆达作者。作业分故。我意欲尔。非譬不成。是故无过。广如前说。如是等分别。依止第一义中作者及业建立不成。复次有人言。我有作者无彼作业。是故无过。论者偈曰

  有者不作无　　无者不作有

释曰。此谁不作。谓作者业。何故不作。偈曰

  此由著有过　　彼过如先说

释曰。如上所说实不实门。第一义中无实作者作不实业。亦无实作者能作实业。此二句立义有别因及譬喻。广如前说。复次偈曰

  作者实不实　　亦实亦不实
  不作三种业　　是过先已说
  作业实不实　　亦实亦不实
  非俱作者作　　过亦如先说

释曰。此诸过失如前广明。唯有立义为差别耳。由如是观。偈曰

  缘作者有业　　缘业有作者
  由此业义成　　不见异因故

释曰。于世谛中。作者作业更互相观。离此之外。更无异因能成业义。如是外人品。初已来说因立譬。义皆不成。及违义故。不免过失。复次或有人言。第一义中有阴入界。以彼取故。佛婆伽婆作如是说。为遮彼故。偈曰

  如业作者离　　应知取亦尔

释曰。如先已遮。作者缘业。业缘作者。如是取缘取者取者缘取。第一义中不可得故。此义云何。由作者业二俱离故。彼取取者亦如是离。复次此中分别第一义中无实调达取者实取。何以故。以观取故。譬如耶若达多。如是第一义中亦无无实取者取无实取。亦实不实取立义应知。复次第一义中无实可取为实提婆达多取观彼取者故。譬如耶若达多取。如是第一义中亦无不实取。为不实取者取。亦实不实取。为亦实不实取者取。立义差别。因及譬喻如先已说。如是不等分别亦应类遮。复次由业作者及取取者。第一义中以性离故。如偈曰

  及余一切法　　亦应如是观

释曰。何等余法。谓自他所解。若果若因。能依所依。能相所相。或总别等。如是诸法亦应观察。果缘于因。因缘于果。此义得成。是世俗法非第一义。何以故。或有人谓第一义中因果等法皆有自体。今欲拔彼执着箭故。少分开示。非第一义中。乳实作酪。何以故。以观果故。譬如经等。若言世间。悉见乳作于酪。汝说无者。即为破坏世间所见。此执不然。何以故。我立义言非第一义。故我无过。或有人言。第一义中乳不作酪。而世谛中作。由此义故。汝譬不成。立义亦坏。若言诸法不作自果者。譬亦不成。何以故。彼一切法各有定因果故。论者言。汝语不善。何以故。初分别者非我所受。次分别者譬喻亦成。何以故。以此经等非彼酪因。前立义中已简别故。非譬喻无体。复次僧佉人言。如我立义因中有果。因能起作无不作故。此若无者彼因则无。如龟毛衣是何等因。谓酪瓶等。是故有果。复次若无果者。是义不然。何以故。如乳中无酪。草中亦无彼求酪者。何故取乳而不取草。由彼取故。知因有果。又如乳中无酪。亦无三界。等是无者。何因缘故从乳因缘而生于酪。不生三界。由彼乳中不生三界。非一切物从一因起。是故定知因中有果。又若无者。何故决定如窑师见土堪作瓶者取以为瓶。非取一切。由此功能。能有起作。知因有果。若无果者。因亦无体。终无一物无果有因。而无此事。是故当知。因有体故。彼果亦有。论者言。如汝立因。无不作者。非立义法。以是果故因义不成。汝言无果有因义则不尔。由有此故彼得成者。此于世谛中成。非第一义。以第一义中因及譬喻二皆无体。若物彼处有者。彼物不于彼处起故。如因自体。由此法体二种差别。彼义不成。有过失故。如破初因。彼取乳等诸因亦应以此道理答遣。复次如毗婆沙师所执因中无果而因能起果者。此因无力。亦不能起作彼无体故。譬如兔角。又如犊子儿。执果有非有。皆不可说。而因能起作如此意者。于世谛中作者因成。第一义中若因若果。有及非有。皆不可得故。我无过。复次异僧佉人言。因中果体不可得者。由果细故。此执不然。何以故。因中无粗故。粗先无体后时可得者。即是因中无果。汝立义破。若汝意欲细者为粗。是亦不然。何以故。不见细者转为粗故。后时粗果与细相违。法体颠倒。立义过故。复次异僧佉人言。因作果者。是义不然。由了作故。应如是问。此了作者。其相云何。彼答如灯了作瓶等。此执已如观缘品破。复次第一义中灯不了作彼瓶衣等。何以故。以眼取故。有碍故。色故。触故。说故。因等譬如土块。复次异僧佉言。果若未起及已灭功能自体有不名为了。是故我说有如是果。而言因能作果者。此云何作。谓因自体转为果体。语意如此。论者言。若汝过去未来受为因者。依止不成。若谓现在受为因者。则无譬喻。彼果不成。有此等过。又汝因果不异。若不异者。则此非彼因。以不异故。如因自体。以非因故。因义不成。因不成故。法自性坏。立义过故。现在果者。亦无实体。以无起故。彼有不成。譬喻无体。如是诸不异门亦应随所执破。已说实因不能作果。于世谛中若无因者。亦不作果。以彼无故。如无龟毛不可为衣。如是若无果者因亦不作。此立义有异。因喻同前。彼半有半无执者。二俱过故。亦如先说。复次自部及鞞世师等言。因有果无。此因能作。以未起无果。我不受故。如虚空华。已生果者。因无力用。未生果者。因有功能。由如此义。因中无果。论者言。如汝立因未起无果我不受者。此意云何。汝为现见故不受耶。为立验故不受耶。为一切量不受耶。如是分别因义不成。立因有过。非一向故。彼未起果有故者。此验不能令他信解。汝言无果起者。此无果起。无譬喻故。云何可知。复次第一义中乳不生酪。何以故。以观因故。譬如绢起。复次泥实名求那假瓶名求泥。第一义中泥不成瓶。何以故。观求泥故。譬如余物。复次第一义中垂[古*頁]等相非牛体相。何以故。以观体故。譬如马相。复次别名阿婆也婆。总名阿婆也毗。第一义中无实经等成绢。何以故。以观阿婆也毗故。譬如余物。如是作者及业无自体性。品义如此。是故得成。如佛告极勇猛菩萨言。善男子。色非作者使作者。如是受想行识亦非作者使作者。若色至识非作者使作者。此是般若波罗蜜。又如摩诃般若波罗蜜经中。舍利弗言。婆伽婆。无作是般若波罗蜜。佛言。作者不可得故。又如佛告极勇猛菩萨言。善男子。色非善。非不善。受想行识亦复如是。若色至识非善非不善。是名般若波罗蜜。如是等诸修多罗。此中应广说

释观作者业品竟

    般若灯论释观取者品第九

复次为令谛观取者无体。有此品起。如偈曰

  眼耳等诸根　　受等诸心法
  此先有人住　　一部如是说

释曰。一切自部皆无此执。唯有婆私弗多罗立如是义。眼等诸根。受等心法。此若有者。则有先住。道理如是。若不尔者。偈曰

  若取者无体　　眼等不可得
  以是故当知　　先有此住体

释曰。我见有是取者先住。何以故。以取者故。由此取者可得故。在诸取先住。譬如织者在经纬前。复次取者之先有眼等取。何以故。以有取故。如竹篾等。如是取及取者二俱得成。以是义故。我先说言第一义中有是阴等取及取者。婆伽婆说不可破坏。论者偈曰

  若眼等诸根　　受等诸心法
  彼先有取者　　因何而施设

释曰。眼及受等以无体故。异取更无一物可得有。何取者而施设耶。如是彼于尔时不有。以取无体故。此中立验。眼等取前无彼取者。何以故。以施设故。如经绢等。是故取者不成。由取者不成故。因义则坏。由因坏故。彼经绢等譬喻无体。以第一义中取及取者体不成故。复次有异婆私弗多罗言。如先生天上。生天业尽天上取者得如是住。后取人等诸阴故。彼取者阿含得成。论者言。彼生天者。天上取体天施设故。又汝总说阿含。无别验故。令生疑惑。不应定信。如偈曰

  若无眼等根　　先有彼住者
  亦应无取者　　眼等有无疑

释曰。汝意如是。义则不然。何以故。若不观取者。眼等诸取体则不成。此意如是。若此二法互不相观。如此次第义不应尔。所谓此是眼等诸法取。此是调达名取者。此是调达名取者。此是眼等诸法取。由此偈曰

  或有取了人　　或有人了取
  无取何有人　　无人何有取

释曰。或有取了人者。谓眼等诸法。或有人了取者。谓见者闻者。由取取者。更互相观。世谛中成非第一义。后半偈者。由彼无体。彼因过失汝不得离。复次婆私弗多罗言。汝今何故自生分别言有先住。在彼眼等诸根之前。后还自破。我等法中亦作此说。如偈曰

  一切眼等根　　先无一人住

释曰。无一人住者。谓彼眼等一一根。先各有人住。何以故。偈曰

  由彼眼等根　　异异了彼异

释曰。眼等者谓耳鼻舌身受等。由眼至受各各有异。故得说言。此是见者。此是触者。由观异取故。彼取者得。成汝言因。不成者。无如此义。论者偈曰

  若眼等诸根　　先无一住者
  眼等一一先　　彼别云何有

释曰。由诸外道一一取先立有取者。谓眼耳等先各有人住。是义不然。何以故。若不观眼等取者无体故。此意如是。由前立验。眼等取先一一取者。义亦不成。复次汝若定执有彼取者。今当问汝。为此见者。即是闻者。乃至受者。为见闻者。乃至受者。各各异耶。若受先说者。是义不然。如偈曰

  见者即闻者　　闻者即受者
  一一若先有　　是义则不然

释曰。彼如是说则同外道。此义云何。外道所说彼身根处积聚法者。如草土成舍。而有别人于中受用。如是人者。不可识知。谓见者等。此义不然。何以故。彼一体故立义有过。复次非第一义中彼见者体不异闻者。何以故。闻者故如别体闻者由相续异故。见闻不同。汝言体不异者。此立义过。复次见者欲见不观。于眼色应可得。何以故。不异闻者故。譬如闻者。由与闻者不异验故。不观于眼。彼色可得。若其不尔。见者异法。此皆不成。立义过故。复有异僧佉言。我若是一丈夫则堕余根去过如历诸窗牖。由彼处处眼等为因起色等觉。以我既不遍则有别方所。若不依彼眼等诸根。则见闻者等皆不得成。由我遍故。则不至余根。是故无过。论者言。汝立因者有大过失。由一一根中皆先有我。是义不然。何以故。道理无有如此我故。若人欲得异阴入界。有一丈夫为见者等。论主教彼如先观入品遮。当如此解不复广释。或有欲避如先过失说有取者。其相云何。彼谓见者闻者各各差别。而是一我。如此执者。是亦有过。如偈曰

  若见闻者异　　受者亦差别

释曰。如汝分别得何等过。今当示汝。如偈曰

  见闻者不同　　是我则多体

释曰。若世间物异彼物者。则彼此俱有。以其异故。如瓶钵等。见闻者异亦复如是。由见闻者异故。嗅尝触者亦各差别。以是义故。于一相续中有无量我。而不欲尔。是故第一义中见者闻者有别相续。此异不然。此中说验。见者取者不异闻者。以彼取者因果合有故。如见者自体。复次如前偈言。见者闻者异。此言见者为缘则闻者可得。以如是义我成多体。又过去时等各差别故。复次此中说验。第一义中取者无体。何以故。以缘起故。如取自体。复次第一义中调达眼等不名调达取者之取。何以故。以眼等故。譬如耶若达多眼等自体。是故取者及取。二皆不成。以不免前过故。婆私弗多罗言。取及取者。若一若异。俱不可说。是故无过。论者言。可说有故。岂非过耶。复次于一身根聚。若果若因诸聚食者。我则无量。而不欲尔。以是故我则不一。此义得成。以识别故。如多相续见者不一多我得成。复次有异人言。有如是取。如佛所说。名色缘六入。彼色是四大为取者取。是故有实取者。由六入具足次生受等。非眼等先有。彼取者因施设故。譬如瓶等。此是如来所说道理。汝违此理。是故汝先所立义破。论者偈曰

  眼耳及受等　　所从生诸大
  于彼诸大中　　取者不可得

释曰。由彼取者。无实体故。依第一义名色位中取者无体。然世谛中名色为因施设取者。是故不违阿含所说。以彼眼等及大唯是聚故。汝立取者。为因此义。不成有过失故。如理谛观。彼无实体。如偈曰

  眼先无取者　　今后亦复无
  以无取者故　　无有彼分别

释曰。眼等诸取取者不然。彼异取故。如别相续四大取者。如是验知前不可得。以实体不成故。譬如四大实体。由第一义无故。取及取者一异俱坏。一异不成故。彼分别灭。云何灭耶。以无实有故。有分别灭。因施设故。无分别灭。复次汝立有故。欲令我解。我于第一义中验无体故。有分别灭。有既灭故。无亦随灭。如婆伽婆楞伽经中偈曰

  以觉观察时　　物体不可得
  以无自体故　　彼法不可说

如前人言。有取取者。彼皆不成。取为因过。已如上说。取及取者皆无自性。故有此品。以是义故。此证得成。如般若波罗蜜经中说。佛告极勇猛菩萨言。善男子。色无见者使见者。受想行识无见者使见者。若色至识无见者使见者。此是般若波罗蜜。复次色无知者见者。受想行识无知者见者。若色至识无知者见者。此是般若波罗蜜。如是等诸修多罗。此中应广说

释观取者品竟

般若灯论释卷第六般若灯论释卷第七

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观薪火品第十

复次前品已遮取及取者。除其执见。今复令解不一不异缘起法故。有此品起。外人言。第一义中有取取者。何以故。由此二法互相观故。譬如火薪。云何知耶。如佛所说。第一义中有阴等取及以取者。此因成故。我义得立。论者言。总遮起故。薪火亦遮。汝今未悟犹言有实。如观阴品说。若离色因。色不可得。因亦如此。虽先已破。今当复遮。汝应谛听。此遮方便火薪二种欲令有者。为是一耶。为是异耶。若尔有何过。薪火一者。是义不然。何以故。如偈曰

  若火即是薪　　作者作业一

释曰。由彼地等譬喻无故。此不相应。有人言。四大是薪。暖界是火。复有人言。彼诸大中暖界增起故名为火。论者此中更方便说。第一义中薪火二事不为一体。何以故。作者作业故。譬如斫者所斫有异。火为作者。燃为作业。以作者业异故。薪火不为一。复次若火即是薪作者作业一。若定尔者。汝不应言是薪是火。薪外有火者。一体义坏。以不暖不烧火即无用。法体无别故。立义有过。汝言薪火一者。是义不然。复次薪火异者。是亦不然。何以故。如偈曰

  若火异于薪　　离薪应有火

释曰。以其异故。譬如余物。而不欲尔。此中说验。第一义中火薪不异。何以故。以有观故。如薪自体。如是第一义中火薪不异。何以故。以有观故。如火自体。若言火薪别物。皆有相观。一切有观故。因非一向者。是义不然。何以故。彼一切等观义相似亦同遮故无过。若定欲得火薪异者。有过失故。如偈曰

  如是常应燃　　以不因薪故

释曰。不观薪故。彼应常燃。纵无薪时。火亦不灭。以其异故。又干薪投火亦无焰起。义皆不然。如偈曰。

  复无燃火功　　火亦无烧业

释曰。无可烧相业无体故而不欲尔。何以故。幼男小女尽知有因。皆欲有业故。此中立验。第一义中火薪不异。何以故。以有因故。有起作故。有业故。如薪自体广如前说。薪门亦尔。以薪为燃因。有起有业。皆同火说。是故非因。譬喻不成。若汝意谓火正燃时名为薪者。是亦不然。如偈曰

  若火正燃时　　汝谓为薪者
  彼时唯有火　　谁是可燃薪

释曰。于世谛中。未燃时名薪。正燃时名火。以薪是火缘。于正燃时唯说火故此起亦唯聚。唯是独自故能为烧煮照明果因故说为火。第一义中起不可得。先已遮故。复次若汝意谓四大齐等。火界不增。说名为薪。或说三大名之为薪。彼三或四是其所烧。火亦如是。大聚和合故说为火。如是说者。今当立验。第一义中火不烧薪。何以故。以其大故。譬如水大。如是色故。有故。粗故。色阴所摄故。外故。有生故有因故。如是因验此应广说。如彼意谓第一义中火能烧者。是则不然。复次如前偈说。彼时唯有火。谁是可燃。薪者唯是何义。谓唯大积聚故。起别观故。于世谛中说为薪火。汝谓于正燃时说为薪等者。是义不然。问曰地等和合中。有火能烧故。汝立喻者。此喻不成。答曰。成立相似者彼亦同破地等自相我引为喻。汝言喻不成者。我无此过。以第一义中遮故。不坏世间所解故。复次鞞世师言火薪微尘我之一分。此一分尘与后尘合。此业作和合依止二尘。彼二微尘和合起作名陀腊脾(毗佉反唐言实)。如是三尘已去渐次起已作光明故。名为火陀腊脾。如是薪尘与薪尘合。彼薪火二更互相观。以相观故。得成因果。论者言。彼亦如前偈说。若火异于薪。离薪应有火。如是等执。前已广遮。此中应说。复次非第一义中火作光明。何以故。以其大故。譬如余大及遮彼起第一义中火大微尘不能起作火陀腊脾。何以故。以微尘故。如余微尘。问曰。汝前立义有何所以。为起余尘。为都无起。若起余尘立义则坏若都不起。则譬喻无体。答曰。汝语不善。如先分别。非我所欲。后分别者。譬喻亦成。何以故。如火微尘不能起火。地等诸尘一一皆尔。复次第一义中彼火微尘不能起火。何以故。以异故。譬如水。如是作故。坏故。起故等诸因。此应广说。复次僧佉人言。如我立义彼萨埵(唐言明相)遏逻阇(唐言尘)诸触色增时说名为火若多摸(唐言暗)增时说名为薪是故定以薪为火因。以薪为因故。观薪说火。论者言。彼亦有过。以第一义中暖非火体。何以故。以大故。如前譬遮。复次偈曰

  若异则不到

释曰。若火异薪者异故则不到。譬如未到火薪。由作者喻火。作业喻薪。此二和合名为作相。义正如是。复次偈曰

  不到故不烧　　不烧故不灭
  不灭住自相

释曰。由此火无因离薪得成故。则住自相。住自相故名之为常。既无此义故。知火薪不异。若立异者。如先已遮。此应广说。如后偈曰

  此物共彼物　　异者则不然

外人言。若异不到者得如是过。如前偈言。异则不到。不到不烧等由异有到无如上过。云何验耶。如女人丈夫异故。相到世间所解无能破者。如偈曰

  然异于可燃　　此二能相至
  如女至丈夫　　如丈夫至女

论者偈曰

  若然异可然　　此二相到者

释曰。汝意立异譬。彼男女纵如是者。则互不相观。以薪火处同而起。到相复是异故。不相观者可言我得因非一向。如偈曰

  火薪既有异　　则不互相观

释曰。互不相观者。此义云何。谓作者作业和合则空。如薪火异。意不欲尔。何以故。彼二无到故。汝说作者作业和合相异者。是义不然。执法别故。立义有过。何等过耶。汝说异故。而能相到。如男女者。二不可得。以异门不成故。非非一向因过。但彼外人自迷于义。智慧轻薄。作如是说。品初成立薪火一异。譬喻无故。二皆不成。外人言。第一义中有薪有火。何以故。互相观故。此若无者。彼二相观则不得有。譬如兔角。由有薪火更互相观故。得说言此是火薪。此是薪火。以是义故譬喻得成。论者偈曰

  若火观于薪　　若薪观于火
  何等体先成　　而说相观有

释曰。若相观者。为薪先成。为火先成。汝应分别。如是此二。无一先成。别相观者。以第一义中观不成故。因义不成。亦譬喻过。若汝言于世谛中立此因者。与义相违。又无譬喻。成立有过。若汝意谓彼薪先成故无过者。是义不然。如偈曰

  若火观薪者　　火成已复成
  薪亦当如是　　无火可得故

释曰。汝若定作如此分别者。火已先成。后观薪故。此义云何。由薪不观火薪先成故。语意如是。而不欲然。此中说验。第一义中薪在火先。无如此义。何以故。以有观故。如火自体前已广说。外人言。若薪与火无一先成者。今薪火相观一时而有。如牛左右角同时起故。此义得成。论者偈曰

  若此待得成　　彼亦如是待
  今无一物待　　云何二体成

释曰。此谓火体相。彼谓薪体相。外人意欲薪火俱成。一一有故。此义不然。何以故。由彼自因更互相观生不成故。语义如此。复次牛角喻者。亦如是问。彼二角中何等是左何等是右。世人所解由相观故。第二得成。无如此义。复次如偈曰

  若体待得成　　不成云何待
  不成而有待　　此待则不然

释曰。谓彼物。不成此无所待。语义如是。此中说验。第一义中薪不观火。何以故。火体不成故。如地水等。复次偈言不成而有待者。外人若作如此说者有过失故。云何过失。偈言此待则不然。以无待故。如虚空华。复次此待不然。何以故。薪体无故。譬如余物火门。亦应作如是说。复次观察彼者。如偈曰

  无火可观薪　　薪非不观火

释曰。薪不观火薪体不成。如此道理如先已说。亦遮异体。彼别相续。异不成故偈曰

  无薪可观火　　火非不观薪

释曰。遮相待故及遮异体应知。复次偈曰

  火不余处来　　薪中亦无火

释曰。遮异体故。及遮去实并薪火故。或有人言。无薪有火。或言有待。或言无待。二俱不成。何以故。若无薪体火无所依。依止无故。去则不成。薪中亦无火者。是义云何。由有起故。譬如识。复次已破薪火。余亦同遮。偈曰

  如薪余亦遮　　去来中已说

释曰。如第一义中已去未去。去时无去。已烧未烧。烧时无烧。义亦如是。何以故。以烧故。如火自体。诸如是等此中应说。复次如去者不去。未去者不去。离亦无去。今亦第一义中烧者不烧。未烧者不烧。离亦无烧。如是等验。先已广说。何以故。二作空故。无烧者故。二俱过故。譬如土块。应如是说。复次如偈曰

  即薪非是火　　异薪亦无火

释曰。遮一体故。遮异体故。如其次第。先已解说。偈曰

  火亦不有薪　　火中亦无薪
  薪中亦无火

释曰。如有牛者。如水中华。如器中果。彼如是故火薪不成。譬喻无体。如品初立义。有取取者互相观故。如火薪者。此譬无故。不免过失。薪火一异。遮无体故。由如此义根本不成。如偈曰

  已遮火及薪　　自取如次第
  一切净无余　　瓶衣等亦尔

释曰。云何方便遮自取耶。此中立验。第一义中彼自取二。不得一体。何以故。作者作业故。如斫者所斫。彼自及取亦不异体。何以故。以有观故。亦余物故。如取自体。取门亦应如是广说。此复云何。第一义中取与自我不得异体。何以故。以有观故。亦余物故。譬如自我。如是第一义中调达之取。若成不成。不为调达我之所取。何以故。以有观故。亦以我故。譬如余调达我。复次第一义中调达之我。不取调达之取。何以故。以取故。如耶若取。如是调达之取。若成不成。不观调达我。何以故。以取故。如耶若取。如是火薪我取次第已说。一切无余者。法喻不成故。瓶衣等者。彼瓶等物。若果若因。总实别实。应如是知。云何验耶。如瓶土二。第一义中不得一体。何以故。作者及业故。如斫者所斫。亦不异体。何以故。有观故亦果故。如土自体。如遮薪火。色非色法。亦应类遮。此复云何。如佉陀罗树。根茎枝叶与佉陀罗树不得一体。何以故。斫一枝时。非斫一切故。譬如枣树。复次第一义中佉陀罗树与佉陀罗根茎枝叶不得异体。何以故。根等坏时。树亦坏故。如根等自体。复次第一义中彼经纬等与绢体不异。何以故。以有观故。此等坏时。彼亦坏故。如经自体。如一体异体及一异。俱如前过失。此应广说。由如是故。第一义中如理谛观。若一若异。此体不成。于世谛中自在说者。不违世所解。随顺戒定慧世谛中说。世人执为第一义谛。为遮此故。如偈曰

  若计我真实　　诸法各各异
  应知彼说人　　不解圣教义

释曰。云何不解圣教义耶。现见及验义皆不成。而执为实故名不解。此意如是。以是义故。此品中明不一不异。别缘起义。开示行者。是故得成。如梵天王问经中偈曰

  离身不见法　　离法不见身
  不一亦不异　　应当如是见

释曰。如是见者。谓不见彼见。如是等诸修多罗。此中应广说

释观薪火品竟

    般若灯论释观生死品第十一

复次前品已遮诸法无性空所对治。自性无故。今欲令他解悟生死无自体性。有此品起。外人言。第一义中有是五阴。何以故。由婆伽婆作别名说。及为尽彼故。勤方便说。此若无者。如来不应作别名说。亦不为尽彼故。作如是说。如无第二头。不可言眼病。由此有故。作别名说。及为尽彼故。说如是言。诸比丘生死长远。有来无际。诸凡夫人不解正法。不知出要。是故汝等为尽生死故。应随顺行。应如是学。由如是义说因有力。是故当知有彼阴等。论者言。汝虽引圣言而未详圣旨。是义云何。由佛世尊见诸凡夫。无始已来。于生死中未起对治。无对治故流转不息。从烦恼生业。从业生生。由生相续盛受诸苦。如世库藏。佛见此已故说是言。生死长远犹如幻焰。又生死苦种种无量。如来为欲尽生死故。建立众生于勤精进。若谛观察生死涅槃于第一义中无毫厘差别。若汝欲令第一义中生死涅槃有差别者。因义不成。若世谛中分别因者。譬喻无体。如佛先说生死无际者。为对破彼说无因辈明。有因为初。能生诸法。言有起者。如来为彼一分众生作如是说。有诸外道。欲求过失。问佛世尊。如偈曰

  生死有际不　　佛言毕竟无
  此生死无际　　前后不可得

释曰。未起圣道对治已来。由生老死相续不息。展转为因。初起无定。是故无际无边成立世谛中说。非第一义。有信心人。信婆伽婆不颠倒语。非不信者。何以故。颠倒心人说相似验。为对彼故。作如是说。彼劫初众生。身根觉聚皆由前世善不善业集因所成。何以故。能为苦乐法等起因故。如今现在身根聚等如是不共取境因故。可饶益长养故。能为他作饶益故。作他嗔喜因故。可散坏法故。为共取境界因故。如此等因立义譬喻如前广说。应如此知。外人言。生死有初。何以故。以有边故。法若有边非谓无始。譬如瓶等。由正智起时见生死边。如我所说因有力故。是故定知生死有初。论者偈曰

  非独于生死　　初际不可得
  一切法亦然　　悉无有初际

释曰。瓶等无初。何以故。展转因起故。初既不成。譬喻则坏。立义过故。汝言有边为因者。义亦不然。何以故。虚妄分别生死有因佛不记故。此义如后当说。外人言。若汝欲得生死无始者。如是生死亦应无终。何以故。以无始故。譬如丈夫。及彼虚空。论者言。汝言丈夫及余法无起者。于世谛中亦不应尔。何以故。法体不成。譬喻无故。彼稻谷等。世谛门中虽复无始。而见灭坏。汝立难者与义相违。复次有异聪慢者言。汝婆伽婆无一切智。何以故。彼说生死无初际。自欲显己无智故。譬如死尸无所觉了。论者言。遣执着故。作如是说。此义云何。诸外道等分别生死谓有初际。是故佛言无有初际。无初际者。即说生死无始。云何无始。以其无故。如是生死无始故。初际不可见。非婆伽婆于彼无智。复次生死无际者。此中立验。第一义中诸阴似先不如是有。何以故。无前际故。譬如幻主作幻丈夫。外人言。由无分别识取彼幻主所作幻人色等为境。彼诸色等于后时中亦如是有故。譬喻无体。论者言。幻主所作幻丈夫者。自无实体。见亦如是。由无分别识色境界中幻作丈夫自体空故。譬喻得成。无无体过。是故汝言生死是有及为尽彼故。引佛说为因者。此皆不成。外人言。第一义中有阴相续。是名生死。何以故。彼中有故。此若无者。彼中亦无。譬如兔角。由生死中有染有净故。生死是有。我所欲义既成立故。汝言为因不成及违义者。是则不然。论者偈曰

  此既无前后　　彼中何可得

释曰。如彼中体不可得故。语义如是。譬如幻师幻作丈夫。于彼相续求中体者。无如此义。何以故。以前后不成中无体故。汝喻非也。如所说过。今还在汝如是谛观生死无体。偈曰

  是故前后中　　次第此不然

释曰。前中后者。谓生老死。外人若言生死有自体。何以故。生老死有故。如石女无儿。不可说有生老死者。此执不然何以故。彼石女儿生老死初中后不成故。因义不成。譬喻无体。以第一义中一物生等自体不成故。复次云何生等初中后次第不成。应审观察。如偈曰

  若谓生是先　　老死是其后
  生则无老死　　不死而有生

释曰。若汝意谓生为先者。应离老死独自而生。若定有物离彼生者。如此物体。终不可得。譬如火马。自体无起。何以故马非火故。语意如此。先无今起名生。新新变异名老。命根断坏名死。复次不死而有生者。谓前世不死如是而生故。然非所欲。复次此中立验。老死之先不得有生。何以故。彼自体故。譬如火在暖先。复次若汝欲避如此过失。作如是言。先有老死。后有生者。是亦不然。如偈曰

  若先有老死　　而后有生者
  未生则无因　　云何有老死

释曰。无法未生而有老死。以依止无体故。语意如是。复次此中立验。先生老死。是则不然。何以故。以彼为体故。譬如住外人言。老死随着生故。无如是过。论者偈曰

  生及于老死　　俱时则不然
  生时即死故　　二俱得无因

释曰。何故不然。生时即死无如此义。何以故。生无体故。此义世间所无。生无体者。得何过失。二俱得无因过二谓老死同时故。以共生故。如老死非生因今生亦非老死因。是故老死同时起者。此义不然。由此观察故。偈曰

  若彼先后共　　次第皆不然
  何故生戏论　　谓有生老死

释曰。以是义故。第一义中不应起戏论。如品初所说。以生老死为因。成立生死者。此义不成。以不免前所说过失。如生老等。约前后中观察不成。自余诸法皆亦类破。此复云何。今当显示。如偈曰

  如是诸因果　　及与彼体相
  受及受者等　　所有一切法
  不但于生死　　前际不可得
  如是一切法　　悉亦无前际

释曰。一切法者。谓能量所量知及所知。得解脱者。解脱行等。如彼所立因果体相。是皆不然。其义云何。今说少分。谓第一义中彼稻谷等芽先不有。何以故。以其果故。如芽自体。若汝欲得因先果者。是亦不然。何以故。第一义中因先无果。以无因故。僧佉人言。有如是因。能了彼果。论者言。汝谓有因能了果者。是亦不然。何以故。彼因种种果亦别故。譬如泥团作彼瓶等。复次能了之物。及所了物。彼有别异。此无别异。如日宝珠灯及药草光有差别。瓶等无别故。若谓因果同时者。是亦不然。以第一义中稻芽二种不得同时。何以故。一时起故。如牛二角。复次垂[古*頁]等相在牛体先。无如此义。何以故。依止无体故。如壁与画。如是相先有体。是亦不然。何以故。以其体故。譬如大丈夫体不在丈夫相先。又如地不先坚。复次体相二法同时起者。是亦不然。何以故。同时起故。譬如香味。如前广破。如品初成立。及与彼过所说苦空。令人了达。是品所明。以是义故。此证得成。如般若波罗蜜经中说。佛告极勇猛菩萨言。善男子。色不生不死。如是受想行识不生不死。若色受想行识无生无死。是名般若波罗蜜。复次极勇猛。如涅槃无际。一切法亦无际。如是等诸修多罗。此中应广说

释观生死品竟

般若灯论释卷第七般若灯论释卷第八

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观苦品第十二

复次苦无自性。所对治空。遮定执故。有此品起。外人言。第一义中有是诸阴。何以故。由苦故。此若无者。则无彼苦。如第二头。阴是苦者。如经偈曰

  苦集亦世间　　见处及彼有

以是义故。第一义中有是诸阴。论者言。虚妄分别于苦不然。如偈曰

  有人欲得苦　　自作及他作
  共作无因作　　彼果皆不然

释曰。第一义中种种无量如理观察。彼皆不然。云何观察。苦非自作。如偈曰

  苦若自作者　　则不从缘生

释曰。由自作故。则不藉因缘。是故苦从缘起。即无此义。而彼不然。复欲得故。此义云何。谓从缘起。如偈曰

  由现阴为因　　未来阴得起

释曰。第一义中诸阴相续名调达者非调达作。何以故。藉缘起故。譬如一有由现阴为因牵后阴起义正如此。复次鞞世师言。身等诸根觉聚虽别而我无异。彼一遍住亦是作者彼作此苦故。是自作。若言诸行刹那刹那生灭。无常者。此说有过。得何等过。此心刹那俱生之苦。不即此苦刹那心作故。非自作亦非他作。何以故。他所作业自受果者。此义不然。汝意若欲令他作者则违自悉檀。论者言。此中立验。汝言丈夫即是作者。是义不然。何以故。以其常故。譬如虚空。以常验故。知非作者。丈夫作者法自体破立义过故。复次若汝定谓我作此苦即不从缘起有如是过。此义云何。以我法中名苦为我。义意如是。复次若言丈夫作业即是自作非不藉余因缘共作后得起者。是义不然。何以故。由无量因共我作苦应如是知。如彼干草及牛粪等为火作缘。义意正尔。复次调达之苦非调达我作。何以故。由苦故如耶若苦。汝前说言。若刹那诸行等无别作者。彼业所作即是自作者。今当答汝。第一义中苦不可说故我无过。彼世谛中相以相续因果不别。世间咸见作如是说。如言彼处灯来此庵罗树是我所种。此亦如是。后时有相与彼前思相续。因果不别前有相思。此刹那作名为自作。由前刹那思所积集善不善业。彼业灭时与后为因。如彼灯焰前为后因。如是展转相续乃至得果。故非不作而得。亦非作已失灭。若汝意谓诸行刹那先所集业不受后果。何以故。以其异故。如别相续者。是义不然。如偈曰

  处处缘起法　　不即是彼缘
  亦不异彼缘　　不常亦不断

释曰。我悉檀如是。汝立异故为因者。此义不成。何以故。由先心刹那所传来业。对治未生。相续与果。以功能胜异故。譬如以紫矿汁浸摩多弄伽子种之。后时花中有紫矿色不违世谛。复次说有丈夫者言。一边作业。一边受果。无如上过。论者言。彼一边者不作而得。此一边者已作失坏。以作业边永不得果。有此过失。外人言。我是一故无过。云何知一。与一数相应故。论者言。我与一数相应无如此义。何以故。由有故。譬如一数。以是义故。苦非自作。亦不他作。此义云何。如偈曰

  若前阴异后　　后阴异前者
  此阴从彼生　　可言他作苦

释曰。若人欲得他作苦者。法体不成。立义有过。而实不然。云何不然。此中立验。第一义中调达后阴于先阴非他。何以故。调达阴故。譬如后自阴体。又彼苦体。相续不别故。立义譬喻如前应知。复次执有人者说如是言。他所造业自受果者。是义不然。何以故。诸位差别皆人作故。名自作苦。亦名他作。二家所立者。我无此过。论者言。汝但有此语。是亦不然。如偈曰

  若人自作苦　　离苦无别人
  何等是彼人　　言人自作苦

释曰。何等是苦。谓五阴相。离彼苦阴无别有人。云何而言。人作于苦。复次若汝执。言人与五阴不一不异者。是义不然。何以故。但于五阴施调达名。无人可得。以缘起故。譬如瓶等。如是第一义中彼人不成。人既不成。无作苦者。复次他人作苦。是义不然。如偈曰

  若他人作苦　　持与此人者
  离苦何有他　　而言他作苦

释曰。离苦无人。前已遮故。人有别体令证知者。以无验故。如是自作苦不可得。先已立验晓诸未解。是故偈曰

  自作若不成　　何处有他作
  若他人作苦　　彼还是自作

释曰。无自作苦而指示言他作苦者。此语不然。如别相续决定报业。言他作者。无如此义。是故偈言。何处有他作。语意如是。汝言位有差别人无异者。此为妄语。以是义故。若自作苦。若他作者。此皆不然。复次异尼犍子作如是言。人自作苦故苦是自作。而苦不即人名为他作。是故自作他作二门得成。论者偈曰

  自作苦不然

释曰。无人作苦。此义如是。由苦无自体人无体故。若谓苦体是人者。义亦不然。何以故。偈曰

  苦不还作苦

释曰。如先偈言。苦若自作者。则不从缘起。此之二句。如彼已遮语意如是。复次若苦还作苦者。即是果还作果。又苦自起不待因缘。此之二种世所不见。汝前说言。苦不即人此人作苦名他作者。此说不善。如偈曰

  若他作苦者

释曰。外人意欲以人为他。此人无体不能作苦。何故不作。以其空故。空则无物。云何起作。无起有体者。智人所不欲。是故偈曰

  无他谁作苦

释曰。无此他义。语意如是。以是义故。自作他作此皆不然。俱作者言二作苦故无过。为遮此故。阿阇梨偈曰

  若一一作成　　可言二作苦

释曰。一一不作如先已遮。苦非自作亦非他作。是故汝言二作苦者。此义不然。亦不无因。何以故。此无因执。如无起品已遮。此中偈曰

  自他二不作　　无因何有苦

释曰。此品前来所说遮苦若无因者。则亦无苦。无因有苦。无如是义。由第一义中苦不可得。语意如此。如是种种观察彼苦无体。外人品初言。有诸阴以苦故为因者。第一义中此执不成。如偈曰

  不独观于苦　　四种义不成
  外所有诸法　　四种亦皆无

释曰。如前所说道理。彼外色等观察亦无此义。云何色不自作。何以故。若有若无。因不然故。如前已说。又从缘起故。如芽自体不名自作。若言从诸大作名他作者。是义不然。云何不然。诸大于色不名为他。何以故。以其外故。如色自体。又遮实有故。色无自体。他义不成。亦非共作。以一一不成故。亦不无因。何以故。此无因执前已遮故。如是声等亦应类破。是故品初说因由苦故者。有过失故。此义不成。今此品中为欲显示苦是空义。是故得成。如般若波罗蜜经中说。佛告极勇猛菩萨言。善男子。色非苦非乐。如是受想行识非苦非乐。若色受想行识非苦非乐。是名般若波罗蜜。又如梵王问经中说。云何名圣谛。若苦若集。若灭若道。不名圣谛。彼苦等不起。乃名圣谛。如是等。复次声闻乘中婆伽婆说。有比丘问佛言。瞿昙。苦自作耶。佛言不。他作耶。佛言不。俱作耶。佛言不。无因作耶。佛言不。如是等诸修多罗。此中应广说

释观苦品竟

    般若灯论释观行品第十三

复次为令他解一切诸行种种差别皆无自性。有此品起。此中外人引经立义。如偈曰

  婆伽婆说彼　　虚妄劫夺法

释曰。云何知彼诸行等法是虚妄耶。彼诸行等自体无故。诳凡夫故。邪智分别。谓为可得。故是虚妄。又能为彼第一义谛境界念等。妄失因故是虚妄法。婆伽婆说者。谓于诸经中。告诸比丘作如是说。彼虚妄劫夺法者。谓一切有为法最上实者。谓涅槃真法。如是诸行是劫夺法。是灭坏法。声闻法中作如是说。大乘经中亦作是说。诸有为法皆是虚妄。诸无为法皆非虚妄。此二阿含皆明诸行是虚妄法。此义得成。论者言。此中立验。第一义中内诸法空。何以故。劫夺法故。如幻化人。外人言。立义出因无差别故。汝言第一义中诸法空者。是无所有劫夺法者。亦无所有。出因阙故。立义不成。有过失故。论者偈曰

  若妄夺法无　　有何名劫夺

释曰。汝谓立义出因皆无所有。若尔此既是无。竟有何物可名劫夺。以无体故。譬如兔角。是故虚妄劫夺。此之二语。非是无义。复有何义分别境界。彼自体空是虚妄义。不如实有。喻若光影。是劫夺义。因与立义此二不同。是故我无立义阙因过失。无二过故。所欲义成。复次劫夺语者。佛婆伽婆拔烦恼障。及智障根。永尽无余。故作此说。如偈曰

  婆伽婆说此　　为显示空义

释曰。劫夺语者。与空无别体。如言彼处有烟此说彼处有火。外人言。虚妄语者非是无义。此有何义。谓如来不说诸法无我。若尔云何。说虚妄语。如偈曰

  见法变异故　　诸法无自体

释曰。此偈说何义。谓见诸法变异故知诸法无体。云何无体。以非常住故。婆伽婆说虚妄语者。道理如是。又如偈曰

  有体非无体

释曰。云何名有。自体有故。如汝道理者。诸法则无体。而此不然。偈曰

  由诸法空故

释曰。诸法无我我所故。汝义如是。是故应信诸法有体。若不如此者。偈曰

  自体若非有　　何法为变异

释曰。现见此体有变异故。是故定知有变异法。此中立验。第一义中诸法有体。何以故。体变异故。此若无体。则无变异。如石女儿。由有体变异。谓内入等。是故第一义中法有自体。论者偈曰

  若法有自体　　云何有变异

释曰。法有自体而变异者。是义不然。何以故。以自体者不可坏故。而今现见彼体变异。是故当知。彼变异体与无自体不得相离。汝所立因则自相违。有人言虚妄法义者。谓不如实见法无自体者。此谓说无我义。何以故。言自体者。即是我名。见法变异者。此谓诸法转变灭坏。是故虚妄语者。与其无我不得相离。此虚妄语即说无我。非谓说空。是故圣道未起。我见山未崩。内外诸法我及我所光影显现圣道起时。于此诸法不复分别我及我所。若言诸法无自体者。如外道所执我。此我无体成立此义者。则成我所成。如是因者。成立无我。不成立空及无自体。论者言。汝等分别法无体者。谓如兔角。无体如是。故生怖畏。譬如小儿夜见自影。谓是非人失声惊怖。汝亦如是。如汝所言外道执我立此无我则成我所成者。汝今谛听。若以虚妄之言。为成立无我及外道执。我亦无自体。作此解者。如是如是。我今成立法空为因开示汝者。此亦成立人无我义。何以故。此人无我。与彼法空不相离故。如是此因令人信解。如立义者。声是无常。云何出因。谓彼作故。言作故者。苦空无我亦得成立。如是成立虚妄法者。无其自体。即亦成立。人无我义。以不相离故。如外人言。虚妄义者。此明诸法自体不住。今答此义。若法可取者。偈曰

  彼体不变异　　余亦不变异
  如少不作老　　老亦不作少

释曰。此二譬喻如数次第相似相对。此中立验。法住自体变异者不然。何以故。不舍自体故。譬如少老。若言彼前刹那异相老住名变异者。此亦不然。何以故。异相已去故。譬如老若。外人言。如乳不舍自体而转成酪。以是义故。因非一向者。是义不然。今当问汝。何者是酪。彼言乳是。若乳是酪。不舍自体。云何分别。此名为酪。若定分者。偈曰

  若此体即异　　乳应即是酪

释曰。由乳不舍色。味力用利益等故。乳不为酪。异亦不然。何以故。如偈曰

  异乳有何物　　能生于彼酪

释曰。无酪可起故。余体亦无变异。汝言因非一向者。是义不然。有异人言。我亦不说乳不生酪。酪相异乳。然以和合自在力故乳生于酪。论者言。汝言和合自在力者。此乳为舍自体能生于酪。为不舍自体而生酪耶。若尔有何过。若舍自体则不得言乳生于酪。若不舍自体此则相违。云何相违。若是乳者。云何名酪。若是酪者。云何是乳。于彼世间悉如是解。若有人言。乳不生酪但变为酪。如此义者亦同前遮。如是观察。第一义中诸法异者此皆不成。汝言诸法有体以此为因者。此因不成。外人言。第一义中诸法不空。何以故。此相违法有故。如颠倒智及不颠倒智。此若无者则无违法。如虚空花由违不空故有空法。以是义故。如所说因诸法不空。论者言。若第一义中有阴等者。除此有物立于空法。而第一义中实无一法是不空者。如偈曰

  若一法不空　　观此故有空
  无一法不空　　何处空可得

释曰。空不空者。于世谛中依止法体。如是分别。此义云何。如有舍宅。有人住故名舍不空。人不住故则名舍空。今第一义中无一法不空。何处得有空法可得。如汝向言有相违法分别为因者。此因不成。但为遮执着故假言空耳。复次十七。地论者言。如所分别。自体无故。分别体空。此诸法空。真实是有。云何真实。不观作者故。论者言。汝此见者名著空见。外人言。何故名我以为着空。论者言。由一切法无体故空。空非实法。不应执着。为遮此故。如前偈中。若有一法是不空者。此是有分别智境界。此是无分别智境界。若有一物是空此名。空智境界而无此物。以无一物是不空者。此谓一切法皆空。是故偈言。何处空可得。复次无一法不空者。此言何谓。不空见者。空火所烧。分别空者。此亦烧故。是故偈言。何处空可得。复次行二行者。作此分别。如幻马等无体故空。如实马等有体不空。此觉差别无二行者。以无分别行般若波罗蜜时。第一义谛境界。真实观一切法。犹如虚空。一相无相。见无所见。偈言。无一法不空。何处空可得。以是义故。彼因不成。外人言。纵令不成及与相违。汝一切时恒遮于空。我意亦尔。以是义故。所欲得成。论者言。非空智起。诸法乃空。法体自空。智了空故。如灯照知。无瓶非作。何以故。彼瓶无体。不可令有故。是故汝说不善思量。复有人言。汝说空者。与他作过。而依止空。见空无力。复言无空。是故汝等所欲义破。亦违自悉檀。云何自违。如梵天王问经偈曰

  若有解空者　　皆是见法性

又如楞伽经偈曰

  若离于和合　　无有如是体
  是故空无起　　我说无自性

如是违汝阿含。论者言。汝不闻耶。如金刚般若波罗蜜经中说。解我法门如筏喻者。是法尚应舍。何况于非法。又如摩诃般若波罗蜜经中说。不观色空。不观色不空。此谓空见亦是执着故须遮止。若复有作不空分别者。此亦应舍。以此二执大过失故。非舍空者有过如是种种诸见过患坏乱于心。如来为彼未离苦众生。断苦种子故。起第一大悲。如偈曰

  如来说空法　　为出离诸见

释曰。见谓身见等。空谓对治内入空等。若有众生善根未熟。未得无生深法忍者。不解正道。如偈曰

  诸有见空者

释曰。云何名见空者。谓执着于空言有此空。此执着空有何过失。如偈曰

说彼不可治

释曰。如来说彼空见众生不可疗治。此义云何。如服下药。动作诸病。而复不泄。反成重病。如是说空法。为舍诸恶见。若还执空者。说彼不可治。以是义故。舍空无过。又如有人车没泥中。为出车故语异人言。与无所有为我出车。而彼异人为出车已。从其车主索无所有。由彼不解此语意故。为诸智人之所轻笑。是故汝等不应执空以之为有。以是义故。彼因不成。过不离汝。由汝所说因义不成。我立自因无前过失。及有力故。云何有力。说诸行空令人信解。品义如此。是故得成。如般若波罗蜜经中。佛告极勇猛菩萨言。善男子。彼一切法从颠倒起。不实无所有。虚妄不如实极勇猛。若有人行一法者。此颠倒行不如实行。又如梵王所问经说。世间愚人执着诸谛。此法非实亦非虚妄。如是等诸修多罗此中应广说

释观行品竟

    般若灯论释观合品第十四

复次。为令信解空所对治诸有合法。皆无自性。有此品起。外人言。汝说一切法自性皆空。如是说者。违正道理。何等道理。如佛所说。有根尘识三种和合。名之为触。以是义故。汝先所说则为相违。如我所立第一义中诸法有体。何以故。以此为因。说名为合故。此若无者。如来不说此因名合。譬如不因龟毛说为衣服。由佛说有贪嗔痴等。如是三结。名之为合。由我说因符正道理。是故诸法非无自体论者言。汝虽有此说。义则不然。如偈曰

  见可见见者　　此三各异方
  二二互相望　　一切皆不合

释曰。见与可见及彼见者。二二相望更互不合。又一切不合。由如是故。偈曰

  应知染染者　　及彼所染法
  余烦恼余入　　三种皆无合

释曰。染谓欲相。烦恼者。谓能染污众生相续故。说染等为烦恼。余谓嗔等。此亦三种。谓嗔嗔者及所嗔等。余入者。眼前已说。此中余者。谓耳鼻舌身意。云何名入。谓心心数法所起处门。故名为入。此亦三种。谓闻可闻闻者。乃至知可知知者。彼染烦恼等及以余入。二二相望更互不合。又一切不合。如可见等无合应知。今为令他解无疑故。偈曰

  异共异有合　　此异不可得
  及诸可见等　　异相皆不合

释曰。可见等者。谓见可见见者。如是染染者可染。皆不相合。此中说验。第一义中见者不与可见及见相合。何以故。彼不异故。若物不异者。终不相合。譬如自体。有人言异。共异合者。此中染等相续。若在别处则不相合。由彼别处及别相续无间随转故。名为和合。此因得成。论者言。若可见等。先在别处。后在一处。名为合者。此因不成。亦无验故。汝语不善。彼如是故。偈曰

  非独可见等　　异相不可得
  及余一切法　　异亦不可得

释曰。如前所说道理。彼闻可闻闻者。嗔可嗔嗔者等。皆无合义。外人言。汝言我及可见眼等无异者。此义不成。因不成故。论者言。非因不成。何以故。如偈曰

  异与异为缘

释曰。待异故名为异。偈曰

  离异无有异

释曰。以种为缘起者。待此种子故。名芽为异。偈曰

  若从缘起者　　此不异彼缘

释曰。非第一义中可见异眼。何以故。差别语有观故。譬如可见自体。若法从缘起者。不异彼缘。若言异者。应离此种芽从余出。如火不观异体自性是暖。如是见者不观可见。闻者不观可闻。染者不观染等。如火不待于冷而自体是暖者。此异不成。何以故。于世谛中无此义故。外人言。见者与眼等异不须相观。何以故。以相别故。譬如牛马。此中境界显现者。名为识相此是见者。此见者所有行聚眼识所依清净色以为境。此名为眼。形色及显色此名可见。如我所说因有力故。见者眼等异义得成。论者言。此语不然。第一义中牛马二体不可得故。复有人言。想差别故。果因别故。见者眼等异义成者。还同前答。复次鞞世师人言。有异法体。与物和合故。论者言。若汝欲令有异法体与物合者。亦应无第二物。自然有异。以彼立异有别体故。此中作验。无有异法与物和合。何以故。物体故。譬如未有言说已前物体。复次第一义中异无自体。何以故。由总别故。譬如色体。复次第一义中异非起说及觉智因。何以故。由是差别觉智言说因故。譬如色体。复次此异。为在异中。为在不异中。此有何过。若在异中者。如偈曰

  异中无有异

释曰。若彼异法先已是异。而言此异。向彼异中是则无义。异法空故。鞞世师所立异义不成。若于不异中有者。此亦不然。如偈曰

  不异中亦无

释曰。此谓自体而有异过。如彼所说。因义破故。异法不成。外人言。一异者是二边。汝今遮异。异法则无。此异若无。应受不异。是故汝得违悉檀过。论者言。如异法无。已令他解。不异无者。如偈曰

  由无异法故　　不异法亦无

释曰。观异故有不异。已遮异故。不异亦无。云何遮。今说验。第一义中见者可见不得为异。何以故。差别言语观故。譬如可见自体。如是有故。果故。因故。疑智境界故。是等诸因。此应广说。彼如是一异俱遮。由一等不成故。此如偈曰

  一法则不合　　异法亦不合

若有人言。有如是染与染者合。何以故。由合时故。如水乳二。复次第一义中有染者合。何以故。差别言说观故。譬如食者与食相合。论者偈曰

  合时及已合　　合者亦皆无

释曰。如前所说方便异法相合无如是义。由彼外人品初说因。已与其过。为令他解。合无自体。是品中义。是故得成。如般若波罗蜜经中说。佛告极勇猛菩萨言。善男子。色不合不散。如是受想行识不合不散。若色至识不合不散。此是般若波罗蜜。如是等诸修多罗此中应广说

释观合品竟

般若灯论释卷第八般若灯论释卷第九

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观有无品第十五

复次空所对治若有若无。为令他解缘起诸法不断不常故。有此品起。外人言。汝说诸法无自体者。是义不然。何以故。违汝自言。亦立义过故。云何违言。如有人说我母是石女。我父修梵行。他人难曰。若汝父母审如是者。云何有汝。汝若从生则石女梵行义皆不立。汝亦如是。若无自体。云何名诸法。既云诸法。云何无自体。故是违言。亦立义过。论者言。汝谓诸法有自体者。第一义中如何等物。以无譬故。汝语非也。复次若我先于第一义中忍有诸法后立无者可违自言。而实不尔故不相违。又世谛中安立诸法如幻等者我所不遮。无立义过。或有聪明邪慢者言。何等诸法是无自体。若如虚妄分别诸法有体。汝言此法无自体者。此则成我所成。若此诸法从因缘起。而汝意欲此无体者。则违现见。及与世间所解相违。论者言。于真实中无分别识缘。色起者不可得故。此物有故者。如前已遮。世谛所说者。我不遮故。不违现见及世间所解。是故汝所说者。义则不然。复次第一义中若有一法有自体者。则无起义。如偈曰

  法若有自性　　从缘起不然

释曰。若谓诸法有自性者。得如是过。若汝定谓见法有起不能破我者。此中应问。汝言见法有起者。是依他因缘耶。如偈曰

  若从因缘起　　自性是作法

释曰。若是作法者。此则无自体因缘相。云何若法不共无间自分生唯一能起自果者。此是因相翻此名缘云何名作。若法有自体者。则不须作。然今有作故知无体。此中立验。第一义中内入无体。何以故。因缘起故。譬如幻师幻作牛等法。若有自体则不从因缘起。复次有人不解此中譬喻。作如是言。幻咒药力泥草木等是有非无。由此有故。彼象马等形像显现。以是义故。汝譬喻中无成立法。论者言。汝不善说。我引喻者以象马等无体为喻。不取草木有体为喻。复次若谓草木地等有起有实者。前已遮故。有人言。所有诸法从缘生者。皆有自体。如虚空等不从缘起而是有法。汝所出因此非一向。论者言。汝不善说。因缘生法如幻梦焰。世谛中有。非第一义。此义云何。如偈曰

  若有自性者　　云何当可作

释曰。若是作法者。不离无自性。由所对治自体无故。是故出因非非一向。于世谛中虚空等者。亦是无生。犹如兔角。岂是有耶。诸有为法皆无自性。前已观察令他信解。今复立验。第一义中诸法无体。何以故。由作故。又是差别言说观故。如幻人等。若是一物有自性者。则与上相违。复次此中外人立验。第一义中彼内入等皆有自体。何以故。由起自他差别言说因故。譬如因长有短。长为短因。今言自者。与他差别言说为因论者言。诸法无体。先已立验。由汝执故。今当复说。如偈曰

  法既无自性　　云何有他性

释曰。若法有自性者。观自性故。得说他性。自性既无观何说他。汝言自性与他为因者。此因不成。及违义故。又第一义中短长无故。譬喻不成。外人言。第一义中眼等有体。何以故。由体故。譬如火暖。论者言。火无自体。如观阴品已破有及起灭。第一义中亦前已遮。火不成故。譬喻无体。又如偈曰

  自他性已遣　　何处复有法

释曰。体义已遮故诸法无性。由法无故因义不成。语意如是。外人偈曰

  若人见自他　　及有体无体
  彼则不能见　　如来真实法

如汝所言自他性已遣。何处复有法。如偈所说。此语则违。复次有如是体。由相违故。如乌角鸱。论者言。第一义中已遮起故。如偈曰

  有体既不立　　无法云何成

释曰。为遮有执。是故言无。无更无体。虽不言无。无非我欲。何以故。以无别法可执取故。是故亦非。因义不成。复次偈曰

  此法体异故　　世人名无体

释曰。法无体故名之为无。更无一法名为无体。是故汝立因义不成。及违义故。云何违义。汝立相违法为因。由相违破故。所立有法此亦不成故是相违。又第一义中乌鸱无体故。譬喻不成。由此观察自他无体三皆不成。菩萨摩诃萨以无著慧不见诸法若自若他及有无等。云何不见。以升无分别智车故。复次诸浅智人前世未起深大法忍。于彼自他有无等法。言说熏习故。覆障实慧。如前偈言。若人见自他。及有体无体。彼则不能见如来真实法。此义云何。见自他等违正道理。及阿含故。偈意如是。违道理者。如先已说。违阿含者。汝今当听。如偈曰

  佛能如实观　　不著有无法
  教授迦旃延　　令离有无二

释曰。云何教授。如佛告迦旃延。世间多有依止二边。谓若有若无。有深智者不著有无。如是等。又如佛告阿难。若言有者。是执常边。若言无者。是执断边。复次或有人言。若第一义中诸法悉无有者。云何得有见谛法。由世谛中法从缘起故。以智观察从缘起法。无自无他无有无无。遮如是见名为见谛。云何见谛。此缘起法是见实因故。何人见实。谓诸佛子得缘起智日光所照。以此为因故。论者言。怖畏空者作如是说。犹如世人怖畏虚空。执著有对实物依止故。生心欲得远离虚空。远离空者。由彼依止自他等见。如偈言。若人见自他。及有体无体。彼则不能见。如来真实法。此义云何。如是见者。名为邪见。是故佛教迦旃延中。若有若无。二边俱遮是正道理。由此道理不应见彼自他等法。此复云何。如偈曰

  法若有自体　　则不得言无

释曰。先未起时及后坏时。皆无体故。又若诸法有自性者。偈曰

  法有自性者　　后异则不然

释曰。如火以暖为相。后时冷者不然。为此故说不相似喻。如法是常而是起作者。义则不然。此中立验。如证得实法。内入等体则不显现。何以故。由内入等后时异故。如水得火故暖。非暖为水自性。复次经部师言。如我阿含木中有种种界。由如是义水亦有暖。汝云暖非水自性者。此譬不成。论者言。彼阿含中作此说者。谓有比丘获得神通及心自在。随其所缘草木等物欲变为金。若水火等如意则成。故言木中有种种界。种种界者。此谓木中有多界功能。若彼物中有功能者。此物功能非彼物体。若诸功能是彼体者。如地大中有四功能。亦应具以湿暖动等为地大体。不唯取坚。复次毗婆沙师言。世位虽别而体有不异。应如是知。何以故。由是识境界故。如现在者。以是义故。汝先出因言体异者。非我所受。若汝欲不异者。则自义不成。论者言。第一义中现在物者。有亦不成。汝喻非也。若谓有法经历于世及诸位中者。是义不然。何以故。已遮起故。复次于去来中无现在法。非现在故。如虚空花。又世谛中过去未来体亦不成。若僧佉人作如是言。汝先出因言异体者。此义不然。何以故。我立诸法有二种义。一为覆蔽。二入自性藏中。为成此义更须立验。定有如是不灭诸法。何以故。由覆蔽故。譬如日焰翳彼星光。又是识境界故。时节说故。如现在世。是故汝立因义不成。应如是答。现在物者。第一义中有亦不成。何以故。无譬喻故。汝立覆蔽以为因者。义亦不成。此中应说云何验耶。彼未了者终是不了。何以故。以不了故。如虚空花。复次不入自性藏者。终无入义。何以故。以不入故。譬如思。又如自性藏。由此执法。有过失故。如偈曰

  若有是自性　　则不得言无
  自性有异者　　毕竟不应然

释曰。由是自性不变异故。譬喻则无。若是无法则无变异。如石女儿。从小至大。以此变异。令人信者。终不可得。如偈曰

  若无自性者　　云何而可异

释曰。二边有过智者。不受外人言。汝说自性有体无体皆无变异。意欲尔耶。是故汝先所立义破。因亦不成。云何不成。若有自性而变异者。此不然故。论者言。此说不然。何以故。我言无者。明自性空。非欲说有。彼自性法。如偈曰

  实无有一法　　自性可得者

释曰。有自性者不然。而汝为彼烦恼习气。自在力故。作此分别。如先偈说。若无自性者。云何而可异。此变异过。如先已说。遮止二边。及成立者。皆是世谛。非第一义。是故我先立义不破。于世谛中有变异故。亦非所出因义不成。复次鞞世师言。第一义中眼等诸入定有自体。何以故。此等能为有觉因故。譬如涅槃。论者言。汝说有觉因者。此因不成。何以故。如焰中水亦为觉因。是故因非一向。今当更说。如偈曰

  有者是常执　　无者是断见
  是故有智者　　不应依有无

释曰。彼断常执有何过失。法若常者。乐应常乐。苦应常苦。亦无厌苦求乐起于圣道。先已有者不须因故。法若断者。则无染净及苦乐等。虽复受持禁戒空无果故。是皆不然。有无俱者。名为恶见。由此恶见能闭天人趣涅槃门。是故欲出生死旷野者。欲共诸天婇女游戏受乐者。欲断一切受乐。欲受一切戏论。息乐者不应依止有无二见。何以故。依止彼者得断常过故。云何二见是断常过。如偈曰

  若法有自性　　非无即是常
  先有而今无　　此即是断过

释曰。由如是等断常过故。说中道者。应正思惟。依世谛故色等法起。是有觉因。色若未起及已灭者。是无觉因。第一义中觉自体空。以无起故非是有见。如幻所作故。不着无见。由如是故不堕二边。此中为遮诸法自性。令人信解。从缘起法不断不常。品义如此。是故得成。如般若波罗蜜经中。佛告极勇猛菩萨言。善男子。色不断不常。如是受想行识不断不常。若色至识不断不常。此是般若波罗蜜又如月灯三昧经偈曰

  有无是二边　　净不净亦尔
  是故有智者　　离边不住中

如是等诸修多罗此中应广说

释观有无品竟

    般若灯论释观缚解品第十六

复次已遮有无离断常过。此中为明空所对治系缚解脱无自性义。此品次生。有人言。第一义中诸内入等定有自体。何以故。由彼入等有缚解故。此若无者则无缚解。如石女儿不可言说。是故定知。第一义中诸入有体。论者言。诸行相缚如幻焰梦。而彼无智极盲暗者。无始已来为我我所执之所吞食。贪等烦恼杻械所拘。是故如来为令出离生死囹圄爱见关钥故。于世谛中假名相说。正智起时于彼极重贪等结使得远离故。名为解脱。非第一义作此施设。何以故。第一义中有缚解者。义不然故。如来所说有生死者。但假施设。而无于中实流转者。涅槃亦尔。但假施设。而无于中般涅槃者。见是经故。阿阇梨言。若定分别有缚解者。今此系缚。为是诸行。为是众生。若是诸行者。为是常耶。是无常乎。二皆不然。何以故。若是常者。如偈曰

  若诸行是常　　彼则无流转

释曰。诸行是常令人信者。验则无体。若立常者。则无缚无解。缚解无故法体颠倒。立义有咎。复次诸行是常无流转者。是义云何。诸趣往来先后相续。名为生死。若是常者。诸行则无先后差别。而言流转者。义则不然。复次鞞世师。及自部人言。若诸行常则无起灭先后差别无流转者。今诸行无常应有流转。此亦不然。何以故。如偈曰

  无常无流转

释曰。若无常者灭不复起。是故。诸行五种往来者。是则不然。复次无常不流转者。如外诸行。此中立验。第一义中内诸行等流转者不然。何以故。由无常故。如外瓶等。如诸行二种若常若无常流转者俱不然。若汝分别有众生流转者。亦如前答。为此众生常而流转。为无常流转。若俱立者。亦如先说过。是义云何。众生常者则无流转。何以故。不变异故。亦无先后差别故。众生无常亦无流转。何以故。彼已灭者。无起法故。如偈曰

  众生亦同过

释曰。是故众生若常无常有流转者。亦如前所立诸行验过。复次佛法中人欲令诸行及人是无常者。作如是言。未起对治道者。前灭诸行以此为因。后起诸行相续为果。众生亦然。如是诸行流转义成。故我无过。论者言。彼语不善。已灭诸行及与众生。为后刹那作其缘者。如先次第缘中已遮。立义及譬有过失故。此亦如是故我无咎。复次路伽耶陀者言。汝说诸行若常无常皆无流转者。此成我义。云何知耶。如我论中偈曰

  舍摩唯眼见　　一种名丈夫
  多闻说后世　　如人言兽迹
  汝今极端正　　恣食任所之
  过去业皆无　　此身唯行聚
  死者竟不还　　此事汝应信

是故当知无一法从此世至后世。亦无人从后世来入胎。若有人言。此胎已前更有前世。云何验知。谓此入胎初觉次前灭心为次第缘。何以故。由觉故。如后起觉。此譬不然。何以故。唯有一觉故。由此一觉乃至未终。常如是住。故无先世。复次亦无后世。以何道理作是说耶。如调达命终心不作后世初入胎心。何以故。命终心故。如阿罗汉命终之心。论者言。诸行流转者。世谛中不遮。诸行是常计流转者。此亦俱遮。故非成汝所成。复次调达色觉与调达声觉。此非不异。何以故。境界别故。譬如他人身相续觉。由如是验有譬喻故。非世谛中先世不成。复次非无后世。云何验耶。谓彼有漏命终之心。能续后世初受胎心。何以故。由有漏故。与彼命终因心别故。于世谛中义不相违。复次路伽耶陀者言。第一义中彼调达觉与一切人觉亦不异。何以故。由是觉故。如调达觉。论者言。汝语非也。彼调达觉。第一义中前已遮故。又汝言。第一义中与一切人觉不异者。此执不成。于世谛中立不异者。则与世相违。复次彼阿罗汉命终之心有续念无续念者。第一义中此皆不成。譬喻无故。成立有过。若立无漏心不续后世者。于世谛中成我所成。复次犊子部言。如我立义阴入界等。若一若异。若常无常。皆不可说。人亦如此。汝先所说二种过失不能破我。何以故。如是人者有流转故。论者偈曰

  若人流转者　　诸阴入界中
  五种求尽无　　谁为受流转

释曰。无流转故。云何验知。第一义中无人可得。何以故。离五阴外无别体故。犹如兔角。虽实无人而汝谓有。此人我执覆障实慧。如翳眼人见毛轮等。复次偈曰

  若从取至取　　则招无有过
  无取复无有　　其谁当往来

释曰。若从此取向后取者。取体则空。本由取故施设于有取体既空有无所寄无取无有则无质碍。无质碍故无可流转。而汝定谓有往来者。是则不然。外人言。我中有中有取阴故取义得成。无前过失。异部破言。汝舍中有趣生有时。此二中间无取无有。如前过失。汝不得离。复次经部等人言。汝此言者不解我义。何以故。此舍及取。先后刹那同一时故。而言无取无有者。是义不然。如汝前言五求尽无谁流转者。今当答汝有如是人。何以故。向后取住故。此若无者。不可说向后取中住。如石女儿。由有此人从于前取向后取住。云何验知。如佛言曰。我于往昔作顶生王。及善见王。故知有人从此至彼。论者言。如先偈说。若从取至取。则招无有过。此义云何。初有之取不作。后有依止之因。何以故。离有自性有无体故。譬如调达从此一房到彼一房。如汝所言。有彼诸取能成人者。是义不然。何以故。由取故。如余人取。是故偈言。无取复无有。其谁当往来。如是诸行及以众生。第一义中有流转者。是皆不然。复次执有解脱者。亦应观察。此解脱者。为是诸行。为是众生。为当是人。若言诸行得解脱者。今此诸行。为是常耶。是无常乎。若汝欲令第一义中诸行常者。是则不然。如偈曰

  诸行涅槃者　　是事终不然

释曰。第一义中以无起故诸行常者。于世谛中亦不成故。若第一义中诸行无常得涅槃者。是亦不然。何以故。由无常故。如外地等。若谓众生得解脱者。是亦不然。如偈曰

  众生涅槃者　　是事亦不然

释曰。若常无常若有分别。若无分别得涅槃者。是皆不然。云何众生是常不得涅槃。无视听等诸根具故。譬如虚空。若非质碍。又无视听。而是有者。世所不信。如石女儿。若谓无常得涅槃者。是亦不然。何以故。若无常者无解脱义。如外地等。已验无常不得解脱。外人所立法体差别得解脱者。是皆不成。立义过故。复次婆私弗多罗言。如我立义。言有人者。不可说常亦非无常。由如是故解脱义成。无如上过。论者言。汝谓第一义中人是实有不可说常及以无常得解脱者。是亦不然。何以故。藉因施设故。譬如瓶等。如是则破。若实法者亦是无常。譬如色等。由此验故。汝立实人者。则为可说。体是无常。汝言法体差别不可说者。此言则坏。立义过故。复次无余涅槃一刹那时。人若有体即是常过。人若无体即是断过。若言无余涅槃彼刹那时不可说人有体无体者。此则与我中论义同。如经偈说

  解脱若有我　　有我即是常
  解脱若无我　　无我即无常

复次此中立验。第一义中缘人之觉无实境界。何以故。由觉故。譬如缘瓶等觉。由验彼人无一物故。第一义中则无解脱。若汝定言人是实法。何以故。由可识故。譬如色等者。此义不然。无常等物。同是可识。无别体故。如兔角等因非一向。复次自部人言。由因缘故。展转相续。诸行增长。若与贪等。烦恼共起。障碍善趣。贪等有故。缚义得成。若被缚者。听闻正法。正念思惟。发生明慧。除无智暗。得离贪等。名为解脱。以是义故。缚脱得成。汝云何言。无缚无解。论者偈曰

  诸行生灭相　　不缚亦不解
  众生如前说　　不缚亦不解

释曰。如先已说。诸行是常。诸行无常。皆无流转。如外地等。今亦如是。诸行众生若常无常有缚解者。此皆不然。如外地等。是故诸部如所分别。第一义中一切诸行流转涅槃者。此皆不然。其执云何。彼谓诸行新新灭坏。或初如是住。乃至后时方有坏者。或谓不可说常及无常者。此诸行等皆无流转及般涅槃。何以故。是起灭故。譬如瓶等。如先偈言。诸行起灭者。不缚亦不解。众生如前说。不缚亦不解。诸行无住。何以故。刹那刹那别时而起。此相位中有缚解者。此义不然。如前已说。汝言诸行与贪俱起者。此已灭故。已灭之法得解脱者。是则不然。未来当起诸行刹那得解脱者。此亦不然。以相违故。偈言诸行起灭者。无缚解故。复次阿毗昙人言。如我俱舍论偈曰。无学心生时。诸障得解脱。汝云何言都无缚解。论者言。彼生时者。若有染污。若无染污。俱无解脱。有过失故。不可说者。彼染污时亦如上生时。若有染污若无染污。俱无解脱。不可说故。复次经部人言。相续道中有缚解故无过。论者言。彼相续者。无实体故。相续道中若有染污若无染污。亦无解脱。如前已破。于世谛中缚解成故。无断灭过。若执众生有缚解者。今答此义。如前偈说。众生无体故。缚解法亦无。又如偈说。诸行常无常。皆无缚无解。众生常无常。亦无缚无解。此意正尔。复有人言。有彼众生没在诸取。故名为缚。此缚息故名得解脱。然此众生常以无常皆不可说。先言诸行若常无常皆有过者。我无此咎。论者偈曰

  若为诸取缚　　缚者无解脱

释曰。因诸取故说为取者。此人正为诸取缚故。名解脱者。义则不然。缚解二法性相违故。复次第一义中调达之取。此取不作彼调达者。何以故。由取故如耶。若取若定如此先无其取而有彼者。义则不然。如偈曰

  无取故无缚　　何位人可缚

释曰。若离取位无别人位。以是义故。无人可缚。偈意如此。复有人言。定有众生是其可缚。何以故。由有缚故。如有杻械枷锁等具幽禁彼人。由此诸取为能缚故。知有众生是其可缚。论者偈曰

  若缚者先缚　　可言缚能缚
  而先实无缚　　去来中已遮

释曰。汝谓先有缚具故有可缚众生。而缚者之先实无缚具。云何验耶。由调达无缚何以故。以同时故。如调达体。复次已缚者不缚。何以故。已被缚故。已被缚者不复更缚。如不解脱未缚者亦不缚。何以故。以无缚故。如解脱者。缚时亦不缚。何以故。彼缚时者。一分已缚。一分未缚。有二过故。复次不可说者。亦无缚义。何以故。不可说故。如解脱时是已脱者。此则不然。复次去来品中。已广分别已去未去及以去时有初发者。三皆不然。此亦如是。已缚未。缚及以缚时有缚初起者。三皆不然。云何不然。彼已缚者有更缚初起。义则不然。何以故。由已缚故。譬如久已缚者。彼未缚者有缚初起。是亦不然。何以故。由未缚故。譬如久解脱者。若谓缚时有缚初起者。是亦不然。何以故。二俱过故。及不可说故。如解脱时。问曰。我意定谓有如是缚。何以故。有相违故。譬如智慧对治无知缚。对治者。所谓解脱。由解脱故缚则非无。答曰。若汝定谓。有解脱者。为已缚者。为未缚者。为正缚时有解脱耶。三皆不然。如偈曰

  缚者则无脱

释曰。缚对治道未起之时。此名为缚。不得名脱。何以故。无对治故。如具缚者。偈曰

  未缚者无脱

释曰。由缚空故。缚空者。于世谛中缚无体故。如久解脱者。若谓脱时名解脱者。谁是脱时。汝应定说。若已缚者名为脱时。是亦不然。偈曰

  缚时有脱者　　缚脱则一时

释曰。缚脱同时不欲如此。是故彼人。复欲取缚。复欲取解。若如此者。有缚解过。不能避故。由如是故。第一义中有解脱者。此义不然。如汝上言。有相违故。及对治者。此因譬喻二皆不成。立义有过。外人言。第一义中解脱是有。何以故。求解脱者有希望故。果若无者。终不为彼起希望心。譬如屯度婆蛇顶珠。由定有故。求解脱者起希望心。如偈曰

  我灭无诸取　　我当得涅槃

释曰。云何当知有涅槃耶。譬如薪上火灭。是故定有涅槃可得。论者言。汝谓我灭无诸取我当得涅槃者。此执不然。如偈曰

  受如是执者　　此执为不善

释曰。若起如是缘取我当得涅槃者。此非善执。何以故。此不善执障解脱故。偈意正尔。复次取无自体。而计取为境缘。此所起邪分别智名不善执。是故汝言。求解脱者有希望故。以此为因者。此因不成。如是谛观诸行众生。及彼人等有缚脱者。此皆不然。如阿阇梨教诸学者。说此偈曰

  不应舍生死　　不应立涅槃
  生死及涅槃　　无二无分别

释曰。第一义中生死涅槃一相无差别。如虚空相故。无分别智境故。不集不散。非实法故。是故不应作是分别。舍离生死安置涅槃。若立若谤者。皆分别智。自在可得物境界故。若是可得物境界者。此等皆是集散法故。复次或有众生堪以涅槃而教化者。诱引彼故说有涅槃。云何安立。但于未来不善诸行分别不起烦恼息相。是则名为寂灭涅槃。故名安立。又为令彼厌离生死。作如是言。生死苦多。汝应舍离。何以故。诸行展转从缘起者。自体无实。如幻梦焰。即说此等名为生死。舍离此故名为涅槃。世谛门中作如是说。非第一义。何以故。第一义中诸行空故。烦恼息相名涅槃者。此等亦无。不应置立别有涅槃。由彼诸行自体无起。本来寂灭如涅槃故。而欲安立为涅槃者。此义不然。舍生死者。亦不应尔。如前偈言。不应舍生死。不应立涅槃。生死及涅槃。无二无分别。应如是解生死涅槃。第一义中无差别故。若谓此二境界差别。由境别故慧亦别者。二俱不然。如彼外人品初所说。第一义中有是生死有缚解故以为因者。此义不成。由彼说验成立法者。论者前来已与彼过。令他解悟生死涅槃空无所有。是此品义。是故得成。如般若波罗蜜经中。佛告极勇猛菩萨言。善男子。色无缚无脱。受想行识无缚无脱。若色至识无缚无脱。是名般若波罗蜜。又如梵王所问经说。佛言。梵王。我不得生死。不得涅槃。何以故。言生死者。但是如来假施设故。而无一人于中流转。说涅槃者。亦假施设。而无一人般涅槃者。如是等诸修多罗此中应广说

释观缚解品竟

般若灯论释卷第九般若灯论释卷第十

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观业品第十七

释曰。今此品者。亦为遮空所对治。令解业果无自体义故说

阿毗昙人言。彼于前品中说诸行流转。众生及人等亦皆流转者不然。而彼验中立义言。诸行若常若无常者。是断常过故。有流转者不然。而说诸行毕竟无有流转。彼先作此说故。我今此中说常无常。无如是过。而有诸行流转。作是说者。欲令物解。第一义中定有如是内诸入诸行生死与业果合故。此若无者。不见诸行与业果有合。譬如石女儿。今有诸行与业果合故。而有生死。是故我今观察业果。其义如阿毗昙中广说。故彼偈言。自护身口思。及彼摄他者。慈法为种子。能得现未果。所言思者。谓能自调伏远离非法。与此心相应思故名为思摄他者。谓布施爱语救护怖畏者。以如是等能摄他故。名为摄他。慈者谓心心即名法。亦是种子。种子者亦名因。为谁因耶。谓果之因。是何等果。谓是现在未来之果。云何名心为种子耶。谓能起身口业故。名为种子。云何名非法。违法故名为非法。非法者谓恶及不善等。云何名无记。谓违法非法名为无记。无记者有四种业。一者报生。二者威仪。三者工巧。四者变化。又无记者。不记善不善故。名为无记。又无记者。不起善不善果。亦名无记。有如是等差别。俱舍论中亦有二种。其义云何。故论偈曰

  大仙所说业　　思及思所起
  于是二业中　　无量差别说

释曰。云何名大仙。声闻辟支佛诸菩萨等亦名为仙。佛于其中最尊上故。名为大仙。已到一切诸波罗蜜功德善根彼岸故。名为大仙。复次前偈列名。今当别释。其义云何。故论偈言

  如前所说思　　但名为意业
  从思所起者　　即是身口业

释曰。云何说思但是意业。谓思与意相应名为意业。复次此思于意门中得究竟故。名为意业。非身口业。云何名从思所起。谓知已知已作作者名思所起业。此业有二种。谓身及口。若于身门究竟。口门究竟者。名身业口业。说二业已。次说无量种差别。云何名无量种差别耶。故论偈言

  身业及口业　　作与无作四
  语起远离等　　皆有善不善

释曰。语起者。谓以文字了了出言。名为语起。云何名远离。谓运动身手等。运动者。谓起念言。我当作此善业。从初受善业思。后受善业思。所起之人。若作善业。若不作业。远离无作色体恒生。不远离者。亦如是念言。我当作此不善业。若身若口若意从初不善业刹那所起之人。若作恶业。若不作从不善因。名不远离。无作色体恒生。云何名作无作色。以身口色令他解者名为作色。不以身口色令他解者名无作色。故论偈言

  受用自体福　　罪生亦如是
  及思为七业　　能了诸业相

释曰。云何名受用自体。谓檀越所舍房舍园林衣服饮食卧具汤药资身具等。云何名福。谓捞漉义。见诸众生没溺烦恼河中。起大悲心。漉出众生。置涅槃岸故名为福。非福者。谓作种种不善之事。能令众生入诸恶道。云何亦是受用自体。谓违背福故。名为非福。解福非福已。次解思义。以何法故。名之为思。谓功德与过恶。及非功德与过恶。起心所作意业者名思。彼论如是以七种业说为业相。乃至坐禅诵经听闻记念等。亦名为业。皆摄在七种中故。而不别说。有此业故。见业与果合。与果合者。谓于五趣中有五阴起相。是故品初说业与果合为出因者。第一义中有生死义得成。以有缚有解故。有生死体。论者言。今此业者。为一起已乃至受果已来恒住耶。为一刹那起已即灭耶。是皆不然。其过如论偈说

  若住至受果　　此业即为常
  业若灭去者　　灭已谁生果

释曰。若业自体起已无间不坏。后方有坏者不然。堕常过故。阿毗昙人言。如芭蕉竹苇等。于后与果已即坏。是故无过。论者言。竹苇等一一刹那随坏不住。后时相似相续断者。于世谛中说坏耳。若第一义中说业如竹苇等相续至受果者不然。若言有业法自体先后俱不坏者。难令物解汝非无过。阿毗昙人言。初未得坏因故不坏。后时得坏因来方坏。有何过耶。论者言。此义不然。汝立有坏因者。而彼物不是坏因。与此物异故。是因故。譬如余物。如阿含中说。身及诸根等一刹那起已不住。汝义与经相违。若汝欲避此过。而受起已无间即坏者。是亦有过。业若灭者。即无自体。若汝意谓。业正灭时能与果者。而此灭时名半灭。半未灭能与果者不然。同前所答过。若汝言不可说灭已与果不灭与果者。此名不可说业。若不可说业于第一义中能与果者不然。不可说故。譬如欲生时。汝所见者不能坚固。出因不成。亦违汝义

阿毗昙人言。有相续故。我义无违。云何知耶。故论偈言

  如芽等相续　　而从种子生
  由是而生果　　离种无相续

释曰。此谓从芽生茎。乃至枝叶花果等各有其相。种子虽灭由起相续展转至果。若离种子芽等相续则无流转。以是故其义云何。故论偈言

  种子有相续　　从相续有果
  先种而后果　　不断亦不常

释曰。云何不断。谓有种子相续住故。云何不常。谓芽起已种子坏故。内法亦尔。如论偈说

  如是从初心　　心法相续起
  从是而起果　　离心无相续

释曰。此谓慈心不慈心名为业。此心虽灭而相续起。此相续果起者。谓爱非爱有受想故。若离心者果则不起。今当说相续法。其义云何。故论偈言

  从心有相续　　从相续有果
  故业在果先　　不断亦不常

释曰。云何不断。谓相续能起果故。云何不常。不至第二刹那住故。此中作验。第一义中有如是业果与众生名字诸行合诸有欲得胜果众生。如来为说得果方便故。此若无如来不说得乐果方便。譬如虚空花鬘。今说有方便者。其义云何。故论偈言

  求法方便者　　谓十白业道
  胜欲乐五种　　现未二世得

释曰。法者谓果法。方便者谓得果法。因因者谓白业。果者谓现在未来得五欲乐。得何等果。谓得报果依果。白谓善净。能成就福德因缘者。从是十白业道生。十者谓不杀不盗。不邪行。不妄语。不两舌。不恶口。不无益语。不嫉。不恚。不邪见等。名十白业。亦名十善业道。皆从身口意生。云何名胜果。谓于人天趣中得最胜人天。其义云何。故论偈言

  人能降伏心　　利益于众生
  是名为慈善　　得二世果报

释曰。以是故佛说有此得果方便。如所说者其义得成。论者言。汝说业果有相续故。而以种子为喻者。则有大过。如论偈说

  作此分别者　　得大及多过
  是如汝所说　　于义则不然

释曰。云何不然。此谓如汝向分别有种子相续相似法体者不然。何以故。种子有形有色有对。是可见法得有相续。今思惟是事尚不可得。何况心之与业无形无色无对不可见。刹那刹那生灭不住。欲与为验者。是验不成。又从种至芽者。为灭已相续至芽。为不灭相续至芽。若灭已至芽者。芽则无因。若不灭而至芽者。应从初种子常生于芽。若尔者。一种子中则生一切众芽。是事不然。有大过故。正量部人谓阿毗昙人言。如汝所说。有人相续能起天等相续业者。是义不然。何以故。种性别故。譬如荏婆子不生庵罗果等。若善心次第能起善不善无记心。无记心次第能起善不善心。不善心次第能起善无记心者。义皆不然。乃至欲界系心次第能起色界无色界系心。及起无漏心。无漏心复展转起欲界色界无色界系心。亦如上说芽起者。今悉不然。如前所立验中已总破故。有作善者。是亦不然。我今当说顺业果报正分别义。是何分别。如前分别种子相续相似者。如我所说。无彼过故。过垢不能染。说何等耶。谓说正分别义。是谁说耶。如阿含经中偈言。诸佛及缘觉。声闻等所说。一切诸圣众。所共分别者。分别何等。故论偈言

  不失法如券　　业如负财物
  而是无记性　　约界有四种

释曰。此谓不失法在。如债主有券主。虽与财而不散失。至于后时子本俱得。业亦如是。能得后果。业虽已坏由有不失法在。能令行人得胜果报。亦如债主既得财已。于负债人前毁其本券。如是如是。不失法能与造业者果已。其体亦坏不失法者有几种耶。约界有四。云何为四。谓欲界色界无色界及无漏界。不失法者是何性耶。是无覆无记性。无覆者亦名不隐没。无记此谓不说善不善故名为无记。此不失法。何道所断。故论偈言

  不为见道断　　而是修道断
  以是不失法　　诸业有果报

释曰。此谓见苦集灭道所不断。何时断耶。谓修道进向后果时断。复次见苦所断不善业。虽断由此不失法在。见苦时不断者。是不失法。能与果故。如目犍连被外道辱。离波多比丘被梵摩达王十二年禁。目犍连等虽获圣果。由不失法在故。受宿不善业报。故论偈言

  若见道所断　　彼业至相似
  则得坏业等　　如是之过咎

释曰。此不失法。若为见道所断。若共业俱至后世者。是则有过。有何过耶。若不失法同见道所断。随眠烦恼业亦俱断者。即坏业果。坏何等果。谓坏见道所断不善业果。是义应知。修道若不断者。圣人应具足有凡夫业。以是故烦恼业为见道断。不失法不为见道断。是故言如业见道断不失法修道进向后果时断。彼度欲界向色界时。度色界向无色界时断者亦如是。故论偈言

  一切诸行业　　相似不相似
  现在未终时　　一业一法起

释曰。相似者。谓同类业。于现在命终时。有一不失法。起总持诸业。不相似者。谓业种差别。如欲界业色界业无色界业。有无量种。复次有几种业为不失法持耶。故论偈言

  如是二种业　　现在受果报
  或言受报已　　此业犹故在

释曰。二业者。谓思及从思生。或有人言。业受报已而业犹在者。以不念念灭故。又如前说无量种差别者。亦一一有一不失法起持故。何故不失法与果已犹在而不更数数与果耶。谓已与果故。如已了之券。已还财讫纵有券在更不复得。不失法亦如是。已与果故更不数数得果。此不失法于何时灭耶。故论偈言

  度果及命终　　至此时而灭
  有漏无漏等　　差别者应知

释曰。此谓修道时断者。如前命终时。相似不相似业。共有一不失法持者是也。如须陀洹等度果已灭阿罗汉及凡夫人死已而灭。此不失法复有差别。云何差别。由漏无漏业别故。不失法亦有漏无漏。彼如是故。不失法亦从种种业起。能令众生受方土受趣受色受形受信受戒等差别果。与果已然后方灭。以是故。其义云何。故论偈言

  虽空而不断　　虽有而不常
  诸业不失法　　此法佛所说

释曰。空者谁空。谓诸行空。如外道所分别。有自性法者无也。而业不断者。有不失法在故。云何为有。有谓生死。生死者。谓诸行于种种趣流转故。名为生死。云何不常。业有坏故。云何名不失法。谓佛于处处经中说。作此分别者应尔。以是故。如我先说业与果合为出因者。义非不成。论者言。汝所说者。是皆不然。今为汝说正业因缘。其义云何。如论偈说

  业从本不生　　以无自性故
  业从本不灭　　以其不生故

释曰。我宗中业无有生。如是种子相续者。第一义中亦无有生。是故汝所立譬喻无体。而有阙譬喻过。诸业云何不生。以无自性是故不生。今且答正量部人说种子有相续过。汝谓有业与果合而无断常过者。云何无过。谓由有不失法在。我今推求毕竟无故。如上偈说。业从本不生。是不失法第一义中亦不成。若有业生者。为业故可有不失法。业既无体。不失法亦无体。因不成故。违汝义宗。云何违耶。谓业与果合者。翻成世谛。令物解故。如汝前谓阿毗昙人有种子相续过者。此义不然。如阿毗昙人先作种子相续譬喻者。有何意耶。今为汝说。此阿毗昙人有如是意。谓种子相续。展转因果随起不坏故。而以种子相续不断不常为喻者。如是欲得汝先说种性别故为因者。因义不成。由有心及心数法相续起无别故。又汝出因非一向有别过云何非一向。今现见有别相续能起别果。云何知耶。如牛毛生莞角生设萝(似荻而坚中生于陆地突厥西胡用为箭笴尔雅云[竺-二+(嶙-山)]坚中盖竹之类也)。正量部人言。阿含经中佛如是说。有不失法。以此法故。不断不常。诸体得成。彼言以业不起。不失法亦不起。为出因而道。我因义不成者。此语不然。论者言。如佛所说。若无起者彼即无坏。汝今欲得受此义者。成就我所欲。然汝宗中不受此法故。若汝立自宗义。谓无起无坏者。其义不成。复次汝立诸法有自体者。决定应受。业无自体。若诸法有自体者。即为有过。其过云何。如论偈说

  业若有自体　　是即名为常
  而业是无作　　常法无作故

释曰。此谓有自体者。即为是常。若常即是不可作业。何以故。常法不可作故。亦无变坏相。复次若业是无作。有何过耶。其过如论偈说

  若业是无作　　无作应自来
  住非梵行罪　　今应得涅槃

释曰。梵者谓涅槃。若行涅槃行者。名为梵行。住此行者名住梵行。翻此者名不住梵行。何等是住梵行。谓作善业已而得涅槃名住梵行。何等是住非梵行。谓不作善业者名住非梵行。若此业不作自得涅槃者。一切行非梵行人皆应得涅槃。非独行梵行者得涅槃。有如是过咎。然于世谛作瓶作绢等。亦有是过。其过如论偈说

  破一切世俗　　所有言语法
  作善及作恶　　亦无有差别

释曰。此谓如世间言。彼是造罪众生。彼是造福众生者不然。以汝言不作罪福自然得故。其过云何。如论偈说

  以有业住故　　而名不失者
  亦应与果已　　今复更与果

释曰。住者云何。谓自体在故。更与果者。由业住故。虽与作者果已如有券在已偿之债重须偿故。业亦如是。由有体在还得与果。阿毗昙人复言。第一义中有如是诸业。彼因有故。此业若无而有因者不然。譬如龟毛衣。今有业因。谓诸烦恼。是故如所说因。第一义中定有诸业。论者言。此语不善。如论偈说

  烦恼若业性　　彼即无自体
  若烦恼非实　　何有业是实

释曰。性者谓因。此说烦恼是业因。譬如泥为瓶体。如是烦恼为业体。云何非实。谓烦恼无自体故。云何无自体。谓先所观察已遮起法。亦遮诸体有自体。此谓烦恼非是业因。以是故因义不成。及违汝义。云何违耶。谓于世谛中以烦恼为业因。非第一义。是故言违。复次如先观烦恼品中偈说。爱非爱颠倒。而为所起缘。彼既无自体。故烦恼非实。先已广遮故。阿毗昙人言。第一义中有如是烦恼。以有果故非无而受果。譬如聋者耳根果及耳识。今有此烦恼果。云何名果。果谓业也。如是第一义中有烦恼故。非因义不成。亦非违义。如我所欲之义得成。复次有业。以有果故非无。如虚空花。由有业果是身非无业而有果。以是义故。当知有业。论者言。是义非也。汝不正思惟邪见所恼。虚妄分别作是说耳。其过如论偈说

  说业及烦恼　　而为诸身因
  业烦恼自空　　身从何所有

释曰。何处说耶。谓诸论中诸贤圣等约世谛说。若于第一义中观察者。是皆不然。如我宗中先已说方便故。此谓诸法上中下贵贱好丑等种种果报无有自体。如说业及烦恼无自体。身亦无自体。以是故。烦恼为业因业为身因者。是皆不然。所说之过。今还在汝。所立譬喻。皆亦不成。复次阿毗昙人言。第一义中有如是业有受果者故。此若无则无彼受者。譬如虚空花鬘。今有业故有受果者。其义云何。故论偈言

  为无明所覆　　为爱结所系
  而于本作者　　不一亦不异

释曰。明所治者。名为无明。覆者谓翳障慧眼。云何为名。名谓众生。何故名众生。谓有情者数数生故。云何名爱。爱谓贪着。着即是结。与谁为结。谓系众生。云何名系。谓与贪等相应故。如无始经中所说。众生为无明所覆。爱结所系。于无始生死中往来受种种苦乐。如是诸众生等。自作恶不善业。还自受不善果报。此受业果者。即是我所欲得作者。然此作者。不可说一异故。是有受果者。由第一义中有彼业故。论者言。汝所说者。义皆不然。此论初已来一切诸法皆已观察。无有从缘起果。亦无不从缘起果。以是故。其义如论偈说

  业不从缘生　　不从非缘生
  以业无自体　　亦无起业者

释曰。此谓业等无起业有三种。一谓业。二谓果报。三谓受果者。今推求业无起故。作者亦无起。作及作者先皆已遮。无有实体。如我所说无业及无作者方便。其义云何。如论说偈

  无业无作者　　何有业生果
  既无有此果　　何有受果者

释曰。以是故。汝言第一义中有业有受果者其义不成。亦违汝义。云何违耶。谓翻以世谛令物解故。阿毗昙人言。拨无业无果者。是邪见过。能障慧眼。彼说中论是真实见者不然论者言。汝语非也。其义云何。如论偈说

  如佛神通力　　现作化佛身
  于是须臾间　　化身复起化
  此初化身佛　　而名为作者
  化佛之所作　　是即名为业

释曰。此谓作者与化相似。展转从缘起。无有我体故。而此所作业者。亦如化人无有自体。譬如化佛复起于化。如是身口业等所作之事。虽无有实而可眼见。应如是知。烦恼者名为三毒。九结。十缠。九十八使等。能起身业口业意业。分别今世后世善不善无记苦报乐报不苦不乐报。及起现报生报后报等。如是诸业一一皆空。设有所作。亦无自体。其义云何。如论偈说

  业烦恼亦尔　　作者及果报
  如乾闼婆城　　如幻亦如焰

释曰。此谓业等从因缘和合生。如幻化无实但可眼见。是世谛中有非第一义。复次欲得善趣。及欲得涅槃者。亦是世谛所说。如汝谓我拨无业果是邪见过者。过亦无体。阿毗昙人言。彼虽欲得于世谛中有一切法。而于第一义中诽谤无一切法者。还不免过。论者言。如经中偈说。有体既不成。无体亦不成。又如经偈说。有者是常见。无者是断见。是故有及无。智者不应依。汝言拨无业果者。我不欲尔。以是故汝先谓。我不免过者。我无此过。复次汝闻第一义中诸体无自体。业果及业果合作者及受者。皆空无体。而谓虚住梵行空无所获者。是愚痴心。为欲开发愚痴障故。以业等有而令物解。云何解。谓解如佛以神通力现作化佛等事故。此品初与外人所说过。而以业果无自体义令众生解。是品义意以是故。如梵王所问经说。佛告梵王。若无业无果者。即是菩提。如是菩提无业无果。得菩提者亦无业无果。彼得授记及圣种性亦复如是。若无业无业报者。彼圣种性亦不能起身口等业。复次如观缘品中说。所有诸物体皆无有自性。已遮眼等非是异处及自在等有。何以故。眼等不从赤白众缘起。众缘亦不能生眼入等。亦如观本际品。已遮生死本际无自体故。如无第二头。不可说第二头眼有病。如观行品偈说。大圣说空义。令离诸见故。若复执有空。诸佛所不化。此已遮诸见及无明等烦恼故说空。若复执空。云何可化。亦如以水救火。若水中有火起者。则不可救。如观苦中已遮苦四义不成。亦遮外万物等四义不成。何以故。苦不名自作法不自作法。以无自体故。何有人作苦。若说有我法各异相。当知是人不得法味。若言诸法是善是不善是无记是有漏无漏有为无为等别异者。是人于甚深寂灭法中。为无义利。如本住中已遮。本住不可得故。亦遮三世无有戏论分别。以是故诸法则空。如作作者中说。决定有作者。不作决定业。决定无作者。不作无定业。何以故。决定业无作。是业无作者。如刀不自割。指不自触。以是故定作者无作。作者亦无业。如是先后俱等不可得故。复次若无作等法。则无有罪福。罪福等无故。罪福果报亦无。若无罪福果报。亦无涅槃。以是义故。于世谛中说有诸业。非第一义。如梦所见不应于中妄生忧喜。如幻所作。而无实体。如乾闼婆城日出时现。但诳人眼而无所有。如佛告诸比丘。生死无际。诸凡夫人不解正法故。为说生死长远。又如佛言。诸比丘为欲尽生死故。应随顺行。亦如无上依经说。佛为怜愍世间住于乱慧无因恶因诤论者故。于世谛中说有诸法。有我。有人。有众生。有命者。复次佛婆伽婆见彼众生生死相续未起对治故。说生死长远。所以者何。为欲尽彼生死际故。建立众生。于勤精进善观察者。了彼生死及与涅槃无少差别可得。以是故无有生死。亦无涅槃。又如观缘中说。是作缘中无。非缘中亦无。彼中遮作不可得故。亦不与缘合而言有作不然。如观三相中。已遮生故。若生等不成。则无彼有为。有为法无故。何得有无为。又如遮去与去者。若谓去法即是去者。作者作业是即为一。若言去法异于去者。则离去者而有去法。亦离去法而有去者。二俱有过。如观圣谛亦说。第一义中空无体义。如彼偈说。诸佛以是故回心不说法。佛所解深法众生不能入。何以故。第一义中无有空执。若言空者。是执着相。如遮见中已遮边等四见。若说有边。则无后世。若说无边。亦无后世。何以故。第一义中诸法空故。如偈说。何处。何因缘。何人起诸见。若言有见起者不然。如遮合中言。物果不从缘合不合生。以果无故。合法亦无。如遮成坏。有体不生体。亦不生无体。无体不生体。亦不生无体。亦破三时无有相续。以是等义应知如遮缚解无有自体。以无众生往来阴界诸入五种推求无往来者。以是故第一义中不说离生死外别有涅槃。如宝胜经偈言。涅槃即生死。生死即涅槃。实相义如是。云何有分别。如遮有无中。已遮诸法若有若无。若有人言。见有见无见自他性。是则不见真实道理。如金光明女经中说。无明体相本自不有妄想因缘和合而生。善女当观诸法如是。何处有人及以众生。本性空寂无所有故

般若灯论释卷第十般若灯论释卷第十一

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观法品第十八

释曰。今此品者。亦为遮空所对治令解诸行我我所空故说

诸外道等虽说我见有无量种。亦以五受阴为所缘。是故今当次观诸阴。如佛所说。若有沙门婆罗门等言见我者。但见五阴。实无有我。有异僧佉人作是说言。身相形色及四大聚诸根。诸根聚诸识等为我。论者言。汝于四大诸根阴相。若总若别。起我分别者。是事不然。如论偈说

  若我是阴相　　即是起尽法
  我若异诸阴　　是则非阴相

释曰。我者是世谛义。起于言说称云我者以阴为境。僧佉人复言。随有阴处我义得成。即是我所立义得成。论者言。如汝意者。我是诸阴。若我是阴。即起尽法。此中说验。第一义中四大及造色聚诸根。诸根聚诸识。及识身等。非我是起尽法故。譬如外四大等。果故因故。可识境界故。亦果报故。以是等因广为作验。有自部论师言。我若是阴。一一身中有多阴故。亦有多我。复次我若是阴。即起尽法。以彼诸阴起尽法故。即自破汝无起无尽差别我也。差别法体破故。汝立义有过。复次我若是阴。即起尽法。然外人不欲令我是起尽故。其所计我无起无尽者。亦复不能令我信解。以是故我今说验。第一义中毕竟无我。何以故。无起无尽法故。譬如兔角。复次我者若是阴。即起尽法。以是故我今说验。第一义中色等五阴决定非我。何以故。起尽法故。譬如瓶。如是阴者果故因故。暂有故。忧喜因故。邪智正智疑智因故。非我是诸因。义广如前验。释即阴已。我异阴者。鞞世师人言。身及诸根觉等之外。而别有我。能与苦乐等作依止。是作者。是无心。是常是遍。作如是说。复有僧佉人言。有如是我。云何有耶。因果之外别有于我。然非作者。是受食者。是净是遍。无听闻等具。僧佉鞞世师等谓论者言。如彼所说。立验方便。我无此过。复有以丈夫为因者。亦言无如上过。以是义故。鞞世师等言。诸阴外别有我者。亦复不能令物信解。论者知故说偈答云。我异诸阴则非阴相。非者言无。非阴相者。阴无我故。言无阴相。今当说验。第一义中色阴等外无别有我。无阴相故。譬如石女儿。鞞世师人言。如彼涅槃。非阴相而是有我体。如是虽非阴相而亦是有。论者言。如经偈言。亦无有一处一法是无为。此言无为涅槃等。并已遮故。一向是无。然常遍我非苦乐等依止。有起故。譬如色等。汝所立我亦非是遍。何以故。是实故。譬如瓶。应如前验。鞞世师人言。如虚空是实是遍。我亦如是。如彼所立验者不然。非一向是实者皆不遍。论者言。汝立虚空是实者。前已遮故。如遮我是遍故亦遮虚空是遍不非一向是实者皆遍。复次我亦如是非是作者。何以故。非质碍故。譬如思业。我亦非常。是实法故。譬如瓶。我者是可知故非常。是一物故非常。是等诸因。须广出验。复次我者亦非无因。以有体故。譬如瓶。第一义中思不是我。是一物故。譬如柱。我者非常非遍。亦不无因。是一物故。或为正智邪智疑智因故。有时为喜为怒因故。譬如柱。有是等验。次破僧佉人别执。有我是受食者。于第一义中无我受食。所言疑智因者。如夜见杌。我是一物故。如瓶。应如是说。复次有外人作如是意。谓论者言。彼既不令我是一物。复还简别言我。是物是体是无常是不遍。是疑智等。作是说者其义不然。亦如有人自生分别。譬如石女实自无儿。何得示他青黄色耶。汝今所说令物解者。是则虚妄。论者言。汝语非也。取后有识者。谓施设我。是故说识为我。如般若经中偈言。调心为善哉。调心招乐果。又如阿含经偈言。我与己为亲。不以他为亲。智者善调我。则得生善趣。此谓世谛中假说有我。是诸外道分别所执悉皆遮故。我无过咎。复次身及诸根非常遍我不共取境因可取故譬如柱。如是诸根是可量故。应广说验。僧佉人言。以何义故阴中无我。若彼阴中定无我者。汝喻无体。何以故。柱等诸物亦有我故。论者言。我亦不论有我。但遮诸阴及身根等非常遍我不共取境因。此是我立义意。如汝妄说不能依我所立验解。复次诸修行者自于此阴当善观察。如此我者。为是阴相。为非阴相。如上偈说。若我是阴即起尽法。以是故言彼阴非我。以起灭故。譬如诸阴。复次非阴相者。如上偈说我若异诸阴。是则非阴相。以是义故。无有我也。无阴相故。譬如空华。其义如是。复次若我非阴相。我则无生。如空华。如石女等。若言是阴相者是亦无我。何以故。是起是因是果是物故。譬如瓶。行者如是观察已。即得通达无我。复次鞞世师人言。有如是我。见境界故。我若是无。众生身中则无有我。根等无心。犹如窗牖而得见物者。是事不然。由我与根相异故和合乃见。彼见是我故知有我。论者言。以见境界言是我者。义亦不然。何以故。我见境界者。此验无体。如是若无我者先所见物后见还识是先所见知有我者。无如是因及譬喻。若立身中得有我者。无如是因及譬喻。若以能忆先所更事知有我者。无如是因及譬喻。若以有业有果报可得故知有我者。无如是因及譬喻。如是等因悉当广遮。鞞世师中有聪慢者。谓论者言。说我之声由其身中有实我境界。声于彼转有处假设故。譬如唤人为师子。复次缘我境界名为正智。缘异境界名颠倒智。譬如丈夫丈夫智。云何为异境界。谓身及诸根因果聚等名异境界。云何为颠倒智。谓缘阴为我名颠倒智故言异境界。颠倒智随实境界。如其义智彼即是我。是故有我。论者言。汝所计我。如我法中不遮世谛泛说有我。汝若作是立义者反成我义。云何成我义。我佛法中名识为我。声如其义。名为实我。若于色等诸阴名为我者。是则为假。如阿含经中所说。依众分故得名为车。我亦如是。以阴为因假说为我。有如此经。又复识能取后有故说识为我。若外人意谓声召实我境界不召于识是作故。譬如身。智缘实我境界不缘于识是作故。譬如身。如是证有我者。论者言。若第一义中召我之声及缘我智。皆以心为境界。汝意谓不如实义者。反成我义。云何成我义。于一切时一切处。我见等先已遮故。若世谛中遮。是事不然。有假设声。有召实体声。智亦如是。有缘假境界。有缘实境界。我佛法义得成。我所欲者亦成。若于第一义中无召实我之声亦无我为境界。如汝所说师子声义是假设故。彼师子境界不如其义。复次声于假施设处起彼处。但见众缘聚集境界。如师子等声。若外人意谓我声及智非众缘聚集境界。作是执者此即自坏。以是故汝差别法坏。是立义有过。复次若外人有未深解道理者。谓我言如彼所说五阴及诸根等非是不共取境因。但欲遮差别法不遮我体。彼嫌我者自违本宗。论者言。我者是世谛中假名字耳。如汝所分别者是常是遍是受食者我法于世谛中遮故。汝今欲令他信解者。是我无体。若第一义中一切时有我。悉皆遮故。不但独遮差别法也。以是故汝之所说如嚼虚空。僧佉人言。有处有如是我故。于彼可遮。犹如遮此井无水。即知余井有水。如是遮身及诸根中无我。定知余处有我。复次由身根中有我故遮。不以身诸根中无我故遮。以是故知有我。论者言。先已遮故。内诸入等非自在天作。非自性藏作。非时作。非那逻延作。如是亦遮有处我不作内入等无起故。譬如兔角。第一义中水等不成。譬喻无体。是故此说不然。僧佉人复言。有如是我。有我所故。譬如自体有则有我所物谓我舍宅卧具衣服及眼耳诸根等故知有我。论者言。我若是有。我所之物得成。然我是无。先已令汝解故。其义如论偈说

  我既无所有　　何处有我所
  无我无我所　　我执得永息

释曰。此中言无我。以是故因不成。譬喻无体。第一义中有我自体不成。复次若有人言。有如是我。果有故。能依有故。作如是因者。亦以前过答。诸行者应如是观察实义。所说道理者。即是已说修行果也。复次僧佉人言。有如是我。在彼无我我所身根识中。何以故。彼法中修行者。真实智起时。言我得无我无我所者。由见实我故。如石女无儿。不可得说住于解脱言。我得无我无我所智。由有住解脱者言。我得无我无我所智故。故知有我。论者言。虽诸行聚等刹那刹那坏相续法起得见无我无我所而无实我。二乘之人得无我故。唯见有此法生此法灭。起如是见。然我境界无故。缘我之心亦不起。我无体故。无有我所内外等法。以缘我之心不复起故。乃至得无我之念亦不起。唯除世俗名字菩萨摩诃萨住无分别智。能见诸行本来无生。其义如论偈说

  得无我我所　　不见法起灭
  无我我所故　　彼见亦非见

释曰。此谓唯有假施设我。其义如是。第一义中无有我与法。如翳眼人以眼病故不见实法。无实毛轮妄见毛轮。汝亦如是。实无有我妄见有我。以邪见故起取着意。以是故。我为因义不成。若谓我得无我我所。由见实我为因者。无我我所自体不成。体不成故。即是因义不成。汝得如是过。故修行者欲得见内外入真实者。当勤观察内外法空。问曰。得空者有何义利。答曰。如论偈说

  得尽我我所　　亦尽内外入
  及尽彼诸取　　取尽则生尽

释曰。取谓欲取见取戒取我语取。行者见无我故得我语取尽。我语取根本尽故余取自尽。诸取尽故则生尽。生尽故得解脱。二乘之人见无我故烦恼障尽。乘彼乘去。是名说断烦恼障。说断烦恼障方便已。次说断智障方便。其义如论偈说

  解脱尽业惑　　彼苦尽解脱
  分别起业惑　　见空灭分别

释曰。此谓生因诸有烦恼。未离欲众生不缘境界而起烦恼。是诸烦恼从何而起。谓从可意不可意诸分别起。有分别故则有烦恼。是故分别为烦恼因。如有种子则有芽生。如是非圣者。有不正思惟分别故。起业烦恼。若无分别则无诸业烦恼。譬如圣相续体。彼染污心起作意故名为烦恼。由染污心起身口所作故名业。云何名烦恼。谓贪嗔等。能令众生垢污相续。是名烦恼。当知起业烦恼皆因戏论分别。彼应断者是世谛相。云何灭分别。谓见空则灭。云何见空则灭。谓空智起时则无分别。是故说灭。复次有声闻人言。见人无我故则无可意不可意分别烦恼及缠。是等俱断烦恼缠断已成就声闻果。果得成已何用法无我耶。论者言。汝不善说。为拔烦恼根蔓熏习令无余故。若离法无我终不能得烦恼根蔓熏习尽无余。以此事故用法无我。复次不染污无知者。诸佛世尊于一切法境界

得不颠倒。觉了此觉所治障。是不染污无知。若不见法无我则不能断。是故法无我非是无用。以如是故戏论寂灭无余相者。所谓空也。如实见空故即是解脱。解脱者。谓脱分别。如经偈言。佛为杀生者略说不害法。小说空涅槃。为大二俱说。此谓如来为杀生者略说不害物命为最上法。为诸声闻说人空及涅槃为最上法。为大乘者说二无我为最上法。说断智障方便已。有外人言。彼上引佛经中偈说我与己为亲。不以他为亲。智者善调我。则得生善趣。以是故汝言无我者。自违汝先所立之义。是故遮我者不成。论者言。复有众生起如是见。拨无因果。覆障正智。作如是言。毕定无我。无此世无后世故。亦无作善恶业果报。亦无众生。受彼化生一切时中。作不善事必堕恶道。如临崄岸。以是故诸婆伽婆为欲摄取诸众生故。勤行大悲。依世谛中施设有我。其义如论偈说

  为彼说有我　　亦说于无我
  诸佛所证法　　不说我无我

释曰。诸佛世尊见诸众生心心数法相续不断至未来世。以是因缘。为说假我。复有众生计言有我。为常为遍。自作善不善业自作受食者。有如是执。然彼众生为邪我绳缚其心故。于身根识等无我境界。迷而起我。虽有禅定三昧三摩跋提之力。将其远去。乃至有顶。如绳系鸟牵已复堕。于生死苦犹不生厌。诸佛世尊知众生已。为息彼苦断我执绳。于五阴中为说无我。复有众生善根淳厚诸根已熟。能信甚深大法。堪得一切种智。为彼众生宣说诸佛所证第一甘露妙法。令知有为如梦如幻如水中月。自性空故。不说我不说无我。问曰。何故不说我无我耶。答曰。我无我分别境界无故。以是故。世谛之中假说有我。如汝所言。谓我违于先所立义。然我亦不违先所立。汝若言第一义中欲令有我。违宗之过今还在汝。论者引经偈言。众生堕生死。不脱如是苦。无我无众生。唯有法与因。此经明第一义中毕竟无我。令有我者。我无是验。已说遮我力故。复次今当解异分别者。有二种外道。各执不同。一者言。诸行聚刹那刹那坏。乃至后时命终分诸行坏。是故无我。若无我者。业果所为。是则无体。此诸外道见是事故即生怖畏。生怖畏故亦有施设我。施设我者。谓执说有我。二者复有卢迦耶蜜迦(唐言无后世外道即路伽耶)言。唯有身及诸根无我自体。于诸行中假名众生。而实无我受持诸行。言有生死流转者。是事不然。何故作此言耶。彼诸外道愚于因果所为。但眼见身相诸根等。即是丈夫。更无别我。如前偈中亦说无我。云何无我。谓于身根聚中无我。诸佛于一切法得了了智。如前偈中佛不说我。不说无我。何故不说我无我耶。由证解一切法真实无戏论故。无戏论已断我无我执。我无我执断已。起我无我境界亦无。何以故。妄置色等为我无我种。是执不起故。如般若经中说。极勇猛。色非是我非是无我。受想行识非我非无我。若色受想行识非我非无我。是名般若波罗蜜。如上说见空戏论灭者。今还重释。云何得戏论灭。谓一切体自相不可得。如虚空相。如是不见。是名见空。若见一切诸法空不可说者。其义云何。如论偈说

  为说息言语　　断彼心境界
  亦无起灭相　　如涅槃法性

释曰。此中明言语起不可得。云何起不可得。谓心境界断故。云何为心境界。谓色等是心境界。第一义中色等不成就故。云何色不成就。谓无起灭相故。云何如涅槃法性。谓如涅槃法性无所有相。如是观者名为见空。复次云何见空。谓体无体不见二故。是名真见。或有人如是疑。云何名真见耶。我今为说。如无尽慧经偈言。于第一义中。云何有二相。彼智亦不行。何况诸文字。此经谓心意识等。于第一义中。毕竟无体。何以故。一切诸法寂静相故。心及诸法一切皆如。无人能作。如宝积经中说非空令诸法空。如是等法各各自空。等真如同涅槃故。是义应知。如经说。佛坐道场。知诸烦恼无体无起。从分别起。自性不起。佛如是知。以是故此义得成。如经偈言。识是诸有种彼识行境界。见境无我已有种子是灭。此中明有种寂灭。是故言如涅槃。云何如涅槃。谓见一切法无生平等。见平等已心境界断。心境断已言说亦断。言说断已。世谛相所执戏论得寂灭。是故言见空戏论灭。有人言。寂灭相者。即是涅槃真如法中性。云何言如涅槃法性耶。论者言。戏论分别者。谓是世间。是涅槃。或说涅槃无为是寂灭法。执说世间是生死法。此中论者说。一切诸法若世间。若出世间。无生性空。皆寂灭相。为着法众生不知生死即涅槃相。以是故今阿阇梨以涅槃等为喻者。令知诸法从本以来空无相无作寂灭无戏论故。自部及外人等谓我言。彼中道说无一切句义与路伽耶说无则无差别。应如是答我言。一切句义无者亦有差别。汝不解故出是言耳。有人言。如以智慧知而舍。不以智慧知而舍。岂无差别。若言说无同者。是则凡夫与罗汉不异。生盲与有目不异。平地与丘陵不异。若如是说。中道路伽则无差别。作此说者。不解差别。是为无智。若路伽说无与中道说无是同者。于何时同耶。为世俗言说时同。为见真实时同。且论世谛时同。拨无因果执者则拔白法善根。行一切不善道。坏世谛法故。复次中道说无者。则不如是。所谓说因果相续如幻如焰行善业道以有漏阴相续故。其义云何。过去有阴相续灭。现在有阴相续起。现在有阴相续灭。未来有阴相续起。譬如梦是名中道说无与路伽说无。非世谛时同。亦非见真实时同。汝说无者。此说无之识缘无境。起一切时。以执无为相。然是邪智。以破戒垢自涂其身。非是息苦因而是起苦因说中道者。未见真实已前。有此色等境界。觉此色等境界。觉见真实时。得空解已。色等境界执觉不起。由见道理故。直言无者。是事不然。无有彼色。境界觉者。非第一义中如实义觉故。譬如有觉。以此验与彼路伽说无者过。复次中道说无与路伽耶说无者。所释不同。云何不同。佛法遮有不执无。而令物解。譬如须弥芥子。巨细殊远。汝言说无同者。亦复如是。第一义中一切法遮。如涅槃相。为随顺福德聚。所说诸行于世谛中。是实如佛言。所有内外诸物世间说实说不实。我亦如是。顺世间法说实说不实。其义云何。如论偈说

  一切实不实　　亦实亦不实
  非实非不实　　是名诸佛法

释曰。如佛所说。世间欲得及不欲得。我亦如是。于世谛中说欲得说不欲得。复次内外诸入色等境界。依世谛法说不颠倒。一切皆实。第一义中内外入等。从缘而起。如幻所作体不可得。不如其所见故。一切不实。二谛相待故。亦实亦不实。修行者证果时。于一切法得真实无分别故。不见实与不实。是故说非实非不实。复次实不实者。如佛所说。为断烦恼障故。说内外入我我所空。是名一切皆实。不实者。谓佛法中说识为我。世不解者。妄执有我有我所。指示他云。我是作者。是闻者。是坐禅者。是修道者。是名不实。摩诃衍中一切不起。无一切物。是有可为分别无分别。二智境界故非实非不实。复次云何名佛。于一切法不颠倒真实觉了。故名为佛。云何名法。若欲得人天善趣及解脱乐。佛知众生诸根性欲不颠倒故。为说人天道及涅槃道。故名为法。复次自他相续所有熏习及无熏习烦恼怨贼。悉能破坏故。是名为法。真实道理不与外道等共。为拔一切执着箭故。应勤修习。复次自部及外人同谓我言。汝若分别自体尽舍无余得真实者。此真实相云何。若不说其相不立自宗。云何但与他过。是汝之失。论者言。实如所言。若实相可说我能分别。而彼实相非是文字。不可言说。为欲安慰初修行者。以分别智而为解释。其义云何。如论偈说

  寂灭无他缘　　戏论不能说
  无异无种种　　是名真实相

释曰。无他缘者。是真实法。不以他为缘。故名无他缘。所谓不从他闻亦无保证。自体觉故。寂灭者。自体空故。非差别分别物境界故。名为寂灭。戏论不能说者。戏论谓言说。见真实时不可说故。而不能说。无异者谓无分别。无分别者。谓无一境界可见分别。以分别无境界故名无分别。无种种义者。谓一味故。无体义故。无差别故。是名无种种义。此谓真实相也。复次由无分别故。戏论所不能说。由寂灭故。是无分别智境界。复名无他缘。由无他缘。是故过言语道。真实自体我不能说。复次此遮一切体。自体言说能得真实。自体能起无分别智。能令行者解自觉真实方便。如是语言是得第一义方便。如汝所言。云何为真实相。若不说其相不立自宗。独与他过。是汝之失者。我无此失。以此偈答。即是说真实相。如是且约第一义说真实相。令复约世谛说之。其义云何。如论偈说

  从缘所起物　　此物非缘体
  亦不离彼缘　　非断亦非常

释曰。此明从缘起果。此果不即因。是中说验因果不一起。异觉境界故。譬如觉及境界。从缘所起果者亦不离彼缘。若离者果起则堕无因过。复次此中立验因与果不别。藉缘方起故。譬如因自体。以如是因果不一亦不异故。不断亦不常。复次虽因坏已果起之时。由有因类相续住。然非因坏故果亦坏。以不异故。而体不断。由果时因已坏故而不是常。如经偈言。以有体起故。彼断不可得。以有体灭故。彼常不可得。云何不断不常。谓缘起法尔刹那刹那相续起。是故不断。有为法体念念灭故不常。今当为汝开演其义。如论偈说

  不一亦不异　　不断亦不常
  是名诸世尊　　最上甘露法

释曰。甘露者。谓得无分别智因故。如诸佛以已所得智。于一切众生界。以佛日言说光。随众生机令开慧花。复次诸声闻人。以习闻思修慧得真实甘露法。现证涅槃息一切苦。或为福智聚未满足故。虽不证解脱。后世决得。其义云何。如论偈说

  诸修真实者　　今虽未得果
  将来决定得　　如业不假勤

释曰。诸修真实行者。若此世。若后世。而不得果者。因熏习诸行。未来世中自然得真实智。亦无他为缘。如论偈说

  诸佛未出世　　声闻已灭尽
  然有辟支佛　　依寂静起智

释曰。如三密经说。辟支佛依寂静故起实。智慧者由身心寂静为因故。智慧得起。是名甘露法。若今世。若后世。有能修真实者。必定得甘露法。是故欲得解脱。应当修行是真实法。此品中破外人立验。亦说自验无过。而令信解诸阴我我所空。是此品义意。以是故我义得成。如般若经中说。极勇猛。色非是我非是无我。乃至受想行识非是我非是无我。若色受想行识非我体非无我体。是名般若波罗蜜。如经偈言。无我无众生无人无受者。但众缘名身。佛得如是解。此中明我人众生及诸行聚是等皆空无有因起。又如空寂所问经说。一切众生。竖我见幢。张无明帆。处烦恼风。入生死海。诸佛大悲。张大教网。捞漉天人。置涅槃岸如上偈说。不二安隐门。能破诸邪见。诸佛所行处。是名无我法

释观法品竟

    般若灯论释观时品第十九

释曰。今此品者。亦为遮空所对治。解诸体无自体故说

鞞世师人言。第一义中有时。法自体为了因故。譬如灯。若无时云何得有了因。譬如龟毛衣。由有物体故。以时为了因。是故有时。论者言。世谛之中诸行若起。即名为作。此起但是诸物体起。更无别起。此诸行因果已起名过去时。因灭果起名现在时。因果俱未起名未来时。作有分齐故。约物为时。无有别时。世谛中亦假说有时。如言构乳时来。然外人分别执言有时。第一义中应作如是观察。鞞世师人言。有为法外别说有时。而是常论者言。今遮此时故。第一义中有为法外不别。有时有体故。譬如有为自体。第一义中无有。常时可识故。譬如瓶。鞞世师人言。如虚空等。非是一向无常。论者言。彼虚空异分无体。亦如是遮故。鞞世师人言。色体外有时与色。和合缘现在时。有识起故。譬如人与杖合。如识见提婆达多境界与杖合者亦如是。于色上起现在现在识。此色之外有别体者名为时。是故别有时论者言。汝言有识起为因者缘杖之识。于非时相境界起故。时相则坏。执杖者非常故。常义则坏。自体法差别法。如是等皆破故。是汝立义出因等过。与杖和合者譬喻无体。第一义中执杖者不成故为喻不然。缘色之觉与时和合。此觉不能显了。是故无时。复次三时别成者。为有相待。为无相待。若立时有待成者。其过如论偈说

  现在及未来　　若待过去时
  现在及未来　　过去时已有

释曰。此谓时有待。时有待故。譬如过去时。复次若待过去时有现在未来时者。应过去时中有现在未来时。何以故。因过去时成现在未来时故。亦应现在未来时住过去时中。如是现在未来尽名过去时。若一切时尽名过去时者。则无现在未来时。尽过去故。若无现在未来时。亦应无过去时。何以故。现在未来时已在过去时中故。复次若时有待者。或彼同时有。不与待相违故。譬如父子异。若不立时有待者。现在未来有别起过。其义如论偈说

  现在与未来　　过去时中无
  现在与未来　　待何而得有

释曰。此谓过去时中无现在未来时。若谓过去时中无现在未来时。而因过去时成现在未来时。此二云何得成。若无现在未来时。有何等过。此下说验。第一义中无现在未来时。自体时有待故。譬如过去时。复次鞞婆沙人言。现在未来于过去中。得同时故。而有相待。论者言。亦有别时相待。如兄弟。非是一向汝语非也。如是有时相待不成。复次若无时相待得成者。其过如论偈说

  不待过去时　　彼二则不成
  现在及未来　　是则无有时

释曰。彼二者谓现在未来为二。不待过去时则不成现在未来时。何以故。若不待过去时有现在未来时者。于何处有现在未来时。以无相待故。现在未来时亦不成。其义云何。如论偈说

  与过去无别　　余二次第转
  及上中下品　　一体等应观

释曰。以此方便应展转说。其义云何。如论偈说

  未来又过去　　若待现在时
  未来及过去　　现在时中有
  未来及过去　　现在时中无
  未来及过去　　待何而得有
  不待现在时　　彼二则不成
  未来及过去　　是则无有时
  现在及过去　　若待未来时
  现在及过去　　未来时中有
  现在及过去　　未来时中无
  现在及过去　　待何而得有
  不待未来时　　彼二则不成
  现在及过去　　是则无有时

释曰。此是释论偈。如前自成立。与外人过。云何为上中下品次第乃至一体等。譬如人类。同名为人。于中而有差别。功德具足名上品人。稍减者名中品人。全无者名下品人。如是等为待故成。为不待故成。且有上者。非上自体有相待故。譬如中自体。如是中亦非中。自体有相待故。譬如下自体。下亦非下。自体有相待故譬如上自体。复次以有相待为因。欲令汝解上中下等无自体故。汝不欲得无自体耶。若欲得有自体者。待中故唤为上。是亦不然。如是一数体及一二等亦如前遮。一数者今当说。第一义中一非一数体。何以故。是数有待故。譬如二数等。如是二非二数体。多非多数体。应如一数说。第一义中。不欲于法体外而有彼数。云何欲得谓一者。无二及无异故。名为一。无一及无异故名为二。无二及无异故名为三。自三已后总名为多。亦如前遮。而令开解今当更说。第一义中一亦非一。是可数故。譬如异。如是二亦非二。多亦非多。亦如一数说。应作是验。等者云何。谓一尘非一尘。是可数故。譬如异如是二尘非二尘。多尘非多尘。亦如上说。及长短远近前后因果。非长短远近前后因果。乃至有为无为。非有为非无为亦如是说。鞞世师人言。第一义中有如是时。何以故。有分量故。若无时则无分量。如马无角。不可说有分量。由有时故则有刹那罗婆摸呼多昼夜半月一月时行年双等分量。若有分量。是则有时。譬如稻谷等。有故则有分量故知有时。论者言。汝之所说义不相应。何以故。如论偈说

  不取不住时　　住时亦不有
  可取不可取　　云何可施设

释曰。不住者。谓诸行聚是起灭法。名为不住。世谛中行聚等名时。是时名不可取。住时者亦不于法体外有非色时可取。是名住时。云何可取不可取。云何施设。时若可取即能施设。时不可取不能施设。以是故。诸行如是。曰行等作有分齐。诸行生住灭。摸呼[口*栗]多等法。有分量故名为时。如汝所说。因者其义不成何以故。无所依故譬如无体。鞞世师人言。有常时。以有刹那罗婆摸呼[口*栗]多过去未来等种种差别。譬如净摩尼珠。因彼众色而有种种相现。论者言。此体待彼体得有刹那等名。我义如是。如论偈说

  此彼体相待　　世谛法如是
  第一义无体　　离体何有时

释曰。相待者。谓外人于世谛中立有相待。我义亦尔。第一义中无有常时。如我所说过者。汝不能免。鞞世师人言。第一义中有实时体。如非他及他一时及非一时迟疾等。即是时相。非无体而有相。论者言。第一义中无少许体。世谛之中有诸行差别相待相续。非他及他等识起一时者。谓诸行无差别刹那相待非一时者。有迟有疾。迟者谓后时相续随转。疾者谓下相续随转。非他识起者。但是诸行无别有时。汝所立因无体。何处有时体可得。若外人意谓。他等识起缘诸行法非是时者。何处可得时耶。论者言。汝以时是常是一令他解者。此验无有。我今说验。于世谛中常一之时。非是起他等识因识故。譬如色等识。鞞世师人复言。定有实时。有假设体故。论者问言。似何等物。鞞世师答言。如色等。论者言。第一义中色等体不成。如先已说。能令物解。色相无体。色相无体故。譬喻无体。譬喻无体故时亦不成。我亦无而说有。譬如车军林等。虽无实体而有施设。故非是一向。有人意谓。依诸行法施设有时。如说昼日住摸呼[口*栗]多住。作此说者。应如是答。如论偈说

  因物故有时　　离物无有时
  亦无少物体　　何处时可得

释曰。此谓因物生故则名为时。离此行法无别时体。执有时者。言定有时。有起差别。言说因故。不见无法。能起言说。因见有已作今作当作瓶故。即知有时。论者言。汝语不善已作瓶等能起言说因者。是诸行法亦非是时。汝因不成。有相违过。能起言说因者。是世谛法。汝种种说时皆不成故。如先说了因者。义亦不成。此品初已来与外人成立过。自说成立无过。遮空所对治时无有自体。为令信解。此品义意如是。以是故。此下引经显成。如放光经佛说。佛告须菩提。时非色法非无色法。非受想行识法。非无受想行识法。非生法。非无生法。非住法。非无住法。非异法。非无异法。非坏法。非无坏法。非受法。非住法。非出法。非无受无住无出法。乃至非老相。非病相。非死相。非青相。非啖相。非坏相。非散相。非无老无病无死无青无啖无坏无散相。须菩提。若非色非生非住非异非坏相者。是名般若波罗蜜。复次须菩提。若非色非非色。乃至非受想行识非非受想行识者。时即非时亦非非时。若时非时非非时不可言说者。是名般若波罗蜜。又如妙臂经中所说。菩萨摩诃萨了知三世所有诸行。已起故。说名过去世。未起故。说名未来世。起时故说名现在世。此现在世阴界入等住者。了知不住。何以故。一刹那时不住故。此一刹那即有起时。住时差别。以刹那不住速灭故。定无有时

释观时品竟

般若灯论释卷第十一般若灯论释卷第十二

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观因果和合品第二十

释曰。今此品者。亦为遮空所对治。以鞞世师等于前品中立时不成故说。鞞婆沙人及僧佉人等言。第一义中有如是时。果有生灭故。如种子与水土和合。以时节有体故而芽得生。若无因者。果则不生。以是故如前所说。因有力故。当知有时。论者言。若有说言因缘和合有果生者。今当答之。如论偈说

  若谓众因缘　　和合而果生
  是果先已有　　何须和合生

释曰。和合中若有果者。得如是过。何以故。有不生故。若有而从和合中生者。有云何生。若言生者。和合中则无。何以故。有之与生二法相违。复次若有果则不生。已有故。果若已有不须更生。何以故。生与不生此二相违。若有言因缘和合中无果而能生果者。今当答之。如论偈说

  若谓众因缘　　和合而果生
  和合中无果　　何须和合生

释曰。此谓果不生。无有生故。譬如兔角。若无生者。生法体坏。是汝立义等过。若立因缘和合中有果者。今当重破。如论偈说

  若谓众因缘　　和合而有果
  是果应可取　　而实不可取

释曰。此谓果不可取。何以故。一心欲取而不能取。以果无故。此下作验和合中有芽名果亦不可取。何以故。和合中无果故不可取。若不可取者。是中则无。譬如种中无有瓶绢。如是于和合中无芽名果故不可取。僧佉人言。彼说和合中不可取者。亦有是义。所谓极远极近及诸根损患。心迷闷时。有隔障等。能障于取。虽有物体而不可取。非一向无故不可取。若言无者。是彼出因立义之过。复次更有异僧佉人言。如前所说过者。今当更说。彼上出因言不可取者。此因有何等义。为是现量不可取耶。如诸根识而实是有。亦不为现量所取故。彼立因者。非是一向。若以验量不可取者。因义不成。犹如验因中果。有取可量故。若可量者。因则不空。譬如有果体。如是苦乐二种能为贪嗔诸见三烦恼因。色声五种亦能为贪嗔等三烦恼因。以是因等有验量故。因中果有取。汝虽言现量不可取。然今验量。有可取故。彼出因义不成。若现量及验量俱不可取者。此违我义。及因不成。论者言。我道不可取者。谓于因缘和合中毕竟无果故不可取。汝言极远等亦不可取。非一向无者。世谛之中亦无此理。何况第一义耶。于第一义中亦无极远等物。如上苦乐色声等于第一义中亦无。是则因义不成。所言果者。果亦自体空故。若因中无果者。世谛中果亦不生。譬如拒不能生拒因亦不能生因。汝言因能生果者。于世谛中亦已被破。复有异僧佉人言。若因未生时先无因体。果亦先无。而后方生。论者言。今当说验。若先无因后亦不生无有故。譬如空华石女等。广如前说验。今更总答修多罗人及鞞世师等计因中无果者。如论偈说

  若谓众因缘　　和合无果者
  是则众因缘　　与非因缘同

释曰。此言无果者谓果空故。因之与果云何差别。因相者谓自果生无间生自分生等差别。是为因相。缘相者。谓通生种种果能长养他令他相续。乃至远处通生诸果。非自分生能广饶益。如是等名为因缘差别相。与非因缘同者。谓非因缘不生于果。何以故。果空故。以是故因缘与非因缘同。复次今为执因中无果者。出验第一义中种子等诸因缘不能生果。何以故。果空故。譬如非因缘。复次修多罗人言。缘能生果。何以故。有决定缘能生果故。若果空者。义不相应。论者言。第一义中无如是验。还同上非因缘过。欲令他信解者。汝验无力。修多罗人复言。见麦种子能生麦芽以是故。彼出因者无有义理。论者言。世谛之中实见麦种能生麦芽。非第一义。若于第一义中麦生芽者。是义不然。如是观察有果生者。不然。如先答。汝立果生灭。以为因者。果有生义。不然。复次今问。执因中无果者。因为生果已而灭。为未生果而先灭耶。执者答言。我有何过为此二问。论者言。义不相应。如论偈说

  与果作能已　　而因方灭者
  与因及灭因　　则便有二体

释曰。此谓于世谛中亦不欲令与者灭者一法有二体过。复次若未与果作能而先灭者。今当欲答。如论偈说

  若因未与能　　而因先灭者
  因灭而果起　　此果则无因

释曰。此谓不欲无因而有果。以是故非因灭已而果方生。何以故。已灭故。譬如久已灭者。此义一切世间之所共解。亦复不须更令物解。修多罗人复言。和合法起有同时能生果。如灯与光同时而起。是义应尔。论者言。若谓同时而生果者。是亦不然。如论偈说

  若同时和合　　而能生果者
  能生及所生　　堕在一时中

释曰。此谓有同时过而不欲令能生所生二法。如父子二同时而起。有如上过。复次云何别时起。谓所生及能生因果为二。今次作验。非果与因和合同时俱起。何以故。所生及能生二故。譬如父子二。如先所说有器炷油等和合有力故。世谛中灯共光同时起。非灯与光相望为因果。是故汝说不善。复更有异僧佉人言。未和合前果已先起。后和合时方乃显了。论者答言。无有是义。如论偈说

  若未和合前　　已有果起者
  离彼因缘已　　果起则无因

释曰。此谓离和合因缘而先有果者。世谛之中实亦不见有如此事。以是故。我佛法中无果先起。汝言后显了者。先已答讫。更有异僧佉人言。因法虽已灭至果起时犹有因体住。论者言。若因灭已而体不舍。即住为果体者。无如是义。何以故。如论偈说

  若因变为果　　因即有向去
  先有而复生　　则堕重生过

释曰。此谓因体为果而体不舍。如提婆达多。不舍此宅而至彼宅。何以故。因体已有。而复更起则为重生。既不生果。全无所作。复次若谓即因变为果者。即是不名变。变不名即是如泥团。不即是瓶。泥团灭已而有瓶生。不得称变。不变故。譬如泥自体。僧佉人复言。因能生果。我义如是。无如上过。论者言。若不舍因体而名果者。但名字有差别而无果体。如上说过。汝不能免若舍因体果体起时而因还住果体中者。是义不然。汝不思量。作如是说。复次今问。执有异僧佉汝言。因能起者。为因已灭能起果耶。为未灭能起果耶。二俱不然。如论偈说

  为已灭生果　　为未灭生果
  因灭者已坏　　云何能生果

释曰。此谓已灭者。不复是因。何能生果。若因起已。而体不灭。何能生果。汝之所说。义不相应。复有异僧佉人言。实法恒住。而前物体灭。后物体起。有此变异。以是义故。因体不灭。而能生果论者言是。亦有过。前体灭时。实法亦灭何以故。实法与物体不异故。譬如已灭法体。后法体起时实法亦起。何以故。实法与物体不异故。譬如已起法体。如汝所说。与世谛道理相违。若依第一义道理。有何法体灭。有何法体生。而言有变异耶。何以故。一切时无有譬喻。汝所说者。是义不然。复次汝言前法体灭者。此体为是因体。为非因体。若是因体者。前法体灭。因体亦灭。偈言因灭者。谓非是已灭因有能起果力。复次若前法灭非因体者。如论偈说

  因果和合住　　云何得生果
  不与果和合　　何物能生果

释曰。此谓因不生果。何以故。因果体不异故。如因自体不自生因。若因与果和合共住。既不生果。因则无用。法体有颠倒故。是汝立义之过。若有人言。因不与果和合者。亦如上答。物不生果。何以故。果空故。譬如余果且已总遮。因能生果。今当别说。遮彼眼识等果若此眼识以眼为因者。此眼为见已取境。为不见而取境。二俱不然。若眼见而取。然后识起者。识则无用。若眼不见而取者。色之境界则为无用。复有人言。第一义中因能生果。何以故。因与果作因故。若因不生果者。是则乳非酪因。譬如乳与瓶。论者言。汝说不善。何以故。如论偈说

  无有过去果　　与过去因合
  亦无未来果　　与已生因合

释曰。此谓因果俱无故。譬如兔角。复次过去因。以时别故则不与果和合。复次已生未生果与已生未生因不和合者。如论偈说

  已果及未因　　毕竟无和合
  未果及已因　　亦复无和合

释曰。此谓时别。因果二故。已生果与已生。未生因已坏。果与已坏。未坏因不和合者。如论偈说

  无有已生果　　与已未因合
  亦无已坏果　　与已未因合

释曰。此谓因果二得同时者。先已遮故由时有别。汝义不成。作是观察。因之与果。永无和合。如论偈说

  因若不和合　　云何能生果
  因若有和合　　云何能生果

释曰。此下作验。第一义中因不生果。不和合故。譬如种子在地芽不出高山。复次今有道理与彼执稻种中无果及有果者过。如论偈说

  因中果若空　　云何能生果
  因中果不空　　云何能生果

释曰。此谓种不生果。以果空故。如先所答。譬如余果。因中果不空者。谓果已有故。因不生果。譬如因不生。因先已答故。鞞婆沙人言。果未起前。此果先有。论者言。无如是义。今为遮此过故。如论偈说

  未起果不空　　不空则无灭
  以无起灭故　　果得不空过

释曰。此谓果不从缘起。以果有自体故。若有而起者。无如是义。已有故不须更起。若谓不起而有果者。是则果体。应常不灭。以是故。果得不空。过而执者。不欲令果有不空过。如论偈说

  果不空不起　　果不空不灭
  以果不空故　　无起亦无灭

释曰。果若空则无起灭。若定有者不须复起。无起故无灭。以是故果若不空。云何起灭。复次云何欲得如此果者。是起灭法故。果若已有。则不见有起灭法。譬如现在相。复有路伽耶言。果未起前。果无自体。何以故。果体空故。果已起者。亦无他法体。论者言。是说虚妄无有义理。我今答汝。何以故。如论偈说

  果空云何起　　果空云何灭
  以果是空故　　无起亦无灭

释曰。此谓第一义中果空而有起者不然。何以故。果无体故。譬如空华。第一义中于稻芽上有麦芽无体。体灭者是亦不然。无体故。譬如非稻芽灭。复次从缘起者自体皆空。是我法中第一义观故。若谓有少许物而不空者。此等之物则不从因缘生。世谛之中亦无是事。譬如空华。如上偈说未起果不空果得不空过。此谓果不空者。得无起灭过。今令汝解第一义中果空而有起故。譬如幻等。第一义中果空。以有灭故。亦如幻等。果亦如是。若果以无他体为体者。此果则无起无灭。世谛之中亦无果故。譬如空华。亦如上说。果空云何起。果空云何灭。此谓起灭。俱无体故。此果既空则无起灭。然外人不欲令果无起灭故。此中立验。内入等果非无自体。而有起故。譬如幻等。以此无起。无灭之验。即破汝果。有起有灭。汝差别法破故。是汝立义之过。复次能生之因。此因与果。为一耶。为异耶。其过如论偈说

  因与果一者　　终无有是义
  因与果异者　　亦无有是义

释曰。何故因果不得一异耶。是中过咎。如论偈说

  因果若一者　　能所则为一
  因果若异者　　因则同非因

释曰。此谓汝不欲得能生所生二如父与子。云何为一。亦如火与薪。云何得一。此之二喻。世间共见。以是故我今说验。因之与果不得为一。何以故。能生所生有异故。譬如父子二。此谓计一者过。复次执异者云何。谓因与果异故。譬如一切非因法。而汝不欲因同非因。汝意欲得因果二法相续不异。复次今问。执因中先有果者。此果为先有已生。为未有而生。是皆不然。其过如论偈说

  果若已有者　　何用从因生
  果若未有者　　因复何能生

释曰。此谓果若有自体者。何假因生。世谛之中亦复不能令人信解。果若无自体者。如虚空华。于世谛中而亦不能令人解也。如上偈说。果空云何生。以此观察。第一义中因能生果者不然。若因不生果者则不是因。如前外人所立。能生果者。因应处处为因故。今为破此因义不成。汝亦违先所说。于第一义中成立因生果义。复次今言违者。谓于第一义中因不生果。世谛之中有如幻化等生故。鞞世师人复言。第一义中因能生果。何以故。世人咸言。此果之因故。当知因能生果。若因不生果者。终不指示言。此是果之因。譬如驼角弓。无故不说。今以有故说。如说眼是因识是果。稻是因芽是果。以有故说。若说识与芽喻得成者。即是我所立义得成。其验如是。论者言。若曾有少许果生是第一义者。可得言此是因此是果。可作如是指示。今能生因无故。汝上所引世人咸说是果之因者。所立不成。亦违汝义。复有僧佉人言。得和合法故果生。此和合法由得时节故能生于果。而此品初彼遮我言。果有生灭为因故。因不成者。非是不成。亦非独因能生果。复由和合及得时节而能生果。如彼所言。因不生果者。正成我义。论者言。因缘和合者。非是实法自体能生。若自体生已可能生果。今则不然。何以故。其过如论偈说

  自体及众缘　　和合不能生
  自体既不生　　云何能生果

释曰。此谓和合不生于果。何以故。非实法故。譬如幻等。亦如提婆百论遮和合偈中说。一和合者无。诸和合亦无。若言是一者。应离因缘有。今当为汝分别正义。如论偈说

  是故果不从　　缘合不合生
  以果无有故　　和合法亦无

释曰。此谓离诸缘无和合法。复次如先已遮因不生果。今遮和合亦不生果。云何不生。谓此和合非是近生亦非远生。第一义中不生者。如先遮因缘中已令信解。如是和合法不生果非和合法亦不生果。又如百论中说。世间名字由和合有。法体非有。体非有故。亦无和合。以是故。品初外人所说因者。与出因过。遮彼时法。为令信解因果无自性故。是此品义意。以是故我义得成。如般若经中说。极勇猛色非因非果。若色非因非果。乃至受想行识非因非果。何以故。色无和合故。若色无和合。乃至受想行识亦无和合。不见色。不见受想行识。无所行者。是名般若波罗蜜。如佛于识趣后世经中说偈言。若说和合处。是说方便门。为趣第一义。智者如是解

释观因果品竟

    般若灯论释观成坏品第二十一

释曰。今此品者。亦为遮空所对治。如前品。以因果无自性故。已令信解。今为显示诸法无成坏故说

僧佉人言。第一义中有时。何以故。时是成坏因故。若无时者。则不是因。譬如蛇足。由有时故。成坏二法随时而转。是故说时为因。因得成故。即是我所立义得成。论者言。成坏二法。为离成有坏。为不离成有坏。为与俱有坏。是皆不然。如论偈说

  离成无有坏　　与俱亦无坏
  离坏无有成　　与俱亦无成

释曰。我佛法义如是如是。如汝所说。时为因者。其义不成。何以故。若离成有坏者。则不因成有坏。坏则无因。又无成法可坏故。云何为成。谓众缘合。云何为坏。谓众缘散。复次若离成有坏者无成。谁当坏故。譬如无瓶。是故离成无坏。若谓与俱而有坏者。是亦不然。何以故。法先别成。然后有合。是合法不离于异。若离异者。坏则无因。是故与俱亦无坏。如是若离坏共坏无有成者。何以故。若离坏有成。成则为常。常是不坏相。而实不见有法是常。以是故离坏亦无成。若谓与俱有成者。是亦不然。成坏相违。云何得一时俱。僧佉人言。何有与他立过。自义得成。自若成者。应说道理。论者答言。汝义非也。其过如论偈说

  离成则无坏　　云何得有坏
  离死则无生　　无坏何有成

释曰。此谓离成无有坏法。世间之人皆共解故。不须广说。释离成无坏已。复次与俱亦无坏者。如论偈说

  若成与坏俱　　云何当可得
  亦如生与死　　不可得同时

释曰。此中说验坏之与成非同时有。何以故。成是坏缘故。譬如死与生不可得俱。释不俱已。复次第二分别离坏无成者。如论偈说

  若离坏有成　　云何当可得
  诸体上无常　　一切时中有

释曰。此谓离坏无成。何以故。如立义中诸体无常者。谓色法等自体无常故。譬如无常。自体复有。正量部人言。法虽无常得坏因来法体即坏。非一切时皆有无常。论者言。若尔者。譬如有人服泻药已便泻。乃语他言。是天泻我不言药泻。汝亦如是。无常之法。一切时中能坏法体。而言待坏因来者。是事不然。若得坏因无常始能坏法体者。但是坏因能坏法体。何得复言无常能坏。今问外人法体。为是坏性得坏因来坏耶。为非坏性得坏因来坏耶。此法体若是坏性。得坏因来坏者不然。何故不然。法体起时无间即坏。亦起便灭不到第二刹那。云何得待坏因来坏。若法自体非坏者。譬如涅槃。亦不待彼坏因来坏。复次坏无有因坏无因故。法则不坏。譬如无为。以此验故。破彼坏因。彼因既破。即破法体。是汝立义之过。且成坏二法前后而有者不然。释离坏无成已。复次同时有成坏者。义亦不然。何以故。如论偈说

  成与坏同时　　云何而可得
  亦如生与死　　同时者不然

释曰。此谓作是观时。义同前解。复次互不成者。如论偈说

  成坏互共成　　此二无有成
  离此二互成　　二法云何成

释曰。此谓成坏二法不可得成。如外人先说有时而为成坏因者。因则不成。萨婆多鞞婆沙人复言。此自性坏法非起而即灭。由起无间有住故。此住无间而有灭。论者言。是事不然其义如论偈说

  尽者无有起　　无尽亦无起
  有尽者无坏　　无尽亦无坏

释曰。此谓若法有无常者名为尽。有尽者则无起。起尽二法相违故。譬如生与死。若言起已而无间不灭者。此非尽法。以是故。如向所说起尽法者。于世谛中不成故。有尽法者不须思惟分别。无尽者非坏自体故。譬如解脱。鞞世师人言。应有成坏。体法有故。若无成坏。亦无体法。譬如蟾蜍毛而成坏。是物体法故。必有成坏故。论者言。第一义中若有。一物实有成坏者应说成坏法。然无成坏可说故。其义如论偈说

  若离彼成坏　　则无有物体
  是成坏二法　　离物体亦无

释曰。物体者。以成为体故。成既无体。汝向说体法有故为因者不成。何以故。所依无体故。能依亦不成。复次汝以物体为因者。今说其过。修多罗人言。物体无实。自性是空。然于物上有成坏法。萨婆多人复说言。物有实体。自性不空。于此物上而有成坏。今总答彼二部成坏。如论偈说

  有成坏二法　　物体空不然
  有成坏二法　　体不空不然

释曰。此中立验如上。体法有故。若言自体有者。则应不坏。以是故汝等立因不成。复次更有与过道理。此成坏法为一耶为异耶。二俱不然。是义云何。如论偈说

  是成坏二法　　一体者不然
  是成坏二法　　异体者不然

释曰。此谓相违故。譬如愚与智。然此二法同依一物。譬如余物体。此亦因义有不成过。鞞世师人说偈言

  我常见物体　　有成亦有坏
  是故知体法　　定有而不空

论者言。汝实见者。但是同凡夫智非第一义。今当为汝分别其意。如论偈说

  起者先已遮　　无起法亦遮
  见成者愚痴　　见坏者亦尔

释曰。此谓无成坏体。外人若言见成坏者。云何知是愚痴非第一义耶。论者言。此先已答。汝若意由不足。今更为说。于第一义中若见有物体者。此成与坏可依彼体。然此物者。为有体能生体。为无体能生体。是皆不然。何以故。其义如论偈说

  有体不生体　　亦不生无体
  无体不生体　　亦不生无体

释曰。有体不生体者。第一义中无体故。譬如已生体。若外人言。如种子体。后时能生芽故。谓是体能生体者。是亦有过。何以故。芽未生时亦无芽体。以稻体不生故。芽未生时无有名字。此谓未有言说故。譬如余未生物体。不生无体者。体无故。譬如兔角无体。不生体者。谓无因体。体无生故。亦如兔角无体。不生无体者。先已说验破故。今问体等。为自生耶。为他生耶。并有过故。其义如论偈说

  法体不自生　　亦不从他生
  亦无自他生　　今说何处生

释曰。如是不生前已广说故。此谓毕竟无生。以成坏无有体故。汝根本因义不成。若第一义中欲得有体者。今当说过。如论偈说

  诸法有体者　　即堕断常见
  当知所受法　　若常若无常

释曰。何故尔耶。谓此法若常若无常故。何以故。常者不坏故。是常见过。无常者坏故。是断见过。有外人言。我无是过。其义云何。引上偈本云。诸法有体者。非常亦非断。论者问言。何故尔耶。外人复引论偈答曰

  起尽相续者　　由果及与因
  因灭而果起　　不断亦不常

释曰。外人意谓。因始灭时有果起故不断。果始起时有因灭故不常。亦如经说。五阴无常苦空无我。而不断灭。以是义故。因之与果非断非常。论者言。若如是者。义不相应。前灭后起。今说其过。如论偈说

  是起尽相续　　由因及果者
  因灭而果起　　若断及若常

释曰。此谓因灭更不生故。则堕断过。已灭者不起故。譬如燋种。鞞世师等谓论者言。如彼论中偈说。若物从缘起。此果不即缘亦不离彼缘。非断亦非常。此谓论者先所欲得。今复说为过者不然。论者言。此语不善。何以故。此偈于世谛中说不断不常。非第一义。何以故。第一义中一切法无断常过。僧佉人言。因变为果。住果故得说有体无断常过。论者言。是义不然。汝转变无验。不令人解。转变义者。先已遮故。汝今复起转变分别者。今更说验。若物不可变者。终无有变。何以故。不可变故。譬如兔角。复次若诸体有自体者。义不应尔。其过如论偈说

  先有自体者　　后无则不然
  涅槃时便断　　即有断灭过

释曰。今现见此体有起有灭。是故诸体无自体。所以者何。起灭法故。此义先已说。复次若诸体先有自体者。阿罗汉心心数法。后时更不生故。即断灭过。此过汝不能避。若汝意言涅槃时是断者。亦从是断未涅槃前诸有相续时。我何有断灭过。而谓相续无断过者。汝不善说。我前说涅槃时断者。正遮汝言。未入涅槃前诸有相续。如前言涅槃时便断者。此已令解是断见过故。若后时是断者。障于解脱。何故尔耶。由此断见不得解脱故。如是答汝。汝心犹不足者。今当复听。此现在有末后命终时。是名死有。未来有中初受生心者。是名初有。此中义意。如论偈说

  死有者是灭　　取初有不然
  死有未灭时　　取初有不然

释曰。此中说验。第一义中死有是灭者。不取未来有。是灭故是死有故。譬如阿罗汉死有。复次死有名过去有。初有名现在有。若死有灭次起初有者。是则无因。若言此死有未灭时能取初有。是有故。得无过者。此中说验。死有未灭者不能取。初有未灭故。譬如现在有。外人复言死有欲灭。能取初有。论者言。亦不善说其过如论偈说

  是死有灭时　　能生初有者
  灭时是一有　　生时是异有

释曰。此谓灭时生时。二有各异故。云何能取耶。外人答言。如彼所说。有相续而体异者。我亦如是。论者言。提婆达多死有不取。提婆达多初有有异故。譬如耶若达多死有。又复汝谓已灭未灭灭时取初有者不然。如上二有过。又复汝谓若灭未现前能取初有者。同前二有过。如是生时及已生取初有者。亦不然。还如前过。以是故。如论偈说

  灭时及生时　　取初有不然
  而此灭阴者　　后复还生耶

释曰。此谓外人不欲得已灭之阴还复重生。如一人一时有二自体者无也。若谓初有灭时即后有生者。今应随在何阴中死。即于此阴中生。不应余阴中生。如是死有灭已。能取初有者不成。已令信解死有灭时能取初有者亦不成。以是故。已灭及灭时俱不成如我所说道理。死时诸阴灭已。还用此阴相续生者。亦不然。其过如论偈说

  如是三时中　　有相续不然
  若无三时者　　何有有相续

释曰。此谓死有续生初有者不然。相续不断不常。语者是世谛非第一义谛。是故我所立者不破。以是故。如品初外人说有如是时为成坏因者。今广说此因过故。立时不成。以成坏无自性。令物信解是品义意。是故此下引经显成。如般若中说。佛告极勇猛。色不死不生。受想行识不死不生。若色受想行识无死无生。是名般若波罗蜜

释观成坏品竟

般若灯论释卷第十二般若灯论释卷第十三

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观如来品第二十二

释曰。今此品者亦为遮空所对治。令决定解第一义谛如来身故说

修多罗人及鞞世师等言。有自体色等诸体是体故譬如如来。何等是如来。谓金刚三昧解脱道同起无间第十六刹那心。彼差别门初起刹那即名为智。此智是第一义谛如来智。所依阴亦名如来。论者言。若依止世谛智诸体及如来有自性。汝欲得取此成我义。今依第一义谛观如来。若此智是阴自体者。已摄入诸阴中。今遮如来。亦遮彼智。如论偈说

  非阴不离阴　　阴如来互无
  非如来有阴　　何等是如来

释曰。阴者谓积聚义。阴非如来者。如来自体非是阴故。此中说验。第一义中阴非如来。阴是起尽法故。譬如凡夫诸阴又如外四大等。如是以作故为因者。当广说验。复次诸阴非如来。已遮此阴起法。亦遮实法。及遮色等阴故。复次今将智为一门别遮第一义中智非如来。是起尽法故。是智故。譬如凡夫智。诸外道等谓阴外有如来以此方便成立于我今答此故。若离阴外有如来者。无验可令信解。如是离阴有如来者不然。互无者。谓如来中无阴阴中无如来。如来中无阴者。譬如雪山中无药。不得言有药。阴中无如来者。譬如林中无师子。不得言有师子。非如来有阴者。如具足财者名为有财。不以不具足者名为有财。如是以五种观察如来不成。如所说观察方便时无有如来。譬如收贼多获众人谓言是贼。及其捡验还是好人无有实贼。如是离阴之外何等是丈夫。何等是自在。汝所说如来不成。所说不成故亦阙于譬喻。譬喻阙故。是立义有过。修多罗人复言。因阴故假设名如来。我等所说无过。论者言。是义不然。汝所说者则为有过。如论偈说

  因阴有如来　　则无有自体
  若无自体者　　云何因他有

释曰。此谓有自体者得如是过应作是知如来无自体。此中说验。于第一义中如来无自体。以假设故。譬如旋火轮。无实故。譬如瓶。阿毗昙人言。第一义中瓶有实体。可识故。譬如色。论者言。瓶等是实者。亦不成无有。譬喻故。然瓶及水等是世谛中有色者。第一义中无实。何以故。若法分别无者是世谛。乃至最后不无者亦是世谛。阿毗昙人复言。如五阴是假设。如来亦是假设。而言如来自体是作者以如是解成立。如来无自体者。反成我义。何以故。诸阴是作故。若言以他为缘有如来起者。如是成立。亦无譬喻可为譬喻。如是一切以他为缘者。悉有自体。亦如火轮色等是无分别眼识境界故。如是一切以他为缘者皆有自体。我宗立义如是。论者言。火于空中上下遍转而无轮体。以轮体空而为喻者不然。火等有起。先已遮故。如是实法及眼识等诸识色等境界。先皆已遮。如眼乃至色等。一切法亦如是遮故。若待因缘而起者。有自体义不成。何以故。如论偈说

  法从他缘起　　有我者不然
  若无有我者　　云何有如来

释曰。此谓以他为缘者。是假设故。譬如幻人。若如来无自体者。何能成立诸体有自体。譬喻以如是意。先所譬喻则为有过。复次汝言如来有自体故。一切诸体得有自体者。是亦不然。外人言。虽无一物可为如来。而如来是有我喻得成。无如上过。论者言。是义不然。何以故。如论偈说

  若无有自体　　云何有他体
  若离自他体　　何等是如来

释曰。此谓毕竟无有如来。若言自体他体之外别有如来体者。第一义中不成汝非无过。犊子部言。因阴施设有如来。不可言与阴一异。何以故。非阴自体故不一。非无阴自体故不异。若如是说如来者其义得成。论者言。为第一义如来取阴施设耶。为非第一义如来取阴施设耶。彼若取阴为如来者。取则无义。若非如来者。今问其义。如论偈说

  彼未取阴前　　已有非如来
  而今取阴故　　始是如来耶

释曰。此谓未取阴前已有我者。外人意言如此。论者言。若尔者如论偈说

  彼未取阴时　　则无有如来
  未取无自体　　云何后取阴

释曰。此谓离取如来不成。何以故。如来无自体故。如外人所执我无阴体我后时取如来阴为如来。论者言。今遮此我不取如来阴我非如来故。譬如余物不取如来阴为如来。若如来取阴已后为如来者。汝等欲得尔耶。如上偈说过。今问如来者。为是阴体。为非阴体。若是阴体。已如前答。若异阴体。则无如来。何以故。非阴自体故。譬如兔角。亦如前说。第一义如来未起已前非如来不取如来阴未起已前无如来故。譬如非如来。如论偈说

  犹如未有取　　不得名为取
  若离于彼取　　无处有如来

释曰。此谓离取无如来体。今当说验。五阴中无丈夫。是作故。譬如瓶。如是从缘起法无丈夫。是作故。譬如瓶。无常法无丈夫。是作故。譬如瓶。正智邪智疑智中无丈夫。是作故。譬如瓶。忧喜因中谛所摄中无丈夫。是作故。譬如瓶。如是诸因当广说验。犊子部复言。第一义中有如来。若言无者。佛所不记。如外道所执丈夫。如来即记言无。然未曾说无。如来若言无者。何缘复记。有人问言。死后无如来耶。佛亦不答。以是故有如来。论者言。如经中说。有一国王来问佛言。世尊。我有所疑。请问世尊。唯愿世尊。为我直答。不须广说。身中我者为大为小。为长为短。色相方圆各似何等。为在一处。为遍身中。佛言。大王。王得自在。今还问王。大王宫中庵罗树果作何气味。形状色相复似何等。王言。世尊。我所住宫无庵罗树。云何问言气味形色。佛言。大王。身中有我。王可问言大小长短。然此身中本无有我。云何令我答王所问。如是答者即是如来记于无我。多摩罗跋外道说言。第一义中有如来。取施设故。此谓若言无者。不于取上。而有施设。云何有取。谓取无上解脱熏修诸阴相续。故名如来。如经所说。佛之名者非父母作。乃至非诸天作。其义如是。复次云何名佛。谓最后得解脱时乃名为佛。以如是等故有如来。论者言。如上偈说。不即不离阴。阴中无如来。如来中无阴。非如来有阴。何等是如来。此谓如来于此第一义中毕竟不可得故。如论偈说

  一异无如来　　五种求不得
  云何当以取　　施设有如来

释曰。此谓第一义中有自体者。云何可施设耶。若可施设则非第一义中有自体者。若言如瓶。是假施设。欲得尔者。汝所立义。便为不成。如汝所言。以施设有如来者。此立因验第一义中不成。亦与因义相违。云何相违。谓取施设而有瓶等。但是世谛中有故。非第一义。复有自部人谓论者言。彼向说偈。若无有诸取云何有如来者。为不善说。我今说言有取者取若无取者。亦无有取。譬如龟毛聚。云何名取。谓无漏解脱不共法等。以为五阴。有所任持。是故如所说因云何名取者。谓如来身此如来有故。我所立义得成。论者言。是义不然。何以故。如论偈说

  如来所取取　　此取不可得
  取及取者空　　及一切种空

释曰。此谓取无自体。无自体义先已令解。不复更说。一切种者。谓自体种他体种等见真实者。一切种门观察之时。于第一义中不可施设。随顺世谛而有施设。云何施设。谓不可思议未曾有十力无畏不共等诸功德海熏修如来。为一切世间之所供养。中论者。因彼五阴作是施设。如经言。一人出世。多人利益多人安乐。以是义故名假施设。如佛言曰。我是众生真善知识。一切众生有生苦等令得解脱。又如佛言。应知者我已知。应识者我已识。应修者我已修。阿含经中作如是说。我所立义不与相违如来。于世谛中作是施设。非第一义。外人复言。第一义中不欲得者。自违彼宗。论者言。若第一义中有如来令人信解者。汝不出验。而亦不能破我所立。我非先受第一义故然后说遮。诸外道等甚可怜愍何以故。如经偈说

  十力无垢轮　　一切三有日
  无量众所归　　普照无明闇

  (众所归有本作言说光)

此谓如眼病者不信有日。或有说言。如来无一切智。是人故。譬如余人。复有说言。如来智者。非一切智。是智故。譬如凡夫智。复有说言。如来身者。非一切智所依止处。是身故。譬如凡夫身。论者言。是等所说非也。若第一义中如来无一切智而令信解。是人故。是凡夫智故。是凡夫身故。而为因者。此等因义咸皆不成。法身者。永离人故。智故。身故。诸有戏论故。三界所不摄故。是出世间无漏法聚故。名为法身。复次若更有人说言。如来无一切智。是作故。广说如是。诸因者。如前所立与其过咎。若复有人作譬喻言。如来身者。非一切智所依止处。是尸故。譬如凡夫死尸。此喻过失亦同前遮。智门譬喻出因等。若言是能取及有所缘。亦以此过说之。复次汝言如来无一切智者。此有何义。为一切不知少有所知耶。为一不知耶。若外人受初问者。即应问言。何故不知。若外人意谓不能知诸根境界。是故言不知者。论者言。此诸根等亦能有知。何以故。可知境界故。譬如自手等。若受后问者。汝先立义则为自破。何以故。汝先以人故为因者。岂有人一事不知耶。又复世间悉知故云何知耶。谓知如来有真解故。汝以凡夫等为喻者。是皆不然。世间凡夫亦少有所知故。复次如诸天等能知过去未来现在三界所摄及不摄等事。谓如来不知此事耶。若不知者。反成我义。云何成我义。谓汝天等以邪智所知故。与如来不同。又复以此智恶故名为无智耶。如汝所事大师等。为有一切智。为无一切智耶。若是一切智者。如来亦是一切智。若汝师无一切智而说如来无一切智者。如是之言不可信也。何以故。为汝师非一切智故。复有外道号聪慢者说言。如来无一切智。何以故。如来不记十四难故。又复说言。如来无一切智。何以故。如来不记孙陀利死故。又复说言。如来无一切智。何以故。如来不记旃遮女婆罗门作毁谤事故。又复说言。如来无一切智。何以故。如来不定记华氏城坏故。又复说言。如来无一切智。何以故。如来不知生死前际自障其无知故。又复说言。如来无一切智。何以故。如来不知提婆达多坏僧等事度出家故。是等不记不知者。如来无一切智故。论者言。汝聪慢等虚妄所说立义出因及以譬喻。今与其过。汝何不说。尼干外道计有我人众生寿命。汝何不说。鞞世师人计有实法。汝何不说。僧佉人计有自性。汝何不说。韦陀中所说丈夫如此等事。不能记不能说故。名为无一切智耶。为是等皆无故不记耶。又复汝言。总不知故名为不知者。此即是知。何等是总为一切诸法皆无自体而已。令物解故。佛涅槃后当来之世。诸弟子等亦以无自体义令众生解。复有弥息伽外道言。佛家所说十二部经者。非一切智人所说。有作者故。譬如鞞世师等论。论者言。若有作者。汝出因义不成。何以故。见有可化众生故。如来无功用。自然出言说。犹如天鼓。空中自鸣。如我法中作者受者皆无故。汝立有作者义。是因不成。汝违陀有作者诵习故。譬如鞞世师等论。汝所立因则非一向。若外人如是意韦陀文句无有作者。其义云何。作者时远。不能忆故。论者言。是说不善。汝但说因。无有譬喻。又汝韦陀中言一力山中造。一力毗陀三摩山中造三摩毗陀。迦逋处(唐言白领地)造阿闼毗陀。云何言无作者耶。是故汝立宗义不成若言是了非作者此了义先已遮。汝立了义不能成就。何以故。文句是作法。如人受学次第。披读文字章句。譬如僧佉论文句。复次汝文句是作法。有乐欲故。譬如僧佉论文句复次文句是作法。有受持故。譬如僧佉论文句。复次文句是作法。有诵习故。譬如僧佉论文句。以是等因应广为验。如弥息伽外道所计韦陀声是常者。今遮此义。汝所分别声者。非声自体。何以故。为根所取故。譬如色。复次声非了出法。是可依行因故。如言提婆达多将瓶来。即依声将瓶来。不将余物来。譬如头语手语等。如是有故。复次声非了出法。是所召法故。譬如头语等如是有故。复次声非了出法是能成立法故。譬如头语等。如是有故。复次声非出法。是喜怒因故譬如头语等。如是有故。以是等因当广为验。若有人言。劫初诸天子故者。亦同前遮。又复韦陀是破戒恶人所作说。杀生祀天。亲处邪行饮酒等故。譬如波西目伽论外人言。韦陀中说杀生者不是非法。以咒力禳不畏杀罪故。譬如以咒毒不害人。论者言。不与取邪行等。是极恶法。然非一向。是故作此杀生罪。是趣恶道因故。作意杀非以狂乱时杀故。譬如不入祭祀羊。又复若言羊等梵天遣来为祭祀者。此义不然。非为祭祀而来生也。何以故。是受食物故。譬如业报果。如是有故等。诸因广如上说。彼如是不颠倒一切法无自体者。如来所说一切天人之所供养。如来有一切智十力无畏等诸功德具足故。且置是事。今还说我本宗。如论偈说

  彼所取五阴　　不从自体有
  若无自体者　　云何有他体

释曰。此谓若不从自体有。云何从他体有。何以故。无自体故。亦无他体。其义如论偈说

  法体如是故　　取及取者空
  云何当以空　　而说空如来

释曰。思惟观察取及取者。是二皆空。云何以空说空。如来无是事故。外人言。彼先所说一切诸法皆无戏论。今复说言一切法空者。还是戏论。违本所说。论者言。实如所问。何以故如论偈说

  空则不应说　　非空不应说
  俱不俱亦然　　世谛故有说

释曰。若有人言离于闻慧而能于一切境界得第一义空者。则不说一切法空。无如是人故。为欲随顺所化众生福智聚故说空等语。但以世谛施设故说。为欲洗濯不善分别垢故。为破邪见痴眼膜故。说一切境界不空。何以故。若为说空增长邪见。又为破执我等膜故说一切境界空。第一义中如幻如焰。自体无生故。二俱不说。为遮异人立验故。为息于境界起二见过故。为得第一义故。说言无二。如是为洗濯不善分别垢故。说空无相无作梦幻等语。是故说空灭一切见。如论偈说

  若法有自体　　见空有何益
  诸见分别缚　　为遮此见故

释曰。此谓物有自体见空无益。为破彼见故赞于空。外人言。若言二俱不说者。此语即有戏论过。论者言。汝语非也。为遮异人分别故。而言二俱不可说。不可说故无过。譬如以声止声。复次若以第一义令信解者。无如是验。若住第一义心。以世谛智说。第一义中一切法空。作是说者无过。如后偈说。若不依世谛不解第一义。此谓为遮不空故说空。然不取空。是故无过。如是如来自体亦空。若有人言。如来若常若无常。亦常亦无常。非常非无常。世间有边。世间无边。亦有边亦无边。非有边非无边。若如来义得成。我义亦如是成者。今当答之。答如论偈说

  于寂灭法中　　无常等四过
  亦于寂灭中　　无边等四过

释曰。此谓如来。自体空能依无体。所依分别亦无体若外人意欲以如来出因。引喻成立我者。其义不成。以是故。因喻不同。亦违先义。如文殊所问经说。佛告文殊师利。不生不灭名为如来。若有人言。第一义中如来灭后不记有无。是故有如来。不如石女无儿说言无儿。我今答彼。汝以种种分别习气熏习智慧故。执说如来。是皆不然。如论偈说

  粗重执见者　　说如来有无
  如来灭度后　　云何不分别

释曰。此谓如来灭后如来有耶如来无耶。亦有亦无耶。非有非无耶。是义不然。正习智眼开者。如论偈说

  如来自体空　　不应起思惟
  灭后有如来　　及无有如来

释曰。此谓境界无体慧无分别。以是故。汝先出因。譬喻有过。何以故。有无常无常色身。言教身法身。能相所相因果。能觉所觉。空无相无作无愿。如幻如梦等。悉是分别。如论偈说

  戏论生分别　　如来过分别
  为戏论所覆　　不能见如来

释曰。譬如生盲者不见日轮。不见如来亦复如是。何故不见。戏论分别覆慧眼故。是名不见。云何为见。能见法性如来。是名为见。复次如经偈言。能见缘起者。是名为见法。若能见法者。即为见如来。复次色身是如来言教。身及法身。亦是如来者。如前偈说。戏论生分别。如来过分别。又如金刚般若经中偈言

  若以色见我　　以音声求我
  是人行邪道　　不能见如来

作如是观察时。外人所立诸体自体言有成立。引如来为譬喻者不然。如论偈说

  以如来自体　　同世间自体
  如来无体故　　世间亦无体

释曰。此谓观如来时诸阴界等无有自体。分别一切自体皆无体故。云何分别。谓阴界入能相所相。若因若果。有体无体。一异等法。如上广分别者。悉皆无体。诸阴入等云何无体。如观阴品中说。若离彼色因有色者不然。如彼所观道理阴无体故。如来亦无体。又如观界品中说无物是虚空。彼中如虚空等观察六界时。非自体非他体。非能相非所相。一切诸体悉皆无故。已说色无自体。次观识界。如是识界等分别为如来者。观彼识界。非体非无体。非能相非所相。无自体故。亦无如来。又如观入品说入无自体已令开解。离此诸入无别见者得成。如是以诸入境界为如来者。义皆不成。又如然可然品已明一异俱遮薪之与火皆无自体。如是若以智为如来。及以三十二相八十种好。慈悲喜舍。十力无畏。三十七道品。六波罗蜜。诸功德聚为如来。乃至法性法界法住实际真如涅槃。如是等法与如来身。为一为异。非一非异。此等无自体故。如来亦无自体。又如观缘品说无起中已遮起故。亦遮如来起无自体。又如观去来品已遮去来无自体故。如来亦无自体。以是故外人立义皆无自体。亦违先出因义故。如向偈说。如来无体故。世间亦无体。是故品初说外人立义等过而令信解。自说法身有成立义。亦令信解。以是义故。我义得成。如楞伽经中说。佛告大慧菩萨。如来身者。非常非无常。非因非果。非有为非无为。非觉非界。非相非无相。非是阴非离阴。非言说非所说物。非一非异。悉无和合乃至无所得无所缘。出过一切戏论者。名为如来。又如如来三密经说。佛告寂慧菩萨。如来身者。等虚空身。无等身。胜一切世间最胜身遍一切众生如身。无譬喻身。无相似身清净无垢身。无染污身。自性清净身。自性无生身。自性无起身。不与心意识等和合身。如幻如焰如水中月自体身。空无相无愿所观察身。遍满十方身。于一切众生平等身。无边无尽身。无动无分别身。于住不住得无坏身。无色体身。无受想行识身。非地界非水界非火界非风界等所合成身。如是身者。非实非生。亦非大等所成。非实非实法。一切世间所不能知。不从眼生。不依耳闻。不为鼻识所知。非舌所成。亦不与身相应。又如舍利弗陀罗尼经所说。唯修一心念佛。不以色见如来。不以无色见如来。不以相不以好。不以戒定慧解脱解脱知见。不以生。不以家。不以姓。不以眷属。乃至非自作非他作。若能如是名为念佛。又如佛地经中偈言。无起等法是如来。一切法与如来同。虽凡夫智妄取相。而常行于无法中。无漏根力众德镜于。中显现如来像。而实无有真如体。亦未曾有如来身。世间所见如镜像。从本无于往来相。又如楞伽经偈言。佛以阴缘起无处有人见。若言无人见云何可观察

释观如来品竟

般若灯论释卷第十三般若灯论释卷第十四

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观颠倒品第二十三

释曰。今此品者。亦为遮空所对治。令解颠倒无自性故说

自部人言。有分别故。起诸烦恼。如是烦恼从颠倒起。以颠倒故则有贪等。彼若无者。义不相应。故论偈言

  分别起烦恼　　说有贪嗔等
  善不善颠倒　　从此缘而起

释曰。诸论中说贪嗔等。随次第起善不善者。谓爱非爱从此缘起。非不从缘。应知不正思惟分别。能为起烦恼缘。此中立验。第一义中诸阴等有自体。是第一义中阴等从因缘起故。譬如贪等。若无自体不从缘起。譬如虚空华。论者言。是义不然。如论偈说

  爱非爱颠倒　　皆从此缘起
  我无自体故　　烦恼亦非实

释曰。非实者谓贪等烦恼非第一义中起。以是故汝阙譬喻。是立义有过。汝若言我以世谛为喻非第一义者。无有所成立法。若于世谛中有成立者。反成我义。如论偈说

  我若有若无　　是二皆不成
  因我有烦恼　　我无彼不起

释曰。此谓我者非世谛得成。亦非第一义中得成。以是故。若离于我则烦恼不有。所以者何。能依无体故。所依亦无体。为开此义故如偈说。因我有烦恼者。烦恼是我法。亦是所受用故。然我自体不成。如观我品中观烦恼无能依处故。其验如是。第一义中贪等皆无。我依止无体故。譬如石女不生子。何得说言子色白黑耶。自部人言。虽无有我但心与烦恼和合故有烦恼起。而烦恼是心上法。汝立无我义者。其因不成。论者言。汝语非也。其过如论偈说

  谁有彼烦恼　　有义则不成
  若离众生者　　烦恼则无属

释曰。此谓烦恼是众生者。于一切处推求众生不可得。若离众生烦恼无属心起者。先已遮故。亦除识自体故。亦遮有实故。汝心义不成。非我因义不成。自部人言。彼受无烦恼义者。则以无为体。无体之体成故。诸体更互无体相。论者言汝今欲得诸体若瓶若绢及余物等有者。为是体。为是无体。而言能起有觉因耶。欲令瓶是无体者。则不应说此瓶与青黄黑色等和合。亦不应说青黄等色示人。若有无瓶绢处不可说。青黄等色亦不可指示于人。无依止处故。是诸烦恼毕竟无主无体义者。如石女儿无青黄相可说故。是故以无为体义不成。今当次答自部人等。如论偈说

  身起烦恼见　　缘于我我所
  烦恼与染心　　五求不可得

释曰。名色聚集因名为身。缘于自身起染污见。是名身见。贪等三种与此义同。如观如来品中偈说。非阴不离阴。阴中无如来。如来中无阴。非如来有阴。诸烦恼亦如。五种中无烦恼者。能起苦故名为烦恼。染者非烦恼。今为遮不异义故。若染者即烦恼。能烧所烧同得一过。亦不异烦恼有染者。此义已如先遮。复次若异烦恼得有染者。则离烦恼独有染者过。是故异体不成。染者中亦无烦恼。烦恼中亦无染者。亦非染者有烦恼。如是五种求烦恼无体。以烦恼无体故。则无能成立法。是汝譬喻有过。如论偈说

  爱非爱颠倒　　本无有自体
  以何等为缘　　而能起烦恼

释曰。如我法中爱非爱颠倒本来无体。以是故。第一义中烦恼非是从缘起法。无能成立法故。是汝立义之过。复次有自部人言。色等六物能起颠倒。云何无耶。彼谓无者。其义不尔。故论偈言

  色声香味触　　及法为六种
  爱非爱为缘　　于物起分别

释曰。此谓缘六种物能起诸烦恼。此中说验。第一义中有爱非爱颠倒为缘能起贪嗔痴等。第一义中物有体故。若言无者。非六物体。譬如生盲者眼识。又贪嗔等能起颠倒分别。如我所说。因有力故。有诸颠倒。以是因缘譬喻无过。论者言。汝语非也。皆是虚妄。如论偈说

  色声香味触　　及法体六种
  如乾闼婆城　　如焰亦如梦

释曰。如是等自体皆无自体。势分亦无。乃至世谛诽谤之过亦无。无何过耶。以无此物故。云何如乾闼婆城。以时处等众人共见故。是名如乾闼婆城。云何如焰。譬如愚者。见热时焰。谓言是水。逐之不已。徒自疲劳。竟无所得。如是一切诸法自体皆空。着法凡夫亦复如是。故言如焰。云何如梦。有时有所思念因果体及一切法无自体故。是名如梦。若色中有者。如论偈说

  若爱若非爱　　何处当可得
  犹如幻化人　　亦如镜中像

释曰。第一义中爱非爱皆不可得。何以故。第一义中色像等自体空故。云何如幻化人。于不实境界显现相似故。云何如像。不待人工而能起现。与形相似故。以是因缘。汝上出因立义等不成。何以故。第一义中物体不成故。亦违汝义。如论偈说

  若不因彼爱　　则无有不爱
  因爱有不爱　　是故无有爱
  无不爱待爱　　无爱待不爱
  若以爱为缘　　施设有不爱

释曰。爱无自体。其义如是。以是故。不应有不爱。不爱无体故。爱不待不爱而言有爱者。是亦不然。如论偈说

  无有可爱者　　何处当起贪
  不爱若无体　　何处当起嗔

释曰。彼二无体故痴亦无体。是故如所说过。今还在汝。修多罗人言。第一义中有如是爱非爱颠倒。如佛经所说。若经中说者。当知是有譬如说无我定是无我。今经中现有此语。所谓无常计常。无我计我。无乐计乐。不净计净。是名颠倒。以是义故。第一义中有如是爱非爱颠倒。论者言于世谛中有爱非爱颠倒。非第一义中有。是故我说无过。如论偈说

  于第一义中　　毕竟无颠倒
  如来终不说　　是我无我等

释曰。第一义中亦不说我无我故。汝譬喻及出因无体。复次若修多罗人意言。第一义中不欲得有颠倒。何以故。颠倒者有二种。一者随顺生死。二者随顺涅槃。云何名随顺生死。所谓无常常倒。无我我倒。无乐乐倒。无净净倒。云何名随顺涅槃。所谓于空执空。于无常执无常。有如是等故名颠倒。若欲得无分别智者。当断此二种颠倒。为是智障故。自部人言。若于无常之物起无常见是颠倒者。其义不然。论者言。颠倒者是何义耶。自部人言。实是无常。谓是常者可名颠倒。论者言。是说不善。其过如论偈说

  无常谓常者　　名为颠倒执
  无常亦是执　　空何故非执

释曰。谓彼智所缘颠倒境界故。此言即是颠倒义。譬如人言。离三界欲已。何故不名解脱。如此之言即是解脱。自部人言。汝今复说无常亦空。云何不是第一义耶论者言。无起故。此无起义。道理如先已遮。譬如涅槃无起亦无无常。复次此无常体能起常分别智。若言是颠倒执常觉。所缘境界则无有体。是故如前偈说。无常亦是执空何故非倒者即是颠倒。何以故。有分别故。譬如常执者。此中立验。第一义中色无常者。即是颠倒。是分别故。譬如执色为常。自部人言。智分别者。言诸行空。其智非一向颠倒。论者言。亦是颠倒。我说无过。自部人言。若如是者。此空智非是得解脱因。是倒故。譬如内入是苦乐等智之境界。论者言。汝立义中是何义耶。自部人言。缘眼空智非是得解脱因耶。论者言。若尔者反成我义。云何成我义。以无分别智得解脱故。若言眼空。眼空之智是有分别故。且置是语。今还为汝说我本宗。如执无常为常。即是颠倒。无我为我。无乐为乐。不净为净。亦如是说。有自部人立义分别言。有如是执。以有能执所执故。然其起执凡有三种。而不是无。论者言。汝义不然。如论偈说

  执具起执者　　及所执境界
  一切寂灭相　　是故无有执

释曰。执有三种。谓具起及境界等。执具者。是能执总缘物体智。起执者。谓所执心。或妄置。或非拨等。又须执者。谓起执人所执境界者。谓所计常乐我净等境界。此之三法皆自体空。如我所说道理。欲令开解执具等一切皆寂灭相。是故无执。而彼执者。以有有之言令物解者。无有譬喻。以是故。如论偈说

  执性无有故　　邪正等亦无
  谁今是颠倒　　谁是非颠倒

释曰。第一义中谁是颠倒。谁是非颠倒。菩萨摩诃萨住无分别智。不行一切分别。无正无邪。无颠倒无不颠倒。复次若人言定有颠倒。有具足颠倒者故。譬如有盖则有持盖者。凡夫有颠倒亦如是。由有颠倒者。是故有颠倒。论者言。是义不然。如上偈说。执性无有故。邪正等亦无。此二道理先已令开解故。有起者亦不成如是如是。颠倒及颠倒者亦不成故。如上偈说。谁是颠倒谁非颠倒。此言谓无颠倒。无颠倒故颠倒者亦无。复次若有颠倒即有非颠倒。以是故。汝因义不成。第一义中譬喻无体。亦违汝义。复次世间人言。与颠倒合者名颠倒人。此之颠倒。为与已起倒者有合耶。为与未起倒者有合耶。为与起倒时有合耶。今答此三种与颠倒合者。是皆不然。如论偈说

  已起者无合　　未起亦无合
  离已未倒者　　有合时不然

释曰。此谓已有倒者。更与倒合。则为无用。何以故。倒者空故。譬如余不倒者。若言有倒与时合者。此有俱过。离倒不倒与时合者不然。作是观时悉皆不然。若言有者。汝今当答。此之颠倒与谁合耶。是故无有与倒合者。以是义故。汝得如先所说过。复次如第一义中一切诸体皆无自性。说此道理已令开解。以是故。如论偈说

  无起未起者　　云何有颠倒
  诸倒悉无生　　何处起颠倒

释曰。此谓偈意显无生故无有颠倒。汝出因等。皆是有过。如论偈说

  常乐我净等　　而言实有者
  彼常乐我净　　翻则为颠倒

释曰。此谓第一义中有常我等。应知亦是颠倒。如论偈说

  我及常乐等　　若当是无者
  无我苦不净　　而应是可得

释曰。此谓无我等自体能除我等倒。以有相待故。无我等亦不成无。无我故何处有我。是颠倒见故。譬如无人。终不于杌起人想颠倒。如是因等其过难免。以是观察常无常等颠倒及不颠倒。无有因故。无因者。如论偈说

  以彼无因故　　则无明行灭
  乃至生老死　　是等同皆灭

释曰。此谓无明行识名色六入触受爱取有生及老死等。由无颠倒因故证得无自体息诸烦恼。其义得成。诸说有自体者。是诸烦恼。为有实体。为无实体。今何所问。如论偈说

  若人诸烦恼　　有一自实体
  云何能断除　　谁能断有体

释曰。此谓有自体者。不可坏故。若诸烦恼无实如兔角者。亦如此偈说过。云何不能断。谓无者。不可舍故。如虚空华不可舍。无自体故。如马体无。不可令舍此无。复次若作是意。谓有实烦恼。圣道起时能断故。谓此说无过者。此实烦恼似何等相。对治道起而能断耶。汝之立义难令物解。以是故起有实体无实体烦恼分别。而能断此分别者不然。是中立验。第一义中烦恼无。自体是断故。譬如幻作女人虽是幻化而诸凡夫起染欲心。后知非实染心自舍。烦恼无实亦复如是。此中已说外人所成立验有过。显我自成立验无过。令解颠倒无自体故。是品义意。以是故。此下引经显成。如金光明女经中偈说。言语非是色。一切处无有。毕竟无有故。烦恼亦如是。如语无实体。不住于内外。烦恼体无实。亦不住内外。佛告舍利弗。若解染污即如实义。无一染污颠倒可得。众生起染。若无实者。即是颠倒。若彼颠倒是无实者。于中无真实相故。舍利弗。如是解者说为清净。以烦恼无实体故。如来成正觉时。所说烦恼。非是色。非是无色。非受想行识。非无受想行识。非非识。非非无识。不可见故。不可取故。解者无所断除。证时亦无所得。不以证。不以得。无证无得。无相无为。但假名字。犹如幻化。于诸法不动相非取非不取。如影如响。离相离念。无生无灭

    般若灯论释观圣谛品第二十四

释曰。今此品者。亦为遮空所对治。令解四圣谛无自体义故说

自部人言。若谓圣谛空无自体。是义不尔。故论偈言

  若一切法空　　无起亦无灭
  说圣谛无体　　汝得如是过

释曰。如彼所说道理。令物信解者。是事不然。空故如虚空华。以是故。彼招此过。起灭无体故。即无苦谛体。苦谛无体故。能起集谛。亦无体。集谛无体故灭谛亦无体。灭谛无体故向苦灭道。以正见为首。道谛所修即为无体。如上偈说。彼得此过。以是故。诸有怖畏生死众生。于四谛境界勤行精进。苦应知。集应断。灭应证。道应修。此等皆无。云何无耶。故论偈言

  若知及若断　　修证作业等
  圣谛无体故　　是皆不可得

释曰。四圣谛者。谓能作圣人相续体故。名为圣谛。又复谛者。谓真实义。若说无者。是义不然。故论偈言

  圣谛无体故　　四果亦无有
  以果无体故　　住果者亦无

释曰。此谓身见疑戒取等众过为薪。圣谛为火。须陀洹。斯陀含。阿那含。阿罗汉等。见圣谛火能烧烦恼。住果者。谓得须陀洹道。须陀洹果。又名不为他缘和合故。所有天魔不能破坏。又与戒定慧解脱解脱知见等和合故名僧。是僧名为无上福田。彼若无者。其义不尔。故论偈言

  若无有僧宝　　则无有八人
  圣谛若无体　　亦无有法宝

释曰。若无僧宝不应有四道四果差别。复次无僧宝故。亦无法宝。法宝无故。亦无佛宝。故论偈言

  若无法僧者　　云何有佛宝
  若三宝皆空　　则破一切有

释曰。佛者谓自觉圣谛。复能觉他。故名为佛。云何为宝。谓难得故。如经偈言。应解我已解。应修我已修。应断我已断。由是故称佛。此谓于一切法有自体中得平等觉是故名佛。如修多罗中偈言。于无体法中。觉了尽无余。诸法平等觉。是故名为佛。此谓诸佛所觉境界。若言无体者不然。如上偈说。若三宝皆空则破一切有。是义有过。故论偈言

  若因果体空　　法非法亦空
  世间言说等　　如是悉皆破

释曰。此谓作是说者。而不欲得有过。此过云何免耶。若不立空而有起灭诸体有自体者彼得无过。是中作验。诸体有自体有起灭故。若言诸体无自体者。不应见有起灭譬如空华。论者言。汝所引者义皆不然。如论偈说

  汝今自不解　　空及于空义
  能灭诸戏论　　而欲破空耶

释曰。空者能灭一切执着戏论。是故名空。空义者谓缘空之智。名为空义。汝今欲得破坏真实相者。如人运拳以打虚空。徒自疲极终无所损。汝若作是言。如上偈说。若一切法空。无起亦无灭。汝作如是说者。亦徒疲劳不解中意。何以故。如论偈说

  诸佛依二谛　　为众生说法
  一谓世俗谛　　二谓第一义

释曰。世谛者谓世间言说。如说色等起住灭相。如说提婆达多去来。毗师奴蜜多罗吃食。须摩达多坐禅。梵摩达多解脱。如是等谓世间言说。名为世谛。是等不说名第一义。第一义者云何。谓是第一而有义故。名第一义。又是最上无分别智真实义故。名第一义。真实者。无他缘等为相。若住真实所缘境界无分别。智者名第一义。为遮彼起等随顺。所说无起等及闻思修慧。皆是第一义。慧者云何。是第一义。能为第一遮作不颠倒方便因缘故。是故复名第一义也。如论偈说

  若人不能解　　二谛差别相
  即不解真实　　甚深佛法义

释曰。此谓若人不解二谛差别。不错乱境界相者。不正思惟。多者此人不解甚深佛法。而起有体无体执觉。深者云何。难涉渡。佛者如先已解。法者为令天人证得甘露法故。行者于如是等甚深境界。应知应断应证应修。复次说不颠倒教者名甘露法。是人于第一甚深无分别智道理不解故。虽行不颠倒住真法境界。而于无起无灭法体说众生。于非境界起境界见。作如是说者。不解中论道理。而言世谛中起灭等法。一切皆无。作是分别者。其过亦如上偈说。若一切法空无起亦无灭。有如是分别者。不解诸佛如来随顺世谛。说有持戒修定生住灭等诸法体。无智之人谓第一义中亦有是事。作是虚妄分别者。堕在诸有旷野之中。无有出期

自部人言。若以第一义谛得解脱者。不应宣说二谛。论者言。以是事故。如论偈说

  若不依世谛　　不得第一义
  不依第一义　　终不得涅槃

释曰。世俗谛者。一切诸法无生性空。而众生颠倒故妄生执着。于世间为实。诸贤圣了达世间颠倒性故。知一切法皆空无自性。于圣人是第一义谛。亦名为实。佛为众生依二谛说。云何为第一义谛。谓普过一切言语道故。一切小乘所分别者。令离一切分别因故。复次若无世谛不能证得第一义谛。以是故。烦恼及生等灭者。是涅槃相。若不依第一义谛。涅槃之道终不可得。复次外道中。若有聪慢者。作如是分别。有空不空。云何为空。谓见诸阴空。以彼执见无体故。云何不空。谓见诸阴不空。而言我已见我。今见我当见如是诸阴空。不离诸阴有空。空中见诸阴。诸阴中见空。作是见者。是不正思惟。名增上慢。如论偈说

  少智愚痴者　　以恶见坏空
  如不善捉蛇　　不如法持咒

释曰。此谓与无分别慧命作障碍故。如是等为恶见所坏。复次于诸无体起有体见。亦名坏空。譬如不善捉蛇之人。自害其命。于空执有体者。亦能害解脱命。如持咒人不依咒法而自损坏。以是故。不善解空者。能作种种不饶益事。如论偈说

  诸佛以是故　　回心不说法
  佛所解深法　　众生不能入
  汝今若如是　　于空生诽谤
  谓法无起灭　　乃至破三宝

释曰。诽谤者。谓言一切是空。汝嗔忿故。欲与空作过者。空终不被汝过。何以故。诸体无自体者。于第一义中空故无体。无体义者。我亦不用以有执着相故。复次为遮自部人所分别空者。今遮此空故而言空无自体。亦不执空作是分别。空者今应舍故。如宝积经中说。佛告迦叶。宁起我见如须弥山。亦不作增上慢者起于空见。以是义故。不见色空。不见色不空。如论偈说

  若然于空者　　则一切皆然
  若不然空者　　则一切不然

释曰。此谓正见空者何等为一切皆然。谓有起等。云何然耶。谓有无等及眼等。皆自体空。如幻丈夫。丈夫自体。空何以故。一切藉众缘聚集为体故。云何为体。体谓苦也。云何为苦。谓此起者名苦。见苦等行名为苦谛。云何为集。谓起苦因者名集。复次集者。谓从此起苦故名集。若见集等行名为集谛。灭苦因者名之为灭。见灭等行名为灭谛。为得灭苦因方便故。而名为道。若见道等行名为道。谛彼圣谛如是有故其法得成。以自然智觉。于一切行故乃名为。佛随顺声闻说者。如经言。佛告诸比丘。如是苦者我于往昔不闻诸法中得眼起智起明起觉起是等诸体自体皆如幻故。第一义中见无起等名见圣谛。如文殊道行经说。佛告文殊师利。若见一切诸法无起。即解苦谛。若见一切诸法无住。即能断集。若见一切诸法毕竟涅槃。即能证灭。文殊师利。若见一切诸法无自体。即是修道。以是义故。摩诃衍中圣谛道理得成。道理成故。智慧得成。智慧成故。一切皆可然若诽谤空者。如上偈说。若不然空者。一切皆不然。如论偈说

  汝今持自过　　而欲与我耶
  亦如人乘马　　自忘其所乘

释曰。若汝不欲令空有过失者。今当说之。如论偈说

  汝若见诸法　　皆有自体者
  诸体无因缘　　还成自然见

释曰。若见诸体有自体者。则无诸体从因缘生。不待因缘而有体故。复次若见诸体有自体者。今当说过。如论偈说

  若因果无待　　作者及作业
  及至起灭等　　一切法皆坏

释曰。此谓不待因缘者。因果等义皆亦不成。汝云何于空义妄生分别。譬如小儿见画夜叉而生怖心。发声大叫。若色等是空无有自体。如虚空华。作是分别者。不应于此而生怖畏。以是故。如论偈说

  从众缘生法　　我说即是空
  但为假名字　　亦是中道义

释曰。眼等诸体从缘起者。诸缘中眼等非有非无非。亦有亦无非。非有非非无。非异非一。非自非他。亦非俱非不俱。所有从缘起者。第一义中自体无起。依世谛故有眼等起。我说此起空者。谓自体空故。如经偈言。从缘不名生。生法无自体。若有属缘者。是即名为空。世间出世间。但是假施设。其有解空者。名为不放逸。如楞伽经说。自体无起。体无起者。如佛告大慧。我说一切法空。若言从缘生者。亦是空之异名。何以故。因施设故。世间出世间法。并是世谛所作。如是施设名字即是中道。如摩诃般若波罗蜜经说。云何名中道。谓离有起无起及有无等边故。名为中道。所谓诸体无起无不起。非有非无。非常非无常。非空非不空。修中道者。观察之时。不见眼有体。不见眼无体。乃至色受想行识不见体。不见无体。又如宝积经说。佛告迦叶。有是一边。无是一边。离二中间。则无色无受想行识。如是中道名为得证实相方便。以是故。如论偈说

  未曾有一法　　不从因缘生
  如是一切法　　无不是空者

释曰。此谓从缘所起物。譬如幻等丈夫毕竟无体。僧佉人言。如虚空等不从缘生。从缘生法为出因者。于彼宗中一分之义此义不成。是彼出因之过。论者言。虚空之过已如先说。大过咎者。今聚汝身难可逃避。云何过咎。如论偈说

  若一切不空　　无起亦无灭
  无四圣谛体　　过还在汝身

释曰。此义云何。若苦非空有自体者。则无作者。无作者故。不从缘生。执是有者。世谛之中亦所不信。何况第一义耶。以是故。如论偈说

  不从缘生者　　何处当有苦
  无常即苦义　　彼苦无自体

释曰。此谓若不从因缘生者。即是常。常则非苦。修多罗人言。若无常故苦。苦故无我。若无我者。则无自体。以如是故苦无自体。论者言。汝所说者义不相应。如论偈说

  苦既无自体　　何处当有集
  以集无有故　　是则破于空

释曰。此谓苦体无起。何以故。若有自体者。不待因缘有。如论偈说

  苦若定有性　　先来所不见
  于今云何见　　其性不异故

释曰。若先不见苦性。得圣果时亦应不见。何以故。性若定者。云何可见。如论偈说

  苦若有体者　　不应有灭义
  汝著有体故　　即破于灭体
  苦若有定性　　则无有修道
  道若可修者　　即无有定性

释曰。此谓若有灭体即有苦体。修者云何数数起正见等。故名为修。若此道体先已成就而有起者不然。若欲避此等过。而说道可修者。如论偈说

  若道是可修　　即无有自体
  苦集乃至灭　　是等悉皆无

释曰。此谓道有起义若成亦不离无自体。以是故。如上偈所说道理。无起苦者。以苦无故。灭则无体。若言是灭苦之道者。如论偈说

  为灭苦者道　　何有道可得
  不解苦自体　　亦不解苦因

释曰。此谓如汝所说道理苦有自体。有自体者则不可解。亦不解苦因之过。断义不成。不断因体故。断即无体。爱体无尽者。有尽义不成。灭名无体。无体故证灭义不成。若无证灭趣灭之道。有自体者。则无有修。若无修道亦无证四果人。若欲得有证果人。而执有自体见不舍者。今问何故不舍。若所证之果有自体者。云何复说有能证人。以是故。如论偈说

  既无果自体　　住果向亦无
  以无有八人　　则无有僧宝

释曰。八人者。谓四道四果。人有差别故。人者云何。谓人中胜人士夫等。若四圣谛无自体者。非独无僧。如论偈说

  若无四圣谛　　亦无有法宝
  无有法僧故　　云何当有佛

释曰。佛者能以法觉弟子故名佛。复次今问执有自体者。佛婆伽婆为有自体。为无自体。问曰。此有何过而作是问耶。答曰。若汝欲得佛有自体者。则不藉觉了真如而名为佛。如论偈说

  不以觉为缘　　佛堕无缘过
  不以佛为缘　　觉堕无缘过
  佛有自体者　　诸菩萨修行
  为佛勤精进　　不应得成佛
  是法及非法　　无人能作者
  不空何须作　　有体作不然

释曰。此谓若法有自体而起作者不然。又汝意谓亦不长小令大。亦不了闇令明。此过已如前说。自部人言。云何作者皆无自体。论者言。处处作者。皆见无自体故。譬如幻所作事内入等。有作亦如是。而此内入亦无自体。若有一物有自体者。即违先义。此谓无有所作体故。汝执有自体义。体若有者。汝可分明为我说之。若言有作及有体者。似何等物。是故汝所说者。皆是邪见。如论偈说

  无法非法因　　果得无因过
  若离法非法　　汝得无待果

释曰。若汝意谓不违世论。作如是说。欲得有法非法者。如论偈说

  若汝欲得有　　法非法因果
  从法非法起　　云何不是空

释曰此谓凡有起者皆空故。譬如幻所作事。非独违汝自宗。今更有余过咎。如论偈说

  一切言说事　　世间皆被破
  若坏缘起法　　空义亦不成

释曰。言说者谓作是言。作瓶作衣提婆达多言将白牛来我欲饮乳。若瓶等有自体须。作者不然若不欲得从缘起者。如上偈说。若坏缘起法。空义则不成。汝坏空义得何等过。如论偈说

  一物不须作　　亦无人起业
  不作名作者　　则坏于空义
  无生亦无灭　　是则名为常
  种种诸物类　　皆住于自体

释曰。云何为物类。譬如画壁有种种色。种种形。种种性。种种量等差别。云何名住自体。谓无作者名住自体。以不坏故。而名为常。若言常者。如论偈说

  未得者应得　　及尽苦边业
  一切烦恼断　　以无空义故

释曰。此谓世间出世间所证胜法者。及尽苦边者。不须修对治法。所说之相。而不欲得。如是故欲得从缘起法。如幻如焰。自体无起。为有体无体等。有过失故。翳慧眼者妄见诸法不从缘起。此见是世谛见。妄执为第一义。其见何等。如论偈说

  所谓苦与集　　乃至于灭道
  见有生灭者　　是见名不见

释曰。云何不见。谓不见如实缘起法故。自部人言。若离见苦等诸行无有别见谛法。论者言。见谛者有何义耶。自部人言。谓见内诸入等有自体。不颠倒故。论者言。汝所说起等道理。先来已遮。见苦等无起。是见谛义者。得成汝向说。见内入等有自体不颠倒者。是语颠倒。汝之所欲。其义不成。应细观察。云何见苦。非如子从母索欢喜丸。指手言。得此品中为自部人所说有过遮空对治明圣谛无体。令物信解是品义意。以是故。此下引经显成。如梵王所问经说。佛告梵王。以此门应知苦非圣谛。知集灭道亦非圣谛。复次云何是圣谛耶。梵王。若苦无起。是名圣谛。集无能起。是名圣谛。见一切法毕竟如涅槃无起灭者。是名圣谛。若知诸法平等无二修于道者。是名圣谛。是故经说。若见因缘法。是人能见佛。亦见圣谛。能得圣果。灭诸烦恼

释观圣谛品竟

般若灯论释卷第十四般若灯论释卷第十五

        偈本龙树菩萨　释论分别明菩萨

        大唐中印度三藏波罗颇蜜多罗译

    观涅槃品第二十五

释曰。今此品者。亦为遮空所对治。令解涅槃无自体义故说

鞞婆沙人言。彼先言。若一切非空。则无有起灭。此谓无自体义。无自体者。如石女儿。则无起灭。烦恼无自体故。非是起灭。而烦恼及名色因亦非起灭者。如上偈说。无断苦证灭。复谁得涅槃。彼先已作此说者。我今欲得有所断故证于涅槃。如经所说。染与染者。共起烦恼。此尽灭故。名为涅槃。如是涅槃心得解脱譬如灯灭。得涅槃者。由烦恼有自体故。如彼上说无自体者。若无烦恼体亦无涅槃。譬如石女儿。复次若以无自体为验无得涅槃者。亦破得涅槃义。即是破于差别法体。是彼立义出因之过。论者言。汝说不善。诸法无自体者。如幻灯灭。是亦不违世谛智境界故。无自体者。从无始因缘展转而起。如幻如焰。诸行无起。即是涅槃。证得涅槃亦复如是。无有自体。我亦不立无体体故。非立义过。上引石女为喻者。于第一义中得成。汝执有自体义者。不可坏故。有所断者不然。以是故。若不见真实理。而说有自体者。得涅槃义不成。法自体坏故。是事云何。汝向出因立义譬喻。三法皆不成故有过。复次鞞婆沙人言。如彼偈说。若一切非空则无有起灭。无断苦证灭。复谁得涅槃者。不然。我今立有涅槃。云何为涅槃。谓第一义中诸行有自体。断诸烦恼及灭名色而得涅槃故。非如驼角。涅槃不尔。有体有断有灭有得故。论者言。如先偈说。若一切非空。则无有起灭。无断苦证灭。云何得涅槃者。此谓有自体。不可坏故。自体者。若是自宗出因立喻有相似者。所成能成则为有力。而今无此力故。因与喻义亦不成。又亦违汝先所立义。我今问汝所立涅槃。为是第一义谛。为是世谛。若欲得是第一义谛者。我今答之。如论偈说

  无退亦无得　　非断亦非常
  不生亦不灭　　说此为涅槃

释曰。此谓如是涅槃。我所欲得。如汝所说。断故灭故。为出因等。断诸烦恼得涅槃者。此等因义。今皆不成。颠倒心故。作如是说。义皆不然。复次诸执有涅槃者。或说涅槃是真实法。或说涅槃是施设法。二俱不然。以是义故。次须观察。如论偈说

  涅槃有自体　　即堕老死相
  涅槃是体者　　即是有为法

释曰。此谓涅槃有自体者。无验可令信解。若令涅槃有体。即堕老死相。何以故。无有体离老死相。亦无老相死相离体。小乘之人不欲涅槃有老死相。以是故。如我出验。第一义中涅槃非是体。无老死相故。譬如石女儿。是故汝宗因义不成。因不成故。亦与正义相违故。复次今更与过。若汝不欲涅槃是有为。而欲得涅槃。是无为者不然。无处有一物是体复是无为者。今当立验。涅槃非是体无为故。譬如空华。复次更说其过。如论偈说

  涅槃若有体　　云何是无因
  亦无有一法　　离因而得有

释曰。此谓体者。皆藉因得有施设。涅槃是体不得无因。以是故此中出验。涅槃非是体。无因能施设故。譬如兔角。多摩罗跋。及修多罗人等言(多摩罗跋者唐言赤铜叶)。如鞞婆沙师说。涅槃如灯灭。我今说涅槃者。但是无起。于世谛中施设有故。我所立者其义相应。论者言。今答此者。如论偈说

  汝涅槃非体　　云何是无体
  若涅槃无体　　云何是无因

释曰。鞞婆沙等分别涅槃是第一义。善以息烦恼为因。今汝义非如是体故。而言涅槃无体者。为无善等耶。义皆不然。譬如空华。若言涅槃无实无自体者。无如是验。能令开解。涅槃非无体者。汝之所说难令人解。复次鞞婆沙分别涅槃先有体后无体。以灯为喻者。此是显示世间所解。以灯未灭时有体。灭已是无体。若汝计无体同彼已灭灯者。如向偈说。若涅槃无体云何是无因。此谓如灯无体。而有因施设作灯。如是诸阴烦恼无体。而有因施设为涅槃。如论偈说

  涅槃非无体　　而不藉因者
  若无因无缘　　是名为涅槃

释曰。如汝所说。涅槃无体是第一义。以是故。因有来去流转相而施设有生死涅槃有体无体者。是世谛中所说。非第一义。如论偈说

  大师所说者　　断有断非有
  是故知涅槃　　非无亦非有

释曰。如经说。或有人以有求出有。或有人不以有求出有。是皆不然。若言涅槃是体者不然。犊子部言。我今立涅槃者。与彼不同。有是体义。有非体义。有二义故。无如上过。是义应尔。论者言。汝所立者其义不然。如论偈说

  若汝说涅槃　　是体是非体
  涅槃是体故　　解脱者不然

释曰。此谓体非体相违故。若是体则非非体。若是非体则不是体。若相待者。则有体非体相。如是说者。义不相应。何以故。有分别执着过故。犊子部言。涅槃者。云何非体。谓身及诸根无体故。名为非体。云何是体。谓有毕竟无上乐故。名为是体。论者言。此语不善。身诸根及觉等已遮故。亦即是遮无起等。毕竟无上乐者。如遮有为起。亦遮彼乐。若欲以无为乐令物解者。无此验体。汝之所立义不相应。复次若言涅槃有自体者。如论偈说

  若汝说涅槃　　二俱有自体
  涅槃是无为　　二体是有为

释曰。此偈显何义耶。谓显体非体外别有涅槃相。若彼法与此法有别相而是法体者不然。譬如水与火。如是体非体为涅槃相者不然。复次修多罗人言。涅槃者非体非非体故俱不可说。彼向言有二体过及有为者不然。论者言。亦无是事。今答此语。如论偈说

  汝若说涅槃　　非体非非体
  体非体若成　　二非体亦成

释曰。此谓如明与闇。有明故可说闇。如是有体非体故。有非体非非体得成。复次如论偈说

  非体非非体　　若是涅槃者
  如是二非体　　以何法能了

释曰。此谓若言以智能了者。此智先已遮故。如论偈说

  如来灭度后　　不言有与无
  亦不言有无　　非有及非无
  如来现在世　　不言有与无
  亦不言有无　　非有及非无

释曰。此谓身中有神。神与身一。神与身异。离身有神。即身是神。诸不记中皆不说。是故第一义中涅槃不成。汝出因义亦不成。其过在汝。鞞婆沙人复言。第一义中有涅槃怖畏生死者。为求彼故起勤精进。不见求者为得无法故起勤精进。论者言。如我宗中不见有人得彼涅槃。第一义中生死及涅槃俱无差别故。如论偈说

  生死边涅槃　　无有少差别
  涅槃边生死　　亦无少差别

释曰。此谓生死涅槃同无所得。是二俱不可得故。亦如分别性无故。生死涅槃皆不可得。已令信解。是故如汝所说为得涅槃而起精进为因者。其义不成。亦违于义。今以涅槃生死令开解者。如论偈说

  生死际涅槃　　涅槃际生死
  于此二中间　　无有少许法

释曰。涅槃者真如法界空之异名。真如无别异故。譬如虚空。虽有方之殊别而无异相。鞞婆沙人言。彼说一切恶见皆以空能出离。及欲得涅槃是空者。若谓涅槃是无能对治诸见者不然。是故有涅槃。是对治故。譬如明对治闇。论者言。此中灯光能照及有体者不成故。汝喻无体。是能成立之过。我言空者。谓一切诸法不可得也。即是说有所得对治。然彼有所得境界一切时不可得故。而空非是有体。无生故。譬如空华。亦非是无。先已说遮故。执着空者。亦是邪见。是故智者。应舍此执。若无智者。执空有体。空有体故则无利益。如宝积经说。佛告迦叶。若有人言能见空者。我说彼人不可治也。如是故空义不成。汝言对治为因者。因义不成。复次若第一义中有此见者。彼对治法可然。今观此诸见无故。如论偈说

  灭后有无等　　及常等诸见
  涅槃前后际　　诸见所依止

释曰。此谓如来灭后。为有如来。为无如来。为亦有如来亦无如来。为非有如来非无如来。世间有边。世间无边。亦有边亦无边。非有边非无边。乃至世间常。世间无常。亦常亦无常。非常非无常。如是四见有十二种。如来灭后依涅槃起。世间边等依未来起。世间常等依过去起。如是等见。云何起邪。由有虚妄分别习气过故。然此分别无有自体。已令开解。以是故。如论偈说

  诸体悉皆空　　何有边无边
  亦边亦无边　　非边非无边
  何有此彼物　　何有常无常
  亦常亦无常　　非常非无常

释曰。如是等分别所依止境界无体。彼依止无体故。分别心亦无体。所以者何。一切法一切时一切种。从众缘和合生。毕竟空故。无自性故。如是法中何者有边。谁为有边亦边无边非边无边。乃至何者是身。谁为有身。身一神一。身异神异。如是等六十二见。于毕竟空中皆不可得。以是故。如修多罗中偈说。所分别既无。分别何处起。能分别灭故。所分别亦亡。论初已来推求诸法。有亦无。无亦无亦有亦无亦无。非有非无亦无。是名诸法实相平等性空。灭诸戏论得安隐道。若依世谛中出因者。已如前说过。修多罗人言。第一义中有涅槃。佛为令众生证得故。观根观心观法观时观方而为说法。若无涅槃者。佛不应作此说法。乃至说八万四千诸行烦恼对治门。为得涅槃而有所说。故有涅槃。论者言。若第一义中以说法为因。汝欲得尔耶。如论偈说

  有所得皆谢　　戏论息吉祥
  如来无处所　　无一法为说

释曰。有所得皆谢者。谓有所得境界无体故。有所得心亦无体。复次有所得境界无为故。有所得心亦不起。如是一切有所得皆谢。戏论息者。谓有所得境界无体。彼境界言说相亦不起。以是故名戏论息。吉祥者。谓一切灾殃悉无体故。名为吉祥。由彼所起分别性。一切法不成。及一切法不可说故。第一义中以说法为因者。如上偈说。如来无处所。无一法为说。复次因自觉所得真实法者。不可言说。然此言说者。同分别境界故。所证真实法者。不可言说。如上偈说。如来无处所。无一法为说。复次如来说法者云何。为摄诸有故。无量千劫积集福智聚。佛身从此福智聚生。譬如如意珠悉能显现一切色像。以一切众生心自在愿力故。如来无功用有声出摄于三乘。佛身力故。所有闻者。迷故谓言如来为我说法。为说法者。于世谛中施设而有。复次阴非如来。离阴亦无如来。先已观故。如来名者。无有一物无能说者。亦无听者。亦无说处。以无实体故。如上偈说。如来无处所。无一法为说。复次诸行无所造作。及诸行聚是无漏。二障俱断。为不共佛法等作依止。具此四法故名如来。彼诸行聚无所造作故。有说法者不然。乃至听法者。是有漏行聚。而言听者受者。皆是言说。无有实体。第一义中如幻如化。谁说谁听。以是故。如来无处所。无一法为说。复次如来行菩萨道时。种宿愿力自在。以四摄法摄诸众生。是诸众生以种定报善根因缘力故。由信乐诸根心愿自在。为令一切众生欢喜故。六十种具足。无功用说法。声依如来起。然如来常定。心无功用力所作无觉观体而言有声出者。是皆不然。以如是故。如来无处所。无一法为说。复次于先佛所说法。自解自证故。一切诸法皆先佛已说。今佛随顺而说。不加一字。以是故。如来无处所。无一法为说。复次第一义中一切诸法毕竟空故。无有一法为总相智为别相智可取。以是故。如来无处所。无一法为说。如金刚般若经说。如来为菩萨时。定光佛边无一法可受。何以故。不可取不可说故。诸外道等甚可怜愍。我今以此无体自体空最上乘所说道理。破其邪辩。然彼外道依止恶见道理。而自覆藏己宗之过。执其所见。说是偈言

  彼第一义中　　佛本不说法
  佛无分别者　　说大乘不然
  化佛说法者　　是事则不然
  佛无心说法　　化者非是佛
  于第一义中　　彼亦不说法
  无分别性空　　有悲心不然
  众生无体故　　亦无有佛体
  彼佛无体故　　亦无悲愍心

外道等谓论者言。彼佛法中若言世谛中有悲愍者。犹如石女哭儿。论者言。此中明第一义者。一相故。所谓无相。无佛亦无大乘。第一义者。是不二智境界。汝说偈者。正是说我佛法道理。今当为汝说如来身。如来身者。虽无分别。以先种利他愿力为大誓庄严熏修故。能摄一切众生。于一切时起化佛身。因此化身有文字章句次第出声。不共一切外道声闻辟支佛故。而为开演二种无我。为欲成就第一义波罗蜜故。为欲成就乘最上乘者故。名为大乘。有第一义佛故。依止彼佛而起化身。从此化身起于说法。由第一义佛为说法因故。不坏我所立义。亦不坏世间所欲。复次萨婆多人言。如来所说法者。皆是有分别故说法。以他众生心自在愿力起说法因故。譬如为声闻等说法。论者言。是义不然。化佛说法者是无分别。非如汝语一向分别。萨婆多人言。佛无分别而为说法者不然。无分别故。譬如土块。论者言。化佛与第一义佛不可说异故。世谛中有佛者。不遮世谛中。彼第一义佛为说法因者。亦不遮第一义中。如来无戏论故。分别如来。若有悲若无悲。皆是戏论。如是戏论悉皆无体。所悲愍众生及能起悲者。亦皆无体。如汝先说。若世谛中有悲谓如石女哭儿者。是喻不然。悲云何相。谓见他有苦起忧苦心。是名悲相。譬如慈母怜极爱子。诸佛菩萨于诸众生起怜愍心。亦复如是。纵令石女有悲怜心。于我何妨。而复不尔。譬如龟毛空与太虚空而不相似。是故设有悲者。诸佛悲心与石女悲心亦不相似。诸佛悲者。无量劫来积集熏修究竟具足。遍满一切诸众生界。若石女无此悲者。更莫复言世谛有悲者与石女悲相似。此品初鞞婆沙等所立验者。论主已说其过。显示涅槃无有自体。以是故。此下引经显成。如梵天王所问经偈言。实无有涅槃。如来说涅槃。如虚空自结。如虚空自解。梵王白佛言。若有分别众生欲得一切法有起有灭者。佛于其人亦不出世。若于涅槃起分别相言是有体者。然彼众生决定不能出于生死。世尊。涅槃者。其义云何。一切相皆寂灭。是为涅槃。一切所作皆已谢。是为涅槃。世尊。愚痴众生于佛法中虽得出家。而堕外道见中求涅槃体。如于麻中求油。指手言得。何异乳中求觅生酥。若于一切法毕竟寂灭中求涅槃者。乃至邪慢外道中声闻非佛法中声闻。若是正见成就行者。不作一法有起有灭。亦不欲得证获一法。亦不见圣谛理。如摩诃般若中说。佛告须菩提。涅槃者。如幻如梦。如影如焰。如镜中像。如水中月。如乾闼婆城

释观涅槃品竟

    般若灯论释观世谛缘起品第二十六

释曰。今此品者。亦为遮空所对治。而以世谛缘起故说

目部人谓我言。彼先言如来无处所无一法为说者。其义不然。论者言。我今当说。如来为欲惊怖一切外道及人天等众生令息诸恶见过患故。说缘起法。佛由觉了缘起法故。名称高远遍一切世间。以是因缘故名为佛。汝今与缘起法作过者。自违所欲。如论偈说

  无明之所覆　　造作彼三种
  后有诸行业　　由此往诸趣

释曰。明所对治名为无明。而此无明能覆障众生智慧。造作后有诸行。云何名后有。谓未受生者与不相离和合因果。共趣向后有故。名为后有。云何名诸行。行有三种。一谓无我法。二谓刹那。三谓三种业。云何为三业。谓福非福不动等。复有三种。谓身语意。无明者非独为诸行缘。亦能与识等后支展转为缘。体亦非独无明覆障众生。更有诸余烦恼行者。谓造作有为法故。名之为行。如论偈说

  以诸行因缘　　识托于诸趣
  识相续托已　　尔时名色起

释曰。云何为识。于一一物分别取境界故名识。托者言生。行缘者。谓行与识为缘故名行缘。亦非独诸行与识为缘。彼识生时亦有诸心数法共生。以是故亦以诸心数法为缘。复次行缘识者。如阿罗汉。亦有诸行。何故不与托后有识为缘。以彼爱绳断故。不与托后有识为缘。是故爱等诸烦恼。亦与受后世识作缘。何故独言诸行耶。为诸行有胜力故。譬如王者斗战得胜。非独王胜。一切兵众亦名为胜。由王为主故言王胜。复次或有人起如是意言。无明为不善诸行因可然。但愚痴者是不善故。云何得与善法诸行为因耶。此谓未断无明者。为欲受天女眷属乐故。而造诸福德行。以是故无明亦与福德行为展转因。复次生死者。是第一义不善所有福德诸行。系属生死者皆名不善。以是故无明能总与诸行为缘。复次善趣不善趣不动趣三种业者。各有上中下差别。是等诸行名为往诸趣业。往诸趣者。诸师各执不同。如萨婆多人说言。有彼中阴。以有名色相续。往托生处故。正量部人昙无鞠多部人等说言。无彼中阴。但以行为缘。而识得起。尔时名为托生。复次计有中阴者言。有色诸众生等。于一处灭。是有色众生。还相续生。无间前后起至彼异趣。名为托生。相续随生故。譬如灯。以是故名色依止阴而有相续。从死刹那至受生刹那无间生故。名为受生。譬如现在人从此到彼。复次无中阴者言。色界死有生有。二有中间更无中有。有漏故。譬如无色界死有生有而无中有。何以故。死有中间有身起者。非是中阴。身是报故。譬如现在所受得身。复次有身起者。是苦谛所摄故。譬以意体为身。往至异处。刹那刹那相续随起故。而无中有。非一向有阴。汝立中阴义者。是义不成。复次有中阴者言。若无中阴。云何得至后受生处耶。复次无中阴者言。从死有相续至生有时。如授经。如传灯。如行印。如镜像现。如空声响。如水中日月影。如种子生芽。如人见酢口中生涎。如是后阴相续起时。无有中阴往来传此向彼。是故智者应如是解。如上偈说。识相续托已。尔时名色起。云何为名色耶。名有二种。一谓自往诸趣。二谓为烦恼所使强令入诸趣中。复次名者。谓无色四阴。总名为名。云何为色。色者可变异故名色。谓四大及四尘等。非独识为名色缘。无明行等亦为彼缘。复次识缘名色者。识及无明等非是定与名色为缘。有处有化生者而亦与彼六入为缘。如无色界生者。此识但与名为缘。如论偈说

  从于名色体　　次第起六入
  情尘等和合　　而起于六触

释曰。云何为内六入。谓眼入耳入鼻入舌入身入意入等。眼入者。以色为境界故。彼清净色是眼识所依止处故。名清净色。以为眼入。如是以声等为境界。彼清净色。是耳等识所依止处故。名清净色。为耳等入。意入者。以无间次第灭为彼意入。云何为入。谓识及心心数法等。从清净色中起故。名之为入。何故名触。谓与苦受乐受不苦不乐受等。各和合故名触。如论偈说

  因彼眼与色　　及作意三种
  与名色为缘　　尔乃识得生

释曰。识得生者。如眼以色为缘。识缘色故而识得生。如是耳以声为缘。耳识得生。乃至意以法为缘。意识得生。云何名触。如论偈说

  彼色识眼等　　三种共和合
  如是名为触　　从触起于受

释曰。境界与根意等三种为一体故。而名为触。触为缘故起三种受。如论偈说

  受为起爱缘　　为受故起爱
  爱又为取缘　　取者有四种

释曰。此谓求欲之相而名为爱。无闻凡夫为乐受故起贪求心。如舐刀蜜。不觉后时伤舌过患。若为乐受起贪者可尔。云何于苦受不苦不乐受而起贪耶。谓以苦受不苦不乐受亦为爱缘故。受苦受时亦有求离心生。亦是爱也。是故无过。四取者。谓欲取见取戒取我语取。云何为取。谓积集义。复次爱增长故。亦即是取。为得五欲乐故。起追求心。亦名为取。如论偈说

  由取诸有故　　取者起于有
  以无取者故　　脱苦断诸有

释曰。有者是业相。复次有者。是生异名。而生之因法亦名为有。若尔者云何即因是果耶。今现见因受果名故。譬如佛出世。乐彼识等五支果分。是现在世所摄故。而言从无明行生。若得值善知识听闻正法起正思惟。于苦乐等诸行能见无常苦空无我等行。复次诸行无生自体空。彼起真实智者。不复起爱。不起爱故无复追求。如上偈说。若无有取者。脱苦断诸有。此义云何。谓有取故有有。若无取则无有。有云何相。如论偈说

  五阴是有体　　从有次起生
  老病死忧悲　　哀泣愁苦等

释曰。此谓亦说五阴因为有支体。复次五阴因名有者。谓非独五阴因名有。无色界四阴因亦名有。生者谓先无阴体今有阴起。老者谓变坏相。死者谓无阴体。病者谓身为苦所逼。忧悲者。谓从爱别离怨憎会等。内被烧然有相起故。哀泣者。谓丧失所爱及有福德眷属。因此发声。称其德行。而哀泣之。苦谓身受。愁谓心受。劳倦者谓身心疲极。如是广说生等皆名为苦者云何。如论偈说

  愁及劳倦等　　皆以生为因
  独此苦阴起　　毕竟无乐相

释曰。独苦阴起者。谓不与乐和合故。阴者谓聚。起者谓生阴。相续者是世谛所摄缘起。非第一义。如先品中已说无起令信解故。我所立者不破。若言生死行流转者。云何是不起耶。我今答之。如论偈说

  是谓为生死　　诸行之根本
  无智者所作　　见实者不为

释曰。诸行生死根无智所作者。此谓无智者不见诸行无始已来展转从缘起如幻如焰过患故。而求于乐。为求乐故造福非福不动等诸行。见实不作者。谓圣道已起见真实故。智障烦恼体无明已断故。如论偈说

  无明若已断　　诸行不复生
  修习智慧故　　无明乃得断

释曰。此谓诸行不生阙于缘故。如种子无体故芽则不生。今修习何智得断无明。如此论中所说照缘起智。遮一切诸体有自体。解人法二无我境界。空智修者。谓数数习。如论偈说

  一一支灭者　　彼彼支不起
  唯独苦阴聚　　名为正永灭

释曰。此谓行等一一有支对治道起故。则灭此等有支更不起者。由行灭故。行灭则识灭。乃至生老死忧悲等灭。唯独苦阴正永灭者。是世谛所摄故。若第一义中是无明等无起无灭。云何复名缘起耶。佛依世谛故说第一义。我义如是。如前偈说。不依于世谛。不能说第一。以是故不坏我所立义。此品初自部人谓我言。立义有过者今说无此过故。而以世谛缘起。令物信解是品义意。如佛说无起者名为缘起。此谓不起者说为缘起。若彼无起云何有灭。若能于无灭觉无灭者。名解缘起法等

释观世谛缘起品竟

    般若灯论释观邪见品第二十七

释曰。今此品者亦为遮空所对治令解诸见空故说

自部人言。有自体五取阴。是见处故。阴若是无而为见处者不然。五阴是见处者如俱舍论中说。彼五阴者是苦是集是世间是见处。如是等是有故。论者言。不然。今当观察诸见。此中如论偈说

  往昔过去世　　我为有为无
  是常等诸见　　皆依先世起

释曰。此谓我于过去。为是有为是无。为亦有亦无。为非有非无。如是诸见依过去世起。世间常世间无常亦常亦无常非常非无常等四见因待现在世阴故说过去世阴常等诸见。皆依此起。依者。谓缘为谁缘谓诸见缘。见有何义。谓执着于取等。如论偈说

  复有异诸见　　执未来不起
  未来起等边　　皆依未来起

释曰。此诸见依过去世起。世间有边世间无边亦有边亦无边非有边非无边等四见。因现在阴故。未来当起阴者。名为后边。今且观察。依止先世起诸见者。如论偈说

  过去世有我　　是事则不然
  彼先世众生　　非是今世者

释曰。云何不然。谓时别故。异业所生故。譬如余众生。复次身及诸根亦别故。若言根等虽异而我是一者。此亦不然。如论偈说

  还是昔我者　　但是取自体
  若离彼诸取　　复有何我耶

释曰。此谓如提婆达多过去世我还是今日我者不然。取别故。譬如耶若达多。我以是故。前世生还是今日生者不然。复次若欲得我相异取相者。如上偈说。若离于诸取。复有何我耶。无如是我故。离阴有我先已广遮。计有我者。若作是意。不欲令我无体。即以取为我体者。作是分别。如似说无我者。亦以取体为我。如论偈说

  若取是我者　　何处更有我
  由取起灭故　　云何是取者

释曰。第一义中。取不是我。取有起灭法二体先已说无我。令信解故。云何为取。谓取及取者。取是业。取者是作业人。譬如薪火二种。复次如先已遮我故我义不成。云何不成。如先偈说。取非即是我。以有起灭故。我者亦非是有亦非是无。如是我者。世谛中亦不能令物解。今当更答计离阴有我者。如论偈说

  若异于彼取　　有我者不然
  离阴应可取　　而不可取故

释曰。此谓我若异取者不然。何以故。若离取有我者。云何可说取是我相。若无相可说则离取无我。若谓离取无我。但取是我者。是亦不然。离取无有我异故。譬如余物。此中立验。不异取有我。取是可取法我不可取故。譬如取自体。何以故。取有起灭。我则不尔。复次云何以取即为取者。若谓离取而有取者。是亦不然。若不取五阴而有取者。应离五阴别有取者。彼义如是。我今说道理者。如论偈说

  我不异于取　　亦不即是取
  而复非无取　　亦不定是无

释曰。此谓我不离取。亦不即取。而非无取。亦不是无。已令物解。若言过去世有我者不然。如论偈说

  今世无过去　　是事亦不然
  过去前生者　　与今世不异
  若今与前异　　离前应独立
  如是应常住　　不为现阴缘

释曰。此谓问者。不欲得如此。云何欲得。谓欲得前世五阴与今世五阴为缘。我今立验。如提婆达多。今世五阴与过去五阴。不得有异。相续不异故。过去阴为因故。譬如提婆达多。过去五阴。非但有此离前应独立过。亦更有余咎如上偈说。如是应常住。不为现阴缘。云何为缘耶。谓后阴不起故。若尔者则不从死有生。而彼前世所受生阴。仍在过去。今别更有异阴于现在生以是故。则有大过。云何为过。如论偈说

  诸业皆断坏　　此人所造业
  彼人当受报　　得如是过咎

释曰。若尔者即有断过。失于诸业果报故。又彼人作罪。此人受果。复次若言业之与生一时起者不然。如论偈说

  非生共业起　　此中有过故
  我是作如瓶　　先无而后起

释曰。我者云何是造作耶。谓先无后有。我者先不起烦恼业。应如瓶以外法为生因。不以先世所集业为生因。如是能生后阴因者。则为无体。非有非不有。复次过去世亦同前二种过。非有非不有者。无如是法故。观察过去世有无等四句已。今当次观未来四句。如论偈说

  或有如是见　　来世有我起
  来世无我起　　同过去有过

释曰。此谓来世一异俱不俱等。今亦如是遮故。如论偈说

  若天与人一　　我则堕于常
  天既是无生　　常不可生故

释曰。如是我者即堕常过。自部人言。一异等义有何过耶。论者言。若未生天即是天者。我则无起。无起者即是常。以是故。我未生天时应能起天所作业。而无是事。若谓我是常未生天时已能起天所作业者。世人所不信故。复次若我无常。此人中我天中生时。昔人中我今即坏故。若汝意谓欲得有异而无如上所说一过者。是事不然。计异者亦有过故。如论偈说

  若天与人异　　我则堕无常
  天与人异故　　相续者不然

释曰。其过云何。谓有异故。譬如提婆达多与耶若达多。二我相续则为有过。复次若有人言。我相续是一有是天义有是人义。今当答之。如论偈说

  若天在一分　　人又在一分
  常无常共俱　　一处者不然

释曰。云何不然。谓有天处有天即是常。天处无人故。无人即是无常。若有人处有人即是常。人处无天故。无天即是无常。犹如一物一处。亦白亦黑者。其义不然。若有人言。我非是常亦非无常者。如论偈说

  若常与无常　　二义得成者
  非常非无常　　汝意亦得成

释曰。此义难令人解故。复次第一义中者。如论偈说

  有处有人来　　从住处有去
  生死则无始　　而无有是事

释曰。有处者。若天世处人世处。有人者。谓若天若人。住处者。谓住天等世界处。有去者。谓有人向异趣处去。若尔者此我无始已来恒有。而即是常。而无是事。云何无耶。谓众生及人先已遮故。以是义故。无有常我。若言虽无常我而有无常我者。是亦不然。如论偈说

  若无有常我　　谁复是无常
  亦常亦无常　　非常非无常

释曰。此谓待常故说无常。本无有常待。何说无常。复次常无常等。皆已不成。今当观察边等四句。如论偈说

  世间若有边　　云何有后世
  世间若无边　　云何有后世

释曰。边者云何。谓究竟处尽处等名边。如似阿罗汉涅槃阴。而今有后世在者。谓前世阴为因。后世阴为果。展转无终。如是依前阴因起后阴果故。然今有此诸阴展转相续起。如论偈说

  此诸阴相续　　犹如然灯焰
  以是故世间　　非有边无边

释曰。此中立验。有无明烦恼未尽。诸阴相续不断。此阴有果故。譬如灯焰相续。以是故。世间有边者不然。此相似果起不坏者。非前阴不坏有后果故。譬如灯前焰。以是故。世间无边者不然。如所说验义者。应如论偈说

  前世阴已坏　　后阴别起者
  则不因前阴　　是名为有边

释曰。此谓前阴起已即灭。不为后阴相续因者。即是有边。如论偈说

  若前阴不坏　　后阴不起者
  既不因前阴　　而即是无边

释曰。云何无边。谓一切时常住故。是义不然。如论偈说

  一分是有边　　一分是无边
  离彼有无边　　更无俱等边

释曰。此谓无世间最后边等四句。所以者何。如论偈说

  云何一取者　　一分是有坏
  一分是无坏　　如是者不然

释曰。云何不然。如前二种灯喻验中已破故。是为不然。如论偈说

  有边及无边　　是二得成者
  非有非无边　　其义亦得成

释曰。此谓若一人是亦有边亦无边成者。以相待故。非有边非无边亦成。而无是事。如第一义中。总说一切见皆不然。作如是令物解者。如论偈说

  是第一义中　　一切法空故
  何处何因缘　　何人起诸见

释曰。此谓若第一义中一切诸体皆空者。有何人缘何境。以何为因起何等见。以彼人空境空因空见空故。有人有境有因有见起者不然。以是义故。品初自部人言。第一义中。有如是五取阴自体是见处者。此出因义不然。云何不然。第一义中已令物解一切诸见悉皆空故。不然若依世谛中而立因者。自违汝义。佛婆伽婆为世亲者。见一切众生虚妄分别起种种苦种子诸见故而起怜愍。如论偈说

  佛为断诸苦　　演说微妙法
  以怜愍为因　　我今礼瞿昙

释曰。断苦者。谓断一切众生生死等一切诸苦。妙法者。谓清净故。名为妙法。能灭烦恼熏习火故。名为清净。复次一切功德因增长圆满故。亦名清净。妙法者。所谓大乘。如胜鬘经说世尊。摄受妙法者。谓守护大乘。何以故。世尊。一切声闻辟支佛乘。皆从大乘中出生故。乃至一切世间出世间善法。亦皆从大乘中出生故。世尊譬如阿耨达池出四大河。如是如是。世尊。大乘者。能生声闻辟支佛乘。如是乘者。以慈悲喜舍为因。不以世间名利为因。今礼瞿昙者。谓能开示无上妙法宝故。名为瞿昙。复次姓瞿昙故。名为瞿昙。礼者云何。有二种礼。一谓口言称叹。二谓屈身头面着地。如梵王所问经偈言。深解因缘法。则无诸邪见。法皆属因缘。无自定根本。因缘法不生。因缘法不灭。若能如是解。诸佛常现前。此品初说自部人立验有过。又以诸见空故。而令开解是品义意。如般若中说佛告勇猛极勇猛菩萨摩诃萨。知色非起见处。亦非断见处。乃至受想行识非起见处。亦非断见处。若色受想行识非起见处。亦非断见处者。是名般若波罗蜜。今以无起等差别缘起令开解者。所谓息一切戏论及一异等种种见。悉皆寂灭。是自觉法。是如虚空法。是无分别法。是第一义境界法。以如是等真实甘露。而令开解是。一部论宗意。问曰。诸佛所说初中后皆真实。此论中何须广立诸验耶。答曰。或有愚钝诸众生等。于佛阿含不能正信为欲摄取彼众生故。广立诸验。我今顶礼龙树阿阇梨故。而作颂曰

  牟尼法王子　　大智阿阇梨
  以般若妙理　　开演此中论
  善解利他行　　为照世日月
  显了甚深法　　说得佛道因
  阇梨所作者　　我今悉解释
  息诸恶见故　　造般若灯论
  此般若灯者　　深妙无比法
  然我今所作　　若有少福德
  以此般若灯　　愿摄众生类
  见法身如来　　遍满十方刹
  得自所觉法　　息诸见戏论
  寂灭无分别　　无比如虚空
  复愿般若灯　　普照于世界
  为闇所覆者　　建立于涅槃

般若灯论释第二十七品竟

一切论到彼岸者。深大智慧者。乘于大乘者。分别照明大菩萨。造此释中论长行讫。而发愿言

  愿以一念善　　随喜回向等
  与一切众生　　命终见弥勒

般若灯论释卷第十五


大乘二十颂论

    No. 1576

大乘二十颂论

        龙树菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

  归命不可思议性　　诸佛无著真实智
  诸法非言非无言　　佛悲愍故善宣说

  第一义无生　　随转而无性
  佛众生一相　　如虚空平等
  此彼岸无生　　自性缘所生
  彼诸行皆空　　一切智智行
  无染真如性　　无二等寂静
  诸法性自性　　如影像无异
  凡夫分别心　　无实我计我
  故起诸烦性　　及苦乐舍等
  世间老病死　　为苦不可爱
  随诸业坠堕　　此实无有乐
  天趣胜妙乐　　地狱极大苦
  皆不实境界　　六趣常轮转
  众生妄分别　　烦恼火烧燃
  堕地狱等趣　　如野火烧林
  众生本如幻　　复取幻境界
  履幻所成道　　不了从缘生
  如世间画师　　画作夜叉相
  自画己自怖　　此名无智者
  众生自起染　　造彼轮回因
  造已怖坠堕　　无智不解脱
  众生虚妄心　　起疑惑垢染
  无性计有性　　受苦中极苦
  佛见彼无救　　乃起悲愍意
  故发菩提心　　广修菩提行
  得无上智果　　即观察世间
  分别所缠缚　　故为作利益
  从生及生已　　悉示正真义
  后观世间空　　离初中后际
  观生死涅盘　　是二俱无我
  无染亦无坏　　本清净常寂
  梦中诸境界　　觉已悉无见
  智者寤痴睡　　亦不见生死
  愚痴闇蔽者　　坠堕生死海
  无生计有生　　起世间分别
  若分别有生　　众生不如理
  于生死法中　　起常乐我想
  此一切唯心　　安立幻化相
  作善不善业　　感善不善生
  若灭于心轮　　即灭一切法
  是诸法无我　　诸法悉清净

  佛广宣说世间法　　当知即是无明缘
  若能不起分别心　　一切众生何所生
  于彼诸法法性中　　实求少法不可得
  如世幻师作幻事　　智者应当如是知
  生死轮回大海中　　众生烦恼水充满
  若不运载以大乘　　毕竟何能到彼岸

大乘二十颂论


大乘广百论释论

    No. 1571 [cf. Nos. 1569, 1570]

大乘广百论释论卷第一

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破常品第一之一

  稽首妙慧如日轮　　垂光破闇开净眼
  远布微言广百论　　百圣随行我当释

论曰。为显邪执我我所事性相皆空。方便开示三解脱门故造斯论。执见事性为方便故起相分别。随取事相为依止故生邪愿乐。既显事空二即非有。其我所事略有二种。谓常无常。常住事胜寂静安乐。众生闻乐清旷无为多生欣乐。无常事劣能引诸苦。众生见苦炽火所烧多生厌离由是论。初先破常事。故说颂曰

  一切为果生　　所以无常性
  故除佛无有　　如实号如来

论曰。诸有世间鄙执他论所说种种常住句义。多越现量所行境界。以能生果比量安立。既能生果。亦应比度从缘而生。如粗色等。若非缘生。无胜体用。应不能生。如空花等若许彼义从缘而生。即定灭坏。如所生果。所以佛说诸行无常。从缘生灭。如苦乐等。是故唯佛无颠倒说。得名如来。见一切境无挂碍故。若尔所余无生果用此应是常。既不生果。不可比度。从缘生故。虽尔既无能生果用。如永灭无。应比非有。为显此言。其义决定。故复颂曰

  无有时方物　　有性非缘生
  故无时方物　　有性而常住

论曰。诸有性法。定从缘生。如苦乐等。若非缘生。定无有性。如空花等。此若有性。应从缘生。若从缘生。灭必随逐。无容常住。如是说已。或复诸法。必依缘生。方知有性。如现在法。若非缘生。即非有性。如未来法。为辨此义故说无有时方等言。此显所说其理决定。若时若方。若物差别。遍一切处皆无诤论。如说菩萨住循法观。于诸法中不见少法出缘生外。又彼非处方便殷勤。何以故。颂曰

  非无因有性

论曰。彼虽方便殷勤立常。而竟不能说有道理。如是句义所立能立。一分所依不极成故。既不许有余同类义。同喻阙故。比量不成。设复强说。终成非理。何以故。颂曰

  有因即非常

论曰。纵彼强说常性有因。既许有因。即非常性。如苦炽火相应所生。此因便能违害根本虽无生因而有了因。有因总故。即为极成。复次有执一切性皆是常。若立一切皆无常性。俱阙同喻。比量不成。此亦不然。同前过故。又彼虽立隐性为常。而立显相有其生灭。由此足能显无常性。遮破常性。彼论遮破。显相是常及非有故。若说显相亦无生灭。前位无减。后位无增。诸造论者何所为耶。何所造耶。若谓诸法虽有隐显而无生灭。此亦不然。前后两位若无差别。便无增减有何隐显。又离体外无别有位。位有隐显。体亦应然。汝虽不欲体有生灭。理所逼故。必应信受。如是所立前后两位。隐显非常为同法喻。由此我立不与汝同。立常同喻定非有故。又所立义必须有因。非唯起心即可成立。故次颂曰

  故无因欲成　　真见说非有

论曰。诸有比量。能成立他所不许义。乃名能立。若离正因。但有言说。虚陈自意。义终不成。有言无因义得成者。诸有所立一切应成。纵一切成。仁今何吝。我亦无吝。彼自不成。一切皆成。汝亦不许

复次有余偏执明论声常。初不待缘。后无坏灭。性自能显。越诸根义。为决定量曾不差违。现比等量依士夫见。士夫有失见是疑因。故能依量皆难信受。此亦不然。与前所说非爱过咎。不相离故。若所依止。士夫及见皆有过故。能依诸量亦有失者。汝及汝师见及言论。既有过失。云何可信。汝所发言。便成自害若汝意谓。汝及汝师所发言词。亦是定量。余声非者。无有比量。但爱自宗。亦复自违所立宗义。又以比量立明论声非士夫造。体是常住。因及同喻。应更须成。设复能成。则为自害。又明论声与所余声同是声性。云何但说此声是常。余声无常亦不可说。余人自许声是无常。由士夫造故非是常。今则不许故是常住。法性决定。岂随论者许与不许成常无常。不可说言一切法性随见差别其体转变。一物同时有多体相。更互相违。非道理故。若法随人情计转者。应舍自宗取所余见。又立常者。所说道理唯依异法。无同法故。所立不成。或舍自意。是故彼宗不任推捡。唯构虚言。都无实义

复次有余执言。唯异法喻。即名能立。异法遍故。比量本为遮余义故。现见遮相所杂糅缘。能显义故。为定此义。复作是言。诸所作者。既是无常。故知非作理应常住。此言为显异法决定。此亦不然。随自意语不能如实。显正理故。所以者何。唯显异义所遮事境名为同喻。其异法喻二分俱行可名为遍。若无同喻何所遍耶。不可说言自体自遍。又诸比量欲遮余义。要有同法然后方成。同法若是无异法应非有。离其同异二聚法外。更不许有余句义故。由此即破现见遮相。所杂糅缘能显于义。又以不见所作为因。欲成有常。终无是义。以一切处未曾见有。故说颂曰

  见所作无常　　谓非作常住
  既见无常有　　应言常性无

论曰。见所作者。皆是无常。谓非作者。皆是常住。既见所作。无常性有。应言非作常住性无。诸所作者既许有体。非所作者应许无体。以非作因于乐等有曾所未见龟毛等无皆可得故。如是非作违害能立所依自相非正能立为不尔耶。诸相违因若不遮碍。自共所许。乃于自境能立相违自相差别。今此所依共许为有。若不共许。无容依此竞常无常。故非作因。不能违害所依自相。有释此言我今不许。聚极微外有散极微。故此违因无自害失。此释不然。彼依总相建立一切常法为有。岂劳分别聚散有无。如是释者。空等无为都不许有。不可为难。色等极微虽依世俗许其为有。而是所作。故非所作因义不成。若于如是不成因上。作相违过亦不得成。颂中应言常性无者。正破所依空等性有。兼辨能依常住性无。若言空等无实有性。所依无故因义不成。何能违害有法自相。此亦不然。但说遮遣余有类物为此因故。因有三种。一有体法。如所作等。二无体法。如非作等。三通二法。如所知等。今所立因唯遮所作。不言别有非作自性。此因同类色等上无。于其异类龟毛等有。是故违害有法自相。又说颂曰

  愚夫妄分别　　谓空等为常

论曰。随有所见皆无谛实。智不清白。故名愚夫。于寻思地恒自安处。推求分别诸法性相。于中或有智见猛利。虚妄计度越路而行。各恃所知皆自憍举。互兴异论檀立师资。俱未断除分别见网。无明昏睡缠覆其心。如在梦中所缘皆妄。非如梦智所计空等。常住实有而可信依

复次有余释子执虚空等实有常住。故契经言。虚空无色无见无对。当何所依。然藉光明虚空显了。此经义说。实有虚空常住无色无见无对。无复所依。因光明显。或有疑难。佛既不说别有所依如风轮等。如是虚空应无体相。为释此难。故说虚空容受有对光明等色以果显因有实体相。又说虚空风所依止。非无体相能作所依。此亦不然。非经义故。若谓虚空是有果法。应有生灭。生灭随故。体则无常。如色心等。若无生灭。应无体相。如龟毛等。为显风轮离同类聚。无别所依如地轮等。所以经说。风轮依空。不遮风轮。前念现在同类同聚。生起所依。故作是说。为显虚空无有同异生起所依如过去等无别实有常住体相故。复经说虚空无色无见无对。当何所依。不见实有色受等物。无有同异生起所依。又显虚空因光明等。依世俗谛假施设。有如因色等假立瓶等。是故复说。然藉光明虚空显了。不可依此即说虚空。离光明等实有体相。虽因影闇亦立虚空。然影闇中眼有障碍。或有除此更无所见。不能辩了余物有无。所以不说。然藉影闇虚空显了。于光明中眼无障碍。若见无有余障碍物。即便依此假立虚空。勿谤虚空假亦非有。是故不说无有虚空。又若虚空实有体相。藉诸光明而显了者。应如青等有色有见有对有依。经不应说无色无见无对无依。世俗假有。无此过失。依无碍色假立虚空。质碍等性不相应故。又此虚空四谛不摄。虽执实有。然必应许。有分别智之所了知。除五识身所引意识。其余有漏不定外门分别意识。决定不能缘实有境。故说颂曰

  智者依世间　　亦不见此义

论曰。诸有智者。依止世间随分别识于虚空等虽复专精愿求实义。乃至少分亦不可得。唯见依名所起分别似虚空等种种影像

复次为破如前所执空等由遍满故。体实有常。故说颂曰

  非唯一有分　　遍满一切分
  故知一一分　　各别有有分

论曰。时方物类各有差别。所以言分。空等与彼诸分相应。故名有分。非一有分常住真实。与一切分周遍相应。勿复令此所相应分。一一遍与一切相应。故此有分。随所相应诸分差别成无量分。即此诸分不待余依。说名虚空。或余物类。故汝所说实有常住空等遍满因义不成。若言空等亦由分别假立方分故无过者。此亦不然。实无方分。不离如前所说过故。瓶等亦应假立方分。依第一义方分实无。此因但于异法上有。同法既阙与义相违。又虚空等差别名言。唯依诸分和合而立。分别假立有方分故。如唯依彼色等和合。立宫殿等种种名言。此意显示。虚空等声唯依世俗境界而立。又若可说有方分者。应如青等不可说为常遍实有虚空等性。是则所立能立一分所依不成

复次或有执时真实常住。以见种等众缘和合。有时生果。有时不生。时有作用。或舒或卷。令枝条等随其荣瘁。此所说因具有离合。由是决定知实有时。时所待因都不可见。不见因故所以无生。以无生故即知无灭。无生无灭故复言常。为破彼执。故说颂曰

  若法体实有　　卷舒用可得
  此定从他生　　故成所生果

论曰。时用卷舒待他方立。故此时用随缘而转。体相若无取舍差别诸有作用兴废不成。又时作用依他而转。如地色等定是无常。即以此事为其同法。用所依时何容常住。故善时者作如是言。业风所引大种差别。自类为因展转相续。循环递代终而复始。随缘不同冷暖触异。分位差别说名为时。时虽具有因缘生灭。相似相续隐覆难知。岂以不知言无因等

复次有执时体亦常亦遍。摄藏无量差别功能。外缘击发起诸作用。芽茎等果随用生成。此亦不然。所依时体若无迁变。能依功能岂可击发。不见所依种等无变。而有生长芽等功能。即此击发功能因缘。足有生成芽等作用。何须妄计无用时耶。又说颂曰

  若离所生果　　无有能生因
  是故能生因　　皆成所生果

论曰。诸法要待自所生果。有胜体用方得名因。所生若无。能生讵有。由是所执能生之因。必待余法成别因故。如苦乐等定是无常。岂不因法先有体用。后果生时因名方显。如外众缘先有体用。果法生已乃得缘名。时亦如是。其体常遍。具含种种生长功能。诸果生时名用方显。又未生果亦得因名。待当果故。如稻麦种。汝所立时。其体常遍。具含种种生长功能。诸能与体既许无异。能应同体一一遍常。是则起用生一果时于一果处应生一切。如是便成因果杂乱。我立功能望所生果时处决定。故无此失。汝立功能一一常遍。不应辄许时处决定。若言论主所立功能同斯过者。此亦不然。我立功能依因缘有种种差别非遍非常。随自因缘种种差别。所生诸果时处决定。故无起用生一果时于一果处遍生一切。所以因果不相杂乱。不同汝立时与功能。皆是遍常前后不异。是故唯汝有杂乱失。又说颂曰

  诸法必变异　　方作余生因
  如是变异因　　岂得名常住

论曰。世间共许。功能所依种子等法。必舍前位而取后位。体相转变方为芽等所生果因。如是因性理无差失。所立常因应亦同此。体相转变方能为因。既许转变无容常住。岂不世间亦许种等。果未生位体相未转。虽无作用而得名因。不尔世间虽假名说。而实种等将至灭位。正能生果方得名因。种等尔时必有变异。为不根尘不灭无变而有作用生诸识耶。此亦将灭体相转变能生诸识。故不相违。有余师说。根尘望识如种芽等生灭道理。一切因果法不同时此难于彼便成疏远

复次有余外道。执自然因体常无有生灭变异。自然为因生一切果。为破彼执故。说颂曰

  若本无今有　　自然常为因
  既许有自然　　因则为妄立

论曰。若一切法本无今有。计有自然常住为因。法应自然本无今有。何用妄立自然常因。既许自然不待因故。又体自然常无变易。果未生位既未能生。果法生位应亦如是。前后一故因义不成。计自然常便失二事。谓失摄受决定因缘能生自果。及失见有所生粗果。证有自许微细常因。若谓自然要待和合众缘资助方能生果众缘虽别。然和合时资助自然令起总用。此一总用本无今有。是故自然体虽常有。先不生果后方能生。是亦不然。自然常有。云何不令众缘常合。众缘合时其性虽别。然互相助共生一果。除此更无总用可得。又自然性虽处众缘。共和合位亦不能生。体无别故。如未生位。又常住法体相凝然。不可改转。缘何能助。若许自然从缘改转。如所生果应是无常。是故唯有无常诸缘。互相资助起胜体用。异于前位能生其果。非所立常能离前失。复次有诸外道建立常因。时无改变能生于果。此亦应以用相违因为喻遮遣。又说颂曰

  云何依常性　　而起于无常
  因果相不同　　世所未曾见

论曰。诸行生起必似自因。故不可言生异类果。岂不现见从月爱珠引出清流。因果异类。我亦不说从因生果。所有体相一切皆同。但言因果相生义中不相离相决定相似。以于世间曾未见有如是因果不同相故。世间共见粗无常果。无不从彼无常因生。类知细果是无常故。犹如粗果因定无常。是故色等因果性法。与无常相定不相离。为决此义。复作是言。一切细果所因色等。定是无常。果无常故。譬如粗果所因色等

复次有作是见。空等遍常。若于一分众缘合时即依此分发生声等。若遍所依发声等者。住极远境根亦应知。为破彼见故。说颂曰

  若一分是因　　余分非因者
  即应成种种　　种种故非常

论曰。若谓空等众缘合时。一分有用发生自果。余分无用自果不生。空等即应分分差别。分分体用有差别故。应如声等定是无常。又此空等体恒周遍。能为种种自果所依。是种种相所依止故。如锦绣等可证非常。又如前说。常法凝然不可改转。缘何能助所计空等。应亦如是体既常住。虽众缘合何能发生声等自果

复次有作是见。一分起时但从一物大等诸果展转变异差别增长。大等诸果变故无常。一物自性不变故常。此亦不然。义相违故。大等皆用自性为体。大等变时自性应变。由此自性应是无常。体无异故。犹如大等。又此自性其体周遍。一分变时余无量分体无异故。应亦随变。是则一分一法起时。余分余法皆应同起。如是举体有作用故。如大等果应是无常。又以前颂兼破此执。由彼所计自性最胜三分合成。所谓萨埵剌阇答摩。第一萨埵其性明白。第二剌阇其性躁动。第三答摩其性阇昧。此三一一相用众多。皆是神我所受用事。我以思为性。思所受用时。剌阇性躁警萨埵等令起种种转变功能。三法和同随于一分。变成大等。转名最胜。譬如大海其水湛然。随于一分风等所击。变成种种骇浪奔涛。如是所执自性最胜。一分有用变成大等。余分无能无所转变。是即自体应成种种。成种种故定是非常。如大等果相非常住。又三自性一一皆有明躁昧等众多作用。自性作用既许体同。以性随用应成多体。自性最胜无差别故。是则最胜体亦应多。自性最胜体成多故。应如大等定是无常

复次有执极微是常。是实和合相助有所生成。自体无亏而起诸果。此亦不然。义不成故。若许和合必有方分。既有方分定是无常。若言极微遍体和合。无方分者。此亦不然。何以故。颂曰

  在因微圆相　　于果则非有
  是故诸极微　　非遍体和合

论曰。若诸极微遍体和合。无方分故非少分合。是则诸微应同一处。实果应与自因遍合。无别处故。应亦微圆。若尔应许一切句义。皆越诸根所了知境。由见所依余可知故。是则违害世间自宗。若言实果虽与自因遍体和合无别处所。然由量德积集力故。令其实果亦可得见。谓诸实果虽无住处方分差别。然由量德积集殊胜。令所依实非大似大。方分差别分明可见。此但有言都无实义。我先难汝。所生实果与诸极微既无别处。应如极微越诸根境。汝不能救何事余言。若所依实如是相现。应舍实体同彼能依。既成他相应舍自相。亦不可说。如颇胝迦不舍前相而现余相。其体无常前后异故。此若同彼。应舍实体。德依于实。实体既无。德亦非有。无实无德。谁现谁相。故可不说所生实果不舍自相而现他相。如是即应唯德可见。所有实性皆越根境。此亦违汝自所立宗

复次有说极微有其形质。更相碍故居处不同。是则极微住虽邻次。而处各别应不和合。若许和合处同不同。即违自执。及有分过。有说极微生处各异。虽复无间而不相触。各据一方相避而住。积集差别似有方分。无间处生似有流转。刹那前后展转相续。有因有果非断非常。为兼破彼。故复颂曰

  于一极微处　　既不许有余
  是故亦不应　　许因果等量

论曰。如是所说诸极微相。竟不能遮有方分失。何以故。颂曰

  微若有东方　　必有东方分
  极微若有分　　如何是极微

论曰。是诸极微既有质碍。日轮才举舒光触时。东西两边光影各现。逐日光移随光影转。承光发影处既不同。故知极微定有方分。既有方分便失极微。如是极微即可分析。应如粗物非实非常。违汝论宗极微无方分常住实有造世间万物

复次所执极微定有方分。行所依故。如能行者凡所游行必有方分。若无方分则无所行。何以故。颂曰

  要取前舍后　　方得说为行

论曰。进所欣处。名为取前。退所厌处。名为舍后。要依前后方分差别起取舍用。乃名为行。离方分行所未曾见。极微既是行用所依。故知极微定有方分。若无所行行用差别。是则应拨行者为无。故说颂曰

  此二若是无　　行者应非有

论曰。依前后方起取舍用。方若非有。用亦应无。若尔虽行应如不动。若汝拨无行处行用。是则所依行者亦无。执此极微便着邪见。又诸极微若无行用。则不能造有方分果。若无所造有方分果。即诸天眼亦无所见。是则所立一切句义。越诸根境顿绝名言。云何自立句义差别

复次若执极微无初中后。即净眼根亦不能见。应如空花都无所有。为显此义。故说颂曰

  极微无初分　　中后分亦无
  是则一切眼　　皆所不能见

论曰。若执极微是常是一。无生住灭三种时分。无前中后三种方分。应似空花都无实物。是则极微越诸根境。不为一切眼所观见。自他推捡都不可得。是故不应计为实有。此中正破外道所执。极微是常无有方分。越诸根境非眼所见。兼显极微无常有分。非越根境净眼所见

复次为破极微因果同处。及显因体定是无常。故说颂曰

  若因为果坏　　是因即非常
  或许果与因　　二体不同处

论曰。诸有碍物余碍逼时。若不移处必当变坏。如是极微果所侵逼。或相受入异体同居。如以细流溉粗沙聚。或复入中令其转变。如妙药汁注赤镕铜。若许如前则有诸分。既相受入诸分支离。如相离物不共生果。是则应无一切粗物。又若同彼有诸细分。即应如彼体是无常。若许如后自说极微。体有变坏何待征难。若并不许。应许极微互相障隔因果别处。以有碍物处必不同。如非因果诸有碍物。又说颂曰

  不见有诸法　　常而是有对
  故极微是常　　诸佛未曾说

论曰。现见石等于自住处对碍余物。既是无常。极微亦尔。云何常住对碍与常。互相违反二法同体。理所不然。复有别释。余物共合变坏生因。名为有对。不尔极微皆有对碍。碍证无常其义明了。若谓极微障碍余物。他不全许。故须别立余物共合变坏生因。比度极微是无常者。是则但应以能生义。证极微性定是无常。何以颂中说为有对。故知此言是有碍义。虽不全许。而因义成。彼许极微碍余物故。既破极微方亦随坏。因极微果证实有方。极微既无。果则非有。何缘而立方实常耶。又方不定待缘而立。假施设有。非实非常。由上所说诸因缘故。极微是常。佛未曾说。但言诸行皆是无常。唯我大师独称觉者。于一切境智见无碍。所说无倒真号如来。愍彼邪徒不能归信诸行无常。诚哉佛说无为非行。何废常耶。然所立常无过二种。一有所作。二无所作。若有所作非谓无为。若无所作但有名想。故契经说。去来及我虚空涅槃是五种法。但有名想都无实义

大乘广百论释论卷第一大乘广百论释论卷第二

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破常品第一之余

复次有执涅槃实有常乐。如契经说。苾刍当知。有涅槃界。无生无灭无相无为究竟安乐。此亦依前理教应破。又说颂曰

  离缚所缚因　　更无真解脱
  生成用阙故　　设有亦名无

论曰。前已具说诸有句义越现量境于诤论时。必以生果比量安立非涅槃界能有所生。云何比知实有常乐。若许能生。则违自论。涅槃无果。违诸行故。是故涅槃体非实有。设许实有。于自依身无成胜用。何名解脱。若令己身萧然自在。永离系缚可名解脱。此于己身无如是用。是故设有于身无益。何党如是无用法为。若许有用则同有为。既许无用便同兔角。诸有智者。定应不许。有用无为无用实有。故知涅槃体非实有。此中烦恼及随烦恼。顺生后受诸决定业。总名为缚。由此势力令诸有情久处生死广大牢狱受诸剧苦不解脱故。诸缚所招五取蕴果。总名所缚。所生苦果系属集因不自在故。所有能除诸缚圣道。总名为因。由此永断烦恼随眠。不引诸业不招后苦。证得离系解脱果故。此解脱果。非离能缚所缚及因别有实体。谓从能缚得解脱时。非能缚外别证解脱。如实证见分位别故。即彼不生。名为解脱。所缚亦尔。离烦恼缚萧然自在分位差别。名为解脱。无别有法。因亦如是。作用差别离诸烦恼。名为解脱。离圣道外无别有法。是故离此缚所缚因。无别实有涅槃解脱

复次涅槃若有必有所依。此所依者。若蕴若我般涅槃时。俱不可得。故说颂曰

  究竟涅槃时　　无蕴亦无我
  不见涅槃者　　依何有涅槃

论曰。住无余依般涅槃位。前蕴永灭后蕴不生。其中都无诸蕴相续。既不见有般涅槃者。依何说有真实涅槃。若于尔时亦许施设。有其真实补特伽罗。便堕如来灭后定有。见处过失。若于尔时不施设有补特伽罗。还同前过。般涅槃者。既不可得。是故决定无实涅槃。以于世间都未曾见无贪等者。有贪等故。设复计有涅槃所依。是则涅槃有所依故。应如贪等其性无常。又若涅槃体是有者。则有缘相而可了知。应如色等不出生死。如说世尊若求涅槃体实有者不出生死。所以者何。言涅槃者。永灭众相离诸散动。此经义言。一切世间散动妄见皆永离故。彼所发起所取能取相永灭故。证得涅槃。是故涅槃决定非是一切有执所依缘处。有说二句知其次第。涅槃永灭所缘众相。永离一切能缘散动。涅槃既绝众相散动。不可以有而取涅槃。然经说有涅槃界等。为破拨无涅槃者见。有执生死无始无终。决定无有般涅槃界。故佛说有烦恼众苦炽火永灭。般涅槃界无生无灭无相无为究竟安乐。此立道理。显生死火非常相续永无灭期。从众缘生有损恼故。犹如世间山林炽火。谓生死苦虽无始来依众缘生相续无断。若遇善友闻法修行。无漏圣道现在前时。灭诸烦恼不起诸业。后苦不续。名曰涅槃。譬如世间薪尽火灭。然此涅槃圣道所证。究竟寂灭离诸性相。永绝一切分别戏论。所以契经种种宣说。皆为方便除妄见执。诸有智者应正觉知。勿谓涅槃是有无等。若于生死起诸分别。易作方便。令其断除。若于涅槃起诸分别。其病深固难可救疗。是故不应执有无等

复次数论外道作如是言。因果散坏悕望止息。唯有思我离系独存。尔时名为涅槃解脱。为破彼执故。说颂曰

  我时舍诸德　　离爱有何思

论曰。随所现境分别受用。汝说名思。即执为我。此必不离根境和合。如是二事不离悕望。为满悕望根境和合。随所现境思即受用。般涅槃时悕望止息。因果散坏何得有思。既无有思我亦非有。云何汝说唯有思我离系独存。尔时名为涅槃解脱。若汝复谓般涅槃时虽无有思而有我在。此亦不然。故说颂曰

  若有我无思　　便同无所有

论曰。汝宗计我思为性相。般涅槃时思既非有。性相俱灭。更无所有。复依何物而说有我。若谓尔时虽无思用而有种子我体犹存。譬如眼根见色为用。有时用灭而眼体在。此亦不然。若有所依可有是事。所以者何。功能差别。名为种子。如是种子必依于他。既无所依。何有种子。先世诸行功能差别所引识上。能生眼识差别功能。说名为眼。如是眼根必定依止阿赖耶识及四大种。无余依中因果散坏。悕望思虑悉皆灭尽。都无所依。而计有我体是种子。理不应然。又若执我即是种子。由此发思差别作用。此我即应最胜所摄。有胜功能起诸法故。又若执我是种所依。由此为因。能生思果。便失自宗。思即是我。及失思我其性懈堕。唯是受者。而非作者。若所执我非即是思。汝今应说如是我相。若不说相而我成者。则应一切妄执皆成。又说颂曰

  无余有我种　　则定能生思
  要无我无思　　诸有乃无有

论曰。若无余依般涅槃界有我种子不永拔者。则应决定生现起思。我无异故犹如前位。思若现起则有一切。何名解脱生死系缚。若言此中虽有我种众具阙故思不得生。此亦不然。我无异故应如前位。众具无阙。又汝所执我体周遍。与他众具恒共相应。无别处故犹如己有。云何而言众具有阙。若言众具各属自我。虽他众具恒共相应。不属己故言有阙者。此亦不然。处无别故恒共相应。何不属已。如是所执后当广破。若说此位究竟寂灭。本无有我。今复无思。一切种子无所依故。即便永灭不生后有。如无外种芽等不生。如是即名究竟解脱。非空非有。非断非常。非苦非乐。非我无我。非染非净。绝诸戏论。为止邪见拨无涅槃。故说真有常乐我净。此方便言。不应定执。既不执有亦不拨无。如是乃名正知解脱

复次胜论外道作如是言。若能永拔苦乐等本。弃舍一切唯我独存。萧然自在无所为作。常住安乐。名曰涅槃。如是涅槃决定应许。若唯苦灭无有我者。便为断坏。何谓涅槃。又此涅槃离诸系缚。自在为相。智者欣乐。体若都无。何所欣乐。此有虚言而无实义。为破彼执。故次颂曰

  若离苦有我　　则定无涅槃
  是故涅槃中　　我等皆永灭

论曰。汝执一切苦乐等法皆是我德。乃至未灭恒常随逐自所依我。云何此中与我相离。我无异故。应如前位与彼相应。又此乐等无余依中应不永离自所依我是我德故。犹如数等。如汝所执一德遍德是我德故。常与我合。苦等亦然。云何相离。如是此我。于无余依般涅槃界理所逼故。亦与苦等诸德相应。是则涅槃决定无有。我恒被缚不解脱故。生死唯有众苦聚集。因缘力故无始轮回。无明所迷妄生我执。谓我恒为苦火焚烧。恐失我故不求解脱。设求解脱亦不能证。妄执我故众苦炽盛。诸有智者依真善友无倒了知如是事已。为欲息灭炽然大苦。精勤方便如救头然。得圣慧水数数灌注。如所烧薪炽然永灭。寂静安乐。名曰涅槃。如是生死纯大苦聚。炽然永灭安乐涅槃。诸有智人谁不欣乐。谁有智者身婴重病。恐身断故欣乐此疾。唯有愚人能为是事。如地狱中诸有情类。虽为种种猛焰焚烧。大苦煎迫时无暂废。而于自身深爱著者。皆是所作恶业势力。无明妄见鬼魅所缠。未拔我见烦恼根本。令彼有情怖畏断灭。智者观见诸行相续。空无有我纯大苦聚。永断灭时何所怖畏。是故若能离于我见。必定欣乐永灭涅槃。由此亦能舍于断见。以见我断。名为断见。非唯苦断名为断见。故契经说。见我世间永断坏故。名为断见。言世间者。显我所事执我我所真实有体。闻彼断时便生断见。若无所执则无断见。唯依所执我我所事。所起颠倒断常两见。无上大师立边执见。由此妄见击发生死。大苦炽火令其增广逼迫无量无智有情。是故世尊称赞永灭。离欲寂静最胜安乐。令其可化深心欣乐。如是涅槃非无非有。妙智所证名为胜义。又诸义中最为胜故。过此更无所求义故。名为胜义。复次有作是说。常法定有。以胜义谛无生无灭真实善有能为所缘生圣智故。此亦不然。非胜义故。若胜义谛是实有者。应如色等从众缘生。若非缘生。应如兔角。体非实有。又无同喻有因不成。设许因成则非常住。又胜义谛体若是有。应如瓶等。非圣智境。若真圣智缘有为境。应如余智。非真圣智。不断烦恼不证涅槃。胜义谛理。非空非有。非常非无常。欲于其中求少有性。定不可得。为显此义故。次颂曰

  宁在世间求　　非求于胜义
  以世间少有　　于胜义都无

论曰。世间有法略有三种。一现所知法。如色声等。二现受用法。如瓶衣等。如是二法世共知有不待成立。三有作用法。如眼耳等。由彼彼用证知是有。如此三法是入世俗所了受境。世间复有三种无法。谓究竟无及随三有前后际无。为简此无故说少有。又简妄见所立诸法故言少有。如是世俗三有三无。依胜义说。皆非真实。以胜义谛非有非无。分别语言皆不能及。宁在世间虚伪事内。欲求有性少易可得。于胜义谛真实理中。欲求有性究竟难得。以此世间少分有性。于彼尚无。况余有性。若尔宁乐如是少有世间不须如是都无胜义。以于世间虽有种种灾患过失。而有少法可得受用。胜义谛中无有少法。何所受用。不尔世间胜义有苦无苦可欣厌故。谁有智者。知水不消成重病苦。更求多饮。哀哉世间愚痴颠倒。欣赞生死众苦炽然。厌毁胜义寂静安乐。如此痴言何烦听受。是故智者当勤精进观诸法空。于生死苦应除邪愿。于胜义乐应修正愿。如是具足三解脱门。虽复久居生死大海。而非生死过失所染。萧然解脱利乐有情。由此善通契经句义。方便善巧证法空者。虽处猛焰而不焚烧。虽现死生而常解脱

    大乘广百论释论破我品第二之一

复次胜论外道作如是言。前说无余般涅槃位。无蕴无我依谁而说。有涅槃者。其理不然。我定有故。若无我者。依缘何法而起我见。我见若无。执我所见亦不得有。若异生等从无始来。不起如是我我所见。应如永灭萨迦耶见。不受三界生死众苦。又不应说缘心根身发生我见。以心根身世间说为我所有故。又我我所决定有异。所属能属言所诠故。如天授等所乘车等。又缘他身我见无故。若许我见缘心根身为境生者。应如天授德授等见。亦缘他身为境生起。亦不应说自他心等有差别故。我见不缘无始时来自心根等。刹那展转前后各异。而许俱缘生我见故。又此我见不缘现在自心为境。与世现见事相违故。亦不得缘过去未来心等为境。彼无体故。如空华等不生我见。现见有我非曾当故。又于一身二心不并。故不可说缘现自心而生我见。又心念念异灭异生。若无我者。云何得有忆识习诵恩怨等事。又心根等决定不为我见所缘。男女等相此中无故。如瓶盆等。是故决定有真实我。由此为缘发生我见。因斯谓我是大丈夫

如是所说虽有虚言。而无实义。所以者何。我若是有。应如色等从缘而生。生定归灭则非常住。若非缘生应如兔角。无胜体用。何名为我。又虽立我是有是常。而竟不能立因立喻。非无因喻。所立得成。若唯立宗则得成者。一切所立皆应得成。设复方便矫立因喻。即所立我其体非常。一切有因皆非常故。又所立我定非实有。常住我性是所知故。是所说故。如瓶盆等。又所立我若是实有。应非颠倒我见所缘。若称实见是颠倒者。一切圣智皆应颠倒。一切圣智称境而见。既非颠倒。我见亦尔。应非颠倒。若尔我见应如圣智。非无始来生死根本。若此我见称实而知。而无始来引生死者。圣智亦应引诸生死。则应究竟不得涅槃。是故异生愚痴颠倒。于五取蕴无我法中。妄执有我。因执我所。由此妄执我我所见。不称实境成颠倒故。能引三界生死众苦。若于无我五取蕴中。起圣智见通达无我及无我所。永断生死证得涅槃。是故定应信受无我。又汝所言。以心根身世间说为我所有故。不应缘彼生我见者。我亦不应是我见境。世间亦说我所有我。有如是相。是故不应以世间说为我所故。非我见境我我所事相望不定。或有别物。或无别物。又汝所言。所属能属言所诠故。如天授等。我与我所定有异者。此因不定。世间亦说。如是饮食所有香味特异于常。岂离香味别有饮食。我我所见虽俱缘蕴。而或别执一蕴为我。余蕴为所。或复总执内蕴为我。外蕴为所。故所立宗有相符过。又汝所言。以缘他身我见无故。心等非是我见境者。我亦应非我见所缘。由于他我我见无故。若缘他我不起我见。而缘自我生我见者。虽缘他身不起我见。何妨我见缘自心等。无智有情不了平等空无我理。唯于诸行无始数习我我所见。于自于他诸蕴相续。执自为我。异我为他。其中都无我之实性。又汝所言。亦不应说。自他心等有差别故。我见不缘无始时来自心根等刹那展转前后各异。而许俱缘生我见者。此亦不然。自身前后因果相续。自望于他因果断故。如汝所执。我体是一。前后无异。他我相别。我见自缘己身中我。力用斯尽不缘他我。我亦如是。自身前后虽念念别。而无始来因果不断。如灯河等相续假一。无智有情谓为一我而生我见。他身于自因果断故。我见不缘。又汝计我。自他相似皆遍皆常。无所系属。我见何缘。缘此非彼。若汝计我有所系属。或有所生此彼差别。应如色等其性无常。是故当知有为因果相续各异。故令我见如是差别。又汝所说。我见不缘现在自心为境等难。皆不应理。所以者何。缘自身中前后因果。相续假一生我见故。无缘现在自心等过。又一身中有多心品。因果相属名一有情。异心品中发起我见。缘异心品计我何失。汝等所计我是实者。我见见我应如正见即非妄见。若不见我应如邪见。则非我见。又汝所言。心等念念异灭异生。若无我者。云何得有忆识习诵恩怨等者。此亦不然。有情身中一一各有阿赖耶识。一类相续任持诸法种子不失。与一切法互为因果。熏习力故。得有如是忆识习诵恩怨等事。汝所计我常无变易。后位如前应无是事。有应常有。无应常无。我体一故。不可说言。我用转变。用不离体。我亦应变。若尔此我应如色等体用俱变则是无常。若言心等皆属于我。心等转变有如是事。故所属我亦得其名。若尔心等应从我起。能生果故。我应非常。若我于心无生长用。云何得言心属于我。我既是常。不能任持心等种子。云何得有忆识等事。又汝所言。此心根等决定不为我见所缘。男女等相此中无故。如瓶等者。此因不成。男女等相身现有故。又所计我。亦应不为我见所缘。男女等相我中无故。即所立因便为不定。为显此义。故次颂曰

  内我实非男　　非女非非二
  但由无智故　　谓我为丈夫

论曰。依止身相有差别故。世俗说为男女非二。此身别相内我中无。以所计我体是一故。又男等相生生改易。亦见此生有转变者。舍别异相取所余相。汝所执我常无变易。无舍无取故无此相。亦不可说男女等相。虽非我体而是我德。我与德合。说为男等。所以者何。乐等德中所不说故。我不共德略有九种。一苦。二乐。三贪。四嗔。五勤勇。六法。七非法。八行。九智。男女等相九所不摄。云何而言。此是我德。又乐等德遍诸所依。男女等相所依不遍。云何得说此为我德。又不可说男女等相同异性摄。由同异性。亦得说我为男女等。所以者何。同异性者。所依决定常遍所依。我既是常。男女等相常应不舍。应一切时常有三相。又男等相遍表一切我及身等。云何唯我同异性摄。又同异性所依各别。设许唯我同异性摄。云何一我有三同异。不见一依有多同异。亦不可说。如波罗奢一树之上有三同异。波罗奢性树性实性。我亦如是。一我体上有三同异。男性女性非男女性。所以者何。波罗奢性遍波罗奢。树性遍树。实性遍实。此三所依互有宽狭。我上三性皆唯遍我。所依无别。云何为喻。是故唯依无始数习妄想分别所起假相。世俗道中说为男等。非有实我有男等相。但由无明憍逸妄想。愚夫自谓我是丈夫。亦有自谓为女非二。颂中略故。且说丈夫。以身中有男女等相。所执我体男等相无。故汝比量因有不成。不定过失。若汝复言。我及身等。虽复皆有男女等相。然我是实身等是假。此亦不然。若男等相二处皆有。云何得知一假一实。应立量言。我见决定不缘实我。男女等相所杂糅故。如缘身等。起男等相所杂糅心。又我见等。不缘实我有所缘故。如余心等。又我见境非是实我。男等相心之所缘故。犹如身等。故汝所言虚无实义

复次顺世外道作如是言。诸法及我大种为性。四大种外无别有物。即四大种和合为我。及身心等内外诸法。现世是有前后世无。有情数法如浮泡等。皆从现在众缘而生。非前世来不往后世。身根和合安立差别。为缘发起男女等心。受用所依与我和合。令我体有男等相现。缘此我境复起我见。谓我是男女及非二。今应问彼。汝说大种和合变异为身根等。如是成内大种自性。为是男等。非男等耶。彼答言非。内外大种。性无异故。虽大种性内外无异。然有安立形相差别。如是世间所知形相。所有男等自性差别。皆是自心分别所起。非实物中有如是性。若尔颂曰

  若诸大种中　　无男女非二
  云何诸大种　　有男等相生

论曰。若四大种本性无有男女非二。云何得有男等相生。男女等心何缘而起。受用所依虽与我合。云何令我男等相现。若我无有男女等相。云何我见。谓我是男女及非二。若本性无。虽与他合。终不能令转成余相。亦不能令生余相心。如鲜白物虽合余色不成余相。不起余心颇胝迦等。余色合时前灭后生。不可为喻。是故决定无有实我。大种为性经久时住。有男等相我见所缘

复次记论外道作如是言。诸法及我。一切皆与三相和合。由此三相。皆能发起三种心声。何谓三相。一者男相。能生诸法。二者女相。能灭诸法。三非二相。能守本位。此亦不然。诸法及我。体非三相。云何能起三种心声。亦不可说。与他合故转成三相。前所说过不相离故。若法及我。体非三相。三相合故转成三相。三相更无余三相合。故此三相应非三相。应不能起三种心声。又此三相与非相合。能使非相转成相者。诸法及我与相合时。应令三相转成非相。是则毕竟应不能起三种心声。又此三相功能差别。更互相违必应不并。云何一物得有三声。如角等物。男女非二。三声所呼世共知故。又一物上三相功能。更互相违而得并者。应一切物皆具三相。不应现见声有差别。又此三相若实有者。唯应依止有法非无。是则三声应不周遍。云何现见诸方言音。有法上无。无法上有。现见境界不可诽谤。若无三相而有三声。则一切处皆应如是。又此三相配生住灭。理不应然。男死女生非二生死。世现见故。又此三相无别实体。后当广辨。是故但随世俗言路。说有男等三声差别。非别实有如是三相。外道执有如是三相。依附实我我见所缘。是颠倒智。内道不执。故无颠倒。汝不应依。有颠倒智与无倒者。正决择时立为定量。以我见缘证实有我。又此我见。为随我相执有我耶。为随自觉执有我耶。若随我相应。名正见。若随自觉。应不缘我。又若初者。颂曰

  汝我余非我　　故我无定相

论曰。若汝身中我之自相。诸余身中我亦同有。随我自相而起我见。云何一见不缘一切。既无一见缘一切我。故知我见不随我相。若汝身中我自相异。余身中我自相复别。汝以为我。余则为非。余以为我。汝则为非。是则此我相不决定。既无定相。便无定性。性相不定。非实非常。云何执我真实常住。又立量言。自身我见。不随自我自相而起。不缘余我自相生故。如所余缘所有心等。又自身我应不为缘。发自我见汝许我故。如他身我。又诸我见。定不缘我。自他境相互有无故。如青黄等能缘之心。又一切我非我见境。诸余有法所不摄故。犹如一切兔角等无。又一切我非实我性。是所知故。如一切法。是故我见不缘实我。诸所计我无实性相。一切智者皆非所见。唯诸愚人恒深乐着。如病眼境定非实有。故不可以我见所缘。证立此我实有常住。若第二者。颂曰

  岂不于无常　　妄分别为我

论曰。若随自觉执有我者。岂不但缘无常身等。虚妄分别执为实我。所以者何。现见世间但缘身等。前后随缘分位差别。虚妄计度。我肥我瘦。我胜我劣。我明我闇。我苦我乐。身等无常可有是事。常住实我无此差别。由此比知。一切我见。皆无实我以为境界。唯缘虚妄身等为境。随自妄想觉慧生故。如缘闇绳颠倒蛇执。又如世间虚妄分别。执有空华第二月等。必由先见世间少事。然后方执有如是事。我见执我亦复如是。先缘生灭五取蕴事。后方决定执有实我。又如梦中虚妄境界。随先所见和合计度。我见境界亦复如是。先缘诸蕴。然后和合虚妄计度。又诸我见略有二种。一者俱生。二者分别。俱生我见。由无始来。内因力故恒与身俱。不待邪教及邪分别。任运而起。故名俱生。此复二种。一常相续。在第七识缘第八识。起自心相。即执为我。名为我见。二有间断。在第六识缘五取蕴。或总或别起自心相。即执为我。名为我见

如是二种。俱生我见微细难断。数数修习胜无我观。方能除灭分别我见。由现在世外缘力故。非与身俱。要待邪教及邪分别。然后方起。故名分别。此亦二种。一缘邪教所说蕴相。起自心相。分别为我。名为我见。二缘邪教所说我相。起自心相。分别为我。名为我见如是二种分别我见。粗重易断圣谛现观。初现行时即便除灭。如是所说一切我见。心外蕴境或有或无。心内蕴境一切皆有。是故我见皆缘无常。诸蕴行相妄执为我。诸蕴行相从缘生故。是虚幻有妄所执我。非缘生故决定非有。故契经说。苾刍当知。世间沙门婆罗门等。所有我见。一切皆缘五取蕴起

复次今应审问。诸翳盲徒空无我理。有何所失。而强分别固执我耶。若一切法空无我者。生死涅槃二事俱失。所以者何。由有我故。诸无智者乐着生死。先造能招善不善业。后受所感爱非爱果。诸有智者欣乐涅槃。先观生死苦火煎逼。发心厌离。后方舍恶勤修诸善。得正解脱。如是一切皆由我成。我为作者。我为受者。我为苦逼发心厌离。舍恶修善证得涅槃。若尔颂曰

  我即同于身　　生生有变易
  故离身有我　　常住理不然

论曰。若我先造种种行业。后方领受种种果报。是则此我体应转变。因必有转变。果有差别故。无有道理。因不转变而果众多。及非恒有。谓所执我那落迦等。诸趣诸界生差别中。若能造受种种业果。则应同身生生变易。非天授等。身无变易。先能造作善恶二业。后能领受苦乐两果。是故我体同所依身。能造受故。生生变易。有变易故。则有生灭。生灭相应。岂得常住。又所执我不离身等。有情数摄。体非常故。如所依身。是故执我常住离身。能为作者。及为受者。生死轮回。皆不应理。以离身等无别用故

复次云何此我能造诸业。若谓与身合故能造。由此内我有勤勇德。因此德故。与身和合起诸作业。此德作业虽待依身。而属于我。如以金石投于树枝。重德相应故有摇动。是德作用虽待树枝。而属金石。此亦不然。有触对物。可有如是动摇作用。汝我不尔。云何身合能造诸业。所以者何。颂曰

  若法无触对　　则无有动摇
  是故身作业　　非命者能造

论曰。一切能起动摇作业。决定不离有触对物。我无触对。虽与身合。云何能作摇动业因。如所执时无有触对。虽与身合不能作业。心及心法唯能生风。风与身合方能造业。故所立因无不定过。此说近因。非展转故。又可合者必有方分。两物相触无间名合。所执我等既无方分。云何与身合故造业。不可假说我有方分。即有实起作业功能。勿以假名说水为火。即有实火焚烧作用。由能说人假说诸法。非能说人有差别故。令所说法其性转变。法性决定前已具论。于本颂中。无触对者。显无方分。无动摇者。显无合义。又自有动方能动他。如金石等要自有动。方能为因令树枝动。我既无动无形碍故。何能为因令所依动。如金石等不动转位。无触对者显无形碍。无形碍故自无有动。无动摇者显非动因。如是所执无动神我。尚无能动一毫之力。况能造业得名作者。既不造业即无有果。若不受果何名受者

复次如汝所言。我为苦逼发心厌离舍恶修善得解脱者。此亦不然。何以故。颂曰

  我常非所害　　岂烦修护因
  谁恐食金刚　　执仗防众蠹

论曰。汝所计我既无变易。如太虚空其体常住。一切灾苦皆不能害。岂烦精进修防护因。有变坏身。苦所逼害罪所涂染。理须防护。谁有智者。了知金刚物无能坏。而恐侵食。率侣执仗防诸蠹虫。唯有愚人。或为是事。可变坏物应加守卫。若汝意谓。命可害故。我亦随害。此亦不然。我既是常。不应随害。又汝计命三事和合。谓身我意前已遮破。我与身合无方分故。如汝所计。色等诸德无和合义。又和合者无别有性。唯有方分无间而生。既无别体。复何所害。此设可害必随所依。所依既常。云何可害。设复害命。于我何恼。以汝所计我常无碍。如太虚空寒暑风雨霜雹无损。如是我性苦何所恼。又所执我其性凝然。前后无变。设离众恶。复何所增而名解脱。岂不此位善法增耶。我性既常。善增何益。所执我体常无改变。余法虽生亦无增损。如是解脱。于我无用。是故执我常住无变。生死涅槃二事俱失。若空无我二事俱成

大乘广百论释论卷第二大乘广百论释论卷第三

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破我品第二之余

复次有作是言。若无我者。心等生已无间即灭。宿生念智忆昔某名。即是今我此不应有。所以者何。今昔异故。世间不见忆昔他身。谓为今我。是故定有常住句义。缘之生念。言彼即我。此亦不然。我先已说。因果虽殊相续假一。缘此假一言昔是今。又说颂曰

  若有宿生念　　便谓我为常
  既见昔时痕　　身亦应常住

论曰。若宿生念依相似相。见昔似今谓今为昔。便谓有我是一是常。既见今身依相似相。疮痕似昔谓昔为今。身亦应许是常是一。此显共知有差别物。依相续假亦谓无异。故不可以谓无异相。比知有我是一是常。又忆昔身苦乐等事。谓今是昔而是无常。亦应比知。虽谓今昔我无有异。而非常住。又虽今昔其体有异。然由昔智了受所缘。有胜功能熏在宅识。随缘觉发念力相应。似昔所缘境界相现。如是名为忆宿生事。虽无有我是一是常。而有忆念宿生事智。世间现见服仙药等。服之经久。药体虽无。然有所引胜功能在。后时成熟除疾益寿。然无有我。此亦如是。若唯有念。谁为念者。亦不可言念为念者。以有二种俱无过故。设复有我谁为念者。亦不可言我为念者。以所执我非智相故。若言我体虽非智相。与思合故能有思念。是则此我与思合时。于自他相应有取舍。若有取舍便是无常。若无取舍不异前故。与思合时亦无思念。是则此我。亦非念者。又说颂曰

  若我与思合　　转成思念者
  思亦应非思　　故我非常住

论曰。若所执我本性非思。与思合故转成思念。如颇胝迦体非青等。青等合故变成青等。是则此思与非思我。而共合故应成非思。若思虽与非思我合。不舍本性不成非思。我亦应尔。虽与思合。不舍本性不成思念。颇胝迦宝青等合时。举体别生故见异色。非即本性变成余相。以颇胝迦其体清润。余色合故举体别生。形相同前谓为本质。实非本性变成余色。又颇胝迦前后异体。相差别故。如青黄等。我亦应尔。云何是常。又应同此非实我性。由此即破彼论异说。谓有说言。颇胝迦宝。其性清净不障眼目。余色合时各别处住。不舍本相不取余相。若有作意或不作意。还见本相及近彼色。复有说言。颇胝迦宝其性明彻。犹如明镜。余色合时影现其内。见者目乱。谓成余色。而实此宝不变如前。此皆非理。违比量故。为眼所见。如电如灯。云何前后体相无变又所执我思生前后。其相有无不决定故。则应同思念念生灭。又我思合转成思者。与苦乐合应成苦乐。若不尔者。虽苦乐合不舍前位。犹如虚空雨火无变。应非受者。故说颂曰

  我与乐等合　　种种如乐等
  我如乐等故　　非一亦非常

论曰。乐等性相更互相违。故有种种我与彼合。应如乐等成种种相。故此我性应如乐等。身身各别非一非常。亦如乐等非真我性。是故离思别有我体。与思合故同于思相。名为念者。不应道理。即念自性似所念境。相状生时虽无主宰。似有作用假名念者。记别分明。说名为念。一法义分无无二过

复次数论外道作如是言。思即是我其性常住。如是思我离心心法。别有体相难可了知。所以者何。思我体相非现量境。以其自相非诸世间所共知故。非比量境。以其思相唯在于我不共余故。夫比量者。比知共相。以果等总相比因等总有所立思我由不共故。无同法喻。同法喻既无。异法亦非有。无待对故。由是思我理实为无。设许有我以思为性。应当征问。如是我性为由他力得成思耶。为由自力得成思耶。若由他力得成思者。应是无常如眼识等。若由自力得成思者。应不待缘如虚空等。为显此义又说颂曰

  若谓我思常　　缘助成邪执
  如言火常住　　则不缘薪等

论曰。如法已生自相安住。终不更藉因及众缘。不可生已复更生故。我亦应尔。思体既常。自相安住。不依他立。云何复待转变众缘资助思我。令其转变受用种种所受用具。若不依他而转变者。则无缘助有所受用。若可转变。应是无常。如世间火其性无常。若以酥油灌薪草。等投其火中便增炽盛。若不尔者。火势衰微薪等若无。火则非有。既缘薪等。火岂是常。我既藉缘。宁容常住。若汝复言。我论中说。如是思我其体虽常。然藉根尘和合显了。如瓶盆等。由光明显。所以者何。思我不能自然观察。要待转变因果相应。方得显了。故虽藉缘而我常住。如是救义其过弥增。所以者何。不见瓶等为缘所显而体是常。真如涅槃虽可显了。然依世俗。非据胜义。非胜义中有常无常了不了等分别戏论。所执思我缘所显故。应如瓶等其性非常。若汝复谓隐时思我虽无思虑而有功能。如是功能不异思虑。既无思虑。何有功能。又思功能必依思体。体既非有。能何所依。又隐时我以思为性。思既非有。我则是无。云何而言隐时思我虽无思虑而有功能。设言隐时我非思者。汝今应说。我相如何。若不说相而我成者。则应一切妄执皆成。如是推征前已具说。又汝所执。诸有功能与功能者其性为一。是则能者。非能所依。性是一故。又于此位。无能者故。不可说言能即依能。自于自用。理相违故。亦不可说能无所依。勿有最胜。亦无过失。所以者何。若思功能无所依止而自立者。转变功能亦应自立。何须最胜。又汝所执。思我功能随所受用有无量种。既许能多。如何体一。汝宗定执体能一故。世间未有一法体上不同一时能生多果。不同时者。显于一时。一法体上能生多果。时若不同。其体必异。云何汝执一我前后有多功能起多思虑。又此思我云何一时不起一切受果思虑。若言思虑必待转变方得起者。此亦不然。云何最胜具诸功能。而不顿起一切转变最胜功能无障碍故。设许最胜于一时间顿起一切转变作用。是即最胜。体应断灭。举体皆变。失本性故。如最胜体。我亦应然。其性皆常。具诸能故。如是汝执隐时思我具诸功能而无思虑。有多过失。终不能免

复次有余方便救此义言。我是思者。思为我用。非用灭时。用者随灭现见眼等。虽无能照色等作用。而有其体。是故隐时虽无思用而有思者。我体非无。此亦不然。隐时我相应与思别。还同前过。岂不作用与作用者。体不异故无别相耶。汝言正似痴象沐浴。意避轻咎翻招重秽。思用我体既无别异。思用灭时我体应灭。是则思我皆定无常。便害自宗。何名救义。又汝所言。现见眼等虽无能照色等作用而有其体。我亦尔者。此亦不然。故次颂曰

  如至灭动物　　作用彼无有

论曰。如能照了色等作用。乃至灭来恒随了别自境界识。由此作用即是识体。作用若灭识体则无。眼等诸根至相续断。常无此用。自性异故。所以者何。眼等自性非能照等。故彼灭时此不随灭。眼等所造净色为性。汝我离思无别有体不可用灭而体独存。岂不说我思者为相。云何乃言离思无体。汝前虽说。然不应理。所以者何。思者。思用既不同灭。应有别体我体非思。过如前说用无别体。先难复来。又思思者相待而立。俱有方成。阙一不可。思与思者。若一若异。定触如前所说两过。如是释已。复有别释。如他眼等乃至灭来。常有作用能生别物。非汝所执我思作用。许为如此别物所依照色等用。即是眼等各于自境生识功能。眼等诸根随所生识。种种自相差别显现。虽离因识无别有体。而离果识别有自相。汝执有我能生于思。不许离思别有自相。是故不可引为同喻。故说颂曰

  故有我无思　　其理不成就

论曰。有别相者。不同体故。可得说言一灭一在。思用思者既无别相。思若灭时思者亦灭。是故汝执有我无思所立道理。定不成就。复次有执离思别有实我。其体周遍一分生思。谓我一分先与智合。引起能生殊胜思行。后时一分意合生思。故无如前所说过失。此不应理。故说颂曰

  余方起思界　　别处见于思

论曰。方处若异。因果不成。未见世间种与芽等。各住远处因果得成。汝执能生殊胜思行。先于远处我与智合。习诵经书工巧等事。令其善巧熏在我中。后于异方若无障碍。我与意合生起现思。是则分明因果异处。岂不行思所合我体。不别异故无此过耶。若尔一切行等因果悉与我合。处应皆同。便失汝宗我体周遍。一分智合引起思行。一分意合生起现思。若汝复谓如镕铁铤。其铤一头先与火合。余头虽复不与火合。由体一故亦渐镕销。行思亦然。生处虽别。我体一故。因果成者。此亦不然。故次颂曰

  如铁铤镕销　　我体应变坏

论曰。如镕铁铤。其铤一头先与火合。当即销镕于后展转热势相及。余离火处皆复销镕。如是我体先于一分与智和合变生思果。于后展转势力相通。异处意合变生思果。是则我体应非常住。如何妄立我是常耶。又汝执我唯依少分能生于思说名思者。此亦不然。故次颂曰

  思如意量小　　我似虚空大
  唯应观自相　　则不见于思

论曰。汝执我体一分意合能生于思。说名思者。余分我体不与意合不生思故不名思者意有质碍。细似极微。我性虚通广如空界。少分意合能发于思。余分无边皆无思虑。故应从多观是我相。不应就少见为思者。夫于自体假立名言。或依多相而表于体。或为他染以彰其相。如此二事我上皆无。故我不应说名思者。若汝复言。思非我相。思是德。我是实。此实德业三种自性不相杂乱。何为不可。以汝不能离思别显我之自相。是为不可。若不别显我之自相。终不能立我有实体。自相毕竟不可说故。汝所立我则为无我。又汝所立我非思者。便失我相。非思者。故如色等法非我非思。又思为先所造诸业。应不属我则成相违。与自他思俱不合故。我无思虑与彼所求。因果事物非意相遇。应如乌鹊厄多罗果。由如是等众多过失。我便散坏终不得成。复次有余苟避如是过网。不许我体少分起用。执能依德遍所依我。此亦不然。德若遍。我根等和合便为无用。无根等处有乐等故。若言不尔。由我一分与根等合遍生乐等。如在一处炷等行力。发起灯光明遍多处。若尔颂曰

  我德若周遍　　何为他不受

论曰。若我与德体俱遍者。一人乐等应遍诸我。何为余我皆不受耶。宁许一分我与意合。即于是处生苦乐等。我能领受。无此过失。若汝复言。我所有物唯属于我。我能领纳一人乐等。虽遍诸我然唯属一。不系余人。云何令他受我苦乐。世间现见所有财物。唯主能受。非他所用。若处有别是事可然。既是同居何妨共受。诸同处物若不属己。虽无取舍自在受用。见触受用谁复能遮。现见世间非属己物。若同一处见触无遮。今苦乐等无形质故。唯能见触不可取舍。是故汝言不成救义。若言余我于他苦乐。由有闇障不能领受。如世间物虽复同居。眼无障者能有所见。眼若有障即无所观。我亦如是。于自苦乐无闇障故。便能领受于他苦乐。虽复同居有闇障故。不能领受。若尔闇障少分转耶。彼言不也。周遍转故。此障彼我处不同耶。复言不也。处无别故。若尔颂曰

  能障既言通　　不应唯障一

论曰。一闇障处有无量我。处既无别一我被障。余则不然。谁能信解闇相无别。我相是同能障所障。处复无别所受乐等。其义亦然。是则有障及以无障。受与不受一切应同。不见世间有诸外闇如汝所计内闇差别。前虽执德不遍所依。而我体遍与他德合。应亦能受。过同此言。我岂不说乐等与意其处要同方能领受故无受他乐等过失。汝等外道随自意言。非随意言能契正理。非可照物处灯明中。而此灯明不能照了。我亦应尔。云何不受。若汝复言。虽一切我体皆周遍。而自乐等不共于他。何以故。乐等诸德由行势力而得生故。此行势力依法非法而能受果。故此义成。如是方便于理无益。过失同前。不成救义。如是论者。依理推征。邪观为先。立我常遍能作能受。义不得成

复次有说萨埵剌阇答摩三德非思而为作者。我思非作而能领受。为破此义故。次颂曰

  若德并非思　　何能造一切
  彼应与狂乱　　俱痴无所成

论曰。所执三德体若非思。何能为我造化万物。若本无思而有所造。彼与狂乱何事不同。设复如狂。斯有何失。若如狂者。为我造立所受用事。应不得成。未见世间痴狂仆匠能为主等办如意物。又彼诸德于所作事。若无善巧应似愚人于雕画等不能成办于所作事。若有善巧。云何不能即自受用。为显此义故。复颂曰

  若德能善解　　造舍等诸物
  而不知受用　　非理宁过此

论曰。若言诸德如工巧者。于难作事能善施为。内外所须无不成办。而于受用易见事中。不善了达。一何非理。除守自愚谁朋此见如是三德于受用中。亦有善巧为彼体故。如于善巧诸所作事。此显作受者俱依三德成故。不须别立我思。为受者。若言胜性虽体非思。然随缘势造化万物。为令思我自在受用。如草木等虽无所思而依业力生花果等。种种不同为人受用。若尔胜性所作无思。应同华果。受已不绝。诸有思惟而生果者。受用足已果便休废。胜性非思。如外草木。又常不坏我受用已。所作便息。其理不然。若言三德其性黠慧。凡所施为无不善巧。我为神主能善思惟。令彼造作自在领受。谓彼三德了知神我。意有所须方起觉慧。随起作用造化万物。于是思我自在受用。汝此言说。但述自宗。于诤义中都无所用。又汝所立。我有思惟。德有觉慧。如是二种俱能领纳。了别自境性相差别难可了知。是故不应虚妄分别觉慧属德思惟在我。又德应失觉慧自相。无思惟故。犹如色等。汝言三德了知神我。意有所须方起觉慧。起作用等。此则不然。自性位中无觉慧用。谁能知我意有所须。若于尔时觉慧已起。何待知我意欲方起。若于尔时觉慧未起。云何三德初起于大。若无觉慧大体自起。一切万物亦应自起。故此觉慧于变异果。自性因中都无所用。有余复立比量救言。觉慧非思。是无常故。诸无常者。皆非思虑。犹如色等。如是自言违害自意。思惟分别得觉慧名。若不思惟便非觉慧。云何而说觉慧非思。又先已说觉慧思惟。俱了自境性相无别。云何觉慧无有思惟。是故汝言有自违过。又无常因有不成过。就生灭义。自宗不许。隐显义释。他宗不成。若言因义不应分别。但就总说此亦不然。若别俱成。可就总说。如其别见。总显为因。别既不成。总依何立。又依作用说有隐显。依此立为无常因义。汝立我思亦有作用。故有因义不定过失。又汝欲立觉慧体外别有我思。或我思外别有觉慧。皆不得成。如是种类非共所许。由此汝立无得成义。是故所说我思能受三德能作。其义不成

复次有执我体常遍无碍能造万物。名为作者。此亦不然。义相违故。若汝执我有动作用。名为作者。即有无常及有质碍。不遍过失现见无常。不遍有碍。方有动作。常遍无碍。有动作用。曾未见故。若所执我无有动作。云何得名能造作者。是故必应许有动作。若尔应许我体无常。有碍不遍。为显此义。故次颂曰

  有动作无常　　虚通无动作

论曰。风界势力能生动作。谓由风界诸行流转。于异处生相续不绝。依世俗理说名动作。依此动作说为作者。此必不越有碍无常。有碍无常即非周遍。汝宗亦许极微动作。有碍不遍前已遮遣。执为常者显是无常。是故比量无不定过。若言我宗不许内我体有动作因不成者。此亦不然。必应许故。若无动作何名作者。汝虽不许业句动作而有作者。言依动作。如说火焰来去等言。又必应许我有作用。若全不许我有作用。我则为无。同兔角等。为显此义。故次颂曰

  无用同无性

论曰。若汝所执。我有作用。可为作者。名言所依。若无作用。则同非有。依何说我以为作者。既无作用应不名有。若谓有言。不依作用。但依同性。及彼相应。此亦不然。世间智者依有用体。说有名言。若无有用则无有体无用无体名。依谁立云何而言有作者我。若汝不了。有言所依但应受持。默不语法何须强说。我有作者有言依止。有用之体世智共许。汝必应随。若汝定执我无作用。应如共许毕竟无法。由此比量我即为无。何不爱乐空无我理。为显此义。故次颂曰

  何不欣无我

论曰。如过去法既无能生。诸法作用即无自体。由此同法。我亦应然。无世共许焰行等用。亦无自许往来等用。应无自体。如是我性都无所有。非唯顺理。亦称汝心。何不欣求空无我理。计不信者正为无明。所起邪执力强故耳。若汝谓我虽无别用而能为境生我见心故名作者。此亦有失。前已广破。今复重来。又我不能为我见境。无作用故。犹如兔角此我见等亦不缘我。有所缘故。如缘色心若实有我能生我见。此我云何如善幻术。随其所愿现种种相。诳惑世间令起种种我见差别。为显此义。故次颂曰

  或观我周遍　　或见量同身
  或执如极微

论曰。一类外道执我周遍于一切处受苦乐故。我无形质亦无动作。不可随身往来生死。故知内我遍于一切。一类外道作如是言。我若周遍如虚空者。不应随身受诸苦乐。应如空界无所往来。其性湛然非作受者。是故我性应如色等随所依身形量不定。虽无形碍而有所依。转变随身受诸苦乐。虽依形质有卷有舒。而我体性无生无灭。如油渧水随水广狭。虽有卷舒而无增减。一类外道复作是言。若我体性随形量者。即应如身有分有变。又汝执我随所依身。似水依堤如油逐水。是则此我如彼水油。既变既多非常非一。引此为喻而言我体为常为一。与理相违。是故我体住于身内。形量极细如一极微。不可分析体常无变。动虑动身能作能受。此亦不然。以违理故。众微聚积成极大身。我住其中形量甚小。云何小我能转大身。举体同时皆见动作。若汝意谓我量虽小。而于身中往来击发。渐次周匝如旋火轮。以速疾故谓言俱动。若尔我体巡历身中。应有生灭及成众分。但是迁流至余处者。定归生灭必有众分。既言我转。所至非恒。如彼灯光。岂有常一。常必非动。动即非常。我动而常。深违正理。又所执我有住有行。何得说为是常是一。若行时我不舍住性。应如住位则无所行。若行时我舍其住性。别体即生。常一何在。如是等类我执无边。以理推征皆不成立。为显此义。故次颂曰

  智者达非有

论曰。若有实我性相皆同等以为缘生我见者。如是我见不应得有。种种差别更互相违。以此知无常住实我。但由久习虚妄我见熏在识中功能成熟。如身逐业缘变不同。我见随因缘别亦尔。唯有心相变现众多。于中都无一我实体。故诸贤圣积无倒因。方便勤求证我非有

复次诸有说我能证解脱。但顺愚心。终违正理。所以者何。故次颂曰

  常法非可恼　　何舍恼解脱
  是故计我常　　证解脱非理

论曰。若计我常无有变易。虽遭众苦霜雹等灾。如太虚空都无所损。不应智者。观诸世间众苦所逼。发心厌离方便正勤以证解脱。此显我常不可恼故。虽触众苦应不觉知。若不觉知则无厌离。若无厌离则不正勤。若不正勤则无解脱。哀哉外道狂乱无知。譬如有人惧诸霜雹疾风瀑雨水火等灾损害虚空。勤加守护。既执有我无恼湛然。讵劳自苦妄求解脱。谁有心者。顾此痴狂无缘自苦不深悲愍。外道经中咸作是说。着我生死离我涅槃。既赞舍我令欣解脱。如何固执有实我耶。为显此义。故复颂曰

  我若实有性　　不应赞离我

论曰。我若实有。缘生我见即是真实。不应劝舍为证实我。应更殷勤劝修我见令其坚固。云何劝舍真实我见令修虚妄无我见耶

又诸外道。或随师教。或自寻思。起诸我见。种种诤论互相违反。云何执此为实见耶。于一我上竞执纷纭乍可生疑。如何执实。若无我见不称实我。汝不应说能证涅槃。不称实见证涅槃者。知真趣脱。此说应虚。为显斯义故次颂曰

  定知真实者　　趣解脱应虚

论曰。有我若实无我我所。解脱方便见应成虚。有我我所违逆涅槃随顺生死。见应是实。若颠倒见随顺涅槃。无颠倒见随顺生死。云何汝论。作如是言。定知实者能趣解脱。以此定知空无我见。得涅槃故所证非虚。我我所见涅槃时舍。应如余见是其颠倒。又汝论说我见无倒。在闻思位至修位中。我见既舍复成颠倒。以其我相略有二种。一有。二无。有顺生死。无顺涅槃。故有我见入圣时舍。汝此狂论。为世所嗤。审察即无。如何实有。如绳在闇乍见言蛇。及至谛观乃知非实。外道亦尔。无明闇中见无常身谓有常我。若得圣智谛观此身。达空无我而证解脱。知有我见初实后虚确言称境有信无智。既许我见初实后虚。得涅槃时应许无我。后若无者。前亦应无。为显此义。故次颂曰

  解脱中若无　　前亦应非有

论曰。此中意显。如解脱位我无有相。未解脱时亦应非有。性无别故。或复身等于解脱时既无有我。未解脱位。亦应无我。相无别故。诸外道等无智睡眠。眯覆慧目不了诸行。相续道中微细差别。妄执有我是一是常。不可以其无智杂见谓证真理。要依无杂清净智见方证真理。为显此义。故次颂曰

  无杂时所见　　彼真性应知

论曰。以不杂火自有水相。知杂火时暖非水体。身等自相应知亦尔。得解脱时空无我故。杂我见位亦无有我。或复我体应知亦然。无杂位中既无有相。杂我见位有相亦无。是故应知无杂所见称法实性杂见不然

复次诸外道等咸设难言。若一切法空无我者。是心根身云何不断。无常诸行空无我者。悉皆断灭如灯火声。此亦不然。故次颂曰

  若无常皆断　　草等何不然

论曰。虽诸草等无我无常。然有因缘相续不断。心根身等应知亦然。故所立因有不定过。又立因喻证心根身皆有断灭。此言未了。为一念生无间即灭更不相续名为断耶。为经多时相续不绝后要当尽名为断耶。若言初者。阙于同法。灯等随因多时起故。若言第二我亦许然。无余涅槃生死断故。为破前因。复说颂曰

  此理设为真　　无明亦非有

论曰。无明自性非我非常。应亦如灯自然断灭。若如是者。无明所生贪等惑障。应自然断。若尔即应生死系缚。不由功用自然解脱。此二半颂俱显前因。有不定失。内外为异

复次诸外道等有作是说。色等诸法虽是无常。然依我故相续无断。此亦不然。违解脱故。若色等法依我生者。我既是常前后无异。即应毕竟不证解脱。若言诸法虽依我生。然由缘助。故无此失。若尔诸法唯应由彼众缘而生。我复何用能生众缘与所生果更相随顺同有同无。我既是常。一切时有。果则不尔。岂藉彼生我用难知缘力共了。如何党我不信众缘。为显此义。故次颂曰

  现见色等行　　从缘生住灭
  故知汝执我　　虽有而无用

论曰。色等诸行生住灭时。现见从缘不依于我。汝执我体既非缘生。即无作用如前已说。又色等法生住灭相。种类及时皆不同故。何得依一常住我缘。如烧煮等依缘别故。熟德色类亦有差别。如是差别不依一缘。谓无始来色等诸法。名言熏习种类不同。及先所造诸有趣业。种种差别功能转变。随所遇缘成熟发起。变生色等生等差别。所言缘者。谓精血等是其生缘。衣食定等是其住缘。毒药灾横四大乱等。是其灭缘。诸所计我无此别用。外道愚痴强立为有。为显此义。复说颂曰

  如缘成芽等　　缘成种等生
  故无常诸法　　皆无常所起

论曰。如外种等依自因缘功能差别而得生起。复待余缘助发功力。变生自类芽等诸果。内身心等应知亦然。诸行相续同类异类。随所遇缘生果差别。此则显示内身心法。体无常故。如外芽等。必从自类无常因生。我于身心无能生用。非缘生故。如龟毛等。复次为显诸法虽无有我而非断常二过所及。故于品后。复说颂曰

  以法从缘生　　故体而无断
  以法从缘灭　　故体亦非常

论曰。诸法展转从无始来。依同类因生等流果。起后后果。续前前因。于中无间。所以不断。若前因灭。后果不生。于中有间。可名为断。由对治生前因力灭后果不续。所以非常。若法凝然不舍前相其体无变。可名为常。又前因灭。所以非常。后果续生所以非断。又因生故。所以非常。能生果故。所以非断。又念念别。所以非常。相似相续。所以非断。又法非有。所以非常。亦复非无。所以非断。有即为常。无便断故。如是佛子远离二边。悟入缘生处中妙理。正观一切非有非无。法尚性空。我岂为有。萨迦耶见及以随眠并此所生于斯永灭。复观诸行平等性空。彼此俱亡自他想灭。遍于一切所化有情。起无缘慈澍妙法雨。穷未来际极太虚空。利乐有情胜用无尽。此勇猛者空观所持。众苦炽然皆不能触。见大生死如空宅中。妄想所牵众多忧苦。譬如猛火腾焰震烈。焚烧无量。无智有情悲愿缠心。无所怯惮。投身没命而拔济之。此大慧者观空无倒。我想既除离我所执。二爱尽故。不复乐观贪等烦恼所依止事。为饶益他常处生死。于中不染。即大涅槃。虽处尘劳无边苦海。恒受胜乐过二涅槃

大乘广百论释论卷第三大乘广百论释论卷第四

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破时品第三之一

复次有作是言。如说已灭未生无体。其理不然。诸有为法前后两际作用虽无而体恒有。分位别故三世不同。无必不生有定无灭。为破此义。故次颂曰

  瓶等在未来　　即非有过现

论曰。色等诸法在未来世。过去现在二世皆空。后遇因缘二相方起。云何汝说无必不生。未来世相在过现无。云何而言有定无灭。若执未来有二世相。此不应理。故次颂曰

  未来过现有　　便是未来无

论曰。若在未来有过现相。应如后位便失未来。一法一时实有多相。互相违反其义不成。即由此理言一一世皆有多相亦不成立

复次若谓色等有未来体。流趣二世说有过现。为破此执。复说颂曰

  未来若已谢　　而有未来体
  生则恒未来　　云何成过现

论曰。若色等法有未来体。是即应无过现二世。以不可说异相法中。有别异相如苦乐等。又若一法流转三时说三世者。便成杂乱。又色等法流转三时。若不异者应无三世。若有异者是则异相。本无而生有已还灭。一切有为应亦如是。便为退失说常有宗。又说颂曰

  法若在未来　　现有未来相
  应即为现在　　如何名未来

论曰。若色等法未来现有。应如现在便失未来。未来既无二世非有。彼为先故一切应无。复次有说。诸法体虽常有。然唯能取等流果用。说名现在。如是一用现在遍有。去来定无。不杂乱故。余用不尔。为破此言。故次颂曰

  去来如现有　　取果用何无

论曰。过去未来色等诸法。既如现在常有体性。为同类因取等流果。此用何故非常有耶。此取果用所待众缘。于一切时亦常有故。如是诸法体用常有。应一切时名现在世。恒名现在义亦不成。要待去来立现在故。又未来果如现在法。已有体故不应复取。又诸果法因缘合时。若无所生则不名果。所生若有此即本无。从缘而生。体亦应尔。是则一切本无而生。有已还灭。应同前过。谓便退失说常有宗。若言其用或有或无。法体常存。故无此失。亦不应理。故次颂曰

  若体恒非无　　何为不常住

论曰。恒有名常。色等诸法体既恒有。云何非常。设许有为体皆常者。便违经说诸行无常。若言诸行体虽恒有。有为相合故是无常。此亦不然。体既常有与彼相合复何所成。岂不能成取自果用。用不离体。体亦应成。若用须成体不成者。用可生灭体应是常。若色等体常用无常者。即虚空等体用应无常。又若体常用无常故。亦令此体成无常者。用虽无常。由体常故。即令此用应亦是常。又此体用应别谛摄。以常无常义不同故。又若色等体不藉缘。而与有为诸相合者。太虚空等体亦应然。彼既不然。此云何尔

复次过去世言。为简别相总诠一切过去义耶。为简总相别诠一类过去义耶。若尔何失。若简别相总诠一切过去义者。其理不成。故次颂曰

  过去若过去　　如何成过去

论曰。若过去法一切体相悉皆过去。是则一切都无所有。如何汝说。过去是有依是体相。汝意说为过去有者亦无有故。又过去者。名为已灭。若过去世亦过去者。是则过去亦应已灭。若过去世亦已灭者。如何汝今执有过去。如彼未来现在已灭。不名未来现在世故。若依正理。应如是说。过去世言。无别实义简去实有差别名相。依止世俗假立名相。总说过去非有别义。若汝意谓。如名饮油。虽不饮油。而假名说。世间共许别目一事。此过去言。亦复如是。简于总相别诠一类过去义者。理亦不然。故次颂曰

  过去不过去　　如何成过去

论曰。若过去法。一切体相非悉过去。如何汝今执为过去。汝说过去色等诸法体无阙故。又过去者。名为已灭。若过去世不过去者。是则过去体非已灭。若过去体非已灭者。如何汝今执为过去。如彼未来及现在世。自体不灭。非过去故。岂不前说如世假名。简于总相别诠一物。过去世法其体虽在取果用无。故名过去。汝说此用即所依体。如何体在而用灭无。若体与用不相随逐。应如别物不成体用。又但用灭。说名过去。唯汝独立。非世共知。云何得引饮油为喻。世间共许不可推征。独所立者应诘问故。若说诸法其体常有。三世不成。唯于现在实有体上。假立名故。非于现在实有体上假立三名。即失现体。是故所执过去不成。如破过去未来亦尔。未来若未来。如何成未来。未来不未来。如何成未来。总别征难。皆同前说

复次未来世法为藉众缘已有生耶。未有生耶。若尔何过。若藉众缘已有生者。其理不成。故次颂曰

  未来若有生　　如何非现在

论曰。若未来法已从缘生。及有体性应名现在。有性及生是现在相。非离现在而可了知。言虽方便令成现在。而意正为破有未来。又显未来非现在故。应如过去决定无生。若言未来未有生者。理亦不成。故次颂曰

  未来若无生　　如何非常住

论曰。若未来法未从缘生而有体性。以无生故。如虚空等体应常住。此亦方便令成常住。而意正为破有未来。如是征难。过去未来。体若实有无灭无生。应如空等失无常性。便违经说去来无常。如说过去未来色等尚是无常。何况现在。是故过去未来诸法。并非实有。现在无为所不摄故。如龟毛等不可说言世所摄故。应如现在体是实有。现在非唯是实有故。同喻不成。因或不定。或相违故

复次往来论者作如是言。不善我宗。妄说此过。所以者何。我宗中说。诸行四相展转相依。三世往来不相舍离。由生等合故成无常。法性不坏故说恒有。是故恒有不废无常。符顺契经。称当正理。此前已破体既恒有。应如太虚非生等合。又以能生色等诸行。说为生相。如是能生诸行作用。未来未有。要藉因缘和合资助。然后方有。若不然者。因缘和合便成无用。若许生用本无今有有已还无。则一切行同有为故。皆亦应尔。云何而说体虽恒有而是无常。往来论者。为避如是所说过失。复作是言。若色等行与生等合。有此过者。今有为法三世往来。有世坏相应是无常。以灭坏相是无常故。世间共许一切无常灭坏为相。谓有为法。未来世坏入于现在。现在世坏复入过去。若尔颂曰

  若未来无生　　坏故非常者
  过去既无坏　　何不谓无常

论曰。过去世体最居后故。更无余世可令转入。既守自位恒无坏灭。应如空等体非无常。如是便违契经所说。若言过去虽恒有体更无灭坏。而从现在坏已转入。故得有生。生灭二种是无常相。随具不具并表无常。去来各一。现在具二。是故三世皆是无常。此不应理。生无有故。汝宗自执生在未来过去现在都无生用。云何今说过去有生。汝执过现已从缘生。更不藉缘。生如何有。若执过去定有生者。生必归灭。一向记故。如现未故。复应有灭。世间亦许未来诸法可藉缘生。非过现世。又过去世非现未故。应如空等定无有生。是故能相及所相法。应如帝释并恒策迦。一时并入常无常火。以位如体体如位故

复次如说过去未来色等尚是无常。何况现在。汝等虽诵如是经文。而不知义。所以者何。汝执一法。往来三世。体无生灭。云何无常。又汝所执。现在法体即是去来。云何相况。不可一法自为比况。世间不见如是事故。亦不可言体虽无异位差别故。得为比况。所以者何。位若即体。体无异故。位亦无别。位若离体。位可无常。体应常住。又体如位。世所摄故。是有为故。应有差别。又汝所执三世实有不相因待。皆与生等有为相合。前后无异。现在无常。有何胜相。异彼去来。而说过去未来色等尚是无常。何况现在。若言诸法前后位别。三时转变。故是无常。未来居前无生有灭。过去居后无灭有生。现在居中有生有灭。过未各一尚是无常。何况现在。具有二种而非无常。此亦不然。未来无生应如空等。云何有灭。过去有生。应如现在云何无灭。又汝宗说。未来有生。现在有灭。过去无二。云何今者作异说耶。又现在世亦无实体。从前世来转入后世。如何依此建立生灭。既无生灭岂是无常。所以者何。故次颂曰

  现在世无常　　非由过去等
  除斯二所趣　　更无有第三

论曰。现在世法非前世来。不往后世。云何无常。汝说现在。由余世故。转成异相。说为无常。余世谓去来。异相谓生灭。现在不可余世转成。亦复不可转成余世。云何现在建立生灭。颂言非由过去等者。等取未来现在世法不往未来非从过去。汝宗自许。然过去世非现所往。以世别故。譬如未来。其未来世非现所从。以世别故。犹如过去既无余世往来转变。云何现在生灭无常。若说现在从过去来往未来世。亦同此破。故契经说。有为诸法非前际来。不往后际。故破此执。其理决定。顺圣教故。又现在法。若余世来往余世者。应往来时不舍前相。不成余相。世间现见提婆达多余方往来相无异故。如是三世位虽许别。相无异故便成杂乱。由位与相若一若异皆有过失不可免故。汝等所宗往来论者。亦不忍许世相杂乱。是故汝今如此安立。往来生灭。不成救义。如是现在虽许往来。其无常性亦不成立。于往来时相无异故。应似空花非无常性。汝亦不许空花异相有及无常。现在若尔。即违自宗及契经说。若汝复言。三世体相虽无别异。然观诸行粗位差别开发觉慧。故于一法自心分别安立分位。由此自心安立分位有差别故。说此一法以为无常。此亦不然。自心分别所见境界。即是自心但随众缘诸行种熟。自心变作种种分位。自心所变无实体相。何为精勤安立异法。但应信受诸法唯心。又觉慧等诸心心法。非随实有诸法转变。但随串习成熟种子。及心所现众缘势力。变生种种境界差别。故外道等随其自心变生种种诸法性相。若法性相是实有者。岂可如是随心转变。诸有智者。不应许彼所执现在实法有生。以必不从去来二世。更无第三可从生故。灭必随生。生既非有。灭亦定无。以必不往去来二世。更无第三可往彼故。如是以理推捡汝宗。三世无常都不可见。有何现在殊胜无常。而契经言。何况现在。汝立一法经历诸位。虽生等随而无变易。相及所依前后无异。有何改转而说无常。亦不可言随三世位有差别故。说为无常。体既无变。位如何别。位体若异位自无常。体应常住如虚空等。是故三世但世俗有。于中都无一法真实。然于如是世俗法中。现在诸行所有生灭。由与身俱世间现见。是故现在无常义胜。依之假立去来无常。以彼去来无别有体。但依现在曾当假立。故依现在现见无常。假立去来曾当生灭。去来无常依现在故。现在无常胜去来世。欲使有情知去来世。不现见法尚是无常。何况现在。现与身俱。现见生灭而非无常。由是契经。作如是说。现在世法现有无常。过去未来曾当生灭。是故有情于三世事。当观无常应深厌离。为显诸行本无而生先无定体。故复颂曰

  若后生诸行　　先已有定体
  说有定性人　　应非是邪执

论曰。如有外道起邪执言。诸行本来决定相属。转变时分不可改易。不由期愿及以人功。汝等亦应同彼所见。所以者何。由说因果安立差别。本来相属不可回转。未来诸法四事决定。所谓因果所依所缘。如本定相而后生故。若尔不应待因缘生。既因缘生。云何本有。为显未来诸行有体因缘无用。故次颂曰

  若法因缘生　　即非先有体
  先有而生者　　生已复应生

论曰。诸行本有与生相违。如法已生不复生故。无常诸行若无生者。虽遇因缘亦无变易。则应退失无常行性。以无生故。譬如空花。若有生者。如取果用。于生位前应未有体。颂言生已复应生者。以说过门显异法喻。谓有为行非先有性。从缘生故如取果用。诸先有者不从缘生。如已生法。若汝复言。我说诸行虽本有体不待因缘。然取果用本无而有待因缘者。此亦不然。取自果用不离体故。应如其体亦先有性。或诸行体不离用故。应如其用非先有性。汝等所执本有诸行。如顽铁铤都无胜用。因果道理皆不相应。以有定性常无变故。执常有论。有多过失。谓违世间。诽谤世间一切共知因果理故。又违自宗。诽谤一切诸因诸缘生果理故。又违自言。立法本有从缘生故。又违比量。如取果用非常有故。又违现量。现见色等非常有故。由有多过。应舍此见。应知去来非离现在别有实性。世所摄故。如现在世但依现在。心变异相假施设有。现在亦非胜义谛有。从缘生故。如幻事等。又三世行皆相待立。如长短等。何有实性。又一切行皆悉无常。有生有灭。非有非无。若定是无。如兔角等应定不生。若定是有。如所执空应定不灭。若无生灭。如龟毛等。岂是无常。谁有智人。知一切行皆有生灭。而言常有依行立世。世岂是真。现在尚非真。去来何有实。若去来世实非有者。宿住死生通何所见。应知二通见曾当有。既现是无。无无差别。通力所见分限应无。是则异生三乘圣众。知去来世劫数应同。汝执去来皆现是有。亦同此过。故次颂曰

  若见去来有　　如何不见无

论曰。去来亦有无量因果。展转隔绝中间非有。故说为无。又汝亦说过去未来无取果等种种作用。过去未来既有有无二义差别。何故二通唯见其有而不见无。若不见无。诸得通者不应照见过去未来经尔所劫空无有佛。尔所劫中空无物等。是故不应唯见其有。去来现无曾当是有。以现无故不同现在。曾当有故为境差别。若同现无则无远近时差别者。汝执去来俱是现有同在一世。应如现在无有远近时分差别。是则诸通应不能照去来远近时劫差别。过失既同。何得为难。若言去来虽同现有。然由行世时有前后远近差别。故异生等见近非远无无远近。其过不同。此亦不然。故次颂曰

  既现有去来　　应不说为远

论曰。过去未来既同现有。应如现在是近非远。若言去来虽现有体而无用故说为远者。此亦不然。用不离体。过同前说。又此意言。去来色等既同现有。同一世故。应如现在无有前后远近差别。过去未来既无远近。诸得通者皆应无碍。等见一切过去未来。是则如来所知无量。余二乘等所知有量。此等差别一切应无。是故去来虽现非有。而曾当有因果不同展转相续时分决定。由此曾当有为方便。或有久习智见猛利。复由种姓法尔殊胜。极前后际展转相续。如其所欲皆能照知。或有习性与此相违。随其所应但知少分。此显去来非现有性。但得通者。自因缘力胜劣不同。方便作意有差别故。自心变似曾当有法。体相不同。远近有异。依此立有过去未来时劫不同通力胜劣。非谓实有过去未来缘之起通照知远近。为破未来法非法等先有体。性故说颂曰

  未作法若有　　修戒等唐捐

论曰。若在未来未作福行。先已有者。现在加行修施戒等。则为唐捐。又若未来先有法者。非法亦有不可断坏。为舍恶戒勤修加行。徒自苦身都无所益。如是执有未来论者。诸有所为皆空无果。是故应舍如是恶见。信受未来非先有性

复次执未来有小乘人言。诸行未来虽先有性。然犹未有取果功能。为欲引起取果功能。勤修加行不空无果。数论外道亦作是言。于自性中虽有种种诸法自体。而相犹隐。为欲令彼法相显现。勤修加行不空无果。即彼异论复作是言。于自性中虽有种种诸法功能。而未有体。为成其体勤修加行不空无果。为破此三。故说颂曰

  若少有所为　　界则先非有

论曰。若先无用加行令生。先未有显方便令有。先未有体令有体者。则不应言果先是有。用显及体由加行成。可名为果。体隐功能本来有故。不应名果。又用显体与体隐能不相离故。体隐功能应同用等。本无今有。是则一切皆从缘生。汝等不应说果先有。或用显体应同体等本来是有。则应一切不从缘生。皆不名果。汝等执有未来论者。便为谤果常有非果。不相离故。又若汝等矫设方便。作如是言。法虽先有。然由因故少起异相。说名果者。但此异相由因所成。可名为果。体既本有。不应名果。然此异相本无今有。如何汝等言果先有。若汝复言。相虽今起。然不离体。体先有故。亦说果相是先有者。相体既一。俱应本有。因则无用。便同谤因外道过失

复次若执果性一切时有。便违经说诸行无常。所以者何。故次颂曰

  诸行既无常　　果则非恒有
  若有初有后　　世共许非常

论曰。性非恒有。故名无常。一切无常定有生灭。生名为初。灭名为后。有初有后。是无常义。若执果性一切时有。无初无后岂是无常。彼经复言。有生灭者。以世共和粗无常相。示现三世细无常理。世间现见从缘所生。内外诸行初生后灭。不知念念生灭无常。故以初后生灭为因。用灯光等为同法喻。显彼念念皆有生灭。本无而有。有已还无。非一切时恒有果性。恒有论者。过去未来诸行常有。无生无灭。现在诸行生灭亦无。便违自经说无常义。若言诸行体虽恒有而无常相恒共相应名无常者。此亦不然。前已略非。后当广破。此颂义中。正破异部。兼破数论二种异说。谓隐体能虽复恒有。而显相体或有或无。就隐体能说果先有。据显相体说为无常。果若无常则非先有。以诸无常定有初后。初生后灭是无常义。隐体功能既无初后。无生无灭岂是无常。即以此义亦应非果。不相离救。还同前破。又彼说言。声等乐等虽有种种分位差别。然其因果皆不相离。同依一体而建立故。此意若说声等自性前后无异言因与果不相离者。即无所诤。以许声等前念为因能生后念等流果故。若说声等因果位一。是则因果应无差别。或言声等因位有果。亦无违诤。以许一时望后望前为因果故。若言声等。因果位别而体一者。是则相违。体一时异。不应理故。时分不同。体必异故。时虽有别体无异者。是则不可说为无常。又一体法于一时中决定无有隐显二义。既许隐显时有差别。是则分明许所依体。亦有差别。是故不可说言声等分位差别建立因果。其体无异

复次为欲示现说常有论有违宗过。故复颂曰

  应非勤解脱　　解脱无去来

论曰。若能永断诸烦恼缚。无倒圣见未来现有。应如现在能断烦恼能证涅槃。是则一切不由功用。从本已来自然解脱。便违自宗要勤方便修生圣道方得解脱。若许修道得解脱者。则应无有过去未来。有烦恼缚及所招苦而得解脱不应正理。若解脱者。无烦恼苦。则违自宗。说去来有。又说颂曰

  或许有去来　　贪应离贪者

论曰。前理所逼定无去来。或彼守愚确执为有。假纵其执。故置或言得解脱时。去来二世。贪等若有。在解脱位。无贪等者。应离所依而有贪等。世间未见无所煮物而有煮等。此亦应尔。岂不诸行如是生时实无作用及作用者。但假安立二种差别。故契经言。唯有诸法。唯有因果。都无作用。理实如是。然解脱时贪等永灭。依贪等上假立作用。亦不可得无用无者。如空花等而言是有。理不得成。若解脱时犹有贪等。如未解脱。应名恶人。应造诸恶应不解脱。若言尔时虽有贪等而不成就故名解脱。既是贪等烦恼所摄。应如前位非不成就。又此去来贪等若有。应如现在能有作用。若尔脱者应造诸恶。应名恶人。又此去来贪等烦恼。若有作用应名现在。若无作用应似空花。云何而言有体无用。是故智者不应信受过去未来现有实体

复次未生已有。违世共知。所以者何故次颂曰

  若执果先有　　造宫舍严具
  柱等则唐捐

论曰。若宫舍等色等诸行。于未生位已有体者。世间现见为造彼物。勤加功力则为虚弃。诸有或言先虽有体而未有用。先有隐体未有显相。先虽有能而未有体。为令有用及显体故。勤加功力亦不唐捐。此亦不然。用显相体与体隐能不相离故。皆应先有。已如前说。如是邪执世间相违。又一切法皆先有者。为脱众苦设教度生。如是等事皆不成立。此则亦与自宗相违

复次因说执果先有者过。先无果执其过易了。为略破之。故复颂曰

  果先无亦尔

论曰。如是所执亦违世间。自宗所许果先定无。世间自宗皆不可故。有作是言。此颂义意总破一切因果别执。若因与果别有体相。云何异法能生异法。未见香味别体相生。此说不然。若体相异因果理隔。或相违损可不相生。若有诸行体相虽别。然相随顺现为因果。如何难言。因果若异。如香味别。应不相生。世间自宗皆许父子业果体异而得相生。是故因果非定不异。如是说者。此正为破定说因中无果者论。食米齐者。作如是言。种等不能亲生芽等。但由种等引彼芽等。同类极微令其聚集。如如所引同类极微。如是如是合生粗果。此义不然。彼诸极微与粗麦等。种类体相皆有差别。云何同类。又是常故。应无胜用。亦不应令常法有用。云何而言由种等力引彼芽等同类极微。令其和合生粗芽等。又彼外道计离色等别有实果衣瓶等物。此类先无。由何因造。为求此果。勤加功力造作缕等。皆应无用。以彼不许如是缕等。能作亲因。造同类果。若彼不许从异类因生异类果。是则粗果。定应不生。先无体故。又实极微应不能造粗同类果。汝计常故。如虚空等。所依实果既无所有。能依色等行等德业。皆不得成。是则都无诸根境界。便为损坏一切所立。是故不应定执异类因中无果。世间亦见从异类因能生种种异类果故。因果道理最为微细。非定一异非先有无。若于其中执一执异先有先无。皆失正理。所以者何。因果若一。因应如果。是果非因。果应如因。是因非果。如是因果便成杂乱。又若因果定是一者。即无能生所生差别。无能生故不名为因。因既是无。果亦非有。无所生故不名为果。果既是无。因亦非有。因果二种相待立故。因果若无。说谁为一。故知因果非定是一。因果若异。应从自因生于他果。与彼异故。犹如自果。亦应自果从他因生。与彼异故。犹如自因。是则一因应生一切果。亦应一果从一切因生。又应从自因不生自果。与彼异故。犹如他果。亦应自果不从自因生。与彼异故。犹如他因。则一切因应不生果。应一切果不从因生。现见自因唯生自果不生他果。现见自果从自因生非他因生。故知因果亦非定异。若于因中先定有果。果则如因。应不更生。若于因中先定无果。则如非果。应不可生。现见从因更可生果。故知其果非先有无。如是因果非定一异非先有无其理决定。傍论已了。应复正论

复次数论外道作如是言。果实不生其体本有。由转变故。立有时分因果差别。为破彼执。故复颂曰

  诸法有转变　　慧者未曾知
  唯除无智人　　妄分别为有

论曰。诸妙慧者。能知一切障外极远深细法义。未曾知有如是诸法转变时分因果差别。唯除外道。如阴暗夜有眩医人妄有所见。自不能了而为他说言一切法实无生灭。但有时分因果转变。所谓声等。或复乐等。不舍自体。转成余相。时分不同名为转变。于转变时以时分相。有差别故。说有生灭。汝今计何以为转变。为时体耶。为时相耶。且不应说时体转变。以转变时汝先自执不舍自体如前位故。亦不应言时相转变。汝执时相有生灭故。前后各别。何名转变。又若时体不可转变。但可时相有转变者。应离时体别有时相。若言体相非定一异。更互为依相从而说。相由体故。前后非异。体由相故前后非一。体相相资。俱名转变。若尔则应体由相故有生有灭。相由体故无转无变。体有生灭则同幻事。非实非常。相无转变则似空花。非因非果。便失自宗。亦不应言体相性一。实无因果。由义异故。得有因果。性若是一。义云何异。一异不同应有别物。既有因果分位不同。先后各异应非转变。电光灯焰无转变故。若言因果分位差别转变有异。未必先后一体一时有唯量等种种分位。转变异故。此有虚言而无实义。一法一时有生住灭。更互相违成大过故。世间不见一法一时有生住灭。唯见异法异时有三。又不应言时体常有。虽无生灭而有转变。勿汝所执常住思我。虽无生灭亦有转变。设许思我亦有转变。应如乐等非思我性。又许时体有转变者。时体即是乐等自性。如是自性。举体应变。若尔则应失自宗义。最胜定无全体转变。若全转变。即是无常。又汝时分乐等三法。和合共成。应如林等。体非实有。因果亦尔。若言即用乐等为性故是实有。此亦不然。时等唯一。乐等有三。一三不同。如何相即。若必相即。乐等如时。应唯有一。时如乐等。应有其三。又如乐等遍一切时。此一一时应遍一切。如是时分应成杂乱。时既一一不遍一切。乐等亦应不遍一切。如是乐等与无量时为自性故。应成无量又如乐等隐时亦有此一一时。应亦如是则应无有隐显差别。以一切时有一切故。由此不应决定相即。既不相即。应计为假。或应不许乐等为性。如推时分。因果亦然。又诸因果。或劣或胜。或净或秽。云何同以一乐苦痴三法为性。若必尔者。汝等外道无始时来无所不作。同以乐等为自性故。汝等今者虽得人身。而应即是狗等下类。所食甘馔应即粪秽。谁有智者。无缘执此外道邪宗而自毁辱。是故汝说果实不生其体本有。由转变故立有时分因果差别。正理相违。不任推究。哀哉外道。宿习痴狂。宝爱邪宗憎背正法。盲无慧目不了是非。随顺迷徒种种妄执。如是已说时体是常相有转变。不应正理。诸有智人审观应舍

大乘广百论释论卷第四大乘广百论释论卷第五

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破时品第三之余

复次有诸异部。于无常法说有刹那暂时住体。即依住体立有实时。为破彼言。故说颂曰

  无常何有住　　住无有何体

论曰。自相经停。故名为住。有为诸法。无常所迁。不能暂停。如何有住。既无住体。依何立时。所以者何。言无常者。或即法灭。或法灭因。一切有为无常所逼暂生即灭何容有住。住位住依无常随逼。应如后位不得少留。若谓无常虽居住位。尔时住力能制无常。扶己所依令其暂住。此亦非理。故次颂曰

  初若有住者　　后应无变衰

论曰。生灭相续。不舍自类。后异相起名曰变衰。后位住相与前住体既无差别。何有变衰。亦不应言由后法起令前住相而有变衰。住体如前相无变故。岂非后起前住变耶。云何余生余法名变。现见余生余亦名变。如酪既生说乳为变。粗虽似变。细则不然。所以者何。世间乳酪同类相续。别相难知。不悟其中有细生灭。谓前乳变由后酪生。微细理中即前住体变由后起。其义难知

复次要自审察知有住体。方可为他说有住相。然无方便可审住体。知其定有能住于法。所以者何。故次颂曰

  譬如无一识　　能了于二义
  如是无一义　　二识所能知

论曰。所识诸境要由能识。前观后察方知是有。若有一身同类二识。于一现境前观后察。审知境相不异于前。尔乃可言现法有住。即无一身同类二识。于一现境前观后察。汝等云何能知现法刹那有住依此立时。汝不可言。前念意识观未来法。后念意识察现在法。知有住体。以未来世法未有故。亦不可言。前念意识观现在法。后念意识察过去法。知有住体。以过去世法已灭故。纵许去来法是有者。时移世易不可名住。又不可言。色等诸法于现在世住经多时。心等诸法无常迅速。故二念心同缘现在。前观后察知其有住。既同有为如何不等。色等诸法非久时住。是有为故。犹如心等。有余执色有住非心。此亦应以心为喻破。一有情身同类二识。定不共缘现在一法。一身同类前后识故。如缘前后青黄二心。亦不可说。五识所观意识能审知其有住。汝等不许二识俱生。意识生时境已灭故。设许一身多识并起。各缘别境非能审知。虽许意识知五识境。然各自变同现量摄。俱受新境非重审知。由是故说。无有一义二识能知。复次亦无一识审知二义。皆实有体。所以者何。若欲作意审知前有后境未生。审知后有前境已灭。尚无有能审一实有。况能知二现在二境。虽俱可了。皆新受故。非重审知缘余境识。不能审知余境实有。带余相故。犹如各别缘二境心。又审察心不能审察外境实有。带余相故。如新了受现在境心。又数论者作如是说。若立慧体念念各异知诸法者。是则不应。先求后证。先受后忆。先疑后决。所以者何。不见天授先求受疑后时祠授能证忆决。由是当知。唯有一慧常能照了一切境界。故立量言。知青等慧决定不离。知黄等慧是慧体故。如黄等慧。是故一慧知一切义。此亦不然。常法转变皆先已破。不应重执。又汝云何知此一慧其体是常知一切义。非不审察所知慧相。可言此慧知一切境。非即此慧能自审知。色等法中曾不见故。此慧必有别慧能知。是所知故。犹如色等。又青等慧其性各别。所知异故。如自他慧。此中意明。无有一慧能重审知二境实有。不言一慧不知多法。勿一念心不了多境。又明慧体不能自审。不言慧体不能自照。勿心心法不能自证。若尔不应后时自忆。若言照境是用非体。体非照故。不随境别照用随缘。乃有无量有多用故。无如上失。此亦不然。体若非照。应如色等。不名为慧。若言照用。不离体故。无斯过者。此亦不然。用不离体。照应成一。不离体故。犹如慧体。体不离用。慧应成多。不离用故。犹如照用。用随体一。违前比量。体随用多。违自所立。若用随体无差别者。总缘别缘希求证得。领受忆念犹豫决定。如是等用差别应无。若体随用有差别者。汝所立慧应念念别。亦应无有先求后证。先受后忆。先疑后决。是则汝言翻成自害。又汝若言慧体虽一。然用随缘变成多种。故无失者。此亦不然。慧用随缘变成多故。应如乐等其性非一。世间不见有色等物体常是一用变成多。世俗事中假立体用。容可施设体一用多。胜义理中无如是义。如何一物实有一多。又汝所言慧体念念各别异故。如异身慧。应无先求后证等者。因义不成。自宗不许。前后两慧体有异故。又许照用虽念念别而有先求后证等事。故所立因有不定失。又乐等异别慧所缘。彼此俱。许即为同喻。由此比知缘别境识。别慧缘故。体应有异。谓青等识其体各异。别慧缘故。犹如乐等。岂不乐等于转变时合成色等其相无异

尔时复为一慧所缘。所立同喻。便阙能立。此非真过。我说别慧所缘为因证体有异。不言唯为别慧所缘。斯有何失。然彼乐等其性各异。必应许有别慧所缘。是故决定无有一慧。其体是常知一切义。故无一识审知二义。皆实有体。其理成立。为释颂文起斯傍诤。今应且止辨正所论

复次今应诘问有住论者。如是住体为待余住能住于法。为不尔耶。若尔何过。若待余住能住法者。应如所住不名能住。若不待余能住法者。所住亦尔。应不待余为显此义。故次颂曰

  时若有余住　　住则不成时

论曰。自性不能助成自性。故无同类同时相待。诸有为法必待异类相助而成。如慧与心。地与水等。如是若执住别有住。此住则应失于住体。待余住故。如所住法。颂中时者。是住别名。此正应言住有余住。住不成住成文故尔。由此生等亦无同类。故所立量无不定失。又次颂曰

  时若余住无　　后灭应非有

论曰。时者谓住。余住若无。如所住法不能自住。既不自住岂能住他。如是则应不名能住。能住无故。诸有为法何能暂住经一刹那。初住既为无。后灭如何有。初住后灭相待立故。又若此住不待余住。自能住者法亦应尔。自力能住不待余住。住既是无。灭亦非有。云何汝执初住后灭。又住灭等互为助伴能起作用。住相既空。亦无灭等。是则诸法应无后灭。无后灭者何谓无常

复次诸有为法与无常相为一为异。若尔何失。若言是异。应非无常。若言是一。应无有住。为显此义。故复颂曰

  法与无常异　　法则非无常

论曰。色等诸法名无常者。无常相合说为无常。色受想等其相各别。自性有异。故非无常。若尔色等异无常故。应如空等。体非无常。若言色等虽有差别。而用无常以为共相。如是共相若离色等。色等异彼。还同前过。若言色等与彼共相体不相离。是则色等无异性故。应失自相。若言诸法各有二相。谓自及共不相舍离。如是二种一通一别。相不同故。应非一体。如无常相。非即色等。如是色等亦非无常。相既有异。虽共和合而体不同。犹如色味。若谓色等实非无常。无常合故假说无常。如执杖人说名为杖。故无色等非无常过。若尔修习无常观者。于其色等非无常法。自心增益立为无常。此无常观应成颠倒。若尔不应能断烦恼。是故无常应即色等。若即色等复失自相。如是诸法自相共相。世俗道中相待假立。不可定执为一为异。于胜义理都不可论。已说无常与法异过。为显一过。复说颂曰

  法与无常一　　法应非有住

论曰。无常与住。性相相违。云何一法具有二种。如苦与乐。性相相违。尚不相应。况同一体。若色等法与无常一。是则决定无暂住义。如何依住立有实时

复次有作是说。如上所言。诸法无常何有住者。此不应理。所以者何。诸法自性虽复同时。然其作用前后差别。如四大种为共有因。体必同时。用有先后。如是三相体虽俱有。而彼作用时分不同。先生相用。次住后灭。住相用时。虽有无常。而无胜用。住有用故。能住所依住相用讫无常得。次复起胜用灭所依法。此亦不然。生住灭相自性作用。皆互相违。如苦乐等。必不并起。云何体俱用有先后。自性相违而许并起。何不许彼作用同时。用既不俱。体亦应尔四大种喻。理未必然。用不同时。体亦应尔。又住无常体若俱有。不应作用先后不同。若谓住强无常劣故。住先起用无常后起。此亦不然。故次颂曰

  无常初既劣　　住力定应强
  此二复何缘　　后见成颠倒

论曰。体既同时。用有先后。故不可说二相力齐。定应住胜无常是劣。若尔何缘后时复见。无常力胜摧伏住力。灭坏所依及住相等。后时住力应制无常。以力强故犹如初位。于此中间无别方便可令住相力用损减。及令无常力用增盛。若言住相作用已讫。故于此时其力损减。彼无常相先未作用故于此时其力增盛。此亦不然。理相违故。住与无常先后体一。何缘力用衰盛不同。住相尔时体无亏减。何缘力用炊有衰损。又住相用齐何当止。若言住用唯一刹那。何缘此住极为知定。若住相力唯有尔所。谓能住法经一刹那。若尔无常今复何用。住力既尽所住诸法自然不住。何用灭为。如是住相初后体同。所作事业亦无有异。有时起用有时不起。此义难了。智者应思。又于后时无常力胜能灭住相。彼此同知。由是亦应信无常力前位已胜能摧住相。若尔住相常应无用。何执如是无用住为。是故智者应信无住。既无有住。时依何立。又执无常初劣后胜。并执住相初胜后劣。皆不应理。故复颂曰

  若遍诸法体　　无常力初劣
  应都无有住　　或一切皆常

论曰。若无常相初时力劣。不能灭法。法自然住。何缘执此无用住耶。是则住相应本无有。以无用故。犹如兔角。若言住相初时力胜能伏无常。则一切时皆应得胜。体无异故。若尔有为常应不灭便违经说诸行无常

复次今应诘问贪住相人。诸有为法为无常相决定俱生。为作用时无常始起。初且不然。故次颂曰

  无常若恒有　　住相应常无

论曰。有为诸法无常所迁不能暂停。先已具辨。此无常相损害有为。如极暴恶怨家债主。常随迁逼不令暂住。是故若说一切有为恒有无常。则常无住。后亦不然。故复颂曰

  或彼法先常　　后乃非常住

论曰。若刹那终无常始起。此无常相前位应无。尔时彼法应成常住。无无常故。如虚空等。非常住名。如无常体。别有少法。但由远离无常相故。立常住名。由此色等失有为性。若言后时必当灭故无斯过者。此亦不然。无为法中曾未见故。如虚空等初离无常。后决定无可灭坏义。有为诸法应亦如是。如何后时必当坏灭。又初色等与后无异。应如后位无常所随

复次为摄上义。故复颂曰

  若法无常俱　　而言有住者
  无常相应妄　　或住相应虚

论曰。若有为法无常相俱而言有为有住相者。如是二相性相相违。是则定应一虚一实。所以者何。若言住相有胜力用住持有为令暂不灭。住力既尽。诸有为法自然灭坏。若尔灭相复何所为。或后住相应如前位。有胜力用伏彼无常令其无力灭所依法。若尔何缘执无常相。若言无常虽有力用能灭诸法。而法初时势力微劣未为强敌。故无常相权时放舍令暂得住。若尔住相复何所为。或前无常应如后位。灭所依法令不暂停。若尔何缘执有住相

复次有作是言。前说无住有何体者。此说不然。住体虽无然有不住。诸法自体不可拨无。应作是言。诸行生灭展转相续。无间灭时有刹那顷无住法体。所以者何。无常力用迁流不住。立之为灭。法体无者。灭何所依。若说法外有无常相为法灭因。亦同此难。我亦不拨诸法皆无。但言汝等所执真实。时所依体皆不可得。所以者何。执有住体与时为依。前已广破执有生灭与时为依。亦不应理。所以者何。本无今有假说名生。本有今无假说名灭。如是生灭既非实有。云何依此执有实时。复云何知生灭是假。本无今有名生。本有今无名灭。生之与灭皆二合成。如舍如林。岂名真实。又生与灭二分所成。半有半无。如何定有。又本无分不名为生。体非有故。如龟毛等。其今有分亦不名生。体非无故。如涅槃等。又本有分不名为灭。体非无故。如虚空等。其今无分。亦不名灭。体非有故。如兔角等。一一别分既非生灭。二种和合岂是生灭。假名诸法。是事可然。真实法中无如是义。又于生灭各二分中。本无未来今无过去。去来二际已灭未生。其体既无非实生灭。今有本有俱现在摄。岂一刹那生灭并有。不可现在有二刹那。初名为生。后名为灭。时既有别。世云何同。若必尔者。世应杂乱。生时灭未有。应名未来。灭时生已无。应名过去。又灭灭法令无入过去灭。在现在说名有。生既生法令有入现在生。应未来说名无。又本无时名为未来。于今有时名为现在。于本有时名为现在。其今无时名为过去。云何二世合成一时。而言此时决定实有。如是推征生灭非实。不应依此立有实时。若有为法无实生灭。如何上言无常所迁。暂生即灭何容有住。无常既无何能迁法。我上所言。皆为破执。随他意语非自意。然彼执无常复执有住。为破彼住且许无常。今住既无。无常亦破。不应谓我定许无常。我如良医应病与药。诸有所说皆随所宜。故所发言不应定执。若色等法实有住者。容可审知。是有为性既无有住。复非无为。是故不应执为实有。既色等法非定实有。云何汝等依此立时。世俗可然。非为胜义

复次有作是说。若离有为别立住体。能住于法既言有过。即有为法。前前刹那能生后后。名住何失。此亦不然。最后刹那诸有为法不生后果。应无住相。既无住相。应名无为。若尔已前诸有为法。与此同类应非有为。若有为法后后刹那续前前故名住相者。此亦不然。后念生时若与前念为住相者。生相应无。若尔有为应无四相。若后生时。望前为住。当位名生二相俱有。是即说生以为住相。名虽有异用应无别。如是四相既无别用。何须立此无用相为。最后刹那既无后念。续此而生。应无住相。是故即法住相亦无

复次有作是言。令有为法于将灭时能生后果。是住相用由此用故。诸有为法虽不暂停而有住相。此亦不然。最后刹那不生后果。应无住相。过同前说。若谓尔时亦能生后。余缘阙故后果不生。既彼后果毕竟不生。云何知前有能生用。若见前时同类有用。比知最后亦有用者。此亦不然。现见异故。前时诸行有后果生。最后诸行后果不续。得果既别。为因岂同。若同为因。应俱有果若尔最后。刹那不成。又汝不应前后诸行。以同类故更相比决。谓皆为因。勿后无果。例前亦尔。或前有果例后亦然。又前诸行亦非一向。于将灭时能生后果。入灭定等最后念心。不能生后等流果故。亦不应言望后。亦行为同类因。种类别故。勿阿罗汉入无余心缘生他识。或无识身名同类因取等流果。若尔应无永灭度义。若言后心缘生他识。或无识身。非因缘故。无有过者。此亦不然。入灭定等最后念心。望后色行亦非因缘。云何生彼名住相力。若言色行望彼后心以同性故。是等流果后心与彼为同类因。是因缘故名住力者。入无余心望他身识及无识身。汝宗亦许有同性义。云何非彼同类因耶。夫因缘者。自类熏习生果功能非余法也。是故汝立住相不成。非一切法生同类故。又因缘者。世俗假立。如何依彼立实住相。又汝五因取果与果皆许因缘。云何但说一同类因取果一用为住相力。又未来世无实有体。云何望彼为同类因。过去未来非现在世及无为摄。同兔角等。非实有性。是故因时果未有故。如望兔角非彼实因。果现前时因已无故。如从龟毛非彼实果。因果尚非真实有体。依立住相岂得实有。既无住相。时何所依。是故定无实有时体

复次云何定知诸法有体而依法体执有实时。若由现见知法有体。此亦不然。见非实故。所以者何。故次颂曰

  无所见见无　　回心缘妄境
  是故唯虚假　　有忆念名生

论曰。一切所见皆识所为。离识无有一法是实。谓无始来数习诸见。随所习见。随所遇缘。随自种子成熟差别。变似种种法相而生。犹如梦中所见事等。皆虚妄现都无一实。一切皆是心识所为。云何定知诸法有体。外境若无内识应有。犹如梦等无境有心。云何复起如是妄执。境既是无识。如何有识体。定有亦不可知自体。不能知自体故。汝等不许识并生故。设复许有诸识并生。亦无展转亲相缘义。云何能知识体定有。若尔大乘应如梦哑。拨一切法皆悉是虚。不能辨说一切世间出世间法自性差别。或复不如诸梦哑者。彼能分别种种境界。但阙语缘不能辨说。今此不能分别诸法。亦不能说。是大苦哉。我等不能随善如是大乘所立虚假法义。以一切法皆可现见不可拨无现见法故。奇哉可愍。薄福愚人不能信解大乘法义。若有能见可见所见。能见既无谁见所见。以诸能见不能自审。知自有体亦不审他。于审察时能见所见。皆无所有不可审察。是故不应执现见法。决定有体。以回心时诸所缘境皆虚假故。所以者何。起忆念时实无见等种种境界。但随因缘自心变似。见等种种境相而生。以所忆念非真实故。唯有虚假忆念名生。如所曾更诸法体相。回心追忆。故名为念。当忆念时曾所更境皆无有故。能念亦无。而名念者。随顺串习颠倒诸见。假名施设。由此念故。世间有情妄起种种分别诤论。竞执诸法自性差别。没恶见泥不能自出。若无所见亦无所闻。是则一切都无所有。云何今时编石为筏。诸有行愿复何所为。随顺世俗所见所闻。强假施设。不应为难。胜义理中二俱不许。一切分别戏论绝故。非诸如来有法可说。亦无有法少有所得。故契经言。如来昔在燃灯佛所。无有少法可说可取。若尔精进则为唐捐。应弃如来甘露圣教。为欲方便除倒见执。施设二事。俱无有过。既言一切所见能见皆无所有。云何无过。虽无真实所见能见。而诸愚夫颠倒谓有。为欲除彼增上慢见。随顺世间施设无过。若能随此圣教修行。随俗说为真佛弟子。世俗愚夫随自心变颠倒境相而起见心。佛非其境于彼无用。云何说为如来弟子。由佛愿行为增上缘。起彼见心。故亦无失。谓佛世尊在昔因位。为欲利乐一切有情。发起无边功用愿行。由此证得无分别慧。因此慧力发起无量利乐有情作用无尽。诸有情类用佛愿行。所得妙慧为增上缘。自心变现能顺世间。最胜生道及顺出世。决定胜道诸佛形相。及所说法。缘自心相起增上慢。谓我见佛闻说法音。信顺修行世出世行。是故说为如来弟子。若尔应从颠倒愿行。生无分别无倒见慧。以本愿行见有利乐一切有情而生起故。设许如是有何相违。因果异类岂不相违。又一一因应生一切。随因势用生异类果。彼此俱许有何相违。如从有漏发生无漏。非根生根。非识生识。不可见此能生异类。即令一一皆生一切。同见同知。不应为难。彼此俱有非爱过故。又世俗法力用难思。不可一一难令齐等。现见世间末达那果。及余能发风病等物。若有如量如时服者。除风病等为无病因。羯罗那等则不如是。是故异类虽得相生。而非一因生一切果。又本愿行亦非颠倒。以能了知诸法实义。于一切法无所执着。能为无上妙果生因。虽复发心起诸胜行。求无上果利乐有情。然似幻师起诸幻事。都无所执。故非颠倒。复次如前应问。云何定知诸法有体而依法体执有实时。若彼答言由随法体起现见心。后重审察能自了知。我昔曾更如是境界。若无法体起现见心。后时不应如是审察。是故定知诸法有体。复应问彼。重审察时为有法体可现见不。彼言。不也。所以者何。生已即灭。彼于今时无所见见。谓无所见而生于见。又应问彼。重审察时前现见心为可回返忆我昔见如是境耶。彼言。不也。所以者何。过去诸法不可回返。故无回心。谓无有能回过去心来至现在若尔今时由谁审察。能决定知诸法有体。彼言由念。所以者何。要依现见后方有念。非无法体可有现见。是故定知诸法有体。此但有言而无实义。所以者何。一切忆念但缘有名无实境起。由此忆念唯缘妄境。是故唯有世俗虚假忆念名生。谓于非有虚妄境界。如对目前分明记忆。故名忆念。实无有体颠倒相现。故名非有。虚妄境界。是故不应随虚妄见计度诸法谓实有体

复次汝上所言。要依现见后方有念。非无法体有现见者。此亦不然。前已略说。见非实故。所见能见皆无所有。是故不可以其现见证法有体。前虽略说。而未广辩。云何定知诸法非有。诸所执有略有二种。一者无为。二者有为。无为是常。先已广破。谓若有用能生诸法。应如有为非无为体。若无有用不能生法。应如兔角。其体是无。有为有二。谓过未有。及现在有。过去未来如前已辩。谓曾当有非现有体。若现有体应名现在。若言无用。故非现在。既现有体。云何无用。若言其用必藉缘故。非恒有者。用可无常。体不藉缘应是常住。若言此体能起于用。用非常故。体亦无常。是则此体能起于用。用暂有故。体非恒有。又若有为体恒是有而能起用。故非无为。虚空等体亦许恒有。何不起用说名有为。无为恒有而不起用。有为起用如何恒有。又过去体定非现有。名已灭故。过去摄故。如过去用。未来世体亦非现有。名未生故。未来摄故。如未来用。若言去来体虽是有不名现有非现在故。所立比量便立已成。此理不然。汝立三世体非本无今有。亦非本有今无。一切时有。如所执空故名现有。非现世摄名为现有。我今遮破恒现前有。是故比量非立已成。若汝不许去来二世其体现有。则应如用先后是无。体非常有。是则一切有为之法。若体若用皆待众缘。本无今有本有今无。便失汝宗。法体常有。若言去来体是现有。世所摄故。犹如现在。理亦不成。汝许去来用非现有。是世所摄。则所立量有不定失。若言去来体是实有。世所摄故。如现在者。理亦不然。若依胜义我宗现在。亦非实有则无同喻。若依世俗用瓶盆等。是世所摄而非实有。则所立量有不定过。若言去来体是实有。余非实有。所不摄故。如共所知实有法者。此亦不然。若依胜义无同法喻。若依世俗便立已成。我宗亦许去来曾当是实有故。又如共知世俗实法。余非实有。所不摄故。应非去来体现实有。如是等类有多相违。又去来体非现实有。余实有法。所不摄故。如共所知非实有法。如是等类比量无边。是故去来非现有体。但依现在假名建立。谓现在心缘曾当法。似彼相现假说去来。实非过未。由此去来共所许法。非离现在别有实体。自宗所许世所摄故。犹如现在诸立过去。未来有体如现在者。皆同数论外道所计自性体常用有起谢。彼既有过。此亦应然。是故自称佛弟子者。应舍此执。现在诸法虽世俗有而非胜义。所以者何。若胜义有。应不藉缘。既待缘生犹如幻事。如何可说是真实有。又现在法有生有灭。犹如幻化。云何实有。若现在法是实有者。应如所执虚空等性。无生无灭。岂名现在。又现在法已生未灭。二分合成。已生待未来。未灭待过去。相待立故。非实有体。如粗细等。揽非实法和合而成。如树林等。云何实有。又于现在一一法上有多种性。如何实有。谓一一法皆有蕴性处性界性有漏无漏世出世间色心等性有无量种。于诸性中谁实谁假。不可说言。如是等性是义差别同依一体。除此诸性更有何体。亦不可言。一性是体余性是义。同名为性无有差别。云何一体。余皆是义。亦不可言。如是等性是名差别。其义是一。若尔不应生别行解。亦不可言。差别行解但缘其名。苦无常等种种行解。皆缘义故。是故一一有为法体皆用无量性相合成。如舍林等非真实有。但依世俗说有实体。若言诸性皆是共相。以可说故。如军林等。是假非实。比量所得。自相是实现量所得。既言是实。其相如何。现量所得云何可说。若不可说。如何言实。若可言实。即应可说。云何自相是不可说。若言自相假说为实。非是真实。是则一切若假若实。皆依世俗假想施设云何汝等定执诸法皆有实体。若一切法皆非实有。如何现前分明可见。镜像水月健达缚城。梦境幻事第二月等。分明可见。岂实有耶。世间所见皆无有实。云何以见证法是真。觉时所见一切非真。是识所缘如梦所见。梦心所见决定非真。乱识所缘如第二月。如是虽无真实法体。而能为境。生现见心。因斯展转发生忆念。前后俱缘非真有境。是故不可以生忆念证法是真。法既非真。时如何实。若缘妄境生于倒见。境可是虚。见应是实。境既是虚。见云何实。如在梦中。谓眼等识缘色等境。觉时知彼二事俱无。妄境倒心亦复如是。愚夫谓有。圣者知无。有倒心境二种皆虚。无倒境心俱应是实。世俗可尔。胜义不然。以胜义中心言绝故。若于胜义心言绝者。云何数说。心境是虚。为破实执。故且言虚。实执若除。虚亦不有。若实若虚。皆为遣执。依世俗说。非就胜义。胜义谛言亦是假立。为翻世俗非有定诠。现见心境可言是无。忆念境心云何非有。现见尚无。忆念岂有。若一切法都非实有。如何世间现造善恶。若无善恶。苦乐亦无。是则拨无一切因果。若拨因果则为邪见。岂不怖此邪见罪耶。奇哉世间愚痴难悟。唯知怖罪不识罪因。一切善恶苦乐因果。并世俗有。胜义中无。我依胜义言不可得。不拨世俗何成邪见。于世俗中执胜义有。不称正理。是为邪见。今于此中为破时执。略说诸法俗有真无。其义虚实研究是非。于后品中当广分别。已略成立远离二边中道实义。诸有聪慧乐胜义人当勤修学。谓常无常二边邪执。如其次第。略破应知

大乘广百论释论卷第五大乘广百论释论卷第六

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破见品第四

复次若如所言诸法性相世俗事有胜义理空。如来于中智见无碍。言音辩了巧悟他心。如何世间犹为种种妄见所魅诤论纷纭。由能闻者有过失故。何者名为闻者过失。谓贪己见。不求胜解。于善恶说不能了知。若无如是三种过失。是则名为闻正法器。为显此义故说颂曰

  禀和希胜慧　　是法器应知
  异此有师资　　无因获胜利

论曰。要具三德名为法器。一者禀性柔和无有偏党。恒自审察不贪己见。二者常希胜解求法无厌。不守己分而生喜足。三者为性聪慧于善恶言能正了知德失差别。若无如是所说三德。虽有师资终无胜利。言胜利者。所谓师资开悟证得如其次第。如彼六师诸外道等。虽闻正法而无所证。非佛于彼无愍济心。亦非圣教不中正理。以于世间所应度者。闻佛圣教皆已度讫。为显此义故次颂曰

  说有及有因　　净与净方便
  世间自不了　　过岂在牟尼

论曰。诸佛如来无碍智见。观利他事不过四种。谓所舍证及此二因。体义皆真名言非谬。即是四谛圣教所摄。佛虽广说而彼不知。过在世间非牟尼失。以诸外道觉慧庸微。及阙正修故不能解。如彼烈日放千光明。盲者不见于日无咎

复次彼诸外道。定为无明放逸睡眠缠覆心识。于自所许不能信依。所以者何。故次颂曰

  舍诸有涅槃　　邪宗所共许
  真空破一切　　如何彼不欣

论曰。诸外道宗皆言弃舍我所有事。唯我独存远离羁缠。萧然解脱无为惔怕。名曰涅槃。离相真空绝诸妄境。亦无分别执有等心。观此能除一切心境。正归无上大般涅槃。不违汝等所求解脱。如何憎背而不生欣。我等涅槃唯除我所。空亦破我知何所欣。汝涅槃中若有我者。必不离所何成涅槃。我如前破。不应重执故当欣此离我真空。有则可除空无能遣。执有起过观空即除。空有二途德失悬隔。云何汝等党有诽空。可愍邪徒痴狂无智。不能信受有益真空。常好邪求无益妄有。而于正教反生嫌嫉。如彼恶子淫乱迷心。耽媔色声猖蹶无礼。于母慈训不知敬从。自任凶顽反生怨害

复次若离真空毕竟无别舍证方便。故次颂曰

  不知舍证因　　无由能舍证
  是故牟尼说　　清凉余定无

论曰。彼诸外道虽复发心。求证涅槃及舍生死。由不善知舍证方便。于所舍证终不能成。憎背真空耽着妄有。故于方便名不善知。除真空观无舍生死。及证涅槃别方便故。诸有贪求外道见者。终不能得出世清凉。言清凉者则是一切苦及苦因究竟寂静。唯有空观是证得因。除此更无别方便故。如是空观佛法中有。一切外道邪论所无。故牟尼说四沙门果。我法中有。余法定无。以诸外道执着己见诽空观故不证涅槃。云何应知我等所执定非舍证正方便耶。前已具说。执常句义立实有时。皆有过失后当广破。执根境等故知汝执非正方便。又诸外道于涅槃处。实不能离我所见等。而谓彼处有自内我。解脱我所名为涅槃。所以者何。我与我所毕竟无有相离义故。汝不可言苦乐等法。于涅槃处远离于我。汝自立为我所有故。如汝所执我之自体。亦不可言我之自体。非我所有同喻无因。勿汝所执我无自体。便似空华有违宗过。是故汝等外道所执。不能究竟舍离生死。亦不能证究竟涅槃。由此应知非正方便

复次诸外道等。制造书论虽彼所诠少分有实。谓说施等是牵引因。能招善趣及余胜乐。又说杀等是牵引因。能招恶趣及余剧苦。然彼书论前后相违。亦复许为杀生等业。又能引发诸恶见趣。亦从如是见趣所生。如有盲人遇游正道。或时迷失复履邪途。外道书论亦复如是。有实有虚不可依信。若尔如来三藏圣教。或有所说难可信解。是则一切内外经书。无可信者成太过失。所以者何。佛经中说种种神变不可思议。又说甚深真实义理。诸有情类不能测量。复说如来三业作用。声闻乘等所不能知。谓无功用普于十方无量无边极远世界。随诸有情一一根性。无量无数品类差别。如其所乐能于一时现妙色身饶益无尽。虽断一切寻伺分别。而能为彼无量有情宣说无边甚深广大真实美妙无尽法音。于一念顷能除有情无量无边心行秽垢。其心虽无实生实灭。亦无一切能缘所缘而一念顷普于一切所知境界现见周尽。于现见时远离一切能见所见分别思惟。虽断一切随眠缠缚。而于三有现受死生。虽久离欲而生欲界。现处居家迫迮牢狱。贮畜种种财谷珍奇。养育妻儿亲眷僮仆。如是等事皆难信知。故我于此深怀犹豫。事若唯有诚可生疑。然事亦空故。次颂曰

  若于佛所说　　深事以生疑
  可依无相空　　而生决定信

论曰。此颂意言。如来为怖外道群鹿。大师子吼示现真空。如是真空其义决定。分明理教所共成立。诸有智者用为定量。锐难精思皆不能越。随顺空理无倒勤修。众善庄严成无上果。于此应生决定信解。唯空是实余并非真。但是如来随物机欲。善权方便显示宣扬。又佛所言虽有无量。略唯二种。谓空不空。若于不空有所疑者。可依空理比度应知。诸法皆空云何可见。由识言境有义不成。诸法体相略有二种。谓识所识及言所言。一境同时有多识起。随见差别境相不同。此识不应随外境起。由一境体多相不成。故知所识决定非有。言是假立唯诠共相。一切共相皆非实有。多法成故如军林等。又诸共相皆依别法。所依别法其数无边。诸近见者不能普见。既不见别。不应见总。如二性等依二等物不见所依必不能见。如是共相既非所见。如何依彼建立能诠。是故共相但假施设。非为实有可为言诠。又诸共相若实有者。一一法上全有分有俱不得成。一一法上若全有者。应如别法共相不成。一一法上若分有者。应成多分非一共相。又实等上无别有一。实等总性慧所缘故。如非实等。总性即是诸法共相。是故共相非有实体。但诸世间假共施设。如是诸法。或识所识。或言所言。二种推征俱非实有除此二境更无别法。故应信解诸法皆空。由此契经有如是说。诸法实性无示无对。皆同一相。所谓无相。诸法性相非言所行。言不能诠故名无示。非心心法所行境故。非缘有对之所能对故名无对。非超二种所行相外别有余相故名无相。空相无二故名一相。不为妄执贪等毒箭损害。真见所证真空分明可了故名为相。又真空理离有无等一切法相故名无相。无相无二故说为一。即以如是无相为相。故名为相非别有相

复次彼诸外道作如是言。诸佛所说略有二种谓空不空空言若实余说应虚。若佛所言一分是实。则类余分亦非虚者。我等所言亦应如是。云何总拨言不可信。汝等外道于现事中有谬失故不可依信。所以者何。故次颂曰

  观现尚有妄　　知后定为虚

论曰。彼诸外道邪觉乱心。浅近事中尚有颠倒。况于后世深远难知。因果理中而无谬失。是故所言不可依信。于何浅近我有倒耶谓胜论者计同异等是现量境。诸数论者计苦乐等是现量境。如是等事其数无边。皆有颠倒。所以者何。如胜论执同异性等是现量境。其理不成。牛马等性分别意识。于色等法假施设有。越诸根境非现量得。遍诸所依无差别故。如和合体。彼计第六和合句义。其体是一遍诸所依。越诸根境非现量得。同异等性其义亦尔。云何执为现量境界。又彼论说有实句义。是现量境。理亦不然。所以者何。瓶衣等物分别意识。于色等法假施设有。云何执为现量境界。然彼论说瓶衣等物因德业实同异合故。为眼所见及身所触。故是根境现量所知。此必不然。先明因德所引实智非现量摄。谓因青等暖等诸德所引实智。定非见触现量所摄。非业同异实所引生依随余相合所生故。如因香味所引实智。因业引生实智亦尔。如其所应比量遮破。谓因诸业所引实智。亦非见触现量所摄。非同异性实所引生依随余相合所生故。如因香味所引实智。因实引生所有实智。如见壸等知是牛等。既破壶等诸实句义。非所见触。即已破彼所引实智。以壶等智必因德业方乃得生。此前已破。是故亦非现量所摄。因同异性所引实智。亦非见触现量所摄。依随余相合所生故。如非实等所有诸智。谓非实智于德业等言此非实依随余相合所生故。定非见触现量所摄。余智亦尔。由是应知。一切句义假合生智。皆非真实缘彼现量。谓缘实智非是真实。缘实现量假合生故。如德等智。如是乃至缘和合智亦非真实。缘彼现量假合生故。如实等智故不应执六句义中有现量境。是故胜论于其现世浅近事中亦有颠倒

复次彼数论者执色等法三德合成。是实非假现量所得。理亦不然。多法成故。如军林等。色等应假。云何言实。又乐等三其性别故。如未变位不应成一。又色等法若是实有。应如乐等非三合成。又乐等三其相各异。云何和合共成一相。不可合时转为一相。与未合时体无别故。又乐等三性既各异。相不应同。汝执性相定是一故。性应如相同。相应如性异。又乐等别。色等是总。汝执总别既定是一。总应如别是三非一。别应如总。是一非三。云何别三成于总一。又转变时乐等三德若不和合共成一相。如未转时其相差别。不应现见是一色等。若三和合共成一相应失乐等三种别相不可说言乐等三德各有二相。一总二别。所以者何。总相若一不应即三。总相若三不应见一。若言乐等一一皆有。乐等三相共相和杂难可了知。故见一者。此亦不然。各有三相还应见三。如何见一。云何可知乐等有异。又若一一皆有三相。何须和合共成色等。即应一一能成色等。根境差别为我受用。又此三德各有三相。互有差别。如何色等其相是一。又若乐等一一皆能成色等法。一一法体皆三合成。是则诸法若性若相。应无差别。同以三德三相成故。若尔所有大等因果。唯量诸大诸根差别。一切不成世间现见情与非情净秽等物。现比等量亦无差别。违诸世间现所见故。成大过失。如是等类。外道邪师所执虽多。皆不应理。谁能挠搅粪秽聚为。我佛法中多诸法将。已摧彼敌。故不烦词。如是外道于浅近处。白日夷途尚致颠蹶。况于深远崄绝稠林巨夜重昏而无谬失。谁有识者。信彼邪言为止归邪。故复颂曰

  诸依彼法行　　被诳终无已

论曰。若诸有情随彼外道昧见倒执所说法行。彼随恶友邪教化力。妄见熏习所任持故。诽毁如来证所起法。获大罪业其量无边。由是因缘堕诸恶趣。受大忧苦无有出期。故有智者。勿类愚夫随恶友行而自欺诳。应随诸佛真实无罪。速证出离圣教修行

复次如上所言。佛经中说种种神变不可思议。又说甚深真实义理。诸有情类不能测量。乃至广说。如是等事。难信知者诚如所言。诸佛功德所说义理。皆甚深故难可信知汝等愚夫薄福少智。唯求自利不愿济他。未饮大悲甘露法味。岂能信解如是法门。若有慧光破无明闇。深心悲愍一切有情。求佛菩提具广大福。乃能信解如是法门。谓诸如来昔无量劫。悲慧种姓熏发其心。为拔有情生死大苦。为求无上正等菩提。于诸佛所恭敬供养。听闻正法系念思惟。修集无边法随法行。谓施戒忍勤定慧等。种种难行微妙胜行。殷重无间修习圆满。证得无上正等菩提。获不思议自在神力。本愿所引妙用无穷。于此何缘而不信解。现见世间机关等事。先势所引任运动摇。如是如来殊胜神变。本愿所引任运施为。又如世间习幻术者。若极成满处多人众妙用难思。何况如来。久修胜定增上满足。神通作用而可测量。是故汝等于诸如来不思议事。应生信解。于佛圆德自在神通。当至心求。勿怀放逸。有声闻等于佛无边不思议力。自知绝分悲号伤叹。声振三千。汝等云何诽谤不信

复次诸有智者。自往涅槃昧识逢师不能随学。为显此义。故说颂曰

  智者自涅槃　　是能作难作
  愚夫逢善导　　而无随趣心

论曰。烦恼缠缚无始时来。数习坚强牢固难断。涅槃虚寂无相无名。胜德无边高深难证。诸有智者。不因他教。自然能度生死大海。证得究竟大般涅槃。是大丈夫能作难作。愚夫久没诸欲淤泥。耽味欢娱不求出离。如狗贪咬染血枯骨。虽杖逼之犹不弃舍。愚夫亦尔。味着诸欲圣言诃责。亦不厌离。如是智者。自然开觉证大涅槃。是作难作。愚夫放逸无所觉知。虽遇圣言不希寂灭

复次生死甚苦涅槃极乐。过失功德粗着易了。如何有情安然不欲。厌背生死欣趣涅槃。以彼愚痴有怖畏故。谓怀我爱闻涅槃空。恐证无余我便断灭。由此怖畏。是故不欲厌背生死欣趣涅槃。如是怖畏由少智生。所以者何。故次颂曰

  不知无怖畏　　遍知亦复然
  定由少分知　　而生于怖畏

论曰。若诸有情都无觉慧。于一切法无所了知。彼于涅槃不生怖畏。若有遍知诸法正理。彼达生死及与涅槃。生死生时唯假苦生。生死灭时唯假苦灭。本来无我诸法皆空。故于涅槃全无怖畏。若有但解般涅槃时。诸行皆灭都无所有。不知行苦任运自灭。无实体用离我我所。彼由身见我爱所持。闻涅槃中空无所有。惧我断灭便生怖畏。如是怖畏因少智生。故有智者应正除断。又非串习故生怖畏。所以者何。故次颂曰

  生死顺流法　　愚夫常习行
  未曾修逆流　　是故生怖畏

论曰。诸异生者说名愚夫。烦恼随眠无不成就。欣生厌死不乐涅槃。从无始来数曾受领。增上生道可爱异熟。未曾修习决定胜道。增上生道诸果异熟。贪等随眠所依止处。虽为苦火常所焚烧。而不觉知欢娱游戏。于生死苦常习行故。不知过患无厌离心。于其解脱无罪乐味。由不曾知不乐修证。如世溷猪耽乐粪秽。清闲美膳非所欣求。如是愚夫乐生死苦。于解脱乐无希慕意。由未串习。闻说其名不能信受。反生怖畏。诸有智者由思择力。于解脱乐应正勤求。勿类愚夫倒生厌怖

复次诸有信求无倒解脱。或性贤善。或由慧力。将修真实见方便时。若于其中为作障碍。所获罪业其量无边。为显此义。故说颂曰

  诸有愚痴人　　障他真实见
  无由生善趣　　如何证涅槃

论曰。真实空见是证圆满无上智因。又是永灭一切无义涅槃方便。此方便道是不思议功德生处。由是展转疾证菩提。不住涅槃利乐无尽。随其所化无量有情根性不同。安立种子及成熟等。利乐无穷诸有愚人。由无明闇覆自慧眼。不见真空。复以邪说及余方便。障他所修。如前功德。彼获罪业无量无边。唯有如来能知其际。由重恶业染坏其心。后生善趣去之甚远。随眠缠缚相续坚牢。种种业因能为重障。方便顺忍尚不得生。正见涅槃如何可证。知障正法罪业既深。智者应当自防勿犯

复次诸有障他修正法者。彼后自引邪见令生。此邪见罪过于毁戒。为显此义。故复颂曰

  宁毁犯尸罗　　不损坏正见

论曰。如契经言。宁毁净戒不坏正见。此意云何。毁净戒者唯能自坏。若坏正见兼坏自他。令无量生受大苦果。及失无量无边利乐。又毁戒者由犯戒故常怀惭愧诃厌自身。坏正见者无惭无愧。赞成邪见恒自贡高。又毁戒者不增邪见。若坏正见令破戒恶未生而生。生已增广坚固难坏。又毁净戒但障生天。坏正见者障涅槃乐。所以者何。故次颂曰

  尸罗生善趣　　正见得涅槃

论曰。毁戒坏见。虽复俱能损坏善因障碍乐果。然毁戒轻。坏见极重。所以者何。持戒生天增长结缚受生死苦。正见能证三乘菩提得涅槃乐。是故智者勿坏正见

复次诸法真理何者是邪。谓一切法空无我理。若尔此理亦有过失。所以者何。如有一类闻空无我谓法皆无。诽拨一切因果正理。乃至断灭一切善根。此自见有过。非空无我咎。由恶取空妄起邪见。行诸恶行空无我理。心言不测非彼所证。愚夫闻说诸法皆空。不知圣意。便拨世俗因果亦无灭诸善法。此岂是空无我过失。圣说空教有何意耶。为遣一切虚妄有执。若尔亦应说诸法有。为遣妄执诸法空故。实尔若有执诸法空。如来亦说诸法是有。既为遣执说有说空。诸法真理为空为有。诸法真理非有非空。分别戏论皆不能及。何缘圣说非虚妄耶。为除邪执故非虚妄。空有二教俱能除执。何故如来多说空教。以诸有情多分执有。生死多分从有执生。是故如来为除有执灭生死苦。多说空教。若空若有皆是教门。何故前说空为真理。方便假说亦不相违。又此空言是遮非表。非唯空有亦复空空。遍遣执心令契诸法。非有非空究竟真理。诸法真理实非空性。空为门故假说为空。真理非空。空为门者。真理非有。应有为门。随机说门。有亦无过。然其门义顺在于空有有有等皆顺执心。空空空等皆违妄执。故有智者。闻说空言应离一切有无等执。悟法真理非有非无。勿起有无分别戏论

复次劣慧者。前不应辄说空无我理增其恶见。所以者何。故次颂曰

  宁彼起我执　　非空无我见
  后兼向恶趣　　初唯背涅槃

论曰。彼谓世间诸劣慧者。我执即是萨迦耶见。其我所见亦带我执。故我执言亦摄彼见。我执虽复不称正理。而宁彼起过失轻故。空无我见虽称正理。然彼不能如实了达。因斯诽拨诸法皆无。过失重故。宁彼不起。云何此二过失轻重。谓初我执唯背涅槃。后恶取空兼向恶趣。彼劣慧者恶取空时。尚厌善根。况诸含识。彼由厌背善及世间。断灭善根损害含识。非唯弃背清凉涅槃。亦持自身足地狱火。起我见者。无如是事。所以者何。彼贪我乐欲我离苦。不造众罪广修诸福。脱诸恶趣不失人天。但怖涅槃不证解脱。故契经说。宁起我见如妙高山。非恶取空增上慢者。若尔诸法空无我理。邻近险趣。圣不应说。劣慧者前实不应说。而胜慧者随此修行获大义利。故须为说。所以者何。故次颂曰

  空无我妙理　　诸佛真境界
  能怖众恶见　　涅槃不二门

论曰。求解脱者除妙空观。无别方便能证涅槃。智者欲除诸恶见垢。离此无有余胜方便。有见执有所缘境故。如余有见不证涅槃。亦不能除诸恶见垢。修此空行至究竟者。能证极果无上菩提。普为有情方便开示。复令圆证所求妙果。诸有能成自他利乐。空无我观最为胜因。故应善知有情根性。方便开示令其悟入

复次如来为除恶见鬼魅。说空无我阿揭陀药。所以者何。诸恶见者。闻说空名皆生怖畏。渐次调伏自然息除。为显此义。故说颂曰

  愚闻空法名　　皆生大怖畏
  如见大力者　　怯劣悉奔逃

论曰。愚谓恶见。损覆慧眼。彼闻空名。诸恶见命自然损害。空虽无心欲害恶见。而力大故。闻名自灭。如闻虎名怯者自丧。又如世间调善龙象。于其两颊威汗交流。虽复无心损害物命。而彼龙象威力大故。其见闻者惊怖奔逃。空理亦然。威力大故。令恶见者闻名惊怖。自然损灭。空理无心。非为损物。证空理者。应为害他。若证真空其心寂静。平等无二。岂欲害他。然为利乐诸有情故。方便开示空无我理。怀恶见者。闻之自灭。为显此义。故次颂曰

  诸佛虽无心　　说摧他论法
  而他论自坏　　如野火焚薪

论曰。诸佛无心欲摧他论。然为利乐所化有情。开示昔来诸佛广路。谓一切法性相皆空。前后如来无不游履。从因至果引导群迷。外道邪徒诸恶见论。闻斯空教自然坏灭。如在山林野火腾焰。湿薪积木烈日所干。虽无有人持火来就。然薪逼火如自引烧。恶见邪徒诸论亦尔。空教势力而自崩摧

复次诸外道宗皆说妄有。欲令弃舍故说真空。所以者何。故次颂曰

  诸有悟正法　　定不乐邪宗
  为余出伪门　　故显真空义

论曰。有智自能简别真伪。遇此正法不乐邪宗。如识宝人得无价宝。终不复乐余水精珠。诸外道宗皆立妄有。去正法远如假伪门。诳惑有情令失大利。故我显示佛教真空。令彼邪徒趣真背伪

复次何缘外道欣乐邪宗。厌背圣教。由身见力。若知无我必无欣厌。所以者何。故次颂曰

  若知佛所说　　真空无我理
  随顺不生欣　　乖违无厌怖

论曰。若知佛教空无我理。断除身见所起随眠。观察世间如空舍宅。虚妄诸行生死轮回。兴盛无欣衰损无厌。无忧无喜无畏泰然。若有身见谓我损益。衰盛起时便生忧喜。因斯便有怖畏无穷。故有智人应除我执

复次诸外道众。由着我执。能为自缚亦缚有情。所损既多。深可悲愍。为显此义。故说颂曰

  见诸外道众　　为多无义因
  乐正法有情　　唯不深悲愍

论曰。诸外道众贪爱我执。能令自他起无量罪。萨迦耶见是一切恶生根本故。如说所有恶不善法。一切皆以萨迦耶见为本而生。诸有中怀乐善法者。自无定执随顺他缘。为彼外道邪言诳惑。亦贪我见起无量罪。如是外道能令自他俱起种种坚固缠缚。唯有智人而不悲愍。故乐正法净意有情。起利乐心应深悲愍。殷勤为说无我真空。令修正见离诸系缚

复次诸佛菩萨常住于世。实有真净利乐他心。何故世间犹有无量信邪倒见谤法有情。由佛所说境智甚深微细难悟。外道不尔。所以者何。故次颂曰

  婆罗门离系　　如来三所宗
  眼耳意能知　　故佛法深细

论曰。诸婆罗门唯常习诵虚言为道。耳识能知。非是深细离系外道。唯以露形身体臭秽种种猛利自苦为道。眼识能知。亦非深细如来圣教。以证真空无漏慧剑。永断所有内烦恼贼。获得无上正等菩提。利益安乐一切含识。理教意趣甚深微细。诸有通达如实理者。于佛圣教或知不知。由佛理教最深细故。外道愚夫不能悟入。外信外道粗浅邪言。少信如来深细圣教。世间多信婆罗门者。以婆罗门多行诳诈。诵咒祠火自苦除愆。矫设吉祥妄说祸福。为活命故种种方便。诳诸女人戍达罗等。令于彼所生希有心。供给所须推为尊贵。古昔黠慧诸婆罗门。隐造明书言自然有。唯得自诵不许他观。赞婆罗门最为尊贵。刹帝利等皆是卑贱。给施所须获无量福。愚夫无智不能测量。谓真福田信敬供养。然彼明书非自然有。有所诠故如世俗言。又彼明书非尽称理。非圣说故如虚诳言。婆罗门种非实尊贵。非真福田。常行乞匈养妻儿故如贫癞者故。有智人不应归信。婆罗门法既多诳诈。离系外道所学如何。彼所学法多顺愚痴。所以者何。故次颂曰

  婆罗门所宗　　多令行诳诈
  离系外道法　　多分顺愚痴

论曰。离系外道都不知真。唯贪后乐现受剧苦。诸有所言多不合理。愚痴种类聚结成群。为世愚痴之所归信。云何决定知彼愚痴。以露身形无羞耻故。如狂如畜。如似婴儿。若婆罗门实非尊贵。何缘贵胜亦敬事之。以彼习诵诸明论故。诸婆罗门。实无所识。为活命故于一切时诵诸明论。诈现异相。以动人心。世间贵胜不审观察。谓其有德故敬事之。又明论中虽无胜义。而有世俗少分礼仪。世间贵胜为习学故。彼虽无德亦申敬事。余有不诵诸明论者。以同类故世俗相承不审观察亦兼敬事。离系外道与彼不同。云何世间亦多敬事。以其薄知星历道度观鸟解梦占相吉凶。故凡愚人多申敬事。又婆罗门诵诸明论以难成故世共敬之。离系外道以苦行故世共愍念。此皆不能解脱生死。诸有智者当正了知。勿随彼见。故次颂曰

  恭敬婆罗门　　为诵诸明故
  愍念离系者　　由自苦其身

论曰。婆罗门法勤诵诸明。世以为难故共恭敬。然诸明论非解脱因。但有虚言无实义故。离系外道极自苦身。亦以为难。世共愍念。云何自苦非解脱因。是异熟果非善法故。彼拔发等所生身苦。由过去世恶行所招。是业异熟非善法故。如乐异熟非解脱因。若言此苦现功力生。非异熟果因不成者。此亦不然。彼所受苦是异熟果。以无所益与色根识俱生苦故。如地狱中所受身苦。自部亦有不许此苦。是异熟者。应以此量而决了之。诸有身苦非异熟者。亦非能证解脱亲因。有漏身受现缘生故。如淫欲乐。又彼自苦非解脱因。违圣教故。如自害苦。彼师所说。非是圣教。非如来等所共说故。如淫书等。故彼自苦。但是前世恶行所招。及以现在愚痴所起。定非能证真解脱因

复次有作是言。依尊胜身能得解脱。世间尊胜谓婆罗门。故婆罗门能证解脱。非余杂类可得涅槃。此说不然。故次颂曰

  如苦业所感　　非真解脱因
  胜身业所生　　亦非证解脱

论曰。如离系宗所受身苦。业异熟故非解脱因。婆罗门身设许尊胜。亦业所感非解脱因。身虽不能亲证解脱。而身中善是解脱因。若尔余身善亦如是。云何但说婆罗门耶。又婆罗门根境等法。与余种类一切皆同。云何自言彼胜余劣。是故彼说。唯诳愚夫。诸有智人不应信受。然婆罗门非胜余类。此洲人故。如戍达罗。戍达罗等非劣彼姓。此洲人故。如婆罗门既言外道所说皆虚。未知如来法有何实。为遣此疑。故说颂曰

  略言佛所说　　具二别余宗
  不害生人天　　观空证解脱

论曰。佛说无量深妙法门。利乐有情要唯二种。一者不害能感人天。二者观空能证解脱。损恼他意及所发生。身语二业总名为害。若能断彼所说害法。修诸善因名为不害。谓十善业。布施爱语利行同事。及诸静虑无色定等。由此得生人天善趣。受诸胜妙无染果报。依此能除一切烦恼。及能修习无量善因。真如实际离相名空。正观此空。证涅槃乐空无我理。于诸法中无相无名。咸同一味寂静安乐。即是涅槃。此必观空。方可证故。如是善趣解脱二因。唯佛法中具足可得。外道虽说施等少分。生人天因而不圆满。所以者何。彼诸外道无有显析因果智故。不言意思生胜福故。无别解脱律仪法故。善趣粗业尚不委知。涅槃妙因故其绝分。如来所说理教周圆。外道邪徒如何不乐。由佛正教违彼邪宗。乖本所贪。故不欣乐。为显此义。而说颂曰

  世人耽自宗　　如爱本生地
  正法能摧灭　　邪党不生欣

论曰。如本生地虽不膏腴。久处其中而不愿舍。自宗亦尔。虽与理违。以本师承故不能离。尚不欲乐余外道宗。况慕如来甘露圣教。甚深实相真空智火。能焚外道邪执积薪。违彼本心。故不欣乐。诸有智者应善思惟。勿染邪宗致违正法

复次佛法普照如盛日轮。求胜智人应当信仰。为显此义。故说颂曰

  有智求胜德　　应信受真宗
  正法如日轮　　有目因能见

论曰。此中显示要具二德能信大乘。一者有知。二者希求殊胜功德。大乘能灭一切邪宗。随顺大乘多所饶益。谓自能证无上涅槃。令他有情亦出生死。大乘正法如彼日轮。普为世间破无明闇。有慧目者因此法光。分明照知真伪色像。背邪从正避崄求安。利乐自他无不成办。诸有智者应信大乘。勿顾邪宗诽毁正法。自受沉溺生死淤泥。诳惑有情令失大利。智与愚异。谓识是非智勿似愚不辨真伪。若有真实利乐他心。应以大乘摧邪立正。勤修空观速证菩提。利乐有情穷未来际

大乘广百论释论卷第六大乘广百论释论卷第七

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破根境品第五

复次如上所言。后当广破根境等者。我今当说。根是了别境界所依。将欲破根先除其境。境既除已根亦随亡。迦比罗云。瓶衣等物唯色等成。诸根所行体是实有。为破此计。故说颂曰

  于瓶诸分中　　可见唯是色
  言瓶全可见　　如何能悟真

论曰。汝宗自说眼等诸根各取自境不相杂乱。眼唯见色。瓶通四尘。岂见色时全见瓶体。此显瓶体非眼所见。非唯色故。犹如声等。岂不瓶体亦是色耶。我不言瓶体唯非色。但言瓶体非唯色成。故所立因无不成失。汝于现事既有乖违。而言悟真。此何可信。如眼所见唯色非瓶。香等亦然。故次颂曰

  诸有胜慧人　　随前所说义
  于香味及触　　一切类应遮

论曰。鼻舌身根。其境各异。全取瓶体。义亦不成。瓶非三根所取境界。一一比量如前应知。声既非恒。故此不说类其色等。声亦应然。如是一切瓶衣车等。皆非色根所取境界。非定意识取于外境。必随色根。瓶等既非色根境界。意亦应尔。若不尔者。盲聋等人。亦应了别色等外境。如是瓶等非根所行。皆是自心分别所起。若言瓶等与色等法体无异故。眼等诸根。如取自境。亦取瓶等。是故诸根。亦能渐次取瓶等境。若尔瓶等应是一切色根所行。即违诸根各取自境。或一瓶等体应成多。或许诸根不取瓶等。唯色等体是根境故。色等各别既非是瓶。如何合时成实瓶体。若言瓶等众分合成。见一分时言见瓶等。如见城分亦名见城。此亦不然。城非实故。城体是假。众分合成。见一分时不名全见。瓶等若尔。是假非真。汝等云何执实可见。又见一分言可见者。其理不然。故次颂曰

  若唯见瓶色　　即言见瓶者
  既不见香等　　应名不见瓶

论曰。若和合中有众多分。由一分故全得其名。谓于一瓶有色等分。由见色故言见瓶者。所余香等既不可见。应从多分言不见瓶。亦不应言色体是胜。瓶一分故。犹如香等。色等于瓶既无胜劣。应从香等名不可见。世间立名。或从多分。或就最胜。色上全无。香等有一。是故瓶等应从香等名不可见。是则外色亦应非实。是可见性。是瓶衣等不可见法。一分摄故。犹如香等世间共知。瓶色可见。云何得立不可见耶。世间所知随自心变。假说可见非外实色。今遮心外实有可见。故不相违不可见法。无所有故。应不可说。所以者何。可见无故名不可见。无法都无如何可说。可见之法以有体故。可为他说。此亦不然。无体之法亦是说因。若不尔者。不可见言现应无有。又见于色都无所益。何故说色以为可见。非不可见。所以者何。非由能见及不能见。令色有异。云何由见说色可见。非由不见说不可见。如瓶上色是可见故。说瓶可见。瓶上香等不可见故。亦应说瓶。为不可见其理等故。又眼见时。说色可见。眼不见时。亦应说色为不可见。其理等故。瓶之与色。既有可见不可见义。何故今者。偏破可见立不可见。可见起执。遮可见故言不可见。非立瓶色为不可见。又色亦非全体可见。如何由色而说见瓶。所以者何。故次颂曰

  有障碍诸色　　体非全可见
  彼分及中间　　由此分所隔

论曰。有障碍色非全可见。彼分中间此分所隔。如隔壁等所有诸色。虽见一分而不见余。故应如瓶名不可见。于诸分中此分非胜。余分为多。此应从多名不可见。粗色渐析未至极微。常有多分。若至极微非色根境。是故诸色皆不可见。岂不极微外面傍布无所障隔。相邻而住全可见耶。众微总相是假非实。一一别相非色根境。有碍极微面有彼此。如何得立色法实有全体可见。虽诸极微总相是假。一一别住实不可见。然诸极微和合相助。不可分析。面有彼此。故一一微其体实有。全分可见。此亦不然。故次颂曰

  极微分有无　　应审谛思察
  引不成为证　　义终不可成

论曰。极微亦与余物合故。应如粗物有分是假。破常品中已辨极微有分非实。极微一一既不可见。云何和合相助可见。若相助时。不舍本相。不应相助若舍本相应非极微。以相助时。若如本细应无助力。应不可见。若转成粗应非极微。应假非实审思极微。由有碍故。有分非实不可全见。是故不可引证诸色实而可见。如色由前所说道理。有分无实非色根境。如是一切有质碍法。皆众分成非色根境。为显此义。故复颂曰

  一切有碍法　　皆众分所成

论曰。诸有碍法以慧析之。皆有众分相依而立。析若未尽。恒如粗事。众分合成是假非实。析之若尽便归于空。如毕竟无越色根境。诸可见者皆众分成。世所共知。并假非实。细分障隔不可全见。极微相助。理复不成。诸有碍物皆可析之。尽未尽时归空是假。是故都无真实色法可见可闻可嗅尝等。所诠色法既非根境。能诠亦然。故次颂曰

  言说字亦然　　故非根所取

论曰。一切所闻音声言说。渐次分析至一字名。此亦如前。犹有细分。复渐分析乃至极微。此非所闻。犹有细分。复渐分析乃至都无。析未尽来。是有碍故。常有细分。是假非实。又声细分前后安立。互不相续。体无合义。非实诠表。非实可闻。其理分明。故复别说。若声细分同时而生。非前后立如色细分。萨罗罗萨。如是等字。同时可闻。义应无别。如是已破色等五尘。体是实有色根所得

复次有说。形色是眼所见。今应征问。如是形色。为离显色。为即显耶。若离显者。应非眼见。离青等故。如乐音等。若即显者。应如显色。亦非眼见。前已广论。又说颂曰

  虽显色有形　　云何取形色

论曰。若离显色别有形者。云何依显而取形耶。如离显色有乐音等。自根取时不依于显。然依显色而取于形。如远见火。知暖总相。是故形色决定应非色根所取。或非眼见。若复有言。不依青等而取形者。应如是破。不动显处形色了别。必色根境。了别为先缘形相故。诸缘形相必色根境。了别为先。如旋火轮形相了别。或如闇中形相了别。有作是言。形显二色其体各别。能了异故。如香味等。现见世间长等青等。能了各异。若尔世间诸大造色。与金银等能了异故。应有别体。因既不定。宗义岂成。或复云何取形色者。若形实有是眼所见。云何依触而取形耶。不见青等依触而取。形既依触而可了知。应如涩等非眼所见。此因若言定依于触而了形者。依于显色。应不了形。若言依触定了形者。触风水等应亦了形。此难非理。我意但言。形可依触而了知故。非眼所见。不言形了依触决然。若尔显色亦依触了。应不可见。如依触故。知火色等。此必长等差别所隔。方可了知。故所立因无不定失。所以者何。若依于触了别青等。定是比知。非眼所见。青等共相此必长等差别所隔。非亲依触。不可难言。形亦应尔。以形于触无决定故。显有决定。故不相类。如是已破离显有形。即显亦非。故次颂曰

  即显取显色　　何故不由身

论曰。形若即是青等显色。显色如形应由身取。是则显色身触应知。即是形故。犹如形色。身触知形不知其显。故知显色非即是形。此意说形非即显色。不同知故。犹如乐音。形若与显非即非离。应如车等其体非真。形体若实。如青色等。应与显色或即或离。又诸形类无别极微。一一极微无长等故。离显极微别有长等。极微自性难可了知。形显极微。量既无别。云何离显别有实形。亦不可说。一一极微有长等相。长等如粗体可分析。何谓极微。又诸极微量无差别。彼此共许。今说极微有长等相便违自宗。汝所学宗许极微量。无差别故。亦应信受。离显无形。若言极微虽无长等而由积集成长等形。即显极微集成长等。何须别执有形极微。又长等形非如青等。极细分析本相犹存。故长等形非色根境。无实体故。犹若空花。若诸极微非实长等。如何积集成长等耶。汝许极微体非粗大。云何积集成粗大耶。是故长等非。实有性。但是青等积集所成

复次胜论宗中。离色等外别立实有同异性等。彼由能依色等势力为色根境。此亦不然前说色等非色根取。故彼亦非色根境界。彼宗有说。实等要因粗德色德合故方见。若无二德。应如极微及空中风。虽有不见。此亦不然。粗如长等。析即归无。色非可见。并如前说。如何因斯能见实等。彼复有说。所依实等要由能依色故可见。如热水中。水覆火色。虽有火实而不可见。即彼论中有破此说。青等染色染白衣时。不见白色应不见衣。不可说言。由见染色见染所依。染所依实与衣合故。亦得见衣。所以者何。水火二实既共和合。由见水色即见于水。亦应由此见于火实。彼宗二师俱不合理。且借彼一以破彼宗。为破彼执。复说颂曰

  离色有色因　　应非眼所见
  二法体既异　　如何不别观

论曰。色所依实名为色因。如是色因若离青等。应如味等非眼所见。色与色因性相若异。如青黄等应可别观。实既离色。不可别观。应如色体无别实性。实之与色亦可别观。如见青黄二解别故。如是二解非色根识。假合生故如非实心

复次或胜论者作如是言。诸色实有。而言聚色非实有故不可见者。若执一处。有众多色可有此过。我说同类处必不同。故于一处唯有一色。无此过者。此亦不然。若色实有应不可见。无细分故。如虚空等。此因不定。以色性等亦无细分而可见故。汝云何知离色体外别有色性。复云何知色性可见。为破彼执。故说离色有色因等。此中色性说为色因。色智色言藉此生故。若此色性异色体一。周遍一切离青等处。亦应可见离青等处。既不可见。色性定应非眼所见。有作是言。若执色性其体周遍。容有此失。我说色性随自所依。各各不同。无斯过者。此亦不然。若色性等随自所依体不同者。无青等处。青等欻生。有青等处。青等欻灭。尔时色性与所依色。其处不同。应各别立。而汝不许云何无过。若言色性有迁动能。转至余处或复新起。是即此性非一非常。既许一常体应周遍。还同前失。离青等处亦应可见。既不可见。应非眼境。岂不中间或余法上无了因故不可见耶。何名为了因。谓形量差别。若尔色性应不可见。所依诸色无形量故。又此色性应非眼见。体周遍故。如声性等。色与色性体相若异。应可别观如青黄等。然此二种不可别观。是色是性故无有异。不可说言。见而不了。是色是性二相差别。色性相异应如青黄。为缘发生似己见故。能见既同。所见应一。故离色外无别色性。既无色性离色可见。如何比量因不定耶。余声性等随其所应。一一研寻例如前破

复次胜论宗中说。地水火有色触故。皆为眼身二根所得。世间共许。地等三大是眼所见身所觉故。风唯身得。以无色故。此亦不然。已破眼见。当破身觉。若随世间共所许者。身唯能觉触德非余。所以者何。故次颂曰

  身觉于坚等　　共立地等名
  故唯于触中　　说地等差别

论曰。世间身觉坚湿暖动。便共施设地水火风。是故唯触名为地等。非离触外有别所依。地等四实此义意言。地等四实不离于触。身所觉故。如坚等触。若执地等非触所摄。应如味等非身所觉。若于坚等立地等名。则无所诤。体无别故。若立地等是触所依。非即坚等。违此比量。颂中初半明地等大。自相身觉即触所摄。后半明彼地等共相。非触所摄。身不能觉。唯是分别意识所知。前色性等自相共相。随其所应类亦应尔

复次地等诸大。于烧等时无异相生。故非根境。如烧瓶等。于熟位中有异相生。谓赤色等。此诸异相德句所摄。离此无别实句相生。如何可言。离德别有地等实句身根所觉。为显此义。故复颂曰

  瓶所见生时　　不见有异德
  体生如所见　　故实性都无

论曰。瓶等烧时有赤色等。诸德相起现见异前。除此更无实句瓶体。与未烧位差别而生。瓶等实句若别有体。应如德句有异相起。能烧所烧和合等位。既无有别实句相生。应如空等非实有性。亦非色根所取境界。但是分别意识所知。世俗谛收假而非实

复次外道余乘。各别所执粗显境相。我已略遮。今当总破外道余乘遍计所执一切境相。谓彼境相略有二种。一有质碍。二无质碍。有质碍境皆可分析。有质碍故。如舍如林。析即归空。或无穷过。是故不可执为实有。无质碍境亦非实有。无质碍故。犹若空花。又所执境略有二种。一者有为。二者无为。诸有无法从缘生故。犹如幻事非实有体。诸无为法亦非实有。以无生故。譬似龟毛。又所执境一一法上。随诸义门有众多性。若是实有。应互相违。复析归空或无穷过。又所执色应非实色。是所知故。犹如声等。广说乃至。所执诸法应非实法。是所知故。犹如色等。由此道理。一切所执若有若无皆非真实。诸有智者应正了知。有无等境皆依世俗。假立名相。非真胜义。复次已破其境。复为破根。先破余乘。故说颂曰

  眼等皆大造　　何眼见非余

论曰。眼等五根皆四大种。所造净色为其自性。故契经言。谓四大种所造净色。名眼等根。此世俗言非胜义说。若执为实其义不成。所以者何。同是造色。何缘见用。唯眼非余。未见世间二法相似。所起作用更互不同。岂不诸根其相有异。谓各能作自识所依。此果有异非相差别。相既无别。果如何异。用有异故。其果不同。现见世间用殊相一。如诸药草。损益用别。坚等相同。相既是同。用应非异。又应诸根即是大种。生识用别名眼等根。如即坚等作用不同。得药草名种种差别。此不应然。相用体一。名有异故。由见等用有差别故。即显眼等相有差别。非有别用。依无别相。用既不同相必有异。故离大种别有义成。若尔药草用既不同。亦应离大别有其体。许有别体于义何违。若如见等全离大种。义可无违。然非全离。何得无违。若言眼等性类虽同而相有异。便违自宗。汝宗性类即法体相。性类既同。相由何异。不可一体有同不同。二相差别俱非假有。如一色上无有青黄二相差别。若一法性可分二相。于中一一复应可分。如是展转应析至空。或至无穷。常非实有。又眼等根体由何异。由见等因有差别故。岂非见等同用大种。以为其因。云何有别。若由大种有差别故。所生见等有差别者。即应依此差别大种。眼识等生何用眼等。非唯大种是见等因。如何可言。彼无异故。见等无别。复有何因。谓善恶业。此业复由贪乐见等众缘展转差别而生。由此业故见等有异。若多满业别感见等。其义可然。若唯一业总感一身。如何有异。又色界身业无差别唯厌味等一业所招。彼界诸根应无差别。若言一业有多功能。故所感身诸根别者。业与功能俱是作用。如何一用而有多用。不言一用复有多用。但说一体有多功能。由此功能发生多果。如同分眼。体虽是一而能生识及生自类。假说可然。实云何尔。一即是多。理相违故。若许一业有多功能。感多根者何不许业。唯感一根能生多识。如是抑难于理何益。又一根处有损益时。余根亦应同有损益。又若一根身应鄙陋。我不抑汝。令唯一根。但欲挫汝一业多用。又业力故。无有诸根同时损益。如地狱中。虽有猛火焚烧其身。而彼有情诸根不灭。又由根处身相端严。如青盲人形非鄙陋。又若一业能生多果。以生别识证有别根。如是比量应不成立。此有彼有。此无彼无。但可成立差别功能。不应证有差别体相。又即此业差别功能。何不能生差别诸识。诸识生时业已灭故。无能生用。若尔眼等应不从彼业用而生。若业所引习气犹存能生眼等。何不从彼业引习气诸识生耶。此不应然。生无色界眼等五识。应亦现行业习所依。识体有故。立有色根。无如是失。生无色界大种无故。造色亦无。何缘生彼无大种耶。离色贪故。即由此因损害识种。故眼等识于彼不生。此不应然。非于境界离贪欲故。能缘识种亦被损害。勿于欲界。得离欲者。或于三界得离欲者。能缘彼识毕竟不生。若言所依由自地业所引发故能生诸识。身生色界于欲界境应不能缘。若尔应言。生无色界无境界故。彼识不生。何故不缘下地境起。若言于彼已离贪故不能缘者。此先已说。先何所说。谓生上地应不能缘下地境界。若即业种能生五识。不应根处有损益故。识随损益。所以者何。非业习气用彼为依。彼变异故。识随变异。由现彼识有损益故。令业习气亦有损益。所以者何。世间现有缘即心境妄分别识。能令余法损益事成。如在梦心妄谓心等。若不觉知根处损益。能依之识损益应无。此中必有微细觉受。如是等类问答无穷。恐厌繁词。故应且止。诸法性相微细甚深。浅识之俦极难开悟。且应随俗说有诸根。非卒研穷能契实义。故次颂曰

  故业果难思　　牟尼真实说

论曰。此颂义言。诸业眼等异熟因果。不可思议。唯有如来能深了达。非余浅识智力所行。应随世间且说为有。非暂思择能会其真。诸法实性内证所知。非世寻思所行境界。若执实有。理必不然。所以者何。违比量故。谓眼非见。如耳等根。耳亦非闻。如眼根等。鼻不能嗅。如舌等根。舌不能尝。如鼻根等。身不能觉。如上诸根。一切皆由造色性故。或大种故。或业果故。又眼等根皆有质碍。故可分析令悉归空。或无穷过。是故不应执为实有。但是自心随因缘力。虚假变现如幻事等。俗有真无

复次数论外道作如是言。色等境界皆二根取。谓眼等见及内智知。今应审察。见智于境。为同一时。为有先后。设许先后。谁后谁先。先后同时。皆不应理。所以者何。故次颂曰

  智缘未有故　　智非在见先
  居后智唐捐　　同时见无用

论曰。见是智缘智随见起。若未有见智必不生。如生盲人无了色智。是故智起定非见先。若居见后智即唐捐。见已了色智复何用。汝宗法起必为我须。非但随因任运起故。若见已了复须起智。应一境上了了无穷。若二同时见应无用。两法俱有因果不成。如牛二角。如苦乐等。汝应不许见为智因。若智知境不由见生。盲聋等人应明了境。又不应有盲聋等人。以皆分明了色等故。又不应立五有情根。意独能了色等境故

复次有立眼耳境合方知。其理不然。故次颂曰

  眼若行至境　　色远见应迟
  何不亦分明　　照极远近色

论曰。眼谓眼光是眼用故。不离眼故。亦得眼名。若此眼光行至色处。何故远色见不淹迟。如何月轮与诸近色。举目齐见无迟速耶。未见世间有行动物一时俱至远近二方。由是因缘应立比量。照远色见不至远色。照近色见时无异故。如近色见。照近色见不至近色。照远色见时无异故。如远色见。又若眼光至色方见。极远近色应见分明。与非近远见应无异。既有差别。故非至境。非鼻等根。于香味触有此远近明昧不同。由是比知眼不至境。于近远境用差别故。犹如磁石。又眼趣色先见不见。二俱不然。故次颂曰

  若见已方行　　行则为无用
  若不见而往　　定欲见应无

论曰。本为见色行趣于境。其色已见。行复何为见已方行。又违先立眼之与耳境合方知。亦不可言不见而往。眇无指的行趣何方。如瞽目人所欲趣向不定能至。此亦应然。不见而往应无住期。或于中间遇色便止。期心往者或果所求。或由力竭中涂而住。如是二种理既不成。更无第三。故非境合

复次有说。眼根不合故见。此亦不然。故次颂曰

  若不往而观　　应见一切色
  眼既无行动　　无远亦无障

论曰。不合体无相无别故。应见一切。或全不观。所以者何。缘无差别。从缘有法差别不成。岂不诸色由远由障而不见耶。眼既不行何远何障而令不见若眼与色不合而见。应无远近障无障殊。不合之因无差别故。有见不见。理不得成。又极远名无实有体。云何能碍令见不生。非二中间诸法名远。彼于见用不能碍故。若执中间诸法名远。碍见用者。远障应同。言眼趣色。亦有此过。谓极远名无实体等。执眼为常行趣于色。实有此过。所以者何。执眼无常行趣于色。可言力竭不至远方。若执眼常用无变坏行趣于色。过与前同。行与不行二俱有过。故眼见色非行不行。岂不光明助眼令见光明被障故不见耶。夜分远望珠灯中色。既隔闇障应不能观。若言眼根虽不至色然同磁石远近用殊。此亦不然。疑难等故。世间共见。何疑难耶。此亦不然。真俗异故。世间见俗汝执为真。世亦不知不合而见。如何可说与磁石同

前诸颂中虽正破眼。亦兼破耳。以义同故。谓若耳根境合知者。不应远近一时俱闻。声从质来。既有远近。不应一念同至耳根。耳无光明。不应趣境。设许趣境。过同眼根。又声离质来入耳闻。亦不应理。钟鼓等声现不离质。远可闻故。若耳与声无闻而取。应如香等不辨方维。若耳与声不合而取。应无远近一切皆闻。不合体无相无别故。或应一切皆不能闻。是故耳根声合不合。实取自境二俱不成

复次若执眼根能见于色。应见自性。所以者何。故次颂曰

  诸法体相用　　前后定应同
  如何此眼根　　不见于眼性

论曰。法体相用前后应同。展转相望无别性故。眼若能见应如我思。于一切时以见为体。是则眼根不对境位。应常能见如对境时。彼位色无而有见用。应以眼体为其所观。若无色时眼不能见。应有色位亦不能观。又若眼根以见为体。应能自见如彼光明。即违自宗。根非根境。若不自见。应不见他。如生盲人都无所见。又汝宗言。眼等色等诸法相用乐等所成。相用虽殊其体无别。眼见色体即是自观。亦违自宗。根非根境。又眼见色称实而观。色与眼根体真是一。如能见色应见眼根。既不见根。应不见色。不可眼色体实有殊。勿违自宗。同乐等性不应说眼不称实观。勿违自宗。现量所摄。若言自见世事相违。此亦不然。体用别故。若言见用即是乐等。青等亦然。应不可见。若言根境其体有殊。便违自宗。俱乐等性不可一性。有众多体转变亦然。不离性故。若言其体即别即同。除汝巧言谁能说此。根境体一见境非根。如是宗言。极难信解。如破眼见。耳等例然。根境皆同乐等性故。又应一境一切根行。亦应一根行一切境。是则根境安立不成。故不应言诸根实有

复次鸺鹠子言。我宗根境其性有异。不同彼失。所以者何。眼等五根随其次第。即是火空地水风实。眼见三实。谓火地水及见于色。身觉四实。谓除其空。兼觉于触。耳唯闻声。鼻唯嗅香。舌唯尝味。故我师宗不同彼失。若尔根境有异有同。异且可然。同如彼失。眼等火等其相不同。如何五根五实为性。地水火实。异青等故。非眼所观。地水火风若体异触。应非身觉。是故汝宗亦有多过。又彼宗执眼色意我四法合故能见于色。此亦不然。故次颂曰

  眼中无色识　　识中无色眼
  色内二俱无　　何能合见色

论曰。眼色识二各别无二。非和合故。无见用生。三法合时与别无异。如何可执有见用生。有小乘说。此难不然。谁言合时与别无异。诸法一一虽各无能。而和合时相依有用。若和合位有异相生。与前不同。应非眼等。若和合位无异相生。与前既同。应无见用。若言同类有异相生。此亦不然。理相违故。类之与相其体不殊。如何可言类同相异。同异二义互相乖违。而言体一。必不应理。若眼等三能生见用。尔时见用应亦生三。不可同时有因有果。而三起见。非见起三。一刹那中彼此俱有。如何相望有因非因。又应同时无因果义。果体已有。岂复须因。若不同时应许先后。同时不立先后岂成。果时无因。果是谁果。因时无果。因是谁因。若尔应无一切因果。尚不许有。况立其无。而说种种因果不同。此世俗言。非为胜义。正破外道。兼破小乘。故此颂中唯破眼等。我或已破。故不重论。如破眼等合故见色。耳等亦应随义而破

复次耳所闻声能成名句诠表法义胜色等尘。故于此中重审观察。令知诠表俗有真无。为所闻声能诠表义。为不尔耶。若尔何失。初且不然。故次颂曰

  所闻若能表　　何不成非音

论曰。所闻与音声之异目。俱能显义。表即是诠。此中显示声不能诠。设许能诠。便失声性。以声自相定不能诠。无分别识所了知故。如余自相。又声自相定不能表。所欲说义。同喻无故。如不共因。声之共相非耳所闻。一一皆依多法成故。有细分故。如非实等。此若能诠便失声性非所闻故。犹如乐等。非离声性别有所闻。犹如色等。非声性故。后亦不然。故次颂曰

  声若非能诠　　何故缘生解

论曰。若所闻声不能诠表。不应由此名句智生。唯句与名能诠表义。故于此处不说文身。又若语声不能诠表。应同余响非义智因。若尔不应闻声了义。闻既了义应是能诠岂不意识耳识后生。依所闻声假立共相。此能诠表引义智生。意识生时。声与耳识二俱已灭。共相何依。声体既无。谁之共相。若谓念力追忆前声。心等依之假立共相。应心心法各别所缘。不随心缘应非心法。若谓共相不要依声。唯分别心假想建立。如何此相唯属于声。若言因声而得起者。耳根识等岂非此因。又耳识生不缘共相。如何定作立共相因。若言如色见已便增。此亦同疑。不可为证。若言诸法功力难思。既尔云何强立共相。若言二相同依一声自相先闻后意俱了。声相既异。体云何同。心相既殊。体亦应别。不可意识二相合缘。念唯记前所取相故。若声共相念不由闻。自相亦应不闻而忆二先别了后可合缘。别了既无。合缘岂有。是故共相非实能诠。亦非音声。定不能表。虽广诤论而理难穷。应止傍言推寻本义

复次执声与耳合不合闻。多同色破。又声与耳合故能闻。理必不然。故次颂曰

  声若至耳闻　　如何了声本

论曰。本谓说者。声起源故。若声离本来至耳闻。如何得知能发声者。既了发处声必不来。亦不应言耳往声处。用无光质。何以知行。又诠表声不可全了。所以者何。故次颂曰

  声无顿说理　　如何全可知

论曰。名句细分渐次而生。耳不顿闻。如何全了。亦不应说追念故知。念必似前具如先辨。不可离念率尔能知。应不藉闻意别能了。若尔聋者应自了声。或能说人言音无用。若言闻声次第缘力引故全了。此亦不然。次全了心不必生故。若言全了必次闻生。此亦不然。天耳通后必隔定心。方全了故。又余意识从闻声后。亦经多时方全了故。不可执有实诠表声。先耳能闻后意能了。但是虚妄分别识心。变现言音谓为诠表

复次应审推征声名何法。其体实有。是耳所闻。若尔不然。故次颂曰

  乃至非所闻　　应非是声性
  先无而后有　　理定不相应

论曰。未来声体非耳所闻。眼等五根取现境故。则未来声应非声性。非所闻故。如色等尘。若未来声与现同类。现可闻故。彼亦名声。应现在声与彼同类。彼非声故。现亦非声。又从未来流入现在。现可从彼说为非声。未来不从现在流入。如何由现说彼为声。若现可闻是声性者。应此声性本无而生。则违汝宗。先有声性。声性先有。应非始生既非始生。后应无灭。无生无灭声性应常。又过去声应非声性。非所闻故。如未来声。若未非声。流入现在。现是声故。说彼为声。应现在声流入过去。过非声故。现亦非声。若尔则应三世声性相待而立。皆非实声。又现在声从未来至得名生者。应过去声从现在至亦说名生。则过去声应名现在。后应更灭。若过去声从现在至得名灭者。应现在声从未来至亦说名灭。则现在声应名过去。后应不灭。未来无二应说为常。有灭有生应名过现。如是推征声性散坏。色等亦尔。如理应思

复次有数论者作是执言。心往境处方能了别。此亦同前根往境破。又不应说心离于根独能了境。故次颂曰

  心若离诸根　　去亦应无用

论曰。心若离根定不能了。色等诸法去亦唐捐。若不待根心独了境。盲聋等类应了诸尘。或复应无盲聋等类。此前已辨。无假重论。又养诸根心则明利。是故决定心不离根。有执内心其体周遍。用依各别往所了尘。用即是心现境行相。起即了境。去复何为。不可执言别现别了。勿现色等了声等尘。又心不应离用趣境。汝执体遍行趣何方。又不应然。故次颂曰

  设如是命者　　应常无有心

论曰。心若趣尘。体则不遍。心常往境。我应无心。然微细心身中恒有。睡眠闷等诸位常行。有息等故。梦可得故。劳倦增故。引觉心故。任持身故。触身觉故。又若内身恒无心者。如死尸等。害应无愆。供应无福。则与空见外道应同。有执心体不遍不行。但用有行亦同此过。心用心体不相离故。又若心体往趣前尘。有触内身应无觉受。应勤思虑不损内心。若执其心非自境合。应如余境。亦不能知。应一一心知一切境。或一一境一切心知。如是诸宗执实根境。皆不应理。应信非真。岂不大乘亦同此过。设许少实。此过应同若尔应无世间诸事。想颠倒故。谓彼非无想者是何。而由颠倒令谓世事是有非无。想谓想蕴。故次颂曰

  令心妄取尘　　依先见如焰
  妄立诸法义　　是想蕴当知

论曰。初心生时取青等相。如立标帜为后忆持。取越色根所行境相。故名为想。由此想故。后时能忆境相分明。虽一切心皆有其想。而果位胜故说依先。以后分明显先是有。此想妄立一切世间有情无情诸法义相。如依阳焰有水想生。诳惑自心亦为他说。由此妄想建立根尘及余世间诸事差别。为显此想依多法成是假非真。故说想蕴。又显世间法义差别。皆由想立。故说当知。岂不五识缘实有尘。随五识行。意识亦尔。想与诸识境界必同。何得定言想为颠倒。谁言诸识缘实有尘。而妄为难。故次颂曰

  眼色等为缘　　如幻生诸识

论曰。如诸幻事体实虽无而能发生种种妄识。眼等亦尔。体相皆虚。如矫诳人。生他妄识想随此发。境岂为真。根境皆虚。如先具述。此所生识亦复非真。所现皆虚犹如幻事。非诸识体即所现尘。勿同彼尘。识无缘虑。亦不离尘别有识体。离所现境识相更无。如何可言识体实有。如有颂曰

  彼能缘诸识　　非即所现尘
  亦不离彼尘　　故无相可取

有说幻事皆实非虚。咒术功能加木石等。令其现似车马等相。此相或用声等为体。或体即是识之一分。为破彼救。故次颂曰

  若执为实有　　幻喻不应成

论曰。若幻是实声等为体。如余声等应不名幻。若言幻事迅速不停。如化所为。故说名幻。此亦不然。体既实有。如余声等。何不名真。迅速不停亦非幻相。勿电光等亦得幻名。若言诳惑世间名幻。幻相非虚。何名诳惑。若言能生常等倒故。即应余法亦得幻名。又不应言幻是识分。非解了性。岂即是心。或应异名。说唯识义。应信诸法皆不离心。如何一心实有多分。或应信受识体非真。若识是真而许多分。应一切法其体皆同。若识体一而现二分。如阳焰中现似有水。则不应言幻是识分。其体实有识无二故。非所执水是阳焰分。如何喻识体一分多。若尔大乘说何为幻。我所说幻。如世共知。觉慧推寻诸幻事性。实不可得。言岂能诠。故一切法皆如幻事。其中都无少实可得。如有颂言

  以觉慧推寻　　诸法性非有
  故说为无性　　非戏论能诠

是故诸法因缘所生。其性皆空犹如幻事。若法性空而现似有。何异罥索笼系太虚。法性理然汝何惊异。世事难测。其类寔繁。为证斯言。故次颂曰

  世间诸所有　　无不皆难测
  根境理同然　　智者何惊异

论曰。如一思业能感当来。内外无边果相差别。极善工匠所不能为。是名世间第一难测。又如外种生长芽茎。无量枝条花叶根果。形色间杂严丽宛然。是名世间第二难测。又如淫女身似粪坑九孔常流种种不净。而贪欲者见发淫情。是名世间第三难测。又如花树。名曰无忧。淫女触之。众花竞发枝条垂拂如有爱心。是名世间第四难测。又如花树名好乐音。闻作乐声举身摇动。枝条袅娜如舞跃人。是名世间第五难测。又如花树名好鸟吟。闻鸟吟声即便摇动。枝条袅娜如喜抃人。是名世间第六难测。又如生上经无量生。退下生时便求母乳。腾跃嬉戏寝食贪淫。是名世间第七难测。又如欣乐无上菩提。应正勤修微妙善法。而行放逸拨法皆无。是名世间第八难测。又如厌舍迫迮居家。至道场中而营俗务。贪着财色无悔愧心。是名世间第九难测。又如净定所发神通。妙用无边不相障碍。随心所欲一切皆成。是名世间第十难测。如是难测世事无边。根境有无方之甚易。世俗故有。胜义故空。诸有智人不应惊异。为显诸法俗有真空。故于品终。复说颂曰

  诸法如火轮　　变化梦幻事
  水月彗星响　　阳焰及浮云

论曰。如旋火轮变化梦等。虽现似有而实皆空。诸法亦然。愚夫妄执分别谓有。其体实无。离妄执时都无所见。如净眼者不睹空花。无为圣智所见乃真。能缘所缘行相灭故。如是善顺契经所言。有为识心所行非实。是故根境皆俗非真。由识所行如火轮等。诸外道辈所见非真。由执有无如眩翳等。欲求圣智除妄契真。应顺如来圆净法教

大乘广百论释论卷第七大乘广百论释论卷第八

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破边执品第六

如是已辨根境皆虚。复为涤除非真句义边执垢秽。故说颂曰

  诸法若实有　　应不依他成
  既必依他成　　定知非实有

论曰。若一切法性相实有。应不依他而得成立。既色等法必依他成。如此彼岸定非实有。鸺鹠所执实等句义。有等为因而得显了。有等句义复因实等。为自所依方可了别。又色等法待自因缘。及光明等而得显现。不见少法自体为依。故色等尘皆非实有。若言相待虽立别名而此彼岸其体实有。即色等故。同喻不成。此说不然。色等相待体相无异。此彼两岸相待有殊。故此彼岸非即色等。其体非实。同喻得成。又彼所宗实等句义。若无因立。应似空花。若有因成。应同幻事。故不可执其体实有。数论宗中色等诸法。不离乐等依乐等成。乐等亦应依他而立。若不尔者。转变应无。有因无因类同前说。是故色等其体非真。复次诸外道宗执有瓶等。即色离色皆不得成。以必依他瓶等可了。如前同喻。其体非真。不可说言。瓶等即色瓶依色了。故不依他。所以者何。故次颂曰

  非即色有瓶

论曰。非即色体可立有瓶。声等亦成瓶自性故。色非声等为其自性。如何可立色即是瓶。声等亦应非即瓶体。义同色破。故不别论。又一一瓶多法为体。色等不尔。如何即瓶。色等即瓶应如瓶一。瓶即色等应如彼多。故不可言瓶。与色等体俱实有相即而成。若谓色体散时。体非瓶聚即转为瓶。亦应色体散时。体是色聚转成非色。若色聚时亦瓶亦色。是则一法应有二相。此前已破体应成多。是故瓶等非即色等。有作是说。离色有瓶。德实异故。应无此失。瓶依有等方可了知。是假非真已如前说。又不可执离色有瓶。所以者何。故次颂曰

  非离色有瓶

论曰。非离色等别有实句。瓶衣等物为色等依。所以者何。瓶衣等物若非色等。应如空等非色等依。是则应无瓶衣等物。以不共德无故如意。意必是无。非无常故。如先所破我虚空等。是故瓶等非离色等。若即若离。义既不成。瓶等皆虚。理应成立

复次瓶等色等互相依成。理俱不然。故次颂曰

  非依瓶有色　　非有瓶依色

论曰。瓶等色等体皆非实。如何定立能依所依。此中依言或表因义。欲显实德。因果不成。鸺鹠子执依瓶等因有色等果。此违比量。谓非色等瓶等为因。是色等声所诠表故。取色等心所缘境故。如色性等常故无因。数论师执依色等因有瓶等果。亦违比量。谓非瓶等色等为因。不离彼故。乐等性故。即如色等彼执色等。与其有性非即非离。非即有故。应如兔角。非瓶等因。若言色等即是有性。应同有性体无差别。若言色等乐等为性。既许体同。无斯过者。此亦不然。违汝自宗根境别故。复大过失。乐苦痴三有性亦同。应无异故。若言乐等非是有性。应如兔角。其体都无。色等亦应同彼非有。不相离故。如乐等三是即一切皆非实有。故非色等为瓶等因

复次胜论者言。彼立同性与诸法一。有斯过者。我立同性与诸法异。由相异故。应无此失。诸法相望有同有异。法体局别。所以名异。有性该通。所以名同。通局既殊。故相有异。由相异故。异外有同。若如是者。同异句义。应异性外别立有同。有同异故。如所同法。若言不尔。此同异性。境界异故。异外无同。其所同法。境界一故。法外有同。若尔诸法应有异性。所以者何。故次颂曰

  若见二相异　　谓离瓶有同
  二相既有殊　　应离瓶有异

论曰。若见诸法同异相异。即于法外别立有同。既见诸法同异相殊。应于法外别立有异。同异二相俱遍诸法。异应如同离法别有。设许法外有异有同。此复应有余同异性。如是展转同异无穷。则不可知二相差别。二皆遍故。俱无穷故。异应如同名同非异。同应如异名异非同。是故法外无别同异。又若实等与有性别。应不能知实等是有。带别相智不能审知。余别相法。前已具辨。如何世间于非有性实等法上起有智耶。若言实等虽非有性与有合故起有智者。则实等法假名为有。体非真有。应说为无。如边鄙人立餐立溺。便痢不洗。不嚼杨枝。假号为牛。非真牛犊。实等亦尔。假有真无。又汝应言。何者真有余与有合。假说有耶。若言有性是真有者。其理不然。无差别故。有与实等齐有智缘。如何可言一真一假。又真有假有应非一。智缘真假相别故。如王与王使。又言实等其体各异。有性是同。故与有别。此亦不然。实等真体亦无有异。但可功能相等有别。有性亦尔。功用有殊。云何定执有异实等。所以者何。俱所知故。并非无故。同有用故。应互相似皆异皆同。是故有性非离实等

复次今应问彼。法外有性以何为喻知实有耶。若言如一所依实等。其相各别不生数智。一数是同能生数智。法与数合名一瓶等。由相异故。实等非一有与法殊。此为同喻。若尔瓶等非一智知。体非一故。如二三等。若言瓶等体虽非一而一合故名为一者。是则此一虽非瓶等与瓶等合。应名瓶等。为显此义。故次颂曰

  若一不名瓶　　瓶应不名一

论曰。譬如一数与实等合。不名实等。如是实等虽与一合。应不名一。更互相合义无别故。世间不应名一瓶等。或复实等与一合时。为成一相。为当不尔。若成一相应捐实等。一数相非实等体故。若捐实等。一数应无。以数必依实等成故。若言实等不成一相。应非一智一言所了。虽与彼合。体非彼故。如空合人智言各别。若如槊等与人合故。虽与人异而得人名。其理不然。彼假说故。若言实等名为一者。亦是假说。理又不然。无真一故。若言一数是真一者。理亦不然。智言同故。若言一数遍该实等。实等不尔。故非真一。理亦不然。前已破故。谓不应为一智所缘。实等亦应非真有异。于实等上起数智言。既说为假。于其数上实等智言。例亦应尔。相待智言二无别故。如何可说一假一真。故立量言。所执实等非真实等。数智数言所行境故。如一二等。所执一等非真数体。实等智言所行境故。犹如实等。是故一切其体非真。又数与实曾无合时。云何乃言瓶与一合。说瓶为一。所以者何。故次颂曰

  瓶一曾无合　　瓶应无一名

论曰。实居空处一在实中。处既不同。岂得名合。则应一数不表一瓶。由处不同如二等数。若作是说。能依所依体互相遍。故名为合。此亦不然。故次颂曰

  若色遍于实　　色应得大名
  敌论若非他　　应申自宗义

论曰。若色等德遍所依实。应如实体亦得大名。地等处广既得大名。色等亦然。如何非大。又色等德应有形碍。称地等故。犹如地等。是则色等不依他成。有形碍故。如所依实俱有形碍。处应不同。实之与德应非因果。如是等类。过失众多。汝所立宗。便为散坏。若言色等德句所摄故无形碍。此亦不然。敌论非他。应申宗义。对他敌论自叙唐捐。我佛法中聪睿勇猛。见真理者。于汝所宗六种句义。如狂寱语无承敬心。徒引何益。或复色等依地等时。为一分转。犹如乐等。为遍转耶。若一分转。应一实上有德无德有青无青。如是等过。若言遍转。色等诸德应亦名大。与实处同犹如地等。实在空中德居实上。所据各别。如何处同。我意不言。同依一处。但言德实其体相遍据空量等。故说处同。德若名大。应更有德。然德无德。故不名大。敌论非他。应申宗义。对他敌论自叙唐捐。或复此中言虽难德。同实名大而意难实。同德无形以其处同。犹如色等。我宗地等。皆有形质如何同德。无形碍耶敌论非他。应申宗义。对他敌论自叙唐捐。或复色等与其果实同依因实和合而生。诸因实中果体皆遍。处无别故。德应如实。亦立大名。实应如德不立大称。若言我宗实大非德不可相类。其理不然。敌论非他。应申宗义。对他敌论自叙唐捐。或复彼宗极微量小。众微和合起粗果时。粗果与因处无别故。极微与色应成粗大。色与粗果应成极微。若言我宗因小果大色无形量。理亦不然。敌论非他。应申宗义。对他敌论自叙唐捐

如是已说有。数色等离实有体多。诸过难其同异性如有应遮共。德如数余。不共德及业差别。如色等破。于诸实中各别转故。胜论所执唯有尔所为心言因显诸法有。以理推究。皆不得成。故不应执。又说颂曰

  有数等能相　　显所相不成
  除此更无因　　故诸法非有

论曰。已辨有性数及色等不能显有自所依法。除此无有余决定因。可证诸法其体实有。不可无因立有诸法。勿有所立一切皆成。故不可言诸法实有。应随世俗假说非无。唯此无愆堪任推究。异此违越世俗己宗。鸺鹠所宗实等非有。非有性故。犹若空花。有性亦无。非实等故。犹如兔角。是故皆虚

复次数论者言。诸法不待有性数等而可了知。故先诸失于我无过。为破彼言。复说颂曰

  离别相无瓶　　故瓶体非一
  一一非瓶故　　瓶体亦非多

论曰。色香味等体相不同。别根所行非余根境。离彼诸法无别有瓶。故如色等瓶体非一。既不许一瓶体应多。一一非瓶如何多体。色等性相展转不同。岂得各成一类瓶体。若一一法其体皆瓶。共和合时。可名多体。既无此义。瓶体非多。亦不应言。瓶体实有。而不可说为一为多。兔角龟毛非实有故。岂不色等合成军林。说名一多。瓶亦应尔。此唯世俗假说军林。其中都无军林实体。若执实有。应如瓶破。汝亦不说别有军林。又色香等无共合义。故不可说和合为瓶。所以者何。故次颂曰

  非无有触体　　与有触体合
  故色等诸法　　不可合为瓶

论曰。合谓其体展转相触。此唯有触。谓地水等色声香味。非触所摄。如何相触或触触耶。既无有触。合义不成。如无触思。终无合义。若言色等有相触义。应触所摄。犹如地等则唯触体同类相合色等诸尘。定无合理。合则便失。色等性故。设许色等聚集名合。而色等性终非实瓶。所以者何。故次颂曰

  色是瓶一分　　故色体非瓶
  有分既为无　　一分如何有

论曰。色等聚集总说为瓶。色唯一分。理非瓶体。不可以瓶为瓶一分。如是声等例亦应然。一一非瓶。皆瓶分故。如是瓶分。理亦不成

有分既无。分为谁分。色等一一其体非瓶。除此更无真实瓶体。瓶体无故。瓶分亦无。岂色等尘实为瓶分。军林等物假说为有。分与有分即离难思。应随世间所见而说。不可委细推究其真。又若色等体实是瓶。一切应瓶。故次颂曰

  一切色等性　　色等相无差
  唯一类是瓶　　余非有何理

论曰。瓶衣车等所依事中。色等能依性相无别。若色等体皆实是瓶。衣等亦应皆是瓶体。即色等故。如共许瓶。或所执瓶应非瓶体。即色等故。如衣车等。色等不应同而有异。依之建立瓶等类殊。汝宗更无同异性故。不由细分安布差别。令其瓶等其相有异。同以色等为自性故。瓶等不应异于色等。违自所执因果一故。如瓶衣等有不异失。色等亦然。即一瓶故。又不应说色异味等不异瓶等。故次颂曰

  若色异味等　　不异于瓶等
  瓶等即味等　　色何即瓶等

论曰。瓶等即用味等为体。应如味等与色有异。故不可言色异味等。不异瓶等理相违故。亦不应言味等一一与色等异不异瓶等瓶等即用。色等诸法以为自体。无别性故。如是已辨色等诸法与瓶等一其义不成。今当显说与瓶等异理亦不成。故次颂曰

  瓶等既无因　　体应不成果
  故若异色等　　瓶等定为无

论曰。地等大体揽色等成。故五大因即五唯量。谓揽声量成于空大。更加触量成于风大。复加色量成于火大。又加味量成于水大。总揽五量成于地大。大望瓶等同体相成。如量能成。同类果故。若异色等。瓶等无因。既无有因。体应非果。以一切果待因成故。是故若言瓶等异色。即应瓶等非果非因。非色等故。如龟毛等。又非根境。非因果故。色根所行无非因果。此非因果根所不行。或复应无瓶等诸法。非因果故。如石女儿。自性许因思我许果。根所显故。无不定失。如是数论所立瓶等。若一若异皆不得成

复次胜论者言。瓦等细分生瓶等故。瓶等有因。既有其因。体即是果。有因是果。其体非无。此亦不然。故次颂曰

  瓶等因若有　　可为瓶等因
  瓶等因既无　　如何生瓶等

论曰。瓦等细分依余法成。何能为因生于瓶等。不见世间依他而立。非自有法能作他因。岂不种等虽依他立而能为因生于芽等。此同有难。非救前失。世所共知何容致难。汝之所执异世所知。故于此中同彼有难。世所知法。依他生已。不复重生。不依他立。由自有力。能作他因。汝执不然。依他成法乃至未灭。恒依他住。因若灭无果即随灭。故汝所执异世所知。无体无能岂生他果。或有因法有体有能。可能生他余有因法。汝执瓦等极微为因。或余为因此并非有。以无因故。瓦等体无。无体无力何能生果。彼论宗中。因有二种。俱能生果。谓常无常诸无常因。必依常立常非有故。无常亦无。无无常因。果由何有。故彼因果皆不得成

复次有作是言。瓶等瓦等诸和合物。从本以来同类因果展转相续随类不同。其体实有一而可见。此亦不然。诸和合物渐次分析归于色等。色等如前已辨非有。云何依彼有和合物。此和合物一及可见皆如前破。不应重执。又色等法共和合时无有一体。故次颂曰

  色等和合时　　终不成香等
  故和合一体　　应如瓶等无

论曰。色等合时。终不展转变成香等。故虽和合不成一体。勿舍别相失色等名。由是因缘和合一体应如瓶等。其体实无。谓如瓶等离色等法无别体故。一体不成和合亦然。非离色等有别体故。体不成一。又和合时一一细分非和合故。应如未合不合成一细分。不应各名和合。勿一合内有多合体。是故和合体非实有。又和合物必依色成。色体尚无和合焉有。色体无者。如次颂曰

  如离于色等　　瓶体实为无
  色体亦应然　　离风等非有

论曰。应知。此中四大造色俱名为色变坏相故。变坏色相大造合成故。离大造无实有性。不可此中唯一是色。勿唯此一变坏非余。又亦不应一切是色。勿一切色皆同一体。体若有殊应失色性。不可一性有众多体。勿一切法皆同一性。是故色名无实有体。唯依风等假立色名。如色体虚。受等亦尔。领纳等相推体实无。唯有世间虚假名相。若无大造。如何世间有火等物烧煮等用。又若一切皆无所有。诸所安立应不得成。我不言无诸法体用。但说汝论所立皆无。谓世所知色受等体烧煮等用。一切非无。若诸愚夫分别倒见所执体用。我说为无。非诸圣人见此为有。妄情所执都无有故

复次胜论者说。火是能烧。地是所烧。其体真实烧煮等用。亦真实有熟变色等。现可知故。今应诘问。火何所烧。为暖为余。汝应审答。并许何失二俱不然。所以者何。故次颂曰

  暖即是火性　　非暖如何烧
  故薪体为无　　离此火非有

论曰。暖非所烧即火性故。于自有用现事相违。又汝宗中所烧非暖。故不应执暖为所烧。亦不应言所烧是地。非暖性故。犹如水风薪是所烧。所烧无故。薪体非有。薪体既无。火依何立。火必依薪而得生起。所烧薪尽。火便无故。能烧所烧既并非有。熟变色等岂实有耶。故执实有能烧所烧烧煮等用。皆不应理。有说此颂不唯破彼胜论外道地是所烧。但总破言地等诸法。非暖性故。非所暖体。此说不然。非暖性故。既无同喻。应不成因。不可说言。如未烧位。地等色聚。非是所烧。于彼聚中常有暖性。异相随故。亦名所烧。苦乐等法随所依身。由火变异亦名所烧。无色界法前世下地所牵引故。亦名所烧。故非此因所引同喻。设为同喻。理亦不然。烧非烧名。唯有触物。世间共许。非余法故。此非烧名。虽通余法而局同类。如非实言。又小乘人不执实有所烧等法。何用破为。若言破彼世俗所烧。便违世间。何成比量

复次离系外道作如是言。地大极微及余果物。虽非是火而与火合。由杂火故。似暖相现。然彼地等真实非烧。异暖性故。亦非非烧。似暖相故。虽俱不可说而实是所烧。此亦不然。故次颂曰

  余暖杂故成　　如何不成火
  若余不成暖　　由火法应无

论曰。若地大等由火杂故真成暖性。应令成火。暖触摄故。如实火大。若彼火杂不成暖性。由火为因所生熟变。异触诸法亦应无有。如火不能生余暖触。若无熟变色等诸法谁能烧煮烧煮于谁。故烧煮等皆非实。有火非实能烧。触所摄故。如地大等。地非实所烧。触所摄故。如火大等。能煮所煮准此应破。故彼所执。其理不成

复次应重审问。食米齐宗诸火极微为有薪不。无且非理。故次颂曰

  若火微无薪　　应离薪有火

论曰。若火极微离薪而有。粗火同彼应不托薪。若不托薪即应无有烧煮等用。如火极微。若尔即应失于火性。无烧煮用。如地水风。不见世间有如是火无烧煮用及离于薪。故火极微必依薪有。如现见火依附于薪。或应信知极微非火。无火用故。犹若龟毛。有亦不然。故次颂曰

  火微有薪者　　应无火极微

论曰。若火极微恒与薪合应名粗火。何谓极微。于一切时与薪合故。应如粗火失极微性。地与彼合亦不成微。余亦应然。种类同故。则应决定无一极微。色法既然心法亦尔。心与心法俱生灭故。又一切法一体不成。所以者何。故次颂曰

  审观诸法时　　无一体实有

论曰。诸有为法待因缘成。积集而生。积集而灭。无有一法其体独存。于一体中复渐分析。乃至极细犹有众分。若诸法体非一应多。此亦不然。故次颂曰

  一体既非有　　多体亦应无

论曰。要先有一。后积成多。一体尚无。多体焉有。又汝执一藉缘生多。一体既无。多体岂有。一体非有。前已具论。是故定无真实多体。虽彼所执一我独存。而体周圆与多我合。又多法合一体不成。一既不成。多由何立。岂不空等独一无二。世咸共了是一体耶。世共所知。是假非实。汝所执实非世所知。如何得知空等一体。唯是假有。故次颂曰

  若法更无余　　汝谓为一体
  诸法皆三性　　故一体为无

论曰。若谓诸法更无余伴唯一独存。说名为一。空等诸法一一体上皆有三性。谓有一物。有谓大有。一谓一数。物谓物类。即实德业三中随一。故虚空等一一法上皆有三性。若不尔者。虚空等上有一智言。应不得起。由是无有一法独存。如何可言实有一体。若言有一皆表实等。故唯实等名有一物。是则有一无有一故。应不能起有一智言。若言假说无斯过者。此亦不然。前已破故。谓智言等谁假谁真。应并为真。或俱是假。又一切法其相虽殊。应得实名或德或业。是故假说。其过弥深。终不能除。一成三失。一有三性一体不成。一既不成三亦非有。是故诸法非一非多。而言一多是假非实。或有异释。一法成三。谓一法言简异非一非一极略。所谓二种。简二及前即成二性。根本法体以为第三。故一切法皆有三性。今应征问。简二取一。乃是自心分别有异。如何令法。成三性耶。又简前二弥成其一。非二非多名为一故。是则立一反破其三。何名以三而破其一。复有异释一法成三。简去来今三非有故。如无君等简异立名。此简三无故成三性。此释非理。所以者何。异类无边岂唯三种。简无立有。无不唯三。简有立名有过千数。如何但说一法成三。又相简别。唯在自心。或在名言。何关法体。是故此释于破无能。复有释言。常先已破。今此唯破执有无常。所执无常皆有三性。谓生住灭。显在诸经。此亦不然。生住灭相。时分各异。如苦乐舍必不同时。时既不同。体相亦别。何名一法其性有三。又若说生无间即灭。应言二性。何得论三。又生灭时前后各异。如去来世不名一法。如何难言一法二性。是故此释理亦不成。复有释言。诸有为法极于一念。于一念中有多刹那时分性故。如腊缚等。言三性者。显性非一。不唯有三。此亦不然。时分前后非一法故。如何可说一法有三。是故如前释为最胜。诸法一一非一非多。随世俗言有多有一。世俗诸法随世俗情。假立为有。不任推究。诸有智人于世俗法。应随说有勿固寻思。若有寻思世俗诸法。求其性相不异有人。手执灯炬入于闇室。求闇性相。所以者何。世俗诸法犹如幻闇。众缘所成不任思求。求即散坏

复次为显世间所执诸法皆非真实。及显外道所执不同。故次颂曰

  有非有俱非　　一非一双泯
  随次应配属　　智者达非真

论曰。一切世间色等句义。名言所表。心慧所知。情执不同。略有四种。谓有非有俱许俱非。随次应知。配四邪执。谓一非一双许双非。数论外道执有等性。与诸法一即当有句。此执非真。所以者何。若青等色与色性一。应如色性其体皆同。五乐等声与声性一。应如声性其体皆同。香味触等类亦应尔。眼等诸根与根性一。应如根性其体皆同。应一一根取一切境。应一一境对一切根。又一切法与有性一。应如有性其体皆同。又乐苦痴及与思我。与有性一。应如有性其体皆同。是则汝宗所立差别皆不成就。故彼所执决定非真。胜论外道说有等性。与法非一当非有句。此亦非真。所以者何。若青等色与色性异。应如声等非眼所行。声等亦然。异声等性应如色等。非耳等境。又一切法非有性者。应如兔角。其体本无。是则应同空无我论。或同余道邪见师宗。岂不有性非即诸法。法虽非有而有有耶。所依法无。能依岂有。又有性上无别有性。应不名有所余诸法。虽有有性非有性故。其体应无。是则一切所立句义。皆不得成。便同拨无邪见外道。故彼所执决定非真。无惭外道执有等性。与彼诸法亦一亦异。当于亦有亦非有句。此亦非真。所以者何。若有等性与色等一。同数论过。与色等异。同胜论失一异二种。性相相违而言体同。理不成立。一应非一。即异故如异。异应非异。即一故如一。一异既不成。有非有焉立。一异相异而言体同。则一切法皆应无异。异相既无一相何有。一异二相相待立故。若谓一法待对不同名一异者。即应一异二并非真。或随一假一法二相。互相乖违。俱言是真。必不应理。故彼所执决定非真。邪命外道执有等性。与彼诸法非一非异。当于非有非非有句。此亦非真。所以者何。若有等性与法非一。同胜论过。与法非异。同数论失。又一异相世共知有。汝独拨无违世间失。又汝所说非一异言。为但是遮为偏有表。若偏有表应不双非。若但是遮应无所执。有遮有表理互相违。无表无遮言成戏论。汝执诸法性相非空。而说双非。但为避过此双非语。亦不应论。违汝所宗法性相故。若诸法性一一俱非。此俱非言亦不应说。举言必有俱非性故。是则汝曹应常结舌。发言便坏自论所宗。默亦不成。以俱非故。语默俱失。一何苦哉。谁有智人而不悲愍。故彼所执决定非真。如是世间四种外道。邪论恶见扰坏其心。虚妄推寻诸法性相。皆不中理竞执纷纭。于诸法中起四种谤。谓有非有双许双非。增益损减相违戏论。是故世间所执非实

复次外道余乘弊魔恶友邪论恶见扰坏其心。于其世间虚伪诸法。种种思构妄执为真。于相续假谓是真常。积集假中执为实有。为显此义。复说颂曰

  于相续假法　　恶见谓真常
  积集假法中　　邪执言实有

论曰。有为诸行前灭后生。无始时来展转相续。生灭变异微细难知。因果连绵其状如一。愚夫恶见谓是真常。邪执纠纷递相诽斥。色等诸法恃托因缘。虚假集成都无实体。微细积聚密合难分。众分和同冥然似一。愚夫僻执言有实体。各据一途互兴诤论。又于相续积集假中。不达诸门分位假有。横计种种义类不同。执一法中有多实性。如是所迷自性差别。皆由恶见邪执而生。缘此轮回诸趣诸有。备受众苦未有出期。是故应除恶见邪执。信解诸法因缘集成。是假非真。无颠倒理

复次为显诸法众缘所成。非一非常无我无法。犹如幻化。情有理无。是俗非真。复说颂曰

  诸法众缘成　　性羸无自在
  虚假依他立　　故我法皆无

论曰。诸法虚假众缘所成。起住依他体无自在。念念生灭众分集成。非一非常犹如幻化。愚夫执有。智者达无。故于其中无我无法。一切外道及所余乘。计一计常为我为法。一常非有我法定无。故辨缘成显二无我

复次有作是言。字名句合诠表自心。所欲说义一一各别。虽不能诠而和合时。能有所表。若义非有。诠亦应无。既有能诠。定应有义。为破彼执。故次颂曰

  果众缘合成　　离缘无别果
  如是合与果　　诸圣达皆无

论曰。此颂意言。诸无为法非缘成故。犹若空花。体用都无。如前广说。诸有为法众缘所成。如幻所为无实体用。缘合成果果不离缘。如树成林林非异树。揽缘成果顺世俗言。胜义理中无如是事。故诸圣者了达皆无。所以者何。名之与句并字所成。字复揽于众分为体。字一一分多刹那成。前后刹那无和合义。要前念灭后念方生。生有灭无其理决定。无之与有合义不成。前后二时有亦不合。时分异故。犹如去来。合义既无。字分焉有。尚无字分。字体岂成。字体既无。名句非有。无字名句。合义不成。如何可言字名句合能诠表义。然诸世间随自心变。谓有众字和合为名。复谓众名和合为句。谓此名句能有所诠。能诠所诠皆自心变。诸心所变情有理无。圣者于中如实知见。云何知见。谓见彼法皆是愚夫虚妄识心分别所作假而非实俗有真无。随顺世间权说为有。是故一切能诠所诠。俗有真无不应固执

复次于诸所缘空无我见。能速成办自利利他。所以者何。愚夫于境执我我所。生死轮回。圣者于中达空无我。速证常乐。能巧利他。是故应修空无我见。令自利满妙用无穷。为显此见是利自他正真要道。故说颂曰

  识为诸有种　　境是识所行
  见境无我时　　诸有种皆灭

论曰。识能发生诸烦恼业。由此三有生死轮回。故说识心为诸有种。能牵后有得识食名。如是识心缘色等起。无所缘境识必不生。若能正观境为无我。所缘无故能缘亦无。能所既亡众苦随灭。证寂无影清凉涅槃。至此位时名自利满。诸有本愿为利益他。住此位中化用无尽。亦令有识证此涅槃。是故欲求自他胜利真方便者。应正勤修空无我见。复有别释。识为诸有种者。谓宅识中种种熏成诸业习气无明有爱所随增故。能感三有生死轮回。识为所依。故说为识。境是识所行者。识中习气由执色等境界熏成随缚境界。是所依故。名曰所行。见境无我时者。谓无我见观一切境性相空时。诸有种皆灭者。由无我见永断一切无明有爱二种随眠。由此二种是发业因。及能润业令生果故。断此二种业果不生。尔时所有诸戏论事及烦恼事。种子俱断。故名皆灭。非一切种识等皆无。所以者何。由圣道起但灭一切虚妄分别戏论习气。令有漏法毕竟不生。一类有情。诸无漏法无所依故。亦皆断灭。一类有情。由本愿力所任持故。无漏诸识相续不断。能为殊胜广大甚深无碍辩等无边功德所依止处。又由识等增上力故。圆满究竟神通作用。穷未来际任运相续。如是皆由本愿行力所引发故。自利利他功德无尽。令诸有情成熟解脱。尽未来际妙用无穷。是故应修空无我观舍诸边执

大乘广百论释论卷第八大乘广百论释论卷第九

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    破有为相品第七

复次已别分别根境无我。今当总辨有为相空。谓色心等诸有为法。具生住灭三有为相生为首故。先当破生。生相既亡。住灭随遣。有说果体本无而生。为破彼言。故说颂曰

  若本无而生　　先无何不起

论曰。种等诸因至变坏位。能引芽等诸果令生。若诸因中本无诸果。何故芽等此位方生。后位如先果应不起。先位如后果亦应生。又从此因应生彼果。或应此果从彼因生。若此彼因无彼此果而不生者。彼此因力应亦不生同本无故。若尔一切因果皆无。便违自宗所说因果。有说果体本有而生。为破彼言。复说颂曰

  本有而生者　　后有复应生

论曰。若诸因中本有诸果。何故芽等后不更生。后位如今。果应更起。今位如后。果不应生。又果本来因中有体。何故此位乃说为生。若言今时方得显者。显不离体应本非无。今位如先亦应不显。先同此位显应非无。显本非无今复显者。后应更显。是则无穷本有与生义相乖反。言果本有。生必不成。既无有生。果义便失。果义既失。便无有因。则违自宗有因果义

复次果先无论作如是言。果或违因。故非并有。此言非理。故次颂曰

  果若能违因　　先无不应理

论曰。胜论者说。果或违因。或不违因。果违因者。合违于业。合果后生。前业灭故。又相违法略有二种。一能障碍。二能坏灭。后谓合德灭坏业因。初谓合德障碍重等。令其所起坠等业无。如是合德其体未有。应不能违先所起业。世间未见无体能违。汝不应言。合德与业如囚与脍。俱有相违。勿违自宗。因果不并。若许一念业与合俱。后亦应然。无差别故。便违自论及世共知。故不应言。果先非有

复次果先有论作如是言。一切因中果体先有。此亦非理。故次颂曰

  果立因无用　　先有亦不成

论曰。数论者说。一切因中果体先有。此亦不然。生果显果。故说名因。果体本来已生已显。因便无用。所以者何。体与显生不相离故。应如其体从本非无。本有显生因义非有。因非有故。果义不成。便违自宗。立有因果

复次诸法生时义不成故。不应定执诸法有生。所以者何。故次颂曰

  此时非有生　　彼时亦无生
  此彼时无生　　何时当有生

论曰。果已有时。其体有故。如本有法。应不名生。果未有时。其体无故。如定无法。亦不名生。又诸果法用起名生。其体既无。用依何立。又能生果。故说名因。果体既无。因何所起。既无所起因义不成。因义不存果从何出。除此二位更无生时。故定无生如虚空等。又若执法体恒是有。定不名生。无所起故。用虽有起。此在未来。无故非生。现在已有。自宗不许。除此二位无别生时。是故无生其理决定

或胜论执多实为因。积集共生一合德果。阙众缘时未有合德。由是故说。此时无生。具众缘时。已有合德。由是故说。彼时无生。以初合时合体有故。应如后位不得名生。后位已生。不重生故。可不名生。初位不然。名生何咎。后若不生果应违实。而汝不许。果实相违障破相违合德违业。不违于实。前已略明。除此彼时更无异位。是故合德决定无生。如是色等依托实因。实未有时果体未有。由是故说。此时无生。实已有时果体已有。由是故说。彼时无生。以初有时色等有故。应如后位不得名生。离此彼时更无别位。是故色等决定无生。如是合德障碍重等。令其不生坠堕等业。此能障体有时无时。彼业不生。准前应说。离有无时更无异位。故坠等业决定无生。或数论执。乳等因变成酪等果。故说名生。因体有时因性未变。由是故说。此时无生。若于尔时因性已变便失因性。应不名因。果体有时因即成果。由是故说。彼时无生。若于尔时果体生者。应异法起非即因成。除此彼时更无异位。是故酪等决定无生。自性等因成大等果。准此推究。皆非有生

复次所生无故生义不成。所以者何。故次颂曰

  如生于自性　　生义既为无
  于他性亦然　　生义何成有

论曰。说常有宗色等五蕴。数论外道乐等三德。诸法生时不令自性有变异故。生义不成。法未生时。一切生用皆未有故。生义不成。诸法生时。不令他性有变异故。生义不成。诸法生已。一切生用皆已息故。生义不成。不可说言色等乐等相用有变故说名生。以于生时性与相用。若一若异过等违宗。亦不可言色等乐等自性有变故说名生。勿于生时色等乐等变成受等苦等自性。有作是言。果先有论。有前失故。生义可无。果先无论。因缘和合果体将成。生义应有。果将成时其体未有。如何可说果从缘生。知因有能当成果体。如言煮饭故说果生。若尔生名应假非实。色等生时犹未有故。如是假说理亦无违。以生时无后方见故。若尔见位乃可名生。以于见时方说生故。如何不了言理而问。虽见时说非见时生。说因见生非因生故。何故生时无有此见。以见无故。知生时无。如何不知义理而答。岂不见无名为无见。何得以问而作其答。若尔应有问答无穷。无见见无。言无尽故。又亦不可说无为生。无似空花违生理故。至现有位亦不名生。有似无为违生理故。所生无故。生义不成。复次执有生者。作如是言。果有三时。前后差别将成作用。及究竟时显彼不成。故次颂曰

  初中后三位　　生前定不成

论曰。果先无论。于未生时三位不成。无无别故。初中后位依有而彰。未生体无如何可立。或应许果未起非无。见彼三时唯依有故。果先有论。于未生时三位不成。有无别故。有体无别相用未兴。如何可言三时有异。又此三位既不同时。生亦不成。故次颂曰

  二二既为无　　一一如何有

论曰。初中后位相待而成。二二既无。一一岂有。亦不可说三位同时。初中后名依时立故。又不可说三时并有。勿有此三相杂乱过。汝亦不许三位同时。故有一时三定非有。若言觉慧于色等法。观二二时立一一位。是则三位假有真无。违汝师宗三时实有。是故三位唯假非真。不应定执果有三位

复次色等诸法决定无生。能生因缘不成立故。生者决定从自从他从俱因缘。三皆不可。为显此义。故说颂曰

  非离于他性　　唯从自性生
  非从他及俱　　故生定非有

论曰。一法一时自为因果。理不成故。非从自生。若一体中有二相别。说为因果。自义不成。自言遮他。显于自相果从因起。何谓自生。又体如相应不成一。相如其体应不成二。是故所言一体二相。说为因果。理必不成。又自生言依义生不依义生者。则非自生。不依义生。便同树响何能定表。诸法自生。又自生言依慧生不依慧生者。则从他生。不依慧生。应同狂醉言无根系。难可信依。又自生言生他解不生他解者。便失自宗。他解不生发言无益。何缘强立自生论耶。现见世间法从缘起。言自生者。与此相违。又若自生应违世法。刀不自割。针不自缝。又自生言依汝生不依汝生者。非谓自生不依汝生。应非汝说。哀哉愚昧不识自言。又言自生同无因论。拨无一切生果因缘。有作是言。自不生自生时无故。如已灭无。若言生时其体已有。应如现在生用唐捐。体显名生。亦不应理。显与体异便失自生。显与体同显应本有。显若本有生用应无。故自生言定不中理。言从他起。理亦不然。以法生时自体未有。既无有自熟对名他。因缘名他。对于自果。自果未有。他义不成。若言生时自果已有。因缘无用非谓他生。显故名生。亦不应理。显不离体应本非无。又因名他对异于果。果异因故。应亦名他。因果俱他。便无有自。自非有故。他亦应无。从他生言便无有义。又慧观果说因为他。果之与因必不俱有。因时无果。谁藉他生。果时无因。从谁他起。岂不以慧观后观前。说从他生言无有失。谓观当果或念过因。因果俱成犹如父子。假名可尔。理实不然。因果异时有无不并。如何可执实从他生。如父子言。亦不应理。世间父子多有同时。虽复一无而可假说。因果不尔。法喻岂同。若谓先时于异体物。以慧观察取其异相。次于因果观后念前。建立自他二相差别。后发语时不触前二。但随想说法从他生。故法喻同无前过失。此救非理。所以者何。异物同时无因果义。因之与果必不同时。父子不然。何得为喻。又若假说此义非无。汝执为真。故不应理。若言何为咀嚼虚空。现见因缘能生于果。果相异彼。说彼为他。何假繁词。固相征难。随意勿说。他与非他。必有能生所生差别。此足为喜。何藉多言。言随欲生。无劳穷诘恣汝常喜熟与相遮。忧喜自心妄想生故。汝言必有能生所生。为假为真随汝意答。若言是假违汝所宗。若言是真。难诘何咎。所生未有对何能生。能生已无所生何对。故就胜义他生不成。依世俗论徒言无益。夫兴诤论为见不同。举世咸知。何劳泛说。故不应执定从他生。自他俱生。亦不中理。如前二失。积在汝宗。别既不成。总如何立。由是诸法决定无生。自他俱生皆非理故

复次能生所生同时前后。俱不应理。故定无生。所以者何。故次颂曰

  前后及同时　　二俱不可说
  故生与瓶等　　唯假有非真

论曰。若所生法在能生前。既离能生所生何有。此所生法设离能生。是则能生便为无用。若所生法在能生后。无所依止何有能生。设离所生能生何用。又此二法若不同时。能是谁能所为何所。若所生法与能生俱。生既同时。应不相待。如牛两角互不相依。应无能生所生差别。所生未有能生亦无。所生有时能生何用。如是二法前后同时。理俱不成。故生非有。随俗说有。能生所生不可推征。时分同异。复次执果有生必依新旧。新旧无故生不得成。由二俱非诸法自相。互相违反必不同时。设许同时应离法有。若离法有谁旧谁新。汝不应言异体相表。现见法外无旧无新。亦不应言同体俱有。更相违故。如善恶心前后亦非。故次颂曰

  旧若在新前　　前生不应理
  旧若居新后　　后生理不成

论曰。现见世间前新后旧。不应蔽执前旧后新。要前有新后转成旧。旧若前有新则为无。新名前生旧名后故。新若无者旧亦应无。新旧既无生依何有。旧居新后。理亦不然。法新起时既无有旧。体无别故。后亦应无。若言后时别生旧体。是则新起。何谓旧生。后生婴孩赤色未变。而名耆旧。理必不然。若法初生而名旧者。则一切法毕竟无新。新既为无旧亦非有。旧必以新为前导故。若谓诸法念念别生。恒名为新。都无旧者。旧既非有新亦应无。简旧名新旧无何简。所简无故。能简亦无。是故不应执有新旧。既无新旧生岂得成。然诸世间见有为法。相似相续谓为一体。前盛后衰说为新旧。圣随彼说有旧有新。依此立生假而非实

复次果体若生。必依过去未来现在因体而生。然皆不成。故次颂曰

  现非因现起　　亦非因去来
  未来亦不因　　去来今世起

论曰。现在果法非现因生。因果同时理不成故。虽形影等因果同时。是假非真随俗而说。去来二世已灭未生。体相是无因用非有。又现在法体相已成。岂更藉他三世因起。未来果法不因去来。已灭未生无因用故。岂不现在将欲灭时。有体为因生未来果。未来无体生何所依。若言未来生时有体。应名现在。何谓未来。汝不应言生即是有。亦不可说有即是生。有若即生。生应现在。生若即有。有应未来。有在未来。未来应现在。生居现在。现在应未来。则违汝宗世相揩定。亦违自说生在未来。故不可言现在将灭。为因引起未来果生。生时有无皆有失故

复次有说。未来体相具有。由此生用得有所依。生迁未来令入现在。灭迁现在令入过去。为破彼言故说颂曰

  若具即无来　　既灭应非往

论曰。犹如现在。体相具故。未来不应来入现在。或应未来。非现等故。体相不具。犹若空花。又应未来非现在故。犹如过去不入现在。又若未来体相已具。应无生用。犹如现在。或未来世生用应无。以非现在犹如过去。色等诸法虽居现在。定当灭故。亦名为灭。此现在法不往过去。时定异故。犹如未来。又现在法应如过去。不往过去。由非未来。又过去时。非现所往如未来等。世所摄故。现在亦非。未来所入。世所摄故。犹如未来。过去未来。非现等故。应如兔角体相俱无。未来体无。生依何有。故不应执色等果生。生既是无灭亦非有。但随俗说有灭有生。似有而无。犹如幻等。为显此义。复说颂曰

  法体相如是　　幻等喻非虚

论曰。色等诸法。前后际无。现不久停。犹如幻等。又色等法。若从缘生。如幻所为。皆非实有。非缘生者。皆似空花。性相俱空。不应言有。法既非有。生等定无。如何可说。生迁未来令入现在。灭迁现在令入过去

复次生住灭相前后同时。理俱不成。故不应执。所以者何。故次颂曰

  生住灭三相　　同时有不成
  前后亦为无　　如何执为有

论曰。一体一时有众多相。互相违反理必不成。若执同时体应各异。既执体一。应不同时。执不同时。亦不应理。所相体一。如何异时。法体生时住灭未有。至住灭位生相已无。而言体同。极为迷谬。若言前后相异体同。善恶色心体应是一。然舍前相后相起时。体与相同。应有舍得。如何可执前后体同。三体不同。亦不应理。以生住灭遍诸有为。三体如何各唯一相。许各一相。理亦不然。灭体无生应非因起。生体无灭应性是常。住无灭生应非蕴摄。若许一一。复有三相。有如前过。或复无穷。同时前后。三相不成。更无异途。如何执有

复次若离所相别有生等。应如色等有生等相。则生等相应无异体。所以者何。故次颂曰

  若生等诸相　　复别有生等
  应住灭如生　　或生住如灭

论曰。若生等相自所依俱。如自所依别有生等。此生等相幖帜既同。其体如何。展转有异。若言生等如色等法。虽生等俱而体有异。碍等相别。体异可然。生等相同。体如何异。生等作用既有差别。应如色等其体各异。此因不定如眼等根。用虽有多。而体一故。用有差别不可例同。眼等用殊时同故体一。生等用别时。异故体多。生等何缘用时有异。自体俱起不待异时。作用如何待时有异。住灭二相初既用无。后亦应然。体无别故。或复生等同与法俱等有生故。应互相似。一一皆有他诸作用。或自作用一一皆无。是故不应别有生等

复次色等诸法与生等相其体为异。为不异耶。异且不然。故次颂曰

  所相异能相　　何为体非常

论曰。色等诸法若异生等。如择灭等应无生灭。不应观彼皆是无常。观彼无常应成颠倒。若言色等与生等合。虽观无常而非颠倒。如名杖角以作人牛。此不应尔。异生等故。应似无为。非生等合。色等生等。体相若异。如何以一心慧而观。谓色等生色等住灭。故色等法非异生等。不异亦非。故次颂曰

  不异四应同　　或复全非有

论曰。若色等法不异生等。应如生等析一成三。生等亦应混三成一。与色等法体不异故。或生等相各失自体。与其住等体不异故。色等亦然应失自体。与其生等体为一故。是则应无所相色等。所相无故能相亦无。则无有为。无为亦尔。相待立故。一切应无。故色等法非异生等

复次因果有无皆不可立。生依彼故。亦不得成。所以者何。故次颂曰

  有不生有法　　有不生无法
  无不生有法　　无不生无法

论曰。有生有法义不得成。生有同时。递相违故。有生无法亦不得成。如已灭无。非所生故。无生有法理不得成。如未生无非能生故。无生无法亦不得成。如前二无非因果故。或二无法因果不成。如毕竟无非因果故。如是已破因果异体。为破同体。复说颂曰

  有不成有法　　有不成无法
  无不成有法　　无不成无法

论曰。有成有法。其理不成。有法已成。成无用故。成复成者。成则无穷。若成异相。其体应别。相异体一。理必不然。相与其体不相离故。有成无法。理亦不成。其相异故。如苦乐等。或复有无应无差别。有无体一。与理相违。无成有法。其义不成。如有成无所说过故。无成无法。义亦不成。如前有无相成过故。或复无者。即是数论所执自性。不依他成。虽有隐能而无显体。依彼所执故说为无。如是有无因果同异。皆不成故。决定无生

复次已生未生。生用已灭及未得故。俱无有生。除已未生。有生时体不可知故。亦无有生。若言生时二半为体。谓生半分。半分未生。此亦不然。故次颂曰

  半生半未生　　非一生时体
  或已未生位　　应亦是生时

论曰。半生未生非生时体。生未生故。如已未生。如已未生有二相别非生时体。生时亦然。有生未生二种相异。如何可立为一生时。或应已生及未生位。亦共合说为一生时。有生未生二相异故。如汝所执半生未生。此显生时已未生位。皆失自性。故定无生。岂不生时具有二相。已生半分半分未生。已生未生各有一相。如何可难令互相成。一一别观可生时异。总观二相岂异生时。若言生时体一相二。已未生位体二相殊。故已未生与生时异。如何体一二相相违。相既不同。体应成二。非一有分从二分生。勿违生时。二半为体。若半已起名作生时。半既未生应名未起。又半生已生用已无。半复未生生用未有。如何二半合立生时。若生用无名生时者。已未生位应名生时。便失自宗三位差别。故离二位无别生时。生时既无二位非有。是故诸法决定无生

复次应问。迷徒生时。自性为因缘起。为是自然。初且不然。故次颂曰

  生时若是果　　体即非生时

论曰。若生时体从因缘生。即非生时。已有体故。未来将起故名生时。未来体无。说谁为果。若言此位观待当来。至现在时名为果者。亦应说近。何立远名。如是生时非已生故。如未生位非实生时。又此生时时远摄故。如已灭位。何谓生时。若言生时体虽未有。众缘会故已得近名。同是未来。体俱非有。余远此近差别何缘。亦违汝宗去来皆远。故汝所执但有虚言。后亦不然。故次颂曰

  生时若自然　　应失生时性

论曰。若生时体非因缘生。应是无为失生时性。若非缘起得名生时。一切无为应生时摄。又非缘起应类空花。体既是无。岂生时摄。若体非有名作生时。即一切无。应生时摄。是故诸法无实生时

复次有作是说。若无生时。已生未生亦应非有。生时已过未至生时。建立已生未生二位。生时无者二位亦无。又无生时二位应合。故有二位。中间生时。为破彼言。故次颂曰

  已生异未生　　别有中间位
  生时异二位　　应别有中间

论曰。若谓已生未生不合。由生时位隔在中间。若无生时二位应合。如两界首必有封疆。是故生时定应有者。生时二位应有中间。未生生时。生时生已。更相异故。如是中间复有中间。展转增长有无穷过。过无穷故。难立生时。又已未生种类别故。如色声等无别中间。既无中间。生时何有。又生时位若在未来。即名未生。未来摄故。若居现在。即名已生。现在摄故。若非现未不名生时。如过去等。是故诸法无别生时

复次假许生时已未生位三分各别。而审推征。为舍生时得已生位。为当不舍得此位耶。初不应然。故次颂曰

  若谓生时舍　　方得已生时
  是则应有余　　得时而可见

论曰。若舍生时得已生位。未得已得两位中间。应有得时如生时位。若许尔者。余复有余。如前生时有无穷过。过无穷故。难立得时。若舍生时得已生位。离此二位无别得时。从未生时至已生位。应离二位无别生时。又舍生时得已生位。体应有异。非一法生。后亦不然。故次颂曰

  若至已生位　　理必无生时
  已生有生时　　云何从彼起

论曰。已生生时必不俱有。时分异故。犹如去来。若已生位有生时者。或应同体。或异体俱。则非已生从生时起。自从自起。世现相违。俱有非因。如牛两角。若言一体二相不同。得说为因无斯过者。二相前后体不应同。二相俱时应非因果。又若同体生时已生。于自他性应失应得。相不离体。如体应同。体不离相。如相应别。体同相别。理必不然。法之与时体无有异。故不可说时异法同。一法一时有同有异。说为因果。理必不成。如从生时至已生位。进退征责过难多途。从未生时至生时位。研核诘问如理应思。是故生时非别实有

复次立有生时已生位别。此无实义。但有虚言。所以者何。故次颂曰

  未至已生位　　若立为生时
  何不谓无瓶　　未生无别故

论曰。若立生时非已生位。将至此位名作生时。瓶名已生。生时未至。已生位故。瓶体定无。瓶体既无。生依何法。不可无法名作生时。勿一切无皆名生位。故应于有立生时名。若谓生时其体已有无斯过者。此亦不然。未至已生与未生位无差别故。有义不成。若谓生时是未来世。最后位故非体全无。此不应理。同未来摄等非已生。无前后故。若未来世。半有半无。有同已生。世应杂乱。故生时位。但有虚言。生时既无。生亦非有

复次若谓生时体虽未满。而用起故非是全无。非有非无不同两位。是故诸法别有生时。此亦不然。故次颂曰

  非生时有用　　能简未生时
  亦非体未圆　　别于已生位

论曰。未生生时无用有用。二位差别。理不可然。生时体无。用应非有。生时体有。应是已生。设许生时有能起用。而体未有。应名未生。非未生名别有少法。但遮已起名未生时。既名未生。何能简彼。若少有体。应名已生。既非已生。应无少体。不可一法半有半无。有无相违不同体故。若许体别。有即已生。无即未生。生时岂有。故离二位无别生时

复次或应生时即已生位。非无有故。如已生时。为显此因。故说颂曰

  前位生时无　　后位方言有
  兼成已生位　　故此位非无

论曰。未起用时名为前位。于此前位未有生时。正起用时。名为后位。于此后位方有生时。是则生时成已生位。有异前故。如已生时。非体全无。可与前异。所言兼者。谓舍全无。即未生时。名全无位。生时舍彼。是有非无。由此兼前成已生位。若舍无位必至有时。有即已生中无异位。依何而立别有生时。是故生时即已生位。非无有故。如已生时。又此生时应许有体。若无有体生用应无。体用并无。生时岂有。若无体用而有生时。则一切无。皆应顿起。无无异故。如此生时。又若生时体用非有。因缘和合应无所为。有不生无。如前已说。故生时位是有非无。有即已生。更无异位。故不应立别有生时

复次无别生时理应信受。愚犹固执。略复推征。如是生时为无为有。有即已起。无即未生。除此孰为生时位体。为显此理。复说颂曰

  有时名已生　　无时名未起
  除兹有无位　　谁复谓生时

论曰。所执生时推征其性。不过二种。谓有及无。如是有无二位所摄。除此无别中间生时。汝等何缘非理横执。此极粗浅。而汝尚迷。况复幽微。汝能思测。故应信受无别生时。生时既无。生如何有。是故诸法理实无生。生既实无。住灭亦尔。生为先故非有义成。故不别遮住灭二相

复次已别广破果先有无。为总略遮果先有等。故于品后。复说颂曰

  诸有执离因　　无别所成果
  转生及转灭　　理皆不可成

论曰。数论所执。果不离因。果同其因。体本实有。如是果体生灭不成。果不离因同因常故。因果体一差别理无。诸法性常无增无减。是则所作唐设其功。少有所为便违自论。有不可灭无不可生。大等亦应无生灭义。即自性故。如乐苦痴。又大不应从自性起。自能起自。世现相违。是则世间现见因果。生灭作用一切皆无。世现所知。汝尚诽毁。况能信受深隐义耶。如是观生都非实有。生无实故。灭亦实无。但随世间说有生灭。随世所说是俗非真。胜义理中无生无灭。一切法性非断非常生灭既无。法应常住如前广破。常性实无。若尔应无一切法性。不尔我说俗法非无。岂不我宗说一自性。转变力故无所不为。虽有所为而无生灭断常等过。所以者何。果起不生性变成故。果谢不灭归本性故。果性非常前变灭故。果性非断后变生故。转变非恒。故非定有。自性不易。故非定无。此亦不然。诸法生灭理既不立。汝宗所执转变岂存。又转变言及自性等。前已广破。无宜重执。故汝所说理必不然。有作是言。我经部等。因缘和合无间果生。果起酬因复能生后如是展转。无始时来。因果连绵相续不绝。无有生灭断常等过。所以者何。相续无始。故无有生。未得对治相续不尽。故无有灭。相续改转。所以非常。相续连绵。所以非断。非一性故亦非转变。此亦不然。若有生灭可有相续。生灭既无。相续何有。无生灭义。前已广论。相续有终。是则为断。相续无始。是则为常。相续体一。即有转变。故立相续。过失弥多。有作是言。我说诸法常有部等。一切有为。从本以来性相实有。酬前起后三世迁流。无有断常生灭等过。所以者何。体恒有故。无生无灭。有为相合。所以非常。果起酬因。所以非断。念念别故。非变非续。此亦不然。说常有宗先已破故。色等诸法体若恒有。应似无为离有为相。便同数论一切皆常。不可说言用有生灭。用不离体应同体常。体不离用。应非恒有。若用本有。应不名生。若用本无应非可起。用未生位生用未有。不可名生。用已生位。生用已息。亦不名生。除此二位无别生时。前已广说。故不可执。诸法用生。生既是无。灭亦非有。又若色等有为相合。故是无常。此有为相无余相合。应非无常。若言此相与余相合。是则无穷。若言有为有大小相。展转相相非无穷者。此亦不然。如色等法。余相合故。不名能相。生等亦然。与余相合。应非能相。又如大相。不以所相色等诸法为其能相。小相亦尔。不应所相大生等法以为能相。若别有相应至无穷。若别无相。应成常住。又有为相定非实有。若实有者。与理相违。所以者何。如无为法。有无为相。离法实无。此亦应然。同三相故。无为实有。前已广遮。一切有为亦非实有。以慧分析便归空故。又对无为立有为法。无为无故。有为亦无。有为无为若从缘起。即同幻事。若不藉缘便似空花。故不应执以为实有。如契经言。有为无为皆是世俗。分别假立其体俱空。除为无为。更无别法设复说有。但是虚言。有为无为摄一切法。此二空故诸法皆空。空中都无分别戏论。虚通无碍即圣慧明。故契经言。一切诸法从本皆空。空即无性。由无性故。即是般若波罗蜜多。其中都无少法可说。为生为灭。为断为常。为一为异。为来为去。天帝当知。若有净信诸善男子或善女人。能如是说。不谤般若波罗蜜多。异此说者。皆名为谤。若说常空应堕断灭。遮常有故。不堕此边。执常不空应堕断灭。常无因果名断灭故。我诸所说皆是遮言。遮谓遮他生灭等执。无生非灭。唯为遮生。无灭非生。但为遮灭。非断常等。类此应知。虽涅槃时生死断灭。此方便说是假非真。如说天中有常乐等。是随俗说。非称实言。应以前说诸句文词随其所应破诸妄执。我等皆妄。谁复为真。谓毕竟空心言路绝。分别戏论皆不能行。唯诸圣贤内智所证。是故智者应正勤修。证此真空舍彼妄执

大乘广百论释论卷第九大乘广百论释论卷第十

        圣天菩萨本　护法菩萨释

        三藏法师玄奘奉　诏译

    教诫弟子品第八

复次正论已立邪道伏膺。于密义中尚余微滞。以净理教。重显真宗。遣彼余疑。故说颂曰

  由少因缘故　　疑空谓不空
  依前诸品中　　理教应重遣

论曰。虽一切法本性皆空。而初学徒未能见故。追爱妄有怖达深空。或为余缘未能决了。以正理教重显前宗。令彼除疑舍诸倒执。既一切法本性皆空。未达此空。以何为性。诸法无我。此复云何。谓无自性应正晓示。何假转音正示无由。以无体故。但可假说。诸法无我无性可取。故名为空。如契经言。空名诸法。无我无性无执无取。胜义理中。都无少法有我有性可说名空。若尔空名应不可说。实不可说。但假立名。如说太虚。虽无自性实不可说。而假立名。空既离言。有应可说亦不可说。实无体故。如说诸法实性都无。无性理中无二无说。若尔说者言及所言。一切皆空。今应无说。既有所说。应不皆空。为显此疑。故次颂曰

  能所说若有　　空理则为无

论曰。言能说者。谓能说人。言及所言。俱名所说。此三总摄有为无为。谓眼等根及色等境。此若实有。何法为空。为遣此疑。故复颂曰

  诸法假缘成　　故三事非有

论曰。能说言义三事性空。假托众缘而成立故。余宗亦许。诸法名言皆是自心。随俗安立。如是说者。言及所言。皆胜义无。唯世俗有。如何谓此三事不空。云何定知三事非有。谓依他立。如幻所为。不依他成。皆如兔角是故三事自性皆空。为益世间假有言说。又汝何为疑难真空。我意犹望成昔有见。应舍此意。所以者何。非破他宗能成己见。如破他说。无碍故常。非即能成自无常性。设有此理汝亦不成。所以者何。故次颂曰

  若唯说空过　　不空义即成
  不空过已明　　空义应先立

论曰。若唯破空不空成者。不空已破空义应成。前诸品中。已说一切立不空义所有过失。若汝欲成不空义者。先当方便除前过失。不除前失但说空过。汝不空义终不得成。非显他人有失无德。即能成己有德无愆。要具二能方成己见。谓立与破。故次颂曰

  诸欲坏他宗　　必应成己义
  何乐谈他失　　而无立己宗

论曰。要具立破自见方成。立破二能见所依故。唯彰他失。不显己宗自义得成。终无是理。何缘汝辈唯乐破空。不念欲成己之有义。故于立破二事应均。方可得成自宗有义。汝欲立有毕竟无能。故诸法空其理决定。岂不空论。此过亦齐不显己宗唯彰他失。此质非理。空无我宗。前诸品中。已广显故。然空无我遣有我成。故破汝宗我宗已立。若尔空论但有虚言。空无我名无实义故。如是如是。诚如所言。空无我名。是假非实。为破他执假立自宗。他执既除自宗随遣。为显此义。复说颂曰

  为破一等执　　假立遣为宗
  他三执即除　　自宗随不立

论曰。一异及非。名为三执。俱同一异。故不别论。一等三宗。若正观察皆归无性。无少可存。彼性本空。非由今破。故契经说。迦叶当知。所见本空非由今破。诸修空者证本性空。故诸破言皆是假说。立亦应尔。权设非真。诸法皆空。宗依何立。依汝所执。故我立宗。所执既无。宗应不立。汝谓为有。故宗非无。为存自宗应许他有。为遣汝执。故立我宗。汝所执无。我宗弥立。虽尔不可立空为宗。现见世间瓶等有故。虽空无我比量多端。而被强威现量所伏。不尔瓶等非现量知。所以者何。故次颂曰

  许瓶为现见　　空因非有能
  余宗现见因　　此宗非所许

论曰。我若许瓶现量所得。空因比量可说无能。然我说瓶非现量得。空因比量何为无能。瓶等诸尘皆非现见。破根境等。诸品已论。不可余宗。谓瓶现见对此安立。为证有因。所见若同可引为证。所见既异。谁肯顺从。是故空因不违现量。能立诸法性相皆空。瓶等诸尘世间现见。若以比量皆立为空。是则世间无不空法。空无翻对应不得成。为举此疑。故说颂曰

  若无不空理　　空理如何成

论曰。夫立空理翻对不空。不空若无。空亦非有。如何可立诸法皆空。为决此疑。故复颂曰

  汝既不立空　　不空应不立

论曰。立不空者翻对于空。既不信空。不空焉立。如何可立诸法不空。汝不信空而得立有。我不执有何废立空。若言不空亦有所对。谓互有无及定无空。我空亦然。对世俗有。遣彼妄有。故立真空。又所立空专为遣执。不必对有方立于空。如为遣常说无常教。虽常非有而立无常。又汝此中不应疑难。翻对在有不在于空。有事非无有翻有对。空理非有何对何翻。若谓不然。空是宗故。如立色等。无常为宗。此无常宗。既定是有。空宗亦尔。应必非无。此说非真。因不定故。世间现见。无亦是宗。理亦应然。故次颂曰

  若许有无宗　　有宗方可立
  无宗若非有　　有宗应不成

论曰。无宗若有。对立有宗。无宗若无。有宗何对若言无对而立有宗。即自违前责空有对。若一切法无不皆空。无我真空咸同一味。如何现见诸法不同。此亦不然。世俗有故。胜义无故。理不相违。为显此义。故说颂曰

  若诸法皆空　　如何火名暖
  此如前具遣　　火暖俗非真

论曰。若一切法本性皆空。如何世间有火等异。世俗事有。诸法不同。胜义理空。无火等异。故汝疑难于理不然。火等如前破根境等。已具观察是俗非真。如何此中复为疑难。若法非有空何所遮。空有所遮。故法应有。若尔四论展转相遮。皆应是真。便违自意。为显此义。故说颂曰

  若谓法实有　　遮彼说为空
  应四论皆真　　见何过而舍

论曰。遮所遮故建立能遮。所遮若无能遮岂有如言非雨。故说名冬。冬时所遮雨时必有。空遮有故有定非无。此亦不然。因不定故。一等四论展转相遮皆应是真。是所遮故。真即无过。皆应可宗。汝见何愆。舍三执一。故不可说实有所遮。若诸所遮皆实有者。自言无过。汝过应真汝拨无空。此空应实。若一切法性相都无。是则世间皆应断灭。尚不执有。况复执无。执有执无皆成过故。为显此义。故说颂曰

  若诸法都无　　生死应非有
  诸佛何曾许　　执法定为无

论曰。若法全无应无生死。因果展转相续轮回。非定执无。何得为难。我说世俗因果非无。诸佛世尊智见无碍。亦未曾许定有定无。如契经中。佛告迦叶。诸法性相非有非无。有是一边。无是第二。谓常与断。此二中间。无色无见无住无像。不可表示不可施设。此意说言。世俗有故。依之建立生死轮回。胜义空故。诸法性相非有非无。心言路绝。若一切法真离有无。复以何缘而言俗有。真虽无二俗有何乖。应离于真别有其俗。虽不相离而义有殊。俗顺世情真谈实理。故真无二俗有多途。又一切宗皆许无二。而有种种体类不同。是故不应辄。生疑难。为显此义。故说颂曰

  若真离有无　　何缘言俗有
  汝本宗亦尔　　致难复何为

论曰。若色等法真离有无。复有何缘而言俗有。因果不断生死轮回。俗顺世情因缘假有。真谈实理非有非无。汝等本宗皆许无二。而言法有辄难何为。所以者何。如诸句义非即是有。勿一切法其体皆同。亦非非有。勿一切法其体皆无。非有非无。虽遍诸法而立种种。句义不同。我法亦然。何烦致难。由此道理余难亦通。所以者何。故次颂曰

  诸法若都无　　差别应非有
  执诸法皆有　　差别亦应无

论曰。若一切法实性都无。所有世间因果差别。谓从眼等眼识等生。此皆应无。无无别故。此同上释。谓不执无。执有执无皆非理故。又若执有其过亦同。所以者何。若一切法皆同有性。所有世间因果差别。谓从眼等眼识等生。此皆应无有无别故。定于有上随相不同。建立世间诸法差别。我亦如是。真故虽空于俗有中建立差别。故汝所难即为唐捐。有劣慧人复生疑难。若法非有则定应无。能破有因。此难非理世俗有故。汝执非无。能立有因何故非有。为显此义。复说颂曰

  若谓法非有　　无能破有因
  破有因已明　　汝宗何不立

论曰。若谓诸法性相皆无能破有因。亦非有者。此慧极劣。以于现前粗显事中不能了故。世俗所摄。能破有因前已广明。何谓非有。汝不可说俗有非因。胜义理中无立破故。若不忍许能破有因。何不立因证自宗有。如我广说能破有因。汝立有因一未曾见。如何可执诸法非空。空言是破。破他便立。有言是立。自立方成。是故我空无劳别立。汝所执有须别立因。别因既无。何缘知有。破因易得立因难成。故破有因未为奇妙。若尔汝宗。何不破空。为破彼言。故说颂曰

  说破因易得　　是世俗虚言
  汝何缘不能　　遮破真空义

论曰。破因易得是俗虚言。未见有因破真空故。小乘外道虽恶真空。而未有因破真空义。如何可说易得破因。诸法性空易立难破。诸法性有难立易倾。真伪皎然。如何固执。有被立破。固网所笼自出无能。矫作是说。声为定量。表法有无。既有有声。法应定有。法若非有。有声应无。为破此言。故说颂曰

  有名诠法有　　谓法实非无
  无名表法无　　法实应非有

论曰。彼立诸名以声为性。此立名等。非即是声。故但举名以破彼执。有声诠有。汝执所诠法实非无。无声表无。应信所诠。法实非有无声非量。便自违宗。故汝所言非为证有。此劣慧者欲脱己愆。徒设功劳终不能免。依实有法立实有名。因实有名生实有解。法若非有。应无有名。有名若无。应无有解。既有有解。故法非无。此亦不然。假立名故。为显此义。故说颂曰

  由名解法有　　遂谓法非无
  因名知法无　　应信法非有

论曰。若闻有名生于有解。遂谓诸法是有非无。既闻无名生于无解。应信诸法非有是无。此既不然。彼云何尔。依名生解。是证空因谓为有因。必不应理。法体若有何待有名。既待有名方生有解。故知诸法体实为无。但假立名世共流布。有名决定无实所诠。如人号牛依想立故。名能遣有而立有因。不异有人以明为闇。有若可说是假非真。所以者何。故次颂曰

  诸世间可说　　皆是假非真
  离世俗名言　　乃是真非假

论曰。世间言说皆随自心。为共流传假想安立。法若可说是假非真。非假是真定不可说。诸可说者皆俗非真。前诸品中已广成立。故所执有是假非真。如舍如军。可言说故。一等四执。前已具遮。更不立余真实有法。是则此论应堕无边。为释此疑。故说颂曰

  谤诸法为无　　可堕于无见
  唯蠲诸妄执　　如何说堕无

论曰。谤诸有法可堕无边。唯遣妄情岂堕无执。为破有执且立为无。有执若除无亦随遣。又世俗有前已数论。故不应言。此堕无执。唯许俗有。真应是无。不许真无。应许真有。此言非理。故次颂曰

  有非真有故　　无亦非真无
  既无有真无　　何有于真有

论曰。若有真有可有真无。真有既无。真无岂有。无真无故。真有亦无。真非有无。如前屡辩。如何复执真是有无。若真非无何意频说。诸法性相俗有真无。此说意言。唯俗是有。真无此有。故说真无。若尔此真俗无为体。若不尔者。应别有真。若别有真有非唯俗。有既唯俗。真体应无。真体若无。何欣修证。此中一类释此难言。我说真无是遮非表。世间妄见执有为真。遮此有真不表无体。然其真体即是俗无。非离俗无别有真体。言真无者。谓俗无真。此遮其真。无别所表。此于言义未究其源。谁谓真无别有所表。若遮余法别有所诠。是遮表言。遮余法已表余共相。如非众生非黄门等。若遮余法无别所诠。是唯遮言。遮所遮已。其力斯竭。如勿食肉勿饮酒等。此真无言。唯遮其真无别所表。不言可悉。如非有言。唯遮其有不诠非有。亦不表余。若诠其无或表余法。则不应说此非有言。若非有言诠于有者。非无之说应表其无。如是遮言。愚智同了彼无疑难。重说何为。彼难意言。有若唯俗。真即非有。何所修证但说真无。是遮非表。乃至广说。岂释难耶。复有释言。修无我观方便究竟。见真理时一切俗有皆不显现。故说真无。此亦不然。意难了故。若俗非有说名为真。应无所证。若别有真。是所证者。则不应言有唯是俗。又违经说都无所见。乃名见真少有所见。即非见真。是故此言亦非正释。如是释者。应作是言。真非有无。心言绝故。为破有执假说为无。为破无执假说为有。有无二说皆世俗言。胜义理中有无俱遣。圣智所证。非有非无。而有而无。后当广说。有作是难。证法空因为有为无。有则余法亦应是有。无则不能证诸法空。为举此难。故说颂曰

  有因证法空　　法空应不立

论曰。空必依因方可得立。若不尔者。一切应成。因既不空。余亦应尔。唯阳焰等水等性空。则所立宗皆不成就。为释此难。复说颂曰

  宗因无异故　　因体实为无

论曰。数论师等。总别无异。勤勇无间所发等因。皆即是声。应如声体。不通余故。因体不成胜论师等。计总与别或异不异。其不异者。过同前师。异即如前诸品已破。故异不异皆不成因。由此故说。宗因无异。因体实无。又所立因体若实有。应与宗体或一或异。然不可说因与宗体。或一或异。非一异故。犹若军林。是假非真。世俗所摄。随顺世间虚妄分别。建立种种宗因不同。遣诸邪执。邪执既遣宗因亦亡。故不可言法同因有。宗因假立皆俗非真。复有难言。证法空喻为无为有。无则不能证诸法空。有则诸法如喻应有。此亦不然。故次颂曰

  谓空喻别有　　例诸法非空
  唯有喻应成　　内我同乌黑

论曰。喻则是因一分所摄。因既俗有。喻亦应然。若谓离因别有喻体。以例诸法是有非空。此定不然。离因之喻必不能证所立义宗。如所立宗非因摄故。若非因喻能立义宗。内我如乌。黑性应立。又应一切所立皆成。无因事同易可得故。由是喻体必不离因。故应同因不可为难。若一切法本性皆空。证见此空有何胜德。为叙此难。故说颂曰

  若法本性空　　见空有何德

论曰。非于离我诸行法中证见我空少有胜德。诸法亦尔。若本性空。证见此空。何所饶益。若无所益何用劬劳。修能证空无量加行。为释此难。复说颂曰

  虚妄分别缚　　证空见能除

论曰。诸法诸行虽空无我。而诸愚夫虚妄分别执一异等。由此虚妄分别势力。生长贪等烦恼随眠。随缘发生诸善恶业。没三有海相续轮回。三苦所煎不能自出。勤修加行证无我空。渐次断除虚妄分别。随其所应证三菩提。自利利他功德无尽。虚妄分别其体是何。谓三界心心所有法。岂不此法亦本性空。如诸愚夫所执色等。何能引苦煎迫有情。若此虽空而能引苦。是则色等亦有此能。何故但言虚妄分别。虽色心等皆本性空。而要依于虚妄分别。计度诸法为有为无。因是发生杂染清净。由斯含识染净不同。是故但言虚妄分别。法若实有。是事可然。法既实无。如何计度。为有无等。染净不同。如梦等中。虽无色等。而有种种相现分明。此喻不然。于梦等位有分别故。作用非无。分别为依。现诸境像起诸染净。是事可然。今既皆空。无实分别。谁能起此作用不同。无体有能曾所未见。若无有体而有功能。兔角龟毛应皆有用。又无烦恼或无善根。而诸有情有染净者。已断烦恼应更轮回。未种善根应获常乐。此中一类释此难言。世俗非无。故无此失。应问世俗非谛实耶。彼答不然。随世俗量是实有故。亦名谛实。如何可说一法一时。有无相违俱名谛实。生等亦尔。一法一时。有生无生。有灭无灭。有断无断。有常无常。有来无来。有去无去。乃至广说。更互相违。如何可言俱是谛实。彼作是说。一法一时。无义为真有义为俗。义差别故互不相违。犹如世间施等善法。性有漏故得不善名。善根相应。故亦名善。俱名谛实而不相违。此理不然。施等善法观待异故。可不相违一法一时。有无二谛无别观待。何得无违。所以者何。安和名善。善有二种。所谓世间及出世间。出世善法。毕竟能害烦恼诸缠。究竟安和名胜义善。世间善法。暂时有能毕竟无能。暂时能伏烦恼缠故。名世俗善。非永能断烦恼缠故。亦得名为胜义不善。此善不善互不相违。有能无能时分异故。如施等善住一刹那。说名有能。过此已后必不能住。说名无能。有能无能虽在一法。时分异故而不相违。第二刹那施等不住。既无有体。谁名无能。由彼体无能定非有。能非有故即名无能。或能无能时分无异。所望境别。故不相违。所以者何。暂时能伏贪等缠故。名为有能。不能断灭贪等种故。名曰无能。如服酥膏能除风疾。不遣痰癊。有能无能。时分虽同。而所望境有差别故。互不相违一法一时。有无二谛境无差别。何得无违。彼复救言。如一念识我执依故。世俗名我由胜义故。亦名无我。我无我别。而不相违一法一时。有无亦尔。虽无境别而不相违。此亦不然。我无我义不相违故。所以者何。一刹那心不自在故。名为无我。我执所依。亦名为我。如契经言。若识是我应得自在。不应转变。而诸愚夫。依发我执故说名我。不自在义我执依义。虽同一识而不相违。一法一时有无相及。俱名谛实。岂得无违。汝今为成。有无二谛同在一法。互不相违。虽引众多世间譬喻种种方便。终不能成。彼重救言。如一青色。据自故有。望他故无。诸法亦然。一一法性。据俗故有。望真故无。此亦不然。青黄体异。可据自有。望他为无。俗之与真其体不别。据自可有望谁为无。寻究其俗实即是真。非考彼青实成黄色。故汝所立法喻不同。又俗与真体不相离。如何俗体望真为无。如契经中。佛告善现。世俗胜义无各别体。世俗真如即是胜义。非离其色别有于空。乃至识空亦复如是。如何一法无别境时。二义相违俱名谛实。由是古昔轨范诸师。情事不同安立二谛。世俗谛语近显俗情。胜义谛言远表实事。世俗诸法虽称俗情。而事是虚。故非谛实。又现量证缘起色心。言不能诠。应非俗谛。故契经说。所有世间名句所诠。名为俗谛。此经意说。世共所知。能诠所诠相应法义。及为诠表非共所知。法义经书。名为俗谛。现量所证缘起色心。非言所诠。亦非俗谛。若言假立名言所诠。故此色心亦俗谛摄。究竟胜义应亦非真。假立名言所诠表故。究竟胜义无此色心。真理都无。事有法故。非二谛摄。此法应无。则违世间现量所证。若言是有非二谛收。应立第三。非真俗谛。若言虽有缘起色心。是诸世间现量所得。而非究竟胜义谛收。假说名为世俗谛摄。随意假立世俗名言。有实色心则无诤论。此为依故染净义成。若谓色心世俗故有。由胜义故非有非生。如是所言。为有何义。若言如彼无分别智。所行境界究竟空无。不如是有。故说非有。若尔所行究竟无故。无分别智应不得生。设许得生亦非真智。缘无境故。如了余无。智既非真。境应是俗。虽言色心不如是有。而复弥显色心实有。由说非有究竟无故。无异相故。定应是有。既定是有。由是亦应许此色心实有生等。若汝意谓。虽复色心亦有亦生。而非胜义。应先审定。胜义是何。然后可言。此非胜义。若言胜义是无分别。智慧所行究竟空无。此先已破。谓彼所行究竟无故。无分别智应不得生。乃至广说。又此所行非真胜义。以是无故。犹如兔角。或非有故。如彼空花。若言胜义是可研穷。此亦不然。境无异故。夫研穷者。不舍世俗。又世俗法不可研穷。此可研穷应离世俗。然非离俗别有胜义。故不可说此可研穷。是故汝言非胜义相。若谓余宗所执胜义。都非有故。是胜义相。此亦不然。彼谓缘生暂住等性。名为胜义。今拨非有。便违自宗及现量等。若言谛实是胜义相。是则世俗应非谛实。何故前言俗为谛实。设许唯说非有非生。名为谛实。是有是生唯假言说。妄分别立既非谛实。唯假言说妄分别立。如何能起染净作用。故彼释难。其理不成。非说龟毛名为有体。即有作用能缚世间。复有余师释此难曰。分别所执法体是无。因缘所生法体是有。由斯发起烦恼随眠。系缚世间轮回三有。或修加行证无我空。得三菩提脱生死苦。因缘生法虽通色心。而心是源所以偏说。虚妄分别能缚世间。厌此能修证空加行。虽有境界若无有心。虚妄寻思终不系缚亦不能厌修无我空。证三菩提出离生死。为证此义。引契经言

  遍计所执无　　依他起性有
  妄分别失坏　　堕增减二边

此中一类释此义言。名是遍计所执。义是依他起性。名于其义非有故无。义随世间非无故有。不可引此证有依他。此释不然。义相违故。若名于义非有故无。义亦于名是无何有。又于其义所立名言。既因缘生如义应有。若妄所执能诠性无。妄执所诠其性岂有。名随世俗有诠表能。汝不许为依他起性。义亦随俗假说有能。何不许为遍计所执。世俗假立能诠所诠。无应并无有应齐有。如何经说一有一无。故汝所言。不符经义。应信遍计所执性无。是诸世间妄情立故。依他起性从因缘生。非妄情为应信是有。彼证己义。复引经言

  由立此此名　　诠于彼彼法
  彼皆性非有　　由法性皆然

此颂不能证成彼义。经意不说。名于义无但说所诠。法性非有辨诸法性。皆不可诠。名言所诠。皆是共相。诸法自相皆绝名言。自相非无共相非有。此中略说。所诠性无非谓能诠。其性实有。故颂但说彼非有言。不尔应言此性非有。彼为证此依他性无。复引经中所说略颂

  无有少法生　　亦无少法灭
  净见观诸法　　非有亦非无

此亦不能证依他起其性非有。所以者何。此颂意明遍计所执自性差别。能诠所诠其体皆空。无生无灭离执净见。观诸世间。因缘所生非无非有。故此非证依他起无。若有依他何缘经说。一切法性无不皆空。又契经言。佛告善现。色等诸法自性皆无。复有经言。佛告大慧。一切法性皆无有生。先有先无不可生故。此有密意。密意如何。谓此诸经唯破遍计所执自性。非一切无。若一切无便成邪见。云何知有此密意耶。余契经中显了说故。谓薄伽梵说如是言。我唯依于相应自性说一切法自性皆无。若有如言而生执着。谓染净法自性皆无。彼恶取空名为邪见。相应自性即是世间。遍计所执由心转变。似外诸尘。依此诸尘起诸倒执。因此倒执计有自他。能诠所诠相应自性染净诸法。即是依他。故知诸经有此密意。又到彼岸般若经中。佛自分明判有无义。遍计所执所集所增。所取常恒无变易法。如是一切皆名为无。因缘所生皆说为有。又余经说。遍计所执自性无生。依他起性所摄诸法从因缘生。又慧度经作如是说。行慧度者善知色性。善知色生善知色如乃至广说。又诸经说。诸法无性无生灭等。皆应分别不可如言。执为了义勿世俗谛。诸法亦无。便恶取空成大邪见。此言非理。所以者何。于了义经异分别故。世尊自说。若诸经中说空无相无愿无行无生无灭。无有自性无有有情命者主宰补特伽罗解脱门等名了义经。我言合理。以于余经佛自决判我依遍计所执自性。于余经中说一切法皆无自性无生无灭本来寂静自性涅槃。依依他起自性说言。诸有情心生灭流转。乃至广说。又余经中。佛告具寿舍利子言。色自性空。自性空故无生无灭。无生灭故无有变易。受想行识亦复如是。此依遍计所执自性。说自性空无生灭等。以诸愚夫随自心变色等诸法周遍计度。执有真实自性差别。世尊依彼说色等法自性皆空。无生灭等依他起性。由无遍计所执性故。亦说为空。非自性空。无生灭等。如来处处说三自性。皆言遍计所执性空。依他圆成二性是有。故知空教别有意趣。不可如言拨无诸法。如言取义名谤大乘。故契经言。若有菩萨。如言取义不求如来所说意趣。是名于法非理作意。亦名非处信解大乘。若有菩萨不如其言而取于义。思求如来所说意趣。是名于法如理作意。亦名是处信解大乘。若尔云何释此经句。佛告天子。汝等当知。佛于菩提都无所得。亦无少法。可生可灭。所以者何。以一切法无生无灭。是故如来出现世间。有作是释。诸佛证得大菩提时。远离一切分别戏论。虽出世间而不可说有证得等。复有释言。佛以菩提为其自性。故无所得。如契经言。菩提即佛。佛即菩提。故无所得。如其法性而觉知故。不生先无不灭先有。以诸法性离戏论故。无生无灭。无上菩提。现在前故。说名如来出现世间。又契经说。善现当知。色名诸色无性之性受想行等。广说亦尔。此经意明。依他起性以其遍计所执色等无性所显离言法性为其自性。若一切法都无所有。如何无性而复言性。若言色等世俗无性。即是色等胜义之性。与理相违。所以者何。夫胜义者。分别戏论所不能及。岂得以无为其自性。若以无性为自性者。应类余无不名胜义。应不能证无上菩提。则违自宗成大过失。依他起性若实有者。便违经说。故契经言

  诸法从缘起　　缘法两皆无
  能如是正知　　名通达缘起
  若法从缘生　　此法都无性
  若法都无性　　此法非缘生

如是二经说缘生法。虽无自性而不相违。以从缘生法有二种。一者遍计所执。二者依他起性。此中意明。遍计所执自性非有不说依他。若说依他都无自性。便拨染净二法皆无。名恶取空自他俱损。此妄分别谁复能遮。得正见时自当能遣。今且应问。依他起性何智所知。谓无分别智所引生世间净智。既无分别。何名世间。谓言此智是无分别。若有分别应不能行。诸法实相但应缘彼遍计所执虽有分别。而说能行法实相者。虚妄分别。应亦能行诸法实相。又今未得无分别后法实相智。如何定知有依他起。此依他起非如现见蛇执所依。如何定言实有此性。唯无分别智所引生世间净智知依他起。与论相违。如彼论言。遍计执性何智所行。为凡智耶。为圣智耶。俱非所行。以无相故。依他起性何智所行。俱是所行。然非出世圣智所行。又言五事几是所取。几是能取。三是所取。分别正智通能所取。名相分别。分别所取正智有二。一缘真如。第二是彼所引生故。今犹未得相等。又是依他起性。故彼论言。遍计所执五事不摄。依他起性四事所摄。若依他起世智所缘而说非空。甚可嗤笑。诸法实相非是世间。心智所行如前屡辨。故不应说。实有依他论说依他。亦凡智境据自证受。故不相违。依他起性即心心法从缘起时。变似种种相名等尘实自证受而增上慢。谓取外尘。然诸外遮遍计所执。无体相故非所缘缘。故非圣凡智所行境。一切有漏心及心法。唯能证受自所现尘。未能如实证余心境。无漏世智相应心品。由性离染自他俱证。故说依他净智所了。与论所说理不相乖。汝嗤笑言。自呈愚昧。非显我说与理相违。若从缘生心及心法。同遍计执皆自性空。便似空花何能系缚。三有含识生死轮回。是故依他非无体实。论者本意决定应然。若不尔者。何缘故说。妄分别缚证空能除。谁睹龟毛能计能缚。谁见兔角能证能除。由是应知。有心心法。但无心外所执诸尘。云何定知诸法唯识。处处经说。于此何疑。故契经言。佛告善现。无毛端量实物可依。愚夫异生造诸业行。唯有颠倒与彼为依。颠倒即是虚妄分别。虚妄分别即心心法。又契经言。无有少法自性可得。唯有能造。能造即是心及心法。又契经说三界唯心。如是等经其数无量。是故诸法唯识理成。岂不决定执一切法实唯有识亦成颠倒。是则应如色等诸法颠倒境故其体实无。又境既无识云何有。不应一识二分合成。勿当失于心自一相。若言识体实无二分。能缘所缘行相空故。但随世俗同所了知有能缘心故说唯识。则应亦说境界非无。世俗同知有心境故。若许实有少分识体。应说此体。其相如何。既不可言能识所识。如何定说唯有识耶。诸契经言。唯有识者。为令观识舍彼外尘。既舍外尘妄心随息。妄心息故证会中道。故契经言

  未达境唯心　　起二种分别
  达境唯心已　　分别亦不生
  知诸法唯心　　便舍外尘相
  由此息分别　　悟平等真空

愚夫异生贪着境味。受诸欲乐无舍离心。生死轮回没三有海。受诸剧苦解脱无因。如来慈悲。方便为说诸法唯识。令舍外尘。舍外尘已妄识随灭。妄识灭故便证涅槃。故契经言

  如世有良医　　妙药投众病
  诸佛亦如是　　为物说唯心

虽说极微亦可分析。据方所故。如舍如瓶。此难极微可成多分。是假非实。不可全无。若不尔者。心及心法。一刹那中时分摄故。如岁月等众分合成。亦可全无。成大过失。如是等类随见不同。分隔圣言令成多分。互兴诤论各执一边。既不能除恶见尘垢。谁能契当诸佛世尊所说大乘清深妙旨。未会真理随己执情。自是非他深可怖畏。应舍执着空有两边。领悟大乘不二中道。如契经说。菩萨当知。身见为根所生诸见。感匮法业系缚世间。轻彼拨无诸法邪见。及于此见称赞流通。因是所生感匮法业。经无量劫坠那落迦。恶趣轮回受大忧苦。昔微善力来至人中。愚钝盲聋多诸忧苦。身形卑陋人不喜观。鄙拙言辞闻皆不悦。或宿曾种增上善根。来生人间受殊胜报。由昔摄受谤法业因。偏执如来破相。空教。非毁所说显实法门。令诸世间非法谓法。法谓非法。非义谓义。义谓非义。自损损他深可悲愍。然佛所说无不甚深。二谛法门最为难测。今且自励依了义经。略辨指归息诸诤论。世俗谛者。谓从缘生世出世间色心等法。亲证离说展转可言。亲证为先后方起说。此世俗谛亦有亦生。假令所成犹诸幻事。从分别起如梦所为。有相可言名世俗谛。胜义谛者。谓圣所知分别名言。皆所不及自内所证。不由他缘无相绝言。名胜义谛。如是略说。二谛法门。正法学徒同无所诤。依前世俗染净法生。依后胜义证于寂灭。是故圣说心境有三。一者有言有相心境。二者无言有相心境。三者无言无相心境。初于名言能有觉悟亦有随眠。次于名言虽有随眠而无觉悟。后于名言随眠觉悟一向永无。初二缘世俗。后一缘胜义。复有永离言说随眠。后所得心通缘二谛。若于世俗起坚执见。及于世俗起不顺见。此二俱名虚妄分别。是生一切无义利门。系缚有情令不解脱。空无我见能悉断除。令诸有情离三有缚。自证究竟寂灭涅槃。亦转化他令得解脱。拔除正习障根本故。若于世俗起不顺见。此于胜义定有乖违。为明此见。故说颂曰

  法成一成无　　违真亦违俗
  故与有一异　　二俱不可言

论曰。若执诸法与其有性。定为一者。法则成一。定为异者。法则成无。是即违真。亦复违俗。所以者何。若一切法与有性一。色应如声是声非色。声应如色。是色非声。即有性故。法应成一若一切法。与有性异。即色声等。体悉成无。非有性故。如空花等。若执诸法与一性等。定一异过。如应当知。是故有等与法一异。二种妄见违俗及真。俱是俱非相违戏论。过同一异。故不别论。于胜义中有无等寂。一切问难皆不得成。为显此义。故说颂曰

  有非有俱非　　诸宗皆寂灭
  于中欲兴难　　毕竟不能申

论曰。胜义理中无少有法。以一切法本性无性。故有见宗于斯寂灭。依有见故非有见生。此见既亡彼见随灭。真若非有圣智不行。圣智所行必非非有。故非有见不证其真。圣智观真不观非有。简俗有故说真非有。真非有言还依俗说。真非有教能顺趣真。是故诸经多说非有。有非有见于此既除。俱是俱非皆应类遣。以其有等皆可表诠。真绝表诠故非有等。一切恶见扰动其心。于正理中广兴邪难。皆依如是有等见生。此见既除彼亦随灭。虽欲猛励抗论真空。由无所依措言何寄。如空无底足不可依。诸有大心发弘誓者。欲穷来际利乐有情。应正断除妄见尘垢。应妙悟入善逝真空。为满所求当勤修学

  已除见有累　　复遣执无尘
  善开妙中道　　愿世咸归寂

圣天菩萨造论既周。重叙摧邪。复说颂曰

  我在为燎邪宗火　　沃以如来正教酥
  又扇因明广大风　　谁敢如蛾投猛焰

三藏法师。于鹫岭北得闻此论。随听随翻。自庆成功。而说颂曰

  圣天护法依智悲　　为挫群邪制斯论
  四句百非皆殄灭　　其犹劫火燎纤毫
  故我殉命访真宗　　欣遇随闻随译讫
  愿此速与诸舍识　　俱升无上佛菩提

大乘广百论释论卷第十


大乘破有论

    No. 1574

大乘破有论

        龙树菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

归命一切佛诸有智者。应当如实了知诸法。此中云何。谓一切性从无性生。亦非无性生。一切性若有生者。彼性是常。是性无实。犹如空华。当知诸法与虚空等。彼诸法生亦与空等。一切缘法皆如虚空。彼无实故。当云何有。诸法无因而复无果。亦无诸业自性可得。此中一切而无有实。无世间故无出世间。一切无生亦无有性。云何诸法而有所生。世间亲爱父子眷属。虽有所生而无其实。不从先世之所生故。亦非现世有其相故。此于世间无义可转。犹如月中见诸影像。世间无实从分别起。此分别故分别心生。由此心为因即有身生。是故有身行于世间。蕴所成故名之为身。诸蕴皆空无有自性。蕴无自性而亦无心。以无心故是故无身。当知自性离诸分别。若无其心亦无有法。若无其身亦无有界。此中所说是无二道。此所说者是真实说。此中一切离诸所缘。此中所说离诸所缘。此中所作离诸所缘。此中所得离诸所缘。所有布施持戒忍辱精进禅定智慧诸法如是常行。不久时中即能证得无上菩提。以慧方便安住实际。起悲愍行广度众生。虽复如是有所得相。一切智性而不可说得。彼一切法但有名字。一切但于有想中住。现前无实差别所生。差别生法而无所有。彼一切法本无有名。但以假名而表了故。当知诸法而无实体。一切皆从分别所生。此中若无分别者。即同虚空离诸分别。如说眼者能见于色。作此说者是真实语。世间有诸邪执心者。执此所说如实而转。彼一切法聚类所现。当知此说是佛所说。是故应知。此中义者眼不见色。乃至意不知法。若如是知是为智者。即能通达第一义谛。如是乃名最上真实。我今依经。如是略说

大乘破有论


大乘中观释论

    No. 1567 [cf. Nos. 1564-1566]

大乘中观释论卷第一

        安慧菩萨造

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

    观缘品第一

归命一切智。所有世俗胜义二谛。本无所行。若无所行。摄化有情事。即当舍离。菩萨为开示故。造此中论。然此不同一切外道所说缘生。佛说缘生法。为令觉悟多慢心者。生极净信。于诸论中。此论宗重。谓缘生义。即无灭等句。最胜缘生。显明开示。是故论初赞叹世尊。如本颂言

  不灭亦不生　　不断亦不常等

释曰。灭者。无常性故名灭。发起名生。断生死故名断。择灭涅槃常时性故名常。如有人言。若佛出世。若不出世。法性常住。此缘生者。亦即是常。一者无差别义。如所说离此即是为缘生之法何所生邪。谓种种义。如其所说。从因所生。生已有果。来者向此名来。若无来义转时此即无去。无去义转时即无过去世所行。非今有灭。此即无灭。此法如是说。余生等亦然。若取着言诠即为戏论。如其言诠。于如是性。执有性者。彼皆息灭此即名为灭诸戏论离诸娆恼性分。别自性空已乃名寂静。今此如是无灭等十种句义。如前所说十种对治。此中皆止周尽是论皆说此义此如是义成。余一切论中皆同此缘法。今此义中。若此因若彼缘。如薪生火。而彼所取如是应知。常不断义。如前句所说发起之义。此所说成。若因中有故设因坏时后还不离果起无前后时性故。如澡沐已受食。此非缘生。若言无生。自语相违。不和合对治。此即世俗缘生。不和合故。若胜义谛所生。此中止遣。世俗谛识中体性不和合胜义谛体性。此中止遣。何等是世俗。何等是胜义。若胜上所说相续义性。以世俗谛伺察时。此不和合。以彼现证非涅槃所得。此所作性不异胜义谛故。亦不止遣。若智所成。即彼世俗谛。不异胜义谛。如瓶等色等。而此一类色受等法。决定境界智不许可。彼智无性故。譬如瓶等堕世俗有性。虽无所取非世俗无。此中所说。世俗所取之义。是自非他。如理应知。世俗者即是世俗所取故。如树林等非极微许。而有所取道理可得。若方分分别差别分别等性而彼决定世俗有性。此非道理。以物体遍计有树林等对碍。而识中有彼树林等为所表故。然识中物性非无道理。由是树于彼识而为所缘。如是能表识中得有所表。是故非物体树于识中有。此如是说故。余说亦然于能表所表中。遍计无体亦无所成。何法可成邪。谓如诸佛境界。色等决定。此何不成。如彼诸佛境界。此亦然有。非如识中遍计生等。此中止遣。识中物体若有性者。此非道理。若彼胜上如来之智。如所说义。故名胜义。余皆世俗。不实性故此说最上。谓佛所说善文善义是故颂言

  我稽首礼佛　　诸说中第一

释曰。若文义二。无著智性。唯佛大师而善宣说。何所说邪。谓说无生性。今为证成无生性故。彼无灭等诸差别义。亦如是证成。如是建立无生法故。或有人言。所说生者。我知差别之性如是自生。为遮遣彼说。是故颂言

  诸法不自生

释曰。所言生者。本无今有之别名。自者。我性义。彼如是说。互相损恼。自语相违。不和合对治。或如瓶等。即不见有自生之法。如前瓶等。自体无性故。诸生法无性。生已复生。亦复无性。如是眼等决定和合。若尔即有对治过失。若有如是因。即有如是果。彼果体有生。以因果二法无别异性故。若言自生。此应思择。又复泥团离瓶。瓶离于因。此中色等当云何有。若离泥团。果因二种无别异性。若泥团离瓶。而此果体即不和合。泥团若坏。瓶有所得。即非果时有因性故。此僧佉人言。譬如色等非果因二法有别异性。色等自体亦如离瓶先无有性。若彼决定实无所成。所说无异如瓶所作。杖轮水等非此所阙。彼等无别异性因果二无性故。何名无别异。谓不见因自体能作。如是果有所作。亦复不得无异性故。若无所作。何名因果。决定自体无别异性。若因无作。彼无作时果不和合。有异人言。我知差别。诸法从他性生。为对遣彼说。是故颂言

  亦不从他生

释曰。他生者。别异义。如他性瓶等不生眼等。由如是故。自缘既不生。他性亦然。若止遣诸法自相。应知有过。此中或有彼不和合。如是所作非胜义谛中。他缘能生内六处等。以他性故。此如瓶等。此中他性瓶等如内六处缘胜义谛中生无性可得。世俗谛中亦然。生无性可得相违义性无因生性及共生等。若有所得皆他义故。如是所有中论成就。究竟义中离不和合对治等法。若复如是世俗谛中有所得者。决定如前对治相违。世俗缘生有所得故。此亦非所得如是有所成即和合无性成已见边二不和合。如是即于诸所成中有共过失。若别异所成。当知自有差别过失。此广文不书。恐繁且止。非中论所说。如前对治。何以故。后对治亦尔。无此中所成和合道理。有异人言。取彼实有泥团。随有杖等诸作用法共生瓶等。此异意乐。故颂止言

  共生亦无性

释曰。彼增上所作言非二法共生。若尔有言说对治过失。有异人言。如所意乐诸法如是无因而生。为遣彼义。是故颂言

  亦不无因生

释曰。如他所说。无因生性有所得者。即时处等彼相离性。决定有生可得。彼时处性能不相离。此若止遣对治过失。此中或有生性。诸论皆说。是有漏义。如是有性各各系属。诸性有生。此中皆止。若有所作。即与阿含相违。如佛所说。有四种缘能生诸法。而此四缘诸经论中皆如是说。何等为四。谓因缘。所缘缘。次第缘。增上缘。如是四缘无第五缘。诸异宗中有执我者。执极微者何所以邪。此中若有常因者。彼时处性即能相离。彼一切果乃有同生。现见时处等不相离性次第生法彼同作因。即不相离因性可得。此无过失。是故同作诸因。此中非因。彼说如是生无有性。若有因故决定有果。彼同作诸因决定因性。此本有故。若同作因此相离者。即如前说对治相违。以本和合故。而彼诸因如是建立差别因无性。然彼处等有相离性可同生者。此之分位如士夫等。由如是故非士夫等。因本无和合性。士夫等句义。亦如自体。亦非定有。士夫等本性和合所有因性。如种子等。以士夫等本来分位或离所作性。如种子等因有所得或无所得。此复云何。若本来分位离所作性。或有所得即是无常。若不离所作自相亦即无因。如前已说非诸士夫。如彼种子能生于果。若如是见。此非道理。彼遍计性故。是故前说无第五缘。亦非断灭。世间所有诸执无因恶因诤论乱意之者。为摄化彼故。如其分位于世俗谛开示宣说诸因缘等。此即非胜义谛。或有问言。自果于缘中为有邪。为无邪。物体第三分别无性。故颂答言

  如诸法自性　　不在于缘中

释曰。譬如瓶衣。非即有故。亦非异故。如是眼等自性。若自缘若他缘若共有。而彼诸缘非即非异。若离自体即无有果。由自力能即有诸缘。此无异性应当思择。由如是故。因果二法无别异性。何所以邪。若离是因。果不能成。彼能作因。其义亦然。若定有异性而彼自果于诸缘中即无所生。是故颂言

  以无自性故　　他性亦复无

释曰。若有此二。即互不相离。若见有他性。如此彼二非缘时中有果。非果时中有缘。若他性随生。即因果二法非俱时有。刹那性故。若生不生二所作性。二俱无性。若不坏因。未来有果。此智所安立。乃说他性然。若取着他性非胜义谛有。或有人言。诸经论中皆说他缘能生诸法。云何此说非他性生。若诸缘中他性不生。岂可无自性诸法于缘中住。若尔缘即是非缘。若自性无所有者。果从他缘生。即非道理。故颂答言

  亦非缘生果

释曰。然生法所作有果可成。为总止余义。是故颂言

  果不从缘有　　有无果生止
  若说生法时　　无依无所生

释曰。前说果不生无所成者。以能生果者自亦无性。若能生所生及彼生法。定有别异生法可得者。即彼所作说为能生。此中别异生法即无所成。若果离于缘。即所生生法云何得成。他所系属故。或有人言。所作如是从缘所成。非物体自性成故。是故非眼等六处能成缘法有此意乐。故颂答言

  果不从缘生　　此果缘中生

释曰。若彼决定别异生法为可有者。彼无生法中间所作。若生而彼眼等决定生法互相离性。或如是生亦何不成。如是说者。彼无自性法。此中有过失。此异宗说。是故有过。若从缘生果。彼果性无依。缘亦无常。相离性中果云何成。如有颂言

  果若别异解　　无道理可依
  若一法作成　　果体不可立

如本颂言

  非无缘有果　　无缘果亦无
  如是世俗中　　常性不可得

释曰。若或无缘。果即不成。若有果故。彼诸法体即有所得。彼等诸法亦非先有性故。是义当知从缘所生。若离缘生。虚无有果。譬如芽等。何能和合。若言从种生芽。即能生所生二和合故。亦非种子等缘一向能生。以余法成即能有果。由如是故。果非常有。或有人言。从缘有果。此即非常。亦非无常。如是性中能生得成。释者言。如汝所说。此有法故。即此所成。如是决定胜义谛中。非无缘有果。非无果有缘。俱不见故。眼等诸法此中亦然。于其缘性若止遣者。定知有过。是故当知。从缘有果。诸果体生。谓从因缘次第缘所缘缘增上缘生故。以诸缘分别果体差别如是得成。譬如已成熟果。而诸因体差别分别。是故能作所作此中分别。此如是说。决定有果。决定之言即印持义。此中有果其义显明。世俗谛中果法增胜。即有所得。然无分位可着。若果性有着。即他宗义。谓于缘中非实有果。若彼如是从缘生果。互相所摄有果随转。彼虽分位各别。然有果生此说缘生。是故此等诸缘生已亦各别故。诸未信许言即是不乐说义。若此果不生。即彼无有缘。何等为缘。谓随所意乐。是故若无有缘。能生于果。此无道理。若或无缘。又复何有缘性可生

大乘中观释论卷第一大乘中观释论卷第二

        安慧菩萨造

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

    观缘品第一之余

复次此中或有异意。谓以刹那如是缘性可成于果。虽非相续此无过失。是故颂言

  非有亦非无　　缘义和合尔

释曰。所言无者。如兔角等。缘亦何无。此中意者。如前说性。此不可说不可伺察。谓以彼因于分位中不能取故。所言有者。诸缘于何性而有所说。是中无有少法而可施作。若有彼因及作用事。如上所说。此即为有如是果缘。其义显明。如瓶灯等。此应思择。此中决定。若有所离。即无所有亦非无有缘不和合故。如所说果或果分位彼三种功用能所性极成。彼若缘异即无功用。所施作故。此说显明。彼有所生此无所离。此说义成。此中无有少法不生及非有性如量增广体不生故。以无生法而可增故。若诸缘有体性。即不和合生。此中无功用体性止遣。其有如是有性者。有人谓于彼无功用不和合体性中亦有所成。如痴等体性。或量中减少。或生中减少。非坏因而有。非常因而有。如瓶决定离别异性。或彼境界智生。其理应思。若对治法起。即能遣除冥暗。若彼二种决定为有者。于境界智中即不成就。以世俗谛中。譬如灯等及瓶生因有所成故。是故应知。亦无所离。或有人言非有非非有。生时缘成故。谓以生时有作用性所发起故。此中虽有亦复不成决定生性。彼有即是增上所作。是故颂言

  诸法无自性　　非有亦非无

释曰。谓以生时种类所作或有或无。后亦如是。不离有性无性或有所得。如是有诸缘论中说是相。非不有故。如兔角等。亦有说相。此有说相即世俗谛。非胜义谛。能成彼果说名因缘。然彼亦无诸法不有亦非不有。若其不有即无法可成。若尔云何有此能成之因而得和合。有若不成与成相违。无即决定。不成无。彼有性生故。譬如兔角亦有亦无决定不成。于一法中相违自性。本不生故。二俱有过。以如是因成如是果。岂得和合。若或于彼心心所法而有取着。此即说为所缘缘法。如是决定彼不和合。若胜义谛中如是眼识等有法可说。彼法生时无言说性。是故此中非所缘法而得和合。若有所说彼即相违。无亦相违。若有所缘。应知皆是世俗谛故。非胜义谛。胜义谛者。此中止遣。若有法转时。即诸相随转。是即所缘。此说是为所缘缘法。是故颂言

  于此无缘法　　云何有缘缘

释曰。若无缘之法生时。云何复有所缘法生。彼体无成故。又若等无间灭法。彼即容受所作为等无间缘。此中决定如是分别。是故颂言

  若法未生时　　即不应有灭
  灭法何能缘　　故无次第缘

释曰。若法未生如石女儿死若法已生诸法皆灭。是故无彼次第缘法而得和合。以生灭性不和合故。即灭即生。而彼灭缘当云何有。是故缘灭无说性可转如是则应生时为缘。若生时为缘者。生时已生又何用缘。生者起义。此不有故彼何有缘。若有所成。即是增上缘法。此若决定起伺察时。即无所有。故此诸法皆无自性。若起言说及伺察时。实无自性可得成就。是故颂言

  诸法无自性　　非有亦非无
  此有彼法起　　如是无所有

释曰。彼如是性非有性故。乃有是缘。论中所说缘者说有彼果故。如佛所说诸缘法者。谓有士夫所作果增上果胜报果平等果。非无体性故。如兔角等。或说有果。若如实所说。非胜义谛。何所以邪。果若有若无。缘中皆止遣。若如实观察不即缘有果。不离缘有果。是故颂言

  若谓缘无果　　果从缘中出
  是果何不从　　非缘中而出

释曰。非缘中出者。如砂出油。若或止遣缘生。定知有过。复次颂言

  若果从缘生

释曰。有异意乐。若言有果从缘可生。亦何不从非缘所成。以相似无性故。若正缘有成。非缘亦应成。若止其不生。又定知有过。复次颂言

  是缘无自性

释曰。意谓若无自性。彼云何能所作差别。此中谓显果非自成故。复次颂言

  从无自性生　　何得从缘生

释曰。此中意者。如尊者提婆所说颂言

  如衣因所成　　能成因别异
  成法若自无　　别异因何有

今此品中皆为止遣如是义故。或有人言

  果不从缘生　　不从非缘生
  以果无有故　　缘非缘亦无

释曰。彼生不能无性故。此中有言果由缘成。缘法者是果之种类。果无自成无自种类。彼果决定从他性生而有所得。然为止其定生性故。无有缘成。亦无非缘成。无缘种类。无非缘种类。无非缘种类果可有果生无性。谓因等及缘有果圆成。彼缘所成此果无性。果无性故。缘与非缘复云何有。此中意者。若说生若说缘若说果。应知唯是世俗分别。如是皆非胜义谛境。今此品中皆为证成如。是义故

    观去来品第二之一

前品已止生义。今当次第。胜义谛中诸有物体。如是总聚差别之义。而悉止遣。余有所观次应发起。如前品余所分别说。诸有物体皆悉无性。谓先止遣彼生义已。余诸句义亦然止遣。诸有所作虽复如是多种止已。然善巧智中有所生义还复发起。此无过失。有人言去。此中去者。去法胜义谛有彼果。此法有实性故。能作所作作法非不和合。今为止遣彼有能作所作及作法故。有此品起。此中应问。为已去名去。为未去名去。故颂答言

  已去无有去

释曰。已去名谢灭。若有去法可去。即彼去法为不极成。即不和合。自语相违。复次颂言

  未去亦无去

释曰。未去未生。若有去法可去。即如前所说。自语相违。不和合对治。复有人言。此言去者。总摄作用。诸差别等如所意乐。去时有去。为对彼异意故。颂遣言

  离已去未去　　去时亦无去

释曰。而彼去时。或有所去。即不离已去未去二种法中。何以故。于一法中互相违性彼不生故。此中若说诸法无性。是义成就。若以是法于非法中有所成者。即去时去又何不成。是故亦无去时可去。复有人言。现见世间举足下足有行动相。此往彼方不离所观。有可去相。彼复谓言。世所作事。先由作者后有所作。作事方成。去相亦尔。复次颂言

  动处则有去　　此中有去时

释曰。若复别异。此云何有。复次颂言

  非已去未去

释曰。彼异意者。谓以去时有行动相。乃说去时以成去义。复次颂言

  是故去时去

释曰。异意谓离已去未去去时有去。复次颂言

  云何于去时　　而当有去法
  以离于去法　　去时不可得

释曰。于一去法中若有去时可和合者。即应二种去法有性。而此去法不可得故。如是决定法止遣相离者。此有过失。若此去法有去可和合者。即非去时。如是决定。若言去时去法彼和合者。云何去时而有去邪。何所以邪。复次颂言

  若去时有去　　则有二种去
  一谓有去时　　二谓去时去

释曰。若言去时得有去者。此义不然。离已去未去无去时和合可去。是故若见有是法。还成过失。如所说过失者。谓去时有去。若此二种决定有去理可成者。即彼去法应于去时去可得邪。若尔即有二法可得。一谓去法去。二谓去时去。若尔此说还成去法可去。若有二去法者。此无道理。何以故。若去法去时有所成者。彼何决定。或有所得。此复云何。若或无所有。彼决定说。云何有此去时可去。诸法亦然。皆如是止若法决定。应有如是去时可去。非已去未去无如是见。是故此中无二去法。若有即成别异过失。复次颂言

  若有二去法　　即有二去者

释曰。此何所以。如颂言

  以离于去者　　去法不可得

释曰。若如此说已。余皆亦然。无二去者可见。亦非所乐。此复云何。此中如是无去者去时去法可去。若有去时可去者。非彼亦无去法可得。是故于其一去。者中无二去法。若有即成过失。或有人言。于一去法中去者相离。即无所得。若有所作即有去者。此中若有所依。即去时去法或有可说。是故无二去法和合。如是若于如前所说过失遣除。即无有少法可作。若有别异还成过失。复次颂言

  若离于去者　　去法不可得

释曰。去法若离。即俱时所起彼去作用即当破散。是中何有去者可得。若无去者。彼去者性所作无性。此中去者若不相离。而彼去法亦云何有。今此去者去法如实伺察。云何可说有去相邪。此去者中云何实有去者去法而可施作。又或去者若有别异。此复云何。复次颂言

  去者即不去

释曰。何所以邪。谓法自相止遣。复次颂言

  不去者不去

释曰。谓如前所有。相违法故。复次颂言

  离去不去者　　无第三去者

释曰。以彼如是第三无性。是故此中无有去义。前言去者不去。如其所说。止法自相。为证成此义。复次颂言

  若言去者去　　云何有此义

释曰。无有是义。此复云何。复次颂言

  若离于去法　　去者不可得

释曰。以离去法。去者不和合。若有如是去法与彼去者。此中和合亦无别异去法可有。若或决定去有所作。即彼去法有去和合。复次颂言

  去法若欲去　　非无去者去

释曰。若言如是异法有着。即离去法。去者可见。去法不离去者体故。彼皆无性。若复止遣法自相者。还成过失。若定有彼去法可成。如是即有二去法可立。乃成。去者。有去何等为二。一者有动。二即去者有异法可去。如是去法即成差别此中无有去法可取道理。若尔即有别异去者别异去法。若无去者去法可立。此无过失。有人谓去有发起可说有去。此中若或去者已去有发起邪。或别异邪。如是分位有所著故。所以颂言

  已去中无发

释曰。已去者。去彼去作用而已谢故。此中何有去法发起。复次颂言

  未去中无发

释曰。未去者。彼去作用未有生故。若离已去。未去性亦无发起。复次颂言

  离已去未去　　去时中无发

释曰。是故今时云何有。去而得发起。所以去法发起无性去者无性其义亦然。由是当知胜义谛中去者去法分别悉无。或有人言。此中应有如是去法。已去未去去时分位因性可成。彼说不然。若或先有去法发起。即有去时。后亦复有去者发起。此中无去法故。即无去作用。去时作用已谢灭故。如前所说。去法发起即无分位。亦无去时可有。若彼去时有所发者。又离去法去时不有。云何当有已去未去。彼皆无性。如是无去故。云何如前去法有所发起。以彼去法发起无故。去中皆止诸有体性。去无性故。即不和合。此中决定说者。若无去故何有去法。以无去无去法故。亦无彼去作用发起。去云何有。复次颂言

  去未去去时　　云何有分别

释曰。若不见有如是去法所发起故。余一切处其义亦然。已去未去去时分位。因性所成。一切皆无去法可得。以彼如是发无性故。若有如是去法。于胜义谛中如理思择。分位对治悉无所有。云何当有已去未去去时分位

大乘中观释论卷第二大乘中观释论卷第三

        安慧菩萨造

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

    观去来品第二之余

复次颂言

  去者即不住

释曰。于一同生法中。相违所作丛杂无性

  不去者不住

释曰。去法止息名之为住。今不去者。去法无性不应止息。若或本有住法可得者。然亦住法无二和合。若有二和合。今应如实观。是故颂言

  离去不去者　　何有第三住

释曰。去不去者。是二不住。此如是义即如前说。复次颂言

  去者若当住　　云何有此义
  以离于去法　　去者不可得

释曰。总止住法。复次颂言

  去未去去时　　止息诸分别

释曰。若彼去时不住可尔。彼已去者应可住邪。此亦不然。已去者无别去法。去法已坏。是故无住。此中无有已去者住。今此住法如是止已。余诸过失所说亦然。复次颂言

  所有行止法　　皆同去义说

释曰。此所说已。余法皆同。已去未去去时去法不生。已去未去去时去法初发。已去未去去时去法止息。住法亦然已住未住住时住法不生。已住未住住时住法初发。已住未住住时住法止息。此中法自相等。若止遣者则生过失此中所有去者去法二种。于胜义谛中欲求实性者。如理应知。一性异性诸有物体皆法性故。是中若有所生皆客尘事。世俗所行世俗所成。然无异性。是故去者去法二无异性。此应思择。此中应知。风界动转即有去者。身等动发往方处相。此乃名去。非去者去法二性别异。于自类中有异说者。皆止是义

复次颂言

  去法即去者　　是事则不然

此复云何。颂言

  若谓于去法　　即为是去者
  作者及作业　　即一性可立

释曰。虽有作者作业二相。然彼作者作业互无异性。以彼作者作业自相息故。或可一性和合。即体用有相。世俗所成。世俗有性。以彼实无所成。于世俗所作决定可得。是故非无性非一性。此中若有所止。还成过失。生法显明。若止遣者。即无果体。亦无往去方处动发等相

复次毗婆沙人。及吠夜迦啰拏人言。去者去法有别异故。彼谓去者。能去非物体。去物体由去者故说有所得。所作如是。能作亦然

复次胜论者言。如是能于物中有性故有去者。用彼去法动发行往方处等相。此如是说。余皆亦然

释者言。不然。去法若尔。作者功能于物体中为有差别邪。无差别邪。此复云何。若有差别者。诸异力能或复别有齐等力能。于一能作中若成体性。此即是为作者力能。非所作等功能。此若所作等力能。即非作者功能。是中云何如实决定。或言自相差别。此即还成不定。若或自相无差别者。即一切处应无差别性。今以物体如是增上所依。火不能作地等事业。亦非无其事用作者和合力能相应。故知物体如是非作者功能。此说义成。由如是故。所有物体如是能作如是所作及此如是增上作用。是中作者即得和合。是故非彼功能差别。亦非自体差别所成。若或物体无有差别。即功能可成。如是亦然。诸力能者互无差别一无异性。故知物体若一性。是中亦无多法所成。若异性是中亦无多法所成。云何二种功能而可成邪。或离所得。即彼如是此之所作是善功能缘法差别。作者物体缘差别有。此名胜上差别长养。是故非作者力能和合。若或分位差别。如是作者分别。是故此说名为作者。若因果转时。彼能作所作性分位差别。即不可得。彼非物体差别性故。若或施设彼有性等。此不和合。故名去者。复次颂言

  去法异去者　　是事亦不然

释曰。若离去法而彼去者。即不决定。若离去法不决定时。无复别异去者可去。此所分别。若有去者去法二种可得。即去者去法有二可成。所以有去法故即有去者。有去者故即有去法。如因果二不相离性。此说义成。若因果同生即无性可得。如种生芽。是故有去法故即有去者。有去者故即有去法。若一性所成。若异性所成。然去者去法二俱无有。胜义谛中此说成就。云何无所有。此义文广。恐繁且止。此中遮遣非复引证。为遮遣故如是表示。此所说已。余处应知。此后复当止遣何义。若因去法即知去者。彼如是去。云何二种有其别异。若然云何和合。复次颂言

  因去知去者　　不能用是去

释曰。不作是义。此中应问。无数义门从义界中出。皆转是义。今云何言不作是义。故颂答言

  先无有去法　　故无去者去

释曰。为彼如是去者所作。何有少法而可去邪。由如是故。世间所见。何等法是先来已生有所去邪。何等法是后来生时有所去邪。复次颂言

  因去知去者　　不能用异去
  于一去者中　　不有二去故

释曰。云何二去。一谓因去。知去者故。二谓若有去者复用去法。此中止遣。复次颂言

  若实有去法　　去者不用三
  不实有去法　　去者不用三

此中云何。复次颂言

  去法有不有　　去者不用三

释曰。若或实有若不实有。此中去者去法不用三去。若实有者。即去者去法和合。若不实有者。即去者离去法。若亦有亦不有者。二俱无性。或可实有者。去者有故。不实有者。去者不有故。亦有亦不有者。二无去法故。是故去者不用三去。所以不作是义。若彼实有去者实有去法。即所作不有。能作不和合。以不实有故。即无所作不有者为去不生故。亦有亦不有者。亦无所作。彼无性故以不有故。是故去者不用三去。何以故。如是去者自无性故。若有不有悉无所作。彼皆无性。若说去法。此中皆是随顺所说。复次颂言

  是故去去者　　所去处皆无

释曰。此说胜义谛中成就。如是别异说有能作所作作法。此中止遣。此中或说去之作用。如理应思。是故当知。此中所说作者作业作法。诸有分别皆无实体。为证成是义故此品生

    观六根品第三

前品止遣一切作者作业作法诸所造作相违行相已。复次颂言

  见闻及嗅尝　　触知等六根
  此见等六根　　说能取诸境

释曰。此论所说。如是见等六根行诸境界。谓眼见色乃至意知法。此有所说。当知皆是世俗道理。增上所作此无相违。若于胜义谛中。色等眼等所取能取性不可得。此复云何。复次颂言

  是眼即不能　　自见于己体

释曰。若眼能见自性者。彼眼即应如是同前。自见己体。以诸法自性不能自见无异性故。如火热性。亦复不能自见己体。是中亦无能见自性。复次颂言

  若不能自见　　云何能见他

释曰。无能见自性故。譬如耳等。亦无能见自性可得。彼眼若以能取自性于色境中有所见者。此说还成。眼为能见。譬如薪火变异。即说名烧。非火自体能烧。复次颂言

  火喻即不能　　成于眼见法

释曰。何所以邪。若彼热性能然火者。彼不热之性何不能然。是故若无彼薪。此火不有。热性不应能自烧故。复次颂言

  去未去去时　　前已答是事

释曰。如前已去未去去时不去中。已说是事。今此亦然。已烧未烧烧时无烧。已见未见见时无见。是故无已烧无未烧。不离所烧。无已见无未见。不离所见。如前所说。如其次第。随应止遣。复次颂言

  见若未见时　　即不名为见

释曰。若或为常。如瓶衣等。复次颂言

  若言能所见　　此云何和合

释曰。以不和合而彼见法亦复止遣。或可能见所见二法和合。彼即可说有能所见。然彼二法不和合故。何所以邪。于一见法中而彼所见不得和合。无别异故。若有能见即非无所见。若有所见。即能见应成。又若决定有彼见法。即彼能见亦复应成。能见若成。所见亦然。复次颂言

  能见亦不见　　见法无性故

释曰。若或离眼别有见相。可说所见。或说能见。以无能见及所见故。复次颂言

  所见亦不见　　见法离性故

释曰。此中若或诸缘止息。亦无能见所见可说。何以故。此所见中非能见故。若有造作彼即有见。说名所见。此中亦然。同上所说。于能见中无见可得。何以故。此中若有诸差别法体性可见。而悉止遣。若有如是能见所见见法发起即非无作者作业作法和合。见及见法亦有所起。此复云何。复次颂言

  离见不离见　　见者不可得

释曰。以无见法发起和合。第二见法本无性故。亦无决定而可发起。以彼见法离所见性不和合故。或可所见能见二俱无故。复次颂言

  以无见者故　　云何有所见

释曰。能所见性作用相违。若离和合性即无见者。若无见者即所见性。不得和合。此中能见所见决定无见。云何可说能所见邪。以见离性故。见无性故。或有人言。若谓诸行是空诸法无我。有此理故。如眼所见。即无别异能所见者。彼即无其实果可得。云何乃有识等四法而发起邪。故颂遣言

  见可见无故　　识等四法无

释曰。如所说理。此能见所见皆不成就。彼果生起识触受爱。如是四法云何和合。若决定有识等四法。即有彼果取法可生。以实无故。次颂遣言

  四取等诸缘　　云何当得有

释曰。谓以识等及取缘有生缘老死。此等诸法无所成故。无所有故。今此品初他所建立。闻等声等诸说皆止。此中见者悉无所作。是故颂言

  闻嗅味触知　　如是等诸根
  而悉同于上　　眼见法中说

释曰。此中应知。如眼见说能闻所闻等。譬如能见所有闻等。如应广说。此中且止。已遣一切不和合对治故。此说成就。此中能见所见见法。诸有分别物体无性。今此品中悉为证成。如是义故

大乘中观释论卷第三大乘中观释论卷第四

        安慧菩萨造

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

    观五蕴品第四

次第此品今当止遣。彼十二处诸有所作。或有异宗现所安立。谓于胜义谛中实有内外十二处法。以蕴摄故。论者言然此非无所摄道理。但以世俗谛中有其所摄。非胜义谛。以彼诸蕴无实性故

又有异宗。计所造色有性可得欲谓大种积集所成

今对遣彼等。是故颂言

  若离于色因　　色即不可得

释曰。色因者。谓地水火风。彼四大种。由其因故有色处等诸色可得。若离自性即不可得。是故世俗假施设有。若或别异物体有性。此不能说。何所以邪。复次颂言

  离色因有色　　色则堕无因
  无因无有义　　何法无因立

释曰。若因色中物体有性。即当对说。果色物体而有所成。若无因有果。即无所成义。是故无有无因可见。是中亦无少法可说。复次颂言

  若复离于色　　有其色因者
  即是无果因　　无果因何立

释曰。若果色中物体有性。即当对说因色物体而有所成。若有因有果彼所作性。如是乃说因法可转。此若如是离色因有色离色有色因者。即彼如是无坚湿暖动诸相离性。眼等青等云何可得。以色声等相离性故。同彼身中坚湿暖动诸有所得。今为对遣彼说。复次颂言

  若已有色者　　色因无所起
  若无有色者　　亦不用色因

释曰。若言有色。分别色因。或谓无色。或亦有亦无。此如是说。俱非道理。是故应知。非有亦非无。缘义和合尔

有异人言若尔无因当可得邪

故颂遣言

  无因而有色　　是事亦不然

释曰。极成法中无如是说

胜论者言。我欲谓彼地等极微诸色是无因色

论者言。彼无相似自类诸色无有体相。如是分别是果非果。俱非道理。譬如瓶等。地等所成。彼非无因。然极微因。无实因性。以无因故。如虚空等非一边故。此说非彼因性可得本性无体故。虽瓶等有因。而非意中谓彼一向有体可成。亦非同生性。以极微因而无果故。既非同生性。彼即非道理。又若分别虚空等。常非一切所向。以虚空等方分分别。若或别异有性可立者。故颂遣言

  是故于色中　　离有无分别

释曰。如其分别于诸色中能造所造若果若因计有体者。皆是诤论。安立处所。于自所成中而有相违。如佛所言。色处者。谓四大所造。彼能造义。即因义成。应知所说非胜义谛。复次颂言

  果若似于因　　此说即不然

释曰。彼诸大种坚湿暖动自性而不可见。非彼自性色有所得。是故非诸大种与果和合

有异人言。若尔即果不似因邪

为遮遣此义。故颂答言

  果若不似因　　是事亦不然

释曰。若不相似性即无果可成。止其果性故。受等多义亦同此说。复次颂言

  所有受心想　　诸行一切种
  及余一切法　　皆同色法说

释曰。彼受心想行皆同色法。止遣诸相。如所遮遣。是义应知。云何受心想行如彼色邪。谓离诸因即不可得。以眼色等因诸有分位彼彼无实因性所成。若或离彼无实因性。是中亦无少法可得。亦非离受等果见有眼色等因。以无果故因亦无体。若离自因有受等果而可成者。即离受等果。彼因亦有心。若离心因心可立者。是法无因。无有此义。何法无因而可立邪。若复离于心有其心因者。即是无果因。无果因何有此如是等。诸有所说。应知有为之法若离诸蕴而有性者。他所计执。譬如瓶等。若一性异性。皆止其义。余一切法亦如是说。复次颂言

  彼一切诸法　　皆同色法说
  若诤论安立　　随所起即空

复次若有乐说空者。应以空义答。是故颂言

  一切不离空　　一切得成就

又复显示彼一切法无自性义。是故颂言

  若见一物性　　一切法亦然
  若解一法空　　一切皆空故
  言说有所得　　诸所作皆空
  一切无所得　　一切皆成就

释曰。虽胜义谛中彼一切法说无自性。然所作所得而亦不空。彼如前说。皆得成就。于一切法无所得义而有所成。此中品初说蕴摄等。应知如是诸蕴无性无有所成

    观六界品第五

复次异宗所计。谓胜义谛中有地水火风识等诸界所成士夫。譬如虚空。彼引证云。如佛所言。诸苾刍当知。士夫六界成身。譬如虚空。此说见边

论者言。此说无相。谓世俗谛。如是诸相有所说者。非胜义谛。是故颂言

  空相未有时　　先无彼虚空

释曰。无障碍相即虚空相。此说义成。若或先有虚空而可成者。如是亦然。有相可立说为先有。若有是相此中即无成就因义。然此如是相非无成就义。此中但为止遣诸法自相。是故颂言

  云何无相中　　彼有相可得

释曰。如是分位无成就义。复次颂言

  无实相无体　　云何相可转

释曰。次当止遣。云何无相中而有能相。所相可转云何二俱。说为有相。此复云何。故颂遣言

  于无相法中　　相则无所相

释曰。于无相中无有物体。无分位可立。与相相违故。复次颂言

  离有相无相　　无异处可转

释曰。此遍遮遣。是中亦复无所成义。复次颂言

  所相既无体　　能相亦不立

释曰。所相不相离性故。复次颂言

  能相无有故　　亦无有所相

释曰。能相不相离性故。若二俱决定。即成对治过失。亦非能所二相有异性可成。若此如是有过失生。所说亦然。云何二法能成于一。亦复云何一法成二。故颂遣言

  是故无能相　　亦无有所相

释曰。若一若二有所成性。此中皆遣。故前颂言。能相无有故。亦无有所相。若所相可成。即能相无体。若所相能相二俱无体。别异亦无体。是故决定此皆无体

有异人言。无障碍处是虚空相。如是能相。相彼所相

论者言。当知此说即一分因。云何是彼无障碍处说为能相。此中如是亦无能相。此非道理

异人言。若彼虚空能相所相非道理者。何故虚空与三摩钵底为所缘相。又复欲贪断处为境界故。如是岂非虚空有彼能所相邪。彼相有故。此亦何无。故颂遣言

  离所相能相　　亦无有别相

释曰。如譬喻者言。有碍无体无物碍处是为虚空。此亦不然。若此无其有体。云何当有其无。亦非胜义谛中有质碍体。彼无性故。云何无体虚空。或计其有。如是对治有体此说总遣诸性。是故颂言

  若使无有有　　云何当有无

释曰。胜义谛中如是所有。若性无性悉离有体。如佛所言。诸苾刍。我此声闻乃至若有知解若无知解。如是所说皆世俗谛。非胜义谛。胜义谛者。此中颂言

  有无既已无　　谁为知解者

释曰。无性可成。彼即离相。此复云何。有性无性止遣相违。即彼有性于一切处悉不可得。是故颂言

  非有体无体　　无能相所相

释曰。如其所说同虚空法。此中地水火风识等五界所说。皆同彼虚空界。是等皆无所相能相。亦非有体亦非无体。皆如虚空遮遣一切所有言说。于诸句义中。若有诤论及邪见安立法中妄计路伽耶陀等。如是诸说皆非佛语。应当舍离。如其所说。此悉非有。谓以胜义谛中诸界处等自性不可说然此亦无无性可立但为止遣所作物性此中非彼无性可得。如是所说遍遣诸性

如异部师所说颂言

  遣有言无性　　亦不取无性
  如说青非青　　不欲成其白

此中应知。于二种见悉当遮遣。都无所得。诸界处等。若有所成。皆是世俗谛摄。彼彼所有别别自体。善不善法已生未生彼法常在。虽复勤作虚无果利。设使先有所生后即无性。若如是知。如是所成。此无过失。以是因故。性无性二有所诠表无所诠表互有相违。计有性可生。即非道理。是故亦非有性亦非无性。二法可成。何以故。从缘有故。先有性可生。所生即无性。性无所生故。有性非道理。如是无实所生。此说有者即是相违。若或一切有所生者。一切有生非一切故。若一切生有力能者。何名力能。因差别生。何能差别果有所生。彼等力能。此复云何。为有异耶。为无异耶。何以故。若有异者。即无分位可立能令果起。此即分别相违。若无异者。即彼如是一切皆有。是中一切生法可立。若离相者。即一切处应无差别。云何有性可生。彼决定因岂得和合。是故若一性若异性。此不可说。如是亦然。物体差别力能和合无能生因表了有性。若于无实自性法中。诸界处等如是决定。有所见者。此即相违。所有世出世间善不善法已生未生诸有所作。若欲不虚果利。应当断除世俗谛法。此所断者。谓即二种决定所见。此中颂言

  见有性无性　　彼即少智慧
  无真实微妙　　圣慧眼开生
  虽观于诸性　　当寂止诸见
  此即胜义谛　　远离一切见

释曰。若于诸见能止息者。即当远离诸娆恼性。于一切法而得寂静

大乘中观释论卷第四大乘中观释论卷第五

        安慧菩萨造

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

    观染法染者品第六

复次有异宗言。于胜义谛中诸界处等性与无性有所知解。由彼杂染成其有性。如佛所言。染者着染法故。行自损害行他损害行俱损害。如是乃至痴者着于痴法。其义亦然

论者言。此中非无杂染道理。虽有如幻。谓以无实染等体故。但以行聚所成。世俗言说。非胜义谛。何所以邪。此言染法。染者为先有邪。为后有邪。为染者染法俱时起邪。三皆不然。是故颂言

  若先有染者　　后有其染法
  云何离染法　　而有染者生

释曰。此说毕竟应知此义遮其所离。若染法无体。染者亦然。止其所作非熟无果有果成熟。其义可见。若离染法有染者成。如是乃应别有染法。此即染者因染法得。若尔云何染者有故染法即成。染法有故染者即成。然后起染。此义显明。如果成熟。若有爱境即染法成。若无爱境云何有染。应当止遣安立过失。此中亦非先有染者后起染法

故颂遣言

  有染者复染　　云何当可得

释曰。所依染法无体性故。如已成熟。复次颂言

  若有若无染　　染者亦复然

释曰。若先有染者后有染法。即一切处。如染法体。是故先无染者道理

令为证成此义。是故颂言

  染者先有染　　离染者染成

释曰。染法若无爱体可作。是中其或见有所成。此非道理

有异宗言。离彼染者别有染法。离彼染法染者可立

论者言。若离染法得有染者。此中非有。何所以邪。若先有染法后有染者即离染者乃有染法。此中染法不有。即无爱境能成染法道理。以爱境后有故。由如是故。若离自性别因染者。得有染法。即彼染法因染者得。若尔即非爱境能成染法。以爱境居后故。所成不可得。若如此者岂非过邪。亦非先有染法后成染者

复次颂言

  有染复染者　　亦云何当得

问曰。或离染法有其染者。既有对待过失。此中染法染者二法同起而可成邪

故颂答言

  如是若同生　　亦复非道理
  染法染者二　　此当云何用

释曰。谓以染法染者二相离性互有所违。若法未生二俱无性。若法已生所作无体。但由爱境所成染法故有染者。而彼爱境及所起染法悉亦止遣。问曰。彼染法染者为一性可合邪。为异性合邪

故颂答言

  彼染法染者　　非一性有合

释曰。此何所以。非彼一性而可合故。若有二法合即极成。此中应知。是提婆达多起染。不复为彼提婆达多染者之因。彼若说合。此非道理

复次异性亦不可合。故颂遣言

  异性若有合　　云何当可得

释曰。异法异性若有合者。彼即相违而非一处。有二法生道理可得。后当止遣

复次颂言

  若一性可合　　离伴亦应合

释曰。此言合者。同体为义。凡一性者即是因义。若此一性定有合者。如前所说提婆达多。合义应见。是故无一性因。可合道理。虽于一性因无合可成。然若止其合义。应知有过

复次颂言

  异性若有合　　离伴亦应合

释曰。此中所说。譬如瓶衣。彼等异性而不能合。若立合者。非有异性相合因故。如前即有对待过失。异性若合有所得者。彼非异性亦应得合。此岂无过

复次颂言

  若异性有合　　染染者何用

释曰。此中说合。无合道理。何所以邪。如是二法各各已成别别自体。即无别法为所成义。是中亦无所成可得。故知异性无有诠表。若计异性得有合者

故颂遣言

  若染染者二　　各各自体成
  是二若有合　　前亦应得合

释曰。而彼二法汝今云何。此说得成各各体故。若或染法染者。是二汝以何义分别二法各各自体令成其合论中言或者。此说合义。若起分别时虚无果利。彼等自体无所成性。若言合者。是中染者。无有少分染法可作染法。亦非染者可有

复次颂言

  异相不成合　　汝欲求成合
  合相若已成　　复欲成其异

释曰。合性不成。彼义极成。一法异性合不可得。异性极成不成合义。故无染法染者二法同时。或复次第异性可生。亦复更互相离性故。由是此中无合道理。今此观察如汝意欲。何等异性次第可起。或复同时

今为证成此义。故颂遣言

  如是染染者　　非合不合成
  诸法亦如染　　非合不合成

释曰。此中云何。所谓非唯染法染者。非合不合。诸法亦然

    观有为品第七之一

复次或有人言。胜义谛中有彼贪等诸杂染法。以有为故。譬如眼等

论者言。若如是说。遍所成故立喻不正。何以故。胜义谛中若有眼等。应有生等有为诸相。若其无者。如兔角等。亦应有彼有为诸相。是故有为诸相。于胜义谛中决定不成。云何生等有为诸相而可成立

此中应问。彼生等法增上所作。是有为耶。是无为耶。二俱不然

故颂答言

  若生是有为　　即应有三相

释曰。譬如能相。此中有为能相如是。不然云何有为诸相。此中所说二法和合三相遍行故。此中三相亦悉止遣彼法自相

复次颂言

  若生是无为　　不作有为相

释曰。如是所成应当遮遣安立过失。何以故。无为自体亦无性故。譬如灭法。此如是决定。有如是过失。如是住与无常。余法亦然。皆同生法

论者言。相者即是理法执持为性。如是所说。云何生等为复相离。有彼业用而可转耶。或不离耶

复次颂言

  生等三法离　　即无相业用

释曰。云何生等有为诸法次第可转。若法体未生。即住灭二法不能为彼作有为相。以未生故。是即能相无所诠表。若法自体毕竟已灭。即能相无体故无生住二法。以彼灭法自无性故。已生即无住。无住即无生灭亦无性。若言无常随逐住法。即不能作有为之相

故百论颂言

  住何有灭相　　无常何有住
  若先有住法　　后不复应有
  若常有无常　　有住不有常
  或先有其常　　后即不有常
  无常与住同　　若有其体者
  有常即邪妄　　或有住亦妄

颂意如是。若有为法不相离者。云何以一物体于一时中而得和合

故颂遣言

  不于一时中　　生住灭和合

释曰。以互相违故

或有人言。有彼同种因性一时可生。或复次第所作得成

论者言。此复云何。或复于彼有体中得耶。或离能相所相有所得耶。若有体得者。非于有体中有实体性同生可得。亦非所作别有其因。若或无体。此即亦无同生可有。是故体中无有如是决定生等。如生自相。亦复云何次第可成

复次颂言

  生住灭诸相　　别有有为相
  有即是无穷　　无即非有为

释曰。若离生等别有生法而可成者。彼即定有异法可立。如是乃有无穷之过。有为无为之相故非和合

复次犊子部师言。生等诸法虽是有为。云何可说为无穷耶

彼宗颂言

  生生之所生　　唯生于本生
  本生之所生　　复生于生生

此颂意者。诸法生时并法自体。有十五法共成生法。即彼如是有生住异灭诸法具足。此如是法无有差别。若差别分别者有十五法。所谓一生。二住。三灭。四若是白法。即正解脱生。五若是黑法。即邪解脱生。六若非出离法。即非出离法生。七若是出离法。即出离法生。八生生。九住住。十灭灭。十一正解脱眷属。十二邪解脱眷属。十三非出离法眷属。十四出离法眷属。除本生自体成十四法。若并本生法总成十五。生生及本生二法为始意。为此中生生所生唯本生生。更无别法本生所生还生生生。如是乃生诸余法等。此即不堕无穷之过

论者言。如是所说皆非道理

故颂破言

  若谓是生生　　能生于本生
  生生从本生　　何能生本生

释曰。自体如是无有性故

次颂破言

  若谓是本生　　能生于生生
  本生从彼生　　何能生生生

释曰。自体如是无有性故

又复有言。生生生时。即当能生。以无别故

次颂破言

  若谓生生时　　能生本生者
  生生若未生　　何能生本生

释曰。生生若未生。生时即无体。无体即不生。有何力能能生本生。若无力能即无诠表

大乘中观释论卷第五大乘中观释论卷第六

        安慧菩萨造

        西天译经三藏朝散大夫试鸿胪卿传梵大师赐紫沙门臣法护等奉　诏译

    观有为品第七之二

又复有言。我宗有别道理。令彼生法离无穷过。故彼宗颂言

  如灯能自照　　亦能照于他
  彼生法亦然　　自生复生他

论者言。作如此说。亦非道理。以无照故。若有暗冥即有所照。故颂破言

  灯中自无暗　　住处亦无暗
  破暗乃名照　　无暗即无照

释曰。今此观察若无有暗。是故灯不自照。亦不照他

复次颂言

  无少处可照　　是灯何能照
  生亦无少分　　生法可成就

又复有言。彼灯生时即可照邪

论者言。若灯生时亦不能照。以先分位无暗可破。若彼有暗即有所破。如是乃说。灯能自照。亦复照他。今此所说云何灯不到暗而能破暗。若不到者。故颂遣言

  云何灯生时　　而能破于暗
  彼灯初生时　　不能及于暗

释曰。灯初生时。无有性故。若或俱时。又无分位。若灯不到暗能破暗者

复次颂言

  灯若不到暗　　而能破暗者
  灯在于此间　　应破一切暗

释曰。同法若不到。差别因无体。譬如磁石。力能差别无决定因。此说亦非有其力能。先有所成故。如彼磁石所成皆遍。是法生时无所诠表。力能无体故。此复云何

复次颂言

  若灯能自照　　亦能照他者
  暗亦于自他　　暗蔽定无疑

释曰。此非所乐自所作处有相违故。灯亦复然。此非所乐。灯以照明为所成性。若灯与暗相违。灯即可成自照照他。无复别异所作性故。暗以暗蔽所成其性。若暗与明相违。暗即亦应自暗暗他。如是安立非有此义。如瓶等色现可见故

此中应问。所言生法自生。为未生生。为已生生

故颂答言

  生法若未生　　自体不能生

释曰。未生无体。故不能生。若其无者。如兔角等。因性不生故

复次颂言

  生法若已生　　生已复何生

释曰。若法已生还复生者。此义应知。如其作已。不复更作。是故生已何复有生。由此应知必无生法自生道理。若从他生。其义亦然。若生时生者。离已生未生。别无生时可得

复次颂言

  非已生未生　　生时亦不生

或有人言。彼生时者。少分已生少分未生。如是中间无别有体

论者言。若彼生法相离之性。或有少分而可生者。如是余法亦然可生。是中云何有所生耶。若一切法有所生者。如是谛观非今所说。岂有生时而可得耶。以彼生时无分位故。又一切法自体无分位可成。如是应知。若无生时。云何有彼生法可得

复次毗婆沙师言。有未来法体生向现在。故有生时可生

论者言。云何生时先有法体生向现在。有何异法说生时耶。此中无有少法。云何有其生法自体。以彼生法先无所得自体无性故。云何如是有所成耶。若复现转之法常不离自相。此说相违。若于过去未来转者。又非道理。若别异可生者。彼牛生时亦应有马。无此道理。若无少法以未来体生向现在。所说生时此即相违。由如是故。生时不生。已生法不生。若生已复生。彼即无体可生。以无自性故无。即如兔角无有生故

复次颂言

  去未去去时　　前品此已说

释曰。此诸所说前已广明

复次五顶子人言。若法实无生性。云何因法而得显明

论者言。彼等决定所说。此皆止遣。此中应知。不显明时因亦不离。亦复云何有其不离。此说显明。是故去未去去时。前品已广说。若或诸法有所离者。即成粗重前不实因。亦非如是先有所生。亦非离因别有法体。以有所离故

有异人言。有果可生。由自因和合故。或种子等和合因性物体功能及彼业用此无差别。若不生者。云何自生他生而得成耶。由如是故。彼一切果于一切时及一切处。皆有所生

论者言。所言和合者。为一性耶。为异性耶。或已生未生或复生时。自因彼果有和合耶。此所计执于一切处皆非道理。谓已生未生各无有性。彼因果二先性不立。无所诠表有性无体。是故汝所说种子等和合。已生未生皆无所有。已生未生各无性故。若有种子等和合。即所立相违。无未生性可诠表故。若其无者。如兔角等。是故无果和合可有。云何生法当有所得。又有人言。生法不相离。此说为生时。故颂遣言

  若生时有生　　彼生相已破

释曰。此非次第。此中云何若有若无亦有亦无。一切处离皆悉止遣

又有人言。若此生法从缘生时。云何所生无道理耶。如名瓶生。瓶从缘生。如是生时乃有所成

论者言。若彼生时决定有瓶。是瓶云何生已复生。彼瓶生时未有发起作用力故。是瓶云何别有生时别有生法而当得耶。且无瓶生之时。生已还有衣相可得。诸有所作若离所依。亦非道理。故颂遣言

  云何生时生　　而说为缘起

释曰。诸外道等。以巧辩才说缘生法。彼自相违。佛说缘生不同一切外道知解故。佛为破彼巧辩才勤求所知。彼所知法于胜义谛中伺察无义。彼外道等诬谤因果起恶见根本。佛以善法方便化度。为令彼断不正见故。如佛所言。此有故彼有。此生故彼生。如是等说。皆世俗谛。非胜义谛。胜义谛者

复次颂言

  若法众缘生　　彼自性寂灭

释曰。此义离自性故。如契经说。佛言。大慧。诸法自性本来不生。然以和合一切性亦非无自性

复次颂言

  是故生时生　　如是皆寂灭

释曰。此无不和合对治过失。况复如是有所生耶。故前颂言。若法缘生自性寂灭。无复自性故。是故诸法。无实因缘发起所生及作用等

又有人言。若法从缘生。可名生时耶

故颂遣言

  若法未生时　　如瓶等何有
  缘法假和合　　生已复何生

释曰。云何有体可生而无生时道理。谓所生非有故。譬如未生法。彼无自性。此说义成

复次颂言

  若生时有生　　是即有所生
  诸生性如幻　　此生复谁生

释曰。若法已生复有别异生者。生即无穷。是故决定无生法可作。亦非别有本生能生于生

复次颂言

  若生已复生　　是生即无穷

释曰此无未生。亦无本生。能生道理

复次颂言

  若无生而生　　法皆如是生

释曰。而彼生法亦然。何有意谓此生而为有生。真实理中无生可有。非意驰流谓一切有

复次颂言

  有法不应生　　无亦非道理
  有无俱不然　　前品此已说

释曰。证成前品云何生法而有所得。此中应问。灭时可有生法立耶。谓诸生相生已即坏。诸法坏性而同等故

故颂答言

  若灭时有生　　无体而可得

释曰。此中不应生灭同时。生时分位亦无有灭

复次颂言

  若法不灭时　　彼体不可得

释曰。如空花等。此中住法而非一向。有所住者。此说不成

此中应问。为未住体住。为已住体住。为住时住耶

故颂答言

  未住体不住　　住不住相违
  住住时不住　　此复何有住

释曰。住者现在过去二法一处同时不生。是故无住。又离已住未住。住时无体。谓以胜义谛中无生法可得。从前广说。悉为证成无实生法。生法若无。云何有住

复次颂言

  若灭时有住　　彼无体可得
  住灭二相违　　住位中无灭

释曰。若说无灭时。彼体不可得。灭法随逐有为相故。若住时有灭。无此道理。此中所说

复次颂言

  诸法于常时　　皆有老死相

释曰。老者衰变前相。死者坏灭为义。谓以自体于一切时而常转易。若有生时。即无老死法成。后亦不得生法可成。如火无冷性。今所观察

复次颂言

  而有何等法　　离老死有住

此中应问。诸有住法。为自体住。为别有住法而成住耶

故颂答言

  住不自相住　　异住非道理
  如生不自生　　亦不从他生

复次如别颂言

  此住若未住　　住体云何立
  此住若已住　　复何住可成
  若已住更住　　此住即无穷
  若或无住住　　法皆如是住

论者言。一切生法皆随顺说。若有灭处。即无生住。二法以相离性。彼不有故。如是生住灭法诸说皆然

此中应问。所言灭者。为已灭灭耶。为灭时灭耶

故颂答言

  已灭法不灭　　未灭法灭空

释曰。云何是已灭法不灭。谓法灭已灭即无体。此中灭法彼不生故。如是亦然。灭时及未灭二俱有过。何以故。谓一切法。于胜义谛中止遣其生

复次颂言

  彼灭时亦然　　无生何有灭

释曰。生法既尔。何有住体。灭亦不可得。住灭二法。彼相违故。是故无住亦复无灭。彼无住者。住性离故。若除遣住法。灭法即成。是故无有诸物分位。如是亦无一切物体

大乘中观释论卷第六大乘中观释论卷第七

        安慧菩萨造

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

    观有为品第七之三

复次自部答异宗言

  此分位定住　　先分位显明

释曰。如乳位中。乳亦不即。于此位灭。如前所说。有无二法。互相违故。复次颂言

  异分位定住　　先分位已灭

释曰。如是决定住异位中若有所转如酪分位无别异灭。何以故。酪已成时。乳即不生。此中决定坏失次第。各别分位无异性故。若言物体不灭。此即相违。或计灭有所得。彼非道理。今当止遣。他法既无生住可止。自法亦无。今所说灭。以自法无故。复次颂言

  如彼一切法　　生相不可得
  即此一切法　　灭亦不可得

释曰。此中云何。若一切处有灭法者。彼即无实。复次颂言

  若法是有者　　灭即不可得
  不可于一处　　有有无二性

释曰。互相违故。复次颂言

  无法即无果　　灭亦不可得
  如无第二头　　不可言其断

或有人言。依止灭体。是中欲令灭有所得。故颂答言

  法不自体灭　　他体亦不灭
  如生不自生　　他体亦不生
  此灭若未灭　　自体可能灭
  此灭若已灭　　灭已复何灭
  是灭若有异　　灭即是无穷
  灭若无所灭　　法皆如是灭

或造释者言。若彼生法止遣法自相者所说。即有对待过失。谓以胜义谛中有有为法对待无为。今对彼说。是故颂言

  生住灭不成　　即无有为法
  有为法不成　　何得有无为

释曰。对待所起。此说毕竟。譬如石女不生于子。世俗决定物体不成

此中应问。若无有为之法及有为相。云何世尊说有三种有为法相。故颂答言

  如梦亦如幻　　如乾闼婆城
  所说生住灭　　其相亦如是

释曰。诸法如梦幻及乾闼婆城。皆是分别智境界性。是故显示象马车步男子女人国城等相。彼体皆空。是故所有生等诸法皆是智境界性之所发起。于胜义谛中所显无体自性空故。故佛欲令于诸行中舍离常见。令得调伏。乃作是说。止生老等。所言老者。老亦非老。此即自语有所得相违。是故颂言

  老亦不离老　　老时无所有
  此性老不成　　异性亦如是
  是故一法中　　老即不可得
  老老而无老　　非自体他体
  此老不自老　　一切老亦然
  老若有别异　　老即是无穷
  解脱出离道　　自具足亦然
  若法离自相　　果亦不可得

释曰。如说解脱。诸有善法此即说为缘因。彼善法性若有所得。云何说彼以为缘因。若尔而彼识等亦可说为缘因而有所得。何以故。以差别性彼无体故。差别识性亦非自体。有善法性以其自体诸善法性为缘因故。于解脱中无有果利。若善法性因有解脱者。如是决定舍离自体。何以故。以所立诸法入自体故。若不尔者。如前所说。云何不以不善解脱而成善法解脱所作。若如前说。善法解脱此亦不离有分别故。是故当知。彼一切法若已生若未生二解脱因。彼即不生。复次颂言

  已脱不可说　　未脱不可说
  脱未脱无说　　脱时亦无说
  此解脱若异　　解脱即无穷
  若无脱而脱　　皆如是解脱

释曰。若如是知。彼出离道亦然。具足如所生说。诸佛世尊。于契经中。有说颂言

  色法如聚沫　　受即如浮泡
  想同阳焰生　　行如芭蕉相
  识如彼幻法　　显示所立法
  如梦如影像　　亦同于响应

复说。于诸行中一切法无我即无自性。当知此中所言我者。即是自性别名。此中所说。彼真如法无有戏论。若说决定皆是虚诳妄取之法

    观作者作业品第八

或有人言。前品所说。破一切法诸有所作。有为不成故。何得有无为。若作此说。何故与彼阿含相违。如佛世尊。于契经中。有说颂言

  应修善法行　　勿修恶法行
  修善法行人　　二世安乐寂

如此颂意。即有作者作法。亦复有果。所说是实如所观察。何故但言世俗。非胜义耶

论者言。诸有作者。于胜义谛中。若实有若不实有。若亦实亦不实有。作业亦然。若实有若不实有。亦实亦不实有。由如是故。而彼作者于所作中若实有作者。亦应实有作业。如是互推。作者作业皆无有实。若实不实二种俱于胜义谛中。无极微许决定实法。若作者有实。然亦无实作业可得。若作业有实。而彼作者亦不和合。复次颂言

  作者若有实　　亦不作实业

释曰。若如所说。何可信耶。故下颂言

  实所作无故　　无所作差别

释曰。若复止息善不善业。即所作不生。若所作中有二。作者亦复有二。亦非于所作中有能作者。此遣法自相。此复云何。故下颂言

  有业无作者

释曰。若于作者作业中。执着所作生起。此即还成法自相相违。今当止遣。复次颂言

  无实所作故

释曰。以无所生作用差别故。若复作用有所和合。即所作有二。业亦有二。亦非离其所作有业。此遣法自相。复次颂言

  有作者无业

释曰。若所作业与作用法彼相离者。即能作所作二俱丛杂。此遣法自相

复有人言。若有能作及作用法彼即有业生起。应可说为实有作者。以作者生时业亦无异。由有作用和合故。彼亦无别实有。此无过失

论者言。何名无过。以作者作业及所用法彼能作所作悉无作故。此中若有能作所作。过如先说。若无所作。能作亦无。以离所作故。此即云何。有其能作所作及所作业用。此如是故。余处亦然。随应遮遣。今此文广。恐繁且止。复有人言。作者所作之业不实可尔。而彼作者可应实有。今为对遣彼说。是故颂言

  作者亦无实

释曰。若计作者作业为实。今此言中亦当止遣。复次颂言

  若实有作者　　亦实有作业
  作者及作业　　二俱堕无因

释曰。此言能作即是作者。此言所作即是其业。若或所作离于作者有业可作。如是亦当但有作者无所作时应有作业。有即无因。若作者作业堕无因性。即有一向过失。此应思择。复次颂言

  若有果无因　　因即非道理

释曰。此言因者。即说为缘。若法有因转时缘即随摄。因若无体现事止息。此即是无。云何有义可摄于缘。此复云何。故下颂言

  作作者无体　　作用不和合

释曰。如断薪等。若无所断果体。彼能断者及断所用作具斧等皆不和合。断所作用当何有依。彼无体故。作者作业无体亦然。此复云何。故下颂言

  若无法非法　　所作等无体

释曰。若离所作。能作作用即无有业。故下颂言

  法非法无故　　从生果亦无

释曰。此义云何。由此即无恶趣善趣及解脱道随应果等。复次颂言

  无果无解脱　　亦无生天道
  非唯生天道　　解脱道亦无

释曰。若尔世间诸有一切作用。皆悉堕于无果利中。世间果者如种子等。作用随转即能生果。彼若无体即无果利

或有人言。如是所说作者无实。其义可尔。彼所作业此乃是实。以能作故。此无过失

论者言。此何无过。今言作者。即是因之别名。业即是果。且非果法离因自体别有所作。如是若有作者作业。即有因有果。和合建立。今此如是作业不异于作者。作者不异于作业。故所作业而亦不离。以差别因彼无性故。此云何知。若法有缘及所作具。即因果性成。今此所说非不显明

或有人言。作者亦实亦不实故。作业亦实亦不实故。下颂答彼增上言

  作者实不实　　亦不作二业
  有无互相违　　一处即无二

释曰。于一法中有无二法和合作用。彼即无体。非道理故。如是决定和合作者作业亦不可得。以相违故亦非道理。复次颂言

  作作者作用　　所作实非实
  着即生过失　　此因如先说

释曰。此中应知。若实不实皆对待所说。故下颂言

  所作实不实　　亦实亦不实
  作者及作业　　此因如先说
  作者诸所作　　非实非不实
  应知业亦然　　此因如先说
  实所作即无　　不实又无因
  有无互相违　　一处何有二

释曰。此中所说三种对待。如生法说。是故应知。非佛世尊于一切处而悉止遣作者作业及诸作用。此即不堕诸无因过

论者言。此实无过。我亦不说无其作者及彼作业。何以故。我欲表示作者作业互所成故

复次颂言

  因作者有业　　因业有作者

释曰。应知此中随转施设皆无自体。作者作业。若成不成。离有离无。证成中义。世俗所得。故下颂言

  世俗遣异性　　我见成就相

释曰。若有人言。此与阿含相违者。彼因义不成

有外人言。胜义谛中有其作者。何以故。如佛所说有能取所取故

论者言。今为遮遣彼说故说。于彼诸作用中有其能取。若能取所取二法不坏。即作者随转亦不相离。如是应知。能取所取互所摄故。由是建立。因作者有业。因业有作者。是故因其能取而有所取。因所取故即有能取。此即非胜义谛。今复云何。离彼作者作业有遮遣邪。此中所作因义。若或止遣作者作业。彼能取所取。此亦应离

复次颂言

  若胜义谛中　　有作者作业
  彼能取所取　　此亦应遮遣
  作者作业等　　此义如是故
  余法自及他　　相因义应观

释曰。若果若因。能相所相。同生不同生等。因果二法物体有得。若言有因。即堕果数。如彼生法。若有义可取。即彼有性。若彼无者。非彼有生。色等诸法若无义可取。即彼无体可观。何况因果离于自体而有力能。若离自体有力能者。即有所得相违。譬如离于泥团可有瓶邪。物体分位法中所起。此说即是瓶生泥团。譬如瓶水。无彼别异分位性故。亦非瓶如木故。又非泥团分位即说有瓶。犹如别瓶若自力能而有所得。此即相违。若乐等法因有力能。即有乐等果法。乐等有故即乐等差别有所发起。此中所说。有所得者。此说亦无少法相违。若离因果而有力能。说所成者。如是决定彼无力能成其因果。此即或成颠倒计执。或成决定。不共因中相违离因无体故。若不共因非一向成故。若因果和合。即物体有性。如是所说因果二法。此中应知非胜义谛

大乘中观释论卷第七大乘中观释论卷第八

        安慧菩萨造

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

    观先分位品第九

前品中说。如作者作业。彼能取所取二法。亦互不相离施设有性。非胜义谛故。有异宗说此颂言

  眼耳等诸根　　受等心所法
  彼所取若成　　有取者先住

释曰有一宗人作如是说。彼说有因。故下颂言

  若无彼先住　　何有眼耳等

释曰。此中意乐先有物体。譬如织者。故下颂言

  以是故当知　　先已有法住

释曰若彼所取见等有法先住。乃有所取。如造器用

复次颂言

  眼耳等诸根　　受等心所法
  有法先住者　　以何可了知

释曰。彼宗意者。应知有其他法能取。即有所取可得

论者言。彼眼等根别异。所取先无其体。此义不成。此遣法差别。若或施设所取不有。即所施设物性无体。如无经纬即[疊*毛]等不成。此遣法自相

复次颂言

  若离眼等根　　有法先住者

释曰见闻及受者。此等诸法若有先住。故下颂言

  应离眼耳根　　有见等无疑

释曰。今此非有。其眼根中无有见法可得和合。非离眼根有见法故。如是所说。余义亦然。离眼等根而有何法。若取若舍若异眼根。何有见闻。若无所取。或见或闻。云何可知。此是所见所闻。此是能见能闻。亦非眼等先有能见及受者可成。此复云何差别。见性不有体故。何以故。若离眼等有法先住能成见闻者。此即无住。若不离眼等有法先住。此乃见即是闻。亦非道理。非见分位灭故。若或如是能见眼根与所见相不相离者。是故离眼等根亦无所取。何有能取。若见若闻。若离所取。复何能取。或有颂言

  一切眼等根　　实无法先住

释曰。云何一一根有法先住。故下颂言

  眼等根所取　　异相复异种

释曰。此非眼等彼一一根先有法住。复次颂言

  若眼等诸根　　无法先住者
  彼眼等诸根　　当云何先有

释曰。若一一根决定有法而先住者。此乃先复有先。若尔为即为离邪。今此如是。亦非眼根之前先有彼余耳等诸根。彼等未有成故。此复云何。故下颂言

  若见即闻者　　闻者即受者
  一一有先住　　如是非道理

释曰。非离见分位中有彼闻者受者而得和合。亦非先有眼等诸根见性可得。眼等相违故

复次颂言

  若见闻各异　　受者亦复异
  见时若能闻　　即成多我体

释曰。若眼等一一根。先各有异。即见闻各异。受者亦异。若或见等次第所成。如是若有见即能闻者。此乃因见有闻。此复云何。以各别相续成多我体。若言别有取者。此应观察。彼宗引云。如佛所言。名色缘六处。而彼色者四大所成。即有能取所取。是故实有取者分位。由眼等根与六处和合次第。乃有受法生起

复次颂言

  眼耳等诸根　　受等心所法
  彼从诸大生　　彼大无先住

释曰。彼能取性毕竟说者。云何离彼所取先有大种所成。若尔即非所取。以能取非所取成故。若所取如是决定有彼所取性者。如秤低昂。即因果生灭离所取法。彼同时性如是决定。能取差别即有多性可得。非无差别一性同生。以离所取有所成故。若或大种所取随生。即无法先住。若彼大种无先住者。云何大种所成眼等诸根有其所取。亦非能取所取中间决定有法可得

复次颂言

  眼耳等诸根　　受等心所法
  若无先住者　　眼等亦应无

释曰。若眼等诸根无法先住者。即无有法能取所取。即何有眼等能取相待因性

有人言。应知能取无性可得。此即是为发生正见舍离邪见。如佛所言。若法有性皆如幻化。此即正见。若法无性如幻化者。此即邪见。此中颂言

  彼眼等先无　　今后亦复无
  以三时无故　　有性皆息灭

释曰。诸有分别于胜义谛中悉不成故。若有分别皆是世俗施设所得。胜义谛中即无分别。遣有性故。世俗谛中有所得法。皆如幻化。如前所言。有法先住者。即是邪见所说。此无相违

    观薪火品第十

复次所作。如说薪火物体有性。非如作者作业一向对待所成。若薪火二法决定有性无性。如作者作业此即不成

此中应问。若欲令其薪火二法物体有性者。为一性邪。为复多性有所得邪。此义云何。是故颂言

  若火即是薪　　作作者一性

释曰。有所安立。此说毕竟。此言薪者。因薪能作于火烧时此有薪之业用。薪火非一。是故作者作业非一性故。如陶师与瓶。此遣法自相。薪火若一性者。即能烧所烧薪火二法不得和合。此遣法差别。故下颂言

  若薪异于火　　离薪应有火

释曰。此中意者。若异法异性现事止息。即无能烧所烧。若火烧时薪即不有即无所起。此应思择。若无起时彼即无性。亦非无薪有火可见。若异于薪亦不见有因待之法。是故无异。如无经纬即[疊*毛]等不成

复次颂言

  异即应常然　　火不因薪故
  薪即复无功　　此业用相违

释曰。虽有他法不相因待。不因彼薪火自烧故

复次颂言

  火若常然者　　然火功相违
  此如先所说　　离薪别有火

释曰。若无其薪火常然者。此即无因。若尔离薪常然乃可安立。若火常然能发起者。彼然火具等诸相施作而悉相违。如是即无作业功用。有薪亦无因待起处。即所烧相业用无体。若谓烧时离火有薪。火不灭时异薪无体。若无有异。此岂无过。云何烧时中有其薪。若无所烧之薪异火有者。当火烧时薪亦遍有。火若遍有。如是当知。薪无异性。此应思择。若言烧时不有薪者。是故薪火俱无异性。若谓烧时有薪。此非道理

复次颂言

  异火即不到

释曰。与到相违故。如别物体。故下颂言

  不到即不烧

释曰。譬如别薪。故下颂言

  不烧即不灭

释曰。若薪尽即火灭。其或离薪即然火不成。故下颂言

  不灭即常住

释曰。若自体常然者。如积土块。云何离火而有薪邪。以异不到故。若言薪在火中。此亦不然

复次颂言

  若异薪有火　　即薪能到火
  如此人至彼　　彼人至此人

释曰。如是决定与到相违。若如是说喻即不成。此乃有所得相违之言

复次颂言

  若异薪有火　　欲令薪到火
  彼二互相离　　薪火何能到

释曰。如彼人此人勿以一性异性取其物体。彼若有者。即互相因待若其无体。如石女儿。若法因待而有。如是乃有能取所取。亦不可说一性异性。物体有性此即成就

复次颂言

  若因薪有火　　亦因火有薪

释曰。能烧所烧二不可得。故下颂言

  二何法先成　　薪火相因有

释曰。此毕竟说。彼二先后俱无体故。此意即。是无相因待。若彼二法有异性先成。即有薪火相因。若其无者。此非道理

复次颂言

  若因薪有火　　火即成复成

释曰。此中何因有彼薪火。相因道理。故下颂言

  亦非不有薪　　而有火可得

释曰。火不因薪。彼无体故。火亦如是。若先有所成。复因薪而有。此即云何。二法互相因待先后可得。若此所得同时发起。亦非互相因待道理。此复云何。故下颂言

  若法有因待　　是法还成待

释曰。若彼二相因者。即彼薪火二相还成待法。此应思察故下颂言

  二法无所成　　已成云何待

此义云何

复次颂言

  若未成有待　　未成当何待

释曰。未成即无体。因待亦无体。故下颂言

  若因待有成　　自待非道理

释曰。若自体有成复。何所成彼。薪火相因是。义不成

复次颂言

  二因成无体　　无不因薪火

释曰。若不因薪。火应常然。故下颂言

  因薪火亦无

释曰。先后相因而不成故。故下颂言

  因火亦无薪

释曰。亦非烧时有薪。彼无体故

复次毗世师言。有不见相极微之火。有业及业用。二法差别。是中先有一分和合。如是乃有薪一分来发起火相。故颂遣言

  火不余处来

论者言。今此何因业用和合。以差别因性所生故。若有分位业用生起。即彼分位。彼彼方处各各差别。汝先说言一分和合。此非道理。以业无依故。亦非起时。若合若离差别因性业用分位有所生起。亦非离所起时别有对待因性可得。生时如是果体作用。此中亦非先无差别。亦非法差别因。中间一分无体。亦非中间一分而得和合。于差别中若有一分和合。即俱时分位所作相违。亦无坏其业用。所生道理或有害故。若计灭有所得。即彼物体还复堕于差别法中。是故当知。火不从彼余处而来。亦无如是自差别所作一分有体和合。云何于彼差别不差别中。计着多性。又一分中亦有所著。又于无分位中着火有性。如是薪火二法。此应思择。如前已说。次下颂言

  薪中亦无火

释曰。离火亦无差别因性。彼火因果无异性火故。此应思择。又复能取发起所得。彼即不有。是故无别异性薪从余处而来至火。亦非无火。故下颂言

  余法亦复然　　如去来品说

释曰。若或无薪。云何得有能烧所烧。若有所烧时。非无能烧。亦无能烧中有能烧发起。若有能烧时。非无所烧。是故无能烧所烧亦非相离

大乘中观释论卷第八大乘中观释论卷第九

        安慧菩萨造

        译经三藏朝散大夫试鸿胪卿光梵大师赐紫沙门臣惟净等奉　诏译

    观薪火品第十之余

复次颂言

  即薪而无火

释曰。遣一性故

  异薪亦无火

释曰。薪火二法遣异性故

  火中亦无薪　　薪中亦无火

释曰。总遣异性故。此中薪火二法。一性异性俱不可见。如瓶非木。又如水中莲花。异性不成故。是故胜义谛中。薪火二法非相因有。而彼二法毕竟空故

复次颂言

  如说薪火法　　能所取亦然

释曰。一性异性互相因待次第不成。复次颂言

  余诸法皆同

释曰。彼能取所取。非作者作业一性可着。亦非异性所取。离亦不生。若异性所取。即互不到。不到即不烧。不烧即不灭。不灭即是常。若法常住。彼即互相因待不成。若成不成二法。相因毕竟无体。若人计火从余方来。有其能取及所取者。此义不成。故下颂言

  及彼瓶衣等

释曰。彼瓶衣等因果二法。同生不同。生能相所相。彼等所成。如非泥团即是其瓶。彼瓶果法有作用故。亦非异瓶别有果法作用所成。非彼二法互相因待。若成不成相因无体。此如是故。余处随应所说亦然。若胜义谛中无一异性。是故不应取着

如有颂言

  非受非不受　　异复云何有
  如能取所取　　诸所说亦然

复次颂言

  若人执有我　　诸法有实性
  各各差别说　　彼不解佛法

    观生死品第十一

复有人言。胜义谛中亦有生死。何以故。如佛所言。生死长远。众生愚迷不知正法。我欲令彼如理修行得尽生死。乃作是言。汝诸苾刍。应如是学。以此证知。胜义谛中有其生死

论者言。如佛所说。皆是方便世俗施设。非胜义谛。亦非不有生死而说。长时有法可尽。彼生死者众生所受。若如理修行。即能尽彼生死有性。此中先说薪火二法能取所取彼等次第。此非道理

复次颂言

  大牟尼所说　　生死无先际

释曰。此义云何。所言生死者。即是无际。无际即无始。今此义者。无最上无先际。故言无际。又非有彼先际。故名无际。故下颂言

  今此如是说　　无先亦无后

释曰。先后义无体无自性故。如兔角等。应如是见。由如是故。中亦不可得说。非不有故。如兔角等

复次颂言

  若无有先后　　中复云何有

释曰。生死无自性。彼云何有。故下颂言

  是故此中无　　先后共次第

释曰。此中应问。如所表示。无先后共。即次第不生。而何有众生受生老死。又云何修行。尽生死有性。此即不成。故颂答言

  若使先有生　　后有老死者
  不老死有生

释曰。若不离老死而有生者。应不离老而有死邪。故下颂言

  后老死非理

释曰。若或异法有所成者。譬如牛马。异体应可同生。云何生不有死。又何不死有生。若生老死先有体者。即彼本来有其生死

复次颂言

  若使后有生　　先有老死者
  彼所有老死　　无生即无因

释曰。无因即无所依。无依即无生。无生即无相续有性

复次颂言

  无此生老死　　亦无有先后
  老死亦复然　　亦应与生共

释曰。此义云何。若言生时有其死者。以彼生灭二法无同时性。又复无因二俱不生。彼无性故。若或同生。又生老死无相待因性

复次颂言

  若不生即无　　先后共次第
  云何戏论言　　有生老死合

释曰。胜义谛中戏论不生故

复次颂言

  若诸法因果　　能相及所相
  所受及受者　　真实义如是

释曰。能知所知等一切法。先后共次第皆不和合。若先有果后有其因。果即无因。此即因有相违。若先有因后无果者。即因果不和合。若因果二法同时有者。如是决定彼因果性亦复无体。若已生若未生。二法相因俱无体故。能相所相所说亦然

复次颂言

  非但说生死　　先际不可得
  诸法亦复然　　先际不可得

    观苦品第十二

复有人言。胜义谛中有彼诸蕴苦所成性。如佛所言。略说五取蕴。由苦所得故

论者言。此等所说皆世俗谛。非胜义谛。何以故。此苦果故。此苦果者多种分别

复次颂言

  自作及他作　　共作无因作

释曰。有一类人。欲令此苦各别系属。故下颂言

  彼等于诸果　　所作非道理

复次颂言

  苦若自作者　　即不从缘成

释曰。若自作者。而彼诸法皆自体所成。非同生性故。若离自体即无对待因性。亦非同生可有。故下颂言

  以有此蕴故　　有未来五蕴

释曰。缘所成故。此中若法缘所成性。即无自作。此遣法自相。又复亦非他作道理

复次颂言

  若有此五蕴　　与未来蕴异
  于此彼蕴中　　应有他作苦

释曰。今此五蕴与未来五蕴诸有所作。非此二法互有他性。何以故。灭与未生二无性故。此中亦非苦能作苦。自作他作。云何可成

复次颂言

  若人自作苦　　离苦何有人
  云何自作中　　离人而有苦

释曰。若复离蕴无所施设。彼复云何有苦可作

复次颂言

  若苦他人成　　授与此人者
  他亦名自作　　离苦何有苦

释曰。此非离苦而复有苦。苦无异故

复次颂言

  若他人作苦　　离他何有苦
  亦非有作已　　他能授于此

复次颂言

  自作若不成　　复何有他作
  若他人作苦　　即亦名自作

释曰。或有人言。若人自作苦。即非他所成。应有他作邪。对此异意。故下颂言

  苦不名自作　　亦非他人作
  是故所作中　　离苦人无体

释曰。今此如是。非有所作。亦非有苦。若以彼苦自作苦者。即自所作。道理相违。是故此说以无有人何有他作。彼无性故。若复他无自体。是中云何他能作苦。若人自体不生。即无所有。他体不生。即无他作。是故无有他能作苦。若或自他二法共作苦者。亦非道理

复次颂言

  若有自他作　　即有共作苦
  今无自他共　　无因亦非理

如有颂言

  他相若自作　　他相此无因
  此若有自因　　何有无因作

释曰。胜义谛中苦无体故

复次颂言

  非但说于苦　　四种俱不有

释曰。此复云何。色等亦然。故下颂言

  外诸法皆同　　四种俱不有

释曰。色非自体作故。彼能作所作。若有若无。皆非所作。若有能作。即所作无体。无即非能作。云何无中计有我作。此即着于能作。亦非他法。成已复成色法作用。是中亦非他性可成。今此所说。若从缘生。彼即无有异法可得。亦非自他缘法不生。又一切法非无因故。由是胜义谛中。色等诸法体不可得

    观行品第十三

前品所说破色等蕴。此即亦有对治相违。何以故。如佛所言。诸苾刍。汝等应当如实了知。色是无常。乃至识法亦是无常。以此文证。有色等蕴

论者言。此世俗谛增上所说。非胜义谛。故有颂言

  若彼虚妄法　　是世俗有为
  无妄涅槃法　　即是胜义谛

释曰。此虚妄者。是邪智境界。愚人不实。于虚诳法无分位中。计色有性

复次颂言

  彼虚妄法者　　诸行妄取故

释曰。此即无所得相违。故下颂言

  即彼虚妄法　　是中何所取

释曰。无所有故。譬如兔角。虚妄之法而不和合。是故虚妄法者。虽有所说皆是虚妄。故佛世尊广为开示。普尽一切若根若随烦恼所知二障等法。皆悉是空。使令除断即彼空性离二边故。此中所说诸虚妄法。决定皆是世俗谛有。若虚妄法。于胜义谛中。如乾闼婆城。又或虚妄法者。虽复所说是中亦非妄法可有。故佛世尊诸有所说。悉无相违。若言诸法不有。即是证成自性空义。遣妄执故

复次颂言

  诸法无自性　　见有异性故

释曰。若见有法变异之性。彼即无我。无我即无常。无常即不有。如是所说。是为虚妄。此法如是。故下颂言

  无性法亦无　　一切法空故

释曰。虽说诸法皆空。即彼诸法犹如空花。亦非有彼无自性法。又或无所成故

复次颂言

  若法无自性　　法云何有异

释曰。若法有异。自性亦异。若彼诸法无自性者。即不和合。是故若见诸法各各自性有别异者。云何不说此为虚妄。故下颂言

  若法有自性　　亦复何有异

释曰。若其无者。即无法可有异性和合。计有性者。即堕过失。此复云何

复次颂言

  若诸法即异　　无异法可有
  现住法若异　　后变异不成

释曰。若后异者。譬如老作老相。此即自比量相违

或有人言。若不离自体有法可异者。乳应即成酪。若尔即有因一向过失

复次颂言

  若法即有异　　乳应即成酪

释曰。亦非离彼滋味气势报体等法。乳即成酪。以缘性故。又复亦非异乳有酪。此即于第二时有一向过失。故下颂言

  若或异于乳　　云何得成酪

释曰。亦非异乳有酪可得。此即不堕一向过失。是故无有异法可见。有即虚妄。何以故。自性空故。胜义谛中。亦无少分不空之法对待空法而有所成

复次颂言

  若有不空法　　即应有空法
  无少不空法　　何得有其空

释曰。因不成故。此中非有空法可说。今此如是证成。世尊所说空义。如其所说。此复云何。故下颂言

  遣有故说空　　令出离诸见
  若或见有空　　诸佛所不化

释曰。此即遣诸空执。诸佛世尊所说无疑。何况有异。若欲有其空者。此乃于法自性有所取着。此中亦非有性可取。应当舍离。若或于空有所取者。此即边执。彼有执者无异方便。应知此等佛所不化

大乘中观释论卷第九


大丈夫论

    No. 1577

大丈夫论卷上

        提婆罗菩萨造

        北凉沙门道泰译

    施胜品第一

  敬礼等正觉　　大悲哀世尊
  因彼起正法　　三界中真济
  众中第一尊　　无量功德藏
  菩萨本所行　　我当说少分
  我今哀愍彼　　开演妙施门
  一切诸贤士　　应当欢喜听
  菩萨行施时　　大地皆震动
  巨海涌众宝　　慧云雨妙花
  无心犹如是　　况有情识者
  菩萨施广大　　犹如虚空界
  假使五通仙　　充满十方刹
  听闻犹尚难　　况复分别说
  无有地方所　　而不以求施
  净水浸大地　　无有不遍处
  无有一切物　　菩萨所未施
  无有一众生　　不曾受施者
  论者语大地　　一切应礼汝
  何故礼大地　　菩萨行施处
  菩萨一日施　　种种众杂物
  辟支佛百劫　　不能知边际
  所以不能知　　大悲为施体
  能成种智果　　施因为最大
  此是智者说　　施能到彼岸
  若一到彼岸　　诸度悉具足
  波罗蜜义者　　名为和集声
  譬如多人处　　名之为大众
  菩提之种子　　能成大智果
  一切众事具　　莫不由施成
  施是生天道　　出世之胞胎
  无相施为妙　　平等为最胜
  身及物皆施　　无有所吝惜
  一切处皆施　　无有方所者
  一切时皆施　　无有不施时
  于此四施中　　心智常不动
  如是行施者　　名不思议施
  若施一众生　　一切尽蒙乐
  若不如是施　　是名为欺诳
  虽名施一人　　是为施一切
  所以名一切　　大悲心普故
  大悲所以普　　为求种智故
  施佛及罗汉　　世名良福田
  不悲平等施　　是为最胜施
  无量财宝施　　不如暂止息
  悲心施一人　　功德如大地
  为己施一切　　得报如芥子
  救一厄难人　　胜余一切施
  众星虽有光　　不如一月明
  众生垢心重　　所施恒为己
  菩萨悲心施　　如灰去众秽
  救济慈悲施　　普为群生类
  如是慈悲施　　功德无穷尽
  如此微妙施　　安乐诸众生
  贪求佛智慧　　心无有厌足
  如是悲心施　　能除无明障
  开导愚冥者　　使得智慧眼
  能灭诸结使　　消伏老病死
  施与悲心俱　　众生之甘露

    施胜味品第二

  大悲所起施　　意愿成菩提
  如是知见人　　能成一切施
  如是一切施　　终成一味智
  大悲心为体　　能起种种施
  种种救众生　　得到于智处
  能除诸爱结　　及以无明垢
  能令一切众　　悉皆得安乐
  如是悲心施　　谁不生爱乐
  大悲心所起　　功德之施利
  不能生爱乐　　背离于救济
  是人为爱系　　菩提甚难得
  诸欲求佛者　　爱乐施甘味
  智人喜惠施　　甘乐菩提味
  深见三有过　　涅槃味甚乐
  速疾欲远离　　一念顷不住
  又见于施乐　　复过于涅槃
  爱乐施自在　　心则忘菩提
  心既忘菩提　　谓菩提难得
  自观乐施心　　由悲众生故
  不觉施味乐　　施有三乐味

一者求报施味。二者求解脱施味。三者求大悲心施味。此三种味者名增长乐味施

    施主体品第三

受者得无量珍宝心大欢喜。施者行少施时心大欢喜。过于受者百千万倍。能如是施者是为第一行

  成就救济者　　饮大悲甘露
  菩萨行此行　　永除悭病老

菩萨悲心以施为体。世间众生以结使为体。纯以众苦以为一味。为得乐故行悲心施。日以照明为用。月以清凉为性。菩萨以悲为体。智慧及财施安乐于一切。如从歌罗逻乃至老时十时差别虽至于老不舍婴孩之相。菩萨虚渴施心救济众生亦不舍凡夫。离欲至于非想不离凡夫之相。菩萨不舍施心救济众生亦复如是。欲除施渴当饮大施之水。施渴暂息余渴不已。爱乐施故。一切众生依食而存。大悲亦尔。依施而存。菩萨法身不依饮食而得存济。大悲为食菩萨身存。悲心如火。欲施如饥。施与好食。菩萨乐与无有厌足。悲如大海施如沃焦。救济心为水如沃焦吞流。欲向菩提以众生为伴悲心为体。施无厌足如海吞众流无有止息

  一切众生来　　各各索异物
  菩萨皆施与　　心无有疲惓
  诸苦恼众生　　尽皆为除灭
  设有未除者　　心无有厌足

    施主乞者增长品第四

有大悲者能处生死。种种施与灭众生苦。若能如此善住生死

  福德善丈夫　　悲心施惠手
  拔贫穷淤泥　　不能自出者

悲心为体能行大施灭众生苦。如盛热时兴大云雨。起大悲云雨于施雹。摧破贫穷如坏山石。拯贫穷者无限齐施。令彼穷者永离贫苦。以大施雨普益一切。众生贫穷永无住处。菩萨为救众生修行施时。魔及眷属皆生嫉妒愁忧苦恼。菩萨修行无量财施法施之时。悭贪嫉妒悉皆惊号莫不愁怖

  慈心端严身　　悲心为千眼
  施为金刚杵　　菩萨如帝释
  悉皆能摧坏　　贫穷阿修罗
  菩萨悲心弓　　种种施为箭
  破贫穷怨贼　　永无有住处
  悲心坚固根　　爱语以为茎
  忍辱为枝条　　布施以为果
  求者为鸟鹿　　乞者如大风
  能吹施果落　　贫者得满足
  菩萨出时夜　　慈心如满月
  净施以为光　　求如拘牟头
  以净施光明　　令彼得开敷

乞者既得满足欢喜悦豫转相施与亦如菩萨。施乞求者展转相闻亦如菩萨。菩萨布施流闻一切。诸贫穷者皆来归向。如旷野树行人热时皆往归趣。菩萨爱乐名胜得解脱。何以故。能使乞求者来使我得施福故。以施福故名得胜处。一切众生皆来归集。如是大士悉应敬礼。菩萨心喜即觉身轻。以此相故当知必有来乞求者。若有人来语菩萨言。有乞者来。菩萨欢喜即以财物而赏使者。菩萨即以余物而与乞者。见乞者来欢喜爱敬。求者言乞。作此语时怀怜愍心。若有乞者不知菩萨

体性乐施。菩萨执手欢喜与语。犹如亲友。坏彼不知使生知相。彼乞求者得财欢喜。傍人见之亦复欢喜。愿此救济我者长存于世。此乃乞者真济。菩萨见乞者时身心欢喜。面如满月。使彼乞者欢喜悦豫如甘露涂心。菩萨和颜悦色用慈心眼视于前人如饮甘露。譬如有人盗窃他物至市卖之若得速售心大欢喜。菩萨得施乞者物时。心大欢喜复过于是。如巨富人多饶财宝千子具足随意恣与爱念欢喜。不及菩萨于乞者心大欢喜。菩萨见乞者时心大欢喜。胜于他人见所亲者。若见前人得多财宝。随心恣意而自[矛*合]高。菩萨见之倍生欢喜若见乞者发言时。菩萨施渴心重。耳闻乞言如饮甘露。若闻乞言心生爱重无能坏者。若闻具足则坏其爱心。菩萨于乞求者常生爱念。若闻其足声则坏其爱味。菩萨观前受施福田。颇有共我等者遂见贪爱。众生则与我等。所以者何。彼贪心无足我施心无厌。彼贪心者爱大施主。菩萨见多乞者亦深生爱敬。贪求者常求施主。欲乞施者常求乞者所欲与之。菩萨常与世人相乞者。皆就施者而乞。菩萨就乞者而施。乞者闻施者财物匮尽生大苦恼。菩萨求乞者不得之时心生忧恼复过于彼百千万倍。于求乞者菩萨思惟。佛言求不得苦真复如是。菩萨于乞求者生难遭想。所以者何。若无乞者檀波罗蜜则不满足。无上菩提则不可得。是故于乞求者深生悲恼。若有乞者无上菩提便为手执不难。菩萨闻乞者言与我与我心生欢喜。此今即便与我无上菩提。世间愚痴众生若闻乞财则生轻慢不生爱敬。菩萨念言所以名为乞者。多是愚痴众生以悭心故与作恶名。如是人者乃可名为施者。虽有财物复无施心。虽有财施心复无受者。若具足三事是大福德人。如有贫人得大宝藏心生恐惧。或王贼水火来见侵夺。遇值亲友而语之言。我今为汝作诸方便令无丧失即大欢喜。菩萨得乞者以为善伴。心大欢喜亦复如是。菩萨悲心遍一切处。于彼乞者特生怜愍。菩萨悲心见乞者和颜悦色。使彼乞者生必得之想。乞者见菩萨颜色和悦之时。即生决定必得之想。菩萨见乞者时。语言。汝来欲须何等随意而取。安慰之言。善来贤者莫生恐怖。我当为汝作依止处。如是种种安慰乞者。常以爱语使彼乞者心得清凉。种种财宝随意而与。诸乞求者贪火炽盛。菩萨常以施乳灭贪求火。若能如是种种施者。名为生人。若不如是名为死人。受施者大得财物。余人见之欢喜赞叹。菩萨尔时菩提之果如在掌中。悲心净则施净。若无悲心施不清净。菩萨作是思惟。善调顺意者敬悲心胜能使施净。菩萨见贫穷者悲心极重。众生极贫得菩萨施便成巨富。譬如有人得如意珠所欲皆得。诸贫穷者得值菩萨一切贫苦悉皆除灭。菩萨先行财施。次舍所亲。又舍手足。复舍身命。如是渐渐次第而舍。菩萨往乞者所与其财宝。唤其乞者与其诸亲。若乞者自来现求索相与其手足。若发言求索便舍身命。若不来者自往施之。有来求者尚舍身命。况复财物而不施与。菩萨成就悲心如自己体未曾舍离。见来求者。于己身所生于他想。菩萨身中生其恼热。云何愚痴乃于我身生于他想。语乞者言。一切财物先皆与汝。都是汝物。汝今但取。云何言乞。诸求者言。何时见与。菩萨报言。我先于三界尊前发弘誓愿。是时与汝。汝今云何方从我乞。菩萨发心愿一切众生于我财物生己有想。如辛头河飞鸟走兽往至其所随意而饮无遮护者。与以不与先以舍离更不言与。亦复不生欢喜之心。何以故。先以与竟。以一切所舍使诸众生皆当得乐。菩萨于一切众生是走使者。一切众生皆是施主。诸贫穷者心充足时。菩萨尔时檀波罗蜜悉得满足。檀波罗蜜满足之时知功德满足。悭贪者见乞者时则背其面。修功德者见乞者时欢喜瞻视亲近。乞者则得。菩萨施时见受施者展转相施便生欢喜。一切众生赞叹欢喜。菩萨闻其赞叹心大欢悦胜得解脱之乐。菩萨悲心施时。见一切众生多得财宝充足快乐。诸众生等得快乐已。而发愿言。我当久处生死修诸功德不求解脱。菩萨既见众生能久处生死心大欢喜。我今便为得现果报。设当不得菩提亦为具足

    胜解脱品第五

菩萨思惟。常所爱胜解脱者来觉悟我。彼来者不为财宝。为欲成就我大事故来。菩萨或为人王。修诸功德者来而白王言。有乞者来。王即念言。此言乞者乃是胜解脱来。我今得之。王自念言。我今不为贪着王位。为欲利益一切众生。不应空居王位。应修施果满足。而彼使者乃是觉悟我者。凡为乞者甚难为颜。心怀惭耻言色变异。菩萨即知其意而安慰言。若有所须随意而求。乞者既得财物心大欢喜。施者受者二俱欢喜如涅槃乐。三有生死炽然大苦。菩萨处之如涅槃乐。何以故。为欲救济诸众生故。菩萨念言。悲众生者即是我解脱。以大施惠救济众生。众生得乐即是我解脱。虽复大施若无悲心不名为施。若有悲心施即是解脱。菩萨思念。我于往昔三界尊前闻解脱极乐。我今已证。何以故。称意而施即是解脱。若阿罗汉解脱乐与悲心所起施乐相似者。我则爱之。若不相似我则不爱。唯爱施乐以为解脱。悲心起施所得快乐无有比类。无悲心施解脱之乐百千万分不得为喻。悲心起施所得喜乐。若当可以喻为喻。最为极大。是故不可为喻

    施主增长品第六

悲心起施能与众生乐聚。如是施主与众生乐者。胜于解脱名为最胜。施主成他乐。因修悲者于一切众生得平等心。如是者名为檀越。不能如是施者名为乞者。若行施时使闻者悲泣。是名善施。若不如是不名善主。若行布施能使受者子孙恣意受用欢喜赞叹名健施主。若乞而与不名施主。自往而与名善施主。若舍一切财物爱心而与不名施主。有悲心虽不与物名大施主。诸来求欲皆使随意。使称本望名善施主。不能称彼本望虽复大富名贫穷者。富者虽与无悲愍心。名曰与不名施主。悲愍心施是名施主。若不食啖无有果报。施虽与不名为施。无悲心施虽与不名为施。有悲心者虽复不施名之为施。若求报施者名为施者。商贾之人亦可名施。若求报施果报犹尚无量。况有悲心不求报施果报何可称计。若求报施唯可自乐。不能救济徒自疲劳。悲心施者能有救济。后得果时能大利益。贫穷者不如有财者。有财者不如能食。能食者不如能施者。悲心施者善一切众生。富者应施。施者应悲。富者能施富得坚牢。施者能悲施得坚牢。修施者得富。修定者得解脱。修悲心者得无上菩提。果中最胜

    恭敬乞者品第七

菩萨思惟。因彼乞者得证菩提。我当以此菩提回与一切众生。以报恩故。我今因施众生得无比乐。因此乐故得成菩提。如此菩提我当施与乞者。我今因施乞者得于快乐胜解脱乐。因中施乐犹尚如是。况无上菩提。我当舍之施诸乞者。如是乞者其恩甚重无以可报。如此乞者乃能与我作大乐因。若以财宝不足报恩。当以所得无上菩提而施与之。以我福故。愿使乞者于将来世亦如我今成大施主。菩萨内自思惟。因于乞者得施快乐。使乞者得无上菩提为法施檀越。诸乞求者见菩萨大施。而问之言。为求何等而等行大施。菩萨各答言。我今不求人天果报声闻涅槃。愿得无上菩提拔济一切众生。诸悭贪者而作念言。菩萨云何能行大施心不疲厌。菩萨答言。我师三界尊悲念一切众生。我今无以报师恩故施无疲厌。一切之乐无胜解脱乐者。我爱众生胜爱解脱。我以爱念众生欲令得解脱故修种种施。若生死不极苦者。我施终不求菩提。以生死苦故我施求菩提。拔生死苦者谁之所作。烦恼以业之所造作。使一切众生以悲心为体常乐惠施

    施悭品第八

不念恩人无有悲心。若无悲心不能行施。若不施者不能济渡众生生死。无悲心者无复亲友。有悲心者能有亲友。计我者以爱为体。救济者以悲为体。心有重爱无有知者。有重悲心者亦无能知。若不行施覆蔽悲心。如以画石乃知真伪。若见苦厄者能行大施则知有悲心。悭心多者正使所亲从乞则成怨憎。悲心多者假使怨家亦如亲友。悭心多者虽施泥土重于金玉。悲心多者虽施金玉轻于草木。悭心多者丧失财宝心大忧恼。悲心多者虽有财宝无施处时心怀悲苦。复过于彼。舍财物者。凡有二种。一者命终时舍。二者布施时舍。死时舍者。一切都舍无有毫厘至后世。布施舍者。舍于少物得大果报。何有知者见此过患而不行施。若行施时令受者喜悦自亦喜悦。若人不能深生喜悦便自欺诳。若有乞者有所求索。为求有故施与少物心则欢喜。复有施者自往施与。不求果报而行大施。余有少许心中快乐不可为喻。设有美食若不施与而食啖者不以为美。设令恶食得行布施。然后食者心中欢喜以为极美。若行施竟有余自食。善丈夫者心生喜乐如得涅槃。无信心者谁信是语。设有美食有饥者在前不能施与。是人食尚不能施与。况胜解脱能施与人。设令多有财物有来乞者。尚无施心。况施少物。不见是人于生死中有少乐处。适可住于涅槃。若人于大水边不能以少水施与。生死之中苦恼无量。汝莫在中住。适可速入般涅槃。如有大水欲施人不以为难。如有悲心欲取涅槃亦不为难。世间粪土易得于水。悭贪之人闻乞粪土犹怀吝惜。况复财物

    财物施品第九

如有二人。一则大富。一则贫穷。有乞者来。如是二人俱怀苦恼。有财物者惧其求索。无财物者我当云何得少财物与之。如是二人忧苦虽同果报各异。悲恼念者生天人中受无量乐。悭贪者生饿鬼中受无量苦。若菩萨有悲愍心于前众生便为具足。况复与少物。如人大富多有财宝。随意而用心生欢乐。菩萨悲心念施忧恼过于是人百千万倍。有悲心者无有财物。见人乞时不忍言无悲苦堕泪。见苦恼者不能堕泪。何得名为修行悲者。胜者设闻他苦尚不能堪忍。况复眼见他苦恼而不救济者。无有是处。有悲心者见贫苦众生无财可与。悲苦叹息无可为喻。救众生者见众生受苦悲泣堕泪。以堕泪故知其心软。菩萨体净悉皆显现。何以故。知其显现。见苦众生时眼中堕泪。以是故知菩萨其体净软。菩萨悲心犹如雪聚。雪聚见日则皆融消。菩萨悲心见苦众生。悲心雪聚故眼中流泪。菩萨有三时。一者见修功德人。以爱敬故为之堕泪。二者见苦恼众生无功德者。以悲愍故为之堕泪。三者修大施时。悲喜踊跃亦复堕泪。计菩萨堕泪已来多四大海水。世间众生舍于亲属悲泣堕泪。不及菩萨见贫苦众生无财施时悲泣堕泪。菩萨入救众生禅极乐心相应无尽宝藏自然而出。一切乞者自然而至。善丈夫者能以财物大施乞者。乞者得财物已亦行大施。菩萨能以财物施于众生使其富足。以等悲心。闻乞者声为之雨泪。乞者见菩萨雨泪。虽不言与当知必得。菩萨见乞者来时极生悲苦。乞者得财物时心生欢喜得灭悲苦。菩萨闻乞言时悲泣堕泪不能自止。乞者言足尔时方止。菩萨修行种种施已众生满足。便入山林修行禅定。云何灭除诸众生三毒苦患。菩萨财物倍多无乞者可施。我今何为守之而住。今当舍之出家

    舍一切品第十

菩萨大有财物无有乞者。唤之不来菩萨思惟。故当断诸结使无有来者。菩萨悲心。一切众生众苦围绕。发愿度诸众生。菩萨诸有所索一切皆舍无物不与。欲求佛智最上救济一切众生。尊有胜悲心欲行救济何物不舍。有悲心者为他故涅槃尚舍。况复舍身。舍身命财有何难也。舍财物者不如舍身。舍身者不如舍于涅槃。涅槃尚舍。有何不舍。悲心彻髓得自在悲。作救济者大菩萨施都无难也。是一切众生最亲与他作向乐因。悲者一切都舍离诸疲劳。一切众生真济。怨亲平等身命尚与。何物不舍。一切众生极重财利。乐爱命重于财物。一切众生舍财为易舍命为难。菩萨舍一切财物欢喜。不如舍身命时得胜欢喜。种种施味悉知。以施为食。因之得存。与他乐者欲知施身气味故施身。见他乞支体者心中欢喜胜于舍财欢喜。如乐施者得欢喜乐。不如菩萨舍身时得胜欢喜。阎浮提人乞财物者。无我福德故得乞身者来。舍财者财物由他或不称意。舍身者我得自在。随意舍与不由于他。此身不牢不定速朽之物。可爱念者可速疾取。诸食肉者语菩萨言。汝今以热肉血施我。我当何以报恩。菩萨报言。若欲报恩者更语余人。有悲心者能施身肉可往取之。若能如是便是报恩。语乞者言。汝今为我取不坚身。使我得坚牢身。汝恩极重。何以可报。未来世中舍身之果即用施汝。我为救济一切众生故舍于身命。舍身者得于法身。得法身者得一切种智。使一切众生皆得此果。舍此身者得于法身。法身者能与一切众生利乐。能如此思惟。云何不生喜乐速舍此身。菩萨舍身时作是思惟。我为众生作亲友者。我以度生死。应度一切众生脱于生死。以是故我今舍身。菩萨作是思惟。我此舍身功德不属悲众生数。还以养我功德法身。若心如是决定之时舍身无有难相。菩萨舍身所以不难。以当成法身故。是故欢喜。贪爱重者多得财时欢喜无量。不及菩萨舍身欢喜百千万倍。菩萨以智慧悲心为体。为众生故求于法身。菩萨舍身时乐胜于世人得转轮圣王自在快乐。如刹利种若坏敌阵。能舍身命得生天上。舍身命时欢喜无量。菩萨以智慧悲心舍于身命时欢喜最胜。复过于彼。凡愚众生为财利故在于敌阵舍于身命。成为解脱投岩赴火丧身无数。况复菩萨以智慧悲心为一切而不舍身命。愚痴众生以爱着心为国土故舍于身命。菩萨智慧悲心为物而舍身命。何足为难。菩萨发誓愿时一切皆舍。虽有是语一切众生实未得利。修行布施尔时一切众生得利益受用。菩萨舍身不足为难。知身无常苦空不净。为众生故而不舍离。是则为难。菩萨悲心为众生舍身不足为难。乐舍无有厌足。此则为难。假设使一凡夫令返大地力不能就甚生忧恼。菩萨见苦众生未度脱时。心怀悲恼复过于是。以悲心故。菩萨观身轻于草土。为众生舍身何足为难。若人为己身故一念中受不杀戒。是人命终必生天上。菩萨为众生舍于身命。所有功德生死之中无有受处。唯至菩提乃能容受。菩萨若闻有人来乞身时。即时生念。我已久舍此身而不自取。方从我索必当谓我有悭惜心而试我耳

    舍阴受阴品第十一

阿罗汉舍后边身得涅槃乐。不及菩萨为众生舍身时乐。阿罗汉得解脱。不如菩萨为众生故受身时乐。菩萨生念我以不取涅槃为众生故得受是身。是最为妙。菩萨念言。我舍身命用施。复更受身不入解脱。是为最胜。我乐闻如来济度众生功德。我得救众生悲心气味不取涅槃。甚爱乐此事。菩萨为众生舍身施时。虽不证涅槃胜得涅槃者。以不得为众生舍身气味故。菩萨受是阴身极是大苦。如为众生舍身时乐等无有异。世间凡人为贫穷病苦之所缠逼。不能舍离乐欲舍身。众生厌患阴身不能救济者欲速入涅槃。菩萨思惟涅槃甚乐。生死阴身极为大苦。我当代一切众生受此阴身之苦使得解脱。阿罗汉身尽佛亦身尽。身尽虽同不能救济。佛灭身为善

    舍身命品第十二

菩萨为一切种智故。大悲心为众生故。舍身舍命得果报不空。若一切舍身不得果报名空舍身。菩萨舍身为着财众生欲使生羞耻故。菩萨为众生舍身命者。易于悭贪者舍一团饭。菩萨舍于身命为悭贪者生其羞耻。菩萨所以施命为护他命故。何以故。他命即是我命。菩萨虽舍身命不济他者。为观阴身过故。为益众生复更受身。若非大悲何有智者而乐阴身。若无大悲。施味者不能乐处生死。菩萨常乐行施。大悲自在随受生死身如涅槃乐

    现悲品第十三

菩萨悲心极大在于身中无有知者。菩萨舍身命时一切天人所以得知。菩萨悲心极以深大。遍一切众生无有见者。以财施法施无畏施悉得知见。一切众生身者无不是病无有知者。以三事故知其有病。何者为三。饮食衣服汤药即是病相。菩萨悲心以三事得显。何者为三。即是财法无畏施也。菩萨与一切众生作乐。为灭一切众生苦故舍身救之。菩萨不求果报视如刍草。菩萨大悲作种种方便。犹如乳聚以血施人易于世人以水用施。如菩萨昔日五处出血施诸夜叉鬼。踊跃欢喜无可为喻。为欲救济一切诸众生故。有余人问菩萨言。大悲者有何气味。能使舍血易于舍水。大悲心菩萨答言。以不求果报为他得乐故舍身命。何以故。乐无相为首入悲心乐。有人见菩萨大悲疑之为是悲体。以大施故知是悲体。世人生疑。为当悲来入菩萨身中菩萨往入悲中。菩萨舍身者一切所不能共。唯大悲者能。得一切种智时一切众生所不能共。有大悲心为益众生所欲皆得。无有难者决定得空。心欲利益众生大悲常在心者。无上菩提便如在手中无异。得住无生忍者。能显现陀罗尼得住十地。自在当知如佛

    法施品第十四

财施者人道中有百千万。财施果报。能得法施。唯大悲者。能得法施财施果报。后身得无量乐。悲者法施现证涅槃。乐施欢喜甘露满足。菩萨悲一味。以是因缘无一刹那欲趣解脱。种种法施竟请诸听法者。我得法施果时必受我请。菩萨时施名为欲施非根本施。成佛时施名根本法施

  佛智处虚空　　大悲为密云
  法施如甘雨　　充满阴界池
  四摄为方便　　安乐解脱因
  修治八正道　　能得涅槃果

财施除众生身苦。法施除众生心苦。无量劫财施为得法施果。法施能与众生无畏施。极厌患生死智者求涅槃。悲救众生者求于法施。菩萨受钱财为修施故。修行施时为得法施。见众生有二种贪爱愚痴。贪爱多者施财宝。愚痴多者施与其法。施财者为其作无尽钱财。施法者为得无尽智故。财施者为得身乐。法施者为得心乐。随所化众生所欲得义称意。满足称之无疲惓意。得大功德法施欢喜。增益端正如秋满月。常为众生心眼不离。财施者为众生所爱。法施者常为世间之所敬重。财施者与愚人所爱。法施者为智者所爱。财施坏财贫穷。法施坏功德贫穷者。此二种施谁不敬重。财施者能与现乐。法施者能与天道涅槃之乐。乐爱悲者能爱一切众生。爱一切众生即是爱己。阿罗汉舍于众生入涅槃去。尚不为智者所爱。况苦众生者谁当爱乐。常行惠施远离十恶恭敬父母。若如是者是报我恩。若欲续佛种者。当以悲心为首饶益于他。常能思念成就众生事

大丈夫论卷上大丈夫论卷下

        提婆罗菩萨造

        北凉沙门道泰译

    发菩提心品第十五

施事已足为一切众生亲者。未曾一念不与悲心相应。菩萨悲心遍缘一切无不缘者。以悲心遍故。后成佛时得一切种智无有障碍。以悲心故。舍声闻解脱发菩提心。此初一念之心。唯佛知其边量。况菩提行解脱乐。方初一念发菩提心。犹如大地金大地土不相方喻。初发心时以能净诸结使招一切功德。菩提是发心果。为一切众生求乐。菩萨发菩提心竟。未发愿者问。解脱云何。以何因缘故问。以发心者如从解脱中来。是故问言。云何为解脱相为往到解脱故知为解脱来耶。已发愿者答言。发菩提心时欢喜快乐犹如解脱。是故得知。欲供养一切佛者当发菩提之心。欲报佛恩者当发坚牢菩提之心。除发菩提心更无有法能至菩提。若无菩提心则不得佛果。若不得佛果则不能救度众生。欲与一切众生无量大乐当发菩提之心。何以故。菩提心者。是一切众生乐因。一切诸色不离四大。一切乐事不离菩提心。怪哉。云何乃不畏生死之苦乃畏无畏菩提之心。若欲止息一切众生苦者。无过发菩提之心。发菩提心者是初止息因。初止息得无上止息。得财宝利不如得功德利。得功德利不如得智慧利。得智慧利不如得菩提心利。若放逸废忘不念菩提心者。如禽兽无异。汝今云何不发悲心。当知悲心者即是大菩提。欲趣向佛智应发菩提之心。为结使所障者不能发解脱之心。为业报障者不能发菩提之心。云何邪趣。云何正趣。为有爱所牵以四空为解脱者名为邪趣。发菩提心修八正道名为正趣。为得富报者修行于施。为得乐报者修行悲心。为欲救济安乐众生者当坚发菩提之心。不修福者有三事难得。一者不得亲近善友。二者不能悲心厌离。三者不能敬尚佛慧。未发菩提心者应当发心。若发菩提心者得一切种智

    功德胜品第十六

有人等以财物施一福田。心不同故得报有种种。有得三有乐者。有得寂灭乐者。有得利他乐者。思愿胜故得报不同。以爱心作福者受报时愚闇。悲心修福者受果时得于智慧。不败坏菩提心为饶益众生作福者。当知此福为福中最胜。其余修福名相似福非第一福。修一味智慧。当知此福为最第一。饶益世间故三宝种不断。知业知果知归依佛慈悲。计我行福如行恶者甚可惭愧。善丈夫者见人天世间无救。终不为己修福。生死中苦尚不可闻。况复眼见。众生受身极可患厌。云何为我修福作业悲者所不能作。一刹那顷不离悲心为众生亲友。云何为我作福。有尝功德味者得自在修福得他报恩胜气味。梦中尚不为己修福。况复觉时。以智能见过终不求有造福。悲心者终不为解脱修福。智者弃求有业。悲者弃解脱业。所以者何。悲者为利益他故。无胜智慧平等造作。因福一果福无与等者。从十力得智。为己得乐舍利他乐名背恩者。唯我能知。从佛得知故一切众生是我修福之伴。设当得果而独受用名背恩者。极难得乐岂得独受。其如是丈夫为一切所弃。设得千涅槃乐不为饶益。不如救一众生苦胜得千涅槃乐。解脱乐尚不独受。何以故。见世间众生无归无救故。尚不独受解脱乐。况复无上菩提

    胜解脱品第十七

更有余三昧定慧境界众生皆悉作佛。以有此三昧故不欲取于解脱。头陀除一切过恶寂灭如在口中。真济者为众生苦故而不证取

  定慧悲自生　　见世间众苦
  世间真济者　　终不越度去

如海潮终不过限。修悲者百劫苦行。若能度于一人终不出生死力。能得解脱。为众生故处于生死。于三种施一切时常如节会。不乐己乐为他作乐。日夜于生死中而不处。欢喜快乐如处涅槃。菩萨常为众生作利益业欢喜乐味智。菩萨乃于梦中得欢喜乐。胜于解脱。菩萨得为他作乐欢喜气味。诸有众生不得气味证于解脱。智人若得解脱知利他乐欢喜气味者。必当还来利益众生。畏于生死为自利益求于解脱以为极乐者。不如菩萨受阴身时欢喜快乐为利他故。若自一已受逼迫苦者乃可入于涅槃。一切众生受逼迫苦。云何舍于众生入于涅槃。见自己苦者入于涅槃。悲者见一切众生苦皆住己心。云何舍于众生入于涅槃。若能为他作乐欢喜即是涅槃。若不如是即是生死。于众生有平等悲者为他作乐欢喜即是涅槃。佛所赞说。若解脱如利益一人欢喜乐者为智者所爱。若与他重乐不计功者即是解脱。悲者为他作乐不望果报。若能如是即是解脱。若不如是即是生死。若为己求乐者即是苦也。舍于己乐为他求乐即是涅槃。世间众生以破苦故名为解脱。修悲者能破他苦即是胜解脱也。破他苦者二俱得乐。何有智者舍二解脱取一解脱。世间人言。有智者得于解脱。菩萨作是思惟。我不信是语。何有智人舍救他乐取于解脱。自己得乐能与他作乐。三有中乐胜解脱乐。菩萨为众生受苦。胜于他人为己得解脱乐

    饶益他品第十八

世间众生为己乐故。于生死中身心疲劳。菩萨心得休息悲心作饶益。他生死中除对治法更无有乐。菩萨除利益他更无有乐。菩萨得作利他欢喜乐。知利他者即是自利。舍自己利爱利他乐。知利己乐即是利他乐。知利他乐即是利己乐。知利他乐时即自己乐故。人有上中下。愚人者见他得乐心生苦恼。中人者己自苦时知苦。上人者见他乐时心生快乐。见他苦时如自己苦。菩萨四摄法中与他同利。云何同利。他苦则苦他乐则乐。是名同利。悲心平等无有他想。菩萨与众生同苦同乐。菩萨自己身特生苦恼。何以故。不能救众生苦故。不观过去不观未来。随众生意作灭苦对治。菩萨自意亦如他意。世间众生与他利乐还望返报。菩萨与他利乐不望其报。菩萨虽悲心平等爱一切众生。然于怨憎中倍与利乐。于怨憎边与利乐时心中欢喜。如舍身命时欢喜者名为平等。若不如是名不平等。于怨憎中倍与利乐者名称悲心所作。菩萨于一切众生等生悲心。然于恶行众生倍生怜愍。譬如大富长者唯有一子爱念之心彻于骨髓。菩萨爱念一切众生亦复如是。如有恶子不欲父得胜己事者是名背恩。一切怨憎众生于菩萨所同一味恶。菩萨于怨憎人生同一味悲心。世间众生得报恩者生其欢喜。若菩萨于怨憎人所与其利乐。心生欢喜倍过于是。世间众生若骂时他不还报便大欢喜。菩萨得他骂时心大欢喜。有爱心者于三界中悉皆普遍。菩萨悲心亦普遍三界。菩萨悲地狱众生不如悲爱着三界愚痴众生。众生乐于己乐为无量大苦之所系缚。菩萨为利他乐故为无量大苦之所系缚。一切众生皆同一事。皆欲离苦得乐。与他利乐为胜有为。利向己者亦是悲因亦是喜因。为利向他者见之生于悲喜。自为己利所以生悲。见其得乐所以欢喜。四无量心者内心欲修缘。四摄法者为众生利乐名为最胜。修四无量者能与世法及出世法。因世法出世法及四无量心都是同一境界。何以故。同一利益众生。同得一无上菩提果故。悲者能利他。智者能舍。不生希有心。不生高下心

    胜施他苦品第十九

菩萨见他苦时即是菩萨极苦。见他乐时即是菩萨大乐。以是故菩萨恒为利他。凡愚众生见他苦时自己为乐。见他苦不以为苦。贤人者自苦以乐乐他不以己苦。凡愚众生为己少乐而大苦他。贤人者为与他少乐自受大苦。恶行者修少乐因得大乐时虽生欢喜。不及菩萨以少乐利他人时心大欢喜倍过于是。菩萨见他受苦以身代之。身虽受苦不以为苦。心中快乐生大欢喜。菩萨悲心得自在乐。不为三有诸苦之所逼恼。菩萨饮悲甘露故不为诸苦所苦。不为苦所苦故能为他受苦。凡愚众生见他苦时心中生乐。见他乐时心中生苦。菩萨见他苦时则苦乐时则乐。无悲心者见他苦时如月极冷。有悲心者见他受苦如夏盛日。不问愚智见他苦时。皆生厌离生忧恼因。有悲心者深生怜愍作决定心。一切众生苦即是我苦。菩萨作念。若不能发大精进者。何由能坏此大苦。菩萨与一切众生同利苦乐皆同。须勤劳得成菩提。菩萨作念。我得菩提已舍与一切众生。还于生死之中。从初发心还至菩提。复舍与众生然不可得。菩萨为利他故行四摄法终不疲厌。犹如大地持一切物终不疲厌。为己身者自受其乐尚生疲厌。菩萨为他作乐不生疲厌。菩萨为他作乐。见阿鼻苦如涅槃乐。于余苦边有何疲厌。若为一众生受乐自受无量地狱。常作勇猛与他作乐不生疲厌。以何因缘为他作乐不生疲厌。菩萨观一切众生。不见他想都如自己。众生为结使所著。于一切处皆欲害他。为悲所持者。于一切苦无不欲受。菩萨为他受逼迫苦。如苦者乐解脱乐。菩萨乐代他受逼迫苦时即大悲心净。智慧观他受苦悲心即在中住。悲心住处则苦不得住。虽复悲者为一切众生苦之所缠。如是为他利乐心生欢喜胜解脱乐。菩萨见他受苦如自己苦。自己得乐欲与他人。自觉胜于涅槃。悲者常欲自受其苦与他乐。悲之与苦不得一刹那顷而得共住。行恶者见他苦时欲得远避。见他得乐心不喜悦。菩萨见他苦时不欲远离。无爱者无一切苦业。何以故。除他人苦生大欢喜故。菩萨与他大乐不必欢喜。见他与人少乐心大欢喜。何以故。体性尔故。菩萨见他得乐自己亦乐。菩萨见人与他少乐。云何不生欢喜

    爱悲品第二十

若人不知身心常为极苦所缚。则不能知他心中苦。无悲者无恶不作。若见他衰祸心不调软。此人名为极恶行者。若有重恩者何时能念。临死之人虽有美药以为极苦。为极行恶。无福德者得慈悲甘药作极苦想。若人巨富多饶财宝。但自食啖不与他人为人所呵。虽有智慧多闻若无悲心。亦为人之所讥呵。若见苦恼众生难得悲心者非功德器。犹如破器不任盛水。有悲心者见苦众生虽不能救济。可不能叹言苦哉众生。见众生为贪欲嗔恚愚痴所病。生老病死之苦常为众苦之所恼逼。怪哉众生堕是大苦。世间众生身苦心苦。常为结业之所破坏。呜呼怪哉。世间众生逼迫之苦。何有菩萨而不生悲。身住于驶流没生死无穷可畏大苦海。众生常为苦苦所苦。行苦所苦。坏苦所苦。若见一苦足生悲因。况复具足三苦。愚痴众生常为百千诸苦所苦。若见一苦应生悲心。况复百千诸苦。应当了知。世间诸苦于一一苦中未生悲心者应当生悲。已生悲心应当增长。况复无量。若闻世间种种无量诸苦。石尚应软。况有心者而不生悲。若闻世间悲呼之声。枯树犹应生华。况有心者而不生悲。世间苦一味心柔软者易生悲心。有悲心者菩提之果便在掌中

    觉悟儜丈夫品第二十一

  悲心极丰富　　利他已生乐
  贫穷悲心人　　不能贪此乐
  婴愚爱自在　　悲心则背去
  悲心已背去　　众苦皆来集

爱自在者。处生死中欲分苦与他共回流生死。悲心者。于世间众生分寂灭乐共之而去。有爱心者乐于三有。知爱过者则乐涅槃。作利益他者则乐悲心。爱自在者常乐世间。受身为己乐故。悲自在者常乐受身。为乐他故。爱自在者常乐己乐以为自缚。悲心者恒为欲与他乐而为自缚。爱自在者常为己乐无有疲厌。悲心者为与他乐而无疲厌。愚爱小者不爱自己亦不爱他。菩萨亦爱自己。愚痴众生常为我者。实是为他

    大丈夫品第二十二

菩萨悲心唯有一事之所逼迫。常为他事苦来逼迫。更无余事。是名成就悲聚。弃于涅槃如弃其苦。受于有身如取解脱。与世间利乐者名此为悲。知涅槃功德生死过患然不舍有为。如是一切尽是大悲功德。一切处离欲。以涅槃为体而不取涅槃。名勇健者。大悲因缘故能入生死周旋往返。观诸有尽灭知众生是苦为救为依。心持大悲厌恶己身求十力身大悲之处得处悲处功德。如转轮圣王虽有千子然爱相好具者。佛亦如是。于一切众生爱有悲心者。唯能作福无智无悲名为丈夫。有福有智名善丈夫。若修福修悲修智名大丈夫。应看悲者。有悲者应共语说。敬礼悲者具一切功德

    说悲品第二十三

世间人天阿修罗等。受身有种种苦。唯有菩萨彻髓悲者。知一切善法以悲为首。智人当知。如似一切诸字悉昙为首。一切善法皆入悲中。如似一舍众色皆入。若见虚空净即见大悲净。见虚空无边大悲亦无边。佛说。若欲现前见我当恭敬大悲。若欲见我。当观三界皆悉受苦。苦无边故大悲亦无边。苦住故大悲亦住。大悲住在。何处住在。一切众生贪欲嗔恚愚痴生老病死种种苦聚与诸眷属在中而住。有大悲心能知他苦。此名与佛共住。有三种施一切功德养身。犹如乳母。是名大悲

    施悲净品第二十四

犹如雪山生一切药。大悲雪山生三种施。一切功德除悲更无有法能与世间作乐。施作悲体能为世间作种种乐。无上果报为三施所成。悲是三施之因。众生祖母能生如来。一切众生无上最胜归依谁不恭敬。能生三施是名大悲。菩萨大悲功德极多在心中住。唯有一事而不远离无有染着。常作利益他事无有疲厌。世间出世间乐及利他乐。皆从悲生。是以我今恭敬于悲能利益世间大悲者。我亦恭敬种种功德。实如所说有二功德最胜。能利益他及自净悲。悲能净于施。是以我今爱敬施能庄严于悲。我亦爱敬悲诸有同悲音者。亦复爱敬悲能净心体施能净业道。能净心体能净业道。即能净涅槃道能净无上菩提道。悲能净舍。无悲者垢污于舍。施能净悲悲能净施。是名世间端正。悲能生信敬。犹如大地为众华庄严。大悲亦复如是。世间众生为烦恼日之所烧逼。得悲心者皆生凉乐。犹如夏热之时得清凉风皆得止息

    爱悲胜品第二十五

施缘取。取缘爱。有爱则有取。无爱则无取。有悲必有舍。无悲亦无舍。爱故取增长。舍故悲增长。爱恩者生爱。是过患怨则增长悲心。爱增长为自己乐则害他。悲增长能与他乐自己则苦。爱增长而害他者则非希有。悲心者舍己身命而与他人。是为希有。爱著者名愚贱人。常在贫穷受诸苦恼。有悲功德者常处富贵。贪爱者可得断绝。有止足时得智慧则能断绝止足。得悲心者无有止足。常施他故。爱心者能招集一切诸苦成大苦聚。悲心者能生一切功德。若悲不舍不净业者我所不欲。设悲不能救济我亦不欲。若悲不乐求菩提亦非我所欲。爱心者能生一切苦。悲心者能生一切乐。从悲起身口业者。名为胜业。悲心者能为一切众生作无尽乐

    智悲解脱品第二十六

智悲二事何者为胜。智者唯能自归依。悲者能使他人归依无上之道。有悲无智非智者所爱。有智无悲亦非智者所爱。能障无上道。智不与悲心相应。能障无上道智。菩萨以为无智。一念不乐生死悲不欲解脱。解脱味如甘露悲者以为无味。如美食无盐以为无味。解脱虽甘若无悲心菩萨以为无味。若大悲与解脱别解脱皆应敬礼。以大悲是诸佛母故。解脱者名永无余灭一切事。悲心如善咒。能咒死者还活。若受有相续不断身者是常过。若取解脱是断过。离二边故名之为佛救一切众生。若无佛者则无解脱。若无悲者亦无得佛。悲能生解脱。以是事故菩萨取悲。悲体一事能作二事。一能救众生。二能生佛种智

    发愿品第二十七

菩萨思惟。一切众生共有无量种苦。我当发于悲心成一切种智。灭一切众生无量种共有之苦。菩萨见一切众生沉没无量无边生死苦海得平等悲心。婴愚无知乐解脱者生放舍心。世间大苦聚生我胜悲心。菩萨思惟。我有悲心观苦众生未得菩提道。我云何使众生得解脱道。菩萨思惟。一切世间我最少福。我今不能救济众生。菩萨思惟。我于三界众生作大亲友。而众生常为身苦心苦逼恼。我今名为空恶活者。菩萨思惟。我生不能破世间苦。不能利益众生我用受是身为。菩萨思惟。我是一切众生亲友。我当养育于怨家所作大利益。菩萨思惟。一切众生能为我作端严业。不使一众生作不端严意。菩萨作是思惟。言利他者。求他人之相都不可得都如自己。何者为他即是利己。菩萨思惟。若有可愿处使一切众生身心之苦一时俱集我身。常为受之使众生得乐不以为苦。菩萨思惟。我菩提道中住一切所有诸苦。我皆能堪忍。所以者何。众生没溺生死苦海我不能度脱。菩萨思惟。虽有重结使然菩提道难得。如是但有悲智二事为伴心终不疲厌。菩萨思惟。善逝所行道我今从中去。我今于世间悲心施众生。当思惟。我如彼无异。菩萨思惟。我今为世间依救当发弘誓。愿修大庄严智慧为善伴。我今佛慧牙将生。菩萨思惟。我欲灭众生苦。使一切众生得乐。欲作一切事。我常为悲心之所教诏。菩萨思惟。生死之苦闻尚疲厌。悲者能得堪忍世间苦故。为悲心尚向生死门。菩萨思惟。生死苦极可厌恶。欲入涅槃。大悲语言。苦恼众生未度。云何舍弃而去。菩萨思惟。有为苦具足涅槃出世乐。我今知生死有为苦涅槃无为乐。悲心常乐三种施。菩萨思惟。我甚畏诸有。以悲心救众生故乐处诸有。悲心语菩萨言。我使汝处生死终不放汝。何以故。为报恩故。菩萨思惟。解脱乐为度众生尚不欲食。悲心遮我使不得食。况生死不坚牢乐。菩萨思惟。一切乐中第一佛说涅槃。是涅槃虽乐我智不欲去。所以智不欲去者悲和合故。菩萨思惟。我今敬尚涅槃。所以者何。涅槃中无生老病死故。涅槃虽乐悲心所牵。为众生故而不得去。悲心是诸佛之母。是以不舍向于涅槃。若涅槃就我犹尚不证。况弃众生而向涅槃。菩萨思惟。我欲向涅槃。悲是佛母就我与乳。云何舍去无上菩提。设当不与众生利乐我亦不求。况复涅槃。菩萨思惟。不应向涅槃舍无归依众生故。悲心故使我不证涅槃。涅槃是尽生边。若无生者何能救拔众生。菩萨思惟。受生者有二种乐。一者救众生乐。二者解脱乐。我云何舍二种乐取一种乐。菩萨思惟。一切凡夫尽共有一切种智性。一切种智凡夫易得。以是故我爱凡夫不爱解脱。菩萨思惟。随有苦众生处悲心得生悲得增长。以是故。我爱有中。菩萨语悲心言。汝使我得清净增长。使一切众生尽得清净尽得增长。菩萨语悲心言。众生在苦为百千众苦之所逼迫。今日使众生必得安乐与我成办此事。菩萨语悲心言。众生为爱所缚为死所摄。见世间无归无依为救众生故受种种苦。菩萨思惟。我爱大丈夫。见有众生堕在苦中舍涅槃乐。为安乐众生自勉励此事。菩萨思惟。向救众生得无生忍决定智得授记别。得授记别者我今供养恭敬。菩萨思惟。佛得遍净眼。使我现前合掌请佛。愿授我记

    等同发愿品第二十八

十方诸佛现在前者为救众生事。我今作发菩提愿。一切众生所作事我已堪任为作。诸佛大悲皆称我等。善哉。我所有若智若福。使我一切无归依为作解脱。世尊使我常莫乐小智之心。世尊使我如世尊具足十力。若众生结使炽火烧心。使我以法水灭众生结使炽火。摧破魔怨得贤智得转法轮坏一切众生衰恼。随有一切众生。我皆一时为转法轮。一切所作福皆用为是。以此福德使我得最胜法身。犹如虚空遍一切处。得二种身教化世间。以我此福与诸佛和合。无救众生使得解脱。种种烦恼异相作苦能为苦因。我所有福以智慧力灭众生苦。使我以此福一切众生满虚空界为作一味乐。使我常满所愿阴盖贼众能劫功德世间畏死。使我以此福救藏一切众生。随世间几时而住我善法亦住。以我善故一切世间出世间悉皆离苦得乐。常一时和合一切众生。菩萨思惟。自今已去常从乞者请受教令。从今以往常于我身所深生体信莫生他想。种种所欲随其给使满足。菩萨思惟。使我从今乃至菩提无有一身不见佛时。菩萨思惟。使我从今生死长远设我不见佛时。莫一刹那顷离于悲心。菩萨思惟。使我迫至成佛见外众生所受诸苦极逼恼我身我皆代受。使我身得彻髓悲心。使我身身得使佛智解脱。菩萨思惟。使我悲心犹如虚空。一切山河树木飞鸟走兽皆依空住。一切众生一切时皆入我悲中。我依一切众生得立善根。以我此善回与一切众生得解脱果。一切道路桥船方所皆是众生共有。使我一切诸善亦一切众生共有。菩萨思惟。地水火风一切众生共有。使我所修诸善亦一切众生共有。我因一切众生所得善根。回与一切众生得无碍智。菩萨思惟。我所作诸善使一切众生得离魔界入于佛界。使我得智恒十波罗蜜佛智现前。使一切众生得安隐乐得不动心。一切众生所有衰恼。使互相救济。菩萨语福德言。一切众生为无明所障不知自苦他苦。汝当开解。菩萨布施行净水时。使一切众生除有爱结渴得无上道悲。我施水时愿使一切众生免恩爱僮仆恒得自在得法财富。使我福如河。慈心无垢花。持戒以为底。施如驶流水除众生渴苦。使我悲心恒如大河。菩萨思惟。我悲心如海。净戒如海潮。忍辱如波浪。智如海虫动。慈心如一味水。凡我所施者使成慈心海。使施福得悲甘露。除众生生老病死

    胜发愿品第二十九

若我于一众生起于悲心与利乐时。愿使大悲坚固。以悲灭众生苦。使一切众生苦皆来逼我。我今以此无畏施福。使一切众生皆得大悲。我今所有忍辱功德。于将来世刀兵劫时。以我悲心灭一切众生嗔。以施食功德饥馑劫时使得饮食充足一切众生。以水施众生功德使成就悲心住一切众生心中。以衣施众生功德使一切众生得惭愧心。以灯明施佛因缘功德。使我将来得于佛日灭一切闇。以施眼功德使我将来世。愿一切众生速得佛眼。以我舍头功德使一切众生向菩提心。以我药施因缘功德。使一切众生除生老病死。以我走使供给众生功德因缘。使一切众生得无上无漏成菩提道。以我华幢盖供养佛塔因缘功德。使一切众生得高胜福。以我旛供养舍利功德因缘。使一切众生除闇得明。以铃声供养因缘。使一切众生得梵音声。以香华璎珞供养因缘功德。使一切众生除诸结使垢烦恼臭秽。以供养三宝因缘功德。使一切众生常值三宝不曾空缺。以我于崄道中为诸商贾除崄道畏功德因缘。使一切众生出生死畏。以我度众生海难功德因缘。使一切众生度生死海。以我所有净善因缘功德。使一切众生摧破四魔得成正觉。我当得三菩提。我于众生虽道是语。为欲安慰众生故说是语。以此功德使一切众生得无上菩提。一切众生菩提即是我菩提。一切众生为痴所障使得无上菩提。以此因缘功德使一切众生于前成佛我最后成。以我于生死中往返因缘功德。使一切众生皆得作佛。以我发善心功德因缘。使一切众生皆得佛智。若有见闻受持读诵者。皆作无上菩提之因。我欲满一切众生欲愿。我愿故未满。若我见苦众生悲吟之声。以此功德使一切众生皆得作佛欢喜瞻睹。设我修诸善行不使一切众生作佛者。我尚不喜闻。况复履行。菩萨语功德言。汝若不能拥护众生作依止者。我亦不欲于汝及以果报。何以故。为众生修福不自为己故。若众生尽我善如虚空。于三时中与众生乐。施以菩提心。胜丈夫悲发愿。此名说悲心。亦名五种说。亦名救众生。总名大丈夫行贤。偈有五百。古书有八百。阿阇梨犊子部提波罗大菩萨生在南方。是所作竟

大丈夫论卷下


广百论本

    No. 1570 [cf. Nos. 1569, 1571]

广百论本一卷

        圣天菩萨造

        三藏法师玄奘奉　诏译

    破常品第一

  一切为果生　　所以无常性
  故除佛无有　　如实号如来
  无有时方物　　有性非缘生
  故无时方物　　有性而常住
  非无因有性　　有因即非常
  故无因欲成　　真见说非有
  见所作无常　　谓非作常住
  既见无常有　　应言常性无
  愚夫妄分别　　谓空等为常
  智者依世间　　亦不见此义
  非唯一有分　　遍满一切分
  故知一一分　　各别有有分
  若法体实有　　卷舒用可得
  此定从他生　　故成所生果
  若离所生果　　无有能生因
  是故能生因　　皆成所生果
  诸法必变异　　方作余生因
  如是变异因　　岂得名常住
  若本无今有　　自然常为因
  既许有自然　　因则为妄立
  云何依常性　　而起于无常
  因果相不同　　世所未曾见
  若一分是因　　余分非因者
  即应成种种　　种种故非常
  在因微圆相　　于果则非有
  是故诸极微　　非遍体和合
  于一极微处　　既不许有余
  是故亦不应　　许因果等量
  微若有东方　　必有东方分
  极微若有分　　如何是极微
  要取前舍后　　方得说为行
  此二若是无　　行者应非有
  极微无初分　　中后分亦无
  是则一切眼　　皆所不能见
  若因为果坏　　是因即非常
  或许果与因　　二体不同处
  不见有诸法　　常而是有对
  故极微是常　　诸佛未曾说
  离缚所缚因　　更无真解脱
  生成用阙故　　设有亦名无
  究竟涅槃时　　无蕴亦无我
  不见涅槃者　　依何有涅槃
  我时舍诸德　　离爱有何思
  若有我无思　　便用无所有
  无余有我种　　则定能生思
  要无我无思　　诸有乃无有
  若离苦有我　　则定无涅槃
  是故涅槃中　　我等皆永灭
  宁在世间求　　非求于胜义
  以世间少有　　于胜义都无

    破我品第二

  内我实非男　　非女非非二
  但由无智故　　谓我为丈夫
  若诸大种中　　无男女非二
  云何诸大种　　有男等相生
  汝我余非我　　故我无定相
  岂不于无常　　妄分别为我
  我即同于身　　生生有变易
  故离身有我　　常住理不然
  若法无触对　　则无有动摇
  是故身作业　　非命者能造
  我常非所害　　岂烦修护因
  谁恐食金刚　　执杖防众蠹
  若有宿生念　　便谓我为常
  既见昔时痕　　身亦应常住
  若我与思合　　转成思念者
  思亦应非思　　故我非常住
  我与乐等合　　种种如乐等
  我如乐等故　　非一亦非常
  若谓我思常　　缘助成邪执
  如言火常住　　则不缘薪等
  如至灭动物　　作用彼无有
  故有我无思　　其理不成就
  余方起思界　　别处见于思
  如铁铤镕销　　我体应变坏
  思如意量小　　我似虚空大
  唯应观自相　　则不见于思
  我德若周遍　　何为他不受
  能障既言通　　不应唯障一
  若德并悲思　　何能造一切
  彼应与狂乱　　俱痴无所成
  若德能善解　　造舍等诸物
  而不知受用　　非理宁过此
  有动作无常　　虚通无动作
  无用同无性　　何不欣无我
  或观我周遍　　或见量同身
  或执如极微　　智者达非有
  常法非可恼　　何舍恼解脱
  是故计我常　　证解脱非理
  我若实有性　　不应赞离我
  定知真实者　　趣解脱应虚
  解脱中若无　　前亦应非有
  无杂时所见　　彼真性应知
  若无常皆断　　草等何不然
  此理设为真　　无明亦非有
  现见色等行　　从缘生住灭
  故知汝执我　　虽有而无有
  如缘成芽等　　缘成种等生
  故无常诸法　　皆无常所起
  以法从缘生　　故体而无断
  以法从缘灭　　故体亦非常

    破时品第三

  瓶等在未来　　即非有过现
  未来过现有　　便是未来无
  未来若已谢　　而有未来体
  此则恒未来　　云何成过现
  法若在未来　　现有未来相
  应即为现在　　如何名未来
  去来如现有　　取果用何无
  若体恒非无　　何为不常住
  过去若过去　　如何成过去
  过去不过去　　如何成过去
  未来若有生　　如何非现在
  未来若无生　　如何非常住
  若未来无生　　坏故非常者
  过去既无坏　　何不谓为常
  现在世无常　　非由过去等
  除斯二所趣　　更无有第三
  若后生诸行　　先已有定体
  说有定性人　　应非是邪执
  若法因缘生　　即非先有体
  先有而生者　　生已复应生
  若见去来有　　如何不见无
  既见有去来　　应不说为远
  未作法若有　　修戒等唐捐
  若少有所为　　果则非先有
  诸行既无常　　果则非恒有
  若有初有后　　世共许非常
  应非勤解脱　　解脱无去来
  或许有去来　　贪应离贪者
  若执果先有　　造宫舍严具
  柱等则唐捐　　果先无亦尔
  诸法有转变　　慧者未曾有
  唯除无智人　　妄分别为有
  无常何有住　　住无有何体
  初若有住者　　后应无变衰
  譬如无一识　　能了于二义
  如是无一义　　二识所能知
  时若有余住　　住则不成时
  时若余住无　　后灭应非有
  法与无常异　　法则非无常
  法与无常一　　法应非有住
  无常初既劣　　住力定应强
  此二复何缘　　后见成颠倒
  若遍诸法体　　无常力初劣
  应都无有住　　或一切皆常
  无常若恒有　　住相应常无
  或彼法先常　　后乃非常住
  若法无常俱　　而言有住者
  无常相应妄　　或住相应虚
  无所见见无　　回心缘妄境
  是故唯虚假　　有忆念名生

    破见品第四

  禀和希胜慧　　是法器应知
  异此有师资　　无因获胜利
  说有及有因　　净与净方便
  世间自不了　　过岂在牟尼
  舍诸有涅槃　　邪宗所共许
  真空破一切　　如何彼不欣
  不知舍证因　　无由能舍证
  是故牟尼说　　清凉余定无
  若于佛所说　　深事以生疑
  可依无相空　　而生决定信
  观现尚有妄　　知后定为虚
  诸依彼法行　　被诳终无已
  智者自涅槃　　是能作难作
  愚夫逢善导　　而无随趣心
  不知无怖畏　　遍知亦复然
  定由少分知　　而生于怖畏
  生死顺流法　　愚夫常习行
  未曾修逆流　　是故生怖畏
  诸有愚痴人　　障他真实见
  无由生善趣　　如何证涅槃
  宁毁犯尸罗　　不损坏正见
  尸罗生善趣　　正见得涅槃
  宁彼起我执　　非空无我见
  后兼向恶趣　　初唯背涅槃
  空无我妙理　　诸佛真境界
  能怖众恶见　　涅槃不二门
  愚闻空法名　　皆生大怖畏
  如见大力者　　怯劣悉奔逃
  诸佛虽无心　　说摧他论法
  而他论自坏　　如野火焚薪
  诸有悟正法　　定不乐邪宗
  为余出伪门　　故显真空义
  若知佛所说　　真空无我理
  随顺不生欣　　乖违无厌怖
  见诸外道众　　为多无义因
  乐正法有情　　谁不深悲愍
  婆罗门离系　　如来三所宗
  耳眼意能知　　故佛法深细
  婆罗门所宗　　多令行诳诈
  离系外道法　　多分顺愚痴
  恭敬婆罗门　　为诵诸明故
  愍念离系者　　由自苦其身
  如苦业所感　　非真解脱因
  胜身业所生　　亦非证解脱
  略言佛所说　　具二别余宗
  不害生人天　　观空证解脱
  世人耽自宗　　如爱本生地
  正法能摧灭　　邪党不生欣
  有智求胜德　　应信受真宗
  正法如日轮　　有目因能见

    破根境品第五

  于瓶诸分中　　可见唯是色
  言瓶全可见　　如何能悟真
  诸有胜慧人　　随前所说义
  于香味及触　　一切类应遮
  若唯见瓶色　　即言见瓶者
  既不见香等　　应名不见瓶
  有障碍诸色　　体非全可见
  彼分及中间　　由此分所隔
  极微分有无　　应审谛思察
  引不成为证　　义终不可成
  一切有碍法　　皆众分所成
  言说字亦然　　故非根所取
  离显色有形　　云何取形色
  即显取形色　　何故不由身
  离色有色因　　应非眼所见
  二法体既异　　如何不别观
  身觉于坚等　　共立地等名
  故唯于触中　　说地等差别
  瓶所见生时　　不见有异德
  体生如所见　　故实性都无
  眼等皆大造　　何眼见非余
  故业果难思　　牟尼真实说
  智缘未有故　　智非在见先
  居后智唐捐　　同时见无用
  眼若行至境　　色远见应迟
  何不亦分明　　照极远近色
  若见已方行　　行即为无用
  若不见而往　　定欲见应无
  若不往而观　　应见一切色
  眼既无行动　　无远亦无障
  诸法体相用　　前后定应同
  如何此眼根　　不见于眼性
  眼中无色识　　识中无色眼
  色内二俱无　　何能合见色
  所闻若能表　　何不成非音
  声若非能诠　　何故缘生解
  声若至耳闻　　如何了声本
  声无顿说理　　如何全可知
  乃至非所闻　　应非是声性
  先无而后有　　理定不相应
  心若离诸根　　去亦应无用
  设如是命者　　应常无有心
  令心妄取尘　　依先见如焰
  妄立诸法义　　是想蕴应知
  眼色等为缘　　如幻生诸识
  若执为实有　　幻喻不应成
  世间诸所有　　无不皆难测
  根境理同然　　智者何惊异
  诸法如火轮　　变化梦幻事
  水月彗星响　　阳焰及浮云

    破边执品第六

  诸法若实有　　应不依他成
  既必依他成　　定知非实有
  非即色有瓶　　非离色有瓶
  非依瓶有色　　非有瓶依色
  若见二相异　　谓离瓶有同
  二相既有殊　　应离瓶有异
  若一不名瓶　　瓶应不名一
  瓶一曾无合　　瓶应无一名
  若色遍于实　　色应得大名
  敌论若非他　　应申自宗义
  有数等能相　　显所相不成
  除此更无因　　故诸法非有
  离别相无瓶　　故瓶体非一
  一一非瓶故　　瓶体亦非多
  非无有触体　　与有触体合
  故色等诸法　　不可合为瓶
  色是瓶一分　　故色体非瓶
  有分既为无　　一分如何有
  一切色等性　　色等相无差
  唯一类是瓶　　余非有何理
  若色异味等　　不异于瓶等
  瓶等即味等　　色何即瓶等
  瓶等既无因　　体应不成果
  故若异色等　　瓶等定为无
  瓶等因若有　　可为瓶等因
  瓶等因既无　　如何生瓶等
  色等和合时　　终不成香等
  故和合一体　　应如瓶等无
  如离于色等　　瓶体实为无
  色体亦应然　　离风等非有
  暖即是火性　　非暖如何烧
  故薪体为无　　离此火非有
  余暖杂故成　　如何不成火
  若余不成暖　　由火法应无
  若火微无薪　　应离薪有火
  火微有薪者　　应无火极微
  审观诸法时　　无一体实有
  一体既非有　　多体亦应无
  若法更无余　　汝谓为一体
  诸法皆三性　　故一体为无
  有非有俱非　　一非一双泯
  随次应配属　　智者达非真
  于相续假法　　恶见诸真常
  积集假法中　　邪执言实有
  诸法众缘成　　性羸无自在
  虚假依他立　　故我法皆无
  果众缘合成　　离缘无别果
  如是合与果　　诸圣达皆无
  识为诸有种　　境是识所行
  见境无我时　　诸有种皆灭

    破有为相品第七

  若本无而生　　先无何不起
  本有而生者　　后有复应生
  果若能违因　　先无不应理
  果立因无用　　先有亦不成
  此时非有生　　彼时亦无生
  此彼时无生　　何时当有生
  如生于自性　　生义既为无
  于他性亦然　　生义何成有
  初中后三位　　生前定不成
  二一既为无　　一一如何有
  非离于他性　　唯从自性生
  非从他及俱　　故生定非有
  前后及同时　　二俱不可说
  故生与瓶等　　唯假有非真
  旧若在新前　　前生不应理
  旧若居新后　　后生理不成
  现非因现起　　亦非因去来
  未来亦不因　　去来今世起
  若具即无来　　既灭应非往
  法体相如是　　幻等喻非虚
  生住灭三相　　同时有不成
  前后亦为无　　如何执为有
  若生等诸相　　复有别生等
  应住灭如生　　或生住如灭
  所相异能相　　何为体非常
  不异四应同　　或复全非有
  有不生有法　　有不生无法
  无不生有法　　无不生无法
  有不成有法　　有不成无法
  无不成有法　　无不成无法
  半生半未生　　非一生时体
  或以未生位　　应亦是生时
  生时若是果　　体即非生时
  生时若自然　　应失生时性
  已生异未生　　别有中间位
  生时异二位　　应别有中间
  若谓生时舍　　方得已生时
  是则应有余　　得时而可见
  若至已生位　　理必无生时
  已生有生时　　云何从彼起
  未至已生位　　若立为生时
  何不谓无瓶　　未生无别故
  非生时有用　　能简未生时
  亦非体未圆　　别于已生位
  前位生时无　　后位方言有
  兼成已生位　　故此位非无
  有时名已生　　无时名未起
  除兹有无位　　谁复谓生时
  诸有执离因　　无别所成果
  转生及转灭　　理皆不可成

    教诫弟子品第八

  由少因缘故　　疑空谓不空
  依前诸品中　　理教应重遣
  能所说若有　　空理则为无
  诸法假缘成　　故三事非有
  若唯说空过　　不空义即成
  不空过已明　　空义应先立
  诸欲坏他宗　　必应成己义
  何乐谈他失　　而无立己宗
  为破一等执　　假立遣为宗
  他三执既除　　自宗随不立
  许执为现见　　空因非有能
  余宗现见因　　此宗非所许
  若无不空理　　空理如何成
  汝既不立空　　不空应不立
  若许有无宗　　有宗方可立
  无宗若非有　　有宗应不成
  若诸法皆空　　如何火名暖
  此如前具遣　　火暖俗非真
  若谓法实有　　遮彼说为空
  应四论皆真　　见何过而舍
  若诸法都无　　生死应非有
  诸佛何曾许　　执法定为无
  若真离有无　　何缘言俗有
  汝本宗亦尔　　致难复何为
  诸法若都无　　差别应非有
  执诸法皆有　　差别亦应无
  若谓法非有　　无能破有因
  破有因已明　　汝宗何不立
  说破因易得　　是世俗虚言
  汝何缘不能　　遮破真空义
  有名诠法有　　谓法实非无
  无名表法无　　法实应非有
  由名解法有　　遂谓法非无
  因名知法无　　应信法非有
  诸世间可说　　皆是假非真
  离世俗名言　　乃是真非假
  谤诸法为无　　可坠于无见
  唯蠲诸妄执　　如何说堕无
  有非真有故　　无亦非真无
  既无有真无　　何有于真有
  有因证法空　　法空应不立
  宗因无异故　　因体实为无
  谓空喻别有　　例诸法非空
  唯有喻应成　　内我同乌黑
  若法本性空　　见空有何德
  虚妄分别缚　　证空见能除
  法成一成无　　违真亦违俗
  故与有一异　　二俱不可言
  有非有俱非　　诸宗皆寂灭
  于中欲兴难　　毕竟不能申

圣天菩萨。造论既周。重叙摧邪。复说颂曰

  我在为燎邪宗火　　沷以如来正教酥
  又扇因明广大风　　谁敢如蛾投猛焰

广百论本一卷


六十颂如理论

    No. 1575

六十颂如理论

        龙树菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

  归命三世寂默主　　宣说缘生正法语
  若了诸法离缘生　　所作法行如是离

  离有无二边　　智者无所依
  甚深无所缘　　缘生义成立
  若谓法无性　　即生诸过失
  智者应如理　　伺察法有性
  若有性实得　　如愚者分别
  无性即无因　　解脱义何立
  不可说有性　　不可说无性
  了知性无性　　大智如理说
  涅盘与生死　　勿观别异性
  非涅槃生死　　二性有差别
  生死及涅槃　　二俱无所有
  若了知生死　　此即是涅槃
  破彼生有性　　分别灭亦然
  如幻所作事　　灭现前无实
  若灭有所坏　　知彼是有为
  现法尚无得　　复何知坏法
  彼诸蕴不灭　　染尽即涅槃
  若了知灭性　　彼即得解脱
  若生法灭法　　二俱不可得
  正智所观察　　从无明缘生
  若见法寂静　　诸所作亦然
  知此最胜法　　获法智无边
  缘生性可见　　是义非无见
  此中微妙性　　非缘生分别
  佛正觉所说　　有说非无因
  若尽烦恼源　　即破轮回相
  诸法决定行　　见有作有取
  前后际云何　　从缘所安立
  云何前已生　　彼后复别转
  故前后边际　　如世幻所见
  云何幻可生　　云何有所著
  痴者于幻中　　求幻而为实
  前际非后际　　执见故不舍
  智观性无性　　如幻焰影像
  若谓生非灭　　是有为分别
  而彼缘生轮　　随转无所现
  若已生未生　　彼自性无生
  若自性无生　　生名云何得
  因寂即法尽　　此尽不可得
  若自性无尽　　尽名云何立
  无少法可生　　无少法可灭
  彼生灭二道　　随事随义现
  知生即知灭　　知灭知无常
  无常性若知　　不得诸法底
  诸法从缘生　　虽生即离灭
  如到彼岸者　　即见大海事
  若自心不了　　异生执我性
  性无性颠倒　　即生诸过失
  诸法是无常　　苦空及无我
  此中见法离　　智观性无性
  无住无所缘　　无根亦不立
  从无明种生　　离初中后际
  痴闇大恶城　　如芭蕉不实
  如乾闼婆城　　皆世幻所见
  此界梵王初　　佛如实正说
  后诸圣无妄　　说亦无差别
  世间痴所闇　　爱相续流转
  智者了诸爱　　而平等善说
  初说诸法有　　于有求实性
  后求性亦无　　即无著性离
  若不知离义　　随闻即有着
  而所作福业　　凡愚者自破
  如先平等说　　彼诸业真实
  自性若了知　　此说即无生
  我如是所说　　皆依佛言教
  如其所宣扬　　即蕴处界法
  大种等及识　　所说皆平等
  彼智现证时　　无妄无分别
  此一若如实　　佛说为涅槃
  此最胜无妄　　无智即分别
  若心有散乱　　与诸魔作便
  若如实离过　　此即无所生
  如是无明缘　　佛为世间说
  若世无分别　　此云何无生
  若无明可灭　　灭已即非生
  生灭名乖违　　无智起分别
  有因即有生　　无缘即无住
  离缘若有性　　此有亦何得
  若有性可取　　即说有生住
  此中疑复多　　谓有法可住
  若菩提可证　　即处处常语
  若住性可取　　此说还有生
  若谓法有实　　无智作是说
  若谓法有处　　取亦不可得
  法无生无我　　智悟入实性
  常无常等相　　皆由心起见
  若成立多性　　即成欲实性
  彼云何非此　　常得生过失
  若成立一性　　所欲如水月
  非实非无实　　皆由心起见
  贪嗔法极重　　由是生见执
  诤论故安立　　离性而执实
  彼因起诸见　　见故生烦恼
  若此正了知　　见烦恼俱尽
  当知法无常　　从缘生故现
  缘生亦无生　　此最上实语
  众生邪妄智　　无实谓实想
  于他诤论兴　　自行颠倒转
  自分不可立　　他分云何有
  自他分俱无　　智了无诤论
  有少法可依　　烦恼如毒蛇
  若无寂无动　　心即无所依
  烦恼如毒蛇　　生极重过失
  烦恼毒所覆　　云何见诸心
  如愚见影像　　彼妄生实想
  世间缚亦然　　慧为痴所网
  性喻如影像　　非智眼境界
  大智本不生　　微细境界想
  着色谓凡夫　　离贪即小圣
  了知色自性　　是为最上智
  若着诸善法　　如离贪颠倒
  犹见幻人已　　离所作求体
  知此义为失　　不观性无性
  烦恼不可得　　性光破邪智
  智离染清净　　亦无净可依
  有依即有染　　彼净还生过
  极恶烦恼法　　若见自性离
  即心无动乱　　得渡生死海
  此善法甘露　　从大悲所生
  依如来言宣　　无分限分别

  此中如是难可说　　随智者见即成就
  智者随观随顺门　　如是皆从大悲转
  一切法中真实性　　智者随应如理观
  所向由是信得生　　拔彼众生离诸苦
  此义甚深复广大　　我为胜利故赞说
  如大智言今已宣　　自他痴闇皆能破
  破彼痴闇烦恼已　　如如所作离魔障
  由是能开善趣门　　诸解脱事而何失
  持净戒者得生天　　此即决定真实句
  设破戒者住正心　　虽坏戒而不坏见
  种子生长非无义　　见义利故广施作
  不以大悲为正因　　智者何能生法欲

六十颂如理论


十二门论品

    No. 1568

    十二门论品目

观因缘门第一

  (万法所因似各有性推而会之实自无性通达无滞故谓之门)

观有果无果门第二

  (重推无性之法为先有而生为先无而生有无无生以之为门)

观缘门第三

  (上推因此推缘四缘广略皆无有果故以为门)

观相门第四

  (上三门推因缘无生此推三相三相既无以之为门)

观有相无相门第五

  (此推三相之实为有相而相为无相而相有无无相故以为门)

观一异门第六

  (即推有相无相为在一法为在异法不一不异以之为门)

观有无门第七

  (上推三相非相此明四相亦非生住为有变异为无同处不有异处亦无故以为门)

观性门第八

  (既知有无又推其性变易无常从缘而有则非性也故以为门)

观因果门第九

  (无性之法既无因果变异处推求则无得理故以为门)

观作门第十

  (无因无果则为无作四处既无以之为门)

观三时门第十一

  (既推无作必尽其因故寻三时无作而以为门)

观生门第十二

  (作为有造生为有起时中既无谁为生者即以为门)

    十二门论序

十二门论者。盖是实相之折中。道场之要轨也。十二门者。总众枝之大数也。门者开通无滞之称也。论之者。欲以穷其源尽其理也。若一理之不尽。则众异纷然。有或趣之乖。一源之不穷。则众涂扶疏。有殊致之迹。殊致之不夷。乖趣之不泯。大士之忧也。是以龙树菩萨。开出者之由路。作十二门以正之。正之以十二。则有无兼畅。事无不尽。事尽于有无。则忘功于造化。理极于虚位。则丧我于二际。然则丧我在乎落筌。筌忘存乎遗寄。筌我兼忘。始可以几乎实矣。几乎实矣。则虚实两冥。得失无际。冥而无际。则能忘造次于两玄。泯颠沛于一致。整归驾于道场。毕趣心于佛地。恢恢焉。真可谓运虚刃于无间。奏希声于宇内。济溺丧于玄津。出有无于域外者矣。遇哉后之学者。夷路既坦。幽涂既开。真得振和鸾于北冥。驰白牛以南回。悟大觉于梦境。即百化以安归。夫如是者慧。复知曜灵之方盛。玄陆之未希也哉。睿以鄙倍之浅识犹敢朋。用诚虚关。希怀宗极。庶日用之有宜。冀岁计之能殖。况才之美者乎。不胜敬仰之至。敢以钝辞[打-丁+豆]思。序而申之。并目品义题之于首。岂其能益也。庶以此心。开疾进之路耳

    观因缘门第一

        龙树菩萨造

        姚秦三藏鸠摩罗什译

说曰。今当略解摩诃衍义。问曰。解摩诃衍者。有何义利。答曰。摩诃衍者。是十方三世诸佛甚深法藏。为大功德利根者说。末世众生薄福钝根。虽寻经文不能通达。我愍此等欲令开悟。又欲光阐如来无上大法。是故略解摩诃衍义。问曰。摩诃衍无量无边不可称数。直是佛语尚不可尽。况复解释演散其义。答曰以是义故。我初言略解。问曰。何故名为摩诃衍。答曰。摩诃衍者。于二乘为上故。名大乘。诸佛最大是乘能至。故名为大。诸佛大人乘是乘故。故名为大。又能灭除众生大苦。与大利益事故名为大。又观世音。得大势。文殊师利。弥勒菩萨等。是诸大士之所乘故。故名为大。又以此乘。能尽一切诸法边底。故名为大。又如般若经中。佛自说摩诃衍义无量无边。以是因缘故名为大。大分深义所谓空也。若能通达是义。即通达大乘。具足六波罗蜜无所障碍。是故我今但解释空。解释空者。当以十二门入于空义。初是因缘门所谓

  众缘所生法　　是即无自性
  若无自性者　　云何有是法

众缘所生法有二种一者内二者外。众缘亦有二种。一者内。二者外。外因缘者。如泥团转绳陶师等和合故有瓶生。又如缕绳机杼识师等和合故有叠生。又如治地筑基梁椽泥草人功等和合故有舍生。又如酪器钻摇人功等和合故有酥生。又如种子地水火风虚空时节人功等和合故有芽生。当知外缘等法皆亦如是。内因缘者。所谓无明行识名色六入触受爱取有生老死。各各先因而后生。如是内外诸法。皆从众缘生。从众缘生故。即非是无性耶。若法自性无他性亦无。自他亦无。何以故。因他性故无自性。若谓以他性故有者。则牛以马性有。马以牛性有。梨以柰性有。柰以梨性有。余皆应尔。而实不然。若谓不以他性故有。但因他故有者。是亦不然。何以故。若以蒲故有席者。则蒲席一体。不名为他。若谓蒲于席为他者。不得言以蒲故有席。又蒲亦无自性。何以故。蒲亦从众缘出。故无自性。无自性故。不得言以蒲性故有席。是故席不应以蒲为体。余瓶酥等外因缘生法。皆亦如是不可得。内因缘生法皆亦如是不可得。如七十论中说

  缘法实无生　　若谓为有生
  为在一心中　　为在多心中

是十二因缘法。实自无生。若谓有生。为一心中有。为众心中有。若一心中有者。因果即一时共生。又因果一时有。是事不然。何以故。凡物先因后果故。若众心中有者。十二因缘法。则各各别异。先分共心灭已。后分谁为因缘灭。法无所有何得为因。十二因缘法若先有者。应若一心若多心。二俱不然。是故众缘皆空。缘空故从缘生法亦空。是故当知。一切有为法皆空。有为法尚空。何况我耶。因五阴十二入十八界有为法故说有我。如因可然故说有然。若阴入界空。更无有法可说为我。如无可然不可说然。如经说。佛告诸比丘。因我故有我所。若无我则无我所。如是有为法空故。当知无为涅槃法亦空。何以故。此五阴灭。更不生余五阴。是名涅槃。五阴本来自空。何所灭故说名涅槃。又我亦复空。谁得涅槃。复次无生法名涅槃。若生法成者。无生法亦应成。生法不成。先已说因缘。后当复说。是故生法不成。因生法故名无生。若生法不成。无生法云何成。是故有为无为。及我皆空

    观有果无果门第二

复次诸法不生。何以故

  先有则不生　　先无亦不生
  有无亦不生　　谁当有生者

若果因中先有。则不应生。先无亦不应生。先有无亦不应生。何以故。若果因中先有而生。是则无穷。如果先未生而生者。今生已复应更生。何以故。因中常有故。从是有边复应更生。是则无穷。若谓生已更不生。未生而生者。是中无有生理。是故先有而生。是事不然。复次若因中先有果。而谓未生而生。生已不生者。是亦二俱有。而一生一不生。无有是处。复次若未生定有者。生已则应无。何以故。生未生共相违故。生未生相违故。是二作相亦相违。复次有与无相违。无与有相违。若生已亦有。未生时亦有者。则生未生不应有异。何以故。若有生。生已亦有。未生亦有。如是生未生有何差别。生未生无差别。是事不然。是故有不生。复次有已先成。何用更生。如作已不应作。成已不应成。是故有法不应生。复次若有生因中未生时。果应可见而实不可见。如泥中瓶蒲中席。应可见而实不可见。是故有不生。问曰。果虽先有。以未变故不见。答曰。若瓶未生时。瓶体未变故不见者。以何相知。言泥中先有瓶。为以瓶相有瓶。为以牛相马相故有瓶耶。若泥中无瓶相者。亦无牛相马相。是岂不名无耶。是故汝说因中先有果而生者。是事不然。复次变法即是果者。即应因中先有变。何以故。汝法因中先有果故。若瓶等先有变亦先有。应当可见而实不可得。是故汝言未变故不见。是事不然。若谓未变不名为果。则果毕竟不可得。何以故。是变先无后亦应无。故瓶等果毕竟不可得。若谓变已是果者。则因中先无。如是则不定。或因中先有果。或先无果。问曰。先有变但不可得见。凡物自有。有而不可得者。如物或有近而不可知。或有远而不可知。或根坏故不可知。或心不住故不可知。障故不可知。同故不可知。胜故不可知。微细故不可知。近而不可知者。如眼中药。远而不可知者。如鸟飞虚空高翔远逝。根坏故不可知者。如盲不见色。聋不闻声。鼻塞不闻香。口爽不知味。身顽不知触。心狂不知实。心不住故不可知者。如心在色等则不知声。障故不可知者。如地障大水壁障外物。同故不可知者。如黑上墨点。胜故不可知者如有钟鼓音不闻捎拂声。细微故不可知者。如微尘等不现。如是诸法虽有。以八因缘故不可知。汝说因中变不可得。瓶等不可得者。是事不然。何以故。是事虽有。以八因缘故不可得。答曰。变法及瓶等果。不同八因缘不可得。何以故。若变法及瓶等果。极近不可得者。小远应可得。极远不可得者。小近应可得。若根坏不可得者。根净应可得。若心不住不可得者。心住应可得。若障不可得者。变法及瓶法无障应可得。若同不可得者。异时应可得。若胜不可得者。胜止应可得。若细微不可得者。而瓶等果粗应可得。若瓶细故不可得者。生已亦应不可得。何以故。生已未生细相一故。生已未生俱定有故。问曰。未生时细生已转粗。是故生已可得。未生不可得。答曰。若尔者。因中则无果。何以故。因中无粗故。又因中先无粗。若因中先有粗者。则不应言细故不可得。今果是粗。汝言细故不可得。是粗不名为果。今果毕竟不应可得。而果实可得。是故不以细故不可得。如是有法。因中先有果。以八因缘故不可得。先因中有果。是事不然。复次若因中先有果生者。是则因因相坏。果果相坏。何以故。如叠在缕。如果在器。但是住处不名为因。何以故。缕器非叠果因故。若因坏果亦坏。是故缕等非叠等因。因无故果亦无。何以故。因因故有果成。因不成果云何成。复次若不作不名果。缕等因不能作叠等果。何以故。如缕等不以叠等住故能作叠等果。如是则无因无果。若因果俱无。则不应求因中若先有果若先无果。复次若因中有果而不可得。应有相现。如闻香知有华。闻声知有鸟。闻笑知有人。见烟知有火。见鹄知有池。如是因中若先有果。应有相现。今果体亦不可得。相亦不可得。如是当知。因中先无果。复次若因中先有果生。则不应言因缕有叠因蒲有席。若因不作他亦不作。如叠非缕所作。可从蒲作耶。若缕不作蒲亦不作。可得言无所从作耶。若无所从作。则不名为果。若果无因亦无。如先说。是故从因中先有果生。是则不然。复次若果无所从作。则为是常。如涅槃性。若果是常。诸有为法则皆是常。何以故。一切有为法皆是果故。若一切法皆常。则无无常。若无无常亦无有常。何以故。因常有无常。因无常有常。是故常无常二俱无者。是事不然。是故不得言因中先有果生。复次若因中先有果生。则果更与异果作因。如叠与着为因。如席与障为因。如车与载为因。而实不与异果作因。是故不得言因中先有果生。若谓如地先有香。不以水洒香则不发。果亦如是。若未有缘会。则不能作因。是事不然。何以故。如汝所说。可了时名果。瓶等物非果。何以故。可了是作。瓶等先有非作。是则以作为果。是故因中先有果生。是事不然。复次了因但能显发。不能生物。如为照闇中瓶故然灯亦能照余卧具等物。为作瓶故和合众缘不能生余卧具等物是故当知。非先因中有果生。复次若因中先有果生。则不应有今作当作差别。而汝受今作当作。是故非先因中有果生。若谓因中先无果而果生者。是亦不然。何以故。若无而生者。应有第二头第三手生。何以故。无而生故。问曰。瓶等物有因缘。第二头第三手无因缘。云何得生。是故汝说不然。答曰。第二头第三手及瓶等果。因中俱无。如泥团中无瓶。石中亦无瓶。何故名泥团为瓶因。不名石为瓶因。何故名乳为酪因。缕为叠因。不名蒲为因。复次若因中先无果而果生者。则一一物应生一切物。如指端。应生车马饮食等。如是缕不应但出叠。亦应出车马饮食等物何以故。若无而能生者。何故缕但能生叠而不生车马饮食等物。以俱无故。若因中先无果而果生者。则诸因不应各各有力能生果。如须油者要从麻取不笮于沙。若俱无者。何故麻中求而不笮沙。若谓曾见麻出油。不见从沙出。是故麻中求而不笮沙。是事不然。何以故。若生相成者。应言余时见麻出油不见沙出。是故于麻中求不取沙。而一切法生相不成故。不得言余时见麻出油故麻中求不取于沙。复次我今不但破一事。皆总破一切因果。若因中先有果生。先无果生。先有果无果生。是三生皆不成。是故汝言余时见麻出油。则堕同疑因。复次若先因中无果而果生者。诸因相则不成。何以故。诸因若无。法何能作何能成。若无作无成。云何名为因。如是作者不得有所作。使作者亦不得有所作。若谓因中先有果。则不应有作作者作法别异。何以故。若先有果。何须复作。是故汝说作作者作法诸因皆不可得。因中先无果者。是亦不然。何以故。若人受作作者分别有因果。应作是难。我说作作者及因果皆空。若汝破作作者及因果。则成我法。不名为难。是故因中先无果而果生。是事不然。复次若人受因中先有果。应作是难。我不说因中先有果故。不受此难亦不受因中先无果。若谓因中先亦有果亦无果而果生。是亦不然。何以故。有无性相违故。性相违者。云何一处。如明闇苦乐去住缚解不得同处。是故因中先有果先无果。二俱不生。复次因中先有果先无果。上有无中已破。是故先因中有果亦不生。无果亦不生。有无亦不生。理极于此。一切处推求不可得。是故果毕竟不生。果毕竟不生故。则一切有为法皆空。何以故。一切有为法。皆是因是果。有为空故无为亦空。有为无为尚空。何况我耶

    观缘门第三

复次诸法缘不成。何以故

  广略众缘法　　是中无有果
  缘中若无果　　云何从缘生

瓶等果一一缘中无。和合中亦无。若二门中无。云何言从缘生。问曰。云何名为诸缘。答曰

  四缘生诸法　　更无第五缘
  因缘次第缘　　缘缘增上缘

四缘者。因缘。次第缘。缘缘。增上缘。因缘者。随所从生法。若已从生今从生当从生。是法名因缘。次第缘者。前法已灭次第生。是名次第缘。缘缘者。随所念法。若起身业。若起口业。若起心心数法。是名缘缘。增上缘者。以有此法故彼法得生。此法于彼法为增上缘。如是四缘。皆因中无果。若因中有果者。应离诸缘而有果。而实离缘无果。若缘中有果者。应离因而有果。而实离因无果。若于缘及因有果者应可得。以理推求而不可得。是故二处俱无。如是一一中无。和合中亦无。云何得言果从缘生。复次

  若果缘中无　　而从缘中出
  是果何不从　　非缘中而出

若谓果缘中无而从缘生者。何故不从非缘生。二俱无故。是故无有因缘能生果者。果不生故缘亦不生。何以故。以先缘后果故。缘果无故一切有为法空。有为法空故无为法亦空。有为无为空故。云何有我耶

    观相门第四

复次一切法空何以故

  有为及无为　　二法俱无相
  以无有相故　　二法则皆空

有为法不以相成。问曰何等是有为相。答曰。万物各有有为相。如牛以角峰垂[古*頁]尾端有毛。是为牛相。如瓶以底平腹大颈细唇粗。是为瓶相。如车以轮轴辕轭。是为车相。如人以头目腹脊肩臂手足。是为人相。如是生住灭。若是有为法相者。为是有为。为是无为。问曰若是有为有何过。答曰

  若生是有为　　复应有三相
  若生是无为　　何名有为相

若生是有为者。即应有三相。是三相复应有三相。如是展转则为无穷。住灭亦尔。若生是无为者。云何无为与有为作相。离生住灭谁能知是生。复次分别生住灭故有生。无为不可分别是故无生。住灭亦尔。生住灭空故有为法空。有为法空故无为法亦空。因有为故有无为。有为无为法空故一切法皆空。问曰。汝说三相复有三相是故无穷。生不应是有为者。今当说

  生生之所生　　生于彼本生
  本生之所生　　还生于生生

法生时通自体七法共生。一法。二生。三住。四灭。五生生。六住住。七灭灭。是七法中。本生除自体。能生六法。生生能生本生。本生还生生生。是故三相虽是有为而非无穷。住灭亦如是。答曰

  若谓是生生　　还能生本生
  生生从本生　　何能生本生

若谓生生能生本生。本生不生生生。生生何能生本生

  若谓是本生　　能生彼生生
  本生从彼生　　何能生生生

若谓本生能生生生。生生生已还生本生。是事不然。何以故。生生法应生本生。是故名生生。而本生实自未生。云何能生生生。若谓生生生时能生本生者是事亦不然。何以故

  是生生生时　　或能生本生
  生生尚未生　　何能生本生

是生生生时。或能生本生。而是生生自体未生。不能生本生。若谓是生生生时能自生亦生彼。如灯然时能自照亦照彼。是事不然何以故

  灯中自无闇　　住处亦无闇
  破闇乃名照　　灯为何所照

灯体自无闇。明所住处亦无闇。若灯中无闇。住处亦无闇。云何言灯自照亦能照彼。破闇故名为照。灯不自破闇。亦不破彼闇。是故灯不自照。亦不照彼。是故汝先说灯自照亦照彼。生亦如是自生亦生彼者。是事不然。问曰。若灯然时能破闇。是故灯中无闇。住处亦无闇。答曰

  云何灯然时　　而能破于闇
  此灯初然时　　不能及于闇

若灯然时不能到闇。若不到闇不应言破闇。复次

  灯若不及闇　　而能破闇者
  灯在于此间　　则破一切闇

若谓灯虽不到闇。而力能破闇者。此处然灯应破一切世间闇。俱不及故。而实此间然灯。不能破一切世间闇。是故汝说灯虽不及闇。而力能破闇者。是事不然。复次

  若灯能自照　　亦能照于彼
  闇亦应如是　　自蔽亦蔽彼

若谓灯能自照亦照彼。闇与灯相违。亦应自蔽亦蔽彼。若闇与灯相违。不能自蔽亦不蔽彼。而言灯能自照亦照彼者。是事不然。是故汝喻非也。如生能自生亦生彼者。今当更说

  此生若未生　　云何能自生
  若生已自生　　已生何用生

此生未生时。应若生已生。若未生生。若未生而生。未生名未有。云何能自生。若谓生已而生生已即是生。何须更生。生已更无生作已更无作。是故生不自生。若生不自生。云何生彼。汝说自生亦生彼。是事不然。住灭亦如是。是故生住灭是有为相。是事不然。生住灭有为相不成故有为法空。有为法空故无为法亦空。何以故。灭有为名无为涅槃。是故涅槃亦空。复次无生无住无灭。名无为相。无生住灭则无法。无法不应作相。若谓无相是涅槃相。是事不然。若无相是涅槃相。以何相故。知是无相。若以有相知是无相。云何名无相。若以无相知是无相。无相是无。无则不可知。若谓如众衣皆有相唯一衣无相正以无相为相故。人言取无相衣。如是可知无相衣可取。如是生住灭是有为相。无生住灭处当知是无为相。是故无相是涅槃者。是事不然。何以故。生住灭种种因缘皆空。不得有有为相。云何因此知无为。汝得何有为决定相。知无相处是无为。是故汝说众相衣中无相衣喻涅槃无相者。是事不然。又衣喻后第五门中广说。是故有为法皆空。有为法空故无为法亦空。有为无为法空故我亦空。三事空故一切法皆空

    观有相无相门第五

复次一切法空。何以故

  有相相不相　　无相亦不相
  离彼相不相　　相为何所相

有相事中相不相。何以故。若法先有相。更何用相为。复次若有相事中相得相者。则有二相过。一者先有相。二者相来相。是相是故有相事中相无所相。无相事中相亦无所相。何法名无相。而以有相相。如象有双牙。垂一鼻。头有三隆。耳如箕。脊如弯弓。腹大而垂。尾端有毛。四脚粗圆。是为象相。若离是相。更无有象可以相相。如马竖耳垂[髟/公/心]。四脚同蹄。尾通有毛。若离是相。更无有马可以相相。如是有相中相无所相。无相中相亦无所相。离有相无相。更无第三法可以相相。是故相无所相。相无所相故。可相法亦不成。何以故。以相故知是事名可相。以是因缘故相可相俱空。相可相空故万物亦空。何以故。离相可相更无有物。物无故非物亦无。以物灭故名无物。若无物者何所灭。故名为无物。物无物空故一切有为法皆空。有为法空故无为法亦空。有为无为空故我亦空

    观一异门第六

复次一切法空。何以故

  相及与可相　　一异不可得
  若无有一异　　是二云何成

是相可相。若一不可得。异亦不可得。若一异不可得。是二则不成。是故相可相皆空。相可相空故一切法皆空。问曰。相可相常成。何故不成。汝说相可相一异不可得。今当说凡物或相即是可相。或相异可相。或少分是相。余是可相。如识相是识离所用识更无识。如受相是受离所用受更无受。如是等相即是可相。如佛说。灭爱名涅槃。爱是有为有漏法。灭是无为无漏法。如信者有三相。乐亲近善人。乐欲听法乐行布施。是三事身口业故。色阴所摄信是心数法故。行阴所摄。是名相与可相异。如正见是道相。于道是少分。又生住灭是有为相于有为法是少分。如是于可相中少分名相。是故或相即可相。或相异可相。或可相少分为相。汝言一异不成故。相可相不成者。是事不然。答曰。汝说或相是可相如识等。是事不然。何以故。以相故可知名可相所用者名为相。凡物不能自知。如指不能自触。如眼不能自见。是故汝说识即是相可相。是事不然。复次若相即是可相者。不应分别是相是可相。若分别是相是可相者。不应言相即是可相。复次若相即是可相者。因果则一。何以故相是因可相是果。是二则一。而实不一。是故相即是可相。是事不然。汝说相异可相者。是亦不然。汝说灭爱是涅槃相。不说爱是涅槃相。若说爱是涅槃相。应言相可相异。若言灭爱是涅槃相者。则不得言相可相异。又汝说信者有三相俱不异。信若无信则无此三事。是故不得相可相异又相可相异者。相更复应有相。则为无穷。是事不然。是故相可相不得异。问曰。如灯能自照亦能照彼。如是相能自相亦能相彼。答曰。汝说灯喻三有为相中已破。又自违先说。汝上言相可相异。而今言相自能相亦能相彼。是事不然。又汝说可相中少分是相者。是事不然。何以故。此义或在一中。或在异中。一异义先已破故。当知少分相亦破。如是种种因缘相可相。一不可得异不可得。更无第三法成相可相。是故相可相俱空。是二空故。一切法皆空

    观有无门第七

复次一切法空。何以故。有无一时不可得。非一时亦不可得。如说

  有无一时无　　离无有亦无
  不离无有有　　有则应常无

有无性相违。一法中不应共有。如生时无死。死时无生。是事中论中已说。若谓离无有有无过者。是事不然。何以故。离无云何有有。如先说法生时通自体七法共生。如阿毗昙中说。有与无常共生。无常是灭相故名无。是故离无有则不生。若不离无常有有生者。有则常无。若有常无者。初无有住。常是坏故。而实有住。是故有不常无。若离无常有有生者。是亦不然。何以故。离无常有实不生。问曰。有生时已有无常而未发。灭时乃发坏是有。如是生住灭老。得皆待时而发。有起时生为用令有生。生灭中间住为用持是有。灭时无常为用灭是有。老变生至住变住至灭。无常则坏得常。令四事成就。是故法虽与无常共生有非常无。答曰。汝说无常是灭相与有共生。生时有应坏。坏时有应生。复次生灭俱无。何以故。灭时不应有生。生时不应有灭。生灭相违故。复次汝法无常与住共生。有坏时应无住。若住则无坏。何以故。住坏相违故。老时无住住时无老。是故汝说生住灭老无常得本来共生。是则错乱。何以故。是有若与无常共生。无常是坏相。凡物生时无坏相。住时亦无坏相。尔时非是无无常相耶。如能识故名识。不能识则无识相。能受故名受。不能受则无受相能念故名念。不能念则无念相。起是生相。不起则非生相。摄持是住相。不摄持则非住相。转变是老相。不转变则非老相。寿命灭是死相。寿命不灭则非死相。如是坏是无常相。离坏非无常相。若生住时虽有无常不能坏有。后能坏有者何用共生为。如是应随有坏时乃有无常。是故无常虽共生。后乃坏有者。是事不然。如是有无共不成。不共亦不成。是故有无空。有无空故一切有为空。一切有为空故无为亦空。有为无为空故众生亦空

    观性门第八

复次一切法空。何以故。诸法无性故。如说

  见有变异相　　诸法无有性
  无性法亦无　　诸法皆空故

诸法若有性。则不应变异。而见一切法皆变异。是故当知诸法无性。复次若诸法有定性。则不应从众缘生。若性从众缘生者。性即是作法。不作法不因待他名为性。是故一切法空。问曰。若一切法空。则无生无灭。若无生灭。则无苦谛。若无苦谛。则无集谛。若无苦集谛。则无灭谛。若无苦灭则无至苦灭道。若诸法空无性。则无四圣谛。无四圣谛故。亦无四沙门果。无四沙门果故。则无贤圣。是事无故。佛法僧亦无。世间法皆亦无。是事不然。是故诸法不应尽空。答曰。有二谛。一世谛。二第一义谛。因世谛。得说第一义谛。若不因世谛。则不得说第一义谛。若不得第一义谛。则不得涅槃。若人不知二谛。则不知自利他利共利。如是若知世谛。则知第一义谛。知第一义谛。则知世谛。汝今闻说世谛。谓是第一义谛。是故堕在失处。诸佛因缘法名为甚深第一义。是因缘法无自性故我说是空。若诸法不从众缘生。则应各有定性五阴。不应有生灭相五阴。不生不灭即无无常。若无无常。则无苦圣谛。若无苦圣谛。则无因缘生法集圣谛。诸法若有定性。则无苦灭圣谛。何以故。性无变异故。若无苦灭圣谛。则无至苦灭道。是故若人不受空。则无四圣谛。若无四圣谛。则无得四圣谛。若无得四圣谛。则无知苦断集证灭修道。是事无故。则无四沙门果。无四沙门果故。则无得向者。若无得向者则无佛。破因缘法故则无法。以无果故则无僧。若无佛法僧。则无三宝。若无三宝。则坏世俗法。此则不然。是故一切法空。复次若诸法有定性。则无生无灭无罪无福。无罪福果报。世间常是一相。是故当知诸法无性。若谓诸法无自性从他性有者。是亦不然。何以故。若无自性。云何从他性有。因自性有他性故。又他性即亦是自性。何以故。他性即是他自性故。若自性不成。他性亦不成。若自性他性不成。离自性他性何处更有法。若有不成无亦不成。是故今推求无自性无他性。无有无无故。一切有为法空。有为法空故无为法亦空。有为无为尚空。何况我耶

    观因果门第九

复次一切法空。何以故。诸法自无性。亦不从余处来。如说

  果于众缘中　　毕竟不可得
  亦不余处来　　云何而有果

众缘若一一中。若和合中俱无果如先说。又是果不从余处来。若余处来者。则不从因缘生。亦无众缘和合功。若果众缘中无。亦不从余处来者。是即为空。果空故一切有为法空。有为法空故无为法亦空。有为无为尚空。何况我耶

    观作者门第十

复次一切法空。何以故。自作他作。共作无因作。不可得故。如说

  自作及他作　　共作无因作
  如是不可得　　是则无有苦

苦自作不然。何以故。若自作即自作其体。不得以是事即作是事。如识不能自识。指不能自触。是故不得言自作。他作亦不然。他何能作苦。问曰。众缘名为他。众缘作苦故。名为他作。云何言不从他作。答曰。若众缘名为他者。苦则是众缘作。是苦从众缘生。则是众缘性。若即是众缘性。云何名为他。如泥瓶泥不名为他。又如金钏金不名为他。苦亦如是。从众缘生故。众缘不得名为他。复次是众缘。亦不自性有故。不得自在。是故不得言从众缘生果。如中论中说

  果从众缘生　　是缘不自在
  若缘不自在　　云何缘生果

如是苦不得从他作。自作他作亦不然。有二过故。若说自作苦他作苦。则有自作他作过。是故共作苦亦不然。若苦无因生亦不然有无量过故。如经说。裸形迦叶问佛。苦自作耶。佛默然不答。世尊。若苦不自作者。是他作耶。佛亦不答。世尊若尔者。苦自作他作耶。佛亦不答。世尊。若尔者。苦无因无缘作耶。佛亦不答。如是四问。佛皆不答者。当知苦则是空。问曰。佛说是经。不说苦是空。随可度众生故作是说。是裸形迦叶谓人是苦因。有我者说。好丑皆神所作。神常清净无有苦恼。所知所解悉皆是神。神作好丑苦乐。还受种种身。以是邪见故问佛。苦自作耶。是故佛不答。苦实非是我作。若我是苦因。因我生苦。我即无常。何以故。若法是因及从因生法皆亦无常。若我无常。则罪福果报皆悉断灭。修梵行福报是亦应空若我是苦因则无解脱。何以故。我若作苦离苦无我。能作苦者以无身故。若无身而能作苦者。得解脱者亦应是苦。如是则无解脱。而实有解脱。是故苦自作不然。他作苦亦不然。离苦何有人而作苦与他。复次若他作苦者。则为是自在天作如此邪见问故。佛亦不答。而实不从自在天作。何以故。性相违故。如牛子还是牛。若万物从自在天生。皆应似自在天。是其子故。复次若自在天作众生者。不应以苦与子。是故不应言自在天作苦。问曰。众生从自在天生。苦乐亦从自在所生。以不识乐因故与其苦。答曰。若众生是自在天子者。唯应以乐遮苦。不应与苦。亦应但供养自在天则灭苦得乐。而实不尔。但自行苦乐因缘而自受报。非自在天作。复次彼若自在者。不应有所须。有所须自作不名自在。若无所须何用变化作万物如小儿戏。复次若自在作众生者。谁复作是自在。若自在自作则不然。如物不能自作。若更有作者。则不名自在。复次若自在是作者。则于作中无有障碍。念即能作。如自在经说。自在欲作万物。行诸苦行即生诸腹行虫。复行苦行生诸飞鸟。复行苦行生诸人天。若行苦行初生毒虫。次生飞鸟。后生人天。当知众生从业因缘生。不从苦行有。复次若自在作万物者。为住何处而作万物。是住处为是自在作。为是他作。若自在作者。为住何处作。若住余处作。余处复谁作。如是则无穷。若他作者则有二自在。是事不然。是故世间万物。非自在所作。复次若自在作者。何故苦行供养于他。欲令欢喜从求所愿。若苦行求他。当知不自在。复次若自在作万物。初作便定不应有变。马则常马人则常人。而今随业有变。当知非自在所作。复次若自在所作者即无罪福。善恶好丑皆从自在作故。而实有罪福。是故非自在所作。复次若众生从自在生者。皆应敬爱如子爱父。而实不尔。有憎有爱。是故当知非自在所作。复次若自在作者。何故不尽作乐人尽作苦人。而有苦者乐者。当知从憎爱生故不自在。不自在故非自在所作。复次若自在作者。众生皆不应有所作。而众生方便各有所作。是故当知非自在所作。复次若自在作者。善恶苦乐事不作而自来。如是坏世间法。持戒修梵行皆无所益。而实不尔。是故当知非自在所作。复次若福业因缘故于众生中大。余众生行福业者亦复应大。何以贵自在。若无因缘而自在者。一切众生亦应自在。而实不尔。当知非自在所作。若自在从他而得。则他复从他。如是则无穷。无穷则无因。如是等种种因缘。当知万物非自在生。亦无有自在。如是邪见问他作故。佛亦不答。共作亦不然。有二过故。众因缘和合生故。不从无因生。佛亦不答。是故此经。但破四种邪见。不说苦为空。答曰。佛虽如是说。从众因缘生苦。破四种邪见即是说空。说苦从众因缘生。即是说空义。何以故。若从众因缘生则无自性。无自性即是空。如苦空。当知有为无为及众生。一切皆空

    观三时门第十一

复次一切法空。何以故。因与有因法。前时后时一时生不可得故。如说

  若法先后共　　是皆不成者
  是法从因生　　云何当有成

先因后有因。是事不然。何以故。若先因后从因生者。先因时则无有因。与谁为因。若先有因后因者。无因时有因已成。何用因为。若因有因一时。是亦无因。如牛角一时生左右不相因。如是因非是果因。果非是因果。一时生故。是故三时因果皆不可得。问曰。汝破因果法。三时中亦不成。若先有破后有可破。则未有可破。是破破谁。若先有可破而后有破。可破已成。何用破为。若破可破一时。是亦无因。如牛角一时生左右不相因故。如是破不因可破。可破不因破。答曰。汝破可破中亦有是过。若诸法空则无破无可破。我今说空则成我所说。若我说破可破定有者。应作是难。我不说破可破定有故。不应作是难。问曰。眼见先时因如陶师作瓶。亦有后时因。如因弟子有师。如教化弟子已后时识知是弟子。亦有一时因。如灯与明。若说前时因后时因一时因不可得。是事不然。答曰。如陶师作瓶。是喻不然。何以故。若未有瓶。陶师与谁作因。如陶师一切前因皆不可得。后时因亦如是不可得。若未有弟子谁为是师。是故后时因亦不可得。若说一时因如灯明。是亦同疑因。灯明一时生云何相因。如是因缘空故。当知一切有为法无为法众生皆空

    观生门第十二

复次一切法空。何以故。生不生生时不可得故。今生已不生。不生亦不生。生时亦不生。如说

  生果则不生　　不生亦不生
  离是生不生　　生时亦不生

生名果起出。未生名未起未出未有。生时名始起未成。是中生果不生者。是生生已不生何以故。有无穷过故。作已更作故。若生生已生第二生。第二生生已生第三生。第三生生已生第四生。如初生生已有第二生。如是生则无穷。是事不然。是故生不生复次若谓生生已生所用生生是生不生而生。是事不然。何以故。初生不生而生。是则二种生。生已而生。不生而生故。汝先定说而今不定。如作已不应作。烧已不应烧。证已不应证。如是生已不应更生。是故生法不生不生法亦不生。何以故。不与生合故。又一切不生有生过故。若不生法生。则离生有生。是则不生。若离生有生则离作有作。离去有去。离食有食。如是则坏世俗法。是事不然。是故不生法不生。复次若不生法生。一切不生法皆应生。一切凡夫。未生阿耨多罗三藐三菩提皆应生。不坏法阿罗汉烦恼不生而生。兔马等角不生而生。是事不然。是故不应说不生而生。问曰。不生而生者。如有因缘和合时方．作者．方便．具足。是则不生而生。非一切不生而生。是故不应以一切不生而生为难。答曰。若法生时。方．作者．方便。众缘和合生。是中先定有不生。先无亦不生。又有无亦不生。是三种求生不可得如先说。是故不生法不生。生时亦不生。何以故。有生生过。不生而生过故。生时法生分不生如先说。未生分亦不生如前说。复次若离生有生时。则应生时生。而实离生无生时。是故生时亦不生复次若人说生时生。则有二生。一以生时为生。二以生时生。无有二法。云何言有二生。是故生时亦不生。复次未有生无生时。生于何处行。生若无行处则无生时生。是故生时亦不生。如是生不生生时皆不成。生法不成故无生住灭亦如是。生住灭不成故。则有为法亦不成。有为法不成故。无为法亦不成。有为无为法不成故。众生亦不成。是故当知。一切法无生。毕竟空寂故

十二门论一卷


顺中论义入大般若波罗蜜经初品法门

    No. 1565 [cf. Nos. 1564, 1566, 1567]

    顺中论义入大般若波罗蜜经初品法门翻译之记

诸国语言。中天音正。彼言那伽夷离淳那。此云龙胜。名味皆足。上世德人。言龙树者。片合一厢。未是全当。龙胜菩萨通法之师。依大般若。而造中论众典。于义包而不悉。大乘论师。名阿僧佉。解未解处。别为此部。魏尚书令仪同高公征国上宾瞿昙流支。在第供养。正通佛法。对释昙林。出斯义论。武定元年岁次癸亥八月十日挥辞丙寅凡有一万三千七百二十七字

顺中论义入大般若波罗蜜经初品法门卷上

        龙胜菩萨造　无著菩萨释

        元魏婆罗门瞿昙般若流支译

归命一切智

  不灭亦不生　　不断亦不常
  不一不异义　　不来亦不去
  佛已说因缘　　断诸戏论法
  故我稽首礼　　说法师中胜

如是论偈。是论根本。尽摄彼论我今更解。彼复有义。如是如是。如彼义说。如是如是。断诸众生喜乐取着如是如是。随义造论。无有次第

问曰。汝说此论。义无次第。或有次第。何意因缘。而说义论。如所依法。如是造论。答曰。此如是义。世尊已于大经中说言。憍尸迦。于未来世。若善男子。若善女人。随自意解。为他说此般若波罗蜜。彼人唯说相似般若波罗蜜。非说真实般若波罗蜜。帝释王言。世尊。何者是实般若波罗蜜。而言相似非实般若波罗蜜。佛言。憍尸迦。彼人当说色无常。乃至说识无常。如是说苦无我不寂静空无相无愿。如是乃至说一切智。彼如是人。不知方便。有所得故。如是应知。帝释王言。世尊。何者是实般若波罗蜜。佛言。憍尸迦。尚无有色。何处当有常与无常。如是乃至无一切智。何处复有常与无常。如是等故

又言。憍尸迦。若善男子。若善女人。如是教他修行般若波罗蜜。而说般若波罗蜜。作如是言。善男子。来修行般若波罗蜜。汝善男子。乃至无有少法可舍。汝心勿于少法中住。何以故。如是般若波罗蜜中。无有正法。若过法者。是则无法。于何处住。何以故。憍尸迦。如一切法自体性空。若其彼法自体空者。彼法无体。若无体者。是名般若波罗蜜。若是般若波罗蜜者。彼无少法可取可舍。若生若灭。若断若常。若一义。若异义。若来若去。此是真实般若波罗蜜。依彼因缘故造此论。我如是知般若波罗蜜。此方便故。我今解释。所谓入中论门。彼善男子。善女人言。我知色无常。乃至识无常苦无我等。以此因缘故。是相似般若波罗蜜。非是真实般若波罗蜜

问曰。若说色空无相无愿。云何此法唯是相似。非实般若波罗蜜耶。此三解脱世尊所说。非有为故。云何彼空亦相似耶。答曰。以取着故

问曰。取着何法。答曰。于色取着。于空取着。若有取着。云何得是般若波罗蜜。此取著者。岂非是见。一切诸见。皆因如来说空故断。又复何人即见彼空。彼人复以何法对治。唯无二际。是则能除。无二际故。名为非际。是故如来已为迦叶。如是说言。一切诸见。见空得出。若人取空。于空生见。我不能救。以此义故。师说偈言

  空对一切见　　是如来所说
  于空生见者　　彼则无对治

又复余师名罗睺罗跋陀罗言

  一切见对治　　如来说空是
  不爱空不着　　着空空亦物
  不爱空不空　　此二非不爱
  无能坏佛语　　佛语处处遍

又复经中佛说偈言

  夫人不正见　　少智故取空
  如捉蛇不坚　　如咒不善成

诸如是等。取着于色。取着色体。或分别空。分别不空。彼如是色。毕竟无物。云何当有空与不空。又如彼色。一切诸法皆亦如是。如佛世尊如是说言。如不异色。别更有空。亦不异空。别更有色。如色于空。空于色义。亦复如是。如是等故。又复经中佛言。迦叶。若有何人。见法不空。如是之人。法亦是空。空亦是法。又佛说言。所言空者。空自体空。所言色者。色自体空。若有少法而不空者。彼则有空。一切诸法皆无自体。何处当有空与不空。依此义故。有偈说言

  若法有不空　　空亦得言有
  无有法不空　　依何法说空

我依此知。以取着故。相似义成。问曰。若师如是。以此方便。解释般若波罗蜜义。以何义故。先造中论。名为造作。而非是经。答曰。若人愚痴。非是黠慧。彼人起心。如是分别。毁呰诸经。谓经不熟。唯论是实。余法无论。为彼人故。此有偈言

  伐烦恼怨尽　　救有救恶道
  如来有伐救　　此二余法无

此偈非唯直是根本。亦以赞叹供养如来。亦断一切戏论。分别诸取着等故说此偈。问曰。云何。答曰。有无量种供养如来。以如来有无量功德。今且略说三种供养。一者随法顺行供养。二者资财奉施供养。三者自身礼拜供养。此初随法顺行供养。供养中胜。以此偈法。供养如来。供养中胜。非物供养。问曰。此说何人供养如来。答曰。若人通达不生际者。又复有说言。须菩提于先礼我。论师如是。以此偈法供养如来。问曰。供养世尊。第一上吉。是故论初。应法供养。谓此偈法。如说能断一切取着。戏论等者。今应当说。答曰。汝听。我今为说。善意思念。言戏论者。所谓取著有得有物二。及不实取诸相等。是戏弄法。故名戏论。彼今略说。所谓取体。若取非体。取体非体。或取非体非非体等。此偈于彼一切皆断。问曰。云何皆断。答曰。偈言

  佛已说因缘　　断诸戏论法
  故我稽首礼　　说法师中胜

因缘生者。皆是戏论。问曰。因缘生者。云何戏论。答曰。因缘生者。世尊已于小乘中说。随顺次第得入法义。亦以对治外道取法。问曰。云何对治。答曰。外道恶见。彼有体见。有断常见。如是乐着一切世界。摩醯首罗。时节微尘胜。及自性断灭等。生如是分别。彼外道人。如是分别。则失因缘。彼人如是乐戏论故。名为恶见。此之戏论。是诸外道取着之法。为断此故。世尊已说。无明因缘而生于行。无明灭故。诸行灭等。以如是故。有世界生。以如是故。则世界灭。非余法故。如是生灭

问曰。摩醯首罗。时节微尘胜者。自性及断灭等。此等因缘。能生世界。灭世界者。此诸因缘。可是戏论。若因缘生。因缘灭者。云何戏论。答曰。以取着故。次第乃至取着涅槃。如来亦遮。何况不遮取着因缘。外道之人。取着体故。失于善道。行于恶道。戏论不实。问曰。云何。答曰摩醯首罗。若作世界。彼为是常。为是无常。为为他作。不为他作。彼为生已。而有所作。为是未生。而有所作为有而作。为无而作。彼如是等。皆悉不然。若作世界。为常而作。无常而作。为为他作。不为他作。为生不生。为有为无。如是一切。皆不相应。无道理故

问曰。云何名为无道理耶。答曰。若是常法云何而得造作世界。若是常法作世界者。虚空亦应得作世界。是事不可。若是无常作世界者。瓶等亦应造作世界。若常无常。作世界者。虚空与瓶皆应得作。是事不可。若汝意谓。常无常过。离常无常。更别有作作世界者。是则无穷作世界作。更复有作之所作故。此复有过。瓶亦应是作世界作。是事不可。若汝意谓。此是过者。则无作者而作世界。此义不成。问曰。云何不成。答曰。无众生故。若无作者。尚自非有。况复有作。如其无作。得有造作。是则无物。亦应得作。若其得作。兔角亦应作石女儿。又亦应作虚空花鬘。是事不可。亦可作瓶而皆不作

若已生者。当知不得造作世界。如瓶不作。若未生者。亦不得作。如石女儿。若是有者。不作世界。犹如其人。若是无者。不作世界。犹如兔角

此于世界常无常等。不相似过。又复如是摩醯首罗常无常等。若是世界之因缘者。世间罪福。亦是所作。是事不可。若如是者。一切罪福。则无果报。然今现见世间。罪福皆有果报。又复胜等。无物体故。不作世界。此义成就。先已广说。以无因缘。是故彼无。若丈夫作丈夫不成。自不成故。不能成法。若有丈夫。可有转行。如胜是常。无因缘故。胜无转行。以是常故。如丈夫觉。丈夫无觉。则常如胜。若如是者。一切诸法。皆悉是常。若无物者。何法为常。若无法常。云何分别流转行等。迦卑罗师。汝是弟子。云何有胜。有丈夫者。汝当说之。令义成就。尔乃于后常等法成

问曰。云何无胜。答曰。云何有胜。问曰。以阿含故。答曰。我今亦以阿含故无。问曰。以道理故。有胜成就。迭相摄故。答曰。何者道理。问曰。有胜以见次第有坏相故。如见树皮。知有树心。答曰。若如是者。是汝家中。私量所量。道理成就。实无此胜。见坏相故。犹如兔角。兔角是有见坏相故。如树皮等

若汝意谓。虽无面等。而是有者。不相类故。则知无胜。以不生故。如石女儿。若如虚空则不成就。若如涅槃。是则无物无体。云何成有不有。此我今说。汝虽有语。都无义理。如汝向者。见宗因喻。而有所说。皆不相应。此我今说。破汝胜法。有无量种。不可具说。略说少分。于汝法中。言丈夫者。此无众生。无因缘故。犹如兔角。如汝向者。言丈夫是世界因缘。已引喻者。世界因缘。今共筹量。若不能说缘具。则减缘具减故。是则有过。譬喻则减。汝则退坏一切诤对不成就者。无譬喻故。应先自观己之朋。已说自因相。若其是常。则非作者。若是无常。亦非作者。若为他作。亦非作者。不为他作。亦非作者。若体已生。亦非作者。若是未生。亦非作者。若其是有。亦非作者。若其是无。亦非作者。皆有譬喻。不能具说。当审思量。自朋有喻。他朋无喻。如是如是。摩醯首罗。时微尘等。世界因缘。则不成就。若此成就。作与所作。迭互相作。无如是事。若有此事。摩醯首罗。则能作胜胜。亦能作摩醯首罗。如是等故。如是外道。说作所作。迭互相违。皆不相应

问曰。如汝所说。缘具不成。是则有过。譬喻则减。复退坏者。此我今说。何等缘具。何者减相。若何等人。宗因喻等。三是缘具。彼如是人。则三种减。唯因譬喻。此二有过。以缘具故。宗则无减。以是言说之根本故。又义成故。此久已说有三种减。因喻二减。若人分别此之三分。具足和合故名缘具。彼如是人。应三种减。若复有人因三相语。则是缘具。彼人三种。云何有减。若缘具过。若譬喻减。云何彼人而当有减。若缘具过。汝未知故。作如是说。说喻减已。得缘具过。若复退坏。答曰。云何如是挝打虚空。若能舍离摩醯首罗之朋分已则可起心自谓黠慧尔乃摄取。若耶须摩之朋分也。汝此语言不能说于出世间法与世间法。复不相应。以其虚妄最凡鄙故。此如是故。则不须答。若耶须摩论师说言。此言语法。云何复离世谛之法。此我今说。以何者是。彼因三相。若何者法语为缘具。复以何者是因三相

问曰。朋中之法。相对朋无。复自朋成。如声无常。以造作故。因缘坏故。作已生故。如是等故。若法造作。皆是无常。譬如瓶等。声亦如是。作故无常。诸如是等。一切诸法。作故无常。答曰。何名作法。为作名作。离作名作。此今解释。若以作故。名为作者。声是作法。声皆是作。是故名作。若如是者。朋法不摄。则不得言。声是朋法。若汝意谓。有如是过。声与作异。声则非作。若法离作。不得言作。以如是故。知声非作。若声非作。是则无法。若无法者。云何言常。或言无常。若分别物。分别物法。云何作声。为有故作。为无故作。此今解释。有法不作。无亦不作。若法有无。亦不成作。若汝说言。声是作法。故无常者。是事不然。又如汝说三种相故。是名作法。因及因语。皆是缘具。则不相应。问曰。云何名为不相应耶。答曰。以不成故。一切作法无三种相。无朋对故。作朋之对。彼朋不作。是故相破。若不作者。是则无法。若无法者。云何破坏。如是两朋。非等非胜。非有作法。若无法坏。亦可说言。兔角破坏。以无体故。义不相应

若汝意谓。无常之朋。常朋相对。如是随起。此我今说。汝甚愚痴。以不成法。而欲成法。此无常者。名为无物。若无物者。则无自朋。自朋不成。不得随起。不得回转。若如是者。不得言朋。如虚空等。以无物故。若汝说言。他朋常者。是义不然。问曰。云何不然。答曰常不成故。如此常者。为是有物。为是无物。若是有物。瓶则是常。以有物故。若常无物。兔角应常。以无物故。是故不得言常无常。若汝说言。作法随自朋不离。是义不然。以其自朋不成就故。问曰。云何不成。答曰。此说不成与朋相似。得言相似。以相似故。有自他朋。而汝朋者。则不相应。以所成法。未成就故

问曰。云何名为所成未成。答曰。以所成法是无常故。无常无物。如其无物。何处相似。何者相似。谓瓶无常亦相似生。若如是说。所成之法。有异相似。得言相似。以相似故。有自他朋。此所成法。若有二种得言相似。瓶与无常。有二种法。得言相似。无二种法故不相似。彼所成法。若未生者。何名无常。云何名为所成成就。云何无常所成成就。问曰。云何名为所成不成。答曰。然此所成。或时是声。或是无常。或声无常。若合或和。此等一切皆不可成。若不可成。为于何处有所成法。若分别物。分别物法。若有相似

若汝意谓。离声无常二种法。外更摄余物。名所成者。是义不然。物不成故彼何者物。离声等二。于何处摄。而得言物。彼若是声。彼则不得名为所成。以成就故。若是无常。彼无法故。所成不成。声不能破。若是合者。是亦不然。物与无物。不可得合。是故不合。和亦如是。而不可得

若复意谓。声异所成。是义不然。无常与声。不别异故。不异成故。若汝说言。有朋法作。是义不然。离朋有法。义不成就。于佛法中。离物以外。更无物法。问曰。缘具所成。此二相对。名物物法。答曰。缘具所成。二皆不成。离作物外。更无作法。如是作法。与朋不离。若作离朋。朋则非作。唯作是法。离作无法。不离于声。而有作法是故偈言

  生作唯相貌　　作者亦如是
  一切生不实　　生法如兔角

如是作法。非有故有。非无故有。亦复非是有无故有。如是思量。作法三相。义不相应。作法无物语于何处得为缘具。若三种减。若缘具过

又复语言。于三种相。则不相应。语所说法。皆空无故。无自相故。句之与语。非一非异。离字无句。非一非异。字微尘成。因微尘有。然彼微尘。无分可得。以无分故。微尘自无。不能有成。若起若灭

问曰。如汝所言。所说法空。以法空故。语三种相。皆不成者。是义不然。所说有故。此语所说有可得故。因缘坏等。云何而言。所说法空。遮三种相。答曰。因缘破坏。义不相应。不成就故。声因缘坏。云何相应。以念念故。以不住故。既是无物。何处得有。因缘破坏。以不生故。犹如兔角。若复无常。此语三相。若常无常。二不相应。如虚空无。又亦如瓶。无有因缘。如是因缘。一切皆无。有二过故。此等一切。悉皆如是。邪法所摄。皆是戏论。破外道故。佛说因缘

问曰。若如是者。云何因缘。得言戏论。如来世尊以诸因缘是实故说。佛如是说。此无明等。是大苦聚。和合而生。若无明灭。大苦聚灭。如来世尊说苦圣谛。或说苦灭。若是实者。云何戏论。答曰。贤面当听。此今略说。何名无明。以不能知四颠倒故。说名无明。云何名实。又言。苦是苦圣谛者。如来世尊不如是说。如胜思惟梵天问经。佛言。梵天。若彼苦是实圣谛者。一切牛猪。诸畜生等。应有实谛。何以故。以彼皆受种种苦故。又言。梵天。若彼集是实圣谛者。六道众生。应有实谛何以故。以彼因集生诸趣故。又言。梵天。若彼灭是实圣谛者。一切世间堕邪断见说灭法者。应有圣谛。何以故。彼说灭法为涅槃故。又言。梵天。若彼道是实圣谛者。缘于一切有为道者。应有实谛。何以故。以彼依有为法。求离有为法故。以是故知。苦非实谛。又复说言。知苦无生。是名苦实圣谛。是故如来经说偈言

  一谛名不生　　有人说四谛
  道场不见一　　何况复有四
  如是未来世　　常有诸比丘
  恶意出家已　　如是坏我法

是故得知一切诸法悉皆不生。通达知者。是实圣谛。是故如来复有说言。须菩提。乃至无有微尘等法故名不生。彼何法知而得。名为知不生法。若无生忍而得。名为无生法忍。以是故知。苦等四法。非四圣谛。若如彼人之所分别。则非是智。若有能知不生不灭。乃得言谛。乃得言智。此如是义。圣须菩提问如来言

  为苦是涅槃　　苦智是涅槃
  为集是涅槃　　集智是涅槃
  为灭是涅槃　　灭智是涅槃
  为道是涅槃　　道智是涅槃
  佛言须菩提　　苦非是涅槃
  苦智非涅槃　　苦集非涅槃
  集智非涅槃　　苦灭非涅槃
  灭智非涅槃　　道非是涅槃
  道智非涅槃　　又复须菩提
  四圣谛平等　　我说是涅槃
  如是涅槃者　　非苦非苦智
  如是次第至　　非道非道智
  时圣须菩提　　白佛言世尊
  复以何者是　　四圣谛平等
  佛言须菩提　　所言平等者
  随在于何处　　非苦非苦智
  如是次第至　　非道非道智
  若彼一切法　　一切法真如
  不虚妄真如　　如是法住等
  我说彼涅槃　　而非是苦等
  一切法不生　　以无自体故
  如是说能知　　一切法不生
  是名实圣谛

问曰。若如是者。以何义故。如来经中说四圣谛。答曰。此为次第随顺入故。佛如是说。非第一义。或实或妄语。是故世尊说言。梵天言实圣谛。实圣谛者。何处无实无妄语等。以是义故。四颠倒起。此智非实。如是苦谛。实不成就。我义成就

问曰。我则不说非智为实。我说非智觉故名实。云何而说。于无常法谓是常法故名非智。于苦谓乐故名非智。无我谓我故名非智。不净谓净故名非智。如是等者。皆非是智。若于无常。能知无常。于苦知苦。于无我法。能知无我。于不净法。能知不净。如是知者。彼得言智。彼得言实。如是我说智名为实。非无智实。答曰。此痴臭气风来薰我以戏论故。此痴最大乐着智故。问曰。云何。答曰。偈言

  若其有无常　　可得言有常
  既无少无常　　何处当有常
  若其少有苦　　可得言有乐
  既无微少苦　　何处当有乐
  若少有无我　　可得言有我
  既无有无我　　何处当有我
  若有不寂静　　可得有寂静
  既无不寂静　　何处有寂静

而于色体。贪取着已。或分别常。分别无常。色自体空。毕竟无物。何处有常。及有无常。如是等类。如色如是。至一切法。皆此因缘。成就戏论。然此因缘。亦是戏论。非唯因缘。如是戏论。乃至取佛。亦是戏论

问曰。云何。答曰。善男子。听汝勿憍慢。佛智难解。世尊偈言

  持心如金刚　　深信佛智慧
  知心地无我　　能闻微细智

今汝善意生。金刚心善。面汝今听说戏论不戏论相

问曰。云何。答曰。此如是义。佛大经中。觉菩萨故言。须菩提。非体不觉非体。须菩提言。世尊。云何体能觉非体耶。佛言。不尔。须菩提。须菩提言。世尊。云何非体能觉体耶。佛言。不尔。须菩提。须菩提言。世尊。云何体能觉体耶。佛言。不尔。须菩提。须菩提言。世尊。云何非体能觉非体耶。佛言。不尔。须菩提。须菩提言。世尊。云何一切法不可得耶。不可觉耶。不可证耶。若体不觉非体。非体不觉体。体不觉体非体不觉非体。此当无耶。佛言。有觉有得。非此四句法。须菩提言。世尊。云何觉。佛言。须菩提。非体非非体。彼如是觉。何处无戏论。彼如是觉。非戏论。非戏论法。彼如是觉。慧命须菩提白佛言。世尊。菩萨摩诃萨。何者戏论。佛言。须菩提。色常无常者。菩萨摩诃萨戏论。须菩提。受想行识常无常者。菩萨摩诃萨戏论。若知色。若不知色者。菩萨摩诃萨戏论。如是知受想行识。不知受想行识者。菩萨摩诃萨戏论。知苦圣谛者戏论。断集者戏论。证灭者戏论。修道者戏论。修行四禅者戏论。修行四无量。四无色。三摩跋提。四念处。四正勤。四如意足。五根。五力。七觉分。八圣道者戏论。修行空解脱门。无相无愿解脱门者戏论。修行八解脱。九次第。随顺行。三摩跋提者戏论。得须陀洹果。斯陀含果。阿那含果。阿罗汉果。辟支佛道者戏论。我得缘觉菩提者戏论。我具足满十菩萨地者戏论。我得菩萨行者戏论。我教化众生。令成就者戏论。我生如来十力者戏论。我得四无所畏。四无碍智。十八不共法满足者戏论。我得一切具足者戏论。我断一切结习者戏论。彼菩萨摩诃萨修行般若波罗蜜。已知色若常无常戏论。不应如是戏论。菩萨如是不戏论乃至我得一切智者戏论。不应如是戏论。如是不戏论。何以故。自体自体不戏论。非自体非自体不戏论。自体非自体不戏论。非自体自体不戏论。更无有法可以戏论。何处戏论。谁为戏论何者戏论。云何戏论。是故须菩提。色不戏论。乃至识不戏论。略说乃至菩提不戏论。如是须菩提。菩萨摩诃萨如是不戏论。应如是修行般若波罗蜜须菩提言。世尊。云何色不戏论。乃至识不戏论。略说乃至菩提不戏论。佛告慧命须菩提言。须菩提。色无自体。乃至识无自体。略说乃至一切智无自体。彼不戏论。须菩提。如是因缘色不戏论。乃至识不戏论。乃至一切智不戏论。如是菩萨摩诃萨修行般若波罗蜜。成菩萨法。汝今善意。知此戏论不戏论相。偈言

  佛已说因缘　　断诸戏论法
  故我稽首礼　　说法师中胜

此偈成就四种所得。戏论则断

顺中论义入大般若波罗蜜经初品法门卷上顺中论义入大般若波罗蜜经初品法门卷下

        龙胜菩萨造　无著菩萨释

        元魏婆罗门瞿昙般若流支译

问曰。阿阇梨意。为何义故。而造此论。答曰。依顺道理。入大般若波罗蜜义。为令众生舍诸戏论取着等故。既舍离已。依顺道理。速入般若波罗蜜故。既依道理。速入般若波罗蜜已。舍诸戏论一切取着。舍诸戏论取着等已。速疾成就无上正觉。为此义故。师造此论

问曰。此无因缘。而作是说。答曰。此因缘者第一因缘。谓令众生依顺道理。入于般若波罗蜜已。速成正觉。问曰。若如是者。何者般若波罗蜜耶。答曰。岂可不作如是说言

  不灭亦不生　　不断亦不常
  不一不异义　　不来亦不去

此如是偈。是修多罗道理。阿含如次第释。今释偈句。非灭不灭。非生不生。应知。诸句皆如是说

问曰。以何义故不如是言。此法非灭故名不灭。此法非生故名不生。或可说言。此法无灭故名不灭。此法无生故名不生。如是等耶。答曰。如是之义。以于阿含道理有妨。是故不得作如是说。问曰。云何有妨。答曰。何法无灭。何法无生。问曰。第一义谛。答曰。若如是者。有二种谛。所谓世谛。第一义谛。若有二谛。汝朋则成。问曰。若异世谛。有第一义谛。成我朋分。为有何过。如说偈言

  如来说法时　　依二谛而说
  谓一是世谛　　二第一义谛
  若不知此理　　二谛两种实
  彼于佛深法　　则不知实谛

答曰。汝快善说。我说亦尔。依于二谛如来说法。依二谛说。说法真如。不破不二。若其二者。异第一义。法真如别。有世谛法。真如一法。真如尚不可得。何处当有二法真如。而可得也。若说二谛。此如是说。不异世谛。而更别有第一义谛。以一相故。谓无相故。此如是义。师偈说言

  若人不知此　　二谛之义者
  彼于佛深法　　则不知真实

问曰。此云何谛。答曰。若此不破。问曰。此之二谛何物不破。答曰。一相。所谓无相。无自体。如本性空。如此则是谛。如有偈中说谛相言

  二种法皆无　　戏论不戏论
  不分别不异　　此义是谛相

若如此偈。云何如来依二谛说。一切如来皆无所依。不依世谛。亦复不依第一义谛。如来说法。心无所依。何用多语。但说所论。旧所谛者。如前所说。第一义谛。若灭若生。二皆无者。此则应说。云何名为第一义谛。问曰。涅槃是常。彼涅槃处。无生无灭。若如是者。一切外道朋皆成就。彼外道人。岂可不作如是说言。我涅槃常。寂静不动不变不坏。有法有物。彼涅槃中。无灭无生。此等皆是外道之人分别涅槃。取着涅槃。此不相应常我胜者。外道所说常我胜者。以无体故。答曰。云何汝涅槃者。何者涅槃。而涅槃中无生无灭

问曰。贪欲嗔痴及阴等。尽更不复生。是名涅槃。答曰。此名尽者。谓失无体灭故名尽。彼灭云何。可于灭中复有灭耶。或于体中有无体耶。何故遮我汝此语者。为依何物以为境界。而说此语。为体境界非体境界。为体非体二种境界。一切诸法皆不如是。以相违故。若不生者。是则无体。彼义云何。于彼不生无体之中。为有生不而汝遮我此不生中则无有生。依如道理阿含义故。汝难不退。涅槃空故。以异涅槃更无法故。如是成就

有如是说。何者名为第一义空。彼处说言。第一义谛。名为涅槃。彼涅槃者。涅槃亦空。复有经中说言。世尊。言涅槃者。名为寂静。无一切相。无一切念。复有说言。此涅槃者涅槃所谓体非体空。如是等说

如是一切种种思量。第一义谛体不可得。是故不得遮生遮灭。若汝意谓。第一义谛微少有体。而可说者。即是我证。汝今何用思量此处。又如经说。我今说之。如来说言。文殊师利如所说法。无如是法。如是不说。亦如是无。亦不可得。问曰。如是说者。云何而避。答曰。若无少法无体聚物。若或可说。若不可说。一切皆无。如是名避。舍此二谛所摄诤对

问曰。言谁语义为有何过。答曰。若如是说。则于道理阿含有妨。问曰。云何道理阿含有妨。答曰。如先圣者须菩提言。何时世尊本为菩萨摩诃萨时。修行般若波罗蜜故。正观此法。彼时正观色不生。乃至正观一切智不生。正观凡夫不生。乃至正观佛不生。而汝意谓。此谁语义。别有法者。则不相应。又舍利弗不如是说。如慧命须菩提所说语义。我如是知色不生。乃至一切智不生。凡夫不生。乃至佛不生耶。如是阿含有妨碍故。是谁语义。则不相应

若汝复谓是谁语义。虽不离法。而说言离。譬如乳渧。水渧像身。磨物石身。第一义谛亦复如是。言谁语义。此我今释。此不相应。此乳等体。则是有体。汝取体已。渧等法外。更异法遮。汝今云何第一义谛可有体耶。若有体者。此灭生等。则可遮言。不离法有。是故汝义。则不相应。为有何法。非灭非生。问曰第一义谛。答曰。彼是何法。问曰。涅槃。答曰。彼复何物。问曰。烦恼阴尽则名为灭。亦名无体。如是我说名为涅槃是我意解。答曰。若如是者。断灭之法。亦是涅槃。若彼先生烦恼业阴。后时尽灭。尽灭无体。亦是涅槃。未来未生亦是涅槃。如是涅槃。直是断灭。若如是者。断灭之法。则是涅槃义。可成就。未来是无。此既未至。云何相应。以是义故。汝应可羞放舍。如是摄取涅槃。问曰。汝涅槃。涅槃何类。答曰。经中可不如是说言。一切诸法。无始来灭。本性不生。无自体耶

又复经中说言。世尊。若有沙门。诸法本性寂灭相中。求涅槃体。我说彼人。名为外道。如是等耶。又复经中有说偈言

  无始寂不生　　本来自性灭
  而转法轮时　　世尊开显法

又阿阇梨复说偈言

  不寂静不得　　不断亦不常
  不灭亦不生　　如是名涅槃

如是思量道理阿含。第一义谛。有物不成。以是义故。先说道理。非灭不灭。非生不生。如是一切如是。则为不二义成。此如是说。不生是色。不异不生别更有色。色是不生。不异于色别有不生。乃至一切智。乃至佛如是尽灭。则不异色。乃至一切智。乃至佛此如是说。若尽若色。若复不二。此一切法非合非离乃至一切智。乃至佛者此义成就。此语太烦。可舍不须。第一义谛。言说甚多。如是知已。可舍此语。不须更论修多罗义。我今解释。或依道理。或以阿含。彼阿含者。何者阿含。所谓一切大乘经典。一切大乘修多罗中。皆说如是不灭等句。然于般若波罗蜜中。说此处多。此是阿含。今说道理。问曰。云何道理阿含。此如是偈。如经意释。答曰。汝清净心。至心善听。我今解释。此之灭名。于体上有。非无体有。如是生。如是断。如是常。如是等。彼如是体。种种思量。皆不可成。问曰。彼体云何不成。答曰。以因缘故。若何等法。有因缘者。彼无自体。若无自体。彼法无体。此无体者。无自体故。譬如兔角。以无因缘。是故无法。此一切法。皆无自体。以因缘故。如幻如梦

若汝意谓。彼实有体。有自体者。云何知有。因缘生故。犹如瓶者。此我今释。如是因缘。分别无义。若法自体。何用因缘。先自有故。若无自体。何用因缘。以无法故。以是义故。分别因缘。则无义理。若说体者。应如是知。彼无体者。无自体故。是故如来如是说言。须菩提。一切和合。皆无自体。以因缘故。一切和合。和合皆空如是一切。体不成就。问曰。云何灭等而不成就。答曰。体灭异体。彼体不生故不成就。问曰。云何不生而得有体。答曰。无自体故。若何者法。无自体者。彼法无生。则如兔角。自体无体。问曰。彼云何无。答曰以因缘故。若言有体。无因缘者。无如是法

若汝意谓。空数缘灭。非数缘灭。如是等法。非有因缘。而有不无。是义不然。问曰。云何不然。答曰。如是灭者。汝岂可不作是思惟。彼灭云何。为有为无。又复何者空等无为。既非是生。云何为有。若是有者。兔角亦有。是义不可。问曰。若何等法。自体无者。彼生则无。云何而言。彼复无灭。答曰。汝心憍慢。自谓。数数被破。自爱己朋。摄灭不舍。我于向者。可不说言。以不生故。若不生者。灭云何成。若不灭者。而复云何得成不生。不生法中。非唯无灭。亦复无断。如是若常。若一若异。若来若去。此等一切于不生中。皆不成就。如说偈言

  于不生体中　　则无灭可得
  不灭则不生　　皆不可成就

如是二法。则无前后。谓法先生。后时灭二。或亦先灭。后时生二。问曰。云何无耶。答曰。以有为法无无始故。又一切法悉皆空故。问曰。若人有为无无始者。则无此过。我则不尔。有为有始。摩醯首罗。时微尘等。有为因缘。有无始故。是故何人有为无始。则无此过。或先生已。于后时灭。或先灭已。后时乃生无决定故。有为无始。非此决定。则非我义。我则不尔。有为有始。摩醯首罗。时微尘等。有为因缘。有无始故。又毗耶婆如是说言。生者必死。死者必生。如是等故。答曰。汝既倒已方始作势。此我于先。可不已遮。摩醯首罗时微尘等。非因缘耶。若非因缘。云何成始。又复汝引。摩醯首罗时微尘等。为有因缘。为无因缘。若更有者。是则有为无始义成。若更无者。摩醯首罗时微尘等。非有为始。以非因故。犹如兔角。一切法体。皆无因缘。是义不成。若是何人。摄受此意。有为无始。彼如是人。则得见过。以其说言有为有始。有为无始。是故名见

问曰。汝唯如是。与他朋过。不住自朋。答曰。若说体者。得如是过。过不在我。又我如是自体空中。一切法中。我无分别有为之法有。何者始。何者无始有。何者终。何者无终。如是等也。如阿阇梨所说偈言

  一切体中空　　何者终不终
  终者是何终　　非终非何终

如是思量。灭生二种。次第相对。如父子者。义不相应。则无此灭。问曰。云何无耶。答曰。思量此灭。如是灭法。或在前有。或后时有。或二时有。或一或异。若或二者。一切不成。又复灭者。灭名无体。失尽非常。诸如是等。若无体者。彼复云何。成有成无

若汝意谓。体亦是灭。非是非体。如是体者。云何灭体。而复可坏。如瓶可灭。以有体故。若无生者。何处有体。或得有灭。或有或无。如是如来有偈说言

  何人不取生　　彼人无物灭
  彼不著有无　　不取世界物

此灭如是。云何成有。若成就无。又此灭者。灭名无常。于汝法中。无常三种。一者念念坏灭无常。二者和合离散无常。三者竟毕如是无常。此如是等三种无常。有无所摄。世尊皆遮。问曰。云何皆遮。答曰。世尊说言。须菩提。若有体者。可得言尽。复有说言。无常之物。则为不实。非生灭相。若体有灭。无常不成。如是灭义若依道理。阿含思量。皆不成就。是故于灭不应摄取。问曰此义云何。为唯遮灭。若有若无。为复遮余一切法体。答曰。取一切体。若有若无。此取皆遮。非唯遮灭。问曰。何义故遮。答曰。断过过故。师如是说。所谓偈言

  若取有着常　　无则堕断见
  是故黠慧者　　不依止有无

又复有说。所谓偈言

  若人见于有　　或见无是痴
  彼不知修行　　寂静安隐处

又复有说言。迦旃延。有则堕常。无则堕断。又复经中说言。迦叶。有是一边。无是一边。中者非有。亦非是无。以无体故。此义应知。无自体故。一切体有。一切体无。义皆不然。此如是义。如世尊说言。须菩提。于体自体一切法中。若有若无。义皆不然。须菩提言。实尔。世尊。如是处处。摄一切体。若有若无。一切皆遮。以无体故。以不生故。有无皆无。亦无有灭

问曰。如是如是。于一切法不生法中。无有灭者。如一切法不生之义。汝今应说。此义云何。复无断耶。答曰。此断名者。则于体有。非于无体。彼体不成。问曰。云何不成。答曰。自体他体。悉皆无体。以无体故。犹如兔角。非有自体。非有他体。非体不体。以不生故。如是一切体不生者。此义则成。如阿阇梨所说偈言

  或自体他体　　或体或无体
  如是见不见　　佛法第一义

是故无体。则亦无断。又复如是。常断之相。是有所摄。或非有摄。如是二种。世尊皆遮。问曰。此何故遮。答曰。佛为教成迦旃延故。有无皆遮。世尊。真知体非体者。是故无断。又此若有本性成者。云何得言无法无物。或复言异。或言无体。此若有法。可断可灭可失等者。可得名断。然彼有法本性自无。云何不失。而或言断。如说偈言

  若法本性有　　此可得言无
  若言本性异　　此义不可得
  以本性无故　　变异不可得
  若本性有者　　可得言变异

又复此中。前言有体。言有体已。后时言无。常断过成。如偈说言

  若有自体者　　非无而亦常
  先有后时无　　则成就断见

此摄断常二种过失。故如是遮。若说体者。成断常过。以依如是道理阿含。思量彼断。则不可成。彼如是断则不成就。问曰。云何不成。答曰。以无因故。以不灭故。所谓断者。名灭无体。无体无因。若或无灭。犹如兔角。若法有体。可得言因。可得言灭。其犹如瓶。师如是说。所谓偈言

  法有因有灭　　彼可见如芽
  灭中无灭者　　是故无灭因

此无因故。则知是无。复不灭故。汝心如是。欲求真实。不应着断

问曰。我今已解。受此无断。若摄此断。一切恶中。最为鄙恶云何不常。答曰。我上岂可不说不生。若不生者。云何有常。若不生常。兔角亦常。是则不可。故非有常。世尊说言。若法不生。不得言常。亦复非断。是故常断二皆不成。以堕边故。若汝意谓。虚空我等。不生而有。亦得是常。如说有法。无有因缘而实是常。以是义故。虚空我等。常则成者。是义不然。何用思惟。石女之子。或黑或白。虚空等无。而汝思惟。是常亦尔。问曰。彼虚空等。云何无物。答曰。空等毕竟物不可得。犹如兔角。毕竟如是。六根各各皆不能得。如是空等。亦不可得。是故知无。以是无故。虚空等常。义则不成。又不生故。无义则成。如汝意谓。是有法者。若当未有法不成。有法不成。以不生故。无自体故。若有体者。以自体故。彼是有故。不须和合。以是有故。若无自体。无自体中。则无有法。以无物故。犹如兔角。如偈说言

  体无自体故　　是则无有法
  此因缘此生　　此义不如是

若汝意谓。虚空是有。以有相者。彼相亦无。无初无后。亦无二故。复有不生。若不生法。而有相者。兔角应有。长短等相。此义不然

若汝意谓。我相可得。彼相六识所不取故。相不可得。若汝意谓。相现见者。则失自法。以根得故。若如是者。汝所立我是无常等。若汝意谓。非根境界。相则不摄

问曰。虽如是破而实有。我一句说故。此若一句。摄两字说。则知彼有。犹如澡灌。我亦如是两两字说故。则知有我(此一我字翻彼二字)。答曰。此语不成。一厢语故。如彼虚空。亦如梦等(此一梦字翻彼二字)。我亦如是。是故无我。如彼虚空。又亦如梦。此等一切二字所说。皆悉是无。我亦如是。是故无我。又复无我。以其作故。若物是作。则知无我。犹如彼瓶。如是身作。故身无我。以是作故

若汝意谓。以于身中见命等相。知有我者。命等相中。无常无常。如是思量。常则不成。若汝意谓。我实不说有法是常。亦复不说。无法为断。更复有法。于三世转。不灭名常。若无法者。不得有义。是故我言有法是常。若无法者。则为是断。汝是意。我今解释。若有法者。是则得言三世流转。常法定住。不动不变。云何而得三世流转。若流转者。则是无常。问曰。云何无常。答曰。若过去者。云何是常。若过去者。则是无常。云何过去。过去名失。名尽名灭。名为无体。彼云何常。若其无体。云何过去。若有物体。云何过去。若其有者。石女之子。亦应是常。以无体故

又若过去。常义不成。未来世常。义亦不成。问曰。云何不成。答曰。此未来者。名为无体。名为不生。名为不出。彼若如是。云何为常。若其常者。兔角亦常。此义不可。若谓有物。云何未来。若或是常。若或未来。义不相应

又现在常。义亦不成。问曰。云何不成。答曰。此现在者。现法流转故。名现在。彼现在法。一念不住。若一念住。一劫亦住。而此住相。实不可得。以无住故。念亦是无。若念转者。云何是常。若不生者。何有现在。未来过去。时节成就。时无体故。若有体者。是则过去。未来现在。则不是时。若是时者。过去未来。现在非体。时或与体。若一若异。义皆不成。又时与体。有尚不成。何况过去。未来现在。或复是常。若有体常。体自不成。体不成故。云何成常。是故常无。如汝意谓。如其无物。则非法者。此最不成。汝何意故谓无物者。则非是法。若以无物。则非法者。是则有法。亦非是法。以无与有。共相对故。以无法无。有法亦无。以彼无法不成就故。如其无法不成法者。云何有法而得成法。云何有法名为有法

若汝意谓。此有法者。更有因缘。有此有法。则有法与彼无法。则不相对。此今解释。若汝分别此有法者。更有有法。二有平等相似相对。不同无者。此之有法更有有法。更无有法。此我今释。若彼有法。更有有法。是则无穷。若汝意谓。从于无法。而有有法。是则无因。而有法生。是则有法。义不成就。如是无法。而有法生。无信乐者。如是有无。汝舍勿摄

又有法明相对明示彼有法者。若其有体。得言有法。若无体者。是则不得名为有法。彼体不成。体若不成。云何而得。成有成无。汝可舍此。有无分别。何用此为

复有义释。如是灭生断常等法。其义云何。为一物中一时而有。为当前后。此我今释。不相应法。云何一处互相违故。灭等相违。不得同处。于一物中。云何不坏

若汝意谓。于一念中。有灭有生。有断常等。则不相应。若汝复谓。于一物中。非一念转异异念中差别转者。则不相应。问曰。云何名为不相应耶。答曰。若如是者。更异法灭。更异法生。更异法断。更异法常。如是等故。此一物中。云何别异。若汝意欲避如是过。异物异灭。物外异生。异断异常。如是等者。此则不成。问曰。云何不成。答曰。若如是者则。于一物。亦得言有。亦得言无无此道理。是故一异。义则不成。非唯灭等。一异不成。复何者。法若有灭等。彼共灭等。一异不成。问曰。云何为唯灭等。一异不成。为一切法一异不成。答曰。一切诸法皆亦如是。一异不成。如偈句言。亦非一义。非异义故。问曰。云何一切诸法一异不成。答曰。以不生故。如石女儿。若法生者。一异义成。若一切法皆不生者。一异之义。云何可成。如石女儿。本自不生。无自体故。又无自体。以因缘故。因缘法者。无法可得。若因缘者。则非是生。经中说故。此一异义。则不成就

问曰。云何因缘名为不生。若不生者。云何而说名为因缘。若因缘者。云何不生。若不生者。云何因缘。如其因缘。名不生者。义不相应。答曰。此不相应。若说因缘。则不相应。若体是有。云何因缘。以先有故。如其无者。则是无法。云何因缘。以无法故。如其无法。有因缘者。是则兔角亦须因缘。因者无体。以无物故。如虚空花。是故此义道理则成。思惟因缘。则是不生。何者因缘

问曰。因缘二种。一内。二外。内者。所谓无明缘行。乃至老死。外因缘者。所谓一切器世间中。种子芽等。答曰。此如是法。今共筹量。若汝分别此无明等十二诸分。因缘法者。如汝所说。此十二分。为如车分。于车为分。名为因缘。为此十二而共和合。名为因缘。为一一分。自是因缘。为二二分二分因缘。为当于此一切分外。更有因缘。为唯相貌。此一切法。如是思量。皆不相应。问曰。云何名为不相应耶。答曰。以念念故。若唯是一。则无因缘。问曰。云何是一。则无因缘。答曰。若如是者。唯一无明。得为因缘。余非因缘。又复二者。亦非因缘。以灭与生。二不俱故。如生不生。则不和合。分别车分。亦不相应。因缘和合。不可得故。现见车分。于一时中。有法和合。无明等分。于一时中。不见有法。如是因缘。说名因缘。如车分车。无明等分。则不如是。灭生生灭。法无和合。若无和合。为说何法。若无所说。云何说法。所有言说。是法相貌。云何相貌。可得言有。如阿阇梨提婆偈言

  一法名无体　　以无和合故
  若一无体者　　是则无和合

若离诸分。更别有法。则非因缘。以不生故。如是因缘不生义成。如佛说言。言因缘者。因缘则空。是故应舍因缘之义。不应摄受。如是思量。一义异义。二皆不成。又见一已。取异相对。既见异故。取一相对。相对不成。如偈说言

  异异因缘外　　更无有法生
  不异因缘外　　则无法可得
  异异更无异　　不异异亦无
  如其异无者　　异更不可得

如是一异。应舍勿摄。如是舍已。知本性空。心念彼空。何用摄受。虚妄不实。问曰。如是如是。一切诸法本性自空。此第一义。是真是实。我今始解。如来实语。如世尊说。一切诸法本性自空。无自体故。此复云何。世间之人。一切现见去来不成。答曰。以阿含故。问曰。何者阿含。答曰。此如是义。于大经中。如来说言。须菩提。一切诸法去来行空。彼人不觉。取着不舍。而彼空法。不去不来。无有一法。而不空者。又复说言。一切诸法悉不来者。此是阿含。又道理故。若法不生。则无去来。犹如兔角。此义成就。又偈说言

  已去则不去　　未去亦不去
  离已去未去　　现去则非去

此复广说。何者为去。何法是去。去者是谁。若是我去。以无我故。去义不成。汝法我常。不动不摇。云何能去。若我能去。虚空亦去。而此虚空。实无去法。我者不能从于此方而到彼方。无离无合。汝所立我。遍一切处。则无去处。自在秉执。遍一切故。以是义故。我则不去。若汝意谓。以身随心。是故有行。此义不然。以其有常无常过故。又以有分无分过故。又以有色无色过故。心非作故。身不随行。行不可得。心身有无。常不成就。云何此方行到彼方。如迦卑逻弟子意谓由胜因缘丈夫流转。如是名行。丈夫作已回故名还。是故由胜得有去来。此我解释。汝今乃以虚空之华。作欢喜丸。与石女儿。令使食之。汝胜是无。而汝意谓。由胜力故。丈夫去来。胜虽是常。而能令使丈夫去来。义亦如是。如汝意解。如丈夫行。则非是作。亦不成就有所行法。若村城等。此先已遮。以不生故

又复更有说有为者。彼则无去无动摇故。行是相貌。如是相貌。非有为体。如是皆说。一切有为念念无常。如是不住。云何有行。是故偈言。有生得言行。亦得言作者。如是故知。有为之法。虽生虽行。如是生者。于先已遮。复有偈言

  有为无来处　　念念不住故
  又亦无去处　　如是故无住

如是有为行至异处。则无此理。无行作故。如是有为有尚不成。况有行去。若到已还。自体空故

若汝意谓。阴有行去。有为不摄。此义不然。阴不成故。问曰。云何不成。答曰。因缘空故。此义云何。犹如兔角。毕竟如是。无有因缘。色等诸阴。亦复如是。因缘毕竟。不可得也。此如是知因缘空故。色等阴无。如阿阇梨所说偈言

  离色之因缘　　色则不可得
  亦复不离色　　而见色因缘
  离色之因缘　　色自成就色
  物不得因缘　　不得无因缘

应如是知。无因缘故。色则是无。如是一切。若汝意谓。微尘是有。此不成故。如是行义。则不可成。如汝说言。一切现见有行去来。此义不然。现不成故。问曰。云何不成。答曰。此现者名或知或物。此我今释。若知应说。何者是知。是谁之现。若六境界。是可得者。境界无故。云何可得知是现耶。有念念者。彼则无现。乃至不疑。有现无现。是则为胜。知现之知。此知非现知境界故。知不成故。说有物人。则舍自法。物云何现。此之现相。量遮法中。广遮此事。此何者现。今何者现。又复如来有偈说言

  眼则不见色　　识则不知法
  此第一隐密　　世间不能知

如是之义。阿阇梨言

  何人自于自　　不曾能自见
  若不能见自　　云何能见他

如是无现。现不可得。如汝说言。一切现见。有去来者。此义不然。去来非色。云何言现。非眼所得。非意所念。彼不成有。岂可现见。若汝意谓。以有比故。知是有者。比亦不成。前有现故。比之与现。俱不成故。比者名知。是意分别。如是比者。唯意能取。意所摄故。是故此义则不如是。意亦无故

问曰。此如是义若法不生。则无去来。亦复无现。谁安隐心。不狂之人。而受此义。谓于一切不生法中。而有去来。如是异义。如是一义。如是常义。如是断义。如是生义。如是灭义。此等一切以不生故。皆悉不成。又一切法云何不生。答曰偈言

  非自亦非他　　非二非无因
  一切法如是　　是故皆不生

顺中论义入大般若波罗蜜经初品法门卷下


壹输卢迦论

    No. 1573

壹输卢迦论一卷

        龙树菩萨造

        后魏瞿昙留支雒阳译

  体自体无常　　如是体无体
  自体性无体　　故说空无常

问曰。以何义故造此一偈论。说何等义破何等人。答曰。为读诵者于广大部生懈倦心。又为聪睿先已广习无量诸论于如来法海义中思惟而生懈倦。于无常自体空不异义中。生异相疑。为断此疑故造斯论。说何义者。今当说。谓一切法无常自体空。自体空不离无常。一切法自性自体空。是故无有常。一切诸佛缘觉声闻。于空法中而得出离。非于诸行断常法中而得解脱。偈言

  灭空住有体　　则成于常见
  若谓后时灭　　则成于断见

以此义故。说一切法自体空。诸佛缘觉声闻罗汉。于此义中得利益故。破何等人者。今当说。若有所得人离于诸行。说有无常则非正见。若无常离有为。无常则常犹如虚空。若如是者。则有为无为体无差别。若有为与无为合。无为合故则瓶不可破。若无为与有为合。有为合故则涅槃可坏。若不异者。则一切法不可破坏。如涅槃常非缘生故。若诸行非因缘生。不异虚空涅槃者。则有为法不名无常。若诸行非因缘生。是无常者。则虚空涅槃不名为常。若如是者。则有为无为无有胜法。若无常离有为。犹名无常者。则有为离常。应名为常。但是事不然。若如是者。何等修多罗中作如是说。以何义说。汝今所说以何义说。汝今所说义不相应。非汝邪思之所能量。是故汝说非为正见。若人有所得。谓过去未来现在法自体成者。当知是人则非正见。何以故。无因生见故。若言未来体非因缘生自体成者。则现在法亦非因缘生自性体成。以未来现在自性平等无差别故。若性平等者。现在有法皆从缘生。未来法何故非缘生。汝今此义为以修多罗说为依义说。说不相应则无理趣。若无理趣则不可信。若未来法无因缘生自性成者。未来之法犹如虚空无有因缘。离因缘故非因缘生。则无实未来体。无未来故现在过去亦无。现在过去无故三世无体。若有体者则是常见无因生故。若佛弟子有所得见。则与外道迦毗罗等无差别。此论非为迦毗罗忧楼迦诸外道等。为汝等辈同见之人故造斯论。向说破何等人。为令汝等有所得人断除邪见故作斯论。一输卢迦偈句义今当释。偈言自体性无常者。自体名有生。有法故名为体。有所得人于此法中心取为体。此法于阴界入中有声缘转。如说一体二体多体。如彼此人一二众多各有自体故名自体。如地水火风坚湿热动各有自性。如是各各自相自体故言自体。有所得人谓生住灭同相者。是义不然。自体性无常故。彼体名有所得人分别故生。是故离诸法无无常体。以自相无常故。如佛告比丘。一切诸行皆悉无常。以此说故。离法有无常自相者。是事不然。若汝不了云何无常。我今当说。偈言如是体无体故。体无体者。汝所分别无常者。彼无常无体。是故体无体。自性无体故言无体。偈言自体性无体者。离无体更无别体故。言自体无体。若汝意谓离无体而有体者。是义不然。以汝此法非修多罗说故。若谓无体是自体者。是亦不然。以修多罗所不说故。世尊。于何等修多罗中说如此法。于佛世尊修多罗中。都无此义。以非经说故不成就。非大圣修多罗所说之义则不应信。是故非唯言说而得取证。偈言故说空无常者。如调伏三蜜提经中说。佛告三蜜提。眼空无常无不动。无不坏无不变。何以故。性如是故。耳鼻舌身意亦复如是。世尊。于此修多罗中说空说无常。以是义故。知诸法空无常。无常无体。是故诸法性自无体则无体义成。若能如是入修多罗义。其义则成。若不入修多罗。其义则坏。以我所说入修多罗。其义则成。是故性自无体其义成就。一输卢迦论一卷。凡诸法体性法物事有名异义同。是故或言体。或言性。或言法。或言有。或言物。莫不皆是有之差别。正音云私婆婆。或译为自体体。或译为无法有法。或译为无自性性

壹输卢迦论一卷


中论

    No. 1564 [cf. Nos. 1565-1567]

中论卷第一

    释僧睿序

中论有五百偈。龙树菩萨之所造也以中为名者。照其实也。以论为称者。尽其言也。实非名不悟。故寄中以宣之。言非释不尽。故假论以明之。其实既宣。其言既明。于菩萨之行道场之照。朗然悬解矣。夫滞惑生于倒见。三界以之而沦溺。偏悟起于厌智。耿介以之而致乖。故知大觉在乎旷照。小智缠乎隘心。照之不旷。则不足以夷有无一道俗。知之不尽。则未可以涉中途泯二际。道俗之不夷。二际之不泯。菩萨之忧也。是以龙树大士。析之以中道。使惑趣之徒望玄指而一变。括之以即化。令玄悟之宾丧咨询于朝彻。荡荡焉。真可谓坦夷路于冲阶。敝玄门于宇内。扇慧风于陈枚。流甘露于枯悴者矣。夫百梁之构兴。则鄙茅茨之仄陋。睹斯论之宏旷。则知偏悟之鄙倍。幸哉此区之赤县。忽得移灵鹫以作镇。险陂之边情。乃蒙流光之余惠。而今而后。谈道之贤始可与论实矣。云天竺诸国。敢预学者之流。无不玩味斯论以为喉衿。其染翰申释者。甚亦不少。今所出者。是天竺梵志名宾伽罗。秦言青目之所释也。其人虽信解深法。而辞不雅中。其中乖阙烦重者。法师皆裁而裨之。于经通之理尽矣。文或左右未尽善也。百论治外以闲邪。斯文袪内以流滞。大智释论之渊博。十二门观之精诣。寻斯四者。真若日月入怀无不朗然鉴彻矣。予玩之味之不能释手。遂复忘其鄙拙。托悟怀于一序。并目品义题之于首。岂期能释耶。盖是欣自同之怀耳

    中论观因缘品第一(十六偈)

        龙树菩萨造梵志青目释

        姚秦三藏鸠摩罗什译

  不生亦不灭　　不常亦不断
  不一亦不异　　不来亦不出
  能说是因缘　　善灭诸戏论
  我稽首礼佛　　诸说中第一

问曰。何故造此论。答曰。有人言万物从大自在天生。有言从韦纽天生。有言从和合生。有言从时生。有言从世性生。有言从变生。有言从自然生。有言从微尘生。有如是等谬故堕于无因邪因断常等邪见。种种说我我所。不知正法。佛欲断如是等诸邪见令知佛法故。先于声闻法中说十二因缘。又为已习行有大心堪受深法者。以大乘法说因缘相。所谓一切法不生不灭不一不异等。毕竟空无所有。如般若波罗蜜中说。佛告须菩提。菩萨坐道场时。观十二因缘。如虚空不可尽。佛灭度后。后五百岁像法中。人根转钝。深着诸法。求十二因缘五阴十二入十八界等决定相。不知佛意但著文字。闻大乘法中说毕竟空。不知何因缘故空。即生疑见。若都毕竟空。云何分别有罪福报应等。如是则无世谛第一义谛。取是空相而起贪着。于毕竟空中生种种过。龙树菩萨为是等故。造此中论

  不生亦不灭　　不常亦不断
  不一亦不异　　不来亦不出
  能说是因缘　　善灭诸戏论
  我稽首礼佛　　诸说中第一

以此二偈赞佛。则已略说第一义。问曰。诸法无量。何故但以此八事破。答曰法虽无量。略说八事则为总破一切法。不生者。诸论师种种说生相。或谓因果一。或谓因果异。或谓因中先有果。或谓因中先无果。或谓自体生。或谓从他生。或谓共生。或谓有生。或谓无生。如是等说生相皆不然。此事后当广说。生相决定不可得故不生。不灭者。若无生何得有灭。以无生无灭故。余六事亦无问曰。不生不灭已总破一切法。何故复说六事。答曰。为成不生不灭义故。有人不受不生不灭。而信不常不断。若深求不常不断。即是不生不灭。何以故。法若实有则不应无。先有今无是即为断。若先有性是则为常。是故说不常不断。即入不生不灭义。有人虽闻四种破诸法。犹以四门成诸法。是亦不然。若一则无缘。若异则无相续。后当种种破。是故复说不一不异。有人虽闻六种破诸法。犹以来出成诸法。来者。言诸法从自在天世性微尘等来。出者。还去至本处。复次万物无生。何以故。世间现见故。世间眼见劫初谷不生。何以故。离劫初谷。今谷不可得。若离劫初谷有今谷者。则应有生。而实不尔。是故不生。问曰若不生则应灭。答曰不灭。何以故。世间现见故。世间眼见劫初谷不灭。若灭今不应有谷而实有谷。是故不灭。问曰。若不灭则应常。答曰不常。何以故。世间现见故。世间眼见万物不常。如谷芽时种则变坏。是故不常。问曰若不常则应断。答曰不断。何以故。世间现见故。世间眼见万物不断。如从谷有芽。是故不断。若断不应相续。问曰。若尔者万物是一。答曰不一。何以故。世间现见故。世间眼见万物不一。如谷不作芽芽不作谷。若谷作芽芽作谷者。应是一。而实不尔。是故不一。问曰若不一则应异。答曰不异。何以故。世间现见故。世间眼见万物不异。若异者。何故分别谷芽谷茎谷叶。不说树芽树茎树叶。是故不异。问曰。若不异应有来。答曰无来何以故。世间现见故。世间眼见万物不来。如谷子中芽无所从来。若来者。芽应从余处来。如鸟来栖树。而实不尔。是故不来。问曰。若不来应有出。答曰不出。何以故。世间现见故。世间眼见万物不出。若有出。应见芽从谷出。如蛇从穴出。而实不尔。是故不出。问曰。汝虽释不生不灭义。我欲闻造论者所说。答曰

  诸法不自生　　亦不从他生
  不共不无因　　是故知无生

不自生者。万物无有从自体生。必待众因。复次若从自体生。则一法有二体。一谓生。二谓生者。若离余因从自体生者。则无因无缘。又生更有生生则无穷。自无故他亦无。何以故。有自故有他。若不从自生。亦不从他生。共生则有二过。自生他生故。若无因而有万物者。是则为常。是事不然。无因则无果。若无因有果者。布施持戒等应堕地狱。十恶五逆应当生天。以无因故。复次

  如诸法自性　　不在于缘中
  以无自性故　　他性亦复无

诸法自性不在众缘中。但众缘和合故得名字。自性即是自体。众缘中无自性。自性无故不自生。自性无故他性亦无。何以故。因自性有他性。他性于他亦是自性。若破自性即破他性。是故不应从他性生。若破自性他性即破共义。无因则有大过。有因尚可破。何况无因。于四句中生不可得。是故不生。问曰。阿毗昙人言。诸法从四缘生。云何言不生。何谓四缘

  因缘次第缘　　缘缘增上缘
  四缘生诸法　　更无第五缘

一切所有缘。皆摄在四缘。以是四缘万物得生。因缘名一切有为法。次第缘除过去现在阿罗汉最后心心数法。余过去现在心心数法。缘缘增上缘一切法。答曰

  果为从缘生　　为从非缘生
  是缘为有果　　是缘为无果

若谓有果。是果为从缘生。为从非缘生。若谓有缘。是缘为有果为无果。二俱不然。何以故

  因是法生果　　是法名为缘
  若是果未生　　何不名非缘

诸缘无决定。何以故。若果未生。是时不名为缘。但眼见从缘生果。故名之为缘。缘成由于果。以果后缘先故。若未有果何得名为缘。如瓶以水土和合故有瓶生。见瓶缘知水土等是瓶缘。若瓶未生时。何以不名水土等为非缘。是故果不从缘生。缘尚不生。何况非缘。复次

  果先于缘中　　有无俱不可
  先无为谁缘　　先有何用缘

缘中先非有果非无果。若先有果不名为缘。果先有故。若先无果亦不名为缘。不生余物故。问曰。已总破一切因缘。今欲闻一一破诸缘。答曰

  若果非有生　　亦复非无生
  亦非有无生　　何得言有缘

若缘能生果。应有三种。若有若无若有无。如先偈中说。缘中若先有果不应言生。以先有故。若先无果不应言生。以先无故。亦应与非缘同故。有无亦不生者。有无名为半有半无。二俱有过。又有与无相违。无与有相违。何得一法有二相。如是三种求果生相不可得故。云何言有因缘。次第缘者

  果若未生时　　则不应有灭
  灭法何能缘　　故无次第缘

诸心心数法。于三世中次第生。现在心心数法灭。与未来心作次第缘。未来法未生。与谁作次第缘。若未来法已有即是生。何用次第缘。现在心心数法无有住时。若不住何能为次第缘。若有住则非有为法。何以故。一切有为法常有灭相故。若灭已则不能与作次第缘。若言灭法犹有则是常。若常则无罪福等。若谓灭时能与作次第缘。灭时半灭半未灭。更无第三法。名为灭时。又佛说。一切有为法念念灭。无一念时住。云何言现在法有欲灭未欲灭。汝谓一念中无是欲灭未欲灭。则破自法。汝阿毗昙说。有灭法有不灭法。有欲灭法有不欲灭法。欲灭法者。现在法将欲灭。未欲灭法者。除现在将欲灭法。余现在法及过去未来无为法。是名不欲灭法。是故无次第缘。缘缘者

  如诸佛所说　　真实微妙法
  于此无缘法　　云何有缘缘

佛说。大乘诸法。若有色无色有形无形有漏无漏有为无为等诸法相入于法性。一切皆空无相无缘。譬如众流入海同为一味。实法可信随宜所说不可为实。是故无缘缘。增上缘者

  诸法无自性　　故无有有相
  说有是事故　　是事有不然

经说十二因缘。是事有故是事有。此则不然。何以故。诸法从众缘生故自无定性。自无定性故无有有相。有相无故。何得言是事有故是事有。是故无增上缘。佛随凡夫分别有无故说。复次

  略广因缘中　　求果不可得
  因缘中若无　　云何从缘出

略者。于和合因缘中无果。广者。于一一缘中亦无果。若略广因缘中无果。云何言果从因缘出。复次

  若谓缘无果　　而从缘中出
  是果何不从　　非缘中而出

若因缘中求果不可得。何故不从非缘出。如泥中无瓶。何故不从乳中出。复次

  若果从缘生　　是缘无自性
  从无自性生　　何得从缘生
  果不从缘生　　不从非缘生
  以果无有故　　缘非缘亦无

果从众缘生。是缘无自性。若无自性则无法。无法何能生。是故果不从缘生。不从非缘生者。破缘故说非缘。实无非缘法。是故不从非缘生。若不从二生。是则无果。无果故缘非缘亦无

    中论观去来品第二(二十五偈)

问曰。世间眼见三时有作。已去未去去时。以有作故当知有诸法。答曰

  已去无有去　　未去亦无去
  离已去未去　　去时亦无去

已去无有去已去故。若离去有去业。是事不然。未去亦无去。未有去法故。去时名半去半未去。不离已去未去故。问曰

  动处则有去　　此中有去时
  非已去未去　　是故去时去

随有作业处。是中应有去。眼见去时中有作业。已去中作业已灭。未去中未有作业。是故当知去时有去。答曰

  云何于去时　　而当有去法
  若离于去法　　去时不可得

去时有去法。是事不然。何以故。离去法去时不可得。若离去法有去时者。应去时中有去。如器中有果。复次

  若言去时去　　是人则有咎
  离去有去时　　去时独去故

若谓已去未去中无去。去时实有去者。是人则有咎。若离去法有去时。则不相因待。何以故。若说去时有去。是则为二。而实不尔。是故不得言离去有去时。复次

  若去时有去　　则有二种去
  一谓为去时　　二谓去时去

若谓去时有去是则有过。所谓有二去。一者因去有去时。二者去时中有去。问曰。若有二去有何咎。答曰

  若有二去法　　则有二去者
  以离于去者　　去法不可得

若有二去法。则有二去者。何以故。因去法有去者故。一人有二去二去者。此则不然。是故去时亦无去。问曰。离去者无去法可尔。今三时中定有去者。答曰

  若离于去者　　去法不可得
  以无去法故　　何得有去者

若离于去者。则去法不可得。今云何于无去法中。言三时定有去者。复次

  去者则不去　　不去者不去
  离去不去者　　无第三去者

无有去者。何以故。若有去者则有二种。若去者若不去者。若离是二。无第三去者。问曰。若去者去有何咎。答曰

  若言去者去　　云何有此义
  若离于去法　　去者不可得

若谓定有去者用去法。是事不然。何以故。离去法。去者不可得故。若离去者定有去法。则去者能用去法。而实不尔。复次

  若去者有去　　则有二种去
  一谓去者去　　二谓去法去

若言去者用去法。则有二过。于一去者中而有二去。一以去法成去者。二以去者成去法。去者成已然后用去法。是事不然。是故先三时中。谓定有去者用去法。是事不然。复次

  若谓去者去　　是人则有咎
  离去有去者　　说去者有去

若人说去者能用去法。是人则有咎。离去法有去者。何以故。说去者用去法。是为先有去者后有去法。是事不然。是故三时中无有去者。复次若决定有去有去者。应有初发。而于三时中。求发不可得。何以故

  已去中无发　　未去中无发
  去时中无发　　何处当有发

何以故。三时中无发

  未发无去时　　亦无有已去
  是二应有发　　未去何有发
  无去无未去　　亦复无去时
  一切无有发　　何故而分别

若人未发则无去时。亦无已去。若有发当在二处。去时已去中。二俱不然。未去时未有发故。未去中何有发。发无故无去。无去故无去者。何得有已去未去去时。问曰。若无去无去者。应有住住者。答曰

  去者则不住　　不去者不住
  离去不去者　　何有第三住

若有住有住者。应去者住。若不去者住。若离此二。应有第三住。是事不然。去者不住。去未息故。与去相违名为住。不去者亦不住。何以故。因去法灭故有住。无去则无住。离去者不去者。更无第三住者。若有第三住者。即在去者不去者中。以是故。不得言去者住。复次

  去者若当住　　云何有此义
  若当离于去　　去者不可得

汝谓去者住。是事不然。何以故。离去法。去者不可得。若去者在去相。云何当有住。去住相违故。复次

  去未去无住　　去时亦无住
  所有行止法　　皆同于去义

若谓去者住。　是人应在去时已去未去中住。三处皆无住。是故汝言去者有住。是则不然。如破去法住法。行止亦如是。行者。如从谷子相续至芽茎叶等。止者。谷子灭故芽茎叶灭。相续故名行。断故名止。又如无明缘诸行乃至老死是名行。无明灭故诸行等灭是名止。问曰。汝虽种种门破去去者住住者。而眼见有去住。答曰。肉眼所见不可信。若实有去去者。为以一法成。为以二法成。二俱有过。何以故

  去法即去者　　是事则不然
  去法异去者　　是事亦不然

若去法去者一。是则不然。异亦不然。问曰一异有何过。答曰

  若谓于去法　　即为是去者
  作者及作业　　是事则为一
  若谓于去法　　有异于去者
  离去者有去　　离去有去者

如是二俱有过。何以故。若去法即是去者。是则错乱破于因缘。因去有去者。因去者有去。又去名为法。去者名为人。人常法无常。若一者则二俱应常二俱无常。一中有如是等过。若异者则相违。未有去法应有去者。未有去者应有去法。不相因待。一法灭应一法在。异中有如是等过。复次

  去去者是二　　若一异法成
  二门俱不成　　云何当有成

若去者去法。有若以一法成。若以异法成。二俱不可得。先已说无第三法成。若谓有成。应说因缘无去无去者。今当更说

  因去知去者　　不能用是去
  先无有去法　　故无去者去

随以何去法知去者。是去者不能用是去法。何以故。是去法未有时。无有去者。亦无去时已去未去。如先有人有城邑得有所起。去法去者则不然。去者因去法成。去法因去者成故。复次

  因去知去者　　不能用异去
  于一去者中　　不得二去故

随以何去法知去者。是去者不能用异去法。何以故。一去者中。二去法不可得故。复次

  决定有去者　　不能用三去
  不决定去者　　亦不用三去
  去法定不定　　去者不用三
  是故去去者　　所去处皆无

决定者。名本实有。不因去法生。去法名身动。三种名未去已去去时。若决定有去者。离去法应有去者。不应有住。是故说决定有去者不能用三去。若去者不决定。不决定名本实无。以因去法得名去者。以无去法故不能用三去。因去法故有去者。若先无去法则无去者。云何言不决定去者用三去。如去者去法亦如是。若先离去者。决定有去法。则不因去者有去法。是故去者。不能用三去法。若决定无去法去者何所用。如是思惟观察。去法去者所去处。是法皆相因待。因去法有去者。因去者有去法。因是二法则有可去处不得言定有。不得言定无。是故决定知。三法虚妄。空无所有。但有假名。如幻如化

    中论观六情品第三(八偈)

问曰。经中说有六情。所谓

  眼耳及鼻舌　　身意等六情
  此眼等六情　　行色等六尘

此中眼为内情色为外尘。眼能见色乃至意为内情。法为外尘。意能知法。答曰无也。何以故

  是眼则不能　　自见其己体
  若不能自见　　云何见余物

是眼不能见自体。何以故。如灯能自照亦能照他。眼若是见相。亦应自见亦应见他。而实不尔。是故偈中说。若眼不自见何能见余物。问曰。眼虽不能自见。而能见他。如火能烧他不能自烧。答曰

  火喻则不能　　成于眼见法
  去未去去时　　已总答是事

汝虽作火喻。不能成眼见法。是事去来品中已答。如已去中无去。未去中无去。去时中无去。如已烧未烧烧时俱无有烧。如是已见未见见时俱无见相。复次

  见若未见时　　则不名为见
  而言见能见　　是事则不然

眼未对色。则不能见。尔时不名为见。因对色名为见。是故偈中说。未见时无见。云何以见能见。复次二处俱无见法。何以故

  见不能有见　　非见亦不见
  若已破于见　　则为破见者

见不能见。先已说过故。非见亦不见。无见相故。若无见相。云何能见。见法无故见者亦无。何以故。若离见有见者。无眼者。亦应以余情见。若以见见。则见中有见相。见者无见相。是故偈中说。若已破于见则为破见者。复次

  离见不离见　　见者不可得
  以无见者故　　何有见可见

若有见见者则不成。若无见见者亦不成。见者无故。云何有见可见。若无见者。谁能用见法分别外色。是故偈中说。以无见者故何有见可见。复次

  见可见无故　　识等四法无
  四取等诸缘　　云何当得有

见可见法无故。识触受爱四法皆无。以无爱等故。四取等十二因缘分亦无。复次

  耳鼻舌身意　　声及闻者等
  当知如是义　　皆同于上说

如见可见法空。属众缘故无决定。余耳等五情声等五尘。当知亦同见可见法。义同故不别说

    中论观五阴品第四(九偈)

问曰。经说有五阴。是事云何。答曰

  若离于色因　　色则不可得
  若当离于色　　色因不可得

色因者。如布因缕。除缕则无布。除布则无缕。布如色缕如因。问曰若离色因有色。有何过。答曰

  离色因有色　　是色则无因
  无因而有法　　是事则不然

如离缕有布。布则无因。无因而有法。世间所无有。问曰。佛法外道法世间法中皆有无因法。佛法有三无为。无为常故无因。外道法中虚空时方神微尘涅槃等。世间法虚空时方等。是三法无处不有。故名为常。常故无因。汝何以说无因法世间所无。答曰。此无因法但有言说。思惟分别则皆无。若法从因缘有。不应言无因。若无因缘则如我说。问曰。有二种因。一者作因。二者言说因。是无因法无作因。但有言说因。令人知故。答曰。虽有言说因。是事不然。虚空如六种中破。余事后当破。复次现事尚皆可破。何况微尘等不可见法。是故说无因法世间所无。问曰。若离色有色因。有何过。答曰

  若离色有因　　则是无果因
  若言无果因　　则无有是处

若除色果。但有色因者。即是无果因。问曰。若无果有因。有何咎。答曰。无果有因世间所无。何以故。以果故名为因。若无果云何名因。复次若因中无果者。物何以不从非因生。是事如破因缘品中说。是故无有无果因。复次

  若已有色者　　则不用色因
  若无有色者　　亦不用色因

二处有色因。是则不然。若先因中有色。不名为色因。若先因中无色。亦不名为色因。问曰。若二处俱不然。但有无因色。有何咎。答曰

  无因而有色　　是事终不然
  是故有智者　　不应分别色

若因中有果因中无果。此事尚不可得何况无因有色。是故言无因而有色。是事终不然。是故有智者。不应分别色。分别名凡夫。以无明爱染贪着色。然后以邪见生分别戏论说因中有果无果等。今此中求色不可得。是故智者不应分别。复次

  若果似于因　　是事则不然
  果若不似因　　是事亦不然

若果与因相似。是事不然。因细果粗故。因果色力等各异。如布似缕则不名布。缕多布一故。不得言因果相似。若因果不相似。是亦不然。如麻缕不成绢。粗缕无出细布。是故不得言因果不相似。二义不然。故无色无色因

  受阴及想阴　　行阴识阴等
  其余一切法　　皆同于色阴

四阴及一切法。亦应如是思惟破。又今造论者。欲赞美空义故。而说偈

  若人有问者　　离空而欲答
  是则不成答　　俱同于彼疑
  若人有难问　　离空说其过
  是不成难问　　俱同于彼疑

若人论议时。各有所执。离于空义而有问答者。皆不成问答。俱亦同疑。如人言瓶是无常。问者言。何以故无常。答言。从无常因生故。此不名答。何以故。因缘中亦疑不知为常为无常。是为同彼所疑。问者若欲说其过。不依于空而说诸法无常。则不名问难。何以故。汝因无常破我常。我亦因常破汝无常。若实无常则无业报。眼耳等诸法念念灭。亦无有分别。有如是等过。皆不成问难。同彼所疑。若依空破常者。则无有过。何以故。此人不取空相故。是故若欲问答。尚应依于空法。何况欲求离苦寂灭相者

    中论观六种品第五(八偈)

问曰。六种各有定相。有定相故则有六种。答曰

  空相未有时　　则无虚空法
  若先有虚空　　即为是无相

若未有虚空相。先有虚空法者。虚空则无相。何以故无色处名虚空相。色是作法无常。若色未生。未生则无灭。尔时无虚空相。因色故有无色处。无色处名虚空相。问曰。若无相有虚空。有何咎。答曰

  是无相之法　　一切处无有
  于无相法中　　相则无所相

若于常无常法中。求无相法不可得。如论者言。是有是无云何知各有相。故生住灭是有为相。无生住灭是无为相。虚空若无相。则无虚空。若谓先无相后相来相者。是亦不然。若先无相。则无法可相。何以故

  有相无相中　　相则无所住
  离有相无相　　余处亦不住

如有峰有角尾端有毛颈下垂[古*頁]。是名牛相。若离是相则无牛。若无牛是诸相无所住。是故说于无相法中相则无所相。有相中相亦不住。先有相故。如水相中火相不住。先有自相故。复次若无相中相住者。则为无因。无因名为无法。而有相．相．可相。常相因待故。离有相无相法。更无第三处可相。是故偈中说离有相无相余处亦不住。复次

  相法无有故　　可相法亦无
  可相法无故　　相法亦复无

相无所住故。则无可相法。可相法无故。相法亦无。何以故。因相有可相。因可相有相。共相因待故

  是故今无相　　亦无有可相
  离相可相已　　更亦无有物

于因缘中。本末推求。相可相决定不可得。是二不可得故。一切法皆无。一切法皆摄在相可相二法中。或相为可相。或可相为相。如火以烟为相。烟亦复以火为相。问曰。若无有有。应当有无。答曰

  若使无有有　　云何当有无
  有无既已无　　知有无者谁

凡物若自坏。若为他坏。名为无。无不自有。从有而有。是故言若使无有有云何当有无。眼见耳闻尚不可得。何况无物。问曰。以无有有故无亦无。应当有知有无者。答曰。若有知者。应在有中应在无中。有无既破。知者亦同破

  是故知虚空　　非有亦非无
  非相非可相　　余五同虚空

如虚空种种求相不可得。余五种亦如是。问曰。虚空不在初不在后。何以先破。答曰。地水火风众缘和合故易破。识以苦乐因故知无常变异故易破。虚空无如是相。但凡夫悕望为有。是故先破。复次虚空能持四大。四大因缘有识。是故先破根本。余者自破。问曰。世间人尽见诸法是有是无。汝何以独与世间相违。言无所见。答曰

  浅智见诸法　　若有若无相
  是则不能见　　灭见安隐法

若人未得道。不见诸法实相。爱见因缘故种种戏论。见法生时谓之为有。取相言有。见法灭时谓之为断。取相言无。智者见诸法生即灭无见。见诸法灭即灭有见。是故于一切法虽有所见。皆如幻如梦。乃至无漏道见尚灭。何况余见。是故若不见灭见安隐法者。则见有见无

    中论观染染者品第六(十偈)

问曰。经说贪欲嗔恚愚痴。是世间根本。贪欲有种种名。初名爱次名著次名染次名淫欲。次名贪欲。有如是等名字此是结使。依止众生众生名染者。贪欲名染法。有染法染者故。则有贪欲。余二亦如是。有嗔则有嗔者。有痴则有痴者。以此三毒因缘起三业。三业因缘起三界。是故有一切法答曰。经虽说有三毒名字。求实不可得。何以故

  若离于染法　　先自有染者
  因是染欲者　　应生于染法
  若无有染者　　云何当有染
  若有若无染　　染者亦如是

若先定有染者。则不更须染。染者先已染故。若先定无染者。亦复不应起染要当先有染者然后起染。若先无染者。则无受染者。染法亦如是。若先离人定有染法。此则无因。云何得起似如无薪火。若先定无染法。则无有染者。是故偈中说若有若无染。染者亦如是。问曰。若染法染者先后相待生。是事不可得者。若一时生有何咎。答曰

  染者及染法　　俱成则不然
  染者染法俱　　则无有相待

若染法染者一时成。则不相待。不因染者有染法。不因染法有染者。是二应常。已无因成故。若常则多过。无有解脱法。复次今当以一异法。破染法染者。何以故

  染者染法一　　一法云何合
  染者染法异　　异法云何合

染法染者。若以一法合。若以异法合。若一则无合。何以故。一法云何自合。如指端不能自触。若以异法合。是亦不可。何以故。以异成故。若各成竟不须复合。虽合犹异。复次一异俱不可。何以故

  若一有合者　　离伴应有合
  若异有合者　　离伴亦应合

若染染者一。强名为合者。应离余因缘而有染染者。复次若一。亦不应有染染者二名。染是法染者是人。若人法为一。是则大乱。若染染者各异。而言合者。则不须余因缘而有合。若异而合者。虽远亦应合。问曰。一不合可尔。眼见异法共合。答曰

  若异而有合　　染染者何事
  是二相先异　　然后说合相

若染染者。先有决定异相。而后合者是则不合何以故。是二相先已异。而后强说合。复次

  若染及染者　　先各成异相
  既已成异相　　云何而言合

若染染者先各成别相。汝今何以强说合相。复次

  异相无有成　　是故汝欲合
  合相竟无成　　而复说异相

汝已染染者异相不成故。复说合相。合相中有过。染染者不成。汝为成合相故。复说异相。汝自已为定。而所说不定。何以故

  异相不成故　　合相则不成
  于何异相中　　而欲说合相

以此中染染者异相不成故。合相亦不成。汝于何异相中而欲说合相。复次

  如是染染者　　非合不合成
  诸法亦如是　　非合不合成

如染恚痴亦如是。如三毒一切烦恼一切法亦如是。非先非后非合非散。等因缘所成

中论卷第一中论卷第二

        龙树菩萨造梵志青目释

        姚秦三藏鸠摩罗什译

    观三相品第七(三十五偈)

问曰。经说有为法有三相生住灭。万物以生法生。以住法住。以灭法灭。是故有诸法。答曰不尔。何以故。三相无决定故。是三相为是有为能作有为相。为是无为能作有为相。二俱不然。何以故

  若生是有为　　则应有三相
  若生是无为　　何名有为相

若生是有为。应有三相生住灭。是事不然。何以故。共相违故。相违者。生相应生法。住相应住法。灭相应灭法。若法生时。不应有住灭相违法。一时则不然。如明闇不俱。以是故生不应是有为法。住灭相亦应如是。问曰。若生非有为。若是无为有何咎。答曰。若生是无为。云何能为有为法作相。何以故。无为法无性故。因灭有为名无为。是故说不生不灭名无为相。更无自相。是故无法。不能为法作相。如兔角龟毛等不能为法作相。是故生非无为。住灭亦如是。复次

  三相若聚散　　不能有所相
  云何于一处　　一时有三相

是生住灭相。若一一能为有为法作相。若和合能与有为法作相。二俱不然。何以故。若谓一一者。于一处中或有有相。或有无相。生时无住灭。住时无生灭。灭时无生住。若和合者。共相违法。云何一时俱。若谓三相更有三相者。是亦不然。何以故

  若谓生住灭　　更有有为相
  是即为无穷　　无即非有为

若谓生住灭更有有为相。生更有生有住有灭。如是三相复应更有相。若尔则无穷。若更无相。是三相则不名有为法。亦不能为有为法作相。问曰。汝说三相为无穷。是事不然。生住灭虽是有为。而非无穷。何以故

  生生之所生　　生于彼本生
  本生之所生　　还生于生生

法生时通自体七法共生。一法二生三住四灭五生生六住住七灭灭。是七法中。本生除自体。能生六法。生生能生本生。本生能生生生。是故三相虽是有为。而非无穷。答曰

  若谓是生生　　能生于本生
  生生从本生　　何能生本生

若是生生能生本生者。是生生则不名从本生生。何以故。是生生从本生生。云何能生本生。复次

  若谓是本生　　能生于生生
  本生从彼生　　何能生生生

若谓本生能生生生者。是本生不名从生生生。何以故。是本生从生生生。云何能生生生。生生法应生本生。而今生生不能生本生。生生未有自体。何能生本生。是故本生不能生生生。问曰。是生生生时非先非后。能生本生。但生生生时能生本生。答曰不然。何以故

  若生生生时　　能生于本生
  生生尚未有　　何能生本生

若谓生生生时能生本生可尔。而实未有。是故生生生时。不能生本生。复次

  若本生生时　　能生于生生
  本生尚未有　　何能生生生

若谓是本生生时能生生生可尔。而实未有。是故本生生时。不能生生生。问曰

  如灯能自照　　亦能照于彼
  生法亦如是　　自生亦生彼

如灯入于闇室照了诸物。亦能自照。生亦如是。能生于彼。亦能自生。答曰不然。何以故

  灯中自无闇　　住处亦无闇
  破闇乃名照　　无闇则无照

灯体自无闇。明所及处亦无闇。明闇相违故。破闇故名照。无闇则无照。何得言灯自照亦照彼。问曰。是灯非未生有照亦非生已有照。但灯生时。能自照亦照彼。答曰

  云何灯生时　　而能破于闇
  此灯初生时　　不能及于闇

灯生时名半生半未生。灯体未成就云何能破闇。又灯不能及闇。如人得贼乃名为破。若谓灯虽不到闇而能破闇者。是亦不然。何以故

  灯若未及闇　　而能破闇者
  灯在于此间　　则破一切闇

若灯有力。不到闇而能破者。此处燃灯。应破一切处闇。俱不及故。复次灯不应自照照彼。何以故

  若灯能自照　　亦能照于彼
  闇亦应自闇　　亦能闇于彼

若灯与闇相违故。能自照亦照于彼。闇与灯相违故。亦应自蔽蔽彼。若闇与灯相违。不能自蔽蔽彼。灯与闇相违。亦不应自照亦照彼。是故灯喻非也。破生因缘未尽故。今当更说

  此生若未生　　云何能自生
  若生已自生　　生已何用生

是生自生时。为生已生。为未生生。若未生生则是无法。无法何能自生。若谓生已生。则为已成。不须复生。如已作不应更作。若已生若未生。是二俱不生故无生。汝先说生如灯能自生亦生彼。是事不然。住灭亦如是。复次

  生非生已生　　亦非未生生
  生时亦不生　　去来中已答

生名众缘和合有生。已生中无作故无生。未生中无作故无生。生时亦不然。离生法生时不可得。离生时生法亦不可得。云何生时生。是事去来中已答。已生法不可生。何以故。生已复生。如是展转则为无穷。如作已复作。复次若生已更生者。以何生法生。是生相未生。而言生已生者。则自违所说。何以故。生相未生而汝谓生。若未生谓生者。法或可生已而生。或可未生而生。汝先说生已生。是则不定。复次如烧已不应复烧。去已不应复去。如是等因缘故。生已不应生。未生法亦不生。何以故。法若未生。则不应与生缘和合。若不与生缘和合。则无法生。若法未与生缘和合而生者。应无作法而作。无去法而去。无染法而染。无恚法而恚。无痴法而痴。如是则皆破世间法。是故未生法不生。复次若未生法生者。世间未生法皆应生一切凡夫。未生菩提今应生菩提不坏法。阿罗汉无有烦恼。今应生烦恼。兔等无角今皆应生。但是事不然。是故未生法亦不生。问曰。未生法不生者。以未有缘无作无作者无时无方等故不生。若有缘有作有作者有时有方等和合故未生法生。是故若说一切未生法皆不生。是事不尔。答曰。若法有缘有时有方等和合则生者。先有亦不生。先无亦不生。有无亦不生。三种先已破。是故生已不生。未生亦不生。生时亦不生。何以故。已生分不生。未生分亦不生。如先答。复次若离生有生时者。应生时生。但离生无生时。是故生时亦不生。复次若言生时生者。则有二生过。一以生故名生时。二以生时中生。二皆不然。无有二法。云何有二生。是故生时亦不生。复次生法未发则无生时。生时无故生何所依。是故不得言生时生。如是推求。生已无生。未生无生。生时无生。无生故生不成。生不成故住灭亦不成。生住灭不成故有为法不成。是故偈中说去未去去时中已答。问曰。我不定言生已生未生生生时生。但众缘和合故有生。答曰。汝虽有是说。此则不然。何以故

  若谓生时生　　是事已不成
  云何众缘合　　尔时而得生

生时生已种种因缘破。汝今何以更说众缘和合故有生。若众缘具足不具足。皆与生同破。复次

  若法众缘生　　即是寂灭性
  是故生生时　　是二俱寂灭

众缘所生法。无自性故寂灭。寂灭名为无。此无彼无相。断言语道灭诸戏论。众缘名。如因缕有布因蒲有席。若缕自有定相。不应从麻出。若布自有定相。不应从缕出。而实从缕有布。从麻有缕。是故缕亦无定性。布亦无定性。如燃可燃因缘和合成。无有自性。可燃无故燃亦无。燃无故可燃亦无。一切法亦如是。是故从众缘生法无自性。无自性故空如野马无实。是故偈中说生与生时二俱寂灭。不应说生时生。汝虽种种因缘欲成生相。皆是戏论非寂灭相。问曰。定有三世别异。未来世法得生。因缘即生。何故言无生。答曰

  若有未生法　　说言有生者
  此法先已有　　更复何用生

若未来世中。有未生法而生。是法先已有。何用更生。有法不应更生。问曰。未来虽有。非如现在相。以现在相故说生。答曰。现在相未来中无。若无云何言未来生法生。若有不名未来。应名现在。现在不应更生。二俱无生故不生。复次汝谓生时生亦能生彼。今当更说

  若言生时生　　是能有所生
  何得更有生　　而能生是生

若生生时能生彼。是生谁复能生

  若谓更有生　　生生则无穷
  离生生有生　　法皆能自生

若生更有生。生则无穷。若是生更无生而自生者。一切法亦皆能自生。而实不尔。复次

  有法不应生　　无亦不应生
  有无亦不生　　此义先已说

凡所有生。为有法有生。为无法有生。为有无法有生。是皆不然。是事先已说。离此三事更无有生。是故无生。复次

  若诸法灭时　　是时不应生
  法若不灭者　　终无有是事

若法灭相是法不应生。何以故。二相相违故。一是灭相。知法是灭。一是生相。知法是生。二相相违法。一时则不然。是故灭相法不应生。问曰。若灭相法不应生。不灭相法应生。答曰。一切有为法念念灭故。无不灭法离有为。无有决定无为法。无为法但有名字。是故说不灭法终无有是事。问曰。若法无生应有住。答曰

  不住法不住　　住法亦不住
  住时亦不住　　无生云何住

不住法不住。无住相故。住法亦不住。何以故。已有住故。因去故有住。若住法先有。不应更住。住时亦不住。离住不住更无住时。是故亦不住。如是一切处求住不可得故。即是无生。若无生云何有住。复次

  若诸法灭时　　是则不应住
  法若不灭者　　终无有是事

若法灭相。是法无有住相。何以故。一法中有二相相违故。一是灭相。二是住相。一时一处有住灭相。是事不然。是故不得言灭相法有住。问曰。若法不灭应有住。答曰。无有不灭法。何以故

  所有一切法　　皆是老死相
  终不见有法　　离老死有住

一切法生时无常。常随逐无常有二。名老及死。如是一切法。常有老死故无住时。复次

  住不自相住　　亦不异相住
  如生不自生　　亦不异相生

若有住法。为自相住为他相住。二俱不然。若自相住则为是常。一切有为法从众缘生。若住法自住。则不名有为。住若自相住。法亦应自相住。如眼不能自见。住亦如是。若异相住则。住更有住。是则无穷。复次见异法生异相。不得不因异法而有异相。异相不定故。因异相而住者。是事不然。问曰。若无住应有灭。答曰无。何以故

  法已灭不灭　　未灭亦不灭
  灭时亦不灭　　无生何有灭

若法已灭则不灭。以先灭故。未灭亦不灭。离灭相故。灭时亦不灭。离二更无灭时。如是推求。灭法即是无生。无生何有灭。复次

  法若有住者　　是则不应灭
  法若不住者　　是亦不应灭

若法定住则无有灭。何以故。由有住相故。若住法灭则有二相。住相灭相。是故不得言住中有灭。如生死不得一时有。若法不住亦无有灭。何以故。离住相故。若离住相则无法。无法云何灭。复次

  是法于是时　　不于是时灭
  是法于异时　　不于异时灭

若法有灭相。是法为自相灭。为异相灭。二俱不然。何以故。如乳不于乳时灭。随有乳时。乳相定住故。非乳时亦不灭。若非乳不得言乳灭。复次

  如一切诸法　　生相不可得
  以无生相故　　即亦无灭相

如先推求。一切法生相不可得。尔时即无灭相。破生故无生。无生云何有灭。若汝意犹未已。今当更说破灭因缘

  若法是有者　　是即无有灭
  不应于一法　　而有有无相

诸法有时推求灭相不可得。何以故。云何一法中。亦有亦无相。如光影不同处。复次

  若法是无者　　是即无有灭
  譬如第二头　　无故不可断

法若无者则无灭相。如第二头第三手无故不可断。复次

  法不自相灭　　他相亦不灭
  如自相不生　　他相亦不生

如先说生相。生不自生。亦不从他生。若以自体生。是则不然。一切物皆从众缘生。如指端不能自触。如是生不能自生。从他生亦不然。何以故。生未有故。不应从他生。是生无故无自体。自体无故他亦无。是故从他生亦不然。灭法亦如是。不自相灭不他相灭。复次

  生住灭不成　　故无有有为
  有为法无故　　何得有无为

汝先说有生住灭相故有有为。以有有为故有无为。今以理推求。三相不可得。云何得有有为。如先说。无有无相法。有为法无故。何得有无为。无为相名不生不住不灭。止有为相故名无为相。无为自无别相。因是三相有无为相。如火为热相地为坚相水为冷相。无为则不然。问曰。若是生住灭毕竟无者。云何论中得说名字。答曰

  如幻亦如梦　　如乾闼婆城
  所说生住灭　　其相亦如是

生住灭相无有决定。凡人贪着谓有决定。诸贤圣怜愍欲止其颠倒。还以其所著名字为说。语言虽同其心则异。如是说生住灭相。不应有难。如幻化所作。不应责其所由。不应于中有忧喜想。但应眼见而已。如梦中所见不应求实。如乾闼婆城日出时现而无有实。但假为名字不久则灭。生住灭亦如是。凡夫分别为有。智者推求则不可得

    中论观作作者品第八(十二偈)

问曰。现有作有作者有所用作法。三事和合故有果报。是故应有作者作业。答曰。上来品品中。破一切法皆无有余。如破三相。三相无故无有有为。有为无故无无为。有为无为无故。一切法尽无作作者。若是有为。有为中已破。若是无为。无为中已破。不应复问汝着心深故。而复更问。今当复答

  决定有作者　　不作决定业
  决定无作者　　不作无定业

若先定有作者定有作业。则不应作。若先定无作者定无作业。亦不应作。何以故

  决定业无作　　是业无作者
  定作者无作　　作者亦无业

若先决定有作业。不应更有作者。又离作者应有作业。但是事不然。若先决定有作者。不应更有作业。又离作业应有作者。但是事不然。是故决定作者决定作业。不应有作。不决定作者不决定作业。亦不应有作。何以故。本来无故。有作者有作业。尚不能作。何况无作者无作业。复次

  若定有作者　　亦定有作业
  作者及作业　　即堕于无因

若先定有作者定有作业。汝谓作者有作。即为无因离作业有作者。离作者有作业。则不从因缘有。问曰。若不从因缘有作者有作业。有何咎。答曰

  若堕于无因　　则无因无果
  无作无作者　　无所用作法
  若无作等法　　则无有罪福
  罪福等无故　　罪福报亦无
  若无罪福报　　亦无有涅槃
  诸可有所作　　皆空无有果

若堕于无因。一切法则无因无果。能生法名为因。所生法名为果。是二即无。是二无故无作无作者。亦无所用作法。亦无罪福。罪福无故亦无罪福果报及涅槃道。是故不得从无因生。问曰。若作者不定。而作不定业有何咎。答曰。一事无尚不能起作业。何况二事都无。譬如化人以虚空为舍。但有言说而无作者作业。问曰。若无作者无作业。不能有所作。今有作者有作业应有作。答曰

  作者定不定　　不能作二业
  有无相违故　　一处则无二

作者定不定。不能作定不定业。何以故。有无相违故。一处不应有二。有是决定。无是不决定。一人一事云何有有无。复次

  有不能作无　　无不能作有
  若有作作者　　其过如先说

若有作者而无业。何能有所作。若无作者而有业。亦不能有所作。何以故。如先说。有中若先有业。作者复何所作。若先无业云何可得作。如是则破罪福等因缘果报。是故偈中说。有不能作无无不能作有。若有作作者。其过如先说。复次

  作者不作定　　亦不作不定
  及定不定业　　其过如先说

定业已破。不定业亦破。定不定业亦破。今欲一时总破。故说是偈。是故作者不能作三种业。今三种作者。亦不能作业。何以故

  作者定不定　　亦定亦不定
  不能作于业　　其过如先说

作者定不定。亦定亦不定。不能作于业。何以故。如先三种过因缘。此中应广说。如是一切处求作者作业。皆不可得。问曰。若言无作无作者。则复堕无因。答曰。是业从众缘生假名为有。无有决定。不如汝所说。何以故

  因业有作者　　因作者有业
  成业义如是　　更无有余事

业先无决定。因人起业。因业有作者。作者亦无决定。因有作业名为作者。二事和合故得成作作者。若从和合生则无自性。无自性故空。空则无所生。但随凡夫忆想分别故。说有作业有作者。第一义中无作业无作者。复次

  如破作作者　　受受者亦尔
  及一切诸法　　亦应如是破

如作作者不得相离。不相离故不决定。无决定故无自性。受受者亦如是。受名五阴身。受者是人。如是离人无五阴。离五阴无人。但从众缘生如受受者。余一切法。亦应如是破

    中论观本住品第九(十二偈)

问曰。有人言

  眼耳等诸根　　苦乐等诸法
  谁有如是事　　是则名本住
  若无有本住　　谁有眼等法
  以是故当知　　先已有本住

眼耳鼻舌身命等诸根。名为眼耳等根。苦受乐受不苦不乐受。想思忆念等心心数法。名为苦乐等法。有论师言。先未有眼等法。应有本住。因是本住。眼等诸根得增长。若无本住。身及眼等诸根。为因何生而得增长。答曰

  若离眼等根　　及苦乐等法
  先有本住者　　以何而可知

若离眼耳等根苦乐等法。先有本住者。以何可说以何可知。如外法瓶衣等。以眼等根得知。内法以苦乐等根得知。如经中说。可坏是色相。能受是受相。能识是识相。汝说离眼耳苦乐等先有本住者。以何可知说有是法。问曰。有论师言。出入息视眴寿命思惟苦乐憎爱动发等是神相。若无有神。云何有出入息等相。是故当知。离眼耳等根苦乐等法。先有本住。答曰。是神若有。应在身内如壁中有柱。若在身外。如人被铠。若在身内。身则不可坏。神常在内故是故言神在身内。但有言说虚妄无实。若在身外覆身如铠者。身应不可见。神细密覆故。亦应不可坏而今实见身坏。是故当知。离苦乐等先无余法。若谓断臂时神缩在内不可断者。断头时亦应缩在内不应死。而实有死。是故知离苦乐等先有神者。但有言说虚妄无实。复次若言身大则神大。身小则神小。如灯大则明大灯小则明小者。如是神则随身不应常。若随身者。身无则神无。如灯灭则明灭。若神无常。则与眼耳苦乐等同。是故当知。离眼耳等先无别神。复次如风狂病人。不得自在。不应作而作。若有神是诸作主者。云何言不得自在。若风狂病不恼神者应离神别有所作。如是种种推求离眼耳等根苦乐等法。先无本住。若必谓离眼耳等根苦乐等法有本住者。无有是事。何以故

  若离眼耳等　　而有本住者
  亦应离本住　　而有眼耳等

若本住离眼耳等根苦乐等法先有者。今眼耳等根苦乐等法。亦应离本住而有。问曰。二事相离可尔但使有本住。答曰

  以法知有人　　以人知有法
  离法何有人　　离人何有法

法者眼耳苦乐等。人者是本住。汝谓以有法故知有人。以有人故知有法。今离眼耳等法何有人。离人何有眼耳等法。复次

  一切眼等根　　实无有本住
  眼耳等诸根　　异相而分别

眼耳等诸根苦乐等诸法。实无有本住。因眼缘色生眼识。以和合因缘。知有眼耳等诸根。不以本住故知。是故偈中说一切眼等根实无有本住。眼耳等诸根各自能分别。问曰

  若眼等诸根　　无有本住者
  眼等一一根　　云何能知尘

若一切眼耳等诸根。苦乐等诸法。无本住者。今一一根。云何能知尘。眼耳等诸根无思惟。不应有知。而实知尘。当知离眼耳等诸根。更有能知尘者。答曰。若尔者。为一一根中各有知者。为一知者在诸根中。二俱有过。何以故

  见者即闻者　　闻者即受者
  如是等诸根　　则应有本住

若见者即是闻者。闻者即是受者。则是一神。如是眼等诸根。应先有本住。色声香等无有定知者。或可以眼闻声。如人有六向随意见闻。若闻者见者是一。于眼等根随意见闻。但是事不然

  若见闻各异　　受者亦各异
  见时亦应闻　　如是则神多

若见者闻者受者各异。则见时亦应闻。何以故。离见者有闻者故。如是鼻舌身中。神应一时行。若尔者。人一而神多。以一切根一时知诸尘。而实不尔。是故见者闻者受者。不应俱用。复次

  眼耳等诸根　　苦乐等诸法
  所从生诸大　　彼大亦无神

若人言离眼耳等诸根苦乐等诸法别有本住。是事已破。今于眼耳等所因四大。是四大中亦无本住。问曰。若眼耳等诸根。苦乐等诸法。无有本住可尔。眼耳等诸根。苦乐等诸法应有。答曰

  若眼耳等根　　苦乐等诸法
  无有本住者　　眼等亦应无

若眼耳苦乐等诸法。无有本住者。谁有此眼耳等。何缘而有。是故眼耳等亦无。复次

  眼等无本住　　今后亦复无
  以三世无故　　无有无分别

思惟推求本住。于眼等先无。今后亦无。若三世无。即是无生寂灭不应有难。若无本住。云何有眼等。如是问答。戏论则灭。戏论灭故。诸法则空

    中论观燃可燃品第十(十六偈)

问曰应有受受者。如燃可燃。燃是受者。可燃是受。所谓五阴。答曰。是事不然。何以故。燃可燃俱不成故。燃可燃。若以一法成。若以二法成。二俱不成。问曰。且置一异法。若言无燃可燃。今云何以一异相破。如兔角龟毛无故不可破。世间眼见实有事而后可思惟。如有金然后可烧可锻。若无燃可燃。不应以一异法思惟。若汝许有一异法。当知有燃可燃。若许有者则为已有。答曰。随世俗法言说。不应有过。燃可燃若说一若说异。不名为受。若离世俗言说。则无所论。若不说燃可燃。云何能有所破。若无所说则义不可明。如有论者。破破有无。必应言有无。不以称有无故而受有无。是以随世间言说故无咎。若口有言便是受者。汝言破即为自破。燃可燃亦如是。虽有言说亦复不受。是故以一异法。思惟燃可燃。二俱不成。何以故

  若燃是可燃　　作作者则一
  若燃异可燃　　离可燃有燃

燃是火。可燃是薪。作者是人。作是业。若燃可燃一。则作作者亦应一。若作作者一。则陶师与瓶一。作者是陶师。作是瓶。陶师非瓶。瓶非陶师。云何为一。是以作作者不一故。燃可燃亦不一。若谓一不可则应异。是亦不然。何以故。若燃与可燃异。应离可燃别有燃。分别是可燃是燃。处处离可燃应有燃。而实不尔是故异亦不可。复次

  如是常应燃　　不因可燃生
  则无燃火功　　亦名无作火

若燃可燃异。则燃不待可燃而常燃。若常燃者则自住其体。不待因缘人功则空。人功者。将护火令燃。是功现有。是故知火不异可燃

复次若燃异可燃燃即无作。离可燃火何所然。若尔者火则无作。无作火无有是事。问曰。云何火不从因缘生。人功亦空答曰

  燃不待可燃　　则不从缘生
  火若常燃者　　人功则应空

燃可燃若异。则不待可燃有燃。若不待可燃有然。则无相因法。是故不从因缘生。复次若燃异可燃。则应常燃。若常燃者。应离可燃别见有燃。更不须人功。何以故

  若汝谓燃时　　名为可燃者
  尔时但有薪　　何物燃可燃

若谓先有薪烧时名可燃者。是事不尔。若离燃别有可燃者。云何言燃时名可燃。复次

  若异则不至　　不至则不烧
  不烧则不灭　　不灭则常住

若燃异可燃。则燃不应至可燃。何以故。不相待成故。若燃不相待成。则自住其体。何用可燃。是故不至。若不至则不燃可燃何以故。无有不至而能烧故。若不烧则无灭。应常住自相。是事不尔。问曰

  燃与可燃异　　而能至可燃
  如此至彼人　　彼人至此人

燃与可燃异。而能至可燃。如男至于女。如女至于男。答曰

  若谓燃可燃　　二俱相离者
  如是燃则能　　至于彼可燃

若离燃有可燃。若离可燃有燃。各自成者。如是则应燃至可燃。而实不尔。何以故。离燃无可燃。离可燃无燃故。今离男有女。离女有男。是故汝喻非也。喻不成故。燃不至可燃。问曰。燃可燃相待而有。因可燃有燃。因燃有可燃。二法相待成。答曰

  若因可燃燃　　因燃有可燃
  先定有何法　　而有燃可燃

若因可燃而燃成。亦应因燃可燃成。是中若先定有可燃。则因可燃。而燃成。若先定有燃。则因燃可燃成。今若因可燃而燃成者。则先有可燃而后有燃。不应待燃而有可燃。何以故可燃在先燃在后故。若燃不燃可燃。是则可燃不成。又可燃不在余处离于燃故。若可燃不成。燃亦不成。若先燃后有可燃。燃亦有如是过。是故燃可燃。二俱不成。复次

  若因可燃燃　　则燃成复成
  是为可燃中　　则为无有燃

若欲因可燃而成燃。则燃成已复成。何以故。燃自住于燃中。若燃不自住其体。从可燃成者。无有是事。是故有是燃从可燃成。今则燃成复成。有如是过。复有可燃无燃过。何以故。可燃离燃自住其体故。是故燃可燃相因待。无有是事。复次

  若法因待成　　是法还成待
  今则无因待　　亦无所成法

若法因待成。是法还成本因待。如是决定则无二事。如因可燃而成燃。还因于燃而成可燃。是则二俱无定。无定故不可得。何以故

  若法有待成　　未成云何待
  若成已有待　　成已何用待

若法因待成。是法先未成。未成则无。无则云何有因待。若是法先已成已成。何用因待。是二俱不相因待。是故汝先说燃可燃相因待成。无有是事。是故

  因可燃无燃　　不因亦无燃
  因燃无可燃　　不因无可燃

今因待可燃燃不成。不因待可燃燃亦不成。可燃亦如是。因燃不因燃。二俱不成。是过先已说。复次

  燃不余处来　　燃处亦无燃
  可燃亦如是　　余如去来说

燃不于余方来入可燃可燃中亦无燃。析薪求燃不可得故。可燃亦如是。不从余处来入燃中。燃中亦无可燃。如燃已不燃未燃不燃燃时不燃。是义如去来中说。是故

  可燃即非然　　离可燃无燃
  燃无有可燃　　燃中无可燃
  可燃中无燃

可燃即非燃。何以故。先已说作作者一过故。离可燃无燃。有常燃等过故。燃无有可燃。燃中无可燃。可燃中无燃。以有异过故。三皆不成。问曰。何故说燃可燃答曰。如因可燃有燃。如是因受有受者。受名五阴。受者名人。燃可燃不成故受受者亦不成。何以故

  以燃可燃法　　说受受者法
  及以说瓶衣　　一切等诸法

如可燃非燃。如是受非受者。作作者一过故。又离受无受者。异不可得故。以异过故。三皆不成。如受受者。外瓶衣等一切法皆同上说。无生毕竟空。是故

  若人说有我　　诸法各异相
  当知如是人　　不得佛法味

诸法从本已来无生。毕竟寂灭相。是故品末说是偈。若人说我相。如犊子部众说。不得言色即是我。不得言离色是我。我在第五不可说藏中。如萨婆多部众说。诸法各各相。是善是不善是无记。是有漏无漏有为无为等别。异如是等人。不得诸法寂灭相。以佛语作种种戏论

    中论观本际品第十一(八偈)

问曰。无本际经说。众生往来生死。本际不可得。是中说有众生有生死。以何因缘故而作是说。答曰

  大圣之所说　　本际不可得
  生死无有始　　亦复无有终

圣人有三种。一者外道五神通。二者阿罗汉辟支佛。三者得神通大菩萨佛于三种中最上故言大圣。佛所言说无不是实说。生死无始。何以故。生死初后不可得。是故言无始汝谓若无初后。应有中者。是亦不然。何以故

  若无有始终　　中当云何有
  是故于此中　　先后共亦无

因中后故有初。因初中故有后。若无初无后。云何有中。生死中无初中后。是故说先后共不可得。何以故

  若使先有生　　后有老死者
  不老死有生　　不生有老死
  若先有老死　　而后有生者
  是则为无因　　不生有老死

生死众生。若先生渐有老。而后有死者。则生无老死。法应生有老死老死有生。又不老死而生。是亦不然。又不因生有老死。若先老死后生。老死则无因。生在后故。又不生何有老死。若谓生老死先后不可。谓一时成者。是亦有过。何以故

  生及于老死　　不得一时共
  生时则有死　　是二俱无因

若生老死一时则不然何以故。生时即有死故。法应生时有死时无。若生时有死。是事不然。若一时生则无有相因。如牛角一时出则不相因。是故

  若使初后共　　是皆不然者
  何故而戏论　　谓有生老死

思惟生老死三皆有过故。即无生毕竟空。汝今何故贪着。戏论生老死。谓有决定相。复次

  诸所有因果　　相及可相法
  受及受者等　　所有一切法
  非但于生死　　本际不可得
  如是一切法　　本际皆亦无

一切法者。所谓因果相可相。受及受者等。皆无本际。非但生死无本际。以略开示故。说生死无本际

    中论观苦品第十二(十偈)

有人说曰

  自作及他作　　共作无因作
  如是说诸苦　　于果则不然

有人言。苦恼自作。或言他作。或言亦自作亦他作。或言无因作。于果皆不然。于果皆不然者。众生以众缘致苦。厌苦欲求灭。不知苦恼实因缘有四种谬。是故说于果皆不然何以故

  苦若自作者　　则不从缘生
  因有此阴故　　而有彼阴生

若苦自作。则不从众缘生。自名从自性生。是事不然。何以故。因前五阴有后五阴生。是故苦不得自作。问曰。若言此五阴作彼五阴者。则是他作。答曰。是事不然。何以故

  若谓此五阴　　异彼五阴者
  如是则应言　　从他而作苦

若此五阴与彼五阴异。彼五阴与此五阴异者。应从他作。如缕与布异者。应离缕有布。若离缕无布者。则布不异缕。如是彼五阴异此五阴者。则应离此五阴有彼五阴。若离此五阴无彼五阴者。则此五阴不异彼五阴。是故不应言苦从他作。问曰自作者。是人人自作苦。自受苦。答曰

  若人自作苦　　离苦何有人
  而谓于彼人　　而能自作苦

若谓人自作苦者。离五阴苦。何处别有人。而能自作苦。应说是人。而不可说。是故苦非人自作。若谓人不自作苦。他人作苦与此人。者是亦不然。何以故

  若苦他人作　　而与此人者
  若当离于苦　　何有此人受

若他人作苦。与此人者。离五阴无有此人受。复次

  苦若彼人作　　持与此人者
  离苦何有人　　而能授于此

若谓彼人作苦授与此人者。离五阴苦。何有彼人作苦持与此人。若有者应说其相。复次

  自作若不成　　云何彼作苦
  若彼人作苦　　即亦名自作

种种因缘彼自作苦不成而言他作苦。是亦不然。何以故。此彼相待故。若彼作苦于彼亦名自作苦。自作苦先已破。汝受自作苦不成故。他作亦不成。复次

  苦不名自作　　法不自作法
  彼无有自体　　何有彼作苦

自作苦不然。何以故。如刀不能自割。如是法不能自作法。是故不能自作。他作亦不然。何以故。离苦无彼自性。若离苦有彼自性者。应言彼作苦。彼亦即是苦。云何苦自作苦。问曰。若自作他作不然。应有共作。答曰

  若此彼苦成　　应有共作苦
  此彼尚无作　　何况无因作

自作他作犹尚有过。何况无因作。无因多过。如破作作者品中说。复次

  非但说于苦　　四种义不成
  一切外万物　　四义亦不成

佛法中虽说五受阴为苦。有外道人。谓苦受为苦。是故说。不但说于苦四种义不成。外万物。地水山木等。一切法皆亦不成

    中论观行品第十三(九偈)

问曰

  如佛经所说　　虚诳妄取相
  诸行妄取故　　是名为虚诳

佛经中说。虚诳者。即是妄取相。第一实者。所谓涅槃非妄取相。以是经说故。当知有诸行虚诳妄取相。答曰

  虚诳妄取者　　是中何所取
  佛说如是事　　欲以示空义

若妄取相法即是虚诳者。是诸行中为何所取。佛如是说。当知说空义。问曰。云何知一切诸行皆是空。答曰。一切诸行虚妄相故空。诸行生灭不住。无自性故空。诸行名五阴。从行生故。五阴名行。是五阴皆虚妄无有定相。何以故。如婴儿时色非匍匐时色。匍匐时色非行时色。行时色非童子时色。童子时色非壮年时色。壮年时色非老年时色。如色念念不住故。分别决定性不可得。婴儿色为即是匍匐色乃至老年色为异。二俱有过。何以故。若婴儿色即是匍匐色。乃至老年色者。如是则是一色皆为婴儿。无有匍匐乃至老年。又如泥团常是泥团终不作瓶。何以故。色常定故。若婴儿色异匍匐色者。则婴儿不作匍匐。匍匐不作婴儿。何以故。二色异故。如是童子少年壮年老年色不应相续。有失亲属法无父无子。若尔者。唯有婴儿应得父。余则匍匐乃至老年不应有分。是故二俱有过。问曰。色虽不定。婴儿色灭已。相续更生乃至老年色。无有如上过。答曰。婴儿色相续生者。为灭已相续生。为不灭相续生。若婴儿色灭。云何有相续。以无因故。如虽有薪可燃。火灭故无有相续。若婴儿色不灭而相续者。则婴儿色不灭。常住本相亦无相续。问曰。我不说灭不灭故相续生。但说不住相似生故言相续生。答曰。若尔者。则有定色而更生。如是应有千万种色。但是事不然。如是亦无相续。如是一切处求色无有定相。但以世俗言说故有。如芭蕉树求实不可得。但有皮叶。如是智者求色相。念念灭更无实色可得。不住色形色相。相似次第生难可分别。如灯炎分别定色不可得。从是定色更有色生不可得。是故色无性故空。但以世俗言说故有。受亦如是。智者种种观察。次第相似故生灭难可别知。如水流相续。但以觉故说三受在身。是故当知。受同色说。想因名相生。若离名相则不生。是故佛说。分别知名字相故名为想。非决定先有。从众缘生无定性。无定性故如影随形。因形有影。无形则无影。影无决定性。若定有者。离形应有影。而实不尔。是故从众缘生。无自性故不可得。想亦如是。但因外名相。以世俗言说故有。识因色声香味触等眼耳鼻舌身等生。以眼等诸根别异故。识有别异。是识为在色为在眼为在中间。无有决定。但生已识尘识此人识彼人。知此人识为即是知彼人识。为异是二难可分别。如眼识耳识亦难可分别。以难分别故。或言一或言异。无有决定分别。但从众缘生故。眼等分别故空无自性。如伎人含一珠出已复示人则生疑。为是本珠为更有异。识亦如是。生已更生。为是本识为是异识。是故当知。识不住故无自性。虚诳如幻。诸行亦如是。诸行者身口意。行有二种净不净。何等为不净。恼众生贪着等名不净。不恼众生实语不贪着等名净。或增或减。净行者。在人中欲天色天无色天受果报已则减。还作故名增。不净行者亦如是。在地狱畜生饿鬼阿修罗中受果报已则减。还作故名增。是故诸行有增有减故不住。如人有病。随宜将适病则除愈。不将适病则还集。诸行亦如是。有增有减故不决定。但以世俗言说故有。因世谛故得见第一义谛。所谓无明缘诸行。从诸行有识着。识着故有名色。从名色有六入。从六入有触。从触有受。从受有爱。从爱有取。从取有有。从有有生。从生有老死忧悲苦恼恩爱别苦怨憎会苦等。如是诸苦皆以行为本。佛以世谛故说。若得第一义谛生真智慧者则无明息。无明息故诸行亦不集。诸行不集故见谛所断身见疑戒取等断。及思惟所断贪恚色染无色染调戏无明亦断。以是断故一一分灭。所谓无明诸行识名色六入触受爱取有生老死忧悲苦恼恩爱别苦怨憎会苦等皆灭。以是灭故五阴身毕竟灭更无有余。唯但有空。是故佛欲示空义故。说诸行虚诳。复次诸法无性故虚诳。虚诳故空。如偈说

  诸法有异故　　知皆是无性
  无性法亦无　　一切法空故

诸法无有性。何以故。诸法虽生不住自性。是故无性。如婴儿定住自性者。终不作匍匐乃至老年。而婴儿次第相续有异相现匍匐乃至老年。是故说见诸法异相故知无性。问曰。若诸法异相无性即有无性法有何咎。答曰。若无性云何有法云何有相。何以故。无有根本故但为破性故说无性。是无性法若有者。不名一切法空。若一切法空。云何有无性法。问曰

  诸法若无性　　云何说婴儿
  乃至于老年　　而有种种异

诸法若无性则无有异相而汝说有异相。是故有诸法性若无诸法性云何有异相。答曰

  若诸法有性　　云何而得异
  若诸法无性　　云何而有异

若诸法决定有性。云何可得异性。名决定有不可变异。如真金不可变。又如暗性不变为明。明性不变为暗。复次

  是法则无异　　异法亦无异
  如壮不作老　　老亦不作壮

若法有异者。则应有异相。为即是法异。为异法异。是二不然。若即是法异。则老应作老。而老实不作老。若异法异者。老与壮异壮应作老。而壮实不作老。二俱有过。问曰。若法即异。有何咎。如今眼见年少经日月岁数则老。答曰

  若是法即异　　乳应即是酪
  离乳有何法　　而能作于酪

若是法即异者。乳应即是酪。更不须因缘。是事不然。何以故。乳与酪有种种异故。乳不即是酪。是故法不即异。若谓异法为异者。是亦不然。离乳更有何物为酪。如是思惟。是法不异。异法亦不异。是故不应偏有所执。问曰。破是破异犹有空在。空即是法。答曰

  若有不空法　　则应有空法
  实无不空法　　何得有空法

若有不空法。相因故应有空法。而上来种种因缘破不空法。不空法无故则无相待。无相待故何有空法。问曰。汝说不空法无故空法亦无。若尔者。即是说空。但无相待故不应有执。若有对应有相待。若无对则无相待。相待无故则无相。无相故则无执。如是即为说空。答曰

  大圣说空法　　为离诸见故
  若复见有空　　诸佛所不化

大圣为破六十二诸见。及无明爱等诸烦恼故说空。若人于空复生见者。是人不可化。譬如有病须服药可治。若药复为病则不可治。如火从薪出以水可灭。若从水生为用何灭。如空是水能灭诸烦恼火。有人罪重贪着心深。智慧钝故。于空生见。或谓有空。或谓无空。因有无还起烦恼。若以空化此人者。则言我久知是空。若离是空则无涅槃道。如经说。离空无相无作门。得解脱者。但有言说

    中论观合品第十四(八偈)

说曰。上破根品中。说见所见见者皆不成。此三事无异法故则无合。无合义今当说。问曰。何故眼等三事无合。答曰

  见可见见者　　是三各异方
  如是三法异　　终无有合时

见是眼根。可见是色尘。见者是我。是三事各在异处终无合时。异处者。眼在身内色在身外。我者或言在身内。或言遍一切处。是故无合。复次若谓有见法。为合而见不合而见。二俱不然。何以故。若合而见者。随有尘处应有根有我。但是事不然。是故不合。若不合而见者。根我尘各在异处亦应有见。而不见。何以故。如眼根在此不见远处瓶。是故二俱不见。问曰。我意根尘。四事合故有知生。能知瓶衣等万物。是故有见可见见者。答曰。是事根品中已破。今当更说。汝说四事合故知生。是知为见瓶衣等物已生。为未见而生。若见已生者。知则无用。若未见而生者。是则未合。云何有知生。若谓四事一时合而知生。是亦不然。若一时生则无相待。何以故。先有瓶次见后知生。一时则无先后。知无故见可见见者亦无。如是诸法如幻如梦无有定相。何得有合。无合故空。复次

  染与于可染　　染者亦复然
  余入余烦恼　　皆亦复如是

如见可见见者无合故。染可染染者亦应无合。如说见可见见者三法。则说闻可闻闻者余入等。如说染可染染者。则说嗔可嗔嗔者余烦恼等。复次

  异法当有合　　见等无有异
  异相不成故　　见等云何合

凡物皆以异故有合。而见等异相不可得。是故无合。复次

  非但见等法　　异相不可得
  所有一切法　　皆亦无异相

非但见可见见者等三事异相不可得。一切法皆无异相。问曰。何故无有异相。答曰

  异因异有异　　异离异无异
  若法从因出　　是法不异因

汝所谓异。是异因异法故名为异。离异法不名为异。何以故。若法从众缘生。是法不异因。因坏果亦坏故。如因梁椽等有舍。舍不异梁椽。梁椽等坏舍亦坏故。问曰。若有定异法。有何咎。答曰

  若离从异异　　应余异有异
  离从异无异　　是故无有异

若离从异有异法者。则应离余异有异法。而实离从异无有异法。是故无余异。如离五指异有拳异者拳异。应于瓶等异物有异。今离五指异。拳异不可得。是故拳异。于瓶等无有异法。问曰。我经说。异相不从众缘生。分别总相故有异相。因异相故有异法。答曰

  异中无异相　　不异中亦无
  无有异相故　　则无此彼异

汝言分别总相故有异相。因异相故有异法。若尔者。异相从众缘生。如是即说众缘法。是异相离异法不可得故。异相因异法而有。不能独成。今异法中无异相。何以故。先有异法故何用异相。不异法中亦无异相。何以故。若异相在不异法中。不名不异法。若二处俱无。即无异相。异相无故此彼法亦无。复次异法无故亦无合

  是法不自合　　异法亦不合
  合者及合时　　合法亦皆无

是法自体不合。以一故。如一指不自合。异法亦不合。以异故。异事已成不须合故。如是思惟。合法不可得。是故说合者合时合法。皆不可得

中论卷第二中论卷第三

        龙树菩萨造梵志青目释

        姚秦三藏鸠摩罗什译

    观有无品第十五(十一偈)

问曰。诸法各有性。以有力用故。如瓶有瓶性布有布性。是性众缘合时则出。答曰

  众缘中有性　　是事则不然
  性从众缘出　　即名为作法

若诸法有性。不应从众缘出。何以故。若从众缘出。即是作法无有定性。问曰。若诸法性从众缘作。有何咎。答曰

  性若是作者　　云何有此义
  性名为无作　　不待异法成

如金杂铜则非真金。如是若有性则不须众缘。若从众缘出当知无真性。又性若决定。不应待他出。非如长短彼此无定性故待他而有。问曰。诸法若无自性。应有他性。答曰

  法若无自性　　云何有他性
  自性于他性　　亦名为他性

诸法性众缘作故。亦因待成故无自性。若尔者。他性于他亦是自性。亦从众缘生相待故。亦无无故。云何言诸法从他性生。他性亦是自性故。问曰。若离自性他性有诸法。有何咎。答曰

  离自性他性　　何得更有法
  若有自他性　　诸法则得成

汝说离自性他性有法者。是事不然。若离自性他性则无有法何以故。有自性他性法则成。如瓶体是自性依物是他性。问曰。若以自性他性破有者。今应有无。答曰

  有若不成者　　无云何可成
  因有有法故　　有坏名为无

若汝已受有不成者。亦应受无亦无。何以故。有法坏败故名无。是无因有坏而有。复次

  若人见有无　　见自性他性
  如是则不见　　佛法真实义

若人深着诸法。必求有见。若破自性则见他性。若破他性则见有。若破有则见无。若破无则迷惑。若利根着心薄者。知灭诸见安隐故。更不生四种戏论。是人则见佛法真实义。是故说上偈。复次

  佛能灭有无　　如化迦旃延
  经中之所说　　离有亦离无

删陀迦旃延经中。佛为说正见义离有离无。若诸法中少决定有者。佛不应破有无。若破有则人谓为无。佛通达诸法相故。说二俱无。是故汝应舍有无见。复次

  若法实有性　　后则不应异
  性若有异相　　是事终不然

若诸法决定有性。终不应变异。何以故。若定有自性。不应有异相。如上真金喻。今现见诸法有异相故。当知无有定相。复次

  若法实有性　　云何而可异
  若法实无性　　云何而可异

若法定有性。云何可变异。若无性则无自体。云何可变异。复次

  定有则着常　　定无则着断
  是故有智者　　不应著有无

若法定有有相。则终无无相。是即为常。何以故。如说三世者。未来中有法相。是法来至现在。转入过去。不舍本相。是则为常。又说因中先有果。是亦为常。若说定有无。是无必先有今无。是则为断灭。断灭名无相续。因由是二见。即远离佛法。问曰。何故因有生常见。因无生断见。答曰

  若法有定性　　非无则是常
  先有而今无　　是则为断灭

若法性定有。则是有相非无相。终不应无。若无则非有。即为无法。先已说过故。如是则堕常见。若法先有。败坏而无者。是名断灭。何以故。有不应无故。汝谓有无各有定相故。若有断常见者。则无罪福等破世间事是故应舍

    中论观缚解品第十六(十偈)

问曰。生死非都无根本。于中应有众生往来若诸行往来。汝以何因缘故。说众生及诸行尽空无有往来。答曰

  诸行往来者　　常不应往来
  无常亦不应　　众生亦复然

诸行往来六道生死中者。为常相往来。为无常相往来。二俱不然。若常相往来者。则无生死相续。以决定故。自性住故。若以无常往来者。亦无往来生死相续。以不决定故。无自性故。若众生往来者。亦有如是过。复次

  若众生往来　　阴界诸入中
  五种求尽无　　谁有往来者

生死阴界入即是一义。若众生于此阴界入中往来者。是众生于燃可燃品中。五种求不可得。谁于阴界入中而有往来者。复次

  若从身至身　　往来即无身
  若其无有身　　则无有往来

若众生往来。为有身往来。为无身往来。二俱不然。何以故。若有身往来。从一身至一身。如是则往来者无身。又若先已有身。不应复从身至身。若先无身则无有。若无有云何有生死往来。问曰。经说有涅槃灭一切苦。是灭应诸行灭若众生灭。答曰。二俱不然。何以故

  诸行若灭者　　是事终不然
  众生若灭者　　是事亦不然

汝说若诸行灭若众生灭。是事先已答。诸行无有性。众生亦种种推求生死往来不可得。是故诸行不灭。众生亦不灭。问曰。若尔者则无缚无解。根本不可得故。答曰

  诸行生灭相　　不缚亦不解
  众生如先说　　不缚亦不解

汝谓诸行及众生有缚解者。是事不然。诸行念念生灭故。不应有缚解。众生先说五种推求不可得。云何有缚解。复次

  若身名为缚　　有身则不缚
  无身亦不缚　　于何而有缚

若谓五阴身名为缚。若众生先有五阴。则不应缚。何以故。一人有二身故。无身亦不应缚。何以故。若无身则无五阴。无五阴则空。云何可缚。如是第三更无所缚。复次

  若可缚先缚　　则应缚可缚
  而先实无缚　　余如去来答

若谓可缚先有缚。则应缚可缚。而实离可缚先无缚。是故不得言众生有缚。或言。众生是可缚。五阴是缚。或言。五阴中诸烦恼是缚。余五阴是可缚。是事不然。何以故。若离五阴先有众生者。则应以五阴缚众生。而实离五阴无别众生。若离五阴别有烦恼者则应以烦恼缚五阴。而实离五阴无别烦恼。复次如去来品中说。已去不去。未去不去。去时不去。如是未缚不缚。缚已不缚。缚时不缚。复次亦无有解。何以故

  缚者无有解　　无缚亦无解
  缚时有解者　　缚解则一时

缚者无有解。何以故。已缚故。无缚亦无解。何以故。无缚故。若谓缚时有解。则缚解一时。是事不然。又缚解相违故。问曰。有人修道现入涅槃得解脱。云何言无。答曰

  若不受诸法　　我当得涅槃
  若人如是者　　还为受所缚

若人作是念。我离受得涅槃。是人即为受所缚。复次

  不离于生死　　而别有涅槃
  实相义如是　　云何有分别

诸法实相第一义中。不说离生死别有涅槃。如经说。涅槃即生死。生死即涅槃。如是诸法实相中。云何言是生死是涅槃

    中论观业品第十七(三十三偈)

问曰。汝虽种种破诸法。而业决定有。能令一切众生受果报。如经说。一切众生皆随业而生。恶者入地狱。修福者生天。行道者得涅槃。是故一切法不应空。所谓业者

  人能降伏心　　利益于众生
  是名为慈善　　二世果报种

人有三毒。为恼他故生行。善者先自灭恶。是故说降伏其心利益他人。利益他者。行布施持戒忍辱等不恼众生。是名利益他。亦名慈善福德。亦名今世后世乐果种子。复次

  大圣说二业　　思与从思生
  是业别相中　　种种分别说

大圣略说业有二种。一者思。二者从思生。是二业如阿毗昙中广说。

  佛所说思者　　所谓意业是
  所从思生者　　即是身口业

思是心数法。诸心数法中能发起有所作故名业。因是思故起外身口业。虽因余心心数法有所作。但思为所作本。故说思为业。是业今当说相

  身业及口业　　作与无作业
  如是四事中　　亦善亦不善
  从用生福德　　罪生亦如是
  及思为七法　　能了诸业相

口业者四种口业。身业者。三种身业。是七种业有二种差别。有作有无作。作时名作业。作已常随逐生名无作业。是二种有善不善。不善名不止恶。善名止恶。复有从用生福德。如施主施受者。若受者受用。施主得二种福。一从施生。二从用生。如人以箭射人。若箭杀人有二种罪。一者从射生。二者从杀生。若射不杀。射者但得射罪。无杀罪。是故偈中说罪福从用生。如是名为六种业。第七名思。是七种即是分别业相。是业有今世后世果报。是故决定有业有果报故。诸法不应空。答曰

  业住至受报　　是业即为常
  若灭即无业　　云何生果报

业若住至受果报。即为是常。是事不然。何以故。业是生灭相。一念尚不住。何况至果报。若谓业灭。灭则无。云何能生果报。问曰

  如芽等相续　　皆从种子生
  从是而生果　　离种无相续
  从种有相续　　从相续有果
  先种后有果　　不断亦不常
  如是从初心　　心法相续生
  从是而有果　　离心无相续
  从心有相续　　从相续有果
  先业后有果　　不断亦不常

如从谷有芽。从芽有茎叶等相续。从是相续而有果生。离种无相续生。是故从谷子有相续。从相续有果。先种后有果。故不断亦不常。如谷种喻。业果亦如是。初心起罪福。犹如谷种。因是心余心心数法相续生。乃至果报。先业后果故不断亦不常。若离业有果报。则有断常。是善业因缘果报者。所谓

  能成福德者　　是十白业道
  二世五欲乐　　即是白业报

白名善净。成福德因缘者。从是十白业道。生不杀不盗不邪淫不妄语不两舌不恶口不无益语不嫉不恚不邪见。是名为善。从身口意生是果报者。得今世名利。后世天人中贵处生。布施恭敬等虽有种种福德。略说则摄在十善道中。答曰

  若如汝分别　　其过则甚多
  是故汝所说　　于义则不然

若以业果报相续故。以谷子为喻者。其过甚多。但此中不广说。汝说谷子喻者。是喻不然。何以故。谷子有触有形。可见有相续。我思惟是事。尚未受此言。况心及业。无触无形不可见。生灭不住欲以相续。是事不然。复次从谷子有芽等相续者。为灭已相续。为不灭相续。若谷子灭已相续者。则为无因。若谷子不灭而相续者。从是谷子常生诸谷。若如是者。一谷子则生一切世间谷。是事不然。是故业果报相续则不然。问曰

  今当复更说　　顺业果报义
  诸佛辟支佛　　贤圣所称叹

所谓

  不失法如券　　业如负财物
  此性则无记　　分别有四种
  见谛所不断　　但思惟所断
  以是不失法　　诸业有果报
  若见谛所断　　而业至相似
  则得破业等　　如是之过咎
  一切诸行业　　相似不相似
  一界初受身　　尔时报独生
  如是二种业　　现世受果报
  或言受报已　　而业犹故在
  若度果已灭　　若死已而灭
  于是中分别　　有漏及无漏

不失法者。当知如券。业者如取物。是不失法。欲界系色界系无色界系亦不系。若分别善不善无记中。但是无记。是无记义阿毗昙中广说。见谛所不断。从一果至一果。于中思惟所断。是以诸业。以不失法故果生。若见谛所断而业至相似。则得破业过。是事阿毗昙中广说。复次不失法者。于一界诸业相似不相似。初受身时果报独生。于现在身从业更生业。是业有二种。随重而受报。或有言。是业受报已业犹在。以不念念灭故。若度果已灭。若死已而灭者。须陀洹等度果已而灭。诸凡夫及阿罗汉死已而灭。于此中分别有漏及无漏者。从须陀洹等诸贤圣。有漏无漏等应分别。答曰。是义俱不离断常过。是故亦不应受。问曰。若尔者。则无业果报。答曰

  虽空亦不断　　虽有亦不常
  业果报不失　　是名佛所说

此论所说义。离于断常。何以故。业毕竟空寂灭相。自性离有何法可断何法可失。颠倒因缘故往来生死。亦不常。何以故。若法从颠倒起。则是虚妄无实。无实故非常。复次贪着颠倒不知实相故。言业不失。此是佛所说。复次

  诸业本不生　　以无定性故
  诸业亦不灭　　以其不生故
  若业有性者　　是则名为常
  不作亦名业　　常则不可作
  若有不作业　　不作而有罪
  不断于梵行　　而有不净过
  是则破一切　　世间语言法
  作罪及作福　　亦无有差别
  若言业决定　　而自有性者
  受于果报已　　而应更复受
  若诸世间业　　从于烦恼生
  是烦恼非实　　业当何有实

第一义中诸业不生。何以故。无性故。以不生因缘故则不灭。非以常故不灭。若不尔者。业性应决定有。若业决定有性。则为是常。若常则是不作业。何以故。常法不可作故。复次若有不作业者。则他人作罪此人受报。又他人断梵行而此人有罪。则破世俗法。若先有者。冬不应思为春事。春不应思为夏事。有如是等过。复次作福及作罪者。则无有别异。起布施持戒等业。名为作福。起杀盗等业。名为作罪。若不作而有业。则无有分别。复次是业若决定有性。则一时受果报已。复应更受。是故汝说以不失法故有业报。则有如是等过。复次若业从烦恼起。是烦恼无有决定。但从忆想分别有。若诸烦恼无实。业云何有实。何以故。因无性故业亦无性。问曰。若诸烦恼及业无性不实。今果报身现有。应是实。答曰。

  诸烦恼及业　　是说身因缘
  烦恼诸业空　　何况于诸身

诸贤圣说。烦恼及业是身因缘。是中爱能润生。业能生上中下好丑贵贱等果报。今诸烦恼及业。种种推求无有决定。何况诸身有决定果。随因缘故。问曰。汝虽种种因缘破业及果报。而经说。有起业者。起业者有故。有业有果报。如说

  无明之所蔽　　爱结之所缚
  而于本作者　　不即亦不异

无始经中说。众生为无明所覆。爱结所缚。于无始生死中。往来受种种苦乐。今受者于先作者。不即是亦不异。若即是人作罪受牛形。则人不作牛。牛不作人。若异则失业果报堕于无因。无因则断灭。是故今受者于先作者。不即是亦不异。答曰

  业不从缘生　　不从非缘生
  是故则无有　　能起于业者
  无业无作者　　何有业生果
  若其无有果　　何有受果者

若无业无作业者。何有从业生果报。若无果报。云何有受果报者。业有三种。五阴中假名人是作者。是业于善恶处生。名为果报。若起业者尚无。何况有业有果报及受果报者。问曰。汝虽种种破业果报及起业者。而今现见众生作业受果报。是事云何。答曰

  如世尊神通　　所作变化人
  如是变化人　　复变作化人
  如初变化人　　是名为作者
  变化人所作　　是则名为业
  诸烦恼及业　　作者及果报
  皆如幻与梦　　如炎亦如向

如佛神通力所作化人。是化人复化作化人。如化人无有实事但可眼见。又化人口业说法。身业布施等。是业虽无实而可眼见。如是生死身作者及业。亦应如是知。诸烦恼者。名为三毒。分别有九十八使九结十缠六垢等无量诸烦恼。业名为身口意业。今世后世分别有善不善无记。苦报乐报不苦不乐报。现报业生报业后报业。如是等无量作者。名为能起诸烦恼业能受果报者。果报名从善恶业生无记五阴。如是等诸业皆空无性。如幻如梦。如炎如向

    中论观法品第十八(十二偈)

问曰。若诸法尽毕竟空无生无灭。是名诸法实相者。云何入。答曰。灭我我所著故。得一切法空。无我慧名为入。问曰。云何知诸法无我。答曰

  若我是五阴　　我即为生灭
  若我异五阴　　则非五阴相
  若无有我者　　何得有我所
  灭我我所故　　名得无我智
  得无我智者　　是则名实观
  得无我智者　　是人为希有
  内外我我所　　尽灭无有故
  诸受即为灭　　受灭则身灭
  业烦恼灭故　　名之为解脱
  业烦恼非实　　入空戏论灭
  诸佛或说我　　或说于无我
  诸法实相中　　无我无非我
  诸法实相者　　心行言语断
  无生亦无灭　　寂灭如涅槃
  一切实非实　　亦实亦非实
  非实非非实　　是名诸佛法
  自知不随他　　寂灭无戏论
  无异无分别　　是则名实相
  若法从缘生　　不即不异因
  是故名实相　　不断亦不常
  不一亦不异　　不常亦不断
  是名诸世尊　　教化甘露味
  若佛不出世　　佛法已灭尽
  诸辟支佛智　　从于远离生

有人说神。应有二种。若五阴即是神。若离五阴有神。若五阴是神者神则生灭相。如偈中说。若神是五阴即是生灭相。何以故。生已坏败故。以生灭相故。五阴是无常。如五阴无常。生灭二法亦是无常。何以故。生灭亦生已坏败故无常。神若是五阴。五阴无常故。神亦应无常生灭相。但是事不然。若离五阴有神。神即无五阴相。如偈中说。若神异五阴。则非五阴相。而离五阴更无有法。若离五阴有法者。以何相何法而有。若谓神如虚空离五阴而有者。是亦不然。何以故。破六种品中已破。虚空无有法名为虚空。若谓以有信故有神。是事不然。何以故。信有四种。一现事可信。二名比知可信。如见烟知有火。三名譬喻可信。如国无鋀石喻之如金。四名贤圣所说故可信。如说有地狱有天有郁单曰。无有见者。信圣人语故知。是神于一切信中不可得。现事中亦无。比知中亦无。何以故。比知。名先见故后比类而知。如人先见火有烟。后但见烟则知有火。神义不然。谁能先见神与五阴合。后见五阴知有神。若谓有三种比知。一者如本。二者如残。三者共见。如本。名先见火有烟。今见烟知如本有火。如残。名如炊饭一粒熟知余者皆熟。共见。名如眼见人从此去到彼亦见其去。日亦如是。从东方出至西方。虽不见去以人有去相故。知日亦有去。如是苦乐憎爱觉知等。亦应有所依。如见人民知必依王。是事皆不然。何以故。共相信先见人与去法合而至余方。后见日到余方故知有去法。无有先见五阴与神合后见五阴知有神。是故共相比知中亦无神。圣人所说中亦无神。何以故。圣人所说。皆先眼见而后说。又诸圣人说余事可信故。当知说地狱等亦可信。而神不尔。无有先见神而后说者。是故于四信等诸信中。求神不可得。求神不可得故无。是故离五阴无别神。复次破根品中。见见者可见破故。神亦同破。又眼见粗法尚不可得。何况虚妄忆想等而有神。是故知无我。因有我故有我所。若无我则无我所。修习八圣道分。灭我我所因缘故。得无我无我所决定智慧

又无我无我所者。于第一义中亦不可得。无我无我所者。能真见诸法。凡夫人以我我所障慧眼故。不能见实。今圣人无我我所故。诸烦恼亦灭。诸烦恼灭故。能见诸法实相。内外我我所灭故诸受亦灭。诸受灭故无量后身皆亦灭。是名说无余涅槃。问曰。有余涅槃云何。答曰。诸烦恼及业灭故。名心得解脱。是诸烦恼业。皆从忆想分别生无有实。诸忆想分别皆从戏论生。得诸法实相毕竟空。诸戏论则灭。是名说有余涅槃。实相法如是。诸佛以一切智观众生故。种种为说。亦说有我亦说无我。若心未熟者。未有涅槃分。不知畏罪。为是等故说有我。又有得道者。知诸法空但假名有我。为是等故说我无咎。又有布施持戒等福德。厌离生死苦恼畏涅槃永灭。是故佛为是等说无我。诸法但因缘和合。生时空生。灭时空灭。是故说无我。但假名说有我。又得道者。知无我不堕断灭故说无我无咎。是故偈中说。诸佛说有我亦说于无我。若于真实中不说我非我。问曰。若无我是实。但以世俗故说有我。有何咎。答曰。因破我法有无我。我决定不可得。何有无我。若决定有无我。则是断灭生于贪着。如般若中说菩萨有我亦非行。无我亦非行。问曰。若不说我非我空不空。佛法为何所说。答曰。佛说诸法实相。实相中无语言道。灭诸心行。心以取相缘。生以先世业果报故有。不能实见诸法。是故说心行灭。问曰。若诸凡夫心不能见实。圣人心应能见实。何故说一切心行灭。答曰。诸法实相即是涅槃。涅槃名灭。是灭为向涅槃故亦名为灭。若心是实。何用空等解脱门。诸禅定中。何故以灭尽定为第一。又亦终归无余涅槃。是故当知。一切心行皆是虚妄。虚妄故应灭。诸法实相者。出诸心数法。无生无灭寂灭相。如涅槃。问曰经中说。诸法先来寂灭相即是涅槃。何以言如涅槃。答曰。着法者。分别法有二种。是世间是涅槃。说涅槃是寂灭不说世间是寂灭。此论中说一切法性空寂灭相。为着法者不解故。以涅槃为喻。如汝说涅槃相空无相寂灭无戏论。一切世间法亦如是

问曰。若佛不说我非我。诸心行灭。言语道断者。云何令人知诸法实相。答曰。诸佛无量方便力。诸法无决定相。为度众生或说一切实。或说一切不实。或说一切实不实。或说一切非实非不实。一切实者。推求诸法实性。皆入第一义平等一相。所谓无相。如诸流异色异味入于大海则一色一味。一切不实者。诸法未入实相时。各各分别观皆无有实。但众缘合故有。一切实不实者。众生有三品有上中下。上者观诸法相非实非不实。中者观诸法相一切实一切不实。下者智力浅故。观诸法相少实少不实。观涅槃无为法不坏故实。观生死有为法虚伪故不实。非实非不实者。为破实不实故。说非实非不实。问曰。佛于余处。说离非有非无。此中何以言非有非无是佛所说。答曰。余处为破四种贪着故说。而此中于四句无戏论。闻佛说则得道。是故言非实非不实。问曰。知佛以是四句因缘说。又得诸法实相者以何相可知。又实相云何。答曰。若能不随他。不随他者。若外道虽现神力说是道是非道。自信其心而不随之。乃至变身虽不知非佛。善解实相故心不可回。此中无法可取可舍故。名寂灭相。寂灭相故。不为戏论所戏论。戏论有二种。一者爱论。二者见论。是中无此二戏论。二戏论无故。无忆想分别。无别异相。是名实相。问曰。若诸法尽空。将不堕断灭耶。又不生不灭或堕常耶。答曰不然。先说实相无戏论。心相寂灭言语道断。汝今贪着取相。于实相法中见断常过。得实相者。说诸法从众缘生。不即是因亦不异因。是故不断不常。若果异因则是断。若不异因则是常。问曰。若如是解有何等利。答曰。若行道者。能通达如是义。则于一切法。不一不异不断不常。若能如是。即得灭诸烦恼戏论。得常乐涅槃。是故说诸佛以甘露味教化。如世间言得天甘露浆。则无老病死无诸衰恼。此实相法是真甘露味。佛说实相有三种。若得诸法实相。灭诸烦恼。名为声闻法。若生大悲发无上心。名为大乘。若佛不出世。无有佛法时。辟支佛因远离生智。若佛度众生已。入无余涅槃。遗法灭尽。先世若有应得道者。少观厌离因缘。独入山林远离愦闹得道。名辟支佛

    中论观时品第十九(六偈)

问曰。应有时以因待故成。因有过去时。则有未来现在时。因现在时。有过去未来时。因未来时。有过去现在时。上中下一异等法。亦相因待故有。答曰

  若因过去时　　有未来现在
  未来及现在　　应在过去时

若因过去时。有未来现在时者。则过去时中。应有未来现在时。何以故。随所因处有法成。是处应有是法。如因灯有明成。随有灯处应有明。如是因过去时。成未来现在时者。则过去时中。应有未来现在时。若过去时中。有未来现在时者。则三时尽名过去时。何以故。未来现在时。在过去时中故。若一切时尽过去者。则无未来现在时。尽过去故。若无未来现在时。亦应无过去时。何以故。过去时因未来现在时故。名过去时。如因过去时成未来现在时。如是亦应因未来现在时成过去时。今无未来现在时故。过去时亦应无。是故先说。因过去时成未来现在时。是事不然。若谓过去时中无未来现在时。而因过去时成未来现在时。是事不然。何以故

  若过去时中　　无未来现在
  未来现在时　　云何因过去

若未来现在时。不在过去时中者。云何因过去时。成未来现在时。何以故。若三时各异相。不应相因待成。如瓶衣等物各自别成不相因待。而今不因过去时。则未来现在时不成。不因现在时。则过去未来时不成。不因未来时。则过去现在时不成。汝先说过去时中。虽无未来现在时。而因过去时。成未来现在时者。是事不然。问曰。若不因过去时。成未来现在时。而有何咎。答曰

  不因过去时　　则无未来时
  亦无现在时　　是故无二时

不因过去时。则不成未来现在时。何以故。若不因过去时。有现在时者。于何处有现在时。未来亦如是。于何处有未来时。是故不因过去时。则无未来现在时。如是相待有故。实无有时

  以如是义故　　则知余二时
  上中下一异　　是等法皆无

以如是义故。当知余未来现在亦应无。及上中下一异等诸法亦应皆无。如因上有中下。离上则无中下。若离上有中下。则不应相因待。因一故有异。因异故有一。若一实有不应因异而有。若异实有。不应因一而有。如是等诸法。亦应如是破。问曰。如有岁月日须臾等差别故知有时。答曰

  时住不可得　　时去亦叵得
  时若不可得　　云何说时相
  因物故有时　　离物何有时
  物尚无所有　　何况当有时

时若不住不应可得。时住亦无。若时不可得。云何说时相。若无时相则无时。因物生故则名时。若离物则无时。上来种种因缘破诸物。物无故何有时

    中论观因果品第二十(二十四偈)

问曰。众因缘和合现有果生故。当知是果从众缘和合有。答曰

  若众缘和合　　而有果生者
  和合中已有　　何须和合生

若谓众因缘和合有果生。是果则和合中已有。而从和合生者。是事不然。何以故。果若先有定体。则不应从和合生。问曰。众缘和合中虽无果。而果从众缘生者。有何咎。答曰

  若众缘和合　　是中无果者
  云何从众缘　　和合而果生

若从众缘和合则果生者。是和合中无果。而从和合生。是事不然。何以故。若物无自性。是物终不生复次

  若众缘和合　　是中有果者
  和合中应有　　而实不可得

若从众缘和合中有果者。若色应可眼见。若非色应可意知。而实和合中果不可得。是故和合中有果。是事不然。复次

  若众缘和合　　是中无果者
  是则众因缘　　与非因缘同

若众缘和合中无果者。则众因缘即同非因缘。如乳是酪因缘。若乳中无酪。水中亦无酪。若乳中无酪则与水同。不应言但从乳出。是故众缘和合中无果者。是事不然。问曰。因为果作因已灭。而有因果。无如是咎。答曰

  若因与果因　　作因已而灭
  是因有二体　　一与一则灭

若因与果作因已而灭者是因则有二体。一谓与因。二谓灭因。是事不然。一法有二体故。是故因与果作因已而灭。是事不然。问曰。若谓因不与果作因已而灭。亦有果生。有何咎。答曰

  若因不与果　　作因已而灭
  因灭而果生　　是果则无因

若是因不与果。作因已而灭者。则因灭已而果生。是果则无因。是事不然。何以故。现见一切果。无有无因生者。是故汝说因不与果作因已而灭亦有果生者。是事不然。问曰。众缘合时而有果生者。有何咎。答曰

  若众缘合时　　而有果生者
  生者及可生　　则为一时俱

若众缘合时有果生者。则生者可生即一时俱。但是事不尔何以故。如父子不得一时生。是故汝说众缘合时有果生者。是事不然。问曰。若先有果生。而后众缘合。有何咎。答曰

  若先有果生　　而后众缘合
  此即离因缘　　名为无因果

若众缘未合。而先有果生者。是事不然。果离因缘故。则名无因果。是故汝说众缘未合时先有果生者。是事则不然。问曰。因灭变为果者。有何咎。答曰

  若因变为果　　因即至于果
  是则前生因　　生已而复生

因有二种。一者前生。二者共生。若因灭变为果。是前生因应还更生。但是事不然。何以故。已生物不应更生。若谓是因即变为果。是亦不然。何以故。若即是不名为变。若变不名即是。问曰。因不尽灭但名字灭。而因体变为果。如泥团变为瓶。失泥团名而瓶名生。答曰。泥团先灭而有瓶生。不名为变。又泥团体不独生。瓶盆瓮等皆从泥中出。若泥团但有名。不应变为瓶。变名如乳变为酪。是故汝说因名虽灭而变为果。是事不然。问曰。因虽灭失而能生果。是故有果。无如是咎。答曰

  云何因灭失　　而能生于果
  又若因在果　　云何因生果

若因灭失已。云何能生果。若因不灭而与果合。何能更生果。问曰。是因遍有果而果生。答曰

  若因遍有果　　更生何等果
  因见不见果　　是二俱不生

是因若不见果。尚不应生果。何况见。若因自不见果。则不应生果。何以故。若不见果。果则不随因。又未有果。云何生果若因先见果。不应复生。果已有故。复次

  若言过去因　　而于过去果
  未来现在果　　是则终不合
  若言未来因　　而于未来果
  现在过去果　　是则终不合
  若言现在因　　而于现在果
  未来过去果　　是则终不合

过去果不与过去未来现在因合。未来果不与未来现在过去因合。现在果不与现在未来过去因合。如是三种果。终不与过去未来现在因合。复次

  若不和合者　　因何能生果
  若有和合者　　因何能生果

若因果不和合则无果。若无果云何因能生果。若谓因果和合时因能生果者。是亦不然。何以故。若果在因中。则因中已有果。云何而复生。复次

  若因空无果　　因何能生果
  若因不空果　　因何能生果

若因无果者。以无果故因空。云何因生果。如人不怀妊。云何能生子。若因先有果。已有果故不应复生。复次今当说果

  果不空不生　　果不空不灭
  以果不空故　　不生亦不灭
  果空故不生　　果空故不灭
  以果是空故　　不生亦不灭

果若不空。不应生不应灭。何以故。果若因中先决定有。更不须复生。生无故无灭。是故果不空故。不生不灭。若谓果空故有生灭。是亦不然。何以故。果若空。空名无所有。云何当有生灭。是故说果空故不生不灭。复次今以一异破因果

  因果是一者　　是事终不然
  因果若异者　　是事亦不然
  若因果是一　　生及所生一
  若因果是异　　因则同非因
  若果定有性　　因为何所生
  若果定无性　　因为何所生
  因不生果者　　则无有因相
  若无有因相　　谁能有是果
  若从众因缘　　而有和合生
  和合自不生　　云何能生果
  是故果不从　　缘合不合生
  若无有果者　　何处有合法

是众缘和合法。不能生自体。自体无故云何能生果。是故果不从缘合生。亦不从不合生。若无有果者。何处有合法

    中论观成坏品第二十一(二十偈)

问曰。一切世间事现是坏败相。是故有坏。答曰

  离成及共成　　是中无有坏
  离坏及共坏　　是中亦无成

若有成若无成俱无坏。若有坏若无坏俱无成。何以故

  若离于成者　　云何而有坏
  如离生有死　　是事则不然
  成坏共有者　　云何有成坏
  如世间生死　　一时俱不然
  若离于坏者　　云何当有成
  无常未曾有　　不在诸法时

若离成坏不可得。何以故。若离成有坏者。则不因成有坏。坏则无因。又无成法而可坏。成名众缘合。坏名众缘散。若离成有坏者。无成谁当坏。如无瓶不得言瓶坏。是故离成无坏。若谓共成有坏者。是亦不然。何以故。法先别成而后有合。合法不离异。若坏离异坏则无因。是故共成亦无坏。若离坏共坏无有成者。若离坏有成成则为常。常是不坏相。而实不见有法常不坏相。是故离坏无成。若谓共坏有成者。是亦不然。成坏相违。云何一时有。如人有发无发不得一时俱。成坏亦尔。是故共坏有成。是事不然。何以故。若谓分别法者。说成中常有坏。是事不然。何以故。若成中常有坏。则不应有住法。而实有住。是故若离坏共坏不应有成。复次

  成坏共无成　　离亦无有成
  是二俱不可　　云何当有成

若成坏共亦无成。离亦无成。若共成则二法相违。云何一时。若离则无因。二门俱不成。云何当有成。若有应说。问曰现有尽灭相法。是尽灭相法。亦说尽亦说不尽。如是则应有成坏。答曰

  尽则无有成　　不尽亦无成
  尽则无有坏　　不尽亦不坏

诸法日夜中念念常灭尽过去。如水流不住。是则名尽。是事不可取不可说。如野马无决定性可得。如是尽无决定性可得。云何可得分别说有成。是故言尽亦不成。成无故亦不应有坏。是故说尽亦无有坏。又念念生灭常相续不断故名不尽。如是法决定常住不断。云何可得分别说言今是成时。是故说无尽亦无成。成无故无坏。是故说不尽亦无坏。如是推求。实事不可得故。无成无坏。问曰。且置成坏。但令有法有何咎。答曰

  若离于成坏　　是亦无有法
  若当离于法　　亦无有成坏

离成坏无法者。若法无成无坏。是法应或无或常。而世间无有常法。汝说离成坏有法。是事不然。问曰。若离法但有成坏。有何咎。答曰。离法有成坏。是亦不然。何以故。若离法谁成谁坏。是故离法有成坏。是事不然。复次

  若法性空者　　谁当有成坏
  若性不空者　　亦无有成坏

若诸法性空。空何有成坏。若诸法性不空。不空则决定有。亦不应有成坏。复次

  成坏若一者　　是事则不然
  成坏若异者　　是事亦不然

推求成坏一则不可得。何以故。异相故。种种分别故。又成坏异亦不可得。何以故。无有别故。亦无因故。复次

  若谓以眼见　　而有生灭者
  则为是痴妄　　而见有生灭

若谓以眼见有生灭者。云何以言说破。是事不然。何以故。眼见生灭者。则是愚痴颠倒故。见诸法性空无决定如幻如梦。但凡夫先世颠倒因缘得此眼。今世忆想分别因缘故。言眼见生灭。第一义中实无生灭。是事已于破相品中广说。复次

  从法不生法　　亦不生非法
  从非法不生　　法及于非法

从法不生法者。若失若至二俱不然。从法生法。若至若失是则无因。无因则堕断常。若已至从法生法。是法至已而名为生。则为是常。又生已更生。又亦无因生。是事不然。若已失从法生法者。是则失因。生者无因。是故从失亦不生法。从法不生非法者。非法名无所有。法名有。云何从有相生无相。是故从法不生非法。从非法不生法者。非法名为无。无云何生有。若从无生有者。是则无因。无因则有大过。是故不从非法生法。不从非法生非法者。非法名无所有。云何从无所有生无所有。如兔角不生龟毛。是故不从非法生非法。问曰。法非法虽种种分别故无生。但法应生法。答曰

  法不从自生　　亦不从他生
  不从自他生　　云何而有生

法未生时无所有故。又即自不生故。是故法不自生。若法未生则亦无他。无他故不得言从他生。又未生则无自。无自亦无他。共亦不生。若三种不生。云何从法有法生。复次

  若有所受法　　即堕于断常
  当知所受法　　为常为无常

受法者。分别是善是不善常无常等。是人必堕若常见若断见。何以故。所受法应有二种。若常若无常。二俱不然。何以故。若常即堕常边。若无常即堕断边。问曰

  所有受法者　　不堕于断常
  因果相续故　　不断亦不常

有人虽信受分别说诸法。而不堕断常。如经说五阴无常苦空无我。而不断灭。虽说罪福无量劫数不失。而不是常。何以故。是法因果常生灭相续故往来不绝。生灭故不常。相续故不断。答曰

  若因果生灭　　相续而不断
  灭更不生故　　因即为断灭

若汝说诸法因果相续故不断不常。若灭法已灭更不复生。是则因断。若因断云何有相续。已灭不生故。复次

  法住于自性　　不应有有无
  涅槃灭相续　　则堕于断灭

法决定在有相中。尔时无无相。如瓶定在瓶相。尔时无失坏相。随有瓶时无失坏相。无瓶时亦无失坏相。何以故。若无瓶则无所破。以是义故灭不可得。离灭故亦无生。何以故。生灭相因待故。又有常等过故。是故不应于一法而有有无。又汝先说因果生灭相续故。虽受诸法不堕断常。是事不然。何以故。汝说因果相续故有三有相续。灭相续名涅槃。若尔者。涅槃时应堕断灭。以灭三有相续故。复次

  若初有灭者　　则无有后有
  初有若不灭　　亦无有后有

初有名今世有。后有名来世有。若初有灭次有后有。是即无因。是事不然。是故不得言初有灭有后有。若初有不灭。亦不应有后有。何以故。若初有未灭而有后有者。是则一时有二有。是事不然。是故初有不灭无有后有。问曰。后有不以初有灭生。不以不灭生。但灭时生。答曰

  若初有灭时　　而后有生者
  灭时是一有　　生时是一有

若初有灭时。后有生者。即二有一时俱。一有是灭时。一有是生时。问曰。灭时生时二有俱者则不然。但现见初有灭时后有生。答曰

  若言于生灭　　而谓一时者
  则于此阴死　　即于此阴生

若生时灭时一时无二有。而谓初有灭时后有生者。今应随在何阴中死。即于此阴生。不应余阴中生。何以故。死者即是生者。如是死生相违法。不应一时一处。是故汝先说灭时生时一时无二有。但现见初有灭时后有生者。是事不然。复次

  三世中求有　　相续不可得
  若三世中无　　何有有相续

三有名欲有色有无色有。无始生死中不得实智故。常有三有相续。今于三世中谛求不可得。若三世中无有。当于何处有有相续。当知有有相续。皆从愚痴颠倒故有。实中则无

中论卷第三中论卷第四

        龙树菩萨造梵志青目释

        姚秦三藏鸠摩罗什译

    观如来品第二十二(十六偈)

问曰。一切世中尊。唯有如来正遍知。号为法王。一切智人是则应有。答曰。今谛思惟。若有应取。若无何所取。何以故。如来

  非阴不离阴　　此彼不相在
  如来不有阴　　何处有如来

若如来实有者。为五阴是如来。为离五阴有如来。为如来中有五阴。为五阴中有如来。为如来有五阴。是事皆不然。五阴非是如来。何以故。生灭相故。五阴生灭相。若如来是五阴。如来即是生灭相。若生灭相者。如来即有无常断灭等过。又受者受法则一。受者是如来。受法是五阴。是事不然。是故如来非是五阴。离五阴亦无如来。若离五阴有如来者。不应有生灭相。若尔者。如来有常等过。又眼等诸根不能见知。但是事不然。是故离五阴亦无如来。如来中亦无五阴。何以故。若如来中有五阴。如器中有果水中有鱼者。则为有异。若异者。即有如上常等过。是故如来中无五阴。又五阴中无如来。何以故。若五阴中有如来。如床上有人器中有乳者。如是则有别异。如上说过。是故五阴中无如来。如来亦不有五阴。何以故。若如来有五阴。如人有子。如是则有别异。若尔者。有如上过。是事不然。是故如来不有五阴。如是五种求不可得。何等是如来。问曰。如是义求如来不可得。而五阴和合有如来。答曰

  阴合有如来　　则无有自性
  若无有自性　　云何因他有

若如来五阴和合故有。即无自性。何以故。因五阴和合有故。问曰。如来不以自性有。但因他性有。答曰。若无自性。云何因他性有。何以故。他性亦无自性。又无相待因故。他性不可得。不可得故不名为他。复次

  法若因他生　　是即为非我
  若法非我者　　云何是如来

若法因众缘生。即无有我。如因五指有拳。是拳无有自体。如是因五阴名我。是我即无自体。我有种种名。或名众生人天如来等。若如来因五阴有。即无自性。无自性故无我。若无我云何说名如来。是故偈中说法若因他生是即为非我。若法非我者云何是如来。复次

  若无有自性　　云何有他性
  离自性他性　　何名为如来

若无自性。他性亦不应有。因自性故名他性。此无故彼亦无。是故自性他性二俱无。若离自性他性。谁为如来。复次

  若不因五阴　　先有如来者
  以今受阴故　　则说为如来
  今实不受阴　　更无如来法
  若以不受无　　今当云何受
  若其未有受　　所受不名受
  无有无受法　　而名为如来
  若于一异中　　如来不可得
  五种求亦无　　云何受中有
  又所受五阴　　不从自性有
  若无自性者　　云何有他性

若未受五阴。先有如来者。是如来今应受五阴。已作如来。而实未受五阴时先无如来。今云何当受。又不受五阴者。五阴不名为受。无有无受而名为如来。又如来一异中求不可得。五阴中五种求亦不可得。若尔者。云何于五阴中说有如来。又所受五阴。不从自性有。若谓从他性有。若不从自性有。云何从他性有。何以故。以无自性故。又他性亦无。复次

  以如是义故　　受空受者空
  云何当以空　　而说空如来

以是义思惟。受及受者皆空。若受空者。云何以空受。而说空如来。问曰。汝谓受空受者空。则定有空耶。答曰不然。何以故

  空则不可说　　非空不可说
  共不共叵说　　但以假名说

诸法空则不应说。诸法不空亦不应说。诸法空不空亦不应说。非空非不空亦不应说。何以故。但破相违故。以假名说。如是正观思惟。诸法实相中。不应以诸难为难。何以故

  寂灭相中无　　常无常等四
  寂灭相中无　　边无边等四

诸法实相。如是微妙寂灭。但因过去世。起四种邪见。世间有常。世间无常。世间常无常。世间非常非无常。寂灭中尽无。何以故。诸法实相。毕竟清净不可取。空尚不受。何况有四种见。四种见皆因受生。诸法实相无所因受。四种见皆以自见为贵。他见为贱。诸法实相无有此彼。是故说寂灭中无四种见。如因过去世有四种见。因未来世有四种见亦如是。世间有边。世间无边。世间有边无边。世间非有边非无边。问曰。若如是破如来者。则无如来耶。答曰

  邪见深厚者　　则说无如来
  如来寂灭相　　分别有亦非

邪见有二种。一者破世间乐。二者破涅槃道。破世间乐者。是粗邪见。言无罪无福。无如来等贤圣。起是邪见舍善为恶。则破世间乐。破涅槃道者。贪着于我。分别有无。起善灭恶。起善故得世间乐。分别有无故不得涅槃。是故若言无如来者。是深厚邪见。乃失世间乐。何况涅槃。若言有如来。亦是邪见。何以故。如来寂灭相。而种种分别故。是故寂灭相中。分别有如来。亦为非

  如是性空中　　思惟亦不可
  如来灭度后　　分别于有无

诸法实相性空故。不应于如来灭后思惟若有若无。若有无。如来从本已来毕竟空。何况灭后

  如来过戏论　　而人生戏论
  戏论破慧眼　　是皆不见佛

戏论名忆念取相分别此彼。言佛灭不灭等。是人为戏论。覆慧眼故不能见如来法身。此如来品中。初中后思惟。如来定性不可得。是故偈说

  如来所有性　　即是世间性
  如来无有性　　世间亦无性

此品中思惟推求。如来性即是一切世间性。问曰。何等是如来性。答曰。如来无有性。同世间无性

    中论观颠倒品第二十三(二十四偈)

问曰

  从忆想分别　　生于贪恚痴
  净不净颠倒　　皆从众缘生

经说因净不净颠倒。忆想分别生贪恚痴。是故当知有贪恚痴。答曰

  若因净不净　　颠倒生三毒
  三毒即无性　　故烦恼无实

若诸烦恼。因净不净颠倒。忆想分别生。即无自性。是故诸烦恼无实。复次

  我法有以无　　是事终不成
  无我诸烦恼　　有无亦不成

我无有因缘若有若无而可成。今无我诸烦恼云何以有无而可成。何以故

  谁有此烦恼　　是即为不成
  若离是而有　　烦恼则无属

烦恼名为能恼他。恼他者应是众生。是众生于一切处推求不可得。若谓离众生但有烦恼。是烦恼则无所属。若谓虽无我而烦恼属心。是事亦不然。何以故

  如身见五种　　求之不可得
  烦恼于垢心　　五求亦不得

如身见。五阴中五种求不可得。诸烦恼亦于垢心中。五种求亦不可得。又垢心于烦恼中。五种求亦不可得。复次

  净不净颠倒　　是则无自性
  云何因此二　　而生诸烦恼

净不净颠倒者。颠倒名虚妄。若虚妄即无性。无性则无颠倒。若无颠倒。云何因颠倒起诸烦恼。问曰

  色声香味触　　及法为六种
  如是之六种　　是三毒根本

是六入三毒根本。因此六入生净不净颠倒。因净不净颠倒生贪恚痴。答曰

  色声香味触　　及法体六种
  皆空如炎梦　　如乾闼婆城
  如是六种中　　何有净不净
  犹如幻化人　　亦如镜中像

色声香味触法自体。未与心和合时。空无所有。如炎如梦。如化如镜中像。但诳惑于心无有定相。如是六入中。何有净不净。复次

  不因于净相　　则无有不净
  因净有不净　　是故无不净

若不因于净。先无有不净。因何而说不净。是故无不净。复次

  不因于不净　　则亦无有净
  因不净有净　　是故无有净

若不因不净。先无有净。因何而说净。是故无有净。复次

  若无有净者　　何由而有贪
  若无有不净　　何由而有恚

无净不净故。则不生贪恚。问曰。经说常等四颠倒。若无常中见常。是名颠倒。若无常中见无常。此非颠倒。余三颠倒亦如是。有颠倒故。颠倒者亦应有。何故言都无。答曰

  于无常着常　　是则名颠倒
  空中无有常　　何处有常倒

若于无常中着常。名为颠倒。诸法性空中无有常。是中何处有常颠倒。余三亦如是。复次

  若于无常中　　着无常非倒
  空中无无常　　何有非颠倒

若着无常言是无常。不名为颠倒者。诸法性空中无无常。无常无故谁为非颠倒。余三亦如是。复次

  可着著者着　　及所用着法
  是皆寂灭相　　云何而有着

可著名物著者名作者。著名业。所用法名所用事。是皆性空寂灭相。如如来品中所说。是故无有着。复次

  若无有着法　　言邪是颠倒
  言正不颠倒　　谁有如是事

著名忆想分别此彼有无等。若无此著者。谁为邪颠倒。谁为正不颠倒。复次

  有倒不生倒　　无倒不生倒
  倒者不生倒　　不倒亦不生
  若于颠倒时　　亦不生颠倒
  汝可自观察　　谁生于颠倒

已颠倒者。则更不生颠倒。已颠倒故。不颠倒者亦不颠倒。无有颠倒故。颠倒时亦不颠倒。有二过故。汝今除憍慢心。善自观察。谁为颠倒者。复次

  诸颠倒不生　　云何有此义
  无有颠倒故　　何有颠倒者

颠倒种种因缘破故。堕在不生。彼贪着不生。谓不生是颠倒实相。是故偈说。云何名不生为颠倒。乃至无漏法尚不名为不生相。何况颠倒是不生相。颠倒无故何有颠倒者。因颠倒有颠倒者。复次

  若常我乐净　　而是实有者
  是常我乐净　　则非是颠倒

若常我乐净是四实有性者。是常我乐净则非颠倒。何以故。定有实事故。云何言颠倒。若谓常我乐净倒是四无者。无常苦无我不净。是四应实有。不名颠倒。颠倒相违故名不颠倒。是事不然。何以故

  若常我乐净　　而实无有者
  无常苦不净　　是则亦应无

若常我乐净是四实无。无故无常等四事亦不应有。何以故。无相因待故。复次

  如是颠倒灭　　无明则亦灭
  以无明灭故　　诸行等亦灭

如是者如其义。灭诸颠倒故。十二因缘根本无明亦灭。无明灭故三种行业。乃至老死等皆灭。复次

  若烦恼性实　　而有所属者
  云何当可断　　谁能断其性

若诸烦恼即是颠倒。而实有性者。云何可断。谁能断其性。若谓诸烦恼皆虚妄无性而可断者。是亦不然。何以故

  若烦恼虚妄　　无性无属者
  云何当可断　　谁能断无性

若诸烦恼虚妄无性。则无所属。云何可断。谁能断无性法

    中论观四谛品第二十四(四十偈)

问曰。破四颠倒。通达四谛。得四沙门果

  若一切皆空　　无生亦无灭
  如是则无有　　四圣谛之法
  以无四谛故　　见苦与断集
  证灭及修道　　如是事皆无
  以是事无故　　则无四道果
  无有四果故　　得向者亦无
  若无八贤圣　　则无有僧宝
  以无四谛故　　亦无有法宝
  以无法僧宝　　亦无有佛宝
  如是说空者　　是则破三宝

若一切世间皆空无所有者。即应无生无灭。以无生无灭故。则无四圣谛。何以故。从集谛生苦谛。集谛是因苦谛是果。灭苦集谛名为灭谛。能至灭谛名为道谛。道谛是因灭谛是果。如是四谛有因有果。若无生无灭则无四谛。四谛无故。则无见苦断集证灭修道。见苦断集证灭修道无故。则无四沙门果。四沙门果无故。则无四向四得者。若无此八贤圣。则无僧宝。又四圣谛无故。法宝亦无。若无法宝僧宝者。云何有佛。得法名为佛。无法何有佛。汝说诸法皆空。则坏三宝。复次

  空法坏因果　　亦坏于罪福
  亦复悉毁坏　　一切世俗法

若受空法者。则破罪福及罪福果报。亦破世俗法。有如是等诸过故。诸法不应空。答曰

  汝今实不能　　知空空因缘
  及知于空义　　是故自生恼

汝不解云何是空相。以何因缘说空。亦不解空义。不能如实知故。生如是疑难。复次

  诸佛依二谛　　为众生说法
  一以世俗谛　　二第一义谛
  若人不能知　　分别于二谛
  则于深佛法　　不知真实义

世俗谛者。一切法性空。而世间颠倒故生虚妄法。于世间是实。诸贤圣真知颠倒性。故知一切法皆空无生。于圣人是第一义谛名为实。诸佛依是二谛。而为众生说法。若人不能如实分别二谛。则于甚深佛法。不知实义。若谓一切法不生是第一义谛。不须第二俗谛者。是亦不然。何以故

  若不依俗谛　　不得第一义
  不得第一义　　则不得涅槃

第一义皆因言说。　言说是世俗。是故若不依世俗。第一义则不可说。若不得第一义。云何得至涅槃。是故诸法虽无生。而有二谛。复次

  不能正观空　　钝根则自害
  如不善咒术　　不善捉毒蛇

若人钝根。不善解空法。于空有失而生邪见。如为利捉毒蛇不能善捉反为所害。又如咒术欲有所作不能善成则还自害。钝根观空法亦如是。复次

  世尊知是法　　甚深微妙相
  非钝根所及　　是故不欲说

世尊以法甚深微妙。非钝根所解。是故不欲说。复次

  汝谓我着空　　而为我生过
  汝今所说过　　于空则无有

汝谓我着空故。为我生过。我所说性空。空亦复空。无如是过。复次

  以有空义故　　一切法得成
  若无空义者　　一切则不成

以有空义故。一切世间出世间法皆悉成就。若无空义。则皆不成就。复次

  汝今自有过　　而以回向我
  如人乘马者　　自忘于所乘

汝于有法中有过不能自觉。而于空中见过。如人乘马而忘其所乘。可以故

  若汝见诸法　　决定有性者
  即为见诸法　　无因亦无缘

汝说诸法有定性。若尔者。则见诸法无因无缘。何以故。若法决定有性。则应不生不灭。如是法何用因缘。若诸法从因缘生则无有性。是故诸法决定有性。则无因缘。若谓诸法决定住自性。是则不然。何以故

  即为破因果　　作作者作法
  亦复坏一切　　万物之生灭

诸法有定性。则无因果等诸事。如偈说

  众因缘生法　　我说即是无
  亦为是假名　　亦是中道义
  未曾有一法　　不从因缘生
  是故一切法　　无不是空者

众因缘生法。我说即是空。何以故。众缘具足和合而物生。是物属众因缘故无自性。无自性故空。空亦复空。但为引导众生故。以假名说。离有无二边故名为中道。是法无性故不得言有。亦无空故不得言无。若法有性相。则不待众缘而有。若不待众缘则无法。是故无有不空法。汝上所说空法有过者。此过今还在汝。何以故

  若一切不空　　则无有生灭
  如是则无有　　四圣谛之法

若一切法各各有性不空者。则无有生灭。无生灭故。则无四圣谛法。何以故

  苦不从缘生　　云何当有苦
  无常是苦义　　定性无无常

苦不从缘生故则无苦。何以故。经说无常是苦义。若苦有定性。云何有无常。以不舍自性故。复次

  若苦有定性　　何故从集生
  是故无有集　　以破空义故

若苦有定性者。则不应更生。先已有故。若尔者。则无集谛。以坏空义故。复次

  苦若有定性　　则不应有灭
  汝着定性故　　即破于灭谛

苦若有定性者。则不应灭。何以故。性则无灭故。复次

  苦若有定性　　则无有修道
  若道可修习　　即无有定性

法若定有。则无有修道。何以故。若法实者则是常。常则不可增益。若道可修。道则无有定性。复次

  若无有苦谛　　及无集灭谛
  所可灭苦道　　竟为何所至

诸法若先定有性。则无苦集灭谛。今灭苦道。竟为至何灭苦处。复次

  若苦定有性　　先来所不见
  于今云何见　　其性不异故

若先凡夫时。不能见苦性。今亦不应见。何以故。不见性定故。复次

  如见苦不然　　断集及证灭
  修道及四果　　是亦皆不然

如苦谛性先不见者后亦不应见。如是亦不应有断集证灭修道。何以故。是集性先来不断。今亦不应断。性不可断故。灭先来不证。今亦不应证。先来不证故。道先来不修。今亦不应修。先来不修故。是故四圣谛。见断证修四种行。皆不应有。四种行无故。四道果亦无。何以故

  是四道果性　　先来不可得
  诸法性若定　　今云何可得

诸法若有定性。四沙门果先来未得。今云何可得。若可得者。性则无定。复次

  若无有四果　　则无得向者
  以无八圣故　　则无有僧宝

无四沙门果故。则无得果向果者。无八贤圣故。则无有僧宝。而经说八贤圣。名为僧宝。复次

  无四圣谛故　　亦无有法宝
  无法宝僧宝　　云何有佛宝

行四圣谛得涅槃法。若无四谛则无法宝。若无二宝云何当有佛宝。汝以如是因缘。说诸法定性。则坏三宝问曰。汝虽破诸法。究竟道阿耨多罗三藐三菩提应有。因是道故名为佛。答曰

  汝说则不因　　菩提而有佛
  亦复不因佛　　而有于菩提

汝说诸法有定性者。则不应因菩提有佛。因佛有菩提。是二性常定故。复次

  虽复勤精进　　修行菩提道
  若先非佛性　　不应得成佛

以先无性故。如铁无金性。虽复种种锻炼。终不成金。复次

  若诸法不空　　无作罪福者
  不空何所作　　以其性定故

若诸法不空。终无有人作罪福者。何以故。罪福性先已定故。又无作作者故。复次

  汝于罪福中　　不生果报者
  是则离罪福　　而有诸果报

汝于罪福因缘中。皆无果报者。则应离罪福因缘而有果报。何以故。果报不待因出故。问曰。离罪福可无善恶果报。但从罪福有善恶果报。答曰

  若谓从罪福　　而生果报者
  果从罪福生　　云何言不空

若离罪福无善恶果。云何言果不空。若尔离作者则无罪福。汝先说诸法不空。是事不然。复次

  汝破一切法　　诸因缘空义
  则破于世俗　　诸余所有法

汝若破众因缘法第一空义者。则破一切世俗法。何以故

  若破于空义　　即应无所作
  无作而有作　　不作名作者

若破空义。则一切果皆无作无因。又不作而作。又一切作者不应有所作。又离作者。应有业有果报有受者。但是事皆不然。是故不应破空。复次

  若有决定性　　世间种种相
  则不生不灭　　常住而不坏

若诸法有定性。则世间种种相。天人畜生万物。皆应不生不灭常住不坏。何以故。有实性不可变异故。而现见万物。各有变异相生灭变易。是故不应有定性。复次

  若无有空者　　未得不应得
  亦无断烦恼　　亦无苦尽事

若无有空法者。则世间出世间所有功德未得者。皆不应得。亦不应有断烦恼者。亦无苦尽。何以故。以性定故

  是故经中说　　若见因缘法
  则为能见佛　　见苦集灭道

若人见一切法从众缘生。是人即能见佛法身。增益智慧。能见四圣谛苦集灭道。见四圣谛得四果灭诸苦恼。是故不应破空义。若破空义则破因缘法。破因缘法。则破三宝。若破三宝。则为自破。

    中论观涅槃品第二十五(二十四偈)

问曰

  若一切法空　　无生无灭者
  何断何所灭　　而称为涅槃

若一切法空。则无生无灭。无生无灭者。何所断何所灭。而名为涅槃。是故一切法不应空。以诸法不空故。断诸烦恼灭五阴。名为涅槃。答曰

  若诸法不空　　则无生无灭
  何断何所灭　　而称为涅槃

若一切世间不空。则无生无灭。何所断何所灭。而名为涅槃。是故有无二门。则非至涅槃。所名涅槃者

  无得亦无至　　不断亦不常
  不生亦不灭　　是说名涅槃

无得者。于行于果无所得。无至者。无处可至。不断者。五阴先来毕竟空故。得道入无余涅槃时。亦无所断。不常者。若有法可得分别者。则名为常。涅槃寂灭无法可分别故。不名为常。生灭亦尔。如是相者名为涅槃。复次经说。涅槃非有非无非有无。非非有非非无。一切法不受内寂灭名涅槃。何以故

  涅槃不名有　　有则老死相
  终无有有法　　离于老死相

眼见一切万物皆生灭故。是老死相。涅槃若是有则应有老死相。但是事不然。是故涅槃不名有。又不见离生灭老死别有定法而名涅槃。若涅槃是有即应有生灭老死相。以离老死相故。名为涅槃。复次

  若涅槃是有　　涅槃即有为
  终无有一法　　而是无为者

涅槃非是有。何以故。一切万物从众缘生。皆是有为。无有一法名为无为者。虽常法假名无为。以理推之。无常法尚无有。何况常法不可见不可得者。复次

  若涅槃是有　　云何名无受
  无有不从受　　而名为有法

若谓涅槃是有法者。经则不应说无受是涅槃。何以故。无有有法不受而有。是故涅槃非有。问曰。若有非涅槃者无应是涅槃耶。答曰

  有尚非涅槃　　何况于无耶
  涅槃无有有　　何处当有无

若有非涅槃。无云何是涅槃。何以故。因有故有无。若无有。何有无。如经说。先有今无则名无。涅槃则不尔。何以故。非有法变为无故。是故无亦不作涅槃。复次

  若无是涅槃　　云何名不受
  未曾有不受　　而名为无法

若谓无是涅槃。经则不应说不受名涅槃。何以故。无有不受而名无法。是故知涅槃非无。问曰。若涅槃非有非无者。何等是涅槃。答曰

  受诸因缘故　　轮转生死中
  不受诸因缘　　是名为涅槃

不如实知颠倒故。因五受阴往来生死。如实知颠倒故。则不复因五受阴往来生死。无性五阴不复相续故。说名涅槃。复次

  如佛经中说　　断有断非有
  是故知涅槃　　非有亦非无

有名三有。非有名三有断灭。佛说断此二事故。当知涅槃非有亦非无。问曰。若有若无非涅槃者。今有无共合。是涅槃耶。答曰

  若谓于有无　　合为涅槃者
  有无即解脱　　是事则不然

若谓于有无合为涅槃者。即有无二事合为解脱。是事不然。何以故。有无二事相违故。云何一处有。复次

  若谓于有无　　合为涅槃者
  涅槃非无受　　是二从受生

若谓有无合为涅槃者。经不应说涅槃名无受。何以故。有无二事从受生。相因而有。是故有无二事。不得合为涅槃。复次

  有无共合成　　云何名涅槃
  涅槃名无为　　有无是有为

有无二事共合。不得名涅槃。涅槃名无为。有无是有为。是故有无非是涅槃。复次

  有无二事共　　云何是涅槃
  是二不同处　　如明暗不俱

有无二事。不得名涅槃。何以故。有无相违一处不可得。如明暗不俱。是故有时无无。无时无有。云何有无共合。而名为涅槃。问曰。若有无共合非涅槃者。今非有非无应是涅槃。答曰

  若非有非无　　名之为涅槃
  此非有非无　　以何而分别

若涅槃非有非无者。此非有非无。因何而分别。是故非有非无是涅槃者。是事不然。复次

  分别非有无　　如是名涅槃
  若有无成者　　非有非无成

汝分别非有非无是涅槃者是事不然。何以故。若有无成者。然后非有非无成。有相违名无。无相违名有。是有无第三句中已破。有无无故。云何有非有非无。是故涅槃。非非有非非无。复次

  如来灭度后　　不言有与无
  亦不言有无　　非有及非无
  如来现在时　　不言有与无
  亦不言有无　　非有及非无

若如来灭后若现在。有如来亦不受。无如来亦不受。亦有如来亦无如来亦不受。非有如来非无如来亦不受。以不受故。不应分别涅槃有无等。离如来谁当得涅槃。何时何处以何法说涅槃。是故一切时一切种。求涅槃相不可得。复次

  涅槃与世间　　无有少分别
  世间与涅槃　　亦无少分别

五阴相续往来因缘故。说名世间。五阴性毕竟空无受寂灭。此义先已说。以一切法不生不灭故。世间与涅槃无有分别。涅槃与世间亦无分别。复次

  涅槃之实际　　及与世间际
  如是二际者　　无毫厘差别

究竟推求世间涅槃实际无生际。以平等不可得故。无毫厘差别。复次

  灭后有无等　　有边等常等
  诸见依涅槃　　未来过去世

如来灭后有如来无如来。亦有如来亦无如来。非有如来非无如来。世间有边世间无边。世间亦有边亦无边。世间非有边非无边。世间常世间无常。世间亦常亦无常。世间非有常非无常。此三种十二见。如来灭后有无等四见。依涅槃起。世间有边无边等四见。依未来世起。世间常无常等四见。依过去世起。如来灭后有无等不可得。涅槃亦如是。如世间前际后际有边无边有常无常等不可得。涅槃亦如是。是故说世间涅槃等无有异。复次

  一切法空故　　何有边无边
  亦边亦无边　　非有非无边
  何者为一异　　何有常无常
  亦常亦无常　　非常非无常
  诸法不可得　　灭一切戏论
  无人亦无处　　佛亦无所说

一切法一切时一切种。从众缘生故。毕竟空故无自性。如是法中。何者是有边谁为有边。何者是无边。亦有边亦无边。非有边非无边。谁为非有边非无边。何者是常谁为是常。何者是无常。常无常非常非无常。谁为非常非无常。何者身即是神。何者身异于神。如是等六十二邪见。于毕竟空中皆不可得。诸有所得皆息。戏论皆灭。戏论灭故。通达诸法实相得安隐道。从因缘品来。分别推求诸法。有亦无。无亦无。有无亦无。非有非无亦无。是名诸法实相。亦名如法性实际涅槃。是故如来无时无处。为人说涅槃定相。是故说诸有所得皆息。戏论皆灭

    中论观十二因缘品第二十六(九偈)

问曰汝以摩诃衍说第一义道。我今欲闻说声闻法入第一义道。答曰

  众生痴所覆　　为后起三行
  以起是行故　　随行堕六趣
  以诸行因缘　　识受六道身
  以有识着故　　增长于名色
  名色增长故　　因而生六入
  情尘识和合　　而生于六触
  因于六触故　　即生于三受
  以因三受故　　而生于渴爱
  因爱有四取　　因取故有有
  若取者不取　　则解脱无有
  从有而有生　　从生有老死
  从老死故有　　忧悲诸苦恼
  如是等诸事　　皆从生而有
  但以是因缘　　而集大苦阴
  是谓为生死　　诸行之根本
  无明者所造　　智者所不为
  以是事灭故　　是事则不生
  但是苦阴聚　　如是而正灭

凡夫为无明所盲故。以身口意业。为后身起六趣诸行。随所起行有上中下。识入六趣随行受身。以识着因缘故名色集。名色集故有六入。六入因缘故有六触。六触因缘故有三受。三受因缘故生渴爱。渴爱因缘故有四取。四取取时以身口意业起罪福。令后三有相续。从有而有生。从生而有老死。从老死有忧悲苦恼种种众患。但有大苦阴集。是故知凡夫无智。起此生死诸行根本。智者所不起。以如实见故。则无明灭。无明灭故诸行亦灭。以因灭故果亦灭。如是修习观十二因缘生灭智故是事灭。是事灭故乃至生老死忧悲大苦阴皆如实正灭。正灭者毕竟灭。是十二因缘生灭义。如阿毗昙修多罗中广说

    中论观邪见品第二十七(三十一偈)

问曰。已闻大乘法破邪见。今欲闻声闻法破邪见。答曰

  我于过去世　　为有为是无
  世间常等见　　皆依过去世
  我于未来世　　为作为不作
  有边等诸见　　皆依未来世

我于过去世。为有为无。为有无为非有非无。是名常等诸见依过去世。我于未来世。为作为不作。为作不作为非作非不作。是名边无边等诸见依未来世。如是等诸邪见。何因缘故名为邪见。是事今当说

  过去世有我　　是事不可得
  过去世中我　　不作今世我
  若谓我即是　　而身有异相
  若当离于身　　何处别有我
  离有无身我　　是事为已成
  若谓身即我　　若都无有我
  但身不为我　　身相生灭故
  云何当以受　　而作于受者
  若离身有我　　是事则不然
  无受而有我　　而实不可得
  今我不离受　　亦不即是受
  非无受非无　　此即决定义

我于过去世有者。是事不然。何以故。先世中我不即作今我。有常过故。若常则有无量过。何以故。如人修福因缘故作天而后作人。若先世我即是今我者。天即是人。又人以罪业因缘故作旃陀罗。后作婆罗门。若先世我即是今我者。旃陀罗即是婆罗门。譬如舍卫国婆罗门名提婆达。到王舍城亦名提婆达。不以至王舍城故为异。若先作天后作人。则天即是人。旃陀罗即是婆罗门。但是事不然。何以故。天不即是人。旃陀罗不即是婆罗门。有此等常过故。若谓先世我不作今我。如人浣衣时名为浣者。刈时名为刈者。而浣者与刈者虽不异。而浣者不即是刈者。如是我受天身名为天。我受人身名为人。我不异而身有异者。是事不然。何以故。若即是者。不应言天作人。今浣者于刈者。为异为不异。若不异。浣者应即是刈者。如是先世天即是人。旃陀罗即是婆罗门。我亦有常过。若异者。浣者即不作刈者。如是天不作人。我亦无常。无常则无我相。是故不得言即是。问曰。我即是。但因受故分别是天是人。受名五阴身。以业因缘故分别是天是人是旃陀罗是婆罗门。而我实非天非人。非旃陀罗非婆罗门。是故无如是过。答曰。是事不然。何以故。若身作天作人。作旃陀罗作婆罗门。非是我者。则离身别有我。今罪福生死往来。皆是身非是我。罪因缘故堕三恶道。福因缘故生三善道。若苦乐嗔喜忧怖等。皆是身非我者。何用我为。如治俗人罪。不豫出家人。五阴因缘相续罪福不失故有解脱。若皆是身非我者。何用我为。问曰。罪福等依止于我。我有所知身无所知故。知者应是我。起业因缘罪福是作法。当知应有作者。作者是我。身是我所用。亦是我所住处。譬如舍主以草木泥塈等治舍。自为身故随所用治舍有好恶。我亦如是。随作善恶等得好丑身。六道生死皆我所作。是故罪福之身皆属于我。譬如舍但属舍主不属他人。答曰。是喻不然。何以故。舍主有形。有触有力故能治舍。汝所说我无形无触故无作力。自无作力亦不能使他作。若世间有一法无形无触能有所作者。则可信受知有作者。但是事不然。若我是作者。则不应自作苦事。若是念者。可贪乐事不应忘失。若我不作苦而苦强生者。余一切皆亦自生。非我所作。若见者是我。眼能见色眼应是我。若眼见而非我。则违先言见者是我。若见者是我。我则不应得闻声等诸尘。何以故。眼是见者。不能得闻声等尘故。是故我是见者。是事不然。若谓如刈者用镰刈草。我亦如是以手等能有所作者。是事不然。何以故。今离镰别有刈者。而离身心诸根无别作者。若谓作者虽非眼耳等所得亦有作者。则石女儿能有所作。如是一切诸根皆应无我。若谓右眼见物而左眼识。当知别有见者。是事不然。今右手习作左手不能。是故无别有作者。若别有作者。右手所习左手亦应能。而实不能。是故更无作者。复次有我者言。见他食果口中涎出。是为我相。是事不然。何以故。是念力故非是我力。又亦即是破我因缘。人在众中愧于涎出。而涎强出不得自在。当知无我。复次又有颠倒过罪。先世是父今世为子。是父子我一。但身有异。如从一舍至一舍。父故是父。不以入异舍故便有异。若有我是二应一。如是则有大过。若谓无我五阴相续中亦有是过。是事不然。何以故。五阴虽相续。或时有用或时无用。如蒲桃浆持戒者应饮蒲桃酒不应饮。若变为苦酒还复应饮。五阴相续亦如是。有用有不用。若始终一我有如是过。五阴相续无如是过。但五阴和合故假名为我无有决定。如梁椽和合有舍。离梁椽无别舍。如是五阴和合故有我。若离五阴实无别我。是故我但有假名无有定实。汝先说离受别有受者。以受分别受者是天是人。是皆不然。当知但有受无别受者。若谓离受别有我。是事不然。若离受有我。云何可得说是我相。若无相可说。则离受无我。若谓离身无我但身是我。是亦不然。何以故。身有生灭相。我则不尔。复次云何以受即名受者。若谓离受有受者。是亦不然。若不受五阴而有受者。应离五阴别有受者。眼等根可得而实不可得。是故我不离受。不即是受。亦非无受。亦复非无。此是定义。是故当知。过去世有我者。是事不然。何以故

  过去我不作　　是事则不然
  过去世中我　　异今亦不然
  若谓有异者　　离彼应有今
  我住过去世　　而今我自生
  如是则断灭　　失于业果报
  彼作而此受　　有如是等过
  先无而今有　　此中亦有过
  我则是作法　　亦为是无因

过去世中我。不作今我。是事不然。何以故。过去世中我。与今我不异。若今我与过去世我异者。应离彼我而有今我。又过去世我。亦应住彼此身自更生。若尔者即堕断边。失诸业果报。又彼人作罪此人受报。有如是等无量过。又是我应先无而今有。是亦有过。我则是作法。亦是无因生。是故过去我。不作今我。是事不然。复次

  如过去世中　　有我无我见
  若共若不共　　是事皆不然

如是推求过去世中邪见有无。亦有亦无。非有非无。是诸邪见。先说因缘过故。是皆不然

  我于未来世　　为作为不作
  如是之见者　　皆同过去世

我于未来世中。为作为不作。如是四句。如过去世中过咎。应在此中说。复次

  若天即是人　　则堕于常边
  天则为无生　　常法不生故

若天即是人。是则为常。若天不生人中。云何名为人。常法不生故。常亦不然。复次

  若天异于人　　是即为无常
  若天异人者　　是则无相续

若天与人异。则为无常。无常则为断灭等过。如先说过。若天与人异。则无相续。若有相续。不得言异。复次

  若半天半人　　则堕于二边
  常及于无常　　是事则不然

若众生半身是天。半身是人。若尔则有常无常。半天是常。半人是无常。但是事不然。何以故。一身有二相过故。复次

  若常及无常　　是二俱成者
  如是则应成　　非常非无常

若常无常二俱成者。然后成非常非无常。与常无常相违故。今实常无常不成。是故非常非无常亦不成。复次今生死无始。是亦不然。何以故

  法若定有来　　及定有去者
  生死则无始　　而实无此事

法若决定有所从来。有所从去者。生死则应无始。是法以智慧推求。不得有所从来。有所从去。是故生死无始。是事不然。复次

  今若无有常　　云何有无常
  亦常亦无常　　非常非无常

若尔者。以智慧推求。无法可得常者。谁当有无常。因常有无常故。若二俱无者。云何有亦有常亦无常。若无有常无常。云何有非有常非无常。因亦有常亦无常故。有非有常非无常。是故依止过去世常等四句不可得。有边无边等四句依止未来世。是事不可得。今当说。何以故

  若世间有边　　云何有后世
  若世间无边　　云何有后世

若世间有边。不应有后世。而今实有后世。是故世间有边不然。若世间无边。亦不应有后世。而实有后世。是故世间无边亦不然。复次是二边不可得。何以故

  五阴常相续　　犹如灯火炎
  以是故世间　　不应边无边

从五阴复生五阴。是五阴次第相续。如众缘和合有灯炎。若众缘不尽灯则不灭。若尽则灭。是故不得说世间有边无边。复次

  若先五阴坏　　不因是五阴
  更生后五阴　　世间则有边
  若先阴不坏　　亦不因是阴
  而生后五阴　　世间则无边

若先五阴坏。不因是五阴更生后五阴。如是则世间有边。若先五阴灭已。更不生余五阴。是名为边。边名末后身。若先五阴不坏。不因是五阴而生后五阴。世间则无边。是则为常。而实不尔。是故世间无边。是事不然。世间有二种。国土世间。众生世间。此是众生世间。复次如四百观中说

  真法及说者　　听者难得故
  如是则生死　　非有边无边

不得真法因缘故。生死往来无有边。或时得闻真法得道故。不得言无边。今当更破亦有边亦无边

  若世半有边　　世间半无边
  是则亦有边　　亦无边不然

若世间半有边半无边。则应是亦有边亦无边。若尔者。则一法二相。是事不然。何以故

  彼受五阴者　　云何一分破
  一分而不破　　是事则不然
  受亦复如是　　云何一分破
  一分而不破　　是事亦不然

受五阴者。云何一分破。一分不破。一事不得亦常亦无常。受亦如是。云何一分破。一分不破。常无常二相过故。是故世间亦有边亦无边则不然。今当破非有边非无边见

  若亦有无边　　是二得成者
  非有非无边　　是则亦应成

与有边相违故有无边。如长相违有短。与有无相违。则有亦有亦无。与亦有亦无相违故。则有非有非无。若亦有边亦无边定成者。应有非有边非无边。何以故。因相待故。上已破亦有边亦无边第三句。今云何当有非有边非无边。以无相待故。如是推求。依止未来世有边等四见皆不可得。复次

  一切法空故　　世间常等见
  何处于何时　　谁起是诸见

上以声闻法破诸见。今此大乘法中说。诸法从本以来毕竟空性。如是空性法中无人无法。不应生邪见正见。处名土地。时名日月岁数。谁名为人。是名诸见体。若有常无常等决定见者。应当有人出生此见。破我故无人生是见。应有处所色法现见尚可破。何况时方。若有诸见者应有定实。若定则不应破。上来以种种因缘破。是故当知见无定体。云何得生。如偈说。何处于何时。谁起是诸见

  瞿昙大圣主　　怜愍说是法
  悉断一切见　　我今稽首礼

一切见者。略说则五见。广说则六十二见。为断是诸见故说法。大圣主瞿昙。是无量无边不可思议智慧者。是故我稽首礼

中论卷第四


辩中边论

    No. 1600 [No. 1599; cf. No. 1601]

辩中边论卷上

        世亲菩萨造

        大唐三藏法师玄奘奉　诏译

    辩相品第一

  稽首造此论　　善逝体所生
  及教我等师　　当勤显斯义

此中最初安立论体。颂曰

  唯相障真实　　及修诸对治
  即此修分位　　得果无上乘

论曰。此论唯说如是七义。一相。二障。三真实。四修诸对治。五即此修分位。六得果。七无上乘。今于此中先辩其相。颂曰

  虚妄分别有　　于此二都无
  此中唯有空　　于彼亦有此

论曰。虚妄分别有者。谓有所取能取分别。于此二都无者。谓即于此虚妄分别。永无所取能取二性。此中唯有空者。谓虚妄分别中。但有离所取及能取空性。于彼亦有此者。谓即于彼二空性中。亦但有此虚妄分别。若于此非有。由彼观为空。所余非无故。如实知为有。若如是者则能无倒显示空相。复次颂曰

  故说一切法　　非空非不空
  有无及有故　　是则契中道

论曰。一切法者。谓诸有为及无为法。虚妄分别名有为。二取空性名无为。依前理故说此一切法非空非不空。由有空性虚妄分别故说非空。由无所取能取性故说非不空。有故者。谓有空性虚妄分别故。无故者。谓无所取能取二性故。及有故者。谓虚妄分别中有空性故。及空性中有虚妄分别故。是则契中道者。谓一切法非一向空。亦非一向不空。如是理趣妙契中道。亦善符顺般若等经说一切法非空非有。如是已显虚妄分别有相无相。此自相今当说。颂曰

  识生变似义　　有情我及了
  此境实非有　　境无故识无

论曰。变似义者。谓似色等诸境性现。变似有情者。谓似自他身五根性现。变似我者。谓染末那与我痴等恒相应故。变似了者。谓余六识了相粗故。此境实非有者。谓似义似根无行相故。似我似了非真现故。皆非实有。境无故识无者。谓所取义等四境无故。能取诸识亦非实有。复次颂曰

  虚妄分别性　　由此义得成
  非实有全无　　许灭解脱故

论曰。虚妄分别。由此义故成非实有。如所现起非真有故。亦非全无。于中少有乱识生故。如何不许此性全无。以许此灭得解脱故。若异此者。系缚解脱则应皆无。如是便成拨无杂染及清净失。已显虚妄分别自相。此摄相今当说。但有如是虚妄分别。即能具摄三种自性。颂曰

  唯所执依他　　及圆成实性
  境故分别故　　及二空故说

论曰。依止虚妄分别境故。说有遍计所执自性。依止虚妄分别性故。说有依他起自性。依止所取能取空故。说有圆成实自性。已显虚妄分别摄相。当说即于虚妄分别入无相方便相。颂曰

  依识有所得　　境无所得生
  依境无所得　　识无所得生

论曰。依止唯识有所得故。先有于境无所得生。复依于境无所得故。后有于识无所得生。由是方便得入所取能取无相。复次颂曰

  由识有得性　　亦成无所得
  故知二有得　　无得性平等

论曰。唯识生时现似种种虚妄境故。名有所得。以所得境无实性故。能得实性亦不得成。由能得识无所得故。所取能取二有所得。平等俱成无所得性。显入虚妄分别无相方便相已。此差别异门相今次当说。颂曰

  三界心心所　　是虚妄分别
  唯了境名心　　亦别名心所

论曰。虚妄分别差别相者。即是欲界色无色界诸心心所。异门相者。唯能了境总相名心。亦了差别名为受等诸心所法。今次当说此生起相。颂曰

  一则名缘识　　第二名受者
  此中能受用　　分别推心所

论曰。缘识者。谓藏识。是余识生缘故。藏识为缘所生转识。受用主故名为受者。此诸识中受能受用想能分别。思作意等诸相应行。能推诸识此三助心故名心所。今次当说此杂染相。颂曰

  覆障及安立　　将导摄圆满
  三分别受用　　引起并连缚
  现前苦果故　　唯此恼世间
  三二七杂染　　由虚妄分别

论曰。覆障故者。谓由无明覆如实理障真见故。安立故者。谓由诸行植本识中业熏习故。将导故者。谓有取识引诸有情至生处故。摄故者。谓名色摄有情自体故。圆满故者。谓六内处令诸有情体具足故。三分别故者。谓触能分别根境识三顺三受故。受用故者。谓由受支领纳顺违非二境故。引起故者。谓由爱力令先业所引后有得起故。连缚故者。谓取令识缘顺欲等连缚生故。现前故者。谓由有力令已作业所与后有诸异熟果得现前故。苦果故者。谓生老死性有逼迫酬前因故。唯此所说十二有支。逼恼世间令不安隐。三杂染者。一烦恼杂染。谓无明爱取。二业杂染谓行有。三生杂染。谓余支。二杂染者。一因杂染。谓烦恼业。二果杂染。谓所余支。七杂染者。谓七种因。一颠倒因。谓无明。二牵引因。谓行。三将导因。谓识。四摄受因。谓名色六处。五受用因。谓触受。六引起因。谓爱取有。七厌怖因。谓生老死。此诸杂染无不皆由虚妄分别而得生长。此前总显虚妄分别有九种相。一有相。二无相。三自相。四摄相。五入无相方便相。六差别相。七异门相。八生起相。九杂染相。如是已显虚妄分别。今次当说所知空性。颂曰

  诸相及异门　　义差别成立
  应知二空性　　略说唯由此

论曰。应知所取能取空性。略说但由此相等五。所知空性其相云何。颂曰

  无二有无故　　非有亦非无
  非异亦非一　　是说为空相

论曰。无二谓无所取能取。有无谓有二取之无。此即显空无性为性。故此空相非有非无。云何非有无。二有故。云何非无有。二无故。此显空相非有非无。此空与彼虚妄分别非异非一。若异应成法性异法。便违正理。如苦等性。若一则应非净智境。亦非共相。此即显空与妄分别离一异相。所知空性异门云何。颂曰

  略说空异门　　谓真如实际
  无相胜义性　　法界等应知

论曰。略说空性有此异门。云何应知此异门义。颂曰

  由无变无倒　　相灭圣智境
  及诸圣法因　　异门义如次

论曰。即此中说所知空性。由无变义说为真如。真性常如。无转易故。由无倒义说为实际。非诸颠倒。依缘事故。由相灭义说为无相。此中永绝一切相故。由圣智境义说为胜义性。是最胜智所行义故。由圣法因义说为法界。以一切圣法缘此生故。此中界者。即是因义无我等义如理应知。云何应知空性差别。颂曰

  此杂染清净　　由有垢无垢
  如水界全空　　净故许为净

论曰。空性差别略有二种。一杂染。二清净。此成染净由分位别。谓有垢位说为杂染。出离垢时说为清净。虽先杂染后成清净。而非转变成无常失。如水界等出离客尘。空净亦然非性转变。此空差别复有十六。谓内空外空内外空大空空空胜义空有为空无为空毕竟空无际空无散空本性空相空一切法空无性空无性自性空。此等略义云何应知。颂曰

  能食及所食　　此依身所住
  能见此如理　　所求二净空
  为常益有情　　为不舍生死
  为善无穷尽　　故观此为空
  为种性清净　　为得诸相好
  为净诸佛法　　故菩萨观空

论曰。能食空者。依内处说即是内空。所食空者。依外处说即是外空。此依身者。谓能所食所依止身此身空故名内外空。诸器世间说为所住。此相宽广故名为大。所住空故名为大空。能见此者。谓智能见内处等空。空智空故说名空空。如理者。谓胜义即如实行。所观真理此即空故名胜义空。菩萨修行为得二净。即诸有为无为善法。此二空故名有为空及无为空。为于有情常作饶益。而观空故名毕竟空。生死长远无初后际。观此空故名无际空。不观为空便速厌舍。为不厌舍此生死故。观此无际生死为空。为所修善至无余依般涅槃位。亦无散舍而观空故名无散空。诸圣种姓自体本有非习所成说名本性。菩萨为此速得清净。而观空故名本性空。菩萨为得大士相好。而观空故名为相空。菩萨为令力无畏等一切佛法皆得清净。而观此空故名一切法空。是十四空随别安立。此中何者说名为空。颂曰

  补特伽罗法　　实性俱非有
  此无性有性　　故别立二空

论曰。补特伽罗及法实性俱非有故名无性空。此无性空非无自性。空以无性为自性故名无性自性空。于前所说能食空等。为显空相别立二空。此为遮止补特伽罗法增益执空损减执。如其次第立后二空。如是已显空性差别。此成立义云何应知。颂曰

  此若无杂染　　一切应自脱
  此若无清净　　功用应无果

论曰。若诸法空未生对治无客杂染者。一切有情不由功用应自然解脱。若对治已生亦不清净。则应求解脱勤劳无果既尔。颂曰

  非染非不染　　非净非不净
  心性本净故　　由客尘所染

论曰。云何非染非不染。以心性本净故。云何非净非不净。由客尘所染故。是名成立空差别义。此前空义总有二种。谓相安立。相复有二。谓无及有。空性有相。离有离无离异离一以为其。相。应知安立即异门等

    辩障品第二

已辩其相。障今当说。颂曰

  具分及一分　　增盛与平等
  于生死取舍　　说障二种性

论曰。具分障者。谓烦恼障及所知障。于诸菩萨种性法中具为障故。一分障者。谓烦恼障。障声闻等种性法故。增盛障者。谓即彼贪等行。平等障者。谓即彼等分行。取舍生死。能障菩萨种性所得无住涅槃。名于生死有取舍障。如是五障随其所应。说障菩萨及声闻等二种种性。复次颂曰

  九种烦恼相　　谓爱等九结
  初二障厌舍　　余七障真见
  谓能障身见　　彼事灭道宝
  利养恭敬等　　远离遍知故

论曰。烦恼障相略有九种。谓爱等九种结爱结障厌。由此于顺境不能厌离故。恚结障舍。由此于违境不能弃舍故。余七结障真见。于七遍知如次障故。谓慢结能障伪身见遍知。修现观时有间无间我慢现起。由此势力彼不断故。无明结能障身见事遍知。由此不知诸取蕴故。见结能障灭谛遍知。由萨迦耶及边执见怖畏灭故。由邪见谤灭故。取结能障道谛遍知。取余法为净故。疑结能障三宝遍知。由此不信受三宝功德故。嫉结能障利养恭敬等遍知。由此不见彼过失故。悭结能障远离遍知。由此贪着资生具故。复有别障能障善等十种净法。其相云何。颂曰

  无加行非处　　不如理不生
  不起正思惟　　资粮未圆满
  阙种性善友　　心极疲厌性
  及阙于正行　　鄙恶者同居
  倒粗重三余　　般若未成熟
  及本性粗重　　懈怠放逸性
  著有着资财　　及心性下劣
  不信无胜解　　如言而思义
  轻法重名利　　于有情无悲
  匮闻及少闻　　不修治妙定

论曰。如是名为善等法障。所障善等其相云何。颂曰

  善菩提摄受　　有慧无乱障
  回向不怖悭　　自在名善等

论曰。如是善等十种净法。谁有前说几种障耶。颂曰

  如是善等十　　各有前三障

论曰。善有三障。一无加行。二非处加行。三不如理加行。菩提有三障。一不生善法。二不起正思惟。三资粮未圆满。发菩提心名为摄受。此有三障。一阙种性。二阙善友。三心极疲厌性。有慧者。谓菩萨于了此性有三种障。一阙正行。二鄙者共住。三恶者共住。此中鄙者。谓愚痴类乐毁坏他名为恶者。无乱有三障。一颠倒粗重。二烦恼等三障中随一有余性。三能成熟解脱慧未成熟。性障断灭名无障。此有三障。一俱生粗重。二懈怠性。三放逸性。回向有三障。令心向余不向无上正等菩提。一贪着诸有。二贪着资财。三心下劣性。不怖有三障。一不信重补特伽罗。二于法无胜解。三如言而思义。不悭有三障。一不尊重正法。二尊重名誉利养恭敬。三于诸有情心无悲愍。自在有三障令不得自在。一匮闻生长能感匮法业故。二少闻。三不修治胜三摩地

复次如是诸障于善等十。随余义中有十能作。即依彼义应知此名。十能作者。一生起能作。如眼等于眼识等。二安住能作。如四食于有情。三任持能作。谓能任持如器世间于有情世间四照了能作。如光明于诸色。五变坏能作。如火等于所熟等。六分离能作。如镰等于所断等。七转变能作。如金师等转变金等成镮钏等。八信解能作。如烟等于火等。九显了能作。如因于宗。十至得能作。如圣道等于涅槃等。依如是义故。说颂言

  能作有十种　　谓生住持照
  变分离转变　　信解显至得
  如识因食地　　灯火镰工巧
  烟因圣道等　　于识等所作

于善等障应知亦然。一生起障。谓于其善以诸善法应生起故。二安住障。谓于菩提以大菩提不可动故。三任持障。谓于摄受以菩提心能任持故。四照了障。谓于有慧以有慧性应照了故。五变坏障。谓于无乱转灭迷乱名变坏故。六分离障。谓于无障此于障离系故。七转变障。谓于回向以菩提心转变相故。八信解障。谓于不怖无信解者有怖畏故。九现了障。谓于不悭于法无悭者。为他显了故。十至得障。谓于自在此是能得自在相故。所障十法次第义者。谓有欲证无上菩提。于胜善根先应生起。胜善根力所任持故。必得安住无上菩提。为令善根得增长故。次应发起大菩提心。此菩提心与菩萨性为所依止。如是菩萨由已发起大菩提心及胜善根力所持故。断诸乱倒起无乱倒。由见道中无乱倒故。次于修道断一切障。既断障已持诸善根回向无上正等菩提。由回向力所任持故。于深广法便无怖畏。既无怖畏。便于彼法见胜功德。能广为他宣说开示。菩萨如是种种功德力所持故。疾证无上正等菩提。于一切法皆得自在。是名善等十义次第。虽善等法即是觉分波罗蜜多。诸地功德而总别异。今应显彼菩提分等诸障差别。颂曰

  于觉分度地　　有别障应知

论曰。复于觉分波罗蜜多诸地功德各有别障。于菩提分有别障者。颂曰

  于事不善巧　　懈怠定减二
  不植羸劣性　　见粗重过失

论曰。于四念住有于诸事不善巧障。于四正断有懈怠障。于四神足有三摩地减二事障。一于圆满欲勤心观随减一故。二于修习八断行中随减一故。于五根有不植圆满顺解脱分胜善根障。于五力有羸劣性障。谓即五根由障所杂有羸劣性。于七等觉支有见过失障。此是见道所显示故。于八圣道支有粗重过失障。此是修道所显示故。于到彼岸有别障者。颂曰

  障富贵善趣　　不舍诸有情
  于失德减增　　令趣入解脱
  障施等诸善　　无尽亦无间
  所作善决定　　受用法成熟

论曰。此说十种波罗蜜多所得果障。以显十种波罗蜜多自性之障。谓于布施波罗蜜多说富贵自在障。于净戒波罗蜜多说善趣障。于安忍波罗蜜多说不舍有情障。于精进波罗蜜多说减过失增功德障。于静虑波罗蜜多说令所化趣入法障。于般若波罗蜜多说解脱障。于方便善巧波罗蜜多说施等善无穷尽障。由此回向无上菩提。令施等善无穷尽故。于愿波罗蜜多说一切生中善无间转障。由大愿力摄受能顺善法生故。于力波罗蜜多说所作善得决定障。由思择力及修习力能伏彼障非彼伏故。于智波罗蜜多说自他受用法成熟障。不如闻言而觉义故。于地功德有别障者。颂曰

  遍行与最胜　　胜流及无摄
  相续无差别　　无杂染清净
  种种法无别　　及不增不减
  并无分别等　　四自在依义
  于斯十法界　　有不染无明
  障十地功德　　故说为十障

论曰。于遍行等十法界中有不染无知障。十地功德如次建立为十地障。谓初地中所证法界名遍行义。由通达此证得自他平等法性。第二地中所证法界名最胜义。由通达此作是思惟。是故我今于同出离。一切行相应遍修治。是为勤修相应出离。第三地中所证法界名胜流义。由通达此知所闻法是净法界最胜等流。为求此法。设有火坑量等三千大千世界。投身而取不以为难。第四地中所证法界名无摄义。由通达此乃至法爱亦皆转灭。第五地中所证法界名为相续无差别义。由通达此得十意乐平等净心。第六地中所证法界名无杂染无清净义。由通达此知缘起法无染无净。第七地中所证法界名种种法无差别义。由通达此知法无相。不行契经等种种法相中。第八地中所证法界名不增不减义。由通达此圆满证得无生法忍。于诸清净杂染法中不见一法有增有减。有四自在。一无分别自在。二净土自在。三智自在。四业自在。法界为此四种所依。名四自在所依止义。第八地中唯能通达初二自在所依止义。第九地中亦能通达智自在所依义。圆满证得无碍解故。第十地中复能通达业自在所依义。随欲化作种种利乐有情事故。复略颂曰

  已说诸烦恼　　及诸所知障
  许此二尽故　　一切障解脱

论曰。由此二种摄一切障故。许此尽时一切障解脱。前障总义有十一种。一广大障。谓具分障。二狭小障。谓一分障。三加行障。谓增盛障。四至得障。谓平等障。五殊胜障。谓取舍生死障。六正加行障。谓九烦恼障。七因障。谓于善等十能作障。八入真实障。谓觉分障。九无上净障。谓到彼岸障。十此差别趣障。谓十地障。十一摄障。谓略二障

辩中边论卷上辩中边论卷中

        世亲菩萨造

        大唐三藏法师玄奘奉　诏译

    辩真实品第三

已辩其障。当说真实。颂曰

  真实唯有十　　谓根本与相
  无颠倒因果　　及粗细真实
  极成净所行　　摄受并差别
  十善巧真实　　皆为除我见

论曰。应知真实唯有十种。一根本真实。二相真实。三无颠倒真实。四因果真实。五粗细真实。六极成真实。七净所行真实。八摄受真实。九差别真实。十善巧真实。此复十种。为欲除遣十我见故。十善巧者。一蕴善巧。二界善巧。三处善巧。四缘起善巧。五处非处善巧。六根善巧。七世善巧。八谛善巧。九乘善巧。十有为无为法善巧。此中云何根本真实。谓三自性。一遍计所执自性。二依他起自性。三圆成实自性。依此建立余真实故。于此所说三自性中。许何义为真实。颂曰

  许于三自性　　唯一常非有
  一有而不真　　一有无真实

论曰。即于如是三自性中遍计所执相常非有。唯常非有。于此性中许为真实。无颠倒故。依他起相有而不真。唯有非真。于依他起许为真实。有乱性故。圆成实相亦有非有。唯有非有。于此性中许为真实。有空性故。云何相真实。颂曰

  于法数取趣　　及所取能取
  有非有性中　　增益损减见
  知此故不转　　是名真实相

论曰。于一切法补特伽罗所有增益及损减见。若知此故彼便不转。是遍计所执自性真实相。于诸所取能取法中所有增益及损减见。若知此故彼便不转。是名依他起自性真实相。于有非有所有增益及损减见。若知此故彼便不转。是名圆成实自性真实相。此于根本真实相中无颠倒故。名相真实。无颠倒真实者。谓无常苦空无我性。由此治彼常等四倒。云何应知此无常等依彼根本真实立耶。颂曰

  无性与生灭　　垢净三无常
  所取及事相　　和合苦三种
  空亦有三种　　谓无异自性
  无相及异相　　自相三无我
  如次四三种　　依根本真实

论曰。无常三者。一无性无常。谓遍计所执。此常无故。二生灭无常。谓依他起。有起尽故。三垢净无常。谓圆成实。位转变故。苦三种者。一所取苦。谓遍计所执。是补特伽罗法执所取故。二事相苦。谓依他起。三苦相故。三和合苦。谓圆成实。苦相合故。空有三者。一无性空。谓遍计所执。此无理趣可说为有。由此非有说为空故。二异性空。谓依他起。如妄所执不如是有。非一切种性全无故。三自性空。谓圆成实。二空所显为。自性故。无我三者。一无相无我。谓遍计所执。此相本无故名无相。即此无相说为无我。二异相无我。谓依他起。此相虽有而不如彼遍计所执故名异相。即此异相说为无我。三自相无我。谓圆实成。无我所显以为自相。即此自相说为无我。如是所说无常苦空无我四种。如其次第依根本真实各分为三种。四各三种如前应知。因果真实。谓四圣谛。云何此依根本真实。颂曰

  苦三相已说　　集亦有三种
  谓习气等起　　及相未离系
  自性二不生　　垢寂二三灭
  遍知及永断　　证得三道谛

论曰。苦谛有三。谓无常等四各三相。如前已说。集谛三者。一习气集。谓遍计所执自性执习气。二等起集。谓业烦恼。三未离系集。谓未离障真如。灭谛三者。一自性灭。谓自性不生故。二二取灭。谓所取能取二不生故。三本性灭。谓垢寂二。即择灭及真如。道谛三者。一遍知道。二永断道。三证得道。应知此中于遍计所执唯有遍知。于依他起有遍知及永断。于圆成实有遍知及证得。故依此三建立道谛。粗细真实。谓世俗胜义谛。云何此依根本真实。颂曰

  应知世俗谛　　差别有三种
  谓假行显了　　如次依本三
  胜义谛亦三　　谓义得正行
  依本一无变　　无倒二圆实

论曰。世俗谛有三种。一假世俗。二行世俗。三显了世俗。此三世俗如其次第。依三根本真实建立。胜义谛亦三种。一义胜义。谓真如胜智之境名胜义故。二得胜义。谓涅槃。此是胜果亦义利故。三正行胜义。谓圣道。以胜法为义故。此三胜义应知但依三根本中圆成实立此圆成实总有二种。无为有为。有差别故。无为总摄真如涅槃。无变异故名圆成实。有为总摄一切圣道。于境无倒故亦名圆成实。极成真实略有二种。一者世间极成真实。二者道理极成真实。云何此二依彼根本真实立耶。颂曰

  世极成依一　　理极成依三

论曰。若事世间共所安立。串习随入觉慧所取。一切世间同执此事。是地非火色非声等。是名世间极成真实。此于根本三真实中。但依遍计所执而立。若有理义聪睿贤善能寻思者。依止三量证成道理施设建立。是名道理极成真实。此依根本三真实立。净所行真实亦略有二种。一烦恼障净智所行真实。二所知障净智所行真实。云何此二依彼根本真实而立。颂曰

  净所行有二　　依一圆成实

论曰。烦恼所知二障净智所行真实。唯依根本三真实中圆成实立。余二非此净智境故。云何应知相名分别真如正智摄在根本三真实耶。颂曰

  名遍计所执　　相分别依他
  真如及正智　　圆成实所摄

论曰。相等五事随其所应。摄在根本三种真实。谓名摄在遍计所执相。及分别摄在依他。圆成实摄真如正智。差别真实略有七种。一流转真实。二实相真实。三唯识真实。四安立真实。五邪行真实。六清净真实。七正行真实。云何应知此七真实依三根本真实立耶。颂曰

  流转与安立　　邪行依初二
  实相唯识净　　正行依后一

论曰。流转等七随其所应。摄在根本三种真实。谓彼流转安立邪行。依根本中遍计所执及依他起。实相唯识清净正行。依根本中圆成实立。善巧真实谓为对治。十我见故。说有十种云何于蕴等起。十我见耶。颂曰

  于蕴等我见　　执一因受者
  作者自在转　　增上义及常
  杂染清净依　　观缚解者性

论曰。于蕴等十法起十种我见。一执。一性。二执因性。三执受者性。四执作者性。五执自在转性。六执增上义性。七执常性。八执染净所依性。九执观行者性。十执缚解者性。为除此见修十善巧。云何十种善巧真实依三根本真实建立。以蕴等十无不摄在三种根本自性中故。如何摄在三自性中。颂曰

  此所执分别　　法性义在彼

论曰。此蕴等十各有三义。且色蕴中有三义者。一所执义色。谓色之遍计所执性。二分别义色。谓色之依他起性。此中分别以为色故。三法性义色。谓色之圆成实性。如色蕴中有此三义。受等四蕴界等九法各有三义随应当知。如是蕴等由三义别无不摄入彼三性中。是故当知十善巧真实。皆依根本三真实而立。如是虽说为欲对治十种我见故修蕴等善巧。而未说此蕴等别义。且初蕴义云何应知。颂曰

  非一及总略　　分段义名蕴

论曰。应知蕴义略有三种。一非一义。如契经言。诸所有色等。若过去若未来若现在若内若外若粗若细若劣若胜若远若近。二总略义。如契经言。如是一切略为一聚。三分段义。如契经言。说名色蕴等各别安立色等相故。由斯聚义蕴义得成。又见世间聚义名蕴。已说蕴义。界义云何。颂曰

  能所取彼取　　种子义名界

论曰。能取种子义。谓眼等六内界。所取种子义。谓色等六外界。彼取种子义。谓眼识等六识界。已说界义处义云何。颂曰

  能受所了境　　用门义名处

论曰。此中能受受用门义。谓六内处。若所了境受用门义。是六外处。已说处义。缘起义云何。颂曰

  缘起义于因　　果用无增减

论曰。于因果用若无增益及无损减。是缘起义。应知此中增益因者。执行等有不平等因。损减因者。执彼无因。增益果者。执有我行等缘无明等生。损减果者。执无明等无行等果。增益用者。执无明等于生行等有别作用。损减用者。执无明等于生行等全无功能。若无如是三增减执。应知彼于缘起善巧。已说缘起义。处非处义云何。颂曰

  于非爱爱净　　俱生及胜主
  得行不自在　　是处非处义

论曰。处非处义略由七种不得自在。应知其相。一于非爱不得自在。谓由恶行虽无爱欲而堕恶趣。二于可爱不得自在。谓由妙行虽无爱欲而升善趣。三于清净不得自在。谓不断五盖不修七觉支。决定不能作苦边际。四于俱生不得自在。谓一世界无二如来二转轮王俱时出现。五于胜主不得自在。谓女不作转轮王等。六于证得不得自在。谓女不证独觉无上正等菩提。七于现行不得自在。谓见谛者必不现行害生等事。诸异生类容可现行。多界经中广说此等。应随决了是处非处。如是已说处非处义。根义云何。颂曰

  根于取住续　　用二净增上

论曰。二十二根依于六事增上义立。谓于取境眼等六根有增上义。命根于住一期相续有增上义。男女二根于续家族有增上义。于能受用善恶业果乐等五根有增上义。于世间净信等五根有增上义。于出世净未知等根有增上义。已说根义。世义云何。颂曰

  因果已未用　　是世义应知

论曰。应知因果已未受用。随其所应三世义别。谓于因果俱已受用。是过去义。若于因果俱未受用。是未来义。若已受用因未已受用果。是现在义。已说世义。谛义云何。颂曰

  受及受资粮　　彼所因诸行
  二寂灭对治　　是谛义应知

论曰。应知谛者即四圣谛。一苦圣谛。谓一切受及受资粮。契经中说。诸所有受皆是苦故。受资粮者。谓顺受法。二集圣谛。谓即彼苦所因诸行。三灭圣谛。谓前二种究竟寂灭。四道圣谛。谓即苦集能对治道。已说谛义。乘义云何。颂曰

  由功德过失　　及无分别智
  依他自出离　　是乘义应知

论曰。应知乘者。谓即三乘。此中如应显示其义。若从他闻涅槃功德生死过失而起此智。由斯智故得出离者。是声闻乘。不从他闻涅槃功德生死过失自起此智。由斯智故得出离者。是独觉乘。若自然起无分别智。由斯智故得出离者。名无上乘。已说乘义。云何有为无为法义。颂曰

  有为无为义　　谓若假若因
  若相若寂静　　若彼所观义

论曰。应知此中假谓名等。因谓种子所摄藏识。相谓器身并受用具。及转识摄意取思惟。意谓恒时思量性识。取谓五识取现境故。思惟即是第六意识。以能分别一切境故。如是若假若因若相。及相应法总名有为。若寂静者。谓所证灭及能证道。能寂静故。彼所观义。谓即真如。是寂静道所缘境故。如是所说若诸寂静若所观义总名无为。应知此中缘蕴等十义所起正知。名蕴等善巧

真实总义略有二种。谓即能显所显真实。能显真实。谓即最初三种根本。能显余故。所显真实。谓后九种。是初根本。所显示故。所显九者。一离增上慢所显真实。二对治颠倒所显真实。三声闻乘出离所显真实。四无上乘出离所显真实。由粗能成熟细能解脱故。五能伏他论所显真实。依喻导理降伏他故。六显了大乘所显真实。七入一切种所知所显真实。八显不虚妄真如所显真实。九入我执事。一切秘密所显真实

    辩修对治品第四

已辩真实。今次当辩修诸对治。即修一切菩提分法此中先应说修念住。颂曰

  以粗重爱因　　我事无迷故
  为入四圣谛　　修念住应知

论曰。粗重由身而得显了。故观察此入苦圣谛。身以有粗重诸行为相故。以诸粗重即行苦性。由此圣观有漏皆苦。诸有漏受说为爱因。故观察此入集圣谛。心是我执所依缘事。故观察此入灭圣谛。怖我断灭由斯离故。观察法故。于染净法远离愚迷入道圣谛。是故为入四圣谛理。最初说修四念住观。已说修念住。当说修正断。颂曰

  已遍知障治　　一切种差别
  为远离修集　　勤修四正断

论曰。前修念住。已能遍知一切障治品类差别。今为远离所治障法。及为修集能对治道。于四正断精勤修习。如说已生恶不善法为令断故。乃至广说。已说修正断。当说修神足。颂曰

  依住堪能性　　为一切事成
  灭除五过失　　勤修八断行

论曰。依前所修离集精进。心便安住有所堪能。为胜事成修四神足。是诸所欲胜事因故。住谓心住。此即等持故。次正断说四神足。此堪能性。谓能灭除五种过失修八断行。何者名为五种过失。颂曰

  懈怠忘圣言　　及惛沉掉举
  不作行作行　　是五失应知

论曰。应知此中惛沉掉举合为一失。若为除灭惛沉掉举不作加行。或已灭除惛沉掉举。复作加行俱为过失。为除此五修八断行。云何安立彼行相耶。颂曰

  为断除懈怠　　修欲勤信安
  即所依能依　　及所因能果
  为除余四失　　修念智思舍
  记言觉沉掉　　伏行灭等流

论曰。为灭懈怠修四断行。一欲二正勤三信四轻安。如次应知。即所依等。所依谓欲勤所依故。能依谓勤依欲起故。所因谓信是所依。欲生起近因。若信受彼便希望故。能果谓安是能依。勤近所生果。勤精进者得胜定故。为欲对治后四过失。如数修余四种断行。一念二正知三思四舍。如次应知。即记言等。记言谓念能不忘境。记圣言故。觉沉掉者谓即正知。由念记言。便能随觉惛沉掉举二过失故。伏行谓思。由能随觉沉掉失已。为欲伏除发起加行。灭等流者。谓彼沉掉既断灭已。心便住舍平等而流。已说修神足。当说修五根。所修五根云何安立。颂曰

  已种顺解脱　　复修五增上
  谓欲行不忘　　不散乱思择

论曰。由四神足心有堪能。顺解脱分善根满已。复应修习五种增上。一欲增上。二加行增上。三不忘境增上。四不散乱增上。五思择增上。此五如次第即信等五根。已说修五根。当说修五力。何者五力次第云何。颂曰

  即损障名力　　因果立次第

论曰。即前所说信等五根。有胜势用复说为力。谓能伏灭不信障等。亦不为彼所陵杂故。此五次第依因果立。以依前因引后果故。谓若决定信有因果。为得此果发勤精进。勤精进已便住正念。住正念已心则得定。心得定已能如实知。既如实知无事不办。故此次第依因果立。如前所说。顺解脱分既圆满已复修五根。何位修习顺决择分。为五根位五力位耶。颂曰

  顺决择二二　　在五根五力

论曰。顺决择分中暖顶二种在五根位。忍世第一法在五力位。已说修五力。当说修觉支。所修觉支云何安立。颂曰

  觉支略有五　　谓所依自性
  出离并利益　　及三无染支

论曰。此支助觉故名觉支。由此觉支位在见道。广有七种。略为五支。一觉所依支。谓念。二觉自性支。谓择法。三觉出离支。谓精进。四觉利益支。谓喜。五觉无染支。此复三种。谓安定舍。何故复说无染为三。颂曰

  由因缘所依　　自性义差别
  故轻安定舍　　说为无染支

论曰。轻安即是无染因缘。粗重为因生诸杂染。轻安是彼近对治故。所依谓定自性即舍故。此无染义别有三。说修觉支已。当说修道支。所修道支云何安立。颂曰

  分别及诲示　　令他信有三
  对治障亦三　　故道支成八

论曰。于修道位建立道支。故此道支广八略四。一分别支。谓正见。此虽是世间而出世后得。由能分别见道位中自所证故。二诲示他支。谓正思惟正语一分等起。发言诲示他故。三令他信支。此有三种。谓正语正业正命。四对治障支。亦有三种。谓正精进正念正定。由此道支略四广八。何缘后二各分为三。颂曰

  表见戒远离　　令他深信受
  对治本随惑　　及自在障故

论曰。正语等三如次表已。见戒远离令他信受。谓由正语论议决择令他信知。已有胜慧。由正业故不作邪业令他信知。已有净戒。由正命故。应量应时如法乞求衣钵等物令他信。已有胜远离。正精进等三如次对治本随二烦恼及自在障。此所对治略有三种。一根本烦恼。谓修所断。二随烦恼。谓惛沉掉举。三自在障。谓障所引胜品功德。此中正精进别能对治。初为对治彼勤修道故。正念别能对治。第二系念安住止等相中。远离惛沈及掉举故。正定别能对治。第三依胜静虑。速能引发诸神通等胜功德故。修治差别云何应知。颂曰

  有倒顺无倒　　无倒有倒随
  无倒无倒随　　是修治差别

论曰。此修对治略有三种。一有颠倒顺无颠倒。二无颠倒有颠倒随。三无颠倒无颠倒随。如是三种修治差别。如次在异生有学无学位菩萨。二乘所修对治有差别相云何应知。颂曰

  菩萨所修习　　由所缘作意
  证得殊胜故　　与二乘差别

论曰。声闻独觉以自相续身等为境而修对治。菩萨通以自他相续身等为境而修对治。声闻独觉于身等境。以无常等行相思惟而修对治。若诸菩萨于身等境。以无所得行相思惟而修对治。声闻独觉修念住等。但为身等速得离系。若诸菩萨修念住等。不为身等速得离系。但为证得无住涅槃。菩萨与二乘所修对治。由此三缘故而有差别

修对治总义者。谓开觉修损减修莹饰修发上修邻近修。谓邻近见道故。证入修增胜修初位修中位修后位修有上修无上修谓所缘作意至得殊胜

    辩修分位品第五

已说修对治。修分位云何。颂曰

  所说修对治　　分位有十八
  谓因入行果　　作无作殊胜
  上无上解行　　入出离记说
  灌顶及证得　　胜利成所作

论曰。如前所说修诸对治。差别分位有十八种。一因位。谓住种性补特伽罗。二入位。谓已发心。三加行位。谓发心已未得果证。四果位。谓已得果。五有所作位。谓住有学。六无所作位。谓住无学。七殊胜位。谓已成就诸神通等殊胜功德。八有上位。谓超声闻等已入菩萨地。九无上位。谓已成佛。从此以上无胜位故。十胜解行位。谓胜解行地一切菩萨。十一证入位。谓极喜地。十二出离位。谓次六地。十三受记位。谓第八地。十四辩说位。谓第九地。十五灌顶位。谓第十地。十六证得位。谓佛法身。十七胜利位。谓受用身。十八成所作位。谓变化身。此诸分位差别虽多应知。略说但有三种。其三者何颂曰

  应知法界中　　略有三分位
  不净净不净　　清净随所应

论曰。于真法界位略有三。随其所应摄前诸位。一不净位。谓从因位乃至加行。二净不净位。谓有学位。三清净位。谓无学位。云何应知依前诸位差别建立补特伽罗。颂曰

  依前诸位中　　所有差别相
  随所应建立　　诸补特伽罗

论曰。应知依前诸位别相。如应建立补特伽罗。谓此住种性。此已发心等

修分位总义者。谓堪能位即种性位。发趣位即入加行位。不净位净不净位。清净位有庄严位遍满位。谓遍满十地故无上位

辩中边论卷中辩中边论卷下

        世亲菩萨造

        大唐三藏法师玄奘奉　诏译

    辩得果品第六

已辩修位。得果云何。颂曰

  器说为异熟　　力是彼增上
  爱乐增长净　　如次即五果

论曰。器谓随顺善法。异熟力。谓由彼器增上力。令诸善法成上品性。爱乐谓先世数修善力。今世于善法深生爱乐。增长谓现在数修善力。令所修善根速得圆满。净谓障断得永离系。此五如次即是五果。一异熟果。二增上果。三等流果。四士用果。五离系果。复次颂曰

  复略说余果　　后后初数习
  究竟顺障灭　　离胜上无上

论曰。略说余果差别有十。一后后果。谓因种性得发心果如是等果展转应知。二最初果。谓最初证出世间法。三数习果。谓从此后诸有学位。四究竟果。谓无学法。五随顺果。谓因渐次应知。即是后后果摄。六障灭果。谓能断道即最初果。能灭障故说为障灭。七离系果。谓即数习及究竟果。学无学位如次远离烦恼系故。八殊胜果。谓神通等殊胜功德。九有上果。谓菩萨地。超出余乘未成佛故。十无上果。谓如来地。此上更无余胜法故。此中所说后六种果。即究竟等前四差别。如是诸果但是略说。若广说即无量果总义者。谓摄受故。差别故。宿习故。后后引发故。标故。释故。此中摄受者。谓五果。差别者。谓余果。宿习者。谓异熟果。后后引发者。谓余四果。标者谓后后等四果。释者谓随顺等六果。分别前四果故

    辩无上乘品第七

已辩得果。无上乘今当说。颂曰

  总由三无上　　说为无上乘
  谓正行所缘　　及修证无上

论曰。此大乘中总由三种无上义故名无上乘。三无上者。一正行无上。二所缘无上。三修证无上。此中正行无上者。谓十波罗蜜多行。此正行相云何应知。颂曰

  正行有六种　　谓最胜作意
  随法离二边　　差别无差别

论曰。即于十种波罗蜜多随修差别有六正行。一最胜正行。二作意正行。三随法正行。四离二边正行。五差别正行。六无差别正行。最胜正行。其相云何。颂曰

  最胜有十二　　谓广大长时
  依处及无尽　　无间无难性
  自在摄发起　　得等流究竟
  由斯说十度　　名波罗蜜多

论曰。最胜正行有十二种。一广大最胜。二长时最胜。三依处最胜。四无尽最胜。五无间最胜。六无难最胜。七自在最胜。八摄受最胜。九发起最胜。十至得最胜。十一等流最胜。十二究竟最胜。此中广大最胜者。终不欣乐一切世间富乐自在。志高远故。长时最胜者。三无数劫熏习成故。依处最胜者。普为利乐一切有情为依处故。无尽最胜者。回向无上正等菩提无穷尽故。无间最胜者。由得自他平等胜解。于诸有情发起施等波罗蜜多。速圆满故。无难最胜者。于他有情所修善法但深随喜。令自施等波罗蜜多速圆满故。自在最胜者。由虚空藏等三摩地力。令所修施等速圆满故。摄受最胜者。无分别智之所摄受。能令施等极清净故。发起最胜者。在胜解行地最上品忍中。至得最胜者。在极喜地。等流最胜者。在次八地。究竟最胜者。在第十地及佛地中。菩萨如来因果满故。由施等十波罗蜜多。皆有如斯十二最胜。是故皆得到彼岸名。何等名为十到彼岸。颂曰

  十波罗蜜多　　谓施戒安忍
  精进定般若　　方便愿力智

论曰。此显施等十度别名。施等云何各别作业。颂曰

  饶益不害受　　增德能入脱
  无尽常起定　　受用成熟他

论曰。此显施等十到彼岸各别事业。如次应知。谓诸菩萨由布施波罗蜜多故。于诸有情普能饶益。由净戒波罗蜜多故。于诸有情不为损害。由安忍波罗蜜多。故他损害时深能忍。受由精进波罗蜜多故。增长功德。由静虑波罗蜜多故。起神通等能引有情令入正法。由般若波罗蜜多故。能正教授教诫有情令得解脱。由方便善巧波罗蜜多故。回向无上正等菩提。能令施等功德无尽。由愿波罗蜜多故。摄受随顺施等胜生。一切生中恒得值佛。恭敬供养常起施等。由力波罗蜜多故。具足思择修习二力伏灭诸障。能令施等常决定转。由智波罗蜜多故。离如闻言诸法迷谬。受用施等增上法乐。无倒成熟一切有情。如是已说最胜正行。作意正行其相云何。颂曰

  菩萨以三慧　　恒思惟大乘
  如所施设法　　名作意正行

论曰。若诸菩萨以闻思修所成妙慧。数数作意思惟大乘。依布施等如所施设契经等法。如是名为作意正行。此诸菩萨以三妙慧思惟大乘有何功德。颂曰

  此增长善界　　入义及事成

论曰。闻所成慧思惟大乘。能令善根界得增长思所成慧思惟大乘。能正悟入所闻实义。修所成慧思惟大乘。能令所求事业成满。谓能趣入修治地故。作意正行有何助伴。颂曰

  此助伴应知　　即十种法行

论曰。应知如是作意正行。由十法行之所摄受。何等名为十种法行。颂曰

  谓书写供养　　施他听披读
  受持正开演　　讽诵及思修

论曰。于此大乘有十法行。一书写。二供养。三施他。四若他诵读专心谛听。五自披读。六受持。七正为他开演文义。八讽诵九思惟。十修习行。十法行。获几所福。颂曰

  行十法行者　　获福聚无量

论曰。修行如是十种法行。所获福聚其量无边。何故但于大乘经等说修法行获最大果。于声闻乘不如是说。颂曰

  胜故无尽故　　由摄他不息

论曰。于此大乘修诸法行。由二缘故获最大果。一最胜故。二无尽故。由能摄益他诸有情。是故大乘说为最胜。由虽证得无余涅槃。利益他事而恒不息。是故大乘说为无尽。如是已说作意正行。随法正行其相云何。颂曰

  随法行二种　　谓诸无散乱
  无颠倒转变　　诸菩萨应知

论曰。随法正行略有二种。一无散乱转变。二无颠倒转变。菩萨于此应正了知。此中六种散乱无故。名无散乱。六散乱者。一自性散乱。二外散乱。三内散乱。四相散乱。五粗重散乱。六作意散乱。此六种相云何应知。颂曰

  出定于境流　　味沉掉矫示
  我执心下劣　　诸智者应知

论曰。此中出定由五识身。当知即是自性散乱。于境流者。驰散外缘即外散乱。味沉掉者。味着等持惛沉掉举即内散乱。矫示者。即相散乱。矫现相已修定加行故。我执者。即粗重散乱。由粗重力我慢现行故。心下劣者。即作意散乱。依下劣乘起作意故。菩萨于此六散乱相。应遍了知当速除灭。如是已说无散乱转变。无颠倒转变云何应知。颂曰

  智见于文义　　作意及不动
  二相染净客　　无怖高无倒

论曰。依十事中如实智见。应知建立十无倒名。此中云何于文无倒。颂曰

  知但由相应　　串习或翻此
  有义及非有　　是于文无倒

论曰。若于诸文能无间断次第宣唱说名相应。共许此名唯目此事。展转忆念名为串习。但由此二成有义文。与此相违文成无义。如实知见此二文者。应知是名于文无倒。于义无倒其相云何。颂曰

  似二性显现　　如现实非有
  知离有非有　　是于义无倒

论曰。似二性显现者。谓似所取能取性现。乱识似彼行相生故。如现实非有者。谓如所显现实不如是有。离有者。谓此义所取能取性非有故。离非有者。谓彼乱识现似有故。如实知见此中义者。应知是名于义无倒。于作意无倒者。颂曰

  于作意无倒　　知彼言熏习
  言作意彼依　　现似二因故

论曰。所取能取言所熏习名言作意。即此作意是所能取分别所依。是能现似二取因故。由此作意是戏论想之所熏习名言作意。如实知见此作意者。应知是于作意无倒。于不动无倒者。颂曰

  于不动无倒　　谓知义非有
  非无如幻等　　有无不动故

论曰。前说诸义离有非有。此如幻等非有无故。谓如幻作诸象马等。彼非实有。象马等性亦非全无。乱识似彼诸象马等而显现故如是诸义无如现似所取能取。定实有性亦非全无。乱识似彼所取能取而显现故。等声显示阳焰梦境及水月等。如应当知。以能谛观义如幻等。于有无品心不动散。如实知见此不动者。应知是于不动无倒。于二相无倒者。谓于自相及共相中俱无颠倒。于自相无倒者。颂曰

  于自相无倒　　知一切唯名
  离一切分别　　依胜义自相

论曰。如实知见一切眼色乃至意法皆唯有名。即能对治一切分别。应知是于自相无倒。此依胜义自相而说。若依世俗非但有名。可取种种差别相故。于共相无倒者。颂曰

  以离真法界　　无别有一法
  故通达此者　　于共相无倒

论曰。以无一法离法无我者故。真法界诸法共相摄。如实知见此共相者。应知是于共相无倒。于染净无倒者。颂曰

  知颠倒作意　　未灭及已灭
  于法界杂染　　清净无颠倒

论曰。若未断灭颠倒作意。尔时法界说为杂染。已断灭时说为清净。如实知见此染净者。如次是于染净无倒。于客无倒其相云何。颂曰

  知法界本性　　清净如虚空
  故染净非主　　是于客无倒

论曰。法界本性净若虚空。由此应知。先染后净二差别相。是客非主。如实知见此客相者。应知是名于客无倒。于无怖无高俱无颠倒者。颂曰

  有情法无故　　染净性俱无
  知此无怖高　　是于二无倒

论曰。有情及法俱非有故。彼染净性亦俱非有。以染净义俱不可得。故染净品无减无增。由此于中无怖无慢。如实知见无怖高者。应知是名于二无倒

无倒行总义者。谓由文无倒。能正通达止观二相。由义无倒。能正通达诸颠倒相。由作意无倒。于倒因缘能正远离。由不动无倒。善取彼相。由自相无倒。修彼对治无分别道。由共相无倒能正通达本性清净。由染净无倒。了知未断及已断障。由客无倒。如实了知染净二相。由无怖无高二种无倒。诸障断灭得永出离。此十无倒如次安立。于彼十种金刚句中。何等名为十金刚句。谓有非有无颠倒。所依幻等喻无分别。本性清净杂染清净。虚空喻无减无增。为摄如是十金刚句有二。颂言

  应知有非有　　无颠倒所依
  幻等无分别　　本性常清净
  及杂染清净　　性净喻虚空
  无减亦无增　　是十金刚句

且初安立十金刚句。自性者。谓自性故。所缘故。无分别故。释难故。自性故者。谓三自性。即圆成实遍计所执及依他起。是初三句如次应知。所缘故者即三自性。无分别故者。谓由此无分别即无分别智。及于此无分别即本性清净。如次应知安立境智。谓三自性及无分别。释难故者。谓所余句。且有难言。遍计所执依他起相。若实是无云何可得。若实是有不应诸法本性清净。为释此难说幻等喻。如幻事等虽实是无而现可得。复有难言。若一切法本性清净。如何得有先染后净。为释此难说有染净及虚空喻。谓如虚空虽本性净。而有杂染及清净时。复有难言。有无量佛出现于世。一一能度无量有情。令出生死入于涅槃。云何生死无断灭失。涅槃界中无增益过。为释此难说染及净无减无增。又有情界及清净品俱无量故。第二安立彼自性者。如有颂言

  乱境自性因　　无乱自性境
  乱无乱二果　　及彼二边际

如是已说随法正行。离二边正行云何应知。如宝积经所说中道行。此行远离何等二边。颂曰

  异性与一性　　外道及声闻
  增益损减边　　有情法各二
  所治及能治　　常住与断灭
  所取能取边　　染净二三种
  分别二边性　　应知复有七
  谓有非有边　　所能寂怖畏
  所能取正邪　　有用并无用
  不起及时等　　是分别二边

论曰。若于色等执我有异。或执是一名为一边。为离此执说中道行。谓观无我乃至儒童。见有我者定起此执。我异于身或即身故。若于色等执为常住是外道边。执无常者是声闻边。为离此执说中道行。谓观色等非常无常定执有我。是增益有情边。定执无我是损减有情边。彼亦拨无假有情故。为离此执说中道行。谓我无我二边中智。定执心有实。是增益法边。定执心无实。是损减法边。为离此执说中道行。谓于是处无心无思无意无识。执有不善等诸杂染法。是所治边。执有善等诸清净法。是能治边。为离此执说中道行。谓于二边不随观说。于有情法定执为有。是常住边。定执非有是断灭边。为离此执说中道行。谓即于此二边中智执有无明所取能取各为一边。若执有明所取能取各为一边。如是执有所治诸行能治无为。乃至老死及能灭。彼诸对治道所取能取各为一边。此所能治所取能取。即是黑品白品差别。为离此执说中道行。谓明与无明无二无二分。乃至广说。明无明等所取能取皆非有故。杂染有三。谓烦恼杂染。业杂染。生杂染。烦恼杂染复有三种。一诸见。二贪嗔痴相。三后有愿。此能对治。谓空智无相智无愿智。业杂染。谓所作善恶业。此能对治。谓不作智。生杂染有三种。一后有生。二生已心心所念念起。三后有相续。此能对治。谓无生智无起智无自性智。如是三种杂染除灭说为清净。空等智境。谓空等法三种杂染。随其所应。非空等智令作空等。由彼本性是空性等。法界本来性无染故。若于法界或执杂染或执清净各为一边。本性无染非染净故。为离此执说中道行。谓不由空能空于法。法性自空乃至广说

复有七种分别二边。何等为七。谓分别有分别非有各为一边。彼执实有补特伽罗以为坏灭。立空性故。或于无我分别为无为。离如是二边分别说中道行。谓不为灭补特伽罗方立空性。然彼空性本性自空。前际亦空后际亦空中际亦空。乃至广说。分别所寂分别能寂各为一边。执有所断及有能断。怖畏空故。为离如是二边分别。说虚空喻。分别所怖分别从彼所生可畏各为一边。执有遍计所执色等。可生怖故。执有从彼所生苦法。可生畏故。为离如是二边分别说画师喻。前虚空喻为声闻说。今画师喻为菩萨说。分别所取分别能取各为一边。为离如是二边分别说幻师喻。由唯识智无境智生。由无境智生复舍唯识。智境既非有识。亦是无要。托所缘识方生故。由斯所喻与喻同法。分别正性分别邪性各为一边。执如实观为正为邪。二种性故。为离如是二边分别说两木生火喻。谓如两木虽无火相。由相钻截而能生火。火既生已还烧两木。此如实观亦复如是。虽无圣道正性之相。而能发生正性圣慧。如是正性圣慧生已。复能除遣此如实观。由斯所喻与喻同法。然如实观虽无正性相。顺正性故亦无邪性相。分别有用分别无用各为一边。彼执圣智要先分别方能除染。或全无用。为离如是二边分别说初灯喻。分别不起分别时等各为一边。彼执能治毕竟不起。或执与染应等时长。为离如是二边分别说后灯喻。如是已说离二边正行差别。无差别正行云何。颂曰

  差别无差别　　应知于十地
  十波罗蜜多　　增上等修集

论曰。于十地中十到彼岸。随一增上而修集者。应知说为差别正行。于一切地皆等修集布施等十波罗蜜多。如是正行名无差别六正行总义者。谓即如是品类最胜。由此思惟如所施设大乘法等。由如是品无乱转变修奢摩他。及无倒转变修毗钵舍那为如是义修中道行而求出离。于十地中修习差别无差别行。如是已说正行无上。所缘无上其相云何。颂曰

  所缘谓安界　　所能立任持
  印内持通达　　增证运最胜

论曰。如是所缘有十二种。一安立法施设所缘。二法界所缘。三所立所缘。四能立所缘。五任持所缘六印持所缘。七内持所缘。八通达所缘。九增长所缘。十分证所缘。十一等运所缘。十二最胜所缘。此中最初谓所安立。到彼岸等差别法门。第二谓真如。第三第四如次应知。即前二种到彼岸等差别法门。要由通达法界成故。第五谓闻所成慧境。任持文故。第六谓思所成慧境。印持义故。第七谓修所成慧境。内别持故。第八谓初地中见道境。第九谓修道中乃至七地境。第十谓即七地中世出世道品类差别分分证境。第十一谓第八地境。第十二谓第九第十如来地境。应知此中即初第二。随诸义位得彼彼名。如是已说所缘无上。修证无上其相云何。颂曰

  修证谓无阙　　不毁动圆满
  起坚固调柔　　不住无障息

论曰。如是修证总有十种。一种性修证缘无阙故。二信解修证。不谤毁大乘故。三发心修证。非下劣乘所扰动故。四正行修证。波罗蜜多得圆满故。五入离生修证。起圣道故。六成熟有情修证。坚固善根长时集故。七净土修证。心调柔故八得不退地受记修证。以不住着生死涅槃。非此二种所退转故。九佛地修证。无二障故。十示现菩提修证。无休息故。无上乘总义者。略有三种无上乘义。谓正行无上故。正行持无上故。正行果无上故。何故此论名辩中边。颂曰

  此论辩中边　　深密坚实义
  广大一切义　　除诸不吉祥

论曰。此论能辩中边行故名辩中边。即是显了处中二边能缘行义。又此能辩中边境故名辩中边。即是显了处中二边所缘境义。或此正辩离初后边中道法故名辩中边。此论所辩是深密义。非诸寻思所行处故。是坚实义。能摧他辩非彼伏故。是广大义。能辩利乐自他事故。是一切义。普能决了三乘法故。又能除灭诸不吉祥。永断烦恼所知障故

  我辩此论诸功德　　咸持普施群生类
  令获胜生增福慧　　疾证广大三菩提

辩中边论卷下


辩中边论颂

    No. 1601 [cf. Nos. 1599, 1600]

辩中边论颂一卷

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    辩相品第一

  唯相障真实　　及修诸对治
  即此修分位　　得果无上乘
  虚妄分别有　　于此二都无
  此中唯有空　　于彼亦有此
  故说一切法　　非空非不空
  有无及有故　　是则契中道
  识生变似义　　有情我及了
  此境实非有　　境无故识无
  虚妄分别性　　由此义得成
  非实有全无　　许灭解脱故
  唯所执依他　　及圆成实性
  境故分别故　　及二空故说
  依识有所得　　境无所得生
  依境无所得　　识无所得生
  由识有得性　　亦成无所得
  故知二有得　　无得性平等
  三界心心所　　是虚妄分别
  唯了境名心　　亦别名心所
  一则名缘识　　第二名受者
  此中能受用　　分别推心所
  覆障及安立　　将导摄圆满
  三分别受用　　引起并连缚
  现前苦果故　　唯此恼世间
  三二七杂染　　由虚妄分别
  诸相及异门　　义差别成立
  应知二空性　　略说唯由此
  无二有无故　　非有亦非无
  非异亦非一　　是说为空相
  略说空异门　　谓真如实际
  无相胜义性　　法界等应知
  由无变无倒　　相灭圣智境
  及诸圣法因　　异门义如次
  此杂染清净　　由有垢无垢
  如水界全空　　净故许为净
  能食及所食　　此依身所住
  能见如此理　　所求二净空
  为常益有情　　为不舍生死
  为善无穷尽　　故观此为空
  为种性清净　　为得诸相好
  为净诸佛法　　故菩萨观空
  补特伽罗法　　实性俱非有
  此无性有性　　故别立二空
  此若无杂染　　一切应自脱
  此若无清净　　功用应无果
  非染非不染　　非净非不净
  心性本净故　　由客尘所染

    辩障品第二

  具分及一分　　增盛与平等
  于生死取舍　　说障二种性
  九种烦恼相　　谓爱等九结
  初二障厌舍　　余七障真见
  谓能障身见　　彼事灭道宝
  利养恭敬等　　远离遍知故
  无加行非处　　不如理不生
  不起正思惟　　资粮未圆满
  阙种性善友　　心极疲厌性
  及阙于正行　　鄙恶者同居
  倒粗重三余　　般若未成就
  及本性粗重　　懈怠放逸性
  著有着资财　　及心性下劣
  不信无胜解　　如言而取义
  轻法重名利　　于有情无悲
  匮闻及少闻　　不修治妙定
  善菩提摄受　　有慧无乱障
  回向不怖悭　　自在名善等
  如是善等十　　各有前三障
  于觉分度地　　有别障应知
  于事不善巧　　懈怠定减二
  不植羸劣性　　见粗重过失
  障富贵善趣　　不舍诸有情
  于失德减增　　令趣入解脱
  障施等诸善　　无尽亦无间
  所作善决定　　受用法成熟
  遍行与最胜　　胜流及无摄
  相续无差别　　无杂染清净
  种种法无别　　及不增不减
  并无分别等　　四自在依义
  于斯十法界　　有不染无明
  障十地功德　　故说为十障
  已说诸烦恼　　及诸所知障
  许此二尽故　　一切障解脱

    辩真实品第三

  真实唯有十　　谓根本与相
  无颠倒因果　　及粗细真实
  极成净所行　　摄受并差别
  十善巧真实　　皆为除我见
  许于三自性　　唯一常非有
  一有而不真　　一有无真实
  于法数取趣　　及所取能取
  有非有性中　　增益损减见
  知此故不转　　是名真实相
  无性与生灭　　垢净三无常
  所取及事相　　和合苦三种
  空亦有三种　　谓无异自性
  无相及异相　　自相三无我
  如次四三种　　依根本真实
  苦三相已说　　集亦有三种
  谓习气等起　　及相未离系
  自性二不生　　垢寂二三灭
  遍知及永断　　证得三道谛
  应知世俗谛　　差别有三种
  谓假行显了　　如次依本三
  胜义谛亦三　　谓义得正行
  依本一无变　　无倒二圆实
  世极成依一　　理极成依三
  净所行有二　　依一圆成实
  名遍计所执　　相分别依他
  真如及正智　　圆成实所摄
  流转与安立　　邪行依初二
  实相唯识净　　正行依后一
  于蕴等我见　　执一因受者
  作者自在转　　增上义及常
  杂染清净依　　观缚解者性
  此所执分别　　法性义在彼
  非一及总略　　分段议名蕴
  能所取彼取　　种子义名界
  能受所了境　　用门义名处
  缘起义于因　　果用无增减
  于非爱爱净　　俱生及胜主
  得行不自在　　是处非处义
  根于取住续　　用二净增上
  因果已未用　　是世义应知
  受及受资粮　　彼所因诸行
  二寂灭对治　　是谛义应知
  由功德过失　　及无分别智
  依他自出离　　是乘义应知
  有为无为义　　谓若假若因
  若相若寂静　　若彼所观义

    辩修对治品第四

  以粗重爱因　　我事无迷故
  为入四圣谛　　修念住应知
  已遍知障治　　一切种差别
  为远离修集　　勤修四正断
  依住堪能性　　为一切事成
  灭除五过失　　勤修八断行
  懈怠忘圣言　　及惛沉掉举
  不作行作行　　是五失应知
  为断除懈怠　　修欲勤信安
  即所依能依　　及所因能果
  为除余四失　　修念智思舍
  记言觉沉掉　　伏行灭等流
  已种顺解脱　　复修五增上
  谓欲行不忘　　不散乱思择
  即损障名力　　因果立次第
  顺决择二二　　在五根五力
  觉支略有五　　谓所依自性
  出离并利益　　及三无染支
  由因缘所依　　自性义差别
  故轻安定舍　　说为无染支
  分别及诲示　　令他信有三
  对治障亦三　　故道支成八
  表见戒远离　　令他深信受
  对治本随惑　　及自在障故
  有倒顺无倒　　无倒有倒随
  无倒无倒随　　是修治差别
  菩萨所修习　　由所缘作意
  证得殊胜故　　与二乘差别

    辩修分位品第五

  所说修对治　　分位有十八
  谓因入行果　　作无作殊胜
  上无上解行　　入出离记说
  灌顶及证得　　胜利成所作
  应知法界中　　略有三分位
  不净净不净　　清净随所应
  依前诸位中　　所有差别相
  随所应建立　　诸补特伽罗

    辩得果品第六

  器说为异熟　　力是彼增上
  爱乐增长净　　如次即五果
  复略说余果　　后后初数习
  究竟顺障灭　　离胜上无上

    辩无上乘品第七

  总由三无上　　说为无上乘
  谓正行所缘　　及修证无上
  正行有六种　　谓最胜作意
  随法离二边　　差别无差别
  最胜有十二　　谓广大长时
  依处及无尽　　无间无难性
  自在摄发起　　得等流究竟
  由斯说十度　　名波罗蜜多
  十波罗蜜多　　谓施戒安忍
  精进定般若　　方便愿力智
  饶益不害受　　增德能入脱
  无尽常起定　　受用成熟他
  菩萨以三慧　　恒思惟大乘
  如所施设法　　名作意正行
  此增长善界　　入义及事成
  此助伴应知　　即十种法行
  谓书写供养　　施供听披读
  受持正开演　　讽诵及思修
  行十法行者　　获福聚无量
  胜故无尽故　　由摄他不息
  随法行二种　　谓诸无散乱
  无颠倒转变　　诸菩萨应知
  出定于境流　　味沉掉矫示
  我执心下劣　　诸智者应知
  智见于文义　　作意及不动
  二相染净客　　无怖高无倒
  知但由相应　　串习或翻此
  有义及非有　　是于文无倒
  似二性显现　　如现实非有
  知离有非有　　是于义无倒
  于作意无倒　　知彼言熏习
  言作意彼依　　现似二因故
  于不动无倒　　谓知义非有
  非无如幻等　　有无不动故
  于自相无倒　　知一切唯名
  离一切分别　　依胜义自相
  以离真法界　　无别有一法
  故通达此者　　于共相无倒
  知颠倒作意　　未灭及已灭
  于法界杂染　　清净无颠倒
  知法界本性　　清净如虚空
  故染净非主　　是于客无倒
  有情法无故　　染净性俱无
  知此无怖高　　是于二无倒
  异性与一性　　外道及声闻
  增益损减边　　有情法各二
  所治及能治　　常住与断灭
  所取能取边　　染净二三种
  分别二边性　　应知复有七
  谓有非有边　　所能寂怖畏
  所能取正邪　　有用并无用
  不起及时等　　是分别二边
  差别无差别　　应知于十地
  十波罗蜜多　　增上等修集
  所缘谓安界　　所能立任持
  印内持通达　　增证运最胜
  修证谓无阙　　不毁动圆满
  起坚固调柔　　不住无障息
  此论辩中边　　深密坚实义
  广大一切义　　除诸不吉祥

辩中边论颂


成唯识宝生论(一名二十唯识顺释论)

    No. 1591 [cf. Nos. 1588-1590]

成唯识宝生论卷第一(一名二十唯识顺释论)

        护法菩萨造

        大唐三藏法师义净奉　制译

  有情恒为众苦逼　　炽燃猛火烧内心
  善士意乐起慈悲　　譬如自身皆自受
  敬礼善慧诸佛种　　于众烦恼皆除灭
  与无依者作归依　　能令极怖心安隐
  微笑降伏大魔军　　明智觉了除众欲
  于此大乘能善住　　深识爱源唯自心

论曰。谓依大乘成立三界但唯是识

释曰。此复何意。辄名大乘。本契弘心。坚持禁戒。遍诸生品。拔济有情。普令出离。获得难胜。无罪之行。极妙吉祥。是诸善逝。去而随去。无边大路。并所获果。圆满尊极。余不能知。由此义故。名为大乘。如经所说。言大乘者。谓是菩提萨埵所行之路。及佛胜果。为得此故。修唯识观。是无过失。方便正路。为此类故。显彼方便。于诸经中。种种行相。而广宣说。如地水火风并所持物品类难悉方处无边。由此审知自心相现。遂于诸处。舍其外相。远离欣戚。复观有海。諠静无差。弃彼小途。绝大乘望。及于诸有。耽着之类。观若险崖。深生怖畏。正趣中道。若知但是自心所作。无边资粮易为积集。不待多时。如少用功。能成大事。善逝行处。犹若掌中。由斯理故。所有愿求。当能圆满。随意而转。纵如所许有其外事。然由内心意乐殷重弘誓力故。能到无边六度之岸。若异此者。所舍之物尽持行施。及所遗生。何能总遍令其欢喜。惬顺求心。此即便成无边际境。所为施事。无有竟期。又复所有广为利益有情戒等。于诸无障有情之类。随彼乐欲悉能称意。赴彼希望正行施等。速便收集正觉资粮。由斯但自心。复何须外境。若许外事。复与正理义有相违。故知境无斯成胜妙。如仗自心妄生分别。作色等解。起身见等。无实不待外诸有情。而作所缘因生离染然于施等。各随其事。而能获果。实不假藉识外境事

若其识外有别境者。遂便依彼起诸烦恼。既被执取随转而住。见此过已心舍离生。深怀厌弃不悕大觉。既舍有情界如何欲弘益。由非摄取诸有生类。小心自度大行难成。然诸觉情依斯而转。方能长养菩提资粮。谓于客尘有为之事厌背心故证无为法。由无为法体不生长故。希余小寂偏证一边。无上觉山遂便沦退。若无外境爱厌俱亡。正觉之处斯成易得。岂非大悲常存于念。菩提萨埵极果方成。唯识之言。便为违害。然而大悲要托他身为缘性故。既除外境。但缘自识。此则便成怜自身故。利他为意大行方竖。唯顾己身寔乖弘度。虽陈雅责因斯无过。藉外相续为增上缘。于自识中现有情相。缘此为境起大悲心。于有情处而作弘益。此无相违。决定如是。应起信心。假令于彼色声等处一一推求彼无其我。设使和集我亦不成。然而本性不可舍故。既同所许无我为宗。当于何处欲兴悲念。于世共许当情妄执为所缘相以为有情。亦不应言。情所执事即是外境。由此应知。假令不乐理必许然。但于自识现有情相。依仗斯事色相生焉。是故定知无其外境。若离于识必不可得。是颠倒故。何谓颠倒本无外境见为实物。非妄执故。终能获得无上之处。可为应理唯识之见。是真实故。为彼方便深成称理

如何得知斯为实见。三界唯心是诠说故。凡有诤事欲求决定。须藉二门。一顺阿笈摩。二符正理。谓欲为彼信证圣人无倒宣说。所有传教引阿笈摩。若为此余不信之者。应申正理。或可为彼二人俱陈两事。如所信事令安住故。陈其正理。又为显其所论正理。有依仗处说阿笈摩。由其正理不依传教。未见真者所有言说。无非谬故名强思构。是故应知。阿笈摩者便成正理所托之处。或于自部有力用故。为此先陈阿笈摩教。尔来据义依大乘说。即第七声目其所为。谓欲证得彼大乘理说唯识观。是真实故。此不虚性。以阿笈摩善成立故。又若唯据言说大乘。犹如于义。假名乘者。依第七声所说声也。谓即依托大乘言教聚集之处。真实句义而成立之。但唯是识为欲明其所立宗义。于大乘教而引一隅。显所立宗。不于自教有相违背

此复何故名阿笈摩。辄自引证说斯言耶。谓从能说如理教者。假彼相续为增上缘。此教方生。于其听者识之差别。体有功能现前而住。或是亲闻或复传说。于所诠事当情相状。次第而生犹如笔画。章句形段昉然明现。从他来故名阿笈摩。若复有时自生忆念随顺本相识方生者。从彼生故得阿笈摩名。犹如自说名为佛语。德者义相。为智因故名智资粮岂非一切但唯有识。此违所许故。及自语相违。理固不然。非由于色有别异故。依识差别而为建立。如无色界所有差别。如无色界实无其色。但依于识分为四种立空处等。余界亦然。设复说三。于识何妨。犹若有情虽无差异然而安立欲色界殊。据其所系色差别故。色虽无异别立无过

岂不诠教言唯有心。今此立宗言唯有识。说违本教谅在凭虚义有所归。诚无斯过由其先许心意识了。是名差别。由同体事名不俱陈。故以异名而宣其义。即此唯了之言非众共许。欲令解义取共知声。更陈余号。复更显与经不相违。重说意识二声。况彼二义知体不别。即是其果。若欲要明不违经者。心了二声同其一义。明不违教。释妨已周。何须更说意与识耶。若说了声心异名者。心望心所是别有体犹如于境同生之类。念昔睡等便成是无。此则前后理相违背。实无此过。有所由故。此中心言许有相应。即是了言兼摄于彼。若如是者。识外之境心意诠故。于其心处更置唯声。意有取遮以为其果。境若无者遂成无用。唯声不遮。可如来责。现遮所缘境。如何言无用。若如斯解。由同生法及所缘境俱是离心别有其体。一便遮止。一乃见留。岂得事无由绪而空谈。自爱若无别意。诚如所诘。然由于境心聚共缘决断等事同类性故。于心所处假说心声。复为遮其非所许事。故于心处更置唯声。纵有所谈此还非理便成。亦是不取心言非一处显真假二事俱能彰显有力用故。如牛等声于心所处置此心言说心声时真事便舍。如于边鄙假说为牛。垂胡等事理定应弃。有言本意二事俱说。亦应更作一种异声。用表斯义或可摄声。撮略而显依俗论法。犹如欲声而为辩释。非唯自意能为巧释。元其绪系生决定耶。亦复不由有染等言。苏呾啰中有染等说。于其遮遣无有力用。于彼亦有有境言故。境亦不遮所说唯声。便成无用。若言外境非理须遮。无阿笈摩摩呾啰声。二处同故。随遮一事无决定因。是故须依异宗之见。心心所法体不相离。但位有别。即此唯声能遮外事。同生之法。无不遮故。凡总相声所有诠名。于其自事必不差别。非为决定而并现前。由其不遮理便总摄。为欲述晓如斯道理。故说心言许有相应。若离心所独心非有。故不应难。亦遣同遮。作是释时。唯遮外境。实有功能。述已义成。故说唯言以理准余但遮境事岂非所引有此中言。明知于余有除心所。复是容有如六识身。名为识聚若言此中说识蕴时兼摄心所。理定不然。想受及思。诸心所法。余蕴无故。若言犹如于色蕴者。由如取其仳喏那分立为色蕴。想等同然非相似故。若言许取由色差别。便以识声说其识蕴。非色等法是心位差。犹如于想。若以位差简有差时。随其色类为简别已。以色等声于识而立。此亦非理。斯乃便成。拨其识聚。由彼被斯色受等声割其分故。非位差外别可得故。离仳喏那位差之外。别有色位。犹如乐等所现相状。忧愁苦恼。于斯相处安置识声。随牛[爿*賣]理。若如是者。识六识身为其识蕴。义乃相违眼等诸识色等相现。故由其并是色聚所收。复更有余杂乱之过。若其青等相现之时。或违或顺。色行二蕴便成杂乱。如是复成于乐等位。受等相杂准斯道理。亦是破其总别之义。有说识能遍故是总相。声犹如初相。此之别相。谓是色等彼乃是其现相位差之因性故。此亦如前受等。便有杂乱之过。是故除其心所性言。犹如成立所有色聚。唯心之声表唯识耳。此亦不能于其心所及以所缘令疑断绝。言唯字者。有何所遮。虽言心所不离于心。此成虚言。由其相状体各别故所言识者。唯观现境杂染等性。但是爱着体非照察。如何能见。此即于彼体成殊别。及以更互。上来所述道理既多。然于本宗未为的要。且息傍论应辩正宗。心及心所设令体别。以其心字亦得相收。应知此义共成已久。若于其处诸心所法。不以自名而显说者。应知此中即是总目。所有心聚如调心等。但道其心。此谓共成。故知唯声但遮其境。若无境者。如何于青及甜味等。而了别之。由理不能拨现见故。谁言拨其现见之境。但于自识境相生焉。由自识相领受之时。遂即计执所有青等。如外而住。但为是其邪妄之解。犹如眩目见发蝇等。斯乃但是识之相别。现其蝇相即便妄执为有蝇耶。然而在外曾无蝇等自性可得。如何作境令识别生。此若无境。如何得之识似于彼相状生耶。要有本相似彼相生。可于此时得言似彼。如斯之事世皆共许。如于阳炎谓言似水。非无其境。亦能见故。如于萨埵有觉相生。而非离于色等体外有别萨埵实事可得。亦非色等或总或别。有其自性变坏等性而简别故。于心实事亦复不能舍其本性。或可萨埵是覆俗有。如斯道理。我亦同然。于色等处谓从于识。生差别性是覆俗故。如依色处执为车等。然而但由情所计执。于其色等覆障实性。于众缘处作自相状。而安置之。如在于外。即于是处见车等故。未审覆俗是何义耶。是覆障义。顺俗情故。由彼于其车乘等处计执自性。是覆俗有。覆其实体。生余执故。故彼妄情施设其相。先于斯事而执取之。虽无实相妄生境想。又如常等情所现相。何有本相而随顺之。是故虽无识外实境。识所现相。其理善成。或可此中言似相者。乃是随顺颠倒事义。如阳炎处翻作水解。便作水想。识亦于其色等相处生起倒情。故言现相。此不相违。有说其颠倒境亦依实事方始生心。此亦同前。悉皆征责

复有外律。作斯异执。离色等外别有我体。此复依何而生于倒。经云。依内。此亦无违。谓于俱生所起身见密而说故。故云于我正可用心。当见现见。如其亲近恶友等人。即云于我故作是说。然彼凡小妄生其识。遂起颠倒为外境相。或可随顺他共成事。而为言说。即如世间所共许事将为境者。即于其事唯识生起。是故由斯似境相故。缘色等识不取外境。如眩翳人见发蝇等。此外境空但唯有识。是其宗义。即由此义而为难曰。此喻不成。于光明分妄生发想。斯由其眼根亏力故。有说有别大种生而可见。遂令情执为其发等。若如是立似境相现。但唯识者处时等定便成非理。如其所有色等诸境离识别有。即于色等定其方所所现形量分局之处。其识于彼形量决断。方隅决定似彼相生。斯成应理。若如所许不由外境。但唯内识起妄所执色相生者。于余无处。如何不随形量决定处时现识相耶。随于方处见其处定。如随处有非一切处。境既无定。即于余处亦应可见。或不可见。然彼所立定不取其外境生识。于非有境所生之觉。曾无决定处时可得。有其实事。说境空故。决定时处所现之相。便成非有。然不如是。此既无定见色等心与彼乃是不相离性。是故不应执境空无。既无重执有有分者。此显立宗有相违过。若言其喻有成理者。身不定属理有相违。相应时处。和会共观。不偏属一。由觌斯境。此不应理。许境无故。此既境无。或复异类。言异类者。见异相时。此是根坏为其缘故。如眩翳人。亦不应有诸能观者咸皆患翳。然于时处现相应者。于诸身处不定而生。并于色等能见识生。准此应知。外境无故。于所量事在不定身不见生故。此则同前难斥宗过。又诸事用亦不应理。诸实发等现见。能为磨镜等用。何不用此识之发相。虽无真实事。而作用转生。此亦非理。无功能故。若其识分有功能者。眩目所觌何无发用。此之同有似发相故。斯亦同前。所量之境作用功能。不可见故。出其宗过。三喻为依。三事不同。于不实境而作三喻。由依根境功能差别。应知根有二种。一是色根。二非色根。即此初根由闇损故妄见其事。故为初喻。次第二根。于彼梦中见有差别。述第二喻。由其彼境有功力故。能生倒见引第三喻。此则是其一家异释。有余复言。处时决定。故缘色等心心是依托。非内现事而为其境。犹如缘彼章句之心。然于心内据最初起。随现有事而执取故。又且诸觉容有定时。然而于心如何定处。非无方处物有方处定及不定。故此据境上所有之法。于其心处而假说之。斯亦无过。此处能作现相事故。说为定处。凡由彼事心得生者。即名为境。此谓成立别有外境。取共许者将以为喻。于其相应时处住者。咸共生其无异相故。缘色等心以外一事而为其因。如同学类依教者。心依增上识。此得生起随其自相作用生故。故知离识别有色等。此不应有更应成立无发等用彼相之觉。犹如梦觉是觉性故。上来所述众多成立相违道理。意欲障他不定之过。有余复言。谓即于斯时处二种有其实义。即于此处时处决定应成非有。仁既不许有其境事。依彼差别亦不许故。何劳为他作便成过。此若非有便即相符。如贼被捉唱疮痛言。强作前宗诚为粗浅。不应理故。若言于识所现相状为所许者不应道理。虽呈雅思不异前释。或复随于时处差别所有之事。即于此处见其时处许为决定。纵于所许有实外境。然而色等永为定者。此亦非理异时异处有时见故。设令于此常时见有。然他不许如何于他不共许境。此之能别决定道理可遣许耶。故但于识而现其相。复有别作相违因难而为诘责。犹如成立境是空无我。还成立时处决定令非有故。若其时处是共许者。便成共许而遮遣之。由其无违方可得作相违之言。若言不是众所共许。斯乃全无我所不爱。由斯理故成无力难

复有自许。但用遮遣。于无境处。缘空之识无定时处故。彼之决定于色等处共见有故。成立外境是其实有。此亦应知离彼随成。但有遮遣不应理故。但用此一不能令他生其正解。斯非真实。且如前宗所立之义。由底蜜攞之所损故。于眼睛上有其疏膜。如罗网目外观白色。于彼隙中明相斯显。便生妄解将为发等。即此之喻于其所立。随成理阙。今应问彼。若光明相发等形状。此不应理。此光明相有见为黄。或见为赤。然于发等见为纯黑。或见众彩。如铄羯罗弓等。然其明目总能见者。于彼光边不观异相。如事见之。能作斯语。在隙光处倒为发解。此即便成。见发等心境空无性。光明支分非发相性故。及此似发等相现故。非但为因能为生者。遂令作其所缘性故。勿令缘其色等诸识便成缘彼眼等诸根因义同故。或可更有如斯别意。托实事因方生颠倒。余则不尔。斯言是实此亦便依。在内安布种子成就。不待外境。凡论境者。要须自相安布在心。然后方得成所缘性。其光明分起不关心。如何得作所缘之性。此亦未堪发生欢悦。次有计云。其患目人大种失度。睛生翳眩损其眼分。由彼损力便生异相。令于外境别大种生。依损根识便能见彼。是故定知羝蜜梨迦。所有觉慧缘实外境。如斯计者有大过失。凡邪倒事所起觉心。皆来设难。于乐等倒托谁为缘。而生是相作其境耶。虽无外境然有妄见。此则颠倒。便成非有。若言世俗不共许事。我即将此以为邪倒。还有大过。苦空等见缘萨帝时。是彼类故。此则不劳功力能见非倒。诸具缚者咸是悟真。如来出世宣扬正法。此即便成空无果利。何处得有如是定判。偏令翳目独受邪迷。又复于彼情有相状。见其有情飞行往还。令诸觉者观其摇扬。此诸萨埵许大种生。何不计命。设复百千群翳同聚。遂于一处各观别形。此时如何有对碍物。而不更相共为排摈。若言此亦由其翳力。则底蜜攞多用其功。于所学门善修幻术。能令诸法自性迁移。或应见许彼非质碍。非质碍故。如无贪等。便非色性。斯乃何殊唯识论者

又复何劳非处呈力。彼许大种。于其一一非青等性。但由种合因缘力故。眼等诸识缘彼相生。此本宗义凡是聚合非实物有。即此之识缘非实物。不劳深构。无违诤故。讵烦辛苦而为成立

成唯识宝生论卷第一

大唐景龙四年岁次庚戌四月壬午朔十五日景申三藏法师大德沙门义净宣释梵本并缀文正字

翻经沙门吐火罗大德达秣磨证梵义

翻经沙门中天竺国大德拔努证梵义

翻经沙门罽宾国大德达摩难陀证梵文

翻经沙门淄州大云寺大德惠沼证义

翻经沙门洛州崇光寺大德律师道[田*林]证义

翻经沙门福寿寺寺主大德利明证义

翻经沙门洛州太平寺大德律师道恪证义

翻经沙门大荐福寺大德大胜庄证义

翻经沙门相州禅河寺大德玄伞证义笔受

翻经沙门大荐福寺大德律师智积证义正字

翻经沙门德州大云寺寺主惠伞证义

翻经沙门西凉州伯塔寺大德惠积读梵本

翻经婆罗门右骁卫翊府中郎将员外置宿卫臣李释迦读梵本

翻经婆罗门东天竺国左卫翊府中郎将员外置同正员臣瞿金刚证译

翻经婆罗门东天竺国大首领臣伊舍罗证梵本

翻经婆罗门左领军卫中郎将迦湿弥罗国王子臣阿顺证译

翻经婆罗门东天竺国左执戟直中书省臣度颇具读梵本

翻经婆罗门龙播国大达官准五品臣李输罗证译

金紫光禄大夫守尚书左仆射同中书门下三品上柱国史馆国公臣匡臣源等及修文馆学士三十三人同监

判官朝散大夫行著作佐郎臣刘令植

使金紫光禄大夫行秘书监检校殿中监兼知内外闲厩陇右三使上柱国嗣号王臣邑成唯识宝生论卷第二(一名二十唯识顺释论)

        护法菩萨造

        大唐三藏法师义净奉　制译

论曰。复言处时定如梦者。谓如诸觉虽无其境共许有定。若时决定而有方处。见村园等复有定时。现前可得。然非彼有。斯言为显虽有决定时处之觉而无境故。彼于他成因无用故。即彼因云诸无境者。便成时处不决定故。由斯道理既有其定。故知所言彼之决定。非显有言。欲令成彼境无非有。不应道理。此即全无宗之过也。又成立时能有功能。有功能说。所立既无能立非有。能遍无故所遍亦无。方能与他出其宗过。犹如于秤无其重故。无别有分。此既共许。说无重故便舍别物。然非于此翻彼便成。时处定故能得成立。令境是有无随成故。犹如耳识所听闻性。不能成立声是其常。虽无不闻性。然不遮无常。他所成立外境是有。今欲显其是不定因。纵非外事于情亦复见其时处有决定义。有说由心惑乱。遂乃便生时处定解。然于梦中无其实境决定可得。故世共许。如何将此比余定事。为作过耶。若此梦想欲同觉者。理应梦心便是错解。斯则但是判在自应。而为嚼咽实不能知他之本意。非是他不许事。于此更令置其差别而难于他。成正理故。此已于前善为通讫。由此所有时处定心外境非有。不应致难。心带相生。何不合理。又向所说。应言惑乱为定解者。许离识外无定时处曾无非假遂令简彼。安能别言望所余事。斯为应理。然许如斯色类咸非外境。何须非处令安能别为出其过。尔者于彼梦中。实亦无其处时决定。相状在心由何得知。如有颂言

  若眠于夜裹　　见日北方生
  参差梦时处　　如何有定心

此但不委前后所述。朋党旨趣空爱巧词。由于时处不许。但言唯于此处。故不应诘处时决定。于他所许不相应故。如前已述。复有立言。梦心有境。是其念故。准知处等是其决定。此即缘彼曾境起故。于其梦中多有所见。设在空中见其流水。或于宏海都大火然。此亦是其昔时曾见。若水若空。或炎或海。各于别处观断事物。梦中起念为一处解执为空河。若不尔者。应许生盲忆青等故。若不许此。于其梦中是忆念者。生盲之人应忆青茜。凡为忆念是曾受故。此辈于青不能生想。应成道理。又复梦中自观斩首。此亦是念合其余事而有功能如向陈说。或中有位亲见自身被他斫截。观彼前身作自心解。曾受而舍今时尚忆。此固无违。岂不如先所经之物名为忆念。彼便梦中生其异见。非同昔时所观之物。非不定故。非唯一向曾所领事生忆念耶。即如多年曾所学业所有书疏。后起忆时。或倒次第。或复增言。或于其文而有忘失。若尔此之忆念便成非有。忆念之境遂是空无。非余实物别事相属。于其决定实事想心而为施设。如于马首曾不观角。然于忆时见其境事。如曾领受为自解相。于其念处生其异解。不缘外境。然于梦中见马有角如牛角者。准此应知。于寤所见。遂在梦中起颠倒想。成立空河生其忆念。此亦如是。纵有非倒之见。于彼梦内相续识中而生其执。所见之相固非识外。是故当知。梦中忆念有真实境。道理不成。然复梦者所见之事。如在目前睹江山等。然非寤时所有忆念能得如斯分明显著。既无异相何意不。同于其梦内被睡乱心所生忆。念于境分明见在目前。然非于梦觉寤之后。平善心中得有斯见。由如是故。而于梦中分明显现。彼此决断犹如觉时见境明白准彼梦心所见之物非关忆念。先于梦中曾见有物。后时梦内忆前梦事。然斯梦忆如彼觉人。虽念其境状似障隔。处遥远时不能显著观其色等。又如所言。生盲之类于其梦中无所睹见。虽有巧词。理应不成。此亦随其自种功能。至成就位。遂于心上梦观青等。然此未曾而作计会。如余流类虽梦青等遂令言说启发无由。又梦所见多是今生不曾经事而现在前。是故梦心不关忆念。纵令是念缘过境故。此则成立念境空无。过去未来非现在故。犹如非有。据实事故此中意言。其能缘觉境虽非有。然而时处决定可得。故知所许以境为先。方能见者。未能于我作无利事有余复言。由梦障心有力用故。于其别事暂时生起。识体清净无碍现前。犹如定者三摩地力。清净光明观无碍故。如于小室梦觌象群。及睹诸余广大之物。又梦见自身于别界趣等。在彼托生。然不能言于彼余体。非执受身为我身解。如非梦时受用之体。然非不舍此趣之身更执余处。得有斯理。复非此时。有其生死。便成见有亡尸之过

又复纵许有其生死。然于重生有其违害。后时觉寤其旧体。曾无毫厘亏损处。又于卧时。傍人不曾见身有异。然此渐顿于受生时有相违失。由此应知。但唯是识于彼熏习功能。现时即便观见种种相貌分明在心。斯为应理。又复纵于平田广石藤蔓虚悬。寝卧于斯观大境此亦非色。无质碍故。犹如受等。又此所许。于地水等是其色性体应质碍。若不许者。失对碍性复非无表。有不定过。由斯与彼道理同故。此之梦心有何奇异。营大功业不假外形。而能巧利构兹壮丽。或见崇墉九仞飞甍十丈。碧条藿蘼红花璀璨。匠人极思亦未能雕。若言于他同斯难者。彼无此过。不假外色功力起故。但由种熟仗识为缘。即于此时意识便现。又未曾见有经论说于彼梦中生其别色。是故定知畏难巧说于己所宗。盖其穴隙纵为方便。终亦不能令其梦中有别色起。是故理善成。处时定如梦

身不定如鬼者。实是清河无外异境。然诸饿鬼悉皆同见脓满而流。非唯一睹。然于此处实无片许脓血可得。何容得有溢岸而流。虽无实境决定属一。理定不成。此即应知。观色等心虽无外境不决定性。于身非有遮却境无。即彼成立有境之因。有不定过。于无境处亦有多身。共观不定。如何实无脓流之事。而诸饿鬼不别观之。由其同业咸于此位。俱见脓流悭吝业熟同见此苦。由昔同业各熏自体。此时异熟皆并现前。彼多有情同见斯事。实无外境为恩益故。准其道理仁亦于斯共同造作。所有熏习成熟之时。便无别相色等相分从识而生。是故定知不由外境识方得起。岂非许此同一趣生。然非决定彼情同业。由现见有良家贱室贫富等异。如是便成见其色等。应有差别。同彼异类见成非等。故知斯类与彼不同。彼亦不由外境力故。生色等境然诸饿鬼虽同一趣。见亦差别。由业异相所见亦然。彼或有见大热铁团融煮迸灒。或时见有屎尿横流非相似故。虽同人趣。薄福之人。金带现时见为铁锁赫热难近。或见是蛇吐其毒火。是故定知虽在人趣。亦非同见。若如是类无别见性。由其皆有同类之业。然由彼类有同分业生同分趣。复有别业各别而见。此二功能随其力故。令彼诸人有同异见。彼以此义亦答余言。有说别趣有情鬼傍生等。应非一处有不别见。由别作业异熟性故。此虽成趣业有差别。同观之业还有不异即诸有情自相续中有其别异。业种随故。彼任其缘各得生起

有余复言。诸饿鬼等同见事时。非无外境。由此器界是诸有情共增上业之所生故。要假现有河水澄流。方于此处见脓流等。由其薄福悭贪垢故。遂见如此不可爱事。若其彼类不见水者。即诸有情同增上力感得共果。理便阙失故。知此类有其实境。脓血等识要假其事此方有故。如于相续身邪倒执。执为我解由。无别事同见脓等。是故不定属一身生者。此由不能善了所缘故有斯见要待心心所了前境相故。说为所缘。然非饿鬼见其流水。如何不见得作所缘。若以别相即于水处睹脓流者。何处得有如斯定判观其本水。然于水相曾无片许为所观察。但睹其相而为境界。有说由似相状识许。此名为境。脓血之识无彼相故。方知不缘水等为境犹如军觉亦非为因成所缘性有大过失。前已申述。然此外境。于所缘心曾无恩益。若但为因亦大过失。前已说故。又如所言。由共相业之所感故必须见者。此亦不然。未生失眼及以远方不能观故。生无色者亦应得见。若言非彼业力生者。转向余生亦应不见。若言后时是所须者。我亦同然如无色界趣余生时。非无益故。然于饿鬼理亦同然。又复缘我所生邪见。即如次前所引道理。不缘色等有为之事。不缘彼相故如无为觉。是故定知自不晓了。必不令他能为解悟。然诸论文极分明故。如有颂云

  纵使河流鬼不见　　设有所见别为形
  明知彼皆由故业　　业障瞳人坏明睛

境虽非有。由业过故而令眼见体。是现有。而不能见斯即自许。故所见物便有别形。由此应知。实无脓血便有妄见。有余复言。然诸饿鬼由其非爱恶业力故。遂令其眼见如是相。虽同一时。余有福类所不见物。此遂谛观可厌之境。由此故知。诸饿鬼心缘其实境。今应问彼。为由眼根作斯妄见。虽无前境见非爱事。为当前境实有斯事。眼识依此生了别耶初且非理。许不爱境无妄心成故。若言此见由想差别实不相违前境空无。是所许故。其第二计如何彼境能现此形。若言由其恶业生者。如何一处众多同类得共居耶。不许碍物此得共余同一处故。如石与瓦许有同居。故知脓水体是别。方令同处见。是其应理。质碍性故。犹如乐等成非碍性。若言脓等是质碍性。不应一处可见如石。由此故知。一处见者。与理相违。若言聚物多有间隙。于彼空处共相涉入多者映余。设令相似不可别见。犹如水乳遍皆合故。又极坚硬金刚石等。火分入中是相违故。又复定者业力眼药所发眼根。决定能观前境之事远近粗细。不论可意及不可意。随其力用悉能见之。应有诚说。由此不能作如是说。于彼隙中更相涉入。虽在一处除可念水见非爱脓。此则许有外境实事。余人所观曾无缘碍及其睹水应见余形。鬼亦同然。俱瞻于水。如煮香油。咸皆共嗅。若言虽彼无别因缘但由其业不能于境水脓俱见。斯固是其暂违共许。非理爱脓。然仗自识一类同业自种熟时随缘现前起诸相貌。斯之妙理何不信耶。又复更有诸防护者。容像可畏。摄胆摧心。拔利刀执罥索。见便驱逐不令得近。纵使此时遭其巨难。亦不能得强作分疏言。此生类由彼恶业为胜缘故虽复先无忽然而有。此即便成扶助。唯识共立真宗。由此道理识所现相固无违害。如是应知不定属身虽无外境在识成就

如梦有损用。虽无外境。理亦得成。由于梦内男女两交。各以自根更互相触。虽无外境触而有作用成现流不净。但是识相自与合会为其动作。此既如是。于余亦然。恶毒刀兵霜雹伤害。虽无外境但依其识有毒刀等。何理不成此作用事。既无外境成共许故。宁容得有宗之过耶。彼定不能成作用者。此亦于其相离之处差别之触。于识分上现斯相状。便于自宗有不定过。然唯于识精流事成。复有说云。忆如斯位诸有生类。于一切时不见有故。然此所述不能成因。有不定过。觉情于事作用亦成。流泄之因于识转故。又复彼定不成作用之因。为当但据总相之识。言不能成。为识差别。此之初见即无同喻。由此所云识能为用。其增上识亦能生故。若第二计。其识能为所有作用。便与不能成事之因。有不定过。若尔何处得有如斯定事同无有境。或时有缘能为事用。非一切耶。功能别故。由彼诸缘功能各异。随其功能而为作用。又复与汝执外境师。其理相似境既同有。何不诸事一切时成。是故应许。于别别事各有功能作用之时呈其异相。此即便同唯识者见

有余复言。理实不由触着女形能生不净。觉时亦尔。然由极重染爱现前。便致如斯流溢之相。由于梦有等无间缘差别力故。遂便引起非理作意。以此为因便见流泄。如于梦中虽无实境。能流不净服毒严食触女形等。身体烦疼根充足力生男女等。于其梦中事应成有。是故定知。如于梦泄无境有用。觉之如是虽用无境非为应理。虽无其境识用成者。若于觉时纵境非有。许是唯识作用得成。此即岂非善符唯识。无境论者有何不爱。若言别有如斯意趣。诸有触等咸仗外事方成作用。但唯有识理不能成。如栴檀木磨作香泥用涂身体能除热闷使得清凉。然此流泄但依识生。此还于理未为的当。依触等境而有作用。非所许故。由非不许有外触者。而欲令他依斯触事作用起故。由此不应与他作用。便成非有之过也。由其成立唯有识者。但是事物所有作用差别。皆从识处生故。于此乍可作如斯难。既无外境。如何离识能有作用而成事耶。既有此征。便申雅喻。由如梦内损害事成。此于唯识能有作用。并已如前颇具申述。若尔梦餐毒等。应成身病。此亦由其唯识有用。犹如于境而有定属。还将后答用杜先疑。或复有时见其毒等。虽无实境而有作用。由见不被蛇之所螫。然有疑毒能令闷绝流汗心迷。若遭蛇螫亦于梦中由咒天等增上力故。遂令饱食气力充强。又复闻乎。为求子息事隐床人。梦见有人共为交集便得其子。如何得知于彼梦内被毒等伤。是为非有。睡觉之后不睹见故。今此所论还同彼类。于现觉时将为实事。见毒药等执为非谬。真智觉时便不见故。同彼梦中体非是实。然于梦中许实色者。彼亦获斯非所爱事。毒等果用便成实有。若言无者。但有毒相毒等用无。此云毒状便成违害。许毒相等固成无益。于其识上药体无故。是故定知。实无外境。但于觉心生其作用。犹如于梦觉亦同然。斯乃真成称契道理。上来且随如所说事。将别梦喻及别鬼等。如彼所陈四种之难。各为喻讫。今更复以奈洛迦喻。答彼诸难。其事善成。由极恶情极恶卒等有定处时不定皆见。咸不离识而有别形。并狗乌等所生墋害猛利之苦。随捶栲事至受罪终。可将斯喻随言难诘。凡诸释答。如上应思

复次理实无有极恶卒等。如所说事。有定不定。因何得生。然亦于彼起作用心。生此之因当时有用。获得生故。即此所观众多相异。假藉功能。并由内心相续随转业力差别。而为正因。复更假于取等顺缘。共相助故。随事而起见等转成。异熟等果悉皆显现。由此虽无实有狱卒。然于彼中要藉相似自造恶业增上力故。共于此中见处定等。亦复于彼生作用心。此等即是于彼色等非外实有显从识生。为明此义作斯成立。然由不待离识之境。是能遍故。出相违过。若触等境是色自性。即是所立。若言但是实事定执谓立已成。由将出彼过失之言为方便故。应知即是显己自宗成立之相。于中所立随顺之因。以梦等识为其喻故。即此执言。显如斯义决定处时所有事体。当情显现诸相貌故。如于梦内遍味其心。既梦觉后分明之想睹色等时。实亦不缘非识之色。未必要须色等境现。然由同业异熟所感共受用时。于自相续不定属一而生起故。犹如饥渴诸饿鬼辈。有同恶业见脓河等。或复如于极恶之处。皆见猛卒。于此宜应两皆成立。如现见境有其作用而显现故。如于梦中但唯识相。见与女人为交涉事。如狱卒等。皆共睹其苦害之事。并可述之。岂非要须极恶卒等成非有已方可将为能立之事。此既不成。便成无有。同喻之过。固无如是便成之失。由斯等物亦复将为有情。犹如无说。离于执受非受事故。然此亦非是执受事。犹如瓦木。亦如蚁封。由其不是有情数故。有何意故不许狱卒及狗乌等是有情数。然此同见有情形势及有动摇。亦不假藉外缘力故。如余萨埵。若尔斯乃便为诸因不成。此难非理。诸那洛迦所有动作不待外缘。彼那洛迦先罪恶业为任持者作摇动故。如木影舞同众生相

复由彼定不是有情。于五趣中所不摄故。犹如木石。由此故知。彼定不应同恶生类。如余恶生生于此处。同受于此所有共苦。然彼不受此之苦故。彼趣有情所有共苦不同受故。如持鬘等非那洛迦。而诸恶生同受斯苦。由彼共业俱生此处。若异此者。生尚难得。况受害耶。虽有斯理。其狱卒等不受彼苦。不是共成。此非正说。彼生不受同害苦故。由非能害者还如彼害生。一种焦然同受于苦。若也转计道为更互。共相害恼。故许彼生有时受苦。此亦非理。由其展转相害之时。此是那洛迦。此是波罗者。此之行伍便为亡失。以其能害可有作用为缘由故。说为狱卒。如一既尔。余亦应然。此则两皆成狱卒性。即那洛迦体性不离。遂成乖失。由此非是狱卒性故。如三十三天。意欲显说其那洛迦非被害者。若许更互。为害理齐。彼此相陵知己有力形量壮等更互相欺。不应生怖。设令见彼极大形躯。忖己骁勇便生胜想。如是知已宁容有怖。岂如那洛迦见于狱卒等。何况形量气力不殊。见彼之时令兴怯念。又复俱为狱典。形量是同。身力既齐。此无强弱。理应别有形量不等勇健墋列见便生怖。如是计时。那落迦类正受苦时。见彼卒来便生大怖。忧火内发胸臆全烧。相续苦生形骸战越。恶业生类受如斯恼。纵令善巧明智之徒。亦复未能总知其事。此之阶位理固相违。由于世间亦见斯事。有生恶意怀鸩毒心。欲害于他令生怯畏。虽即在于极重可畏怖惧之处。被拘顿时。不同怯者。生其怖畏。然而彼类怀坚硬心多见有故。彼那洛迦受苦之类。多怀恐怖身若镕锁。故此那洛迦非为能害者。由如屠所系柱之兽。然此是彼生怖因故。非受彼苦

成唯识宝生论卷第二成唯识宝生论卷第三(一名二十唯识顺释论)

        护法菩萨造

        大唐三藏法师义净奉　制译

论曰。奈洛迦波罗如猎鹿者。如是应知。非但不受相害之苦。然于器处共相之苦。亦复不受此之狱卒能害彼故。若异此者。彼在热铁融沸地上受烧然苦不能忍时。如何此际能逼害他。于此热地身动转时。那洛迦类自身支节。尚不能持。岂况更能有所为作。然而但可于热铁中洋沸腾涌。身由他制无片自在。然彼狱卒勇健害他。是故定知不受彼苦。犹若厨人遥执铁铲于热油内转彼煎鱼。或将狱卒为那洛迦。以其相害无功能故。尔者便成违狱卒义。然由那洛迦类受烧害时不能相害。若尔便成不是狱卒。言那洛迦奈洛迦波罗立为宗者。有违宗过。又复若言。受彼热铁极苦触故。诸那洛迦不能害彼。如以生命置炎炭中。或可斯类不沾此苦。如睹史天。此显狱卒。非那洛迦。即于此见外人别释。引经为证。极成乖失。然而暂为少慧之辈。显其僻见略举疏条。彼便难曰。于地狱处。狱卒之流不受苦者。我不许故。如经说云。汝等苾刍。有奈洛迦名六触处。若诸有情生在彼中。彼若以眼视诸色时。咸悉了见不可爱事。实彼有情有如斯事。狱卒非情何所观见。对执不许有情论者。便是共聚咀嚼虚空。彼设难云。诸那洛迦受彼苦时。有其差别得异身故。如一无间多无间罪。此亦未能闲他意趣。如前所云。生奈洛迦有情之类受苦切时。简于余趣所有苦毒。然彼狱中所有共苦咸悉同受。然于彼处由重业风惊飙猛烈。身遭极苦一无间者。则不受之。望彼多种无间猛苦。不同受故便成不定。为显斯事除彼狱卒。诸那洛迦无斯差别。彼趣同苦咸悉受故。即所立宗无异宗处。转生道理何成不定。然一无间受同苦故。有外难云。由其狱卒不受苦者。斯非正答。有不定故。然且不应作斯定判。见一受苦。令余亦然。现见世间共睹斯事。如羊骆驼被蝎蜇时。遂便致死。鸟之一分将以为食。且据傍生有斯差异。于人趣中亦复见有一不受苦。如患块者。医人遂便蹈热铁上。即以热脚蹋于病处。病人虽受极苦。医足曾无痛处。然而有情实无差别。此亦由其奈洛迦趣俱生苦法以不见故。遂不名此为那洛迦。见蜇毒等能断命根。此亦但是呈其广见。巧识俗途非关所论。契理之事。若云但据趣之相似。是彼趣收于斯宗处。即彼趣中见有不受彼趣之苦。显他宗有不定过者。此亦未解我成立义。当趣所有决定之苦。彼不共受是前作用能立义故。然非人畜在彼趣生。准彼法式须定受者。而不受之。所云羊等遭蝎毒时。有断命苦。或被热足所生之痛。若全不受彼趣苦故。非彼趣性可有斯愆。有异执云。然而狱卒由自他业增上所生不被害故。互相苦刻。他不许也。我今谓汝。而于自见乐着昏心。设在虚空步步颠蹶。奈洛迦波罗非他所害故。他逼所生所有苦痛必定不受。是其所许。然而执云不受彼处形害苦者。与谁助力。此转难曰。虽复有斯更互相害。由作用别致使位殊。犹如所缚能缚之异。尔者还将自语返破己宗。由匪同时能缚所缚。更互容为系绊之事。若言彼二次第而为。此亦非理。由非受系名为被缚。及其缚彼为能缚者。然而此二纵令苦次。于那洛迦亦不能立。若受墋毒极苦之时非那洛迦。若被他害。遭彼恼时是那洛迦。是不应许。一相续形有生有死。成大过故。同在一时更互相害。不容成故。由非一念是卒还非能为此计。若救转计虽同一趣。由作用别名号便异。一名那洛迦。一号狱卒。犹如人趣非典狱者有被枷者。此亦非理。不托彼故。由非仗托作用差别说那洛迦如被缚者。然此但由趣为因故。斯乃如何舍其狱卒。是故定知位有差别。由非趣同作斯缘绪。能所缚殊由作用别之所为故。理应随彼而作分位。诚无有违。若时许乐阶位别者。应须共许诸那洛迦非狱卒也。于我所宗唯尔是要。由此与前能立之义。善符顺故。若许实有那洛迦性。由作用别。有时名作掌狱者故。斯之执见所有阶位便。成无失然。则许有阶级殊途如。有颂云

  多嗔为墋业　　好行罪恶事
  见苦心欢悦　　当生琰摩卒

由非此相那洛迦有。若此伽他是实义者。如何辄尔作如是言。其狱卒等非有情数。随那洛迦所见之相。作如斯说。理复何违。诸近见者。由睹于他举动差别。为所量故测度彼心。然本在识种子熟时。随有如是相状差别。而起分别。随彼所见佛作斯说。欲令波跛恶业有情断除罪见。于奈洛迦极恶之处。彰显恶业所生苦报。随彼情见。于其识外说非爱事。礭论实理咸是内缘似相而现。固无违也

有异执云。虽复更相俱为苦害。此等阶级不越常途。由非此时有其定位。被害之者名那洛迦。能害之人号波罗矣。是故定知。诸那洛迦正被害时。无有便成狱卒之过

执此计时于我所成狱卒事用。曾无片许令爱乐耶。有说此由业力有斯异状。随逐有情还非一准。由此先曾更相恼害。复于狱处共为刑戮。彼此逼害遭诸痛苦。若有生命自无身力。能害于他但知忍苦。更无余暇。由彼有情先共为怨。故使今时更相苦害。彼皆是此那洛迦者。而彼展转共相害事。非他所许。随其自业识相生故。而云非是狱卒性故。彼非能害此出过言。全无意况。若被害者许是那洛迦。然能害者即不受。斯苦有说于同一趣诸狱卒类未必要须同形量等然与彼卒墋毒可畏。见便生怖。高大形躯非常威壮。设有形量可容相似。然彼身形含毒可畏。如篾戾车。见便悚惧。是能害者。设使此类躯貌矬[坐*委]。由其禀性是猛利故。纵令敌者形状伟大。情不比数事同草芥。陵篾彼徒力有容裕。此亦未能闲他意趣幽邃深义。然彼疏失。我且恕之。诸那洛迦更互相害事亦不殊。形量力等必须相似。有时虽复作如斯说。乘兹语势遂即难言。未必要须形量相似。此欲共谁而为击难。诸有忖度自身勇力。于他决胜便无怖心。如是许时。由其墋害或复威严者。斯乃诚为无义言也。由切逼迫生极怖故。非能害者。作成立时道其极怖。作便成过。方便显斯差别之相。仁今更复成立墋害。及以威严。此则便成大为恩造。能为善伴增我光辉。如上所言。得差别体。地狱器苦不同受之。或诸猛火由业力故便无烧苦。斯则自非。善友谁能辄作斯说。凡是密友性善之人。不论夷险常为恩益。为欲显其不受烧苦故致斯言。然于此时助成立义。即是显出善友之意。由其不受彼之苦故。意欲成立非那洛迦。今复更云。由其业力说有大火。言不烧者。斯则真成立唯识义。由无实火但唯业力能坏自性。既定不受如斯苦故。便成此火自性元无。然有实性。是宗所许。若也许其是识现相事体元无。此由业力故无实火。斯成应理。由其先业为限齐故。若异此者。彼增上业所招之果既现在。彼如何不见。如无智者欲求火灭更复浇酥。令唯识宗转益光炽。由斯众理。证此非成那洛迦类

设尔不成。那洛迦类是鬼是畜。理亦何伤。尔者既非那洛迦。如何生恶处。由非得余趣生于奈洛迦。若尔既生彼处已应同那洛迦。又复如何而许彼处得有生理。若生于彼当趣同分。彼初生时必应非有。有情数性非所许故。复由于彼同趣有情。无不定故。若执此见名为生者。诸大威神亦有于兹奈洛迦处为救有情应济之苦。此则虽非那洛迦类。亦见有故便成不定。非即据斯恒决定见作斯说故。此意欲论。唯于恶趣奈洛迦中而见有故。当尔之时诸琰摩王侍从使者。王若出行此必随逐。是时彼王并及侍从不出于界。若其彼界无差别类。云何天上亦有傍生。如天象等虽非天趣而生彼故。如是琰摩王界诸狱卒类。及狗乌等然非彼类亦生其中。由此道理同那洛迦。诸狱卒等生地狱时。即彼趣摄。何以故。同处生故。即由斯理能成决定。应受彼苦。此救不然。虽生地狱非那洛迦。何以故。不同受故。如天上傍生地狱中不尔者。诸有傍生及诸天等处不差别。如那洛迦等自业能感差别不同。彼所作业随自业力而受彼苦。是故定知天上傍生必有能感天上乐业。方乃生天同受彼乐。由顺乐业之所生故

所执傍生鬼不受彼苦故者。诸有傍生及饿鬼等。彼所生趣受种种苦。不尔云何诸狱卒等不受彼苦。由是故知。那洛迦苦非生报。业趣所受故。由如那剌陀等。若尔非无业者而生彼故。此亦如前已广分别。如彼业力之所感者。而于中现。此非同喻。然彼所立决定不成。非我所许。然于此中如铁山等乍离乍合。有所作故。有余师说。彼狱卒等亦受彼苦。然则所说因喻不同。前后相违故。应更说所依别故。或由增上火异业力而不受苦。何以故。如不受时。斯言有失。有余复说。犹如无色界苦受乐受亦有受处。然彼受者有所受故。此亦如是。斯见非理。然无色界有情生者。非是器故。彼界无处受等及行。云何方界摄取彼等。方分为因。有方分者。以为因故。如是应知实无方分。但唯有生欲色二界有情生者。有因积集。是故彼生应有方分。犹如色界有方分故。欲界亦然。彼界因故。不尔以无色故无住处故。犹如不和合者。此不如理。若尔应许彼那洛迦业增上力生异大种。非是有情之所摄故。地等大种于地狱中起别形显量力差别。如有情像颜色等异手。足身分量力差别。长短大小。于彼作用方名卒等。若尔非有情者云何卒等不待外缘手足身分种种作用。欲令彼等生大怖畏。变现种种增胜威力动手足等。此由风界令动手足。种种作用别别示现。彼之风力如人意乐。随念所作诸那洛迦。亦复如是。才见此时便生怖畏。彼地狱中那洛迦等。由业力故生大怖畏。犹如木人能有所作。种种示现大种和合。虽无思觉。业力因缘。遂见如是动手足等相状有异示现所作。诸无情等道理许成。彼之地处诸那洛迦业增上力。便令自见羝羊山等乍来乍去。斯非有情而亦见有。此则住处地等差别及狱卒等非是有情。理得成立。无劳致惑。尔者非无所缘。是狱卒等意乐生故。彼诸卒等及以地等处所不同形相表示那洛迦等。许由业力于地狱中地等大种生是形色差别变异手足动等处及大种。或有无斯诸系缚等。以业力故。理应不成。何缘不许。识由业力如是转变。如梦所见色等和合。外有影生种种相现。理应共许。转变作用。识由业力如是转变。与处相违。若许由业力何用异大种者。诸狱卒等由四大种种种转变动手足等作用别故。如梦所见色等处故。彼等形状无体用故。或非地等差别相故。如前所说羝羊山等。他不许成色相变故。变化亦然。形状等异由他力故。此由识变种种异相转转形仪差别不同。离识之外更无一物而有可见。此中外难。若但由识转变别异种种形仪狱卒等想。自识变故。同苦因故。诸那洛迦非狱卒等。此四大种由增上果同业生故。于受苦时不同受故。是故方须说四大种。如是所说不善他宗。云何不善。但说有情自识变现见狱卒等能为墋毒。由自识现各见卒等。诸苦害具互不相违。然如自识见苦害等同类影现。彼因同故。苦受用俱。师与弟子所作事业有同不同。于不同事而强说同。及孤地狱互不相见。苦不同故。所立大种。理谓不成

业熏习余处者。谓有执那洛迦由自业力差别因生。彼业熏习。理应许在识相续中。彼由业力不在余处积集力故。唯地等处业所作时。合因果故。此乃是为彼习果处卒等影像识缘差别和合得生。种种色类如应分别。不尔是诸大种和合积集因业力故。由业相续差别果成。如是应知。自身相续得定果故。习之忆念缘于种子。亦无殊异有情相续。如是知已。所以取少分一人等。显示所取相续内熏心及心所相差异果五趣所摄。自业熏习之所成故。如无色界熏习之果。离心心所无别不相应行。此中唯说名言差别体事无异。故是密意。或不离心心所体事不同及以生处。未离欲者。色之熏习。如如自力生处得生。行安立故。如无色界熏习之业。或心心所不离色处。大种所生业力和合。方能生故。或识相续住熏习果。故如念爱。憎等亦复如是。大所造色影像识变亦不离识。彼之形状差别所说执余处有果所熏识有果者。彼所习果此为因故。有余师说。唯自体力变为果也。欲色界生。业力熏习识依止故。如无色界。积集生业所熏习故。彼说无记识所依止熏习及余识聚俱相应果此不应有。是故说依止者。遍于一切有情所摄。或不用力便应得之。复有余说。自身业果于一身上而有因果。故如异熟识所安置。业是差别。故说身大种别别安布。果不应有。彼若如是。余人身识能依所依。同一作业亦无差别。有情施设。故同一流注俱异熟识。尔者非卒等想差别大种和合建立。地狱有情。是故相续有其差别。尔者若时相续无间之识。增上因故能生别识种种异类。此时应有相续别异因果转生。不尔云何此即欲说因差别故。如心相续和合种子是安立因。此中所说唯因能立。不说识增上缘是依止故。从斯种子无间相续识之差别。然由种子自体相续方得转生。言增上者。如彼地等唯能为缘。能造四大亦应如是。此亦不然。从自种子生时。说此唯缘。不尔从识相续别有四大种子。犹如无色界没生色界时。彼增上果。是异熟业之所感。得受用资具犹如异熟果。此可爱乐自业相续所感。此之正理顺阿笈摩识所变果

何因不许者。此由自见非理僻执。强思构画谁能辄说。谁识之果违阿笈摩。因何尔许。阿笈摩经不立唯识。离唯识外更无色等。不应别说有十二处。虽尔不离其识并十二处立善等法。如是应知有色等处。是佛说故。若离色等所立不成。违佛语故。或色等处体实有故。犹如意处。是佛说故。识与色等亦非别有。犹如法处。斯理不应。此中所说不遮唯识。何以故

依彼所化生。世尊密意趣。说有色等处。如化生有情者。如佛世尊说有化生有情。但唯依心相续不断能往后世。是其密意。不说实有化生有情。此言密意。谓欲调伏一类有情。是故佛言有化生有情。是密意说也。谓彼断见所害有情。随自乐为者。无后世者。无善恶因果者。为欲洗除此之恶见。是故说心相续不断。心相续言显当生故。此死彼生犹斯理故。相续不断说有化生。是为密意。离识之外更无别我。云何知然。如契经说。无我无众生。但有法因故。契经不尔。彼经不说有情亦有亦无。是故契经不相违故。心相续言显其不断能往后世。如是应知如色等处。此为成熟一类有情。说斯密意。是故所立亦无自教相违之过。如斯所立。因亦不定。何以故。依世。俗谛。佛说别有化生有情。元亦不说离识蕴已有善不善及彼果等。别有有情。是因不定。是故佛说。为除断见无后世者。如来世心相续不断。于其识蕴假立有情。于略诠中而说有故。离心无境。有其四意。何谓为四。一者密意。二者境界。三者显果。四者密意义。分别所缚如是因缘说十二处。此之一切当应建立。次第发起如理问答。云何密意说十二处。而有众生如心相续。相续不断。说有情能诠所诠于心安立执形像事。此中如是色等声境当应分别

识从自种生似境相。而转为成内外处。佛说彼为十者。从彼眼等处生彼色等处。如理应知。于彼二处说斯种子相及彼识。如世尊说。为成处等说共许声眼等差别此欲成立。说其青等分明显现。彼同类色从彼识。起未离欲者识之种子殊胜安立故得出生彼等种子。虽且安立果未现受。乃至未得相应缘力无间生灭。刹那刹那相续等中。获得微细体性巧妙差别转变得殊胜者。如谷麦等地等为缘和合增长。体性不同转转安立芽等出现。如斯法性外之种子。内亦如是。此之内心相续现前相对无间刹那之顷能生青等体性差别。然此种子说为眼界。如次现为彼彼果性。心及心所安立此色为其眼处。彼亦如是。若如是色差别显现。识体和合。警觉青等种子在阿赖耶识。由未显现识能警觉。影像变异自体差别。如颇胝迦琉璃云母等。以薄物裹随其本色影现识生。此乃世尊如理分析。说为色处。然自教中说彼意识形状不同。住利益故。所以此色说为色处。如是乃至坚湿暖等识之影像。所依所缘力用最胜。是异熟识之所生事。种子相状出生影现。声及名等变异差别之所取故。如是应成色之分段功能不同之所安立阿赖耶识。诸有智者分分觉了。而分别之说内外处。安布差别。是密意也。如安立界。此立识界依止意界依六出生。如是意界自性差异。然亦说彼十八界耶。如异熟识与眼等识次第为种名眼等处别别显现。何故名种。由能出生芽等众物。别异体性。如能造大及所造色。共许出生自类芽等。生差别故。犹如稻麦等诸种子。世间共许。彼之体性异类非一。乃能出生眼及眼识。并与第二刹那相应。从此二界生得彼缘随顺所立警觉之性。非为一事一时能生。如一心所别别能生无量色性故。此亦如是。异熟之识于眼等处或同或异。识所生时自体别故。异熟之识为眼等处。彼色微细。眼等诸根识。生种种功能。不同极难见故。亦不如此。有别眼等。或缘色等清净四大。尔者别阿笈摩。佛说肉眼等处清净四大所造色有见有对如是。乃至身等亦复如是。此不如理识之影像。密意说故。由是四大不离识之相分。斯亦不取缘青等识而为种子。以熏习识执着相故。识之种子由彼熏习。是异熟识之所持故。此亦不然。有清净色有见有对。不尔若有对等识之显现。非眼等识所熏习故。然烂坏种依止所缘。安立表示此亦不了。阿笈摩中安布分析。由是阿赖耶识。无始时来因果展转无量功力能含藏故。别别发起体色相待。彼彼界处生等别现。非一切时一时总生。如是广说眼等差别。乃至身相亦复如是。彼识种子欲示现力体性殊胜。此契经中。佛说安立阿陀那识。即如地等影像所现缘等相应。彼所安立种种芽性。体无损坏。然彼形状芽等显现和合力故。坚等体性随缘现生。以阿赖耶识所有因果色处和合。或由地等影现变异不同。能造四大。在于色处。然此假立语业所诠。于无色界语业虽转言诠不及。于彼界中色不现故。或色断故。不作是说。虽有色之种子。非眼境故。此之色种影缘力故。建立果色故。由此因故。质碍不成。诸有眼根映所损者。非此所取种之清净。方堪所用。如是乃至身不杂乱。所依所缘他所安立。如彼断坏及烂性等。彼之所立理应合有。是故此中若随色类。一一分别转转无穷

有余复言。说十二处。为欲成熟一类有情此说无力。亦无义故。人无性理。极妙甚深难解难入。亦令悟入。由是佛说立唯识义。复令如是无力之人。亦令易入于其色处。无量过失。是故此门执我之者。令舍离故。如说苦谛身之苦故。如是说处色等狂乱增上爱着所住种子之密意者。因立果名

成唯识宝生论卷第三成唯识宝生论卷第四(一名二十唯识顺释论)

        护法菩萨造

        大唐三藏法师义净奉　制译

论曰。识从自种生者。以因性同故。非有质碍。所依所缘五识身境识之相故。犹如意识。或不离心心所体性。彼眼等识同共作业。能生因故。犹如意处法处。此说表示苏呾罗意。经但说意。不立宗故。彼所破者亦不成立斯之所立。唯少分义若立此义。不应更说广造众论。此云何知。犹密意等说成立果及以境界。入人无性说十二处亦复如是。若离眼等色自性已。即能趣入人无我性。何以故。此从二六内外差别。谓即眼等色等六境。如是转生。亦不从彼差别见者。乃至眼触眼等作用。离此自性不应别更有其作者。若依眼等而作事业。自在受用斯说为我我执所缚。今于此中唯内外处和合自在。眼等作用有生灭故。斯亦非我眼等为因。无触对故。常与有情不相舍离但说为因。然能作者。于眼等处义亦如前。是故从彼别类不生。由是能悟人无性理。若人无性能调伏者。趣寂之人此亦能入。何以故。由于生死见众苦逼。以苦无常。于生死中心生厌离。无我见力顿能弃舍。怖我断者。次第因尽故。犹如薪尽火即灭故。是故佛言。为斯等类说十二处。有说是中不为人无性理说十二处。此之二相等无差别。有物性故。我见颠倒。以对治故。此说如理。如以颠倒对治颠倒。此非所许亦不善了。我之所立此之处等。宁无差别。心及心所体相差别。若此志乐心心所时。然彼眼处非耳等处。由是此说相差别故。此亦如是同时非一识生于彼。是眼等处自性乐欲。然而色等住金性时。非银等性。相无差别。此之金等离色等已。不能异说有其别物。如是道理。此无差别。不于体性说有色等。若如所说相颠倒故。不能对治。此与前执有情性同。如彼有情于无我处而见我者。是颠倒性。斯见颠倒。此能除遣如色等处。除我倒故。若心相续不断无颠倒者。此亦非理。是中自性乐欲相似不颠倒者。斯亦不善了前后故。若有说云。方便悟入人无自性。说色等处有其体性。犹如意处法处。若心心所我之自性。彼爱乐者。便无诤论。若离心心所别有我体实无有喻。此之言论如所分别。总相类故。非第一义。若说方便趣我无性。是亦不然。如应观察。安立此之巧妙方便。说色等处。然佛所说。但有如斯所应作事。谓欲令入我无自性。何烦更别说唯有心。此既非有。如何得云说十二处是密意耶。此亦非理。由其更说法无自性。是极重事欲令悟入。世尊遂说色等诸法而无自性。欲使诸余诸大菩萨得彼如来殊胜妙位。周遍生界为大胜益。此如何作。谓色等诸法相似现前。但唯是心。除识已外曾无片物为色等性。是可见事。由是故知。色等诸法无有自性。斯言意显诸事自性由自识力变现生起。理成决定。随其所知所有诸事。并皆离识无别可取。但唯是此而现相状。是以故知。实无自性。便能悟入法无性理

有说若为悟入法无性者。此据能胜作是说耶。所见之境唯是错乱。据胜义理本性空无。作此宣扬善符中观。所见境无识非有故。斯固未闲。作何意趣。且说如是心心所法所见之境不称其事。妄为领纳取不实相。名为错乱。岂非但说而唯有识。若言诸法一亦无者。尔复如何有所宣说。境既是无。识非有故。将梦等喻善为晓之。如上所陈。无劳致惑。不得外境。但唯识现。此复云何。识义非理。若是具义。由于业边亲益果故。即以此言便成答难。亦复不由体有别故。能成方异有说能持自体。此中复云是自性义。此亦同前已分析讫。此义不然。离其作具要有别事。方为作用。犹如自己。还持自身。故不应也。为欲令生悟法无性。说唯有识。将为契当。若言总无一切诸法。皆无有我。由此名为我无自性。斯即共许我之自性。悉皆非有。如是便成法无自性。诸法非有。由是故知。识亦同尔。性既非有。如何于此欲为安立为彼诸法并非有者。犹如假我更连趣性。无自体者。此是所许。更连趣体全无性也。此则便成法无性者。谓一切法皆无性故。是故应知。识亦同尔。此既非有。如何依此欲使迷人入法无性。由无有我遂令证入诸法无性。共许如斯为善方便。尔者如何欲为建立。成彼方便说十二处。证人无性。实非全无一切诸法。方始名为法无自性。是故应知。法无性声非诠。诸法皆无自体。更连趣言。亦同于此。不欲总诠一切非有。然而意说。诸缘生法无有我性。彼即是有。此我无性。其相云何。谓唤我作无自性故。是故名为人无自性。非是全无诸法自性。色等诸法随据一分。说无自性非谓全无。是故应知。言法无性非全无体。若言诸法事皆无者。即不应名法无自性。理应云说诸法总无。尔者但由所执法无自性缘有功能获得差别。离他自性简别彼之实我自体。恒时不有所诠之相。此谓诸法无自性义非是豁脱总拨为空。然所执者是何言耶。所谓无明倒见迷执。从其自心种子成熟。由他而转现相不同。执于外境有别自性。由如倒见作外相解。于自所见生定执时此则名为所执之事

此复云何。谓无一物。如何无物名所执耶。由此故然

若于此执有片实物体不虚者。即不应名是情所执。然由于此义有相应。由其计执实事自体不相忓故。若有实物不名计执。由此分齐近见之境。此则悉皆说为所执。假使用识以为斯境。作所量时。此亦还成所执之义。是故应知所执之识。亦是无性。即唯识性。是能悟入所有诸法。皆无自体微妙方便。但是本识随处现相。然无外境少许可得。从色至识悉皆如是。非是能现相分之识。体亦无也。若言异此。但遣遮色。说此唯声唯识之言。便不成就缘识之识。有其境故。复更便成缘色之识。是为有境。何者是其体离于彼不可说事。诸佛世尊方能了察。云何了察此义。后时我当宣释。此即是其心心生法有真实事。越言诠道是有性故。亦不便成一切诸法悉皆非有同豁脱空。是故应知证悟真理。善入方便说唯识教。斯为称理。由其次第渐能爴烈诸分别网所有正缘。为生因性故。尔者若许安立。离言诠处。是实有事。此即还成。于彼色等亦同荷负。有真自性。犹如于识。若尔还应问彼何处得有如斯道理。见他许有非所诠识。亦令色等同遣如斯未曾见有如是之事。以由爱蜜酪亦令贪。若复转计。言彼有斯不相离性事同芽者。能有随生果之因用。彼若言有不相离性。幸示方隅。以理推征定无共许。若言如识将为境时。由所执体名为所执。实事相貌作彼生因。色亦同斯。是执性故。亦应合有缘生之事。与作因缘犹如识者。此乃便成无片非爱。于彼五聚皆依他起。是所许故。遍计分别法性之义。可由于此理同于彼。现有如斯正教言故。若言其色亦有离识。实依他起。犹如受等。如斯意趣有不定[億-音+(夫*夫)]所执之分亦有识故。即此受等缘生之分。斯则是为四聚体性。然此现其影相之分。即是依于心心生聚而施设故。由斯道理其喻必成。而于所立无随合义。亦复更有立已成过。缘起之色亦是受等自性性故。因此遂令而于因处置差别言。冀蠲其过而云于识。现所执相差别生故。此即除其不定之过。仍在相中然共所许。受等自体是自证性。境无有故。既有斯理。实可依凭。然色别有无别因由。以义推寻。固非齐致。若尔一切诸识皆悉无有所知境者。此如何知。又云若有余识得与余识而为境耶。亦如有云。诸佛境界其法是有并余识境。若于佛境不以自心取为境者。斯即无容能有宣说。如此说者。并成妄设。如有思度发言诠故。由其言义所表之相。即是唯识现多种相。虽无外境似触其事而识得生。此即是为言论因也。如云生已即灭之声。假令息教博士绝声应听其响。固非于彼情有所得。然即于中共申言论。但可许业能为造作。领纳是受。彼即便成。许有实我。岂复当时别有真我而可得耶。不许同时二识生者。余识无间体是灭坏。如斯切难亦不相应。余识领此不相应故。亦以此言兼遮后难。如彼说云。如知境有。何以得知。此亦于其共相之境而为构画。说之为知。复亦与彼同招诘责。如彼所说。诠表如来有诸胜德。汝亦应成证知胜德。由此便非是佛之境。固亦不同如食米斋。此之共相是实有物。是故定知。不由外境现前力故。方能了察。此中但由心聚构画而便生起。既有斯理。于佛境界为难不成。此则因论生论傍义且周。然密意果其因应说。此之密意有其二因。一谓余教相违。二于正理有害。说唯识教即是相违。此阿笈摩不言成故。又复于彼幻网经中。如佛为于色。等境处生分别者。作如是说。即此眼识所知之色。不见实有及以定住。但于妄情起邪分别。作决定解而生言论。唯斯是实。余义成非。如是广陈。乃至于法次第说云。多闻圣弟子应如是学。我观过去未来现在眼识观彼所有诸色。然于彼处无有常定。无妄无异实事可得。或如所有。或无倒性。悉皆非有。唯除圣者。出过世间斯成真实。世尊。说此皆虚妄等。违阿笈摩。正理相违。宜且为说方兴问绪发起疑情。如何复知如是说者。此非是实。犹如说识。是如言义。说十二处。由其一性及非一性。思察之时。将以为境。无堪能故。是故定知。不如所说。即是其义故于今者试作商量。此色声等所应生处。各随自体。由于其识作生相貌。色等事相是识之境。色识名色。声识名声。余皆准此。此色声等应无支分。体是其一。如有分色。由此便于自所依处无支分性故。然此色等是有事物。体是质碍。有所断割。于其同类多处性故。能生识等不同处故。(此中阙极微义)由量力故。决断有无。于诸量中现量为胜。若无外境如何能起如是觉情。此事是我别根之所知也

别根如梦等。虽无外境。然亦得有。此已如前。细为分别

此若后缘时所见境已亡。如何许现量。于诸量为最者。若其当时生现量觉。此是我之别根所了。尔时于境遂无所见。唯是意识所刊定故眼识当时已谢灭故。义既如是。如何彼境许成现量耶。况复是为殊异论者。许一切法刹那不住。此觉起时。色等诸境亦皆已灭。现量之理。斯何得成。虽复如前善开释已。仍为于斯甚深法义不能窥测。更设难言。由量力故断为有者。或复此由违比量故。于色等处遮使成无。纵实由量。刊定有无。然由于彼别根比知及正教等诸量之中别根最胜。由亲证境是果性故。要于此处无违害已。方于余量而成立之。此即别根于色等处既亲证会。岂能令彼比量相违。辄欲遮其色等有性。如何外色成别根境。由若无境不能于此生如是觉。此事是我别根知也。此言意道。各别自证领受相生。重起心缘而宣说故。犹如曾领苦乐染等。此固不然。于余亦尔。别根如梦等见有如斯前已具说。于梦等位。亦有现见色等诸境。即如所言。覆察之心是有故者。显此立因有不定过。然由梦翳及罪逆心之所损故。如似别根现前明见。虽无实境而有见事。复亦不越识之体性。于所领事现前纳受。为断割故。由斯道理意欲成立色等实境是离识者。有相违过。徒事慢心。此复更有因不成过。此觉后缘时。所见境已亡。如何许现量。眼等诸识见色等时。彼实不能生斯断割。此但由其各别内证相分性故。因此为先意识随后取其定相。总集思构方能决断。又复当时识不俱起。设尔有其色等诸境眼等识灭后何能见。能见非有。所鉴岂成。正于此时何所悕望。从其灭识宁能有见。况于色等共识同亡。是故应知。此不能见色等诸境。藉彼见力重审之心。观于色等。如何许成别根量性。复于彼时意识断割。不共许为现量性故。由无能见及俱谢故。有余师云。于此最初领受其境。非分别垢之所染故。彼定缘于外色实境。此亦非理。是不成故。由非他许离于言诠。色等外境是识所知。然由内有自证之事。当尔之时不起思构。便缘诸境相貌差别。彼但许有如斯内缘。此亦随其相貌现时。但依于识。犹如共成。苦乐染等。然由将彼色等外境为别根量。此但是为虚妄情执。犹如彼此数量业等。还将此难用拓余疑。于梦见事。从梦觉已后覆缘想。虽复当时无境。然有上心之知。现量亦尔。由因此故。后时意识决了非无。彼亦尤无拨别根量。于自内证心心所生。不离自证而有现量。是所许故。然于外境将为现量斯妄增益。即是所遮。如前为出不成之过。未见解词。但事空言。寔无的当。彼全不许有外色等。更欲仗之明有现量。然所成立。不能远离所斥之过。故若也不曾领受前境意识。不能生忆念也。决定应许。于彼外境曾领受之。由斯能见于色等境许别根性。斯乃不成。曾领受境方能忆者。所以云何。由有理故

已说如相识者。虽无外境如境相现。眼等诸识遂得生起。如前已说。次复云何从此生忆念者。从此识后与念相应。即于此相分别意识而生起也。由领其境念方起故。其义不成。若尔于色等处。以现量性决定了知。所有相貌生忆念性故。犹如乐等。于忆念上安置形像而领取之。决断前相内自证解。然非不领。犹如石等。有其焰等。生意识时。亦不能生此之忆念。由斯决定依比量力于色等境。应必定有亲领受之。若异此者。所许忆念便成非有。复由于此受领之境成现量故。世间言论。名之为见。若于色等是忆念性。如共成者。可有斯过。即由于此外色等处领受忆念。理不许成。由有理故。如离于境得有其见。忆念同然。为其能立。不共成故。宗及于喻欲晓悟他。于境领受全无力用

成唯识宝生论卷第四成唯识宝生论卷第五(一名二十唯识顺释论)

        护法菩萨造

        大唐三藏法师义净奉　制译

论曰。如何不与色等诸境而相关涉名作见耶。若遣斯难。此不劳言。由斯识体自现形相。虽无色等而境得成。此前已说。梦狱翳等为能喻事。随其所应广陈比量

从此生忆念者。不待外境而现前故。见之自性方始得生。虽无实义。念与意俱由现见识所有功能安置力故。随其次第假藉余缘为能牵引觉想方生。当尔之时名为忆念。如何复知见之与忆两体差殊。若此见忆俱并不藉外境有故能生自体。由似境者。为性邪疑。说分别识见之为用。不生计度前境相状。但有自证体性生起念之相也。取其言相安布之差了相不明分别生也。以见为先熏习所遣。即此自性由他故生。见不然也。见之与念条然别故。为此定须许如斯理。假令虽复有其外境。二皆有境。缘相不殊。见之与忆自体不同。如有异途幸应为说。彼设虽缘现在之境。名之为见。如缘过去。说之为念。由无境者。彼虽境异有无之相。所缘别故。斯之异相。缘亦不能而于见念为片思也。宜应说为自体别故。斯成异相。尔者此境是其识所现相。若为决定知如是耶。由于前境决知见已与彼相似所起之识分明不忘。取彼事时。即名斯事而为似相。犹如决了丈夫相貌。方名此作似丈夫耶。似相了知非不曾见。然非曾见能有如斯决断之理。为由不许有外境故。斯亦非理。由彼自证心心所生解相不同是所许故。斯固于他全不成难。汝既分别于事善巧。我聊致问。理复如何同时自证。既不许有如何此见能决定耶。非过去事能有忆念。由彼非是自证性故。又非自证。如所说事违道理故。先当援己后乃击他。所有陈谋方能获胜。斯即念托境生。不共成也。复于梦处领纳外境。令共成托后时自可道彼元无成非理故。犹如乐等领受乐事。若其外境元有可领。但有似相错乱现前。当尔之时外境非有。自然决断。犹如梦者。觉乃知非

梦者见非有。觉已乃至非。若也觉时亦不领境。犹如梦中。彼是非有。世人自知。然不如是。是故定知于正觉时。然色等境有真领受不同梦中识无力用。此亦不能而为晓喻。令于色等领受义成。由作梦者处梦中时不能了境。是为非有。若由远离于睡闇时得分明慧。随其所有别别曾缘熏成念种。然于梦位所领之境。忆令上心方生决断。此事非有。彼既如是。此亦还然。虽非外色可为领受。便即翻作见外色心。起妄分别。重重现前数数缘虑。生此类性所有功能熏习成种令其上心。即此熏习。更欲彰其不实事故。后起余缘彰见真义。由有睡眠相似法故。虽于觉位亦曰睡也。为此熏习恒随逐故。世间睡眠犹如余睡。但有妄情离识别见。色声等境。而被缠缚极受艰辛。漂泊生津沦回欲海。由未正得熏习断故。犹如梦中不能觉了色等境无。未能称事于非起故。不了是无。为境所诳。纵有闻思所生之智。为由分别熏习随故。未现证真不能正起。亦名诳妄。当尔之时。名为不觉。及由于彼熏习种子对治已生。毕竟拔除深有力用。于创起时非世先有。由此名为出世间智。正断一切分别性故。无分别智获得现行。能除熏习无知睡故。证悟真觉于时藉此。无分别智以为因故。由此之力方便起故。决能截除色等诸义。固执熏习。名为清净。由涉计度诸境相故。号曰世间。彼智现已。但唯是识随其色类缘会力故。生起之时。唯于自识现其相分。妄执诸境而作生因。然非离识有自性故。色声等境而生了知。其所立量。若据总相不知彼境。是为无者。许能立因有不成过。若言差别觉时不知。还有不成与前相似。觉悟之位了境元无。宗所许故。既有斯过。理固不能以斯能立成其前境有可领纳。或有于此不成之过。申述解词犹若元来。不为境解此无之智。理不应成。要先知境方于此事能生此心。说为非有若尔的知前境是有。如何能得更复言无观相是有。复乃云无现是相违。若为通释。彼诸宗等拨为非有。固不相违。如诸外论。谓为常等。生前灭后悉并非无。或于方所或此非余。有境无余。何过之有。若时于我将为无者。由非不了可拨为无。于无起知非所许故。此不如文于兹色等说我为无。然于色等造作之处。无真实我非据我也。若尔于色等聚乍可无[億-音+(夫*夫)]。说识我无。如何免难。由不许有第二之识。于余识处了我为无。亦非不领于前而能忆念于后。设令生念境已亡故。是故应许但唯有识。而现于相。即如所许。然于识处知我是无。拨无其我。识若生时。此智尔时知无我体。然由离境了唯有识。随此相貌。缘若生时解境为无。岂非齐致。然于色等了无我时。于色等处是为共相。非是自相。由此各依以为定性。自体异故。然非相似所有相貌是实事有。欲令于余而作简别。有其异相附识而生。犹如实事有集心分。于识自体转起现前。世俗言论因斯生起。了知外境。但是自心所生领受。本非居外。斯乃是为最胜修习。所获性故。此由无明盖覆于慧。如在外转观斯共相。即如所见时俗言成。随世俗情于言说路令得明解。于诸论处似事而转。别以形相而宣说之。于所余事作其遮遣。于此事中应有形段。若总相是实即是总相。应如色等自体各异。而于别事体不相应。此则色等成非异体。如色似声。又复如彼一异非言所许共相。此但覆俗当情显现无所诤也。此既不许将为实事。斯乃便成于色声等成非异体。又复色等一一便成有多体故。共相之状体无边故。此则合有多种体性。便成诸事皆为一体。如随自缘所带相像。断割前境此之体相。亦是假立众多相貌。为俗言论而分别之。由此便成于色声等。无我之智亦是共相。断割性故。取其无境更成光显唯识之宗。然于色等无我解时。有别相分。复由前后分段本无故。斯乃是为先取别相分明决断。于异决了随而摄取。事境性故。若青莲也简去其白。识缘莲体。决断是青。言无我者。理亦同然凡起决断。谓即于他所执我相仗此思构。方生决断无别我体。纵虽无境而智得生。理既齐衡何有乖诤

若诸有情由自相续者。若言于此自相体中。各有无量功能不同。于自识中变现别故。至成熟时。由自种力识现在前。不由外境而得兴起。非离自识从外境生。然由亲近善恶友故。为益及损。此不得成。由于真妄损益之中但以言声说为境故。既缘声义两种皆无。于斯断割便成非有。由彼有其理非理行。可令善恶逐彼而行。彼行既无可取随学。宁容有故。此则曾不依托外境。而识得生。违所许过。必定依托。外色等境。缘色等心。犹如有事。无事声心复如观他所有行迹。是能于境决断性故。亦复由如色等诸识定缘外境。如圣量言。但是于内似相现故。此固无力。破唯识义。由展转增上识互决定成者。由其展转识相假故。即此二识更互相依。本不待声及于色等。由所立喻不顺于宗。亦复全无违教之失。有他相续为别识故。他识为因自识生故。善恶二友作用理成。外境引梦拨使成无。目击友人。何不同睡而遣为非。有何劳强立展转相。因梦闻善恶。非由别识生。如何现在随他识行。复如何知但由余识分别得生。于他言事随顺情起。此识生时。更有余识功能差别。为因现故。且闻者识。如结契时。唯声现相有差别体。识乃得生。不依外境。方能了事仗自功能。所有差别托己内缘为声相解。即于前境而有了知。此时但是自识熟位功能转起。但有声相共识俱生。详观斯理。又复圣者威神至极。无其文字离取声相。为间隙时成说方便。然则但由胜差别故。能作斯事。遂令余识殊别相生。是共许故。斯即是为唯识功力。然则曾无声之自相能至余识。是他共许。以将为喻。纵许如是。但依他识声觉得生。斯乃便成恒常听响。此之声觉总被生津。虽住远方及耳根坏。并应闻说。无有废时。若其许觉由外声起。有时闻听耳识方行。分别因起。仍须处在相应。耳根复无损坏。方能于境觉察是非。由此全无便成并见。总听之过非独如此。识待有能差别性故。事判于声。犹如于声自性各异。能生此觉。非余相心。亦如于声非闻一切。缘此声相但返缘斯。唯生此觉。于觉有时。但生如此差别之缘。有力用故。为因非余。即如于声在相应处于自相续生其相像。且如此事种子现前。随自用果方能生起如是便成无相似过。复次诸字咸有支分。分析至穷非根取性。犹若极微非同时生。不合聚故。既不和聚有其决断计一常声。处虚空者。不应是理。缘此声心不可得故。又彼许其所有细分。体相似故。及是非根所行性故。然非功能有其差别及以造作容有安置。势力道理。复如外声。随所依缘差别之响。有其自相为缘之因。识亦如是。何有非爱。岂非所云。由展转增上者。即是许其取余识故。此识便成有于外境如不取境。喻分便违。斯难非理。此识由其余识现相为所缘故。喻乃共成。如余宗立。犹如于彼非现在声随以一相而为成立。但有彼相识生而已。其宗许成。我喻亦然何成有过。何故如来之识差别。于余分别之境并除。不异相续而转。无边差别所化有情。在彼多心相若为起。如彼一声体无差异。随自乐相识从生起。但由如来威神之力。极修所致令彼得生于别功能非一之境。不同色类多而无杂。一时兴用分别事成犹如灯宝镜等现相。复以如来诸化用事。难思威力超寻思境。是共学故。强为斯难。非成妙说。若言梦觉两位不差。由并许其无实境性。随其差别咸引于果。梦中所见或善或恶。是总标也。及于觉位心亦无境。此亦便应俱时获果。或应如梦亦皆无果。无境性故。或复翻此斯难不然。由有理故

心由睡眠坏梦觉果不同者。然则梦心由睡坏故。性不分明。即此善恶能招劣果。如于觉时。或缘别事。不为恭敬。或时余思乱心。于彼惠施虽行果不增。大识虽无境果亦同。然随种差别。能招当果爱非爱事。由斯梦觉体有差殊。得果不同。非乖道理。复非由境善等体殊。所作业用招胜劣果。然由自性及相应等自体增故。及以相违。此即梦等有其差别。以此为缘非关有境。或时生已。便于斯境能起害心造于极恶。复于此处能招胜报。种下中上善不善业。以此而言实不藉其外境有故。植果差殊。或时有缘。过去罗汉身福等事。实无其境。犹如梦获果不同。有不定过。后于梦中翘诚庆悦。如来出世虽无实境。大果当招。此喻便成。于宗不顺。有余师云。虽被梦损情断前境而不闇昧如睡初觉。尚有余昏。未足眠时强起情翳。身体沉重见不分明。即此之损于彼梦中相应之识诚固难有。由于梦内心心生法。当尔之时明白观境。忧愁恐怖极思惟心。纵使觉时未能同此。由此要须是有情数。于共见境取相分故。然于梦中七色之业。不立业道由其梦色非见无对。是不共境不堪为世。言论事故。所云色业非业道者。斯乃便成。不察由绪。然此所论。于彼梦识见不分明获果微劣。醒觉之位亦应如此。既有斯过。而便答曰。由梦损故获其少果。如若不损与觉何殊。即如所云。梦识于境了事分明。便招胜果。此若为通由于梦中心明断割。许其招得上妙果报七色业道不建立者。本为评章招果差别。遂论业道。由绪何从。由非招果要须假斯业道方就。于方便位被极重缠害斯意乐。遂令招得最恶之果。轻薄烦恼纵造根本。亦未能同极清净心。于修善位方便根本。类此应知

唯识论者。亦由于他相续兴害。随心所生成其业道。有余师说。由他知故方成罪者。此非正答。何意要须待于共境方建立斯。非由他力始成业道。然藉堪为世言论事。由如苾刍断青流秽。犯斯等罪岂在情边。及由共境假他知故。若于梦中实有青等为所了事。由大师制便成有罪。惑可翻余。非由其事。是有是无。此成应理。若也生界但唯识者。便成无有语身业耶。然由大种及从种生名为身也。语业即是从种生色。此二营为成杀妄等。两种若无事便非有。诸屠猎者。但唯自识转变显现便招杀罪。岂不相违由非前生命根自断。遂令他得杀生罪耶。此违所许身语二业。不尔云何

死由他识别者。屠脍等识犹如屠者。既兴方便彼遂分离。此亦如是。但由自识能有作用。差别现时。便与彼命为杀害因。尔乃但由自识功力妄现身相藉此势故。立为业道。自余业道准此应知。由斯道理。复有共许识之差别。遂与他身作坏因性。即如鬼神及健达缚等。其所嫌处恶念便生。由鬼等识变现为因。遂令前生得失念等。复由圣者专心念时。由他识力为胜缘故。遂于梦中屏除睡昧。便观彼彼差异形仪。识于众像而领纳之。言命根者。谓是随应。顺彼趣业力所招引。异熟识流注时限齐如所摄引事。便转变令彼一业所招连续同分之报。断绝相违。非谓一切流皆断绝。如他所许。于其六处据同分断。说名为绝。识与命离假言其断。但由自他两识为缘。所有作用命根断灭

犹如于隐者获得胜上定。及由作用力差别功能成者令生变异。但是内心差别性故。如是虽无身语二业。杀盗等事理得善成。于彼经中定说隐者。意发嗔火缘斯力故。随便杀彼无量有情。此亦由心令彼断故。必如前理。应可推征。决定须许成就隐者。意乐害力令无量生咸致命断。若异此者。乐欲是其意害大罪。事乃不成。故知引证成意罪大。若也非人知彼意趣。当时为作杀害事者。此亦便成。明显身业罪中最大。有时不假余相续识。便遭石坠烟炭雨等。损害有情。谁增上力令躯命断。固非此识现如是相。还为杀害。便有自缚相违过故。此难非理。即由斯识相续无能与斯命断随顺性故。犹如疑毒令心闷乱。但是随顺自内相续。识无力用更为连住。由此名为寿命断也。然而许有石等相现。亦匪成违。但由增上识故令他命终者。邻次之后。何不寿终。及其死时彼便非有。既不现前。如何成罪。及于断命为因性耶。虽呈雅难应返问之。彼行杀时所招业道。若于当时结业道者。何不于时遂便卒命。若于缘时彼死方结。如何此得杀生过耶。若言相合得杀罪者。此二别时有无体异。如何能作共合事耶。然则此事作论尊者。已详定断于能害者。自相续中有其差别。业性流注。然我于斯有如是见。由能杀者增上识故。断彼相续更互相因。决定由此不假别事。后致终亡。当被伤时。成其杀业。由断他命此有功能。决定由斯取亡没故。然能害者但有此力。于断彼命与作亲因。或时即死。或复后终。由增上识能与他识展转为害。令他后识刹那为障。更不相续。亦非害者。但唯以意便成杀业。由此有其退转之义。于彼行害事乖离故。以理言之。他更不藉余缘致死。由斯必定而取命终。乘此为因命乃断故。由斯即立杀生业道。此成无过。如是贼等随事应知。若异此途彼能害者。于彼后时有何力用。他死之时方招杀罪。更复容成越理之失。不假能害。自身之中。有其差别。而但据彼被害者身有殊异故。后死之时方成罪者。由此加功彼命断故。此即已言。当尔之时。何不死等。合以当时方便杀业。当时即得杀生之罪。死由彼故。然于后时更无异相。是可得故。还将此理用遣余疑。尔者犹如梦中能害所害。身等无故。斯乃便成无业道过。此由梦内识亦不能害他相续。是故于斯不成业道。翻此觉时便成于业。已广成立但唯是心中无间事能成害业

且纵如斯。广陈异见。仍须执理更诘殊端。如唯有识。彼他心智。为知他心。为不了耶。若言不知者何谓了他心。此名由智了他心故。如其不了。便成诳妄。即此能诠于焉有失。如其知者。于离识境而领受故。所成唯识理致便乖。二事相违如何遣难。所以云何。有深义故。他心智云何知境。不如实者。意取极深所证会处。彼曰他心。若有许识便伤他智。如无诚违自教。若他心智缘于外境。如观心外有境为缘。斯难避咎。了境非实。固无[億-音+(夫*夫)]尤。如何知境。不称其实而得名作他心智耶。此中意言。如所证事前境不虚。由此方名是他心智。尔者知于前境既不如实。于此岂得名曰他心。理不如是。未闲本意。虽于他心不缘为境。似彼相状识上现耶。是故离心无境可得生似彼相。然不如境斯成本意。立作他心。此中但是领彼似相。由此名为不如实性。虽不同彼似彼相生。离心无境。已共成故。能知之者。随境相生。如知自心智者。二心同时不共聚故。固非现在。决定应许已灭未生。但可得一而为其境。体复是无。但唯自识还缘过现诸心聚法为彰显相领纳自心。于此事中世咸共许。了他心事理亦应知。尔者若于自心亲能了别。如何复说不如实知。为由于境不实知故。名为不实。为是无事。将以为有。而得名为称实知也。若尔如何得说不如。其境所有领纳皆是其无。由彼不能了实境故。此亦不然。不知如佛境者。此他心智。他缘青等了彼所缘。即是称实。何以便将佛知心体自性清净而云不知凡云了他心。以他心为缘。了自心相。假说知他。即彼他心自性真体是何境界。此亦不然。不尔云何佛知他心。自性即是离心知有。设有离心之色佛了。何伤此即心是实有。两共许成。离心实色与理违背故不同也。若尔佛了他心。应不知境。由境妄故。佛依妄知。亦复何损。如人观幻。岂不知虚。佛同虚知。何过之有。若尔诸佛境界有何相状。诸佛境界非余所知。若佛不知心。何名一切智。即彼无倒所有自性。无知睡尽而得明觉。正晓了时。诸有觉了自他心者。彼之真性不能了故。故言彼智不称境知。复云何通睡尽之智。能正了斯。由此觉知无言境性。超过语路。但自证知。是故不能以言诠及。然于此识所有自性。非是余识之所能知。既非所知。非言能及。彼但总相为其境故。然斯唯有妄构画性。即此构画于自证性。识之实相极辽远故。唯于识处了不实相。此二皆成。不称实境。所以者何。于非实事作实事解。而为决断。由于彼识现虚妄相故

成唯识宝生论卷第五


成唯识论

    No. 1585 [cf. Nos. 1586, 1587]

成唯识论卷第一

        护法等菩萨造

        三藏法师玄奘奉　诏译

稽首唯识性。满分清净者。我今释彼说。利乐诸有情。今造此论为于二空有迷谬者生正解故。生解为断二重障故。由我法执二障具生。若证二空彼障随断。断障为得二胜果故。由断续生烦恼障故证真解脱。由断碍解所知障故得大菩提。又为开示谬执我法迷唯识者。令达二空。于唯识理如实知故。复有迷谬唯识理者。或执外境如识非无。或执内识如境非有。或执诸识用别体同。或执离心无别心所。为遮此等种种异执。令于唯识深妙理中得如实解故作斯论。若唯有识。云何世间及诸圣教。说有我法。颂曰

  １由假说我法　　有种种相转
  彼依识所变　　此能变唯三
  ２谓异熟思量　　及了别境识

论曰。世间圣教说有我法。但由假立非实有性。我谓主宰。法谓轨持。彼二俱有种种相转。我种种相。谓有情命者等。预流一来等。法种种相。谓实德业等。蕴处界等。转谓随缘施设有异。如是诸相若由假说依何得成。彼相皆依识所转变而假施设。识谓了别此中识言亦摄心所。定相应故。变谓识体转似二分。相见俱依自证起故。依斯二分施设我法。彼二离此无所依故。或复内识转似外境。我法分别熏习力故。诸识生时变似我法。此我法相虽在内识而由分别似外境现。诸有情类无始时来。缘此执为实我实法。如患梦者患梦力故心似种种外境相现。缘此执为实有外境。愚夫所计实我实法都无所有。但随妄情而施设故说之为假。内识所变似我似法。虽有而非实我法性。然似彼现故说为假。外境随情而施设故非有如识。内识必依因缘生故非无如境。由此便遮增减二执。境依内识而假立故唯世俗有。识是假境所依事故亦胜义有

云何应知。实无外境唯有内识似外境生。实我实法不可得故。如何实我不可得耶。诸所执我略有三种。一者执我体常周遍。量同虚空。随处造业受苦乐故。二者执我其体虽常而量不定。随身大小有卷舒故。三者执我体常。至细如一极微。潜转身中作事业故。初且非理。所以者何。执我常遍量同虚空。应不随身受苦乐等。又常遍故应无动转。如何随身能造诸业

又所执我一切有情为同为异。若言同者。一作业时一切应作。一受果时一切应受。一得解脱时一切应解脱。便成大过。若言异者。诸有情我更相遍故体应相杂。又一作业一受果时。与一切我处无别故应名一切所作所受。若谓作受各有所属无斯过者。理亦不然业果及身与诸我合。属此非彼不应理故。一解脱时。一切应解脱。所修证法一切我合故。中亦非理。所以者何。我体常住不应随身而有舒卷。既有舒卷如槖籥风。应非常住

又我随身应可分析。如何可执我体一耶。故彼所言如童竖戏。后亦非理。所以者何。我量至小如一极微。如何能令大身遍动。若谓虽小而速巡身如旋火轮似遍动者。则所执我非一非常。诸有往来非常一故。又所执我复有三种。一者即蕴。二者离蕴。三者与蕴非即非离。初即蕴我理且不然。我应如蕴非常一故。又内诸色定非实我。如外诸色有质碍故。心心所法亦非实我。不恒相续待众缘故。余行余色亦非实我。如虚空等非觉性故。中离蕴我理亦不然。应如虚空无作受故。后俱非我理亦不然。许依蕴立非即离蕴应如瓶等非实我故。又既不可说有为无为。亦应不可说是我非我。故彼所执实我不成

又诸所执实有我体。为有思虑为无思虑。若有思虑应是无常。非一切时有思虑故。若无思虑。应如虚空不能作业亦不受果。故所执我理俱不成

又诸所执实有我体。为有作用为无作用。若有作用如手足等应是无常。若无作用如兔角等。应非实我。故所执我二俱不成

又诸所执实有我体。为是我见所缘境不。若非我见所缘境者。汝等云何知实有我。若是我见所缘境者。应有我见非颠倒摄。如实知故。若尔如何执有我者。所信至教皆毁我见称赞无我。言无我见能证涅槃。执着我见沉沦生死。岂有邪见能证涅槃。正见翻令沉沦生死

又诸我见不缘实我。有所缘故。如缘余心。我见所缘定非实我。是所缘故。如所余法。是故我见不缘实我。但缘内识变现诸蕴。随自妄情种种计度。然诸我执略有二种。一者俱生。二者分别。俱生我执。无始时来虚妄熏习内因力故恒与身俱。不待邪教及邪分别任运而转。故名俱生。此复二种。一常相续在第七识。缘第八识起自心相执为实我。二有间断在第六识。缘识所变五取蕴相。或总或别起自心相执为实我。此二我执细故难断。后修道中数数修习胜生空观方能除灭。分别我执亦由现在外缘力故非与身俱。要待邪教及邪分别然后方起故名分别。唯在第六意识中有。此亦二种。一缘邪教所说蕴相起自心相分别计度执为实我。二缘邪教所说我相。起自心相分别计度执为实我。此二我执粗故易断。初见道时观一切法生空真如即能除灭。如是所说一切我执自心外蕴或有或无。自心内蕴一切皆有。是故我执皆缘无常五取蕴相。妄执为我。然诸蕴相从缘生故是如幻有。妄所执我横计度故决定非有故契经说。苾刍当知。世间沙门婆罗门等所有我见一切皆缘五取蕴起。实我若无云何得有忆识诵习恩怨等事。所执实我既常无变。后应如前是事非有。前应如后是事非无。以后与前体无别故。若谓我用前后变易非我体者。理亦不然。用不离体应常有故。体不离用应非常故。然诸有情各有本识。一类相续任持种子。与一切法更互为因熏习力故。得有如是忆识等事。故所设难于汝有失非于我宗。若无实我谁能造业谁受果耶。所执实我既无变易。犹如虚空。如何可能造业受果。若有变易应是无常。然诸有情心心所法因缘力故。相续无断。造业受果。于理无违

我若实无。谁于生死轮回诸趣。谁复厌苦求趣涅槃。所执实我既无生灭。如何可说生死轮回。常如虚空。非苦所恼何为厌舍求趣涅槃。故彼所言常为自害。然有情类身心相续烦恼业力轮回诸趣。厌患苦故求趣涅槃。由此故知。定无实我但有诸识。无始时来前灭后生。因果相续。由妄熏习似我相现。愚者于中妄执为我

如何识外实有诸法不可得耶。外道余乘所执外法理非有故。外道所执云何非有。且数论者执。我是思。受用萨埵刺阇答摩所成大等二十三法。然大等法三事合成。是实非假。现量所得。彼执非理所以者何。大等诸法多事成故。如军林等。应假非实。如何可说现量得耶

又大等法若是实有。应如本事非三合成。萨埵等三即大等故。应如大等。亦三合成。转变非常为例亦尔。又三本事各多功能。体亦应多。能体一故。三体既遍。一处变时余亦应尔。体无别故。许此三事。体相各别。如何和合共成一相。不应合时变为一相。与未合时体无别故。若谓三事体异相同。便违己宗体相是一。体应如相冥然是一。相应如体显然有三。故不应言三合成一。又三是别。大等是总。总别一故应非一三。此三变时若不和合成一相者。应如未变。如何现见是一色等。若三和合成一相者。应失本别相体亦应随失。不可说三各有二相。一总二别。总即别故。总亦应三。如何见一。若谓三体各有三相。和杂难知。故见一者。既有三相。宁见为一。复如何知三事有异。若彼一一皆具三相。应一一事能成色等。何所阙少待三和合。体亦应各三。以体即相故。又大等法皆三合成。展转相望应无差别。是则因果唯量诸大诸根差别皆不得成。若尔一根应得一切境。或应一境一切根所得。世间现见情与非情净秽等物现比量等。皆应无异。便为大失。故彼所执实法不成。但是妄情计度为有。胜论所执实等句义多实有性。现量所得。彼执非理。所以者何。诸句义中。且常住者。若能生果。应是无常。有作用故如所生果。若不生果应非离识实有自性。如兔角等。诸无常者。若有质碍。便有方分。应可分析。如军林等。非实有性。若无质碍如心心所。应非离此有实自性

又彼所执地水火风。应非有碍实句义摄。身根所触故。如坚湿暖动。即彼所执坚湿暖等。应非无碍德句义摄。身根所触故。如地水火风。地水火三对青色等。俱眼所见。准此应责。故知无实地水火风。与坚湿等各别有性。亦非眼见实地水火

又彼所执实句义中。有碍常者。皆有碍故。如粗地等。应是无常。诸句义中色根所取无质碍法。应皆有碍。许色根取故。如地水火风

又彼所执非实德等。应非离识有别自性。非实摄故。如石女儿。非有实等应非离识有别自性。非有摄故。如空花等。彼所执有。应离实等无别自性。许非无故。如实德等。若离实等应非有性。许异实等故。如毕竟无等。如有非无无别有性。如何实等有别有性。若离有法有别有性。应离无法有别无性。彼既不然此云何尔。故彼有性唯妄计度。又彼所执实德业性。异实德业。理定不然。勿。此亦非实德业性。异实等故。如德业等

又应实等非实等摄。异实等性故。如德业实等。地等诸性对地等体更相征诘。准此应知。如实性等无别实等性。实等亦应无别实性等。若离实等有实等性。应离非实等有非实等性。彼既不尔此云何然。故同异性唯假施设。又彼所执和合句义定非实有。非有实等诸法摄故。如毕竟无。彼许实等现量所得以理推征尚非实有况彼自许和合句义非现量得。而可实有。设执和合是现量境。由前理故亦非实有。然彼实等。非缘离识实有自体现量所得。许所知故。如龟毛等。又缘实智非缘离识实句自体现量智摄。假合生故。如德智等。广说乃至缘和合智。非缘离识和合自体现量智摄。假合生故。如实智等。故胜论者实等句义。亦是随情妄所施设。有执有一大自在天。体实遍常能生诸法。彼执非理。所以者何。若法能生必非常故。诸非常者必不遍故。诸不遍者非真实故。体既常遍。具诸功能应一切处时顿生一切法。待欲或缘方能生者。违一因论。或欲及缘亦应顿起。因常有故。余执有一大梵．时．方．本际．自然．虚空．我等。常住实有。具诸功能生一切法。皆同此破。有余偏执。明论声常。能为定量表诠诸法。有执一切声皆是常。待缘显发。方有诠表。彼俱非理。所以者何。且明论声许能诠故。应非常住如所余声。余声亦应非常声体。如瓶衣等待众缘故。有外道执。地水火风极微。实常。能生粗色。所生粗色不越因量。虽是无常而体实有。彼亦非理。所以者何。所执极微若有方分。如蚁行等。体应非实。若无方分。如心心所。应不共聚生粗果色。既能生果。如彼所生。如何可说极微常住

又所生果。不越因量。应如极微不名粗色。则此果色。应非眼等色根所取。便违自执。若谓果色量德合故。非粗似粗色根能取。所执果色既同因量。应如极微无粗德合。或应极微亦粗德合。如粗果色。处无别故。若谓果色遍在自因。因非一故可名粗者。则此果色体应非一。如所在因。处各别故。既尔此果还不成粗。由此亦非色根所取。若果多分合故成粗。多因极微合应非细。足成根境何用果为。既多分成。应非实有。则汝所执前后相违

又果与因俱有质碍。应不同处。如二极微。若谓果因体相受入。如沙受水药入镕铜。谁许沙铜体受水药。或应离变非一非常。又粗色果体若是一。得一分时应得一切。彼此一故。彼应如此

不许违理。许便违事。故彼所执进退不成。但是随情虚妄计度。然诸外道品类虽多。所执有法不过四种。一执有法与有等性其体定一。如数论等。彼执非理。所以者何。勿一切法即有性故。皆如有性。体无差别便违三德我等体异。亦违世间诸法差别。又若色等即色等性。色等应无青黄等异。二执有法与有等性。其体定异。如胜论等。彼执非理。所以者何。勿一切法非有性故。如已灭无。体不可得。便违实等自体非无。亦违世间现见有物。又若色等非色等性。应如声等。非眼等境。三执有法与有等性。亦一亦异。如无惭等。彼执非理。所以者何。一异同前一异过故。二相相违。体应别故。一异体同俱不成故。勿一切法皆同一体。或应一异是假非实。而执为实理定不成。四执有法与有等性。非一非异。如邪命等。彼执非理。所以者何。非一异执同异一故。非一异言为遮为表

若唯是表应不双非。若但是遮应无所执。亦遮亦表应互相违。非表非遮。应成戏论。又非一异。违世共知有一异物。亦违自宗色等有法决定实有。是故彼言唯矫避过。诸有智者勿谬许之

余乘所执离识实有色等诸法。如何非有彼所执色不相应行。及诸无为。理非有故。且所执色总有二种。一者有对极微所成。二者无对非极微成。彼有对色定非实有。能成极微非实有故。谓诸极微若有质碍。应如瓶等。是假非实。若无质碍。应如非色。如何可集成瓶衣等。又诸极微。若有方分。必可分析。便非实有。若无方分。则如非色。云何和合承光发影。日轮才举照柱等时。东西两边光影各现。承光发影。处既不同。所执极微定有方分。又若见触壁等物时。唯得此边不得彼分。既和合物即诸极微。故此极微必有方分

又诸极微随所住处必有上下四方差别。不尔便无共和集义。或相涉入。应不成粗。由此极微定有方分。执有对色即诸极微。若无方分。应无障隔。若尔便非障碍有对。是故汝等所执极微。必有方分。有方分故。便可分析。定非实有。故有对色实有不成。五识岂无所依缘色

虽非无色而是识变。谓识生时。内因缘力变似眼等色等相现。即以此相为所依缘。然眼等根非现量得。以能发识比知是有。此但功能非外所造。外有对色理既不成。故应但是内识变现。发眼等识名眼等根。此为所依生眼等识。此眼等识外所缘缘。理非有故。决定应许自识所变为所缘缘。谓能引生似自识者。汝执彼是此所缘缘。非但能生。勿因缘等亦名此识所缘缘故。眼等五识了色等时。但缘和合似彼相故。非和合相异诸极微有实自体。分析彼时。似彼相识定不生故

彼和合相既非实有。故不可说是五识缘。勿第二月等能生五识故。非诸极微共和合位可与五识各作所缘。此识上无极微相故。非诸极微有和合相不和合时无此相故。非和合位与不合时。此诸极微体相有异。故和合位如不合时色等极微。非五识境。有执色等一一极微。不和集时非五识境。共和集位展转相资有粗相生。为此识境。彼相实有。为此所缘

彼执不然共和集位与未集时体相一故。瓶瓯等物极微等者缘彼相识应无别故。共和集位一一极微。各各应舍微圆相故。非粗相识缘细相境。勿余境识缘余境故。一识应缘一切境故。许有极微尚致此失。况无识外真实极微。由此定知。自识所变似色等相为所缘缘

见托彼生带彼相故。然识变时随量大小。顿现一相非别变作众多极微合成一物。为执粗色有实体者。佛说极微令其除析。非谓诸色实有极微。诸瑜伽师以假想慧于粗色相。渐次除析至不可析假说极微。虽此极微犹有方分而不可析。若更析之便似空现。不名为色。故说极微是色边际。由此应知。诸有对色皆识变现非极微成。余无对色。是此类故。亦非实有。或无对故。如心心所。定非实色。诸有对色现有色相。以理推究离识尚无。况无对色现无色相而可说为真实色法。表无表色岂非实有。此非实有。所以者何。且身表色若是实有。以何为性。若言是形便非实有。可分析故。长等极微不可得故。若言是动。亦非实有。才生即灭无动义故。有为法灭不待因故。灭若待因应非灭故。若言有色非显非形。心所引生能动手等名身表业理亦不然。此若是动义如前破。若是动因应即风界。风无表示不应名表

又触不应通善恶性。非显香味类触应知。故身表业定非实有。然心为因。令识所变手等色相生灭相续转趣余方。似有动作表示心故。假名身表。语表亦非实有声性。一刹那声无诠表故。多念相续便非实故外有对色前已破故。然因心故。识变似声生灭相续似有表示。假名语表。于理无违。表既实无。无表宁实。然依思愿善恶分限。假立无表理亦无违。谓此或依发胜身语善恶思种增长位立。或依定中止身语恶现行思立。故是假有。世尊经中说有三业。拨身语业岂不违经。不拨为无但言非色。能动身思说名身业。能发语思说名语业。审决二思意相应故。作动意故说名意业。起身语思有所造作。说名为业。是审决思所游履故通生苦乐异熟果故。亦名为道。故前七业道亦思为自性。或身语表由思发故假说为业。思所履故说名业道。由此应知。实无外色唯有内识变似色生不相应行亦非实有。所以者何。得非得等。非如色心及诸心所。体相可得。非异色心及诸心所作用可得。由此故知。定非实有。但依色等分位假立。此定非异色心心所有实体用。如色心等。许蕴摄故。或心心所及色无为所不摄故。如毕竟无定非实有。或余实法所不摄故。如余假法。非实有体。且彼如何。知得非得异色心等有实体用。契经说故。如说如是补特伽罗成就善恶。圣者成就十无学法。又说异生不成就圣法。诸阿罗汉不成就烦恼。成不成言显得非得。经不说此异色心等有实体用。为证不成。亦说轮王成就七宝。岂即成就他身非情。若谓于宝有自在力。假说成就。于善恶法何不许然。而执实得。若谓七宝在现在故。可假说成。宁知所成善恶等法。离现在有。离现实法理非有故。现在必有善种等故。又得于法有何胜用。若言能起应起无为。一切非情应永不起。未得已失应永不生。若俱生得为因起者。所执二生便为无用。又具善恶无记得者。善恶无记应顿现前。若待余因得便无用。若得于法是不失因。有情由此成就彼故。诸可成法不离有情若离有情实不可得。故得于法俱为无用得实无故。非得亦无。然依有情可成诸法分位假立三种成就。一种子成就。二自在成就。三现行成就。翻此假立不成就名。此类虽多。而于三界见所断种未永害位。假立非得名异生性。于诸圣法未成就故。复如何知异色心等有实同分。契经说故。如契经说此天同分此人同分。乃至广说。此经不说异色心等有实同分。为证不成。若同智言因斯起故。知实有者。则草木等应有同分。又于同分起同智言。同分复应有别同分。彼既不尔。此云何然。若谓为因起同事欲知实有者。理亦不然。宿习为因起同事欲。何要别执有实同分。然依有情身心相似分位差别假立同分。复如何知。异色心等有实命根。契经说故。如契经说。寿暖识三。应知命根说名为寿。此经不说异色心等有实寿体。为证不成

又先已成色不离识。应此离识无别命根。又若命根异识实有。应如受等。非实命根。若尔如何经说三法。义别说三。如四正断。住无心位寿暖应无。岂不经说。识不离身。既尔如何名无心位。彼灭转识。非阿赖耶。有此识因后当广说。此识足为界趣生体。是遍。恒续。异熟果故。无劳别执有实命根。然依亲生此识种子。由业所引功能差别住时决定假立命根。复如何知。二无心定无想异熟。异色心等有实自性。若无实性应不能遮心心所法令不现起。若无心位有别实法异色心等能遮于心名无心定。应无色时有别实法异色心等。能碍于色名无色定。彼既不尔。此云何然。又遮碍心何须实法。如堤塘等假亦能遮谓修定时于定加行厌患粗动心心所故。发胜期愿遮心心所。令心心所渐细渐微。微微心时熏异熟识成极增上厌心等种。由此损伏心等种故。粗动心等暂不现行。依此分位假立二定。此种善故定亦名善。无想定前求无想果。故所熏成种。招彼异熟识。依定粗动想等不行。于此分位假立无想。依异熟立得异熟名。故此三法亦非实有

成唯识论卷第一成唯识论卷第二

        护法等菩萨造

        三藏法师玄奘奉　诏译

复如何知。诸有为相。异色心等有实自性。契经说故。如契经说。有三有为之有为相。乃至广说。此经不说异色心等有实自性。为证不成。非第六声便表异体。色心之体即色心故。非能相体定异所相。勿坚相等异地等故。若有为相异所相体。无为相体应异所相。又生等相若体俱有。应一切时齐兴作用。若相违故用不顿兴。体亦相违如何俱有。又住异灭用不应俱。能相所相体俱本有。用亦应然。无别性故。若谓彼用更待因缘。所待因缘应非本有。又执生等便为无用。所相恒有而生等合。应无为法亦有生等。彼此异因不可得故。又去来世非现非常。应似空花非实有性。生名为有。宁在未来。灭名为无应非现在。灭若非无生应非有。又灭违住宁执同时。住不违生何容异世。故彼所执进退非理。然有为法因缘力故。本无今有。暂有还无。表异无为假立四相。本无今有有位名生。生位暂停即说为住。住别前后复立异名。暂有还无无时名灭。前三有故同在现在。后一是无故在过去。如何无法与有为相。表此后无为相何失。生表有法先非有。灭表有法后是无。异表此法非凝然。住表此法暂有用。故此四相于有为法虽俱名表而表有异。此依刹那假立四相。一期分位亦得假立。初有名生。后无名灭。生已相似相续名住。即此相续转变名异。是故四相皆是假立。复如何知。异色心等有实诠表名句文身。契经说故。如契经说。佛得希有名句文身。此经不说异色心等有实名等。为证不成。若名句文异声实有。应如色等非实能诠。谓声能生名句文者。此声必有音韵屈曲。此足能诠何用名等。若谓声上音韵屈曲即名句文。异声实有。所见色上形量屈曲。应异色处别有实体。若谓声上音韵屈曲如弦管声非能诠者。此应如彼声。不别生名等。又谁说彼定不能诠。声若能诠。风铃声等应有诠用。此应如彼不别生实名句文身。若唯语声能生名等。如何不许唯语能诠。何理定知能诠即语。宁知异语别有能诠。语不异能诠人天共了执能诠异语。天爱非余。然依语声分位差别而假建立名句文身。名诠自性句诠差别。文即是字为二所依。此三离声虽无别体。而假实异亦不即声。由此法词二无碍解境有差别。声与名等蕴处界摄亦各有异。且依此土说名句文依声假立。非谓一切。诸余佛土亦依光明妙香味等假立三故。有执随眠异心心所。是不相应行蕴所摄。彼亦非理。名贪等故。如现贪等。非不相应。执别有余不相应行。准前理趣皆应遮止

诸无为法离色心等。决定实有理不可得。且定有法略有三种。一现所知法。如色心等。二现受用法。如瓶衣等。如是二法世共知有。不待因成。三有作用法。如眼耳等。由彼彼用证知是有。无为非世共知定有。又无作用如眼耳等。设许有用应是无常。故不可执无为定有。然诸无为所知性故。或色心等所显性故。如色心等。不应执为离色心等实无为性。又虚空等为一为多。若体是一遍一切处。虚空容受色等法故。随能合法体应成多。一所合处余不合故。不尔诸法应互相遍。若谓虚空不与法合。应非容受。如余无为。又色等中有虚空不。有应相杂。无应不遍。一部一品结法断时应得余部余品择灭。一法缘阙得不生时。应于一切得非择灭。执彼体一理应尔故。若体是多便有品类。应如色等。非实无为。虚空又应非遍容受。余部所执离心心所实有无为。准前应破。又诸无为。许无因果故。应如兔角。非异心等有。然契经说有虚空等诸无为法。略有二种。一依识变假施设有。谓曾闻说虚空等名。随分别有虚空等相。数习力故心等生时。似虚空等无为相现。此所现相前后相似无有变易假说为常。二依法性假施设有。谓空无我所显真如。有无俱非。心言路绝。与一切法非一异等。是法真理故名法性。离诸障碍故名虚空。由简择力灭诸杂染。究竟证会故名择灭。不由择力本性清净。或缘阙所显故名非择灭。苦乐受灭故名不动。想受不行名想受灭。此五皆依真如假立。真如亦是假施设名。遮拨为无故说为有。遮执为有故说为空。勿谓虚幻故说为实。理非妄倒故名真如。不同余宗离色心等有实常法名曰真如。故诸无为非定实有

外道余乘所执诸法。异心心所非实有性。是所取故。如心心所。能取彼觉亦不缘彼。是能取故。如缘此觉。诸心心所依他起故。亦如幻事。非真实有。为遣妄执心心所外实有境故。说唯有识。若执唯识真实有者。如执外境亦是法执。然诸法执略有二种。一者俱生。二者分别。俱生法执无始时来。虚妄熏习内因力故。恒与身俱。不待邪教及邪分别。任运而转。故名俱生。此复二种。一常相续。在第七识缘第八识起自心相执为实法。二有间断。在第六识缘识所变蕴处界相。或总或别起自心相执为实法。此二法执细故难断。后十地中数数修习胜法空观方能除灭。分别法执亦由现在外缘力故非与身俱。要待邪教及邪分别。然后方起。故名分别。唯在第六意识中有。此亦二种。一缘邪教所说蕴处界相。起自心相分别计度执为实法。二缘邪教所说自性等相。起自心相。分别计度执为实法。此二法执粗故易断。入初地时观一切法法空真如。即能除灭。如是所说一切法执自心外法或有或无。自心内法一切皆有。是故法执皆缘自心所现似法。执为实有。然似法相从缘生故。是如幻有。所执实法妄计度故。决定非有。故世尊说。慈氏当知。诸识所缘唯识所现。依他起性如幻事等。如是外道余乘所执。离识我法皆非实有。故心心所。决定不用外色等法。为所缘缘。缘用必依实有体故。现在彼聚心心所法。非此聚识亲所缘缘。如非所缘。他聚摄故。同聚心所亦非亲所缘。自体异故。如余非所取。由此应知。实无外境唯有内识似外境生。是故契经伽他中说

如愚所分别外境实皆无。习气扰浊心。故似彼而转。有作是难。若无离识实我法者。假亦应无。谓假必依真事似事共法而立。如有真火有似火人有猛赤法乃可假说此人为火。假说牛等应知亦然。我法若无依何假说。无假说故。似亦不成。如何说心似外境转。彼难非理。离识我法前已破故。依类依实假说火等。俱不成故。依类假说理且不成。猛赤等德非类有故。若无共德而假说彼应亦于水等假说火等名。若谓猛等虽非类德而不相离故可假说。此亦不然。人类猛等现见亦有互相离故。类既无德又互相离。然有于人假说火等。故知假说不依类成。依实假说理亦不成。猛赤等德非共有故。谓猛赤等在火在人。其体各别。所依异故。无共假说有过同前。若谓人火德相似故可假说者。理亦不然。说火在人非在德故。由此假说不依实成。又假必依真事立者。亦不应理。真谓自相。假智及诠俱非境故。谓假智诠不得自相。唯于诸法共相而转。亦非离此有别方便施设自相为假所依。然假智诠必依声起。声不及处此便不转。能诠所诠俱非自相。故知假说不依真事。由此但依似事而转。似谓增益非实有相。声依增益似相而转。故不可说假必依真。是故彼难不应正理。然依识变对遣妄执真实我法说假似言。由此契经伽他中说

  为对遣愚夫　　所执实我法
  故于识所变　　假说我法名

识所变相虽无量种。而能变识类别唯三。一谓异熟。即第八识多异熟性故。二谓思量。即第七识恒审思量故。三谓了境。即前六识了境相粗故。及言显六合为一种。此三皆名能变识者。能变有二种。一因能变。谓第八识中等流异熟。二因习气。等流习气由七识中善恶无记熏令生长。异熟习气由六识中有漏善恶熏令生长。二果能变。谓前二种习气力故。有八识生现种种相。等流习气为因缘故。八识体相差别而生。名等流果果似因故。异熟习气为增上缘感第八识。酬引业力恒相续故立异熟名。感前六识酬满业者从异熟起名异熟生。不名异熟有间断故。即前异熟及异熟生名异熟果果异因故。此中且说我爱执藏持杂染种能变果识名为异熟。非谓一切。虽已略说能变三名。而未广辩能变三相。且初能变其相云何。颂曰

  初阿赖耶识　　异熟一切种
  ３不可知执受　　处了常与触
  作意受想思　　相应唯舍受
  ４是无覆无记　　触等亦如是
  恒转如瀑流　　阿罗汉位舍

论曰。初能变识大小乘教名阿赖耶。此识具有能藏所藏执藏义故。谓与杂染互为缘故。有情执为自内我故。此即显示初能变识所有自相。摄持因果为自相故。此识自相分位虽多。藏识过重是故偏说。此是能引诸界趣生善不善业。异熟果故说名异熟。离此命根众同分等恒时相续胜异熟果不可得故。此即显示初能变识所有果相。此识果相虽多位多种。异熟宽不共故偏说之。此能执持诸法种子令不失故名一切种。离此余法能遍执持诸法种子不可得故。此即显示初能变识所有因相。此识因相虽有多种持种不共是故偏说。初能变识体相虽多略说唯有如是三相

一切种相应更分别。此中何法名为种子。谓本识中亲生自果功能差别。此与本识及所生果不一不异。体用因果理应尔故。虽非一异而是实有。假法如无非因缘故。此与诸法既非一异。应如瓶等是假非实。若尔真如应是假有。许则便无真胜义谛。然诸种子唯依世俗说为实有不同真如。种子虽依第八识体。而是此识相分非余。见分恒取此为境故。诸有漏种与异熟识。体无别故无记性摄。因果俱有善等性故亦名善等。诸无漏种非异熟识性所摄故。因果俱是善性摄故。唯名为善。若尔何故决择分说二十二根。一切皆有异熟种子。皆异熟生。虽名异熟而非无记。依异熟故名异熟种。异性相依如眼等识。或无漏种由熏习力转变成熟立异熟名。非无记性所摄异熟。此中有义一切种子皆本性有不从熏生。由熏习力但可增长。如契经说一切有情无始时来有种种界。如恶叉聚法尔而有。界即种子差别名故。又契经说无始时来界。一切法等依。界是因义。瑜伽亦说诸种子体无始时来性虽本有。而由染净新所熏发。诸有情类无始时来若般涅槃法者一切种子皆悉具足。不般涅槃法者便阙三种菩提种子。如是等文诚证非一。又诸有情既说本有五种性别故。应定有法尔种子不由熏生。又瑜伽说地狱成就三无漏根是种非现。又从无始展转传来法尔所得本性住性。由此等证无漏种子法尔本有不从熏生。有漏亦应法尔有种。由熏增长不别熏生。如是建立因果不乱。有义种子皆熏故生。所熏能熏俱无始有。故诸种子无始成就。种子既是习气异名。习气必由熏习而有。如麻香气花熏故生。如契经说诸有情心染净诸法所熏习故。无量种子之所积集。论说内种定有熏习。外种熏习或有或无。又名言等三种熏习总摄一切有漏法种。彼三既由熏习而有。故有漏种必藉熏生。无漏种生亦由熏习。说闻熏习闻净法界等流正法而熏起故。是出世心种子性故。有情本来种姓差别。不由无漏种子有无。但依有障无障建立。如瑜伽说于真如境若有毕竟二障种者立为不般涅槃法性。若有毕竟所知障种非烦恼者一分立为声闻种性一分立为独觉种性。若无毕竟二障种者即立彼为如来种性。故知本来种性差别依障建立非无漏种。所说成就无漏种言。依当可生非已有体。有义种子各有二类。一者本有。谓无始来异熟识中法尔而有生蕴处界功能差别

世尊依此说诸有情无始时来有种种界如恶叉聚法尔而有。余所引证广说如初。此即名为本性住种。二者始起。谓无始来数数现行熏习而有。世尊依此说有情心染净诸法所熏习故无量种子之所积集。诸论亦说染净种子由染净法熏习故生。此即名为习所成种。若唯本有转识不应与阿赖耶为因缘性。如契经说

  诸法于识藏　　识于法亦尔
  更互为果性　　亦常为因性

此颂意言。阿赖耶识与诸转识。于一切时展转相生互为因果。摄大乘说。阿赖耶识与杂染法互为因缘。如炷与焰展转生烧。又如束芦互相依住。唯依此二建立因缘。所余因缘不可得故。若诸种子不由熏生。如何转识与阿赖耶有因缘义非熏令长可名因缘。勿善恶业与异熟果为因缘故。又诸圣教说有种子由熏习生。皆违彼义。故唯本有理教相违。若唯始起有为无漏无因缘故应不得生。有漏不应为无漏种。勿无漏种生有漏故。许应诸佛有漏复生。善等应为不善等种。分别论者虽作是说心性本净客尘烦恼所染污故名为杂染离烦恼时转成无漏故无漏法非无因生。而心性言彼说何义。若说空理空非心因常法定非诸法种子。以体前后无转变故。若即说心应同数论相虽转变而体常一。恶无记心又应是善。许则应与信等相应。不许便应非善心体。尚不名善况是无漏。有漏善心既称杂染如恶心等性非无漏。故不应与无漏为因。勿善恶等互为因故。若有漏心性是无漏应无漏心性是有漏。差别因缘不可得故。又异生心若是无漏。则异生位无漏现行。应名圣者。若异生心性虽无漏而相有染不名无漏。无斯过者则心种子亦非无漏。何故汝论说有异生唯得成就无漏种子。种子现行性相同故。然契经说心性净者说心空理所显真如。真如是心真实性故。或说心体非烦恼故名性本净。非有漏心性是无漏故名本净。由此应信。有诸有情无始时来有无漏种不由熏习法尔成就。后胜进位熏令增长。无漏法起以此为因。无漏起时复熏成种。有漏法种类此应知。诸圣教中虽说内种定有熏习。而不定说一切种子皆熏故生。宁全拨无本有种子。然本有种亦由熏习令其增盛方能得果故说内种定有熏习。其闻熏习非唯有漏。闻正法时亦熏本有无漏种子令渐增盛展转乃至生出世心故亦说此名闻熏习。闻熏习中有漏性者是修所断。感胜异熟。为出世法胜增上缘。无漏性者非所断摄与出世法正为因缘。此正因缘微隐难了。有寄粗显胜增上缘方便说为出世心种。依障建立种姓别者意显无漏种子有无。谓若全无无漏种者彼二障种永不可害即立彼为非涅槃法。若唯有二乘无漏种者彼所知障种永不可害。一分立为声闻种姓一分立为独觉种姓。若亦有佛无漏种者彼二障种俱可永害。即立彼为如来种姓。故由无漏种子有无障有可断不可断义。然无漏种微隐难知故约彼障显性差别。不尔彼障有何别因而有可害不可害者。若谓法尔有此障别无漏法种宁不许然。若本全无无漏法种则诸圣道永不得生。谁当能害二障种子而说依障立种姓别。既彼圣道必无生义说当可生亦定非理。然诸圣教处处说有本有种子皆违彼义。故唯始起理教相违。由此应知。诸法种子各有本有始起二类。然种子义略有六种。一刹那灭。谓体才生无间必灭有胜功力方成种子。此遮常法常无转变不可说有能生用故。二果俱有。谓与所生现行果法俱现和合方成种子。此遮前后及定相离现种异类互不相违。一身俱时有能生用。非如种子自类相生前后相违必不俱有。虽因与果有俱不俱。而现在时可有因用。未生已灭无自体故。依生现果立种子名不依引生自类名种。故但应说与果俱有。三恒随转。谓要长时一类相续至究竟位方成种子。此遮转识。转易间断与种子法不相应故。此显种子自类相生。四性决定。谓随因力生善恶等功能决定方成种子。此遮余部执异性因生异性果有因缘义。五待众缘。谓此要待自众缘合功能殊胜方成种子。此遮外道执自然因不待众缘恒顿生果。或遮余部缘恒非无。显所待缘非恒有性。故种于果非恒顿生。六引自果。谓于别别色心等果各各引生方成种子。此遮外道执唯一因生一切果。或遮余部执色心等互为因缘。唯本识中功能差别具斯六义成种非余。外谷麦等识所变故。假立种名非实种子。此种势力生近正果名曰生因引远残果令不顿绝即名引因内种必由熏习生长亲能生果是因缘性。外种熏习或有或无。为增上缘办所生果。必以内种为彼因缘。是共相种所生果故。依何等义立熏习名。所熏能熏各具四义令种生长。故名熏习。何等名为所熏四义。一坚住性。若法始终一类相续能持习气。乃是所熏。此遮转识及声风等性不坚住故非所熏。二无记性。若法平等无所违逆。能容习气乃是所熏。此遮善染势力强盛无所容纳故非所熏。由此如来第八净识。唯带旧种非新受熏。三可熏性。若法自在性非坚密能受习气乃是所熏。此遮心所及无为法依他坚密故非所熏。四与能熏共和合性。若与能熏同时同处不即不离。乃是所熏。此遮他身刹那前后无和合义故非所熏。唯异熟识具此四义可是所熏。非心所等。何等名为能熏四义。一有生灭。若法非常能有作用生长习气。乃是能熏。此遮无为前后不变无生长用故非能熏。二有胜用。若有生灭势力增盛能引习气。乃是能熏。此遮异熟心心所等势力羸劣故非能熏。三有增减。若有胜用可增可减摄植习气。乃是能熏。此遮佛果圆满善法无增无减故非能熏。彼若能熏便非圆满。前后佛果应有胜劣。四与所熏和合而转。若与所熏同时同处不即不离。乃是能熏。此遮他身刹那前后无和合义故非能熏。唯七转识及彼心所有胜势用。而增减者具此四义可是能熏。如是能熏与所熏识俱生俱灭熏习义成。令所熏中种子生长如熏苣蕂故名熏习。能熏识等从种生时。即能为因复熏成种。三法展转因果同时。如炷生焰焰生焦炷。亦如芦束更互相依。因果俱时理不倾动。能熏生种种起现行如俱有因得士用果。种子前后自类相生如同类因引等流果。此二于果是因缘性。除此余法皆非因缘。设名因缘应知假说是谓略说一切种相。此识行相所缘云何。谓不可知执受处了。了谓了别。即是行相。识以了别为行相故处谓处所。即器世间。是诸有情所依处故。执受有二。谓诸种子及有根身。诸种子者谓诸相名分别习气。有根身者谓诸色根及根依处。此二皆是识所执受。摄为自体同安危故。执受及处俱是所缘。阿赖耶识因缘力故自体生时。内变为种及有根身。外变为器。即以所变为自所缘。行相仗之而得起故。此中了者谓异熟识于自所缘有了别用。此了别用见分所摄。然有漏识自体生时。皆似所缘能缘相现。彼相应法应知亦尔。似所缘相说名相分。似能缘相说名见分。若心心所无所缘相。应不能缘自所缘境。或应一一能缘一切。自境如余余如自故。若心心所无能缘相应不能缘。如虚空等。或虚空等亦是能缘。故心心所必有二相。如契经说

  一切唯有觉　　所觉义皆无
  能觉所觉分　　各自然而转

执有离识所缘境者。彼说外境是所缘。相分名行相。见分名事。是心心所自体相故。心与心所同所依缘行相相似。事虽数等而相各异。识受想等相各别故。达无离识所缘境者。则说相分是所缘。见分名行相。相见所依自体名事。即自证分。此若无者应不自忆心心所法。如不曾更境必不能忆故。心与心所同所依根。所缘相似。行相各别。了别领纳等作用各异故。事虽数等而相各异。识受等体有差别故。然心心所一一生时。以理推征各有三分。所量能量量果别故。相见必有所依体故。如集量论伽他中说

  似境相所量　　能取相自证
  即能量及果　　此三体无别

又心心所若细分别应有四分。三分如前。复有第四证自证分。此若无者谁证第三。心分既同应皆证故。又自证分应无有果。诸能量者必有果故。不应见分是第三果。见分或时非量摄故。由此见分不证第三。证自体者必现量故。此四分中前二是外后二是内。初唯所缘后三通二。谓第二分但缘第一。或量非量或现或比。第三能缘第二第四。证自证分唯缘第三。非第二者以无用故第三第四皆现量摄。故心心所四分合成。具所能缘无无穷过。非即非离唯识理成。是故契经伽他中说

  众生心二性　　内外一切分
  所取能取缠　　见种种差别

此颂意说。众生心性二分合成。若内若外皆有所取能取缠缚。见有种种或量非量或现或比多分差别。此中见者是见分故。如是四分或摄为三。第四摄入自证分故。或摄为二。后三俱是能缘性故皆见分摄。此言见者是能缘义。或摄为一体无别故如入楞伽伽他中说

  由自心执着　　心似外境转
  彼所见非有　　是故说唯心

如是处处说唯一心。此一心言亦摄心所。故识行相即是了别。了别即是识之见分。所言处者。谓异熟识由共相种成熟力故变似色等器世间相。即外大种及所造色。虽诸有情所变各别。而相相似处所无异。如众灯明各遍似一。谁异熟识变为此相。有义一切。所以者何。如契经说。一切有情业增上力共所起故。有义若尔诸佛菩萨应实变为此杂秽土。诸异生等应实变为他方此界诸净妙土。又诸圣者厌离有色生无色界必不下生变为此土复何所用。是故现居及当生者。彼异熟识变为此界。经依少分说一切言。诸业同者皆共变故。有义若尔器将坏时既无现居及当生者。谁异熟识变为此界

又诸异生厌离有色生无色界现无色身。预变为土。此复何用。设有色身与异地器粗细悬隔不相依持。此变为彼亦何所益。然所变土本为色身依持受用故若于身可有持用便变为彼。由是设生他方自地。彼识亦得变为此土。故器世界将坏。初成。虽无有情而亦现有。此说一切共受用者。若别受用准此应知。鬼人天等所见异故诸种子者谓异熟识所持一切有漏法种。此识性摄故是所缘

无漏法种虽依附此识。而非此性摄故非所缘。虽非所缘而不相离。如真如性不违唯识。有根身者。谓异熟识不共相种成熟力故变似色根及根依处。即内大种及所造色。有共相种成熟力故。于他身处亦变似彼。不尔应无受用他义。此中有义亦变似根。辩中边说似自他身五根现故。有义唯能变似依处。他根于己非所用故。似自他身五根现者。说自他识各自变义。故生他地或般涅槃。彼余尸骸犹见相续。前来且说业力所变外器内身界地差别。若定等力所变器身。界地自他则不决定。所变身器多恒相续。变声光等多分暂时。随现缘力击发起故。略说此识所变境者。谓有漏种十有色处及堕法处所现实色。何故此识不能变似心心所等为所缘耶。有漏识变略有二种。一随因缘势力故变。二随分别势力故变。初必有用后但为境。异熟识变但随因缘。所变色等必有实用。若变心等便无实用。相分心等不能缘故。须彼实用别从此生。变无为等亦无实用。故异熟识不缘心等。至无漏位胜慧相应。虽无分别而澄净故。设无实用亦现彼影。不尔诸佛应非遍知。故有漏位此异熟识但缘器身及有漏种。在欲色界具三所缘。无色界中缘有漏种。厌离色故无业果色。有定果色于理无违。彼识亦缘此色为境。不可知者谓此行相极微细故难可了知。或此所缘内执受境亦微细故外器世间量难测故名不可知。云何是识取所缘境行相难知。如灭定中不离身识应信为有。然必应许灭定有识有情摄故如有心时。无想等位当知亦尔

成唯识论卷第二成唯识论卷第三

        护法等菩萨造

        三藏法师玄奘奉　诏译

此识与几心所相应。常与触作意受想思相应。阿赖耶识无始时来乃至未转。于一切位恒与此五心所相应。以是遍行心所摄故。触谓三和。分别变异。令心心所触境为性。受想思等所依为业。谓根境识更相随顺故名三和。触依彼生令彼和合。故说为彼。三和合位皆有顺生心所功能说名变异。触似彼起故名分别。根变异力引触起时。胜彼识境。故集论等但说分别根之变异。和合一切心及心所。令同触境是触自性。既似顺起心所功能。故以受等所依为业。起尽经说受想行蕴一切皆以触为缘故。由斯故说识触受等因二三四和合而生。瑜伽但说与受想思为所依者。思于行蕴为主胜故举此摄余。集论等说为受依者以触生受近而胜故。谓触所取可意等相与受所取顺益等相。极相邻近引发胜故。然触自性是实非假。六六法中心所性故。是食摄故。能为缘故。如受等性非即三和。作意谓能警心为性。于所缘境引心为业。谓此警觉应起心种引令趣境故名作意。虽此亦能引起心所。心是主故但说引心。有说令心回趣异境。或于一境持心令住故名作意。彼俱非理。应非遍行不异定故。受谓领纳顺违俱非境相为性。起爱为业。能起合离非二欲故。有作是说。受有二种。一境界受。谓领所缘。二自性受。谓领俱触。唯自性受是受自相。以境界受共余相故。彼说非理。受定不缘俱生触故。若似触生名领触者。似因之果应皆受性

又既受因应名因受。何名自性。若谓如王食诸国邑。受能领触所生受体名自性受。理亦不然。违自所执不自证故。若不舍自性名自性受。应一切法皆是受自性。故彼所说但诱婴儿。然境界受非共余相。领顺等相定属己者名境界受。不共余故。想谓于境取像为性。施设种种名言为业。谓要安立境分齐相方能随起种种名言。思谓令心造作为性。于善品等役心为业。谓能取境正因等相。驱役自心令造善等。此五既是遍行所摄。故与藏识决定相应。其遍行相后当广释。此触等五与异熟识行相虽异。而时依同所缘事等。故名相应。此识行相极不明了。不能分别违顺境相。微细一类相续而转。是故唯与舍受相应。又此相应受唯是异熟。随先引业转不待现缘。住善恶业势力转故。唯是舍受。苦乐二受是异熟生。非真异熟待现缘故。非此相应。又由此识常无转变。有情恒执为自内我。若与苦乐二受相应。便有转变。宁执为我。故此但与舍受相应。若尔如何此识亦是恶业异熟。既许善业能招舍受此亦应然。舍受不违苦乐品故。如无记法善恶俱招。如何此识非别境等心所相应互相违故。谓欲希望所乐事转。此识任运无所希望。胜解印持决定事转。此识瞢昧无所印持。念唯明记曾习事转。此识昧劣不能明记。定能令心专注一境。此识任运刹那别缘。慧唯简择德等事转。此识微昧不能简择。故此不与别境相应。此识唯是异熟性故。善染污等亦不相应。恶作等四无记性者。有间断故定非异熟。法有四种。谓善不善有覆无记无覆无记。阿赖耶识何法摄耶。此识唯是无覆无记异熟性故。异熟若是善染污者。流转还灭应不得成。又此识是善染依故。若善染者互相违故。应不与二俱作所依。又此识是所熏性故。若善染者如极香臭应不受熏。无熏习故染净因果俱不成立。故此唯是无覆无记。覆谓染法。障圣道故。又能蔽心令不净故。此识非染。故名无覆。记谓善恶。有爱非爱果及殊胜自体可记别故。此非善恶。故名无记

触等亦如是者。谓如阿赖耶识唯是无覆无记性摄触作意受想思亦尔。诸相应法必同性故。又触等五如阿赖耶。亦是异熟所缘行相俱不可知。缘三种境五法相应。无覆无记。故说触等亦如是言。有义触等如阿赖耶。亦是异熟及一切种。广说乃至无覆无记。亦如是言无简别故。彼说非理。所以者何。触等依识不自在故。如贪信等不能受熏。如何同识能持种子。又若触等亦能受熏。应一有情有六种体。若尔果起从何种生。理不应言从六种起。未见多种生一芽故。若说果生唯从一种。则余五种便为无用。亦不可说次第生果。熏习同时势力等故。又不可说六果顿生。勿一有情一刹那顷六眼识等俱时生故。谁言触等亦能受熏持诸种子。不尔如何触等如识名一切种。谓触等五有似种相名一切种。触等与识所缘等故。无色触等有所缘故。亲所缘缘定应有故。此似种相不为因缘生现识等。如触等上似眼根等非识所依。亦如似火无能烧用。彼救非理。触等所缘似种等相后执受处方应与识而相例故。由此前说一切种言定目受熏能持种义。不尔本颂有重言失

又彼所说亦如是言无简别故。咸相例者定不成证。勿触等五亦能了别触等亦与触等相应。由此故知。亦如是者随所应说非谓一切。阿赖耶识为断为常。非断非常以恒转故。恒谓此识无始时来一类相续常无间断。是界趣生施设本故。性坚持种令不失故。转谓此识无始时来念念生灭前后变异。因灭果生非常一故。可为转识熏成种故。恒言遮断转表非常。犹如瀑流因果法尔。如瀑流水非断非常相续长时有所漂溺。此识亦尔。从无始来生灭相续非常非断。漂溺有情令不出离。又如瀑流虽风等击起诸波浪而流不断。此识亦尔。虽遇众缘起眼识等而恒相续。又如瀑流漂水下上鱼草等物随流不舍此识亦尔。与内习气外触等法恒相随转。如是法喻意显此识无始因果非断常义。谓此识性无始时来刹那刹那果生因灭。果生故非断。因灭故非常。非断非常是缘起理。故说此识恒转如流。过去未来既非实有。非常可尔。非断如何。断岂得成缘起正理。过去未来若是实有可许非断如何非常。常亦不成缘起正理。岂斥他过己义便成。若不摧邪难以显正。前因灭位后果即生。如秤两头低昂时等。如是因果相续如流。何假去来方成非断。因现有位后果未生。因是谁因。果现有时前因已灭。果是谁果。既无因果谁离断常。若有因时已有后果。果既本有。何待前因。因义既无果义宁有无因无果岂离断常。因果义成依法作用。故所诘难非预我宗。体既本有用亦应然。所待因缘亦本有故。由斯汝义因果定无。应信大乘缘起正理。谓此正理深妙离言因果等言皆假施设。观现在法有引后用。假立当果对说现因。观现在法有酬前相。假立曾因对说现果。假谓现识似彼相现。如是因果理趣显然。远离二边契会中道。诸有智者应顺修学。有余部说虽无去来而有因果恒相续义。谓现在法极迅速者犹有初后生灭二时。生时酬因灭时引果。时虽有二而体是一。前因正灭后果正生。体相虽殊而俱是有。如是因果非假施设。然离断常。又无前难谁有智者舍此信余。彼有虚言都无实义。何容一念而有二时。生灭相违宁同现在。灭若现在生应未来。有故名生既是现在。无故名灭宁非过去。灭若非无生应非有。生既现有灭应现无。又二相违如何体一。非苦乐等见有是事生灭若一时应无二。生灭若异宁说体同。故生灭时俱现在有同依一体理必不成。经部师等因果相续理亦不成。彼不许有阿赖耶识能持种故。由此应信大乘所说因果相续缘起正理

此识无始恒转如流乃至何位当究竟舍。阿罗汉位方究竟舍。谓诸圣者断烦恼障究竟尽时名阿罗汉。尔时此识烦恼粗重永远离故说之为舍。此中所说阿罗汉者通摄三乘无学果位。皆已永害烦恼贼故。应受世间妙供养故。永不复受分段生故。云何知然。决择分说诸阿罗汉独觉如来皆不成就阿赖耶故。集论复说若诸菩萨得菩提时顿断烦恼及所知障成阿罗汉及如来故。若尔菩萨烦恼种子未永断尽非阿罗汉应皆成就阿赖耶识。何故即彼决择分说不退菩萨亦不成就阿赖耶识。彼说二乘无学果位回心趣向大菩提者。必不退起烦恼障故。趣菩提故。即复转名不退菩萨。彼不成就阿赖耶识。即摄在此阿罗汉中。故彼论文不违此义。又不动地已上菩萨。一切烦恼永不行故。法驶流中任运转故。能诸行中起诸行故。刹那刹那转增进故。此位方名不退菩萨。然此菩萨虽未断尽异熟识中烦恼种子。而缘此识我见爱等不复执藏为自内我。由斯永舍阿赖耶名。故说不成阿赖耶识。此亦说彼名阿罗汉。有义初地已上菩萨。已证二空所显理故。已得二种殊胜智故。已断分别二重障故。能一行中起诸行故。虽为利益起诸烦恼。而彼不作烦恼过失。故此亦名不退菩萨。然此菩萨虽未断尽俱生烦恼。而缘此识所有分别我见爱等不复执藏为自内我。由斯亦舍阿赖耶名。故说不成阿赖耶识。此亦说彼名阿罗汉。故集论中作如是说。十地菩萨虽未永断一切烦恼。然此烦恼犹如咒药所伏诸毒。不起一切烦恼过失。一切地中如阿罗汉已断烦恼。故亦说彼名阿罗汉。彼说非理。七地已前犹有俱生我见爱等。执藏此识为自内我。如何已舍阿赖耶名。若彼分别我见爱等不复执藏说名为舍。则预流等诸有学位。亦应已舍阿赖耶名。许便违害诸论所说。地上菩萨所起烦恼。皆由正知不为过失。非预流等得有斯事。宁可以彼例此菩萨。彼六识中所起烦恼。虽由正知不为过失。而第七识有漏心位任运现行执藏此识。宁不与彼预流等同。由此故知彼说非理。然阿罗汉断此识中烦恼粗重究竟尽故。不复执藏阿赖耶识为自内我。由斯永失阿赖耶名说之为舍。非舍一切第八识体。勿阿罗汉无识持种。尔时便入无余涅槃。然第八识虽诸有情皆悉成就。而随义别立种种名。谓或名心。由种种法熏习种子所积集故。或名阿陀那。执持种子及诸色根令不坏故。或名所知依。能与染净所知诸法为依止故。或名种子识。能遍任持世出世间诸种子故。此等诸名通一切位。或名阿赖耶。摄藏一切杂染品法令不失故。我见爱等执藏以为自内我故。此名唯在异生有学。非无学位不退菩萨有杂染法执藏义故。或名异熟识。能引生死善不善业异熟果故。此名唯在异生二乘诸菩萨位。非如来地犹有异熟无记法故。或名无垢识。最极清净诸无漏法所依止故此名唯在如来地有。菩萨二乘及异生位持有漏种可受熏习。未得善净第八识故如契经说

  如来无垢识　　是净无漏界
  解脱一切障　　圆镜智相应

阿赖耶名过失重故最初舍故此中偏说。异熟识体菩萨将得菩提时舍。声闻独觉入无余依涅槃时舍。无垢识体无有舍时。利乐有情无尽时故。心等通故随义应说然第八识总有二位。一有漏位。无记性摄。唯与触等五法相应。但缘前说执受处境。二无漏位。唯善性摄。与二十一心所相应。谓遍行别境各五善十一。与一切心恒相应故。常乐证智所观境故。于所观境恒印持故。于曾受境恒明记故。世尊无有不定心故。于一切法常决择故。极净信等常相应故。无染污故。无散动故。此亦唯与舍受相应。任运恒时平等转故。以一切法为所缘境。镜智遍缘一切法故

云何应知此第八识离眼等识有别自体。圣教正理为定量故。谓有大乘阿毗达磨契经中说

  无始时来界　　一切法等依
  由此有诸趣　　及涅槃证得

此第八识自性微细。故以作用而显示之。颂中初半显第八识为因缘用。后半显与流转还灭作依持用。界是因义。即种子识无始时来展转相续亲生诸法故名为因。依是缘义。即执持识无始时来与一切法等为依止故名为缘。谓能执持诸种子故与现行法为所依故即变为彼及为彼依。变为彼者谓变为器及有根身。为彼依者谓与转识作所依止。以能执受五色根故眼等五识依之而转。又与末那为依止故第六意识依之而转。末那意识转识摄故如眼等识依俱有根。第八理应是识性故亦以第七为俱有依。是谓此识为因缘用。由此有者由有此识。有诸趣者有善恶趣。谓由有此第八识故执持一切顺流转法令诸有情流转生死。虽惑业生皆是流转。而趣是果胜故偏说。或诸趣言通能所趣。诸趣资具亦得趣名。诸惑业生皆依此识。是与流转作依持用。及涅槃证得者由有此识故有涅槃证得。谓由有此第八识故。执持一切顺还灭法令修行者证得涅槃。此中但说能证得道。涅槃不依此识有故。或此但说所证涅槃。是修行者正所求故。或此双说涅槃与道。俱是还灭品类摄故。谓涅槃言显所证灭。后证得言显能得道。由能断道断所断惑究竟尽位证得涅槃。能所断证皆依此识。是与还灭作依持用。又此颂中初句显示此识自性无始恒有。后三显与杂染清净二法总别为所依止。杂染法者谓苦集谛。即所能趣生及业惑。清净法者谓灭道谛。即所能证涅槃及道。彼二皆依此识而有。依转识等理不成故。或复初句显此识体无始相续。后三显与三种自性为所依止。谓依他起遍计所执圆成实性。如次应知。今此颂中诸所说义离第八识皆不得有。即彼经中复作是说

  由摄藏诸法　　一切种子识
  故名阿赖耶　　胜者我开示

由此本识具诸种子故能摄藏诸杂染法。依斯建立阿赖耶名。非如胜性转为大等。种子与果体非一故。能依所依俱生灭故。与杂染法互相摄藏。亦为有情执藏为我。故说此识名阿赖耶。已入见道诸菩萨众得真现观名为胜者。彼能证解阿赖耶识。故我世尊正为开示。或诸菩萨皆名胜者。虽见道前未能证解阿赖耶识。而能信解求彼转依。故亦为说。非诸转识有如是义。解深密经亦作是说

  阿陀那识甚深细　　一切种子如瀑流
  我于凡愚不开演　　恐彼分别执为我

以能执持诸法种子。及能执受色根依处。亦能执取结生相续。故说此识名阿陀那。无性有情不能穷底故说甚深。趣寂种性不能通达故名甚细。是一切法真实种子。缘击便生转识波浪恒无间断犹如瀑流。凡即无性。愚即趣寂。恐彼于此起分别执堕诸恶趣障生圣道。故我世尊不为开演。唯第八识有如是相。入楞伽经亦作是说

  如海遇风缘　　起种种波浪
  现前作用转　　无有间断时
  藏识海亦然　　境等风所击
  恒起诸识浪　　现前作用转

眼等诸识无如大海恒相续转起诸识浪。故知别有第八识性。此等无量大乘经中。皆别说有此第八识。诸大乘经皆顺无我违数取趣。弃背流转趣向还灭。赞佛法僧毁诸外道。表蕴等法遮胜性等。乐大乘者许能显示无颠倒理契经摄故。如增壹等至教量摄。又圣慈氏以七种因证大乘经真是佛说。一先不记故。若大乘经佛灭度后有余为坏正法故说。何故世尊非如当起诸可怖事先预记别。二本俱行故。大小乘教本来俱行。宁知大乘独非佛说。三非余境故。大乘所说广大甚深非外道等思量境界。彼经论中曾所未说。设为彼说亦不信受。故大乘经非非佛说。四应极成故。若谓大乘是余佛说非今佛语。则大乘教是佛所说其理极成。五有无有故。若有大乘即应信此诸大乘教是佛所说。离此大乘不可得故。若无大乘声闻乘教亦应非有。以离大乘决定无有得成佛义。谁出于世说声闻乘。故声闻乘是佛所说。非大乘教不应正理。六能对治故。依大乘经勤修行者皆能引得无分别智。能正对治一切烦恼。故应信此是佛所说。七义异文故。大乘所说意趣甚深。不可随文而取其义便生诽谤谓非佛语。是故大乘真是佛说。如庄严论颂此义言

  先不记俱行　　非余所行境
  极成有无有　　对治异文故

余部经中亦密意说阿赖耶识有别自性。谓大众部阿笈摩中密意说此名根本识。是眼识等所依止故。譬如树根是茎等本。非眼等识有如是义。上坐部经分别论者俱密意说此名有分识。有谓三有。分是因义唯此恒遍为三有因。化地部说此名穷生死蕴。离第八识无别蕴法穷生死际无间断时。谓无色界诸色间断。无想天等余心等灭。不相应行离色心等无别自体。已极成故。唯此识名穷生死蕴。说一切有部增壹经中亦密意说此名阿赖耶。谓爱阿赖耶．乐阿赖耶．欣阿赖耶．喜阿赖耶。谓阿赖耶识是贪总别三世境故立此四名。有情执为真自内我。乃至未断恒生爱着故。阿赖耶识是真爱着处。不应执余五取蕴等。谓生一向苦受处者于余五取蕴不生爱着。彼恒厌逆余五取蕴念我何时当舍此命此众同分此苦身心令我自在受快乐故。五欲亦非真爱着处。谓离欲者于五妙欲虽不贪着而爱我故。乐受亦非真爱着处。谓离第三静虑染者虽厌乐受而爱我故。身见亦非真爱着处。谓非无学信无我者虽于身见不生贪着而于内我犹生爱故。转识等亦非真爱着处。谓非无学求灭心者虽厌转识等而爱我故。色身亦非真爱着处。离色染者虽厌色身而爱我故。不相应行离色心等无别自体。是故亦非真爱着处。异生有学起我爱时虽于余蕴有爱非爱而于此识我爱定生。故唯此是真爱着处。由是彼说阿赖耶名。定唯显此阿赖耶识

已引圣教当显正理。谓契经说杂染清净诸法种子之所集起。故名为心。若无此识彼持种心不应有故。谓诸转识在灭定等有间断故。根境作意善等类别易脱起故。如电光等不坚住故。非可熏习。不能持种。非染净种所集起心。此识一类恒无间断如苣蕂等。坚住可熏。契当彼经所说心义

若不许有能持种心。非但违经亦违正理。谓诸所起染净品法无所熏故不熏成种则应所起唐捐其功。染净起时既无因种。应同外道执自然生。色不相应非心性故。如声光等理非染净内法所熏。岂能持种

又彼离识无实自性宁可执为内种依止。转识相应诸心所法。如识间断易脱起故。不自在故。非心性故。不能持种亦不受熏。故持种心理应别有。有说六识无始时来依根境等前后分位事虽转变而类无别。是所熏习能持种子。由斯染净因果皆成。何要执有第八识性。彼言无义。所以者何。执类是实则同外道。许类是假便无胜用应不能持内法实种。又执识类何性所摄。若是善恶应不受熏。许有记故。犹如择灭。若是无记善恶心时无无记心此类应断。非事善恶类可无记。别类必同别事性故。又无心位此类定无。既有间断性非坚住。如何可执持种受熏。又阿罗汉或异生心识类同故应为诸染无漏法熏。许便有失。又眼等根或所余法与眼等识根法类同应互相熏。然汝不许。故不应执识类受熏。又六识身若事若类。前后二念既不俱有如隔念者非互相熏。能熏所熏必俱时故。执唯六识俱时转者。由前理趣既非所熏。故彼亦无能持种义。有执色心自类无间前为后种因果义立。故先所说为证不成。彼执非理无熏习故。谓彼自类既无熏习。如何可执前为后种。又间断者应不更生。二乘无学应无后蕴。死位色心为后种故。亦不应执色心展转互为种生。转识色等非所熏习前已说故。有说三世诸法皆有。因果感赴无不皆成。何劳执有能持种识。然经说心为种子者起染净法势用强故。彼说非理。过去未来非常非现如空花等。非实有故。又无作用不可执为因缘性故。若无能持染净种识一切因果皆不得成。有执大乘遣相空理为究竟者。依似比量拨无此识及一切法。彼特违害前所引经。智断证修染净因果皆执非实成大邪见。外道毁谤染净因果亦不谓全无。但执非实故。若一切法皆非实有菩萨不应为舍生死精勤修集菩提资粮。谁有智者为除幻敌求石女儿用为军旅。故应信有能持种心依之建立染净因果。彼心即是此第八识

又契经说有异熟心善恶业感。若无此识彼异熟心不应有故。谓眼等识有间断故。非一切时是业果故。如电光等非异熟心。异熟不应断已更续。彼命根等无斯事故。眼等六识业所感者犹如声等。非恒续故。是异熟生非真异熟。定应许有真异熟心酬牵引业遍而无断变为身器作有情依。身器离心理非有故。不相应法无实体故。诸转识等非恒有故。若无此心谁变身器。复依何法恒立有情。又在定中或不在定有别思虑无思虑时理有众多身受生起。此若无者不应后时身有怡适或复劳损。若不恒有真异熟心。彼位如何有此身受。非佛起余善心等位。必应现起真异熟心。如许起彼时。非佛有情故。由是恒有真异熟心。彼心即是此第八识

又契经说有情流转五趣四生。若无此识彼趣生体不应有故。谓要实有。恒遍无杂。彼法可立正实趣生。非异熟法趣生杂乱住此起余趣生法故。诸异熟色及五识中业所感者不遍趣生。无色界中全无彼故。诸生得善及意识中业所感者。虽遍趣生起无杂乱而不恒有。不相应行无实自体。皆不可立正实趣生。唯异熟心及彼心所实恒遍无杂。是正实趣生。此心若无生无色界起善等位应非趣生。设许趣生摄诸有漏生无色界起无漏心。应非趣生便违正理。勿有前过及有此失故。唯异熟法是正实趣生。由是如来非趣生摄。佛无异熟无记法故。亦非界摄非有漏故。世尊已舍苦集谛故。诸戏论种已永断故。正实趣生既唯异熟心及心所。彼心心所离第八识理不得成。故知别有此第八识

又契经说有色根身是有执受。若无此识彼能执受不应有故。谓五色根及彼依处。唯现在世是有执受彼定由有能执受心。唯异熟心先业所引非善染等。一类能遍相续执受有色根身。眼等转识无如是义。此言意显眼等转识皆无一类能遍相续执受自内有色根身。非显能执受唯异熟心。勿诸佛色身无执受故。然能执受有漏色身唯异熟心。故作是说。谓诸转识现缘起故。如声风等。彼善染等非业引故。如非择灭。异熟生者非异熟故。非遍依故。不相续故。如电光等。不能执受有漏色身。诸心识言亦摄心所。定相应故如唯识言。非诸色根不相应行可能执受有色根身。无所缘故。如虚空等。故应别有能执受心。彼心即是此第八识

又契经说寿暖识三更互依持得相续住。若无此识能持寿暖令久住识不应有故。谓诸转识有间有转如声风等。无恒持用不可立为持寿暖识。唯异熟。识无间无转犹如寿暖。有恒持用故可立为持寿暖识。经说三法更互依持。而寿与暖一类相续。唯识不然。岂符正理。虽说三法更互依持而许唯暖不遍三界。何不许识独有间转此于前理非为过难。谓若是处具有三法无间转者可恒相持。不尔便无恒相持用前以此理显三法中所说识言非诠转识。举缓不遍岂坏前理。故前所说其理极成。又三法中寿暖二种既唯有漏。故知彼识如寿与暖定非无漏。生无色界起无漏心。尔时何识能持彼寿。由此故知有异熟识一类恒遍能持寿暖。彼识即是此第八识

又契经说诸有情类受生命终必住散心非无心定。若无此识生死时心不应有故。谓生死时身心惛昧。如睡无梦极闷绝时。明了转识必不现起。又此位中六种转识行相所缘不可知故。如无心位必不现行。六种转识行相所缘有必可知。如余时故。真异熟识极微细故。行相所缘俱不可了。是引业果一期相续。恒无转变。是散有心名生死心。不违正理。有说五识此位定无。意识取境。或因五识。或因他教。或定为因。生位诸因既不可得。故受生位意识亦无。若尔有情生无色界后时意识应永不生。定心必由散意识引。五识他教彼界必无。引定散心无由起故。若谓彼定由串习力后时率尔能现在前。彼初生时宁不现起。又欲色界初受生时串习意识亦应现起。若由惛昧初未现前此即前因。何劳别说。有余部执。生死等位别有一类微细意识。行相所缘俱不可了。应知即是此第八识

极成意识不如是故。又将死时由善恶业下上身分冷触渐起。若无此识彼事不成。转识不能执受身故。眼等五识各别依故。或不行故

第六意识不住身故。境不定故。遍寄身中恒相续故。不应冷触由彼渐生。唯异熟心由先业力恒遍相续执受身分。舍执受处冷触便生。寿暖识三不相离故。冷触起处即是非情。虽变亦缘而不执受。故知定有此第八识

又契经说识缘名色。名色缘识。如是二法展转相依譬如芦束俱时而转。若无此识彼识自体不应有故。谓彼经中自作是释。名谓非色四蕴。色谓羯逻蓝等。此二与识相依而住如二芦束更互为缘恒俱时转不相舍离。眼等转识摄在名中。此识若无说谁为识。亦不可说名中识蕴谓五识身。识谓第六。羯逻蓝时无五识故。又诸转识有间转故。无力恒时执持名色。宁说恒与名色为缘。故彼识言显第八识

成唯识论卷第三成唯识论卷第四

        护法等菩萨造

        三藏法师玄奘奉　诏译

又契经说一切有情皆依食住。若无此识彼识食体不应有故。谓契经说食有四种。一者段食变坏为相。谓欲界系香味触三于变坏时能为食事。由此色处非段食摄。以变坏时色无用故。二者触食触境为相。谓有漏触才取境时摄受喜等能为食事。此触虽与诸识相应。属六识者食义偏胜。触粗显境摄受喜乐及顺益舍资养胜故。三意思食希望为相。谓有漏思与欲俱转。希可爱境能为食事。此思虽与诸识相应。属意识者食义偏胜。意识于境希望胜故。四者识食执持为相。谓有漏识由段触思势力增长能为食事。此识虽通诸识自体。而第八识食义偏胜。一类相续执持胜故。由是集论说此四食三蕴五处十一界摄。此四能持有情身命令不坏断故名为食。段食唯于欲界有用。触意思食虽遍三界而依识转随识有无。眼等转识有间有转。非遍恒时能持身命。谓无心定睡眠闷绝无想天中有间断故。设有心位随所依缘性界地等有转易故。于持身命非遍非恒。诸有执无第八识者依何等食经作是言。一切有情皆依食住。非无心位过去未来识等为食。彼非现常如空花等无体用故。设有体用非现在摄如虚空等非食性故。亦不可说入定心等与无心位有情为食。住无心时彼已灭故。过去非食已极成故。又不可说无想定等不相应行即为彼食。段等四食所不摄故。不相应法非实有故。有执灭定等犹有第六识于彼有情能为食事。彼执非理后当广破。又彼应说生上二界无漏心时以何为食。无漏识等破坏有故。于彼身命不可为食。亦不可执无漏识中有有漏种能为彼食。无漏识等犹如涅槃。不能执持有漏种故。复不可说上界有情身命相持即互为食。四食不摄彼身命故。又无色无身命无能持故。众同分等无实体故。由此定知。异诸转识有异熟识。一类恒遍执持身命令不坏断。世尊依此故作是言。一切有情皆依食住。唯依取蕴建立有情。佛无有漏非有情摄。说为有情依食住者当知皆依示现而说。既异熟识是胜食性。彼识即是此第八识

又契经说住灭定者身语心行无不皆灭。而寿不灭亦不离暖。根无变坏。识不离身。若无此识住灭定者。不离身识不应有故。谓眼等识行相粗动。于所缘境起必劳虑。厌患彼故暂求止息渐次伏除至都尽位。依此位立住灭定者。故此定中彼识皆灭。若不许有微细一类恒遍执持寿等识在。依何而说识不离身。若谓后时彼识还起如隔日疟名不离身。是则不应说心行灭。识与想等起灭同故。寿暖诸根应亦如识便成大过。故应许识如寿暖等实不离身。又此位中若全无识应如瓦砾非有情数。岂得说为住灭定者。又异熟识此位若无。谁能执持诸根寿暖。无执持故皆应坏灭。犹如死尸便无寿等。既尔后识必不还生。说不离身彼何所属。诸异熟识舍此身已。离识余身无重生故。又若此位无持种识。后识无种如何得生。过去未来不相应法非实有体已极成故。诸色等法离识皆无。受熏持种亦已遮故。然灭定等无心位中如有心位定实有识。具根寿暖有情摄故。由斯理趣住灭定者。决定有识实不离身。若谓此位有第六识名不离身亦不应理。此定亦名无心定故。若无五识名无心者。应一切定皆名无心。诸定皆无五识身故。意识摄在六转识中。如五识身灭定非有。或此位识行相所缘不可知故。如寿暖等非第六识。若此位有行相所缘可知识者。应如余位非此位摄。本为止息行相所缘可了知识入此定故。又若此位有第六识彼心所法为有为无。若有心所经不应言住此定者心行皆灭。又不应名灭受想定。此定加行但厌受想故此定中唯受想灭。受想二法资助心强。诸心所中独名心行。说心行灭何所相违。无想定中应唯想灭。但厌想故然汝不许。既唯受想资助心强此二灭时心亦应灭。如身行灭而身犹在。宁要责心令同行灭。若尔语行寻伺灭时语应不灭而非所许。然行于法有遍非遍。遍行灭时法定随灭。非遍行灭法或犹在。非遍行者谓入出息。见息灭时身犹在故。寻伺于语是遍行摄。彼若灭时语定无故。受想于心亦遍行摄。许如思等大地法故。受想灭时心定随灭。如何可说彼灭心在。又许思等是大地法灭受想时彼亦应灭。既尔信等此位亦无。非遍行灭余可在故。如何可言有余心所。既许思等此位非无受想应然。大地法故。又此定中若有思等亦应有触。余心所法无不皆依触力生故。若许有触亦应有受。触缘受故。既许有受想亦应生。不相离故。如受缘爱非一切受皆能起爱。故触缘受非一切触皆能生受。由斯所难其理不成。彼救不然有差别故。谓佛自简唯无明触所生诸受为缘生爱。曾无有处简触生受。故若有触必有受生。受与想俱其理决定。或应如余位受想亦不灭。执此位中有思等故。许便违害心行灭言。亦不得成灭受想定。若无心所识亦应无。不见余心离心所故。余遍行灭法随灭故。受等应非大地法故。此识应非相应法故。许则应无所依缘等。如色等法亦非心故。又契经说意法为缘生于意识。三和合触与触俱起有受想思。若此定中有意识者。三和合故必应有触。触既定与受想思俱。如何有识而无心所。若谓余时三和有力成触生触能起受等。由此定前厌患心所故在定位三事无能不成生触亦无受等。若尔应名灭心所定。如何但说灭受想耶。若谓厌时唯厌受想。此二灭故心所皆灭。依前所厌以立定名。既尔此中心亦应灭。所厌俱故如余心所。不尔如何名无心定。又此定位意识是何。不应是染或无记性。诸善定中无此事故。余染无记心必有心所故。不应厌善起染等故。非求寂静翻起散故。若谓是善。相应善故。应无贪等善根相应。此心不应是自性善或胜义善。违自宗故非善根等及涅槃故。若谓此心是等起善。加行善根所引发故。理亦不然违自宗故。如余善心非等起故。善心无间起三性心。如何善心由前等起。故心是善由相应力。既尔必与善根相应。宁说此心独无心所。故无心所心亦应无。如是推征眼等转识于灭定位非不离身。故契经言不离身者。彼识即是此第八识

入灭定时不为止息此极寂静执持识故。无想等位类此应知

又契经说心杂染故有情杂染。心清净故有情清净。若无此识彼染净心不应有故。谓染净法以心为本。因心而生依心住故。心受彼熏持彼种故。然杂染法略有三种。烦恼业果种类别故。若无此识持烦恼种界地往还无染心后诸烦恼起皆应无因。余法不能持彼种故。过去未来非实有故。若诸烦恼无因而生。则无三乘学无学果。诸已断者皆应起故。若无此识持业果种。界地往还异类法后。诸业果起亦应无因。余种余因前已遮故。若诸业果无因而生。入无余依涅槃界已。三界业果还复应生。烦恼亦应无因生故。又行缘识应不得成。转识受熏前已遮故。结生染识非行感故。应说名色行为缘故。时分悬隔无缘义故。此不成故后亦不成。诸清净法亦有三种。世出世道断果别故。若无此识持世出世清净道种。异类心后起彼净法皆应无因。所执余因前已破故。若二净道无因而生。入无余依涅槃界已。彼二净道还复应生。所依亦应无因生故。又出世道初不应生。无法持彼法尔种故。有漏类别非彼因故。无因而生非释种故。初不生故后亦不生。是则应无三乘道果。若无此识持烦恼种。转依断果亦不得成。谓道起时现行烦恼及彼种子俱非有故。染净二心不俱起故。道相应心不持彼种。自性相违如涅槃故。去来得等非实有故。余法持种理不成故。既无所断能断亦无。依谁由谁而立断果。若由道力后惑不生立断果者。则初道起应成无学。后诸烦恼皆已无因。永不生故。许有此识一切皆成。唯此能持染净种故。证此识有理趣无边。恐厌繁文略述纲要。别有此识教理显然。诸有智人应深信受。如是已说初能变相。第二能变其相云何。颂曰

  ５次第二能变　　是识名末那
  依彼转缘彼　　思量为性相
  ６四烦恼常俱　　谓我痴我见
  并我慢我爱　　及余触等俱
  ７有覆无记摄　　随所生所系
  阿罗汉灭定　　出世道无有

论曰。次初异熟能变识后应辩思量能变识相。是识圣教别名末那。恒审思量胜余识故。此名何异第六意识。此持业释如藏识名。识即意故。彼依主释。如眼识等。识异意故。然诸圣教恐此滥彼故于第七但立意名。又标意名为简心识。积集了别劣余识故。或欲显此与彼意识为近所依故但名意。依彼转者显此所依。彼谓即前初能变识。圣说此识依藏识故。有义此意以彼识种而为所依。非彼现识。此无间断不假现识为俱有依方得生故。有义此意以彼识种及彼现识俱为所依。虽无间断而有转易名转识故。必假现识为俱有依方得生故。转谓流转。显示此识恒依彼识取所缘故

诸心心所皆有所依。然彼所依总有三种。一因缘依。谓自种子。诸有为法皆托此依。离自因缘必不生故。二增上缘依。谓内六处。诸心心所皆托此依。离俱有根必不转故。三等无间缘依。谓前灭意。诸心心所皆托此依。离开导根必不起故。唯心心所具三所依名有所依非所余法。初种子依有作是说。要种灭已现果方生。无种已生集论说故。种与芽等不俱有故。有义彼说为证不成。彼依引生后种说故。种生芽等非胜义故。种灭芽生非极成故。焰炷同时互为因故。然种自类因果不俱。种现相生决定俱有。故瑜伽说无常法与他性为因。亦与后念自性为因。是因缘义。自性言显种子自类前为后因。他性言显种与现行互为因义。摄大乘论亦作是说。藏识染法互为因缘。犹如束芦俱时而有。又说种子与果必俱。故种子依定非前后。设有处说种果前后应知皆是随转理门。如是八识及诸心所定各别有种子所依。次俱有依有作是说。眼等五识意识为依。此现起时必有彼故。无别眼等为俱有依。眼等五根即种子故。二十唯识伽他中言

  识从自种生　　似境相而转
  为成内外处　　佛说彼为十

彼颂意说。世尊为成十二处故。说五识种为眼等根。五识相分为色等境。故眼等根即五识种。观所缘论亦作是说

  识上色功能　　名五根应理
  功能与境色　　无始互为因

彼颂意言。异熟识上能生眼等色识种子名色功能。说为五根无别眼等。种与色识常互为因。能熏与种递为因故。第七八识无别此依。恒相续转自力胜故。第六意识别有此依。要托末那而得起故。有义彼说理教相违。若五色根即五识种。十八界种应成杂乱。然十八界各别有种。诸圣教中处处说故。又五识种各有能生相见分异。为执何等名眼等根。若见分种应识蕴摄。若相分种应外处摄。便违圣教眼等五根皆是色蕴内处所摄。又若五根即五识种。五根应是五识因缘。不应说为增上缘摄。又鼻舌根即二识种。则应鼻舌唯欲界系。或应二识通色界系。许便俱与圣教相违。眼耳身根即三识种。二界五地为难亦然。又五识种既通善恶。应五色根非唯无记。又五识种无执受摄。五根亦应非有执受。又五色根若五识种。应意识种即是末那。彼以五根为同法故。又瑜伽论说眼等识皆具三依。若五色根即五识种。依但应二。又诸圣教说眼等根皆通现种。执唯是种便与一切圣教相违。有避如前所说过难。朋附彼执复转救言。异熟识中能感五识。增上业种名五色根。非作因缘生五识种。妙符二颂善顺瑜伽。彼有虚言都无实义。应五色根非无记故。又彼应非唯有执受。唯色蕴摄。唯内处故。鼻舌唯应欲界系故。三根不应。五地系故。感意识业应末那故。眼等不应通现种故。又应眼等非色根故

又若五识皆业所感。则应一向无记性摄。善等五识既非业感。应无眼等为俱有依。故彼所言非为善救。又诸圣教处处皆说。阿赖耶识变似色根及根依处器世间等。如何汝等拨无色根。许眼等识变似色等不许眼等藏识所变。如斯迷谬深违教理。然伽他说种子功能名五根者。为破离识实有色根。于识所变似眼根等。以有发生五识用故。假名种子及色功能。非谓色根即识业种。又缘五境明了意识。应以五识为俱有依。以彼必与五识俱故。若彼不依眼等识者。彼应不与五识为依。彼此相依势力等故。又第七识虽无间断。而见道等既有转易。应如六识有俱有依。不尔彼应非转识摄。便违圣教转识有七。故应许彼有俱有依。此即现行第八识摄。如瑜伽说。有藏识故得有末那。末那为依意识得转。彼论意言现行藏识为依止故。得有末那非由彼种。不尔应说有藏识故意识得转。由此彼说理教相违。是故应言。前五转识一一定有二俱有依。谓五色根同时意识。第六转识决定恒有一俱有依。谓第七识。若与五识俱时起者亦以五识为俱有依。第七转识决定唯有一俱有依。谓第八识。唯第八识恒无转变。自能立故无俱有依。有义此说犹未尽理。第八类余既同识性。如何不许有俱有依。第七八识既恒俱转。更互为依斯有何失。许现起识以种为依。识种亦应许依现识。能熏异熟为生长住依。识种离彼不生长住故

又异熟识有色界中能执持身依色根转。如契经说。阿赖耶识业风所飘遍依诸根恒相续转。瑜伽亦说。眼等六识各别依故不能执受有色根身。若异熟识不遍依止有色诸根。应如六识非能执受。或所立因有不定失。是故藏识若现起者定有一依。谓第七识。在有色界亦依色根。若识种子定有一依。谓异熟识。初熏习位亦依能熏。余如前说。有义前说皆不应理。未了所依与依别故。依谓一切有生灭法。仗因托缘而得生住。诸所仗托皆说为依。如王与臣互相依等。若法决定有境为主令心心所取自所缘。乃是所依。即内六处。余非有境定为主故。此但如王非如臣等。故诸圣教唯心心所名有所依。非色等法无所缘故。但说心所心为所依。不说心所为心所依。彼非主故。然有处说依为所依或所依为依。皆随宜假说。由此五识俱有所依定有四种。谓五色根六七八识。随阙一种必不转故。同境分别染净根本所依别故。圣教唯说依五根者。以不共故又必同境。近相顺故。第六意识俱有所依唯有二种。谓七八识。随阙一种必不转故。虽五识俱取境明了。而不定有故非所依。圣教唯说依第七者。染净依故同转识摄。近相顺故。第七意识俱有所依但有一种。谓第八识。藏识若无定不转故。如伽他说

  阿赖耶为依　　故有末那转
  依止心及意　　余转识得生

阿赖耶识俱有所依亦但一种。谓第七识。彼识若无定不转故。论说藏识恒与末那俱时转故。又说藏识恒依染污。此即末那。而说三位无末那者依有覆说。如言四位无阿赖耶。非无第八。此亦应尔。虽有色界亦依五根。而不定有非所依摄。识种不能现取自境。可有依义而无所依。心所所依随识应说。复各加自相应之心。若作是说妙符理教。后开导依。有义五识自他前后不相续故。必第六识所引生故。唯第六识为开导依。第六意识自相续故。亦由五识所引生故。以前六识为开导依。第七八识自相续故。不假他识所引生故。但以自类为开导依。有义前说未有究理。且前五识未自在位。遇非胜境可如所说。若自在位。如诸佛等于境自在。诸根互用任运决定不假寻求。彼五识身宁不相续。等流五识既为决定染净作意势力引生。专注所缘未能舍顷。如何不许多念相续。故瑜伽说决定心后方有染净。此后乃有等流眼识善不善转。而彼不由自分别力。乃至此意不趣余境。经尔所时眼意二识。或善或染相续而转。如眼识生乃至身识应知亦尔。彼意定显经尔所时眼意二识俱相续转。既眼识时非无意识。故非二识互相续生。若增盛境相续现前。逼夺身心不能暂舍时五识身理必相续。如热地狱戏忘天等。故瑜伽言若此六识为彼六识等无间缘。即施设此名为意根。若五识前后定唯有意识。彼论应言若此一识为彼六识等无间缘。或彼应言若此六识为彼一识等无间缘。既不如是故知五识有相续义。五识起时必有意识能引后念意识令起。何假五识为开导依。无心睡眠闷绝等位意识断已。后复起时藏识末那既恒相续。亦应与彼为开导依。若彼用前自类开导。五识自类何不许然。此既不然彼云何尔。平等性智相应末那。初起必由第六意识。亦应用彼为开导依。圆镜智俱第八净识。初必六七方便引生。又异熟心依染污意。或依悲愿相应善心。既尔必应许第八识亦以六七为开导依。由此彼言都未究理。应说五识前六识内随用何识为开导依。第六意识用前自类或第七八为开导依。第七末那用前自类或第六识为开导依。阿陀那识用前自类及第六七为开导依。皆不违理由前说故。有义此说亦不应理。开导依者谓有缘法为主能作等无间缘。此于后生心心所法。开避引导名开导依。此但属心非心所等。若此与彼无俱起义。说此于彼有开导力。一身八识既容俱起。如何异类为开导依。若许为依应不俱起。便同异部心不并生

又一身中诸识俱起。多少不定若容互作等无间缘。色等应尔。便违圣说等无间缘唯心心所。然摄大乘说色亦容有等无间缘者。是纵夺言。谓假纵小乘色心前后有等无间缘夺因缘故。不尔等言应成无用。若谓等言非遮多少但表同类。便违汝执异类识作等无间缘。是故八识各唯自类为开导依深契教理。自类必无俱起义故。心所此依应随识说。虽心心所异类并生。而互相应。和合似一。定俱生灭。事业必同。一开导时余亦开导。故展转作等无间缘。诸识不然不应为例。然诸心所非开导依。于所引生无主义故。若心心所等无间缘各唯自类。第七八识初转依时。相应信等此缘便阙。则违圣说诸心心所皆四缘生。无心睡眠闷绝等位。意识虽断而后起时。彼开导依即前自类。间断五识应知亦然。无自类心于中为隔名无间故。彼先灭时已于今识为开导故。何烦异类为开导依。然圣教中说前六识互相引起。或第七八依六七生。皆依殊胜增上缘说。非等无间故不相违。瑜伽论说若此识无间诸识决定生。说此为彼等无间缘。又此六识为彼六识等无间缘。即施设此名意根者。言总意别亦不相违。故自类依深契教理。傍论已了应辩正论。此能变识虽具三所依。而依彼转言但显前二。为显此识依缘同故。又前二依有胜用故。或开导依易了知故

如是已说此识所依。所缘云何。谓即缘彼。彼谓即前此所依识。圣说此识缘藏识故。有义此意缘彼识体及相应法。论说末那我我所执恒相应故。谓缘彼体及相应法。如次执为我及我所。然诸心所不离识故。如唯识言无违教失。有义彼说理不应然。曾无处言缘触等故。应言此意但缘彼识见及相分。如次执为我及我所。相见俱以识为体故。不违圣说。有义此说亦不应理。五色根境非识蕴故。应同五识亦缘外故。应如意识缘共境故。应生无色者不执我所故。厌色生彼不变色故。应说此意但缘藏识及彼种子。如次执为我及我所。以种即是彼识功能非实有物不违圣教。有义前说皆不应理。色等种子非识蕴故。论说种子是实有故。假应如无非因缘故。又此识俱萨迦耶见任运一类恒相续生。何容别执有我我所。无一心中有断常等二境别执俱转义故。亦不应说二执前后。此无始来一味转故。应知此意但缘藏识见分。非余。彼无始来一类相续似常一故。恒与诸法为所依故。此唯执彼为自内我。乘语势故说我所言。或此执彼是我之我。故于一见义说二言。若作是说善顺教理。多处唯言有我见故。我我所执不俱起故。未转依位唯缘藏识。既转依已亦缘真如及余诸法。平等性智证得十种平等性故。知诸有情胜解差别示现种种佛影像故。此中且说未转依时。故但说此缘彼藏识。悟迷通局理应尔故。无我我境遍不遍故。如何此识缘自所依。如有后识即缘前意。彼既极成此亦何咎。颂言思量为性相者。双显此识自性行相。意以思量为自性故。即复用彼为行相故。由斯兼释所立别名。能审思量名末那故。未转依位恒审思量所执我相。已转依位亦审思量无我相故

此意相应有几心所。且与四种烦恼常俱。此中俱言显相应义。谓从无始至未转依此意任运恒缘藏识与四根本烦恼相应。其四者何。谓我痴我见并我慢我爱。是名四种。我痴者谓无明。愚于我相迷无我理故名我痴。我见者谓我执。于非我法妄计为我。故名我见。我慢者谓倨傲。恃所执我令心高举。故名我慢。我爱者谓我贪。于所执我深生耽着。故名我爱。并表慢爱有见慢俱。遮余部执无相应义。此四常起扰浊内心令外转识恒成杂染。有情由此生死轮回不能出离。故名烦恼。彼有十种此何唯四。有我见故余见不生。无一心中有二慧故。如何此识要有我见。二取邪见但分别生唯见所断。此俱烦恼唯是俱生修所断故。我所边见依我见生。此相应见不依彼起。恒内执有我故要有我见。由见审决疑无容起。爱着我故嗔不得生。故此识俱烦恼唯四。见慢爱三如何俱起。行相无违俱起何失

瑜伽论说贪令心下慢令心举。宁不相违。分别俱生外境内境所陵所恃粗细有殊故。彼此文义无乖返。此意心所唯有四耶。不尔。及余触等俱故。有义此意心所唯九。前四及余触等五法。即触作意受想与思。意与遍行定相应故。前说触等异熟识俱。恐谓同前亦是无覆。显此异彼故置余言及是义集。前四后五合与末那恒相应故。此意何故无余心所。谓欲希望未遂合事。此识任运缘遂合境。无所希望故无有欲。胜解印持曾未定境。此识无始恒缘定事。经所印持故无胜解。念唯记忆曾所习事。此识恒缘现所受境无所记忆。故无有念。定唯系心专注一境。此识任运刹那别缘。既不专一故无有定。慧即我见故不别说。善是净故非此识俱。随烦恼生必依烦恼前后分位差别建立。此识恒与四烦恼俱。前后一类分位无别。故此识俱无随烦恼。恶作追悔先所造业。此识任运恒缘现境。非悔先业故无恶作。睡眠必依身心重昧外众缘力有时暂起。此识无始一类内执不假外缘故彼非有。寻伺俱依外门而转。浅深推度粗细发言。此识唯依内门而转。一类执我故非彼俱。有义彼释余义非理。颂别说此有覆摄故。又阙意俱随烦恼故。烦恼必与随烦恼俱。故此余言显随烦恼。此中有义五随烦恼。遍与一切染心相应。如集论说。惛沉掉举不信懈怠放逸于一切染污品中恒共相应。若离无堪任性等染污性成无是处故。烦恼起时心既染污。故染心位必有彼五。烦恼若起必由无堪任嚣动不信懈怠放逸故。掉举虽遍一切染心。而贪位增但说贪分。如眠与悔虽遍三性心。而痴位增但说为痴分。虽余处说有随烦恼或六或十遍诸染心。而彼俱依别义说遍。非彼实遍一切染心。谓依二十随烦恼中解通粗细无记不善通障定慧相显说六。依二十二随烦恼中解通粗细二性说十。故此彼说非互相违。然此意俱心所十五。谓前九法五随烦恼并别境慧。我见虽是别境慧摄。而五十一心所法中义有差别。故开为二。何缘此意无余心所。谓忿等十行相粗动。此识审细故非彼俱。无惭无愧唯是不善。此无记故非彼相应。散乱令心驰流外境。此恒内执一类境生。不外驰流故彼非有。不正知者。谓起外门身语意行违越轨则。此唯内执故非彼俱。无余心所义如前说。有义应说六随烦恼遍与一切染心相应。瑜伽论说不信懈怠放逸忘念散乱恶慧一切染心皆相应故。忘念散乱恶慧若无。心必不能起诸烦恼。要缘曾受境界种类。发起忘念及邪简择。方起贪等诸烦恼故。烦恼起时心必流荡。皆由于境起散乱故。惛沉掉举行相互违。非诸染心皆能遍起。论说五法遍染心者。解通粗细违唯善法。纯随烦恼通二性故。说十遍言义如前说。然此意俱心所十九。谓前九法六随烦恼。并念定慧及加惛沈。此别说念

准前慧释。并有定者。专注一类所执我境曾不舍故。加惛沈者。谓此识俱无明尤重心惛沈故。无掉举者此相违故。无余心所如上应知。有义复说十随烦恼遍与一切染心相应。瑜伽论说放逸．掉举．惛沈．不信．懈怠．邪欲．邪胜解．邪念．散乱．不正知。此十一切染污心起。通一切处三界系故。若无邪欲邪胜解时。心必不能起诸烦恼。于所受境要乐合离。印持事相方起贪等诸烦恼故。诸疑理者于色等事必无犹豫。故疑相应亦有胜解。于所缘事亦犹豫者。非烦恼疑。如疑人杌。余处不说此二遍者。缘非爱事疑相应心邪欲胜解非粗显故。余互有无义如前说。此意心所有二十四。谓前九法十随烦恼加别境五。准前理释。无余心所如上应知。有义前说皆未尽理。且疑他世为有为无。于彼有何欲胜解相。烦恼起位若无惛沈应不定有无堪任性。掉举若无应无嚣动。便如善等非染污位。若染心中无散乱者。应非流荡非染污心。若无失念不正知者。如何能起烦恼现前。故染污心决定皆与八随烦恼相应而生。谓惛沉掉举不信懈怠放逸忘念散乱不正知。忘念不正知念慧为性者不遍染心。非诸染心皆缘曾受有简择故。若以无明为自性者。遍染心起由前说故。然此意俱心所十八。谓前九法八随烦恼并别境慧。无余心所及论三文。准前应释。若作是说不违理教

成唯识论卷第四成唯识论卷第五

        护法等菩萨造

        三藏法师玄奘奉　诏译

此染污意何受相应。有义此俱唯有喜受。恒内执我生喜爱故。有义不然。应许喜受乃至有顶。违圣言故。应说此意四受相应。谓生恶趣忧受相应。缘不善业所引果故。生人欲天初二静虑喜受相应。缘有喜地善业果故。第三静虑乐受相应。缘有乐地善业果故。第四静虑乃至有顶舍受相应。缘唯舍地善业果故。有义彼说亦不应理。此无始来任运一类缘内执我恒无转易。与变异受不相应故。又此末那与前藏识。义有异者皆别说之。若四受俱亦应别说。既不别说定与彼同。故此相应唯有舍受。未转依位与前所说心所相应。已转依位唯二十一心所俱起。谓遍行别境各五善十一。如第八识已转依位。唯舍受俱任运转故。恒于所缘平等转故。末那心所何性所摄。有覆无记所摄。非余。此意相应四烦恼等是染法故。障碍圣道隐蔽自心。说名有覆。非善不善故名无记。如上二界诸烦恼等。定力摄藏是无记摄。此俱染法所依细故任运转故亦无记摄。若已转依唯是善性。末那心所何地系耶。随彼所生彼地所系。谓生欲界现行末那相应心所即欲界系。乃至有顶应知亦然。任运恒缘自地藏识。执为内我非他地故。若起彼地异熟藏识。现在前者名生彼地。染污末耶缘彼执我。即系属彼名彼所系。或为彼地诸烦恼等之所系缚名彼所系。若已转依即非所系

此染污意无始相续。何位永断或暂断耶。阿罗汉灭定出世道无有。阿罗汉者总显三乘无学果位。此位染意种及现行俱永断灭。故说无有。学位灭定出世道中俱暂伏灭。故说无有。谓染污意无始时来微细一类任运而转。诸有漏道不能伏灭。三乘圣道有伏灭义。真无我解违我执故。后得无漏现在前时。是彼等流亦违此意。真无我解及后所得。俱无漏故名出世道。灭定既是圣道等流。极寂静故此亦非有。由未永断此种子故。从灭尽定圣道起已。此复现行乃至未灭。然此染意相应烦恼。是俱生故非见所断。是染污故非非所断。极微细故所有种子。与有顶地下下烦恼。一时顿断势力等故。金刚喻定现在前时。顿断此种成阿罗汉。故无学位永不复起。二乘无学回趣大乘。从初发心至未成佛。虽实是菩萨亦名阿罗汉。应义等故不别说之。此中有义末那唯有烦恼障俱。圣教皆言三位无故。又说四惑恒相应故。又说为识杂染依故。有义彼说教理相违。出世末那经说有故。无染意识如有染时定有俱生不共依故。论说藏识决定恒与一识俱转。所谓末那。意识起时则二俱转。所谓意识及与末那。若五识中随起一识则三俱转。乃至或时顿起五识则七俱转。若住灭定无第七识。尔时藏识应无识俱。便非恒定一识俱转。住圣道时若无第七。尔时藏识应一识俱。如何可言若起意识。尔时藏识定二俱转。显扬论说。末那恒与四烦恼相应。或翻彼相应恃举为行。或平等行。故知此意通染不染。若由论说阿罗汉位无染意故便无第七。应由论说阿罗汉位舍赖耶故便无第八。彼既不尔。此云何然。又诸论言转第七识得平等智。彼如余智定有所依相应净识。此识无者彼智应无。非离所依有能依故。不可说彼依六转识。许佛恒行如镜智故。又无学位若无第七识。彼第八识应无俱有依。然必有此依。如余识性故。又如未证补特伽罗无我者彼我执恒行。亦应未证法无我者法我执恒行。此识若无彼依何识。非依第八彼无慧故。由此应信二乘圣道灭定无学此识恒行。彼未证得法无我故。又诸论中以五同法证有第七为第六依。圣道起时及无学位。若无第七为第六依。所立宗因便俱有失。或应五识亦有无依。五恒有依六亦应尔。是故定有无染污意。于上三位恒起现前。言彼无有者依染意说。如说四位无阿赖耶非无第八。此亦应尔

此意差别略有三种。一补特伽罗我见相应。二法我见相应。三平等性智相应。初通一切异生相续。二乘有学。七地以前一类菩萨有漏心位。彼缘阿赖耶识。起补特伽罗我见。次通一切异生声闻独觉相续。一切菩萨法空智果不现前位。彼缘异熟识起法我见。后通一切如来相续。菩萨见道及修道中法空智果现在前位。彼缘无垢异熟识等起平等性智。补特伽罗我见起位。彼法我见亦必现前。我执必依法执而起。如夜迷杌等方谓人等故。我法二见用虽有别而不相违。同依一慧。如眼识等体虽是一而有了别青等多用不相违故。此亦应然。二乘有学圣道灭定现在前时。顿悟菩萨于修道位。有学渐悟。生空智果现在前时。皆唯起法执。我执已伏故。二乘无学及此渐悟法空智果不现前时。亦唯起法执我执已断故。八地以上一切菩萨。所有我执皆永不行。或已永断或永伏故。法空智果不现前时。犹起法执不相违故。如契经说八地以上一切烦恼不复现行。唯有所依所知障在。此所知障是现非种。不尔烦恼亦应在故。法执俱意于二乘等虽名不染。于诸菩萨亦名为染。障彼智故。由此亦名有覆无记。于二乘等说名无覆。不障彼智故。是异熟生摄。从异熟识恒时生故名异熟生。非异熟果。此名通故。如增上缘余不摄者皆入此摄。云何应知此第七识离眼等识有别自体。圣教正理为定量故。谓薄伽梵处处经中说心意识三种别义。集起名心。思量名意。了别名识。是三别义。如是三义虽通八识而随胜显第八名心。集诸法种起诸法故。第七名意。缘藏识等恒审思量为我等故。余六名识。于六别境粗动间断了别转故。如入楞伽伽他中说

  藏识说名心　　思量性名意
  能了诸境相　　是说名为识

又大乘经处处别说有第七识故此别有。诸大乘经是至教量。前已广说故不重成。解脱经中亦别说有此第七识。如彼颂言

  染污意恒时　　诸惑俱生灭
  若解脱诸惑　　非曾非当有

彼经自释此颂义言。有染污意从无始来。与四烦恼恒俱生灭。谓我见我爱及我慢我痴。对治道生断烦恼已。此意从彼便得解脱。尔时此意相应烦恼。非唯现无亦无过未。过去未来无自性故。如是等教诸部皆有。恐厌广文故不繁述

已引圣教当显正理。谓契经说不共无明微细恒行覆蔽真实。若无此识彼应非有。谓诸异生于一切分恒起迷理不共无明覆真实义障圣慧眼。如伽他说

  真义心当生　　常能为障碍
  俱行一切分　　谓不共无明

是故契经说。异生类恒处长夜无明所盲惛醉缠心曾无醒觉。若异生位有暂不起此无明时。便违经义。俱异生位迷理无明有行不行不应理故。此依六识皆不得成。应此间断彼恒染。故许有末那便无此失。染意恒与四惑相应。此俱无明何名不共。有义此俱我见慢爱非根本烦恼。名不共何失。有义彼说理教相违。纯随烦恼中不说此三故。此三六十烦恼摄故。处处皆说染污末那与四烦恼恒相应故。应说四中无明是主。虽三俱起亦名不共。从无始际恒内惛迷曾不省察。痴增上故。此俱见等应名相应。若为主时应名不共。如无明故许亦无失。有义此痴名不共者如不共佛法。唯此识有故。若尔余识相应烦恼此识中无应名不共。依殊胜义立不共名。非互所无皆名不共。谓第七识相应无明。无始恒行障真义智。如是胜用余识所无。唯此识有故名不共。既尔此俱三亦应名不共。无明是主独得此名。或许余三亦名不共。对余痴故且说无明。不共无明总有二种。一恒行不共。余识所无。二独行不共。此识非有。故瑜伽说。无明有二。若贪等俱者名相应无明。非贪等俱者名独行无明。是主独行唯见所断。如契经说。诸圣有学不共无明已永断故不造新业。非主独行亦修所断。忿等皆通见修所断故。恒行不共余部所无。独行不共此彼俱有。又契经说。眼色为缘生于眼识。广说乃至意法为缘生于意识。若无此识彼意非有。谓如五识必有眼等增上不共俱有所依。意识既是六识中摄。理应许有如是所依。此识若无彼依宁有。不可说色为彼所依。意非色故。意识应无随念计度二分别故。亦不可说五识无有俱有所依。彼与五根俱时而转如牙影故。又识与根既必同境。如心心所决定俱时。由此理趣极成意识。如眼等识必有不共显自名处等无间不摄增上所依。极成六识随一摄故

又契经说。思量名意。若无此识彼应非有。谓若意识现在前时。等无间意已灭非有。过去未来理非有故。彼思量用定不得成。既尔如何说名为意。若谓假说。理亦不然。无正思量假依何立。若谓现在曾有思量。尔时名识宁说为意。故知别有第七末那。恒审思量正名为意。已灭依此假立意名。又契经说。无想灭定染意若无彼应无别。谓彼二定俱灭六识及彼心所。体数无异。若无染意于二定中一有一无。彼二何别。若谓加行界地依等有差别者。理亦不然。彼差别因由此有故。此若无者彼因亦无。是故定应别有此意。又契经说。无想有情一期生中心心所灭。若无此识彼应无染。谓彼长时无六转识。若无此意我执便无。非于余处有具缚者一期生中都无我执。彼无我执应如涅槃便非圣贤同所诃厌。初后有故无如是失。中间长时无故有过。去来有故无如是失。彼非现常无故有过。所得无故能得亦无。不相应法前已遮破。藏识无故熏习亦无。余法受熏已辩非理。故应别有染污末那于无想天恒起我执。由斯贤圣同诃厌彼。又契经说。异生善染无记心时恒带我执。若无此识彼不应有。谓异生类三性心时。虽外起诸业而内恒执我。由执我故令六识中所起施等不能亡相。故瑜伽说。染污末那为识依止。彼未灭时相了别缚不得解脱。末那灭已相缚解脱。言相缚者谓于境相不能了达如幻事等。由斯见分相分所拘不得自在。故名相缚。依如是义有伽他言

  如是染污意　　是识之所依
  此意未灭时　　识缚终不脱

又善无覆无记心时。若无我执应非有漏。自相续中六识烦恼与彼善等不俱起故。去来缘缚理非有故。非由他惑成有漏故。勿由他解成无漏故。又不可说别有随眠是不相应现相续起。由斯善等成有漏法。彼非实有已极成故。亦不可说从有漏种生彼善等故成有漏。彼种先无因可成有漏故。非由漏种彼成有漏。勿学无漏心亦成有漏故。虽由烦恼引施等业。而不俱起故非有漏正因。以有漏言表漏俱故。又无记业非烦恼引。彼复如何得成有漏。然诸有漏由与自身现行烦恼俱生俱灭互相增益方成有漏。由此熏成有漏法种。后时现起有漏义成。异生既然有学亦尔。无学有漏虽非漏俱。而从先时有漏种起。故成有漏于理无违。由有末那恒起我执。令善等法有漏义成。此意若无彼定非有。故知别有此第七识。证有此识理趣甚多。随摄大乘略述六种。诸有智者应随信学。然有经中说六识者。应知彼是随转理门。或随所依六根说六。而识类别实有八种。如是已说第二能变。第三能变其相云何。颂曰

  ８次第三能变　　差别有六种
  了境为性相　　善不善俱非

论曰。次中思量能变识。后应辩了境能变识相。此识差别总有六种。随六根境种类异故。谓名眼识乃至意识。随根立名具五义故。五谓依发属助如根。虽六识身皆依意转。然随不共立意识名。如五识身无相滥过。或唯依意故名意识。辩识得名心意非例。或名色识乃至法识。随境立名顺识义故。谓于六境了别名识。色等五识唯了色等。法识通能了一切法。或能了别法独得法识名。故六识名无相滥失。此后随境立六识名。依五色根未自在说。若得自在诸根互用。一根发识缘一切境。但可随根无相滥失。庄严论说如来五根一一皆于五境转者。且依粗显同类境说。佛地经说。成所作智决择有情心行差别。起三业化作四记等。若不遍缘无此能故。然六转识所依所缘粗显极成。故此不说。前随义便已说所依。此所缘境义便当说。次言了境为性相者。双显六识自性行相。识以了境为自性故。即复用彼为行相故。由斯兼释所立别名。能了别境名为识故。如契经说眼识云何。谓依眼根了别诸色。广说乃至意识云何。谓依意根了别诸法。彼经且说不共所依未转依位见分所了。余所依了如前已说。此六转识何性摄耶。谓善不善俱非性摄。俱非者谓无记。非善不善故名俱非。能为此世他世顺益故名为善。人天乐果虽于此世能为顺益非于他世。故不名善。能为此世他世违损。故名不善。恶趣苦果虽于此世能为违损非于他世。故非不善。于善不善益损义中不可记别。故名无记。此六转识若与信等十一相应是善性摄。与无惭等十法相应不善性摄。俱不相应无记性摄。有义六识三性不俱。同外门转互相违故。五识必由意识导引俱生同境成善染故。若许五识三性俱行。意识尔时应通三性。便违正理故定不俱。瑜伽等说藏识一时与转识相应三性俱起者。彼依多念。如说一心非一生灭无相违过。有义六识三性容俱。率尔等流眼等五识。或多或少容俱起故。五识与意虽定俱生。而善性等不必同故。前所设难于此唐捐。故瑜伽说。若遇声缘从定起者。与定相应意识俱转余耳识生。非唯彼定相应意识能取此声。若不尔者于此音声不领受故不应出定。非取声时即便出定。领受声已若有希望后时方出。在定耳识率尔闻声理应非善。未转依者率尔堕心定无记故。由此诚证五俱意识非定与五善等性同。诸处但言五俱意识亦缘五境不说同性。杂集论说等引位中五识无者。依多分说。若五识中三性俱转。意随偏注与彼性同。无偏注者便无记性。故六转识三性容俱。得自在位唯善性摄。佛色心等道谛摄故。已永灭除戏论种故。六识与几心所相应。颂曰

  ９此心所遍行　　别境善烦恼
  随烦恼不定　　皆三受相应

论曰。此六转识总与六位心所相应。谓遍行等。恒依心起与心相应。系属于心故名心所。如属我物立我所名。心于所缘唯取总相。心所于彼亦取别相。助成心事得心所名。如画师资作模填彩。故瑜伽说。识能了别事之总相。作意了此所未了相。即诸心所所取别相。触能了此可意等相。受能了此摄受等相。想能了此言说因相。思能了此正因等相。故作意等名心所法。此表心所亦缘总相。余处复说。欲亦能了可乐事相。胜解亦了决定事相。念亦能了串习事相。定慧亦了德失等相。由此于境起善染等。诸心所法皆于所缘兼取别相

虽诸心所名义无异而有六位种类差别。谓遍行有五。别境亦五。善有十一。烦恼有六。随烦恼有二十。不定有四。如是六位合五十一。一切心中定可得故。缘别别境而得生故。唯善心中可得生故。性是根本烦恼摄故。唯是烦恼等流性故。于善染等皆不定故。然瑜伽论合六为五。烦恼随烦恼俱是染故。复以四一切辩五差别。谓一切性及地时俱。五中遍行具四一切。别境唯有初二一切。善唯有一。谓一切地。染四皆无。不定唯一。谓一切性。由此五位种类差别。此六转识易脱不定。故皆容与三受相应。皆领顺违非二相故。领顺境相适悦身心说名乐受。领违境相逼迫身心说名苦受。领中容境相于身于心非逼非悦名不苦乐受。如是三受或各分二。五识相应说名身受。别依身故。意识相应说名心受。唯依心故。又三皆通有漏无漏。苦受亦由无漏起故。或各分三。谓见所断修所断非所断

又学无学非二为三。或总分四。谓善不善有覆无覆二无记受。有义三受容各分四。五识俱起任运贪痴。纯苦趣中任运烦恼。不发业者是无记故。彼皆容与苦根相应。瑜伽论说。若任运生一切烦恼。皆于三受现行可得。若通一切识身者。遍与一切根相应。不通一切识身者。意地一切根相应。杂集论说。若欲界系任运烦恼发恶行者亦是不善。所余皆是有覆无记。故知三受各容有四。或总分五。谓苦乐忧喜舍。三中苦乐各分二者。逼悦身心相各异故。由无分别有分别故。尤重轻微有差别故。不苦不乐不分二者。非逼非悦相无异故。无分别故。平等转故。诸适悦受五识相应恒名为乐。意识相应。若在欲界初二静虑近分名喜。但悦心故。若在初二静虑根本名乐名喜。悦身心故。若在第三静虑近分根本名乐。安静尤重无分别故。诸逼迫受五识相应恒名为苦。意识俱者有义唯忧。逼迫心故。诸圣教说意地戚受名忧根故。瑜伽论说。生地狱中诸有情类。异熟无间有异熟生苦忧相续。又说地狱寻伺忧俱。一分鬼趣傍生亦尔。故知意地尤重戚受尚名为忧。况余轻者。有义通二。人天中者恒名为忧。非尤重故。傍生鬼界名忧名苦。杂受纯受有轻重故。奈落迦中唯名为苦。纯受尤重无分别故

瑜伽论说。若任运生一切烦恼皆于三受现行可得。广说如前。又说俱生萨迦耶见唯无记性。彼边执见应知亦尔。此俱苦受非忧根摄。论说忧根非无记故。又瑜伽说。地狱诸根余三现行定不成就。纯苦鬼界傍生亦尔。余三定是乐喜忧根。以彼必成现行舍故。岂不客舍彼定不成。宁知彼文唯说客受。应不说彼定成意根。彼六客识有时无故。不应彼论唯说客受通说意根。无异因故。又若彼论依客受说。如何说彼定成八根。若谓五识不相续故定说忧根为第八者。死生闷绝宁有忧根。有执苦根为第八者。亦同此破。设执一形为第八者理亦不然。形不定故。彼恶业招容无形故。彼由恶业令五根门恒受苦故。定成眼等。必有一形于彼何用。非于无间大地狱中可有希求淫欲事故。由斯第八定是舍根。第七八识舍相应故。如极乐地意悦名乐无有喜根。故极苦处意迫名苦无有忧根。故余三言定忧喜乐。余处说彼有等流乐。应知彼依随转理说。或彼通说余杂受处。无异熟乐名纯苦故。然诸圣教意地戚受名忧根者。依多分说。或随转门。无相违过。瑜伽论说生地狱中诸有情类异熟无间有异熟生苦忧相续。又说地狱寻伺忧俱。一分鬼趣傍生亦尔者。亦依随转门

又彼苦根意识俱者。是余忧类。假说为忧。或彼苦根损身心故。虽苦根摄而亦名忧。如近分喜益身心故。虽是喜根而亦名乐。显扬论等具显此义。然未至地定无乐根。说彼唯有十一根故。由此应知。意地戚受纯受苦处亦苦根摄。此等圣教差别多门。恐文增广故不繁述。有义六识三受不俱。皆外门转互相违故。五俱意识同五所缘。五三受俱意亦应尔。便违正理故必不俱。瑜伽等说藏识一时与转识相应三受俱起者。彼依多念。如说一心非一生灭。无相违过。有义六识三受容俱。顺违中境容俱受故。意不定与五受同故。于偏注境起一受故无偏注者便起舍故。由斯六识三受容俱。得自在位唯乐喜舍。诸佛已断忧苦事故。前所略摽六位心所。今应广显彼差别相。且初二位其相云何。颂曰

  １０初遍行触等　　次别境谓欲
      胜解念定慧　　所缘事不同

论曰。六位中初遍行心所即触等五。如前广说。此遍行相云何应知。由教及理为定量故。此中教者如契经言。眼色为缘生于眼识。三和合触。与触俱生有受想思。乃至广说。由斯触等四是遍行

又契经说。若根不坏境界现前。作意正起方能生识。余经复言。若于此作意即于此了别。若于此了别即于此作意。是故此二恒共和合。乃至广说。由此作意亦是遍行。此等圣教诚证非一。理谓识起必有三和。彼定生触必由触有。若无触者心心所法应不和合触一境故。作意引心令趣自境。此若无者心应无故。受能领纳顺违中境。令心等起欢戚舍相。无心起时无随一故。想能安立自境分齐。若心起时无此想者。应不能取境分齐相。思令心取正因等相造作善等。无心起位无此随一故必有思。由此证知触等五法心起必有。故是遍行。余非遍行义至当说。次别境者。谓欲至慧所缘境事多分不同。于六位中次初说故。云何为欲。于所乐境希望为性。勤依为业。有义所乐谓可欣境。于可欣事欲见闻等有希望故。于可厌事希彼不合。望彼别离岂非有欲。此但求彼不合离时可欣自体非可厌事。故于可厌及中容境一向无欲。缘可欣事若不希望亦无欲起。有义所乐谓所求境。于可欣厌求合离等有希望故。于中容境一向无欲。缘欣厌事若不希求亦无欲起。有义所乐谓欲观境。于一切事欲观察者有希望故。若不欲观随因境势任运缘者即全无欲。由斯理趣欲非遍行。有说要由希望境力诸心心所方取所缘。故经说欲为诸法本。彼说不然。心等取境由作意故。诸圣教说作意现前能生识故。曾无处说由欲能生心心所故。如说诸法爱为根本。岂心心所皆由爱生。故说欲为诸法本者。说欲所起一切事业。或说善欲能发正勤。由彼助成一切善事。故论说此勤依为业。云何胜解。于决定境印持为性。不可引转为业。谓邪正等教理证力于所取境审决印持。由此异缘不能引转。故犹豫境胜解全无。非审决心亦无胜解。由斯胜解非遍行摄。有说心等取自境时无拘碍故皆有胜解。彼说非理。所以者何。能不碍者即诸法故。所不碍者即心等故。胜发起者根作意故。若由此故彼胜发起。此应复待余便有无穷失。云何为念。于曾习境令心明记不忘为性。定依为业。谓数忆持曾所受境令不忘失能引定故。于曾未受体类境中全不起念。设曾所受不能明记念亦不生。故念必非遍行所摄。有说心起必有念俱。能为后时忆念因故。彼说非理。勿于后时有痴信等前亦有故。前心心所或想势力足为后时忆念因故。云何为定。于所观境令心专注不散为性。智依为业。谓观德失俱非境中。由定令心专注不散。依斯便有决择智生。心专注言显所欲住即便能住。非唯一境。不尔见道历观诸谛前后境别应无等持。若不系心专注境位便无定起。故非遍行。有说尔时亦有定起。但相微隐。应说诚言。若定能令心等和合同趣一境故是遍行。理亦不然。是触用故。若谓此定令刹那顷心不易缘故遍行摄。亦不应理。一刹那心自于所缘无易义故。若言由定心取所缘故遍行摄。彼亦非理。作意令心取所缘故。有说此定体即是心。经说为心学心一境性故。彼非诚证。依定摄心令心一境说彼言故。根力觉支道支等摄。如念慧等非即心故。云何为慧。于所观境简择为性。断疑为业。谓观德失俱非境中。由慧推求得决定故。于非观境愚昧心中无简择故非遍行摄。有说尔时亦有慧起。但相微隐。天爱宁知。对法说为大地法故。诸部对法展转相违。汝等如何执为定量。唯触等五经说遍行。说十非经。不应固执。然欲等五非触等故定非遍行。如信贪等。有义此五定互相资。随一起时必有余四。有义不定。瑜伽说此四一切中无后二故。又说此五缘四境生。所缘能缘非定俱故。应说此五或时起一。谓于所乐唯起希望。或于决定唯起印解。或于曾习唯起忆念。或于所观唯起专注。谓愚昧类为止散心。虽专注所缘而不能简择。世共知彼有定无慧。彼加行位少有闻思。故说等持缘所观境。或依多分故说是言。如戏忘天专注一境起贪嗔等。有定无慧。诸如是等其类实繁。或于所观唯起简择。谓不专注驰散推求。或时起二。谓于所乐决定境中起欲胜解。或于所乐曾习境中起欲及念。如是乃至于所观境起定及慧。合有十二。或时起三。谓于所乐决定曾习起欲解念。如是乃至于曾所观起念定慧。合有十三。或时起四。谓于所乐决定曾习所观境中起前四种。如是乃至于定曾习所观境中起后四种。合有五四。或时起五。谓于所乐决定曾习所观境中具起五种。如是于四起欲等五。总别合有三十一句。或有心位五皆不起。如非四境率尔堕心及藏识俱。此类非一。第七八识此别境五随位有无。如前已说。第六意识诸位容俱。依转未转皆不遮故。有义五识此五皆无。缘已得境无希望故。不能审决无印持故。恒取新境无追忆故。自性散动无专注故。不能推度无简择故。有义五识容有此五。虽无于境增上希望。而有微劣乐境义故。于境虽无增上审决。而有微劣印境义故。虽无明记曾习境体。而有微劣念境类故。虽不作意系念一境。而有微劣专注义故。遮等引故说性散动。非遮等持。故容有定。虽于所缘不能推度。而有微劣简择义故。由此圣教说眼耳通是眼耳识相应智性。余三准此有慧无失。未自在位此五或无。得自在时此五定有。乐观诸境欲无减故。印境胜解常无减故。忆习曾受念无减故。又佛五识缘三世故。如来无有不定心故。五识皆有作事智故。此别境五何受相应。有义欲三除忧苦受。以彼二境非所乐故。余四通四。唯除苦受。以审决等五识无故。有义一切五受相应。论说忧根于无上法思慕愁戚求欲证故。纯受苦处希求解脱。意有苦根前已说故。论说贪爱忧苦相应。此贪爱俱必有欲故。苦根既有意识相应。审决等四苦俱何咎。又五识俱亦有微细印境等四。义如前说。由斯欲等五受相应。此五复依性界学等。诸门分别如理应思

成唯识论卷第五成唯识论卷第六

        护法等菩萨造

        三藏法师玄奘奉　诏译

已说遍行别境二位。善位心所其相云何。颂曰

  １１善谓信惭愧　　无贪等三根
      勤安不放逸　　行舍及不害

论曰。唯善心俱名善心所。谓信惭等定有十一。云何为信。于实德能深忍乐欲心净为性。对治不信乐善为业。然信差别略有三种。一信实有。谓于诸法实事理中深信忍故。二信有德。谓于三宝真净德中深信乐故。三信有能。谓于一切世出世善深信有力能得能成起希望故。由斯对治彼不信心。爱乐证修世出世善。忍谓胜解。此即信因。乐欲谓欲即是信果。礭陈此信自相是何。岂不适言。心净为性。此犹未了彼心净言。若净即心应非心所。若令心净惭等何别。心俱净法为难亦然。此性澄清能净心等。以心胜故立心净名。如水清珠能清浊水。惭等虽善非净为相。此净为相无滥彼失。又诸染法各别有相。唯有不信自相浑浊。复能浑浊余心心所。如极秽物自秽秽他。信正翻彼故净为相。有说信者爱乐为相。应通三性体应即欲。又应苦集非信所缘。有执信者随顺为相。应通三性。即胜解欲。若印顺者即胜解故。若乐顺者即是欲故。离彼二体无顺相故。由此应知心净是信。云何为惭。依自法力崇重贤善为性。对治无惭止息恶行为业。谓依自法尊贵增上。崇重贤善羞耻过恶。对治无惭息诸恶行。云何为愧。依世间力轻拒暴恶为性。对治无愧止息恶行为业。谓依世间诃厌增上。轻拒暴恶羞耻过罪。对治无愧息诸恶业。羞耻过恶是二通相。故诸圣教假说为体。若执羞耻为二别相。应惭与愧体无差别。则此二法定不相应。非受想等有此义故。若待自他立二别者。应非实有便违圣教。若许惭愧实而别起。复违论说十遍善心。崇重轻拒若二别相。所缘有异应不俱生。二失既同何乃偏责。谁言二法所缘有异。不尔如何。善心起时随缘何境。皆有崇重善及轻拒恶义。故惭与愧俱遍善心所缘无别。岂不我说亦有此义。汝执惭愧自相既同。何理能遮前所设难。然圣教说顾自他者。自法名自世间名他。或即此中崇拒善恶。于己益损名自他故。无贪等者等无嗔痴。此三名根生善胜故。三不善根近对治故。云何无贪。于有有具无著为性。对治贪著作善为业。云何无嗔。于苦苦具无恚为性。对治嗔恚作善为业。善心起时随缘何境。皆于有等无著无恚。观有等立非要缘彼。如前惭愧观善恶立。故此二种俱遍善心。云何无痴。于诸理事明解为性。对治愚痴作善为业。有义无痴即慧为性。集论说此报教证智决择为体。生得闻思修所生慧。如次皆是决择性故。此虽即慧为显善品有胜功能。如烦恼见故复别说。有义无痴非即是慧。别有自性。正对无明如无贪嗔。善根摄故。论说大悲无嗔痴摄非根摄故。若彼无痴以慧为性。大悲如力等应慧等根摄。又若无痴无别自性。如不害等应非实物。便违论说十一善中三世俗有余皆是实。然集论说慧为体者。举彼因果显此自性。如以忍乐表信自体。理必应尔。以贪嗔痴六识相应。正烦恼摄起恶胜故立不善根。断彼必由通别对治。通唯善慧。别即三根。由此无痴必应别有。勤谓精进。于善恶品修断事中勇悍为性。对治懈怠满善为业。勇表胜进简诸染法。悍表精纯简净无记。即显精进唯善性摄。此相差别略有五种。所谓被甲加行无下无退无足。即经所说有势有勤有勇坚猛不舍善轭。如次应知。此五别者。谓初发心自分胜进。自分行中三品别故。或初发心长时无间殷重无余修差别故。或资粮等五道别故。二乘究竟道欣大菩提故。诸佛究竟道乐利乐他故。或二加行无间解脱胜进别故。安谓轻安。远离粗重调畅身心堪任为性。对治惛沈转依为业。谓此伏除能障定法令所依止转安适故。不放逸者精进三根。于所断修防修为性。对治放逸成满一切世出世间善事为业。谓即四法于断修事皆能防修名不放逸。非别有体。无异相故。于防恶事修善事中。离四功能无别用故。虽信惭等亦有此能。而方彼四势用微劣。非根遍策故非此依。岂不防修是此相用。防修何异精进三根。彼要待此方有作用。此应复待余便有无穷失。勤唯遍策。根但为依。如何说彼有防修用。汝防修用其相云何。若普依持即无贪等。若遍策录不异精进。止恶进善即总四法。令不散乱应是等持。令同取境与触何别。令不忘失即应是念。如是推寻不放逸用。离无贪等竟不可得。故不放逸定无别体。云何行舍。精进三根令心平等正直无功用住为性。对治掉举静住为业。谓即四法令心远离掉举等障静住名舍。平等正直无功用住。初中后位辩舍差别。由不放逸先除杂染。舍复令心寂静而住。此无别体如不放逸。离彼四法无相用故。能令寂静即四法故。所令寂静即心等故。云何不害。于诸有情不为损恼无嗔为性。能对治害悲愍为业。谓即无嗔于有情所不为损恼假名不害。无嗔翻对断物命嗔。不害正违损恼物害。无嗔与乐不害拔苦。是谓此二粗相差别。理实无嗔实有自体。不害依彼一分假立。为显慈悲二相别故。利乐有情彼二胜故。有说不害非即无嗔别有自体。谓贤善性。此相云何。谓不损恼。无嗔亦尔。宁别有性。谓于有情不为损恼慈悲贤善是无嗔故。及显十一义别心所。谓欣厌等善心所法。虽义有别说种种名。而体无异故不别立。欣谓欲俱无嗔一分。于所欣境不憎恚故。不忿恨恼嫉等亦然。随应正翻嗔一分故。厌谓慧俱无贪一分。于所厌境不染着故。不悭憍等当知亦然。随应正翻贪一分故。不覆诳谄无贪痴一分。随应正翻贪痴一分故。有义不覆唯无痴一分。无处说覆亦贪一分故。有义不慢信一分摄。谓若信彼不慢彼故。有义不慢舍一分摄。心平等者不高慢故。有义不慢惭一分摄。若崇重彼不慢彼故。有义不疑即信所摄。谓若信彼无犹豫故。有义不疑即正胜解。以决定者无犹豫故。有义不疑即正慧摄。以正见者无犹豫故。不散乱体即正定摄。正见正知俱善慧摄。不忘念者即是正念。悔眠寻伺通染不染。如触欲等无别翻对。何缘诸染所翻善中有别建立有不尔者。相用别者便别立之。余善不然故不应责。又诸染法遍六识者。胜故翻之别立善法。慢等忿等唯意识俱。害虽亦然。而数现起损恼他故。障无上乘胜因悲故。为了知彼增上过失。翻立不害。失念散乱及不正知。翻入别境。善中不说。染净相翻净宁少染。净胜染劣少敌多故。又解理通说多同体。迷情事局随相分多。故于染净不应齐责。此十一法。三是假有。谓不放逸舍及不害。义如前说。余八实有相用别故。有义十一。四遍善心。精进三根遍善品故。余七不定。推寻事理未决定时不生信故。惭愧同类依处各别。随起一时第二无故。要世间道断烦恼时有轻安故。不放逸舍无漏道时方得起故。悲愍有情时乃有不害故。论说十一六位中起。谓决定位有信相应。止息染时有惭愧起。顾自他故。于善品位有精进三根。世间道时有轻安起。于出世道有舍不放逸。摄众生时有不害故。有义彼说未为应理。推寻事理未决定。心信若不生应非是善。如染心等无净信故。惭愧类异。依别境同。俱遍善心前已说故。若出世道轻安不生。应此觉支非无漏故。若世间道无舍不放逸。应非寂静防恶修善故。又应不伏掉放逸故。有漏善心既具四法。如出世道。应有二故。善心起时皆不损物。违能损法有不害故。论说六位起十一者。依彼彼增作此此说故。彼所说定非应理。应说信等十一法中。十遍善心。轻安不遍。要在定位方有轻安。调畅身心余位无故。决择分说十善心所定不定地皆遍善心。定地心中增轻安故。有义定加行亦得定地名。彼亦微有调畅义故。由斯欲界亦有轻安。不尔便违本地分说信等十一通一切地。有义轻安唯在定有。由定滋养有调畅故。论说欲界诸心心所。由阙轻安名不定地。说一切地有十一者。通有寻伺等三地皆有故。此十一种前已具说第七八识随位有无。第六识中定位皆具。若非定位唯阙轻安。有义五识唯有十种。自性散动无轻安故。有义五识亦有轻安。定所引善者亦有调畅故。成所作智俱必有轻安故。此善十一何受相应。十五相应。一除忧苦。有逼迫受无调畅故。此与别境皆得相应。信等欲等不相违故。十一唯善。轻安非欲。余通三界。皆学等三。非见所断。瑜伽论说信等六根唯修所断非见所断。余门分别如理应思。如是已说善位心所。烦恼心所其相云何。颂曰

  １２烦恼谓贪嗔　　痴慢疑恶见

论曰。此贪等六性是根本烦恼摄故。得烦恼名。云何为贪。于有有具染着为性。能障无贪生苦为业。谓由爱力取蕴生故。云何为嗔于苦苦具憎恚为性。能障无嗔不安隐性恶行所依为业。谓嗔必令身心热恼起诸恶业。不善性故。云何为痴。于诸理事迷闇为性。能障无痴一切杂染所依为业。谓由无明起疑邪见贪等烦恼随烦恼业。能招后生杂染法故。云何为慢。恃己于他高举为性。能障不慢生苦为业。谓若有慢于德有德心不谦下。由此生死轮转无穷受诸苦故。此慢差别有七九种。谓于三品我德处生。一切皆通见修所断。圣位我慢既得现行。慢类由斯起亦无失。云何为疑于诸谛理犹豫为性。能障不疑善品为业。谓犹豫者善不生故。有义此疑以慧为体。犹豫简择说为疑故。毗助末底是疑义故。末底般若义无异故。有义此疑别有自体。令慧不决。非即慧故。瑜伽论说六烦恼中见世俗有。即慧分故。余是实有。别有性故。毗助末底执慧为疑。毗助若南智应为识。界由助力义便转变。是故此疑非慧为体。云何恶见。于诸谛理颠倒推求度染慧为性。能障善见招苦为业。谓恶见者多受苦故。此见行相差别有五。一萨迦耶见。谓于五取蕴执我我所。一切见趣所依为业。此见差别有二十句六十五等。分别起摄。二边执见。谓即于彼随执断常。障处中行出离为业。此见差别诸见趣中有执前际四遍常论一分常论。及计后际有想十六无想俱非各有八论。七断灭论等。分别趣摄。三邪见。谓谤因果作用实事。及非四见诸余邪执。如增上缘名义遍故。此见差别诸见趣中有执前际二无因论四有边等不死矫乱。及计后际五现涅槃。或计自在世主释梵及余物类常恒不易。或计自在等是一切物因。或有横计诸邪解脱。或有妄执非道为道。诸如是等皆邪见摄。四见取。谓于诸见及所依蕴。执为最胜能得清净。一切斗诤所依为业。五戒禁取。谓于随顺诸见戒禁及所依蕴。执为最胜能得清净。无利勤苦所依为业。然有处说执为最胜名为见取。执能得净名戒取者。是影略说。或随转门。不尔如何非灭计灭非道计道说为邪见。非二取摄

如是总别十烦恼中。六通俱生及分别起。任运思察俱得生故。疑后三见唯分别起。要由恶友或邪教力自审思察方得生故。边执见中通俱生者。有义唯断。常见相粗恶友等力方引生故。瑜伽等说。何边执见是俱生耶。谓断见摄。学现观者起如是怖。今者我我何所在耶。故禽兽等若遇违缘皆恐我断而起惊怖。有义彼论依粗相说。理实俱生亦通常见。谓禽兽等执我常存。炽然聚集长时资具。故显扬等诸论。皆说于五取蕴执断计常。或是俱生或分别起。此十烦恼谁几相应。贪与嗔痴定不俱起。爱憎二境必不同故。于境不决无染着故。贪与慢见或得相应。所爱所陵境非一故说不俱起。所染所恃境可同故说得相应。于五见境皆可爱故。贪与五见相应无失。嗔与慢疑或得俱起。所嗔所恃境非一故说不相应。所蔑所憎境可同故说得俱起。初犹豫时未憎彼故说不俱起。久思不决便愤发故说得相应。疑顺违事随应亦尔。嗔与二取必不相应。执为胜道不憎彼故。此与三见或得相应。于有乐蕴起身常见。不生憎故说不相应。于有苦蕴起身常见。生憎恚故说得俱起。断见翻此说嗔有无。邪见诽拨恶事好事。如次说嗔或无或有。慢于境定疑则不然。故慢与疑无相应义。慢与五见皆容俱起。行相展转不相违故。然与断见必不俱生。执我断时无陵恃故。与身邪见一分亦尔。疑不审决与见相违。故疑与见定不俱起。五见展转必不相应。非一心中有多慧故。痴与九种皆定相应。诸烦恼生必由痴故。此十烦恼何识相应。藏识全无末那有四。意识具十。五识唯三。谓贪嗔痴。无分别故。由称量等起慢等故。此十烦恼何受相应。贪嗔痴三俱生分别。一切容与五受相应。贪会违缘忧苦俱故。嗔遇顺境喜乐俱故。有义俱生分别起慢。容与非苦四受相应。恃苦劣蕴忧相应故

有义俱生亦苦俱起。意有苦受前已说故。分别慢等纯苦趣无。彼无邪师邪教等故。然彼不造引恶趣业。要分别起能发彼故。疑后三见容四受俱。欲疑无苦等亦喜受俱故。二取若缘忧俱见等。尔时得与忧相应故

有义俱生身边二见但与喜乐舍受相应。非五识俱。唯无记故。分别二见容四受俱。执苦俱蕴为我我所常。断见翻此与忧相应故

有义二见若俱生者。亦苦受俱。纯受苦处缘极苦蕴苦相应故。论说俱生一切烦恼皆于三受现行可得。广说如前。余如前说。此依实义。随粗相者贪慢四见乐喜舍俱。嗔唯苦忧舍受俱起。痴与五受皆得相应。邪见及疑四俱除苦。贪痴俱乐通下四地。余七俱乐除欲通三。疑独行痴欲唯忧舍。余受俱起如理应知。此与别境几互相应。贪嗔痴慢容五俱起。专注一境得有定故。疑及五见各容四俱。疑除胜解不决定故。见非慧俱不异慧故。此十烦恼何性所摄。嗔唯不善损自他故。余九通二。上二界者唯无记摄。定所伏故。若欲界系分别起者。唯不善摄。发恶行故。若是俱生。发恶行者亦不善摄。损自他故。余无记摄。细不障善。非极损恼自他处故。当知俱生身边二见。唯无记摄不发恶业。虽数现起不障善故。此十烦恼何界系耶。嗔唯在欲。余通三界。生在下地未离下染。上地烦恼不现在前。要得彼地根本定者。彼地烦恼容现前故。谓有漏道虽不能伏分别起惑及细俱生。而能伏除俱生粗惑。渐次证得上根本定。彼但迷事。依外门转。散乱粗动正障定故。得彼定已彼地分别俱生诸惑皆容现前。生在上地下地诸惑分别俱生皆容现起。生第四定中有中者。由谤解脱生地狱故。身在上地将生下时。起下润生俱生爱故。而言生上不起下者。依多分说。或随转门。下地烦恼亦缘上地。瑜伽等说欲界系贪求上地生味上定故。既说嗔恚憎嫉灭道。亦应憎嫉离欲地故。总缘诸行执我我所断常慢者得缘上故。余五缘上其理极成。而有处言贪嗔慢等不缘上者。依粗相说。或依别缘。不见世间执他地法为我等故。边见必依身见起故。上地烦恼亦缘下地。说生上者于下有情恃己胜德而陵彼故总缘诸行执我我所断常爱者得缘下故。疑后三见如理应思。而说上或不缘下者。彼依多分。或别缘说。此十烦恼学等何摄。非学无学彼唯善故。此十烦恼何所断耶。非非所断彼非染故。分别起者唯见所断粗易断故。若俱生者唯修所断细难断故。见所断十实俱顿断。以真见道总缘谛故。然迷谛相有总有别。总谓十种皆迷四谛。苦集是彼因依处故。灭道是彼怖畏处故。别谓别迷四谛相起。二唯迷苦八通迷四。身边二见唯果处起。别空非我属苦谛故。谓疑三见亲迷苦理。二取执彼三见戒禁及所依蕴为胜能净。于自他见及彼眷属。如次随应起贪恚慢。相应无明与九同迷。不共无明亲迷苦理。疑及邪见亲迷集等。二取贪等准苦应知。然嗔亦能亲迷灭道。由怖畏彼生憎嫉故。迷谛亲疏粗相如是。委细说者贪嗔慢三见疑俱生随应如彼。俱生二见及彼相应爱慢无明。虽迷苦谛细难断故修道方断。嗔余爱等迷别事生不违谛观故修所断。虽诸烦恼皆有相分。而所仗质或有或无。名缘有事无事烦恼。彼亲所缘虽皆有漏。而所仗质亦通无漏。名缘有漏无漏烦恼。缘自地者相分似质。名缘分别所起事境。缘灭道谛及他地者相分与质不相似故。名缘分别所起名境。余门分别如理应思。已说根本六烦恼相。诸随烦恼其相云何。颂曰

      随烦恼谓忿　　恨覆恼嫉悭
  １３诳谄与害憍　　无惭及无愧
      掉举与惛沈　　不信并懈怠
  １４放逸及失念　　散乱不正知

论曰。唯是烦恼分位差别。等流性故名随烦恼。此二十种类别有三。谓忿等十各别起故名小随烦恼。无惭等二遍不善故名中随烦恼。掉举等八遍染心故名大随烦恼。云何为忿。依对现前不饶益境愤发为性。能障不忿执仗为业。谓怀忿者多发暴恶身表业故。此即嗔恚一分为体。离嗔无别忿相用故。云何为恨。由忿为先怀恶不舍结怨为性。能障不恨热恼为业。谓结恨者不能含忍恒热恼故。此亦嗔恚一分为体。离嗔无别恨相用故。云何为覆。于自作罪恐失利誉隐藏为性。能障不覆悔恼为业。谓覆罪者后必悔恼不安隐故。有义此覆痴一分摄。论唯说此痴一分故。不惧当苦覆自罪故。有义此覆贪痴一分摄。亦恐失利誉覆自罪故。论据粗显唯说痴分。如说掉举是贪分故。然说掉举遍诸染心。不可执为唯是贪分。云何为恼。忿恨为先追触暴热佷戾为性。能障不恼蛆螫为业。谓追往恶触现违缘心便佷戾。多发嚣暴凶鄙粗言蛆螫他故。此亦嗔恚一分为体。离嗔无别恼相用故。云何为嫉。徇自名利不耐他荣妒忌为性。能障不嫉忧戚为业。谓嫉妒者闻见他荣深怀忧戚不安隐故。此亦嗔恚一分为体。离嗔无别嫉相用故。云何为悭。耽着财法不能慧舍秘吝为性。能障不悭鄙畜为业。谓悭吝者心多鄙涩畜积财法不能舍故。此即贪爱一分为体。离贪无别悭相用故。云何为诳。为获利誉矫现有德诡诈为性。能障不诳邪命为业。谓矫诳者心怀异谋多现不实邪命事故。此即贪痴一分为体。离二无别诳相用故。云何为谄。为网他故矫设异仪险曲为性。能障不谄教诲为业。谓谄曲者为网帽他曲顺时宜矫设方便为取他意或藏己失。不任师友正教诲故。此亦贪痴一分为体。离二无别谄相用故。云何为害。于诸有情心无悲愍损恼为性。能障不害逼恼为业。谓有害者逼恼他故。此亦嗔恚一分为体。离嗔无别害相用故。嗔害别相准善应说。云何为憍。于自盛事深生染着醉傲为性。能障不憍染依为业。谓憍醉者生长一切杂染法故。此亦贪爱一分为体。离贪无别憍相用故。云何无惭。不顾自法轻拒贤善为性。能障碍惭生长恶行为业。谓于自法无所顾者轻拒贤善不耻过恶。障惭生长诸恶行故。云何无愧。不顾世间崇重暴恶为性。能障碍愧生长恶行为业。谓于世间无所顾者崇重暴恶不耻过罪。障愧生长诸恶行故。不耻过恶是二通相。故诸圣教假说为体。若执不耻为二别相则应此二体无差别。由斯二法应不俱生。非受想等有此义故。若待自他立二别者应非实有。便违圣教。若许此二实而别起复违论说俱遍恶心。不善心时随缘何境皆有轻拒善及崇重恶义故。此二法俱遍恶心。所缘不异无别起失。然诸圣教说不顾自他者。自法名自世间名他。或即此中拒善崇恶。于己益损名自他故。而论说为贪等分者。是彼等流非即彼性。云何掉举。令心于境不寂静为性。能障行舍奢摩他为业。有义掉举贪一分摄。论唯说此是贪分故。此由忆昔乐事生故。有义掉举非唯贪摄。论说掉举遍染心故。又掉举相谓不寂静。说是烦恼共相摄故。掉举离此无别相故。虽依一切烦恼假立。而贪位增说为贪分。有义掉举别有自性。遍诸染心如不信等非说他分体便非实。勿不信等亦假有故。而论说为世俗有者。如睡眠等随他相说。掉举别相谓即嚣动。令俱生法不寂静故。若离烦恼无别此相不应别说障奢摩他。故不寂静非此别相。云何惛沈。令心于境无堪任为性。能障轻安毗钵舍那为业。有义惛沈痴一分摄。论唯说此是痴分故。惛昧沉重是痴相故。有义惛沈非但痴摄。谓无堪任是惛沈相。一切烦恼皆无堪任。离此无别惛沈相故。虽依一切烦恼假立而痴相增但说痴分

有义惛沈别有自性。虽名痴分而是等流。如不信等非即痴摄。随他相说名世俗有。如睡眠等是实有性。惛沈别相。谓即瞢重。令俱生法无堪任故。若离烦恼无别惛沈相。不应别说障毗钵舍那。故无堪任非此别相。此与痴相有差别者。谓痴于境迷闇为相。正障无痴而非瞢重。惛沈于境瞢重为相。正障轻安而非迷闇。云何不信。于实德能不忍乐欲心秽为性。能障净信惰依为业。谓不信者多懈怠故。不信三相翻信应知。然诸染法各有别相。唯此不信自相浑浊。复能浑浊余心心所。如极秽物自秽秽他。是故说此心秽为性。由不信故于实德能不忍乐欲。非别有性。若于余事邪忍乐欲是此因果。非此自性。云何懈怠。于善恶品修断事中懒惰为性。能障精进增染为业。谓懈怠者滋长染故。于诸染事而策勤者亦名懈怠。退善法故。于无记事而策勤者于诸善品无进退故是欲胜解。非别有性。如于无记忍可乐欲非净非染无信不信。云何放逸。于染净品不能防修纵荡为性。障不放逸增恶损善所依为业。谓由懈怠及贪嗔痴不能防修染净品法。总名放逸。非别有体。虽慢疑等亦有此能。而方彼四势用微劣障三善根遍策法故。推究此相如不放逸。云何失念。于诸所缘不能明记为性。能障正念散乱所依为业。谓失念者心散乱故

有义失念念一分摄。说是烦恼相应念故。有义失念痴一分摄。瑜伽说此是痴分故。痴令念失故名失念。有义失念俱一分摄。由前二文影略说故。论复说此遍染心故。云何散乱。于诸所缘令心流荡为性。能障正定恶慧所依为业。谓散乱者发恶慧故

有义散乱痴一分摄。瑜伽说此是痴分故。有义散乱贪嗔痴摄。集论等说是三分故。说痴分者遍染心故。谓贪嗔痴令心流荡胜余法故说为散乱

有义散乱别有自体。说三分者是彼等流。如无惭等非即彼摄。随他相说名世俗有。散乱别相谓即躁扰。令俱生法皆流荡故。若离彼三无别自体。不应别说障三摩地。掉举散乱二用何别。彼令易解此令易缘。虽一刹那解缘无易。而于相续有易义故。染污心时由掉乱力常应念念易解易缘。或由念等力所制伏如系猿猴。有暂时住故。掉与乱俱遍染心。云何不正知。于所观境谬解为性。能障正知毁犯为业。谓不正知者多所毁犯故

有义不正知慧一分摄。说是烦恼相应慧故。有义不正知痴一分摄。瑜伽说此是痴分故。令知不正名不正知。有义不正知俱一分摄。由前二文影略说故。论复说此遍染心故。与并及言显随烦恼非唯二十。杂事等说贪等多种随烦恼故。随烦恼名亦摄烦恼。是前烦恼等流性故。烦恼同类余染污法但名随烦恼。非烦恼摄故。唯说二十随烦恼者谓非烦恼。唯染粗故。此余染法或此分位或此等流。皆此所摄随其类别如理应知。如是二十随烦恼中。小十大三定是假有。无惭无愧不信懈怠定是实有。教理成故。掉举惛沈散乱三种

有义是假。有义是实。所引理教如前应知。二十皆通俱生分别。随二烦恼势力起故。此二十中小十展转定不俱起。互相违故。行相粗猛各为主故。中二一切不善心俱。随应皆得小大俱起。论说大八遍诸染心。展转小中皆容俱起。有处说六遍染心者惛掉增时不俱起故。有处但说五遍染者以惛掉等违唯善故。此唯染故非第八俱。第七识中唯有大八。取舍差别如上应知。第六识俱容有一切。小十粗猛五识中无。中大相通五识容有。由斯中大五受相应。有我小十除三。忿等唯喜忧舍三受相应。谄诳憍三四俱除苦

有义忿等四俱除乐。谄诳憍三五受俱起。意有苦受前已说故。此受俱相如烦恼说。实义如是若随粗相忿恨恼嫉害忧舍俱。覆悭喜舍余三增乐。中大随粗亦如实义。如是二十与别境五皆容俱起不相违故。染念染慧虽非念慧俱。而痴分者亦得相应故。念亦缘现曾习类境。忿亦得缘刹那过去故。忿与念亦得相应。染定起时心亦躁扰。故乱与定相应无失。中二大八十烦恼俱。小十定非见疑俱起。此相粗动彼审细故。忿等五法容慢痴俱。非贪恚并是嗔分故。悭痴慢俱非贪嗔并是贪分故。憍唯痴俱。与慢解别是贪分故。覆诳与谄贪痴慢俱。行相无违贪痴分故。小七中二唯不善摄。小三大八亦通无记。小七中二唯欲界摄。诳谄欲色。余通三界。生在下地容起上十一。耽定于他起憍诳谄故。若生上地起下后十。邪见爱俱容起彼故。小十生上无由起下。非正润生及谤灭故。中二大八下亦缘上。上缘贪等相应起故

有义小十下不缘上。行相粗近不远取故。有义嫉等亦得缘上。于胜地法生嫉等故。大八谄诳上亦缘下。下缘慢等相应起故。梵于释子起谄诳故。憍不缘下非所恃故。二十皆非学无学摄。此但是染彼唯净故。后十唯通见修所断。与二烦恼相应起故。见所断者随迷谛相或总或别烦恼俱生。故随所应皆通四谛。迷谛亲疏等皆如烦恼说。前十有义唯修所断。缘粗事境任运生故

有义亦通见修所断。依二烦恼势力起故。缘他见等生忿等故。见所断者随所应缘总别惑力皆通四谛。此中有义忿等但缘迷谛惑生非亲迷谛。行相粗浅不深取故

有义嫉等亦亲迷谛。于灭道等生嫉等故。然忿等十但缘有事。要记本质方得生故。缘有漏等准上应知

成唯识论卷第六成唯识论卷第七

        护法等菩萨造

        三藏法师玄奘奉　诏译

已说二十随烦恼相。不定有四。其相云何。颂曰

  不定谓悔眠　　寻伺二各二

论曰。悔眠寻伺于善染等皆不定故。非如触等定遍心故。非如欲等定遍地故。立不定名。悔谓恶作。恶所作业追悔为性。障止为业。此即于果假立因名。先恶所作业后方追悔故。悔先不作亦恶所摄。如追悔言我先不作如是事业。是我恶作。眠谓睡眠。令身不自在昧略为性。障观为业。谓睡眠位身不自在心极闇劣。一门转故。昧简在定。略别寤时。令显睡眠非无体用。有无心位假立此名。如余盖缠心相应故。有义此二唯痴为体。说随烦恼及痴分故。有义不然亦通善故。应说此二染痴为体。净即无痴。论依染分说随烦恼及痴分摄。有义此说亦不应理。无记非痴无痴性故。应说恶作思慧为体。明了思择所作业故。睡眠合用思想为体。思想种种梦境相故。论俱说为世俗有故。彼染污者是痴等流。如不信等说为痴分。有义彼说理亦不然。非思慧想缠彼性故。应说此二各别有体。与余心所行相别故。随痴相说名世俗有。寻谓寻求。令心匆遽于意言境粗转为性。伺谓伺察。令心匆遽于意言境细转为性。此二俱以安不安住身心分位所依为业。并用思慧一分为体。于意言境不深推度及深推度义类别故。若离思慧寻伺二种体类差别不可得故。二各二者。有义寻伺各有染净二类差别。有义此释不应正理。悔眠亦有染净二故。应说如前诸染心所有是烦恼随烦恼性。此二各有不善无记。或复各有缠及随眠。有义彼释亦不应理。不定四后有此言故。应言二者显二种二。一谓悔眠。二谓寻伺。此二二种种类各别。故一二言显二二种。此各有二。谓染不染。非如善染各唯一故。或唯简染故说此言。有亦说为随烦恼故。为显不定义说二各二言。故置此言深为有用

四中寻伺定是假有。思慧合成圣所说故。悔眠有义亦是假有。瑜伽说为世俗有故有义此二是实物有。唯后二种说假有故。世俗有言随他相说非显前二定是假有。又如内种体虽是实而论亦说世俗有故。四中寻伺定不相应。体类是同粗细异故。依于寻伺有染离染立三地别。不依彼种现起有无故无杂乱。俱与前二容互相应。前二亦有互相应义。四皆不与第七八俱。义如前说。悔眠唯与第六识俱非五法故。有义寻伺亦五识俱。论说五识有寻伺故。又说寻伺即七分别谓有相等。杂集复言。任运分别谓五识故。有义寻伺唯意识俱。论说寻求伺察等法皆是意识不共法故。又说寻伺忧喜相应曾不说与苦乐俱故。舍受遍故可不待说。何缘不说与苦乐俱。虽初静虑有意地乐。而不离喜总说喜名。虽纯苦处有意地苦。而似忧故总说为忧。又说寻伺以名身等义为所缘。非五识身以名身等义为境故。然说五识有寻伺者。显多由彼起非说彼相应。杂集所言任运分别谓五识者。彼与瑜伽所说分别义各有异。彼说任运即是五识。瑜伽说此是五识俱分别意识相应寻伺。故彼所引为证不成。由此五识定无寻伺。有义恶作忧舍相应。唯戚行转通无记故。睡眠喜忧舍受俱起。行通欢戚中庸转故。寻伺忧喜舍乐相应。初静虑中意乐俱故。有义此四亦苦受俱。纯苦趣中意若俱故。四皆容与五别境俱。行相所缘不相违故。悔眠但与十善容俱。此唯在欲无轻安故。寻伺容与十一善俱。初静虑中轻安俱故。悔但容与无明相应。此行相粗贪等细故。睡眠寻伺十烦恼俱。此彼展转不相违故。悔与中大随惑容俱。非忿等十各为主故。睡眠寻伺二十容俱。眠等位中皆起彼故。此四皆通善等三性。于无记业亦追悔故。有义初二唯生得善。行相粗鄙及昧略故。后二亦通加行善摄。闻所成等有寻伺故。有义初二亦加行善。闻思位中有悔眠故。后三皆通染净无记。恶作非染解粗猛故。四无记中悔唯中二。行相粗猛非定果故。眠除第四非定引生。异熟生心亦得眠故。寻伺除初彼解微劣不能寻察名等义故。恶作睡眠唯欲界有。寻伺在欲及初静虑。余界地法皆妙静故。悔眠生上必不现起。寻伺上下亦起下上。下上寻伺能缘上下。有义悔眠不能缘上。行相粗近极昧略故。有义此二亦缘上境。有邪见者悔修定故。梦能普缘所更事故。悔非无学离欲舍故。睡眠寻伺皆通三种。求解脱者有为善法皆名学故。学究竟者有为善法皆无学故。悔眠唯通见修所断。亦邪见等势力起故。非无漏道亲所引生故。亦非如忧深求解脱故。若已断故名非所断。则无学眠非所断摄。寻伺虽非真无漏道。而能引彼从彼引生故通见修非所断摄。有义寻伺非所断者。于五法中唯分别摄。瑜伽说彼是分别故。有义此二亦正智摄。说正思惟是无漏故。彼能令心寻求等故。又说彼是言说因故。未究竟位于药病等未能遍知。后得智中为他说法必假寻伺。非如佛地无功用说。故此二种亦通无漏。虽说寻伺必是分别。而不定说唯属第三。后得正智中亦有分别故。余门准上如理应思

如是六位诸心所法。为离心体有别自性。为即是心分位差别。设尔何失。二俱有过。若离心体有别自性。如何圣教说唯有识。又如何说心远独行。染净由心。士夫六界。庄严论说复云何通。如彼颂言

  许心似二现　　如是似贪等
  或似于信等　　无别染善法

若即是心分位差别。如何圣教说心相应。他性相应非自性故。又如何说心与心所俱时而起如日与光。瑜伽论说复云何通。彼说心所非即心故。如彼颂言

  五种性不成　　分位差过失
  因缘无别故　　与圣教相违

应说离心有别自性。以心胜故说唯识等。心所依心。势力生故说似彼现。非彼即心。又识心言亦摄心所。恒相应故。唯识等言及现似彼皆无有失。此依世俗。若依胜义心所与心非离非即。诸识相望应知亦然。是谓大乘真俗妙理。已说六识心所相应。云何应知现起分位。颂曰

  １５依止根本识　　五识随缘现
      或俱或不俱　　如涛波依水
  １６意识常现起　　除生无想天
      及无心二定　　睡眠与闷绝

论曰。根本识者阿陀那识。染净诸识生根本故。依止者谓前六转识。以根本识为共亲依。五识者谓前五转识。种类相似故总说之。随缘现言显非常起。缘谓作意根境等缘。谓五识身内依本识。外随作意五根境等众缘和合方得现前。由此或俱或不俱起。外缘合者有顿渐故。如水涛波随缘多少。此等法喻广说如经。由五转识行相粗动。所籍众缘时多不俱。故起时少不起时多。第六意识虽亦粗动。而所籍缘无时不具。由违缘故有时不起。第七八识行相微细。所籍众缘一切时有。故无缘碍令总不行。又五识身不能思虑。唯外门转起籍多缘。故断时多现行时少。第六意识自能思虑。内外门转不籍多缘。唯除五位常能现起。故断时少现起时多。由斯不说此随缘现。五位者何。生无想等。无想天者谓修彼定厌粗想力生彼天中违不恒行心及心所想灭为首。名无想天。故六转识于彼皆断。有义彼天常无六识。圣教说彼无转识故。说彼唯有有色支故。又说彼为无心地故。有义彼天将命终位。要起转识然后命终。彼必起下润生爱故。瑜伽论说后想生已是诸有情从彼没故。然说彼无转识等者。依长时说。非谓全无。有义生时亦有转识。彼中有必起润生烦恼故。如余本有初必有转识故。瑜伽论说。若生于彼唯入不起。其想若生从彼没故。彼本有初若无转识如何名入。先有后无乃名入故。决择分言所有生得心心所灭名无想故。此言意显彼本有初有异熟生转识暂起。宿因缘力后不复生。由斯引起异熟无记分位差别。说名无想。如善引生二定名善。不尔转识一切不行。如何可言唯生得灭。故彼初位转识暂起。彼天唯在第四静虑。下想粗动难可断故。上无无想异熟处故。即能引发无想定思。能感彼天异熟果故。及无心二定者。谓无想灭尽定。俱无六识故名无心。无想定者。谓有异生伏遍净贪未伏上染。由出离想作意为先。令不恒行心心所灭想灭为首。立无想名。令身安和故亦名定。修习此定品别有三。下品修者现法必退。不能速疾还引现前。后生彼天不甚光净形色广大。定当中夭。中品修者现不必退。设退速疾还引现前。后生彼天虽甚光净形色广大而不最极。虽有中夭而不决定。上品修者现必不退。后生彼天最极光净形色广大。必无中夭。穷满寿量后方殒没。此定唯属第四静虑。又唯是善。彼所引故。下上地无由前说故。四业通三。除顺现受。有义此定唯欲界起。由诸外道说力起故。人中慧解极猛利故。有义欲界先修习已。后生色界能引现前。除无想天至究竟故。此由厌想欣彼果入故唯有漏。非圣所起。灭尽定者。谓有无学。或有学圣。已伏或离无所有贪上贪不定。由止息想作意为先。令不恒行恒行染污心心所灭立灭尽名。令身安和故亦名定。由偏厌受想亦名灭彼定。修习此定品别有三。下品修者现法必退。不能速疾还引现前。中品修者现不必退。设退速疾还引现前。上品修者毕竟不退。此定初修必依有顶游观无漏为加行入。次第定中最居后故。虽属有顶而无漏摄。若修此定已得自在。余地心后亦得现前。虽属道谛而是非学非无学摄。似涅槃故。此定初起唯在人中。佛及弟子说力起故。人中慧解极猛利故。后上二界亦得现前。邬陀夷经是此诚证。无色亦名意成天故。于藏识教未信受者。若生无色不起此定。恐无色心成断灭故。已信生彼亦得现前。知有藏识不断灭故。要断三界见所断惑方起此定。异生不能伏灭有顶心心所故。此定微妙要证二空。随应后得所引发故。有义下八地修所断惑中。要全断欲余伏或断。然后方能初起此定。欲界惑种二性繁杂障定强故。唯说不还三乘无学及诸菩萨得此定故。彼随所应生上八地皆得后起。有义要断下之四地修所断惑。余伏或断。然后方能初起此定。变异受俱烦恼种子障定强故。彼随所应生上五地皆得后起。若伏下惑能起此定。后不断退生上地者。岂生上已却断下惑。断亦无失。如生上者断下末那得生惑故。然不还者对治力强。正润生位不起烦恼。但由惑种润上地生。虽所伏惑有退不退。而无伏下生上地义。故无生上却断下失。若诸菩萨先二乘位已得灭定后回心者。一切位中能起此定。若不尔者或有乃至七地满心方能永伏一切烦恼。虽未永断欲界修惑。而如已断能起此定。论说已入远地菩萨方能现起灭尽定故。有从初地即能永伏一切烦恼如阿罗汉。彼十地中皆起此定。经说菩萨前六地中亦能现起灭尽定故。无心睡眠与闷绝者。谓有极重睡眠闷绝令前六识皆不现行。疲极等缘所引身位违前六识故名极重睡眠。此睡眠时虽无彼体。而由彼似彼。故假说彼名。风热等缘所引身位亦违六识。故名极重闷绝。或此俱是触处少分。除斯五位意识恒起。正死生时亦无意识。何故但说五位不行。有义死生及与言显。彼说非理。所以者何。但说六时名无心故。谓前五位及无余依。应说死生即闷绝摄。彼是最极闷绝位故。说及与言显五无杂。此显六识断已后时依本识中自种还起。由此不说入无余依。此五位中异生有四。除在灭定。圣唯后三。于中如来自在菩萨唯得存一。无睡闷故。是故八识一切有情心与末那二恒俱转。若起第六则三俱转。余随缘合起一至五。则四俱转乃至八俱。是谓略说识俱转义。若一有情多识俱转。如何说彼是一有情。若立有情依识多少。汝无心位应非有情。又他分心现在前位如何可说自分有情。然立有情依命根数或异熟识。俱不违理。彼俱恒时唯有一故。一身唯一等无间缘。如何俱时有多识转。既许此一引多心所。宁不许此能引多心。又谁定言此缘唯一。说多识俱者许此缘多故。又欲一时取多境者多境现前。宁不顿取。诸根境等和合力齐。识前后生不应理故。又心所性虽无差别。而类别者许多俱生。宁不许心异类俱起。又如浪像依一起多。故依一心多识俱转。又若不许意与五俱。取彼所缘应不明了。如散意识缘久灭故。如何五俱唯一意识。于色等境取一或多。如眼等识各于自境取一或多。此亦何失。相见俱有种种相故。何故诸识同类不俱。于自所缘若可了者一已能了。余无用故。若尔五识已了自境。何用俱起意识了为。五俱意识助五令起。非专为了五识所缘。又于彼所缘能明了取异于眼等识故非无用。由此圣教说彼意识名有分别。五识不尔。多识俱转何不相应。非同境故。设同境者彼此所依体数异故。如五根识互不相应。八识自性不可言定一。行相所依缘相应异故。又一灭时余不灭故。能所熏等相各异故。亦非定异。经说八识如水波等无差别故。定异应非因果性故。如幻事等无定性故。如前所说识差别相依理世俗非真胜义。真胜义中心言绝故。如伽他说

  心意识八种　　俗故相有别
  真故相无别　　相所相无故

已广分别三能变相为自所变二分所依。云何应知依识所变假说我法非别实有。由斯一切唯有识耶。颂曰

  １７是诸识转变　　分别所分别
      由此彼皆无　　故一切唯识

论曰。是诸识者。谓前所说三能变识及彼心所。皆能变似见相二分。立转变名。所变见分说名分别。能取相故。所变相分名所分别。见所取故。由此正理彼实我法离识所变皆定非有。离能所取无别物故。非有实物离二相故。是故一切有为无为若实若假皆不离识。唯言为遮离识实物。非不离识心所法等。或转变者。谓诸内识转似我法外境相现。此能转变即名分别。虚妄分别为自性故。谓即三界心及心所。此所执境名所分别。即所妄执实我法性。由此分别变似外境假我法相。彼所分别实我法性决定皆无。前引教理已广破故。是故一切皆唯有识。虚妄分别有极成故。唯既不遮不离识法。故真空等亦是有性。由斯远离增减二边。唯识义成契会中道。由何教理唯识义成。岂不已说。虽说未了。非破他义己义便成。应更礭陈成此教理。如契经说三界唯心。又说所缘唯识所现。又说诸法皆不离心。又说有情随心垢净。又说成就四智菩萨能随悟入唯识无境。一相违识相智。谓于一处鬼人天等随业差别所见各异。境若实有此云何成。二无所缘识智。谓缘过未梦境像等非实有境。识现可得彼境既无。余亦应尔。三自应无倒智。谓愚夫智若得实境。彼应自然成无颠倒。不由功用应得解脱。四随三智转智。一随自在者智转智。谓已证得心自在者随欲转变地等皆成。境若实有如何可变。二随观察者智转智。谓得胜定修法观者随观一境众相现前。境若是实宁随心转。三随无分别智转智。谓起证实无分别智一切境相皆不现前。境若是实何容不现。菩萨成就四智者。于唯识理决定悟入。又伽他说

  心意识所缘　　皆非离自性
  故我说一切　　唯有识无余

此等圣教诚证非一。极成眼等识五随一故如余不亲缘离自色等。余识识故如眼识等亦不亲缘离自诸法。此亲所缘定非离此。二随一故如彼能缘。所缘法故如相应法。决定不离心及心所。此等正理诚证非一。故于唯识应深信受。我法非有空识非无。离有离无故契中道。慈尊依此说二颂言

  虚妄分别有　　于此二都无
  此中唯有空　　于彼亦有此
  故说一切法　　非空非不空
  有无及有故　　是则契中道

此颂且依染依他说。理实亦有净分依他。若唯内识似外境起。宁见世间情非情物处时身用定不定转如梦境等。应释此疑。何缘世尊说十二处。依识所变非别实有。为入我空说六二法。如遮断见说续有情。为入法空复说唯识。令知外法亦非有故。此唯识性岂不亦空。不尔。如何。非所执故。谓依识变妄执实法理不可得说为法空。非无离言正智所证唯识性故说为法空。此识若无便无俗谛。俗谛无故真谛亦无。真俗相依而建立故。拨无二谛是恶取空。诸佛说为不可治者。应知诸法有空不空。由此慈尊说前二颂。若诸色处亦识为体。何缘乃似色相显现。一类坚住相续而转。名言熏习势力起故。与染净法为依处故。谓此若无应无颠倒。便无杂染亦无净法。是故诸识亦似色现。如有颂言

  乱相及乱体　　应许为色识
  及与非色识　　若无余亦无

色等外境分明现证。现量所得。宁拨为无。现量证时不执为外。后意分别妄生外想。故现量境是自相分。识所变故亦说为有。意识所执外实色等。妄计有故说彼为无。又色等境非色似色非外似外如梦所缘。不可执为是实外色。若觉时色皆如梦境不离识者。如从梦觉知彼唯心。何故觉时于自色境不知唯识。如梦未觉不能自知。要至觉时方能追觉。觉时境色应知亦尔。未真觉位不能自知。至真觉时亦能追觉。未得真觉恒处梦中。故佛说为生死长夜。由斯未了色境唯识。外色实无可非内识境。他心实有宁非自所缘。谁说他心非自识境。但不说彼是亲所缘。谓识生时无实作用。非如手等亲执外物日等舒光亲照外境。但如镜等似外境现名了他心。非亲能了。亲所了者谓自所变。故契经言。无有少法能取余法。但识生时似彼相现名取彼物。如缘他心色等亦尔。既有异境何名唯识。奇哉固执触处生疑。岂唯识教但说一识。不尔如何。汝应谛听。若唯一识宁有十方凡圣尊卑因果等别。谁为谁说。何法何求。故唯识言有深意趣。识言总显一切有情各有八识．六位心所．所变相见．分位差别及彼空理所显真如。识自相故。识相应故。二所变故。三分位故。四实性故。如是诸法皆不离识。总立识名。唯言但遮愚夫所执定离诸识实有色等。若如是知唯识教意。便能无倒善备资粮。速入法空证无上觉。救拔含识生死轮回。非全拨无恶取空者违背教理能成是事。故定应信一切唯识。若唯有识都无外缘。由何而生种种分别。颂曰

  １８由一切种识　　如是如是变
      以展转力故　　彼彼分别生

论曰。一切种识谓本识中能生自果功能差别。此生等流异熟士用增上果。故名一切种。除离系者非种生故。彼虽可证而非种果。要现起道断结得故。有展转义非此所说。此说能生分别种故。此识为体故立识名。种离本识无别性故。种识二言简非种识。有识非种种非识故。又种识言显识中种。非持种识。后当说故。此识中种余缘助故。即便如是如是转变。谓从生位转至熟时。显变种多重言如是。谓一切种摄三熏习共不共等识种尽故。展转力者谓八现识及彼相应相见分等。彼皆互有相助力故。即现识等总名分别。虚妄分别为自性故。分别类多故言彼彼。此颂意说。虽无外缘由本识中有一切种转变差别及以现行八种识等展转力故彼彼分别而亦得生。何假外缘方起分别。诸净法起应知亦然。净种现行为缘生故。所说种现缘生分别。云何应知此缘生相。缘且有四。一因缘。谓有为法亲办自果。此体有二。一种子。二现行。种子者谓本识中善染无记诸界地等功能差别。能引次后自类功能。及起同时自类现果。此唯望彼是因缘性。现行者谓七转识及彼相应所变相见性界地等。除佛果善极劣无记。余熏本识生自类种。此唯望彼是因缘性。第八心品无所熏故。非简所依独能熏故。极微圆故不熏成种。现行同类展转相望皆非因缘。自种生故。一切异类展转相望亦非因缘。不亲生故。有说异类同类现行展转相望为因缘者。应知假说。或随转门。有唯说种是因缘性。彼依显胜。非尽理说。圣说转识与阿赖耶展转相望为因缘故。二等无间缘。谓八现识及彼心所前聚于后自类无间等而开导令彼定生。多同类种俱时转故如不相应非此缘摄。由斯八识非互为缘。心所与心虽恒俱转。而相应故和合似一。不可施设离别殊异。故得互作等无间缘。入无余心最极微劣无开导用。又无当起等无间法故非此缘。云何知然。论有诚说。若此识等无间彼识等决定生。即说此是彼等无间缘故。即依此义应作是说。阿陀那识三界九地皆容互作等无间缘。下上死生相开等故。有漏无间有无漏生。无漏定无生有漏者。镜智起已必无断故。善与无记相望亦然。此何界后引生无漏。或从色界或欲界后。谓诸异生求佛果者定色界后引生无漏。彼必生在净居天上大自在宫得菩提故。二乘回趣大菩提者定欲界后引生无漏。回趣留身唯欲界故。彼虽必往大自在宫方得成佛。而本愿力所留生身是欲界故。有义色界亦有声闻回趣大乘愿留身者。既与教理俱不相违。是故声闻第八无漏色界心后亦得现前。然五净居无回趣者。经不说彼发大心故。第七转识三界九地亦容互作等无间缘。随第八识生处系故。有漏无漏容互相生。十地位中得相引故。善与无记相望亦然。于无记中染与不染亦相开导。生空智果前后位中得相引故。此欲色界有漏得与无漏相生。非无色界。地上菩萨不生彼故。第六转识三界九地有漏无漏善不善等各容互作等无间缘。润生位等更相引故。初起无漏唯色界后。决择分善唯色界故。眼耳身识二界二地鼻舌两识一界一地自类互作等无间缘。善等相望应知亦尔。有义五识有漏无漏自类互作等无间缘未成佛时容互起故。有义无漏有漏后起。非无漏后容起有漏。无漏五识非佛无故。彼五色根定有漏故。是异熟识相分摄故。有漏不共必俱同境根发无漏识理不相应故。此二于境明昧异故。三所缘缘。谓若有法是带己相心或相应所虑所托。此体有二。一亲二疏。若与能缘体不相离。是见分等内所虑托。应知彼是亲所缘缘。若与能缘体虽相离。为质能起内所虑托。应知彼是疏所缘缘。亲所缘缘能缘皆有。离内所虑托必不生故。疏所缘缘能缘或有。离外所虑托亦得生故。第八心品有义唯有亲所缘缘。随业因力任运变故。有义亦定有疏所缘缘。要仗他变质自方变故。有义二说俱不应理。自他身土可互受用。他所变者为自质故。自种于他无受用理。他变为此不应理故。非诸有情种皆等故。应说此品疏所缘缘一切位中有无不定。第七心品未转依位是俱生故必仗外质。故亦定有疏所缘缘。已转依位此非定有。缘真如等无外质故。第六心品行相猛利。于一切位能自在转。所仗外质或有或无。疏所缘缘有无不定。前五心品未转依位粗钝劣故必仗外质故亦定有疏所缘缘。已转依位此非定有缘过未等无外质故。四增上缘。谓若有法有胜势用能于余法或顺或违。虽前三缘亦是增上。而今第四除彼取余为显诸缘差别相故。此顺违用于四处转生位成得四事别故。然增上用随事虽多而胜显者唯二十二应知即是二十二根。前五色根以本识等所变眼等净色为性。男女二根身根所摄故即以彼少分为性。命根但依本识亲种分位假立非别有性。意根总以八识为性。五受根如应各自受为性。信等五根即以信等及善念等而为自性。未知当知根体位有三种。一根本位谓在见道除后刹那无所未知可当知故。二加行位。谓暖顶忍世第一法近能引发根本位故。三资粮位。谓从为得谛现观故发起决定胜善法欲。乃至未得顺决择分所有善根名资粮位。能远资生根本位故。于此三位信等五根意喜乐舍为此根性。加行等位于后胜法求证愁戚亦有忧根非正善根故多不说。前三无色有此根者有胜见道傍修得故。或二乘位回趣大者为证法空地前亦起九地所摄生空无漏。彼皆菩萨此根摄故。菩萨见道亦有此根但说地前以时促故。始从见道最后刹那乃至金刚喻定所有信等无漏九根皆是已知根性。未离欲者于上解脱求证愁戚。亦有忧根非正善根故多不说。诸无学位无漏九根一切皆是具知根性。有顶虽有游观无漏而不明利非后三根。二十二根自性如是。诸余门义如论应知

成唯识论卷第七成唯识论卷第八

        护法等菩萨造

        三藏法师玄奘奉　诏译

如是四缘依十五处义差别故立为十因。云何此依十五处立。一语依处。谓法名想所起语性。即依此处立随说因。谓依此语随见闻等说诸义故。此即能说为所说因。有论说此是名想见。由如名字取相执着随起说故。若依彼说便显此因是语依处。二领受依处。谓所观待能所受性。即依此处立观待因。谓观待此令彼诸事或生或住或成或得。此是彼观待因。三习气依处。谓内外种未成熟位。即依此处立牵引因。谓能牵引远自果故。四有润种子依处。谓内外种已成熟位。即依此处立生起因。谓能生起近自果故。五无间灭依处。谓心心所等无间缘。六境界依处。谓心心所所缘缘。七根依处。谓心心所所依六根。八作用依处。谓于所作业作具作用即除种子余助现缘。九士用依处。谓于所作业作者作用即除种子余作现缘。十真实见依处。谓无漏见除引自种于无漏法能助引证。总依此六立摄受因。谓摄受五办有漏法具摄受六办无漏故。十一随顺依处。谓无记染善现种诸行能随顺同类胜品诸法。即依此处立引发因。谓能引起同类胜行及能引得无为法故。十二差别功能依处。谓有为法各于自果有能起证差别势力。即依此处立定异因谓各能生自界等果。及各能得自乘果故。十三和合依处。谓从领受乃至差别功能依处于所生住成得果中有和合力。即依此处立同事因。谓从观待乃至定异皆同生等一事业故。十四障碍依处。谓于生住成得事中能障碍法。即依此处立相违因。谓彼能违生等事故。十五不障碍依处。谓于生住成得事中不障碍法。即依此处立不相违因。谓彼不违生等事故。如是十因二因所摄。一能生二方便。菩萨地说牵引种子生起种子名能生因。所余诸因方便因摄。此说牵引生起引发定异同事不相违中。诸因缘种。未成熟位名牵引种已成熟位名生起种。彼六因中诸因缘种皆摄在此二位中故。离有现起是能生因如四因中生自种者而多间断。此略不说。或亲办果亦立种名。如说现行谷麦等种。所余因谓初二五九及六因中非因缘法。皆是生熟因缘种余故总说为方便因摄。非此二种唯属彼二因余四因中有因缘种故。非唯彼八名所余因彼二因亦有非因缘种故。有寻等地说生起因是能生因余方便摄。此文意说六因中现种是因缘者皆名生起因。能亲生起自类果故。此所余因皆方便摄。非此生起唯属彼因余五因中有因缘故。非唯彼九名所余因彼生起因中有非因缘故。或菩萨地所说牵引生起种子。即彼二因。所余诸因即彼余八。虽二因内有非能生因而因缘种胜显故偏说。虽余因内有非方便因而增上者多显故偏说。有寻等地说生起因是能生因余方便者。生起即是彼生起因余因应知即彼余九。虽生起中有非因缘种而去果近亲显故偏说。虽牵引中亦有因缘种而去果远亲隐故不说。余方便摄准上应知。所说四缘依何处立。复如何摄十因二因。论说因缘依种子立。依无间灭立等无间。依境界立所缘。依所余立增上。此中种子即是三四十一十二十三十五六依处中因缘种摄。虽现四处亦有因缘而多间断。此略不说。或彼亦能亲办自果如外麦等亦立种名。或种子言唯属第四。亲疏隐显取舍如前。言无间灭境界处者应知总显二缘依处非唯五六。余依处中亦有中间二缘义故。或唯五六余处虽有而少隐故略不说之。论说因缘能生因摄。增上缘性即方便因。中间二缘摄受因摄。虽方便内具后三缘而增上多故此偏说。余因亦有中间二缘然摄受中显故偏说。初能生摄进退如前所说因缘必应有果。此果有几依何处得。果有五种。一者异熟。谓有漏善及不善法所招自相续异熟生无记。二者等流。谓习善等所引同类或似先业后果随转。三者离系。谓无漏道断障所证善无为法。四者士用。谓诸作者假诸作具所办事业。五者增上。谓除前四余所得果。瑜伽等说习气依处得异熟果。随顺依处得等流果。真见依处得离系果。士用依处得士用果。所余依处得增上果。习气处言显诸依处感异熟果一切功能。随顺处言显诸依处引等流果一切功能。真见处言显诸依处证离系果一切功能。士用处言显诸依处招士用果一切功能。所余处言显诸依处得增上果一切功能。不尔便应太宽太狭。或习气者唯属第三。虽异熟因余处亦有此处亦有非异熟因而异熟因去果相远。习气亦尔故此偏说。随顺唯属第十一处。虽等流果余处亦得此处亦得非等流果而此因招胜行相显。随顺亦尔故偏说之。真见处言唯诠第十。虽证离系余处亦能此处亦能得非离系而此证离系相显故偏说。士用处言唯诠第九。虽士用果余处亦招此处亦能招增上等而名相显是故偏说。所余唯属余十一处。虽十一处亦得余果招增上果余处亦能而此十一多招增上。余已显余故此偏说。如是即说此五果中若异熟果牵引生起定异同事不相违因增上缘得。若等流果牵引生起摄受引发定异同事不相违因初后缘得。若离系果摄受引发定异同事不相违因增上缘得。若士用果有义观待摄受同事不相违因增上缘得。有义观待牵引生起摄受引发定异同事不相违因除所缘缘余三缘得。若增上果十因四缘一切容得。傍论已了应辩正论

本识中种容作三缘生现分别除等无间。谓各亲种是彼因缘为所缘缘于能缘者。若种于彼有能助力或不障碍是增上缘。生净现行应知亦尔。现起分别展转相望容作三缘无因缘故。谓有情类自他展转容作二缘除等无间。自八识聚展转相望定有增上缘必无等无间。所缘缘义或无或有。八于七有。七于八无。余七非八所仗质故。第七于六五无一有。余六于彼一切皆无。第六于五无。余五于彼有。五识唯托第八相故。自类前后第六容三余除所缘取现境故。许五后见缘前相者五七前后亦有三缘。前七于八所缘容有能熏成彼相见种故。同聚异体展转相望唯有增上诸相应法所仗质同不相缘故。或依见分说不相缘。依相分说有相缘义谓诸相分互为质起如识中种为触等相质。不尔无色彼应无境故。设许变色亦定缘种勿见分境不同质故。同体相分为见二缘见分于彼但有增上。见与自证相望亦尔。余二展转俱作二缘。此中不依种相分说但说现起互为缘故。净八识聚自他展转皆有所缘能遍缘故。唯除见分非相所缘相分理无能缘用故。既现分别缘种现生。种亦理应缘现种起。现种于种能作几缘。种必不由中二缘起待心心所立彼二故。现于亲种具作二缘与非亲种但为增上。种望亲种亦具二缘于非亲种亦但增上。依斯内识互为缘起分别因果理教皆成。所执外缘设有无用况违理教何固执为。虽分别言总显三界心及心所而随胜者诸圣教中多门显示。或说为二三四五等如余论中具广分别。虽有内识而无外缘由何有情生死相续。颂曰

  １９由诸业习气　　二取习气俱
      前异熟既尽　　复生余异熟

论曰。诸业谓福非福不动。即有漏善不善思业。业之眷属亦立业名。同招引满异熟果故。此虽才起无间即灭无义能招当异熟果。而熏本识起自功能。即此功能说为习气。是业气分熏习所成简曾现业故名习气。如是习气展转相续至成熟时招异熟果。此显当果胜增上缘。相见．名色．心及心所．本末。彼取皆二取摄。彼所熏发亲能生彼本识上功能名二取习气。此显来世异熟果心及彼相应诸因缘种。俱谓业种二取种俱是疏亲缘互相助义。业招生显故颂先说。前异熟者谓前前生业异熟果。余异熟者谓后后生业异熟果。虽二取种受果无穷而业习气受果有尽。由异熟果性别难招等流增上性同易感。由感余生业等种熟。前异熟果受用尽时复别能生余异熟果。由斯生死轮转无穷何假外缘方得相续。此颂意说由业二取生死轮回皆不离识心心所法为彼性故

复次生死相续由诸习气。然诸习气总有三种。一名言习气。谓有为法各别亲种。名言有二。一表义名言。即能诠义音声差别。二显境名言。即能了境心心所法。随二名言所熏成种作有为法各别因缘。二我执习气。谓虚妄执我我所种。我执有二。一俱生我执。即修所断我我所执。二分别我执。即见所断我我所执。随二我执所熏成种令有情等自他差别。三有支习气。谓招三界异熟业种。有支有二。一有漏善。即是能招可爱果业。二诸不善。即是能招非爱果业。随二有支所熏成种令异熟果善恶趣别。应知我执有支习气于差别果是增上缘。此颂所言业习气者应知即是有支习气。二取习气。应知即是我执名言二种习气。取我我所及取名言而熏成故皆说名取。俱等余文义如前释

复次生死相续由惑业苦。发业润生烦恼名惑。能感后有诸业名业。业所引生众苦名苦。惑业苦种皆名习气。前二习气与生死苦为增上缘助生苦故。第三习气望生死苦能作因缘亲生苦故。颂三习气如应当知。惑苦名取能所取故。取是着义业不得名。俱等余文义如前释。此惑业苦应知总摄十二有支。谓从无明乃至老死如论广释。然十二支略摄为四。一能引支。谓无明行。能引识等五果种故。此中无明唯取能发正感后世善恶业者。即彼所发乃名为行。由此一切顺现受业别助当业皆非行支。二所引支。谓本识内亲生当来异熟果摄识等五种。是前二支所引发故。此中识种谓本识因。除后三因余因皆是名色种摄。后之三因如名次第即后三种。或名色种总摄五因于中随胜立余四种。六处与识总别亦然

集论说识亦是能引识中业种名识支故。异熟识种名色摄故。经说识支通能所引业种识种俱名识故。识是名色依非名色摄故。识等五种由业熏发虽实同时。而依主伴总别胜劣因果相异。故诸圣教假说前后。或依当来现起分位有次第故说有前后。由斯识等亦说现行因时定无现行义故。复由此说生引同时润未润时必不俱故。三能生支。谓爱取有。近生当来生老死故。谓缘迷内异熟果愚发正能招后有诸业为缘引发亲生当来生老死位五果种已。复依迷外增上果愚缘境界受发起贪爱缘爱复生欲等四取。爱取合润能引业种及所引因转名为有俱能近有后有果故。有处唯说业种名有此能正感异熟果故。复有唯说五种名有亲生当来识等种故。四所生支。谓生老死。是爱取有近所生故。谓从中有至本有中未衰变来皆生支摄。诸衰变位总名为老。身坏命终乃名为死。老非定有附死立支。病何非支。不遍定故。老虽不定遍故立支。诸界趣生除中夭者将终皆有衰朽行故。名色不遍何故立支。定故立支。胎卵湿生者六处未满定有名色故。又名色支亦是遍有。有色化生初受生位虽具五根而未有用尔时未名六处支故。初生无色虽定有意根而不明了未名意处故。由斯论说十二有支一切一分上二界有。爱非遍有宁别立支。生恶趣者不爱彼故。定故别立。不求无有生善趣者定有爱故。不还润生爱虽不起然如彼取定有种故。又爱亦遍。生恶趣者于现我境亦有爱故。依无希求恶趣身爱经说非有。非彼全无。何缘所生立生老死所引别立识等五支。因位难知差别相故依当果位别立五支。谓续生时因识相显。次根未满名色相增。次根满时六处明盛。依斯发触因触起受。尔时乃名受果究竟。依此果位立因为五。果位易了差别相故总立二支以显三苦。然所生果若在未来为生厌故说生老死。若至现在为令了知分位相生说识等五。何缘发业总立无明润业位中别立爱取。虽诸烦恼皆能发润而发业位无明力增。以具十一殊胜事故。谓所缘等广如经说。于润业位爱力偏增。说爱如水能沃润故。要数溉灌方生有芽且依初后分爱取二。无重发义立一无明。虽取支中摄诸烦恼。而爱润胜说是爱增。诸缘起支皆依自地有所发行依他无明如下无明发上地行。不尔初伏下地染者所起上定应非行支。彼地无明犹未起故。从上下地生下上者彼缘何受而起爱支。彼爱亦缘当生地受若现若种于理无违。此十二支十因二果定不同世。因中前七与爱取有或异或同。若二三七各定同世。如是十二一重因果足显轮转及离断常。施设两重实为无用。或应过此便致无穷。此十二支义门别者九实三假。已润六支合为有故。即识等五三相位别名生等故。五是一事。谓无明识触受爱五余非一事。三唯是染烦恼性故。七唯不染异熟果故。七分位中容起染故假说通二余通二种。无明爱取说名独相不与余支相交杂故余是杂相。六唯非色。谓无明识触受爱取余通二种。皆是有漏唯有为摄。无漏无为非有支故。无明爱取唯通不善有覆无记。行唯善恶。有通善恶无覆无记。余七唯是无覆无记。七分位中亦起善染。虽皆通三界而有分有全。上地行支能伏下地。即粗苦等六种行相有求上生而起彼故。一切皆唯非学无学圣者所起。有漏善业明为缘故违有支故非有支摄。由此应知圣必不造感后有业于后苦果不迷求故。杂修静虑资下故业生净居等于理无违。有义无明唯见所断。要迷谛理能发行故。圣必不造后有业故。爱取二支唯修所断。贪求当有而润生故。九种命终心俱生爱俱故。余九皆通见修所断。有义一切皆通二断。论说预流果已断一切一分有支无全断者故。若无明支唯见所断。宁说预流无全断者。若爱取支唯修所断。宁说彼已断一切支一分。又说全界一切烦恼皆能结生。往恶趣行唯分别起烦恼能发。不言润生唯修所断诸感后有行皆见所断发由此故知无明爱取三支亦通见修所断。然无明支正发行者唯见所断。助者不定。爱取二支正润生者唯修所断。助者不定。又染污法自性应断。对治起时彼永断故。一切有漏不染污法非性应断。不违道故。然有二义说之为断。一离缚故。谓断缘彼杂彼烦恼。二不生故。谓断彼依令永不起。依离缚断说有漏善无覆无记唯修所断。依不生断说诸恶趣无想定等唯见所断。说十二支通二断者于前诸断如应当知。十乐舍俱。受不与受共相应故。老死位中多分无乐及容舍故。十一苦俱非受俱故。十一少分坏苦所摄。老死位中多无乐受依乐立坏故不说之。十二少分苦苦所摄。一切支中有苦受故。十二全分行苦所摄。诸有漏法皆行苦故。依舍受说十一少分。除老死支如坏苦说。实义如是。诸圣教中随彼相增所说不定。皆苦谛摄取蕴性故。五亦集谛摄业烦恼性故。诸支相望增上定有余之三缘有无不定。契经依定唯说有一。爱望于取有望于生有因缘义。若说识支是业种者行望于识亦作因缘。余支相望无因缘义。而集论说无明望行有因缘者依无明时业习气说。无明俱故假说无明实是行种

瑜伽论说诸支相望无因缘者依现爱取唯业有说。无明望行爱望于取生望老死有余二缘。有望于生受望于爱无等无间有所缘缘。余支相望二俱非有。此中且依邻近顺次不相杂乱实缘起说。异此相望为缘不定。诸聪慧者如理应思。惑业苦三摄十二者无明爱取是惑所摄。行有一分是业所摄。七有一分是苦所摄。有处说业全摄有者应知彼依业有说故。有处说识业所摄者彼说业种为识支故。惑业所招独名苦者唯苦谛摄为生厌故。由惑业苦即十二支故此能令生死相续

复次生死相续由内因缘不待外缘故唯有识。因谓有漏无漏二业正感生死故说为因。缘谓烦恼所知二障助感生死故说为缘。所以者何。生死有二。一分段生死。谓诸有漏善不善业由烦恼障缘助势力所感三界粗异熟果。身命短长随因缘力有定齐限故名分段。二不思议变易生死。谓诸无漏有分别业由所知障缘助势力所感殊胜细异熟果。由悲愿力改转身命无定齐限故名变易。无漏定愿正所资感妙用难测名不思议。或名意成身随意愿成故。如契经说。如取为缘有漏业因续后有者而生三有。如是无明习地为缘无漏业因有阿罗汉独觉已得自在菩萨生三种意成身。亦名变化身。无漏定力转令异本如变化故。如有论说。声闻无学永尽后有云何能证无上菩提。依变化身证无上觉非业报身故不违理。若所知障助无漏业能感生死。二乘定性应不永入无余涅槃。如诸异生拘烦恼故。如何道谛实能感苦。谁言实感。不尔如何。无漏定愿资有漏业。令所得果相续长时展转增胜假说名感。如是感时由所知障为缘助力非独能感。然所知障不障解脱。无能发业润生用故。何用资感生死苦为。自证菩提利乐他故。谓不定性独觉声闻及得自在大愿菩萨。已永断伏烦恼障。故无容复受当分段身。恐废长时修菩萨行遂以无漏胜定愿力。如延寿法资现身因令彼长时与果不绝。数数如是定愿资助乃至证得无上菩提。彼复何须所知障助。既未圆证无相大悲。不执菩提有情实有无由发起猛利悲愿。又所知障障大菩提。为永断除留身久住。又所知障为有漏依。此障若无彼定非有。故于身住有大助力。若所留身有漏定愿所资助者分段身摄二乘异生所知境故。无漏定愿所资助者变易身摄。非彼境故。由此应知。变易生死性是有漏异熟果摄。于无漏业是增上果。有圣教中说为无漏出三界者。随助因说。颂中所言诸业习气即前所说二业种子。二取习气即前所说二障种子。俱执着故。俱等余文义如前释。变易生死虽无分段前后异熟别尽别生。而数资助前后改转。亦有前尽余复生义。虽亦由现生死相续而种定有。颂偏说之。或为显示真异熟因果皆不离本识故不说现。现异熟因不即与果。转识间断非异熟故。前中后际生死轮回不待外缘既由内识。净法相续应知亦然。谓无始来依附本识有无漏种由转识等数数熏发渐渐增胜。乃至究竟得成佛时。转舍本来杂染识种。转得始起清净种识。任持一切功德种子。由本愿力尽未来际起诸妙用相续无穷。由此应知唯有内识。若唯有识何故世尊处处经中说有三性。应知三性亦不离识。所以者何。颂曰

  ２０由彼彼遍计　　遍计种种物
      此遍计所执　　自性无所有
  ２１依他起自性　　分别缘所生
      圆成实于彼　　常远离前性
  ２２故此与依他　　非异非不异
      如无常等性　　非不见此彼

论曰。周遍计度故名遍计。品类众多说为彼彼。谓能遍计虚妄分别。即由彼彼虚妄分别遍计种种所遍计物。谓所妄执蕴处界等若法若我自性差别。此所妄执自性差别总名遍计所执自性。如是自性都无所有。理教推征不可得故。或初句显能遍计识。第二句示所遍计境。后半方申遍计所执若我若法自性非有。已广显彼不可得故。初能遍计自性云何。有义八识及诸心所有漏摄者皆能遍计。虚妄分别为自性故。皆似所取能取现故。说阿赖耶以遍计所执自性妄执种为所缘故。有义第六第七心品执我法者是能遍计。唯说意识能遍计故。意及意识名意识故。计度分别能遍计故。执我法者必是慧故。二执必与无明俱故。不说无明有善性故。痴无痴等不相应故。不见有执导空智故。执有执无不俱起故。曾无有执非能熏故。有漏心等不证实故一切皆名虚妄分别。虽似所取能取相现而非一切能遍计摄。勿无漏心亦有执故。如来后得应有执故。经说佛智现身土等种种影像如镜等故。若无缘用应非智等。虽说藏识缘遍计种。而不说唯故非诚证。由斯理趣唯于第六第七心品有能遍计。识品虽二而有二三四五六七八九十等遍计不同故言彼彼。次所遍计自性云何。摄大乘说是依他起遍计心等所缘缘故。圆成实性宁非彼境。真非妄执所缘境故依展转说亦所遍计。遍计所执虽是彼境。而非所缘缘故非所遍计。遍计所执其相云何。与依他起复有何别。有义三界心及心所由无始来虚妄熏习。虽各体一而似二生。谓见相分。即能所取。如是二分情有理无。此相说为遍计所执。二所依体实托缘生。此性非无名依他起。虚妄分别缘所生故。云何知然。诸圣教说虚妄分别是依他起。二取名为遍计所执。有义一切心及心所由熏习力所变二分从缘生故亦依他起。遍计依斯妄执定实有无一异俱不俱等。此二方名遍计所执。诸圣教说唯量唯二唯种种。皆名依他起故。又相等四法十一识等论皆说为依他起摄故。不尔无漏后得智品二分应名遍计所执。许应圣智不缘彼生。缘彼智品应非道谛。不许应知有漏亦尔。又若二分是遍计所执。应如兔角等非所缘缘。遍计所执体非有故。又应二分不熏成种后识等生应无二分。又诸习气是相分摄。岂非有法能作因缘。若缘所生内相见分非依他起二所依体例亦应然。无异因故。由斯理趣众缘所生心心所体及相见分有漏无漏皆依他起。依他众缘而得起故。颂言分别缘所生者应知且说染分依他。净分依他亦圆成故。或诸染净心心所法皆名分别能缘虑故。是则一切染净依他皆是此中依他起摄。二空所显圆满成就诸法实性名圆成实。显此遍常体非虚谬。简自共相虚空我等。无漏有为离倒究竟胜用周遍亦得此名。然今颂中说初非后。此即于彼依他起上常远离前遍计所执。二空所显真如为性。说于彼言显圆成实与依他起不即不离。常远离言显妄所执能所取性理恒非有。前言义显不空依他。性显二空非圆成实。真如离有离无性故。由前理故此圆成实与彼依他起非异非不异。异应真如非彼实性。不异此性应是无常。彼此俱应净非净境。则本后智用应无别。云何二性非异非一。如彼无常无我等性。无常等性与行等法异应彼法非无常等。不异此应非彼共相。由斯喻显此圆成实与彼依他非一非异。法与法性理必应然。胜义世俗相待有故。非不证见此圆成实而能见彼依他起性。未达遍计所执性空不如实知依他有故。无分别智证真如已后得智中方能了达依他起性如幻事等。虽无始来心心所法已能缘自相见分等。而我法执恒俱行故不如实知众缘所引自心心所虚妄变现。犹如幻事阳焰梦境镜像光影谷响水月变化所成非有似有。依如是义故。有颂言

  非不见真如　　而能了诸行
  皆如幻事等　　虽有而非真

此中意说。三种自性。皆不远离心心所法。谓心心所及所变现众缘生故。如幻事等非有似有诳惑愚夫。一切皆名依他起性。愚夫于此横执我法有无一异俱不俱等。如空花等性相都无。一切皆名遍计所执。依他起上彼所妄执我法俱空。此空所显识等真性名圆成实。是故此三不离心等。虚空择灭非择灭等何性摄耶。三皆容摄。心等变似虚空等相。随心生故依他起摄。愚夫于中妄执实有此即遍计所执性摄。若于真如假施设有虚空等义圆成实摄。有漏心等定属依他。无漏心等容二性摄。众缘生故摄属依他。无颠倒故圆成实摄。如是三性与七真如云何相摄。七真如者。一流转真如。谓有为法流转实性。二实相真如。谓二无我所显实性。三唯识真如。谓染净法唯识实性。四安立真如。谓苦实性。五邪行真如。谓集实性。六清净真如。谓灭实性。七正行真如。谓道实性。此七实性圆成实摄。根本后得二智境故。随相摄者流转苦集三前二性摄。妄执杂染故。余四皆是圆成实摄。三性六法相摄云何。彼六法中皆具三性。色受想行识及无为皆有妄执缘生理故。三性五事相摄云何。诸圣教说相摄不定。谓或有处说依他起摄彼相名分别正智圆成实性摄彼真如遍计所执不摄五事。彼说有漏心心所法变似所诠说名为相。似能诠现施设为名。能变心等立为分别。无漏心等离戏论故但总名正智不说能所诠。四从缘生皆依他摄。或复有处说依他起摄相分别遍计所执唯摄彼名正智真如圆成实摄。彼说有漏心及心所相分名相余名分别。遍计所执都无体故为显非有假说为名。二无倒故圆成实摄。或有处说依他起性唯摄分别遍计所执摄彼相名。正智真如圆成实摄。彼说有漏心及心所相见分等总名分别虚妄分别为自性故遍计所执能诠所诠随情立为名相二事。复有处说名属依他起性义属遍计所执。彼说有漏心心所法相见分等由名势力成所遍计故说为名。遍计所执随名横计体实非有假立义名。诸圣教中所说五事文虽有异而义无违。然初所说不相杂乱。如瑜伽论广说应知。又圣教中说有五相此与三性相摄云何。所诠能诠各具三性。谓妄所计属初性摄。相名分别随其所应所诠能诠属依他起。真如正智随其所应所诠能诠属圆成实。后得变似能诠相故。二相属相唯初性摄妄执义名定相属故。彼执着相唯依他起虚妄分别为自性故。不执着相唯圆成实无漏智等为自性故。又圣教中说四真实。与此三性相摄云何。世间道理所成真实依他起摄三事摄故。二障净智所行真实圆成实摄二事摄故。辩中边论说初真实唯初性摄共所执故。第二真实通属三性。理通执无执杂染清净故。后二真实唯属第三。三性四谛相摄云何。四中一一皆具三性。且苦谛中无常等四各有三性。无常三者。一无性无常。性常无故。二起尽无常。有生灭故。三垢净无常。位转变故。苦有三者。一所取苦。我法二执所依取故。二事相苦。三苦相故。三和合苦。苦相合故。空有三者。一无性。空性非有故。二异性空。与妄所执自性异故。三自性空。二空所显为自性故。无我三者。一无相无我。我相无故。二异相无我。与妄所执我相异故。三自相无我。无我所显为自相故。集谛三者。一习气集。谓遍计所执自性执习气。执彼习气假立彼名。二等起集。谓业烦恼三未离系集。谓未离障真如。灭谛三者。一自性灭。自性不生故。二二取灭。谓择灭二取不生故。三本性灭。谓真如故。道谛三者。一遍知道。能知遍计所执故。二永断道。能断依他起故。三作证道。能证圆成实故。然遍知道亦通后二。七三三性如次配释。今于此中所配三性或假或实如理应知。三解脱门所行境界与此三性相摄云何。理实皆通随相各一。空无愿相如次应知。缘此复生三无生忍。一本性无生忍。二自然无生忍。三惑苦无生忍。如次此三是彼境故。此三云何摄彼二谛。应知世俗具此三种胜义唯是圆成实性。世俗有三。一假世俗。二行世俗。三显了世俗。如次应知即此三性。胜义有三。一义胜义。谓真如胜之义故。二得胜义。谓涅槃胜即义故。三行胜义。谓圣道胜为义故。无变无倒随其所应故皆摄在圆成实性。如是三性何智所行遍计所执都非智所行。以无自体非所缘缘故。愚夫执有圣者达无亦得说为凡圣智境。依他起性二智所行圆成实性唯圣智境。此三性中几假几实。遍计所执妄安立故可说为假。无体相故非假非实。依他起性有实有假。聚集相续分位性故说为假有。心心所色从缘生故说为实有。若无实法假法亦无。假依实因而施设故。圆成实性唯是实有。不依他缘而施设故。此三为异为不异耶。应说俱非无别体故妄执缘起真义别故。如是三性义类无边。恐厌繁文略示纲要

成唯识论卷第八成唯识论卷第九

        护法等菩萨造

        三藏法师玄奘奉　诏译

若有三性。如何世尊说一切法皆无自性。颂曰

  ２３即依此三性　　立彼三无性
      故佛密意说　　一切法无性
  ２４初即相无性　　次无自然性
      后由远离前　　所执我法性
  ２５此诸法胜义　　亦即是真如
      常如其性故　　即唯识实性

论曰。即依此前所说三性立彼后说三种无性。谓即相生胜义无性。故佛密意说一切法皆无自性非性全无。说密意言显非了义。谓后二性虽体非无。而有愚夫于彼增益妄执实有我法自性。此即名为遍计所执。为除此执故。佛世尊于有及无总说无性。云何依此而立彼三。谓依此初遍计所执立相无性由此体相毕竟非有如空华故。依次依他立生无性。此如幻事托众缘生。无如妄执自然性故假说无性非性全无。依后圆成实立胜义无性。谓即胜义由远离前遍计所执我法性故假说无性非性全无。如太虚空虽遍众色而是众色无性所显。虽依他起非胜义故亦得说为胜义无性。而滥第二故此不说。此性即是诸法胜义。是一切法胜义谛故。然胜义谛。略有四种。一世间胜义。谓蕴处界等。二道理胜义。谓苦等四谛。三证得胜义。谓二空真如。四胜义胜义。谓一真法界。此中胜义依最后说。是最胜道所行义故。为简前三故作是说。此诸法胜义亦即是真如。真谓真实显非虚妄。如谓如常表无变易。谓此真实于一切位常如其性故曰真如。即是湛然不虚妄义。亦言显此复有多名。谓名法界及实际等。如余论中随义广释。此性即是唯识实性。谓唯识性略有二种。一者虚妄。谓遍计所执。二者真实。谓圆成实性。为简虚妄说实性言。复有二性。一者世俗。谓依他起。二者胜义。谓圆成实。为简世俗故说实性。三颂总显诸契经中说无性言非极了义。诸有智者不应依之总拨诸法都无自性

如是所成唯识相性。谁于几位如何悟入。谓具大乘二种姓者。略于五位渐次悟入。何谓大乘二种种姓。一本性住种姓。谓无始来依附本识法尔所得无漏法因。二习所成种姓。谓闻法界等流法已闻所成等熏习所成。要具大乘此二种姓。方能渐次悟入唯识。何谓悟入唯识五位。一资粮位。谓修大乘顺解脱分。二加行位。谓修大乘顺决择分。三通达位。谓诸菩萨所住见道。四修习位。谓诸菩萨所住修道。五究竟位。谓住无上正等菩提。云何渐次悟入唯识。谓诸菩萨于识相性资粮位中能深信解。在加行位能渐伏除所取能取引发真见。在通达位如实通达。修习位中如所见理数数修习伏断余障。至究竟位出障圆明。能尽未来化有情类复令悟入唯识相性。初资粮位其相云何。颂曰

  ２６乃至未起识　　求住唯识性
      于二取随眠　　犹未能伏灭

论曰。从发深固大菩提心。乃至未起顺决择识求住唯识真胜义性。齐此皆是资粮位摄。为趣无上正等菩提。修习种种胜资粮故。为有情故勤求解脱。由此亦名顺解脱分。此位菩萨依因善友作意资粮四胜力故于唯识义虽深信解而未能了能所取空。多住外门修菩萨行。故于二取所引随眠犹未有能伏灭功力令彼不起二取现行。此二取言显二取取。执取能取所取性故。二取习气名彼随眠。随逐有情眠伏藏识。或随增过故名随眠。即是所知烦恼障种。烦恼障者。谓执遍计所执实我萨迦耶见而为上首百二十八根本烦恼。及彼等流诸随烦恼。此皆扰恼有情身心能障涅槃名烦恼障。所知障者。谓执遍计所执实法萨迦耶见而为上首见疑无明爱恚慢等。覆所知境无颠倒性能障菩提名所知障。此所知障决定不与异熟识俱。彼微劣故。不与无明慧相应故。法空智品与俱起故。七转识内随其所应。或少或多如烦恼说。眼等五识无分别故法见疑等定不相应。余由意力皆容引起。此障但与不善无记二心相应。论说无明唯通不善无记性故。痴无痴等不相应故。烦恼障中此障必有。彼定用此为所依故。体虽无异而用有别。故二随眠随圣道用有胜有劣断惑前后。此于无覆无记性中是异熟生。非余三种。彼威仪等势用薄弱非覆所知障菩提故。此名无覆望二乘说。若望菩萨亦是有覆。若所知障有见疑等如何此种契经说为无明住地。无明增故总名无明。非无见等。如烦恼种立见一处欲色有爱四住地名。岂彼更无慢无明等。如是二障分别起者见所断摄。任运起者修所断摄。二乘但能断烦恼障。菩萨俱断。永断二种唯圣道。能伏二现行通有漏道。菩萨住此资粮位中二粗现行虽有伏者。而于细者及二随眠止观力微未能伏灭。此位未证唯识真如。依胜解力修诸胜行。应知亦是解行地摄。所修胜行其相云何。略有二种谓福及智。诸胜行中慧为性者皆名为智。余名为福。且依六种波罗蜜多通相皆二。别相前五说为福德。第六智慧或复前三唯福德摄。后一唯智。余通二种。复有二种谓利自他。所修胜行随意乐力一切皆通自他利行。依别相说六到彼岸菩提分等自利行摄。四种摄事四无量等一切皆是利他行摄。如是等行差别无边皆是此中所修胜行。此位二障虽未伏除修胜行时有三退屈。而能三事练磨其心于所证修勇猛不退。一闻无上正等菩提广大深远心便退屈引他已证大菩提者练磨自心勇猛不退。二闻施等波罗蜜多甚难可修心便退屈。省己意乐能修施等。练磨自心勇猛不退。三闻诸佛圆满转依极难可证心便退屈。引他粗善况己妙因练磨自心勇猛不退。由斯三事练磨其心坚固炽然修诸胜行。次加行位其相云何。颂曰

  ２７现前立少物　　谓是唯识性
      以有所得故　　非实住唯识

论曰。菩萨先于初无数劫善备福德智慧资粮顺解脱分既圆满已。为入见道住唯识性复修加行伏除二取。谓暖顶忍世第一法。此四总名顺决择分。顺趣真实决择分故。近见道故立加行名。非前资粮无加行义。暖等四法依四寻思四如实智初后位立。四寻思者寻思名义自性差别假有实无。如实遍知此四离识及识非有名如实智。名义相异故别寻求。二二相同故合思察。依明得定发下寻思观无所取立为暖位。谓此位中创观所取名等四法皆自心变假施设有实不可得。初获慧日前行相故立明得名。即此所获道火前相故亦名暖。依明增定发上寻思观无所取立为顶位。谓此位中重观所取名等四法皆自心变假施设有实不可得。明相转盛故名明增。寻思位极故复名顶。依印顺定发下如实智于无所取决定印持。无能取中亦顺乐忍。既无实境离能取识。宁有实识离所取境。所取能取相待立故。印顺忍时总立为忍。印前顺后立印顺名。忍境识空故亦名忍。依无间定发上如实智印二取空立世第一法。谓前上忍唯印能取空。今世第一法二空双印。从此无间必入见道故立无间名。异生法中此最胜故名世第一法。如是暖顶依能取识观所取空。下忍起时印境空相。中忍转位于能取识如境是空顺乐忍可。上忍起位印能取空。世第一法双印空相。皆带相故未能证实。故说菩萨此四位中。犹于现前安立少物。谓是唯识真胜义性。以彼空有二相未除。带相观心有所得故。非实安住真唯识理。彼相灭已方实安住。依如是义故有颂言

  菩萨于定位　　观影唯是心
  义相既灭除　　审观唯自想
  如是住内心　　知所取非有
  次能取亦无　　后触无所得

此加行位未遣相缚。于粗重缚亦未能断。唯能伏除分别二取违见道故。于俱生者及二随眠有漏观心有所得故有分别故未全伏除全未能灭。此位菩萨于安立谛非安立谛俱学观察。为引当来二种见故。及伏分别二种障故。非安立谛是正所观非如二乘唯观安立。菩萨起此暖等善根。虽方便时通诸静虑而依第四方得成满。托最胜依入见道故。唯依欲界善趣身起余慧厌心非殊胜故。此位亦是解行地摄。未证唯识真胜义故。次通达位其相云何。颂曰

  ２８若时于所缘　　智都无所得
      尔时住唯识　　离二取相故

论曰。若时菩萨于所缘境无分别智都无所得。不取种种戏论相故。尔时乃名实住唯识真胜义性。即证真如智与真如平等平等俱离能取所取相故。能所取相俱是分别。有所得心戏论现故。有义此智二分俱无。说无所取能取相故。有义此智相见俱有。带彼相起名缘彼故。若无彼相名缘彼者应色智等名声等智。若无见分应不能缘。宁可说为缘真如智。勿真如性亦名能缘。故应许此定有见分。有义此智见有相无。说无相取不取相故。虽有见分而无分别说非能取非取全无。虽无相分而可说此带如相起不离如故。如自证分缘见分时不变而缘此亦应尔。变而缘者便非亲证如后得智应有分别。故应许此有见无相。加行无间此智生时体会真如名通达位。初照理故亦名见道。然此见道略说有二。一真见道。谓即所说无分别智。实证二空所显真理。实断二障分别随眠。虽多刹那事方究竟而相等故总说一心。有义此中二空二障渐证渐断。以有浅深粗细异故。有义此中二空二障顿证顿断。由意乐力有堪能故。二相见道。此复有二。一观非安立谛有三品心。一内遣有情假缘智能除软品分别随眠。二内遣诸法假缘智能除中品分别随眠。三遍遣一切有情诸法假缘智能除一切分别随眠。前二名法智各别缘故。第三名类智总合缘故。法真见道二空见分自所断障无间解脱。别总建立名相见道。有义此三是真见道。以相见道缘四谛故。有义此三是相见道。以真见道不别缘故。二缘安立谛有十六心。此复有二。一者依观所取能取别立法类十六种心。谓于苦谛有四种心。一苦法智忍。谓观三界苦谛真如。正断三界见苦所断二十八种分别随眠。二苦法智。谓忍无间观前真如证前所断烦恼解脱。三苦类智忍。谓智无间无漏慧生于法忍智各别内证。言后圣法皆是此类。四苦类智。谓此无间无漏智生审定印可苦类智忍。如于苦谛有四种心集灭道谛应知亦尔。此十六心八观真如八观正智。法真见道无间解脱见自证分差别建立名相见道。二者依观下上谛境别立法类十六种心。谓观现前不现前界苦等四谛各有二心。一现观忍。二现观智。如其所应法真见道无间解脱见分观谛断见所断百一十二分别随眠名相见道。若依广布圣教道理说相见道有九种心。此即依前缘安立谛二十六种止观别立。谓法类品忍智合说各有四观。即为八心。八相应止总说为一。虽见道中止观双运而于见义观顺非止。故此观止开合不同。由此九心名相见道。诸相见道依真假说世第一法无间而生及断随眠非实如是。真见道后方得生故。非安立后起安立故。分别随眠真已断故。前真见道证唯识性。后相见道证唯识相。二中初胜故颂偏说。前真见道根本智摄后相见道后得智摄。诸后得智有二分耶。有义俱无离二取故。有义此智见有相无。说此智品有分别故。圣智皆能亲照境故。不执着故说离二取。有义此智二分俱有。说此思惟似真如相不见真实真如性故。又说此智分别诸法自共相等观诸有情根性差别而为说故。又说此智现身土等为诸有情说正法故。若不变现似色声等宁有现身说法等事。转色蕴依不现色者转四蕴依应无受等。又若此智不变似境离自体法应非所缘。缘色等时应缘声等。又缘无法等应无所缘缘。彼体非实无缘用故。由斯后智二分俱有。此二见道与六现观相摄云何。六现观者。一思现观谓最上品喜受相应思所成慧。此能观察诸法共相引生暖等。加行道中观察诸法。此用最猛偏立现观暖等不能广分别法又未证理故非现观。二信现观。谓缘三宝世出世间决定净信。此助现观令不退转立现观名。三戒现观谓无漏戒除破戒垢令观增明亦名现观。四现观智谛现观。谓一切种缘非安立根本后得无分别智。五现观边智谛现观。谓现观智谛现观后诸缘安立世出世智。六究竟现观。谓尽智等究竟位智。此真见道摄彼第四现观少分。此相见道摄彼第四第五少分。彼第二三虽此俱起而非自性故不相摄。菩萨得此二见道时生如来家。住极喜地。善达法界得诸平等。常生诸佛大集会中。于多百门已得自在。自知不久证大菩提。能尽未来利乐一切。次修习位其相云何。颂曰

  ２９无得不思议　　是出世间智
      舍二粗重故　　便证得转依

论曰。菩萨从前见道起已。为断余障证得转依。复数修习无分别智。此智远离所取能取。故说无得及不思议。或离戏论说为无得。妙用难测名不思议。是出世间无分别智。断世间故名出世间。二取随眠是世间本。唯此能断独得出名。或出世名依二义立。谓体无漏及证真如。此智具斯二种义故独名出世。余智不然。即十地中无分别智。数修此故舍二粗重。二障种子立粗重名。性无堪任违细轻故令彼永灭故说为舍。此能舍彼二粗重故便能证得广大转依。依谓所依即依他起与染净法为所依故。染谓虚妄遍计所执。净谓真实圆成实性。转谓二分转舍转得。由数修习无分别智断本识中二障粗重故能转舍依他起上遍计所执及能转得依他起中圆成实性。由转烦恼得大涅槃。转所知障证无上觉。成立唯识意为有情证得如斯二转依果。或依即是唯识真如。生死涅槃之所依故。愚夫颠倒迷此真如。故无始来受生死苦。圣者离倒悟此真如。便得涅槃毕究安乐。由数修习无分别智断本识中二障粗重故能转灭依如生死及能转证依如涅槃。此即真如离杂染性。如虽性净而相杂染。故离染时假说新净。即此新净说为转依。修习位中断障证得。虽于此位亦得菩提而非此中颂意所显。颂意但显转唯识性。二乘满位名解脱身。在大牟尼名法身故

云何证得二种转依。谓十地中修十胜行断十重障证十真如二种转依由斯证得。言十地者。一极喜地。初获圣性具证二空能益自他生大喜故。二离垢地。具净尸罗远离能起微细毁犯烦恼垢故。三发光地。成就胜定大法总持能发无边妙慧光故。四焰慧地。安住最胜菩提分法烧烦恼薪慧焰增故。五极难胜地。真俗两智行相互违合令相应极难胜故。六现前地。住缘起智引无分别最胜般若令现前故。七远行地。至无相住功用后边出过世间二乘道故。八不动地。无分别智任运相续相用烦恼不能动故。九善慧地。成就微妙四无阂解能遍十方善说法故。十法云地。大法智云含众德水蔽一切如空粗重充满法身故。如是十地总摄有为无为功德以为自性。与所修行为胜依持令得生长故名为地

十胜行者即是十种波罗蜜多。施有三种。谓财施无畏施法施。戒有三种。谓律仪戒。摄善法戒饶益有情戒。忍有三种。谓耐怨害忍安受苦忍。谛察法忍。精进有三种。谓被甲精进摄善精进利乐精进。静虑有三种。谓安住静虑。引发静虑办事静虑。般若有三种。谓生空无分别慧法空无分别慧俱空无分别慧。方便善巧有二种。谓回向方便善巧拔济方便善巧。愿有二种。谓求菩提愿利乐他愿。力有二种。谓思择力修习力。智有二种。谓受用法乐智成熟有情智。此十性者。施以无贪及彼所起三业为性。戒以受学菩萨戒时三业为性。忍以无嗔精进审慧及彼所起三业为性。精进以勤及彼所起三业为性。静虑但以等持为性。后五皆以择法为性。说是根本后得智故。有义第八以欲胜解及信为性。愿以此三为自性故。此说自性若并眷属一一皆以一切俱行功德为性。此十相者。要七最胜之所摄受方可建立波罗蜜多。一安住最胜。谓要安住菩萨种性。二依止最胜。谓要依止大菩提心。三意乐最胜。谓要悲愍一切有情。四事业最胜。谓要具行一切事胜。五巧便最胜。谓要无相智所摄受。六回向最胜。谓要回向无上菩提。七清净最胜。谓要不为二障间杂。若非此七所摄受者所行施等非到彼岸。由斯施等十对波罗蜜多一一皆应四句分别。此但有十不增减者谓十地中对治十障证十真如无增减故。复次前六不增减者为除六种相违障故。渐次修行诸佛法故。渐次成熟诸有情故。此如余论广说应知。又施等三增上生道。感大财体及眷属故。精进等三决定胜道。能伏烦恼成熟有情及佛法故。诸菩萨道唯有此二。又前三种饶益有情。施彼资财不损恼彼。堪忍彼恼而饶益故。精进等三对治烦恼。虽未伏灭而能精勤修对治彼诸善加行永伏永灭诸烦恼故。又由施等不住涅槃。及由后三不住生死。为无住处涅槃资粮。由此前六不增不减。后唯四者为助前六令修满足不增减故。方便善巧助施等三愿助精进力助静虑智助般若令修满故如解深密广说应知。十次第者。谓由前前引发后后。及由后后持净前前。又前前粗后后细故易难修习次第如是。释总别名如余处说。此十修者有五种修。一依止任持修。二依止作意修。三依止意乐修。四依止方便修。五依止自在修。依此五修修习十种波罗蜜多皆得圆满。如集论等广说其相。此十摄者。谓十一一皆摄一切波罗蜜多互相顺故。依修前行而引后者。前摄于后必待前故后不摄前不待后故。依修后行持净前者后摄于前持净前故前不摄后非持净故。若依纯杂而修习者。展转相望应作四句。此实有十而说六者应知后四第六所摄。开为十者第六唯摄无分别智后四皆是后得智摄缘世俗故。此十果者。有漏有四除离系果。无漏有四除异熟果。而有处说具五果者或互相资或二合说。十与三学互相摄者。戒学有三。一律仪戒。谓正远离所应离法。二摄善法戒。谓正修证应修证法。三饶益有情戒。谓正利乐一切有情。此与二乘有共不共甚深广大如余处说。定学有四。一大乘光明定。谓此能发照了大乘理教行果智光明故。二集福王定。谓此自在集无边福如王势力无等双故。三贤守定。谓此能守世出世间贤善法故。四健行定。谓佛菩萨大健有情之所行故。此四所缘对治堪能引发作业如余处说。慧学有三。一加行无分别慧。二根本无分别慧。三后得无分别慧。此三自性所依因缘所缘行等如余处说。如是三慧初二位中种具有三。现唯加行。于通达位现二种三。见道位中无加行故。于修习位七地已前若种若现俱通三种。八地以去现二种三。无功用道违加行故。所有进趣皆用后得无漏观中任运起故。究竟位中现种俱二。加行现种俱已舍故。若自性摄戒唯摄戒。定摄静虑。慧摄后五。若并助伴皆具相摄。若随用摄戒摄前三。资粮自体眷属性故。定摄静虑。慧摄后五。精进三摄。遍策三故。若随显摄戒摄前四。前三如前及守护故。定摄静虑。慧摄后五。此十位者五位皆具。修习位中其相最显。然初二位顿悟菩萨种通二种现唯有漏。渐悟菩萨若种若现俱通二种。已得生空无漏观故。通达位中种通二种现唯无漏。于修习位七地已前种现俱通有漏无漏。八地以去种通二种现唯无漏。究竟位中若现若种俱唯无漏。此十因位有三种名。一名远波罗蜜多。谓初无数劫。尔时施等势力尚微被烦恼伏未能伏彼。由斯烦恼不觉现行。二名近波罗蜜多。谓第二无数劫。尔时施等势力渐增非烦恼伏而能伏彼。由斯烦恼故意方行。三名大波罗蜜多。谓第三无数劫。尔时施等势力转增能毕竟伏一切烦恼。由斯烦恼永不现行。犹有所知微细现种及烦恼种故未究竟。此十义类差别无边。恐厌繁文略示纲要。十于十地虽实皆修而随相增地地修一。虽十地行有无量门而皆摄在十到彼岸。十重障者。一异生性障。谓二障中分别起者依彼种立异生性故。二乘见道现在前时唯断一种名得圣性。菩萨见道现在前时具断二种名得圣性。二真见道现在前时彼二障种必不成就。犹明与闇定不俱生。如秤两头低昂时等。诸相违法理必应然。是故二性无俱成失。无间道时已无惑种何用复起解脱道为。断惑证灭期心别故。为舍彼品粗重性故。无间道时虽无惑种而未舍彼无堪任性。为舍此故起解脱道。及证此品择灭无为。虽见道生亦断恶趣诸业果等而今且说能起烦恼是根本故。由斯初地说断二愚及彼粗重。一执着我法愚即是此中异生性障。二恶趣杂染愚即是恶趣诸业果等。应知愚品总说为愚。后准此释。或彼唯说利钝障品俱起二愚。彼粗重言显彼二种。或二所起无堪任性。如入二定说断苦根所断苦根虽非现种而名粗重。此亦应然。后粗重言例此应释。虽初地所断实通二障。而异生性障意取所知。说十无明非染污故。无明即是十障品愚。二乘亦能断烦恼障。彼是共故非此所说。又十无明不染污者唯依十地修所断说。虽此位中亦伏烦恼断彼粗重而非正意。不断随眠故此不说。理实初地修道位中亦断俱生所知一分。然今且说最初断者后九地断准此应知。住满地中时既淹久。理应进断所应断障。不尔三时道应无别。故说菩萨得现观已复于十地修道位中唯修永灭所知障道留烦恼障助愿受生非如二乘速趣圆寂。故修道位不断烦恼将成佛时方顿断故。二邪行障谓所知障中俱生一分及彼所起误犯三业。彼障二地极净尸罗。入二地时便能永断。由斯二地说断二愚及彼粗重。一微细误犯愚。即是此中俱生一分。二种种业趣愚。即彼所起误犯三业。或唯起业不了业愚。三闇钝障。谓所知障中俱生一分令所闻思修法忘失。彼障三地胜定总持及彼所发殊胜三慧。入三地时便能永断。由斯三地说断二愚及彼粗重。一欲贪愚。即是此中能障胜定及修慧者。彼昔多与欲贪俱故名欲贪愚。今得胜定及修所成彼既永断欲贪随伏。此无始来依彼转故。二圆满闻持陀罗尼愚。即是此中能障总持闻思慧者。四微细烦恼现行障。谓所知障中俱生一分第六识俱身见等摄。最下品故不作意缘故远随现行故说名微细。彼障四地菩提分法。入四地时便能永断。彼昔多与第六识中任运而生执我见等同体起故说烦恼名。今四地中既得无漏菩提分法彼便永灭。此我见等亦永不行。初二三地行施戒修相同世间。四地修得菩提分法方名出世。故能永害二身见等。宁知此与第六识俱。第七识俱执我见等与无漏道性相违故。八地以去方永不行七地已来犹得现起与余烦恼为依持故。此粗彼细伏有前后。故此但与第六相应身见等言亦摄无始所知障摄定爱法爱。彼定法爱三地尚增。入四地时方能永断。菩提分法特违彼故。由斯四地说断二愚及彼粗重。一等至爱愚。即是此中定爱俱者。二法爱愚。即是此中法爱俱者。所知障摄二愚断故烦恼二爱亦永不行。五于下乘般涅槃障。谓所知障中俱生一分令厌生死乐趣涅槃同下二乘厌苦欣灭。彼障五地无差别道。入五地时便能永断。由斯五地说断二愚及彼粗重。一纯作意背生死愚。即是此中厌生死者。二纯作意向涅槃愚。即是此中乐涅槃者。六粗相现行障。谓所知障中俱生一分执有染净粗相现行。彼障六地无染净道。入六地时便能永断。由斯六地说断二愚及彼粗重。一现观察行流转愚。即是此中执有染者。诸行流转染分摄故二相多现行愚。即是此中执有净者。取净相故相观多行未能多时住无相观。七细相现行障。谓所知障中俱生一分执有生灭细相现行。彼障七地妙无相道。入七地时便能永断。由斯七地说断二愚及彼粗重。一细相现行愚。即是此中执有生者。犹取流转细生相故。二纯作意求无相愚。即是此中执有灭者。尚取还灭细灭相故。纯于无相作意勤求未能空中起有胜行。八无相中作加行障。谓所知障中俱生一分令无相观不任运起。前之五地有相观多无相观少。于第六地有相观少无相观多。第七地中纯无相观。虽恒相续而有加行。由无相中有加行故未能任运现相及土。如是加行障八地中无功用道。故若得入第八地时便能永断。彼永断故得二自在。由斯八地说断二愚及彼粗重。一于无相作功用愚。二于相自在愚。令于相中不自在故。此亦摄土相一分故。八地以上纯无漏道任运起故三界烦恼永不现行。第七识中细所知障犹可现起。生空智果不违彼故。九利他中不欲行障。谓所知障中俱生一分令于利乐有情事中不欲勤行乐修己利。彼障九地四无阂解。入九地时便能永断。由斯九地说断二愚及彼粗重。一于无量所说法无量名句字后后慧辩陀罗尼自在愚。于无量所说法陀罗尼自在者谓义无阂解。即于所诠总持自在。于一义中现一切义故。于无量名句字陀罗尼自在者谓法无阂解。即于能诠总持自在。于一名句字中现一切名句字故。于后后慧辩陀罗尼自在者谓词无阂解。即于言音展转训释总持自在。于一音声中现一切音声故。二辩才自在愚。辩才自在者谓辩无阂解。善达机宜巧为说故。愚能障此四种自在。皆是此中第九障摄。十于诸法中未得自在障。谓所知障中俱生一分令于诸法不得自在。彼障十地大法智云及所含藏所起事业。入十地时便能永断。由斯十地说断二愚及彼粗重。一大神通愚。即是此中障所起事业者。二悟入微细秘密愚。即是此中障大法智云及所含藏者。此地于法虽得自在而有余障未名最极。谓有俱生微所知障。及有任运烦恼障种。金刚喻定现在前时彼皆顿断入如来地。由斯佛地说断二愚及彼粗重。一于一切所知境极微细着愚。即是此中微所知障。二极微细碍愚。即是此中一切任运烦恼障种。故集论说得菩提时顿断烦恼及所知障成阿罗汉及成如来证大涅槃大菩提故

成唯识论卷第九成唯识论卷第十

        护法等菩萨造

        三藏法师玄奘奉　诏译

此十一障二障所摄。烦恼障中见所断种于极喜地见道初断。彼障现起地前已伏。修所断种金刚喻定现在前时一切顿断。彼障现起地前渐伏。初地以上能顿伏尽令永不行如阿罗汉。由故意力前七地中虽暂现起而不为失。八地以上毕竟不行。所知障中见所断种于极喜地见道初断。彼障现起地前已伏。修所断种于十地中渐次断灭金刚喻定现在前时方永断尽。彼障现起地前渐伏乃至十地方永伏尽。八地以上六识俱者不复现行。无漏观心及果相续能违彼故。第七俱者犹可现行。法空智果起位方伏。前五转识设未转依无漏伏故障不现起。虽于修道十地位中皆不断灭烦恼障种而彼粗重亦渐断灭。由斯故说二障粗重一一皆有三位断义。虽诸位中皆断粗重而三位显。是故偏说。断二障种渐顿云何。第七识俱烦恼障种三乘将得无学果。时一刹那中三界顿断。所知障种将成佛时一刹那中一切顿断。任运内起无粗细故。余六识俱烦恼障种见所断者三乘见位真见道中一切顿断。修所断者随其所应一类二乘三界九地一一渐次九品别断。一类二乘三界九地合为一聚九品别断。菩萨要起金刚喻定一刹那中三界顿断。所知障种初地初心顿断一切见所断者。修所断者后于十地修道位中渐次而断。乃至正起金刚喻定一刹那中方皆断尽。通缘内外粗细境生品类差别有众多故。二乘根钝渐断障时必各别起无间解脱。加行胜进或别或总。菩萨利根渐断障位。非要别起无间解脱刹那刹那能断证故。加行等四刹那刹那前后相望皆容具有

十真如者。一遍行真如。谓此真如二空所显无有一法而不在故。二最胜真如。谓此真如具无边德于一切法最为胜故。三胜流真如。谓此真如所流教法于余教法极为胜故。四无摄受真如。谓此真如无所系属。非我执等所依取故。五类无别真如。谓此真如类无差别。非如眼等类有异故。六无染净真如。谓此真如本性无染亦不可说后方净故。七法无别真如。谓此真如虽多教法种种安立而无异故。八不增减真如。谓此真如离增减执。不随净染有增减故。即此亦名相土自在所依真如。谓若证得此真如已现相现土俱自在故。九智自在所依真如。谓若证得此真如已于无碍解得自在故。十业自在等所依真如。谓若证得此真如已普于一切神通作业总持定门皆自在故。虽真如性实无差别而随胜德假立十种。虽初地中已达一切而能证行犹未圆满。为令圆满后后建立

如是菩萨于十地中勇猛修行十种胜行断十重障证十真如于二转依便能证得。转依位别略有六种。一损力益能转。谓初二位。由习胜解及惭愧故损本识中染种势力益本识内净种功能。虽未断障种实证转依而渐伏现行亦名为转。二通达转谓通达位。由见道力通达真如断分别生二障粗重证得一分真实转依。三修习转。谓修习位。由数修习十地行故渐断俱生二障粗重渐次证得真实转依。摄大乘中说通达转在前六地有无相观通达真俗间杂现前令真非真现不现故。说修习转在后四地纯无相观长时现前勇猛修习断余粗重多令非真不显现故。四果圆满转。谓究竟位。由三大劫阿僧企耶修集无边难行胜行金刚喻定现在前时永断本来一切粗重顿证佛果圆满转依。穷未来际利乐无尽。五下劣转。谓二乘位。专求自利厌苦欣寂唯能通达生空真如断烦恼种证真择灭无胜堪能名下劣转。六广大转。谓大乘位。为利他故趣大菩提生死涅槃俱无欣厌具能通达二空真如双断所知烦恼障种顿证无上菩提涅槃有胜堪能名广大转。此中意说广大转依舍二粗重而证得故

转依义别略有四种。一能转道。此复有二。一能伏道。谓伏二障随眠势力令不引起二障现行。此通有漏无漏二道加行根本后得三智随其所应渐顿伏彼。二能断道。谓能永断二障随眠。此道定非有漏加行。有漏曾习。相执所引未泯相故。加行趣求所证所引未成办故。有义根本无分别智亲证二空所显真理。无境相故能断随眠。后得不然故非断道。有义后得无分别智虽不亲证二空真理无力能断迷理随眠。而于安立非安立相明了现前无倒证故亦能永断迷事随眠。故瑜伽说修道位中有出世断道世出世断道。无纯世间道能永害随眠。是曾习故相执引故。由斯理趣诸见所断及修所断迷理随眠唯有根本无分别智亲证理故能正断彼。余修所断迷事随眠根本后得俱能正断。二所转依。此复有二。一持种依。谓本识。由此能持染净法种与染净法俱为所依。圣道转令舍染得净。余依他起性虽亦是依而不能持种故此不说。二迷悟依。谓真如。由此能作迷悟根本诸染净法依之得生。圣道转令舍染得净。余虽亦作迷悟法依而非根本故此不说。三所转舍。此复有二。一所断舍。谓二障种。真无间道现在前时障治相违彼便断灭永不成就。说之为舍。彼种断故不复现行妄执我法。所执我法不对妄情。亦说为舍。由此名舍遍计所执。二所弃舍。谓余有漏劣无漏种。金刚喻定现在前时引极圆明纯净本识。非彼依故皆永弃舍。彼种舍已现有漏法及劣无漏毕竟不生。既永不生亦说为舍。由此名舍生死劣法。有义所余有漏法种及劣无漏金刚喻定现在前时皆已弃舍。与二障种俱时舍故。有义尔时犹未舍彼。与无间道不相违故。菩萨应无生死法故。此位应无所熏识故。住无间道应名佛故。后解脱道应无用故。由此应知。余有漏等解脱道起方弃舍之。第八净识非彼依故。四所转得。此复有二。一所显得。谓大涅槃。此虽本来自性清净而由客障覆令不显真圣道生断彼障故令其相显名得涅槃。此依真如离障施设。故体即是清净法界

涅槃义别略有四种。一本来自性清净涅槃。谓一切法相真如理。虽有客染而本性净。具无数量微妙功德。无生无灭湛若虚空。一切有情平等共有。与一切法不一不异。离一切相一切分别。寻思路绝名言道断。唯真圣者自内所证。其性本寂故名涅槃。二有余依涅槃。谓即真如出烦恼障。虽有微苦所依未灭。而障永寂故名涅槃。三无余依涅槃。谓即真如出生死苦。烦恼既尽余依亦灭。众苦永寂故名涅槃。四无住处涅槃。谓即真如出所知障。大悲般若常所辅翼。由斯不住生死涅槃利乐有情穷未来际用而常寂故名涅槃。一切有情皆有初一。二乘无学容有前三。唯我世尊可言具四。如何善逝有有余依。虽无实依而现似有。或苦依尽说无余依。非苦依在说有余依。是故世尊可言具四。若声闻等有无余依如何有处设彼非有。有处说彼都无涅槃岂有余依彼亦非有。然声闻等身智在时有所知障。苦依未尽圆寂义隐。说无涅槃。非彼实无烦恼障尽所显真理有余涅槃。尔时未证无余圆寂故亦说彼无无余依。非彼后时灭身智已无苦依尽无余涅槃。或说二乘无涅槃者依无住处不依前三。又说彼无无余依者依不定性二乘而说。彼才证得有余涅槃。决定回心求无上觉。由定愿力留身久住。非如一类入无余依。谓有二乘深乐圆寂得生空观亲证真如。永灭感生烦恼障尽显依真理有余涅槃。彼能感生烦恼尽故后有异熟无由更生。现苦所依任运灭位余有为法既无所依与彼苦依同时顿舍显依真理无余涅槃。尔时虽无二乘身智而由彼证可说彼有。此位唯有清净真如。离相湛然寂灭安乐。依斯说彼与佛无差。但无菩提利乐他业。故复说彼与佛有异。诸所知障既不感生。如何断彼得无住处。彼能隐覆法空真如令不发生大悲般若穷未来际利乐有情故。断彼时显法空理。此理即是无住涅槃。令于二边俱不住故。若所知障亦障涅槃。如何断彼不得择灭。择灭离缚彼非缚故。既尔断彼宁得涅槃。非诸涅槃皆择灭摄。不尔性净应非涅槃。能缚有情住生死者断此说得择灭无为。诸所知障不感生死。非如烦恼能缚有情。故断彼时不得择灭。然断彼故法空理显。此理相寂说为涅槃。非此涅槃择灭为性。故四圆寂诸无为中初后即真如。中二择灭摄。若唯断缚得择灭者不动等二四中谁摄。非择灭摄。说暂离故。择灭无为唯究竟灭。有非择灭非永灭故。或无住处亦择灭摄。由真择力灭障得故。择灭有二。一灭缚得。谓断感生烦恼得者。二灭障得。谓断除障而证得者。故四圆寂诸无为中初一即真如。后三皆择灭。不动等二暂伏灭者非择灭摄究竟灭者择灭所摄。既所知障亦障涅槃。如何但说是菩提障。说烦恼障但障涅槃岂彼不能为菩提障。应知圣教依胜用说。理实俱能通障二果。如是所说四涅槃中唯后三种名所显得。二所生得。谓大菩提。此虽本来有能生种而所知障碍故不生。由圣道力断彼障故令从种起名得菩提。起已相续穷未来际。此即四智相应心品

云何四智相应心品。一大圆镜智相应心品。谓此心品离诸分别。所缘行相微细难知。不妄不愚一切境相。性相清净离诸杂染。纯净圆德现种依持。能现能生身土智影。无间无断穷未来际。如大圆镜现众色像。二平等性智相应心品。谓此心品观一切法自他有情悉皆平等。大慈悲等恒共相应。随诸有情所乐示现受用身土影像差别。妙观察智不共所依。无住涅槃之所建立。一味相续穷未来际。三妙观察智相应心品。谓此心品善观诸法自相共相无碍而转。摄观无量总持之门及所发生功德珍宝。于大众会能现无边作用差别皆得自在。雨大法雨断一切疑令诸有情皆获利乐。四成所作智相应心品。谓此心品为欲利乐诸有情故。普于十方示现种种变化三业成本愿力所应作事。如是四智相应心品虽各定有二十二法能变所变种现俱生。而智用增以智名显。故此四品总摄佛地一切有为功德皆尽。此转有漏八七六五识相应品。如次而得。智虽非识而依识转识为主故说转识得。又有漏位智劣识强。无漏位中智强识劣。为劝有情依智舍识故说转八识而得此四智。大圆镜智相应心品有义菩萨金刚喻定现在前时即初现起。异熟识种与极微细所知障种俱时舍故。若圆镜智尔时未起便无能持净种识故。有义此品解脱道时初成佛故乃得初起。异熟识种金刚喻定现在前时犹未顿舍。与无间道不相违故。非障有漏劣无漏法但与佛果定相违故。金刚喻定无所熏识无漏不增应成佛故。由斯此品从初成佛尽未来际相续不断。持无漏种令不失故。平等性智相应心品菩萨见道初现前位违二执故方得初起。后十地中执未断故有漏等位或有间断。法云地后与净第八相依相续尽未来际。妙观察智相应心品生空观品二乘见位亦得初起。此后展转至无学位或至菩萨解行地终或至上位。若非有漏或无心时皆容现起法空观品菩萨见位方得初起。此后展转乃至上位。若非有漏生空智果或无心时皆容现起。成所作智相应心品有义菩萨修道位中后得引故亦得初起有义成佛方得初起。以十地中依异熟识所变眼等。非无漏故有漏不共必俱同境根发无漏识理不相应故。此二于境明昧异故。由斯此品要得成佛依无漏根方容现起。而数间断。作意起故。此四种性虽皆本有而要熏发方得现行因位渐增。佛果圆满不增不减尽未来际。但从种生不熏成种。勿前佛德胜后佛故。大圆镜智相应心品有义但缘真如为境。是无分别非后得智。行相所缘不可知故。有义此品缘一切法。庄严论说大圆镜智于一切境不愚迷故。佛地经说如来智镜诸处境识众像现故。又此决定缘无漏种及身土等诸影像故行缘微细说不可知。如阿赖耶亦缘俗故。缘真如故是无分别。缘余境故后得智摄。其体是一随用分二。了俗由证真。故说为后得。余一分二准此应知。平等性智相应心品有义但缘第八净识。如染第七缘藏识故。有义但缘真如为境。缘一切法平等性故。有义遍缘真俗为境。佛地经说平等性智证得十种平等性故。庄严论说缘诸有情自他平等随他胜解示现无边佛影像故。由斯此品通缘真俗二智所摄于理无违。妙观察智相应心品缘一切法自相共相皆无障碍二智所摄。成所作智相应心品有义但缘五种现境。庄严论说如来五根一一皆于五境转故。有义此品亦能遍缘三世诸法不违正理。佛地经说成所作智起作三业诸变化事决择有情心行差别领受去来现在等义。若不遍缘无此能。故然此心品随意乐力或缘一法或二或多。且说五根于五境转不言唯尔故不相违。随作意生缘事相境起化业故后得智摄。此四心品虽皆遍能缘一切法而用有异。谓镜智品现自受用身净土相持无漏种。平等智品现他受用身净土相。成事智品能现变化身及土相。观察智品观察自他功能过失雨大法雨破诸疑网利乐有情。如是等门差别多种。此四心品名所生得。此所生得总名菩提。及前涅槃名所转得。虽转依义总有四种而今但取二所转得。颂说证得转依言故。此修习位说能证得。非已证得因位摄故。后究竟位其相云何。颂曰

  ３０此即无漏界　　不思议善常
      安乐解脱身　　大牟尼名法

论曰。前修习位所得转依应知即是究竟位相。此谓此前二转依果。即是究竟无漏界摄。诸漏永尽非漏随增性净圆明故名无漏。界是藏义。此中含容无边希有大功德故。或是因义。能生五乘世出世间利乐事故。清净法界可唯无漏摄。四智心品如何唯无漏。道谛摄故唯无漏摄。谓佛功德及身土等皆是无漏种性所生。有漏法种已永舍故。虽有示现作生死身业烦恼等似苦集谛而实无漏。道谛所摄。集论等说。十五界等唯是有漏。如来岂无五根五识五外界等。有义如来功德身土甚深微妙非有非无。离诸分别绝诸戏论。非界处等法门所摄。故与彼说理不相违。有义如来五根五境妙定生故法界色摄。非佛五识虽依此变然粗细异。非五境摄。如来五识非五识界。经说佛心恒在定故。论说五识性散乱故。成所作智何识相应。第六相应。起化用故。与观察智性有何别。彼观诸法自共相等。此唯起化。故有差别。此二智品应不并生。一类二识不俱起故。许不并起于理无违。同体用分俱亦非失。或与第七净识相应。依眼等根缘色等境是平等智作用差别。谓净第七起他受用身土相者平等品摄。起变化者成事品摄。岂不此品摄五识得。非转彼得体即是彼。如转生死言得涅槃不可涅槃同生死摄。是故于此不应为难。有义如来功德身土如应摄在蕴处界中。彼三皆通有漏无漏。集论等说十五界等唯有漏者。彼依二乘粗浅境说。非说一切。谓余成就十八界中唯有后三通无漏摄。佛成就者虽皆无漏而非二乘所知境摄。然余处说佛功德等非界等者。不同二乘劣智所知界等相故。理必应尔。所以者何。说有为法皆蕴摄故。说一切法界处摄故。十九界等圣所遮故。若绝戏论便非界等亦不应说即无漏界善常安乐解脱身等。又处处说转无常蕴获得常蕴。界处亦然。宁说如来非蕴处界。故言非者是密意说。又说五识性散乱者说余成者。非佛所成。故佛身中十八界等皆悉具足而纯无漏。此转依果又不思议超过寻思言议道故。微妙甚深自内证故。非诸世间喻所喻故。此又是善白法性故。清净法界远离生灭极安隐故。四智心品妙用无方。极巧便故。二种皆有顺益相故。违不善故。俱说为善。论说处等八唯无记。如来岂无五根三境。此中三释广说如前。一切如来身土等法皆灭道摄。故唯是善。圣说灭道唯善性故。说佛土等非苦集故。佛识所变有漏不善无记相等。皆从无漏善种所生。无漏善摄。此又是常无尽期故。清净法界无生无灭性无变易故说为常。四智心品所依常故无断尽故亦说为常。非自性常从因生故。生者归灭一向记故。不见色心非无常故。然四智品由本愿力所化有情无尽期故穷未来际无断无尽。此又安乐无逼恼故。清净法界众相寂静。故名安乐。四智心品永离恼害。故名安乐。此二自性皆无逼恼。及能安乐一切有情。故二转依俱名安乐。二乘所得二转依果唯永远离烦恼障缚无殊胜法故但名解脱身。大觉世尊成就无上寂默法故名大牟尼。此牟尼尊所得二果永离二障亦名法身。无量无边力无畏等大功德法所庄严故。体依聚义总说名身故。此法身五法为性。非净法界独名法身。二转依果皆此摄故。如是法身有三相别。一自性身。谓诸如来真净法界。受用变化平等所依。离相寂然绝诸戏论。具无边际真常功德。是一切法平等实性。即此自性亦名法身。大功德法所依止故。二受用身。此有二种。一自受用。谓诸如来三无数劫修集无量福慧资粮所起无边真实功德。及极圆净常遍色身。相续湛然尽未来际恒自受用广大法乐。二他受用。谓诸如来由平等智示现微妙净功德身。居纯净土为住十地诸菩萨众现大神通转正法轮决众疑网令彼受用大乘法乐。合此二种名受用身。三变化身。谓诸如来由成事智变现无量随类化身。居净秽土为未登地诸菩萨众二乘异生称彼机宜现通说法令各获得诸利乐事。以五法性摄三身者。有义初二摄自性身。经说真如是法身故。论说转去阿赖耶识得自性身。圆镜智品转去藏识而证得故。中二智品摄受用身。说平等智于纯净土为诸菩萨现佛身故。说观察智大集会中说法断疑现自在故。说转诸转识得受用身故。后一智品摄变化身。说成事智于十方土现无量种难思化故

又智殊胜具摄三身。故知三身皆有实智。有义初一摄自性身。说自性身本性常故。说佛法身无生灭故。说证因得非生因故。又说法身诸佛共有遍一切法犹若虚空无相无为非色心故。然说转去藏识得者。谓由转灭第八识中二障粗重显法身故。智殊胜中说法身者。是彼依止彼实性故。自性法身虽有真实无边功德而无为故不可说为色心等物。四智品中真实功德镜智所起常遍色身摄自受用。平等智品所现佛身摄他受用。成事智品所现随类种种身相摄变化身。说圆镜智是受用佛。转诸转识得受用故。虽转藏识亦得受用。然说转彼显法身故。于得受用略不说之。又说法身无生无灭唯证因得非色心等。圆镜智品与此相违。若非受用属何身摄。又受用身摄佛不共有为实德故四智品实有色心皆受用摄。又他受用及变化身皆为化他方便示现。故不可说实智为体。虽说化身智殊胜摄。而似智现或智所起。假说智名体实非智。但说平等成所作智能现受用三业化身。不说二身即是二智。故此二智自受用摄。然变化身及他受用虽无真实心及心所。而有化现心心所法。无上觉者神力难思故能化现无形质法。若不尔者云何如来现贪嗔等。久已断故。云何声闻及傍生等知如来心。如来实心等觉菩萨尚不知故。由此经说。化无量类皆令有心。又说如来成所作智化作三业。又说变化有依他心依他实心相分现故。虽说变化无根心等。而依余说。不依如来。又化色根心心所法无根等用故不说有。如是三身虽皆具足无边功德。而各有异。谓自性身唯有真实常乐我净。离诸杂染众善所依。无为功德。无色心等差别相用。自受用身具无量种妙色心等真实功德。若他受用及变化身。唯具无边似色心等利乐他用化相功德。又自性身正自利摄。寂静安乐无动作故。亦兼利他。为增上缘令诸有情得利乐故。又与受用及变化身为所依止。故俱利摄。自受用身唯属自利。若他受用及变化身唯属利他。为他现故。又自性身依法性土。虽此身土体无差别。而属佛法相性异故。此佛身土俱非色摄。虽不可说形量小大。然随事相其量无边。譬如虚空遍一切处。自受用身还依自土。谓圆镜智相应净识由昔所修自利无漏纯净佛土因缘成熟。从初成佛尽未来际相续变为纯净佛土。周圆无际众宝庄严。自受用身常依而住。如净土量身量亦尔。诸根相好一一无边。无限善根所引生故。功德智慧既非色法。虽不可说形量大小。而依所证及所依身亦可说言遍一切处。他受用身亦依自土。谓平等智大慈悲力由昔所修利他无漏纯净佛土因缘成熟。随住十地菩萨所宜变为净土。或小或大或劣或胜前后改转。他受用身依之而住。能依身量亦无定限。若变化身依变化土。谓成事智大慈悲力由昔所修利他无漏净秽佛土因缘成熟。随未登地有情所宜化为佛土。或净或秽或小或大前后改转。佛变化身依之而住。能依身量亦无定限。自性身土一切如来同所证故体无差别。自受用身及所依土虽一切佛各变不同。而皆无边不相障碍。余二身土随诸如来所化有情有共不共。所化共者同处同时。诸佛各变为身为土形状相似不相障碍。展转相杂为增上缘。令所化生自识变现。谓于一土有一佛身为现神通说法饶益。于不共者唯一佛变。诸有情类无始时来种性法尔更相系属。或多属一或一属多。故所化生有共不共。不尔多佛久住世间各事劬劳实为无益。一佛能益一切生故。此诸身土若净若秽无漏识上所变现者。同能变识俱善无漏。纯善无漏因缘所生。是道谛摄非苦集故。蕴等识相不必皆同。三法因缘杂引生故。有漏识上所变现者同能变识皆是有漏。纯从有漏因缘所生是苦集摄。非灭道故。善等识相不必皆同。三性因缘杂引生故。蕴等同异类此应知。不尔应无五十二等。然相分等依识变现。非如识性依他中实。不尔唯识理应不成。许识内境俱实有故。或识相见等从缘生。俱依他起虚实如识。唯言遣外不遮内境。不尔真如亦应非实。内境与识既并非虚。如何但言唯识非境。识唯内有境亦通外。恐滥外故但言唯识。或诸愚夫迷执于境起烦恼业生死沉沦不解观心勤求出离。哀愍彼故说唯识言令自观心解脱生死。非谓内境如外都无。或相分等皆识为性。由熏习力似多分生。真如亦是识之实性。故除识性无别有法。此中识言亦说心所。心与心所定相应故。此论三分成立唯识。是故说为成唯识论。亦说此论名净唯识。显唯识理极明净故。此本论名唯识三十。由三十颂显唯识理。乃得圆满非增减故

  已依圣教及正理　　分别唯识性相义
  所获功德施群生　　愿共速登无上觉

成唯识论卷第十

    成唯识论后序

        吴兴沈玄明撰

原夫。觉海澄玄。涵万流而浚宗极。神几阐妙。被众象而凝至真。朗慧日而镜六幽。泄慈云而清八宇。演一音而悬解。逸三乘以遐骛。体陈如之半器。津有有于鹿园。照善现之满机。绎空空于鹫岭。虽绝尘于常断。讵遗筌于有空。显无上之灵宗。凝中道于兹教。逮金河灭景。派淳源而不追。玉牒霏华。绪浇风而竞扇。于是二十八见迷。桑雁于五天。一十六师乱。云牛于四主。半千将圣。兹惟世亲寔贤劫之应真。晦生知以提化。飞光毓彩诞映资灵。曜常明于八蕴。藻初情于六足。秀谈芝于俱舍。摽说有之余宗。摄玄波于大乘。贲研空之至理。化方升而照极。湛冲一于斯颂。唯识三十偈者。世亲归根之遗制也。理韬渊海。泛浮境于荣河。义郁烟飙。丽虹章于玄圃。言含万象。字苞千训。妙旨天逸。邃彩星华。幽绪未宣。冥神绝境。孤明敛映。秘思潜津。后有护法安慧等十大菩萨。韫玄珠于八藏。耸层构于四围。宅照二因。栖清三观。升晖十地。澄智水以润贤林。邻几七觉。皎行月而开重夜。优柔芳烈。景躅前修。箭涌泉言。风飞宝思。咸观本颂。各裁斯释。名曰成唯识论。或名净唯识论。空心外之二取。息滞有之迷涂。有识内之一心。遣归空之妄执。晦斯心境。苦海所以长沦。悟彼有空。觉岸于焉高蹈。九十外道。乱风辙而靡星旗。十八小乘。轫羬轩而扶龙毂。穷神体妙。诣赜探机。精贯十支。洞该九分。顾十翼而搏仙羽。俯九流以浚琼波。尽邃理之希微。阐法王之奥典。称谓双绝。筌象兼忘。曜灵景于西申。閟虹光于震旦。济物弘道。眇归宗德。粤若大和上三藏法师玄奘。体睿舍真。履仁翔慧。九门禅宴。证静于融山。八万玄津。腾流于委海。叠金墙而月曜。峻玉宇而霞骞。轶芳粹于澄兰。孕风华于龙翼。悼微言之匿彩。嗟大义之沦晖。用启誓言。肆兹遥践泳祥河之辍水。攀宝树之低枝。循镂杠以神游。[跳-兆+蘭]霙峰而安步。升紫阶而证道。瞰玄影以严因。采奥观奇。徒苍龙于二纪。缄檀篆贝。旋白马于三秦。我

大唐庆表金轮。祯资枢电。奄大千而光宅。御六辩以天飞。神化潜通。九仙賮宝玄猷旁阐。百灵耸职。凝旒邃拱。沓通梦于霄晖。掞组摛华。焕腾文以幽赞。爰降纶旨。溥令翻译

敕尚书左仆射燕国公于志宁。中书令高阳公许敬宗等润色。沙门释神泰等证义。沙门释靖迈等质文。肇自贞观十九年终于显庆之末。部将六十。卷出一千。韬轶蓬莱。池湟环渤。载隆法宝。大启群迷。颂德序经。并纡宸藻。玄风之盛。未之前闻。粤以显庆四年龙栖协洽。玄英应序。厥闰惟阳。糅兹十释四千五百颂。汇聚群分。各遵其本。合为一部。勒成十卷。月穷于纪。铨综云毕。精括诂训。研详夷夏。调惊韶律。藻掞天[這-言+(序-予+手)]。白凤甄奇。紫微呈瑞。遂使文同义异。若一师之制焉。斯则古圣今贤。其揆一也。三藏弟子基鼎族高门。玉田华胄。壮年味道。绮日参玄。业峻林远。识清云镜。闲仪玉莹。陵道邃而澄明。逸韵兰芳。掩法汰而飞辩。绪仙音于八梵。舞霄鹤以翔祯。摛丽范于九章。影桐鸾而绚藻。升光译侣。俯潜睿而融晖。登彩义徒。顾猷畅而高视。秀初昕之琁景。晋烛玄儒。矫弥天之绝翰。腾迈真俗。亲承四辩。言奖三明。疏发户牖。液导津涉。缋功资素。通理寄神。综其纲领。甄其品第。兼撰义疏。传之后学。庶教蟠黄陆。跨合璧于龟畴。祥浮紫宫。掩连珠于麟籀。式罄庸謏叙其宗致云


大乘阿毗达磨集论

    No. 1605 [cf. No. 1606]

大乘阿毗达磨集论卷第一

        无著菩萨造

        三藏法师玄奘奉　诏译

    本事分中三法品第一

  本事与决择　　是各有四种
  三法摄应成　　谛法得论议
  几何因取相　　建立与次第
  义喻广分别　　集总颂应知

蕴界处各有几。蕴有五。谓色蕴受蕴想蕴行蕴识蕴。界有十八。谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。处有十二。谓眼处色处。耳处声处。鼻处香处。舌处味处。身处触处。意处法处

何因蕴唯有五。为显五种我事故。谓身具我事。受用我事。言说我事。造作一切法非法我事。彼所依止我自体事。何因界唯十八。由身具等能持过现六行受用性故。何因处唯十二。唯由身具能与未来六行受用为生长门故。何故名取蕴。以取合故名为取蕴。何等为取。谓诸蕴中所有欲贪。何故欲贪说名为取。谓于未来现在诸蕴能引不舍故。希求未来染着现在欲贪名取。何故界处名有取法。应如蕴说。色蕴何相。变现相是色相。此有二种。一触对变坏。二方所示现。云何名为触对变坏。谓由手足块石刀杖寒热饥渴蚊虻蛇蝎。所触对时即便变坏。云何名为方所示现。谓由方所可相。示现如此如此色。如是如是色或由定心。或由不定寻思相应种种构画。受蕴何相。领纳相是受相。谓由受故。领纳种种净不净业诸果异熟。想蕴何相。构了相是想相。谓由想故。构画种种诸法像类。随所见闻觉知之义起诸言说。行蕴何相。造作相是行相。谓由行故。令心造作于善不善无记品。中驱役心故。识蕴何相。了别相是识相。谓由识故。了别色声香味触法种种境界。眼界何相。谓眼曾现见色。及此种子积集异熟阿赖耶识。是眼界相。如眼界相耳鼻舌身意界相亦尔。色界何相。谓色眼曾现见。及眼界于此增上。是色界相。如色界相声香味触法界相亦尔。眼识界何相。谓依眼缘色似色了别。及此种子积集异熟阿赖耶识。是眼识界相。如眼识界相耳鼻舌身意识界相亦尔。处何相。如界应知随其所应

云何建立色蕴。谓诸所有色。若四大种及四大种所造。云何四大种。谓地界水界火界风界。何等地界。谓坚鞕性。何等水界。谓流湿性。何等火界。谓温热性。何等风界。谓轻等动性。云何所造色。谓眼根耳根鼻根舌根身根。色声香味所触一分。及法处所摄色。何等眼根。谓四大种所造眼识所依清净色。何等耳根。谓四大种所造耳识所依清净色。何等鼻根。谓四大种所造鼻识所依清净色。何等舌根。谓四大种所造舌识所依清净色。何等身根。谓四大种所造身识所依清净色。何等为色。谓四大种所造眼根所行义。谓青黄赤白长短方圆。粗细高下正不正。光影明闇云烟尘雾。迥色表色空一显色。此复三种。谓妙不妙俱相违色。何等为声。谓四大种所造耳根所取义。或可意或不可意。或俱相违。或执受大种为因。或不执受大种为因。或俱大种为因。或世所极成。或成所引。或遍计所起。或圣言所摄。或非圣言所摄。何等为香。谓四大种所造鼻根所取义。谓好香恶香平等香俱生香和合香变异香。何等为味。谓四大种所造舌根所取义。谓苦酢甘辛咸淡。或可意或不可意。或俱相违或俱生。或和合或变异。何等所触一分。谓四大种所造身根所取义。谓滑性涩性轻性重性软性缓急冷饥渴饱力劣闷痒黏病老死疲息勇。何等法处所摄色。有五种应知谓极略色。极迥色。受所引色。遍计所起。色定自在所生色

云何建立受蕴。谓六受身。眼触所生受。耳触所生受。鼻触所生受。舌触所生受。身触所生受。意触所生受。如是六受身。或乐或苦或不苦不乐。复有乐身受苦身受不苦不乐身受。乐心受苦心受不苦不乐心受。复有乐有味受苦有味受不苦不乐有味受。乐无味受苦无味受不苦不乐无味受。复有乐依耽嗜受苦依耽嗜受不苦不乐依耽嗜受。乐依出离受苦依出离受不苦不乐依出离受。何等身受。谓五识相应受。何等心受。谓意识相应受。何等有味受。谓自体爱相应受。何等无味受。谓此爱不相应受。何等依耽嗜受。谓妙五欲爱相应受。何等依出离受。谓此爱不相应受

云何建立想蕴。谓六想身。眼触所生想。耳触所生想。鼻触所生想。舌触所生想。身触所生想。意触所生想。由此想故。或了有相。或了无相。或了小或了大。或了无量。或了无少所有无所有处。何等有相想。谓除不善言说无想界定及有顶定想。所余诸想。何等无相想。谓所余想。何等小想。谓能了欲界想。何等大想。谓能了色界想。何等无量想。谓能了空无边处识无边处想。何等无少所有无所有处想。谓能了无所有处想

云何建立行蕴。谓六思身。眼触所生思。耳触所生思。鼻触所生思。舌触所生思。身触所生思。意触所生思。由此思故思作诸善。思作杂染。思作分位差别。又即此思除受及想与余心所法心不相应行。总名行蕴。何等名为余心所法。谓作意触欲胜解念三摩地慧信惭愧无贪无嗔无痴勤安不放逸舍不害贪嗔慢无明疑萨迦耶见边执见见取戒禁取邪见忿恨覆恼嫉悭诳谄憍害无惭无愧惛沉掉举不信懈怠放逸忘念不正知散乱睡眠恶作寻伺

何等为思。谓于心造作意业为体。于善不善无记品中役心为业。何等作意。谓发动心为体。于所缘境持心为业。何等为触。谓依三和合诸根变异分别为体。受所依为业。何等为欲。谓于所乐事彼彼引发所作希望为体。正勤所依为业。何等胜解。谓于决定事随所决定印持为体。不可引转为业。何等为念。谓于串习事令心明记不忘为体。不散乱为业。何等三摩地。谓于所观事令心一境为体。智所依止为业。何等为慧。谓于所观事择法为体。断疑为业

何等为信。谓于有体有德有能忍可清净希望为体。乐欲所依为业。何等为惭。谓于诸过恶自羞为体。恶行止息所依为业。何等为愧。谓于诸过恶羞他为体。业如惭说。何等无贪。谓于有有具无著为体。恶行不转所依为业。何等无嗔。谓于诸有情苦及苦具无恚为体恶行不转所依为业。何等无痴。谓由报教证智决择为体。恶行不转所依为业。何等为勤。谓心勇悍为体。或被甲或加行。或无下或无退或无足。差别成满善品为业。何等为安。谓止息身心粗重身心调畅为体。除遣一切障碍为业。何等不放逸。谓依止正勤无贪无嗔无痴修诸善法。于心防护诸有漏法为体。成满一切世出世福为业。何等为舍。谓依止正勤无贪无嗔无痴。与杂染住相违。心平等性。心正直性。心无功用住性为体。不容杂染所依为业。何等不害。谓无嗔善根一分心悲愍为体。不损恼为业

何等为贪。谓三界爱为体。生众苦为业。何等为嗔。谓于有情苦及苦具心恚为体。不安隐住恶行所依为业。何等为慢。谓依止萨迦耶见心高举为体。不敬苦生所依为业。何等无明。谓三界无知为体。于诸法中邪决定疑杂生起所依为业。何等为疑。谓于谛犹豫为体。善品不生所依为业。何等萨迦耶见。谓于五取蕴等随观执我及我所。诸忍欲觉观见为体。一切见趣所依为业。何等边执见。谓于五取蕴等随观执或断或常。诸忍欲觉观见为体。障处中行出离为业。何等见取。谓于诸见及见所依五取蕴等。随观执为最为胜为上为妙。诸忍欲觉观见为体。执不正见所依为业。何等戒禁取。谓于诸戒禁及戒禁所依五取蕴等。随观执为清净为解脱为出离。诸忍欲觉观见为体。劳而无果所依为业。何等邪见。谓谤因谤果。或谤作用。或坏实事。或邪分别。诸忍欲觉观见为体断善根为业。及不善根坚固所依为业。不善生起为业。善不生起为业。如是五见。几增益见。几损减见。四是增益见。谓于所知境增益自性及差别故。于诸见中增益第一及清净故。一多分是损减见。计前后际所有诸见。彼于此五几见所摄。谓或二或一切。于不可记事所有诸见。彼于此五几见所摄。谓或二或一切。薄伽梵观何过失故。于蕴界处以五种相非毁执我。由观彼摄受萨迦耶见者。有五种过失故。谓异相过失。无常过失。不自在过失。无身过失。不由功用解脱过失。于五取蕴有二十句萨迦耶见。谓计色是我。我有诸色色。属于我。我在色中。如是计受想行识是我。我有识等识。等属我。我在识等中。于此诸见。几是我见几是我所见。谓五是我见。十五是我所见。何因十五是我所见。由相应我所故。随转我所故。不离我所故。萨迦耶见。当言于事了不了耶。当言于事不得决了。如于绳上妄起蛇解

何等为忿。谓于现前不饶益相。嗔之一分心怒为体。执杖愤发所依为业。何等为恨。谓自此已后即嗔一分怀怨不舍为体。不忍所依为业。何等为覆。谓于所作罪他正举时。痴之一分隐藏为体。悔不安住所依为业。何等为恼。忿恨居先嗔之一分心戾为体。高暴粗言所依为业。生起非福为业。不安隐住为业何等为嫉。谓耽着利养不耐他荣嗔之一分心妒为体。令心忧戚不安隐住为业。何等为悭。谓耽着利养于资生具贪之一分。心吝为体。不舍所依为业。何等为诳。谓耽着利养贪痴一分。诈现不实功德为体。邪命所依为业。何等为谄。谓耽着利养贪痴一分矫设方便隐实过恶为体。障正教授为业。何等为憍。谓或依少年无病长寿之相。或得随一有漏荣利之事。贪之一分令心。悦豫为体。一切烦恼及随烦恼所依为业。何等为害。谓嗔之一分。无哀无悲无愍为体。损恼有情为业。何等无惭。谓贪嗔痴分。于诸过恶不自羞为体。一切烦恼及随烦恼助伴为业。何等无愧。谓贪嗔痴分。于诸过恶不羞他为体。一切烦恼及随烦恼助伴为业。何等惛沈。谓愚痴分。心无堪任为体。障毗钵舍那为业。何等掉举。谓贪欲分。随念净相心不寂静为体。障奢摩他为业。何等不信。谓愚痴分。于诸善法心不忍可心不清净心不希望为体。懈怠所依为业。何等懈怠。谓愚痴分。依着睡眠倚卧为乐心不策励为体。障修方便善品为业。何等放逸。谓依懈怠及贪嗔痴不修善法。于有漏法心不防护为体。憎恶损善所依为业。何等忘念。谓诸烦恼相应念为体。散乱所依为业。何等不正知。谓诸烦恼相应慧为体由此慧故起不正知身语心行毁所依为业。何等散乱。谓贪嗔痴分心流散为体。此复六种。谓自性散乱外散乱内散乱相散乱粗重散乱作意散乱。云何自性散乱。谓五识身。云何外散乱。谓正修善时于五妙欲其心驰散。云何内散乱。谓正修善时沉掉味着。云何相散乱。谓为他归信矫示修善。云何粗重散乱。谓依我我所执。及我慢品粗重力故。修善法时于已生起所有诸受起我我所。及与我慢执受间杂取相。云何作意散乱。谓依余乘余定若依若入。所有流散能障离欲为业

何等睡眠。谓依睡眠因缘。是愚痴分心略为体。或善或不善或无记。或时或非时。或应尔或不应尔。越失可作所依为业。何等恶作。谓依乐作不乐作应作不应作。是愚痴分心追悔为体。或善或不善或无记。或时或非时。或应尔或不应尔。能障心住为业。何等为寻。谓或依思或依慧。寻求意言令心粗转为体。何等为伺。谓或依思或依慧。伺察意言令心细转为体。如是二种。安不安住所依为业

复次诸善心所断自所治为业。烦恼随烦恼障自能治为业

何等名为心不相应行。谓得无想定灭尽定无想异熟命根众同分生老住无常名身句身文身异生性流转定异相应势速次第时方数和合等。何等为得谓于善不善无记法。若增若减假立获得成就。何等无想定。谓已离遍净欲未离上欲出离想。作意为先故。于不恒行心心所灭。假立无想定。何等灭尽定。谓已离无所有处欲。超过有顶暂息想。作意为先故。于不恒行诸心心所及恒行一分心心所灭。假立灭尽定。何等无想异熟。谓已生无想有情天中。于不恒行心心所灭。假立无想异熟。何等命根。谓于众同分先业所引。住时决定假立命根。何等众同分。谓如是如是有情。于种种类自体相似。假立众同分。何等为生。谓于众同分诸行本无今有。假立为生。何等为老。谓于众同分诸行相续变异。假立为老。何等为住。谓于众同分诸行相续不变坏。假立为住。何等无常。谓于众同分诸行相续变坏。假立无常。何等名身。谓于诸法自性增言假立名身。何等句身。谓于诸法差别增言假立句身何等文身。谓于彼二所依诸字。假立文身。此言文者能彰彼二故。此又名显。能显彼义故。此复名字。无异转故。何等异生性。谓于圣法不得假立异生性。何等流转。谓于因果相续不断。假立流转。何等定异。谓于因果种种差别。假立定异何等相应。谓于因果相称。假立相应。何等势速。谓于因果迅疾流转。假立势速。何等次第。谓于因果一一流转。假立次第。何等为时。谓于因果相续流转。假立为时。何等为方。谓于东西南北四维上下因果差别假立为方。何等为数。谓于诸行一一差别。假立为数。何等和合。谓于因果众缘集会假立和合

云何建立识蕴。谓心意识差别。何等为心。谓蕴界处习气所熏。一切种子阿赖耶识。亦名异熟识。亦名阿陀那识以能积集诸习气故。何等为意谓一切时缘阿赖耶识思度为性。与四烦恼恒相应。谓我见我爱我慢无明。此意遍行。一切善不善无记位。唯除圣道现前若处灭尽定及在无学地又六识以无间灭识为意。何等为识。谓六识身。眼识耳识鼻识舌识身识意识。何等眼识。谓依眼缘色了别为性。何等耳识。谓依耳缘声了别为性。何等鼻识。谓依鼻缘香了别为性。何等舌识。谓依舌缘味了别为性。何等身识。谓依身缘触了别为性。何等意识。谓依意缘法了别为性

云何建立界。谓色蕴即十界。眼界色界耳界声界鼻界香界舌界味界身界触界。及意界一分。受蕴想蕴行蕴即法界一分。识蕴即七识界。谓眼等六识界及意界

何等界法蕴不摄耶。谓法界中诸无为法。此无为法复有八种。谓善法真如不善法真如无记法真如虚空非择灭择灭不动及想受灭。何等善法真如。谓无我性。亦名空性无相实际胜义法界。何故真如说名真如。谓彼自性无变异故。何故真如名无我性。离二我故。何故真如名为空性。一切杂染所不行故。何故真如名为无相。以一切相皆寂静故何故真如名为实际。以无颠倒所缘性故。何故真如名为胜义。最胜圣智所行处故。何故真如名为法界。一切声闻独觉诸佛妙法所依相故。如善法真如。当知不善法真如无记法真如亦尔。何等虚空。谓无色性容受一切所作业故。何等非择灭。谓是灭非离系。何等择灭。谓是灭是离系。何等不动。谓已离遍净欲。未离上欲苦乐灭。何等想受灭。谓已离无所有处欲。超过有顶暂息想。作意为先故。诸不恒行心心所灭。及恒行一分心心所灭又若五种色若受想行蕴。及此所说八无为法。如是十六总名法界

云何建立处。谓十色界即十色处。七识界即意处。法界即法处

由此道理诸蕴界处三法所摄。谓色蕴法界意处。如说眼及眼界。若有眼亦眼界耶。设有眼界亦眼耶。或有眼非眼界。谓阿罗汉最后眼。或有眼界非眼。谓处卵[穀-禾+卵]羯逻蓝时。頞部昙时。闭尸时。在母腹中若不得眼。设得已失。若生无色异生所有眼因。或有眼亦眼界。谓所余位。或有无眼无眼界。谓已入无余依涅槃界。及诸圣者生无色界。如眼与眼界。如是耳鼻舌身与耳等界。随其所应尽当知。若有意亦意界耶。设有意界亦意耶。或有意非意界。谓阿罗汉最后意。或有意界非意。谓处灭定者所有意因。或有意亦意界。谓所余位。或有无意无意界。谓已入无余依涅槃界。若生长彼地。即用彼地眼还见彼地色耶。或有即用彼地眼还见彼地色。或复余地。谓生长欲界用色廛眼见欲廛色。或用色廛上地眼见下地色。如以眼对色。如是以耳对声。如生长欲界如是生长色界。若生长欲界。即以欲廛鼻舌身。还嗅尝觉欲廛香味触。若生长色界。即以色廛身。还觉自地触。彼界自性定无香味。离段食贪故。由此道理亦无鼻舌两识。若生长欲界。即以欲廛意知三界法及无漏法。如生长欲界。如是生长色界。若生长无色界。以无色廛意。知无色廛自地法及无漏法。若以无漏意知三界法及无漏法。何故诸蕴如是次第。由识住故谓四识住及识。又前为后依故。如其色相而领受故。如所领受而了知故。如所了知而思作故。如所思作随彼彼处而了别故。又由染污清净故。谓若于是处而起染净。若由领受取相造作故。染污清净。若所染污及所清净。由此理故说蕴次第

何故诸界如是次第。由随世事差别转故。云何世事差别而转。谓诸世间最初相见。既相见已更相问讯。既问讯已即受沐浴涂香花鬘。次受种种上妙饮食。次受种种卧具侍女。然后意界处处分别。以内界次第故建立外界。随此次第建立识界。如界次第处亦如是。蕴义云何。诸所有色。若过去若未来若现在。若内若外若粗若细。若劣若胜若远若近。彼一切略说一色蕴。积聚义故。如财货蕴。如是乃至识蕴。又苦相广大故名为蕴。如大材蕴。如契经言。如是纯大苦蕴集故。又荷杂染担故名为蕴。如肩荷担

界义云何。一切法种子义。又能持自相义。又能持因果性义。又摄持一切法差别义。处义云何。识生长门义是处义

如佛所说。色如聚沫。受如浮泡。想如阳焰。行如芭蕉。识如幻化。以何义故色如聚沫乃至识如幻化。以无我故。离净故。少味故。不坚故不实故

大乘阿毗达磨集论卷第一大乘阿毗达磨集论卷第二

        无著菩萨造

        三藏法师玄奘奉　诏译

    本事分中三法品第一之二

复次蕴界处广分别云何。嗢柁南曰

  实有性等所知等　　色等漏等已生等
  过去世等诸缘等　　云何几种为何义

蕴界处中云何实有。几是实有。为何义故观实有耶。谓不待名言此余根境。是实有义。一切皆是实有。为舍执着实有我故。观察实有

云何假有。几是假有。为何义故观假有耶。谓待名言此余根境。是假有义一切皆是假有。为舍执着实有我故。观察假有

云何世俗有。几是世俗有。为何义故观世俗有耶。谓杂染所缘。是世俗有义。一切皆是世俗有。为舍执着杂染相我故。观察世俗有。云何胜义有。几是胜义有。为何义故观胜义有耶。谓清净所缘。是胜义有义。一切皆是胜义有。为舍执着清净相我故。观察胜义有。云何所知。几是所知。为何义故观所知耶。谓所知有五种。一色二心三心所有法四心不相应行五无为。若于是处杂染清净。若所杂染及所清净。若能杂染及能清净。若于此分位若此清净性。由依此故一切皆是所知。此中色谓色蕴。十色界十色处。及法界法处所摄诸色。心谓识蕴。七识界及意处。心所有法。谓受蕴想蕴相应行蕴。及法界法处一分。心不相应行。谓不相应行蕴及法界法处一分。无为谓法界法处一分。又所知法者谓胜解智所行故。道理智所行故。不散智所行故。内证智所行故。他性智所行故。下智所行故。上智所行故。厌患智所行故。不起智所行故。无生智所行故。智智所行故。究竟智所行故。大义智所行故。是所知义。一切皆是所知。为舍执着知者见者我故。观察所知

云何所识。几是所识。为何义故观所识耶。谓无分别故。有分别故。因故转故相故。相所生故。能治所治故。微细差别故是所识义。一切皆是所识。为舍执着能见者等我故。观察所识

云何所通达。几是所通达。为何义故观所通达耶。谓转变故随闻故入行故来故往故出离故。是所通达义。一切皆是所通达。为舍执著有威德我故。观察所通达

云何有色。几是有色。为何义故观有色耶。谓色自性故。依大种故。喜集故。有方所故。处遍满故。方所可说故。方处所行故。二同所行故。相属故随逐故。显了故变坏故。显示故积集建立故。外门故内门故。长远故分限故。暂时故示现故。是有色义。一切皆是有色。或随所应为舍执著有色我故。观察有色

云何无色。几是无色。为何义故观无色耶。谓有色相违是无色义。一切皆是无色。或随所应。为舍执着无色我故。观察无色

云何有见。几是有见。为何义故观有见耶。谓眼所行境是有见义。余差别如有色说。一切皆是有见。或随所应。为舍执着眼境我故。观察有见

云何无见。几是无见。为何义故观无见耶。谓有见相违是无见义。一切皆是无见。或随所应。为舍执着非眼境我故。观察无见

云何有对。几是有对。为何义故观有对耶。谓诸有见者皆是有对。又三因故说名有对。谓种类故积集故不修治故。种类者。谓诸色法互为能碍互为所碍。积集者。谓极微已上。不修治者。谓非三摩地自在转色。又损害依处是有对义。一切皆是有对。或随所应为舍执着不遍行我故。观察有对

云何无对。几是无对。为何义故观无对耶。谓有对相违是无对义。一切皆是无对。或随所应。为舍执着。遍行我故。观察无对

云何有漏。几是有漏。为何义故观有漏耶。谓漏自性故。漏相属故。漏所缚故。漏所随故。漏随顺故。漏种类故。是有漏义五取蕴十五界十处全。及三界二处少分。是有漏。为舍执着漏合我故。观察有漏

云何无漏。几是无漏为何义故观无漏耶。谓有漏相违是无漏义。五无取蕴全及三界二处少分。是无漏为舍执着离漏我故。观察无漏

云何有诤。几是有诤。为何义故观有诤耶。谓依如是贪嗔痴故。执持刀杖发起一切斗讼违诤。彼自性故。彼相属故。彼所缚故。彼所随故。彼随顺故。彼种类故。是有诤义。乃至有漏有尔所量。有诤亦尔。为舍执着诤合我故观察有诤

云何无诤。几是无诤。为何义故观无诤耶。谓有诤相违是无诤义。乃至无漏有尔所量。无诤亦尔。为舍执着离诤我故。观察无诤

云何有染。几是有染。为何义故观有染耶。谓衣如是贪嗔痴故。染着后有自身。彼自性故。彼相属故。彼所缚故。彼随逐故。彼随顺故。彼种类故。是有染义。乃至有诤有尔所量。有染亦尔。为舍执着染合我故。观察有染

云何无染。几是无染。为何义故观无染耶。谓有染相违是无染义乃至无诤有尔所量。无染亦尔。为舍执着离染我故。观察无染

云何依耽嗜。几是依耽嗜。为何义故观依耽嗜耶。谓依如是贪嗔痴故染着五欲。彼自性故。彼相属故。彼所缚故。彼随逐故。彼随顺故。彼种类故。是依耽嗜义。乃至有染有尔所量。依耽嗜亦尔。为舍执着耽嗜合我故。观察依耽嗜

云何依出离。几是依出离。为何义故观依出离耶。谓依耽嗜相违是依出离义。乃至无染有尔所量。出离亦尔。为舍执着离耽嗜我故。观察出离

云何有为。几是有为。为何义故观有为耶。谓若法有生灭住异。可知是有为义。一切皆是有为唯除法界法处一分。为舍执着无常我故。观察有为

云何无为。几是无为。为何义故观无为耶。谓有为相违是无为义。法界法处一分是无为。为舍执着常住我故。观察无为。无取五蕴当言有为当言无为。彼不应言有为无为。何以故。诸业烦恼所不为故。不应言有为。随欲现前不现前故。不应言无为。如世尊说。法有二种。谓有为无为。云何今说此法非有为非无为。若由此义说名有为。不以此义说名无为。若由此义说名无为。不以此义说名有为。依此道理唯说二种

云何世间。几是世间。为何义故观世间耶。谓三界所摄。及出世智后所得似彼显现。是世间义。诸蕴一分十五界十处全。及三界二处一分是世间。为舍执着世依我故观察世间

云何出世。几是出世。为何义故观出世耶。谓能对治三界。无颠倒无戏论无分别故。是无分别出世间义。又出世后所得亦名出世。依止出世故是出世义。诸蕴一分及三界二处一分是出世。为舍执着独存我故。观察出世

云何已生几是已生。为何义故观已生耶。谓过去现在是已生义。一切一分是已生。为舍执着非常我故。观察已生。又有二十四种已生。谓最初已生。相续已生。长养已生。依止已生。转变已生。成熟已生。退堕已生。胜进已生。清净已生。不清净已生。运转已生。有种已生。无种已生。影像自在示现已生。展转已生刹那坏已生。离会已生。异位已生。生死已生成坏已生。先时已生。死时已生。中时已生续时已生

云何非已生。几是非已生。为何义故观非已生耶。谓未来及无为法是非已生义。一切一分是非已生。为舍执着常住我故。观察非已生。又已生相违是非已生义

云何能取。几是能取。为何义故观能取耶。谓诸色根及心心所是能取义。三蕴全色行蕴一分。十二界六处全。及法界法处一分是能取。为舍执着能受用我故。观察能取。又能取有四种。谓不至能取。至能取。自相现在各别境界能取。自相共相一切时一切境界能取。又由和合识等生故。假立能取

云何所取。几是所取。为何义故观所取耶。谓诸能取亦是所取。或有所取非能取。谓唯是取所行义。一切皆是所取。为舍执着境界我故。观察所取

云何外门。几是外门。为何义故观外门耶。谓欲界所系法是外门义。除依佛教所生闻思慧及彼随法行所摄心心所等。四界二处全及余一分。欲界所摄是外门。为舍执着不离欲我故。观察外门

云何内门。几是内门。为何义故观内门耶。谓外门相违是内门义。除四界二处全及余一分是内门。为舍执着离欲我故。观察内门

云何染污。几是染污为何义故观染污耶。谓不善及有覆无记法是染污义。有覆无记者。谓遍行意相应烦恼等。及色无色界系诸烦恼等。诸蕴十界四处一分是染污。为舍执着烦恼合我故。观察染污

云何不染污。几是不染污。为何义故观不染污耶。谓善及无覆无记法是不染污义。八界八处全。诸蕴及余界处一分是不染污。为舍执着离烦恼我故。观察不染污

云何过去。几是过去。为何义故观过去耶。谓自相已生已灭故。因果已受用故。染净功用已谢故。摄因已坏故。果及自相有非有故。忆念分别相故。恋为杂染相故。舍为清净相故。是过去义。一切一分是过去。为舍执着流转我故。观察过去

云何未来。几是未来。为何义故观未来耶。谓有因非已生故。未得自相故。因果未受用故。杂染清净性未现前故。因及自相有非有故。希为杂染相故。不希为清净相故。是未来义。一切一分是未来。为舍执着流转我故。观察未来

云何现在。几是现在。为何义故观现在耶。谓自相已生未灭故因果受用未受用故。杂染清净正现前故。能显过去未来相故。作用现前故。是现在义。一切一分是现在为舍执着流转我故。观察现在

何故过去未来现在。说名言事非涅槃等。内自所证不可说故。唯曾当现是言说所依故

云何善。几是善。为何义故观善耶。谓自性故相属故。随逐故发起故。胜义故生得故。加行故现前供养故。饶益故引摄故。对治故寂静故等流故。是善义。五蕴十界四处一分是善。为舍执着法合我故。观察善。何等自性善。谓信等十一心所有法。何等相属善。谓彼相应法。何等随逐善。谓即彼诸法习气。何等发起善。谓彼所发身业语业。何等胜义善。谓真如。何等生得善。谓即彼诸善法。由先串习故感得如是报。由此自性即于是处不由思惟任运乐住。何等加行善谓依止亲近善丈夫故。听闻正法如理作意。修习净善法随法行。何等现前供养善。谓想对如来。建立灵庙图写尊容。或想对正法。书治法藏兴供养业。何等饶益善。谓以四摄事饶益一切有情。何等引摄善。谓施性福业事及戒性福业事故引摄生天乐异熟引摄生富贵家。引摄随顺清净法。何等对治善。谓厌坏对治。断对治。持对治远分对治。伏对治。离系对治。烦恼障对治。所知障对治。何等寂静善。谓永断贪欲。永断嗔恚。永断愚痴。永断一切烦恼。若想受灭。若有余依涅槃界。若无余依涅槃界。若无所住涅槃界。何等等流善。谓已得寂静者。由此增上力故。发起胜品神通等世出世共不共功德

云何不善。几是不善。为何义故观不善耶。谓自性故相属故随逐故发起故。胜义故生得故加行故现前供养故。损害故引摄故所治故障碍故。是不善义。五蕴十界四处一分是不善。为舍执着非法合我故。观察不善。何等自性不善。谓除染污意相应及色无色界烦恼等。所余能发恶行烦恼随烦恼。何等相属不善。谓即此烦恼随烦恼相应法。何等随逐不善。谓即彼习气。何等发起不善。谓彼所起身业语业。何等胜义不善。谓一切流转。何等生得不善。谓由串习不善故。感得如是异熟。由此自性即于不善任运乐住。何等加行不善。谓依止亲近不善丈夫故。听闻不正法不如理作意行身语意恶行。何等现前供养不善。谓想对归依随一天众已。或杀害意为先。或邪恶意为先。建立祠庙广兴供养业。令无量众广树非福何等损害不善。谓于一切处起身语意种种邪行。何等引摄不善。谓行身语意诸恶行已。于恶趣善趣引摄不爱果异熟。或引或满。何等所治不善。谓诸对治所对治法。何等障碍不善。谓能障碍诸善品法

云何无记。几是无记。为何义故观无记耶。谓自性故相属故。随逐故发起故。胜义故生得故。加行故现前供养故。饶益故受用故。引摄故对治故。寂静故等流故。是无记义。八界八处全及余蕴界处一分是无记。为舍执着离法非法我故。观察无记。何等自性无记。谓八色界处意相应品命根众同分名句文身等。何等相属无记。谓怀非秽非净心者。所有由名句文身所摄受心心所法。何等随逐无记。谓即彼戏论习气。何等发起无记。谓彼所摄受诸心心所法。所发身业语业。何等胜义无记。谓虚空非择灭。何等生得无记。谓诸不善有漏善法异熟。何等加行无记。谓非染非善心者。所有威仪路工巧处法。何等现前供养无记。谓如有一想对归依随一天众。远离杀害意邪恶见。建立祠庙兴供养业。令无量众于如是处不生长福非福何等饶益无记。谓如有一于自仆使妻子等所。以非秽非净心而行惠施。何等受用无记。谓如有一以无简择无染污心受用资具。何等引摄无记。谓如有一于工巧处串习故。于当来世复引摄如是相身。由此身故习工巧处速疾究竟。何等对治无记。谓如有一为治疾病得安乐故。以简择心好服医药。何等寂静无记。谓色无色界诸烦恼等。由奢摩他所藏伏故。何等等流无记。谓变化心俱生品

复有示现善不善无记法。此复云何。谓佛及得第一究竟菩萨摩诃萨。为欲饶益诸有情故有所示现。当知此中无有一法真实可得

云何欲界系。几是欲界系。为何义故观欲界系耶。谓未离欲者所有善不善无记法。是欲界系义。四界二处全及余蕴界处一分。是欲界系。为舍执着未离欲界欲我故。观察欲界系

云何色界系。几是色界系。为何义故观色界系耶。谓已离欲界欲未离色界欲者。所有善无记法。是色界系义。除前所说四界二处余蕴界处一分。是色界系。为舍执着离欲界欲我故。观察色界系

云何无色界系。几是无色界系。为何义故观无色界系耶。谓已离色界欲未离无色界欲者。所有善无记法。是无色界系义。三界二处四蕴一分。是无色界系。为舍执着离色界欲我故。观察无色界系

复次有一分离欲具分离欲通达离欲损伏离欲永害离欲。复有十种离欲。谓自性离欲。损害离欲。任持离欲。增上离欲。愚痴离欲。对治离欲。遍知离欲。永断离欲。有上离欲。无上离欲。何等自性离欲。谓于苦受及顺苦受处法生厌背性。何等损害离欲。谓习欲者畅热恼已生厌背性。何等任持离欲。谓饱食已于诸美膳生厌背性。何等增上离欲。谓得胜处已于下劣处生厌背性。何等愚痴离欲。谓诸愚夫于涅槃界生厌背性。何等对治离欲。谓由世间出世间道断诸烦恼。何等遍知离欲。谓已得见道者。于三界法生厌背性。何等永断离欲。谓永断地地诸烦恼已生厌背性。何等有上离欲。谓世间声闻独觉所有离欲。何等无上离欲。谓佛菩萨所有离欲。为欲利乐诸有情故

云何有学。几是有学。为何义故观有学耶。谓求解脱者所有善法。是有学义。十界四处诸蕴一分。是有学。为舍执着求解脱我故。观察有学

云何无学。几是无学。为何义故观无学耶。谓于诸学处已得究竟者所有善法。是无学义。为舍执着已脱我故。观察无学

云何非学非无学。几是非学非无学。为何义故观非学非无学耶。谓诸异生所有善不善无记法。及诸学者染污无记法。诸无学者无记法并无为法。是非学非无学义。八界八处全及余蕴界处一分。是非学非无学。为舍执着不解脱我故。观察非学非无学

云何见所断。几是见所断。为何义故观见所断耶。谓分别所起染污见疑见处疑处。及于见等所起邪行烦恼随烦恼及由见等所发身语意业。并一切恶趣等蕴界处。是见所断义。一切一分是见所断。为舍执着见圆满我故。观察见所断

云何修所断。几是修所断。为何义故观修所断耶。谓得见道后见所断相违诸有漏法。是修所断义。一切一分是修所断。为舍执着修圆满我故。观察修所断

云何非所断。几是非所断。为何义故观非所断耶。谓诸无漏法除顺决择分。是非所断。十界四处诸蕴一分。是非所断。为舍执着成满我故观察非所断

云何缘生。几是缘生。为何义故观缘生耶。谓相故分别支故略摄支故建立支缘故建立支业故支杂染摄故义故甚深故差别故顺逆故。是缘生义。一切皆是缘生。唯除法界法处一分诸无为法。为舍执着无因不平等因我法故观察缘生

何等相故。谓无作缘生故。无常缘生故。势用缘生故。是缘生相

何等分别支故。谓分别缘生为十二分。何等十二。谓无明行识名色六处触受爱取有生及老死

何等略摄支故。谓能引支所引支。能生支所生支。能引支者。谓无明行识。所引支者。谓名色六处触受。能生支者。谓爱取有。所生支者谓生老死

何等建立支缘故。谓习气故引发故思惟故俱有故。建立支缘随其所应

何等建立支业故。谓无明有二种业。一令诸有情于有愚痴。二与行作缘。行有二种业。一令诸有情于诸趣中种种差别。二与识作缘。由熏习故。识有二种业。一持诸有情所有业缚。二与名色作缘。名色有二种业。一摄诸有情自体。二与六处作缘。六处有二种业。一摄诸有情自体圆满。二与触作缘。触有二种业。一令诸有情于所受用境界流转。二与受作缘受有二种业。一令诸有情于所受用生果流转。二与爱作缘。爱有二种业。一引诸有情流转生死。二与取作缘。取有二种业。一为取后有。令诸有情发有取识。二与有作缘。有有二种业。一令诸有情后有现前。二与生作缘。生有二种业。一令诸有情名色六处触受次第生起。二与老死作缘。老死有二种业。一数令有情时分变异。二数令有情寿命变异何等支杂染摄故。谓若无明若爱若取。是烦恼杂染所摄。若行若识若有。是业杂染所摄。余是生杂染所摄

何等义故。谓无作者义。有因义。离有情义。依他起义。无作用义。无常义。有刹那义。因果相续不断义。因果相似摄受义。因果差别义。因果决定义。是缘起义

何等甚深故。谓因甚深故。相甚深故。生甚深故。住甚深故。转甚深故。是甚深义。又诸缘起法虽刹那灭而住可得。虽无作用缘而有功能缘可得。虽离有情而有情可得。虽无作者而诸业果不坏可得。是故甚深。又诸缘起法。不从自生。不从他生不从共生。非不自作他作因生。是故甚深

何等差别故。谓识生差别故。内死生差别故。外谷等生差别故。成坏差别故。食持差别故。爱非爱趣分别差别故。清净差别故。威德差别故。是差别义

何等顺逆故谓杂染顺逆故清净顺逆。故是说缘起顺逆义

大乘阿毗达磨集论卷第二大乘阿毗达磨集论卷第三

        无著菩萨造

        三藏法师玄奘奉　诏译

    本事分中三法品第一之三

云何缘。几是缘。为何义故观缘耶。谓因故等无间故所缘故增上故。是缘义。一切是缘。为舍执着我为因法故。观察缘何等因缘。谓阿赖耶识及善习气。又自性故差别故助伴故等行故增益故障碍故摄受故。是因缘义。自性者。谓能作因。自性差别者。谓能作因差别。略有二十种。一生能作。谓识和合望识。二住能作。谓食望已生及求生有情。三持能作。谓大地望有情。四照能作。谓灯等望诸色。五变坏能作。谓火望薪。六分离能作。谓镰等望所断。七转变能作。谓工巧智等望金银等物。八信解能作。谓烟望火。九显了能作。谓宗因喻望所成义。十等至能作。谓圣道望涅槃。十一随说能作。谓名想见。十二观待能作。谓观待此故于彼求欲生。如待饥渴追求饮食。十三牵引能作。谓悬远缘。如无明望老死。十四生起能作。谓邻近缘。如无明望行。十五摄受能作。谓所余缘。如田水粪等望谷生等。十六引发能作。谓随顺缘。如正事王令王悦豫。十七定别能作。谓差别缘。如五趣缘望五趣果。十八同事能作。谓和合缘。如根不坏境界现前。作意正起望所生识。十九相违能作。谓障碍缘。如雹望谷。二十不相违能作。谓无障碍缘。如谷无障。助伴者。谓诸法共有而生必无缺减。如四大种及所造色随其所应。等行者。谓诸法共有等行所缘必无缺减。如心心所。增益者。谓前际修善不善无记法故。能令后际善等诸法展转增胜后后生起。障碍者。谓随所数习诸烦恼故。随所有惑皆得相续增长坚固。乃令相续远避涅槃。摄受者。谓不善及善有漏法能摄受自体故

何等等无间缘。谓中无间隔。等无间故。同分异分心心所生。等无间故。是等无间缘义。何等所缘缘。谓有分齐境所缘故。无分齐境所缘故。无异行相境所缘故。有异行相境所缘故。有事境所缘故。无事境所缘故。事所缘故。分别所缘故。有颠倒所缘故。无颠倒所缘故。有碍所缘故。无碍所缘故。是所缘缘义。何等增上缘。谓任持增上故。引发增上故。俱有增上故。境界增上故。产生增上故。住持增上故。受用果增上故。世间清净离欲增上故。出世清净离欲增上故。是增上缘义

云何同分彼同分。几是同分彼同分。为何义故观同分彼同分耶。谓不离识彼相似根于境相续生故。离识自相似相续生故。是同分彼同分义。色蕴一分眼等五有色界处一分。是同分彼同分。为舍执着与识相应不相应我故。观察同分彼同分

云何执受。几是执受。为何义故观执受耶。谓受生所依色故。是执受义。色蕴一分五有色界处全及四一分。是执受。为舍执着身自在转我故。观察执受

云何根。几是根为何义故观根耶谓取境增上故。种族不断增上故。众同分住增上故受用净不净业果增上故。世间离欲增上故。出世离欲增上故。是根义。受识蕴全色行蕴一分。十二界六处全法界法处一分。是根为舍执着增上我故观察根

云何苦苦性。几是苦苦性。为何义故观苦苦性耶。谓苦受自相故。随顺苦受法自相故。是苦苦性义。一切一分是苦苦性。为舍执著有苦我故。观察苦苦性

云何坏苦性。几是坏苦性。为何义故观坏苦性耶。谓乐受变坏自相故。随顺乐受法变坏自相故。于彼爱心变坏故。是坏苦性义。一切一分是坏苦性。为舍执著有乐我故。观察坏苦性

云何行苦性。几是行苦性。为何义故观行苦性耶。谓不苦不乐受自相故。随顺不苦不乐受法自相故。彼二粗重所摄受故。不离二无常所随不安隐故。是行苦性义。除三界二处诸蕴一分。一切是行苦性。为舍执著有不苦不乐我故观察行苦性

云何有异熟。几是有异熟。为何义故观有异熟耶。谓不善及善有漏。是有异熟。十界四处诸蕴一分。是有异熟。为舍执着能舍能续诸蕴我故。观察有异熟。又异熟者。唯阿赖耶识及相应法。余但异熟生非异熟

云何食。几是食。为何义故观食耶。谓变坏故。有变坏者境界故。有境界者希望故。有希望者取故。有取者是食义。三蕴十一界五处一分是食为舍执着由食住我故。观察食。又此食差别建立略有。四种一不净依止住食。二净不净依止住食。三清净依止住食。四示现住食

云何有上。几是有上。为何义故观有上耶。谓一切有为故。无为一分故。是有上义。除法界法处一分。一切是有上。为舍执着下劣事我故。观察有上

云何无上。几是无上。为何义故观无上耶。谓无为一分故。是无上义。法界法处一分。是无上。为舍执着最胜事我故。观察无上

由此所说差别道理。余无量门可类观察。复次蕴界处差别略有三种。谓遍计所执相差别。所分别相差别。法性相差别。何等遍计所执相差别。谓于蕴界处中。遍计所执我。有情命者生者养者数取趣者意生者摩纳婆等。何等所分别相差别。谓即蕴界处法。何等法性相差别。谓即于蕴界处中我等无性无我。有性

复有四种差别。谓相差别。分别差别。依止差别。相续差别。何等相差别。谓蕴界处一一自相差别。何等分别差别。谓即于蕴界处中。实有假有。世俗有胜义有。有色无色。有见无见。如是等无量差别分别如前说。何等依止差别。谓乃至有情依止差别有尔所。当知蕴界处亦尔。何等相续差别。谓一一刹那蕴界处转。于相差别善巧为何所了知。谓了知我执过患。于分别差别善巧为何所了知。谓了知聚想过患。于依止差别善巧为何所了知。谓了知不作而得。虽作而失想过患。于相续差别善巧为何所了知。谓了知安住想过患

又蕴界处有六种差别。谓外门差别。内门差别。长时差别。分限差别。暂时差别。显示差别。何等外门差别。谓多分欲界差别。何等内门差别。谓一切定地。何等长时差别。谓诸异生。何等分限差别。谓诸有学。及除最后刹那蕴界处。所余无学。何等暂时差别谓诸无学最后刹那蕴界处。何等显示差别。谓诸佛及已得究竟菩萨摩诃萨所示现诸蕴界处

    大乘阿毗达磨集论本事分中摄品第二

云何摄。略说摄有十一种。谓相摄界摄种类摄分位摄伴摄方摄时摄一分摄具分摄更互摄胜义摄

何等相摄。谓蕴界处一一自相。即体自摄

何等界摄。谓蕴界处所有种子阿赖耶识能摄彼界

何等种类摄。谓蕴界处其相虽异。蕴义界义处义等故展转相摄

何等分位摄。谓乐位蕴界处即自相摄。苦位不苦不乐位亦尔。分位等故

何等伴摄。谓色蕴与余蕴互为伴故。即摄助伴余蕴界处亦尔

何等方摄。谓依东方诸蕴界处还自相摄。余方蕴界处亦尔

何等时摄。谓过去世诸蕴界处还自相摄。未来现在诸蕴界处亦尔

何等一分摄。谓所有法蕴界处所摄但摄一分非余。应知一分摄

何等具分摄。谓所有法蕴界处所摄。能摄全分。应知具分摄

何等更互摄。谓色蕴摄几界几处。十全一少分。受蕴摄几界几处。一少分。如受蕴想行蕴亦尔。识蕴摄几界几处。七界一处。眼界摄几蕴几处。色蕴少分一处全。如眼界耳鼻舌身色声香味触界亦尔。意界摄几蕴几处。一蕴一处。法界摄几蕴几处。三蕴全色蕴少分一处全。眼识界摄几蕴几处。识蕴意处少分。如眼识耳鼻舌身意识界亦尔。眼处摄几蕴几界。色蕴少分一界全。如眼处耳鼻舌身色声香味触处亦尔意处摄几蕴几界。一蕴七界。法处摄几蕴几界。三蕴全一少分一界全。如是诸余法以蕴界处名说。及余非蕴界处名说。如实有假有世俗有胜义有。所知所识所达。有色无色有见无见。如是等如前所显。随其所应与蕴界处更互相摄。尽当知

何等胜义摄。谓蕴界处真如所摄。于摄善巧得何胜利。得于所缘略集胜利。随彼彼境略聚其心。如是如是善根增胜

    大乘阿毗达磨集论本事分中相应品第三

云何相应。略说相应有六种。谓不相离相应。和合相应。聚集相应俱有相应。作事相应。同行相应

何等不相离相应。谓一切有方分色与极微处互不相离

何等和合相应。谓极微已上。一切有方分色更互和合

何等聚集相应。谓方分聚色展转集会

何等俱有相应。谓一身中诸蕴界处。俱时流转同生住灭

何等作事相应。谓于一所作事展转相摄。如二苾刍随一所作更互相应

何等同行相应。谓心心所于一所缘展转同行。此同行相应复有多义。谓他性相应非己性。不相违相应非相违。同时相应非异时。同分界地相应非异分界地。复有一切遍行同行相应。谓受想思触作意识。复有染污遍行同行相应。谓于染污意四种烦恼。复有非一切时同行相应。谓依止心。或时起信等善法。或时起贪等烦恼随烦恼法。复有分位同行相应。谓与乐受诸相应法。与苦受不苦不乐受诸相应法。复有无间同行相应。谓在有心位。复有有间同行相应。谓无心定所间。复有外门同行相应。谓多分欲界系心心所。复有内门同行相应。谓诸定地所有心心所。复有曾习同行相应。谓诸异生所有心心所。及有学者一分心心所。复有未曾习同行相应。谓出世间诸心心所。及初后时出世后所得诸心心所。于相应善巧得何胜利。能善了悟唯依止心。有受想等染净诸法相应不相应义。由此了悟。即能舍离计我能受能想能思能念染净执着。又能善巧速入无我

    大乘阿毗达磨集论本事分中成就品第四

云何成就。谓成就相如前所说。此差别有三种。谓种子成就。自在成就。现行成就

何等种子成就。谓若生欲界。欲色无色界系烦恼随烦恼。由种子成就故成就。及生得善。若生色界。欲界系烦恼随烦恼。由种子成就故成就。亦名不成就。色无色界系烦恼随烦恼。由种子成就故成就。及生得善。若生无色界。欲色界系烦恼随烦恼。由种子成就故成就。亦名不成就。无色界系烦恼随烦恼。由种子成就故成就。及生得善。若已得三界对治道。随如是如是品类对治已生。如此如此品类由种子成就得不成就。随如是如是品类对治未生。如此如此品类由种子成就故成就

何等自在成就。谓诸加行善法。若世出世静虑解脱。三摩地三摩钵底等。功德及一分无记法。由自在成就故成就

何等现行成就。谓诸蕴界处法。随所现前若善若不善若无记。彼由现行成就故成就。若已断善者。所有善法由种子成就故成就。亦名不成就。若非涅槃法。一阐底迦。究竟成就杂染诸法。由阙解脱因亦名阿颠底迦。以彼解脱得因必竟不成就故

于成就善巧得何胜利。能善了知诸法增减。知增减故于世兴衰离决定想。乃至能断若爱若恚

    大乘阿毗达磨集论决择分中谛品第一之一

云何决择。略说决择有四种。谓谛决择法决择得决择论议决择

云何谛决择。谓四圣谛。苦谛集谛灭谛道谛。云何苦谛。谓有情生及生所依处

何等有情生即有情世间。谓诸有情生在那落迦傍生饿鬼人天趣中。人谓东毗提诃。西瞿陀尼。南赡部洲。北俱卢洲。天谓四大王众天三十三天。夜摩天睹史多天乐变化天他化自在天。梵众天梵辅天大梵天。少光天无量光天极光净天。少净天无量净天遍净天。无云天福生天广果天。无想有情天无烦天无热天善现天善见天色究竟天。无边空处天无边识处天无所有处天非想非非想处天。何等生所依处即器世间。谓水轮依风轮。地轮依水轮。依此地轮有苏迷卢山七金山四大洲八小洲内海外海。苏迷卢山四外层级四大王众天。三十三天所居处别。外轮围山虚空宫殿。若夜摩天睹史多天化乐天他化自在天。及色界天所居处别。诸阿素洛所居处别。及诸那落迦所居处别。谓热那落迦。寒那落迦。孤独那落迦。及一分傍生饿鬼所居处别。乃至一日一月周遍流光所照方处名一世界。如是千世界中有千日千月千苏迷卢山王千四大洲千四大王众天千三十三天千夜摩天千睹史多天千乐变化天千他化自在天千梵世天。如是总名小千世界。千小千界总名第二中千世界。千中千界总名第三大千世界。如此三千大千世界。总有大轮围山周匝围绕。又此三千大千世界同坏同成。譬如天雨滴如车轴。无间无断从空下注。如是东方无间无断无量世界。或有将坏。或有将成。或有正坏或坏已住。或有正成或成已住。如于东方乃至一切十方亦尔。若有情世间若器世间。业烦恼力所生故。业烦恼增上所起故。总名苦谛

复有清净世界。非苦谛摄。非业烦恼力所生故。非业烦恼增上所起故。然由大愿清净善根增上所引。此所生处不可思议。唯佛所觉。尚非得静虑者静虑境界。况寻思者

复次苦相差别有八。谓生苦老苦病苦死苦怨憎会苦爱别离苦求不得苦。略摄一切五取蕴苦。生何因苦。众苦所逼故。余苦所依故。老何因苦。时分变坏苦故。病何因苦。大种变异苦故。死何因苦。受命变坏苦故。怨憎会何因苦。合会生苦故。爱别离何因苦。别离生苦故。求不得何因苦。所悕不果生苦故。略摄一切。五取蕴何因苦。粗重苦故。如是八种略摄为六。谓逼迫苦转变苦合会苦别离苦所悕不果苦粗重苦。如是六种广开为八。若六若八平等平等。如说三苦。此中八苦。为三摄八八摄三耶。展转相摄。所谓生苦老苦病苦死苦怨憎会苦。能显苦苦。爱别离苦求不得苦。能显坏苦。略摄一切五取蕴苦。能显行苦。如说二苦。谓世俗谛苦。胜义谛苦。何者世俗谛苦。何者胜义谛苦。谓生苦乃至求不得苦。是世俗谛苦。略摄一切五取蕴苦。是胜义谛苦

云何苦谛共相。谓无常相苦相空相无我相。何等无常相。略有十二。谓非有相坏灭相变异相别离相现前相法尔相刹那相相续相病等相种种心行转相资产兴衰相器世成坏相。何等非有相。谓蕴界处于一切时我我所性常非有故

何等坏灭相。谓诸行生已即灭。暂有还无故。何等变异相。谓诸行异生由不相似相续转故

何等别离相。谓于诸行失增上力。或他所摄执为己有。何等现前相。谓正处无常由因随逐今受无常故

何等法尔相。谓当来无常由因随逐定当受故

何等刹那相。谓诸行刹那后必不住故。何等相续相。谓无始时来诸行生灭相续不断故

何等病等相。谓四大时分受命变异故。何等种种心行转相。谓于一时起有贪心。或于一时起离贪心。如是有嗔离嗔有痴离痴。若合若散若下若举。若掉离掉。若不寂静若寂静。若定不定。如是等心行流转故

何等资产兴衰相。谓诸兴善终归衰变故。何等器世成坏相。谓火水风三种成坏有三灾。顶谓第二第三第四静虑。第四静虑外宫殿等。虽无外灾成坏。然彼诸天与宫殿等俱生俱灭说有成坏。复有三种中劫。所谓饥馑疫病刀兵。此小三灾劫究竟位方乃出现。谓世界成已。一中劫初唯减。一中劫后唯增。十八中劫亦增亦减。二十中劫世界正坏。二十中劫世界坏已住。二十中劫世界正成。二十中劫世界成已住。合此八十中劫为一大劫。由此劫数显色无色界诸天寿量。如说以寿尽故福尽故业尽故。彼彼有情从彼彼处没。云何寿尽。谓时死。云何福尽。谓非时死即非福死。以彼有情贪着定味。福力减尽因此命终。云何业尽。谓顺生受业顺后受业俱尽故死

何等苦相。谓或三苦或八苦或六苦。广说如前。是名苦相。何故经说若无常者即是苦耶。由二分无常为缘苦相可了知故。谓生分无常为缘。苦苦性可了知故灭分无常为缘。坏苦性可了知故。俱分无常为缘。行苦性可了知故。即依此义薄伽梵说。诸行无常诸行变坏。又依此义言。诸所有受我说皆苦。又于生灭二法所随诸行中。有生等八苦。性可了知故。佛说言。若无常者即是苦。又于无常诸行中。有生等苦可了知者。如来依此密意说言。由无常故苦非一切行

何等空相。谓若于是处此非有。由此理正观为空。若于是处余是有。由此理如实知有。是名善入空性。如实知者不颠倒义。于何处谁非有于蕴界处常恒凝住。不变坏法我我所等非有。由此理彼皆是空。于何处谁余有。即此处无我性。此我无性无我有性。是谓空性。故薄伽梵密意说言。有如实知有。无如实知无。复有三种空性。谓自性空性。如性空性。真性空性。初依遍计所执自性观。第二依依他起自性观第三依圆成实自性观

何等无我相。谓如我论者所立我相蕴界处非此相。由蕴界处我相无故。名无我相。故薄伽梵密意说言。一切法皆无我。如世尊说。此一切非我所。此非我处此非我我。于如是义应以正慧如实观察。此言何义。谓于外事密意说此一切非我所。于内事密意说此非我处此非我我。所以者何。以于外事唯计我所相。是故但遣我所。于内事通计我我所相。是故双遣我我所

前说无常皆刹那相。此云何知。如心心所是刹那相。当知色等亦刹那相。由心执受故。等心安危故。随心转变故。是心所依故。心增上生故。心自在转故。又于最后位变坏可得故。生已不待缘自然灭坏故当观色等亦念念灭

如世尊说。诸所有色。彼一切若四大种若四大种所造。此依何意说依容有意。说同在一处。依此而有是造义。若于此聚此大种可得。当知此聚唯有此大种非余。或有聚唯一大种。或有二大种。或有乃至一切大种。所造色亦尔。若于此聚此所造色可得。当知此聚唯此非余。或有聚唯一所造色。或二所造色。或有乃至多所造色随其所应

又说粗聚色极微集所成者。当知此中极微无体。但由觉慧渐渐分析细分损减。乃至可析边际。即约此际建立极微。为遣一合想故。又为悟入诸所有色非真实故

复次苦法略有八种差别。谓有广大不寂静苦。有寂静苦。有寂静不寂静苦。有中不寂静苦。有微薄不寂静苦。有微薄寂静苦。有极微薄寂静苦。有非苦似苦住大寂静。云何广大不寂静苦。谓生欲界未曾积集诸善根者。云何寂静苦。谓即此已生顺解脱分善根者。云何寂静不寂静苦。谓即此为世间道离欲已种善根者。云何中不寂静苦。谓生色界远离顺解脱分者。云何微薄不寂静苦。谓生无色界远离顺解脱分者。云何微薄寂静苦。谓诸有学。云何极微薄寂静苦。谓诸无学命根住缘六处。云何非苦似苦住大寂静。谓已得究竟菩萨摩诃萨等。乘大悲愿力故生诸有中。复次前说死苦。死有三种。谓或善心死。或不善心死。或无记心死。善心死者。谓于明利心现行位。或由自善根力所持故。或由他所引摄故。发起善心趣命终位。不善心死者。谓亦于明利心现行位。或由自不善根力所持故。或由他所引摄故。起不善心趣命终位。无记心死者。谓若于明利心现行位。若于不明利心现行位。或由阙二缘故。或由加行无功能故。起无记心趣命终位

修净行者临命终位。于身下分先起冷触。不净行者临命终位。于身上分先起冷触。不净行者中有生时。其相显现如黑羊羔光。或如阴暗夜分。修净行者中有生时。其相显现如白练光。或如晴夜分

又此中有在欲色界正受生位。亦从无色界命终后位。亦名意生健达缚等。极住七日或中夭。或时移转

住中有中。亦能集诸业。先串习力所引善等。思现行故。又能睹见同类有情。又中有形似当生处。又此中有所趣无碍。如具神通往来迅速。仍于生处有所拘碍。又此中有于所生处。如秤两头低昂道理。终没结生时分亦尔。住中有中于所生处发起贪爱。亦用余烦恼为缘助。此中有身与贪俱灭。羯逻蓝身与识俱生。此唯是异熟。自此已后根渐生长。如缘起中说。于四生类或受卵生。或受胎生。或受湿生。或受化生

大乘阿毗达磨集论卷第三大乘阿毗达磨集论卷第四

        无著菩萨造

        三藏法师玄奘奉　诏译

    决择分中谛品第一之二

云何集谛。谓诸烦恼及烦恼增上所生诸业。俱说名集谛。然薄伽梵随最胜说。若爱若后有爱。若喜贪俱行爱。若彼彼喜乐爱。是名集谛。言最胜者是遍行义。由爱具有六遍行义。是故最胜。何等为六。一事遍行。二位遍行。三世遍行。四界遍行。五求遍行。六种遍行

云何烦恼。谓由数故相故缘起故境界故相应故差别故邪行故界故众故断故。观诸烦恼

何等数故。谓或六或十六。谓贪嗔慢无明疑。见十谓前五见又分五。谓萨迦耶见边执见邪见见取戒禁取

何等相故。谓若法生时相不寂静。由此生故身心相续不寂静转。是烦恼相

何等缘起故。谓烦恼随眠未永断故。顺烦恼法现在前故。不正思惟现前起故。如是烦恼方乃得生。是名缘起

何等境界故。谓一切烦恼还用一切烦恼为所缘境。及缘诸烦恼事。又欲界烦恼除无明见疑。余不能缘上地为境。上地诸烦恼不能缘下地为境。已离彼地欲故。又缘灭道谛诸烦恼。不能亲缘灭道为境。唯由依彼妄起分别说为所缘。又烦恼有二种。谓缘无事及缘有事。缘无事者。谓见及见相应法。所余烦恼名缘有事

何等相应故。谓贪不与嗔相应。如嗔疑亦尔。余皆得相应。如贪嗔亦尔。谓嗔不与贪慢见相应。慢不与嗔疑相应。无明有二种。一一切烦恼相应无明。二不共无明。不共无明者。谓于谛无智。见不与嗔疑相应。疑不与贪慢见相应。忿等随烦恼更互不相应。无惭无愧于一切不善品中恒共相应。惛沉掉举不信懈怠放逸。于一切染污品中恒共相应

何等差别故。谓诸烦恼依种种义立种种门差别。所谓结缚随眠随烦恼缠暴流轭取系盖株杌垢烧害箭所有恶行漏匮热恼诤炽然稠林拘碍等

结有几种。云何结。何处结耶。结有九种。谓爱结恚结慢结无明结见结取结疑结嫉结悭结

爱结者。谓三界贪爱结所系故不厌三界。由不厌故广行不善不行诸善。由此能招未来世苦。与苦相应

恚结者。谓于有情苦及顺苦法心有损害。恚结所系故。于恚境相心不弃舍。不弃舍故广行不善不行诸善。由此能招未来世苦。与苦相应

慢结者。即七慢。谓慢过慢慢过慢我慢增上慢下劣慢邪慢。慢者。谓于下劣计己为胜。或于不相似计己相似。心举为性。过慢者。谓于相似计己为胜。或复于胜计己相似。心举为性。慢过慢者。谓于胜己计己为胜。心举为性。我慢者。谓于五取蕴观我我所。心举为性。增上慢者。谓于未得上胜证法。计己已得上胜证法。心举为性。下劣慢者。谓于多分胜计己少分劣。心举为性。邪慢者。谓实无德计己有德。心举为性。慢结所系故。于我我所不能了。知不了知故执我我所。广行不善不行诸善。由此能招未来世苦。与苦相应

无明结者。谓三界无智无明结所系故。于苦法集法不能解了。不解了故广行不善不行诸善。由此能招未来世苦。与苦相应

见结者。即三见。谓萨迦耶见边执见邪见。见结所系故。于邪出离妄计追求妄兴执着。于邪出离妄执着已。广行不善不行诸善。由此能招未来世苦。与苦相应

取结者。谓见取戒禁取。取结所系故。于邪出离方便妄计执着。以妄执着邪出离方便故。广行不善不行诸善。由此能招未来世苦。与苦相应

疑结者。谓于谛犹豫。疑结所系故。于佛法僧宝妄生疑惑。以疑惑故于三宝所不修正行。以于三宝所不修正行故。广行不善不行诸善。由此能招未来世苦。与苦相应

嫉结者。谓耽着利养不耐他荣发起心妒。嫉结所系故。爱重利养不尊敬法。重利养故。广行不善不行诸善。由此能招未来世苦。与苦相应

悭结者。谓耽着利养于资生具其心吝惜。悭结所系故。爱重畜积不尊远离重畜积故。广行不善不行诸善。由此能招未来世苦。与苦相应

缚有三种。谓贪缚嗔缚痴缚。由贪缚故缚诸有情令处坏苦。由嗔缚故缚诸有情令处苦苦。由痴缚故缚诸有情令处行苦。又依贪嗔痴故。于善加行不得自在。故名为缚

随眠有七。谓欲爱随眠嗔恚随眠有爱随眠慢随眠无明随眠见随眠疑随眠。欲爱随眠者。谓欲贪品粗重。嗔恚随眠者。谓嗔恚品粗重。有爱随眠者。谓色无色贪品粗重。慢随眠者。谓慢品粗重。无明随眠者。谓无明品粗重。见随眠者。谓见品粗重。疑随眠者。谓疑品粗重。若未离欲求者。由欲爱嗔恚随眠之所随增。未离有求者。由有爱随眠之所随增。未离邪梵行求者。由慢无明见。疑随眠之所随增。由彼众生得少对治便生憍慢。愚于圣谛。虚妄计度外邪解脱解脱方便。于佛圣教正法毗柰耶中。犹豫疑惑

随烦恼者。谓所有诸烦恼皆是随烦恼。有随烦恼非烦恼。谓除烦恼。所余染污行蕴所摄一切心所法。此复云何。谓除贪等六烦恼。所余染污行蕴所摄忿等诸心所法。又贪嗔痴名随烦恼。心所法由此随烦恼随恼于心。令不离染。令不解脱。令不断障。故名随烦恼。如世尊说。汝等长夜为贪嗔痴随所恼乱心恒染污

缠有八种。谓惛沉睡眠掉举恶作嫉悭无惭无愧。数数增盛缠绕于心故名为缠。谓随修习止举舍相。及彼所依梵行等所摄净尸罗时。缠绕于心

暴流有四。谓欲暴流有暴流见暴流无明暴流。随流漂鼓是暴流义。随顺杂染故。初是习欲求者。第二是习有求者。后二是习邪梵行求者。能依所依相应道理故

轭有四种。谓欲轭有轭见轭无明轭。障碍离系是轭义。违背清净故。此亦随其次第习三求者相应现行

取有四种。谓欲取见取戒禁取我语取。执取诤根执取后有。是取义所以者何。由贪着欲系缚耽染为因。诸在家者更相斗诤。此诤根本是第一取。由贪着见系缚耽染为因。诸出家者更相斗诤。此诤根本是后三取。六十二见趣。是见取。各别禁戒多分苦行。是戒禁取。彼所依止萨迦耶见。是我语取。由见取戒禁取。诸外道辈更相诤论。由我语取诸外道辈互无诤论。与正法者互有诤论。如是执着诤论根本。复能引取。后有苦异熟。故名为取

系有四种。谓贪欲身系。嗔恚身系戒禁取身系。此实执取身系。以能障碍定意性身故名为系。所以者何。能为四种心乱因故。谓由贪爱财物等因令心散乱。于斗诤事不正行为因令心散乱。于难行戒禁苦恼为因令心散乱。不如正理推求境界为因令心散乱

盖有五种。谓贪欲盖。嗔恚盖。惛沉睡眠盖。掉举恶作盖。疑盖。能令善品不得显了。是盖义。谓于乐出家位觉邪行位止举舍位

株杌有三。谓贪株杌嗔株杌痴株杌。由依止贪嗔痴。先所串习为方便故。成贪等行心不调顺。无所堪能难可解脱。令诸有情难断此行。故名株杌

垢有三种。谓贪垢嗔垢痴垢由依止贪嗔痴故。毁犯如是尸罗学处。由此有智同梵行者。或于聚落或闲静处。见已作如是言。此长老作如是事行如是行。为聚落刺点染不净。说名为垢

烧害有三。谓贪烧害嗔烧害痴烧害。由依止贪嗔痴故。长时数受生死烧恼。故名烧害

箭有三种。谓贪箭嗔箭痴箭。由依止贪嗔痴故。于有有具深起追求相续不绝。于佛法僧苦集灭道常生疑惑。故名为箭

所有有三。谓贪所有嗔所有痴所有。由依止贪嗔痴故。积畜财物有怖有怨多住散乱。故名所有

恶行有三。谓贪恶行嗔恶行痴恶行。由依止贪嗔痴故。恒行身语意恶行。故名恶行。又即依此贪嗔痴门。广生无量恶不善行故。建立三不善根。所以者何。以诸有情爱味世间所有为因行诸恶行。分别世间怨相为因行诸恶行。执着世间邪法为因行诸恶行。是故此贪嗔痴。亦名恶行。亦名不善根

漏有三种。谓欲漏有漏无明漏。令心连注流散不绝。故名为漏。此复云何。依外门流注故立欲漏。依内门流注故立有漏。依彼二所依门流注故立无明漏

匮有三种。谓贪匮嗔匮痴匮。由依止贪嗔痴故。于有及资生具恒起追求无有厌足。常为贫乏众苦所恼。是故名匮

热有三种。谓贪热嗔热痴热。由依止贪嗔痴故。不如正理执着诸相执着随好。由执着相及随好故烧恼身心。故名为热

恼有三种。谓贪恼嗔恼痴恼。由依止贪嗔痴故。随彼彼处爱乐耽着。彼若变坏便增愁叹。种种忧苦热恼所触。故名为恼

诤有三种。谓贪诤嗔诤痴诤。由依止贪嗔痴故。执持刀杖兴诸战诤种种斗讼。是故贪等说名为诤

炽然有三。谓贪炽然嗔炽然痴炽然。由依止贪嗔痴故。为非法贪大火所烧。不平等贪大火所烧。及为邪法大火所烧。故名炽然

稠林有三。谓贪稠林嗔稠林痴稠林。由依止贪嗔痴故。于诸生死根本行中广兴染着。令诸有情感种种身流转五趣。是故贪等说名稠林

拘碍有三。谓贪拘碍嗔拘碍痴拘碍。由依止贪嗔痴故。顾恋身财无所觉了乐处愦闹。得少善法便生厌足。由此不能修诸善法。故名拘碍

诸如是等烦恼义门差别无量

何等邪行故。谓贪嗔二烦恼。迷境界及见起邪行慢。迷有情及见。起邪行萨迦耶见边执见邪见。迷所知境起邪行见取戒禁取。迷诸见起邪行疑。迷对治起邪行无明。迷一切起邪行。又十烦恼皆迷苦集起诸邪行。是彼因缘所依处故。又十烦恼皆迷灭道起诸邪行。由此能生彼怖畏故

何等界故。谓除嗔余一切通三界系。嗔唯欲界系

又贪于欲界与乐喜舍相应。如于欲界于初二静虑亦尔。于第三静虑与乐舍相应。已上唯与舍相应。嗔与苦忧舍相应。慢于欲界与喜舍相应。于初二静虑与乐喜舍相应。于第三静虑与乐舍相应。已上唯舍相应。如慢萨迦耶见边执见见取戒禁取亦尔。邪见于欲界与忧喜舍相应。于色无色界随所有受皆与相应。疑于欲界与忧舍相应。于色无色界随所有受皆与相应。无明有二种。谓相应不共。相应无明。一切烦恼相应故。若于是处随所有受皆得相应。不共无明。于欲界与忧舍相应。于上界随所有受皆得相应。何故诸烦恼皆与舍相应。以一切烦恼堕中庸位方息没故。又贪于欲界在六识身。如贪嗔无明亦尔。贪于色界在四识身。于无色界在意识身。如贪无明亦尔。慢见疑于一切处在意识身。又贪嗔慢于欲界缘一分事转。如于欲界于色无色界亦尔。所余烦恼于一切处遍缘一切事转

何等众故。谓二众烦恼。一见所断众。二修所断众。见所断众复有四种。一见苦所断众。二见集所断众。三见灭所断众。四见道所断众。欲界见苦所断具十烦恼。如见苦所断见集灭道所断亦尔。色界见苦等四种所断。各九烦恼除嗔。如色界无色界亦尔。如是见所断烦恼众。总有一百一十二烦恼。欲界修所断有六烦恼。谓俱生萨迦耶见边执见。及贪嗔慢无明。色界修所断有五烦恼除嗔。如色界无色界亦尔。如是修所断烦恼众。总有十六烦恼

何等断故。谓如此差别断由此作意断从此而得断。如此差别断者谓遍智故远离故得对治故。遍智者。谓彼因缘事遍智自体遍智过患遍智。远离者。虽彼暂生而不坚执。得对治者。谓未生者令不生故。已生者令断故。得对治道。由此作意断者。何等作意能断耶。总缘作意观一切法皆无我性。能断烦恼无常等行。但为修治无我行故。从此而得断者。从何而得断耶。不从过去已灭故。不从未来未生故。不从现在道不俱故。然从诸烦恼粗重而得断为断。如是如是品粗重生。如是如是品对治若此品对治生。即此品粗重灭。平等平等。犹如世间明生暗灭。由此品离系故。令未来烦恼住不生法中。是名为断

云何烦恼增上所生诸业。谓若思业若思已业。总名业相。又有五种业。一取受业。二作用业。三加行业。四转变业。五证得业。今此义中意多分别加行业

何等思业。谓福业非福业不动业

何等思已业。谓身业语业意业

又此身语意三业。或善或不善。不善者即十不善业道。谓杀生不与取欲邪行虚诳语离间语粗恶语杂秽语贪欲嗔恚邪见。善者即十善业道。谓离杀生离不与取离欲邪行离虚诳语离离间语离粗恶语离杂秽语无贪无嗔正见

又杀生等应以五门分别其相。谓事故意乐故方便故烦恼故究竟故

如契经言故思造业。云何名为故思造业。谓他所教敕故思造业。他所劝请故思造业。无所了知故思造业。根本执着故思造业。颠倒分别故思造业。此中根本执着故思造业。颠倒分别故思造业。若作若增长非不受异熟。作者。谓起造诸业令其现行。增长者。谓令习气增益

如契经言决定受业。云何名为决定受业。谓作业决定。受异熟决定分位决定

十不善业道异熟果者。于三恶趣中随下中上品。受傍生饿鬼那落迦异熟。等流果者。各随其相于人趣中感得自身众具衰损增上果者。各随其相感得所有外事衰损。广说如经

十善业道异熟果者。于人天趣中受人天异熟。等流果者。即于彼处各随其相。感得自身众具兴盛。增上果者。即于彼处各随其相。感得所有外事兴盛

善不善业。于善趣恶趣中感生异熟时。有招引业圆满业。招引业者。谓由此业能感异熟果。圆满业者。谓由此业生已领受爱不爱果。或有业由一业力牵得一身。或有业由一业力牵得多身。或有业由多业力牵得一身。或有业由多业力牵得多身。若一有情成就多业。云何次第受异熟果。于彼身中重者先熟。或将死时现在前者。或先所数习者。或最初所行者。彼异熟先熟

如契经言。有三种业。谓福业非福业不动业。何等福业。谓欲界系善业。何等非福业。谓不善业。何等不动业谓色无色界系善业

如契经说。无明缘行。若福非福及与不动。云何福及不动行缘无明生。有二种愚。一异熟果愚。二真实义愚。由异熟果愚故发非福行。由真实义愚故发福及不动行

杀生业道贪嗔痴为方便。由嗔究竟。如杀生粗恶语嗔恚业道亦尔。不与取业道贪嗔痴为方便。由贪究竟。如不与取欲邪行贪欲业道亦尔。虚诳语业道贪嗔痴为方便。于三种中随由一究竟。如虚诳语离间语杂秽语业道亦尔。邪见业道贪嗔痴为方便。由痴究竟

如契经言。有共业。有不共业。有强力业。有劣力业。云何共业。若业能令诸器世间种种差别。云何不共业。若业能令有情世间种种差别。或复有业。令诸有情展转增上。由此业力说诸有情更互相望为增上缘。以彼互有增上力故。亦名共业。是故经言。如是有情与余有情互相见等。而不受用不易可得。云何强力业。谓对治力强补特伽罗故。思所造诸不善业。由对治力所摄伏故。令当受那落迦业转成现法受。应现法受业转令不受。所以此业名强力者。由能对治业力强故。又故思所造一切善业皆名强力。依此业故薄伽梵说。我圣弟子能以无量广大之业善熏其心。诸所造作有量之业。不能牵引不能留住。亦不能令堕在彼数。又对治力劣补特伽罗故。思所造诸不善业。望诸善业皆名强力。又故思造业异熟决定不断不知。名强力业。此中意说。一切善不善业异熟决定。圣道力不断者。皆名强力业。又欲界系诸不善业性皆是强力。又先所串习名强力业。又依强位名强力业。又不可治者。所造诸业名强力业。无涅槃法故。又由田故发强力业又由心加行故发强力业。又由九种因发强力业。谓由田故事故自体故所依故作意故意乐故助伴故多修习故与多众生共所行故。与此相违是劣力。业如世尊说。若有说言。彼彼丈夫补特伽罗。随如是如是业。若作若增长还受如是如是异熟。若有是事便不应修清净梵行。亦不可知正尽诸苦作苦边际。若有说言。彼彼丈夫补特伽罗。随如是如是顺所受业。若作若增长。还受如是如是顺所受异熟。若有是事便应修习清净梵行。又亦可知正尽诸苦作苦边际。如是经言有何密意。此中佛意为欲遮止如是邪说。谓乐俱行业。还能感得乐俱行异熟。苦俱行业。还能感得苦俱行异熟。不苦不乐俱行业。还能感得不苦不乐俱行异熟。故作是说。又为开许如是正说。谓乐俱行业顺乐受者。还受乐异熟。顺苦受者。还受苦异熟。顺不苦不乐受者。还受不苦不乐异熟。苦俱行业顺乐受者。还受乐异熟。顺苦受者。还受苦异熟。顺不苦不乐受者。还受不苦不乐异熟。不苦不乐俱行业顺乐受者。还受乐异熟。顺苦受者。还受苦异熟。顺不苦不乐受者。还受不苦不乐异熟。如是名为此经密意。又业差别有三种。谓律仪业。不律仪业。非律仪非不律仪业

云何律仪业。谓别解脱律仪所摄业。静虑律仪所摄业。无漏律仪所摄业。别解脱律仪所摄业者。即是七众所受律仪。谓苾刍律仪。苾刍尼律仪。式叉摩那律仪。勤策律仪。勤策女律仪。邬波索迦律仪。邬波斯迦律仪。及近住律仪。依止何等补特伽罗建立出家律仪。依能修行远离恶行。远离欲行补特伽罗。依止何等补特伽罗建立邬波索迦律仪邬波斯迦律仪。依能尽受远离恶行。不远离欲行补特伽罗。依止何等补特伽罗建立近住律仪。依止不能远离恶行。及不能远离欲行补特伽罗。若唯修学邬波索迦一分学处为说成就。邬波索迦律仪为说不成就。应说成就而名犯戒。扇搋半择迦等。为遮彼受邬波索迦律仪不耶。不遮彼受邬波索迦律仪。然遮彼邬波索迦性。不堪亲近承事苾刍苾刍尼等二出家众故。又半择迦有五种。谓生便半择迦。嫉妒半择迦。半月半择迦灌洒半择迦。除去半择迦

静虑律仪所摄业者。谓能损伏发起犯戒烦恼种子。离欲界欲者所有远离。离初静虑欲者所有远离。离第二静虑欲者所有远离。离第三静虑欲者所有远离。是名静虑律仪所摄身语业

无漏律仪所摄业者。谓以见谛者由无漏作意力。所得无漏远离戒性。是名无漏律仪所摄业

云何不律仪业。谓诸不律仪者。或由生彼种姓中故。或由受持彼事业故。所期现行彼业决定。何等名为不律仪者。所谓屠羊养鸡养猪捕鸟捕鱼猎鹿罝兔劫贼魁脍控牛缚象立坛咒龙守狱谗构好为损等

云何非律仪非不律仪业。谓住非律仪非不律仪者。所有善不善业

又业差别有三种。谓顺乐受业。顺苦受业。顺不苦不乐受业。顺乐受业者。谓从欲界乃至第三静虑所有善业。顺苦受业者。谓不善业。顺不苦不乐受业者。谓第三静虑已上所有善业

又业差别有三种。谓顺现法受业。顺生受业。顺后受业。顺现法受业者。若业于现法中异熟成熟。谓从慈定起已。于彼造作若损若益必得现异熟。如从慈定起。从无诤定起。从灭定起。从预流果起。从阿罗汉果起亦尔。又于佛为上首僧中造善恶业必得现异熟。又有余猛利意乐方便。所行善不善业亦得现异熟。顺生受业者。若业于无间生中异熟成熟。谓五无间业。复有所余善不善业。于无间生异熟熟者。一切皆名顺生受业。顺后受业者。若业于无间生。后异熟成熟。是名顺后受业。又业差别有四种。谓黑黑异熟业。白白异熟业。黑白黑白异熟业。非黑白无异熟业能尽诸业。黑黑异熟业者。谓不善业。白白异熟业者。谓三界善业。黑白黑白异熟业者。谓欲界系杂业。或有业意乐故黑方便故白。或有业。方便故黑意乐故白。非黑白无异熟业能尽诸业者。谓于加行无间道中诸无漏业

总约一切无漏业。所有障碍随顺体性。如其次第建立。曲秽浊等诸染污业。净牟尼等诸清净业

复有施等诸清净业。云何施业。谓因缘故等起故处所故。自体故。分别施业。因缘者。谓无贪无嗔无痴善根。等起者。谓彼俱行思处所者。谓所施物自体者。谓正行施时身语意业。云何施圆满。谓数数施故。无偏党施故。随其所欲圆满施故。施得圆满。又无所依施故广清净施故。极欢喜施故。数数施故田器施故。善分布新旧施故。施得圆满

云何应知施物圆满。谓所施财物非诳诈得故。所施财物非侵他得故。所施财物非秽离垢故。所施财物清净故。所施财物如法所引故。如是应知施物圆满

如契经说。成就尸罗。善能防护别解脱律仪。轨则所行皆悉圆满。见微细罪生大怖畏。于诸学处善能受学。云何成就尸罗。能受能护净尸罗故。云何善能防护别解脱律仪。能善护持出离尸罗故。云何轨则所行皆悉圆满。具净尸罗难为毁责故。云何见微细罪生大怖畏。勇猛恭敬所学尸罗故。云何于诸学处善能受学圆满。受学所学尸罗故

从是已后依止尸罗。释佛经中护身等义。云何名为防护身语。由彼正解所摄持故。云何身语具足圆满。终不毁犯所毁犯故。云何身语清净现行。由无悔等渐次修行。乃至得定为依止故。云何身语极善现行。染污寻思所不杂故。云何身语无罪现行。远离邪愿修梵行故。云何身语无害现行。不轻陵他易共住故。云何身语随顺现行。由能随顺涅槃得故。云何身语随隐显现行。隐善显恶故。云何身语亲善现行。同梵行者摄受尸罗故。云何身语应仪现行。于尊尊位离憍慢故。云何身语敬顺现行。于尊教诲敬顺受故。云何身语无热现行。远离苦行热恼下劣欲解故。云何身语不恼现行。弃舍财业无悔恼故。云何身语无悔现行。虽得少分不以为喜而无悔恨故。如世尊说。如是有情皆由自业。业所乖诤。从业所生依业出离业能分别一切有情高下胜劣。云何有情皆由自业。由自造业而受异熟故

云何业所乖诤。于受自业所得异熟时。善不善业互违诤故。云何从业所生。是诸有情远离无因恶因。唯从业所生故。云何依业出离。依对治业解业缚故。云何由业有情高下。谓犹业故于善恶趣得自体差别。云何胜劣。谓诸有情成就功德过失差别

如世尊说有情业异熟不可思议。云何业异熟可思议。云何业异熟不可思议。谓诸善业于人天趣得可爱异熟。是可思议。诸不善业堕三恶趣得不爱异熟。是可思议。即由此业感诸有情自身异熟等种种差别。不可思议。又即善不善业。处差别事差别因差别异熟差别品类差别等。皆不可思议。复有种种外事差别。能感业用不可思议。又末尼珠药草咒术相应业用不可思议。又诸观行者威德业用不可思议。又诸菩萨自在业用不可思议。所谓命自在故。心自在故。财自在故。业自在故。生自在故。胜解自在故。愿自在故。神通自在故。智自在故。法自在故。诸大菩萨由如是等自在力故。所作业用不可思议。又一切佛所作诸佛应所作事业用不可思议。如是集谛总有四种行相差别。谓因相集相生相缘相。云何因相。谓能引发复有习气因。是名因相。云何集相。谓彼彼有情所集习气。于彼彼有情类为等起因。是名集相。云何生相。谓各别内身无量品类差别生因。是名生相。云何缘相。谓诸有情别别得舍因。是名缘相

大乘阿毗达磨集论卷第四大乘阿毗达磨集论卷第五

        无著菩萨造

        三藏法师玄奘奉　诏译

    决择分中谛品第一之三

云何灭谛。谓相故甚深故世俗故。胜义故不圆满故圆满故无庄严故。有庄严故。有余故。无余故。最胜故。差别故分别灭谛

何等相故。谓真如圣道烦恼不生。若灭依若能灭若灭性。是灭谛相。如世尊说。眼耳及与鼻舌身及与意。于此处名色究竟灭无余。又说。是故汝今当观是处。所谓此处眼究竟灭远离色想。乃至意究竟灭远离法想。由此道理显示所缘。真如境上有漏法灭。是灭谛相。何等甚深故。谓彼诸行究竟寂灭。如是寂灭望彼诸行。不可说异。不可说不异。不可说亦异亦不异。不可说非异非不异。所以者何。无戏论故。于此义中若生戏论。非正思议非道非如。亦非善巧方便思故。如世尊说。此六触处尽离欲灭寂静没等。若谓有异。若谓无异。若谓亦有异亦无异。若谓非有异非无异者。于无戏论便生戏论。乃至有六处可有诸戏论。六处既灭绝诸戏论即是涅槃

何等世俗故。谓以世间道摧伏种子所得灭。是故世尊别名说为彼分涅槃

何等胜义故谓以圣慧永拔种子所得灭。何等不圆满故。谓诸有学。或预流果摄。或一来果摄。或不还果摄等所有灭

何等圆满故。谓诸无学阿罗汉果摄等所有灭

何等无庄严故。谓慧解脱阿罗汉所有灭。何等有庄严故。谓俱分解脱三明六通阿罗汉等所有灭

何等有余故。谓有余依灭

何等无余故。谓无余依灭

何等最胜故。谓佛菩萨无住涅槃摄所有灭。以常安住一切有情利乐事故

何等差别故。谓无余永断永出永吐尽离欲灭寂静没等。何故名无余永断。由余句故。何故名永出。永出诸缠故。何故名永吐。永吐随眠故。何故名尽。见道对治得离系故。何故名离欲。修道对治得离系故。何故名灭。当来彼果苦不生故。何故名寂静。于现法中彼果心苦永不行故。何故名没。余所有事永灭没故。何故此灭复名无为。离三相故。何故此灭复名难见。超过肉眼天眼境故。何故此灭复名不转。永离诸趣差别转故。何故此灭名不卑屈离三爱故。何故此灭复名甘露。离蕴魔故。何故此灭复名无漏。永离一切烦恼魔故。何故此灭复名舍宅。无罪喜乐所依事故。何故此灭复名洲渚。三界隔绝故。何故此灭复名弘济。能遮一切大苦灾横故。何故此灭复名归依。无有虚妄意乐方便所依处故。何故此灭名胜归趣。能为归趣一切最胜圣性所依处故。何故此灭复名不死。永离生故。何故此灭名无热恼永离一切烦恼热故。永离一切求不得苦大热恼故。何故此灭名无炽然。永离一切愁叹忧苦诸恼乱故。何故此灭复名安隐。离怖畏住所依处故。何故此灭复名清凉。诸利益事所依处故。何故此灭复名乐事。第一义乐事故。何故此灭名趣吉祥。为证得彼易修方便所依处故。何故此灭复名无病。永离一切障碍病故。何故此灭复名不动。永离一切散动故。何故此灭复名涅槃。无相寂灭大安乐住所依处故。何故此灭复名无生。离续生故。何故此灭复名无起。永离此后渐生起故。何故此灭复名无造。永离前际诸业烦恼势力所引故。何故此灭复名无作。不作现在诸业烦恼所依处故。何故此灭复名不生。永离未来相续生故

如是灭谛总有四种行相差别谓灭相静相妙相离相。云何灭相烦恼离系故。云何静相。苦离系故。云何妙相。乐静事故。云何离相。常利益事故

云何道谛。谓由此道故知苦断集证灭修道是略说道谛相。道有五种。谓资粮道加行道见道修道究竟道

何等资粮道。谓诸异生所有尸罗。守护根门饮食知量。初夜后夜常不睡眠。勤修止观正知而住。复有所余进习诸善。闻所成慧。思所成慧。修所成慧。修习此故得成现观解脱所依器性

何等加行道。谓有资粮道皆是加行道。或有加行道非资粮道。谓已积集资粮道者。所有顺决择分善根。谓暖法顶法顺谛忍法世第一法。云何暖法。谓各别内证于诸谛中。明得三摩地钵罗若及彼相应等法。云何顶法。谓各别内证于诸谛中。明增三摩地钵罗若及彼相应等法。云何顺谛忍法。谓各别内证于诸谛中。一分已入随顺三摩地钵罗若及彼相应等法。云何世第一法。谓各别内证于诸谛中。无间心三摩地钵罗若及彼相应等法。何等见道。若总说。谓世第一法无间无所得三摩地钵罗若及彼相应等法。又所缘能缘平等平等智为其相。又遣各别有情假法假。遍遣二假所缘法智为相

若别说见道差别。谓世第一法无间苦法智忍苦法智。苦类智忍苦类智。集法智忍集法智。集类智忍集类智。灭法智忍灭法智。灭类智忍灭类智。道法智忍道法智。道类智忍道类智。如是十六智忍。是见道差别相

云何苦。谓苦谛。云何苦法。谓苦谛增上所起教法。云何法智。谓于加行道中观察谛增上法智。云何智忍。谓先观察增上力故。于各别苦谛中起现证无漏慧。由此慧故永舍见苦所断一切烦恼。是故名为苦法智忍。云何苦法智。谓忍无间由此智故。于前所说烦恼解脱而得作证。是名苦法智。云何苦类智忍。谓苦法智无间无漏慧生。于苦法智忍及苦法智各别内证。言后诸圣法皆是此种类。是故名为苦类智忍。云何苦类智。谓此无间无漏智生。审定印可。苦类智忍。是名苦类智。如是于余谛中随其所应。诸忍诸智尽当知

于此位中由法忍法智觉悟所取。由类忍类智觉悟能取。又此一切忍智位中。说名安住无相观者。如是十六心刹那。说名见道。于所知境智生究竟。名一刹那

一切道谛由四种相应随觉了。谓安立故思惟故证受故圆满故。云何安立故。谓声闻等随自所证已得究竟。为欲令他亦了知故。由后得智以无量种名句文身安立道谛。云何。思惟故谓正修习现观方便。以世间智如所安立思惟数习。云何证受故。谓如是数习已自内证受最初见道正出世间无戏论位。云何圆满故。谓此位后圆满转依。乃至证得究竟。彼既证得究竟位已。复由后得智以名句文身安立道谛

如契经言。远尘离垢于诸法中正法眼生者。此依见道说。诸法忍能远尘。诸法智能离垢。遍知故永断故道得清净

如契经言。见法得法极通达法究竟坚法。越度一切悕望疑惑不假他缘。于大师教余不能引。于诸法中得无所畏。此亦依见道说。见法者。谓诸法忍。得法者。谓诸法智。极通达法者。谓诸类忍。究竟坚法者。谓诸类智。越度一切悕望者。由诸忍智于自所证无有悕虑。越度一切疑惑者。于此位中于他所证无有犹豫。不假他缘者。于所修道中无他。引道自然善巧。于大师教余不能引者。于佛圣教不为邪道所化引故。于诸法中得无所畏者。于依所证问记法中。诸怯劣心永无有故

何等修道。谓见道上所有世间道出世间道软道中道上道加行道无间道解脱道胜进道等。皆名修道

云何世间道。谓世间初静虑。第二静虑。第三静虑。第四静虑。空无边处。识无边处。无所有处。非想非非想处。如是静虑无色。由四种相应广分别。谓杂染故清白故建立故清净故。何等杂染故。谓四无记根。一爱二见三慢四无明。由有爱故味上静虑杂染所染。由有见故见上静虑杂染所染。由有慢故慢上静虑杂染所染。由无明故疑上静虑杂染所染。如是烦恼恒染其心。令色无色界烦恼随烦恼相续流转

何等清白故。谓净静虑无色。由性善故说名清白

何等建立故。有四种建立。谓支分建立。等至建立。品类建立。名想建立

云何支分建立。谓初静虑有五支。何等为五。一寻二伺三喜四乐五心一境性。第二静虑有四支。何等为四。一内等净二喜三乐四心一境性。第三静虑有五支。何等为五。一舍二念三正知四乐五心一境性。第四静虑有四支。何等为四。一舍清净二念清净三不苦不乐受四心一境性。对治支故。利益支故。彼二所依自性支故。诸无色中不立支分。以奢摩他一味性故。云何等至建立。谓由七种作意证入初静虑。如是乃至非想非非想处。何等名为七种作意。谓了相作意。胜解作意。远离作意。摄乐作意。观察作意。加行究竟作意。加行究竟果作意

云何品类建立。谓初静虑具软中上三品熏修。如初静虑余静虑及无色三品熏修亦尔。由软中上品熏修初静虑故。于初静虑中还生三异熟。如初静虑于余静虑中若熏修若生果各三品亦尔。于无色界中无别处所故。不立生果处所差别。然由三品熏修无色定故。彼异熟生时有高有下有劣有胜

云何名想建立。谓于初静虑所摄定中。诸佛世尊及得究竟大威德菩萨摩诃萨所入三摩地。彼三摩地一切声闻及独觉等尚不了其名。岂能知数。况复证入。如于初静虑所摄定中。于余静虑无色所摄定中亦尔。如是所说皆依静虑波罗蜜多

何等清净故。谓初静虑中边际定。乃至非想非非想处边际定。是名清净。云何出世道。谓于修道中法智类智品。所摄苦智集智灭智道智。及彼相应三摩地等。或未至定所摄。或初静虑乃至无所有处所摄。非想非非想处唯是世间不明了想恒现行故。由此道理故名无想。如世尊言。乃至有想三摩钵底。方能如实照了通达。灭定亦是出世间摄。由圣道后所证得故。要于人趣方能引发。或于人趣或于色界能现在前。生无色界多不现起。由住寂静解脱异熟者。于此灭定多不发起。勤方便故

云何软道。谓软软软中软上品道。由此道故能舍三界所系地地中上上上中上下三品烦恼

云何中道。谓中软中中中上品道。由此道故能舍三界所系地地中中上中中中软三品烦恼

云何上道。谓上软上中上上品道。由此道故能舍三界所系地地中软上软中软软三品烦恼

云何加行道。谓由此道能舍烦恼。是名修道中加行道

云何无间道。谓由此道无间永断烦恼令无所余

云何解脱道。谓由此道证断烦恼所得解脱。云何胜进道。谓为断余品烦恼。所有加行无间解脱道。是名胜进道。又复弃舍断烦恼加行或勤方便思惟诸法。或勤方便安住诸法。或进修余三摩钵底诸所有道名胜进道。又为引发胜品功德。或复安住诸所有道。名胜进道

复云何修如是诸道。谓得修习修除去修对治修。得修者。谓未生善法修习令生。习修者。谓已生善法修令坚住不忘倍复增广。除去修者。谓已生恶不善法修令永断。对治修者。谓未生恶不善法修令不生。又道生时能安立自习气。是名得修。即此道现前修习。是名习修。即此道现在前时能舍自障。名除去修。即此道既舍自障。令彼未来住不生法。名对治修。复有四种对治名对治修。谓厌坏对治断对治持对治远分对治。云何厌坏对治。谓于有漏诸行见多过患。云何断对治。谓加行道及无间道。云何持对治。谓解脱道。云何远分对治。谓此后诸道

又道差别有十一种。谓观察事道。勤功用道。修治定道。现观方便道。亲近现观道。现观道。清净出离道。依根差别道。净修三学道。发诸功德道。遍摄诸道道。如是诸道随其次第谓三十七菩提分法。四种正行。四种法迹。奢摩他。毗钵舍那。三无漏根

此中一切菩提分法。皆由五门而得建立。谓所缘故自体故助伴故修习故修果故

四念住所缘者谓身受心法。复有四事。谓我所依事。我受用事。我自体事。我染净事。自体者。谓慧及念。助伴者。谓彼相应心心所等。修习者。谓于内身等修循身等观。如于内于外于内外亦尔。内身者。谓于此身中所有内色处。外身者。谓外所有外色处。内外身者。谓内处相应所有外处根所依止。又他身中所有内色处。云何于身修循身观。谓以分别影像身与本质身平等。随观内受者。谓因内身所生受。外受者。谓因外身所生受。内外受者。谓因内外身所生受。如受心法亦尔。如于身修循身观。如是于受等修循受等观如其所应。又修习者。谓欲勤策励勇猛不息。正念正知及不放逸。修习差别故。欲修习者。谓为对治不作。意随烦恼勤修习者。谓为对治懈怠随烦恼。策修习者。谓为对治惛沉掉举随烦恼。励修习者。谓为对治心下劣性随烦恼。勇猛修习者。谓为对治疏漏疲倦随烦恼。不息修习者。谓为对治得少善法生知足喜随烦恼。正念修习者。谓为对治忘失尊教随烦恼。正知修习者。谓为对治毁犯追悔随烦恼。不放逸修习者。谓为对治舍诸善轭随烦恼。修果者。谓断四颠倒趣入四谛身等离系

四正断所缘者。谓已生未生所治能治法。自体者。谓精进。助伴者。谓彼相应心心所等。修习者。如契经说。生欲策励发起正勤策心持心。此中诸句显修正勤及所依止。所依止者。谓欲。正勤者。谓策励等。于止举舍相作意中。为欲损减惛沉掉举发起正勤故次说言策心持心。修果者。谓尽弃舍一切所治。于能对治若得若增。是名修果

四神足所缘者。谓已成满定所作事。自体者。谓三摩地。助伴者。谓欲勤心观及彼相应心心所等。云何欲三摩地。谓由殷重方便触心一境性。云何勤三摩地。谓由无间方便触心一境性。云何心三摩地。谓由先修三摩地力触心一境性。云何观三摩地。谓由闻他教法内自简择触心一境性。又欲三摩地者。谓由生欲触心一境性。勤三摩地者。谓由策励发起正勤触心一境性。心三摩地者。谓由持心触心一境性。观三摩地者。谓由策心触心一境性。修习者。谓数修习八种断行。何等为八。谓欲精进信安正念正知思舍。如是八种略摄为四。谓加行摄受继属对治。又欲勤心观修有二种。谓并因缘聚散远离修。不劣不散彼二所依随顺修。修果者。谓已善修治三摩地故。随所欲证。所通达法即能随心通达变现。又于别别处所法中。证得堪能自在作用。如所愿乐能办种种神通等事。又能引发胜品功德。五根所缘者。谓四圣谛。自体者。谓信精进念定慧。助伴者。谓彼相应心心所等。修习者。谓信根于诸谛起忍可行。修习精进。根于诸谛生忍可已。为觉悟故起精进行。修习念根。于诸谛发精进已。系念起不忘失行。修习定根。于诸谛既系念已。起心一境性行。修习慧根。于诸谛心既得定起简择行修习。修果者。谓能速发谛现观及能修治暖顶。引发忍世第一法

如五根五力亦尔。差别者。由此能损减所对治障。不可屈伏故名为力

七觉支所缘者。谓四圣谛如实性。自体者。谓念择法精进喜安定舍。念是所依支。择法是自体支。精进是出离支。喜是利益支。安定舍是不染污支。由此不染污故。依止不染污故。体是不染污故。助伴者。谓彼相应心心所等。修习者。谓依止远离。依止无欲。依止寂灭。回向弃舍修念觉支。如念觉支乃至舍觉支亦尔。如是四句次第显示。缘四谛境修习觉支。修果者。谓见所断烦恼永断

八圣道支所缘者。谓即此后时四圣谛如实性。自体者。谓正见正思惟正语正业正命正精进正念正定。正见是分别支。正思惟是诲示他支。正语正业正命是令他信支。见戒命清净性故。正精进是净烦恼障支。正念是净随烦恼障支。正定是能净最胜功德障支。助伴者。谓彼相应心心所等。修习者。如觉支说。修果者。谓分别诲示他令他信。烦恼障净。随烦恼障净。最胜功德障净故

四种正行者。谓苦迟通行。苦速通行。乐迟通行。乐速通行。初谓钝根未得根本静虑。第二谓利根未得根本静虑。第三谓钝根已得根本静虑。第四谓利根已得根本静虑。四种法迹者。谓无贪无嗔正念正定。无贪无嗔能令增上戒学清净。正念能令增上心学清净。正定能令增上慧学清净。奢摩他者。谓于内摄心令住等住安住近住。调顺寂静最极寂静。专注一趣平等摄持。毗钵舍那者。谓简择诸法。最极简择。普遍寻思。周审观察。为欲对治粗重相结故。为欲制伏诸颠倒故。令无倒心善安住故

又依奢摩他毗钵舍那立四种道。或有一类已得奢摩他非毗钵舍那。此类依奢摩他进修毗钵舍那。或有一类已得毗钵舍那非奢摩他。此类依毗钵舍那进修奢摩他。或有一类不得奢摩他亦非毗钵舍那。此类专心制伏惛沉掉举双修二道。或有一类已得奢摩他及毗钵舍那。此类奢摩他毗钵舍那二道和合平等双转

三根者。谓未知当知根已知根具知根。云何末知当知根。谓于加行道及于见道十五心刹那中所有诸根。云何已知根。谓从第十六见道心刹那已上。于一切有学道中所有诸根。云何具知根。谓于无学道所有诸根

依初静虑地现修道时。亦修欲界系所有善根。于彼得自在故。如依初静虑地修欲界善根。如是依一切上地现修道时。皆能修习下界下地所有善根。于彼得自在故

何等究竟道。谓依金刚喻定。一切粗重永已息故。一切系得永已断故。永证一切离系得故。从此次第无间转依。证得尽智及无生智十无学法等。何等为十。谓无学正见。乃至无学正定。无学正解脱。无学正智。如是等法名究竟道

云何名为一切粗重。略说有二十四种。谓一切遍行戏论粗重。领受粗重。烦恼粗重。业粗重。异熟粗重。烦恼障粗重。业障粗重。异熟障粗重。盖粗重。寻思粗重。饮食粗重。交会粗重。梦粗重。病粗重。老粗重。死粗重。劳倦粗重。坚固粗重。粗粗重。中粗重。细粗重。烦恼障粗重。定障粗重。所知障粗重

云何系得。谓于粗重积集假立系得性。云何离系得。谓于粗重离散假立离系得性

云何金刚喻定。谓居修道最后断结道位所有三摩地。或加行道摄。或无间道摄。加行道摄者。谓从此已去非一切障所碍能破一切障。无间道摄者。谓从此无间尽智无生智生。又此三摩地无间坚固一味遍满。为显此义薄伽梵说。如大石山无缺无隙无穴一段。极善圆满十方猛风所不动转。云何名为无间转依。谓已证得无学道者三种转依。何等为三。谓心转依道转依粗重转依

云何尽智。谓由因尽所得智。或缘尽为境

云何无生智。谓由果断所得智。或缘果不生为境

十无学法当知依止无学戒蕴定蕴慧蕴解脱蕴解脱知见蕴说

如是道谛总有四种行相差别。谓道相如相行相出相。云何道相。因此寻求真实义故。云何如相。以能对治诸烦恼故。云何行相。善能成办心令不颠倒故。云何出相。趣真常迹故。于诸谛中十六行相。皆通世间及出世间。世间出世间有何差别。于所知境不善悟入善悟入性差别故。有障无障性差别故。有分别无分别性差别故。所以者何。于诸谛中无常苦等十六世间行相。不善通达真如性故。烦恼所随眠故。依名言门起戏论故。出世行相与此相违。出世行相现在前时。虽复现证见无常义。然不依名言戏论门。见此是无常义。如无常行相于无常义。余行相于余义随其所应当知亦尔

大乘阿毗达磨集论卷第五大乘阿毗达磨集论卷第六

        无著菩萨造

        三藏法师玄奘奉　诏译

    决择分中法品第二

云何法决择。法者。谓十二分圣教。何者十二。一契经。二应颂。三记莂。四讽颂。五自说。六缘起。七譬喻。八本事。九本生。十方广。十一希法。十二论议

何等契经。谓以长行缀缉略说所应说义。如来观察十种胜利。缉缀长行略说诸法。谓易可建立。易可宣说。易可受持。恭敬法故。菩提资粮速得圆满。速能通达诸法实性。于诸佛所得证净信。于法僧所得证净信。触证第一现法乐住。谈论决择悦智者心。得预聪明英睿者数

何等应颂。即诸经或中或后以颂重颂。又不了义经应更颂释。故名应颂

何等记莂。谓于是处圣弟子等谢往过去。记莂得失生处差别。又了义经说明记莂。记莂开示深密意故

何等讽颂。谓诸经中以句宣说。或以二句或三或四或五或六

何等自说。谓诸经中或时如来悦意自说。何等缘起。谓因请而说。又有因缘制立学处。亦名缘起

何等譬喻。谓诸经中有比况说

何等本事。谓宣说圣弟子等前世相应事

何等本生。谓宣说菩萨本行藏相应事

何等方广。谓菩萨藏相应言说。如名方广。亦名广破。亦名无比。为何义故名为方广。一切有情利益安乐所依处故。宣说广大甚深法。故为何义故名为广。破以能广破一切障。故为何义故名为无比。无有诸法能比类故

何等希法。若于是处宣说声闻。诸大菩萨及如来等。最极希有甚奇特法

何等论议。若于是处无有颠倒。解释一切深隐法相

如是契经等十二分圣教三藏所摄。何等为三。一素怛缆藏。二毗柰耶藏。三阿毗达磨藏。此复有二。一声闻藏。二菩萨藏。契经应颂记莂讽颂自说。此五声闻藏中素怛缆藏摄。缘起譬喻本事本生。此四二藏中毗柰耶藏并眷属摄。方广希法。此二菩萨藏中素怛缆藏摄。论议一种声闻菩萨二藏中阿毗达磨藏摄何故如来建立三藏为欲对治疑随烦恼故。建立素怛缆藏。为欲对治受用二边随烦恼故。建立毗柰耶藏。为欲对治自见取执随烦恼故。建立阿毗达磨藏。复次为欲开示三种学故。建立素怛缆藏。为欲成立增上戒学增上心学故。建立毗柰耶藏。为欲成立增上慧学故。建立阿毗达磨藏。复次为欲开示正法义故。建立素怛缆藏。为显法义作证安足处故。建立毗柰耶藏。为令智者论议决择。受用法乐住故。建立阿毗达磨藏

如是三藏所摄诸法为谁所行。是闻所成思所成修所成。心心所法所行。如契经说。诸心心所法有所缘有行相有所依及相应。彼于此法为何所缘。谓契经等。作何行相。谓蕴等相应义。为何所依。谓他表了忆念习气何等相应。谓互为助伴。于所缘行相平等解了

云何于法所缘差别。若略说有四种。谓遍满。所缘。净行所缘。善巧所缘。净惑所缘

遍满所缘复有四种。谓有分别影像所缘。无分别影像所缘。事边际所缘。所作成就所缘。有分别影像所缘者。谓由胜解作意。所有奢摩他毗钵舍那所缘境界。无分别影像所缘者。谓由真实作意。所有奢摩他毗钵舍那所缘境界。事边际所缘者。谓一切法尽所有性如所有性。尽所有性者谓蕴界处。如所有性者。谓四圣谛十六行相真如。一切行无常。一切行苦。一切法无我。涅槃寂静空无愿无相。所作成就所缘者。谓转依。如是转依不可思议。十六行相中空摄几行相。谓二。无愿摄几行相。谓六。无相摄几行相。谓八

净行所缘复有五种。谓多贪行者缘不净境。多嗔行者缘修慈境。多痴行者缘众缘性诸缘起境。憍慢行者缘界差别境。寻思行者缘入出息念境。善巧所缘亦有五种。谓蕴善巧界善巧处善巧缘起善巧处非处善巧。处非处善巧应云何观。应如缘起善巧观。处非处善巧缘起善巧有何差别。若以诸法流润诸法。令离无因不平等因生故。是缘起善巧因果相称。摄受生故。是处非处善巧

净惑所缘者。谓下地粗性上地静性。真如及四圣谛。是名净惑所缘

若欲于法勤审观察。由几道理能正观察。由四道理。谓观待道理。作用道理。证成道理。法尔道理。云何观待道理。谓诸行生时要待众缘。云何作用道理。谓异相诸法各别作用。云何证成道理。谓为证成所应成义。宣说诸量不相违语。云何法尔道理。谓无始时来于自相共相所住法中。所有成就法性法尔

于诸法中正勤观察。云何于法而起寻思。谓起四种寻思。一名寻思。二事寻思。三自体假立寻思。四差别假立寻思。云何名寻思。谓推求诸法名身句身文身自相皆不成实。云何事寻思。谓推求诸法蕴界处相皆不成实。云何自体假立寻思。谓于诸法能诠所诠相应中推求自体。唯是假立名言因性。云何差别假立寻思。谓于诸法能诠所诠相应中推求差别。唯是假立名言因性

于法正勤修寻思已。云何于法起如实智。谓起四种如实智。一名寻思所引如实智。二事寻思所引如实智。三自体假立寻思所引如实智。四差别假立寻思所引如实智。云何名寻思所引如实智。谓如实知名不可得智。云何事寻思所引如实智。谓如实知事相亦不可得智。云何自体假立寻思所引如实智。谓如实知实有自性不可得智。云何差别假立寻思所引如实智。谓如实知实有差别不可得智。依法勤修三摩地者。瑜伽地云何当知。有五种。一持二作三镜四明五依。云何持。谓已积集菩提资粮。于暖等位于诸圣谛所有多闻。云何作。谓缘此境如理作意。云何镜。谓缘境有相三摩地。云何明。谓能取所取无所得智依此道理佛薄伽梵妙善宣说

  菩萨于定位　　观影唯是心
  义想既灭除　　审观唯自想
  如是住内心　　知所取非有
  次能取亦无　　后触无所得

云何依。谓转依。舍离诸粗重得清净转依故。于诸法中云何法善巧。谓多闻故。云何义善巧。谓于阿毗达磨毗奈耶中善知其相故

云何文善巧。谓善知训释文词故。云何词善巧。谓能善知我我所等世俗言词不深执着随顺说故。云何前际后际密意善巧。谓能善知于前际领受于后际。出离故

于诸法中云何住法。若不得修慧唯勤方便修习闻思。不名住法。若不得闻思唯勤方便修习修慧。亦不名住法。若俱得二种方便安住。乃名住法。若唯于法受持读诵为他演说思惟其义。是名闻思。若修三摩地方便不知足。是名修慧。三摩地方便者。谓无间殷重方便及无倒方便。不知足者。谓不生味着修上奢摩他方便

何因缘故唯方广一分名为菩萨波罗蜜多藏。由此分中广说一切波罗蜜多数故。相故次第故释词故修故差别故摄故所治故功德故更互决择故

何缘方广分名广大甚深。由一切种智性广大甚深故

何因缘故一分众生于方广分广大甚深不生胜解反怀怖畏。由远离法性故。未种善根故。恶友所摄故

何因缘故一分众生于方广分广大甚深虽生胜解而不出离。由深安住自见取故。常坚执着如言义故。依此密意薄伽梵于大法镜经中说如是言。若诸菩萨随言取义。不如正理思择法故。便生二十八不正见。何等名为二十八不正见。谓相见。损减施设见。损减分别见。损减真实见。摄受见。转变见。无罪见。出离见。轻毁见。愤发见。颠倒见。出生见。不立宗见。矫乱见。敬事见。坚固愚痴见。根本见。于见无见见。舍方便见。不出离见。障增益见。生非福见。无功果见。受辱见。诽谤见。不可与言见。广大见。增上慢见

如方广分说。一切诸法皆无自性。依何密意说。谓无自然性故。无自体性故。无住自体故。无如愚夫所取相性故。复次于遍计所执自性。由相无性故。于依他起自性。由生无性故。于圆成实自性。由胜义无性故

又于彼说言。一切诸法无生无灭。本来寂静自性涅槃。依何密意说。如无自性无生亦尔。如无生无灭亦尔。如无生无灭本来寂静亦尔。如本来寂静自性涅槃亦尔

复次有四种意趣。由此意趣故方广分中一切如来所有意趣应随决了。何等为四。一平等意趣。二别时意趣。三别义意趣。四补特伽罗意乐意趣。复次有四种秘密。由此秘密故于方广分中一切如来所有秘密应随决了。何等为四。一令入秘密。二相秘密。三对治秘密。四转变秘密

复次方广分中于法三摩地善巧菩萨相。云何可知。谓由五种因故。一刹那刹那消除一切粗重所依。二出离种种想得乐法乐。三了知无量无分别相。四顺清净分无分别相恒现在前。五能摄受转上转胜。圆满成就佛法身因

声闻藏法菩萨藏法等。从如来法身所流。何因缘故以香鬘等供养恭敬菩萨藏法。便生广大无边福聚。非声闻藏法。以菩萨藏法是一切众生利益安乐所依处故。能建大义故。无上无量大功德聚所生处故

    大乘阿毗达磨集论决择分中得品第三之一

云何得决择。略说有二种。一建立补特伽罗故。二建立现观故

云何建立补特伽罗。略有七种。谓病行差别故。出离差别故。任持差别故。方便差别故。果差别故。界差别故。修行差别故。应知建立补特伽罗

云何病行差别。此有七种。谓贪行嗔行痴行慢行寻思行等分别薄尘行。补特伽罗差别故

云何出离差别。此有三种。谓声闻乘独觉乘大乘。补特伽罗差别故

云何任持差别。此有三种。谓未具资粮。已具未具资粮。已具资粮。补特伽罗差别故

云何方便差别。此有二种。谓随信行随法行。补特伽罗差别故

云何果差别。此有二十七种。谓信胜解见至身证。慧解脱俱分解脱。预流向预流果。一来向一来果。不还向不还果。阿罗汉向阿罗汉果。极七返有。家家一间。中般涅槃。生般涅槃。无行般涅槃。有行般涅槃。上流。退法阿罗汉。思法阿罗汉。护法阿罗汉。住不动阿罗汉。堪达阿罗汉。不动法阿罗汉。补特伽罗差别故。云何界差别。谓欲界异生有学无学。如欲界有三色无色界亦尔又有欲色界菩萨。又有欲界独觉及不可思议如来。补特伽罗差别故

云何修行差别。略有五种。一胜解行菩萨。二增上意乐行菩萨。三有相行菩萨。四无相行菩萨。五无功用行菩萨。补特伽罗差别故

何等贪行补特伽罗。谓有猛利长时贪欲。如是嗔行痴行慢行。及寻思行补特伽罗。皆有猛利长时差别。何等等分行补特伽罗。谓住自性位烦恼。何等薄尘行补特伽罗。谓住自性位微薄烦恼

何等声闻乘补特伽罗。谓住声闻法性。若定若不定性是钝根。自求解脱发弘正愿。修厌离贪解脱意乐。以声闻藏为所缘境。精进修行法随法行得尽苦际。何等独觉乘补特伽罗。谓住独觉法性。若定若不定性是中根自求解脱发弘正愿。修厌离贪解脱意乐。及修独证菩提意乐。即声闻藏为所缘境。精进修行法随法行。或先未起顺决择分。或先已起顺决择分。或先未得果。或先已得果出无佛世。唯内思惟圣道现前。或如麟角独住。或复独胜部行得尽苦际。何等大乘补特伽罗。谓住菩萨法性。若定若不定性是利根。为求解脱一切有情。发弘正愿修无住处涅槃意乐。以菩萨藏为所缘境。精进修行法随法行。成熟众生修净佛土。得受大记证成无上正等菩提

何等未具资粮补特伽罗。谓缘谛增上法为境。发起软品清信胜解。成就软品顺解脱分未定生时。何等已具未具资粮补特伽罗。谓缘谛增上法为境。发起中品清信胜解。成就中品顺解脱分已定生时。何等已具资粮补特伽罗。谓缘谛增上法为境。发起上品清信胜解。成就上品顺解脱分即此生时

又未具资粮者。谓缘谛增上法为境。于诸谛中。成就下品谛察法忍。成就下品顺决择分未定生时。已具未具资粮者。谓缘谛增上法为境于诸谛中。成就中品谛察法忍成就中品。顺决择分已定生时。已具资粮者。谓缘谛增上法为境。于诸谛中。成就上品谛察法忍。成就上品顺决择分即此生时

此中三品顺决择分者。谓除世第一法。由此世第一法性唯一刹那必不相续。即此生时定入现观非前位故。从下中品顺解脱分。顺决择分有可退义。此唯退现行非退习气。已依涅槃先起善根者。不复新发起故。何等随信行补特伽罗谓资粮已具性是钝根。随顺他教修谛现观。何等随法行补特伽罗。谓资粮已具性是利根。自然随顺谛增上法修谛现观

何等信胜解补特伽罗。谓随信行已至果位

何等见至补特伽罗。谓随法行已至果位

何等身证补特伽罗。谓诸有学已具证得八解脱定。何等慧解脱补特伽罗。谓已尽诸漏而未具证八解脱定。何等俱分解脱补特伽罗。谓已尽诸漏及具证得八解脱定

何等预流向补特伽罗。谓住顺决择分位。及住见道十五心刹那位。何等预流果补特伽罗。谓住见道第十六心刹那位。即此见道。亦名趣入正性决定。亦名于法现观。若于欲界未离欲者。后入正性决定位得预流果。若于欲界倍离欲者。后入正性决定位得一来果。若已离欲界欲者。后入正性决定位得不还果。若已永断见道所断一切烦恼得预流果。何故但言永断三结得预流果。最胜摄故。何故最胜。以于解脱是不发趣因故。虽已发趣复为邪出离因故。及为不正出离因故。又此三结是迷所知境因故。迷见因故。迷对治因故。何等一来向补特伽罗。谓于修道中已断欲界五品烦恼安住彼道。何等一来果补特伽罗。谓于修道中已断欲界第六品烦恼安住彼道。何等不还向补特伽罗。谓于修道中已断欲界第七第八品烦恼安住彼道。何等不还果补特伽罗。谓于修道中已断欲界第九品烦恼安住彼道。若已永断一切见道所断烦恼。及已永断欲界修道所断一切烦恼。得不还果。何故但言。永断五顺下分结得不还果。最胜摄故。何故最胜。能为下趣下界胜因故。何等阿罗汉向补特伽罗。谓已永断有顶八品烦恼安住彼道。何等阿罗汉果补特伽罗。谓已永断有顶第九品烦恼安住彼究竟道。若阿罗汉永断三界一切烦恼。何故但言。永断五顺上分结得阿罗汉果。最胜摄故。何故最胜。是取上分因及不舍上分因故

何等极七返有补特伽罗。谓即预流果。于人天生往来杂受。极至七返得尽苦际。何等家家补特伽罗谓即预流果。或于天上或于人中。从家至家得尽苦际。何等一间补特伽罗。谓即一来果。或于天上唯受一有得尽苦际。何等中般涅槃补特伽罗。谓生结已断起结未断。或中有才起即便圣道现前得尽苦际。或中有起已为趣生有才起思惟。即便圣道现前得尽苦际。或思惟已发趣生有。未到生有即便圣道现前得尽苦际。何等生般涅槃补特伽罗。谓二结俱未断才生色界已。即便圣道现前得尽苦际。何等无行般涅槃。谓生彼已不由加行圣道现前得尽苦际。何等有行般涅槃补特伽罗。谓生彼已由加行力圣道现前得尽苦际

何等上流补特伽罗。谓于色界地地中皆受生已。乃至最后入色究竟。于彼无漏圣道现前得尽苦际。复有乃至往到有顶圣道现前得尽苦际。又杂修第四静虑有五品差别。一下品修。二中品修。三上品修。四上胜品修。五上极品修。由此五品杂修第四静虑故。如其次第生五净居

何等退法阿罗汉。谓钝根性。若游散若不游散。若思惟若不思惟。皆可退失现法乐住。何等思法阿罗汉。谓钝根性。若游散若不游散若不思惟。即可退失现法乐住。若思惟已能不退失。何等护法阿罗汉。谓钝根性。若游散便可退失现法乐住。若不游散即能不退。何等住不动阿罗汉。谓钝根性。若游散若不游散。皆能不退现法乐住。亦不能练根。何等堪达阿罗汉。谓钝根性。若游散若不游散。皆能不退现法乐住。然堪能练根。何等不动法阿罗汉。谓利根性。若游散若不游散。皆能不退现法乐住

何等欲界异生补特伽罗。谓于欲界若生若长不得圣法。何等欲界有学补特伽罗。谓于欲界若生若长。已得圣法犹有余结。何等欲界无学补特伽罗。谓于欲界若生若长。已得圣法无有余结。如欲界有三色无色亦尔。何等欲色界菩萨补特伽罗。谓与灭离无色界生静虑相。应住静虑乐而生欲界或生色界。何等欲界独觉补特伽罗。谓无佛出世时生于欲界。自然证得独觉菩提

何等不可思议如来补特伽罗。谓且于欲界始从示现。安住睹史多天妙宝宫殿。乃至示现大般涅槃。示现一切诸佛菩萨所行大行。何等胜解行菩萨补特伽罗。谓住胜解行地中成就菩萨下中上忍。何等增上意乐行菩萨补特伽罗。谓十地中所有菩萨。何等有相行菩萨补特伽罗。谓住极喜离垢发光焰慧极难胜现前地中所有菩萨。何等无相行菩萨补特伽罗。谓住远行地中所有菩萨。何等无功用行菩萨补特伽罗。谓住不动善慧法云地中所有菩萨

复次如说预流果补特伽罗。此有二种。一渐出离。二顿出离。渐出离者。如前广说。顿出离者。谓入谛现观已。依止未至定发出世间道。顿断三界一切烦恼。品品别断唯立二果。谓预流果阿罗汉果如是补特伽罗多于现法或临终时善辨圣旨。设不能辨由愿力故。即以愿力还生欲界。出无佛世成独胜果

大乘阿毗达磨集论卷第六大乘阿毗达磨集论卷第七

        无著菩萨造

        三藏法师玄奘奉　诏译

    决择分中得品第三之二

云何建立现观。略有十种。谓法现观。义现观。真现观。后现观。宝现观。不行现观。究竟现观。声闻现观。独觉现观。菩萨现观

何等法现观。谓于诸谛增上法中已得上品净信胜解随信而行

何等义现观。谓于诸谛增上法中已得上品谛察法忍。此忍居顺决择分位。此由三种如理作意所显发故。复成三品。谓上软上中上上。何等真现观。谓已得见道十六心刹那位所有圣道。又见道中得现观边。安立谛世俗智不现在前。于修道位此世俗智方可现前。何等后现观。谓一切修道

何等宝现观。谓于佛证净。于法证净。于僧证净。何等不行现观。谓已证得无作律仪。虽居学位而谓我今已尽那落迦。已尽傍生。已尽饿鬼。已尽颠坠恶趣。我不复造恶趣业感恶趣异熟。何等究竟现观。如道谛中究竟道说。何等声闻现观。谓前所说七种现观。从闻他音而证得故。名声闻现观

何等独觉现观。谓前所说七种现观。不由他音而证得故。名独觉现观。何等菩萨现观。谓诸菩萨于前所说七现观中。起修习忍而不作证。然于菩萨极喜地中。入诸菩萨正性决定。是名菩萨现观

声闻现观菩萨现观有何差别。略说有十一种。谓境界差别。任持差别。通达差别。誓愿差别。出离差别。摄受差别。建立差别。眷属差别。胜生差别。生差别。果差别

其果差别复有十种。谓转依差别。功德圆满差别。五相差别。三身差别。涅槃差别。证得和合智用差别。障清净差别。和合作业差别。方便示现成等正觉入般涅槃差别。五种拔济差别。诸无量等最胜功德。何现观摄后现观究竟现观。摄彼复云何。谓无量解脱胜处遍处无诤愿智无碍解神通相随好清净力无畏念住不护无忘失法永断习气大悲不共佛法一切种妙智。如是等功德诸契经中处处宣说

无量者。谓四无量。云何慈。谓依止静虑于诸有情与乐相应意乐住具足中。若定若慧及彼相应诸心心所。云何悲。谓依止静虑于诸有情离苦意乐住具足中。若定若慧余如前说。云何喜。谓依止静虑于诸有情不离乐意乐住具足中。若定若慧余如前说。云何舍。谓依止静虑于诸有情利益意乐住具足中。若定若慧余如前说。解脱者。谓八解脱。云何有色观诸色。谓依止静虑于内未伏见者色想。或现安立见者色想。观所见色住具足中。若定若慧及彼相应诸心心所。乃至为解脱变化障。云何内无色想观外诸色。谓依止静虑于已伏见者色想。或现安立见者无色想观所见色住具足中若定若慧。余如前说。云何净解脱身作证具足住。谓依止静虑于内净不净诸色。已得展转相待想展转相入想展转一味想故。于彼已得住具足中。若定若慧余如前说。乃至为解脱净不净。变化烦恼生起障。云何无边空处解脱。谓于随顺解脱无边空处住具足中。若定若慧余如前说。如无边空处解脱。无边识处。无所有处。非想非非想处解脱亦尔。乃至为解脱。寂静解脱无滞碍障。云何想受灭解脱。谓依止非想非非想处解脱。超过诸余寂静解脱。住于似真解脱。住具足中心心所灭。为解脱想受灭障

胜处者。谓八胜处。前四胜处由二解脱所建立。后四胜处由一解脱所建立。此中解脱是意解所缘。胜处是胜伏所缘。自在转故。依有情数非有情数说色少多。依净不净说色好恶。依人与天说色劣胜。余如解脱中说。胜伏所缘故名胜处

遍处者。谓十遍处所缘遍满故名遍处。于其遍满住具足中若定若慧。及彼相应心心所法。是名遍处。何故于遍处建立地等。由此遍处观所依能依色。皆遍满故。余随所应如解脱说。如是遍处能成满解脱

无诤者。谓依止静虑于防护他所应起烦恼住具足中。若定若慧及彼相应诸心心所。愿智者。谓依止静虑于为了所知愿具足中。若定若慧余如前说

无碍解者。谓四无碍解。云何法无碍解。谓依止静虑于一切法名差别无碍具足中。若定若慧余如前说。云何义无碍解。谓依止静虑于诸相及意趣无碍具足中。若定若慧余如前说。云何训词无碍解。谓依止静虑于诸方言音及训释诸法言词无碍具足中。若定若慧余如前说。云何辩才无碍解。谓依止静虑于诸法差别无碍具足中。若定若慧余如前说

神通者。谓六神通。云何神境通。谓依止静虑于种种神变威德具足中。若定若慧及彼相应诸心心所。云何天耳通。谓依止静虑于随闻种种音声威德具足中。若定若慧余如前说。云何心差别通。谓依止静虑于入他有情心行差别威德具足中。若定若慧余如前说。云何宿住随念通。谓依止静虑于随念前际所行威德具足中。若定若慧余如前说。云何死生通。谓依止静虑于观有情死生差别威德具足中。若定若慧余如前说。云何漏尽通。谓依止静虑于漏尽智威德具足中。若定若慧及彼相应诸心心所。相随好者。谓依止静虑于相随好庄严所依示现具足中。若定若慧及彼相应诸心心所。并彼所起异熟

清净者。谓四清净。云何依止清净。谓依止静虑于随所欲依止取住舍具足中。若定若慧及彼相应诸心心所。云何境界清净。谓依止静虑。于随所欲境界变化智具足中。若定若慧余如前说。云何心清净。谓依止静虑于如所欲三摩地门自在具足中。若定若慧余如前说。云何智清净。谓依止静虑于随所欲陀罗尼门任持具足中。若定若慧余如前说

力者。谓如来十力。云何处非处智力。谓依止静虑于一切种处非处智具足中。若定若慧及彼相应诸心心所。云何自业智力。谓依止静虑于一切种自业智具足中。若定若慧余如前说。余力随应当知亦尔

无畏者。谓四无畏。云何正等觉无畏。谓依止静虑由自利门。于一切种所知境界正等觉自称德号建立具足中。若定若慧及彼相应诸心心所。云何漏尽无畏。谓依止静虑由自利门。于一切种漏尽自称德号建立具足中。若定若慧余如前说。云何障法无畏。谓依止静虑由利他门。于一切种说障碍法自称德号建立具足中。若定若慧余如前说。云何出苦道无畏。谓依止静虑由利他门。于一切种说出苦道法自称德号建立具足中。若定若慧余如前说

念住者。即三念住。谓御大众时。于一切种杂染不现行具足中。若定若慧余如前说

不护者。即三不护。谓御大众时于随所欲教授教诫方便具足中。若定若慧余如前说。无忘失法者。谓于一切种随其所作所说明记具足中。若定若慧余如前说

永断习气者。谓一切智者于非一切智所作不现行具足中。若定若慧余如前说

大悲者。谓于缘无间苦境大悲住具足中。若定若慧余如前说

不共佛法者。即十八种不共佛法。谓于不共身语意业清净具足中。于所依及果根未得不退具足中。于不共业现行具足中。于不共智住具足中。若定若慧余如前说

一切种妙智者。谓于蕴界处一切种妙智性具足中。若定若慧及彼相应诸心心所

云何引发如是等功德。谓依止清净四静虑。若外道若声闻若菩萨等。引发四无量五神通。多分依止边际第四静虑。若声闻若菩萨若如来等引发所余功德。何因引发如是功德。谓依止静虑数数思惟。随所建立法故。如是等功德略有二种。一现前发起自所作用。二安住自性。若现发起自所作用。以出世后所得世俗智为体。若安住自性。用出世智为体

无量作何业。谓舍所治障哀愍住故。能速圆满福德资粮。成熟有情心无厌倦

解脱作何业。谓引发变化事。于净不净变化无有艰难。于寂静解脱无有滞碍。能住第一寂静圣住。由胜解思惟故

胜处作何业。谓能令前三解脱所缘境界自在而转。由胜伏所缘故

遍处作何业。谓善能成办解脱所缘。遍满流布故

无诤作何业。谓所发语言闻皆信伏。爱护他心最为胜故。如其所应发语言故

愿智作何业。谓能善记别三世等事。一切世间咸所恭敬。由远一切众众所归仰故

无碍解作何业。谓善说法要悦众生心。能绝一切所疑网故

神通作何业。谓以身业语业记心。化导有情令入圣教。善知有情一切心行及过未已。如应教授令永出离。相及随好作何业。谓能令暂见。谓大丈夫心生净信

清净作何业。谓由此势力故。取生有随其乐欲。或住一劫或复劫余。或舍寿行。或于诸法自在而转。或于诸定自在而转。或复任持诸佛正法

力作何业。谓为除舍无因恶因论不作而得论。无倒宣说增上生道。悟入一切有情心行。正说法品。意乐随眠境界资粮当能出离。随其所应宣说决定胜道。降伏诸魔。善能记别一切问论

无畏作何业。谓处大众中自正建立我为大师。摧伏一切邪难外道

念住作何业。谓能不染污摄御大众。不护作何业。谓能无间断教授教诫所化徒众

无忘失法作何业。谓能不舍离一切佛事。永断习气作何业。谓离诸烦恼亦不显现。似诸烦恼所作事业

大悲作何业。谓日夜六时遍观世间。不共佛法作何业。谓由身语意业清净已得不退。若行若住映蔽一切听闻独觉

一切种妙智作何业。谓能绝一切有情一切疑网。令正法眼长时得住。由此有情未成熟者令其成熟。已成熟者令得解脱

于上所说现观位中。证得后后胜品道时。舍前所得下劣品道。又即此时集断作证于无余依涅槃界位。声闻独觉一切圣道无不皆由顿舍所舍。非诸菩萨。是故唯说诸菩萨等为无尽善根者。无尽功德者。何故建立诸无记事。由彼所问不如理故。何故所问不如理耶。远离因果染净所应思处故

何缘菩萨已入菩萨超升离生位。而非预流耶。由得不住道一向预流行不成就故。何缘亦非一来耶。故受诸有无量生故。何缘亦非不还耶。安住静虑还生欲界故

又诸菩萨已得谛现观。于十地修道位唯修所知障对治道。非烦恼障对治道。若得菩提时顿断烦恼障及所知障。顿成阿罗汉及如来。此诸菩萨虽未永断一切烦恼。然此烦恼犹如咒药所伏诸毒。不起一切烦恼过失。一切地中如阿罗汉已断烦恼

又诸菩萨于所知境应修善巧。于诸方便应修善巧。于虚妄分别应修善巧。于无分别应修善巧。于时时中应修练根

云何所知境。谓略有六种。一迷乱。二迷乱所依。三不迷乱所依。四迷乱不迷乱。五不迷乱。六不迷乱等流

云何方便善巧。谓略有四种。一成熟有情方便善巧。二圆满佛法方便善巧。三速证通慧方便善巧。四道无断绝方便善巧

云何虚妄分别。谓略有十种。一根本分别。二相分别。三相显现分别。四相变异分别。五相显现变异分别。六他引分别。七不如理分别。八如理分别。九执着分别。十散乱分别。此复十种。一无性分别。二有性分别。三增益分别。四损减分别。五一性分别。六异性分别。七自性分别。八差别分别。九随名义分别。十随义名分别

云何无分别。谓略有三种。一知足无分别。二无颠倒无分别。三无戏论无分别。如此三种异生声闻菩萨。如其次第应知。其相无戏论无分别。复离五相。一非无作意故。二非超过作意故。三非寂静故。四非自性故。五非于所缘作加行故。谓于所缘不起加行。若诸菩萨性是利根。云何复令修练根行。谓令依利软根引发利中根。复依利中根引发利利根故

    大乘阿毗达磨集论决择分中论议品第四

云何论议决择略说有七种。谓义决择。释决择。分别显示决择。等论决择。摄决择。论轨决择。秘密决择

何等义决择。谓依六义而起决择。何等六义。谓自性义因义果义业义相应义转义。自性义者。谓三自性。因义者。谓三因。一生因。二转因。三成因。果义者。谓五果。一异熟果。二等流果。三增上果。四事用果。五离系果。业义者。谓五业。一取受业。二作用业。三加行业。四转变业。五证得业。相应义者。谓五相应。一聚结相应。二随逐相应。三连缀相应。四分位相应。五转变相应。转义者。谓五转。一相转。二安住转。三颠倒转。四不颠倒转。五差别转

何等释决择。谓能解释诸经宗要。此复云何。略有六种。一所遍知事。二所遍知义。三遍知因缘。四遍知自性。五遍知果。六彼证受。又十四门辩释决择。何等十四。谓摄释门。摄事门。总别分门。后后开引门。遮止门。转变字门。坏不坏门。安立补特伽罗门。安立差别门。理趣门。遍知等门。力无力门。别别引门。引发门。何等分别显示决择。谓于如所说蕴等诸法中随其所应。作一行顺前句顺后句二句三句四句述可句遮止句等

何等等论决择。谓依八。何八。若之词问答决择一切真伪。复有四种等论决择道理。一能破。二能立。三能断。四能觉

何等摄决择。谓由十处摄诸决择。何等十处。一成所作决择处。二趣入决择处。三胜解决择处。四道理决择处。五论决择处。六通达决择处。七清净决择处。八引发决择处。九句差别决择处。十不由功用暂作意时一切义成决择处

何等论轨决择。略有七种。一论体。二论处。三论依。四论庄严。五论负。六论出离。七论多所作法

第一论体复有六种。一言论。二尚论。三诤论。四毁论。五顺论。六教论。言论者。谓一切世间语言。尚论者。谓诸世间所随闻论。世智所尚故。诤论者。谓互相违返所立言论。毁论者。谓更相愤怒发粗恶言。顺论者。谓随顺清净智见所有决择言论。教论者。谓教导有情心未定者令其心定。心已定者令得解脱所有言论

第二论处。谓或于王家。或于执理家。或对淳质堪为量者。或对善伴。或对善解法义沙门婆罗门等而起论端。第三论依。谓依此立论略有二种。一所成立。二能成立。所成立有二种。一自性。二差别。能成立有八种。一立宗二立因。三立喻四合。五结六现量。七比量八圣教量。所成立自性者。谓我自性或法自性差别者。谓我差别或法差别。立宗者。谓以所应成自所许义。宣示于他令彼解了。立因者。谓即于所成未显了义。正说现量可得不可得等信解之相。立喻者。谓以所见边与未所见边和会正说。合者。为引所余此种类义。令就此法正说理趣。结者。谓到究竟趣所有正说。现量者。谓自正明了无迷乱义。比量者。谓现余信解。圣教量者。谓不违二量之教。第四论庄严。谓依论正理而发论端。深为善美名论庄严。此复六种。一善自他宗。二言音圆满。三无畏。四辩才。五敦肃。六应供

第五论负。谓舍言言屈言过。舍言者。谓自发言称己论失称他论德。言屈者。谓假托余事方便而退。或说外事而舍本宗。或现忿怒憍慢覆藏等。如经广说。言过者。略有九种。一杂乱。二粗犷。三不辩了。四无限量。五非义相应。六不应时。七不决定。八不显了。九不相续

第六论出离。谓观察德失令论出离或复不作。若知敌论非正法器时众无德自无善巧不应兴论。若知敌论是正法器时众有德自有善巧方可兴论

第七论多所作法。略有三种。一善达自他宗由此堪能遍兴谈论。二无畏由此堪能处一切众而兴论端。三辩才由此堪能于诸问难皆善辩答

复次若欲自求利益安乐。于诸论轨应善通达。不应与他而兴诤论。如薄伽梵于大乘阿毗达磨经中说如是言。若诸菩萨欲勤精进修诸善品。欲行真实法随法行。欲善摄益一切有情。欲得速证阿耨多罗三藐三菩提者。当正观察十二处法。不应与他共兴诤论。何等十二。一者宣说证无上义微妙法时。其信解者甚为难得。二者作受教心而请问者甚为难得。三者时众贤善观察德失甚为难得。四者凡所兴论能离六失甚为难得。何等为六。谓执着邪宗失。矫乱语失。所作语言不应时失。言退屈失。粗恶语失。心恚怒失。五者凡兴论时不怀犷毒甚为难得。六者凡兴论时善护他心甚为难得。七者凡兴论时善护定心甚为难得。八者凡兴论时欲令己劣他得胜心甚为难得。九者己劣他胜心不烦恼甚为难得。十者心已烦恼得安隐住甚为难得。十一者既不安住常修善法甚为难得。十二者于诸善法既不恒修。心未得定能速得定。心已得定能速解脱甚为难得

何等秘密决择。谓说余义名句文身。隐密转变更显余义。如契经言

  逆害于父母　　王及二多闻
  诛国及随行　　是人说清净

又契经言

  不信不知恩　　断蜜无容处
  恒食人所吐　　是最上丈夫

又契经言

  觉不坚为坚　　善住于颠倒
  极烦恼所恼　　得最上菩提

又契经言。菩萨摩诃萨成就五法。施波罗蜜多速得圆满。何等为五。一者增益悭吝法性。二者于施有倦。三者憎恶乞求。四者无暂少施。五者远离于施

又契经言。菩萨摩诃萨成就五法名梵行者。成就第一清净梵行。何等为五。一者常求以欲离欲。二者舍断欲法。三者欲贪已生即便坚执。四者怖治欲法。五者三二数贪

何故此论名为大乘阿毗达磨集。略有三义。谓等所集故。遍所集故。正所集故

大乘阿毗达磨集论卷第七


大乘阿毗达磨杂集论

    No. 1606 [cf. No. 1605]

大乘阿毗达磨杂集论卷第一

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    本事分中三法品第一之一

  诸会真净究竟理　　超圣行海升彼岸
  证得一切法自在　　善权化导不思议
  无量希有胜功德　　自他并利所依止
  敬礼如是大觉尊　　无等妙法诸圣众
  敬礼开演本论师　　亲承圣旨分别者
  由悟契经及解释　　爰发正勤乃参综

今此颂中无倒称赞最胜功德敬申顶礼。以供养三宝及造此论经释二师随其所应。所以者何。此论所依及能起故。佛薄伽梵是契经等一切教法平等所依。无师自悟诸法实性。一分教起所依处故。从此无间圣弟子众依法随学法为依者。法界所流故。经释二师亦契如来所说正法。一分无倒闻思修行。为依止故随而造论。初二颂显示如来应正等觉胜德六义。所谓自性因果业相应差别义。诸会真净究竟理者。显自性义。谓诸佛法身以一切种转依真如为体性故。超圣行海升彼岸者。显因义。谓佛菩提从一切种极喜等十地圣行无量无数大劫。圆满修习因所生故。证得一切法自在者。显果义。谓永断一切烦恼障所知障及彼余习。证得无边希有功德无上三菩提果。于一切法自在转故。善权化导不思议者。显业义。谓以超非一切智境。神通记说教诫变现等无量调伏方便。导引可化有情令心界清净故。无量希有胜功德者。显相应义。谓超寻思数量。无边种种难行苦行。所生无上大悲力无畏等功德法宝相应故。自他并利所依止者。显差别义。谓如来受用变化自性身。如其次第自他并利所依故。所依者。身义体义。无差别也。自他并利所依者。就胜而说。谓受用身自利最胜处大会中。能受第一广大甚深法圣财故。变化身者。他利最胜遍于十方一切世界。能起无间。犹工巧业等诸变化事。建立有情所应作故。自性身者。谓诸善逝共有法身最极微细一切障转依真如为体故。于自他利并为最胜。由证此身得余身故。此三佛身是差别义。当知此中亦赞法僧功德。法宝者。自性因果等义所摄故。僧宝者。随此修学所生故。庶令学者无诸怖畏。方造论端建兹体性

  本事与决择　　是各有四种
  三法摄应成　　谛法得论议
  几何因取相　　建立与次第
  义喻广分别　　集总颂应知

问何故论端先辩蕴等。答欲令学者于几何因等诸思择处得善巧故。所以者何。由此善巧能得二种称赞利益。所谓作意称赞利益。论议决择称赞利益。作意称赞利益者。谓善顺增长奢摩他毗钵舍那故。善顺增长奢摩他者。谓于如是诸思择处已作善巧。得无疑故。随其所乐于一境界正观现前。心易定故。善顺增长毗钵舍那者。以无量门观察一切所知境界。速令正慧究竟满故。论议决择称赞利益者。由于如是诸思择处善通达故。成就一切问答自在。于诸异论得无所畏

问蕴界处各有几种。答蕴有五种。谓色蕴受蕴想蕴行蕴识蕴。界有十八。谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。处有十二。谓眼处．色处．耳处．声处．鼻处．香处．舌处．味处．身处．触处．意处．法处

问何因蕴唯有五答为显五种我事故谓为显身具我事。受用我事。言说我事。造作一切法非法我事。彼所依止我自体事。于此五中前四是我所事。第五即我相事。言身具者。谓内外色蕴所摄。受等诸蕴受用等义。相中当说。彼所依止我自体事者。谓识蕴是身具等所依我相事义。所以者何。世间有情多于识蕴计执为我。于余蕴计执我所

问何因界唯十八。答由身具等能持过现六行受用性故。身者。谓眼等六根。具者。谓色等六境。过现六行受用者。谓六识。能持者。谓六根六境能持六识。所依所缘故。过现六识能持受用者。不舍自相故。当知十八以能持义故说名界

问何因处唯十二。答唯身及具能与未来六行受用为生长门故。谓如过现六行受用相为眼等所持。未来六行受用相。以根及义为生长门亦尔。所言唯者。谓唯依根境立十二处。不依六种受用相识

问云何名取蕴。答以取合故名为取蕴取者。谓诸蕴中所有欲贪。何故欲贪说名为取。谓于未来现在诸蕴能引不舍故。希求未来染着现在欲贪名取欲者希求相。贪者染着相。由欲希求未来自体为方便故。引取当蕴令起现前。由贪染着现在自体为方便故。执取现蕴令不舍离。是故此二说名为取。问何故界处说有取法。答应如蕴说。当知界处与取合故名有取法

问色蕴何相。答变现相是色相。此有二种。一触对变坏。二方所示现。触对变坏者。谓由手足乃至蚊蛇所触对时即便变坏。方所示现者。谓由方所可相示现如此如此色。如是如是色或由定心。或由不定寻思相应种种构画。方所者。谓现前处所。如此如此色者。谓骨锁等所知事同类影像。如是如是色者。谓形显差别。种种构画者。谓如相而想

问受蕴何相。答领纳相是受相。谓由受故领纳种种净不净业所得异熟。若清净业受乐异熟。不清净业受苦异熟净不净业受不苦不乐异熟。所以者何。由净不净业感得异熟阿赖耶识。恒与舍受相应。唯此舍受是实异熟体。苦乐两受从异熟生故。假说名异熟

问想蕴何相。答构了相是想相。由此想故构画种种诸法像类。随所见闻觉知之义起诸言说。见闻觉知义者。眼所受是见义。耳所受是闻义。自然思构应如是。如是是觉义。自内所受是知义。诸言说者。谓诠辩义

问行蕴何相。答造作相是行相。由此行故令心造作。谓于善恶无记品中驱役心故。又于种种苦乐等位驱役心故

问识蕴何相。答了别相是识相。由此识故了别色声香味触法等种种境界

问眼界何相。答谓眼曾现见色。及此种子积集异熟阿赖耶识是眼界相。眼曾见色者。谓能持过去识受用义以显界性。现见色者。谓能持现在识受用义以显界性。及此种子积集异熟阿赖耶识者。谓眼种子。或唯积集。为引当来眼根故。或已成熟。为生现在眼根故。此二种名眼界者眼生因故。如眼界相耳鼻舌身意。界相亦尔。问色界何相。答诸色眼曾现见。及眼界于此增上。是色界相。眼界于此增上者。谓依色根增上力外境生故。如色界相声香味触法界相亦尔

问眼识界何相。答谓依眼缘色似色了别。及此种子积集异熟阿赖耶识是眼识界相。如眼识界耳鼻舌身意识界相亦尔

问处何相。答如界应知随其所应。谓眼当见色。及此种子等随义应说

云何建立色蕴。谓诸所有色。若四大种及四大种所造。所造者。谓以四大种为生依立持养因义。即依五因说名为造。生因者即是起因谓离大种色不起故。依因者即是转因谓舍大种诸所造色无有功能。据别处故。立因者即随转因。由大变异能依造色随变异故。持因者即是住因。谓由大种诸所造色相似相续生。持令不绝故。养因者即是长因。谓由大种养彼造色令增长故

四大种者。谓地水火风界。地界者坚劲性。水界者流湿性。火界者温热性。风界者轻动性。所造色者。谓眼等五根。色声香味所触一分及法处所摄色。眼根者。谓四大种所造眼识所依。清净色为体。耳根者。谓四大种所造耳识所依。清净色为体。鼻根者。谓四大种所造鼻识所依。清净色为体。舌根者。谓四大种所造舌识所依。清净色为体。身根者。谓四大种所造身识所依。清净色为体

色者。四大种所造眼根所行义。谓青黄赤白长短方圆。粗细高下若正不正。光影明闇云烟尘雾。迥色表色空一显色。此复三种。谓妙不妙俱相违色。此青等二十五色建立。由六种因。谓相故安立故损益故作所依故作相故庄严故。如其次第四十八一一一。迥色者。谓离余碍触方所可得。空一显色者。谓上所见青等显色

声者四大种所造耳根所取义。若可意。若不可意。若俱相违。若因受大种。若因不受大种。若因俱大种。若世所共成。若成所引。若遍计所执。若圣言所摄。若非圣言所摄。如是十一种声。由五种因所建立。谓相故。损益故。因差别故。说差别故。言差别故。相者。谓耳根所取义。说差别者。谓世所共成等三。余如其所应。因受大种者。谓语等声。因不受大种者。谓树等声。因俱者。谓手鼓等声。世所共成者。谓世俗语所摄。成所引者。谓诸圣所说。遍计所执者。谓外道所说。圣非圣言所摄者。谓依见等八种言说

香者四大种所造鼻根所取义。谓好香恶香平等香俱生香和合香变异香。当知此香三因建立。谓相故损益故差别故。俱生香者。旃弹那等。和合香者。谓和香等。变异香者。谓熟果等。味者四大种所造舌根所取义。谓苦酢甘辛咸淡。若可意若不可意若俱相违。若俱生若和合若变异。建立此味应如香说

所触一分者四大种所造身根所取义。谓滑涩轻重软缓急冷饥渴饱力劣闷痒黏病老死疲息勇。此所触一分由八因建立。谓相故摩故称故触故执故杂故界不平等故界平等故。水风杂故冷。地水杂故黏。界平等故息力勇。勇者无畏饱。由二种界不平等故有饥等。余触

法处所摄色者。略有五种。谓极略色．极迥色．受所引色．遍计所起色．自在所生色。极略色者。谓极微色。极迥色者。谓即此离余碍触色。受所引色者。谓无表色。遍计所起色者。谓影像色。自在所生色者。谓解脱静虑所行境色。云何建立受蕴。谓六受身眼触所生受。乃至意触所生受。若乐若苦若不苦不乐。复有乐身受苦身受不苦不乐身受。乐心受苦心受不苦不乐心受。复有乐有味受苦有味受不苦不乐有味受。乐无味受苦无味受不苦不乐无味受。复有乐依耽嗜受苦依耽嗜受不苦不乐依耽嗜受。乐依出离受苦依出离受不苦不乐依出离受。身受者。谓五识相应受。心受者。谓意识相应受。有味受者。谓自体爱相应受。无味受者。谓此爱不相应受。依耽嗜受者。谓妙五欲爱相应受。依出离受者。谓此爱不相应受。如是建立由四种因。谓所依故自体故。集所依故。杂染清净故。集色所依建立身受。集无色所依建立心受。由杂染故建立有味等。由清净故建立无味等。此爱不相应者。谓离系及随顺离系。云何建立想蕴。谓六想身。眼触所生想。乃至意触所生想。由此想故或了有相。或了无相。或了小大无量。或了无少所有无所有处有相想者。谓除不善言说无相界定及有顶定想所余想。无相想者。谓前所除想。小想者。谓能了欲界想。大想者。谓能了色界想。无量想者。谓能了空。无边处识无边处想。无所有处想者。谓能了无所有处想。不善言说想者。谓未学语言故。虽于色起想而不能了。此名为色故名无相想。无相界定想者。谓离色等一切相无相涅槃想故。名无相想。有顶定想者。谓彼想不明利。不能于境图种种相故。名无相想。小者。谓欲界下劣故。大者。谓色界增上故。无量者。谓空无边处识无边处无边际故。是故缘彼诸想亦名小大无量

云何建立行蕴。谓六思身。眼触所生思。乃至意触所生思。由此思故思作诸善。思作杂染。思作分位差别。又即此思除受及想与余心所有法并心不相应行。总名行蕴。虽除受想。一切心所有法及心不相应行。皆行蕴相。然思最胜与一切行为导首。是故偏说。为显此义故。说由思造善法等。善者。谓当说信等。杂染者。谓当说贪等。根本烦恼及贪等烦恼分少分烦恼。分位差别者。谓于思所发种种行位。假设心不相应行

问何等名余心所有法。答所谓作意触欲胜解念三摩地慧信。惭愧无贪无嗔无痴勤安不放逸舍。不害贪嗔慢无明。疑萨迦耶见边执见见取戒禁取邪见忿恨覆恼嫉悭诳谄憍害无惭无愧惛沉掉举不信懈怠放逸忘念不正知散乱睡眠恶作寻伺。如是思等五十五法。若遍行若别境若善若烦恼若随烦恼若不定。如其次第五五十一十二十四应知。又此诸心所有法若相若业。当广分别

思者。于心造作意业为体。于善不善无记品中役心为业。于心造作意业为体者。此辩其相。于善等品中役心为业者。此辩其业。以于所作善等法中发起心故

作意者。发动心为体。于所缘境持心为业。于所缘境持心者。谓即于此境数数引心。是故心得定者名得作意。触者。依三和合诸根变异分别为体。受所依为业。谓识生时所依诸根随顺生起苦乐等受变异行相。随此行相分别触生

欲者于所乐事彼彼引发所作希望为体。正勤所依为业。彼彼引发所作希望者。谓欲引摄见闻等一切作用故。胜解者。于决定事随所决定印持为体。不可引转为业。随所决定印持者。谓是事必尔非余决了胜解。由胜解故所有胜缘不能引转。念者。于串习事令心明记不忘为体。不散乱为业。串习事者。谓先所受。不散乱业者。由念于境明记忆故令心不散

三摩地者。于所观事令心专一为体。智所依止为业。令心专一者。于一境界令心不散故。智所依者。心处静定知如实故

慧者。于所观事择法为体。断疑为业。断疑者。谓由慧择法得决定故

信者。于有体有德有能忍可清净希望为体。乐欲所依为业。谓于实有体起忍可行信。于实有德起清净行信。于实有能起希望行信。谓我有力能得能成

惭者。于诸过恶自羞为体。恶行止息所依为业

愧者。于诸过恶羞他为体。业如惭说。无贪者。于有有具无著为体。恶行不转所依为业

无嗔者。于诸有情苦及苦具无恚为体。恶行不转所依为业

无痴者。由报教证智决择为体。恶行不转所依为业。惭等易了故不再释。报教证智者。谓生得闻思修所生慧。如次应知。决择者。谓慧勇勤俱

勤者。被甲方便无下无退。无足心勇为体成满善品为业。谓如经说。有势有勤有勇坚猛不舍善轭。如其次第应配释被甲心勇等诸句。满善品者。谓能圆满随初所入根本静虑。成善品者。谓即于此极善修治

安者。止息身心粗重身心调畅为体。除遣一切障碍为业。除遣一切障碍者。谓由此势力依止转故

不放逸者。依止正勤无贪嗔痴修诸善法。于心防护诸有漏法为体。成满一切世出世福为业。谓由正勤等为先能修一切善法及防有漏。是故依此四法假立不放逸体。有漏法者。谓诸漏及漏处所境界

舍者。依止正勤无贪嗔痴与杂染住相违。心平等性。心正直性。心无功用住性为体。不容杂染所依为业。心平等性等者。谓以初中后位辩舍差别。所以者何。由舍与心相应离沉没等不平等性故。最初证得心平等性。由心平等远离加行自然相续故。次复证得心正直性。由心正直于诸杂染无怯虑故。最后证得心无功用住性。不害者。无嗔善根一分心悲愍为体。不损恼为业。当知不害不离无嗔故亦是假

贪者三界爱为体。生众苦为业。生众苦者谓由爱力五取蕴生故

嗔者。于诸有情苦及苦具心憎恚为体。不安隐住恶行所依为业。不安隐住者。谓心怀憎恚多住苦故

慢者。依止萨迦耶见心高举为体。不敬苦生所依为业。不敬者。谓于师长及有德所而生憍傲。苦生者。谓生后有故

无明者。谓三界无智为体。于诸法中邪决定疑杂染生起所依为业。邪决定者。谓颠倒智。疑者犹豫。杂染生起者。谓贪等烦恼现行。彼所依者。谓由愚痴起诸烦恼

疑者。于谛犹豫为体。善品不生依止为业。于谛犹豫者。亦摄于实犹豫。如其所应灭道谛摄故。善品不生者。谓由不决不造修故

萨迦耶见者。于五取蕴等随观执我及我所。诸忍欲觉观见为体。一切见趣所依为业

边执见者。于五取蕴等随观执。若常若断。诸忍欲觉观见为体。障处中行出离为业。处中行者。谓离断常缘起正智

见取者。谓于诸见及见所依五取蕴等。随观执为最为胜为上为妙。诸忍欲觉观见为体。执不正见所依为业。戒禁取者。于诸戒禁及戒禁所依五取蕴等。随观执为清净为解脱为出离。诸忍欲觉观见为体。劳而无果所依为业。戒禁者。谓恶见为先。劳无果者。由此不能得出离故

邪见者。谤因谤果。或谤作用。或坏实事。或邪分别。诸忍欲觉观见为体。断善根为业。及不善根坚固所依为业。不善生起为业。善不生起为业。谤因者。谓无施与无爱乐无祠祀无妙行无恶行等。谤果者。谓无妙行及恶行业所招异熟等。谤作用者。谓无此世间无彼世间。无母无父无化生有情等。诽谤异世往来作用故。诽谤任持种子作用故。诽谤相续作用故。坏实事者。谓无世间阿罗汉等。邪分别者。谓余一切分别倒见。断善根者。谓由增上邪见非一切种

问如是五见几增益见几损减见。答四是增益见。于所知境增益自性及差别故。于诸见中增益第一及清净故。谓于五取蕴所知无我境。增益我我所自性。是萨迦耶见。增益我常无常差别。是边执见。于诸恶见增益第一。是见取。即于此见增益清净。是戒禁取。一多分是损减见。一多分者。由邪分别不必损减故

问计前后际所有诸见。彼于此五几见所摄。答或二或一切。问于不可记事所有诸见。彼于此五几见所摄。答或二或一切。二者。谓边执见及邪见自相故。一切者谓五见眷属故

问薄伽梵观何过失故。于蕴界处以五种相诽毁计我。答观彼摄受萨迦耶见者。有五种过失故。谓异相过失。无常过失。不自在过失。无身过失。不由功用解脱过失。异相过失者。谓色蕴等非我体性。异我相故。无常过失者。谓非我处色蕴等中。我应无常故。所以者何。非所依无能依有故不自在过失者。谓不应观我有色等。我应不自在故所以者何。我于色等不能自在转故。无身过失者。谓非离色等异处有我。我应无身故。所以者何。离身计我不可得故。不由功用解脱过失者。设有如是分别我相亦不应理。无色等我不由功用应解脱故。所以者何。身缚若无我应任运解脱

问于五取蕴有二十句萨迦耶见。谓计色是我我有诸色。色属于我我在色中。如是计受想行识是我我有识等识等属我我在识等中。于此诸见几是我见几我所见。答五是我见。十五是我所见。谓计色是我。计受想行识是我。此五是我见。余十五是我所见。何因十五是我所见。相应我所故。随转我所故。不离我所故。相应我所者。谓我有色乃至我有识。所以者何。由我与彼相应说有彼故。随转我所者。谓色属我乃至识属我所以者何。若彼由此自在力转。或舍或役。世间说彼是我所故。不离我所者。谓我在色中乃至我在识中。所以者何。彼计实我处在蕴中遍体随行故

问萨迦耶见当言于事了不了耶。答当言于事不得决了。如于绳上妄起蛇解。于事不决了者。若能决了色等实相。必不应起虚妄我见。譬如有人欻尔见绳遂执为蛇。不了绳相而起蛇执

忿者。依止现前不饶益相嗔之一分。心怒为体。执仗愤发所依为业。当知忿等是假建立。离嗔等外无别性故。恨者。自此已后即嗔一分。怀怨不舍为体。不忍所依为业自此后者。谓从忿后。不忍者。谓不堪忍不饶益事

覆者。于所作罪他正举时。痴之一分隐藏为体。悔不安住所依为业。法尔覆藏所作罪者心必忧悔。由此不得安隐而住

恼者。忿恨居先嗔之一分心戾为体。高暴粗言所依为业。生起非福为业。不安隐住为业。高暴粗言者。谓语现凶疏切人心腑

嫉者。耽着利养不耐他荣。嗔之一分心妒为体。令心忧戚不安隐住为业。悭者。耽着利养。于资生具贪之一分心吝为体。不舍所依为业。不舍者。由悭吝故。非所用具亦恒聚积

诳者。耽着利养贪痴一分。诈现不实功德为体。邪命所依为业

谄者。耽着利养贪痴一分。矫设方便隐实过恶为体。障正教授为业。矫设方便隐实过恶者。谓托余事以避余事。障正教授者。由不如实发露所犯。不任教授故

憍者。或依少年无病长寿之相。或得随一有漏荣利之事。贪之一分令心悦豫为体。一切烦恼及随烦恼所依为业。长寿相者。谓不死觉为先分别此相。由此能生寿命憍逸。随一有漏荣利事者。谓族姓色力聪睿财富自在等事。悦豫者。谓染喜差别

害者。嗔之一分无哀无悲无愍为体。损恼有情为业

无惭者。贪嗔痴分。于诸过恶不自耻为体。一切烦恼及随烦恼助伴为业。无愧者。贪嗔痴分。于诸过恶不羞他为体。业如无惭说

惛沈者。谓愚痴分心无堪任为体。障毗钵舍那为业

掉举者。谓贪欲分。随念净相心不寂静为体。障奢摩他为业。随念净相者。谓追忆往昔随顺贪欲戏笑等故心不寂静

不信者。谓愚痴分。于诸善法心不忍可。心不清净。心不悕望为体。懈怠所依为业。懈怠所依者。由不信故无有方便加行乐欲

懈怠者。谓愚痴分。依着睡眠倚卧为乐心不策励为体。障修方便善品为业

放逸者。依止懈怠及贪嗔痴不修善法。于有漏法心不防护为体。增恶损善所依为业。忘念者。烦恼相应念为体。散乱所依为业。不正知者。烦恼相应慧为体。由此慧故起不正知身语心行。毁犯所依为业。不正知身语心行者。谓于往来等事不正观察。以不了知应作不应作故多所毁犯

散乱者。谓贪嗔痴分心流散为体。此复六种。谓自性散乱。外散乱。内散乱。相散乱。粗重散乱。作意散乱。自性散乱者。谓五识身由彼自性于内静定无功能故。外散乱者。正修善时于五妙欲其心驰散。谓方便修闻等善法。舍彼所缘心外驰散处妙欲中。内散乱者。正修善时沉掉味着。谓修定者发起沉掉及味着故退失静定。相散乱者。为他归信矫示修善。谓欲令他信己有德故现此相。由此因缘所修善法渐更退失。粗重散乱者。依我我所执及我慢品粗重力故。修善法时于已生起所有诸受。起我我所及与我慢。执受间杂取相。谓由我执等粗重力故于已生起乐等受中。或执为我。或执我所。或起我慢。由此所修善品永不清净。执受者。谓初执着。间杂者。从此已后由此间杂诸心相续。取相者。谓即于此受数执异相。作意散乱者。谓于余乘余定若依若入所有流散。谓依余乘或入余定。舍先所习发起散乱。当知能障离欲为业。谓依随烦恼性散乱说

睡眠者。依睡因缘。是愚痴分心略为体。或善或不善或无记。或时或非时。或应尔。或不应尔。越失所作依止为业。睡因缘者。谓羸瘦疲倦身分沉重。思惟闇相舍诸所作曾数此时串习睡眠。或他咒术神力所引。或因动扇凉风吹等。愚痴分言为别于定。又善等言为显此睡非定痴分。时者。谓夜中分。非时者。谓所余分。应尔者。谓所许时设复非时。或因病患或为调适。不应尔者。谓所余分。越失所作依止为业者。谓依随烦恼性睡眠说

恶作者。依乐作不乐作应作不应作。是愚痴分心追悔为体。或善或不善或无记。或时或非时。或应尔或不应尔。能障心住为业乐作者。乐欲为先造善恶行。不乐作者。由他势力及诸烦恼之所驱逼。令有所作如其所应。愚痴分者随烦恼所摄。时者。乃至未出离。非时者。出离已后。应尔者。于是处。不应尔者。于非处

寻者。或依思或依慧寻求意言令心粗为体。依思依慧者。于推度不推度位。如其依第追求行相意言分别

伺者。或依思或依慧伺察意言令心细为体。依思依慧者。于推度不推度位。如其次第伺察行相意言分别。如是二种安不安住所依为业。寻伺二种行相相类故。以粗细建立差别

复次诸善心法断自所治为业。烦恼随烦恼障自能治为业。如信惭等能断不信及无惭等贪等烦恼能障无贪对治等法。谓障碍彼令不生故。当知忿等诸随烦恼能障慈等。各别对治亦尔

大乘阿毗达磨杂集论卷第一大乘阿毗达磨杂集论卷第二

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    本事分中三法品第一之二

何等名为心不相应行。谓得无想定灭尽定无想异熟命根众同分生老住无常名身句身文身异生性流转定异相应势速次第时方数和合等。如是心不相应行。应以五门建立差别。谓依处故自体故假立故作意故地故。二无心定具足五门。无想天异熟除作意。余唯初三

得者。谓于善不善无记法。若增若减假立获得成就。善不善无记法者。显依处。若增若减者。显自体。何以故。由有增故说名成就上品信等。由有减故说名成就下品信等。假立获得成就者。显假立。如是于余随其所应建立当知

无想定者。谓已离遍净欲。未离上欲。出离想作意为先故。于不恒行心心法灭。假立无想定。已离遍净欲者。已离第三静虑贪。未离上欲者。未离第四静虑已上贪。出离想作意为先者。解脱想作意为前方便。不恒行者。转识所摄。灭者。谓定心所引不恒现行。诸心心法暂时间灭所依位差别。以能灭故名灭

灭尽定者。谓已离无所有处欲。超过有顶。暂息想作意为先故。于不恒行诸心心法及恒行一分心心法灭。假立灭尽定。此中所以不言未离上欲者。为显离有顶欲。阿罗汉等亦得此定故。一分恒行者。谓染污意所摄

无想异熟者。谓已生无想有情天。于不恒行心心法灭。假立无想异熟

命根者。谓于众同分先业所感。住时决定假立寿命。众同分者。于一生中诸蕴相续。住时决定者。齐尔所时令众同分常得安住。或经百年或千年等。由业所引功能差别

众同分者。谓如是如是有情于种种类自体相似假立众同分。于种种类者。于人天等种类差别。于自体相似者。于一种类性

生者。谓于众同分诸行本。无今有性。假立为生。问外诸色等亦有生相。何故唯举众同分耶。答为于有情相续建立有为相故。所以者何。外诸色等有为相成坏所显。内诸行有为相生老等所显故。老者。谓于众同分诸行相续变异性。假立为老。住者。谓于众同分诸行相续不变坏性。假立为住。无常者。谓于众同分诸行相续变坏性。假立无常相续。变坏者。谓舍寿时当知此中依相续位建立生等。不依刹那

名身者。谓于诸法自性增言。假立名身。自性增言者。谓说天人眼耳等事

句身者。谓于诸法差别增言。假立句身。差别增言者。谓说诸行无常一切有情当死等义。文身者。谓于彼二所依诸字。假立文身。彼二所依诸字者谓。自性差别增言所依诸字如[褒-保+可]壹邬等。又自性差别及此二言总摄一切。如是一切由此三种之所诠表。是故建立此三为名句文身。此言文者。能彰彼二故。此又名显能显义故。此复名字无异转故。所以者何。如眼名眼异。此名外更有照了导等异名改转。由彼同显此想故。非[褒-保+可]壹等字离[褒-保+可]壹等差别外更有差别能显此。字故无异转说名。为字无异。转者谓不流变

异生性者。谓于圣法不得假立异生性

流转者。谓于因果相续不断。假立流转。所以唯于相续不断立流转者。于一刹那或于间断。无此言故

定异者。谓于因果种种差别假立定异。因果种种差别者。谓可爱果妙行为因。不可爱果恶行为因。诸如是等种种因果展转差别。相应者。谓于因果相称假立相应。因果相称者。虽复异类因果相顺亦名相称。由如布施感富财等

势速者。谓于因果迅疾流转。假立势速

次第者。谓于因果一一流转。假立次第因。果一一流转者谓不俱转

时者。谓于因果相续流转。假立为时。何以故。由有因果相续转故。若此因果已生已灭立。过去时。此若未生立未来时。已生未灭立现在时

方者。谓即于东西南北四维上下因果差别假立为方。何以故。即于十方因果遍满假说方故。当知此中唯说色法所摄因果。无色之法遍布处所无功能故

数者。谓于诸行一一差别。假立为数。一一差别者于一无别二三等数不应理故

和合者。谓于因果众缘集会。假立和合。因果众缘集会者。且如识法因果相续。必假众缘和会。谓根不坏境界现前能。生此识作意正起。如是于余一切如理应知

如是等心不相应行法。唯依分位差别而建立故。当知皆是假有。谓于善不善等增减。分位差别建立一种。于心心法分位差别建立三种。于住分位差别建立一种。于相似分位差别建立一种。于相分位差别建立四种。于言说分位差别建立三种。于不得分位差别建立一种。于因果分位差别建立余种。因果者。谓一切有为法能生余故名因。从余生故名果

云何建立识蕴。谓心意识差别

心者。谓蕴界处习气所熏。一切种子阿赖耶识。亦名异熟识。亦名阿陀那识。以能积集诸习气故。习气者。谓由现行蕴等令彼种子皆得增益。一切种子识者。谓能生蕴等诸法种子所积集故。阿赖耶识者。谓能摄藏诸法种子故。又诸有情取为我故。异熟识者。先业所生故。阿陀那识者。谓能数数令生相续。持诸根等令不坏故。又言心者。谓能积集一切法习气故

云何知有阿赖耶识。若无此识。执受初明了种子业身受无心定命终无。皆不应理。释此伽他。如摄决择分说。由八种相。证阿赖耶识决定是有。谓若离阿赖耶识依止执受不可得故。最初生起不可得故。明了生起不可得故。种子体性不可得故。业用体性不可得故。身受体性不可得故。处无心定不可得故。命终之识不可得故。云何依止执受不可得耶。由五因故。谓阿赖耶识先行因感眼等。转识现缘因发。如说根境作意力故诸转识生。乃至广说。是名初因。又六识身善恶可得。是第二因。又六识身一类异熟无记性摄必不可得。是第三因。又六识身各别依转。随所依止彼识生时。即应彼识执所依止。余无执受不应道理。设许执受亦不应理。以离识故。是第四因。又所依止应成数数执受过失。所以者何。由彼眼识于一时转一时不转。余识亦尔。是第五因

云何最初生起不可得耶。谓设有难言。若有阿赖耶识。应一有情二识俱起。应告彼曰。汝于非过妄生过想。容有二识俱时转故。所以者何。犹如有一俱时欲见乃至欲识。随有一识。最初生起不应道理。何以故。尔时作意无有差别。根及境界不坏现前。何因缘故识不俱转

云何明了生起不可得耶。谓若有定执识不俱生。与眼等识俱行一境。明了意识应不可得。所以者何。若时随忆曾所受境。尔时意识不明了生。非于现境所生意识。得有如是不明了相。是故应信诸识俱转。或应许彼第六意识无明了性

云何种子体性不可得耶。谓六转识身各各异故。所以者何。此六转识从善无间不善性生。不善无间善性复生。从二无间无记性生。下界无间中界生。中界无间妙界生。妙界无间乃至下界生。有漏无间无漏生。无漏无间有漏生世间无间出世生。出世无间世间生。非如是相识为种子体应正道理。又心相续长时间断经久流转不息。是故转识能持种子不应道理。云何业用不可得耶。谓若无诸识同时生。起业用俱转不应道理。所以者何。略说识业有四种。谓了别外器。了别依止。能了别我。了别境界。如是四种识了别业。一一刹那俱现可得。非于一识一刹那中有如是等差别业用。是故必有诸识俱起

云何身受体性不可得耶。谓如有一。或如理思。或不如理思。或不思惟。或复推寻。若心在定若不在定。身受生起非一众多。若无阿赖耶识如是身受应不可得。既现可得。是故定有阿赖耶识

云何处无心定不可得耶。如世尊说。入无想定及灭尽定。当知尔时识不离身。若无阿赖耶识。尔时识应离身。识若离身便应舍命。非谓处定

云何命终之识不可得耶。谓临命终时识渐舍离所依身分。发起冷触或上或下。非彼意识有时不转。故知唯有阿赖耶识。能执持身随于身分。若舍此识冷触可得身无觉受。意识不然。是故若无阿赖耶识。命终之识必不可得

意者。谓一切时缘阿赖耶识。思度为性。与四烦恼恒相应。谓我见我爱我慢无明。又此意遍行。一切善不善无记位。唯除圣道现前若处灭尽定及在无学地。又复六识以无间灭识为意。当知此中由所缘故。释义故相应故生起时故。显了于意。何故圣道现前无染污意耶。由胜义智与我见现行极相违故。出圣道后。从阿赖耶识复更现起。以有学位未永断故。又灭尽定望无想定。极寂静故。此染污意不得现行。无间灭意者。由随觉故。无间觉义是意义。当知此中随显相说

识者。谓六识身眼识乃至意识眼识者。谓依眼缘色了别为性。耳识者。谓依耳缘声了别为性。鼻识者。谓依鼻缘香了别为性。舌识者。谓依舌缘味了别为性。身识者。谓依身缘触了别为性。意识者。谓依意缘法了别为性。当知此中由所依故。所缘故自性故。建立于识。云何建立界。谓色蕴即十界眼等五根界。色等五境界及法界一分。受想行蕴即法界一分。识蕴即七识界。谓眼等六识界及意界。何故建立界处无别相耶。建立蕴中已说眼等各别相故。是故从诸蕴中出界建立。从诸界中出处建立

何等界法蕴不摄耶。法界中无为法蕴所不摄。此无为法。复有八种。谓善法真如。不善法真如。无记法真如。虚空非择灭择灭。不动及想受灭

如是建立八无为中。当知所依差别故。分析真如假立三种。不由自性故。善法真如者。谓无我性空性。无相实际。胜义法界。何故真如说名真如。由彼自性无变异故。谓一切时无我实性无改转故说无变异。当知此则是无我性。离二我故。何故复说此名空性。一切杂染所不行故。所以者何。由缘此故能令一切诸杂染事悉皆空寂。虽复有时说有杂染。当知但是客尘烦恼之所染污。何等名为客尘染污。谓由未拔所取能取种子故。令依他性心二行相转。非法性心。以诸法法性自性清净故。何故复说此名无相。诸相寂静故。诸相者。谓色受等乃至菩提。诸所戏论。真如性中彼相寂灭。故名无相。何故复说此名实际。无倒所缘故。实者。谓无颠倒。此处究竟故名为实际。过无我性更无所求故。何故复说此名胜义。最胜圣智所行处故。何故复说此名法界。一切声闻独觉诸佛妙法所依相故。如善法真如。当知不善法真如无记法真如亦尔。虚空者。谓无色性。容受一切所作业故。无色性者。谓唯违于色。无性相法意识境界。是名虚空。意识境界者。谓法界摄故。唯违色言。为别受等共有真如择灭非择灭无常性等。虽兔角等亦是无性。然彼不与诸法相违。以彼唯是毕竟无故。又兔角等非唯违色。由与受等诸法共故。是故唯说与色相违无性相言。为别受等无色之法。何以故。受等自体是有性相非无性相故

非择灭者。谓是灭非离系。不永害随眠故。择灭者。谓是灭是离系。永害随眠故

不动者谓已离遍净欲。未离上欲。苦乐灭无为

想受灭者。谓已离无所有处欲。止息想作意为先故。诸不恒行心心法。及恒行一分心心法灭。无为

当知。此中有二种应断法。谓诸烦恼及此所依受。受有二种。谓变异及不变异。如其次第苦乐非苦乐当知烦恼断故。建立择灭二受断故。如其次第建立不动及受想灭。烦恼断者。谓除此品粗重所得转依。受断者。谓除此能治定障所得转依。是故得第二静虑时。虽证苦灭而不建立无为。以变异受未尽断故。又若五种色若受想行蕴。及此所说八无为法。如是十六总名法界

云何建立处。谓十色界即十色处。七识界即意处。法界即法处

由此道理诸蕴界处三法所摄。谓色蕴法界及与意处。由色蕴摄十色界。法界即摄法界。意处摄七识界。是故三法摄一切法

如是建立蕴界处已。今乘此义应更分别。问眼耳与鼻各有二种。云何不立二十一界。答彼虽有二然界不别。所以者何。其相相似俱眼相故。所作相似俱于眼境。眼识一所作故。如是耳鼻随理应知。为身端严各生二种。何以故。如是分布一界二所身得端严。不由余故。问为常依一一眼故眼识得生。为亦依二耶。答亦得依二。明了取故。所以者何。若俱开二眼取色明了非如开一譬如一室俱然二灯。同发一光照极明了。如是一光依二灯转当知此中道理亦尔。问于一一根门种种境界俱现在前。于此多境为有多识次第而起。为俱起耶。答唯有一识种种行相俱时而起。若诸段食与舌根合。当知身舌二识恒俱时起。又声间断故。不从异处展转生起相续往趣余方。然譬于灯置在自处。能于一时随其势力遍发光明。声顿遍发理亦如是。问何故于近障声闻不明了。答声有对故。于障细隙微少而生故不明了。问于六识中几有分别。答唯一意识由三分别故有分别。三分别者。谓自性分别。随念分别。计度分别。自性分别者。谓于现在所受诸行自相行分别。随念分别者。谓于昔曾所受诸行追念行分别。计度分别者。谓于去来今不现见事思构行分别。复有七种分别。谓于所缘任运分别。有相分别。无相分别。寻求分别。伺察分别。染污分别。不染污分别。初分别者。谓五识身如所缘相无异分别。于自境界任运转故。有相分别者。谓自性随念二种分别。取过现境种种相故。无相分别者。谓希求未来境行分别。所余分别皆用计度分别以为自性。所以者何。以思度故。或时寻求。或时伺察。或时染污。或不染污。种种分别。问若了别色等故名为识。何故但名眼等识。不名色等识耶。答以依眼等五种解释道理成就。非于色等。何以故。眼中之识故名眼识。依眼处所识得生故。又由有眼识得有故。所以者何。若有眼根眼识定生。不盲瞑者乃至闇中亦能见故。不由有色眼识定生。以盲瞑者不能见故。又眼所发识故名眼识。由眼变异识亦变异。色虽无变识有变故。如迦末罗病损坏眼根。于青等色皆见为黄。又属眼之识故名眼识。由识种子随逐于眼而得生故。又助眼之识故名眼识。作彼损益故。所以者何。由根合识有所领受令根损益。非境界故。又如眼之识故名眼识。俱有情数之所摄故。色则不尔。不决定故。眼识既然余识亦尔。问为眼见色。为识等耶。答非眼见色亦非识等。以一切法无作用故。由有和合假立为见。又由六相。眼于见色中最胜非识等。是故说眼能见诸色何等为六。一由生因。眼能生彼故。二由依处。见依眼故。三由无动转。眼常一类故。四由自在转。不待缘合念念生故。五由端严。转由此庄严所依身故。六由圣教。如经中说。眼能见色故。如是所说六种相貌。于识等中皆不可得。识动转者。当知多种差别生起。何故无为立在界处不在蕴耶。无蕴义故。所以者何。色等诸法有去来等种种差别总略积聚说名为蕴。聚积义是蕴义常住之法无有此义。是故无为非蕴所摄。何故即如是法以蕴界处门差别说耶。欲令所化有情于广略门生善巧故。所以者何。于蕴门中略说色识。于界处门随其所应广说十七。又于蕴门广说受等。于界处门略说为一法界法处。又蕴门中唯说建立有为法相。界门广说建立能取所取及取体性处门唯说建立能取所取。由此唯显取生门故。已辩傍乘义。今当释本文

问如经中说眼及眼界。若眼亦眼界耶。设眼界亦眼耶答或有眼非眼界。谓阿罗汉最后眼。或有眼界非眼。谓处卵[穀-禾+卵]羯逻蓝时。頞部陀时。闭尸时。在母腹中若不得眼。设得已失。若生无色。异生所有眼因或有眼亦眼界谓于余位。或有无眼无眼界。谓已入无余涅槃界。及诸圣者生无色界。如眼与眼界。如是耳鼻舌身与耳等界。随其所应尽当知。阿罗汉最后眼者。谓入涅槃时最后刹那。尔时眼非眼界。非余眼因故。无色界异生有眼因者。谓从彼退堕当生有色界。以阿赖耶识持眼种子定当生眼故。生彼众圣不退还故。无有眼界。有身界无身者。谓唯生无色界异生。彼唯有身因故。非处卵[穀-禾+卵]等。彼必有身故。若身坏灭寿命亦无。问若有意亦意界耶。设有意界亦意耶。答或有意非意界。谓阿罗汉最后意。或有意界非意。谓处灭定者所有意因。或有意亦意界。谓于所余位。或有无意无意界。谓已入无。余涅槃界。唯有意界非意。中所以不取入无想定者。以彼有染污意故。问若生长彼地即。用彼地眼还见彼地色耶。答或有即用彼地眼还见彼地色。或复余地。谓生长欲界用欲行眼还见欲行色。或用色行眼见色行色。或用上地眼见下地色。如以眼对色。如是以耳对声。如生长欲界。如是生长色界。生者。谓初受生时。长者。谓后增长。若生长欲界即以欲行鼻舌身。还嗅尝觉欲行香味触。若生长色界即以色行身。还觉自地触。彼界自性定无香味。离段食贪故。由此道理亦无鼻舌两识若生长欲界即以欲行意了三界法及无漏法。如生长欲界。如是生长色界。若生长无色界。以无色行意了无色行自地法及无漏法。若以无漏意了三界法及无漏法。无色行意了无色行自地法及无漏法者。谓依圣弟子说。若外异生唯了自地法若住此法者。或有由先闻熏习力。亦缘上地为起彼故

问何故诸蕴如是次第。答由识住故。谓四识住及识。又前为后依故。如其色相而领受故。如所领受而了知故。如所了知而思作故。如所思作随彼彼处而了别故。如其色相而领受者。谓由随顺乐受等根境二力故。乐受等生。如所领受而了知者。谓随所受取诸相故。如所了知而思作者。谓随所想造诸业故。如所思作随彼彼处而了别者。谓随所作业于诸境界及异趣中识转变故。又由染污清净故。谓若依是处而起染净。若由领受取相造作故。染污清净。若所染污及所清净。由此理故说蕴次第。若依是处起染净者。谓依有根身。若由领受者。谓由有染无染等受。如其次第染污清净。若由取相造作者。谓由如理不如理转故。如其次第染污清净。若所染污及所清净者。谓心有粗重无粗重生故

何故诸界如是次第。由随世事差别转故。云何世事差别而转。谓诸世间最初相见。既相见已更相问讯。既问讯已即受沐浴涂香花鬘。次受种种上妙饮食。次受种种卧具侍女。然后意界处处分别。以内界次第故建立外界。随此次第建立识界。如界次第处亦如是。问蕴义云何。答诸所有色若过去若未来若现在。若内若外若粗若细。若劣若胜若远若近。彼一切略说一色蕴。积聚义故。如财货蕴。如是乃至识蕴当知依止十一种。爱所依处故。于色等法建立过去等差别。十一种爱者。谓顾恋爱。希望爱。执着爱。内我爱。境界爱。欲爱定爱。恶行苦爱。妙行乐爱。远爱。近爱。由如是爱所缘境故。如其次第立过去等种种差别。又有差别。谓已生未生差别故能取所取差别故。外门内门差别故。染不染差别故。近远差别故。如其所应于色等诸法建立过去等差别。已生者。谓过去现在。未生者。谓未来。外门者。谓不定地内门者。谓诸定地。余句易了不复分别。又苦相广大故名为蕴。如大材蕴。依止色等发起生等广大苦故。如经言。如是纯大众苦蕴集。又荷杂染担故名为蕴如肩荷担。荷杂染担者。谓烦恼等诸杂染法依色等故。譬如世间身之一分能荷于担。即此一分名肩名蕴。色等亦尔。能荷杂染担故。名之为蕴

问界义云何。答一切法种子义。谓依阿赖耶识中诸法种子说名为界。界是因义故。又能持自相义是界义。又能持因果性义是界义。能持因果性者。谓于十八界中根境诸界及六识界。如其次第又摄持一切。法差别义是界义。摄持一切法差别者。谓诸经说地等诸界及所余界。随其所应皆十八界摄

问处义云何。答识生长门义是处义。当知种子义。摄一切法差别义。亦是处义

复次如佛所说。色如聚沫。受如浮泡。想如阳焰。行如芭蕉。识如幻化。问以何义故色如聚沫。乃至识如幻化。答以无我故。离净故。少味故。不坚实故。谓非有远离虚妄不坚实义。是经所说诸句义。又为对治我净乐常四颠倒故。如其次第说无我等诸句差别

大乘阿毗达磨杂集论卷第二大乘阿毗达磨杂集论卷第三

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    本事分中三法品第一之三

复次蕴界处广分别云何嗢拖南曰

  实有性等所知等　　色等漏等已生等
  过去世等诸缘等　　云何几种为何义

问蕴界处中云何实有。几是实有。为何义故观实有耶。答谓不待名言此余根境是实有义。一切皆是实有。为舍执着实有我故。观察实有。所以建立此三问者。为断相事二愚及增益执故。云何实有者辩实有相为断相愚。一切实有者为断事愚。舍着实我者为断增益执。如是余处如理应知。不待名言根境者。谓不分别色受等名言而取自所取义。不待此余根境者。谓不待此所余义而觉自所觉境。非如于瓶等事要待名言及色香等方起瓶等觉

云何假有。几是假有。为何义故观假有耶。谓待于名言此余根境是假有义。一切皆是假有。为舍执着。实有我故。观察假有

云何世俗有几是世俗有。为何义故观世俗有耶。谓杂染所缘是世俗有义。一切皆是世俗有。为舍执着杂染相我故。观察世俗有杂染所缘者。能发一切杂染义故。杂染相我者。执我为杂染因故

云何胜义有。几是胜义有。为何义故观胜义有耶。谓清净所缘是胜义有义。一切皆是胜义有。为舍执着清净我相故。观察胜义有。清净所缘者。为得清净缘此境界。是最胜智所行义故。一切皆是胜义有者。以一切法不离真如故。诸法无我性是名真如。彼无我性真实有故

云何所知。几是所知。为何义故观所知耶。谓所知有五种色。心心所有法心不相应行无为。色谓色蕴。十色界十色处及法界法处所摄诸色。心谓识蕴。七识界及意处。心所有法。谓受蕴想蕴相应行蕴及法界法处一分。心不相应行谓不相应行。蕴及法界法处一分。无为谓法界法处一分。若依是处杂染清净。若所杂染及所清净。若能杂染及能清净。若于此分位。若此清净性。由依此故。一切皆是所知。处者谓色法。所染净者。谓心法。能染净者。谓贪等信等心所有法如其次第。分位者。谓于色心及心法分位。假立心不相应行法。清净性者。谓清净无为法。如其所应非一切。所以者何。唯法界及择灭。是清净性故。又所知法者。谓信解智所行故。道理智所行故。不散智所行故。内证智所行故。他性智所行故下智所行故。上智所行故。厌患智所行故。不起智所行故。无生智所行故。智智所行故。究竟智所行故。大义智所行故。当知此中以十三种智所缘境界。显示所知义。十三智者。谓闻所生智。思所生智。世间修所生智。胜义智。他心智法智种类智。苦智集智灭智道智。尽无生智。大乘智。如是诸智随其次第是信解等智他心智名他性智者。谓缘他心为境故。法智名下智者。谓于诸谛最初生故。种类智名上智者。谓从法智后所生故为厌患故名厌患智。为不起故名不起智。缘无生故名无生智。缘智故名智智。缘究竟故名究竟智。缘大义故名大义智。自利利他名为大义。为舍执着知者见者我故。观察所知

云何所识。几是所识。为何义故观所识耶。谓无分别故。有分别故。因故转故相故。相所生故。能治所治故。微细差别故。当知是所识义。无分别者。谓五识身。有分别者。谓意识身。因者。谓阿赖耶识。转者。谓所余识。相者。谓根及义。相所生者。谓根义所生诸识。能治所治者。谓有贪离贪。有嗔离嗔。有痴离痴。如是等。微细差别者。谓七种难识了别差别。故七种难识了别者。一不可知了别器了别。谓一切时无分别行相故。二种种行相了别。谓一法一行有种种相。此难建立是故微细。三俱有了别。谓一时间诸识俱起。云何各别了自境界。此难建立是故微细。当知此微细言通一切处。四能治所治速疾回转了别。谓具缚者云何有贪等心。须臾转变起离贪等心。五习气了别。谓诸业现行熏习于心。云何非离心外别有习气亦非即心。又与果时次第而转。六相续了别。谓无量种感自身业熏习在识。云何于余明了将命终位暂起觉悟。余业熏习转于异趣令生相续。七解脱了别。谓阿罗汉心证得第一无戏论法性。超过生死曾所积习一切种有漏行。云何此心行相流转。此难建立是故微细。如是当知。一切皆是所识。为舍执着能见者等我故。观察所识。见者等言当知。为显见者闻者嗅者尝者触者识者

云何所通达。几是所通达为何义故观所通达耶。谓转变故随闻故入行故来故往故出离故。是所通达义言所通达者。谓六神通所有境界。以如意通运转差别所显故。说此所通达境界名为转变。以天耳通了达种种异趣音声故名随闻。以他心通了有贪等种种心行。故名入行。以宿住通了过去生展转来事。故名来。以天眼通了达未来所往生事故名往。以漏尽通了知解脱三界方便故名出离。如是一切皆是所通达。后以三通遍缘一切境界故。为舍执着自威德我故。观察所通达

云何有色。几是有色。为何义故观有色耶。谓色自性故。依大种故。喜集故。有方所故。处遍满故。方所可说故。方处所行故。二同所行故。相属故。随逐故。显了故。变坏故。显示故积集建立故。外门故。内门故。长远故。分限故。暂时故。示现故。是有色义。色自性者。谓即用色法为自性故名为有色。非与余色合故名为有色。是故最初说色自性。依大种者。此显与余色合故名有色。诸所造色与大种色合故名有色。诸大种色展转合故名有色。喜集者。即有色法以喜为集名为喜集。非如现在喜爱以先触受等为集名为喜集。有方所者。有分量故。处遍满者。形量遍十方故。方所可说者。可说在此在彼方故。方处所行者。谓随所住方所缘性故。二同所行者。谓二有情共所缘性故。非如无色法。如自所受他不能取故。相属者。谓眼识等亦名有色系。属有色根故。随逐者。谓生无色界异生诸色种子所随逐故。显了者谓诸寻思由能显了所缘境故。变坏者。谓五蕴。由手等所触受等所切。随其所应即便变坏以变坏是色义故。显示者。谓诸言说显示义故。积集建立者。谓极微已上色。有微细分可建立故外门者。谓欲界色。妙欲爱所生故。内门者谓色界色。定心爱所生故。由此道理说彼诸色。名意生身。长远者。谓异生色不可建立。前后两际有边量故。分限者。谓有学色。已作生死分限故。暂时者。谓无学色。唯余现在一有身故。示现者。谓如来等所现诸色。唯是示现非真实故。一切皆是有色。或随所应。一切是有色者。谓变坏色等。随所应者。谓余色外门等六。色差别当知与受等共。为舍执著有色我故。观察有色

云何无色。几是无色。为何义故观无色耶谓有色相违是无色义。一切皆是无色。或随所应。为舍执着无色我故。观察无色。一切是无色者。谓与无色相系属故

云何有见。几是有见。为何义故观有见耶。谓眼所行境是有见义。余差别如有色说。谓如前说。色自性等乃至示现说名有色。如是有见自性等乃至示现。说名有见一切皆是有见。或随所应。一切是有见者。谓相属有见。等所以者何。诸无色法与有见色相属故。亦名有见为舍执着眼境我故。观察有见

云何无见。几是无见。为何义故观无见耶。谓有见相违是无见义。一切皆是无见。或随所应。为舍执着非眼境我故。观察无见

云何有对。几是有对为何义故观有对耶。谓诸有见者皆是有对。又三因故说名有对。谓种类故。积集故。不修治故。种类者。谓诸色法互为能碍。互为所碍。能碍往来是有对义。此唯应言互为能碍。所以复言互为所碍者。为建立光明等色是有对故。以彼唯是所碍非能碍性性自尔故。种类是自性义。积集者。谓极微已上。以一极微无对碍故。不修治者。谓非三摩地自在转色。定自在力所转诸色无对碍故。如平等心。诸天又损害依处。是有对义谓若依若缘能生嗔恚名为有对。即以如是有对义故。一切皆是有对。或随所应。谓所余义为舍执着不遍行我故。观察有对

云何无对。几是无对。为何义故观无对耶。谓有对相违是无对义。一切皆是无对。或随所应为舍执着遍行我故。观察无对。云何有漏。几是有漏。为何义故观有漏耶。谓漏自性故。漏相属故。漏所缚故。漏所随故。漏随顺故漏种类故。是有漏义。漏自性者。谓诸漏自性漏性合故名为有漏。漏相属者。谓漏共有心心法。及眼等漏相应故。漏所依故。如其次第名有漏。漏所缚者谓有漏善法。由漏势力招后有故。漏所随者。谓余地法。亦为余地诸漏粗重所随逐故。漏随顺者。为顺决择分。虽为烦恼粗重所随。然得建立为无漏性。以背一切有顺彼对治故。漏种类者。谓阿罗汉有漏诸蕴。前生烦恼所起故。五取蕴十五界十处全及三界二处少分是有漏。谓除最后三界二处少分圣道眷属及诸无为。非有漏故。为舍执着漏合我故。观察有漏

云何无漏。几是无漏。为何义故观无漏耶。谓有漏相违是无漏义。五无取蕴全及三界二处少分是无漏。为舍执着离漏我故。观察无漏

云何有诤。几是有诤。为何义故观有诤耶。谓以依如是贪嗔痴故。执持刀杖发起一切斗讼违诤。执持刀杖等是诤因贪等是诤自性。如是彼自性故。彼相属故。彼所缚故。彼所随故。彼随顺故。彼种类故。是有诤义。乃至有漏有尔所量。有诤亦尔。彼所随义故。为舍执着诤合我故。观察有诤

云何无诤。几是无诤。为何义故观无诤耶。谓有诤相违是无诤义。乃至无漏有尔所量无诤亦尔。为舍执着离诤我故观察无诤

云何有染。几是有染。为何义故观有染耶。谓若依如是贪嗔痴故。染着后有自身。彼自性故。彼相属故。彼所缚故。彼随逐故。彼随顺故。彼种类故。是有染义。染着后有者。谓贪嗔痴是染着。后有因故名染。云何嗔恚是染着后有因。谓由憎嫉诸清净法染着后有故。如是乃至有诤有尔所量。有染亦尔。为舍执着染合我故观察有染

云何无染。几是无染。为何义故观无染耶。谓有染相违是无染义。乃至无诤有尔所量。无染亦尔。为舍执着离染我故。观察无染。云何依耽嗜。几是依耽嗜。为何义故观衣耽嗜耶。谓若依如是贪嗔痴故。染着五欲。彼自性故。彼相属故。彼所缚故。彼随逐故。彼随顺故。彼种类故。是依耽嗜义。何等嗔恚能起染着。谓憎嫉出离如是乃至有染有尔所量。依耽嗜亦尔。为舍执着耽嗜合我故。观察依耽嗜

云何依出离几是依出离。为何义故观依出离耶。谓依耽嗜相违是依出离义。乃至无染有尔所量。出离亦尔。为舍执着离耽嗜我故。观察出离

云何。有为几是有为。为何义故观有为耶。谓若法有生灭住异可知。当知是有为义。一切皆是有为。唯除法界法处一分。为舍执着无常我故。观察有为

云何无为。几是无为。为何义故观无为耶谓有为相违是无为义。法界法处一分是无为为舍执着常住我故观察无为。问无取五蕴当言有为。当言无为。答彼不应言有为无为。何以故。诸业烦恼所不为故。不应言有为。随欲限前不限前故。不应言无为。所以者何。无取诸蕴随所欲乐。若现前若不现前无为不尔。以常住故问如薄伽梵说。一切法有二种。谓有为无为。云何今说此法非有为非无为耶答此亦不离二种故。所以者何。若由此义说名有为。不以此义说名无为。若由此义说名无为。不以此义说名有为。依此道理唯说二种。何以故。随欲现前不现前义故。说名有为。诸业烦恼所不为义故。说名无为。是故此亦不离二种

云何世间。几是世间。为何义故观世间耶。谓三界所摄及出世智后所得似彼显现是世间义。似彼显现者。谓似三界所摄相显现。似真如等所现相貌。是出世间。未曾得故。如是诸蕴一分十五界十处全。及三界二处一分。是世间。一分者。谓除正智所摄及后所得似出世间相显现并无为法。为舍执着世依我故。观察世间

云何出世。几是出世。为何义故观出世耶谓能对治三界。无颠倒无戏论无分别故。是无分别出世间义。能对治三界者。谓诸圣道此复二种。一声闻独觉所得。对治常等颠倒。无颠倒分别故名无分别。二菩萨等所得。对治一切色等法戏论。无戏论分别故名无分别。诸无为法非一切分别所依处故。名无分别。又出世后所得。亦名出世。依止出世故。如是诸蕴一分。及三界二处一分是出世为舍执着独存我故。观察出世

云何已生。几是已生。为何义故观已生耶。谓过去现在是已生义。一切一分是已生。为舍执着非常我故。观察已生。又有二十四种已生。谓最初已生。相续已生。长养已生。依止已生。转变已生。成熟已生。退堕已生胜进已生清净已生。不清净已生。运转已生。有种已生。无种已生。影像自在示现已生。展转已生。刹那坏已生。离会已生。异位已生。生死已生。成坏已生。先时已生。死时已生。中时已生。续时已生。最初已生者。谓初续生时。相续已生者。谓续生已后。长养已生者谓由眠梦饮食梵行定为因。四种长养。依止已生者。谓内诸根。转变已生者。谓能随顺生乐受等诸根变异成熟已生者。谓于衰老位。退堕已生者。谓舍善趣生恶趣中。胜进已生者。谓与彼相违。清净已生者。谓游戏忘念意相愤怨。乐变化天。他化自在色无色界诸天。多放逸故。随其所应。于所受用境及所住定自在而转。不清净已生者。谓彼所余。运转已生者。谓往来位。有种已生者。谓除阿罗汉最后蕴。无种已生者。谓最后蕴。影像自在示现已生者。谓所知事同分色。解脱所生色。及如来等色。如其次第。展转已生者。谓前后生相续。刹那坏已生者。谓一一刹那诸行相。离会已生者。谓爱不爱于会离位。及心于有贪离贪等位。异位已生者。谓于羯逻蓝等位。生死已生者。谓有情世间。成坏已生者。谓器世间。先时已生者。谓先时有。死时已生者。谓死有。中时已生者。谓中有。续时已生者。谓生有

云何非已生。几是非已生为何义故观非已生耶。谓未来及无为法。是非已生义。一切一分是非已生。为舍执着常住我故。观察非已生。又已生相违是非已生义

云何能取。几是能取。为何义故观能取耶。谓诸色根及心心法。是能取义。三蕴全色行蕴一分。根相及相应相。如其次第十二界六处全及法界法处一分相应自体。是能取。为舍执着能受用我故。观察能取受用我者。计我能得爱不爱境。又能取有四种。谓不至能取。至能取。自相现在各别境界能取。自相共相一切时一切境界能取。不至能取者。谓眼耳意根。至能取者。谓余根。自相现在各别境界能取者。谓五根所生。自相共相一切时一切境界能取者。谓第六根所生又由和合识等生故。假立能取性。所以者何。以依众缘和合所生识等。假说能取。不由真实义诸法无作用故

云何所取。几是所取。为何义故观所取耶。谓诸能取亦是所取。以眼根等意识所取故。或有所取非能取。谓唯是取所行义。唯者决定义。此言为简心所有法。一切皆是所取。为舍执着境界我故。观察所取

云何外门。几是外门。为何义故观外门耶。谓欲界所系法是外门义。除依佛教所生闻思慧及彼随法行所摄心心法等。问何故闻思所生慧及彼随法行所摄心心法等。非外门耶。答等流法为因故。由此势力缘涅槃等。等流法者。谓诸佛真证种类教法。鼻识舌识香味四界。香味两处全及余一分欲界所摄。是外门。为舍执着不离欲我故。观察外门

云何内门。几是内门。为何义故观内门耶。谓外门相违是内门义。除四界二处全及所余一分。是内门。为舍执着离欲我故。观察内门。云何染污。几是染污。为何义故观染污耶。谓不善及有覆无记法。是染污义。有覆无记者。谓遍行意相应烦恼等。及色无色界系诸烦恼等。诸蕴十界四处一分是染污。十界者。谓七识色声法界。四处者。谓色声意法处。为舍执。着烦恼合我故。观察染污

云何不染污。几是不染污。为何义故观不染污耶。谓善及无覆无记法。是不染污义。八界八处全。诸蕴及余界处一分。是不染污。为舍执着离烦恼我故。观察不染污

云何过去。几是过去。为何义故观过去耶。谓自相已生故灭故。因果已受用故。染净功用已谢故。摄因已坏故。果及自相有非有故。忆念分别相故。恋为杂染相故。舍为清净相故。是过去义。因果已受用者。谓已生故已灭故。如其次第。染净功用已谢者。谓如现在贪等信等令心染净。功能无故。摄因已坏者。置习气已方灭故。果及自相有非有者。谓于今时所引习气有故。能引实事无故。忆念分别相者。谓唯有彼所缘境相故。一切一分是过去。除未来现在及无为故。为舍执着流转我故。观察过去

云何未来。几是未来。为何义故观未来耶。谓有因非已生故。未得自相故。因果未受用故。杂染清净性未现前故。因果自相有非有故。希为杂染相故。不希为清净相故。是未来义。有因非已生者。为简无为。彼虽非已生而无因故。未得自相者。自体未生故。因果未受用者。谓彼种子未作所作故。彼性未生故。一切一分是未来。为舍执着流转我故。观察未来。云何现在。几是现在。为何义故观现在耶。谓自相已生未灭故。因果受用未受用故。染净现前故。能显过去未来相故。作用现前故。是现在义。因果受用未受用者。谓因已灭故。果犹有故。能显过去未来相者。谓现在世是能施设去来世相。所以者何。依止现在假立去来故。约当得位假立未来。约曾得位假立过去。作用现前者。谓眼等法正为识等所依等事故。一切一分是现在。为舍执着流转我故。观察现在。问何故过去未来现在。说名言事非涅槃等耶。答内自所证不可说故。唯曾当现是言说所依处故。所以者何。因说过去等事。遂显经中三种言事。谓依三世建立非涅槃等。由彼内自所证离名言故。不可宣说。又唯去来今。是见闻觉知言说所依处故

云何善。几是善。为何义故观善耶。谓自性故相属故随逐故发起故第一义故生得故方便故现前供养故饶益故引摄故对治故寂静故等流故。是善义。五蕴十界四处一分是善。十界者。谓七识色声法界。四处者。谓色声意法处。为舍执着法合我故观察善。自性善者。谓信等十一心所有法。相属善者。谓彼相应法。随逐善者。谓即彼诸法习气。发起善者。谓彼所发身业语业。第一义善者。谓真如。生得善者。谓即彼诸善法。由先串习故感得如是报。由此自性即于是处不由思惟任运乐住。即于是处者。谓于信等处。由此自性不由思惟者。谓无功用不假善友力等。任运乐住者。非唯欲乐。是生得。亦信等俱任运起故。方便善者。谓依止亲近善丈夫故。听闻正法如理作意。修习净善法随法行。修习净善者。谓于正法中一切闻等所生善法。现前供养善者。谓想对如来建立灵庙图写尊容。或想对正法书治法藏兴供养业。饶益善者。谓以四摄事饶益一切有情。引摄善者。谓以施性福业事及戒性福业事故。引摄生天乐异熟。引摄生富贵家。引摄随顺清净法。引摄生天乐异熟及生富贵家者。显得尊贵因。引摄随顺清净法者。显得涅槃因。对治善者。谓厌坏对治。断对治。持对治。远分对治。伏对治。离系对治。烦恼障对治。所知障对治。此诸对治后当广释。寂静善者。谓永断贪欲永断嗔恚永断愚痴。永断一切烦恼。若想受灭。若有余依涅槃界。若无余依涅槃界。若无所住涅槃界。如是皆名寂静善法。等流善者。谓已。得寂静者。由此增上力故。发起胜品神通等世出世共不共功德

大乘阿毗达磨杂集论卷第三大乘阿毗达磨杂集论卷第四

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    本事分中三法品第一之四

云何不善。几是不善。为何义故观不善耶谓自性故相属故随逐故发起故第一义故生得故方便故现前供养故损害故引摄故所治故障碍故。是不善义。五蕴十界四处一分是不善。为舍执着非法合我故。观察不善。自性不善者。谓除染污意相应及色无色界烦恼等。所余能发恶行烦恼随烦恼。此复云何。谓欲界系不任运起者是不善。若任运起能发恶行者亦是不善。所余是有覆无记。相属不善者。谓即此烦恼随烦恼相应法。随逐不善者。谓即彼习气。发起不善者。谓彼所起身业语业。第一义不善者。谓一切流转。生得不善者。谓由串习不善故感得如是异熟。由此自性即于不善任运乐住。方便不善者。谓依止亲近不善丈夫故。听闻不正法不如理作意。行身语意恶行。现前供养不善者。谓想对归依随一天众已。或杀害意为先。或邪恶见为先。建立祠庙兴供养业。令无量众广树非福。杀害意为先建立祠庙者。谓于是处害牛羊等以祭天神。邪恶见为先建立祠庙者。谓于是处受自饿等苦求福求愿。损害不善者。谓于一切处起身语意种种邪行。引摄不善者。谓行身语意诸恶行已。于恶趣善趣引摄不爱果异熟。或引或满。于恶趣中具受引满果异熟。于诸善趣唯受满果。谓生彼已由恶行力受贫穷苦。所治不善者。谓诸对治所对治法。障碍不善者。谓能障碍诸善品法。如数与众集等

云何无记。几是无记。为何义故观无记耶。谓自性故相属故随逐故发起故第一义故生得故方便故现前供养故饶益故受用故引摄故对治故寂静故等流故。是无记义。八界八处全及余蕴界处一分。是无记。八界者。谓五色根香味触界。八处亦尔。为舍执着离法非法我故。观察无记。自性无记者。谓八色界处意相应品。命根众同分。名句文身。相属无记者。谓怀非秽非净心者。所有由名句文身所摄受心及心法。非秽非净心者。显善不善相违心。由名句文身所摄受者。显彼行相义。以彼意言门转故。随逐无记者。谓即彼戏论习气。以名身等熏习心故。由此习气后戏论生。发起无记者。谓彼所摄诸心心法所发身业语业。此所摄者。谓怀非秽非净心者。所有名身等戏论行相所摄心心法。第一义无记者。谓虚空非择灭。生得无记者。谓诸不善有漏善法报方便无记者。谓非染非善心者。所有威仪路工巧处法。非染非善心者。此显若非染非善心所发威仪路等。是无记性。所余随其所应或善或不善。现前供养无记者。谓如有一想对归依随一天众。远离杀害意邪恶见。而建立祠庙兴供养业。令无量众于如是处不生长福非福。饶益无记者。谓如有一于自仆使妻子等所。以非秽非净心而行惠施。受用无记者。谓如有一以无简择无染污心受用资具。无简择心者为别善性。无染污心者为别不善性。引摄无记者。谓如有一于工巧处串习故。于当来世复引摄如是相身。由此身故。习工巧处速疾究竟。对治无记者。谓如有一为治疾病得安乐故。以简择心好服医药。寂静无记者。谓色无色界诸烦恼等。由奢摩他所藏伏故。等流无记者。谓变化心俱生品。是证等流故名等流无记。变化心相应共有等法名俱生品。此心心法谓嬉戏故发起变化是无记性。若为利益安乐有情。当知是善。复有示现善不善无记法。此复云何。谓佛及得第一究竟菩萨摩诃萨。为欲饶益诸有情故有所示现。当知此中无有一法真实可得。有所示现者。谓佛菩萨由所化有情力故。示现种种善不善等。示现不善者。谓化作贼等示现断其首足等事。怖余有情令调伏故

云何欲界系。几是欲界系。为何义故观欲界系耶。谓未离欲者所有善不善无记法。是欲界系义。未离欲言显犹未离少分欲界欲。是未证得三摩地义。若异此者非至定法。亦应是欲界系。所以者何。由彼已得三摩地故。爱乐断灭。以所治粗重少分断故。亦得说有一分离欲。外诸色等是未离欲。业增上力所生故。亦名欲界系。经言。一切有情共有业增上力所生者。为显生色无色界者亦有未离欲。业种随逐故。四界二处全。及余蕴界处一分。是欲界系。四界者。谓香味鼻舌识界。二处者。谓香味处。余一分者。谓除色无色界系及无漏法。为舍执着欲增上我故。观察欲界系

云何色界系。几是色界系。为何义故观色界系耶。谓已离欲界欲。未离色界欲者。所有善无记法。是色界系义。除前所说四界二处。余蕴界处一分是色界系。一分者。谓除欲无色界系及无漏法。为舍执着离欲界欲我故。观察色界系

云何无色界系。几是无色界系。为何义故观无色界系耶。谓已离色界欲。未离无色界欲者。所有善无记法。是无色界系义。三界二处四蕴一分。是无色界系。三界者。谓意界法界意识界。二处者。谓意处法处。四蕴者。谓受等。亦有三摩地所生色。少故不说。一分者。谓除欲色界系及无漏法。为舍执着离色界欲我故。观察无色界系

复次有一分离欲。具分离欲。通达离欲。损伏离欲。永害离欲。一分具分离欲者。谓或依地离欲说。若于此地乃至能断八品烦恼。是一分离欲。若已断第九品。是具分离欲。或依萨迦耶离欲说。若有学位是一分离欲。若无学位是具分离欲。通达离欲者。谓由见道离欲。损伏离欲者。谓由世间道离欲。永害离欲者。谓由出世间道离欲。复有十种离欲。谓自性离欲。损害离欲任持离欲。增上离欲。愚痴离欲。对治离欲。遍知离欲。永断离欲。有上离欲。无上离欲。如是十种离欲当知。是违背义不必断义。由自性故离欲名自性离欲。乃至由永断故离欲名永断离欲。如是诸句义分别种类应知。自性离欲者。谓于苦受及顺苦受处法生厌背性。损害离欲者。谓习欲者畅热恼已生厌背性。任持离欲者。谓饱食已于诸美膳生厌背性。增上离欲者。谓得胜处已于下劣处生厌背性。犹如世间已得城主等胜位已。于村主等下劣位生厌背心。愚痴离欲者。谓诸愚夫于涅槃界生厌背性。以不了达寂静性故。及坚实着萨迦耶故。对治离欲者。谓由世出世道断诸烦恼。遍知离欲者。谓已得见道者于三界法生厌背性。由遍了知行苦性已。厌背一切有漏事故。永断离欲者。谓永断地地诸烦恼已生厌背性。有上离欲者。谓诸世间声闻独觉所有离欲。无上离欲者。谓佛菩萨所有离欲。为欲利乐诸有情故

云何有学。几是有学。为何义故观有学耶。谓求解脱者所有善法。是有学义。从积集资粮位已去名求解脱者。当知求证解脱分位。名积集资粮位。十界四处诸蕴一分是有学。十界者。谓七识色声法界。四处者。谓色声意法处。为舍执着求解脱我故。观察有学

云何无学。几是无学。为何义故观无学耶。谓于诸学处已得究竟者所有善法。是无学义。以阿罗汉等于增上戒心慧学处已得究竟故名无学。十界四处诸蕴一分是无学。为舍执着已脱我故。观察无学

云何非学非无学。几是非学非无学。为何义故观非学非无学耶。谓诸异生所有善不善无记法。及诸学者染污无记法。诸无学者无记法并无为法。是非学非无学义诸异生者。谓除求解脱者。以彼于诸学处求修学故。即名有学。有学染污无记者。如其所应不善及有覆无记是染污。无覆无记是无记。八界八处全及余蕴界处一分。是非学非无学。为舍执着不解脱我故。观察非学非无学

云何见所断。几是见所断。为何义故观见所断耶。谓分别所起染污见疑。见处疑处。及于见等所起邪行烦恼随烦恼。及见等所发身语意业。并一切恶趣等蕴界处。是见所断义。此中分别所起染污见疑者。谓闻不正法等为先。所起五见等。分别所起言为简。俱生萨迦耶见及边执见。问何相边执见。是俱生耶。答谓断见已学现观者起如是怖。今者我我为何所在。见处者。谓诸见相应共有法。及彼种子。疑处亦尔。于见等所起邪行烦恼随烦恼者。谓依见等门及缘见等。所起贪等一切一分。是见所断。一分者。除修所断及无漏故。为舍执着见圆满我故。观察见所断

云何修所断。几是修所断。为何义故观修所断耶。谓得见道后。见所断相违诸有漏法。是修所断义。见所断相违者。谓除分别所起染污见等。余有漏法。有漏法言亦摄随顺决择分善。粗重所随故。一切一分是修所断。一分者。除见所断及无漏法。为舍执着修圆满我故。观察修所断

云何非所断。几是非所断。为何义故观非所断耶。谓诸无漏法除决择分善。是非所断。无漏法者。谓出世圣道及后所得并无为法。十界四处诸蕴一分。是非所断。问何等色声是非所断。答无学身中善身语业自性。是非所断。为舍执着成满我故。观察非所断

云何缘生。几是缘生。为何义故观缘生耶。谓相故。分别支故。略摄支故。建立支缘故。建立支业故。支杂染摄故。义故。甚深故。差别故顺逆故。是缘生义

相者。谓无作缘生故。无常缘生故。势用缘生故。是缘生相。由此相故薄伽梵说。此有故彼有。此生故彼生。谓无明缘行乃至广说。此有故彼有者。显无作缘生义。唯由有缘故果法得有。非缘有实作用能生果法。此生故彼生者。显无常缘生义。非无生法为因故。少所生法而得成立。无明缘行等者。显势用缘生义。虽复诸法无作无常。然不随一法为缘故一切果生。所以者何。以诸法功能差别故。如从无明力故诸行得生。乃至生力故得有老死。分别支者。谓分别缘生为十二分。由十二支缘起差别故。何等十二。谓无明行识名色六处触受爱取有生及老死

略摄支者。谓前所分别无明等十二支。今复略摄为四。谓能引支所引支能生支所生支。唯由如是四种支故。略摄一切因果生起法尽。谓于因时有能引所引。于果时有能生所生。能引支者。谓无明行识。为起未来生故。于诸谛境无智为先。造诸行业熏习在心故。所引支者。谓名色六处触受。由心习气力能令当来名色等前后相依次第生起种子得增长故。能生支者。谓爱取有。由未永断欲等爱力。于欲等中爱乐。妙行恶行差别为先发起贪欲。以有有取识故。于命终位将与异熟随顺贪欲。随一业习气现前有故。所生支者。谓生老死。由如是业差别习气现前有故。随于一趣一生等差别众同分中。如先所引名色等异熟生起故。生老死言为显依三有为相故。所以老死合立一支者。为显离老得有死故。非于胎生身中离名色等得有六处等法。是故于彼各别立支

建立支缘者。谓习气故引发故思惟故俱有故。建立支缘随其所应。依四缘相建立支缘。且如无明望行。前生习气故。得为因缘。由彼熏习相续所生诸业能造后有故。当于尔时现行无明能引发故。为等无间缘。由彼引发差别诸行流转相续生故。思惟彼故。为所缘缘。以计最胜等不如理思惟缘愚痴位为境界故。彼俱有故。为增上缘。由彼增上力令相应思颠倒缘境而造作故。如是一切随其所应尽当知

建立支业者。谓无明支有二种业。一令诸有情于有愚痴。二与行作缘。令诸有情于有愚痴者。谓由彼所覆于前中后际不如实知故。由此因缘起如是疑。我于过去世为有为无如是等。与行作缘者。由彼势力令后有业得增长故。行有二种业。一令诸有情于诸趣中种种差别。二与识作缘。令诸有情于趣差别者。由业势力令诸有情趣种种异趣故。与识作缘者。由习气力能使当来名色等生起种子得增长故。识有二种业。一持诸有情所有业缚。二与名色作缘。持诸有情业缚者。与行所引习气俱生灭故。与名色作缘者。由识入母胎名色得增长故。名色有二种业。一摄诸有情自体。二与六处作缘。摄有情自体者。由彼生已得预有情众同分差别数故。与六处为缘者。由名色等前支为依止六处等后支得生起故。六处有二种业。一摄诸有情自体圆满二与触作缘。摄诸有情体圆满者。由彼生已余根无缺故。触有二种业。一令诸有情于所受用境界流转。二与受作缘。令有情于境转者。依此为门。受用顺乐受等三种境界故。受有二种业。一令诸有情于所受用生果流转。二与爱作缘。令有情于受用生果流转者。由此为依受用种种可爱等业异熟故。与爱为缘者。悕求与此和合等为门。诸爱生故。爱有二种业。一引诸有情流转生死。二与取作缘。引诸有情流转生死者。由彼势力生死流转无断绝故。与取作缘者。爱味求欲为门。于欲等中贪欲转故。取有二种业。一为取后有令诸有情发有取识。二与有作缘。为取后有发有取识者。为那落迦趣等差别后有相续不断。令业习气得决定故。与有作缘者。由此势力诸行习气得转变故。有有二种业。一令诸有情后有现前。二与生作缘。令后有现前者。能引无间余趣故。与生作缘者。由此势力余众同分转故。生有二种业。一令诸有情名色六处触受次第生起。二与老死作缘。令名色等次第起者。能引后后位差别故。与老死作缘者。由有此生彼相续变坏皆得有故。老死有二种业。一数令有情时分变异坏少盛故。二数令有情寿命变异坏寿命故

支杂染摄者。若无明若爱若取。是烦恼杂染所摄。若行若识若有。是业杂染所摄。余是生杂染所摄。问何故识支业杂染摄耶。答诸行习气所显故。义者。谓无作者义。有因义。离有情义。依他起义。无作用义。无常义。有刹那义。因果相续不断义。因果相似摄受义因果差别义。因果决定义。是缘起义。谓离自在天等作者故。是无作者义。以无明等为因故。是有因义。无自然我故。是离有情义。托众缘生故。是依他起义众缘作用空故。是无作用义。以非恒故是无常义。生时过已无暂住故。是有刹那义。因刹那灭果刹那生时分等故。是因果相续不断义。不从一切一切生故。是因果相似摄受义。从非一一类因一非一类果生故。是因果差别义。于余相续不受果故。是因果决定义。甚深者。因甚深故。相甚深故。生甚深故。住甚深故。转甚深故。是甚深义。谓即由此无作者等义显缘起法五种甚深。由二种义显因甚深。对治不平等因无因论故。由一种义显相甚深。是无我相故。由二种义显生甚深。虽从众缘果法得生。然非彼所作故。由二种义显住甚深。实无安立显现似住故。由四种义显转甚深。因果流转难了知故。又诸缘起法虽刹那灭而住可得。虽无作用缘而有功能缘可得。虽离有情而有情可得。虽无作者而诸业果不坏可得。是故甚深。业果不坏者虽内无作者而有作业受彼果报又诸法不从自生。不从他生。不从共生。非不自作他作因生。是故甚深。不从自生者。谓一切法非自所作。彼未生时无自性故。不从他生者。谓彼诸缘非作者故。不从共生者。谓即由此二种因故。非不自作他作因生者。缘望果生有功能故。又有差别。谓待众缘生故非自作。虽有众缘无种子不生故非他作。彼俱无作用故非共作。种子及众缘皆有功能故非无因生。是故如是说。自种有故不从他。待众缘故非自作。无作用故非共生。有功能故非无因。若缘起理非自非他。遣双句者犹为甚深。况总忘四句。是故缘起最极甚深

差别者。谓识生差别故。内死生差别故。外谷生差别故。成坏差别故。食持差别故。爱非爱趣分别差别故。清净差别故。威德差别故。是差别义。识生差别者。谓眼色为缘眼识得生。如是等内死生差别者。依有情世间说。谓无明等为缘能生行等。外谷生差别者。谓种缘芽芽缘茎。如是展转枝叶花果次第得生。成坏差别者。谓一切有情共业增上力为缘大地等生故。食持差别者。谓四食为缘三界有情相续住故。爱非爱趣分别差别者。谓妙行恶行为缘往善恶趣故。清净差别者。谓顺解脱分善为缘生顺决择分善。如是见道等渐次乃至得阿罗汉果等。或外从他闻音内如理作意为缘发生正见。次第乃至诸漏永尽。威德差别者。谓内证为缘发神通等最胜功德。由此差别应随广说诸行缘起

顺逆者。谓杂染顺逆故。清净顺逆故。是说缘起顺逆。杂染顺逆者。或依流转次第说谓无明缘行。如是等顺次第说或依安立谛说。谓老死苦老死集老死灭老死趣灭行。如是等逆次第说。清净顺逆者。谓无明灭故行灭。如是等顺次第说。由谁无故老死无。由谁灭故老死灭。如是等逆次第说。应如是观缘生起义。一切皆是缘生。唯除法界法处一分诸无为法。为舍执着无因不平等因我故。观察缘生

云何缘。几是缘。为何义故观缘耶。谓因故等无间故所缘故增上故。是缘义。一切是缘。为舍执着。我为因法故。观察缘。因缘者。谓阿赖耶识及善习气与有漏无漏诸法。如其次第为因缘故。阿赖耶识复有二种。谓成熟及加行。成熟者。是诸生得法因缘。加行者。是诸方便法及当来世余阿赖耶识因缘。又加行阿赖耶识者。谓于此生中现行转识等之所熏集。善习气者。谓顺解脱分习气。由此习气用出世间证等流法为缘生故。能与出世法作因缘。又自性故差别故助伴故等行故增益故障碍故摄受故。是因缘相。当知此中以自性等六种因相显因缘义。谓自性差别两句建立能作因。余句如其次第建立俱有相应同类遍行异熟因

自性者。谓能作因自性依因自性建立能作因故。当知一切因皆能作因所摄。为显差别义故。复别建立助伴等因

差别者。谓能作因差别略有二十种。一生能作。谓识和合望识。由此和合所作本无今有故。二住能作。谓食望已生及求生有情。由此势力生已相续不断故。三持能作。谓大地望有情。载令不堕故。四照能作。谓灯望诸色了闇障故。五变坏能作。谓火望薪。令彼相续变异故。六分离能作。谓镰望所断。令连属物成二分故。七转变能作。谓工巧智等望金银等物。转彼方分成异相故。八信解能作。谓烟望火。由此比知不现见故。九显了能作。谓宗因喻望所成义。由此得正决定故。十等至能作。谓圣道望涅槃。由此证彼故。十一随说能作。谓名想见。由如名字取相执着随起说故。十二观待能作。谓观待此故。于彼求欲生。如待饥渴追求饮食。由此是彼欲生因故。十三招引能作。谓悬远缘。如无明望老死。由此异位展转招当有故。十四生起能作。谓邻近缘。如无明望行。由此无间生当有故。十五摄受能作。谓所余缘。如田水粪等望谷生等。虽自种所生。然增彼力故。十六引发能作。谓随顺缘。如臣事王令王悦豫。由随顺引发故。十七定别能作。谓差别缘。如五趣缘望五趣果。由差别自性招别别果故。十八同事能作。谓和合缘。如根不坏境界现前。作意正起望所生识。以成自所作必待余能作故。十九相违能作。谓障碍缘。如雹望谷。能损彼故。二十不相违能作。谓无障碍。如谷无障与上相违。于此能作因差别中。唯说识和合等者。且举纲要为诸智者依此一方。类思余故

助伴者。谓诸法共有而生。必无缺减。如四大种及所造色随其所应。非一切聚定有四大及色等所造。若于是处有尔所量。此必俱生互不相离

等行者。谓诸法共有等行所缘必无缺减。如心心法前约助伴。决定建立俱有因中。唯说大种及所造色者。此但略摽纲目。以心心法互不相离性。决定故。亦助伴摄。若尔不应别立相应因诸心心法亦共有因所摄故。虽尔然义有异。谓诸法共有等行所缘互不相离。此等行故立相应因。非唯共有义。如心心法

增益者。谓前际修习善不善无记法故。能令后际善等诸法展转增胜后后生起。前际修习者。谓先所数习现行义。后际展转增胜后后生起者。谓由彼长养诸种子故。于未来世即彼种类增胜而生。如是诸法能为相似增长因故立同类因

障碍者。谓随所数习诸烦恼故。随所有惑皆得相续增长坚固。乃令相续远避涅槃。此遍行因。非唯令相似烦恼增长。所以者何。若有随习贪等烦恼。皆令嗔等一切烦恼相续增长坚固。由此深重缚故障解脱得。是故建立遍行因

摄受者。谓不善及善有漏法能摄受自体故。即是异熟因。由此能引摄当来一向不相似。无覆无记自体所摄。异熟果故即摄受义。建立异熟因。善有漏言为简无漏。由违生死故不能感异熟果

大乘阿毗达磨杂集论卷第四大乘阿毗达磨杂集论卷第五

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    本事分中三法品第一之五

等无间缘者。谓中无间隔。等无间故。同分异分心心法生。等无间故。是等无间缘义。中无间隔等无间者。不必刹那中无间隔。虽隔刹那。但于中间无异心隔。亦名中无间隔。若不尔入无心定心望出定心。应非等无间缘。然是彼缘。是故于一相续中前心望后心。中间无余心隔故。是等无间缘。如心望心当知心法亦尔。同分异分心心法生等无间者。谓善心心法望同分善异分不善无记无间。生心心法为等无间缘。如是不善无记心心法望同分异分无间。生心心法亦尔。又欲界心心法望欲色无色界及无漏无间。生心心法为等无间缘。如是色界等心心法各各别望色界等及欲界等无间。生心心法如其所应尽当知

问为一切心无间一切心生耶。为有各别决定耶。答有。今于此中若广别说如是心无间如是心生者。便生无量言论。是故唯应略总建立心生起相。谓诸心生起由十种力。一由串习力。二由乐欲力。三由方便力。四由等至力。五由引发力。六由因力。七由境界力。八由忆念力。九由作意力。十由相续力

串习力者复有三种。谓下中上品。若于诸定入住出相。未了达故是下品。虽已了达未善串习故是中品。既了达已复善习故是上品。若有下品串习力者。于诸静虑诸无色定唯能次第入。若有中品串习力者。亦能超越入。唯能方便超越一间。若有上品串习力者。随其所欲或超一切。若顺若逆入诸等至

乐欲力者。谓已得第二静虑者入初静虑已。若欲以第二静虑地心出。或欲以欲界善及无覆无记心出。即能现前而出于定。如是广说。余一切地如理当知。方便力者。谓初修行者唯欲界善心无间色界心生。未至定善心无间初根本静虑心生。初根本静虑善心无间第二静虑地心生。如是广说。乃至有顶皆如理知。等至力者。谓已入清净三摩钵底。或时还生清净等至。或时生染。引发力者。谓从三摩地起乃至现行定地心。与不定刹那心间杂随转。乃至由彼相违烦恼现行故。即便退失。此相违烦恼相应心。复由因等四力方得现行。因力者。谓先以积习能退障故决定应退。境界力者。谓净相势力增上境界现前故。能随顺生贪等烦恼。忆念力者。谓忆念分别过去境界而生戏论。作意力者。谓由观察作意思惟种种净妙相貌

相续力者有九种。命终心与自体爱相应。于三界中各令欲色无色界生相续。谓从欲界没还生欲界者。即以欲界自体爱相应命终心结生相续。若生色无色界者。即以色无色界自体爱相应命终心结生相续。如是从色无色界没。若即生彼若生余处。有六种心。如其所应尽当知。又此自体爱唯是俱生。不了所缘境。有覆无记性摄。而能分别我自体。生差别境界。由此势力诸异生辈。令无间中有相续。未离欲圣者亦尔。临命终时乃至未至不明了想位。其中能起此爱现行。然能了别。以对治力之所摄伏。已离欲圣者。对治力强故。虽未永断然此爱不复现行。彼由随眠势力令生相续中有。初相续刹那唯无覆无记。以是异熟摄故。从此已后或善或不善或无记。随其所应除彼没心。以中有没心常是染污。犹如死有生有相续心刹那。亦唯无覆无记。若诸菩萨愿力受生者。命终等心当知一切一向是善。已说因论生论等无间缘义。所缘缘者。谓有分齐境所缘故。无分齐境所缘故。无异行相境所缘故。有异行相境所缘故。有事境所缘故。无事境所缘故。事所缘故。分别所缘故。有颠倒所缘故。无颠倒所缘故。有碍所缘故。无碍所缘故。是所缘缘义。有分齐境所缘者。谓五识身所缘境界。由五识身各别境界故。无分齐境所缘者。谓意识所缘境界。以意识身缘一切法为境界故

无异行相境所缘者。谓不能了别名想众生意识所缘境界。由彼于境不能作名字故。有异行相境所缘者。谓与此相违

有事境所缘者。谓除见慢及此相应法。余所缘境界。无事境所缘者。谓前所除所缘境界。由彼于我处起故。事所缘者。谓除无漏缘不同分界地遍行于事不决了及未来所缘。余所缘境界。分别所缘者。谓前所除所缘境界。由彼唯缘自所分别为境界故。有颠倒所缘者。谓常等行所缘境界。无颠倒所缘者。谓无常等行所缘境界。有碍所缘者。谓未断所知障者所缘境界。无碍所缘者。谓已断所知障者所缘境界。复次若欲决择所缘缘义。应以相故差别故安立故遍知故断故。建立所缘相者。谓若义是似此显现心心法生因。彼既生已还能执着。显了内证此义。是所缘相

差别者有二十九种。一非有所缘。谓颠倒心心法及缘。过去未来梦影幻等所缘境界二有所缘。谓余所缘境界。三无所缘所缘。谓色心不相应行无为。四有所缘所缘。谓心心法。五正性所缘。谓善法。六邪性所缘。谓染污法。七非正性非邪性所缘。谓无覆无记法。八如理所缘。谓善心心法。九不如理所缘。谓染污心心法。十非如理非不如理所缘。谓异此心心法。十一同类所缘。谓善等缘善等。自地缘自地。有漏缘有漏。无漏缘无漏。如是等。十二异类所缘。谓善等缘不善等。余地缘余地。有漏无漏缘无漏有漏。如是等十三异性所缘。谓有寻有伺心心法所缘。十四一性所缘。谓无寻无伺心心法所缘。十五威势所缘。谓无想及彼方便心心法所缘境界。及空识无边处所缘境界。此中前二句能除想故名威势。所余性大故名威势。十六略细所缘。谓无所有处所缘境界。十七极细所缘。谓非想非非想所缘。过此更无极细性故。十八烦恼所缘。谓即此能有所缘故。如经中说断灭所缘。十九法所缘。谓圣教名句文身。二十义所缘。谓依此法义。二十一狭小所缘。谓声闻乘等。二十二广大所缘。谓大乘。二十三相所缘。谓止举舍相。二十四无相所缘。谓涅槃及第一有。二十五真实所缘。谓真如及十六行所缘诸谛。二十六安住所缘。谓灭尽定及定方便心心法所缘。二十七自在所缘。谓解脱等乃至一切种智诸功德所缘。二十八须臾所缘。谓无学所缘唯此生故。二十九随转所缘。谓佛菩萨所缘境界

安立者。谓所缘境体非真实。唯安立故。由四种因知所缘境体非真实。谓相违识相故。无所缘境。识可得故不由功用。应无倒故随三智转故。由此道理能取体性亦非真实。三智者。谓自在智。观察智无。分别智。为显四因。乃说颂曰

  鬼傍生人天　　各随其所应
  等事心异故　　许义非真实
  于过去事等　　梦像二影中
  虽所缘非实　　而境相成就
  若义义性成　　无无分别智
  此若无佛果　　证得不应理
  得自在菩萨　　由愿解力故
  如欲地等成　　得定者亦尔
  成就简择者　　有智得定者
  思惟一切法　　如义皆显现
  无分别智行　　诸义皆不现
  当知无有义　　由此亦无识

遍知者。谓如实知相差别安立所缘境界

断者。谓声闻等及与大乘所得转依。声闻乘等所得转依。虽于蕴界处所缘得解脱。然于彼不得自在。大乘所得转依具得二种已说。所缘缘随文决择义

增上缘者。谓任持增上故。引发增上故。俱有增上故。境界增上故。产生增上故。住持增上故。受用果增上故。世间清净离欲增上故。出世清净离欲增上故。是增上缘义

任持增上者。谓风轮等。于水轮等器世间。于有情世间大种。于所造诸根。于诸识如是等。引发增上者。谓一切有情共业于器世间故。有漏业于异熟果。如是等俱有增上者。谓心于心法作意。于心触。于受。如是等。此后增上依二十二根建立。境界增上者。谓眼耳鼻舌身意根。由此增上力色等生故。产生增上者。谓男女根。由此增上力得入胎故。住持增上者。谓命根。由此增上力众同分得住故。受用果增上者。谓苦乐忧喜舍根。依此能受爱非爱异熟故。世间清净离欲增上者。谓信勤念定慧根。由此制伏诸烦恼故。出世清净离欲增上者。谓所建立。未知欲知根。已知根。具知根。由此永害诸随眠故

云何同分彼同分。几是同分彼同分为何义故。观同分彼同分耶。谓不离识彼相似根于境相续生故。离识自相似相续生故。是同分彼同分义。初是同分。诸根与识俱识相似。于诸境界相续生故。由根与识相似转义。说名同分。第二是彼同分。诸根离识自类相似。相续生故。由根不与识合。唯自体相似相续生。根相相似义。说名彼同分。色蕴一分。眼等五有色界处一分。是同分彼同分。为舍执着与识相应不相应我故。观察同分彼同分

云何执受。几是执受。为何义故观执受耶。谓受生所依色故。是执受义。若依此色受得生。是名执受。色蕴一分。五有色界处全。及四一分。是执受。色蕴一分者。谓根根居处所摄。五有色界处全者。谓眼等。四一分者。谓不离根色香味触。为舍执着身自在转我故。观察执受

云何根几是根。为何义故观根耶。谓取境增上故。种族不断增上故。众同分住增上故。受用净不净业果增上故。世间离欲增上故。出世离欲增上故。是根义。取境增上者。谓眼等六由此增上力。于色等境心心法转故。种族不断增上者。谓男女根由此增上力。子孙等胤流转不绝故。余如增上缘中说。受识蕴全。色行蕴一分。十二界六处全。法界法处一分是根。色蕴一分者。谓眼耳鼻舌身男女根。行蕴一分者。谓命信勤念定慧根。十二界全者。谓六根六识界。六处全者。谓内六处。法界法处一分者。谓命及乐等信等五根。为舍执着增上我故。观察根

云何苦苦性。几是苦苦性。为何义故观苦苦性耶。谓苦受自相故。随顺苦受法自相故。是苦苦性义。苦受自相者。谓苦受即用苦体为自相故。名苦苦性。随顺苦受法自相者。谓能生此受根境及相应法随顺苦受故。名苦苦性。一切一分是苦苦性。为舍执著有苦我故。观察苦苦性

云何坏苦性。几是坏苦性。为何义故观坏苦性耶。谓乐受变坏自相故。随顺乐受法变坏自相故。于彼爱心变坏故。是坏苦性义。此中乐受及随顺乐受法。于变坏位能生忧恼故。此变坏是坏苦性。又由爱故令心变坏。亦是坏苦。如经中说。入变坏心一切一分。是坏苦性。为舍执著有乐我故。观察坏苦性

云何行苦性。几是行苦性。为何义故观行苦性耶。谓不苦不乐受自相故。随顺不苦不乐受法自相故。彼二粗重所摄受故。不离二无常所随不安隐故。是行苦性义。不苦不乐受者。谓阿赖耶识相应受。随顺不苦不乐受法者。谓顺此受。诸行。彼二粗重所摄受者。谓苦坏二苦粗重所随故。不离二无常所随不安隐者。谓不解脱二苦故。或于一时堕在苦位。或于一时堕在乐位。非一切时唯不苦不乐位。是故无常所随不安隐义。是行苦性。除三界二处诸蕴一分。一切是行苦性。三界者。谓意界法界意识界。二处者。谓意处法处。一分者。谓除无漏相。为舍执著有不苦不乐我故。观察行苦性

云何有异熟。几是有异熟。为何义故观有异熟耶。谓不善及善有漏。是有异熟。由不善及有漏善法。能有当来阿赖耶识及相应异熟。由彼异熟故此二种名有异熟。十界四处诸蕴一分。是有异熟。十界者。谓七识色声法界。四处者。谓色声意法处。一分者。谓除无记无漏。为舍执着能舍能续诸蕴我故。观察有异熟。又异熟者。唯阿赖耶识及相应法。余但异熟生非异熟余者谓眼耳等及苦乐等。是阿赖耶识余。此唯得名异熟生。从异熟生故。云何食。几是食。为何义故观食耶。谓变坏故有变坏者。境界故有境界者。悕望故有悕望者。取故有取者。是食义。初是段食。由变坏时长养根大故。二是触食。由依可爱境触摄益所依故。三是意思食。由系意悕望可爱事力摄益所依故。四是识食。由阿赖耶识执持力身得住故。所以者何。若离此识所依止身便烂坏故。三蕴十一界五处一分是食。为舍执着由食住我故。观察食。又此四食差别建立略有四种。一不净依止住食。谓欲界异生由具缚故。二净不净依止住食。谓有学及色无色界异生有余缚故。三清净依止住食。谓阿罗汉等解脱一切缚故。四示现住食。谓诸佛及已证大威德菩萨。由唯示现食力住故

云何有上。几是有上。为何义故观有上耶。谓一切有为故。无为一分故。是有上义。除法界法处一分。一切是有上。以一切法中涅槃及清净真如是最胜相故。为舍执着下劣事我故。观察有上

云何无上。几是无上。为何义故观无上耶。谓无为一分故。是无上义。法界法处一分。如前所说是无上。为舍执着最胜事我故。观察无上。由此所说差别道理。余无量门可类观察。复次蕴界处差别略有三种。谓遍计所执相差别。所分别相差别。法性相差别。遍计所执相差别者。谓于蕴界处中遍计所执。我有情命者生者养者数取趣者意生者摩纳婆等。于蕴等中实无我等自性。但是遍计所执相故。所分别相差别者。谓即蕴界处法。由于此处我有情等虚妄分别转故。法性相差别者。谓即于蕴界处中我等无性无我有性。由离有无相真如用蕴等中我等无性无我有性为相故。当知此中依三自性及多分依数取趣无我理说三种相

复有四种差别。谓相差别。分别差别。依止差别。相续差别。相差别者。谓蕴界处一一自相差别如色受等。分别差别者。谓即于蕴界处中。实有假有。世俗有胜义有。有色无色。有见无见。如是等无量差别。分别如前说。依止差别者。谓乃至有情依止差别有尔所。当知蕴界处亦尔。由依各别内身蕴等诸法种种异故。相续差别者。谓一一刹那蕴界处转。于一身中蕴等诸法一一刹那性变异故

问于相差别善巧为何所了知耶。答了知我执过患。问于分别差别善巧为何所了知耶。答了知聚想过患。问于依止差别善巧为何所了知耶。答了知不作而得虽作而失想过患。问于相续差别。善巧为何所了知耶。答了知安住想过患

又蕴界处有六种差别。谓外门差别。内门差别。长时差别。分限差别。暂时差别。显示差别。外门差别者。谓多分欲界差别。多分言为简等流法。为因闻思所生慧。内门差别者。谓一切定地。长时差别者。谓诸异生。分限差别者。谓诸有学及除最后刹那蕴界处。所余无学。暂时差别者。谓诸无学最后刹那蕴界处。显示差别者。谓诸佛及已得究竟菩萨摩诃萨。所示现诸蕴界处

    大乘阿毗达磨杂集论本事分中摄品第二

复次若略说摄有十一种。谓相摄界摄种类摄分位摄。伴摄方摄时摄一分摄具分摄更互摄胜义摄

相摄者。谓蕴界处一一自相即体自摄。如色蕴摄色蕴。广说乃至法处摄法处。界摄者。谓蕴界处所有种子阿赖耶识能摄彼界。由彼种子此中有故。种类摄者。谓蕴界处其相虽异。蕴义界义处义等故展转相摄。蕴义等者。谓色受等皆有聚义。虽相各异一切相摄更互相望同一类故。界义等者。谓眼耳等皆有能持受用义故一切相摄。处义等者。谓眼耳等皆生长门义相应故一切相摄

分位摄者。谓乐位蕴界处即自相摄。苦位不苦不乐位亦尔。分位等故。如色受等虽同蕴类。然苦乐等分位差别。乐位还摄乐位非苦等位。如是苦位不苦不乐位还自相摄。如蕴界处亦尔

伴摄者。谓色蕴与余蕴互为伴故。即摄助伴。余蕴界处亦尔。如色蕴与余受等互为助伴能摄五蕴。如是受等一一助伴各摄五蕴。如蕴界处亦尔。互为伴故。一一皆摄一切界处。方摄者。谓依东方诸蕴界处还自相摄余方。蕴界处亦尔时摄者。谓过去世诸蕴界处还自相摄。未来现在诸蕴界处亦尔

一分摄者。谓所有法蕴界处所摄。但摄一分非余。如戒蕴但摄色蕴等一分。定慧蕴等但摄行蕴一分。欲恚害界但摄法界一分。空无边处等但摄意法处一分。如是等

具分摄者。谓所有法蕴界处所摄。能摄全分。如苦蕴摄五取蕴。欲界摄十八界。无想有情处摄十处除香味。由此道理于余经中诸蕴界处所摄。一切法能摄全分

更互摄者。色蕴摄几界几处。十全一少分。受蕴摄几界几处。一少分。如受蕴想行蕴亦尔。识蕴摄几界几处。七界一处。眼界摄几蕴几处。色蕴少分一处全。如眼界耳鼻舌身色声香味触界亦尔。意界摄几蕴几处。一蕴一处。法界摄几蕴几处。三蕴全色蕴少分一处全。眼识界摄几蕴几处。识蕴意处少分。如眼识耳鼻舌身意识界亦尔。眼处摄几蕴几界。色蕴少分一界全。如眼处耳鼻舌身色声香味触处亦尔。意处摄几蕴几界。一蕴七界。法处摄几蕴几界。三蕴全一少分一界全。如是诸余法以蕴界处名说。及余非蕴界处名说。如实有假有世俗有胜义有所知所识所达有色无色有见无见。如是等如前所显。随其所应。与蕴界处更互相摄尽当知。随其所应者。如蕴一一摄诸界处。界一一摄诸蕴处。处一一摄诸蕴界。如是广说当思了知。胜义摄者。谓蕴界处真如所摄

如是摄相。随诸世间共所成立。相摄道理复有六种。一依处摄。如世间说。赡部洲摄于人。阿练若摄于鹿。当知此中眼等诸根摄眼等识亦尔。二任持摄。如世间说。绳等摄薪束等。当知此中身根摄眼等根亦尔。三同事摄。如世间说。众人同事共相保信更互相摄。当知此中同一缘转。诸相应法更互相摄亦尔四摄受摄。如世间说。主能摄录自仆使等。当知此中阿赖耶识摄受自身亦尔。五不流散摄。如世间说。瓶摄持水。当知此中。诸三摩地摄余心心法亦尔。六略集摄。如世间说。海摄众流。当知此中色受蕴等摄眼耳等亦尔。如前所说十一种摄。皆依此中略集摄说

问于摄善巧得何胜利。答得于所缘略集胜利随彼彼境略聚其心。如是如是善根增胜

    大乘阿毗达磨杂集论本事分中相应品第三

复次略说相应有六种。谓不相离相应。和合相应。聚集相应。俱有相应。作事相应。同行相应。不相离相应者。谓一切有方分色与极微处互不相离。由诸色等极微所摄同一处所不相离故。和合相应者。谓极微已上一切有方分色更互和合。如浊水中地水极微更互和合。聚集相应者。谓方分聚色展转集会。如二埿团相击成聚

俱有相应者。谓一身中诸蕴界处。俱时流转同生住灭。作事相应者。谓于一所作事展转相摄。如二苾刍随一所作更互相应

同行相应者。谓心心法于一所缘展转同行。此同行相应复有多义。谓他性相应非己性。如心不与余心相应。受不与余受相应。如是等。又不相违相应非相违。如贪嗔不相应。善不善不相应。如是等。又同时相应非异时。如现在去来不相应。又同分界地相应非异分界地。如欲界色无色界不相应。初静虑第二静虑不相应。如是等。又有一切遍行同行相应。谓受想思触作意及识。由此六法于一切位决定相应。随无一法余亦无故。又有染污遍行同行相应。谓于染污意四种烦恼。由此四法于一切时恒相应故。又有非一切时同行相应。谓依止心或时起信等善法。或时起贪等烦恼随烦恼法。又有分位同行相应。谓与乐受诸相应法。与苦受不苦不乐受诸相应法。又有无间同行相应。谓在有心位又有有间同行相应。谓无心定所间。又有外门同行相应。谓多分欲界系心心法。又有内门同行相应。谓诸定地所有心心法。又有曾习同行相应。谓诸异生所有心心法。及有学无学者一分心心法。一分言谓摄一向世间善不善无记法。如其所应。又有未曾习同行相应。谓出世间诸心心法。及初后时出世后所得诸心心法。初后时言为显非先种类初念已去及第二念等已去出世心心法是未曾习性

问于相应善巧得何胜利。答能善了悟。唯依止心。有受想等染净诸法相应不相应义。由此了悟。即能舍离计我能受能想能思能念染净执着。又能善巧速入无我

    大乘阿毗达磨杂集论本事分中成就品第四

复次成就相如前已说谓于善不善无记法。若增若减假立获得成就。此差别有三种。谓种子成就。自在成就。现行成就

种子成就者。谓若生欲界。欲色无色界系烦恼随烦恼由种子成就故成就。及生得善生欲界。三界烦恼随烦恼成就者依未离欲异生说。若已离欲。或生上地随所离欲地。即此地烦恼随烦恼亦成就。亦不成就。未永害随眠故。对治道所损故。如其次第。及生得善者。随所生地即此地成就。若生色界欲界系烦恼随烦恼由种子成就故成就。亦名不成就。色无色界系烦恼随烦恼。由种子成就故成就。及生得善。若生无色界。欲色界系烦恼随烦恼由种子成就故成就。亦名不成就。无色界系烦恼随烦恼。由种子成就故成就。及生得善。若已得三界对治道。随如是如是品类对治已生。如此如此品类种子成就。得不成就。随如是如是品类对治未生。如此如此品类由种子成就故成就。已得三界对治道者。谓已得出世圣道。随如是如是品类对治已生者。谓修道所断。上品等烦恼对治已生。如此如此种类种子成就得不成就者。谓已永害随眠故

自在成就者。谓诸方便善法。若世出世静虑解脱三摩地三摩钵底等功德。及一分无记法。由自在成就故成就方便善法者。谓闻所生慧等。虽先有种子。若离今生数习增长。终不能起现前故。一分无记法者。谓工巧处变化心等

现行成就者。谓诸蕴界处法。随所现前若善若不善若无记。彼由现行成就故成就

若已断善根者所有善法。由种子成就故成就。亦名不成就。若非涅槃法。一阐底迦究竟成就杂染诸法。由阙解脱因。亦名阿颠底迦。以彼解脱得因毕竟不成就故

问何等名为解脱得因

答若于真如先以集起烦恼粗重。若遇随顺得对治缘。便能永害此堪任性。名解脱得因。若与此相违名无解脱因

问于成就善巧得何胜利。答能善了知诸法增减。知增减故。于世兴衰离决定想。乃至能断若爱若恚

大乘阿毗达磨杂集论卷第五大乘阿毗达磨杂集论卷第六

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    决择分中谛品第一之一

复次略说决择有四种。谓谛决择法决择得决择论议决择。谛决择复有四种。谓依苦集灭道四圣谛说

苦谛云何。谓有情生及生所依处。即有情世间器世间。如其次第若生若生处。俱说名苦谛。有情生者。谓诸有情生在地狱畜生饿鬼人天趣中。人谓东毗提诃西瞿。陀尼南赡部洲北俱卢洲。天谓四大王众天三十三天夜摩天睹史多天乐变化天他化自在天。梵众天梵辅天大梵天少光天无量光天极光净天少净天无量净天遍净天无云天福生天广果天无想有情天无烦天无热天善现天善见天色究竟天。无边空处天无边识处天无所有处天非想非非想处天。生所依处即器世界。谓水轮依风轮。地轮依水轮。依此地轮有苏迷卢山七金山四大洲八小洲内海外海。苏迷卢山四外层级四大王众天。三十三天所居处别。外轮围山。虚空宫殿。若夜摩天睹史多天乐变化天他化自在天。及色界天所居处别。诸阿素洛所居处别。及诸那落迦所居处别。谓热那落迦。寒那落迦。孤独那落迦。及一分傍生饿鬼所居处别。乃至一日一月周遍流光。所照方处名一世界。如是千世界中有千日千月千苏迷卢山王千四大洲千四大王众天千三十三天千夜摩天千睹史多天千乐变化天千他化自在天千梵世天。如是总名小千世界。千小千界总名第二中千世界。千中千世界总名第三大千世界。如此三千大千世界总有大轮围山周匝围绕。又此三千大千世界同坏同成。譬如天雨滴如车轴无间无断从空下注。如是东方无间无断。无量世界或有将坏。或有将成。或有正坏。或坏已住。或有正成。或成已住。如于东方乃至一切十方亦尔。如是若有情世间若器世间。业烦恼力所生故。业烦恼增上所起故。总名苦谛。业烦恼力所生。业烦恼增上所起者。此二句如其次第显有情世间及器世间俱是苦性。复有清净世界非苦谛摄。非业烦恼力所生故。非业烦恼增上所起故。然由大愿清净善根增上所引。此所生处不可思议。唯佛所觉。尚非得静虑者静虑境界。况寻思者

复次已略辩苦谛相。今当广显诸经所说苦相差别。所谓生苦老苦病苦死苦怨憎会苦爱别离苦求不得苦。略摄一切五取蕴苦。生何因苦。众苦所逼故。余苦所依故。众苦所逼者。谓曾于母胎生熟藏间。具受种种极不净物所逼迫苦。正出胎时复受支体逼切大苦。余苦所依者。谓有生故老病死等众苦随逐。老何因苦。时分变坏苦故。病何因苦。大种变异苦故。死何因苦。寿命变坏苦故。怨憎会何因苦。合会生苦故。爱别离何因苦。别离生苦故。求不得何因苦。所希不果生苦故。略摄一切。五取蕴何因苦。粗重苦故。如是八种略摄为六。谓逼迫苦转变苦合会苦别离苦所希不果苦粗重苦。如是六种广开为八。转变苦中分三种故。若六若八平等平等。问如说三苦。此中八苦为三摄八八摄三耶。答展转相摄。所谓生苦乃至怨憎会苦能显苦苦。顺苦受法苦自相义故。爱别离苦求不得苦能显坏苦。已得未得顺乐受法坏自相义故。略摄一切五取蕴苦能显行苦。不解脱二无常所随不安隐义故。问如说二苦。谓世俗谛苦。胜义谛苦。何者世俗苦。何者胜义苦。答生苦乃至求不得苦。是世俗谛苦。世间智境界故。略摄一切五取蕴苦。是胜义谛苦。由安立真如门出世智境界故

复次诸观行者。于苦圣谛以四种行观察共相。谓无常相苦相空相无我相

无常相者略有十二。谓非有相坏灭相变异相别离相现前相法尔相刹那相相续相病等相种种心行转相资产兴衰相器世成坏相。非有相者。谓蕴界处于一切时我我所性常非有故。言无常者是非有义。由苦圣谛恒无有我我所自性。无者是除遣义。常者是一切时义。以常无故名曰无常。坏灭相者。谓诸行生已即灭。暂有还无故。变异相者。谓诸行异异生。由不相似相续转故。别离相者。谓于诸行失增上力。或他所摄执为己有。以于资具等事。或时自在失坏。或他陵夺为己有故。现前相者。谓正处无常。由因随逐今受无常故。法尔相者。谓当来无常。由因随逐定当受故。死无常性决定当受。刹那相者。谓诸行刹那后必不住。诸行念念劣得自体。无间必坏故。相续相者。谓无始时来诸行生灭相续不断。由无始生死展转相乘轮回不绝故。病等相者。谓四大时分寿命变异。由四大乖违齿发疏落等住时势尽故。种种心行转相者。谓于一时起有贪心。或于一时起离贪心。如是有嗔离嗔有痴离痴。若合若散若下若举。若掉离掉。若不寂静若寂静。若定不定。如是等心行流转。由住能治所治位差别故。资产兴衰相者。谓诸兴盛终归衰变。由诸世间富贵荣盛不可爱乐非究竟故。器世成坏相者。谓火水风三种成坏。由火水风灾令大地等数成坏故。能烧浸燥如其次第。又有三灾顶。谓第二第三第四静虑。由火水风能坏世界安立处所乃至第一第二第三静虑边际。次上所余名三灾顶。如其次第第二第三第四静虑处所差别。第四静虑外宫殿等。虽无外灾成坏。然彼诸天与宫殿等俱生俱灭。说有成坏。由彼有情初生时与宫殿等俱生。终没时与彼俱灭。即说此为成坏故。又有三种中劫所谓饥馑疫病刀兵。此小三灾劫究竟满方乃出现。谓世界成已一中劫初唯减。一中劫后唯增。十八中劫亦增亦减。一中劫初唯减者。谓劫成时第二十一劫。一中劫后唯增者。谓最后劫。十八中劫亦增亦减者。谓于中间十八。二十中劫世界正坏。二十中劫世界坏已住。二十中劫世界正成。二十中劫世界成已住。合此八十中劫为一大劫。由此劫数显色无色界诸天寿量。如说以寿尽故福尽故业尽故。彼彼有情从彼彼处没。云何寿尽。谓时死此约时没说。由所引寿时分究竟应时死故。云何福尽。谓非时死即非福死。此约非时没说。以彼有情贪着定味。福力减尽因此命终。由爱定味损害所修引寿业力非时死故。云何业尽。谓顺生受业顺后受业俱尽故死。此约相续没说。由于此处顺生后受业受用斯尽。以无业故不复生此

苦相者。或三或八或六广说如前。何故经说若无常者即是苦耶。由三分无常为缘苦相可了知故。谓生分无常。灭分无常。俱分无常。生分无常。为缘故苦苦性可了知。生分无常者。谓本无今有。苦品诸行体是逼迫。由此无常为缘苦苦性可了知。灭分无常为缘坏苦性可了知。灭分无常者。谓已有还无。乐品诸行不可爱乐。由此无常为缘坏苦性可了知。俱分无常为缘行苦性可了知俱分无常者。谓粗重诸行相续流转。若生若灭俱不可乐。由此俱分无常为缘行苦性可了知。即依此义薄伽梵说。诸行无常诸行变坏。又依此义言诸所有受我说皆苦。当知此中于不苦不乐受及乐受。密意故说苦苦。受苦性世间共了故不复密意说。又于生灭二法所随诸行中有生等八苦。性可了知故。佛说言若无常者即是苦。又于无常诸行中有生等苦可了者。如来依此密意说言。由无常故苦非一切行。若不尔圣道无常故亦应是苦

空相者。谓若于是处此非有。由此理正观为空。若于是处余是有。由此理如实知有。是名善入空性。如实知者不颠倒义。问于何处谁非有。答于蕴界处常恒凝住。不变坏法我我所等非有。由此理彼皆是空。问于是处谁余有。答即此处无我性。此我无性无我有性。是谓空性。由彼诸行常等相我此中无故。诸行恒时离我性相。无我真性此中有故。非一向无此俱名空性。故薄伽梵密意说言。有如实知有无如实知无。又有三种空性。谓自性空性。如性空性。真性空性。初依遍计所执自性观。由此自相定非有故。第二依依他起自性观。由此如所计度皆非有故。第三依圆成实自性观。由此即空真性故

无我相者。谓如我论者。所立我相蕴界处非此相。由蕴界处我相无故。名无我相我论外道计度诸行为我。彼诸行非此相故名无我。故薄伽梵密意说言。一切法皆无我。如世尊说。此一切非我所。此非我处此非我我。于如是义应以正慧如实观察。此言何义。谓于外事密意说此一切非我所。于内事密意说此非我处此非我我所。所以者何。以于外事唯计我所相。是故但遣我所。于内事通计我我所相。是故双遣我我所

问前说无常皆刹那相。此云何知。答如心心法是刹那相。当知色等亦刹那相。由心执受故。等心安危故。随心转变故。是心所依故。心增上生故。心自在转故。又于最后位变坏可得故。生已不待缘自然坏灭故。当观色等亦念念灭。诸无常行坏灭等相。心心法刹那相。世间共了。更不重辩。诸色等法刹那灭相。世不共了故今成立。由心执受者。谓色等身。由刹那心念念执受故刹那灭。等心安危者。谓色等身恒与识俱。识若舍离即便烂坏。由身与心安危等故。决定如心念念生灭。随心转变者。谓世间现见心。在苦乐贪嗔等位身随转变。随刹那心而转变故身念念灭。是心所依者。谓世间共知心依止有根身。若法依此生非此自无坏。能依有可见。如火芽等依薪种等。是故此身是刹那心所依止故。亦刹那灭。心增上生者。谓一切内外色皆心增上所生。能生因刹那灭故。所生果亦刹那灭。如世尊说。诸因诸缘能生于色。彼亦无常。无常因缘力所生故。色云何常。随此经句义。身定刹那灭。心自在转者。谓若证得胜威德心。于一切色如其所欲自在转变。由随刹那能变胜解转变生故。色等刹那道理成就。于最后位变坏可得者。谓诸色等初离自性念念变坏。于最后位欻尔变坏。不应道理然此可得。故知色等从初已来念念变坏。自类相续渐增为因。能引最后粗相变坏。是故色等念念生灭。生已不待缘自然坏灭者。谓一切法从缘生已。不待坏缘自然坏灭。以不待余缘自然坏灭故。最初生已决定坏灭。若言生已初无灭坏。后方有者不然。无差别故。故知一切可灭坏法。初才生已即便坏灭。是故诸法刹那义成

问如世尊说。诸所有色彼一切若四大种若四大种所造。此依何意说。答依容有意说同在一处。依此而有是造义。由所造色离大种处别自建立无功能故。若于此聚此大种可得。当知此聚唯有此大种非余。或有聚唯一大种。如干泥团等。或有二大种。谓即此湿。或有三大种。谓即此暖。或有一切大种。谓即此湿暖泥团等。于移转位所造色亦尔。若于此聚此所造色可得。当知此聚唯此非余。或有聚唯一所造色如光等。或有二所造色如有声香风等。或有三所造色如香烟等。由此香烟有色香触差别所显故。触差别者。谓此中轻性。或有四所造色。如沙糖团等。或有五所造色。谓即此有声时。又若于此聚大种造色随分可得。当知此中有此非余。此依粗物说非种子。一一聚中有一切种子故

又说粗聚色极微集所成者。当知此中极微无体无实无性。唯假建立。展转分析无限量故。但由觉慧渐渐分析。细分损减乃至可析边际。即约此际建立极微。问若诸极微无实体性何故建立。答为遣一合想故。若以觉慧分分分析所有诸色。尔时妄执一切诸色为一合想即便舍离。由此顺入数取趣无我性故。又为悟入诸所有色非真实故。若以觉慧如是分析所有诸色至无所有。尔时便能悟入诸色皆非真实。因此悟入唯识道理。由此顺入诸法无我性故

复次苦法略有八种差别。谓有广大不寂静苦。有寂静苦。有寂静不寂静苦。有中不寂静苦。有微薄不寂静苦。有微薄寂静苦。有极微薄寂静苦。有非苦似苦住大寂静。云何广大不寂静苦。谓生欲界未曾积集诸善根者。由欲界一切生趣苦具足所显故。未集善根不能遮止往诸趣故。如其次第名广大不寂静苦。云何寂静苦。谓即此已生顺解脱分善根者。决定趣向般涅槃故。云何寂静不寂静苦。谓即此为世间道离欲已种善根者。由即此欲界苦为世间道离欲已种善根者决定超越苦苦等故。然非毕竟故。如其次第。如是中不寂静苦等随所应当释。云何中不寂静苦。谓生色界远离顺解脱分者。云何微薄不寂静苦。谓生无色界远离顺解脱分者。云何微薄寂静苦。谓诸有学。云何极微薄寂静苦。谓诸无学命根住缘六处。云何非苦似苦住大寂静。谓已得究竟菩萨摩诃萨等。乘大悲愿力故生诸有中。由能除灭无量众生相续大苦故。名住大寂静

复次前说死苦。死有三种。谓或善心死。或不善心死。或无记心死。善心死者。谓于明利心现行位。或由自善根力所持故。或由他所引摄故。发起善心趣命终位。不善心死者。谓亦于明利心现行位。或由自不善根力所持故。或由他所引摄故。起不善心趣命终位。无记心死者。谓若于明利心现行位。若于不明利心现行位。或由阙二缘故。或由加行无功能故。起无记心趣命终位。此中所言善等心死者。当知依我爱相应将命终心位前说。修净行者临命终位。于身下分。先起冷触。不净行者临命终位。于身上分先起冷触。又不净行者中有生时。其相显现如黑羊羔光。或如阴闇夜分。修净行者中有生时。其相显现如白练光。或如晴明夜分。又此中有在欲色界正受生位。亦从无色界命终后位。亦名意生健达缚等。极住七日。或有中夭。或时移转。言意生者。谓受化生身。唯心为因故。香所引故。名健达缚。是随逐于香往受生处。义极住七日。或有中夭者。此约速得生缘者说。若过七日不得生缘。必定命终还生中有。如是展转乃至七返更不得过。或时移转者。谓于此位往余生处。强缘现前。如得第四静虑起阿罗汉增上慢比丘。彼地中有生时。由谤解脱邪见故。转生地狱中有。又住中有中亦能集诸业。先串习力所引善等思现行故。又能睹见同类有情。谓先所共行善不善者。如于梦中见已与彼现同游戏。又中有形似当生处如当生处。前时有形而起故。又此中有所趣无碍。如具神通往来迅速。仍于生处有所拘碍。又此中有于所生处。如称两头低昂道理。终没结生时分亦尔。又住中有中于所生处发起贪爱。亦用余烦恼为缘助。此中有身与贪俱灭。羯逻蓝身与识俱生此唯是异熟。自此已后根渐生长。如缘起中说。于四生类。或受卵生。或受胎生。或受湿生。或受化生。如缘起中说者。谓名色等前后次第如说

  最初羯逻蓝　　次生頞部昙
  从此生闭尸　　闭尸生键南
  次钵罗奢佉　　后发毛爪等
  及色根形相　　渐渐而生长

云何集谛。谓诸烦恼及烦恼增上所生诸业。俱说名集谛。由此集起生死苦故。烦恼增上所生业者。谓有漏业。若尔何故。世尊唯说爱为集谛。由最胜故。谓薄伽梵随胜而说。若爱。若后有爱。若贪喜俱行爱。若彼彼希乐爱。是名集谛。言最胜者是遍行义。由爱具有六遍行义。是故最胜。何等为六。一事遍行。谓于一切已得未得自身境界事遍行故。于已得自身起爱。于未得自身起后有爱。于已得境界起贪喜俱行爱。于未得境界起彼彼希乐爱。二位遍行。谓于苦苦性等三位诸行中遍随行故。于已得苦苦性位起别离爱。于未得苦苦性位起不和合爱。于坏苦性位起不别离爱。及和合爱。已得未得差别故。于行苦性位起愚痴爱。由烦恼粗重所显故。及不苦不乐受所显故。唯阿赖耶识是最胜行苦位。依止此位因我痴门贪爱转故。三世遍行。谓于三世中遍随行故。于过去世起追忆行遍随行爱。于未来世起希乐行遍随行爱。于现在世起耽着行遍随行爱。四界遍行。谓欲色无色三爱次第遍三界故。五求遍行。谓由贪爱遍求欲有邪梵行故。由欲求力不脱欲界招欲界苦。由有求力不脱二界招色无色界苦。由邪梵行求力不脱生死彼彼流转故。六种遍行。谓有无有爱遍行断常一切种故

烦恼者。谓由数故相故缘起故境界故相应故差别故邪行故界故众故断故。观诸烦恼。数者。谓或六或十。六谓贪嗔慢无明疑见。十谓前五见。又分五谓萨迦耶见。边执见邪见见取戒禁取

相者。若法生时相。不寂静由此生故身心相续。不寂静转是烦恼相。不寂静性是诸烦恼共相。此复有六。谓散乱不寂静性。颠倒不寂静性。掉举不寂静性。惛沈不寂静性。放逸不寂静性。无耻不寂静性

缘起者。谓烦恼随眠未永断故。顺烦恼法现在前故。不正思惟现前起故。如是烦恼方乃得生。烦恼随眠未永断者。彼品粗重未永拔故。顺烦恼法现在前者。现前会遇可爱等境故。不正思惟现前起者。于彼境界取净等相。能随顺生贪嗔等故

境界者。谓一切烦恼还用一切烦恼为所缘境。及缘诸烦恼事。又欲界烦恼除无明见疑。余不能缘上地为境。此无明等虽亦有能缘上地者。然彼不能亲缘上地如缘自地。由依彼门起分别故。立彼为所缘。所言无明缘上地者。谓与见等相应见者。除萨迦耶见不见世间。缘他地诸行执为我故。上地诸烦恼不缘下地为境。已离彼地欲故。又缘灭道谛诸烦恼。不能亲缘灭道为境。由灭道谛出世间智及后得智内所证故。唯由依彼妄起分别说为所缘。分别所计境不离分别故。又烦恼有二种。谓缘无事及缘有事。缘无事者。谓见及见相应法。见谓萨迦耶见及边执见。所余烦恼名缘有事

相应者。谓贪不与嗔相应。如嗔疑亦尔。余皆得相应。何故贪不与嗔相应。一向相违法必不俱转故。又贪不与疑相应者。由慧于境不决定必无染着故。余得相应者。与余慢等不相违故。如贪嗔亦尔。谓嗔不与贪慢见相应。若于此事起憎恚。即不于此生于高举。及能推求与余相应如理应知。慢不与嗔疑相应。无明有二。一一切烦恼相应无明。二不共无明。不共无明者。谓于谛无智。见不与嗔疑相应。疑不与贪慢见相应。忿等随烦恼更互不相应。展转相违法必不相应故。如贪分与嗔分。若不相违。犹如烦恼展转相应。无惭无愧于一切不善品中恒共相应。若离不顾自他不善现行无是处故。惛沉掉举不信懈怠放逸。于一切染污品中恒共相应。若离无堪任性等染污性成无是处故

差别者。谓诸烦恼依种种义立种种门差别。所谓结缚随眠随烦恼缠瀑流轭取系盖株杌垢烧害箭所有恶行漏匮热恼诤炽然稠林拘碍等

问结有几种。云何结。何处结耶。答结有九种。谓爱结恚结慢结无明结见结取结疑结嫉结悭结

爱结者。谓三界贪爱。结所系故不厌三界由不厌故广行不善不行诸善由此能招未来世苦与苦相应。当知此中宣说诸结若相若用若位辩结差别。且如爱结何等是结。谓三界贪是结自性。云何为结。谓有此者不厌三界。由此展转不善现行善不现行。于何位结。谓于后世苦果生位。如是恚结等并如理应知

恚结者。谓于有情苦及顺苦法心有损害。恚结所系故。于恚境相心不弃舍。不弃舍故广行不善不行诸善。由此能招未来世苦与苦相应

慢结者。即七慢。谓慢过慢慢过慢我慢增上慢下劣慢邪慢。慢者。谓于下劣计己为胜。或于相似计己相似。心举为性。过慢者。谓于相似计己为胜。或复于胜计己相似。心举为性。慢过慢者。谓于胜己计己为胜。心举为性。我慢者。于五取蕴观我我所。心举为性。增上慢者。谓于未得上胜证法计己已得上胜证法。心举为性。下劣慢者。谓于多分胜计己少分劣。心举为性。邪慢者。谓实无德计己有德。心举为性。慢结所系故。于我我所不能了知。不了知故执我我所。广行不善不行诸善。由此能招未来世苦与苦相应

无明结者。谓三界无智。无明结所系故。于苦法集法不能解了。不解了故广行不善不行诸善。由此能招未来世苦与苦相应。于苦集法不解了者。谓于果性因性有漏诸行。所有过患不了知故

见结者。即三见。谓萨迦耶见边执见邪见。见结所系故。于邪出离妄计追求。谓我当解脱我所解脱。既解脱已我当常住。或当断灭。又谓佛法中定无解脱。如是执着邪出离已。广行不善不行诸善。由此能招未来世苦与苦相应

取结者。谓见取戒禁取。取结所系故。于邪出离方便妄计执着。弃舍八圣支道。妄执萨迦耶见等。及彼为先若戒若禁为清净道。以妄执着邪出离方便故。广行不善不行诸善。由此能招未来世苦与苦相应

疑结者。谓于谛犹豫。疑结所系故。于佛法僧宝妄生疑惑。以疑惑故于三宝所不修正行。以于三宝所不修正行故。广行不善不行诸善。由此能招未来世苦与苦相应

嫉结者。谓耽着利养不耐他荣发起心妒。嫉结所系故爱重利养不尊敬法。重利养故广行不善不行诸善。由此能招未来世苦与苦相应

悭结者。耽着利养于资生具其心吝惜。悭结所系故。爱重畜积不尊远离。重畜积故广行不善不行诸善。由此能招未来世苦与苦相应

缚有三种。谓贪缚嗔缚痴缚。由贪缚故缚诸众生令处坏苦。由嗔缚故缚诸众生令处苦苦。由痴缚故缚诸众生令处行苦。由贪等缚缚处坏苦等者。以贪嗔痴于乐等受常随眠故。又依贪嗔痴故。于善方便不得自在故名为缚。犹如外缚缚诸众生。令于二事不得自在。一者不得随意游行。二者于所住处不得随意所作。当知内法贪嗔痴缚亦复如是

随眠有七种。谓欲爱随眠嗔恚随眠有爱随眠慢随眠无明随眠见随眠疑随眠。欲爱随眠者。谓欲贪品粗重。嗔恚随眠者。谓嗔恚品粗重。有爱随眠者。谓色无色贪品粗重。慢随眠者。谓慢品粗重。无明随眠者。谓无明品粗重。见随眠者。谓见品粗重。疑随眠者。谓疑品粗重。若未离欲求者由欲爱嗔恚随眠之所随眠。由依彼门此二增长故。未离有求者由有爱随眠之所随眠。未离邪梵行求者由慢无明见疑随眠之所随眠。由彼众生得少对治。便生憍慢。愚于圣谛。虚妄计度外邪解脱解脱方便。随其次第三见二取。如结中说。于佛圣教正法毗柰耶中。犹豫疑惑

大乘阿毗达磨杂集论卷第六大乘阿毗达磨杂集论卷第七

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    决择分中谛品第一之二

随烦恼者。谓所有诸烦恼皆是随烦恼。有随烦恼非烦恼。谓除烦恼所余染污行蕴所摄一切心法。此复云何。谓除贪等六烦恼。所余染污行蕴所摄忿等诸心法。又贪嗔痴名随烦恼心法。由此随烦恼随恼于心令不离染令不解脱令不断障故。名随烦恼。如世尊说。汝等长夜为贪嗔痴随所恼乱心恒染污。缠有八种。谓惛沉睡眠掉举恶作嫉悭无惭无愧数数增盛。缠绕于心故名缠。由此诸缠数数增盛缠绕一切观行者心于修善品为障碍故。修善品者。谓随修习止举舍相及彼所依梵行等所摄净尸罗时。此复云何。谓修止时惛沉睡眠为障。于内引沉没故。修举时掉举恶作为障。于外引散乱故。修舍时嫉悭为障。由成就此于自他利吝妒门中数数摇动心故。修净尸罗时无惭无愧为障。由具此二犯诸学处无羞耻故

暴流有四。谓欲暴流有暴流见暴流无明暴流。随流漂鼓是暴流义。随顺杂染故。初是习欲求者。第二是习有求者。后二是习邪梵行求者。能依所依相应道理故。见暴流是能依。无明暴流为所依。由有愚痴颠倒推求解脱及方便故

轭有四种。谓欲轭有轭见轭无明轭。障碍离系是轭义。违背清净故。此亦随其次第习三求者相应现行

取有四种。谓欲取见取戒禁取我语取。执取诤根执取后有是取义。所以者何。由贪着欲系缚耽染为因。诸在家者更相斗诤。此诤根本是第一取。由贪着见系缚耽染为因。诸出家者更相斗诤。此诤根本是后三取。六十二见趣是见取。各别禁戒多分苦行是戒禁取。彼所依止萨迦耶见是我语取。由见取戒禁取诸外道辈更相诤论。以于是处见不一故。由我语取诸外道辈互无诤论。于我有性皆同见故。然由此取诸外道等与正法者互有诤论。由彼不信有无我故。如是执着诤论根本。复能引取后有苦异熟故名为取

系有四种。谓贪欲身系嗔恚身系戒禁取身系此实执取身系。以能障碍定意性身故名为系。所以者何。由此能障定心自性之身故名系。非障色身。何以故。能为四种心乱因故。谓由贪爱财物等因令心散乱。于斗诤事不正行。为因令心散乱。于难行戒禁苦恼为因令心散乱。不如正理推求境界为因令心散乱。由彼依止各别见故。于所知境不如正理种种推度妄生执着。谓唯此真余并愚妄。由此为因令心散动。于何散动。谓于定心如实智见

盖有五种。谓贪欲盖嗔恚盖惛沉睡眠盖掉举恶作盖疑盖。能令善品不得显了是盖义。覆蔽其心障诸善品令不转故。问于何等位障诸善法答于乐出家位觉正行位止举舍位。于乐出家时贪欲盖为障。希求受用外境界门。于彼不欣乐故。于觉正行时嗔恚盖为障。于所犯学处同梵行者正发觉时。由心嗔恚不正学故。于止举两位惛沉睡眠掉举恶作盖为障。如前所说。能引沉没及散乱故。于舍位疑盖为障。远离决定不能舍故

株杌有三。谓贪嗔痴。由依止贪嗔痴先所串习为方便故。成贪等行心不调顺。无所堪能难可解脱。令诸众生难断此行故名株杌。所以者何。对治道犁难可破坏。约此义故立为株杌。于无量生串习贪等以成其行。坚固难拔犹株杌故

垢有三种。谓贪嗔痴。由依止贪嗔痴故。毁犯如是尸罗学处。由此有智同梵行者。或于聚落或闲静处见已。作如是言。此长老作如是事行如是行。为聚落刺点染不净。说名为垢。以贪嗔痴能现犯戒不净相故

烧害有三。谓贪嗔痴。由依止贪嗔痴故。长时数受生死烧恼。故名烧害。由于无始生死流转因贪嗔痴数被生死苦烧害故

箭有三种。谓贪嗔痴。由依止贪嗔痴故。于有有具深起追求相续不绝。于佛法僧苦集灭道常生疑惑。故名为箭。于诸有财三宝四谛。随爱疑门能射伤故

所有有三。谓贪嗔痴。由依止贪嗔痴故。积畜财物有怖有怨。多住散乱故名所有。由多积集所有资具恒与怖等共相应故

恶行有三。谓贪嗔痴。由依止贪嗔痴故。恒行身语意恶行。故名恶行。由贪嗔痴能引杀生等诸不善行故。又即依此贪嗔痴门。广生无量恶不善行故。建立三不善根。所以者何。以诸有情爱味世间。所有为因行诸恶行贪求财利。行恶行故分别世间。怨相为因行诸恶行。由怀嗔恚不忍他过多行恶故执着世间。邪法为因行诸恶行。由怀愚痴起颠倒见。因祠祀等行诸恶故。是故此贪嗔痴亦名恶行。亦名不善根

漏有三种。谓欲漏有漏无明漏。令心连注流散不绝故名为漏。此复云何。依外门流注故立欲漏。依内门流注故立有漏。依彼二所依门流注。故立无明漏。令心连注流散不绝是漏义

匮有三种。谓贪嗔痴。由依止贪嗔痴故。于有及资生具恒起追求无有厌足。常为贫乏众苦所恼故。故名匮。以贪嗔痴能令身心恒乏短故

热有三种。谓贪嗔痴。由依止贪嗔痴故。不如正理执着诸相执着随好。由执着相及随好故。烧恼身心。故名为热。不如正理妄执相好烧身心故

恼有三种。谓贪嗔痴。由依止贪嗔痴故。随彼彼处爱乐耽着。彼若变坏便增愁叹。种种忧苦热恼所触。故名为恼。由于色等诸可乐事深爱着已。彼若变坏是诸有情。便为种种愁叹等苦所恼乱故

诤有三种。谓贪嗔痴。由依止贪嗔痴故。执持刀杖兴诸战诤种种斗讼。是故贪等说名为诤

炽然有三。谓贪嗔痴。由依止贪嗔痴故。为非法贪大火所烧。非法贪者。谓随贪着不善业道。又为不平等贪大火所烧。不平等贪者。谓非法非理贪求境界。又为邪法大火所烧。邪法者。谓诸外道恶说法律。以非法贪等能发身心炽然大火。如火炽然故名炽然

稠林有三。谓贪嗔痴。由依止贪嗔痴故。于诸生死根本行中广兴染着。令诸有情感种种身流转五趣。令诸有情处生死本行大树稠林难可出离。是故贪等说名稠林

拘碍有三。谓贪嗔痴。由依止贪嗔痴故。顾恋身财无所觉了乐处愦闹。得少善法便生厌足。由此不能修诸善法故名拘碍。依贪嗔痴顾身财等。拘碍有情不得自在修诸善故。又此顾恋身等。即依五种心拘碍说。何等为五谓顾恋身顾恋诸欲乐相杂住。阙于随顺教诫教授。于诸善品得少为足。拘碍心故名心拘碍。诸如是等烦恼义门差别无量

邪行者。谓贪嗔二烦恼。迷境界及见起邪行。修道所断见道所断。随其次第。贪嗔二种缘少净相及相违相为境界故。名迷境界虽亦缘。有情起于贪嗔。然依境界门起故。亦名迷境界。慢迷有情及见起邪行。以于下劣等起计己胜等行于有情门邪解转故。萨迦耶见边执见邪见。迷所知境起邪行。依增益损减门。如其所应。见取戒禁取迷诸见起邪行。由于诸见过失取为第一及戒禁清净故。疑迷对治起邪行。于诸谛中成二解故。无明迷一切起邪行。又十烦恼皆迷苦集起诸邪行。是彼因缘所依处故。所以者何。苦集二谛皆是十种烦恼因缘。又为依处。是故一切迷此因缘依处起诸邪行。又十烦恼皆迷灭道起诸邪行。由此能生彼怖畏故。所以者何。由烦恼力乐着生死。于清净法起悬崖想生大怖畏。又诸外道于灭道谛。妄起种种颠倒分别。是故十惑皆迷灭道起诸邪行

界云何。谓除嗔余一切通三界系。嗔唯欲界系。缘违损境生故。又贪于欲界与乐喜舍相应。如于欲界于初二静虑亦尔。于第三静虑与乐舍相应。已上唯与舍相应。贪于欲界与乐相应者。谓在五识身。与喜相应者在意识身。与舍相应者在一切处。于相续末位所以不与忧苦相应者。由此欣行转故。嗔与苦忧舍相应。苦相应者在五识身。忧相应者在第六识。所以不与喜乐相应者。由此戚行转故嗔能逼恼自相续故名戚行。与舍相应者于一切处。如前说。慢于欲界与喜舍相应。于初二静虑与乐喜舍相应。于第三静虑与乐舍相应。已上唯舍相应。慢于欲界乐不相应者以五识无故。若尔于初二静虑。云何与乐相应。与意地乐相应故无过。云何于彼有意地乐。由说彼地有喜乐故。如经言。云何为喜。谓已转依者依于转识。心悦心踊心适心调心安适受受所摄。依于转识者即依意识。于三摩呬多位余识无故。云何为乐。谓已转依者依阿赖耶识。摄受所依所依怡悦安适受受所摄此经意说。乐受依初二静虑生时。与如是心心法聚相应。由欣踊行还令此聚皆得踊悦。又令所依阿赖耶识。自体安乐怡适。由此乐受作二事故。体虽是一建立二种。若喜若乐。是故说此相应慢与乐喜相应。如慢萨迦耶见边执见见取戒禁取亦尔。邪见于欲界与忧喜舍相应。于色无色界随所有受皆与相应。云何邪见于欲界与忧喜相应。谓先造妙行恶行者。见此无果生欣戚故。所以不与苦乐相应者。由一切见皆在意地故。疑于欲界与忧舍相应。于色无色界随所有受皆与相应。所以欲界非喜相应者。不决定心若未息灭喜不生故。色界中疑疑上静虑者。由喜乐定力所引持故。亦得随转。是故于彼亦与喜乐相应。无明有二种。谓相应不共相应无明。一切烦恼相应故。若于是处随所有受皆得相应。不共无明于欲界与忧舍相应。于上界随所有受皆得相应。喜乐相应不相应理应如疑说。何故诸烦恼皆与舍相应。以一切烦恼堕中庸位方息没故。所以者何。烦恼生起展转相续渐渐微薄。势力将尽堕处中位。于此位中必与舍受相应

又贪于欲界在六识身。如贪嗔无明亦尔。贪于色界在四识身。彼无鼻舌识故。于无色界唯在意识身。如贪无明亦尔。慢见疑于一切处唯在意识身。由彼于称量等门转故。又贪嗔慢于欲界缘一分事转。如于欲界于色无色界亦尔。慢缘一分事转者。随于一分高举生故。所余烦恼于一切处遍缘一切事转

众云何。谓二众烦恼。见道所断众。修道所断众。欲界见苦所断具十烦恼。如见苦所断见集灭道所断亦尔。若迷此起邪行即见此所断。问若缘此为境即迷此起邪行耶。答不必尔。缘无漏为境。烦恼唯于有漏事随增故。若是处是彼因缘及所依处。彼迷此起邪行。是见苦所断如见苦所断见集灭道所断亦尔。随其所应色界见四种所断。各有九烦恼除嗔。如色界无色界亦尔。如是见道所断烦恼众。总有一百一十二。欲界修所断有六烦恼。谓俱生萨迦耶见边执见。及贪嗔慢无明。何等名为修所断。俱生萨迦耶见。谓圣弟子虽见道已生。而依止此故我慢现行。如经言。长老驮索迦当知。我于五取蕴不见我我所。然于五取蕴有我慢我欲我随眠。未永断未遍知未灭未吐。犹如乳母有垢腻衣。虽以卤土等水浣濯极令离垢。若未香熏臭气随转。复以种种香物熏坌臭气方尽。如是佛圣弟子。虽以见道永断分别身见之垢。若未以修道熏习相续。无始串习虚妄执着习气所引不分别事我见随转。复以随道熏习相续彼方永灭。俱生边执见者。谓断见所摄。由此见故于涅槃界其心退转生大怖畏。谓我我今者何所在耶。贪等烦恼修道所断者。谓除见品所摄。色界修道所断有五除嗔。如色界无色界亦尔。如是修道所断烦恼总有十六

断云何。谓如此差别断。由此作意断从此而得断。如此差别断者。谓遍知故远离故得对治故。遍知者。谓彼因缘事遍智自体遍智过患遍智。彼因缘事遍智者。谓知烦恼随眠未永断故。如是等如前说。自体遍智者。谓知此烦恼生已极恼乱心性。过患遍智者。谓知此烦恼能引自害。能引害他。能引俱害。能生现法过。能生后法过。能生现法后法过。能令有情受此所生身心忧苦。远离者。虽彼暂生而不坚执。由彼因缘事遍智等三种遍智。于彼已生一切烦恼。心不坚执方便远离。得对治者。谓未生者令不生故。已生者令断故得对治道。为令未生已生烦恼不生永断。修治道故。问何等作意能断耶。答总缘作意观一切法。皆无我性能断烦恼。总缘作意者。谓合缘一切法共相行作意。问若唯总缘诸法无我智能断烦恼者。何故显示无常等行。答非为断烦恼故修习彼行。但为修治无我行故。由依无常行引得苦行。依止苦行引无我行。如经言。无常故苦。苦故无我。是故建立此无我行为无上。无上有三种。谓智无上行无上解脱无上。智无上者。谓无我智。得此智已更无所求故。行无上者谓乐。速通行一切。行中最第一故。解脱无上者。谓无。学不动解脱。于一切解脱最为胜故。此三无上如其次第。依止见修无学道说。问从何而得断耶。答不从过去已灭故。不从未来未生故。不从现在道不俱故。然从诸烦恼粗重而得断为。断如是如是品粗重。生如是如是品对治。若此品对治生。即此品粗重灭。平等平等犹如世间明生暗灭。由此品离系故。令未来烦恼住不生法中。是名为断

复次烦恼增上所生业云何。谓若思业若思已业。总名业相。又业有五种。谓取受业作用业加行业转变业证得业。取受业者。谓眼等能见色等。作用业者。谓地等能任持等。或复诸法自相所作。谓所有色质碍变坏如是等。加行业者。谓意解为先起身业等。转变业者。谓金师等造庄严具等。证得业者。谓圣道等证涅槃等。今此义中意多分别加行业。颇亦兼有证得作用二业。思业云何。谓福业非福业不动业。思已业云何。谓身业语业意业又。此身语意三业或善或不善。不善者即十不善业道。谓杀生不与取欲邪行。妄语离间语粗恶语绮语。贪欲嗔恚邪见。善者即十善业道。谓离杀生乃至离杂秽语无贪无嗔正见。今于此中唯以业道显身等业者。为随顺经就胜而说。彼方便等亦身等业所摄故。前三中四后三业道。随其次第是身语意业相。又杀生等应以五门分别其相。谓事故意乐故方便故烦恼故究竟故杀生。等事者。谓有情数非有情数。如其所应依此处所起杀生等。意乐者。谓于此事起此想意乐。及起当作此业道意乐。方便者。谓此作用或自或他发身语意。烦恼者。谓贪嗔痴。如其所应或总或别。究竟者。由彼彼方便如是如是业道圆满。或于尔时或于后时。于此义中杀生事者。谓有情数。意乐者。谓此想及必害意方便者。谓为害故如刀杖等。烦恼者。谓贪等。究竟者。谓彼众生由方便故。或无间死或后时死。不与取等事及究竟当广分别。余如理应思。不与取事者。谓他所摄若有情数非有情数。究竟者。谓取为己有。欲邪行事者。谓非所行女。或虽所行非分非处非时非量。及不应理一切男及不男究竟者。谓两两交会虚。诳语事者谓。见闻觉知不见不闻不觉不知意乐者谓。别异想欲别异说究竟者。谓时众及对言者领解。离间语事者。谓诸有情若和合若不和合。意乐者。谓即于彼起乖离及不和合意。究竟者。谓所破领解。粗恶语事者。谓诸有情能为损害。究竟者。谓发粗恶言。绮语事者。谓能引摄不饶益义。究竟者。谓正发此言。贪欲事者。谓他所摄资财。意乐者。谓起此想及爱乐。方便者。谓思量筹度欲为己有。究竟者。决定执为己有。嗔恚事者。谓诸有情能为损害。究竟者谓决定加害等。邪见事者。谓实有义。意乐者。谓于实有起非有想。及彼欲乐。究竟者。谓决定诽谤。如经言故思造业。云何名为故思造业。略有五种。谓他所教敕故思造业。他所劝请故思造业。无所了知故思造业。根本执着故思造业。颠倒分别故思造业。他所教敕故思造业者。犹如有一。虽不欲乐因他强力之所教敕发起故思行不善业。他所劝请故思造业者。犹如有一。虽不欲乐因他劝请因他引导。执为利益发起故思行不善业。无所了知故思造业者犹如有一。不了德失无所执着。随欲所作发起故思行不善业。根本执着故思造业者。犹如有一。为贪嗔等诸不善根缠蔽其心。猛利执着发起故思行不善业。颠倒分别故思造业者。犹如有一。依不平等因见爱乐邪法。为求当来可爱异熟发起故思行不善业。于此五中根本执着故思造业。颠倒分别故思造业。此二种若作若增长非不受异熟。所以者何。前三故思作业虽作不增长。轻故不必受异熟。后二故思作业若作若增长。重故必定受异熟。作者。谓起造诸业令其现行。增长者。谓令习气增益。于阿赖耶识中长养异熟种子故。如经言。决定受业者云何决定。谓作业决定。受异熟决定。分位决定。作业决定者。由宿业力感得决定异熟相续。于此生中必造此业。何以故。应造此业期限决定故。终不越限必造此业。乃至诸佛世尊大神通力。亦不能为障令其不造。随因决定力果相续转变故。受异熟决定者。如先所说故思造业。分位决定者。谓现法受等分位决定业。如由此业于现法中必定受异熟。由此业必受。生异熟由此业必受后异熟又十不善业。道异熟果者于三恶趣。中随下中上品受傍。生饿鬼那落迦异熟。等流果者。各随其相于人趣中感得自身众具衰损。谓从恶趣没后生人中。由杀盗等各随其相。感得自身众具衰损。所谓寿命短促常贫穷等如其所应。增上果者。各随其相感得所有外事衰损。谓杀生等各随其相。感稼穑等外事衰损所谓外具乏少光泽。是杀生增上果如是等。如经言。于一切十不善业道修习。多修习故生于那落迦傍生饿鬼。是彼异熟果若得来此人同分中。由杀生故今得短寿。不与取故乏少财物。欲邪行故妻不贞良。由虚诳语故多被诽谤。离间语故亲友乖离。粗恶语故恒闻不如意声。由绮语故言不威肃。由贪欲故贪转猛盛。由嗔恚故嗔转猛盛。由邪见故痴转猛盛。诸邪见者痴增上故。是彼等流果。由极修习杀生业故。一切外事乏少光泽。不与取故多遭霜雹。欲邪行故多诸尘坌。妄语故多诸臭秽。离间语故高下险阻。粗恶语故其地碱卤硗确秽恶。绮语故时候乖变。贪欲故果实鲜少。嗔恚故果味辛苦。邪见故果味辛苦。或全无果。是彼增上果。又十善业道异熟果者。谓于人天趣中受人天异熟。等流果者。谓即于彼处各随其相感得自身众具兴盛。增上果者。谓即于彼处各随其相感得外事兴盛。如不善业道建立异熟果等三种差别。如是有漏善业道。于人天中三果差别。如其所应亦当建立。又善不善业于善趣恶趣中感生异熟时。有二种差别。谓招引业圆满业。招引业者。谓由此业能牵异熟果。圆满业者。谓由此业生已领受爱不爱果。复次或有业。由一业力牵得一身。谓由一业力长养一生异熟种子故。或有业由一业力牵得多身。谓由一业力长养多生异熟种子故。或有业由多业力牵得一身。谓由多业刹那数数长养一生异熟种子故。或有业由多业力牵得多身。谓多刹那业更相资待。展转长养多生异熟种子故。问若一有情成就多业。云何次第受异熟果耶。答于彼身中重者先熟。或将死时现在前者。或先所数习者。或最初所行者。彼异熟先熟。如经言有三种业。谓福业非福业不动业。福业者。谓欲界系善业。非福业者。谓不善业。不动业者。谓色无色界系善业。问何故色无色系善业名不动耶。答如欲界中余趣圆满善不善业。遇缘转得余趣异熟。非色无色系业。有如是事。所受异熟界地决定故。是故约与异熟不可移转。名为不动。又定地摄故说为不动。问如经中说。无明缘行。若福非福及与不动。云何福及不动行缘无明生耶。答有二种愚。一异熟愚。二真实义愚。由异熟愚故发非福行。由真实义愚故发福及不动行。由异熟愚发非福行者。由彼一向是染污性。无明合时必不容受信解异熟行相正见故。由真实义愚发福不动行者。真实义即四圣谛。于彼愚痴名真实义愚。未见谛者虽起善心。由彼随眠所随缚故。亦名愚痴。由彼势力于三界苦不如实知。便能发起后有因性福不动行。非已见谛者能发此业。无真实义愚故。是故彼业说因此生。复次杀生业道贪嗔痴为方便。由嗔究竟。如杀生粗恶语嗔恚业道亦尔。杀生贪为方便者。为皮肉等故。嗔为方便者。为除怨等故。痴为方便者。为祠祀等故。由嗔究竟者。离无慈悲必不杀害他有情故。粗恶语等如理应知。不与取业道贪嗔痴为方便。由贪究竟。如不与取欲邪行贪欲亦尔问贪欲等云何用贪等为方便。答前说贪欲业道于他资财决定执为己有为性。若即于此资财先起余贪。加行追求欲为己有。即立此为贪方便。若先起嗔余勿有。此是嗔方便。若先起痴。谓于他物取为己有无有过失。是痴方便。如是所余如理应知。虚诳语业道贪嗔痴为方便。于三种中随由一究竟。如妄语离间语绮语亦尔。邪见业道贪嗔痴为方便。由痴究竟

复次如经言有共业。有不共业。有强力业有劣力业。云何共业。若业能令诸器世间种种差别。云何不共业。若业能令有情世间种种差别。或复有业。令诸有情展转增上。由此业力说诸有情更互相望为增上缘。以彼互有增上力故。亦名共业。由此势力诸有情类展转互为诸心心法变异生因。是故经言。如是有情与余有情互相见等。而不受用不易可得。云何强力业。谓对治力强补特伽罗故。思所造诸不善业。由对治力所摄伏故。令当受那落迦业转成现法受。应现法受业转令不受。所以此业名强力者。由能对治业力强故。此能治业望所治业其力强胜。令彼所感诸苦异熟转变灭故。又故思所造一切善业望不善业。对治力强皆名强力。依此业故薄伽梵说。我圣弟子能以无量广大之业善熏其心。诸所造作有量之业。此业不能牵引不能留住。亦不能令堕在彼数。又对治力劣补特伽罗。故思所造诸不善业望诸善业皆名强力。又故思造业异熟决定。不断不知名强力业。此中意说。一切善不善业无有差别。但异熟决定。诸圣道力所不断者。皆名强力业。又欲界系诸不善业性皆是强。众多烦恼随烦恼等为助伴故。又先所串习名强力业。以数熏习于相续故又依强位名强力业。由处盛年所造诸业猛利执着净信所发故。又不可治者。所造诸业。名强力业。由无涅槃法者所有诸业。非对治力所能伏故。又由田故发强力业。谓害母等业。又由心加行故发强力业。谓于无上菩提发强大愿等。此所生业其力猛盛名强力业。复次由九种因发强力业。谓田故事故自体故所依故作意故意乐故助伴故多修习故与多众生共所行故。由此九因发强力业田者。谓具大功德堪为福田。事者。谓所施物多而精妙。自体者。谓戒胜于施修胜于戒如是等。所依者。谓已离欲者作诸福业。作意者。谓猛利净信俱行作意意乐者。谓希求涅槃所有意乐助伴者。谓更广修习余福业事共相摄受。多修习者。谓数数修习或数数寻思。与多众生共所行者。谓自作教他见作随喜。与此相违是劣力业

如世尊说。若有说言。彼彼丈夫补特伽罗。随如是如是业若作若增长还受如是如是异熟。若有是事便不应修清净梵行。亦不可知正尽诸苦作苦边际。若有说言。彼彼丈夫补特伽罗。随如是如是顺所受业若作若增长。还受如是如是顺所受异熟。若有是事便应修习清净梵行。又亦可知正尽诸苦作苦边际。如是经言有何密意。此中佛意为欲遮止如是邪说。谓乐俱行业还能感得乐俱行异熟。苦俱行业还能感得苦俱行异熟。不苦不乐俱行业还能感得不苦不乐俱行异熟。故作是说。若有说言。彼彼丈夫补特伽罗。随如是如是业若作若增长。还受如是如是异熟。若有是事便不应修清净梵行。亦不可知正尽诸苦作苦边际。何故便不应修清净梵行。以诸烦恼极猛利者要由智慧自励自策。与忧苦俱护持禁戒。若于当来受彼异熟时。还与忧苦俱者护持禁戒应无义利。又于他妻等与喜乐俱毁犯禁戒。若于当来受彼异熟时。还与喜乐俱者精勤远离即为唐捐。是故说言。若有是事便不应修清净梵行。何故亦不可知正尽诸苦作苦边际即由如是修习梵行招苦异熟故。是故世尊为遮如是外道邪说。乐俱行业还受乐异熟。苦俱行业还受苦异熟。不苦不乐俱行业还受不苦不乐异熟。异熟因异熟果决定相似故说是经。又为开许如是正说。谓乐俱行业。顺乐受者还受乐异熟顺苦受者还受苦异熟。顺不苦不乐受者还受不苦不乐异熟。苦俱行业。顺乐受者还受乐异熟。顺苦受者还受苦异熟。顺不苦不乐受者还受不苦不乐异熟。不苦不乐受俱行业。顺乐受者还受乐异熟。顺苦受者还受苦异熟。顺不苦不乐受者还受不苦不乐异熟。乐俱行业有二种。谓善不善。随其所应顺当来世苦受乐受不苦不乐受。还能感得乐等异熟。如是苦俱行业。不苦不乐俱行业。各有二种。随顺乐等感乐等异熟。随其所应。如是名为此经密意

大乘阿毗达磨杂集论卷第七大乘阿毗达磨杂集论卷第八

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    决择分中谛品第一之三

复次业差别有三种。谓律仪业。不律仪业。非律仪非不律仪业。律仪业复有三种。谓别解脱律仪所摄。静虑律仪所摄。无漏律仪所摄。别解脱律仪所摄业者。即是七众所受律仪。谓比丘律仪比丘尼律仪。式叉摩那律仪。沙弥律仪。沙弥尼律仪。邬波索迦律仪。邬波斯迦律仪。及近住律仪。依止何等补特伽罗建立出家律仪。依能修行远离恶行远离欲行。由比丘等出家五众。乃能尽寿远离杀生等恶行。及能远离非梵行故。依止何等补特伽罗建立邬波索迦律仪邬波斯迦律仪。依能尽寿远离恶行不远离欲行。由彼二众建立尽寿离欲邪行。非离非梵行故。依止何等补特伽罗建立近住律仪。依止不能远离恶行。及不远离欲行。是故为彼但制日夜近住律仪。为令渐渐俱修学故。问若唯修学邬波索迦一分学处。为说成就邬波索迦律仪。为说不成就耶。答应说成就而名犯戒。问扇搋半择迦等为遮彼受邬波索迦律仪不耶。答不遮彼受邬波索迦律仪。然遮彼邬波索迦性。不堪亲近承事比丘比丘尼等二出家众故。如扇搋半择迦。不堪亲近承事比丘比丘尼等二出家众故。遮彼邬波索迦性。二形亦尔。男女烦恼恒俱现行。不堪亲近承事二众故不别说。又半择迦有五种。谓生便半择迦。嫉妒半择迦。半月半择迦。灌洒半择迦。除去半择迦

静虑律仪所摄业者。谓能损伏发起犯戒烦恼种子。离欲界欲者所有远离。离初二三静虑欲者所有远离。是名静虑律仪所摄身语业。性发起犯戒烦恼者。谓贪嗔等欲界所系烦恼随烦恼。能损伏彼种子者。谓由伏对治力损彼种子。离欲界欲者。谓由伏对治力。或少分离欲或全分离欲。所有远离者。谓从彼犯戒所得远离性。离初二三静虑欲者。谓由远分对治力。令彼发起犯戒烦恼所有种子转更衰损。所以不说离第四静虑欲者。由无色界粗色无故。略不建立色戒律仪

无漏律仪所摄业者。谓已见谛者由无漏作意力所得无漏远离戒性

不律仪业者。谓诸不律仪者。或由生彼种姓中故。或由受持彼事业故。所期现行彼业决定。何等名为不律仪者。所谓屠羊养鸡养猪捕鸟捕鱼猎鹿罝兔。劫盗魁脍害牛缚象。立坛咒龙守狱谗构好为损等。屠羊者。为欲活命屠养买卖。如是养鸡猪等随其所应。缚象者恒处山林调执野象。立坛咒龙者。习咒龙蛇戏乐自活。谗构者。以离间语毁坏他亲持用活命。或由生彼种姓中或由受持彼事业者。谓即生彼家若生余家。如其次第。所期现行彼业决定者。谓身语方便为先决定要期现行。彼业是名不律仪业

非律仪非不律仪业者。谓住非律仪非不律仪者所有善不善业。若布施爱语等业。若殴击等业。律仪不律仪所不摄故。名非律仪非不律仪

又业差别有三种。谓顺乐受业。顺苦受业。顺不苦不乐受业。顺乐受业者。谓从欲界乃至第三静虑所有善业。顺苦受业者。谓不善业。顺不苦不乐受业者。谓第四静虑已上所有善业等

复次业差别有三种。谓顺现法受业。顺生受业。顺后受业。顺现法受业者。若业于现法中异熟成熟。谓从慈定起已。于彼造作若损若益必得现异熟。如从慈定起。从无诤定灭尽定预流果阿罗汉果起亦尔。又于佛为上首僧中。造善恶业必得现异熟又有余猛利意乐方便。所行善不善业亦得现异熟所以名为现法受业。若业于此生作即于此生熟故。顺生受业者。若业于无间生中异熟成熟。无间生者即次此生。谓五无间业等能得生异熟问若造一无间者。于无间生中可受其异熟若造多无间业者。于无间生中云何得受其异熟。答于一生中顿受一切所得异熟无有过失。所以者何。若造众多无间业者。所感身形最极柔软。所感苦具众多猛利。由此顿受种种大苦。复有所余善不善业。于无间生异熟熟者。一切皆名顺生受业。顺后受业者。若业于无间生后异熟成熟。于此业中从初熟位建立顺现法受等名。不唯受此一位异熟。若业于此生造即从此生已去异熟成熟。说名顺现法受业。若业于此生造从无间生已去异熟成熟。说名顺生受业若业于此生造度无间生已去异熟成熟。说名顺后受业若作是说即为善顺诃怨心经。如彼经言。由无间业于那落迦中数数死生受大苦异熟。复次有四种诸业差别。谓黑黑异熟业。白白异熟业。黑白黑白异熟业。非黑白无异熟业能尽诸业。黑黑异熟业者。谓不善业。由染污故。不可爱异熟故。白白异熟业者。谓三界善业。不染污故。可爱异熟故。黑白黑白异熟业者。谓欲界系杂业。善不善杂故。云何一业亦善不善。此中不约生刹那相说一种业亦善不善。然约意乐及方便总说一业。是此经意约此二种。若黑若白互不相似。建立一种黑白业故。或有业意乐故黑。方便故白。或有业方便故黑。意乐故白。意乐故黑。方便故白者。犹如有一。为欲诳他先现其相。令信己故行于惠施。乃至出家方便故黑。意乐故白者。犹如有一。欲令子及门徒远危处安。由怜愍心现发种种身语粗恶。遂于此时发生杂染非黑白无异熟业。能尽诸业者。谓于方便无间道中诸无漏业。以方便无间道是彼诸业断对治故。非黑者离烦恼垢故。白者一向清净故。无异熟者生死相违故。能尽诸业者。由无漏业力永拔黑等三有漏业与异熟习气故

复次总约一切无漏业无有差别所有障碍随顺体性。如其次第建立曲秽浊等诸染污业。净牟尼等诸清净业。曲业者。若身语意业能障正直八圣道支令不生长。秽业者。若身等业能污相续。依此发生如是障业。浊业者。若身等业依止外道颠倒见生。一切如来清净圣教之所对治不信。混浊之所摄故。复有差别堕在断常。边违处中行义名曲。损减见所摄增恶清净所立法义名秽。萨迦耶见所摄。障真无我见义名浊。净业者。与如是等诸杂染业相违类解。三净业者。谓善净尸罗。正直见所摄。身语意业远离毁犯戒见垢故。三牟尼业者。谓学无学所有无漏身语意业。唯诸牟尼有此业故。又有施等诸清净业。施业云何。谓因缘故等起故处所故自体故。分别施业因缘者。谓无贪无嗔无痴善根。等起者。谓彼俱行思。处所者。谓所施物。自体者。谓正行施时身语意业。云何施圆满。谓数数施故无偏党施故。随其所欲圆满施故。施得圆满。依此义故经作是说。为大施主者。此显数数施义。由彼串习成性数数能施故。一切沙门婆罗门等者。此显无偏党施义。无有差别一切施故。若食若饮等者。此显随其所欲圆满施义如所意愿一切资财皆施与故复次无所依施故。广清净施故极欢喜施故。数数施故。田器施故。善分布新旧施故施。得圆满。依此义故经作是说。解脱舍舒手施乐。远离常祠祀舍具足。于正施时乐等分布。如是诸句随其次第。显示无所依施等。无所依施者。谓不回向有及资财而行惠施。田器者。谓贫苦田功德田。舒手者。广行惠施手不潜缩故。常祠祀者。串习祠祀以成性故。舍具足者。慧为先故。于正施时乐等分布者。于来求者以所施物等分布故。云何应知施物圆满。谓所施财物非诳诈得故。所施财物非侵他得故。所施财物非秽离垢故。所施财物清净故。所施财物如法所引故。是名施物圆满。依此义故经作是说发起正勤所得。财物者此显施物非。诳诈得诳诈得者谓不起正勤。而得财物于自住处他所寄物。谋诈得故运手臂力所得财物者。此显施物非侵他得。侵他得者。非自运动手力而得。他所勤。苦种种方便获得财物。侵陵取故离污垢物者。此显施物非秽离垢。由所施物远离污垢染污故。如法财者。此显施物清净。远离刀毒酒等非净施物。故如法所得者。此显施物如法所引。远离伪斗称等邪命财故

复次如经中说。成就尸罗善能防护别解脱律仪。轨则所行皆悉圆满。见微细罪生大怖畏。于诸学处善能受学。云何成就尸罗。能受能护净尸罗故。谓受持净戒相应无缺。故名成就尸罗。云何善能防护别解脱律仪。能善护持出离尸罗故。谓为求解脱别别防护所有律仪。故名别解脱律仪。由此律仪能速出离生死苦故。云何轨则所行皆悉圆满。具净尸罗难为毁责故。轨则圆满者。诸威仪等。非聪慧人所呵责故。所行圆满者。远离五种诸比丘众所不行处故。何等为五。谓唱令家。淫女家。酤酒家。王家。旃荼罗羯耻那家。云何见微细罪生大怖畏。勇猛恭敬所学尸罗故。于遮罪中勇猛恭敬。修学护持犹如性罪。是故名为见微细罪生大怖畏。云何于诸学处善能受学。圆满受学所学尸罗故。谓具足圆满受学学处。是故名为于诸学处善能受学。从是已后依止尸罗。释佛经中护身等义。云何名为防护身语。由彼正解所摄持故。谓如佛所听。往来等事必先觉察方正行故。云何身语具足圆满。终不毁犯所毁犯故。谓不违损清净尸罗。云何身语清净现行。由无悔等渐次修行久至得定为依止故。谓依定力令犯戒垢极远离故。云何身语极善现行。染污寻思所不杂故。谓染污寻思所不能杂。一向净故。云何身语无罪现行。远离邪愿修梵行故。谓不回向有及资财修行梵行。为诸圣贤所称赞故。云何身语无害现行。不轻陵他易共住故。谓不由自高陵蔑于人。难共住等为损害故。云何身语随顺现行。由能随顺涅槃得故。谓能随顺得涅槃得能引圣道故。云何身语随隐显现行。隐善显恶故。谓隐自功德显自过失。云何身语亲善现行。同梵行者摄受尸罗故谓同梵行摄受尸罗应归趣故。云何身语应仪现行。于尊尊位离憍慢故。谓于尊长及等尊长所。摧伏憍慢如应供事故。云何身语敬顺现行。于尊教诲敬顺受故。谓于尊语言敬顺而受。离自见取故。云何身语无热现行。远离苦行热恼下劣欲解故。谓离外道下劣欲解行诸苦行。不自烧然故。云何身语不恼现行。弃舍财业无悔恼故。谓由弃舍财业无有追悔。彼于后时无热恼故。云何身语无悔现行。虽得少分不以为喜。无悔恨故。谓修善品虽获少分不生喜足。离诸悔恨尽其所能而修习故。如世尊说。如是有情皆由自业。业所乖诤。从业所生。依业出离。业能分判一切有情高下胜劣。云何有情皆由自业。由自造业而受异熟故。谓诸有情由其自业故名自业。自者不与他共。受自业异熟故名自业。云何业所乖诤于受自业所得异熟时。善不善业互违诤故。谓诸有情由业乖诤故。名业所乖诤。随善恶业力自所受异熟爱不爱别故。问是诸有情受自作业爱不爱异熟时。初从何生。为无因耶。为因世性自在等耶。答从业所生。云何从业所生。是诸有情远离无因恶因。唯从业所生故。谓诸有情远离无因恶因。唯由业等因缘所生。如是已说依业流转。为明归灭亦依诸业。是故经言。依业出离。云何依业出离。依对治业解业缚故。谓依无漏业能断有漏业故。唯依业而得出离。云何有情高下。谓由业故。于善恶趣得自体差别。云何胜劣。谓诸有情成就功德过失差别。如世尊说。有情业异熟不可思议。如是经意非一切种皆不可思议。云何业异熟不可思议。云何可思议。谓诸善业于人天趣得可爱异熟。是可思议。诸不善业堕三恶趣得不爱异熟。是可思议。由善恶业往善恶趣。感得可爱不可爱异熟。世间智者能思议故。由此能引发正见等功德故。即由此业感诸有情自身异熟等种种差别不可思议。谓内身等异熟有形色等。无量差别难可思议。除一切智不能思议。强思议者发狂等过故

复次即善不善业处差别。事差别。因差别。异熟差别品类差别等。皆不可思议。由即此业处差别等。无量无边难可思议故处者。谓住如是处造如是业。或于城邑或于村落如是等。事者。谓所依事。或有情数或非有情数。因者。谓善不善根如其所应。异熟者。谓异熟内身。品类者。谓种种差别无量品类。又有种种外事差别。能感业用不可思议。由何等业感棘刺等锋铓铦利。如是等类。堕在世间。不思议摄。思议世间佛所制故。又末尼珠药草咒术相应业用不可思议。末尼相应业者。谓月爱珠等能出水等业用难思。药相应业者。谓执持此药藏隐形等。咒相应业者。谓诵此咒便不烧等。术相应业者。谓由彼彼术故治热病等。又诸观行者威德业用不可思议。云何彼心威德力故。能动大地升虚空等。又诸菩萨自在业用不可思议。所谓命自在故。心自在故。财自在故。业自在故生自在故。胜解自在故。愿自在故。神通自在故。智自在故。法自在故。诸大菩萨由如是等自在。力故所作业用不可思议。谓诸菩萨。由命自在力持诸寿行。随所欲乐尔所时住。由心自在力随其所乐。于三摩地入出自在。由胜解自在力转大地等为水火等。胜解自在。由愿自在力随其所乐。能引无数自利利他圆满大愿。由神通自在力为欲摄化无量有情。显示种种神通变现。由智自在力于诸法义训释言词。无滞辩说圆满究竟。由法自在力以无量种名句文身。建立素怛缆等无上教法随其所应。乃至一切有情于一时间能令彼心皆大欢喜。又一切佛所作诸佛应所作事。业用不可思议。云何如来到于究竟无功用处。证得清净一味法界。诸佛世尊之所应作。利益安乐诸有情事。随时如应皆能成立。如是诸佛及佛境界不可思议

复次如是集谛总有四种行相。所谓因相集相生相缘相。因相云何。谓能引发后有习气因。是名因相。由业烦恼是能引发后有习气因故。集相云何。谓彼彼有情所集习气。于彼彼有情类为等起因。是名集相。由诸有情所集习气。于人天等有情类中。能为相似形貌种类。平等起因故。生相云何。谓各别内身无量品类差别生因。是名生相。是诸有情各别内身。相续决定趣生地等。所有一切品类差别。乃至有顶生因故。缘相云何。谓诸有情别别得舍因。是名缘相。能令有情得未曾得。自体舍已。曾得自体故。如是名为集谛体相

云何灭谛。谓由相故甚深故世俗故胜义故不圆满故圆满故无庄严故有庄严故有余故无余故最胜故差别故。分别灭谛

相者。谓真如圣道烦恼不生。若灭依若能灭若灭性。是灭谛相。如世尊说。眼耳及与鼻舌身及与意。于此处名色究竟灭无余。又说是故汝今当观是处。所谓此处眼究竟灭远离色想。乃至意究竟灭远离法想。由此道理显示所缘。真如境上有漏法灭。是灭谛相

甚深者。谓彼诸行究竟寂灭。如是寂灭望彼诸行。不可说异不异亦异亦不异非异非不异。所以者何。若彼诸行究竟寂灭。如是寂灭与彼诸行可说异者。应与诸行不相系属条然异体。若不异者应是染相。由此道理非俱非不俱。何以故。无戏论故。于此义中若生戏论非正思议。非道非如亦非善巧方便思故。如世尊说。此六触处尽离欲灭寂静没等。若谓有异无异亦有异亦无异非有异非无异者。于无戏论便生戏论。乃至有六处可有诸戏论。六处既灭绝诸戏论。即是涅槃。若于如是绝诸戏论寂灭涅槃。不正思议是名戏论。于应异思议乃异思议故。云何应异思议。谓正妙离等种种思议

世俗者。谓以世间道摧伏种子所得灭。是故世尊别名说为彼分涅槃

胜义者。谓以圣慧永拔种子所得灭

不圆满者。谓诸有学或预流果摄。或一来果摄。或不还果摄等所有灭

圆满者。谓诸无学阿罗汉果摄等所有灭。无庄严者。谓慧解脱阿罗汉所有灭。无三明等最胜功德所庄严故

有庄严者。谓俱分解脱三明六通阿罗汉等所有灭。有无量种种量胜功德所庄严故

有余者。谓有余事灭

无余者。谓无余事灭

最胜者。谓佛菩萨无住涅槃摄所有灭。以常安住一切有情利乐事故

差别者。谓无余永断永出永吐尽离欲灭寂静没等。何故名无余永断。由余句故。谓无余永断是标句。余是释句。是故说言。由余句故。由后别句释此总故。缠及随眠皆悉永断故。名无余永断。何故名永出。永出诸缠故。此依断诸缠说。谓已生者皆远离故。何故名永吐。永吐随眠故。此依断随眠说。谓除根本永不生故。如是诸灭由见修道对治别故。建立二种。尽及离欲故。次问言。何故名尽。见道对治得离系故。烦恼聚中余少分故。亦名为尽。何故名离欲。修道对治得离系故。由彼修道离诸地欲渐次所显。故名离欲。由有如是俱离系故。当来苦灭故。次问言。何故名灭。当来彼果苦不生故。能成未来苦不生法。故名为灭。又于现法忧恼寂静故。次问言。何故名寂静。于现法中彼果心苦永不行故。何故名没。余所有事永灭没故。宿业烦恼所感诸蕴自然灭尽。故名为没。由如是等别句释前无余永灭总句。何故此灭复名无为。离三相故。生灭住异三有为相究竟相违。故名无为。何故此灭复名难见。超过肉眼天眼境故。唯圣慧眼所行境界。故名难见。何故此灭复名不转。永离诸趣差别转故。离地狱等往来流转恒常安住。故名不转。何故此灭名不卑屈。离三爱故。永离欲色无色三爱。于诸有中无所卑屈。故名不卑屈。何故此灭复名甘露。离蕴魔故。永离一切死所依蕴。故名甘露。何故此灭复名无漏。永离一切烦恼魔故。何故此灭复名舍宅。无罪喜乐所依事故。解脱喜乐所依止故名舍宅。何故此灭复名洲渚。三界隔绝故。于生死大海挺出高原。故譬洲渚。何故此灭复名弘济。能遮一切大苦灾横故。证得此灭生老病等诸苦灾横永远离故。何故此灭复名归依。无有虚妄意乐方便所依处故。由于彼灭所发意乐及正方便无虚妄性所依处故。所依止义是归依义。何故此灭名胜归趣。能为归趣一切最胜圣性所依处。故由此寂灭能为归趣最胜圣性所依止处。是阿罗汉证得方便所缘境故。何故此灭复名不死。永离生故。诸无生者必不死故。何故此灭名无热恼。永离一切烦恼热故。永离一切求不得苦大热恼故。何故此灭名无炽然。永离一切愁叹忧苦诸恼乱故。一切愁等炽然永息极清凉故。名无炽然。何故此灭复名安隐。离怖畏住所依处故。无老病死等一切怖畏。圣住所依故名安隐。何故此灭复名清凉。诸利益事所依处故。一切清凉善法所依。故名清凉。何故此灭复名乐事。第一义乐事故。出世间乐所依事故名乐事。何故此灭名趣吉祥。为证得彼易修方便所依处故。为证涅槃易修方便所缘境故。何故此灭复名无病。永离一切障碍病故。离烦恼等诸障碍病故名无病。何故此灭复名不动。永离一切散动故。离诸境界戏论散动故名不动。何故此灭复名涅槃无相。寂灭大安乐住所依处故。永离一切色等诸想。究竟寂灭大安乐住所缘境故。名为涅槃

复次依灭谛辩无生等名义差别。与苦谛相义相违故。苦谛相者于彼彼处有情类中相续而生。为翻彼相。是故问言。何故此灭复名无生。离相续故。苦谛相者续生已后自身众分渐次圆满。为翻彼相。是故问言。何故此灭复名无起。永离此后渐生起故。苦谛相者宿业烦恼势力所造。为翻彼相。是故问言。何故此灭复名无造永离前际诸业烦恼势力所引故。又现在苦是能造作。余有异熟诸业烦恼所依止处。为翻彼相。是故问言。何故此灭复名无作。不作现在诸业烦恼所依处故。又苦相者后有异熟相续生起无有间断。为翻彼相。是故问言。何故此灭复名不生。永离未来相续生故

复次灭谛有四种相。谓灭相静相妙相离相。何故名灭相。烦恼离系故。谓流转因烦恼离系故名灭。何故名静相。苦离系故。行苦所摄。不寂静相取蕴离系故名静。何故名妙相。乐净事故。诸烦恼苦究竟离系。自然乐净以为自体故名妙。何故名离相。常利益事故。不复退还最极安隐。如其次第名常利益安隐利益。最胜善性是灭谛相

云何道谛。谓由此道故知苦断集证灭修道。是略说道谛相。今于此中依四圣谛以其作用显道体相

又道有五种。谓资粮道方便道见道修道究竟道。如是五种依道自性及眷属。以显道谛差别

资粮道者。谓诸异生所有尸罗。守护。根门饮食知量初夜后夜常不睡眠勤修止观正知而住。复有所余进习诸善。闻思修所生慧修习此故。得成现观解脱所依器性。谓诸异生所有尸罗。乃至正知而住等。是资粮道体。由彼修习净尸罗等极圆满故。复有所余进习诸善者。谓无悔等由闻思等所生诸慧得成暖等。次第见谛永断诸障。相续堪任性

方便道者。谓所有资粮皆是方便。或有方便非资粮。谓已积集资粮道者。所有顺决择分善根。谓暖法顶法顺谛忍法世第一法。暖法者。谓各别内证于诸谛中明得三摩地钵罗若。及彼相应等法。由净定心依谛增上契经等法。于意言门诸义显现。缘彼所生奢摩他毗钵舍那等。是名暖法顶法者。谓各别内证于诸谛中明增三摩地钵罗若。及如相应等法。由彼顶法展转增进居上位故。顺谛忍法者。谓各别内证于诸谛中一分已入随顺三摩地钵罗若。及彼相应等法。一分已入者。于无所取一向忍解故。一分随顺者。于无能取随顺通达。所依处故。世第一法者。谓各别内证于诸谛中无间心三摩地钵罗若。及彼相应等法。从此无间必起最初出世道故

大乘阿毗达磨杂集论卷第八大乘阿毗达磨杂集论卷第九

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    决择分中谛品第一之四

云何见道若总说。谓世第一法无间。无所得三摩地钵罗若。及彼相应等法。由无分别奢摩他毗钵舍那等为体相故

又所缘能缘平等平等智为其相。由此通达所取能取无性真如故

又遣各别有情假法假。遍遣二假所缘法智为相。云何遣各别有情假所缘法智为相。由此智于自相续中不分别我相故。不分别者。是除遣义。云何遣各别法假所缘法智为相。由此智于自相续中不分别色等法相故。云何遍遣二假所缘法智为相。由此智于一切处无有差别不分别我及法相故

复次若别说见道差别。谓世第一法无间。苦法智忍苦法智。苦类智忍苦类智。集法智忍集法智。集类智忍集类智。灭法智忍灭法智。灭类智忍灭类智。道法智忍道法智。道类智忍道类智。如是十六种。于诸圣谛中法类智忍及法类智。是见道差别相。苦者。谓苦谛。苦法者。谓苦谛增上所起教法。法智者。谓于方便道中观察谛增上法智。智忍者。谓先观察增上力故。于各别苦谛中起现证无漏慧。由此慧故永舍见苦所断一切烦恼。今于此中所说义者。谓于方便道中观察依止苦谛所起契经等法。如理作意所摄智增上力故。于自相续苦谛中现证彼真如。出世间慧正见体生。由此慧故永舍一切见苦所断三界所系二十八随眠。是故名为苦法智忍

苦法智者。谓忍无间。由此智故于前所断烦恼解脱而得作证。所以者何。先由忍故永断一切见苦所断烦恼。令所依转从此无间。由如是智生证得转依。是名苦法智

苦类智忍者。谓苦法智无间无漏慧生。于苦法智忍及苦法智各别内证。言后诸圣法皆是此种类。所以者何。由初二种若忍若智。是后一切学与无学圣法种类。从此彼得生故。是故无漏慧生各别内证缘此为境。言后诸圣法皆是此种类。是故名为苦类智忍

苦类智者。谓此无间无漏智生。审定印可苦类智忍。所以者何。由苦类智忍无间无漏智生。于苦类智忍内证印可。故名苦类智

如是于余谛中随其所应。诸忍诸智尽当知。于此位中由法忍法智觉悟所取。由类忍类智觉悟能取。所以者何。出世间道有二境界。谓真如及正智。法智品道真如为境。类智品道正智为境。由此诸忍智如实了知故。又于此一切忍智位中。说名安住无相观者。如薄伽梵说第六无相住补特伽罗者。即现住此忍智位中者是也。于此位中一切相皆不可得故。又无相住有六种。谓空无相无愿灭定有顶见道。如是十六心刹那说名见道。所以者何。由如是忍智所摄十六心刹那。于曾所未见四圣谛境。各以四刹那见故。名为见道。又心刹那者。谓于所知境智生究竟名一刹那。非唯于本无今有生时名心刹那。何以故。乃至于所知境能知智生所作究竟名一刹那故。如说苦应遍知是一心刹那。如是集应永断等亦尔。又如上说。见道差别皆假建立非真实尔。何以故。出世位中各别内证绝戏论故

复次一切道谛由四种相应随觉了。谓安立故思惟故证受故圆满故。安立者。谓声闻等随自所证已得究竟。为欲令他亦了知故。由后得智以无量种名句文身安立道谛。谓于诸谛中有如是如是忍如是如是智。如是等。思惟者。谓正修习现观方便。以世间智如所安立思惟数习。证受者。谓如是数习已。自内证受最初见道。正出世间无戏论位。圆满者。谓此位后圆满转依乃至证得究竟。彼既证得究竟位已。复由后得智以名句文身安立道谛。如是四相真实道轮数数展转。相依而转无有断绝。如经言远尘离垢于诸法中正法眼生者。此依见道说。诸法忍能远尘。诸法智能离垢。由彼最初于诸谛中妙圣慧眼为自性故。法忍能远尘者。由诸法忍永断一切烦恼尘故。法智能离垢者。由诸法智已断障垢依得生故。又于此忍智两位如其次第。遍智故永断故道得清净。依此而说远尘离垢。又经言。见法得法极通达法究竟坚法。越度一切希望疑惑。不假他缘。于大师教余不能引。于诸法中得无所畏者。此亦依见道说。于所化有情圣谛现观无间说故。见法者。谓诸法忍。由彼通达真实法故。得法者。谓诸法智。彼于转依能作证故。极通达法者。谓诸类忍。通达诸圣法。是此二类故。究竟坚法者。谓诸类智。于诸所知已究竟故。越度一切希望者。由诸忍智出世间道。证得长夜所希圣果。于自所证无希虑故。越度一切疑惑者。于此位中于他所证无有犹豫。谓余亦能证此胜位故。不假他缘者。于所修道中虽无他导引自然善巧故。于大师教余不能引者。于佛圣教已得证净。虽转余生不为邪道所化引故。于诸法中得无所畏者。于依所证问记法中。如恶欲增上慢者怯劣心永无有故

云何修道。谓见道上所有世间道出世间道软道中道上道方便道无间道解脱道胜进道等。皆名修道。所以者何。诸佛圣弟子已得谛现观。从此已上为断余结方便数习世间道等。是名修道

世间道者。谓世间初静虑第二静虑第三静虑第四静虑。空无边处识无边处无所有处非想非非想处。如是静虑无色。由四种相应广分别。谓杂染故清白故建立故清净故

杂染者。谓四无记根。一爱二见三慢四无明。由此四惑染污其心。于诸染污静虑定门令色无色界一切有覆无记。烦恼随烦恼生长不绝。所以者何。由有爱故味上静虑杂染所染。贪味净定轻安乐故。由有见故见上静虑杂染所染。依止静虑发起计度先际等见故。由有慢故慢上静虑杂染所染。依证胜定起高慢故。由无明故疑上静虑杂染所染。求解脱者由未通达真实道理。于胜品所证常生疑惑。为解脱耶不解脱耶。如是烦恼恒染其心。令色无色大小二惑相续流转

清白者。谓净静虑无色。由性善故说名清白。虽是世间离缠垢故亦名为净

建立者。有四种建立。谓支分建立。等至建立。品类建立。名想建立。于诸静虑具四建立。诸无色中唯有。三种除支分

支分建立者。谓初静虑有五支。何等为五。一寻二伺三喜四乐五心一境性。第二静虑有四支。何等为四。一内等净二喜三乐四心一境性。第三静虑有五支。何等为五。一舍二念三正智四乐五心一境性。第四静虑有四支。何等为四。一舍清净二念清净三不苦不乐受四心一境性。问法有无量。何故唯立寻等为支。答对治支故。利益支故。彼二所依自性支故。由此三种支分满足不待余故。初静虑中寻伺二种是对治支。能断欲界欲恚害等寻伺故。喜乐二种是利益支。由寻伺支治所治已得离生喜乐故。心一境性是彼二所依自性支。依止定力寻等转故。第二静虑中内等净是对治支。由此能治寻伺故。喜乐是利益支。心一境性是彼二所依。自性支义如前说。第三静虑中舍念正知是对治支。由此三能治喜故。乐是利益支。心一境性是彼二所依。自性支义如前说。第四静虑中舍清净念清净是对治支。由此二能治乐故。不苦不乐受是利益支。心一境性是彼二所依。自性支诸无色中不立支分。以奢摩他一味性故

云何等至建立者。谓由七种作意证入初静虑。如是乃至非想非非想处。何等名为七种作意。谓了相作意。胜解作意。远离作意。摄乐作意。观察作意。方便究竟作意。方便究竟。果作意。此广分别如声闻地后瑜伽处。云何证入初静虑时由七作意。谓由定地作意见欲界中过患等故。了达粗相。初静虑中此相无故名为静相。是名了相作意。如是作意犹为闻思之所间杂。从此已上超越闻思。一向修相缘粗静相以为境界。修奢摩他毗钵舍那。数数思惟如所寻思粗静性相。是名胜解作意。由修习此故。最初断道生彼俱行作意。名远离作意。由此能断上品烦恼故。及能远离彼品粗重故。此观行者复欣乐上断见上断功德。已触少分远离喜乐。为欲除去惛沉睡眠。时时修习净妙作意以悦其心。是名摄乐作意。如是正修行者方便善品所资持故。令欲界系烦恼缠垢不复现行。因此为欲审察烦恼断与未断。复更作意观察彼生随顺净相。是名观察作意。如是行者数数观察进修对治。为令欲界一切烦恼于暂时间得离系故。此对治道相应作意。是初静虑最后方便故。名方便究竟作意。从此无间证得根本最初静虑俱行作意。是名方便究竟果作意。又由了相作意发希愿心。为正了知所应断所应得。为断故为得故。由胜解作意为所求义发正方便。由远离作意舍上品惑。由摄乐作意舍中品惑。由观察作意安心于所证远离增上慢。由方便究竟。作意舍下品惑由方便究竟果作意领彼所修作意修果。如为证入初静虑定修七作意。如是乃至为证入非想非非想处定。如应当知又粗相者。谓于一切下地从欲界乃至无所有处。如是粗相略有二种。一住于重苦。不寂静住故。二命行微少。寿命短促故。静相者。谓于一切上地从初静虑乃至非想非非想处。与粗相相违故

品类建立者。于初静虑定具三品熏修。谓软中上。如初静虑余静虑及无色三品熏修亦尔。由软中上品熏修初静虑故。于初静虑中还生三异熟。如初静虑于余静虑中若熏修若生果各三品亦尔。诸静虑中三品熏修生三果者。谓梵众天梵辅天大梵天。如是等广说如前。于无色界中无别处所故。不立生果差别。所以者何于无色界无有安堵宫殿等处故。不建立生果差别。然由三品熏修无色定故。彼异熟生时有高有下有劣有胜。彼异熟生时有高有下者。由寿命等有差别故。有劣胜者。染污不染污多分少分有差别故

名想。建立者谓于四静虑中三摩地差别无量名字不可算数不可思议。何以故。于初静虑所摄定中诸佛世尊及得究竟大威德菩萨摩诃萨所入三摩地。彼三摩地一切声闻及独觉等尚不了其名。岂能知数。况复证入如般若波罗蜜多经中说。三摩地其数过百。如是于余大乘经中说。三摩地其数无量。如于初静虑所摄定。于余静虑无色所摄定亦尔。如是所说皆依静虑波罗蜜多

清净者。谓初静虑中边际定。乃至非想非非想处边际定。是名清净静虑无色边际定者。为欲引发胜品功德得自在等。修堪任定到究竟处故

出世间道者。谓于修道中法智类智品所摄苦智集智灭智道智。如是八智相于见道中已广说。及彼相应三摩地等。或未至定所摄。或初静虑乃至无所有处所摄。非想非非想处唯是世间。不明了想恒现行故。由不明了想恒现在前。非极明了现行圣道之所依止。是故一向世间所摄。由此道理彼想羸劣不能猛利。取所缘相故名无相。复云何知非想非非想处无有圣道。由世尊说。乃至有想三摩钵底。方能如实照了。通达灭尽三摩钵底。是出世间。由圣道后所证得故。要于人趣方能引发。言引发者是初起义。或于人趣或于色界能现在前。先已生起后重现前故。或于人趣者谓即于此生。或于色界者。谓后生彼。云何圣弟子已得无色定已离色界。欲复生色界耶。不必永离色界。欲方入无色定。是故此中应作四句。若已离色界欲者。一切皆能入无色界寂静解脱定耶。设能入无色界寂静解脱定者。一切已离色界欲耶。答此初句者。谓依未至定已离色界欲。而不能得入无色界寂静解脱定。第二句者。谓诸圣者已得第四静虑。不求生无色界而起厌背。第四静虑行恒现在前。舍断结道依胜进道。渐次能入无色界寂静解脱定。第三句者。谓即此行者勤求离欲依断结道。渐次能入无色界寂静解脱定。第四句者。谓除上尔所相。问无色界中何故灭定不起现前。答生无色界此灭尽定多分不起现前。由住寂静解脱异熟者于此灭定多不发起勤方便故。所以者何。诸圣弟子为欲安住寂静住故。于人趣等引此灭定令现在前。若已生无色界者。不由功用自然安住第一寂静解脱异熟住不复发起方便功用求此灭定令现在前

软道者。谓软软软中软上品道。由此道故。能舍三界所系地地中上上上中上下三品烦恼。中道者。谓中软中中中上品道。由此道故。能舍三界所系地地中中上中中中软三品烦恼

上道者。谓上软上中上上三品道。由此道故。能舍三界所系地地中软上软中软软三品烦恼

如是软中上品道。复各别分为软等三建立九品。为显修道所断烦恼渐次断故。复何因缘软软品道。能断上上品烦恼。由此烦恼于极猛利毁灭惭愧无羞耻者身中。粗重现行易可觉了易可分别。是故此上品烦恼犹如粗垢。微少对治即能除遣。若下下品烦恼在与上相违者身中。微隐现行难可觉了难可分别。如微隐垢大力对治方能除遣。由此道理当知所余能治所治相翻建立亦尔

方便道者。谓由此道能舍烦恼所以者何。由正修如是道时。能渐舍离各别上品等烦恼所生品类粗重。一分渐得转依。是名修道中方便道

无间道者谓由此道无间。永断烦恼令无所余。所以者何。由此道无间。能永除遣此品烦恼所生品类粗重令无有余。又转粗重依得无粗重。是名修道中无间道

解脱道者。谓由此道证断烦恼所得解脱所以者何。由此道能证烦恼永断所得转依故。胜进道者。谓为断余品烦恼所有方便无间解脱道。是名胜进道。所以者何。为断此品后余烦恼所有方便无间解脱道。望此品是胜进故名胜进道。又复弃舍断烦恼方便。或勤方便思惟诸法。或勤方便安住诸法。或进修余三摩钵底诸所有道。名胜进道。又复者为显余义。舍断烦恼诸方便道。但正思惟契经等法。或复于先所思所证法中安住观察。或复进入余胜品定。诸如是等名胜进道。又为引发胜品功德。或复安住诸所有道。名胜进道。所以者何。若为引发神通无量等诸胜品功德。或彼生已现前安住。如是等道名胜进道。如是已广说修道相差别。今乘义势更辩诸道修之差别

修云何。略说有四种。谓得修习修除去修对治修。得修者。谓未生善法修习令生。习修者。谓已生善法修令坚住不忘倍复增广。除去修者。谓已生恶不善法修令永断。对治修者。谓未生恶不善法修令不生。如是四种修差别相。随其所应依四正断说。为得故修名为得修。由此修力得所未得诸善法故。习即是修名为习修。由此修力数习已得诸善法故。为除故修名除去修。由此修力除去现行位诸不善法故。修习对治名对治修。对治未来诸不善法令成不生法故又道生时能安立自习气。是名得修。从此种类展转增盛相续生故。又即此道现前修习。是名习修。由即此道现前行故。又即此道现在前时能舍自障。是名除去修。由此能灭自所对治粗重障故。又即此道既舍自障。又令彼未来住不生法中。是名对治修。由已得转依于未来世安置彼障令住不生法故。又由具四种对治故。名对治修。谓厌坏对治。断对治。持对治。远分对治。厌坏对治者。于有漏诸行见多过患。谓以如病如痈等行厌坏五取蕴故。断对治者。谓方便及无间道。由彼能断诸烦恼故。持对治者。谓解脱道。由彼任持断得故远分对治者。谓此后诸道。由彼令先所断烦恼转远离故。如是四种对治差别。是前对治修差别义

复次道差别有十一种。谓观察事道。勤功用道。修治定道。现观方便道。亲近现观道。现观道。清净出离道。依根差别道净修三学道。发诸功德道。遍摄诸道道。当知此中由觉分等差别故。建立十一种道如其次第谓三十七。菩提分法四种正行四种法迹。奢摩他毗钵舍那三无漏根。观察事道者。谓四念住。由此最初以不净等行观察一切身受心法事故。勤功用道者。谓四正断。由遍观察一切事已为断诸障发勤精进故。修治定道者。谓四神足。如是净除一切障已。复由欲勤心观门修三摩地。令成调顺堪任性故。现观方便道者。谓信等五根。如是修治三摩地已。为欲证得无漏圣道。勤修增上缘暖顶方便故。亲近现观道者。谓信等五力。如是已得增上缘者。为欲无间通达谛理。修习摧伏不信等障。忍第一法近方便故。现观道者。谓七觉支。由此最初各别内证觉真理故。清净出离道者。谓圣八支道。由从此后为令修道所断烦恼永得清净修出离道故。由此道理菩提分法如是次第。依根差别道者。谓四正行。由依近分根本等地差别及利钝根差别故。苦正行者依止未至及无色定。如其次第止观劣故。乐正行者依止根本静虑双道转故。二迟通者。谓钝根依苦乐。二速通者。谓利根依苦乐。净修三学道者。谓四法迹。由此净修增上戒等三学故。无贪无恚能净修治增上戒学。终不于贪欲嗔恚门毁犯所学处故。正念能净修治增上心学。由不忘所缘持心令定故。正定能净修治增上慧学。由心得定能。证如实智故。发诸功德道者。谓奢摩他毗钵舍那。由此能成办一切功德故。摄诸道道者。谓三无漏根。由此能摄初中究竟一切道故。未知欲知根摄方便道及见道。已知根摄修道。具知根摄究竟道

大乘阿毗达磨杂集论卷第九大乘阿毗达磨杂集论卷第十

        安慧菩萨糅

        大唐三藏法师玄奘奉　诏译

    决择分中谛品第一之五

复次一切菩提分法无有差别。皆由五门而得建立。谓所缘故自体故助伴故修习故修果故。如初四念住有五门。所余菩提分法亦尔

四念住所缘境者。谓身受心法。复有四事。谓我所依事。我受用事。我自体事。我染净事。何故唯建立此为所缘境。由颠倒觉愚痴凡夫多分计我。依止有根身。受用苦乐等。取了境为相。由贪等染污。由信等清净。是故最初为正观察真实事相。是故建立此四种事为所缘境

念住自体者。谓慧及念。由佛经中有于身等循观言故。及有念住言故。如其次第

念住助伴者。谓彼相应心心法等。彼者彼念慧二法

念住修习者。谓于内身等修循身等观。如于内于外于内外亦尔。内身者。谓于此身中所有内色处。由自身中眼耳鼻舌身根内处所摄故。堕有情数故名内。外身者。谓外所有外色处。由外色声香味触等外处所摄故。非有情数故名外。内外身者。谓内处相应所有外处根所依止。由己身中眼等五处相应根所依住所有色等外处堕有情数故。外处所摄故名内外。又于他身中所有内色处。约处建立约身建立说名内外。云何于身修循身观。谓以分别影像身与本质身平等。循观于身境循观身相似性故。名于身循身观。由循观察分别影像身门。审谛观察本质身故。内受者。谓因内身所生受。缘眼等处为境界故。依自身生故名内。外受者。谓因外身所生受。缘色等处为境界故。依他身生故名外。内外受者。谓因内外身所生受。缘自身中外处为境故。缘他身中内处为境故名内外。如受心法亦尔。如于身修循身观。如是于受等修循受等观如其所应

又修习者。谓欲勤策励勇猛不息正念正知及不放逸。修习差别故。欲修习者。谓为对治不作意随烦恼。勤修习者。谓为对治懈怠随烦恼。策修习者。谓为对治沉掉随烦恼。励修习者。谓为对治心下劣性随烦恼。心下劣性者。谓于胜品所证功德。由自轻蔑门心生怯弱性。勇猛修习者。谓为对治疏漏疲倦随烦恼。疏漏疲倦者。谓能引蚊虻等处所生逼恼。不息修习者。谓为对治得少善法生知足喜随烦恼。由得少善生知足喜故。止息所余胜进善品。正念修习者。谓为对治忘失尊教随烦恼。正知修习者。谓为对治毁犯追悔随烦恼。毁犯追悔者。谓于往来等事不正知而行。先越学处后生悔恼。不放逸修习者。谓为对治舍诸善轭随烦恼。舍善轭者。由放逸过失故。于所造修胜进善品。舍勤方便不能究竟。念住修果者。谓断四颠倒趣入四谛身等离系。是名修果断。四颠倒者。谓四念住随其次第能断净乐常我四种颠倒。修不净观故。了知诸受皆是苦故。通达诸识依缘差别念念变异故。观察染净唯有诸法无作用者故。又此四种如其次第趣入四谛。亦名修果。由身念住趣入苦谛。所有色身皆行苦相。粗重所显故。是故修观行时能治此轻安。于身差别生故。由受念住趣入集谛。以乐等诸受是和合爱等所依处故。由心念住趣入灭谛。观离我识当无所有惧我断门生涅槃怖永远离故。由法念住趣入道谛。为断所治法为修能治法故。又此四种如其次第能证得身受心法离系果。由此修习渐能远离身等粗重故。四正断所缘境者。谓已生未生所治能治法。初正断缘已生所治法为境。为断已生恶不善法。乐欲生故。第二正断缘未生所治法为境。第三正断缘未生能治法为境。第四正断缘已生能治法为境。如经所说。应广配释

正断自体者。谓精进

正断助伴者。谓彼相应心心法等

正断修习者。如经说生欲策励。发起正勤策心持心。此中诸句显修正勤及所依止。所依止者。谓欲乐欲。为先发精进故。正勤者。谓策励等。于止举舍相作意等中。若由止等相作意。不顾恋所缘境。纯修习对治。尔时名策励。为欲损减沉没掉举发起正勤。所以者何。若沉没随烦恼生时。为损减彼故。以净妙等作意策练其心。若掉举随烦恼生时。即以内证略摄门制持其心。尔时名为发起正勤。即为显此损减沉掉善巧方便。故次说言策心持心

正断修果者。谓尽弃舍一切所治。于能对治若得若增。是名修果。初二正断尽舍一切所治。如其所应。断舍一切已生未生恶不善法故。第三正断得能对治。能生未生诸善法故。第四正断增能对治。已生善法令增广故

四神足所缘境者。谓已成满定所作事。此复云何。由已成满三摩地力。发起种种神变等事。是所缘境

神足自体者。谓三摩地

神足助伴者。谓欲勤心观及彼相应心心法等。欲三摩地者。谓由殷重方便证心一境性。殷重方便者。谓由猛利乐欲猛利恭敬方便得三摩地。勤三摩地者。谓由无间方便触心一境性。勤者。谓常精进无时暂间。心三摩地者。谓由先修定力触心一境性。所以者何。由于前生数修定力。令彼种子功能增长。由种子力令心任运于三摩地随顺转变。由此速证心一境性。观三摩地者。谓由闻他教法内自简择触心一境性。又欲三摩地者。谓由生欲触心一境性。勤三摩地者。谓由策励发起正勤触心一境性。心三摩地者。谓由持心触心一境性。观三摩地者。谓由策心触心一境性。为显发生神足因性故。引修正断中生欲策励等诸句持心策心。是此次第。心三摩地者。由持心故得定持心。于内寂静略摄速证定故。观三摩地者。由策心故得定。依法观门策练其心速得定故

神足修习者。谓数修习八种断行。何等为八。谓欲精进信安正念正知思舍。如是八种略摄为四。谓加行摄受继属对治。加行者。谓欲精进信。欲为精进依。信为欲因。所以者何。由欲求故。为得此义发勤精进。如是欲求不离信受。有体等故。摄受者。谓安。由此轻安摄益身心故。继属者。谓正念正知。由不忘所缘安心一境故。若有放逸生如实了知故。随其次第。对治者。谓思舍。策心持心二加行力。已生沉掉能远离故。又能引发离随烦恼止等相故

复次欲勤心观修有二种。谓并因缘聚散远离。修不劣不散彼二所依随顺修。此中显示欲等。能远离聚散及因缘等二种修义。聚因缘者。谓远离毗钵舍那故由懈怠门所生沉没散因缘者。谓远离不净想故。由掉动门所生高举。聚者。谓由惛沉睡眠门于内踧踖。散者。谓由随顺净妙相门于外驰散。不劣随顺修者。谓依观察相观察诸法。不散随顺修者。谓依不净想观察发毛等事。彼二所依随顺修者。谓修光明想。依如是次第。薄伽梵说。我之欲乐无有下劣亦无高举。于内不聚于外不散。有前后想及上下想。开发其心远离缠缚。与光明俱自修其心。当令我心无诸闇蔽。神足修果者。谓已善修治三摩地故。随所欲证所通达法。即能随心通达变现。又于别别处所法中。证得堪能自在作用。如所愿乐能办种种神通等事。又能引发胜品功德

五根所缘境者。谓四圣谛。由谛现观方便所摄作此行故

五根自体者。谓信精进念定慧

五根助伴者。谓彼相应心心法等

五根修习者。谓信根于诸谛起忍可行修习。精进根于诸谛生忍可已为觉悟故。起精进行修习。念根于诸谛发精进已。起不忘失行修习。定根于诸谛既系念已。起心一境性行修习。慧根于诸谛心既得定。起简择行修习。五根修果者。谓能速发谛现观。由此增上力不久能生见道故。又能修治暖顶引发忍世第一法。即现此身已入顺决择分位故

如五根五力亦尔。差别者。由此能损减所对治障不可屈伏故名为力。谓五力所缘境等与根相似。然果有差别。所以者何。如说果者。谓能损减不信等障故。胜过于前虽与五根所缘境界自体等相似。然不可屈伏义有差别故。别立力分

七觉支所缘境者。谓四圣谛如实性。如实性者。即是胜义清净所缘故

觉支自体者。谓念择法精进喜安定舍。如是七法是觉支自体。念者是所依支。由系念故令诸善法。皆不忘失。择法者是自体支。是觉自相故。精进者是出离支。由此势力能到所到故。喜者是利益支。由此势力身调适故。安定舍者是不染污支。由此不染污故。依此不染污。故体是不染污故。如其次第由安故不染污。由此能除粗重过故。依定故不染污。依止于定得转依故。舍是不染污体永除贪忧不染污位为自性故

觉支助伴者。谓彼相应心心法等

觉支修习者。谓依止远离。依止无欲。依止寂灭。回向弃舍修念觉支。如念觉支乃至舍觉支亦尔。如是四句随其次第显示缘四谛境修习觉支。所以者何。若缘苦体为恼苦时。于苦境界必求远离故。名依止远离。若缘爱相苦集为苦集时。于此境界必求离欲故。名依止离欲。若缘苦灭为苦灭时。于此境界必求作证故。名依止寂灭。弃舍者。谓趣苦灭行。由此势力弃舍苦故。是故若缘此境时。于此境界必求修习故名回向弃舍

觉支修果者。谓见道所断烦恼永断。由七觉支是见道自体故

八圣道支所缘境者。谓即此后时四圣谛如实性。由见道后所缘境界。即先所见诸谛如实性为体故

道支自体者。谓正见正思惟正语正业正命正精进正念正定。如是八法名道支自体。正见者。是分别支。如先所证真实简择故。正思惟者。是诲示他支。如其所证方便安立发语言故。正语正业正命者。是令他信支。如其次第。令他于证理者决定信有见戒正命清净性故。所以者何。由正语故随自所证。善能问答论议决择。由此了知有见清净。由正业故往来进止正行具足。由此了知有戒清净。由正命故如法乞求佛所听许衣钵资具。由此了知有命清净。正精进者。是净烦恼障支由此永断一切结故。正念者。是净随烦恼障支。由此不忘失正止举相等。永不容受沉掉等随烦恼故。正定者。是能净最胜功德障支。由此引发神通等无量胜功德故

道支助伴者。谓彼相应心心法等

道支修习者。如觉支说。谓依止远离依止无欲依止寂灭。回向弃舍修习正见。乃至广说。如是诸句义如前所说道理应随顺知

道支修果者。谓分别诲示他。令他信烦恼障净随烦恼障净最胜功德障净故

四正行者。谓苦迟通行。苦速通行。乐迟通行。乐速通行。初谓钝根未得根本静虑。第二谓利根未得根本静虑。第三谓钝根已得根本静虑。第四谓利根已得根本静虑。苦正行者。谓依未至及无色地。如其次第。奢摩他毗钵舍那微劣故。乐正行者。谓依静虑双道转故。迟通者。谓钝根依苦乐二地。速通者。谓利根依苦乐二地

四法迹者。谓无贪无嗔正念正定。无贪无嗔能令增上戒学清净。不因贪恚门毁犯学处故。正念能令增上心学清净。由于所缘无有忘失持心令定故。正定能令增上慧学清净。由定心者能如实遍知故

奢摩他者。谓于内摄心令住等住安住近住。调顺寂静最极寂静。专注一趣平等摄持。如是九行令心安住。是奢摩他。令住者摄外攀缘内离散乱。最初系心故。等住者。最初系缚粗动心已。即于所缘相续系念。微细渐略故。安住者。或时失念于外驰散。寻复敛摄故。近住者。从初已来为令其心于外不散。亲近念住故。调顺者。从先已来于散乱因色等法中。起过患想增上力故。调伏其心令不流散故。寂静者。于扰动心散乱恶觉随烦恼中深见过患。摄伏其心令不流散故。最极寂静者。或时失念散乱觉等率尔现行。即便制伏令不更起故。专注一趣者。精勤加行无间无缺。相续安住胜三摩地故。平等摄持者。善修习故。不由加行远离功用。定心相续离散乱转故。毗钵舍那者。谓简择诸法最极简择。普遍寻思周审观察。为欲对治粗重相结故。为欲制伏诸颠倒故。令无倒心善安住故。此中诸句依正行所缘境说。或依善巧所缘境说。或依净烦恼所缘境说。简择诸法者。尽所有故。最极简择者。如所有故。普遍寻思者。由有分别作意俱行慧建立诸法相故。周审观察者。委具推求故

又依奢摩他毗钵舍那立四种道。或有一类。已得奢摩他非毗钵舍那。此类依奢摩他进修毗钵舍那。或有一类。已得毗钵舍那非奢摩他。此类依毗钵舍那进修奢摩他。或有一类。不得奢摩他亦非毗钵舍那。此类专心制伏沉掉双修二道。或有一类。已得奢摩他及毗钵舍那。此类奢摩他毗钵舍那二道和合平等双转。此中依于止观说四种道。初已得止故宴坐住心。乃至平等摄持。未得观故还复宴坐。依三摩地简择诸法。乃至周审观察。第二与此相违。第三二俱未得双进修习。云何修习。谓听闻法由受持门进修正观。以此为先进修于止。第四已得二种相应俱转

三根者。谓未知欲知根已知根具知根。未知欲知根者。谓于方便道及于见道十五心刹那中所有诸根。此中显示顺决择分所摄方便道。及见道十五刹那所有诸根。是未知欲知根体。言诸根者。谓意根信等五根。由未至等地所依差别故。如其所应有乐喜忧舍根随一。忧根者。谓方便道时顺决择分后。于上解脱希求欲证愁戚所摄。如是十根先未知真。为欲得知修习转故。名未知欲知根。已知根者。从第十六见道心刹那已上。于一切有学道中所有诸根。是已知根体。所以者何。即前十根从第十六见道心刹那。乃至金刚喻定。于如是有学道中。未有所应知境。曾所不知故。名已知根。具知根者。谓于无学道所有诸根。言诸根者。即前所说九根除忧根。于无学道中说名具知根。具知者。谓阿罗汉等此所有根名具知根。无学身中无有忧根所应学无故

复次依止修道分别修义。谓依初静虑地现修道时。亦修欲界系所有善根。于彼得自在故。如依初静虑地修欲界善如是依一切上地现修道时。皆能修习下界下地所有善根。于彼得自在故。当知此中所说义者。谓依止上地现前修习道时。下界下地所有善根。虽不现前亦皆修习。何以故。于彼得自在故。自在者。谓转增胜现行自在故

究竟道者。谓依金刚喻定一切粗重永已息故。一切系得永已断故。永证一切离系得故。从此次第无间转依。证得尽智及无生智十无学法何等为十。所谓无学正见乃至无学正定无学正解脱无学正智。如是等法名究竟道

云何名一切粗重。略说有二十四种。谓一切遍行戏论粗重。领受粗重。烦恼粗重。业粗重。异熟粗重。烦恼障粗重业障粗重。异熟障粗重。盖粗重。寻思粗重。饮食粗重。交会粗重。梦粗重。病粗重。老粗重。死粗重。劳倦粗重。坚固粗重。粗粗重。中粗重。细粗重。烦恼障粗重。定障粗重。所知障粗重。如是二十四种略摄一切粗重

一切遍行戏论粗重者。谓执眼等诸法习气无始时来依附阿赖耶识相续不断。即此名为戏论习气。从此习气眼等诸法。及名言执数数生起。领受粗重者。谓有漏诸受习气。烦恼粗重者。谓烦恼随眠。业粗重者。谓有漏业习气。异熟粗重者。谓异熟无堪能性。烦恼障粗重者。谓猛利长时烦恼性。业障粗重者。谓能障道无间等业障性。异熟障粗重者。谓与谛现观相违。地狱等自体得。盖粗重者。谓能障碍善品方便盛贪欲等性。寻思粗重者。谓能障碍欣乐出家欲寻思等性。饮食粗重者。谓极多少食于方便行无堪任性。交会粗重者。谓两两形交身心疲损性。梦粗重者。谓睡眠所发身惛劣性。病粗重者。谓诸界互违所发不安隐性。老粗重者。谓大种衰变所起不随转性。死粗重者。谓临命终时诸根乱性。劳倦粗重者。谓远行等所作支体顿弊性。坚固粗重者。谓无涅槃法者。如其所应。所有戏论粗重等性。粗中细粗重者。谓欲色无色所有粗重。如其次第。烦恼障粗重者。谓声闻独觉菩提所治。定障粗重者。谓九次第定所发功德所治。所知障粗重者。谓一切智性所治如是随其所应。一切粗重永已息故。名究竟道。如说如是行者。心解脱圆满。慧解脱圆满。身粗重永息。由成就念为因故。于最初门善调善护善防善覆极善修治。谓于眼所识色乃至于意所识法亦尔

系得者。谓于粗重积集。假立系得性

离系得者。谓于粗重离散。假立离系得性。金刚喻定者。谓居修道最后断结道位所有三摩地。此复略有二种。谓方便道摄无间道摄。方便道摄者。谓从此已去不为一切障所碍而能破一切障。无间道摄者。谓从此无间尽智无生智生。又此三摩地无间坚固一味遍满。云何此金刚喻定名无间。谓此相续流非世间行所间缺故。坚固者。非一切障所坏。能坏一切障。极坚猛故。一味者。无分别性纯一味故。遍满者。缘一切所知法共相真如为境故。为显此义薄伽梵说。如大石山无缺无隙无穴一段。极善圆满十方猛风所不动转。无间转依者。谓已证得无学道者所有三种转依。何等为三。谓心转依道转依粗重转依。心转依者。谓已得无学道证得法性心自性清净。永离一切客尘随烦恼故。名为转依。即是真如转依义。道转依者。谓昔世间道于现观时转成出世说名有学。余有所作故。若永除一切所治。永离三界欲时。此道自体究竟圆满。立为转依。粗重转依者。谓阿赖耶识一切烦恼随眠永远离故。名为转依

尽智者。谓由因尽所得智。或缘尽为境。所以者何。由有尽故而起此智。名为尽智。或缘尽为境故名尽智。此义意言。于此位中由永断集令无有余。所得智名尽智。或缘因尽为境故名尽智

无生智者。谓由果断所得智。或缘果不生为境。所以者何。由有无生故所得智名无生智。或缘无生为境名无生智。此义意言。由有当来一切苦果毕竟不生法性故。而得此智。虽缘余谛为境亦名无生智。或缘苦谛无生为境。故名无生智

又十无学法。当知依止无学戒蕴定蕴慧蕴解脱蕴解脱智见蕴说。何以故。无学正语正业正命。是无学戒蕴。无学正念正定。是无学定蕴。无学正见正思惟正精进。是无学慧蕴。无学正解脱。是无学解脱蕴。无学正智。是无学解脱智见蕴

复次道谛有四行相。谓道相如相行相出相。何故名道相。因此寻求真实义故。所以者何。由此圣道是诸圣者证真义路。是故名道。何故名如相。以能对治诸烦恼故。所以者何。一切烦恼皆不如理道能除此是故名如。何故名行相。善能成办心令不颠倒故。所以者何。心不觉悟真实道理。于无常等法起常等颠倒。善能修治此颠倒心。令离颠倒觉真实义。是故名行。何故名出相。趣真常迹故。所以者何。由此圣道能趣出离究竟常迹。是故名出。问于诸谛中有十六行。皆通世间及出世间。世出世行有何差别。答于所知境不善悟入善悟入性差别故。有障无障性差别故。有分别无分别性差别故。所以者何。于诸谛中无常苦等十六世间行于所知境界。不通达真如性故。烦恼所随眠故。依名言门起戏论故。如其次第。不善悟入有障碍有分别。出世间行与此相违。善悟入无障碍无分别。由此道理世出世行互有差别。云何出世行无有分别。而善悟入。所知境界由彼诸行现在前时。虽复现证见无常义然不依名言戏论门见此是无常义。如无常行于无常义。余行于余义。随其所应亦如是

大乘阿毗达磨杂集论卷第十大乘阿毗达磨杂集论卷第十一

        安慧菩萨糅释上集论

        大唐三藏法师玄奘奉　诏译

    决择分中法品第二之一

云何法决择。法者。谓十二分圣教。何者十二。一契经。二应颂。三记别。四讽颂。五自说。六缘起。七譬喻。八本事。九本生。十方广。十一希法。十二论议

契经者。谓以长行缀缉略说所应说义。问何故如来不广开演所应说义耶。答如来观察十种胜利略说诸法。谓易可建立。易可宣说。易可受持。恭敬法故。菩提资粮速得圆满。速能通达诸法实性。于诸佛所得证净信。于法僧所得证净信。触证第一现法乐住。谈论决择悦智者心得预聪明英睿者数。云何名为易可建立。诸说法者以无量门安立开示所应说义。今以略言易建立故。云何名为易可宣说。能以少言词广显大义故。如说能令心住等住。如是广说。易可受持者。令能闻者易受持故。恭敬法故。菩提资粮速得圆满者。了知佛法深慧所证。即于是法深生敬爱。由敬爱门信等资粮速圆满故。速能通达诸法实性者。即由敬法方便力故。令其智慧转复猛利。渐能通达诸法实性。于三宝所得证净信者。由悟圣教妙善建立。于说者等净信生故。触证第一现法乐住者。于诸如来密意深义。猛利加行正思量已。获得增上证欢喜故。谈论决择悦智者心者。善能开发深隐义故。得预聪明英睿者数者。广大美称流布十方故。当知后二种合为一胜利

应颂者。即诸经中或中或后以颂重颂。又不了义经应更颂释。故名应颂

记别者。谓于是处圣弟子等谢往过去。记别德失生处差别。又了义经说名记别。记别开示深密意故

讽颂者。谓诸经中以句宣说。或以二句或三或四或五或六

自说者。谓诸经中或时如来悦意自说如伽他曰。若于如是法发勇猛精进静虑谛思惟。尔时名梵志

缘起者。谓因请而说。随依如是补特伽罗。起如是说故。又有因缘制立学处。亦名缘起。谓依如是因缘。依如是事乃至广说

譬喻者。谓诸经中有比况说。为令本义得明了故。说诸譬喻

本事者。所谓宣说圣弟子等前世相应事

本生者。所谓宣说诸菩萨行本相应事

方广者。谓菩萨藏相应言说。如名方广。亦名广破。亦名无比。为何义故名为方广。一切有情利益安乐所依处故。宣说广大甚深法故。为何义故名为广破。以能广破一切障故。为何义故名为无比。无有诸法能比类故。此方广等皆是大乘义差别名。由与七种大性相应故名大乘。何等名为七种大性。一境大性。以菩萨道缘百千等无量诸经。广大教法为境界故。二行大性。正行一切自利利他广大行故。三智大性。了知广大补特伽罗法无我故。四精进大性。于三大劫阿僧企耶。方便勤修无量百千难行行故。五方便善巧大性。不住生死及涅槃故。六证得大性。证得如来诸力无畏不共佛法等无量无数大功德故。七业大性。穷生死际示现一切成菩提等。建立广大诸佛事故

希法者。若于是处宣说声闻诸大菩萨及如来等最极希有甚奇特法

论议者。若于是处无有颠倒。解释一切深隐法相。以无颠倒一切法相论议经等深隐义故

如是契经等十二分圣教三藏所摄。何等为三。一素怛缆藏。二毗奈耶藏。三阿毗达磨藏。此复有二。一声闻藏。二菩萨藏。契经应颂记别讽颂自说。此五声闻藏中素怛缆藏摄。缘起譬喻本事本生。此四二藏中毗奈耶藏并眷属摄。缘起者。宣说有因缘建立诸学处。是正毗奈耶藏摄。譬喻等三。是彼眷属摄。方广希法。此二菩萨藏中素怛缆藏摄。方广者。文义广博正菩萨藏摄。希法差别难思广大威德最胜相应。是故亦是菩萨藏摄。论议一种。声闻菩萨二藏中阿毗达磨藏摄。问何故如来建立三藏。答为欲对治疑随烦恼故。建立素怛缆藏。为欲断除所化有情于种种法发起疑惑。宣说契经应颂等故。为欲对治受用二边随烦恼故。建立毗柰耶藏。二边者。谓欲乐行边。自苦行边。对治受用者。遮彼受用畜积等故。开彼受用百千如法衣服等故。为欲对治自见取执随烦恼故。建立阿毗达磨藏。处处广释诸法差别如实相故。复次为欲开示三种学故。建立素怛缆藏。所以者何。要依此藏所化有情解了三学。由此藏中广开三种所修学故。为欲成立增上戒学增上心学故。建立毗柰耶藏。要依此藏二增上学方得成立。所以者何。广释别解脱律仪学道圣教为所依止。方能修治净尸罗故。依净尸罗生无悔等。渐次修学心得定故。为欲成立增上慧学故。建立阿毗达磨藏。要依此藏增上慧学方得成立。所以者何。由此藏中能广开示简择诸法巧方便故。复次为欲开示正法义故。建立素怛缆藏。依止此藏文义易了故。为显法义作证安足处故。建立毗柰耶藏。依止此藏能修二种作证学行故。毗柰耶是法义作证安足处。安足处者是所依义。为令智者论议决择受用法乐住故。建立阿毗达磨藏。依止此藏诸有智者。更相问答论议决择受法乐住。由此藏中以无量门开示诸法自相共相等真实法性故。如是三藏具有八万四千法蕴。谓依声闻乘。尊者阿难常所受持。问一一法蕴其量云何。答十百之数是法蕴量。十百者千数义。若尔何故不直说是千数耶。为显建立一一法蕴千数因故。所以者何。初一数增以成十数。十数复增以成百数千等数量。因十百数方得成立。谓十百名千。百千名百千。百百千名俱胝。如是等一切后后数位决定用此十百二数随一为因。是故此中唯总取十百两数。以用建立一一法蕴由此数量总计八万四千法蕴。成八俱胝四十洛叉。问如是三藏所摄法为谁所行境耶。答是闻思。修所生诸心心法所行境界。所行者是所缘义

复次因此所缘相。依心心法建立有缘等义。如经中说。诸心心法有缘有行有依相应彼于此法为何所缘。谓契经等此显名身句身文身。所摄契经等教法为所缘境。作何等行。谓蕴等相应义。此显依蕴等义所起言教法。彼心心法作此行相。何所依止。谓他表了忆念习气。此显正说法时用他表了为所依止。如说从他言音故。次此后时忆念为所依止。如所闻已随念数习故。复此后时习气为所依止。由后串习习气力强。虽离忆念而似彼显现故。何等相应。谓互为助伴于所缘行平等解了。由心心法互为助伴。于契经等所缘境界。以蕴等相应义行平等解了故

云何于法所缘差别。若略说有四种。谓遍满所缘。治行所缘。善巧所缘。净惑所缘。遍满所缘复有四种。谓有分别影像所缘。无分别影像所缘。事边际所缘。所作成就所缘。有分别影像所缘者。谓由胜解作意。所有奢摩他毗钵舍那所缘境。胜解作意者。一向世间作意。无分别影像所缘者。谓由真实作意。所有止观所缘境。真实作意者。一向出世间。及此后所得作意。事边际所缘者。谓一切法尽所有性如所有性。尽所有性者。谓蕴界处。为显所知诸法体事唯有尔所分量边际。是故建立蕴界处三。如所有性者。谓四圣谛十六行真如。一切行无常。一切行苦。一切法无我。涅槃寂静空无愿无相。由如是等义差别门了所知境故。名如所有性。或以谛门了所知境。谓即前所说诸蕴界处。随其所应了知是苦乃至是道。或以行门了所知境。谓一一谛各由四行及一切法无有差别皆真如行。或以诸法邬柁南门了所知境。谓诸行无常乃至涅槃寂静。或以解脱门了所知境。谓空无愿无相如是等所作成就所缘者。谓转依。已得转依者无有颠倒。所缘显现故。如是转依不可思议。前说如所有性中有十六行及三解脱门。如是二种更互相摄。问空摄几行。答二。谓空行无我行。问无愿摄几行。答六。谓无常行苦行因行集行生行缘行。由彼于三界无所愿求故。问无相摄几行。答八。谓灭道八行。由彼不能行诸相故。治行所缘者。略说有五种。谓多贪行者缘不净境。多嗔行者缘修慈境。多痴行者缘众缘性诸缘起境。憍慢行者缘界差别境。寻思行者缘入出息念境。何故多贪行者等缘不净等。修治行所缘境耶。由此能息除增上贪等故。善巧所缘者。略有五种。谓蕴善巧。界善巧。处善巧。缘起善巧。处非处善巧。处非处善巧应云何观。应如缘起善巧观。问缘起善巧处非处善巧有何差别。答若以诸法流润诸法。令离无因不平等因生故。是缘起善巧。谓以无明等诸法流润行等诸法。非彼诸法无因而生。亦非自在天等不平等因生。如是观智名缘起善巧。因果相称摄受生起故。是处非处善巧。谓虽唯有法为因。然由摄受相称因。方能生起相称果。如善行感可爱异熟恶行感不可爱异熟。如是比如是观智。名处非处善巧。净惑所缘者。谓下地粗性上地静性。真如及四圣谛。下地粗性上地静性者。依世间道说。由此制伏诸缠故。真如及四圣谛者。依出世道说。略故真如。广故四圣谛。由此永害诸随眠故

复次因辩观察契经等法。应当解释诸法道理。由依此道理能观彼法故。问若欲于诸法正勤审观察。由几种道理能正观察耶。答由四种道理。谓观待道理。作用道理。证成道理。法尔道理。观待道理者。谓诸行生时要待众缘。如芽生时要待种子时节水田等缘。诸识生时要待根境作意等缘。如是等。作用道理者。谓异相诸法各别作用。如眼根等为眼识等所依作用。色等境界为眼识等所缘作用。眼等诸识了别色等。金银匠等善修造金银等物。如是比。证成道理者。谓为证成所应成义。宣说诸量不相违语。所应成义者。谓自体差别所摄所应成义。诸量不相违语者。谓现量等不相违立宗等言。法尔道理者。谓无始时来于自相共相所住法中。所有成就法性法尔。如火能烧水能烂。如是等诸法成就法性法尔。如经言。眼虽圆净空无有常乃至无我。所以者何。其性法尔。复次于诸法中正勤观察四道理已。云何而起寻思。谓起四种寻思。一名寻思。二事寻思。三自体假立寻思。四差别假立寻思。名寻思者。谓推求诸法名身句身文身自相皆不成实。由名身等是假有故。观彼自相皆不成实。事寻思者。谓推求诸法蕴界处相皆不成实。由诸蕴等如名身等。所宣说事皆不成实。是故观彼相不成实。推求者是观察义。自体假立寻思者。谓于诸法能诠所诠相应中推求自体。唯是假立言说因性。能诠所诠相应者。谓此二互为领解因性。所以者何。善名言者。但闻能诠由忆念门。便于所诠得生领解。或但得所诠由忆念门。便于能诠得生领解。于如是种类共立相应中。眼等自相唯是假立。但于肉团等名言。因中起此名言故。若如是观察是名自体假立寻思。差别假立寻思者。谓于诸法能诠所诠相应中推求差别。唯是假立名言因性。所以者何。以于能诠所诠相应中。推求若常无常有上无上有色无色有见无见等差别相。唯是假立名言因性。如是观察是名差别假立寻思

复次于法正勤修寻思已。必于诸法得如实智。云何而起如实智耶。谓起四如实智。一名寻思所引如实智。二事寻思所引如实智。三自体假立寻思所引如实智。四差别假立寻思所引如实智。名寻思所引如实智者。谓如实知名不可得智。事寻思所引如实智者。谓如实知事相亦不可得智。自体假立寻思所引如实智者。谓如实知实有自性不可得智。差别假立寻思所引如实智者。谓如实知实有差别不可得智。此四如实智如前所寻思了知。名等如实皆不可得

复次依法修三摩地者瑜伽地。云何当知。此地略有五种。谓持任镜明依。持者。谓已积集菩提资粮。于暖等位依诸圣谛所有多闻。如所多闻安立止观所缘境故。说名为持。又已积集菩提资粮者。为求谛现观听受契经等法。故名多闻。任者。谓缘此境如理作意。由此作意。依所多闻无倒思惟。所闻义相任持心故。镜者。谓缘此境有相三摩地。此三摩地即缘多闻。为境与定相俱故名有相。由此三摩地犹带所知事同分影像相故。又此三摩地能审照察所知事质。故譬于镜。明者。谓能取所取无所得智。由此智见道所摄现观转故。云何菩萨依瑜伽地方便修学证无所得。谓诸菩萨已善积集福德智慧二种资粮已。过第一无数大劫已。闻随顺通达真如。契经等法如理作意。发三摩地依止定心。思惟定中所知影像。观此影像不异定心。依此影像舍外境想。唯定观察自想影像。尔时菩萨了知诸法唯自心故。内住其心知一切种所取境界皆无所有。所取无故。一切能取亦非真实。故次了知能取非有。次复于内舍离所得二种自性证无所得。依此道理佛薄伽梵妙善宣说。菩萨于定位观影唯是心。义想既灭除。审观唯自想。知所住内心知所取非有。次能取亦无。后触无所得。依者。谓转依。舍离一切粗重得清净转依故。当知此中以因果两位释瑜伽地。由持等四种释此地因。最后一种释此地果

复次云何于诸法中法善巧。云何义善巧。云何文善巧。云何词善巧。云何前际后际密意善巧。如是五问随顺经中所说诸句。如尊者阿难告舍利子。长老当知。若诸比丘成就五法。即能速受多受善受受已不失。于此经中即由五法如其所应成速受等四种句义。云何法善巧。谓多闻故。于法善巧便能速受。由具多闻者多分能速受文句差别故。云何义善巧。谓于阿毗达磨毗奈耶中善知其相故。于义善巧便能多受。若善了知阿毗达磨等相。乃于蕴界处等所说事中。便能摄集众多文故。云何文善巧。谓善知训释文词故。云何词善巧。谓能善知我我所等世俗言词。不深执着随顺说故。若于文词俱得善巧。便能妙善领受所说。善知训释文词故。善知我我所等世俗言词。不深执着随顺说故。即能无倒领受文义。云何前际后际密意善巧。谓能善知于前际领受于后际出离故。若于前际后际密意善巧。便能受已而不失坏。依止前际所受法。后能证得出离故。由善了知如来密意。便能证取圣教坚实。云何于诸法中安住于法。若不得修慧唯勤方便修习闻思。不得名为安住于法。若不得闻思唯勤方便修习修慧。亦不得名安住于法。若俱得二种方便安住。如是乃名安住于法。如经言。大德当知。若诸比丘如是住法。乃可名为住法比丘。于此经中世尊显示。若能具依闻思修住。方名住法。非随住一方便修习得名住法。若唯于法受持读诵为他宣说等。是名闻思所生慧。如说若于是处多究其文。读诵宣说又多寻思。唯修闻思慧不修习。修慧舍离瑜伽等。不可建立为住法。若修三摩地方便不知足。是名修所生慧。如说若有不得闻思唯修修慧。亦不可立为住法。是故世尊因住法比丘说如是言。若比丘于法究竟。所谓契经应颂乃至广说。已后复说言。不舍瑜伽。如是等应如理知。若有具得闻思修慧依二种住。是名住法不舍瑜伽。如是等者。谓修三摩地方便不知足。显示修所生慧。三摩地方便者。谓无间殷重方便。及无颠倒方便。此则显示二种方便。一无间殷重方便所摄。如说不舍瑜伽故。二无颠倒方便所摄。如说不舍作意故。不知足者。谓不生味着修上奢摩他方便。如说不舍内心奢摩他故。此则显示不生味着故。及修上奢摩他方便故。名为不舍

复次何因缘故。十二分圣教中方广分名菩萨波罗蜜多藏耶。由此分中广说一切波罗蜜多数故。相故次第故释词故修故差别故摄故所治故功德故更互决择故。问于何处说。答如经中说。大乘者即是菩萨波罗蜜多藏。云何宣说波罗蜜多数相次第。乃至更互决择。数有二种。一计算数。二决定数。计算数者。谓六波罗蜜多。决定数者。谓波罗蜜多数唯有六不增不减。何以故。一切菩萨道略有二种。一增上生道。二决定胜道。如其次第三三摄故。所以者何。增上生有三种。一大资财。二大自体。三大眷属。施波罗蜜多感大资财果。戒波罗蜜多感大自体果。由持净戒生善趣中得尊贵身故忍波罗蜜多感大眷属果。能行忍者一切众生咸所归附故。决定胜道有三种。一伏诸烦恼修习善品方便。二成熟有情方便。三成熟佛法方便。如是三中随阙一种。菩萨决定胜道必不成就。成熟有情方便者。谓静虑波罗蜜多。依此发神通成熟有情故。复次波罗蜜多是无住处涅槃方便故。其数唯六。所以者何。由诸菩萨为翻住涅槃故。于生死中摄增上生。为翻住生死故。即于生死而不染污。是故前三是得增上生方便。后三是不染污方便。随其所应如前应知。不染污方便者。由精进故修习对治。由静虑故伏诸烦恼。由智慧故永害一切烦恼随眠。复次为摄益一切有情故。对治一切烦恼故。波罗蜜多唯有六种。所以者何。菩萨摩诃萨由布施故引摄资财。方便摄益一切有情。由持戒故不起侵损逼迫恼乱。方便摄益一切有情。如其次第不毁坏他财身心故。由忍辱故堪受侵损逼迫恼乱。方便摄益一切有情。由堪忍他侵损己财等故。由此三种善能摄益一切有情。由精进故虽未永伏一切烦恼。而依善品修彼对治。由静虑故永伏烦恼。由智慧故永害随眠。由此三种善能对治一切烦恼。相者。谓诸菩萨波罗蜜多相。云何施波罗蜜多相。谓诸菩萨安住菩萨法性菩提心为依止。以悲导心舍一切时所有身语意业。如是由种性故愿故意乐故事故自体故。显施波罗蜜多相。种性者。谓菩萨法性。愿者。谓菩提心。意乐者。谓悲导心。事者。谓舍诸所有。自体者。谓身语意业。云何戒波罗蜜多相。谓诸菩萨安住菩萨法性菩提心为依止。以悲导心受持一切菩萨戒时所有身语意业。云何忍波罗蜜多相。谓诸菩萨安住菩萨法性菩提心为依止。以悲导心堪忍安受诸怨苦时所有身语意业。云何精进波罗蜜多相。谓诸菩萨安住菩萨法性菩提心为依止。以悲导心引发一切胜善法时所有身语意业。云何静虑波罗蜜多相谓诸菩萨安住菩萨法性菩提心为依止。以悲导心起一切种身语意业自在用时。所有一切心恒安住。云何慧波罗蜜多相。谓诸菩萨安住。菩萨法性菩提心为依止。以悲导心起一切种身语意业自在用时。所有一切诸法简择复次若所行施依止萨伐若性。能感萨伐若性。摄受萨伐若性。能为一切萨伐若事。是名施波罗蜜多相。如是四句随其次第。由发起故习气故自体故等流故。显波罗蜜多相。发起者。谓依止一切智性。凡所生起一切施行。皆回向萨伐若性故。习气者。谓能感一切智性。即所行施熏修相续。于当来世能感萨伐若性故。自体者。谓摄受一切智性。即所行施究竟圆满。尔时能办佛法身故。等流者。谓能为一切一切智事。从此后时由受用变化身等流门。发起一切萨伐若事故。如施波罗蜜多相乃至慧波罗蜜多相。皆应如是说

次第者。谓前前波罗蜜多能为后后所依止故。所以者何。菩萨摩诃萨由施波罗蜜多串习舍施内外事故。不顾身命弃大宝藏受持禁戒由护戒故。他所毁骂终不反报。由如是等遂能堪忍。以能堪忍寒热等苦。虽遭此缘加行不息发勤精进。精进方便证究竟果成满静虑。静虑满已。由净定心如实知故。证得出世究竟大慧。复次前前波罗蜜多后后所持故。谓戒能持施。乃至慧能持静虑。由具尸罗施得清净。何以故。由行布施摄益有情。由具尸罗不为恼害。是故菩萨于受施者。以离恼害善能施与清净乐具故。由净戒力施得清净。如是由忍力故戒得清净。何以故。由能忍受他不饶益。终不毁犯所学处故。由精进故忍得清净。何以故。由勇猛力故久处生死不以为难。能受众生违逆等苦。由静虑故精进清净。何以故。由喜乐俱能勤修习一切善法无休息故。由具慧故静虑清净。何以故。若由无量门数数观诸法。能证内寂静。增长三摩地。又伽他说。无有静虑而不因慧。复次由粗细故。波罗蜜多前后次第。所以者何。于诸行中施行最粗故先建立。于忍等行戒复为粗故次建立。乃至于慧静虑为粗。一切行中慧为最细故最后立

释词者。谓诸菩萨所行布施。所以名施波罗蜜多者。谓由大施故离过故离垢故。名施波罗蜜多。大施者。尽舍一切内外事故。长时施故。离过者。远离不平等追求等过故。离垢者。永断一切所治悭故。如无尽慧经施无尽中说云何离垢。永断所治并习气故。如是三句显波罗蜜多三种最胜。何等为三。一自体最胜并积习。二方便最胜。三果最胜。积习者。谓长时施故。如施波罗蜜多有三种。乃至慧波罗蜜多亦尔。戒等离过者。谓远离我增益等随其所应。如无尽慧经广说。复次由与十二种最胜相应故。名波罗蜜多。何等名为十二最胜。一广大最胜。不求一切世间乐故。又最上故。二长时最胜。经三大劫阿僧企耶所积习故。三所为最胜。为利益安乐一切有情故。四无尽最胜。由回向大菩提究竟无尽故。五无间最胜。由得自他平等胜解令诸有情于施等波罗蜜多速圆满故。六无难最胜。唯由随喜他所行施等令波罗蜜多速圆满故。七大自在最胜。由得虚空藏等诸三摩地令布施等波罗蜜多速圆满故。八摄受最胜。无分别智所摄受故。九发起最胜。谓解行地中上品忍位所行施等波罗蜜多。十证得最胜。谓初地中所得施等波罗蜜多。十一等流最胜。谓余八地中所行施等波罗蜜多。十二圆满最胜。谓第十地及如来地所有施等波罗蜜多。如其次第菩萨圆满故。佛圆满故。复次最胜所作故。最胜所至故。名波罗蜜多。一切佛菩萨所为所到故。复次到所知彼岸故。名波罗蜜多。安住佛性故。复次济度自他最极灾横故。名波罗蜜多。能令自他越度生死大苦海故。共词已释。不共今当说。能舍施者当来贫苦。能舍受者现在热恼。故名为施。能令诸根永寂静故。能趣清净诸善趣故。能为清凉所依处故。说名为戒。随其次第。能引守护诸根门故。是往清净善趣因故。能为无悔等渐次乃至涅槃所依故。远离一切忿热灰故。远离不舍怨害心故。显发损者常安隐故。说名为忍。怨害心者。谓起报怨心。不舍者。谓不弃此心。能坏怨心名为损者。显此无畏故名显发。损者常安隐故。损害生长作用相应故名精进。损害作用相应者。谓前二正断。以能损害不善法故。生长作用相应者。谓后二正断。以能生长诸善法故。能持能息能静能调。又能引发故名静虑。能持者。谓于境系心。能息者。谓息诸散乱。能静者。谓令心寂静。能调者。谓制伏诸缠。能引发者。谓能引发自在作用。他所发智故。内证智故。种别智故。得寂静智故。胜德智故。名为慧。他所发智者。谓从他言音所生慧。及如理作意相应慧。内证智者。谓出世间慧。种别智者。谓出世间后所得慧。得寂静智者。谓修道中治烦恼慧。胜德智者。谓能引发胜功德慧

大乘阿毗达磨杂集论卷第十一大乘阿毗达磨杂集论卷第十二

        安慧菩萨糅释上集论

        大唐三藏法师玄奘奉　诏译

    决择分中法品第二之二

云何修。略有五种。谓依止任持修。依止作意修。依止意乐修。依止方便修。依止自在修

依止任持修复有四种。一依止因修。谓由种性力于波罗蜜多修习正行。二依止报修。谓由胜自体力于波罗蜜多修习正行。三依止愿修。谓由本愿力于波罗蜜多修习正行。四依止简择力修。谓由慧力于波罗蜜多修习正行

依止作意修亦有四种。一依止胜解作意修。谓于一切波罗蜜多相应经教起增上胜解。二依止爱味作意修。谓于已得波罗蜜多见胜功德起深爱味。三依止随喜作意修。谓于一切世界一切有情所行施等深生随喜。四依止喜乐作意修。谓于自他当来胜品波罗蜜多深生愿乐

依止意乐修复有六种。谓由无厌意乐。广大意乐。欢喜意乐。恩德意乐。无染意乐。善好意乐故。修诸波罗蜜多。此中菩萨于施波罗蜜多无厌意乐者。谓诸菩萨于一有情一刹那顷。假使殑伽沙等世界满中七宝以用布施。又以殑伽沙等身命布施。如是布施经殑伽沙等大劫。如于一有情所。如是乃至于一切有情界如是施时。皆令彼于阿耨多罗三藐三菩提速得成熟。修行如是差别施时。菩萨意乐由不厌足。如是意乐是名菩萨于施波罗蜜多无厌意乐。又诸菩萨修行如是施波罗蜜多时。展转相续无一刹那有退有断。乃至究竟坐菩提座。如是意乐是名菩萨于施波罗蜜多广大意乐。又诸菩萨修行如是施波罗蜜多时。于施所摄诸有情所生大欢喜。是诸有情施所摄受虽生欢喜犹不能及如是意乐。是名菩萨于施波罗蜜多欢喜意乐。又诸菩萨修行如是施波罗蜜多时。观施所摄一切有情。于我己身有大恩德。不见己身于彼有恩。由资助我阿耨多罗三藐三菩提故。如是意乐是名菩萨于施波罗蜜多恩德意乐。又诸菩萨修行如是施波罗蜜多时虽于无量诸有情所兴大施福。而不希报恩当来果报。如是意乐是名菩萨于施波罗蜜多无染意乐。又诸菩萨修行如是施波罗蜜多时。以所修行广大施聚所得果报。施诸有情不自为己。又以此福共诸有情回向阿耨多罗三藐三菩提如是意乐是名菩萨于施波罗蜜多善好意乐。又诸菩萨修行戒波罗蜜多乃至慧波罗蜜多时无厌意乐者。谓诸菩萨假使经于殑伽沙等生。是一一生殑伽沙等大劫寿量。于此长时诸资生具常所匮乏。三千大千世界满中炽火。恒在其中行住坐卧。唯能修习一刹那戒波罗蜜多。或乃至慧波罗蜜多如是展转差别修习。所有戒聚乃至慧聚究竟满足。现能证得阿耨多罗三藐三菩提。是诸菩萨修行如是戒波罗蜜多乃至慧波罗蜜多时。于此戒聚乃至慧聚。修习意乐犹不满足。如是意乐是名菩萨于所修习戒波罗蜜多乃至慧波罗蜜多无厌意乐。又诸菩萨修行如是戒波罗蜜多乃至慧波罗蜜多时。展转相续无一刹那有退有断。乃至究竟坐菩提座。如是意乐是名菩萨于所修行戒波罗蜜多乃至慧波罗蜜多广大意乐。又诸菩萨修行如是戒波罗蜜多乃至慧波罗蜜多时。于此所摄诸有情所生大欢喜。是诸有情由此所摄虽生欢喜。犹不能及如是意乐。是名菩萨于所修行戒波罗蜜多乃至慧波罗蜜多欢喜意乐。又诸菩萨修行如是戒波罗蜜多乃至慧波罗蜜多时。观此所摄一切有情。于我己身有大恩德。不见己身于彼有恩。由资助我阿耨多罗三藐三菩提故。如是意乐是名菩萨于所修行戒波罗蜜多乃至慧波罗蜜多恩德意乐。又诸菩萨修行如是戒波罗蜜多乃至慧波罗蜜多时。虽于无量诸有情所兴大戒福乃至慧福。而不希报恩当来果报。如是意乐是名菩萨于所修行戒波罗蜜多乃至慧波罗蜜多无染意乐。又诸菩萨修行如是戒波罗蜜多乃至慧波罗蜜多时。以所修行广大戒聚乃至慧聚所得果报。施诸有情不自为己。又以此福共诸有情回向阿耨多罗三藐三菩提。如是意乐是名菩萨于所修行戒波罗蜜多乃至慧波罗蜜多善好意乐

依止方便修复有三种。谓由无分别智观察三轮皆清净故所以者何。由此方便一切作意所修诸行速成满故。依止自在修亦有三种。谓身自在故。行自在故。说自在故。身自在者。谓诸如来自性受用。二身行自在者。谓诸如来变化身。由此能示现一切有情一切种同法行故。说自在者。谓能宣说六波罗蜜多一切种差别无有滞碍故。差别云何。谓由十八种任持以显六波罗蜜多差别。何等十八。谓身任持。心任持。善法任持。善任持。菩提任持。悲任持。不舍有情任持。舍下劣心任持。无生法忍任持。善根方便任持。善根圆证任持。善根无尽任持。无厌倦任持。诸所思事成满任持。御众业任持。证入大地任持。引发佛性任持。建立佛事任持。施等六种各三差别。如其次第三三所摄。施三种者。谓财施。无畏施。法施。戒三种者。谓律仪戒。摄善法戒。饶益有情戒。忍三种者。谓耐怨害忍。安受苦忍。谛察法忍。精进三种者。谓被甲精进。方便精进。饶益有情精进。静虑三种者。谓现法乐住静虑。引发神通静虑。饶益有情静虑。慧三种者。谓缘世俗慧。缘胜义慧。缘有情慧。当知财施能任持身。由饮食等诸资生具摄益受者所依身故。无畏施能任持心。安慰他心离忧怖故。如是余句随义应思。下劣心者。谓诸菩萨厌生死苦同二乘心。由安受苦忍所任持故方舍此心。善根无尽者。谓穷生死际恒作一切有情利益安乐事。乃至于无余涅槃界亦不弃舍。由饶益有情精进所任持故。御众业者。谓依止内证故。教授教诫所化有情。心未定者令其得定。心已定者令其解脱。由饶益有情静虑所任持故。证入大地者。谓先信解甚深教法。资粮圆满速能证入初极喜地。由缘世俗慧所任持故。所余易了故不重释

又差别者。谓施有七种。一根本施。谓种性位菩萨所有施波罗蜜多。依止种性而行施故。二弘誓施。谓发心位菩萨所有施波罗蜜多。依受大愿而行施故。三摄受施。谓自他利行位菩萨所有施波罗蜜多。四无执受施。谓观真实义位菩萨所有施波罗蜜多。以无施者等分别执受故。五无摄受施。谓威德位菩萨所有施波罗蜜多。虽不摄受外资生具。但由虚空藏等三摩地力。举手麾空随欲皆雨珍宝等物。六随所应施。谓成熟位菩萨所有施波罗蜜多。随所化宜而行施故。七广大施。谓最胜菩提位所有施波罗蜜多。以无上故。如施有七种。乃至慧亦尔。随其所应

摄云何。谓为摄菩萨地故。于中略说施等波罗蜜多。此摄略有四种。一种性摄。谓施波罗蜜多等种性相应随顺知。二发心摄。谓差别发心所摄故。发心有二种。谓无差别差别。无差别者。谓愿我当证阿耨多罗三藐三菩提。差别者。谓愿我施波罗蜜多速得圆满。乃至慧波罗蜜多速得圆满。当知此中由差别发心摄诸波罗蜜多。此是彼因故。三自他利摄。谓由施摄故摄受一切富乐自在。是名自利摄。由此施故引摄财物为饶益他。是名他利摄。如是所余摄相随义应知。四胜义摄。此复多种。谓或依法界说。以真如是施等共相故。或依智资粮说。以能成办一切智器故。或依智摄受说。以能成满一切智故。或依知随转说。以五波罗蜜多随慧波罗蜜多转故。或依智相说。以慧波罗蜜多是正智自体故。如是胜义以真如及正智为体故。能摄施等。由此略说。所余摄义如理应思

所治者。谓施等六如其次第。以悭吝犯戒忿恚懈怠散乱恶慧为所治。复次乃至一切波罗蜜多所摄善法彼所对治及所知障。皆是波罗蜜多所治

功德者。谓依五果无量无边称赞胜利。皆名功德。谓能永断自所对治。是诸波罗蜜多离系果。于现法中由此施等摄受自他。是士用果于当来世后后增胜展转生起。是等流果。大菩提是增上果。感大财富往生善趣。无怨无坏多诸喜乐。有情中尊身无损害。广大宗族随其次第。是施等波罗蜜多异熟果。更互决择者略有三种。一方便。二差别。三差别显示。方便者。谓施方便中一切可得。如舍内外一切身财。是施方便。此方便中若舍一切。是施波罗蜜多。即于此中若慈悲心。遮防一切损害逼迫恼乱他性。是戒波罗蜜多。即于此中忍受遮碍损害疲倦。是忍波罗蜜多。即于此中数数发起勇励施心。是精进波罗蜜多。即于此中其心纯善。系心一境不外流散。是静虑波罗蜜多。即于此中善取施行如实因果不取异见。是慧波罗蜜多。如是乃至慧波罗蜜多方便中。随其所应当善建立。由无畏施一切处有施故

差别者略有四种。一自体差别。二助伴差别。三劝赞差别。四种殖差别。施等波罗蜜多自体差别者。如其次第。以弃舍防护堪耐策勤心住决择为体。助伴差别者。谓施等方便中余波罗蜜多悉皆随转。如前广说。劝赞差别者。谓于施等劝励赞美随喜庆悦。种殖差别者。谓于他相续中建立施等波罗蜜多。此中施波罗蜜多是财施。余五波罗蜜多是无畏施。一切六是法施。皆于他相续中种殖故。差别显示者。谓由一行等差别显示施等波罗蜜多。如有问言。若施波罗蜜多亦戒波罗蜜多耶。设戒波罗蜜多亦施波罗蜜多耶。为答此问应作顺后句。谓所有戒波罗蜜多皆是施波罗蜜多。或有施波罗蜜多非戒波罗蜜多。谓戒波罗蜜多所不摄施波罗蜜多。如是乃至以慧波罗蜜多对施波罗蜜多。皆应作顺后句。余互相望亦如理应思。此中依始业地渐次修者。说后必待前前不待后。是故皆作顺后句。若已串习六种顿修皆互相摄。如菩萨地说。摄善法戒者。谓六波罗蜜多若依纯杂相资助说应作四句。复次诸所有施皆波罗蜜多耶。设波罗蜜多皆是施耶。为答此问应作三句。或有是施非波罗蜜多。谓所行施不回向大菩提。或有亦施亦波罗蜜多。谓所行施等回向大菩提。或有非施非波罗蜜多。谓除上所说法。如是乃至依慧波罗蜜多。一一皆应作四句如理当思。复次一切行施皆能生施波罗蜜多种类福耶。此应作四句。初句。谓所行施不回向大菩提。第二句。谓于施波罗蜜多劝励赞美随喜庆悦。第三句谓所行施回向大菩提。第四句。谓除上尔所相。如是乃至依慧波罗蜜多。各作四句如理应思

复次何缘说方广分为广大甚深耶。由一切种智性广大甚深故。谓此所得一切种智性果最广大甚深故。因受果名。是故别说方广分为广大甚深

复次何缘一分众生。于方广分广大甚深不生胜解。反怀怖畏耶。由远离法性故。未种善根故。恶友所摄故。法性者。谓菩萨种性是彼自体故。由一分众生无菩萨种性故。心性下劣于广大甚深教不能胜解。是故怖畏。又一分众生虽有菩萨种性。而于大菩提未种正愿等诸善根故。于此不能胜解。是故怖畏。又一分众生虽已种善根。而为诽谤大乘众生。恶友所摄故。于此不能胜解。是故怖畏。复次何缘一分众生于方广分广大甚深虽生胜解。而不得出离耶。由深安住自见取故。常坚执着如言义故。深安住自见取者更不进求了义经故。常坚执着如言义者恒坚封执不了义经故。如闻一切法毕竟无自性言故。便拨一切诸法性相皆无所有。如是于余不了义经坚执如言义亦尔。是故虽信大乘而不得出离。以大乘经由种种意说故。依此密意薄伽梵于大法镜经中说如是言。若诸菩萨随言取义。不如正理思择法故。便生二十八不正见。何等名为二十八不正见耶。谓相见。损减施设见。损减分别见。损减真实见。摄受见。转变见。无罪见。出离见。轻毁见。愤发见。颠倒见。出生见。不立宗见。矫乱见。敬事见。坚固愚痴见。根本见。于见无见见。舍方便见。不出离见。障增益见。生非福见。无功果见。受辱见。诽谤见。不可与言见。广大见。增上慢见。相见者。谓闻大乘经中所说一切诸法皆无自性无生无灭本来寂静自性涅槃等言。不善密意但随此言义便生胜解。谓佛所说一切诸法定无自性定无生等。执着如是无性等相。是名相见。彼执着如是无性等相时。便谤三自性。谓遍计所执自性。依他起自性。圆成实自性。遍计所执自性者。谓诸愚夫于色等相。周遍计度起增益执。谓此是色乃至此是涅槃。此所执义无实无体。唯有名言之所施设。依他起自性者。谓即此色等唯是虚妄分别自体。又因果性或异不异。圆成实自性者。谓一切法真如实性。于此三性起诽谤行。即次三见。谓损减施设见。损减分别见。损减真实见。彼如是诽谤一切种一切法时。为欲成立此邪见故。便复摄受少分道理。又于所有开示离言诸法实性了义契经。广设方便皆悉转变令顺己见。如是二种即次二见谓摄受见。转变见。彼又起如是见。若依此见行善不善。定皆无罪无有过失。一切所行皆归妙善。先所积习一切障垢皆得出离。如是二种即次二见。谓无罪见。出离见。彼如是执自见已。便于此见相违安立蕴等诸法。声闻藏中妄生轻毁。又于不信如是邪见声闻人等深生憎嫉。如是二种即次二见。轻毁见。愤发见。彼又随顺自恶邪见。谓我当建立如实空无相无愿。于非彼相起彼相想。而于彼相颠倒建立。又作是思惟。若能悟入如是法性。或令他入一切皆生无量功德。如是二种即次二见。谓颠倒见。出生见。若他于彼所起恶见如理诘责。彼于尔时竟不乐欲。建立自宗。反以讥弄妄理诘责于他。如是二种即次二见。谓不立宗见。矫乱见。彼又起如是增上慢。谓若能如是修行。是真供养恭敬诸佛世尊。如是见者名敬事见。诸有善达无倒法性者。为令舍离彼恶见故。虽以种种真实成立道理方便开悟。坚守愚见曾无舍心。谓唯此真余并邪妄。如是见者名坚固愚痴见。如上所说。诸见所有习气粗重。是名根本见。为欲开示如上所说十七种见诸过失门。复说余见。谓即相见名于见无见见。此实坚执无性等相而起。不执一切相想故。即损减施设见。损减分别见。损减真实见。名舍方便见。由彼诽谤一切法性。于勤精进起无用想故。即摄受见转变见。名不出离见。非方便修学不能证果故。即无罪见出离见。名障增益见。所行邪僻无容尽障故。即轻毁见愤发见。名生非福见。由于正法同梵行所起邪行门。便能引发大衰损故。即颠倒见出生见名无功果见。由所安立非正法性授者受者俱不能证胜进果故。即不立宗见矫乱见。名受辱见。非理兴论无宜得胜故。即敬事见名诽谤见。所不应说强增益故。即坚固愚痴见名不可与言见。邪执空者不应与言。徒设多词终无所益故。即根本见名广大见。由此当来诸恶见类转增广故。即上所说二十七见。皆名增上慢见。并能发起虚妄无实增上慢故。此云何知。由彼经中即次后说。如是诸见十七即十。十即十七。二十七即一。一即二十七故

复次如方广分说。一切诸法皆无自性。此言依何密意说。谓无自然性故。无自体性故。无住自体故。无如愚夫所取相性故。无自然性者。由无自然性故说无自性。不遮待缘性故说无自性。无自体性者。由此自体曾所经有。即此自体不可复有故。说为无性。无住自体者。体虽现在未至坏相次必当灭。体无住义故说无性。无如愚夫所取相性者。如诸愚夫未见谛者。依止名言戏论熏习门。妄取诸法性相远离。如是所取自性故说无性

复次于遍计所执自性。相无性故。于依他起自性。生无性故。于圆成实自性。胜义无性故。更依异门显无性义故言。复次一切法者即三自性。谓遍计所执自性。依他起自性。圆成实自性。遍计所执自性定无自相。自相无故名相无性。相无性故名为无性。依他起自性待众缘故非自然生。无自然生性故名生无性。生无性故名为无性。圆成实自性清净所缘故。于依他起中无遍计所执相所显自体故。胜义为自体故。无性所显故名胜义无性。胜义无性故名为无性。由此道理是故如来说。一切法皆无自性。非一切种性相俱无说为无性

又彼说言。一切诸法无生无灭本来寂静自性涅槃。此依何密意说。如无自性无生亦尔。如无生无灭亦尔。如无生无灭本来寂静亦尔。如本来寂静自性涅槃亦尔

复次有四种意趣。由此意趣故。方广分中一切如来所有意趣应随决了。何等为四。谓平等意趣。别时意趣。别义意趣。众生意乐意趣。平等意趣者。如说我于尔时曾名胜观如来应正等觉。与彼法身无差别故。别时意趣者。如说若有愿生极乐世界皆得往生。若暂得闻无垢月光如来名者。即于阿耨多罗三藐三菩提决不退转。如是等言意在别时故。别义意趣者。如说一切诸法皆无自性。如是等言不可如文便取义故。众生意乐意趣者。谓于一善根。或时称赞。为令欢喜勇猛修故。或时毁呰。为遮得少善生喜足故。为贪行者称赞佛土富乐庄严。为慢行者称赞诸佛或有增胜。为恒悔恼障修善者。说如是言。于佛菩萨虽行轻毁。然彼众生亦生天趣。为不定种性者。舍离声闻下劣意乐故。记大声闻当得作佛。又说一乘更无第二。复次有四种秘密。由此秘密故。于方广分中一切如来所有秘密应随决了。何等为四。谓令入秘密。相秘密。对治秘密。转变秘密。如是四种于大乘中略摄如来一切所说秘密道理。令入秘密者。谓于声闻乘说色等诸法皆有自性。为令无怖畏渐入圣教故。相秘密者。谓于三自性说一切法皆无自性无生无灭等。对治秘密者。谓为调伏诸过失者。如来宣说种种密教。如为对治八种障故说最上乘。何等为八。谓轻佛法懈怠少善生喜足贪慢行恶作不定性差别。广说指事随其所应如四意趣说。转变秘密者。谓经所说隐密名言。如说于不坚坚觉深住于颠倒。极烦恼所恼。得最上菩提此中密意者。谓于不散动起坚固胜觉。所以者何。坚有二义。一贞实。二散动。由此散动令心刚逸故亦名坚。深住于颠倒者。谓翻常乐我净四倒为无常等故名颠倒。于此不退故名深住。极烦恼所恼者。谓于长时精勤苦行极为劳倦所逼恼故。得最上菩提者。若具如上所说。三事定速当证无上菩提。复次方广分中于法三摩地善巧菩萨相云何可知。谓由五种因故。一刹那刹那消除一切粗重所依。二出离种种想得乐法乐。三了知无量无分别相大法光明。四顺清净分无分别相恒现在前。五能摄受转上转胜。圆满成就佛法身因。如是五种依诸菩萨三种称赞功德说。谓奢摩他称赞功德。毗钵舍那称赞功德。此二俱分称赞功德。奢摩他称赞功德复有二种。一刹那刹那胜进轻安无有间缺。遍所依故。刹那刹那消除一切粗重所依。二胜解谛观一切教法无有差别。同一味故。远离种种蕴界处等诸义相想。得契经等喜乐法乐。毗钵舍那称赞功德亦有二种。一随所择法无有间缺。不忘失故。由忆念门于无量无分别相契经等法。以慧照了二转依前所有色像无分别无加行相恒现在前。第五一种。是此二俱分称赞功德法身者。谓所知障永断转依所摄。此于第十地名圆满。于如来地名成就。为令法身速得圆满成就故。引殖转上转胜等流习气故名摄受。彼因如是五种。即显五修能得五果。何等为五。谓息相修。和合修。无相修。无功用修。转相修

问声闻藏法菩萨藏法等从法身所流。何故众生以香鬘等供养菩萨藏法。便生广大无边福聚。非声闻藏法耶。答以菩萨藏法是一切众生利益安乐所依处故。能建大义故。无上无量大功德聚所生处故

大乘阿毗达磨杂集论卷第十二大乘阿毗达磨杂集论卷第十三

        安慧菩萨糅释上集论

        大唐三藏法师玄奘奉　诏译

    决择分中得品第三之一

云何得决择。略说有二种。谓建立补特伽罗。建立现观。前为能证。后是所证。补特伽罗虽非实有。由四种缘是故建立。谓言说易故。顺世间故。离怖畏故。显示自他具德失故。言说易者。若于无量色等差别无量差别相想法中。总合建立一假有情。即呼召往来等。种种言说遂不为难。顺世间者。非诸世间。唯依法想而起言说。多分依有情想而起言说。是故圣者为化世间。必应同彼方便建立补特伽罗。离怖畏者。世间有情未会甚深缘起法性。若闻一切有情无我。便生怖畏不受正化。显示自他具德失者。若离假立有情差别。唯说诸法染净相者。是则一切无有差别。不可了知如是身中如此过失若断未断。如是身中如此功德若证未证。是故建立补特伽罗

云何建立。略有七种。谓病行差别故。出离差别故。任持差别故。方便差别故。果差别故。界差别故。修行差别故。病行差别复有七种。谓贪行嗔行痴行慢行寻思行等分行薄尘行。出离差别有三种。谓声闻乘独觉乘大乘。任持差别有三种。谓未具资粮已具未具资粮已具资粮。方便差别有二种。谓随信行随法行。果差别有二十七。谓信解见至身证。慧解脱俱解脱。预流向预流果。一来向一来果。不还向不还果。阿罗汉向阿罗汉果。极七返有。家家一间。中般涅槃。生般涅槃。无行般涅槃。有行般涅槃。上流。退法阿罗汉。思法阿罗汉。护法阿罗汉。住不动阿罗汉。堪达阿罗汉。不动法阿罗汉。界差别者。谓欲界异生有学无学。如欲界有三色界无色界亦尔。又有欲色界菩萨。又有欲界独觉。不可思议如来修行差别略有五种。一胜解行菩萨。二增上意乐行菩萨。三有相行菩萨。四无相行菩萨。五无功用行菩萨。如是等补特伽罗无量差别。贪行补特伽罗者。谓有猛利长时贪欲。虽于下劣可爱境界。而能发起上品贪故。起即长时无断绝故。如贪行者乃至寻思行者亦尔。各随自境。猛利长时如理配释

等分行补特伽罗者。谓住自性位烦恼。远离猛劣住平等位诸烦恼故。随境界势力烦恼现行故

薄尘行补特伽罗者。谓住自性位微薄烦恼。如前所说自性位烦恼相。今此烦恼望彼是微薄故。虽于增上所缘境界。而微薄性烦恼现行。昔所修习胜对治力所摧伏故

声闻乘补特伽罗者。谓住声闻法性若定不定性是钝根。自求解脱发弘正愿。修厌离贪解脱意乐。以声闻藏为所缘境。精进修行法随法行得尽苦际。当知此中以种性根愿意乐境界行果差别说声闻乘。对独觉菩萨根性。说此为钝。若不尔即与随法行等利根言相违

独觉乘补特伽罗者。谓住独觉法性若定不定性是中根自求解脱发弘正愿。修厌离贪解脱意乐。及修独证菩提。意乐即声闻藏为所缘境。精进修行法随法行。或先未起顺决择分。或先已起顺决择分。或先未得果。或先已得果。出无佛世。唯内思惟圣道现前。或如麟角独住。或复独胜部行得尽苦际。若先未起顺决择分亦不得果。如是方成麟角独住。所余当成独胜部行

大乘补特伽罗者。谓住菩萨法性若定不定性是利根。为求解脱一切有情。发弘大愿修无住处涅槃意乐。以菩萨藏为所缘境。精进修行法随法行。成熟众生修净佛土。得受大记。证成无上正等菩提。得受大记者。谓住第八菩萨地。证得无生法忍故

未具资粮补特伽罗者。谓缘谛增上法为境。发起软品清信胜解。成就软品顺解脱分。未定生时

已具未具资粮补特伽罗者。谓缘谛增上法为境。发起中品清信胜解。成就中品顺解脱分。已定生时

已具资粮补特伽罗者。谓缘谛增上法为境。发起上品清信胜解。成就上品顺解脱分。即此生时

又未具资粮者。谓缘谛增上法为境。于诸谛中成就下品谛察法忍。成就下品顺决择分。未定生时

已具未具资粮者。谓缘谛增上法为境。于诸谛中成就中品谛察法忍。成就中品顺决择分。已定生时

已具资粮者。谓缘谛增上法为境。于诸谛中成就上品谛察法忍。成就上品顺决择分。即此生时

如是三种补特伽罗。由成就顺解脱分顺决择分各三品故。约能引生顺决择分。及谛现观如其次第。未定已定即此生时。于谛增上法清信胜相。是顺解脱分。即于此法谛察法忍相。是顺决择分。如其次第信增上故。慧增上故。此中三品顺决择分者。谓除世第一法。由世第一法性唯一刹那必不相续。即此生时定入现观非前位故。从下中品顺解脱分顺决择分有可退义。此唯退现行非退习气。已依涅槃先起善根者。不复新起故。依此下品顺解脱分善根薄伽梵说。若有具世间增上品正见。虽经历千生不堕三恶趣

又有四种顺解脱分。一者依凭顺解脱分。二者胜解顺解脱分。三者爱乐顺解脱分。四者趣证顺解脱分。从善法欲乃至为求解脱所有善根。皆名依凭顺解脱分。于彼相应教法所有胜解俱行善根。是名胜解顺解脱分。缘解脱境作意相续清净喜俱所有善根。是名爱乐顺解脱分。即于此生决定发起顺决择分所有善根。是名趣证顺解脱分

复有六种顺决择分。谓随顺顺决择分。胜进顺决择分。通达顺决择分。余转顺决择分。一生顺决择分。一座顺决择分。若最初所起缘谛境行下品善根。是名随顺顺决择分。即此善根转成中品。是名胜进顺决择分。望前下品是增胜故。即此善根增至上品。于此生中决定堪能通达谛理。是名通达顺决择分。又即此位中不定种性者。为回向最胜菩提。及诸独觉为求无师自证菩提。转趣余生。是名余转顺决择分。若于此生定能通达。是名一生顺决择分。若于此座定能通达。是名一座顺决择分

随信行补特伽罗者。谓资粮已具性是钝根。随顺他教修谛现观

随法行补特伽罗者。谓资粮已具性是利根。自然随顺谛增上法修谛现观

信解补特伽罗者。谓随信行已至果位。见至补特伽罗者。谓随法行已至果位。身证补特伽罗者。谓诸有学已具证得八解脱定。即不还果说名身证。由身证得八解脱定。具足住故。八解脱者。谓有色观诸色等。后当广说

慧解脱补特伽罗者。谓已尽诸漏而未具证八解脱定。唯究竟断慧。所对治烦恼障故

俱分解脱补特伽罗者。谓已断诸漏及具证八解脱定。由烦恼障分及定障分俱得解脱故。预流果向补特伽罗者。谓住顺决择分位。及住见道十五心刹那位。此中意说。始从一座顺决择分乃至。未得初果。皆名预流果向。豫流果补特伽罗者。谓住见道第十六心刹那位。即此见道。亦名入正性决定。亦名于法现观。问谁于见道最后心位得初果耶。答若于欲界未离欲者。后入正性决定得预流果。谓次第者。虽少分离欲亦名未离欲。彼后入正性决定。至第十六心位得预流果。若倍离欲者后入正性决定得一来果。谓先用世间道已断欲界修道所断六品烦恼。名倍离欲。彼后入正性决定。至第十六心位得一来果。若已离欲者后入正性决定得不还果。谓先用世俗道已断欲界修道所断九品烦恼。名已离欲。彼后入正性决定。至第十六心位得不还果。问若已永断见道所断一切烦恼得预流果。何故但言永断三结得预流果耶。答最胜所摄故。由此三种障解脱。得最为殊胜。所以者何。于解脱是不发趣因故。虽已发趣复为邪出离因故。及不正出离因故。由萨迦耶见执五取蕴为我我所深生爱乐故。于大苦聚不生厌背。于胜解脱无发趣心。或有众生。虽已发趣解脱。然由戒禁取及疑。僻执邪道疑正道故。便邪出离及不正出离。又此三结是迷所知境因故。迷见因故。迷对治因故所以者何。由萨迦耶见迷所知境。于大苦聚虚妄增益我我所相故。由戒禁取迷能知见。于颠倒见谓为清净出离因故。由疑迷正对治。于三宝所不决定故

一来果向补特伽罗者。谓于修道中已断欲界五品烦恼安住彼道。所以者何。由见道后已断欲界乃至中中品烦恼及住彼断道故

一来果补特伽罗者。谓于修道中已断欲界第六品烦恼安住彼道。所以者何。由已永断中软品烦恼断道究竟。建立此故

不还果向补特伽罗者。谓于修道中已断欲界第七第八品烦恼安住彼道。所以者何。由一来果后已断欲界软上软中品烦恼及住彼断道建立此故

不还果补特伽罗者。谓于修道中已断欲界第九品烦恼安住彼道。所以者何。由彼永断欲界软软品烦恼断道究竟。建立此故。问若已永断一切见道所断烦恼。及已永断欲界修道所断一切烦恼得不还果。何故但言永断五顺下分结得不还果耶。答最胜所摄故。云何最胜。由此五结能为下趣下界胜因故名最胜。所以者何下趣者。谓地狱畜生饿鬼。下界者。谓欲界。以萨迦耶见戒禁取疑为最胜因。令诸有情不越下趣故。以贪欲嗔恚为最胜因。令诸有情下越下界故

阿罗汉果向补特伽罗者。谓已永断有顶八品烦恼安住彼道

阿罗汉果补特伽罗者。谓已永断有顶第九品烦恼安住彼究竟道。问若阿罗汉永断三界一切烦恼。何故但言永断一切五顺上分结得阿罗汉果耶。答最胜所摄故。云何最胜。由此五结是取上分因及不舍上分因故名最胜。所以者何。由色无色爱取欲界上色无色界生故。由掉慢无明不舍此上生故。以爱慢疑上静虑者。为彼所恼故

极七返有补特伽罗者谓即豫流。于人天生往来杂受。极至七返得尽苦际

家家补特伽罗者。谓即预流。或于天上或于人中。从家至家得尽苦际。所以者何。即预流果进至一来果向。或于天上或于人中。决定往来极受二有方般涅槃故

一间补特伽罗者。谓即一来。或于天上唯受一有得尽苦际。所以者何。即一来果进至不还果向。或于天上唯受一有得般涅槃故。唯有一隙容此一生故名一间

中般涅槃补特伽罗者。谓生结已断起结未断。或中有才起。即便圣道现前得尽苦际。或中有起已。为趣生有才起思惟。即便圣道现前得尽苦际。或思惟已发趣生有。未到生有即便圣道现前得尽苦际。此中显示三种中般。由烦恼力往趣生处令生有相续。此烦恼已尽。唯由随眠力令命终后诸蕴续起。此随眠余犹未尽。或中有才起由串习力圣道现前断余随眠。即于此位入般涅槃。或中有起已。为往生有才发思惟。圣道现前断余随眠入般涅槃。或思惟已往生有处。未得生有圣道现前。断余随眠入般涅槃。如是三种望生有处。未发才发已远去位差别建立。随顺七善丈夫趣经

生般涅槃补特伽罗者。谓二结俱未断才生色界已。即便圣道现前得尽苦际

无行般涅槃补特伽罗者。谓生彼已不由加行。圣道现前得尽苦际。不由加行者。由宿串习力。无漏圣道任运现前。无功用故

有行般涅槃补特伽罗者。谓生彼已由加行力。圣道现前得尽苦际。由加行者。与上相违故

上流补特伽罗者。谓于色界地地中皆受生已。乃至最后入色究竟。于彼无漏圣道现前得尽苦际。复有乃至往到有顶圣道现前得尽苦际。此中显示二种上流。一极至色究竟。二极至有顶。极至色究竟者。谓多爱味补特伽罗。由多生起软等静虑差别爱味故始从梵众天乃至色究竟。于一切处次第各受一生。乃至最后入色究竟得般涅槃。极至有顶者。谓不杂修第四静虑。唯避净居。如前次第生一切处。乃至有顶方般涅槃。又杂修第四静虑有五品差别。一下品修。二中品修。三上品修。四上胜品修。五上极品修。由此五品杂修第四静虑故。如其次第生五净居

退法阿罗汉者。谓钝根性。若游散若不游散。若思惟若不思惟。皆可退失现法乐住。思惟者欲害自身。不思惟者不欲害自身。退现法乐住者。谓退世间静虑等定

思法阿罗汉者。谓钝根性若游散若不游散。若不思惟即可退失现法乐住。若思惟已能不退失

护法阿罗汉者。谓钝根性。若游散便可退失现法乐住。若不游散即能不退住。不动阿罗汉者。谓钝根性。若游散若不游散。皆能不退现法乐住。亦不能练根。练根者。谓转下钝根成上利根。是故不动法不说能练根。性是利根故

堪达阿罗汉者。谓钝根性。若游散若不游散。皆能不退现法乐住。堪能练根。不动法阿罗汉者。谓利根性。若游散若不游散。皆能不退现法乐住

欲界异生补特伽罗者。谓于欲界若生若长。不得圣法

欲界有学补特伽罗者。谓于欲界若生若长。已得圣法犹有余结

欲界无学补特伽罗者。谓于欲界若生若长。已得圣法无有余结。如欲界有三。如是色无色界各有三种随相应知

欲色界菩萨者。谓与灭离无色界生静虑相应住静虑乐。而生欲界或生色界。问何缘菩萨不生无色界。答若已证得最胜威德菩萨凡所受生。皆欲利益安乐众生。以无色界非成熟众生处故。灭离无色界生静虑者。谓能除遣无色界生所有胜定。住静虑乐者。谓不退静虑。由此菩萨善巧回转故。为欲成熟所化有情。或生欲界或生色界

欲界独觉者谓无佛出世时生于欲界。自然证得独觉菩提

不思议如来者。谓且于欲界始从示现安住睹史多天妙宝宫殿。乃至示现大般涅槃。示现一切诸佛菩萨所行大行。一切菩萨所行者。谓从示现睹史多天宫。乃至现大神变降伏魔军。诸佛所行者。谓从示现成等正觉。乃至示现大般涅槃

胜解行菩萨者。谓住胜解行地中。成就菩萨下中上忍。由其安住菩萨种姓。始从初发大菩提愿。乃至未入极欢喜地。未得出世真实内证故。名胜解行菩萨

增上意乐行菩萨者。谓十地中所有菩萨。由已证得出世内证清净意乐故。有相行菩萨者。谓住极喜离垢发光焰慧极难胜现前地中所有菩萨。由此六地虽不喜乐而为诸相所间杂故

无相行菩萨者。谓住远行地中所有菩萨。由此菩萨若作功用乃至随其欲乐。能令诸相不现行故

无功用行菩萨者。谓住不动善慧法云地中所有菩萨。由此菩萨已得纯熟无分别智故

复次如说预流补特伽罗。此有二种。一渐出离。二顿出离。渐出离者。如前广说。顿出离者。谓入谛现观已。依止未至定发出世间道顿断三界一切烦恼。品品别断唯立二果。谓预流果阿罗汉果。品品别断者。谓先顿断欲色无色界修道所断上上品随眠。如是乃至软软品。顿断三界者。如见道所断。非如世间道界地渐次品品别断。此义以何为证。如指端经说。诸所有色乃至识。若过去若未来若现在。广说乃至若远若近。总此一切略为一分一团一积一聚。如是略已。应观一切皆是无常一切皆苦。乃至广说。依如是观但可建立初后二果。由此二果如其次第。永断三界一切见修所断烦恼。无余所显故。不立第二第三两果。由此二果已见谛者。唯断欲界修道所断。有余无余所显故。又依如是顿出离者。如来于分别经中预流果无间即建立阿罗汉果。如是补特伽罗多于现法或临终时善办圣旨。设不能办由愿力故。即以愿力还生欲界。出无佛世成独胜果。设不办者未能无余离诸欲故。即以愿力生欲界者。彼能速证般涅槃故

建立现观略有十种。谓法现观。义现观。真现观。后现观。宝现观。不行现观。究竟现观。声闻现观。独觉现观。菩萨现观。法现观者。谓于诸谛增上法中已得上品清信胜解随信而行。所以者何。由于诸谛增上契经等法中从闻他音增上缘力。已得最后顺解脱分善根所摄上品清信胜解由得如是清信胜解故。说名以法现观现观诸谛

义现观者。谓即于诸谛增上法中已得上品。于诸谛境谛察法忍。此忍居顺决择分位。所以者何。由即于如上所说法中如理作意。增上缘力于苦等谛境。已得最后顺决择分善根所摄上品谛察法忍。此谛察法忍由三种如理作意所显发故。复成三品谓上软上中上上。上软者。谓即此生时软位。上中者。谓顶忍位。上上者。谓世第一法位

真现观者。谓已得见道十六心刹那位所有圣道。又于见道中得现观边安立谛世俗智。由出世智增上缘力长养彼种子故。名得此智而不现前。以见道十六心刹那无有间断。不容现起世间心故。于修道位此世俗智方现在前

后现观者。谓一切修道。由见道后一切世间出世间道皆名后现观故

宝现观者。谓于佛证净于法证净于僧证净。由佛圣弟子于三宝所已得决定证清净信。谓薄伽梵是真正等觉者。法毗奈耶是真善妙说。圣弟子众是真净行者

不行现观者。谓已证得无作律仪故。虽居学位而谓我今已尽地狱畜生饿鬼颠坠恶趣。我不复能造恶趣业感恶趣异熟。已得无作律仪者。谓已证得圣所爱戒所摄律仪。由得此故。此所对治地狱异熟等必不复行。由地狱等永尽不行故。名不行现观

究竟现观者。如道谛中究竟道说。谓已息一切粗重已。得一切离系得。如是等

声闻现观者。谓前所说七种现观。从闻他音而证得故。名声闻现观

独觉现观者。谓前所说七种现观。不由他音而证得故。名独觉现观

菩萨现观者。谓诸菩萨于前所说七现观中。起修集忍而不作证。为于声闻独觉调伏方便中得善巧故。哀恋众生。不于下乘而出离故。然于菩萨极喜地中入诸菩萨正性决定。是名菩萨现观

已说现观。差别今当说。问声闻菩萨现观有何差别。答略说有十一种。谓境界差别。任持差别。通达差别。誓愿差别。出离差别。摄受差别。建立差别。眷属差别。胜生差别。生差别。果差别

境界差别者。谓缘方广大乘为境故。任持差别者谓满大劫阿僧企耶。福智资粮圆满故

通达差别者。谓由补特伽罗法无我理增上法。方便所引出世间智。俱通达二无我故

誓愿差别者。谓能通达一切有情与己平等。犹如自身誓愿摄益故

出离差别者。谓依十地而出离故

摄受差别者。谓无住涅槃所摄受故

建立差别者。谓善修治诸佛净土故

眷属差别者。谓摄受一切所化众生为眷属故

胜生差别者。谓如世间腹所孕子继父种族令不断绝。如是菩萨绍隆佛种令不断绝。是佛真子相故

生差别者。谓于如来大集会中生故。果差别者。复有十种。谓转依差别。功德圆满差别。五相差别。三身差别。涅槃差别。证得和合智用差别。障清净差别。和合作业差别。方便示现成等正觉入般涅槃差别。五种拔济差别。转依差别者。谓染不染一切种所依粗重永断故。一切无上功德所依永转故

功德圆满差别者。谓力无所畏不共佛法等无边功德永成满故

五相差别者。谓清净等五相差别。一清净差别。谓永断一切烦恼并习气故。二圆净差别。谓遍修治佛净土故。三身差别谓法身圆满故。四受用差别。谓一切时处大集会与诸菩萨受用种种大法乐故。五业差别。谓随其所应起种种变化。遍于十方无量无边诸世界中作诸佛事故

三身差别者。谓证得圆满自性受用变化身故

涅槃差别者。谓于无余涅槃界为欲利乐一切有情。一切功德无断绝故

证得和合智用差别者。谓证得最极清净法界一味故。于彼能依一切种妙智用一一佛功能等一切佛功能故

障清净差别者。谓永断一切烦恼障所知障故

和合作业差别者。谓化导一一有情作用。皆一切佛增上力故

方便示现成等正觉入般涅槃差别者。谓于十方一切世界。随其所应。乃至后际数数示现成正觉等。令一切所化众生成熟解脱故

五种拔济差别者。谓拔济灾横等五事。一拔济灾横。谓如来入城邑等时。令盲聋等得眼耳等。二拔济非方便谓令得世间正见远离一切邪恶见故。三拔济恶趣。谓令生见道越诸恶趣故。四拔济萨迦耶。谓令证阿罗汉果永脱三界故。五拔济乘。谓令诸菩萨不乐下乘故

问如经说。四无量等最胜功德何现观所摄耶。答后现观究竟现观所摄。所以者何。如是最胜功德。诸圣弟子等或于修道或究竟道之所发起。是故二现观所摄。彼复云何谓无量解脱胜处遍处无诤愿智无碍解神通相随显清净力无畏念住不护无忘失法永断习气大悲十八不共佛法一切种妙智。如是等功德如来于诸经中。或依声闻乘说。或依大乘说。此诸功德随其所应。略以五门显示其相。谓所依境界行相自体助伴

无量者。谓四无量。一慈无量。二悲无量。三喜无量。四舍无量。慈云何。谓依止静虑于诸有情与乐相应意乐。住具足中若定若慧。及彼相应诸心心法。此中显慈无量。以静虑为所依。有情为境界。愿彼与乐相应为行相。定慧为自体。一切功德皆奢摩他毗钵舍那所摄故。诸心心法为助伴。当知悲等一切功德随其所应亦尔。悲云何。谓于诸有情离苦意乐。住具足中若定若慧。余如前说所依自体助伴与慈相似故。喜云何。谓于诸有情不离乐意乐。住具足中若定若慧。余如前说。舍云何。谓依止静虑于诸有情利益意乐。住具足中若定若慧。余如前说。利益意乐者。谓于与乐相应等有情所弃舍爱等。作是思惟。当令彼解脱烦恼。如是意乐名舍行相。利益意乐行相圆满。名住具足

解脱者。谓八解脱。广说如经。云何有色观诸色解脱。谓依止静虑于内未伏见者色想。或现安立见者色想。观所见色。住具足中若定若慧。及彼相应诸心心法。乃至为解脱变化障。有色者。谓于内身未依无色定伏除见者色想故。或见者色想。安立现前故。观诸色者。谓以意解观见好恶等色故。解脱者。谓能解脱一切变化障故

云何内无色想观外诸色解脱。谓于内已伏见者色想。或现安立见者无色想。观所见色住具足中若定若慧。余如前说。内无色想者。谓于内身已依无色定伏除见者色想故。或见者无色想。安立现前故。谓见者名想现在前行。余如前释

云何净解脱身作证具足住。谓于内净不净诸色。已得展转相待想展转相入想展转一味想故。于彼已得具足中若定若慧。余如前说。乃至为解脱净不净变化烦恼生起障。此中显示于净不净诸色。依展转相待想展转相入想。得展转一味想。所以者何。待诸净色于余色中谓为不净。待不净色于余色中谓为清净。非不相待。何以故。唯见一类时净不净觉无故。又于净中不净性所随入。于不净中净性所随入。何以故。于薄皮所覆共谓为净。中现有发毛等三十六种不净物故。如是展转总一切色合为一味清净想。解如是已得随所乐色。解脱自在者能断净不净色变化障及于此中烦恼生起障。何等名于变化烦恼。谓于净色变化加行功用。与不净色变化相违故

云何无边虚空处解脱。谓于随顺解脱无边虚空处。住具足中若定若慧。余如前说。如无边虚空处解脱。无边识处无所有处非想非非想处解脱亦尔。乃至为解脱寂静解脱无滞碍障。如是四种若圣弟子所得能顺无漏。是清净性方名解脱。解脱爱味故。寂静解脱者。谓超色无色于中清净。名无滞碍。味着无色是此障

云何想受灭解脱。谓依止非想非非想处解脱。超过诸余寂静解脱。住于似真解脱具足住中心心法灭。为解脱想受灭障。此显想受灭解脱。以非想非非想处为所依。无境界行相助伴。心心法无故。以心心法灭为自体。又此解脱似真解脱。圆满为性。以圣弟子由出世间道已得转依。诸心心法暂不现起。于此位中极寂静故。染污意不现行故

此八解脱亦名圣住。诸圣所住故。然诸圣者多依二住。谓第三第八以最胜故。是故经中于此二解脱有身作证具足住言。非余由此二种。如其次第。有色无色解脱障断无余故。证得圆满转依故。说名最胜

胜处者。谓八胜处。广说如经。前四胜处由二解脱所建立后四胜处由一解脱所建立。从彼所流故。所以者何。谓内有色想观外色少。若好若恶若劣若胜。于彼诸色胜知胜见得如实想。是初胜处。内有色想观外色多若好若恶。广说乃至得如实想。是第二胜处。此二胜处从有色观诸色解脱所出。内无色想观外色少。广说乃至得如实想。是第三胜处。内无色想观外色多。广说乃至得如实想。是第四胜处。此二胜处从内无色想观外诸色解脱所出。是故前四胜处。由二解脱所建立。内无色想观外诸色。若青青显青现青光。犹如乌莫迦花。或如婆罗痆斯深染青衣。若青青显青现青光。如是内无色想观外诸色。若青乃至青光亦尔。于彼诸色胜知胜见得如实想。是第五胜处。内无色想观外诸色。若黄乃至黄光。犹如羯尼迦花。或如婆罗痆斯深染黄衣。若黄广说乃至得如实想。是第六胜处。内无色想观外诸色。若赤乃至赤光。犹如般豆时缚迦花。或如婆罗痆斯深染赤衣。若赤广说乃至得如实想。是第七胜处。内无色想观外诸色。若白白显白现白光。犹如乌沙斯星色。或如婆罗痆斯极鲜白衣若白白显白现白光。如是内无色想观外诸色。若白白显白现白光亦尔。于彼诸色胜知胜见得如实想。是第八胜处。如是四胜处从净解脱身。作证具足住所出。此中解脱是意解所缘。胜处是胜伏所缘。少多等境随意自在。或令隐没故或随欲转故少色者。有情数色。其量小故多色者。非有情数色。舍林地山等其量大故。好色恶色者。净不净显色所摄。劣色胜色者。若人若天随其次第。于彼诸色胜者自在转故。知者由奢摩他道故。见者由毗钵舍那道故。得如实想者谓于已胜未胜中得无增上慢想故。若青者是总句青显者是俱生青。青现者是和合青。青光者。谓彼二所放鲜净光青。如青黄赤白广说亦尔。于一处说二譬喻者为显俱生和合二显色故。谓若青者总举花衣二青。青显者依花青说。以俱生故。青现者依衣青说。以和合方成故。青光者依二种说。由彼二种俱有鲜净光故。如是二譬喻中若青青显等。总句释句如相应知。如青黄等亦尔。余如解脱中说。何等为余。谓内有色想观外色等。如有色观诸色等随相应释。已说胜处胜所缘境界

遍处者。谓于遍满住具足中若定若慧。及彼相应心心法。是名遍处。遍满者其量广大周普无边。此复十种。谓地水火风青黄赤白无边空处无边识处皆悉遍满。问何故于遍处建立地等。答由此遍处观所依能依色皆遍满故。若于此中不建立地等。遍处者。即离所依大种亦不能观青等所造色为遍满相。是故为观所依能依皆悉遍满建立地等。余随所应如解脱中说。谓无边空处等

当知此中依解脱故造修。由胜处故起方便。由遍处故成满。若于彼得成满。即于解脱究竟

大乘阿毗达磨杂集论卷第十三大乘阿毗达磨杂集论卷第十四

        安慧菩萨糅释上集论

        大唐三藏法师玄奘奉　诏译

    决择分中得品第三之二

复次无诤者。谓依止静虑于防护他所应起烦恼住具足中。若定若慧及彼相应诸心心法。所以者何。住无诤者若欲往诣一切有情所应见处。先于自所住处以愿智力观彼有情。为于我身当来烦恼现前行不。如是观已。若知于我所当起爱恚悭嫉等烦恼。即便不往。若不当起乃往其所。以能护他诸烦恼诤令不当起。故名无诤

愿智者。谓依止静虑于为了所知愿具足中。若定若慧。余如前说。所以者何。由得愿智者为欲了知所有三世等所应知事。先于彼彼事发正愿心。愿我如实了知如是如是。次入增上静虑。从彼起已所愿成满。谓能了知所应知故

无碍解者。谓四无碍。一法无碍解。二义无碍解。三训词无碍解。四辩才无碍解

法无碍解者。谓依止静虑于一切法名差别无碍具足中。若定若慧。余如前说。名差别者。谓依无明等于无智无见不现观等差别名中。无碍具足若定若慧乃至广说。名法无碍解

义无碍解者。谓于诸相及意趣无碍具足中。若定若慧。余如前说。相者。谓诸法自相共相。意趣者。谓别义等。若于此中通达无碍具足。名义无碍解

训词无碍解者。谓于诸方言音及训释诸法言词无碍具足中若定若慧。余如前说。诸方言音者。谓无量国邑各随自想所起种种言音差别训释诸法。言词者。谓可破坏故名世间。可变坏故名色如是等。若于是中通达无碍。名训词无碍解

辩才无碍解者。谓于诸法差别无碍具足中。若定若慧。余如前说。诸法差别者。谓实有假有世俗有胜义有如是等。若于此中通达无碍。名辩才无碍解

神通者。谓六神通。一神境通。二天耳通。三心差别通。四宿住随念通。五死生通。六漏尽通。神境通者。谓依止静虑于种种神变威德具足中。若定若慧及彼相应诸心心法。种种神变威德具足者。谓变一为多等种种神变自在具足

天耳通者。谓依止静虑于随闻种种音声威德具足中。若定若慧。余如前说。种种声者。谓人天等声

心差别通者。谓依止静虑于入他有情心行差别威德具足中。若定若慧。余如前说。入他有情心行差别者。谓如实知有贪等心行差别

宿住随念通者。谓依止静虑于随念前际所行威德具足中若定若慧。余如前说。随念前际所行者。谓随念过去生名字种族等展转差别事

死生通者。谓依止静虑于观有情死生差别威德具足中。若定若慧。余如前说。观诸有情死生差别者。谓以天眼观诸有情死时生时好色恶色。当往善趣当往恶趣后际差别

漏尽通者。谓依止静虑于漏尽智威德具足中。若定若慧及彼相应诸心心法。漏尽智者。谓由此智通达一切漏尽方便。及诸漏尽威德具足者此智成满故

相随好者。谓依止静虑于相随好庄严所依示现具足中。若定若慧及彼相应诸心心法。并彼所起异熟果。所以者何。谓佛世尊由定慧增上力。为欲化度诸有情故。示现三十二大丈夫相。及八十种随好相庄严色身。然佛世尊非彼自体。以法身所显故。若诸菩萨能如是示现者。当知定慧为其自性。若所余于大集会中生者用彼所起异熟果为自性

清净者。谓四清净。一依止清净。二境界清净。三心清净。四智清净。如是四种一切相清净。唯佛世尊及已得大神通菩萨摩诃萨所得。依止清净者。谓依止静虑于随所欲依止取住舍具足中。若定若慧及彼相应诸心心法。取住舍具足者。谓随所欲生即便能取。既生彼已随其所欲。寿行分量即能留住。若欲舍诸寿行即便能舍。如其次第三种具足。境界清净者。谓于随所欲境界变化智具足中。若定若慧乃至广说。变化智具足者。谓先无今有色等名化转。先已生色等令成金银等名变。悟一切种境相差别名智。如其次第三种具足。心清净者。谓于如所欲三摩地门自在具足中。若定若慧。余如前说。由随所欲刹那刹那能入无量三摩地差别故。智清净者。谓依止静虑于随所欲陀罗尼门任持具足中。若定若慧。余如前说。陀罗尼门任持具足者。谓于四十二字中随思惟一字。以此为先便能证得一切法差别名言善巧

力者。谓如来十力。一处非处智力。二自业智力。三静虑解脱三摩地三摩钵底智力。四根上下智力。五种种胜解智力。六种种界智力。七遍趣行智力。八宿住随念智力。九死生智力。十漏尽智力

处非处智力者。谓依止静虑于一切种处非处智具足中。若定若慧及彼相应诸心心法。一切种处非处智具足者。谓于一切种因非因智无著无碍现行中。所有三摩地等。自业智力者。谓于一切种自业智具足中。若定若慧。余如前说。以于一切种自业智无著无碍现行中。所有三摩地等。如是余力随其所应当正建立。云何随其所应

静虑解脱三摩地三摩钵底智力者。谓于一切种静虑解脱等持等至智具足中。若定若慧。余如前说。由于一切种静虑解脱等持等至智无著无碍现行中所有三摩地等为体故。如是根上下智力者。谓于一切种根上下智无著无碍现行中。所有三摩地等。种种胜解智力者。谓于一切种差别胜解智无著无碍现行中。所有三摩地等。种种界智力者。谓于一切种差别界智无著无碍现行中。所有三摩地等

遍趣行智力者。谓于一切种遍趣行智无著无碍现行中。所有三摩地等。宿住随念智力者。谓于一切种宿住随念智无著无碍现行中。所有三摩地等

死生智力者。谓于一切种死生智无著无碍现行中。所有三摩地等。漏尽智力者。谓于一切种漏尽智无著无碍现行中。所有三摩地等

无畏者。谓四无畏。一正等觉无畏。二漏尽无畏。三障法无畏。四出苦道无畏

正等觉无畏者。谓依止静虑由自利门。于一切种所知境界正等觉自称德号建立具足中。若定若慧及彼相应诸心心法。如经言。我是正等觉者。设有世间沙门婆罗门若天魔梵。依法立难。或令忆念言。于是法非正等觉。我于是事正见无缘。以于此事正见无由故。得安隐住无怖无畏。自称我处大仙尊位。于大众中正师子吼转大梵轮。一切世间沙门婆罗门若天魔梵所不能转

漏尽无畏者。谓依止静虑由自利门。于一切种漏尽自称德号建立具足中。若定若慧。余如前说。如经言。我诸漏永尽。如是等。广说如前

障法无畏者。谓依止静虑由利他门。于一切种说障碍法自称德号建立具足中。若定若慧。余如前说。如经言。又我为诸弟子说障碍法。染必为障。乃至广说

出苦道无畏者。谓依止静虑由利他门。于一切种说出离道法自称德号建立具足中。若定若慧。余如前说。如经言。又我为诸弟子说出离道。诸圣修习决定出离决定通达。设有世间沙门婆罗门若天魔梵。依法立难。或令忆念言。修此道非正出离。不正尽苦及证苦边。我于是事正见无缘。乃至广说如是四无畏略说有二。谓自利利他。前二是自利。由智断差别故。后二是利他。由远离所治法修习能治法故。以正等觉无畏由内智自利门言。我于一切种所知境界差别边际皆正等觉。于一切世间前自称德号立正无难具足中所有定慧乃至广说。当知余。无畏如应亦尔。一切种漏尽者。谓诸烦恼并习气永尽。一切种障碍法者谓一切杂染所。对治法一切种出离道者。谓从方便道乃至究竟道

念住者。即诸如来三不共念住谓御大众时于一切种烦恼不现行具足中。若定若慧。广说如前。何等为三念住。所谓大师哀愍一切。欲求义利起大悲心。为诸弟子宣说法要。告诸比丘。汝等当知。此能利益。此能安乐。此能利益安乐。尔时若有诸弟子众恭敬听闻。闻已谛受住奉教心。精进修行法随法行。如来于彼不生欢喜心不踊跃。但起大舍住念正知。随诸圣众所应修习教诫教授。是名初不去念住

又复大师哀愍一切。欲求义利起大悲心。为诸弟子宣说法要。乃至此能利益安乐。尔时若有诸弟子众不恭敬听闻。乃至不精进修行法随法行。如来于彼不生恚恨。不舍保任心无怅恨。但起大舍。乃至广说。是名第二不共念住

又复大师哀愍一切。欲求义利起大悲心。为诸弟子宣说法要。乃至此能利益安乐。尔时一分弟子恭敬听闻。乃至精进修行法随法行。一分弟子不恭敬听闻。乃至不精进修行法随法行。如来于彼不生欢喜。乃至心不怅恨。如是三念住。显大师御众时随其次第。于一切种爱恚俱烦恼并习气不现行具足中。所有定慧等为体

不护者。即三不护。谓大师御众时。于随所欲教授教诫方便具足中。若定若慧乃至广说。何等为三。如经言。如来身业清净现行无不清净。现行身业可须覆藏。谓勿他知我之所有语业意业。现行亦尔。由彼大师心无惧虑。善御所化一切大众随其所欲。自然强力折伏摄受。教诫教授方便具足

无忘失法者。谓于一切种随其所作所说明记具足中。若定若慧乃至广说。此中显示依化事门。于随所作等念具足中。所有三摩地等。是无忘失法

永断习气者。谓一切智者。于非一切智所作不现行具足中。若定若慧乃至广说。此中显示一切智者于所有能表有余烦恼所知障身语所作不现行具足中所有三摩地等。是永断习气

大悲者。谓于缘无间苦境大悲住具足中。若定若慧乃至广说。此中显示于缘一切三界有情无间一切种苦境大悲住具足中所有三摩地等。是名大悲

不共佛法者。即十八不共佛法。彼复云何。谓于不共身语意业清净具足中。于所依及果根未得不退具足中。于不共业现行具足中。于不共智住具足中。若定若慧乃至广说。何等十八。如经言。如来无有误失。无卒暴音。无忘失念。无不定心。无种种想。无不择舍。志欲无退。精进无退。念无退。定无退。慧无退。解脱无退。一切身业智为前导随智而转。一切语业智为前导随智而转。一切意业智为前导随智而转。知过去世无著无碍。知未来世无著无碍。知现在世无著无碍。建立彼相如经广说

如来无有误失者。谓阿罗汉比丘虽漏已尽。为乞食故出游城邑。或于一时与恶象恶马恶牛恶狗等共为游止。或于一时践蹑丛刺齐足越坑。或于一时入女人家。不依正理而作语言。或于林野舍弃正道而行邪径。或与盗贼猛恶兽等共为游止。如是等误失事阿罗汉犹有。如来永无

无卒暴音者。谓阿罗汉或于一时游行林野迷失道路。或入空宅扬声叫唤发大暴音。因不染污习气过失聚。露唇齿而现大笑。如是等卒暴音阿罗汉犹有。如来永无

无忘失念者。谓阿罗汉犹有不染污。久远所作久远所说忘失忆念。如来永无。无不定心者。谓阿罗汉敛心方定。出即不定。如来于一切位无不定。心无种种想者。谓阿罗汉于有余生死起违逆想。于无余涅槃起寂静想。如来于生死涅槃无差别想。由住第一大舍故。无不择舍者。谓阿罗汉不以智慧简择。弃舍有情利益事。如来无此等事故无不择舍。又阿罗汉于所知障净有未得退。谓志欲退精进退念退定退慧退解脱退。如是六退如来永无

又阿罗汉或于一时善身业转。或于一时无记身业转。语业意业亦尔。如来三业智为前导故随智而转。故无有无记。智为前导者。智所等起故。随智而转者与智俱行故

又阿罗汉比丘于三世所知事。不能起心即解故智见有着不能一切悉解。故智见有碍。如来于三世境暂起心时即遍知一切。是故智见无著无碍。十八中前六于不共身语意业清净具足中。所有三摩地等为体。无有误失依身清净说。无卒暴音依语业清净说。无忘失念无不定心。无种种想无不择舍。此四依意业清净说。志欲无退乃至解脱无退。此六于所依及果根未得不退具足中。所有三摩地等为体。所依谓志欲。果谓解脱。根谓精进等。一切身语意业智为前导随智而转。此三于不共业现行具足中。所有三摩地等为体。知去来今无著无碍。此三于不共智住具足中。所有三摩地等为体

一切种妙智者。谓于蕴界处一切种妙智性具足中。若定若慧及彼相应诸心心法。云何于蕴界处一切种妙智性具足。谓于蕴等自性差别相。通达一切差别边际智成满故

云何引发如是等功德。谓依止清净四静虑。若外道若声闻若菩萨等。引发四无量五神通。多分依止边际第四静虑。若声闻若菩萨若如来等引发所余功德。何因引发如是功德。谓依止静虑数数思惟。随所建立法故。此中显示如是等功德引发所依止。能引发补特伽罗。能引发方便。云何能引发方便。谓于随所建立教法。以众多作意定心。起数数思惟行相。如欲引发无量时依止静虑。于慈俱心无恨无怨等教法。以修慧相应作意数数思惟。欲引发神通等时依止静虑。于变一为多等教法。以修慧相应作意数数思惟。如是于一切处数数思惟。如所建立随相应知

又如是等功德略有二种。一现前发起自所作用。二安住自性。若现前发起自所作用。以出世间后所得世俗智为体。若安住自性。用出世间智为体。又现前发起自所作用者。谓诸圣者随其所应发起断所治障等种种作业。安住自性者。谓最胜寂静无分别智所摄。无缘无量等现法乐住

复次无量作何业。谓舍所治障哀愍住故。能速圆满福德资粮。成熟有情心无懈倦。舍所治障者。谓如其次第四无量。能舍嗔害不乐爱恚故。哀愍住者。谓四无量。于利益有情事随顺转住。由于一切有情哀愍住故能速圆满福德资粮。成熟有情心无懈倦者。由愍诸有情不顾自身故

解脱作何业。谓引发变化事。于净不净变化无有艰难。于寂静解脱无有滞碍。能住第一寂静圣住。由胜解思惟故。此中显初二解脱能引发变化事。由第三解脱。于净不净变化无有艰难。由四无色解脱。于寂静解脱无有滞碍。由最后解脱。能住第一寂静圣住。由胜解思惟故者。显如是如是胜解义是解脱义。胜处作何业。谓能令前三解脱所缘境界自在而转。由胜伏所缘故

遍处作何业谓善能成办解脱所缘。遍满流布故。无诤作何业。谓所发语言闻皆信伏。爱护他心最为胜故。如其所应发语言故

愿智作何业。谓能善记别三世等事。一切世间咸所恭敬。由达一切众所归仰故

无碍解作何业。谓善说法要悦众生心。能绝一切诸疑网故

神通作何业。谓以身业语业记心。化导有情令入圣教。善知有情一切心行及过未已。如应教授令永出离。此中显示神境天耳乃至漏尽通。如其次第能起身业化导等用。由天耳通解了一切言音差别能引语业故。相及随好作何业。谓能令暂见谓大丈夫心生净信

清净作何业。谓由此势力故。取生有随其乐欲。或住一劫或复劫余。或舍寿行。或于诸法自在而转。或于诸定自在而转。或复任持诸佛正法。此中显示由所依清净随其所乐于所依身取住舍自在。即摄三句。谓故取生有等。由境界清净于诸法中得自在转。由心清净于三摩地得自在转。由智清净任持如来无上正法

力作何业。谓为除舍无因恶因论不作而得论。无倒宣说增上生道。悟入一切有情心行正说法器。意乐随眠境界资粮当能出离。随其所应宣说决定胜道降伏诸魔。善能记别一切问论。此中显初二力能说增上生道。余八力能说决定胜道。如是二种具足显示诸佛所作。所以者何。世尊由处非处智力折伏一切世间无因论者恶因论者。宣说无倒增上生道。诸外道等于增上生或谓无因或谓自性。自在等为因故。名无因恶因论。由自业智力折伏一切世间不作而得论者。无倒宣说善趣正道。诸外道等谓不作业自然得报故。名不作而得论。由静虑解脱等持等至智力。悟入一切有情心行。心所修行故名心行。由根上下智力。悟入一切正说法器。以信等根若善成熟能为法器故。由种种胜解智力。悟入一切胜劣意乐。由种种界智力。悟入一切可破随眠诸烦恼性。由遍趣行智力。悟入一切大小乘教法所摄境界。由宿住随念智力。悟入一切资粮前生所集圣道因缘。是名资粮。由死生智力。悟入一切当来功能性。由漏尽智力。悟入一切三界出离。由如是悟入已随其所应宣说解脱出世圣道。此十名力者。善能降伏诸魔故。善能记别一切问论故。降伏诸魔者。由此十力能降伏蕴魔烦恼魔天魔死魔。为最胜故。虽断所知障亦不能为碍故名最胜。记别一切问论者。谓于处非处乃至漏尽一切处。所有问论记别无滞故

无畏作何业谓处大众中自正建立我为大师。摧伏一切邪难外道。大师者。自利利他众德圆满故摧伏邪难外道者。谓能摧伏于如来所说成等正觉永断诸漏障道法中邪难外道故

念住作何业。谓能不染污摄御大众。由于恭敬听闻等无爱恚等诸烦恼故

不护作何业。谓能无间断教授教诫所化徒众。由无藏护自过虑显彰故

无忘失法作何业。谓能不舍离一切佛事。所以者何。由此于诸有情现前应利益事。能无放逸不越一刹那故

永断习气作何业。谓离诸烦恼亦不显现似诸烦恼所作事业。非如阿罗汉比丘犹现误失等事

大悲作何业。谓日夜六时遍观世间。谁减谁退谁增谁进。如是等种种观察

不共佛法作何业。谓由身语意业清净以得不退若行若住。映蔽一切声闻独觉。如此诸句依前所说。于不共三业清净具足等相。如应配释

一切种妙智作何业。谓能绝一切有情一切疑网。令正法眼长时得住。由此有情未成熟者令成熟。已成熟者令解脱。绝疑网者于一切处智无碍故。令正法眼得久住者。于彼彼时方为断所化有情疑惑。宣说种种法门差别。诸结集者次第结集。令不灭故。依此法眼未成熟有情令速成熟。已成熟者速令解脱。复次于诸现观位证得后后胜品道时。舍前所得下劣品道。如证得此果所摄道时。即舍此向所摄道。以不复现前故

又即此时集断作证。由得果时永断此所治种类烦恼品粗重令无余故。证得胜品转依故

复次于无余涅槃界声闻独觉一切圣道。由顿舍所舍非。诸菩萨是故唯说诸菩萨为无尽善根者无尽功德者。顿舍所舍者。是究竟不现行舍义。非诸菩萨所得圣道。有如是舍。为欲利益一切有情皆得涅槃故由此因缘无尽慧经等。说诸菩萨为无尽善根者无尽功德者

复次何故建立诸无记事。由彼所问不如理故。何故所问不如理耶。远离因果染净所应思处故。此中显示如来于诸外道所问世间常无常等事中建立十四不可记事。由彼所问不如正理能引无义利故。何等问论能引义利。谓依四圣谛所有问论。由此问论因果染净应思处所摄故

复次何缘菩萨已入菩萨超升离生位而非预流耶。由得不住道一向预流行不成就故。何缘亦非一来耶。故受诸有无量生故。何缘亦非不还耶。安住静虑还生欲界故

又诸菩萨已得谛。现观于十地修道位。唯修所知障对治道。非烦恼障对治道。若得菩提时顿断烦恼障及所知障。顿成阿罗汉及如来。此诸菩萨虽未永断烦恼。然此烦恼犹如咒药所伏诸毒。不起一切烦恼过失。一切地中如阿罗汉已断烦恼

复次诸菩萨于所知境应修善巧。于诸方便应修善巧。于虚妄分别应修善巧。于无分别应修善巧。于时时中应修练根

所知境者略有六种。一迷乱。二迷乱所依。三不迷乱所依。四迷乱不迷乱。五不迷乱。六不迷乱等流迷乱者。谓能取所取执。迷乱所依者。谓圣智所行唯有行相。虚妄分别为体。由有此故一切愚夫迷乱执转不迷乱所依者。谓真如是无分别智所依处故。迷乱不迷乱者。谓随顺出世智所有闻慧等诸善法分别所知境故随顺无分别智故。不迷乱者。谓无分别智。不迷乱等流者。谓圣道后所得善法。方便善巧者略有四种。一成熟有情善巧。二圆满佛法善巧。三速证神通善巧。四道无断善巧。成熟有情善巧者。谓四摄事。由摄受彼令处善法故。圆满佛法善巧者。谓慧波罗蜜多。如经言。若菩萨摩诃萨欲得圆满施波罗蜜多乃至一切种妙智性。当学般若波罗蜜多故。速证神通善巧者。谓日夜六时发露诸恶。随喜功德。劝请诸佛。回向善根等。广说如圣者弥勒所问经道无断善巧者。谓无住处涅槃。由此数数究竟无断。周遍十方一切世界。随所应化。示现一切佛菩萨行

虚妄分别者略有十种。谓根本分别。相分别。相显现分别。相变异分别。相显现变异分别。他引分别。不如理分别。如理分别执着分别。散乱分别。根本分别者。谓阿赖耶识。是一切分别种子故。相分别者。谓身所居处所受用识。是所取相故。彼复如其次第以诸色根器世界色等境界为相。相显现分别者。谓六识身及意。如前所说。所取相而显现故。相变异分别者。谓如前所说。身等相变异生起。相显现变异分别者。谓如前所说。眼识等相显现。于苦乐等位差别生起。他引分别者。谓教法所摄名句文身相。此复二种。一恶说法律为体。二善说法律为体。由此增上力如其次第引二作意所摄。谓不如理分别如理分别执着分别者。谓不如理分别所起六十二见所摄。所有分别散乱分别者。谓如理分别所起无性等执为相所有分别

此复十种。谓无性分别。有性分别。增益分别。损减分别。一性分别。异性分别。自性分别。差别分别。随名义分别。随义名分别。如是十种分别依般若波罗蜜多初分宣说。如经言。舍利子。是菩萨实有菩萨正不随观菩萨。正不随观菩萨名正不随观般若波罗蜜多。正不随观菩提。正不随观行。正不随观不行。所以者何。名自性空非空性。色自性空非空性。乃至识自性空非空性。何以故。此色空性非即色亦不离色。别有空性。色即是空性。空性即是色乃至识亦尔。何以故。此唯有名。所谓此是菩萨名。此是菩萨。此是般若波罗蜜多。此是菩提。此是色乃至此是识。由彼自性无生无灭无染无净。菩萨行般若波罗蜜多时正不随观生。乃至正不随观净。何以故。于所计度彼彼诸法假立客名。由随客名而起言说。随如是如是言说。起如是如是执着。菩萨于如是一切名正不随观。正不随观故不生执着。于此经中为对治无性分别故。说如是言。是菩萨实有菩萨。如是等由实有言。是有性义故。为对治有性分别故。说如是言。正不随观菩萨乃至正不随观不行。由遣补特伽罗及法二性故。为对治增益分别故。说如是言。所以者何。名自性空。由遣不实遍计所执自性故。为对治损减分别故。说如是言。非空性。由于此名遍计所执自性远离性一切时有故。为对治一性分别故。说如是言。此色空性非即色。乃至此识空性非即识。由自性异故。所以者何。色等是遍计所执自性。空性是圆成实自性故。为对治异性分别故。说如是言。亦不离色别有空性。乃至空性即是识。由遍计所执自性无相故。离彼彼无性不可得故为对治自性分别故。说如是言。此唯有名。所谓此是色乃至此是识等。由离能诠无有决定所诠自性故。为对治差别分别故。说如是言。由彼自性无生乃至正不随观净。由遣生等差别相故。为对治随名义分别故。说如是言。于所计度彼彼诸法假立客名。由随客名而起言说如是等。为对治随义名分别故。说如是言。菩萨于如是一切名正不随观。正不随观故不生执着。由随义于名不见不执故

无分别者略有三种。一知足无分别。二无颠倒无分别。三无戏论无分别。如此三种异生声闻菩萨如次第应知。由诸异生随于一无常等法性。究竟思已便生喜足。谓是事必然更无异望。是名知足无分别。尔时一切寻思分别皆止息故。由诸声闻于诸蕴中为对治常等颠倒故。如理观察唯有色等法时。便得出世间智通达无我性。是名无颠倒无分别。由诸菩萨知色等法唯戏论已。遂能除泯一切法相。得最极寂静出世间智。通达遍满真如。是名无戏论无分别。此无分别智复离五相。谓非无作意故。非超过故。非寂止故。非自性故。非于所缘作加行故。名无分别所以者何。若无作意故名无分别。熟眠醉等应是无分别智。由彼不思惟诸法相故。若超过故名无分别。从第二静虑已上一切地。应是无分别智。由彼超过寻伺故。若尔三界心心法是分别体。言即为相违。若寂止故名无分别。灭受想定应是无分别智。分别心心法于彼寂止故。若尔智亦应无。若自性故名无分别。色等应是无分别智。彼非分别自性故。若于所缘作加行故名无分别。即分别性应是无分别智。若谓此是无分别。此加行相即分别相故。是故无分别智非彼五相。若尔当云何观无戏论无分别相。谓于所缘不起加行。此复云何。若诸菩萨过随顺教观察诸法。若性若相皆不真实。由此观察串习力所持故。不由加行于如实无戏论界一切法真如中内心寂定。如是乃名无戏论无分别智

复次若诸菩萨性是利根。云何复令修练根耶。谓令依利软根引发利中根。复依利中根引发利利根故。前已说一切菩萨性是利根。而复说于时时中应修练根者。由于自种类复有软等三品后后相引发故。说名练根。若异此者诸利根种性补特伽罗应根唯一品。诸菩萨等根品差别应不可得。然有可得。是故利根复有差别

大乘阿毗达磨杂集论卷第十四大乘阿毗达磨杂集论卷第十五

        安慧菩萨糅释上集论

        大唐三藏法师玄奘奉　诏译

    决择分中论品第四之一

云何论决择。略说有七种。谓义决择。释决择。分别显示。决择。等论决择。摄决择。论轨决择。秘密决择

义决择者。谓依六义而起决择。何等六义。谓自性义因义果义业义相应义转义

自性义者。谓遍计所执等三自性

因义者谓三因。一生因二转因。三成因生因者。谓因等四缘由此能生诸有为故。转因者谓由此次第彼法转如无明缘行等。乃至集灭。由此次第染净转故。成因者。谓现量可得。不可得等正说所摄。由此能成立先所未了所成义故果义者。谓五果何等为五。一异熟果。二等流果。三增上果。四上用果。五离系果。异熟果者。谓阿赖耶识等。等流果者。谓前生诸善法所起自相续后诸善法。增上果者。谓一切有情共业增上力所感器世间。士用果者。谓稼穑等。离系果者。谓由圣道随眠永灭。业义者。谓五种业。一取受业。二作用业。三加行业。四转变业。五证得业。此五业义如前业染中释。相应义者。谓五种相应。何等为五。一聚结相应。二随逐相应。三连缀相应。四分位相应。五转变相应。聚结相应者。谓于舍等有木石等。随逐相应者。谓随眠等因。由有此故。虽烦恼等不现行。而说与彼相应。连缀相应者。谓亲属等展转相应。分位相应者。谓摄受益等相续分位。由此分位现前说名与乐相应。乃至与不苦不乐相应故。转变相应者。谓客尘烦恼等现前由有此故。说与贪等信等相应。转义者。谓五种转。一相转。二安住转。三颠倒转。四不颠倒转。五差别转。相转者。谓生等三有为相。由彼三相差别转故。安住转者。谓所持法住能持中而转故。颠倒转者。谓杂染法不如实转故。不颠倒转者。谓清净法如实转故。差别转者。谓一切行过去未来现在内外等差别转故

释决择者。谓能解释诸经宗要开发彼义故。此复云何。略有六种。谓所遍知事。所遍知义。遍知因缘。遍知自性。遍知果彼证受。由此六义随其所应遍释诸经故。名释决择。所遍知事。谓蕴等。所遍知义谓无常等。遍知因缘。谓净尸罗守根门等。遍知自性。谓菩提分法。遍知果。谓解脱。彼证受。谓解脱智见

又十四门辩释决择。何等十四。谓摄释门。摄事门。总别分门。后后开引门。遮止门。转变字门。坏不坏门。安立数取趣门。安立差别门。理趣门。遍知等门。力无力门。别别引门引发门。摄释门者。谓若于是处宣说诸经缘起。所以句义次第意趣释难

摄事门者。谓若于是处约学事圣谛事等辩释诸经。如说诸恶者莫作诸善者奉行善调伏自心是诸佛圣教。此伽他中依三学说如是等

总别分门者。谓若处显示先以一句总。标后以余句别释。如十二暇总集经中先说。自圆净他圆净。二句后如其次第五句五句别释。如是等

后后开引门者。谓若处显示能为后后开引所依故。此诸法如是次第说。如信等五根先后次第。必先信受乃发精进发精进已然后念住。既念住已心得安定。心安定已方如实知。如是等

遮止门者。谓若处显示依止此事遮止此事。如斤柯喻经中。依止漏尽遮止四种补特伽罗。一处正法外。二处正法中。但得闻思便生喜足。三于修慧中心生怯弱。四资粮未满。告诸比丘。我知我见我说漏尽。如是等一段经文遮止第一。不勤精进修习观行者遮止第二。说斤柯喻遮止第三。说船筏喻遮止第四。转变字门者。谓若处显示转余显了字义变成余义。如不信不知恩等伽他后当说

坏不坏门者。谓若处显示失坏不失坏。彼二方便彼二差别。如善生经说。失坏者。谓染着内外依事。内依事五取蕴为相。外依事四宅妻子等为相。不失坏者。谓远离此二种染着。失坏方便者。谓不出家虽复出家。而行放逸不得漏尽与此相违是无失坏方便。佛告善生。族姓子。有二种事俱为美妙。若落须发乃至趣于非家。若尽诸漏乃至自称不受后有者。此正显不失坏及彼方便。兼显失坏及彼方便。由与此相相违故。不失坏差别者。如伽他中显。谓诸比丘美妙寂静离诸漏。此显出家及漏尽。为显漏尽复说余句。谓离欲离系缚。无执受涅槃任持最后身。摧伏魔所使者。此显由世间道离欲。由出世道永断顺下分结。永断顺上分结。永断内依事。此则略说因尽果尽。亦兼显失坏差别。由与此相相违故。安立数取趣门者。谓若处显示依尔所补特伽罗说如是言。如水喻经中依二数取趣说三种四种差别言。何等为二。谓异生及见谛异生。差别有三。谓无白法少白法多白法。见谛差别有四。谓住四果三有学一无学

安立差别门者。谓若处显示四句等所问义。如无常经说。若正观者一切观色耶。设观色者一切正观耶。应作四句。初句。谓于受等四蕴无有常净乐我颠倒增益。又观彼为应知应断。第二句。谓于色蕴有常净乐我颠倒增益。又观彼为不应知不应断。第三句。谓于色蕴无有常净乐我颠倒增益。又观彼为应知应断。第四句。谓于受等四蕴有常净乐我颠倒增益。又观彼为不应知不应断。如因色作四句。如是因受等一切处应广说乃至说言。若所作已办者。一切自谓不受后有耶。设自谓不受后有者。一切所作已办耶。此应作四句。初句。谓诸异生乃至命终恒行妙行。第二句。谓断见者。第三句。谓无学。第四句。谓除上尔所相

理趣门者。谓若处显示六理趣义。何等为六。一真义理趣。二证得理趣。三教导理趣。四离二边理趣。五不思议理趣。六意乐理趣。如是六种。前三如其次第应随后三决了。如爱味经中。佛告诸比丘。于色有味乃至广说此中显示。由远离增益损减二边理趣。决了真义理趣有味有患有出离者。显离损减边。于色乃至于识者显离增益边由显示染污清净唯依诸蕴不依我故。乃至告诸比丘。我自证知由此故。乃至已证觉无上正等菩提者。显由不思议理趣决了证得理趣。此显真证内自所受故。如是一切经皆是教导理趣。应随意乐理趣决了。谓依所遍知事。所遍知义。遍知。遍知果。彼证受。意乐说此经。所遍知事者。谓色等。所遍知义者。谓有味等。由此差别义遍知色等事故。遍知者。谓于五取蕴由如是三转如实遍知。遍知果者。谓从此诸天世间乃至并天人皆得解脱乃至极解脱。彼证受者。谓自证知我已证觉无上正等菩提

遍知等门者。谓若处显示依真实相宣说遍知相义。永断相义。作证相义。修习相义。即此真实相等品类差别相义。能依所依相属相义。遍知等障碍法相义。遍知等随顺法相义。于不遍知等及遍知等过失功德相义。此亦如爱味经广说。真实相者。谓取蕴所摄苦谛相。遍知相者。谓即于此有味等如实知。永断相作证相者。谓从一切世间得解脱。由永断诸障证得转依故。修习相者。谓离颠倒心多修习住。品类差别相者真实相有五种差别。谓色乃至识。遍知相有三种差别。谓味由味故。乃至出离由出离故。如实知永断相作证相。各有二种差别。谓烦恼解脱。苦解脱。从此诸天世间乃至并天人皆得解脱者。显烦恼解脱。为显此差别义故。次说出离言。何以故。由余经言。出离云何。谓若于是处贪欲永灭贪欲永断。超过贪欲故。如是由能生未来苦烦恼得离系故。苦亦解脱。为显此差别义故。次说离系缚极解脱。修习相有二种差别。谓见道修道。离颠倒心者显示见道。多修习住者显示修道。能依所依相属相者谓显示真实相等。为后后所依性。遍知等障碍法相者。谓如是三转不如实知。遍知等随顺法相者。谓观察如所安立色等法中味等相。于不遍知等过失相者。谓不解脱乃至不证觉无上正等菩提。与此相违名于遍知等功德相

力无力门者。谓若处显示诸一一句皆有功能。若不说一句义即不了。如缘起经说。此有故彼有。此生故彼生。所谓无明缘行等。如是诸句一一皆有功能。如前缘起相中说

别别引门者。谓若处显示先标经一句。后以无量义门广释。如经言。若比丘成就六法。尚能口风吹碎高广大雪山王。况无明死尸。何等为六。若诸比丘心生善巧乃至方便善巧。云何比丘心生善巧。所谓比丘离欲恶不善法。乃至第四静虑具足住。如是比丘心生善巧。云何比丘心住善巧。所谓比丘善修习故。所有顺退分静虑转为顺住分。如是比丘心住善巧。云何比丘心起善巧。所谓比丘善修习故。所有顺住分静虑转为顺胜进分。如是比丘心起善巧。云何比丘生长善巧。所谓比丘未生善法方便令生。乃至广说二正断。如是比丘生长善巧。云何比丘损减善巧。所谓比丘已生恶法方便令断。乃至广说二正断。如是比丘损减善巧。云何比丘方便善巧。所谓比丘欲三摩地。断行成就修如意足。乃至广说四如意足。如是比丘方便善巧

引发门者。谓若处显示一一句中宣说四句。是一一句复分四句。如是展转无边引发。如引佛经言。诸菩萨有四种净修菩提法。一者善修空性。二者于诸众生心无挂碍。三者常摄利益诸菩萨众。四者以无染心广开法施。如是四法于自利利他门净修菩提。为欲对治四种所治障故。何等为四。一贪着定味。二嗔恚。三慢。四爱着利养。又有差别。初显烦恼断对治。余显远离下劣乘。由诸菩萨三种因缘远下劣乘。一摄受一切有情。二已入法者令成熟。三未入法者令入正法。又有差别。初显智资粮。余显福资粮。此三差别者。摄受成熟令入三门。各能生长胜品福故。又由二缘差别。一由意乐。谓慈心俱。二由正行。谓说证教二行。又诸菩萨成就四法能修空性。一者于内心无动摇。二者信解择力所持。三者于一切法如实通达。四者解脱一切障。如是四法显修所依及修差别。以何为依。谓静虑波罗蜜多。云何修差别。一由异生道。谓闻思力所持。二由学道。谓达诸法实性。三由无学道。谓脱一切障。又诸菩萨成就四法。于诸有情心无挂碍。一者修慈。二者不毁正行。三者不分别相。四者堪忍劬劳。如是四法显所依及无挂碍心差别。谁为所依。谓过去生所修慈。云何无挂碍心差别。谓于住邪行所心无违毁。于怨家所不分别怨相。为利益他精勤无懈。又诸菩萨成就四法。常能摄益诸菩萨众。一者不自称量。二者正教诲转。三者柔和易可共住。四者精勤承事供养。如是四法显示所依及摄益差别。何等为依。谓摧伏憍慢

云何摄益差别。谓后所说三句。于劣等胜三种菩萨所如其次第又诸菩萨成就四法。能无染心广开法施。一者善达障难。二者善能除遣愚痴沉没。三者欢喜摄受。四者爱乐为依怙法。如是四法显示所依及广开法施差别。何等为依。谓善通达利养恭敬是障难法。云何广开法施差别。谓示现教导赞励庆喜。示现者于愚痴沉没。教导赞励者于着放逸自轻下劣。庆喜者于正行圆满。由性爱乐法故。如是前四句中。一一句复引发四句差别。如是等名引发门

分别显示决择者。谓于如所说蕴等法中。随其所应作一行顺前句顺后句二句三句四句述可句遮止句等。一行者即问论法。谓以一法与余法。一一互相问已除此法。更以第二法与余法互相问。如是一一问一切法。如有问言。若成就眼处亦色处耶。设成就色处亦眼处耶。此应作顺前句答。若成就眼处亦耳处耶。此应作四句答。如是乃至对意处如理应说。若成就眼处亦法处耶。此亦应作顺前句答。若成就色处亦眼处耶。设成就眼处亦色处耶。此应作顺后句答。若成就色处亦耳处耶。此亦应作顺后句答。如是乃至对法处如理应说。若成就耳处亦眼处耶。此应作四句答。如是乃至对法处如理应说。如是一一次第渐减。诸处更互如理应说

顺前句者。谓于诸法中随取二法更互相问。依止前法以答所问。如有问言。若智亦所知耶。设所知亦智耶。此应作顺前句答。诸智亦所知。有所知非智。谓余法

顺后句者。谓即二法展转相问。依止后法以答所问。如有问言。若所取亦能取耶。设能取亦所取耶。此应作顺后句答。诸能取亦所取。有所取非能取。谓色等五境及法处。除相应二句者。谓于所问应二句答。不得有余。如有依蕴建立依界建立。而发问言。若蕴数亦界数耶。设界数亦蕴数耶。此应作二句答。或蕴数非界数。谓色蕴识蕴何以故。无有一界全摄色蕴相。或全摄识蕴相故。或界数非蕴数谓法界

三句者。谓于所问唯三句答。如有问言。若蕴数亦处数耶。设处数亦蕴数耶。此应三句答。或蕴数非处数。谓色蕴或处数非蕴数。谓法处。或蕴数亦处数。谓识蕴意处。俱非数者。于蕴处中决定不有

四句者。谓于所问作四句答。如有问言。若成就眼根亦耳根耶。设成就耳根亦眼根耶。应四句答。初句。谓聋者眼根已生不舍。第二句。谓盲者耳根已生不舍。第三句。谓眼耳根已生不舍。第四句除上尔所相

述可句者。谓于所问顺尔而答。以如是言述可所问。如有问言。诸无常者皆是行耶。设当是行皆无常耶。应述可答所问如是

遮止句者。谓于所问不尔而答。以不尔言遮止所问。如有问言。蕴外诸行几谛摄耶。应遮止答蕴外无行

等论决择者。谓依八何八若之词。问答决择一切真伪。八何词者。且如问言。何谁无所得。谓已得般若波罗蜜多菩萨摩诃萨。何所无所得。谓所取相能取相。用何无所得。谓用般若波罗蜜多。为何无所得。谓为救脱一切有情令住无上正等菩提。由何无所得。谓由遇佛出世听闻正法。如理作意法随法行。何之无所得。谓一切法之无所得。于何无所得。谓于胜解行地乃至第十菩萨地。几何无所得。谓十一种。一已生已灭。二未生。三现前。四因力所生。五善友力所生。六一切法无所得。七空性无所得。八有我慢。九无我慢。十未具资粮。十一已具资粮。如是十一无所得。随所有过去未来现在。若内若外若粗若细若劣若胜若远若近次第应知。如何词若词亦尔。谓若能无所得。若所无所得。若用无所得。若为无所得。若由无所得。若彼无所得。若于无所得。若尔所无所得。如是一切处尽当知。复有四种等论决择道理。谓能破能立能断能觉。能破者。谓遮破他宗言。彼恶说非为善事。能立者。谓建立自宗言。此善说真为善事。能断者。谓能决种种他所生疑。能觉者。谓开晓愚情令解妙义

复有五种等论决择道理。谓如颂言

  自性所依识　　清净方便等
  当知五各六　　观所知诸法

自性等六者一自性二因三境界四行相五等无间六增上。所依等六者。一所依二依三摄四相应五成就六杂染。识等六者。一识二受三想四作意五智六遍知。清净等六者。一清净二词三出离四甚深五解脱门六入一切法。方便等六者。一方便二通达三修四圆证五究竟六引发

自性有四种。谓实自性假自性世俗自性胜义自性。因有四种。谓生因成因转因还因。境界有七种。谓有相境有分别境对治境安住境增益境损减境自在境。行相有五种。谓分析行相差别行相正解行相观察行相作随作行相。等无间有九种。谓自类等无间。异类等无间。三摩钵底等无间。退等无间。生等无间。邻次等无间。隔越等无间。起等无间。灭等无间。增上有七种。谓取增上生增上住增上受用杂染增上清净增上田增上执受增上。所依有八种。谓界所依趣所依洲渚所依村田所依补特伽罗所依无病所依尸罗所依庄严所依。依有五种。谓众具依善友依法依作意依三摩钵底依。摄有十一种。谓界摄相摄种类摄分位摄助伴摄时摄方摄具分摄一分摄更互摄胜义摄。相应有十种。谓他性相应不相违相应遍行相应不遍行相应所治相应能治相应曾习相应未曾习相应下劣相应广大相应。成就有三种。谓种子成就自在成就现行成就。杂染有四种。谓烦恼杂染业杂染生杂染障杂染

识有六种。谓眼识耳鼻舌身意识。受有三种。谓苦乐不苦不乐。想有二十种。谓无常想无常苦想苦无我想厌离食想一切世间不可乐想过患想断想离欲想灭想死想不净想青瘀想脓烂想破坏想膖胀想食啖想血涂想离散想骨锁想空观想。作意有七种。谓了相作意胜解作意远离作意摄乐作意观察作意方便究竟作意方便究竟果作意。智有十种。谓法智类智世俗智他心智苦智集智灭智道智尽智无生智。遍知有九种。谓欲系见苦集所断断遍知。色无色系见苦集所断断遍知。欲系见灭所断断遍知。色无色系见灭所断断遍知。欲系见道所断断遍知。色无色系见道所断断遍知。顺下分结断遍知。色爱尽遍知。无色爱尽遍知

清净有七种。谓戒清净心清净见清净度疑清净道非道智见清净行智见清净行断智见清净。词有八种。谓八何词八若词。出离有六种。谓世间出离声闻出离独觉出离大乘出离不毕竟出离毕竟出离。甚深有十种。谓相甚深杂染甚深清净甚深缘起甚深业甚深智甚深生甚深菩提甚深佛甚深教甚深。解脱门有三种。谓空无愿无相。入一切法有八种。谓一切法欲为根本。作意所生触所集起。受所引摄定为上首。慧为最胜。解脱为坚固。出离为后边

方便有七种。谓任持方便瑜珈方便相方便决择方便隔越方便邻次方便邻次隔越方便。通达有五种。谓有相文字通达所摄能摄通达迟通达速通达法性通达。修有四种。谓得修习修除去修对治修。圆证有四种。谓果圆证离欲圆证根满足圆证功德圆证。究竟有六种。谓智究竟断究竟毕竟究竟不毕竟究竟下劣究竟广大究竟。引发有二十种。谓无量引发乃至一切种妙智引发

大乘阿毗达磨杂集论卷第十五大乘阿毗达磨杂集论卷第十六

        安慧菩萨糅释上集论

        大唐三藏法师玄奘奉　诏译

    决择分中论品第四之二

实自性者。谓诸法实有性。假自性者。谓诸法假有性。世俗自性者。谓诸法世俗有性。胜义自性者。谓诸法胜义有性。生因者。谓因等四缘。成因者。谓三量。一现量二比量三声量。转因者。谓顺缘起。还因者。谓逆缘起。有相境者。谓眼等五识所缘色等五境。由缘此所生唯有无分别相故。有分别境者。谓意识所缘境。由缘此境有分别生故。对治境者。谓缘此境弃舍杂染。由能对治故。安住境者。谓缘此境能生圣天梵住。由众圣所住故。增益境者。谓缘此境能转胜进。是增胜因故。损减境者。谓缘此境能入无想定灭尽定。是损减心心法因故。自在境者。谓缘此境发神通等胜品功德。是自在因故。分析行相者。谓种种品类分析诸法。如有色无色有见无见。如是等。差别行相者。谓诸法差别义。如一信相或名心净。或名喜乐。或名忍可。如是等。正解行相者。谓以种种行相正解所缘境。如了别行相名识。取像行相名想。领纳行相名受。如是等。观察行相者。谓十六行。即无常等四因等四灭等四道等四。或世俗六行。谓粗行障行苦行静行妙行离行。作随作行相者。谓作所作已复更随作。如由此行善守护已。复更起余随守护行。自类等无间者。谓贪无间还复生贪。嗔等亦尔。各别种类等无间生故。异类等无间者。谓贪无间嗔等生。欲界无间色界生。色界无间无色界生。如是等。三摩钵底等无间者。谓三摩钵底无间相生。如欲界善无间入初静虑。初静虑无间还生欲界。如是于第二静虑等及无色定如理应知。退等无间者。谓从静虑等退时无间所生起。生等无间者。谓受生时无间所生。如从欲界无间生色界等。邻次等无间者。谓诸心心法无间次第生。于其中间心无断绝故。隔越等无间者。谓起灭定等时。前生心心法望后生心心法。中间隔越故。起等无间者。谓若此法无间彼法次第生。灭等无间者。谓此法无间彼法次第灭。如心心法无间灭已。或入灭尽定。或入无想定等。或入无余涅槃界。取增上者。谓眼等根望能取境界。有增上力故。生增上者。谓男女根望生胎孕。有增上力故。住增上者。谓命根望身等住。有增上力故。受用杂染增上者。谓五受根望所受用。有增上力故。又为贪等所随眠故。谓乐贪所随眠。苦嗔所随眠。不苦不乐痴所随眠。清净增上者。谓信等五根未知欲知等三根望世出世清净法。有增上力故。田增上者。谓共业望器世间生。有增上力故。执受增上者。谓四大种望所造色

界所依者。谓欲界等所摄身。趣所依者。谓五趣所摄身。洲渚所依者。谓赡部洲等。村田所依者。谓若依此村田而有即用此为所依。补特伽罗所依者。谓若依此补特伽罗而有即用此为所依。无病所依者。谓若依无病而有即用此为所依。尸罗所依者。谓若依尸罗而有即用此为所依。庄严所依者。谓若依彼彼沙门庄严诸功德生。即用彼为所依。众具依者。谓四依即衣服等。善友依者。谓若依此善等生起。法依者。谓契经等十二分教。作意依者。谓七种作意即了相作意等。三摩钵底依者。谓七依定如经言。我说依初静虑能尽诸漏。乃至依无所有处亦尔。界摄者。谓诸界种子。由此能摄种所生法。相摄者。谓诸法自相还能自摄。种类摄者。谓约色种类有十色处色蕴所摄。如是等。分位摄者。谓顺乐受等分位所摄。助伴摄者。谓色五蕴所摄。彼眷属故。如是等。时摄者。谓过去等摄过去等。方摄者。谓于此方所有蕴等即此方摄。具分摄者。谓欲色无色无漏诸色摄一切色。一分摄者。谓眼根摄色蕴。如是等。更互摄者。谓蕴界处更互相摄。胜义摄者。谓诸法无常苦不净空无我真如所摄。他性相应者。谓与他性相应非己性。不相违相应者。谓虽与他性相应然不相违非相违。如贪与嗔乐与苦。如是等。遍行相应者。谓触受想思作意于一切心。无明我慢我爱萨迦耶见。此四烦恼于染污意。不遍行相应者。谓除遍行所余贪等信等。所治相应者。谓诸烦恼更互相应。能治相应者。谓对治道所摄善法更互相应。曾习相应者。谓除出世间及出世后所得法。余相应法。未曾习相应者。谓前所除诸相应法。下劣相应者。谓声闻独觉乘所摄诸相应法。广大相应者。谓诸佛菩萨所有相应法。成就杂染识等乃至七种清净。已说其相。不复重释

八何词者。谓何谁信。何所信。用何信。为何信。由何信。何之信。于何信。几何信。八若词者。谓若能信。若所信。若用信。若为信。若由信。若彼信。若于信。若尔所信。如是等无量法门皆有八种。不毕竟出离者。谓由世间道。毕竟出离者。谓由出世间道。前四易解故不重释。相甚深者。谓三自性。杂染甚深者。谓真如云何染而不染。清净甚深者。谓即真如云何净而不净。缘起甚深者。谓无有法于所生起有实作用。然彼诸法种种生起。如是等又实无我似我显现。业甚深者。谓有业有果报而作者不可得。智甚深者。谓无分别智。云何此智无有分别。而能分明观真如性。生甚深者。谓诸菩萨不由业烦恼力而示现受生。菩提甚深者。谓于无漏界中诸佛菩提不可建立。一性无量相续所证故。不可建立种种性。所依无差别故。诸佛甚深者。谓于一大集会中。有无量无边诸佛世尊种种身种种意乐。然不谓有自他差别。又化身佛不住佛相。而能造作种种佛事。教甚深者。谓于大乘教中有种种秘密意乐差别三解脱门及一切法。欲为根本等。已说其相。不复重释

任持方便者。谓于资粮所有方便。瑜伽方便者。谓奢摩他毗钵舍那。相方便者。谓于止举舍相中所有方便。决择方便者。谓于顺决择分中所有方便。隔越方便者。谓即任持方便。邻次方便者谓即决择方便。邻次隔越方便者。谓即瑜伽及相二种方便。于顺决择分中名邻次于任持方便中名隔越。去圣道远故。通达修圆证。余处已说故不重释。智究竟者。谓尽无生智。断究竟者。谓一切烦恼无余永断。毕竟究竟者。谓由出世间道。不毕竟究竟者。谓由世间道。下劣究竟者。谓声闻独觉。广大究竟者。谓诸佛菩萨。菩萨究竟者。谓于最后位。诸佛究竟者。谓无障智生时。犹如百千俱胝等日一时出现。二十种引发前已广说。摄决择者。谓由十处摄诸决择。何等十处。谓成所作决择。趣入决择。胜解决择。道理决择。论决择。通达决择。清净决择。引发决择。句差别决择。不由功用暂作意时一切义成决择。成所作决择者。谓能决择成办世间种种养命方便等。趣入决择者。谓能观察我于三乘当入何乘。云何令他亦得趣入。胜解决择者。谓由闻慧如所闻教起胜信解。道理决择者。谓由思慧称量前后所说意趣。论决择者。谓如所闻思建立问论道理。为令展转受用法乐。通达决择者。谓见道能通达谛理故。清净决择者。谓修道以能无余净诸烦恼故。引发决择者。谓胜进道以能引发胜功德故。句差别决择者。谓以二三四句等差别引发门。演说无边法义差别故。不由功用暂作意时一切义成决择者。谓如来智离先功用。于一切义暂作意时。无著无碍智见转故

论轨决择者略有七种。一论体。二论处。三论依。四论庄严。五论负。六论出离。七论多所作法。于此七门方便善巧名论轨决择

论体者复有六种。一言论。二尚论。三诤论。四毁论。五顺论。六教论。言论者。谓一切世间语言。尚论者。谓诸世间所随闻论。世智所尚故。诤论者。谓互相违反所立言论。毁论者。谓更相愤怒发粗恶言。顺论者。谓随顺清净智见所有决择言论。教论者。谓教导有情心未定者令其心定。心已定者令得解脱。所有言论。论处者。或于王家。或于执理家。或对淳质堪为量者。或对善伴。或对善解法义沙门婆罗门等而起论端。于王家者。谓若于是处王自降临。执理家者。谓若是处处断王事。淳质堪为量者。谓商人等。善伴者。谓于伴侣中立论者。敌论者不越其言。善解法义沙门婆罗门等者。谓于彼彼论中善通达文义。论依者。谓依此立论略有二种。一所成立二能成立。所成立有二。一自性二差别。能成立有八种。一立宗二立因三立喻四合五结六现量七比量八圣教量所成立。自性者。谓我自性法自性。若有若无所成立

差别者。谓我差别法差别。若一切遍若非一切遍。若常若无常。若有色若无色。如是等无量差别

立宗者。谓以所应成自所许义。宣示于他令彼解了。所以者何。若不言以所应成者自宗已成而说示他应名立宗。若不言自所许义者。说示他宗所应成义应名立宗。若不言他者。独唱此言应名立宗。若不言宣示者。以身表示此义应名立宗。若不言令他解了者。听者未解此义应名立宗。若如所安立无一切过量故。建立我法自性若有若无。我法差别遍不遍等具足前相。是名立宗

立因者。谓即于所成未显了义。正说现量可得不可得等信解之相。信解相者。是信解因义。所以者何。由正宣说现量可得不可得等相故。于所应成未显了义信解得生。是故正说彼相名立因。现量可得不可得者。谓依自体及相貌说

立喻者。谓以所见边与未所见边和会正说。所见边者。谓已显了分。未所见边者。谓未显了分。以显了分显未了分令义平等。所有正说名立喻

合者。为引所余此种类义。令就此法正说理趣。谓由三分成立如前所成义已。复为成立余此种类所成义故。遂引彼义令就此法。正说道理是名合

结者。谓到究竟趣所有正说。由此道理极善成就。是故此事决定无异。结会究竟。是名结。已说立宗等相。今当就事略显。如无我论者。即于此事对我论者先说诸法无我。此言是立宗。次说若于蕴施设四过可得故。此言是立因。所以者何。若于诸蕴施设实我者。此所计我为即蕴相。为于蕴中。为于余处。为不属蕴而施设耶。若即蕴相而施设者。蕴不自在从众缘生是生灭法。若即彼相我不成就是名初过。若于蕴中而施设者所依诸蕴既是无常。能依之我亦应无常是第二过。若离蕴于余处施设者。我无所因我亦无用。是第三过。若不属蕴而施设者。我应独存自性解脱。更求解脱唐捐其功。是第四过。次说如于现在施设过去。此言是立喻所以者何。若同现在相施设实有过去者。此所计过去为即现在相。为于现在中。为于余处。为不待现在而施设耶。若即现在相而施设者。已生未灭是现在相。过去法体亦应已生未灭为相。是初过。若于现在中施设者。于未灭中施设灭体不相应故不应道理。是第二过。若离现在于余处施设者。除现在外余实有为事少分亦不可得。云何于彼施设。是第三过。若不待现在而施设者。亦应施设无为为过去世。是第四过。然过去世相灭坏故。无相义成。若同现在施设即成四过。是故过去相不成就诸法。无我亦尔。若于蕴施设即四过可得故无我义成。次说如是遮破我颠倒已。即由此道理常等亦无。此言是合。后说由此道理是故五蕴皆是无常乃至无我。此言是结

现量者。谓自正明了无迷乱义。自正义言显自正取义。如由眼正取色等。此言为简世间现所得瓶等事共许为现量所得性。由彼是假故非现量所得。明了言为简由有障等不可得因故。不现前境。无迷乱言为简旋火为轮幻阳焰等

比量者。谓现余信解。此云何。谓除现量所得余不现事决定俱转。先见成就今现见彼一分时。于所余分正信解生。谓彼于此决定当有由俱转故。如远见烟知彼有火。是名现量为先比量

圣教量者。谓不违二量之教。此云何。谓所有教现量比量皆不相违决无移转定可信受。故名圣教量

论庄严者。谓依论正理而发论端深为善美。名论庄严。此复六种。一善自他宗。二言音圆满。三无畏。四辩才。五敦肃。六应供。善自他宗者。谓于自宗他宗若文若义前后无间淳熟明解。言音圆满者。谓善解声论方起论端。离当所说言音过失。所发言音无杂乱等。无畏者。谓处大众虽为无量僻执英俊结谋围绕。所发言词坦然无畏。辩才者谓言词无滞。敦肃者。谓言无卒暴。观敌论者。言词究竟方乃发言。应供者。谓立性贤和发言温善方便随顺。敌论者心

论负者。谓舍言言屈言过。由此三种诸立论者堕在负处受他屈伏。舍言者。谓自发言称己论失。称他论德。谓我不善汝为善等。言屈者。谓假托余事方便而退。或说外事而舍本宗。或现忿怒憍慢覆藏等。如经广说假托余事方便退者。谓托余事乱所说义。如经说。长老阐铎迦与诸外道共论。或毁已立宗。或立宗已毁。言过者略有九种。一杂乱。二粗犷。三不辩了。四无限量。五非义相应。六不应时。七不决定。八不显了。九不相续。杂乱者。谓舍所论事广说异言。粗犷者。谓愤发卒暴言词躁急。不辩了者。谓所说法义众及敌论所不领悟。无限量者。谓言词重叠所说义理。或增或减。非义相应者。略有五种。一无义。二违义。三损理。四与所成等。五招集过难义。不可得故。义不相应故不决定故。能成道理。复须成故。一切言论非理非谛所随逐故。不应时者。谓所应说前后不次。不决定者。谓立已复毁。毁而复立。速疾转换难可了知。不显了者。谓越阐陀论相不领而答。或典或俗言词杂乱。不相续者谓于中间言词断绝

论出离者。谓观察德失令论出离。或复不作。恐堕负处故不兴论。设复兴起能善究竟。又若知敌论非法器。时众无德自无善巧不应兴论。若知敌论是法器。时众有德自有善巧方可兴论。敌论非法器者。谓彼不能出不善处安置善处。时众无德者。谓不淳质乐僻执有偏党等。自无善巧者。谓于论体乃至论庄严中不善通达。与此相违名敌论者是法器等

论多所作法者。谓略有三种。将兴论端定所须法。何等为三。一善达自他宗。由此堪能遍兴谈论遍于言事而兴论故。二无畏。由此堪能处一切众而兴论端。三辩才。由此堪能于诸问难皆善辩答

复次若欲自求利益安乐。于诸论轨应善通达。不应与他而兴诤论。如薄伽梵于大乘阿毗达磨经中说如是言。若诸菩萨欲勤精进修诸善品。欲行贞实法随法行。欲善摄益一切有情。欲得速证阿耨多罗三藐三菩提者。当正观察十二处法。不应与他共兴诤论。何等十二。一者宣说证无上义微妙法时。其信解者甚为难得。二者作受教心而请问者甚为难得。三者时众贤善观察德失甚为难得。四者凡所兴论能离六失甚为难得。何等为六。谓执着邪宗失。矫乱语失。所作语言不应时失。言退屈失。粗恶语失。心恚怒失。五者凡兴论时不怀犷毒甚为难得。六者凡兴论时善护他心甚为难得。七者凡兴论时善护定心甚为难得。八者凡兴论时欲令己劣他得胜心甚为难得。九者己劣他胜心不烦恼甚为难得。十者心已烦恼得安隐住甚为难得。十一者既不安住常修善法甚为难得。十二者于诸善法既不恒修。心未得定能速得定。心已得定能速解脱。甚为难得。于此经中已说欲勤精进修诸善品。何故复言欲行贞实法随法行。为显意乐清净故。所以者何。不为利养恭敬等事修闻思等诸善品故。欲善摄益有情者。为别声闻等行。由诸菩萨以利他行为胜故。如是菩萨自利利他行具足已。速证无上正等菩提。又此经中诸句义意。谓兴论时大乘法性无上甚深。若无诤心解尚为难。况为诤竞。凡兴诤论虽起请问。无心求解但求过失。又傍证者心不贤直。不善宗门乐着僻执。凡所言论多具六失所以者何。凡兴论时或有私心执着邪宗。或矫方便求他误失。或不待言竟便兴乱语。或敌论者言称正理反相诽拨。或作粗言。恼敌论者及时众心。或复于彼自怀恚怒。多具如是六种过失。又兴论时身心寂静甚为难得。不寂静故二事难成。谓善护他心善护自心。由此令他心得净信。于解脱处正勤方便令自心定。又兴论时多起此心。云何令我得胜。他堕负处。若不遂心。即怀热恼。由有此故。不安乐住。由此不能无间修善。是故于彼增上证法有未得退。秘密决择者。谓说余义名句文身。隐密转变更显余义。如经言

  逆害于父母　　王及二多闻
  诛国及随行　　是人说清净

今此颂中诠表世间共可极重罪恶文字。转变密显余清净义。何等世间共可极重罪恶。谓逆害尊人及大众。尊人有二。一别二共。共又二种。一护世间。二应供养。别亦二种。谓父及母。护世间者。谓王应供养者。谓多闻梵志世间共许最清净故。若总杀害名逆尊人。若诛国人及随行畜生名害大众。显此义者名诠表世间共可极重罪恶文字。云何转此文字密显净义。谓逆害父母等言。转变密显永断爱等余义故。所以者何。若爱若业。若有取识。戒见二取。眼等六处。及所行境。如其次第名母父等。法相似故。爱为发因。业为生因。由此能殖习气种子类世间父。由此二因令有取识流转不绝。于流转时虽求解脱。然由二种非方便法障解脱得。谓妄计度清净最胜。戒见二取犹如世间多闻梵志。恒妄计着最胜清净。此有取识所依所缘六处境界。犹如世间国及随行。若能永断如是等法。当知是人最为清净。又如经说

  不信不知恩　　断密无容处
  恒食人所吐　　是最上丈夫

今此颂中宣说世间极下劣义。所有文字转变密显余最上义。世间下劣凡有四种。谓意业下劣身业下劣语业下劣受用下劣。意业下劣复有二种。一者不信善生相违。不信有后世等。不行施等故。二不知恩顺生不善。不顾往恩违越世理。起害母等所有恶行故。身业下劣者。谓行窃盗攻墙密处最可轻贱。活命业故。语业下劣者。谓妄语等最可轻贱。于善众中所不容故。受用下劣者。谓鬼犬鸟等好食所吐故。显此义者名说世间极下劣义文字。云何转此文字显无上义。谓不信等言转变密显余胜义故。不信者。谓解脱智见。自现证故。不知恩者。谓涅槃智。有为名恩。无为非恩。知非恩故。名不知恩。断密者。谓永断后有续因烦恼故。无容处者。谓于当来诸趣苦处不复生故。食吐者。谓于现法中虽假资具力暂持身。而于命财不生欣乐故。若能如是。是最上丈夫。又如经说

  觉不坚为坚　　善住于颠倒
  极烦恼所恼　　得最上菩提

此如前说。然其体性。谓诸菩萨依三摩地。由见修二道证大菩提

又余经说。菩萨摩诃萨成就五法施波罗蜜多速得圆满。何等为五。一者增益悭吝法性。二者于施有倦。三者憎恶乞求。四者无暂少施。五者远离于施。增益悭吝法性者。谓由永断悭吝随眠并彼习气。证得彼法性真如转依故。于施有倦者。谓为修施誓受长时难行苦行故。憎恶乞求者。谓欲其自取。厌彼乞求故。无暂少施者。谓一切时一切物施故。远离于施者。谓常远离期报施等故

又余经说。菩萨摩诃萨成就五法名梵行者。成就第一清净梵行。何等为五。一者常求以欲离欲。二者舍断欲法。三者欲贪已生即便坚执。四者怖治欲法。五者二二数会。成就第一清净梵行者。谓出世间道。常求以欲离欲者。谓即以此如实遍智永断彼故。此如实遍智者。谓能通达此真如智。舍断欲法者。谓恒观察舍断非梵行方便。欲贪已生。即便坚执者。谓于内欲贪已生。即便坚执摈出于外。怖治欲法者。谓说欲过患怖诸有情。立对治道拔济一切。二二数会者。谓于染净因果差别四真谛中。以世出世二道及奢摩他毗钵舍那二道。数数证会故

何故此论名为大乘阿毗达磨集。略有三义。谓等所集故。遍所集故。正所集故。由释词理以显得名故为此问。等所集者。谓证真现观诸大菩萨共结集故。遍所集者。谓遍摄一切大乘阿毗达磨经中诸思择处故。正所集者。谓由无倒结集方便。乃至证得佛菩提故

大乘阿毗达磨杂集论卷第十六


大乘百法明门论本事分中略录名数

    No. 1614

大乘百法明门论本事分中略录名数

        天亲菩萨造

        大唐三藏法师玄奘译

如世尊言。一切法无我。何等一切法。云何为无我。一切法者。略有五种。一者心法。二者心所有法。三者色法。四者心不相应行法。五者无为法。一切最胜故。与此相应故。二所现影故。三分位差别故。四所显示故。如是次第。第一心法略有八种。一眼识。二耳识。三鼻识。四舌识。五身识。六意识。七末那识。八阿赖耶识

第二心所有法。略有五十一种。分为六位。一遍行有五。二别境有五。三善有十一。四烦恼有六。五随烦恼有二十。六不定有四。一遍行五者。一作意二触三受四想五思。二别境五者。一欲二胜解三念四定五慧。三善十一者。一信二精进。三惭四愧。五无贪六无嗔七无痴。八轻安九不放逸十行舍十一不害。四烦恼六者。一贪二嗔。三慢四无明。五疑六不正见。五随烦恼二十者。一忿二恨。三恼四覆。五诳六谄。七憍八害。九嫉十悭。十一无惭十二无愧。十三不信十四懈怠。十五放逸十六惛沈。十七掉举十八失念。十九不正知二十散乱。六不定四者。一睡眠二恶作。三寻四伺

第三色法。略有十一种。一眼二耳三鼻四舌五身。六色七声八香九味十触。十一法处所摄色

第四心不相应行法。略有二十四种。一得二命根。三众同分。四异生性。五无想定。六灭尽定。七无想报。八名身九句身十文身。十一生十二老。十三住十四无常。十五流转。十六定异。十七相应。十八势速。十九次第。二十方。二十一时。二十二数。二十三和合性。二十四不和合性

第五无为法者。略有六种。一虚空无为。二择灭无为。三非择灭无为。四不动灭无为。五想受灭无为。六真如无为

言无我者。略有二种。一补特伽罗无我。二法无我

大乘百法明门论


大乘成业论

    No. 1609 [No. 1608]

大乘成业论一卷

        世亲菩萨造

        大唐三藏法师玄奘奉　诏译

如处处经中世尊说。三业谓身业语业意业。此中有说身所造业故名身业。语即是业故名语业。此二皆用表与无表为其自性。意相应业故名意业。此业但以思为自性。今于此中何法名表。且身表业形色为性。缘此为境心等所生。谁之形色谓身形色。若身形色。何故前言身所造业故名身业。谓总名身一分摄故名身形色。依身大种而发生故名身所造。以总身言于别亦转。如世间说居邑住林。何缘复说缘此为境心等所生。为欲简彼唇等形色。彼非缘彼心等所生。以缘言音心等生故。又为简彼宿愿心等所引形色。彼非缘彼心等所生。余异熟因心等生故。何故名表。此能表示自发业心令他知故。为显此义故。说颂言

  由外发身语　　表内心所思
  譬彼潜渊鱼　　鼓波而自表

形色者何。谓长等性。何者长等。谓于彼生长等名想。此摄在何处。谓色处所摄。今应思择。长等为是极微差别犹如显色。为是极微差别积聚。为别一物遍色等聚。设尔何失。长等若是极微差别应如显色。诸色聚中一一细分。长等可取。若是极微差别积聚。此与显色极微积聚。有何差别。即诸显色积聚差别。应成长等。若别一物遍色等聚。一故遍故。一一分中应全可取。于一切分皆具有故。或应非一。于诸分中各别住故。又坏自宗十处皆是极微积集。又应朋助食米齐宗执实有分遍诸分故。即于和合诸聚色中。见一面多便起长觉。见一面少便起短觉。见四面等便起方觉。见诸面满便起圆觉。见中凸出便起高觉见中坳凹便起下觉。见面齐平起于正觉。见面参差起不正觉。如旋转轮观锦绣时。便生种种异形类觉。不应实有异类形色同在一处如诸显色。若许尔者。应于一一处起一切形觉。然无是事。是故形色无别有体。即诸显色于诸方面安布不同起长等觉。如树蚁等行列无过。若尔云何。于远闇处不了显色了形色耶。如何不了树等形色。而能了彼行列形耶。然离树等无别行列。或于远闇诸聚色中。若显若形俱不能了。虽复能取而不分明。疑是何物此何所见。由是应知但取显色。由远闇故见不分明。故表是形理不成立

有说。身表行动为性。缘此为境心等所生。何缘复说。缘此为境心等所生。为欲简彼唇等摇动。彼非缘彼心等所生。以缘言音心等生故云何名行动。谓转至余方。此摄在何处。谓色处所摄。何缘知此转至余方。谓差别相不可知故。此理不然。如熟变物虽才触火。光雪。酢等诸熟变缘即有差别。而不可知彼差别相。然彼前后非无有异。此亦应然。如长薪草众分相似。各别生焰虽有差别。而不可知彼差别相。然彼众分非无有异。此亦应然。若熟变物才触缘时。诸熟变相不即生者。彼于后时亦应不生。缘无异故。若长薪草众分相似。非分分中别生焰者。彼焰应无由彼别故。形量照明焰热差别。是故不应以差别相不可知故。便谓即此转至余方。应审了知彼差别相。若谓灭因不可得故知即此法转至余方。此亦非理。如心心所声灯焰等。有何灭因而念念灭。余亦应尔。灭不待因若言心等亦有灭因。谓唯各别自无常相。若尔何故余不许然。余既不然。此云何尔。故知心等灭不待因。心等既然余亦应尔。若余法灭不待因者。薪等未与火等合前。彼色等性应不可取。如合后位后亦应如前位。可取如何。风手未触未执灯铃已前。灯焰铃声分明可取。非于后位然焰声灭不待风手。薪等亦然不应为难。又若薪等由火等灭。彼色等性不可取者。才触无间应不可取。彼才触时有差别故。又彼外缘无差别故。诸熟变物下中上品。诸熟变相差别生时。由彼为因。后后生起前前灭坏。谁复为因。不应此法由彼故生。即此复由彼法故灭。二相违法非共一因。世极成立故有为法不待灭因。任运自灭如前可取。不可取者。应知相续随转灭坏差别之相。有微增故。又若灭法亦有因者。是则应无无因灭法。心心所等如待因生。灭亦应尔。非离心等别有无常世共成立。又因异故灭应差别。如火光雪酢等异故熟变差别。又已灭法应更可灭许有因故。犹如色等。是故灭法决定无因。灭无因故才生即灭。故知无有转至余方。若谓生因不可得故。知即此法转至余方。此亦非理有生因故。谓前与后而作生因。如前念心与后念心。前念熟变与后熟变。乳与其酪。葡萄汁与酒。酒复与酢等故。无少法转至余方。转相既无何有行动。又若有住则无行动。既无行动彼应常住。法若无住亦无行动。才生即灭无动义故。若尔现见行动者何。余方所见非即本物何缘知彼非本物耶。由彼彼方新新生故。如草火焰及如影行。非此方影余方可见形质不动。日等光明远近回转便见彼影或长或短或移转故。又障光明少分生故。有反诘言。何缘征难。至余方义且如何知。余方所见非即本物。此亦应引前理为证。谓若有住则无动等。又外火等缘无差别。而于后时差别可取。由此证知念念各别。又若以证异因无故。谓余所见还是本物。既无有因证即本物。何缘不谓非本物耶。由此二义应俱不定。故至余方义不成立

日出论者作如是言。诸行实无至余方义。有为法性念念灭故。然别有法心差别为因。依手足等起此法。能作手足等物。异方生因是名行动。亦名身表。此摄在何处。谓色处所摄。若尔何缘不许眼见如诸显色。既非所见不表示他。如何名表。复云何知此法实有。云何此法能令自身转趣余方别异而起。若言由心差别。所生风界即应如是。风界其性是动。足能为彼异方生因。何乃离风执有动法。又草叶等离外风界无别动法。云何移转。然诸风界摇触等生其性能动。即应许彼能令手等转余方生何劳别执。若体若用俱不极成能动法生

若不尔者即心差别。所生风界能为手等异方生因应是身表。如是风界无所表示。云何名表。又许触处是善不善便非释子

若不尔者即心差别。能令自身余方生起。即身生起应是身表。是则身表应假非实。自身多法合为体故。又无表示云何名表。香等不能表示他故。又许香等是善不善便非释子。若不尔者即心差别。所生显色应是身表。显色非心差别所起。自种子风差别生故。又许显色是善不善便非释子。若此显色体非身表。此余方生应是身表。天爱任汝于此表业尽力所能勤加转计。然此非用功力能成。何乃于中徒生劳倦。谁能成立生别有体。此所执生非如色等。是所现见非如眼等。是能现见何缘知有。又不可见云何名表。前说不能表示他故。又若显色是善不善。可说此生为身表业。然诸显色非善不善。前已说故。生亦应然。是故定无身实表业。若尔身业应唯无表。此无表名为目何法。谓法处摄律仪色等。云何欲界有善无表离表而发。若欲界中有此无表复有何过。应随心转。如在色界是则余心及无心位。应无律仪不律仪等。若谓受时要期发语。所引发故无斯过者。说戒经时默无所说亦无要期。如何获得虚诳语罪。又应无有无记身业。以无表业唯二种故。又亦应无一刹那顷善恶身业。以诸无表定相续故。谓若轻心不发无表。重心所发决定相续。虽彼随情计度实有身语业色。而不应成善不善性。所以者何。彼说色业于命终位必皆舍故。如何由此能得当来爱非爱果。有作是言此何非理。谓过去业其体实有。能得当来所感果故。此于痈上更复生痈。谓执过去业体实有。先有后无名为过去。如何可执其体实有。若尔世尊何故自说

  业虽经百劫　　而终无失坏
  遇众缘合时　　要当酬彼果

无失坏言。为显何义。显所作业非无果义由后半颂证此义成。谁不信受善不善业。虽经久远而能得果。但应思择。如何得果。为由相续转变差别。如稻种等而得果耶。为由自相经久远时安住不坏而得果耶。若由相续转变差别而得果者。义且可然。若由自相经久远时安住不坏而得果者。应言此业经久远时体不谢灭而能得果。若谓此业非自相。无名为谢灭。然由此业无复作用名谢灭者。如何此业无复作用。由更不能引当果故。何缘不能更引当果。此于彼果已曾引故。不可于果引而复引。如法已生不重生故。何缘不引余等流果。以等流果无分限故。岂不此果亦现在时。已曾引故不须重引。业体不灭常应现在。何不常引所得果耶。岂不前言不可于果引而复引。如法已生不重生故。如何复难前虽有言而未释难。业体恒有应如中际。常名现在常能引果。应如初际恒复可生。若谓过去业体虽有。而无作用故非现在。非现在故不能引果。此亦不然。既恒有体应如现在恒有作用。又汝所宗过去诸法有与果用何非现在。若谓现在。唯依诸法取果用说。理亦不然。用义同故。应俱现在过去诸法。无取果用名过去者。有与果用应名现在。此用尽时应名谢灭。是则诸法灭而复灭。如是亦应生而复生。故彼宗义理不成立。又法如何名能引果。谓安立彼令当生故。诸漏尽者。最后刹那应不引果后不生故。是则此念应非现在。不应更灭入于过去。初现在时已无作用。如何后时说名谢灭。若虽无用而更灭者。是则过去复应须灭。若灭已复灭。应生已更生。便有自违前所说过。若谓此念虽有能生后果作用。而缘阙故后果不生。此亦非理。果必不生。如何知有能生作用。应言此念违顺二缘有非有故。虽从因生而无作用能生后果。是故彼宗如是种类能引果义理必不成。由此但应于果种子能长养故。名能引果。又彼宗说过去未来体皆实有未来。何故非如现在能引果耶。若一切时一切物有何时何物体非有故。而经言遇众缘合时当酬彼果。又彼应说谁于何位于谁有能言安立彼令当生故。名能引果。以一切时一切有故。是故所言谓过去业其体实有能得当来。所感果者。理定不成

若尔应许由善不善身语二业。蕴相续中引别法起。其体实有心不相应行蕴所摄。有说此法名为增长。有说此法名不失坏。由此法故能得当来爱非爱果。意业亦应许有此法。若不尔者余心起时此便断灭。心相续中若不引起如是别法。云何能得当来世果。是故定应许有此法。若于先时诵习文义。后经久远复生忆念。又于先时于诸境界数见闻等。后经久远于彼境中还生忆念。于何刹那引起何法。由此后时还生忆念

又先趣入灭定等心引起何法。由此后时还从定起生出定心。又紫矿汁染拘橼花。彼二俱灭引起何法。后结果时瓤生赤色。故离彼计身语二业所引别法。但应由思差别作用熏心相续令起功能。由此功能转变差别当来世果差别而生。如紫矿汁染拘橼花相续转变至结果时其瓤色赤。内法熏习应知亦尔。又何不许身语二业熏心相续。以身语业由心引成善不善故。不应由心成善不善。于异相续能与当来爱非爱果。非余造业余受果故。若所作业体虽谢灭。由所熏心相续功能转变差别。能得当来爱等果者。处无心定及无想天心相续断。如何先业能得当来爱非爱果。有作是说。于此生中先所熏心必还相续故。得当来爱非爱果。既已间断何因能续。入定心作等无间缘故能令续。彼久谢灭云何能作等无间缘。如破过去业能得果。此亦同彼应如理破。故出定心不应续起

有作是说。依附色根种子力故后心还起。以能生心心所种子依二相续。谓心相续色根相续。随其所应岂不经说。意法为缘生于意识。云何离意而意识生。应知意种或时名意以于因中立果名故。如于所触立饥渴名。如何一一心心所法。从二种子相续而生。不见芽等从种生法。有如是事。可藉多缘生于一果。无从二种有一果生。若尔还应不免前过。谓无心定及无想天心相续断。如何先业能得当来爱非爱果。是彼宗过何谓彼宗。谓执此位全无心者。若说此位是有心者。即无斯过。如尊者世友所造问论中言。若执灭定全无有心。可有此过。我说灭定犹有细心故无此失。彼复引经证成此义。如契经言。处灭定者身行皆灭。广说乃至根无变坏识不离身。今此位中许有何识

有说。此有第六意识。岂不经说。意法为缘生于意识。三和合触与触俱起有受想思。云何此位得有意识而无三和。或有三和而无有触。或复有触而无受想。由是说名灭受想定。有作是释。如何世尊说。受缘爱而一切受非皆爱缘。触亦应尔。非一切触皆受等缘。世尊余经自简此义。谓无明触所生诸受为缘生爱曾无有处。简触生受。无简别故非为善释。有别释言。三和触者。三事有力合故。触生于此位中。三事无力可能生触及生受想。由入定心所厌坏故。正在定位尚无有触。况有受想。故此位中唯余意识无诸心所。若尔此位意识。是何为善为染为无记性。设尔何失。若善性者如何善性。非无贪等善根相应。设无贪等善根相应。如何无触。若谓由善等无间缘所引发故此识善者。理不应然。善心无间生三心故。又善根力所引善心。无因能遮无贪等故。又无善根应不成善。然此灭定如灭是善。若染性者如何染性。不与贪等烦恼相应。设与贪等烦恼相应。如何无触。如佛于彼十问经中自作是说。所有受蕴想蕴行蕴皆触为缘。又无想定尚不许染。况灭尽定。若是无覆无记性者。为异熟生。为威仪路。为工巧处。为能变化。设尔何失。若异熟生。如何有顶定心无间。此下八地中间悬隔。而起欲界异熟生心。如何复从此心无间。而得现起不动等心。如摩诃俱瑟祉罗契经中作如是问。出灭定时当触几触。答言具寿。当触三触。谓不动触。无所有触。及无相触。又异熟心宿业所引。有何道理。由灭定前要期势力。令彼出定时限不过。复有何缘。要于有顶缘灭为境定心边际。欲界宿业习气所引。异熟果心方得现起。非于前位。又以何缘。于此所起异熟生色断已不续。异熟生心断而更续。若威仪路或工巧处。或能变化。如何此心缘威仪等。无触而能有所造作。又许所修九次第定及八解脱体皆是善。不应此位现起染污或无记心。又用有顶缘灭为境寂静思惟定为依止。方能现入灭受想定。如摩诃俱瑟祉罗契经中依灭尽定作如是问。几因几缘为依能入无相界定。答言具寿。二因二缘为依能入无相界定。谓不思惟一切相。及正思惟无相界。若灭定中有意识者。此缘何境。作何行相。若缘灭境作静行相。如何非善。设是善者。如何不许与无贪等善根相应。设许相应。如何不许触为缘起。若缘余境作余行相。如何入灭定心无间起散乱心而不违理。设自计度有余无记由此二因亦不应理。是故汝等不如实知阿笈摩义。纵情妄计第六意识灭定等有。由是而执此位有心

若尔云何许灭定等诸无心位亦有心耶。应如一类经为量者。所许细心彼位犹有。谓异熟果识具一切种子。从初结生乃至终没。展转相续曾无间断。彼彼生处由异熟因。品类差别相续流转。乃至涅槃方毕竟灭。即由此识无间断故。于无心位亦说有心。余六识身于此诸位皆不转故说为无心。由灭定等加行入心增上力故。令六识种暂时损伏不得现起故名无心。非无一切。心有二种。一集起心。无量种子集起处故。二种种心。所缘行相差别转故。灭定等位第二心阙故名无心。如一足床阙余足故亦名无足。彼诸识种被损伏位。异熟果识刹那刹那转变差别。能损伏力渐劣渐微乃至都尽如水热箭引烧发力。渐劣渐微至都尽位。识种尔时得生果。便初从识种意识还生。后位随缘余识渐起。即前所说异熟果识。摄藏种种诸法种子。彼彼余识及俱有法善不善性数熏发时。随其所应种力增盛。由此相续转变差别。随种力熟随遇助缘。便感当来爱非爱果依如是义有说颂言

  心与无边种　　俱相续恒流
  遇各别熏缘　　心种便增盛
  种力渐次熟　　缘合时与果
  如染拘橼花　　果时瓤色赤

世尊依此。于解深密大乘经中。说如是颂

  阿陀那识甚深细　　一切种子如暴流
  我于凡愚不开演　　恐彼分别执为我

能续后有能执持身故。说此名阿陀那识。摄藏一切诸法种子故。复说名阿赖耶识。前生所引业异熟故。即此亦名异熟果识。若不许有此异熟识。复有何识能执持身。非有余识能遍持身。乃至命终恒不舍故。又何处蕴烦恼随眠对治生时可名能断。若言蕴在能对治心。此不应理。如何随眠烦恼随逐可为能治。又诸有情生无色界。染善无漏心正起时。有何趣摄异熟法在。或应许趣通非异熟及不系法。便与理违。又不还果生有顶处。为尽余漏修对治道。无所有处无漏起时。于有顶处有何别物。自体犹存而不名死非众同分。或复命根离色心等别有实物。此二唯于异熟诸蕴。相似势分而假建立。相似势分无别实体。如稻稗等相似势分。故定应许异六识身。有如上说持种识体

即依此识。赤铜鍱部经中建立有分识名。大众部经名根本识。化地部说穷生死蕴。云何此识缘境行相。此境行相不可了知。云何名识而得如是。如执灭定等位有余。识者境界行相难知。此亦应尔。此识摄在何取蕴中。理实应言识取蕴摄。若尔经句当云何通。如说云何名识取蕴谓六识身。又说云何识缘名色识谓六识。应知此经别有密意。如契经说。云何行蕴谓六思身。非行蕴中更无余法。此亦应尔。说六非余有何密意。且如世尊解深密说。我于凡愚不开演者。恐彼分别执为我故。何缘愚夫执此为我。此无始来穷生死际。行相微细无改变故。又以六识所依所缘行相品类粗易了故。与诸烦恼及对治道有相应故。建立杂染清净品故。体是果识由此比知有种识故。诸契经中随所宣说不说因识。与上所说皆相违故。是名说六非余密意。由此已释。余部经中唯说六识身为有分识等。随其所应皆无违害。又于今时一一部内无量契经皆已隐没。如释轨论广辩应知。故不应计阿赖耶识定非经说。理必有故。若尔一身应有二识俱时而转。谓异熟识及余转识。如是何过。若一身中二识俱转。应俱时立二有情身。如余身中二识俱转。此无有失。因果二识展转为依不相离故。又异熟识是余转识所熏习故。非异身中二识俱转。有如是事故无此失。颇有现见种与种果相续异耶。现见世间青莲花等。根与茎等相续各异而为种果。此亦应然。又纵世间见与不见。若不许有阿赖耶识。便有如前所说过难。故应定许阿赖耶识离六识身其体实有

何缘不许我体实有与六识身为所依止。汝所执我其相云何。而说能为六识依止。若许我如阿赖耶识生灭相续随缘转变。与识何殊。而执为我。若执我体是一是常毕竟无变。如何可说受识等熏为所依止。夫熏习者。令彼所熏相续变成功能差别。如紫矿汁熏拘橼花。令彼相续功能转变。若无熏习则无转变差别功能。如何先时领智贪等数习异故。后经久时念智贪等生起差别。又无心位与彼后时我体无别。今既无识。后意识等从何而生。又于识等我有何能。而执我为识等依止。若言识等因我故生。我体恒时既无差别。如何识等渐次而生。非于一时一切顿起。若谓更待余因缘助方能生者。离余因缘。如何知有我能生用。若言识等依我而转。诸法才生无间即灭。既无住义何容有转。故不应执我体实有与六识身为所依止。又执有我。违阿笈摩说一切法皆无有我故。汝所执一常实我都无正理。但率妄情

由此证成。但思差别熏习同时阿赖耶识令其相续转变差别。能引当来爱非爱果。非如彼说身语业相

若不许有身语二业。岂能遗谤三业契经。不能遗谤。然能如理解释此经令无过失。如何无失解释此经。应除执毒当为广说。何为契经说有三业。何者是身何者是业。何义名身何义名业。复以何义名为身业语业意业。问亦如是。复以何缘契经唯说身等三业。非眼等耶。何为契经说三业者。为显三业摄十业道。劝励怖多所作者故。如略说三学授佛栗氏子。有执诸业唯身所造非语非意。为显彼二亦有所造故说三业。身谓诸根大造和合差别为体。业即是思差别为性。积集所成。是为身义。大造极微积集成故。有说种种秽恶集成。是为身义。身是种种诸不净物所依处故。若尔天趣应无有身。随作者意有所造作。是为业义。能动身思说名身业。思有三种。一审虑思。二决定思。三动发思。若思能动身即说为身业。此思能引令身相续异方生因风界起故。具足应言动身之业。除动之言但名身业。如益力之油但名力油。如动尘之风但名尘风。此亦如是十业道中。初三业道许身业摄。谓杀生不与取欲邪行。如何思业而得彼名。由此思业能动其身。令行杀盗及邪行故。思力动身令有所作即名思作。如世间说狂贼烧村薪草熟饭。思复云何得名业道。思有造作故名为业。复与善趣恶趣为道。通生彼故得业道名。或所动身是思业道三种思业依彼转故。又杀盗淫由思业起依身而生。随世俗故亦名身业。然此实非善不善性。亦随世俗假立其名。为令世间依此门故。于善恶思勤修止作。是故假说善不善名。若唯思业是善不善。何故业道契经中言。由身三种故思造业。作及增长是不善故。能生苦果及苦异熟。此经意说。能动于身。以身为门。身为依处。缘杀盗淫为境。思业为因能感苦果异熟名身三种故思造业。除此余思名为意业。意相应故不能动发身及语故。若尔何缘经说。二业所谓思业及思已业。即前所说三种思中。初二种思名为思业。第三一思名思已业。无违经过。语谓语言音声为性。此能表了所欲说义故名为语。能发语思说名语业。或复语者字等所依。由带字等能诠表义故名为语。具足应言发语之业。除发之言但名语业。喻说如前。意者谓识能思量故。趣向余生及境界故。说名为意。作动意思说名意业。令意造作善不善等种种事故。具足应言作意之业。除作之言但名意业。或意相应业名意业。除相应言但名意业。喻说如前。若三种业但思为体。于散乱心及无心位。尔时无思如何得有名具律仪不律仪者。由思差别所熏成种不损坏故。名具律仪不律仪者。故无有过。思差别者。简取胜思能发律仪不律仪表。由此思故熏成二种殊胜种子。依二种子未损坏位。假立善恶律仪无表。齐何当言损坏如是由思差别所熏成种。谓从此后不作因生遮不遮思。如先所受谁能损坏如是种子。谓若有思能发于表。因此弃舍善恶律仪。及余舍因亦能损坏。所以不说眼等业者。由此经中。但说有情加行之业。不说诸法作用之业。何谓有情加行之业。谓随作者意所造作。何谓诸法作用之业。谓眼耳等各别功能

  佛说三业义深细　　我依理教妙辩成
  愿乘此福济群生　　咸使速证清净觉

大乘成业论一卷


大乘法界无差别论

    No. 1626 [cf. No. 1627]

大乘法界无差别论

        坚慧菩萨造

        大唐于阗三藏提云般若等译

  稽首菩提心　　能为胜方便
  得离生老死　　病苦依过失

菩提心略说有十二种义。是此论体。诸聪慧者应如次知。所谓果故因故。自性故。异名故。无差别故。分住故。无染故。常恒故。相应故。不作义利故。作义利故。一性故。此中最初显示菩提心果。令见胜利。次即说彼所起之因。然后安立。此出生相。及显异名而无差别。于一切位无有染着。常与净法而共相应。不净位中无诸功用。于清净位能作利益。一性涅槃应知。如是十二种义今此论中次第开阐。何者名为菩提心果。谓最寂静涅盘界。此唯诸佛所证。非余能得。所以者何。唯佛如来能永灭尽一切微细烦恼热故。于中无生永不复生意生诸蕴故。无老此功德增上殊胜圆满究竟无衰变故。无死永舍离不思议变易死故。无病一切烦恼所知障病及与习气皆永断故。无苦依无始时来无明住地所有习气皆永除故。无过失一切身语意误犯不行故。此则由菩提心。为最上方便不退失因一切功德。至于究竟而得彼果。彼果者即涅盘界。何者为涅盘界。谓诸佛所有转依相不思议法身。以菩提心是不思议果因。如白月初分故今顶礼。复次颂曰

  能益世善法　　圣法及诸佛
  所依宝处如　　如地海种子

复次菩提心如地。一切世间善苗生长所依故。如海一切圣法珍宝积聚处所故。如种子一切佛树出生相续之因故。如是已说菩提心果。云何此因。颂曰

  信为其种子　　般若为其母
  三昧为胎藏　　大悲乳养人

复次云何此因积集。应知如转轮王子。其中于法深信为菩提心种子。智慧通达为母。三昧为胎藏。由定乐住一切善法得安立故。大悲为乳母。以哀愍众生。于生死中无有厌倦。一切种智得圆满故。云何自性。颂曰

  自性无染着　　如火宝空水
  白法所成就　　犹如大山王

复次应知此菩提心因积集已。有二种相。谓离染清净相。白法所成相。离染清净相者。谓即此心自性不染。又出客尘烦恼障得清净。譬如火摩尼宝虚空水等为灰垢云土所覆翳时。虽其自性无所染着。然犹远离灰等故。令火等得清净。如是一切众生自性无差别心。虽贪等烦恼所不能染。然犹远离贪等故。其心得清净。白法所成相者。谓如是自性清净心。为一切白法所依。即以一切白净法而成其性。如说须弥山众宝所依。即以众宝而合成故。云何异名。颂曰

  至于成佛位　　不名菩提心
  名为阿罗诃　　净我乐常度
  此心性明洁　　与法界同体
  如来依此心　　说不思议法

复次此菩提心。永离一切客尘过恶。不离一切功德成就。得四种最上波罗蜜。名如来法身。如说世尊如来法身。即是常波罗蜜。乐波罗蜜。我波罗蜜。净波罗蜜。如来法身即是客尘烦恼所染自性清净心差别名字。又如说。舍利弗。此清净法性即是法界。我依此自性清净心。说不思议法。云何无差别。颂曰

  法身众生中　　本无差别相
  无作无初尽　　亦无有染浊
  法空智所知　　无相圣所行
  一切法依止　　断常皆悉离

复次此菩提心。在于一切众生身中。有十种无差别相。所谓无作以无为故。无初以无起故。无尽以无灭故。无染浊以自性清净故。性空智所知以一切法无我一味相故。无形相以无诸根故。圣所行以是佛大圣境界故。一切法所依以染净诸法所依止故。非常以是杂染非常法性故。非断以是清净非断法性故。云何分位。颂曰

  不净众生界　　染中净菩萨
  最极清净者　　是说为如来

复次此菩提心。无差别相故。不净位中名众生界。于染净位名为菩萨。最清净位说名如来。如说。舍利弗。即此法身。为本际无边烦恼藏所缠。从无始来生死趣中生灭流转。说名众生界。复次舍利弗。即此法身。厌离生死漂流之苦。舍于一切诸欲境界。于十波罗蜜及八万四千法门中。为求菩提而修诸行。说名菩萨。复次舍利弗。即此法身。解脱一切烦恼藏。远离一切苦。永除一切烦恼随烦恼垢。清净极清净最极清净。住于法性。至一切众生所观察地。尽一切所知之地。升无二丈夫处。得无障碍无所著一切法自在力。说名如来应正等觉。是故舍利弗。众生界不异法身。法身不异众生界。众生界即是法身。法身即是众生界。此但名异非义有别。云何无染。颂曰

  譬如明净日　　为云之所翳
  烦恼云若除　　法身日明显

此复云何。于不净位中。现有无量诸烦恼。而不为染。譬如日轮为云所覆而性常清净。此心亦尔。彼杂烦恼但为客故。云何常恒。颂曰

  譬如劫尽火　　不能烧虚空
  如是老病死　　不能烧法界
  如一切世间　　依虚空起尽
  诸根亦如是　　依无为生灭

复次云何。于此现有生老死。而言是常。譬如虚空虽劫灾火起不能为害。法界亦尔。是故经言。世尊。生死者但随俗说有。世尊。死者诸根隐没。生者诸根新起。非如来藏有生老死若没若起。世尊。如来藏过有为相。寂静常住不变不断故。云何相应。颂曰

  如光明热色　　与灯无异相
  如是诸佛法　　于法性亦然
  烦恼性相离　　空彼客烦恼
  净法常相应　　不空无垢法

复次云何未成正觉。而言于此佛法相应。譬如光明热色等与灯无有异相。诸佛法于法身亦如是。如说。舍利弗。诸佛法身有功德法。譬如灯有光明热色不离不脱。摩尼宝珠光色形状亦复如是。舍利弗。如来所说诸佛法身智功德法不离不脱者。所谓过恒河沙如来法也。复次如说有二种如来藏空智。何等为二。所谓空如来藏。一切烦恼若离若脱智。不空如来藏。过恒河沙不思议诸佛法不离不脱智。云何不作义利。颂曰

  烦恼藏缠覆　　不能益众生
  如莲华未开　　如金在粪中
  亦如月盛满　　阿修罗所蚀

复次众生法身。即与如是功德相应。何故无有如来德用。应知此如莲未开。诸恶见叶共包裹故。如金堕厕。在于觉观粪秽中故。如满月被蚀。我慢罗睺所执取故。如池水被浊。贪欲尘土所混杂故。如金山被翳。嗔恚泥垢所封着故。如虚空被覆。痴愚重云之所蔽故。如日未出。在无明习气地中故。如世界未成。在六处水大藏中故。如云无雨。相违缘现前故。总为颂曰

  如莲金等未开显　　佛体客尘翳亦然
  是时功德不自益　　反此则能为大利

云何作义利。颂曰

  如池无垢浊　　如莲大开敷
  亦如上真金　　洗除众粪秽
  如虚空清净　　朗月星围绕
  离欲解脱时　　功德亦如是
  譬如日明现　　威光遍世间
  如地生众谷　　如海出众宝
  如是益众生　　令从诸有脱
  了知诸有性　　而起于大悲
  若尽若不尽　　斯皆无所著
  佛心如大云　　住于实际空
  三昧总持法　　甘雨随时降
  一切诸善苗　　因此而生长

此偈中义与前相反。应知则是清净法身。远离客尘众患故。成就自性功德故。证斯法者则名如来应正等觉。于常住寂静清凉不思议涅盘界。恒受安乐。为一切众生之所归仰。云何一性。颂曰

  此即是法身　　亦即是如来
  如是亦即是　　圣谛第一义
  涅盘不异佛　　犹如冷即水
  功德不相离　　故无异涅盘

若如来法身异涅盘者。经中不应作如是说。如彼颂曰

  众生界清净　　应知即法身
  法身即涅盘　　涅盘即如来

复次如有经言。世尊。即此阿耨多罗三藐三菩提名涅盘界。即此涅盘界名如来法身。世尊。无异如来无异法身。言如来者即法身也

复次应知。此亦不异苦灭谛。是故经言。非以苦坏名苦灭谛。言苦灭者。以从本已来无作无起。无生无灭。无尽离尽。常恒不变无有断绝。自性清净。远离一切烦恼藏。具足过恒河沙不离不脱智不思议诸佛法。是故说名如来法身世尊。即此如来法身。未离烦恼藏。说名如来藏。世尊。如来藏智。是如来空智。世尊。如来藏者。一切声闻独觉。本所不见本所不证。唯佛世尊。永坏一切烦恼藏。具修一切苦灭道之所证得。是故当知。佛与涅盘无有差别。譬如冷触不异于水。复次应知。唯有一乘道若不尔者。异此应有余涅盘故。同一法界岂有下劣涅盘胜妙涅盘耶。亦不可言由下中上胜劣诸因而得一果。以现见因差别果亦差别故。是故经言。世尊。实无胜劣差别法证得涅盘世尊。平等诸法证于涅盘。世尊。平等智。平等解脱。平等解脱见。证得涅盘。是故世尊。涅盘界者名为一味。所谓平等味解脱味也

大乘法界无差别论此论丹藏与国宋二藏不同。此则丹本。有五字四句二十四颂。间挟七言一偈。离为十二段。段段各释。吾祖贤首疏。所释者。此本也。按彼国宋两本。有七字四句二十偈。一举并出。后方次第释之。其初偈曰。法界不生亦不灭。无老病死无蕴过。由彼发胜菩提心。是故我今稽首礼者是也。今按开元录。及贤首疏。并以此论为单译。而国宋两本与此丹本文虽有异。义则无殊。必是开元之后。后代重译也。但未详何代何人之译。此须待勘。二藏直以为提云般若译者错耳


大乘法界无差别论(一名如来藏论)

    No. 1627 [cf. No. 1626]

大乘法界无差别论一卷(一名如来藏论)

        坚慧菩萨造

        大唐于阗三藏提云般若译

  法界不生亦不灭　　无老病死无蕴过
  由彼发胜菩提心　　是故我今稽首礼
  有情菩提心具足　　能生圣者及自然
  一切善法所依处　　由如地海种子等
  彼种含在母胎中　　亦如乳母共长养
  信心胜智菩提本　　大定大悲育应知
  性净觉心常无垢　　犹如大宝太虚空
  如苏迷卢超众岳　　一切白法宝生处
  贪嗔痴等皆断尽　　不为烦恼过所牵
  过于殑伽沙伎能　　万法圆满光映彻
  净我乐常波罗蜜　　得成应供十方尊
  因时即是菩提心　　果满德圆名正觉
  彼体能含法界相　　智光朗彻净无瑕
  菩提心法不思议　　诸佛如来皆赞叹
  无始以来非造作　　无有质碍亦无终
  以空无相慧了知　　诸佛如来之境界
  彼性一切法所依　　远离断常二种见
  法身与彼众生界　　是故佛说本无差
  不净及与净非净　　极净次第应当知
  初即众生次菩萨　　最后如来极清净
  尘垢所污性不明　　喻若重云掩丽日
  烦恼云网皆解脱　　日轮光照满虚空
  劫火炽盛在空中　　太虚本无有烧相
  如是法性不被烧　　老病死火无能坏
  一切世间生灭法　　皆悉不离于虚空
  如是无为法界中　　诸根依此而生灭
  如灯明暖色和合　　离此三法更无灯
  如是佛法与体俱　　离此法外无别体
  客尘烦恼性非有　　与彼净体先相离
  不空无垢法相应　　无有断脱常随转
  如莲开已叶所盖　　如金性净没秽中
  亦如满月罗睺吞　　不能照世烦恼覆
  如清池水妙华敷　　金山埿滓无能污
  如净空中星月满　　解慧圆间垢消除
  譬如旭日照世间　　千光晃耀普周遍
  如地如海谷宝满　　得脱生死养众生
  恒处生死发智悲　　常无常等无住着
  禅定总持清净水　　牟尼王云善谷因
  斯即法身是如来　　亦名圣帝真圆寂
  如水与冷不相离　　佛果涅槃亦复然

论摄颂曰

  果因及自性　　异名与差别
  异相不染性　　亦名常和合
  有无义一性　　略说有十二
  菩提心之名　　应知其次第

释曰。此是论体

其中先示菩提心果。次明功能。从彼因起。因既起已即自性施设相貌异名差别。随受身处不被污染故。说为常和合。无别善法相应。住烦恼中名为无义。出缠清净名为有义。亦名一性俱涅槃故。十二种义次第应知。于中何者是菩提心果。所谓诸佛寂灭涅槃是也。亦非余者。何以故。微细习气悉已断故。言无生者。意成诸蕴本不生故。言无老者。寂灭功能增长殊胜至边际故。言无病者。一切烦恼习障及所知障俱永断故。言无死者。不思议变易无终尽故。言无蕴者。无始无明住地悉以断故。言无过者。一切身口意业无过失故。亦能超过一切诸功能故。彼由何得从菩提心。最胜方便不退失因。而能证得涅槃果故。何者名涅槃界。所谓诸佛不可思议法界之性转依法身。是涅槃界也。是故我今顶礼彼不思议菩提之心。因果增长渐渐明盛。如初月故

复次菩提心种子者。一切世间善法谷生所依住处。如大地故。一切圣者法宝出处。如大海故。一切诸佛道树之所从生。次第之因如种子故。此是菩提心之果也

复次何以得知彼因相应。如转轮王子。言净信者。即是菩提心种。言胜智者。即最胜般若能了一切。名之为母。三摩地者。以定为胎。一切善法安住其中。安乐为体。言大悲者。于诸众生起大悲故。于生死中不疲倦故。及能圆满一切种智。养菩提心。为乳母故。复次彼因和合菩提之心。应知有二。何者为二。一谓烦恼所染污相。二谓白法自性之相。于中染者。彼自性清净常心不染。而为客尘烦恼覆障染污。犹如火等自性清净为灰埿云尘等障蔽。譬如火与宝珠虚空及水自性不染。若离灰等。火等自性皆得清净。一切众生亦复如是。自性之心皆同清净。为贪等烦恼之所染污。若离贪等则心得清净。复云何知白法之相亦皆清净。自性清净一切白法之所依止。一切白法亦从彼生。如苏迷卢山出生宝故。菩提之心亦复如是。一切技艺皆得圆满。获得四种大波罗蜜多。是故说为如来法身。如经中说。世尊。如来法身是常波罗蜜。乐波罗蜜。我波罗蜜。净波罗蜜。彼如来法身。为烦恼随烦恼之所染污。自性清净心是异名说。如经中说。舍利弗。此善法如实真如法界自性清净心相应法体。我依此自性清净心。为众生故说为不可思议

复次彼心于诸众生。为十种事无差别相。所谓无作故。无始不生故。无终不灭故。无碍自性光明故。以空智知一切法一味相犹无性故。无性即无相离诸根境界故。是圣者所行诸佛境界故。一切法所依染净诸法所依止故。远离于常染法无常故。远离于断白法不断故。此复差别略有三相。言不净者。即初说名为众生界。净不净者。即次说明为菩萨也。极清净者。说为如来。如经所说。舍利弗。即此法界过于恒沙。无边烦恼[穀-禾+卵]所缠里。无始世来常为生死波浪漂流。往来生灭恒处中流。说名众生。舍利弗。即此法界无边。厌离生死不住涅槃。一切欲界中住。行十波罗蜜。摄八万四千法门。行菩提行时。名为菩萨。舍利弗。即此法界一切俱胝烦恼解脱。度一切苦。远离一切烦恼随眠缠垢。证得清净最极清净法性中住。一切众生之所瞻仰。住一切尔焰地。得大势力无障无著。于一切法得自在力。说名如来应正等觉。是故舍利弗。无别众生界。无别法身。众生界即法身。法身即众生界。此无二义文字差别

此复云何。在不净时烦恼所染。犹如重云掩覆丽日。自性清净心无有染。客尘烦恼既除遣已。日轮晃曜遍满虚空。既有生老病死。云何复说此性为常。犹如火劫烧太虚空。空界无为本无烧相。法界无为亦复如是。老病死火无能烧坏。是故经说。世尊。世间言说有死有生。非如来藏有生死也。世尊。死者旧诸根坏。生者新诸根起。世尊。如来藏离有为境界相常住寂静。此之藏性既常住不变。未能发起云何得与佛法相应。犹如灯明及与暖色更无别相。法与法身亦复如是。如佛说言。舍利弗。譬如灯无二法功能无异。所为光明及暖色等不相离故。或如宝珠光明形色。如是如是舍利弗。如来所说法身不相离法。智慧功能所为过殑伽沙如来之法。如说。世尊。有二种如来藏空不空智。何者为二。世尊。所谓空如来藏。与烦恼[穀-禾+卵]和合无别不了解脱。不空者。过恒河沙不离不脱不异不思议佛法成就。说如来法身。何故法身万德圆满功德具足。众生因何不得解脱。喻若莲华。邪见罗网叶所覆故。亦如真金。堕于疑惑不净秽故。犹如满月。我慢罗睺之所吞故。如清池水。贪欲尘垢之所浊故。喻彼金山。为嗔恚埿所涂染故。如太虚空。愚痴之云遍满遮故。如日未出。无明住地之所障故。六处大蕴胎藏中住。如器世间相未成故。如是无雨缘未合故

  莲花金满月　　池水金山空
  如日大地云　　佛性客尘染
  烦恼覆功能　　佛事无由作
  略说九譬喻　　染净翻应知

由此如来法身亦复如是。一切烦恼客尘离障尽故。自性功能具足故。得成应供一切众生同共受用。证得常住寂静清凉不思议涅槃界。所谓说如来应正等觉。非异如来法身外别有涅槃。又如所说。众生界得清净时。应知即是法身。法身即是涅槃界。涅槃即是如来。如经中说。世尊。无上正等觉者即是涅槃。世尊。涅槃界者即是如来法身。世尊法身之外无别如来。世尊。如来者即是法身。此无有异也。即是苦灭等。是故经言。世尊。非坏法故名为苦灭。然苦灭者无始无作无生无起无灭无尽离尽。常住不动寂静自性清净。破一切烦恼[穀-禾+卵]。过殑伽河沙不离不脱不思议佛法具足。说如来法身。世尊。此是如来藏。未脱烦恼[穀-禾+卵]。名如来藏。世尊。如来藏者。是诸如来空智。世尊。如来藏。一切声闻缘觉所不能见。先未曾见。昔未曾得。唯有如来得证。及破一切烦恼[穀-禾+卵]。修习一切苦灭道。是故如水与冷。觉性与涅槃无二无别故。或说一乘性欲。或不涅槃。又说同一法界。或小涅槃或中涅槃或大涅槃不尔。下中上因中转果应为一也。因既差别果亦差别。是故言。世尊。无有下中上者得涅槃。世尊。平等法者。平等智者。平等解脱者。解脱知见者。证得涅槃。是故世尊。涅槃界一味等味所谓明解脱味

大乘法界无差别论一卷此是国宋藏。所谓法界无差别论。提云般若译者。今按开元录及贤首疏。则彼丹本五言二十四颂者。真是提云般若所译。而贤首疏所译者。又此论。录及疏中并为单译。而国宋两本与彼丹本。文虽有异义则无殊。必是开元之后。后代重译。但未知何代何人之译。此须待勘。而二藏直以此为提云般若译者错也


大乘广五蕴论

    No. 1613 [cf. No. 1612]

大乘广五蕴论一卷

        安慧菩萨造

        大唐中天竺国三藏地婆诃罗奉　诏译

佛说五蕴。谓色蕴。受蕴。想蕴。行蕴。识蕴。云何色蕴谓四大种。及大种所造色。云何四大种。谓地界。水界。火界。风界。此复云何。谓地坚性。水湿性。火暖性。风轻性。界者。能持自性所造色故

云何四大所造色。谓眼根。耳根。鼻根。舌根。身根。色声香味。及触一分。无表色等。造者因义。根者最胜自在义。主义。增上义。是为根义。所言主义。与谁为主。谓即眼根。与眼识为主。生眼识故。如是乃至身根。与身识为主。生身识故

云何眼根。谓以色为境。净色为性。谓于眼中。一分净色如净醍醐。此性有故。眼识得生。无即不生

云何耳根。谓以声为境。净色为性。谓于耳中。一分净色。此性有故。耳识得生。无即不生

云何鼻根。谓以香为境。净色为性。谓于鼻中。一分净色。此性有故。鼻识得生。无即不生

云何舌根。谓以味为境。净色为性。谓于舌上。周遍净色。有说。此于舌上。有少不遍。如一毛端。此性有故。舌识得生。无即不生

云何身根。谓以触为境。净色为性。谓于身中。周遍净色。此性有故。身识得生。无即不生

云何色。谓眼之境。显色。形色。及表色等。显色有四种。谓青黄赤白。形色。谓长短等

云何声。谓耳之境。执受大种因声。非执受大种因声。俱大种因声

诸心心法。是能执受。蠢动之类。是所执受。执受大种因声者。如手相击。语言等声。非执受大种因声者。如风林驶水等声。俱大种因声者。如手击鼓等声

云何香。谓鼻之境。好香．恶香．平等香。好香者。谓与鼻合时。于蕴相续。有所顺益。恶香者。谓与鼻合时。于蕴相续。有所违损。平等香者。谓与鼻合时。无所损益

云何味。谓舌之境。甘醋碱辛苦淡等

云何触一分。谓身之境。除大种。谓滑性．涩性．重性．轻性．冷饥渴等

滑谓细软。涩谓粗强。重谓可称。轻谓反是。暖欲为冷。触是冷因。此即于因。立其果称。如说诸佛出世乐。演说正法乐。众僧和合乐。同修精进乐。精进勤苦。虽是乐因。即说为乐。此亦如是。欲食为饥。欲饮为渴。说亦如是。已说七种造触。及前四大十一种等

云何无表色等。谓有表业。三摩地所生。无见无对色等。有表业者。谓身语表。此通善不善无记性。所生色者。谓即从彼善不善表所生之色。此不可显示故名无表。三摩地所生色者。谓四静虑所生色等。此无表色。是所造性。名善律仪。不善律仪等亦名业。亦名种子。如是诸色。略为三种。一者可见有对。二者不可见有对。三者不可见无对。是中可见有对者。谓显色等。不可见有对者。谓眼根等。不可见无对者。谓无表色等

云何受蕴。受有三种。谓乐受．苦受．不苦不乐受。乐受者。谓此灭时。有和合欲。苦受者。谓此生时。有乖离欲。不苦不乐受者。谓无二欲。无二欲者。谓无和合。及乖离欲。受谓识之领纳

云何想蕴。谓能增胜。取诸境相。增胜取者。谓胜力能取。如大力者。说名胜力

云何行蕴。谓除受想。诸余心法。及心不相应行。云何余心法。谓与心相应诸行。触．作意．思．欲．胜解．念．三摩地．慧．信．惭．愧．无贪．无嗔．无痴．精进．轻安．不放逸．舍．不害．贪．嗔．慢．无明．见．疑．无惭．无愧．昏沉．掉举．不信．懈怠．放逸．失念．散乱．不正知．恶作．睡眠．寻伺

是诸心法。五是遍行

此遍一切善不善无记心故名遍行

五是别境

此五一一。于差别境。展转决定。性不相离。是中有一。必有一切

十一为善。六为烦恼。余是随烦恼。四为不定。此不定四。非正随烦恼以通善及无记性故。触等体性及业。应当解释

云何触。谓三和合。分别为性

三和。谓眼色识。如是等。此诸和合心心法生故名为触。与受所依为业

云何作意。谓令心发悟为性。令心心法现前警动。是忆念义任持攀缘心为业

云何思。谓于功德过失。及以俱非。令心造作意业为性

此性若有。识攀缘用。即现在前。犹如磁石引铁令动。能推善不善无记心为业

云何欲。谓于可爱乐事。希望为性。爱乐事者。所谓可爱见闻等事。是愿乐希求之义能与精进所依为业

云何胜解。谓于决定境。如所了知。印可为性。决定境者。谓于五蕴等。如日亲说。色如聚沫。受如水泡。想如阳炎。行如芭蕉。识如幻境。如是决定。或如诸法所住自相。谓即如是而生决定。言决定者即印持义。余无引转为业。此增胜故。余所不能引

云何念。谓于惯习事。心不忘失。明记为性。惯习事者。谓曾所习行。与不散乱所依为业

云何三摩地。谓于所观事。心一境性。所观事者。谓五蕴等。及无常苦空无我等。心一境者。是专注义。与智所依为业。由心定故。如实了知

云何慧。谓即于彼择法为性。或如理所引。或不如理所引。或俱非所引

即于彼者。谓所观事。择法者。谓于诸法自相共相由慧简择。得决定故。如理所引者。谓佛弟子。不如理所引者。谓诸外道。俱非所引者。谓余众生。断疑为业。慧能简择。于诸法中。得决定故

云何信。谓于业果诸谛宝等。深正符顺。心净为性

于业者。谓福。非福。不动业。于果者。谓须陀洹。斯陀含。阿那含。阿罗汉果。于谛者。谓苦集灭道谛。于宝者。谓佛法僧宝。于如是业果等。极相符顺。亦名清净。及希求义。与欲所依为业

云何惭。谓自增上。及法增上。于所作罪。羞耻为性。罪谓过失。智者所厌患故。羞耻者。谓不作众罪。防息恶行。所依为业

云何愧。谓他增上。于所作罪。羞耻为性。他增上者谓怖畏责罚。及议论等。所有罪失。羞耻于他。业如惭说

云何无贪。谓贪对治。令深厌患。无著为性。谓于诸有。及有资具。染着为贪。彼之对治。说为无贪。此即于有。及有资具。无染着义。遍知生死诸过失故。名为厌患。恶行不起。所依为业

云何无嗔。谓嗔对治。以慈为性。谓于众生。不损害义。业如无贪说

云何无痴。谓痴对治。如实正行为性。如实者略。谓四圣谛广。谓十二缘起。于彼加行。是正知义。业亦如无贪说

云何精进。谓懈怠对治。善品现前。勤勇为性。谓若被甲。若加行。若无怯弱。若不退转。若无喜足。是如此义。圆满成就。善法为业

云何轻安。谓粗重对治。身心调畅。堪能为性。谓能弃舍十不善行。除障为业。由此力故。除一切障。转舍粗重

云何不放逸。谓放逸对治。依止无贪。乃至精进。舍诸不善。修彼对治诸善法故。谓贪嗔痴。及以懈怠。名为放逸。对治彼故。是不放逸。谓依无贪．无嗔．无痴．精进四法。对治不善法。修习善法故。世出世间正行所依为业

云何舍。谓依如是无贪。无嗔。乃至精进。获得心平等性。心正直性。心无功用性。又复由此。离诸杂染法。安住清净法。谓依无贪。无嗔无痴。精进性故。或时远离昏沉掉举诸过失故。初得心平等。或时任运无勉励故。次得心正直。或时远离诸杂染故。最后获得心无功用。业如不放逸说

云何不害。谓害对治。以悲为性。谓由悲故。不害群生。是无嗔分。不损恼为业

云何贪。谓于五取蕴。染爱耽着为性。谓此缠缚。轮回三界。生苦为业。由爱力故。生五取蕴

云何嗔。谓于群生。损害为性。住不安隐。及恶行所依为业。不安隐者。谓损害他。自住苦故

云何慢。慢有七种。谓慢．过慢．过过慢．我慢．增上慢．卑慢．邪慢。云何慢。谓于劣计己胜。或于等计己等。如是心高举为性。云何过慢。谓于等计己胜。或于胜计己等。如是心高举为性。云何过过慢。谓于胜计己胜。如是心高举为性。云何我慢。谓于五取蕴。随计为我。或为我所。如是心高举为性。云何增上慢。谓未得增上殊胜所证之法。谓我已得。如是心高举为性。增上殊胜所证法者。谓诸圣果。及三摩地。三摩钵底等。于彼未得。谓我已得。而自矜倨。云何卑慢谓于多分殊胜。计己少分下劣。如是心高举为性。云何邪慢。谓实无德。计己有德。如是心高举为性。下生敬重所依为业。谓于尊者。及有德者。而起倨骜。不生崇重

云何无明。谓于业果谛宝。无智为性。此有二种。一者俱生。二者分别。又欲界贪嗔。及以无明。为三不善根。谓贪不善根。嗔不善根。痴不善根。此复俱生。不俱生。分别所起。俱生者。谓禽兽等。不俱生者。谓贪相应等。分别者。谓诸见相应与虚妄决定。疑烦恼所依为业

云何见。见有五种。谓萨迦耶见．边执见．邪见．见取．戒取。云何萨迦耶见。谓于五取蕴。随执为我。或为我所。染慧为性。萨谓败坏义。迦耶谓和合积聚义。即于此中。见一见常。异蕴有我蕴。为我所等。何故复如是说。谓萨者破常想。迦耶破一想。无常积集。是中无我及我所故。染慧者。谓烦恼俱。一切见品所依为业

云何边执见。谓萨迦耶见增上力故。即于所取。或执为常。或执为断。染慧为性。常边者。谓执我自在。为遍常等。断边者。谓执有作者丈夫等彼死已不复生。如瓶既破更无盛用。障中道出离为业

云何邪见。谓谤因果。或谤作用。或坏善事。染慧为性。谤因者。因谓业烦恼性。合有五支。烦恼有三种。谓无明爱取。业有二种谓行及有。有者。谓依阿赖耶识诸业种子此亦名业。如世尊说。阿难。若业能与未来果彼亦名有。如是等。此谤名为谤因。谤果者。果有七支。谓识名色六处触受生老死。此谤为谤果。或复谤无善行恶行。名为谤因。谤无善行恶行果报。名为谤果。谤无此世他世。无父无母。无化生众生。此谤为谤作用。谓从此世往他世作用。种子任持作用。结生相续作用等。谤无世间阿罗汉等。为坏善事。断善根为业。不善根坚固所依为业。又生不善。不生善为业

云何见取。谓于三见。及所依蕴。随计为最为上为胜为极。染慧为性。三见者。谓萨迦耶。边执。邪见。所依蕴者。即彼诸见所依之蕴。业如邪见说

云何戒禁取。谓于戒禁。及所依蕴。随计为清净为解脱。为出离。染慧为性。戒者。谓以恶见为先。离七种恶。禁者。谓牛狗等禁。及自拔发。执三支杖僧佉定慧等。此非解脱之因。又计大自在或计世主。及入水火等。此非生天之因。如是等。彼计为因。所依蕴者。谓即戒禁所依之蕴。清净者。谓即说此无间方便。以为清净。解脱者。谓即以此解脱。烦恼出离者。谓即以此出离生死。是如此义。能与无果唐劳疲苦所依为业。无果唐劳者。谓此不能获出苦义

云何疑。谓于谛宝等。为有为无。犹预为性。不生善法。所依为业。诸烦恼中。后三见及疑。唯分别起。余通俱生。及分别起

云何忿。谓依现前不饶益事。心愤为性。能与暴恶。执持鞭杖。所依为业

云何恨。谓忿为先。结怨不舍为性。能与不忍。所依为业

云何覆。谓于过失。隐藏为性谓藏隐罪故。他正教诲时。不能发露。是痴之分。能与追悔。不安隐住。所依为业

云何恼。谓发暴恶言。陵犯为性。忿恨为先。心起损害。暴恶言者。谓切害粗犷。能与忧苦。不安隐住。所依为业。又能发生非福为业。起恶名称为业

云何嫉。谓于他盛事。心妒为性。为名利故。于他盛事。不堪忍耐。妒忌心生。自住忧苦。所依为业

云何悭。谓施相违。心吝为性。谓于财等。生吝惜故。不能惠施。如是为悭。心遍执着利养众具。是贪之分。与无厌足。所依为业。无厌足者。由悭吝故。非所用物。犹恒积聚

云何诳。谓矫妄于他诈现不实功德为性。是贪之分。能与邪命。所依为业

云何谄。谓矫设方便。隐己过恶。心曲为性。谓于名利。有所计着。是贪痴分。障正教诲为业。复由有罪。不自如实发露归忏。不任教授

云何憍。谓于盛事。染着倨傲。能尽为性。盛事者。谓有漏盛事。染着倨傲者。谓于染爱。悦豫矜恃。是贪之分。能尽者。谓此能尽诸善根故

云何害。谓于众生。损恼为性。是嗔之分。损恼者。谓加鞭杖等。即此所依为业

云何为惭。谓所作罪。不自羞耻为性。一切烦恼。及随烦恼。助伴为业

云何无愧。谓所作罪。不羞他为性。业如无惭说

云何昏沉。谓心不调畅。无所堪任。蒙昧为性。是痴之分。与一切烦恼。及随烦恼。所依为业

云何掉举。谓随忆念喜乐等事。心不寂静为性。应知忆念先所游戏欢笑等事。心不寂静。是贪之分。障奢摩他为业

云何不信。谓信所治。于业果等。不正信顺。心不清净为性。能与懈怠。所依为业

云何懈怠。谓精进所治。于诸善品。心不勇进为性。能障勤修众善为业

云何放逸。谓依贪嗔痴懈怠故。于诸烦恼。心不防护。于诸善品。不能修习为性。不善增长。善法退失。所依为业

云何失念。谓染污念。于诸善法。不能明记为性。染污念者。谓烦恼俱。于善不明记者。谓于正教授。不能忆持义能与散乱所依为业

云何散乱。谓贪嗔痴分。令心心法流散为性。能障离欲为业

云何不正知。谓烦恼相应慧。能起不正身语意行为性。违犯律行所依为业。谓于去来等。不正观察故。而不能知应作不应作。致犯律仪

云何恶作。谓心变悔为性。谓恶所作故名恶作。此恶作体非即变悔。由先恶所作。后起追悔故。此即以果从因为目。故名恶作。譬如六触处说为先业。此有二位。谓善不善。于二位中。复各有二。若善位中。先不作善。后起悔心。彼因是善。悔亦是善。若先作恶。后起悔心。彼因不善。悔即是善。若不善位。先不作恶。后起悔心。彼因不善。悔亦不善。若先作善。后起悔心。彼因是善。悔是不善

云何睡眠。谓不自在转。昧略为性。不自在者。谓令心等不自在转。是痴之分。又此自性不自在故。令心心法极成昧略。此善不善。及无记性。能与过失。所依为业

云何寻。谓思慧差别。意言寻求。令心粗相分别为性。意言者。谓是意识。是中或依思。或依慧而起。分别粗相者。谓寻求瓶衣车乘等之粗相。乐触苦触等所依为业

云何伺。谓思慧差别。意言伺察。令心细相分别为性。细相者。谓于瓶衣等。分别细相成不成等差别之义

云何心不相应行。谓依色心等。分位假立。谓此与彼不可施设。异不异性。此复云何。谓得．无想定．灭尽定．无想天．命根．众同分．生．老．住．无常．名身．句身．文身．异生性。如是等

云何得。谓若获。若成就。此复三种。谓种子成就。自在成就。现起成就。如其所应

云何无想定。谓离遍净染未离上染。以出离想作意为先所有不恒行心心法灭为性

云何灭尽定。谓已离无所有处染。从第一有更起胜进。暂止息想作意为先。所有不恒行。及恒行一分。心心法灭为性不恒行。谓六转识。恒行。谓摄藏识。及染污意。是中六转识品。及染污意灭。皆灭尽定

云何无想天。谓无想定所得之果。生彼天已。所有不恒行。心心法灭为性

云何命根。谓于众同分。先业所引住时分限为性

云何众同分。谓诸群生各各自类相似为性

云何生。谓于众同分。所有诸行。本无今有为性

云何老。谓彼诸行相续。变坏为性

云何住。谓彼诸行相续。随转为性

云何无常。谓彼诸行相续。谢灭为性

云何名身。谓于诸法自性。增语为性。如说眼等

云何句身。谓于诸法差别增语为性。如说诸行无常等

云何文身。谓即诸字。此能表了前二性故。亦名显。谓名句所依。显了义故。亦名字。谓无异转故。前二性者。谓诠自性及以差别。显谓显了

云何异生性。谓于圣法。不得为性

云何识蕴。谓于所缘。了别为性。亦名心。能采集故。亦名意。意所摄故。若最胜心。即阿赖耶识。此能采集诸行种子故。又此行相不可分别。前后一类相续转故。又由此识从灭尽定。无想定。无想天起者。了别境界转识。复生待所缘缘差别转故。数数间断还复生起。又令生死流转回还故。阿赖耶识者。谓能摄藏一切种子。又能摄藏我慢相故。又复缘身为境界故。又此亦名阿陀那识。执持身故。最胜意者。谓缘藏识为境之识。恒与我痴．我见．我慢．我爱相应。前后一类相续随转。除阿罗汉圣道。灭定现在前位。如是六转识。及染污意。阿赖耶识。此八名识蕴

问蕴为何义。答积聚是蕴义。谓世间相续品类趣处差别色等总略摄故。如世尊说。比丘所有色。若过去。若未来。若现在。若内若外。若粗若细。若胜若劣。若近若远。如是总摄为一色蕴

复有十二处。谓眼处．色处．耳处．声处．鼻处．香处．舌处．味处．身处．触处．意处．法处。眼等五处。及色声香味处。如前已释。触处谓诸大种及一分触。意处即是识蕴。法处谓受想行蕴。并无表色等。及诸无为

云何无为。谓虚空无为．非择灭无为．择灭无为。及真如等。虚空者。谓容受诸色。非择灭者。谓若灭非离系

云何非离系。谓离烦恼对治诸蕴毕竟不生

云何择灭。谓若灭是离系

云何离系。谓烦恼对治诸蕴毕竟不生

云何真如。谓诸法法性法无我性

问处为何义。答诸识生长门是处义

复有十八界。谓眼界．色界．眼识界．耳界．声界．耳识界．鼻界．香界．鼻识界．舌界．味界．舌识界．身界．触界．身识界．意界．法界．意识界。眼等诸界。及色等诸界。如处中说。六识界者。谓依眼等根。缘色等境。了别为性。意界者。即彼无间灭等。为显第六识依止。及广建立十八界故。如是色蕴即十处十界及法处法界一分。识蕴即意处及七心界。余三蕴及色蕴一分。并诸无为。即法处法界

问界为何义。答任持无作用性自相是界义。问以何义故说蕴界处等。答对治三种我执故。所谓一性我执。受者我执。作者我执。如其次第

复次此十八界几有色。谓十界一少分。即色蕴自性。几无色。谓所余界

几有见。谓一色界。几无见。谓所余界

几有对。谓十色界。若彼于此有所碍故。几无对。谓所余界

几有漏。谓十五界。及后三少分。谓于是处烦恼起故。现所行处故。几无漏。谓后三少分。几欲界系。谓一切。几色界系。谓十四。除香味及鼻舌识。几无色界系。谓后三。几不系。谓即彼无漏。几蕴所摄。谓除无为。几取蕴所摄。谓有漏。几善。几不善。几无记。谓十通三性。七心界色声。及法界一分。八无记性。几是内。谓十二。除色声香味触及法界。几是外。谓所余六

几有缘。谓七心界及法界少分。心所法性。几无缘。谓余十及法界少分

几有分别。谓意识界。意界。及法界少分

几有执受。谓五内界。及四界少分。谓色香味触。几非执受。谓余九及四少分

几同分。谓五内有色界。与彼自识等境界故

几彼同分。谓彼自识空时。与自类等故

大乘广五蕴论一卷


大乘唯识论

    No. 1589 [Nos. 1588, 1590; cf. No. 1591]

    大乘唯识论序

唯识论者。乃是诸佛甚深境界。非是凡夫二乘所知。然此论始末明三种空。何者为三。一者人无我空。二者因缘法体空。三者真归佛性空。我空者。我本自无。但凡夫之人愚痴颠倒。于五阴中妄计为有。何以知无。凡夫依心识妄想分别。于五阴因缘法中见我为有。然此我相于五阴中实不可得。若尔般若观此五阴中一二离二。实体不可得犹如兔角。若有此我于一中住者。应于一中见。应于异中见。应于和合中见。云何一中无我者。以有常无常过故。若有我与五阴一者。五阴无常我亦应无常。复有我若与阴一者。我是常故阴亦应常。若我与阴二者。一边即同前无常。一边即同前常。若离二边者此亦不然。离于二边别相不可得。是故实无神我。如是知者名入人无我空。因缘法体空者。谓诸色等因缘法。以随俗因缘起。云何随俗因缘起。世人见牛起于牛想不起马想。见马起于马想不起牛想。色等法中亦复如是。见柱起柱想不起色想。见色起色想不起柱想。如薪火相待无实。以离于薪更无实火。以离于火更无实薪。于薪更无实火。以离于火更无实薪。于薪更无实火能作薪因。以离于火更无实薪能作火因。而见火说假名薪。见薪说假名火。以相待成故。如是能成所成。而不离能成因而有所成。不离所成因而有能成。如彼薪火能成所成亦实无。是名因缘法体空。真如法空者。所谓佛性清净之体古今一定。故经云佛性者名为第一义空。所言空者体无万相故。言其空无万相者。无有世间色等有为法故无万相。非是同于无性法。以其真如法体。是故经云。去八解脱者名不空空。是故不同无法空也。若如是观。是名解真如法空。唯识论言唯识者。明但有内心无色香等外诸境界。何以得知。如人目有肤翳妄见毛轮犍闼婆城等种种诸色实无前境界。但虚妄见有如是诸众生等外诸境界。故言唯识。若尔但应言破色。不应言破心。此亦有义。心有二种。一者相应心。二者不相应心。相应心者。谓无常妄识虚妄分别。与烦恼结使相应。名相应心。不相应心者。所谓常住第一义谛。古今一相自性清净心。今言破心者。唯破妄识烦恼相应心。不破佛性清净心。故得言破心也

大乘唯识论一卷

        天亲菩萨造

        陈天竺三藏真谛译

  修道不共他　　能说无等义
  顶礼大乘理　　当说立及破
  无量佛所修　　除障及根本
  唯识自性静　　昧劣人不信

于大乘中立三界唯有识。如经言。佛子三界者唯有心。心意识等是总名。应知此心有相应法。唯言者为除色尘等

  实无有外尘　　似尘识生故
  犹如翳眼人　　见毛二月等

大乘中立义。外尘实无所有。若尔云何见有外尘。为证此义故言。似尘识生故。由识似尘现故。众生于无尘中见尘。为显此识故立斯譬如眼有病及眼根乱。于无物中识似二月及鹿渴等而现。唯识义亦如是。是故三界实无外尘。识转似尘显。三性二谛同无性性。名非安立

  处时悉无定　　无相续不定
  作事悉不成　　若唯识无尘

此偈欲显何义。若离六尘。色等识生不从尘生。何因此识有处得生。非一切处生。于此处中或生不生而不恒生。若众人同在一时一处。是识不定相续生非随一人。如人眼有翳见毛二月等。余人则不见。复有何因翳眼人所见发蝇等尘。不能作发蝇等事。余尘能作。又梦中所得饮食衣服毒药刀杖等。不能作饮食等事余物能作。又乾闼婆城实非有。不能作城事。余城能作。若同无尘。是四种义云何不同。是故离尘。定处定时不定相续及作事。是四义悉不成。非不成。定处等义成如梦。云何梦中离诸尘有处。或见国园男女等非一切处。或是处中有时见有时不见而不恒见。是故离尘。定处定时得成立。如饿鬼续不定。如饿鬼相续不定得成。云何得成。一切同见脓河等。脓遍满河故名脓河。犹如酥瓮。饿鬼同业报位故。一切悉见脓等遍满河中非一。如见脓河。余粪秽等河亦尔。或见有人捉持力杖。遮护不令得近。如此唯识相续不定离尘得成如梦害作事

如梦离男女交会出不净为相梦害得成作事亦尔。如此喻各各譬处时定等四义得成

复次如地狱一切由地狱譬四义得成立。云何得成。见狱卒及共受逼害。如地狱中诸受罪人见狱卒等定处定时见狗乌山等来平等见非一。受逼害亦尔。实无狱卒等。由同业报增上缘故。余处亦如是。由此通譬四义得成。何故狱卒狗乌等不许是实众生无道理故是狱卒不成地狱道受罪人故如地狱苦不能受故。若彼地狱人更互相害。云何得分别此是地狱人彼是狱卒。若同形貌力量无更互相怖畏义。于赤铁地火焰恒起。彼自不能忍受烧燃苦。云何于中能逼害他。彼非地狱人。云何得生地狱中。云何畜生得生天上。如是地狱畜生及饿鬼别类等生地狱中名为狱卒。是事不然

  如畜生生天　　地狱无杂道
  地狱中苦报　　由彼不能受

若畜生生天由杂业能感起世界乐。生中受天乐报。狱卒等不尔。不受地狱苦报故。是故畜生及饿鬼。无道理得生地狱中

  由罪人业故　　似狱卒等生
  若许彼变异　　于识何不许

由地狱人业报故。四大别类生狱卒等种种差别显现色形量异。说名狱卒等。变异亦尔。或显现动摇手足等。生彼怖畏作杀害事。或有两山相似羺羊乍合乍离。铁树林中铁树利刺或低或竖彼言不无此事。何故不许由识起业识有变异。而说是四大有此变异。复次

  业熏习识内　　执果生于外
  何因熏习处　　于中不说果

是罪人业于地狱中。能见如此等事四大聚及其变异。此业熏习在地狱人识相续中。不在余处。此熏习处是识变异似狱卒等。是业果报而不许在本处。非熏习处而许业果生。何因作如此执。阿含是因。若但识似色等尘生无色等外尘。佛世尊。不应说实有色等诸入。此阿含非因。以非阿含意故

  色等入有教　　为化执我人
  由随别意说　　如说化生生

如佛世尊说有化生众生。由别意故说。幻相续不断乃至来生。复次佛说

  无众生及我　　但法有因果

由此别说知是别教。佛世尊说。色等诸入亦如是。为度宜闻说入众生。此说依教意。别教意云何

  识自种子生　　显现起似尘
  为成内外入　　故佛说此二

此偈欲显何义。似尘识从自种子胜类变异生。是种子及似尘。显现为似色识生方便门故。佛世尊次第说。眼入色入乃至似触识。从自种子至变异差别生。是种子及似触。显现为触识生方便门故佛世尊说。为身入及触入若约此义说入。有何利益

  若他依此教　　得入人无我
  由别教能除　　分别入法空

若佛世尊由此义说诸入。受化弟子得入人空。从唯六双但六识生。无一法为见者乃至为触者。若知此义说人空。所化弟子得入人我空。由别说者。由说唯识教。得入法我空。云何得入法空。一切法唯识生似色尘等。无有一法色等为相。若知如此得入法空。若一切法一向无。是唯识亦应无。云何得成立。非一切法一向无。说为法空。非知此义名入法空。若尔云何得入法空。由除分别性相故。得入法空。如凡夫分别所有法相。由此法相一切法空无所有。是名法空。不由不可言体诸佛境界说诸法空。如此唯识由别识所分别体无所有故空。若入此理得成立唯识入法我空。不由拨一切法无。若不如此别识应成别识境。唯识义则不成。识尘实有故。此云何可信由此义。佛世尊说。色等入是有不由实有。色等入为眼识等境界。由如此理是义可信

  外尘与邻虚　　不一亦不异
  彼聚亦非尘　　邻虚不成故

此偈欲显何义。是色等入各各是眼识等境。为当与邻虚一如有分色鞞世师所执。为当不一由邻虚各别故。为当是邻虚聚色入与邻虚成一作眼识境。是义不然。是有分色于分中不可见异体故。亦非多邻虚各各不可见故。亦非多邻虚聚集成尘。由邻虚不成一物故。云何不成

  一时六共聚　　邻虚成六方
  若六同一处　　聚量如邻虚

有六邻虚从六方来。与一邻虚共聚。是一邻虚不成一物。有六方分故。是一邻虚处他方邻虚不得住故。若一邻虚处即是六处。一切同一处故。则一切聚物量同邻虚。更互不相过故。如邻虚量聚亦不应可见。若汝言邻虚不得聚集无方分故。此过失不得起。是邻虚聚更互相应。罽宾国毗婆沙师作如此说。则应问之。如汝所说邻虚聚物。此聚不异邻虚

  若邻虚不合　　聚中谁和合
  复次无方分　　邻虚聚不成

若邻虚无和合。于聚中此和合属何法。若汝言邻虚更互得和合。此义不然。何以故。邻虚无方分故。若和合不成。何况有假名聚。应如此说。聚有方分。若和合义不可立。无方分邻虚云何和合得成。是故邻虚不成一物。邻虚和合。若可然若不可然。今所不论

  若物有方分　　不应成一物

邻虚东方分异余五方。乃至下方分亦如是。若分有异邻虚取分为体。云何得成一物影障复云何

若一邻虚无有方分。日正出时云何一边有影。何故作如此问。是邻虚无有别分正为日所照。复次此邻虚与彼邻虚若并无方分。云何相障。何以故。此邻虚无有余分。是处相合他来则障。若无有障一切六方邻虚同一处故。则一切聚同邻虚量。此义已如前说。是影及障。属聚不属邻虚。云何不许此义。汝今许聚是有异邻虚不。故说影障属聚耶不也。若同则无二。若聚不异邻虚。此影及障则不属聚。何以故。但形相分别谓之为聚。何用作此思量。是色等诸尘体相未破。何者为其体。眼等境界及青等类此义即应共思量。此眼等境界及青等类。汝执为尘体。为是多物为。是一物若尔有何失。若多者其失如前。若一者亦有过。如偈言

  若一无次行　　俱无已未得
  及别类多事　　亦无细难见

若一切青黄等无有隔别。是眼境界执为一物。于地则无次第行。若一下足应遍行一切。此间已得彼处未得。于一时中此二不成。何以故。一时中一物不应有已得未得。不应有多别类如象马等军。亦不应有多别事。何以故。是一物处多物则在其中。此彼差别云何得成。复次云何为一是二所至中间则空。复次是最细水虫与大同色。无不可见义。若汝由相差别色等诸尘。执有别物不由别义。若尔决定约邻虚别类。应分别尘差别。则邻虚不成一物。色等五尘非眼等境界。是故唯识义得成。诸尘者。谓识及识法为体。离能取所取故无增。立正因果故不减。无无因及不平等因。二空及十二缘生即是其自性。如偈言。是有是无由依诸量可决是非。一切量中证量最胜。若尘实无如此证智。云何得起。所谓我证如此

  证智如梦中

如梦时。离尘见山树等色。无有外尘。证智亦如此

  是时如证智　　是时不见尘
  云何尘可证

如汝所说证智起时。谓我如此证。此时中汝不得见尘。但意识分别。眼识已灭故。是尘云何可证若人说刹那灭。此人是时执色乃至触已谢。问若非五识所量。意不能忆持。是故五尘决定是五识所量。量者是名见。是故色等六尘说是所证。答是义不然。谓先已证尘后方忆持。何以故

如说似尘识

离色等六尘眼等六识。似六尘起。此义如前说

从此生忆持

从此似尘识有。分别意识与忆持相应。似前所起之尘后时得生。是故不可执由忆持起。谓先以识证尘。若如梦中识无尘得起觉时。若尔如世人自知梦识无尘。亦应自知觉识无尘。既无此事。故知觉时所见尘。异梦中所见。复次梦有更起义。觉时则不尔。非一切无尘。答此言非证

  梦见尘非有　　未觉不能知

如是虚妄分别串习惛熟。世人见非实尘如梦所见谓为实有。觉则不尔。如实能解梦尘非有。如是若观行人修出世治道得无分别智。入非安立圣谛见位得觉悟。是时无分别智。后得清净世智。如理见六尘实无所有。此义平等。若由自相续转异胜故。众生六识似六尘起。实不从尘生者。由事善恶友听受正邪二法。众生有正邪二定。云何得成。若所亲近及说实无

  更互增上故　　二识正邪定

一切众生由更互识增上故。有二种识定成。或正定或邪定。更互者。自他共成自他事。是故别识相续胜能故。别识相续胜能生。不从外尘起。若如梦识无境界。觉识亦如此者。云何梦觉二人。行善作恶爱憎两果。未来不同

  梦识由眠坏　　未来果不同

是正因。能令梦心无有果报。谓惛睡所坏故。心弱不能成善恶业。问若一切唯有识。则无身及言。云何牛羊等畜生。非屠儿所害而死。若彼死非屠儿所作。屠儿云何得杀生罪。答曰

  由他识变异　　死事于此成
  如他失心等　　因鬼等心力

犹如鬼神等心变异故。令他或失念。或得梦。或着鬼等。诸变异得成。复次有神通人心愿故。有如此事。如娑罗那王等得梦。由大迦旃延心愿故。复次阿兰若仙人嗔心故。毗摩质多罗王见怖畏事。如是由他识变异。能断他命根。因此事故。同类相续断说名为死。此义应知。复次

  云何檀陀林　　空寂由仙嗔

若由他识变异增上不许众生死。世尊。成立心重罚最为大罪。问优婆离长者。长者汝曾闻不。云何檀陀柯林。迦陵伽林。摩登伽林。空寂清净。长者答言。瞿昙。曾闻由仙人嗔心

  心重罚大罪　　若尔云何成

若汝执有诸鬼神爱敬仙人故。杀害此中众生。不由仙人嗔心。若尔云何由此业心重罚大罪。剧于身口重罚。由仙人嗔心故。如是多众生死故。心重罚成大罪。若一切唯识。他心通人为知他心为不知。若尔有何所以。若不知云何得他心通。若知云何言识无境

  他心通人智　　不如境云何
  如知自心故　　不知如佛境

是他心智境云何不如由无智故。如不可言体他心则成佛境如此不能知故。此二境界不如非是此显现故。能取所取分别未灭故。此唯识理无穷。简择品类甚深无底

  成就唯识理　　我造随自能
  如理及如量　　难思佛等境

我等作一切功用。不能思度此理。此理非觉观所缘故。何人能遍通达此境。是佛境界。何以故。诸佛世尊于一切法知无碍故。如量如理。此境唯佛所见

婆薮槃豆菩萨造唯识论竟

菩提留支法师。先于北翻出唯识论。慧恺以陈天嘉四年岁次癸未正月十六日。于广州制旨寺。请三藏法师枸罗那他。重译此论。行翻行讲。至三月五日方竟。此论外国本有义疏。翻得两卷。三藏法师更释本文。慧恺注记。又得两卷。末有僧忍法师。从晋安赍旧本达番禺。恺取新文对仇校旧本。大意虽复略同。偈语有异。长行解释。词繁义阙。论初无归敬。有识君子宜善寻之。今谨别抄偈文。安于论后。庶披阅者为易耳。此论是佛法正义。外国盛弘　沙门慧恺记

  修道不共他　　能说无等义
  顶礼大乘理　　当说立及破
  无量佛所修　　除障及根本
  唯识自性静　　昧劣人不乐
  实无有外尘　　似尘识生故
  犹如翳眼人　　见毛两月等
  处时悉无定　　无相续不定
  作事悉不成　　若唯识无尘
  定处等义成　　如梦如饿鬼
  续不定一切　　同见脓河等
  如梦害作事　　复次如地狱
  一切见狱卒　　及共受逼害
  如畜生生天　　地狱无杂道
  地狱中苦报　　由彼不能受
  由罪人业故　　似狱卒等生
  若许彼变异　　于彼何不许
  业熏习识内　　执果生于外
  何因熏习处　　于中不说果
  色等入有教　　为化执我人
  由随别意说　　如说化生生
  识自种子生　　显现起似尘
  为成内外入　　故佛说此二
  若他依此教　　得入人无我
  由别教能除　　分别入法空
  外尘与邻虚　　不一亦不异
  彼聚亦非尘　　邻虚不成故
  一时六共聚　　邻虚成六方
  若六同一处　　聚量如邻虚
  若邻虚不合　　聚中谁和合
  复次无方分　　邻虚聚不成
  若物有方分　　不应成一物
  影障复云何　　若同则无二
  若一无次行　　俱无已未得
  及别类多事　　亦无细难见
  证智如梦中　　是时如证智
  是时不见尘　　云何尘可证
  如说似尘识　　从此生忆持
  梦见尘非有　　未觉不能知
  更互增上故　　二识正邪定
  梦识由眠坏　　未来果不同
  由他识变异　　死事于此成
  如他失心等　　因鬼等心力
  云何檀陀林　　空寂由仙嗔
  心重罚大罪　　若尔云何成
  他心通人智　　不如境云何
  如知自心故　　不知如佛境
  成就唯识理　　我造随自能
  如理及如量　　难思佛等境

大乘唯识论


大乘五蕴论

    No. 1612 [cf. No. 1613]

大乘五蕴论一卷

        世亲菩萨造

        三藏法师玄奘奉　诏译

如薄伽梵略说五蕴。一者色蕴。二者受蕴。三者想蕴。四者行蕴。五者识蕴

云何色蕴。谓四大种及四大种所造诸色。云何四大种谓地界水界火界风界。云何地界。谓坚强性。云何水界。谓流湿性。云何火界。谓温燥性。云何风界。谓轻等动性。云何四大种所造诸色。谓眼根耳根鼻根舌根身根。色声香味所触一分无表色等。云何眼根。谓色为境清净色。云何耳根。谓声为境清净色。云何鼻根。谓香为境清净色。云何舌根。谓味为境清净色。云何身根。谓所触为境清净色。云何为色。谓眼境界。显色形色及表色等。云何为声。谓耳境界。执受大种因声。非执受大种因声。俱大种因声。云何为香。谓鼻境界。好香恶香及所余香。云何为味。谓舌境界。甘味酢味碱味辛味苦味淡味

云何为所触一分。谓身境界。除四大种。余所造触。滑性涩性重性轻性冷饥渴等。云何名为无表色等。谓有表业及三摩地所生色等无见无对

云何受蕴。谓三领纳。一苦二乐三不苦不乐。乐谓灭时有和合欲。苦谓生时有乖离欲。不苦不乐谓无二欲

云何想蕴。谓于境界取种种相

云何行蕴。谓除受想。诸余心法及心不相应行

云何名为诸余心法。谓彼诸法与心相应。彼复云何。谓触作意受想思。欲胜解念三摩地慧。信惭愧无贪善根无嗔善根无痴善根精进轻安不放逸舍不害。贪嗔慢无明见疑。忿恨覆恼嫉悭诳谄憍害无惭无愧惛沉掉举不信懈怠放逸忘念散乱不正知。恶作睡眠寻伺

是诸心法。五是遍行。五是别境。十一是善六是烦恼。余是随烦恼。四是不决定

云何为触。谓三和合分别为性。云何作意。谓能令心发悟为性。云何为思。谓于功德过失及俱相违。令心造作意业为性。云何为欲。谓于可爱事希望为性。云何胜解。谓于决定事即如所了印可为性。云何为念。谓于串习事令心不忘明记为性。云何三摩地。谓于所观事令心一境不散为性。云何为慧。谓即于彼择法为性。或如理所引。或不如理所引。或俱非所引

云何为信。谓于业果诸谛宝中。极正符顺心净为性。云何为惭。谓自增上及法增上。于所作罪羞耻为性

云何为愧。谓世增上于所作罪羞耻为性

云何无贪。谓贪对治。令深厌患无著为性

云何无嗔。谓嗔对治。以慈为性

云何无痴。谓痴对治。以其如实正行为性

云何精进。谓懈怠对治。心于善品勇悍为性

云何轻安。谓粗重对治。身心调畅堪能为性

云何不放逸。谓放逸对治。即是无贪乃至精进依止此故舍不善法。及即修彼对治善法

云何为舍。谓即无贪乃至精进依止此故。获得所有心平等性心正直性心无发悟性。又由此故于已除遣染污法中无染安住

云何不害。谓害对治。以悲为性

云何为贪。谓于五取蕴染爱耽着为性

云何为嗔。谓于有情乐作损害为性

云何为慢。所谓七慢。一慢。二过慢。三慢过慢。四我慢。五增上慢。六卑慢。七邪慢。云何慢。谓于劣计己胜。或于等计己等。心高举为性。云何过慢。谓于等计己胜。或于胜计己等。心高举为性。云何慢过慢。谓于胜计己胜。心高举为性。云何我慢。谓于五取蕴随观为我或为我所。心高举为性。云何增上慢。谓于未得增上殊胜所证法中。谓我已得。心高举为性。云何卑慢。谓于多分殊胜计己少分。下劣心高举为性。云何邪慢。谓实无德计己有德。心高举为性

云何无明。谓于业果及谛宝中无智为性。此复二种。所谓俱生分别所起。又欲缠贪嗔及欲缠无明。名三不善根。谓贪不善根。嗔不善根。痴不善根

云何为见。所谓五见。一萨迦耶见。二边执见。三邪见。四见取。五戒禁取。云何萨迦耶见。谓于五取蕴随观为我或为我所。染污慧为性。云何边执见。谓即由彼增上力故。随观为常或复为断。染污慧为性。云何邪见。谓或谤因或复谤果。或谤作用或坏善事。染污慧为性。云何见取。谓即于三见及彼所依诸蕴。随观为最为上为胜为极。染污慧为性。云何戒禁取。谓于戒禁及彼所依诸蕴。随观为清净为解脱为出离。染污慧为性。云何为疑。谓于谛等犹豫为性。诸烦恼中后三见及疑唯分别起。余通俱生及分别起

云何为忿。谓遇现前不饶益事心损恼为性。云何为恨。谓结怨不舍为性。云何为覆。谓于自罪覆藏为性。云何为恼。谓发暴恶言尤蛆为性。云何为嫉。谓于他盛事心妒为性。云何为悭。谓施相违心吝为性。云何为诳。谓为诳他诈现不实事为性。云何为谄。谓覆藏自过方便所摄心曲为性。云何为憍。谓于自盛事染着倨傲心恃为性。云何为害。谓于诸有情损恼为性

云何无惭。谓于所作罪不自羞耻为性。云何无愧。谓于所作罪不羞耻他为性。云何惛沈。谓心不调畅无所堪能蒙昧为性。云何掉举。谓心不寂静为性。云何不信。谓信所对治。于业果等不正信顺。心不清净为性。云何懈怠。谓精进所治。于诸善品心不勇猛为性。云何放逸。谓即由贪嗔痴懈怠故。于诸烦恼心不防护。于诸善品不能修习为性。云何失念谓染污念于诸善法不能明记为性。云何散乱。谓贪嗔痴分心流荡为性。云何不正知。谓于身语意现前行中不正依住为性

云何恶作。谓心变悔为性。云何睡眠。谓不自在转心极昧略为性。云何为寻。谓能寻求意言分别思慧差别令心粗为性。云何为伺。谓能伺察意言分别思慧差别令心细为性。云何心不相应行。谓依色心心法分位。但假建立不可施设。决定异性及不异性。彼复云何。谓得无想等至灭尽等至无想所有。命根众同分。生老住无常。名身句身文身异生性如是等类

云何为得。谓若获若成就。此复三种。谓若种子若自在若现前。如其所应

云何无想等至。谓已离遍净贪。未离上贪。由出离想作意为先。不恒现行心心法灭为性

云何灭尽等至。谓已离无所有处贪。从第一有更求胜进。由止息想作意为先。不恒现行及恒行一分心心法灭为性

云何无想所有。谓无想等至果。无想有情天中生已。不恒现行心心法灭为性。云何命根。谓于众同分中。先业所引。住时决定为性。云何众同分。谓诸有情自类相似为性。云何为生。谓于众同分中。诸行本无今有为性。云何为老。谓即如是诸行相续变异为性。云何为住。谓即如是诸行相续随转为性。云何无常。谓即如是诸行相续谢灭为性。云何名身。谓诸法自性增语为性。云何句身。谓诸法差别增语为性。云何文身。谓诸字为性。以能表彰前二种故。亦名为显。由与名句为所依止显了义故。亦名为字。非差别门所变易故。云何异生性。谓于诸圣法不得为性。如是等类已说行蕴

云何识蕴。谓于所缘境了别为性。亦名心意。由采集故。意所摄故。最胜心者。谓阿赖耶识。何以故。由此识中诸行种子皆采集故。又此行缘不可分别。前后一类相续随转。又由此故从灭尽等至无想等至无想所有起者。了别境名转识还生。待所缘缘差别转故。数数间断还复转故。又令生死流转旋还故。阿赖耶识者。谓能摄藏一切种子故。又能摄藏我慢相故。又复缘身为境界故。即此亦名阿陀那识。能执持身故。最胜意者。谓缘阿赖耶识为境。恒与我痴我见我慢及我爱等相应之识。前后一类相续随转。除阿罗汉果及与圣道灭尽等至现在前位

问以何义故说名为蕴。答以积聚义说名为蕴。谓世相续品类趣处差别色等总略摄故

复有十二处。谓眼处色处。耳处声处。鼻处香处。舌处味处。身处触处。意处法处。眼等五处及色声香味处。如前已释。言触处者。谓四大种及前所说所触一分。言意处者。即是识蕴。言法处者。谓受想行蕴无表色等及与无为。云何无为。谓虚空无为。非择灭无为。择灭无为。及真如等。云何虚空。谓若容受诸色。云何非择灭。谓若灭非离系。此复云何。谓离烦恼对治而诸蕴毕竟不生。云何择灭。谓若灭是离系。此复云何。谓由烦恼对治故诸蕴毕竟不生。云何真如。谓诸法法性法无我性

问以何义故名为处耶。答诸识生长门义。是处义

复有十八界。谓眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界

眼等诸界及色等诸界。如处中说。六识界者。谓依眼等根缘色等境。了别为性。言意界者。谓即彼无间灭等。为欲显示第六意识。及广建立十八界故。如是色蕴即十处十界及法处法界一分识蕴即意处及七心界。余三蕴及色蕴一分并诸无为即法处法界

问以何义故说名为界。答以能任持无作用性自相义故。说名为界

问以何义故宣说蕴等。答为欲对治三种我执。如其次第三种我执者。谓一性我执。受者我执作者我执

复次此十八界几有色。谓十界一少分即色蕴自性

几无色。谓所余界

几有见。谓一色界

几无见。谓所余界

几有对。谓十有色界。若彼于是处有所障碍。是有对义

几无对。谓所余界

几有漏。谓十五界及后三少分。由于是处烦恼起故。现所行处故

几无漏。谓后三少分

几欲界系。谓一切

几色界系。谓十四。除香味鼻舌识

几无色界系谓后三

几不系。谓即彼无漏界

几蕴所摄。谓除无为

几取蕴所摄谓有漏

几善几不善几无记。谓十通三种七心界及色声法界八无记

几是内。谓十二。除色声香味触及法界。几是外。谓六即所除

几有缘。谓七心界及法界少分心所有法

几无缘。谓余十及法界少分

几有分别。谓意界意识界法界少分

几执受。谓五内界及四界少分。谓色香味触

几非执受。谓余九四少分

几同分。谓五内有色界。由与自识等境界故

几彼同分。谓即彼自识空时与自类等故

大乘五蕴论一卷


大乘庄严经论

    No. 1604

    大乘庄严经论卷第一

        太子右庶子安平男臣李百药奉　敕序

臣闻。天帝受无上之法。景福会昌。轮王致正真之道。神祇合德。是则圣人执契。玄化潜通。至诚所感。冥功斯应。皇情西顾。法海东流。如开洪范之图。似得圆光之梦。持线妙典。发金口而秘纶言。书叶旧章。自龙宫而升麟阁。昔迦维驭世。大启法门。悬明镜于无象。运虚舟于彼岸。空有兼谢。生灭俱忘。绝智希夷之表。遗形动寂之外。然随缘利见。应迹生知。震大地而萃人天。放神光而掩日月。百亿须弥。俱沾声教。三千世界。尽入堤封。愍三毒之缰锁。矜五荫之缠盖。惜飞电于浮生。叹悬藤于逝水。八关云辟。开慧识于幽涂。三乘方轨。运慈心于朽宅。龙兴雾集。神动天随大道为心。望法云而遐举。闻声悟道。渐初地而依仁。迁奈苑之乔枝。入祇园之隩室。酌智水之余润。承慧日之末光。既而税驾连河。归真双树。圣灵逾远。像教浸微。大义或乖。斯文将坠。穿凿异端。分析多绪。是末非古。殊涂别派。天亲初学之辈。尚致西河之疑。龙树究竟之俦。弥深东鲁之叹。仰惟法宝。尽谛无为。故经文云。佛以法为师。佛从法生。佛依法住。岂止研几尽性。妙物穷神。出入无间。苞含元气而已。若夫惟天为大。寒暑运其功。谓地盖厚。山泽通其气。是以姬文以大圣之姿。幽赞易道。丘明怀同耻之德。祖述微言。诸经著论。俯同斯旨。大乘庄严论者。无著菩萨纂焉。菩萨以如来灭度之后。含章秀发。三十二相。具体而微。八千亿结。承风俱解。弘通正法。庄饰经王。明真如功德之宗。显大士位行之地。破小乘执着。成大乘纲纪。其菩提一品。最为微妙。转八识以成四智。束四智以具三身。详诸经论所未曾有。可谓闻所未闻。见所未见

圣上受飞行之宝命。总步骤于前王。屈天师之尊。智周万物。应人皇之运。道照三明。慈惠外宣。神机内湛。端扆而役百灵。垂拱而朝万国。弥纶造化之初。含吐阴阳之际。功成作乐。既章韶舞。治定制礼。言动翠华。金轮所王。封疆之固惟远。芥城虽满。龟鼎之祚无穷。光阐大猷。开导群品。凡诸内典。尽令翻译。摩伽陀国三藏法师波罗颇蜜多罗。唐言明友。即中天竺刹利王之种姓也以大唐贞观元年十二月入京。法师戒行精勤。才识明敏。至德邻于初果。多能亚夫将圣。继澄什之清尘。来仪上国。摽生远之逸气。高步玄门。帝心简在。皇储礼敬。其博闻强记。探幽洞微。京城大德。莫不推许。粤以贞观四年。恭承明诏。又

敕尚书左仆射[邱-丘+千]国公房玄龄。散骑常侍行太子左庶子杜正伦铨定。义学法师慧乘慧朗法常智解昙藏智首道岳惠明僧辩僧珍法琳灵佳慧赜慧净玄谟僧伽等。于胜光寺共成胜业。又敕太府卿兰陵男萧璟监掌修缉。三藏法师云。外国凡大小乘学。悉以此论为本。若于此不通。未可弘法。是以覃思专精。特加研究。慧净法师。聪敏博识。受旨缀文。玄谟法师。善达方言。又兼义解。至心译语。一无纰谬以七年献春此始。撰定斯毕。勒成十有三卷二十四品。敕太子右庶子安平男李百药序之云尔

大乘庄严经论卷第一

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    缘起品第一

偈曰

  义智作诸义　　言句皆无垢
  救济苦众生　　慈悲为性故
  巧说方便法　　所谓最上乘
  为发大心者　　略以五义现

释曰。庄严大乘经论。谁能庄严。答义智能庄严。问义智云何庄严。答开作诸义。问以何开作。答以言及句。问以何等言。以何等句。答以无垢言以无垢句。无垢言者。谓能至涅槃城。无垢句者。谓字句相应。若离无垢言句。则于诸义不能开晓。问以何义故庄严。答为救济苦众生故。问众生自苦。何因救济。答为菩萨者大悲为体生怜愍故。问若救他苦庄严何法。答庄严如来巧说方便法。问何等方便法。答所谓最上乘。问为谁故庄严。答为发大乘心者。问以几义庄严。答略以五义示现。问何者五义。偈曰

  譬如金成器　　譬如花正敷
  譬如食美膳　　譬如解文字
  譬如开宝箧　　是各得欢喜
  五义法庄严　　欢喜亦如是

释曰。此中五譬即譬彼五义庄严。如其次第。能令发大心者信向故。受教故。思惟故。修习故。证得故。问其义云何。答金成譬。为令信向转彼心故。华敷譬。为令受教开示彼故。食膳譬。为令思惟得法味故。解文譬。为令修习更不思故。开箧譬。为令证得真实菩提分宝自觉证故。由此五义分别大乘。能令彼人得生爱乐。问若彼法自性功德具足。何义更须庄严为。答此问。偈曰

  譬如庄美质　　临镜生胜喜
  妙法庄严已　　得喜更第一

释曰。譬如美质加庄像。现在于镜则生胜喜。何以故。为有悦故。菩萨亦尔。庄严妙法义入自心则生胜喜。何以故。为有问故。问彼法有何功德须此庄严。强欲令他恭敬信受耶。偈曰

  譬如饮药苦　　病差则为乐
  住文及解义　　苦乐亦如是
  譬如难事王　　因事得威力
  如是难解义　　因解得法财
  譬如见生宝　　不别则不爱
  如是闻妙法　　不觉亦不喜

释曰。此三偈次第显示妙法有三功德。一显断障因功德。二显自在因功德。三显妙喜因功德。问此义云何。答如饮苦药。初时则苦。以难服故。后时则乐。以病差故。此法亦尔。住文时苦。味难得故。解义时乐。障病破故。如事严王。初时则苦。难得意故。后时则乐。与威力故。此法亦尔。思惟时苦。深难解故。思度时乐。长圣财故。如见生宝。未别时则不爱。谓无用故。识别时则深重。知有用故。此法亦尔。修行时则不喜。谓空无用故。修度时则深悦。知有大用故。缘起品究竟

    大乘庄严经论成宗品第二

释曰。有人疑此大乘非佛所说。云何有此功德可得。我今决彼疑网。成立大乘真是佛说。偈曰

  不记亦同行　　不行亦成就
  体非体能治　　文异八因成

释曰。成立大乘略有八因。一者不记。二者同行。三者不行。四者成就。五者体。六者非体。七者能治。八者文异。第一不记者。先法已尽后佛正出。若此大乘非是正法。何故世尊初不记耶。譬如未来有异世尊即记。此不记故知是佛说。第二同行者。声闻乘与大乘非先非后一时同行。汝云何知此大乘独非佛说。第三不行者。大乘深广非忖度人之所能信。况复能行外道制诸论。彼种不可得。是故不行。由彼不行故是佛说。第四成就者。若汝言余得菩提者说有大乘。非是今佛说有大乘。若作此执则反成我义。彼得菩提亦即是佛如是说故。第五体者。若汝言余佛有大乘体此佛无大乘体。若作此执亦成我义。大乘无异体是一故。第六非体者。若汝言此佛无大乘体。则声闻乘亦无体。若汝言声闻乘是佛说故有体大乘非佛说故无体。若作此执有大过失。若无佛乘而有佛出说声闻乘者理不应故。第七能治者。由依此法修行得无分别智。由无分别智能破诸烦恼。由此因故不得言无大乘。第八文异者。大乘甚深非如文义。不应一向随文取义言非佛语。复次若汝言初不记者。由佛无功用心舍故。若作此执是义不然。偈曰

  诸佛三因缘　　现见亦护法
  如来智无碍　　舍者不应尔

释曰。若此大乘非佛说者。是为大障。诸佛有三因缘。何故不记。一无功用智恒起是眼恒见。二恒作正勤守护正法。三如来智力无有障碍。由此三因。汝言舍而不记者。不应道理。复次若汝言有体者。即声闻乘是大乘体。何以故。即以此乘得大菩提故。若作此执是义不然。偈曰

  非全非不违　　非行非教授
  是故声闻乘　　非即是大乘

释曰。有四因缘非即以声闻乘为大乘体。非全故。非不违故。非行故。非教授故。非全者。声闻乘无有利他教授。但为自厌离欲解脱而教授故。非不违者。若言声闻乘以自方便而教授他。即是他利教授。是义不然。何以故。虽以自利安他。彼亦自求涅槃勤行方便。不可以此得大菩提故。非行者。若汝言若能久行声闻乘行则得大菩提果。是义不然。非方便故。声闻乘非大菩提。方便不以久行。非方便能得大乘果。譬如构角求乳。不可得故。非教授者。如大乘教授声闻乘无。是故声闻乘不得即是大乘。复次今更示汝相违义。偈曰

  发心与教授　　方便及住持
  时节下上乘　　五事一切异

释曰。声闻乘与大乘有五种相违。一发心异。二教授异。三方便异。四住持异。五时节异。声闻乘若发心若教授若勤方便。皆为自得涅槃故。住持亦少。福智聚小故。时节亦少。乃至三生得解脱故。大乘不尔。发心教授勤方便。皆为利他故。住持亦多。福智聚大故。时节亦多。经三大阿僧祇劫故。如是一切相违。是故不应以小乘行而得大乘果。复次若汝言佛语有三相。一者入修多罗。二者显示毗尼。三者不违法空。汝以一切法无自性而为教授。违此三相故非佛语。若作此执是义不然。偈曰

  入自大乘经　　现自烦恼灭
  广大甚深义　　不违自法空

释曰。今此大乘亦不违三相。入自大乘修多罗故。现自烦恼毗尼故。由菩萨以分别为烦恼故。广大甚深即是菩萨法空。不违此空得大菩提故。是故此乘与三相不相违。复次前说不行者。我今更示此义令汝信受。偈曰

  有依及不定　　缘俗亦不普
  退屈忖度人　　宁解大乘义

释曰。由有五因彼忖度者不能得入大乘境界。彼智有依故。不定故。缘俗故。不普故。退屈故。彼有依者。智依教生。非证智故。不定者。有时更有。异智生故。缘俗者。忖度世谛。不及第一义谛故。不普者。虽缘世谛但得少解。不解一切故。退屈者。诤论辩穷即默然故。大乘者即无所依乃至终不退屈。不退屈者。无量经中有百千偈说大乘法。由得此法辩才无尽。是故大乘非忖度人境。问汝说声闻乘非佛菩提方便。若尔何者是耶。偈曰

  广大及甚深　　成熟无分别
  说此二方便　　即是无上乘

释曰。广大者。谓诸神通。由极勤方便令他信解故。甚深者。谓无分别智。由难行故如其次第。一为成熟众生。二为成熟佛法。即说此二为无上菩提方便。此二方便即是无上乘体。问若尔有人于中怖畏。过失云何。偈曰

  不应怖而怖　　由怖被烧然
  怖引非福故　　长时过患起

释曰。若人非怖畏处妄生怖畏。是人即堕极热恶道而被烧然。何以故。由此怖畏引大非福聚生。由此罪故能令是人经无量劫受大热恼。问彼人复有何因生此怖畏。偈曰

  非性非法朋　　少慧少因力
  怖此深妙法　　退失大菩提

释曰。若人生怖由四因缘。一非种性。离菩萨性故二非法朋。离善知识故三少慧力。未解大乘法空故。四少因力。先世不种诸波罗蜜自性善根故。由此因缘于甚深妙法横生怖想。由此想故于大菩提福智二聚应得不得。是名为退。汝今应知。此退过患最极深重。已说怖过及怖因。次说不应怖畏因。偈曰

  无异即互无　　有异即险处
  无譬种种说　　续说多门说
  非有如文义　　诸佛甚深体
  聪慧正观人　　应知不应怖

释曰。无异即互无者。若汝言声闻乘即是大乘无异大乘体。若如是者。即声闻辟支佛乘复无有体。何以故。由得佛故。如是一切皆是佛乘。何因怖耶。有异即险处者。若汝许有异大乘体。此体即是一切智道。最为第一险处。由难度故此应仰信。何因怖耶。无譬者。于一时中无二大乘并出可以相比。何因怖一不怖二耶。种种说者。今此大乘非独说空。亦说大福智聚。应解此意。何因独怖空耶。续说者一切时中决定相续说空汝非乍闻。何因怖耶。多门说者彼彼经中多门异说显大要用。破诸分别得无分别智。若异此说无大用者。如来但应言空不说如法性实际等。既说有多门何因独怖空耶。非有如文义者。大乘甚深不如文义。何因随文取义而怖空耶。诸佛甚深体者。佛性甚深卒难觉识应求了别何因怖耶。由如是等因缘故。聪慧正观人于此大乘不应怖畏。已说不应怖畏因。次说能行此法智。偈曰

  随次闻思修　　得法及得慧
  此智行此法　　未得勿非毁

释曰。若人最初依善知识能起正闻。次于正义能起正忆。次于真实境界得生正智。次从彼彼得证法果。次从彼后起解脱智。是人此智随深入远能行此法。汝若自无此智。不应决定言非佛语。已说能行此法智。次遮怖畏此法句。偈曰

  不解解不深　　深非思度解
  解深得解脱　　诸怖不应尔

释曰。不解者。若汝言如是深法非我所解。如是起怖畏者不应尔。解不深者。若汝言佛解亦不深。如其解深何故说深。如是起怖畏者不应尔。深非思度解者。若汝言何故此深。非思量境界。如是起怖畏者不应尔。解深得解脱者。若汝言何故独解深义能得解脱。非思量人能得解脱。如是起怖畏者不应尔。如是已遮怖畏此法句。次以不信成立大乘。偈曰

  由小信界伴　　不解深大法
  由汝不解故　　成我无上乘

释曰。小信者。狭劣信解故。小界者。阿梨耶识中熏习小种子故。小伴者。相似信界为眷属故。此三若小则不信别有大乘。由此不信则成我所立是无上法。已说成立大乘次遮谤毁大乘。偈曰

  随闻而得觉　　未闻慎勿毁
  无量余未闻　　谤者成痴业

释曰。汝随少闻得有觉悟。不应随闻复生谤毁。汝于未闻无信可尔。何以故。不积善故未闻者多慎勿谤毁。汝无简别若生谤毁更增痴业。坏前闻故。已遮谤毁。次遮邪思。偈曰

  如文取义时　　师心退真慧
  谤说及轻法　　缘此大过生

释曰。师心者。谓自见取。非智者。边求义故。退真慧者。如实真解未得退故。谤说者。毁善说故。轻法者。嫉所闻故。缘此非福次身受大苦报。是名大过起。已遮邪思。次遮恶意。偈曰

  恶意自性恶　　不善不应起
  况移于善处　　应舍大过故

释曰。恶意者。是憎嫉心。自性恶者。此心是自性罪。尚不可于过失法中起。何况于非过法中起。是故急应须舍大过患故。成宗品究竟

    大乘庄严经论归依品第三

释曰。如此已成立大乘。次依大乘摄胜归依。偈曰

  若人归三宝　　大乘归第一
  一切遍勇猛　　得果不及故

释曰。一切归依三宝中。应知大乘归依最为第一。何以故。由四种大义自性胜故。何者四义。一者一切遍义。二者勇猛义。三者得果义。四者不及义。此义后当说。由此四义多有留难。诸归依者或能不能。能者为胜。已说归依胜。次劝胜归依。偈曰

  难起亦难成　　应须大志意
  为成自他利　　当作胜归依

释曰。难起者。所谓胜愿。由弘誓故。难成者。所谓胜行。由经无量劫故。由如此难应须发大志意。何以故。为欲成就他利与自利故。他利者。所谓愿行。由愿行是名闻因故。自利者。所谓大义。由大义是自体果故。前说四义。今当先说一切遍义。偈曰

  众生遍乘遍　　智遍寂灭遍
  是名智慧者　　四种一切遍

释曰。大乘归依者有四种一切遍。一者众生一切遍。欲度一切众生故。二者乘一切遍。善解三乘故。三者智一切遍。通达二无我故。四者寂灭一切遍。生死涅槃体是一味。过恶功德不分别故。已说一切遍义。次说勇猛义。偈曰

  悕望佛菩提　　不退难行行
  诸佛平等觉　　勇猛胜有三

释曰。大乘归依有三种胜勇猛。一愿胜勇猛。归依佛时求大菩提多生欢喜知胜功德故。二者行胜勇猛。起修行时不退不屈难行行故。三者果胜勇猛。至成佛时与一切诸佛平等觉故。复次由此勇猛。彼诸佛子恒得善生。偈曰

  发心与智度　　聚满亦大慈
  种子及生母　　胎藏乳母胜

释曰。菩萨善生有四义。一者种子胜。以菩提心为种子故。二者生母胜。以般若波罗蜜为生母故。三者胎藏胜。以福智二聚住持为胎藏故。四者乳母胜。以大悲长养为乳母故。复次善生者。由勇猛故恒得胜身。偈曰

  妙相成生力　　大乐大方便
  如此四成就　　是名为胜身

释曰。菩萨身胜有四种。一者色胜。得妙相严身胜转轮王等相故。二者力胜。得成熟众生自在力故。三者乐胜。得寂灭上品佛地无边乐故。四者智胜。得救一切众生大巧方便故此四成就是名佛子善生。所谓色成就力成就乐成就智成就。复次由此勇猛得与王子相似。偈曰

  光授法自在　　巧说善治摄
  由此四因故　　佛种则不断

释曰。由四因缘王种不断。一者入位受职。二者增上无违。三者善能决判。四者分明赏罚。善生佛子亦尔。一者蒙光授。谓一切诸佛与大光明令受职故。二者法自在。谓于一切法中智慧自在他无违故。三者能巧说。谓对佛众中善说法故。四者善治罚谓于学戒者过恶能治功德能摄故。复次由此勇猛得与大臣相似。偈曰

  入度见觉分　　持密利众生
  由此四因故　　得似于大臣

释曰。有四种因是大臣功德。一者入王禁宫。二者见王妙宝。三者秘王密语。四者自在赏赐。勇猛菩萨亦尔。一者常得善入诸波罗蜜。二者常见处处经中大菩提分宝。由不忘法故。三者常持如来身口意密。四者常能利益无边众生。已说勇猛义。次说得果义。偈曰

  福德及尊重　　有乐亦苦灭
  证乐证法阴　　习尽有灭舍

释曰。大乘归依者得此八果。一者信解时得大福德聚。二者发心时得三有尊重。三者故意受生时得三有中乐。四者解自他平等时得大苦聚灭。亦得灭一切众生苦力。五者入无生忍时觉证最上乐。六者得菩提时证大法阴。法阴者所谓法身。如此法身名为大。名为胜。名为常。名为善聚。是无边修多罗等法藏故名大。一切法中最上故名胜。永无有尽故名常。为力无畏等善法积聚故名善聚。七者得熏习聚尽永灭无余。八者得有灭舍。有舍者不住生死。灭舍者不住涅槃。已说得果义。次说不及义。偈曰

  大体及大义　　无边及无尽
  由善世出世　　成熟神通故

释曰。大乘归依者。所有善根由四因故。一切声闻辟支佛所不能及。一者大体。二者大义。三者无边。四者无尽问此云何。答大体者。谓世间善根。已得超过二乘故。大义者。谓出世善根。二乘出世但自利故。无边者。谓成熟善根。能成熟无边众生故。无尽者。谓神通善根。至无余涅槃亦无尽故。已说归依胜义。次说归依差别。偈曰

  希望及大悲　　种智亦不退
  三出及二得　　差别有六种

释曰。归依差别有六种。一自性。二因。三果。四业。五相应。六品类。悕望为自性。至心求佛体故。大悲为因。为一切众生故。种智为果。得无上菩提故。不退为业。行利他难行行不退不屈故。三出为相应。具足三乘出离行故。二得为品类。世俗得法性得粗细差别故。已说功德差别。次说行差别。偈曰

  归依有大义　　功德聚增长
  意悲遍世间　　广流大圣法

释曰。大义谓自他利行。自利行者。谓功德增长复有多种。若思度。若数数。若时节。皆无有量。由不可思度故。不可数知故。毕竟恒行。时无分齐故。他利行者。作意及悲遍一切众生故。广勤方便流大圣法故。大圣法者大乘法故。归依品究竟

    大乘庄严经论种性品第四

释曰。已说归依义。次说种性差别。偈曰

  有胜性相类　　过恶及功德
  金譬与宝譬　　九种各四种

释曰。种性有九种差别。一有体。二最胜。三自性。四相貌。五品类。六过恶。七功德。八金譬。九宝譬。如是九义一一各有四种差别。此偈总举。余偈别释。此中先分别有体。偈曰

  由界及由信　　由行及由果
  由此四差别　　应知有性体

释曰。种性有体由四种差别。一由界差别。二由信差别。三由行差别。四由果差别。由界差别者众生有种种界无量差别。如多界修多罗说。由界差别故。应知三乘种性有差别。由信差别者。众生有种种信可得。或有因力起。或有缘力起。能于三乘随信一乘非信一切。若无性差别则亦无信差别。由行差别者。众生行行或有能进或有不能进。若无性差别则亦无行差别。由果差别者。众生菩提有下中上。子果相似故。若无性差别则亦无果差别。由此四差别。是故应知。种性有体。已说种性有体。次说种性最胜。偈曰

  明净及普摄　　大义亦无尽
  由善有四胜　　种性得第一

释曰。菩萨种性由四种因缘。得为最胜。一由善根明净。二由善根普摄。三由善根大义。四由善根无尽。何以故。非诸声闻等善根如是明净故。非一切人善根摄力无畏等故。余人善根无他利故。余人善根涅槃时尽故。菩萨善根不尔。由此为因。种性最胜。已说种性最胜。次说种性自性。偈曰

  性种及习种　　所依及能依
  应知有非有　　功德度义故

释曰。菩萨种性有四种自性。一性种自性。二习种自性。三所依自性。四能依自性。彼如其次第。复次彼有者。因体有故。非有者。果体非有故。问若尔云何名性。答功德度义故。度者出生功德义。由此道理。是故名性。已说种性自性。次说种性相貌。偈曰

  大悲及大信　　大忍及大行
  若有如此相　　是名菩萨性

释曰。菩萨种性有四种相貌。一大悲为相。哀愍一切苦众生故。二大信为相。爱乐一切大乘法故。三大忍为相。能耐一切难行行故。四大行为相。遍行诸波罗蜜自性善根故。已说种性相貌。次说种性品类。偈曰

  决定及不定　　不退或退堕
  遇缘如次第　　品类有四种

释曰。菩萨种性品类。略说有四种。一者决定。二者不定。三者不退。四者退堕。如其次第。决定者遇缘不退。不定者遇缘退堕。已说种性品类。次说种性过失。偈曰

  应知菩萨性　　略说有四失
  习惑与恶友　　贫穷属他故

释曰。菩萨种性过失。略说有四种。一者习惑。功德不行烦恼多行故。二者恶友。离善知识狎弊人故。三者贫穷。所须众具皆乏少故。四者属他。系属于人不自在故。已说种性过失。次说种性功德。偈曰

  功德亦四种　　虽堕于恶道
  迟入复速出　　苦薄及悲深

释曰。菩萨种性。虽有如前过失。若堕恶道应知于中复有四种功德。一者迟入。不数堕故。二者速出不久住故。三者苦薄。逼恼轻故。四者悲深。哀愍众生亦成就故。已说种性功德。次说种性金譬。偈曰

  譬如胜金性　　出生有四种
  诸善及诸智　　诸净诸通故

释曰。胜金性者所出有四义。一者极多。二者光明。三者无垢。四者调柔。菩萨种性亦尔。一者为无量善根依止。二者为无量智慧依止。三者为一切烦恼障智障得清净依止。四者为一切神通变化依止。已说种性金性譬。次说种性宝性譬。偈曰

  譬如妙宝性　　四种成就因
  大果及大智　　大定大义故

释曰。妙宝性者四种成就依止。一者真成就依止。二者色成就依止。三者形成就依止。四者量成就依止。菩萨种性亦尔。一者为大菩提因。二者为大智因。三者为大定因。定者由心住故。四者为大义因。成就无边众生故。已广分别性位。次分别无性位。偈曰

  一向行恶行　　普断诸白法
  无有解脱分　　善少亦无因

释曰。无般涅槃法者。是无性位。此略有二种。一者时边般涅槃法。二者毕竟无涅槃法。时边般涅槃法者有四种人。一者一向行恶行。二者普断诸善法。三者无解脱分善根。四者善根不具足。毕竟无涅槃法者无因故。彼无般涅槃性。此谓但求生死不乐涅槃人。已说无性。次说令入。偈曰

  广演深大法　　令信令极忍
  究竟大菩提　　二知二性胜

释曰。广演深大法者。为利他故。谓无智者。令得大信。已大信者令成就极忍能行不退。已极忍者令究竟成就无上菩提。二知者。谓诸凡夫及诸声闻。若得如是彼诸二人。则知自性性德圆满性最为殊胜。问云何胜。偈曰

  增长菩提树　　生乐及灭苦
  自他利为果　　此胜如吉根

释曰。如是种性能增长极广功德大菩提树。能得大乐。能灭大苦。能得自他利乐以为大果。是故此性最为第一。譬如吉祥树根。菩萨种性亦尔。种性品究竟

大乘庄严经论卷第一大乘庄严经论卷第二

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    发心品第五

释曰。如说已分别菩萨种性。次分别菩萨发菩提心相。偈曰

  勇猛及方便　　利益及出离
  四大三功德　　二义故心起

释曰。菩萨发心有四种大。一勇猛大。谓弘誓精进甚深难作长时随顺故。二方便大。谓被弘誓钾已恒时方便勤精进故。三利益大。谓一切时作自他利故。四出离大。谓为求无上菩提故。复次此四种大显示三种功德。第一第二大显示作丈夫所作功德。第三大显示作大义功德。第四大显示受果功德。此三功德以二义为缘。所谓无上菩提及一切众生。由此思故发菩提心。已说发心相。次说发心差别。偈曰

  信行与净依　　报得及无障
  发心依诸地　　差别有四种

释曰。菩萨发心依诸地有四种差别。一信行发心。谓信行他。二净依发心。谓前七地。三报得发心。谓后三地。四无障发心。谓如来地。已说差别。次当广释。问如此发心。以何为根。何所依止。何所信。何所缘。何所乘。何所住。何等障难。何等功德。何等自性。何所出离。何处究竟。偈曰

  大悲与利物　　大法将种智
  胜欲亦大护　　受障及增善
  福智与修度　　及以地地满
  初根至后竟　　随次解应知

释曰。菩萨发心以大悲为根。以利物为依止。以大乘法为所信。以种智为所缘。为求彼故。以胜欲为所乘。欲无上乘故。以大护为所住。住菩萨戒故。以受障为难。起异乘心故。以增善为功德。以福智为自性。以习诸度为出离。以地满为究竟。由地地勤方便。与彼彼相应故。如此已广分别。次说受世俗发心。偈曰

  友力及因力　　根力亦闻力
  四力总二发　　不坚及以坚

释曰。若从他说得觉而发心。是名受世俗发心。此发心由四力。一者友力发心。或得善知识随顺故。二者因力发心。或过去曾发心为性故。三者根力发心。或过去曾行诸善根所圆满故。四者闻力发心。或处处说法时无量众生发菩提心故。又习善根者。或现在如法常闻受持等故。复次彼四力发心总为二种。一者不坚发。谓友力发心故。二者坚发。谓因等三力发心故。已说世俗发心。次说第一义发心。偈曰

  亲近正遍知　　善集福智聚
  于法无分别　　最上真智生

释曰。第一义发心显有三种胜。一教授胜。亲近正遍知故。二随顺胜。善集福智聚故。三得果胜。生无分别智故。此发心名欢喜地。由欢喜胜故。问此胜以何为因。偈曰

  诸法及众生　　所作及佛体
  于此四平等　　故得欢喜胜

释曰。四平等者一法平等。由通达法无我故。二众生平等。由至得自他平等故。三所作平等。由令他尽苦如自尽苦故。四佛体平等。由法界与我无别决定能通达故。已说胜因。次说胜差别。偈曰

  生位及愿位　　亦猛亦净依
  余巧及余出　　六胜复如是

释曰。第一义发心复有六胜。一生位胜。二愿位胜三勇猛胜。四净依胜。五余巧胜。六余出胜。问此六云何胜。偈曰

  生胜由四义　　愿大有十种
  勇猛恒不退　　净依二利生
  巧便进余地　　出离善思惟
  如此六道理　　次第成六胜

释曰。生胜由四义者。一种子胜。信大乘法为种子故。二生母胜。般若波罗蜜为生母故。三胎藏胜。大禅定乐为胎藏故。四乳母胜。大悲长养为乳母故。愿大有十种者。十大愿如十地经说。发此愿胜故。勇猛恒不退者。能行难行永不退故。净依二利生者。一知自近菩提。二知利他方便故巧便进余地者。得趣上地方便故。出离善思惟者。思惟住诸地中所建立法故问云何思惟。答如所建立分齐分别知故。以是分别亦知无分别故。已说发心。次说譬喻显此发心。偈曰

  如地如净金　　如月如增火
  如藏如宝箧　　如海如金刚
  如山如药王　　如友如如意
  如日如美乐　　如王如库仓
  如道如车乘　　如泉如喜声
  如流亦如云　　发心譬如是

释曰。如此发心与诸譬喻。何义相似。答譬如大地。最初发心亦如是。一切佛法能生持故。譬如净金。依相应发心亦如是。利益安乐不退坏故。譬如新月。勤相应发心亦如是。一切善法渐渐增故。譬如增火。极依相应发心亦如是。益薪火炽积行依极故。譬如大藏。檀波罗蜜相应发心亦如是。以财周给亦无尽故。譬如宝箧。尸波罗蜜相应发心亦如是。功德法宝从彼生故。譬如大海。羼提波罗蜜相应发心亦如是。诸来违逆心不动故。譬如金刚。毗梨耶波罗蜜相应发心亦如是。勇猛坚牢不可坏故。譬如山王。禅波罗蜜相应发心亦如是。物无能动以不乱故。譬如药王。般若波罗蜜相应发心亦如是。惑智二病此能破故。譬如善友。无量相应发心亦如是。一切时中不舍众生故。譬如如意珠。神通相应发心亦如是。随所欲现能成就故。譬如盛日。摄相应发心亦如是。如日熟谷成熟众生故。譬如美乐。辩相应发心亦如是。说法教化摄众生故。譬如国王。量相应发心亦如是。能为正道不坏因故。譬如仓库。聚相应发心亦如是。福智法财之所聚故。譬如王路。觉分相应发心亦如是。大圣先行余随行故。譬如车乘。止观相应发心亦如是。二轮具足安乐去故。譬如涌泉。总持相应发心亦如是。闻者虽多法无尽故。譬如喜声。法印相应发心亦如是。求解脱者所乐闻故。譬如河流。自性相应发心亦如是。无生忍道自然而流不作意故。譬如大云能成世界。方便相应发心亦如是。示现八相成道化众生故。如此等及二十二譬。譬彼发心。如圣者无尽慧经广说应知。已说发心譬喻。次说不发心过失。偈曰

  思利及得方　　解义亦证实
  如是四时乐　　趣寂则便舍

释曰。菩萨有四种乐。一思利乐。谓思惟利益他时。二得方乐。谓至得巧方便时。三解义乐。谓解了大乘意时。四证实乐。谓证人法无我时。若人弃舍众生趣向寂灭。应知是人不得菩萨如是四乐。已呵不发心。发心者应赞叹。偈曰

  最初发大心　　善护无边恶
  善增悲增故　　乐喜苦亦喜

释曰。若菩萨初发大菩提心。尔时依无边众生。即得善护不作诸恶。为此故是人远离退堕恶道畏。复次由有善及增故于乐常喜。由有悲及增故于苦常喜。为此故是人远离退失善道畏。已赞发心。次说因此发心得不作护。偈曰

  爱他过自爱　　忘己利众生
  不为自憎他　　岂作不善业

释曰。若略示彼义。菩萨爱他过于自爱。由此故忘自身命而利于他。不为自利而损于彼。由此故能于众生绝诸恶业。已说得不作护。次说得不退心。偈曰

  观法如知幻　　观生如入苑
  若成若不成　　惑苦皆无怖

释曰。菩萨观一切诸法如似知幻。若成就时于烦恼不生怖。菩萨观自生处如入园苑。若不成就时于苦恼亦不生怖。若如是者。更有何意而退菩提心耶。复次偈曰

  自严及自食　　园地与戏喜
  如是有四事　　悲者非余乘

释曰。菩萨以自功德而为自严。以利他欢喜而为自食。以作意生处而为园地。以神通变化而为戏喜。如此四事。唯菩萨有。于二乘无。菩萨既有此四事。云何当退菩提心。已说不退心。次遮畏苦心。偈曰

  极勤利众生　　大悲为性故
  无间如乐处　　岂怖诸有苦

释曰。菩萨以大悲为体。是故极勤利他。虽入阿鼻地狱如游乐处。菩萨如是于余苦中岂生怖畏。因此怖畏而退心耶。偈曰

  大悲恒在意　　他苦为自苦
  自然作所作　　待劝深惭羞

释曰。诸菩萨大悲阇梨常在心中。若见众生受苦即自生苦。由此道理自然作所应作。若待善友劝发深生极重惭羞。偈曰

  荷负众生担　　懈怠丑非胜
  为解自他缚　　精进应百倍

释曰。菩萨发心荷负众生重担。若去赊缓此是丑事。非为第一端正众生。菩萨应思。若自若他有种种急缚。谓惑业生。为解此缚应须百倍精进。过彼声闻作所应作。发心品究竟

    大乘庄严经论二利品第六

释曰。已说发心。次说依此发心随顺修行自他利行。偈曰

  大依及大行　　大果次第说
  大取及大忍　　大义三事成

释曰。大依者。依止大菩提而发心故。大行者。为利自他而发行故。大果者。令得无上菩提故。如其次第。大取者。发心时摄一切众生故。大忍者。发行时忍一切大苦故。大义者。得果时广利一切众生业成就故。已说次第。次说自他无差别。偈曰

  他自心平等　　爱则于彼胜
  如是有胜相　　二利何差别

释曰。菩萨得他自心平等。或由信得。谓世俗发心时。或由智得。谓第一义发心时。菩萨虽有此心。然爱他身则胜自身。于他既有如此胜想。则不复分别何者为自利何者为他利。俱无别故。已说无差别。次说他利胜。偈曰

  于世无怨业　　利彼恒自苦
  悲性自然起　　是故利他胜

释曰。菩萨于诸世间久绝怨业。是故恒为成就他利。自身受诸勤苦。由大悲为体自然起故。由此道理则利他为胜。问如是利他云何随顺。偈曰

  善说令归向　　令入亦令调
  令成亦令住　　令觉令解脱
  集德及生家　　得记并受职
  至成如来智　　以是利群生

释曰。三种众生。谓住下中上性。菩萨如其所住而摄取之。以十三种随顺利益。一者善说。由随教及记心故。二者令归向。由神通力故。三者令入。由向已能令信受正教故。四者令调。由入已断其疑故。五者令成。由成熟善根故。六者令住。由教授令心住故。七者令觉。由得智慧故。八者令解脱。由得神通等诸胜功德故。九者集德。由遍集福智故。十者生家。由生佛家故。十一者得记。由八地受记故。十二者受职。由十地受职故。十三者得如来智。由入佛地故。问如此随顺云何成立。偈曰

  不倒及不高　　无著亦通达
  能忍及调顺　　远去亦无尽
  应知此八义　　成就彼十三

释曰。不倒者。若人已住于性。菩萨随机而为说法不妄授故。不高者。彼归向时不恃神通而自高故。无著者。彼入正法时不染众生故。通达者。断彼疑网故。能忍者。善成熟彼故。调顺者。随顺教授非不调教授故。远去者。随顺生家等非不远去令他能作故。无尽者。菩萨利益众生一切时愿无尽故。是名成就应知。问此随顺云何胜差别。偈曰

  习欲大可畏　　有爱动而倒
  乐灭断烦恼　　大悲求佛法

释曰。习欲者。谓欲界人。大可畏者。身心苦多及向恶趣故。有爱者。谓色无色界人。动而倒者。彼乐无常故动。行苦故倒。乐灭者。谓自利人。断烦恼者。由烦恼所持则苦不断为离苦故。自断烦恼而求寂灭。大悲者。谓利他人。求佛法者。此人常求一切佛法。拟利一切众生故。偈曰

  世间求自乐　　不乐恒极苦
  菩萨勤乐他　　二利成上乐

释曰。世间愚痴常求自乐。而不得乐反得极苦。菩萨不尔。常勤乐他而二利成就。更得第一大涅槃乐。此是菩萨胜随顺差别。已说利他随顺。次以此行回向众生。偈曰

  异根于异处　　异作有异行
  凡是诸所作　　回以利众生

释曰。菩萨回向随眼等诸根行种种处作种种威仪业行利益众生。凡是诸行。若事相应及以相似。彼皆回向一切众生。如行清净经中广说。已说回向心。次遮不忍心。偈曰

  众生不自在　　常作诸恶业
  忍彼增悲故　　无恼亦无违

释曰。众生为烦恼所恼心不自在。是故作诸恶业。菩萨智慧于彼常起大忍增长大悲。是故于彼不起恼心。亦不欲作不随顺事。已遮不忍心。次显随顺大。偈曰

  胜出与寂静　　功德及利物
  次第依四义　　说大有四种

释曰。诸菩萨有四种随顺大。一者胜出大。于三有五趣中而胜出故。如般若波罗蜜经说。须菩提。若色有法非无法者是摩诃衍。不能胜出一切世间天人阿修罗故。二者寂静大。随向无住处涅槃故。三者功德大。福智二聚增长故。四者利物大。常依大悲不舍众生故。二利品究竟

    大乘庄严经论真实品第七

释曰。已说随顺修行。次说第一义相。偈曰

  非有亦非无　　非如亦非异
  非生亦非灭　　非增亦非减
  非净非不净　　此五无二相
  是名第一义　　行者应当知

释曰。无二义是第一义。五种示现。非有者。分别依他二相无故非无者。真实相有故。非如者。分别依他二相无一实体故。非异者。彼二种如无异体故。非生非灭者。无为故。非增非减者。净染二分起时灭时法界正如是住故。非净者。自性无染不须净故。非不净者。客尘去故。如是五种无二相。是第一义相应知。已说第一义。次遮于彼起颠倒。偈曰

  我见非见我　　无相非无缘
  异二无我故　　解脱唯迷尽

释曰。我见非见我者。无我相故。何以故。由我相但是分别故。非无缘者。烦恼习气所起缘五受阴故。异二无我故者。二谓我见及五受阴。亦非异此二种而有我相。如是我见但是迷谬。实无我相可得故。解脱唯迷尽者。若缘自身起解脱亦唯迷尽。无别有我名解脱者故。已遮妄见。次诃颠倒。偈曰

  云何依我见　　不见苦自性
  迷苦及苦者　　法性与无性

释曰。云何依我见不见苦自性者。咄哉世间云何依止。我见起种种迷不能了达诸行。是苦自性而常随逐邪。迷苦及苦者法性与无性者。苦谓受彼苦触。苦者谓苦不断非我与苦相应。名为苦者。迷苦谓不解苦自性。迷苦者谓不解无我。法性者唯法。由人无我故。无性者非法。由法无我故。偈曰

  云何缘起体　　现见生异见
  闇故不见有　　亦复不有见

释曰。云何缘起体现见生异见者。咄哉世间云何现见。诸行各从缘起。而依此体横生异见。谓眼等诸根体非缘起。邪闇故不见有。亦复不有见者。由无明故缘起之法是有而不见有。我体不有而复有见。问若尔云何得涅槃。偈曰

  生死与涅槃　　无二无少异
  善住无我故　　生尽得涅槃

释曰。生死涅槃无有二。乃至无有少异。何以故。无我平等故。若人善住无我而修善业。则生死便尽而得涅槃。如是已遮颠倒。次应说彼对治。偈曰

  福智无边际　　生长悉圆满
  思法决定已　　通达义类性

释曰。此偈显第一集大聚位。福智无边际者。由差别无数及时节无边故。生长悉圆满者。菩萨集此大聚到彼岸故。思法决定已者。依止定心而思惟故。通达义类性者。解所思诸法义类。悉以意言为自性故。偈曰

  已知义类性　　善住唯心光
  现见法界故　　解脱于二相

释曰。此偈显第二通达分位。由解一切诸义唯是意言为性。则了一切诸义悉是心光。菩萨尔时名善住唯识。从彼后现见法界。了达所有二相。即解脱能执所执。偈曰

  心外无有物　　物无心亦无
  以解二无故　　善住真法界

释曰。此偈显第三见道位。如彼现见法界故。解心外无有所取物。所取物无故。亦无能取心。由离所取能取二相故。应知善住法界自性。偈曰

  无分别智力　　恒平等遍行
  为坏过聚体　　如药能除毒

释曰。此偈显第四修道位。菩萨入第一义智转依已。以无分别智恒平等行及遍处行。何以故。为坏依止依他性熏习稠林过聚相故。问此智力云何。答譬如阿伽陀大药。能除一切众毒。彼力如此。偈曰

  缘佛善成法　　心根安法界
  解念唯分别　　速穷功德海

释曰。此偈显第五究竟位。缘佛善成法者。诸菩萨于佛善成立一切妙法中作总聚缘故。问云何总聚缘。答心根安法界。此明入第一义智故。由此慧安住法界。是故此心名根。问此后复云何。答解念唯分别。谓此后起观如前观事。处处念转。解知诸念唯是分别非实有故。问如此知已得进何位。答速穷功德海。谓如是知已佛果功德海。能速穷彼岸故。真实品究竟

    大乘庄严经论神通品第八

释曰。说真实义已。次显菩萨神通相。偈曰

  起灭及言音　　心行亦先住
  向彼令出离　　六智自在通

释曰。起灭者。谓生死智境。知诸众生生死故。言音者。谓天耳智境。随彼所起言语悉闻知故。心行者。谓他心智境。能知他人心行差别故。先住者。谓宿命智境。知彼先住善恶所集故。向彼者。谓如意智境。随彼处处往教化故。出离者。谓漏尽智境。知彼众生出离应不应故。如此六智。于诸世界六义差别。遍知无碍勇猛自在。是名菩萨神通自性。已说自性。次说修习。偈曰

  第四极净禅　　无分别智摄
  如所立方便　　依此净诸通

释曰。如所依禅。如所摄智。如所立方便。菩萨作意修习则得最上神通。已说修通。次说得果。偈曰

  三住住无比　　所住善供养
  令彼得清净　　是说神通果

释曰。神通有三种果。一胜住果。此住有三种。一圣住。二梵住。三天住。所得无比无上故。二善供养果。随所住处世间众生大供养故。三令他清净果。能令供养者得清净故。问神通有六种业。一自业。二他业。三光业。四戏业。五化业。六净业此云何。偈曰

  世生成坏事　　见彼犹如幻
  种种他所欲　　自在随意成

释曰。此偈上半显示自业。见诸世界及诸众生若成若坏。犹如幻故。下半显示他业。谓动地放光等事。随他所欲自在现故。十种自在如十地经说。偈曰

  神光照恶趣　　令信生善道
  威力震天宫　　动殿令魔怖

释曰。此偈显示光业。光业二种。一救苦。二怖魔。上半偈明救苦。谓下照恶道众生。令发信心得生善道故。下半偈明怖魔。谓上照天宫动魔宫殿令魔惊怖故。偈曰

  游戏诸三昧　　僧中最第一
  恒现三种化　　以是利众生

释曰。此偈上半显示戏业。于佛众中游戏诸定最得自在。下半显示化业。化有三种。一业化。工巧业处自在化故。二随化。随他所欲自在化故。三上化。住兜率天等胜上化故。以是三化恒为利益。偈曰

  智力普自在　　刹土随欲现
  无佛令闻佛　　悬掷有佛境

释曰。此偈显示净业。净业二种。一净刹土。二净众生。上半偈明净刹土。由智自在随彼所欲能现水精琉璃等清净世界故。下半偈明净众生。于无佛世界能令闻佛起净信心生有佛处故。已说业用。次说相应。偈曰

  成熟众生力　　诸佛所称誉
  发语无不信　　如是说相应

释曰。神通相应有三种。一成生相应。譬如鸟翅初得成就。二称誉相应。常得诸佛之所赞叹。三信受相应。凡所言说人皆信受。已说相应。次说住神通具。偈曰

  六智及三明　　八解八胜处
  十遍诸三昧　　勇猛资神通

释曰。菩萨住神通具有六种差别。一六智。二三明。三八解脱。四八胜处。五十遍入。六诸三昧。如是六义。是分别神通具差别。已说住神通具。次说神通大。偈曰

  能安不自在　　常勤于利物
  行有无怖畏　　勇猛如师子

释曰。菩萨神通有三种大。一自在大。众生由烦恼故不得自在。菩萨智力能自在安置故。二欢乐大。由常勤利益众生一向乐故。三无畏大。行三有中得极勇猛如师子故。神通品究竟

    大乘庄严经论成熟品第九

释曰。已说诸菩萨神通。诸菩萨云何自成熟。偈曰

  欲信舍悲忍　　念力坚支具
  应知自成熟　　此九皆上品

释曰。菩萨有九种自成熟。一者欲成熟。由悕求大法故。二者信成熟。由净心说者故。三者舍成熟。由灭离烦恼故。四者悲成熟。由怜愍众生故。五者忍成熟。由能行难行故。六者念成熟。由一切受持故。七者力成熟。由皆能通达故。八者坚成熟。由恶魔外道不能夺故。九者支成熟。由善分圆满故。如此九种穷最上位。是名成熟相。此九成熟。一一有因有体有业。今当说。偈曰

  近友闻亦思　　胜勇胜究竟
  摄法及受法　　说欲成熟相

释曰。亲近善友。听闻正法。如法思惟。此三能起大欲。是名欲因。上大精进一切不思议处究竟无疑。是名欲体。于大乘法有灾横处则能守护。菩萨所说信心领受。是名欲业。偈曰

  如来福智聚　　净心不可坏
  速受定智果　　说信成熟相

释曰。婆伽婆如是广说。是名信因。得不坏净。是名信体。得定智果。是名信业。偈曰

  善护于六根　　离恶起对治
  乐修诸善法　　说舍成熟相

释曰。以念倚等善护六根。是名舍因。离不善觉起无间道。是名舍体。一切善法恒乐修习。是名舍业。偈曰

  见诸众生苦　　哀怜离小心
  受身世间胜　　说悲成熟相

释曰。菩萨见众生苦。是名悲因。起极怜愍远离小乘心。是名悲体。得一切世间胜诸地不退。是名悲业。偈曰

  持性数修习　　极苦能安忍
  善根恒乐进　　说忍成熟相

释曰。持耐忍谓名门数习成性。是名忍因。能受极风寒等苦。是名忍体。随胜生处恒修善法。是名忍业。偈曰

  报净善随顺　　极入善恶说
  能起大般若　　说念成熟相

释曰。得清净器。是名念因。随所闻说善恶二义。闻思修已深了不忘。是名念体。能生出世般若。是名念业。偈曰

  二聚界圆满　　果起依最上
  世间得第一　　说力成熟相

释曰。福智二聚种子充满。是名力因。能得最上依止。是名力体。世间第一随意成熟。是名力业。偈曰

  深观妙法理　　诸魔不可夺
  能与异部过　　说坚成熟相

释曰。妙法道理作心观察。是名坚固。恶魔波旬不能障碍。是名坚体。能与他部而作过失。是名坚业。偈曰

  所有善根聚　　依勤能发起
  离恶及修善　　说支成熟相

释曰。彼成熟善根聚。是名支因。依此因能发起上精进。是名支体。离诸不善乐修胜善。是名支业。偈曰

  如此九种物　　自熟亦熟他
  增善增法身　　如世极亲者

释曰。欲等九物能自成熟亦成熟他。常增长一切善根及增长法身。由此二种增故。如似世间第一亲者。已说菩萨自得成熟。次说菩萨成熟众生。偈曰

  痈熟则堪治　　食熟则堪啖
  众生熟亦尔　　二分舍用故

释曰。二分者。一障分。二治分。障熟须舍。如痈熟须溃。治熟须用。如食熟须啖。是名成熟依止。已说成熟依止。次说成熟差别。偈曰

  舍普胜随善　　得常渐为八
  如此诸成熟　　是说差别种

释曰。成熟他相有八种。一者舍成熟。令灭烦恼故。二者普成熟。化以三乘故。三者胜成熟。过外道法故。四者随成熟。应机说故。五者善成熟心恭敬故。六者得成熟。令不倒解故。七者常成熟。令永不退故。八者渐成熟。令次第增长故。已说成熟差别。次说成熟心胜。偈曰

  利子及利亲　　利己三利胜
  菩萨利一切　　过彼胜无比

释曰。譬如世人安乐自子安乐自亲安乐自身。此心最胜。菩萨普欲成熟一切众生。过彼三心不可为比。是故菩萨成熟众生。其心最胜。问此胜云何成立。偈曰

  世间不自爱　　何况能爱他
  菩萨自爱舍　　但为爱他故

释曰。世人虽欲自爱尚不能自安利处。况能爱他安他利处。菩萨不尔。舍于自爱但为爱他。是故成熟众生胜过于彼。问用此心胜云何成熟。偈曰

  身财一切舍　　平等及无厌
  所乏令充足　　安立于善根

释曰。此偈显示檀波罗蜜成熟众生。檀有三种。一资生檀。内外身财一切舍故。二平等檀。于诸施田离高下故。三无厌檀。勇猛恒施不疲倦故。以是三檀二世随摄。于现在世皆令充足。于未来世安立善根。偈曰

  常与性及满　　自乐不放逸
  引入于戒足　　二果常无尽

释曰。此偈显示尸波罗蜜成熟众生。菩萨有五种尸罗。一者常尸罗。生生常有故。二者自性尸罗。无功用心住真实体故。三者圆满尸罗。十善业道皆具足故。如十地经说。四者自乐尸罗。恒自爱乐故。五者不放逸尸罗。念念无犯故。以是五种尸罗二世随摄。于现在世安立戒品。于未来世令依报二果功德无绝。偈曰

  不益得益想　　极忍解方便
  令彼起随顺　　及种诸善根

释曰。此偈显示羼提波罗蜜成熟众生。若他以不饶益事来向菩萨。菩萨于彼得饶益解起极忍辱。何以故。由彼随顺令我忍波罗蜜得增长故。亦以是忍二世随摄。于现在世令起归向。于未来世令种善根。偈曰

  久劫行上勤　　利物心无退
  令生一念善　　况欲善无量

释曰。此偈显示毗梨耶波罗蜜成熟众生。菩萨于亿百千劫行最上精进。为成熟无边众生心无退转。以是精进二世随摄。于现在世但令得生一念善心。况于未来令无量善根皆得增益。偈曰

  得上自在禅　　离染及见慢
  现在令归向　　未来善法增

释曰。此偈显示禅波罗蜜成熟众生。菩萨所得禅定远离爱见慢等故自在最上。以是禅定二世随摄。于现在世令归向第一妙法。于未来世令增长一切善根。偈曰

  知真及知意　　能断一切疑
  于法令恭敬　　自他功德满

释曰。此偈显示般若波罗蜜成熟众生。知真者。解法不颠倒故。知意者。了达众生心行断彼疑故。以是般若二世随摄。于现在世令向大法深生恭敬。于未来世令彼自身功德及他身功德皆得圆满。偈曰

  善趣及三乘　　大悲有三品
  尽于未来际　　如是熟众生

释曰。此偈显示大成熟相有三种。一者位大。谓穷四位安立善道及以三乘。二者品大。悲极三品。下者信行地。中者初地至七地。上者八九十地。三者时大。时节无边尽未来际。菩萨如是利益众生。是名大成熟相。成熟品究竟

大乘庄严经论卷第二大乘庄严经论卷第三

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    菩提品第十

释曰。已说菩萨成熟众生。次说菩萨得一切种智。偈曰

  一切难已行　　一切善已集
  一切时已度　　一切障已断

释曰。此偈显一切种智因圆满。一切难已行者。由具足行无量百千种难行行未曾疲倦故。一切善已集者。由具足聚集诸波罗蜜自性善根故。一切时已度者。由具足经长时大劫阿僧祇故。一切障已断者。由具足断一切大乘障谓诸地所有微细障故。偈曰

  成就一切种　　此即为佛身
  譬如大箧开　　众宝无不现

释曰。此偈显一切种智果圆满有三义分别。一至得。二自性。三譬喻。成就一切种者。谓至得分别。从此已后成就一切种智故。此即为佛身者。谓自性分别。即说一切种智为佛身体故。譬如大箧开众宝无不现者。谓譬喻分别。不可思议菩提分宝皆现前故。已说一切种智为佛身。次说此身无二相。偈曰

  白法为佛身　　非无亦非有
  佛为法宝因　　法则善根因

释曰。白法为佛身者。转六波罗蜜等一切善法为佛体故。非无亦非有者。此体非无。何以故。真如无别故。亦复非有。何以故。自性不成就故。是名无二相。佛为法宝因者。佛说一切法故。及以神通力故。法则善根因者。众生为田善根为谷。如是法宝于所化众生田生长善根谷故。偈曰

  具法亦离法　　如藏亦如云
  生法雨法雨　　故成如是譬

释曰。此偈重显前义。具法亦离法者。诸佛具足一切善法故。远离一切不善法故。如藏亦如云者。佛宝如藏法宝如云。问此以何义。答生法雨法雨故成如是譬。佛宝能出生法宝。与大藏相似。法宝能生长一切众生善根。与大云相似。已说佛身无二相。次说是无上归依。偈曰

  诸佛常救护　　众生三染污
  诸惑诸恶行　　及以生老死

释曰。此偈略显救护义。诸佛常救护者。由毕竟救护故。问救护何法。答众生三染污。谓烦恼染污。业染污。生染污。诸惑者。即烦恼染污。诸恶行者。即业染污。及以生老死者。即生染污。问云何救护。答于此三种众生一切时救护不舍。即是毕竟义。偈曰

  诸灾及恶趣　　身见亦小乘
  如是诸众生　　一切皆救护

释曰。此偈广显救护义。诸灾者。谓盲聋喑哑狂乱形残等众生。由佛力故。盲者得视。聋者得听。哑者能言。狂者得正。乱者得定。形残者得具足。如是救护。恶趣者。谓地狱等众生放火照触。令得离苦不复更入。如是救护。身见者。谓着我众生令得人无我解入二乘涅槃。如是救护。小乘者。谓二乘性。不定众生方便引入大乘。如是救护。偈曰

  佛为胜归处　　无比故无上
  如前种种畏　　无不令脱者

释曰。此偈显归依胜。由佛无譬喻故为无上。是故如前所说三种染污众生及余灾等众生。一切皆能救护。偈曰

  诸佛善满身　　一切世间胜
  妙法化众生　　以度悲海故

释曰。此偈显归依胜因。诸佛善满身一切世间胜者。此由自利究竟。由力无畏等诸善功德自性满故。妙法化众生以度悲海故者。善解教化众生方便。及度大悲海岸究竟故。偈曰

  尽于未来际　　普及一切生
  恒时利益彼　　是说归依大

释曰。此偈显归依大。大有三义。一者时大。穷一切众生生死际故。二者境大。以一切众生为境故。三者事大。恒时作利益救脱其苦令出离故。已说无上归依。次说如来转依相。偈曰

  二障种恒随　　彼灭极广断
  白法圆满故　　依转二道成

释曰。此偈显示转依有离有得。二障种恒随彼灭极广断者。此明所治远离。谓烦恼障智障二种种子。无始已来恒时随逐。今得永灭极者。一切地广者。一切种此皆断故。白法圆满故。依转二道成者。此明能治成就。谓佛体与最上圆满白法相应。尔时依转得二道成就。一得极清净出世智。道二得无边所识境界智道。是名转依。偈曰

  彼处如来住　　不动如山王
  尚悲乐灭人　　况着诸有者

释曰。此偈显示如来转依诸转中胜。何以故。如来转依住无漏界处。如山王镇地安住不动。如此转已见于声闻缘觉乐寂灭人尚生怜愍。何况远边下贱著有苦恼众生。偈曰

  他利及无上　　不转及不生
  广大与无二　　无住亦平等
  殊胜与遍授　　是说如来转
  显示十功德　　差别义应知

释曰。此二偈显示如来转依有十种功德差别。何等为十。一者他义转。谓转依已为利他故。二者无上转。谓转依已一切法中而得自在过二乘转故。三者不转转。谓转依已染污诸因不能转此依彼依转故。四者不生转。谓转依已一切染污法毕竟不起故。五者广大转。谓转依已示现得大菩提及般涅槃故。六者无二转。谓转依已生死涅槃无有二故。七者不住转。谓转依已有为无为俱不住故。八者平等转。谓转依已与声闻缘觉。同解脱烦恼障故。九者殊胜转。谓转依已力无畏等一切佛法无与等故。十者遍授转。谓转依已恒以一切乘而教授故。偈曰

  如空遍一切　　佛亦一切遍
  虚空遍诸色　　诸佛遍众生

释曰。此偈显示佛体一切遍与虚空相似。初二句直说。后二句释说。譬如虚空遍一切色聚。佛体亦尔遍一切众生聚。若以众生现非佛故。言佛体不遍者。是义不然。未成就故。偈曰

  譬如水器坏　　月像不现前
  如是众生过　　佛像亦不现

释曰。此偈显示佛体虽遍而众生不见。譬如水器破坏不见月像。如是众生过失不见佛像。此义得成。偈曰

  譬如火聚性　　或然或灭尽
  如是诸佛化　　或出或涅槃

释曰。此偈显示诸佛教化有出有没。譬如火性有时炽然有时灭尽。诸佛教化亦复如是。有时示现出世。有时示现涅槃。如是已说如来转依。次说如来事业恒无功用。偈曰

  意珠及天鼓　　自然成自事
  佛化及佛说　　无思亦如是

释曰。此偈显示佛事无功用。譬如如意宝珠虽复无心自然能作种种变现。如来亦尔。虽复无功用心自然能起种种变化。譬如天鼓虽复无心自然能出种种音声。如来亦尔。虽复无功用心自然能说种种妙法。偈曰

  依空业无间　　而业有增减
  依界事不断　　而事有生灭

释曰。此偈显示佛事无间。譬如世间依空所作无时断绝。诸佛亦尔。依无漏界而作佛事亦无断绝。譬如世间依空所作有增有减。诸佛亦尔。依无漏界而作佛事亦有生灭。已说无功用心不舍佛事。次说无漏法界甚深。偈曰

  如前后亦尔　　及离一切障
  非净非不净　　佛说名为如

释曰。此偈显示法界清净相。如前后亦尔者。所谓非净。由自性不染故。及离一切障者。所谓非不净。由后时客尘离故。非净非不净佛说名为如者。是故佛说是如非净非不净。是名法界清净相。偈曰

  清净空无我　　佛说第一我
  诸佛我净故　　故佛名大我

释曰。此偈显示法界大我相。清净空无我者。此无漏界由第一无我为自性故。佛说第一我者。第一无我谓清净如。彼清净如即是诸佛我自性。诸佛我净故。故佛名大我者。由佛此我最得清净。是故号佛以为大我。由此义意。诸佛于无漏界建立第一我。是名法界大我相。偈曰

  非体非非体　　如是说佛体
  是故作是论　　定是无记法

释曰。此偈显示法界无记相。作体者。人法二相不可说故。非非体者。如相实有故。如是说佛体者。由此因缘故说佛体非体非非体。是故作是论定是无记法者。无记谓死后有如来死后无如来。死后亦有如来亦无如来。死后非有如来非无如来。如是四句不可记故。是故法界是无记相。偈曰

  譬如铁热息　　譬如眼翳除
  心智息亦尔　　不说有无体

释曰。此偈显示法界解脱相。譬如铁热息譬如眼翳除者。如是二物热息翳除可说非体非非体。何以故。非体者。由热翳无相故。非非体者。由息相有体故。心智息亦尔不说有无体者。诸佛心智以贪为热以无明为翳。彼二若息亦说非体非非体。何以故。非体者。由贪及无明息故。非非体者。由心慧解脱有故。是名法界解脱相。已说相甚深。次说处甚深。偈曰

  诸佛无漏界　　非一亦非多
  前身随顺故　　非身如空故

释曰。此偈显示法界处甚深。诸佛无漏。法界非一亦非多。何以故。非一者。由前身随顺故。非多者。由非身故。问云何非身。答如虚空故。是名法界处甚深。已说处甚深。次说业甚深。偈曰

  譬如大宝藏　　众宝之所依
  净界亦如是　　佛法之依止

释曰。此偈显示法界依止业。由清净法界为力无畏等诸菩提分宝所依止故。偈曰

  譬如密云布　　洒雨成百谷
  净界亦如是　　流善熟众生

释曰。此偈显示法界成熟众生业。由从清净法界流诸善根成熟众生故。偈曰

  譬如日月盈　　皎净轮圆满
  净界亦如是　　善根聚圆满

释曰。此偈显示法界到究竟业聚。谓福智由清净法界。如此二聚得圆满故。偈曰

  譬如日轮出　　流光照一切
  净界亦如是　　流说化群生

释曰。此偈显示法界说正法业。偈曰

  譬如日光合　　同事照世间
  净界亦如是　　佛合同业化

释曰。此偈显示法界化所作业。譬如多日多光一时和合同作一事。谓干熟等。如是多佛多智一时和合同作一业。谓变化等。偈曰

  譬如日光照　　无限亦一时
  净界佛光照　　二事亦如是

释曰。此偈显示法界无分别业。譬如日光普照无有分限亦复一时。如是佛光普照无限一时亦复如是。偈曰

  譬如诸日光　　说有云等翳
  净界诸佛智　　说有众生障

释曰。此偈显示法界不作业。譬如日光云等为翳是故不照。如是佛光众生过失为障。五浊多故。是故不有所作。偈曰

  譬如滋灰力　　染衣种种色
  净界行愿力　　解脱种种智

释曰。此偈显示法界解脱智业。譬如别衣由滋灰力。有处得种种色。有处不得种种色。三乘净界亦尔。由行愿力诸佛解脱得种种智。二乘解脱不得种种智。偈曰

  无漏界甚深　　相处业三种
  诸佛如是说　　譬如染画空

释曰。此偈重显前甚深义。无漏界甚深相处业三种者。此无漏界世尊略说三种甚深。一者相甚深。二者处甚深。三者业甚深。相甚深有四种。一清净相。二大我相。三无记相。四解脱相。如其次第。由前四偈所显处甚深一种。谓一多不住故。由第五偈所显业甚深有八种。一宝依止业。二成熟众生业。三到究竟业。四说正法业。五化所作业。六无分别业。七智不作业。八解脱智业。如其次第。由后八偈所显。诸佛如是说。譬如染画空者。此无漏界无有戏论。譬如虚空是故甚深。如是甚深差别说者。譬如染于虚空画于虚空。是义应知。偈曰

  一切无别故　　得如清净故
  故说诸众生　　名为如来藏

释曰。此偈显示法界是如来藏。一切无别故者。一切众生一切诸佛等无差别。故名为如。得如清净故者。得清净如以为自性。故名如来。以是义故可说一切众生名为如来藏。已说无漏界甚深。次说诸佛变化。偈曰

  声闻及缘觉　　菩萨与如来
  初化退世间　　至佛退菩萨

释曰。此偈显示增上变化。一切世间变化声闻变化能退。一切声闻变化缘觉变化能退。一切缘觉变化菩萨变化能退。一切菩萨变化诸佛变化能退。无有一人变化能退诸佛变化。是故如来变化最得增上。偈曰

  如是佛变化　　无量不思议
  随人随世界　　随时种种现

释曰。此偈显示甚深变化。此甚深有二种。一者无量。二者不思议。问此事云何。答随何根人随何世界随何时节。如其差别。若多若少。种种变化。如是无量亦不思议。是故如来变化最为甚深。自下次说别转变化。偈曰

  如是五根转　　变化得增上
  诸义遍所作　　功德千二百

释曰。此偈显示转五根变化。此变化得二种增上。一者得诸义遍所作。谓一一根皆能互用一切境界故。二者得功德千二百。谓一一根各得千二百功德故。偈曰

  如是意根转　　变化得增上
  极净无分别　　恒随变化行

释曰。此偈显示转意根变化。意根谓染污识。由此转故得极净无分别智。恒与一切变化随行共所作故。偈曰

  如是义受转　　变化得增上
  净土如所欲　　受用皆现前

释曰。此偈显示转义受变化。义谓五尘受谓五识。由此二转刹土清净。所欲现前随意受用。偈曰

  如是分别转　　变化得增上
  诸智所作业　　恒时无碍行

释曰。此偈显示转分别变化。分别谓意识。由此转故诸智所作。一切时变化无有障碍。偈曰

  如是安立转　　变化得增上
  住佛不动句　　不住于涅槃

释曰。此偈显示转安立变化。安立谓器世界。由此转故。住佛不动无漏法界。得不般涅槃。恒起增上变化。偈曰

  如是欲染转　　变化得增上
  住佛无上乐　　示现妻无染

释曰。此偈显示转欲染变化。由此转故得二种变化。一者得无上乐住。二者得于妻无染。偈曰

  如是空想转　　变化得增上
  随欲一切得　　所去皆无拥

释曰。此偈显示转空想变化。由此转故得二种变化。一者所欲皆得。得虚空藏故。二者所去无拥。得虚空解故。偈曰

  如是无量转　　如是无量化
  不思议所作　　诸佛依无垢

释曰。此偈总结前义。由无量转故得无量变化。如是诸佛不思议业。一切皆依无漏法界。是义应知。已说诸佛变化。次说诸佛成熟众生。偈曰

  令集亦令长　　令熟亦令脱
  熟熟不无余　　世间无尽故

释曰。此偈显示次第成熟因。未集善根者令聚集。已集善根者令增长。已长善根者令成熟。已熟善根者令解脱。使得最极清净。如是十方诸佛各各善说。熟已复熟不般涅槃。何以故。由诸世间无有尽故。偈曰

  难得已具得　　处处为物归
  希有非希有　　由得善方便

释曰。此偈显示已熟菩萨行非希有相。难得已具得处处为物归者。无上菩提最上功德。此未曾有。今已具足相应。由此相应故能恒于十方世界为物归处。希有非希有者。如是处处成熟众生。是为希有。如此希有亦非希有。何以故。由得善方便故。善方便者。谓随机道即是清净行。偈曰

  转法及法没　　得道亦涅槃
  处处方便起　　不动真法界

释曰。此偈显示普遍成熟因。转法及法没得道亦涅槃者。谓于一刹那中有处示现转无量法轮。有处示现正法灭尽。有处示现得大菩提。有处示现入于涅槃。此由众生行不同故。处处方便起不动真法界者。若众生应可成熟。如来随彼住处处处教化。然于无漏法界亦复不动偈曰

  不起分别意　　成熟去来今
  处处化众生　　三门常示现

释曰。此偈显示自然成熟因。不起分别意成熟去来今者。一切诸佛不作是念。我曾成熟众生。我当成熟众生。我今成熟众生。何以故。由无分别故。处处化众生三门常示现者。虽无功用而一切时。以诸善根于十方世界。遍以三门成熟众生。三门者。谓三乘教门故。偈曰

  如日自然光　　照闇成百谷
  法日光亦尔　　灭惑熟众生

释曰。此偈譬显自然义。譬如日轮无勤方便自然放光处处破闇成熟百谷。诸佛亦尔。虽无功用以法日光处处灭惑成熟众生。偈曰

  一灯燃众灯　　极聚明无尽
  一熟化多熟　　无尽化亦然

释曰。此偈显示展转成熟因。譬如一灯。传然众灯。极大灯聚无量无数而一灯无尽。诸佛亦尔。一佛成熟化多成熟极大众生聚无量无数。然其化力亦复无尽。偈曰

  巨海纳众流　　无厌复无溢
  佛界摄众善　　不满亦不增

释曰。此偈显示无厌成熟因。譬如巨海广纳百川无有厌足亦无盈溢。为容受故。佛界亦尔。常摄无量清净善根。而不满足亦不增长。由希有故。已说诸佛成熟众生。次说诸佛法界清净。偈曰

  二障已永除　　法如得清净
  诸物及缘智　　自在亦无尽

释曰。此偈显示法界性义。二障已永除法如得清净者。谓清净相。由烦恼障及智障悉永尽故。诸物及缘智自在亦无尽者。谓自在相。由于诸物及缘彼智。二种自在永无尽故。偈曰

  一切种如智　　修净法界因
  利乐化众生　　此果亦无尽

释曰。此偈显示法界因义。一切种如智修净法界因者。谓为清净法界于一切时修一切种如门智以为因故。利乐化众生此果亦无尽者。谓为教化众生于一切时与一切众生利乐二果恒无尽故。偈曰

  发起身口心　　三业恒时化
  二门及二聚　　方便悉圆满

释曰。此偈显示法界业义。发起身口心三业恒时化者。谓起身业口业心业一切时教化众生故。二门及二聚方便悉圆满者。论具足二门二聚为方便故。二门谓三昧门陀罗尼门。二聚谓福德聚智慧聚。偈曰

  自性及法食　　变化位差别
  此由法界净　　诸佛之所说

释曰。此偈显示法界位义。自性及法食变化位差别者。谓自性身食身化身位差别故。此由法界净诸佛之所说者。若法界不清净此位不成故。已说诸佛法界清净。次说诸佛三身。偈曰

  性身及食身　　化身合三身
  应知第一身　　余二之依止

释曰。一切诸佛有三种身。一者自性身。由转依相故。二者食身。由于大集众中作法食故。三者化身。由作所化众生利益故。此中应知。自性身为食身化身依止。由是本故。偈曰

  食身于诸界　　受用有差别
  众土名身业　　一切皆异故

释曰。食身于一切世界中诸徒众诸刹土诸名号诸身诸业。如此诸受用事悉皆不同。偈曰

  平等微细身　　受用身相合
  应知受用身　　得是化身因

释曰。平等谓自性身。一切诸佛等无别故。微细者。由此身难知故。受用身谓食身。此身与平等身合由依起故。应知受用身复是化身因者。由所欲受用一切示现故。偈曰

  化佛无量化　　是故名化身
  二身二利成　　一切种建立

释曰。由化身诸佛于一切时化作无量差别。佛由此化故名为化身。二身者谓食身化身。二利者谓自利他利。食身以自利成就为相。化身以他利成就为相。如此二利。一切种成就故。次第建立食身及化身。偈曰

  工巧及出生　　得道般涅槃
  示此大方便　　令他得解脱

释曰。复次化身者。于一切时教化众生。或现工巧。或现出生。或现得菩提。或现般涅槃。如是种种示大方便。皆令众生而得解脱。此是他利成就相。偈曰

  应知佛三身　　是佛身皆摄
  自他利依止　　示现悉三身

释曰。应知此三身摄一切诸佛身。示现一切自利他利依止故。偈曰

  由依心业故　　三佛俱平等
  自性无间续　　三佛俱常住

释曰。彼三种身如其次第。一切诸佛悉皆平等。由依故。一切诸佛自性身平等。法界无别故。由心故。一切诸佛食身平等。佛心无别故。由业故。一切诸佛化身平等。同一所作故。复次一切诸佛悉同常住。由自性常故。一切诸佛自性身常住。毕竟无漏故。由无间常故。一切诸佛食身常住。说法无断绝故。由相续常故。一切诸佛化身常住。虽于此灭复彼现故。已说诸佛身。次说诸佛智。偈曰

  四智镜不动　　三智之所依
  八七六五识　　次第转得故

释曰。四智镜不动三智之所依者。一切诸佛有四种智。一者镜智。二者平等智。三者观智。四者作事智。彼镜智以不动为相。恒为余三智之所依止。何以故。三智动故。八七六五识次第转得故者。转第八识得镜智。转第七识得平等智。转第六识得观智。转前五识得作事智。是义应知。偈曰

  镜智缘无分　　相续恒不断
  不愚诸所识　　诸相不现前

释曰。此偈显示转第八识得镜智。镜智缘无分者。于一切境界不作分段缘故。相续恒不断者。于一切时常行不断绝故。不愚诸所识者。了知一切境界障永尽故。诸相不现前者。于诸境界离行相缘无分别故。偈曰

  镜智诸智因　　说是大智藏
  余身及余智　　像现从此起

释曰。此偈显示镜智用。镜智诸智因说是大智藏者。彼平等智等诸智一切种皆以镜智为因。是故此智譬如大藏。由是诸智藏故。余身及余智像现从此起者。余身谓受用身等。余智谓平等智等。由彼身像及彼智像。一切皆从此智出生。是故佛说此智以为镜智。偈曰

  众生平等智　　修净证菩提
  不住于涅槃　　以无究竟故

释曰。此偈显示转第七识得平等智。众生平等智修净证菩提者。若诸菩萨证法现前时。即得一切众生平等智。若修习此智最极清净。即得无上菩提。不住于涅槃。以无究竟故者。由众生无尽故无究竟。无究竟故不住涅槃。由此义故说为平等智。偈曰

  大慈与大悲　　是二恒无绝
  众生若有信　　佛像即现前

释曰。此偈显示平等智用。大慈与大悲是二恒无绝者。诸佛如来于一切时随逐众生。何以故。大慈大悲无断绝故。众生若有信佛像即现前者。如其所信随彼现故。是故或有众生见如来青色。或有众生见如来黄色。如是一切此前二智即是法身。偈曰

  观智识所识　　恒时无有碍
  此智如大藏　　总持三昧依

释曰。此偈显示转第六识得观智。观智于所识一切境界恒无障碍。譬如大藏。与一切陀罗尼门一切三昧门而为依止。何以故。如是二门皆从此智生故。偈曰

  恒在大众中　　种种皆示现
  能断诸疑网　　雨大法雨故

释曰。此偈显示观智用义如偈说。此观智即是食身。偈曰

  事智于诸界　　种种化事起
  无量不思议　　为利群生故

释曰。此偈显示转前五识得作事智。彼作事智于一切世界中作种种变化事。无量无边不可思议。如此等业。皆为利益一切众生故。此作事智即是化身。偈曰

  摄持及等心　　开法亦作事
  如是依四义　　次第四智起

释曰。摄持者。谓闻法摄持故。等心者。谓于一切众生得自他平等故。开法者。谓演说正法故。作事者。谓起种种化业故。依第一义镜智起。依第二义平等智起。依第三义观智起。依第四义作事智起。偈曰

  性别及不虚　　一切亦无始
  无别故不一　　依同故不多

释曰。此偈显示诸佛不一不多。不一者。由性别故。不虚故。一切故。无始故。无别故。性别者。由无边诸佛性别。若言唯有一佛而有当得菩提者。是义不然。故佛不一。不虚者。若福智聚虚则应余菩萨不得菩提。由二聚不虚故。是义不然。故佛不一。一切者。若言唯有一佛则应是佛不利益一切众生。由佛建立一切众生作佛故。是义不然。故佛不一。无始者。若言唯有最初一佛。是佛应无福智二聚而得成佛。是义不然。故佛不一。无别者。若言有别佛无福智二聚。是义不然。故佛不一。不多者。由依同故。一切诸佛法身由依无漏界故。已说诸佛智。次说入佛方便。偈曰

  分别若恒有　　真实则永无
  分别若永无　　真实则恒有

释曰。若分别自性是恒有。则真实自性是永无。由不可得故。若分别自性是永无。则真实自性是恒有。由可得故偈曰

  欲修最上修　　不见一切修
  欲得最上得　　不见一切得

释曰。彼如是最上修。彼修不可得。彼如是最上得。彼得不可得。偈曰

  尊重及长时　　观佛希有法
  缘此速得佛　　去佛菩提远

释曰。若有菩萨于佛世尊极生尊重及长时正勤观佛未曾有法。缘此观心及长时精进。而谓我当速得无上菩提。应知如是菩萨去佛菩提则为甚远。何以故。彼有慢故。偈曰

  观法唯分别　　此义如前知
  菩萨无分别　　说彼速成佛

释曰。若菩萨观一切诸法唯是分别。观彼分别亦无分别。即得入彼无生忍位。由如此义说得菩提。已说入佛方便。次说诸佛同事。偈曰

  应知诸河水　　别依亦别事
  水少虫用少　　未入大海故
  一切入大海　　一依亦一事
  水大虫用大　　亦复常无尽
  如是诸别解　　别意亦别业
  解少利益少　　未入佛体故
  一切入佛体　　一解亦一意
  解大利益大　　极聚亦无尽

释曰。别水譬诸菩萨别解。别依譬诸菩萨别意。一水譬诸如来一解。一依譬诸如来一意。由诸河水别故水事业亦别。由水少故水虫受用亦少。何以故。未得同入大海故。诸菩萨亦尔。由解别故作业亦别。由解少故利益众生亦少。何以故。未得同入佛体故。诸水若入大海。即同一依。即同一体。由水一故事业亦一。由水大故水虫受用亦大。若诸菩萨同入佛体。即同一意。即同一解。由解一故作业亦一。由解大故利益亦大。极一切众生聚亦无有尽。如是已说诸佛体用次说一偈劝进悕求。偈曰

  无比圆白法　　众生利乐因
  乐住无尽藏　　智者应求发

释曰。无比圆白法者。由佛自利成就故。众生利乐因者。由佛利他成就故。乐住无尽藏者。由佛善根无过无上是无尽乐藏故。智者应求发者。有智之人应求如此最胜乐住而发大菩提心故。菩提品究竟

大乘庄严经论卷第三大乘庄严经论卷第四

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    明信品第十一

释曰。已说无上菩提随顺。菩提者所谓信。此信相今当说。偈曰

  已生及未生　　正受及似受
  他力亦自力　　有迷亦不迷
  现前不现前　　听法及求义
  观察等十三　　分别于信相

释曰。信相差别有十三种。一者已生信。谓过去现在信。二者未生信。谓未来信。三者正受信。谓内信。四者似受信。谓外信。五者他力信。谓粗信。由善友力生故。六者自力信。谓细信。由自力生故。七者有迷信。谓恶信。由颠倒故。八者不迷信。谓好信。由无倒故。九者现前信。谓近信。由无障故。十者不现前信。谓远信。由有障故。十一者听法信。谓闻信。由闻生故。十二者求义信。谓思信。由思生故。十三者观察信。谓修信。由修生故。已说信相差别。次说信种差别。偈曰

  可夺间无间　　有多亦有少
  有覆及无覆　　相应不相应
  有聚亦无聚　　极入亦远入
  复此十三义　　分别于信种

释曰。信种差别亦有十三。一者可夺信。谓下品信。二者有间信。谓中品信。三者无间信。谓上品信。四者多信。谓大乘信。五者少信。谓小乘信。六者有覆信。谓有障信。由不能胜进故。七者无覆信。谓无障信。由能胜进故八者相应信。谓熟修信。由恒行及恭敬行故。九者不相应信。谓不熟修信。由离前二行故。十者有聚信。谓有果信。由能得大菩提故。十一者无聚信。谓无果信。由不能得大菩提故。十二者极入信。谓功用信。从初地至七地故。十三者远入信。谓极净信。从八地至佛地故。已说信种。次说信障难。偈曰

  多忘亦懈怠　　行迷并恶友
  善羸及邪忆　　放逸复少闻
  闻喜及思喜　　因定增上慢
  应知此等过　　障碍于信相

释曰。障者相违义。多忘者。于已生信为障。懈怠者。于未生信为障。行迷者。于正受似受信为障。如先所受能受执着故。恶友者。于他力信为障。以倒法令受故。善羸者。于自力信为障。邪忆者。于不迷信为障。放逸者。于现前信为障。少闻者于听法信为障。不听了义故。闻喜者。于求义信为障。少思惟故。思喜及定慢者。于观察信为障。少修及不细观察故。问何障障信种。偈曰

  不厌及不习　　有厌亦有覆
  无应及无聚　　应知障信种

释曰。不习者于可夺信有闻信为障。不厌者。于小信为障。不厌生死故。有厌者。于大信为障。厌生死故。有覆者。于无覆信为障。无应者。于相应信为障。无聚者。于有聚信为障。已显示信障难。次赞叹信功德。偈曰

  信有大福德　　不悔及大喜
  不坏将坚固　　进位并得法
  自利与他利　　亦复速诸通
  以此诸功德　　赞叹信利益

释曰。大福德者。赞现在信不悔者。赞过去信。不追变故。大喜者。赞正受信及似受信。定相应故。不坏者。赞友力信。正道不坏故坚固者。赞自力信。不退舍故。进位者。赞不迷信现前信听法信求义信观察信有间信。得法者。赞无间信。自利者。赞少信。他利者。赞多信。速通者。赞诸自分信。谓无覆信相应信有聚信极入信速入信。偈曰

  狗龟奴王譬　　次第譬四信
  习欲习诸定　　自利利他人

释曰。譬如饿狗求食无厌。诸习欲人信亦复如是。于一切时种种信故。譬如盲龟水中藏六。诸习外定人信亦复如是。唯知修习世间定故。譬如贼奴畏主。勤作诸自利人信亦复如是。为怖生死勤方便故。譬如大王自在诏敕。诸利他人信亦复如是。增上教化无休息故。菩萨自解诸信。复广分别令他得解。如是劝诸众生生大乘信。已赞信功德。次遮下劣心。偈曰

  人身及方处　　时节皆无限
  三因菩提得　　勿起下劣心

释曰。人身及方处时节皆无限者。得无上菩提有三因无限。一者人身无限。由人道众生得无限故。二者方处无限。由十方世界得无限故。三者时节无限。由尽未来际刹那刹那得无限故。三因菩提得勿起下劣心者。由此三因无限。是故诸菩萨于无上菩提不应退屈起下劣心。已遮下劣心。次显福德胜。偈曰

  得福由施彼　　非由自受用
  依他说大乘　　不依自义法

释曰。得福由施彼非由自受用者。譬如以食施彼则得大福。由利他故。非自受用能得大福。由自利故。问若尔菩萨云何得福。答依他说大乘不依自义法。诸菩萨如是依他说大乘经得大福德。不依自利说小乘经得大福德。已说胜福。次说得果。偈曰

  大法起大信　　大信果有三
  信增及福增　　得佛功德体

释曰。大法起大信大信果有三者。谓有智人于大乘圣法而生大信。由此大信得三种果。问得何等果。答信增及福增得佛功德体。此明一得大信果。信增长故二得大福果。福增长故三得大菩提果。功德无等及佛体大故。明信品究竟

    大乘庄严经论述求品第十二之一

释曰。如是已说种种信。次说以信求诸法。偈曰

  三藏或二摄　　成三有九因
  熏觉寂通故　　解脱生死事

释曰。三藏或二摄者。三藏谓修多罗藏毗尼藏阿毗昙藏。或二谓此三由下上乘差别故。复次为声闻藏及菩萨藏。问彼三及二。云何名藏。答由摄故。谓摄一切所应知义。问云何成三。答成三有九因。立修多罗者。为对治疑惑。若人于义处处起疑。为令彼人得决定故。立毗尼者。为对治受用二边。为离乐行边遮有过受用。为离苦行边听无过受用。立阿毗昙者。为对治自心见取。不倒法相此能示故。复次立修多罗者。为说三学。立毗尼者。为成戒学。心学由持戒故不悔。由不悔故随次得定。立阿毗昙者。为成慧学。不颠倒义此能择故。复次立修多罗者。为正说法及义。立毗尼者。谓成就法及义由勤方便烦恼灭故。立阿毗昙者。为通达法及义。由种种简择此为方便故。由此九因故立三藏。问别用如此通用云何。答熏觉寂通故解脱生死事。此明解脱生死是其通用。由闻故熏。由思故觉。由止故寂。由观故通。由此四义生死诸事永得解脱。偈曰

  经律阿毗昙　　是各有四义
  具解成种智　　一偈得漏尽

释曰。若略说三藏一一各有四义。若菩萨能了此义。则成就一切种智。若声闻能了一偈则得诸漏永尽。问云何一一四种义。偈曰

  依故及相故　　法故及义故
  如是四种义　　是说多罗义

释曰。修多罗有此四义。一依二相三法四义。依者。是处是人是用。谓随是何国土。随是何诸佛。随是何众生。如来依此三种说修多罗。相者。谓世谛相及第一义谛相。法者。谓阴界入缘生谛食等法。义者。谓释所以。偈曰

  对故及数故　　伏故及解故
  如是四种义　　是说毗昙义

释曰。阿毗昙有此四义。一对二数三伏四解。对者是向涅槃法。谛菩提分解脱门等说故。数者是相续法。于一一法色非色可见不可见等差别无量说故。伏者。是胜上法。于诤论众中决判法义退彼说故。解者。是释义法。由阿毗昙修多罗义易可解故。偈曰

  罪起净出故　　人制解判故
  四义复四义　　是说毗尼义

释曰。毗尼有二种四义。初四义者。一罪二起三净四出。罪者。罪自性。谓五聚罪。起者。罪缘起。此有四种。一无知。二放逸。三烦恼疾利。四无恭敬心。净者。罪还净。由善心不由治罚。出者。罪出离。此有七种。一者悔过。谓永遮相续。二者顺教。谓与学羯磨治罚。三者开许。谓先时已制后时更开。四者更舍。谓僧和合与学者舍。是时先犯还得清净。五者转依。谓比丘比丘尼男女转根出不共罪。六者实观。谓法忧陀那由胜观察。七者性得。谓见谛时细罪无体。由证法空法尔所得。复四义者。一人二制三解四判。人者谓犯罪人。制者谓依彼犯人大师集众说彼过失制立学足。解者谓如所制更广分别。判者谓云何得罪。云何不得罪。如是应持。已说求法。次说求缘。偈曰

  佛说所缘法　　应知内外俱
  得二无二义　　二亦不可得

释曰。佛说所缘法应知内外俱者。佛说一切所缘法有三种。一内二外三俱。彼能取自性身等为内。所取自性身等为外。合二自性为俱。得二无二义二亦不可得者。于此内外二缘如其次第得无二义。问云何得。答若所取义与能取义无别观。若能取义与所取义无别观。复次合二为一。由于内外二缘得如如故。如是彼二无有二义。则此二缘亦不可得。问已说得缘。云何得智。偈曰

  三缘得三智　　净持意言境
  了别义光已　　安心唯有名

释曰。三缘谓如前说内外俱三境。三智谓闻思修三慧。由依三缘能得三慧。问云何得。答若于三缘净持意言境即得闻慧。意言者分别也。净者信决定。持者择彼种。由此得闻慧。若于三缘了别义光已即得思慧。谓知义及光不异意言。由此得思慧。若于三缘安心唯有名即得修慧。谓知义及光但唯是名。由此得修慧。如先所说二缘不可得。是故应知彼三缘者。是闻思修三慧依止。已说求缘。次说求作意。偈曰

  最初谓种性　　所作及依止
  信安及欲生　　依定亦依智
  别缘种种缘　　通达及修种
  自性与功力　　领受及方便
  自在小大等　　如是有十八
  尽摄诸作意　　行者应勤修

释曰。十八种作意者。一种性作意。二所作作意。三依止作意。四信安作意。五欲生作意。六依定作意。七依智作意。八别缘作意。九种种缘作意。十通达作意。十一修种作意。十二自性作意。十三功力作意。十四领受作意。十五方便作意。十六自在作意。十七小作意。十八大作意。种性作意者。由声闻等三乘性定故。所作作意者。由福智二聚圆满故。依止作意者。由在家出家迫迮不迫迮差别故。信安作意者。念佛相应故。欲生作意者。随念佛时信心相应故。依定作意者。有觉有观等三三昧相应故。依智作意者。从闻思修方便次第生故。别缘作意者。此有五种。于修多罗忧陀那伽陀阿波陀那。一受二持三读四思五说故。种种缘作意者。此有七种。名缘句缘字缘人无我缘法无我缘色缘无色缘。色缘谓身缘。无色缘谓受心法缘。通达作意者。此有四种。一通达物。谓知苦体。二通达义。谓知苦无常空无我义。三通达果。谓知解脱。四通达觉。谓知解脱智。修种作意者。此有四种修及三十七种。修四种修者。谓人无我种修。法无我种修见种修。智种修。三十七种修者。谓不净苦无常无我四种修。是名四念处种修。复次得习断对治四种修。是名四正勤种修。复次为对治知足乱疑掉动沉没四障故欲进念慧四种修。是名四神足种修。复次住心者。为成就出世间故起信勤不忘心住简择五种修。是名五根种修。复次如是五修能治五障即名为力。是名五力种修。复次于菩提正忆简择勇猛庆悦调柔心住平等七种修。是名七觉分种修。复次得决定故。成净持地业。思惟分别故。圣所受三戒能持故。先所得道勤习故。法住相不忘故。无想心住转依故。如是八种修。是名八道分种修。自性作意者。此有二种。一奢摩他。二毗钵舍那。此二是道自性故。功力作意者。力有二种。一拔除熏习。二拔除相见。领受作意者。诸佛菩萨教授所有法流悉受持故。方便作意者。于定所行处方便有五。一解数方便。于名句字数悉通达故。二解具方便。具有二种。一分量具所谓诸字。二非分量具所谓名句等。三解分别方便。分别二种。一依名分别义。二依义分别名非分别者字也。四解次第方便。谓先取名后转取义。五解通达方便。通达有十一种。一通达客尘。二通达境光。三通达义不可得。四通达不可得不可得。五通达法界。六通达人无我。七通达法无我。八通达下劣心。九通达高大心。十通达所得法。十一通达所立法。自在作意者。自在三种。一惑障极清净。二惑智二障极清净。三功德极清净。小作意者。谓初清净。大作意者。谓后二清净。已说求作意。次说求真实义。偈曰

  离二及迷依　　无说无戏论
  三应及二净　　二净三譬显

释曰。离二及迷依无说无戏论者。此中应知。三性俱是真实。离二者。谓分别性真实。由能取所取毕竟无故。迷依者。谓依他性真实。由此起诸分别故。无说无戏论者。谓真实性真实。由自性无戏论不可说故。三应及二净二净三譬显者。三应谓初真实。应知第二真实应断。第三真实应净。二净谓一者自性清净。由本来清净故。二者无垢清净。由离客尘故。此二清净由三种譬喻可得显现。谓空金水。如此三譬。一则俱譬自性清净。由空等非不自性清净故。二则俱譬无垢清净。由空等非不离客尘清净故。偈曰

  法界与世间　　未曾有少异
  众生痴盛故　　着无而弃有

释曰。法界与世间未曾有少异者。非法界与世间而有少异。何以故。法性与诸法无差别故。众生痴盛故着无而弃有者。由众生愚痴炽盛。于世间无法。不应着而起着。于如如有法。不应舍而弃舍。已说求真实。次说求真实譬喻。偈曰

  如彼起幻师　　譬说虚分别
  如彼诸幻事　　譬说二种迷

释曰。如彼起幻师譬说虚分别者。譬如幻师依咒术力变木石等以为迷因。如是虚分别依他性亦尔。起种种分别为颠倒因。如彼诸幻事譬说二种迷者。譬如幻像金等种种相貌显现。如是所起分别性亦尔。能取所取二迷恒时显现。偈曰

  如彼无体故　　得入第一义
  如彼可得故　　通达世谛实

释曰。如彼无体故得入第一义者。如彼谓幻者幻事无有实体。此譬依他分别二相亦无实体。由此道理即得通达第一义谛。如彼可得故通达世谛实者。可得谓幻者幻事体亦可得。此譬虚妄分别亦尔。由此道理即得通达世谛之实。偈曰

  彼事无体故　　即得真实境
  如是转依故　　即得真实义

释曰。彼事无体故即得真实境者。若人了彼幻事无体。即得木等实境。如是转依故即得真实义者。若诸菩萨了彼二迷无体。得转依时即得真实性义。偈曰

  迷因无体故　　无迷自在行
  倒因无体故　　无倒自在转

释曰。迷因无体故无迷自在行者。世间木石等虽复无体而为迷因。若得无迷行则自在不依于他。倒因无体故无倒自在转者。如是依未转时虽复无体而为倒因。若得转时由无倒故。圣人亦得自在依自在行。偈曰

  是事彼处有　　彼有体亦无
  有体无有故　　是故说是幻

释曰。是事彼处有彼有体亦无者。此显幻事有而非有。何以故。有者是幻像事。彼处显现故。非有者彼实体不可得故。有体无有故是故说是幻者。如是有体与无体无二。由此义故说彼是幻。偈曰

  无体非无体　　非无体即体
  无体体无二　　是故说是幻

释曰。无体非无体非无体即体者。此显幻事非有而有。何以故。非有者。彼幻事无体由无实体故。而有者。彼幻事非无体由像显现故。无体体无二是故说是幻者。如是无体与体无二。由此义故说彼是幻。偈曰

  说有二种光　　而无二光体
  是故说色等　　有体即无体

释曰。说有二种光而无二光体者。此显虚妄分别有而非有。何以故。有者。彼二光显现故。非有者。彼实体不可得故。是故说色等有体即无体者。由此义故。故说色等有体即是无体。偈曰

  无体非无体　　非无体即体
  是故说色等　　无体体无二

释曰。无体非无体非无体即体者。此显虚妄分别非有而有。何以故。非有者。彼二光无体由无实体故。而有者。彼二光非无体由光显现故。是故说色等无体体无二者。由此义故。故说色等无体与体而无有二。问体与无体何不一向定说而令彼二无差别耶。偈曰

  有边为遮立　　无边为遮谤
  退大趣小灭　　遮彼亦如是

释曰。如其次第。一为遮有边。二为遮无边。三为遮趣小乘寂灭。是故不得一向定说。问云何遮有边。答有边为遮立。此明由于无体知无体故。不应安立有。问云何遮无边。答无边为遮谤。此明由于有体知世谛故。不应非谤无。问云何遮趣小乘寂灭。答退大趣小灭遮。彼亦如是。此明由彼二无别故。不应厌体入小涅槃。偈曰

  色识为迷因　　识识为迷体
  色识因无故　　识识体亦无

释曰。色识为迷因识识为迷体者。彼所迷境名色识。彼能迷体名非色识。色识无体故识识体亦无者。色识无故非色识亦无。何以故。由因无故彼果亦无。偈曰

  幻像及取幻　　迷故说有二
  如是无彼二　　而有二可得

释曰。幻像及取幻迷故说有二者。迷人于幻像及取幻。由迷故说有能取所取二事。如是无彼二而有二可得者。彼二虽无而二可得。由迷显现故。问此譬欲何所显。偈曰

  骨像及取骨　　观故亦说二
  无二而说二　　可得亦如是

释曰。骨像及取骨观故亦说二者。观行人于骨像及取骨。由观故说有能观所观二事。无二而说二可得亦如是者。彼二虽无而二亦可得。由观显现故。问如是观已。何法为所治。何法为能治。偈曰

  应知所治体　　谓彼法迷相
  如是体无体　　有非有如幻

释曰。应知所治体谓彼法迷相者。此中应知。所治体即是法迷相。法迷相者谓如是如是体故。如是体无体有非有如幻者。如是体说有者。由虚妄分别故。说非有者。由能取所取二体与非体无别故。如是有亦如幻无亦如幻说此相如幻。偈曰

  应知能治体　　念处等诸法
  如是体无相　　如幻亦如是

释曰。应知能治体念处等诸法者。此中应知。能治体即是诸法。诸法者。谓佛所说念处等法。如是如是体故。如是体无相如幻亦如是者。彼体亦如幻。何以故。如诸凡夫所取。如是如是有体故。如诸佛所说。如是如是无体故。如是体无相。而佛世尊示现入胎出生踰城出家成正觉。如是无相而光显现。是故如幻。问若诸法同如幻。以何义故。一为能治。一为所治。偈曰

  譬如强幻王　　令余幻王退
  如是清净法　　能令染法尽

释曰。譬如强幻王令余幻王退者。彼能治净法亦如幻王。由能对治染法得增上故。彼所治染法亦如幻王。由于境界得增上故。如是清净法能令染法尽者。如彼强力幻王能令余幻王退。菩萨亦尔。知法如幻。能以净法对治染法。是故无慢。问世尊处处说如幻如梦如焰如像如影如响如水月如化。如此八譬各何所显。偈曰

  如幻至如化　　次第譬诸行
  二六二二六　　一一一有三

释曰。如幻至如化次第譬诸行者。幻譬内六入。无有我等体但光显现故。梦譬外六入。所受用尘体无有故。焰譬心及心数二法。由起迷故。像复譬内六入。由是宿业像故。影复譬外六入。由是内入影内入增上起故。响譬所说法。法如响故。水月譬依定法定则如水。法则如月。由彼澄静法显现故。化譬菩萨故意受生。不染一切所作事故。二六二二六一一一有三者。初二六谓内六入外六入。彼幻梦二譬。所显二谓心及心数。彼炎譬所显。复二六谓内六入外六入。彼像影二譬所显。一一一谓说法三昧受生。彼响月化三譬所显。已说真实义。次求能知智。偈曰

  不真及似真　　真及似不真
  如是四种智　　能知一切境

释曰。不真及似真真及似不真者。不真谓不真分别智。由不随顺出世智分别故。似真谓非真非不真分别智。从初极通达分由随顺出世智故。真谓出世无分别智。证真如故。似不真谓非分别非不分别智。即出世后得世智故。如是四种智能知一切境者。由此四智具足知一切境界。已说求智。次说求染污及清净。偈曰

  自界及二光　　痴共诸惑起
  如是诸分别　　二实应远离

释曰。自界及二光痴共诸惑起者。自界谓自阿[黍-禾+利]耶识种子。二光谓能取光所取光。此等分别。由共无明及诸余惑故得生起。如是诸分别二实应远离者。二实谓所取实及能取实。如是二实染污应求远离。偈曰

  得彼三缘已　　自界处应学
  如是二光灭　　譬如调箭皮

释曰。得彼三缘已自界处应学者。三缘谓内外俱。如前说。自界谓诸分别。应如是解。处谓名处。此名处应安心。应学谓修止观二道。如是二光灭。譬如调箭皮者。谓分别二种光息。譬如柔皮熟[革*卬]令软。亦如调箭端曲令直转依亦尔。若止若观一一须修。得心慧二脱则二光不起。如是清净应求至得

大乘庄严经论卷第四大乘庄严经论卷第五

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    述求品之二

释曰。已说求染净。次说求唯识。偈曰

  能取及所取　　此二唯心光
  贪光及信光　　二光无二法

释曰。能取及所取此二唯心光者。求唯识人应知。能取所取。此之二种唯是心光。贪光及信光二光无二法者。如是贪等烦恼光。及信等善法光。如是二光亦无染净二法。何以故。不离心光别有贪等信等染净法故。是故二光亦无二相。偈曰

  种种心光起　　如是种种相
  光体非体故　　不得彼法实

释曰。种种心光起如是种种相者。种种心光即是种种事相。或异时起。或同时起。异时起者。谓贪光嗔光等。同时起者。谓信光进光等。光体非体故不得彼法实者。如是染位心数净位心数。唯有光相而无光体。是故世尊不说彼为真实之法。已说求唯识。次说求诸相。偈曰

  所相及能相　　如是相差别
  为摄利众生　　诸佛开示现

释曰。相有二种。一者所相。二者能相。此偈总举。余偈别释。偈曰

  共及心及见　　及位及不转
  略说所相五　　广说则无量

释曰。共及心及见及位及不转者。所相有五。一者色法。二者心法。三者心数法。四者不相应法。五者无为法。彼共者谓色法。心者谓识法。见者谓心数法。位者谓不相应法。不转者谓虚空等无为法。略说所相五广说则无量者。彼识常起如是五相。此五所相是世尊略说。若广说者则有无量差别。已说所相诸相。次说能相诸相。偈曰

  意言与习光　　名义互光起
  非真分别故　　是名分别相

释曰。能相略说有三种。谓分别相。依他相。真实相。此偈显示分别相。此相复有三种。一有觉分别相。二无觉分别相。三相因分别相。意言者谓义想。义即想境。想即心数。由此想于义能如是如是起意言解。此是有觉分别相。习光者。习谓意言种子。光谓从彼种子直起义光未能如是如是起意言解。此是无觉分别相。名义互光起者。谓依名起义。光依义起。名光境界。非真唯是分别世间。所谓若名若义。此是相因分别相。如此三种相。悉是非真分别。是名分别相。偈曰

  所取及能取　　二相各三光
  不真分别故　　是说依他相

释曰。此偈显示依他相。此相中自有所取相及能取相。所取相有三光。谓句光义光身光。能取相有三光。谓意光受光分别光。意谓一切时染污识。受谓五识身。分别谓意识。彼所取相三光及能取相三光。如此诸光。皆是不真分别故。是依他相。偈曰

  无体体无二　　非寂静寂静
  以无分别故　　是说真实相

释曰。此偈显示真实相真实谓如也。此相有三种。一自相。二染净相。三无分别相。无体体无二者。是真实自相。无体者。一切诸法但分别故。体者。以无体为体故。无二者。体无体无别故。非寂静寂静者。是真实染净相。非寂静者。由客尘烦恼故。寂静者。由自性清净故。以无分别故者。是真实无分别相。由分别不行境界。无戏论故。已说三种能相。复次偈曰

  应知五学境　　正法及正忆
  心界有非有　　第五说转依

释曰。彼能相复有五种学境。一能持。二所持。三镜像。四明悟。五转依。能持者。谓佛所说正法。由此法持彼能缘故所持者。即正忆念。由正法所持故。镜像者。谓心界。由得定故。安心法界如先所说。皆见是名。定心为镜法界为像故。明悟者。出世间慧。彼有如实见有。非有如实见非有。有谓法无我。非有谓能取所取于此明见故。转依者。偈曰

  圣性证平等　　解脱事亦一
  胜则有五义　　不减亦不增

释曰。圣性证平等解脱事亦一者。圣性谓无漏界。证平等者。诸圣同得故。解脱事亦一者。诸佛圣性与声闻缘觉平等。由解脱同故。胜则有五义不减亦不增者。虽复圣性平等。然诸佛最胜自有五义。一者清净胜。由漏习俱尽故。二者普遍胜。由刹土通净故。三者身胜。由法身故。四者受用胜。由转法轮受用不断故。五者业胜。由住兜率天等现诸化事利益众生故。不减者。谓染分减时。不增者。谓净分增时。此是五种学地解相似。彼解脱所相法及三种能相法故。已说所相能相。次说求解脱偈曰

  如是种子转　　句义身光转
  是名无漏界　　三乘同所依

释曰。如是种子转者。阿梨耶识转故。句义身光转者。谓余识转故。是名无漏界者。由解脱故。三乘同所依者。声闻缘觉与佛同依止故。偈曰

  意受分别转　　四种自在得
  次第无分别　　刹土智业故

释曰。意受分别转四种自在得者。若意若受若分别。如此三光若转即得四种自在。问何者为四。答次第无分别刹土智业故。一得无分别自在。二得刹土自在。三得智自在。四得业自在。偈曰

  应知后三地　　说有四自在
  不动地有二　　余地各余一

释曰。应知后三地说有四自在者。谓不动地善慧地法云地。成就彼四种自在。不动地有二余地各余一者。不动地有第一无分别自在。第二刹土自在由无功用无分别故。由刹土清净故。善慧地有第三智自在。由得四辩善巧胜故。法云地有第四业自在。由诸通业无障碍故。偈曰

  三有二无我　　了入真唯识
  亦无唯识光　　得离名解脱

释曰。复有别解脱门。三有二无我了入真唯识者。由知二无我为方便故。菩萨于三有中分别人法皆无有体。是故无我。如是知已。亦非一向都无有体。取一切诸法真实唯识故。亦无唯识光得离名解脱者。菩萨尔时安心唯识。识光亦无即得解脱。何以故。由人法不可得离有所得故。偈曰

  能持所持聚　　观故唯有名
  观名不见名　　无名得解脱

释曰。复有别解脱门。能持所持聚者。能持谓所闻法。所持谓正忆念。聚谓福智满。由先聚力故而有所持。观故唯有名者。但有言说无有义故。复次唯名者。唯识故。复次唯名者。非色四阴故。观名不见名无名得解脱者。复次观所观名复不见名。由义无体故。又不见识故。又不见非色四阴故。如是名亦不可得。离有所得故。故名解脱。偈曰

  我见熏习心　　流转于诸趣
  安心住于内　　回流说解脱

释曰。复有别解脱门。我见熏习。心流转于诸趣者。有二种我见滋灰故言熏习。由此熏习为因。是故流转生死。安心住于内。回流说解脱者。若知所缘不可得。置心于内摄令不散。即回彼流说名解脱。已说求解脱。次求无自体。偈曰

  自无及体无　　及以体不住
  如执无体故　　法成无自体

释曰。自无及体无及以体不住者。自无谓诸法自然无。由不自起故。不自起者。属因缘故。体无谓诸法已灭者不复起故。及以体不住者。现在诸法刹那刹那不住故。此三种无自体。遍一切有为相。是义应知。如执无体故法成无自体者。如所执着实无自体。由自体无体故。如诸凡夫。于自体执着常乐我净。如是异分别相亦复无体。是故一切诸法成无自体。偈曰

  无自体故成　　前为后依止
  无生复无灭　　本静性涅槃

释曰。无自体故成前为后依止者。由前无性故次第成立后无生等。问此云何。答无生复无灭本静性涅槃。若无性则无生。若无生则无灭。若无灭则本来寂静。若本来寂静则自性涅槃。如是前前次第为后后依止。此义得成。已说求无自性。次说求无生忍偈曰

  本来及真实　　异相及自相
  自然及无异　　染污差别八

释曰。有八种无起法。名无生法忍。一者本来无起。由生死非有本起故。二者真实无起。由法无先后异先起法无故。三者异相无起。由非旧种处更得起故。四者自相无起。由分别性毕竟不起故。五者自然无起。由依他性自性不起故。六者无异无起。由真实性非有异体起故。七者染污无起。由尽智时染污诸见不复起故。八者差别无起。由诸佛法身非有差别起故。此八无起法。说名无生法忍。已说求无生忍。次说求一乘。偈曰

  法无我解脱　　同故性别故
  得二意变化　　究竟说一乘

释曰。此中八意佛说一乘。一者法同故。谓声闻等人无别法界。由所趣同故。故说一乘。二者无我同故。谓声闻等人同无我体。由趣者同故。故说一乘。三者解脱同故。谓声闻等人同灭惑障。由出离同故。故说一乘。四者性别故。谓不定三乘性人引入大乘。故说一乘。五者诸佛得同自意故。谓诸佛得如此意如我所得。一切众生亦同我得。由此意故。故说一乘。六者声闻得作佛意故。谓诸声闻昔行大菩提聚时有定作佛性。彼时佛加故胜摄故。得自知作佛意。由此人前后相续无别。故说一乘。七者变化故。谓佛示现声闻而般涅槃为教化故。如佛自说。我无量无数以声闻乘示现涅槃。由离此方便更无方便化小根人入大乘故。理实唯一故说一乘。八者究竟故。谓至佛体无复去处。故说一乘。如是处处经中以此八意佛说一乘。而亦不无三乘。问若尔复有何义以彼彼意而说一乘。偈曰

  引接诸声闻　　摄住诸菩萨
  于此二不定　　诸佛说一乘

释曰。彼彼意有二义。一为引接诸声闻故。二为摄住诸菩萨故。若诸声闻于自乘性不定。佛为引接彼人令入大乘。故说一乘。若诸菩萨于自乘性不定。佛为摄住彼人令不退大乘故说一乘。偈曰

  声闻二不定　　见义不见义
  见义不断爱　　断爱俱软根

释曰。声闻不定复有二种。一者见义乘。彼见谛发大乘故。二者不见义乘。彼不见谛发大乘故。见义复有二种。一者断爱。彼已离欲界欲故。二者不断爱。彼未离欲界欲故。此中见义二人。应知具足软品。由根钝故。偈曰

  二得圣道人　　回向于诸有
  回向不思议　　二生相应故

释曰。如是见义得圣道二人。能以圣道回向诸有。如是回向名不思议生。由以圣道回向生故。如此二人与二生相应。问何者二生。偈曰

  愿力及化力　　随欲而受生
  愿力不断爱　　化住阿那含

释曰。二生者。一愿自在生。二化自在生。初是未离欲人。后是阿那含人。问如此二人云何软品。偈曰

  由二乐涅槃　　数数自厌故
  二俱说钝道　　久久得菩提

释曰。由此二人先有乐灭心故。恒起自厌心故。是故彼道说为钝道。由不能速得无上菩提故。偈曰

  所作未办人　　生在无佛世
  修禅为化故　　渐得大菩提

释曰。所作未办人者。谓见谛未断爱未得阿罗汉果人。此人生在无佛世界。生已自能勤修诸禅为变化故。此人依止此化。渐渐更得无上菩提。如此三位。如佛胜鬘经说。如是声闻次得缘觉后得作佛。如大譬中说。一者先见谛位。二者佛空时生。自能修禅舍于生身而受化身。三者当得无上菩提。已说求一乘。次说求明处。偈曰

  菩萨习五明　　总为求种智
  解伏信治摄　　为五五别求

释曰。菩萨习五明总为求种智者。明处有五。一内明。二因明。三声明。四医明。五巧明。菩萨学此五明总意为求一切种智。若不勤习五明。不得一切种智故。问别意云何。答解伏信治摄为五。五别求如其次第学。内明为求自解学。因明为伏外执学。声明为令他信学。医明为所治方学。巧明为摄一切众生。已说求明处。次说求长养善根。所谓作意满足诸波罗蜜。此作意有四十四种。初谓知因作意。乃至最后谓知我胜作意。此等作意今当显说。偈曰

  知因及念依　　共果与信解
  四意随次第　　修习诸善根

释曰。此偈有四种作意。一知因作意。二念依作意。三共果作意。四信解作意。菩萨最初住性而作是念。我今自见波罗蜜性知可增长。是名知因作意。次作是念。我今已发大心诸波罗蜜决定当得圆满。何以故。以此大心为依止故。是名念依作意。次作是念。我已发心。为利自他勤修诸波罗蜜。此果若共即愿受之。若不共他即愿不受。是名共果作意。次作是念。我今勤行自他利时。应通达涅槃真实方便。所谓不染三轮如过去诸佛曾解。未来诸佛当解。现住诸佛今解。我皆正信。是名信解作意。如是后后作意应知。次第亦尔。偈曰

  得喜有四种　　二恶不能退
  应知随修意　　此复有四种

释曰。此偈有三种作意。一得喜作意。二不退作意。三随修作意。菩萨次作是念。我今信解诸波罗蜜得四种喜。谓障断喜聚满喜。摄自他二利喜。与依报二果喜。是名得喜作意。次作是念。我今为成就自他佛法修行诸波罗蜜时。虽遇恶人违逆恶事逼恼终无退心。是名不退作意。次作是念。我今为得无上菩提。于诸波罗蜜应起四种随修。所谓应忏悔六波罗蜜诸障。应随喜六波罗蜜诸行。应劝请六波罗蜜法义。应以六波罗蜜回向无上菩提是名随修作意。偈曰

  净信及领受　　乐说与被钾
  起愿亦悕望　　方便复七种

释曰。此偈有七种作意。一净信作意。二领受作意。三乐说作意。四被钾作意。五起愿作意。六悕望作意。七方便作意。菩萨次作是念。我今应于诸波罗蜜法义起深信力持。是名净信作意。次作是念。我今于诸波罗蜜法义。应一向起求不生诽谤。是名领受作意。次作是念。我今应以诸波罗蜜法义开示他人。是名乐说作意。次作是念。我今应令诸波罗蜜满足起大勇猛。是名被钾作意。次作是念。我今为满足诸波罗蜜愿值满足诸缘。是名起愿作意。次作是念。我今求正成就缘。是名悕望作意。次作是念。我今思惟诸波罗蜜业伴方便。是名方便作意。此中被钾作意。起愿作意。悕望作意。教授中当分别。偈曰

  勇猛及怜愍　　如是二作意
  应知二差别　　一一有四种

释曰。此偈有二种作意。一勇猛作意。二怜愍作意。此二各有四种差别。菩萨思惟方便已。次作是念。我今应起四种勇猛为坚牢故。为成熟故。为供养故。为亲近故。为坚牢者六。六波罗蜜修。所谓六施乃至六智。六施谓施施乃至施智。戒等六种亦复如是。为成熟者。以诸波罗蜜为摄物方便成熟众生。为供养者以檀为利益供养。以戒等为修行供养。为亲近者。亲近不倒教授诸波罗蜜人。是名勇猛作意。次作是念。我今应起四无量心。诸波罗蜜现前时应起慈心。悭等现前时应起悲心。他人诸波罗蜜现前时应起喜心。他人信诸波罗蜜时应起无染心。是名怜愍作意偈曰

  有羞亦有乐　　及以无屈心
  修治与称说　　此复为五种

释曰。此偈有五种作意。一有羞作意。二有乐作意。三无屈作意。四修治作意。五称说作意。菩萨次作是念。若我于诸波罗蜜。懈怠不作及以邪作。应起深惭愧等。应转檀等不转是名有羞作意。次作是念。我今于所缘诸波罗蜜境界。应持心不乱。是名有乐作意。次作是念。我今于退诸波罗蜜方便作怨家想。是名无屈作意。次作是念。我今于诸波罗蜜相应诸论。应善集修治。是名修治作意。次作是念。我今为生他解。应如其根器应赞扬诸波罗蜜法义。是名称说作意。偈曰

  依度得菩提　　非随自在等
  过恶及功德　　此二亦应知

释曰。此偈有二作意。一依度作意。二应知作意。菩萨如前称扬已。次作是念。我今依止诸波罗蜜得大菩提。非依自在天等。是名依度作意。次作是念。我今应知障诸波罗蜜过恶及诸波罗蜜功德。是名应知作意。偈曰

  喜集及见义　　乐求求四种
  平等无分别　　现持当缘故

释曰。此偈有三种作意。一喜集作意。二见义作意。三乐求作意。菩萨知已。次作是念。我应欢喜聚集福智二聚。是名喜集作意。次作是念。我今见诸波罗蜜自性。能得无上菩提利益。是名见义作意。次作是念。今见是利应起四求。一求平等。止观双修故。二求无分别。三轮清净故。三求现持。求持能成诸度法义故。四求当缘。求未来成就诸度缘故。是名乐求作意。偈曰

  七非有取见　　四种希有想
  翻此非希有　　此想亦有四

释曰。此偈有三种作意。一见非有取作意。二希有想作意。三非希有想作意。菩萨乐求已。次作是念。七种非有取。我今应见。一非有为有非有取。二过失非失非有取。三功德非德非有取。四非常为常非有取。五非乐为乐非有取。六非我为我非有取。七寂灭非灭非有取。如来为对治此七非有取。次第说空等三三昧。及说四种法优陀那。是名见非有取作意。次作是念。我今于诸波罗蜜。应起四种希有想。所谓大想广想不求报恩想不期果报想。是名希有想作意。次作是念。翻此希有于诸波罗蜜亦有四种非希有想。所谓由诸波罗蜜广大故。能得无上菩提。能住自他平等。能不求一切世间供养。能不求过诸世间胜身胜财。是名非希有想作意。偈曰

  离堕众生边　　大义及转施
  究竟与无间　　如是复五种

释曰。此偈有五种作意。一离边作意。二大义作意。三转施作意。四究竟作意。五无间作意。菩萨次作是念。我今应以诸波罗蜜于一切众生转。是名离边作意。次作是念。我今应以诸波罗蜜广饶益一切众生。是名大义作意。次作是念。我今所有诸波罗蜜功德愿施一切众生。是名转施作意。次作是念。愿一切众生所有诸波罗蜜三处究竟。谓菩萨地究竟。如来地究竟。利益众生究竟。是名究竟作意。次作是念。我应修习诸波罗蜜于一切时无有间断。是名无间作意。偈曰

  方便恒随摄　　心住不颠倒
  于退则不喜　　进则欢喜生

释曰。此偈有三种作意。一随摄作意。二不喜作意。三欢喜作意。菩萨次作是念。我今应住不颠倒心于佛所知应以诸波罗蜜恒时随摄。是名随摄作意。次作是念。我今于退屈诸波罗蜜者不应生悦。是名不喜作意。次作是念。我今于增进诸波罗蜜者应生庆悦。是名欢喜作意。偈曰

  相似不欲修　　真实欲修习
  不随及欲得　　欲得有二种

释曰。此偈有四种作意。一不欲修作意。二欲修作意。三不随作意。四欲得作意。菩萨次作是念。我今于相似诸波罗蜜不应修习。是名不欲修作意。次作是念。我今于真实诸波罗蜜应勤修习。是名欲修作意。次作是念。我今于诸波罗蜜障碍作意应断。是名不随作意。次作是念。我今欲得授记位诸波罗蜜。欲得决定地诸波罗蜜。是名欲得作意。偈曰

  定作未来行　　常观他行满
  信解自第一　　知体无上故

释曰。此偈有三种作意。一定作作意。二观他作意。三我胜作意。菩萨次作是念。我见当来诸趣以智方便一切波罗蜜决定当行。是名定作作意。次作是念。我今应观十方诸大菩萨诸波罗蜜得满足时愿我亦得满足。同一事故。是名观他作意。次作是念。我今自信所行诸波罗蜜。于诸行中最为第一。何以故。我观此体更无上故。是名我胜作意。偈曰

  以此诸作意　　修习于诸度
  菩萨一切时　　善根得圆满

释曰。此偈总结前义应知。已说求长养善根。次说求法差别。偈曰

  求法谓增长　　上意及广大
  有障亦无障　　及以诸神通
  无身亦有身　　得身及满身
  多慢及少慢　　及以无慢故

释曰。求法有十三种差别。一者增长求。谓以正闻增长信故。二者上意求。谓在佛边受法流故。三者广大求。谓得神通菩萨具足远闻诸佛法故。四者有障求。谓初增长信者故。五者无障求。谓上意求者故。六者神通求。谓广大求者故。七者无身求。谓闻思慧无法身故。八者有身求。谓修慧有多闻熏习种子身故。九者得身求。谓初地至七地。十者满身求。谓八九十地。十一者多慢求。谓信行地。十二者少慢求。谓初七地。十三者无慢求。谓后三地。已说求法差别。次说求法因缘。偈曰

  为色为非色　　为通为正法
  相好及病愈　　自在无尽因

释曰。求法有四因缘。一为色。二为非色。三为神通。四为正法。为色者。相好因故。为非色者。灭烦恼病因故。为神通者。自在因故。为正法者。无尽因故。如梵天王问经说。菩萨求法具足四想。一者如妙宝想。难得义故。二者如良药想。除病义故。三者如财物想。不散义故。四者如涅槃想。苦灭义故。由法是相好庄严因故如妙宝想。由法是灭烦恼病因故如良药想。由法是神通自在因故如财物想。由法是正法无尽因故如涅槃想。已说求法因缘。次说求远离分别。偈曰

  无体体增减　　一异自别相
  如名如义者　　分别有十种

释曰。有十种分别。一者无体分别。二者有体分别。三者增益分别。四者损减分别。五者一相分别。六者异相分别。七者自相分别。八者别相分别。九者如名起义分别。十者如义起名分别。般若波罗蜜经中为令诸菩萨远离此十种分别故说十种对治。为对治无体分别故。经言有菩萨菩萨。为对治有体分别故。经言不见菩萨等。为对治增益分别故。经言舍利弗色自性空。为对治损减分别故。经言非色灭空。为对治一相分别故。经言若色空非色。为对治异相分别故。经言空不异色色不异空空即是色。为对治自相分别故。经言此色唯名。为对治别相分别故。经言色不生不灭非染非净等。为对治如名起义分别故。经言名者作客故如名义不应着。为对治如义起名分别故。经言一切名不可见不可见故如义名不应着。已说求远离分别。次说求法大偈曰

  菩萨胜勇猛　　二求得真实
  随顺诸世间　　功德如海满

释曰。求法有三种大。一者方便大。由最上精进求世谛第一义谛。真实不颠倒故。二者他利大。由作世间依怙以第一义安置故。三者自利大。由一切功德如海满足故。述求品究竟

大乘庄严经论卷第五大乘庄严经论卷第六

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    弘法品第十三

释曰。已说求法。次应以法为人演说。偈曰

  难得复不坚　　愍苦恒喜施
  况以法利世　　增长亦无尽

释曰。此偈先遮法悭。难得复不坚者。谓身命财。愍苦恒喜施者。菩萨尚能于一切时舍此三种不坚之法施诸苦厄众生。由慈悲故。况以法利世增长亦无尽者。何况大法得之不难而生悭吝。是故菩萨应以此法广利世间。何以故。法得增长亦无尽故。已遮法悭。次说利益。偈曰

  自证不可说　　引物说法性
  法身寂灭口　　悲流如蟒吸

释曰。自证不可说引物说法性者。世尊不说自所证法。由不可说故。为引接众生复以方便而说法性问云何方便。答法身寂灭口悲流如蟒吸。诸佛以法性为身。寂灭为口。极广清净离二障故。以大慈悲流出教网引接众生。譬如大蟒张口吐涎吸引诸物。一切诸佛身口悲同引接亦尔。大悲无尽由毕竟故。偈曰

  彼修得果故　　修说非无义
  但闻及不闻　　修说则无理

释曰。彼修得果故修说非无义者。诸佛以方便说自所证引接世间。由能行者修力自在而得果故。是故彼修及佛所说得非无义。但闻及不闻修说则无理者。若但闻法得见真义。彼修则无利益。若不闻法得入于修。彼说则无利益。已说说法利益。次说说法差别。偈曰

  阿含说证说　　谓口谓通力
  通力谓相好　　余色及虚空

释曰。诸菩萨说法有二种差别。一者阿含说。谓以口力而说。二者证说。谓以通力而说。通力说复有多种。或相好说。或树林说。或乐器说。或空中说。已说说法差别。次说说法成就。偈曰

  无畏及断疑　　令信亦显实
  如此诸菩萨　　说成就应知

释曰。诸菩萨说法成就由四种义。一者无畏。二者断疑。三者令信。四者显实。如梵天王问经说。菩萨四法具足则能开于广大法施。何等为四。一者摄治妙法。二者自慧明净。三者作善丈夫业。四者显示染净。此中第一多闻故得无畏。第二大慧故能断疑。第三不依名利故令他信受。第四由通达世谛第一义谛故能显二种真实。谓染相真实净相真实。偈曰

  美语及离醉　　无退无不尽
  种种及相应　　令解非求利
  及以遍教授　　复次成就说

释曰。美语者。他嗔骂时不恶报故。离醉者。醉有二种。一他称赞时醉。二自成就时醉。谓家色财等成就生爱喜故。离者如此二醉于心灭故。无退者。不懈怠故。无不尽者。离于法悭一切说故。种种者。不重说故。相应者。不违现比量故。令解者。字句可解故。非求利者。不为财利令彼信故。遍教授者。被三乘故。已说说法成就。次说语成就。偈曰

  不细及调和　　善巧亦明了
  应机亦离求　　分量与无尽

释曰。不细者。遍徒众故。调和者。悦可意故。善巧者。开示字句分明故。明了者。令易解故。应机者。随宜说故。离求者。不依名利说故。分量者。乐闻无厌故。无尽者。不可穷故。已说语成就。次说字成就。偈曰

  举名及释义　　随乘亦柔软
  易解而应机　　出离随顺故

释曰。举名者。相应诸字句不违验故。释义者。释言诸字句不违理故。随乘者。随乘诸字句不违三乘故。柔软者。离难诸字句不违于声故。易解者。聚集诸字句得义易故。应机者。应物诸字句逗机宜故。出离者。不在诸字句向涅槃故。随顺者。正行诸字句随顺八支圣道故。偈曰

  菩萨字成就　　如前义应知
  声有六十种　　是说如来事

释曰。如来有六十种不可思议音声。如佛秘密经中说。寂静慧如来具足六十种声语。所谓润泽柔软可意意乐清净。如是广说。此中润泽声者。众生善根能持摄故。柔软声者。现前闻法得乐触故。可意声者。由善义故。意乐声者。由善字故。清净声者。无上出世后得故。无垢声者。诸惑习气不相应故。明亮声者。字句易解故。善力声者。具足功德破诸外道恶邪见故。乐闻声者。信顺出离故。不绝声者。一切外道无能断故。调伏声者。贪等烦恼能对治故。无刺声者。制戒乐方便故。不涩声者。令犯戒人得正出故。善调声者。教化教授故。悦耳声者。乱心对治故。身倚声者。能引三摩提故。心了声者。能引毗钵舍那故。心喜声者。善断疑故。喜乐生声者。决定拔邪故。无热恼声者。信受不悔故。能持智声者。成就闻因智依止故。能持解声者。成就思因智依止故。不隐覆声者。不悭法而说故。可爱声者。令得自利果故。渴仰声者。已得果人深愿乐故。教敕声者。不思议法正说故。令解声者。思议法正说故。相应声者。不违验故。有益声者。如其所应教示导故。离重声者。不虚说故。师子声者。怖外道故。象声者。振大故。雷声者。深远故。龙声者。令信受故紧那罗声者。歌音美故。迦陵频伽声者。韵清亮故。梵声者。出远去故。命命鸟声者。初得吉祥一切事成故。天王声者。无敢违故天鼓声者。破魔初故离慢声者。赞毁不高故。入一切声者。入毗伽罗论一切种相故。离不正声者。忆不忘故。应时声者。教化事一切时起故。无羞声者。不依利养故。不怖声者。离惭羞故。欢喜声者。闻无厌故。随舍声者。一切明处善巧入故。善友声者。一切众生利成就故。常流声者。相续不断故。严饰声者种种显现故。满足声者。一音无量声说法故。众生根喜声者。一语无量义显现故。不毁呰声者。如所立义信顺故。不增减声者。应时量说故。不躁急声者。不疾疾说故。遍一切声者。远近徒众同依止故。一切种成就声者。世间法义皆譬喻令解故。已说字成就。次说说法大。偈曰

  开演及施设　　建立并总举
  别说与断疑　　略广皆令解

释曰。开演者。谓言说也。施设者。谓诸句也。建立者谓善相应也。如是分别开示。如其次第总举别说。断疑使义浅近易解。令听受者于所说法得决定故。略者一说。彼利根人速得解故。广者重说。彼钝根人迟得解故。偈曰

  说者及所说　　受者三轮净
  复离八种过　　说者净应知

释曰。说者及所说受者三轮净者。何等三轮一是说者。谓诸佛菩萨。二是所说。谓总说名字等诸种。三是受者。谓前略说得解人广说得解人。复离八种过说者净应知者。说者清净。应知复离八种过失。问何者八耶。偈曰

  懈怠及不解　　拒请不开义
  及以不断疑　　断疑不坚固
  厌退及有吝　　如是八种过
  诸佛无彼体　　故成无上说

释曰。八种过者。一懈怠。二不解义。三拒请。四不开义。五不断疑。六断疑不决定。七心有厌退不一切时说故。八有吝。不尽开示故。一切诸佛如是八过悉皆远离。是故得成无上说法。已说说法大。次说义成就偈曰

  此法随时善　　生信喜觉因
  义正及语巧　　能开四梵行

释曰。此法随时善生信喜觉因者。随时善谓初中后善。如其次第。闻思修时为信因故。为喜因故。为觉因故。为觉因者。定心观察此法道理得如实智故。义正及语巧能开四梵行者。义正谓善义及妙义。与世谛第一义谛相应故。语巧谓易受及易解由文显义现故。由此故能开示四种梵行。问何者四耶。偈曰

  不共他相应　　具断三界惑
  自性及无垢　　是行为四种

释曰。四梵行者。一者独。二者满。三者清。四者白。不共他相应者是独义。由此行不共外道同行故。具断三界惑者是满义。由此行具断三界烦恼故。自性者是清义。由此行是无漏自性净故。无垢者是白义。由此行在漏尽身种类得无垢净故。已说说法义成就。次说说法节。偈曰

  所谓令入节　　相节对治节
  及以秘密节　　是名为四节

释曰。诸佛说法不离四节。一者令入节。二者相节。三者对治节。四者秘密节。间此四节依何义。偈曰

  声闻及自性　　断过亦语深
  次第依四义　　说节有四种

释曰。令入节者。应知教诸声闻入于法义令得不怖。说色等是有故。相节者。应知于分别等三种自性。无体无起自性清净。说一切法故。对治节者应知依断诸过对治八种障故。如大乘中说。受持二偈得尔所功德。皆为对治故说。此对治后当解。秘密节者。应知依诸深语由回语方得义故。如大乘经偈说。不坚坚固解善住于颠倒。为烦恼所恼。速得大菩提。此节中不坚坚固解者。不坚谓诸众生其心不乱。于此不乱作坚固解。此解最胜能得菩提。乱者心驰坚着。不能至得菩提故。此是第一句义。善住于颠倒者。颠倒谓常乐我净执。若人能于颠倒中解无常无乐无我无净善住不退。即能速得菩提。不尔不得故。此是第二句义。为烦恼所恼者。长时勤修难行苦行由极疲倦能得菩提。不尔不得故。此是第三句义。已说说法节。次说说法意。偈曰

  平等及别义　　别时及别欲
  依此四种意　　诸佛说应知

释曰。诸佛说法不离四意。一平等意。二别义意。三别时意。四别欲意。平等意者。如佛说。往昔毗婆尸佛即我身是。由法身无差别故。如是等说。是名平等意。别义意者。如佛说。一切诸法无自性故无生故。如是等说。是名别义意。别时意者。如佛说。若人愿见阿弥陀佛。一切皆得往生。此由别时得生故如是说。如是等说。是名别时意。别欲意者。彼人有如是善根。如来或时赞叹或时毁呰。由得少善根便为足故。如是等说是。名别欲意。已说说法意。次说受持大乘功德。偈曰

  轻佛及轻法　　懈怠少知足
  贪行及慢行　　悔行不定等
  如是八种障　　大乘说对治
  如是诸障断　　是人入正法

释曰。此二偈显示大乘断障功德。障有八种。一者轻佛障。二者轻法障。三者懈怠障。四者少知足障。五者贪行障。六者慢行障。七者悔行障。八者不定障。为对治轻佛障故。大乘经说。往昔毗婆尸佛即我身是。为对治轻法障故。大乘经说。于无量恒河沙佛所。修行大乘乃得生解。为对治懈怠障故大乘经说若有众生愿生安乐国土。一切当得往生。称念无垢月光佛名。决定当得作佛。为对治少知足障故。大乘经说有处赞叹檀等行。有处毁呰檀等行。为对治贪行障故。大乘经说。诸佛国土极妙乐事。为对治慢行障故。大乘经说。或有佛土最胜成就。为对治悔行障故。大乘经说。或有众生于佛菩萨起不饶益事得生善道。为对治不定障故。大乘经说。诸佛授记声闻当得作佛及说一乘。是名受持大乘得离八障。偈曰

  若文及若义　　二偈勤受持
  功德数有十　　是名胜慧者
  善种得圆满　　死时欢喜胜
  受生随所欲　　念生智亦成
  生生恒值佛　　闻法得信慧
  远离于二障　　速成无上道

释曰。此三偈显示受持大乘集得功德。此功德有十种。一者成就一切善根种子圆满依止。二者临命终时得无上喜悦。三者于一切处得随愿受生。四者于一切生处得自性念生智。五者所生之处恒得值佛。六者恒在佛边闻大乘法。七者成就增上信根。八者成就增上慧根。九者得远离惑智二障。十者速得成就无上菩提。若人于一切大乘经典。若文若义乃至一句。正勤受持。则得如是十种功德。此中应知。于现在世得初二种功德。于未来世得余八种功德。渐渐增胜。已说持法功德。次说说法功德。偈曰

  慧善及不退　　大悲名称远
  巧便说诸法　　如日朗世间

释曰。若诸菩萨具足五因名善说法。一者不倒说。由慧善故。二者恒时说。由不退故。三者离求说。由大悲故。四者令信说。由名称远故。五者随机说由巧便故。由此五因能善说法。导引众生多生恭敬。譬如日出照朗世间。弘法品究竟

    大乘庄严经论随修品第十四

释曰。已说菩萨弘法。次说菩萨随法修行。此中随修有知义有知法有随法有同得有随行。今当次第显示。偈曰

  于二知无我　　于三离邪正
  菩萨如是解　　是名知义人

释曰。此偈明菩萨知义。于二知无我者。谓于人法二种而知无我。由知能取所取无有体故。于三离邪正者。三谓三种三昧。即空无相无愿。由空三昧知无有体。解分别性故。由无相无愿三昧知无自体。由解依他真实性故。离邪正者。此三三昧引出世智故不邪。是世间故不正。菩萨如是解。是名知义人者。菩萨若知人法二种无我。能知三种三昧。离邪离正。如此则名知义。偈曰

  如是知义已　　知法犹如筏
  闻法不应喜　　舍法名知法

释曰。此偈明菩萨知法。初学菩萨得知义已。次应知法。谓能知修多罗等经法。犹如筏喻。不得但闻而生欢喜。何以故是法应舍。譬如筏故。是名知法。偈曰

  凡夫有二智　　即通二无我
  为成彼智故　　如说随法行

释曰。此偈明菩萨随法。凡夫有二智者。谓知义智知法智。即通二无我者。由此二智故亦能通达人法二种无我。为成彼智故。如说随法行者。菩萨为成就彼二种智。应如所说法随顺修行。是名随法。偈曰

  成就彼智时　　出世间无上
  凡住初地者　　所得皆同得

释曰。此偈明菩萨同得。成就彼智时出世间无上者。由彼智体最胜故。初地谓欢喜地。一切住欢喜地菩萨所得功德。彼初入地人亦皆同得故。偈曰

  见道所灭惑　　应知一切尽
  随次修余地　　为断智障故
  应知诸地中　　无分别建立
  次第无间起　　如是说随行

释曰。此二偈明菩萨随行。此中见道所灭烦恼。入初地时一切悉尽。是故修习余地但为断于智障。然于诸地各有二智。一无分别智。二地建立智菩萨若在正观。于刹那刹那得尔所法而不分别。是名无分别智。菩萨出观后。分别观中所得法如是如是分数。是名地建立智。如此二智不得并起及间余法起。恒无间行。是名菩萨随行。菩萨能如是随行有四种不放逸轮。一者胜土论。二者善人轮。三者自正轮。四者先福轮。如此四轮今当次第说。偈曰

  易求及善护　　善地亦善伴
  善寂此胜土　　菩萨则往生

释曰。此偈明胜土轮。土胜有五因缘。一者易求。谓四事供身不难得故。二者善护。谓国王如法恶人盗贼不得住故。三者善地。处所调和无疫疠故。四者善伴。谓同戒同见为伴侣故。五者善寂。谓昼日无喧夜绝声故。偈曰

  多闻及见谛　　巧说亦怜愍
  不退此丈夫　　菩萨胜依止

释曰。此偈明善人轮。善人亦具五因缘。一者多闻。成就阿含故。二者见谛。得圣果故。三者巧说能分别法故。四者怜愍。不贪利故。五者不退。无疲倦故。偈曰

  善缘及善聚　　善修及善说
  善出此五种　　是名自正胜

释曰。此偈明自正轮。自正亦具五因缘。一者善缘。妙法为缘故。二者善聚。福智具足故。三者善修。止观诸相应时修故。四者善说。无求利故。五者善出。所有上法恭敬修故。偈曰

  可乐及无难　　无病与寂静
  观察此五种　　宿植善根故

释曰。此偈明先福轮。先福亦具五因缘。一者可乐。二者无难。三者无病。四者三昧。五者智慧。第一事由住胜土为因。第二事由值善人为因。后三事由自正成就为因。已说四种不放逸轮。次说烦恼出烦恼。偈曰

  远离于法界　　无别有贪法
  是故诸佛说　　贪出贪余尔

释曰。如佛先说。我不说有异贪之法。能出于贪嗔痴亦尔。由离法界则别无体故。是故贪等法性得贪等名。此说贪等法性能出贪等。此义是经旨趣。偈曰

  由离法性外　　无别有诸法
  是故如是说　　烦恼即菩提

释曰。如经中说。无明与菩提同一。此谓无明法性施设菩提名。此义是经旨趣。偈曰

  于贪起正思　　于贪得解脱
  故说贪出贪　　嗔痴出亦尔

释曰。若人于贪起正思观察。如是知已于贪即得解脱。故说以贪出离于贪。出离嗔痴亦复如是。已说烦恼出烦恼。次说远离二乘心。偈曰

  菩萨处地狱　　为物不辞苦
  舍有发小心　　此苦则为剧

释曰。菩萨慈悲为诸众生入大地狱不辞大苦。若灭三有功德起小乘心。菩萨以此为苦。最为深重。问此义云何。偈曰

  虽恒处地狱　　不障大菩提
  若起自利心　　是大菩提障

释曰。菩萨虽为众生长时入大地狱不以为苦。何以故。于广净菩提不为障故。若起异乘乐涅槃心。即为大苦。何以故。于大乘乐住而为障故。此偈显前偈义应知。已说遮二乘心。次说遮怖畏心。偈曰

  无体及可得　　此事犹如幻
  性净与无垢　　此事则如空

释曰。无体及可得此事犹如幻者。一切诸法无有自性。故曰无体。而复见有相貌显现。故曰可得。诸凡夫人于此二处互生怖畏。此不应尔。何以故。幻相似故。譬如幻等实无有体而显现可见。诸法无体可得亦尔。是故于此二处不应怖畏。性净与无垢此事则如空者。法界本来清净。故曰性净。后时离尘清净。故曰无垢。诸凡夫人于此二处互生怖畏。此不应尔。何以故。空相似故。譬如虚空本性清净。后时亦说离尘清净。法界性净及以无垢亦复如是。是故于此二处不应怖畏。复次更有似画譬喻。能遮前二怖畏。偈曰

  譬如工画师　　画平起凹凸
  如是虚分别　　于无见能所

释曰。譬如善巧画师能画平壁起凹凸相。实无高下而见高下。不真分别亦复如是。于平等法界无二相处。而常见有能所二相。是故不应怖畏。此中复有似水譬喻。能遮后二怖畏。偈曰

  譬如清水浊　　秽除还本清
  自心净亦尔　　唯离客尘故

释曰。譬如清水垢来则浊。后时若清唯除垢耳。清非外来本性清故心方便净亦复如是。心性本净客尘故染。后时清净除客尘耳。净非外来本性净故。是故不应怖畏。偈曰

  已说心性净　　而为客尘染
  不离心真如　　别有心性净

释曰。譬如水性自清而为客垢所浊。如是心性自净而为客尘所染。此义已成。由是义故。不离心之真如别有异心。谓依他相说为自性清净。此中应知。说心真如名之为心。即说此心为自性清净。此心即是阿摩罗识。已遮怖畏。次遮贪罪。偈曰

  菩萨念众生　　爱之彻骨髓
  恒时欲利益　　犹如一子故

释曰。诸菩萨爱诸众生。此名为贪。余如偈说。偈曰

  由利群生意　　起贪不得罪
  嗔则与彼违　　恒欲损他故

释曰。若谓菩萨爱诸众生起贪名罪者。此义不然。何以故。此贪恒作利益众生因故。偈曰

  如鸽于自子　　普覆生极爱
  如是有悲人　　于生爱亦尔

释曰。譬如鸽鸟多贪爱念诸子最得增上。如是菩萨多悲爱诸众生。增上亦尔。偈曰

  慈与嗔心违　　息苦苦心反
  利则违无利　　无畏违畏心

释曰。菩萨于诸众生由得慈心故。与嗔心相违。由得息苦心故。与作苦心相违。由得利益心故。与无利心相违。由得无畏心故。与作畏心相违。是故菩萨起如是贪不得名罪。已遮贪罪。次说修行差别。偈曰

  善行于生死　　如病服苦药
  善行于众生　　如医近病者
  善行于自心　　如调未成奴
  善行于欲尘　　如商善贩卖
  善行于三业　　如人善浣衣
  善行不恼他　　如父于爱子
  善行于修习　　如钻火不息
  善行于三昧　　如财与信人
  善行于般若　　如幻师知幻
  是名诸菩萨　　善行诸境界

释曰。诸菩萨修行有九种差别。一者善行生死。譬如病久服苦涩药。但为差病不生贪染。菩萨亦尔。亲近生死但为思惟策励。非为染着。二者善行众生。譬如良医亲近病者。菩萨亦尔。有大悲故不舍烦恼病苦众生。三者善行自心。譬如有智之主善能调服未成就奴。菩萨亦尔。善能调伏未调伏心。四者善行欲尘。譬如商人善于贩卖。菩萨亦尔。于檀等诸度增长资财。五者善行三业。譬如善浣衣师能除秽垢。菩萨亦尔。修治三业能令清净。六者善行不恼众生。譬如慈父爱于小儿虽秽不恶。菩萨亦尔。众生加损未尝嗔恼。七者善行修习。譬如钻火未热不息。菩萨亦尔。修习善法曾无间心。八者善行三昧。譬如出财得保信人日日滋益。菩萨亦尔。修习诸定不乱不味功德增长。九者善行般若。譬如幻师知幻非实。菩萨亦尔。于所观法得不颠倒。是名菩萨修行差别。已说修行差别。次说三轮清净。偈曰

  常勤大精进　　熟二令清净
  净觉无分别　　渐渐得菩提

释曰。常勤大精进熟二令清净者。菩萨以大精进力勤行自他二利。是故众生及自并得成熟。是名清净。净觉无分别渐渐得菩提者。净觉谓法无我智。此智不分别三轮。谓修者所修正修。故得清净。由此净故渐渐得成无上菩提。随修品究竟

大乘庄严经论卷第六大乘庄严经论卷第七

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    教授品第十五

释曰。已说菩萨随修。次说如来教授。偈曰

  行尽一僧祇　　长信令增上
  众善随信集　　亦具如海满

释曰。行尽一僧祇长信令增上者。若诸菩萨行行尽一阿僧祇劫。尔时长养于信方至上品。问独信增耶。答众善随信集亦具如海满。谓于信增时一切众善随信聚集。亦得具足如大海水湛然圆满。偈曰

  聚集福德已　　佛子最初净
  极智及软心　　勤修诸正行

释曰。聚集福德已者。如前所说聚集故。佛子最初净者。令护清净故。及于大乘作正直见。不颠倒受义故。极智者。得多闻故。软心者。离诸障故。勤修诸正行者。有堪能故。偈曰

  自后蒙诸佛　　法流而教授
  增益寂静智　　进趣广大乘

释曰。自后蒙诸佛法流而教授者。此诸菩萨从此已后。蒙诸佛如来以修多罗等法而为说之。譬如为说十地经。增益寂静智进趣广大乘者。此菩萨若得教授则增益奢摩他智。于广大乘而能进修。如是得教授已。次起六种心。偈曰

  想名及了句　　思义亦义知
  法总亦义求　　六心次第起

释曰。六心者。一根本心。二随行心。三观察心。四实解心。五总聚心。六悕望心。想名者。谓根本心。初于修多罗等法观察无有二义。唯想名聚故。了句者。谓随行心。次随诸句决了差别及次第故。思义者。谓观察心。次于彼义内正思惟故。义知者。谓实解心。于彼思义如实知故。法总者谓总聚心。更聚前法复总观故。义求者。谓悕望心。于彼义趣求得意故。如是起六心已。次起十一种作意。偈曰

  有求亦有观　　一味将止道
  观道及二俱　　拔沈并抑掉
  正住与无间　　于中亦尊重
  置心一切缘　　作意有十一

释曰。十一种作意者。一有觉有观作意。二无觉有观作意。三无觉无观作意。四奢摩他作意。五毗钵舍那作意。六二相应作意。七起相作意。八摄相作意。九舍相作意。十恒修作意。十一恭敬作意。有求者。谓有觉有观作意。此作意以意言相续观察诸法。有观者谓无觉有观作意。此作意虽离于觉亦以意言相续观察诸法。一味者。谓无觉无观作意。此作意离于意言而相续观察诸法。止道者。谓奢摩他作意。此作意但缘诸法名。观道者。谓毗钵舍那作意。此作意但缘诸法义。二俱者。谓二相应作意。此作意能一时缘名义拔沈者。谓起相作意。此作意若缘名心沈即能策起。抑掉者。谓摄相作意。此作意若缘义心散即能摄持。正住者。谓舍相作意。此作意若心平等能住舍心。无间者。谓恒修作意。此作意能依正住修习无废。尊重者。谓恭敬作意。能于习时尊重名义。如是起十一种作意已。复应修习九种住心。偈曰

  系缘将速摄　　内略及乐住
  调厌与息乱　　或起灭亦尔
  所作心自流　　尔时得无作
  菩萨复应习　　如此九住心

释曰。九种住心者。一安住心。二摄住心。三解住心。四转住心。五伏住心。六息住心。七灭住心。八性住心。九持住心。此九住教授方便。应知系缘者。谓安住心。安心所缘不令离故。速摄者。谓摄住心。若觉心乱速摄持故。内略者。谓解住心。觉心外广更内略故。乐住者。谓转住心。见定功德转乐住故。调厌者。谓伏住心。心若不乐应折伏故。息乱者。谓息住心。见乱过失令止息故。或起灭亦尔者。谓灭住心。贪忧等起即令灭故。所作心自流者。谓性住心。所作任运成自性故。尔时得无作者。谓持住心。不由作意得总持故。如是修习得住心已。次令此心得最上柔软。偈曰

  下倚修令进　　为进习本定
  净禅为通故　　当成胜软心

释曰。下倚修令进为进习本定者。菩萨得住心时。应知已得下品身倚心倚。为增进此倚更修根本禅定。问更修本定为何功德。答净禅为通故当成胜软心。诸菩萨为起诸神通故。为欲成就最胜柔软心故。是故进修本定。问起诸神通欲何所作。胜柔软心复云何成。偈曰

  起通游诸界　　历事诸世尊
  最上软心得　　供养诸佛故

释曰。起通游诸界历事诸世尊者。诸菩萨欲往无量世界。欲经无量劫数。欲历无量诸佛。欲承事供养及闻正法。为此事故起诸神通。问何故作此事。答最上软心得供养诸佛故。由供养诸佛为因故。更得成就第一胜柔软心。如是得胜心已。便得诸佛之所称扬。偈曰

  未入净心前　　五种称扬得
  器体成净故　　堪进无上乘

释曰。未入净心前五种称扬得者。谓此菩萨于净心地前。先得如来称扬。其五种功德问此称扬于菩萨有何利益。答器体成净故堪进无上乘。此菩萨得如来称扬已。便成就清净器体。于无上乘则堪进入。问如来称扬彼菩萨。何等五功德。偈曰

  念念融诸习　　身倚及心倚
  圆明与见相　　满净诸法身

释曰。五功德者。一者融习。二者身倚。三者心倚。四者圆明。五者见相。融习者。一一刹那消融一切习气聚故。身倚者。修习轻安遍满身故。心倚亦尔。圆明者。圆解一切种空离分数故。见相者。见无分别相为后清净因故。满净诸法身者。为满为净一切种法身。常作如是五因故。问何时满何时净。答十地时满。佛地时净。此中应知五种功德。前三是奢摩他分。后二是毗钵舍那分。菩萨于此时中于世间法皆得具足。如是得称扬已。次起通达分善根。偈曰

  尔时此菩萨　　次第得定心
  唯见意言故　　不见一切义

释曰。此菩萨初得定心离于意言。不见自相总相一切诸义。唯见意言。此见即是菩萨暖位。此位名明。如佛灰河经中所说明。此明名见法忍。偈曰

  为长法明故　　坚固精进起
  法明增长已　　通达唯心住

释曰。此中菩萨为增长法明故起坚固精进。住是法明通达唯心。此通达即是菩萨顶位。偈曰

  诸义悉是光　　由见唯心故
  得断所执乱　　是则住于忍

释曰。此中菩萨若见诸义悉是心光。非心光外别有异见。尔时得所执乱灭。此见即是菩萨忍位。偈曰

  所执乱虽断　　尚余能执故
  断此复速证　　无间三摩提

释曰。此中菩萨为断能执乱故。复速证无间三摩提。问有何义故此三摩提名无间。答由能执乱灭时尔时入无间。故受此名。此入无间即是菩萨世间第一法位。随其次第说暖等诸位已。次说见道起。偈曰

  远离彼二执　　出世间无上
  无分别离垢　　此智此时得

释曰。远离彼二执者。所执能执不和合故。出世间无上者。得无上乘故。无分别者。即彼二执分别无故。离垢者。见道所断烦恼灭故。菩萨尔时名远尘离垢得法眼净。偈曰

  此即是转依　　以得初地故
  后经无量劫　　依净方圆满

释曰。此即是转依以得初地故者此离垢。即是菩萨转依位。何以故。得初地故。问依极净耶。答后经无量劫依净方圆满。非于此初即得极清净。由后经无量阿僧祇劫。此依方得清净圆满故。偈曰

  尔时通法界　　他自心平等
  平等有五种　　五无差别故

释曰。尔时通法界他自心平等者。菩萨于初地即得通达平等法界。由此通达故能观他身即是自身。亦得心平等。问此时得几种心平等。答平等有五种。五无差别故。何谓为五。一者无我平等。谓于自他相续不见有我。无差别故。二者有苦平等。谓于自他相续所有诸苦。无差别故。三者所作平等。谓于自他相续欲作断苦。无差别故。四者不求平等。谓于自他所作不求反报。无差别故。五者同得平等。如余菩萨所得我得亦尔。无差别故。偈曰

  诸行虚分别　　净智了无二
  解脱见所灭　　如是说见道

释曰。诸行虚分别净智了无二者。此中菩萨于三界诸行唯见不真分别。以极净智了彼无二。净智者。出世间故。无二者。二执无故。彼无二体即法界也。解脱见所灭如是说见道者。谓解脱见道所灭烦恼。法界即是解脱。若见解脱灭烦恼时。说名菩萨初得见道。偈曰

  无体及似体　　自性合三空
  于此三空解　　此说名解空

释曰。三空者。一无体空。谓分别性。彼相无体故。二似体空。谓依他性。此相如分别性无体故。三自性空。谓真实性。自体空自体故。此偈显菩萨得空解脱门。偈曰

  应知缘无相　　悉尽诸分别
  此中无愿缘　　不真分别尽

释曰。此偈上半显得无相解脱门。下半显得无愿解脱门。应知此中菩萨具得三解脱门。偈曰

  此时所得法　　一切菩提分
  应知彼菩萨　　同得如见道

释曰。一切菩提分者。谓四念处等。彼菩萨得见道时亦得此法。偈曰

  觉世唯诸行　　无我唯苦着
  无义自我灭　　大义依大我

释曰。觉世唯诸行无我唯苦著者。此菩萨觉诸世间但是诸行实无有我。众生计着唯着苦耳。无义自我灭者。谓染污身见灭故。大义者。利益一切众生故。大我者。以一切众生为自己故。此中菩萨灭自我见。依大我见作众生利益事。是谓大义依大我。偈曰

  无我复我见　　无苦亦极苦
  益彼不求报　　以利自我故

释曰。此中诸菩萨。无我者。谓无自身无义我见。复我见者。谓有他身大义我见。无苦者。谓无自身所起诸苦。亦极苦者。谓有他身所起诸苦。益彼不求报者。无悕望故。何以故。以利自我故。诸菩萨利益众生时。即是利益自我。是故无外希望。偈曰

  自脱心最上　　他缚即坚广
  苦边不可尽　　如是应勤作

释曰。自脱心者。谓灭自见道所断烦恼故。最上者。此解脱由无上乘故。他缚即坚广者。由一切众生相续所起烦恼故。苦边不可尽者。众生界无边如虚空故。如是应勤作者。众生如是苦。菩萨应为众生断苦。作边作已复作。不应休息故。偈曰

  自苦不自忍　　岂忍他诸苦
  此生及穷生　　翻彼谓菩萨

释曰。众生于一期生苦及穷生死际。不可思议苦无能忍受者。此菩萨翻彼不能忍受。悉能为之忍受故。言翻彼谓菩萨。偈曰

  于他行等爱　　利彼不退转
  希有非希有　　他利自利故

释曰。于他行等爱利彼不退转者。菩萨于一切众生行。平等爱心无有差别。若求乐利益。若行乐利益。若求行时。利益之心无有退转。希有非希有他利自利故者。此不退转事于诸世间希有最上。然此希有亦非希有。何以故。他得益时即是菩萨自得益故。偈曰

  余地说修道　　二智勤修习
  无分别建立　　净法及众生

释曰。余地者。谓后九地。问余地何所修。答二智勤修习。二智者。一无分别智。二如所建立智。无分别智谓出世智。如所建立智谓后得世智。问此二智有何功能。答净法及众生。此中无分别智成熟佛法。是其功能。如所建立智成熟众生是其功能。偈曰

  修位二僧祇　　最后得受职
  入彼金刚定　　破诸分别尽

释曰。修立二僧祇最后得受职者。二僧祇谓第二及第三大劫阿僧祇。最后谓究竟修。于此修位方便受职。问受职已更何所作。答入彼金刚定破诸分别尽。问因何义故名金刚定。答分别随眠此能破故。是故此定名金刚喻。偈曰

  转依究竟净　　成就一切种
  住此所作事　　但为利群生

释曰。转依究竟净者。谓永离一切烦恼障及智障故。成就一切种者。谓得一切种智由无上故。住此所作事者。谓住此位中乃至穷众生生死际。示现成道及现涅槃故。问此事何所为。答但为利群生。如此等事一向但为利益一切众生故。自下次明因大教授得大义利。偈曰

  牟尼尊难见　　常见得大义
  以闻无等法　　净信资养心

释曰。此偈明菩萨因大教授常得现前见佛常闻无等正法。常起极深净信遍满于心。此明初时得大义利。偈曰

  若于教授中　　法门如欲住
  如人拔险难　　佛劝亦如是

释曰。若于教授中法门如欲住者。有诸菩萨于教授时中。或于如来法门。心欲乐住也。如人拔险难佛劝亦如是者。譬如有人堕在深坑。有能捉发悬掷高岸。佛劝亦尔。若彼菩萨乐住寂灭深坑。诸佛如来。强能置之佛果高岸。此明次时得大义利。偈曰

  世间极净眼　　胜觉无分别
  譬如大日出　　除幽朗世间

释曰。若诸菩萨成佛时。永退一切世间法故眼得最极清净。尔时名得无分别胜觉。譬如日轮大出能除幽暗照朗世间。此明毕竟时得大义利。如是广说已。次以一偈总结前义。偈曰

  佛子善集满　　成就极广定
  恒受尊教授　　能穷功德海

释曰。此偈义如文显现。教授品究竟

    大乘庄严经论业伴品第十六

释曰。已说如来大教授。菩萨起业以方便为伴。今当说。偈曰

  譬如大地种　　任持四种物
  如是三种业　　建立一切善

释曰。此偈显示菩萨集起业方便。譬如大地种任持四种物者。何谓四物。一者大海。二者诸山。三者草木。四者众生。是谓四物。如是三种业建立一切善者。海等四物譬一切善法。如是菩萨三业能聚集一切诸善。所谓檀等诸波罗蜜。及一切菩提分法。偈曰

  难行业能行　　应形无量劫
  身口心自性　　拔彼不退转

释曰。此偈显示菩萨救他业方便。难行业能行应形无量劫者。何谓难行业。谓众生欲得小乘出离。菩萨于彼极生大苦。欲令彼转异乘心故。变种种形。于无量世界经无量劫数。而能久受勤苦作种种难行业。身口心自性拔彼不退转者。谓菩萨为拔彼故。虽复处处久受勤苦。三业自性终无退屈。偈曰

  如人怖四害　　深防为自身
  菩萨畏二乘　　护业亦如是

释曰。此偈显示菩萨自护业方便。如人怖四害深防为自身者。何谓四害。一者毒物。二者兵仗。三者恶食。四者怨仇。是谓四害。深防者为利益自身故。菩萨畏二乘护业亦如是者。毒等四害譬二乘人诸业方便。菩萨怖畏此故。深自防护起二乘心。何以故。由断大乘种故。大乘善根未起令不起故。已起复令灭故。及与佛果作障碍故。偈曰

  作者业所作　　三轮不分别
  得度净业海　　功德无有边

释曰。此偈显示菩萨清净业方便。作者业所作三轮不分别者。何谓三轮。一者作者。二者业。三者所作。是谓三轮。不分别者。此三不可得故。由此故三轮得清净。三轮清净故业清净。得度净业海功德无有边者。到业彼岸故。功德无边者由无尽故。业伴品究竟

    大乘庄严经论度摄品第十七之一

释曰。已说起业方便业所聚集诸波罗蜜。今当说。此中先说忧陀那偈。偈曰

  数相次第名　　修习差别摄
  治障德互显　　度十义应知

释曰。此中六波罗蜜应知有十种义。一制数。二显相。三次第。四释名。五修习。六差别。七摄行。八治障。九功德。十互显。此中有六偈制立六波罗蜜数唯有六。偈曰

  资生身眷属　　发起初四成
  第五惑不染　　第六业不倒

释曰。此偈显示为摄自利三事故。立波罗蜜数唯有六。一者增进。二者不染。三者不倒。彼初四波罗蜜。如其次第能令四事增进。一资生成就。由布施故。二自身成就。由持戒故。三眷属成就。由于忍辱。行忍辱者多人爱故。四发起成就。由于精进。一切事业因此成故。第五禅波罗蜜。能令烦恼不染。折伏烦恼由此力故。第六般若波罗蜜。令业不颠倒。一切所作如实知故。偈曰

  施彼及不恼　　忍恼是利他
  有因及心住　　解脱是自利

释曰。此偈显示为摄二利六事故。立波罗蜜数唯有六。初为摄利他三事故。立前三波罗蜜令起正勤。如其次第一者施彼。二者不恼。三者忍彼恼后为摄自利。三事故须立。后三波罗蜜令起正勤。如其次第。一者有因。由依精进故。二者心住。由心不定令定故。三者解脱。由心已定令解脱故。偈曰

  不乏亦不恼　　忍恼及不退
  归向与善说　　利他即自成

释曰。此偈显示为摄利他六事故。立波罗蜜数唯有六。菩萨行六波罗蜜时。如其次第。于彼受用令不乏故。不恼彼故。忍彼恼故。助彼所作令不退故。以神通力令归向故。以善说法断彼疑故。菩萨如是利他即是自利。为他所作即自所作。由此因缘得大菩提故。偈曰

  不染及极敬　　不退有二种
  亦二无分别　　具摄大乘因

释曰。此偈显示为摄大乘四因故。立波罗蜜数唯有六。一者不染。二者极敬。三者不退。四者无分别。菩萨修行施时于财不染无顾恋故。受持戒时于诸学处起极敬故。行忍辱精进时。此二不退。忍于众生非众生所作苦得不退故。精进于修行善时得不退故。行禅定般若时。此二无分别。奢摩他毗钵舍那平等所摄故。如此四因摄一切大乘因尽偈曰

  不着及不乱　　不舍亦增进
  净惑及智障　　是道皆悉摄

释曰。此偈显示为摄大乘六道故。立波罗蜜数唯有六。问道者何义。答有方便者为道。此中檀波罗蜜。于诸资财不着为道。由施时于境离染着故。尸波罗蜜。于诸境界不乱为道。由求受戒时一切心乱摄令住故。及比丘住护者。求境界时。一切业乱不能转故。羼提波罗蜜。于诸众生不舍为道。由一切不饶益事不生厌故。毗梨耶波罗蜜。于修诸善增长为道。由精进发起令增上故。禅波罗蜜。于烦恼障令清净为道。般若波罗蜜。于智慧障令清净为道。如是六种道摄一切大乘道尽。偈曰

  为摄三学故　　说度有六种
  初三二初一　　后二二一三

释曰。此偈显示为摄三种增上学故。立波罗蜜数唯有六。此中立初三波罗蜜。为摄初一戒增上学。戒有二种谓聚及眷属。尸罗为聚。檀及羼提为眷属。何以故。施于求受时资财不吝故。忍于护持时打骂不报故。此中立后二波罗蜜。如其次第。为摄心慧二增上学。此中立第四一波罗蜜。应知具摄三增上学。由一切三学精进为伴故。已制六波罗蜜数。次显六波罗蜜相。偈曰

  分别六度体　　一一有四相
  治障及合智　　满愿亦成生

释曰。诸菩萨修诸波罗蜜。一一皆有四相。一治障。二合智。三满愿。四成生。治障者。檀等六行。如其次第。对治悭贪破戒嗔恚懈怠乱心愚痴故。合智者。悉与无分别智共行。由通达法无我故。满愿者。施于求财者随其所欲而给与之。戒于求戒者随其所欲以身口意护而教授之。忍于悔过者与之欢喜。精进于作业者随欲助之。定于学定者随欲授法。智于有疑者随欲决断。成生者。先以施摄。后以三乘法随其所应而成熟之。先安立于戒等中。后以三乘成熟亦尔。已显六波罗蜜。相次说六波罗蜜次第。偈曰

  前后及下上　　粗细次第起
  如是说六度　　不乱有三因

释曰。六波罗蜜次第有三因缘。一前后。二下上。三粗细。前后者。谓依前后得起。何以故。由不顾资财故受持戒。行持戒已能起忍辱。忍辱已能起精进。精进已能起禅定。禅定已能解真法。下上者。前者为下后者为上。下者施上者戒。乃至下者定上者智。粗细者。前者为粗后者为细。粗者施细者戒。乃至粗者定细者智。何故粗易入易作故。何故细难入难作故。已说六波罗蜜次第。次释六波罗蜜名。偈曰

  除贫亦令凉　　破嗔与建善
  心持及真解　　是说六行义

释曰。能除贫穷故名施。能令清凉故名戒。由具戒者于境界相中烦恼热息故。能破嗔恚故名忍。忍破嗔恚能令尽故。能建善故名进。建立善法由此力故。能持心故名定。摄持内意故。能解真法故名慧。晓了第一义谛故。已释六波罗蜜名。次说修习六波罗蜜。偈曰

  物与思及心　　方便并势力
  当知修六行　　说有五依止

释曰。诸菩萨修习诸波罗蜜有五依止。一者物依止。二者思惟依止。三者心依止。四者方便依止。五者势力依止。物依止修诸波罗蜜有四种。一者依止因。依种性力而修习故。二者依止报。依自身成就力而修习故。三者依止愿。依昔愿力而修习故。四者依止数。依智慧力而修习故。思惟依止修诸波罗蜜亦有四种。一者信思惟。于诸波罗蜜相应教而生信心故。二者味思惟。于诸波罗蜜中见功德味故。三者随喜思惟。于一切世界一切众生所有诸波罗蜜皆生随喜故。四者悕望思惟。于自身及他未来所有胜波罗蜜起悕望故。心依止修诸波罗蜜有六种。一者无厌心。二者广大心。三者胜喜心。四者胜利心。五者不染心。六者善净心。何谓修檀六种心。若菩萨以满恒河沙数世界七宝及以身命。于一刹那施一众生。如是乃至尽众生界。所愿成熟无上菩提者以此门施心无厌足。如是相心是名修檀无厌心。若菩萨如是相施。从初相续乃至成佛。无刹那顷有绝有减。如是相心是名修檀广大心。若菩萨以施摄他时生极重欢喜。过于受者得财时生喜。如是相心是名修檀胜喜心。若菩萨以施摄他时。见他受物极饶益我。非我自用为极饶益。何以故。由施摄他令我成就无上菩提因故。如是相心是名修檀胜利心。若菩萨如是广施不求报恩及以果报。如是相心是名修檀不染心。若菩萨如是广施所生福聚所得果报。愿施一切众生非为自受。又与一切众生共之回向无上菩提。如是相心是名修檀善净心。何谓修戒等六种心。若菩萨有恒河沙数自身。一一身复有恒河沙数劫寿。一一寿中复乏一切资生。于此乏中复有火聚。遍满三千大千世界。菩萨以此多身经此多寿在此火聚起四威仪。于一刹那但修一戒。如是乃至尽诸戒聚。乃至尽诸智聚。能得无上菩提者。菩萨修之心无厌足。如是相心是名修戒等无厌心。若菩萨从初修戒乃至修智。极坐道场无有间断。如是相心是名修戒等广大心。若菩萨修戒等摄他时生极重欢喜。过于受摄者得利益时生喜。如是相心是名修戒等胜喜心。若菩萨修戒等摄他时。见他得利极饶益我。非我自利为极饶益。如是相心是名修戒等胜利心。若菩萨修戒等时。不求报恩及以果报。如是相心是名修戒等不染心。若菩萨广修戒等所生福聚所得果报。愿施一切众生非为自受。又与一切众生共之回向无上菩提。如是相心是名修戒等善净心。方便依止修诸波罗蜜有三种。三种者即是三轮清净。此清净由无分别智为方便故。以此方便一切作意悉得成就。势力依止修诸波罗蜜亦有三种。一者身势力。二者行势力。三者说势力。身势力者。应知是佛自性身及受用身。行势力者。应知是佛化身。以此化身于一切相为一切众生示现一切善行故。说势力者。谓演说六波罗蜜一切种时无滞碍故

大乘庄严经论卷第七大乘庄严经论卷第八

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    度摄品第十七之二

释曰。已说修习六波罗蜜。次说六波罗蜜差别。六波罗蜜差别各有六义。一者自性。二者因。三者果。四者业。五者相应。六者品类。偈曰

  施彼及共思　　二成亦二摄
  具住不悭故　　法财无畏三

释曰。此偈明檀波罗蜜六义。施彼者是施自性。由以己物施诸受者故。共思者是施因。由无贪善根与思俱生故。二成者是施果。由财成就及身成就故。言身成就者。具摄命等五事。如五事经中说。施食得五事。一者得命。二者得色。三者得力。四者得乐五者得辩。二摄者是施业。由自他二摄满足及大菩提满足故。具住不悭故者。是施相应。由具足住不悭人心中故。法财无畏三者。是施品类。品类有三。一者法施。二者财施。三者无畏施故。如是六义。智者应知应习。偈曰

  六支灭有边　　善道及持等
  福聚具足故　　二得为二种

释曰。此偈明尸波罗蜜六义。六支者是戒自性。由住具戒乃至受学诸学足故。灭有边者是戒因。灭是涅槃。为求涅槃度诸有边受行戒故。善道者是戒果。善道及不悔等次第五心住因戒得故。持等者是戒业。戒有三能。一者能持。由能任持一切功德如大地故。二者能静。由能止息一切烦恼火热故。三者无畏。由能不起一切怖憎等诸罪缘起岂畏起诸罪故。福聚具足故者。是戒相应。由一切时身口意业皆行善行故。二得为二种者。是戒品类。二得谓受得及法得。受得者。摄波罗提木叉护。法得者。摄禅护及无流护故。偈曰

  不报耐智性　　大悲及法依
  五德并二利　　具胜彼三种

释曰。此偈明羼提波罗蜜六义。不报耐智性者。是忍自性。一不报。二耐。三智。此三次第是三忍自性。不报者是他毁忍自性。耐者是安苦忍自性。智者是观法忍自性。大悲及法依者是忍因。一大悲为因。二法依为因。法依者。谓受戒及多闻故。五德者是忍果。如经中说。忍得五种果。一得少憎愱。二得不坏他意。三得喜乐。四得临终不悔。五得身坏生天。二利者是忍业。由三忍故能作自利利他二种业。如经偈说。作彼二义。自利利他。若知他嗔。于彼自息。具胜者。是忍相应忍难行故名最胜。具足最胜名相应。如经中说。忍最上难行故。彼三种者。是忍品类。彼人有三品。一他毁忍。二安苦忍。三观法忍故。偈曰

  于善于正勇　　有信有欲故
  念增及对治　　具德彼七种

释曰。此偈明毗梨耶波罗蜜六义。于善于正勇者。是精进自性。遮余业中勇猛故言善。除外道解脱中勇猛故言正。有信有欲故者。是精进因。由信及求精进得起故。念增者。是精进果。念定等功德复由精进起故。对治者。是精进业。如经中说。起精进者能得乐住。不杂诸恶不善法故。具德者。是精进相应。由具无贪等功德故。彼七种者。是精进品类。彼人有七品精进。一学戒精进。二学定精进。三学慧精进四身精进。五心精进。六无间精进。七尊重精进。偈曰

  心住及念进　　乐生亦通住
  诸法之上首　　彼种三复三

释曰。此偈明禅波罗蜜六义。心住者。是定自性。由心住内故。念进者。是定因。有念故于缘不忘。依进故禅定得起。乐生者是定果。离退方便离果不虚故。通住者。是定业。通谓五通。住谓三住。圣住天住梵住。禅定能令五通及三住皆得自在住故。诸法之上首者。是定相应。如经中说。三摩提者诸法上首故。彼种三复三者。是定品类。彼人有二种三品。一者有觉有观无觉有观无觉无观三品故。二者喜俱乐俱舍俱三品故。偈曰

  正择与定持　　善脱及命说
  诸法之上首　　彼亦有三种

释曰。此偈明般若波罗蜜六义。正择者。是慧自性。由离邪业及世间所识业。正择出世间法故。定持者。是慧因。由定持慧如实解法故。善脱者。是慧果。谓于染污得善解脱。何以故。由世间出世间大出世间正择故。命说者。是慧业。由慧命及善说慧命者以彼无上正择为命故。善说者。正说正法故。诸法之上首者是慧相应。如经中说。般若者一切法中上故。彼亦有三种者。是慧品类。彼人有世间出世间大出世间三品正择故。已说六波罗蜜差别。次说六波罗蜜摄行。偈曰

  一切白净法　　应知乱定俱
  六度总三双　　是类皆悉摄

释曰。一切白净法者。谓檀等诸行法。应知彼行法总摄有三种。一者乱。二者定。三者俱。彼乱者以前二波罗蜜摄施戒不定故。定者以后二波罗蜜摄禅及实慧定故。俱者以中二波罗蜜摄忍及精进定不定故。已说六波罗蜜摄行。次说六波罗蜜治障。偈曰

  檀离七着故　　不着说七种
  应知余五度　　障治七皆然

释曰。檀离七着故不着说七种者。彼檀著有七种。一资财着。二慢缓着。三偏执着。四报恩着。五果报着。六障碍着。七散乱着。此中障碍著者。谓檀所对治贪。随眠不断故。散乱著者。散乱有二种。一下意散乱求小乘故。二分别散乱分别三轮故。由菩萨行檀时远离此七着故说七不着。应知余五度障治七皆然者。应知戒等五波罗蜜亦各有七着。离七着故亦各说七不着。此中有差别者。翻檀波罗蜜离资财着。即是戒等五波罗蜜离第一着。所谓戒离破戒着。忍离嗔恚着。精进离懈怠着。禅定离乱心着。智慧离愚痴着。戒等离障碍著者。彼障随眠皆断除故。戒等离分别著者。随其三轮不分别故。已说六波罗蜜治障。次说六波罗蜜功德。此中先说利他功德。偈曰

  恒时舍身命　　离求愍他故
  因施建菩提　　智摄施无尽

释曰。此偈显示檀波罗蜜利他功德。恒时舍身命者。谓诸菩萨一切时施自身命与一切求者故。离求愍他故者。不求报恩及以爱果由大悲为因故。因施建菩提者。因是施已建立一切众生于三乘菩提故。智摄施无尽者。此施由无分别智所摄乃至无余涅槃其福无尽无穷利益一切众生故。偈曰

  恒时守禁勤　　离戒及善趣
  因戒建菩提　　智摄戒无尽

释曰。此偈显示尸波罗蜜利他功德恒时守禁勤者。菩萨有三聚戒。一律仪戒。二摄善法戒。三摄众生戒。初戒以禁防为体。后二戒以勤勇为体。诸菩萨一切时恒守护故。离戒及善趣者。谓不着得戒及不求爱果故。偈曰

  恒时耐他毁　　离求畏无能
  因忍建菩提　　智摄忍无尽

释曰。此偈显示羼提波罗蜜利他功德。恒时耐他毁者。诸菩萨于一切时若一切众生以一切极恼事来毁菩萨。菩萨悉能忍受故。离求畏无能者。不求报恩不求善趣不为怖畏不为无能故。偈曰

  恒时誓勤作　　杀贼为无上
  因进建菩提　　智摄进无尽

释曰。此偈显示毗梨耶波罗蜜利他功德。恒时誓勤作者。诸菩萨无比修精进有二自性。一弘誓为自性。二勤方便为自性。杀贼为无上者。菩萨修精进但为杀自他烦恼贼。为得无上菩提故。偈曰

  恒时习诸定　　舍禅下处生
  因定建菩提　　智摄定无尽

释曰。此偈显示禅波罗蜜利他功德。恒时习诸定者。诸菩萨摄无边三摩提而修习故。舍禅下处生者。弃舍无上禅乐住来就下劣处受生。何以故。由大悲故。偈曰

  恒了真余境　　佛断尚不着
  因智建菩提　　悲摄智无尽

释曰。此偈显示般若波罗蜜利他功德。恒了真余境者。了真谓第一义谛平等相。人法二无我智故。余境谓无边。名相等差别故。佛断尚不著者。佛断谓涅槃诸菩萨修般若尚不着佛涅槃。何况求生死。此中前五波罗蜜。以无分别智摄故。乃至无余涅槃功德无尽。般若波罗蜜。以大悲摄故。恒不舍众生功德无尽。六偈别说利他功德已。次以一偈总说前义。偈曰

  广大及无求　　最胜与无尽
  当知一一度　　四德悉皆同

释曰。四功德者。一广大功德。二无求功德。三最胜功德。四无尽功德。前六偈第一句显广大功德。利多众生故。第二句显无求功德。第三句显最胜功德。第四句显无尽功德。复次六波罗蜜复有清净功德。偈曰

  得见及遂愿　　并求合三喜
  菩萨喜相翻　　彼退悲极故

释曰。此偈显示檀波罗蜜清净功德。彼乞求者于菩萨生三喜。一得见时生喜。二遂愿时生喜。三求见求遂时生喜。由不见不遂时不生喜故。菩萨一切时于乞求者翻彼三喜亦生三喜。一得见彼时生喜。二遂彼愿时生喜。三求见求遂彼时生喜。此中应知。彼求者三喜不如菩萨三喜。何以故。菩萨大悲具足故。偈曰

  自身财眷属　　由悲恒喜施
  彼三远离行　　何因不禁守

释曰。此下显示尸波罗蜜清净功德。此偈明远离身三恶行。菩萨于自身自财自眷属中。由大悲故尚恒欢喜好施于他。况于他身他财他眷属中。三种远离行而不禁守耶。偈曰

  不顾及平等　　无畏亦普施
  悲极有何因　　恼他而妄语

释曰。此偈明远离妄语恶行。凡起妄语有四因缘。一为自利。恋身命故。二为利他。利所爱故。三为怖畏。惧王法故。四为求财。有所须故。菩萨则不尔。一者不顾。不恋身命故。二者平等。他身与自得等心故。三者无畏。离五怖故。四者普施。以一切物施一切故。菩萨悲愍恒深。复有何因而起妄语。偈曰

  平等利益作　　大悲惧他苦
  亦勤成熟生　　极远三语过

释曰。此偈明远离余三语恶行。菩萨于一切众生恒作平等利益。岂欲坏他眷属而作两舌。菩萨大悲恒欲拔除一切众生之苦。于他苦中极生怖惧。岂欲为苦于他而作恶口。菩萨恒行正勤。恒欲成熟一切众生。岂欲不成熟他而作绮语。是故菩萨能极远离此三语过。偈曰

  普施及有悲　　极善缘起法
  何因不能耐　　意地三烦恼

释曰。此偈明远离意三恶行。菩萨由普施一切物故离贪烦恼。由大悲故离嗔烦恼。由极善缘起法故离邪见烦恼。如是等破戒对治差别。是菩萨戒清净功德。偈曰

  损者得益想　　苦事喜想生
  菩萨既如是　　忍谁何所忍

释曰。此偈显示羼提波罗蜜清净功德。损者得益想者。菩萨于彼不饶益者得饶益想。应须忍辱。何以故。为成忍辱因故。苦事喜想生者。菩萨于受苦事中更生喜想。何以故。成就利他因故。菩萨既无不饶益想起处及苦想起处。于谁边起忍于何事起忍。偈曰

  菩萨他想断　　爱他过自爱
  于他难行事　　精进即无难

释曰。此偈显示毗梨耶波罗蜜清净功德。菩萨为他难行精进而得不难。何以故。他想断故。及一切时生于他爱。过自爱故。菩萨如是为他精进。岂复难行。是故精进清净。偈曰

  少乐二自乐　　着退尽痴故
  是说三人禅　　菩萨禅翻彼

释曰。此偈显示禅波罗蜜清净功德。少乐者。谓世间禅。二自乐者。谓声闻禅及缘觉禅。著者。若世间禅着自见。若二乘禅着涅槃。退者。谓世间禅。尽者。谓二乘禅。无余涅槃时尽故。痴者。彼三人禅如其所应。有染痴无染痴故。菩萨禅翻彼者。谓翻彼三人禅。何以故。多乐自乐他乐故。不着不退无尽无痴故。是谓禅定清净功德。偈曰

  暗触及二灯　　如是三人智
  譬如日光照　　菩萨智无比

释曰。此偈显示般若波罗蜜清净功德。譬如暗中以手触物。凡夫人智亦如是。何以故。得少境故。不明了故。不恒定故。譬如二灯室中照物。声闻人智及缘觉智亦如是。何以故。得少境故。渐明了故。未极净故。譬如日光照物。菩萨智亦如是。何以故。得遍满故。以明了故。极清净故。如是无比。是谓菩萨般若清净功德。复次六波罗蜜后有八种无上功德。偈曰

  依类缘回向　　因智田依止
  如是八种胜　　无上义应知

释曰。八无上者。一依二类三缘四回向五因六智七田八依止。问此八于六度云何得无上。答檀依者。以依菩萨故。檀类者。此有三种。一物施。以舍自身命故。二无畏施。以救济恶道生死畏故。三法施。以说大乘法故。檀缘者。以大悲为缘起故。檀回向者。以求大菩提故。檀因者。以先世施业熏习种子为因故。檀智者。以无分别智观察三轮。不分别施者受者财物故。檀田者。田有五人。一求人。二苦人。三无依人。四恶行人。五具德人。应知此中以具德胜人为无上。檀依止者。由三种依止故。一依止信向。二依止思惟。三依止三昧。依止信向者。如分别修中信思惟所说。依止思惟者。如分别修中味思惟随喜思惟希望思惟所说。依止三昧者。谓依金刚藏等定。如势力依止修中所说。如是依等无上故檀得无上。如檀八无上。戒等五波罗蜜八无上。应知亦尔。此中戒品类无上者。谓菩萨戒。忍品类无上者。谓来杀菩萨者卑下劣弱。精进品类无上者。谓修诸波罗蜜所对治断。禅品类无上者。谓菩萨三摩提。智品类无上者。谓缘如如境。戒等由胜田无上者。谓大乘法。余六无上如檀中说。复次檀及精进复有不共差别功德。问檀差别云何。偈曰

  施一令得乐　　多劫自受苦
  尚舍为爱深　　何况利翻彼

释曰。若诸菩萨施一众生令其得乐。自身多劫受贫穷苦尚施无吝。由爱深故。爱深者。谓悲差别。何况施一众生令其得乐。自身多劫获大福利也。偈曰

  乞者随所欲　　菩萨一切舍
  彼求为身故　　利彼百种施

释曰。此偈上半总说。谓随彼所求菩萨悉舍。下半解释。谓彼乞者为自利故一切欲得。菩萨为利他故百种悉舍。偈曰

  舍身尚不苦　　何况余财物
  出世喜得故　　起苦是无上

释曰。菩萨舍身时。由心故不生苦。此心显示菩萨出世间。何以故。得欢喜故。问此喜从何得。答从起苦得。是故起苦是菩萨无上。是故菩萨在出世间上。偈曰

  乞者一切得　　得喜非大喜
  菩萨一切舍　　喜彼喜大故

释曰。乞者所须菩萨皆施。乞者得喜。此喜非是大喜。问何故。答由菩萨一切皆舍喜彼得财。此喜为大。夺彼喜故。偈曰

  乞者一切得　　有财非见富
  菩萨一切舍　　无财见大富

释曰。此偈显菩萨财无尽差别。偈曰

  乞者一切得　　非大饶益想
  菩萨一切舍　　得大饶益想

释曰。此显菩萨大悲差别。偈曰

  乞者自在取　　如取路傍果
  菩萨能大舍　　余人无是事

释曰。此显菩萨无著差别。问说檀不共功德差别已。精进不共功德差别复云何。偈曰

  胜因依业种　　对治等异故
  如是六种义　　精进有差别

释曰。精进有六种差别。一胜差别。二因差别。三依止差别。四业差别。五种差别。六对治差别。此偈总举。余偈别释。偈曰

  白法进为上　　进亦是胜因
  及得诸善法　　进则为依止

释曰。此偈说精进胜差别因差别依止差别。白法进为上者。说最胜差别。由于一切善法中说精进为最胜故。进亦是胜因者。说因差别。由说精进是无上因故。及得诸善法进则为依止者。说依止差别。由依止精进得一切善法故。偈曰

  现乐与世法　　出世及资财
  动静及解脱　　菩提七为业

释曰。此偈说精进业差别。此业差别有七种。一得现法乐住。二得世间法。三得出世间法。四得资财。五得动静。动静者。由是世间不究竟故。六得解脱。解脱者。由断身见故。七得菩提。菩提者。由大菩提故。偈曰

  增减及增上　　舍障亦入真
  转依与大利　　六说精进种

释曰。此偈说精进种差别种差别有六种。一增减精进。谓四正勤。二恶法减二善法增故。二增上精进。谓五根。由于解脱法为增上义故。三舍障精进。谓五力。由彼障碍不能碍故。四入真精进。谓七觉分。由见道建立故。五转依精进。谓八圣道分。由修道是究竟转依因故。六大利精进。谓六波罗蜜。由自利利他故。偈曰

  种复有五异　　弘誓将发行
  无下及不动　　第五说无厌

释曰。五异者。一弘誓精进。谓欲发起行故。二发行精进。谓现行诸善故。三无下精进。谓得大果下体无故。四不动精进。谓寒热等苦不能动故。五无厌精进。谓不以少得为足故。此五种如经中所说。有弘誓精进。有现起精进。有勇猛精进。有坚固精进。有不舍佛道精进。于诸善法中。如其次第应知。偈曰

  三种下中上　　由依三乘尔
  亦二下上觉　　利有小大故

释曰。彼精进依人差别。复说三种及二种。三种者。依三乘行人差别。如其次第。下中上精进故。问何因复二种。答下上觉故。下觉者。依二乘行人。上觉者。依大乘行人。如其次第。说于小利及大利故。何以故。为自利故。为他利故。偈曰

  财着烦恼着　　厌着知足着
  四着不能退　　对治分四种

释曰。此偈说精进对治差别。由对治四著有四不退。说四种对治差别。问此云何。答檀等诸行。由四着为碍故而不得行。一者财着。于财极吝故。二者烦恼着。于财起染故。三者厌着。于檀等行有退屈故。四者知足着。于少施等喜满足故。行精进者对治如此四着。能得不退故说四种对治差别。已说六波罗蜜功德。次说六波罗蜜互显。偈曰

  相摄及差别　　依法亦为因
  六度互相成　　一切种分别

释曰。六波罗蜜相成自有四义。一相摄。二差别。三依法。四为因。相摄者。无畏施摄戒忍二度。由此二度能与无畏故。法施摄定智二度。由此二度能与法故。俱施摄精进一度。由此一度能行二施故。问戒摄几种。答摄善法戒一切檀等皆摄。如是忍等互摄如其所应作。差别者。檀等六种即为六施。谓施施戒施乃至般若施。于他相续建立檀等故。依法者所有诸经所有檀等诸义显示。所有檀等诸义所有诸经显示。处处相摄应知。为因者。谓檀为戒等因。何以故。不顾财者能行戒等故。戒亦施等因。何以故。比丘受护者能舍一切所有受故。住戒者。能具足忍等故。又受摄善法戒为檀等故。如是忍等互为因。如其所应作。如是说六波罗蜜义已。次说四摄行。偈曰

  布施将爱语　　利行并同利
  施平及彼说　　建立亦自行

释曰。四摄者。一布施摄。二爱语摄。三利行摄。四同利摄。施平者。即布施摄。彼说者。谓爱语摄。说彼波罗蜜义故。建立者谓利行摄。建立众生于波罗蜜中故。自行者。谓同利摄。建立他已自亦如是行故。问何故说此四摄体。答此说摄他诸方便。偈曰

  摄他四方便　　即是四摄性
  随摄亦摄取　　正转及随转

释曰。布施者。是随摄方便。由财施随他身起摄故。爱语者。是摄取方便。由无知疑惑者令受义故。利行者。是正转方便。由此行诸善转故。同利者。是随转方便。菩萨自如说行众生知已先未行善亦随行故。问四摄业云何。偈曰

  令器及令信　　令行亦令解
  如是作四事　　次第四摄业

释曰。布施者。能令于法成器。由随顺于财则堪受法故。爱语者。能令于法起信。由教法义彼疑断故。利行者。能令于法起行。由如法依行故。同利者。能令彼得解脱。由行净长时得饶益故。是为四摄业。问世尊亦说二摄。此云何。偈曰

  四体说二摄　　财摄及法摄
  财一法有三　　次第摄四摄

释曰。此四摄体。世尊余处说为二摄。谓财摄法摄。即以二摄摄于四摄。财摄摄初一摄。法摄摄后三摄。问云何摄后三。答法有三种。一所缘法。二所行法。三所净法。如其次第摄后三摄。应知偈曰

  下中上差别　　如是四摄种
  倍无及倍有　　亦纯合三益

释曰。四摄种差别有三。谓下中上。由诸菩萨摄三乘人差别故。由此三种差别次第复有三益。一倍无益二倍有益。三纯有益。倍无益者。谓解行地菩萨摄。倍有益者。谓入大地菩萨摄。纯有益者。谓八地已上菩萨摄。由彼决定能令众生成就故。偈曰

  菩萨欲摄众　　依此四方便
  大利及易成　　得赞三益故

释曰。若诸菩萨欲摄徒众者。一切皆须依此四摄以为方便。何以故。由一切大利得成就故。由是乐易方便故。由得诸佛称扬故。偈曰

  四摄于三世　　恒时摄众生
  成就众生道　　非余唯四摄

释曰。此四摄于三世中已摄当摄现摄一切众生。是故此四摄是成熟众生道。非余诸道。余道无体故。别说六度四摄已。次以一偈总结前义。偈曰

  不着及寂静　　能耐将意勇
  不动并离相　　亦摄摄众生

释曰。此偈上三句结六度义。下一句结四摄义。偈义如前解。菩萨以此六行行此四摄。显示六波罗蜜。成就自利利他。四摄成就亦尔。是故如其次第。先说六度。后说四摄。度摄品究竟

大乘庄严经论卷第八大乘庄严经论卷第九

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    供养品第十八

释曰。已说业所聚集诸行。未说供养如来。此供养今当说。偈曰

  依物缘回向　　因智田依止
  如是八供养　　供养诸如来

释曰。略说供养如来有八种。何谓为八。一者依供养。二者物供养。三者缘起供养。四者回向供养。五者因供养。六者智供养。七者田供养。八者依止供养。问此八义云何。偈曰

  现前不现前　　衣服饮食等
  深起善净心　　为满于二聚
  常愿生佛世　　三轮不分别
  成熟诸众生　　最后十一种

释曰。此二偈八句显示前八义。应知现前不现前者。谓依供养。依现在及过去未来诸佛而供养故。衣服饮食等者。谓物供养。以衣服等而供养故。深起善净心者。谓缘起供养。以深净信心而供养故。为满于二聚者。谓回向供养。为满福智二聚而供养故。常愿生佛世者。谓因供养。由有宿愿愿生佛世。令我有益不虚供养故。三轮不分别者谓智供养。设供受供供具三事不可得故。成熟诸众生者。谓田供养。众生为田。教彼供养令种善根故。最后十一种者。谓依止供养。此依止有十一种。一者依止物。由依财物而供养故。二者依止思惟。由依味思惟随喜思惟希望思惟故。三者依止信。由信大乘发菩提心故。四者依止愿。由发弘誓愿故。五者依止悲。由怜愍众生故。六者依止忍。由难行能行故。七者依止行。由诸波罗蜜故。八者依止正念。由如法不倒故。九者依止正见。由如实觉了故。十者依止解脱。由声闻烦恼灭故。十一者依止真实。由得大菩提故。问供养种差别云何。偈曰

  因果及内外　　粗细与大小
  亦远近差别　　是名供养种

释曰。世等差别为供养种差别。彼过去为因。现在为果现在为因未来为果。如是因果谓去来今。应知内者自供养。外者令他供养。粗者利供养。细者随顺供养。小者劣供养。大者胜供养。有慢者为劣。无慢者为胜。三轮不分别故。远者欲后时供养近者即今时供养。复次隔世供养者为远。无间供养者为近。复次发愿于未来欲供养者为远。发愿于现在即供养者为近。问何等供养如来为最上供养。偈曰

  供养诸如来　　最上由自意
  信心通方便　　和合五胜故

释曰。五种自意供养如来。应知此供养为最上供养。何谓为五一者净信。二者深心。三者神通。四者方便。五者和合。净信者。于大乘法说供养处生净信故。深心者此心有九种。一味心。二随喜心。三希望心。四无厌心。五广大心。六胜喜心。七胜利心。八无染心。九善净心。此九心如修诸波罗蜜中说。神通者。谓依虚空藏等诸三摩提故。方便者。谓无分别智方便摄故。和合者。谓一切诸大菩萨和合一果入一切果故。供养品究竟

    大乘庄严经论亲近品第十九

释曰。已说供养如来。云何亲近善知识。偈曰

  如前供养佛　　略说有八种
  亲近于善友　　应知八亦然

释曰。应知亲近善知识亦有依等八种。问此中八义复云何。偈曰

  调静除德增　　有勇阿含富
  觉真善说法　　悲深离退减

释曰。此偈显示第一依亲近。若善知识具足十种功德者。应堪亲近。何谓为十。一者调伏。二者寂静。三者惑除。四者德增。五者有勇。六者经富。七者觉真。八者善说。九者悲深。十者离退。调伏者与戒相应由根调故。寂静者。与定相应由内摄故。惑除者。信念与慧相应烦恼断故。德增者。戒定慧具不缺减故。有勇者。利益他时不疲惓故。经富者。得多闻故。觉真者。了实义故。善说者。不颠倒故。悲深者。绝希望故。离退者。于一切时恭敬说故。偈曰

  敬养及给侍　　身心亦相应
  愿乐及以时　　下心为缘起

释曰。此偈上半显示物亲近。下半显示缘起亲近。物亲近有三。一者财。谓恭敬供养。二者身。谓随顺给侍。三者心。谓给侍时身心相应。缘起亲近亦有三种。一者愿乐。二者知时。三者除慢。偈曰

  为离于贪着　　为求随顺行
  随顺如所教　　以此令彼喜

释曰。此偈上半显示回向亲近。下半显示因亲近。回向亲近者。不为贪着利养故。但为随顺修行故。因亲近者。菩萨如所教授随顺修行。为亲近善知识因。何以故。菩萨以此随顺令彼善知识心生欢喜故。偈曰

  善解于三乘　　自乘令成就
  成生及净土　　为法不为财

释曰。此偈显示智田依止三种亲近。善解于三乘自乘令成就者。显示智亲近。善解三乘者由智故。成生及净土者。显示田亲近。田有二种。一众生田。二佛土田。问此二云何名田。答自所闻法于众生相续中而建立故。随所住佛土修清净因故。为法不为财者显示依止亲近。菩萨但以法利具足为依止。是故亲近善知识。不以财利具足为依止故。问亲近善知识种差别云何。偈曰

  因果及随法　　内外与粗细
  胜劣亦远近　　是谓种差别

释曰。因果差别者。谓过去亲近为因。现在亲近为果。现在亲近为因。未来亲近为果。随法差别者。谓善知识所流法门。随其差别而修行故。内外差别者。自亲近为内。令他亲近为外。粗细差别者。自听为粗。内心思惟为细。胜劣差别者。有慢亲近为劣。无慢亲近为胜。远近差别者。现在趣中亲近为近。生报趣中亲近为远。复次生报趣中亲近为近。后报趣中亲近为远。复次无间亲近为近。隔世亲近为远。复次愿于现在亲近为近。愿于未来亲近为远。问何等亲近善知识得为最上。偈曰

  亲近善友胜　　自意五如前
  信心通方便　　和合等别故

释曰。如前供养诸佛。由五种自意故得为最胜。谓净信深心神通方便和合。此中亲近善知识最胜亦尔。由净信者。于大乘经说。亲近处生净信故。由深心者。心亦九种。谓味心乃至善净心。亲近修行故。由神通者。谓依虚空藏等三摩提而亲近故。由方便者。谓依无分别智摄故。由和合者。诸大菩萨以一果入一切果故。亲近品究竟

    大乘庄严经论梵住品第二十

释曰。菩萨所修四梵住此云何。偈曰

  梵住有四种　　一一有四相
  治障与合智　　转境及成生

释曰。梵住者。谓四无量。即慈悲喜舍。此中应知菩萨四无量。一一各有四种相。一治障。由所治断故。二合智。得无分别智对治胜故。三转境。由众生缘法缘无缘故。四成生。由作胜业成就众生故。问何等众生为众生缘。何等法及无缘为法缘及无缘。偈曰

  乐苦喜烦恼　　如是众生缘
  法缘说彼法　　无缘即彼如

释曰。四种众生聚是众生缘。一求乐众生聚。二有苦众生聚。三有喜众生聚。四烦恼众生聚。慈者于求乐众生聚起与乐行。悲者于有苦众生聚起拔苦行。喜者于有喜众生聚起不离行。舍者于诸受起烦恼众生聚起令离行。是名众生缘。法缘者。即是说彼四种梵住法。说名法缘。无缘者。即是彼如以无分别故。说名无缘。偈曰

  及彼如义故　　忍位得清净
  身口业所摄　　亦尽诸烦恼

释曰。彼四种行应知。无缘慈者。以如缘故。八地无生法忍时得。一切善根亦得圆满。彼清净故。及慈所依身口二业所摄者。诸烦恼亦尽。如烦恼所缘。说意自体诸烦恼断。断所缘故。如是修多罗中说。问彼四梵住何等行差别。偈曰

  有动及不动　　亦啖及不啖
  应知四梵住　　如是行差别

释曰。彼四梵住应知。有四种行差别。一者动。二者不动。三者啖。四者不啖。动者退分。可退故。不动者。住分及胜分。不可退故。啖者染污。贪着乐味无大心故。不啖者。不染污也。此退等行。是梵住差别。诸菩萨住不动及不啖中。不住于动及啖中。问梵住种差别云何。偈曰

  前六及前二　　下地亦下心
  相似等为下　　翻下则为上

释曰。下上差别者。彼不定地自性。前六品为下。一切定地前二品亦为下。谓软软软中下地亦为下。谓下七地菩萨观上地故。下心亦为下。谓诸声闻故。相似亦为下。谓未得无生法忍菩萨故。如所说下翻此下则为上应知。问此四梵住能得几果。偈曰

  所生欲界报　　满聚亦成生
  不离及离障　　具足五为果

释曰。菩萨住诸梵住为因具得五果。一者欲界众生中生。是果报果。二者二聚圆满。是增上果。三者成熟众生。是丈夫果。四者一切生处不离梵住。是依果。五者所生之处恒离彼障。是相离果。问此梵住中有何等事是菩萨相偈曰

  设遇重障缘　　及以自放逸
  欲知菩萨相　　梵心无退转

释曰。菩萨有二事。梵心不动应知。是为菩萨相。一者设遇重障因缘心终无异。是菩萨相。二者设自放逸谓能治不现前时心亦无异。是菩萨相。况无量现前时。问梵住障碍云何。偈曰

  四梵有四障　　嗔恼忧欲故
  菩萨具此障　　多种过失起

释曰。彼四梵所对治具有四障。如其次第。一嗔二恼三忧四欲。由如此障梵无体故。若有此四复生多种过失。问多失云何。偈曰

  如是诸烦恼　　起则有三害
  自害亦害彼　　及以尸罗害

释曰。此偈显示三害过失。一自害。谓自苦思作。二他害。谓他苦思作。三尸罗害。谓俱苦思作。偈曰

  有悔亦失利　　失护及师舍
  治罚并恶名　　如是六呵责

释曰。此偈显示得六种呵责过失。一者自呵责。由有忧悔故。二者他呵责。由失利养故。三者天呵责。由失拥护故四者大师呵责。由大师所舍故。五者梵行呵责。由智慧梵行人如法治罚故。六者十方人呵责。恶名流出故。偈曰

  后身诸难堕　　梵住今亦退
  心数亦苦得　　复次三过生

释曰。此偈显示后得三种过失。一者堕难。由此恶业得。后世恶报故。二者退行。由已得退及未得退退失现在未来梵住故。三者苦生。由心数法从彼生大忧苦故。问已说过失。何者是功德。偈曰

  善住梵住人　　远离彼诸恶
  生死不能污　　不舍济群生

释曰。住梵住者得二功德。一者舍烦恼。如前所说过失悉远离故。二者不舍众生。为成熟众生生死不能污故。问已知功德。此功德云何知最尊最上。偈曰

  如人有一子　　有德生极爱
  菩萨于一切　　起梵胜过彼

释曰。由过此譬则显示菩萨四种梵住最尊最上。问大悲以何等众生为所缘。偈曰

  炽然及怨胜　　苦逼亦闇覆
  住险将大缚　　食毒并失道
  复有非道住　　及以瘦涩者
  如此十众生　　大悲心所缘

释曰。菩萨大悲略以十种众生为境界。一是炽然众生。谓乐着欲染者。二是怨胜众生。谓修善时为魔障碍者。三是苦逼众生。谓在三涂者。四是闇覆众生。谓恒行不善者。由不识业报故。五是住险众生。谓不乐涅槃者。由生死险道不断绝故。六是大缚众生。谓外道僻见者。由欲向解脱为种种僻见坚缚所缚故。七是食毒众生。谓啖定味者。譬如美食杂毒则能害人。善定亦尔。为贪所著则便退失。八是失道众生。谓增上慢者。由于真实解脱道中而迷谬故。九是非道住众生。谓于下乘不定者。由有退故。十是瘦涩众生。谓诸菩萨于二聚未满者。如此十种众生。是菩萨大悲所缘境界。已说大悲境界。次说大悲得果。偈曰

  障断及觉因　　与乐亦爱果
  自流五依故　　是人去佛近

释曰。障断者。是相离果彼障断故。觉因者。是增上果。利益众生故。与乐者。是丈夫果。丈夫所作故。爱果者。是果报果。得可爱报故。自流者。是依果。与未来胜悲故。如是五果皆依大悲所得。当知如此菩萨去佛菩提则为不远。已说大悲得果。次说大悲不住。偈曰

  生死苦为体　　及以无我性
  不厌亦不恼　　大悲胜觉故

释曰。一切生死以苦为体以无我为性。菩萨于苦得如实知。于无我得无上觉。如是得知觉已。由大悲故于生死不生厌离。由胜觉故亦不为烦恼所恼。是故菩萨得不住涅槃。亦不住生死。已说大悲不住。次说大悲功德。偈曰

  见苦自性时　　知苦生悲苦
  亦知舍方便　　恒修不厌生

释曰。菩萨观世间苦见其自性时。即生悲苦。如彼远离方便亦求如实知。知已恒修不厌。是名大悲功德。已说大悲功德。次说大悲差别。偈曰

  自性与数择　　宿习及障断
  应知菩萨悲　　如此四差别

释曰。此大悲随其次第有四差别。一者自性。成自然故。二者数择。见功德过失故。三者宿习。由先世久修故。四者障断。由得离欲断所治恼障清净故。复有六种差别。偈曰

  非等亦非常　　非深亦非顺
  非道非不得　　翻六悲如是

释曰。翻非大悲六种差别。即是大悲六种差别。一者平等。二者常恒。三者深极。四者随顺。五者净道。六者不得。平等者。于乐受等众生所有诸受皆知是苦故。常恒者。乃至无余涅槃亦无尽故。深极者。入地诸菩萨得自他平等故。随顺者于一切众生苦如理拔济故。净道者。所对治恼得断除故。不得者。得无生法忍时。诸法不可得故。已说大悲差别次说大悲如树。偈曰

  悲忍思愿生　　成熟次第说
  大根至大果　　悲树六事成

释曰。此大悲树应知以六事成就。一者大悲。二者忍辱。三者思惟。四者胜愿。五者胜生。六者成熟。此即是根茎枝叶华果六位。问此事云何。答此树以大悲为根。以忍辱为茎。以利益众生思惟为枝。以胜生愿为叶。以所得胜生为华。以成熟众生为果。问何故六事先后如此。偈曰

  无悲则无忍　　如是六次第
  胜生若不得　　成熟众生无

释曰。若无大悲则不能起大苦难行忍。若无大苦难行忍则不能起利益众生思惟。若无利益众生思惟则不能起胜生愿。若无胜生愿则不能向胜生处。若不向胜生处则不能成熟众生。问前后相似如此。成立相似复云何。偈曰

  根生以慈润　　茎擢以乐广
  念正则增枝　　愿续则长叶
  内缘成为华　　外缘成为果
  当知悲根等　　如是次第成

释曰。此中成立相似者。悲以慈润能令滋生。由有慈者见他苦已生悲苦故。是故以悲为根。忍以乐想能令抽擢。由菩萨利他苦生乐想乐想生已能令忍辱得广大故。是故以忍为茎。思以正念能令增进。由忍广已能于利他事中起正念故。是故以思为枝。愿以相续能令长成。由前灭后生。譬如叶长落故抽新。是故以愿为叶。生以内缘成为实。由自身成熟则受生不虚。是故以生为华。成熟者。以外缘成为实。由他身成熟则利益不虚。是故以成熟众生为果。如是次第。成立应知。已说大悲如树。次赞大悲功德。偈曰

  大悲利益作　　谁于他不起
  于苦胜乐生　　乐生由悲故

释曰。此义如偈所说。已赞大悲功德。次说大悲无著。偈曰

  菩萨悲自在　　寂静尚不住
  世乐及身命　　此爱云何起

释曰。一切世间皆爱世乐及自身命。一切声闻缘觉虽不爱世乐及自身命。而于涅槃起住着意。菩萨不尔。大悲自在故。于涅槃尚不住。何况住彼二爱中。已说大悲无著。次说大悲爱胜。偈曰

  贪爱非无障　　世悲亦世间
  菩萨悲爱起　　障尽亦过世

释曰。悲爱最胜自有二义。一者障尽。二者过世。爱亲等贪则自体是障。行世间悲体虽非障而是世间。菩萨悲爱自体障尽而复过世。故为最胜。问云何障尽。偈曰

  有苦及无智　　大海及大闇
  拔济以方便　　云何不障尽

释曰。有苦为大海。无智为大闇。能拔济方便是大悲。此悲爱则障尽。问云何过世。偈曰

  罗汉及缘觉　　如是悲爱无
  何况余世间　　岂得不过世

释曰。阿罗汉辟支佛尚无大悲爱。况余世间而有可得。若如是者。岂不过世乎。已说大悲爱胜。次说大悲无厌。偈曰

  得悲诸菩萨　　舍苦而起苦
  彼初起苦怖　　证时欣乐甚

释曰。舍苦者。谓诸菩萨以大悲故欲舍他苦。而起苦者。由舍他苦则起自苦。彼初起苦怖者。彼初谓信行地菩萨。彼于起苦中而生怯怖。由自他平等未见故。由苦如实未触故。证时欣乐甚者。证时谓净心地菩萨。彼于起苦中生极欣乐。由见自他平等故。由苦如实已触故。已说大悲无厌。次说大悲苦胜。偈曰

  悲苦最希有　　苦胜一切乐
  更乐悲生故　　办非有况余

释曰。悲苦最希有者。谓从他苦而生大悲。从大悲而生自苦。如是悲苦有何希有。而得过此故为最希有。苦胜一切乐者。即此悲苦。胜于一切世间之乐。问何故。答更乐悲生故。此诸菩萨更以悲苦为乐。由此苦从大悲生故。办非有况余者。彼乐所作已办者尚无。况余世间而得有也。已说大悲苦胜。次说大悲施胜。偈曰

  施与悲共起　　能令菩萨乐
  三界中乐受　　比此无一分

释曰。若布施与大悲俱生。则能起菩萨胜乐。于三界中所作诸乐。欲比大悲施所作乐。无有一分而得相似。已说大悲施胜。次说大悲忍苦。偈曰

  生死苦自性　　不舍由悲故
  起苦利他因　　云何舍不习

释曰。一切苦悉入生死苦中。诸菩萨不舍生死由大悲故。菩萨起苦是利他因。菩萨不舍生死时即是不舍一切苦。已说大悲忍苦。次说大悲施果。偈曰

  悲施财三果　　悲者恒增长
  爱生及摄生　　资生复三乐

释曰。悲施财三果悲者恒增长者。谓菩萨大悲能增长三种果。一者增悲。由修习故能令自体增长。二者增施。由悲自在故能令施得增长。三者增财。由施自在故能令财得增长。爱生及摄生资生复三乐者。从是三果复生三乐。一者从悲为因生爱生乐。二者从施为因生摄生乐。三者从财为因生资生乐。已说大悲增果。次说大悲劝进。偈曰

  悲长及施增　　成生亦乐起
  牵来复将去　　大悲劝如是

释曰。大悲劝进菩萨行六种功德。大悲义言。菩萨汝修习我令我滋长。汝舍资财令施增进。汝应以施成熟众生。汝应以施令自乐起。汝若施者招引大菩提二聚及余令向己来。汝若施者将导二聚及余令向大菩提去。已说大悲劝进。次说大悲乐胜。偈曰

  苦者悲诸苦　　不施云何乐
  以令自乐故　　施乐拔他苦

释曰。苦者悲诸苦者。诸菩萨以悲起诸苦。是故名苦者。不施云何乐者。菩萨大悲故以他苦为自苦。若不施他乐云何得自乐。以令自乐故施乐拔他苦者。若菩萨施众生乐拔众生苦时。即是菩萨自作乐。已说大悲乐胜。次说大悲教授。偈曰

  悲者教自施　　施彼勿自求
  施报愿不受　　有愿还以施

释曰。此偈教行无求施。悲者教自施施彼勿自求者。大悲义言。汝施施他时莫求自乐。他乐若无自乐亦无。何以故。乐不别故。施报愿不受有愿还以施者。若我施果亦愿不受。设有果时还以布施。偈曰

  施及于施果　　普施于一切
  彼乐我乐故　　施彼我无须

释曰。此偈教行施果施。谓施及施所得果。普施一切众生。何以故。悲者以彼乐为自乐故。是故菩萨所有施果。皆应布施一切众生。大悲作如是教授。偈曰

  轻财而以施　　来多复来好
  不用而自来　　还用展转施

释曰。此偈教行厌财施。若人厌财而行施者。是人虽不欲财而财自来。极广极妙道理如此。以大心故。若有如此还用布施。是则资财来而复来。菩萨则施而复施。何以故。非求自乐。欲令施施无穷故。偈曰

  悲者以大悲　　尽施及常施
  应作如是施　　慎勿求施果

释曰。此偈教行无间施应知。偈曰

  若我不乐施　　施果不施时
  施无一刹那　　以无施爱故

释曰。此偈教行无厌施应知。偈曰

  不作不与果　　与果与作者
  是汝观恩过　　与我不相似

释曰。此偈教行舍恩施。菩萨语施云。若人行汝者。汝方与果。是汝待报恩过失。我则不尔。是汝不与我相似。复次若人行汝者。汝但与此人果。汝则是待报恩者。我则不尔。所行施果与一切众生。是汝不与我相似。已说大悲教施。次说大悲行施。偈曰

  无障及净句　　利彼亦自量
  无求与无著　　悲者如是施

释曰。无障者。谓不夺他物行施故。净句者。以如法财行施。谓不以毒物兵杖酒等施故。利彼者。以施摄他时置于善根故。自量者。不令自眷属有乏少故。无求者。谓前众生或无。心求或无口求。见彼乏少自然而施。及不简福田故。无著者。不求报恩及以果报故。偈曰

  尽广胜常喜　　离着亦清净
  回向于二处　　菩提及善根

释曰。尽者。内外物施故。广者。多物施故。胜者。妙物施故。常者。恒施故。喜者。离嗔施故。谓乞求者作不饶益时忍而喜施。离著者。无希望故。如前无著说。清净者。以如法故。如前净句说。回向菩提者。回向大菩提故。回向善根者。回向随顺善根器故。已说大悲行施。次说大悲受用差别。偈曰

  有财而自用　　及用施众生
  得喜施喜胜　　三乐养心故

释曰。菩萨自受用财生喜。及用财布施众生生喜。二喜相比施喜为胜。何以故。三乐养心故。三乐者。一布施喜。二摄他喜。三菩提聚满足喜。已说大悲受用差别。次说大悲增长诸度。偈曰

  悭恶嗔放逸　　缘着及邪着
  如是六蔽者　　悲令六度增

释曰。悭者。少物不能舍故。恶者。破戒及恼他故。嗔者。于少不饶益起大嗔故。放逸者。于诸善法不勤行故。缘著者。五欲乱心故。邪著者。外道无慧故。如是住六蔽者。大悲怜愍为说过失。令六波罗蜜而得增长。说大悲增长诸度已。此大悲从四缘生。亦应显示。偈曰

  苦乐不苦乐　　因力及善友
  自体相续流　　大悲四缘义

释曰。苦乐不苦乐者。显示缘缘具缘。三受三苦俱起悲故。问舍受云何苦。答由行苦故。因力者。显示因缘。善友者。显示增上缘。自体相续流者。显示次第缘。问大悲如是生已云何得平等。偈曰

  行相及思惟　　随顺与离障
  不得亦清净　　六义悲平等

释曰。大悲平等有六种。一者行相平等。由三受位众生平等知是苦故。二者思惟平等。由平等怜愍故。三者随顺平等。由平等救济故。四者离障平等。由平等不恼故。五者不得平等。由自他及悲三轮平等不可得故。六者清净平等。由八地无生忍时平等得故。问如是别说大悲已。此四梵住云何修习得令无上。偈曰

  慈等令无上　　自意修亦五
  信心通方便　　和合如前说

释曰。如前供养诸佛亲近善友皆由五种自意修习得令无上。梵住亦尔。由净信者。于大乘经说。梵住处生净信故。由深心者。以九种心修梵住故。由神通者。依虚空等定而修习故。由方便者。依无分别智所摄故。由和合者以一果入一切果故。梵住品究竟

大乘庄严经论卷第九大乘庄严经论卷第十

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    觉分品第二十一之一

释曰。诸菩萨有羞相(羞兼惭愧)。此中应说。偈曰

  治障及合智　　缘境亦成生
  菩萨有羞相　　如是四差别

释曰。此偈显示菩萨有羞有四种相。一自性。二伴类。三境界。四作业。治障者。谓离无羞。此即是羞自性。合智者。与无分别知相应。此智是羞伴类。缘境者。菩萨以小无障众生为可羞境。即是声闻缘觉。小者对大乘故。无障者。破烦恼障故。成生者。菩萨有羞以建立众生为业。此是有羞四种相。问诸菩萨有羞于何行中起。偈曰

  菩萨于六度　　障增及治减
  不勤亦勤行　　于此有羞起

释曰。诸菩萨于四事中极生羞耻。一者于诸度障增时极生羞耻。二者于诸障治减时极生羞耻。三者修诸度懈怠时极生羞耻。四者随顺烦恼法勤行时极生羞耻。所谓诸根常开而不禁守。问菩萨有羞种差别云何。偈曰

  六品及二品　　七地与二乘
  亦似则为下　　反此应知上

释曰。六品者。不定地中前六品有羞为下。二品者。诸定地中前二品有羞为下。七地者。菩萨十地中前七地有羞为下。二乘者。谓下心众生有羞为下。由有增上慢故。亦似者。谓未得无生忍菩萨彼有羞亦为下。翻此诸下有羞。应知即是诸上有羞。问何法是有羞障。及彼障有几过失。偈曰

  无羞惑不断　　三害及六呵
  堕难退苦三　　如前十二失

释曰。无羞者。是菩萨有羞障。若有此障则烦恼不断。烦恼不断则先生三害。一自害。谓不正思惟。由自恼故。二他害。谓嗔及舍。由恼他故。问嗔者恼众生可尔。舍者云何恼众生。答菩萨应化众生。舍而不化。是谓为恼。俱害者。谓破尸罗。由恼自他故。起三害已即于现法得六呵责。由疑悔失利失护弃舍治罚恶名故。随其次第得六种呵责。所谓自呵责乃至十方人呵责。如是已后复有三种过失生。一退堕诸难处。二退失已得未得善法。三从彼生大苦受。是谓无羞生十二种过失。问已知障及过失。何者是有羞功德。偈曰

  此等一切恶　　菩萨若有羞
  当知一切尽　　起彼对治故
  天人聪慧生　　速满于二聚
  成生不退转　　离不离为果

释曰。初偈显示有羞离过功德。如前过失。菩萨有羞一切不有故。后偈显示有羞集得功德。具足聚集五胜果故。天人聪慧生者。是得果报果。谓常生天上及以人中恒得聪慧故。速满于二聚者。是得增上果。谓得大菩提二聚故。成生不退转者。是得丈夫果。丈夫所作故。离者。是得相离果。离彼障故。不离者。是得依果。一切生处不离彼障对治故。问有羞功用譬喻云何。偈曰

  有衣翻有垢　　凡夫无惭故
  天衣更无垢　　菩萨有惭尔
  菩萨惭具足　　如空不可污
  欲胜诸菩萨　　亦以惭庄严
  譬如慈母爱　　惭护众生然
  观生及化生　　此事由惭起

释曰。此中第一偈显示惭如衣服。何以故。有惭者过垢不能污故。第二偈上半显示惭如虚空。何以故。有惭者虽值世间八法不被染故。第二偈下半显示惭如庄严。何以故。有惭者端正胜余菩萨故。第三偈显示惭如慈母。何以故有惭者拥护生死一切过失如象马军观生化生由此起故。衣服譬显惭能对治住诸烦恼。虚空譬显惭能对治染着八法。庄严譬显惭能随顺同行。慈母譬显惭能成熟众生。问菩萨行惭有何相。偈曰

  不忍及不行　　亦忍及亦行
  当知此四种　　是说行惭相

释曰。此偈显示四种行惭相。一不忍。二不行。三忍。四行。何以故。有惭者于一切过恶有前二相。不忍故。不行故。于一切功德有后二相。忍故。行故。问云何惭羞得无上。偈曰

  教习于惭羞　　亦起五自意
  信法等别故　　无上如前知

释曰。如前知者于大乘经说。惭羞处生净信故。以九种深心修习故。依虚空等定修习故。由无分别智摄故。以一果入一切果故。已说菩萨有羞。次说菩萨无畏。偈曰

  诸菩萨无畏　　体相及差别
  坚固与殊胜　　今当次第解

释曰。菩萨无畏有四义解释。一体相。二差别。三坚固。四殊胜。问体相云何。偈曰

  进定慧三起　　勇健勤猛作
  是说无畏相　　亦显于众名

释曰。精进禅定般若。此三若起是无畏体相。勇健勤猛。此四显无畏众名。问此三于何行中无畏。偈曰

  诸有所作中　　下动愚则畏
  离三三决定　　是名无畏安

释曰。菩萨于诸所作中其心若下若动若愚则生怖畏。何以故。下心者。于彼无勤修故。动心者。于彼心不住故。愚心者。于彼无方便故。彼三对治随其次第。即是精进禅定般若。是故精进等三。若得决定则名无畏。问云何决定。答此三对治任运现前。是名决定。问已说体相。云何差别。偈曰

  自性及大愿　　不顾及不退
  闻深亦能化　　置彼于佛身
  亦行诸苦行　　不舍于生死
  生死不能染　　此十是差别

释曰。此二偈随其次第说无畏有十种差别。一者自性。谓性成就得无畏故。二者大愿。谓发菩提心得无畏故。三者不顾。谓勤自利时不顾身命得无畏故。四者不退。谓勤利他时有违逆者得无畏故。五者闻深。谓听实义时得无畏故。六者能化。谓难化众生以通力化得无畏故。七者置彼于佛身。谓建立众生于大菩提得无畏故。八者亦行诸苦行。谓行种种难行苦行得无畏故。九者不舍生死。谓故意受生得无畏故。十者生死不能染。谓处染不染得无畏故。问已说差别。云何坚固。偈曰

  恶朋及重苦　　闻深不能退
  譬如螽翅风　　不动须弥海

释曰。菩萨无畏于三缘得不动。一遇恶朋。二遭重苦。三闻深法。譬如螽蟴振羽不能荡海摇山。彼之三缘不能动菩萨心亦复如是。是故菩萨无畏得坚固。问已说坚固。云何殊胜。偈曰

  诸说无畏中　　菩萨无畏上
  相异坚殊胜　　与彼不相似

释曰。由前三义胜故。菩萨无畏于诸说无畏中最为殊胜。已说菩萨无畏。次说菩萨不退。偈曰

  不退诸菩萨　　品类有三事
  于闻进苦故　　惭勇为依止
  欲乐大菩提　　是说不退性
  未成成极成　　差别诸地显

释曰。此二偈显示不退品类依止自性差别。彼品类有三种。一闻法无厌不退。二恒大精进不退。三生死苦恼不退。依止有二种。一惭二勇。有惭者不退退者可羞耻故。有勇者不退。退者非猛健故。自性谓欲乐大菩提。欲乐若回即得退故。差别有三种。一未成。谓信行地菩萨不退。二成。谓初地至七地菩萨不退。三极成。谓八地已上菩萨不退。已说菩萨不退。次说菩萨知法。偈曰

  知法知法业　　知相知无尽
  得果及二门　　成生亦住法

释曰。知法者。谓知五明处。一内明。二因明。三声明。四医明。五巧明。知此五论是谓知法。知法业者。谓知自利利他。以此为业。知内论者。为自修及为他说。知因论者。为申己义及屈他义。知声论者。为自善音令他信受。知医论者。为除他疾。知巧论者。为令他解。知论相者。谓知此五论得有五因是菩萨知论相。一闻得。二持得。三诵得。四思得。五通得。菩萨先于论有闻。闻已受持。持已习诵。诵已正思。思已通达。通达者知此是功德此是过失此是善语此是恶语。知无尽者。谓如此知乃至无余涅槃亦无尽故。得果者。谓自知得一切种智故。二门者。一三昧门。二陀罗尼门。知论菩萨以三昧门成熟众生。随彼化摄故。以陀罗尼门成熟佛法。随所得法皆能持故。已说菩萨知法。次说菩萨知世间。偈曰

  身知亦口知　　及以实谛知
  菩萨知世间　　最胜余无等

释曰。菩萨有三种知世间。一身知世间。二口知世间。三谛知世间。问云何身知。云何口知。偈曰

  身知则舒颜　　口知则先语
  为令成器故　　正法随修行

释曰。舒颜者。谓熙怡欢笑。此是身知世间。先语者。谓慰问赞美。此是口知世间。问此知何所为。答为令成器故。问令成何器。答正法随修行令成此器故。问云何谛知世间。偈曰

  二知知世生　　二知知世灭
  为息复为得　　谛知勤修行

释曰。二知知世生者。知苦集二谛则知世间常生。由生及生方便故。二知知世灭者。知灭道二谛则知世间可灭。由灭及灭方便故。问知谛世间复何所为。答为息复为得谛智勤修行。息者苦集谛。得者灭道谛。诸菩萨为息苦集谛为得灭道谛故观诸谛修智具足。如是知世间。即是知世间业。已说菩萨知世间。次说菩萨修习四量。偈曰

  能诠及义意　　了义亦无言
  当知此四种　　是说四量相

释曰。能诠者。如来所说十二部经。此法为量。非人为量。义意者。谓文中所以。此义为量。非语为量。了义者。谓世间可信及佛所印可。此了义为量。非不了义为量。无言者。谓出世证智。此智为量。非识为量。问世尊何故说此四量。偈曰

  谤法及非义　　邪思与可言
  遮此四事故　　次第说四量

释曰。说能诠法为量遮谤说人说。义意为量遮非义文句说。了义为量遮邪思倒解说。智为量遮可言智。问依此四量有何功德。偈曰

  信心及内思　　正闻与证智
  菩萨不可坏　　依量功德尔

释曰。依第一量则信心不可坏。依第二量则正思不可坏。依第三量则正闻不可坏。依第四量则世智不可坏。已说菩萨修习四量。次说菩萨四无碍解。偈曰

  于门相言智　　通达无比伦
  此即是菩萨　　四种无碍解

释曰。第一者谓知门智。能知义中所有名门差别故。第二者谓知相智。能知此义属此名故。第三者谓知言智。能知异土言音故。第四者谓知智智。能知自能说法故。知此四种是无碍解。偈曰

  能说及所说　　说具合三事
  四二复二种　　次第三事因

释曰。能说所说说具。此三事各有因缘。能说有四因缘。一教授智。二成熟智。三聚满智。四令觉智。所说有二因缘。一法二义。四智于此二有用故。说具有二因缘。一言二智。由此二得成说故。偈曰

  举法及释法　　令解与避难
  建立四无碍　　以是义应知

释曰。举法者以门故。释法者以相故。令解者以言故。避难者以智故。应知此中以所说法及义以说具言及智。次第建立四无碍解。问云何名无碍解。无碍解有何业。偈曰

  内证及外觉　　故称无碍解
  能断一切疑　　此即是彼业

释曰。此偈上半立名。下半显业。名者。由诸菩萨初以出世间智内证诸法得平等如解。后以后得世智外觉诸法法门差别。由此道理故名无碍解。业者。复由此解能断一切众生一切疑网。此名为业。已说菩萨四无碍解。次说菩萨二聚功德。偈曰

  福智为二聚　　胜报亦不污
  一切诸菩萨　　胜相皆如此

释曰。福智为二聚者。二聚谓福聚及智聚。胜报亦不污者。诸菩萨由福聚故。于生死中作胜报成就因。由智聚故。于彼胜报作不染污因。是故菩萨胜相无等。问二聚摄六度云何偈曰

  初二为福体　　第六即是智
  余三二聚因　　五亦成智聚

释曰。初二为福体者。应知施戒二波罗蜜为福聚体。第六即是智者。应知般若波罗蜜即为智聚体。余三二聚因者。应知忍辱精进禅定三波罗蜜。通为二聚因。由俱作故。五亦成智聚者。复由般若能回向故。一切诸波罗蜜皆成智聚。问云何名聚。云何聚业。偈曰

  正修及数修　　资善名为聚
  自利与他利　　成就则名业

释曰。此偈上半释名。下半显业。名者。三婆罗名为聚。三者正修义。婆罗者数修义。由正修及数修善法则得资长。由资长故名聚。业者。由此聚故则能成就自他二利。是名为业。问二聚种差别云何。偈曰

  入地入无相　　及入无功用
  受职并究竟　　二聚次第因

释曰。此中种差别者。彼信行地聚为入地因。六地中聚为入无相因。无相者。第七地所摄聚。彼相不起故。第七地聚为入无功用因。第八第九地聚为入受职因。第十地聚为入究竟因。究竟者佛地所摄故。已说菩萨二聚功德。次说菩萨修习四念处。偈曰

  依止及对治　　入谛与缘缘
  作意并至得　　随顺亦随转
  觉境及受生　　限极将最上
  长时与后证　　胜修十四种

释曰。此二偈明菩萨四念处有十四种胜修。一依止胜修。二对治胜修。三入谛胜修。四缘缘胜修。五作意胜修。六至得胜修。七随顺胜修。八随转胜修。九觉境胜修。十受生胜修。十一限极胜修。十二最上胜修。十三长时胜修。十四后证胜修。依止胜修者。谓依大乘经起闻思修慧为自体故。对治胜修者。谓能对治不净苦无常无我法想四倒。由入身等法无我故。入谛胜修者。谓如其次第次第入苦集灭道谛故。自入他入。如中边分别论说。缘缘胜修者。谓缘一切众生身等为境界故。作意胜修者。谓身等不可得故。至得胜修者。谓身等不离不合故。随顺胜修者。谓得诸障对治能对治彼障故。随转胜修者。谓凡夫二乘所修念处亦摄随转为教授故。觉境胜修者。谓知身如幻色相似故。知受如梦皆邪觉故。知心如空自性净故。知法如客。客谓缠垢。譬如虚空有烟云尘雾故。受生胜修者。谓故意受生成就转轮王等最胜。身受心法亦不染故。限极胜修者。谓修下品念处亦过余人修最上品。自性利故。最上胜修者。谓能不作功用总别修习四念处故。长时胜修者。谓修至无余涅槃亦无尽故。后证胜修者。谓十地及佛地中皆可得故。已说菩萨修习四念处。次说菩萨修习四正勤。偈曰

  三舍及入地　　住寂与得记
  成生亦受职　　净土并圆满

释曰。菩萨为对治四念处障故修习四正勤。若广说此对治则有十种差别。由对治十行障故。十行者。一舍着行。谓受有中胜报而不染着。二舍盖行。谓离一切障盖。三舍下行。谓离二乘作意。四入地行。谓入初六地。五住寂行。谓入第七地。六得记行。谓入第八地。七成生行。谓入第九地。八受职行。谓入第十地。九净土行。谓第八第九第十三地。十圆满行。谓入佛地。菩萨为对治此十行障故修习四正勤。是为广说差别。问此十差别修义云何。偈曰

  依止于欲故　　起勤起精进
  摄心与正持　　十治修如是

释曰。修义者。谓依欲起勤。依勤起精进摄心正持。是名修义。此中有平等修。有有相修。有精进修。平等修者。由正勤能令止观平等故。有相修者。由止举舍三相合修故。精进修者。为断止观中没掉二障起精进故。问云何起精进。答谓摄心及正持。摄心者。谓奢摩他。正持者。若心平等则如是住如是正持。以此三修修前十行。是名修正勤。已说菩萨修习四正勤。次说菩萨修习四神足。偈曰

  分别四神足　　略以三事解
  依止及方便　　亦成就应知

释曰。此中略以三事分别四神足。一依止。二方便。三成就。问云何依止。偈曰

  禅定所依止　　差别有四足
  一欲二精进　　三心四思惟

释曰。应知禅波罗蜜所依止有此四足差别。问云何方便。偈曰

  起作及随摄　　系缚并对治
  随次八断行　　三一二二成

释曰。起作及随摄系缚并对治者。方便亦有四种。一起作方便。二随摄方便。三系缚方便。四对治方便。问此四种方便。各以何等行成。答随次八断行三一二二成。八断行者。一信二欲三勤四猗五念六智七思八舍。此中随其次第以信欲勤三行成立起作方便。由信起欲。由欲起勤。如是次第故。以猗一行成立随摄方便。由猗息已定得生故。以念智二行成立系缚方便。由正念故心于定中不离所缘。由正智故心离所缘觉已随摄。以思舍二行成立对治方便。由思故对治没缠。由舍故对治掉缠。此二是诸烦恼对治故。问云何成就。偈曰

  能见及能授　　游戏亦游愿
  自在并得法　　成就此六种

释曰。六成就者。一能见成就。二能授成就。三游戏成就。四游愿成就。五自在成就。六得法成就。能见成就者。谓五眼。肉眼天眼慧眼法眼佛眼此成就故。能授成就者。谓六通。依此能教授故。如其次第。身通往彼所。天耳通闻其音而为说法。他心通知障有无为之除断。宿住通知过去行借力令知使其生信。天眼通知死此生彼令其生厌。漏尽通为之说法令得解脱。游戏成就者。此有多种。谓变化等诸定。游愿成就者。谓入愿力游诸愿果。谓放光发声等。此不可数。广如十地经说。自在成就者。谓十自在。亦如十地经说。得法成就者。谓得力无所畏及不共法。已说菩萨修习四神足。次说菩萨修习五根。偈曰

  觉行闻止观　　信等根所缘
  增上是根义　　成就利益故

释曰。信根以菩提为所缘。进根以菩萨行为所缘。念根以闻大乘法为所缘。定根以奢摩他为所缘。慧根以如实智为所缘。问云何是根义。答此信等于所缘增上。故名为根。能成就利益故。已说菩萨修习五根。次说菩萨修习五力。偈曰

  应知信等根　　垂入于初地
  如前五根障　　能羸故名力

释曰。此中五根临入初地时。能令不信懈怠失念乱心无知羸劣。故名为力。已说菩萨修习五力。次说菩萨修习七觉分。偈曰

  菩萨入初地　　建立于觉分
  诸法及众生　　于此得平等

释曰。诸菩萨入初地时。觉彼法故建立觉分。问云何觉。答于一切法及自他身得平等解。如此名觉。如其次第。法无我及人无我故。偈曰

  譬如轮王行　　七宝为先导
  菩萨趣正觉　　七分常圆满

释曰。此明诸菩萨七觉分与转轮圣王七宝相似。问何分与何宝相似。偈曰

  念伏于诸境　　择法破分别
  进速无余觉　　明增喜遍身
  障尽猗而乐　　诸作从定生
  随时所欲住　　弃取皆由舍

释曰。第一念觉分与轮宝相似。未降国土轮能降故。未伏境界念能伏故。第二择法觉分与象宝相似。诸国勍敌象能摧故。分别胜怨择能破故。第三精进觉分与马宝相似。大地阔边马速穷故。真如极际进速觉故。第四喜觉分与珠宝相似。珠光烛幽王欢极故。法明破暗心喜满故。第五猗觉分与女宝相似。王受快乐女摩触故。智脱障恼猗息恶故。第六定觉分与藏臣宝相似。王有所须从臣出故。智有所用从定生故。第七舍觉分与兵宝相似。主兵阅众弃弱取强随转轮圣王所住不疲倦故。菩萨修行弃恶取善随无分别智所住无功用故。成立七觉分与七宝相似。其义如此。偈曰

  依止及自性　　出离与功德
  第五说不染　　此分有三种

释曰。七觉分如其次第。念是依止分。一切菩提分依此而行故。择是自性分。一切菩提以此为自体故。进是出离分。以此能令菩萨至究竟故。喜是功德分。以此能令心乐满故。猗定舍三是不染分。猗是不染因故。定是不染依止故。舍是不染自性故。已说菩萨修习七觉分。次说菩萨修习八正道分。偈曰

  一转如前觉　　立分二亦然
  次三三业净　　后三三障断

释曰。一转如前觉者。第一分。如前位中如实觉后时随转。说名正见。立分二亦然者。第二分。如前位中自所立分而解。入佛经中如佛所立为他分别。名正思惟。次三三业净者。次三谓正语正业正命。三业谓语业身业俱业。如其次第。以次三正摄此三业故。后三三障断者。后三谓正勤正念正定。三障谓智障定障自在障。如其次第。以后三正治此三障。由修正勤长时不退屈故智障断。由修正念掉没无体故定障断。由修正定胜德成就故自在障断。如是建立八正道分应知

大乘庄严经论卷第十大乘庄严经论卷第十一

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    觉分品第二十一之二

释曰。已说菩萨修习道分。次说菩萨修习止观。偈言

  安心于正定　　此即名为止
  正住法分别　　是名为观相

释曰。安心于正定此即名为止者。谓心依正定而不见。心非无正定而立止故。是名止相。正住法分别是名为观相者。谓依正住分别法体。是名观相。问此二行云何修。偈曰

  普欲诸功德　　是二悉应修
  一分非一分　　修有单双故

释曰。普欲诸功德是二悉应修者。若人遍欲求诸功德。是人于止观二行悉应修习。如经中说。佛告诸比丘。若有所求云何令得。诸比丘。离欲离恶不善法。乃至广说。诸比丘。有二法应须修习。所谓止观。一分非一分者。一分谓或止或观。非一分谓止观合。问何故。答修有单双故。单修者一分。或止修或观修。双修者非一分。谓止观合修。问此二行云何种差别。复云何业。偈曰

  能通及能出　　无相亦无为
  净土及净果　　是二即为业

释曰。此偈上半明种差别。下半明业。此二法在信行地名依止修。若入大地复有四种差别。一能通修。谓入初地。二能出修。谓入乃至六地。于彼六地出有相方便故。三无相修。谓入第七地。四无为修。谓入后三地。作功用修名有为。后三地不作功用故名无为。此五是种差别。净土者。依后三地修净土行。净果者。作转依行。此二净。即是彼业。已说菩萨止观。次说菩萨修习五种巧方便。偈曰

  自熟与成生　　速果并作业
  生死道不绝　　说此为五巧

释曰。五种巧方便者。一自熟佛法。以无分别智为巧方便。二成熟众生。以四摄法为巧方便。三速得菩提。以忏悔随喜请转法轮生起胜愿为巧方便。四作业成就。以二门为巧方便。二门者。谓陀罗尼门及三昧门以此二门能成就利益众生业故。五生死道不绝。以无住处涅槃为巧方便。问云何巧差别。云何巧业。偈曰

  菩萨巧无等　　差别依诸地
  能成自他利　　说是名为业

释曰。此偈上半明巧差别。下半明巧业。差别者。此五方便于诸菩萨最上无等。何以故。于诸地中不与二乘共故。是故差别。业者。能成就自身他身一切利益。是名为业。已说菩萨巧方便。次说菩萨陀罗尼。偈曰

  业报及闻习　　亦以定为因
  依止此三行　　持类有三种

释曰。陀罗尼品类有三种。一报得。由先世业力得故。二习得。由现在闻持力而得故。三修得。由依定力得故。问云何种差别。偈曰

  二小一为大　　一大复三种
  地前与地上　　不净及净故

释曰。二小一为大者。于彼三种品类中。报得及习得。应知此二为小。修得者。应知此一为大。一大复三种者。于彼大种类中。应知复有三种。谓软中上。未入地菩萨所有为软。以入不净地菩萨所有为中。谓初七地。入清净地菩萨所有为上。谓后三地。问云何业。偈曰

  应知诸菩萨　　恒依陀罗尼
  闻法及持法　　作业皆如是

释曰。此中应知。诸菩萨依止陀罗尼恒开示妙法及常受持。以此为业。已说菩萨陀罗尼。次说菩萨起诸愿。偈曰

  思欲共为体　　智独是彼因
  诸地即为地　　二果亦为果
  应知差别三　　种种大清净
  此业有二种　　自利与利他

释曰。此二偈以六义分别诸愿。一自性二因三地四果五差别六业。彼思欲相应共为自性。以智为因。诸地为地。二果为果。谓即果及未来果。以诸愿为因。心得遂故。心遂者。如心所欲皆成就故。又以愿力游诸愿果。所谓身放光明口发音响乃至广说。差别有三种。一种种。谓信行地愿如是如是欲得故。二广大。谓入地菩萨十大愿故。三清净。谓后后诸地转转清净。乃至佛地极清净故。是名差别。彼业二种。一自利成就。二利他成就。是名为业。已说菩萨诸愿。次说菩萨修习三三昧。偈曰

  应知二无我　　及以二我依
  二依常寂灭　　三定所行境

释曰。三三昧有三种所行。一人法。二无我。是空三昧所行。二彼二执所依五取阴。是无愿三昧所行。三彼依毕竟寂灭。是无相三昧所行。彼三种所取体为三种境界。彼三种能取体为三种三昧。是名三三昧。问三三昧名义云何。偈曰

  空定无分别　　无愿厌背生
  无相恒乐得　　彼依常寂灭

释曰。空定无分别者。无分别义是空三昧义。由人法二我不分别故。无愿厌背生者。厌背义是无愿三昧义。由厌背我执所依故。无相恒乐得彼依常寂灭者。乐得义是无相三昧义。由乐得彼所依毕竟寂灭故。问三三昧云何起。偈曰

  应知及应断　　及以应作证
  次第空等定　　修习有三种

释曰。应知及应断及以应作证者。应知谓人法二无我。应断谓二我执所依。应证谓彼依毕竟寂灭。次第空等定修习有三种者。此中为知人法二无我故修空三昧。为断彼二执所依故修无愿三昧。为证彼依毕竟寂灭故修无相三昧。已说菩萨修习三三昧。次说菩萨四法忧陀那。偈曰

  如前三三昧　　四印为依止
  菩萨如是说　　为利群生故

释曰。四法印者。一者一切行无常印。二者一切行苦印。三者一切法无我印。四者涅槃寂灭印。此中应知。无常印及苦印为成无愿三昧依止。无我印为成空三昧依止。寂灭印为成无相三昧依止。菩萨说此四印为三三昧依止。皆为利益诸众生故。问何等是无常义乃至何等是寂灭义。偈曰

  无义分别义　　不真分别义
  息诸分别义　　是名四印义

释曰。此中诸菩萨以无义是无常义。由分别相毕竟常无故。以分别义是无我义。由分别相唯有分别。此二是分别相。由无体故。不真分别义是苦义。由三界心心法为苦体故。此是依他相。息诸分别义是寂灭义。此是真实相。复次应知依他相。复以刹那刹那坏为无常义。问云何成立刹那坏义。偈曰

  由起及从因　　相违亦不住
  无体与相定　　随转并灭尽
  变异因亦果　　执持与增上
  随净及随生　　成义有十五

释曰。此二偈以十五义成立刹那刹那灭义。一由起。二从因。三相违。四不住。五无体。六相定。七随转。八灭尽。九变异。十因。十一果。十二执持。十三增上。十四随净。十五随生。由此十五义刹那坏义可得成立。第一由起者。诸行相续流名起。若无刹那刹那灭义。而有诸行相续流名起者不然。若汝言物有暂时住后时先者灭后者起名相续者则无相续。由暂住时后起无故。第二从因者。凡物前灭后起必籍因缘。若离因缘则无体故。若汝言彼物初因能生后时多果者不然。初因作业即便灭尽。岂得与后诸果作因。若汝言初因起已更不起者。建立此因复何所用。若汝言起已未灭后时方灭者。彼至后时谁为灭因。第三相违者。若汝复执是能起因复为灭因者不然。起灭相违同共一因无此理故。譬如光暗不并冷热不俱。此亦如是。是故起因非即灭因。若如汝执诸行起已非即灭者。则违阿含及道理。违阿含者。佛语诸比丘。诸行如幻是坏灭法。是暂时法刹那不住。违道理者。诸修行人于诸行生灭中思惟刹那刹那灭。若不如是于临终时见彼灭相则无厌恶离欲解脱。是则同余凡夫。第四不住者。若汝言诸行起已得有住者。为行自住得因他住。若行自住何故不能恒住。若因他住彼住无体。何所可因。二俱不尔。是故刹那刹那灭义得成。第五无体者。若汝执住因虽无坏因未至。是故得住。坏因若至后时即灭。非如火变黑铁者不然。坏因毕竟无有体故。火变铁譬我无此理。铁与火合黑相似灭赤相似起。能牵赤相似起是火功能。实非以火变于黑铁。又如煎水至极少位后水不生亦非火合水方无体。第六相定者。佛说有为法有为相一向决定所谓无常。汝执诸行起已非即灭者。是有为法则有少时而非无常。便堕非一向相。第七随转者。若汝言若物刹那刹那新生者云何于中作旧物解。应说由相似随转得作是知。譬如灯焰相似起故起旧灯知而实差别前体无故。第八灭尽者。若汝言云何得知后物非前。应说由灭尽故。若住不灭则后刹那与初刹那住无差别。由有差别故知后物而非前物。第九变异者。若汝言物之初起非即变异者不然。内外法体后边不可得故。由初起即变渐至明了。譬如乳至酪位酪相方现。而变体微细难可了知。由相似随转谓是前物。以是故刹那刹那灭义得成。第十因者。若汝许心是刹那灭。彼心起因谓眼色等诸行。彼果刹那灭故因亦刹那。由不可以常因起无常果故。第十一果者。彼眼等诸行亦是心果。是故刹那灭义得成。由不可以无常因起常果故。第十二执持者。若汝言云何得知眼等诸行亦是心果。应说由心执持得增长故。第十三增上者。又如佛说。心将世间去。心牵世间来。由心自在世间随转。识缘名色此说亦尔。故知诸行是心果。第十四随净者。净是禅定人心。彼人诸行随净心转。如经中说。修禅比丘具足神通心得自在。若欲令木为金则得随意。故知诸行皆是心果。第十五随生者。如作罪众生所得外物一切下劣。作福众生所得外物一切妙好。故知诸行皆是心果。因是刹那果非刹那无此道理。由因自在故。如是总成立一切内外诸行是刹那已。次别成立内法是刹那。偈曰

  初起及续起　　长起及依起
  变起与熟起　　劣起亦胜起
  明起无明起　　及以异处起
  种起无种起　　像起十四起

释曰。此二偈以十四种起成立内法诸行是刹那义。一者初起。谓最初自体生。二者续起。谓除初刹那余刹那生。三者长起。谓眠食梵行正受长养故生。四者依起。谓眼等诸识依止眼等根生。五者变起。谓贪等染污令色等变生。六者熟起。谓成胎婴儿童子少壮中年老位等生。七者劣起。谓诸恶道生。八者胜起。谓诸善道生。九者明起。谓欲界后二天及色界无色界一切天生。十者无明起。谓除前明处所余诸处生。十一者异处起。谓此处死彼处生。十二者种起。谓除阿罗汉最后五阴生。十三者无种起。谓前所除最后五阴生。由后生种子无故。十四者像起。谓入解脱禅者定自在力故诸行像生。问复以何因成立此十四种起。偈曰

  续异及断异　　随长亦随依
  住过及去过　　无住无无死
  亦有随心相　　行者应当知
  如此九种因　　成前十四起

释曰。此二偈以九种因成立。前十四起。九种因者。一续异。二断异。三随长。四随依。五住过。六去过。七无住。八有死。九随心。第一续异者。此因成立第一初起。若最初起时因体无差别者。则后时诸行相续而起亦无差别。因体无差别故。由因有差别故。后余诸行刹那得成。第二断异者。此因成立第二续起。若一一刹那无差别因者。则后时断差别亦不可得。由断有差别故。诸行刹那此义得成。第三随长者。此因成立第三长起。能令诸行圆满故名为长。若无刹那而有诸行长养者不然。由彼住故。若诸行得住则不得渐大圆满。非谓长养。第四随依者。此因成立第四依起。若执能依不住所依得住者不然。如人乘马人去马不去无有此理。如是识依于根。识有刹那。依无刹那不然亦尔。第五住过者。此因成立六起。谓变起熟起劣起胜起明起无明起。成立变起熟起者。若执诸行初起即住不灭者不然。无变起故。谓贪等变色永不可得。由初无变后亦尔故。若初无变后诸熟位亦不可得。由先有变后方熟故。成立劣起胜起刹那亦尔。若执诸行得住而有善恶熏习次第与果者不然。诸行不住次第相续各得与果。此义可尔。成立明起无明起刹那亦尔。若诸行得住则明起亦无不住则有。由心转故。无无明起亦尔。后时无变异故。第六去过者。此因成立第十一异处起。若执诸行往余处名去者不然。我今问汝。诸行去作为起已将诸行往余处。为不起将诸行往余处。若起已将往者此处起已余处不起此即是住。而言去者是义相违。若不起将往者不起则本来无去。而言去者此语无义。又复若诸行去作住此处。即作所作令诸行去。是亦不然。住则不得到余处故。若诸行到余处方作所作。是亦不然。无有离去而有诸行到余处故。若此处住若余处住。离诸行外毕竟求作不可得。是故不异诸行相续而有去。作去既无体则刹那义成。若汝言若实无去云何世人见去。应说由无间相续假说名去实无去体。若汝言复有何因诸行得相续去。应说因缘无量。有心力自在如威仪等去。有宿业自在如中阴中去。有手力自在如放箭掷石去。有依止自在如乘车乘船去。有使力自在如风吹物去。有自体自在如风性傍去火性上去水性下去。有术力自在如依咒依药在空而去。有磁石自在能令铁去。有通力自在如乘通去。如是等有无量因缘。能令诸行相续假说名去。是义应知。第七无住者。此因成立第十二种起。若诸行得住。余时更有种子起者不然。刹那刹那无余因故。若诸行不住后种子起是义可然。第八有死者。此因成立第十三无种起。若无刹那而有死时无种起者不然。先有种起后命终时方无种起。是亦不然。由一一刹那因无体故。是故死心刹那不可得成。第九随心者。此因成立第十四像起。由心自在刹那刹那彼像得起。若无刹那而像得起无此理故。问如是别成立内有为法刹那已。复有何因能成立外法四大及六种造色是刹那耶。偈曰

  由滋及由涸　　性动增亦减
  二起与四变　　薪力及渐微
  亦说随心起　　及以难问成
  一切诸外法　　无非刹那体

释曰。此二偈以十四因成立外法是刹那。水有二因。一滋二涸。若无刹那水或时滋长或时干涸不可显现。若人作如是问既无刹那水有何因而滋。复有何因而涸。彼则不能答。今见水有滋涸。故知刹那是水滋涸因。风有三因。一性动二增盛。三减息。若风性住则无动时。行无体故。亦无增盛亦无减息。由彼住故。地有六因。谓二起四变。二起者。由水由风地起可得。谓劫生时。彼地是水风果。故知地亦是刹那。四变者。由四所作地变可得。一业力所作。由众生业力有差别故。二人功所作。由掘凿等故。三诸大所作。由火水风故。四时节所作。由时改转异相现故。若无刹那四变不可得。因无体故。如地有六因。知是刹那。色香味触六因亦尔。是故亦是刹那。火有一因。所谓薪力。薪力火增故火得起。已共火起薪即不得住。火烧薪已火亦不住。若火不由薪。后时无薪火应久住。由随同义故火。声在后说声有一因。所谓渐微譬如钟声后时渐微可得。若无刹那后时小声无可得。理法入色有一因谓随心起。如受戒时随心下中上。起心因刹那故。彼果亦刹那。是故外法刹那亦成。复次总由难问故。我今问汝。何故欲得诸行无常不欲得诸行刹那灭。若汝言一一刹那灭不可知者不然。譬如灯焰。于不动位彼刹那亦不可知。汝何故不欲令彼体无刹那。若汝言灯焰体有刹那细故不可觉者。诸行亦尔。何故不欲令有刹那。若汝言灯焰与诸行不相似者不然。不相似有二种。一自性不相似。二时分不相似。若此自性不相似者。此譬得成。非自体为譬故。非如以灯喻灯以牛喻牛譬则不成。若取时分不相似者。此譬亦成。由灯焰及诸行皆刹那相似故。若非刹那譬则不成。今更问汝。如人乘乘。其乘住时其人去不。答不。若尔者所依根住能依识去。亦无道理。若汝言何故现见灯焰念念灭。灯炷如是住。应说汝见非见。由炷相续刹那刹那有坏有起汝不如实知故。若汝言诸行刹那如灯焰者世人何故不知。应说由诸行是颠倒物故相续刹那随转。此不可知而实别别起。世人谓是前物生颠倒知。若不尔则无无常常倒。倒体若无染污亦无。复从何处而有解脱。由是难问则诸行刹那成。成立无常义已。次成立无我义。问人者为可说有为可说无。偈曰

  人假非实有　　言实不可得
  颠倒及染污　　染因成立故

释曰。人假非实有者。可说人是假名有非实体有。若如此则不堕一向执。离有无故。问人是实有云何知无。答言。实不可得。由彼人不如色等有实可得非觉智证故。问人非觉智不证。佛又说我者现在可得。汝言不可得者不然。答此言可得非实可得。由颠倒故。佛说无我计我。是名颠倒问云何知是颠倒。答由染污故。身见是染污。所谓我我所执。若不颠倒则非染污。问云何知我执是染污。答染污因故。由我执为因贪等染污得起。是故知是染污。问如汝所许于色等五阴说人假有。此人与阴为一为异。偈曰

  假人与实阴　　不可说一异
  若说一异者　　则有二过生

释曰。假人与阴不可说一不可说异。若说一异二过则生。二过者。若说人与阴一。阴即是人及人是实。若说人与阴异。阴虽非人人亦是实。以是故。人是施设有。一异不可说。是故如来止记论成。偈曰

  若执人是实　　一异应可说
  一异不可说　　此说则无理

释曰。若人违大师教执有实人。是实人与阴一异则应可说。而执与阴一异不可说。此说则无道理。若汝言人不可说如火与薪非异非不异者不然。偈曰

  异相及世见　　圣说亦不然
  火薪非不说　　有二可得故

释曰。异相者。火谓火大。薪谓余大。各有别相。是故火与薪异。世见者。世人离火见薪。谓可烧木等。亦离薪见火。如风吹焰去。是故火与薪异。圣说亦不然者。佛世尊无处说。火之与薪一异不可说。是故汝执火薪一异不可说。此说无道理。若汝言非离薪见火风即是薪者不然。有二可得故。由火之与风二相别故。复次偈曰

  二有故识起　　人缘则非义
  好灭及恶生　　言生复非理

释曰。若人执人有实。谓见者闻者觉者识者食者知者说者。若尔彼眼等识起。为以人为缘说人是作者。为以人是主说人是作者。若以人为缘者。二有故识起人缘则非义。由人于识起中无有少力可见故。若以人是主者。好灭及恶生言生复非理。若人为主。已生所爱识。应毕竟令不灭。不应令灭。未生不爱识。应毕竟令不生。不应令生。以是故。汝不应执人是见者乃至识者。复次偈曰

  汝执实人中　　何业可成立
  无实强令实　　违佛三菩提

释曰。若人是实有。汝以何业可得成立。凡是实有必有事业。如眼等净色以见等事业可得成立。人无是等事业可得成立。是故人非实有。复次汝于无实人中强欲令有实人。即违如来三种菩提。一者甚深菩提。二者不共菩提。三者出世菩提。若见实人。则非甚深菩提。则非不共外道菩提。则非世间不习菩提。是故此执是世间所取。是外道着处。是生死。恒习。复次若人是见者乃至识者眼等诸根为有功用为无功用。若有功用为自然起为由人起。问彼何所疑。偈曰

  若用自然起　　即有三过生
  若以人为缘　　眼等则无用

释曰。若言眼等功用自然起者。人于眼等不作事业则有三种过生。若言以人为缘功用得起者。眼等诸根则一向无有功用。问何者是功。用自然起三过。偈曰

  人非作者故　　用非常起故
  起非一时故　　自起则不然

释曰。若眼等功用不待人作自然而起。则人非作者。云何名见者乃至识者。此是第一过失。若眼等功用自然起则应常起。不应起时非常。此是第二过失。若眼等功用常起则起应一时。云何不得并起。此是第三过失。由此义故。若言自然起者不然。问以人为缘复有何过。偈曰

  人住用先无　　人坏则人断
  更有第三体　　为缘无此义

释曰。若言人住与功用为缘者。人既常有。何故功用先无后有。是义不然。若言人坏为缘者。人坏则堕无常。是亦不然。若言更有第三不住不坏人为缘者。无有此义。如是依道理说实人不可得。复次偈曰

  诸法无我印　　及说真实空
  有我有五过　　是故知无我

释曰。法印经中佛说。一切法无我。真实空经中佛说。有业有报作者不可得。舍前阴起后阴。起灭唯法。增五经中说。若执有我有五过失。一者堕于见处起我见命者见。二者同于外道。三者僻行邪行。四者。于空不欲不信不住。五者圣法不得清净。如是依阿含说。有实人亦不可得。问若无实人。云何世尊处处经中而说有人。谓知者负担者及建立随信行等人耶偈曰

  由依染净法　　位断说有异
  行异相续异　　无实假说人

释曰。由依染污法及清净法。有位差别及断差别。故建立假人有差别。若无假人差别则不可说有行差别及相续差别。如知经中说。何等诸法谓染污法。何等为知谓清净法。如负担经中说。何者负担谓染污法。何者弃担谓清净法。若无行差别及相续差别则不可说。此二法为知者负担者。菩提分法多位差别。谓方便道见道修道究竟道。若无行及相续差别则不可说。彼菩提分法有随信行等人差别。由无实人。约法差别可得假说。以此道理。故知所说但是假人。若佛意不说是假人说实人则无用。由起众生我见故。偈曰

  不为起我见　　由见已起故
  无始已习故　　无用应解脱

释曰。佛不应为起众生我见说有实人。由众生我见先已起故。亦不为令众生数习我见说有实人。由众生我见先已习故。亦不为令我见众生得解脱故说有实人。一切无功用者。皆应自然得解脱故。以是故一切未见谛者。有我见而无解脱。非如苦体先时不见后时方见。人不如是。非先不见后时方见。又如苦体先时不见后亦不见。即无解脱人体亦尔。先时亦见后时亦见。则无解脱。若实有我则决定有我所。从此二执即起我爱及余烦恼。如是则无解脱。以是故不应欲得有实人。以我见等过皆悉起故。如是别说菩提分已。次总结前义。偈曰

  惭羞等功德　　菩萨常具足
  自利既不舍　　亦令他利成

释曰。此义如前所显略说。觉分品究竟

大乘庄严经论卷第十一大乘庄严经论卷第十二

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    功德品第二十二

释曰。已说菩萨诸觉分。次说菩萨诸功德。偈曰

  舍身及胜位　　忍下亦长勤
  不味不分别　　六行说希有

释曰。此偈显示行希有。檀行者。若能施自身命。则为希有。余非希有。戒行者。若能弃舍胜位慕道出家。则为希有。余非希有。忍行者。若能不顾身命忍于下劣众生。则为希有。余非希有。精进行者。若能长时正勤乃至穷生死际而不断绝。则为希有。余非希有。禅行者。若能于胜定乐而不啖味不彼受生。则为希有。余非希有。慧行者。若能起无分别智。则为希有。余非希有。若声闻人分别四谛而有厌离。菩萨则不尔。是名六种行希有。偈曰

  生在如来家　　得记并受职
  及以得菩提　　四果说希有

释曰。此偈显示果希有。菩萨有四种果。一者入初地时生如来家。是须陀洹果。二者于第八地中而得授记。是斯陀含果。三者于第十地中而得受职。是阿那含果。四者佛地。是阿罗汉果。前三是学果。第四是无学果。已说菩萨希有。次说菩萨非希有。偈曰

  离欲与得悲　　胜修及平等
  依此修诸度　　是行非希有

释曰。若菩萨已得离欲而行布施非为希有。不染于物物易舍故。若菩萨已得大悲而持戒忍辱非为希有。若菩萨已得胜修。谓第八地。由无功用无分别故。行后三度非为希有。若菩萨已得自他平等心行一切诸度亦非希有。由利他时即如自利。无有退屈心故。已说菩萨非希有。次说菩萨平等心。偈曰

  菩萨爱众生　　不同生五爱
  自身与眷属　　子友及诸亲

释曰。此偈显示菩萨于诸众生得平等心。众生有五种爱心不得平等。一爱自身。二爱眷属。三爱儿子。四爱朋友。五爱诸亲。由此五爱不得平等亦非毕竟。如人或时亦行自害。菩萨爱众生心则平等。由不舍不退故。偈曰

  无偏及无犯　　遍忍起善利
  禅亦无分别　　六度心平等

释曰。此偈显示菩萨行六度得心平等。无偏者。是布施心平等。于诸求者不堕爱憎故。无犯者。是持戒心平等。乃至微细戒行亦不缺故。遍忍者。是忍辱心平等。普于胜劣众生皆能忍故。起善利者。是精进心平等。为起一切善根及起自他一切种利而勤行故。禅亦者。是学定心平等。菩萨修定亦为起诸善根及为起诸利益而精进故。无分别者。是修慧心平等。从初发心乃至究竟所行诸度皆三轮清净故。是名诸度心平等。已说菩萨平等心。次说菩萨饶益众生事。偈曰

  令器及令禁　　耐恶与助善
  入法亦断疑　　六行饶益事

释曰。此偈显示诸菩萨以六波罗蜜饶益诸众生。令器者。以施饶益。令彼得成修善器故。令禁者。以戒饶益。随其堪能而令持故。耐恶者。以忍饶益。能受众生违逆事故。助善者。以进饶益。佐助众生营善业故。入法者。以定饶益。回邪入正通力能故。断疑者。以智饶益。若凡若圣所有疑网皆除故。已说菩萨六度饶益。次说菩萨七似饶益。一似母饶益。二似父饶益。三似善友饶益。四似同侣饶益。五似健奴饶益。六似阇梨饶益。七似和上饶益。问云何似母饶益。偈曰

  等心生圣地　　长善防诸恶
  教习以多闻　　五业如慈母

释曰。譬如慈母于子作五种饶益业。一怀胎。二出生。三长养。四防害。五教语。菩萨饶益众生五业亦尔。一等心向众生。二生之于圣地。三长养诸善根。四防护诸恶作。五教习以多闻。是名菩萨五种似母业。问云何似父饶益。偈曰

  令信令戒定　　令脱令劝请
  亦为防后障　　五业如慈父

释曰。譬如慈父于子作五种饶益业。一下种子。二教工巧。三为娉室。四付善友。五为绝债不令后偿。菩萨五业亦尔。一令起信以为圣体种子。二令学增上戒定以为工巧。三令得解脱喜乐以为娉室。四令劝请诸佛以为善友。五为遮诸障阂以为绝债。是名菩萨五种似父业。问云何似善友饶益。偈曰

  秘深及呵犯　　赞持与教授
  令觉诸魔事　　五业如善友

释曰。譬如善友于己作五种饶益业。一密语为覆。二恶行令断。三善行称誉。四所造佐助。五遮习恶事。恶事四种。一射猎。二奸非。三耽酒。四博戏。菩萨五业亦尔。一非器者秘其深说。二犯戒者如法呵责。三具戒者以善称誉。四修行者教令速证。五魔事者即令觉知。是名菩萨五种似善友业。问云何似同侣饶益。偈曰

  与乐及与利　　乐恒利亦恒
  及以不离散　　五业如同侣

释曰。譬如有智同侣于己作五种饶益业。一与乐。二与利。三恒与乐。四恒与利。五不乖离。菩萨五业亦尔。一与不颠倒乐。世间成就者名乐。由此得乐受故。二与不颠倒利。出世成就者名利。由此对治烦恼病故。余三可解。是名菩萨五种似同侣业。问云何似健奴饶益。偈曰

  成生开出要　　忍害与二成
  示以巧方便　　五业如健奴

释曰。譬如健奴为主作五种饶益业。一极诸所作。二得不欺诳。三忍诸打骂。四作事精好。五解巧方便。菩萨五业亦尔。一成熟众生。二开示出要。三忍诸恶事。四与世间乐。五与出世利。是名菩萨五种似健奴业。问云何似阇梨饶益。偈曰

  遍授及示要　　舒颜亦爱语
  不求彼恩报　　五业如阇梨

释曰。得无生忍者说为阇梨。譬如阇梨于弟子作五种饶益业。一教其诸法。二示其速要。三身知舒颜。四口知爱语。五心无悕望。菩萨五业亦尔应知。问云何似和上饶益。偈曰

  令满及令脱　　断障与世乐
  及与出世利　　五业如和上

释曰。譬如和上于弟子作五种饶益业。一度令出家。二与其受戒。三禁断诸过。四摄持以财。五教授以法。菩萨五业亦尔。一令满二聚。二令得解脱。三令断诸障。四与世间乐。五与出世利。是名菩萨五种似和上业。已说菩萨七似饶益。次说众生六种报恩。偈曰

  不着及不犯　　知作亦善行
  如是修六度　　是报菩萨恩

释曰。如菩萨饶益众生。众生报菩萨恩亦如是。不著者。布施报恩。不犯者。持戒报恩。知作者。修忍报恩。菩萨爱忍彼知而作。即是报恩。善行者。行余三度报恩。以精进行定慧即得解脱故。后三度合名善行。已说众生六种报恩。次说菩萨五种希望。偈曰

  六增及六减　　成生与进地
  大觉是五处　　希望有五种

释曰。诸菩萨于五处常起希望。一希望六度增长。二希望六蔽损减。三希望成熟众生。四希望胜进诸地。五希望无上菩提。是名五种希望。已说菩萨五种希望。次说菩萨四种不空果。偈曰

  断怖与发心　　除疑亦起行
  四事化众生　　必定不空果

释曰。诸菩萨四业利益。众生必不空果。一为说深法必得不怖。二令发菩提心必得佛果。三为之断疑必无重起。四为说六度必能修习。是名四业不空果。已说菩萨四种不空果。次说菩萨六种正行。偈曰

  离求离后有　　遍起诸功德
  修禅舍无色　　智合方便行

释曰。离求者。布施正行不望报故。离后有者。戒忍正行不求后有故。遍起诸功德者。精进正行。修禅舍无色者。禅定正行。智合方便行者。般若正行。三轮清净为般若。回向菩提为方便。如宝积经说。施不求报如是广说。已说菩萨六种正行。次说菩萨六度进退分。偈曰

  着财与毁禁　　慢下将堕善
  啖味亦分别　　是退翻为进

释曰。六度所对治是退分因。翻彼所对治。即是能对治。应知即是进分因。已说菩萨六度进退分。次说菩萨六度真似功德。偈曰

  假许及诈相　　诳喜亦伪勤
  身静口善说　　是似翻即真

释曰。假许者是似布施。谓语求者言所有恣取而彼来即吝。诈相者是似持戒。谓覆藏诸恶而诈善威仪。诳喜者是似忍辱。谓甘言虚悦而规害待时。伪勤者是似精进。谓虚说我求佛果而实心希世报。身静者是似禅定。谓身口端默而恶觉扰心口。善说者是似般若。谓为他巧说而身自不行。此六是不真行。翻此不真行即为真行。已说菩萨真似功德。次说菩萨为众生除六蔽。偈曰

  与彼六度行　　除彼六蔽障
  菩萨化众生　　地地皆如是

释曰。众生有六蔽能障彼六波罗蜜。所谓悭贪破戒嗔恚懈怠乱心愚痴。菩萨如其次第。给其所须令行布施。乃至令行般若。使彼众生得除六障。即是与施乃至与智。已说菩萨除众生六蔽。次说诸佛授菩萨记。偈曰

  授记有二种　　人别及时别
  转记及大记　　此复为二种

释曰。授记有二种。一人差别。二时差别。人差别授记有四种。一未发心授记。谓性位。二已发心授记。三现前授记。四不现前授记。时差别授记有二种。一有数时授记。二无数时授记。复次更有二种授记。一转授记。二大授记。转授记者。谓记彼菩萨后于如是如来如是时节当得授记。问云何大授记。偈曰

  八地得无生　　断慢断功用
  诸佛及佛子　　一体同如故

释曰。大授记者。谓在第八地中得无生忍时。由断自言我当作佛慢故。及断一切分别相功用故。得一切诸佛菩萨同一体故。问云何同一体。答不见诸佛诸菩萨与自己身而有差别。何以故。同一如故。偈曰

  刹土及名号　　时节与劫名
  眷属并法住　　记复有六种

释曰。复有此六种授记。一者于如是刹土。二者有如是名号。三者经如是时节。四者有如是劫名。五者得如是眷属。六者如是时节正法住世。已说诸佛授记。次说菩萨六种决定。偈曰

  财成及生胜　　不退与修习
  定业无功用　　六事决定成

释曰。菩萨由六度增上得六种决定。一者财成决定。由施常得大财成就故。二者生胜决定。由戒常得随意受生故。三者不退决定。由忍诸苦常不退故。四者修习决定。由进恒时习善无间息故。五者定业决定。由禅成就众生业永不退故。六者无功用决定。由智得无生忍无分别智自然住故。已说菩萨六种决定。次说菩萨六种必应作。偈曰

  供养及学戒　　修悲亦勤善
  离諠深乐法　　六事必应作

释曰。诸菩萨为成就六度故。于诸地中决定应作六事。一者必应供养。此为成就檀度。若不长时供养则檀度不得圆满。供养义如供养品说。二者必应学戒。此为成就戒度。若不长时学戒则戒度不得圆满。三者必应修悲。此为成就忍度。若不长时忍诸不饶益事则忍度不得圆满。四者必应勤善。此为成就进度。若心放逸不修诸善则进度不得圆满。五者必应离諠。此为成就禅度。若在聚落多诤扰心则禅度不得圆满。六者必应乐法。此为成就智度。若不遍历诸佛听法无厌。如海纳流无时盈溢。则智度不得圆满。已说菩萨六种必应作。次说菩萨六种必常作。偈曰

  厌尘及自省　　耐苦修善法
  不味不分别　　六行必常起

释曰。诸菩萨为成就六度故。必应常作六事。一者厌尘。谓知五欲过失。譬如粪秽虽少亦臭。布施果报虽多亦苦。由不着故能行三施。此事常修则檀度圆满。二者自省。谓昼夜六时常自省察所作三业。知过则改。此事常修则戒度圆满。三者耐苦。若有他来作诸不饶益事。及自求法忍诸寒热等苦。此事常修则忍度圆满。四者修善。善谓六波罗蜜。于诸地中此事常修则进度圆满。五者不味。谓不啖禅中胜乐恒来欲界受生。此事常修则禅度圆满。六者不分别。谓于三轮异相不起分别。此事常修则智度圆满。已说菩萨六种必常作。次说菩萨六度胜类。偈曰

  法施及圣戒　　无生起大乘
  定悲如实智　　六行此为胜

释曰。施有多种。以法施而为最上。戒有多种。以圣人所爱无流戒而为最上。忍有多种。以八地无生忍而为最上。精进有多种。以起大乘度脱众生而为最上。定有多种。以出世第四禅与大悲合者而为最上。智有多种。以如实通达诸法智而为最上。已说菩萨六度胜类。次说四种假建立。偈曰

  立法及立谛　　立理亦立乘
  五七四三种　　建立假差别

释曰。四种假建立者。一法假建立。二谛假建立。三道理假建立。四乘假建立。问各有几种。答法假建立有五种差别。谛假建立有七种差别。道理假建立有四种差别。乘假建立有三种差别。法假建立五种者。偈曰

  所谓五明处　　皆是大乘种
  修多祇夜等　　类有差别故

释曰。法假建立五种。即是五明论。此五皆是大乘修多罗祇夜等种类差别。五明处如觉分品说。谛假建立七种者。偈曰

  轮转及空相　　唯识与依止
  邪行亦清净　　正行如七种

释曰。七种差别即是七如。一轮转如。二空相如。三唯识如。四依止如。五邪行如。六清净如。七正行如。轮转如者谓生死。即是三界心心法。此从分别起。此分别复从因缘起。不从自在等因生。亦非无因生。由分别境界空故。一切时但有分别依他二性轮转。空相如者谓法无我。一切诸法同一空如以为相故。唯识如者谓无分别智。依止如者谓苦谛。此有二种。一器世间。二众生世间。邪行如者谓集谛。此即是爱。清净如者谓灭谛。此有二种。一烦恼障净。二智障净。正行如者谓道谛。如此七种如名谛假建立。此中应知三种如是分别依他二性。谓轮转如依止如邪行如。四种如是真实性。谓空相如唯识如清净如正行如故。分别依他二性摄者即是世谛。真实性摄者即是真谛。道理假建立四种者。偈曰

  正思正见果　　择法现等量
  亦说不思议　　道理有四种

释曰。道理假建立有四种。一相待道理。二因果道理。三成就道理。四法然道理。相待道理者。所谓正思。由待正思出世正见方始得起。离正思惟更无别方便故。因果道理者。所谓正见及果。成就道理者。所谓以现等量简择诸法。法然道理者。所谓不可思议处。此法已成故如。问何故正思能起正见。此已成就不应更思。何故正见能断烦恼及得于灭。此已成就不可更思。诸如是义悉是法然道理。如此四种名道理假建立。乘假建立三种者。偈曰

  心说行聚果　　五各下中上
  依此三品异　　建立有三乘

释曰。依五义三品建立三乘。五义者。一心二说三行四聚五果。三品者。谓下中上。若声闻五事俱下。心下者求自解脱。说下者说自利法。行下者行自利行。聚下者福智狭小但三生等。果下者得声闻果。若缘觉乘五事俱中。若菩萨乘五事俱上。心上者谓四种恩心。如金刚波若经说。说上者如其恩心作如是说法。行上者如其说法作如是行行。聚上者如其行行得如是聚满。果上者如其聚满得无上菩提。复次若声闻乘从他闻法内自思惟。以分别智得果。若缘觉乘不从他闻内自思惟。亦以分别智得果。若菩萨乘不从他闻。以无分别智得果。此三种名乘假建立。已说四种假建立。次说菩萨四种求知。偈曰

  名物互为客　　二性俱是假
  二别不可得　　是名四求义

释曰。诸菩萨四种求诸法。一名求。二物求。三自性求。四差别求。名求者。推名于物是客。此谓名求。物求者。推物于名是客。此谓物求。自性求者。推名自性及物自性知俱是假。此谓自性求。差别求者。推名差别及物差别。知俱空故悉不可得。此谓差别求。说四求已。次分别四如实知。偈曰

  真智有四种　　名等不可得
  二利为大业　　成在诸地中

释曰。诸菩萨于诸法有四种如实知。一缘名如实知。二缘物如实知。三缘自性如实知。四缘差别如实知。如实知者。由知一切名等皆不可得故。二利为大业成在诸地中者。诸菩萨于诸地中起自利利他大事。此名如实知业。偈曰

  住持及受用　　种子合三因
  依止及心法　　亦种为彼缚

释曰。三因者。一住持因。二受用因。三种子因。住持因者谓器世界。受用因者谓五欲境界。种子因者谓阿梨耶识。由此识是内外诸法种子因故。此三因如绳即是能缚。问此缚缚何等物。答依止及心法。亦种为彼缚所缚亦有三种。一依止。二心法。三阿梨耶识。问依止是何等。答是眼等六根。问阿梨耶识是何等。答是三界内外诸法种子。此中但有阿梨耶识可缚。无人我可缚。此名如实知系缚。偈曰

  安相在心前　　及以自然住
  一切俱观察　　至得大菩提

释曰。安相在心前者。安相谓闻思修慧方便。人所缘起分别故。名安相及以自然住者。彼相谓自性现前。非分别故名自然住。一切俱观察者。彼二所缘非所缘体无分别故。以此方便为诸相对治。彼二应次第观察。谓先观安相。后观自然住相。此二皆非缘体。彼起四倒即得随灭。至得大菩提者。若修行人但观察人相。唯得声闻缘觉菩提。若观察一切法相即得无上菩提。如是随其所缚而得解脱。此名如实知解脱。问此解脱由何所知由何所尽。偈曰

  若智缘真如　　远离彼二执
  亦知熏聚因　　依他性即尽

释曰。若具知三性即尽依他性。若智缘真如者。是知真实性。远离彼二执者。是知分别性。亦知熏聚因者。是知依他性。依他性即尽者。由知三性即熏习聚尽。熏习聚者。谓阿梨耶识问此尽有何功德。偈曰

  缘彼真如智　　观察无异相
  有非有现见　　想作自在成

释曰。观察无异相者。别相及如无差别见故。此说二乘与菩萨差别。二乘相及无相差别而见。如是见已悉舍于相。于无相界起作意缘入无相三昧。菩萨则不尔。于真如外不见别有诸相。于无相界亦见无相。由菩萨智无种种相修故。有非有现见者。有名真如境界。非有名相境界。皆现见故。想作自在成者。谓欲作神通等事一切皆由忆想分别而成。此是如实知利益。问凡夫及菩萨二见云何显示。偈曰

  覆实见不实　　应知是凡夫
  见实覆不实　　如是名菩萨

释曰。凡夫无功用不见真如见不真实相。菩萨无功用见真如不见不真实相。问已知差别。云何转依及得解脱。偈曰

  不见见应知　　无义有义境
  转依及解脱　　以得自在故

释曰。无义境界谓诸相。此即不见。有义境界谓真如。此即见。如是说名转依。见所执境界无体。及见真如有体。如是说名解脱。何以故。以得自在故。自在者。谓随自意转自然不行诸境界。如经说。若有相则被缚。若被缚则无解脱。不行一切境界即是解脱。问云何如实知净土方便。偈曰

  众生同一种　　地境皆普见
  此即净土障　　应知亦应舍

释曰。众生同一种地境皆普见者。器世界是大境界。一切众生同见一种类。皆言此是大地故。此即净土障者。由作此见即与净土方便而为障碍。应知亦应舍者。菩萨知此想为障碍已。即应勤舍此想。是名对治。已说菩萨四种如实知。次说菩萨五种无量。偈曰

  应化及应净　　应得亦应成
  应说此五事　　菩萨五无量

释曰。五事无量者。一应化事无量。由摄一切众生界故。二应净事无量。由摄一切器世界故。三应得事无量。由摄一切法界故。四应成事无量。由摄一切可化众生故。五应说事无量。由摄十二部经是化众生方便故。已说菩萨五种无量。次说菩萨说法有八果。偈曰

  发心及得忍　　净眼与尽漏
  法住学亦断　　受用为八果

释曰。菩萨若勤说法能得八果。一诸听法者或发菩提心。二或得无生忍。三或于诸法远尘离垢得法眼净。此谓下乘所摄。四或得诸漏尽。五令正法久住。由此正说得展转受持故。六未学义者令得学义。七未断疑者令得断疑。八已断疑者令得受用正法无障大喜味。已说菩萨说法有八果。次说大乘七大义。偈曰

  缘行智勤巧　　果事皆具足
  依此七大义　　建立于大乘

释曰。若具足七种大义说为大乘。一者缘大。由无量修多罗等广大法为缘故。二者行大。由自利利他行皆具足故。三者智大。由人法二无我一时通达故。四者勤大。由三大阿僧祇劫无间修故。五者巧大。由不舍生死而不染故。六者果大。由至得力无所畏不共法故。七者事大。由数数示现大菩提大涅槃故。已说大乘七大义。次说八法摄大乘。偈曰

  性信心行入　　成净菩提胜
  如是八种事　　总摄诸大乘

释曰。此以八事总摄一切大乘。八事者。一种性如性品说。二信法如信品说。三发心如发心品说。四行行如度摄品说。五入道如教授品说。六成熟众生。谓初七地七净佛国土谓第八不退地。八菩提胜谓佛地。菩提有三种。谓声闻菩提。缘觉菩提。佛菩提。佛菩提大故为胜。于此佛地示现大菩提及大涅槃故。已说八法摄大乘。次说菩萨五人差别。偈曰

  信行及净行　　相行无相行
  及以无作行　　差别依诸地

释曰。菩萨有五人差别。一信行人。谓地前一阿僧祇劫。二净心行人。谓入初地。三相行人。谓二地至六地。四无相行人。谓第七地。五无作行人。谓后三地已说菩萨五人差别。次说菩萨诸相差别。偈曰

  不着及清净　　降嗔与勤德
  不动并见实　　有欲名菩萨

释曰。此偈以自利门说菩萨相。不著者是能行施不着诸欲故。清净者是能持戒。降嗔者是能忍辱。勤德者是能精进。不动者是能习定。见实者是能修智。有欲者是能起愿乐大菩提故。行此七事说名菩萨相。偈曰

  随摄及无恼　　耐损并勇力
  不放逸多闻　　利彼名菩萨

释曰。此偈以利他门说菩萨相。随摄者是施。恒以四摄摄众生故。无恼者是戒。自信于他不起恼害见故。耐损者是忍。他来违逆不怀加报意故。勇力者是进。在苦度众生无有退屈心故。不放逸者是定。不着禅味来就下处生故。多闻者是智能断一切众生疑故。如是勤行利他是菩萨相。偈曰

  厌财及舍欲　　忘怨亦勤善
  巧相无恶见　　内住名菩萨

释曰。此偈以住功德门说菩萨相。厌财者住施功德。知悭财过堕于恶道来贫穷故。舍欲者住戒功德。若着五欲不能出家受持戒故。忘怨者住忍功德。他来损己不怀不报故。怀报者如似画石。不怀报者如似画水。一堕恶道。一生善趣。勤善者住进功德。为自他二利恒行六波罗蜜故。巧相者住定功德。善能分别止举舍三相故。无恶见者住智功德。一切诸相不可得故。内住者住愿功德。内谓大乘论住不动故。偈曰

  具悲亦起惭　　耐苦及舍乐
  持念并善定　　不舍名菩萨

释曰。此偈以不退门说菩萨相。具悲者是施不退。愍他苦人能行施故。起惭者是戒不退。观此世他世及法人不造诸非故。耐苦者是忍不退。风雨寒热等及他违损事一切皆忍故。舍乐者是进不退。能行正勤人不着自乐故。持念者是定不退。能善摄心人由念力故。善定者是慧不退。无分别智具足故。不舍者是愿不退。不舍大乘故。偈曰

  除苦不作苦　　容苦不畏苦
  脱苦不思苦　　欲苦名菩萨

释曰。此偈以离苦门说菩萨相。除苦者是施。施他物时除他贫穷故。不作苦者是戒。戒自居时不作苦恼他故。容苦者是忍。自他利时诸苦能受故。不畏苦者是进。行难行时恒得不退故。脱苦者是定。离欲欲界时解脱苦苦故。不思苦者是慧。三轮清净时不起分别故。欲苦者是愿为化众生乐住生死故。偈曰

  乐法及性法　　呵法亦勤法
  自在法明法　　向法名菩萨

释曰。此偈以摄法门说菩萨相。乐法者是施。爱施等法故。性法者是戒。自性护持故。呵法者是忍。讥嫌嗔法故。勤法者是进。勤行大乘法故。自在法者是定。诸禅自在故。明法者是慧。无上般若具足故。向法者是愿。一向乐大菩提故。问云何名法。答由一切诸波罗蜜法皆随转故。偈曰

  财制护善乐　　法乘于此七
  七种不放逸　　是故名菩萨

释曰。此偈以不放逸门说菩萨相。一财不放逸。此由布施不施不坚施则坚固故。二制不放逸。此由持戒如佛说应作者作不应作者不作故。三护不放逸。此由忍辱护自他心无两害故。四善不放逸。此由精进常起正勤行六度故。五乐不放逸。此由修定诸禅乐受不味着故。六法不放逸。如实真法此能知故。七乘不放逸。此由大愿魔王来坏其菩提心亦不退故。偈曰

  不遂及小罪　　不忍退亦乱
  小见及异乘　　七羞名菩萨

释曰。此偈以有羞门说菩萨相。一不遂羞。羞悭贪故。二小罪羞。羞微细罪见怖畏故。三不忍羞羞不忍故。四退羞。羞懈怠故。五乱羞。羞退定故。六小见羞。羞余小执通达法无我故。七异乘羞。羞起小乘心舍大菩提故。偈曰

  今世后世舍　　起勤亦得通
  等说及大果　　七摄名菩萨

释曰。此偈以摄生门说菩萨相。一今世摄谓以布施摄现在众生。二后世摄。谓以持戒摄未来众生。得胜生处方能摄故。三舍摄。谓以忍辱摄有恼乱众生。四起勤摄。谓以精进摄懈怠众生。五得通摄。谓以禅定摄他方众生往彼化故。六等说摄。谓以智慧摄下中上众生。等心为说无增减故。七大果摄。谓以大愿若得佛果摄诸众生无有余故。此诸偈义以异门说六度及大愿。是菩萨相应知。已说菩萨诸相差别。次说菩萨诸名差别。偈曰

  应知诸菩萨　　亦名摩诃萨
  亦名有慧者　　亦名上成就
  亦名降伏子　　亦名降伏持
  亦名能降伏　　亦名降伏牙
  亦名为勇猛　　亦名为上圣
  亦名为导师　　亦名大名称
  亦名为有悲　　亦名大福德
  亦名自在行　　亦名正说者

释曰。此十六名皆依义立。一切菩萨总有此名。若人闻有此名。应知即是菩萨。已说菩萨诸名差别。次说菩萨诸义差别。偈曰

  实觉大义觉　　一切觉恒觉
  及以方便觉　　五觉名菩萨

释曰。由有五觉故名菩萨。一者实义觉。觉人法无我故。二者大义觉。觉自他义故。三者一切觉。觉一切种义故。四者恒觉。虽现涅槃觉无尽故。五者方便觉。觉随物机而作方便故。偈曰

  随我及小见　　及以诸识身
  亦于虚分别　　四觉名菩萨

释曰。复由四觉名为菩萨。一随我觉。由觉心故。心谓阿梨耶识。二小见觉。由觉意故。意谓与我见等四惑相应缘阿梨耶识者。三识身觉。由觉识故。识谓六识身。四虚分别觉。由觉不真分别故。不真分别者。即前心意识。一切菩萨唯觉。此是不真分别故。偈曰

  无境及真义　　永无亦圆满
  亦说不可得　　五觉名菩萨

释曰。复由五觉名为菩萨。一无境觉。觉依他性故。二真义觉。觉真实性故。三永无觉。觉分别性故。四圆满觉。觉一切境一切种故。五不可得觉。觉三轮清净故。三轮者。一应觉。谓菩萨境。二依觉。谓菩萨身。三觉性。谓菩萨智。此三不可得故。名不可得觉。偈曰

  成就及处所　　胎藏随次现
  及以断深疑　　五觉名菩萨

释曰。复由五觉名为菩萨。一成就觉。谓成佛果。二处所觉。谓住兜率天宫。三胎藏觉。谓入母胎。四随次现觉。谓出胎受欲出家修行成道。五断深疑觉。谓为诸众生转大法轮。偈曰

  得不得及住　　于自亦于他
  有说与无说　　有慢及慢断
  未熟亦已熟　　如此十一种
  一切皆能觉　　是故名菩萨

释曰。复由十一种觉故名菩萨。得不得及住者。如其次第过去未来现在觉。于自亦于他者。谓内觉外觉。有说与无说者。谓粗觉细觉。有慢及慢断者。谓劣觉胜觉。未熟亦已熟者。谓远觉近觉。未熟者觉彼久远方觉。已熟者觉彼于近即觉。功德品究竟

大乘庄严经论卷第十二大乘庄严经论卷第十三

        无著菩萨造

        大唐天竺三藏波罗颇蜜多罗译

    行住品第二十三

释曰。已说菩萨功德。次说菩萨五种相。偈曰

  内心有怜愍　　爱语及勇健
  开手并释义　　此五菩萨相

释曰。菩萨有五种相。一怜愍。二爱语。三勇健。四开手。五释义。怜愍者。以菩提心摄利众生故。爱语者。令于佛法得正信故。勇健者。难行苦行不退屈故。开手者。以财摄故。释义者。以法摄故。此五种相应知。初一是心。后四是行。已说菩萨五种相。次说菩萨在家出家分。偈曰

  菩萨一切时　　恒居轮王位
  利益众生作　　在家分如此

释曰。菩萨在家恒作轮王。化行十善离于十恶。此是利益。偈曰

  受得及法得　　及以示现成
  三种出家分　　在于一切地

释曰。菩萨出家有三分。一受得分。谓从他受护。二法得分。谓得无流护。三示现分。谓变化作受。得分谓信行地。法得分及示现分。谓入大地。偈曰

  应知出家分　　无量功德具
  欲比在家分　　最胜彼无等

释曰。二分挍量出家分胜。由无量功德具足故。已说菩萨在家出家分。次说菩萨五种极大心。偈曰

  爱果及善根　　涅槃欲令得
  未净净极净　　谓在诸地中

释曰。五极大心者。一乐极大心。二利极大心。三未净极大心。四已净极大心。五极净极大心。爱果者。谓乐极大心。令诸众生得后世爱果故。善根者。谓利极大心。令诸众生现行诸善及得涅槃故。未净者。谓未净极大心。即信行地菩萨。净者谓已净极大心。即初地至七地菩萨。极净者。谓极净极大心。即后三地菩萨。已说菩萨五种极大心。次说菩萨四种摄众生。偈曰

  欲乐及平等　　增上与徒众
  四心于诸地　　摄受一切生

释曰。四种摄众生者。一欲乐心摄。由以菩提心摄故。二平等心摄。由入初地得自他平等心摄故。三增上心摄。由居主位以自在力摄故。四徒众心摄。由摄成自弟子故。已说菩萨四种摄众生。次说菩萨四种受生。偈曰

  业力及愿力　　定力亦通力
  依此四种力　　菩萨而受生

释曰。四种受生者。一业力生。二愿力生。三定力生。四通力生。业力生者。谓信行地菩萨业力自在随所欲处而受生故。愿力生者。谓入大地菩萨愿力自在为成熟他受畜生等生故。定力生者。谓得定菩萨定力自在舍于上界下受生故。通力生者。谓得神通菩萨通力自在。能于兜率天等示现诸相而受生故。已说菩萨四种受生。次说菩萨十一住相。偈曰

  证空证业果　　住禅住觉分
  观谛观缘起　　无相无功用
  化力净二门　　及以菩提净
  以此诸所说　　立地相应知

释曰。十一住者即十一地。住者名地故。证空者显初住相。多住人法二无我故。证业果者显第二住相。证业及果不坏能护戒故。住禅者显第三住相。能生欲界而不退禅故。住觉分者显第四住相。能入生死而不舍觉分故。观谛者显第五住相。以明教化恼唯恼心以我无故。观缘起者显第六住相。能不起染心而依缘起受生故。无相者显第七住相。行虽功用而上参一道多住无相故。无功用者显第八住相。虽净佛土而无起作多住无功用故。化力者显第九住相。四辩自在能成熟一切众生故。净二门者显第十住相。三昧门陀罗尼门极清净故。净菩提者显第十一住相。一切智障断究竟故。已说菩萨十一住相。次说菩萨依地立名。偈曰

  初三三行净　　次三三慢断
  后三觉舍化　　第十有四名

释曰。于十地中建立十菩萨名。初三三行净者。初地名见净。菩萨得人法二见对治智故。第二地名戒净。菩萨微细犯垢永无体故。第三地名定净。菩萨诸禅三昧得不退故。次三三慢断者。第四地名断法门异慢。菩萨于诸经法破起差别慢故。第五地名断相续异慢。菩萨入十平等心于一切相续得平等故。第六地名断染净异慢。菩萨如性本净客尘故。染能住缘起法。如不起黑白差别见故。后三觉舍化者。第七地名得觉。菩萨住无相力。能念念中修三十七觉分故。第八地名行舍。菩萨住无功用无相故。亦名净土。菩萨方便行与不退地菩萨合故。第九地名化众生。菩萨能成熟一切众生故。第十有四名者。一名大神通。菩萨得大神通故。二名满法身。菩萨具无量三昧门陀罗尼门故。三名能现身。菩萨住兜率天等示相身故。四名受职。菩萨于诸佛所得受职故。已说菩萨依地立名。次说菩萨随地修学及学果。偈曰

  随次依前六　　见性修三学
  随次依后四　　得果有四种

释曰。随次依前六见性修三学者。菩萨于初地通达真如。第二地学增上戒。第三地学增上心。第四第五第六地学增上慧。慧有二境。一法实。谓苦等四谛。二缘起。谓逆顺观十二因缘。此二境亦在第二第三地中。是故彼地亦增上慧建立。然第四地中菩提分慧增上。第五地中谛观慧增上。第六地中缘起观慧增上。故此三地建立增上慧学。随次依后四得果有四种者。依第七地得无相有功用住。为第一果。依第八地得无相无功用住。为第二果。依第九地得成熟众生。为第三果。依第十地得二门成熟。为第四果。已说随地修学及学果。次说菩萨随地修习无流五阴。偈曰

  见性净三身　　亦在前六地
  余地净余二　　远离五障故

释曰。初地见性如前解。第二地中戒身清净。第三地中定身清净。第四第五第六地中慧身清净。后四地及佛地解脱身解脱知见身清净。由离五障故。五障者。第七地中以执相无知为障。第八地中以功用无知为障。第九地中以不能化生无知为障。第十地中以未净二门无知为障。佛地中以碍障无知为障谓此无知能碍声闻缘觉境界智诸佛知一切境无碍。由解脱此障故。已说菩萨随地修无流五阴。次说菩萨随地成就未成就。偈曰

  未成就成就　　成复未成成
  如地建立知　　分别无分别

释曰。未成就成就者。彼信行地是未成就。自余诸地是名成就。成复未成成者。于前成就地中复有未成就成就。七地已还名未成就。有功用故。八地已上是名成就。无功用故。问前说欢喜地亦是成就。此义云何。答如地建立知分别无分别。此由于地建立中知唯分别。于此分别亦无分别。所执能执俱无体故。约此义故说名成就。偈曰

  应知诸地中　　修习及成就
  此二不思议　　诸佛境界故

释曰。菩萨于诸地中各有修习及成就。应知地地皆不可思议。由诸菩萨内自证觉是诸佛所知非余人境界故。已说菩萨随地成就未成就。次说菩萨入地十种相。偈曰

  明信及无劣　　无怯亦无待
  通达及平等　　离偏亦离着
  及以知方便　　亦在圣众生
  如此十种相　　地地皆圆满

释曰。入地菩萨地地皆有十相。何者为十。一明信。二无劣。三无怯。四无待。五通达。六平等。七离偏。八离着。九知方便。十圣众生。明信者。于自地得明。于诸法中除无知故。于他地得信。于后诸地生愿乐故。无劣者。闻深妙法不惊怖故。无怯者。行难行行极勇猛故。无待者。起自地行不待教故。通达者。他地方便能起故平等者。普于众生同自心故。离偏者。耳闻毁誉无高下故。离著者。得轮王等位无爱染故。知方便者。知诸法不可得为佛方便故圣众生者。诸佛徒众恒在生故。此等十相地地皆具应知。已说菩萨入地十种相。次说菩萨地中十度相。偈曰

  有欲无六障　　其次无乱慧
  不漂亦不回　　事友及供养
  回向将生胜　　修善与戏通
  功德藏如是　　佛子十六相

释曰。诸菩萨于诸地中得十度有十六相。何者十六。一有欲乐。行诸度故。二无悭。离施障故。三无违。离戒障故。四无恚。离忍障故。五无懈。离进障故。六慈悲。离定障故。慈悲能与乐拔苦。是嗔恼对治。由定得故。七无恶慧。离慧障故。恶慧有三。谓自性分别。随忆分别。显示分别。此能断故。八无乱慧。离异乘心故。九不漂不为人天胜乐醉其心故。十不回不为不成就苦及难行苦退其心故。十一事友。依佛所示善知识闻大乘故。十二供养。供养三宝故。十三回向善巧方便故十四生胜。此显愿波罗蜜相。离八难处不离诸佛菩萨故。十五修善此显力波罗蜜相。无间修诸善根故。十六戏通此显智波罗蜜相。游戏诸大神通功德故。菩萨若得此相。则为一切众中上首。是名佛子十六相。已说菩萨地中十度相。次说菩萨度度五功德。偈曰

  地地升进时　　度度有五德
  二及二及一　　应知止观俱

释曰。地地升进时度度有五德者。菩萨于一一地修一一度。于一一度皆具五种功德。何者为五。一灭习。二得猗。三圆明。四相起。五广因。灭习者。一一刹那灭除依中习气聚故。得猗者。离种种相得法乐故。圆明者。遍知一切种不作分段故。相起者。由入大地无分别相生故。广因者。为满为净一切种法身福聚智聚摄令增长故。二及二及一应知止观俱者。此中应知。初二功德是奢摩他分。次二功德是毗钵舍那分。第五功德是俱分。已说菩萨度度五功德。次释菩萨十地名。偈曰

  见真见利物　　此处得欢喜
  出犯出异心　　是名离垢地
  求法持法力　　作明故名明
  惑障智障薪　　能烧是焰慧
  难退有二种　　能退故难胜
  不住二法观　　恒现名现前
  杂道邻一道　　远去名远行
  相想无相想　　动无不动地
  四辩智力巧　　说善称善慧
  二门如云遍　　雨法名法云

释曰。见真见利物此处得欢喜者。菩萨于初地中一见真如。谓见自利。昔曾未见今时始见。去菩提近故。二见利物。谓见利他。一一刹那能成熟百众生故。由此二见起胜欢喜故名欢喜地出犯出异心是名离垢地者。菩萨于二地中出二种垢。一出犯戒垢。二出起异乘心垢。由出二垢故名离垢地。如十地经说我等应得应净一切种智故勤精进。求法持法力作明故名明者。菩萨于三地中得三昧自在力。于无量佛法能求能持。得大法明为他作明。由能以法自明明他故名明地。惑障智障薪能烧是焰慧者。菩萨于四地中以菩提分慧为焰自性。以惑智二障为薪自性。此地菩萨能起慧焰烧二障薪故名焰慧地。难退有二种能退故难胜者。菩萨于五地中有二种难。一勤化众生心无恼难。二众生不从化心无恼难。此地菩萨能退二难于难得胜故名难胜地。不住二法观恒现名现前者。菩萨于六地中依般若力。能不住生死涅槃二法。如此观慧恒现在前故名现前地。杂道邻一道远去名远行者。菩萨于七地中近一乘道故名远去。问谁是远去。答功用方便究竟此远能去。由此远去故名远行地。相想无相想动无不动地者。菩萨于八地中有相想及无相有功用想二想俱不能动。由无此动故。故名不动地。四辩智力巧说善称善慧者。菩萨于九地中四无碍慧最为殊胜。于一刹那顷三千世界所有人天异类异音异义异问。此地菩萨能以一音普答众问遍断众疑。由此说善故名善慧地。二门如云遍雨法名法云者。菩萨于十地中由三昧门及陀罗尼门。摄一切闻熏习因。遍满阿梨耶识中。譬如浮云遍满虚空。能以此闻熏习云。于一一刹那。于一一相。于一一好。于一一毛孔。雨无量无边法雨。充足一切可化众生。由能如云雨法故名法云地。问释别名已。云何名住云何名地。偈曰

  为集诸善根　　乐住故说住
  数数数无畏　　复以地为名

释曰。为集诸善根乐住故名住者。诸菩萨为成就种种善根。于一切时乐住一切地。是故诸地说名为住。数数数无畏复以地为名者。步弥耶名为地。步者数数义。弥者实数义。耶者无畏义。诸菩萨欲进上地。于一一地中数数断障碍。数数得功德。是名数数义。地以十数为量。诸菩萨于一一地中知断尔所障碍。知得尔所功德。知此不虚是名实数义。上地是无畏处。诸菩萨畏于自地中退失自他利功德进求上地。是名无畏义。由此三义故名为地。已说菩萨十地名。次说菩萨四种得地差别。偈曰

  由信及由行　　由达亦由成
  应知诸菩萨　　得地有四种

释曰。四种得地者。一由信得。二由行得。三由通达得。四由成就得。由信者。以信得诸地故。如信地中说。由行者。以正行得诸地故。诸菩萨于大乘法有十种正行。一书写。二供养。三流传。四听受。五转读。六教他。七习诵。八解说。九思择。十修习。此十正行能生无量功德聚。此行得地故名行得。通达者。通达第一义谛。乃至七地名通达。得成就者。八地至佛地名成就得。已说菩萨四种得地。差别次说菩萨四种修行。差别偈曰

  诸度诸觉分　　诸通及诸摄
  为大亦为小　　俱入亦俱成

释曰。总说一切菩萨行不过四种。一波罗蜜行。二菩提分行。三神通行。四摄生行。说波罗蜜行为求大乘众生。说菩提分行为求小乘众生。说神通行为令二种众生得入佛法。说摄生行为令二种众生成熟佛法。行住品究竟

    大乘庄严经论敬佛品第二十四

释曰。已说菩萨。行住次说礼佛。功德偈曰

  合心及离心　　不离利益心
  怜愍诸众生　　救世我顶礼

释曰。此偈礼如来无量胜功德。合心者。是慈心。由与乐故。离心者。是悲心。由拔苦故。不离心者。是喜心。由恒悦故。利益心者。是舍心。由无染故。偈曰

  一切障解脱　　一切世间胜
  一切处遍满　　心脱我顶礼

释曰。此偈礼如来三处胜功德。一切障解脱者。显解脱胜。由一切惑障一切智障得解脱故。一切世间胜者。显制入胜。由心自在随其所缘随意转故。一切处遍满者。显遍入胜。由一切境中智遍满故。由此三义心于三处而得解脱。故说心解脱。偈曰

  能遮彼惑起　　亦能害彼惑
  染污诸众生　　悲者我顶礼

释曰。此偈礼如来无诤胜功德能遮彼惑起者。一切众生应起烦恼。如来凡所作业能令不起亦能害彼惑者。彼惑若已起。如来亦能令起对治方便。若余人无诤但能令他缘自不起烦恼。而不能令他起对治。如来无诤则不尔。非但令彼不起。亦能令彼起对治是故为胜。染污诸众生悲者我顶礼者。如来无诤三昧。于一切染污众生偏起怜愍。是故于彼名为悲者。偈曰

  无功用无著　　无碍恒寂静
  能释一切疑　　胜智我顶礼

释曰。此偈礼如来愿智胜功德。如来愿智由五事胜。一于起无功用。二于境不着。三于中无碍。四恒时寂静。五能释众疑。由此五义是故为胜。余人愿智。一非无功用。作意起故。二非无著。假定力故。三非无碍。少分知故。四非恒静。非常定故。五不释疑。有无知故。偈曰

  所依及能依　　于言及于智
  说者无碍慧　　善说我顶礼

释曰。此偈礼如来无碍胜功德。所说有二种。一所依谓法二能依。谓义。说具有二种。一方言二巧智。如来于此所说及说具慧常无碍。是故为胜。说者即显无碍业。开示有方故名善说。偈曰

  能去及能闻　　知行知来去
  令彼得出离　　教授我顶礼

释曰。此偈礼如来神通胜功德。能去者。是如意通。能往彼彼所故。能闻者。是天耳通。能闻彼彼音故。知行者。是他心通。能知彼人心行差别故。知来者。是宿住通。能知彼人前世从此因来故。知去者。是生死通。能知彼人今世从此因去故。令彼得出离者。是漏尽通。能如实为彼说法故。偈曰

  众生若有见　　知定是丈夫
  深起净信心　　方便我顶礼

释曰。此偈礼如来相好胜功德。一切众生若有见者。即知如来是大丈夫。及于如来起净信业。由以相好为方便故。偈曰

  取舍住变化　　定智得自在
  如此四清净　　世尊我顶礼

释曰。此偈礼如来清净胜功德。清净四种。一身清净。二缘清净。三心清净。四智清净。取舍住者。显身清净。能于自身寿中若取若舍若住得自在故。变化者。显缘清净。能于诸境转变起化得自在故。定者。显心清净。能于诸定出入得自在故。智者。显智清净。能知诸境无碍得自在故。偈曰

  方便及归依　　清净与出离
  于此破四诳　　降魔我顶礼

释曰。此偈礼如来力胜功德。魔依四事破坏众生。何者四事。一依方便诳惑众生。言受用五尘得生善道不堕恶道。二依归依诳惑众生。言自在天等是归依处余处则非。三依清净诳惑众生。言世间诸定唯此清净余非清净。四依出离诳惑众生。言小乘道果唯此出离非有大乘。佛为破魔四事显己十力。一以是非智力破魔第一事。由善方便可得生天非恶方便故。二以自业智力破魔第二事。由自业生天非依自在天等力故。三以禅定智力破魔第三事。由具知禅定解脱三昧三摩跋提故。四以后七智力破魔第四事。由下根等令离上根等安置故。偈曰

  于智亦于断　　于离亦于障
  能说自他利　　摧邪我顶礼

释曰。此偈礼如来无畏胜功德。于智者。是说一切智无畏。于断者。是说漏尽无畏。于离者。是说尽苦道无畏。于障者。是说障道无畏。此中智及断是说自利功德。离及障是说利他功德。若诸外道难言。瞿昙。非具一切智。非尽一切漏。说道不能尽苦。说障不能妨道。如来于此四难而能摧伏。故名无畏。偈曰

  在众极治罚　　自无所护故
  离二染正住　　摄众我顶礼

释曰。在众极治罚自无所护故者。此礼如来不护胜功德。若自有所护在众不能说极治罚故。离二染正住者。此礼如来念处胜功德。离二染者无喜忧故。正住者不忘念故。由此二种功德胜故。能摄于一切徒众此即是业。偈曰

  行住一切处　　无非一切智
  由断一切习　　实义我顶礼

释曰。此偈礼如来断习胜功德。如来于一切处一切时。行住等事。无非一切智威仪。由具断一切烦恼习故。若无一切智者。烦恼虽尽而习不尽。于行住时或逢奔车逸马即被损害。由非一切智威仪故。如来无此事。由实有一切智故。偈曰

  利益众生事　　随时不过时
  所作恒无谬　　不忘我顶礼

释曰。此偈礼如来不忘胜功德。如来作利益众生事。恒得其时不过其时。此是不忘法业。如来所作一切时皆实不虚此是不忘法自性。偈曰

  昼夜六时观　　一切众生界
  大悲具足故　　利意我顶礼

释曰。此偈礼如来大悲胜功德。如来以大悲故昼夜六时观察众生谁退谁进。未起善根者令其得起。已起善根者令其增进。虽日六时而实一切时恒转法轮。由大悲具足故。此即大悲业。于一切众生常起利益意。此是大悲自性。偈曰

  由行及由得　　由智及由业
  于一切二乘　　最上我顶礼

释曰。此偈礼如来不共胜功德。如来有十八不共法。一身无失。二口无失。三念无失。四无异想。五无不定心。六无不知已舍。七欲无减。八精进无减。九念无减。十慧无减。十一解脱无减。十二解脱知见无灭。十三智知过去无著无碍。十四智知未来无著无碍。十五智知现在无著无碍。十六身业随智慧行。十七口业随智慧行。十八意业随智慧行。此中由行者。摄初节六不共。由得者。摄第二节六不共。由智者。摄第三节三不共。由业者。摄第四节三不共。一切声闻缘觉于余一切众生为上。如来由此四事不共故。于彼上复上。故名最上。偈曰

  三身大菩提　　一切种得故
  众生诸处疑　　能除我顶礼

释曰。此偈礼如来种智胜功德。三身者。一自性身。二受用身。三化身。此说种智自性。问此智于一切境知一切种复云何。答一切众生于一切处生疑。此智能断。此说种智业。偈曰

  无著及无过　　无秽亦无息
  无动无戏论　　清净我顶礼

释曰。此偈礼如来度满胜功德。无著者。于诸资财无所染故。无过者。于身等业永无垢故。无秽者。世法诸苦不浊心故。无息者。少有所得不即住故。无动者。心恒寂静不散乱故。无戏论者。一切法中所有分别皆不行故。如来此六圆满具离六障。故名清净。偈曰

  成就第一义　　出离一切地
  于他得尊极　　解脱诸众生
  无尽等功德　　现在皆具足
  世见众亦见　　不见人天等

释曰。此二偈礼如来佛相胜功德。此中略说佛相有六种。一体二因三果四业五相应六差别。由此六种表知是佛故说佛相。成就第一义者。此是体相。由真如最清净第一义成就故。出离一切地者。此是因相。由出离一切菩萨地故。于他得尊极者。此是果相。由于一切众生中得第一故。解脱诸众生者。此是业相。由能令一切众生得解脱故。无尽等功德现。世皆具足者。此是相应相。世见众亦见不见人天等者。此是差别相。世见者。谓种种世界皆见。此是化身。众亦见者。谓佛大弟子众亦见。此是受用身。不见者。谓人天等一切时不见。此是自性身。此即三身差别。敬佛品究竟。大乘修多罗庄严论极清净时说已究竟

大乘庄严经论卷第十三


佛性论卷

    No. 1610

佛性论卷第一

        天亲菩萨造

        陈天竺三藏真谛译

    缘起分第一

问曰。佛何因缘说于佛性。答曰。如来为除五种过失。生五功德故。说一切众生悉有佛性。除五种过失者。一为令众生离下劣心故。二为离慢下品人故。三为离虚妄执故。四为离诽谤真实法故五为离我执故。一为令众生离下劣心者。有诸众生未闻佛说有佛性理。不知自身必当有得佛义故。于此身起下劣想。不能发菩提心。今欲令其发心。舍下劣意故。说众生悉有佛性。二为离高慢心者。若有人曾闻佛说众生有佛性故。因此发心。既发心已。便谓我有佛性故能发心。作轻慢意。谓他不能。为破此执故。佛说一切众生皆有佛性。三为离虚妄执者。若人有此慢心。则于如理如量。正智不得生显故起虚妄。虚妄者。是众生过失。过失有二。一本无。二是客。一本无者。如如理中。本无人我。作人我执。此执无本。由无本执故。起无明等。由无明起业。由业起果报。如此三种。无实根本。所执是无故知能执皆成虚妄故。由于此执所起无明诸业果报。并是虚妄故。无受者作者。而于中执有。是虚妄故言本无。二是客者。有为诸法皆念念灭。无停住义。则能骂所骂二无所有。但初刹那为旧。次刹那为客。能骂所骂起而即谢。是则初刹那是怨。次则非怨。以于客中作于旧执此执不实故名虚妄。若起此执。正智不生。为除此执故说佛性。佛性者。即是人法二空所显真如。由真如故。无能骂所骂。通达此理。离虚妄执。四为除诽谤真实法者一切众生过失之事。并是二空。由解此空故。所起清净智慧功德。是名真实。言诽谤者。若不说佛性则不了空。便执实有。违谤真如。净智功德。皆不成就。五离我执者。若不见虚妄过失。真实功德。于众生中。不起大悲。由闻佛说佛性故。知虚妄过失。真实功德。则于众生中。起大悲心。无有彼此故除我执。为此五义因缘。佛说佛性生五种功德。五功德者。一起正勤心。二生恭敬事。三生般若。四生阇那。五生大悲。由五功德。能翻五失。由正勤故。翻下劣心。由恭敬故。翻轻慢意。由般若故。翻妄想执。由生阇那俗智。能显实智。及诸功德故。翻谤真法。由大悲心。慈念平等故翻我执。翻我执者。由佛性故。观一切众生。二无所有。息自爱念。观诸众生。二空所摄。一切功德。而得成就。是故于他而生爱念。由般若故。灭自爱念。由大悲故。生他爱念。由般若故。舍凡夫执。由大悲故。舍二乘执由般若故。不舍涅槃。由大悲故。不舍生死。由般若故。成就佛法。由大悲故。成熟众生。由二方便。住无住处。无有退转。速证菩提。灭五过失。生五功德。是故佛说一切众生皆有佛性

    佛性论破执分第二中破小乘执品第一

复次佛性有无。成破立义应知。破有三种。一破小乘执。二破外道执。三破菩萨执。初破小乘执者。佛为小乘人说有众生不住于性。永不般涅槃故。于此生疑。起不信心

释曰。所以生疑者。由佛说故。小乘诸部。解执不同。若依分别部说。一切凡圣众生。并以空为其本。所以凡圣众生。皆从空出故。空是佛性。佛性者即大涅槃。若依毗昙萨婆多等诸部说者。则一切众生。无有性得佛性。但有修得佛性。分别众生。凡有三种。一定无佛性。永不得涅槃。是一阐提犯重禁者。二不定有无。若修时即得。不修不得。是贤善共位以上人故。三定有佛性。即三乘人。一声闻从苦忍以上即得佛性。二独觉从世法以上即得佛性。三者菩萨十回向以上是不退位时得于佛性。所以然者。如经说有众生不住于性。永无般涅槃故。又阿鋡说。佛十力中。性力所照。众生境界。有种种性。乃至粗妙等界不同故称性力。所以者何。一切众生有性无性异故。有佛性者则修种种妙行。无佛性者。则起种种粗恶。是故学小乘人。见此二说皆有道理。未知何者为定故起疑心。复次生不信心者。于二说中。各偏一执故不相信。何者。若从分别部说。则不信有无性众生。若萨婆多等部说。则不信皆有佛性故。明有佛性者。问执无性曰。汝云何有无性众生。永不般涅槃。答曰。众生既有种种粗妙不同故知理有有性无性。汝若不信有无性众生永不涅槃。而信有众生有种种粗妙等界者。是义不然。何以故。执不平等故。问曰。汝信有众生种种粗妙等界。即令信有无性众生者。亦应信有无根众生耶。何以故。众生由有根无根故。有种种粗妙等界。汝若不信有无根众生者。云何信有粗妙等界。若谓有粗妙等界。不关有根无根者。我亦信有粗妙等界。不关有性无性之义。有何过失。若汝言无有无根众生者。我亦说无有无性众生。答曰。汝以有根无根。例我有性无性。是义不然。何以故。汝谓无根者。为是众生。为非众生。若是众生。有二过失。一者泰过过失。若无六根。而是众生者。则一切无情草木石等。皆是众生。同无根故。二者不及过失。本说六根以为众生。既无六根。更说何物。为众生耶。而汝说无根众生。是义不然。故知不为有根无根。说粗妙等界。正为有性无性说粗妙耳。难曰。若汝谓我立无根众生。有二过失者。汝立犯重一阐提人无有佛性。永不得涅槃。亦有二失。一者泰过过失。众生本以我见无明为凡夫法。寻此无明。由违人空故起。既起无明故有业报。若不违人空。则无无明业报。既无无明业报等三轮。若尔应是圣人作于凡夫。若谓众生无佛性者。但圣为凡。无凡得圣。此成泰过。二者不及过失。若汝谓有众生无佛性者。既无空性。则无无明。若无无明。则无业报。既无业报。众生岂有。故成不及。而汝谓有众生无佛性者。是义不然。何以故。汝既不信有无根众生。那忽信有无性众生。以二失同故。问曰。汝说有众生无佛性者。如刹底利种。为具有四性。及地狱人天等性。为不具有。若言不具有者。人应常人。永无作诸道义。若具足有者。则违经。如经中说。如来性力能了种种粗妙等界。此众生性。既其平等。经不证故。又若汝谓有众生永不般涅槃者。义亦不然。如人先为刹底利。后作婆罗门。或人或天。无决定相故。若汝说不具足者。则与立譬相违。何以故。俱不具故。汝说无佛性众生永不得佛。如人无天性。则应永无天报。若无天性。而得天报者。亦应有无佛性众生而得涅槃。复次若具足性与譬相似者。则无佛性众生应具有佛性。若有有无二性。为相违不。若相违者。则应一有一无。是义不可。若无涅槃性众生。则不应有涅槃性。汝言具二性者。义亦不然。何以故。如刹底利无婆罗门性。二性相违。决定无故。后则不得为婆罗门。乖世道故。又若俱有性义者。后时决得。若不具性义者。后决不得。若一人具此二义。定何所属。又问。汝立无佛性众生。始终定无。为不定无。譬如大地。初无金性。后时或有。有已更无。汝立无佛性。亦如是不。若如此者。则应得二乘性竟。后更不得。得大乘性竟后应更失。得定性已。后更不定。虽修得通达解脱等功德后还更失。则修道无用。决定立性。并成无用故。又问。汝立无定性众生如地。或时转为金宝等物。无佛性众生住于下性。是人性不定故。能转为涅槃者。为今生转。为未来转。若汝谓今生转者。云何得转。为值三宝得解脱三善根故转。为不值而能得转。若言修功德分故现在转者。何谓无佛性众生永住下性。是义自坏。若汝谓今世虽修善根终不得转。未来方转故名住下性者。此性于未来中。为修善故转。不修故转。若修故转。今修何故不转。若言未来不修善自然转者。现在未修。何故不转。又若汝谓无佛性。是定无者。如火定热性。不可转为水冷性。佛性亦尔。有无应定皆不可转。若不可转者。汝立此定。为由因故定。不由因故定。若由因故定。此定不成定。何以故。本时未是定。由因方定故。若说不由因而定者。则无穷过失。是故我说此性亦复不定。不由因故。是义应成。如汝说定等共无因。若尔非理之事并应得成。二者不平等过失。如人谓石女生两儿。一白一黑。亦如兔有两角。一利一钝。若人不由因说。此不平等义。亦应得成。如汝所说。此若不成。汝亦不立。三者失同外道。有本定有。无本定无。有不可灭。无不可生。此等过失。由汝邪执。无性义生故。问曰。若尔云何佛说众生不住于性。永无般涅槃耶。答曰。若憎背大乘者。此法是一阐提因。为令众生舍此法故。若随一阐提因。于长时中。轮转不灭。以是义故。经作是说。若依道理。一切众生。皆悉本有清净佛性。若永不得般涅槃者。无有是处。是故佛性决定本有。离有离无故

    佛性论破执分第二中破外道品第二

复次为外道不识佛性故。彼立义应知。有外道说。一切诸法。皆有自性。等有不空。性各异故。若诸法悉空。无自性者。则水火色心。生死涅槃。并无自性。自性既无。应可转火为水。转于涅槃更作生死。何以故。等无自性故。现见火性定热。不可为水。水性定湿。不可为火。涅槃生死。亦复如是。不可互相转作。如此二法。并有自性故。若互可转。则修道无用。故知诸法各有自性。是故不空。复次为破外道自性义应知。难曰。汝说诸法各有自性不空。性定异者。是义不然。何以故。自性决定不可得故。决定者。离此泰近泰远八种不可见因外。若物定有。则应可见。若物定无。则不可见。譬如兔角及蛇耳等。以决定智。依道理觅。决不可得。定永无故。诸法自性。亦复如是。故知诸法无自性故空。若汝说瓶等诸物更互各异。如瓶异衣等者。是义不然。何以故。瓶与色等。为即自性。为离自性。若定即离者。义皆不可。若是一者。则不应有八。瓶与数相违故。一义不立若定异者。缘色则不应得瓶。如人缘牛曾不见马。故瓶等即离自性。皆不可得。若汝说有性有故诸法有。自性不空者。是义不然。何以故。有性无自性故。有性若是自性有者。则不离空有二处。若有中有者。则二有相并无能所用。法既以有。何劳复须自性有耶。若无中有者。那不能令兔角龟毛等有。故知二处不立。复次问曰。汝说自性与瓶等。为一为异。若一者。则不应有八性。若有八者。一数即乖。若言异者。则不通有便无言智。何以故。汝言由自性有故有言说。及生智慧。今既是异故。知无言说。无言说故。智慧不生。有无即离。皆不可得故。自性定无。又若汝说。汝言亦空。是故一切诸法不空者。此义不然。何以故。如是语言入诸法摄故。语言亦空。故知诸法皆空。若汝说语言可闻故不空者。是义不然。何以故。语言自性不可得故。语言因缘种种异故。异相者有八事。一觉。二观。三功用。四风气。五八处。八处者。脐胸喉舌根项齿鼻唇。六音声。七名字。八开闭。具此八义故。言声得生。分别语言。并入一切诸法摄。故知同皆是空。又汝言。若汝说空平等者。云何于八种因缘。但生语言。不生余法。是义不然。何以故。汝不识他义本故。若有人立不从因缘。能出语言。汝对此人。可施此难。我今说因果决定。不无因缘。因果定者。如从因生果。若果不从因生。则应本来有果。若因不生果。果何缘有。若因果俱无性者。则自他同无。云何自生不生于他。为自果生。他果不生故。不得无性。由因生故。不可说有。从他生故。不可说无。以是义故。我说因果决定。汝难不成。如中论偈言

  一切处诸法　　从自不得生
  从他二亦尔　　从无因亦然

初言一切处诸法者。明处有三。一约四生处。谓三界生处。及无流界生处。此四摄一切内外处尽。四中所有一切诸法摄法亦尽。二约内道外道。摄一切所有法。处通世出世皆尽。三约有情无情。摄一切法皆尽。处通三世摄有皆尽故言一切处诸法。次三句以四种因缘觅诸法实生。皆不可得。一从自。二从他。三俱从自他。四不从自他。寻此四句。皆无生义故知诸法悉非性有一。不从自生者。若从自生。生则无用。自既以有。何劳复生。故文言从自不得生。二若从他生。何不生于异果。同皆是无故。故言从他不得生。三若俱从自他生者。亦复不然。前约异体相续。立自他义。如两物相望故。互为自他。以张望王。张即为自。王即为他。以王望张。王自张他。义亦如是。此二他性为一为异。若两他性是一者。则无自他义。非两相望故若彼他义。异此他义者。彼即不成他。以异他性故。彼他既非他。此他亦复失本。由他望我故。我有他义。他既非他。我他亦失。本由他故。有自他义。既空自性理失。竟何俱从自他生耶。故言二亦然。次约同类因果相望。论自他者。本由种子为因。能生芽果。芽必由因故名为果。种必生果故得名因。因之与果。为一为异。若定一者。则无生义。本已是有复何用生。若定异者。则应生异果。既俱是异因。何故但生自果。不生余果。既自他一异。俱不可得。故知不俱从自他生。所以文言二亦尔。故四不从自他生者。是无因义。若汝谓诸法不从因缘。而自有者。则一切诸法互能相生。火应生水。水能生火。等无因缘故。若不尔者。无因生义。即不得成故。文言从无因亦然。于四句中。求觅生相。并不可得。是故当知。决定无生。复次若汝难即与证量相违。若诸法无实性者。则能所皆不可得。声不至耳。耳不得声。我现见声耳相对。所以得闻。故知不空者。是义不然。何以故。是能所及证量自性。皆不可得故。汝言由自性得成故不空者。是义不然。何以故。此自性于根尘证量中。一异有无等。皆不可得故。自性不成。若汝说云何不可得。由多因成故。若法有自性。即不由因得成。已成物者。更生无用故。若汝言多因各生声自性。譬如鼓声。必由手桴等因缘。随此手等各自分。有得声义者。是义不然。何以故。前自他等四句中。觅生不可得。由性空以显故。若一性不成者。多性云何成。若汝立自性者。是因不劳立。何以故。自性自是有。何复用因为。若汝说一果由一因得成。果以因为体故。若尔但应一人得闻。何以故。由一人击鼓。但一人应闻。余人那并得闻。若多人共闻。则知因果不得一体。若汝说有多果。即从多因生。随至而取。如人散种田中。人田是一。而种子众多。所生芽等。亦复不少。亦如一人打鼓。鼓声众多。故人闻亦多者。是义不然。何以故。本不可取故。若本已有自性。何得称言现见。因打鼓已。后方闻声。若汝说声自性本有。由八种不了故未得者。是义不然。何以故。虽近远等。亦不得闻故知本无自性。若汝说一声转作多声者。是义不然。何以故。一多数相违故。倒义应成。汝义本坏。一多数相违者。汝所立义。声有三种。一但与果相违。二双与因果相违。三但与因相违。初刹那声。但与第二刹那声相违。最后刹那声。但与因相违。无更有别果。中间无数声。前后相望。有无量因果。自俱相违。以是义故。一声生无量声者。是义不可。何以故。一时俱闻故。若前后生多声者。则应前后而闻。不前后闻。一时俱闻者故知非一声生无量声。复次倒义得成故者。若汝谓一能生多。我亦言多能生一。汝若不信多能生一。我亦不信一能生多。复次汝义本坏故者。汝义云。有物德事等三种。唯于物中。可说有德有事。不于德中更复立德。而汝今于声德中。分别有数量德。宁不自乖本执耶。若汝说是数量。但依名句味。不依于声。譬如劫来烧屋。实是火烧。以火与劫相应故。非是劫烧。由火依劫故。故云劫烧。数量亦尔。实是名句味家德。此名句味。与声相应故。数量德依声而说故。我义本不失者。是义不然。何以故。名句味耳根所得故。此名句味为是声。非声耶。若是声者。不应有德。诸德无体故。若非声者。闻声之时。则不应得。于名句味。若一时得。云何复言名句味等有于数量。而声无耶。故知汝义自乖于本。此前破鞞世师

复次破僧佉义应知。内曰。汝义云。声有自性。与自性不异故者。是义不然。何以故。若声有自性。则声应为耳本故。若说声是耳。耳即是声。可说自性即声。声即自性。若不许耳即是声者。亦不许汝声即自性。若汝说声是所闻。耳不尔者。是义不然。何以故。汝声与耳。为一为异。若汝说声是所闻与耳异者。已所闻故与自性亦异。若说声与耳不异者。何故不说声能闻耳。若汝说德如耳者。是亦不然。何以故。若声灭时。耳应俱灭。声耳是一故。如耳声一物不成例。余成不成亦尔。故知诸法决无自性。悉皆是空。若汝说证量。云何成者。是义不然。何以故。今我立证量。显了二空。诸法空故。自性不可得。如见幻事。幻物者证量。所见不如实有诸法亦尔。不如所见而有所见。由体不实故。不有由证量故。不无由体无故。空义得成。以证量故。假有不失。复次一切诸法。无有自性。何以故依因缘生故。譬如火依他而生。离樵即不可见。亦如萤火若火有自性。则应离樵空中自燃。若自燃有。则应离于燃具为更生事。则无有用火成无事。一切诸水所不能灭。若汝说有自性故。是故可灭。若无自性。如幻化火无有实性。无对治故。水不能灭者。是义不然。何以故。责汝此火为本有性。为是无性。若本有性者。末亦是有。本末既有。则应是常。不应可灭。复次自性各各自不同。可相坏故。譬如作事。后作事成。前事则坏。如火为水所灭。若一切法各有自性。何能相灭。若汝说若无自性。则火与樵不得异者。是义不然。何以故。多有过失。能所不异故。若一不异者。有何能所火樵二物。亦可说言。樵为能照。火为所照。若不尔者。则汝义本立一不成。外曰。若汝说火离一异者。云何说火从因缘生耶。内曰。如樵中色等五尘。是时不成樵。即于一时并成热性故。四大四微等八物。皆不一不异。若言冷热等八物一异者。是义不然。何以故。若是一者。冷应至热。即堕常见。若言异者。简空而生。即是断见。缘冷生热。故若异者应有八火。火若有八。一火不生。并如前说。是故诸法悉依缘生。何以故。相续不度故相续故不断。不度故不常。以是义故。断常见灭。不一不异。随世间故。亦说一异。复次若汝说能量所量二法成就。所以诸法各有自性故不空者。是义不然。何以故。量从自生故。不缘所量境而能量智自成者。无有是处。既无所量。能量之名。对何而立。则量何所量耶。若汝说由观所量故。得成能量者。是义不然。何以故。若前境未有。即量何所缘。所量者。是所缘境。能量者。是能缘智。若所量已成。能量何用。所本由能故得所名。若能量未有。已成所量。则能量无用。若所量不关能量。自得成者。有何能所。若汝说能量所量。更互相成。是二各有自性。而更互相合故。一名能量一名所量者。是义不然。何以故。若未相对时。两法已成。而后时得名者。有四过失。一者相对无用。何以故。一切诸法未被缘时。已成所量。智亦如是。未能缘时。已成能量。既自性已成。何用相对。二者为何事未足。复须相对。若为立名。须相对者。体既已立。何故无名。若汝谓体本自性是有。但未相对故。未有名者。是义不可。既未有名。云何有体。三者所量前成。能量后成者。若所量已成故得所量。能量未成。复何所对。而名所量。四者若能所俱时成者。则能所义坏。如牛角并生。则无能所。既前后俱时。求觅自性。皆不可得。故知诸法悉空。复次若汝说。譬如灯为能照。瓶为所照。灯瓶二物本性是有。但相对时名能所照。故量义得成者。是义不然。何以故。灯譬未成故。与量不相似。岂得为譬耶。若汝说云何未成者。灯中无暗故。故不照自体。若照自体体是所照。如瓶等譬。瓶既须别。灯来照灯。亦应更有别灯照之。此则照照无穷过故。而不然者。汝谓证量相似故取灯为譬者。我明不相似故不得为譬。何以故。灯但照他。决不照自。若体有暗。可须自他来照。体既无暗。何劳自他照耶。不如瓶等物体暗不自显故须灯照。若灯复须照。则应更有别灯来照。而不尔者。定知灯但为能照。非是所照。量即不尔。是能是所。能缘前境。名为能量。即自智缘。及为他智缘。故名所量。即自缘者。如眼识为证量。直对前色。不能分别作是青意。若作是青意。解即是意识。是则二心俱起。眼识取色不能自取。意识分别青黄。即是取。眼识不能取自见色境故。但分别眼识所得者。即是所量分别。眼识即是能量。是故证量由他分别故得成立。灯则不尔。但是能照。非是所照不由他照故得成立。以是因缘。不得举此譬于证量。若灯能自照。不更须别灯照者。瓶等亦应自照。不更须别灯来照。若灯体暗故。应照自体。而不须别灯照者。瓶亦应尔。瓶体有暗。则应自照自体。亦不劳别灯来照。瓶应自照故。是则瓶灯一种俱应自照。并不由他。则瓶与灯。复有何异。若灯不应照者。云何能照自体。若体无暗不须照者。复何劳照。若照自体者则有二失。一者体应有暗故须照者。此则与瓶为一。瓶有暗故。既不能自照灯亦有暗。云何能照。二者能所照一。既是一体。竟谁为能所照耶。汝灯譬既不成。证量义亦坏。又不但用一色为瓶。而合八物为瓶者。唯见一色。云何得瓶若见一色。即是瓶者。唯色是瓶。故知证色不证于瓶。又色亦不可证何以故。邻虚色不成就故。汝谓邻虚微尘常不可空故。聚众多成尘。色义则尔者。为当就一尘中有六方不。若有六方。即成六分。若无六方。非谓为色。既有六分。即可分析。若有方无分。是则六尘共入一尘。无量诸尘并应如是。则无成大义。又如一尘。日光照时。为照一边。为东西俱达。若唯照一边则有六分。若东西俱达。色则非有。故知方分不实。悉并是空有何证见。既无有证量。比等诸量。理当自失。又如自性离色等诸尘不可得比。瓶亦如是。若汝云先须证见。后则比知。如先曾证见火与烟相应。有火比烟。后时见烟。虽不见火。而由于前曾见火故。比度前时。知有火者。是义不然。何以故。汝谓由色等尘能比知自性。先来未见。云何由色等而得比知。瓶亦如是。知先来未曾证见。云何见色能比知瓶。是则由证量故有比量。此义不成。证既不成。比譬圣言等量皆失。又有过失。因果无差别故。比智不成。若汝谓自性生五唯等自性为因。五唯为果。因中已有果。果时亦有因。至五唯时。自性终不失。五唯自性即并本有故。自性五唯其体则一。若尔因果无差。云何说五唯能比知自性。此即自体以比自体。义何谓乎。复次破鞞世师义。应知。若汝谓瓶等与色等异者。云何得证若离色等诸德。是物可证者。应知石女有儿用炎水浴。被龟毛衣着兔角屣。戴空华鬘。入闼婆城。共化女戏。是等亦应可证。若此不可证者。瓶等亦尔。色等既无。瓶云何有。如瓶一切诸量亦皆不成。如是自性悉不可得。故知诸法一切皆空。复次为破僧佉执应知。若汝说因中有果故。诸量不成。如诸法有自性者。是义不然。何以故。因果一体故。汝谓自性因中即有果。诸法中即有自性故得比知。若尔因果为一为异。若一者。一体无有异故。不可相比。若汝说因果不一者则自违汝义。若因中定有于果。即成二失。一者以因即果。则失于因。自性一故。只得是果。云何有因。二者若已有果。因则何用。本由因生。果既已有。何复用因。若汝说是因有故自性不失者。是义不然。何以故。自性处所无故。若汝说由密空处故。云何无处所者。是义不然。何以故。密空处并未有故。密者谓四大四尘八物。空者谓空大声尘二物。如此五大五尘二处。并未有者。自性云何得立。自性未变异时。五唯五大。并未有故。空大是空处。四大是密处。二处昔未有时。汝立自性。为在何处。若汝说先自性未有空密者。是义不然。何以故。生因违本故。若变异前未有空密。则无因用。当变异时。始有空密。方有因用者。是则变异。应能生自性。若汝说是时此二未有者。是义不然。何以故。因不成就故。何物为先耶。若汝谓无物先自性者。是义不然。自性无住处故。若无处所。则违汝圣言故。迦毗罗仙为阿修利婆罗门说。昔初唯有一暗冥。此中但有智由处所。既无法。引圣言即自相违。自性及我并不成就。复以何譬得立自性。若汝说第三是其譬喻者。亦复不然。何以故。有二过失故。一者自失本义。二者因性不成。若汝说无异即是譬者。是义不然。第三不成故。若汝说由无异故。第三得成者。是亦不然。但有数故。若汝说数有。即乖义本。若汝所说义本若有数。数即义者。是亦不然。何以故。数灭时义亦坏故。变异与自性。则为无异。如不如并皆不立。自性及变异。无差别故。则因与果为一。并亦不成。若汝说若因果一者。则无言语故。汝难亦无。若因果异者。一义不然。何以故。有三过失故。一自违汝义。二成自颠倒。三言语无因。一自违义本者云何。如此今我取汝义还难汝。汝为信为不信。汝若信我难。汝义即坏。若不信我难者。汝难亦非难。何以知然。由我难故。汝语义得成者。我义亦立。汝所立义。是何时中。为在我难前。为后。为俱时。若在前者。我未有难汝对破谁。若在我难后。我义已成。汝义那立。若俱时者。则无能所。如江海水一时和合。云何辩异。汝我二义便无差别。即成我义。二自颠倒者。汝取生义。难我显义。此非难处。若我立生义。汝可以三时为难。难我生者。不离三时故。若三时不立。是生不成可尔。显义者。由道理故立。若有道理。则三时无异。若无道理。则不能显义。是故不成。不由三时故。是故难生。须依三时。今所难者。须依道理。汝将时节。难道理义故。自成颠倒。三言语无因者。言语由义得成。若无义者。语言不立。因果一体。异义不成。故无语言。若汝说是因是果者。是义不然。何以故。有无常过故。果既无常。因亦应尔。若因无常。则违汝义本。汝因是常。果是无常。果色等变异不可得故。若汝说由色所比故。非不可得者。义亦不然所比无有故。并如前破。证量不成故。比量亦不成。未有空密处故。因无住所。故不得成。若汝说若无可比。比量亦得成。如比有四句。一有比无。二无比有。三有比有。四无比无者。是义不然石女儿兔角等。并应可比。色等可证。非可证。此义何用。是因无道理故。不可得成。若汝说如邻虚空尘。以果比因。自性亦尔者。是义不然。以邻虚不成故。因果异故。离色等尘。不可得故。故譬不得成立。若汝说取非证。比非所证。如地下水。不可知见。比自性我亦如是者。是义不然。何以故。若汝能因石女儿。比龟毛者。我则信汝。因邻虚尘得比自性。若汝说如灯自成。比量亦尔者。是义不然。何以故。离色等八物。灯不可见故。如邻虚尘。离色等亦不可得。所比自性亦不可得故知无自性。若汝说忆知有故。故证量比量并成。若无证比。复何所忆者。是义不然。若离三种知。外方有忆知。证比不成故。三种知者。一异境知。二能别知。三一知。异境知者如人见瓶。后时忆衣。此非谓忆。汝义亦尔。色即异物。已见色时。便忆于瓶。故义不可。二能别知者。譬如张即见瓶。王即后忆者。无有是处。汝义亦尔。觉能取境。我能忆知此两别类不同。是觉前见。我后忆知。无是义故。三一知者。如人正看瓶时。不得生忆。若有忆知。则二过失。一者两知一时不得俱起。以心是一故。心取色时。不得取声。二者根正对境未舍。那复得忆余境。汝觉亦尔。唯是一知。无念念灭。从变异初。至解脱前际。恒是一故。是忆知中。无有忆知。若翻此三知。忆知得成。谓境界同类。能知同类。知念念灭。不得一时。备此三义。忆知得成。汝忆知不成。故证比等量亦不得成。以是缘故。自性义坏。若汝说忆知由自性。所以得成一异。有无等造。初念取境。则备三义。一境二人三智。并一时俱有。至第二念时。前三已灭。后三续起。前后同类。是为一义。前后各一。亦是一义。前无后有。是为异义。前能生后。是其有义。前灭后生。是其无义。备此诸义。故有忆知。由自性故。忆知得成者。内曰。若尔我大欢喜。翻成我义。有何损失。我今由此义故。说无自性。譬如前种能生后谷。此前后谷。不一不二。不有不无。若一者。则无前后。若异者。则前谷后豆。故无一异。自性不有不无者。因灭果生故。因灭故不有。果生故不无。因时未有果故。不可说有。果生时必由因故。不可说无。以是义故。因果忆知并得成就。故说无自性。如谷前后。不一不异。能作种种诸事。忆知亦尔。前后不一不异。故能忆知种种诸境。若汝闻忆知。若是无常。云何修习者。答曰。已无常故。则有修习。譬如劫波婆种子。种植于地。以佉陀罗汁。而溉灌之。后时出生芽茎枝叶。是其自相无有异色。唯果熟时。即成佉陀罗色。为相红赤异。劫波婆自相本色。如是心者。作法非法。是法次第前心熏习后心。如是方便熏习不失故不一异。至果熟时。苦乐等果。即各显现。是故从无自性心诸业得生。如劫波种子。后同佉陀罗色。若作此执。有自性心。是名忆知。或有人说寿者。亦是忆知。若作此执。即无忆知心及寿者。有自性故。则无忘失。若汝说有忘失者。有二过失。一者忆知。若有自性。则无忘失。若有忘失。则无忆知。如此忘失。为有自性。为无自性。若有自性。与忆知性为相违不。若不相违。于一物中。便应一时俱有忆忘两心并起。若相违者。但有自性忘失。则无忆知。忆知既无。何所忘失。若汝说是知先生后灭故说忘失。若尔者自性则不成。若有忆知。自性作具无用。忆知恒有故。若汝说由作具故得成者。则无自性。有过失故。若作者与具一体。则无忆知。知恒有故。若知无者。心或时无。则无自性。心或时有。则无忆知。若无忆知。心则应灭。若汝说有别物故。心得是常者。证知之时。应不忆知。即以证知。当忆知处。是故不失忆知体者。是义不然。何以故。若物常住。则无数习。同类相似。乃可数习。若无自性。似义可成。若有自性。即应恒守一物一事故无相似。无相似故。则无数习。无数习故。则无忆知。若汝立自性忆知者。比量等并不成就。以一体故。一切疑心应是决智。欲即离欲。偷即是施即妇是母是觉。若与自性不异。为当先有。为当后有。若先有者。所觉既无。觉何所觉。若后有者。则因中果义即自坏。若汝说本有者。所觉何物。若言我是所觉者。是义不然。以证比二量我不可得故物若是有不离二量所得。譬如五尘五根。五尘者智不重生故。是名证量。比量者智重生故。先见识生。后比知有根。以识不离根故。如先见烟。后知有火。我者则不尔不如色等可证。过根境故。不如诸根可比。无有相应事故故我非所觉。是故觉若在前。则不成觉。故知一切法如实无自性。唯真实空。是其体性

    佛性论破执分第二中破大乘见品第三

复次为破大乘中学有偏执者应知。若汝说一切有皆由俗谛。一切无。皆由真谛应作此问。善友何者是真实。何者是俗谛。答曰。一切诸法无有自性。是为真实。于无自性法中。说有自性。是名俗谛。以于无中假说有故。问曰。是执无有自性。为当依世俗言故有。为当唯是语言。若依世俗言。有此执者。此执则不可说。何以故。执是无故。若此执唯是语言。则无所诠世俗语言不成就故。若不成就。是世俗者。是义不然。又若汝谓于无自性中。执有自性。是名为俗。若执有者。云何是无。答曰。为颠倒品类故。故无中说有。乃至于无常乐。我等诸法说言皆有。常等诸德。其体实无。但假说有。如此执者。为四倒摄。是故虽执是有。而得是无。问曰。如此颠倒为有为无。若是有者。一切诸法无有自性。是义不然。若是无者。此执颠倒亦不得成。若无性中。执有自性为俗谛者。是义不然。何以故。二谛不可说有。不可说无。非有非无故。真谛不可说有。不可说无者。无人法故。不可说有。显二空故。不可说无。俗谛亦尔。分别性故。不可说有。依他性故。不可说无。复次真谛不定。有无人法。无不无二。空有不有。俗谛亦尔。分别性故。非决定无。依他性故。非决定有

佛性论卷第一佛性论卷第二

        天亲菩萨造

        陈天竺三藏真谛译

    显体分第三中三因品第一

复次佛性体有三种。三性所摄义应知。三种者。所谓三因三种佛性。三因者。一应得因。二加行因。三圆满因。应得因者。二空所现真如。由此空故。应得菩提心。及加行等。乃至道后法身。故称应得。加行因者。谓菩提心。由此心故。能得三十七品。十地十波罗蜜。助道之法。乃至道后法身。是名加行因。圆满因者。即是加行。由加行故。得因圆满。及果圆满。因圆满者。谓福慧行。果圆满者。谓智断恩德。此三因前一则以无为如理为体。后二则以有为愿行为体。三种佛性者。应得因中具有三性。一住自性性。二引出性。三至得性。记曰。住自性者。谓道前凡夫位。引出性者。从发心以上。穷有学圣位。至得性者。无学圣位

    佛性论显体分第三中三性品第二

复次三性所摄者。所谓三无性。及三自性。三无性者。一无相性。二无生性。三无真性。此三性摄如来性尽。何以故。以此三性通为体故。无相性者。一切诸法但名言所显。自性无相貌故。名无相性。无生性者。一切诸法由因缘生故。不由自能生。自他并不成就故。名无生性。无真性者。一切诸法离真相故。无更别有实性可得故。名无真实性。复次三种性者。一分别。二依他。三真实。别有十种义。应知。何等为十。一分别名。二缘成。三摄持。四体相。五应知。六因事说。七依境。八通达。九若无等。十依止。一分别名者。为随名言假说故。立分别性。若无此名言。则分别性不成。故知。此性但是名言所显。实无体相。是名分别性。依他性者。是十二因缘所显道理。为分别性。作依止故。故立依他性。真实性者。一切诸法真如。圣人无分别智境。为清净二性。为解脱三。或为引出一切诸德故。立真实性。是名分别名。二缘成者

问曰。分别性。缘何因故。而得显现

答曰。由缘相名相应故得显现

问曰。依他性。缘何因故得成耶

答曰。缘执分别性故得显现

问曰。真实性。缘何因得成

答曰。由分别依他二性极无所有故得显现。故名缘成。三摄持者。性有三种。法有五分。言三性者。所谓分别。依他。真实。五法者。一相。二名。三分别思惟。四圣智。五如如。前三是世间智。圣智是出世智。如如是无为境。为明此五法摄前三性故

问曰。于五法中。几法摄第一性。答曰。五法并不可摄。何以故。为无体故。问曰。第二性几法能摄。答曰。有四法摄。问曰。第三性几法能摄。答曰。唯如如一法能摄。问曰。若依他性为圣智所摄者。云何说依他性缘分别性得成。答曰。依他有二种。一染浊依他。二清净依他。染浊依他。缘分别得成清净依他。缘如如得成故。四体相者有二。一通二别。通者。由此三性通能成就一切诸余真谛。或二三四七谛等法。故诸真谛不出三性。是以三性为诸真谛通体。二别体者。于三性中。各有实义。何者实义。一者分别性体。恒无所有。而此义于分别性中。非不为实。何以故。名言无倒故。二者依他性体。有而不实。由乱识根境故是有。以非真如故不实。何以故。因缘义无倒故。是以对分别性故名为有。对后真性故非实有。是名有不真实。三者真实性体。有无皆真如如之体。非有非无故

问曰。是三性实相云何

答曰。分别性实相者。人法增益及损减。由解此性故。此执不生。是分别相人法者。是分别所作。若依真谛观。此人法为有名增益执。若依俗谛观。此人法是无名损减执。若通达此分别性。则增益减损二执不生。是名分别实性相。复次依他实性相者。能执所执增益及损减。由解此性故。故此执不生。是名依他性相。此能执所执。若见真为有。则是增益。名为常见。若见俗定无。则是损减。名为断见。若通此二性。断常二执并不得生。是名依他实性相。唯有似尘识故。则无能所。无能所故。无增益执。由有似尘识故。无损减执。复次真实性相者。有无及增益损减执。由解此性故。执不得生。所以者何。若执空为有。名增益谤。若执空为无。名损减谤。若通达此性。则二执不生是名真实性相。五应知等者

问曰。是三性几应知。几不应知

答曰。一切应知何以故。由知三性。能通达三解脱门能除三障故。知分别性。能通达空解脱门。能除肉烦恼。知依他性。通达无愿解脱门。能除皮烦恼。知真实性。能通达无相解脱门。能除心烦恼。又初解脱障。次禅定障。后一切智障故。问曰。三性中。几性不可灭。几性可灭耶。答曰。二性不可灭。一性可得灭。何以故。分别性本来是无故不可灭。真实性本来是真故不可灭。依他性虽有不真实。是故可灭。以是义故。说应知等。六因事说。诸佛说法有二种。一了义经。二不了义经。不了义经者。由此三性。是故佛说不了义经。如缘有灯故。知物在暗中。后时因灯能得了现暗中之物如来亦尔。由有着三性者故。说不了义经。达三性者。自然显了。名了义经。如经中说。若人已得无生法忍。则不退堕。问曰。此言云何成立。答曰。由有三性故。则得成立。如来约分别性故说本来无生忍。约依他性故。说自性无生忍。约真实性故。说惑垢苦本性无生忍

问曰。如来约何性。说如此义。言一切诸法无生无灭。本来寂静。自性涅槃耶。答曰。约无相性。说如是言。问曰。如来约何法。说一切诸法譬如幻化耶。答曰。约无生性说。问曰。如来约何法说如是言。一切诸法譬如虚空。答曰约真实性说。是故佛因三性说故。有了不了义经。七依境者。问曰。此三性为何智境。答曰。分别性者。唯是凡惑境。非圣智境。何以故。无体相故。依他性者。为圣凡俗智境。是俗有故。真实性者。唯为无分别圣智境。如量如理故。如量则摄一切。如理则无颠倒。是名依境。八通达者

问曰。修观行人。若通达分别性者。为当可说行执相中。为不可说行执相中耶。答曰。若由世俗智分别。可说行执相中。若由出世无分别智通达者。可说不行于执相中。是故依他与分别同一无相。如分别依他。真实亦如是。问曰。修观行人。能如真实理。入分别性。照了何性耶。答曰了真实性

问曰。修观行人如真实理。入真实性。照了何性。答曰。了依他性故。然后得真实性。是名通达。九若无等者。问曰。若分别性无。有何过失。答曰。若无分别性。则名言不立。名言不立故则依他性不得成就。乃至净不净品。并皆不立。问曰。若无依他性。有何过失。答曰若无依他性。一切烦恼不由功用。应自能灭。若尔净品亦不得成。问曰。若真实性无。有何过失。答曰若无真实性。则一切一切种清净境不得成故。一切者。别摄真俗尽。一切种者。通摄真俗故。问曰。是真实性者。为可立净为立不净。答曰。不可得说定净不净。若定净者则一切众生不劳修行。自得解脱故。若定不净者。一切众生修道即无果报。若定净者。则无凡夫法。若定不净者。则无圣人法。何以故。净不净品皆以如为本故。若其定净。不即无明。若其不净。不即般若。此两处如性不异故此真如非净。非不净何以故。欲显真如异眼等诸根。异禅定心等故。异眼等诸根者诸根既不被染亦应得同如理清净。而不然者。以有漏业为因故。从本不净。真如不尔。在于佛地本性清净。无有从本。是不净义故异诸根。异定心等者。定体本性自净。可得同真。而为四惑所啖故。转成不净。真如之理。本来清净则不如是。虽复在无明[穀-禾+卵]中。终不为彼所污问曰。此三性几性无体。能生有体。答曰。唯分别一性无体能生依他性体。问曰此几性有体。能生有体。答曰唯是依他一性有不实体。还能生依他体。犹如无明生诸行等。问曰。此三性几性有体。能生无体。答曰真实一性能灭依他。令其无体故。是名若无等。十依止者。问曰分别性依何法得成。答曰。依三法故成。何者三。一相。二名。三思惟。依此三故。分别性立。问曰。依他性依何得成。答曰。依四法成。四法者。谓相名分别圣智等。依此四法故。依他性成。问曰。真实性依何法得成。答曰。此性无住无著无有依处。境无分别

    佛性论显体分第三中如来藏品第三

复次如来藏义有三种应知。何者为三。一所摄藏。二隐覆藏。三能摄藏。一所摄名藏者。佛说约住自性如如。一切众生是如来藏。言如者。有二义。一如如智。二如如境。并不倒故名如如。言来者。约从自性来。来至至得。是名如来。故如来性虽因名。应得果名。至得其体不二。但由清浊有异。在因时为违二空故起无明。而为烦恼所杂故名染浊。虽未即显。必当可现故名应得。若至果时。与二空合。无复惑累。烦恼不染。说名为清。果已显现故名至得。譬如水性。体非清浊。但由秽不秽故。有清浊名。若泥滓浊乱故不澄清。虽不澄清。而水清性不失。若方便澄渟。即得清净。故知净不净名。由有秽无秽故得。非关水性自有净秽。应得至是二种佛性亦复如是。同一真如。无有异体。但违空理故起惑着。烦恼染乱故名为浊。若不违二空。与如一相。则不起无明。烦惑不染。所以假号为清。所言藏者。一切众生悉在如来智内故名为藏。以如如智称如如境故。一切众生决无有出。如如境者。并为如来之所摄持故名所藏。众生为如来藏。复次藏有三种。一显正境无比。离如如境。无别一境出此境故。二显正行无比。离此智外。无别胜智过此智故。三为现正果无比。无别一果过此果故。故曰无比。由此果能摄藏一切众生故。说众生为如来藏。二隐覆为藏者。如来自隐不现。故名为藏。言如来者。有二义。一者现如不颠倒义。由妄想故。名为颠倒。不妄想故。名之为如。二者现常住义。此如性从住自性性来至至得。如体不变异故是常义。如来性住道前时。为烦恼隐覆。众生不见故名为藏。三能摄为藏者。谓果地一切过恒沙数功德。住如来应得性时。摄之已尽故。若至果时方言得性者。此性便是无常。何以故。非始得故。故知本有。是故言常

    佛性论辩相分第四中自体相品第一

复次佛性一切种相有十义应知。言十相者。一自体相。二因相。三果相。四事能相。五总摄相。六分别相。七阶位相。八遍满相。九无变异相。十无差别相。一自体相者。有二种。一者别相。二者通相。别相有三种。何者为三。一者如意功德性。二者无异性。三者润滑性。所言如意功德相者。谓如来藏有五种。何等为五。一如来藏。自性是其藏义。一切诸法不出如来自性。无我为相故。故说一切诸法为如来藏。二者正法藏。因是其藏义。以一切圣人四念处等正法。皆取此性作境。未生得生。已生得满。是故说名。为正法藏。三者法身藏。至得是其藏义。此一切圣人信乐正性。信乐愿闻。由此信乐心故。令诸圣人得于四德。及过恒沙数等一切如来功德。故说此性名法身藏。四者出世藏。真实是其藏义。世有三失。一者对治。可灭尽故名为世。此法则无对治故名出世。二不静住故名为世。由虚妄心果报。念念灭不住故。此法不尔故名出世。三由有倒见故。心在世间。则恒倒见。如人在三界。心中决不得见苦法忍等。以其虚妄故名为世。此法能出世间故名真实。为出世藏。五者自性清净藏。以秘密是其藏义。若一切法随顺此性。则名为内。是正非邪。则为清净。若诸法违逆此理。则名为外。是邪非正。名为染浊。故言自性清净藏。故胜鬘经言。世尊佛性者。是如来藏。是正法藏。是法身藏。是出世藏。是自性清净藏。由说此五藏义故。如意功德而得显现。佛为显此义故。说如意宝。譬如人以宿业故。感得如意宝珠。得此珠已。随其意所乐事。自然得成。佛性亦尔。由伏事善知识。修诸福慧。感得此性。便随修行者意。各各自得三乘之果故。如意功德是其别相。二无别异性者。凡夫圣人。及诸佛无分别。心性过失。功德究竟清净。处平等遍满。譬如虚空。又如土银金器。此三虽异。而其性等皆是空。空处不别故。名无别异性

释曰。言过失者。谓凡夫。功德者。即有学圣人。究竟清净者。即诸佛。此三处虽殊。而其性不异。此即以土喻凡夫。银喻学者。金喻诸佛。虽复三器有异。而其空性一种故。又是有清净遍满等三义。有者显无为义。清净显无染义。遍满显无碍义故。佛告舍利弗。众生界不异法身。法身不异众生界。由此义故。无二无别。唯有名字。如是佛性。于三位中。平等遍满。由净不净品。无变异故。故说如虚空性。三润滑性者。辩如来性。于众生中。现因果义。由大悲于众生软滑为相故。大悲者。有三义。一体。二大。三别异。一体义者。以般若为体。般若有二。一无分别真智。二有分别俗智。今取有分别智。为大悲体。以大悲缘众生起故。二大义者。有五。一为资粮。二为相。三为行处。四为平等。五为最极。一资粮者。能作大福德智慧。二行资粮故。二为相者。能观三苦众生悉济拔故。三为行处者。通三界众生为境界故。四为平等者。为于一切众生处。起平等心故。五最极者。过此修外无更胜行故。三别异义者。有八种。一为自性差别。悲无量者。以无嗔为性。大悲者以无痴为性。二为相差别。悲者以苦苦为相。大悲者以三苦为相。三为行处差别。悲者以欲界为境界。大悲者通三界为境界。四为地差别。悲者以第四禅为其地。大悲者以无流如来果为其地。五境界差别。悲者以凡夫及二乘为境界。大悲者唯菩萨与佛为境界。六为德差别。悲者以离欲欲界德。大悲者离欲三界德。七为救济有差别。悲者但有拔苦之心。无拔苦事。大悲者有心有事。八为究竟不究竟差别。悲者能小暂救济。不能真实救。大悲者能永救济。恒不舍离故。润滑者。润以显其能摄义。滑者显其背失向德义。譬如水界。亦有二能。一则能摄散物唯滑不涩故。由润故。能摄由滑故。不涩故。以润者为因。以滑者为果。故曰现因果义。复次自性清净是其通相义者。如前实空水界等譬并自性清净是其通相故。如来性在烦恼中无所染污故。此四相为四惑障故。为非四人所得故。为四德作本故。为离四倒故为灭生死对治故。故说四相通一别三。一通相者。唯有自性清净相。三别相者一不可思惟。二应得。三无量功德。是名自体相

    佛性论辩相分第四中明因品第二

复次有四种因。能除四障。得如来性义应知。四因者。一信乐大乘。二无分别般若。三破虚空三昧。四菩萨大悲。四障者。一憎背大乘。二身见计执。三怖畏生死。四不乐观利益他事。初障阐提。二障外道。三障声闻。四障独觉。由此四惑。能令四人不能得见自性清净法身。若略说世间有三种众生。一乐生死恒有。二乐灭生死有。三两俱不乐。有灭并忘。一乐生死有者。复有二种。一憎背解脱道。无涅槃性。决乐生死。不乐涅槃。二已堕定位。定位者非圣非凡。进退无取。而是佛法内人。背大乘法。因此人故。佛说是言。我非是其师。其非我弟子。舍利弗。此人从轻暗入重暗。复从重暗。入于盲暗。取暗为友。复取阐提为友。是故我说此人如是二乐。灭生死有者。有二种。一堕非方便。二堕方便中。就堕非方便。复有二。一外道。谓九十六种。二是佛法内人。与外道同执。约正法起邪执我见故。于正教义不能了达。因此人故。佛说是言。若不信乐真空。则与外道无异。复次有增上慢人。取空为见。是真空实解脱门。约此空解脱门。起于空执。谓一切有无。并皆是空。此空执者。即无所有。无所有故。因果二谛道理并失。执此空过故即堕邪无。是等执者。由空而起。故成邪执。一切邪执。莫不由空。故能灭除。此执既依空起故不可治。因此人故。故佛语迦叶。若人起我见。执如须弥山大。我亦许之。何以故。以可灭故。若此增上慢人所起空执。犹如发端四分之一。我急呵责。决定不许。二堕方便中有二。一声闻人。自利修行。但为自度。不为利他。二独觉人。于利他心。无乐无事。但起舍心。无乐者。不乐利他。无事者。了无度人之事。唯为自觉自利故。但起舍心者。舍是平等住心。不愿利人。亦无所损。独自觉悟故言独觉。堕方便声闻亦尔。如末田地及阿斯那二比丘。佛涅槃时。其皆不往。后至迦叶集法藏时。被召方出。迦叶呵责之言。汝为从佛得圣道不。答云实尔。又呵责言。汝大过失。今去。当以佛法付。汝任持。若不如法。罪失属汝。其人甘失忏悔。受旨奉行。三俱不乐者。谓修行大乘最利根人。既不同阐提乐生死有。亦不堕非方便中。同外道执。亦不堕方便中。如二乘人。是故此人具行生死涅槃平等之道。住无住处。虽行生死而不染。虽行涅槃亦非净。但为大悲故。不舍生死。为般若故。不舍涅槃。不离涅槃者。异声闻执永住无为。不舍生死者。异一阐提乐于生死。若乐着生死者。名一阐提。佛法内人。堕定位者。亦同阐提。如是二人。堕在邪定聚中。若乐灭生死有者。是人堕非方便中。则在不定聚。若人乐灭生死有。是人堕方便中。及俱不乐。得前二者。修平等道。是人在正定聚中。离发行大乘修习无障道人之外。所余阐提外道声闻独觉等四人有四种障故。不见佛性。何者四障。一憎背大乘。是阐提障。为对治此故。佛说菩萨修习信乐大乘之法。二于诸法中。起我见执。是外道障。为对治此故。佛说菩萨修习般若波罗蜜。三于生死中。定执苦想。及厌怖心。是声闻障。为对治此故。佛说菩萨修习破空三昧。空三昧者。从初地以上能得此三昧。则破虚空等执。入观之时。不即有无。不离有无。喻如八地真俗双观。而异八地者。八地以上无出入观。初地入时则同。出时则异。四背众生利益事。作舍众生意。是独觉障。为对治此故。佛说修习菩萨大悲。菩萨大悲利他为事。明独觉人但自观因缘。无度他意故无大悲。声闻亦尔为灭此四障故。以信乐等四种为因。令诸菩萨修习此因。得至无上法身清净波罗蜜。是名佛性清净因。如是之人。得名佛子。是故佛子有于四义。一因。二缘。三依止。四成就。初言因者。有二。一佛性。二信乐。此两法佛性。是无为信乐。是有为信乐约性得佛性为了因。能显了正因性故。信乐约加行为生因。能生起众行故。二缘者。谓般若波罗蜜。能生菩萨身。是无为功德家缘故。三依止者。破空定等。乐有之人执断。无处有乐净等故。菩萨修破空三昧。能除彼执。由此定力。是故菩萨法身坚固。则不羸弱。四成就者。菩萨大悲利益他事无尽故。由真如不尽。众生无数故。利益事亦复无尽。是佛性为应得家因故。一因如父身分。二缘如母。三依止如胞胎。四成就如乳母故。诸菩萨由此四义。名为佛子

    佛性论辩相分第四中显果品第三

复次果相义应知。果相者。有二处。一者地前凡圣二位。不得四德。二者十地诸位。地前有如是信乐等四德。为清净佛性因。为对治四倒。如来法身四相功德波罗蜜是其果。应知。四倒者。于色等五阴实是无常。起于常见。实苦起乐见。实无我起我见。实不净起净见。是名四倒。倒者有三义。一见所灭。二修所灭。三非二所灭。见真谛时。能除见倒。定破思惑。能除想倒。非二所灭。能除心倒。为对治此四。说四无倒。何者为四。于色等五阴未有有已有应灭故实无常。如实起无常解。苦时苦故乐灭时苦故舍三时苦故。故实是苦。于中生苦解。无常为因。无常为果。由因果得成。以依他执故。果不自在。因亦如是。未有有已有还无既由前因。是故依他亦不自在。离因果外无别余法为我。是故无我为实。生无我解。不净有二种。一色。二非色。色不净有三。谓初中后。初者。始入胎和合。种子不净。中者。出胎已后。饮食资养。多诸不净。后者。舍身已后。身体坏时。种种不净故。非色者。或喜。或忧。或恶。或无记。或不离欲诸系缚等故非色。由此等法故不净。是以圣人通观三界。皆是不净。如是五阴。如实不净。生不净解。此四皆实。是故非倒。若约佛性。常等四德。此四无倒还成颠倒。为对此倒。是故安立如来法身四德。四德者。一常波罗蜜。二乐波罗蜜。三我波罗蜜。四净波罗蜜。如胜鬘经说。世尊。是诸众生生颠倒心。于内五取阴。无常见常。苦中见乐。无我见我。不净见净。世尊。一切声闻独觉由空解未曾见一切智智境。如来法身应修不修故。若大乘人。由信世尊故。于如来法身。便作常乐我净等解。是人则不名倒。名得正见。云何如此世尊如来法身是常乐我净诸波罗蜜。若人作是见者。名为正见。是如来胸子。胸子者。恒在佛心胸故。复次如来四德波罗蜜。由因次第渐深。应知逆说。翻后为前。谓净我乐常。由一阐提憎背大乘。为翻彼乐住生死不净故。修习菩萨信乐大乘法。得净波罗蜜。是其果应知。由一切外道色等五阴无我性类计执为我。而是色等法。与汝执我相相违故。恒常无我。诸佛菩萨由真如智至得一切法无我波罗蜜。是无我波罗蜜。与汝所见无我相。不相违故。如来说是相恒常无我。是一切法真体性故。故说无我波罗蜜是我。如经偈说

  二空已清净　　得无我胜我
  佛得净性故　　无我转成我

诸外道等。于五取阴中。执见有我。为翻其我执虚妄故。修习般若波罗蜜。至得最胜无我。即我波罗蜜。是其果。应知。由诸声闻人。怖畏生死苦乐。住生死苦灭静中。为翻此乐意故。修习破虚空三昧。一切相世出世法。乐波罗蜜。是其果。应知。由独觉圣人者。不观众生利益等事。但乐独处静住。为翻此意故。修习菩萨大悲为利益众生事。乃至穷于生死。常所持护。常波罗蜜是其果。应知。如是信乐大乘般若波罗蜜。破虚空三昧。菩萨大悲等四因。能成就如来法身四功德波罗蜜。是故佛说由此四德一切如来唯法界为胜。由如虚空。取虚空为边际极后际之后。如是四句现何等义。由修习信乐大乘法故。诸佛至得最极清净波罗蜜故。佛说唯法界为胜为上。由修习般若波罗蜜故。至得众生世界器世界极无我波罗蜜。五阴名众生世间即人空。国土四大名器世界。即是法空。是二空所显故。故说由如虚空。为修习破空三昧等故一切处诸法自在如意应得故。取虚空为边际。由修习菩萨大悲故。于诸众生。常起悲心。护持无有边际故。说极后际之后。后际之后者。假令后际有后。菩萨大悲亦能过之。是故通辩地前圣凡二位。不得四德。复次十地由四障故。未得极果四德。金刚后心。方乃得之应知。何以故。以出三界外有三种圣人。谓声闻。独觉。大力菩萨。住无流界。有四种怨障。由此四怨障故。不得如来法身四种功德波罗蜜。四怨障者。一方便生死。二因缘生死。三有有生死。四无有生死。一方便生死者。是无明住地。能生新无漏业。譬如无明生行。或因烦恼方便。生同类果。名为因缘。如无明生不善行。若生不同类果。但名方便。如无明生善行。不动行故今无明住地生新无漏业亦尔。或生同类。或不同类生福行。名为同类。以同缘俗故。生智慧行。名不同类。以智是真慧故。是名方便生死。二因缘生死者。是无明住地所生无漏业。是业名为因缘生死。譬如无明所生行是业。但感同类不生不同类果。善行但生乐果。不善但招苦报。故名因缘生死。方便生死。譬凡夫位。因缘生死。譬须陀洹以上但用故业不生新业。三有有生死者。是无明住地为方便。无漏业为因。三种圣人是意所生身。譬如四取为缘。有漏业为因三界内生身。有有者。未来生有。更有一生。名为有有。如上流阿那含人于第二生中般涅槃者余有一生故。故名有有。四无有生死者。是三圣意生最后身为缘。是不可思惟退堕。譬如生为缘。老死等为过失。是故无明住地为一切烦恼所依止处。而一切烦恼通名无明者。以无明为众惑根本。根本既未灭尽。由为一切烦恼垢臭秽熏习故。阿罗汉。辟支佛。及自在菩萨。不能至得无所染污大净波罗蜜。复次依此缘。此无明住地微细妄想相游行未息。故极不能至得无行无想大我波罗蜜。因此无明住地为缘。及微细妄想所起无漏业为因。得起三种意生身故。不能至得极离因果苦大乐波罗蜜。若未证得业难生难灭尽无余如来甘露界。及未证得不可思惟退堕界。未灭谢故。不能至得极无别异老死等大常波罗蜜。复次应知。无明住地如烦恼难。无漏业如业难。三种意生身如果报难。不可思惟退堕如过失难。若在三种意生身中。则无常乐我净波罗蜜。故如来法身是常等四波罗蜜。以如来法身一切烦恼习气皆灭尽故。是名极净。一切我无我虚妄执灭息故。故名大我。意所生身因果究竟尽故。故名大乐。生死涅槃平等通达故。故名大常。复次四德各有二缘义。应知。初有二因缘故。说如来法身有大净波罗蜜。一者本性清净名为通相。二者无垢清净故名别相。本性清净通圣凡有故名为通。无垢清净但佛果有。所以名别。复有二种因缘。说如来法身有大我波罗蜜。一由远离外道边见执故无有我执。二由远离二乘所执无我边故。则无无我妄执两执灭息故说大我波罗蜜。复有二种因缘。说如来法身有大乐波罗蜜。一由一切苦集相灭尽无余故。拔除习气相续尽故。二由一切苦灭相证得故。三种意生身灭不更生故。苦灭无余是名大乐波罗蜜。复有二种因缘。说如来法身有大常波罗蜜。一无常生死不损减者。远离断边。二常住涅槃无增益者。远离常边。由离此断常二执故。名大常波罗蜜。故胜鬘经说。若见诸行无常。是名断见。不名正见。若见涅槃常住。是名常见。非是正见。是故如来法身离于二见。名为大常波罗蜜。由此如实法界道理门故。即是涅槃。即是生死。不可分别。即是得入不二法门。亦不一不二。住无住处故由灭诸惑不住生死。由本愿故。不住涅槃。由般若故。诸惑得灭。由大悲故。本愿得成。故不可思量经偈中说

  诸惑成觉分　　生死成涅槃
  修习大方便　　诸佛叵思议

    佛性论辩相分第四中事能品第四

复次事能相义应知。此清净性事能有二。一于生死苦中。能生厌离。二于涅槃。欲求乐愿。若无清净之性。如是二事。则不得成。故经中说。世尊。若无如来藏。于生死苦。无厌离意。亦无欲求乐愿之心。故不定聚众生。起此二事为用。一于生死苦。观于过失。为依止处。生不定聚众生厌离心故。二于涅槃乐。观于功德。为依止处生不定聚。众生欲求乐愿。欲求愿乐。是四种心云何为异。初欲者名信。信有四种。一信有。二信不可思议。三信应可得。四信有无量功德。具是四义故名为欲。二求者。为至得此法。心恒勤求。无有退悔。名之为求。三乐者。思择如不如方便。如方便者。谓涅槃。不如方便。谓生死。思择涅槃。不求速证。思择生死。不求舍离。故名为乐。四愿者。从今发愿。穷未来际。恒以愿摄一切众生未曾舍离。随所行道。并入菩提愿海所摄。以自利故。不舍涅槃。为利他故。不舍生死。故有二观。一于生死观苦过失。二于涅槃观乐功德。故净分人。由清净性。此观得成。言净分者。一福德分。二解脱分。三通达分。福德分者。宿世善根能感此身。具足诸根。为受法器。解脱分者。已下功德种子。能感未来世中解脱果报。通达分者。由圣道故。能通达真如。是名净分。是人由净分为缘。净性为因故成此观。非无因缘。若不由于此二事成观无因缘。如阐提人无涅槃性应得此观。而一阐提既无此观。故知定须因缘观。方可现是清净性。不为客尘之所染污。随三乘中未起一乘信乐。又复未能亲事善知识等。乃至四种圣轮亦未相应。言四轮者。一住如法国土。二依善知识。三调伏自身。四宿植善根。轮有三义。一者未得令得。得令不失。二者能度。从此至彼。从他相续至自相续从自相续复至于他。三者能载。为能从生死得至涅槃。一住善处者。即是能修正行善人所住之处。若于中住恒见此人故得觉意。觉者觉悟。意者善心。因此受持善法等事。故佛说偈言

  无知无善识　　恶友损正行
  蜘蛛落乳中　　是乳转成毒

是名应住如法国土。二近善友善友者。有七分。如偈言

  能施重可信　　能说能忍受
  说深为善友　　安弟子善处

七分者。一能施。由能施故令地怜爱。爱故尊重。重故可信。可信故能说。由能说故能忍受外难。能忍受故能说深理。利于善友。由说深法故。能安善友置于善处。若有能备此七德者。可堪依止为善知识。若总论此七。不出三义。一乐怜愍。二聪明。三堪忍。三义若少一种。则非善友。若但怜愍不能聪明。譬如父母虽念子病不能救治。若但聪明无慈愍者。如怨家师不治他疾。若不能堪忍。则自行不足。怜愍聪明亦不成就故。离虽七种合不出三。能施尊重可信。此三属怜愍摄。能说及说深理。此二属聪明摄。能忍属堪忍摄。安善处并通三种。其聪明者。表离愚痴。能堪忍者。表异凡夫。三怜愍者。表异二乘。唯佛世尊备此三德。故堪为众生真善知识。三调伏自身心者。如正教行。闻时无散乱心。思时无轻慢心。修时无颠倒心。若不自调伏身心者。善处善友。则无所用。四宿植善根者。以为解脱分故。修善根。善根者。谓信戒闻舍智。信者不离三宝正念。戒者为不离善道。闻者自闻令他闻。不令他倒闻。不障他闻。因四闻故。今世得闻及思修等。可为法器。三慧具足。舍者有二。一由昔舍物施他。今则损于贪爱。二由昔舍法施人。今则轻灭无明。由此舍故贪爱无明并稍轻薄。以是因缘得解脱果。智者是人先世已曾思择三宝四谛故。于此生得世正见。乃至尽智及无生智。如是之人。虽具三轮。若无宿善。今生五根。则不具足。便是生于八难等处。故知若无宿世善根。则前三轮无所复用。总此四义。譬之为轮四若少一轮。则不成解脱之名。无由得立。由此四法和合故能得解脱道者。如轮能运能转。至解脱时无复此能如圣王轮。备有四物。所谓毂辋辐轴。若无此四轮则不成。以是义故。若未与四轮相应者。是时厌离生死观及涅槃功德观并不得成。故经中说。一阐提人堕邪定聚。有二种身。一本性法身。二随意身。佛日慧光照此二身。法身者。即真如理。随意身者。即从如理起佛光明为怜愍阐提二身者。一为令法身得生。二为令加行得长修菩提行。故观得成。复有经说。阐提众生决无般涅槃性。若尔二经便自相违。会此二说。一了一不了。故不相违。言有性者。是名了说。言无性者。是不了说。故佛说若不信乐大乘名一阐提。欲令舍离一阐提心故。说作阐提时决无解脱。若有众生有自性清净净永不得解脱者。无有是处。故佛观一切众生有自性故。后时决得清净法身。故经偈言

  聪明人次第　　数数细细修
  除灭自身垢　　如金师炼金

聪明人次第者。明此人有解不倒修能如次学。数数者。时无暂舍。恒自研求。细细者。从微至着。如闻思修慧细细而习。除灭自垢者。稍除无明重轻诸惑。令清净本性。永得显现故。说犹如金师能炼于金。除诸滓璞金。得净光明

佛性论卷第二佛性论卷第三

        天亲菩萨造

        陈天竺三藏真谛译

    辩相分第四中总摄品第五

复次总摄义应知。摄有二种。一者由因。二者由果。由因摄者。是如来性清净。有四种因。三种法与三譬。相似故取海为喻。三法者。一法身清净因。二佛智德生因。三佛恩德因。法身清净因者。修习信乐大乘。应知。佛智德生因者。修习般若及禅定。应知。恩德因者。修习菩萨大悲。应知。修习信乐大乘者。与器相似。此中有无量定慧。大宝所遍满故。故说与器相似。修习般若禅定与宝相似者。般若无分别故。禅定不可思惟。功德所依止故。般若如净宝。禅定如如意宝。修习菩萨大悲如清净水。于一切世间众生。润滑一味故。譬如大海唯一碱味。菩萨大悲润诸众生亦复如是。故此三法于因地中。为所依能依。故说总摄。名如来法海。是名因摄。次由果摄者。明如来法身有三种法与三譬。相似故能总摄三譬。相似者。如日有三。一体。二光。三明。此与三身相似故。三法者。一神通。二流灭。三显净。一神通者。譬日有明能除障自境界无明之暗。以为事用故。与日明相似。二流灭者。谓尽无生智能烧除业烦恼。令无余以为事用故。与日光相似。所言灭者。即是真智正能除惑故。与灭名尽者。即惑无时名为解脱故与尽称。三显净者。谓尽无生境名转依。极清净故。无垢故。澄静故。与日轮相似。清净者。解脱障灭故。无垢者。一切智障灭故。澄静者。客尘所不能染。以本性清净故。转依者。胜声闻独觉菩萨三人所依止法故。又有四种相。应知。一者为生依。二灭依。三善熟思量果。四法界清净相。一生依者。佛无分别道相续依止。若不缘此法。无分别道即不得生。以依缘此故。名此法为道生依。二灭依者。一切诸惑及习气究竟灭不生。无所依止故。若不依此转依法究竟灭惑者。则声闻独觉与佛灭惑不异。由不同故。故知。此法为究竟灭惑依止。三善熟思量果者。善正通达。长时恭敬。无间无余等修习所知真如。是转依果。若在道中。转依为因。若在道后。即名为果。若转依非是善熟思量果者。则诸佛自性应更熟思量。更灭更净。而不然者。故知转依为善熟思量之果。四法界清净相者。一切妄想于中灭尽故。此法界过思量过言说所显现故。故以法界清净为相。此即心行处灭。言语道断。不可诠詺。方是得无所得真如理故。复次如来转依有八种法摄持。应知。八法者。一不可思量。二无二。三无分别。四清净。五照了因。六对治。七离欲。八离欲因。此八合有二意。一离欲。是灭谛。二离欲因。即是道谛。前不可思量等三句属灭谛摄。次清净等三句属道谛摄。初离欲有三句。一者云何不可思量。于有无等四句。觉观思量。不能通达故。一切众生言语名句味等。不能诠辩故。唯圣人无分别智所证知故。故名不可思量。二无二者。如经中说。舍利弗。诸佛法身无二法。无分别法。所言二者。烦恼及业。是名为二。如来法身无此二法。故名无二。三无分别。分别者。烦恼业家习不正思惟。由不正思惟故起二。由通达自性故灭二。是二及分别。不应不行。不应者。上心烦恼不相应共行。不行者。随眠烦恼不共随行。即不应不行。此二处故。故说如来法身苦灭究竟永无生起。云何如此。非为除灭一法故名为灭。以本来不生故名为灭。如无上依经中说。阿难。于无生无灭法中。心意及识。决定不生故

释曰。心者即六识心。意者阿陀那识。识者阿梨耶识。于此三中。不得生故。此中若无三识。则无分别。分别既无。亦无不正思惟等。既无三识。则不得起无明。是以如来法身离不正思惟故。则不起无明。若不起无明。十二有分不为生缘故名不生。又胜鬘经说。是苦灭者。非灭坏法。名为苦灭。坏者破三界见谛。得有余涅槃。灭者除四种生死思惟烦恼。得无余涅槃故言灭。坏由苦灭名。无始时节。非作非生。无灭离尽。常住恒寂。湛然自性清净解脱。一切烦恼[穀-禾+卵]功德。过恒沙数。相摄非相离。不舍离智不可思惟。与如来法相应。如来法身诸佛所说。是如来法身说名离欲。二离欲因者。为得此法身见谛道修道所摄。由境界故说无分别智。有三义。与日相似。无流清净故。与日轮相似。能照了一切境界故。与日明相似。能对治一切真见暗障故。与日光相似

释曰。真见暗障者。谓具足想。烦恼难。业难。果报难。具足想者。以随眠烦恼为因。五尘欲为缘。不正思惟为俱起因。具此三故。名为具足想。是暗障如实不见不知。离欲法身一界故。即得生起。如此应见应知。如来法身离欲。云何见知。谓如实思量不见想。及不见境。境者名分别性。想名依他。不见分别依他二性故。名为真实见知一界。又想者人。境者法。不见此人法想境故名二空。如是一切诸法。如来悉见悉知。由平等平等已通达如真实故。境智等无增减是名平等观。此观能除真实见暗障。是如来法身至得家因。见修二道所摄故。以是义故。此离欲因。不离二修。而得成就。二修者。一如理修。二如量修。故世间所知。唯有二种。一人二法。若能通达此二空者。则为永得应如实际。是故名为如理。如量际者。穷源达性。究法界源故名为际。如理修者。不坏人法。何以故。如此人法本来妙极寂静为性故。无增无减。离有离无。寂静相者。自性清净诸惑本来无生。见此二空名寂静相。自性清净心名为道谛。惑本无生净心不执名为灭谛是心有自性清净。及有烦恼惑障。如此两法。无流界中。善心恶心独自行故。于一念中。两心不相应故。此两法难可通达。如胜鬘经说。世尊。善心念念灭不住。诸惑不能染恶心念念灭。诸惑亦不染。世尊。烦恼不触心。心不触烦恼。云何无触法。而能得染心。如此而知名如理智。如量智者。究竟穷知一切境名如量智。若见一切众生乖如境智。则成生死若扶从境智。则得涅槃。一切如来法。以是义故。名为如量。至初地菩萨得此二智。以通达遍满法界理故。生死涅槃二法俱知。又此两智是自证智见。由自得解不从他得。但自得证知。不令他知故。名自证知见。又此二智有二种相。一者无著。二者无碍。言无著者。见众生界自性清净。名为无著。是如理智相。无碍者。能通达观无量无边界故。是名无碍。是如量智相。又此二智有二义。如理智为因。如量智为果。言如理为因者。能作生死及涅槃因。如量为果者。由此理故。知于如来真俗等法具足成就。又如理智者。是清净因。如量智者。是圆满因。清净因者。由如理。智三惑灭尽。圆满因者。由如量智三德圆满故。前不可思量无二无分别等。三名为离欲。以清净照了对治等。三名离欲因。是名如来转依摄持八种功德

复次转依法身有七种名。应知。一沉没。沉没取阴故。二寂静。诸行无生故。三弃舍。弃舍诸余伴故。四过度。出二苦故。五拔除。拔除本识故。六济度。济度五怖畏故。七断。断于六道果报故

释曰。言沉没取阴者。取名贪爱有四种一欲取。二见取。三戒取。四我语取。取有二义。一受取。二受资粮。受取者。如因受生爱。受资粮者。为贪此受故。取四种资粮。四资粮者。即四取也。一欲取者。贪欲界六尘。二见取者。于欲界中。唯除戒取与常见二种。所余四见。名之为见。贪爱此见。名为见取。三戒取者。于三界中。取世间邪正二道。为离苦得乐。是名为戒。贪着此戒故名为取。四我语取。我语者缘内身故。一切内法为我语。贪着内法名我语取。色无色界定缘内法成故名我语。贪着此定。名之为取。此四取前二属断见。但执现在。谓无未来。后二属常见。执有未来故。又前二是在家人起。后二是出家人执。又前二在家出家斗诤因。后二为在家出家修行因。又前二欲取为所成。见取为能成。后二我语为能成。戒取为所成。复次阴者。有众多义。如别释。今略明有二义。一能生取凡夫五阴能为取因缘故。二从取生。即此五阴。是取家果故。故言取阴。而言沉没者。于法身中。因果俱无故称沉没。取为对治故沈。阴为报尽称没。故说法身约取阴永无。是名沉没。二寂静诸行者。一切有为法名行。与四相相应故。四相者。一生二异。三住四灭。一切有为法。约前际与生相相应。约后际与灭相相应。约中与异住相相应。行役不息故名为行。如来法身则不如是。约前无生。约后无灭。中无病老。湛然常住。无生故说寂。无灭故说静。约前不更生。离意生身故。约后不更死。已过不可思惟退堕故。约前后际不被损污。过无明住地烦恼病故。三弃舍诸余。诸余者。二乘人有三种余。一烦恼余。谓无明住地。二业余。即无漏业。三果报余。谓意生身。一烦恼余应灭。二道余应修。三虚妄余应除。如来已离虚妄。说名无余。二乘未离故名为余。如来转依法身。已度四种生死故。一切烦恼虚妄已灭尽故。一切道已修故。弃生死舍道谛故。此二无四德故。唯法身独住四德圆满故。是名弃舍诸余。四过度二苦者。苦违逆为义。逆有二。一违圣人意。是圣人怨。能恼圣故。二圣意违逆。以圣能除之故。二苦者。一凡夫苦乐二受。二圣人行苦即舍受。又二者。一身苦。二心苦。又二者。一名苦。二色苦。又二者。一二乘界内苦。二菩萨界外苦。故法身地中无二乘粗苦。故名为过。无菩萨四种生死细苦。故名为度。是名过度二苦。五拔除阿梨耶。阿梨耶者。依隐为义。是生死本。能生四种末故。四末者。烦恼有二。业一。果报一。初烦恼本二者。一者一切诸见。以无明为本。无相解脱门为治道。二者离诸见外一切烦恼。以贪爱为本。无愿解脱为对治道。次业本一者。以凡夫性为本。凡夫性者。即是身见故。次果报本一者。一切生死果报。依阿梨耶识为本故。以未离此识果报不断。于法身中。由两道故。二世灭尽故说拔除。言两道者。一无分别智。能除拔现在虚妄。能清净法身。即名尽智。二无分别后智。能令未来虚妄永不得起。圆满法身。即无生智。拔者清净。灭现在惑。除者圆满。断未来惑。故名拔除。六济五怖畏。五怖畏者。一自责畏。二畏他责。三畏治罚。四畏恶道。五畏众集。一自责畏者。如人作诸罪恶。昼夜怖畏。二他责畏者。既自作恶。恒恐他及冥中天神见之。而怀怖畏。三治罚畏者。身所作恶恒惧王治。四恶道畏者。既有罪自随畏生恶道。五众集畏者。三业不净。兼知解不深。恒怖畏德众。若人已证见法身。则离此五畏故。说法身为济五怖畏。七断六道果报者。道义众多。略说二种。一行处故名为道。五阴为所行处。三世为能行。又以生老病死四苦所游处故名为道。二者六种同异故名为道。如人同人异于五道余亦如是。是同异类。云何名道。有二。一众生所轮转处。二业所行处故。以此二义立名为道。如来法身无复此道。若有余涅槃业尽。众生轮转果未尽。无余涅槃因果二种俱尽。故名断灭六道。若有处说如来法身。当知与此七名相应。是说名竟。复次说法身相者。诸苦静息。是法身相。为静苦缘故。复次说法身味。味者有二。一不退堕故名为味。二安乐故名为味。众生在生死中。乃至梦中并未曾见。若修正行人。求见此法。得见之时。即得不退安乐故。以安乐为味。复次说法身事。事者以无相为事。五阴相于中尽无余故。又以无戏论为事。戏论有三。一贪爱二我慢。三诸见。是三戏论如来灭之已尽故。以无戏论为事。戏论者。有三义。一能违碍实理。二名虚诳世间。三障隔解脱。初违正境。次违正行。后违正得。合此三义。名为戏论。又戏论有九种。一通计我。二的计是我。三计我应生。四计我不更生。五计我有色应生。六计我无色应生。七计我有想应生。八计我无想应生。九计我非想非非想应生。一通计我者。于五阴中。通执有我。而不能分别即离。但漫执故。二是我者。于现世五阴中。随取一阴为我。而言是者。是的别义。定是二处。一定在现世有。二定在一阴上执。故名为是。三计我应生者。一切诸见不出有无二种。由有见故。所以执常。于无见中。复有二种。一邪见者。谓一切无因无果。并拨三世故。二断见者。谓唯有现在。不信未来故。四计我不更生者。此计因断见起。五计我有色应生者。于欲色二界中。以色为我。此执则因常见故起。六计我无色应生者。于无色界中。计受心法为我。观色坏灭。此三法不灭。因常见故起。七计我有想应生者。于三界中。除无想及非想天。所余诸处。并计有想为我。因常见起。八计我无想应生者。计无想天及草木等为我。以同无想心故由因常见起。九计我非想非非想应生者。此计有顶处为我。以观想为系缚。计涅槃为坑堑。若不除想。无由解脱。有系缚故。若并除想复恐失我堕涅槃堑。何以故。想与于我不得相离故。不得弃及与不弃。为系缚故。欲除于想故名非想。恐失我故。不敢并除故。名非非想。由此散乱心。不得涅槃故。说此等名为戏论。若能观证法身。一切戏论并不复生。外曰。于法身中。何用立此相等诸义。如汝所立。法身应决定是无。不可执故。若物非六识所得。决定是无。如兔角。兔角者。非六识所得。定是无故。法身亦尔。是故法身决定是无。何用诸义。答曰。汝言非六识所见故法身无者。是义不然。何以故。以由方便能证涅槃故。想称正行是名方便。由此方便。是故法身可知可见。譬如由他心通故。则能得见出世圣心

释曰。他心通者。有三种因缘所得两是方便。一是正道方便。二者一因天耳。二由天眼。因天耳故。闻觉观声。由此声故。得知他心。依天眼能见他肉心孔中有水水相。若黑则知痴。生黄则知贪。赤则知嗔。青白则知善。见缥色时知是无记。因于耳目方便故。比知他心。次正道者。若欲得他心通。须缘自心。先修观行。不用现在心观现世心自体不得一时见故。以现在心能观过去心。何以故。可追缘故。从远至近。次第向后。初则观无量念。如是渐渐至一刹那。乃至灭一刹那。于自心观中而得自在。然后取前人心作自境界。以修观行。初入观时。须作愿心。起要期意。先须假想观前人身身相具足。如是遣析除皮肉骨三相都尽。唯余心在。细细修习。缘前人心。随其利钝。远近奢促。自能彻见。如彼所缘。我皆能见种种诸心故。如他圣心。虽过六根境。亦能得见。如来法身亦复如是。虽非六识所见由方便正行。所以能见。故知是有。不得同无。复次更有别义知法身不无。何以故。若法身无者。则诸正行皆应空失。以正见为先行。摄戒定慧等善法故。所修正行不空无果。由此正行能得果故。故知法身非无。若汝说法身定无。而正行能令至五阴入等灭尽故。当知正行不无果者。是义不然。何以故。涅槃不有故。若五阴等无是涅槃者。则去来二世阴等并无应是涅槃。而此二世阴等无处。既非涅槃故知不取。阴无之处名为涅槃。又若汝取此为涅槃者。狂醉等人应有涅槃。而其无者。故知阴等无处非涅槃也。又若汝言现世五阴无为涅槃者。是义不然何以故。无是无故。若法现在。则非是无。更互相违故。若法已灭。则非现在。若现在则不灭。以有无不得并故。复次依现在阴。修圣道时。不应得涅槃故。八圣道者。依现在五阴得成。是时现世五阴实有未无。此中永无得涅槃义。云何如此。汝立计言。现世五阴无处名为涅槃。依现五阴。修八圣道。得于涅槃。是故汝执现世五阴无名涅槃者。是义不然。若汝言是时烦恼非现在故。无过失者。是亦不然。若汝言修八圣道时。五阴现在者。则诸烦恼非是现世。是时烦恼不得生故。由八圣道得证得见。是故现世得涅槃者。是义不然。何以故。烦恼先非现世故。修道则无用。修圣道时。是诸烦恼未除灭故。汝见非相应。便言非现世。若随逆流。初修行时。烦恼已不相应。此不相应。则非现世。此即是汝所计涅槃。若汝执此是涅槃者。圣道未起时。已应灭惑。已得涅槃故。后修圣道。则无复用。是八圣道能灭诸惑。及得涅槃者。是义不可。故知烦恼灭处不名涅槃。若汝说由圣言故。欲等灭尽名为涅槃。如吉祥经偈说

  灭尽及离欲　　无死堕微妙
  若人见此经　　成佛得寂灭
  无法与此等　　若证则无忧
  是真妙法宝　　由是义吉祥

若汝言欲等诸惑非现世非有是尽。由此三义名灭谛者。是义不然。何以故。第四果同此义故。佛经中说。何者名阿罗汉果。以三界惑尽名罗汉果。但以欲等灭为果。此果实不如此正以出世果报四阴戒等五身为罗汉果但由此惑灭罗汉果得成故。于果中说此因名。涅槃亦尔。由涅槃故诸惑得灭。是故因中说于果名。是故汝说由八圣道能得涅槃道不空者。是义不然。复次法身住时短促。有为法相。非功用得。是三过失。于汝义则坏。若汝所说欲等惑灭。说名法身。汝所立义中。则有三失。一是住时短促。短促者。诸法念念不住。是名灭尽。以灭尽故。不得暂住。汝云何立此灭尽义。为法身耶。以短促时故。失法身常义。二有为法相过失者。若此灭尽是法身。法身则是有为法相。法身若是有为相者。无有是处。三有非功用过失者。此一切诸法依因缘灭则是自性。何以故。灭为本故。若灭非功用得。法身亦不因功用而得。既无功而得者。睡眠狂醉等亦应皆得涅槃。以此三失故。汝义不成。复次若灭尽为涅槃者。则与有为诸法相应。以灭有同动苦二法故。夫有为法皆为欲等惑火所燃。故恒散动不住。则为生老死等所坏。是故恒苦。如佛说言。比丘。生老死等。是有为法。故一切有为。恒燃恒苦。是死者。即是灭尽。此灭尽即有为。若是有为。故知。汝立法身。不得是常。既非常者。汝义宁立何以故。则汝义计最静为动。最乐为苦。是故不然。若汝说从此一灭永无复生为涅槃者。是义不然。何以故。不离前诸过失故。汝言永灭者。生与死灭不异故。是义不可。若汝说永灭为涅槃者。道亦应成涅槃。何以故。无有一灭永不复生。无有此法。我今随汝意说我愿有此灭。若有此灭。终不能离前诸失故。又道灭后烦恼亦复不生。若谓永灭是涅槃者。是道用灭应是涅槃。又若汝说能灭为涅槃者。无别涅槃以为能灭。唯以道用正为能灭。故知。道体应能为灭。若汝说烦恼不生为涅槃者。是义不然。何以故。不免二种失故。若烦恼不生。即与灭尽同体如前死灭等五难过失故。是不生者。为在道前。为在道后。若在道前。未修道时。已应得之。修道无用。若在道后。则属未来。过三世义。则不成立。又汝立无生。其义云何。为是有惑故无生。为是无惑故无生。若烦恼有则无无生。何以故。有无二法不得一时同处故。譬如一人行时不住住时不行。以二法相违行住不得俱故。故知。烦恼在时。则不得立。以无生故。若无烦恼。立无生者。是时烦恼既无约。谁而辩无生耶。譬如人说石女之女不能生儿。复次汝立烦恼无生者。为是物有。为非物有。是物有者。如四大等。有实法。有假名。此等是有物。非物有者。如空花兔角等。了自无故。故言非物有。若言是有物者。则由四缘所成。四缘所成故。无生义则不立。以是义故。有为无为则无差别。若汝说是物有。不为四缘成者。即同邪见外道所执自性邻虚我时方等故。若非有物是涅槃者。但有名字。便如人说兔角尖利。若尔即同前破。则修道无用。外曰。若不取无生为涅槃者。云何佛说无生灭尽为涅槃耶。答曰。道依涅槃能使烦恼未来不生现在者。灭因中说果故。名涅槃为无生灭尽。外曰。何故果说因名。而不直取果体自名。答曰。极微细故。一切法中无有能细涅槃之者。是故若得此法。一切欲等诸惑灭。不更生故。假此粗名。显以细理。理相可知。故此经中作此说也。问曰。云何知此涅槃极微细耶。答曰。大仙不乐说法故。无分别圣智所知故。大师观涅槃。极微细故。观众生根性。不相称故。是故佛心回向寂静。入于涅槃。不欲说法。故经言。我宁不说法。疾入于涅槃故。无分别圣智所知者。如摩健持经说。世尊。若涅槃是有。我今自有聪明利智。云何不见。佛言。涅槃实有。汝今未得无分别圣智故不得见。以微细故。非闻慧所得。以真实故。非思慧所得。思慧双能通达真俗谛故。不得周于妙理无思之界。以甚深故。非世间修慧所得。修慧但得浅理。未能通达甚深之理。以此微细非言语能说故。借粗名显于妙理。由无分别圣智所见故。故言微细得成。外曰。若涅槃是修道所得者。与未能修道之人不得相应。既不相应。是故不共。若不共则是无常。答曰。若从此向前是无。向后是有者。可说无常。无此义故。前际无有故说无生。若汝说未修道时不能得故。无无生者。是义不然。何以故。非道所生故。此法必须因道得至非道能生。是故未修时不得言无。是故无生义立。无后际故。是故无灭中际。无业烦恼等故无变异。以无生异灭等三失故说常住。不同外道以无因故一名常住也。正义者不取因为常住法。如涅槃不由因故有。汝谓邻虚等亦不由因故有。无如是义。何以故。涅槃离有离无。四谤不及。以不由因故得是常。汝计邻虚既有有故不得无因是有因即无常故。若汝说涅槃无三失故常住邻虚等亦无三失故。常住者。是义不然。何以故。汝证义相不成就故。涅槃常住不与邻虚同相异相。邻虚等是有分别故。无有证义。得成涅槃。是无分别故。涅槃常住。邻虚等常住则不得立。复次邻虚等亦不成就。何以故。以独聚不成故独者义不成。以四大不相离故。若聚者亦不成就。以相粗故。并非邻虚尘故。若离涅槃。无有一法。是常住故。以涅槃实有常住依方便得解脱故。修道不空过故。故有涅槃前际等无故。故知。常住过色等相故。故说非色不离清凉等色相故。故说非非色大功用。无分别智所得故。故说真有因出世大精进所成就道佛所得故。故知实有。如经中说。比丘。是法实有。不生不起。不作无为。故知涅槃实常住。此法是如来转依。是故名总摄竟。亦云相应

    佛性论辩相分第四中分别品第六

复次分别相义应知。分别者。是如来性。明一切法。如如清净。是其通相。如般若等经中所说。一切法者。即三性法。如如者。俗如即真如。真如即俗如。真俗二如。无别异故。清净者。有二种。一者因中如如。未得无垢果地如如。无复垢秽故。二者因果俱净。因中是无染清净。至果无垢清净故。如此等义。是佛性通相。为显此义故。佛说般若波罗蜜等诸经。是佛性中。分别众生。自有三种。一者不证见佛性。名为凡夫。二者能证见佛性。名为圣人。三者证至此理究竟清净。说名如来。复次约此佛性。众生事用有三。一者颠倒为事。二者无颠倒为事。三者无颠倒无散乱有别法为正事。颠倒者。一切凡夫。无倒者。一切有学圣人。无倒散者。道后法身。有别法为正事者。是应化二身。为度众生。皆由大悲本愿力故。言颠倒者。一切凡夫有三倒。谓想见心。即皮肉心等三烦恼故。二无颠倒者。无惑无行二种倒故。即一切菩萨有学圣人。惑倒者。违逆真如故。起一切烦恼。名为惑倒。行倒者。二乘人应修常等四德。翻四颠倒。行菩提道。而今不修。但修无常苦等。为解脱因故名行倒。此明是无小乘偏修之行。离此两倒故。说大乘有学圣人三无倒散有别法为正事者。是灭除禅定解脱一切智等三障故。法界澄净澄故。静寂净故。无垢不舍正事大悲本愿恒化众生名为如来。故约此性分别众生。是名分别相

    佛性论辩相分第四中阶位品第七

复次阶位相义应知。阶位义者。于种种法门中。若有分别广说无流法界不出六种。一自性。二因。三果。四事。五总摄。六分别。为显无流界自体故。先说自性。依止此性故。起信乐等四种胜因。由此因故。得常住等四德之果。由佛性故。起厌恶生死乐求涅槃事用得成。由此自性故。得离欲。得离欲因名为总摄。约佛性故。故得分别三种众生。如来所说八万四千法门。为六种所摄。次第在三位中。三位者。一不净位。谓众生界。二者净位。谓菩萨地。三者最清净位。即是佛地。故无上依经说。阿难。是如来法界。无量无边诸烦恼[穀-禾+卵]之所隐蔽。随生死流。漂没六道。无始轮转。我说名众生界。阿难。是众生界。于生死苦而起厌离。除六尘欲。依八万四千法门诸波罗蜜所摄。修菩提道。我说名菩萨。阿难。是众生界。已得出离诸烦恼[穀-禾+卵]。过一切苦。洗除垢秽。究竟法然清净澄洁。为诸众生之所愿见。微妙上地。一切智地。一切无碍。入此中住。至无比能。已得法王大自在力。我说名如来

    佛性论辩相分第四中遍满品第八

复次遍满相应知。遍满者。凡夫圣人。及诸如来。无分别性。次第三位中。一颠倒虚妄。二无倒圣道。三四德究竟清净。此三处平等通达相。并随道理遍满故。譬如土银金等器中虚空遍满平等无差别。如来法界遍满三位中亦复如是。是故从位次第说此遍满。如无上依经说。阿难。是如来界。于三位中一切处等。悉无挂碍。本来寂静。譬如虚空一切色种不能覆不能塞。若土银金器虚空处等。悉无挂碍。是名遍满

佛性论卷第三佛性论卷第四

        天亲菩萨造

        陈天竺三藏真谛译

    辩相分第四中无变异品第九

复次无变异义应知。离有六义。合则成三。离有六种者。一无前后际变异。二无染净异。三无生异。四无转异。五无依住异。六无灭异。言无前后际变异者。如佛为海智菩萨说。解节经偈言

  客尘相应故　　有自性德故
  如前后亦尔　　是无变异相

复次释不净位中。有九种客尘。非所染污故不净。净位中。常乐我净四德。及如来恒沙功德。恒相应故。故说如来性前后无变异。若略说一切烦恼客尘。凡有九种。一者随眠贪欲烦恼。二随眠嗔。三随眠痴。四贪嗔痴等极重上心惑。五无明住地。六见谛所灭。七修习所灭。八不净地。九净地惑。若烦恼在世间离欲众生相续中。为不动业增长家因。能生色无色界。为出世无分别智所灭。是名随眠欲嗔痴等三毒

释曰。言烦恼在者有二。一有体说在。二无体。约因在故说在。言体在者。即见谛。随眠未得治道故言在。约因在者。即思惟随眠。已得治道故。以思惟用见谛为因。思惟虽灭。由有见谛。为思惟因故言因在。思惟必由见谛而生。若除思惟因。有根本见谛惑在。后更能生思惟之惑故。言思惟因在。不动业增长家因者。一思惟能成业。二见谛能得果。何以故。断思惟尽。业不成故。断见谛尽。不感果故。故说不动业。为增长家因。能生色无色界故。为出世无分别智所灭者。有二种灭。一者性灭。二治道灭。一性灭者有二。谓念念灭。及相违灭。相违灭又有二种。一等类相违。如贪违嗔等。二不等类相违。如正思惟违欲嗔等。是名性灭。二治道灭者。有二种。一通二别。通道者。谓观真如。灭三界烦恼。二别道者。如不净观等。能灭贪嗔等烦恼。如苦谛观。灭苦谛惑。不灭集谛惑故。名随眠欲嗔痴等。四三毒极重上心惑者。有诸烦恼在欲行众生相续中。为罪福两行增长家因。但生欲界修不净观等所破。是名贪嗔痴极重上心烦恼。五无明住地惑者。在阿罗汉相续中。为无流业生家因。能生意所生身。为如来菩提所破。是名无明住地惑故。阿罗汉约安立谛观能破诸烦恼。此无明住地。非安立谛观所能破故。犹在罗汉相续中。为无流业生家因。无流业生家因者。流有三义。一者流入三界生死。二者退失。如失欲界流往色界。或失色界流下欲界。则随生死不定一处故名为流。三者流脱功德善根失戒定慧。譬如破塘水则不住。无此三流故名无流。业者作意为义。此意业能生四种生死。如来菩提破者。如来菩提非安立谛观。是名如来菩提。因此道故。能灭此惑故。名无明住地。六见谛所灭惑者。有二种学人。一凡夫。二圣人。此惑在学道凡夫相续中。无始已来未曾见理。因初出世圣道所破名为见谛

释曰。学道凡夫相续中者。若小乘则从暖顶忍世法。此四是学道凡夫位。见谛随眠其未能灭故言在中。无始时节未见者。从无始以来迄至此道所未曾见安立圣谛故言未曾得见。初出世圣道所破者。始自苦法忍初念之道。能破烦恼名为见谛。自此后去并属思惟。平等观者。有利有钝。若利根人。于一念中则等观四谛。八十八惑一时俱断。皆名见谛。若钝根人。于次第观者。则初念观苦。不见余三谛。但断苦下四谛。名为见谛。余未断者。皆属思惟。是名见谛所灭惑。若大乘则十信等诸位。圣人者。初地以上。七修道所灭惑者。在学道圣人相续中。昔已曾见出世圣道所破。是名由修道所灭惑。八不净地。惑者。在未究竟行菩萨相续中。对障菩萨七地为无相无功用道所破对障故

释曰。七地者即前七地已还故无相无功用道者。即八地以上无相者。即真如境。无功用者。即自然升进道。是名不净地惑。九净地惑者。在究竟行菩萨相续中。能障八地以上三地。譬金刚定慧所破。言究竟者。八地以上见境皆周。无更别境所未见者故名究竟。但方便由有浅深故。诸地为别故。分别烦恼有此九种。约此烦恼立众生有四种。一凡夫。二罗汉。三有学。四菩萨。此四种众生。依无流界。由四烦恼故不净。第一众生由四烦恼故不净。第二众生由一烦恼故不净。第三众生由两烦恼故不净。第四众生由两烦恼故不净。第一凡夫由四惑者。前三是随眠贪嗔痴等。后一即上心烦恼。由此四故不净。二由一惑者。即罗汉由无明住地故不净。三由二惑者。谓见谛思惟。即有学圣凡夫学道。凡夫由见谛烦恼故不净。有学圣人由思惟烦恼故不净。是名由二惑。四由二惑者。谓净不净。即是从初地已上至七地菩萨。由不净地惑故不净。若从八地已上三地。由净地惑故不净。是名由二惑故言不净

复次为现此九种烦恼故。立九譬者。一为显贪欲烦恼故。立莲花化佛譬。譬如莲花初开之时。甚可爱乐。后时萎悴。人厌恶之。贪欲亦尔。初依尘成。后依尘坏。故以华譬贪。而华坏时。化佛出世。如贪覆法身。二为嗔烦恼故以蜂为譬者。如蜂若为他所触。放毒螫人。嗔亦如是。若心起嗔。即能自害。复能害他。而有甘蜜。即譬法身。为嗔所覆故。三为无明惑故。立谷中粳粮譬。譬如白米。为糠所覆。不得受用。法身亦尔。为无明[穀-禾+卵]所隐覆故不得现。四为上心三种烦恼。立金堕不净譬。譬如净洁金宝为粪所涂。违逆人心。离欲之人亦复如是。为上心烦恼违逆其意。故说此譬。法身本净为上心惑所覆故言不净。五为显无明住地故。立贫女宝藏譬。譬如贫女宅中地下有金宝藏。为地覆故。受贫穷苦。二乘亦尔。为无明所覆不见佛果故。受四种生死之苦。六为显见谛惑。立庵罗树子譬。譬如庵罗子生芽之时。必破其皮。然后得出。皮譬见谛。芽譬法身。见谛亦尔。初见真理。即破此惑。法身显现故。七为显思惟惑故。立弊帛裹金宝譬。譬如败衣不堪服用。身见真实先来已破。圣道对治数数习故。思惟烦恼无复势力。譬彼败衣金如法身。为思惑所障。八为显不净地惑。立贫女怀王子譬。譬如转轮王子在贫女腹中。胎不能污。七地以还。烦恼亦尔。虽名烦恼。而有三德。一者无染浊智慧慈悲所含养故。二者无过失以不损自他故。三者无量功德能成熟佛法及众生故。若长烦恼即成凡夫不能成熟佛法。若断烦恼。即成二乘不能成熟众生。九为显净地惑故。立摸中金像譬。譬如铸金像未开摸时像已成熟。水等诸物不能破唯斧等乃能破故。八地以上惑亦如是。唯金刚心能破究竟故。因三种自性为显心清净界。名如来藏。故说九种如莲花等譬。三种自性者。一者法身。二如如。三佛性。合此九譬为三。初三譬法身。次一譬如如。后五譬佛性。云何如此明。诸佛法身有二种。一正得。二正说。言正得法身者。最清净法界。是无分别智境。诸佛当体。是自所得法。二正说法身者。为得此法身清净法界正流从如所化众生识生。名为正说法身。正说法身又有二种。一深妙。二粗浅。为安立此二道理。一深妙者。为安大乘道理。二粗浅。为二乘人说此道理。复次第一义谛为安立菩萨甚深法藏。约真俗二谛。安立二乘十二部等种种法藏

释曰。一正得法身者。体是真如。世间无物可为譬者。故还取花中佛像为譬。二正说深妙法身者。以真如一味故。故取蜂家蜜为譬。三粗浅正说法身者。以显真俗种种义味故。故取糠中米为譬。由此三譬显诸佛正得法身正说法身。是三法身遍满摄藏一切众生界无余故。故经说无一众生出如来法身外者。如无一色出虚空外者故。次金堕不净一譬。譬如如者如如有三义故。取金为譬。一者性无变异。二者功德无穷。三者清净无二。自性亦如。无变异故。功德亦如。无增减故。清净亦如。无染污故。故曰如如是真如。如在一切邪定聚及一阐提诸众生中本无差别。若至客尘灭后说名如来藏。故说一切众生为如来藏。能藏如来不得显现。为显此清净无二故。佛说此经。文殊师利诸佛已出离于我取根本。由此自性清净。应一切众生清净。是自性清净与众生清净无有二故。为显此如故说金宝譬。后五譬佛性者。佛性有二种。一者住自性性。二者引出性。诸佛三身。因此二性故得成就。为显住自性故。说地中宝藏譬。此住自性佛性者。有六种德故如宝藏。一者最难得。佛性亦尔。于无数时节。起正勤心。因福德智慧满足庄严。方始显现故。譬如意宝藏。由胜因乃感。二者清净无垢。由佛性与烦恼不相染故。是故譬如意宝。不为不净所污。三者威神无穷。明六神通等功德圆满故。如意宝亦尔。随意能办故说宝藏譬。四者能庄严一切世间功德善根。于一切处相称可故。如意宝亦尔。能为世间种种庄严具。五者最胜。于一切法中无与等故。亦如如意宝。物中最胜故。说宝藏为譬。六者八种世法中无有变异。为十种常住因故。真宝亦尔。虽烧打磨不能改其自性故。取宝藏以譬住自性佛性。二者引出佛性。从初发意。至金刚心。此中佛性名为引出。言引出者。凡有五位。一能出阐提位。二能出外道位。三出声闻位。四出独觉位。五出菩萨无明住地位。此法身能破烦恼[穀-禾+卵]。其体显现故。第六说庵罗树芽为譬。如彼树芽。能破皮肉。得出生为大树王故。说引出佛性。如庵罗树芽能生大树王故。为约此两因故。佛说三身果。一者因住自性佛性故说法身。法身有四种功德。是故第七说败帛裹真金譬。四功德者。一自性有。如金本有。非所造作。二清净。如金本净尘垢不能染污。三为一切功德所依处。如金能感种种贵物故。四平等所得。谓一切众生并同应得。如金无的主众人共有。随其功力修者即得。故说法身犹如真金。二者因引出佛性故说应身。应身有四种功德。是故第八说如贫贱女人有转轮王胎。四功德者。一依止。依止者。三十七道品。是所依止。二者正生。谓欲得应得。即是未知欲知根。三者正住。谓正得。即是知根。四正受用。即知已根。合此四义。名为应身。如胎中转轮王子。亦有四义。一以宿业为依止。二未得王位欲得如初生。三正得王位如住。四得已不失如受用。是故应身以胎中转轮王为譬。三者因引出佛性。复出化身。化身者。有三事。一有相。如水中月。以影相为体故。二由功力。以宿愿所作故。三有始有终故。第九立摸中佛像为譬

释曰。三义者。一有相貌。譬如月影。但似而不真实。化身亦尔。非实体故。二由人工造作者。譬化身宿愿所起。三明有始有终者。譬化身随缘变化故能有始有终。复次以三义故。显此三身。初甚深义。显于法身。甚深者。体微细故。故此法身具足五相五种功德。五相者。一者无为相。离生老等四相过失故。二者无一异相。真与俗谛不一不异。复有二种。一约法辩。二就人论。约法辩不一不异者。为真通故。不可言异。以俗别故。不得言一。如螺白色。螺之与色不一不二。若言异者。见取螺白色时。不应得于螺解。若言一者。不应有香味触异。但应是色。二约人论真俗不一不异者。若真与俗一。凡人见俗则应通真。若通真者。应是圣人。以不见真故。故知不一。若言异者。圣人见俗不应通真。若不通真。即是凡夫。以圣人见故。不得为异。是故不一不异。三离二边相者。有六种中道故。能出离六种二边。何者为六。一者执可灭灭。二者执可畏畏。三者执可执执。四者执正与邪。五者执有作无作。六者执不生同生一。执可灭与灭者。有人谓言。一切诸法毕竟可灭。是名一边。毕竟灭尽。是名为空。复是一边。因此二边偏执。而生怖畏。为离此二边偏执故。佛说诸法不有故。非可灭。不无故非不灭。非灭非不灭。是名中道。故佛立虚空譬。所以宝顶经云。迦叶。譬如有人怖畏虚空。椎胸叫呼。作如是言。善友。汝等为我除此虚空。除此虚空。迦叶。于汝意云何。此空为可除不。迦叶言。不可世尊。佛言。迦叶。若有如是沙门婆罗门怖畏性空。我说是人失心狂乱。所以者何。迦叶。一切诸法并是说空方便。若畏此空。云何不畏一切诸法。若惜诸法。云何不惜此空。问曰。此经为显何义。答曰。为示一切诸法本性非有故说法空非关法灭。然后得空。故于空性不应生怖。是名离可灭灭。二边显非能灭所灭中道二执可畏畏。二边者。以分别性所起色等六尘执为实苦。是为一边生怖畏心。复为一边此是因依他性执分别性于中计有实苦。而生怖畏。为离此二边偏执欲显中道故。佛以画师为譬。迦叶。譬如画师作罗刹像。像甚可畏。画师见像。自生怖畏。覆面不敢看。失心颠狂。迦叶。如是凡夫由自所作色等诸尘。流转生死。于如是法不能通达如实道理。此譬为显何义。为明色等诸尘非是实有但以妄想分别所作。如彼画师自分别作罗刹恶像。见还生怖。是人亦尔。自于空中。而生怖畏

释曰。初一譬约声闻小乘说。此第二譬约大乘说。云何如此以小乘人。于真如中不数习故。故生怖畏。大乘人能数数习空故不生畏。如师子子。闻师子吼。不生怖畏。若不了分别。依他二性执为实有。故被染污。三可执执二边者。分别可执与能执以为实有。为离此二边故。经中佛以幻师为譬。迦叶。譬如幻师作诸幻像。所作虎等还食幻师。迦叶。如是观行比丘。随观一境。显现唯空故。实无所有。虚无真实。云何能得离此二边由依意识生唯识智。唯识智者。即无尘体智。是唯识智若成。则能还灭自本意识。何以故。以尘无体故。意识不生。意识不生故。唯识自灭故。意识如幻师。唯识智如幻虎。以意识能生唯识故。唯识观成。还能灭于意识。何以故。由尘等无故。意识不生。譬如幻虎还食幻师。如提婆法师说偈言

  意识三有本　　诸尘是其因
  若见尘无体　　有种自然灭

四邪正二边者。正者通达位中真实观行分别为正。未通达前分别为邪。为离此二边故。以两木生火为譬如经中说。迦叶。譬如二木相揩即能生火。火生之时。还自烧木。如是正相真实观行。与邪相治生圣智根。智根若成还除邪正二分别故。譬如火生还烧两木。两木若尽。火亦无依。邪正不二故言中道。五有作无作二边者。有作者。有人执言。欲修智慧。必先作意。然后事成。无作者。有人执言。智慧无事无能。何以故。由解惑相对由解生故。惑自然灭。非解能除故。说智慧无事无能。为离此二。是故立于油灯为譬。如经迦叶。譬如燃灯。灯光既起。黑暗即灭。而彼灯光虽不作意。言能灭暗。暗由我灭。而必因于光起。暗方得灭。是故灯光虽不作意。不无事能。智慧亦尔。不作是意我能灭惑。而亦非不由智慧生。惑便除灭。故知智慧不无事能。若说作意。我能灭惑。是名增益。即有作边。若说智慧起时。无明自灭。不由智慧。是名损减。即无作边。为离此二边故。说智慧生不作意。作不作意。非作故不增。非不作故不减。是名中道。六不生同生。二边者。一不生执者。譬如凡夫相续中。烦恼恒起。未曾生道。由惑碍故。未来亦尔。故知永不解脱。即是一边。二同生者。明诸惑于无始长时本有。若对治道与惑同时起者。可能灭惑。若道始生。此道力弱。不能灭惑。故知永不解脱。为离此二边。是故佛说第二灯譬。迦叶。如崄暗山岩及庙堂房舍。无数千年暗在其中。未曾有人燃灯照了。设有人能于中燃灯得成以不。答言。得成。迦叶。此中诸暗得作念言。我住此已久。我今不去是暗能作此意以不。不可世尊。何以故。灯光既成不得不去。迦叶。如是烦恼及业。从无数劫来。在众生相续中。若能生一念正思惟者。则久劫烦恼悉皆自灭。迦叶。是灯光者。即譬圣无分别智。黑暗者。即譬众生烦恼业。由此灯譬。破道不生执。何以故。以道依因缘生故。若因缘未合。道不得生。因缘具者。道即得生。由如燃灯后方暗灭。暗灭譬者。破同生执。以暗分羸弱故可灭。是无颠倒境界故。以白净最强有真实境无颠倒故。是名离六种二边。显六种中道。四离障相者。障有三种。一烦恼障。能离此障。得慧解脱阿罗汉。二禅定障。由离此障故得俱解脱阿罗汉。及独觉等。三一切智障。是菩萨道所破。离此障故。得成正觉。如来法身在三位中。虽有三障。非所染污。五法身界清净相者。凡有四譬譬各四义。初四义者。法身不改如金。如如清净如水。第一义谛无相如空。大般涅槃显了如觉。二四义者。神通转变如金。慈悲润泽如水。自性不舍众生如空。般若解净如觉。三四义者。因本清净无染如金。胜道洗浣如水。解脱无累如空。果体显现如觉。四四义者。乐性利益如金。净体清洁如水。常德无坏如空。我义无著如觉

问曰此五相各显何义。答曰。初无为相者为显种类义。何以故。如来法身以无为为种类相故。二无别异者。为显相义。明如来相者应知。不一不二为相故。三离二边相者。为显足趺义。足者即菩萨一切圣道。趺者圣道所依止处。舍离二边。能依中道之理。得至法身故。四离一切障相者。为显法身功德无诸染污智障永度故。五清净法身相者。显法身果无垢澄寂故。复次五相次第义应知。初无为相者。显常住。二无别异相者。显真实义。三离二边相者。显对治义。四离一切障相者。显解脱义五法界清净者。显自性清净义。如是相生亦得从前向后。从后向前故。复次五义次第者。一自性故说无为。二无分别故。说不一不二。三圣智境界故。说离二边。四自性清净故。说离一切障。五究竟成就故。说法界清净。是名五相。复次五德者。一不可量。二不可数。三不可思。四无与等。二究竟清净。一不可量者。有四义。一由时节久故不可量。二功用大故不可量。三无余不足故不可量。四无中间故不可量。如佛问舍利弗。汝能如量通达如来功德不。舍利弗言。不能世尊。又问。汝云何得信如来功德。舍利弗言。我今依声闻能观见如来戒等功德。无处不生希有。譬如有人行天园。路见宝庄严树生希有心。我今亦尔。世尊。譬如有人在大城外。见彼诸人出入。无不可怜。作如是计。此城中人。皆应可怜。我亦如是。依声闻故。能观如来戒等功德。无非希有。以信知故。二不可数者。是不可量功德。为一为多。其数无穷。过恒沙数。如马先行经中说偈

  若人有千头　　头头有百口
  口口百言舌　　舌舌百言声
  十力等一分　　穷劫说不尽

三不可思者。非觉观境界故。四无与等者。不与声闻独觉菩萨三乘等共得故。五究竟清净者。无明住地永灭无余故。是名法身五德。复次应身者。势用广大故。此身本有三德。一大般若。二大禅定。三大慈悲。大般若者。无分别圣智是其体相。大禅定者。无作意是其体相。已离出入意故。大慈悲者。能拔能救。是其体相。如众生意令得圆满故须此三。一为法乐。二为六通。三为拔济。是故大悲为拔三恶道苦。安置人天大定。能显六通。令生信乐。般若为受法乐。能成熟解脱。是名应身。复次化身者。大悲为本。禅定为变现。般若能令有五种能。一令生厌怖。二令入圣道。三令舍昔执。四令信乐大法。五令受大菩提记。此三大法在因地中。熏修如如。安立本愿。由此本愿。至道后时。随于三身。能作利益众生之事。是故出现五浊世中。事有十四。一现本生事。二现生兜率天。三从天下处中阴。四入胎。五出胎。六学技能。七童子游戏。八出家。九苦行。十诣菩提树。十一破魔军。十二成佛。十三转法轮。十四般涅槃。此十四事。现五浊世。至众生尽。此十四事为五因缘。一为说无常苦无我空涅槃寂静。由此正说音声。能令众生于三有中而生怖畏。二生怖畏已。令入二乘圣道。三入圣道已。生究竟涅槃心。为破如此增上慢心故。说大乘法花等真实法教。令诸众生舍本所执。摄取慈悲般若方便。四摄已。于无上乘中而成熟之。五成熟已。授其无上菩提道记。是名化身事。复次依此三身随一。一身各有一德。法身微细故。甚深是其德。应身威神具足故。广大是其德。化身能济度凡夫等诸众生故。和善是其德。复次此三身者。恒能生起世间利益等事故说常住。常住者。依十种因缘。十者。一因缘无边。二众生界无边。三大悲无边。四如意足无边。五无分别智无边。六恒在禅定无散。七安乐清凉。八行于世间八法不染。九甘露寂静远离死魔。十本性法然无生无灭。一因缘无边故常者。无量劫来。舍身命财。为摄正法。正法既无边际无穷无尽。还以无穷之因感无穷果。果即三身故得是常。二众生无边故常者。初发心时。结四弘誓。起十无尽大愿。若众生不可尽。我愿无尽。众生若尽。我愿乃尽。众生既其无尽。是故化身常在世间。教导众生无有穷尽。三大悲无边故常者。若诸菩萨分有大悲。尚能恒救众生。心无齐限。久住生死。不入涅槃。何况如来众德圆满。常在大悲。救拔恒恩。岂有边际。是故言常。四四如意无边故常者。世间有得四神足者。尚能住寿四十小劫。何况如来为大神足师而当不能住寿自在亿百千劫广化众生。是故名常五无分别慧无边故常者。远离生死涅槃二执。一向与第一义谛相应。不动不出故知是常。六恒在禅定故常者。世间有人得禅定者。尚能不为水火烬溺刀箭所伤。何况如来。常在禅定。而应可坏。是故名常。七安乐清凉故常者。安乐即是金刚心。能除无明住地最后念无常苦。以无苦故。故名安乐。佛果显成故名清凉。是解脱道故名为常。八行于世间八法不染故常者。佛身虽复在于道前。生死相应而不为彼烦恼所染无妄想缘。故是常住。九甘露寂静远离死魔故常者。甘露令人长仙不死。金刚之心。能除无明最后念惑故。得佛果常乐。常乐故寂静。寂静故远离死魔。离死魔故是常住法。十性无生灭故是常者。法身非本无今有。本有今无。虽行三世。非三世法。何以故此是本有非始今有。过三世法。是故名常

问曰。佛说大乘诸经。一向皆言显诸法空如云梦幻。烦恼能障故以云为譬。一切诸业不真实故。以梦为譬。一切五阴果报烦恼业所起故。故以幻为譬。前说此经。显于此义。云何更说一切众生皆有佛性。答曰。已如初说五种功德。除五过失。明有佛性。是故言有。复次此九种譬为显佛性有五义应知。五义者。一真实有。二依方便则可得见。三得见已功德无穷。四无初不应相应[穀-禾+卵]

释曰。无初者。谓烦恼业报并皆无始。故言无初。不应者。由此三故违逆法身。故言不应。相应者。由依法身得起此三。故说相应。[穀-禾+卵]者。此三能藏法身。故名为[穀-禾+卵]。五无初相应善性为法者

释曰。无初者。以性得般若大悲禅定法身并本有故。故言无初体用未曾相离。故言相应。是名无初。相应善性为法者。法身自性无改。由般若故性有威德。由禅定故性能润滑。由大悲故。故称善性为法。如是九譬。释无前后际变异义竟。二无染净变异者。法身不为生死阴界入等所污故言无染。非智数所作故言无净。三无生变异者。法身无生故非起成。非起成故。非是始有。不论变异。四无老变异者。法身无动转故。无所改异故言无老。五无依住变异者。若法有依有住。即有变异。法身不由他故。无依无所的在故言无住。六无灭变异者。法身常住。不可破坏故。言无灭变异。是名无变异。六种别义究竟。复次合六为三者。一前后寂静。谓无前后际异。二无流即无染净异。三无为谓无四相生住灭等故。无有变异。是故一切妄想诸法有三变异。一果报尽故变异。二对治所破故变异。三刹那念念灭故变异。法身不尔。离三过失故一前后寂静故。无果报尽变异。二无流故。无对治破变异三非有为法故。无念念坏变异故。名无变异

    佛性论辩相分第四中无差别品第十

复次无差别义应知。无差别者。此如来性已至极清净位。若略说。是无流界中。约如来性有四义。因此四义故立四名。约于四人。显以四德。四义者。一者一切佛法前后不相离。二者一切处皆如。三者非妄想倒法。四者本性寂静

释曰。一切佛法前后不相离者。如胜鬘经说。世尊。如来藏不空过恒沙数等不相离不舍智不可思惟诸佛功德故。知如来藏由如来功德故不空。不空者。即明佛具足一切功德故。此性一切处皆如者一切诸法无自性故。如无上依经说。一切众生有阴界入。胜负种类内外所现。无始时节相续流转。法然所得至明妙善。以是义故。故知一切处皆如。非妄想颠倒法者。如解节经中说。佛告无尽意菩萨。善男子。如来性者。是真实谛。若如来出世。及不出世。性相常然。非虚妄法。由此经故。知无妄想倒法名真实谛。本性寂静者。如文殊师利遍行经说。佛言。文殊师利诸佛如来本性。自般涅槃不生不灭。以是义故。故知本来自性寂静。复次立四名者。一由佛法不相离故。说名法身。二由性一切处如。故名如来。三由无虚妄颠倒故。名真实谛。四由本来寂静故。名般涅槃。是四义四名。于如来性。无有差别故。说无差别相。复次约四人者。一者非身见众生境界。由此真性是邪执对治故。为身见人。说名法身

问曰。云何对此人以真如名法身

答曰。是诸凡夫色等诸阴无有此性。强横执有我及有我所。由此人法二执染污其心。身见灭处是甘露界。不能信乐。何能通达如来法界。若见此界身见执灭虽复身见已除未除此界恒尔。是故此界乃名真身。凡夫所执既非真实故。不俱在不得名身。为对如是身见凡夫立名为身。二者对颠倒人。说名如来。颠倒人者。谓二乘人。如来常住应修应行而翻倒修无常想等。何以故。此修依于虚妄境起。故名倒修。乐我净等亦复如是。由倒行故。一切二乘不能进修得与如来道果相称。是故常等真如非其境界。此真如者。不如无常等。世间对治故。此真如非如中有如无非如。亦如二乘如者。是非如中如。无非如中非如。云何如此二乘之人。约虚妄观无常等相以为真如。此虚妄观唯因中有。果地则无。是故此如或成或坏。因中则成。果地则坏。菩萨如者离于虚妄。约真性以观真故。如此如于因果中二处无异故。唯成不坏。是故二乘人如逐其定灭去而不来。菩萨如者。因果恒有。去来不异。舍因到果。故称如去。从果出用。故曰如来。是故如来非二乘境界。故对二乘立如来名。三者对散动心人说名真谛。真如者。是无增减法。散动心人者。始行大乘菩萨。迷如来藏有二种人。一者唯信。灭除诸法。名之为空。一切诸法。未分析时。是名为有。若分析竟。乃名为空。二者谓有实法。名之为空。我今应修应得。此二人者迷如来藏。前则执无故迷。后人执有故迷。如来藏者。道理何相。如偈说言

  无一法可损　　无一法可增
  应见实如实　　见实得解脱
  由客尘故空　　与法界相离
  无上法不空　　与法界相随

如来性者。自清净故。能染客尘者。自性空故。故言无一法可损。真如者。与清净因不相离。过恒沙数等不舍智不可思惟。诸佛功德恒相应故。故言无一法可增。若法无因此无法观真如空。以余法有故。观如不空。故言真如。亦空不空。何以故。以离增减二边故。无一法可损故是空。无一法可增故非空。若作是观名真实观。故得远离增减二边为始行菩萨。不能得见此藏理故。为对此人说真实谛。从初地至十地是其境界观于此理。行十地行。是故非关始行境界。四者对十地菩萨。说名涅槃。唯佛一人能得涅槃。余诸菩萨不能至故。如胜鬘经说。世尊。由得涅槃故。世尊。成就如来阿罗诃三藐三佛陀。得一切无量不可思惟究竟清净诸佛功德。是故涅槃四种功德无差别相。复次四功德者。一一切功德。二无量功德。三不可思惟功德。四究竟清净功德。由得涅槃故成如来。是故如来与于涅槃。无有差别。何以故。若离佛者。无得涅槃。若离涅槃。无得佛故

释曰。功德者。初一切功德。即是第八不动地位。无分别。无穿漏。无中间。自然成。菩萨圣道恒相应故。诸佛如来无流界中一切功德皆得成就。二无量功德者。是第九善慧地位。无数禅定陀罗尼门海。能摄无量功德智所依止故。无量功德皆得成就。三不可思惟功德。是第十法云地位。一切如来秘密法藏证见明了智慧所依故。故不可思惟皆得成就。四究竟清净者。一切惑及习气一切智障已灭尽故。由灭尽智障故究竟清净。功德圆满。成就涅槃。与此四功德相摄不相离故。唯佛得涅槃。余人未得。是故如来性于此四义四名四人四德无有差别。故言无差别德。以是因缘。此自性等十相。为显三义。一显本有不可思议竟界。二显依道理修修行可得。三显得已能令无量功德圆满究竟。故造斯论

佛性论卷第四


观所缘论释

    No. 1625 [cf. No. 1624]

观所缘论释

        护法菩萨造

        大唐三藏法师义净奉　制译

  若言能令毒智人　　为令其慧极明了
  及为消除于罪恶　　稽首敬已观其义

论曰。诸许眼等识者。于所弃事。及所收事。或舍或取。是观察果故。所舍事体。及颠倒因。是所显示。此中等言。谓摄他许。依其色根五种之识。由他于彼一向执为缘实事故。意识不然。非一向故。许世俗有缘车等故。纵许意识缘实事境。有其片分。亦能将识相似之相。离无其境。于眼等识。境不相离。得成就已。方为成立。是故于此不致殷勤。又复于串修果。智所了色。诚非呾迦所行境故。及如所见。而安立故。今此但观闻思生得智之境也。如斯意识所缘之境。全成非有。此于自聚。不能缘故。复缘过未。非实事故。犹若无为。为此等言。摄五识身。若尔根识引生所有意识。斯乃如何。非此共其根识同时。或复无间。皆灭色等为所缘故。或缘现在。此非根识。曾所领故。斯乃意识自能亲缘外境体性。此则遂成无聋盲等。复违比量。知有别根。此遮增色。是所欲故。然于意识。不复存怀。眼等诸识。色为依缘。而方有故。无表但是不作性故。自许是无本意如此。此于所缘将为现量。是所取性故。深履邪途故。为此正意遮所缘性。因便方遮斯所依性。同时之根。功能之色。将设许之。言外境者。彼执离斯。而有别境。此显其倒。显彼执有异事可取故言境也。如何当说。或缘总聚。由非总聚。实事应理。诚如来难彼自前后道理相违。余复何失。缘其实事。及缘总聚。是所许故。将欲叙其别过。为此且放斯愆。或许极微。虽复极微唯共聚已而见生灭。然而实体。一一皆缘不缘总聚。犹如色等。设自诸根悉皆现前。境不杂乱。彼根功能。各决定故。而于实事。断割有能。一一极微成所缘境。彼因性故。彼眼等识之因性故。是彼生起亲支分义。然而有说。其所缘境是识生因在诸缘故。或复于彼为总聚者。彼诸论者执众极微所有合聚为此所缘相识生故。由于总聚而生其智。是故定知。彼为所缘。如有说云。若识有彼相。彼是此之境。此二论者。咸言彼相应斯理故。若不言因。此因无喻。犹如因等。成因等性极微总相。是所缘性而成立之。又若自许不于识外缘其实事。应有有法自相违过。然法称不许。斯乃于他亦皆共许。即以为喻。若但如所说应于所立义而属当之。前量意云。论本二因但是明因所以不即是因以无共成之喻。为此须出彼相应因。何以如此

次复显己所论之理。是无谬妄。明他共许置第五声。设许为因。犹如共许。诸非有事。非有性故。非因极微。而且纵许。诸极微体是其因性。但说不合是所缘性。由非彼相极微相故。此云根识极尘非境。如根者言。犹如于根。纵实是识。亲依之因无根相故。非彼之境极微亦尔。诸无其相彼非斯境者何谓也。为此说其名境者等言自性者。谓自共相了者。定也如何。此复名为了耶。如彼相生故。此言意者。同彼相貌而识生起。由随彼体故。此则说名了彼境也。而实离识无别所了。可与其识为因性耶。然而但有前境相状。于其自己。犹如镜像而安布之。共许名斯为了其境。然非极微一一自体识随彼状。由此极微而为境体。纵有因性。由非因义。所缘如根。虽是因性。不为所缘。若由因性许作所缘。根亦同斯。应成彼也。斯言前说彼相应理。故因有不成过。然而意显非唯因性。即是其根所缘之相。若如所说因将为能立者。则彼因性。故为所缘性耶。于根亦有成不定过。若如是者。由非彼相。其义何也。为明成立自己之宗。由非但述他宗过故。已义便成。此言为彰非即能生自识相故。境非极微。犹如眼等。若其是彼因性之言。将为论主前立他宗。明他共许。此时意在遮他显己。能破义成。置斯言矣。宗许定彼不定他宗。恐其不许。向者与他出不定成。即是能破。何假自宗更由比量。凡言不定。未必决定。不成恐致疑惑。是故更须立量。或可由斯非彼相者。于诸极微非定了性。如相识生。是谓决了。既彼非故。明知决了。此亦无由。应可说非决了性故。惟出此因不是所缘。如根极微。有余复作诸识差别。显其成立。眼识不能了极微色。无彼相故。如余根识。如是余识。翻此应言。如根之言诚为乘也。其喻别须义准而出

又复纵是因性之言。为无用矣。彼虽因用非所缘性。此亦如是实为有用。然非声等所有极微。可是余根之识生因。有说于识自体无聚现故。非是所缘如根众微。由境相状安布于识。是彼相性。此非有故。理即说其无有聚现。如是且述。钵啰摩怒不是所缘。彼之能立不相应故。及非境性量善成故。若尔总聚是境。然由所说诸有能立。若望谟阿宗。皆有不成性。理实如此。然而总聚实有彼相。可是所缘无因性。故由彼相识不能生其总聚相识。总聚不生。彼既不生。此识如何。令此缘彼所缘之相不相应故非所缘义。由此前云。彼相应理斯乃不成。若尔何谓所缘之相。凡是境者。理须生其似自相识。随境之识。彼是能生。彼是所缘。有说凡为境者。理必须是心及心生起之因也。此既生已。随境领受而与言论。于时名此为所缘境。若义具斯二种相者。此乃方合名为所缘。是能生性所缘之境。引阿笈摩。此即便是说生缘性。由是生因彼识生缘。共许是其所缘之境。自体相现。此中无益。故不言之。能非总聚。是能生者。非实事故。由其总聚不是实事。此于有聚一异二性不可说故。又复无有不实之事。能有生起果用功能。犹如二月。如第二月。不能生识第二月相。若尔何因有斯相现。根损害故。若时眼根由翳等害损其明德。遂即从斯损害根处。见二月生。非实境故。由此二月。纵有彼相。然非斯境。如第二月。纵令此识有彼相状。由不生故不名斯境。此由非实事有性等。总聚不是识之生因。非实性故如第二月。由斯方立非因性故。不是所缘。还如二月。又复将此第二月喻。于彼相因。应知说其不定之过。复由识义理成就故。过是相违

复缘眼识不缘青等聚集极微。为由彼体非生性故。如余根识。此喻共许。故不别言。第二月喻非实事故。应知此是于非因性而成立之。如所说之。纵有相性。然非彼境。斯言复是非彼因义。若言无有第二月者。如何现见有二相生。谓从内布功能差别。均其次已。似相之识而便转生。犹如梦时见有境起。由此令似妄作斯解。于其月处乘更睹余。诸有说云。而于眼识双现之时。此二次第难印定故。将作同时于斯二种相貌之后意识。便云我见月之第二月也。或复有云。于共许曰数有错乱。由根损故。若望不许外境之宗。如斯众见但是妄执。由非眼识所缘无间引生意识。能于一时。双缘两相。作如斯解见二月耶。又于声等缘彼之识。不知其次应有二声等见同时起耶。好眼之人意识次第尚多难解。何况依于色根之识测其差别。便成多有二相等见一旃达罗。若时离识许实有者。斯乃何劳妄增二月而言于数有其错乱离识之外执有二种极微总聚。此皆阙其一分义故。又如所说能立能斥道理力故。以之为境。成不相应。阙一分故。自体相现。及能生性。具斯二分。方是所缘。于极微处。即阙初支。于第二边。便亡第二。若如是者。如向所论。二种过失。重更收摄。令使无差。有说集相者。于诸极微处。各有集相。即此集尘而有相现。随其所有多少极微。此皆实有在极微处。有总聚相生自相识。实有性故。应是所缘。斯乃双支。皆是有故。此即于前所有成立。求进无由。为聚集相即是极微。为不尔耶。由诸境义有众多相。即此诸微许有微状。亦有集相。如何得令两相共居一事。为应理乎。有众多相。凡诸有色合聚之物。皆以地等四大为性。彼皆自性有胜功能。青黄等相随事随根而为了别。即此于其众多相处极微之处。有总集相。即将此相为眼等识所行境故。是现量性。若如是者。于诸微处。识有聚相。何不言之。尘有聚相。何不言识有聚相耶。所以复云。然于微处有总聚相。即以此言为其方便。亦显识有极微总相。若尔一一极微有此相者。何故复云总集相也。色聚众多极微分别。是论所许。此即是其总聚性故。不是实有。如前已陈。何劳重述。有别意趣。纵令实事。别别体殊。然此相状。但于集处。更相借故。而可了知。说观集相。更无余矣。又复设使诸有极微合聚为性。然而一事。有其胜劣。随事观之。且如苍色。是其地界。如是等说。诚为应理。纵许如是如极赤物初生起时。多事皆强。遂无容矣。依容有处作此诪议。若尔如何说诸极微非根所见。又复如何唯有如知能见极微由其尘相。非是识义非是依根识之境界。故曰非根非根之义。独是如知之所观察。复如何理现见极微尘形不睹。如坚性等。如坚润等。于彼青等。纵有其事。非是眼等。识之境界。根之功能。各决定故。尘亦如是无违共许岂非显微。无其坚性由别体故。此对宗法许共十处。但是大种斯言无过。然此已陈。汝瓨瓯等觉者。汝如是证者。于瓨及瓯便成根觉。相似而观于其自境。识不差故。复由根觉。随现有境而相生故。识境不别。如何得知。由匪于其瓨瓯等处众微有别。而此言说。然诸极微以总聚相而为其境。固非于彼瓨等自体了别之时。于众多聚体有片别彼之实事。相貌之外无别积聚体可得。故缘彼根识便成相状。无有差殊。由此方成于尘自体。是所缘性。复非于彼无别相处覆审之缘。异解性故。如缘青等。若相殊故。所言殊者。相谓形状布置有殊。于其瓨瓯咽腹底等珠异状故。由境有别觉乃遂殊。诚为应理。无如是事。非于根识所观境处极微有殊。然此总聚是三佛栗底。而此总聚非根识境。此已宇破复非非境有别而令识相有殊可为应理。复如何知。诸极微处别状。非有极微形相。无别异故。凡诸事物有支分者。必有别状。于方处转。然诸极微体无方分。至穷极处。斯即何曾得有形别。于瓨瓯等纵令事别。而极圆性曾无有殊。斯乃一体无增减故。是故定知。于总聚处非实物有。凡有方隅布列形状。皆非根识所行之境。上来如此。众多诘责。意欲显其有别相故。瓨瓯等觉非以别事为所缘境。犹若苏佉毒佉情矣。然而极微是不别境。即是彰其非彼境性。若相殊故。方言殊者。此言意显。向云非以不别之事而为境者。是立已成。彼意说言。极微为境。其实无殊。然为形相别故别也。极微无殊我亦共许。是立已成。由诸极微量无别故。此显殊事。是其别境。答非已成。或可此明诸根之识。于瓨瓯等。无有极微相状性故。非是所缘。犹如余识。余识谓意或余根识。但缘青时。无黄相故。于诸极微虽体众多。无差别故。而诸根识差别相故。斯乃共成。非尘状性颂于极微。差别之言同前问答。若其总聚许覆相已。形非实境理方可成。如斯胜理。是应成立。若言离极微如是等如离彼者。彼觉便无故。犹如军等。此言瓨等是非实义。由非实事。此显余宗诸非不实皆非舍彼相违事也。如于声等。青觉非有。此形相别。是覆相有。以其瓨等为境性故。虽引众多异见道理。而竟不能显其极微实事之体有其差别。据内境体。谓立自宗所缘之事。若也总拨无所缘境。便有违世。自许宗过。四种缘性于经说故。此中内声为显不离。于识而有所缘。言境体者。是所取分。是识变为境相之义。然在识外别分而住。将以为境违世之过。如前尚在。由诸世俗共许于境在外而住。应云如外。此不离识其所取分。如外而现。云我见境。生其慢想。寔此为因。如于眼识现其发等外境虽无谓实。无其在外之境非了性故。以理究寻不可了其自体定在于外。纵令许彼实有外相。然非识缘。非彼相性故。非极微相现。如似外相显现之时。此即是其所缘缘也。彼相相应故。由若与相理相应故者。此即是此如因性等。由与自相理相应故。复显所缘差别体相。如云识有彼相故等明不假藉外事为境。如情所计。境相随生。又情所计。若离于识非外有故。此之境相元不离识。由此名为内境相也。此中内声。言不离识。本无其外。望谁为内。及从此生有此方生。或可从此。由第七五义有别故。由非离境得有其识。是故有此方乃识生。不言第五。二法合故。明其所缘。道理合故。显能立也。此即但以共相之境为其能立。若差别者。其仳若南不缘外事。于其梦位以为显示。如说二种为一能立。识有彼相。复是识生。缘此二用方成一量。且复纵许有其内相。但观外境妄有相故。言无地相。如情计境。生其领受境之相状。列在于内。将为应理。如何是彼一分得作同生之缘。其所取分离识无故。斯之一分复还生识。便成自体相违之过。复还是彼一分性故。如能取分斯乃便成。匪能生性。但由外相染识而生。此即相分与识同起。非二同时有因果性。如牛两角。又匪于其不异之事。同在一时以同伴声而合说之。亦非于识别说有境。斯乃如何名同伴性。理实如是。然由相状差别力故。猜卜为异而表宣之。由有见分相分之殊。遂将此识而有差别。若如是者。缘性亦应但是所执。非分别事。有自性体。斯乃应成。非真缘性。此因相违由其缘义。于余所执差别之境。亦共许之。如等无间灭同分之识。为断割时。此识亦以四种多缘而为缘也

观所缘论释一卷


观所缘缘论

    No. 1624 [cf. No. 1625]

观所缘缘论

        陈那菩萨造

        三藏法师玄奘奉　诏译

诸有欲令眼等五识。以外色作所缘缘者。或执极微许有实体。能生识故或执和合。以识生时带彼相故。二俱非理。所以者何

  极微于五识　　设缘非所缘
  彼相识无故　　犹如眼根等

所缘缘者。谓能缘识带彼相起及有实体。令能缘识托彼而生色等极微。设有实体能生五识容有缘义。然非所缘。如眼根等于眼等识无彼相故。如是极微于眼等识。无所缘义

  和合于五识　　设所缘非缘
  彼体实无故　　犹如第二月

色等和合于眼识等有彼相故。设作所缘然无缘义。如眼错乱见第二月。彼无实体不能生故。如是和合于眼等识无有缘义故。外二事于所缘缘互阙一支。俱不应理。有执色等各有多相。于中一分是现量境故。诸极微相资各有一和集相。此相实有各能发生。似己相识故与五识作所缘缘。此亦非理。所以者何

  和集如坚等　　设于眼等识
  是缘非所缘　　许极微相故

如坚等相虽是实有。于眼等识容有缘义。而非所缘。眼等识上无彼相故。色等极微诸和集相。理亦应尔。彼俱执为极微相故。执眼等识能缘极微。诸和集相复有别失

  瓶瓯等觉相　　彼执应无别
  非形别故别　　形别非实故

瓶瓯等物大小等者。能成极微多少同故。缘彼觉相应无差别。若谓彼物形相别故觉相别者。理亦不然。顶等别形唯在瓶等假法上有。非极微故彼不应执。极微亦有差别形相所以者何

  极微量等故　　形别惟在假
  析彼至极微　　彼觉定舍故

非瓶瓯等能成极微有形量别。舍微圆相故。知别形在假非实。又形别物析至极微。彼觉定舍非青等物。析至极微彼觉可舍。由此形别唯世俗有。非如青等亦在实物。是故五识所缘缘体非外色等其理极成。彼所缘缘岂全不有。非全不有。若尔云何

  内色如外现　　为识所缘缘
  许彼相在识　　及能生识故

外境虽无。而有内色似外境现。为所缘缘。许眼等识带彼相起及从彼生。具二义故。此内境相既不离识。如何俱起。能作识缘

  决定相随故　　俱时亦作缘
  或前为后缘　　引彼功能故

境相与识定相随故。虽俱时起亦作识缘。因明者说。若此与彼有无相随。虽俱时生而亦得有因果相故。或前识相为后识缘。引本识中生似自果功能令起不违理故。若五识生唯缘内色。如何亦说眼等为缘

  识上色功能　　名五根应理
  功能与境色　　无始互为因

以能发识比知有根。此但功能非外所造故。本识上五色功能名眼等根。亦不违理。功能发识理无别故。在识在余虽不可说。而外诸法理非有故。定应许此在识非余。此根功能与前境色。从无始际展转为因。谓此功能至成熟位。生现识上五内境色。此内境色复能引起异熟识上五根功能。根境二色与识一异或非一异。随乐应说。如是诸识。惟内境相为所缘缘。理善成立

观所缘缘论


观总相论颂

    No. 1623

观总相论颂一卷

        陈那菩萨造

        三藏法师义净奉　制译

  诸有乐略者　　彼已显方隅
  若有爱烦文　　为彼说总相
  由声及义智　　俗言为本者
  是观总相言　　此颂声及义
  谓声并义二　　此中二种智
  名声兼义智　　彼为根本者
  谓即于因义　　由诸世间说
  以声义智本　　是故勒为颂
  声义及智义　　故略造斯论
  问名义连属　　是俗说为本
  何以故今云　　但唯办声义
  答曰不如此　　纵有连属声
  唯名与义二　　诸有许共相
  所诠及能诠　　此中理印持
  咸摄入于此　　谓不相离性
  方许相连属　　故今不别说
  由能诠名等　　唯局连属门
  了彼所诠义　　故以总相性
  方得解了者　　后当以广说
  故唯声义智　　连属道理成
  有余复意乐　　此中名义二
  有三种差别　　谓声并义二

观总相论颂一卷


解卷论

    No. 1620

解卷论一卷

        陈那菩萨造

        陈西印度三藏真谛译

三界者。唯以言名为体。由强分别。非实有法故不得真。由简择门诸法自性。为生不颠倒智故立此论

  于藤起蛇知　　见藤则无境

昏昧时中。在非远处。于藤色形。见似蛇相。为境所诳。未见差别。谓彼是蛇。生决定解。若见藤异相。不如分别故。虚妄生故。昔解但是乱知则无有境

  若见藤分已　　藤知如蛇知

若分分思量。析此藤境。藤体不可得。若无体。此藤知如蛇知。但是乱知。于藤诸分中。亦如是思量分析。体相不可得故。此知缘藤及藤分悉是乱知

  一切假名类　　简择自性时
  假名从他起　　乃至俗知境

依分分析观察藤等。不见自体故。如蛇知此藤等知。但是乱知。实无有境一切假名。有法瓶衣人等。若观瓦等诸分。乃至俗智境在。及最后分。此中瓶等假名从他而起。最后无分析难显离皆无一切假名类最后分无分析。唯一邻虚。若离一大余大及一大并不可显现。无有体故。如兔角等。其异云何。邻虚者不可立为一物。若有物必有方异。犹如瓶等。瓶等诸物是世间有。有六方异。是故有分不成一物。若邻虚是有。应有六方。则是有分不成一物若不成一物。则为多物所成。与瓶不异。亦无实体

  智人于俗境　　勿起真实意

由此三界唯有散乱。若智人欲求解脱。不应起真实计。问曰。有乱识。答若汝言我信瓶等。外物自性不可得故。但有分别乱识。缘无境起。何以故。幻化人乾闼婆城等实非有。乱识似幻等起而非无。是义不然。以不成就故。云何不成就。如所见不如是有故。此乱识似无物由物无体。云何识得有。如所缘尘自性能缘自性亦如是。所缘尘既无。此乱识不能自起。由他功力。他既不成。起义何在。以是义故。乱识有义。云何得立。于世间无如此法种子等生因。若无所生芽等。果是有则无是处。是故说幻化等譬亦不可立

  一切假名物　　若细心思量
  智人欲等惑　　能除如蛇怖

犹如是说已。识三界但假名。除瓶等粗识。习微细心。如世间所立瓶衣等物。由假名有。约世俗心不违此事。后为遣此俗心。方起简择心。但见唯有乱识。无有外尘。此乱识因不成就故似无物故。体则不成就。内外既无所有。得会法空一切分别所作。欲等诸惑智人易除。譬如于藤妄起蛇想。而生怖畏。若见差别。定知是藤。能除蛇怖。由思量能起。欲等诸尘自性速易能灭。欲等惑妄亦复如是

  智人不违世　　随说世间法
  若欲灭惑障　　依真应观察

如世间瓶衣等物。信有不违。或说示他如此智人先随此事。后若求解脱应修真理。简择世法自性。若如理简择。现起惑灭。未起不生。是立论用

解卷论一卷


究竟一乘宝性论

    No. 1611

究竟一乘宝性论卷第一

        后魏中印度三藏勒那摩提译

    教化品第一

  我今悉归命　　一切无上尊
  为开法王藏　　广利诸群生
  诸佛胜妙法　　谤以为非法
  愚痴无智慧　　迷于邪正故
  具足智慧人　　善分别邪正
  如是作论者　　不违于正法
  顺三乘菩提　　对三界烦恼
  虽是弟子造　　正取邪则舍
  善说名句义　　初中后功德
  智者闻是义　　不取于余法
  如我知佛意　　坚住深正义
  如实修行者　　取同于佛语
  虽无善巧言　　但有真实义
  彼法应受持　　如取金舍石
  妙义如真金　　巧语如瓦石
  依名不依义　　彼人无明盲
  依自罪业障　　谤诸佛妙法
  如是诸人等　　则为诸佛呵
  或有取他心　　谤诸佛妙法
  如是诸人等　　则为诸佛呵
  为种种供养　　谤诸佛妙法
  如是诸人等　　则为诸佛呵
  愚痴及我慢　　乐行于小法
  谤法及法师　　则为诸佛呵
  外现威仪相　　不识如来教
  谤法及法师　　则为诸佛呵
  为求名闻故　　起种种异说
  谤法及法师　　则为诸佛呵
  说乖修多罗　　言是真实义
  谤法及法师　　则为诸佛呵
  求利养摄众　　诳惑无智者
  谤法及法师　　则为诸佛呵
  佛观如是等　　极恶罪众生
  慈悲心自在　　为说法除苦
  深智大慈悲　　能如是利益
  我说不求利　　为正法久住

    究竟一乘宝性论佛宝品第二

  佛体无前际　　及无中间际
  亦复无后际　　寂静自觉知
  既自觉知已　　为欲令他知
  是故为彼说　　无畏常恒道
  佛能执持彼　　智慧慈悲刀
  及妙金刚杵　　割截诸苦芽
  摧碎诸见山　　覆藏颠倒意
  及一切稠林　　故我今敬礼

    究竟一乘宝性论法宝品第三

  非有亦非无　　亦复非有无
  亦非即于彼　　亦复不离彼
  不可得思量　　非闻慧境界
  出离言语道　　内心知清凉
  彼真妙法日　　清净无尘垢
  大智慧光明　　普照诸世间
  能破诸曀障　　觉观贪嗔痴
  一切烦恼等　　故我今敬礼

    究竟一乘宝性论僧宝品第四

  正觉正知者　　见一切众生
  清净无有我　　寂静真实际
  以能知于彼　　自性清净心
  见烦恼无实　　故离诸烦恼
  无障净智者　　如实见众生
  自性清净性　　佛法僧境界
  无阂净智者　　见诸众生性
  遍无量境界　　故我今敬礼

问曰。依何等法有此三宝。答曰。偈言

  真如有杂垢　　及远离诸垢
  佛无量功德　　及佛所作业
  如是妙境界　　是诸佛所知
  依此妙法身　　出生于三宝

    究竟一乘宝性论一切众生有如来藏品第五

问曰。云何得知一切众生有如来藏。答曰。偈言

  一切众生界　　不离诸佛智
  以彼净无垢　　性体不二故
  依一切诸佛　　平等法性身
  知一切众生　　皆有如来藏

又复略说偈言

  体及因果业　　相应及以行
  时差别遍处　　不变无差别
  彼妙义次第　　第一真法性
  我如是略说　　汝今应善知

此偈明何义。偈曰

  自性常不染　　如宝空净水
  信法及般若　　三昧大悲等
  净我乐常等　　彼岸功德果
  厌苦求涅槃　　欲愿等诸业
  大海器宝水　　无量不可尽
  如灯明触色　　性功德如是
  见实者说言　　凡夫圣人佛
  众生如来藏　　真如无差别
  有不净杂净　　及以善净等
  如是次第说　　众生菩萨佛
  如空遍一切　　而空无分别
  自性无垢心　　亦遍无分别
  如虚空遍至　　体细尘不染
  佛性遍众生　　诸烦恼不染
  如一切世间　　依虚空生灭
  依于无漏界　　有诸根生灭
  火不烧虚空　　若烧无是处
  如是老病死　　不能烧佛性
  地依于水住　　水复依于风
  风依于虚空　　空不依地等
  如是阴界根　　住烦恼业中
  诸烦恼业等　　依不善思惟
  不善思惟行　　住清净心中
  自性清净心　　不住彼诸法
  阴入界如地　　烦恼业如水
  不正念如风　　净心界如空
  依性起邪念　　念起烦恼业
  依因烦恼业　　能起阴界入
  依止于五阴　　界入等诸法
  有诸根生灭　　如世界成坏
  净心如虚空　　无因复无缘
  及无和合义　　亦无生住灭
  如虚空净心　　常明无转变
  为虚妄分别　　客尘烦恼染
  菩萨摩诃萨　　如实知佛性
  不生亦不灭　　又无老病等
  菩萨如是知　　得离于生死
  怜愍众生故　　示现有生灭
  佛身不变异　　以得无尽法
  众生所归依　　以无边际故
  常住不二法　　以离妄分别
  恒不执不作　　清净心力故
  法身及如来　　圣谛与涅槃
  功德不相离　　如光不离日

    究竟一乘宝性论无量烦恼所缠品第六

  萎花中诸佛　　众蜂中美蜜
  皮糩等中实　　粪秽中真金
  地中珍宝藏　　诸果子中芽
  朽故弊坏衣　　缠裹真金像
  贫贱丑陋女　　怀转轮圣王
  焦黑泥模中　　有上妙宝像
  众生贪嗔痴　　妄想烦恼等
  尘劳诸垢中　　皆有如来藏
  花蜂糩粪秽　　地果故弊衣
  贫贱女泥模　　烦恼垢相似
  佛蜜实真金　　宝牙金像王
  上妙宝像等　　如来藏相似

问曰。华佛譬喻为明何义。答曰。言萎华者喻诸烦恼。言诸佛者喻如来藏。偈曰

  功德庄严佛　　住于萎华中
  净天眼者见　　去花显诸佛
  佛眼观自法　　遍一切众生
  下至阿鼻狱　　具足如来藏
  自处常住际　　以慈悲方便
  令一切众生　　远离诸障碍
  如朽故华中　　有诸佛如来
  天眼者见知　　除去萎华叶
  如来亦如是　　见贪烦恼垢
  不净众生中　　具足如来藏
  以大慈悲心　　怜愍世间故
  为一切众生　　除烦恼花叶

问曰。蜂蜜譬喻为明何义。答曰。言群蜂者喻诸烦恼。言美蜜者喻如来藏。偈言

  上妙美味蜜　　为群蜂围绕
  须者设方便　　散蜂而取蜜
  如来亦如是　　以一切智眼
  见诸烦恼蜂　　围绕佛性蜜
  以大方便力　　散彼烦恼蜂
  显出如来藏　　如取蜜受用
  犹如百千亿　　那由他诸虫
  遮障微妙蜜　　无有能近者
  有智者须蜜　　杀害彼诸虫
  取上味美蜜　　随意而受用
  无漏智如蜜　　在众生身中
  烦恼如毒虫　　如来所杀害

问曰。糩实譬喻为明何义。答曰。言皮糩者喻诸烦恼。言内实者喻如来藏偈言

  谷实在糩中　　无人能受用
  时有须用者　　方便除皮糩
  佛见诸众生　　身有如来性
  烦恼皮糩缠　　不能作佛事
  以善方便力　　令三界众生
  除烦恼皮糩　　随意作佛事
  如稻谷麦等　　不离诸皮糩
  内实未净治　　不任美食用
  如是如来藏　　不离烦恼糩
  令一切众生　　烦恼所饥渴
  佛自在法王　　在众生身中
  能示以爱味　　除彼饥渴苦

问曰。粪金譬喻为明何义。答曰。粪秽譬喻者诸烦恼相似。真金譬喻者如来藏相似偈言

  如人行远路　　遗金粪秽中
  经百千岁住　　如本不变异
  净天眼见已　　遍告众人言
  此中有真金　　汝可取受用
  佛观众生性　　没烦恼粪中
  为欲拔济彼　　雨微妙法雨
  如于不净地　　漏失真金宝
  诸天眼了见　　众生不能知
  诸天既见已　　语众悉令知
  教除垢方便　　得净真金用
  佛性金亦尔　　堕烦恼秽中
  如来观察已　　为说清净法

问曰。地宝譬喻为明何义。答曰。地譬喻者诸烦恼相似。宝藏譬喻者如来藏相似。偈言

  譬如贫人舍　　地有珍宝藏
  彼人不能知　　宝又不能言
  众生亦如是　　于自心舍中
  有不可思议　　无尽法宝藏
  虽有此宝藏　　不能自觉知
  以不觉知故　　受生死贫苦
  譬如珍宝藏　　在彼贫人宅
  人不言我贫　　宝不言我此
  如是法宝藏　　在众生心中
  众生如贫人　　佛性如宝藏
  为欲令众生　　得此珍宝故
  彼诸佛如来　　出现于世间

问曰。果芽譬喻为明何义。答曰。果皮譬喻者诸烦恼相似。子芽譬喻者如来藏相似。偈言

  如种种果树　　子芽不朽坏
  种地中水灌　　生长成大树
  一切诸众生　　种种烦恼中
  皆有如来性　　无明皮所缠
  种诸善根地　　生彼菩提芽
  次第渐增长　　成如来树王
  依地水火风　　空时日月缘
  多罗等种内　　出生大树王
  一切诸众生　　皆亦复如是
  烦恼果皮内　　有正觉子牙
  依白净等法　　种种诸缘故
  次第渐增长　　成佛大法王

问曰。衣像譬喻为明何义。答曰。弊衣譬喻者诸烦恼相似。金像譬喻者如来藏相似。偈言

  弊衣缠金像　　在于道路中
  诸天为人说　　此中有金像
  种种烦恼垢　　缠裹如来藏
  佛无障眼见　　下至阿鼻狱
  皆有如来身　　为令彼得故
  广设诸方便　　说种种妙法
  金像弊衣缠　　堕在旷野路
  有天眼者见　　为净示众人
  众生如来藏　　烦恼烂衣缠
  在世间险道　　而不自觉知
  佛眼观众生　　皆有如来藏
  为说种种法　　令彼得解脱

问曰。女王譬喻为明何义。答曰。贱女譬喻者诸烦恼相似。歌罗逻四大中有转轮王身喻者。生死歌罗逻藏中有如来藏转轮王相似。偈言

  譬如孤独女　　住在贫穷舍
  身怀转轮王　　而不自觉知
  如彼贫穷舍　　三有亦如是
  怀胎女人者　　喻不净众生
  如彼藏中胎　　众生性亦尔
  内有无垢性　　名为不孤独
  贫女垢衣缠　　极丑陋受苦
  处于孤独舍　　怀妊王重担
  如是诸烦恼　　染污众生性
  受无量苦恼　　无有归依处
  实有归依处　　而无归依心
  不觉自身中　　有如来藏故

问曰。摸像譬喻为明何义。答曰。泥摸譬喻者诸烦恼相似。宝像譬喻者如来藏相似。偈言

  如人融真金　　铸在泥摸中
  外有焦黑泥　　内有真宝像
  彼人量已冷　　除去外泥障
  开摸令显现　　取内真宝像
  佛性常明净　　客垢所染污
  诸佛善观察　　除障令显现
  离垢明净像　　在于秽泥中
  铸师知无热　　然后去泥障
  如来亦如是　　见众生佛性
  俨然处烦恼　　如像在摸中
  能以巧方便　　善用说法椎
  打破烦恼摸　　显发如来藏

    究竟一乘宝性论为何义说品第七

问曰。余修多罗中皆说一切空。此中何故说有真如佛性。偈言

  处处经中说　　内外一切空
  有为法如云　　及如梦幻等
  此中何故说　　一切诸众生
  皆有真如性　　而不说空寂

答曰偈言

  以有怯弱心　　轻慢诸众生
  执着虚妄法　　谤真如实性
  计身有神我　　为令如是等
  远离五种过　　故说有佛性

    究竟一乘宝性论身转清净成菩提品第八

  净得及远离　　自他利相应
  依止深快大　　如彼所为义

初说佛菩提及得菩提方便。偈言

  向说佛法身　　自性清净体
  为诸烦恼垢　　客尘所染污
  譬如虚空中　　离垢净日月
  为彼厚密云　　罗网之所覆
  佛功德无垢　　常恒及不变
  不分别诸法　　得无漏真智

次说无垢清净体。偈言

  如清净池水　　无有诸尘浊
  种种杂花树　　周匝常围绕
  如月离罗睺　　日无云翳等
  无垢功德具　　显现即彼体
  蜂王美味蜜　　坚实净真金
  宝藏大果树　　无垢真金像
  转轮圣王身　　妙宝如来像
  如是等诸法　　即是如来身

次说成就自利利他。偈言

  无漏及遍至　　不灭法与恒
  清凉不变异　　不退寂静处
  诸佛如来身　　如虚空无相
  为诸胜智者　　作六根境界
  示现微妙色　　出乎妙音声
  令嗅佛戒香　　与佛妙法味
  使觉三昧触　　令知深妙法
  细思惟稠林　　佛离虚空相

次说第一义相应。偈言

  如空不思议　　常恒及清凉
  不变与寂静　　遍离诸分别
  一切处不着　　离阂粗涩触
  亦不可见取　　佛净心无垢

次说佛法身。偈言

  非初非中后　　不破坏不二
  远离于三界　　无垢无分别
  此甚深境界　　非二乘所知
  具胜三昧慧　　如是人能见
  出过于恒沙　　不思议功德
  唯如来成就　　不与余人共
  如来妙色身　　清净无垢体
  远离诸烦恼　　及一切习气
  种种胜妙法　　光明以为体
  令众生解脱　　常无有休息
  所作不思议　　如摩尼宝王
  能现种种形　　而彼体非实
  为世间说法　　示现寂静处
  教化使淳熟　　授记令入道
  如来镜像身　　而不离本体
  犹如一切色　　不离于虚空

次说如来常住身。偈言

  世尊体常住　　以修无量因
  众生界不尽　　慈悲心如意
  智成就相应　　法中得自在
  降伏诸魔怨　　体寂静故常

次说不可思议体。偈言

  非言语所说　　第一义谛摄
  离诸觉观地　　无譬喻可说
  最上胜妙法　　不取有涅槃
  非三乘所知　　唯是佛境界

    究竟一乘宝性论如来功德品第九

  自利亦利他　　第一义谛身
  依彼真谛身　　有此世谛体
  果远离淳熟　　此中具足有
  六十四种法　　诸功德差别

略说偈言

  佛力金刚杵　　破无智者障
  如来无所畏　　处众如师子
  如来不共法　　清净如虚空
  如彼水中月　　众生二种见

初说十力。偈言

  处非处果报　　业及于诸根
  性信至处道　　离垢诸禅定
  忆念过去世　　天眼寂静智
  如是等诸句　　说名十种力

如金刚杵者。偈言

  处非处业性　　众生诸信根
  种种随修地　　过宿命差别
  天眼漏尽等　　佛力金刚杵
  能刺摧散破　　痴铠山墙树

次说四无畏。偈言

  如实觉诸法　　遮诸阂道障
  说道得无漏　　是四种无畏
  于所知境界　　毕竟知自他
  自知教他知　　此非遮障道
  能证胜妙果　　自得令他得
  说自他利谛　　是诸处无畏

如师子王者。偈言

  譬如师子王　　诸兽中自在
  常在于山林　　不怖畏诸兽
  佛人王亦尔　　处于诸群众
  不畏及善住　　坚固奋迅等

次说佛十八不共法。偈言

  佛无过无诤　　无妄念等失
  无不定散心　　无种种诸想
  无作意护心　　欲精进不退
  念慧及解脱　　知见等不退
  诸业智为本　　知三世无障
  佛十八功德　　及余不说者
  佛身口无失　　若他来破坏
  内心无动相　　非作心舍心
  世尊欲精进　　念净智解脱
  知见常不失　　示现可知境
  一切诸业等　　智为本展转
  三世无障碍　　广大智行常
  是名如来体　　大智慧相应
  觉彼大菩提　　最上胜妙法
  为一切众生　　转于大法轮
  无畏胜妙法　　令彼得解脱

次说虚空不相应义。偈言

  地水火风等　　彼法空中无
  诸色中亦无　　虚空无阂法
  诸佛无阂障　　犹如虚空相
  如来在世间　　如地水火风
  而诸佛如来　　所有诸功德
  乃至无一法　　共余世间有

次说三十二大人相。偈言

  足下相平满　　具足千辐轮
  跟佣趺上隆　　伊尼鹿王踹
  手足悉柔软　　诸指皆纤长
  鹅王网缦指　　臂肘上下佣
  两肩前后平　　左右俱圆满
  立能手过膝　　马王阴藏相
  身佣相洪雅　　如尼拘树王
  体相七处满　　上半如师子
  威德势坚固　　犹如那罗延
  身色新净妙　　柔软金色皮
  净软细平密　　一孔一毛生
  毛柔软上靡　　微细轮右旋
  身净光圆匝　　顶上相高显
  项如孔雀王　　颐方若师子
  发净金精色　　喻如因陀罗
  额上白毫相　　通面净光明
  口含四十齿　　二牙白踰雪
  深密内外明　　上下齿平齐
  迦陵频伽声　　妙音深远声
  所食无完过　　得味中上味
  细薄广长舌　　二目淳绀色
  眼睫若牛王　　功德如莲华
  如是说人尊　　妙相三十二
  一一不杂乱　　普身不可嫌

次说如水中月偈言

  秋空无云翳　　月在天及水
  一切世间人　　皆见月势力
  清净佛轮中　　具功德势力
  佛子见如来　　功德身亦尔

    究竟一乘宝性论自然不休息佛业品第十

  于可化众生　　以教化方便
  起化众生业　　教化众生界
  诸佛自在人　　于可化众生
  常待时待处　　自然作佛事
  遍觉知大乘　　最妙功德聚
  如大海水宝　　如来智亦尔
  菩提广无边　　犹如虚空界
  放无量功德　　大智慧日光
  遍照诸众生　　有佛妙法身
  无垢功德藏　　如我身无异
  烦恼障智障　　云雾罗网覆
  诸佛慈悲风　　吹令散灭尽

次说大乘业喻。略说偈言

  帝释妙鼓云　　梵天日摩尼
  响及虚空地　　如来身亦尔

初说帝释镜像譬喻。偈言

  如彼毗琉璃　　清净大地中
  天主帝释身　　于中镜像现
  如是众生心　　清净大地中
  诸佛如来身　　于中镜像现
  帝释现不现　　依地净不净
  如是诸世间　　镜像现不现
  如来有起灭　　依浊不浊心
  如是诸众生　　镜像现不现
  天主帝释身　　镜像有生灭
  不可得说有　　不可得说无
  如来身亦尔　　镜像有生灭
  不可得说有　　不可得说无
  如地普周遍　　远离高下秽
  大琉璃明净　　离垢功德平
  以彼毗琉璃　　清净无垢故
  天主镜像现　　及庄严具生
  若男若女等　　于中见天主
  及妙庄严具　　作生彼处愿
  众生为生彼　　修行诸善行
  持戒及布施　　散花舍珍宝
  后时功德尽　　地灭彼亦灭
  心琉璃地净　　诸佛镜像现
  诸佛子菩萨　　见佛心欢喜
  为求菩提故　　起愿修诸行

不生不灭者。即是如来。偈言

  如毗琉璃灭　　彼镜像亦灭
  无可化众生　　如来不出世
  琉璃宝地净　　示现佛妙像
  彼净心不坏　　信根芽增长
  白净法生灭　　佛像亦生灭
  如来不生灭　　犹如帝释王
  此业自然有　　见是等现前
  法身不生灭　　尽诸际常住

次说天中妙鼓譬喻。偈言

  天妙法鼓声　　依自业而有
  诸佛说法音　　众生自业闻
  如妙声远离　　功用处身心
  令一切诸天　　离怖得寂静
  佛声亦如是　　离功用身心
  令一切众生　　得证寂灭道
  于彼战斗时　　为破修罗力
  因鼓出畏声　　令修罗退散
  如来为众生　　灭诸烦恼苦
  为世间说法　　示胜禅定道

一切世间人。不觉自过失。偈言

  聋不闻细声　　天耳闻不遍
  唯智者境界　　以闻心不染

次说云雨譬喻偈言

  知有起悲心　　遍满世间处
  定持无垢藏　　佛雨净谷因
  世间依善业　　依风生云雨
  依悲等增长　　佛妙法云雨

依止器世间。雨水味变坏偈言

  譬如虚空中　　雨八功德水
  到碱等住处　　生种种异味
  如来慈悲云　　雨八圣道水
  到众生心处　　生种种解味

无差别心。偈言

  信于妙大乘　　及中谤法者
  人遮多鸟鬼　　此三聚相似
  正定聚众生　　习气不定聚
  身见邪定聚　　邪见流生死
  秋天无云雨　　人空鸟受苦
  夏天多雨水　　烧鬼令受苦
  佛现世不现　　悲云雨法雨
  信法器能得　　谤法有不闻

不护众生。偈言

  天雨如车轴　　澍下冲大地
  雹及霹雳石　　金刚爆火等
  不护微细虫　　山林诸果树
  草谷稻粮等　　行人故不雨
  如来亦如是　　于粗细众生
  相应诸方便　　般若悲云雨
  诸烦恼习气　　我邪见众生
  如是种类等　　一切智不护

为灭苦火。偈言

  知病离病因　　取无病修药
  苦因彼灭道　　知离触修等
  无始世生死　　波流转五道
  五道中受乐　　犹如臭烂粪
  寒热恼等触　　诸苦毕竟有
  为令彼除灭　　降大妙法雨
  知天中退苦　　人中追求苦
  有智者不求　　人天自在乐
  慧者信佛语　　已信者知苦
  亦复知苦因　　观灭及知道

次说梵天譬喻。偈言

  梵天过去愿　　依诸天净业
  梵天自然现　　化佛身亦尔
  梵宫中不动　　常现于欲界
  诸天见妙色　　失五欲境界
  佛法身不动　　而常现世间
  众生见欢喜　　不乐诸有乐

有现不现。偈言

  从天退入胎　　现生有父母
  在家示婴儿　　习学诸伎艺
  戏乐及游行　　出家行苦行
  现就外道学　　降伏于天魔
  成佛转法轮　　示道入涅槃
  诸薄福众生　　不能见如来

次说日譬喻。偈言

  如日光初出　　普照诸莲华
  有同一时开　　亦有一时合
  佛日亦如是　　照一切众生
  有智如华开　　有罪如华合
  如日照水华　　而日无分别
  佛日亦如是　　照而无分别

次第偈言

  日初出世间　　千光次第照
  先照高大山　　后照中下山
  佛日亦如是　　次第照世间
  先照诸菩萨　　后及余众生

光明轮不同。偈言

  色智身二法　　大悲身如空
  遍照诸世间　　故佛不同日
  日不能遍照　　诸国土虚空
  不破无明闇　　不示何知境
  放种种诸色　　光明云罗网
  示大慈悲体　　真如妙境界
  佛入城聚落　　无眼者得眼
  见佛得大利　　亦灭诸恶法
  无明没诸有　　邪见黑闇障
  如来日光照　　见慧未见处

次说摩尼珠譬喻。偈言

  一时同处住　　满足所求意
  摩尼宝无心　　而满众生愿
  自在大法王　　同住于悲心
  众生种种闻　　佛心无分别

次说响譬喻。偈言

  譬如诸响声　　依他而得起
  自然无分别　　非内非外住
  如来声亦尔　　依他心而起
  自然无分别　　非内非外住

次说虚空譬喻。偈言

  无物不可见　　无观无依止
  过眼识境界　　无色不可见
  空中见高下　　而空不如是
  佛中见一切　　其义亦如是

次说地譬喻。偈言

  一切诸草木　　依止大地生
  地无分别心　　而增长成就
  众生心善根　　依止佛地生
  佛无分别心　　而增广成就
  佛声犹如响　　以无名字说
  佛身如虚空　　遍不可见常
  如依地诸法　　一切诸妙药
  遍为诸众生　　不限于一人
  依佛地诸法　　白净妙法药
  遍为诸众生　　不限于一人

    究竟一乘宝性论校量信功德品第十一

  佛性佛菩提　　佛法及佛业
  诸出世净人　　所不能思议
  此诸佛境界　　若有能信者
  得无量功德　　胜一切众生
  以求佛菩提　　不思议果报
  得无量功德　　故胜诸世间
  若有人能舍　　魔尼诸珍宝
  遍布十方界　　无量佛国土
  为求佛菩提　　施与诸法王
  是人如是施　　无量恒沙劫
  若复有人闻　　妙境界一句
  闻已复能信　　过施福无量
  若有智慧人　　奉持无上戒
  身口意业净　　自然常护持
  为求佛菩提　　如是无量劫
  是人所得福　　不可得思议
  若复有人闻　　妙境界一句
  闻已复能言　　过戒福无量
  若人入禅定　　焚三界烦恼
  过天行彼岸　　无菩提方便
  若复有人闻　　妙境界一句
  闻已复能信　　过禅福无量
  无慧人能舍　　唯得富贵报
  修持禁戒者　　得生人天中
  修行断诸障　　悲慧不能除
  慧除烦恼障　　亦能除智障
  闻法为慧因　　是故闻法胜
  何况闻法已　　复能生信心
  我此所说法　　为自心清净
  依诸如来教　　修多罗相应
  若有智慧人　　闻能信受者
  我此所说法　　亦为摄彼人
  依灯电摩尼　　日月等诸明
  一切有眼者　　皆能见境界
  依佛法光明　　慧眼者能见
  以法有是利　　故我说此法
  若一切所说　　有义有法句
  能令修行者　　远离于三界
  及示寂静法　　最胜无上道
  佛说是正经　　余者颠倒说
  虽说法句义　　断三界烦恼
  无明覆慧眼　　贪等垢所缚
  又于佛法中　　取少分说者
  世典善言说　　彼三尚可受
  何况诸如来　　远离烦恼垢
  无漏智慧人　　所说修多罗
  以离于诸佛　　一切世间中
  更无胜智慧　　如实知法者
  如来说了义　　彼不可思议
  思者是谤法　　不识佛意故
  谤圣及坏法　　此诸邪思惟
  烦恼愚痴人　　妄见所计故
  故不应执着　　邪见诸垢法
  以净衣受色　　垢腻不可染

问曰。以何因缘有此谤法。答曰。偈言

  愚不信白法　　邪见及憍慢
  过去谤法障　　执着不了义
  着供养恭敬　　唯见于邪法
  远离善知识　　亲近谤法者
  乐着小乘法　　如是等众生
  不信于大乘　　故谤诸佛法
  智者不应畏　　怨家蛇火毒
  因陀罗霹雳　　刀杖诸恶兽
  虎狼师子等　　彼但能断命
  不能令人入　　可畏阿鼻狱
  应畏谤深法　　及谤法知识
  决定令人入　　可畏阿鼻狱
  虽近恶知识　　恶心出佛血
  及杀害父母　　断诸圣人命
  破坏和合僧　　及断诸善根
  以系念正法　　能解脱彼处
  若复有余人　　诽谤甚深法
  彼人无量劫　　不可得解脱
  若人令众生　　觉信如是法
  彼是我父母　　亦是善知识
  彼人是智者　　以如来灭后
  回邪见颠倒　　令入正道故
  三宝清净性　　菩提功德业
  我略说七种　　与佛经相应
  依此诸功德　　愿于命终时
  见无量寿佛　　无边功德身
  我及余信者　　既见彼佛已
  愿得离垢眼　　成无上菩提

论曰。第一教化品。如向偈中已说。应知此论。广门有十一品。中则七品。略唯一品。初释一品。具摄此论法义体相。应知偈言

  佛法及众僧　　性道功德业
  略说此论体　　七种金刚句

此偈明何义。言金刚者。犹如金刚难可沮坏。所证之义亦复如是。故言金刚。所言句者。以此论句。能与证义为根本故。此明何义。内身证法无言之体。以闻思智难可证得。犹如金刚。名字章句以能诠彼理中证智。随顺正道。能作根本故。名为句。此复何义。有二义故。何谓二义。一难证义。二者因义。是名为义。金刚字句应如是知

又何谓为义。何谓为字。义者。则有七种证义。何谓七义。一者佛义。二者法义。三者僧义。四者众生义五者菩提义。六者功德义。七者业义。是名为义。是故经言。又第一义谛者。所谓心缘尚不能知。何况名字章句故。所言字者。随以何等名字。章句。言语。风声。能表。能说。能明。能示。此七种义。是名为字。是故经言。又世谛者。谓世间中所用之事。名字章句言语所说故。又此七种金刚句义。如诸经中广说应知。应云何知依佛义故。如来经中告阿难言。阿难。所言如来者。非可见法。是故眼识不能得见故。依法义故。如来经中告阿难言。阿难。所言法者。非可说事。以是故非耳识所闻故。依僧义故。如来经中告阿难言。阿难。所言僧者。名为无为。是故不可身心供养礼拜赞叹故。依众生义故。如来经中告舍利弗言。舍利弗。言众生者。乃是诸佛如来境界。一切声闻辟支佛等。以正智慧不能观察众生之义。何况能证毛道凡夫。于此义中唯信如来。是故舍利弗。随如来信此众生义。舍利弗。言众生者。即是第一义谛。舍利弗言。第一义谛者。即是众生界。舍利弗言。众生界者。即是如来藏。舍利弗言。如来藏者。即是法身故。依菩提义故。经中说言。世尊言阿耨多罗三藐三菩提者。名涅槃界。世尊言。涅槃界者。即是法身故。依功德义故。如来经中告舍利弗言。舍利弗。如来所说法身义者。过于恒沙不离不脱不思议佛法如来智慧功德。舍利弗。如世间灯。明色及触不离不脱。又如摩尼宝珠。明色形相不离不脱。舍利弗。法身之义亦复如是。过于恒沙不离不脱不思议佛法如来智慧功德故。依业义故。如来经中告文殊师利言。文殊师利。如来不分别。不分别无分别。而自然无分别。如所作业自然行故。如是等名略说七种金刚字句。总摄此论体相应知。是故偈言

  七种相次第　　总持自在王
  菩萨修多罗　　序分有三句
  余残四句者　　在菩萨如来
  智慧差别分　　应当如是知

此偈明何义。以是七种金刚字句。总摄此论。一切佛法广说其相。如陀罗尼自在王经序分中三句。余四句在彼修多罗菩萨如来法差别分。应知云何序分有初三句。彼修多罗序分中言。婆伽婆平等证一切法。善转法轮。善能教化调伏无量诸弟子众。如是三种根本字句。次第示现佛法僧宝。说彼三宝次第生起成就。应知余四句者。说随顺三宝因。成就三宝因。应知此明何义。以诸菩萨于八地中。十自在为首。具足得一切自在。是故菩萨坐于道场胜妙之处。于一切法中。皆得自在是故经言。婆伽婆平等证一切法故。以诸菩萨住九地时。于一切法中。得为无上最大法师。善知一切诸众生心。到一切众生根机第一彼岸。能断一切众生烦恼习气。是故菩萨成大菩提。是故经言。善转法轮故。以诸菩萨于第十地中。得住无上法王位。后能于一切佛所作业。自然而行。常不休息。是故经言。善能教化调伏无量诸弟子众故。彼善能教化调伏无量诸弟子众。即彼经中次后示现。是故经言。与大比丘众俱。如是乃至复有无量菩萨众俱。如是次第。善能教化声闻位地及佛菩提。善能调伏一切烦恼。如是毕竟有无量功德。又说声闻菩萨诸功德已。次说诸佛如来不可思议三昧境界。又说诸佛如来三昧境界已。次说无垢大宝庄严宝殿成就。又说大宝庄严宝殿成就已。次说大众云集种种供养赞叹如来。雨种种衣。雨种种华。雨种种香。如是等。示现佛宝不思议事。应知又复次说妙法庄严法座。又说妙法庄严法座已。次说法门名字及示现功德。此明法宝功德差别。应如又复次说诸菩萨摩诃萨迭共三昧行境界。示现种种功德。此明僧宝功德差别。应知又复次说如来放大光明授诸菩萨摩诃萨太子法王位职。又复次说与大无畏不怯弱辩才。又复赞叹诸佛如来第一功德。又复次说最上第一大乘之法。示现如实修行彼大乘故。于法中证果即彼三宝无上功德次第差别。序分中义大都已竟。应如是知。已说自在王菩萨修多罗序分中三宝。次说佛性义。有六十种法。清净彼功德。何以故。以有彼清净无量功德性。为清净彼性。修六十种法。为此义故。十地经中。数数说金。以为譬喻。为清净彼佛性义故。又复即于此陀罗尼自在王经中。说如来业已。次说不清净大毗琉璃摩尼宝喻。是故经言。善男子。譬如善巧摩尼宝师。善知清净大摩尼宝。向大摩尼宝性山中。取未清净诸摩尼宝。既取彼宝。以严灰洗。严灰洗已。然后复持黑头发衣。以用揩磨。不以为足。勤未休息。次以辛味饮食汁洗。食汁洗已。然后复持衣缠裹木以用揩磨。不以为足。勤未休息。次后复以大药汁洗。药汁洗已。次后复更持细软衣。以用揩磨。以细软衣。用揩磨已。然后远离铜铁等矿毗琉璃垢。方得说言大琉璃宝。善男子。诸佛如来亦复如是。善知不净诸众生性。知已乃为说无常苦无我不净。为惊怖彼乐世众生。令厌世间。入声闻法中。而佛如来不以为足。勤未休息。次为说空无相无愿。令彼众生少解如来所说法轮。而佛如来不以为足。勤未休息。次复为说不退法轮。次说清净波罗蜜行。谓不见三事。令众生入如来境界。如是依种种因。依种种性。入佛法中。入法中已故。名无上最大福田。又复依此自性清净如来性故。经中偈言

  譬如石矿中　　真金不可见
  能清净者见　　见佛亦如是

向说佛性有六十种净业功德。何谓六十。所谓四种菩萨庄严。八种菩萨光明。十六种菩萨摩诃萨大悲。三十二种诸菩萨业

已说佛性义。次说佛菩提。有十六种无上菩提大慈悲心

已说佛菩提。次说诸佛如来功德。所谓十力。四无所畏。十八不共法

已说功德。次说如来三十二种无上大业。如是七种金刚句义。彼修多罗广说体相。如是应知。问曰。此七种句有何次第。答曰偈言

  从佛次有法　　次法复有僧
  僧次无碍性　　从性次有智
  十力等功德　　为一切众生
  而作利益业　　有如是次第

已说一品具摄此论法义体相。次说七品具摄此论法义体相。解释偈义应知归敬三宝者。此明何义。所有如来教化众生。彼诸众生归依于佛。尊敬如来。归依于法。尊敬如来。归依于僧。依于三宝。说十二偈。初明佛宝。故说四偈

究竟一乘宝性论卷第一究竟一乘宝性论卷第二

        后魏中印度三藏勒那摩提译

    佛宝品第二

  佛体无前际　　及无中间际
  亦复无后际　　寂静自觉知
  既自觉知已　　为欲令他知
  是故为彼说　　无畏常恒道
  佛能执持彼　　智慧慈悲刀
  及妙金刚杵　　割截诸苦芽
  摧碎诸见山　　覆藏颠倒意
  及一切稠林　　故我今敬礼

此偈示现何义。偈言

  无为体自然　　不依他而知
  智悲及以力　　自他利具足

此偈略明佛宝所摄八种功德。何等为八。一者无为体。二者自然。三者不依他知。四者智。五者悲。六者力。七者自利益。八者他利益。偈言

  非初非中后　　自性无为体
  及法体寂静　　故自然应知
  唯内身自证　　故不依他知
  如是三觉知　　慈心为说道
  智悲及力等　　拔苦烦恼刺
  初三句自利　　后三句利他

此偈明何义。远离有为。名为无为。应知又有为者。生住灭法。无彼有为。是故佛体。非初中后。故得名为无为法身。应知偈言。佛体无前际。及无中间际。亦复无后际故。又复远离一切戏论虚妄分别。寂静体故。名为自然。应知偈言寂静。故不依他知者。不依他因缘证知故。不依他因缘证知者。不依他因缘生故。不依他因缘生者。自觉不依他觉故。如是依于如来无为法身相故。一切佛事无始世来。自然而行常不休息。如是希有不可思议诸佛境界。不从他闻。不从他闻者。不从师闻。自自在智无言之体而自觉知偈言自觉知故既自觉知已。然后为他生盲众生。令得觉知。为彼证得无为法身。说无上道。是故名为无上智悲。应知偈言既自觉知已。为欲令他知。是故为彼说无畏常恒道故无畏常恒道者。明道无畏是常是恒。以出世间不退转法。如是次第又拔他苦烦恼根本。如来智慧慈悲及神力如是三句刀金刚杵譬喻示现。又以何者。为苦根本。略说言之。谓三有中生名色是。又何者为烦恼根本。谓身见等。虚妄邪见疑戒取等。又名色者。是彼所摄所生苦芽。应知如来智慧慈悲心等。能割彼芽。以是义故。说刀譬喻。偈言佛能执持彼智慧慈悲刀故。割截诸苦芽故。又邪见疑所摄烦恼。见道远离。以世间智所不能知。稠林烦恼不能破坏。如世间中树林墙等。彼相似法以如来力能破坏。彼以是故。说金刚杵喻。偈言及妙金刚杵故。摧碎诸见山覆藏颠倒意及一切稠林故。此六种句如来庄严智慧光明入一切佛境界经中次第显说应知。应云何知。彼经中言。文殊师利。如来应正遍知不生不灭者。此明如来无为之相。又复次说无垢清净琉璃地中帝释王身镜像现等。如是乃至九种譬喻。皆明如来不生不灭。又言。文殊师利。如来应正遍知。清净法身亦复如是。不动不生。心不戏论。不分别不分别无分别。不思无思不思议。无念寂灭寂静。不生不灭。不可见不可闻。不可嗅不可尝。不可触无诸相。不可觉不可知。如是等句。皆说寂静差别之相。此明何义。明佛一切所作事中。远离一切戏论分别。寂静自然。次说余残修多罗。彼中说言。如实觉知一切法门者。此明如来不依他故证大菩提。又复次说如来菩提有十六种。是故经言。文殊师利。如来如是如实觉知一切诸法。观察一切众生法性不净有垢有点奋迅。于诸众生大悲现前。此明如来无上智悲。应知文殊师利。如来如是如实觉知一切法者。如向前说。无体为体。如实觉知者。如实无分别佛智知故。观察一切众生法性者。乃至邪聚众生。如我身中法性法体法界如来藏等。彼诸众生亦复如是无有差别。如来智眼了了知故。不净者以诸凡夫烦恼障故。有垢者以诸声闻辟支佛等有智障故。有点者以诸菩萨摩诃萨等依彼二种习气障故。奋迅者能如实知种种众生可化方便。入彼众生可化方便种种门故。大悲者成大菩提得于一切众生平等大慈悲心。为欲令彼一切众生如佛证智。如是觉知证大菩提故。次于一切众生平等转大法轮常不休息。如是三句能作他利益故名为力。应知又此六句次第。初三种句谓无为等功德。如来法身相应示现自利益。余三种句所谓智等示现他利益。又复有义。以有智慧故证得第一寂静法身。是故名为自利益。又依慈悲力等二句转大法轮示现他利益。已说佛宝。次明法宝

    究竟一乘宝性论法宝品第三

论曰。依彼佛宝有真法宝。以是义故次佛宝后示现法宝。依彼法宝故说四偈

  非有亦非无　　亦复非有无
  亦非即于彼　　亦复不离彼
  不可得思量　　非闻慧境界
  出离言语道　　内心知清凉
  彼真妙法日　　清净无尘垢
  大智慧光明　　普照诸世间
  能破诸曀障　　觉观贪嗔痴
  一切烦恼等　　故我今敬礼

此偈示现何义。偈言

  不思议不二　　无分净现对
  依何得何法　　离法二谛相

此偈略明法宝所摄八种功德。何等为八。一者不可思议。二者不二。三者无分别。四者净。五者显现。六者对治。七者离果。八者离因。离者偈言

  灭谛道谛等　　二谛摄取离
  彼各三功德　　次第说应知

此偈明何义。前六功德中初三种功德不思议不二及无分别等。示现彼灭谛摄取离烦恼。应知余残有三句。净显现对治。示现彼道谛摄取断烦恼因。应知又证法所有离名为灭谛。以何等法修行断烦恼名为道谛。以此二谛合为净法。以二谛相名为离法。应知偈言

  不思量无言　　智者内智知
  以如是义故　　不可得思议
  清凉不二法　　及无分别法
  净显现对治　　三句犹如日

此偈明何义。略明灭谛有三种法。以是义故不可思议。应知以何义故不可思议。有四义故。何等为四。一者为无。二者为有。三者为有无。四者为二。偈言非有亦非无。亦复非有无。亦非即于彼。亦复不离彼故。灭谛有三种法。应知者。此明何义。灭谛非可知。有三种法。何等为三。一者非思量境界故。偈言不可得思量。非闻慧境界故。二者远离一切声响名字章句言语相貌故。偈言出离言语道故。三者圣人内证法故。偈言内心知故。又灭谛云何不二法者。及云何无分别者。如不增不减经中如来说言。舍利弗如来法身清凉。以不二法故。以无分别法故。偈言清凉故。何者是二而说不二所言二者。谓业烦恼。言分别者。所谓集起业烦恼因及邪念等。以知彼自性本来寂灭不二无二行。知苦本来不生。是名苦灭谛。非灭法故名苦灭谛。是故经言。文殊师利。何等法中无心意意识行。彼法中无分别。以无分别故不起邪念。以有正念故不起无明。以不起无明故。即不起十二有支。以不起十二有支故。即名无生。是故圣者胜鬘经言。世尊。非灭法故名苦灭谛。世尊。所言苦灭者。名无始无作无起无尽离尽。常恒清凉不变自性清净。离一切烦恼藏所缠。世尊过于恒沙。不离不脱不异不思议佛法毕竟成就。说如来法身。世尊。如是如来法身不离烦恼藏所缠。名如来藏。如是等胜鬘经中广说灭谛应知。又以何因得此灭谛如来法身。谓于见道及修道中无分别智三种日。相似相对法应知。偈言。彼真妙法日故。何等为三。一者日轮清净相似相对法。以远离一切烦恼垢故。偈言清净无尘垢故。二者显现一切色像相似相对法。以一切种一切智能照知故。偈言大智慧光明故。三者对治闇相似相对法。以起一切种智对治法故。偈言普照诸世间故。又以何者是所治法。所谓依取不实事相。虚妄分别念。生贪嗔痴结使烦恼。此明何义。愚痴凡夫依结使烦恼。取不实事相。念故起于贪心。依嗔恚故起于嗔心。依于无明虚妄念故起于痴心。又复依彼贪嗔痴等虚妄分别。取不实事相。念起邪念心。依邪念心起于结使。依于结使起贪嗔痴。以是义故。身口意等造作贪业嗔业痴业。依此业故。复有生生不断不绝。如是一切愚痴凡夫。依结使烦恼集起邪念。依邪念故起诸烦恼。依烦恼故起一切业。依业起生。如是此一切种诸烦恼染业染生染。愚痴凡夫不如实知。不如实见一实性界。如彼如实性。观察如实性而不取相。以不取相故。能见实性。如是实性诸佛如来平等证知。又不见如是虚妄法相。如实知见。如实有法真如法界。以见第一义谛故。如是二法不增不减。是故名为平等证智。是名一切种智。所治障法应如是知。以起真如智对治法故。彼所治法毕竟不复生起现前。偈言能破诸曀障觉观贪嗔痴一切烦恼等故。又此得灭谛如来法身。因于见道中及修道中无分别智。广说如摩诃般若波罗蜜等。修多罗中言。须菩提。真如如来真如平等无差别。如是等应知。已说法宝。次说僧宝

    究竟一乘宝性论僧宝品第四

论曰。依大乘法宝。有不退转菩萨僧宝。以是义故。次法宝后示现僧宝。依彼僧宝故。说四偈

  正觉正知者　　见一切众生
  清净无有我　　寂静真实际
  以能知于彼　　自性清净心
  见烦恼无实　　故离诸烦恼
  无障净智者　　如实见众生
  自性清净性　　佛法僧境界
  无阂净智眼　　见诸众生性
  遍无量境界　　故我今敬礼

此偈示现何义。偈言

  如实知内身　　以智见清净
  故名无上僧　　诸佛如来说

此偈明何义。偈言

  如实见众生　　寂静真法身
  以见性本净　　烦恼本来无

此偈明何义。以如实见本际。以来我空法空应知。偈言正觉正知者。见一切众生清净无有我。寂静真实际故。又彼如实知无始世来本际寂静无我无法。非灭烦恼证时始有。此明何义。此见自性清净法身。略说有二种法。何等为二。一者见性本来自性清净。二者见诸烦恼本来寂灭。偈言以能知于彼自性清净心见烦恼无实故离诸烦恼故。又自性清净心本来清净。又本来常为烦恼所染。此二种法于彼无漏真如。法界中善心不善心俱。更无第三心。如是义者难可觉知。是故圣者胜鬘经言。世尊。刹尼迦善心。非烦恼所染刹尼迦不善心。亦非烦恼所染。烦恼不触心。心不触烦恼。云何不触法而能得染心。世尊。然有烦恼有烦恼染心。自性清净心而有染者。难可了知。如是等圣者胜鬘经中广说。自性清净心及烦恼所染应知。又有二种修行。谓如实修行。及遍修行。难证知义。如实修行者。谓见众生自性清净佛性境界故。偈言无障净智者如实见众生自性清净性佛法身境界故。遍修行者。谓遍十地一切境界故。见一切众生有一切智故。又遍一切境界者。以遍一切境界。依出世间慧。见一切众生乃至畜生有如来藏应知。彼见一切众生有真如佛性。初地菩萨摩诃萨以遍证一切真如法界故。偈言无阂净智眼见诸众生性遍无量境界故。如是内身自觉知。彼无漏法界无障无阂。依于二法。一者如实修行。二者遍修行。此明何义。谓出世间如实内证真如法智。不共二乘凡夫人等应知。此明何义。菩萨摩诃萨出世间清净证智。略说有二种。胜声闻辟支佛证智。何等为二。一者无障。二者无碍。无障者。谓如实修行。见诸众生自性清净境界。故名无障。无阂者。谓遍修行。以如实知无边境界。故名无阂。此明何义。偈言

  如实知见道　　见清净佛智
  故不退圣人　　能作众生依

此偈明何义。又依初地菩萨摩诃萨证智。清净见道不退地乘。能作见彼无上菩提清净胜因应知。偈言如实知见道见清净佛智故。此初地证智。胜余菩萨摩诃萨布施持戒等波罗蜜功德。以是义故。菩萨摩诃萨依如实见真如证智。是故能与一切众生天龙八部声闻辟支佛等作归依处。偈言不退圣人能作众生依故

问曰。以何义故。不明归依声闻僧宝。答曰。菩萨僧宝功德无量。是故应供。以应供故。合应礼拜赞叹供养。声闻之人无如是义。以是义故。不明归依声闻僧宝。此明何义。偈言

  境界诸功德　　证智及涅槃
  诸地净无垢　　满足大慈悲
  生于如来家　　具足自在通
  果胜最无上　　是胜归依义

此偈明何义。略说菩萨十种胜义。过诸声闻辟支佛故。何等为十。一者观胜。二者功德胜。三者证智胜。四者涅槃胜。五者地胜。六者清净胜。七者平等心胜。八者生胜。九者神力胜。十者果胜。观胜者谓观真如境界。是名观胜偈言境界故。功德胜者。菩萨修行无厌足不同二乘少欲等。是名功德胜。偈言功德故。证智胜者。证二种无我。是名证智胜。偈言证智故。涅槃胜者。教化众生故。是名涅槃胜。偈言涅槃故。地胜者。所谓十地等。是名地胜。偈言诸地故。清净胜者。菩萨远离智障。是名清净胜。偈言净无垢故。平等心胜者。菩萨大悲遍覆。是名平等心胜。偈言满足大慈悲故。生胜者。诸菩萨生无生故。是名生胜。偈言生于如来家故。神力胜者。谓三昧自在神通等力胜。是名神力胜。偈言具足三昧自在通故。果胜者。究竟无上菩提故。是名果胜。偈言果胜最无上故。此明何义。有黠慧人。知诸菩萨功德无量修习菩提。无量无边广大功德。有大智慧慈悲圆满。为照知彼无量众生性行稠林。犹如初月。唯除诸佛如来满月。菩萨摩诃萨。知诸声闻乃至证得阿罗汉道。少智慧人无大悲心。为照自身。犹如星宿。既如是知。欲取如来大满月身。修菩提道。而当弃舍初月。菩萨起心礼拜供养。其余星宿声闻辟支佛者。无有是处。此复何义。明为利益一切众生初始发起菩提之心。诸菩萨等已能降伏不为利益他众生身为自利益修持无漏清净禁戒乃至证得阿罗汉果声闻之人。何况其余。得十自在等。无量无边功德菩萨摩诃萨。而同声闻辟支佛等少功德人。无有是处。以是义故。经中偈言

  若为自身故　　修行于禁戒
  远离大慈心　　舍破戒众生
  以为自身故　　护持禁戒财
  如是持戒者　　佛说非清净
  若为他人故　　修行于禁戒
  能利益众生　　如地水火风
  以为他众生　　起第一悲心
  是名净持戒　　余似非清净

问曰。依何等义为何等人。诸佛如来说此三宝。答曰。偈言

  依能调所证　　弟子为三乘
  信三供养等　　是故说三宝

此偈明何义。略说依三种义。为六种人故说三宝。何等为三。一者调御师。二者调御师法。三者调御师弟子。偈言依能调所证弟子故。六种人者。何等为六。一者大乘。二者中乘。三者小乘。四者信佛。五者信法。六者信僧。偈言为三乘信三供养等故。初释第一义。第一第四人归依两足中最胜第一尊佛。示现调御师大丈夫义故。偈言依能调故。为取佛菩提诸菩萨人故。偈言为大乘故。为信供养诸佛如来福田人故。偈言信佛供养故。以是义故。说立佛宝。偈言是故说佛宝故。已释第一义第一第四人。次释第二义。第二第五人归依离烦恼中最胜第一法。示现调御师所证功德法故。偈言依所证故。为自然知不依他知深因缘法辟支佛人故。偈言为中乘故。为信供养第一妙法福田人故。偈言信法供养故。以是义故。说立法宝。偈言是故说法宝故。已释第二义第二第五人。次释第三义。第三第六人归依诸众中最胜第一诸菩萨僧。示现调御师弟子于诸佛如来所说法中如实修行不相违义故。偈言依弟子故。为从他闻声闻人故偈言为小乘故。为信供养第一圣众福田人故。偈言信僧供养故。以是义故。说立僧宝。偈言是故说僧宝故。是名略说依三种义。为六种人故。诸佛如来说此三宝。偈言依能调所证弟子为三乘信三供养等是故说三宝故。又为可化众生令次第入。以是义故。依于世谛示现明说立三归依。此明何义。偈言

  可舍及虚妄　　无物及怖畏
  二种法及僧　　非究竟归依

此偈明何义。法有二种。何等为二。一所说法。二所证法。所说法者。谓如来说修多罗等名字章句身所摄故。彼所说法证道时灭如舍船筏。偈言可舍故。所证法者。复有二种。谓依因果二种差别。以依何法证何法故。此明何义。所谓有道有为相摄。若为有为相所摄者。彼法虚妄。偈言及虚妄故。若虚妄者彼法非实。若非实者彼非真谛。非真谛者即是无常。若无常者非可归依。又复若依彼声闻道所得灭谛。彼亦无物犹如灯灭。唯断少分诸烦恼苦。若如是者则是无物。若无物者云何为他之所归依。偈言无物故。僧者凡有三乘之人。三乘人中依声闻僧常有怖畏。常求归依诸佛如来求离世间。此是学人所应作者。未究竟故。犹进趣向阿耨多罗三藐三菩提故。所言怖畏者。云何怖畏。以阿罗汉虽尽有漏而不断一切烦恼习气。彼于一切有为行相。极怖畏心常现在前。是故圣者胜鬘经言。阿罗汉有恐怖。何以故。阿罗汉于一切无行怖畏想住。如人执剑欲来害己。是故阿罗汉无究竟乐。何以故。世尊依不求依如众生无依彼彼恐怖。以恐怖故则求归依。如是阿罗汉有怖畏。以恐怖故归依如来。故彼若如是有怖畏者。彼人毕竟为欲远离彼怖畏处求无畏处。以是义故依远离彼怖畏之处。名为学者当有所作欲得阿耨多罗三藐三菩提无畏之处。是故声闻法僧二宝是少分归依。非究竟归依。偈言二种法及僧非究竟归依故。此明何义。偈言

  众生归一处　　佛法身彼岸
  依佛身有法　　依法究竟僧

此偈明何义。如向所说。诸佛如来不生不灭寂静不二。离垢法身故。以唯一法身究竟清净处故。又三乘之人无有救者。无归依者。以唯有彼岸无始本际毕竟无尽。是可归依恒可归依。所谓唯是诸佛如来故。如是常恒清凉不变故可归依。圣者胜鬘经中广说应知。问曰。以何义故佛法众僧说名为宝。答曰。偈言

  真宝世希有　　明净及势力
  能庄严世间　　最上不变等

此偈明何义。所言宝者有六种相似。依彼六种相似相对法故。佛法众僧说名为宝。何等为六。一者世间难得相似相对法。以无善根诸众生等百千万劫不能得故。偈言真宝世希有故。二者无垢相似相对法。以离一切有漏法故。偈言明净故。三者威德相似相对法。以具足六通不可思议威德自在故。偈言势力故。四者庄严世间相似相对法。以能庄严出世间故。偈言能庄严世间故。五者胜妙相似相对法。以出世间法故。偈言最上故。六者不可改异相似相对法。以得无漏法世间八法不能动故。偈言不变故。问曰。依何等法有此三宝。而依此法得有世间。及出世间清净生起三宝。答曰。为彼义故说两行偈

  真如有杂垢　　及远离诸垢
  佛无量功德　　及佛所作业
  如是妙境界　　是诸佛所知
  依此妙法身　　出生于三宝

此偈示现何义。偈言

  如是三宝性　　唯诸佛境界
  以四法次第　　不可思议故

此偈明何义。真如有杂垢者。谓真如佛性未离诸烦恼所缠。如来藏故。及远离诸垢者。即彼如来藏转身到佛地得证法身。名如来法身故。佛无量功德者。即彼转身如来法身相中。所有出世间十力无畏等。一切诸功德无量无边故。及佛所作业者。即彼十力等。一切诸佛法自然常作无上佛业。常不休息常不舍离。常授诸菩萨记。彼处次第有四种法不可思议。是故名为如来境界。何等四处偈言

  染净相应处　　不染而清净
  不相舍离法　　自然无分别

此偈明何义。真如有杂垢者。同一时中有净有染。此处不可思议。不可思议者。信深因缘法声闻辟支佛于彼非境界故

是故圣者胜鬘经中。佛告胜鬘言。天女。自性清净心而有染污难可了知。有二法难可了知。谓自性清净心难可了知。彼心为烦恼所染亦难了知。天女。如此二法。汝及成就大法菩萨摩诃萨乃能听受。诸余声闻辟支佛等。唯依佛语信此二法故。偈言染净相应处故。及远离诸垢者。真如非本有染后时言清净。此处不可思议。是故经言心自性清净。自性清净心本来清净。如彼心本体。如来如是知。是故经言。如来一念心相应慧。得阿耨多罗三藐三菩提故。偈言不染而清净故。佛无量功德者。谓前际后际于一向染凡夫地中。常不舍离真如法身。一切诸佛法无异无差别。此处不可思议。是故经言。复次佛子。如来智慧无处不至。何以故。以于一切众生界中终无有一众生身中而不具足如来功德及智慧者。但众生颠倒。不知如来智远离颠倒起一切智无师智无碍智。佛子。譬如有一极大经卷。如一三千大千世界。大千世界一切所有无不记录。若与二千世界等者。悉记二千世界中事。若与小千世界等者。悉记小千世界中事。四天下等者。悉记一切四天下事。须弥山王等者。悉记须弥山王等事。地天宫等者。悉记地天宫殿中事。欲天宫等者。悉记欲天宫殿中事。色天宫等者。悉记色天宫殿中事。若与无色天宫等者。悉记一切无色界天宫殿中事。彼等三千大千世界极大经卷。在一极细小微尘内。一切微尘皆亦如是。时有一人出兴于世。智慧聪达具足成就清净天眼。见此经卷在微尘内。作如是念。云何如此广大经卷在微尘内而不饶益诸众生耶。我今应当勤作方便破彼微尘出此经卷饶益众生。作是念已

尔时彼人即作方便。破坏微尘出此经卷饶益众生。佛子。如来智慧。无相智慧。无阂智慧。具足在于众生身中。但愚痴众生颠倒想覆。不知不见不生信心。尔时如来以无障阂清净天眼。观察一切诸众生身。既观察已作如是言。奇哉奇哉。云何如来具足智慧。在于身中而不知见。我当方便教彼众生觉悟圣道。悉令永离一切妄想颠倒垢缚。令具足见如来智慧在其身内与佛无异。如来即时教彼众生修八圣道。舍离一切虚妄颠倒。离颠倒已见如来智。与如来等饶益众生故。偈言不相舍离法故。及佛所作业者。同一时一切处一切时。自然无分别。随顺众生心。随顺可化众生根性。不错不谬随顺作佛业。此处不可思议。是故经言。善男子。如来为令一切众生入佛法中故。无量如来业作有量说。善男子。如来所有实作业者。于彼一切世间众生。不可量不可数。不可思议不可知。不可以名字说。何以故。以难可得与前众生故。以于一切诸佛国土不休息故。以一切诸佛悉平等故。以过一切诸世间心所作事故。以无分别犹如虚空悉平等故。以无异无差别法性体故。如是等广说已。又说不净大毗琉璃摩尼宝珠譬喻言。善男子。汝依此譬喻。应知如来业不可思议故。平等遍至故。一切处不可呵故。三世平等故。不断绝三宝种故诸佛如来虽如是住不可思议业中。而不舍离虚空法身。虽不舍离虚空法身。而于众生随所应闻名字章句为之说法。虽为众生如是说法。而常远离一切众生心所念观。何以故。以如实知一切众生诸心行故。偈言自然无分别故。依此妙法身出生于三宝者。偈言

  所觉菩提法　　依菩提分知
  菩提分教化　　众生觉菩提
  初句为正因　　余三为净缘
  前二自利益　　后二利益他

此偈明何义。此四种句。总摄一切所知境界。此明何义。初一句者。谓所证法应知。以彼证法名为菩提。偈言所觉菩提法故。第二句。菩提依菩提分知者。以诸佛菩提功德能作佛菩提因故。偈言依菩提分知故。第三句菩提分教化者。以菩提分令他觉故。第四句众生觉菩提者。所化众生觉菩提故。此四种句次第不取相。依此行故。清净菩提出生三宝应知。偈言所觉菩提法依菩提。分知菩提分教化众生觉菩提故。以一句因三句缘故。如来得阿耨多罗三藐三菩提。以得菩提者。十力等诸佛如来法。三十二种诸佛如来作业。依如来业众生闻声。依彼法故。得清净因缘出生三宝应知。是故偈言初句为正因余三为净缘故

究竟一乘宝性论卷第二究竟一乘宝性论卷第三

        后魏中印度三藏勒那摩提译

    一切众生有如来藏品第五

论曰。自此已后余残论偈。次第依彼四句广差别说应知。此以何义。向前偈言

  真如有杂垢　　及远离诸垢
  佛无量功德　　及佛所作业
  如是妙境界　　是诸佛所知
  依此妙法身　　出生于三宝

此偈示现何义。如向所说。一切众生有如来藏。彼依何义故。如是说偈言

  佛法身遍满　　真如无差别
  皆实有佛性　　是故说常有

此偈明何义。有三种义。是故如来说一切时一切众生有如来藏。何等为三。一者如来法身遍在一切诸众生身。偈言佛法身遍满故。二者如来真如无差别。偈言真如无差别故。三者一切众生皆悉实有真如佛性。偈言皆实有佛性故。此三句义。自此下论依如来藏修多罗。我后时说应知。如偈本言

  一切众生界　　不离诸佛智
  以彼净无垢　　性体不二故
  依一切诸佛　　平等法性身
  知一切众生　　皆有如来藏
  体及因果业　　相应及以行
  时差别遍处　　不变无差别
  彼妙义次第　　第一真法性
  我如是略说　　汝今应善知

此偈示现何义。略说此偈有十种义。依此十种说第一义实智境界佛性差别应知。何等为十。一者体。二者因。三者果。四者业。五者相应。六者行。七者时差别。八者遍一切处。九者不变。十者无差别。初依体因故。说一偈

  自性常不染　　如宝空净水
  信法及般若　　三昧大悲等

此初半偈示现何义。偈言

  自在力不变　　思实体柔软
  宝空水功德　　相似相对法

此偈明何义。向说三种义。彼三种义。次第依于自相同相。如来法身三种清净功德。如如意宝珠虚空净水。相似相对法应知。此明何义。思者依如来法身。所思所修皆悉成就故。后半偈者示现何义。偈言

  有四种障碍　　谤法及着我
  怖畏世间苦　　舍离诸众生

此偈明何义。偈言

  阐提及外道　　声闻及自觉
  信等四种法　　清净因应知

此偈明何义。略说一切众生界中有三种众生。何等为三。一者求有。二者远离求有。三者不求彼二。求有有二种何等为二。一者谤解脱道无涅槃性。常求住世间不求证涅槃。二者于佛法中阐提同位。以谤大乘故。是故不增不减经言。舍利弗。若有比丘比丘尼优婆塞优婆夷。若起一见若起二见。诸佛如来非彼世尊。如是等人非我弟子。舍利弗。是人以起二见因缘。从闇入闇从冥入冥。我说是等名一阐提故。偈言谤法故。阐提故。远离求有者。亦有二种。何等为二。一者无求道方便。二者有求道方便。无求道方便者。亦有二种。何等为二。一者多种外道种种邪计。谓僧佉卫世师尼揵陀若提子等。无求道方便。二者于佛法中同外道行。虽信佛法而颠倒取。彼何者是。谓犊子等。见身中有我等。不信第一义谛。不信真如法空。佛说彼人无异外道。复有计空为有。以我相憍慢故。何以故。以如来为说空解脱门令得觉知。而彼人计唯空无实。为彼人故。宝积经中佛告迦叶。宁见计我如须弥山。而不用见憍慢众生计空为有。迦叶一切邪见解空得离。若见空为有。彼不可化令离世间故。偈言及着我故。及外道故。有方便求道者。亦有二种。何等为二。一者声闻。偈言怖畏世间苦故。声闻故。二者辟支佛。偈言舍离诸众生故。及自觉故。不求彼二者。所谓第一利根众生诸菩萨摩诃萨。何以故。以诸菩萨不求彼有如一阐提故。又亦不同无方便求道种种外道等故。又亦不同有方便求道声闻辟支佛等故。何以故。以诸菩萨见世间涅槃道平等故。以不住涅槃心故。以世间法不能染故。而修行世间行坚固慈悲涅槃心故。以善住根本清净法中故。又彼求有众生一阐提人。及佛法中同阐提位。名为邪定聚众生。又远离求有众生中。堕无方便求道众生。名为不定聚众生。又远离求有众生中。求离世间方便求道声闻辟支佛。及不求彼二。平等道智菩萨摩诃萨。名为正定聚众生。又除求于无障碍道大乘众生。余有四种众生。何等为四。一者阐提。二者外道。三者声闻。四者辟支佛。彼四众生有四种障故。不能证故。不能会故。不能见如来之性。何等为四。一者谤大乘法一阐提障。此障对治。谓诸菩萨摩诃萨信大乘故。偈言信法故。二者横计身中有我诸外道障。此障对治。谓诸菩萨摩诃萨修行般若波罗蜜故。偈言及般若故。三者怖畏世间诸苦声闻人障。此障对治。谓诸菩萨摩诃萨修行虚空藏首楞严等诸三昧故。偈言三昧故。四者背舍利益一切众生舍大悲心辟支佛障。此障对治。谓诸菩萨摩诃萨修行大悲。为利益众生故。偈言大悲故。是名四种障。障四种众生。为对治彼四种障故。诸菩萨摩诃萨信修行大乘等四种对治法。得无上清净法身。到第一彼岸。何以故。依此四种清净法界修习善法。此是诸佛随顺法子于佛家生。是故偈言

  大乘信为子　　般若以为母
  禅胎大悲乳　　诸佛如实子

偈言信等四种法清净因应知故。又依果业故。说一偈

  净我乐常等　　彼岸功德果
  厌苦求涅槃　　欲愿等诸业

此初半偈示现何义。偈言

  略说四句义　　四种颠倒法
  于法身中倒　　修行对治法

此偈明何义。彼信等四法。如来法身因此能清净。彼向说四种法。彼次第略说对治四颠倒。如来法身四种功德波罗蜜果应知。偈言略说四句义故。此明何义。谓于色等无常事中起于常想。于苦法中起于乐想。于无我中起于我想。于不净中起于净想。是等名为四种颠倒应知。偈言四种颠倒法故。为对治此四种颠倒故。有四种非颠倒法应知。何等为四。谓于色等无常事中生无常想苦想无我想不净想等。是名四种不颠倒对治应知。偈言修行对治法故。如是四种颠倒对治。依如来法身。复是颠倒应知。偈言于法身中倒故。对治此倒说有四种如来法身功德波罗蜜果。何等为四。所谓常波罗蜜乐波罗蜜我波罗蜜净波罗蜜应知。偈言修行对治法故。是故圣者胜鬘经言。世尊。凡夫众生于五阴法起颠倒想。谓无常常想。苦有乐想。无我我想。不净净想。世尊。一切阿罗汉辟支佛空智者。于一切智境界及如来法身本所不见。若有众生。信佛语故。于如来法身起常想乐想我想净想。世尊。彼诸众生非颠倒见。是名正见。何以故。唯如来法身。是常波罗蜜乐波罗蜜我波罗蜜净波罗蜜。世尊。若有众生于佛法身作是见者。是名正见。世尊。正见者是佛真子。从佛口生从正法生。从法化生得法余财。如是等故。又此四种如来法身功德波罗蜜从因向果。次第而说净我乐常应知。云何次第从因向果。谓诽谤大乘一阐提障。实无有净而心乐着取世间净。此障对治。谓诸菩萨摩诃萨信大乘修行证得第一净波罗蜜果应知。于五阴中见有神我诸外道障。实无神我而乐着取我。此障对治。谓诸菩萨摩诃萨修行般若波罗蜜。证得第一我波罗蜜果应知。此明何义。一切外道执着色等非真实事。以为有我。而彼外道取着我相。无如是我相虚妄颠倒。一切时无我。以是义故。说言如来如实智知一切法无我到第一彼岸。而如来无彼我无我相。何以故。以一切时如实见知不虚妄故。非颠倒故。此以何义。以即无我名为有我。即无我者。无彼外道虚妄神我。名有我者。如来有彼得自在我。是故偈言

  如清净真空　　得第一无我
  诸佛得净体　　是名得大身

此偈明何义。得大身者。谓如来得第一清净真如法身。彼是诸佛如来实我。以得自在体。以得第一清净身。偈言诸佛得净体故。以是义故。诸佛名得清净自在。偈言是名得大身故。以是义故。依于此义诸佛如来于无漏界中得为第一最自在我。又复即依如是义故。如来法身不名为有。以无我相无法相故。以是义故。不得言有。以如彼相如是无故。又复即依如是义故。如来法身不名为无。以唯有彼真如我体。是故不得言无法身。以如彼相如是有故。依此义故。诸外道问。如来死后为有身耶。为无身耶。有如是等。是故如来不记不答。诸声闻人畏世间苦。为对治彼畏世间苦。诸菩萨摩诃萨修行一切世间出世间诸三昧故。证得第一乐波罗蜜果应知。辟支佛人弃舍利益一切众生乐住寂静。为对治彼弃舍众生。诸菩萨摩诃萨修行大悲。住无限齐世间。常利益众生。证得第一常波罗蜜果应知。是名诸菩萨摩诃萨信及般若三昧大悲四种修行。如是次第得如来身净我乐常四种功德波罗蜜果应知。又复有义。依此四种如来法身名为广大。如法界究竟。如虚空尽未来际。此明何义。信修行大乘。是故诸佛如来常得清净法界到第一彼岸。是故说言广大如法界修行般若波罗蜜。是故诸佛如来成就虚空法身。以器世间究竟无我。以修行虚空藏等无量三昧。以是义故。于一切处一切法中皆得自在。是故说言。究竟如虚空。以修行大悲。于一切众生无限齐时。得慈悲心平等。是故说言尽未来际。又此四种波罗蜜等住无漏界中。声闻辟支佛得大力自在。菩萨为证如来功德法身第一彼岸有四种障。何等为四。一者缘相。二者因相。三者生相。四者坏相。缘相者。谓无明住地。即此无明住地与行作缘。如无明缘行。无明住地缘亦如是故。因相者。谓无明住地缘行。即此无明住地缘行为因。如行缘识。无漏业缘亦如是故。生相者。谓无明住地缘依无漏业因生三种意生身。如四种取。缘依有漏业因而生三界。三种意生身生亦如是故。坏相者谓三种意生身缘不可思议变易死如依生缘故有老死。三种意生身缘不可思议变易死亦如是故。又一切烦恼染皆依无明住地根本。以不离无明住地。声闻辟支佛大力菩萨。未得远离无明住地垢。是故未得究竟无为净波罗蜜。又即依彼无明住地缘。以细相戏论习未得永灭。是故未得究竟无为我波罗蜜。又即缘彼无明住地。有细相戏论集。因无漏业生于意阴未得永灭。是故未得究竟无为乐波罗蜜。以诸烦恼染业染生染未得永灭。是故未证究竟甘露如来法身。以未远离不可思议变易生死常未究竟。是故未得不变异体。是故未得究竟无为常波罗蜜。又如烦恼染。无明住地亦如是。如业染。无漏业行亦如是。如生染。三种意生身及不可思议变易死亦如是。如圣者胜鬘经言。世尊。譬如取缘有漏业因而生三有。如是世尊。依无明住地缘无漏业因。生阿罗汉辟支佛大力菩萨三种意生身。世尊。此三乘地三种意生身生。及无漏业生。依无明住地有缘非无缘。如是等胜鬘经中广说应知

复次以声闻辟支佛大力菩萨三种意生身中无净我乐常波罗蜜彼岸功德身。是故圣者胜鬘经言。唯如来法身是常波罗蜜乐波罗蜜我波罗蜜净波罗蜜。如是等故。此明何义。以如来法身自性清净离一切烦恼障智障习气故名为净。是故说言。唯如来法身是净波罗蜜。以得寂静第一自在我故。离无我戏论究竟寂静故名为我。是故说言。唯如来法身是我波罗蜜。以得远离意生阴身因故名为乐。是故说言。唯如来法身是乐波罗蜜。以世间涅槃平等证故。故名为常。是故说言。唯如来法身是常波罗蜜。又复略说有二种法。依此二法如来法身有净波罗蜜应知。何等为二。一者本来自性清净。以因相故。二者离垢清净。以胜相故。有二种法。依此二法如来法身有我波罗蜜应知。何等为二。一者远离诸外道边。以离虚妄我戏论故。二者远离诸声闻边。以离无我戏论故。有二种法。依此二法如来法身有乐波罗蜜应知。何等为二。一者远离一切苦。二者远离一切烦恼习气。此以何义。云何远离一切苦。以灭一切种苦故。以灭一切意生身故。云何远离烦恼习气。以证一切法故。有二种法。依此二法如来法身有常波罗蜜应知。何等为二。一者不灭一切诸有为行。以离断见边故。二者不取无为涅槃。以离常见边故。以是义故。圣者胜鬘经中说言。世尊。见诸行无常。是断见非正见见涅槃常。是常见非正见。妄想见故。作如是见故。以是义故。依如是向说法界法门第一义谛。说即世间法名为涅槃。以此二法不分别故。以证不住世间涅槃故。是故偈言

  无分别之人　　不分别世间
  不分别涅槃　　涅槃有平等

后半偈者示现何义偈言

  若无佛性者　　不得厌诸苦
  不求涅槃乐　　亦不欲不愿

以是义故。圣者胜鬘经言。世尊。若无如来藏者。不得厌苦乐求涅槃。亦无欲涅槃亦不愿求。如是等此明何义。略说佛性清净正因于不定聚众生能作二种业。何等为二。一者依见世间种种苦恼。厌诸苦故。生心欲离诸世间中一切苦恼。偈言若无佛性者不得厌诸苦故。二者依见涅槃乐悕寂乐故。生求心欲心愿心。偈言若无佛性者不求涅槃乐亦不欲不愿故。又欲者。求涅槃故。求者。悕涅槃故。悕者。于悕求法中不怯弱故。欲得者。于所求法中方便追求故。及咨问故愿者。所期法中。所期法者。心心相行。是故偈言

  见苦果乐果　　此依性而有
  若无佛性者　　不起如是心

此偈明何义。凡所有见世间苦果者。凡所有见涅槃乐果者。此二种法。善根众生。有一切依因真如佛性。非离佛性无因缘故起如是心。偈言见苦果乐果。此依性而有故。若无因缘生如是心者。一阐提等无涅槃性。应发菩提心。偈言若无佛性者不起如是心故。以性未离一切客尘烦恼诸垢。于三乘中未曾修习一乘信心。又未亲近善知识等。亦未修习亲近善知识因缘。是故华严性起中言。次有乃至邪见聚等。众生身中皆有如来日轮光照。作彼众生利益。作未来因善根。增长诸白法故。向说一阐提常不入涅槃。无涅槃性者。此义云何。为欲示现谤大乘因故。此明何义。为欲回转诽谤大乘心不求大乘心故。依无量时故。如是说。以彼实有清净性故。不得说言彼常毕竟无清净性。又依相应义故。说一偈

  大海器宝水　　无量不可尽
  如灯明触色　　性功德如是

此初半偈示现何义。偈言

  佛法身慧定　　悲摄众生性
  海珍宝水等　　相似相对法

此偈明何义。以有三处故。次第有三种大海相似相对法。于如来性中依因毕竟成就相应义应知。何等三处。一者法身清净因。二者集佛智因。三者得如来大悲因。法身清净因者。信修行大乘器相似相对法。以彼无量不可尽故。偈言佛法身故。海相似相对法故。集佛智因者。般若三昧珍宝相似相对法。偈言慧定故。珍宝相似相对法故。得如来大悲因者。大慈悲心水相似相对法。偈言悲摄众生性故。水相似相对法故。又修行智慧三昧门宝相似相对法。以彼无分别不可思议有大势力功德相应故。又修行菩萨大悲水相似相对法。以于一切众生柔软大悲得一味等味相行故。如是彼三种法。此三种因和合。毕竟不相舍离。故名相应。后半偈者。示现何义。偈言

  通智及无垢　　不离于真如
  如灯明暖色　　无垢界相似

此偈明何义。有三处次第三种灯相似相对法。于如来法界中依果相应义应知。何等三处。一者通。二者知漏尽智。三者漏尽。此以何义。通者。有五通光明相似相对法。以受用事能散灭。彼与智相违。所治闇法能治相似相对法故。偈言通故。明故。知漏尽智者。无漏智暖相似相对法。以能烧业烦恼无有余残。能烧相似相对法故。偈言智故暖故。漏尽者。转身漏尽色相似相对法。以常无垢清净光明具足相无垢相似相对法故。偈言无垢故色故。又无垢者。以离烦恼障故。清净者。以离智障故。光明者。如自性清净体。彼二是客尘烦恼。如是略说六种无漏智。离烦恼无学身所摄法。于无漏法界中彼此迭共不相舍离。不差别法界平等毕竟。名相应义应知。又依行义故。说一偈

  见实者说言　　凡夫圣人佛
  众生如来藏　　真如无差别

此偈示现何义。偈言

  凡夫心颠倒　　见实异于彼
  如实不颠倒　　诸佛离戏论

此偈明何义。向明如来法界中一切法。真如清净明同相。依般若波罗蜜无分别智法门等。为诸菩萨摩诃萨说。此以何义。略明依三种人。何等为三。一者不实见凡夫。二者实见圣人。三者毕竟成就如来法身。是名三种行应知。应云何知。谓取颠倒。离颠倒。离戏论。如是次第。此以何义。取颠倒者。谓诸凡夫三种虚妄想心见故。偈言凡夫心颠倒故。离颠倒者。以圣人远离虚妄想心见故。偈言见实异于彼故。离戏论者。正离颠倒及诸戏论。以烦恼障智障及烦恼习气诸佛如来根本永尽故。偈言如实不颠倒诸佛离戏论故。自此以下即依此行。余四种义广差别说应知。又复即依彼三种人依时差别故。说一偈

  有不净有净　　及以善净等
  如是次第说　　众生菩萨佛

此偈示现何义。偈言

  体等六句义　　略明法性体
  次第三时中　　说三种名字

此偈明何义。谓向所明无漏法性。如来广说种种法门。彼诸法门略说依于六种句义。所谓摄聚体因果业相应及行偈言体等六句义略明法性体故。于三时中次第依彼三种名字毕竟应知。偈言次第三时中说三种名字故。此以何义。谓不净时名为众生。偈言有不净故。不净净时名为菩萨。偈言有净故。于善净时名为如来。偈言及以善净故以是义故。不增不减经言。舍利弗。即此法身过于恒沙。无量烦恼所缠。从无始来随顺世间生死涛波去来生退名为众生。舍利弗。即此法身厌离世间生死苦恼。舍一切欲。行十波罗蜜摄八万四千法门。修菩提行。名为菩萨。舍利弗。即此法身得离一切烦恼使缠。过一切苦。离一切烦恼垢得净得清净。得住彼岸清净法中。到一切众生所观之地。于一切境界中更无胜者。离一切障离一切碍。于一切法中得自在力。名为如来应正遍知故。偈言如是次第说众生菩萨佛故。自此以下即依彼三时。明如来法性遍一切处故。说一偈

  如空遍一切　　而空无分别
  自性无垢心　　亦遍无分别

此偈示现何义。偈言

  过功德毕竟　　遍至及同相
  下中胜众生　　如虚空中色

此偈明何义。所有凡夫圣人诸佛如来。自性清净心平等无分别。彼清净心于三时中次第于过失时。于功德时。于功德清净毕竟时。同相无差别。犹如虚空在瓦银金三种器中平等无异无差别一切时有。以是义故。经中说有三时次第。如不增不减经言。舍利弗。不离众生界有法身。不离法身有众生界。众生界即法身。法身即众生界。舍利弗。此二法者义一名异故。自此已下。即依此三时。明如来法性遍至一切处。依染净时不变不异。有十五偈。此等诸偈略说要义应知偈言

  诸过客尘来　　性功德相应
  真法体不变　　如本后亦尔

此偈明何义。偈言

  十一偈及二　　次第不净时
  烦恼客尘过　　第十四十五
  于善净时中　　过恒沙佛法
  不离脱思议　　佛自性功德
  本际中间际　　及以后际等
  如来真如性　　体不变不异

初依不净时不变不异。十一偈者

  如虚空遍至　　体细尘不染
  佛性遍众生　　诸烦恼不染
  如一切世间　　依虚空生灭
  依于无漏界　　有诸根生灭
  火不烧虚空　　若烧无是处
  如是老病死　　不能烧佛性
  地依于水住　　水复依于风
  风依于虚空　　空不依地等
  如是阴界根　　住烦恼业中
  诸烦恼业等　　住不善思惟
  不善思惟行　　住清净心中
  自性清净心　　不住彼诸法
  阴入界如地　　烦恼业如水
  不正念如风　　净心界如空
  依性起邪念　　念起烦恼业
  依因烦恼业　　能起阴入界
  依止于五阴　　界入等诸法
  有诸根生灭　　如世界成坏
  净心如虚空　　无因复无缘
  及无和合义　　亦无生住灭
  如虚空净心　　常明元转变
  为虚妄分别　　客尘烦恼染

此虚空譬喻偈示现何义。明如来性。依不净时法体不变。偈言

  不正思惟风　　诸业烦恼水
  自性心虚空　　不为彼二生
  自性清净心　　其相如虚空
  邪念思惟风　　所不能散坏
  诸业烦恼水　　所不能湿烂
  老病死炽火　　所不能烧燃

此偈明何义。如依邪念风轮起业烦恼水聚。依业烦恼水聚。生阴界入世间。而自性心虚空不生不起。偈言不正思惟风诸业烦恼水自性心虚空不为彼二生故。如是依邪念风灾。业行烦恼水灾。老病死等火灾。吹浸烧坏阴入界世间。而自性清净心虚空常住不坏。如是于不净时中器世间相似相对法。诸烦恼染业染生染有集有灭。诸佛如来无为之性。犹如虚空不生不灭。常不变易示现法体。此自性清净法门虚空譬喻。如陀罗尼自在王菩萨修多罗中广说。应知彼经中言。诸善男子。烦恼本无体。真性本明净。一切烦恼羸薄。毗婆舍那有大势力。一切烦恼客尘。自性清净心根本。一切诸烦恼虚妄分别。自性清净心如实不分别。诸佛子。譬如大地依水而住。水依风住风依空住。而彼虚空无依住处。诸善男子。如是四大地大水大风大空大。此四大中唯虚空大以为最胜。以为大力。以为坚固。以为不动。以为不作。以为不散。不生不灭自然而住。诸善男子。彼三种大生灭相应。无实体性刹那不住。诸佛子。此三种大变异无常。诸佛子。而虚空界常不变异。诸佛子。如是阴界入依业烦恼住。诸烦恼业依不正思惟住。不正思惟依于佛性自性清净心住。以是义故。经中说言。自性清净心客尘烦恼染。诸善男子。所有邪念。所有烦恼业。所有阴界入。如是诸法从于因缘和合而生。以诸因缘坏散而灭。诸善男子。彼自性清净心无因无缘故。无和合不生不灭。诸善男子。如虚空界。自性清净心亦复如是。如风大界。不正思惟亦复如是。如水大海。诸业烦恼亦复如是。如地大界。阴界入等亦复如是。是故说言。一切诸法皆无根本。皆无坚实。无住无住本。根本清净。无根本故。已说不净时中依无分别相。自性清净心虚空界相似相对法。已说依彼起不正念风界相似相对法。已说依不正念诸业烦恼因相水界相似相对法。已说依彼生阴界入果相转变地相似相对法。未说彼焚烧死病老等诸过患相火相似相对法。是故次说偈言

  有三火次第　　劫烧人地狱
  能作种种苦　　能熟诸行根

此偈明何义明此三法。老病死火。于不净时中不能变异彼如来藏。是故圣者胜鬘经言。世尊。生死者。依世谛故说有生死。世尊。死者诸根坏。世尊。生者新诸根起。世尊而如来藏不生不死不老不变。何以故。世尊。如来藏者。离有为相境界。世尊如来藏者。常恒清凉不变故。已说依不净时不变不异

次说依净不净时不变不异故。说二偈

  菩萨摩诃萨　　如实知佛性
  不生亦不灭　　复无老病等
  菩萨如是知　　得离于生死
  怜愍众生故　　示现有生灭

此偈示现何义。偈言

  老病死诸苦　　圣人永灭尽
  依业烦恼生　　诸菩萨无彼

此偈明何义。明此老病死等苦火于不净时依业烦恼本生。如世间火依薪本生。以诸菩萨得生意生身。于净不净时毕竟永灭尽。以是义故。诸业烦恼等常不能烧燃。而依慈悲力故。示现生老病死。而远离生等。以见如实故。以是义故。诸菩萨摩诃萨依善根结使生。非依业烦恼结使生。以依心自在力生。依大悲力现于三界。示现生示现老示现病示现死。而彼无有生老病死诸苦等法。以如实见真如佛性不生不灭。是名不净净时。如修多罗中依爱无漏业根本烦恼广说应知。如如来于大海慧菩萨经中说言。大海慧。何者能住世间善根相应烦恼。所谓集诸善根无有厌足故。以心愿生摄取诸有故。求见一切诸佛如来故。教化一切众生心不疲惓故。摄取一切诸佛妙法故。于诸众生常作利益故。常不舍离乐贪诸法结使故。常不舍离诸波罗蜜结使故。大海慧。是名诸菩萨摩诃萨世间善根相应烦恼。依此烦恼诸菩萨摩诃萨生于三界受种种苦。不为三界烦恼过患之所染污。大海慧菩萨白佛言。世尊。此诸善根以何义故说名烦恼。佛告大海慧菩萨言。大海慧。如是烦恼。诸菩萨摩诃萨能生三界受种种苦。依此烦恼故。有三界。非染烦恼三界中生。大海慧。菩萨以方便智力。依善根力故。心生三界。是故名为善根相应烦恼而生三界非染心生。大海慧。譬如长者若居士等唯有一子。甚爱甚念见者欢喜。而彼一子依愚痴心因戏乐故。堕在极深粪厕井中。时彼父母及诸亲属。见彼一子堕在大厕深坑粪中。见已歔欷悲泣啼哭。而不能入彼极深厕粪屎器中而出其子

尔时彼处众中更有一长者子。或一居士子。见彼小儿堕在深厕粪屎井中。见已疾疾生一子想。生爱念心不起恶心。即入深厕粪屎井中出彼一子。大海慧。为显彼义说此譬喻。大海慧。何者彼义。大海慧。言极深井粪屎坑者。名为三界。大海慧。言一子者。一切众生。诸菩萨等于一切众生生一子想。大海慧。尔时父母及诸亲者。名为声闻辟支佛人。以二乘人见诸众生堕在世间极大深坑粪屎井中。既见彼已悲泣啼哭。而不能拔彼诸众生。大海慧。彼时更有一长者子一居士子者。名为菩萨摩诃萨。离诸烦恼清净无垢。以离垢心现见无为真如法界。以自在心现生三界。为教化彼诸众生故。大海慧。是名菩萨摩诃萨大悲。毕竟远离诸有。毕竟远离诸缚。而回生于三界有中。以依方便般若力故。诸烦恼火不能焚烧。欲令一切诸众生等远离诸缚。而为说法。大海慧。我今说此修多罗句。依诸菩萨心。为利益一切众生。得自在力而生三有。依诸善根慈悲心力。依于方便般若力故。是名示现净不净时。又菩萨摩诃萨以如实智知如来法身不生不灭故。得如是菩萨摩诃萨功德法体。此修多罗句向前已说。自下次说大毗琉璃摩尼宝喻。佛言。大海慧。譬如无价大毗琉璃摩尼宝珠。善治善净善光明。堕在泥中住一千年。彼摩尼宝经千年后乃出彼泥。出已水洗。洗已极净。极净洗已。然后极明。即不失本清净无垢摩尼宝体。大海慧。菩萨摩诃萨亦复如是。如实知见一切众生自性清净光明净心而为客尘烦恼所染。大海慧。诸菩萨等生如是心。彼诸烦恼不染众生自性净心。是诸烦恼客尘虚妄分别心起而彼诸菩萨复生是心。我今毕竟令诸众生远离客尘诸烦恼垢。为之说法。如是菩萨不生怯弱心。转于一切众生生增上力。我要毕竟令得解脱。菩萨尔时复生是心。此诸烦恼无有少体。菩萨尔时复生是心。诸烦恼无体。诸烦恼羸薄。是诸烦恼无有住处。如是菩萨如实知诸烦恼虚妄分别而有。依邪见念而有。以正见者。诸烦恼垢不能得起。菩萨尔时复生是心。我应如实观诸烦恼更不复生。以不生烦恼故。生诸善法。菩萨尔时复生是心。我若自起诸烦恼者。云何而得为诸烦恼所缚众生说法令离诸烦恼缚。菩萨尔时复生是心。以我不着诸烦恼故。是故得为诸烦恼缚众生说法。我应修行诸波罗蜜。结使烦恼相应善根。为欲教化诸众生故。又复云何名为世间。以三界相似镜像法故。此明何义。依无漏法界中有三种意生身应知。彼因无漏善根所作名为世间。以离有漏诸业烦恼所作世间法故。亦名涅槃。依此义故。圣者胜鬘经言。世尊。有有为世间。有无为世间。世尊。有有为涅槃。有无为涅槃故。又有为无为心心数法相应法故。故说名为净不净时。此义于第六菩萨现前地说。彼诸漏尽无障碍般若波罗蜜解脱现前修行大悲。以为救护一切众生故。不取证。如宝鬘经中依漏尽故说入城喻。彼经中言。善男子。譬如有城。纵广正等各一由旬。多有诸门路崄黑闇甚可怖畏。有人入者多受安乐。复有一人。唯有一子爱念甚重。遥闻彼城如是快乐。即便舍子欲往入城。是人方便得过崄道到彼城门。一足已入一足未举。即念其子寻作是念。我唯一子。来时云何竟不与俱。谁能养护令离众苦。即舍乐城还至子所。善男子。菩萨摩诃萨亦复如是。为怜愍故修集五通。既修集已垂得尽漏而不取证。何以故。愍众生故舍漏尽通。乃至行于凡夫地中。善男子。城者喻于大般涅槃。多诸门者。喻于八万诸三昧门。路崄难者。喻诸魔业。到城门者。喻于五通。一足入者。喻于智慧。一足未入者。喻诸菩萨未证解脱。言一子者。喻于五道一切众生。顾念子者。喻大悲心。还子所者。喻调众生。能得解脱而不证者。即是方便。善男子。菩萨摩诃萨大慈大悲不可思议。如是善男子。菩萨摩诃萨。大方便力。发大精进起坚固心。修行禅定得证五通。如是菩萨依禅通业善修心净无漏灭尽定现前。如是菩萨即得生于大悲之心。为救一切诸众生故。现前无漏智通。而回转不取寂灭涅槃。以为教化诸众生故。回取世间。乃至示现凡夫人地。于第四菩萨焰地中。为自利益善起精进。为利益他。善起坚固心漏尽现前。于第五菩萨难胜地中。依止五通自利利他。善熟心行无漏灭尽定现前。是故于第六菩萨地中。无障碍般若波罗蜜起漏尽现前。是故于第六菩萨现前地中。得漏尽自在。说名清净。是菩萨如是自身正修行。教化众生令置彼处。得大慈悲心。于颠倒众生生救护心。不着寂灭涅槃。善作彼方便现前世间门。为众生故现前涅槃门。为菩提分满足故。修行四禅回生欲界。以为利益地狱畜生饿鬼凡夫种种众生。示现诸身。以得自在故。已说依不净净时不变不异。次说依善净时不变不异故。说二偈

  佛身不变异　　以得无尽法
  众生所归依　　以无边际故
  常住不二法　　以离妄分别
  恒不热不作　　清净心力故

此偈示现何义。偈言

  不生及不死　　不病亦不老
  以常恒清凉　　及不变等故

此偈明何义。偈言

  以常故不生　　离意生身故
  以恒故不死　　离不思议退
  清凉故不病　　无烦恼习故
  不变故不老　　无无漏行故

此偈明何义。明如来性于佛地时无垢清净光明常住自性清净。以本际来常故不生。以离意生身故。以未来际恒故不死。以离不可思议变易死故。以本后际来清凉故不病。以离无明住地所摄故。若如是者。不堕三世。彼则不变。是故不老。以离无漏业回转故。又复偈言

  有二复有二　　复有二二句
  次第如常等　　无漏境界中

此偈明何义。常恒清凉及不变等。此四种句。于无漏法界中次第一一句二二本二二释义差别。如不增不减修多罗中说言。舍利弗。如来法身常。以不异法故。以不尽法故。舍利弗。如来法身恒。以常可归依故。以未来际平等故。舍利弗。如来法身清凉。以不二法故。以无分别法故。舍利弗。如来法身不变。以非灭法故。以非作法故

已说不变异。次说无差别。无差别者。即依此善净时本际以来毕竟究竟自体相善净如来藏无差别故。说一偈

  法身及如来　　圣谛与涅槃
  功德不相离　　如光不离日

此初半偈示现何义。偈言

  略明法身等　　义一而名异
  依无漏界中　　四种义差别

此偈明何义。略说于无漏法界中依如来藏有四种义。依四种义有四种名应知。何等四义。偈言

  佛法不相离　　及彼真如性
  法体不虚妄　　自性本来净

此偈明何义。佛法不相离者。依此义故。圣者胜鬘经言。世尊。不空如来藏。过于恒沙不离不脱。不思议佛法故。及彼真如性者。依此义故。六根聚经言。世尊。六根如是。从无始来毕竟究竟诸法体故。法体不虚妄者。依此义故。经中说言。世尊。又第一义谛者。谓不虚妄涅槃是也。何以故。世尊。彼性本际来常以法体不变故。自性本来净者。依此义故。经中佛告文殊师利。如来应正遍知本际以来入涅槃故。又复依此四义。次第有四种名。何等为四。一者法身。二者如来。三者第一义谛。四者涅槃。以是义故。不增不减经言。舍利弗言。如来藏者。即是法身故。又复圣者胜鬘经言。世尊。不离法身有如来藏。世尊。不离如来藏有法身。世尊。依一苦灭谛说名如来藏。世尊。如是说如来法身无量无边功德。世尊言。涅槃者。即是如来法身故。后半偈者。示现何义。偈言

  觉一切种智　　离一切习气
  佛及涅槃体　　不离第一义

此四种名。于如来法身无漏界中一味一义不相舍离。是故虽复有四种名。而彼四义不离一法门。不离一法体。此以何义所证一切法。觉一切智。及离一切智障烦恼障习气。此二种法于无漏法界中不异不差别不断不相离。以是义故。大般涅槃经中偈言

  无量种功德　　一切不思议
  不差别解脱　　解脱即如来

以是义故。圣者胜鬘经言。世尊。言声闻辟支佛得涅槃者。是佛方便故。此明何义。言声闻辟支佛有涅槃者。此是诸佛如来方便。见诸众生于长道旷野远行疲惓。恐有退转。为止息故造作化城。如来如是于一切法中得大自在大方便故。故明如是义。世尊如来应正遍知证平等涅槃。一切功德无量无边不可思议清净毕竟究竟。此明何义。依四种义。毕竟功德诸佛如来无差别。涅槃相无上果中佛及涅槃。一切功德不相舍离。若离佛地果中证智。更无余人有涅槃法。示现如是义。依一切种智。于诸佛如来无漏法界中譬喻示现。此明何义。宝鬘经中画师譬喻。示现具足一切功德应知偈言

  如种种画师　　所知各差别
  彼一人知分　　第二人不知
  有自在国王　　敕诸画师言
  于彼摽画处　　具足作我身
  国中诸画师　　一切皆下手
  若不阙一人　　乃成国王像
  画师受敕已　　画作国王像
  彼诸画师中　　一人行不在
  由无彼一人　　国王像不成
  以其不满足　　一切身分故
  所言画师者　　喻檀戒等行
  言国王像者　　示一切种智
  一人不在者　　示现少一行
  王像不成者　　空智不具足

此偈明何义。以是义故。宝鬘经言。善男子。谛听谛听。我今为汝说此譬喻。善男子。譬如三千大千世界所有众生悉善知画。其中或有善能泥涂。或能磨彩。或晓画身不晓手足。或晓手足不晓面目。时有国王。以一张叠与是诸人而告之言。凡能画者皆悉聚集。于此叠上画吾身像。尔时诸人悉来集聚。随其所能而共作之。有一画师。以缘事故竟不得来。诸人画已持共上王。善男子。可言诸人悉集作不。不也。世尊。善男子。我说此喻其义未显。善男子。一人不来。故不得言一切集作。亦不得言像已成就。佛法行者亦复如是。若有一行不成就者。则不名具足如来正法。是故要当具足诸行名为成就无上菩提故。又此檀等诸波罗蜜一一差别。唯是如来所知境界。如来知彼种种差别无量无边应知。以彼算数自在力等不能思议故。以对治彼悭等诸垢。是故得成清净檀等诸波罗蜜。又以修行一切种一切空智及种种三昧门。于第八菩萨不动地中不分别一切菩萨地。无间无隔自然依止道智。修行得无生法忍。成就具足如来无漏戒。成就一切功德。于第九菩萨善慧地中依阿僧祇三昧陀罗尼海门。摄取无量无边诸佛之法依止。解一切众生根智。成就无量无边功德空智。得无生法忍。于第十菩萨法云地中依止一切如来现前蜜智智。成就无量无边功德聚。得无生空法忍。次后得诸三昧。断一切烦恼障智障。依止诸解脱门智。成就清净彼岸功德。具足得一切种一切空智。以如是等四种地智中非声闻辟支佛地。以彼声闻辟支佛等去之甚远。以是义故。说彼四种成就不差别涅槃界。是故偈言

  慧智及解脱　　不离法界体
  无差涅槃界　　日相似相对

此偈明何义。以何等慧以何等智。以何等解脱。彼三不离法界实体。明彼四种功德成就无差别涅槃界。偈言无差别涅槃界故。为彼四种义次第故。有四种相似相对法应知。何等为四。一者佛法身中依出世间无分别慧。能破第一无明黑闇。彼光明照相似相对法应知。偈言慧故。日相似相对故。二者依智故。得一切智智知一切种。照一切事放光明罗网。相似相对法应知。偈言智故。日相似相对故。三者依止彼二自性清净心解脱。无垢离垢光明轮清净。相似相对法应知。偈言解脱故。日相似相对法故。四者即此三种不离法界。不离实体。不相舍离。相似相对法应知。偈言不离法界体故。日相似相对故。是故偈言

  不证诸佛身　　涅槃不可得
  如弃舍光明　　日不可得见

此偈明何义。以如向说无漏法界中无始世界来诸佛法身中无漏诸法一切功德不相舍离。以是义故。远离如来无障无碍。法身智慧离一切障。涅槃体相不可得见。不可得证。如离日光明无日轮可见。以是义故。圣者胜鬘经言。法无优劣故得涅槃。知诸法平等智故得涅槃。平等智故得涅槃。平等解脱故得涅槃。平等解脱知见故得涅槃。是故世尊说。涅槃界一味等味。谓明解脱一味故

究竟一乘宝性论卷第三究竟一乘宝性论卷第四

        后魏中印度三藏勒那摩提译

    无量烦恼所缠品第六

论曰。偈言

  向说如来藏　　十种义示现
  次说烦恼缠　　以九种譬喻

此偈明何义。向依如来藏说无始世界来彼法恒常住法体不转变。明如来藏有十种义。自此以下依无始世界来烦恼藏所缠。说无始世界来自性清净心具足法身。以九种譬喻明如来藏。过于恒沙烦恼藏所缠。如修多罗说应知。九种譬喻者。如偈说言

  萎华中诸佛　　众蜂中美蜜
  皮糩等中实　　粪秽中真金
  地中珍宝藏　　诸果子中芽
  朽故弊坏衣　　缠裹真金像
  贫贱丑陋女　　怀转轮圣王
  焦黑泥模中　　有上妙宝像
  众生贪嗔痴　　妄想烦恼等
  尘劳诸垢中　　皆有如来藏

此偈示现何义。自此以下依此略说四偈句义。余残譬喻五十四偈广说应知。此四行偈总略说。彼广偈中义应知。又依彼义。略说二偈

  华蜂糩粪秽　　地果故坏衣
  贫贱女泥模　　烦恼垢相似
  佛蜜实真金　　宝牙金像王
  上妙宝像等　　如来藏相似

此偈示现何义。偈言

  华蜂等诸喻　　明众生身中
  无始世界来　　有诸烦恼垢
  佛蜜等诸喻　　明众生身中
  无始来具足　　自性无垢体

又复略说此如来藏。修多罗中明一切众生界从无始世界来客尘烦恼染心。从无始世界来净妙法身如来藏不相舍离。是故经言。依自虚妄染心众生染。依自性清净心众生净。云何自心染。依自心染有九种喻。谓萎华等应知。偈言

  贪嗔痴相续　　及结使熏集
  见修道不净　　及净地有垢
  萎华等诸喻　　说九种相对
  无边烦恼缠　　故说差别相

此偈明何义。略说有九种烦恼。于自性清净如来法身界中。如萎华等九种譬喻。于诸佛等常外客相诸烦恼垢亦复如是。于真如佛性常客尘相。何等以为九种烦恼。一者贪使烦恼。二者嗔使烦恼。三者痴使烦恼。四者增上贪嗔痴结使烦恼。五者无明住地所摄烦恼。六者见道所断烦恼。七者修道所断烦恼。八者不净地所摄烦恼。九者净地所摄烦恼。此如是等九种烦恼。以彼九种譬喻示现应知。此明何义。世间贪等众生身中所摄烦恼。能作不动地业所缘。成就色界无色界果报。出世间智能断。名为贪嗔痴使烦恼。偈言贪嗔痴相续故。又增上贪嗔痴众生身中所摄烦恼。能作福业罪业行缘。但能成就欲界果报。唯有不净观智能断。名为增上贪嗔痴等结使烦恼。偈言及结使故。又阿罗汉身中所摄烦恼。能作无漏诸业行缘。能生无垢意生身果报。唯如来菩提智能断。名为无明住地所摄烦恼。偈言熏集故。又有二种学人。何等为二。一者凡夫。二者圣人。凡夫身中所摄烦恼。初出世间心见出世间法智能断。名为见道所断烦恼。偈言见道故。圣人身中所摄烦恼。如先见出世间法修道智能断。名为修道所断烦恼。偈言修道故。又不究竟菩萨。谓从初地乃至七地所摄烦恼。七住地中所对治法。八地已上三住地中。修道智能断。名为不净地所摄烦恼。偈言不净故。又毕竟究竟菩萨身中所摄烦恼。八地已上三地修道智所对治法。金刚三昧智能断。名为净地所摄烦恼。偈言及净地有垢故。是名略说九种烦恼次第。萎华等九种譬喻。我已广说应知。又复即此九种烦恼。依八万四千众生行故。有八万四千烦恼差别。如如来智无量无边故。有如是无量无边烦恼缠如来藏故。言无量烦恼藏所缠如来藏。是故偈言

  愚痴及罗汉　　诸学及大智
  次第四种垢　　及一二复二
  如是次第说　　四凡一圣人
  二学二大智　　名为不净地

此偈明何义。此九种譬喻。于无漏界中如是次第四种譬喻。及第五譬喻。后时二二烦恼诸垢依。烦恼垢染故。言不清净。又复云何知此九种贪等烦恼。于萎华等九种譬喻相似相对。又云何知如来藏于诸佛等九种譬喻相似相对。偈言

  依佛神力故　　有彼众妙华
  初荣时则爱　　后萎变不爱
  如华依荣悴　　有爱有不爱
  贪烦恼亦尔　　初乐后不乐
  群蜂为成蜜　　嗔心啮诸花
  嗔恚心起时　　生种种苦恼
  稻等内坚实　　外为皮糩覆
  如是痴心缠　　不见内坚实
  犹如臭秽粪　　智观贪亦尔
  起欲心诸相　　结使如秽粪
  譬如彼地中　　种种珍宝藏
  众生无天眼　　是故不能见
  如是自在智　　为无明地覆
  众生无智眼　　是故不能见
  如子离皮糩　　次第生芽等
  见道断烦恼　　次第生诸地
  以害身见等　　摄取妙圣道
  修道断烦恼　　故说弊坏衣
  七地中诸垢　　犹如胎所缠
  远离胎藏智　　无分别淳熟
  三地知诸垢　　如泥模所泥
  大智诸菩萨　　金刚定智断
  萎华至泥模　　如是九种喻
  示贪嗔痴等　　九种烦恼垢
  垢中如来藏　　佛等相对法
  如是九种义　　以三种体摄

此偈明何义。谓依法身自性清净心如来藏等三种实体。有诸佛等九种譬喻相似相对法应知。三种实体者偈言

  法身及真如　　如来性实体
  三种及一种　　五种喻示现

此偈明何义。初三种喻示现如来法身应知。三种譬喻者。所谓诸佛美蜜坚固。示现法身。偈言法身故。一种譬喻者。所谓真金示现真如。偈言真如故。又何等为五种譬喻。一者地藏。二者树。三者金像。四者转轮圣王五者宝像。能生三种佛身。示现如来性。偈言如来性故。又法身者。偈言

  法身有二种　　清净真法界
  及依彼习气　　以深浅义说

此偈明何义。诸佛如来有二种法身。何等为二。一者寂静法界身。以无分别智境界故。如是诸佛如来法身。唯自内身法界能证应知。偈言清净真法界故。二者为得彼因。谓彼寂静法界说法。依可化众生说。彼说法应知。以依真如法身有彼说法。名为习气。偈言及依彼习气故。彼说法者。复有二种。一细二粗。细者。所谓为诸菩萨摩诃萨演说甚深秘密法藏。以依第一义谛说故。粗者。所谓种种修多罗祇夜和伽罗那伽陀忧陀那尼陀那等。名字章句种种差别。以依世谛说故。是故偈言

  以出世间法　　世中无譬喻
  是故依彼性　　还说性譬喻
  如美蜜一味　　微细法亦尔
  修多罗等说　　如种种异味

此偈明何义。诸佛美蜜及坚固等三种譬喻。此明如来真如法身有二种义。一者遍覆一切众生。二者遍身中有无有余残。示现一切众生有如来藏。此以何义。于众生界中无有一众生离如来法身在于法身外。离于如来智在如来智外。如种种色像不离虚空中。是故偈言

  譬如诸色像　　不离于虚空
  如是众生身　　不离诸佛智
  以如是义故　　说一切众生
  皆有如来藏　　如虚空中色
  以性不改变　　体本来清净
  如真金不变　　故说真如喻

此偈明何义。明彼真如如来之性。乃至邪聚众生身中自性清净心。无异无差别。光明明了。以离客尘诸烦恼故。后时说言。如来法身如是以一真金譬喻。依真如无差别。不离佛法身故。说诸众生皆有如来藏。以自性清净心虽言清净而本来无二法故。是故经中佛告文殊师利言。文殊师利。如来如实知见自身根本清净智。以依自身根本智故。知诸众生有清净身。文殊师利。所谓如来自性清净身。乃至一切众生自性清净身。此二法者。无二无差别。是故偈言

  一切诸众生　　平等如来藏
  真如清净法　　名为如来体
  依如是义故　　说一切众生
  皆有如来藏　　应当如是知

又复偈言

  佛性有二种　　一者如地藏
  二者如树果　　无始世界来
  自性清净心　　修行无上道
  依二种佛性　　得出三种身
  依初譬喻故　　知有初法身
  依第二譬喻　　知有二佛身
  真佛法身净　　犹如真金像
  以性不改变　　摄功德实体
  证大法王位　　如转轮圣王
  依止镜像体　　有化佛像现

此偈明何义。余五种譬喻。所谓藏树金像转轮圣王宝像譬喻。示现生彼三佛法身。以依自体性如来之性诸众生藏。是故说言。一切众生有如来藏。此示何义。以诸佛如来有三种身得名义故。此五种喻能作三种佛法身因。以是义故说如来性因。此以何义。此中明性义以为因义以是义故。经中偈言

  无始世来性　　作诸法依止
  依性有诸道　　及证涅槃果

此偈明何义。无始世界性者。如经说言。诸佛如来依如来藏。说诸众生无始本际不可得知故。所言性者。如圣者胜鬘经言。世尊。如来说如来藏者。是法界藏。出世间法身藏。出世间上上藏。自性清净法身藏。自性清净如来藏故。作诸法依止者。如圣者胜鬘经言。世尊。是故如来藏是依是持是住持是建立。世尊。不离不离智。不断不脱。不异无为。不思议佛法。世尊。亦有断脱异外离离智有为法。亦依亦持亦住持亦建立。依如来藏故。依性有诸道者。如圣者胜鬘经言。世尊。生死者依如来藏。世尊。有如来藏故。说生死。是名善说故。及证涅槃果者。如圣者胜鬘经言。世尊。依如来藏故有生死。依如来藏故证涅槃。世尊。若无如来藏者。不得厌苦乐求涅槃。不欲涅槃不愿涅槃故。此明何义。明如来藏究竟如来法身不差别。真如体相毕竟定佛性体。于一切时一切众生身中皆无余尽应知。此云何知依法相知。是故经言。善男子。此法性法体性自性常住。如来出世若不出世。自性清净本来常住。一切众生有如来藏。此明何义。依法性依法体。依法相应依法方便。此法为如是为不如是。不可思议。一切处依法依法量依法信。得心净得心定。彼不可分别。为实为不实。唯依如来信。是故偈言

  唯依如来信　　信于第一义
  如无眼目者　　不能见日轮

此偈明何义。略说一切众生界中有四种众生。不识如来藏如生盲人。何等为四。一者凡夫。二者声闻。三者辟支佛。四者初发菩提心菩萨。如圣者胜鬘经中说言。世尊。如来藏者。于身见众生非其境界。世尊。如来藏者。于取四颠倒众生非其境界。世尊。如来藏者。于散乱心失空众生非其境界故。此明何义。身见众生者。谓诸凡夫。以彼凡夫实无色等五阴诸法而取以为有我我所。虚妄执着我我所慢。于离身见等灭谛无漏性甘露之法。信亦不能。何况出世间一切智境界如来藏能证能解。无有是处。又取四颠倒诸众生者。所谓声闻辟支佛人。以彼声闻辟支佛等应修行如来藏常。而不修行如来藏以为常。以颠倒取一切法无常。修行如来藏无常。乐无常修行。以不知不觉故。应修行如来藏乐。而不修行如来藏以为乐。以颠倒取一切法皆苦。修行如来藏苦。乐苦修行。以不知不觉故。应修行如来藏我。而不修行如来藏以为我。以颠倒取一切法无我。修行如来藏无我。乐无我修行。以不知不觉故。应修行如来藏净。而不修行如来藏以为净。以颠倒取一切法不净。修行如来藏不净。乐不净修行。以不知不觉故。如是声闻辟支佛等。一切不能如实随顺法身修行。以是义故。第一彼岸常乐我净法。非彼声闻辟支佛等所知境界。如是乐颠倒无常苦无我不净相等。彼如来藏非其境界。如是之义大般涅槃修多罗中。池水譬喻广明此义应知。彼经中言。迦叶。譬如春时有诸人等在大池浴乘船游戏。失琉璃宝没深水中。是时诸人悉共入水求觅是宝。竞捉瓦石草木沙砾。各各自谓得琉璃珠。欢喜持出乃知非真。是时宝珠犹在水中。以珠力故水皆澄清。于是大众乃见宝珠故在水下。犹如仰观虚空月形。是时众中有一智人。以方便力安徐入水即便得珠。汝等比丘。不应如是修集无常苦无我想不净想等以为真实。如彼诸人各以瓦石草木沙砾而为宝珠。汝等应当善学方便在在处处常修我想常乐净想。复应当知。先所修集四法相貌悉是颠倒。欲得真实修诸想者。如彼智人巧出宝珠。所谓我想常乐净想故。又散乱心失空众生者。谓初发心菩萨。离空如来藏义。以失变坏物修行。名为空解脱门。此以何义。初发心菩萨起如是心。实有法断灭后时得涅槃。如是菩萨失空如来藏修行。又复有人以空为有物。我应得空。又生如是心。离色等法别更有空。我应修行令得彼空。彼人不知空以何等法是如来藏。偈言

  不空如来藏　　谓无上佛法
  不相舍离相　　不增减一法
  如来无为身　　自性本来净
  客尘虚妄染　　本来自性空

此偈明何义。不减一法者。不减烦恼。不增一法者。真如性中不增一法。以不舍离清净体故偈言不相舍离相不增减一法故。是故圣者胜鬘经言。世尊。有二种如来藏空智。世尊。空如来藏。若离若脱若异一切烦恼藏。世尊。不空如来藏。过于恒沙不离不脱不异。不思议佛法故。如是以何等烦恼以何等处无。如是如实见知名为空智。又何等诸佛法。何处具足有。如是如实见知名不空智。如是明离有无二边如实知空相。此二偈中明如是义。又众生若离如是空智。彼人则是佛境界外名不相应。不得定不得一心。以是义故。名散乱心失空众生。何以故。以离第一义空智门无分别境界不可得证不可得见是故圣者胜鬘经言。世尊。如来藏智名为空智。世尊。如来藏空智者。一切声闻辟支佛等。本所不见。本所不得。本所不证。本所不会。世尊。一切苦灭唯佛得证。坏一切烦恼藏。修一切灭苦道故。如是此如来藏。以法界藏故。身见等众生不能得见。已说以身见相对治真实法界未现前故。又如是出世间法身如来藏。非颠倒众生境界。已说以无常等世间法对治出世间法界未现前故。又如是自性清净法界如来空藏。非散乱心失空众生境界。已说以烦恼垢客尘染。空自性清净功德法不相舍离。出世间法身得名故。此明何义。又依一味等味法界无差别智门观察出世间自性清净法身。是名如实知见真如。是故经说。十住菩萨唯能少分见如来藏。何况凡夫二乘人等。是故偈言

  譬如薄云中　　见虚空有日
  净慧诸圣人　　见佛亦如是
  声闻辟支佛　　如无眼目者
  不能观如来　　如盲不见日
  所知一切法　　有无量无边
  遍虚空法界　　无量智能见
  诸如来法身　　充满一切处
  佛智慧能见　　以无量智故

    究竟一乘宝性论为何义说品第七

问曰。真如佛性如来藏义住无障阂究竟菩萨地。菩萨第一圣人亦非境界。以是一切智者境界故。若如是者。何故乃为愚痴颠倒凡夫人说。答曰。以是义故。略说四偈

  处处经中说　　内外一切空
  有为法如云　　及如梦幻等
  此中何故说　　一切诸众生
  皆有如来性　　而不说空寂
  以有怯弱心　　轻慢诸众生
  执着虚妄法　　谤真如佛性
  计身有神我　　为令如是等
  远离五种过　　故说有佛性

此四行偈以十一偈略释应知。偈言

  诸修多罗中　　说有为诸法
  谓烦恼业等　　如云等虚妄
  烦恼犹如云　　所作业如梦
  如幻阴亦尔　　烦恼业生故
  先已如是说　　此究竟论中
  为离五种过　　说有真如性
  以众生不闻　　不发菩提心
  或有怯弱心　　欺自身诸过
  未发菩提心　　生起欺慢意
  见发菩提心　　我胜彼菩萨
  如是憍慢人　　不起正智心
  是故虚妄取　　不知如实法
  妄取众生过　　不知客染心
  实无彼诸过　　自性净功德
  以取虚妄过　　不知实功德
  是故不得生　　自他平等慈
  闻彼真如性　　起大勇猛力
  及恭敬世尊　　智慧及大悲
  生增长五法　　不退转平等
  无一切诸过　　唯有诸功德
  取一切众生　　如我身无异
  速疾得成就　　无上佛菩提

    究竟一乘宝性论身转清净成菩提品第八

论曰。已说有垢如。自此以下说无垢如应知。无垢如者。谓诸佛如来。于无漏法界中远离一切种种诸垢。转杂秽身得净妙身。依八句义略差别说彼真如性无漏法身应知。何等为八偈言

  净得及远离　　自他利相应
  依止深快大　　时数如彼法

是名八种句义。次第一偈示现八种义者。何谓八种。一者实体。二者因。三者果。四者业。五者相应。六者行。七者常。八者不可思议。实体者。向说如来藏不离烦恼藏所缠。以远离诸烦恼转身得清净。是名为实体应知。偈言净故。是故圣者胜鬘经言。世尊。若于无量烦恼藏所缠如来藏不疑惑者。于出无量烦恼藏法身亦无疑惑故。因者。有二种无分别智。一者出世间无分别智。二者依出世间智。得世间出世间依止行智是名为因。偈言得故。果者。即依此得得证智果。是名为果。偈言远离故。业者。有二种远离。一者远离烦恼障。二者远离智障。如是次第故名远离。如是远离自利利他成就。是名为业。偈言自他利故。相应者。自利利他得无量功德。常毕竟住持。是名相应。偈言相应故。行常不思议者。谓三种佛法身。无始世界来作众生利益常不休息。不可思议。偈言依止深快大故。以是义故。略说偈言

  实体因果业　　及以相应行
  常不可思议　　名佛地应知

又依实体依因。于佛地中及得彼方便因故。说三偈

  向说佛法身　　自性清净体
  为诸烦恼垢　　客尘所染污
  譬如虚空中　　离垢净日月
  为彼厚密云　　罗网之所覆
  佛功德无垢　　常恒及不变
  不分别诸法　　得无漏真智

此三行偈以四行偈略释应知。偈言

  佛身不舍离　　清净真妙法
  如虚空日月　　智离染不二
  过恒沙佛法　　明净诸功德
  非作法相应　　不离彼实体
  烦恼及智障　　彼法实无体
  常为客尘染　　是故说云喻
  远离彼二因　　向二无分别
  无分别真智　　及依彼所得

此偈明何义。向说转身实体清净。又清净者略有二种。何等为二。一者自性清净。二者离垢清净。自性清净者。谓性解脱无所舍离。以彼自性清净心体不舍一切客尘烦恼。以彼本来不相应故。离垢清净者。谓得解脱。又彼解脱不离一切法。如水不离诸尘垢等而言清净。以自性清净心远离客尘诸烦恼垢更无余故。又依彼果离垢清净故。说四偈

  如清净池水　　无有诸尘浊
  种种杂花树　　周匝常围绕
  如月离罗睺　　日无云翳等
  无垢功德具　　显现即彼体
  蜂王美味蜜　　坚实净真金
  宝藏大果树　　无垢真金像
  转轮圣王身　　妙宝如来像
  如是等诸法　　即是如来身

此四行偈以八行偈略释应知。偈言

  贪等客烦恼　　犹如浊水尘
  无分别上智　　果法如池水
  示现佛法身　　一切诸功德
  依彼证智果　　是故如是说
  贪如浊水尘　　净法杂垢染
  可化诸众生　　如绕池藕花
  禅定习气润　　远离嗔罗睺
  以大慈悲水　　遍益诸众生
  如十五日月　　远离云罗网
  光明照众生　　能除诸幽闇
  佛无垢日月　　离痴云罗网
  智光照众生　　除灭诸黑闇
  得无等等法　　能与妙法味
  诸佛如蜜坚　　远离蜂糩障
  真实妙功德　　除断诸贫穷
  能与解脱势　　故说金树喻
  法宝真实身　　增上两足尊
  胜色毕竟成　　故说后三喻

又向说以二种智依自利利他业。何者为二。一者出世间无分别智。二者依出世间无分别智。转身得身行因远离烦恼。得证智果故。又何者是成就自利。谓得解脱远离烦恼障远离智障。得无障碍清净法身。是名成就自身利益。又何者是成就他利益。既得成就自身利已。无始世来自然依彼二种佛身。示现世间自在力行。是名成就他身利益。又依自利利他。成就业义故。说四偈

  无漏及遍至　　不灭法与恒
  清凉不变异　　不退寂净处
  诸佛如来身　　如虚空无相
  为诸胜智者　　作六根境界
  示现微妙色　　出于妙音声
  令嗅佛戒香　　与佛妙法味
  使觉三昧触　　令知深妙法
  细思惟稠林　　佛离虚空相

此四行偈以八行偈略释应知。偈言

  略说二种法　　业智应当知
  满足解脱身　　清净真法身
  解脱身法身　　二及一应知
  谓无漏遍至　　及究竟无为
  烦恼尽无漏　　及习气灭故
  无阂及无障　　智遍至应知
  无为以不灭　　实体不失故
  不失名为本　　恒等句解释
  对于恒等句　　有四失应知
  死无常及转　　不可思议退
  以无死故恒　　以常故清凉
  不转故不变　　寂静故不退
  彼究竟足迹　　净智白法体
  具足色声等　　示现于诸根
  如虚空无相　　而现色等相
  法身亦如是　　具六根境界

此偈明何义。经中说言。如虚空相诸佛亦尔者。此依第一义。诸佛如来清净法身自体相不共法故。作如是说。以是义故。金刚般若波罗蜜经言。须菩提。于意云何。可以三十二大人相成就得见如来不。须菩提言。如我解佛所说义者。不以相成就得见如来。佛言。如是如是。须菩提。不以相成就得见如来。须菩提。若以相成就观如来者。转轮圣王应是如来。是故非以相成就得见如来故。此明何义。以依如来第一义谛清净法身明如是义。又依相应义故。说二偈

  如空不思议　　常恒及清凉
  不变与寂静　　遍离诸分别
  一切处不着　　离阂粗涩触
  亦不可见取　　佛净心无垢

此二行偈以八行偈略释应知。偈言

  解脱身法身　　示自利利他
  依自利利他　　彼处相应义
  一切诸功德　　不思议应知
  以非三慧境　　一切种智知
  诸众生佛体　　细故非闻境
  第一非思思　　以出世深密
  世修慧不知　　诸愚痴凡夫
  本来未曾见　　如盲不瞩色
  二乘如婴儿　　不见日月轮
  以不生故常　　以不灭故恒
  离二故清凉　　法性住不变
  证灭故寂静　　一切觉故遍
  不住不分别　　离烦恼不着
  无智障离阂　　柔软离粗涩
  无色不可见　　离相不可取
  以自性故净　　离染故无垢

此偈明何义。虚空譬喻者。明诸佛如来无为诸功德不离佛法身。于所有诸有得不可思议胜大方便业胜大悲业胜大智业。为与一切众生乐相无垢清净三种佛身。所谓实佛受法乐佛及化身佛。常不休息常不断绝。自然修行。以为利益一切众生应知。以不共余人唯诸佛如来法身相应故。此明何义。以依此身相应诸行差别故。说八偈

  非初非中后　　不破坏不二
  远离于三界　　无垢无分别
  此甚深境界　　非二乘所知
  具胜三昧慧　　如是人能见
  出过于恒沙　　不思议功德
  唯如来成就　　不与余人共
  如来妙色身　　清净无垢体
  远离诸烦恼　　及一切习气
  种种胜妙法　　光明以为体
  令众生解脱　　常无有休息
  所作不思议　　如摩尼宝王
  能现种种形　　而彼体非实
  为世间说法　　示现寂静处
  教化使淳熟　　授记令入道
  如来镜像身　　而不离本体
  犹如一切色　　不离于虚空

此八行偈以二十五偈略释应知。偈言

  向说佛法身　　及一切种智
  自在与涅槃　　及第一义谛
  不可思议法　　应供等功德
  唯自身内证　　应当如是知
  彼三身差别　　实法报化等
  所谓深快大　　无量功德身
  明实体身者　　谓诸佛法身
  略说五种相　　五功德应知
  无为无差别　　远离于二边
  出离烦恼障　　智障三昧障
  以离一切垢　　故圣人境界
  清净光明照　　以法性如是
  无量阿僧祇　　不可数思议
  无等诸功德　　到第一彼岸
  实法身相应　　以快不可数
  非思量境界　　及远离习气
  无边等佛法　　次第不离报
  受种种法味　　示现诸妙色
  净慈悲习气　　无虚妄分别
  利益诸众生　　自然无休息
  如如意宝珠　　满足众生心
  受乐佛如是　　神通力自在
  此神力自在　　略说有五种
  说法及可见　　诸业不休息
  及休息隐没　　示现不实体
  是名要略说　　有五种自在
  如摩尼宝珠　　依种种诸色
  异本生诸相　　一切皆不实
  如来亦如是　　方便力示现
  从兜率陀退　　次第入胎生
  习学诸伎艺　　婴儿入王宫
  厌离诸欲相　　出家行苦行
  推问诸外道　　往诣于道场
  降伏诸魔众　　成大妙觉尊
  转无上法轮　　入无余涅槃
  于不清净国　　现如是等事
  世间无休息　　宣说无常苦
  无我寂静名　　方便智慧力
  令彼诸众生　　厌离三界苦
  后入于涅槃　　以入寂静道
  诸声闻人等　　有是虚妄相
  言我得涅槃　　法华等诸经
  皆说如实法　　般若方便摄
  回先虚妄心　　令淳熟上乘
  授妙菩提记　　微细大势力
  令愚痴众生　　过崄难恶道
  深快及以大　　次第说应知
  初法身如来　　第二色身佛
  譬如虚空中　　有一切色身
  于初佛身中　　最后身亦尔

自此以下。即依如是三种佛身。为乐众生利益众生。略说二偈

  世尊体常住　　以修无量因
  众生界不尽　　慈悲心如意
  智成就相应　　法中得自在
  降伏诸魔怨　　体寂静故常

此二行偈以六行偈略释应知。偈言

  弃舍身命财　　摄取诸佛法
  为利益众生　　究竟满本愿
  得清净佛身　　起大慈悲心
  修行四如意　　依彼力住世
  以成就妙智　　离有涅槃心
  常得心三昧　　成就乐相应
  常在于世间　　不为世法染
  得净甘露处　　故离一切魔
  诸佛本不生　　本来寂静故
  以常可归依　　故言归依我
  初七种譬喻　　如来色身常
  后三种譬喻　　善逝法身常

此偈明何义。诸佛如来依法身转得无上身。不可思议应知。依不可思议故。说二偈

  非言语所说　　第一义谛摄
  离诸觉观地　　无譬喻可说
  最上胜妙法　　不取有涅槃
  非三乘所知　　唯是佛境界

此二行偈以五行偈略释应知。偈言

  不可得思议　　以离言语相
  离言语相者　　以第一义摄
  第一义摄者　　非思量境界
  非思量境者　　以无譬喻知
  无譬喻知者　　以最胜无上
  最胜无上者　　不取有涅槃
  不取是二者　　不取功德过
  前五种譬喻　　微细不思议
  如来法身常　　第六譬喻者
  以得自在故　　如来色身常

    究竟一乘宝性论如来功德品第九

论曰。已说无垢真如法身。次说依彼无垢真如法身一切功德。如摩尼宝不离光明形色诸相。如来法身无量无边自性清净无垢功德。亦复如是。以是义故依佛功德。次说二偈

  自利亦利他　　第一义谛身
  依彼真谛身　　有此世谛体
  果远离淳熟　　此中具足有
  六十四种法　　诸功德差别

此偈示现何义。偈言

  于自身成就　　住持诸佛法
  故摄第一身　　为他身住持
  诸如来世尊　　故有世谛体
  佛无量功德　　初身摄应知
  十力四无畏　　大丈夫相等
  彼受乐报体　　第二佛身摄

此偈明何义。明十力等六十四种佛身功德。此云何知。依彼义故。略说二偈

  佛力金刚杵　　破无智者障
  如来无所畏　　处众如师子
  如来不共法　　清净如虚空
  如彼水中月　　众生二种见

自此已下功德品中余残论偈。依此二偈次第示现彼十力等六十四种如来功德。如陀罗尼自在王经广说应知。初依十力故。说二偈

  处非处果报　　业及于诸根
  性信至处道　　离垢诸禅定
  忆念过去世　　天眼寂静智
  如是等诸句　　说十种力名

又依四无畏故。说三偈

  如实觉诸法　　遮诸阂道障
  说道得无漏　　是四种无畏
  于所知境界　　毕竟知自他
  自知教他知　　此非遮障道
  能证胜妙果　　自得令他得
  说自他利谛　　是诸处无畏

又依十八不共佛法故说八偈

  佛无过无诤　　无妄念等失
  无不定散心　　无种种诸想
  无作意护心　　欲精进不退
  念慧及解脱　　知见等不退
  诸业智为本　　知三世无障
  佛十八功德　　及余不说者
  佛身口无失　　若他来破坏
  内心无动相　　非作心舍心
  世尊欲精进　　念净智解脱
  知见常不失　　示现可知境
  一切诸业等　　智为本展转
  三世无障阂　　广大智行常
  是名如来体　　大智慧相应
  觉彼大菩提　　最上胜妙法
  为一切众生　　转于大法轮
  无畏胜妙法　　令彼得解脱

又依三十二大人相故。说十一偈

  足下相平满　　具足千辐轮
  跟佣趺上隆　　伊尼鹿王[跳-兆+尃]
  手足悉柔软　　诸指皆纤长
  鹅王网缦指　　臂肘上下佣
  两肩前后平　　左右俱圆满
  立能手过膝　　马王阴藏相
  身佣相洪雅　　如尼拘树王
  体相七处满　　上半如师子
  威德势坚固　　犹如那罗延
  身色新净妙　　柔软金色皮
  净软细平密　　一孔一毛生
  毛柔软上靡　　微细轮右旋
  身净光圆匝　　顶上相高显
  项如孔雀王　　颐方若师子
  发净金精色　　喻如因陀罗
  额上白毫相　　通面净光明
  口含四十齿　　二牙白踰雪
  深密内外明　　上下齿平齐
  迦陵频伽声　　妙音深远声
  所食至喉现　　得味中上味
  细薄广长舌　　二目淳绀色
  瞬眼若牛王　　功德如莲华
  如是说人尊　　妙相三十二
  一一不杂乱　　普身不可嫌

此佛十力四无所畏十八不共法。三十二大人相。略集一处。是名六十四种功德应知。偈言

  六十四功德　　修因及果报
  一一各差别　　宝经次第说

此偈明何义。向说诸佛如来六十四种功德因果差别。依此次第宝女经中广说应知。又复依此四处。次第有四种喻。谓金刚杵及师子王。虚空譬喻水中月等。有九行偈。依彼九偈。略说偈言

  冲过无慈心　　不共他无心
  故说杵师子　　空水中月喻

又依十力金刚杵喻故。说二偈

  处非处果性　　众生诸信根
  种种道修地　　过宿命差别
  天眼漏尽等　　佛力金刚杵
  能刺碎散斫　　痴铠山墙树

此偈示现何义。略说偈言

  诸如来六力　　次第三及一
  所知境界中　　离三昧诸障
  及离余垢障　　譬如破散截
  铠墙及树等　　亦重亦坚固
  亦不可破坏　　如来十种力
  犹如彼金刚　　故说金刚杵

又依四无畏师子王喻故。说二偈

  譬如师子王　　诸兽中自在
  常处于山林　　不怖畏诸兽
  佛人王亦尔　　处于诸群众
  不畏及善住　　坚固奋迅等

此偈示现何义。略说偈言

  知病苦知因　　远离彼苦因
  说圣道妙药　　为离病证灭
  远离诸怖畏　　善住奋迅城
  佛王在大众　　无畏如师子
  以知一切法　　是故能善住
  一切处不畏　　离愚痴凡夫
  二乘及清净　　以见我无等
  于一切法中　　心常定坚固
  何故名奋迅　　过无明住地
  自在无阂处　　是故名奋迅

又依十八不共法虚空譬喻故。说三偈

  地水火风等　　彼法空中无
  诸色中亦无　　虚空无阂法
  诸佛无障碍　　犹如虚空相
  如来在世间　　如地水火风
  而诸佛如来　　所有诸功德
  乃至无一法　　共余世间有

此偈示现何义。略说偈言

  声闻及空行　　智者及自在
  上上微细法　　故示现五大
  诸众生受用　　如地水火风
  离世离出世　　故说虚空大
  三十二功德　　依止法身有
  如世间灯炷　　明暖及色相
  相应无差别　　诸如来法身
  一切诸功德　　无差别亦尔

又依三十二大丈夫相水中月喻故。说二偈

  秋空无云曀　　月在天及水
  一切世间人　　皆见月势力
  清净佛轮中　　具功德势力
  佛子见如来　　功德身亦尔

此偈示现何义。略说偈言

  三十二功德　　见者生欢喜
  依法报化身　　三种佛而有
  法身净无垢　　远离于世间
  在如来轮中　　众生见二处
  如清净水中　　见于月影像
  是三十二相　　依色身得名
  如摩尼宝珠　　不离光色相
  色身亦如是　　不离三十二

    究竟一乘宝性论自然不休息佛业品第十

论曰。已说无垢诸佛功德。次说诸佛如来作业。彼诸佛业自然而行常不休息。教化众生应知。此依略说。有二种法自然而行。以是义故。依诸佛业自然而行。常不休息常作佛事故。说六偈

  于可化众生　　以教化方便
  起化众生业　　教化众生界
  诸佛自在人　　于可化众生
  常待处待时　　自然作佛事
  遍觉知大乘　　最妙功德聚
  如大海水宝　　如来智亦尔
  菩提广无边　　犹如虚空界
  于无量功德　　大智慧日光
  遍照诸众生　　有佛妙法身
  无垢功德藏　　如我身无异
  烦恼障智障　　云雾罗网覆
  诸佛慈悲风　　吹令散灭尽

此六行偈义以十四偈略释应知。偈言

  以何等性智　　何者何处时
  作业无分别　　是故业自然
  以何等根性　　诸众生可度
  以何等智慧　　能度诸众生
  又以何者是　　化众生方便
  众生以何处　　何时中可化
  进趣及功德　　为果为摄取
  彼障及断障　　诸缘不分别
  进趣谓十地　　功德因二谛
  果谓大菩提　　摄菩提眷属
  彼障谓无边　　烦恼及习气
  断障谓大慈　　及大悲心等
  是名一切时　　常种种因缘
  如是等六处　　次第说应知
  如大海水宝　　空日地云风
  诸地如大海　　智水功德宝
  菩提如空界　　广无中后边
  为利益众生　　二种业如日
  能悉遍照知　　一切众生界
  皆有如来性　　如地中伏藏
  犹如彼大地　　体安固不动
  为利益众生　　见彼我无别
  客尘烦恼等　　本自无体性
  一切皆虚妄　　如云聚不实
  起大慈悲心　　犹如猛风吹
  烦恼智障尽　　如彼云聚散
  化事未究竟　　故常在世间
  从本际以来　　自然不休息

问曰。如向所说诸佛如来不生不灭。若如是者即无为法。无为法者不修行业。云何自然不休息常教化众生事。答曰。为示现彼诸佛大事断诸疑惑。是故依彼不可思议无垢清净诸佛境界。示现大事故。以譬喻说一行偈

  帝释妙鼓云　　梵天日摩尼
  响及虚空地　　如来身亦尔

依此一行修多罗摄取义。偈九种譬喻。自此以下广说余残六十六偈应知。又复依彼广说偈义。九种譬喻略说彼义。及以次第广说如来无上利益一切众生修行究竟。以十九偈解释应知。偈言

  远离一切业　　未曾见有果
  为一切疑人　　除诸疑网故
  说九种譬喻　　彼修多罗名
  广说此诸法　　彼修多罗中
  广说九种喻　　彼名智境界
  快妙智庄严　　有智者速入
  具足佛境界　　说彼天帝释
  琉璃镜像等　　九种诸譬喻
  应知彼要义　　见说及遍至
  以离诸相智　　身口意业密
  大慈悲者得　　离诸功用心
  无分别寂静　　以智故无垢
  如大毗琉璃　　帝释等譬喻
  智究竟满足　　故究竟寂静
  以有净智慧　　是故无分别
  为成种种义　　故说释等喻
  为成彼义者　　说九种见等
  离生离神通　　诸佛现是事
  是名为略说　　种种义譬喻
  先喻解异后　　后喻解异前
  佛体如镜像　　如彼琉璃地
  人非不有声　　如天妙法鼓
  非不作法事　　如彼大云雨
  非不作利益　　而亦非不生
  种种诸种子　　如梵天不动
  而非不淳熟　　如彼大日轮
  非不破诸闇　　如彼如意宝
  而非不希有　　犹如彼声响
  非不因缘成　　犹如彼虚空
  非不为一切　　众生作依止
  犹如彼大地　　而非不住持
  一切种种物　　以依彼大地
  荷负诸世间　　种种诸物故
  依诸佛菩提　　出世间妙法
  成就诸白业　　诸禅四无量
  及以四空定　　诸如来自然
  常住诸世间　　有如是诸业
  一时非前后　　作如是妙业

    究竟一乘宝性论挍量信功德品第十一

论曰。向说四种法。自此已下明有慧人于彼法中能生信心。依彼信者所得功德。说十四偈

  佛性佛菩提　　佛法及佛业
  诸出世净人　　所不能思议
  此诸佛境界　　若有能信者
  得无量功德　　胜一切众生
  以求佛菩提　　不思议果报
  得无量功德　　故胜诸世间
  若有人能舍　　摩尼珠珍宝
  遍布十方界　　无量佛国土
  为求佛菩提　　施与诸法王
  是人如是施　　无量恒沙劫
  若复有人闻　　妙境界一句
  闻已复能信　　过施福无量
  若有智慧人　　奉持无上戒
  身口意业净　　自然常护持
  为求佛菩提　　如是无量劫
  是人所得福　　不可得思议
  若复有人闻　　妙境界一句
  闻已复能信　　过戒福无量
  若人入禅定　　焚三界烦恼
  过天行彼岸　　无菩提方便
  若复有人闻　　妙境界一句
  闻已复能信　　过禅福无量
  无慧人能舍　　唯得富贵报
  修持禁戒者　　得生人天中
  修行断诸障　　非慧不能除
  慧除烦恼障　　亦能除智障
  闻法为慧因　　是故闻法胜
  何况闻法已　　复能生信心

此十四偈以十一偈略释应知。偈言

  身及彼所转　　功德及成义
  示此四种法　　唯如来境界
  智者信为有　　及信毕竟得
  以信诸功德　　速证无上道
  究竟到彼岸　　如来所住处
  信有彼境界　　彼非可思议
  我等可得彼　　彼功德如是
  唯深信胜智　　欲精进念定
  修智等功德　　无上菩提心
  一切常现前　　以常现前故
  名不退佛子　　彼岸净功德
  毕竟能成就　　五度是功德
  以不分别三　　毕竟及清净
  以离对治法　　施唯施功德
  持戒唯持戒　　余二度修行
  谓忍辱禅定　　精进遍诸处
  悭等所治法　　名为烦恼障
  虚分别三法　　是名为智障
  远离彼诸障　　更无余胜因
  唯真妙智慧　　是故般若胜
  彼智慧根本　　所谓闻慧是
  以闻慧生智　　是故闻为胜

又自此已下明向所说义。依何等法说。依何等义说。依何等相说。初依彼法故。说二偈

  我此所说法　　为自心清净
  依诸如来教　　修多罗相应
  若有智慧人　　闻能信受者
  我此所说法　　亦为摄彼人

自此已下次依彼义故。说二偈

  依灯电摩尼　　日月等诸明
  一切有眼者　　皆能见境界
  依佛法光明　　慧眼者能见
  以法有是利　　故我说此法

自此已下次依彼相故。说二偈

  若一切所说　　有义有法句
  能令修行者　　远离于三界
  及示寂静法　　最胜无上道
  佛说是正经　　余者颠倒说

自此已下依护法方便故。说七偈

  虽说法句义　　断三界烦恼
  无明覆慧眼　　贪等垢所缠
  又于佛法中　　取少分说者
  世典善言说　　彼三尚可受
  何况诸如来　　远离烦恼垢
  无漏智慧人　　所说修多罗
  以离于诸佛　　一切世间中
  更无胜智慧　　如实知法者
  如来说了义　　彼不可思议
  思者是谤法　　不识佛意故
  谤圣及坏法　　此诸邪思惟
  烦恼愚痴人　　妄见所计故
  故不应执着　　邪见诸垢法
  以净衣受色　　垢腻不可染

自此已下依谤正法故。说三偈

  愚不信白法　　邪见及憍慢
  过去谤法障　　执着不了义
  着供养恭敬　　唯见于邪法
  远离善知识　　亲近谤法者
  乐着小乘法　　如是等众生
  不信于大乘　　故谤诸佛法

自此已下依谤正法得恶果报故。说六偈

  智者不应畏　　怨家蛇火毒
  因陀罗霹雳　　刀杖诸恶兽
  师子虎狼等　　彼但能断命
  不能令人入　　可畏阿鼻狱
  应畏谤深法　　及谤法知识
  决定令人入　　可畏阿鼻狱
  虽近恶知识　　恶心出佛血
  及杀害父母　　断诸圣人命
  破坏和合僧　　及断诸善根
  以系念正法　　能解脱彼处
  若复有余人　　诽谤甚深法
  彼人无量劫　　不可得解脱

自此已下依于说法法师生敬重心故。说二偈

  若人令众生　　学信如是法
  彼是我父母　　亦是善知识
  彼人是智者　　以如来灭后
  回邪见颠倒　　令入正道故

自此已下依彼说法所得功德。以用回向故。说三偈

  三宝清净性　　菩提功德业
  我略说七种　　与佛经相应
  依此诸功德　　愿于命终时
  见无量寿佛　　无边功德身
  我及余信者　　既见彼佛已
  愿得离垢眼　　成无上菩提

自此已下略说句义。偈言

  依何等法说　　依何等义说
  依何等相说　　如彼法而说
  如彼义而说　　如彼相而说
  彼一切诸法　　六行偈示现
  护自身方便　　以七行偈说
  明诽谤正法　　故有三行偈
  六偈示彼因　　以二偈示现
  于彼说法人　　深生敬重心
  大众闻忍受　　得彼大菩提
  略说三种法　　示现彼果报

究竟一乘宝性论卷第四


决定藏论

    No. 1584 [cf. No. 1579(II, 1)]

决定藏论卷上

        梁天竺三藏真谛译

    心地品第一之一

  智慧靡不通　　于净更无治
  济世论世尽　　顶礼最胜尊
  法如所说者　　静地道为道
  未解此三法　　世转如轮转
  圣僧住于法　　过缚过余众
  十分八分八　　果道道果故

若诸大士夫。欲造论益无知人倒见疑者。所言利益。从正智生。言正智者。出决定藏论曰。本已说。地今广分别解此地义。善答问难。五识地心地经言。阿罗耶识普为种本。云何知有。此是如来藏说。故解节经偈云

  盛识普种本　　深细流如溢
  不为凡人说　　恐生我见故

郁陀南(梁言持散)

  执持本分明　　种本非是事
  身受无识定　　亦非气绝者

以此八种因缘知有阿罗耶识。若离此识根有执持。实无此理。执持有五。一者阿罗耶识持先世业。复从现因后诸识生。如佛阿毗昙说。因根尘心业诸识得生。二者善不善等六识得生。三者于六识中若有一无记识。而独是执所摄持者。无有是处。四者诸识各依根生随生一识根有执持。余根应无。五者诸根数执持。义则不然。以此五义。因阿罗耶识是故诸根名有。执持本者从初诸识不得俱生。亦无是处。若人问言。有阿罗耶识诸识俱生。答曰。如是。汝言无者则为过失。何以故。有实义故。如阿含故。二识俱生。何以知之。如有一人欲得见闻。乃至于知诸识各各自根尘。心欲无异根尘无异。一识得生余者何妨。此为实义。阿含后说分明者。诸识不俱取境不了。若以心识与眼识等为伴取境。是则分明。何以故。曾行诸尘。然后追思多不明了。识识不俱意独缘故。不如缘现则易明了。识识俱故。故知俱生种本者。若离阿罗耶识眼等六识互为本者。则无是处。云何知耶。善识灭时不善心生。不善识灭善心复生。善不善灭无记心生。下界心灭中界识生。中界心灭上识即生。上识亦灭下心还生。有漏识灭无漏心生。无漏心灭有漏还生。故知六识不互为本。如次第心灭。于无数劫还更得生。故知阿罗耶识以为种本非是事者。诸识不俱则无此事。何以故。此有四事。一者器事。二者捉身事。三者言是我事。四者于尘事。如此四事念念俱生。若言一识于一念中知四事者。无有是处。言身受者。若离阿罗耶识有身受者。则无此义。云何知耶。犹如有人若实心作不实心作。要先思惟。若定心不定心诸受于身种种多生诸受得生。故知有阿罗耶识有无识定亦无此义。何以知之。若入无想定入无识定者。六识皆灭。此人应死。如佛所说。入无心定而识不灭。言非气绝者。若离阿罗耶识有气绝者。无有是处。云何知耶。如善恶二人临命终时。善人足冷暖上至顶。顶若冷时人命即灭。恶人死时从顶冷至足暖气灭时此人命终。意识常在身。阿罗耶识持身故。阿罗耶识灭而身即冷。便不觉触。此冷暖二事不由意识故。知有阿罗耶识

郁陀南

  境界相赖起　　更互为因缘
  得共相应生　　与烦恼俱灭

略说四义。知有阿罗耶识事。一种现有灭境界者。阿罗耶识因二境生。一者在内持事故。二者在外持器。不能分别诸相貌故。此内持者。执着邪我见习势力。与根色俱时而执持者即为境界。此欲色界有。无色界中唯有执着邪我见习势力。二者在外持器不分像貌者。在内为阿罗耶识所持即持外界。譬灯持炷油在于内而有外照。阿罗耶识事内外亦尔。此境界者甚深妙细。若以世中多闻智人。亦不能了此境。是恒而有异。云何无异。从初一念来被持境。乃至于死生一味事。阿罗耶识于境界中念念生灭。在欲界中取境微小。于色界中取境广大。于无色界无量空处无量识处取无量境。于无所有处取微细境。于非有想非无想取境甚深微妙。此两境故。微妙故。一味故。念念灭故。微小境故。广大境故。无量境故。微细境故。甚深微妙境故。知有阿罗耶识事。相赖起者。阿罗耶识与五心数法相赖得生。思触受想及于作意。此五大地。是报所摄五法微细。世中智人所不能了。同缘一境无有别异。共不苦不乐无记受俱。余四亦尔。大地心数法相赖故。同报相赖故。微细相赖故。同缘一境故。非苦非乐相赖故。无记相赖故。知有阿罗耶识相赖而起。更互为因缘者。阿罗耶识与余诸识互为因缘。此义有二。一者种本。二者依托。云何种本。诸善不善无记等识。皆因阿罗耶识以为种本。依托者。阿罗耶识持诸色根五识得生。不持不生。有阿罗耶识时意识得生六识。二事为阿罗耶识更互因缘。一者现转增长种本。二者未来欲生之时令受报故。增长种本者。诸识生善不善无记念念熏修。阿罗耶识亦复如是。所以者何。后生诸识渐增长善恶转胜。令受报者。有识于善不善有力者。未来世令阿罗耶识受果报。种本故。依托故。能增长故。令受报故。知有阿罗耶识与诸识互为作因缘。得共相应生者。阿罗耶识或共一识相应得生。如说于心心有我见憍慢为相。于有意识于无意识阿罗耶识恒相应生。此我慢心取阿罗耶识为境。言是我言有我为相。或二识俱生。谓于意识。或三识共生。谓于意意识。于五识中随取一识。或四识相应生。于五识取二识。乃至于五六七识共生。六尘现在前故。此意识依心得立。因心未灭之时意识不解缚故。因心若灭意识则解。意识有二境界。他尘境界。自尘境界。他尘者。谓取五识尘为境。自境界者。谓取于法。而此意识于余七识有异义故。阿罗耶识与六识三受相应共生。谓苦乐不苦不乐。于欲界人天畜生饿鬼少分有三受。与自不苦不乐受共生地狱道。苦受不离。托阿罗耶受共生。三禅地。唯有乐受托阿罗耶识受共生。四禅乃至非想非非想地。唯有不苦不乐受托阿罗耶识受共生。如是六识中善不善无记法与阿罗耶识相应共生。又阿罗耶识与诸识相应共生。与客三受客善不善无记诸识相应得生。不得相杂。何以故。不同境界生故。犹如眼识俱生不与眼杂。阿罗耶识与诸识俱生不得相杂亦复如是。如诸心数同是心法。有种种相相应俱生。无有妨碍阿罗耶识而与七识相应俱生。亦复如是譬如流水与波俱生。无有妨碍。又如明镜诸像俱生不相妨碍。于阿罗耶识而与诸识相应得生。无有妨碍亦复如是。复如眼识。或取一色一种一相。或取多色多种多相。耳识于声。鼻识于香。舌识于味。身识于触。亦复如是。意识遍取种种诸相无有妨碍。分别六识其义如此。心界于前已说至于灭时与四烦恼共相杂生。我见憍慢我欲无明。此四烦恼于定不定地。于善不善无记法中。无有妨碍。即是秽污无记之法。是故阿罗耶识而与诸识相应生故。复与三受相应生故。亦与善等相应生故。以是义故。是故知有阿罗耶识相应共生。与烦恼俱灭者。阿罗耶识即是一切烦恼根本。云何知耶。能起众生世间根本。能生五根及于六识。亦起国土世界根本一切业起诸因缘故。亦是交互牵报根本。云何知耶。无有见他众生不生三受。是故佛说众生递互为增上缘。是以阿罗耶识为一切本。现在世中是苦谛体。未来世中能生集谛。是为一切烦恼根本。问曰。若言阿罗耶识为一切法而作根本。解脱分善通达分善。是诸善根以此与集谛应有妨碍。答曰。阿罗耶识不为达分诸善根本。世间诸善得增长。达分善根转更明胜。达分善根转明胜故。世间诸善得报亦胜。世尊依阿罗耶识为一切种本。故说此言。谓眼界色界眼识界。乃至意界法界意识界。阿罗耶识中有种种性故。故说种本积聚譬喻。如是阿罗耶识而是一切烦恼根本。修善法故此识则灭。言修善者。诸凡夫人起善思惟。而取诸识以为境界。进行安心初观诸谛。若证四谛得眼智明慧。则能破坏阿罗耶识。未见四谛则不能破。何时能见阿罗耶识。如是进行。若诸声闻入不退地。又诸菩萨入不退地。得通达法界则能得见。于此识中即见一切诸烦恼聚。于内于外即见己身为烦恼缚。于内见身而为三界粗恶烦恼诸苦所缚。一切行种烦恼摄者。聚在阿罗耶识中得真如境智。增上行故。修习行故。断阿罗耶识即转凡夫性。舍凡夫法阿罗耶识灭。此识灭故一切烦恼灭。阿罗耶识对治故。证阿摩罗识。阿罗耶识是无常。是有漏法。阿摩罗识是常。是无漏法。得真如境道故证阿摩罗识。阿罗耶识为粗恶苦果之所追逐。阿摩罗识无有一切粗恶苦果。阿罗耶识而是一切烦恼根本。不为圣道而作根本。阿摩罗识亦复不为烦恼根本。但为圣道得道得作根本。阿摩罗识作圣道依因。不作生因。阿罗耶识于善无记不得自在。阿罗耶识灭时有异相貌。谓来世烦恼不善因灭。以因灭故则于来世五盛阴苦不复得生。现在世中一切烦恼恶因灭故。则凡夫阴灭。此身自在即便如化。舍离一切粗恶果报。得阿摩罗识之因缘故。此身寿命便得自在。寿命因缘能灭于身。亦能断命。尽灭无余。一切诸受皆得清净。乃至如经广说。一切烦恼相故。入通达分故。修善思惟故。证阿摩罗识。故知阿罗耶识与烦恼俱灭。如是分别真实解释心意识义。因此解释心意识故。于三界中得知一切烦恼之法诸清净法。余处所说心意识者。为欲教化诸众生故。为诸众生未有深智易生信解。但说六识。问曰。有人有阿罗耶识有六识不。有人有六识无阿罗耶识不。答曰。此有四句。一者如人无心眠时。迷闷心时。入无想定。生无想天。阿那含人入灭尽定。此五种人。有阿罗耶识则无六识。二者阿罗汉。及辟支佛。不退菩萨。如来世尊。此四种人。以有心处有于六识无阿罗耶识。三者凡夫之人。须陀洹。斯陀含。阿那含。以有心处有六识有阿罗耶识。四者诸阿罗汉。及辟支佛。菩萨。世尊。入灭尽定。又世尊入无余涅槃。无阿罗耶亦无六识。一切内外法各有定性。于相不动。何故从十八界唯说六识。有定性故。所余诸界是根是尘是伴侣故。此诸识等日夜牟诟罗罗婆刹那过故。种种因缘眼等诸根色等诸尘。心数为伴种种缘生。随所生处得名不同。如火烧物随所烧处得种种名。谓草火木火粪火。因眼因色随识得生。皆名眼识。乃至心识亦复如是。眼等诸界从始至终。皆是果报无记。有异相识则不尔。是故分别识界不明余界。若有比丘欲知识聚修习此行令心清净多种相貌能了心者。略说有三。乐着烦恼故。染心为过故。断惑方便故。云何比丘知于烦恼。作是思惟。此心久来乐着烦恼。乐烦恼故纵复拔心。置无欲处为欲所牵。不乐暂住速疾退还。更入欲处。如是贪欲处。嗔恚处。愚痴处。睡眠处。乃至放逸之处。纵复拔心置无放逸处。速疾退还入放逸处。亦复如是。如是比丘知于烦恼。云何当知染心为过。此心有染。其既自损亦复损他。现世起恶。来世亦尔。从其所作忧悲苦恼诸恶因缘乃至放逸有过患故。受种种苦亦复如是。知于自心有诸过患。云何当知断惑方便。知于自心有如是过忧悲苦恼。我今不应随如是心受诸苦恼。应制自心随逐于我我不逐心。如是思量知心有欲。拔有欲心置无欲处。即令自心见于福利。乃至拔放逸心亦复如是。如是修行积习善根。是时此心无更余缘。于诸善法修习增长而得安住。憎恶烦恼见先过患。是故比丘修心清净。已知乐着烦恼故。已知染心过患故。已知断惑方便故。即得速证无上清净无漏之心。又别知心亦说转心。谓为假名。又别知心亦说转心。谓为他因。所治心善有二功德。得功德得果之时。心则快乐。修习善法自在无碍。有三种失染浊于心。一者不正思惟。二者结使未断。三者现起烦恼。比丘有三处住。因于六行能受佛教。云何三处。一者住于解脱。二者住解脱门。三者住解脱至。因缘法因于六行。一者无有异行。二者摄心一处。三者善根得生。四者思度见谛不尝余味。五者无增上慢。六者正用信施。施有二种。一受者施。二施者施。施果亦二。一大富果报。二庆悦果报。为应来就故。何者为应来就为未来法。无以未有故。如是应生行相。云何得住。若未来法有行相生。若度故生。从未来已度于现在。终此生彼从未来世终者现世受生。因未来法现世法生。如是住者无有变异。因未来法余现法生。于未来世现世诸法。而未来世现世诸法而未有业。于现世中即有事生。已生具相。于未来世未有具相。于现世中具相而生。若异相生。于未来世因未来性故。因因性故。此两性故。已生异相于现世中现世性故。以果性故。异相而生。以此六种未来世法无义得生。何以故。其未有处从于此处度于彼处。无有是义。既自未生岂容有没。诸现世法若因未来法。现世法生未来诸法。不应未生一切诸法。无有动相。离自相故。无有别业。未来现在若同有相。现世中法独偏有业。无有是处。唯业未生而今得生。诸行不尔。如佛正说诸行无常是说则破。今演业无常。若如汝说诸行应常。僧佉所云。是法未有无义得生。已生诸法无义得灭。此说应是。如佛所说。是法未生应即受生。生已应灭。若如汝说。此义应非。以此诸法若同一相。云何分别。若可分别。是则无穷未生得生。岂有于相未来法性从色等相应。无别异果。未来者以即未有。现世法者言即是果。无有此义。为应成就故。有此实说可为证信。未来诸法未有行相。言未有者而即得生。如未来法过去亦然。何者过去行法。是灭相者从生已过。何者现在行法。是未灭相。从生未过唯生时住。何者未来行法。乃现有因。未生自相未受己身。问曰。未来诸法既本无有能得受生。虚空华等石女兔角云何不生。答曰。此无生因未来行法有正生因。问曰。若未来法有正生因。何故不得一时俱生。答曰。乃有生因待缘不同。是诸行法有近缘者因即能生。是故不俱。何者因缘。佛说有四。一者因缘。二者次第。三者缘缘。四者增上。初一亦因亦缘。余三但缘非因。何者因缘。根有色者。有依者是。以是识者此二种法为一切种一切色根种一切色法种一切心心法种。悉依色根亦依于识。除四大色。此四大色有二种依。一四大种。二十一种。是种相续依于诸法所说者即是因缘。若有色根心心法种而不依耶。若入灭定入无想定生无想天。未来世识不应更生会当有生。是故色根心心法因。若有此识不随色种。诸凡夫人生无色界。寿命尽故。以业尽故。从彼没已来生下界。此色无种不应更生。会应更生。是故诸识是色根本。从世俗道入初禅定生初禅地。欲界不净及诸净法已破。种本未悉断除。何以故。从初禅定后更退还起不净法。从初禅处退生欲界。断有四种。一者避断。二者坏断。三者定断。四者本永拔断。何者避断。如有一人着于欲乐。为断欲故受离欲戒。坚持不犯令得增长。以增长故不复着欲。欲因烦恼不更得生。是名避断。何者坏断。犹如一人有过失想及不净想青瘀等想。及善思惟即坏贪欲。未尽欲者不随于欲。于尘境界心不贪着。是名坏断。何者定断。犹如一人随世俗道离于欲染。及离色染得证寂定持心相续。于欲及色不复更着。是名定断。何者本永拔断。犹如圣人修出世道。离三界染而即得证。于三界中诸烦恼本不复得生。何以故。于现世中已证无欲毕竟不退。已生上界决不更退还生下界。譬如稻麦及诸种子。种虚空中及干燥地。永不得生非不是种。若火焚之皆悉燋灭。失于种相诸烦恼本。于断于灭亦复如是。圣人若入无余涅槃。是善无记种本悉伏。问曰。若言是伏而不都灭何不生报答曰。已断不善种本。于未来世不能生报亦不自生。是名本永拔断。具缚人者。是心有生有苦有乐不苦不乐。此一切心为三种本。善与不善无记等法。亦为种本。诸学人者有世善心及染污无记修道断惑以为种本。世善心等复为余法而作根本。无学人者。断惑已尽有世善心。若属世间若出世间及无记者。以一切诸烦恼惑不作根本。一切善法及无记法即为根本。如是分别诸法根本。是处不说阿罗耶识。有处说者诸世俗法阿罗耶识悉为根本。一切诸法出世间者无断道法阿摩罗识以为种本。如佛所说。比丘。诸阿罗汉为学心法依于四禅现安乐住亦从此心。我说退堕还一一处。问曰。若如此者。诸阿罗汉永断烦恼。云何下地烦恼更生。若不更生。云何退堕。答曰。退有二种一者失退。二者住退。失退者是凡夫人。住退者通于凡圣。依世俗道烦恼已离。后复更起名退失退亦住退退。依出世道烦恼已断。心著作务不作心故。以此中间不能更起现安乐住。如前后亦如是。亦不更起下地诸惑。此住处退非退失退。诸阿罗汉一切惑尽。若不善法未断种本。云何罗汉心善解脱诸漏已尽。若不善法种本已断。云何罗汉于心相续不正思惟。岂复更生云何诸惑而得生耶。是故依出世道已断惑。尽知无退失。已说因缘复有二种。一者生因。二方便因。次第缘者。诸心数法以从次第余法得生。此心数法为生者缘。一是识为识作次第缘。亦名为意。亦名意入。亦名心界。是次第缘复有二种。一者已灭。二者移处。缘缘者此五种识色等诸尘是其缘缘。复于心识内外诸入即是缘缘。是说缘缘。亦有二种。一者猗证。二不猗证。增上缘者。眼等内入俱时生者。与眼识等为增上缘。能使心作。于境界中若俱时生。心心数法更互为缘。过去所造善不善业。于未来世如意不如意所生果报为增上缘。田水粪等为诸种子作增上缘。世间工巧及诸杂业。此等诸智为增上缘。是增上缘复有二种。一者不离。二者有空。此因缘者。能生者是。所余缘者唯能增长。以是行缘俱时同至。是行种本能生诸行。是故诸行不俱时生。以依四缘了知十因。如菩萨地。如佛所说。缘过去行而心得生。缘未来行亦生于心。若过去行及未来无。何法为心而作境界。言因此境佛说生心。以是此心即无为境。问曰。若心境无。是佛所说。正分明者。因双双对诸识得生。双双对者。眼色耳声乃至心法。此正佛说。云何不妨。答曰。此是法尘不为五识而作境界。佛说。是尘即名为法缘心缘法。夫言心识以方便生。佛说此义复何所为。以此心识不取过去识以为境界。亦不取未来诸识为境。去来诸识法尘不摄。若有法者有法相聚。若无法者无法相聚。以此心识随有法者有法义取。随无义者无义法取。以是义故。信知诸识无者为境。若以此识不取有无二种境界。即不能取一切法义。若有说言。心识不取有无为境。是人即妨悉檀多义。问曰。此识若取无法为境。识亦应无。答曰。去来故无识。现在故有。问曰。眼识不得取无为境。心识云何能取无耶。答曰。三世境故。复应广说有五种义。以现心识取无为境。如佛所说。离内外入无有我义。是我无者非有为法非无为法。以是诸识是取无我为境界者。于有智人知总相法则无不信。此是一义。色香味触。离此四尘了不能得。殿堂辇舆饮食衣服及余众具殿堂等法。是其所无。非有为法非无为法。以是诸识取无殿等为境界者。于有智人知总相法则无不信。此是二义。是诸邪见诽谤一切。无因无果无缚无解。是诸法无。若随义理有此诸法。则非邪见。此实都无。于邪见人取无为境无不生识。此是三义。复于诸行无有常住。此无常住亦非有为亦非无为。而此诸识亦非不取无常为境。于有智人知总相法非不生识常无境识。若不得生于一切行不见于常无有义者。依正智慧则不生厌。无染亦尔。亦无解脱不得涅槃。若以此义一切众生诸烦恼惑永缚不脱。此是四义。诸未来行未有生义岂容言灭。然诸圣人于未来行亦无不观生灭之义。此是五义。以是义故。定知诸识取无为境。如佛所说。若过去业了无有者。则无有苦受乐受。此义何谓。于过去生已作已灭善不善业。为未来世受爱不爱果。是行相续业种所生。为此义故。如佛所说。有过去业复有二义。是诸人说不正因者。遮其执故。其有说言。有自在天梵释诸天自性神我时节微尘。言因此法众生苦乐皆悉得生。复为诸人说无因者。为遮其执故。有众多人。说言无因亦说无缘。为诸众生有净不净。不从因缘木石等物。或有尊重或有轻慢。现此事故。是故佛说有过去行。诸贤圣人不着此处。安乐而住此说何义。过去诸行生果故有。未来诸行为因故有。云何信知现在诸行三相显现。过去果故。未来因故。自相相续不断绝故。复依两义现此二法。谓于过去及未来行除实执故。若去来行其相实有则非去来。诸无见人谓去来无现在亦无。如是见等断此执故。如佛所说有去来界有现在界此义何谓。种子相续已生于果故说此义。是名过去。欲生之者种子相续。是名未来。现在诸种果未断者。是现在界。故说此意比丘。知于种子相续。是无量法非一种界。是名知界。何以故。从色等阴生老住灭。无更别法亦非实有。诸未来行遮实有故。无有生者断于实义。云何知耶。于未来生既自未生。云何能生生于他法。现世诸生亦不能生生于现法。此言生相。是诸行成。是诸行生。是诸行起。诸行现在。此明一义而有多名。离此多名复有生相。诸有智人不说此名以为生相。于此诸法各定种因何用别生。此生羸劣而是假名。云何知耶。夫有生者。即行生耶。能生行耶。若生自行能生行法。于有生者行法得起。是义不然。若能起者。是名行生。于一行中应有二生。谓能生者。诸行自生。此亦不然。如说生义余三亦尔。于现在因先所未有诸行起相。是名为生。不以先者是行异相。即名为老。起而未灭。即名为住是刹那生。诸行坏相。是名为灭。若此四法是有为相。何故佛说唯有三相。谓生灭住异。一切行法三世所现。从未来世未生得生。是故依未来世。是生起者是有为相。此未生故不可着处。已生之者于过去世悉皆已灭。依过去世。此言灭者。是有为相亦不可着。已过去故。现世所现是住之者。依于现世是有为相是可着处。以此住者亦复有异。多有过失。此是生者谁敢求之。如于吉祥不吉相随。是故住异合为一相。以是义故三世所现有为法相。若此三相是诸圣人之所思量。何故佛于诸阴中观起灭相依法而住。复更不观于住异相。生及住异。此两种相是起所现。是故生及住异。此二种相合而为一说。于起边故言观起而住。所余一相于第二分安置一边故。说此言观灭相住。复有别义。依此相故便证无染。为厌患故得证解脱。唯观二相是所思惟。以见无常于诸。行法故生厌患。所云无常。未生者生是名为生。生而即坏是名为灭。是名无常。生复多种。谓刹那生。谓受生生。谓起生生。谓别心生。谓不如意生。谓如意生。谓下中上生。有上生无上生。刹那起者。刹那刹那诸行生起。是名刹那生。受生生者。具缚及不具缚从处处堕。于处处中诸阴生起。名受生生。起生生者。从于婴儿乃至壮老。名起生生别心生者。依种种缘与种种受种种善等及种种道。若证解脱及未解脱。无量种心。名别心生。不如意生者。地狱畜生饿鬼于三恶趣受诸苦恼。是名不如意生。如意生者。于人天道受快乐报。下生者。生于欲界。中生者。生于色界。上生者。生无色界。又第一受胎是名下生。第二第三是名中生。第四受胎是名上生。又受诸恶果是名下生。诸无记法除起善果。是名中生。一切善法一切善果。是名上生。有上生者。从欲界处乃至无不用处。无上生者。非想非非想处。又有上生者。谓阿罗汉从于入胎未至最后。一刹那阴最后一念。名无上生。分别老义复有多种。何者身老心老寿老变异老阴老。身老者。发白齿落皮缓面皱乃至如经。身有诸相。心老者。与乐受应。变异生者。若以善心转为不善。于所乐物生爱着处复生变异。是处无果。是名心老。寿老者。日夜刹那罗婆牟诟罗过故寿转减少。乃至次第一切转促。是名寿老。变异老者。一切自在富贵荣华无病色力转减少失故。阴异老者。以生人天阴转增长。从此处没生于恶道下贱之处。名阴异老。又别一老缘。此一老前所说老而便得生。何者诸行刹那刹那所生异异。名别一老。分别住义亦复多种。刹那住相续住依缘住一心住如制法住。刹那住者。唯生时住。相续住者。随处已生诸阴衣食乃至寿尽。复外世器乃至劫尽。名相续住。依缘住者。苦乐等受善恶等法。各各缘现随是持住。名依缘住。一心住者。正定心人住现前定。名一心住。如制法住者。随处境界王领治化国邑聚落。于四种姓依先制事而立住止。名如制法住。无常义者复不一种。何者坏无常变异无常别离无常当生无常来至无常。坏无常者。诸有已生即便失灭。名坏无常。变异无常者。可爱行生不似前者。名变异无常。别离无常者。于可爱物分散别离。此三无常。于未来世是名当生。起于现世是名来至无常。受五欲乐不能自持。脱有零落爱别离至。思惟是事忧悲苦恼。乃至如经不肯厌患。于行法中诸外道辈。多所思惟是等无常。亦生厌离唯离欲界。于诸行法分生厌离。若诸声闻具足思惟是等无常。究竟厌离得证无染乃至解脱

决定藏论卷上决定藏论卷中

        梁天竺三藏真谛译

    心地品之二

略说生缘所摄。自因具足。是名为至。何者为至。似因略故因缘具足。是以得生。故名为至。如是选择知假名有。至若实有则有二种。谓生因有不离因有。若生因有。如未得法从前以来无至为因。岂义得生。若如是者。永不得生不离法因有。以是善法不善无记一时得至。复故碍法亦应共生。是故两因皆悉不然。复法生因各现诸缘所摄。自种如之因。即此种子故名为至。余别因缘在现前故。名离余缘。在此牵缘以此自在假名为至。此自在以诸人者诸法被生被灭。更乐现前速牵生缘。是故名至。略有三义。一者种子成就。二者自在成就。三者现前成就种子成就者。一切恶法诸无记法及生得善无功用生。此诸种子未有定破。圣道拔断诸善种子。未为邪见之所破坏。是名种子成就。云何知耶。诸法种子乃至未坏与不善法若现不现。如此等人悉名成就。以诸善法功力所造。有诸无记生缘所摄诸因具足。是名自在成就。诸现在法在于现前。自相故生。是名现前成就。何者命根依过去业。处处受身为业所牵。有量时住以此牵命。即名命根。又复命根分别有二。谓定不定。有随不随。有少有多。有后无后。有得自在有不自在。阎浮提人离其寿命。余有决定数。阎浮提中或寿无量或复短促。乃至十岁。郁单越人定寿千年。是处随命无余缘死余处不随于阎浮提寿十岁人。是名短促。有诸畜生。于一日中七死七生。乃至一日一夜非想非非想诸天寿命八万大劫。罗汉寿命亦复有后。若诸学人于现在世定入涅槃。诸凡夫人最后生身寿命有后。其余诸人无复有后。自在命根诸阿罗汉菩萨及佛能延寿命。其余寿命不得自在。何者众生种类似分。略说处处受生诸众生类。同界同道同生同类同年同姓。长短等行。以依此分是诸相似。是名众生种类似分。有诸众生依是界分各有似分。于一界中众生受生。以依五道各有似分。一一道中诸众生有诸众生依生分生。一一生生依类分生。一一姓生。有诸众生色声高广事业似分。有诸众生善恶似分各有似分。如杀生人共诸杀生。乃至邪见共邪见人。如离杀人共诸离杀。乃至正见共正见人。须陀洹人共须陀洹。乃至辟支佛其辟支佛。菩萨共菩萨。佛共佛。名相似分。一切众生皆是假名。云何众生似分而是实法。凡夫性者。三界见苦所断烦恼种子未断名凡夫性。又凡夫性复有四种。一者无涅槃性。二者声闻性摄三者辟支佛性摄。四者佛性所摄。离十烦恼无有别性。名凡夫性。何者和合性。因缘具足诸法得生。种种因缘种种法生。名共作因。和合性者。复有六种。受和合。入生和合。六入住和合。工巧智和合。净和合。相从和合。受和合者。因内外入及思惟等诸识得生。三种和合故触得生。因触和合故得生受。入生和合者。无明缘行乃至老死。六入住和合者。依于四食及以命根。工巧智相应业作具人力。是名工巧和合。净和合者。十二难得自他功力。相从和合者。如有一人为大国主如法治化。众生荷赖四海安宁。离如是分无别和合。字和合者。依法性相而立假名。依如是义是名为字。句和合者。已说依自相法善法恶法净法不净法选择分别以名合为句。是句和合。味和合者。名与句合。字义具足。是味和合。于诸略义悉皆是名。于处中义是名为句。于广说义称之为味。唯依于名唯得知名。不知于义。若依于句知诸法性。亦知于鸣不得知广选诸法。依于味身知诸法义。以此名身句味身为五学处得知假名。随方俗语立名不同。若于鸣中无处不同。耳相闻故。何者五学处。一者内学。二者因学。三者声学。四者医方学。五者世工巧学。何者起生诸行因果相续未断。是名起生。复次起生有种子生。犹如诸法有种现起。复有起生种子果生。如有种子未灭种本现前起生。如菩萨地有名流生四非色阴有色流生。如内外十入。于法入中无作色生。有逐流生如次第法。十二因缘有逆。次第十二因缘以此起生即是相续无别有法。何者齐法依无始时各各分齐种子因果法不相杂。诸佛出世及不出世。法常然故有灭分齐犹如逆顺十二因缘有正法齐。谓如五阴及十二入十八界等无有增减有受分齐。如三受法亦无增减有住分齐。谓一切身乃至寿命诸外法。住至一大劫有变分齐。如诸众生已生色界退生欲界有限量齐。如诸众生生有色处身有限量。外法世界亦有限量。何者应尔为说诸法为安诸法为正知法。此中方便即名为应。分别有四。一者见应。二者因应。三者论义应。四者法尔应。如声闻地后当广说。何者迅疾诸行。生灭迅疾不住有行迅疾即是生灭。有力势迅疾。谓地行象马及以人等。又空行天鸟诸夜叉等。有鸣迅疾如声出时。有水迅疾如江河流。有火迅疾如大猛焰焚烧干草。射迅疾者。如人善射箭去迅速。智迅疾者。谓诸圣人简择修行速知诸义。通迅疾者。谓大神通运身速疾。意速疾者。依心速疾神通迅速。何者次第各相对。诸行相续依次第生。是名次第。有生次第如十二因缘。有灭次第如逆因缘。无明灭故乃至老死灭。老死灭故忧悲苦恼一切皆灭。又有道俗法用次第。于晨朝起料理身体。着衣营务嬉戏试艺。洗浴涂香着华严身。食诸饮食眠卧消息。是俗次第。何者道法次第。亦晨朝起次第如前。乃至着衣持钵次第乞食。得饭便还安坐而食。洗手拭钵净足坐禅。讲说读诵作善思惟。于昼日中经行立坐。此二种事治心障治法。于夜半时眠卧消息。于后夜分速疾而起着衣等事。于大众中随其大小。恭敬问讯依次第坐。如法行筹并受卧具。有生次第从少至老则有八时。又有见谛次第。先观苦谛次集灭道。又九定次第。又学次第。以依戒学生于心学次生慧学。何者名时。依日出入识时分齐。依诸行法有生灭故。立三世名以名为时。如年时节一月半月日夜刹那罗婆牟忽多过去现在未来等法。此名时者。离诸行法无有别时。何者名数。数诸异法令知多少。是名为数。复次数者。从一二法乃至多数。复至数后名阿僧祇。以从此后无复数名。何者种子。离诸行法无别种子。以此行法如是起生如是进入。是名种子。亦名为果子果别异不可杂观。何故不杂。依现在果知过去因。依现在因知未来果。以此因亦名为果。因果不杂如谷麦等芽叶枝节未开已开。离此诸法无别种子。如是观察一切行法是种子相。已说断坏恶法种子。何者断坏善法种子。一者恒事恶法与善相违断坏善根。二者着邪见故。邪见重故。亦断善根如诸外道。三者以邪见故诽谤一切作五逆罪亦断善根。四者已断不善恶法种子善根即断。如阿那含登地菩萨。复次一切诸法种子以为一聚。与果已竟而至于果。谓软中上。复更略说诸种子相而得在于阿罗耶识中。一切诸法着妄想习。以此习气亦名实法亦名假名。从此诸法无别有相无不别相如真如法。复次习气遍一切处诸恶罪法。若依此习而摄一切诸法种子诸出世法。何者为本而得生耶。诸恶法种不为其因。此出世法真如境界作缘得生。若不取习为缘得生。何故演说三涅槃性。复说有人无涅槃性。有如此义一切众生有真如境而为缘生障无障。故解脱各异。有诸众生永障种本不能通达真如境界。说此众生无涅槃性。有诸众生不依此义说涅槃性。诸智慧障永依于本亦非解脱为障种本。明于此义有声闻性辟支佛性不如前义。是名佛性。是故无失说出世法所生相续。依阿摩罗识而能得住。以此相续与阿罗耶识而为对治。自无住处是无漏界。无恶作务离诸烦恼。何者为作略说有三。一不净法。二者善法。三无记法。不净作者。是则十不善业道身口意生受行不离为增上缘。此身口业使他令知。是名不净。作善法者。离此十恶而不修习此身口业使他令知。是名善作。无记者。以此威仪如诸工巧此身口业。是无记作。复有诸业不令他知唯自发心。以是心中觉言语依善不净无记等法。是名心作。唯身生起此无异法。是名身作。非是动转。何以故。一切行法刹那灭故。故无至处。唯是言语是谓口业。如是心行此思惟法。即是心作。何以故。刹那灭故。从此至彼。是义不然。离行生起更无余业。眼耳心等亦不能取。是故作者亦假名有。若有诸人随恶眷属。彼处得生渐以长大。其自思惟。依此事业我得寿命。如是业行乐忍而行。是时得知其无覆护。依不善根无诸覆护。所摄勇猛甚深不正思惟。势力摄故。是人即得大不善根。此人未得杀生不善。余不善道所生不善亦未得证乃至未作。从作之时随其有犯。逐业随时复生不善。犹如前人生恶友处。各随其类增长恶业亦复如是。乃至不离无护思事则无覆护。以日日中思增长故。作是业故。诸不善根皆得增长。以安邪思不信懒堕喜忘攀缘恶智共行。使习是业使作是业。从此向后有种本故。以习作故。于相续中是现世者名不覆护。以依舍因乃至未舍诸不信智。此中恶业不信后世有恶果报。即名不信。懒堕者。此恶法中随意而住不能舍离。是名懒堕。喜忘者。诸有过失智人所谤如实不现。是名喜忘。攀缘者。心恼散乱此心相续恒生不住。是名挛缘。恶智者。以此颠倒谓恶为善谓善为恶。是名恶智。以作恶戒为增上缘。此不善等诸不善法。恶思为伴而生不住。是恶戒不依前者如实道理。则名善法。如此分别若有诸人堪受戒者以授善戒。如有诸人从他得戒亦从自得。有得自戒。不从他得。唯比丘戒。何以故。诸比丘戒皆不可得一切人受。若比丘戒不从他受。堪受戒者不堪受者。以此一切若自能得出家戒者。如来法制便不得住。法律制戒正说难知。是故比丘戒法非自受得。若有诸戒离比丘戒自能得者。何故从他而受此戒。守护禁戒有二种分。自羞羞他。欲自犯戒则羞于他。如此禁戒从他而得。自羞者。我自护持无有缺犯。是名得戒。有自羞者。则有他羞。有羞他者未必自羞。是故自羞于法力胜。是自受者若善护持。所生功德无有差别。若从他受有此别异。应先发心亲觐请师。作礼等事威仪如法。思惟言说令知所作。名身口意业作前方便。若自受得唯是心作。是思离者则非覆护。信等五根以取思离为增上缘则名覆护。复受持戒有百种相。以从十种不善道法依受远离。不杀生中唯受一分。乃至邪见亦受片分。是名十种。不杀戒中所受多分乃至邪见。此别十种。复别十种。不杀生戒而具足受乃至邪见。此更十种。若依少时一日一夜。若半月日乃至一年。受离杀戒乃至邪见。是名十种。若依多时过度不至。寿尽受不杀戒乃至邪见。复是十种。乃至寿尽受不杀戒乃至邪见。更别十种。已受不杀。见生不杀乃至邪见。是名十种。自受善戒更劝他受。此更十种。以善言辞赞叹禁戒。此复十种。已受不杀乃至邪见自生欢喜。是名十种。此十十种受戒相貌合成一百。所生功德随戒多少。以此覆护复有八种。一者能生覆护。二者摄受覆护。三者守持覆护。四者治犯覆护。五者软覆护。六者中覆护。七者上覆护。八者清净覆护。未受先思我今欲受离恶禁戒。是名能生正受之时。是名摄受。已受戒竟思离诸恶乃增上缘五根所摄。时共种本间间善持。如所受戒守护思惟。近恶友故若烦恼故生起恶作。即自羞惭则不缺犯。莫令有失应堕恶趣。是名守持。若喜忘失造作诸恶速疾生念。以此过失发露忏悔惭愧自改。后不更犯名治犯相。若复善道少分之中少时受持。唯自守护不劝于他。善说言辞不为赞叹。见同善行不生随喜亦不喜乐。是名为下。若复多分善持禁戒不至寿尽。己自持戒又劝于他。巧说言辞不为赞叹。见同行善不生爱乐。是中覆护。若复具足受持禁戒。乃至小罪皆悉不犯。是名为上。若以依此清净禁戒无恨心故。乃至初禅破戒根本即永断除依舍摩他故。是定覆护。如初禅中第二第三乃至第四亦复如是。复别有异此破戒本远离对治所摄定道甚深断除。此是第一清净持戒。依此净戒依定覆护。得见真谛即证阿那含果。于是时中诸破戒本悉永断除。依未来禅若得初果。于是时中恶道生本皆悉断除。此又有戒皆悉清净圣人所乐。以此第二清净禁戒。是名无漏持戒覆护。此无漏戒得罗汉时。对治净异于灭惑果。此八种戒已合为一。更分为三。一者受行覆护。二者总持覆护。三者清净覆护。前三种戒是受行覆护。次有二种是总持覆护。下中上戒是方便行。是禅定戒及无漏戒。是名清净覆护。此三覆护次第转胜。何故如来说此三戒。谓比丘戒优婆塞戒及以八戒。三因缘故诸受化人能离恶行复离贪欲。此中佛说是比丘戒。有诸受化唯离恶行不离贪欲。此中佛说优婆塞戒。何以故。在家迫迮生烦恼处恒被系锁。具足戒品难可受持。有诸受化恶行贪欲皆不能离。是故如来为说八戒。何以故。此受化人二不能故。为前二戒而作因缘。其自思惟不堪重禁。此前三分现离恶行。后有四分现离贪欲不淫。一分现。二处离。比丘戒者四分义摄。一者受具足分。二者随具足戒受制戒律。三者护他心戒。四者具足守戒。受具足分者。白四羯磨如受大制从初依此。比丘禁戒是名比丘受具足分。从此向后随比丘戒于波罗提木叉谓正命等。此一切处恒持覆护。是名随具足戒受制戒律。有此二分威仪具足。是名护他心戒。威仪行处如声闻地。后自当说。于小罪中见畏不犯同于重戒。若有犯者皆悉发露。是则名为具足守戒。依于五力得生四分。为有信力解脱戒满。依精进力具正命分。依于念力守护诸根。依于慧力因缘分满。依于定力四分具足。何以故。若无五力则无四分。有三分摄优婆塞戒。何者为三。一者他所贵重离破坏分。二者有犯过失改悔清净。三者受持不破不夺他命。不盗他财不得邪淫。是名初分。远离妄语是第二分。远离饮酒是第三分。又五分摄于八戒。何者为五。一者离破坏他。二者离坏自他。三者有犯改悔。四者为不失戒忆念护持。五者念分不散。离于夺命及离偷盗。是名初分。离于淫欲是第二分。何以故。远离淫欲不坏自身。自妻妾故不坏他身。离淫他故离于妄语名第三分。次离三处是第四分。何以故。当习歌舞华香严身高广床座饮食非时。渐渐习知观身空无我。受此戒忆念不犯离于饮酒。是第五分。何以故。恒自忆念我今有戒。以依此分醉酒狂逸都不得发。比丘尼戒式叉摩尼沙弥沙弥尼戒。此等悉属出家戒故。依比丘戒而得此戒。优婆夷戒者属在家故。戒相似故。如优婆塞禁戒无异。何故佛制诸比丘戒亦沙弥戒说此二部。比丘尼戒又说三部谓比丘尼式叉摩尼沙弥尼戒。以诸女人多烦恼故。次第应受比丘尼戒。是故佛制比丘尼戒说为三部。若沙弥尼住于小戒。依次更受式叉摩尼戒。若能得住式叉摩戒。戒品转多不得速为受具足戒。决须二岁学行六法。若乐住此便授具戒。如是多时渐持小戒。次第转久能持具戒。何故沙弥戒中制捉金宝八戒不遮。以此沙弥住出家戒。出家之人而此二品极不相应。谓五欲乐严身嬉戏。随意放逸二者用举陈宿遮前品故说离三种。谓歌舞作乐香华严身高广床座及非时食遮第二品离捉金宝。以此金宝一切陈宿为作根本。从一切物以此为胜。何故沙弥歌舞严身分为二戒。于八戒中合而为一。于出家人不相应故重制为二。于在家人非不相应轻故作一。脱若有犯唯一忏悔。若出家人犯此二戒应二种忏。何故黄门及不能男。不得出家受具足戒。此黄门等若作比丘能作女罪。作比丘尼摩触身故能作男罪。此二种处不堪住故。不得出家受具足戒。以此黄门及不能男。多烦恼故烦恼障故。不能发此正思惟力。依于此力数数思惟。精勤修习清净梵行。何况能得过人圣法。是故不得出家受戒。何以故。难得善人生于是处不可分别。何故黄门及不能男。乃受三归及于五戒。亦不得名称优婆塞优婆夷者。亲近比丘及比丘尼。名优婆塞及优婆夷。此黄门等善摄诸根。若比丘比丘尼等亦不可得常相亲近。比丘比丘尼独处屏覆不得亲近。及按摩等皆不得。如优婆塞等亲近比丘故不得称名优婆塞。此黄门等若善持戒得福皆同。何者非戒非戒离前所说戒及非戒。随所造作善不善业。从身口意以此一切可知非戒及非非戒。以是禁戒自可受所从他受。此两种戒所生功德有差别。不受戒之时若心意同亦同护持生福无异。几种因缘不得具足比丘禁。欲得不得略说有六。一者心破坏故。二者身根不具。三者人根不具。四者断善根故。五者系属他故。六者护他心故。若王缚录怖畏贼难。负他财物畏不得活。作是思惟。我今苦恼难得活命。为我在家有是等苦。诸出家人安乐得活。是故我今出家入众。现同行道得活不难。依此思惟便即出家。为怖畏故受持禁戒有处律制。莫令比丘知我犯禁。众僧和合驱逐出众。其心坏故。故非比丘具足禁戒是名心破坏故。复更思惟在家难活。若其出家资身为易求生不难。及至尽寿得修梵行。亦如他人修行不异。如是思惟即便出家。如此出家非破坏心。虽得具戒而非清净。若瘿癞瘘狂痟等病。如遮法说。是名第二身根不具。是破坏身若得出家。不能敬重供养师长。如是不能供养于他。便复受他清净梵行师友信施衣食卧具。受此重施不易可销。复亦不能增长善法。先所修善并皆退失。是故身根不具不得出家受具足戒。若是黄门及不能男。人根坏故不得出家受具足戒。如前所说诸因缘等。不能男人有三种异。一者具足不能。二者有时非时。三者毁伤损害出生以来本无男根。是名具足不能人。又半月能男。谓前十四日不能。唯第十五日能。又使他摩触则能。不触不能。又见他行欲则能不见不能。是名有时非时。又复刀杖伤损病坏堕落值毒触火咒术所断。先有男根后则失坏悉不能男。是名毁伤损害不能男人。一者本是黄门而不能男。二者本非黄门而不能男。三者本是黄门非不能男。使他触身则能生乐。是名人根不具。断善根者。作诸逆罪污比丘尼破内外道。贼住种种不共住无住。坏善根故而不得受具足禁戒。何以故。是人不羞于自他故。不净染故。无惭愧故。善法损减。系属他者。谓是王人阴谋王家王所识将负他债息。及他人奴他家使人。荷任他债自身质债。父母不听。系属他。故不得出家受具足戒。护他心者。谓诸化人护他心故不得授戒。何以故。诸龙化身以为人形。求欲出家欲闻正法求受具戒。若得具戒。眠卧之时还复龙身。睡眠逼故。已成比丘言是比丘。诸阿监弥诸优婆塞参承修讯便见龙身。于诸比丘皆生疑心。谓诸比丘并非实人。谁敢供养诸龙诸鬼。护他心故不受具戒。此六因缘不得出家受具足戒。若离诸师及以和上。戒不具足僧数不满界不清净。亦不得戒。几种因缘优婆塞戒而不得受。略说有二。一者心破坏故。二者人根不具故。心破坏者。永不得受一切禁戒。不能男者。得受五戒而不得名为优婆塞。如前所说诸因缘事。复次八戒者。心破坏而不得受。随从他故。为利养故。心不清净口说受戒如前所说。有诸因缘不得受戒。离此诸缘得三种戒。复几种因失比丘戒。一者舍戒。二者犯重。三者失根及二根生。四者断于善根。五者命终。若已善受诸比丘戒。五缘则失佛法灭尽。未受戒者欲受不得已受不失。何以故。于是时中末世已至。无有一人心不破坏而求受戒。何况能得四种道果。优婆塞戒生悔心故。善根灭故。寿命尽故。佛法灭故。如比丘戒五戒亦尔。复次八戒。至明晨朝又心破坏。是日命终则失八戒。何者无想定离遍净欲。未离上欲。作心思惟。谓是解脱唯断于心及心数法。如是寂静名无想定。此是假名非别有法。略说有三。下中上修。以下修故。于现世退。不能速疾还更修习生无想天。身光狭劣不同诸天。寿命不具中间得退。中修者。若退失时。还习速得生无想天。光明转胜寿命未尽。亦得中退。上修者。勤修习故不得退失。若得生彼光明寿命悉皆具足不得中死。所以者何。生得心灭数亦灭名无想生。何者灭尽离不用处欲。未离非想非非想欲。作心思惟求寂静处无受无想。于受想中而见过患。即生厌离。受体四禅想体四空。于八禅定悉皆厌离。正灭于心及心数法。即入灭定。灭六识故是名灭定。非灭阿罗耶识故。此亦假名非实有法。亦有三种。下中上修亦如前说。唯不说生。以诸学人得入灭定。谓阿那含名身证者。无学人得入灭定二分解脱。于无想定学无学人并不修。何以故。以诸圣人有所生处不见解脱。圣人知见不生彼处。离于此处别有胜处。以生此处永不能得修习善法。是障难处。何者虚空唯无色处显现虚空。何故空处。无一切色说名虚空。是故假名说空非是实法。何者非数灭以因缘自得现前故生诸法。离此生因余法不生。究竟寂灭名非数灭。是时诸法即不得生。过此生时不复更生。未来未起不得言有。若未来法因缘应生。和合则生为谁所遮而令不生。名之为常。是故无别一法名非数灭。是诸学人已见真谛卵生湿生郁单越生无想天生。女人黄门及不能男无根二根。复有爱愿不更得生。名非数灭同一种相。何以故。是诸学人复生爱染能作生业。无有是处。未拔种本故业受生。何以故。是诸色心不相应法。从于生相至非数灭。于心法中非是心数。若于色中非是可见非不可见。以是义故。名不相应色。及不如意及有舍处名色分别。声分别者。众生数因非众生因众生非众生因。事分别者。是口所作。住分别者。如前说。香分别者。谓根茎皮心叶华果是香分别。香味触中无事分别。住分别者。如前色说。味相分别者。谓甜苦等住亦如前。触有多种分别如前。第三境者。于十方中即可得知。第四境者。三世分别。第五境者。实不实取分别可知。第六境者。于一边处得取具足。如是自分诸有色尘明了分别。何者思惟。能生识者于共于诸根。不破坏者。与明了尘同兴发心。如此思惟能生诸识。是名色阴境分思惟。杂思惟者。于欲界阴入住是处色界色生于此身。云何上界诸色与下界共别处而住不别处耶。答曰。不别处住犹如沙水。是名色阴杂分思惟色阴分别思惟究竟

决定藏论卷中决定藏论卷下

        梁天竺三藏真谛译

    心地品之三

如经中说。六种胜智。谓阴入界四谛因缘二十二根。如是胜智云何分别

郁陀南

  相义及分别　　次第摄受依
  依此六种法　　了知阴入等

何者色相。谓十一种。眼等及触。法入中色有。依四大有是四大。皆是碍相。何者受相。谓有六种眼等触生。又三种受有二种依。谓色及心依色身受。何以故。五根色故。若根有色依眼等受。是名身受。何故五根不名为身。答曰。根自相故用各异故。若异相故不同身相。是故根受不名身受。答曰。不离身故。有眼等根。依根生受故。名身受。此说无过。若说不离言无过者心不离身。是故心受亦名身受。凡一切受皆名身受。答曰。身与诸根不得相离。心不如是。如有众生生无色处离身有心。是故根受得名身受。心得离身故名心受。是一切受得有二名。谓一切受皆是用相三种因缘。一者是尘胜力。二者思惟胜力。三者自在胜力

何者想相六种如前。又六种生有相想无相想小想大想无量想无用想。此一切想得二种异。一者世间。二出世间。缘于欲界是名小想。缘于色界是名大想。缘空识处名无量想。缘无所用处是无用想。此欲界等是名有相想。非想非非想是无相想。出世间想。谓诸学人及无学人。是一切相分别想相。何者行相。如前六种复五种事。一者为与诸尘。二者得共俱故。三者有为远离。四者起烦恼业。五者心得自在。略说三种善不善无记。一切牵果。是名行相

何者识相。亦有六种所谓眼识乃至意识。是识相分复有三种。一者用分。二者缘多分境。三者住诸异分。用分有三。境分有六。住分亦三。如此等分。分别十八取尘为相。是五阴相

何者阴义。色者过去未来现在。乃至近远一切诸色。总名阴义。如是等色乃至于识如是总摄一切和合皆名阴义。何故佛说和合阴义。以此诸阴唯是和合无有实我。是故佛说名为阴义。何者色阴。分别有六。一者随类。二者随相。三者识依不依。四者离识不离识。五者想尘。六者色究竟处。此一切色所谓四大及依四大。是名随类。色相三种。一者净色。二者净尘。三者心尘。共相者皆是质碍。一切诸色皆是共相。何者识。依不依是众生数。名之为依。复有色处。识初入乃至生受。是名识依。离如是色名为不依。何者离识不离识。色不离说名自分。共识。同用故。又复离识名不自分。相似相续能生于触名为自分。虽相似相续不生于触名不自分。有三种想名为色尘。一者色想。二者碍想。三者种种想。色想者三相。一者显现色。二者碍色。三者聚色。此三相尘如次第故取青黑等名为色想。妨人游行名为碍想。取于男女田宅等相名种种想。尘色色究竟者。略说有二。下界堕欲界色界业增上缘。若四空处。依于作业则无有色。依自在定有妙光色。何故一切色种得自在智。修现定故是妙定色。何者受阴。分别有五。一者受类。二者自相。三者生处。四者思惟分别。五者灭处。何者受类用处法。何者自相苦乐不苦不乐。乐受者生乐住乐坏苦爱着因缘。苦受者生苦住苦坏乐离爱因缘。不苦不乐者行苦故苦解脱爱缘。此一切受皆悉是苦名受共相。何者生处。从十六触受阴得生。何者十六。谓六根触碍触依言触苦触乐触不苦不乐触欲触嗔触无明触明触非明无明触。依根取尘名六根触。依尘思惟生于碍触。依心出言名依言触。三种受触依缚依解。欲嗔痴触则依于缚。明非明无明触依于解脱。何者思惟分别。一切诸佛八种分别几种受。何者受集。何者受灭。何者受集行道。何者受灭行道。何者受味。何者受过。何者受灭处。生相分别有三种受。有触集故则有受集。广说如经。是八种相分别受阴。一者自相分别。二者现因分别。三者因灭分别。四者现在未来分别。五者受灭道分别。六者浊用分别。七者清净分别。八者受灭处分别。名分别。何者灭处。初禅灭忧根。二禅灭苦根。三禅灭喜根。四禅灭乐根灭尽定灭舍根是名受灭。处分别

何者想阴。分别有五。一者随类。二者随相。三者颠倒。四者不颠倒。五者决定。取境别相能生想法是名随类。随相有六。已如前释。取境虽异皆想共相名为随相。凡夫无智无明覆心。起邪思惟。依二见半出四颠倒。依于无常谓以为常。是修常想。为依见取出二颠倒。谓苦中计乐。不净计净。依于身见出我颠倒。于无我中取法我相。复有在家名心颠倒。如出家人名见颠倒。分别又有异想颠倒。于四种类生邪修想名想颠倒。于四种类生决定智起信分别名见颠倒。何者不颠倒想。诸有智人无有无明。起正思惟。于无常境见于无常。于苦见苦。于不净境见于不净。于无我境见于无我。起正修想名不颠倒想。于此四种能起信乐是名心不颠倒。于此四种正见正知名见不颠倒。是名想不颠倒。何者决定。分别有五。一尘决定。二用决定。三者假名决定。四者不实决定。五者实义决定。取尘自相取似相是尘决定。于尘生受取别异相名用决定。依于自他是名是生是姓等相。随世俗语作想境界是名假名决定。颠倒取尘名不实决定。如实取尘是名实义决定

何者行阴。分别有五。一者谓尘。二者别住。三者不净。四者清净。五者事。六种思聚胜力牵果是名行尘。生老住等不相应行和合积聚名别住行。何以故。各各异故名别住行。三毒等行名为不净。信等善根名为净行。如前五种。知与尘等是名为事

何者识阴。分别亦五。一者入处。二者不净。三者依故。四者住故。五者多种。欲界中识依外色入名为入处。色界净天依于自阴是为名色。识入处则有二入。四空处识依自四阴说名入处。是入处分别。此凡夫识依二种乐生于不净。依现尘用乐故不净。依于未来生老等苦乐故不净。名不净。识依有六种。是生识依。眼等六入识依得生故得六名。譬如依糠火牛粪等火。亦复如是。是名依故。分别四识住处。如经中说。阴依境界为心住处。有色中识住。广说如经。乃至我说识不至东。余方亦尔。于现世中不乐涅槃。自至寂静清凉得梵自在。我说如是此如来说经中所摄。四识住处后当广说。复略说三有缘住处究竟有缘住静。佛说此三显四识住。烦恼境类烦恼依住。是说名为烦恼执着。以此二种名执着境。一者是境。二者取。境者烦恼缘爱言是我物即是执境。我见烦恼思惟是我。又有四种贪等身结。是业因缘即是取境。如上所执是心住处。何以故诸烦恼境依心得住。犹如湿衣诸尘易住。如肥田中种子增长。诸凡夫人未得厌离。爱欲对治受所牵识。未来世中即得受生悉令具足。乃至未舍凡夫之性。此所受生令具足者是名能住。此相续生是名生死所。余如前说于住缘。如此一切名有缘住处。有色界中诸识来去。无色界中说心没生。此三处住乃至寿遣。如前二处得生增长及于壮大。如是量故得知诸识住处究竟。若有说言异于此义。唯文字殊理则无别。何以故。文字义别无分别故。若有问者则不能答。即便思惟。我云何对脱。若有答。后更思惟我实愚痴。自不知解而答他问。是故智人从一切色乃至行阴爱等诸结暂伏故无能生业结。有智慧故根本永尽。何以知之。诸在家人依贪嗔结则能作业尘味因缘恐憎因缘。于出家人戒取实结而能生业。戒取烦恼与贪同相愿求生天。实结烦恼与嗔同相故谤涅槃。如此诸结依于心地从思惟生。此诸烦恼对治灭故。欲取色等以为境者即得永灭。以此灭故。诸识有惑于四住处则不复住。诸对治识实清净故。如是得知住处寂静。以缘灭故。于未来世当生具足应得相续不复更生。是名有缘住。静阿摩罗识对治世识甚深清净说名不住。复次此识不为缘生。空解脱门善修习故不能生业。无愿解脱门善修习故则能知足。无相解脱门善修习故住于不动如前四义得正解脱。观行于尘于我我所无所取着。是故色等诸尘灭坏心无渴爱。如此诸相心极清净。识清净故不自灭坏。亦复不为他缘所灭。无相续故。于十方处不更入生。于命于死无贪欲故。说无求欲。心譬如树受喻如影。于时二无。是故无树。是故无影。世心灭故。说现尽灭。是无漏心学解脱故。前次第说得寂静。无学解脱故得清净。四余灭故得梵自在。问何故不说识识住处。答曰。言不自相故识得不净。何以故。如来说心自相清净。四处不尔。一切烦恼极不净故。知贪欲等微细难见。色等不尔非烦恼因。不如色等无有众生于一识处而起爱着。如于色等。是故佛说识非住处是名识阴住处分别。多种分别者此说有三。一者有欲心无欲心有嗔无嗔。广说如经。乃至未得解脱及正解脱。此如来说则名第一。是离分别界分别故。于欲界中心有四种。有善不善染污不染污。于色界中心有三种除去不善。无色亦尔。无漏有二。谓学无学。欲界善心分别有二。生得学得。不染污四果报威仪工巧变化。欲界变化一种生得。如天龙鬼无修慧果。于色界中无有工巧。无色界中但有果报。善心如下登高是名第二依界分别。又有异心多种分别烦恼种故。欲界中五。苦集灭道修道破故。色无色界五种亦尔则有十五。及无漏心复有十六。是名第三灭故分别第一是离。复更分别三品助分为三摩提。一者使动。二不使动。一不得定。二者得定。一不正净。二者正净。于第一品。有染心人欲等障心。又于一时有善心人无记心人欲等不起。如是分别有欲等心无欲等心。于第二品。或复有时依内于定安心一处。境念灭故而于五尘心生散乱。极令没故懒堕。覆障。为灭懒堕。于喜乐境不正安故一时浮动。正取境故心不浮动。沉没浮动为烦恼障心不寂静。沈等灭故即得寂静。正思惟故得根本禅。是名心定离前定相。是不定心。至究竟道是故正修。至灭究竟故正解脱。离前二相不正修习不正解脱。取诸定相知第三品。是名识阴分别。何者说阴。次第有八种阴。一者生作。二者治道。三者染因所作。四者住作。五者分别作。六者如处作。七者如粗作。八者如器等作。何者生作。依根依色生于眼识。依意依法亦皆如是。如次第经。前说色阴心数所依后说识阴受等心数在于中。说是名生作次第。何者治道次第。除四颠倒说四念处。于色不净横计为净说身念处。于受计乐说受念处。依于想行无我计我说法念处。依心无常横计为常说心念处。何者染因所作次第。男见女色起于爱染。何故受味爱故。受味爱者依想颠倒。想颠倒者依行烦恼。行烦恼者依于识阴依于根尘。尘用生受取多种尘。是名为想。现世尘用生诸烦恼。名之为行。依诸烦恼生不净识善不善业于未来处生等苦故。更得不净说识在后。何者住作次第。识住四处。一者色。二者受。三者想。四者行。何以故。欲界中色是色住处。于欲界中具足色故。于色界中说为受住。何以故。受显现故。于三无色说想住处。何以故。想显现故。于第四空说行住处。何以故。大思现故八万大劫。是思果故说住四处。是名住作次第。分别作次第者。以色阴故见色听声则知他人。以受阴故心有高下生于苦乐。以想阴故知名生姓。以行阴故分别愚智。以识阴故阴中计我。是名分别作次第。如处作次第者。如在家人色受因缘起于斗诤。若出家人想行因缘亦生斗诤。识于二处并为因缘。如粗作次第者。色最为粗。六识境故。次明受阴。有三受故。男女等相相可知故。贪嗔痴等自可知故。离受想行识难知故。如器等作次第者。色譬如器。盛三受故。受譬饮食。损益身故。想譬鲑[鮥-口+虫]。取异受故。行喻食至。与苦乐故。识譬食者。用受等故。何者摄受。几阴几入几界几因缘分几处非处几根摄受。如色阴等乃至识阴。色阴一阴十入十界法入法界说于少分。六缘少分。于处非处亦说少分。根则有七。受阴摄受者。一阴法入法界。各说少分。一因缘分三缘少分处非处分根中有五。想阴摄受者。一阴法入法界各说少分三缘少分处非处分根则不摄。行阴摄受者。一阴法入法界亦说少分四因缘分五缘少分处非处。分根中具六三根少分。识阴摄受者。一阴一入七界二因缘分三缘少分处非处。分根中说一三根少分。如是阴入乃至于根。交互相摄。又异摄有十阴等诸法摄自种子。是名异摄。阴等诸法自共相摄。是名相摄。阴等诸法遍一切处是名生摄。阴等诸法乐受等住。名别住摄。如阴等一时俱起。名不离摄。诸阴等法在于三世。名为时摄。诸阴等法依处得生。名为处摄。诸阴等法五种等故。名具足摄。诸阴等法分分不具。名少分摄。阴等诸法如如相故。是名真摄。如阴至根合十六摄。又有三种摄一切法。色阴法界意入

何者阴。依几种色色阴得生。依几种处名摄阴生。依于六处色阴得生。一者依处。二者住处。三者卧具处。四者根处。五者根依处。六者如行能故诸定地处。识依七处名摄阴生。一者欲。二者色。三者尘。四者觉。五者观察。六者净行方便。七者清净。欲等四处说在家人。观察之处则是出家精勤持戒。净行方便者。得未来禅。七者清净得根本禅。为四种人说七为四。色阴分别后当广说依色分别

郁陀南

  物种及邻虚　　生形与相续
  业等刹那独　　境杂说有十

复有几物色阴摄眼摄根一物眼识所依。是色清净不离摄故。则有七物。谓眼身地色香味触。三界摄故说有十物。七种如前。及水火风。如眼物等耳鼻及舌亦复如是。离四种根身根九物。何以故。离四根故身得独生。复有声界。不久住故。是故别说有处有声。则有十一色等尘物分别。如细滑等至健皆是触入。依四大地制于别名。依四大净说于滑触。依坚生重不净。不坚生于粗轻为净。不合生于软触。依风水杂则生冷触。持因不具生于饥渴亦生羸劣。持因具足依大平等力饱触生依大不适。饮食难消生诸病触。依身转变四大不调。生于老触。命根转变四大不调。生于死触。依血不等生过患故。食饮毒恶有暂死触。地水相杂则生浊触。去来动转心起烦恼生疲惓触。离上因缘生消息触。四大调和身色不减。生休健触和合诸触。四大别住说有六种。谓净四大共不净。大坚共不坚。不摄及杂。不等平等。一切诸尘色等至触。以二识知自识心识。或同时知或不同时。于色界中现无香味。非无种本。无有抟食。离食欲故。香味二尘抟食摄故。鼻舌二识无现用故。亦有种本。色阴摄色则有九物。四大依大五尘。一切他色假名说阴。法入中色得有二种。物有假有依定自在。定中观色名为物有。是定果化定共识尘。戒非戒色皆是假名。又定尘色处果。定处色相应故。依于定大得生世法。依有漏定及无漏定色。是世法非出世法。何以故。有相思惟定因缘故。一切定人有能生色不能生色。犹如化生。若不思惟依前自在无有闇障。得净光明自然而至现在世。生是名物有思惟。思惟解脱力故得见诸色。色未现前是假名有。非出世定境界之尘出世定色。不可思惟欲色界色。云何为异色界中色。极大清净出光明故。极妙微细非下根尘。无有苦受过苦受故。不可思惟。住邻虚尘无妨碍故。随于心想得有粗细。是五种异。略说色阴有六种相。自相共相依依者相关相用相业相妙相。地水等大坚润热动四大自相。眼等诸根净是自相。是名自相。皆有障碍是色共相。四大是依依者五尘。是相关相。内入有色用增上故外尘得生多种。有一色聚得名坚触。有润有热有动有杂为内入用。是名用相。地等四大依摄熟牵。是事业相。复有别业后当广说。邻虚细色是名妙相。妙相三种。分破极细有生极细。自在极细分破故。邻虚极微生极细故。风等诸微至中阴色。色界中色无色界色自在细故得名极微。如佛经说。人生中住得平等心。修学自心庄严自心作自在心。共一处住不相妨碍。亦无恼害。若于此后生色究竟大梵自在。是其生处下阎浮提。为听法故。破一毛头作十六分。地如一分众天共住无相妨碍。名自在极微。如是色阴物种思惟邻虚色相几种分别。略说有五。后当广说。如经本地智分破故。种分别故。独自分故。共伴分故。无方分故。折色究竟智决定故。是邻虚分非身量故。是故邻虚不生不灭。是故色聚非邻虚生。分别邻虚有十五种。眼等五根色等五尘四大法色。自相分别是名独分。和合邻虚是共伴分。何以故。地等邻虚不相离故。何故有障碍法不离一处。共伴住故。不无障碍。如心大地合根相似故。诸事用生为相似业。增上缘故诸色和合。共为根用故得生起。若不如是非诸和合。眼识等尘根尘无用。是故共伴不得相离。有一种色或碍不碍。如中阴等乃至梵色。名共伴分。色究竟故。诸邻虚色无有方分。不和合故。和合诸色邻虚方分离一方处无邻虚色。如前所说五种邻虚。有五种眼。肉天圣慧法眼似佛眼。五种邻虚几眼境界。肉天二眼所不能见。余三眼见。何以故。唯色和合天眼得见内外上下前后明闇。不见邻虚。智分别故。邻虚色相非体别故。何故邻虚不生不灭可知可说。答具足和合前得生故。未至后时未得别体。于中灭故。譬如水渧。五种相故。邻虚思惟得知不正。于色和合以自体故邻虚得住。是为第一。不正思惟邻虚生灭。是为第二。邻虚色住共伴离伴。是名第三。唯邻虚中色和合住。是名第四。邻虚和合能生他色。他色得生异于邻虚。如是邻虚不正思惟。如正心人又取诸相。离前五种不正思惟。邻虚思惟正故。得起五种功德。和合色处邻虚分故。用行修道。于诸境界无疑惑因所作自在。是一功德。身见灭道渐渐增胜。是二功德。我慢灭道方便得生。是三功德。诸烦恼起起而暂止心得清净。是四功德。为空无相二解脱门便得修慧。是五功德

生者略说色物有五种生。依生种生牵生长生坏生。何者依生。于四大依造色得生。是故四大不名造色。是四大虚造色得生。此色和合是四大依。知色自相。于和合中得知有色。复更有虚不见自相。知无别色。略说得知有相非有相。若虚不见而言有者。譬喻得知。若有共依为得同物。为不同物义有二种。量故力故。若不同量应得小知。小知不得则无是义。若有力故依物不同。离自相故则无别力。此力不同亦无是义。是名依生。何者种生。从自种生譬如谷子。至多因缘芽肉等界地灰等生。遇诸因缘坚物得软。软物得坚。不热得热。热得不热。不动得动动得不动。如是好色及不好色有自相故。为自种子多种得生。是名种生。何者牵生。内入业增不动外物而能得生。譬如世器。宿业牵故内入得生。譬如为业五道入生外诸色物。三种业牵。一者如郁单越依报自生。四天王天至第四天。二者现业自牵外色得生如第五天。三者依他念业外色得生如第六天。是名牵生。何者增长生。具足因缘多种得生。谓色增长渐渐具足。水雨溉灌芽等增长。是名长生。离增长生是名坏生。造色生者。如多种物石磨和合不可分别。知别相故。不如麻豆麦等诸物一处积聚种别可知。何以故。犹如生相能生事用。为因增上造色得生。若一切行从自种本后便得生。何故依四大色说造色生。答四大增减。造色随大亦有损益。犹如眼识离于四大。不别生故。譬如大地。四大持故。如綖持衣。三因缘故。大地增减。方便能令造色增减。工用因故。业因缘故。定自在故。地大能造色增减。三种力故。何者三种。能破增力。能受器力。能生因力。水大者能润力故。火能熟故。风能燥故。是功用故。四大增减能令造色增减。前业相似诸四大生而得相似。是故造色似于四大。是名业因缘故。定自在者前至大地。后时能令造色增减。如能转变四大造色。以地为水以水为地。是定自在。又复略说五种因缘。异相四大使生异果。四大力故。功用力故。咒术力故。神通力故。业行力故。从于此后未至生处。于中阴中诸色和合。何因何缘自种子因能牵生业。是增上缘。以何义故有中阴生。云何可信。于后无依心心数法更生他处。不可至故。若如思惟喻于声响。是义不然。根乱故有如见二月。若如思惟无中阴者譬镜中影。是亦不然。面不减故。影譬不然。若复思惟如心取境无中间识。汝喻不然。心不去故。若是等譬破无中阴。是义不然。是故中阴实有可信是名色阴。生分思惟已生色阴。何者前去取于生处他色处生。答四大在前向受生处。四大依故。于处造色与大共生。四大处生处障故生。又复造色自相遍故。不离大故。能障生处。地等四大粗细可知。如次第说。地界持故能作事业得说有果。水火风界流烧吹等。是三大业。一切诸声唯生灭。于色和合不久相续。于内外二处得知依。一时生处处得闻悉皆遍满。如焰光至无前后无迟疾故。此风二种。谓动不动。轮者不动。空行则动。行于物者恒为随顺持于幻化。持幻化者则是不动。异此皆动。虚空界者。明闇所摄皆是造色。是名空界。离明闇等空界别相不可知故。亦是不动。于众生处有恒光明。有恒闇冥。此中不动。若异此处则名为动。依色和合清净虚朗光明所摄。不清朗者亦是色摄。形者。谓长短等。为是实法为假名耶。答此是假名。何以故。以聚集故。言此是处。言此是形。唯言语故。唯度量故。于八相中无别义故。若以看视于可视者。体性杂故。犹如车等。慧有异故。故说假名。复于法入禅定果色唯得有色。何以故。余香味触生因无故。无复用故。如是于空行风诸香等尘无共生者。以相近故风中有香。复于光中出轮外者。若诸大法及香等尘不复得现。禅定果色于法入中依禅定生。非四大生。似本色故亦说造色。不依四大。从色阴中有几种法。是可见者有障碍者。答一者二种眼识行处离法入色。所余诸色皆不可见。亦有障碍如是分者于色阴中是形。思惟相续者。于色阴中有几种流。答有三种。一者依。二者报生。三者长养。依者有四。报依长养依不等依体性依。报依者二种。一者前品。二者相续前品。是报等所牵故。次报后生是名相续。长养有二。满处长养相增长养。满处者。有色增长。饮食眠卧梵行禅定依此增长。复相增者。从依饮食依满处故恒受乐故。依时熟故。而得增长。诸有色法依此二种而得增长。于无色法唯相增故而得增长。欲界诸色四食长养。何者为四。思识抟触。前二种食未牵牵故是生因缘。后二种食是住因缘。触食是受阴等住缘。所余眠等亦能增长于色界色。不依抟食。不依眠卧。不依梵行。而得增长。诸有色根而随二流。离此二种无别依流。果报相续增长壮大有时得见。何故是报所摄不名长养。答此果报色如安置处。不增不减而得住故。养相续者。依报相续有违从故。有增有减。非根色者。皆有三流。心心数法依于依流依于报流。若依相增而有增长。于法入色无有报生。所余诸法如心心数而可得知。于欲界中诸内外色得果报生。于色界中离于香味。余者是报。复欲界中诸根不具亦是果报。于色界中诸根具足皆是果报。是声界者亦是果报。非是声故是名色阴。相续思惟

业者。色阴中摄。持界几业乃至风界。一切四大有五种业。于此地界开发转业。处所持业。为作依业。互相违业。平等增业。水界业者。流摄湿润违及增长。是为五种。火界业者。光熟破坏违及增长。亦有五种。风界业者。轻动令惨违及增长。是名风业。又有四大于造色生。亦有五业。何者为五。一者能生。二者与依。三者住处。四者胜持。五者增长。何以故。于开发生前得至故。是名能生。已得生者不离处故。是名与依。于增坏等相似性故。是名住处。如量不减能胜持故。是名胜持。令增长故。是名增长。何故眼耳尘色有善不善余尘不尔。答略说有三。软中上思。何者为软。思惟时思。决定时思。作业时思。为善不善身口业生。依极上思二色生故。是故业色有善不善。是故余尘不得如此。从色和合动摇异相为不异相。答说不异相。何以故。于此物处已生未生已坏未坏。动义不然。若动已生而后得动。无有自相。若未生者则无有动。若已坏者不能得动。未生同故。若不坏者则无行相分明别体。至彼因缘是义不然。是故动摇无别实有。是名色阴业分思惟刹那者此具足故。色阴刹那刹那灭故。何以故。行法得生灭无障故。此时生因即是灭因是义不然。何以故。一因异果不得生故。已生住因别相不现故。是故行法自灭不缘于地。行念灭无有障碍。如火等物为破坏因。若是思惟此义不然。共行火等同生灭故。不似前生。唯因能造。是火等事灭者灭因。是义不然。何以故。灭者与行不共俱故。灭若已有于行灭中。诸行相续已断灭故。以是义故不得共俱。灭者灭无为体能作灭因。是故不然。若灭为灭因。不得一时灭。作灭因前后无异故。诸相续法永应不生。若灭异体从灭异义。别有灭相即不可得。是故不然。复次若与火等灭伴能灭。作是思惟。是故心心数等诸灯焰等。有自体灭即应不有。是故不然。复次若力更互相成二能灭故。此是所灭。此是能灭。则无分别。是故不然。复次若二种法各有能分共灭具足。而此二种各有半能各有半不能。是故不然。如是等分于色阴中刹那思惟自体灭故。诸大等法遮灭因故。遮二种灭因故。何以知之。一切诸行心为果故。如心可知皆有刹那

独者。从诸四大造色别相为当不别。答曰。有别。何以故。见别相故。如此别相。谓异根境。余根大境。余造色境度不度故。从诸花香度于麻中等不度变不变故。如苏等中煎煮和合色味等变。坚等不然。是故知有别相造色。四大造色有于别相而体是一。譬如见株起于二智。取相有异而体是一。一者疑智境故。二者决智境故。是喻不然。虽有别相而作一体。于四大中亦应如是。何以知之。是诸四大各自别相。若定如是四大一体不应有四。此义不然。是故造色与大别体。是名独不独义。思惟境者。一切诸法色。所摄者几根几尘。答五色是根。六色是尘。云何根者诸尘成境。根不破者广说如经。于初地中几种因缘。诸根破坏不破坏者。答有二种。一者羸劣。二者皆失。不如此义皆是成根。略说有四变异因缘。一者从外缘生。云何知之。用诸外尘有逆从故。他损伤故。治损伤故。是名外缘。二者从于内缘。如在于内不善思惟。所生欲等诸根损减。从正思惟三摩提等诸根增益。三者业缘得生。如昔业缘有强弱故。诸可爱及不可爱。四者从自体生。一切诸根依自相故时损时益。复次心根破坏有几。答曰。有四。一者从盖所作。于五盖中随一覆心。乱心所作。乱心作者。如着鬼等。所求未得。如四空定及六神通。未得之时自谓言得。起邪心故。名求未得。未了所作。如未多闻及诸工巧依是四义心得破坏。复次云何色等诸尘于根明了。色不至眼于眼明了。不极微细见亦明了。及可见色无覆障者。有光明处又不过远。对眼前尘于眼明了。有诸众生于闇室中亦得了色。唯一种不可见色。如前诸尘肉眼不见。皆天眼见。声者不至无障。若有至者若光闇中不过微细。住于境处即得明了。香味及触至于自根住境处者。是诸天眼可见色者。虽复微细有障及远至住境处皆得明了。不住境处不能得见。复诸圣人圣慧眼者。一切种色皆悉明了。如初地说六种境界。云何解释。第一境者。诸色皆得入众生世及于世器。二者依三种性皆有分别。一者相分别。二者事分别。三者住分别。如是分别青赤白等。乃至广说。事分别者。作无作色。戒非戒色。非戒非非戒色。住分别者。是如意色及不如意及有舍处名色分别。声分别者。众生数因。非众生因。众生非众生因。事分别者。是口所作。住分别者。如前说。香分别者。谓根茎皮心叶华果。是香分别。香味触中无事分别。住分别者。如前色说。味相分别者。谓甜苦等。住亦如前。触有多种分别如前。第三境者。于十方中即可得知。第四境者。三世分别。第五者。实不实取分别可知。第六境者。于一边处得取具足。如是自分诸有色尘明了分别。何者思惟能生识者。于共于诸根不破坏者。与明了尘同兴发心。如此思惟能生诸识。是名色阴境分思惟

杂思惟者。于欲界阴入住是处色界色生于此身。云何上界诸色与下界共别处而住不别处也。答曰。不别处住犹如沙水。是名色阴杂分思。非色阴分别思惟究竟

决定藏论卷下


六门教授习定论

    No. 1607

六门教授习定论一卷

        无著菩萨本世亲菩萨释

        三藏法师义净奉　制译

今欲利益一切有情令习世定及出世定速能舍离诸烦恼故。述此方便。颂曰

  求脱者积集　　于住勤修习
  得三圆满已　　有依修定人

释曰。此初一颂总标六门。言求脱者。谓是求解脱人。积集者。谓能积集胜行资粮。于住勤修习者。于所缘处令心善住。名之为定。由不散乱不动摇故。问云何修习。谓得三圆满已有依修定人。圆满有三。一师资圆满。二所缘圆满。三作意圆满。有依谓是三定。一有寻有伺定。二无寻唯伺定。三无寻无伺定。修定人者。谓能修习奢摩他毗钵舍那。若人能于解脱起愿乐心。复曾积集解脱资粮心依于定有师资等三而为依止有依修习。由习定故能获世间诸福及以殊胜圆满之果先作如是安立次第。故名总标。颂曰

  于三乘乐脱　　名求解脱人
  二种障全除　　斯名为解脱
  应知执受识　　是二障体性
  惑种一切种　　由能缚二人
  已除烦恼障　　习气未蠲除
  此谓声闻乘　　余唯佛能断
  若彼惑虽无　　作仪如有惑
  是习气前生　　若除便异此

释曰。此之四颂释求解脱者。谓于声闻乘等有差别故。于三乘中心乐解脱。名求解脱。云何解脱。二种障全除。斯名为解脱。何者是二障。除之名脱。应知执受识是二障体性。识者即是阿赖耶识。执受者是依止义。谓是烦恼所知二障体性。此复云何。惑种即是烦恼障自性。一切种即是所知障自性。又一切种者。即是二障种子能缚二人。烦恼障种子能缚声闻。一切种子能缚菩萨。由与声闻菩萨为系缚故。云何此二解脱差别。谓声闻人。习气未除。断烦恼障而证解脱唯佛世尊能总除故。云何习气。彼惑虽无所作形仪如有惑者是名习气。此中应言。若惑虽无令彼作相如有惑者。此言作仪如有惑者。即是于因说果名故。彼谓声闻独觉未知。此是谁之习气。谓是前生所有串习之事。尚有余气。今虽惑尽所为相状似染形仪。名为习气。若能除断与此不同。应云若彼习皆无不作仪如惑。颂曰

  种植诸善根　　无疑除热恼
  于法流清净　　是名为积集
  能持乐听法　　善除其二见
  但闻心喜足　　是四事应知

释曰。此之二颂释积集义。如经中说。此人先应修习多闻复听正法。诸见热恼已正蠲除。心之盖缠能正降伏。依此文义故说初颂。云何积集所有善根。谓能持正法故。以此为先。令其信等善法增故。云何无疑。谓乐听法故。由知法故已生未生所有疑惑悉能除灭。云何除热恼。谓除二见故。二见云何。一者欲令他识知见。二者自起高举见。谓作是念。如何令他得知。我是具德之人。是则名为令他识见。依此见故自欲高举。名自高见。此二能令心焦热故。名为热恼。云何法流清净。谓能除遣但闻法时心生喜足故。上之除字流入于此。于法流清净者。谓听法时心无散乱相续而流。心清净故盖缠止息。若听法无厌。更能进思勤修不息。方得名为法流清净。当知此据闻思修位。如次应知

次有十六颂。释于住勤修习。初一总标余是别释。颂曰

  所缘及自体　　差别并作意
  心乱住资粮　　修定出离果

言所缘者。有其三种

  外上及以内　　此三所缘生
  应知住有三　　自体心无乱

释曰。言三种者。一外缘。二上缘。三内缘。外缘谓白骨等观所现影像。是初学境界。上缘谓未至定缘静等相。内缘谓从其意言所现之相为所缘境。自体谓是心无乱相。名之为住。心无乱者。于外等处三种缘时。随其所缘心无动乱。颂曰

  第一住相应　　定心者能见
  于境无移念　　相续是明人
  第二住相应　　厌离心寂静
  专意无移念　　相续是明人
  第三住相应　　于前境凝住
  定意无移念　　相续是明人

释曰。此之三颂如其次第配外上内。言于境无移念者。谓于余境心无散乱。故名无移。相续者。坚守持心令不断绝。言明人者。或因自思。或从他教。于静虑法而起加行。是谓明人。应知如次是随法行及随信行种性。言厌离心寂静专意无移念者。谓于其境生厌离心。前唯观境未能生厌。今时专注心生厌离而不散动。于前境凝住者。谓于意言所现之境缘此境时其心凝定。故云定意无移念相续是明人。颂曰

  坚执及正流　　并覆审其意
  转得心欢喜　　对治品生时
  惑生能息除　　加行常无间
  能行任运道　　不散九应知

释曰。于彼住中。差别有九。谓最初住。正念住。覆审住。后别住。调柔住。寂静住。降伏住。功用住。任运住

此等并依阿笈摩经。随句次第而为修习。若于最初学缘境时。其心坚执名最初住。次于后时令其正念流注不断。名正念住。若依托此有乱心生。更覆审察缘境而住。名为覆审住。次于后时转得差别。名后别住。次于后时对治生起心得自在生欢喜时。名调柔住。于此喜爱以无爱心对治生时。无所爱乐其心安静。名寂静住。次于后时所有已生未生重障烦恼为降伏故。名降伏住。次于后时以加行心于所缘境无间随转一缘而住。名为功用住。次于后时于所缘境心无加行任运随流无间入定缘串习道。名任运住。此之九种心不流散。名之为住。应知以此不散之言。与坚执等皆相配属。颂曰

  励力并有隙　　有用及无用
  此中一六二　　四作意应知
  谓外内邪缘　　粗重并作意
  此乱心有五　　与定者相违
  于彼住心缘　　不静外散乱
  掉沉心味着　　内散乱应知
  应识邪缘相　　谓思亲族等
  生二种我执　　是名粗重乱
  见前境分明　　分别观其相
  是作意散乱　　异斯唯念心
  于作意乱中　　复有其乱相
  于乘及静虑　　初二应除遣

释曰。应知作意。有其四种。一励力荷负作意。二有间荷负作意。三有功用荷负作意。四无功用荷负作意。此中坚执不散。是励力荷负作意。初用功力而荷负故。次正流等六种不散。是有间荷负作意。中间数有乱心起故。无间加行。是有功用行荷负作意。入串习道。是无功用行荷负作意。如是摄已谓一六二。应知即是四种作意。又心散乱。有其五种。一外心散乱。二内心散乱。三邪缘心散乱。四粗重心散乱。五作意心散乱。外心散乱者。于住心境起缘之时。遂缘余事心流散故。内心散乱者。谓掉举等三于所缘境中间乱起故。邪缘散乱者。于修定时诸有寻求。亲识等事而生顾恋。粗重心散乱者。有二我执令其心乱。于修定时有此二事。谓益及损。若身安隐名之为益。身体羸弱即是其损。或云我今得乐。或云我今有苦。或云是我之乐。或云是我之苦。此中我者。是执取义。言作意心散乱者。有其三种。于所缘相分明而住。是思察性。或从此乘更趣余乘。或从此定更趣余定。谓极分别思察定时。遂使心乱名心散乱。异斯唯念心者。此能对治初作意散乱。由不分别而缘于境。但有念心。此明成就心不忘念。此三散乱。初二应舍。第三由是从定趣定。希胜上故亦非是过。颂曰

  住戒戒清净　　是资粮住处
  善护诸根等　　四净因应知
  正行于境界　　与所依相扶
  于善事勤修　　能除诸过失
  最初得作意　　次得世间净
  更增出世住　　三定招三界

释曰。住资粮者。谓戒即是无边功德所依止处。必先住戒。戒行清净无有缺犯。若求戒净有四种因。一善护诸根。二饮食知量。三初夜后夜能自警觉与定相应。四于四威仪中正念而住。何故善护诸根等令戒清净。由正行于境与所依相扶。善事勤修能除于过。初因即是于所行境行清净故。二于所依身共相扶顺。于受饮食离多少故。三于善事发起精勤故。四能除过失。进止威仪善用心故。由此四因戒得清净。如是应知。由三种定得三出离。缘外境时得作意住。缘上境时得世清净。缘内心时得出世净。住者即是永得出离。必趣涅槃更不退转。已释于住勤修习。颂曰

  多闻及见谛　　善说有慈悲
  常生欢喜心　　此人堪教定
  尽其所有事　　如所有而说
  善解所知境　　斯名善教人
  由闻生意言　　说为寂灭因
  名寂因作意　　是谓善圆满

释曰。圆满有三。一师资圆满。二所缘圆满。三作意圆满。此中初颂说师资圆满。意显其人善教圆满。证悟圆满。善语圆满。无染心圆满。相续说法加行圆满。此显教授师众德圆满。由此师故得闻正法有所证悟。次明所缘圆满说第二颂。尽所有事如事而说。善所知境名为善说。此明师资能说诸事穷尽无吝。故名所缘圆满。次明作意圆满说第三颂。此显以闻为因所起意言能与圣道涅槃为正因故。缘此意言所有作意皆得圆满。此中因言显闻。即是意言之因。言寂灭者。即是涅槃及以道谛。自体寂灭及能趣灭故。总言之寂因作意者。明此作意缘寂灭因。何谓所缘了法无性。如是缘时即是其因亦是寂灭故。此作意名为寂因。是一体释。又缘此作意亦名寂因。此别句释。颂曰(准如是释应云寂因作意旧云如理作意者非正翻也)

  谓寻求意言　　此后应细察
  意言无即定　　静虑相有三
  无异缘无相　　心缘字而住
  此是心寂处　　说名奢摩他
  观彼种种境　　名毗钵舍那
  复是一瑜伽　　名一二分定
  粗重障见障　　应知二种定
  能为此对治　　作长善方便

释曰。次明有依诸修定者。必有依托。谓依三定说寻求等。言寻求者。显是有寻。既言有寻。准知有伺。言细察者。显无寻唯伺意言无者。欲显无寻无伺。寻伺皆以意言为性。此据奢摩他法明其定义。说无异缘等。此明无差异义。但缘其字而心得住。名无异缘。亦名无相。但缘其字于观义相所有作意非彼相故。此住名奢摩他。奢摩是寂止义。他是处义。非独奢摩得尽于事。谓据其心寂止之处。心得凝住依止于定。此定即是凝心住处。故名奢摩他。异此便无。次据毗钵舍那法明其定义说次一颂。谓依多境名为众观。所言彼者。谓与彼二俱相属着。即奢摩他及所缘字。是依奢摩他得毗钵舍那依于字处。所有诸义起诸观故。于寂止处所有众义依仗于字。谓缘众义。而起观察名为众观。名一二分定者。或时但有寂处而无众观。或有众观而非寂处。或时俱有应知即是止观双运。又奢摩他毗钵舍那有二种障。谓粗重障及见障。应知二定是此对治。如次应配。何故此二名长善方便。能长善法之方便故。云何令方便法得善清净耶。颂曰

  此清净应知　　谓修三种相
  寂止策举舍　　随次第应知
  若心沈恐没　　于妙事起缘
  若掉恐举生　　厌背令除灭
  远离于沉掉　　其心住于舍
  无功任运流　　恒修三种相
  定者修三相　　不独偏修一
  为遮沈等失　　复为净其心

释曰。为答前问。求净定者修三种相。云何为三。谓止举舍。复云何修。随次第应知。随其惑障生起之时。应次修习。在于何时复修何相。且辩策举相。若心沈恐没定者修三相。如下当知。若心沉没可修策举相。何者是耶。于妙事起缘令心喜为相。又寂止相者。若心掉举。或恐掉举。应修寂处。此云何修厌背令除灭。于所缘境极生厌恶。于自内心令过止息。舍相者。谓离沉掉。于何心中。谓心住舍。此舍相者。即是无功任运流恒修三种相。如是次第修三相时。诸习定者得清净相。又奢摩他等即是定者。于此三相不独修一。何以故。为遮沈等失。复为净其心。若但修止内心沉没。既沉没时便应策举。若因策举心掉散者。观不净境令生厌离。于此舍相正修习时。名为正定能尽有漏。由此遂令心极清净。应知此中皆是随顺正经文句。如理应思。颂曰

  出离并爱乐　　正住有堪能
  此障惑皆除　　定者心清净

释曰。此明清净之益。依去尘经说。佛告诸苾刍。若人欲求内心净。时有惑障现前不能除灭。欲断除者。先于不善业道。勿造大过息罪恶见。而求出家希求出离。若处中烦恼欲嗔害意。起恶寻思障胜爱乐。能除此障说爱乐言。若有微细眷属寻思世间寻思不死寻思障其正住。对治此故说正住言。若有功用方入定者。此定即非堪任之性。若能除此显有堪任。能除于惑说堪能言。此显净定之人得四种胜益。云何修定人果。颂曰

  于此定门中　　所说正修习
  俗定皆明了　　亦知出世定

此颂意显修习奢摩他毗钵舍那者获现果故。若人能依所说定相修习之时。得诸世间胜果圆满及出世果。如前已说

问曰。如上所说欲明何事。答曰

  显意乐依处　　本依及正依
  世间定圆满　　并了于出世

释曰。略说义周。为会前事故说斯颂。如最初云。求脱者为显意乐圆满。积集者依处圆满。此明有心修定必须依托积集资粮故。于住勤修习者。显本依圆满。如经中说。佛告诸苾刍。汝等先当依定能尽有漏。是我所说。若欲求出生死海者。离于正定无别方便。得三圆满者。显正依圆满。明师资承禀决定可依。有依修定人者。此显修习圆满。诸有智者如前所说。远离放逸正修行时。世间诸定悉皆圆满。及出世间咸能证悟。显得果圆满

六门教授习定论一卷


菩萨地持经

    No. 1581 [cf. Nos. 1579(1, 15), 1582]

菩萨地持经卷第一

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持初方便处种性品第一(第一段有一十八品)

  敬礼过去未来世　　现在一切佛世尊

有十法。具足菩萨道。摩诃衍摄。云何为十。一者持。二者相。三者翼。四者净心。五者住。六者生。七者摄。八者地。九者行。十者安立。云何名持。菩萨自种性初发心及一切菩提分法。是名为持。何以故。菩萨依种性。必定堪任阿耨多罗三藐三菩提。是故种性。名必定持。菩萨依初发心修行檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。修此六波罗蜜。功德律仪。智慧律仪。菩提分法。是故初发心名为菩萨行方便持。菩萨依行方便。满足阿耨多罗三藐三菩提。是故行方便名为大菩提持。非种性人。无种性故。虽复发心勤精进。必不究竟阿耨多罗三藐三菩提。是故当知。虽不发心不修行方便犹得名为种性持。若有菩萨种性。而不发心。不修行方便。不能疾成阿耨多罗三藐三菩提。有菩萨种性。发菩提心勤行精进。则能疾成阿耨多罗三藐三菩提。又种性名为持。名为长养。名为因。名为依。名为梯。名为导。名为覆。如种性发心。行方便亦如是。云何为种性。略说有二。一者性种性。二者习种性。性种性者。是菩萨六入殊胜。展转相续无始法尔。是名性种性。习种性者。若从先来修善所得。是名习种性。又种性名为种子。名为界。名为性。又不习者。果细果远。习者。果粗果近。菩萨成就种性者。出过一切声闻辟支佛上。何以故。有二种净。一者烦恼障净。二者智障净。二乘种性烦恼障净非智障净。菩萨种性具足二净。是故一切最胜最上。复有四事胜于一切声闻缘觉。一者根胜。二者道胜。三者巧便胜。四者果胜。菩萨性自利根。缘觉中根。声闻软根。是名根胜。声闻缘觉但为自度。菩萨不尔自度度彼是名道胜。声闻缘觉唯能了知阴界诸入十二缘起是处非处及四真谛。菩萨巧便悉能了知一切诸法。是名巧便胜。声闻得声闻菩提。缘觉得缘觉菩提。菩萨得阿耨多罗三藐三菩提。是名果胜。有六波罗蜜。是菩萨种性相。令诸众生知是菩萨。云何为六。谓檀波罗蜜。乃至般若波罗蜜。檀波罗蜜菩萨种性相者。是菩萨性自乐施。于彼受者以所施物等施不惓。于诸财物若多若少。等心惠施欢喜无悔。若无所施心常惭愧。常为他人叹施功德劝令行施。见有施者心常随喜。于诸尊重耆宿福田应供养者。舍所坐处恭敬奉施。若有人问今世后世如法事者。悉皆为说若有王贼水火恶知识怖。随力所能施以无畏。受他寄物未曾差违。若负人债终不抵捍。兄弟分财平等无二。于诸珍宝深爱著者。教令离贪。尚教他离。况自贪着。性于好财能舍受用。乐修胜业报利弘多。于诸酒色歌舞倡伎种种变现一切戏事。常生惭愧能速远离。得大财宝犹不贪着。何况小利。如是等比。是名檀波罗蜜菩萨种性相

尸罗波罗蜜菩萨种性相者。是菩萨身口意业性自柔软。不增恶行不乐杀生。设作恶业心生惭愧。能疾悔除不令增长。不以刀杖恐怖众生。体性仁贤常怀慈爱。恭敬尊长奉迎供养。善知机宜所作巧便。善随人心言常含笑。舒颜平视先意问讯。知恩报恩。所求正直不伪不曲。受如法财不为非法。性常喜乐修诸福德。见人修福尚以身助。况复自为。若有众生更相残害打缚割截毁訾诃责。有如是等无量众苦。若见若闻心常怜愍。重今世善及后世乐。于轻罪中心常恐怖。况余重恶而不畏慎若见他人农商放牧。书数算计。和合诤讼。求财守护。出息施与。婚姻集会。如是一切如法事中悉与同事。斗乱诤讼互相恐怖。若自若他无义无益。如是一切不与同事。善能遮制十不善道。若为他使随顺其教。已所宜行咨访明哲。于诸事业废我成彼。常怀悲恻不兴怒害。设令暂起寻即除灭。恒修实语不诳众生。不离他亲及无义语。言常柔软无有粗恶于己僮仆尚不粗言。况于他人。于诸功德心常爱乐。见人行者随喜赞善。如是等比。是名尸罗波罗蜜菩萨种性相

羼提波罗蜜菩萨种性相者。是菩萨性自柔和。若遇他人不饶益事。不起恚害无反报心。若他悔谢即受其忏。不怀结恨无复余想。如是等比。是名羼提波罗蜜菩萨种性相

毗梨耶波罗蜜菩萨种性相者。是菩萨性自精进。晨起夜寐不乐习着眠睡偃卧。凡所作事精勤不舍。能善思惟要令究竟。创始造业必定坚固。事若未成终不中废。于第一义心不退没。不自轻言不能成办。于所作事堪能勇猛。入诸大众摧伏邪论。善能酬答一切难问。诸余苦事悉能堪耐。大方便力终不忧悔。何况小事。如是等比。是名毗梨耶波罗蜜菩萨种性相。禅波罗蜜菩萨种性相者。是菩萨于法于义。性善思量无诸乱想。若见若闻山岩林薮。离诸愦乱随顺寂默即生念言。是处安乐是处远离。寻往其所。勤加修学。是菩萨性薄烦恼阴盖轻微。至远离处思量己利。不为恶觉之所恼乱。或时暂起寻即除灭。于怨憎所常起慈心况复余人。若见若闻众生受苦。即起悲心。随力方便度令离苦。性乐饶益安乐众生。或有亲属钱财杀缚驱摈。如是等难悉能安忍。能速受持诸法深义。念力成就所受专谛。久远所修悉能忆持。亦令他人忆念不忘。如是等比。是名禅波罗蜜菩萨种性相

般若波罗蜜菩萨种性相者。是菩萨于一切明处一切智处生慧成就。不顽钝不薄少不愚痴。诸放逸处悉能思量。是名般若波罗蜜菩萨种性相

是菩萨种性粗相我已略说。诸余实义。唯佛世尊能决定知。种性菩萨具足如是性功德者。成就真实白净之法。是故名为难得。名为奇特。名为不可思议。名为不动。名为无上。名为如来住处。正因相应

种性菩萨。成就白净法者。不为四种烦恼之所染污。若染污者。白净之法不现在前。或生恶道。种性菩萨久处生死或堕恶道。堕恶道者疾得解脱。虽处恶道不受大苦。如余众生入地狱者。若苦触身即能厌离。见他受苦能起悲心。如是种性为大悲因。是故菩萨虽堕恶道胜余一切恶道众生。云何四种烦恼。一者久习放逸烦恼数利。二者愚痴习恶知识。三者尊主王贼怨敌所迫不得自在。其心迷乱。四者众具不足常忧身命

种性菩萨复有四法。不得阿耨多罗三藐三菩提。云何为四。一者本无善友诸佛菩萨善说法者。二者虽值善友佛及菩萨善说法者。而谬受学。三者虽值善友佛及菩萨善说法者。不谬受学。而不勤方便。不炽然精进。四者虽值善友佛及菩萨善说法者勤修方便。而善根未熟庄严未备。久远已来心不调伏。菩萨虽有菩萨种性。因缘不具不能得成无上菩提。离是四法疾得阿耨多罗三藐三菩提。若无菩萨种性。虽有一切诸方便行。终不得成无上菩提

    菩萨地持方便处发菩提心品第二

菩萨初发心。是一切正愿始。悉能摄受一切正愿。是故初正愿为自性愿。菩萨发心而作是言。我当求无上菩提安立一切众生。令究竟无余涅槃及如来大智。如是发心求菩萨道。是故初发心名为求行菩萨。缘于菩提及缘众生而发心求。是故初发心摄受一切菩提善根。为上导。为极巧便。为功德具足。为极贤善。为极真实。于一切众生悉舍恶行。于世间出世间正愿为上无上。如是当知。初发心有五相。一者自性。二者行。三者缘。四者德。五者胜。初发心菩萨名为度。大乘菩提诸菩萨数。是故初发心度之所摄。发是心已。渐得阿耨多罗三藐三菩提。是故初发心是菩提根木。发是心已。见诸众生受无量苦。而起悲心欲度脱之。是故初发心是大悲所依。依初发心建立菩萨菩提分法。及众生所作菩萨所学悉能修习。是故初发心是菩萨学之所依。如是初发心名为摄。名为根本。名为依

初发心菩萨有二种。一者出。二者不出。出者。从初发心乃至究竟终不退转。不出者。则有退转。退有二种。一者究竟退。二者不究竟退。究竟退者。退已终不复起菩萨之愿。不究竟退者。退已还起

初发心菩萨有四种缘。四种因。四种力。云何四缘。一者善男子善女人。若见若闻诸佛菩萨有不可思议神通变化。彼见闻已即发是念。是为大事不可思议。能为如是诸变化事。以此见闻为增上缘故。乐佛大智发菩提心。二者虽不见闻如上神变。闻说法者赞叹菩提及菩萨藏。闻则欣庆欢喜信乐。以此闻法为增上缘故。乐佛大智发菩提心。三者虽不闻法。见法灭相而作是念。无量众生当遭大苦。菩萨住世则能除灭。我今当修菩提之道。护持正法。为诸众生灭无量苦。以护法为增上缘故。乐佛大智发菩提心。四者不见法灭。见恶世众生为十烦恼之所恼乱。一者愚痴。二者无惭愧。三者悭嫉。四者苦恼。五者秽污。六者烦恼。七者恶行。八者放逸。九者懈怠。十者不信。见已作是念。大浊世起。于此恶世尚不能发二乘之愿。况能志求无上菩提。我当发心亦令他发。以浊世中发心难得为增上缘故。乐佛大智发菩提心

云何四因。一者种性具足。二者诸佛菩萨善友所摄。三者起大悲心。四者生死苦难行苦。如是久远无量诸苦。于此众苦心不怖畏。种性具足者。所谓无始法尔。善友所摄者。有四事。一者善友不愚不钝。黠慧不邪。二者不教人放逸。亦不以放逸之具授与他人。三者不教人恶行。亦不以恶行之具授与他人。四者终不断人上信上欲上受上精进上方便上功德令其退下。不以下信下欲下受下精进下方便下功德授与他人。所谓断无上大乘令学二乘。断修慧与思惠。断思慧与闻慧。断闻慧与福业。断戒与施。如是等断上功德令其退下。以下功德授令修习。起大悲心者有四事。或有世界有苦恼处。或有世界无有苦恼。菩萨生于有苦恼处。见他受苦。或自受苦。或见俱受。或见生死长久受无间苦。菩萨依自种性性自仁贤。于四境界起下中上悲。于无穷生死无间大苦心不怖畏者。有四事。一者性安隐勇猛。二者黠慧专修思惟。三者于无上菩提。起增上乐。四者于诸众生发增上悲。云何四力。一者自力。二者他力。三者因力。四者方便力。菩萨自力发菩提心。是名自力。因他发心。是名他力。先习大乘相应善根。今少见佛及诸菩萨。或少闻叹说则便发心。是名因力。于现世中近善知识。闻其说法能修众善。是名方便力

菩萨以四缘四因自力因力发菩提心者。坚固不动决定究竟。他力方便力而发心者。不坚固动转不定

菩萨有四事退菩提心云何为四。一者种性不具足。二者恶知识所摄。三者于诸众生。悲心微薄。四者于生死苦生怖畏心

初发心坚固有二事。出过世间殊胜奇特未曾有法。一者于诸众生起亲属想。二者无摄亲属之过。摄亲属过者。受亲属故心生爱恚。初发心坚固有二事。于诸众生起真净心。一者安隐心。二者快乐心。安隐心者。为诸众生除不善处安置善处。快乐心者。贫乏众生无所依怙。能以摄法等心饶益。初发心坚固有二方便。一者净心方便。二者道方便。净心方便者。彼安隐心快乐心日日增长。道方便者。自于日夜成熟佛法。随其力能依净心方便。安乐饶益一切众生

初发心坚固有二门善法所入。一者自利方便。发菩提心。二者他利方便。灭除众苦

初发心坚固有二事。发心成道所摄善法。出胜一切所摄众善。一者因胜。二者果胜。彼菩提因所修善法。是名因胜。无上菩提。是名果胜。胜于一切声闻缘觉。是故菩萨因果殊胜。初发心坚固有二种利益。一者发是心已。即为一切无量众生而作净施尊重福田。二者摄取纯净福德。成就净福者。二转轮王福德所护。若卧若觉。不为恶兽恶鬼神等之所恼害在所生处少病无病。若说法时。身不疲惓心不忘失。性种性菩萨身口意恶性自微薄。既发心已转复轻微。若他所用无验咒术。菩萨用之悉皆神验。已能成就。随顺上忍。能忍他恼。亦不恼他见人相恼。心生怜愍嗔嫉隐覆。幻伪谄曲诸上烦恼皆悉微薄。设起速灭。在所住处无诸恐怖斗诤饥馑非人所恼。如是诸难未起不起。设起速灭。发心菩萨或生恶道速得解脱。受苦微少疾生厌离。于余众生能起悲心。纯净福德之所护故。成就如是等无量净福

    菩萨地持方便处自他利品第三

云何菩萨行。略说诸菩萨所学。如学而学。总说是菩萨行。菩萨于何处学。学有七处。云何为七。一者自利。二者利他。三者真实义。四者力。五者成熟众生。六者自熟佛法。七者无上菩提。云何自利他利。自利他利略说十种。一者纯。二者共三者安。四者乐。五者因摄。六者果摄。七者此世。八者他世。九者毕竟。十者不毕竟。纯共自他利者有二种。一者纯自利。二者纯他利。违菩萨道者。应知应断。顺菩萨道者。应当修学。为已乐故求财自用。为秘法故求佛经法守护执持。为生天故受持禁戒精进禅定智慧等法。为世间贪果故供养佛塔。为贪利故作求利相。为欺彼故无缘自说种种功德。贪他亲附非法摄受自住禅乐舍为众生。是名纯自利。应知应断。布施忍辱悲心为首。回向菩提及欲生天。是名自利共他。应当修学。除如是所说。余纯自利相违者。是名自利共他。纯他利者。无因无果邪见布施。犯戒违道为他说法。自度下地。而以下地净法授与他人。菩萨舍禅愿生欲界。自在菩萨十方世界种种变现。教化众生。如来毕竟力无所畏不共之法。利益一切无量众生。是名纯他利。前所说二种纯他利。应知应断。余纯他利。应当勤学。除如是所说。余纯他利相违者。是名他利共自

安。自他利者。略说五种。一者无罪相。二者摄受相。三者此世。四者他世。五者寂灭。菩萨所摄善根。若多若少。修习成就。亦以此善成就众生调伏建立。是名无罪相。安自他利菩萨。以离染污乐众具乐住禅乐饶益自他。是名摄受相。安自他利菩萨。有此世安非他世。有他世非此世。有此世他世。有非此世非他世。此四种受四种法。次第随其所应。云何为四。有法现世受乐他世受苦。有法现世受苦他世受乐。有法现世受乐他世受乐。有法现世受苦他世受苦。是名此世他世安自他利。涅槃及涅槃道涅槃分。世间法出世间法。是名寂灭安自利他。乐自他利者。略说五种。一者因乐。二者受乐。三者苦对治乐。四者断受乐。五者无罪乐。因乐有二种。一者情尘触因缘。故乐受生。二者今世后世爱果业。是名因乐。众苦息已思惟三种因乐。起身心受。是名受乐。受乐有二种。有漏及无漏。无漏者。学无学。有漏者。三界系。欲界色界无色界。彼一切三界。随其所应六入分别。眼触因缘乃至意触因缘生。五识相应。名为身受。意识相应。名为心受。寒暑饥渴种种苦恼。已起未起对治令息。息已乐知生。是名苦对治乐。灭受想定。是名断受乐。无罪乐者。有四种。一者出家乐。二者远离乐。三者寂灭乐。四者菩提乐。信家非家出家学道。解脱种种在家之难。是名出家乐。断欲恶不善法得初禅离生喜乐。是名远离乐。二禅为首觉观止息是名寂灭乐。一切烦恼究竟灭。于一切法。如实觉知乐。是名菩提乐。因乐者。是乐因非自性。受乐者。非乐因是自性。对治乐者。非乐因非自性。而是息苦除苦。断受乐者。非乐因非自性非除苦。而所有受是真实苦。随住定时是受灭。无罪乐所摄。最后菩提乐。未来现在一切烦恼究竟灭。诸余无罪乐。于彼随顺。是名无罪乐

是菩萨以安隐乐饶益众生。非安隐乐如实知之。随力方便教令除断。若苦而后安者。彼虽忧恼要当饶益。是则菩萨依巧方便。若乐而后不安者。彼虽忧苦不欲去之。以方便力要为除断。何以故。以后必得乐故

是菩萨欲众生安者欲令得乐。与其安者亦欲与乐。安者谓因处。乐者谓果处。是故当知。乐众生者必先安之。彼爱果业今世后世因乐所摄。及苦对治乐。断受乐。无罪乐。决定以此饶益众生。亦名为摄。亦名无罪受乐。及情尘触因乐。是染污有罪不安隐者。不以饶益教令除断。若非染污无罪安隐者。以此饶益一切众生。菩萨亦常随力自行。是名菩萨安乐自他利因摄。果摄自他利者。略说三种因三种果。报因报果福因福果。智因智果。云何为报。报有八种。一者寿具足。二者色具足。三者种性具足。四者自在具足。五者信言具足。六者大力具足。七者人具足。八者力具足。长寿久往。是名寿具足。颜容端政。是名色具足。生于上族。是名种性具足。得大财大众大眷属。是名自在具足。断事听讼制作法度。受与寄付悉从取正。凡所出言人所信伏是名信言具足。有大名称大方便大智慧。种种技艺为人所重。大众恭敬尊重赞叹。是名大力具足。成就丈夫法。是名人具足。少病少恼有所堪能。是名力具足

云何报因。不害众生无伤害心。是名寿因。施灯明净物。是名色因。舍离憍慢。是名种性因。众具惠施。是名自在因。离口四过。是名信言因。摄诸功德立大誓愿。供养三宝及诸尊长。是名大力因。乐丈夫法厌女人法。说丈夫法饶益他人。教令厌离女人之法。是名人因。众生所作如法事中。随其所能悉往营助。是名力因。如是八种。是名报因。略说报因有三种胜。令报增上。一者心净。二者方便净。三者福田净。净心悕望无上菩提。回向善根渐渐增长。信乐修行胜妙纯善。见人行者心生随喜。日夜念念随顺正法随觉随观。是名心净。长夜修习精勤无间。复以此法转授他人。见有授者随喜赞善。见彼受行随顺训导。亦以此法而自建立。是名方便净。略说方便正起方便果。是名福田净

云何报果。菩萨寿具足故。久修善法令诸众生成就善根。是名寿具足果。菩萨色具足故。大众爱乐。众爱乐故。悉共宗敬乐听所说。是名色具足果。菩萨种性具足故。众所敬重供养赞叹。言必受行无所违犯。是名种性具足果。菩萨自在具足故。布施普摄成就众生。是名自在具足果。菩萨信言具足故。常以爱语利益同事。摄取众生化令成就。是名信言具足果。菩萨大力具足故。众生所作悉能营助。众生知恩咸来归仰。凡出言教即皆承用。是名大力具足果。菩萨人具足故。男相成就堪为一切功德法器。于一切方便一切知见得无所畏。于一切时自在游处。一切众生往来同事。人间旷野随意无碍。是名人具足果。菩萨力具足故。精勤方便。坚固方便。速疾方便。修善无厌摄人不惓。是名力具足果。菩萨以此八种报果饶益众生。自熟佛法随顺功德。菩萨住是报果。令诸众生作所应作。众生随教各修所愿。若菩萨虽自有力而彼不从。不名利他。若自无力而受化者顺。亦不名利他。若自有力受化者顺。是二具足则能兼利。菩萨具足二法能自行佛法。以三乘法成就众生。能自究竟无上菩提。众生熟者令得解脱。是故菩萨住八种报果。乃能安乐一切众生。一切众生无际生死。从本已来空无义利。悉令不空获大果实

云何为福。云何为智。檀波罗蜜尸罗波罗蜜羼提波罗蜜。是名为福。般若波罗蜜。是名为智。禅波罗蜜毗梨耶波罗蜜。各有二分。一者福分。二者智分。依禅故修四无量等。是名福分。依禅故修阴界入巧便。处非处巧便。观苦习灭道。善不善法。有罪无罪法。下法上法。垢法净法。及诸缘起。皆能如实分别观察。是名智分。依精进故修行施戒四无量等。是名福分。依精进故修闻思修惠。阴巧便等如前说。是名智分。如是福智略说六种。广说则无量。云何福因智因。福因智因略说三种。一者得长养福智方便处欲。二者随顺近缘。三者本习福智近缘者。不住颠倒缘。住不颠倒缘。习近恶知识。倒说福智倒念倒受。是名住颠倒缘。与此相违净分。名住不颠倒缘。离长养福智方便处欲障不起。是名为近。此三因不具者福智不生

云何福果智果。菩萨依福故。为诸众生于无穷生死备经众苦。随其所欲摄取众生。菩萨依智故。摄受正福种种巧便。为诸众生乃至无上菩提。如是略说福智有四种果。广说则无量。若报若报因若报果。一切依福起。福依智起。此二具足最胜最上。得无上菩提。若福智不具终不能得。是名菩萨因摄果摄自他利。云何此世他世自他利。现修福业获如法财。宿善因缘今受果报。善能转禅住此世乐。依于此世为利众生。依于诸禅现法涅槃如实。世间出世间。向现法涅槃有为法。是名此世自利。即以此法教化众生。是名此世他利他世欲界身财。乃至禅无色生。此世忧苦。思惟修习彼因。是名他世自他利。此世喜乐。思惟修身财因。乃至此世退分。禅无色正受。是名此世他世自他利

云何毕竟不毕竟自他利。欲界身财。有因有果。凡夫世俗净。有因有果。是名不毕竟自他利。一切烦恼毕竟灭。八正道及依此生世俗善法。是名毕竟自他利。毕竟不毕竟有三种。一者自性。二者退。三者受用果尽。自性者。涅槃毕竟。一切有为法不毕竟。八正道不退。受用果不尽毕竟。余善有漏法退。受用果尽不毕竟。是名十种自他利。如是略说广说。菩萨应当随力修学。过去已学。未来当学。一切十种自他利。是名毕竟不毕竟自他利

    菩萨地持方便处真实义品第四之一

云何真实义。略说二种。一者实法性。二者一切事法性。此二法性以种分别复有四种。一者世间所知。二者学所知。三者烦恼障净智所行处法。四者智障净智所行处法。云何世间所知真实义耶。世间众事随顺俗数。知见悉同。谓地即是地。非水非余水火风。色声香味触乃至苦乐。略说此物。即此物非彼物。如是一切决定意解所行处事。世间本来自忆想知不从修习。是名世间所知真实义也。云何学所知真实义耶。如世智人依现智比智。及从师闻思量修学。彼决定智所行处事。结集建立。是名学所知真实义也。云何烦恼障净智所行处法真实义耶。一切声闻缘觉无漏智。若无漏方便。若随生世智修行境界。于彼智缘中烦恼障净。未来世障毕竟不起。是名烦恼障净智所行处法真实义也。所谓四圣谛苦集灭道。观此四谛入无间等惠及无间等所起智慧。声闻缘觉见阴离阴我不可得。诸行缘起生灭和合。阴与离阴。无我人性修习知见。云何智障净智所行处法真实义耶。智所知碍。是名为障。彼智障解脱智修行境界。是名智障净智所行处法真实义也。所谓诸佛菩萨入无我法。入已清净。于一切法离言说自性假名自性。离诸妄想。平等大智修行境界。第一如实无上无边。一切法择永灭不起

又真实相建立二种。一者有性。二者无性。有性者。建立施设假名自性。久远已来世间计着。一切忆想虚妄根本。所谓是色是受想行识眼耳鼻舌身意。地水火风。色声香味触法。乃至涅槃。如是世间假名有自性法。是名为有。无性者。色假名。乃至涅槃假名。无事无依假名。所依一切悉无。是名为无。如上所说。有无是二。俱离法相。所摄二法无有二。无二者。是名中道。离于二边。是名无上。如是真实。是佛世尊净智境界。是诸菩萨所应修学。若修学者。名为大智方便菩萨。当得阿耨多罗三藐三菩提。何以故。菩萨与空解脱相应。在于生死如实知生死。不于生死无常等行而生厌离。能成就佛法利益众生。若不如实知生死者。不能舍离贪恚痴等一切烦恼。若不舍离则以染污受诸生死。以染污心受生死者。不能成就佛法利益众生。若于生死无常等行生厌离者。是菩萨疾得涅槃。疾得涅槃者。亦不能成就佛法利益众生。云何能得阿耨多罗三藐三菩提。若空解脱相应菩萨。则不畏涅槃亦不求涅槃。若菩萨畏涅槃者。不能满足涅槃道。以畏涅槃故不见涅槃功德利益。不见涅槃功德利益。清净信乐皆悉远离。若菩萨求涅槃者。多修习故疾般涅槃。疾般涅槃者。不能成就佛法利益众生。若于生死不如实知。则长受生死。若厌生死。则疾般涅槃若畏涅槃者。不能满足涅槃之道。若求涅槃多修习者。则疾般涅槃。当知是菩萨于阿耨多罗三藐三菩提无大方便。若于生死得如实知。则于生死心不染着。若于生死无常等行不厌离者。不疾涅槃。不畏涅槃者。则能满足涅槃之道。深见涅槃功德利益。若不勤求疾涅槃者。当知是菩萨于阿耨多罗三藐三菩提有大方便。是大方便依第一空解脱。是故名为修第一空解脱菩萨最大方便。谓向如来无上大智故

菩萨地持经卷第一菩萨地持经卷第二

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持方便处真实义品之余

复次菩萨从久远来入无我法智。离言语自性。一切法如实知已。无有一法可起妄想随事取。随如取。不如是念。是事是如。但行其义。行第一义已。一切法如无等等。如实知见。一切平等。观平等心。得第一舍。依第一舍已。一切经论一切巧便。悉善通达。一切苦难终不退转。其心坚固身无疲极。所为巧便得大念力。于诸巧便亦不自高。法化众生无所秘惜。于诸巧便心不怯弱。有所堪能终不退减。能被具足大坚固铠。如是如是。生死苦增。如是如是。堪能增长。无上菩提。如是如是。功德转增。如是如是。憍慢惭减。如是如是。智慧转明。如是如是。彼彼诤讼。犯戒烦恼。皆悉了知。知已放舍。如是如是。功德增长。如是如是。愈更覆藏不令他知。不为利养菩萨如是等无量福利。顺菩提道悉依彼智。是故菩萨。已得菩提今得当得。悉依彼智非余。若劣若胜如是离虚妄。菩萨有如是等无量福利。自能成就无上佛法。以三乘法利益众生。是名正趣。正趣已。自于身财远离贪爱。学离爱已。复教众生令离贪爱。舍于身财等心众生给施所须。善摄诸根。学身口律仪。性不乐恶仁贤真实。忍他侵逼及诸恶行。修学忍已。嗔恨转薄不恼逼他。一切明处精勤修学。善为众生决诸疑难摄取饶益。亦自摄受一切智因。内摄其心安住正受。净四梵处游五神通。一切事业悉方便学一切巧便。若立若废终不疲厌。能善观察第一真实。能善修学第一大乘。终不愿求现世涅槃。如是平等究竟具足。于诸大德奉事供养。于恶众生兴大悲心。随力所能为除恶行。于己嫌恨不饶益者。为起慈心随力堪任不谄不伪安乐饶益。令彼结恨过恶自灭。饶益己者。以等以增。知恩报恩。如法所求皆令满足。若自无力。彼虽不请要作方便。心不休息。令彼知我无所遗惜。是名菩萨远离虚妄。依第一实智。平等方便

云何知一切法离于言说。此施设假名自相诸法。所谓色受想行识乃至涅槃。当知假名无有自性。亦不离彼有。言说行处言说境界。如是无有自性。如言语所说。亦不一切都无所有。如是无所有。亦非一切都无所有。彼云何有有实谤实。此二俱离如是有。是名第一义自性。离一切妄想。智慧行处。若法随说有事转者应有自性。若然者。一法一事应有众多自性。何以故。谓一法一事有众多名字施设故。亦非多名有决定性。亦非一名有自性。余名无自性。是故施设假名。多名一名悉无自性

复次色乃至涅槃。法若随名字有自性者。要先有法而后随意制名。未有名时彼法应无自性。若无自性者。无事制名。是义不然。无名有法。是亦不然。若法本来自性是色。然后以名字言说摄取是色。若然者应离名有色。施设众生应自知。是色不待名知。而众生无名则不知色。以是故知一切诸法离言说自性。如色乃至涅槃亦复如是。复次有二种人坏佛正法。一者若色等诸法色等诸事。施设假名说自性自相。于不实法妄想计着。二者施设假名处假名所依。离言说自性。第一实义诽谤毁灭。一切都无所有。如前说。建立不实法妄相过恶者。谓于色等诸法色等诸事。非实计实。以是过故。破坏正法。又色等诸法色等诸事。因缘分齐诽谤毁灭。都无所有。破坏正法。今当说色等诸法事。因缘分齐。诽谤说言。无有真实。亦无假名。二俱不然。如士夫等阴。说名为人。是则可尔。无事说人则不应尔。如无事说人。如非无事说人。如是因缘分齐色等法建立假名。非是无事而立假名。是则应尔若但假名而无事者。则无依处。亦无假名是不应尔。是人闻难解修多罗大乘甚深空相应义。于如实说一向不解。作不正思惟虚妄分别。以无巧便慧作如是说。一切皆是假名无有真实。作如是观。是为正观。是等于假名所依悉无所有。假名亦无。假名既无。假名真实亦无所有。真实假名。是二俱谤者。是名都无。如是说无者。智慧梵行人。不应共语。不应共住。是为自坏亦坏世间。是故世尊。为是事说。宁起身见不恶取空。何以故。起身见人。于所知戒不谤一切所知。不因此见堕于恶道。不坏他信乐。离苦解脱亦不作留难。亦能建立真谛正法。不于戒律而生懈慢。恶取空者。于所知戒又复诽谤一切所知。以是缘故堕于恶道。亦坏他信乐。离苦解脱亦作留难。于戒慢缓谤实法故破坏佛法。云何为恶取空。若沙门婆罗门。谓此彼都空。是名恶取空。何以故。若言此空无彼性。若言此空有此性。是义应尔。若一切无性。何处何法空。亦不应言此即此空。何等为善取空。若于此物无彼物。故名为空。此物不空如实知是名如实不颠倒。空谓色等施设假名。无有自性。而色等有余。谓色等假名事因缘分齐。俱如实知。谓事分齐有事分齐。假名分齐。不立非实不诽谤实。不增不减不举不下。如实如如。离言说自性如实知。是名善取空。正智所知。我以具足思量结集。说一切法离言说自性。从佛所闻。一切法离言说自性。今当说如佛世尊趣有契经。说偈显示

  如以种种名　　用说种种法
  此亦无有彼　　是法法如是

此偈显示施设假名。名色等诸法。以色等名。宣说诸法。流通言教。说色乃至涅槃。色等假名。无色等自性。色等法亦无余自性。此色等假名。诸法离言说。义无所有。是名第一义自性法。如世尊义品说

  世间集言说　　牟尼悉不着
  不着孰能着　　不起见闻着

此偈显示以色等假名施设色等事。是名世间集言说。此假名。彼事无彼自性。何以故。建立及谤。无有此见故。无彼颠倒见。是名见不着。如是不着。谁能起见着于色等事。若建立。若诽谤。不起着。正观境界。是名为见。听所知言说。是名为闻。是故见闻不起染着。于彼缘中一切舍离。是名不起见闻着

复次佛为讪大迦旃延比丘说。比丘不依地修禅。不依水火风。不依空识无所有非想非非想。非此世非他世。非日月。非见闻觉知。非求非得非觉非观。不依此等而修禅定。云何不依地乃至不依觉观而修禅定。迦旃延。若地地想除。乃至一切一切想除。比丘如是修禅。是名不依地修禅。乃至不依一切修禅。比丘如是修禅者。释天大力天梵天悉来礼敬说偈赞叹

  南无最胜士　　南无士之上
  今我不知汝　　何所依而禅

此契经显示地等假名众事。于彼地等施设假名。是名地想。又此地等想。于彼假名事。若建立自性。若一切毁灭。坏第一义摄受诽谤。是名为想。若除彼想。是名为断。是名为舍。当知是名。从诸如来第一义师。闻一切诸法离言说自性。如是一切法离言说自性者。一切言说为何所应。若无言语不能为人说离言法。既无说亦无闻。无说无闻。彼一切法离言说自性。无能知者。是故应有言说令彼闻知。如是如实。凡愚不知。以是因缘起八种妄想而生三事。一切众生器世间增。一者自性妄想。二者差别妄想。三者摄受积聚妄想。四者我妄想。五者我所妄想。六者念妄想。七者不念妄想。八者俱相违妄想。是名八妄想

云何所生三事。一者自性妄想。差别妄想。摄受积聚妄想。此三妄想。是妄想虚伪处。虚伪攀缘事。由此而生。于色等假名。若彼事处。以名想言语摄受增长。无量虚伪常行不息。二者彼我我所妄想。此二妄想是身见。身见为一切见根本及慢根本。我慢能生一切诸慢。三者彼念妄想。不念妄想。俱相违妄想。随其所应生贪恚痴。是名八种妄想生三种事。所谓妄想处虚伪事。身见我慢事。贪恚痴事。依妄想虚伪生身见我慢。依身见我慢生贪恚痴。此三种事。一切世间积聚分。一切炽然

云何自性妄想。于色等假名事。若妄想言是色。是名自性妄想。云何差别妄想。于此色等假名事。言此是色此非色。此可见此不可见。此有对此无对。此有漏此无漏。此有为此无为。如是等无量分别于自性妄想处作差别妄想。是名差别妄想。云何摄受积聚妄想。于色等假名事。我人寿命众生。于彼俗数妄想于色等饶益。积聚多法。积聚摄受。因起舍宅军众林丛饮食衣服车乘。于彼俗数妄想饶益。是名摄受积聚妄想云何我我所妄想。若彼诸事。是有漏受阴。久远积习我我所著。是故无摄受处。习自见处事。以是因缘。起不如实妄想。是名我我所妄想。云何念妄想。于彼净妙及所喜事。缘妄想。云何不念妄想。于不净及所不喜事。缘妄想。云何念不念俱相违缘妄想。于彼净不净所喜所不喜俱离事。缘妄想。彼略说有二事。谓妄想及妄想依。妄想缘事此二事。俱从本来各各相因。过去妄想生现在妄想缘事。现在妄想缘事生现在缘事妄想。不知现在妄想故。复生未来妄想缘事。缘事生已。必复生彼缘事妄想

云何知妄想。有四种求。四种如实知。云何四种求。一者名求。二者事求。三者自性施设求四者差别施设求。名求者。菩萨于名名分齐观名求。如是事事分齐观。事求。自性施设。自性施设分齐观。自性施设求。差别施设差别施设分齐观。差别施设求。彼名与事。若离相观。若合相观。名事合依。自性施设。差别施设观。云何四如实知。随名求如实知随事求如实知。随自性施设求如实知。随差别施设求如实知。云何随名求如实知。菩萨于名名分齐。求如是名如实知。此名为此事立为想为见为流布。于色等假名事。不立色等名者。无有能知色等事者。若不知者。无思量事。会无思量者。则无言说。如是如实知者。是名随名求如实知。云何随事求如实知。菩萨于事事分齐。求观色等假名事。一切言说事离言说。是名第二随事求如实知。云何随自性施设求如实知。菩萨于色等假名事。自性施设。自性施设分齐。求彼自性施设。此自性事。观自性相如实知。如化如影如响如焰如水中月如梦如幻。观自性相无有真实。是名第三如实知甚深义处随自性施设求如实知。云何随差别施设求如实知。菩萨于差别施设差别施设分齐。求是假名色等事。差别施设不二。观彼事非有性非无性。言说自性不可得。亦非无性。离言说自性而建立性。非有色。第一义谛故。亦非无色。世谛有色故。如有性无性色非色。如是可见不可见。一切法差别施设。皆如是知。此差别施设不二义如实知。是名随差别施设求如实知。若彼八种邪妄想愚痴凡夫。生三种事增长世间。彼四种如实知不具足者。彼邪妄想烦恼起起烦恼故受生死。受生死故随生死生老病死等众苦增长。若菩萨依四种如实知。现世知八种妄想。现世知已。未来依处缘中虚伪事则不复起。彼事不起者。彼未来缘中妄想不生。如是彼事彼妄想灭已。一切虚伪亦灭。虚伪灭已菩萨疾得大乘大般涅槃。现世能得奇特大士行处。净智成就一切大自在力。所谓种种化化神力。种种变变神力。一切智知无所挂碍随其所欲存亡自在。得如是等无量自在。名一切众生最胜无上。如是一切自在菩萨。成就五种上妙功德。一者得第一净心。寂灭正受。而不寂灭一切烦恼。二者一切明处清净知见增长无减。三者为众生故。处在生死而不疲厌。四者善入如来言说旨趣。五者善解大乘不从他受。如是五种功德为五种业。一者现世第一乐住。开觉方便。生身心方便。疲劳悉灭是心寂静。功德之业。二者成就一切佛法。是一切明处。清净知见。功德之业。三者成就众生。是于生死而不疲厌功德之业。四者教化众生起未起疑能为开解。护持正法令得久住。有相似法能灭正法者。善知善说能令除灭。是善入如来言说旨趣。功德之业。五者降伏一切外道异论。坚固精进正愿不灭。是善解大乘不从他受。功德之业。如是菩萨一切所作。皆是五功德业之所摄。谓不染污乐。成熟佛法。成就众生。护持正法。降伏异论。炽然精进。正愿不动。彼四种真实义。初第二是下。第三是中。第四是上

    菩萨地持方便处力品第五

云何为力。略说有三种一者诸佛菩萨得自在三昧。依自在三昧。随其所欲一切堪能。是名圣力。二者法有大果有大利益。是名法力。三者诸佛菩萨先大福德方便成就。诸佛菩萨有俱生奇特未曾有法。是名俱生力。复次此三种力。以种分别。诸佛菩萨有五种力。一者神通力。二者法力。三者俱生力。四者共一切声闻缘觉力。五者不共力。神通者。所谓六通。一者神足。二者天耳。三者他心智。四者宿命智。五者生死智。六者漏尽作证。是名神通力。法力者。所谓六波罗蜜檀波罗蜜。尸罗波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。是名法力是诸法有所堪能。故名法力。云何神足。略说有二种。一者变。二者化。若以种分别则有无量。云何变神足以种分别。所谓震动。炽然。充满。示现。转作异分。去来。大小。色像入身。所往相似。隐显自在。障他神通。与辩。与念。与乐。放大光明。如是等比名变神足。震动者。谓佛菩萨得自在三昧。能有所作震动。寺舍城郭宫殿聚落田宅。地狱畜生饿鬼人天及四天下。千世界二千世界三千世界。百三千世界千三千世界万三千世界。乃至无数三千大千世界。皆悉震动。炽然者。身上出火身下出水。身上出水身下出火。入火三昧举身洞然。现种种色青黄赤白红颇梨色。充满者。身放光明充满一舍。乃至充满无量无数三千大千世界。示现者。谓安坐去来。现为沙门众婆罗门众声闻众缘觉众菩萨众。天龙夜叉乾闼婆阿修罗迦留罗紧那罗摩睺罗伽人非人等众。诸佛菩萨。下至恶道上至人天。皆悉示现。乃至十方恒河沙刹亦复如是。过无量恒河沙刹有佛名刹名。悉能示现。亦说彼佛及国土名号。复过是数随其所欲悉能示现。转作异分者。或变地为水即是真水。如实非余。变作火风亦复如是。如地水火风亦复如是即是非余。如四大色香味触。草木泥土变为饮食衣服璎珞香华涂香诸庄严具。沙砾瓦石变为众宝。雪山王等一切诸山变为金色。一切即是如实非余。好色众生变为恶色。恶色众生变为好色。或好恶色变为中色。或中间色变为好恶色。如好恶色。支节具足。若不具足。若肥若瘦。如是等比所有自相。能变其色自在无碍。非一切变随其所欲。来去者。石壁无碍。上至梵世乃至色究竟天。若来若去。悉得自在。周遍十方无量无边三千大千世界。若化身若粗四大身。若来若去。亦复如是。若远近想。即时往返。大小者。能令雪山如一微尘。令一微尘如雪山王。色像入身者。诸沙门婆罗门一切大众。若村若城草木丛林及诸山地。一切色像悉内身中。时诸大众。各各自见入菩萨身。所往相似者。若至刹利众。如彼色像。身量修短音声语言。悉与彼同。彼之所说。与彼同说。彼所不能为其开演。广说正法令欢喜已。即于前没不令彼知。谁出谁没。为天为人。如刹利婆罗门居士沙门众。四天王天。三十三天。夜摩天。兜率陀天。化乐天。他化自在天。梵身天。梵众天。大梵天。少光天。无量光天。光音天。少净天。无量净天。遍净天。无障天。福生天。广果天。无烦天。无热天。善见天。善现天。色究竟天。亦复如是。隐显者。于大众前作百作千。或复过是乃至无量。然后还没。没已复现。自在者。菩萨能令众生若来若去若住若语。障他神通者。如来神力悉能障蔽诸余神力。亦能令现究竟菩萨一生补处。除如来及等行菩萨。悉能障蔽其余菩萨。除上及等亦悉能障。与辩者。无辩众生能与辩才。与念者。于法失念能令忆念。与乐者。广说正法令彼得闻。随彼身心摄取饶益得止息乐。离诸阴盖专心听法随其时节。非究竟乐四大错乱能令调适。非人所恼亦令休息。放大光明者。谓佛菩萨神力放光遍至十方无量世界。地狱众生苦痛休息。上至诸天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。令见光明来至佛所。他方世界诸菩萨众悉皆来集。略说十方世界无量诸佛无量光明。饶益安乐无量众生。是名转变神足。若以种分别则无量无数。除其自性变为余事。是故名为转变神足

云何化神足。略说无事化作随其所欲悉能化现。是名化神足。是化多种。或化身或化语。化身者。或似自身或不似。或似他身或不似。又自身他身相似不相似。化作相似根及根所依。非作实根。又复化作相似境界。谓饮食众宝色香味触所摄众具。一切随意。又自身相似。或作一身。或作无量。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。种种色像。人及畜生饿鬼地狱。声闻缘觉菩萨如来。如是色像。随其所应悉能化作。自相似身。若异自身。名不相似。他天身等化令相似。是名他相似化。若作彼天不相似身。是名他身不相似化。如天身乃至佛身亦复如是。无量身者。谓佛菩萨。于十方无量无数世界。一时化作种种色像。饶益十方无量众生。佛及菩萨虽至余方。化住如故。或为众生暂现如幻。或作饮食衣服车乘金银真珠琉璃颇梨珂珼玉石如是等物一切化现。如实不异常得受用。是名化身

化语者。妙音具足。广音具足。或从自身起。或从他身起。或无所从起。或说正法。或随事教责。妙音者。谓佛菩萨化作口语。其声深远犹如雷震。或复微妙如迦陵毗伽音。可乐声。悦乐声。可爱声。如是广化无量音声。言辞辩正。易知喜闻。随顺无尽。广声者。谓佛菩萨。化大音声。令天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等。声闻缘觉诸大菩萨。无量众会。乃至一由旬。若内若外。周遍普闻。若小千世界。中千世界。大千世界。乃至十方无量世界。亦悉普闻。为众生故。从其自身。以一音声说无量法。从他起者。化作他语为人说法。除其放逸。无所从起者。空中化声犹如人语。说正法者。为愚痴众生演说正法。令得开解。随事教责者。彼虽不疑得信乐心而为放逸。令生惭愧起不放逸。如是众多。略说三种。化身。化声。化境界。是名化神足。若一一分别则有无量。如是诸佛菩萨二种神足。能办二事。一者为令众生生信乐故。神足现化令入佛法。二者摄苦众生安隐利益

云何宿命智通。谓佛菩萨自知宿命。如是众生是我名字。如契经广说。知他宿命亦如己身。自知宿命能令他知。所知众生本。同事者亦能令彼自识宿命。彼诸众生知与菩萨昔同事已。亦复知余众生与己同事。亦复能令其余众生展转相知。宿命名字名字等种种因缘。此中应广说。从今现在及过去世。乃至无量无数劫事。念念中间。巨细多少次第悉知是名诸佛菩萨宿命智通。菩萨自知宿世行菩萨道未曾有事。能为众生开示显现令其敬信。爱乐佛法厌离生死。亦为显示过去因果。令计常者远离常见。谓于过去妄想常见及以断见。云何生死智通。谓佛菩萨天眼清净过于人眼。见诸众生死时。好色恶色下色上色。乃至后生。渐渐增长诸根成熟。身诸所作善不善无记。天眼光明照见悉知。乃至化色天细微色。一切悉见。上至色究竟天下至无择地狱。于十方世界亦不一一别相方便。十方无量无边世界一切色像。一时普观。于彼彼佛刹彼彼如来种种大众会坐说法。如是一切悉见无余

云何天耳智通。谓佛菩萨以天耳闻天人音声。圣声非圣声。粗声细声辩声不辩声。化声非化声。远声近声一切悉闻。若作有限方便者。上至色究竟天。若无限者。乃至上方无量世界。天声者。从四天王乃至色究竟。人声者。一切四天下声。圣声者。谓诸佛菩萨声闻缘觉所出音声。教诫众生。所谓示教赞喜。令修善法舍不善法。彼诸众生无染心者。受诵论议如法问难。与念教诫及余一切善语利益。如是等声。是名圣声。非圣声者。谓诸众生妄语两舌恶口绮语。从无择狱上至诸天。诸方众生种种诸声。粗声者。谓大众生声。大众会声。种种苦痛迫切之声。相呼唤声。雷霆声。鼓贝声。细声者。乃至耳语极微细声辩声者。谓义理可解。不辩声者。谓义理不可解。如陀弥罗国语。风雨声草木声。鹦鹉鸲鹆声。拘耆罗声。命命鸟等众鸟之声。化声者。谓神通自在。随众生心化作诸声。远声者。除佛菩萨所住村落城邑中声。其余乃至十方无量世界一切音声。诸佛菩萨。以天眼见乃至十方身之所作净不净色。见已方便随宜利益。以天耳闻口之所行净不净声。闻已方便随宜利益。是名略说诸佛菩萨天眼天耳之所作为

云何知他心智通。谓佛菩萨以知他心智通。知十方无量无边世界众生烦恼缠心。知离烦恼缠心。知烦恼相续烦恼使心。知离烦恼相续烦恼使心。知邪愿心。所谓外道心及贪求心。知下心。谓欲界众生乃至禽兽心。知中心。谓色界天心。知上心。谓无色界天心。知苦相应心。知乐相应心。知不苦不乐相应心。一念他心智。知一众生心。随其所念悉如实知。一念他心智。知无量众生心。随其所念悉如实知。复次诸佛菩萨知他心智通。为种种根力。种种解力。种种界力。至处道力。漏尽力。随其所应而作方便

云何漏尽智通。谓佛菩萨烦恼尽如实知。谓己及众生。若尽若不尽。悉如实知。己及众生漏尽方便。已起未起悉如实知。彼诸众生起漏尽增上慢。不起漏尽增上慢。悉如实知。菩萨一切漏尽如实知。而不证漏尽。菩萨不舍烦恼。具诸有漏事。常行彼事而不染污。如是力者。名最上力。又佛菩萨漏尽智通。自离烦恼。亦为众生广分别说。令其舍离增上慢心。当作是知。是漏尽智业

云何法力。谓佛菩萨檀波罗蜜乃至般若波罗蜜。此六波罗蜜各有四事。一者对治。二者成菩提具。三者摄取自他。四者得未来果。云何布施四事。一者布施对治悭贪。二者成菩提具。三者以施摄取成就众生。欲施善心。清净心施。施已不悔。三时欢喜以自饶益。是名自摄。彼诸众生饥渴寒热疾病所须。众难恐怖悉令远离。以此饶益。是名摄他。四者以是因缘。在在所生。得大财富。得大种性。得大眷属。是名布施四功德力。无余无上

云何持戒四事。一者受身口律仪。对治犯戒。二者成菩提具。三者受持净戒。同利摄取成就众生。远离犯戒怨家恐怖卧觉常安。以自饶益。又持戒者。心不悔恨常得欢喜。乃至心定诸自利事。是名自摄。普施众生一切无畏。是名摄他。四者以是因缘命终生天。是名持戒四功德力。无余无上

云何忍辱四事。一者修忍对治不忍。二者成菩提具。三者以坚固忍。同利摄取成就众生。自身及他度大恐怖。是名自他俱摄。四者以是因缘。于未来世无有怨憎无别离者。既无别离亦无忧苦。临命终时心不悔恨。舍此身已生人天中。是名堪忍四功德力。无余无上

云何精进四事。一者精进对治懈怠。二者成菩提具。三者依勤精进。同利摄取成就众生精进乐住离诸恶法功德增长。欢喜悦豫以自饶益。是名自摄。精勤修善。不以身口恐怖众生。众生见已亦乐精进。是名摄他。四者以是因缘。于未来世能成大人奇特功业。是名精进四功德力。无余无上

云何禅定四事。一者禅定对治烦恼。言语乱觉喜乐色想烦恼悉灭。二者成菩提具。三者依诸禅定。同利摄取成就众生。住现法乐以自摄取。其心寂静离于贪欲。是名自摄。于诸众生不嗔不恼。是名摄他。四者以是因缘。于未来果报生于天上。智惠清净神通清净。是名禅定四功德力。无余无上

云何般若四事。一者智惠对治无明。二者成菩提具。三者布施爱语利益同利。摄取成就一切众生。于所知事随义了知。胜妙饶益欢喜悦豫。是名自摄。普为众生巧便说法。令得今世后世安乐。是名摄他。四者以是因缘。摄取一切平等善根。于未来世除障作证。所谓烦恼障及智惠障。是名智慧四功德力。无余无上。是名法力

云何诸佛菩萨俱生力。性识宿命利益众生。思惟长夜无间大苦。悉能堪忍饶益众生。众生爱乐其心随喜。生兜率天随寿命住。有三事胜蔽诸天人。一者天寿。二者天色。三者天名称。生母胎时。奇特光明充满世界。正知入胎。住胎出胎。生堕地时。即行七步举手而言。吾当于世为无上尊。天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等。以天香花伎乐幢幡。种种严饰而为供养。三十二相以自庄严。为最后身。诸魔怨恶所不能坏。坐佛树下慈心伏魔。一一支节有那罗延力。从初弱年为童子时。一切术艺种种技能。自然巧便不从师受。坐于道场菩提树下。无师自然成等正觉。梵王来下劝请说法。雷霆震击发大音声。不能动乱如来正受。恶兽亲附随顺无畏。诸众生类悉皆供养。如彼猿猴奉进香蜜。世尊哀受欢喜弄舞。神龙降雨洗浴其身。若出行时。辄为止雨。菩萨如是坐佛树下。树为曲枝随荫其躯。成正觉已。于六年中。天魔波旬。恒求其短不能得便。常得正念平等安住。一切众生。种种异知。种种异想。种种异觉。生住灭时念念悉知。如来以俱生力示现色身及圣威仪。摄取众生。示现身故。狂者得正。逆胎得顺。盲者得视。聋者得听。令三毒者离欲怒痴。以如是比示现色身。摄取众生。是名示现俱生神力。威仪俱生力者。常右胁卧如师子王。草蓐不乱。风不动衣。行如师子。步若牛王。先举右足次左足随。行处平正无沙砾瓦石。行时安详诸根寂静。若入门时下门为高。食无完过口口无遗。如是无量未曾有事。当知皆是圣威仪所摄俱生神力

云何诸佛菩萨不共声闻辟支佛力。云何共力。不共力者。略说三种。一者细。二者分别。三者界。诸佛菩萨。于无量无数阿僧祇众生。以无量力方便利益。悉如实知。是名为细。一切种神通力法力俱生力。满足成就。是名分别。一切世界一切众生界。是彼力境界。是名为界。声闻者。以二千世界内。国土世界。众生世界。为神通境界。缘觉者。以三千世界。为神通境界。何以故。彼自调伏故。非一切众生。是故唯一三千世界。以为境界。除此已。诸佛菩萨余神力。是名共力。声闻缘觉。尚不能及菩萨神力。况复人天外道凡夫。菩萨有三种示现力。一者神足。二者示他心。三者教诫。此亦神通所摄。随其所应。谓神足他心智。漏尽智

菩萨地持经卷第二菩萨地持经卷第三

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持方便处成熟品第六

云何成熟。略说有六种。一者自性成熟。二者人成熟。三者种分别成熟。四者方便成熟。五者人成熟。六者人相成熟。自性成熟者有善法种子。修习善法随顺二障。清净解脱身心有力。真实方便具足究竟。有佛无佛。堪能次第断烦恼障及智慧障。如痈已熟。至应破时。名之为熟。又如瓦瓶任用之时。名之为熟。亦如庵罗果等堪食用时。名之为熟。如是菩萨。修习善法真正方便。具足究竟次第堪任。离障清净。是名自性成熟。人成熟者。略说四种。有声闻种性。以声闻乘。而成熟之。有缘觉种性。以缘觉乘。而成熟之。有佛种性。以无上大乘。而成熟之。无种性者。则以善趣而成熟之。如是四种人。诸佛菩萨以此四事而成熟之。种分别成熟者。略说有六种。一者诸根成熟。二者善根成熟。三者智慧成熟。四者下成熟。五者中成熟。六者上成熟。诸根成熟者。寿具足。色具足。种性具足。自在具足。信言具足。大力具足。人具足。力具足。身得报果堪能勇猛精进方便。心无疲厌。于一切明处悉方便学。善根成熟者。性少烦恼不起恶法。阴盖轻微质直随顺。智慧成熟者。明慧具足。善说恶说能解义趣。受持分别生智成熟。堪能究竟离诸烦恼。诸根成熟解脱报障。善根成熟解脱业障。智慧成熟解脱烦恼障。下成熟者。有二因缘。一者不久修习诸根善根智慧因缘。一者修习下因。中成熟者。于此二因缘。一胜一劣。上成熟者。当知俱胜

方便成熟者。有二十七种。一者界充满。二者现缘饶益三者度。四者爱乐摄受。五者初处。六者非初处。七者远净。八者近净。九者方便。十者净心。十一者财饶益。十二者法饶益。十三者神足。十四者说法。十五者隐覆说法。十六者显现说法。十七者下方便。十八者中方便。十九者上方便。二十者闻。二十一者思。二十二者修。二十三者摄取。二十四者伏取。二十五者自作。二十六者请他作。二十七者俱作。界充满者。善法种子生长具足。依先修习。善法种子展转相因。增长充满。是名界充满。现缘饶益者。于现在世。不倒说法不倒受持善随顺法。法次法向界充满者。以本因故。现在成熟。现缘饶益者。现在世因现在成熟。度者。亲近善友信心得生。信增上已。离家恶行受持禁戒。非家出家受离欲戒。爱乐摄受者。出苦道迹。欲乐苦行。二俱远离。行于乐道深乐佛法。初处者。以初厌法修行厌离。知胜妙义度功德利。非初处者。已度成熟。于现在世。不离亲近诸佛菩萨。增长住处渐渐增进。转胜成熟。远净者。起懈怠心修行远缘。流转生死经历劫数。堪任清净与此相违。名为近。净方便者。得诸善义欣乐奉行。畏厌来世恶道众苦。于现世中畏恶名称。受持禁戒常行顿行。净心者。正观诸法次第堪忍。于正法中无能坏者亦令众生修习正法。于三宝中得善胜义。信心不动。财饶益者。随其所须。衣食众具一切施与。法饶益者。欲受法者授之以法。乐受义者。为说正义。神足者。神力示现哀愍众生令得信乐。信增上已。修方便净。彼诸众生。若见若闻大神变已。于正法中得清净心。修善方便。说法者。自善解义能为人说。己及众生与正道俱。疾成大智随顺说法隐覆说法者。于少智众生覆藏深义。为说粗现易行之法。显现说法者。智慧众生深入佛法。为说甚深微妙之处。下方便者。不常方便。不顿方便。中方便者。或常方便。或顿方便。行一舍一。不能具足。上方便者。具二方便。闻者。解佛所说修多罗等种种经法。受持诵习精勤方便。思者。于寂静处思惟诸法。开解通达决定法相。修者。谓止举舍。止观前行。修习深乐。止观舍心。摄取者。依止无贪心修行布施。瞻视和上诸师疾病。供施衣食汤药众具。若有忧悔及余烦恼。能为开解。修如是等如法供养。伏取者。心正思惟自护烦恼。见余众生若有毁失。下犯诃责。中犯折伏。上犯驱出。呵责折伏。为安乐彼及余众生。若驱出者。还听忏悔。既安乐彼兼利余人。若不还悔安乐余人。余人见彼犯罪驱出。因是自护。自作者。自如法住随顺说法。令他众生出不善处安立善处。若不如法住众人当言。汝今云何。教授他人发举与念。他应教汝发举与念。请他者。彼善方便巧说法者。众所知识增上爱敬。劝请说法成熟众生。俱者。谓自作劝他。二俱成熟。此二十七种方便成熟。彼六种成熟。分别具足。所谓诸根成熟。善根成熟。智慧成熟。下中上成熟

人成熟者。略说六种。菩萨住于六地成熟众生。谓住解行地菩萨行解行住。净心地菩萨行净心。住行道迹地菩萨行道迹。住决定地菩萨住决定住决定行地菩萨行决定行。住究竟地菩萨到究竟。无种性处人。善趣成熟。数退数进。有种性处人。令得成熟。无有退失。数数增进

人相成熟者。本习声闻。住下成熟者。下欲下方便未离恶趣。于现法中不得沙门果。于现法中不得涅槃。住中成熟者。中欲中方便不堕恶趣。于现法中得沙门果。不得涅槃。住上成熟者。上欲上方便不堕恶趣。于现法中得沙门果及般涅槃。住上成熟者。上欲上方便。于现法中得沙门果及般涅槃。成辟支佛如声闻。何以故。道同声闻故。胜声闻者。谓最后身无师自悟。本习力故。修三十七品断一切结。得阿罗汉证。故名缘觉。又菩萨住解行地者当知下成熟。净心地者中成熟。决定究竟者上成熟住下成熟菩萨。下欲下方便未离恶趣。当知是第一阿僧祇满。炽然不动。快净道品悉不成就。住中成熟菩萨。中欲中方便不堕恶趣。第二阿僧祇满。炽然不动。道品成就快净不成就。住上成熟菩萨。上欲上方便不堕恶趣。第三阿僧祇满炽然不动。快净道品一切成熟。其性淳厚具足炽然。增上妙果增上福利。故名炽然。不还不退坚固升进。故名不动。于菩萨地清净无上。故名快净

彼中财利成熟。神足成熟。隐覆说法成熟。下方便成熟。闻惠成熟。此五种成熟。久远修习犹尚为下。况复近修。余一切成熟事。一一三种说。谓下下下中下上。中下中中中上。上下上中上上。如是等下中上分别。则有无量成熟。当知诸佛菩萨成熟众生。彼菩萨于此成熟事。如所说自熟。佛法诸根成熟。善根成熟。智慧成熟。下中上行成熟。以三乘法。成熟众生

    菩萨地持方便处无上菩提品第七

云何为菩提。略说二种断二种智。是名菩提。二种断者。烦恼障断。及智障断。二种智者。烦恼障断。离垢清净一切烦恼不相续智。及智障断。一切所知无障碍智。复次清净智。一切智。无碍智。灭一切烦恼习。清净明达永断无余。是名无上菩提。彼一切烦恼习究竟断智。是名为清净智。一切界一切事一切种一切时无碍智。是名一切智。界者二种。世界及众生界。事者二种。有为无为。如是有为无为事。无量种分别。自相差别分别。总相差别分别。因果分别。界分别趣分别。善不善无记等分别。时者有三时。过去未来现在。如是知一切界一切事一切种一切时。是名一切智。不假方便发心即知。于一切法了达无碍。是名无碍智。复次百四十不共佛法。及如来无诤智愿智无碍辩。是名无上菩提。百四十不共佛法者。三十二大人相。八十随形好。四无碍智。一切种清净。十力四无畏。三念处三不护。大悲不忘法。断除诸习。一切种妙智。是诸佛法。安立品当广说

无上菩提者。具七无上。于一切菩提最为无上。云何七无上。一者身无上。二者道无上。三者正无上。四者智无上。五者神力无上。六者断无上。七者住无上。如来三十二相庄严其身。是名身无上。如来自度度人。多所过度哀愍世间。利益安乐诸天世人。是名道无上。如来无上无等四正成就。谓正戒正见正威仪正命。是名正无上。如来无上无等四无碍智成就。法无碍义无碍辞无碍乐说无碍。是名智无上。如来无上无等六神通成就。如前说。是名神力无上。如来无上无等一切烦恼习断。智障断成就二断。是名断无上。如来无上无等三种住多于中住。圣住天住梵住。是名住无上。空无相无作。灭尽正受。是名圣住。四禅四无色定。是名天住。四无量心。是名梵住。于彼三住中。四无上住如来多住圣住中住空三昧及灭尽定。天住中住第四禅。梵住中住大悲。如来以是。昼夜六时。常以佛眼观察世间。谁应度者。未起善根我当令起。乃至谁应得无上果。我当建立。是名住无上。身无上者。名大丈夫。道无上者。名为大悲。正无上者。名大戒大法。智无上者。名为大惠。力无上者。名大神通。断无上者。名大解脱。住无上者。名大住多住

复次如来。有十种名称功德随念功德。云何十。如来应等正觉明行足善逝世间解无上士调御丈夫天人师佛婆伽婆。非不如说。故名如来。得一切义故。无上福田故。应供养故。故名为应。如第一义开觉故。名等正觉。三明如契经所说。行者。止观具足故。名明行足。第一上升永不复还。是名善逝。知世界众生界一切种烦恼及清净。是名世间解。第一调伏心巧方便智。一切世间唯一丈夫。是名无上调御士。四种真实智。义法真实故。显示不了义故。依一切义故。广宣说故。断一切疑故显示甚深清白处故。为诸法根故。为一切法导故。为一切舍故。脱一切苦师演说法义。正诸天人。是名天人师。义饶益聚。非义饶益聚。非义非非义饶益聚。具足一切种平等开觉是。名为佛(此三聚是善不善无记)。坏一切魔力故。是名婆伽婆。或无量劫无一佛出世。或一劫中多佛出世。于彼彼十方无量世界。有无量无边阿僧祇佛出现于世。何以故。十方世界有无量菩萨。俱发大愿故。若一菩萨。如是日如是分如是月如是岁发菩提心一切菩萨。亦复如是。即于此日此分此月此岁发菩提心。同一威仪同一堪能同一方便。一切菩萨亦复如是。一世界有无量菩萨。同愿同施同戒同忍同精进同禅定同智慧。况复十方无量世界。一一世界各有无量无数菩萨。无二菩萨同愿同行。于一国土俱时成佛。况复无量一时俱成。又一切菩萨一时同行次第成佛。是亦不然。亦非一成余悉不成。是故十方无量世界。随其所净空无佛处。同行菩萨各各成佛。是故无量世界有无量佛

无一世界二佛俱出。何以故。菩萨长夜作如是愿如是方便。我当于一无佛法处广说正法调伏众生。令脱众苦入于涅槃。如是长夜长养大愿。摄受正道大愿。果成。又一如来。能于三千大千刹土。悉能施作一切佛事。第二佛出无所利益。复次一世界中一佛出世。能令众生自事决定勤修随顺。何以故。彼作是念。一切世界唯一如来。教化周已当入涅槃。更无有佛能令我等修行梵行听受正法。念已疾行淳修精进。修行梵行听受正法。若多佛者不速勤修。以是故。说一世界中唯一如来。众生自为决定勤修

一切如来等无差别。唯除四事。一者寿命。二者名称。三者种性。四者色身。唯此四事有增减相。非余功德。亦非女人得无上菩提。何以故。菩萨于初阿僧祇劫已舍女身。乃至坐佛树下不受女身。一切女人性多烦恼。成就恶智。不以烦恼恶智能得无上菩提

如是无上菩提有无量义。举要言之。有自性义。无上义。名称功德义。随念功德义。堪能义。最胜义。悉如上说。当知真实。复次不思议度诸思议。无量无边功德具足。出过一切声闻辟支佛上。是故名阿耨多罗三藐三菩提。第一最胜无等无上

    菩萨地持方便处力种性品第八

已说菩萨所学处。菩萨学今当说。如是菩萨欲善学菩萨学者。有七事。一者先当多修信解。二者求法。三者说法。四者法次法向。五者正教授。六者教诫。七者摄方便身口意业。云何菩萨多修信解。菩萨于八种解处。净信在前。一心决定乐欲成就。所谓三宝功德。佛法僧功德。诸佛菩萨自在神力。如上所说。真实之义。如上所说。若种种因若种种果。随顺相应而不颠倒。得义得方便。堪任能得。有得方便则能得义。彼得义者。无上菩提。得方便者。一切菩萨所修学道。所谓信解善说。谓修多罗。祇夜。受记。无量言教。微妙善说。菩萨于此八种解处。有二种解力。一者多修解行。二者深忍乐着。彼菩萨求法者。何法求云何求何故求。何法求者。略说。求菩萨藏。声闻藏。外论。世工业处智。十二部经。唯方广部是菩萨藏。余十一部是声闻藏。外论者。略说有三种因论。声论。医方论。世工业处智者。谓种种事业。如金师铁师水师等。及余种种明处所摄。明处者有五种。一者内明处。二者因明处。三者声明处。四者医方明处。五者工业明处。此五种明处菩萨悉求。佛所说者。名为内论略说二种。一者显示正因果。二者显示所作不坏不作不受。因论亦二种。一者能屈他论。二者自申己义。声论有。二种一者显示界色(界与色此二种是声之差别非常所谓阴界形色根本声名为界界有种种别声名为色此二声总一切音声音声论此中应广说)。二者显示巧便言辞。医方论有四种。一者显示善知病。二者显示病因。三者显示能除已起之病。四者显示已除之病。令不重起。世工业处智者。显示种种世业成就。云何是佛所说。不颠倒因有十种。不颠倒因。当知摄一切因一切烦恼一切清净一切无记等。云何为十一者随说因。二者以有因。三者种殖因。四者摄因。五者生因。六者长因。七者自种因。八者共事因。九者相违因。十者不相违因。彼一切法名。名已想。想已说。此诸法名想言说。是名随说因。以有事故有所作。是名以有因。以有手故有所作。以有足故有游行。以有身故有屈申。以有饥渴故有求饮食。如是比无量无数名以有因种诸种子。名种殖因。水土润泽。是名摄因。种子于芽。是名生因。芽茎相续乃至成熟。是名长因种种种子各各自生。是名自种因。彼以有因种殖因摄因生因长因自种因。此六因总说共事因。障碍于生。名相违因。不障碍者。名不相违因。彼相违有六种一者语相违。谓沙门婆罗门所说经论。前后相违。二者所应相违。谓说一切义与理相违。三者生相违。谓生缘不具。障碍于生四者处相违。谓明暗爱恚苦乐等法。五者怨相违。谓毒蛇鼠狼猫鼠。是等虫兽各各怨害。六者对治相违。谓修不净对治贪欲。慈息嗔恚。悲止害觉。无漏道品永断烦恼。此中以生相违故。说此诸因二因所摄。一者生因。二者方便因。若种诸种子生。是名生因。诸余因。是名方便因

复次有四缘。因缘次第缘缘缘增上缘。生因者。是因缘。方便因者。是增上缘。次第缘缘缘者。是心心数法。谓前生心心数法。开导摄受缘摄受生。是故二缘摄因所摄

云何此十因。生一切世间。事云何生一切烦恼。云何生一切清净。若种种谷数世间资生。名想言说。所谓黍稷稻梁胡麻豆麦是名随说因。如大麦若持来若持去。若取若与。如是等种种言说。余一切亦如是以有饥渴身。羸瘦故求索抟食。如是等此名以有因。若种诸种子各各自生。彼初殖种子。是名种殖因(初种种子于后芽茎乃至成熟是名种殖因初种生芽是名生因)。水土润泽令芽得生。是名摄因。彼种子于芽。是名生因。复次芽茎枝叶展转相续。乃至成熟。是名长因。如麦种子。麦芽生非余。余亦如是。是名自种因。彼一切以有因乃至自种因。悉名共事因。以一切和合生故名共事因。霜雹灾害障碍破坏。是名相违因。彼不具不障。是名不相违因诸余一切世间事。皆十因所生。随所宜应当知

彼一切缘起名想言说。所谓无明行识名色六入触受爱取有生老病死忧悲苦恼。是名烦恼随说因。无明缘行。乃至生缘老死等。言说境界顾念味着。诸有支生。是名烦恼以有因。无明等法。现法种子。生余生生老病死。是名种殖因。不近善友听受正法。习不正思惟。无明等生。是名摄因。各各种子无明等生。是名生因。从无明至后有增进相求。至余生生老病死。是名长因。种种种子。俱从无明乃至后有。生地狱饿鬼畜生。及诸人天。是名烦恼自种因。从以有因乃至自种因。是名共事因。若有种性。值佛出世演说善法。近善知识听受善法。正念思惟。法次法向清净道品。是名烦恼相违因。如上说不具者。是名不相违因。是名十因。生一切烦恼应当知

彼一切净法乃至灭尽涅槃。名想言说。是名净法随说因。此念处正勤。乃至八圣道。无明灭乃至生老病死灭。如是名想言说。是名净法随说因。彼以有无明等故。乐求净法。摄受净法。净法得生。是名以有因。若种性具足人。向有余无余涅槃最先行者。是名清净种殖因。彼种性所摄。无漏道品种子。于诸道品法。是名生因。近善知识听受善法。正思惟修。诸根成熟。是名摄因。彼种子。生道品法。向无余涅槃。是名长因。彼声闻种性。以声闻乘而般涅槃。缘觉种性。以缘觉乘而般涅槃。大乘种性。以无上大乘而般涅槃。是名自种因。从以有因乃至自种因。是名共事因。种性不具。不值佛世。生诸难处。不近善友。不闻善法。不正思惟。习行邪道。是名净法相违因。此相违不具者。是名不相违因。诸烦恼相违因。是净法因。净法相违因。是烦恼因。如是烦恼十因。清净十因。过去未来烦恼清净。皆亦如是。无余无上

云何为果。略说五种。一者报果。二者依果。三者解脱果。四者士夫果。五者增上果。若不善法得恶趣报。有漏善法得善趣报。是名报果。若习不善法。乐住不善法。增不善法。若习善法。乐住善法。增益善法。先业相似后果生。是名依果。八圣道灭诸烦恼。名解脱果。若复世俗灭诸烦恼。彼不究竟舍离凡夫。非解脱果。若于现法。依种种世间工巧处业诸士夫事。所谓田种贩卖。宰官理务。书画算数。卜占印封。各有果生。是名士夫果。眼识是眼根增上果。乃至意识是意根增上果。生理不坏是命根增上果。一切二十二根。各为增上。各有果生。当知皆是增上果。此二十二根增上如摄事处说。如是菩萨知佛显示正因果已。于处非处智力种性。次第修习清净增长。非不作异作。有所成熟。亦无自所作业经劫而失。作者不失。不作不受。佛所显示。如是菩萨如实知已。自业智力种性。次第修习清净增长

云何菩萨求闻法。是菩萨住殷勤恭敬。求善说法。善语法。如是比略说善说法住。勤恭敬住。若菩萨为闻一善说法。路由恶道大地炽然。犹尚欢喜从中而过。况为多闻。为一闻法。犹尚不惜所爱之身。况余资生。一闻说法。爱乐恭敬。比前爱敬百千万倍。乃至算数譬喻不得为比。谓闻善说法心无厌足。增益净信其身柔软。心直见直深乐功德。至说法所无留难心。恭敬除慢。但求正法不求名称。为己及他修诸善根。不为利养至说法所。不染心听法。不乱心听法。不染污心听法者。离贡高烦恼。及轻想烦恼。下想烦恼。有七行离贡高烦恼。一者时听。二者欲受。三者顿听。四者敬听。五者不戏。六者随顺。七者不求过失。如是七行。离贡高烦恼。有四行离轻想烦恼。一者恭敬法。二者恭敬说法人。三者不轻法。四者不轻说法人。如是四行。离轻想烦恼。一行离下想烦恼。所谓听受正法不自轻听法。以此一行离下想烦恼。离如是等过听受正法。是名菩萨不染心听法。云何不乱心听法。有四行。一者一心。二者侧听。三者定意。四者一向专乐听受正法。是名菩萨求闻法

菩萨何故求闻法。菩萨求佛所说法。为受正法次法向故。为他广说故。菩萨求因论者。欲知彼论过故。欲降伏异论故。未信佛法者令生信故。已生信者令增广故。菩萨求声论者。广为众生演说正语令爱乐故。为净庄严辞句味故。于一义中种种言辞庄严故。菩萨求医方论者。为除众生种种病故。摄受大众故。菩萨求世间工业处智者。为少方便获致大财饶益无量诸众生故。为教众生种种事业故。如是菩萨求五明处。为无上菩提大智众具究竟满故。非不次第。学一切法而得一切无障碍智。是名菩萨所求如所求所为求

菩萨为他说者。何所说云何说何故说。彼如所求法。如是法说。如所求义。如是义说。以二因缘故说。一者随顺说。二者清净说。随顺说者。住如法威仪说。非不如法。不为高坐无病者说。覆头者在前行者。悉不为说。如修多罗广说。何以故。诸佛菩萨自恭敬法。以敬法故。令余众生深起恭敬。闻已奉持不起轻慢。一切说。一切无间说。不为法悭不作师惓。如次第句味说。如次第句味受。如次第义分别说。义饶益及法饶益。种种义饶益。示所应示。授所应授。照所应照。喜所应喜。现智比智。从师具闻而为人说。非不思量。具足听闻顺向善趣。不乱说善说不深隐说。应四圣谛。随众所应而为广说。此十五种。菩萨普为众生随顺善说。一切利他应当知

复次菩萨于不饶益己者住慈心为说。恶趣行者住安隐心说。苦乐众生放逸贫乞者住安乐哀愍心说。不以嫉缠故自叹毁他。离贪着心不求名利为他说法。如是五种。菩萨清净说法。前后略说二十种。一者时。二者顿。三者次第。四者相续。五者堪耐。六者欢喜。七者欲。八者喜。九者劝。十者不毁。十一者应。十二者文字具足。十三者不杂。十四者如法。十五者随众。十六者慈心。十七者安心。十八者哀愍心。十九者不自誉毁人。二十者不依名利。是名菩萨为他说法

云何菩萨法次法向。略说五种。如所求如所摄法。身口意随转。正思及修。若此法世尊制身口意所作。及若此法听身口意所作。彼身口意业。如是离。如是修。身口意随转。是名法次法向。彼正思者。菩萨独一静处。如所闻法思惟称量观察。先离如是不思处。思量于法。勤思常思顿思。方便不息。又菩萨正思具足。具足行随顺入。有所舍。依义不依于味。闇说明说。如实知。先思量应入者。入已入者。数数思惟。菩萨离不思处者。不随愚心乱心。勤思常思顿思。具足者。未知义者。令得知之。已知义者。不失不忘。具足者。有所入所行。不由他人。能具观察。有所舍者。若知诸法非其境界。当自念言。此佛所知非我境界。如是不谤。自无罪咎。菩萨依义不依味者。善入如来隐密之说。善知闇说明说者。于真实义莫能动摇。初入正思菩萨。先未得忍。于今得之。已得忍者。坚固随顺入于修慧。如是八种。菩萨正思所摄。法次法向修者。略说四种。一者止。二者观。三者修习止观。四者乐止观。止者。谓菩萨八种正思。善正真实。离言说法。若事若义。系心缘中。远离一切虚伪轻躁及诸忆想。缘中解脱系心安立。内三昧相。广说乃至一心。是名为止。观者。彼止所熏修。忆念思惟。如正思法相。忆念选择。乃至明慧。是名为观。修止观者。若行止观。常修方便。顿修方便。是名修习止观。乐止观者。彼彼止观相。心住不动。不勤方便。能自观察。处所摄受心不散乱。是名乐止观。彼菩萨如是如是修习止观。如是如是乐住止观。如是如是乐住止观如是如是止观清净。如是如是止观清净。如是如是身心猗息渐渐增广。如是如是观清净。如是如是知见增广。如是如是习行。修慧者离身心恶。于一切所知知见清净。一切修慧业皆从如是四种修生

云何教授。略说八种教授。菩萨依三摩提。教修行者。若无余。菩萨教者。则自教授。如诸佛法。先当如是知四种求。一者心求者知心求二者根求者知根求。三者悕望求者知悕望求。四者使求者知使求。五者随其所应种种度门。而度脱之。所谓不净慈心。缘起界分别。安那般那念。是名随应度门而度脱之。六者执常边对治。为说中道。七者执断边对治。为说中道。八者除不作作增上慢。不得得不触触不证证增上慢。彼八种教授。略说三处所摄。三处者。先未住心。令系念缘中。已住心者。说得自义。正方便道。未究竟者。令舍中住。知彼心根悕望结使。随应度门而度脱之。令心止住系念缘中。彼执断常对治。为说中道。令住心者。成就自义。正方便道。彼不作作慢乃至不证证慢。未究竟者。令舍中住。如是三事。摄八种教授。如是菩萨。从他受教。教授他已。八力种性清净增长。所谓禅定解脱三昧正受智力。诸根利钝智力。种种解智力。种种界智力。一切至处道智力。宿命智力。生死智力。漏尽智力

云何教诫。略说五种。有罪行者制。无罪行者听。若制若听法。有缺减者。如法举之。数数违犯者。折伏与念。不浊不变淳净正向。若制若听法。真实功德。爱念称叹。令其欢喜。是名略说菩萨五事教诫。所谓若制若听。若举若折伏若欢喜

云何菩萨摄方便。身口意业。略说菩萨四摄事。是名方便。如世尊说四摄事。是名方便。略说四种方便。调伏众生摄取众生。无余无上。一者随摄方便。二者摄方便。三者度方便。四者随顺方便。菩萨种种财施。随摄众生故。莫不信受奉顺修行。是名布施随摄方便次行爱语。愚痴众生舍离痴冥。令无有余具摄显示。是名爱语摄方便。具摄显示已。令彼众生舍不善处觉授与善处。调伏乐住。是名行利度方便。如是菩萨。以同事随顺度脱众生。调伏恭敬。不作是言。汝自无信戒施多闻。云何教他。举罪与念。是名菩萨同利随顺摄方便。如是四摄方便。若总若别。是名菩萨摄方便。身口意业等摄众生调伏成就

菩萨地持经卷第三菩萨地持经卷第四

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持方便处施品第九

复次菩萨。次第满足六波罗蜜已。得阿耨多罗三藐三菩提。所谓檀波罗蜜。尸波罗蜜。羼提波罗蜜。毗梨耶波罗蜜。禅波罗蜜。般若波罗蜜。云何菩萨檀波罗蜜。略说有九种。一者自性施。二者一切施。三者难施。四者一切门施。五者善人施。六者一切行施。七者除恼施。八者此世他世乐施。九者清净施。自性施者。谓菩萨思愿与无贪俱。不惜财身起身口业。舍所施物。舍如法财。住律仪处。见未来果。以如是义。施与众生。是名自性施

一切施者。略说有二种施物。一者内物。二者外物。菩萨舍身。是名内施。若菩萨为食吐众生。食已吐施。是名内外施。除上所说。是名外施。菩萨内施。复有二种。一者随所欲作。他力自在。舍身布施。譬如有人。为衣食故。系属于人为他仆使。如是菩萨不为利养。但为无上菩提。为安乐众生。为满足檀波罗蜜。随所欲作。他力自在。舍身布施。二者随他所须。头目手足种种支节血肉筋骨乃至髓脑随其所求一切施与。菩萨外施。复有二种。一者随其所求。受用乐具欢喜施与。二者奉事彼故。一切舍心。一切施与

菩萨于内外物非无差别。等施一切。或有所施。或有不施。若于众生乐而不安。不乐不安。则不施与。若于众生安而不乐。亦安亦乐。是则尽施。如是略说应施不施。次当广说。若菩萨布施令他受苦。若致逼迫。若被侵欺。及非法求。自力他力不随所欲。菩萨为众生故。宁自弃舍百千身命。不随彼欲令致逼迫残害欺诳。菩萨净心修行布施。饶益无量诸众生时。有求身体头目支节。则不施与。何以故。非是菩萨行净施时。作是念言。是可与是不可与。心生退弱。是故菩萨。以清净心不舍现前。利益众生舍身布施。虽不舍身不违净心。若彼魔天及魔所使。欲行恐怖求其身分。则不施与。不欲令彼得大罪故。或有众生。若狂若乱求其身分。亦不为彼而舍身命。不自住心故。心恼乱故。心不自在故。与上相违来求请者。随其所欲为舍身命。是名菩萨内物应施不应施

菩萨外不施者。若有众生求毒火刀酒。为欲自害若欲害他。是则不施。若为自摄若为摄他。是则施与。若是他财。先不同意不以施人。菩萨不为媒行以此授彼。有虫饮食悉不施与。若有众生。为作戏乐非义饶益。来乞求者。菩萨不施。何以故。若施与者。于菩萨所虽少欢喜。而多起恶行。身坏命终堕于恶道。若戏乐具。不堕恶趣不起善根。而令众生因此成熟为摄取故。是则施与。何者可与何者不可与。谓学捕猎杀生极大贪着。作大方便多杀众生。如是比会菩萨不为。亦不教他。杀羊祀天。亦不施与。恼众生者。来求水陆多众生处。悉不施与。为欲学作罩罗机网。世间种种恼众生具。亦不施与。若骂若杀若缚若罚。亦不自作亦不教他。若怨家怨家子。悉不施与。略说一切逼迫众生戏乐之具。悉不施与

若复种种象马车舆。衣服庄严丰美饮食习学歌舞种种众具。涂身香花。严饰珍玩。园林楼观。舍宅男女。种种技术工巧业处。如是一切戏乐众具。为信乐因缘来请求者。一切尽施。若彼众生。不自知量及不应病。种种饮食。是悉不施。若已饱食。性贪欲得。亦不施与。若有众生。不堪忧恼。求欲自杀食毒投岩。如是等求。悉不施与。若菩萨为王统领多国。不以他人妻子施与。除城邑村落人民赋税。应属我者。则以施之。菩萨所爱妻子奴婢。若施人时。先以软语。方便开喻。若不乐者则不施与。若其乐者随所应施。若恶知识恶人恶鬼。是等来求。悉不施与。亦不施彼令作奴婢。若有恶人来求王位。则不施与。若此恶人。先为王者。菩萨有力则便废退。父母妻子奴婢财物。不以施人。若因布施父母忧恼。妻子僮仆由是致苦。如是等施。菩萨不为。非法之物不以施人。凡所施物。清净如法。不逼迫呵责取他财物而行布施。不犯佛戒而行布施

菩萨于一切众生。平等心施。作福田想。亦不分别怨亲中人功德过恶。是下中上是苦是乐

菩萨不如所求如所许后以少施。亦不先许胜物后施粗恶。若施胜物。心无不泰。不恨不乱。菩萨施已。不自称叹言。我于汝所惠弘多。若施下流不起轻想。况复有德所应恭敬。若有众生住诸恶行。掉动毁戒骂詈嗔恚。亦不悒戚悔恨心施。方于彼所起怜愍心不以邪见而行布施。所谓大会。杀生求法。不为希有吉庆会故而行布施。不为清净一切行分故而行布施。求世间出世间离欲清净。除为清净方便而行布施。不求果报而行布施。一切布施。悉用回向无上菩提。菩萨自知。一切种施因缘故。生一切种如实果报。不由于他而行布施。所谓施食得力。施衣得色。施乘得乐。施灯得眼。如是一切应当广说。菩萨亦不畏贫穷而行布施。以慈悲故而行布施。菩萨亦不以不如法食施来求者。所谓施出家人余残饮食。便利涕唾脓血污食。不语不知饭及麦饭。法应弃者。谓不葱食。葱杂葱污。如是不肉食不酒饮。酒杂酒污。如如法业和合菩萨施人。如是等不如法施不以施人。菩萨不令求者数数往返留难生恼。然后方施。菩萨不以谄故而行布施。如是若王大臣长者居士。此诸檀越知我施已。必当恭敬供养于我。不为要他作使故施。少物尚施。况复多物。不以布施起他贪着。为生患难令致倾灭。不以布施离他城邑。谓以施摄。令其属己。菩萨智慧精进不息。堪能具足自誓庄严。先自行施然后教他。不自懈怠教人行施。一切大会持戒犯戒。从上至下次第等施。菩萨得财多少随舍。不待积聚然后行施。不畏他故而行布施。所谓若嗔若打若责若毁杀缚驱摈。不畏是等而行布施。菩萨欲施心悦。施时欢喜。施已无悔。不以相似摩尼真珠珂珼玉石琉璃珊瑚虚伪之物欺诳他人

菩萨所畜一切财物。初得物时发心舍与一切众生。后来求者自求己物。菩萨时施非不时施。自他净施非不清净。如威仪施非不威仪。决定心施非不定心。见来求者终不嗤笑。亦不轻弄亦不颦蹙。先语称赞然后施与。时应所求不为留难。若彼不求开心自施。若自来取恣听所欲

菩萨不以恶智而行布施。常以善智而修施业。智慧施者。菩萨自量财物多少。随其所宜而行惠施。见来求者作是念言。彼来求者。有二种人。一者富乐非是贫下。亦非孤独有所依怙。二者贫苦。孤茕下贱无所依怙。作是念言。若我财多。当令具足。若财少者。先当周给与彼贫乞无依怙者。先作是念。如所念施。于彼富人不满其意。当以本心辞谢发遣。唯愿仁者勿生恨心

菩萨若见悭贪众生财富无量。自为身惜不敢衣食。往诣其所共为亲善。与作同意而语之言。汝若贪惜不能施与。我舍乃有无量财物。欲行满足檀波罗蜜。普为一切乞求众生。若有众生。从汝求者。可来我舍取财施与。勿令空去。若难自取发遣使来。于我施时汝当随喜。彼闻此已心大欣悦。于我无损彼蒙饶益。因与菩萨共相亲爱。今虽未能即时行施。已种来世离悭种子。以彼次第修习自知为本。以巧方便教令少施。依下无贪教令至中。依中至上

复次菩萨若和上阿阇梨若共住弟子。近住弟子净修梵行。受性悭贪。若不悭贪。财物不具拥其施心。菩萨以己财物向佛法僧欲施作福。舍持与彼令其造作。己自不为。如是菩萨功德更增。令悭贪者降伏烦恼。彼乐法者亦满其愿。如是摄取成熟众生。复次菩萨见彼来者。有求索相。知其心已不令发言。随其所须施令满足。若有商价欺诳他时。菩萨知已。覆藏不说。彼作恶行欺诳他人。尚为覆藏。况复自身。欲满彼愿随意与财。彼无惭愧得已欢喜。无所畏惧熙悦而去。若菩萨为彼商人所欺。先不觉知欺已乃觉。亦不责彼不令忆念。不欲令彼犯不与取。起随喜心。如是等舍所施物。是名菩萨智慧布施

复次菩萨无财施时。先所造作世间工巧。彼业现前。以少方便多获财利。用施众生。若复为他庄严说法。美善说法。慈心说法。贫苦闻法欢喜供养。何况富乐。悭者无惜。况常乐施若有信心长者居士。常习行施。财富无量将求者往令彼饶益彼所行施。所作功德。自身往助。堪能具足。信心清净身口意业。随其力能助彼营理。令其无碍。满足求者。彼乏事力。施事难成。若随朋党。若非法行。若失正念。如是等若菩萨无财。以智慧施。乃至未得净心。净心菩萨不堕恶趣。生生常得无尽之财

复次菩萨知彼邪见求法短者。不授其法不与经卷。若性贪财卖经卷者。亦不施与。若得经卷隐藏不现。亦不施与。若非彼人所知义者。亦不施与。若是彼人所知义者。菩萨于此经卷。已自知义则便持经。随所乐与。若未知义。自须修学。又知他人有如是经示语其处。若更书与。若无示处复不得书。菩萨当复自观其心。为是法悭缠心不能施耶。为更有为不施彼耶。作如是自观已。若少有法悭者当持经与。为法施故。我宁以法施。现世痴哑为除烦恼。犹尚应施。况作将来智慧方便。如是观时。无少许法悭者。彼菩萨应当自学。我为除烦恼故修行法施。满足智慧方便故修行法施。爱念众生故修行法施。菩萨自见内无烦恼。见不施彼。现得智慧。于未来世转增无量。非施彼故。得是功德。经法施者。于未来世获少法利。不及自学智慧开觉。今虽不施必将安乐一切众生。施其智慧。宁为一切今不施与。不为一人与其经卷。如实知已。不施彼者。无有过咎。亦无悔恨。不越菩萨所受禁戒

云何菩萨方便不施。不忍直言必定不与。要以软语开解发遣。作是方便有而不施。菩萨本来所畜众具一切施物。以清净心于一切十方诸佛菩萨舍作净施已。譬如比丘以己衣物于和上阿阇梨所舍作净施。如是作净施因缘故。得畜种种无量财物。故名住圣种菩萨。亦得无量功德。常自忆念如是功德。于一切时常随增长。凡是净施所畜之物。为诸佛菩萨受寄护持。见彼来求观察其人有成就相。先所舍物作净施者。取以与之。诸佛菩萨于一切众生无不舍之物。作如是知。满求者意。观察彼人无成就相。以净施法而开解之。称言贤首。此物先舍。已有所属。软语发遣不令致恨。若以余物两三倍施。作是方便。令知菩萨不以悭故而不惠施。当以不自在故不以施我。如是经法则不施与。菩萨作如是法施者。名智慧施

复次菩萨一切施。所谓法施财施无畏施。比类相貌。若名若义。分别因果。如实知已而行布施。是名菩萨智慧布施。复次菩萨于不饶益己者慈心布施。于苦恼者悲心布施。于功德者喜心布施。于饶益己者及善知识亲族人所。舍心布施。是名菩萨智慧布施。复次菩萨有障施。障施对治如实知之。障施有四种。一者先不修习。二者所施物少。三者财物虽多贪爱增上。四者见未来世具足财果而生贪着。先不习施者。菩萨见正求者。多有财物而不生施心。当知是我不习施故。疾行智慧作是思惟。我昔定当不习施心。致令今日虽有财物见来求者施心不生。今若不施复于来世有此施碍。如是知已。依施障对治而行布施。则能舍离不习施障。所施物少者。菩萨见正求者。所施物少不欲布施。以是施障故。疾行智慧作是思惟。宁安贫苦。要当布施。思惟是已。悲心布施复作是念。我从昔来。宿业过故。他自在故。令我饥寒困苦不能饶益一切众生。宁令我今因是失命现世受苦。要当行施摄取众生。不令受者心不满足。况我今日。有果菜活命。要当安苦而行布施。财物虽多。贪爱增上者。菩萨见正求者。以增上可意故。最上故。于所施物不生施心。彼菩萨知藏积过故。疾行智慧。我于苦中而生乐相。于未来世当受大苦。如是颠倒若知若断。作是思惟已能行布施。见未来财果生贪著者。菩萨行布施已于施果大财生福利见。不能志求无上菩提菩萨知耶。果见为过患已。疾行智慧如实正观。一切诸行无有坚固念念磨灭。受用果报亦复如是。悉是离散磨灭之法。如是观时。果见则断。一切所施悉以回向无上菩提。是名菩萨四种障施对治智慧。应当知。谓分别忍苦。知摄颠倒。观行不坚。前三对治智。是正布施。后一对治智。摄受正果。是名菩萨智慧布施

复次菩萨内独净心淳厚净信觉想胜妙。无量施物意解施与一切众生。是菩萨以少方便生无量功德。是智慧菩萨大智慧施。是名略说菩萨有财无财施所摄法。如是法施分别施净心施。施障对治智慧。布施净心意解施。是名菩萨不共施。当知是名菩萨一切内外所施物。广分别。上一切施。分别当知分别为难施等

云何菩萨难施。略说有三种。菩萨有少财物。自忍贫苦施与他人。是名菩萨第一难施。若菩萨所可爱物性深爱着久习爱着。增上施物越最上贪着。能自开觉施与他人。是名第二难施。若菩萨勤苦得财施与他人。是名菩萨第三难施

云何菩萨一切门施。略说四种。是菩萨若自物。若劝他得物。若自集布施。若父母妻子奴婢作人。若善友大臣亲属。悉皆施与若他所须。是名略说菩萨四种一切门施

云何菩萨善人施。略说五种。一者菩萨信心布施。二者恭敬布施。三者自手施。四者时施。五者不侵他施。是名菩萨善人施

云何菩萨一切行施。略说十三种。一者无依施。二者广施。三者欢喜施。四者常施。五者器施。六者一切施。七者一切处施。八者一切时施。九者无罪施。十者一切物施。十一者方土物施。十二者资财施。十三者谷施。如是十三种是名菩萨一切行施(器者谓四道净福田器)。云何菩萨除恼施。略说有八种。一者菩萨见须饮食者施以饮食。二者须乘与乘。三者须衣与衣。四者须庄严具与庄严具。五者须种种器具悉皆施与。六者须华鬘涂香者随其所欲。七者须舍与舍。八者须灯明者施以灯明。如是八种。是名菩萨除恼施

云何此世他世乐施。略说九种。谓财施法施无畏施。财施者。胜妙清净。如法调伏悭垢藏积垢故。修行布施。调伏悭垢者。舍执着心。调伏藏积垢者。舍受用执着。无畏施者。谓师子虎狼王贼水火等种种恐怖救令得度。法施者。不颠倒说法具足说法。授人禁戒。如是略说菩萨九种施。令诸众生得今世后世安乐。彼财施无畏施。分别此世乐。法施者分别今世后世乐。云何菩萨清净施。略说十种。云何十。一者不留难。二者不异见。三者不积聚。四者不高心。五者无所依。六者不退弱。七者不下心。八者不背面。九者不求恩。十者不求报。不留难施者。菩萨有来求者。疾疾布施不作留难。时满所愿过其速望。不异见者。菩萨于施不起异见言无果报。不以害生布施。谓言是法不于此施。求世间出世间净。不积聚施者。菩萨不久积财然后顿施。何以故。非菩萨有所施物。见来求者。堪能不施。不如法见。非不施与。云何积聚。然后乃施。亦非积聚。而施福增多。所施物等。求者亦等。渐施顿施。以何因缘。见福差别。又复菩萨。见积聚施过。不见随施有过。何以故。谓积聚施。先来求者。或有百数而不施与。令彼嫌恨起不忍心。后来求者。积以顿施。是故菩萨。不积聚施。不高心施者。菩萨于求者所谦下心施。不观他胜竞心布施。不以施故而自称誉。我是施主余者不能。无依施者。菩萨不以名称而行布施。于假名称誉犹如尘坌。不退弱施者。菩萨欲施心悦。施时欢喜。施已无悔。财物增广第一胜妙。菩萨闻他广施胜施。心不自轻生退弱心。不下心施者。菩萨思量。以最胜最上妙物布施。是名不下心施。不背面施者。菩萨等心。不随朋党怨亲中人。悲心等施。不求恩施者。菩萨以悲心愍心而行布施。不于受者计其恩惠。观欲乐众生爱火炽然。无势力故。不求报施者。菩萨施已不怖未来财身具足。观一切行皆悉磨灭。见无上菩提真实福利。如是十种。是名菩萨快净布施。如是菩萨。依九种施具足檀波罗蜜。得阿耨多罗三藐三菩提

    菩萨地持方便处戒品第十之一

云何菩萨尸波罗蜜。略说有九种。一者自性戒。二者一切戒。三者难戒。四者一切门戒。五者善人戒。六者一切行戒。七者除恼戒。八者此世他世乐戒。九者清净戒

云何自性戒。略说四德成就。是名自性戒。云何为四。一者从他正受。二者善净心受。三者犯已即悔。四者专精念住坚持不犯。从他正受者。外顾他于犯愧心生。善净心受者。内自顾于犯惭心生。犯已即悔。专精不犯。如是不犯戒。菩萨有二因缘离悔。是菩萨依受戒。净心戒起。惭愧心起。惭愧心故。善能护戒。护戒故无悔。若从他受若净心受。此二是法。若犯而悔。若专精不犯。此二随法。若从他受。若净心受。若专精不犯。此三法是菩萨不坏戒。犯已即悔者。毁而还复。若菩萨四德成就。是名自性戒。是名真实戒。自安安他。多所安隐多所快乐。哀愍世间利安天人。受戒随戒。当知无量摄受。菩萨无量净戒。摄取一切安乐众生。成大果报获大福利。疾得阿耨多罗三藐三菩提

云何菩萨一切戒。略说二种。一者在家分。二者出家分。是名一切戒。一切戒复有三种。一者律仪戒。二者摄善法戒。三者摄众生戒。律仪戒者。谓七众所受戒。比丘比丘尼。式叉摩尼。沙弥沙弥尼。优婆塞优婆夷。在家出家随其所应。是名律仪戒。摄善法戒者。谓菩萨所受律仪戒。上修大菩提。身口意业。是名略说一切摄善法戒。何者是。谓菩萨依戒住戒。修闻慧思慧奢摩陀毗婆舍那修慧。空闲静默恭敬师长礼事供养。有疾患者。起悲愍心瞻视供给。闻说法者叹言善哉。实功德者称扬赞善。一切众生所作功德。心念口言随喜欢悦。有侵犯者悉能安忍。身口意业已作当作。一切回向无上菩提。随时修习种种胜愿。常勤精进供养三宝。于诸善法心不放逸。念慧护持身口净戒。守摄根门饭食知量。初夜后夜未曾睡眠。亲近善人依善知识。自省己过。知已不犯。随其所犯于佛菩萨及同行所如法悔除如是等护持修习。长养善法戒。是名摄善法戒

摄众生戒者。略说有十一种。一者众生作饶益事。悉与为伴。二者众生已起未起。病等诸苦及看病者。悉与为伴。三者为诸众生说世间出世间法。或以方便令得智慧。四者知恩报恩。五者众生种种恐怖。师子虎狼王贼水火。悉能救护。若有众生丧失亲属财物诸难。能为开解令离忧恼。六者见有众生贫穷困乏。悉能给施随其所须。七者德行具足正受依止。如法畜众。八者先语安慰随时往返。给施饮食说世善语。进止非已去来随物。如是等事。安众生者皆悉随顺。若非安者。皆悉远离。九者有实德者称杨欢悦。十者有过恶者慈心呵责。折伏罚黜令其改悔。十一者以神通力。示现恶道。令彼众生畏厌众恶奉修佛法。欢喜信乐生希有心

云何菩萨。住律仪戒。住摄善法戒。住摄众生戒。善护持戒。善摄善法戒。一切行摄众生戒。菩萨住波罗提木叉戒。舍转轮王出家学道。不顾尊位如视草土。舍离五欲如弃涕唾。乃至来世魔天亦无愿乐。终不为彼修持梵行。心常恐怖如实见过舍现在乐如畏风雹。正见观察而不味着。其性恬静好乐空闲若众若独心常安住。不限持戒生知足想。依戒住戒修习菩萨正受所生无量功德。若近四众不说非法。于空闲处不住恶觉。设令暂起即自悔责深见其过。见过患已还得本心。若闻菩萨一切戒法。大地菩萨微妙无量不可思议久远难行。心不恐怖亦不懈退。而作是念。彼亦丈夫能持菩萨不可思议身口净戒。我亦丈夫必当如彼决定无疑。住律仪菩萨。常省己过不观彼阙。若见凶暴及恶性人。心不恚恨起法心悲心。怜愍方便令得解脱。住律仪菩萨。于众生所。不生怖想。况复加害。住律仪菩萨。成就五种不放逸行。与过去俱。与未来俱。与现在俱。已作当作。菩萨过去所犯如法忏悔。是名过去不放逸行。未来当犯当如法悔。是名未来不放逸行。现在所犯即如法悔。是名现在不放逸行。如所行如所住。专心护持。是名已作不放逸行。依已作不放逸行。如所行如所住。不起犯戒。是名当作不放逸行。住律仪菩萨。功德覆藏恶事发露。少欲知足堪忍众苦不生忧戚。进止安谛威仪庠序。离诸谄曲净修正命。菩萨成就如是十法。名住律仪戒。善护持戒。谓过去五欲心不顾恋。未来五欲不生欣想。现在五欲不念贪着。乐处空闲不生足想。离恶言恶觉心不自轻。安隐乐住善能堪忍。不为放逸威仪净命

菩萨住摄善法戒。于身命财若起少着。即时除灭不令增长。一切犯戒因缘烦恼等起即时除灭。若于众生起恚害怨心。即时除灭。若起懈怠即时除灭。若起味相应禅即时除灭。如实知五处。谓善果善因善因果倒及与非倒。摄善法障。皆如实知。菩萨见善果福利而求善因。摄善法倒。如实知之。菩萨得善根。不起无常常见。苦有乐见。不净净见。非我我见。如实知摄善法障。离不摄善法。菩萨成就如是十行。名住摄善法戒。疾摄诸善法及一切行。所谓依施依戒依忍依精进依禅定。五行成就智慧。菩萨住摄众生戒有十一种。于一一种成就一切行。一者众生所作。皆与同事若始思量及所施作。行路去来。正业方便。守护财物。和合诤讼。世间吉会及诸福业。皆与同事。二者于诸苦事。皆与为伴。若见疾病瞻视供给。盲者将导。迷者次路。聋者指授。躃者荷负。欲缠苦者教令远离。嗔恚睡眠。悼悔疑盖。如是等苦亦令远离欲觉恚觉。害觉亲里觉。国土觉不死觉。轻侮觉族姓觉。悉教远离。众生诤讼不知苦者。能为开解行路疲乏施诸所安。三者为诸众生具足说法。恶行众生。说除恶行善句善味善义。随顺通达增长道品。方便说者。为恶众生。说除恶行。说除悭法。得现果报。少正方便。而得大财得已守护。憎嫉法者令生信乐。清净见谛离诸恶趣。烦恼永尽一切苦灭。四者知恩报恩。饶益己者。善心与语问讯慰喻。赞言。善来设座安处。若等若增酬报无减。诸有所作悉与同事。瞻视病苦随顺说法。除灭恐畏离诸忧悔。若有乏短给施众具。如法依止随顺其心。有实德者称扬欢悦。有过恶者慈心呵责。折伏罚黜。令其改悔。示神通力随所宜现。五者恐怖众生为作救护。所谓水火王贼鬼神恶兽。人非人等一切怖畏。悉为救护令得安隐。若见众生亲属财物诸难忧恼。或见丧失亲属善友知识及诸师长所尊敬者。或有财物王贼所夺。火烧水[漂*寸]亡失宝藏。事业不成强分私财。或恶眷属散弃资产。悉为开解令离忧恼。六者见有众生资生不具。给施所须。饮食衣服汤药众具香花灯明庄严杂饰车乘僮仆财物舍宅。如是等乏。悉皆给施。七者如法受众先与依止。以无贪心哀愍心而为说法赈给所须。若自无者。从彼信心居士长者。求索与之。如法所得衣食汤药。及诸房舍等。共受用无所藏积。以五种法随时教诫。如力种品中说。八者随他心戒。先知众生自性及性。应共住者与共同止。随其所宜与共从事。又随心者。观其所行。若以如是身行如是口行。令彼忧恼。无善利者菩萨不为。虽令忧恼而获善利者菩萨为之。若菩萨自行身行口行。非戒所摄亦非功德智慧方便。令彼忧恼。无善利者菩萨不为。与上相违者菩萨为之。如生忧苦喜乐亦尔。随其所应广分别说。又随心者。若见众生有嗔恨色。尚不叹其德。况说其恶。亦不忏谢。又随心者。人不问讯安慰己者。犹尚自往问讯安慰。况来问讯而不酬和。唯除教诫。又随心者。不恼他人除慈愍心寂静诸根。呵责弟子令其调伏。又随心者。不嗤笑不戏弄。令其惭耻而生疑悔。彼虽不如不言汝今堕在负处。见人谦下亦不自高。又随心者非不习近。不极习近。不非时习近。又随心者。于他亲厚不说其过。于他怨者不称其德。不亲善者。不与同意不多求欲。若有所取知量知足。若有请者不逆其意。若有嫌责如法悔谢九者实功德者。称赞欢悦具足信者。叹信功德。戒闻施慧亦复如是十者应呵责者呵责调伏微过微犯者。以怜愍心软语呵责。中过中犯中语呵责。上过上犯上语呵责。如呵责折伏罚黜亦复如是。软中过软中犯。随时驱出还令共住为化犯戒及余人故。以爱益心黜令出众。上过上犯者。不同住不同食。乃至改悔亦不同住。以慈愍心故。不令彼人于佛法中多起罪过。亦为教诫余众生故。十一者菩萨为饶益故现神通力。或令恐怖或令欢喜。行恶行者示以恶报。所谓寒冰地狱边地狱等诸恶道处。语其人言。汝当观此。人间造恶当生彼中受无量苦。彼见恐怖而生厌怖离诸恶行。菩萨于大众中见不信者问事不答。即时化作金刚力士及诸大力诸天鬼神而恐怖之。以恐怖故。舍高慢心敬信正答。其余大众闻彼正答亦皆调伏。又以神力。现一为多现多为一。石壁皆过身出水火。或复示现共声闻神力。令彼欢悦。未信者信。犯戒者清净。少闻者多闻。悭者能施。痴者得慧。如是菩萨成就一切行利众生戒。是名菩萨三种戒聚。无量功德聚

菩萨地持经卷第四菩萨地持经卷第五

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持方便处戒品之余

菩萨欲学菩萨律义戒。摄善法戒。摄众生戒者。若在家若出家。发无上菩提愿已。于同法菩萨。已发愿者。有智有力。善语善义。能诵能持。如是菩萨所先礼足已作是言。我于大德乞受菩萨戒。大德于我不惮劳者。哀愍听许。作是请已偏袒右肩。于三世十方佛及大地诸菩萨前。恭敬作礼念其功德。起软中上淳净心。于智者前谦下恭敬长跪曲身。于佛像前作是言。唯愿大德。授我菩萨戒。作是语已。一心念住长养净心。我今不久当得无尽无量无上大功德聚。如是念已。默然而住。尔时智者。于彼受者不起乱心。若坐若立而作是言。汝某甲善男子谛听。法弟汝是菩萨不。答言是。发菩提愿未。答言已发

问已复作是言。汝善男子。欲于我所受一切菩萨戒律仪戒摄善法戒摄众生戒。此诸戒是过去未来现在一切菩萨所住戒。过去一切菩萨已学。未来一切菩萨当学。现在一切菩萨今学。汝能受不。答言能。第二第三。亦如是说

智者三说。授彼戒已。受者不起。尔时智者。于佛像前敬礼十方世界诸菩萨众。如是白言。某甲菩萨。于我某甲前三说受菩萨戒。我为作证。一初十方无量诸佛第一无上大师现知见觉者。于一切众生一切法。现知见觉。亦如是白。某菩萨。于我某前三说受菩萨戒。我为作证。第二第三。亦如是白。如是受菩萨戒竟。次第十方一切世界无量诸佛。及住大地诸菩萨前。法有相现。尔时十方世界诸佛菩萨。念是菩萨起如实知见。某世界中某菩萨。从某菩萨受菩萨戒。于是菩萨起子想弟想。慈心爱念。慈心爱念故。令是菩萨善法增长终不退减。如是白。如是知觉。如是受菩萨戒已。智者受者。向十方诸佛及菩萨众敬礼而退。如是菩萨所受律仪戒于余一切律仪戒。最胜最上。摄受无量无边功德。从第一无上真实心起。一切众生一切种恶行对治。波罗提木叉戒。于此律仪戒。百分不及其一。百千万分乃至极算数譬喻亦不及一。摄受一切诸功德故。住菩萨戒者作是思惟。如法者行非法不行。功德转增。学戒菩萨。闻修多罗藏所说及菩萨摩得勒伽藏所说。当勤护持。有智菩萨不从一切菩萨受菩萨戒。若不信者则不从受。谓初闻菩萨戒。不信不顺不能思惟。悭者贪者。多欲者。不知足者。破戒者。慢缓者。不护戒者。嗔者恨者。不堪忍者。懒惰者。懈怠者。着睡眠者。乐说世事者。如是等人悉不从受。若有菩萨修习善心。乃至一[穀-禾+牛]牛乳顷者。不饮酒者。不愚痴者。不怯弱者。不少闻者。不谤菩萨藏修多罗者。从如是等人受菩萨戒。菩萨受菩萨戒者。诽谤违逆菩萨藏者。不向其说亦不教义。何以故。彼闻已不信。无知覆障故而生诽谤。如是谤者。如受菩萨戒。无量功德聚。谤者罪报亦复如是。乃至不舍恶言恶见恶觉。终不舍离。如是罪业菩萨。欲受菩萨戒时。智者应先为说菩萨摩得勒伽藏。说菩萨戒及犯戒相。令受戒者。自心观察智慧思惟。我堪受戒非效他受。是名坚固菩萨如是人者应受菩萨戒

如是菩萨住律仪戒者。有四波罗夷处法。何等为四。菩萨为贪利故自叹己德毁呰他人。是名第一波罗夷处法。菩萨自有财物。性悭惜故。贫苦众生无所依怙来求索者。不起悲心给施所求。有欲闻法吝惜不说。是名第二波罗夷处法

菩萨嗔恚。出粗恶言意犹不息。复以手打或加杖石。残害恐怖嗔恨增上。犯者求悔不受其忏。结恨不舍。是名第三波罗夷处法。菩萨谤菩萨藏说。相似法炽然建立于相似法。若心自解或从他受。是名第四波罗夷处法。是名菩萨四波罗夷处法

是菩萨于四波罗夷处法一一犯。是名波罗夷处法。何况犯四。不能增广现法。庄严菩提。亦不增长现在净心。是名相似菩萨非实菩萨。若菩萨以软中烦恼犯四法者。不名舍律仪戒。若上烦恼犯。是名为舍。若于四法数数违犯。不生惭愧欢喜爱乐。言是功德。是名上烦恼犯。菩萨无有顿犯四波罗夷处法。舍菩萨律仪戒。如比丘舍律仪戒。菩萨失律仪戒已。堪任更受。非如比丘犯木叉戒。不得更受。有二因缘。失菩萨律仪戒。一者舍无上菩提愿。二者起增上烦恼犯无有舍身受身。失菩萨戒。乃至十方在所受生。亦复不失。若菩萨不舍大愿。非上烦恼犯。舍身受身。虽不忆念。从善知识。数数更受犹是本戒。不名新得

是住律仪戒菩萨。当知犯非犯。染污非染污。软中上

若菩萨住律仪戒。于一日一夜中。若佛在世若佛塔庙。若法若经卷若菩萨修多罗藏。若菩萨摩得勒伽藏若比丘僧。若十方世界大菩萨众。若不少多供养乃至一礼。乃至不以一偈赞叹三宝功德。乃至不能一念净心者。是名为犯众多犯。若不恭敬。若懒惰。若懈怠犯。是犯染污起。若忘误犯。非染污起。不犯者。入净心地菩萨。如得不坏净比丘常法。供养佛法僧宝。若菩萨多欲不知足。贪着财物。是名为犯众多犯。是犯染污起。不犯者。为断彼故。起欲方便摄受对治。性利烦恼更数数起

若菩萨见上坐有德应敬同法者。憍慢嗔恨。不起恭敬不让其坐。问讯请法悉不酬答。是名为犯众多犯。是犯染污起。若懒惰懈怠。若无记心。若忘误犯。非染污起。不犯者。若狂若重病。若乱心。若眠作觉想。问讯请法悉不答者。是名不犯。若上座说法及决定论时。若自说法。若听法若自决定论时。若说法众中。若决定论众中。不礼不犯。若护说者心。若以方便令彼调伏。舍离不善。修习善法。若护僧制若护多人意

若菩萨檀越来请。若至自舍。若至寺内。若至余家。若施衣食。种种众具。菩萨以嗔慢心不受不往。是名为犯众多犯。是犯染污起。不犯者。若病若无力。若狂若远处。若道路恐难。若知不受令彼调伏舍恶住善。若先。受请。若修善法不欲暂废。为欲得闻未曾有法饶益之义。及决定论。若知请者为欺恼故。若护多人嫌恨心故。若护僧制。若菩萨有檀越。以金银真珠。摩尼流璃种种宝物。奉施菩萨。菩萨以嗔慢心。违逆不受。是名为犯众多犯。是犯染污。起舍众生故。若懒堕懈怠犯。非染污起。不犯者。若狂若知受已必生贪着。若知受已。施主生悔。若知受已。施主生惑。若知受已。施主贫恼。若知是物是三宝物。若知是物是劫盗得。若知受已多得苦恼。所谓杀缚讁罚夺财呵责

若菩萨众生往至其所欲得闻法。若菩萨嗔恨悭嫉不为说者。是名为犯众多犯。是犯染污起。若懒堕懈怠犯。非染污起。不犯者。若外道求短。若重病若狂。若知不说令彼调伏。若所修法未善通利。若知前人不能敬顺威仪大整。若彼钝根闻深妙法生怖畏心。若知闻已增长邪见。若知闻已毁呰退没。若彼闻已向恶人说破坏正法。若菩萨于凶恶犯戒众生以嗔恨心。若自舍若遮他令舍不教化者。是名为犯众多犯。是犯染污起。若懒堕懈怠。若忘遮他。犯非染污起。何以故。菩萨于恶人所起慈悲心深于善人。不犯者。若狂若知不说。令彼调伏。如前说。若护他心。若护僧制

若菩萨于如来波罗提木叉中毗尼建立遮罪。护众生故。令不信者信。信者增广。同声闻学。何以故。声闻者乃至自度。乃至不离护他。令不信者信。信者增广学戒。何况菩萨第一义度。又复遮罪住。少利少作少方便。世尊为声闻建立者。菩萨不同学此戒。何以故。声闻自度。舍他应住。少利少作少方便。非菩萨自度。度他应住。少利少作少方便。菩萨为众生故。从非亲里婆罗门居士。求百千衣。及自恣与。当观施主堪与不堪。随施应受。如衣钵亦如是。如衣钵。如是自乞缕。令非亲里织师织。为众生故。应畜憍奢耶卧具坐具乃至百千。乃至金银百千。亦应受之。如是等住。少利少作少方便。声闻遮罪。菩萨不共学住。菩萨律仪戒。为诸众生。若嫌恨心。住少利少作少方便者。是名为犯众多犯。是犯染污起。若懒惰懈怠住少利少作少方便犯。非染污起。若菩萨身口谄曲。若现相。若毁呰。若因利求利住邪命法。无惭愧心不能舍离。是名为犯众多犯。是犯染污起不犯者。若断彼故起欲方便。烦恼增上。更数数起

若菩萨掉动心不乐静。高声嬉戏令他喜乐作是因缘。是名为犯众多犯。是犯染污起。若忘误犯。非染污起。不犯者。为断彼故起欲方便如前说。又不犯者。他起嫌恨。欲令止故。若他愁忧。欲令息故。若他性好戏。为摄彼故欲断彼故。为将护故。若他疑菩萨。嫌恨违背和颜戏笑。现心净故

若菩萨作如是见。如是说言。菩萨不应乐涅槃应背涅槃。不应怖畏烦恼。不应一向厌离。何以故。菩萨应于三阿僧祇劫。久受生死求大菩提。作是说者。是名为犯众多犯。是犯染污起。何以故。声闻深乐涅槃畏厌烦恼。百千万倍。不及菩萨深乐涅槃畏厌烦恼。谓诸声闻但为自利。菩萨不尔普为众生。彼习不染污心胜阿罗汉。成就有漏离诸烦恼

若菩萨不护不信之言。不护讥毁亦不除灭。若实有过恶不除灭者。是名为犯众多犯。是犯染污起。实无过恶而不除灭。非染污起。不犯者。若外道诽谤及余恶人。若出家乞食。修善因缘生他讥毁。若前人若嗔若狂而生讥毁

若菩萨观众生应以苦切之言方便利益。恐其忧恼而不为者。是名为犯众多犯。是犯非染污起。不犯者。观彼现在。少所利益多起忧恼

若菩萨骂者报骂。嗔者报嗔。打者报打。毁者报毁。是名为犯众多犯。是犯染污起

若菩萨侵犯他人。或虽不犯令他疑者。即应忏谢。嫌恨轻慢不如法忏谢。是名为犯众多犯。是犯染污起。若懒堕懈怠犯。非染污起。不犯者。若以方便令彼调伏。若彼欲令作不净业。然后受者不谢无罪。若知彼人性好斗讼。若悔谢者。增其嗔怒。若知彼和忍无嫌恨心。恐彼惭耻不谢无罪

若菩萨他人来犯如法悔谢。以嫌恨心。欲恼彼故。不受其忏。是名为犯众多犯。是犯染污起。若不嫌恨。性不受忏。是犯非染污起。不犯者。若以方便令彼调伏。如前说。若彼不如法悔其心不平。不受其忏无罪

若菩萨于他起嫌恨心。执持不舍。是名为犯众多犯。是犯染污起。不犯者。为断彼故。起欲方便如前说

若菩萨为贪奉事。畜养眷属者。是名为犯众多犯。是犯染污起。不犯者。无贪心畜

若菩萨懒堕懈怠耽乐睡眠。若非时不知量。是名为犯众多犯。是犯染污起。不犯者。若病若无力。若远行疲极。若为断彼故起欲方便如前说

若菩萨以染污心论说世事经时者。是名为犯众多犯。是犯染污起。若忘误经时。犯非染污起。不犯者。见他聚话。护彼意故须臾暂听。若暂答他问未曾闻事

若菩萨欲求定心。嫌恨憍慢不受师教。是名为犯众多犯。是犯染污起。若懒堕懈怠犯。非染污起。不犯者。若疾病若无力。若知彼人作颠倒说。若自多闻有力。若先已受法

若菩萨起五盖心不开觉者。是名为犯众多犯。是犯染污起。不犯者。为断彼故起欲方便如前说

若菩萨见味禅以为功德者。是名为犯众多犯。是犯染污起。不犯者。为断彼故起欲方便如前说

若菩萨如是见如是说言。菩萨不应听声闻经法。不应受不应学。菩萨何用声闻法为是名为犯众多犯。是犯染污起。何以故。菩萨尚听外道异论况复佛语。不犯者。专学菩萨藏未能周及。若菩萨于菩萨藏不作方便弃舍不学。一向修集声闻经法。是名为犯众多犯。是犯非染污起

若菩萨于佛所说弃舍不学。反习外道邪论世俗经典。是名为犯众多犯。是犯染污起。不犯者。若上聪明能速受学。若久学不忘。若思惟知义。若于佛法具足观察。得不动智。若于日日。常以二分受学佛经。一分外典。是名不犯。如是菩萨善于世典外道邪论。爱乐不舍不作毒想。是名为犯众多犯。是犯染污起。若菩萨闻菩萨法藏甚深义真实义。诸佛菩萨无量神力。诽谤不受。言非利益非如来说。是亦不能安乐众生。是名为犯众多犯。是犯染污起。或自心不正思惟故谤。或随顺他故谤。是菩萨闻第一甚深义不生解心。是菩萨应起信心不谄曲心。作是学。我大不是盲无慧目。如来慧眼如是随顺说。如来有余说。云何起谤。是菩萨自处无知处。如是如来现知见法。正观正向。不犯非不解谤。若菩萨以贪恚心。自叹己德毁呰他人。是名为犯众多犯。是犯染污起。不犯者。若轻毁外道称扬佛法。若以方便令彼调伏如前说。又不犯者。令不信者信。信者增广

若菩萨闻说法处。若决定论处。以憍慢心嗔恨心。不往听者。是名为犯众多犯。是犯染污起。若懒堕懈怠。是犯非染污起。不犯者。若不解。若病若无力。若彼颠倒说法。若护说者心。若数数闻已受持已知义。若多闻。若闻持。若如说行。若修禅定。不欲暂废。若钝根难悟难受难持。不往者。皆不犯。若菩萨轻说法者。不生恭敬。嗤笑毁呰。但著文字。不依实义。是名为犯众多犯。是犯染污起

若菩萨住律仪戒。见众生所作事。以嗔恨心不与同事。所谓思量诸事。若行路若如法兴利。若田业。若牧牛若和诤。若吉会。若福业。不与同者。是名为犯众多犯。是犯染污起。若懒堕懈怠犯。非染污起。不犯者。若病若无力。若彼自能办。若彼自有多伴。若彼所作事。非法非义。若以方便令彼调伏如前说。若先许他。若彼有怨。若自修善业。不欲暂废。若性闇钝。若护多人意。若护僧制。不与同者。皆不犯

若菩萨见羸病人。以嗔恨心。不往瞻视。是名为犯众多犯。是犯染污起。若懒惰懈怠犯。非染污起。不犯者。若自病。若无力。若教有力。随顺病者。若知彼人自有眷属。若彼有力能自经理。若病数发。若长病。若修胜业。不欲暂废。若闇钝难悟难受难持。难缘中住。若先看他病。如病穷苦亦尔

若菩萨见众生造今世后世恶业。以嫌恨心。不为正说。是名为犯众多犯。是犯染污起。不犯者。若自无智。若无力。若使有力者说。若彼自有力。若彼自有善知识。若以方便令彼调伏如前说。若为正说于我增恨。若出恶言。若颠倒受。若无爱敬。若复彼人性弊[怡-台+龍]悷。若菩萨受他恩惠。以嫌恨心。不以若等若增酬报彼者。是名为犯众多犯。是犯染污起。若懒堕懈怠犯。非染污起。不犯者。若作方便而无力。若以方便令彼调伏如前说。若欲报恩而彼不受

若菩萨见诸众生有亲属难财物难。以嫌恨心。不为开解除其忧恼。是名为犯众多犯。是犯染污起。若懒堕懈怠犯。非染污起。不犯者。如前不同事中说

若菩萨有求饮食衣服。以嗔恨心。不能给施。是名为犯众多犯。是犯染污起。若懒堕懈怠犯。非染污起。不犯者。若自无。若求非法物。若不益彼物。若以方便令彼调伏如前说。若彼犯王法。护王意故。若护僧制

若菩萨摄受徒众。以嗔恨心。不如法教授。不能随时。从婆罗门居士所求衣食卧具医药房舍。随时供给。是名为犯众多犯。是犯染污起。若懒堕懈怠放逸犯非染污起。不犯者。若以方便令彼调伏如前说。若护僧制。若病若无力若使有力者说。若彼有力。多知识大德。自求众具。若曾受教自已知法。若外道窃法。不能调伏

若菩萨以嫌恨。心不随他者。是名为犯众多犯。是犯染污起。若懒堕懈怠犯。非染污起。不犯者。若彼欲为不如法事。若病若无力。若护僧制。若彼虽如法。能令多人起非法事。若伏外道故。若以方便令彼调伏

若菩萨知他众生有实功德。以嫌恨心。不向人说。亦不赞叹。有赞叹者不唱善哉。是名为犯众多犯。是犯染污起。若懒堕懈怠放逸犯。非染污起。不犯者。知彼少欲。护彼意故。若病若无力。若以方便令彼调伏。若护僧制。若令彼人起烦恼。起溢喜。起慢起非义。除此诸患故。若实功德似非实德。若实善说似非善说。若为摧伏外道邪见。若待说竟

若菩萨见有众生应呵责者。应折伏者。应罚黜者。以染污心不呵责。若呵责不折伏。若折伏不罚黜。是名为犯众多犯。是犯染污起。若懒堕懈怠放逸犯非染污起。不犯者。彼不可治不可与语难可教诲。多起嫌恨。若观时。若恐因彼起斗诤相违。若相言讼。若僧诤。若坏僧。若彼不谄曲有惭愧渐自改悔

若菩萨成就种种神力。应恐怖者而恐怖之。应引接者而引接之。欲令众生消信施故。若不以神力恐怖引接者。是名为犯众多犯。是犯染污起。不犯者。若彼众生更起染着。外道谤圣成就邪见。一切不犯。若彼发狂。若增苦受此事起菩萨戒。佛于处处修多罗中说。律仪戒摄善法戒摄众生戒。律仪戒摄。此是菩萨藏摩得勒伽和合说。菩萨当精勤受持起上恭敬。专心修学从他正受。已极清净欲学心。菩提心。利众生心。从初受戒专精护持。若有所犯。即如法忏悔此一切菩萨犯当知突吉罗摄。当向大小乘人能解语。能受悔者如法忏悔。若菩萨以增上烦恼犯波罗夷处法者。失律仪戒。应当更受。若中烦恼犯波罗夷处法者。当向三人若过三人。长跪合掌作突吉罗忏悔。称先所犯罪名。作是说言。大德忆念。我某甲。舍菩萨毗尼。如前所说事。犯突吉罗罪。余如比丘突吉罗忏悔法说。若下烦恼犯波罗夷处法及余所犯。向一人忏悔。若无如法人。当起清净心念言。我终不重犯此罪。于未来世中常摄持律仪戒。若能如是所犯即除。若无如是具足功德人可从受菩萨戒者。是菩萨应于佛像前自受应如是受。整衣服偏袒右肩。右膝着地曲身合掌。作如是言。我某甲白十方世界一切诸佛及入大地诸菩萨众。我今于诸佛菩萨前受一切菩萨戒。律仪戒。摄善法戒。摄众生戒。此诸戒是过去一切菩萨已学。未来一切诸菩萨当学。现在一切菩萨今学。第二第三亦如是说。说已应起。余如前说。若菩萨所犯无无余犯。如世尊说菩萨起嗔烦恼。犯应更受。非贪欲起。当知此意。菩萨起爱念众生为增上。凡有所作一切能作菩萨所作非作所作。犯应更受。菩萨嗔众生者。不能自度度他。亦不能作菩萨所作。如是不作所作。犯应当更受。当知菩萨软中上犯。如四摄品说。若菩萨于此律仪戒具足成就三正法者。得安乐住。一者方便具足。二者净心具足。三者本因具足。菩萨于戒不穿漏。净身口意业不数数犯。发露诸恶。是名方便具足。菩萨为法出家不为身命。为义为禅定。不为财利。为沙门为涅槃。不为非义。不为懈怠。精进不退。不杂众恶不善之法。烦恼受有炽然苦报及未来世生老病死。是名净心具足。菩萨本余生时。广修诸善于今不乏。衣食床卧汤药众具。能修惠施。是名本因具足。住律仪戒菩萨具足三正法者。是名安乐住。与此相违。是名具足三不正法戒。当知苦住。是名略说。广说在家出家一切戒。此一切戒当知分别为难戒等

难戒者。略说三种。菩萨具足大财大势力。能舍出家受菩萨戒。是名第一难戒。菩萨若遭急难乃至失命。于所受戒不令缺减。况具足犯是名第二难戒。菩萨于一切修行一切正受一切忆念。心住不乱。乃至尽寿。于细微戒终不缺减。何况重者。是名第三难戒。一切门戒者有四种。一者正受戒。二者性戒。三者习戒。四者方便成戒。正受戒者。菩萨已受三种律仪戒所谓律仪戒。摄善法戒。摄众生戒。性戒者。菩萨性自贤善身口意净。习戒者。菩萨本余生时如所说。三种戒已曾修习。以本因故。一切恶不乐行心常厌恶。乐修善行。方便成戒者。菩萨依四摄事。于诸众生行善身口业。善人戒者有五种。一者自持净戒。二者授与他人。三者赞叹净戒。四者见同法者心生欢喜。五者设有毁犯如法悔除。一切行戒者彼六种七种一向略说十三种回向大菩提。广摄戒故。是名为广。乐着欲乐。自身苦行。离此二边故。是名无罪欢喜之处。尽其寿命常不还戒。一切利养行外道邪论。烦恼诸缠不能侵欺故。亦不能夺故。是名坚固戒。庄严成就故。当知戒庄严。谓声闻地。离杀生等。律仪戒。摄善法戒。摄众生戒。顺戒不顺戒。护随护戒。大人相报。增上意报。善趣报。利众生报。除恼戒者有八种。菩萨初作是思惟。如我不欲令他杀盗邪淫妄语两舌恶口绮语。手石杖等触恼于我。如我不欲不喜。彼亦如是。云何以此加于他人。以是故不恼于彼。乃至不加手石杖等触。作是思惟已。不以八事触恼众生。是名菩萨除恼戒

此世他世乐戒者有九种。菩萨遮处则遮。开处则开。摄处则摄。应降伏者则降伏之。菩萨于彼身口业。是四种戒。又檀波罗蜜俱戒。羼提波罗蜜．毗梨耶波罗蜜．禅波罗蜜．般若波罗蜜俱戒。是五种戒。如是略说九种戒。是菩萨自己及他。现法乐住及后世乐。是故说名此世他世乐戒

清净戒者有十种。一者初善受戒为沙门为菩提不为身命。二者终不退减起于疑悔。三者不过持戒起非处疑悔故。四者离诸懈怠不乐睡眠。日夜精勤成就善法。五者摄心不令放逸如前不放逸说。六者修习正愿不愿财利及生天上。常修梵行。七者摄持威仪。善于威仪所作众事。方便修习善。如法身口行正命具足。谄曲邪命种种过恶皆悉远离。八者离于二边离随顺欲乐及诸苦行故。九者修习出要。异学诸见皆悉远离。十者于所受戒不缺不减。此十种名清净戒。是名菩萨大戒聚得菩提果。菩萨依此戒已。满足尸波罗蜜。得阿耨多罗三藐三菩提。乃至未成无上正觉得五种福利。一者常为一切诸佛所念。二者终时其心欢喜。三者舍身在所生处。常与净戒诸菩萨众为善知识。四者无量功德聚戒度成就。五者今世后世性戒成就。如前所说。自性等九种戒。当知三戒所摄。所谓律仪戒。摄善法戒。摄众生戒。又复三种。略说能为菩萨三事。一者律仪戒。能令心住。二者摄善法戒自成佛法。三者摄众生戒成就众生。是名菩萨一切事。所谓现法。心得乐住身心不惓。能具足佛法成就众生。是名菩萨戒。是名戒福。是菩萨所作无余无上。过去一切诸菩萨等。求大菩提已于中学。未来当学。现在今学

菩萨地持经卷第五菩萨地持经卷第六

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持方便处忍品第十一

云何菩萨羼提波罗蜜。略说有九种。一者自性忍。二者一切忍。三者难忍。四者一切门忍。五者善人忍。六者一切行忍。七者除恼忍。八者此世他世乐忍。九者清净忍。云何自性忍。菩萨依思惟力。若性能忍他人不饶益事。一切诸忍。依无贪心。纯一悲心。是名略说自性忍。云何菩萨一切忍。略说二种。一依在家。二依出家。此二各有三种。一者他不饶益忍。二者安苦忍。三者法思惟解忍。他不饶益忍者。从久远来。无间大苦。他不饶益。现前迫切。菩萨作如是学。是我自业过恶所招。本作罪业得今日苦。今若不忍。复为未来大苦因缘。我今便为重自造苦。不由于他。又我身及彼。俱是一切有为行苦。彼无智故。于我性苦更增其苦。我今有智。云何复欲重加其苦。又复声闻自利尚不以苦加于他人。况于菩萨广利众生。如是思惟。已修习五种想。于怨亲中人下中胜品。若苦若乐有德无德。如是众生一切能忍。云何五种想。一者本亲属想。二者法数想。三者无常想。四者苦想。五者摄取想。本亲属想者。菩萨作如是学。众生久远已来少非亲者。若父若母。兄弟姊妹。和上阿阇梨。若师若师等及诸所尊。于怨憎所。如是正思惟。时舍怨憎不饶益想。住本亲想。依本亲想已。他不饶益者悉能堪忍。法数想者。菩萨作如是学。因缘行数法数。无我众生寿命。生者骂者打者诤者。如是正思惟时。离众生想住法数想。依法数想已。他不饶益者悉能堪忍。无常想者。菩萨作如是学。一切众生生所起者。一切悉是无常死法。于上复有不饶益事。欲断其命。如是无常众生性是死法。智者不起不清净心。况复手石刀杖欲断其命。如是正思惟。时离常坚固想。住无常不坚固想。依无常想已。他不饶益者悉能堪忍。苦想者。是菩萨观。大力具足者尚不离三相。所谓行苦变易苦苦苦。况复不具足者。菩萨作如是学时。于常苦众生欲令离苦。云何加报重增其苦。如是正思惟时离于乐想住于苦想。忍苦想已。他不饶益者悉能堪忍。摄取想者。菩萨作如是学。我于一切众生发菩提心。于一切众生作亲属想。我应摄取普令安乐。不应于亲属众生应利益处。而复重加不饶益事。如是正思惟时。灭除他想住摄取想。依摄取想已。他不饶益者悉能堪忍。云何为忍。若不嗔不报心不怀恨。是名为忍。安苦忍者。菩萨作如是学。我从昔来常求欲事。为诸苦因生无量大苦。所谓营世生业。治生种殖。奉事王家。如是诸苦莫不备经。皆是痴冥无知过故。今当修习乐因具足善法。无量众苦悉当安忍。况复小苦。如是正思惟时。觉慧具足。一切苦事悉能安忍。一切苦事略说八种。一者依处。二者世法处。三者威仪处。四者摄法处。五者比丘随戒处。六者方便处。七者利众生处。八者诸所作处。依者谓四依法。依正法出家。得比丘分。菩萨若得粗涩弊恶。不恭敬与留难不时。心无忧恼。菩萨于彼众苦不舍精进。如是名为安忍依苦。世法者有九种。一者不利。二者不称。三者毁四者苦。五者坏法坏。六者尽法尽。七者老法老。八者病法病。九者死法死。此诸世法。若离若合能生众苦。是名世法处。菩萨于彼众苦不舍精进。如是名为安忍世法苦。威仪者有四威仪。行住坐卧。是菩萨若行若坐。昼夜二时除去阴障心得清净。不非时卧。卧床坐床草敷叶敷。因此疲极而生众苦。悉能堪忍。菩萨于彼众苦不舍精进。如是名为安忍威仪苦。摄法者有七种。宝供养德供养。咨受正法。广为人说。妙音赞叹。独静思惟。称量观察。忆念摄受。修习止观。菩萨摄此七种法方便修习。所起众苦悉能堪忍。终不因是舍正方便。比丘随戒者。有七种一者毁形好除须发舍俗相。二者着坏色衣。三者舍除不如法世俗所行心正念住。四者依他活命舍世事业。五者尽寿从他求衣不积聚故。六者尽寿障人五欲摄诸根门舍非梵行。七者尽寿舍歌舞倡伎种种戏乐。如是等所作艰难。行比丘戒。由是生苦。菩萨安忍不舍精进。精勤者。菩萨精勤供养三宝。受持读诵菩萨经藏。书写解说。思惟其义。勤加精进修集圣道。由是生苦。菩萨安忍。不因是故舍于众生。利众生处者略说有十一事。如前说。因是生苦。菩萨安忍。不因是故舍于精进。诸所作者。出家衣钵业等。在家营生业等。因是生苦。菩萨安忍。不因是故而舍精进。菩萨虽受众苦。要当安忍修无上菩提。非不修习。修习已终不退转。心常欢喜不生染污。是名安苦忍法。思惟解忍者。是菩萨于法正择。善观开觉。于八种解处深入系念。所谓三宝功德。真实之义。诸佛菩萨大神通力。若因若果。所应得义。得义方便。所知行处。又复解者。有二因缘。一者久远。修习。二者得快净智。是名菩萨一切忍。依于三种分别。广说为难忍等。云何难忍。略说三种。若菩萨于下劣众生不饶益者。悉能堪忍。是名第一难忍。若于仆使自能堪忍。是名第二难忍。下种性人。起增上过而能堪忍。是名第三难忍

云何菩萨。一切门忍略说四种。一者堪忍亲属不饶益事。二者堪忍怨家不饶益事。三者堪忍中人不饶益事。四者堪忍下中上不饶益事

云何善人忍。略说五种。是菩萨先见行忍有大福利。谓修行忍者。于未来世不多结恨不多乖离。心多喜乐死时无悔。身坏命终生于善趣天上化生。见如是等功德福利。能自堪忍教他行忍。常为他人叹忍功德。见他行忍其心随喜

云何菩萨一切行忍。谓六种七种。略说十三种。菩萨见不忍者得大苦报。畏怖故忍。于一切众生慈心悲心亲厚心亲爱故忍。殷勤愿乐无上菩提。欲满足羼提波罗蜜。作因故忍。忍力故出家。如世尊说。常当具足等受持戒。是出家忍。是名受法忍。种性具足及先修习现在住。是名性忍。知一切法无有众生见离言语法数。是名正念法忍。一切不饶益忍一切忍一切处忍。谓一人及大众会。一切时忍。谓平旦日中日入日夜。过去未来现在。若病不病若卧若起。身常行忍不触恼彼。口常行忍离不爱语。意常行忍不兴忿怒。亦复不起不净悕望

云何菩萨除恼忍。略说八种。一者菩萨于苦求者堪忍不恼。二者于凶暴增上恶者。依大悲心堪忍不恼。三者于出家犯戒者。依大悲心堪忍不恼。五种精进堪忍不恼苦恼众生。欲为除苦求法及法次法向。如是法广为宣说。若众生所作悉皆营助精进堪能。是名八种除恼忍。众生所患堪忍为除。所可乏少堪忍饶益

云何菩萨此世他世乐忍。略说九种。是菩萨住不放逸善法。堪忍寒热饥渴蚊虻所触。风日众毒所触。一切堪忍身心疲苦。悉能堪忍。堕生死海生老病死等。诸苦众生哀愍在前。如是忍。菩萨于现法中自住安乐。一切诸恶皆悉远离。复为来世安乐因缘。亦复令他向今世后世安隐快乐。是故名为此世他世乐忍

云何为菩萨清净忍。略说十种。一者他不饶益。无反报心。二者不起恚恨。三者无怨憎想。四者常饶益向如本心后亦如是作饶益已舍不饶益。五者于不饶益者软语辞谢。六者若彼悔谢能速忍受。七者见彼不忍加以悲心。八者见彼修忍倍增敬佛。九者众生恐怖深起悲心。十者断除一切不忍等过离欲清净。如是十种。名菩萨净忍。如是从性忍。乃至净忍广大无量大菩提果。因依是忍。必得阿耨多罗三藐三菩提

    菩萨地持方便处精进品第十二

云何菩萨毗梨耶波罗蜜。略说有九种。一者自性精进。二者一切精进。三者难精进。四者一切门精进。五者善人精进。六者一切行精进。七者除恼精进。八者此世他世乐精进。九者清净精进。云何自性精进。是菩萨心堪能摄受无量善法。利益安乐一切众生。炽然不断亦不颠倒。彼所起身口意业。是名菩萨自性精进

云何一切精进。略说有二种。一依在家。二依出家。此二各有三种。一者弘誓精进。二者摄诸善法。三者利益众生。弘誓精进者。菩萨先起精进方便。心数堪能被弘誓铠。作是念言。我为一众生脱苦因缘故。以百千大劫为一日一夜。如是数亿百千大劫在地狱中。乃至成佛誓不退转。不得无上菩提终不舍精进。况复少时受于少苦。是名菩萨弘誓精进。如是像类菩萨。弘誓精进。起少解少信已。能长养无量开觉勤方便性。况复成就如是弘誓精进。菩萨为无上菩提故利益众生。不以为难生退没想。摄善法精进者。菩萨精进为檀波罗蜜方便成就故。为戒忍禅定般若波罗蜜方便成就故。略说七种。一者不动。一切妄想烦恼异论。无量众苦不倾动故。二者坚固。顿方便故。三者得无量明处。安住正念故。四者方便具足。所当得义。不颠倒道。随顺得故。五者正精进义饶益。所当得义成就愿故。六者炽然。常勤方便故。七者离慢。精进方便心不自举故。菩萨修此七种摄诸善法。精进方便疾满足诸波罗蜜。得阿耨多罗三藐三菩提。一切菩提行善法。皆此精进之所成就。是故此精进为最上最胜因无余无上。是故世尊修多罗中。种种称叹精进。为阿耨多罗三藐三菩提因。菩萨利众生精进有十一种。如戒品说。彼说戒。此说精进

云何菩萨难精进。略说三种。是菩萨精进无间。无衣食想床卧具想己身想。常修善法。是名第一难精进。菩萨如是精进。乃至舍身受身。常修善法不舍精进。是名第二难精进。是菩萨平等分别功德具足。不缓不急心不颠倒。以义饶益精进成就。是名第三难精进。又此菩萨难精进力。当知是摄取大悲及智慧因

云何菩萨一切门精进。略说四种。一者舍离染污法。二者生白净法。三者净除三业。四者增益智慧。舍染污法者。菩萨精进离诸烦恼。未起不起。已起令灭。生白净法者。未生善法方便令生。已生善法方便增广。净除三业者。菩萨精进三业清净。悉能摄取善身口意业。增益智慧者。菩萨精进得闻思修慧。增长具足

云何菩萨善人精进。略说五种。一者无不作一切欲方便。不休息故。二者不下随。其所起若中若上。精进长养故。三者不懈怠。勇猛炽然长久无间。精进方便心不退没。不息不坏故。四者不颠倒义饶益。方便摄取故。五者殷勤。方便精进速疾于无上菩提故。云何菩萨一切行精进者。谓六种七种。略说十三种。六种者所谓常精进。常方便故。顿精进。至到方便故。依精进。因本精进力故。方便精进。思惟计校善方便故。不动精进。一切苦触不倾动故。亦不向余义故。不知足精进。限量胜进不欢喜故。菩萨成就如是六种。一切行精进者。殷勤精进堪能坚固。于诸善法不可毁坏。复有七种。一者与欲俱精进。殷勤欲愿长养无上菩提故。二者等具足精进。诸余烦恼染污心住。菩萨精进于诸善法等心住故。三者胜进精进。诸余烦恼上烦恼心住。断彼烦恼如救头然故。四者求精进。一切明处求故。五者学精进。彼如是诸法。随其所应起法次法向故。六者利众生精进。有十一事如前说。七者自正方便。护精进。若有缺漏。如法悔故。是名七种。如是十三种。是名菩萨一切行精进。菩萨除恼精进。此世他世乐精进。如忍中说

云何菩萨清净精进。略说十种。一者随顺。二者修习。三者专著。四者善摄。五者时具足。六者分别相具足。七者不退弱。八者不坏。九者平等。十者回向大菩提。是菩萨为断除烦恼随其所应修习对治。如爱所缚修不净观。嗔修慈心。痴观缘起。觉观所乱修安般念。慢修分别界方便观。如是等名随顺精进。是菩萨非成就初业精进。谓心已住教授教诫。修习方便调伏方便。是名菩萨修习精进。是菩萨非修习精进。教授教诫。方便心住。然是初业。是菩萨于是方便。专精进方便。常方便。顿方便。是名专著精进。是菩萨因诸所尊。若多闻力不颠倒受。其心安住精进方便。是名善摄精进。是菩萨如是不颠倒受。止时修止。举时修举。舍时修舍。是名时具足精进。菩萨于止举舍相。三昧住起相。常善观察不妄分别。是名菩萨分别相精进。是菩萨闻说第一妙胜。第一甚深。不可思议无量菩萨精进方便。心不自轻亦不怯弱不少胜进。生知足想而不上求。是名菩萨不退弱精进。是菩萨常守根门饮食知量。初夜后夜未曾睡眠。精进方便正智心住。如是等三摩跋提。具精勤成就正义饶益。是名菩萨不坏精进。是菩萨精进方便。不缓不急平等修习。一切方便平等顿修。是名菩萨平等精进。是菩萨一切精进方便所作。回向无上菩提。是名菩萨正回向精进。如是从自性精进乃至清净精进。当得大菩提果。菩萨依是精进满足。毗梨耶波罗蜜。得阿耨多罗三藐三菩提

    菩萨地持方便处禅品第十三

云何菩萨禅波罗蜜。略说九种。一者自性禅。二者一切禅。三者难禅。四者一切门禅。五者善人禅。六者一切行禅。七者除恼禅。八者此世他世乐禅。九者清净禅。云何自性禅。于菩萨藏闻思。前行世间出世间善。一心安住。或止分。或观分。或此二同类。或俱分。是名自性禅

云何菩萨一切禅。略说二种。一者世闻。二者出世间。又随其所应各有三种。一者现法乐住禅。二者出生三昧功德禅。三者利益众生禅。菩萨禅定离一世妄想。身心止息。第一寂灭自举心息。舍离味着及一切相。是名现法乐住禅。菩萨禅定出生种种不可思议无量无边十力种性所摄三昧。彼诸三昧。一切声闻辟支佛不知其名。况复能起及所出生。二乘解脱。除入一切入无碍慧无诤愿智胜妙功德。是名菩萨出生三昧功德禅。利益众生禅者。有十一种。如前说。菩萨依布施。众生所作。以义饶益。皆与同事。为除众苦。如所应说知恩报恩。护诸恐怖。诸难忧苦能为开解。资生不具给施所须。如法畜众善能随顺。见实功德欢喜赞叹。有过恶者等心析伏。神力恐怖或令欢喜是名略说一切禅。无余无上。云何菩萨难禅。略说三种。菩萨久习胜妙禅定。于诸三昧心得自在。哀愍众生欲令成熟。舍第一禅乐而生欲界。是名菩萨第一难禅。菩萨依禅出生无量无数不可思议诸深三昧。出过一切声闻辟支佛上。是名第二难禅。菩萨依禅得无上菩提。是名第三难禅。云何菩萨一切门禅。略说四种。一者有观有觉禅。二者喜俱禅。三者乐俱禅。四者舍俱禅

云何菩萨善人禅。略说五种。一者不味着。二者慈心俱。三者悲心俱。四者喜心俱。五者舍心俱

云何菩萨一切行禅。谓六种七种。略说十三种。善禅。无记化化禅。止分观分禅。自他利禅。正念禅。出生神通力功德禅。名缘。义缘。止相缘。举相缘。舍相缘。现法乐住第一义禅。是名十三种菩萨一切行禅

云何菩萨除恼禅。略说八种。一者菩萨入定。除诸苦患毒害霜雹热病鬼病。是名咒术所依禅。二者菩萨入定能除四大所起众病。是名除恼禅。三者菩萨入定兴致甘雨。能消灾旱救诸饥馑。是名云雨禅。四者菩萨入定。济诸恐难一切水陆人非人怖。是名等度禅。五者菩萨入定能以饮食饶益旷野饥渴众生。是名饶益禅。六者菩萨入定。能以财物调伏众生。是名调伏禅。七者菩萨入定觉诸迷醉。迷十方者等开觉之。是名开觉禅。八者菩萨入定众生所作悉令成就。是名等作禅

云何菩萨此世他世乐禅。略说九种。一者神足变现调伏众生禅。二者随说示现调伏众生禅。三者教诫变现调伏众生禅。四者为恶众生。示恶趣禅。五者失辩众生以辩饶益禅。六者失念众生以念饶益禅。七者造不颠倒论微妙赞颂摩得勒伽为令正法久住世禅。八者世间技术义饶益摄取众生。所谓书数算计资生方法。如是等种种众具禅。九者暂息恶趣放光明禅

云何菩萨清净禅。略说十种。一者世间清净净。不味不染污禅。二者出世间清净净禅。三者方便清净净禅。四者得根本清净净禅。五者根本上胜进清净净禅。六者入住起力清净净禅。七者舍复入力清净净禅。八者神通所作力清净净禅。九者离一切见清净净禅。十者烦恼障智障断清净净禅。如是菩萨无量禅得大菩提果。菩萨依是得阿耨多罗三藐三菩提。已得当得

    菩萨地持方便处慧品第十四

云何菩萨般若波罗蜜。略说九种。一者自性慧。二者一切慧。三者难慧。四者一切门慧。五者善人慧。六者一切行慧。七者除恼慧。八者此世他世乐慧。九者清净慧。云何菩萨自性慧。入一切所知境界。随入已如法择观缘五明处。所谓内明。因明。声明。医方明。世工巧明。是名自性慧

云何菩萨一切慧略说二种。一者世间。二者出世间。是二略说。各有三种。一者所知真实随觉分别。二者善摄五明处及三聚法。三者利众生所作。菩萨以无言说无我法觉了真谛。觉已于上般若第一寂灭处。系念安住离诸妄想。灭除虚伪入于平等大总相观。建立及谤是二俱离入于中道。是名随觉分别慧。善五明处。广说如力种性品。三聚者。义饶益法聚。非义饶益法聚。非义饶益非非义饶益法聚。如是八处。般若善摄。大无上慧众具满足。得阿耨多罗三藐三菩提。利众生所作有十一事。如前说。于彼一一处。智慧方便调伏众生

云何难慧。略说三种。知甚深无我法。是名第一难慧。调伏众生方便。是名第二难慧。一切所知无障碍。是名第三难慧

云何一切门慧。略说四种。所谓学声闻藏菩萨藏闻慧思慧。思惟菩萨所作随顺离诸障碍。思惟力所摄慧。修力所摄正定地无量慧。

云何菩萨善人慧。略说五种。一者得闻正法慧。二者内正思惟俱慧。三者自利利他方便俱慧。四者于诸法法相法住不颠倒决定慧。五者离烦恼慧。复有五种。一者细微如其性境界入。二者周至如其性境界入。三者本得智慧众具俱生。四者诸佛如来及大地菩萨所说法义。悉能受持。五者得净心地乃至究竟地所摄受慧

云何菩萨一切行慧。谓六种七种。略说十三种。于四真谛。苦智。集智。灭智。道智。究竟尽智。无生智。是名六种。七种者法智。比智。等智。神通智。相智。十力方便智。四事具足智。云何菩萨除恼慧。略说八种。一者知经法故名法无碍。二者知法相故名义无碍。三者知诸法名故名辞无碍。四者知诸法种种句义故名乐说无碍。五者伏一切异论智。六者建立一切正论智。七者能治产业增长钱财智。八者善知王者决断世事智

云何菩萨此世他世乐慧。略说九种。于内明处善净建立智。因明声明医方明世工巧明。善净建立智。如是依善净五明菩萨。调伏众生愚痴放逸懈怠令正随其次第。显示授与照明欢喜

云何菩萨清净慧。略说十种。真实义有二种。乃至性如性真实义。摄受流转义有二种。正因及果。摄受取义有二种。颠倒不颠倒。如实知。方便义有二种。一切应作不应作。如实知究竟义有二种。秽污清净。如实知。如是五种十种。分别净慧。当知第一清净。如是菩萨善决定无上慧。得大菩提果。菩萨依是满足般若波罗蜜。得阿耨多罗三藐三菩提。又此六波罗蜜。处处修多罗中世尊分别说。我今略说。当作是知。如来修多罗中。说檀波罗蜜乃至般若波罗蜜。分别从自性檀波罗蜜乃至清净檀波罗蜜所摄。随其所应。如是尸波罗蜜乃至般若波罗蜜所摄。随其所应。当作是知。如来为菩萨时。于无量生苦行相应。一切檀波罗蜜相应。当知乃至般若波罗蜜相应。或为摄一或摄二。或摄三或摄四。或摄五或摄一切六波罗蜜。当知此六波罗蜜。起阿耨多罗三藐三菩提。菩萨大清净法大清净海。一切众生一切种正法因最大珍宝。如是无量功德智慧众具。得阿耨多罗三藐三菩提果。无余无上

菩萨持地经卷第六菩萨地持经卷第七

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持方便处四摄品第十五

云何菩萨爱语。略说有九种。一者自性爱语。二者一切爱语。三者难爱语。四者一切门爱语。五者善人爱语。六者一切行爱语。七者除恼爱语。八者此世他世乐爱语。九者清净爱语

云何菩萨自性爱语。是菩萨可喜真实如法义饶益语。与众生语。是名略说菩萨自性爱语

云何菩萨一切爱语。略说有二种。菩萨慰问舒颜先语。平视和色正念在前问言。道路清泰四大调适。卧觉安乐叹言善来。如是等等心慰问随顺世间。巧便语言安慰问讯。或复咒愿。令妻子眷属钱财谷米增长具足。见功德具足者。叹其信戒施闻智慧。令其欢喜。菩萨说一切种功德相应法。安乐众生。常说等说第一胜妙饶益言说。是名菩萨一切爱语。菩萨爱语二种分别。随世间语及正说法语。慰问赞叹者是名随世间语。第一胜妙饶益说者。是名正说法语

云何菩萨难爱语。略说三种。菩萨于怨家所。以清净心思惟慰喻。发喜饶益而共言说。是名第一难爱语。菩萨于增上愚痴钝根众生。以无厌心思惟筹量。而为说法忍诸疲劳。以法摄取为具足说。是名第二难爱语。菩萨于谄曲幻伪众生。欺和上阿阇梨及尊重福田。或背正向邪。以无害心方便慰喻。发喜饶益而为说法。是名第三难爱语

云何菩萨一切门爱语。略说四种。一者断除诸盖向于善趣。说初所作法。二者断除诸盖实心增进。说应四真谛法。三者见放逸众生在家出家。等心呵责令离放逸住不放逸。四者已起疑惑能为开解。若说法若决定论

云何菩萨善人爱语。略说五种。一者是菩萨说诸佛菩萨正因调伏法。二者正出。三者正依。四者正度。五者正示现。处所因缘制戒。是故此法名为正因。于所受戒有所毁犯教令还净。是故此法名为正出。说四依所摄不颠倒法律至处道。是故此法名为正依。显示出一切苦不退还道。是故此法名为正度。三种示现于一切说无碍。是故此法名为正示现

云何菩萨一切行爱语。谓六种七种。略说十三种。听所应听法爱语。制所应制法爱语。现诸经法爱语。现诸法相爱语。现诸法名字不颠倒爱语。法句种种分别爱语。慰喻爱语。发喜爱语。自恣安以众具代其所作虚受普纳爱语。种种恐怖施安爱语。具足说法摄取爱语。开觉不善法安立善法见闻疑举罪折伏爱语。劝有力说法者爱语。如是十三种。名为一切行爱语

云何菩萨除恼爱语略说八种。是菩萨依口四净八种圣语。是名除恼爱语。口四净者。离妄语两舌恶口绮语。八种圣语者。见闻觉知说不见不闻不觉不知说

云何菩萨此世他世乐爱语。略说九种。一者断亲属难忧苦故爱语说法。二者断财物难忧苦故爱语说法。三者断疾病难忧苦故爱语说法。四者断戒难忧苦故爱语说法。五者断见难忧苦故爱语说法。戒具足。见具足。威仪具足。正命具足故爱语说法

云何菩萨清净爱语。当知有二十种说法如前力种性品说

云何菩萨行利。彼行利者如爱语。广说异行利今当说。谓菩萨一切种爱语。随所说义利安众生。云何菩萨自性行利。是爱语具足显示众生。如所应学随利行行法次法向。住于悲心心无贪着。劝导教授调伏安立。是名略说自性行利

云何菩萨一切行利。略说二种。一切众生未熟者方便令熟。已熟者令至解脱。又说三种。一者与现世利。二者与后世利。三者与现世后世利。劝令众生如法德业。获大财富守护增长与现世利乐。于此现世得大名称及众具乐。摄受安立劝舍大财。非家出家乞求活命与后世利乐。以必定得故现则不定。劝在家出家次第离欲。是名现世后世利乐。于此现世身心止息安隐乐住。后世则生净妙天上。及无余涅槃界而般涅槃

云何菩萨难行利。略说三种。若众生本来不修善因而能行利。是名第一难行利。谓苦劝化故。若本修善根得大财宝。深起贪着而能行利。是名第二难行利。谓彼大放逸处故。外道异学着本邪见而能行利。是名第三难行利。谓彼愚痴极违正法故

云何菩萨一切门行利。略说四种。一者是菩萨不信者劝令生信乃至建立。二者恶戒者劝修净戒。三者恶慧者劝修正慧。四者悭者劝修惠施乃至建立

云何菩萨善人行利。略说五种。一者是菩萨于众生真实利与。二者时与。三者义饶益与。四者柔软与。五者慈心与

云何菩萨一切行行利。谓六种七种。略说十三种。是菩萨应摄等摄应伏等伏。违佛法者除其障碍。中住众生令入法律。已入者以三乘法而成熟之。已成熟者令得解脱。众具护养劝导成熟。所谓劝舍小乘守护大乘。如众具护养。如是独静一心净诸障碍。忆念及修劝令成就。有声闻缘觉种性者。以声闻缘觉乘而成就之。有如来种性者。以无上菩提而成就之

云何菩萨除恼行利。略说八种。若有众生所应惭处令舍无惭缠。以得开觉如无惭缠。如是无愧缠睡缠眠缠掉缠悔缠悭缠嫉缠。悉令闻觉亦复如是

云何菩萨此世他世乐行利。略说九种。普令众生身业清净谓授一切种不杀生。一切种不盗。一切种不邪淫。一切种不饮酒。普令众生口业清净。谓授一切种不妄语。一切种不两舌。一切种不恶口。一切种不绮语。普令众生意业清净。谓授无贪无恚正见

云何菩萨清净行利。略说十种。五种外清净。五种内清净。五种外清净者。一者无罪。二者不随转。三者次第。四者一切。五者如其所应。杂恶行者先恶行者一向恶行者等以善法而成就之。是名无罪利安众生。乐解脱者劝令解脱。是名不随转利安众生。童蒙众生。先说粗法粗近教诫而随顺之。知中智者。为说中法中教诫而随顺之。胜智慧者。为说深法微细教诫而随顺之。令其次第渐得善法。是名次第利安众生四性。乃至天人一切众生。随能随力利益安乐。是名一切利安众生。下善中善上善者。随其所应方便利安。是名如其所应。是名五种外清净行利。五种内清净者。是菩萨广住悲心利安众生。是菩萨忍一切苦而不懈惓。心常欢喜利安众生。是菩萨以自在身。谦卑忍下犹如仆使。亦如孝子如旃陀罗子。离诸我慢利安众生。是菩萨离于利养心不虚伪。心存胜妙利安众生。是菩萨于究竟处终不退转。常以慈心利安众生。是名菩萨五种内清净。如是内外五种清净。是名十种清净利安众生。云何菩萨同利。是菩萨此义此善若等若胜。授与众生悉与己同。是名菩萨与众生同利。菩萨得此同利调伏众生。坚固决定。终不退转于劝授善法。何以故彼作是念。是菩萨与我同利。必能令我安隐。快乐。以是菩萨所授我者自修行故。非不乐因而自修行若以同利教授众生。彼终不言汝自不行。云何劝授教诫他人。汝应从他咨受教诫

有菩萨他同利如是同利不示他。有菩萨不同利如是示同利。有菩萨同利亦示同利。有菩萨亦不同利亦不同利示他。初句者诸菩萨等功德。住菩萨道等功德。菩萨隐覆真实功德不为显示。第二句者下劣众生怖畏深法。菩萨思惟方便调伏。现同彼法如栴陀罗。疾得利益息恼调伏。故现与彼同。第三句者为调伏彼受动摇善根众生故。菩萨以住善根。若上善根显示同利。第四句者心自放逸弃舍他利。从种种施如前说如戒广说。乃至同利彼诸波罗蜜。自成熟佛法成熟摄事。是名略说菩萨善法业。从种种施乃至同利。是种种无量善法菩提分当知三种行二种胜。三种净身口意行。当知是行上妙。无染当知是胜无上。不共彼众生等事等时等是名上妙。众生等者。是菩萨为一切众生行施等善根不自为己。事等者。是菩萨行施等一切种善根。时等者。是菩萨不离方便时节日夜。今世后世常修施等善根心不休息。无染者有四种。是菩萨欢喜心修习善法。不因是故生忧苦悔恨。是菩萨不恼他人不着诸见。不杂恶行行施等善根。是菩萨一切自己功德专至显现。坚固显现寂灭决定。不由于他行施戒等诸善法。是菩萨不于施等善法而求果报。若转轮圣王帝释魔梵。不求他报。不依此等求名利身命。于此等行净欢喜俱不恼乱他。专至无依从施等。乃至同利诸善法行。是名无染。炽然不动快净。是名清净。菩萨入净心地一切善根炽然不动。是炽然净心地。菩萨一切善法不思惟起。是不动净心地。菩萨随所得所修善法则不退转于未来世必定不退。日夜增长如明分月。日夜增长善法不退亦复如是。菩萨住究竟菩萨地一生相续。若最后有所得善根名为快净。于上更无菩萨净地故。是名三种善行三种胜三种净。当知从檀波罗蜜乃至同利一切施等。乃至一切同利。修习清净如来具足充满无上菩提金刚坚固身正法久住果报生。难施乃至难同利。修习清净如来平等奇特未曾有法。成就果报生。一切门施。乃至一切门同利。修习清净如来为一切最胜众生天人供养果报生。善人施等。乃至善人同利。修习清净如来。于彼无足二足四足多足。色无色想无想非想非非想。一切众生最上果报生。一切行施。乃至一切行同利。修习清净如来种种无量功德摄受三十二大人相。八十随形好身果报生。除恼施乃至除恼同利。修习清净如来于菩提树下一切魔怨不能倾动果报生。此世他世乐施。乃至此世他世乐同利。修习清净如来最胜禅解脱三昧正受安乐果报生。清净施。乃至清净同利。修习清净如来一切种清净。所谓四种净身净缘净心净智净果报生。三不护十力四无畏三念处一切不共佛法清净果报生。是名菩萨施等诸善法果报无上。无量菩萨无罪行之所出生

    菩萨地持方便处供养习近无量品第十六

云何菩萨供养如来。略说十种。一者身供养。二者支提供养。三者现前供养。四者不现前供养。五者自作供养。六者他作供养。七者财物供养。八者胜供养。九者不染污供养。十者至处道供养。若菩萨于佛色身而设供养。是名身供养。若菩萨为如来故。若供养偷婆若窟若舍。若故若新。是名支提供养。若菩萨面见佛身及支提而设供养。是名现前供养。若菩萨于如来及支提。悕望心俱欢喜心俱。现前供养。如一如来法。如是过去未来现在一切如来法。如一如来支提法。如是一切如来支提法。作是念。我今现前供养如来。及供养过去未来现在如来。我今现前供养如来支提。及供养一切十方无量世界一切支提。若偷婆。若窟。若舍。若新。若故。是名菩萨共现前不现前供养。若菩萨于不现前如来及支提心念供养。为一切佛故。为一切如来支提故。是名不现前供养。若菩萨于如来般涅槃后。以佛舍利起偷婆。若窟若舍。若一若二若多。乃至亿百千万。随力所能。是名菩萨广不现前供养。以是因缘。得无量大果常摄梵福。是菩萨常于无量大劫不堕恶趣。无上菩提众具满足。若菩萨于如来及支提。现前供养得大功德。不现前供养得大大功德。共现前不现前供养。得最大大功德。若菩萨于如来及支提。手自供养。不依懈堕令他施作。是名菩萨自作供养。若菩萨于如来及支提不独供养。普令父母师友亲属国王大臣长者居士在家出家悉共供养。是名自他共供养。若菩萨有少许物以慈悲心。施彼贫苦薄福众生。令得供养如来及支提。令得安乐而不自为。是名菩萨他作供养。自作供养者得大果报。他作供养者得大大果报。自作他作供养者得最大大果

若菩萨于如来及支提。以衣食床卧汤药众具。问讯礼拜奉迎合掌熏香末香涂香种种花鬘伎乐幢幡缯盖灯明种种赞叹五轮作礼敬绕右旋。以为供养。无尽胜财摩尼真珠珂珼玉石珊瑚琥珀车磲马瑙金银赤宝左旋胜宝摩尼宝环。悬以宝铃散以金钱金缕围绕。施如是等宝。是名财物供养。若菩萨久远于如来及支提。以财物供养。若多若胜。若现前不现前。若自作他作。淳净信心现在前。专精解心而作供养。以是善根回向无上菩提。如是七种名菩萨胜供养。若菩萨自手供养如来及支提。不轻他人不放逸不懈怠。至心恭敬不轻未。不乱心不染污心。不于信心国王诸胜人所现谄曲威仪求财供养。不以雌黄涂佛形像。亦不以汁而洗浴之。亦不烧求求罗香而以供养。阿迦花等诸不净物。悉不用之。是名菩萨六种无染污供养。若菩萨殊胜不染财物。供养如来及支提。若自力得若从他求。若如意得。彼众具自在。如意得财。菩萨若化作身。若二若三乃至百千万亿身。彼一一身悉礼如来。彼一一身化作百千手。彼一一手以种种华香供养如来及支提。彼一切身悉赞叹如来真实功德饶益众生。彼一切身皆以上妙衣服众宝璎珞幢幡花盖。供养如来。如是等名为如意自在力得。系心供养。不待如来出现于世。何以故。住不退转地菩萨。于一切佛刹未曾障碍故。若菩萨不自力得财。不从他求。亦不自在力得而为供养。然于他众生。若阎浮提。若四天下。若千世界。若二千世界。若三千大千世界。乃至十方无量世界。上中下心所作供养。菩萨于彼一切供养。以净信心胜妙解心。周遍随喜。是菩萨以少方便兴大供养摄大菩提具。是菩萨常等真实心可喜乐心。应当修学。彼菩萨少时。乃至一[聲-耳+牛]牛顷。于一切众生修习慈心悲心喜心舍心。于一切有为行起无常想。无常苦想。苦无我想。涅槃安乐想。念佛念法念僧。念波罗蜜。乃至少时。于一切法起少忍知离言说法自性如解脱。离诸妄想无相心住。况复过上。彼菩萨护持禁戒止观菩提分方便。诸波罗蜜诸善摄事方便。是名菩萨至处道供养如来。第一最上最妙最胜无上。如此供养比前财物供养。百倍千倍乃至极算数譬喻不得为比。如是十事。名菩萨一切种供养如来。如供养佛如是法。如是僧。随所应。当知于此三宝作十种供养

菩萨于如来所起六种净心。谓福田无上心。恩德无上心。于一切众生无上心。如优昙钵花难遇心。于三千大千世界独一心。于世间出世间法一切具足依义心。以此六心少想供养如来法僧获无量功德。何况多

菩萨成就几行为善知识。有几行善知识开导无碍。复有几行得善知识净信住处。复有几行善知识调伏众生。为善知识事。菩萨有几行。习近善知识。复有几行想。于善知识听受正法。菩萨于善知识听受正法。复有几处。无有想念菩萨成就八事。满足一切善知识行。一者善住律仪戒而不毁犯。二者多闻现在觉悟。三者得禅定修慧及余止观善根。四者悲心哀愍舍现法乐广化众生。五者成就无畏为众说法。正念不失乐说无畏。六者堪忍。轻欺骂辱诸不爱言。及诸恶行。皆悉能忍。七者无惓。多思惟力为四众说法而不疲懈。八者辩才巧便。凡所说法言辞通利。菩萨有五事。如是一切种功德。具足善知识善知识所作开导无碍。一者先欲安乐众生。二者于彼安乐如实知之不颠倒觉。三者若作方便随顺说法。善能随顺调伏众生有堪能力。四者心不疲厌。五者平等悲念一切众生。于上中下心无偏党

菩萨有五事。得善知识净信住处他闻欢喜。况复现见。一者威仪成就。寂静威仪。具足威仪。举身齐整。二者心常安住。身口意业不悼不躁。三者不诳。谓不诳他故摄持威仪。四者不嫉。谓于他说法及得财利。不生嫉心。常自劝请令他说法。若财向己劝与他人。无谄伪心心常欢喜。见他说法及得利乐。起随喜心如己所得。五者以知足心少积众具所得能舍

菩萨有五事。真善知识。调伏众生为善知识事。一者语言。二者与念。三者教授。四者教诫。五者说法。以是五事广化众生。如声闻地教授教诫。广说如力性品

菩萨有四事。亲近善知识满足。一者若病不病随时供养。爱念恭敬净信饶益。二者随时敬礼。问讯奉迎合掌供养。三者如法衣食汤药众具而作供养。四者若依止者。如法随作而不倾动。如实而说随时往诣。请所应作。菩萨于善知识所成就五想而听法。当作宝想。以难得故。作眼想。得胜俱生智慧因故。作明想。得俱生智慧眼。显示一切种如实境界故。作大果福利想。得涅槃道无上因故。作乐无罪想。现法不得涅槃道。如实观察止观大乐。无罪因故

菩萨于善知识听受经法。于说法人有五处不忆念净心专听。一者不念破戒。谓不念言此犯律仪。不应从彼听受经法。二者不念下姓。谓不念言。我不从彼下姓之人听受经法。三者不念丑陋。谓不念言。我不从彼丑陋之人听受经法。四者不念坏味。谓不念言。我不从彼不正语人听受经法。但依于义不依于味。五者不念坏美语。谓不念言。我不从彼粗言说人听受经法。如是五处不忆念已。是菩萨勤摄正法。于说法人不起嫌想。若下根菩萨。起人过心退不乐听法。当知是菩萨不能自度智慧退减

云何菩萨修四无量。谓慈悲喜舍。略说菩萨四无量有三种修。一者众生缘。二者法缘。三者无缘。菩萨安处一切三聚众生已。若苦若乐不苦不乐众生。欲安乐故。作乐饶益想而修慈心。周满十方一切众生意解想住。是名菩萨众生缘慈。若菩萨起法数想。法数众生行观而修慈心。是名法缘慈。若复于法离诸妄想而修慈心。是名无缘慈。如众生缘法缘无缘慈悲喜舍亦如是。若菩萨于苦众生作除苦想。周满十方而修悲心。是名为悲。于乐众生起乐随喜想。周满十方而修喜心。是名为喜。如是三种众生不苦不乐。随其次第起离痴恚贪想。周满十方而修舍心。是名为舍。若菩萨慈等无量。众生缘与外道共。若法缘者。与声闻缘觉共。非外道共。若菩萨无缘无量。不共一切声闻缘觉及诸外道。若菩萨三无量。当知乐想摄。所谓慈悲喜。一无量安想摄。所谓舍。一切无量。名为哀愍。成就此者。名哀愍菩萨。菩萨观察众生界。有百一十苦而修悲心。云何百一十苦。有一种苦。谓一切众生。皆堕集苦。以集苦无差别故。又二种苦。谓欲根本所爱念事。变易生苦。愚痴报苦。极苦触身而作是言。我苦我苦。愚痴愁忧。亦名二箭。身受心受。又三种苦。谓苦苦行苦变易苦。又四种苦。一者合会别离苦。从爱别离生。二者断苦。从种类没死生。三者相续苦。从无量生死。展转相续生。四者终竟苦。从不得涅槃者五盛阴生。又五种苦。欲缠缘苦。恚痴睡眠悔悼缠缘苦。又六种苦。谓因苦。依恶道因故。果苦。生恶道故。求财苦守护苦。不足苦。坏败苦。又七种苦。谓生苦老苦病苦死苦怨憎会苦。爱别离苦。求不得苦。又八种苦。谓寒苦热苦饥苦渴苦。不自在苦。自作苦。谓尼干等他作苦。谓彼手石刀杖蚊虫等。久住威仪苦。又九种苦。谓自不具足苦。他不具足苦。亲属不具足苦。财物不具足苦。无病不具足苦。戒不具足苦。见不具足苦。现在苦。他世苦。又十种苦。谓食具不足苦。饮具不足苦。车乘不足苦。衣服不足苦。璎珞不足苦。器物众具不足苦。华须涂香众具不足苦。伎乐众具不足苦。灯明众具不足苦。男女给使不足苦。初始苦。复有余九种苦。谓一切苦。大苦。一切门苦。恶行苦。转生苦。不随欲苦。违害苦。相续苦。一切种苦。一切苦者。若前因所起及转时缘苦。大苦者。长夜种种无间大苦。一切门苦者。若地狱畜生饿鬼善趣轮转。恶行苦者。若现世犯他他还报己。若食恶食令身不安。如是种种自身现作还受其苦。若住众多不正思惟。则生一切诸烦恼苦。身口及心多造恶行。于未来世生恶行苦。转生苦者。有六事不决定起轮转生死。自身不定。谓先为王后反贫乞妻子不定。奴婢给使不定。朋友大臣亲属不定。谓今为妻子乃至大臣亲属已。彼于后时在生死中。反为怨害及恶知识财物不决定者。谓于生死中资财无量。后极贫苦。不随欲苦者。欲得长寿不乐短命。恼苦生。欲得端正不乐丑陋。恼苦生。欲为上族不乐卑贱。恼苦生。欲得自在不乐贫穷。恼苦生。欲得大力不乐少力。恼苦生。欲多智慧不乐愚痴。恼苦生。欲降伏彼不乐不如。恼苦生。违害苦者。谓在家妻子减苦。出家烦恼增苦。饥俭苦刀兵恐畏苦。旷野崄处恐怖苦。支节不具苦。杀缚断截捶打苦。驱摈出外苦。相续苦有九种。此中不说。一切种苦者有五种。如前说。五种乐相违苦。谓因苦。受苦。乐对治苦。不断受苦。出家远离寂灭菩提乐对治非家欲界和合觉想凡夫苦。是名五苦。又有五苦。谓逼迫苦。众具不足苦。四大增损苦。失所欲苦。三界烦恼秽污苦。是名五苦。此五种及前五种。略说十种一切种苦。前五十五种此五十五种。略说百一十种苦。是菩萨悲境界。缘彼故悲心生。修习增长成就满足

于彼大苦聚缘十八种苦生大悲心。云何十八苦。谓愚痴报苦。行苦。所摄究竟苦。因苦。生苦。自作苦。他逼迫苦。他作苦。恶戒苦。恶见苦。本因苦。大苦。地狱苦。善趣摄苦。一切性苦。无智苦。增长苦。受苦。鄙秽苦。复次有四行悲名为大悲。一者缘彼众生甚深微细难知之苦。而起悲心。二者久远长养。于百千劫修习殷勤。发悟缘生。三者菩萨随其发悟。入于悲心。为令众生永离众苦故舍百千身命。何况一身及诸财物。四者悉能代受一切种苦出离快净。谓究竟地菩萨。菩萨清净及如来。如来地清净。复次菩萨于此百一十种苦修习悲心。则为修习菩萨一切悲心。则能疾得清净悲心入净心地。菩萨于诸众生极亲厚想。爱念想。欲为所作想。不疲厌想。代受苦想。所作自在想。悲如苦谛无间等。圣弟子究竟深入厌离心相续生。谓菩萨悲心。前行观百一十种大苦种积聚。菩萨如是修习悲心。于内外事无有少物而不舍离无一律仪而不摄持。无一他不饶益而不堪忍。无一精进而不勇猛。无一禅定而不正受。无一智慧而不得入。若人问佛。住何等住处名为菩萨。应正答言。住大悲者是。彼一无量如前说。于诸无量最为无量积聚摄。无量爱果。无量行。一向纯善无有罪过。如是具足修习无量者。有四功德利。修此无量先得第一现法乐住。无量功德具摄受增长。于无上菩提净心坚固。为众生故于生死中代诸众生受一切苦

    菩萨地持方便处菩提品第十七

云何菩萨惭愧。略说有二种。一者自性。二者依处。菩萨行无罪行。自觉非法内自羞耻。是名为惭。以此非法故。于他生畏恭敬羞耻。是名为愧。又羞耻菩萨。性自专精。况复修习。是名菩萨自性惭愧。依处者。略说有四种。若所应作。不随建立而生羞耻。是名初依处。所不应作。随顺建立而生羞耻。是名第二依处。若为恶覆藏而生羞耻。是名第三依处。若自疑悔能自除灭。续起羞耻。是名第四依处。是名依处。云何菩萨不动力。略说有二种。一者自性。二者依处。能断染污心不令一切烦恼自在。堪忍众苦。种种财利种种恐怖。修正方便而不倾动。性自宽忍性能思惟。是故不动。是名自性不动力。复次菩萨不动力。略说五种不动。一者种种轮转苦能速除灭。二者所化种种众生造诸恶行。为是等故长夜受苦。三者伏诸异论。四者为诸大众随顺说法。五者演说胜妙甚深之法。能令菩萨具足受持一切禁戒

云何菩萨心无疲厌。有五因缘。修正方便而不疲厌。一者菩萨性自有力而不疲厌。二者于不疲厌数数修习而不疲厌。三者方便所摄。精进勇猛自观前后。所修转胜而不疲厌。四者深利智慧思惟成就而不疲厌。五者于诸众生深起悲心。常等哀愍而不疲厌。云何菩萨善知诸论。是菩萨于五明处。名身句身味身。从他所闻具足摄受诵习通利。从他闻义。善能思量。如是菩萨知法知义。于法于义已受不忘。未修习者。渐渐增进闻思究竟。次第成熟得喜净心。菩萨如是行者无量满足。善知诸论而不颠倒

云何菩萨善知世间。是菩萨于众生世间。如实了知。所谓生老死。此没彼生。此众生于生死出离。如实了知。复次于众生世间浊世增时。如实了知。离浊世增时。亦如实知。所谓五浊。一曰命浊。二曰众生浊。三曰烦恼浊。四曰见浊。五曰劫浊。谓今世短寿人极寿百岁。是名命浊。若诸众生不识父母。不识沙门婆罗门及宗族尊长。不修义理。不作所作。不畏今世后世恶业果报。不修慧施。不作功德。不修斋法。不持禁戒。是名众生浊。若此众生增非法贪。刀剑布施。器仗布施。诤讼斗乱。谄诳妄语。摄受邪法。及余恶不善法生。是名烦恼浊。若于今世。法坏法没。像法渐起邪法转生。是名见浊。若饥馑劫起。疾病劫起。刀兵劫起是名劫浊。是名菩萨知众生世间。复次菩萨于器世间若成若坏。如实了知。复次菩萨于世间。世间集。世间灭。世间集灭道。世间味。世间患。世间离。如实了知

复次菩萨眼及色俱生四大名士夫。身名为人。无有第三。言我众生想。无第三想。言我眼见色乃至我意识法俱是言说数言是长老。如是生如是姓。如是食。如是苦觉乐觉。如是长寿。如是久住。如是等言说分齐。一切皆如实知。菩萨于此众生世间器世间。八行观察世间义。世间第一义。如实了知。是名知世间

复次菩萨若见上座及胜功德者。尊重奉迎设床请坐。合掌恭敬礼拜问讯。年德等者正言詶对。软语安慰。不起等慢称量彼此。年德下者。随力劝喻。称彼实德。为覆实罪。不令耻惧生退没心。不轻蔑彼。若见众生求法求财。不背面不嚬蹙。欢喜舒颜。不嗤彼阙。见彼圮顿不起轻心。若见一切上中下人。先语问讯。叹言善哉。随宜善处。随力所能摄以财法。不谄曲不自重。不自高不自大。不以增高而自矜异。于诸亲厚一切给与。终不弃捐若病不病。随顺身口意业与相习近。为善知识离诸怨对孤独贫乞无所归荫。随其力能为作依怙。不以忧苦加于众生。因缘事起。所应戏笑。如法戏笑非不如法。不以戏言形名他人。乃至亲密亦复不说。于他人所不久嗔恨。虽复嗔彼不扬其过。若为他人身口毁辱。能善思惟以法自解。自省己过心不躁动。身口意业虑而后行。离十四垢业。谓隐覆六方。离四恶友摄四善友。如修多罗广说。现法乐义。钱财具足。勤力具足。守护具足。以正命心为诸世间工巧之业。不曲不幻不欺诳。常有惭愧行无罪行。威仪具足重慎威仪。为他亲厚受寄不侵。若负人债终不抵捍。分父余财平等无偏。若是真宝主作伪想依实与价。决断世事辩正机速。彼彼所作来求请者。悉与同事终不废退。能随问答。为正事业不为非正。若为国王。以法治世不为非法不乐罚责。于恶戒众以戒建立。成就八种贤圣之语。见则言见。闻觉识知则言识知。不闻不见不觉不知则言不知。菩萨成就如是等法。如世间知如世间转。如实了知。是名知世间

云何菩萨修习四依。是菩萨为义故从他听法。不为味为义听法。不为味者。若闻世间非巧便说。依义菩萨亦专心听。复次菩萨于闇说明说。如实了知。知所应依。不以上座多识。若佛若僧。依止如是诸说法人。如是依止所。应不依于人。于真实义心不动摇。能自了知不由于他。复次菩萨于如来所深信清净。一向信受如来所说。依了义经非不了义。依了义经者。于此法律不可破坏。不了义经者。谓以种种门说而不决定。应有疑问。若菩萨于了义经作不决定者。于此法律则为可坏。复次菩萨得坚固修慧。不以闻思识诸法义用修慧知。不以闻思识知故。闻如来所说第一甚深法义。不起诽谤。是名菩萨修习四依。如是成就者。略说四种。无量显示其义具足。大师修慧所知。一切四依。平等方便。菩萨于彼出要道。皆悉明达而不迷惑

云何菩萨四无碍慧。于一切法一切章句。如其体实。修慧所知无碍不谬。是名法无碍。于一切法一切相。如其体实。修慧所知无碍不谬。是名义无碍。于一切法一切名处。如其体实。修慧所知无碍不谬。是名辞无碍。于一切法一切种分别。如其体实。修慧所知无碍不谬。是名乐说无碍。菩萨如是四无碍。得五处无量巧便。谓阴巧便。界巧便入巧便。缘起巧便。处非处巧便。此四行菩萨于一切法。能自觉悟为他显示。除此已更无有余。能自觉悟。况余显示

云何菩萨菩提具。当知二种。一功德具。二智慧具。此二种具。广说如自他品。又功德智慧具。菩萨初阿僧祇劫名为下。第二为中。第三为上

云何菩萨摩诃衍所摄修习三十七道分是菩萨依四。无碍慧方便。所摄智三十七道分。如实了知而不取证。种种乘方便。彼亦如实知。所谓声闻乘方便。大乘方便。声闻乘方便如实知。如声闻地所说。云何菩萨于大乘方便三十七品如实了知。是菩萨住身身观。不于身身而起妄想。亦非一切非性。于彼身离言说自性。如实了知。是名第一义身身观念处。若菩萨观世谛者。随无量处方便。知身身观念处。如身身观念处。余念处及余道品亦复如是。非身等法妄想观苦。若妄想观集。亦不于断起灭妄想。亦不于得因起道妄想。离言说自性。苦法集法灭法道法。如实了知。依此第一义修道分。名为修谛。若菩萨随世谛无量处方便。名为缘谛修。若彼菩萨于此法如是不起妄想者。是名为止。及彼如实知第一义。及无量处方便知法。是名为观。略说菩萨止有四行。一者第一义。二者俗数智前行。三者一切虚伪妄想不行。四者于此无言无相之法不起妄想其心寂静。一切诸法悉同一味。如是四行。菩萨止起乃至究竟。如来知见。略说菩萨观有四行。谓此四行所起智慧。是名为观。离一切法有无智慧。随无量法分别处观。于此四行菩萨观起乃至究竟。如来知见。是名略说菩萨止观

云何菩萨巧方便。略说十二种。为起内佛法有六种。为外成熟众生有六种。云何为起内佛法六种巧方便。一者菩萨悲心。顾念一切众生。二者一切诸行。如实了知。三者求无上菩提智。四者依顾念众生舍离生死。五者依诸行如实知。以无染心。轮转生死。六者依求佛智慧炽然精进是名为起内佛法六种巧方便。云何为外成熟众生六种巧方便。一者菩萨巧方便以少善根起无量果。一者以少方便。起无量善根。三者毁坏佛法众生除其暴害。四者处中众生令入佛法。五者已入众生令其成熟。六者已成熟者令得解脱。云何菩萨能以少善根得无量果。是菩萨教下劣众生。以少财物施下福田。乃至揣糗施于畜生。施已回向无上菩提。以回向力故得无量果。云何菩萨以少方便起无量善根。是菩萨见有众生修邪法斋而求解脱。则为彼说贤圣八斋断苦方便不究竟法。授少方便得大果斋。复次邪见众生苦身求度。为说中道。令离二边究竟解脱。复次或有众生求生天者。邪见方便投岩赴火不食等苦。则为演说正法禅定。现法乐住。后生天上如法受乐复次或有众生诵习外典求清净者。以佛正法令其诵习思惟其义。又说如来甚深经典。具足显示空相应法。彼闻法已。生厌离心专精净信。于一念顷能摄广大无量善根。况复次第续念不舍。复次菩萨意解思惟起净妙想。即以世间香花珍物供养三宝。亦教他人心想供养。复次如是净心遍满十方一切世界。供养三宝生随喜心。亦复教人令其随喜。复次常修念佛乃至念天。亦教他人令修六念

复次正念合掌恭敬。随时供养一切三宝。亦教他人修此供养。复次于一切众生一切功德皆悉随喜。亦教他人起随喜心。复次于一切众生入广大悲心。悉欲代受一切众苦。亦教他人兴此大悲。复次于过去现在一切所犯。以真实随顺求净戒心。向十方佛至诚忏悔。亦教他人如是悔过。彼常如是悔其所犯以少方便。于一切业障悉得解脱。复次作众多种种无量变化。一切十方佛法僧处及众生处。无量神通他心自在。菩萨摄取切德。复次菩萨修慈悲喜舍。亦教他修。是名菩萨以少方便。生广大无量善根果报

菩萨地持经卷第七

    方便处摄品第十五

云何菩萨爱语。略说有九种。一者自性爱语。二者一切爱语。三者难爱语。四者一切门爱语。五者善人爱语。六者一切行爱语。七者除恼爱语。八者此世他世乐爱语。九者清净爱语。自性爱语者。是菩萨可喜语真实语如法语义饶益语与众生语。是名自性爱语一切爱语者略说二种。一者菩萨见人舒颜平视赞言善来等念在前。先语安慰。道路清泰四大调适卧觉安不。如是等随顺世间巧便调言等心慰问。又复咒。愿妻子眷属钱财谷米增长具足。见具功德者。劝其信戒施闻智慧令其欢喜。二者说一切种功德用应法。安乐众生。常说等说第一胜妙饶益言说。是名菩萨一切爱语。菩萨爱语二种分别。慰问赞叹者。是名随世间语。第一胜妙饶益言说者。是名正说法语。难爱语者略说三种。一者于怨憎所。以清净心思惟慰喻。发喜饶益而共言语。二者于增上愚痴钝根众生。以无厌心思惟筹量。忍诸疲苦以法摄取为具足说。三者于诸谄曲幻伪众生。欺和尚阿阇梨及尊重福田。或恶邪见。以无害心方便慰喻。发喜饶益而为说法。是名难爱语。一切门爱语者略说四种。一者断除诸盖向于善趣。说初所作法。二者断除诸盖实心增进。说应四真谛法。三者见在家出家放逸众生。等心诃责令离放逸。四者已起疑惑能为开解。若说法若决定论。善人爱语者略说五种。一者说佛菩萨正因调伏法。二者正出。三者正依。四者正度。五者正示现。处所因缘制戒。是故此法名为正因。于所受戒有所缺犯。教令还净。是故此法名为正出。说四依所摄正法律至处道。是故此法名为正依。显示出一切苦不退还道。是故此法名为正度。三种示现于一切说无碍。是故此法名为正示现。一切行爱语者谓六种七种。略说十三种。听所应听法爱语。制所应制法爱语。现诸经法爱语。现诸法相爱语。现诸法名字不颠倒爱语。法句种种分别爱语。慰喻爱语。发喜爱语。自恣安以众具代其所作虚受爱语。种种恐怖施安爱语。具足说法摄取爱语。开觉不善安立善法见闻疑举罪折伏爱语。劝有力说法爱语。是十三种名为一切行爱语。除恼爱语者略说八种。依口四净。八种圣语。口四净者。离妄语两舌恶口绮语。八种圣语者。见闻识知见闻觉知说。不见不闻不识不知不见不闻不觉不知说。此世他世乐爱语者略说九种。断亲属难忧苦故。爱语说法。断财物难忧苦故。爱语说法。断疾病难忧苦故。爱语说法。断戒难忧苦故。爱语说法。断见难忧苦故。爱语说法。戒具足见具足威仪具足正命具足故。爱语说法。清净爱语者有二十种说法。如前力种性品说。云何菩萨利益。利益者。如爱语广说。异利益今当说。谓菩萨一切行爱语。随所说义利安众生。自性利益者。是爱语具足。显示众生如所应学。随利益行法次法向。住于悲心无贪心。劝导教授调伏安立。是名自性利益。一切利益者略说二种。一者一切众生未熟者方便令熟。二者已熟者令至解脱。复有三种。一者与现世利。二者与后世利。三者与现世后世利。劝教众生如法德业获大财宝。守护增长与现世利。于此现世得大名称及众具乐。摄受安立劝舍大财。在家出家乞求活命。与后世利乐。已必定得故。现则不定。劝在家出家次第离欲。于此现世身心息止安隐乐住。后世则生净妙天上。及无余涅槃界而般涅槃。是名现世后世利。难利益者略说三种。一切众生本不修善因而能利益。以苦劝化故。二者本修善根得大财宝深起贪着。而能利益彼大放逸故。三者外道异学着本邪见而能利益彼。极愚痴违正法故。一切门利益者略说四种。一者不信者劝令生信。乃至建立。二者恶戒者劝修净戒。三者恶慧者劝修正慧。四者悭贪者劝修慧施。乃至建立。善人利益者略说五种。一者于众生真实利与。二者时与。三者义饶益与。四者柔软与。五者慈心与。一切行利益者谓六种七种。略说十三种。应摄等摄。应伏等伏。违佛法者除其障碍。中住众生令入法律。已入者以三乘法而成熟之。已成熟者令得解脱。众具护养劝导成就。所谓劝舍小乘守护大乘。独静一心。净诸障碍。忆念及修劝令成就。有声闻缘觉种性者。以声闻缘觉乘而成就之。有如来种性者。以无上菩提而成就之。除恼利益者略说八种。若有众生。所应惭处令无惭缠心得开觉。无愧缠。睡缠。眠缠。掉缠。悔缠。悭缠。嫉缠。悉令开觉亦复如是。此世他世乐利益者略说九种。普令众生身业清净。谓授一切种不杀不盗不邪淫不饮酒。普令众生口业清净。谓授一切种不妄语不两舌不恶口不绮语普令众生意业清净。谓授无贪无恚正见。清净利益者略说十种。五种外清净。五种内清净。五种外清净者。一者无罪。二者不随转。三者次第。四者一切。五者随所应。杂恶行者。先恶行者。一向恶行者。等以善法而成就之。是名无罪利安众生。乐解脱者劝令解脱。是名不随转利安众生。童蒙众生为说近法。近教诫而随顺之。中智者为说中法。教诫而随顺之。上智者为说深法。胜微细诫而随顺之。令其次第渐得善法。是名次第利安众生。四姓乃至天人一切众生。随能随力利益安乐。是名一切利安众生。下中上善随其所应方便利益。是名五种外清净。六种内清净者。广住悲心利安众生。忍一切苦而不懈惓。心常欢喜利安众生。以自在身谦卑忍下犹如仆使。亦如旃陀罗子。离于我慢利安众生。离于利养舍于虚伪。心在胜妙利安众生。于究竟处终不退转。常以慈心利安众生。是名五种内清净。如是外内五种清净。是名十种清净利安众生。云何菩萨同事。是菩萨此义此善。若等若胜。受与众生悉与己同。是名同事菩萨。得此同事调伏众生。坚固决定终不退转。于劝授善法。何以故。彼作是念。是菩萨与我同事。必能令我安隐快乐是菩萨所授我者。自修行故。非不乐因而自修行。若以同事教授众生。彼终不言汝自不行。云何劝授教诫于人。汝应从人咨受教诫。有菩萨同事。如是同事不示他。有菩萨不同事。如是同事示他。有菩萨同事。亦示同事。有菩萨不同事。亦不示同事。不示他者。诸菩萨等功德。住菩萨道等功德。菩萨隐覆真实功德。不为显示他者。下劣众生怖畏深法。菩萨思惟方便调伏。现同彼法如旃陀罗。疾得利益息恼调伏故。现与彼同。示亦同事者为调伏彼受动摇善根众生故。菩萨以住善根若上善根。显示同事。亦不示同事者。心自放逸。弃舍他利从种种施。如前说。乃至同事诸波罗蜜。自成熟佛法。成熟众生。是名略说菩萨善法业从种种施。乃至同事。是无量善法菩提分。当知三种行。二种胜。三种净身口意行。是名为行上妙无染。是名为胜上妙。有三种众生等事等时等。众生等者。是菩萨为一切众生行施等善根。不自为己。事等者。是菩萨行施等一切种善根。时等者。是菩萨不离方便。时节日夜今世后世。常修施等善根。心不休息。无染有四种。是菩萨欢喜心修习善法。不因是故生忧苦悔恨。是菩萨不恼他人。不着诸见不杂恶行。行施等善根。是菩萨一切自己功德。专至显现坚固显现。寂灭决定不由于他。行施戒等诸善法。是菩萨不于施等善法而求果报。若转轮圣王帝释魔梵。不求他报。不依此等求名利身命。于此等行净欢喜。俱不恼乱他。专至无依。从施等乃至同事诸善法行。是名无染炽然不动快净。是名清净菩萨入净心地。一切善根炽然不动。是名炽然净心地。菩萨一切善法不思惟起。是名不动净心地。菩萨随所得所修善法则不退转。于未来世必定不退。如明分月。日夜增长善法不退亦复如是。代究竟地菩萨一生相续若最后身所得善根。是名快净。于上更无菩萨净地故。是名三种行二种胜。三种净当知从檀波罗蜜乃至同事。一切施乃至一切同事。修习清净如来。具足充满无上菩提。金刚法身正法久住。果报生。难施乃至难同事。修习清净如来。平等奇特未曾有法成就。果报生。一切门施乃至一切门同事。修习清净如来。一切取胜天人供养。果报生。善人施乃至善人同事。修习清净如来。于无足二足四足多足。色无色想无想非想非非想一切众生。最上果报生。一切行施乃至一切行同事。修习清净如来。种种无量功德摄受。三十二大人相。八十随形好果报生。除恼施乃至除恼同事。修习清净如来。于菩提树下。一切魔怨不能倾动。果报生。此世他世乐施乃至此世他世乐同事。修习清净如来。最胜禅解脱三昧正受安乐。果报生。清净施乃至清净同事。修习清净如来。一切种净。所谓四种身净缘净心净智净。果报生。三不护十力四无畏三念处。一切不共佛法清净。果报生。是名菩萨施等。善法果报无上无量。菩萨无罪行之所出生菩萨地持经卷第八

        北凉中印度三藏昙无谶于姑藏译

    菩萨地持菩提分品之余

云何菩萨坏佛法者除其暴害。处中者令入。已入者令熟。已熟者令解脱。是菩萨于此四种成就众生。当知略说六种巧方便。一者随顺。二者立要。三者异相。四者逼迫。五者报恩。六者清净。菩萨随顺巧方便者。是菩萨欲为众生说法。先如是柔软身口行。以施将顺自舍恚恨。除恚恨已。彼生爱敬乐欲闻法。然后乃为如应说法。易入易解。时说次第谛不颠倒。以义饶益而为说法忍。诸问答调伏众生。第一利益哀愍成就。若以神力示现他心而为说法。或请余人。令种种现化调伏众生。若有略说义饶益论广为分别。若广大论能为略说。授彼令诵自恣问难。彼受诵已广为说义。以一切缘三昧度门随顺教授。随顺教诫摄取众生。令其行义。彼诸众生于如来说甚深微妙空相应经。如其旨趣。彼经中说。离自性法及离诸事不起不灭。如虚空如幻如梦。不知义者闻则惊怖。谤彼深经言非佛说。菩萨为彼众生随顺巧便。于彼深经如来旨趣。随顺其义分别解说而摄取之。如是随顺为彼说言。彼经不说一切都无所有。但言说我自性空无所有。是名离自性离言说。有事依言事转。是故言说有自性。亦非第一义。有彼自性。是故说言离一切事。言说自性。从本已来一切都无所有。云何有生有灭。是故说言不生不灭。譬如虚空有种种色及诸色业。悉容受彼为作依处。谓虚空行住去来屈申俯仰。又如除彼色及色业。已谓无色自性分。名清净虚空。如虚空处色等业转离言说事。种种施设言说妄想虚伪随转亦复如是。又如虚空容色等业。离言说法容受妄想亦复如是。若菩萨以智慧。除一切言说所起。邪惑妄想诸虚伪转。是菩萨以第一圣智离言说事。一切言说自性非性。如虚空清净。亦非彼展转有余自性。是故一切诸法。譬如虚空譬如幻。不如事有亦非一切都无幻事。如是一切法不如言说。愚痴计有亦非一切都无所有。第一义离言说自性。如是方便入非有亦非无。是故知如幻故说如幻。如是菩萨于一切法界。不取不舍不增不减亦无所坏。如实了知。如其所知为人显示。是名菩萨随顺巧方便。云何菩萨立要巧方便。若有众生来从菩萨。求索十种资生众具。为立要言。汝能供养父母沙门婆罗门。广说如上。乃至受戒。若能如是我当施汝。如其不能则不施与。所谓田宅市肆官爵国土钱财六畜工巧医方。若结婚姻。若食不食。所作同事。尔时菩萨为立要言。汝能供养父母。乃至受戒。我当施汝饮食。乃至同事。复次菩萨。若有众生犯罪谋逆。作不饶益事。为他杀缚断截捶打。毁辱呵责驱出质债。为他所执。尔时菩萨为立要言。汝能供养父母。乃至受戒。我当救汝令脱众难。复次若有众生王贼水火人及非人不活恶名诸恐怖等。尔时菩萨为立要言。汝能供养父母。乃至受戒。我当救汝令脱恐怖。若有众生欲恩爱集会远离怨憎。尔时菩萨为立要言。汝能供养父母。乃至受戒。我当方便从汝所愿。复次若有众生疾病困厄。尔时菩萨为立要言。汝能供养父母。乃至受戒。我当令汝病苦得除。菩萨如是立要已。彼诸众生疾修善法远离诸恶得随所欲。是名菩萨立要巧方便。若菩萨与众生立要已。彼诸众生不随要者。如上所许亦不施之。为度彼故非不欲与。诸难恐怖及诸病苦。爱念和合。不爱别离。为度彼故一切放舍。示作如是决定之相。非其实心有放舍念。渐渐要令断不善法建立善法。若复众生无所须欲亦无众难。乃至无病。而与菩萨先为亲厚。随宜劝导令修善法。所谓供养父母。乃至持戒。若彼众生不随其教。尔时菩萨现嗔责相。为度彼故。心无恚恨于诸所作悉现乖异。为度彼故。非实违背。或现加彼不饶益事。欲度彼故。非其实心。菩萨方便现此异相。欲令众生修诸善法断不善法。是名菩萨异相巧方便。云何菩萨现逼迫巧方便。若菩萨为主为王。于自眷属作如是教。若我眷属有不供养父母。乃至犯戒者。我当断其供给。或加谪罚或至驱摈。立一士夫常令伺察。彼诸众生以恐怖故。勤修善法断不善法彼虽不乐强逼令修。是名菩萨逼迫巧方便

云何菩萨报恩巧方便。若菩萨先于众生施诸恩分若施财物。若度众难若度恐怖。和其所念离所不念。救疗众病令得安乐。众生知恩欲报德者。尔时菩萨劝令修善。不须世间财利酬报。报之大者。当供养父母乃至持戒。求报恩者令其行善。是名菩萨报恩巧方便

云何菩萨清净巧方便。住究竟地菩萨。净菩萨道生兜率天。众生念言。某菩萨生兜率天。不久当下生阎浮提。当成如来无上等觉令我爱乐。莫令不乐彼所生处。我亦随生。无量众生乐修是愿。又复菩萨。从兜率天来生世间。若生王宫若婆罗门家。舍上妙乐出家学道。令诸众生舍离憍慢。又于树下苦行六年。令余众生信苦行者断其信乐。又复既成无上菩提。令余众生坚固信乐同求佛道。又成佛已。默然待请。为令众生敬重法故。梵天劝请然后乃说。又以佛眼观察世间。莫令众生作是谤言。但以梵天劝请力故。非是如来大悲故说。为除众生邪摄受故转正法轮。诸余世间所未曾转。及制戒律。是名菩萨清净巧方便。如是巧方便无余无上。是名菩萨六种巧方便。略说广说。坏法众生除其暴害。处中者令入佛法。入者令熟熟令解脱。无余无上。是名菩萨巧方便

云何菩萨陀罗尼略说四种。一者法陀罗尼。二者义陀罗尼。三者咒术陀罗尼。四者得菩萨忍陀罗尼。云何法陀罗尼。菩萨得如是忆念智慧力。于未曾所闻未曾修习名句味身。次第庄严次第所应。无量章句。经无量劫忆持不忘。云何义陀罗尼。如前所说。于此诸法无量义趣。未曾读诵未曾修习。经无量劫忆持不忘。云何咒术陀罗尼。菩萨得如是三昧力。以咒术章句。为众除患。第一神验。种种灾患悉令消灭。云何得菩萨忍陀罗尼。菩萨精勤修习。因起智慧。独一静处。燕默少言亦不游行。知量而食不杂种食。常一坐食思惟禅定少睡眠多觉悟。于如来所说得菩萨忍咒术。所谓

伊致　密致　吉胝鼻　羼提跛大[口*習]波呵([口*習]音稣急反)

于此诸咒术章句义思量观察。如是咒术章句。如是正思惟。如此义尚不自闻。何有所得。如咒术章句。义不可得。是则无义。如是诸义。所谓无义。是故亦无余义可求。如是名为善解咒术句义。善解咒术句义者。以如是义。比知一切诸法义。皆悉善知不从他闻。又知一切言说。一切法自性。义不可得。以此等无言说自性义。则知一切诸法自性义。是名第一义最胜义。得最上欢喜。是菩萨得此陀罗尼咒术处。名得菩萨忍。得此忍者。不久当得净心增上解行地忍。是名菩萨得菩萨忍陀罗尼。彼法陀罗尼。义陀罗尼。菩萨是度初阿僧祇劫入净心地所得。必定不动最胜最妙。若中间所得。或因愿力。或禅定力。不定不任亦不胜妙。如法义陀罗尼。咒术陀罗尼亦如是。得菩萨忍陀罗尼。如前所说。如是一切陀罗尼具四功德者。乃能得之非不具足。云何为四。一者不习爱欲。二者不嫉彼胜。三者一切所求等施无悔。四者乐法深乐菩萨藏。及摩得勒伽藏

云何为菩萨愿。略说五种。一者发心愿。二者生愿。三者境界愿。四者平等愿。五者大愿。彼菩萨初发无上菩提心。是名发心愿。愿未来世为众生故随善趣生。是名生愿。愿正观诸法无量等诸善根。思惟境界。是名境界愿。愿未来世一切菩萨善摄事。是名菩萨平等愿。大愿者。即平等愿。又说十种大愿。一者愿一切种供养无量诸佛。二者愿护持一切诸佛正法。三者愿通达诸佛正法。四者愿生兜率天。乃至般涅槃。五者愿行菩萨一切种正行。六者愿成熟一切众生。七者愿一切世界悉能现化。八者愿一切菩萨。一心方便以大乘度。九者愿一切正方便无碍。十者愿成无上正觉

云何菩萨空三昧。菩萨离一切言说自性。观无言说自性心住。是名空三昧。云何无愿三昧。菩萨于无言说自性事。邪见妄想所起烦恼。苦常见其过。于未来世不愿心住。是名无愿三昧。云何无相三昧。菩萨于无言说自性事。离一切妄想。虚伪相灭。观察如实寂静心住。是名无相三昧。以何等故说三三昧。不增不减。有二种。有及无有。有为无为名为有无我我所名无有。于有为有不愿不随故。立无愿三昧。于无为涅槃愿乐摄受故。立无相三昧。又于此诸事非愿非不愿。然于有不有见以是见故。立空三昧。菩萨修此三三昧。如是建立如实知。若有余行。悉入三三昧门。所谓声闻所学所行

有四忧檀那法。诸佛菩萨为令众生清净故说。云何为四。一切行无常是忧檀那法。一切行苦是忧檀那法。一切法无我是忧檀那法。涅槃寂灭是忧檀那法。诸佛菩萨具足此法。复以此法传授众生。是名忧檀那。过去寂默诸牟尼尊展转相传。是名忧檀那。增上勇出乃至具足出第一有。是名忧檀那。云何菩萨观一切行无常。菩萨观一切行言说自性常不可得。若复不知真实无言说事故有生有灭。若彼观无言说自性一切行无常。观过去行。无生无灭。彼亦无因亦无自性可得。是故亦无因亦无自性。观现在行无生无灭。彼因不得而与果。故自性可得。是故观彼自性而无因。观未来行无生无灭。彼因可得而不与果。故无自性。是故观因而无自性。如是见三世分段诸行相续转时。一一行刹那有三有为。有为相。于刹那后。有四有为相。彼前诸行相自性坏。次未曾行相自性起名为生。起已未坏名为住。顾念前灭行相自性彼起异。异名为老。是故生刹那后。即彼起行相自性坏名为灭。若观起自性行相。即彼自性生住老相无余自性。是故刹那后如是行相自性灭。如是诸生等行相如实观。此四有为相略说二种。有性及无性。如来以起故立一有为相。以自性故立第二有为相。诸行住老故立第三有为相。彼菩萨观有为行分齐。非生非住非老非坏。一切时别有事起。何以故。诸行分齐起时。更无别生别住别老别坏。诸行分齐住老坏时。亦无别生别住别老别坏(一念顷名为一刹那)。菩萨如实观者。不别有生等事可得。若可得者。离色等诸行应别有生。如色等行自性起。彼亦应起。若然者。应有二生行生及生生。若有行生及生生者。或一或异。若一而谓别有生者。彼空无义。若别有生者。此事不然。若异者。彼行生非相生所为。行生相生所为者。此事不然。如生住老亦如是。若坏有法自性者。彼应生灭。若坏生时。一切行应即灭。如入灭尽正受。以少方便心心数法灭。若坏灭时。彼一切行应生。以坏无有故。言坏有生灭者此事不然。彼善男子善女人。一切时常有自性者。不应有厌离。离欲解脱异者应尔。以此事故。菩萨于一切诸行无常如实知。复次菩萨于一切诸行无常相续转时。观三苦相。行苦变易苦苦苦。如是菩萨于一切行苦如实知

复次菩萨。于一切法有为无为无我我所如实知。众生无我及法无我。彼众生无我者。有法非众生。离有法亦非众生。法无我者。一切言说事亦无言说自性法。如是菩萨于一切法无我如实知

复次一切行起因断无余。诸余毕竟灭名般涅槃。烦恼寂灭众苦永息。未入净心地菩萨。未见谛声闻。于涅槃作意解想。说言寂灭涅槃。当知是等不得真实涅槃知见。唯有正思惟。譬如国王长者巨富无量。为诸子故造作戏具。鹿车牛车马车象车。彼诸子等欢喜爱乐。作真鹿马象车等想。其父知子渐已长大。为说真实牛鹿象马。诸子谓父叹已象马。父于后时知子转大。将出宅外示真象马。彼见实已乃知其真。定知其父常所叹说非是我等先所玩好。先所玩好非真象马。如是诸行以为屋宅。未住净心地菩萨。未见谛声闻。如彼童子。诸佛如来及入大地菩萨明见涅槃。为彼菩萨及诸声闻叹说涅槃。彼既闻已随说意解。若彼渐学道品具足。入净心地。及见谛声闻。彼于涅槃生现知见。如是诸佛菩萨所叹说者。非如我等愚痴智慧意想所解。我等所想相似非实。于彼所解生惭愧心。依后知见。譬如病人遇得良医。为治病故说随病药。彼诸病者常习此药。便作信解。乐着此药缘是病差。更起余病应服余药。良医教彼弃舍前药。更服余药。彼诸病者信前药故。不肯弃舍。良医方便令服后药。如是菩萨住净心地。见谛声闻。诸烦恼病。诸佛如来住大地菩萨。为彼说法。上法上上法。深法上深法。上上深法。胜法上胜法。上上胜法。教授教诫。入净心地菩萨。见谛声闻。闻佛所说信受不疑。乘如来所说具足法乘。善能调御游平等道。疾疾正向无余涅槃

    菩萨地持方便处菩萨功德品第十八

菩萨学阿耨多罗三藐三菩提。有五奇特未曾有法。云何为五。一者于诸众生无有因缘而起爱念。二者为诸众生受无量苦。三者烦恼炽盛难化众生方便调伏。四者入第一难解真实之义。五者入不可思议神通之力。如是奇特未曾有法。不与一切诸众生共

菩萨有五事非奇特。能成奇特未曾有法。一者为安众生故受于苦因。受苦因故得受安乐。二者知生死过恶涅槃功德。有净众生念不自受乐。为净众生故受诸生死。三者修静默乐。有净众生念不自受乐。为净众生故演说正法。四者修六波罗蜜善根。有净众生念不自受乐。为净众生故不舍一切众生。亦不舍果报。五者他事己事如是一切利益众生。菩萨有五事。于一切众生其心平等。一者初发心愿。为一切众生其心平等。二者修习大悲心。与哀愍俱其心平等。三者于一切众生作一子想。与爱念俱其心平等。四者观一切众生诸行缘起。一众生法即是一切诸众生法。随顺一切众生其心平等。五者如为一众生行。如是一切众生。利益心俱其心平等。菩萨有五事饶益一切众生。一者说正命饶益。二者不随顺者说随顺法饶益。三者孤独辛苦贫乞无依者为作依怙饶益。四者向善趣者说道饶益。五者为三乘人说三乘饶益。菩萨有五事报众生恩。一者自成功德。二者劝他令成。三者孤独辛苦贫乞无依为作依怙。四者供养如来。五者佛所说法。若读诵若书持若供养。菩萨行菩提道常求五事。一者常愿诸佛出兴于世。二者于诸佛所听六波罗蜜及菩萨藏。三者堪能一切种成熟众生。四者堪能无上成熟众生。五者得阿耨多罗三藐三菩提。阿惟三菩提。声闻菩提。和合声闻

菩萨有五事利益众生真实方便。是菩萨先欲安乐众生。于彼安乐如实知不颠倒觉。如前供养习近无量品说。菩萨有五种方便摄一切正方便。一者随护方便。二者无罪方便。三者思惟力方便。四者净心方便。五者决定方便。随护方便有五种。一者黠护。得俱生智能疾受法。二者念护。念持于法。三者智护。得坚固智观察法义。以黠念智护离于退分。修胜进分。四者自心护。守护根门。五者他心护。随顺他心。无罪方便者。于诸善法不颠倒。炽然无量常修回向菩提。思惟力方便者。是解行地。净心方便者。是净心地具足行地。决定方便者。是决定地决定行地。究竟地。是名五种方便摄一切正方便。菩萨退分有五事。一者不恭敬法及说法者。二者放逸懈怠。三者习众烦恼及诸恶行。四者称量同己及余菩萨起增上慢。五者于法颠倒起增上慢

菩萨胜分有五事与上退分五事次第相违者。是名胜分

菩萨有五事菩萨似功德过。一者于诸凶恶及犯戒者。作非慈饶益。二者现谄曲威仪。三者说世俗诸外道经论。得生智慧能自思惟。四者行于有罪施等善根。五者演说建立似功德法。菩萨有五事菩萨真实功德。一者于诸凶恶及犯戒者起胜悲心。二者具足成就真实威仪。三者于如来说得生智慧能自思惟。四者行于无罪施等善根。五者演说正教。毁相似法。菩萨调伏众生有十种。名正调伏。云何为十。离诸缠离烦恼分恶戒

菩萨有六事。为如来授无上菩提记。一者种性未发心。二者已发心。三者现前。四者不现前。五者时量时定得无上菩提。六者时无量时不定受记。菩萨有三种决定。一者种性名为决定。何以故。堪能为缘。有障决定阿耨多罗三藐三菩提。二者决定发无上菩提心不能乃至不退乃至无上菩提。三者得力利益众生。如所欲如所作。如足不虚。彼最后决定故如来受决定记

菩萨不作五种力故不得阿耨多罗三藐三菩提。一者初发心。二者哀愍众生。三者炽然。四者精进。五者于一切明处方便不厌

菩萨有五事常所修集。一者常不放逸。二者孤独辛苦贫乞无依为作依怙。三者供养如来。四者持戒。有犯即觉。五者所作所行所可忆念。一切回向无上菩提

菩萨有十法菩萨等法第一最胜。一者菩萨种性胜余种性。二者初发心胜一切正愿。三者精进智慧胜余波罗蜜。四者软语胜余摄事。五者如来胜余众生六者大悲胜余无量。七者第四禅胜于余禅。八者空三昧胜余三昧。九者灭尽正受胜余正受。十者清净巧方便胜余巧方便。菩萨有四种正施设。如是正施设。是如来说。非余若天若人。沙门婆罗门如是闻。一者法施设。二者谛施设。三者方便施设。四者乘施设。法施设者。十二部经修多罗等。次第演说次第建立。谛施设者。有一种。谓如实义谛。复有二种。世谛。第一义谛。复有三种。相谛。说谛。作谛。复有四种。苦谛。集谛。灭谛。道谛。复有五种。因谛。果谛。智谛。智境界谛。无上谛。复有六种。实谛。虚妄谛。知谛。断谛。证谛。修谛。复有七种。味谛。患谛。离谛。法谛。解谛。圣谛。非圣谛。复有八种。行苦谛。苦苦谛。坏苦谛。生谛。灭谛。秽污谛。清净谛。正方便谛。复有九种。无常谛。苦谛。空谛。非我谛。有爱谛。无有爱谛。断方便谛。有余涅槃谛。无余涅槃谛。复有十种。自作苦谛。贫穷苦谛。四大增损苦谛。爱恋苦谛。污辱苦谛。业苦谛。烦恼谛。正思惟谛。正见谛。正见果谛。四种方便名方便施设。如前力种性品说。乘施设者。声闻乘。缘觉乘。大乘。一一乘七种施设。四圣谛慧。如是慧。若依若缘伴业众具。如是慧若果。此七种名声闻乘施设。如声闻乘施设。缘觉乘亦如是。离言说境界。一切法如离诸妄想。平等慧。如是慧。若依若缘伴业众具。如是慧若果。此七种名大乘施设。过去未来现在。一切菩萨正施设。已作当作。一切四种无余无上

菩萨有五种无量生一切巧便行。一者众生界无量。二者世界无量。三者法界无量。四者调伏界无量。五者调伏方便无量。六十一种众生名众生界。如意地身分别则有无量。十方无量世界无量。名如娑婆世界。名娑婆主。善不善无记法分别则有无量。调伏有一种。谓一切众生调伏。复有二种。具缚。不具缚。复有三种软中上根复有四种。刹利。婆罗门。毗舍。首陀复有五种。贪欲。嗔恚。愚痴。憍慢。觉观。复有六种。在家。出家。未熟。已熟。未解脱。已解脱。复有七种。恶人。中人。小智人。大智人。现在调伏。未来调伏。随缘调伏。若得缘如是。如是回向。复有八种。谓八众刹利。乃至婆罗门。复有九种。一者如来调伏。二者声闻缘觉调伏。三者菩萨调伏。四者难调伏。五者易调伏。六者软语调伏。七者呵责调伏。八者远调伏。九者近调伏。复有十种。一者地狱。二者畜生。三者饿鬼。四者欲界人天。五者中阴。六者色。七者无色。八者想。九者无想。十者非想非非想。是五十五种分别则为无量。众生界调伏界有何差别。众生界者。不分别一切众生种性处。调伏界者。彼种性处。如是彼彼处转调伏方便无量。如前成熟品说。彼亦无量种分别。如是次第说五种无量。何以故。是菩萨为众生修行。是故说初无量。众生彼处可得。是故说第二无量。众生于彼彼世界烦恼清净法可得。是故说第三无量。观彼彼众生随所堪能脱苦。是故说第四无量。乃至方便脱众生苦。是故说第五无量。是故说五种无量。生菩萨一切巧便行。菩萨有四求。于一切法如实知。一者名求。二者事求。三者自性施设求。四者差别施设求。如前真实品说。菩萨有四事。于一切法如实知。随名求如实知。随事求如实知。随自性施设求如实知。随差别施设求如实知。如前真实品说

诸佛菩萨有五事。为众生说法得大果福利。一者为众生说法生离垢法眼。二者为众生说法得诸漏尽。三者为众生说法发无上菩提心。四者为众生说法得第一菩萨忍。五者为众生说法。闻已受诵。具足修习令法久住。是名五种说法得大果福利

云何名大乘。有七种大故名为大乘。一者法大。谓十二部经。菩萨方广藏。最上最大。二者心大。谓发阿耨多罗三藐三菩提心。三者解大。谓解菩萨方广藏。四者净心大。谓过解行地入净心地。五者众具大。谓福德众具智慧众具得无上菩提。六者时大。谓三阿僧祇劫得无上菩提。七者得大。谓得无上菩提身无与等者。况复过上。彼法大心大解大净心大众具大时大。此六大谓因种得大谓果处。菩萨有八法摄一切摩诃衍菩萨藏所说。谓信菩萨藏。显示一切法真实义。显示一切诸佛菩萨不可思议第一胜妙神力。得闻慧思慧思惟。依闻慧思慧思惟。方便得净心。得净心。方便入修慧行。入修慧行。方便修慧果。成如是修慧果。成毕竟出离。菩萨如是学得无上菩提。菩萨如是学得无上菩提略说十种。一者种性。二者入。三者未净。四者净。五者未熟。六者熟。七者未定。八者定。九者一生。十者最后身。种性者。名未得净心。发心修学名为入。已入未入净心地名为未净。入净心地名为净。净者未入毕竟地名为未熟。入毕竟地名为熟。熟者未入定地名为未定。已入定地名为定。又熟有二种。一者一生。次第得无上菩提。二者最后身。即此生得。如是从种性乃至最后身得无上菩提。此十种菩萨所学而学。于上更无所学。菩萨如所学而学。于上更无菩萨学。菩萨如所学而学。得一切功德名。所谓菩萨摩诃萨。勇猛无上。佛子佛持。大师大圣。大商主大名称。大功德大自在。如是十方无量世界无量菩萨无量因缘。自想施设。当知若有言我是菩萨。不善学菩萨所学者。当知是名字菩萨非实菩萨。若言我是菩萨。善学菩萨所学者。当知是实菩萨

    菩萨地持次法方便处菩萨相品第一(第二段有四品)

菩萨成就五种真实相得入诸菩萨数。一者哀愍。二者爱语。三者勇猛。四者惠施。五者说深法义。此五相。各五种分别。一者自性。二者境界。三者果报。四者次第。五者摄受

哀愍自性有二种。一者至心。二者具足。至心者。安心乐心。具足者。菩萨至心于诸众生。随其所能随其力。身口饶益。爱语自性者。先语安慰。如前摄品说。勇猛自性者。于诸众生志强有力。惠施自性者。胜妙施无烦恼施。说深法义自性者。四无碍智。出生正方便智。哀愍境界有五种。一者受苦众生。二者恶行众生。三者放逸众生。四者邪趣众生。五者烦恼所使众生。从地狱乃至一切苦受相续。是名受苦。虽不受苦而多造作身口意恶行。所谓十二恶律仪。是名恶行。虽不受苦造诸恶行而乐着五欲歌舞戏笑。是名放逸。虽不受苦造诸恶行乐着五欲。而依邪见求苦解脱。是名邪趣。舍离五欲于法出家。不受诸苦乃至邪趣。而具烦恼或有不具。谓正方便。真实凡夫及诸学人。是名烦恼所使。菩萨于此境界哀愍心生无余无上

爱语境界有五种。一者正实语。二者正喜语。三者正饶益语。四者正如法语。五者方便说法语。如前摄品说。菩萨于此境界爱语心生无余无上。勇猛境界有五种。如前菩提分品说。菩萨于此境界勇猛心生无余无上

惠施境界有五种。一者不分别施。二者欢喜施。三者顿施。四者不染污施。五者无依施。如前施品说。菩萨于此境界惠施心生无余无上。说深法义境界有五种。一者于如来所说修多罗。甚深空相应缘起随顺。二者于诸戒律。善知犯不犯及与出犯。三者于摩德勒伽藏。不颠倒建立法相。四者于深法义以想分别。五者于一切法法义种种言辞种种分别。菩萨于此境界说深法义心生无余无上

菩萨哀愍于诸众生修习慈心。利益亲厚方便不厌。多住无罪现法乐摄取众生。如世尊说。慈心福利。身常不被刀杖等害。此中应广说。是名哀愍果

菩萨爱语。于现法中离口四过。两舌恶口妄言绮语。以此爱语自摄摄他。于未来世成就正语。言辄信用。是名爱语果

菩萨勇猛。于现法中离诸懈怠心常欢喜。受持菩萨律仪戒不毁不犯。以堪忍心摄受自他。于未来世菩萨所作悉能修学。学已坚固。是名勇猛界

菩萨惠施及说深法义果。如前力品檀波罗蜜般若波罗蜜说。是名惠施说深法义果。次第者。菩萨先修哀愍。摄取众生。为令众生出不善法安立善法。为具足说教授摄受。是故次说爱语。众生造恶种种烦恼堪能不息。是故次说勇猛。或有众生以财摄受。或有众生以法摄受。或俱摄受。是故次说惠施。说深法义

菩萨。有五种相摄六波罗蜜。此六波罗蜜何相所摄。哀愍相摄禅波罗蜜。爱语相摄尸波罗蜜般若波罗蜜。勇猛相摄羼提波罗蜜毗离耶波罗蜜般若波罗蜜。惠施相摄檀波罗蜜。说深法义相摄禅波罗蜜般若波罗蜜。是名菩萨五种相五种分别

    菩萨地持次法方便处翼品第二

在家出家菩萨翼有四法。菩萨修学疾得阿耨多罗三藐三菩提。一者善修业。二者巧便。三者摄取众生。四者回向。云何善修业。菩萨于六波罗蜜。决定修。专心修。常修。无罪修。云何决定修。檀波罗蜜。是菩萨于来求者。饶益不饶益。有德有过。要当施与。于诸惠施心不倾动。若人非人。沙门婆罗门。世间同法。所不能坏。云何专心修。是菩萨于求来者。舍内外物一切施与无有吝惜。云何常修。是菩萨施无厌惓。一切时平等随得随施。云何无罪修。如施品说。离烦恼施。是名菩萨善修檀波罗蜜。如施如是戒忍精进禅定智慧亦如是。随其所应当知。云何巧便。略说有十种。坏法众生为除恼害。方便巧便。中住者令入。已入者令熟。已熟者令解脱。方便巧便。世论巧便。菩萨戒律若持若毁观察巧便。正愿巧便。声闻乘巧便。缘觉乘巧便。大乘巧便。如是一切巧便。随所应彼彼菩萨地。分别当知。此十巧便为五种事。初四巧便。为利众生。世论巧便。为伏异论。菩萨戒律若持若毁观察巧便。为不起犯戒。已犯者令如法悔。受持清净律仪。正愿巧便。菩萨于未来世一切所欲悉皆得之。三乘巧便。菩萨随种性根解譬喻。随顺说法具足说法。如是十种巧便为五种事。此五种事。一切所作皆悉具足。现法后世利益方便。云何菩萨摄取众生。是菩萨依四摄法。布施爱语利益同事。或有众生。以安饶益。以乐饶益。以安乐饶益。广说如前自他利品。云何菩萨回向。菩萨三门修习善根。谓善修业巧便。摄取众生。彼一切过去未来现在淳净心。回向阿耨多罗三藐三菩提。不以善根求余果报

若世尊说。在家出家菩萨所学法。当知一切皆是善修业巧便。摄取回向四法所摄。菩萨善修业巧便。摄取集聚回向。当知近菩提座。过去未来现在。一切菩萨在家出家。学阿耨多罗三藐三菩提。已学当学今学。如是四法。无余无上

如是四法。在家出家菩萨成就。然彼出家于在家者大有差别。出家菩萨。解脱摄受。父母妻子眷属等过。出家菩萨。解脱摄受。田种治生王家等苦。出家菩萨。具修梵行一切菩提分法。疾得神通若修善法疾得究竟。出家菩萨凡所说法。人所信受。是名在家出家之大差别

菩萨地持经卷第八菩萨地持经卷第九

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持次法方便处净心品第三

菩萨于诸众生有七种怜愍。名第一真实。一者无畏。二者巧便。三者不厌。四者不求。五者不贪。六者广大。七者平等。菩萨不以畏故。于诸众生起怜愍心。修身口意业安乐众生。是名无畏。菩萨以巧便慧。于诸众生起怜愍心。非法非律非真谛不教非处。是名巧便。菩萨于诸众生。一切方便而不疲厌是名不厌。菩萨于诸众生起怜愍心。无所怖求是名不求。菩萨于诸众生起怜愍心。不求恩报是名不贪。菩萨于诸众生起怜愍心不限众生。于众生所得饶益不饶益悉不弃舍。是名广大。菩萨于诸众生起怜愍心。等众生界无有方限是名平等。菩萨成就如是七种怜愍。是名第一真实。菩萨于佛法僧。方便观察得决定解。是名净心。略说有十五种。一者无上心。二者戒心。三者波罗蜜心。四者真实义心。五者神力心。六者安心。七者乐心。八者解脱心。九者坚固心。十者不虚心。十一者不净心。十二者净心。十三者快净心。十四者调伏心。十五者俱生心。专乐佛法僧宝净心。是名无上。受菩萨戒律净心。是名为戒。行施忍精进禅定智慧净心。是名波罗蜜。人无我法无我人法无我第一义法甚深净心。是名真实义。诸佛菩萨不思议神通力俱生力净心。是名神方。于诸众生欲以善法饶益。是名为安。于诸众生欲以摄取饶益。是名为乐。于诸众生离于贪心及与受报。是名解脱。于无上菩提其心坚固。是名坚固。利众生方便开觉方便不颠倒智俱解脱。是名不虚。解行地菩萨心。是名不净。净心地乃至决定行地菩萨心。是名为净。究竟地菩萨心。是名快净。彼不净心是名调伏。净心快净心思惟。是名俱生。性自真实身心清净故名俱生。是名十五净心。此十五净心。随一切地略说作十事。无上心。净修三宝惠一切种行。修一切菩提具第一真实。戒心。受菩萨戒律乃至舍命终不毁犯。若有所犯即能除灭。波罗蜜心。诸善根法常勤修习不放逸住。真实义心。以不染心为众生故。受于生死不舍涅槃解脱净心。神力心。淳厚净信开觉。及修生死想念。多住闻思知量知足。安心乐心解脱心。一切种利益众生而不疲厌。坚固心。炽然精进广大精进。平等方便不缓方便不断方便。不虚心。疾得神通彼彼善法不以少心下心而生足想。调伏心生俱生心。俱生心疾得阿耨多罗三藐三菩提。利益安乐诸天世人。调伏心摄不净心。俱生心摄净心快净心。若世尊说菩萨净心。施设显示一切。皆是十五净心所摄。过去未来现在菩萨。得无上菩提已得当得今得。一切皆是十五净心无余无上。如是十五净心有大果福利。依是得无上菩提

    菩萨地持次法方便处住品第四

已说菩萨种性乃至菩萨所学。而学菩萨相菩萨翼菩萨净心今当略说。菩萨十二住摄一切住一切菩萨行。第十三如来住无上住。云何菩萨十二住。一者种性住。二者解行住。三者欢喜住。四者增上戒住。五者增上意住。六者增上慧住。增上慧住有三种。一者菩提分法相应。二者谛相应。三者缘起生灭相应。菩萨真实观真实智。谓知众生生苦灭苦。是故菩萨于三门三种慧三种住。九者有行有开发无相住。十者无行无开发无相住。十一者无碍住。十二者最上菩萨住。如是十二住摄一切住一切菩萨行。如来住者。过一切菩萨住。阿惟三佛住如来住。后安立品广说。十二住菩萨所建立今当说。云何种性住。是菩萨性自贤善。性自能行功德善法。性贤善故率意方便。诸善法生不待思惟。然后能得种性菩萨。是一切佛法种子。一切佛法种子在于身中离粗烦恼。种性住菩萨虽起上烦恼缠。终不能行五无间业。及断善根种性义如种性品说。是名种性住

云何解行住。是菩萨初发心未得净心地。未得净心地菩萨所有诸行。是名解行住。种性住菩萨于余菩萨住及如来住。生因摄因非方便。亦非得亦非清净。何况如来住。解行住菩萨于余菩萨住及如来住。是方便而非得亦非清净。唯得解行及清净向。解行住菩萨净修欢喜住。得前方便及清净向。欢喜住菩萨净修增上戒住。得前方便及清净向。如是广说乃至最上菩萨住当如是知。最上菩萨住次第净修如来住前方便如来住。顿得及清净。是为菩萨住如来住差别。云何欢喜住。菩萨净心住是名欢喜住。云何增上戒住。菩萨因净心性戒具足住。云何增上意住。菩萨因增上戒净世俗禅三昧正受住。云何菩提分法相应慧住。菩萨因世俗净智真实三昧真谛觉。正念处等三十七菩提分法观察住。云何谛相应慧住。菩萨因菩提分法。观察真谛慧住云何缘起生灭相应慧住。菩萨真谛觉为增上已。有因缘苦生有因缘苦灭观察性住。云何有行有开发无相住。菩萨三种增上慧为增上已。有行有开发不断无间一切法如。离诸妄想修慧俱住。云何无行无开发无相住。即此无相住多修淳至不断无间增长道随顺住。云何无碍住。菩萨依快净不动智慧三昧。于佛所说无上方广章句义辞分别观察住。云何最上菩萨住。菩萨住究竟菩萨道。得阿耨多罗三藐三菩提。大法灌顶一生相续。若最后身于此住次第。得无上菩提作一切佛事住

解行住菩萨。修少行断行不定行所得有退转。欢喜住乃至三种慧住菩萨修广行不断行决定行所得不退转。有行有开发无相住。乃至最上菩萨住菩萨。修无量行不断行决定行所得不退转

解行住菩萨无相修方便。欢喜住乃至增上慧住菩萨。得无相修。第一无相住第二无相住菩萨。无相修净。无碍住最上菩萨住菩萨。无相修果

解行住菩萨行解行时有何行相。解行住菩萨行解行时。以思惟力菩萨所作方便思惟修习。不能性自真实坚固不退。不得菩萨不退转修如修。如是修果种种无碍神通解脱三昧正受悉皆不得。亦未离五恐畏。所谓不活畏。恶名畏。死畏。恶道畏。大众畏。思惟修习利益众生。不能自性哀愍。或时起邪身口意业。有时贪着五欲境界。有时悭惜所有众具。由佛菩萨生于净信。不能自起真实智慧。所谓三宝功德真实义。诸佛菩萨神通力。若因若果若得义若得方便若境界。少闻少思智慧成就不能无量。或时忘失成就菩萨迟苦之道。不能专精行大菩提。炽然方便深乐净信。于可喜不可喜色声香味触法。或颠倒受生二身中间。或时受诵持法久作久修。于此三事忘失正念。或时黠慧受持正法善解其义。或时不解或不善知随顺调伏。或复不知自生佛法。率意说法教授教诫。以率意故不如实知。或时虚说如闇中射或中不中。或时退舍大菩提心。或时受菩萨戒还复毁犯。或时能作利益众生方便。或时厌惓。是故于方便退乐于自乐。或时思惟知乐众生。缺减而不能断。或有除断而数数缺减。或时能说菩萨法藏。或时闻说深妙之法。而生恐怖动摇疑问。于一切众生远离大悲。少能安乐不能广大。不能如上所说学菩萨所学。满足菩萨相菩萨翼菩萨净心。去阿耨多罗三藐三菩提远。不能净心深乐涅槃。舍离生死不动善根。菩提分法悉不成就。如是等是名解行住菩萨行相。解行住菩萨行下忍时。如上所说行相增。行中忍时中。行上忍时下。如是行上忍时断此行相。次第入欢喜住。方便得欢喜住。彼一切法悉无复有住。解行住所说相违一切不染污分法成就名净心住。解行住菩萨有软中上方便。展转净解脱非无罪清净。何以故彼解脱有种种烦恼上缠生故。欢喜住菩萨解脱烦恼上缠。断离烦恼清净解脱生

云何欢喜住菩萨行相。是菩萨于解行住入欢喜住。先善入无上菩提。愿善入菩提方便修习决定。决定有六种一者。能自修习起菩提愿。超余一切净愿。二者无等不共果。超余一切世间境界。三者随度诸众生苦。不共一切声闻缘觉。四者发一念愿性自然乐无量净法及无厌行。五者得无尽愿常不退转。六者增长胜分究竟大菩提。是名真愿。真愿菩萨有四事。一者何等人发心。二者缘何发心。三者发心有何相。四者发心有何福利。解行住菩萨修习一切种善根。出生菩提正行而发心。是名略说人发心。于未来世疾满足一切种菩提具。满足菩萨利益众生事。满足无上菩提一切行。满足一切佛事而发心。是名略说缘发心。菩萨发心疾满足一切种菩提具。菩萨利益众生事。无上菩提一切行。一切佛事。过凡夫地入菩萨位生如来家。名为佛子。决定究竟无上菩提。得不坏净生欢喜心。离非律仪贪恚等心。一切种利益众生一切种菩提具。佛法佛事神力满足。净心攀缘意解次第。自见彼法疾行随顺。生欢喜心持诸善根。出家饶益平等离欲。身心摄受欢喜炽然。善法成就近无上菩提清净净心。于大菩提生欢喜心。菩萨决定心。生离五恐畏。修无我智我想不生。云何当有我爱众具爱。是故离不活畏。不于他人有所求欲。常欲饶益一切众生。是故离恶名畏。离于我见我想不生。是故离死畏。此身命终于未来世。必与诸佛菩萨共会。是故离恶道畏。观于世间无与等者。况复过上。是故离大众畏。如是离五恐畏已。亦得远离闻深法畏。憍慢贡高他不饶益。恚恨贪喜皆悉远离不染污不杂行一切善法一切种精进。方便净信现在修行。于未来事生十大愿。十大愿如前菩提分品说。此欢喜住净修生。一者以清净心常愿供养一切诸佛。二者受持守护诸佛正法。三者劝请诸佛转未曾有法。四者顺行菩萨正行。五者一切器具足成熟。六者一切世界悉能现生。七者自净佛土。八者一切菩萨同一方便以大乘化。九者利益众生一切不空。十者一切世界得阿耨多罗三藐三菩提。作一切佛事。如是大愿能生无量百千大愿。不离众生界不离顺世间。此诸大愿生生常行终不忘失。现法方便精进修净。住十法欢喜住净修生。一者一切佛法不坏信。二者方便观缘起苦阴众生生大悲心。三者观苦众生令得解脱生大慈心。四者以大慈悲。欲度一切受苦众生。自舍己身不舍众生。舍内外物而行布施。五者为度众生故。勤求世间出世间法心不厌惓。六者心不厌惓故知一切论。七者知一切论故。知软中上众生随其所应知世间。八者随所应已。知时知量生惭愧心。九者如是方便得勇健力。十者得世财利供养如来。如是十法净欢喜住。所谓信悲慈施不厌。知论知世间惭愧勇健。供养如来。菩萨修此十法。于余九住增上戒住等。观察一切种道功德过恶。求佛菩萨所有神通乐不坏道。善摄行得依过一切住。得大菩提为大导师。度脱生死旷野众生。教令入行。入行已得。得已果福利成。名为依住。此住者有二因缘。见无量佛闻菩萨藏说。则能解知。知十方无量世界种种佛名。名粗净信见。乃至得真实见是名一因缘。复作是愿。彼佛出世我当生彼随愿往生。如是粗净信见以愿力故。见诸如来一切种供养。乐具饶益随其所能。随其力供养法僧。于如来所听受正法。闻已受持法次法向。以四摄事成熟众生。一切善根回向菩提。以三种清净故。彼诸善根转复清净。如来法僧供养摄受。以四摄事成熟众生。一切善根回向菩提。无量亿百千劫净于身心。譬如真金如是如是着于火中。工师炼治转增明净。菩萨善根转增清净亦复如是。若更受生为转轮王。王阎浮提随意自在。远离悭贪亦化众生离于悭垢。以四摄事摄取众生普令众生得第一义。若欲精进舍家财物。于佛正法出家学道。于一念顷能具菩萨百三昧。能以三昧见百佛世界。以神通智力能动百佛世界。身亦能过光明。普遍能化一身为百。成熟众生能住寿百劫。能知过去百劫事。能知阴界入各百法门。化百菩萨以为眷属。若以愿力神力所作。则有无量亿百千劫不可数知。是名略说欢喜住。所谓决定四事大愿出生。方便精进出生。修净住法彼彼住净修。见佛善根受生神力。广说如修多罗十地欢喜地说。修多罗说十地。即此菩萨藏。摩得勒伽说十住。摄受众生故说地。自受行住故说住。云何增上戒住菩萨行相。是菩萨于欢喜住得十种净心。一者一切种供养尊重福田先语问讯心。二者同法菩萨亲近乐住心。三者胜一切烦恼诸缠魔业心。四者见一切行过恶心。五者见涅槃福利心。六者常修菩提分法善根心。七者随顺修菩提空闲净处心。八者不念世间贪爱贡高利养心。九者离声闻乘向大乘心。十者一切种利益众生心。如是十种心生名得净心。如是净心满足。次第入增上戒住。入增上戒住已。性戒具足转邪业迹。所摄恶戒一切不行。况复中上。如是性戒具足染污不染污业。善趣恶趣业迹。因处果处如实知。报果依果及彼业如实知。自断十恶行十善业。复以此法教授众生。毒业过患恶众生界等无差别。善业恶业第一义苦种种众难。得广大哀愍。见佛善根清净如前说。譬如真金得加私药。着于火中转增明净。菩萨善根清净亦复如是。此住清净心成就受生。作转轮王王四天下。以自在力令诸众生离诸恶戒行善业迹。神力十事如修多罗说。是名略说增上戒住。所谓净心性戒具足。离一切恶戒离一切业迹。一切因果如实知。分别四种业教授众生。众生界善恶业生苦众难。得广大哀愍见佛善根清净受生神力。广说如修多罗十地离垢地说。离恶戒垢故名离垢。彼离垢地即是增上戒住。云何增上意住菩萨行相。是菩萨于增上戒住得十种思惟。十种思惟满具足已。过增上戒住入增上意住。一者净十种净心。二者离十种不净心。三者一切有漏法能生厌离。四者知修对治法。五者修对治法不退转。六者坚固对治胜一切有漏一切魔业。七者于诸佛法无有退弱。八者于诸苦行不以为难。九者信解大乘不乐小乘。十者一切种利益众生。增上意住菩萨。观一切行无量过恶生。于厌离观佛智慧功德福利。生于正念淳净信心。观众生界种种苦行。悲念众生而依于义。于有为行不为放逸。于大菩提炽然精进。于诸众生生大悲心。令诸众生究竟脱苦。观察一切烦恼障碍解脱正智。观察法界一切妄想。烦恼所起对治智慧。成就智慧三昧等观。闻菩萨藏以为方便。因闻方便勤修精进。闻正法故不惜身命。无内外物而不布施。无有尊重而不恭敬。无有正教而不奉行。无有身苦而不求法。以爱念心闻一四句偈。胜于爱念三千大千世界大珍宝聚。若闻一偈正向佛道。净修菩萨行。胜得一切转轮圣王护世帝释魔梵诸王。若有人言我有此法正向佛道净修菩萨行。若能投大火坑受大苦者。当为汝说。菩萨闻已欢喜乐受作是念。若闻正法正向佛道净修菩萨行。正使三千大千世界大火炽然。乃至梵天尚入其中。况复小火。经地狱苦尚求佛法。况复小苦。如是精进方便思惟。求法如法次法向随顺佛法。不以文字音声清净。作是念已。因闻正缘法相。离欲恶不善法。得世俗四禅四无色四无量五神通舍诸禅三昧正受。以愿力故来生欲界。观彼众生能满菩提分法者。而生彼处。离欲故欲缚断舍。诸禅正受故有缚断解行住先如是法如解脱见缚断耶。贪恚痴毕竟不行。见佛善根清净如前说。譬如真金数被炼治离垢明净。菩萨善根转增清净亦复如是。若更受生得帝释身。以离欲善法调伏众生。神力胜前诸住百千万倍。是名略说增上意住。所谓十种思惟成就。入一切行众生界大菩提正分别真实苦。解脱方便正求大恭敬求法法次法向。巧便出生诸禅三昧。正受神通舍于诸禅。以愿力故随所欲生。见佛善根清净受生神力。广说如修多罗十地明地说。闻行法。行法明照。三昧明照故名明地。内心清净故名增上意住。彼明地即此增上意住

云何菩萨菩提分法相应增上慧住。是菩萨于增上意住。得十法明增上满足已。入初增上慧住。十法明如修多罗说。谓平等第一义。若烦恼恼若清净净烦恼系恼无上清净净。是名略说法明义。住此住者十智成熟不坏净为首。如修多罗说。十智成熟生如来家。逮得自在十智观察。为增上已修念处等三十七菩提分法。如修多罗说。修集彼法故身见等离阴界入。微细爱着毕竟不生。如来不称叹业一切不行。所称叹者一切随顺。如如真实心转柔和。修种种行其心快净。知恩报恩随顺功德。种种净法皆悉成就。修上地业得大精进。因彼精进净心深心信解满足。因彼正法外道魔怨不能倾动。见佛善根清净如前说。譬如真金为庄严具余金不及。菩萨善根亦复如是。胜余下地菩萨功德。如育多摩尼光明清净余珠不及。一切风雨所不能灭。如是菩萨下地菩萨声闻缘觉智慧光明所不能及魔怨烦恼皆不能坏。若更受生作焰摩天王。以诸善法教化众生。破身见等神通力。胜于前住百千万倍。是名略说菩提分法增上慧住。所谓十法明成就。入十种成熟修菩提分法身见等。一切着断制业听业。若离若修因彼心转柔和。随顺功德皆悉成就。修上地业得大精进。因彼精进净心深心信解清净。因彼正法魔怨不动。见佛善根清净受生神力。广说如修多罗十地焰地说。彼地菩提分法智焰种。正说法智明照世间。是故彼地名为焰。彼焰地即此菩提分法相应增上慧住

云何菩萨谛相应增上慧住。是菩萨于初增上慧住。得十平等净心。增上满足已。入第二增上慧住。十平等净心。如修多罗说。谓无等等觉。超余众生于法如等。是名略说平等净心义。住此住者智慧增进。于四圣谛有十种如实知。如修多罗说。若缘他若自知若俱知如修多罗毗尼摩得勒伽说。现在苦苦因苦因灭苦因灭方便道。是名略说十种四圣谛。知是谛方便。破坏一切有为行。于诸众生大悲增长。前际后际于四真谛。愚惑邪向令入解脱功德智慧众具。成熟修行正愿正念。正智正说等种种真实功德。增长无余思惟一切种。成熟方便成熟众生。摄众生故修世俗书论。如修多罗说。以工巧业一切。出生悲心诱进安立菩提。随顺世间方便惠施。四大错乱非人所持令得休息。无罪戏乐众具饶益。因此饶益引令乐法。以住止众具而为饶益。王贼所恼度令安隐。处非处方便若听若制吉非吉事惠施成就。现法展转清净饶益。诸颠倒者为说正道。是名摄受众生世俗工巧平等义。见佛善根清净如前说。譬如真金众宝厕填。光明清净胜于余金。如是菩萨智慧方便。胜余菩萨声闻缘觉。譬如日月宫殿一切风轮不能令失。如是菩萨智慧。方便。不为世法之所毁坏。若更受生为兜率天王。以诸善法破坏一切外道邪法神通力。胜于前住亿百千倍。是名略说谛相应增上慧住。所谓平等净心成就。入谛观增长破坏诸行。于诸众生大悲增长。功德智慧众具成熟。正愿正念正智正说等。功德增长无余。思惟一切种成熟方便。成就众生工巧出生。见佛善根清净受生神力。广说如修多罗十地难胜地说。决定智慧难胜。是故彼地名为难胜。彼难胜地即此谛相应增上慧住

云何菩萨缘起相应增上慧住。是菩萨于谛相应增上慧住。得十平等法。增上满足已。入第六住。一者一切法第一义自性平等。二者无言说行无相平等。三者无生平等。四者因缘不起平等。五者毕竟寂灭平等。六者离诸虚伪平等。七者一切行无取无舍平等。八者一切法离平等。九者妄想境界如幻如化平等。十者妄想境界有无无二平等。是名略说十平等法。住此住者于诸众生。大悲增长专乐菩提。知诸世间合散生灭。缘起正行了知依缘出生智慧。及三解脱门空无相无愿。依三三昧离我我所。知者作者有性无性相。如是第一义方便。思惟众生烦恼结缚。因缘和合有为危脆。着我我所生诸过恶。离烦恼结缚因缘。和合自护故。不灭一切有为。摄众生故。如是智慧慈悲随顺。住无障碍解脱般若波罗蜜。住无碍智解脱已。于一切世间行无碍。如是住者名第七地菩萨。方便行忍随顺忍所摄。住无障碍解脱般若波罗蜜。修菩提因缘不退转。世俗有为一切不住。亦不住彼休息寂灭。如是方便智慧随顺入空三昧门。百万空三昧门现在前。如空三昧。无相无愿三昧门亦如是。此诸三昧门现前已得不坏心。一切种佛法殊胜。外道魔怨所不能坏。余如前说。譬如真金众宝厕填胜于余金。如是菩萨善根清净。胜于一切。譬如月光除众生恼。一切风轮不能障蔽。菩萨智慧光明。为诸众生息烦恼火。一切魔怨不能断绝。若更受生为善化自在天王。常以善法灭除众生一切憍慢神通力。胜前亿百千倍。是名略说缘起相应增上慧住。所谓平等法成就。入觉诸缘起生解脱门。离诸邪想方便摄受。住无障碍解脱般若波罗蜜。得无量三昧得不坏心。佛法殊胜。见佛善根清净受生神力。广说如修多罗十地现前地说。无碍智现前。是故彼地名为现前。即此地名为缘起相应增上慧住

云何菩萨有行有开发无相住。是菩萨于缘起相应增上慧住。具足十方便慧。次第出生世间共不共胜进道。增上满足已。入第七住。十方便慧如修多罗说。谓出生世间善法。摄受福德安乐众生。福德众具菩提分法悉得增长。不共一切声闻缘觉。知众生界法界世界如来身口意。是名略说方便慧出生道。如是功德次第胜进。入无量无数如来境界所起处无开发无相想。见无量佛境界所起处。无间无断修习一切威仪。行住思惟不离一切处道。于念念中具足十波罗蜜及一切菩提分法。非如余住。第一欢喜住修习正愿。第二住离恶戒垢。第三住愿转增长得法光明。第四住入道。第五住入世间所作。第六住入甚深法门。此第七住起一切佛法满足助菩提法。是菩萨方便行满摄受住智神通清净行。菩萨于此住。次第入清净第八住。住第八住者一向清净。第七住杂净方便。入不染污名不染污行。此第七住贪等烦恼断故。不名有烦恼。不得佛智慧。如实心清净故。不名离烦恼。此第七住成就无量身口意业。如佛所叹业。如前说五住所得。世间工业智自然满足。为三千大千世界大师。唯除上地菩萨及如来。余无及者。一切禅定菩提分法。皆现前修而不受报

菩萨于此住。思惟方便入善伏三昧。生百万三昧。超过一切声闻缘觉三昧境界。远离烦恼诸妄想行。随顺甚深身口意业。不舍方便胜进之道。顾念众生满足菩提。离一切相无量身口意业。生净修无生法忍。于此住超过自觉境界。余六住佛法攀缘。第六住菩萨能入寂灭。今住此地念念寂灭。而不证寂灭。得未曾有身口意业不思议实际。而不证实际。如是方便智生。为增上已。行共一切众生行。照明世间余如修多罗说。取要言之。为功德事亲属想摄受。修习胜进住三解脱。求下乘者方便调伏。受五欲者求殊胜欲。转诸邪见随顺正念。于诸大会皆悉随顺。余如前说。譬如真金一切摩尼众宝厕填。胜阎浮檀金。菩萨善根清净。胜于一切声闻缘觉及余离垢菩萨。譬如日光照阎浮提。一切湿秽皆令干消。胜于余光。是菩萨智慧光明。能令众生烦恼干消。胜于一切声闻缘觉及余菩萨智慧光明。若更受生。作他化自在天王。以智慧饶益一切神力。胜前亿百千倍。是名略说有行有开发无相住。所谓方便慧胜进道成就。入入如来境界所起处。无间方便。于念念中具菩提分法。染污不染污建立方便行。满足摄受净身口意业。一切世间工巧业满足。得无量三昧。不共一切声闻缘觉。念念寂灭行于一切共世间行。见佛善根清净受生神力。广说如修多罗十地远行地说。方便行满足。是故彼地名为远行。即此地名为有行有开发无相住。云何菩萨无行无开发无相住。是菩萨于初无相住。得十种入一切法第一义智。如修多罗说。谓三世法如所应。无生无起无相无成。第一义离言说。自性不知言说。行自性相生无智邪见计着知离言说事。初中后一切时。烦恼平等入离妄想平等。一切烦恼悉皆远离。是名略说入第一义智。此十种智增上满足已。入第八清净住。是名得快净第一无生法忍菩萨。复有四种求。求一切法四种如实知。知一切法。以求知故离一切妄想计着。现法一切烦恼不起。来世一切究竟不生妄想计着。四种求四种如实知。如前真实品说。从解行住。乃至有行有开发无相住。未得快净。于此住乃得快净。是故名第一无生法忍。得无生法忍已。得甚深行。离初无相住四种恼患。一者有行有开发。二者净地勤方便。三者一切众生利益堪能勤方便。四者微细想行。是故此住名为快净。于甚深法门法流水中。如来劝发出生无量门智慧神通诸业饶益。以劝发故。无量尊身智慧出生。得十自在。如修多罗说。得自在故欲久近住随意即能。诸禅解脱随意所欲资生众具。世工巧业悉得随意。一切生处一切受生随意往生。一切神力一切誓愿随意能得。变一切物成于金宝随意能成。欲知法界名身句身味身于一切法建立巧便即能知之。如是自在力果报福利。如修多罗说。于念念中。常等见佛。善根清净受生神力金光明喻。如修多罗说。是名略说无行无开发无相住。所谓第一义智成就。入得不起法忍恼乱悉离。得快净住甚深法门。诸佛劝发出生无量智慧神通诸业饶益。无量尊身智慧出生。得大势力得大自在力。福利果报善根清净受生神力。广说如修多罗十地不动地说。离有行有开发乘不动胜进道。是故彼地名为不动。即此地名为无行无开发无相住

云何菩萨无碍住。是菩萨乐深解脱上胜进智。知佛法藏菩萨一切种行。为人广说。于所说法所可为说悉如实知。所可说法烦恼清净。谁恼谁净悉如实知。如是善说法名大法师。得无量陀罗尼。善诸音声辩才无尽法陀罗尼。摄受堪能成就。乃至出生菩萨无碍智。坐于法座。所可说法众生乐受堪能成熟。如修多罗说。善根清净受生神力。如修多罗说。是名略说菩萨无碍住。所谓乐深解脱说法行智不思议大法师。善根清净受生神力。广说如修多罗十地善慧地说。安乐一切众生。净修菩萨无碍广说大法。是故彼地名为善慧。即此地名为无碍住

云何最上菩萨住。是菩萨于无碍住。净修一切种法王所应灌顶法。得离垢等无量三昧。作所应作。最后益一切智灌顶三昧现在前。得一切佛同坐身。莲华眷属光明普照。得一切种一切智灌顶。一切刚强悉调伏。得解脱方便佛所住智。无量解脱总持神通。得大念智言辞部分。及大神通善根清净受生神力。是名略说最上菩萨住。广说如修多罗十地法云地说。法云地菩萨满足菩萨道。满足菩提众具。得菩萨胜慧兴大法云。以正觉自觉雨诸众生。烦恼垢秽悉令休息。种种善根增长成熟。是故彼地名为法云。即此地名为最上菩萨住

如上说展转上功德前地所无。彼一一住。若中上根者。一一经亿百千大劫。多有成就软根者。不在数中。彼一切住。要经三阿僧祇大劫。初阿僧祇大劫解行住。过得欢喜住五行胜进第二阿僧祇大劫欢喜住。乃至有开发无相住。过得无开发无相住。此即决定净心菩萨决定胜进。第三阿僧祇大劫。无开发无相住。及无碍智住。过得最上菩萨住。劫有二种。一者日月昼夜时节岁数无量故名阿僧祇。二者大劫无量故名阿僧祇。彼岁数阿僧祇劫。是前阿僧祇菩萨所过。后三阿僧祇大劫无有过。若菩萨增上精进。能转中劫不能转大劫

如是十二住菩萨。三阿僧祇大劫。烦恼障分染污。智障分染污。断彼三住烦恼障分染污。断欢喜住恶趣烦恼分。断增上中烦恼分。一切不行。无开发无相住。无生法忍清净相续。烦恼染污分一切不行。最上菩萨住一切烦恼习使障断入如来住。智障染污分有三种。一者皮二者肤三者骨。欢喜住断皮障。无开发无相住断肤障。如来住断骨障。一切障清净。于此三住智障断。余住随其次第真实庄严。如是十三住。有十一种净。第一种性净。第二解行净。第三净心净。第四戒净。第五意净。第六第七第八正见净。第九方便行满足净。第十真实智神通出生净。第十一正义无尽说无碍净。第十二随顺一切种一切所知智净。第十三如来住一切烦恼障习使智障习使净。如前菩萨功德品说八法。摄一切摩诃衍菩萨藏所摄。此十三住摄第一第二住信心生解行住。于菩萨藏得闻慧思慧。第三住得净心及初修慧行。第四住乃至第九有行有开发无相住修惠广。第十第十一第十二住。净修慧行所摄修慧果。成如来住毕竟出离。声闻住法亦有十二。如菩萨次第当知。一者声闻自种性住。二者入正未越次取证方便住。三者越次取证住。四者得不坏净未圣戒转上漏尽住。五者依增上戒增上意学出生住。第六第七第八得真谛智增上慧学住。九者观察生死无相三昧方便住。十者究竟无相住。十一者解脱觉处住。十二者一切种阿罗汉住

菩萨地持经卷第九

    次法方便处净心品第三

菩萨有七种爱念众生。若成就此爱念者。名真实心第一真实心。一者无畏。二者巧便。三者不厌。四者不求。五者不贪。六者广大。七者平等。菩萨未曾恐畏故于诸众生起爱念心身口意业随顺行爱念安乐。是名无畏。菩萨未曾无巧便而行爱念。所谓非法非律非真谛。行教授非处。是名巧便。菩萨爱念为诸众生。一切所作而不疲厌。是名不厌。菩萨无请而爱念众生。是名无求。菩萨以无贪心而行爱念不求恩报及未来爱果。是名无贪爱念。菩萨于诸众生广大爱念不限众生。于众生所得饶益不饶益悉不弃舍。宁自苦身不苦众生。是名广大。又彼相成就爱念众生。是名平等。爱念不限众生界。是名平等爱念。菩萨成就如是七种爱念。是名真实心第一真实心。菩萨方便观佛法僧。若意解正向决定。是名极净心。又彼极净心略说有十五种。一者无上心。二者随转心。三者波罗蜜心。四者真实义心。五者神力心。六者安心。七者乐心。八者解脱心。九者坚固心。十者不虚伪心。十一者不净心。十二者净心。十三者快净心。十四者调伏心。十五者俱生心。菩萨于佛法僧宝极净心。是名无上心。受菩萨戒于受持律仪极净心。是名随转心。于行施忍精进禅定智慧极净心。是名波罗蜜心。人法无我第一义真实甚深极净心。是名真实义心。于诸佛菩萨不思议神通力俱生力极净心。是名神力心。于诸众生欲以善法饶益。是名安心。于诸众生欲以摄取饶益。是名乐心。于诸众生舍离贪心及与受报。是名解脱心。于无上菩提起一向心。是名坚固心。利众生方便。菩提方便。不颠倒智。俱生解脱。是名不虚伪心。一切解行地菩萨极净心。是名不净心。从净心地乃至决定行地菩萨极净心。是名净心。究竟地菩萨极净心。是名快净心。彼不净心。是名调伏心。思量计数。是名降伏心。净心快净心极净心。是名俱生心。性自清净于身安立。故名俱生心。是名十五极净心。是名十五真实净心。随一切地略说作十事。谓无上心。一切种供养三宝一切菩提。众具无上真实。随转心。受菩萨戒律仪。乃至舍命终不故犯。若有所犯即能除灭。波罗蜜心。勤修善根住不放逸真实义心。以不染污心为众生故。久住生死终不悕望涅槃。解脱神力心。显示正教令起净信及得修慧。多住生死想非少闻思知足。安心乐心。解脱心。一切种种利益众生。而不疲厌。坚固心。炽然精进。广大精进。平等方便。不缓方便。不断方便。不虚伪心。疾得神通。生彼彼善根。不以少心下心。胜劣善根而生足想。降伏心起俱生心。俱生心。疾得阿耨多罗三藐三菩提。利益安乐诸天世人。降伏心摄不净心。俱生心摄净心快净心。若世尊说菩萨净心。施设显示。一切皆是十五净心所摄。是故过去未来现在菩萨。得无上菩提。已得当得今得。一切皆是十五净心。无余无上。如是十五净心有大果福利。依是得无上菩提

    次法方便处住品第四

如是从种性起。如所说菩萨学菩萨相。现菩萨翼。方便成就。菩萨极悕望净。今当略说菩萨十二住。此菩萨住摄一切菩萨行。第十三是阿耨多罗三藐三菩提无上住。云何菩萨十二住。一者种性住。二者解行住。三者欢喜住。四者增上戒住。五者增上意住。六者菩提分法相应增上慧住。七者谛相应增上慧住。八者缘起生灭相应增上慧住。若菩萨真实观观真实。若不观真实则众苦增。若观真实则众苦灭。菩萨于三门行智慧为三增上慧住。九者有行有开发不断道向无相住。十者无行无开发道向无相住。十一者无碍住。十二者最上究竟住。如是十二住摄一切菩萨住一切菩萨行。如来住者。过一切菩萨住。阿惟三佛菩提住。彼最后如来住。建立品广说菩萨十二住。随其建立今当说。云何种性住。谓菩萨种性住者。菩萨功德菩萨所应善法。成就及行性贤善故。率意方便。诸善法生不待思惟率然自得。种性住为一切佛法种子。持一切佛法种子。悉在身中离粗烦恼。种性住菩萨。终不复起烦恼上缠行五无间业及断善根。种性义如前种性品广说。是名种性住。云何解行住。谓菩萨从初发心。不净心及净心菩萨所行。是名解行住。种性住菩萨。于余一切菩萨十一住及如来住。为因转为因摄受。于余菩萨非方便亦非得亦非净。彼何况如来住。解行住菩萨。于一切菩萨住及如来住。是方便而非得亦非清净。唯得解行住及清净向。解行住净已得欢喜住。前方便及即彼净向。欢喜住净已得增上戒住。前方便及即彼净向。如是广说。乃至最上菩萨住。当如是知。最上菩萨住净已次第得如来住。前方便顿得及净。是为菩萨住如来住差别。云何欢喜住。菩萨极净心住。是名欢喜住。云何增上戒住。菩萨因极净心性戒具足住。云何增上意住。菩萨因增上戒净。得世俗禅三昧正受住。云何菩提分法相应增上慧住。菩萨依世俗禅三摩提。净觉了真谛正念处等三十七菩提分法观察住。云何谛相应增上慧住。菩萨因依菩提分。观察如实觉了真谛住。云何缘起生灭相应增上慧住。菩萨以真谛觉为增上已。以智观察有因苦有因苦灭智住。云何有行有开发无相住。菩萨以三种增上慧。为增上已。有行有开发不断无间。一切法如离诸妄想。修慧俱住云何无行无开发无相住。即此无相住。多修淳至不断无间。升进道随顺住。云何无碍住菩萨即依彼快净。不动智慧三昧。得智慧增广为人说法。无上方便于法义辞。分别观住。云何最上菩萨住。菩萨住彼究竟菩萨道阿耨多罗三藐三菩提。大法灌顶。一生相续。若最后身。于此住。次第得无上菩提。作一切佛事。住解行住。菩萨于菩萨修少行断行不决定修行。所得有退转。欢喜住乃至三种增上慧住。于菩萨修广行不断行决定行。所得不退转。有行有开发无相住。乃至最上菩萨住。于菩萨修无量行不断行决定行。所得不退转。解行住菩萨。无相修方便。欢喜住乃至增上慧住菩萨行无相。修第一无相住。升进第二无相住。菩萨无相修净无碍住。最上菩萨住。菩萨无相修果。解行住菩萨。行解行时有何行何状貌何相。解行住菩萨。行解行时。以思惟力。菩萨所作方便。思惟慧修习。不能性自真实坚固不动不退。不得菩萨不退转修。如修如是修果。种种无碍。神通解脱。三昧正受。悉皆不得。亦未离五恐畏。所谓不活畏。恶名畏。死畏。恶道畏。大众畏。思惟修习。利益众生。不能性自哀愍。或时起邪身口意业。有时贪着五欲境界。有时悭惜所有众具。由佛菩萨生于净信。不能自起真实智慧。所谓三宝功德真实义。诸佛菩萨神通力。若因若果。若得义若得方便。若境界少闻少思。智慧成就。不能无量。或时失念成就菩萨迟喜之道。不能专心求大菩提。炽然精进深乐净信。或于三处忘失正念。所谓于可喜不可喜色声香味触法。或时颠倒受生。彼身中间或受诵持法。久作久说。以此因缘忘失正念。或时黠慧受持正法。善解其义。或时不尔。或不善知。随宜调伏方便。或复不知自生佛法方便率意说法。教授教诫。以率意故。不如实知。或时虚说。不时不中如暗中射。或中不中。或时退舍大菩提心。或时起菩提心而复退舍。或时受菩萨戒而复还舍。或时能作利益众生成就。而复厌倦。是故利益方便退。常乐自乐。思惟然后欲乐众生。自知缺减而不能断。令无有余更数缺减。或时于菩萨法藏信受他语。或时闻说深妙之法。而生恐怖动摇疑问。或时于一切众生远离大悲。少能安乐利益众生不能广大。不能如上所说学菩萨所学。不能满足菩萨相菩萨翼方便菩萨真净。去阿耨多罗三藐三菩提远。不能净心深乐涅槃舍离生死。不动善根菩提分法。悉不成就。如是等行相名解行住菩萨行相。解行住菩萨行下忍时。如上所说行相。增行中忍时中行上忍时下如是。行上忍时断此行相。次第入欢喜住。方便得欢喜住。彼一切法悉无复有住解行住所说相违。一切不染污分法成就名净心住。解行住菩萨。有软中上方便。展转净解脱。非无罪清净。何以故。彼解脱有种种上烦恼生故。欢喜菩萨。解脱上烦恼断离烦恼。清净解脱生。云何欢喜住菩萨行相。是菩萨于解行住当入欢喜住。是菩萨先善入无上菩提愿。善入菩提方便修习决定。若复缘他而进舍不决定。未习得六种善决定缘自力修慧菩萨愿生。一者超余一切净愿。无等不共。二者亦是世间亦出世间一切境界。三者随度诸众生苦。不共一切声闻缘觉。四者发一念愿。法性自然无量净果不动转。五者不变异无尽愿。终无能令退转变异。六者胜进分究竟大菩提愿。是名菩萨决定愿。又彼菩萨发心当知四种。初何等众生发心。缘何发心。发心有何相。发心有何福利。此四种发心当知彼解行住菩萨。一切种善修习善根。略说正菩提行出生而发心。是名略说众生发心。于未来世等速疾菩提众具满足。一切菩萨所作满足。无上菩提一切佛法满足。所作佛事满足。是名略说。缘发心正速疾一切种一切菩提众具。随顺菩萨于众生一切种菩萨所作随顺。无上菩提得自觉知随顺一切佛事。随顺而发心。彼发心过一切亿众菩萨及凡夫地入菩萨。超升离生。生如来家。为如来子。决定向无上菩提。决定绍如来种。得如来不坏净。常多欢喜心。不多嗔暴。一切种菩萨所作一切种菩提具。佛法佛事神力皆悉满足。净心攀缘意解。增进自见得法。生欢喜心。遵习善根到于出离远离贪着。无比无等摄养身心。欢喜炽然善法成就。近无上菩提。我于大菩提悕望清净。我已远离一切恐畏。作如是念生欢喜心。谓彼菩萨决定心生离五恐畏善根无我智。我想不生。云何当有我爱众具爱。是故离不活畏。不于他人有所求欲。常欲饶益一切众生。是故离恶名畏。离于我见我想不生。是故离死畏。此身命终于未来世。必与诸佛菩萨共会。是故离恶道畏。观于世间无与等者。况复过上。是故离大众畏。如是离五恐畏已。亦得远离闻深法畏。憍慢贡高他不饶益。恚恨贪喜皆悉远离。不染污故无垢。炽然精进故无凡悕望。于现法中一切种菩萨精进。方便修习上信前行。于未来事生十大愿。十大愿如前菩提分品说。于此欢喜住生。一者以清净心常愿供养一切诸佛。二者受持守护诸佛正法。三者劝请诸佛转未曾有法。四者顺行菩萨正行。五者为成熟众生器。六者游诸佛刹见诸如来亲近闻法。七者自净佛土。八者一切菩萨同一方便以大乘化。九者利益众生一切不空。十者一切世界得阿耨多罗三藐三菩提作一切佛事。如是大愿及余求亲众生界无有断绝。此诸大愿生生常行终不忘失。如是建立前愿在前后愿在后。是名为愿。菩萨如是大愿作门已能生无量百千诸愿。如是未来诸愿现法方便精进。十住净修法欢喜住净修生。一者一切佛法不坏信缘起方便。二者观纯苦众生是悲心。三者我当度众生苦阴是慈心。四者欲度一切苦不顾自身。不顾自身已舍内外物而行布施。五者为度众生故。勤求世间出世间法心不厌倦。六者心不厌倦故知一切论。七者知一切论故。知软中上众生随其所应。八者随所应已。知时知量生惭愧心。九者如是方便得勇健力。十者得世财利供养如来。如是十法净欢喜住。所谓信悲慈施不厌知论随众生惭愧勇健供养如来。菩萨修此十法。于余九住增上戒住等。观察一切种道功德过恶。求佛菩萨所有神通乐不坏道。善摄行得依相过一切住。得大菩提为大导师。度生死旷野教令入行。入行已得。得已果福利成。名为依住。此住者有二因缘。见无量佛闻菩萨藏说。则能解知十方无量世界名种种佛名。粗净信必俱见。乃至得真实见。是名一因缘。复作是愿。彼佛出世我当生彼。随愿往生。如是粗净信见及愿力故。见诸如来。一切种共养乐具饶益。随其所能随其力供养法僧。于如来所听受正法。闻已受持起法次法向。以四摄事成熟众生。以一切善根回向菩提。以三种清净故。彼诸善根转复清净。谓如来法僧供养摄受。以四摄事成熟众生。一切善根回向菩提。无量亿百千劫净于身心。譬如真金如是如是着于火中工师炼治转增明净。菩萨善根转增清净亦复如是。若更受生为转轮王王阎浮提。随意自在远离悭贪。亦化众生离于悭垢。以四摄事摄取众生。普令众生。得第一义若欲精进舍家财物。于佛正法出家学道。于一念顷能入百三昧。能以天眼见百佛世界。神通智力能动百世界。身亦能过。光明普遍能示他人。能化一身为百。成熟众生。能住寿百劫。能知过去百劫事。能知阴界入各百法门。化百菩萨以为眷属。若以愿力神力所作。则有无量亿百千劫不可数知。是名略说欢喜住。所谓决定四种发心正愿方便精进。出生修净住法。彼彼住净修。见佛善根受生神力。广说如修多罗十地欢喜地说。修多罗说十地。即此菩萨藏。摩德勒伽说十住。摄受众生故说他。自受行住故说住

云何增上戒住菩萨行相。是菩萨于欢喜住得十种净心。一者一切种供养尊重福田先语问讯心。二者同法菩萨亲近乐住心。三者胜一切烦恼烦恼魔业自在心。四者见一切行过恶心。五者见涅槃福利心。六者常修菩提分法善根心。七者随顺修菩提空闲静处心。八者不念世间贪爱贡高利养心。九者离下劣乘专向大乘心。十者一切种利益众生心。如是十种正心生名得净心。如是净心增上满足。次第入增上戒住。入增上戒住已。性戒具足。软邪业迹所摄恶戒。一切不行。况复中上十业迹满足性戒。成就如是自性戒慧染污不染污业迹。善趣恶趣道业行。因处果处如实知。报果依果及彼业如实知。自断十恶行十善业。复以此法教授众生。毒业过患恶众生界等无差别。善业恶业。第一义苦种种众难。得广大哀愍。于此增上戒住见佛善根清净如前说。譬如真金得迦私药着于火中转增明净。菩萨善根清净亦复如是。于此住入清净心悕望成就。受生作转轮王王四天下。以自在力令诸众生离诸恶戒行善业迹。神力十倍胜前。是名略说增上戒住。所谓净心性戒具足。离一切种恶戒垢。一切业迹一切因果如实知。分别四种业教授众生。得广大哀愍观众生界业生苦种种众难。见佛善根清净受生神力。广说如修多罗十地离垢地说。离恶戒垢故名离垢。彼离垢地即此增上戒住

云何增上意住菩萨行相。是诸菩萨先于增上戒住得十种净悕望思惟具足已。复有十种心悕望思惟增上满足已。过增上戒住入增上意住。一者思惟我尸净十种心悕望。二者思惟我于此十种净悕望终不复退。三者思惟我于一切漏有漏法心终不着厌离心住。四者思惟我于彼对治修识住。五者思惟我于彼对治法终不退转。六者思惟我于坚固对治终不为一切魔所胜。七者思惟我于诸佛法终不生懈倦。八者思惟我于诸苦行终不畏难。九者思惟我一向信解大乘不乐小乘。十者思惟我常乐一切众生一切种利益。是为入十种心悕望增上意住。菩萨于一切行以患厌行种种对治。观佛智慧功德福利种种福利行而生爱乐淳厚心。欲观众生果苦种种苦行顾念众生。心依于义于一切有为行不为放逸。于大菩提炽然精进。于诸众生广生大悲心。云何令此众生究竟脱苦。即时观察知住无碍解脱智者乃可得。此是无碍智不离通达法界如实智慧。是如实智慧不离禅定解脱三昧正受。是诸禅定不离多闻决定智慧。复作是念。无碍解脱一切佛法以何为本。不离闻为本。作是念已转加精进求法无厌。为闻正法故不惜身命。无内外物而不布施。无有尊重而不求法。以爱念心闻一四句偈。胜于爱念三千大千世界大珍宝聚。若闻一偈如来所说。正向佛道。净修菩萨行。胜得一切转轮圣王护世帝释魔梵诸王。若有人言我有此法如来所说。正向佛道净修菩萨行。若能投大火坑受大苦者。当为汝说。菩萨闻已欢喜乐受作是念。若闻正法正向佛道净修菩萨行。正使三千大千世界大火炽然乃至梵天。尚入其中。况复小火。经地狱苦尚求佛法。况复小苦。如是精进方便思惟求法如法次法向随顺佛法。不以文字音声清净。作是念已。依于闻法正缘法相离欲恶不善法。得世俗四禅四无色四无量五神通。舍诸禅三昧正受。以愿力故观察欲界。彼众生能满菩提分法者而生彼处。离欲故欲缚断。舍诸禅正受故有缚。如是解行住先如是法如解见所起缚断。邪贪恚痴毕竟不行。见佛善根清净如前说。譬如真金数被炼治尽诸垢秽称量不减离垢明净。菩萨善根转增清净亦复如是。若更受生得帝释身。以离欲善法调伏众生神力。如前住千倍。是中诸住百千万倍。是名略说增上意住。所谓心思惟成就入一切行众生界大菩提正分别真实苦解脱。方便正求大恭敬求法法次法向。巧便出生诸禅三昧正受神通。舍于诸禅。以愿力故随所欲生。见佛善根清净受生神力。广说如修多罗十地明地说。闻行法行法明照三昧明照修习。是故此地故名明地。内心清净故名增上意住。彼明地即此增上意住。云何菩萨菩提分法相应增上慧住行相。是菩萨先于增上意住得入十种法明。求多闻为增上满足已。过增上意住入初增上慧住。彼入十种法明如修多罗说。谓所可建立建立建立处第一义等。若烦恼若清净净。烦恼系恼无上清净净。是名略说法明义住。此住者。不怀悕望为首。如修多罗说十智成熟法成就生如来家。逮得自法一切种观为增上已修念处等三十七菩提分法如修多罗说修集彼法故离身见等。随界入微细爱着毕竟不行。如来不称叹业一切不行。所称叹者。一切随顺如如真实。心转柔软修种种行。其心快净。知恩报恩等随顺功德种种净法。皆悉成就。求净上地业得大精进。因彼精进净心深心信解满足。因彼正法外道魔怨不能倾动。见佛善根清净如前说。譬如真金为庄严具余金不及。菩萨善根亦复如是。胜余下地菩萨功德。如育多摩尼光明清净余珠不及。一切风雨所不能灭。如是菩萨下地菩萨声闻缘觉智慧光明所不能及。魔怨烦恼皆不能坏。若更受生作焰摩天王。以诸善法教化众生。破身见等神通力胜于前住百千万倍。此住亿倍。是名略说菩提分法增上慧住。所谓入法明智成熟修菩提分法。身见等一切着断。制业听业若离若修。因彼心转柔和随顺功德皆悉成就。求净上地业得大精进。因彼精进净心深心信解清净。因彼正法魔怨不动。见佛善根清净受生神力。此则略说。广说如修多罗十地焰地说。彼地菩提分法彼地智焰种平等说法。以智慧光照明世间。是故彼地名为焰。彼焰地即此菩提分法相应增上慧住

云何菩萨谛相应第二增上慧住行相。是菩萨先于初增上慧住得十平等净心。增上满足。已入第二增上慧住十平等心。如修多罗说。谓无等。觉觉无等。超余一切众生界法如等。是名略说心平等义住。此住者更求智慧胜进智慧时。于四圣谛有十种如实知。如修多罗说。若教他若自知若俱知。若说修多罗毗尼摩德勒伽方便。若说现在苦因生未来苦因灭彼灭不起彼灭方便胜进。是名略说十种四圣谛。当知如是真谛善以智慧坏一切有为。行于众生界大悲增长前际后际愚惑四谛起于邪趣菩萨正知解脱彼故摄功德智慧众具具足摄持彼悕望度起正念正智精进为首等。种种真实功德增长。无余思惟成熟方便。成熟众生。摄众生故。修习一切世俗书论。如修多罗说。如是功巧业一切出生。悲念众生渐次诱进安立菩提。随顺世俗必定善方便破诸贫穷。四大错乱非人所恼令得休息。无罪戏乐众具饶益。因此饶益引乐令法。以住止众具而为饶益。王贼所恼度令安隐。处非处方便若听若制吉非吉物。应施不施令得所宜。现法展转无有违诤。乃至后世亦无怨结。诸颠倒者为说正道。是名摄受众生世俗工巧及平等义。见佛善根清净如前说。譬如成炼真金莹以砗磲光明清净胜于余金。如是菩萨智慧方便胜余菩萨声闻缘觉。譬如日月宫殿一切风轮不能令失。如是菩萨智慧方便不为一切世法所胜。若更受生为兜率天王。以诸善法破坏一切外道邪法神通力胜于前住百亿倍。是名略说谛相应增上慧住。所谓净心平等成就。入谛观增长破坏诸行。于诸众生大悲增长。功德智慧众具成熟。正愿方便正念正智正说等功德增长。无余思惟。一切种成熟。方便成熟。众生世俗工巧出生。善根清净受生神力。广说如修多罗十地难胜地说。于真谛决定智慧难胜。是故彼地名为难胜。彼难胜地即此义名为谛相应增上慧住

云何菩萨缘起相应增上慧住行相。是菩萨先于谛相应增上慧住。得十平等法。如修多罗说。彼增上满足已入于此住。一切法第一义自性无相平等。无言说行照曜无相平等。即彼无相故自无生平等。因不起平等。自因不起故毕竟寂灭平等。离摄受虚伪平等。无取无舍离行平等。妄想尔焰自性如幻如化平等。离妄想智境界自性有无无二平等。是名略说十平等分别义。住此住者。于诸众生大悲增长。于大菩提殷勤欲乐。知诸世间若生若灭一切种缘起。正观了知因缘起智。入三解脱门知空无相无愿。依彼故离我我所若有若无想。如是第一义善思惟。众生烦恼结缚因缘和合有为性劣。离我我所生诸过恶。非离烦恼因缘和合。我当断彼烦恼因缘和合。自护故不灭一切有为。护众生故如是智悲随行于此住。名向无碍智般若波罗蜜住现在前。一切世间所不能染。如是住者若利第七地。方便行究竟菩萨忍彼随顺忍所摄。是向无碍智般若波罗蜜。修集具足取菩提因缘。不住世俗有为。示现寂灭而不住寂灭。如是方便智慧随顺。入空三昧门。向百万三昧门。如空三昧无相无愿三昧门亦如是。如是向诸三昧已名为不坏心。一切种佛法转增殊胜。外道魔怨所不能坏。余如前说。譬如真金以琉璃庄严胜于余金。如是菩萨善根清净胜于一切。譬如月光除众生恼。四方风轮不能障蔽。菩萨智慧光明亦复如是。为诸众生息烦恼火。一切魔怨不能断绝。若更受生为善化自在天王。常以诸善法灭除众生一切憍慢。神力胜前亿千倍。是名略说缘起相应增上慧住。所谓平等法成就入觉诸缘起生解脱门。离诸邪想方便摄受。住向无碍智般若波罗蜜。得向无量三昧。得不坏心。佛法殊胜。善根清净受生神力。广说如修多罗十地现前地说。无碍智向。是故彼地名为现前。即此义名为缘起相应增上慧住

云何菩萨有行有开发无相住行相。是菩萨于缘起相应增上慧住。次第十方便慧生。一切众生不共世俗及得一切世间不共道方便升进增上满足已入第七住。彼诸方便慧。如修多罗说。谓出生世间善法摄受功德故。于诸众生安心乐心。福德众具菩提分法。渐次增进故。不共声闻故。不共缘觉故。知众生法界故。知世界故。知如来身口意故。如是等方便慧生道。次第方便升进义故。略说当知。如是具足无量无数如来境界各别智彼起无开发无相想无想观无量佛境界起处不断无开转修习一切威仪行住思惟。于彼一切处终不离道。于念念中具足十波罗蜜及一切菩提分法。非如余住。第一欢喜住修习正愿。第二住离恶戒垢。第三住愿转增长得法光明。第四住入道。第五住入世间所作。第六住入甚深法门。此第七住起一切佛法满足菩提分。菩萨方便行满足摄受。于此住智慧神通行清净入第八住。住第八住者。一向清净。此第七住杂清净住前行故得不染污。名不染污行。此第七住一切贪等烦恼断故。不名有烦恼。不名离烦恼不行。亦乐佛法如实心清净故。不名离烦恼。此第七住成就无量清净身口意业。如佛所叹业如前说。五住所得世间工业智自然满足。为三千大千世界大师。唯除上地菩萨及如来。余无及者。一切禅定菩提分法。皆现前修而不受报。菩萨于此住思惟方便入善择三昧门。生百万三昧。超过一切声闻缘觉三昧境界。远离烦恼诸妄想行。随顺甚深身口意业。不舍方便胜进之道。顾念众生满足菩提。离一切相无量身口意业。生净修无生法忍。于此住超过自觉境界。余六住佛法攀缘。第六住菩萨能入寂灭。今住此地。念念寂灭得未曾有身口意业不思议。虽行实际而不证实际。如是方便智生为增上已。行共一切众生行照明世间。余如修多罗说。取要言之。为功德事亲属想摄受。方便胜进住三解脱。求下乘者方便调伏。受五欲者令求胜欲。转诸邪见随顺他心。于诸大会皆悉随顺。余如前说。譬如成炼真金以摩尼珠宝庄严胜阎浮檀金。菩萨善根清净胜于一切声闻缘觉及余离垢菩萨。譬如日光照阎浮提一切泥水皆悉干消胜于余光。是菩萨智慧光明能令众生烦恼干消。胜于一切声闻缘觉及余菩萨智慧光明。若更受生作他化自在天王。以智慧饶益声闻缘觉。一切神力胜前亿百千倍。是名略说有行有开发无相住。所谓方便慧生道方便胜进入知如来境界所起处。无间方便。于念念中集菩提分。染污不染污处方便行满足。摄受净心业生故一切世间工巧业满足。得无量三昧。不共一切声闻缘觉。念念寂灭行于一切共世间行。善根清净受生神力。广说如修多罗十地远行地说。方便行满足。是故彼地名为远行。即此义名为有行有开发无相住。云何菩萨无行无开发无相住行相。是菩萨于初无相住次第得十种入一切法第一义智。如修多罗说。谓三世如所应本来不起不生无相故无余。因性故第一义离言说自性事言说行显示自性相因性无有。彼如是不生故。于彼无知邪计着因于彼无所有事离言说初中后一切时烦恼等。入正离妄想平等。断彼烦恼故十种智增上满足。满足已入第八清净住。于彼不起法得快净第一无生法忍。彼云何谓四种求求一切法。四种如实知知一切法。以求知故。离一切妄想计。着一切法现法。中一切烦恼无生。随顺观来世一切无余无生。观如等前妄想计着因起法。四种求四种如实知。如前真实品说。从解行住起乃至有行有开发无相住。未得快净。于此住乃得快净。是故名第一无生法忍。得无生法忍已得甚深法。离初无相住四种过患。一者有行有开发。二者上地勤求。三者一切种利益众生堪能勤求。四者微细想行。是故此住名为快净。于甚深法门法流水中。如来劝发出生无量门智慧神通诸业饶益。以劝发故出生无量尊身变化智慧得十自在。如修多罗说。得自在故欲久近住随意即能。诸禅解脱随意所欲。资生众具世工巧业悉得随意。一切住处一切受生随意往生。一切神力一切誓愿随意能得。变一切物成于金宝随意能成。欲知法界名身句身味身。于一切法建立巧便。即能知之。如是自在力果报福利。如修多罗说。于念念中常等见佛善根。清净受生神力金光明喻。如修多罗说。是名略说无行无开发无相住。所谓入第一义智成就。入得不起法忍。过患悉离得快净住甚深法门诸佛劝发出生无量智慧神通诸业饶益。无量尊身出生智慧出生。得大势力得大自在力。福利果报善根清净受生神力。广说如修多罗十地不动地说。离有行有开发乘不动胜进道。是故彼地名为不动。即此地名为无行无开发无相住

云何菩萨无碍住行相。是菩萨于此甚深住不以为足。勤修随顺上地胜进知法之行一切种为人广说。随所应说悉如实知所可说法。烦恼清净。谁恼谁净悉如实知。如是善说法名大法师。得无量陀罗尼善诸音声辩才。无尽法陀罗尼如所持法摄受成就。以菩萨无碍智。出生言说。坐于法座如应说法。随其法示喜成如修多罗说。善根清净受生神力。胜进如修多罗说。是名略说菩萨无碍住。所谓乐深解脱说法行智不思议大法师。善根清净受生神力。广说如修多罗十地善慧地说。安乐一切众生。净修菩萨无碍。广说大法。是故彼地名为善慧。即此义名为无碍住。云何最上菩萨住行相。是菩萨于无碍住。净修一切种净法王所应灌顶正受。得离垢等无量三昧。作所应作已一切智殊胜灌顶最后三昧现前。得一切佛同坐身。莲华眷属光明所照。得一切种一切智灌顶已。受调伏解脱方便知一切佛事。得无量解脱总持神通。彼增上故大念智慧生辩才建立大神通。出生善根清净受正神力胜进。是名略说最上菩萨住。广说如修多罗十地法云地说。法云地菩萨满足菩萨道。满足菩提众具。得菩萨胜慧。兴大法云。以正觉自觉。而诸众生烦恼垢秽悉令休息。种种善根增长成熟。是故彼地名为法云。即此义名为最上菩萨住

如上说展转上功德前地所无以软根者不在数。诸中上者上地所得具足建立。彼一一住经亿百千大劫。或复无量。然后具足彼一切住。经三阿僧祇大劫。然后得初阿僧祇大劫解行住。过得欢喜住五行胜进。第二阿僧祇大劫。从欢喜住乃至有开发无相住。过得无开发无相住。彼即此决定。谓净心菩萨决定胜进。第三阿僧祇大劫无开发无相住及无碍智住。过得最上菩萨住。有二阿僧祇劫。若大劫昼夜月分数成时无量故。名阿僧祇。若彼诸大劫数成一劫数过数名阿僧祇。前阿僧祇劫。菩提非少劫阿僧祇得。后三阿僧祇大劫不增。若彼上上精进方便能成超众多中劫。或复超大劫。无超阿僧祇者。如是十二住菩萨。三阿僧祇烦恼障分染污。及智障分染污断。彼三住烦恼障分染污断。欢喜住恶趣烦恼分。增上中烦恼分一切不行。无开发无相住无生法忍清净相续。烦恼分一切染污断不行一切烦恼。最上菩萨住一切烦恼习使障断。入如来住智障分。染污有三种。一者皮。二者肤。三者骨。欢喜住皮障断。无开发无相住肤障断。如来住骨障断。一切障清净。于此三住智障断。余住随其次第真实众具。如是十三住有十一种净。第一种性净。第二解行净。第三净心净。第四戒净。第五意净。第六第七第八正智方便净。第九方便行满足净。第十真实智神通出生净。第十一说正义无碍净。第十二随顺入一切种一切所知智净。第十三如来住习气一切烦恼智障净。如前菩萨功德品说。八法摄一切摩诃衍菩萨藏所说。此十三住摄初第一住信心生解于菩萨藏得闻慧思慧。第三住净心及初修慧行。第四住乃至第九有行有开发无相住修慧广。第十第十一第十二住净修慧行所摄修慧果成如来住。毕竟出离声闻住所有法。此等十二菩萨住。次第当知。一者如声闻自种性住。此亦当知。如超升离生方便住。第二住亦如是。如超升离生信。第三住亦如是。如得不坏净圣爱增上戒住上漏尽第四住亦如是。如依增上戒增上意学出生住。第五住亦如是。如得真谛智增上慧学住。第六第七第八住亦如是。如善观察住无相三昧方便。第九住亦如是。如究竟无相住。第十住亦如是。如禅定起解脱觉住。第十一住亦如是。如一切种阿罗汉住。第十二住亦如是(起解脱入住者起谓从定觉也五解脱入如杂心说)菩萨地持经卷第七菩萨地持经卷第十

        北凉中印度三藏昙无谶于姑臧译

    菩萨地持毕竟方便处生品第一(第三段有五品)

菩萨生略说有五种。一切住一切行菩萨以无罪安乐一切众生。一者息苦生。二者随类生。三者胜生。四者增上生。五者最后生。菩萨以愿力自在力。于饥馑世。受大鱼等身以肉救济一切众生。于疾病世。为大医王救治众病。于刀兵世。为大力王以善方便诚信之言。等心救济。息于战诤。系缚鞭打逼迫之处。为息恼故生于王家。以法正化邪见众生。奉事天神造诸恶行。以愿力自在力生彼天处。断彼邪见及诸恶行。如是无量生处皆悉往生。是名息苦生。菩萨以愿力自在力。于种种众生天龙鬼神阿修罗等迭相恼乱。及诸外道起诸邪见恶不善行。悉生其中为其导首。引令入正。彼所作者菩萨不为。彼不修者菩萨为之。又以善法广为宣说。如是随类受生。乃至无量。是名随类生。菩萨以性受生胜于世间寿色等报。如自他利品说。如是受生亦复无量。是名胜生。菩萨从净心住乃至最上菩萨住在所受生。如前住品说。于阎浮提自在生。乃至大自在。未过究竟地一切受生处于中奇特。是名增上生最上菩萨住受生调伏业菩提众具增上满足。生刹利婆罗门家。得阿耨多罗三藐三菩提。作一切佛事。是名最后生。过去未来现在一切菩萨。皆以此五种受生无余无上。菩萨因此五种受生。疾得阿耨多罗三藐三菩提

    菩萨地持毕竟方便处摄品第二

菩萨一切住一切行等摄众生。略说有六种。一者顿摄。二者增上摄。三者取摄。四者久摄。五者不久摄。六者后摄。菩萨初发心于一切众生作父母想。随力所能以一切种安乐饶益。是名顿摄。菩萨为主于父母尊重。种种方便劝修善法。随时供养知恩报恩。妻子眷属瞻视教授。所犯堪忍疾病救疗。教修善法令其胜进。奴婢作使等心料理不生贱想。菩萨为王摄受人民。如法正化不加非罚。以财以法而为饶益。自守境界不侵他土。随其力能教诸众生令修善法。菩萨为父于他众生尚无偏党。况自眷属而不平等。言常柔软真实不虚。一切杀缚逼迫苦切。皆悉远离。是名增上摄。有二因缘等摄徒众。一者舍于贪心以财饶益离于贫穷。二者教修正义以法饶益拔恶邪见。等心摄受不随偏党。不为法悭不作师倦。不于彼所求于供养。彼乐修者亦不遮止。为令增长福德众具故。未解义令起。已解义令增。疑者为决。悔者令觉。随时为说甚深要义。同其苦乐心无增减。有犯罪者等心教诫。有时呵责有时赞叹。疾病救疗为除忧患。于下念下精进下智慧不起轻想。随宜为说系念境界。随时教授堪忍不恼。于等于胜修胜供养。修习悲心不掉不动。成就戒见威仪正命。和颜平视先语问讯。常修善业不为放逸。以如是法教于徒众亦自修行。菩萨不于一切时摄取徒众。亦非不取亦不趣尔取。是名取摄。软成熟众生久久乃净。是名久摄。中成熟众生不久得净。是名不久摄。上成熟众生于此生堪能清净。是名后摄。是名六种等摄众生。过去未来现在菩萨。已摄当摄今摄。皆此六种无余无上。菩萨如是等摄众生有十二难。一者能善观察犯戒众生若教若舍。二者为调众生苦方便行自护烦恼。三者财物至少而求者多。四者唯有一身多求同事。五者以清净业生放逸人天而其内心初无放逸。六者悲念众生利益同事。七者愚痴谄曲支节残毁若教若舍。八者见生死过而不舍生死。九者未得净心命终之时不失正念。十者未得净心极所爱重众生来求而以惠施。十一者种种异心种种异解来有所求若作若舍。十二者毕竟不放逸而不断烦恼。菩萨于诸众生不观轻重而为方便。或察于人而行于悲。或勇猛方便为造因缘。或修正愿或净信心。或专心思惟观察不惓。或时柔软。或时行舍。或时精进。或时巧方便。菩萨如是正对治巧方便。于十二难能自开解。心不退没

    菩萨地持毕竟方便处地品第三

如上所说十三住。次第为七地。六是菩萨地。一是菩萨如来共地。一者种性地。二者解行地。三者净心地。四者行迹地。五者决定地。六者决定行地。七者毕竟地。种性住名种性地。解行住名解行地。净心住名净心地。增上戒住增上意住三种增上慧住有开发无相住名行迹地。无开发无相住名决定地。于三决定是初决定无碍智住名决定行地。最上菩萨住如来住名毕竟地。如来住地后建立品广说。菩萨于解行地入欢喜地。云何离恶趣报。是菩萨于解行地。依世俗净禅集菩提具。于百一十苦众生修悲愍心。为恶趣众生久处恶道如己舍宅。于此学无上菩提故。堪忍能为一切众生作除苦因。一切众生三恶道业。以清净心愿悉代受。毕竟修行一切善业修习正愿。以世俗净禅正愿力故。恶道烦恼染污受身不久得断。菩萨转恶道身。诸恶道业一切不行。是名菩萨离诸恶趣。过解行地入净心地。前住品说。净欢喜住信等十法。于此地净对治所治及次第建立。云何对治。一者放逸不受菩萨戒违信菩提。是故以信对治。二者于诸众生有杀害心违于大悲。是故悲心对治。三者于诸众生有嗔恚心违于大慈。是故慈心对治。四者顾念命财违于惠施。是故惠施对治。五者于诸众生多求众具违于不惓。是故不惓对治。六者无方便智违于知论。是故知论对治。七者不善随顺违随顺他。是故知世间对治。八者于修善法放逸懈怠违于惭愧。是故惭愧对治。九者长夜生死受无间苦。其心怯劣违于勇猛。是故勇猛对治。十者于佛疑惑违于供养。是故供养对治。如是十种对治所治。略说有二种。一者心净。二者方便净。前三种心净。余者方便净。云何次第。菩萨信于菩提。于苦众生而起悲心。起悲心故欲度众生而起慈心。起慈心故而为惠施。为惠施故修习正义无有厌惓。无有厌惓故知诸经论。知经论故善知世间随顺世间。随顺世间故若烦恼起而生惭愧。以惭愧故不随烦恼得勇猛力。得勇猛力故修正方便善法增长。多得胜利供养如来。如是十法净一切地

    菩萨地持毕竟方便处行品第四

菩萨从解行住乃至最上菩萨住。略说有四行。一者波罗蜜。二者菩提分法。三者神力。四者成熟众生。如前说。六波罗蜜巧方便波罗蜜愿波罗蜜力波罗蜜智波罗蜜。是名波罗蜜行。如前说。十二巧方便。是名巧方便波罗蜜。如前说。五种愿是名愿波罗蜜。十力方便清净。是名力波罗蜜。一切法部分知。是名智波罗蜜。知第一义谛故名般若波罗蜜。知世谛故名智波罗蜜。又无量智名巧方便波罗蜜。求增进智故名愿波罗蜜。一切魔道不能坏故名力波罗蜜。智开觉故名智波罗蜜。如前说。念处等三十七菩提分法四种求四种如实知。是名菩提分法。如前说。六神通是名神力。如前说。二无量。调伏界无量。调伏方便无量。是名成熟众生。如是四行摄一切菩萨行。三阿僧祇劫长夜修行。自性清净胜余世间声闻缘觉。摄大菩提果。施等十法时度自性清净度果度。是故名波罗蜜。诸波罗蜜次第建立有三种。一者对治。二者因起。三者报果。悭贪恶业嗔恚懈怠乱意愚痴。如是六法障碍菩提。六度对治随其所应。余波罗蜜六波罗蜜所摄。是名对治建立。是菩萨始不顾财舍离出家。既出家已受菩萨戒。以护戒故修习忍辱。不怖众生忍力清净。不怖众生故修习无间。善法方便以修精进。无放逸故善一其心。心已善一得如实智。是名因起建立。是菩萨现法修习惠施善法。于未来世。外得大财内得寿命色力安乐辩才五种果报。戒等波罗蜜五种具足者生善趣中。于诸众生寿等奇特。是名初具足彼俱生善方便无有疲厌。忍他侵犯不恼众生。是名第二具足。彼俱生一切方便坚固堪能。是名第三具足。彼俱生少诸尘秽自心堪能知一切义得诸神通。是名第四具足。彼俱生智慧增广。是名第五具足。是名报果建立。彼四波罗蜜众具自性眷属无尽。是名增上戒学禅波罗蜜。是名增上意学般若波罗蜜。是名增上慧学。此三学得菩萨上进学道。此三学摄六波罗蜜无余无上。略说菩萨有四种行摄一切事。一者先习菩提善根。二者利益众生。三者增长善法。四者成熟众生。如是四种行次第建立。是名最上建立

    菩萨地持毕竟方便处建立品第五

十三如来住。名为究竟地。诸佛世尊有百四十不共法。所谓三十二大人相八十种随形好四一切种清净如来十力四无所畏三念处三不护大悲不忘法断除诸习一切种妙智。云何三十二大人相。一者足下安平。二者足下千辐轮。三者纤长指。四者佣足跟。五者手足网缦。六者手足柔软。七者佣腨肠如伊尼延鹿王。八者踝骨不现九者平立手摩膝。十者马藏如马王。十一者身圆满如尼拘类树。十二者身毛上靡。十三者一一毛右旋。十四者身金色。十五者圆光一寻。十六者皮肤细软尘垢不着。十七者两手两足两肩及颈七处满。十八者上身如师子。十九者臂肘佣圆。二十者缺骨满。二十一者身佣直。二十二者四十齿。二十三者齿齐密。二十四者齿白净。二十五者颊车方如师子。二十六者次第得上味。二十七者肉髻。二十八者广长舌。二十九者梵音声。三十者目绀色。三十一者眼上下瞬如牛王。三十二者眉间白毫

八十随形好者。手足二十爪指手足八处表里平满两踝两膝两髀两肩两肘。两腕两股两臀藏相两圆两腨两胁两腋两乳腰背心脐咽腹悉皆妙好。是名咽已下六十种好。上下牙齿两唇两龂两颊两鬓两眼两耳两眉鼻两孔额两角。是名咽已上二十种好

此相好净心地菩萨始得。后一切地渐胜清净。至菩提座乃得快净。余四一切种清净等不共法。快净满足时得下者前菩萨地成就。从净心地起一切胜进菩萨一切相好生。又种种菩提众具有远有近。远者未得相好。近者已得。造种种业得种种报。世尊教化力故说。何以故。众生行种种恶业。得种种恶报。为真实对治故。说种种相好业。令得种种相好果报。众生闻已乐修善法离诸恶业。如相好修多罗说。菩萨持戒忍辱惠施故。得足下安平相。供养父母苦恼众生为作救护故。得足下轮相。不害众生无劫盗想。于所尊重先语问讯合掌恭敬。以爱念财而为供养破诸憍慢故。得纤长指相。即上得三相业得佣足跟相。以四摄事摄取众生故。得手足网缦相。为所尊重涂身洗浴故。得手足柔软相。修诸善法转进无厌故。得佣腨肠相。自受正法广为人说为法走使故。得踝骨不现相。次第修行三业清净瞻病施药离诸我慢修习知足故。得平立手摩膝相。见分离者以法和合修习惭愧施人衣服故。得马藏相。净修三业亦教人修。饮食知量病者施药。摄受难业集聚难财。四大增损能令随顺故。得身圆满相。即上得佣腨肠相业。得身毛上靡相自修善法智慧明达。思惟诸法微细之义。于所尊重乐修供养。于同住者以善友摄教令入义故。得一一毛右旋相以上妙衣食车舆璎珞等严身之具。施于一切不起嗔恚故。得身金色圆光一寻二相。即上得一一毛右旋相业。得皮肤柔软相。等施众生供设大会故。得七处满相。已起未起为作导首。离于我慢柔和其性。为除不善教以善法故。得上身如师子相。即上得纤长指相业。得臂肘佣圆缺骨满身佣直三相。远离两舌坏者和合故。得四十齿齿齐密二相。修欲界慈思惟法义故。得齿白净相。随众生求欢喜施与故。得颊车方相。施胜法味坏诸味者为净其味故。得次第得上味相。受持五戒转以授人常行悲心回向大法故。得肉髻广长舌二相。此肉髻相。无见顶相。即是一相。常修实语爱语时语如法语方便说法故。得梵音声相。普于众生等行慈心犹如父母故。得目绀色眼上下瞬二相。见实德者称扬赞美故。得眉间白毫相。三十二相无差别因皆是持戒。何以故。若犯戒者不得下贱人身。况大人相。如是广说。一一所得随种种业各别建立

复次在家出家菩萨翼四种善修业得一切大人相。决定修者得足下安平相。专心修者得足下千辐轮佣腨肠手足网缦手足柔软七处满缺骨满臂肘佣圆身佣直广长舌九相。常修者得纤长指佣足跟平立手摩膝身圆满齿齐密五相。无罪修者得余诸相。于诸众生无忿恚者得手足柔软皮肤细软二相。次第修时得佣腨肠相。欢喜光明音声善心行得圆光一寻身金色齿白净眉间白毫四相。闻誉不喜覆藏功德得马藏相。所修善根回向菩提得毛上靡四十齿次第得上味肉髻四相。勤修精进得师子上身方颊车二相。安众生心如视一子得齿齐密绀眼睫如牛王三相。修善无厌获得余相。是名四种善修业得三十二大人相

种性地菩萨相好种子处。解行地菩萨修集方便。净心地菩萨得。余地菩萨渐胜清净。如来毕竟地。快净无上。此略说诸相。为软中上众生。余一切佛法皆是大人相。此及余百四十相。于身妙好故说随形好。略说一切众生福德积聚等一毛相。一切毛相福德积聚等一随形好。一切随形好福德积聚增至百倍。乃得一相。除白毫肉髻。余一切相功德增至千倍。乃得白毫相。白毫相功德增至百千倍。乃得肉髻无见顶相。白毫相功德增至亿百千倍。乃得如来法蠡音相。如来随意发声清净梵音乃至十方无量世界。如是如来无量功德积聚不可思议。复次相好善业三种无量。三阿僧祇劫修习。名劫无量。安乐一切众生。名心无量。种种善业。名行无量。是无量福德众具修习出如来相好

四一切种清净者。一者身净。二者境界净。三者心净。四者智净。烦恼习身舍离无余。得最上身生灭自在。是名身净。种种现化及所言说一切境界自在无碍。是名境界净。烦恼悉离善根成熟。是名心净。舍离一切无明秽污。一切所知无碍自在。是名智净

如来十力者。一者处非处智力。二者自业智力。三者禅解脱三昧正受智力。四者诸根利钝智力。五者种种解智力。六者种种界智力。七者至处道智力。八者宿命智力。九者生死智力。十者漏尽智力。此十力如十力修多罗广说。言语所说不乖于如。是故名多陀阿伽驮。净不净果依差别因。是名是处。净不净果差别因相违。是名非处。离增上慢智。是名如实智。如前无上菩提品说。一切智无碍智清净智。是名离增上慢智。堪能一切种利益众生一切魔怨舍离得胜。是名为力。修习摄受随欲自在。是名成就。无上涅槃。是名胜妙。得八圣道离一切恼乱恐怖。是名安隐。自知所得。名为自知。自所得法以哀愍心为人广说。是名转梵轮。何以故。如来于此种种恼乱清净寂灭清凉真实。初转令一切众生皆得清净。是名梵轮。得最上教摄无上大师说。自所得破坏异道。于诸异论不生怯弱。一切诸论胜妙无上。为四众说。是名师子吼。略说自安安彼彼我俱安。开发显示教授宣说。又复略说得义得方便。若天若人诸有所求悉于我得。是名得方便。如病得差除恼安隐。复为人治。是名转法轮。能令一切虚妄邪师得诸对治诸病得差。是名师子吼。若所作业成就已灭。是名过去。若未作未灭而是当作。是名未来。若所作业非作已灭。而是所作。是名现在。以行分别复有三种。谓身口意业。以受法分别复有四种。有受法得现世乐他世苦报。广说如前自他利品。现法后世若安不安。随其所应说法利益。是名处方便。若众生数以非众生数为境界而有所作。是名众生。善根所作。是名为因。爱与不爱祸福果成。是名为报。略说一切时一切行一切处方便一切众生一切境界一切因一切祸一切福。如是一切如来悉知无余无上

四禅八解脱。于禅解脱心得自在。彼彼色像随意悉成。是名禅解脱三昧正受。如说世尊三昧正受。如其正受光照梵天妙音说法。但闻其声不见其形。以是义故。如来入共世间不共世间像类三昧能速成办。于禅解脱心得自在随意悉成。是故说禅解脱三昧正受。复次于诸禅等有二种烦恼。一者未方便修烦恼障碍令不得修。二者已得自地烦恼诸缠所使违胜进道。如来以种种世俗言教。随其色像随其所应。令得禅等修慧满足离恼清净。若得未得若劣若胜。悉如实知。是故名诸禅解脱三昧正受。如实知。向成熟信等五根有软中上。是名诸根利钝。从他生信及自思惟。为方便起软中上欲。是名种种解。种种种性建立。谓三乘种性众生贪欲等性。乃至八万四千行。是名种种界

知诸度门随顺对治。贪欲观不净。广说如声闻地。是名一切至处道。又种种党类各相违背起异见欲常共诤论。如外道沙门婆罗门。一切种向此世他世。亦名至处道智力。如时修多罗广说

知四方众生俗数建立种种名字。谓过去八种事六种同行。如是种种悉能了知。八种者。如是名。如是生。如是种性。如是食。如是苦乐。如是长寿。如是久住。如是寿限。六种同行者。俗数名字刹利等色。父母饮食善恶寿命。八种事六种同行他及自身。作如是说。此是我名。我为刹利婆罗门毗舍首陀。是我父母。我食如是食。我作如是善恶。若少年中年长年。如是六种同行以宿命智皆如实知

一切禅名为天住。依禅得眼故名天眼净。果满足故名快净。人中无此故言过人。虽欲界天有报天眼。人中亦无。众生临死名为死时。黑闇二种。如是像类乘中阴生。如夜黑闇黑羊毛光。故名恶色。白净有二种。如是像类乘中阴生。如明月光波罗奈衣。故名好色。起于恶戒是名恶戒。身口意恶行种种邪见。恶行成就诽谤贤圣。是名恶见诽谤。计着邪见邪因邪果。缘是造作一切邪业。造邪业已。受现世乐未来苦报。成现世苦未来苦报。是名受邪法因成就。种种恶法生恶道中。是名因彼名色分离。是名身坏生分都尽。是名命终。非法恶行是名为恶。受极苦触长夜无间。是名恶趣。堕极下处背大悲等。是名为堕。增上可厌。是名泥犁。与上相违是名净分乘善行生。是名善趣所受自然。是名为天。一切漏无余断一切使对治无漏心无漏智第一增上意增上慧有漏尽。名为心解脱慧解脱依见道修道心得解脱慧得解脱。是名后有得六神通。自如实知能为他说。故说自知作证。我生已尽梵行已立。如是广说

如来十力有七种。一者自性。二者分别。三者不共。四者等。五者造业。六者次第。七者差别。自性者。有说五根自性。有说智慧自性。智慧自性者。说处非处智力不说处非处信等力。如处非处智力余力亦如是。分别者略说有三种。一者时分别。过去未来现在入一切智。二者种分别。一切有为法自相共相入一切种。三者众生分别。一切众生界入一切利益。如是三种分别。广说则有无量

不共者。如来十力不与声闻辟支佛共等者。一切如来十力平等无软中上。造业者。处非处智力。真实因果如实知。伏因果诤论。沙门婆罗门自业智力自所作业。此业受果如实知。伏施福诤论。沙门婆罗门禅解脱三昧正受智力。三种示现调伏教授伏对治相违诤论。沙门婆罗门诸根利钝智力。于诸众生软中上根。如实知。如其所应。如其方便。而为说法。种种解智力于诸众生软中上解净不净解。如实知。教修净解离不净解。种种界智力于诸众生下中上界。如实知。如其心如其根如其欲如其使。彼彼度门教授利益。至处道智力。如来为诸众生种种度门种种教授。如声闻地次第开发显示教授宣说。云何如来教授初业菩萨三昧众具摄受住心。如来为无谄曲者教令修学。作如是言。善男子。汝当独处深乐寂静思惟父母师长所制名字。如此名字内外六入及两中间。一切悉无自性亦无。但是名想施设。如是思惟法不可得。不于未来起当来想。善男子。于现在眼作眼名眼想眼施设。当自观察。我眼尚不可得。况复名想施设言是眼也。如是名想施设一切悉无。名想施设都无真实。彼眼自性亦无。何以故。非彼眼名眼想眼施设眼觉生。但名字言说而生眼觉。非彼眼性可闻可知。于名于事而生眼觉。是故思惟本来眼名眼想眼施设。当来诸法悉不可得。如眼如是耳鼻舌身乃至见闻觉知若求若得若觉若观如是。一切法想乃至当来想如是。坏我想方便道摄受。乃至坏一切法想。方便道摄受如是。一切所知善观察。一切法想当来想。一切虚伪无想无思无相。于一切义无所摄受。当得如来清净智慧三昧种性。彼诸菩萨得不净观。行于慈心观察缘起。分别诸界入出息念。逮得初禅乃至非想非非想处。菩萨无量三昧正受思惟。渐次乃至得阿耨多罗三藐三菩提。是名菩萨至处道。过去如来为初业菩萨如是教授。未来诸佛当如是教。现在诸佛亦如是教。声闻乘如是思惟。疾得神通无碍智一切至处道智力。出一切苦道如实知。离不出道出道饶益。宿命智力观察宿命。于善于恶若厌心若净心。调伏说法伏常论。沙门婆罗门生死智力说众生生死所往生处伏断灭论。沙门婆罗门漏尽智力伏疑惑解脱。沙门婆罗门。次第者。如来得阿耨多罗三藐三菩提顿得十力。后次第现在前阿惟三佛法部分因果故。以处非处智力。观察因果部分。欲界差别故。以自业智力。观察自业而为说法。令离恶业修行善业。为世俗道离欲故。以禅解脱三昧正受智力。教诸众生。复为出世离欲故。以禅解脱三昧正受智力。先教众生。以世俗道离欲。后得出世间道离欲。欲令众生得出世间离欲故。以诸根利钝智力。观察诸根。知诸根已。欲知悕望故。以种种解智力观其悕望。观悕望已。以种种界智力。观察根使。随其方便境界度门而度脱之。以一切至处道智力。于境界度门方便心住摄受心住。行清净已离身见断常等见。为说中道。离一切烦恼故入宿命智力及生死智力。为止所缚不断烦恼。起增上慢教令离故入漏尽智力

又次第者。阿惟三佛法得阿耨多罗三藐三菩提已。先以处非处智力。观察缘起第一义法住。依第一义法住智已。以自业智力观在家分种种业。观在家分种种业已。以禅解脱三昧正受智力观出家分。云何令此出家分于苦解脱当为说道。起大悲心佛眼观察。以诸根利钝智力。观察软中上根而为说法。余种种解智力等。次第如前说

又次第者。阿惟三佛法以处非处智力。观察缘起法界。以自业智力观众生界。如此众生作如是业受如是果。观法界众生界已。以禅解脱三昧正受智力。为苦众生三种示现而教授之。余根利钝智力等。以道度脱一切众生。令脱众苦

差别者。知善不善业。得爱不爱果。是名处非处智力。知善不善业得爱不爱果。不作不受乃至禅解脱等。此业非彼业。是名自业智力。知禅解脱等三种示现教授。乃至知净等俱生相应心。是名禅解脱三昧正受智力。知软中上根。是名诸根利钝智力。乃至知诸根方便生彼悕望。亦名诸根利钝智力。知种种悕望。是名种种解智力。解有六种。一者不出解。谓悕望摩醯首罗那罗延梵世等解。二者出解。谓悕望三乘解。三者远净解。谓悕望软中成熟解。四者近净解。谓悕望上成熟解。五者现法得涅槃解。谓悕望声闻乘得涅槃解。六者将来得涅槃解。谓悕望大乘得涅槃解。乃至知解。所起作种子喻。亦名种种解智力。界分别有四种。如性种子。是名种种解智力。知种种分别种子。是名种种界智力。乃至知涅槃法及顺界道迹。亦名种种界智力。知一切种道迹种种烦恼种种清净。是名至处道智力。乃至知宿命一切趣因。亦名至处道智力。知过去六种言说。是名宿命智力。乃至知过去众生生死。亦名宿命智力。知未来生死。是名生死智力。乃至知未究竟自义众生未来生死。亦名生死智力。知究竟自义现法得涅槃。是名漏尽智力。如是十种智力各各差别。四无畏如修多罗说。如来以此四事于大众中自证而无所畏。智障解脱一切法平等觉。不共声闻是第一无畏。烦恼障解脱共声闻是第二无畏。说出苦道是第三无畏。障道法是第四无畏。如来于是四义自如实知。若有诽谤言不知者。无有是处。无是处故得无所畏无怯弱。不疑惑决定自知。堪为大师自安安彼。前二处满。是自安道。后二处满。是安彼道。一切法平等觉。为向大乘诸菩萨故。烦恼障解脱。为向声闻缘觉乘故。出苦道及障道法二俱为故。如来为诸菩萨声闻缘觉。行出苦道说修多罗。结集经藏者。以说菩萨行立菩萨藏。说声闻缘觉行立声闻藏

三念处如修多罗说。如来长夜作如是念。我善法律为大法主。于受不受不起恼心。略说三种众。一者正趣。二者邪趣。三者非正非邪。于此三众。以正念心而无增减

三不护如修多罗说。略说。一切所作覆藏悉断。是故如来显示三不护。阿罗汉犹有无记突吉罗。或时忘误。唯有如来一切悉无。一切真实。阿罗汉或时论议畏堕负处。或时不悦。或时慧性。是故自护不令习气起不净身口意业。如是一切如来悉无

大悲如前供养习近无量品说

不忘法者。谓如来所可作事。常随忆念。一切作一切说一切巧方便一切时。于此诸事常念不忘

断除诸习者。谓如来动止视瞻言说行住。离烦恼所起相似余习。诸阿罗汉动止视瞻言说行住。有烦恼所起相似余习。如来永断。是故名为断除诸习

一切种妙智者。如来知三种法。义饶益。非义饶益。非义非非义饶益。知非义饶益非义非非义饶益一切法智。是名一切种智。知义饶益。一切法智。是名妙智一切种智及妙智。总说名一切种妙智。是名略说百四十不共法一切相好。菩萨最后身得快净菩提分法。菩提树下乃得满足菩萨最后身。修三十七菩提分法得众相。离障三昧金刚三昧所摄。次第二心顿得十力。乃至一切种妙智快净无上。一切所知无碍无障。快净离垢平等开觉。过一切菩萨行。行如来行。得无上身究竟地。菩萨智如来智有何差别。究竟地菩萨智如罗縠中视。如来智如去罗縠。菩萨智如远见色。如来智如近见色菩萨智如微翳视。如来智如净眼见。菩萨智如处胎视。如来智如出生见。菩萨智如梦中视。如来智如觉时见。是为如来究竟地菩萨智慧差别。诸佛如来于十方世界。施作佛事利益众生。略说有九种。云何为九。一者欲令众生信心清净故。受丈夫身起诸相好。二者为欲利益一切众生断一切疑故。起如来十力。三者以佛十力起一切义。开发如来一切知见。答一切问伏诸邪论建立正论故。起如来四无所畏。四者如来智慧若住不住。随彼调伏离诸烦恼故。起三念处。五者如前说。如是作故。起三不护。六者常以佛眼昼夜观察一切世间故。起大悲心。七者于一切众生一切所作已作故。起不忘法。八者如来所行随顺于如无有余故。起断除诸习。九者非义饶益非义非非义饶益法一切远离。义饶益法分别显示故。起一切种妙智。如来于此百四十不共法作九种佛事。广说则有无量。是名如来住。是名建立。何以故。依菩萨学所学。建立一切利众生事。是故名为建立。自利利他非如声闻缘觉故。名不共。一切佛法大悲不忘。断除诸习一切种妙智。声闻缘觉所不能得。余一切种亦不满足。故名不共。于此显示满足菩萨学道。及学道果一切菩萨学道。及学道果一切种真实说处。是故名为菩萨地。名为菩萨藏摩得勒伽。名摩诃衍摄。名不坏显示。名无障碍清净智根本

若有天人阿修罗人非人沙门婆罗门。于菩萨地起坚固信解。听受修习广为人说。书写经卷种种供养。所得功德与世尊于菩萨藏为初业菩萨开发显示教授宣说所有功德等无有异。何以故。此菩萨地菩萨藏。显示菩萨法律。令多众生受持思惟。建立法次法向。渐转增广不起像法法灭尽相。能令像法实义炽然。能令正法永不灭尽。是故于菩萨地。起坚固信解。听受修习。广为人说。书写供养。所得功德。无量无边

菩萨地持经卷第十


菩萨善戒经

    No. 1582 [cf. Nos. 1579(I, 15), 1581]

菩萨善戒经卷第一

        宋罽宾三藏求那跋摩译

    菩萨地序品第一

如是我闻。一时佛在舍卫国须达多精舍只陀林中。与大比丘僧五百人俱。菩萨千人。尔时世尊即告无量诸菩萨言。谁能于此后恶世时。受持拥护阿耨多罗三藐三菩提。谁能护法。谁能教化一切众生。尔时弥勒菩萨即从座起。偏袒右肩右膝着地。长跪叉手白佛言。世尊。我能于后恶世之中。受持拥护阿耨多罗三藐三菩提。能护正法。能化众生。师子菩萨复作是言。世尊。我亦能以种种方便摄持众生。金刚菩萨言。世尊。若有众生当堕三恶道。我能遮持令不堕落。文殊师利复作是言。世尊。若有众生凡所求索。我悉能令一切具足。智幢菩萨复作是言。我能惠施众生大智。法幢菩萨复作是言。世尊。我能以法普施众生。日光菩萨言。世尊。我能施于众生安乐。月光菩萨言。世尊。我能教化一切众生令修福德。善护菩萨言。世尊。我能教化一切众生令不放逸。无尽意菩萨言。世尊我能教化一切众生。悉令知见无尽界义。月子菩萨言。世尊。我能惠施一切众生无上安乐。善月菩萨言。世尊。我能施于一切众生安乐之因观世音菩萨言。世尊。我能救护众生怖畏。得大势菩萨言。世尊。我能令彼未度者度。众善菩萨言。世尊。我能令彼不调者调。善意菩萨言。世尊。若有众生堕在畜生。我能教化令其调伏。不乐菩萨言。世尊。我能施于愚者智慧。光聚菩萨言。世尊。我能令彼下根之人令得上根。不谛菩萨言。世尊。我能示彼狂者正道。乐见菩萨言。世尊。我能施于无量众生无量安乐。释幢菩萨言。世尊。我能令彼受苦众生常忆苦事。不可思议解脱菩萨言。世尊。我能令彼饿鬼众生远离饥苦。圣光菩萨言。世尊。我能令彼不调者调。维摩诘菩萨言。世尊。我能坏彼众生疑心。光明菩萨言。世尊。我能闭塞三恶道门。金刚功德菩萨言。世尊。我能令彼异解众生悉作一解。无量行菩萨言。世尊。我能施彼众生无漏之道。无所畏菩萨言。世尊。我能坏彼种种怖畏。宝功德菩萨言。世尊。我能显示一切众生功德宝藏。善意菩萨言。世尊。我能以此微妙软语调伏众生。净光菩萨言。世尊。我能以爱调诸众生。宝贤菩萨言。世尊。我能令彼一切众生忆过去世。高贵德光菩萨言。世尊。我能令彼勤修精进。善功德菩萨言。世尊。我能令彼苦恼众生悉得解脱。宝手菩萨言。世尊。我能施彼无量众生种种诸宝。意珠菩萨言。世尊。我能坏彼众生贫穷。破结菩萨言。世尊。我能坏彼众生烦恼。金光明菩萨言。世尊。我能示彼邪伪众生真实之道。功德色菩萨言。世尊。我能令彼诸乘众生皆住一乘。法意菩萨言。世尊。我能令彼悉得法眼。金刚子菩萨言。世尊。我能坏彼众生恶业。法增菩萨言。世尊。我能如法摄持众生。无名菩萨言。世尊。我能令彼一切众生远离三毒。月胜菩萨言。世尊。我能示彼众生善方便。师子意菩萨言。世尊。我能以法施于众生。师子吼菩萨言。世尊。我能破坏众生疑网。香象王菩萨言。世尊我能于后恶世之中示众生梦令坏烦恼。尔时舍利弗作是思惟。甚奇甚特诸菩萨事不可思议。复白佛言。世尊。若有菩萨勤修精进具足方便。而能种种利益众生。世尊。如是等菩萨摩诃萨。众生云何乃从是人乞索头目髓脑血肉及诸所须。世尊。我今定知。如是乞者即是菩萨摩诃萨也。佛言。善哉善哉。舍利弗。实如所言唯诸菩萨乃知菩萨。实非声闻缘觉所及。舍利弗。菩萨摩诃萨虽复现佛种种神足。终不舍于菩萨之心。舍利弗。若有长者生憍慢心。菩萨现作长者之像。破彼慢故。若至那罗延及端正人有憍慢者。悉现其身坏其憍慢。若得圣法示以大乘。何以故。离一解脱更无异解脱故。是故名如来。舍利弗。在家菩萨修集二施。一者法施。二者财施。出家菩萨修集四施。一者笔施。二者墨施。三者经施。四者说法施。出家菩萨具足成就是四施已。能调其心破坏憍慢修集忍辱。舍利弗。出家菩萨具足忍辱。则能受持菩萨禁戒。又复具足三种惠施。乃能受持菩萨禁戒。一者施。二者大施。三者无上施。施者。于四天下尚不吝惜。况于小物。是名为施。大施者。能舍妻子。无上施者。头目髓脑骨肉皮血。菩萨具足如是三施乃具于忍。具是忍已则能受持菩萨禁戒。舍利弗。菩萨欲受菩萨戒时。先当调伏柔软诸根。于生欲处不生欲心。于生嗔处不生嗔心。于生痴处不生痴心。于生畏处不生畏心。若自知具如是四事。则为十方诸佛所知。其人亦能知十方佛。舍利弗。若知不具如是四事。受菩萨戒者。是人亦不得菩萨戒。亦诳十方现在诸佛及诸菩萨。舍利弗。菩萨有二种。一者从嗔因缘。二者从痴因缘。舍利弗。嗔者能作八大地狱因缘。痴者能为诸恶烦恼因缘。以是嗔痴二因缘故能毁菩萨戒。舍利弗。若欲受持菩萨戒者。应先远离欲痴嗔畏。六月昼夜独处闲静纤悔诸罪。我某甲归依佛归依法归依僧。归依十方现在诸佛及菩萨僧。归依释迦牟尼如来。南无佛南无法南无僧。南无十方佛及菩萨僧。南无释迦牟尼佛。南无金刚无坏身。南无宝光。南无无量自在王。南无无上林王。南无无上欢喜。南无宝火。南无宝月光。南无清净。南无手勤精进。南无梵德。南无善功德。南无栴檀功德。南无光功德。南无阿叔伽功德。南无那罗延力。南无华功德。南无莲华。南无财功德。南无念功德。南无善名。南无释种王。南无无胜。南无无边身光南无无边身。南无无动。南无大山王如是等无量世间诸佛菩萨。常住在世宣说法化。唯愿愍哀留心见念。若我过去无量世中及现在世。所作众罪不善恶业。若自作若见他作心生随喜。若取佛物法物僧物招提僧物现在僧物。若自取已若见他取心生随喜。若自造作五逆之罪。见他造作心生欢喜。若自造作十不善业。若见他作心生欢喜。以是不善业因缘故。当生畜生饿鬼地狱。若边地人身长寿天身诸根不具。亲近邪见不值佛世。如是等罪今悉诚心求哀忏悔。如于现在释迦佛前。如来世尊真实知见。其智无碍净眼无障。常为一切众生证人。唯愿观我诚心忏悔。我从今日更不敢作。复次十方诸佛及诸菩萨至心谛听。若我过去无量世中。及现在世所修惠施乃至施于畜生一把。若我持戒乃至一念如是功德。悉以回向无上菩提。如过去佛及诸菩萨发愿回向。如未来佛及诸菩萨发愿回向。亦如十方现在诸佛诸菩萨等发愿回向。舍利弗。菩萨如是至心礼拜恭敬诸佛过六月已。若去若立若行若坐。十方诸佛示其身面。具足三十二相八十种好。虽示菩萨如是相好。而于法界初无动转。何以故。如来真实知其心故。十方诸佛定知是人堪任受持菩萨禁戒修集慈悲。能坏魔众转正法轮。能调众生宣说法界。以是义故。十方诸佛为是菩萨示现其身。舍利弗。如师子吼猫狸能不。不也世尊。若有不于无量世中无量佛所殖诸德本能得受持菩萨戒不不也世尊。舍利弗。如香象王之所负担驴能胜不。不也世尊。舍利弗。如日月光萤火及不。不也世尊。舍利弗。如毗沙门所有财宝贫者等不。不也世尊。舍利弗金翅鸟飞乌能及不。不也世尊。舍利弗。若有能于无量世中无量佛所深殖德本。是人乃能受菩萨戒。了了见于十方诸佛。舍利弗。受菩萨戒已。若有客尘烦恼因缘犯可忏法应当向诸佛忏。菩萨终不造五逆罪。若贪不息乃至生子。应于十方现在佛前满足二年昼夜经常以殷重心求哀忏悔。若为贪心取佛物法物僧物。如本佛前二年忏悔。舍利弗。菩萨若以嗔恚因缘毁禁戒者无有是处。以嗔因缘毁破禁戒得忏悔者亦无是处。尔时优波离于其晨朝从禅定起。即诣佛所头面作礼。右绕三匝却坐一面。白佛言。世尊。如戒经中说。若我弟子有信者。于所受戒乃至失命终不毁犯。世尊。现在若入涅槃。我当云何分别了知声闻禁戒缘觉禁戒菩萨禁戒。世尊。说我于持律中为最第一我今不知毗尼方便。云何当说。今者多有大比丘僧诸菩萨僧。唯愿如来具示广说。佛言。善哉善哉。优波离。至心谛听善思念之。当为汝说。优波离。声闻戒因缘异。菩萨戒因缘异。声闻戒心异。菩萨戒心异。声闻戒庄严异。菩萨戒庄严异。声闻戒方便异。菩萨戒方便异。优波离。声闻戒净非菩萨戒净。菩萨戒净非声闻戒净。声闻之人乃至一念不求于有名声闻戒净。菩萨若不求于有者名大破戒名不净戒。声闻求有是名破戒名不净戒。优波离。菩萨摩诃萨于无量劫常处有中。心不生悔名菩萨戒净。非声闻戒净。以是义故。优波离。汝应宣说。声闻戒急菩萨戒缓。声闻戒塞菩萨戒开。声闻戒中应说因缘。菩萨戒中则不应说。优波离。菩萨之人随众生心非声闻也。是故菩萨于戒小缓声闻护急。优波离。菩萨若于晨朝犯戒。犹故应念阿耨多罗三藐三菩提。自知罪过昼夜三时皆应如是。是名菩萨戒。优波离。菩萨若时时犯不名破戒。声闻若时时犯。是名破戒。是名失戒。是名不得沙门道果。何以故。声闻之人为坏烦恼勤行精进不应毁犯。优波离。菩萨若于恒河沙等劫受五欲乐。亦不失于菩萨禁戒。不名破戒。不名失戒。不名不得菩提之果。优波离。菩萨不能于一世中尽诸烦恼。当以方便渐渐令尽。优波离。阿耨多罗三藐三菩提要须无上大庄严力。然后乃得非一世得。是故如来不说菩萨于生死中而生悔心。亦不宣说永断贪爱。为说喜法甚深法无疑法空法。闻是法已乐于生死。优波离言。世尊。犯有三种。一者贪。二者嗔。三者痴。菩萨所犯何者为重。何者为轻。佛言。优波离。若诸菩萨犯如恒河沙等贪。如是菩萨不名毁戒。若犯一嗔因缘毁戒。是名破戒。何以故。优波离。嗔恚之心能舍众生。贪爱之心能护众生。若爱众生不名烦恼嗔舍众生名重烦恼。优波离。是故如来于经中说。贪结难断不名为重。嗔恚易断名之为重。优波离。难断非重。菩萨常有易断重者。乃至梦中尚不为之。优波离。愚痴菩萨无有方便怖畏犯爱。菩萨有智善知方便。怖畏犯嗔不畏犯爱。尔时文殊师利白佛言。世尊。毗尼者名为调伏。一切法性毕竟是调。如来何故宣说毗尼。文殊师利。若凡夫人能知诸法毕竟调者。如来终不宣说毗尼。以凡夫人不知不解。是故如来为说毗尼。文殊师利。汝今何故不说毗尼。优波离欲得闻之。时文殊师利语优波离。优波离。一切诸法毕竟调伏。一切诸法性不可污。一切诸法性无颠倒。一切诸法其性清净。一切诸法不可宣说。一切诸法无有取着。一切诸法不去不来。一切诸法不可思议。一切诸法无有障碍。一切诸法本无有性。一切诸法无行。一切诸法不出不灭。一切诸法无有三世。一切诸法无有疑网。如是等法佛悉觉知。优波离言。世尊。如文殊师利所说非了了说。佛言。优波离。文殊师利常乐宣说如是解脱。优波离言。世尊。云何名憍慢。若菩萨言。我有菩提心。我为菩提行六波罗蜜。我为般若修造诸行。菩提行深声闻行浅。菩提行净声闻行不净。菩提行毕竟。声闻行不毕竟。若复分别是声闻法是缘觉法是菩萨法是诸佛法。此名为净。此名不净。是名为道。是名非道。是名菩萨憍慢

    菩萨地善行性品第二

菩萨摩诃萨修集圣行行于善果。菩提之道有十法。则能摄取一切善法。何等为十。一者支。二者翼。三者净心。四者行。五者有。六者因。七者器。八者地。九者方便。十者住。云何名支。谓菩萨性。菩萨性者谓初发心及三十七品。何以故。菩萨摩诃萨发菩提心。乃是一切善法根本。是故名支。因此发心得阿耨多罗三藐三菩提。是故名因。因初发心决定必得。阿耨多罗三藐三菩提。是故名性。菩萨摩诃萨因初发心故。得修行檀波罗蜜尸波罗蜜羼提波罗蜜毗离耶波罗蜜禅波罗蜜般若波罗蜜。行六波罗蜜故。则得修行智慧庄严福德庄严修三十七助道之法。是故菩萨发菩提心名之为支。菩萨摩诃萨随发心行具足得阿耨多罗三藐三菩提。是故名支。菩萨摩诃萨若无菩萨性者。虽复发心勤修精进。终不能得阿耨多罗三藐三菩提。是故当知非因发心勤修精进有菩萨性。以是义故菩萨性者名之为支。菩萨虽有菩萨之性若不发心勤修精进。则不能疾成阿耨多罗三藐三菩提。有菩萨性发菩提心勤修精进故。则能疾得阿耨多罗三藐三菩提。以是义故。菩萨性者名之为支。又复支者名因。亦名为梯。亦名增长。亦名庄严。亦名依凭。亦名次第。亦名进行。亦名室宅。以是义故。性名为支。云何名性。性有二种。一者本性。二者客性。言本性者。阴界六入次第相续无始无终法性自尔。是名本性。言客性者。谓所修集一切善法得菩萨性。是名客性。而此经中以是二种名之为性。是二性者名之为支。又复性者亦名为子。亦名为界。亦名为性。复有二种。一细二粗。所言细者无因而得。无因得果故名为细。所言粗者有因而得。从因得果故名为粗。菩萨摩诃萨具足如是二种性者。胜于一切声闻缘觉。况诸外道。以是义故。菩萨摩诃萨得名为胜。何故名胜。以清净故。清净有二。一净智障。二净结障。声闻缘觉净结障故名为净非净智障。菩萨摩诃萨具足二净。以是义故。菩萨性者得名为胜。菩萨摩诃萨复有四事胜于声闻辟支佛等。一者根胜。二者行胜。三方便胜。四得果胜。言根胜者。菩萨摩诃萨本性猛利。缘觉性中声闻性钝。是名根胜。言行胜者。声闻缘觉为自度故修集善法。菩萨之人不自为己。但为众生修集善法。施众安乐大悲怜殷。是名行胜。方便胜者。声闻缘觉唯能了知阴界诸入。不能了知十二因缘及处非处。菩萨方便则能善知一切诸法。是名方便胜。言果胜者。声闻自得声闻菩提。缘觉自得缘觉菩提。菩萨自得菩萨菩提。是名果胜。菩萨性者有六种印。以是印故一切众生则得识知此是菩萨。何等为六。所谓檀波罗蜜乃至般若波罗蜜。以何义故。檀波罗蜜名菩萨性印。菩萨摩诃萨本性能得如是舍心。于诸财物若多若少心不贪着。欲施施时及行施已。悉生欢喜随所施物。若多若少心无疑悔。若少施时亦无羞愧。若无财时常赞叹施。见有悭者能破其心。见行施者心生欣庆。欢喜踊跃如见父母。见来求者深自庆幸。若无财物应以身业供给长老父母诸师。应以喜语软语法语实语正语。除破众生妄语两舌恶口无义语。若有人问犹不说人长短过失。况于无问而自说耶。若有众生怖畏王贼水火之难能为救解。知恩念恩受恩能报。受他寄付不令他疑。若是重宝心不贪着。于己物中心无吝惜。能食能衣惠施于人。能调欲心耽湎之心调戏等心贪伎乐心修集惭愧。虽获大宝不生贪喜。是名檀波罗蜜菩萨性印。云何尸波罗蜜菩萨性印。菩萨摩诃萨身口意业性自净软。于众生中不起恶心恚害之心。若因客尘诸烦恼等造作众罪。作已心悔深生惭愧发露忏悔。于诸众生起怜愍心作一子想。终不以手若杖若石加于一切。心常求觅真善知识。志乐供养父母师长耆旧宿德。破坏憍慢先意问讯知恩念恩。若有乞者软语慰喻。不以幻术诳惑众生。终不乐以非法活命。常喜修集一切功德。教诸众生广修福业。见诸众生所受诸苦。断其命根打缚闭系饥渴寒热。菩萨尔时观彼受苦如己无异。护持佛戒乃至轻微尚不故毁。况余重者。能以十善教化一切。不乐见闻诸恶众生斗诤骂詈。所有三业常为众生终不自为。若有众生具戒忍慧。乐与同行得柔软心。无有害心无不忍心。心常敬重所有诸戒。不诳众生无有两舌及无义语。虽无问者尚赞人善。况有问者而当不说尊重宗敬正实之语。是名尸波罗蜜菩萨性印。云何羼提波罗蜜菩萨性印。菩萨摩诃萨观诸众生。若有来打我是身者。我则不应加恶报之。何以故。我身非身。所谓身者名为真实。真实之身则不可打。而我此身是和合身。和合身者所谓不净。于和合中少分见打多无所损。多无所损何故不喜。嗔者少分有嗔多分不嗔。多不嗔故云何名嗔。若和合打和合受者谁打谁受。譬如二物相触出声。若我嗔者应当自嗔。何以故。以业缘故而得此身。以是身故受是楚毒。譬如有的箭则着之。我若增长是嗔心者。则不能观善恶等法。若不能观善恶法者。必定当堕三恶道中。以是义故若打若骂不应于他生嗔恨心。如是观已。是名羼提波罗蜜菩萨性印。复次若见有打骂者。应于是人生一子想心无怨恨。是名羼提波罗蜜菩萨性印。云何毗梨耶波罗蜜菩萨性印。菩萨摩诃萨勤修精进。晨起夜寐不乐眠卧。终不观于寒热饥渴恐怖欢喜。凡所造作若是世事及出世事。要令究竟终不中废。事若未果终不中悔。虽得他人恭敬供养。于己所修不休不息。于自己身不起轻心言不能得阿耨多罗三藐三菩提。虽见世间难为之事终不退缩。是名毗梨耶波罗蜜菩萨性印。云何禅波罗蜜菩萨性印。菩萨摩诃萨至心乐观诸法实义。乐住寂静及无人处。乐离恶人增长善法。见乐静者欢喜恭敬。虽有烦恼本性轻微。所有善心终不为于诸恶觉观之所破坏。修集慈心视怨如子。若见众生受大苦恼生于悲心。随其己力而为除断。愿诸众生悉令安隐。身设受苦不生忧恼。若失身命及以财物。若系若缚若打若摈。能自晓喻不失正念生于忧苦。专心听法书写受持读诵解说。若他忘失能为诲示。以如是等至心因缘。于后世中不忘法界。是名禅波罗蜜菩萨性印。云何般若波罗蜜菩萨性印。菩萨摩诃萨了知一切世间之事。知诸方术及诸众生所有言说。虽知此事心不迷谬亦不放逸。不为外道之所诳惑。不随邪见所说义理。是名般若波罗蜜菩萨性印。我今粗略说粗印相。后细印相诸佛所知。菩萨性者不可思议。成就具足诸功德事。清净真实具足净法。是故名上。亦名不动。亦名阿耨多罗三藐三菩提印。菩萨摩诃萨若不睹见恶法过患。则不得修一切善法。菩萨摩诃萨修上善时。若以客尘烦恼因缘堕三恶道。犹故胜于恶道众生。何以故。菩萨性故。若以客尘烦恼因缘堕恶道者。能速破坏疾得出离。如其不出不同恶道受于重苦。若受苦时于诸众生犹生大悲。以性因缘故得悲心。是故菩萨胜于一切三恶众生。菩萨摩诃萨以四烦恼因缘故破坏净法。何等为四。一者利重常恒。二者以是二结亲近恶友。三者若于师所王主怨贼而生怖惧故失善心起于烦恼。四者为身命故作诸恶法。以是四法虽有菩萨摩诃萨性。终不能得阿耨多罗三藐三菩提。复有四事。虽有菩萨摩诃萨性。亦不能得阿耨多罗三藐三菩提。何等为四。一者不值善友佛及菩萨不谬说义者。二者虽值善友佛及菩萨。错谬解义不学菩萨所有禁戒。三者虽值善友佛及菩萨随顺解义。不能学持菩萨禁戒。四者虽值善友佛及菩萨随顺解义学菩萨戒。善根未熟未得具足庄严菩提。是故不得阿耨多罗三藐三菩提菩萨虽有菩萨之性。若不具足如是四事。终不能得阿耨多罗三藐三菩提。虽复具足如是四事。无菩萨性而能得成阿耨多罗三藐三菩提者。无有是处

    菩萨地发菩提心品第三

菩萨摩诃萨初发心时立大正愿。作如是言。我得阿耨多罗三藐三菩提时。当大利益一切众生。要当安置一切众生大涅槃中。复当教化一切众生悉令具足般若大智。是则名为自利利他。是故初发菩提心者。则得名为菩提因缘。众生缘因。正义缘因。三十七助道法缘因。摄取一切善法根本。是故菩萨名善大善。名实真实。亦名一切众生善根。能破一切身口意等三业诸恶。一切世间所有誓愿及出世愿。无有能胜阿耨多罗三藐三菩提。如是誓愿无胜无上。菩萨摩诃萨初发三菩提心有五事。何等为五。一者性。二者行。三者境界。四者功德。五者增长。是名为五。菩萨若能发菩提心。则得名为菩萨摩诃萨。定得阿耨多罗三藐三菩提修大乘行。是故初发菩提之心。则能摄取一切善法。菩萨摩诃萨发菩提心随行渐得阿耨多罗三藐三菩提。若不发心终不能得。是故发心是阿耨多罗三藐三菩提根本。菩萨摩诃萨见苦众生心生怜愍。是故菩萨因慈悲心发阿耨多罗三藐三菩提心。因菩提心修三十七品。因三十七品得阿耨多罗三藐三菩提。是故发心名之为支。发菩提心故行菩萨戒。是故发心为菩萨戒支。是故发心名根名因名摄名果亦名为子。菩萨发心复有二种。一者毕竟。二者不毕竟。毕竟者乃至得阿耨多罗三藐三菩提终无退失。不毕竟者则有退失。退有二种。一毕竟退。二不毕竟退。毕竟退者。终不发阿耨多罗三藐三菩提心。不能推求修集其法。不毕竟者求菩提心修集其法。是菩提心有四种因。何等为四。一者若善男子善女人。若见若闻诸佛菩萨不可思议。尔时则生信敬之心。作是念言。佛菩萨事不可思议。若佛菩萨不思议事是可得者。我亦当发阿耨多罗三藐三菩提心。是故至心念于菩提发菩提心。二者复有不见诸佛菩萨不思议事。唯闻诸佛菩萨秘藏。闻已即生敬信之心。得信心故为阿耨多罗三藐三菩提。及大智故发菩提心。三者复有不见诸佛菩萨不思议事。亦不闻法见法灭时。便作是念。无上佛法能灭众生无量苦恼作大利益。唯诸菩萨能令佛法久住不灭。我今亦当发菩提心。令诸众生远离烦恼诸大苦事。护持佛法久住于世。为住世故发菩提心。四者复有不见佛法灭时。唯见恶世诸众生等。具重烦恼贪恚痴等。无惭无愧悭吝嫉妒。愁忧苦恼不信懒惰。见是事已寻作是念。大恶世时众生大恶不能修善。如是恶时尚不能发二乘之心。况阿耨多罗三藐三菩提心。我今当发菩提之心。发是心已乃当教化一切众生令发阿耨多罗三藐三菩提心。是故菩萨于此恶世恶众生中发菩提心。复有四因发菩提心。何等为四。一者性具足。二者善友具足。三者慈心具足。四者观生死苦具足圣行。不畏菩提难行苦行。性具足者。菩萨性自具足善友具足有四事。何等为四。一者善友诸根完具具大智慧。能示善恶不行邪道。是名善友具足。二者心不放逸能破放逸能闭恶道。三者自能具足菩萨禁戒转以教他。四者不以下道转他上道。不以小乘转他大乘。不以修福转他定慧。具足慧心复有四事。何等为四。一者或有世界有苦恼处。或有世界无有苦恼苦恼之处。菩萨发愿往生其中。或见受苦若身自受。生于慈心为破其苦。二者生地狱中。或见受苦若身自受。亦生慈心为破其苦。三者生饿鬼中。或见受苦若身自受。亦生慈心为破其苦。四者生畜生中。或见受苦若身自受。亦生慈心为断其苦。具足慈心复有三种。谓上中下。上者复有四事。一者观生死苦。二者修慈悲心无有终始。三者性勇健心。四者得智慧心。复有四事。何等为四。一不放逸。二具足戒。三能忍辱。四者至心专念阿耨多罗三藐三菩提。复有四事。何等为四。一者等视众生犹如一子。二者于怨亲中无有分别。三者得坚信心。四者修行圣行。是为四。修集慈心有四种力。何等为四。一者内力。二者外力。三者因力。四者庄严力。菩萨摩诃萨至心专念阿耨多罗三藐三菩提。是名内力。为欲化度诸众生故发阿耨多罗三藐三菩提心。是名外力。能于无量阿僧祇劫修集善行。师事诸佛及诸菩萨。是名因力。菩萨摩诃萨乐近善友听受正法。思惟其义如说修行。是名庄严力。若菩萨摩诃萨以是二力发阿耨多罗三藐三菩提心。是名正心不动心不退心不转心。所谓内力因力。若以外力及庄严力。发菩提心。是名不正心动心退心转心。菩萨转心有四因缘。何等为四。一者性不具足。二者恶友具足。三者于诸众生不具悲心。四者不能观察生死过患。菩萨摩诃萨初发菩提心有二事不可思议。何等为二。一者于诸众生作眷属想。二者无众生想。菩萨常以智慧观察。唯是众生众生属谁。是名为二因。是二心能令菩萨无有退转。初发菩提有二种心。何等为二。一者为施众生安隐。二者为施众生快乐。以诸善法化诸众生令离恶法。是名安隐。能以财物账。给众生令离贫穷。所谓衣食房舍卧具病瘦医药。是名快乐。不退菩萨有二种心。何等为二。一者性庄严。二者专心受持庄严。常念欲令众生安乐。是名性庄严。终不退转菩提之心。因是至心能施一切众生安乐。是名受持庄严。不退菩萨出生福德有二处。何等为二。一者菩提之心。二者众生受苦。如是二事名大善法聚。初发坚心菩萨又有二事。胜于一切声闻缘觉。何等为二。一者因胜。二者果胜。菩萨摩诃萨发菩提心所修善法。是名为因。因行善法得阿耨多罗三藐三菩提。是名为果。如是因果胜于一切声闻缘觉。不退菩萨有二大事。何等为二。一者发是心已即为一切无量众生而作福田。为作父母师长和上生大怜愍。以怜愍故行住坐卧若眠若寤。常为诸天之所守护。如转轮王常为五百青衣鬼神之所守护。不退菩萨亦复如是。以怜愍故若更受身无有病苦。二者发心菩萨常为众生之所乐见犹如父母。一切众生于菩萨所。身口意业柔软无恶是名为二。菩萨摩诃萨发菩提心不失正念。于诸众生不起害心。不食肉。不欺诳。常以善法教化众生。众生不受不废不愁。能自调伏。亦能调他。随其所化众生之处。皆悉能令滋长福业。若以客尘烦恼因缘。堕三恶道能速得出。虽同受苦不生楚毒。见受苦者心生悲愍。菩萨初发菩提心者。成就如是无量功德

    菩萨地利益内外品第四

菩萨摩诃萨发菩提心。云何名为菩提之行。菩萨若于此彼之处若学若教。皆为阿耨多罗三藐三菩提。谓戒闻思惟是名菩提行。菩萨摩诃萨于何处学。学有七处。何等为七。一者内义。二者外义。三者真实义。四者不可思议义。五者调众生义。六者自熟佛法义。七者得阿耨多罗三藐三菩提。是名为七。云何内义。内义有十。何等为十。一者真实义。二者为他义。三者调伏义。四者安隐义。五者快乐义。六者因义。七者果义。八者现在义。九者他世义。十者毕竟义。菩萨摩诃萨为他事故。是名内义。真实义者。知烦恼性及对治门。以己乐具施于众生。志常修集无上正道。凡所求索以安众生。既得财物心无贪吝。能以供养佛法众僧父母师长。于千万里求佛经典及菩萨藏。既得法已广令流布不生秘吝。虽解深义不生高心。为生天上说持戒利。为转轮王说布施德。为二乘道说修三昧。为得世间大果报故。教令供养佛法僧宝广修福业。为贪心者而说贪事。为欺诳者说欺诳事。为非法人而作僮仆。菩萨摩诃萨作是事已。是名真实义。菩萨摩诃萨所有自利悉为众生。是名他义。菩萨摩诃萨凡所演说。悉为破坏众邪异见。谓无因果破戒之人不见过故。为说种种毁禁之过。为破三恶而演说法。若有退禅及善法者。为不退故而为说法。为欲增长诸善法故而为说法。欲令众生得自在故而为说法。欲令十方世界众生得善神足而为说法。是名调伏义内义者名为外义。外义者亦名内义。内外义者名调伏义。调伏义者亦名内外义。如来十力四无所畏十八不共法大悲三念处五智三昧。是名真实义。真实义者名内外义。内外义者有二种。何等为二。一者自调。二者调他。菩萨摩诃萨善知方便。是名调伏义。菩萨所行一切善行名调伏义。云何复名内外义。内外义者有五事。何等为五。一者净于他身。二者长他善法。三者现在利益。四者他世利益。五者坏他烦恼。若菩萨摩诃萨随所修善若多若少。以教众生同己所得。是名调伏义。菩萨摩诃萨既自安隐。复己安隐施于众生。所谓若出世及以世间。若欲界若禅定。是名安隐义。安隐义者亦名内外义。亦名调伏义。亦名真实义。菩萨摩诃萨内外义者。有现在乐非他世乐。有他世乐非现在乐。有现在他世乐。有非现在非他世乐。内外义者复有四种。有人受法现世受乐他世受苦。有人受法现世受苦他世受乐。有人受法现世受乐他世亦乐。有人受法现在受苦他世亦苦。菩萨摩诃萨若说涅槃及大涅槃八圣道分三十七品。说世间道出世间道。是名安隐义。安隐义者名内外义。内外义者名为正义。正义者名无上义无胜义安隐义常乐义。菩萨摩诃萨受常乐者。能作内外义正义调义安隐义。云何名快乐义。快乐义者有五种。何等为五。一者因乐。二者受乐。三者断受乐。四者远离乐。五者菩提乐。云何因乐。因内外触。因触因缘故有受乐。是名因乐。因行善法得他世乐。是名因乐。云何受乐。从因因缘身得增长心得安隐。是名受乐。受乐者有二种。何等为二。一者有漏。二者无漏。无漏有二种。一者学地。二者无学。有漏有三。欲界色界无色界。三有有内外入故有六触。六触有二。一者身乐。二者心乐。五识共行名为身乐。意识共行名为心乐。修集圣道断诸受故。道德增长无有诸受。名断受乐。永离烦恼身心无患。名远离乐。受常乐故。名菩提乐。或有说言。无想定者名为断乐。是义不然。何以故不断受故。远离乐者有四种。一者出家乐。二者寂静乐。三者断乐。四者菩提乐。世间之人多有忧苦。永断是苦名出家乐。断欲界贪名寂静乐。永断烦恼名为断乐受常乐故名菩提乐。菩萨常能施众生乐。名菩提乐。菩萨摩诃萨自受常乐转施众生。名菩提乐。何故名因乐。是乐因故名为因乐。不名受乐。受乐者不名因乐名为性乐。断乐者不名因乐不名受乐。以断多乐故名为断乐。远离乐者不名因乐不名受乐不名断乐。以观生死众过患故。名智慧乐。菩提乐者不名因乐不名受乐不名断乐不名离乐。无边常故名菩提乐。名无胜乐。名无边乐。名无上乐。亦名常乐。名寂静乐。菩萨摩诃萨能以如是五种之乐施于众生。是名因义。菩萨摩诃萨常坏众生诸恶之业示以正业。以正业故得无上道。是名因义。菩萨摩诃萨为众生故受大苦恼。以受苦故能调众生。是名因义。菩萨摩诃萨观察善恶。能示众生善恶之事。以开示故得大智慧。得智慧故能坏大恶。是名因义。菩萨摩诃萨因智慧故行六波罗蜜。乃至得阿耨多罗三藐三菩提。是名果义。菩萨摩诃萨以坏贪心。坏贪心故能施众生五种之乐。而诸众生得是乐故。名为果义。菩萨摩诃萨怜愍众生。欲令一切同已受乐。是名内外义。内外义者有三种。因亦三种。果亦三种。报因报果。福因福果。智因智果。云何名报。报有八种。何等为八。一者长寿。二者受身完具。三者得上种姓。四者得自在。五者言语微妙。六者得男子身。七者得大力。八者无能胜者。是名为八。菩萨摩诃萨修集慈心故得长寿。是名因报。菩萨摩诃萨乐以衣食房舍卧具病瘦医药施于众生。是故获得具足之身。菩萨摩诃萨破憍慢心。供养恭敬父母师长有德之人。是故获得上族种姓。菩萨摩诃萨随法而行破于非法。是故获得自在无碍。菩萨真实不欺众生。是故获得言语微妙。菩萨摩诃萨常呵五欲。是故获得男子之身。菩萨摩诃萨常乐供养佛法僧宝。是故其身获得大力。菩萨摩诃萨常能教化一切众生供养三宝。是故能得无能胜者。是名果报。不害众生。命得增长。是名报因。乐以衣食房舍卧具病瘦医药施于众生。是故菩萨得具足身。能破众生所有憍慢故得上姓。能除众生贫穷困苦故得自在。能坏众生妄语两舌恶口无义语故得妙语。赞叹男身呵责女身。以是二因得生人中受男子身。又复远离非法欲故得男子身。菩萨摩诃萨以清净食施于众生。见危惧者能为救解。是故其身获得大力。受持正法读诵解说。是故能得无能胜者。是为报有八种。如是八种因三事故而得增长。何等为三。一者心净。二者庄严净。三者福田净。菩萨摩诃萨至心专求阿耨多罗三藐三菩提。是名心净。供养同学同法同师。是名心净。若见若闻同学同法。心生欢喜。是名心净。修集菩提助道之事。常乐受持书写读诵菩提法藏。复以此法转化众生。若有不受心不忧悔亦不休息。是名庄严净。以此二净名福田净。云何菩萨报果。菩萨长寿名为报果。菩萨何故求于长寿。菩萨得是寿命长故。经无量世修集善法为自利利他。是故菩萨求于长寿。是名报果。菩萨何故求身具足。菩萨得是身具足故。众生乐见爱敬欢喜。以欢喜故易得受化。是故菩萨求具足身。是名报果。菩萨何故求上种姓。上种姓故常为众生之所恭敬。以恭敬故信受其语。或为姓故。或为利故。或为畏故。复受其语。是故菩萨求上种姓。是名报果。菩萨何故求于自在。得自在故则能教化无量众生。具足成就檀波罗蜜。是故菩萨求于自在。是名报果。菩萨何故求微妙语。妙语者菩萨所出言辞众生乐闻。同法同义同行同师常能教化令其调伏。是名报果。菩萨何故求于男子身。男子之身乃是一切善法之器。堪忍众苦能观法界。于四众中无所畏难。于时于义能疾了知。随有所至无所挂碍。是故菩萨求男子身是名报果。菩萨何故求于大力。菩萨成就是大力者。则能修行一切善法。能勤精进救拔众生烦恼诸苦。是故菩萨求于大力。是名报果。菩萨何故求于无胜。菩萨若得是无胜者。则能惠施一切众生所须之物。以是因缘能令众生乐见闻法信受其语。是故菩萨求于无胜是名报果。是八报果菩萨具者。则能长养无上佛法利益众生。则见佛道如观掌中庵摩勒果。菩萨虽复具足成就如是八果。若不能化无量众生令调伏者。则不能得阿耨多罗三藐三菩提。虽复教化令其调伏。若不具足如是八果。亦不能得阿耨多罗三藐三菩提。菩萨摩诃萨成就具足如是八果。以三乘法教化众生。自得阿耨多罗三藐三菩提。菩萨摩诃萨所以具足如是八果。为欲教化调伏众生。名内外义具八果者名为果义。报因报果亦名果义。云何为福。云何为智。三波罗蜜。所谓檀那尸罗羼提。是名福德。般若波罗蜜。是名智慧。余二波罗蜜亦名福因。亦名智因。若勤精进修集禅定。具足成就慈悲喜舍。以是四等因缘力故获得自在。是名福因若勤精进修集三昧。深观五阴诸入诸界。观苦实苦。观集实集。观灭实灭。观道实道。观实非实。观善非善。观法非法。观上观下。观白观黑。观十二缘。是名智因。若勤精进修集一心。乐喜惠施。乐持禁戒。乐修忍辱。是名福因。若勤精进修集一心。乐闻受持书写读诵解说菩萨秘藏经典。以是多闻因缘力故。得大智慧而能分别法界。分别法界是名智果。菩萨福因亦因亦果。菩萨智因亦因亦果。菩萨福因亦福亦智。菩萨智因亦智亦福。是故菩萨福因有六。智因亦六。何等为六。谓六波罗蜜。云何名为福因智因。福因智因有三种。何等为三。一者信心。二者发心。三者亲近善友。是为三福因。智因复有二种。一者善。二者不善。若近恶友修集邪道行施定慧名不善福。破坏如是不善福慧。是名善福。若无信心及以发心不亲善友。终不能得福德智慧若言远离如是三事得福慧者。无有是处。是名福德因智慧因。云何名为福果智果。菩萨摩诃萨成就如是具足福德。不为生死之所沾污。是名为果。菩萨成就具足智慧。远离恶道修集善道。是名为果。菩萨摩诃萨成就具足如是二事。教化众生成阿耨多罗三藐三菩提。是名为果。四无量心亦是菩萨福果智果。菩萨摩诃萨若报因若报果。是名福德福德因福德果。亦名智慧智慧因智慧果。若有说言是二法中若离一法得阿耨多罗三藐三菩提者。无有是处。是名果义。果义者名内外义。云何现在义。若菩萨摩诃萨遍学一切世间诸事。以遍知故得大自在。得自在故能化众生。众生受已修集善法。是名现在义。若菩萨摩诃萨退失善法修集三昧以修定故还得善法。是名现在义。若菩萨摩诃萨客尘烦恼故造作众罪。作已深观定当得果。即生悔心惭愧不作现坏恶业。是名现在义。若以恶业因缘力故。或为他骂或嗔恚打身受楚毒。名现在义。若菩萨摩诃萨修集禅定。以是因缘身受安乐。是名现在义。若菩萨摩诃萨身得自在常乐我净。是名现在义。若菩萨摩诃萨修八圣道。以是因缘获得涅槃。是名现在义。如菩萨众生亦尔。云何他世义。以现因缘受他世身。是名他世义。现在他世义是名内外义。云何为毕竟义。欲界福德非毕竟义。色无色界世间福德虽得自在非毕竟义。如诸菩萨修八圣道获得涅槃。其身无碍无有边际。善法无量名毕竟义。毕竟有三事。何等为三。一者性毕竟。二者退毕竟。三者报尽毕竟。不毕竟亦尔。性毕竟者是名涅槃性。不毕竟名有为法。退毕竟者名声闻缘觉所修八道。不退毕竟者名阿毗跋致。报尽毕竟者世间所有福德果报。报不尽毕竟者谓无上道果。是名十义。菩萨摩诃萨常应修集教化众生。如过去世诸菩萨学。现在未来亦复如是。若菩萨摩诃萨不能修学是十法者。则不能得菩萨禁戒

菩萨善戒经卷第一菩萨善戒经卷第二

        宋罽宾三藏求那跋摩译

    菩萨地真实义品第五

云何名真实义。真实义者有二种。一者法性。二者法等。复有四种。一者世流布。二者方便流布。三者净烦恼障四者净智慧障。云何名世流布。世间之法同其名号。众生见地真实是地终不言火。火真实火不言是地。水风色声香味触衣服饮食璎珞器物伎乐明闇男女舍宅田业苦乐。苦真实苦终不言乐。乐真实乐终不言苦。此是此非定以不定。一切世间从昔已来。传此名相自然而知。不从修集然后知也。是名世流布真实义也。云何名方便流布。如世智人先以筹量。然后造作经书论议。是名方便流布。云何净烦恼障。一切声闻辟支佛等。以无漏智无漏道坏烦恼故得无碍智。是名净烦恼障。以坏烦恼故智得明净。智慧净故身心无碍。是名净智慧障真实义也。云何复名真实。真实者名为四谛。所谓苦集灭道。观此四谛得实智慧。是名声闻辟支佛。声闻辟支佛分观五阴。是故离阴都不见我及以我所分观十二因缘。是故离阴不见众生及以士夫。是名净智慧障真实义也。若智不能知境界者。名曰智障。若能坏障知境界者。名净智障真实义也。真实义者。谓佛菩萨深观一切阴入界故观我无我。众生非众生。士夫非士夫。是名净智障。观诸法界不可宣说。知世谛故分别法界。知诸法界真实性故。名无胜慧。无胜慧者坏一切障。是故名为净智慧障真实义也。真实义者复有二种。一者有。二者无。有者名世流布。世流布者。所谓色受想行识。眼耳鼻舌身。地水火风。色声香味触。善不善无记。出法灭法从缘生法。去来现在有为无为。此世他世日月。见闻识知所得觉观。修集受持乃至涅槃。是名世流布有也。世间有者所谓法性。无者世流布有。从色乃至涅槃其性无故是名为无。众生见故名之为有。法性本无名之为无。诸佛如来所说有无名之真实。真实者名为中道。非有非无名为中道。中道者名无上道。如是中道诸佛世尊除坏障碍。是故名之为一切智。菩萨摩诃萨虽学如是中道犹有障碍。是故不得为一切智。菩萨智慧为方便故。名阿耨多罗三藐三菩提因。何以故。菩萨摩诃萨虽不具足中道智慧。说生死相亦有亦无亦为流布无上佛法。虽在生死亦能了了知生死过患心无厌悔。如其不知生死过者。则不能得坏烦恼结。若心厌者则不能得教化众生护诸佛法疾得涅槃。若得涅槃则不能得阿耨多罗三藐三菩提。若不教化诸众生者。云何能得阿耨多罗三藐三菩提。是故菩萨若在生死之中修菩提道。不畏涅槃不求涅槃。菩萨若畏于涅槃者。则不能得具足庄严菩提之道。亦不能为无量众生赞叹涅槃。于涅槃所不生信喜专念之心。是故菩萨于涅槃所不生怖畏。若是菩萨求涅槃者即能得之。如其得者则不能成阿耨多罗三藐三菩提。以诸佛法教化众生。若是菩萨不能深观生死过患。或生厌离怖畏涅槃。或求涅槃。是名菩萨无善方便。若是菩萨能深观察生死过患乐处其中。不畏涅槃不求涅槃。是名菩萨有善方便。善方便者解第一义空。菩萨摩诃萨修集如是第一义空。名菩萨戒大方便也。为得如来无上智故。若有修集是菩萨戒得真实智。知见诸法无我我所知诸法性。是故于法心无所著。亦说世谛第一义谛。见一切法其心平等。能大惠施。以施因缘善知世事。虽学世事心不厌悔。悉得了知得大念力。虽知世事心无憍慢。常教众生不生悭吝。以巧方便善教众生世间之事。为令众生得阿耨多罗三藐三菩提故。菩萨于是世间之事。勤心修集无有厌悔。若见众生受苦恼时。即得增长阿耨多罗三藐三菩提心。菩萨如是增长善法不生憍慢。于诸众生生怜爱心。菩萨如是增长智慧不生憍慢。破坏众生种种邪见。菩萨若得世间三昧出世三昧。不显己德令他供养。不为世法之所污染。菩萨尔时成就具足无量功德。名菩萨戒。菩萨摩诃萨所有善法。悉以回向菩提之道。名菩萨戒。过去菩萨得阿耨多罗三藐三菩提。皆由成就菩萨禁戒。未来现在亦复如是。菩萨摩诃萨受持三世诸菩萨法。能以佛法教化众生。至心修行菩提之道。为菩提道不惜身命。不惜身命是菩萨戒。惜身命者终不能得菩萨禁戒。乃至吝惜一钱之物。亦不能得菩萨禁戒菩萨摩诃萨为众生故受身畜财。若于是二生吝惜心。假名菩萨非义菩萨。菩萨若能不惜财命。当知则能利益众生。能行忍辱能坏嗔恚嫉妒之心。了知世事善解方便。能坏众生所有疑心。能自增长菩提果因。善能调伏所有诸根。不为四倒之所倾动。能解诸法甚深之义。能得具足四无量心。成就五通四无碍智。毕竟能观十二因缘。逮得菩萨一子之地。能得常乐我净之身。得大自在无上涅槃。善能开示方便涅槃。菩萨摩诃萨成就如是无量功德。皆因禁戒因缘而得。菩萨摩诃萨成就具足菩萨戒者。能为一切众生仆使。若为众生之所嗔骂打害劫夺则生慈心。若见众生厚重烦恼发怜愍心。为欲破坏众生烦恼。系心思惟诸善方便。于诸众生心无奸曲。任力所能施众生乐。不求恩报不怀嗔恨。为坏众生嗔恼心故。思惟方便知恩念恩。无有求者先意行施。若己所有不施求者。不得成就菩萨禁戒。求者三至若不施者。是名犯重。不犯者。若以方便善语慰喻。令彼求者不生恨心。求者二种。一者贫穷。二者邪见。不施贫者则便得罪。不施邪见则不名犯。若不犯者是名善行。善行菩萨谛知法界不可宣说。知法界性知世流布。世流布者。色受想行识乃至涅槃。色乃至涅槃不名真实。何以故。而是色者非有非无。乃至涅槃非有非无。若非有无云何真实。云何非有。众生颠倒计色为我。乃至涅槃横计为我。是名非有。云何非无。世流布故。不虚诳故。可宣说故。是名非无。以是故名非有非无。如所说法如说有者。一法之中应无量名。无量名故则有无量性。何以故。一一法中有无量名故。云何名为无量名耶。如色一法。亦说青黄赤白长短方圆粗细可见不可见有对无对涩滑轻重。是名可说。随说有者。应一法中有无量相。所可宣说实无定性。以言说故流布于世。实无说者及真实性。一切诸法亦复如是。如其色中乃至涅槃有实性者。不应说有青黄赤白乃至轻重。若无实性。未流布时云何可传。以流布性有。无有初始故可流布。若未有色时有流布者。以何因缘无色之时不流布耶。如其流布能作色性者。何故流布而不能作色无量性。是故法性不可宣说。如色受想行识乃至涅槃亦复如是。有二种人远离佛法。非佛弟子永失佛法。一者说色乃至涅槃有真实性。二者不信世流布性如是二人不任受持菩萨禁戒。如其受者受者不得。师则有罪。何故不得。诽谤实法着非法故。是故虽受终不得戒。若不得戒云何得名在此法中为佛弟子。是故名为远离佛法。菩萨戒者非口所得。心口和合然后乃获。是二种人都无实心云何可得。若于色中妄生计着。于佛法中则为永失。若不信色是流布者。是则名为谤一切法。是人则为永失佛法。是故不可宣说若有若无。何以故。如因五阴则有我人众生士夫。若无五阴如是等名何由流布。色亦如是。以有色故则有种种。名字流布。真实之法无有流布。离真实法亦无流布。愚痴之人说诸法空则得大罪。若有说言大乘经中一切法空亦得大罪。不能善解大乘经义。生憍慢心言我善解。随其自心妄想思惟。为人广说亦得大罪。若言一切诸法性无云何得有流布于世亦得大罪。何以故。谤一切法故。谤一切法者即是外道富兰那等真弟子也富兰那谓诸法性无。而佛法中亦有亦无。若有人说一切法空。当知是人不中共住共语论议布萨说戒。若与共住乃至说戒则得大罪。何以故。不解空义故。是人不能自利利他。是故大乘经说。若不解空甚于痴人。何以故。愚痴之人说色是我至识是我。有我见者不坏佛法。不解空义永坏佛法破失灭没。生我见者不至三恶。不解空义为人广说。当知是人必到阿鼻。有我见者不谤三宝。妄说空者诽谤三宝。说有我者不诳众生。不谤实性。不妨法性。不妨众生。获得解脱。不教他人毁犯禁戒。不解空者谤一切法。不解实性。不解法性。妨于解脱。与多众生作恶知识。自不持戒教人毁禁。常乐宣说无作无受。令多众生增长地狱。以是义故。名为远离无上佛法。云何名为不解空义。若有比丘比丘尼优婆塞优婆夷。不信受空。不解于空。不解于法。是则名为不解空义。何以故。说一切法。本性自空无因缘空。说一切法亦无处所。若无处所云何名空。是名不解空。云何名为真解空义。若比丘比丘尼优婆塞优婆夷。说一切法中无有性故。是名为空。法亦不空是名解空。如是解者不妨于义。不谤三宝。是名正解无有错谬。云何正解。如色说色乃至涅槃。分别无有种种相性。是名色空以色真实流布于世。是名不空。以是义故。说色一法亦有亦无。解是二故亦法亦空。终不于中妄生计着。是名真解空义。是故大乘经中说偈

  一法有多名　　实法中则无
  不失法性故　　流布于世间

如色乃至涅槃则有多名。色无自性。无自性者则无多名。有多名者名为流布。以是义故杂藏中说。诸佛世尊不着流布。若见若闻思惟觉知。如色名乃至涅槃名。名为流布。诸佛世尊终不说言。有流布性而生染着。何以故。坏颠倒故。有染著者名为颠倒。如来已断一切恶见故不染着。以不见不说不染着故。名为正见。是故如来为迦栴延比丘。而作是说。迦栴延。我弟子者不着地定。水火风定。空定识定。无所有定。非有想非无想定。非此世非他世。非日非月。非见非闻。非思非量。非取非得。非觉非观。是名禅定。云何比丘不着地定。比丘于地不作地相。乃至觉观不作觉观相。是则名为不着地定。乃至觉观亦复如是。若有比丘能作如是修集定者。即为诸天释天梵天十方诸佛及大菩萨之所赞叹。南无大士。南无大士。咸作是言。我都不知汝在何定修集何定。若有染着地相地名。当知是人名不修空。若于色中不著名相。是名修空。为流布故宣说地相及以地名。若着色相及以色名名增长相。若坏色相及以色名名放舍相。不增不舍是名中道。修集如是二种相故。是名比丘修集地定乃至觉观。若有比丘修是定者。是名实相。以实相故比丘于法无所言说。以诸法性不可说故。是故比丘无所言说。若一切法无可说者。云何说不可说。若不可说云何得闻。若不说不闻。云何得知一切诸法不可宣说。以可知故说令流布。愚痴之人不知不解世流布故。于诸法中生八种谬。一者性谬。二者分别谬。三者聚谬。四者我谬。五者我所谬。六者爱谬。七者不爱谬。八者非爱非不爱谬。是八谬中初三种谬。乃是一切诸谬根本。着性著名不解流布。从此展转生无量谬。我我所谬名为我见。我见复是诸见根本。是二种谬从憍慢生。是故憍慢诸见根本。后三谬者从三毒生。是八种谬摄取一切诸结烦恼。令诸众生回转三有。云何性谬。若色作色想。乃至重作重想。是名性谬。云何分别谬。若分别色是色非色。是可见是不可见。是有对是无对。是名分别谬。云何聚谬。如于色中见我众生士夫寿命。屋舍四众军旅衣食。莲华车乘树木积聚。如是等中各作一相。是名聚谬。云何名我我所谬。于有漏中取我我所。无量世中常生取着计我我所。是名我我所谬。云何爱谬。于净物中生贪着心。是名爱谬。云何不爱谬。于不净物中生嗔恚心。是名不爱谬。云何非爱非不爱谬。于一切净不净物中生贪恚心。是名非爱非不爱谬。是名八谬。菩萨摩诃萨云何能知是八种谬。应推四事。何等四。一者推名。二者推物。三者推性。四者推分别。云何推名。菩萨摩诃萨唯知名名不见名物。是名推名。云何推物。唯知是物不知余者。是名推物。云何推性。知名流布。是名推性。云何推分别。名不见物物不见名。是名推分别。菩萨摩诃萨何故推名。知名实名是故推名。菩萨谛观。若无色名何由说色。若不说色。云何观色。若不观色。云何而得阿耨多罗三藐三菩提。是故菩萨推求知名菩萨何故推求于物若无物者谁有此名。而此名者非不可说。若不可说。云何得知诸法之性。是故菩萨推求于物。菩萨何故推求于性。菩萨摩诃萨知于色性乃至涅槃性。知色流布乃至涅槃流布。云何名为知于色性。知是色性如镜中像幻化梦影响熟时之焰水中月形。是名推性。菩萨何故推求分别。菩萨摩诃萨若分别名。分别物。分别性。分别法。分别非法。分别有无是色非色可见不可见。是名分别。以分别故得阿耨多罗三藐三菩提。是故菩萨推求分别。菩萨摩诃萨为坏八谬推是四事。菩萨何故坏是八谬。八谬因缘增长邪见。邪见增故烦恼增长。烦恼增长故生死增长。生死增长故十二因缘增长。菩萨若修如是四事断除邪见。邪见断故诸烦恼灭。烦恼灭故生死灭。生死灭故知十二因缘灭。知十二因缘灭故修无上道。修无上道故得阿耨多罗三藐三菩提。得阿耨多罗三藐三菩提故能坏众生如是八谬。能教众生知世流布说真实义。若除众生如是八谬名大涅槃。能得现世大自在故。得大神通故。得大方便故。得大禅定故。得大一切智故求得不退不堕处故。是名大涅槃。得大自在菩萨摩诃萨成就五事。一者心得寂静。二者了知世事及出世事。三者为众生故。处在生死心不愁恼。四者了知如来甚深秘藏。五者菩提之心无能坏者。菩萨何故心得寂静。能破现在众生烦恼故心得寂静。为调众生得佛法故。了知世事及出世事。为令众生得利根故。乐处生死心不愁恼。有令众生破坏疑心。受持读诵了知如来甚深秘义。法说非法能灭佛法污辱佛法。犯说非犯受畜八种不净之物。为摈如是诸恶人故。受持解说如来秘密甚深之义。虽知外道微细书论解其义趣。终不破坏菩提之心。如是五事摄取菩萨菩提之事。亦名五事。亦名五功德。何等名为菩提之事。能自利益调伏众生。受持佛法不破菩萨所修禁戒。菩提之心终不倾动。勤修精进坏邪见等说三乘道。菩萨成就如是五事有三种。谓下中上。具足二种是名为下。具足三种是名为中。若具四种是名为上

    菩萨地不可思议品第六

云何菩萨摩诃萨不可思议。菩萨摩诃萨得自在三昧。发心已得无量功德。不造作业而获果报。不修圣道而得圣心。是名菩萨不可思议。少作善业得大果报。为菩提故于无量世修诸苦行。菩萨实知无有众生。而能为之勤修苦行。知无作者及无受者。能作受者。是名菩萨不可思议。不可思议有五种。一者六通不可思议。二者法不可思议。三者共生不可思议。四者不共生不可思议。五者共不共不可思议。云何六通。神足天耳天眼他心智宿命智漏尽智。是名六通不可思议。云何法不可思议。法者所谓檀波罗蜜尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。是名法不可思议。云何神通。神通有二种。一者变。二者化。何等为变。振动出火。光明示现。自转其身。或现去来。现种种色。大众隐显。障他神通。言辞无碍。施他忆念。施众欢乐。放大光明。是名变神通。云何震动。菩萨摩诃萨得自在三昧。能动舍宅聚落村邑城郭国土。从四天下至千世界。二千世界。三千大千世界。百三千大千世界。千三千大千世界。千万三千大千世界。乃至无量无边世界。是名震动。云何出火。身上出火身下出水。身上出水身下出火。或举身出火作种种色。青黄赤白紫黑颇梨是名出火。云何光明。身出光明充遍一舍聚落村邑乃至无量无边三千大千世界。是名光明。云何示现。诸佛菩萨为度众生。示现地狱畜生饿鬼天人杂类乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。或复示现十方世界无量无边恒河沙等诸佛国土及其佛身诸大菩萨。说诸佛名令诸众生皆悉闻知。是名示现。云何为转。诸佛菩萨得自在三昧。能变地为火变火为水。风亦如是。变色为香变香为色。色香味触变为草木衣食璎珞器物石贝琉璃真珠金银等山。好色作恶恶色作好。是名为转。云何去来。或往梵处。从梵处还。或往阿迦腻吒天上复从彼还。或至东方南西北方四维上下。乃至无量无边世界皆亦如是。远能作近近能作远。能令须弥如小微尘。令小微尘如须弥山。是名去来。云何种种色。能现自身。或作男女大小僮仆树林草木。是名种种色。云何大众隐显自在。能以大众内己身中。而心不怖身无妨碍。是诸大众各不自知来往处所。或时往至婆罗门众现同其像。同色同衣形质修短。与彼无差。音声无别。彼所说者亦能说之。彼不能说亦能说之。能以方便善导其人。示已即灭彼众不知何来何灭人耶天耶。如婆罗门众刹利众大会众长者众。四天王众。三十三天众。夜摩天众。兜率陀天众。化自在天众。他化自在天众。梵众梵师天众。大梵天众。少光天众。无量光天众。净光天众。少善天众。大善天众。无边善天众。无云天众。福生天众。广果天众。无暖天众。无诳天众。善见天众。爱见天众。阿迦腻吒天众。亦复如是。于如是等诸天众中。一时之顷百出百没千出千没千万出千万没。是名大众隐显自在。云何障他神通。菩萨摩诃萨除佛世尊。同行同性同定。后边生菩萨所得神通。胜余内外一切神通。是名障他神通。云何言辞无碍。菩萨摩诃萨说法之时。言辞无尽义味无尽乐说无尽。是名言辞无碍。云何施他忆念。菩萨摩诃萨说法之时。无量众生于无量世。诸所失念悉令还忆。是名施他忆念。云何施他欢乐。菩萨摩诃萨说法之时。能令众生身心安乐坏烦恼障。听者欢乐如第三禅。四大诸患一时消灭。诸恶鬼等不得其便。是名施众欢乐。云何放大光明。菩萨摩诃萨放大光明遍照十方无量世界。至地狱中坏地狱苦。至放逸天教修人法。令得人身来至佛所。请召十方无量菩萨。来集佛所教化众生。是名放大光明。如是等事名变神通。转法性故名变神通。云何化神通物无作物故名为化。若化身若化声。化身者。或似己身或似他身。有根具足不具足者。余如转中。又复化为无量之身。诸佛菩萨为众生故化无量身遍无量界。有佛菩萨现遍化身。或有如幻。或有真实。衣食金银琉璃真珠颇梨珂贝亦复如是。为破众生贫穷困苦。是名化身。化声者。诸佛菩萨化现好声疾声妙声。自说义声。他说义声。无义声。说法声。教化声。以是诸声能坏众生放逸之心。是名化声。佛菩萨声深远如雷。如迦陵频伽声。人所爱乐声。遍满声。思惟声。了了声。易解声。喜闻声。无所著声。无可呵声。无尽声。菩萨摩诃萨如是诸声。若三千大千世界所有天众人众声闻众辟支佛众菩萨众。若近若远悉得闻之。如是声中出种种法利益众生。自化声者。如自说法。为放逸众生故。他化声者。如佛化身为他说法。为放逸众生故。无义声者。如虚空出声。说法声者。为痴众生故。教化声者。为放逸者增长不放逸故。诸佛菩萨如是等化神通之事。展转无量不可称计。如是无量不可称计神通变化为于二事。一者为令众生生于信心趣向佛法故。二者为示贫穷困苦众生无上福田故。云何宿命智。菩萨摩诃萨自知宿世与如是等众生共住共行。自识名字及他名字。知自种姓及他种姓。知自饮食及他饮食。自知苦乐及他苦乐。菩萨自知如是宿世。亦能教他令知宿世。自识乃至无量世事。亦能教他识无量世若粗若细。是名宿命智。以是宿命智势力故。能说本昔菩萨因缘。令诸众生于佛法中现在生信。说诸菩萨本因缘经。阇陀伽经。阿浮陀那经。说业因缘恶业善业。为破众生常见及无常见故。是名菩萨宿命智。云何天眼。菩萨摩诃萨以净天眼过于人眼。见诸众生死此生彼。若好色若恶色若好若丑。明见众生善恶等业善恶果。若老若少若自造作若教他作。若粗若细。若人天色。若三恶道色。乃至无量十方世界无量佛土众生之色。明了无量十方诸佛演说法时。是名天眼通。云何天耳。菩萨摩诃萨所闻音声。若天声若人声。若圣声若非圣声。若粗声若细声。若化声若实声。若远声若近声。天声者。从欲天至阿迦尼吒乃至上方无量世界。诸天音声悉得闻之。是名天声。人声者。所谓十方无量世界。圣声者。谓诸佛菩萨声闻缘觉。为化众生宣说佛法。若赞布施持戒善业破坏恶业。读诵解说书写佛经。是名圣声。非圣声者。所谓妄语两舌恶口无义之言。下至三恶上至欲界。所有诸天十方众生。有如是等四种恶口。是名非圣声。云何粗声。谓大众声。大众生声。地狱声。雷震声。贝声鼓声。是名粗声。细声者。谓窃语声。不了声。陀毗罗国声。粟特声。月支声。大秦声。安息声。真丹声。法(丹本佉)沙声。裸形声。鲜卑声。如是等边地声名为细声。何以故。嫉妒烦恼因缘得故。菩萨成就如是天耳。闻诸众生所出善声赞叹恭敬。教住佛法令生信心。广为分别十二部经菩萨秘藏。若闻恶声即便呵责。说恶业过开对治门。是名天耳通。云何他心智通。菩萨悉知十方世界所有众生。共烦恼心不共烦恼心。烦恼系心及不系心。善愿心恶愿心。疑心无疑心。上心下心。贪恚痴心。欲界心色无色界心。乃至一切畜生众生受苦乐心。无苦无乐心。以一心观一众生心。以一心观无量众生心。是名他心智通。诸佛菩萨他心智通。为知众生利钝根故。为知众生诸种性故。知是众生有善心已。即为演说十二部经及菩萨藏。知恶心已即便呵责说恶业过。是名菩萨他心智通。漏尽智通者。菩萨摩诃萨为断烦恼故修集道。自坏烦恼故修集道。为坏众生诸烦恼故而为说法。为坏有漏憍慢众生。为破非道计道众生故。菩萨摩诃萨虽为众生说尽漏法自不尽漏虽未尽漏不为所污。菩萨摩诃萨漏尽智通不可思议。修漏尽通为化众生坏憍慢故。是名漏尽通。云何为法。檀波罗蜜乃至般若波罗蜜果。是名为法。是六种果凡有四事。一者修集道故。二者庄严菩提故。三者自他利益故。四者得后世大善果故。菩萨行施破坏悭贪。庄严菩提道摄取众生。为菩提道令行布施。欲施施时施已欢喜。是名自利。断除众生饥渴苦恼寒热恐怖。是名利他。舍是身已获大自在饶财尊贵。是名大果。是名菩萨布施四事。菩萨摩诃萨受持禁戒除灭恶戒。庄严菩提道摄取众生。为菩提道令持禁戒。离破戒怖卧安觉安。心无悔恨欢喜悦乐。是名自利。于诸众生无有害心施众生无畏是名利他。持戒故受人天乐得道涅槃。是名大果。是名菩萨持戒四事。菩萨摩诃萨修于忍辱破坏不忍。庄严菩提道摄取众生。为菩提道令修忍辱。若自若他远离怖畏。是名自利利他。以忍因缘无有嗔心。眷属不坏不受苦恼。心无悔恨舍是身已受人天乐得道涅槃。是名大果。是名菩萨忍辱四事。菩萨摩诃萨勤修精进破坏懈怠庄严菩提道摄取众生。为菩提道令修精进。卧安觉安离诸烦恼。增长善法身受安乐是名自利。菩萨精进不恼众生打掷呵骂。是名利他。舍是身已受人天乐。身得大力获菩提道是名大果。是名菩萨精进四事。菩萨修定坏破乱心。庄严菩提道摄取众生。为菩提道令修禅定。现世受乐身心寂静。是名自利。以身心静故不恼众生。是名利他。舍是身已受清净身。安隐快乐得道涅槃。是名大果。是名菩萨禅定四事。菩萨摩诃萨成就智慧破坏无明。庄严菩提道以四摄法摄取众生。为菩提道修行智慧。以知法界故身受安乐。是名自利。能教众生世间之事及出世事。是名利他。能坏烦恼智慧二障。是名大果。是名菩萨智慧四事。共生不可思议者。菩萨摩诃萨非宿命智忆宿世事。为观众生善恶诸业。同受苦者为欲利益。菩萨摩诃萨处兜率天。成就寿命有三事胜。一者寿胜。二者色胜。三者名称胜。初下之时放大光明遍照十方。了了自知始入母胞胎时住时出时。于十方面行七步时。无人扶侍作如是言。我今此身是最后边。诸天鬼神乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽。以诸华香微妙伎乐幡盖供养。三十二相庄严其身无能胜者。以慈善力坏魔兵众。一一支节同那罗延所得大力。童龀之年不学世事而能知之。无师而学自然而得阿耨多罗三藐三菩提。梵天劝请为诸众生转正法轮。正受三昧雷声震动不能令动。诸兽亲附爱如父母。畜生奉食知佛心故。云神降雨洗浴其身。树随曲枝荫翳其躯。既成道已六年之中。魔常伺求不得其短。常在禅定成就念心。善能了知觉观起灭。是名菩萨共生不可思议。不共生者为欲利益一切众生。如彼狂人缘见如来还得本心。盲者得眼。倒产得顺。聋者得听。贪嗔痴者悉得除灭。是名不共生不可思议。又共生者。如来所行不可思议。常右胁卧如师子王。若草若叶无有动乱。随蓝猛风不动衣服。发足行步如师子王白鹅王等。若欲行时先发右足。所行之处高下皆平。食无完过遗粒在口。是名共生不可思议。如来世尊。入涅槃时。大地震动。放大光明遍十方界。一切悉闻伎乐之音。是名共生不可思议。云何名为共。声闻缘觉不共。声闻缘觉不共有三。一者细。二者行。三者界。如来悉知一切众生无量烦恼无量对治。是名为细。行者名为六通六波罗蜜法性自生不可思议。是名为行。界者一切世间无碍智慧。是名为界。是名不共不可思议。声闻神通齐二千世界。缘觉神通齐三千大千世界。诸佛菩萨通达无量无边世界。是名不共。共者除上三事余一切法。是名为共。是故声闻辟支佛等。尚不得与佛菩萨共。况凡夫人天外道邪见。菩萨摩诃萨六波罗蜜法性共生不共生。声闻缘觉共法不共法。是名不可思议

菩萨善戒经卷第二菩萨善戒经卷第三

        宋罽宾三藏求那跋摩译

    菩萨地调伏品第七

云何名为菩萨调伏。调伏者有六种。一者性调伏。二者众生调伏。三者行调伏。四者方便调伏。五者熟调伏。六者熟印调伏。性调伏者。有善种子故修善法。修善法故坏二种障。一烦恼障。二智慧障。修善法故身心清净。身心清净故若遇善友诸佛菩萨。若不值遇能坏烦恼智慧二障。如痈已熟若遇医师及以不遇悉得除愈。譬如瓦器任用之时。名之为熟。如庵罗果等任啖食时。亦名为熟。一切众生亦复如是。修集善道毕竟欲得阿耨多罗三藐三菩提时。是名为熟。是名性调伏。众生调伏者有四种。一者有声闻性得声闻道。二者有缘觉性得缘觉道。三者有佛性得佛道。四者有人天性得人天乐。是名为四。是名众生调伏。行调伏者有六种。一者根调伏。二者善根调伏。三者智慧调伏。四者下调伏。五者中调伏。六者上调伏。根调伏者。以调根因缘故。得长命好色种姓自在大力言音微妙男子之身无能胜者。具足成就是报果者。任得阿耨多罗三藐三菩提。常为众生修集苦行。其心初无忧愁悔恨。是名根调伏。善根调伏者。性不好乐造作恶业。五盖轻微诸恶觉观渐渐羸弱。乐受清净纯善之言。是名善根调伏。智慧调伏者。菩萨摩诃萨修集智慧故。心行旷大善能受持读诵经典。解善恶义思惟分别广为人说。以修集智慧故。任得阿耨多罗三藐三菩提。若能具足根调伏善根调伏智慧调伏者能净智障。若具根调伏能净报障。若具善根智慧调伏。能净智障及烦恼障。下调伏者有二种。一者不于无量世中修集善法故。二者不乐推求善根智慧故。名下调伏。中调伏者。于无量世修集善法。得善根调伏不得智慧。名中调伏。上调伏者。具上三事。是名上调伏。方便调伏者。有二十二。一者界增长。二者现在因。三者入于出家。四者初发。五者非初发。六者远净。七者近净。八者庄严。九者至心。十者施食。十一者施法。十二者为示神通生信心故。十三者为说法得生信心。十四者说深密藏广分别法。十五者下庄严。十六者中庄严。十七者上庄严。十八者听法。十九者思惟修集。二十者摄取。二十一者呵责。二十二者不待请说及待请说。界增长者。具善种子。具善种子故他世善根复得增长。现在修集法种子故。他世法种子亦得增长。是名界增长。现在因者。现在世中说法不谬。听法不谬如法受持。因先世因增现在因。因现在因增未来因。又现在因增现在因。是名现在因。入出家者。亲近善友诸佛菩萨信心得生。得信心故舍离世法。受持修行出世之法。出世法者。谓菩萨戒。若不能受名字沙门不名出家。断欲法故乃名出家。不受如是菩萨戒者。不名毕竟永断欲法。断一切爱名为出家。受毕竟乐名为出家。乐易行道名为出家。增长佛法名为出家。乐持禁戒名为出家。是名入出家。初发者。初发心时不乐生死。不乐生死故信心得生。修集于道增益佛法。是名初发。非初发者。发心已后亲近诸佛及佛弟子。受持禁戒读诵书写广为人说。乃至增长上上善法。是名非初发。远净者。如不受持菩萨禁戒。不能读诵书写解说。不随师教懒堕懈怠。经无量劫不能得成阿耨多罗三藐三菩提。是名远净。近净者。受持禁戒读诵书写为人解说。随顺师教勤修精进。速疾能得阿耨多罗三藐三菩提。是名近净。庄严者。至心勤求无上佛道。为菩提故持菩萨戒。为怖畏王师长和上。为名称故持菩萨戒。是名庄严。至心者。于佛法中至心系念。无有疑网不忍之心。护持正法。以菩萨藏菩萨摩夷教化众生。于师和上耆旧长宿有德之人深生恭敬。勤供三宝无有休息。深信三宝常住不变。是名至心。施食者。菩萨摩诃萨见饥馑者施以饮食。随前所须一切供给。是名施食。施法者。菩萨若以一句一偈乃至半偈一部一藏。广为众生演说其义。为菩提故教令行善。是名施法。为示神通生信心者。菩萨摩诃萨以大神通示诸众生。为怜愍故。欲令众生心清净故。为知众生信心净故。为见众生净庄严故。为令众生发阿耨多罗三藐三菩提心故。是名神通。说法生信心者。菩萨自知未有利益。为利他故而演说法。亦复知因利益他故。能灭己罪而演说法。又复自知为他说法。亦得增长已所修善。是名说法。说深密藏广分别法者。菩萨摩诃萨以方便力。能为众生开示如来甚深密藏。为令众生解其义故。为有智者增善根者说深义故。是名说深密藏广分别法。下庄严者。不能至心常行无上贤圣之行。是名下庄严。中庄严者。虽复至心修集圣行不能常行。是名中庄严。上庄严者。亦常亦至心。是名上庄严。听法者。若修无上佛法之时。至心听采十二部经。受持书写读诵解说。是名听法。思惟修集者。既听法已身心寂静。思惟其义破坏疑心。修集三想。谓定慧舍。是名思惟修集。摄取者。以无贪心为人说法。受畜弟子善为教诫。施其衣钵病给医药。知烦恼起随病说法。是名摄取。呵责者。若自知见所起烦恼呵责身心。起烦恼者。不能自利及利益他。轻罪见中中罪见重。如人乱心堕坠坑陷。已堕之后不宜复堕。烦恼若起应当调伏。若见弟子起微烦恼应当呵责。不应受其礼拜供养乃至杨枝澡水。若犯大罪应作摈出羯磨。若呵责者自利利他。是名呵责不待请说者。为自利益受持读诵解说深义。为破众生所起烦恼。为增众生所行善法故为说法。如已所持如持而说如法而住。何以故。菩萨若不如法住者。众生轻慢而作是言。汝自不能如法而住。云何教他。汝今方应从他受法。云何反更为他说法。是名不待请说。待请说者。如持禁戒勤修精进。具足善根乐处闲静。常为一切之所恭敬。所可演说人皆信受。知义知辞善能说法。若有比丘比丘尼优婆塞优婆夷。作如是言。唯愿大士。为调众生开甘露门。是名待请而说。如是等二十二事谁调伏耶。谓六种菩萨住六地者。如是菩萨则能教化调伏众生。何等六地。一者至心专念菩提行地。二者净心为菩提道地。三者如法住地。四者定地。五者毕竟地。六者成就菩提道地。是名为六。为欲调伏无性众生。说人天乐令得不退。为有性说令得调伏增长善法。是名熟调伏。熟调伏印者。声闻之人于无量世修集善根。是名下熟调伏印。复有下熟调伏印。谓下软心下庄严下善根。不能破坏三恶道报。现在不得四沙门果及以涅槃。是名下熟调伏印。云何中熟调伏印。若得中心中庄严中善根破三恶道。现在不得四沙门果及以涅槃。是名中熟调伏印。上熟调伏印者。有上心上庄严上善根破三恶道。现在能得四沙门果及以涅槃。是名上熟调伏印。缘觉亦如是有二事胜。一者修集道胜。二者无师得道胜。菩萨摩诃萨住此专念菩提行地。是名下熟调伏印。住第二地名为中熟。住第三地名为上熟。初地菩萨其心微软。庄严亦尔堕三恶道。修行已经初阿僧祇。初阿僧祇劫未能具足无动无上清净三十七品。中熟调伏印者。菩萨中心中庄严。不堕三恶。修行已经第二阿僧祇劫。虽得清净不动转善具三十七品。未得具足最大寂静三十七品。是名中熟调伏印。上熟调伏印者。菩萨摩诃萨住上熟调伏印。上心上庄严不堕三恶。修行已经第三阿僧祇劫。具足清净不动转善。获大寂静三十七品。即是菩萨无上道故。名为大净不动纯善最大寂静。是名上熟调伏印。下熟调伏印有三种。下下下中下上。中熟有三。中下中中中上。上熟有三。上下上中上上。菩萨摩诃萨具足如是等调伏者。则能增长无上佛法。教化众生调伏诸根。智慧猛利能为众生开示三乘

    菩萨地菩提品第八

云何名菩提。菩提者。谓二种解脱。二种智慧。二解脱者。一烦恼障解脱。二智障解脱。智慧二者。一者能坏烦恼障。二者能坏智慧障。又复无上菩提者。所谓净智无碍智一切智。断一切习。断除一切无记无明。净智者。断一切习知一切界一切法一切行一切世间一切时一切对治。界有二种。一者世界。二者众生界。法亦二种。一者有为。二者无为。行亦二种。一者坏烦恼障。二者坏智慧障。世间二种。一者智。二者愚。时有三种。过去现在未来。对治三种。不净观慈观十二因缘观。是名净智。无碍智者。不假庄严思惟入定。而能通达一切界一切法一切行一切世间一切时一切对治。是名无碍智。复有无碍智。谓百四十不共法。如来所有无诤三昧愿智四无碍智。是名无碍智。名为菩提。云何名为百四十不共之法。谓三十二相八十种好。四净行十力四无所畏三念处三不护大悲不忘断一切习一切行无胜智。是名百四十不共法。后住品中当广说。云何名为无上菩提。具七无上故名无上菩提。一者身无上。二者受持无上。三者具足无上。四者智慧无上。五者不可思议无上。六者解脱无上。七者行无上。身无上者。三十二相庄严身故。受持无上者。诸佛菩萨自利利他能施众生人天乐故。具足无上者。诸佛菩萨有四具足故。所谓寿命具足。见具足。戒具足。行具足。智慧无上者谓四无碍。不可思议无上者。所谓具足六波罗蜜。解脱无上者。如来能坏二种障故。行无上者。所谓圣行天行梵行。圣行者。谓三三昧空无相愿灭尽定天行者。谓四禅四无色定。梵行者谓四无量心。是三种行出佛四行常乐修集。云何为四圣行有二。一者空三昧。二者灭尽定。天行有一。谓第四禅。梵行亦一所谓大悲。如来以是大悲因缘。昼夜六时常观众生。谁无善根当施种子。谁种善根当令增长。乃至谁未发阿耨多罗三藐三菩提心。我当令发阿耨多罗三藐三菩提心。如来以是无上身故名大丈夫。受持无上故名为大悲。具足无上故名到彼岸。智慧无上故名一切智。不可思议无上故名阿罗呵。解脱无上故名大涅槃。行无上故名三藐三佛陀。以是义故如来具足十种名号。所谓如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。无虚妄故名为如来。良福田故名为应供。知法界故名正遍知。具三明故名明行足。不来还故名为善逝。知二世间故名世间解。一者国土世间。二者众生世间。能调伏众生身心恶故。名无上士调御丈夫。能为众生作眼目故。能令众生正知正法正义正归。为诸众生广说义故。能坏一切烦恼苦故。能破众生疑网心故。开示诸法甚深义故。一切善法根本故。是故名为天人之师。知善法聚不善法聚非善非不善法聚。是名为佛坏魔波旬故。能得难得如来身故。名婆伽婆。无量劫中乃至无有一佛出世。是故难得。无量世界有无量佛。十方世界有无量菩萨。同时同愿修集庄严。同时俱发菩提之心。一时一日一月一岁。同施同戒同忍同进同禅同智。以是义故。十方世界应有无量无边佛土。一土之中终无二佛一时出世。若无十方无量世界。如是无量无边菩萨同修善行可无果耶。以是故知。有十方无量无边诸佛世界。何以故。一土之中无二佛故。菩萨摩诃萨初发心时。作如是言。唯我一人能令无量无边众生断烦恼苦入于涅槃。以是愿力获得果报。如来能为三千大千无量世界。说法教化调伏众生。是故一土无二佛出。若一土中有二佛出者。众生不能乐修善法。不生恭敬难遭之想若见一佛则得生于不思议心。佛或涅槃。我等当共及时修善。勤行精进转离生死。生难遭想恭敬之心。修檀波罗蜜乃至修集般若波罗蜜是故一土无二佛出。十方诸佛唯除四事。其余一切平等无二。一者寿。二者姓三者名。四者身。菩萨终不以女人身得阿耨多罗三藐三菩提。何以故。菩萨摩诃萨初阿僧祇劫已断女身。女人之身贪欲多故。二指智故。如是恶智。不能得阿耨多罗三藐三菩提。菩提者不可思议。何以故。一切声闻辟支佛等所不得故。是故无上菩提。无量功德之所成就(二指者谓女人和合智也)

    菩萨地菩提力性品第九

菩萨摩诃萨欲学菩萨戒者。当修信解。常乐求法常乐说法。见持法者深生供养。如法而住。教诲弟子住正法中。善知身口意业方便。云何菩萨修集信解。明信三宝及其功德。信佛菩萨不可思议。信真实义信有因果。信诸众生有种种业种种业果。知善方便及非方便。自信必得阿耨多罗三藐三菩提。自知得义。义者所谓无上菩提。智菩提。方便菩提。方便者。谓菩萨戒乃至三十七品。菩萨戒者闻说法时心忍信受。所谓十二部经。是名菩萨戒。学菩萨戒者当修二事。一者慈心。二者信心。菩萨修集如是二法得信解心。求法者求何事。云何求何故求。求者谓菩萨藏。声闻藏。一切世论。一切世事。菩萨藏者。谓毗佛略。余十一部名声闻藏。世论者有三种。一者因论。二者声论。三者医方论。一切世事者。如金宝工匠一切方术。方术有五。一者内术。二者因术。三者声术。四者知病因治病术。五者知一切作事。菩萨摩诃萨常求如是五种方术。内术者。谓十二部经。菩萨摩诃萨为二事故求十二部经。一者知因果。二者作业不失不作不受。求因论者为二事故。一者为知外道过故。二者为坏外道诸论师故。求声论者亦为二事。一者为解一切法界义故。二者为正一切言辞音声故。求治病术为四事故。一者为知病相貌故。二者为知病因缘故。三者为知病除愈故。四者为知病愈之后更不起故。求十二部经。为知因果者。一切法有十种因。说真因相摄一切因。若生死若解脱。若善若不善。若内若外。若众生若非众生。何等为十。一者流布因。二者从因。三者作因。四者摄因。五者增长因。六者转因。七者不共因。八者共因。九者害因。十者不害因。流布因者。所谓诸法因名得其体相得体相故故可宣说。是名流布因。如因手取因足涉路因身而有去来坐卧。是名从因。如从子得果。是名作因。离子从余而得果者。是名摄因。子灭芽生从芽得果。名增长因。如从子生谷因谷生子。是名转因。随种得果。名不共因。如地水火风。名为共因犯四重禁怨害善法。是名害因。若不犯者。是名不害因害因有五。一者声害。二者生害。三者不共住害。四者怨害。五者定害声害者。犹如世论初说善好后说不善。又复害者。如说诸法一切无常。犹如虚空说一切常谓生老死。是名声害。生害者。如说无因而能生果有因无果。不共住害者。犹如明闇贪恚苦乐。怨害者。如蛇鼠狼马与水牛。如狸与鼠。定害者。如不净观除贪慈心院嗔悲除害心。八圣道分除一切结。复有二因。一者真实因。二者方便因。真实因者所谓种子。方便因者如余外缘。方便因者有四种缘。一者因缘。二者次第缘。三者缘缘。四者增上缘。因缘者诸法生因。增上缘者。谓方便因次第缘。缘缘者。谓心心数法。是名四缘。如是十因。云何出生一切世法及出世法。云何断生死。云何不断生死。如世间中种种谷子。为增长命有种种名。所谓大麦小麦大豆小豆粳粮胡麻等。是名流布因。因于饥渴无气力故。为除是患身得力故。求大小麦乃至胡麻。因于美食。心生贪着。生贪着心故方便求索。是名从因。如彼种子生相似果。是名作因。如彼地水火风粪土人工等。是名摄因。从子增长乃至于果。是名增长因。如子生果从果复生因。是名转因。如麦生麦豆自生豆。是名不共因。如离子已从余生果。是名共因。如子遇雹火烧鸟食。是名害因。离雹火鸟名不害因以是义故。是十种因。出生世法及出世法。又复演说十二因缘所有名相。谓无明因缘行。行因缘识。识因缘名色。名色因缘六入。六入因缘触。触因缘受。受因缘爱。爱因缘取。取因缘有。有因缘生。生因缘老死忧悲愁恼大苦聚集。是名流布因。无明缘行乃至生缘老死。为贪恚故。不断十二因缘。是名从因。现在爱取未来无明。是名作因。现在有。未来行。是名作因。现在识。未来生。是名作因。现在名色六入触受。未来生老死。是名作因。不近善友。不乐听法。不思惟义。不如法住。以此四事。摄取无明乃至生老死。是名摄因。因恶业故。增长无明乃至老死。是名增长因。无明三种。谓下中上。下为中因中为上因乃至老死。是名转因。有无明堕地狱。有无明堕畜生。有无明堕饿鬼。是名不共因。一切众生平等共有十二因缘。是名共因。无明因缘故无具足性。不与如来共生一国。远离善友不得闻法。不思惟义不如法住。不得修集三十七品。是名害因。除无明故性得具足。性具足故得与如来共生一国。亲近善友得闻正法。思惟正义如法而住。修集三十七品。是名不害因。以是义故是十种因出生世法。云何十因生出世法。若说三十七品名相菩提名相乃至涅槃名相。名流布因。因四念处。得四正勤。因四正勤。得如意足。因如意足。得五根。因五根。得五力。因五力。得七觉分。因七觉分得八圣道。因八圣道。得涅槃。是名从因。无明灭故诸行灭行灭故识灭。识灭故名色灭。名色灭故六入灭。六入灭故触灭。触灭故受灭。受灭故爱灭。爱灭故取灭。取灭故有灭。有灭故生灭。生灭故老死灭。老死灭故得涅槃。是名从因。性具足故修三十七品。修三十七品故得涅槃。是名从因。性具足故乃至三十七品能生菩提。是名作因。亲近善友至心闻法。思惟其义如法而住。调伏诸根修八圣道。是名摄因。三十七品能为二种涅槃之因。是名转因。具声闻性得声闻果。具缘觉性得缘觉果。具佛性故得无上道。是名不共因。如是三人悉共修集三十七品。是名共因。性不具足生处八难不闻正法。是名害因。坏害因故得闻正法。名不害因。修集八圣道因缘故得声闻菩提辟支佛菩提。得佛菩提。是增长因。是十种因出生世法出世之法。如是二法各有三世。所谓过去未来现在若有说言离是十因更有因者。无有是处。云何名果。果有五种。一者报果。二者余果。三者解脱果。四者现作果。五者增上果。不善之法得三恶报。有漏善法得人天果。是名报果。以造恶故乐为恶业。以修善故乐修善业。是名余果。修八圣道远离烦恼。名解脱果。凡夫修道虽离烦恼不名解脱果。何以故。非毕竟故若人现世种种方便役力得财。是名现作果。眼根眼识乃至意法意识。名增上果。菩萨摩诃萨以知因果。增长作力修集于道知不作。不受作不失果菩萨。摩诃萨知因果故求十二部经。受持读诵书写解说。得第二业力。若有菩萨不信众生业因果者。终不能得菩萨禁戒。菩萨何故求十二部经。菩萨至心念菩萨戒勤求佛法。乃至一句一偈一义。若见说者心生恭敬欢喜乐闻。不轻于说法者。己身于说法者不求其过。至心奉敬如从佛闻。若说法者吝法不施。应以钱财乃至身命供事奉献。若有菩萨能如是者。名义菩萨。菩萨若能至心听受乃至一句一偈一义。三界烦恼皆悉萎悴具菩萨戒菩萨至心求佛语时。渴法情重不惜身命。设蹈热铁猛火之地不以为患。菩萨摩诃萨以一偈故尚不惜身。况十二部经。为一偈故尚不惜命。况余财物。以闻法利身得安乐。深生信心得柔软心。直心正见见说法者。如见父母心无憍慢。为众生故至心听法终不为己。为增众生所有善根。听受正法不为利养。为众生故受菩萨戒不为自利为正法故不畏王难饥渴寒热虎狼恶兽盗贼等事。先自调伏烦恼诸根。然后听法非时不听。至心听法恭敬说者尊重于法。是名菩萨具菩萨戒。云何菩萨至心听法。听法有四。一者至心。二者一心。三者一切心。四者善心。是名菩萨勤求十二部经。菩萨何故求十二部经。为欲流布诸佛正法故。为欲增长诸佛法故。为令世间信佛法故。为令一切无量众生悉得阿耨多罗三藐三菩提故。是故菩萨求十二部经。菩萨何故求于因论。为知因论诸过罪故。为破外道恶邪论故。为弘方便调众生故。为欲分别如来语义世语义故。是故菩萨求于因论。菩萨何故求于声论。为令言辞净庄严故。不净之言不能宣说明了义故。为欲解知一切义故。坏不正语憍慢心破邪见故。为知方便调众生故。是故菩萨求于声论。菩萨何故求诸医方。为令众生离四百四病故。为怜愍故。为调伏众生故。为生信心故。生喜心故。是故菩萨求诸医方。菩萨何故求世方术。为易得财利众生故。为诸众生生信心故。为知世事破憍慢故。调伏众生故。破一切法诸闇障故。若有菩萨不能如是求五事者。终不能得阿耨多罗三藐三菩提成一切智。为得阿耨多罗三藐三菩提故求于五事。菩萨成就菩萨戒者。为众生说。说何事。云何说。何故说。说何事者。谓十二部经。云何说者。成就五事。何故说者。为得成就阿耨多罗三藐三菩提故。说有二事。一者次第说。二者清净说。次第说者。初说惠施。次说禁戒。次说天乐。次说三昧。次说受持十二部经思惟其义如法而住。是名次第说。清净说者。人在高处己身处下不应说法。除为病患。心不信者不应为说。不厌生死者不应为说。人在已前不应为说。人覆头者不应为说。求过失者不应为说。其余皆如波罗提木叉修多罗中说。何以故。诸佛菩萨恭敬法故。若说法者尊重于法。听法之人亦生宗敬。至心听受不生轻慢。是名清净说。次第说者。一切说一切说一切说。坏吝法心无有憍慢若一句一偈乃至半偈。若辞若义。若法说义说及法义说。示教利喜。或时呵责。或时直说。或时喻说随所应说。或浅近说。为易入说。随所乐说。是名菩萨次第说也。清净说者。菩萨摩诃萨于怨憎中修集慈心。得慈心已于恶众生及放逸人。以诸方便而为说法。乃至受乐其心憍恣及贫穷人。方便开示而为说法。不为赞己毁辱他人饮食利养名誉故说。是名菩萨清净说法。如法住者。身口意业修集善法正思惟义。是名如法而住。云何菩萨思惟于义。菩萨调伏身口意业乐处闲静。若自受持若从他闻。思惟正义不思非义。至心思惟真实之义。为菩提道系心思惟依于实义。不依文字思惟分别此是佛语此非佛语。舍非思惟惧心乱故随所闻声。随声思义不随他语。虽不解义终不言非。何以故。此是诸佛之境界故。菩萨摩诃萨依义不依字。能知如来甚深之义。知法非法无能动转。如是菩萨未得忍者今已得忍。未得三昧今得三昧。是名菩萨如法而住。云何名修集。修集有四。一者舍摩他。二者毗婆舍那。三者爱乐修集。四者随所修集乐在中住。舍摩他者。菩萨摩诃萨修集四禅四无色定。专心缘定能破五盖。因住定故解真实行。能离一切诸恶觉观。其心不乱能思内外法界之义随顺法相。心心数法安住一缘。是名舍摩他。毗婆舍那者。修舍摩他能观法界分别法相。求于善法远离恶法。智慧正见不颠倒见善解于义。是名毗婆舍那。爱乐修集者。至心修集如上二法。至心修者常不放逸。是名爱乐修集乐。住修集者修舍摩他毗婆舍那时。不假方便随意而住。是名乐住修集。菩萨摩诃萨常修二法。亦名乐住。亦名清净。亦名身心寂静。亦名广智。菩萨摩诃萨修是二法。即是得阿耨多罗三藐三菩提根本。菩萨成就菩萨戒者得是二法。是名修集。云何为教。教有八种。菩萨摩诃萨成就三昧。欲教众生先当入定。或与共住然后能以八事教化。何等为八。一者知心。二者知根。三者善根。四者烦恼。五者对治。对治者。有贪心者教观不净。有恚心者教修慈心。有痴心者教观因缘。恶觉观者教令数息。是名为八。以如是等诸善方便教化众生。破断常心说于中道。实无作相而作作相。真实不得而作得想。真实无触而作触想。真实无证而作证想。是八种事能破如是妄想憍慢。复有三事。一者心若不住能令住缘。二者住已能观正法。三者知善方便。若知善方便若知众生心根善根及以烦恼。以是四事能令散心住于缘中破断常见而说法者。是名能观正法。破贪心故说观不净。破嗔恚心说慈心观。破愚痴故说因缘观。破恶觉观说于数息。是名知善方便。若菩萨摩诃萨自于佛所若菩萨所学是八事。复以是法教化众生。是名菩萨摩诃萨净八种力。何等为八。一者知诸禅定解脱力。二者知根力。三者解力。四者世界力。五者知至处道力。六者宿命智力。七者生死智力。八者漏尽智力。是名为八。又复教者复有五种。一者教令远恶。二者教修善法。三者教犯戒者发露忏悔。四者教作忆念羯磨。五者教不受语者作摈出羯磨。菩萨摩诃萨以是五事教化众生。以怜愍心故。清净心故。菩萨摩诃萨若以嗔心教化众生。则不能得菩萨禁戒。若受教者如法而受。应当恭敬至心瞻视供养尊重如父如母如佛菩萨。何以故。以如法受教故。则能疾得声闻菩提缘觉菩提。得阿耨多罗三藐三菩提。是名菩萨教也。善方便者。菩萨摩诃萨一切所有身口意业。悉为调伏一切众生。是名善方便。善方便者有四种。一者惠施。二者软语。三者利益。四者同义。菩萨摩诃萨能施众生衣服饮食房舍卧具病瘦医药。受施之人既受施已。于菩萨所生爱念心。至心听说闻已受持。以受持故菩萨则以软语赞叹。以赞叹故受者欢喜。以欢喜故能坏恶心受持善法。坏恶心故菩萨复言。我已具信戒闻施慧。汝亦当具。菩萨若不具足五事。则不能教一切众生。众生亦言。汝自不具。云何教他令具足那。是故菩萨具足五事。是名菩萨以善方便教化众生。方便者。所谓善调伏。善调伏者所谓不弃不转不退。是名善方便

菩萨善戒经卷第三菩萨善戒经卷第四

        宋罽宾三藏求那跋摩译

    菩萨地施品第十

菩萨摩诃萨求阿耨多罗三藐三菩提。具足庄严六波罗蜜。所谓檀波罗蜜尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜。云何名为菩萨檀波罗蜜。菩萨布施有九种。一者性施。二者一切施。三者难施。四者一切自施。五者善人施。六者一切行施。七者为除施。八者自利利他施。九者寂静施。性施者。自利利他自他俱利。内发善心身口意业。善于财物中心无贪着。是名为施。菩萨行施持戒精进。信十二部经。信因信果。随诸众生所求之物心无吝惜。以如是等身口意业施心财物。如是五事即是五阴。是名性施。云何一切施。一切施者有二种。一者内物。二者外物。菩萨摩诃萨于无量世为施众生受是阴身。是名内物菩萨摩诃萨为食吐鬼。自服食已吐施于彼。是名内物。离是二事是名外施。菩萨摩诃萨舍身布施有二事。一者菩萨不得自在。二者属他。有求不施不能得成阿耨多罗三藐三菩提。是名菩萨不得自在。属他者。菩萨摩诃萨为菩提故。身属众生如世间人。以衣食故为他仆使。菩萨摩诃萨于自身中不得自在。一切众生于菩萨身头目髓脑乃至手足。随意取用而得自在。外施有二事。一者为利众生。二者心无贪吝。菩萨摩诃萨于是内外有施不施。菩萨摩诃萨观诸众生。受施之后不得利乐则不行施。受施之后必得利乐则便行施。菩萨若知缘以身施令众生受苦妨行善法。及非法求亦不应施。菩萨摩诃萨若见百千万亿众生非法因缘求不得故。丧失身命终不为此而行惠施。非法求者。所谓若杀若诳若偷若害。是名不施。复有不施者。菩萨摩诃萨若知身自能多利益。无量众生有来求者则不应施。是亦名施。何以故。有净心故。若知是魔及魔眷属则不应施。若有为魔所迷乱者。来求索时亦不应施。若有狂痴及欲恼乱。如是乞者亦不应施。是名内不施。外不施者。火毒刀酒能为众生作恶因缘。菩萨终不以此施人。若作利益则以布施。菩萨摩诃萨终不为他作恶业使。若知受者受施之后必行恶业。亦不施之是亦名施。何以故。以净心故。手虽不施其心已舍。所以者何。菩萨定知受施之人受已必作无量恶业堕三恶道。是故不施。菩萨虽知受者得物其心欢喜。然知不免三恶道苦。是故不施。菩萨摩诃萨终不教人张弶捕猎。亦不教人事婆薮天。自不杀羊祀祠天神。亦不教他杀羊祠天。不以罗网施来求者。一切怨恶打骂系缚悉不施人。若有困厄贫穷愁恼欲自刑戮。或求刀槊亦不施之。亦不教人自坠高岩投渊赴火以丧身命。若有病人所须之物。是医禁者悉不施之。贪食之人食饱已不施。是名不施。菩萨摩诃萨不以父母师长布施。若为国主不应自在取他妻息以施于人。唯除城邑聚落国土。若自妻息及以僮仆眷属宗族。先以软语慰喻。其心若不肯者则不应施。设其肯者终不施与怨家恶人罗刹恶鬼旃陀罗种。虽以城邑国土聚落惠施于他。终不施与暴恶之人。亦不私以父母师长兄弟妻子僮仆奴婢所有财物布施于人。菩萨不以非法求财而行布施。行施之时于己眷属。不嗔不打不骂不呵。善言教导令其欢喜如是福报汝亦有分。菩萨施时其心平等。不观福田及非福田。不观怨亲种姓尊卑。已许之物终不生悔。多许之物终不少与。不先许好后以恶施。虽许恶与好许少施多。菩萨施时无不喜心嗔心乱心。施已终不于受者所计于恩报。行施之时不以受者是尊贵故恭敬手奉。受者卑贱撩掷而与。若其受者打骂劫夺。菩萨于是终不生嗔。但责烦恼不诃其人。于是人所深生怜愍。终不念言。因是施故我当得成阿耨多罗三藐三菩提。是施亦能庄严菩提。不为求果故而行于施。一切所施悉以回向阿耨多罗三藐三菩提。不为他教故行于布施。不以闻有施果报故而行于施。如经中说。施食得力。施衣得色。施乘者得乐。施灯得好眼。施房舍者得随意物。终不悕得如是等果而行布施。唯以怜愍而行于施。为破贫穷故而行于施。为调众生阿耨多罗三藐三菩提故而行于施。不施非施。非施者。不以残食以施圣人。非圣人者不求不施。不以残食施于父母师长耆宿有德之人。如其求者则应施之。终不以吐脓汗涕唾粪土杂食而以施人。不以秽食而以施人。凡所施食若多若少。先语后施不语不施。不食葱者不以杂葱食施。不食肉者不以杂肉食施。不饮酒者不以杂酒食施。若有酒香亦不以施。是名不净之物不以布施。菩萨摩诃萨见来乞者求时即施。终不以施要他策使。不为天乐而行布施。不以名称而行布施。不求恩报而行布施。不以转轮圣王身故而行布施。不以魔天梵天身故而行布施。不为国王长者恭敬供养尊重而行布施。少物尚施。何况有多。不为诳故而行布施。不为坏他眷属成己眷属乃至聚落城邑国土而行布施。菩萨施时手奉上座。乃至沙弥及持戒毁戒心无疲厌。菩萨施时终不呵毁乞求之人。不为憍慢故而行布施。菩萨摩诃萨于一切物常生舍心。所畜之物常为众生。若有审知菩萨已舍于己有分。作己分取则无有罪。菩萨摩诃萨见求者时心生欢喜。如重病人见大良医。随其所须自恣听取。三时欢喜。所谓未施施时施已。菩萨施时常发是心。设有贫富俱来乞者。应自思惟。若多有物当等施之。如其少者先救贫苦。作是愿者即是阿耨多罗三藐三菩提因。悭有三种。谓下中上。菩萨摩诃萨先坏下悭。以坏下悭则能破坏中上二悭。既自破悭复为众生说破悭法。以说法故利益众生。复次菩萨于不求者强以物施。若无财物应以方便役力求觅而行惠施。若无财施应行法施教化众生。汝今何故不行惠施。前人若随行布施者深生欢喜。身力佐助代其策使。又无财者应以智慧为诸众生开示善恶。复次菩萨不以正典施邪见者。不为活命炫卖经律。若读诵者则应施与。若吝不与名曰法悭。若能说法不为说者亦名法悭。若我不能以法施人。云何能破众生烦恼。菩萨终不作是说言。我今无财不能行施。亦不嗔恼自燋其心。以善方便慰喻求者。我今未有不称来意。何以故。初发心时自言当施一切众生故。复次菩萨闻求者来。即出承迎为施床座。既得相见先意共语软言问讯。随所须物事事供施。菩萨摩诃萨初发心时自言。我今所有之物当施十方诸佛菩萨及诸众生。譬如弟子以衣钵物奉施于师。师虽不取而此弟子得福无量。菩萨亦尔。所有之物奉施诸佛及诸菩萨。诸佛菩萨虽不受取。亦令施者得无量福。常随菩萨如恒河沙。菩萨摩诃萨观己财物。如十方佛菩萨所寄。知佛菩萨于是物所心无悭吝。是故菩萨自在随意以施众生。亦复深观不应施者。应当谏喻。如此物者实非我有。乃是诸佛菩萨所有。以柔软语晓喻求者不令嗔恨。是故菩萨成就具足财法二施。具二施已知性知因知果知分别。菩萨若施于怨憎者。慈因缘故。若施苦者。悲因缘故。若施有德者。喜因缘故。若施眷属兄弟僮仆。舍因缘故。是名菩萨因智慧施。复次菩萨知害施心。害施心者有四种。一者无量世来不习施故。二者财物少故。三者贪着好物故。四者不求后世善果报故。菩萨摩诃萨见来求者。富有财物不即发施心。是则菩萨无量世来不习施心。菩萨尔时应以智力而自思惟。以我从昔无量世来不习施故不即发心。我于今者多有财物兼有求者。若不惠施于未来世。复当增长悭吝之心。终不随顺不修施心。复次菩萨见来求者。财物少故不即发施心。菩萨复应以智慧力而自思惟。我以无量恶业因缘。无量世中身属于他。受大苦恼饥渴寒热。不能利益无量众生。以是业缘令身少财。今若不施复增来世贫穷困苦。我今以是少物施人。虽当贫苦终不至于三恶道苦。作是思惟。能坏少物悭吝之心。复次菩萨见有求者。于好物中心生贪着不即发施心。菩萨尔时应以智慧而自思惟。我于无常而作常想。无我所中作我所想。我若不施则长贪着。是我颠倒。是故菩萨能坏贪着好物之心。复次菩萨不求果报故不行布施。菩萨尔时应思惟言。一切诸法无常无定。若常定者则不须施。何以故。无因果故。以无常故则有因果。今若不施云何当得菩提道果。是故菩萨则能破坏不求果心而行惠施。菩萨摩诃萨知四颠倒。法无决定无有常相。是故能坏四怨恶心。复次菩萨内身寂静。至心思惟常作是念。我设有财当以供养诸佛菩萨。若施法僧。是名菩萨智慧布施。有财无财常作如是系心思惟。法施亦尔。是名一切施。云何菩萨难施能施。菩萨摩诃萨若有少物常以惠施。是名难施。心所爱重贪着之物。无量世中勤求得者。及大方便役力得者。以如是等惠施他人。是名难施。云何一切自施。菩萨摩诃萨若自行施。若教父母兄弟妻子眷属奴婢令行布施。是名一切自施。云何善人施。若善男子以善心施。信心施。至心施。自手施。应时施。如法得财施。是名善人施。云何菩萨一切行施。不求果报故。名一切行施。常施故。名一切行施。福田施故。名一切行施不观福田及非福田施故。是名一切行施。不观时与非时。是名一切行施。不观财物是可施是不可施。是名一切行施。云何菩萨为除故施。若有众生饥渴苦恼。为除此事而行布施。寒者施衣。求乘施乘。求璎珞者施以璎珞。涂香末香杂华灯明。房舍卧具病瘦医药。亦复如是。是名为除故施。云何自利利他施。菩萨摩诃萨若以财法施于彼者。能为己身及以众生作二世乐。常施众生无畏之乐。所谓虎狼师子水火王难怨贼能为救济。是名无畏施。菩萨摩诃萨法施者。凡有所说初无颠倒。是名法施。善能教诫一切众生。是名净法施。菩萨财施利益现在。行法施者则能利益现在他世。复有财施。或为众生作现世苦。法施不尔。能作现在他世乐事。财施不净法施清净。行财施者不名无边。法施之施名无边施。财施易得法施难遇。是名自他利施。云何名寂静施。寂静施者有十种。何等为十。一者无碍施。二者无错谬施。三者非庄严施。四者无高心施。五者无著心施。六者无羞施。七者无愁施。八者无[卑*頁]面施。九者无求恩报施。十者不求果报施无碍施者。菩萨摩诃萨行施之时。不为一切剧务世事之所障碍。虽知求者心无悒迟。然能疾舍称其所求。是名无碍施。无错谬施者。菩萨摩诃萨终不念言。施无果报无善恶报。亦不念言。杀生行施得善果报如婆薮所说。以不贪着施因缘故。得世间乐及阿耨多罗三藐三菩提果。是名无错谬施非庄严施者。菩萨摩诃萨终不聚物为好庄严而行布施。随得随施终不贮积。何以故。菩萨深知财命二法无常难保故。有来求者遇已便施。终不语言。待我庄严然后乃与。何以故。庄严施者则不得名庄严阿耨多罗三藐三菩提菩萨。若待庄严施者。则令众生大受苦恼。是名非庄严施。无高心施者。菩萨摩诃萨见来求者生谦下心。不自赞言我是施主。不求恩报不为胜他。行施名称而行布施。是名无高心施。无著心施者。菩萨摩诃萨不著名称。菩萨善观是名称者。如空如风藕根中丝。若求名施者我则不得阿耨多罗三藐三菩提。是故菩萨求阿耨多罗三藐三菩提不求名称。是名无著心施。无羞施者。行施之时三时欢喜。是名无羞施。无愁施者。菩萨摩诃萨以所重物施已无悔。是故无愁。是名无愁施。无[卑*頁]面施者。菩萨普观一切众生。其心平等无不喜见。是名无[卑*頁]面施。不求恩报施者。以怜愍故。修集慈故。施安乐故。不求报故。是名不求恩报施。不求果报施者。菩萨摩诃萨行施之时。不求转轮圣王身三十三天魔天梵天财物自在。何以故。菩萨深观有为之法如芭蕉树。是故施时不求果报。是故名为不求果报施。如是十事能令菩萨具足成就檀波罗蜜。得阿耨多罗三藐三菩提

    菩萨地戒品第十一

云何名菩萨摩诃萨戒。戒者有九种。一者自性戒。二者一切戒。三者难戒。四者一切自戒。五者善人戒。六者一切行戒。七者除戒。八者自利利他戒。九者寂静戒。自性戒者。菩萨摩诃萨具自性戒有四功德。一者以清净心从他而受。二者其心不净毁所受戒。应当至心惭愧忏悔。悔已专心更不敢犯。菩萨摩诃萨从他受戒生惭愧心。心惭愧故护持不犯。若心不净毁所受戒。心惭愧故不敢覆藏乃至一宿。菩萨犯戒若经一宿。若欲忏者不应直作一犯忏悔。应作念念无量犯悔。何以故。若是多犯作一犯忏者。不得名忏。受者得罪。菩萨从他受持戒时有四事。一者惭愧。二者至心坚持。菩萨摩诃萨至心持戒。终不生于毁犯之心。三者受已一心护持。四者净心受持。菩萨具足四功德戒能作四事。何等四。一者不犯。二者设犯寻悔。三者心生惭愧。四者不生悔恨。是名性戒。性戒菩萨名真实戒。名自他利戒。名饶益众生戒。名利益众生义戒。名增长人天戒。名无量功德戒。菩萨成就如是戒者。生心怜愍则能教化无量众生。菩萨若以客尘烦恼不忏悔者。应常为人赞叹持戒呵责破戒说毁禁者所得过罪。若能如是虽名毁犯罪过轻微。亦能毕竟得阿耨多罗三藐三菩提。是名自性戒。一切戒者。在家出家所受持者名一切戒。在家出家戒有三种。一者戒。二者受善法戒。三者为利众生故行戒。云何名戒。所谓七种戒。比丘比丘尼。式叉摩那。沙弥沙弥尼。优婆塞优婆夷。菩萨摩诃萨若欲受持菩萨戒者。先当净心受七种戒。七种戒者。即是净心趣菩萨戒。如世间人欲请大王。先当净持所居屋宅。是七种戒俱是在家出家所受。菩萨戒者亦复如是。俱是出家在家所受。是名为戒。云何名受善法戒。善法戒者。菩萨摩诃萨离七种戒。为菩提故修身口意十种善法。是名受善法戒。身口意者。若菩萨摩诃萨住戒地已。读诵书写分别解说。思惟修集舍摩他毗婆舍那。恭敬供养尊重赞叹师长和上耆旧有德。时时供给瞻视走使。若病若老。或道路疲顿代担衣钵。若见说法及经呗者称叹善哉。见持戒者尽力拥护赞叹于戒。愿诸众生悉持净戒。见破戒者深生怜愍。善语呵责教令忏悔。身口意业所作诸善。悉发誓愿回向阿耨多罗三藐三菩提。随身口意有气力时。勤心供养佛法僧宝。为增善法勤修精进。为得一切诸善法故修不放逸。常当至心念戒护戒调伏诸根。饮食知足不乐眠卧。初夜后夜读诵经典。忆念三宝亲近善友。乐闻其说自省已过。知已忏悔深生惭愧。至心忆念更不毁犯。向佛法僧同师同法同戒同学发露忏悔。是名受善法戒。为利众生行戒者。有十一种。若有众生欲修善者。即往劝喻共为伴侣共作善业。有瞻病者亦往劝喻共为伴侣。若有众生欲解世法出世法义。即以方便而为解说。有受恩处念欲酬报。酬报者。所谓坚持禁戒读诵书写十二部经。思惟正义分别解说。能救众生种种恐怖。所谓师子虎狼水火王贼。拥护众生令得远离如是等畏。若有众生丧失所亲捐弃财物。所爱别离心生愁忧。能为说法令离苦恼。若有众生贫穷困苦。则能施其所须之物。为持法故受畜弟子不为名利。为持法故往来四众。与共讲论不为利养。为持法故亲近国王大臣长者不为利养。不为檀越曲从人情造作非法身口意业。不得非时往来他家。在家出家俱有非时。非时者。所谓贪时恚时痴时。大风时大雨时。嫁娶时欢会时发行时。除上非时则名为时。随已所得善法功德。悉以转教一切众生心无贪妒。见毁戒者深生怜愍。以清净心善语教告。犹如父母教告诸子。汝所犯者宜应发露如法忏悔。若彼不受不宜如本受其供给身力作役。复应随事举处谪罚。若故不受应当驱遣令出寺庙。为令佛法得增长故。如其不能教呵罚摈故共住者。是名破戒。名非沙门非婆罗门。佛法中臭名旃陀罗。名为屠儿。旃陀罗等及以屠儿。虽行恶业不能破坏如来正法。不必定堕三恶道中。为师不能教诃弟子则破佛法。必定当堕地狱之中。为名誉故聚畜徒众。是名邪见。名魔弟子。不畜弟子不能破坏如来正法。畜恶弟子则坏佛法。坏佛法故名魔弟子。为利养故聚畜徒众。是名邪见。若有神通及他心智识宿命智。然后乃能以菩萨戒教化他人。是人则能畜恶弟子。何以故。知方便故。知方便故破坏恶法开示善法。若有比丘不具如是三种智慧。而言我具是三种智堪能受畜恶弟子者。当知是人则为犯重。若离此事名利他戒。菩萨摩诃萨成就如是戒善戒利益他戒。名为好戒摄一切戒。名到彼岸戒。名解脱戒。名无上戒。名无因果戒。名常乐我净戒。名毕竟无边戒。名一切善方便戒。菩萨若能至心忆念菩萨戒者。胜于一切声闻缘觉。若能具足菩萨戒者。亦得胜于六地菩萨。若有菩萨舍转轮王位。出家学道受解脱戒。放舍五欲如弃涕唾。不念不求不生悔惜。乃至天上五欲之乐。亦复如是。不为人天受快乐故受持禁戒。观五欲乐如火毒蛇。如三恶趣。得他供养观如吐食心不贪着。世人若为人天受乐利养名誉受禁戒者。当知是人不名得戒。成就戒者若住僧中若住空处。是名寂静。不能教化诸众生故不能护法。惜身命故不能护法。贪利养故不能护法。为怨隙故不能护法。为怖畏故不能护法。为憍慢故不能护法。不受法故不能护法。怜愍心故不能护法。惧惭耻故不能护法。是名破戒。名不寂静。若有于戒生知足者。当知是人不名持戒。知因戒故得诸菩萨无量三昧。若无戒者则不增长无量三昧。为三昧故护持禁戒。菩萨受持菩萨戒者。宁失身命终不听用非法之言与恶人住。不念不起诸恶觉观。如其起者心生惭愧呵责忏悔。若坐众中设闻恶语恶事恶法恶声恶义。即应起去。若力能制。置不教呵而舍去者。名之为犯。若力不能制而住听者。是亦名犯。若得不听心是名持戒。作听心者是名破戒。若乐听者是名破戒。不乐听者是名持戒。生悔心者是名持戒。心不悔者是名破戒。菩萨受持菩萨戒者。终不自念我所受戒齐从和上师边受得。自念乃从十方诸佛菩萨边受。我若从师及和上边受得戒者。不名菩萨戒。若从十方佛菩萨边所受得者。乃名菩萨戒。菩萨摩诃萨若分别十八部僧不名得菩萨戒。若能等观悉是十方诸佛菩萨弟子者。是名得菩萨戒。若观一切悉是十方诸佛菩萨弟子住于大地。以住大地因缘故。悉得阿耨多罗三藐三菩提。众生界不可思议。众生法界不可思议。众生性不可思议。众生戒不可思议。我既未得一切智。云何分别是十八部。我若分别则不能得一切戒无碍戒无上戒。以能如是观故得菩萨戒。如过去菩萨所得禁戒。菩萨若能如是观者。则得无量无边福德。能知十方佛菩萨心。亦知具足菩萨戒者得无上道。菩萨摩诃萨观过去诸佛及诸菩萨。未得成就无上道时。具足烦恼学菩萨戒。具足成已得无上道。我今此身亦是众生。亦有五阴。亦具烦恼。亦受菩萨戒修集菩提。亦应当得阿耨多罗三藐三菩提。我亦能调身口意恶。必亦当得阿耨多罗三藐三菩提。菩萨受持菩萨戒者。至心专念自省已过不讼彼短。见行恶者心不嗔恨。见破戒者心生怜愍。无有嗔恼。菩萨受持菩萨戒者。若为恶人之所打掷手拳刀杖恶声骂詈。于是人所不起恶心粗言加报。菩萨若学菩萨戒者有五不放逸。一者观已犯罪如法忏悔。二者观当犯罪如法忏悔。三者观现犯罪如法忏悔。四者至心坚持不作犯想。五者犯已至心忏悔。是名五不放逸菩萨受持菩萨戒者。所有功德应当覆藏。诸所犯罪应当发露。少欲知足堪忍众苦。常乐寂静心无悔恨。不自高不轻躁。修寂灭行及微细行破坏邪命。菩萨成就如是法者。是名菩萨住菩萨戒。菩萨受学菩萨戒者。不念过去五欲之乐。不求未来五欲之乐。于现在五欲心不生着。常乐寂静破恶觉观。成就具足不放逸行。一切众生不敢轻慢。成就忍辱具足净心。学净戒者不惜身命不吝财贿。善知破戒烦恼因缘。善能调伏破戒烦恼。调伏嗔心。能调众生恼害之心。了知颠倒知善因果。知善因果故勤心求之。破坏不信善因果倒。观一切法无常我相无乐净相。破于众生无常常倒无乐乐倒无我我倒不净净倒。修学善戒修集施因戒因忍因精进因禅定因智慧因。菩萨受持利益他戒故。教化众生令行善业。共修善者而为伴侣。常教众生供养三宝。若见离别以善方便还令和合。见有病苦身自供给。见盲瞽者供给所须衣服饮食示导径路善为说法。见有聋者画地示义。见有躄者施其车乘。若无车乘身自荷负。见有贪者以贪受苦能为说法令除贪苦。嗔恚痴疑亦复如是。行路疲乏代其担负。施以水浆床褥所须调身按摩。复有众生乐为罪业菩萨见已应善说法。善辞善义。辞合句合。辞义次第增长善法说义圆足。为欲庄严菩提道故。以善方便教破恶业。为悭贪者说破悭法。增长善法及诸财物。若有众生不信佛法。善为说法令生信心。为破众生烦恼恶业。得八正道故而为说法。复次菩萨学菩萨戒发大誓愿。为破众生诸恶邪见。知恩报恩。忍语软语先意问讯。供养师长耆旧有德。能破愁怖。所谓师子虎狼水火王难怨贼。若有众生丧失父母兄弟眷属妻子僮仆。捐弃财物亲爱别离。能以方便如应说法除其苦恼。常施众生所须之物。所谓衣服食饮房舍卧具病瘦医药。香华璎珞灯烛等物。若菩萨受持菩萨戒者。畜养弟子不能善教说法示导令其调伏贪嗔痴等。不能供给衣服饮食房舍医药。不能为求善厚檀越。若为檀越善说法要。所得财物不能等分。当知是人为名誉故。畜养弟子不名为法。若能随时说法教告。为性为力为菩萨藏。为欲具足菩萨禁戒。修八正道。得阿耨多罗三藐三菩提。是名菩萨真畜弟子不为名誉。菩萨受学菩萨戒者。先当观知众生性界。然后共住为转性界。如应说法随意共行。令其调伏不造诸恶。能破恶法增长善法。所须之物能以惠施。见作恶者深生怜愍。不受语者深生悲恼。于己所作诸恶业等心不生愁。见他造作特生悲愍。何以故。菩萨自于身口意恶。能疾调伏开心忏悔。以有大智因缘力故。菩萨为他亦复造作身口恶业。为欲调伏他恶业故。随他心故。菩萨或时现受欢乐。为调他故。菩萨摩诃萨以为他故不早取阿耨多罗三藐三菩提。菩萨摩诃萨虽随众生不轻不笑不打不骂不说恶事不赞己德。以自高人。不亲近人非不亲近。虽复亲近非时不为。他所爱着不说其过。所不爱者复不赞叹。未知人根不说深义。不从求乞他虽多施应生知足。心不甘乐受人供养常。乐舍财供给他人。常乐赞叹他人善事。见犯禁者不为说戒。无信心者不赞于信。有贪心者不赞惠施。不乐读诵不赞多闻。痴闇之人不赞智慧。若为犯禁赞叹戒者。不喜不乐生于嗔恚羞耻之心。以嗔恚故于佛法中及说者所生大恶心。以恶心故增长地狱。菩萨摩诃萨若如是者。则施众生地狱因缘不名菩萨。随意说法乃至痴者为赞智慧亦复如是。若有菩萨有大神足。如是之人乃能为彼不信之人说菩萨戒。何以故。是人能以神通之力。示彼热地狱寒地狱大地狱小地狱。复作是言。汝今云何不信我语。观是恶果。人中造作令地狱受。汝今若复不信如是菩萨戒者。今当复得如是恶果。彼不信者见是事已。心惊怖畏即生信心。复有菩萨为彼不信。以神通力现罗刹像而作是言。我今求觅诸不信者欲断其命。如其信者我当护念。彼不信者见闻如是即生怖畏。以怖畏故信菩萨戒。复以神力现密迹像执金刚杵。复作是言。若有不信菩萨戒者。当破其头令作七分。彼不信者见闻如是即生怖畏。以怖畏故即便信之。复以神力作种种身。或作一身。或作多身。或作树木山河等身。无碍之身大身小身。身出水火。彼不信者见已即问。如是等事悉是何果。答言。悉是菩萨戒果。彼人闻已于菩萨戒生大信心。若无神通为彼不信说菩萨戒得无量罪。无量罪者于无量世受。是名无量。虽有五逆未足为喻。何以故。五逆罪者则可移转。如阿阇世王。彼不信者罪不可转。五逆罪者极至一世。不信者罪无量世受。是故我言。不可为喻。若取佛物法物僧物现前僧物。如是罪报亦不得喻。何以故。如是罪报极至一世。不信者罪至无量世。如十恒河沙等众生发菩提心。假使有人能令如是恒沙众生退菩提心。教以邪见。如是罪报及不信者罪等无差别。复令如是恒沙众生皆住五地。假使有人尽夺其眼。如是罪报。不信者罪亦复如是。若复有人能破一切诸佛塔庙。杀害一切诸佛弟子。焚烧一切诸佛经典。如是罪报。为不信者说菩萨戒所得罪报。亦复如是。何以故。从因故生地狱。从因故入涅槃。因于说者得无量苦。是故说者得无量罪。虽知大众无量众生堪任能作人天善业及发信心。于是众中若有一人心无信者。亦不可说。是名菩萨利益众生善戒

菩萨善戒经卷第四菩萨善戒经卷第五

        宋罽宾三藏求那跋摩译

    菩萨地忍品第十二

云何菩萨摩诃萨性忍。智慧力故能堪种种苦恼等事。一切忍一切忍。一切忍有怜愍故。得慈心故。性忍有二种。一者出家。二者在家。在家出家俱有三种。一者能忍众生打骂等事。二者能自堪忍一切诸苦。三者忍乐善法。能忍众生打骂等者。菩萨摩诃萨若为众生所打骂时。作是思惟。缘我是身造作恶业今自受报。云何于彼而生嗔恚。我亦不求是苦烦恼。今若不忍后复增多。不忍辱者是则名为苦烦恼因。我所受身及诸烦恼。非众生过自是我咎。若有恶事实不乐受。今若不忍便是自作。若自作者复当自受生死性苦。身若受苦云何不忍。声闻缘觉为自利益尚修忍辱。何况我今为欲利益一切众生而当不忍。我若不忍不得具足菩萨禁戒修八正道得无上道。菩萨摩诃萨作是观时修五种忍一者于怨于亲非怨亲中修行于忍。二者于上中下人修集于忍。三者于受苦受乐不苦不乐人中修集于忍。四者于有福德无福德非有福德非无福德人中修集于忍。五者于一切恶人中修集于忍。菩萨成就如是五忍修集五想。一者众生想。二者法想。三者无常想。四者苦想。五者无我我所想。菩萨为彼恶人所打。云何而能作亲友想。菩萨谛观。过去世时流转生死。无有众生非我父母师长和上眷属亲族所可恭敬供养之者。作是观时怨憎想灭亲友想生。亲想生故能修于忍。是时成就众生之想。法想者。菩萨谛观。众生者名为法界。名有为法。名有漏法。若是法界还对法界谁打谁嗔。无我无我所寿命士夫。以智慧力作是观时。灭众生想成就法想。无常想者。菩萨思惟。一切众生一切有为有漏之法皆悉无常。以无常故谁有骂者谁有受者。若使骂者及以受者暂时停住。则不得言诸法无常。若使常者谁骂谁受。常无常中俱无是二。俱无作受尚不应生微恶之心。何有打骂。是故菩萨破于常想修无常想。以能修集无常想故成就忍心。成忍心故修菩提道。乃至得阿耨多罗三藐三菩提。云何菩萨修集苦想。菩萨摩诃萨作是观察。若欲界众生得大自在。饶财巨富如转轮王尚有三苦。况复余人。三苦者。谓复变苦生死苦苦苦。作是观时。若使众生有此三苦我不应嗔。我若嗔者云何当能救彼众生是三苦耶。我若嗔者则为增长众生三苦。作是观时。乐想灭苦想生。以能修集苦想因缘故。修八正道得阿耨多罗三藐三菩提。云何菩萨修无我无我所想。菩萨谛观。有诸外道说我是常。我若常者众生无我。何以故。众生者即是五阴。五阴无常。若无我者何有我所。是故无我无我所。菩萨复作是观我者即是菩提之心。菩萨初发菩提心时。于众生中得一子心。是名我所。若我于彼有嗔心者。云何得名有我有我所。我若增长嗔恚心者。不能度脱一切众生。作是观时。成就于忍增长无我无我所心得无我想。以是因缘修八正道得阿耨多罗三藐三菩提。云何菩萨能忍众生打骂等苦。菩萨尔时复作是观。我于过去为五欲故备受众苦。在家作务耕田种殖受种种苦。亲近国主市买贩易多受众苦。我于尔时虽受如是种种大苦不得利益。若我今为度众生故。受诸苦恼当得利益。我若当得大利益者。应受无量不可计苦。作是愿时。菩萨则能堪忍众苦。受苦者名一切苦。一切苦者有八种。一者依苦。二者世法苦。三者威仪苦。四者摄法苦。五者乞食苦。六者精进苦。七者为利众生苦。八者营事苦。依苦者名四依苦。若比丘受四依已。得出家受戒得名具足比丘。若得少衣少食卧具病药。不生愁苦心无悔恨。以能修集坏苦心故。修八正道得阿耨多罗三藐三菩提。是名依苦。世法苦者有九种。一者求不得苦。二者恶声苦。三者现对恶法苦。四者苦苦。五者亡失苦。六者物尽苦。七者老苦。八者病苦。九者死苦。是名世法苦。菩萨受是九种苦时。不生愁恼心不悔恨。不废无上菩提之心。以不悔故菩提增长。菩提增长故得阿耨多罗三藐三菩提。威仪苦者名身四威仪。一者行。二者住。三者坐。四者卧。菩萨若行若坐。昼夜常调恶业之心忍行坐苦。非时不卧非时不住。所住内外若床若地若草若叶。于是四处常念供养佛法僧宝。赞叹经法受持禁戒。持无上法广为人说。正思惟义如法而住。分别法界修舍摩他毗婆舍那。菩萨修集如是法时。设有诸苦堪乐忍受。是名威仪苦。摄法苦者有七种一者身舍饰好。二者剃除须发。三者着割截衣。四者一切世事不得自在命属于他。五者乞求活命。六者远离生业少欲知足。七者舍离亲族五欲之乐。是名摄法苦。乞求苦者。供身之物衣服饮食房舍卧具病瘦医药。一切仰他不得不嫌得时知足。乃至尽寿。障受五欲伎乐戏笑忍如是苦是名乞食苦。精勤苦者。菩萨精勤供养三宝。受持读诵菩萨藏经。书写解说思惟其义昼夜不废。勤加精进修集圣道。以精进故堪忍众苦。是名精进苦。为利众生苦者。如上利内外十一事中说。是名利众生苦。营事苦者。熏钵缝衣染作浣濯。众僧使役供给师长。若为供养涂扫佛塔。为善法故终不休息。为阿耨多罗三藐三菩提故忍种种苦。是名营事苦。忍乐善法苦者有八种忍。受三宝所有功德忍。佛菩萨不可思议忍。因忍。果忍。善方便忍。佛菩萨性复有二忍。一者究竟忍。二者净智慧忍。是名法忍。云何菩萨难忍。难忍有三种。一者有无量众生打骂菩萨菩萨能忍。二者菩萨有自在力能打能骂忍受不报。三者菩萨处在种族豪贵能忍卑下。云何一切自忍。菩萨摩诃萨于怨亲中非怨亲中忍。下忍中忍上忍。是名一切自忍。善人忍者。有五种知忍功德。一者不着恶心嗔心。二者心难沮坏。三者心无愁恼。四者死时无悔。五者死已受天人乐。菩萨观忍有如是功德。教化众生令行于忍。自所修忍亦得增长。赞叹忍辱。见行忍者恭敬尊重赞叹礼拜。是名善人忍。一切行忍者。菩萨摩诃萨观不忍者所有过恶。云何名恶果报。能得三恶道故。畏恶道故应修行忍。怜愍故忍。为修慈故忍。为软心故忍为爱众生故忍。至心为阿耨多罗三藐三菩提故忍。具足羼提波罗蜜故忍。为出家故忍。为受戒故忍。为具足性故忍。为欲修集无量世忍故忍。为得忍性故忍。为得无爱无嗔故忍。为见法界故忍。为见众生界故忍。一切时忍。一切国忍一切心忍。是名一切行忍。除忍者。若有贫穷之人数从菩萨乞索所须。复有恶人亦来从乞。复有破戒之人亦来从乞。破坏恶心修集忍心。为破苦故施以乐事。是名除忍。自利利他忍者。菩萨忍于饥渴寒热风雨恶兽终不放逸。生死受苦怜愍众生。菩萨摩诃萨得如是等忍。增长现在一切善法远离烦恼。他世获得无量善果。悉能调伏众生恶心。恶心调故一切烦恼不得其便。现在安乐后获善果。是名自利利他忍。寂静忍者。菩萨若为诸恶众生之所打骂。于彼终不生于恶心。不作怨想作善友想。若无如是诸恶人者。我之善法云何增长。见有骂者软语慰喻。修慈悲心能坏欲界所有烦恼。具足如是十忍菩萨。能修八正道得阿耨多罗三藐三菩提

    菩萨地精进品第十三

云何菩萨性精进。性精进者心勤精进。为摄善法故。为利众生故。为令众生得无上道故。为破颠倒故。以性精进故得身口意业善。是名性精进。一切精进者有二种。一者世。二者出世复有二种。一者在家。二者出家。复有三种。一者庄严。二者摄取善法。三者为利众生。庄严者。菩萨摩诃萨初发心时勤精进庄严。若我能令一人解脱。于无量劫在地狱中受大苦恼。受大苦恼已然后得阿耨多罗三藐三菩提。得菩提已乃至能令一人解脱。亦当受于地狱之苦心不休息。是名庄严。菩萨具足庄严精进。胜于一切声闻缘觉所得功德。不可称计。何以故。为欲利益一切众生受大苦故。若为一人受大苦恼。尚得无量无边功德。何况乃为一切众生。是名菩萨庄严精进摄取善法。勤精进者。若为修行檀波罗蜜尸罗波罗蜜羼提波罗蜜禅波罗蜜般若波罗蜜勤精进者。名为不动。一切烦恼一切恶业一切邪见一切苦恼不倾动故。亦名坚固。健庄严故。复名一切。知世方术及出世法故。复名具足方便。真实因缘修集道故。复名真实。得真实义故。复名为广。一切时中无休息故。复名调伏。勤修精进不生憍慢故。如是七事增长善法。是名摄取善法精进。以勤精进故。具足六波罗蜜勤精进法。于诸趣向菩提法中。是近因缘无上无胜。是故如来于经中说。阿难。勤精进者疾得阿耨多罗三藐三菩提。为利众生勤精进者有十一种。如戒中说。难精进者。菩萨摩诃萨不作衣想。不作食想。不作卧具想。不作我想。不作我所想。不作法想。不作道想。不作菩提想。亦为菩提勤修精进。是名难精进。于一切时一切国一切心勤修精进。是亦名难。不急不缓处中而行。是名难精进。难精进有二种因。一者悲。二者慧。一切自精进者有四种。一者离恶法。二者增长善法。三者莹磨善法。四者增长智慧。离恶法者。名菩萨摩诃萨勤修精进。未生恶法勤作方便令不生故增长善法者。已生善法方便令增广故。莹磨善法者。勤修身口意业因缘。至心系念受持善法故。增长智慧者。若菩萨勤修精进多闻修定增长智慧故。是名一切自精进。善人精进者。菩萨为善法故。勤精进时设烧身首不以为热。菩萨修善法时勤行精进。尚自不觉地狱火热。况世间火。菩萨精进不多不少平等而行。增长精进善调御故。所以者何。心清净故。不休不息心不悔故。得大利益不颠倒故。毕竟能得阿耨多罗三藐三菩提故。是名善人精进。一切行精进者。常勤精进。至心精进。智慧精进。不断精进。庄严精进。忍苦精进。不动精进。不时精进。不知足精进。菩萨成就一切行精进名为大力。常勤精进。安住善处坚固庄严。不休不息得于善法。欲心精进菩萨摩诃萨。求阿耨多罗三藐三菩提故。至心欲精进菩萨摩诃萨。增长菩提心故。方便心精进菩萨摩诃萨。诸烦恼垢不污其心。以身为器成阿耨多罗三藐三菩提故。胜精进菩萨摩诃萨。为于善法不救身首火故。如是菩萨胜于一切声闻缘觉。求精进菩萨摩诃萨。求于世法及出世法诸方术故。学精进菩萨摩诃萨。速得世法及出世法故。利他精进菩萨摩诃萨有十一种如戒中说。不作犯意犯已忏悔。除精进及自利利他。如忍中说。寂静精进者有十种。一者宜。二者修集。三者非动。四者坚持。五者一切时。六者缘三相。七者舍。八者不散。九者调御十者趣向菩提。菩萨若起一切烦恼。为除病故随对治之。如贪欲起观不净相。嗔恚起时修于慈心。愚痴心起观十二因缘。思觉起时观阿那波那。破憍慢故观众生界。是名宜精进。菩萨精进非始非终。无量世中常得成就。是名修集精进。菩萨精进常勤修集亦如初得。是名非动精进。一切时中勤精进故。是名非动。菩萨摩诃萨常能亲近诸师长宿有德之人修学多闻。若修三昧思惟其义。勤行精进随顺听受。是名坚持精进。菩萨摩诃萨心不颠倒。宜修舍摩他时修舍摩他。宜修毗婆舍那时修毗婆舍那。宜修舍时修行于舍。是名一切时精进菩萨善知定慧舍时时修集三相。入相住相起相。不失正念至心精勤。是名缘三相精进。菩萨若闻诸佛菩萨勤精进故不可思议。闻已其心不自轻不愁恼不知足。是名舍精进。菩萨摩诃萨时时调伏诸根诸入。饮食知足。初夜后夜减损睡眠。至心不乱无有放逸。推求庄严发勤精进。修真实义心无颠倒随顺修道。是名不散精进。菩萨精进不急不缓。所作事业处中而行。是名调御精进。菩萨一切精进悉以回向阿耨多罗三藐三菩提。菩萨摩诃萨修性精进乃至寂静精进。悉为阿耨多罗三藐三菩提故。是名一切精进。悉以回向阿耨多罗三藐三菩提。过去世诸菩萨所持精进。悉为阿耨多罗三藐三菩提。未来世诸菩萨所持精进。亦为阿耨多罗三藐三菩提。现在世诸菩萨至心不放逸所持精进。亦为阿耨多罗三藐三菩提。是名趣向菩提精进

    菩萨地禅品第十四

云何菩萨摩诃萨性禅。菩萨若闻菩萨法藏。若思惟义。若世间禅出世间禅。系心一处定智分等修集于道。是名性禅。一切禅者有二种。一者世间。二者出世间。是二种复有三种一者入禅现在受乐。二者入禅增长菩提。三者入禅利益众生现在受乐者。菩萨摩诃萨破诸疑网身心寂静。受远离乐坏诸憍慢。不贪着味离一切相。是名入禅现在受乐。入禅增长菩提者。菩萨摩诃萨禅定有种种缘。不可思惟。不可称计。无有限量。摄十力性得种种三昧如是三昧一切声闻辟支佛等尚不识名。况能修集。复有共法。所谓八胜处。十一切处。四无碍智。愿智无诤智顶智。增长如是共有法故。是名入禅增长菩提。入禅利益众生者。有十一种。如戒中说。菩萨摩诃萨修具如是十一种禅。能化众生破苦烦恼。修集善法种种智慧。知恩报恩能救众生种种苦恼。能施一切所须之物。善知方便能畜弟子。能使弟子随意受行。如是等禅名一切禅。难禅者有三种。一者菩萨摩诃萨入禅定时。所受快乐胜于一切世间之乐及出世乐。为众生故舍禅定乐受欲界身。二者菩萨摩诃萨修集禅定。无量无边阿僧祇等不可思议不可称计。修集三昧。一切声闻辟支佛等。不能知其所入境界。三者菩萨摩诃萨禅因缘故。得阿耨多罗三藐三菩提。是名难禅。一切自禅者有四种。一者共觉观。二者共喜。三者共乐。四者共舍。是名一切自禅。善人禅者有五种。一者无爱。二者共慈。三者共悲。四者共喜。五者共舍。是名善人禅。一切行禅者有十三种。一者善无记。二者神足。三者趣舍摩他四者趣毗婆舍那。五者自利。六者利他七者得五神通功德禅。八者辞因缘。九者义因缘。十者舍摩他相因缘。十一者毗婆舍那相因缘。十二者舍相因缘。十三者现在受乐行因缘。是名一切行禅。除禅者有八种。一者菩萨入三昧时。能除众生种种苦毒。所谓暴风雹雨热病鬼病。是名为禅。二者若入三昧能治众生身中四大不调适苦。是名为禅。三者若入三昧能于亢旱饥馑之世施降甘雨。是名为禅。四者若入三昧能令众生离种种怖。所谓人怖鬼怖水怖陆怖。是名为禅。五者若入三昧能施旷野饥乏众生水浆饮食所须之物。是名为禅。六者若入三昧能施贫穷困苦之人种种所须。是名为禅。七者若入三昧能破十方众生放逸。是名为禅。八者若入三昧能破众生种种疑网。是名为禅。是名除禅。自利利他禅者有九种。一者入禅因神足故调伏众生。二者入禅因他心智故调伏众生。三者入禅因真实说故调伏众生。四者入禅为恶众生示地狱苦。五者入禅令失喑者语。六者入禅令失念者念。七者入禅随顺解说十二部经菩萨法藏菩萨摩夷。为法久住。八者入禅能教众生种种世事。书疏算数读诵书印金木瓦匠。九者入禅为施大光明破三恶众生苦恼。是名自利利他禅。寂静禅者有十种。一者世法寂静净。二者出世法寂静净。三者方便寂静净。四者根本寂静净。五者上寂静净。六者入寂静净。七者住寂静净。八者起寂静净。九者自在寂静净。十者烦恼智慧二障寂静净。如是十种寂静净。名为净禅。菩萨修集如是十种。成就无量无边功德。为得无上菩提果故。过去未来现在菩萨皆修是禅。得阿耨多罗三藐三菩提

    菩萨地慧品第十五

云何菩萨性慧。为一切智故分别法界。是名性慧。又复善学五种方术。所谓内方术因论声论医方一切世事。是名性慧。一切慧者有二种。一者世间。二者出世间。是二种复有三种。一者知如实如实。知五种术。知三聚众生。知利益众生方便。知法界不可说。知四真谛无我无我所。于诸法界无有觉观。观诸法界其心平等。不舍不着不常不断说于中道。是名智慧。二者知世间事及出世法。为阿耨多罗三藐三菩提故。是名智慧。三者观深法界分别演说。为利益众生故。是名智慧。是名一切慧。难慧者有十一种。如戒中说。为调众生故善知其心。是名难慧。知一切法界无有障碍。是名难慧。为诸众生说深法界。是名难慧。善知无我及无我所。是名难慧。一切自慧者。若能受持读诵解说声闻法藏菩萨藏故则得修智。因修智故得智慧力。智慧力故知可修不可修可作不可作。至心观无量事。是名一切自慧。善人慧者有五种。一者因闻正法故得。二者因思惟正法故得。三者因自利利他故得。四者因不颠倒见法处所故得。五者因破烦恼故得。复有五种。一者能知微细甚深义故。二者修集禅定知法界故。三者共慧庄严得智慧故。四者从佛菩萨来故。五者具足获得寂静之心乃至毕竟心故。是名善人慧。一切行慧者有十三种。一者苦智。二者集智。三者灭智。四者道智。五者尽智。六者无生智。七者法智。八者比智。九者世智。十者通智。十一者因智。十二者力智。十三者初心智。是名一切行慧。除慧者。谓四无碍智世智出世智。破一切闇故。是名除慧。自利利他慧者。如初五术中说。以是五术因缘故。得阿耨多罗三藐三菩提。是名自利利他慧。寂静慧者为真实故修集。为众生故修集。为得义故修集。为知因果故修集。为破颠倒故修集。为善知方便故修集。为知作不作事故修集。为知烦恼故修集。为毕竟得故修集。是名寂静慧。菩萨具足如是十慧。名智名慧。亦名毕竟。亦名真实。亦名无量慧。以是无量慧因缘故。菩萨具足般若波罗蜜。具足般若波罗蜜故。得阿耨多罗三藐三菩提。如佛经中。有具足般若有不具足。当知十种性乃至寂静。或说一波罗蜜。或说二三四五六。若说一则摄于六。乃至说六亦摄于六。若有众生闻一一中十种名字。信受奉持读诵书写。分别广说教化众生。毕竟当得具足成就六波罗蜜

    菩萨地软语品第十六

云何菩萨性软语。菩萨摩诃萨欢喜语乐闻语实语法语义语利众生语。是名性软语。一切软语者。菩萨摩诃萨若见有人初未相识。见已软语先意共谈。若见前人端正有德胜于己者不怀妒心。破于憍慢敬意问讯。四大安不。道路疲极不。苦恼不。善来相见。为施床座给施浆水为行世法故。随众生意故菩萨终不为诸众生说粗恶语。所谓死杀破坏劫夺失物。唯说善语。所谓汝儿息长大今已娉娶。财物滋息谷米丰熟。智慧成就。信戒施进广博多闻。菩萨具足如是法语为利众生。是名一切软语。解析软语者有二种。一者随世。二者随出世。世者有二。一者下世。二者上世。出世有二种。一者正法自利出世。二者正法利他出世。菩萨摩诃萨为下上世法软语。为自利利他出世软语。是名解析软语。难软语者。若有众生来害菩萨。菩萨于彼生于子想至心软语。谓打者骂者劫者。又难软语。菩萨摩诃萨常为痴人软语说法。身口意业多受众苦。虽受大苦续复教喻。汝好勤学后当如我。或复见胜是名难软语。复次菩萨见有嗔人妒人悭人。不受师教欺诳师长父母宿德。恶害邪见贼栴陀罗。与共软语不生恶心。是名难软语。一切自软语者有四种。一者为破烦恼因缘故软语。二者为生人天因缘故软语。三者为增长善法因缘故软语。四者为说庄严菩提因缘故软语。复有四种。一者说四真谛令彼解故。二者破四倒故。三者破放逸故。四者破疑心故。是名一切自软语。善人软语者。菩萨摩诃萨教化众生时。有因缘故说法。所谓为解说因缘故说法。为庄严菩提因缘故说法。为神足因缘故说法。为持戒因缘故说法。是故诸法从缘故生。从缘故灭。是名善人软语。一切行软语者。若说法时有可听者。有可遮者。以柔软语随顺法性说字不倒。有恐怖者能以软语令除恐怖。有求乞者亦以软语许之施与。是名一切行软语。除软语者。离口四恶妄语两舌恶口无义语。见则言见。闻则言闻。知则言知。识则言识。不见不闻不识不知亦复如是。是名除软语。自利利他软语者。若见受苦之人为说软语。若以软语教化众生。或以软语教诫众生。或以软语教令正见。或以软语教令行施。或以软语教令正命。或以软语说于正法。是名自利利他软语。寂静软语者有二十种。如初性力品中说。性利他者。若菩萨摩诃萨为教诫他。分别戒义说如法住义。怜愍众生修集悲心。至心教化调伏众生。是名性利他。一切利他者。未熟众生令解脱故。得现世乐及他世乐。教出家者是名他世乐。说法教令破欲界结。是名现在他世乐。以破欲界诸烦恼故身心寂静。身心寂静故受安乐。是名一切利他。难利他者有三种。一者若有众生未种善根未有善因难教化者。是名难利他。二者若有众生多饶财宝势力自在。贪心悭吝难可教化。何以故。放逸故。是名难利他。三者若有外道邪见难可教化。何以故。痴狂故。能化如是等得利益故。是名难利他。一切自利利他者有四种。一者未有信者教令生信。二者未有戒者教令持戒。三者悭贪之人教令修施。四者愚痴之人教令得慧。是名一切自利利他。善人利他者。菩萨摩诃萨教化众生。令知真实知时知义知柔软语。教化修慈。是名善人利他。一切行利他者。菩萨摩诃萨见诸众生可赞叹者则以美言赞叹。可呵责者则以苦言呵责。若有众生于佛正法破信心者则能调伏。未入佛法者教令得入。已得入者为说正法。令彼善根得增长故。调伏安置于三乘中。根已熟者为说解脱。乐声闻者教令发阿耨多罗三藐三菩提心。未有善庄严者教令庄严。无定性者教定性心。是名一切行利他。除利他者。若有众生无惭愧者教令惭愧。粗犷之人教令修心。为妒嫉者除坏妒心。为悭贪者除断悭心。为疑心者除破疑网。是名除利他。自利利他者。菩萨摩诃萨常以十善教化众生。是名自利利他。寂静利他者有十种善。内寂静有五种。外寂静亦有五种。内五种者。一者净。二者不转。三者次第。四者遍有。五者随顺善法。净者。菩萨不以恶法不净法不善法用教众生。是名为净。不转者。菩萨于解脱中不说非解脱。清净法中不说不净。不颠倒中不说颠倒。是名不转。于非解脱不说解脱。不净法中不说清净。颠倒法中不说非倒。是名不转。次第者。菩萨见有痴者说浅易义而调伏之。中根之人为说中法。利根之人为说上法。先说惠施次说持戒后说智慧。是名次第。遍有者。菩萨说法之时不观众生种姓贫富。随力随智而为说法。令彼众生得安乐故。是名遍有。随顺善法者。观诸众生应得下中上法随为说之。是名随顺善法。外寂静五事者。一者菩萨摩诃萨修集无量慈心为众生故。二者受无量苦为众生故。三者得大喜见诸众生得利益故。四者得大自在犹属众生如僮仆故。五者有菩萨具大威德。犹故谦卑如栴陀罗子故。是名内外寂静利他。云何名菩萨摩诃萨同利。菩萨摩诃萨既自成就具足善法。复以此法转劝众生。是名菩萨同利。菩萨摩诃萨为同行故教化众生。众生受已善法心坚难可倾动。何以故。众生谛知菩萨成就是善法已转以劝我。为欲令我得安乐故。若修善法得恶事者。菩萨摩诃萨终不自修以劝于我。菩萨劝化无量众生同己利时。无有一人能说菩萨自不成就而劝于人。亦无有言汝自不善云何劝他令行善法。复次菩萨有自成就不能劝他。有自不成而能劝他。有自成就能劝于他。有自不成亦不劝他。自成就不劝他者。同师同学同法同德不显己功。是名自成不劝于他。自不成就而能劝他者。菩萨若见诸恶众生行于恶法。栴陀罗人乃至畜生。为调伏故同彼受身同于事业。破恶业故。是名自不成就而能劝他。有自成就能劝他者。菩萨摩诃萨自成善法。亦劝他人令成善法。破于憍慢轻心转心。是名自成能劝于他。有自不成不劝他者。若菩萨自放逸故。不能教化调伏众生。菩萨摩诃萨以六波罗蜜自庄严身。以四摄法庄严众生。菩萨摩诃萨以六波罗蜜自调其心。以四摄法调众生心。身口意净故菩提数法净。自身净故众生心净。成就善身心故。名为无上无胜无共。以此无上无胜无共教化众生。是名同利。菩萨摩诃萨于诸众生于时于物悉无分别。于众生中无分别者。菩萨为众生故。行檀波罗蜜乃至般若波罗蜜求诸善法。于时无分别者。菩萨摩诃萨于一切时为众生故。勤心精进求于善法。于物无分别者。菩萨摩诃萨为众生故受畜杂物。然于此物心无贪着。以是三无分别因缘故。得阿耨多罗三藐三菩提。菩萨摩诃萨甘乐修集一切善行心无悔退。以修集因缘故。能坏众生邪法邪见。自所修学善根增长。至心观察善行功德。一切邪见不能沮坏。终不求于转轮王身释身魔身及以梵身。不求恩报利养名誉长寿身乐。菩萨修集如是等法。则得具足檀波罗蜜乃至般若波罗蜜。是名同利。菩萨摩诃萨修同利时心不动坏。清净寂静大明无翳。菩萨摩诃萨住净心地。具足成就无上善法光明善法。光明善法者。菩萨摩诃萨所行善法。一切无有能呰毁者。菩萨摩诃萨心不动者。所修善法无有动转。日夜增长如初生月。寂静善法者。菩萨所得三昧寂静同于如来。垂近阿耨多罗三藐三菩提菩萨摩诃萨一切施戒一切四摄因缘故。得金刚身。得法身果。菩萨摩诃萨难施难戒因缘故。获得如来不可思议功德妙果。一切自施戒因缘故。得诸人天所奉供养果。善人施戒因缘故。于众生中为无有上。一切行施戒因缘故。获得如来三十二相八十种好。除施除戒因缘故。得坐道场菩提树下。魔王眷属不能倾动。自利利他施戒因缘故。获得如来常乐解脱。寂静施戒因缘故得四寂静果。所谓身寂静缘寂静心寂静智寂静。十力四无所畏大悲三念处五智三昧。为众生故数有十八不共之法。利智慧故乃有无量不共法数

菩萨善戒经卷第五菩萨善戒经卷第六

        宋罽宾三藏求那跋摩译

    菩萨地供养三宝品第十七

云何名为菩萨摩诃萨供养如来。供养如来凡有十种。一者供养色身。二者供养塔。三者现见供养。四者不现见供养。五者自供养。六者他供养七者利益供养。八者最胜供养。九者清净供养。十者受持供养。供养色身者。菩萨摩诃萨若见佛色身而供养之。是名供养色身。供养塔者。若菩萨摩诃萨为如来故造作塔庙形像龛窟。修治已坏朽故之塔。若见新塔花香供养。是名供养塔。现见供养者。菩萨摩诃萨若现见如来形像时。如见此佛见十方佛亦复如是。是名现见供养。不现见供养者。菩萨摩诃萨若供养现在诸佛及佛塔庙得信解心。我今现见作是供养。亦得供养过去未来佛。何以故。一切如来同一法性故。以是故则得供养去来诸佛。若我供养现在佛塔。亦得供养去来佛塔。何以故如是诸塔同一法性故。若供养一佛则已供养十方诸佛。若供养一塔则已供养十方佛塔。造作龛窟补治故塔供养塔时亦复如是。是名不现见供养。又复不现见供养者。若不见佛不见佛塔。心想念言。此是如来此是佛塔。一切佛一切塔一切窟一切像亦复如是。是名不现见供养。复有不现见供养者。若菩萨佛涅槃后。为如来故建立塔庙造作龛窟。若一若二乃至无量随力能作。是名不现见供养。如是无量福德果报。摄取无量梵福德果。菩萨摩诃萨以是因缘于无量劫不堕恶趣。亦能庄严菩提之道。菩萨摩诃萨不现见三宝而设供养。胜于现见供养之者。不可称量不可为比。所得果报不可宣说。愚痴之人现见之后而设供养。智慧之人虽不现见而能供养。是名不现见供养。自作供养者。菩萨摩诃萨若供养佛及供养塔。手自经理不令他作。是名自供养。他供养者。若佛若塔欲供养时。聚集多人和合共作非独自作。多人者。所谓父母妻子宗亲眷属僮仆。若王大臣婆罗门长者。邻比知识内人外人男女贫富受苦受乐。若师和上。若同师同和上。若同住同法同学同国同名同姓。乃至邪见及栴陀罗。是名他供养。复有他供养者。菩萨摩诃萨若财富自在。以慈悲心惠施众生。临施之时作是愿言。众生贫苦鲜于福德。今受施已我当劝令供养三宝。以是供养三宝因缘破坏贫穷多获福德。作是愿已惠施众生。施众生已教令供养佛法僧宝。是名他供养。利益供养者。菩萨若于佛及佛塔。奉施衣服饮食卧具医药房舍恭敬礼拜。复以种种杂华涂香末香散香伎乐幡盖灯明供养。又叹如来无量功德。五体投地右绕三匝至无量匝。兼复奉献金银琉璃颇梨珂贝车磲马瑙及身璎珞钟铃之属乃至一钱一线一米。是名菩萨利益供养。最胜供养者。菩萨若于佛及佛塔。所设供养。利益供养。常恒供养。好物供养。现见供养。不现见供养。自供养。他供养。至心供养。喜心供养。至心忍乐供养三宝。以如是等供养回向阿耨多罗三藐三菩提。是名最胜供养。清净供养者。菩萨若于佛及佛塔手自供养非以憍慢轻贱心故。令他执作无有放逸。勤心精进至心净心。非为国主生信敬故。非以当得国王大臣长者居士所供养故。非以自显己之功德而供养也。所作形像不以雌黄鸡子罗差胶油酥等涂地。不烧胶香熏香供养。颇迦花等亦不供养。一切臭华虽有好色亦不供养。乃至种种臭秽之物不以供养。离如是等诸供养者。是名清净供养。受持供养者。菩萨若于佛及佛塔。若自出财若从他求。若作像若作塔。若一若二。若乃至百千无量万亿。一一塔中一一像前恭敬礼拜。以好华香伎乐灯明璎珞幡盖而供养之。亦不以此供养因缘故求阿耨多罗三藐三菩提求于佛道。何以故。菩萨摩诃萨住不退地故。菩萨住是不退地已。于诸佛土受身无碍。菩萨摩诃萨不自出财不求他财。作是愿言。若阎浮提所有众生。有能供养佛法僧宝。从四天下乃至三千大千世界十方无量无边世界所有众生。以上中下供养三宝。我当至心随其欢喜。复作是愿。以是因缘令诸众生悉得成就阿耨多罗三藐三菩提。是名菩萨庄严无上菩提之道。是名如法作供养。菩萨摩诃萨修集慈心如[聲-耳+牛]牛顷。悲喜舍心亦复如是。一切有为无常无我无乐无净。深观涅槃功德微妙。念佛法僧施戒天等。乃至不见法界之中有微分相可得宣说。至心趣行六波罗蜜。以四摄法摄取众生。是名如法作供养。若有比丘常乐喜见恭敬供养金塔金像银塔银像颇梨真珠车磲马瑙璧玉塔像。不喜乐见供养恭敬泥木塔像。当知是人不名如法作供养。是如法作供养名无上供养无胜供养最上供养。如是供养胜诸供养。能得无量无胜之果。菩萨摩诃萨供养三宝为六事故。一者福田无胜故。二者知恩报恩故。三者胜于一切一足二足多足无足故。四者难遇如优昙钵花故。五者无师和上自然得成阿耨多罗三藐三菩提故。六者能令众生获得世乐出世乐因故法僧亦尔。菩萨欲受菩萨戒时当观和上。若具八法乃从受戒一者具足优婆塞戒沙弥戒大比丘戒。二者能致供养。三者善能观察持戒毁戒相貌。四者得舍摩他毗婆舍那。五者慈心怜愍一切。六者能舍己乐以施众生。七者无畏。八者不说非法不听非法。说非法者呵责谏喻。能忍一切呰毁打骂恼害等苦贪嗔痴等毁禁之人及懈怠者。处众说法不辞疲劳。不谬解义亦不误说。发言柔软初不粗犷。常念众生欲令安乐。有疑辄请不怀耻辱。善知方便教化众生。知诸众生烦恼对治。于诸众生其心平等。无有贵贱尊卑之异六根具足威仪庠序。不信谗言细行净行。不自矜高轻蔑于人。不为利养外现谄曲。舍除贪妒悭吝之心。若自得利先推他人。其心常一无有放逸。见他得利欢喜如己。知足少欲唯畜六物。六物之外随得随施。恒劝前人随犯发露为示忆念善知悔法。善能瞻养病苦之人。终不宣说声闻法藏菩萨藏过。若有具足如是法者任为和上。菩萨摩诃萨既受戒已。和上若病应为给使若不病者应随教作。应生虔重恭敬之心。迎逆礼拜立侍左右。奉施衣食卧具医药随顺法语。随法而作无有动转。随所犯罪诚实而说。若听法时作佛想法想比丘僧想。难想眼想。大智因想。大光明想。得大果报想是大涅槃无上道因想。得常乐想。得舍摩他毗婆舍那想。如是想者即是真实法想。是名具足听法功德又听法时应至心听信心听。不应念言我今不应从破戒者。斯下种姓根不具足。不正语者弊性之人而问法也。离如是念至心听法。菩萨摩诃萨受菩萨戒有二种。一者智二者愚。若作如上思惟观者。是名愚痴。不增善法不得大智。菩萨修集四无量心慈悲喜舍。四无量心有三种。一者众生缘。二者法缘。三者无缘。众生缘者。菩萨摩诃萨修集慈心。谛观一切三聚众生一者受乐二者受苦三者受不苦不乐菩萨摩诃萨修集慈心。观受乐者令其增长。观苦众生灭苦生乐。观不苦不乐者断除苦乐令得涅槃。是名众生缘。法缘者菩萨摩诃萨唯观法相不作众生相。若我修慈无众生者。唯得离苦谁得受乐。是名法缘。无缘者舍众生相及以法相增长慈心。是名无缘。如慈余三无量亦复如是。菩萨摩诃萨若因众生修无量心。当知是心不异外道。亦与声闻辟支佛共。菩萨摩诃萨四无量心合则为悲。是故菩萨名为大悲菩萨观察受苦众生有百一十。为除是苦修集大悲。何等百一十。一种生苦。复有二种。一者求不得苦。二者得已失苦。复有三种一者苦苦二者行苦。三者坏苦。复有四种。一者爱别离苦。二者怨憎会苦。三者死苦。四者五阴不灭苦。复有五种。一者欲因缘苦。二者嗔因缘苦。三者睡眠因缘苦。四者掉悔因缘苦。五者疑因缘苦。复有六种。一者恶道因苦。二者恶道果苦。三者多求苦。四者守护苦。五者得无厌苦。六者失苦。复有七种。一者生苦。二者老苦。三者病苦。四者死苦五者爱别离苦。六者怨憎会苦。七者求不得苦。复有八种一者寒苦。二者热苦。三者饥苦。四者渴苦。五者不得自在苦。六者自作苦。如尼揵子。七者他作苦。如王事等。八者久威仪苦。复有九种。一者身贫穷苦。二者他贫穷苦。三者亲爱坏苦。四者失财物苦。五者病苦。六者破戒苦。七者邪见苦。八者现在苦。九者他世苦。复有十种。一者有食无器苦。二者步涉无乘苦。三者求诸璎珞华香不得苦。四者求觅伎乐游戏不得苦。五者求于光明不得苦。六者求给使人不得苦七者求浆不得苦。八者求衣不得苦九者得不用苦。十者见来求苦。复有九种。一者一切苦。二者大苦。三者一切自苦。四者不如法住苦。五者转苦。六者不得自在苦。七者害苦。八者随逐苦。九者一切行苦。一切苦者。由往昔因得现在苦。大苦者。如诸众生无量世中受地狱苦。一切自苦者。如地狱畜生饿鬼人天中苦。不如法住苦者。如作谋议欲害于他事不成就反受其祸如贪饮食后受大苦。如念贪欲嗔恚痴苦。如因身口意恶业受苦。如因毁戒受于忧苦。转苦者。如现在王身转至他世为奴仆苦。如现父母兄弟妻子转至他世为怨憎苦。如现在巨富转至他世受贫穷苦。不得自在苦者。如欲得长命欲得端正。欲得上族。欲得富贵。欲得身力。欲得智慧。欲除怨敌。不得如意苦。害苦者。如世中人求破贫穷不能破苦。出家之人求坏烦恼不能坏苦。如事难苦。兵革起苦。行旷路苦。截手脚苦。闭系打缚苦。驱摈出外苦。一切行苦者。因苦受苦离乐受苦。一切诸受未断故苦。不能出家苦。不能寂静苦。不得菩提苦。多生思觉苦。凡夫苦。四大苦。三界苦。烦恼苦。是名百一十苦。菩萨观察如是等苦增长大悲。如是大苦因十八种而得增长。何等十八。一者愚痴苦。二者受果报苦。三者行苦。四者常苦。五者生苦。六者自作苦。七者他作苦。八者破戒苦。九者邪见苦。十者过世苦。十一者大苦。十二者地狱苦。十三者人天苦。十四者转苦。十五者受苦。十六者不知苦。十七者增长苦。十八者懈怠苦。菩萨常以四事因缘名为大悲。一者谛观众生受苦因缘甚深难解。二者无量世中修集。者三至心修集。四者以至心故为于众生不惜身命。以是四事因缘故。能为众生劳谦忍苦受于苦身。是故菩萨名净大悲。净大悲者名如来地。菩萨摩诃萨观是百一十事。一切菩萨皆悉修集。为众生故增长大悲。如是菩萨能观众生及以法相生于大悲。不能观察无缘之相生于大悲。是故不得名为大悲。如来能具如是三种故名大悲菩萨修集大悲故。得身寂静得心寂静。以是身心寂静因缘故。能破众生所有烦恼。住于净地一子之地。于诸众生爱之如子。以大悲因缘故。为诸众生勤行苦行心无悔退。如声闻道悟四谛时受无漏乐。菩萨修悲亦复如是。菩萨修悲但为众生。不为自身。修悲因缘。菩萨乃至不惜身命及外财物。修悲因缘舍身受身。终不毁失如来禁戒。难得三昧即能得之。难得智慧即能得之。是故如来于经中说。菩萨阿耨多罗三藐三菩提住在何处。当言住于大悲。无量无边不可称计。故名大悲。菩萨修集是无量心得现在乐。能令众生远离苦恼。得无量无上功德之聚。庄严阿耨多罗三藐三菩提

    菩萨地三十七助道品第十八

云何名为菩萨摩诃萨惭愧。惭愧有二种。一者性。二者因缘。性者。菩萨摩诃萨自知所作非法。怖畏恶报而生惭愧。因缘者。菩萨若于自所作恶。恐人知故而生惭愧。性惭愧者。非因缘得如菩萨性。菩萨修惭愧者从因缘得。如八正道因缘。惭愧有四种。一者不应作而作生于惭愧。二者应作不作生于惭愧。三者心自生疑而生惭愧。四者于覆藏罪恐他知故而生惭愧云何名为菩提萨埵。萨埵者。名为勇健无所畏惧。菩萨之性性有健力。以性健故能调烦恼不随其心。能忍众苦种种恐怖。虽有恐怖不能倾动。菩萨所有善法庄严。是名性勇健力。是故名为菩提萨埵。菩萨性勇健力有五因缘。一者种种生死苦。二者众生种种行诸恶业。三者于无量世利益众生受无量苦。四者至心坚持菩萨禁戒。五者至心听受深法。菩萨摩诃萨有五因缘。为诸众生受大苦切心无愁恼。一者有大勇健力故。二者修集无愁故。三者勤善方便健精进故。四者智慧力健故。五者专念修悲心故。云何菩萨解世书籍。菩萨善知世间方术。知字知句知辞知义。心口和合专念受持。是名菩萨知法知义。知法知义故能为他说。以说因缘故法智义智而得增长。是名闻慧思慧。以是闻思慧因缘故。助菩提法而得增长。云何名为菩萨知世。世有二种。一者众生世。二者器世。菩萨摩诃萨观众生世。是故经说。世间苦行受于生死。不知生死不得解脱。如来善知众生世间。是故经说。众生有五浊。一者命浊。二者众生浊。三者烦恼浊。四者见浊。五者劫浊。如今人寿不满百年。是名命浊。如今众生不能孝养父母师长和上沙门婆罗门等。不随义行。不畏现在及未来世。不乐惠施。不喜福德。不乐受斋持戒精进。是名众生浊。如今众生因烦恼故杀害父母。于母姊妹及余亲属强作非法。为与众生作恶因缘。受畜弓箭刀杖牟槊。多有众生妄语两舌恶口无义语。有如是等无量诸恶。不善烦恼起时。是名烦恼浊。如今众生非法见法法见非法。非法说法法说非法。以见说故破坏正法增长邪法。无量众生修集邪见。是名见浊。如恶时恶众生有三种内恶劫起。一者饥馑内劫。二者疫病内劫。三者刀兵内劫。是名劫浊。是名菩萨知众生世间。复次菩萨知器世间。菩萨善知器世成坏因缘。是故经说。迦栴延。如来善知世间。知世间因。知世间灭。知世间道。知世间味。知世间苦。知世间解脱。迦栴延。六入五阴及四大等。名为人身。以人身故随世作相。名之为我。名为众生。名为寿命。名为士夫。名为某甲。如是名字性无真实因烦恼故众生说言我见我闻我知。见闻知者亦无真实。流布如是名姓饮食受苦受乐长寿短寿。是名流布流布者。名为相不名真实。如来善知众生世间器世间故。名如来善知世间。菩萨若见于已年长福德胜者。应起奉迎礼拜问讯安施床座。若见年德与己等者。先意问讯谦下软语执手共座。不生憍慢我胜于彼。若见年德于己少者。先意软语劝以福德。教行善法心不轻慢。设其有罪终不讥刺。随所须物任以给施。菩萨悉于上中下众生。先意软语善法教化。以食以法而摄取之。身口意业善思惟等悉向众生。常作是念。愿我莫与一切众生作恶因缘。于诸众生不作怨想。常生亲想无嗔恚心。设有嗔者不以在意。若他嗔打当观法界。身口意业常自凝重。具足十四事。所谓六方便。四恶知识。四善知识。如善生经说。常能利益今世后世。能求财物。得已能护。营生富足。能作福德不贪不悭。不作幻术诳惑世人。持戒惭愧。有人寄附不令生疑。众生见者如见真实。常近善友治国理民劝以十善。见则言见。闻则言闻。觉则言觉。知则言知。是故菩萨。名知世间。云何名为菩萨学四依。菩萨依义不依于字。菩萨听法不为依字唯为依义。菩萨摩诃萨依法不依人。知法非法。知如是法是佛所说是长老说是众僧说。若是非法。虽闻佛说心不生信。复有是法非佛所说非长老说非众僧说。虽非佛说长老僧说。是法相者闻则信受。菩萨摩诃萨依了义经不依不了义经。依了义者。不可动不可移。了义经者不生疑心。菩萨若于了义经中生疑心者则可移动。菩萨依智不依识。何以故。修智慧者名净智故。是故菩萨解甚深义。虽于深义未得解了终不生谤。是名菩萨成就四依。菩萨成就如是四依。了了能知世道出世道。菩萨复有四道。以四道故知一切法界得无碍智。四道者即是四无碍智。知一切法界。名法无碍智。若知一切法性无碍智无颠倒智。名义无碍智。菩萨若知一切诸法种种名字。名辞无碍智。菩萨若知一切法界一切法名一切法义说不可尽。名乐说无碍智。菩萨具足四无碍智。知阴入界方便十二因缘方便是处非处方便。菩萨具足四无碍智。了了自知菩提之道。复能为人分别广说。云何名为庄严菩提。庄严菩提有二种。一者功德庄严。二者智慧庄严。如自利利他品中说。菩萨若在初阿僧祇劫。修集如是二庄严者。名下庄严。在第二阿僧祇劫修。名中庄严。在第三阿僧祇劫修。名上庄严。云何菩萨修集三十七品。菩萨具足四无碍智得方便智。以方便智故修集三十七品。亦未得证阿耨多罗三藐三菩提。亦知二乘所修道品。知二乘者如初品说。云何名知菩萨所修三十七品。菩萨观身循身观。作是观时不着身相不作空相。亦知是身不可宣说。是名观身第一义。为流布故说名为身。如身余三十七品亦如是。菩萨摩诃萨观是身时不作苦不作集不作灭不作灭因缘道何以故。法界不可说故。菩萨若能如是知苦集灭道。是名第一义修集三十七品。为流布故说苦集灭道。菩萨若知不以觉观观三十七品。是名舍摩他。菩萨若知法界真实不可宣说。是名毗婆舍那。菩萨舍摩他有四种。一者第一义舍摩他。二者期舍摩他。三者真实舍摩他。四者离烦恼怨舍摩他。菩萨具足四舍摩他知一切法界。为阿耨多罗三藐三菩提故。菩萨毗婆舍那有四种。一者共四种舍摩他行。二者远离颠倒。三者分别无量法界。四者知法界无碍。菩萨修集是四种毗婆舍那。为阿耨多罗三藐三菩提故。云何名为菩萨摩诃萨善方便。善方便者有十二种。内六种外六种。内六种者。菩萨常于一切众生起大悲心。真实了知一切诸行。常乐系念阿耨多罗三藐三菩提。乐为众生转于生死。真知烦恼不坏烦恼。为阿耨多罗三藐三菩提勤修精进。是名内方便。外六种者。能令少施得无量福。有功德者能令增长。坏佛法者能令生信。已有信者能令增长。未淳熟者能令淳熟。已淳熟者能令解脱。是名外方便。云何少施得无量福。若有众生于菩萨所闻说法已。以一把食施于饿狗。施物既少福田又薄。以能回向菩提道故。所得福报不可称量。有德增长者。若有众生先受八斋。菩萨复为分别解说。教令回向无上菩提。若有众生深着邪见。一月不食昼断夜食。菩萨即为讲宣正法破其邪心。教令受持八戒斋法。菩萨为破苦不善斋。教令受持善法斋戒。若有众生欲求解脱不知方便。菩萨为说中道实义离于二边。若有众生欲得天身投渊赴火。菩萨为破如是现苦。为说持戒现世受乐后受天身。若有众生为寂静故。读诵解说四毗陀典。菩萨即以十二部经。教令分别思惟其义。复次菩萨以世所有上妙香华供养三宝。亦教众生复令供养。自向十方无量诸佛发愿供养。亦教众生向十方佛发愿供养。复次菩萨常修念佛乃至念天。亦教众生令修六念。复次菩萨身口善业。若多若少悉施众生。亦以是法教化众生。复次菩萨常作是愿。一切众生所有苦事。悉集我身莫令他受。亦以此法转教众生。复次菩萨若有过去现在世罪。悉向十方诸佛忏悔。亦以此法教众生行。复次菩萨自能修集四无量心。亦教众生行四无量。有功德者能令增长。坏佛法人能令生信。已生信者能令增长。未淳熟者能令淳熟。已淳熟者令得解脱。菩萨摩诃萨为是四法修集六事。一者随他。二者无障。三者不动。四者心相似。五者报恩。六者清净。随他者。菩萨若为众生说法。先以软语随彼心语。随身口意任力惠施。令彼恭敬生欢喜之心乐法之心然后为说。随诸众生上中下根说易解法。时节说。次第说。不颠倒说。利益说。怜愍说。若须神通应感化度为示神足。略能说广。广能说略。能破疑网。施其忆念。能广分别出入定处。若有众生不解如来甚深空义。即为开示分别演说。若有众生诽谤方等大乘经典。即为说法令其调伏。若有众生作如是言。如来所说无一切法无一切物。一切诸法无生无灭。犹如虚空如幻如梦。如热时焰乾闼婆城。如水中月。如呼声响。以是不解法性因缘故生于怖畏。生怖畏故而生诽谤。言非佛经是邪见说。菩萨摩诃萨善巧方便。渐渐为开修多罗义。随意而言非一切法无。以一切法不可说故。名为无法。以不可说性无所有故。名为无物。若初无不可说无不可说性。云何可说有生有灭。是故说名无生无灭。若无生灭即名虚空。如虚空中有无量色有无量业。诸色诸业无有障碍。所谓行住屈申俯仰。若无如是诸色诸业名虚空者。是则虚空不可宣说。若因虚空有诸色诸业可宣说者。不得说言虚空之性不可宣说。若彼虚空不可说者。诸色诸业云何可说。菩萨摩诃萨得圣智已。乃知法界不可宣说。尔时菩萨破坏邪相。言一切法有一切法可说。菩萨初以如是圣智教于众生。众生得已自见法性。不可宣说犹如虚空。是故如来说一切法同于虚空。如幻性相非有非无。圣人亦说非有非无。幻若定有。以何因缘有时可见有时不可见。若定无者。云何令人见种种相。实无之法不应生相。一切法界亦复如是。于诸凡夫说有名相。有名相故不得言无。第一义性不可说故不得言有。是故法界如幻有二。是故菩萨于诸法界。不取不舍不增不减。实则知实亦说是实。是名菩萨善随方便。无障者。菩萨摩诃萨见来求。者作如是言。善男子。汝今若能供养三宝父母师长沙门婆罗门者。所须之物。若衣若食床卧病药。华香璎珞幡盖伎乐。田宅屋舍仆使乘用。资生之物悉当与汝。若有众生恐畏忧惧。菩萨语言。汝今若能供养三宝乃至婆罗门者。我当给汝衣食所须乃至一切资生之具。亦当救汝忧惧之事。若有病者亦复语言汝今若能供养三宝乃至婆罗门者。我当为汝求觅良医瞻病好药衣食乃至资生之具令汝病愈。如是众生若能信受菩萨语者。菩萨当作种种方便必令如意。若不受者。菩萨尔时则修舍心。若有信受。菩萨不为称意作者得罪。菩萨先教供养三宝父母师长持戒精进。为调令得阿耨多罗三藐三菩提。若先受语后不受者。以怜愍故则现嗔呵非实恶心。若不施物不为作使非实嫌恨。为调伏故。是名无障不动。心相似者。菩萨若得自在之身。若王大臣多有眷属。先唱是言。若我境内及家中人。其有不能供养三宝父母师长沙门婆罗门毁戒懈怠。我当断其衣服饮食。打骂系缚闭之牢狱。若杀若摈。嘱付大臣使令鉴察。知谁持戒知谁毁戒。谁能供养父母三宝。谁不供养父母三宝。尔时众生以怖畏故。远离诸恶修集善法似菩萨心。是名相似方便。报恩者。菩萨若受檀越衣服饮食卧具病药房舍。若多若少。或遭恐怖有人救解。或遭病苦有疗治者。或闻说法破坏疑心。菩萨摩诃萨以念恩故。悉教是等行于善法。是名报恩。菩萨说法众生闻已。即能供养三宝父母师长沙门婆罗门等。持戒精进。是名报恩寂静者。菩萨摩诃萨安住毕竟菩提地中。修集寂静菩提之道生兜术天。当知不久下阎浮提得阿耨多罗三藐三菩提。众生闻已悉发愿言。如是菩萨成佛之时。我等当于是佛法中出家学道。尔时菩萨下阎浮提。托生刹利婆罗门家。为众生故舍五欲乐。出家学道修行苦行。为苦行者生于恭敬。破苦心故。修苦行已。得阿耨多罗三藐三菩提。坏声闻缘觉菩提心故。既成道已默然而住。释梵天王来劝请故。梵天启请。为令众生于正法中生尊重故。尔时世尊即以佛眼观诸众生然后说法。佛眼观者为破恶名故。所谓众生说言。如来但为梵王劝请非为怜愍。若以佛眼观于众生转法轮者。为破众生邪恶轮故。转法轮已集众制戒。为令众生得解脱故。是名菩萨寂静方便。为令众生得信心故。未入佛法者令得入故。未熟众生令得熟故。已熟众生得解脱故

菩萨善戒经卷第六菩萨善戒经卷第七

        宋罽宾三藏求那跋摩译

    菩萨地助菩提数法余品第十九

云何菩萨摩诃萨陀罗尼。陀罗尼有四种。一者法陀罗尼。二者义陀罗尼。三者辞陀罗尼。四者忍陀罗尼。法陀罗尼者菩萨心得忆念。以念力故得大智慧。大智力故知诸法界。言辞字句坚心受持。经无量世无有忘失。义陀罗尼者。如法陀罗尼随顺解义。于无量世受持不忘。辞陀罗尼者。菩萨摩诃萨为破众生种种恶故。受持神咒读诵通利利益众生。为咒术故受持五法。一者不食肉。二者不饮酒。三者不食五辛。四者不淫。五者不净之家不在中食。菩萨具足如是五法。能大利益无量众生。诸恶鬼神诸毒诸病无不能治。忍陀罗尼者。菩萨摩诃萨智慧力故。心乐寂静不与人居。默然不语独处无伴。于食知足食一种食。坐禅思惟夜不眠寐。时佛即以陀罗尼咒。教之令诵

  乙致　蜜致　羁致毗　羼提　般檀那　莎呵

菩萨尔时从佛受已。深心观察知字无义。以无义故无有义语。若无义语辞亦无义。法亦无义。以无义故一切诸法悉不可说。义者一切诸法无义义也。以忍力故了了能知四陀罗尼。以了知故则得具足忍陀罗尼。以能具足忍陀罗尼故。不久得成阿耨多罗三藐三菩提。菩萨摩诃萨初阿僧祇劫修集行时。得是法义二陀罗尼。因此法义二陀罗尼修集三昧。因修三昧发誓愿故。复得辞忍二陀罗尼。菩萨若能具足四事得四陀罗尼。一者不贪五欲。二者于众生中无嫉妒心。三者能施施已无悔。四者乐闻正法受持读诵书写解说。菩萨法藏菩萨摩夷。云何菩萨发大誓愿有五种。一者发心发愿。二者有发愿。三者行发愿四者善发愿。五者大发愿。初发菩提心时名发心发愿。为利众生生人天故名有发愿。为众生故修无量心名行发愿。修集一切菩萨善法名善发愿。不惜身命护持正法名大发愿。菩萨若以十种供养佛法僧宝护持正法。见持法者供养恭敬。是名大发愿。菩萨摩诃萨生兜率天乃至大涅槃。是名大发愿。菩萨摩诃萨从初发心乃至得阿耨多罗三藐三菩提。是名大发愿。菩萨摩诃萨为度众生遍在诸有随而受身。是名大发愿。菩萨摩诃萨常以大乘菩萨法藏菩萨摩夷教化众生。是名大发愿。菩萨摩诃萨凡所演说无不利益。无善根者令生善芽。是名大发愿。云何名为菩萨摩诃萨修空三昧。菩萨深观一切诸法有可说性。是可说性不可说性中无故名空三昧。云何无愿三昧。菩萨摩诃萨以一切法可宣说故有我有我所。有我有我所故则名为苦。菩萨摩诃萨破邪想故。知一切法不可宣说。是故不着我及我所。无我无我所故更不愿求。是名无愿三昧。云何无相三昧。菩萨摩诃萨知一切法不可宣说。以不可说故悉无一切烦恼之相。以无相故名为寂静。修寂静故是名无相三昧。如来何故说三三昧。一切诸法凡有二种。一者有为有。二者无为有。有为有者谓我我所。无为有者。所谓涅槃。有为有者。菩萨摩诃萨观一切苦不生愿求。是名无愿三昧。无为有者所谓涅槃。菩萨摩诃萨于涅槃中不生乐想。是名无想。无为者亦有亦无。是故菩萨非愿非不愿。菩萨摩诃萨见有有见无无。有中无无无中无有。是名为空。菩萨尔时修空三昧得真实智。如是三昧声闻缘觉。亦修亦学而不能说。一切诸法不可宣说。诸佛菩萨为令众生得寂静故说是四法。一切有为法无常苦无我涅槃寂静。诸佛菩萨为诸众生说是四法。当知已说一切法界诸法根本。是名优陀那。优陀那者。过去无量一切诸佛亦如是说。能作上者名优陀那。增长善法名优陀那。云何菩萨见有为法悉是无常菩萨摩诃萨知有为法可说无常。是故一切有为无常。知诸法性真实义中无因果故不可宣说是故作相言一切法悉是生灭。以是过去有为亦生亦灭。是故过去之法不见有因不见有性。以不见因性故。说过去法悉是无常。现在法知生而不知灭。现在之法不见其因见果见性。不灭故知性不知因。未来有为法不见生灭。是故知因不知果不知性。以未生故。是故菩萨知因不知性。尔时观三世一一念有三相。若过一念则有四相。先灭法已次第生相似法。是名为生。生已作事。是名为住。先灭法相灭法已见相似。是名为老。生已不住至于二念。是名为坏。菩萨见有为法相一种。如生住老亦如是。唯坏相异。何以故。不共三相住故。如是四相见有二种。一者有。二者无。有者三相无者第四相。菩萨见有为法不见生不见住不见老不见坏。何以故。生住老坏无真性故。菩萨摩诃萨见色法生色法住色法老色法坏。不见生住老坏。菩萨摩诃萨以方便观不见四相。方便观者菩萨观。若离色法别有生者。色法生时生亦应生。若尔者一切诸法皆应二生。一者色生。二者生生。如是二生若即法若离法。若不离者则无生生。若言离法别有生者。是义不然。若不离者尔时色无有生。生因缘故生住老坏亦如是。若坏自性有者。当知是坏亦生亦坏。若坏生者当知一切有为之法悉无有灭。入灭定时心心数法常应还生。色法灭时亦应还生。何以故。是坏生故。是故诸法悉应是常。是故菩萨离色法已不见四相。知有为法性无常故。亦常宣说有为无常。菩萨观见有为之法有三种苦。苦苦行苦坏苦。是故如来说有为法一切是苦。云何菩萨见有为法无我。无我者有二种一者众生无我。二者法无我。众生无我者众生非是有法。非是无法。非是离有无法。是名众生无我。法无我者。一切诸法可说。可说性无故。是名法无我有如是等二种无我。是故如来说有为法一切无我。如是有为断现在因障未来因。是名涅槃。无烦恼结故名寂静。若是菩萨以不净心观于涅槃。声闻未得道果观于涅槃。俱亦未实知涅槃性。亦是涅槃相。譬如大王为子息故刻木造作象马鹿兔。王子亦于非真实象马作真实想是王或时赞叹象马。诸子各谓赞己象马。其后出舍见真象马即生惭愧。我等云何于非象马生象马想。云何于此同名同相生真实想。如来亦说。菩萨心不清净。声闻之人未证道果。住生死舍。如来为说涅槃寂静。菩萨声闻闻已亦生真涅槃想。实不能知真涅槃也。闻佛说时生心作想言是涅槃。其后修集八正道已。得净智慧出生死舍。尔乃真实知涅槃性方生惭愧。我等云何于非涅槃生涅槃想。譬如病人往良医所。尔时良医为破病故随病授药。病者得已心生欢喜。作真药想即便服之。既服药已所患虽除更发余病。尔时良医断先所服更与余药。病者复言。大师先药佳良力能治病。非是药能。良医虽说如是药好。而此病者犹故不信。尔时病者服药病差。方乃信药生惭愧心。佛说法时亦复如是。众生闻已坏小烦恼。即便生于真实之想。更起烦恼言佛无常。如来复为说甚深法。虽复闻之犹不生信以本为实。菩萨若得清净之道。尔时方生惭愧之心。如来实常。我云何言如来无常。是故如来说有为法一切无常苦无我等涅槃寂静

    菩萨地功德品第二十

菩萨摩诃萨修菩提行有五事不可思议。一者怜愍一切众生。二者为利众生受生死苦。三者以善方便调伏众生。四者发心欲知甚深难义。五者欲知不可思议神足。如是五法不与一切众生共之。是故得名不可思议。菩萨摩诃萨复有五事不可思议。菩萨摩诃萨为利众生受于苦因。以受苦因故得受安乐。以受乐故具足成就不思议法。复次菩萨观生死过涅槃寂静。为众生故不乐涅槃流转生死。是名受乐。以受乐故具足成就不思议法。复次菩萨乐于空闲寂静默然。为诸众生演说正法。是名受乐。以受乐故具足成就不思议法。复次菩萨摩诃萨为众生故。行六波罗蜜。亦复不求六波罗蜜果。是名受乐。以受乐故具足成就不思议法。复次菩萨摩诃萨营他事业如造已务。甘心喜乐不辞勤苦。是名受乐。以受乐故具足成就不思议法。是名菩萨五事不可思议法。菩萨复有五事于诸众生其心平等。一者初发菩提心时。普为一切非为一人。是名平等。二者菩萨修大悲时。普为一切非为一人。是名平等。三者菩萨修集一子地时。普为一切非为一人。是名平等。四者菩萨普观十二因缘一切等有。是名平等。五者菩萨求阿耨多罗三藐三菩提时。普为一切非为一人。是名平等。菩萨摩诃萨复有五事为利众生。一者教修正命。二者教习世事方便。三者见贫穷者方便教令破贫穷苦。四者为上善者说正实道。五者为三乘故说三乘法。是名五事利益。众生有五事法报菩萨恩。一者受持善法一切禁戒。二者贫者受已如教修行破于贫穷。三者供养三宝。四者于菩萨所闻法受持读诵书写分别解说转以教他。五者见持法者恭敬供养。菩萨摩诃萨行菩提道。至心立愿常求五事。一者常愿世间有佛兴出。二者常愿具足六波罗蜜。三者常愿求觅菩萨法藏菩萨摩夷。四者常愿当得解脱。五者常愿眷属成就。是名为五。菩萨复有五事利益众生。如自利利他品中说。菩萨复有五事疾得阿耨多罗三藐三菩提。一者护法。二者修行善行。三者智慧力。四者专心寂静。五者定得菩萨性。是名为五。护法者。菩萨具足护陀罗尼。从他闻法速得解了。复次菩萨具足护念。以护念故受法不忘。复次菩萨具护智慧。以护智故分别法界。复次菩萨具足护心调诸根故。复次菩萨具护他心随他行故。是名护法修行善行者。菩萨于法顺解顺说。常修善法四无量心愿向阿耨多罗三藐三菩提。是名善行。智慧力者。菩萨摩诃萨从初发心乃至得阿耨多罗三藐三菩提。是名智慧力。专心寂静者。菩萨摩诃萨以十净法供养如来。如上所说。是名寂静。定得菩萨性者。所谓菩萨住一子地不退转地。是名菩萨定得菩萨性。菩萨摩诃萨有五事善法损减。一者不能供养于法及说法者。二者放逸懈怠。三者乐起烦恼心掉不息。四者于同菩萨心生憍慢。五者于菩萨藏颠倒解义。菩萨有五法善法增长。一者供养于法及说法者。二者摄心精进。三者所起烦恼心乐除灭。四者于同菩萨心生恭敬。五者于菩萨藏随顺解义。有五事实非菩萨假名菩萨。实非沙门假名沙门。非婆罗门假名婆罗门。不得菩萨戒不中同止。一者恶性。二者护毁禁者。三者不得禅定示得禅相。四者邪命自活。五者见有智者生嫉诽谤。有五事真名菩萨。真名沙门。真名婆罗门。得菩萨戒得与同止。一者善性调和。二者治毁禁者。三者实得禅定不示其相。四者正命自活。五者见有智者生喜赞叹。菩萨摩诃萨教化众生有十种。一者为破恶法故。二者为知法界故。三者不作犯故。四者犯已惭愧悔故。五者调伏诸根故。六者不放逸故。七者远离恶知识故。八者住寂静处故。九者远离烦恼故。十者得解脱故。是名为十。授菩萨记有六事。一者定有菩萨性未发阿耨多罗三藐三菩提心。二者未有菩萨性而发阿耨多罗三藐三菩提心。三者有菩萨性亦发阿耨多罗三藐三菩提心。四者于无量世为菩提故修行善行。五者定得阿耨多罗三藐三菩提不说时定。六者定得阿耨多罗三藐三菩提亦说时定。是名为六。有三事菩萨定得阿耨多罗三藐三菩提。一者定有性。二者得不退心。三者凡所作事悉为众生生善法芽。菩萨以是三定为佛所记。菩萨摩诃萨不具五事不得阿耨多罗三藐三菩提。一者不发菩提之心。二者不得怜愍之心。三者不勤精进。四者不敬重戒。五者不知一切世事菩萨若不具足如是五事。不得阿耨多罗三藐三菩提。若有说言。离是五法得阿耨多罗三藐三菩提者。无有是处。有五事菩萨常所修集。一者不放逸。二者为破众生贫穷困苦。三者供养三宝。四者至心持戒有犯寻觉。五者所作善事悉以回向阿耨多罗三藐三菩提。菩萨摩诃萨有十法胜一切法。一者菩萨性胜一切性。二者初发菩提心胜于一切世间出世间发心。三者毗梨耶波罗蜜般若波罗蜜胜于一切诸波罗蜜。四者软语摄法胜于诸摄。五者如来胜于一切众生。六者悲心胜于一切无量心。七者所修四禅胜一切禅。八者空三昧胜一切三昧。九者灭尽定胜一切灭定。十者净方便胜一切方便。是为十法。有四事唯佛菩萨独能流布。非余沙门婆罗门天魔梵等所能流布。若从佛闻则能流布。一者法流布。二者实流布。三者方便流布。四者乘流布。法流布者。次第演说十二部经。实流布者有一种。谓不妄语。复有二种。谓世谛。第一义谛。复有三种。相实口实行实。复有四种。谓苦集灭道。复有五种。一者因实。二者果实。三者智实。四者知境界实。五者无上实。复有六种。一者实实。二者虚妄实。三者智实。四者远离实。五者证实。六者修实。复有七种。一者爱实。二者苦实。三者解脱实。四者法实。五者解实。六者圣实。七者非圣实。复有八种。一者行苦实。二者苦苦实。三者生苦实。四者灭实。五者烦恼实。六者解脱实。七者善行实。八者善果实。复有九种。一者无常实。二者苦实。三者不净实。四者空实。五者无我实。六者有爱实。七者断爱实。八者断二爱方便实。九者有余涅槃实。复有十种。一者非分强作苦实。二者贫穷苦实。三者四大不调苦实。四者爱别离苦实。五者怨憎会苦实。六者业实。七者果报实。八者烦恼实。九者善思惟实。十者正见实。是为十法名实流布。方便流布者。如方便品说。乘流布者。所谓声闻乘辟支佛乘佛乘。是名为四。菩萨摩诃萨观一切方便有五无量。一者众生界无量。二者世界无量。三者法界无量。四者调伏界无量。五者调伏方便无量。众生界者。有六十一种。住喜地菩萨。观众生界转为无量。世界无量者。有无量名故。如此世界名为娑婆。是故梵天名娑婆主。法无量者。善不善无记转为无量。调伏无量者有一种。谓调伏故。复有二种。具足烦恼。不具烦恼。复有三种。上中下根。复有四种。婆罗门刹利毗舍首陀。复有五种。多贪多嗔多痴多慢多恶觉观。复有六种。出家在家未熟已熟未得解脱已得解脱。复有七种。一者闻已便解。二者以譬喻得解。三者一句一句解。四者一字一字解。五者现在熟。六者他世熟。七者随因缘熟。复有八种。所谓八众

复有九种。一名如来调伏。二声闻调伏。三缘觉调伏。四菩萨调伏。五难调伏。六易调伏。七软语调伏。八呵啧调伏。九软语呵啧调伏。复有十种。一者地狱。二者畜生。三者饿鬼。四者欲界人天。五者中阴。六者色。七者非色。八者想。九者无想。十者非想非非想。是名十种。是五十五种观作无量。众生界调伏界有何差别。众生界者。都不分别有性无性。调伏界者。分别有性无性调伏方便无量者。如初品中说。是故菩萨五种无量摄取一切方便。菩萨摩诃萨欲知真实当求四事。一者推物。二者推名。三者推性。四者推分别。如是四事亦如前说。诸佛菩萨为众生说法有五事。一者说时即悟四谛。二者说时即得解脱。三者说时即发阿耨多罗三藐三菩提心。四者说时得菩萨羼提。五者众生闻已受持读诵书写解说护持正法。是名诸佛菩萨为众生说法得大功德不可思议。云何名大乘。有七事大故名大乘。一者法大。法大者。菩萨法藏于十二部经最大最上故名毗佛略。二者心大。心大者。谓发阿耨多罗三藐三菩提心。三者解大。解大者。解菩萨藏毗佛略经。四者净大。净大者。菩萨发心已其心清净乃至得阿耨多罗三藐三菩提。五者庄严大。庄严大者。菩萨具足功德庄严智慧庄严。得阿耨多罗三藐三菩提。六者时大时大者。菩萨摩诃萨为阿耨多罗三藐三菩提故。三阿僧祇劫修行苦行。七者具足大。具足大者。菩萨具足三十二相八十种好以自庄严。得阿耨多罗三藐三菩提。法大心大解大净大庄严大时大。如是六大名之为因。具足大者名之为果。有八法能摄一切大乘。一者演说菩萨法藏。说菩萨藏义。说菩萨藏中诸佛菩萨不可思议。思惟其义。修集其义。得具足义。得修集果。解甚深义。是名为八。菩萨摩诃萨如是学者。得阿耨多罗三藐三菩提。菩萨修学菩萨菩提有十种。一者性住。二者入。三者不净心。四者净心。五者不熟。六者熟。七者不定。八者定。九者一生得。十者现身得定性净心学诸法。是名为住发阿耨多罗三藐三菩提心。是名为入。入者未得净地名为不净。得净地已是名为净。净者未入毕竟地时名为未熟。入毕竟地名之为熟。熟者未入定地名为不定。已人定地名之为定。熟有二种。一者一生得阿耨多罗三藐三菩提。二者现身得阿耨多罗三藐三菩提。如是十种菩萨摩诃萨能受菩萨戒行菩萨戒。是十种菩萨摄一切菩萨。若能至心受持修行菩萨戒者。是名菩萨。是名摩诃萨。是名智者。是名勇健。是名上仙。是名佛子。是名佛持。是名大胜是名佛戒。是名无畏。是名大圣。是名商主。是名船师。是名大名称。是名怜愍。是名大功德。是名自在。是名法持。是名不可思议。是名能知十方无量世界如观掌中阿摩勒果。若有人言我是菩萨。不受菩萨戒。不能至心行菩萨戒。然生信心。当知是菩萨欲得阿耨多罗三藐三菩提。若有人言我是菩萨。不能至心受持菩萨戒。心不生信。是名名字菩萨。久久乃得阿耨多罗三藐三菩提。若有人言我是菩萨。受持菩萨戒至心修行信菩萨戒。是名入十种菩萨中。不久定得阿耨多罗三藐三菩提。若有人言我是菩萨。受菩萨戒不能至心护持禁戒。毁破所受心不生信。是名菩萨栴陀罗不名名菩萨。不名义菩萨

    如法住菩萨相品第一

真实菩萨有五种相。菩萨具足五种相故。名真实菩萨。一者怜愍心。二者柔软语。三者勇健。四者不贪。五者解说深义。如是五法有五种智。一者性。二者因缘。三者功德果。四者次第。五者摄取。怜愍性者有二种。一者至心。二者如法。至心者。施众安隐。是名为性。如法者。菩萨摩诃萨如已乐事以施众生。是名如法。柔软性者。先意语欢喜语远恶语利益语。是名柔软性。勇健性者。心无所畏猛健果敢。能破众生畏惧之想。是名健性。不贪性者。一切施一切施一切施清净施施已无悔。是名不贪性。解说深义性者。四无碍智。是名解说深义性。怜愍者有五因缘。一者受苦众生。二者行恶众生。三者放逸众生。四者邪见众生。五者乐烦恼众生。受苦众生者。常受苦恼乃至无有一念之乐。是名受苦。又有众生虽不受苦。造身口意十恶业道。如十六恶律仪。是名行恶众生。复有众生不行恶业不受苦恼。贪着五欲耽乐嬉戏。贪爱已身不修善法。是名放逸。复有众生不受苦恼不行恶业亦不放逸。为求解脱非因见因非果见果。是名邪见。如外道等。复有众生不受苦恼不行恶业。亦不放逸亦不邪见。具烦恼系烦恼障故不修善法。是名怜愍因缘。以是因缘怜愍之心遂得增长。柔软因缘者有五种。一者善先语。二者善喜语。三者善无畏语。四者善净语。五者善教语。此五因缘是名柔软语。如四摄品中说。勇健因缘者有五种。如上三十七助菩提品中说。不贪者有五因缘。一者不分别施。二者喜施。三者至心施。四者净施。五者如法得财施。是名不贪五因缘。如施品说。说甚深义有五因缘。一者说修多罗甚深之义。解说空义。三世中阴退不退我我所。佛性菩萨性如来涅槃三乘。色造色十二因缘。是名修多罗义。二者能说毗尼义。是犯是非犯。是可悔是不可悔。是轻是重。是性重是遮重。是名说毗尼甚深义。三者说摩夷义。佛尔时为众生故说名为犯。为他故说轻作重说重作轻。为令一人得忏悔故。乃至大众中得忏悔故。是名说摩夷甚深义。四者能自解说正义。五者能知诸法名字。怜愍功德果者。菩萨慈心为诸众生。坏恶心故修集慈心。能利众生心无悔恨。常修集故得现世乐。是故如来说慈功果。毒不能害刀不能伤。眠无恶梦诸天拥护。舍此身已得生初禅。是名怜愍功德果。柔软语功德果者。菩萨摩诃萨修柔软语。能破现在口四恶过。是柔软语自利利他。能令众生爱乐喜闻。是名柔软语功德果。勇健功德果者。菩萨现在能破懈怠。受欢喜乐乐于寂静。护持禁戒心无悔恨。自修忍辱教人行忍。修诸苦行庄严菩提心无退转。是名勇健功德果。不贪解说深义二功德果。如上所说。次第者。菩萨摩诃萨先修慈心。为调众生故。次说软语。为破恶业故。见诸众生受恶业者。心不怖畏。生救护故。名为勇健。为调众生故行惠施。次说不贪及以深义。菩萨摩诃萨随是五相摄六波罗蜜。怜愍相者摄禅波罗蜜。柔软语者摄尸波罗蜜般若波罗蜜。勇健相者摄毗梨耶波罗蜜羼提波罗蜜般若波罗蜜。不贪者摄檀波罗蜜。说甚深义摄般若波罗蜜檀波罗蜜

    如法住禅品第二

菩萨摩诃萨若在家若出家俱有四法。有能修学即得阿耨多罗三藐三菩提行。善业方便怜愍众生。善业方便者。为施波罗蜜故修善行专心行常行净行。善行者。菩萨若有财物施乞者时。不观有恩不观无恩。不观福田及非福田。虽有人天沙门婆罗门不能沮坏菩萨施心。是名善行。专心行者。菩萨施时有来求者。舍内外物一切施与心无贪吝。是名专心施。常行者。菩萨施时有来乞者。不观时与非时随得随施。是名常行。净行者。菩萨施时有来乞者。不以名誉故施。非为天乐故施。如施品中说。是名净行。如施四事尸波罗蜜羼提波罗蜜毗梨耶波罗蜜禅波罗蜜般若波罗蜜亦复如是。云何菩萨善方便。若有生心欲破佛法。为调伏故行善方便。欲令中人入佛法故行善方便。虽入未熟为令熟故行善方便。入已既熟令得解脱故行善方便。菩萨为说世间医方技术诸论行善方便。为欲至心受菩萨戒坚持不毁故行善方便。善愿方便。声闻乘方便。辟支佛乘方便。大乘方便此十方便能作五事。初四方便为利益众生行。世术方便为破邪论。菩萨受持菩萨禁戒。终不毁犯。设犯随忏。善发愿方便随所欲事即能得之。菩萨三乘方便随根说法。是故菩萨如是十种方便能作五事。以五事故具足必定。能得世间一切之事。若现在若他世。云何菩萨利益于他。如四摄品中说。云何菩萨善发愿。菩萨所作一切善业。若过去未来现在不求余果。唯求无上菩提道果。是名善发愿。如来若为出家在家说戒。一切摄取如是四事。若出家在家菩萨。若过去未来现在。受持菩萨戒悉得阿耨多罗三藐三菩提。出家菩萨胜于在家。何以故。出家菩萨获得一切菩萨禁戒。在家菩萨不得菩萨一切禁戒。出家菩萨能行寂静清净梵行。在家菩萨不能修行寂静梵行。出家菩萨能行三十七品。在家菩萨不能修行三十七品。出家菩萨解脱一切世间之事。在家菩萨为世间事之所系缚

菩萨善戒经卷第七菩萨善戒经卷第八

        宋罽宾三藏求那跋摩译

    如法住定心品第三

菩萨摩诃萨怜愍众生有七种。何等为七。一者无畏。二者真实。三者不愁。四者不求。五者不爱。六者广大。七者平等。菩萨摩诃萨怜愍众生。无所畏故。修三业善。为破众生诸恶业故。是名无畏。菩萨摩诃萨怜愍众生。非烦恼爱故。非法住非毗尼住非妄语不教化于非处。是名真实。菩萨摩诃萨以怜愍故。为诸众生勤修苦行心无忧悔是名不愁。一切众生不求菩萨。而诸菩萨自修慈心。是名不求菩萨摩诃萨修怜愍时。于诸众生无有贪心无贪心者不求恩报及慈心果。是名不爱。菩萨修慈设有众生打骂恼害。终不舍于修慈之心。是名广大。菩萨修慈不为一人。普为无量无边众生无量法界。是名平等。是为七法。菩萨具足如是七法。名为菩萨至心清净。心清净者有十五种。一者无上净。二者如法净。三者波罗蜜净。四者真实义净。五者不可思议净。六者安隐净。七者乐净。八者不放净。九者坚固净。十者不诳净。十一者不净净。十二者净净。十三者善净。十四者调伏净。十五者性净。菩萨摩诃萨至心专念佛法僧宝。是名无上净。菩萨受持菩萨戒已。至心拥护不令毁犯。是名如法净。菩萨摩诃萨至心具足五波罗蜜。是名波罗蜜净。菩萨至心了知法界无我无我所。为流布故名为士夫。了了通达十二部经甚深之义。甚深义者即第一义。第一义者名真实义净。诸佛菩萨不可思议。从初出世乃至涅槃。是名不可思议净。菩萨至心修集悲心者。普施一切众生安乐。是名安隐净菩萨。摩诃萨为苦众生修集慈心令其得乐。是名乐净。菩萨摩诃萨为诸众生修集慈悲。不求无食心无果心无恩报心。亦不放众生行诸恶行。是名不放净。菩萨摩诃萨为阿耨多罗三藐三菩提。其心坚固不可破坏。是名坚固净。菩萨摩诃萨于无量世至心修集菩提善行。如是菩提及菩提道无有虚诳。是名不诳净。菩萨摩诃萨未得解地。是名不净净。菩萨摩诃萨住于净地乃至毕竟地。是名净净。菩萨摩诃萨住毕竟地修檀波罗蜜。是名善净。菩萨摩诃萨为得净地故调伏其心。是名调伏净。菩萨摩诃萨住于净地及毕竟地。名为性净性净者。不假修集然后清净。性本自尔身心净故。名为性净。菩萨具足是十五法能作十事菩萨因于无上净故能供养三宝。供养三宝即是庄严一切菩提道之根本。菩萨因于受持净故。即能受持菩萨禁戒乃至舍身寿命终不毁犯。若失念犯者即时忏悔。菩萨因于波罗蜜净。常能修集一切善法成不放逸。菩萨因于真实义净虽有烦恼为众生故流转生死。终不忘失涅槃之心。菩萨因不可思议净令无量众生于佛法中得大信心修集道果。菩萨因安隐净乐净不放净。具足成就利益一切众生之事心不愁悔菩萨因坚固净勤修精进破于懈怠成不放逸菩萨因不诳净即得阿耨多罗三藐三菩提。善法增长修行无厌。菩萨因调伏净性净。能以阿耨多罗三藐三菩提教于众生能以安隐施于人天一切众生。菩萨性净摄于三净。所谓不净净净净善净。过去未来现在诸佛及诸菩萨。得阿耨多罗三藐三菩提。已得当得今得。无不由是十五净得。若有说言。菩萨离是十五净法得阿耨多罗三藐三菩提者无有是处

    如法住生菩提地品第四

菩萨摩诃萨性具足。戒具足。学菩萨戒具足。菩萨相具足。成就菩萨庄严具足。十五净心身口意业净。菩萨有十二行摄取一切菩萨所行十三如来行。得阿耨多罗三藐三菩提已。名无胜行。何等名为菩萨十二行。一者性行。二者解行。三者喜行。四者戒行。五者慧行。慧行有三种。一者共助菩提行。二者共谛行。三者共十二因缘行。菩萨摩诃萨以如实见见如实法。若不如实见流转生死。若如实见则断众苦。是故菩萨智慧有三种。是名慧行。六者行行。七者无相行。八者不漏行。九者无行行。十者无碍行。十一者菩萨行。十二者具足行。是名十二行。菩萨若行是十二行。则能摄取一切。诸行如来之行胜一切行。是故名为无胜行。性行者。菩萨摩诃萨修集菩萨功德善法具足。修集诸善法故常乐善法。受持一切佛法种子。自知己身有佛种子坏粗烦恼。是名性行。菩萨具足是性行者。终不能起极重烦恼作五逆罪及一阐提。是名性行。解行者。菩萨摩诃萨发菩提心所修诸行。是名解行。性行菩萨行性行时是菩萨行。十二行及如来行因虽是诸行因亦未得异行。何况如来行亦未得因亦未得果亦未得净。若得一行是名解行。是名行如来行。亦未得如来行。未净如来行。名为得解行净。解行以净解行故得喜行净喜行喜行净故。得戒行净戒行如是。乃至十二行是名菩萨行。具足菩萨行净菩萨行。已得如来行净如来行。喜行者。菩萨至心净菩提心。是名喜行。戒行者。菩萨先净性重不毁遮重。以戒净故修集世禅。是名慧行。乘于世道入四真谛修三十七品。是名共助菩提行。修助菩提实见四谛。是名共谛行共十二因缘行者。若观四谛见一切苦从因缘生从因缘灭。是名共十二因缘行。行行者。为助菩提勤行精进。是名行行。无相行者。虽不见众生相及菩提相。而修菩提不休不息。是名无相行。不漏行者。为助菩提坚持禁戒。无有毁犯不休不息。是名不漏行。无行行者。得阿耨多罗三藐三菩提已。为调伏众生行不为菩提行。是名无行行菩提行者。修集无相行。是名菩提行。不分别法界行名菩提行。无碍行者。修集无分别法界。为无量众生演说正法。令修阿耨多罗三藐三菩提。若一生若现身。是名无上行。行无上行次第得阿耨多罗三藐三菩提已作一切佛事。是名如来行具足性行。菩萨摩诃萨定得十二行具足解行。菩萨摩诃萨断漏粗相具足喜行。菩萨摩诃萨不退转如喜行。乃至菩萨行亦如是。菩萨摩诃萨行性行时。不见一切诸法相貌。乃至菩萨行亦复如是。菩萨行性行时。不求善法及善法果。乃至菩萨行亦复如是。菩萨摩诃萨行性行时得大智力。乃至菩萨行亦复如是。菩萨摩诃萨行性行时断五怖畏。一者不活畏。二者恶名畏。三者死畏。四者恶道畏。五者大众畏。时时犹有身口意恶业。时时生贪念于五欲。于己有物时时悭惜。时时随他不自决定。或时不能观佛法僧实与不实。诸佛菩萨不可思议。不求因不求果。不求多不求少。于得不得不生忧喜。行非方便行不行方便行。少有闻慧时时忘失。具足苦不利智。少念阿耨多罗三藐三菩提不勤精进。不得甚深信解之心。见色声香味触时心生颠倒。舍身他世忘失正念。或时得慧。或时失慧。不能善知随宜方便调伏众生。或说法时不能善解文字句义。闻者或受或有不受。如闇射人或中不中。发菩提心或退不退。或毁菩萨所受禁戒。或欲自乐不为众生。或观菩萨所有果报及福德果。闻深法时。或时惊怖。或时欢喜。或时深信。或时生疑不能修集慈悲之心。少施他乐生大欢喜知足之心。无菩萨相。无菩萨庄严。自见其身去无上道远不能至。心念大涅槃不识助菩提法名。如是等相名性行菩萨。解行菩萨有三种忍。谓下中上。得下忍时如是等相上。得中忍时如是等相中。得上忍时如是等相下。得喜行时断如是相一向是善。具足如是善法故。是名净心。解行菩萨虽有如是三忍心不清净。何以故。行三忍时有下中上。不清净故。住喜行时悉断诸恶。是故清净。又住喜行时发阿耨多罗三藐三菩提心。随顺他语。又自思惟。以是二缘其心坚固。是名净愿。离于世法得出世果破众生苦。胜于声闻缘觉发愿。菩萨摩诃萨一念之愿。能得无量无边福德。如是愿者无动无尽。不退不转增长炽盛。毕竟能得阿耨多罗三藐三菩提。是名真愿。真愿菩萨有四事。一者谁发道心。二者因何发心。三者发心是何等性。四者发心有何功德。发心之时有是四观。谁发道心者。成就解行具善功德善行菩提道。如是众生发菩提心。因何发心者。具足庄严菩提之道利益众生。修阿耨多罗三藐三菩提无量之行。具足成就一切佛法一切佛行。是名因缘。以是因缘发菩提心。一切发心庄严菩提。一切修行菩提之事。随一切智及一切佛事远离凡夫。菩萨名字离凡夫地入决定地。生佛种性得名佛子。定得阿耨多罗三藐三菩提得大喜心。远离贪心妒心嗔心。为他演说菩提之道。具足庄严一切佛法佛事佛行。获得喜心受寂静乐。远离烦恼身受安乐。成就具足清净善法。近阿耨多罗三藐三菩提。至心净心为向菩萨。离一切怖得大喜心。深发菩提心远离五恐怖。修习无我相了知无我无我所。以观无我无我所故不贪于身。是故得离不活怖畏。不求他物乃至一钱常作是愿。云何当令是诸众生得大利益。是故得离恶名怖畏远离我见。离我见故不见有我。是故得离死畏。至心了知。我舍身已常与诸佛菩萨共行。是故得离恶道怖畏。我今至心求出世法。是故得离大众怖畏。菩萨远离如是畏已。亦得远离闻深义畏。离一切慢恼害恶心。离世喜心得清净心。得不坏心。得广大心。得不共心。得如是等心故勤行精进。至心念阿耨多罗三藐三菩提故。以至心信故精勤修集助菩提法。是名喜行。以住喜行心得清净。心清净故至心常念供养如来。常念护法念增长法。至心专念调伏众生。住佛世界亲近诸佛。至心听法净佛国土。常念亲近共佛菩萨善知识行。为利众生得阿耨多罗三藐三菩提而作佛事。未得阿耨多罗三藐三菩提时常作是愿。是名大愿。如是等无量百千愿。名为善愿。作是愿已于现在世勤修精进。为净喜行故。修集十法。信一切佛法故。因十二因缘众生受苦。为苦众生得解脱故修集悲心。为施众生安乐之事修集慈心。为破众生苦恼事故不惜身命。不惜身命故舍内外物。为利众生受苦不悔。心不悔故能知一切世典方术。知世典故能知众生下中上异。随下中上具足惭愧。修如是事其心不退。得勇健力受他财物。能以供养佛法僧宝。是名十法。十法者。一者信。二者悲。三者慈。四者施。五者不愁。六者了知世典。七者随顺世间。八者惭。九者愧。十者健。菩萨摩诃萨修是十法。为持戒故。行于九法观察道果。功德过患知已则能修集于道。至心受持过一切行。得阿耨多罗三藐三菩提。能度众生于生死海。能教众生行诸善行。菩萨尔时住喜行时见无量佛。如菩萨藏所说见闻。复知十方无量世界有无量名有无量佛。知已至心求见能见。是名善愿。又复作愿。愿我常生诸佛世界随愿往生。是名善愿。以得往生诸佛世界。随力供养佛法僧宝。听法受持如法而住。所修善法一切回向阿耨多罗三藐三菩提。以四摄法摄取众生。是故善法增长炽盛。供养三宝摄取众生。于无量劫净于身心。如数炼金其色倍明。菩萨之心亦复如是。其心净故善法则净。菩萨摩诃萨受人身时。作转轮王王四天下。随意自在远离悭贪。亦破众生所有悭贪。以四摄法摄取众生。所作善法若多若少。悉以回向阿耨多罗三藐三菩提。愿令众生一切悉得无上道利。尔时菩萨以勤精进舍家为道。于一念中能具百种三昧。一念中见百世界佛。亦知百佛所行之处。亦能振动百佛世界。其身能过百佛世界。光明遍满百佛世界。神通能变一身为百。化百众生了知去来各百劫事。入百法门阴入界门。各知百数能示百人。以为眷属悉得神通。菩萨摩诃萨住喜行时。能作如是神通等事。以愿力故。是故菩萨发愿不可思议。喜行菩萨有六发心。一者发于善愿勤精进故。二者行净故。三者为得异行故。四者净善根故。五者为善有故。六者不可思议故。喜行者。如十住中欢喜地说。利他故名地。自利故名行。戒行菩萨有何等相。喜行菩萨所有功德。戒行菩萨悉以具足。有十净心。一者心净尽敬奉事诸师和上耆旧宿德不生欺诳。二者心净见同法菩萨先意软语。三者心净胜于一切烦恼魔业。四者心净见一切行多诸过咎。五者心净见涅槃功德。六者心净修集一切助菩提法。七者心净为助菩提修集寂静。八者心净不为世法之所染污。九者心净离声闻乘乐念大乘。十者心净常念利益一切众生。是名十种净心。以具如是十净心故名戒地行。戒地行时具足性戒。共邪业戒不受不念不生欢喜。轻戒不毁。况中上戒。具十善法知善不善。善业恶业。善有恶有。是乘非乘。若因若果。悉了了知。了了知故自行十善。复教众生令行十善。若诸众生恶业因缘受于苦行。心生怜愍修集大悲。为破众生所受苦故。戒行菩萨身寂静心寂静。身心寂静。犹如真金得迦私婆药入火则净。菩萨善心所修善法亦复如是。菩萨摩诃萨住戒行时。若生世间作转轮王王四天下。能转众生毁戒恶业。安置众生善法戒中。余如初说。亦如十住离垢地说。远离一切毁戒垢。故名离垢地。教菩萨戒故名曰戒行。净地戒行义无差别。慧行菩萨有何等相。慧行菩萨得十净心。作如是观。我十净心不退不转。我于一切有漏之法心不甘乐。我于漏法乐喜修集对治法门。于是对治不退不转。一切有漏烦恼魔业悉不见胜。以修集故不生舍心。我甚甘乐佛菩萨行。为佛菩提修诸苦行不生厌悔。我今至心专念大乘。常欲利益一切众生。慧行菩萨观一切行有无量苦行。作是观已不染诸行。观佛功德及以智慧无量福行。至心念佛所有功德得大信心。为破众生苦恼事故。修集悲心善思方便。为令众生得解脱故。为解脱故观于对治。得对治故观善三昧。乐闻菩萨法藏经典。既得闻已勤修精进。为听法故不惜身命。内外财物供养父母和上师长耆旧有德。为诸众生多受众苦。若得受闻菩萨法藏一字一句一偈一义。其心欢喜。胜得三千大千世界满中珍宝。胜得释身魔梵天身转轮王身。若闻说言我有一字一句一偈一义是佛所说。若能受苦投大火坑乃当与汝。菩萨闻已欢喜乐受。即作是言。假使三千大千世界满中猛火。于无量劫尚以身处。况于小火。菩萨尔时勤精进故。作是思惟。若得真义则能利益。无上佛法非以字句能利益也。为解真义故。修世四禅四无色定四无量心及五神通。以修定故愿生欲界。修助菩提利益众生。虽生欲界无欲界结。先断贪欲嗔恚愚痴。犹如真金数被炼治终无损减。修净善根故得帝释胜身。为乐欲者坏贪欲故。令得思惟诸善法故。为令众生真实能知行界众生界故。为苦众生令得解脱知善方便故。为供养父母和上师长福德人故。为令众生如法住故。为得禅定善三昧神通故。如十住明地中说。如十住明地慧行亦尔无有差别。助菩提行菩萨有何等相。慧行菩萨有十法如先说。住如是法心不可坏。修集智慧能为众生演说正法为令调熟。已得熟者为说解脱生佛种性。修三十七品及善方便故。远离我见及以断见断诸烦恼。得忍心软心。善心净。无量行心知恩念恩。具足无量清净善法。勤加精进修作上地一切善业。了知法界及众生界。一切恶人魔及眷属。不能移转沮坏其心。余如上说。犹如工匠作金璎珞。为令众生受欢喜乐。菩萨善法亦复如是。不为声闻辟支佛等之所倾动。生夜摩天破诸众生所有我见。是名菩萨助菩提行。为欲修集利智慧故。修集三十七品破一切见一切漏故。遮一切业故。增长善法故令地清净故。菩萨修集助菩提行。如十住中炎地所说。助菩提行亦复如是等无差别。自利名地利他名行。谛行菩萨先得十清净法。以大净故名共谛行。谛行菩萨见无量世界无量诸佛。观四真谛有十行。若说苦。何故说。何因缘说云何说。谁所说。如是等能真实知。集灭道亦如是。作是观时知谛方便。观一切苦一切谛过患功德。为诸众生增长悲心。知诸众生去来世业。了知世谛知受邪法。为邪法者说于解脱。知庄严事。具足念心具足慧心。种种方便以调众生。解了一切世间方术。为化众生破种种苦。为得阿耨多罗三藐三菩提故。能施众生所须之物。能破众生贫穷困苦。知处非处破邪祠祀。不受倒解菩萨藏义说真实道。余如上说。譬如真金众宝厕填价直无量。菩萨摩诃萨亦复如是。所有善法胜于声闻辟支佛等下地菩萨慧行菩萨如日月光无能毁翳。毗岚大风不能移动。菩萨摩诃萨所有智慧亦复如是。一切声闻辟支佛等所不能动。不为世法之所破坏。舍身往生兜术天上。得大自在破坏邪法。成就无量亿数福德具足如是菩萨智慧为净众生故。为知真谛方便说故。为观生死有大苦故。为欲增长大悲心故。为欲具足功德智慧二庄严故。为发善愿故。为令念心施心慧心转增长故。为欲思惟诸善法故。为欲调伏行众生故。为教世法出世法方便故为净善根故。余如上说。如十住中难胜地说。谛行亦尔无有差别。共十二因缘行菩萨如先说。菩萨摩诃萨住共十二因缘行时观一切法第一义相。第一义相者。即诸法无相。一切诸法不可说故。名之无相。无相者无生灭相。是故诸法无生无灭。无生无灭故见无生平等。无始终平等。有无平等。无取无舍平等。如幻平等。无性平等。无有无无平等。菩萨住是诸平等已增长大悲。至心专念菩提之法。了知世间出灭之处。知十二因缘。知从缘生法。知从十二因缘出生三解脱门。所谓空无相愿。修集三解脱门故。永断我我所相作相受相。是名第一义。为众生故真实思惟。烦恼和合因缘不牢。因缘不牢有为危脆。是故无我无我所。成就具足无量众苦。我能坏散有为之法。虽能坏散不应永灭。我护有为为众生故。作是观时即得无碍慧行。以知无碍智慧行故。于一切世中行无挂碍。以得无碍智慧行故。是名摄取第七地忍。修助菩提共有为行。不乐永灭有为之法。虽不永灭亦不染着。菩萨尔时修是方便。即得万空三昧门。如万空门无相无愿亦复如是。以修三万三昧门故。一切邪见外道声闻缘觉诸魔眷属。不能移转倾动沮坏。余如上说。犹如帝释转轮圣王。所著金冠杂宝厕填。诸天世人之所乐见。菩萨智慧亦复如是。亦为诸佛及诸菩萨之所乐见。如日月光诸明中胜。菩萨智慧亦复如是。菩萨摩诃萨住十二因缘行为令众生见法平等。为知十二因缘得解脱故。得三解脱门故。破坏一切诸邪相故。方便教化转生死故。得无碍智慧故。得无碍智慧行故。得无量三昧门故。不破不动故。增长善法故。清净诸有故。余如十住现前地说。十住中说此之所说等无差别。行行菩萨有何等相。菩萨得助菩提行时。具足能得无量三昧。有共世间不共世间。以具足故入第七行。菩萨尔时于世法中。得大自在至心念慈。功德庄严菩提庄严悉得增长菩萨所得助菩提法。不与声闻辟支佛共。知法界众生界世界界。知佛身心。尔时具足如是功德。知佛境界。无相无业无有觉知。见无量佛土。若行若住若坐若卧。于一切行不失道心。菩萨尔时一一念中增长一切十波罗蜜。具足成就助菩提法。菩萨住喜行时发愿因缘。住第二行远离一切毁戒因缘。住第三行善愿增长得法光明。住第四行离一切障道因缘。住第五行离世学障。住第六行得入深义。令此七法增长趣向一切佛法。具足增长助菩提法。是故菩萨次第当得第八净行。毕竟净故名为净行。七行杂故不名净行。住此行时断诸烦恼。亦不与俱又不名离。烦恼不起不得名俱。未得佛故不得名离。三业清净了知一切世术方便。能为三千大千世界人天之师。唯除八地。三千大千世界众生心无与等。亦除八地。自在入出无量法门。永离声闻辟支佛道。是名清净身口意业。亦修集道无有厌足。能得阿耨多罗三藐三菩提。为众生故说有为法。离身口意一切相貌。得深法忍不生不灭。行六行时入灭尽定。今此行中虽念念灭不取涅槃。是名不可思议。虽共一切众生行菩提行。不为世法之所染污。余如上说。修三解脱调伏众生。不令住于声闻缘觉。调伏众生离五欲乐断诸邪见。修集是时善法增长。无能破坏动转其心。譬如真金厕填众宝价直无量。菩萨功德亦复如是。无量无边不可称计。又如日光一切众生不能思议。菩萨慧光亦复如是。菩萨摩诃萨修集此行。为令众生得无量亿诸三昧故。破坏一切取相心故。得善方便修集道故。见佛世界得解脱故。能入甚深诸法门故。具足得助菩提法故。永断净法不净法故。具足庄严菩提道故。净心业故。了知一切世方术故得无量法门及诸三昧。不与声闻缘觉共故。余如十住远行地说。远行地行义无差别。无相行菩萨有何等相。菩萨摩诃萨住初行时。得十行法知诸法义。及知三世不出不灭。过去不出未来不灭现在无相。无因缘故不出不灭。是故第一义相不可宣说。不可说法可说流布。虽可流布实无有性。性无相故无因无果。然不可说性不可说无。何以故。以可说故。若可说性是有相者。是名邪相。若是有物不可说者。是则无有初中后异。以是故一切时中烦恼不行。入正法界无有思惟。心得平等离疑网故。具足如是十种智已入第八行。菩萨摩诃萨住此行时。即得寂静无生法忍。复有四求求一切法。有四真智知一切法。以求知故能断一切诸邪业等。断邪业故见诸烦恼更不复生。何以故。过去故。又见一切烦恼不灭。何以故。无生因故。现在不起诸结烦恼。不集因故。四求如真实品说。四真实智如解行中说。此行名为寂静法忍。是故菩萨得无生忍。得无生忍故得甚深菩萨行。住深行时行无相行。若有过患及微细相。今悉远离。是故此行名为寂静。住深行已乐住法流。无量诸佛劝发慰喻。以劝发故起入法门。得法门故得十心自在。如上所说。得自在故。欲久近住随意即能。欲入何定随意即入。欲行何行随意修行于一念中随所须物即能得之。若欲了知世间方便即能了知。欲生诸有随意往生。欲示神足随意能现。欲立誓愿随意能得。欲作解观随意成就。欲知法界即能知之。欲知文字知辞知句知法处非法处即能知之。是名自在八行功德。于念念中常见诸佛。余如上说。金喻日喻亦复如是。菩萨摩诃萨住此行时。为破众生所著相故。为真实见第一义故。得真实慧故。得寂静无生忍故。知甚深行故。住法流故。入佛法门故。入不可思议法门故。于佛法中心不可坏不倾动故。得无量神足故。得十种自在故。得十种自在功德故。寂静善根故。于一切有自在往生故。余法如十住中不动地说。不动地此行无有差别。四无碍行菩萨有何等相。菩萨摩诃萨行甚深行无有厌足。修无上慧具足一切法。为众生说了知法界。法界者。所谓烦恼垢净。谁垢谁净了了而知。说如是等法名大法师。名曰成就无量陀罗尼。知方便说辞义无尽。受法持法。随众生念而为说之。非时不说随乐而说是名菩萨四无碍智行。余功德如先说。菩萨摩诃萨住于此行。为诸众生入寂静故。为诸众生知法界故。为诸众生不可思议大法师故。为增长善法故。广说如十住中善慧地所说。为施众生安隐乐故。菩萨摩诃萨住无碍行中。与善慧地义等无差别。住菩萨行菩萨有何等相。菩萨摩诃萨净无碍行。欲为法王入净三昧故。欲具一切智。最后所得三昧法门与。诸佛共同。佛一坐行一切行知一切法。知解脱方便。知佛行处。知无量解脱陀罗尼门。知大忆念。知大神通善根寂静。知净诸有。余如十住法云地说。具足菩萨庄严菩提道菩萨行法云地。与诸佛共得菩提已。施于众生无量法雨。如是法雨能淹一切烦恼尘埃。生法种芽善芽增长成熟善根。是故此地名为法云。以是义故名菩萨行。若说后地功德先地所无。修一一行要经无量那由他劫乃得具足三阿僧祇大劫得一切行。初阿僧祇大劫得解行。过解行已。第二大阿僧祇劫得喜行得喜行时亦行无相行。过无相行已。第三阿僧祇大劫得无行无相行是名菩萨得决定行。过无行无相行得无碍智行。过无碍智行得菩萨行。阿僧祇有二种。一者大劫不可数名阿僧祇。二者中劫不可数名阿僧祇。菩萨修行即是大劫阿僧祇也。若有菩萨勤精进者。能转无量中劫不能转大劫。菩萨摩诃萨修集如是行。能坏烦恼障及智慧障。无相行时断一切烦恼相。后行时永断习气。是名如来行。智障有三。一者皮。二者肤。三者骨。得喜行时已断皮障。得无相行能断肤障。得如来行能断骨障。具足如是等行得十一净。初行得性净。第二行得解净。第三行得心净。第四行得戒净。第五行得愿净。第六第七第八行得智庄严净。第九行具菩提庄严净。第十行真实智净。第十一无碍智净。第十二一切智净。第十三习气净。第一第二行闻菩萨藏便得信心。第三行至心立愿修集余行。第四第五第六行了知法相。第七乃至第十三寂静一切行因果毕竟行。声闻亦有十二种行。有声闻性是名初行。若得世间第一法名第二行。得苦法忍名第三行。得四信心戒得清净名第四行若如戒住法得增长名第五行。若观四谛名第六第七第八行。修集无相三昧名第九行。具足成就三三昧故名第十行获得解脱名十一行。阿罗汉果名十二行

    毕竟地生品第一

菩萨生有五种一切。一切行一切菩萨净。为令众生安隐乐故。一者为离苦有。二者随心行有。三者胜有。四者自在有。五者菩萨后有。远离苦有者。菩萨若见众生饥渴苦恼遭荒谷贵。尔时菩萨以愿力故。受大鱼身无量由旬以施众生。众生食已饥渴得除。以愿力故身转增大。若有恶世一切众生。四百四病同时发作。菩萨尔时以大愿力作大医王。能令众生远离病苦。若有恶世兵甲竞起众生恐怖。地主诤国不知厌足菩萨尔时为大法王有大力势。以善方便和合二敌。以软语故坏其恶心。不打不罚不闭不系。不断其命劫其财宝。等视众生犹如一子怜愍众生。若有邪见为供养天造作邪业。菩萨为破如是邪见示受鬼身。现梦教言。汝今不应杀羊祠祀。是故菩萨为破众生诸苦恼故示受诸有。是名离苦有。随心行有者。菩萨摩诃萨以愿力故。示受畜生种种诸身为破畜生诸恶业故。作恶鬼身作恶人身。又作邪见婆罗门身。或复示作贪五欲身。先随其心示受诸有。为令众生离恶业故。虽受有身不作恶业。若彼作时自终不造。众生见已亦效不作。以善方便破坏众生所有恶业是名随心行有。胜有者。菩萨生时胜诸众生。若姓若色若命若果报。果报如自利利他品说。是名胜有自在有者。修初喜行至十二行。菩萨尔时所示受身。名为自在。自在者即是愿力。从性地乃至十二行。受转轮王身自在天身。乃至阿迦尼吒天身。及过阿迦尼吒一切诸有。于诸有中得无上身。以愿力业力故。是名自在有。菩萨后有者。菩萨最后身名菩萨有。具足成就庄严菩提。若生婆罗门种。若生刹利种。得阿耨多罗三藐三菩提作一切佛事。是名菩萨后有。过去菩萨摩诃萨亦受如是五有。现在未来诸菩萨等亦复如是。因是五有得阿耨多罗三藐三菩提果。若有菩萨修行示受是五有者。即得阿耨多罗三藐三菩提

菩萨善戒经卷第八菩萨善戒经卷第九

        宋罽宾三藏求那跋摩译

    毕竟地摄取品第二

菩萨摩诃萨修一切行时有六事善摄众生。一者至心摄取。二者增益摄取。三者取摄取。四者究竟摄取。五者不毕竟摄取。六者后摄取。菩萨摩诃萨初发心时。摄取众生如父母兄弟妻子眷属。至心系念方便摄取。云何能施众生安乐。作是愿时随力施与。是名菩萨至心摄取。菩萨摩诃萨虽于父母兄弟妻子眷属中。胜心无憍慢倍增供养。若为国王于说眷属。亦复如是。增益者。破坏恶法教以善法。随时礼拜赞叹供养。施以衣食所须之物。知恩报恩瞻病授药。于诸仆使不作贱想如兄弟想。若见有罪堪忍含受。言当柔软无有粗犷。若为国主于诸眷属不加苦痛。不断其命。远离刑罚正法治国。随本种姓所有分界。于他国土不生贪夺。任力养民作一子想。所有之物与眷属共。所言诚实柔软不粗离于悭贪。是名菩萨增益摄取。菩萨摩诃萨摄取诸众生有二因缘。一者财施。二者法施。以财施故破于贫穷。以法施故破于邪见。于诸众生其心平等。不作法悭不作师相憍慢之想。不求恩报不求供养。若有求福来供养者亦不遮止。为令福德庄严增长故。若有修集善法持戒精进之者。瞻视供养亲为执使。不解义者为解说义。已解义者说令增长。若有疑网为说深义能令除断。苦乐同彼心无增减。有犯罪者以善方便教令忏悔。有时呵责有时赞叹。见病苦者瞻视不舍。善以方便为除所患。若有众生下色下进下念下智心不轻慢。随时为说正心因缘。见愁苦者说法慰喻。善自思惟不信他语。无能动者。若得所施与众同等。修集悲心具足成就。或见正命先意问讯。远离恶心常修善法。终不放逸远离懈怠。常作是愿。云何当令我之福德等与一切。菩萨摩诃萨非一切时行取摄取。有利之时尔乃摄取。是名菩萨取摄取。若诸众生诸根闇钝。善根难熟则久远摄取。何以故。究竟当有清净心故。若中根中熟则不久远。何以故。以不久远得净心故。若有利根易熟上熟易净易调。是名菩萨后有摄取。是名菩萨六摄取正法摄取菩萨摩诃萨以此六摄摄取三世一切众生。过去未来现在菩萨摄取众生。悉皆不离如是六摄。菩萨摩诃萨摄众生时有十二难事。菩萨摩诃萨知无我无我所无有众生。而为众生修集苦行。是名一难。为调他故而行呵责。亦自护戒不令毁伤。是名二难。所有物少乞者甚多。是名三难。菩萨一身系属多人趋走给使。是名四难。放逸诸天同彼受身。而其内心初无放逸。是名五难。常为一切众生作使。自于禁戒无所毁失。是名六难。常与贪欲恚痴悭吝谄曲奸伪恶人共住不随彼行。是名七难。了知生死多诸过患而不舍之。是名八难。一切烦恼生死多过。舍命之时心未清净。虽未清净不失正念。是名九难。未得净心能以己身所爱之物妻子眷属而以施人。是名十难。众生异心境界不同。或时软语或时行舍。是名十一难。终不放逸不断烦恼。名十二难。菩萨摩诃萨于诸众生不作轻重。或时作轻。或时作重。或观境界。或作健心。或时立愿。或不放逸。或修智慧或修柔软。或行呵责。或时行舍。或勤精进。或时懈怠。或作方便。菩萨摩诃萨作如是学。于十二难处心不忧悔。既能自护又能利他

    毕竟地毕竟品第三

菩萨摩诃萨修十二行有七地。六是菩萨地。余一地声闻菩萨共。一者性地。二者解地。三者净心地。四者持地。五者定地。六者定行地。七者毕竟地。是名七地。性行解行各为一地。喜行名为净心地。戒行慧行无相行合为持地。无行无相行名为定地。无碍智行名为定行地。如来行名毕竟地毕竟地后当广说。菩萨从下地入净心地时。云何能断三恶道苦。菩萨修集世俗漏禅。修漏禅已得世净禅。修净禅已即得解地。庄严菩提修集一百一十种悲。以修悲故于众生中即得悲心。得悲心故乐三恶道如己舍宅。菩萨自观住三恶道。庄严菩提时为众生故受大苦恼。若我净心有势力者。愿令众生所有苦恼悉集我身。善立大愿。以善愿力世净禅故。远离身心烦恼习气。离习气故转四大身。四大既转。因世净禅故不到三恶。是故菩萨断三恶道苦。过解地已入于净地。余功德如行品中十净心说。此十净法有十对治。不作心。不发心。不受菩萨戒。不信心。恶心。不修集悲。嗔心。忧悔心。不慈心。放逸心。所言粗犷贪惜身命不随世间。懒堕懈怠无渐无愧。苦恼逼身疑网怯弱。不能供养佛法僧宝。如是等对治不净。是十净中。初三法者清净其心。后七法者净于庄严。菩萨摩诃萨信于菩提及菩提道。信菩提道故。见苦众生生大慈心。生慈心故即作是愿。愿我救济如是等苦。以怜愍故舍身惠施无所贪惜。为利众生心无忧悔。心不悔故知世方术。知世方术故善知时节随众生心。以知时故名知世间。以智力故客烦恼来深生惭愧。以惭愧故令彼烦恼不得自在。是名勇健。以勇健故无有放逸。不放逸故修集善法。集善法故受菩萨戒。受菩萨戒故供养三宝。供养三宝故其心清净是名净地

    毕竟地行品第四

菩萨摩诃萨住于解地乃至菩萨地有四行。一者波罗蜜行。二者菩提行。三者神通行。四者熟众生行。波罗蜜行者。六波罗蜜如先说。方便波罗蜜愿波罗蜜力波罗蜜智波罗蜜。是十波罗蜜是名波罗蜜行。善方便有十二种如先说。是名方便波罗蜜。愿有五种如先说。是名愿波罗蜜。十力庄严净是名力波罗蜜。知一切法是处非处名智波罗蜜。知世谛故名智波罗蜜。知第一义谛名般若波罗蜜。复次无量智者名方便波罗蜜。求胜胜智名愿波罗蜜。不为四魔之所障故名力波罗蜜。能知诸法真实性故名智波罗蜜。四念处乃至八正道分四求四真智如先说。是名菩提行神通。如不可思议品说。六通如先说。是名神通行。二无量调伏无量方便无量如先说。是名熟行。菩萨摩诃萨如是四行摄一切行。菩萨摩诃萨无量阿僧祇。究竟具足净诸善法。胜诸声闻辟支佛等。毕竟摄取菩提道果。毕竟能得阿耨多罗三藐三菩提故。是名十波罗蜜。若说次第则有三事。一者对治故。二者生故。三者得果故。对于善法有六事。一者悭贪。二者恶业。三者恚心。四者懈怠。五者乱心。六者愚痴。以是六法因缘故。不得阿耨多罗三藐三菩提。为坏六法故说六波罗蜜。檀波罗蜜乃至般若波罗蜜。六波罗蜜则摄四波罗蜜。是名对治。生者。菩萨摩诃萨舍于一切世俗之物出家学道。是名檀波罗蜜。既出家已受菩萨戒。是名尸罗波罗蜜。以护戒故虽有骂打默受不报。是名羼提波罗蜜。戒既清净勤修善法。是名毗梨耶波罗蜜。以精进故五根调伏。是名禅波罗蜜五根既调知真法界。是名般若波罗蜜。是名为生。果报者。菩萨现在修施等善法。若舍身已外得大财内得五具足。五具足者。生人天中得寿色力安乐辩才。是名施果。以施因缘修集善法。心无嫉妒忍众罪过。是名具足第二果报。以施因缘若作世事及出世事心无厌悔。是名第三果报。以施因缘其心柔软无有错乱是名第四果报。以施因缘了了能知此是福田此非福田。知是可施是不可施。善知方便求财取财。是名第五果报。四波罗蜜摄六波罗蜜有三戒。一者随戒戒。二者随心戒三者随智戒。菩萨尸波罗蜜名为随戒戒。禅波罗蜜名随心戒。般若波罗蜜名随智戒。离是三戒无菩萨戒。菩萨三戒摄一切戒。菩萨有四事能利众生。何等为四。一者为于菩提修集善法。二者先以真智知诸法义。三者增长善法。四者熟众生根。如是四事菩萨能大利益众生。若有说言。离是四事能利众生者。无有是处

    毕竟地三十二相八十种好品第五

十三如来行者。名为毕竟佛地。毕竟佛地者。有百四十不共之法。所谓三十二相八十种好。四一切行净。十力四无所畏。三念处。三不护大悲。常不忘失。断烦恼习一切智是名百四十不共法。三十二相者。一者足下平。二者足下千辐轮。三者指纤长。四者足跟佣满。五者指网缦。六者手足柔软。七者佣[跳-兆+尃]肠如伊尼延鹿王。八者踝骨不现。九者平住手摩膝。十者藏相如象马王。十一者身圆满足如尼拘陀树。十二者身毛上靡。十三者一一毛右旋。十四者身真金色。十五者常光面各一寻。十六者皮肤细软尘垢不着。十七者七处满。十八者上身如师子。十九者臂肘佣圆。二十者缺骨平满。二十一者得身佣相。二十二者口四十齿。二十三者齿密不疏。二十四者齿色白。二十五者颊车方如师子。二十六者味中得上味。二十七者肉髻相。二十八者广长舌。二十九者梵音声。三十者目绀青色。三十一者眼如牛王。三十二者眉间白毫

八十种好者。二十指是名二十好。手足表里八处平满踝膝[月*坒]六处妙好手有三聚肩肘腕六处满。腰奇中是名二好。臗及二尻是名三好。马藏二膊是三好。腰脐两胁两腋两乳是名为八。腹胸脊项是名六十。上下牙齿。上下唇齶。两颊两鬘。两目两肩。及鼻二孔。额上两肞。两耳头圆足。是名八十

菩萨摩诃萨住净地已。以业力故虽得如是八十种好未大明净。道树起时乃得明净。不明净时谓菩萨地行。庄严菩提有二种。一近二远。远者。未得三十二相八十种好果报若得名近说三十二相八十种好。为令众生作善业故。众生造作种种恶业。以恶业故得种种恶果。是故如来说三十二相八十种好种种善业种种善果。众生闻已即得除破种种恶业。菩萨至心修持净戒故得足下平。供养父母和上师长有德之人。以是因缘得足下轮相。于诸众生不生害心无劫盗想。若见父母和上师长有德之人。远出奉迎安施床坐。恭敬礼拜破除憍慢。以是因缘得纤长指。具上三行得足跟佣满。以四摄法摄取众生。以是因缘得指网缦。以好苏油摩洗父母和上。师长有德之人。以是因缘得手足柔软。修集善法不知厌足。以是因缘得佣腨肠。闻法欢喜乐为人说为法走使。以是因缘得踝骨不现相。三业清净瞻病施药。破除憍慢饮食知足。以是因缘得平立手摩膝相。见分离者善言和合。自修惭愧亦教人修。以是因缘得马藏相。自净三业亦教人净。若有众生四大不调能为疗治。以是因缘得身圆相。闻法欢喜乐为人说。以是因缘得身毛上靡相。思惟诸法甚深之义乐修善法。供养父母和上师长有德之人。若行道路佛塔僧坊除去塼石荆棘不净。以是因缘得身毛相。若以饮食璎珞施人除去嗔心。以是因缘获得二相。一者金色。二者常光。以何业缘得一一毛相。即此业缘得身细软尘垢不着。常施众生所须之物。以是因缘得七处满相。自破憍慢调柔其性。随众生心如法而行。为除不善教以善法。以是因缘得上身如师子相。得肩圆相缺骨平满相。以何业缘得纤指相。即此业缘得身佣相。远离两舌和合斗诤。以是因缘得四十齿相齿密不疏相齿齐平相。修欲界慈。以是因缘得白齿相。见有求者欢喜迎送。以是因缘得方颊车相。等视众生犹如一子。以是因缘得上味相。常施众生无上法味。见有忘者施其忆念。自持五戒转以教人。修集悲心能大法施。以是因缘得肉髻相广长舌相。实语喜语法语软语非时不语。以是因缘得梵音声相。修集悲心视诸众生犹如父母。以是因缘获得二相。一者目绀青色。二者眼如牛王。见有德者称实赞叹。以是因缘得白毫相。三十二相虽复各各说其因缘。真因缘者持戒精进。何以故。若不持戒能修精进。尚不得人身。况得三十二相。无见顶相及肉髻相等无差别。复次凡所作事定心不悔。以是因缘得足下平相。若至心作。以是因缘得千辐轮相。第二第三指网缦相。七处满相。细软肩圆缺骨满。身直广长舌相。若常作者。以是因缘得长指相平住摩膝相。常光一寻相齿密不疏相。若净作者。以是因缘获得余相。复次若于众生生淳善心。以是因缘得手足柔软肤体细滑尘垢不着。次第修集时节修集。以是因缘得第二第三第四相。喜修善法心无悔退。以是因缘得金色身。常光齿白眉间毫相。若闻赞叹不生憍慢。覆藏善法不令人知。以是因缘得马藏相。所修善法回向菩提。以是因缘得一一孔一毛相。身毛上靡口四十齿最上味相勤精进故。以是因缘得方颊车上身如师子相。至心爱念一切众生如视一子。以是因缘得齿齐平绀青目牛王眼相。修集善法不知厌足。以是因缘获得余相。菩萨摩诃萨住性行时。修三十二相业。住净行时虽有如是三十二相。相不具足未得明净。住十三行尔乃了了明显具足一切佛法。虽无量相众生不同。有下中上不可思议。是故佛说三十二相。一切众生所有功德和合集聚。正与如来一毛相等。一切毛孔所有功德和合集聚乃成一好。合集众好所有功德。增至百倍乃成一相。唯除白毫无见顶相。合集其余一切诸相。增至千倍成是二相。和合集聚三十二相八十种好所有功德增至千万亿倍乃成如来深远蠡音。其声闻于无量无边诸佛世界。如来成就如是等无量无边功德。以是义故。如来世尊名为无上。所行之法名无上行。三十二相八十种好有三种无量。一者三劫无量。二者修善无量。三者利益众生无量。是故说言如来成就无量功德

    毕竟地住品第六

菩萨四净者。一者身净。二者缘净。三者心净。四者智净。永断习气得清净器。成阿耨多罗三藐三菩提。身得自在生灭自由。是名身净。神通自在名为缘净。修集善法心离烦恼。是名心净。知一切法无有挂碍。得自在智知一切法行。是名智净。菩萨以是四清净法获得十力。何等为十。一者知是处非处力。二者知诸业力。三者知诸禅定解脱力。四者知诸根利钝力。五者知诸众生解力。六者知众生界力。七者知至处道力。八者知过去世力。九者天眼力十者漏尽力。如来所说真实无二。是故名为多陀阿伽度。若说善果及不善果真实因缘真实体真实性真实住真实生。是名是处善不善果非因作因。是名非处破憍慢智。名真实智。名一切智。名无碍智。名为净智。名离慢智。数次第故名第一力。无有上故名一切行。利益众生破坏诸魔故名为力。真实庄严得自在故名为具足。能破一切诸恐怖故名为涅槃。因八正道因破诸苦故名为无上。如法住故名为真实。自得净法怜愍众生而为演说故名为梵轮。梵轮者名为如来。如来者名为清凉。清凉者名之为戒。受持净戒如戒而说。是名清净正说实说利益而说广大说无碍说一切说毕竟说无上说无漏说无为说外说现前说。是故名为大师子吼。说善力方便。说真实因。以真实因缘得真实果。所谓人天及无上果。无上果故名为无上。若作业已增长得果。名为过去。有作业已未受果报。亦名过去。未作业欲作。未得果欲得。是名未来。已作之业未得果报。受果之业已灭过去。是名现在。去来现在业有三种。谓身口意果。身口意果。何处造作身口意善业。是处得果。何处造作身口意恶业。是处得果。是名是处。纯善之业不得恶果。是名非处。不善恶业不得善果。是名非处。人业不受地狱果报。是名非处。地狱之业不受人报。是名非处。唯除能修身戒心慧令地狱报人中轻受。以相似故名地狱报。人中轻受故名人果。是名是处非处。四禅八解脱。如是等法自在修得。以自在故。是故如来常在三昧。说法之时

梵天王等。唯闻音声不见形貌。如是等禅定解脱有二种烦恼。谓未得欲得忧。已得退失忧。如来已断如是二忧得大自在。知诸众生一切心想。虽得了知心不贪着不生欢乐。修集具足欲得便得。大得易得。得已不退。是名第三禅定解脱力。知信等五根有上中下。从闻生者。正思惟生者。是名根力。知上中下欲。是名解力。知种种性声闻性缘觉性如来性众生贪性乃至八万四千烦恼性。是名第五力。知因烦恼获得种种世界之身。是名第六力。知诸烦恼各有对治。知一切有亦各有对。知破一切恶邪见对。是名至处道力。了知四方种种众生种种名字。过去众生念八事。一名。二生。三姓。四食。五受苦乐。六寿。七住。八者命终。复念六事。一者名字。二者刹利等姓。三者亲族父母。四者饮食。五者贫富。六者寿夭。是名第八力天行名为四禅。得四禅果故名为天眼。具足获得淳善果故名为清净。明不同故名过人眼。有欲界天眼。虽复名同以不净故不名天眼。天眼知者见众生堕。堕者名天。复有堕者名为人死。生名中阴。中阴有二种。一者善。二者不善。不善中阴色如黑氀褐。夜闇之时净眼乃见。清净天眼见中阴色亦复如是。善中阴色如婆罗奈女衣。明月之时净眼乃见。清净天眼见中阴色亦复如是。黑色者名下行众生。白色者名上行众生。身口意恶业因缘故名为下行。身口意善业因缘故名为上行。恶业者名为邪见。邪见有二。一者可转。二不可转。诽谤因果言无圣人。名不可转。非因见因非果见果。是名可转。是故恶业名为邪见。善业者名为正见。不谤四谛信善恶业真实果报。是故善业名为正见。恶业因缘死过地狱。不乐受果故名地狱。放逸恶业共为翅羽必至地狱。明见因果故为天眼。善业因缘过于恶死。乐受果报受人天身。以正见故得生善有。生善有者名为人天。明见了了故名天眼。云何善有。以善因缘获得善果是名善有。是名第九力。以修身戒心慧因缘断一切漏。以断漏故获得无漏身戒心慧。无漏身戒心慧有二种。见道修道。以二道故心得解脱慧得解脱。得心慧解脱故能示神通教化众生。是名第十力。十力菩萨知性。知分别。知自相共相不共相。知平等。知业。知次第。知胜不胜。菩萨能知如是七事。知性者。十力性即五根性。以慧多故名为智性。是故说言知处非处。不言信处非处。乃至漏尽亦复如是。分别者有三种。一者分别时。二者分别行。三者分别自相共相十力能知一切时。所谓过去未来现在。是名分别时。十力能知一切十方世界无量烦恼对治。是名分别行。十力能知一切色相。是名自相。知色无常乃至一切法无常。是名共相。是名分别自相共相。不共者。十力不共一切声闻缘觉。十方诸佛同得十力。是名平等。知业者。处非处力。因实知因果实知果。是第二力。如来了知自业果报。亦知众生所有业果。因禅定解脱力故。如来得三种示现能调众生。因知根力了知众生下中上根。以知根故随根说法。因解力故如来了知一切众生善性恶性。为除恶性教以善性。因知世界力故。如来常行世间之法。不为世法之所染污。知世界故知众生界。知众生界故。随根随心随其烦恼而为说法。云何如来初教众生令入佛法。如来若教声闻菩萨初入佛法。作如是言。善男子。汝应修集深乐寂静空闲独处。汝初生时父母为汝所立名字。乃至诸师和上所立名字。当至心观。如我此字父母诸师和上所作。于内外六入有耶无耶。善男子。汝若离于内外诸入不见有者。汝于尔时得真实智。知是名字虚假不真。法亦不真。名亦不真。以名字法不真实故。云何于是而生憍慢。善男子。汝于尔时复应观眼及眼名字。眼有二种。一者名字。二者流布。眼名非眼眼相非眼。若有一物名为眼者是物亦无。若实有眼名亦应实。若真实者众生生时。自应识知不须教诲。未见不教而能知者。以是义故。知名亦不实物亦不实。如眼识亦如是。作是观时除断内外诸入贪着。以断内外贪故。断一切法相。以断一切法相。真实知于一切法性。一切法性者。谓不真实无有相貌。善男子。作是观时若欲得一切智。欲得大慈大悲。欲得初禅乃至非想非非想。欲得性行乃至如来行。欲得菩萨地六通乃至阿耨多罗三藐三菩提悉能得之。是名第六力。因至处道力知真实道不真实道。坏不真道示以真道。因宿命力故知受众苦。知己不乐生死。亦教众生不乐生死坏于常见。因天眼力授人记莂断于断见。因漏尽力如来自知已得解脱。能坏众生见非如来谓真如来。见非沙门言实沙门。非婆罗门言实婆罗门。如来得阿耨多罗三藐三菩提时。得是十力一时而得。云何而说有次第耶。如来得阿耨多罗三藐三菩提时初观因果。是故初名处非处力。如是因果谁所受作。是名业力。以破业故修集禅定。为知众生谁能修集谁不修集故观诸根。根有三种。谓下中上。是名众生性。是名第五力。以知性故知心净不净。是名世界。欲知净心及不净心因缘故知至处道。如是道者断常断见。是名宿命天眼力。二见断故诸漏永尽。名漏尽力。是名次第。复有次第。如来得阿耨多罗三藐三菩提时。最初先观是处非处。次观世业。破世业故观禅解脱。及观众生能修集道不能修集故。次天眼见诸众生诸根利钝。为欲知故。余如先说。复有次第。如来得阿耨多罗三藐三菩提时。观十二因缘是处非处。十二因缘由何而出。是故观业。众生诸业或有受报。或不受报故。天眼观何等。为众生故。观法界。是名为解。法界世界无有差别。欲知难调易调故知宿命。为知受教不受教故知根利钝。知已为说八正道分。名至处道。以道力故断诸烦恼。名漏尽力。处非处力及以业力有何差别。善业恶业了知善果及以恶果。是名是处非处力。作者定受不作不受。是名知业力。为欲调伏不善业故修集禅定。调伏有二种。一者信。二者不信。是故观根信心有二种。一者信三宝。二者信摩醯首罗。是名为解脱。有三种谓下中上。是名世界力。知世界已说于世道声闻道缘觉道菩萨道佛道。是名至处道力。观诸众生善因恶因重业轻业。是名宿命力。因是知故断常断见。是名天眼。真实见故诸漏永尽。是名漏尽力。十力之性悉是智性无有差别。以境界缘故说有差别。四无所畏如常说。如来为众生说于四事。一者声闻不共法解脱。二者声闻共解脱。三者众生苦解脱。四者为众生断苦得解脱说于对治。声闻不共者。我所觉知。若言有法汝不知者。我亦不见沙门婆罗门若人若天若魔若梵如法而言不知不见。以不见故不生羞畏。我漏已尽。若言不尽。不见沙门乃至魔梵如实而言汝漏未尽。以不见故不生羞畏。我已得道。若言是道非毕竟者。我亦不见有诸沙门乃至魔梵如实而言。汝未得道是非毕竟。以不见故不生羞畏。我说障道。若言不障。我亦不见有诸沙门乃至魔梵如实而言说障非障。以不见故不生羞畏。佛所说道为诸菩萨及诸声闻。佛涅槃后集结藏时。声闻藏中除菩萨名。菩萨藏中安菩萨名。是故方等名菩萨藏。不共声闻者。谓如来三念处。如来说法至心听受。心得欢喜受诸安乐。如法而住不违佛教。佛亦不喜。修集舍心不失正念亦不放逸。如来说法有不信受违反所说。佛亦不嗔无有愁恼。修集舍心不失正念亦不放逸。如来说法或有听者。有不听者。听者不喜不听不愁。修集舍心不失正念亦不放逸。是名三念处。复有不与声闻共者。谓三不护。如来不护身口命。有阿罗汉无记业记失念心故。无记业者名突吉罗。如来已断一切无记业。何以故。常修正念故。是故如来随心而说呵责眷属。所谓驱摈粗言加之心无畏难。何以故。身口命净故。复有不与声闻共。所谓大悲如先说。如来作何事。何处作。何因缘作。云何作。何时作。如是诸事能如实知。是名念心。如来知何事者谓一切行。何处者一切世界。何因缘者为调伏众生。云何作者谓善方便。何时作者谓一切时。以是故。如来常修正念之心。如来世尊若动若眴若语若行若住若作。一切时中无烦恼习。是故说言如来永断烦恼习气。阿罗汉等则不如是。是故不与声闻共也。如来觉知三种法聚。一者得利益义聚。二者非利益义聚。三者非利益非不利益义聚。如来了了知是三聚。是故说言如来得一切智。如是等一百四十不共之法。不与声闻辟支佛共。是故名为声闻不共。菩萨行时得三十二相八十种好。然不明净。坐道树下。无师修集三十七品乃得明净。学地菩萨得金刚三昧已。次第二念得十力一切佛法乃至一切净智。悉以得故名一切智无碍智无障智净智寂静智清净智具足智。是名毕竟地。过一切菩萨行一切菩萨地。入如来地如来行得无上身。转菩萨身永断习气。住毕竟地菩萨摩诃萨睹见佛法如罗縠中视。如来世尊都无斯事。是故名净。住毕竟地菩萨见于佛法如远见色。诸佛见法如近见色。毕竟菩萨见于佛法如闇见色。诸佛见法如昼见色。毕竟菩萨如未出胎。诸佛世尊如已出者。毕竟菩萨如梦所见。诸佛世尊如觉见物。毕竟菩萨如灯不明。诸佛世尊如盛明灯。菩萨得阿耨多罗三藐三菩提已。能于一切诸佛世界施作佛事。作佛事者有九种。一一佛事能大饶益无量众生。何等为九。一者自为大丈夫事能令众生信丈夫事。二者以三十二相八十种好庄严其身。为利众生破其疑网。三者如来具足十力。具足十力故能利众生。若有问言。云何为力。则能善解破其疑心。调伏众生坏破邪见。四者如来具足四无所畏。为信三宝。为调伏众生。为破邪见。为大师子吼。五者如来具足三念处。如说而行如行而说破诸烦恼。能畜徒众能化众生。六者如来具足三不护法。为利众生为调众生。昼夜常以佛眼观察诸众生。七者如来具足大悲。为具足羼提波罗蜜。为令众生离诸苦故。为施安乐故。八者如来具足无错谬不失念心。是故无师如法而行如法而住。为利众生令调伏故。为坏众生诸放逸故。九者如来永断烦恼习气。知义法非义法非义非非义法。是故如来说于义法。离非义法非义非非义法。如来具足一百四十不共之法。如是九事能作佛事。是名如来行。是名如来地。是名如来毕竟地。何以故。为如来行如来地如来毕竟地。于无量亿那由他劫。受菩萨戒修菩提行。毕竟菩萨能教无量无边众生住毕竟地。如来一切佛法。悉为众生不自为己。声闻缘觉所有之法。但为自利少利于他。是故二乘无不共法。无上佛法终无似于声闻辟支佛法。大悲不错谬断习气。一切智五智三昧。如来具足一切不共之法。是故名为无上。此经演说菩萨禁戒。菩萨道菩萨戒果。一切菩萨行一切菩萨戒果行。是故名为菩萨地。名菩萨藏菩萨摩夷。摄取一切大乘经典无碍智经。若天若人若沙门若婆罗门。信是经典受持听说读诵书写。广说修集分别其义。见有持者供养恭敬尊重赞叹。灯烛香花伎乐供养。当知是人常为十方诸佛之所护念称说其名。得无量功德聚。何以故。菩萨戒因缘。得阿耨多罗三藐三菩提。受持读诵书写解说菩萨戒故。如来正法久住不灭。诸恶比丘渐就损减。若无菩萨戒者。诸恶比丘渐渐炽盛。如来正法不久则灭。尔时优波离白佛言。世尊。此经当名何经。优波离。是名善戒。名菩萨地。名菩萨毗尼摩夷。名如来藏。名为一切善法根本。名安乐因。名诸波罗蜜聚。尔时优波离闻佛所说欢喜礼拜。右绕而去

菩萨善戒经卷第九


菩萨善戒经一卷优波离问菩萨受戒法

    No. 1583 [cf. Nos. 1579(I, 15, J), 1581,(10), 1582(11), 1499-1561]

菩萨善戒经一卷优波离问菩萨受戒法

        宋罽宾沙门求那跋摩译

菩萨摩诃萨成就戒。成就善戒。成就利益众生戒。先当具足学优婆塞戒沙弥戒比丘戒。若言不具优婆塞戒得沙弥戒者。无有是处。不具沙弥戒得比丘戒者。亦无是处。不具如是三种戒者得菩萨戒。亦无是处。譬如重楼四级次第。不由初级至二级者。无有是处。不由二级至于三级。不由三级至四级者。亦无是处。菩萨具足三种戒已。欲受菩萨戒。应当至心以无贪着舍于一切内外之物。若不能舍不具三戒。终不能得菩萨戒也。尔时受者自观己身如观智者。尔时于寂静处礼十方佛。东向像前右膝着地。合掌而言。大德十方佛菩萨僧听。今我某甲求菩萨戒。我已具优婆塞戒乃至具智者事。是故我从十方佛菩萨僧求菩萨戒。今十方佛菩萨僧观我心。我若有不信心毁菩提心。有恶心虚诳心。莫施我戒。若其无者当施我戒。怜愍故。第二第三亦如是。至心默然住专念已。而作是言。今已施我菩萨戒。我已得菩萨戒。何以故。十方佛菩萨以他心智观我心。我有真实心。当知已施我戒。怜愍故。今我无师。十方佛菩萨为师。第二第三亦尔。尔时十方佛菩萨即作相示。当知得戒

十方佛菩萨告诸大众。破世界有某甲真实受菩萨戒。我今已施。怜愍故。今此人无师我为作师我今护念是我法弟。即起礼十方佛菩萨。是为自羯磨。若有智者以憍慢故不从受者。不得菩萨戒。若是破戒者。若智者在远方。若国土乱。若自重病。若为利益多人。若更无受处。出家在家若能舍能施。深心立愿求阿耨多罗三藐三菩提。尔时若有同菩提心同法同意能说能教善知义者。欲受戒人应往其所头面作礼。偏袒右肩右膝着地。合掌而言。大德谛听。我今从大德乞受菩萨戒大自在戒无上戒无胜戒。大德。于我不重心者。为怜愍故乞施我戒。若彼大德默然听者即应还起更整衣服。向十方三世诸佛世尊及住大地诸菩萨等。头面作礼。任己智力赞叹诸佛及诸菩萨所有功德。专念三宝在佛像前。长跪合掌作如是言。大德。我今某甲。乞受菩萨戒。大德。今当为怜愍故施菩萨戒。若彼大德默然听者。受者尔时应当至心专念三宝生欢喜心。复作是念。今我已得成就无量无边无上功德宝藏。当得菩萨所受持戒。复应一心默然而住。尔时智者语受者言。善男子谛听。法弟菩萨汝今真实是菩萨不。真实发于菩提心不。受者答言。大德。实是智者。复言。汝今具足三种戒不。答言。具足。又问。能舍内外所有物不。答言。能舍。又问。惜身财不。答言。不惜。又问。汝能从我受一切菩萨戒。摄持一切菩提道戒。利益一切诸众生戒。是戒如十方三世诸佛菩萨戒。汝能持不。答言能。第二第三亦如是。尔时智者应唱是言。十方诸佛及诸菩萨大德僧听。今某甲求我。从十方佛菩萨僧。乞受菩萨戒。已具三戒发菩提心。真实菩萨。能舍一切内外所有。不惜身命。愿十方诸佛菩萨僧。怜愍故施某甲菩萨戒。怜愍故施无量无边无上功德宝藏戒。为利益众生故。增长诸佛。菩萨法故。第二第三亦如是。尔时诸方有凉风起。智者当知十方诸佛诸菩萨僧。施是人戒已语受者言。某甲谛听。十方诸佛诸菩萨僧今施汝戒。如一切三世菩萨戒。汝当至心持。能持不。答言能。第二第三亦如是。尔时智者敬礼十方诸佛诸菩萨僧及礼佛像。礼已复唱是言。十方诸佛菩萨大德听。今某甲三说时。已从十方诸佛及菩萨得菩萨戒。说者我是。受者某甲。我为某甲证人。大师者谓十方无量诸佛菩萨僧是。小师者我身是也。师有二种。一可见。二不可见。不可见者。十方诸佛菩萨僧是。可见者。我身是。于可见不可见师边。是人得戒竟。第二第三亦如是。如是羯磨竟。羯磨竟二俱默然。尔时十方世界诸佛及诸菩萨知是相已。告诸大众。彼世界中有如是人从彼智者受菩萨戒。如是人者是我法弟。我今至心怜愍护念。以十方佛诸菩萨僧怜愍护念故。授者受者俱增善法。默然小住已。便起敬礼十方诸佛诸菩萨僧。是名菩萨受菩萨戒已。一切戒。无上戒。无边戒。功德聚戒。寂静戒。净心戒。破一切众生烦恼戒。如是戒者胜于十方一切声闻辟支佛戒。何以故。度脱一切诸众生故。菩萨受菩萨戒已。应当学读菩萨法藏菩萨摩夷。菩萨欲受菩萨戒时。先当观察。若不信者不应从受。悭者贪者。不知足者。破戒污戒不敬重戒。喜贪嗔者。无忍辱者。不能为他遮罪咎者。懈怠懒堕贪受世乐乐说世事。乃至不能一念之顷念于三宝。疑网痴闇。不能读诵菩萨法藏菩萨摩夷及生诽谤。如是之人不应从受。既受戒已不应向彼不信者说。乃至不向谤大乘者说。何以故。若不信者以是因缘堕地狱故。是故菩萨不应向说。若说得罪。菩萨定知向彼说能破彼人恶口恶业及不信心说则无罪。菩萨既受菩萨戒已。师应为说犯非犯法。若知至心能受。不为供养故受。不为效他故受。不为憍慢故受。尔时是师便应为说犯非犯法。某甲谛听。菩萨戒者。有八重法。四重如先。菩萨若为贪利养故自赞其身。得菩萨戒住菩萨地。是名菩萨第五重法

若有贫穷受苦恼者。及以病人来从乞索。菩萨贪惜不施乃至一钱之物。有求法者吝惜不施乃至一偈。是名菩萨第六重法

菩萨若嗔不应加恶。若以手打或杖或石恶声骂辱。或时无力不能打骂心怀嗔忿。若为他人之所打骂。前人求悔不受其忏。故怀嗔恨增长不息心不净者。是名菩萨第七重法。菩萨若有同师同学诽谤。菩萨方等法藏受学顶戴相似非法者不应共住。若定知已不得向人赞叹其德。是名菩萨。第八重法。菩萨有二种。一者在家。二者出家。在家六重。出家八重。是八重法菩萨若犯。一一重法若具足犯。现在不能庄严无量无上菩提。现在不能令心寂静。是则名为名字菩萨。非义菩萨。是名菩萨旃陀罗也。不名沙门。非婆罗门。不能正向阿耨多罗三藐三菩提。菩萨心有三种下中上。若后四重下中心犯不名为犯。若以上心恶心犯者是名为犯。上者所谓乐作如是四事。心无惭愧不知忏悔。不见犯罪赞破戒者。是名上恶心犯。菩萨虽犯如是四重。终不失于菩萨戒也。如比丘犯四重失波罗提木叉戒。菩萨若犯比丘四重。亦失波罗提木叉戒。污菩萨戒。污者现在不能庄严菩提。不得无量福德三昧。是名为污。有二因缘失菩萨戒。一者退菩提心。二者得上恶心。离是二缘乃至他世地狱畜生饿鬼之中。终不失于菩萨戒也。菩萨戒者。不同波罗提木叉戒。菩萨若于后世更受菩萨戒时不名新得。名为开示莹净。今当更说受菩萨戒是犯非犯轻重之相上中下异。菩萨若受菩萨戒已。若于昼夜塔像经卷。读诵之人千万菩萨。不以华香供养礼拜。不能赞叹。心不欢喜乃至一念。是名犯重不名八重。是名菩萨污心疑心。有创堕落起不净心。若有所作无恭敬心。不信故懈怠故。是名犯重不名八重。若无念心是名犯轻。不犯者。若有净心常求菩提。净心者。如须陀洹所有四信

菩萨若不知足不少欲贪着利养。是名犯重不名八重。不犯者。若能定知以不知足能调众生

菩萨若见上座宿德同学同师。生憍慢心及以恶心。不起承迎礼拜设座。不共语言先意问讯。若问所疑不为解说。是名犯重不名八重。是名菩萨污心疑心。有创堕落不起不净有所作不犯者。若病若眠若乱心时。若至心听法供养佛时。写经读诵解说论义共先客语。护说者心知不与语。能令调伏防僧制故。护多人故

若比丘为求罪过听菩萨戒。不信受者。不信教者。及不成就优婆塞戒。不成就沙弥戒。不成就波罗提木叉戒者。不得听菩萨戒。听者得罪。若比丘犯波夜提罪。不惭愧不生悔听菩萨戒者。得偷罗遮罪。若比丘犯偷罗遮罪。不惭愧不生悔听菩萨戒者。得僧伽婆尸沙罪。若比丘犯僧伽婆尸沙罪。不惭愧不生悔听菩萨戒者。得波罗夷罪。谓第八重若有说者。得僧伽婆尸沙。是故经中作如是言。不信者不应听。不信者不应说

有笃信檀越来请菩萨。若自舍若塔寺。若村落若国土。供给所须衣服饮食卧具医药。菩萨憍慢嗔恨轻贱不往受者得罪。是罪因烦恼犯

若菩萨无伴独行至白衣家。得错谬罪。若到白衣舍不能说法开示教化令其供养佛法僧宝。是名犯重不名八重。不犯者。若病若闇钝若狂若远请若道路恐难。知不受请令彼调伏。若先受请。若勤修善法时。若未闻义为欲闻故。若知请主心不真实。若受彼请恐多人嗔若僧制

若有檀越以金银真珠车磲马瑙琉璃颇梨奴婢车乘象马等物杂色敷具。奉施菩萨菩萨应受。若不受者得罪。是罪因烦恼犯。不犯者。若狂若知受已必生贪着。若知受已施主生悔。若知施主施已发狂。若知受已施主贫穷。若知是物是三宝许。若知是物是劫夺得。若知受已多得苦恼。所谓王难贼盗死亡闭系。恶声流布摈令出境。若知受已不能舍用修种福德于良福田

若有众生为解义故。欲得闻法住菩萨所咨启未闻。菩萨轻心慢心不为说者得罪。是罪因烦恼犯。不犯者。若知前人是恶邪见求觅过罪。若病若病始差若狂。若知不说令彼调伏。若佛未制。若知前人于三宝所不生敬重。若举动粗疏。若知钝根闻深义已生于邪见。若忍邪见。若知闻已转向恶人宣说其事破坏正法

若有恶人能作杀害及旃陀罗。菩萨若不亲近往返为说正法者得罪。何以故。菩萨若见持戒精进身口意净不生慈悲若见恶人能生慈悲。是故菩萨若不为说则得犯罪。不犯者若狂若王制若僧制。若虑多人嫌若知不说令彼调伏

若有檀越非亲里。若长者若婆罗门以种种衣奉施菩萨菩萨应受。若菩萨自求多得亦应受之。如衣钵亦如是。如衣钵线亦如是。菩萨若到檀越边求索缕线。使非亲里织师织。教令致织务令广厚。我不自着。汝与檀越俱亦有福。若檀越言。我为师故唯愿自着。菩萨得已若自为身往织师所。教令致织务使广厚。若得衣已自著者。犯重不名八重。若不教者不犯

菩萨若受菩萨戒已。应受应畜憍奢耶敷具。至百千万数金银亦尔。声闻之人但为自利。是故如来不听受畜。菩萨不尔。为利众生是故听畜。不得不受。若为知足名誉故不受者。得失意罪堕落不起。有所作有疑不净。若菩萨以懈怠因缘。不能利益诸众生者得罪。是罪因烦恼犯

若菩萨为人所赞言是十住。若阿罗汉至须陀洹少欲知足。默然受者得罪。是罪因烦恼犯。若菩萨入僧中时。见有诸人非法戏笑不呵责者得罪。不犯者。若听法时为调伏故。为随心说法故。为能利益故

若言菩萨不乐涅槃亦非不乐。不畏烦恼亦非不畏。何以故。流转生死故。若菩萨作是言得罪。何以故。菩萨乐于涅槃。声闻缘觉所不能知。声闻缘觉所乐涅槃。于菩萨乐百分千分百千万分乃至无有一分。菩萨呵责畏于烦恼。声闻缘觉所不能知。声闻缘觉呵责畏于烦恼。于菩萨呵责畏于烦恼。百分千分百千万分乃至无有一分。何以故。声闻缘觉但为自利不能利他。菩萨不尔自利利他故。菩萨虽行有漏故胜罗汉。终日处漏烦恼不污。是故得罪

若菩萨不畏恶声不护恶声得失意罪。若他无恶横称他恶者得犯恶罪。是罪因烦恼犯。若为调伏加之恶语者。得失意罪。非是恶罪。不犯者。若呵外道诈来现受菩萨戒者。若心本无恶口出恶言。若颠狂者。若知呵责有大利益。若知嗔彼彼得利益。若为护戒不生嗔者得罪。若知嗔彼得现少利无他世大利。若菩萨打者报打。骂者报骂。恼者报恼。得失意罪。是罪因烦恼犯

若有菩萨共相讥呵。若实不实菩萨即应谦下归谢。若不能者得罪。不受归谢是亦得罪。以放逸故。不归谢者得罪。以放逸故。不受归谢者得罪。不犯者。若知彼人由来弊恶常来求人短若知不受令彼破恶

若菩萨于他嗔恨常生念言。我若见时当打当骂。不休不息不能自调者犯罪

若菩萨与比丘尼共同一道行不犯。若有贪心得罪。不犯者。为调伏故

若菩萨从非亲里尼受食不犯。何以故。菩萨摩诃萨发菩提心已。于诸众生无非亲里。若菩萨为贪作使多畜弟子犯罪。不犯者。若为调伏。若为护法。若为利益。若无贪心

若菩萨懈怠懒惰。不勤精进乐眠卧者得罪。不犯者。若病若病差气力未足时。若远行时。若读诵疲乏时。若思惟对治时

若菩萨共谈世事无益之言得罪不犯者。若他问说。若随他心为调伏故。说时至心莫作增减

若菩萨憍慢心故。不咨问师不受师教得罪。不犯者。若病若狂若痴。若大聪明多闻有智为调众生。若入定时

若菩萨欲心起时。不观对治疾调灭者犯罪。不犯者。虽观对治烦恼力盛不能令灭。若故自试发欲心时

若菩萨言不应受声闻戒不应读声闻经。何以故。声闻经律不能利益诸众生故。若作是言犯重不名八重。不犯者。为贪着小乘经律者

若菩萨不读不诵菩萨法藏。一向读诵声闻经律得罪。不犯者。若不闻知有菩萨藏。若菩萨不读不诵如来正经。读诵世典文颂书疏者得罪。不犯者。若为论议破于邪见。若二分佛经一分外书。何以故。为知外典是虚妄法佛法真实故。为知世事故。不为世人所轻慢故

若菩萨闻菩萨藏声闻藏有不可思议事。不信不受言非佛说。若自谤若是他谤得罪。若菩萨作是言。我智力羸弱肉眼不净。不见如来甚深境界如来境界佛眼所见唯佛能知。一切法界非我所及。若能如是思惟观者。是名实行。菩萨忍与不忍二俱不犯

若菩萨生嗔慢心。自言持戒多闻智慧悉胜汝者得罪是罪因烦恼犯不犯者。若为破邪见。为破轻蔑于佛法者。若为伏彼自大心故。为未信者生信心故。已生信者得增长故。若菩萨闻说法处。乃至一由旬不往听者得罪。若轻说者不往得罪。是罪因烦恼犯。若懈怠不往者得失意罪。不犯者。若不觉不知不闻。若病若病初差气力未足。若知说者颠倒不正法。虑说者生羞愧心。若说一法更无异义。若修善法。若化众生。若不解彼说。若不能忆念

若菩萨轻说法者。不生恭敬不赞其德。嗤笑所说辞义不正者得罪

菩萨若受菩萨戒已。众生所作事务不与同者得罪。所谓去来入出拥护财物。和合斗诤作诸善事。戒施多闻不共同者得罪。不犯者。若病若不知作。若自营大事。若先许助他若自修善法。若虑多人嗔。若喜若痴若狂。若知不同能调伏彼。若僧制

菩萨若轻说法之人。骂辱打掷嗤笑所说。但依文辞不依义者得罪。是罪因烦恼犯

菩萨若受菩萨戒已。不能随从众生心者得罪。所谓行住坐卧修诸善事。菩萨若受菩萨戒已。见病苦人不能瞻养作给使者得罪。不犯者。若自病若无事力应广劝化。有事力者。若彼病者多有宗亲。若自急修无上善法。若先瞻他病。若根闇钝。如病贫穷困苦亦复如是

菩萨若受菩萨戒已。见恶众生修行恶法。不能教呵劝勉之者得失意罪。不犯者。若知是人有善知识能教呵责。若知为说不随其语。若到解语。若有害心

菩萨若受菩萨戒已。所畜之物与白衣同者得失意罪

菩萨若受菩萨戒已。不应以金银盂器受取饮食。所畜铜器不得同彼白衣。木器角器悉不听用。用者得罪。不犯者。若失本器。若行路请时。若重病

菩萨若受菩萨戒已。受恩不念得罪。是罪因烦恼犯

菩萨若受菩萨戒已。受他恩惠不能报者得罪。报者应当持戒精进坐禅读诵经典。随施主心所喜之事而以报之。不犯者。施主不受。菩萨若受菩萨戒已。见有苦人若死失物王贼水火亲属离别。应往其所说法慰喻。随其所须任力给施。若不能者犯罪。不犯者。若不得自在。若自重病。若不受语。若有疑难。若王嗔彼人。若僧制

菩萨若受菩萨戒已。若畜弟子不能从诸笃信檀越求索所须。衣食卧具医药房舍随时供给。又不随时说法教化者得罪。不犯者。若知弟子有大势力聪明福德多诸檀越。若是外道诈来盗法。若知不能增长佛法。菩萨若受菩萨戒已。应常赞叹他人善事。若隐他德者得罪。是罪因烦恼犯。不犯者。若前人遮。若乱钝不知。若重病。若虑他嫌。若难了知如庵罗果等

菩萨若受菩萨戒已。所坐床榻过八指者得罪。不犯者。若说法时。若受笃信檀越请时。若至外道祠中坐时

菩萨若受菩萨戒已。若弟子中应嗔不嗔。应呵不呵。应罚不罚。应摈不摈得罪。是罪因烦恼犯。不应嗔而嗔。不应呵而呵。不应罚而罚。不应摈而摈得罪。不犯者。若知弟子能烧塔寺作大恶事。或杀师和尚。若同师同和尚。若父母。若待时。若定了知以是因缘破坏众僧。若知后时自生惭愧

菩萨若受菩萨戒已。获大神足。见可怖者而不怖之。可生信者不令生信得罪。不犯者。若知一切信邪倒见。不信佛法

菩萨若受菩萨戒已。常至心念不作犯想。如其犯已寻应向人发露忏悔。所谓大小乘人。能善解义善宣说者。是名菩萨一切戒。从菩萨初地解六波罗蜜。至一切戒一切悉是菩萨禁戒。是名一切戒。如来先于声闻经中所未说者。今于菩萨藏摩夷中说何故名为一切戒。总说出家在家戒故。是一切戒。难戒者有三种。一者菩萨有大自在财富无量。悉能舍离受菩萨戒。是名难戒。二者菩萨。急难之时。犹不令戒有微瑕析况复毁破。是名为难戒。三者菩萨虽随众生行住坐卧。常坚持戒不令毁犯。是名难戒。一切自戒者有四种。一者受。二者性。三者修。四者方便。受者谓三羯磨。性者谓与性共俱。菩萨摩诃萨性柔软故。身口意业常善修者。于无量佛诸菩萨所修方便者。如诸菩萨以四摄法摄取众生。教令修集身口意善。是名一切自戒。善人戒者有五种。一者自持禁戒。二者教他令持。三者赞戒。四者见乐持者欢喜赞叹。五者有犯随悔心无休息。是名善人戒。一切行戒者有十三种。一者发愿回向涅槃。二者广大。三者清净。四者欢喜。五者不破。六者不牵。七者坚固。八者璎珞。九者真实。十者义。十一者信。十二者宝十三者常。如声闻地声闻禁戒一切善法。悉是阿耨多罗三藐三菩提因。是名一切行戒。除戒者有八种。菩萨常应作如是念。如我不喜死。一切众生亦复如是。是故不应杀害物命。如我不喜劫盗贪淫恶口妄语两舌无义语杖石打骂等。一切众生亦复如是。是故不应劫盗贪淫恶口妄语两舌无义。语杖石打骂。是名除戒。菩萨乃至丧失身命。终不毁坏如是八戒。自利利他戒者。菩萨于戒遮处则遮开处则开。若遮处不遮开处不开者得罪。菩萨知一切众生可摄则摄可舍则舍。身口净戒常共檀波罗蜜行。乃至共般若波罗蜜行。如是净戒自利利他。是名自利利他戒。寂静戒者。从初受戒至心坚持。为四沙门果为菩萨果不为身命。是名寂静戒。菩萨坐时见王长者起者得罪。若先加趺见王长者跪者得罪。若先衣不整见王长者。[僉*殳]容整服者得罪。若王长者说恶语时。随意称赞者得罪。不疑之处强生疑者得罪。应疑之处不生疑者得罪。菩萨戒者。初夜后夜不得眠卧。善愿善行善法具足。堪任中用正命成就。远离断常具行中道。离五欲乐无上无胜。远离邪见不破不坏。是名寂静戒。菩萨戒聚成就具足无量妙果。以是戒聚因缘故。具足尸波罗蜜。受者虽未得阿耨多罗三藐三菩提。已得具足五事功德。一者常为诸佛菩萨所念。二者受常净乐。三者临死无悔。四者舍身得生诸佛世界。五者庄严阿耨多罗三藐三菩提。受持菩萨戒者不自为身。唯为利他及庄严阿耨多罗三藐三菩提。是菩萨戒悉是过去未来现在。恒河沙等诸佛菩萨之所成就。乃至十方诸佛菩萨。亦复如是

菩萨善戒经一卷


取因假设论

    No. 1622

取因假设论一卷

        陈那菩萨造

        三藏法师义净奉　制译

论曰。为遮一性异性非有边故。大师但依假施设事。而宣法要。欲令有情方便趣入。如理作意。远离邪宗。永断烦恼。如是三边。皆有过故。我当开释。此中取因假设。略有三种。一者总聚。二者相续。三者分位差别。言总聚者。谓于一时有多法聚。随顺世间。以一性说。如身林等。言相续者。谓于异时因果不绝。以一性说。如羯罗罗等位。名之为人。芽等转异。名之为谷。言分位差别者。谓于一事有其多性。异不异时。而为建立。如色生位异无常性。有见有对。业具性故等。由此三义。密意说有补嗢揭罗。及证圆寂。然此三义。但是假设。不可说为一性异性。及总无性。有过失故。此中且辨总聚有聚。无异性言。事唯二种。为当许有。此二自性。遮其性别。谓于有聚。总聚不别。名无异耶。为但无余。说名无异。此有何过。颂曰

  若无异性体无别　　有聚更互成无异
  或于总聚别事殊　　此复便成多种体

论曰。若许手等自性与身是一名无异者。此即于身无别性故。手等更互成无差别。手便成足。违世间故。或复说彼别别支分非身自性。于聚集时说为身者。此即全无总聚自体少分可得。为异前义故置或言。若于别事非是总聚自性者。即是自性差别由别性故。于聚集时云何与彼无别自性得成应理。不由总聚舍自性故。此复便成多种体性。总聚于多无异性故。若别若总是无异性。由非总别舍自性故。若顿若渐皆成多性。望彼诸事无异性故。如是且辨二计过失。颂曰

  若言唯遮余有性　　二种非有汝成过
  若一有性是所遮　　非无别故两相似

论曰。若言唯遮余有性。二种非有汝成过者。若于有聚无别总聚名无异者。此即更互相待成无异性。若于一处有无异义。第二亦尔。云何汝得免斯过失。如无总聚。有聚亦无。若异此者。无异之言便成无用。若一有性是所遮者。纵许如是于他所执有分实事。唯遮于此名无异者。此亦不然。事无别故。两处相似由无异言。一处既尔于余亦然。如初无异言故。汝不应但遮一处若言意许唯遮彼者。应可但言无其有分。勿言无异。彼之有性是不乐故。若其许彼体性是有不许异者。说无异言方成应理。又有异义。非无别故。两相似者。如离手等更无别身。是有分故。如是手等亦待指等成。其有分手等。如身亦成。非有如是。乃至极微待于声等。声等复待萨埵等。萨埵等复待喜等。待异功能。此即分与有分同有分性故。汝所执便成非有。如是且辨许无异性。有二种过。颂曰

  异性亦尔以一边　　于支分处别别转
  一边便有无穷过　　或非是一及全无

论曰。异性亦尔者有二过。言流至于此由彼于自支分转时。或别别转。或复遍转。此中且辨别别转义。若以一边。于手等处。有分转时。彼亦一边。犹如手等。复更应有一边随起。如是展转。有无穷过。或非是一者。异无穷过故置或言。若言身分一边更不转者。此即应无一有分义便成有分唯有一边。若尔应许唯有手等。何烦党执于己支分。有分转耶。及全无者。一边无穷。及更有过故置及言。以此一边。于分转时。此即全无有分可得。由非有分如手足等。有其一边。若言有分离手等时。无别支分。有分体一故若如是者。便成于彼别支分处各各遍转。唯此二计更无第三分别执故。颂曰

  若遍彼成多种性　　及于手等互无差
  或此非彼故便成　　诸事皆同一微性

论曰。若言遍者。所许有分与支分量同。于一一处皆周遍故。彼即便成多种体性。更有异义故置及言。由于一处遍皆有故。由不许彼别处性故。及余支分更互无差。由彼和合。同一处时。事无别故。此则手处应许有足。便违世间共许道理。或此非彼者。更有异计故置或言。为避前过云有分体。于足转时非于手等有分别转此则无有。于余支分同处过者。此同捺瘿反出眼睛。若如是者。一切有分成一实事。是故诸事成一极微。由彼有分。于自支分。展转起时。乃至唯有一实极微。住处可得。此一支分。便与有分。同一极微。此有分执理成无用。及违自宗。若言离于色等。别有极微。即无如前所说之过。由彼不于色等处转故无此失。理亦不然。于此亦有二执过故。故应许此。有别方分。或无方分。若尔何过。颂曰

  有方分性非极微　　为遮一性异性故
  或无方分多不聚　　或复众同于一微

论曰。由非如是所执极微。理得成就。有方分故。由此方分。更成转细。又复彼遮一异性故。由此于彼自支分处。或同或异。唯此二种。无第三计。已斥其过。非诸极微。有方分故。既无方分。假令共聚。亦不和杂。设许同处。皆同一微。然此极微。不得和聚。一与诸微。相障碍故即诸微体。共成于一。由同处故。如是已说总聚有聚一异之过。颂曰

  相续若一舍婴孩　　渐次乃至童年位
  应失自身非不异　　若言不失便相杂

论曰。若许相续。于有续事。无异性者应许自性。有其二种。由此说为相续自性。或但遮余。此之二种同前总聚。已斥其过。于中别者。今更决择。若别别位领受之时。为舍前位。而领于后。为当不舍。斯有何过。若舍婴孩。至童年位。应失自身。汝若许此。于婴儿位。是不异者。彼移易时。自体应失。于此位中。无异性故。故汝宗云。凡诸实事。有别法起。有别法生。为转变者。无如是理。然非不异。移转位别。安危异故。言不异者。此即是彼如是且论转舍之过若不失者。法相和杂。不舍婴孩。领童年位。孩童等位。体相和杂。应成无别。然不见有如斯之事。已说不异性过。颂曰

  若是异性身不安　　为欲求安劳妄设
  转不相应及生灭　　若言体别成实事

论曰。相续有续。体若异者。诸有先病。后时求差。所有劬劳。皆成妄设。流转之理。不相应故。曾不见有别体之物。如牛马等。得相续故。若言不可说事亦不见者。此难非理。是所成立故。由离二边。于世间事。因果之处。见有斯事非于余处。又如酸酒。欲转成美。心散乱人。修令寂定。所设劬劳。并应无益。由体异故。若异性者。生灭之理。亦不相应。诸有生灭。相续起者。应于现在。支分处转过未现在。云何转耶。一分全遍。并如前破。又性异者。相续体殊。不应生灭。此复何过。若言别者。有为相异。所许相续成实事有。此不应理。次后当说相续一异。已彰其过。复次分位差别。于果性等。其事云何。颂曰

  于果性等分位处　　取彼事已施言说
  若异彼者事无体　　不异二过辨如前

论曰。于果性等。分位之处。取彼事已。而兴言说。异彼无体。谓于色等。说为因果。一异性。自他性。有见有对性等。若言彼事异于此者。此即便成非因果等。亦无自体由无一事。不待于德。于自体处可成言说。此不异性。有二种失。如前总聚已彰其过。于随有处。应可思之。若于有法。说无异性。舍不舍性。亦如前辨。或此于身相续转时。有差别性。譬如牛味。于热病者。能为止息。复能于此。为发动因。已说三种假设之事。异不异性所有过失。总拨无者。次当辨释。颂曰

  若不许身是实有　　无倒说法应无益
  又复应无邪见人　　亦无差别作用事

论曰。如于身处。颠倒说为常乐我净。无倒为说四念住法。若无身者。应成无用。又若不许有相续者。能治所治便成差别。如于余身执以为常为对治彼。便于余身为说无常。此成无用。复次若无分位差别者。说无常等法。亦为无用。又邪见人。说无施无受等。及诸总聚所有福事。应非邪见。然衣食等所有施物。皆是总聚。如有说言。风不能吹。河不流等。言无相续。亦非邪见。然非佛教。许彼风等有实业用。虽有风吹等用。然而不许彼能向余方相续生起。若无相续。皆无如是邪见之事。若无分位差别者。于一色处苦集二相拨无之时邪见差别应成非有色无别故。亦无差别作业之事。又若不许有总聚者。于毗诃罗窣堵波等。福德差殊。应皆非有。又相续别故。其福亦殊。如世尊告勇健长者曰。若有苾刍。受食食已。入无量意定。正念而住。于如是等福德差别。应成非有。若不许有分位差别者。此差别故。业用差别亦成非有。事虽不殊势力有异。其用亦别。是共许故。犹如毒药。和余物时。便为害命。疗病用故。如是等类。拨无其事。皆有过失。若有如是众过失者。何不许彼是实物有。此不应理。有过失故。何者是耶。颂曰

  由遮一性异性故　　非是展转藉因成
  自体亦是可说故　　似境唯从于识起

论曰。由于色等。是实有故。更互相望一异之性。是可说故。其总聚等。是不可说。若如是者。身望余身。云何名异。此由非是更互相因。凡诸事物。若舍于彼。而心取此者。斯则不名取因假设。由不取彼以为因故。然于身等。更互相待。若舍彼时。意不取此。此乃方名取因假设。若舍色等。无其总聚。是故应知。但于自事一异之性。是不可说。非于一切然分位差别。于异性等。更互名异。说之为假。若如是者。于色等处。亦不取故。说为异性。应非实有。理不应尔。由彼自体。是可说故。亦是可得体相别故。非于余事不弃舍故。然此似境。亦从识起。于彼所有一切境相。若离识者。即不能知所有自性。亦是假设。故无有过。如有颂言

  鬼傍生人天　　各随其所应
  同处心异故　　许境非实有

又总聚等非实物有。非是有为无为性故。一切诸法。皆是有为无为性摄。此且非是有为之相。颂曰

  相不相应非有为　　若言有说是密意
  于数取趣亦见说　　若是无为应不坏

论曰。若是有为。应如识等。有生住等有为之相。此不如是。于总聚等。二微聚时。相乃无边。有无穷过。亦非假事。有如是相。一事便有。无边相故。然于现有假施设事。聚集等时。便有生灭。可了知故。若言有说者。实有此言。说总聚等有为之相。如有颂曰

  积聚皆消散　　崇高必堕落
  合会终别离　　有命皆归死

此谓三谟诃等。说有灭相。于毗诃罗等。说有生相。虽有此说。皆是密意。非于胜义有如是相。此生等相。世人皆知。于假处有。即如其事。而为说法。此由随顺离欲事故。虽非胜义。顺清净故。为欲利益诸有情故。作如是说。佛告诸苾刍。若见女人。与母状同者。应为母想。如是等言。皆是假说。宁知生等。是密意说。非胜义耶。于补嗢揭罗。说有生等故。如有一人出现世间能多利益等。又说一切有情皆依食住。又说吾今衰老。须供侍人。一切有情皆归死等。然非于人有生等事。如是且辨。于总聚等。非有为性。若尔应许是无为性。若是无为。应不灭坏。由无为法无灭坏故。诸总聚等。应是常住。如虚空等。非总聚等。可成实事。有为无为。皆不应理。岂复世间于现事处一异性等有不可说耶。有如是说。现见世人。于衣等处。于丝缕等。不曾思量一异性等。而皆共为卖买等事。世尊为欲利益世间。方便宣说。亦不言其一性异性。颂曰

  世尊欲令断烦恼　　同彼世间可思事
  不言一性及异性　　方便说法化众生

论曰。诸佛世尊。不坏世间。如其所有。离难思事。于诸众生。随其意乐差别之性。于被缠迫随眠位中。为欲断彼诸烦恼故。宣说法要。佛告诸苾刍。汝等勿同世人作无益思虑。我说能知能见尽诸有漏。非不知见。乃至如理作意。非不如理。如是应知。如理作意是断烦恼之正因也。不如理思。能生众苦。当遣邪思。宜顺正念。颂曰

  一切义成由此本　　易为方便极难遇
  色命须臾不暂停　　智者宜应速修习

取因假设论一卷


三无性论(出无相论)

    No. 1617

三无性论卷上(出无相论)

        真谛三藏于广州制旨寺翻译

论曰。立空品中。人空已成未立法空。为显法空故。说诸法无自性品释曰。前说空品。后说无性品。欲何所为。答曰。前说空品为显人空。但除烦恼障。是别道故。后说无性品为显法空。通除一切智障及烦恼障。是通道故。复有别用。为除世间三虚妄论。一斗诤为胜论。如露伽耶鞮迦及僧佉等论。二多闻为胜论。如四韦陀及伊鞮诃婆等论。三正行为胜论。如二乘教等。今说二空除此三论。先说人空。为除前外道两论。次说法空。为除后一二乘偏执乃至外道邪执论。显真实正行。依因此行得究竟无比故。复次说人空为破邪法。说法空为立正法。若广明论用如十八部。为显此用故说斯论。此即第一明用分也

论曰。外问于何法中立此无性。应先安立是法。若说如是则无相理有所相应。实虚两境即便可见

答曰。一切诸法不出三性。一分别性。二依他性。三真实性。分别性者。谓名言所显诸法自性即似尘识分。依他性者。谓依因依缘显法自性即乱识分依因内根缘内尘起故。真实性者。谓法如如。法者即是分别依他两性。如如者即是两性无所有。分别性以无体相故无所有。依他性以无生故无所有。此二无所有皆无变异故言如如。故呼此如如为真实性。此即第二相应分。即是立名。次约此三性。说三无性。由三无性应知是一无性理。约分别者。由相无性说名无性。何以故。如所显现是相实无。是故分别性以无相为性。约依他性者。由生无性说名无性。何以故。此生由缘力成。不由自成。缘力即是分别性。分别性体既无。以无缘力故生不得立。是故依他性。以无生为性。约真实性者。由真实无性故说无性。何以故。此理是真实故。一切诸法由此理故同一无性。是故真实性。以无性为性

释曰。约真实性。由真实无性故。说无性者。此真实性更无别法。还即前两性之无。是真实性。真实是无相无生故。一切有为法。不出此分别依他两性。此二性既真实无相无生。由此理故一切诸法同一无性。此一无性。真实是无真实是有。真实无。此分别依他二有。真实有。此分别依他二无故。不可说有亦不可说无。不可说有如五尘。不可说无如免角。即是非有性非无性故名无性性。亦以无性为性名无性性。即是非安立谛。若是三性并是安立。前两性是安立世谛。体实是无安立为有故。真实性即是安立真谛。对遣二有安立二无。名为真谛。还寻此性离有离无故非安立。三无性皆非安立也。此即第三相分。明三种体相也

论曰。此三种性如是无性已说其相。今须说成立道理。分别性者无有体相。何以故。此性非五藏所摄故。若法是有不出五藏。五藏者。一相。二名。三分别。四如如。五无分别智。一相者。谓诸法品类为名句味所依止。名者。即是诸法品类中名句味也。分别者。谓三界心及心法。如如者。谓法空所显圣智境界。无分别智者。由此智故一切圣人能通达如如。此五法中前三是世谛。后二是真如。一切诸法不出此五。若分别性体是有法则应为此五摄。以不摄故故知体无也

外曰。此法若无体相。云何分别。答曰。但有名无义。何以故。如世间于义中立名。凡夫执名分别义性。谓名即义性。此为颠倒。是故但有分别无有实体。外曰。云何知此分别是虚妄执。答曰。此名及义皆是客故。所以然者。名于义中是客非义类故。义于名中亦客非名类故。外曰。云何得知两互为客。答曰。由三义故此理可知。一者先于名智不生。如世所立名。若此名即是义体性者。未闻名时则不应得义既见。未得名时先已得义。又若名即是义。得义之时即应得名。无此义故故知是客。二者一义有多名故。若名即是义性。或有一物有多种名。随多名故应有多体。若随多名即有多体。则相违法一处得立。此义证量所违。无此义故故知是客。三者名不定故。若名即是义性。名既不定义体亦应不定。何以故。或此物名目于彼物故。知名则不定物。不如此故知但是客。复次汝言。此名在于义中。在义云何。为在有义为在无义。若在有义。前三难还成。若在无义则名义俱客。此定成立。外曰。义及名非分别所作。何以故。实名能显实义故。如实有灯照实瓶等。是故名义俱非分别。答曰。是义不然。何以故。照了不平等故。若如汝言。义实有者用名显义。如灯照色。是义不成。何以故。要先得义后立名故。未得义时不得立名。既由先取义后方立名取尚不能了义。何况其名而能了耶。以灯照物。义则不尔。要因于灯故能了物。无先了物然后须灯。是故照义不平等也

释曰。言取尚不能了义者。如识先得义。次取青黄。或是非等。从取后方立名。若取能了义。则不应未取之时识已得义。是故不因于取能得了义。名在取后岂能了也。又若名能了义。余人未识名时。则不应闻名。不得其义。譬如由灯照色。此人因灯能显了色。而余人因此不能见色。无有此义。决定因照能显色故。由名显义则不如是。是故照义不平等也

论曰。外曰。若汝谓由名分别义。实无所分别义。是故名中无义。义中无名。二俱客者。是义不然。何以故。若人执名异于义义异于名。此人既无颠倒。则于义中应无僻执。不应闻说好恶生忧喜心。名义不相关故。闻好恶名即生忧喜心故。知名义相应不得是客。当知客义是汝颠倒

答曰。是义不然。何以故。由久时数习颠倒故有此僻执。不关名义相应。若人已执名异义异由名。于义亦未免僻执。何以故。由长时数习名言熏习故。必由此法门生分别心起虚妄僻执。如凡夫正见人。亦知此身但唯色等行聚。由其数习我执坚固故。于自他相续中不免人我僻执。如此名义分别是法僻执。即是颠倒增益无物故。如人我僻执故。知名义僻执。是法颠倒。既是颠倒云何生此颠倒而非系缚。是故由僻执熏习本识成于种子。能生起依他性。为未来果。此僻执即是分别性。能为未来依他因也。又因此未来依他性果。更生未来法执颠倒。即是由依他性为因。能生未来分别性为果。如此更互相因故。生死恒起相续不断。此即第四成立三性分说。分别性成立义已

别有六种差别。次说此性品类差别。然此分别性差别有六种。一者自性分别。谓分别色等诸阴体相。但以证量所取。五识但能直取五尘。乃至意识直能取法。不于一中种种分别故。名自性分别。直取体性故。二者差别分别。谓有色可见不可见等。色则可见。香味五尘非眼所见。如是随于一自性中。更种种分别不同故。称差别分别也三者觉知分别。谓见前法即识其名字能为他说。既自识名字。复能令他得识故。称觉知分别。四者随眠分别。谓见前物不识名字。不能宣说故。称随眠分别。五者加行分别。又有五种。一随爱分别。二憎忆分别。三和合分别。四远离分别。五随舍分别。由此五分别生三毒烦恼故称加行。合此五就前四。并是约义分别。六名分别又有二种。一有名字。二无名字。有名字。谓此物实如是。或色乃至及识。或有为无为有常无常善恶无记。如是等执皆有名字分别。无名字者。谓此何物为。此云何。何所以。云何如此。此四句分别。初一觅体性。次一求因。谓何因缘故有如此。三觅体差别。四求因差别。此四皆是无名字分别。此依名分别义自性五种。又有五种所分别自性。一依名分别义自性。二依义分别名自性。三依名分别名自性。四依义分别义自性。五依名义分别名义自性。一依名分别义自性者。谓此类是色。由色体性而得成就。乃至此类是受想行识等。由识体性。而得成就也

释曰。谓此人先未得义。前得色名闻说色相。如此有形碍可捉持有坏灭。如此等相名之为色。此人后见色体品类相貌。如昔所闻知其是色。即是由名字能分别色体性。乃至识阴亦尔。先得其名未见其体。后时得体。如昔所闻。即知是受乃至识也

论曰。二依义分别名自性者。谓此类可名为色。彼类不可名色。乃至此类可名为识。彼类不可名识。由先得义。然后分别立其名也。三依名分别名自性者。谓此色名。如人虽得其名未识此名品类。更复思量学其训释。是名依名分别名乃至识名求其所训品类亦尔。四依义分别义自性者。谓未得色名。因不定名分别色类。如人未识物名。但见物体。而分别此体异于余物。不知定是何物。不得其定名故。但名依义分别义。亦如小儿所见。未识名字。及无分别识位。所得境界如五识等。并缘义不缘名也。五依名义分别名义者。谓此类以色为体。此色即是名。如人先已识名识义后重分别。前所识名义。谓此为色体此即色名。乃至此类以识为体。此识即是名。如是等皆名依名义分别名义也。此五分别即是广前六中最初自性分别。前略明故但云自性分别。后广明故分别五种自性也。如是前六后五。皆名分别性品类差别。已说分别性品类差别竟。次说分别性功用。此分别性能分别前六后五。今为显此六五分别性功用差别。有八种分别。能作三种事类。三事类者。一戏论类。二我见我慢类。三欲等惑类。八种分别者。一自性分别。谓色等类色即色。阴等即余四阴类。即是前依名分别义等五种分别自性。及前六中最初自性。如是等皆名自性分别也。二差别分别。谓于色等类可见不可见碍无碍。如是等无量差别分别。皆依止自性分别。是名差别分别也。三聚中执一分别。谓于色所阴。执我众生命者受者。如是等名共期所立执此而起分别又于多法聚中执聚为因谓屋军车衣食饮等。如是等名。皆是共期所立。执此而起分别。是名聚中执一分别也。此两即是内外分别。前执有人后执有法

释曰。共期者。世流布所立名字。皆共期契所作。欲令同作一解也

论曰。四我分别。谓此类是有流有取。长时我执数依串习。从此僻执串习。缘身见所依止类。起虚妄分别。是名我分别也

释曰。此类是有流有取者。类即是阿梨耶识为诸惑本。有流即是无明。有取即是贪爱。过去烦恼十使以灭。不可分别为诸惑名。但总称无明能障智明故。此无明能为诸惑因。能流转生死故称有流。如数人说。流注生死故。心漏连注故。非人所持故。故说有流。取者即是有流家果。因谢过去故名有流果。来在现相续中故名为取。即是现相续中随眠贪欲种子也。若诸烦恼并在现相续中说流说取者。流即四流。取即四取。如此别说此流取等。皆不离本识故。言此类是有流取也。长时我执数依串习者。通说无始来有此流取等惑故。说长时也。我执有三种。一随眠。二上心三习气。言数者。即明随眠。我执数数执止本识。言串者。即上心。我执数数串起。言习者。即明习气。我执数数而起。随眠。上心是内烦恼。得见谛道此惑便灭。习气为久习所成。非正烦恼故。得罗汉时此犹未灭。得法如如方能稍遣。此三我执皆依本识也缘身见所依止类起虚妄分别者。明本识有二义。是三种身见所依止。一能作种子生于身见。二作身见所缘境界。令起虚妄我执正谈。缘此本识作境界起。故称我分别也

论曰。五我所分别。谓此类是有流取。长时我所执数依串习。从此僻执串习。缘我所见所依止类。起虚妄分别。是名我所分别也。所执境界义不异第四。但能分别有我执及我所执为异耳。六爱分别。谓缘可爱净类。虚妄分别。名爱分别也。七憎忆分别。谓缘可憎不净类。虚妄分别。名憎忆分别也。八非爱非憎分别。谓缘非可爱憎类。翻前二分别。名非爱非憎分别也。若略说分别。唯有两种。一分别依止。二分别境界。于八种分别中。自性及差别并辨聚中一执。此三分别能作戏论分别依止。及作戏论分别境界。何以故。依止此类。名想言所起分别。名想言所熏习分别。名戏论分别。于三类中由缘三名故。数数起行种种相貌。如是分别名为戏论。以三类为依止。三名为境界。戏论为分别体。依止境界即是分别性。戏论分别即依他性

释曰。八分别中。前三分别名为戏论。分别此三各各即为依止。即为境界。即为戏论体。何以故。于三分别中。各有能所故。能即是戏论体所中则有二谓类。及名类。即是三种义类名。即是三类种种名。是故以义为依止。以名为境界。缘此名字为法门。取于义类故。正以所取为依止。所缘为境界故。云依止此类缘名想言所起分别。云想言者。谓心想此名言说此名。故云想言。此则分别为想言所依止。今此中立想言者。并是名字。欲显名字有粗细。名则为细。想则小。粗言为最粗。是故用此三名目三分别。初自性分别。直明色等法体。此义为细故立名名。次差别分别。明体差别则小为粗故立想名。彼聚中一执分别。谓瓶屋等此最为粗故从言名也。名想言所熏习分别名戏论分别者。由缘此三名为境界起于分别。所分别即有熏习能分别义。能分别即是戏论分别。于三类中缘三名数数起行种种相貌者。明依止三类缘三名为法门。而数数生起种种相貌。分别依止境界戏论。体唯是一有三义用

论曰。次我及我所。此二分别能作身见及诸见本。能作我慢及诸慢本

释曰。此两分别例前亦应明。即为依止境界及分别体。前既已明例。自可解故。不须辨故。但明能生。后我见及作诸见本。由执有我故生诸见。我所执能作我慢本及诸慢

论曰。后爱憎对二此三分别能生欲嗔及无明等

释曰。此三分别即是三毒。是故能生一切三毒也

论曰。如是八种分别。能作三种事用品类。前三即作戏论类。次两即作我见我慢类。后三即作欲等惑类。初六种分别显摄法义。一切分别。不出此六。凡摄三义。自性及差别此二是分别依止。觉知随眠加行此三是分别体。后一名字是分别境界。是故六种摄法皆尽。觉知随眠通三性。加行唯不善。是上心惑离有五种。随爱生贪。随憎起嗔。随舍生无明。此三是烦恼体。和合远离是烦恼用。由贪故和合。由嗔故远离。由无明故通成此两。不立别能。贪是引境故和合。嗔是弃境故远离。由有无明故有引弃。是故通成二用。次依名分别义等。五种分别。为显分别依止及境界。差别依止及境界。但分别性摄后八种分别。为显三种障事。谓自性差别聚中一执。此三分别能生心烦恼。为一切智障。我及我所。此两分别能生肉烦恼。为解脱障。可爱可憎及翻前二。此三分别能生皮烦恼。为禅定障。此三烦恼即三事类。心烦恼即戏论事类。肉烦恼即我慢事类。皮烦恼即是欲等惑事类。此三事类是依他性。若略说分别。不出三种。一分别依止。二分别体。三分别境界。若说分别体。谓三界心及心法。依止及境界更无别体。以似尘义类为依止。以似尘义类之名为境界耳。次辨相惑粗重惑。若分别性起能为二惑。系缚众生。一者相惑。二者粗重惑。相惑即分别性。粗重惑即依他性。此二惑所以得立者。于依他性中。执为分别性故得立

释曰。呼分别性为相惑者。相谓相貌。说相貌为惑。能为惑缘故说为惑。但依他性是正惑。而说轻重者。分别性但是惑缘说惑故说为轻。依他性正是惑体故说粗重。由相惑故能障无分别智。不合无分别境。分别相貌故。由粗重惑正感后生得诸苦等。两必相由而有故。言二惑系缚众生也

论曰。若人不得不见此二性。从此二惑即得解脱。言不得者。谓不得分别性。此性永无有体故无所得。言不见者。谓不见依他性。依他性虽有体以心不缘相故。此性亦不。有故云不见。此性所以不得不见。由二种道。一见道二除道。由见道故分别即无。故言不得。由除道故依他性即灭。故言不见

释曰。昔由未见理故起邪分别。非有谓有呼曰邪见。由此邪见能障治道。今既见理即达昔所见非有故。云分别性。即无由此正道能除昔邪见故。云依他性。即灭昔分别依他。更无两体。今见除二道。亦一而无两也

论曰。是名分别性功用成立。分别性有四义毕。此次明成立依他性。此性体相已如前说今为成就此性故说成立道理。此性不但以言说为体。何以故。言说必有所依故。若不依乱识品类名言得立。无有是处。若不尔所依品类既无有。所说名言则不得立。若尔则无二性。无二性故则无惑品。无惑品故则有二过。一不由功用自然解脱。二则生死涅槃不可显现。由无此二过失故。是故应知决有依他性

释曰。此中言名言决有所依止。以依他性为所依。由有依他性故得立名。言若无此性则无能立。是故此中明所依品类异前。前则以分别性品类。为名言所依也

论曰。此性体相云何。答曰。唯是相类及粗重惑类。问曰。此类云何说为依他也

答曰。互为因缘共相成故。所以然者。由缘相故粗重得成。由缘粗重相类得成故。说此两类名依他性。何以故。无异体故。并名依他性约义终不同也

问曰。若尔云何此性由无生故名无生性。答曰。所以得名无生者。由他力故生。他既无体。自无能生。以无因无体。是故无生也。问曰。此性云何不知为有为无耶

答曰。此性如所分别。不如是有故不可言有。不一向是无亦不可说无。不如是有故非有。不一向无故非无。若解意者。则一切种名并皆可说。亦可说有亦可说无。亦可说亦有亦无。亦可说非有非无。皆不相违

问曰。此言有者为是物有。为假名有

答曰。具有两义故可说有。不如是有名假名有。非一向无故名物有。谓有物也

问曰。既说为有。为是俗有为是真有。答曰。皆是俗有。何以故。非无分别境界故

问曰。俗谛何相

答曰。俗谛有三相谓我说法说事说。我说者。谓我众生寿者行者人天男女等。法说者。谓色受想行识等。事说者。谓见闻生灭等。此等名为俗。俗成立此依他性类。前分别性亦有四种。一成立有。二成立体相。三成立事用。四成立差别。广明体相已如前说。具明事用。后别更说。今此中在先明有依他性。为欲显有此性故。举惑品等事用。所以事用在体相。前略举也

论曰。此性体云何。下更略说体相

问俗谛何相。下明此性差别也。七种如如甚多义生。如如中明分别依他用。因果生灭无前后义。真谛者谓七种如如。一生二相三识四依止五邪行六清净七正行。一生如如者。谓有为法无前无后。有为法者但两性摄。谓分别依他。此法无前无后。凡有三种。一约二性辨无前后。若说依他性在前无有分别性。依他不成。若说分别性在前无有依他性。分别性不成。是故二性递互相须无有前后以相生故。分别性既无依他性不有。一俱无故即是如如也。二约因果辨无前后。若因定在前。更无所因。则不成因。若无因缘。自然有因者。因则无量。若果定在前。既无有因则不成果。若无因缘。自然有果。果则无穷。是故因果无定。前后转转相望。望前则为果。望后则为因故。生死无初。如是因果体即分别依他。分别既无依他不有。即是如如也。三约生灭辨无前后。若生在前灭在后者。有二过失。一则未有老死已便得生。二则未舍此生便得彼生。若尔又有两失。一者生则无用。此既已生何用彼生。未舍报故。二者生则无穷。已生复生转转而讨。岂得有穷也。若尔复有两失。一者但生不灭。则应是常。二者若有多生是多众生。若尔则因果无有相发生义。又若恒生则无涅槃也。若灭在前生在后者。既未有生灭。何所灭。又应先涅槃后受生死。先有灭故是则解脱已还受系缚。是故生灭无有前后。亦不离分别依他故。曰如如也。二相如如者。谓人法二空。此二空相所以名如如有三义。一离戏论。戏论者。谓执真与俗或一或异等。四谤通称戏论。若执真与俗定一。则不劳修道并皆解脱。悉见真故皆是圣人。又若真俗定是一。则真不能遣俗。义既不能遣俗。俗惑不除无解脱义。但唯凡夫无有圣人也。若执真定异俗。则依俗不能通真。真即不可会无方便故。是故二空离此戏论。故名如如。二是无分别智境界。此智无颠倒。无有俗谛堪为境者。是故此智所会即是如如。三是真实性。若违此性则成生死。若顺此性则得涅槃。此性为一切法真性。故名如如。是故二。名相如如。非言相空。乃以相空为相也。三识如如者。谓一切诸行但唯是识。此识二义故称如如。一摄无倒。二无变异。摄无倒者。谓十二入等一切诸法但唯是识。离乱识外无别余法故。一切诸法皆为识摄。此义决定故称摄无倒无倒故如如。无倒如如。未是无相如如也。无变异者。明此乱识即是分别依他似尘识所显。由分别性永无故。依他性亦不有。此二无所有。即是阿摩罗识。唯有此识独无变异故称如如。前称如如。但遣十二入。小乘所辨一切诸法。唯十二入非是颠倒。今大乘义破诸入。并皆是无。唯是乱识所作故。十二入则为颠倒。唯一乱识则非颠倒故称如如。此识体犹变异。次以分别依他。遣此乱识。唯阿摩罗识是无颠倒。是无变异。是真如如也。前唯识义中亦应作此识说。先以唯一乱识遣于外境。次阿摩罗识遣于乱识故。究竟唯一净识也。四依止如如者。所谓苦谛。若谛有三。一苦类。二苦谛。三苦圣谛。苦类者。谓五取阴。依止此五说名众生。苦所依止不出此五故称苦类。苦谛者。谓不颠倒明此苦类决定违逆圣意。此义是实故名苦谛。圣人缘此决生舍离不起染着。苦圣谛者。谓苦一味。明此苦谛以无体性故空。空故无相。无相故无愿。无一法可愿求者。此约通相。辨三解脱体唯是一。一切诸法不离于此。故称一味。圣是正义。此一味无倒无变。故名圣谛。初苦类即是俗谛。次苦谛即真谛。以无颠倒是安立真谛。后一即是第一义谛。无倒无变异是非安立谛。后去三谛亦尔。五邪行如如者。所谓集谛。例苦亦三。一集类。谓六种贪爱。依六尘所起。能令生死相续不出此类。二集谛者。谓不颠倒知。此六贪爱决定能令诸有相续。真实无倒名为集谛。三集圣谛者。谓集一味不异于前四谛。同以三解脱门为一味故。六清净如如者。所谓灭谛亦有三种。一灭类者。谓四沙门果。即是见思两惑灭尽不生。是其类也。二灭谛者。谓不颠倒。此灭类决定寂静。是其谛义。三灭圣谛者。谓灭一味亦不异前。七正行如如者所谓道谛。亦有三种。一道类者。谓八圣道分。是其类也。二道谛者。谓不颠倒。此八决定能出离集。是其谛义。三道圣谛者。谓道一味亦不异前也。复次依止如如者所谓苦谛。苦谛者。所谓行苦。以无常故。无常有三义。一无有无常。谓苦分别性永无所有。此无所有是无常义。真实有此无所有名真如如。若以前无后无为无常者。此乃俗谛。不颠倒名为如如。非真如如也。二生灭无常。谓苦依他性。此依他性既非实有亦非实无。异真实性故非实有。异分别性故非实无。非实有故是灭。非实无故是生。如此生灭是无常义。而生非实生灭非实灭。是真如如。三离不离无常。谓苦真实性。此性道前未离垢。道后则离垢。约位不定故说无常。体不变异名为如如。复次邪行如如者。所谓集谛。集谛者。谓真似两集。真集者。谓诸烦恼能令五阴相续是有。似集者。谓诸业能得诸道差别。集有三种。一熏习集。谓分别性类惑能熏起集。何以故。由分别类惑能作集家因。二发起集。谓烦恼及业。何以故。由此生起成故

释曰。此发起集即是依他性。依他性体即是烦恼及业。由此性能生起未来五阴自体。又为分别性。所生即是自生。生他故名发起集也

论曰。三不相离集。谓集如如。此如如体未离障说名集。何以故。此如如是集家性故。集所障故。说集如如。此三即三无性故名如如。复次清净如如者所谓灭谛。亦有三义。一体相无生灭。谓分别类惑本无体相故名为灭。二能执无生灭。谓但乱识类惑由因由缘本无有生故名为灭。三垢净二灭。谓本来清净无垢清净。约分别性说本来无垢。约依他性说无垢清净。何以故。此性有体则能染污。由道除垢故得清净。本来清净即是道前道中。无垢清净即是道后。此二清净亦名二种涅槃。前即非择灭自性本有非智慧所得。后即择灭修道所得。约前故说本有。约后故说始有。始显名始有。故名清净如如。复次正行如如者所谓道谛。亦有三义。一知道。谓约分别性。此性无体。但应须知无有可灭。故名知道。二除道。约依他性。此性有体。是故应知是烦恼。类所以须灭。故名除道。三证得道。约真实性。此性是二空故。应知除灭故应得。故名正行如如也。此七种真谛体。即三无性故通名如如。于此七中。前三种是非安立谛。何以故。此三但有别名无别体故。生如如所以在先者。为可除灭故。相如如所以居次者同。是生家灭故。识如如所以在后者。是灭家方便故。后四如如是安立谛。何以故。此四约用立名用有四故。不约体立名体唯一味故。依止所以最先者应知见故。二义应知一所知境多。二但应须知无更余义。所知境多者。于苦谛中有无常苦空无我四种义故。所余集等三谛但有四名无四义异。何以故。集谛但因义为实。灭谛但以寂静为实。道谛但以出离为实。所余有缘等九义皆是假名。二但应须知无更余义者。苦是业果报非烦恼故不可除。非胜德故不须证。非正行故不须修。但为厌离所以须知。是故更无断证修等义也。若知此即能灭除诸惑。是故邪行在第二。由惑灭故证得清净。故清净在第三。由证得清净具足故正行圆满。何以故。道有三用。一见真实义。二除恶法。三能至寂静。此三若具足则道用圆满。故说正行在第四也。此七如如即是真实性

三无性论卷上三无性论卷下(出无相论)

        真谛三藏于广州制旨寺翻译

问曰。此七云何入真实性摄

答曰。此七如如是可赞最极二智境界故。二智者。即是如量如理智。此智是无流过凡夫故。可赞出二乘故。最极又是菩萨智故。可赞是佛智故。最极此显无倒义。是无倒智境界故。复次无戏论故名为真实。无戏论者于相等离一异虚妄故。相等者谓相名分别。正智等四摄。即是五法藏中四法藏也。云何不可说一异。皆有过失故。若真如异相等有三过失。一者此真如。则非相等实体。二者修观行人。则不依相等为方便得通达真如。三者觉真如已。则应未达相等诸法。不相关故也

若真如与相等是一。亦有三过。一者真如既无差别。相等亦应无有差别。二者若见相等即见真如。三者若见真如不能清净。如见相等则无有圣人无得解脱。无有涅槃世出世异。是故由离一异等或戏论故无变异。无变异故即是真实性也

问曰。此性若离一异者。为有为无

答曰。此性不可说无。若无此性者。一切种清净不可得。何以故。相结成真实故。是故不得无此性也。一切种即如理如量智。相结即是分别性依他性也。复次此性实有。由清净境界故。何以故。若心缘此境。即得清净故。复次此性实有故名常住。清净境界故名为善。常住故名为乐。真实无性故说无性。何以故。此性是一切戏论法真实体性故。离有离无故名无真性。此真实性是极智境故。离戏论故。是故应知真实性也。次于依他中。约别道理。分别真实无性。若于真实性中。则具得说真实及无性两义何以故。体是真实是无性故。若于依他分别两性中。则但得说无性。不得说真实。何以故。分别依他非真实故两体是无性。若不无性则分别依他成真实有。若说分别依他是真实。则无无性义。是故不得具说真实无性两义也。若说无性真实性义可然。若说依他分别真实无性。此即不可。真实之名滥分别依他故

问曰。经中说有五相一名言相。二所言相。三名义相。四执着相。五非执着相

又说三相。谓分别相依他相真实相。此二处相摄云何为五摄三。为三摄五

答曰。今约三相分别五相。应知五相中前二相。通为三相所摄。第三相偏为分别相摄。第四相但为依他相摄。第五相唯为真实相摄

释曰。初二相所以通为三相所摄者。初名言相。即是诸法名字及说。此名言是识所作。识似名言相起即是分别性。能分别识即依他性。所分别名言既无所有。能分别识亦无所有。即是真实性。是故初相即三性摄。第二相亦三性摄者。所言相即是名言所目义。谓一切诸物亦是识所作。但识有似物相起即是分别性。能分别识即是依他性。亦二俱无所有。即是真实性。第三相但为分别性所摄者。此名义相应相。谓为物立名。令与物相应。因名得显物。此名义实无所有。无相义故。但是分别性。第四相但为依他性摄者。此执著名义二相。辨其能执故但是依他性。不明所执故非分别。前但出所分别不出能分别故非依他。第五相唯为真性所摄者。此不执著名义二相。即是境智无差别阿摩罗识故。第四第三亦不离真实性。但其所立正为偏显一义耳

论曰。分别各有五种事用。复次此三性应知一一性中皆有五事分别性具。五事用者。一能生依他性。二于依他性中能立名言。三能起人法两执。四能成立二执粗重。五能作入真实性依止事

释曰。初即能生义体。次能生义上名言。第三即能生起人法二相。第四即能生烦恼。第五即能解脱。前三明能作起惑得解方便。第四正明起惑。第五明得解。有此次第者。必有体故立名言由有名言故所以起人法两执。由人法两执故增长起诸烦恼。前唯起人法两执。此则轻微。由此后起无量惑。由此以后久久轮转方能依止。此分别依他得入真实性故得解脱也

论曰。依他性五事者。一生成烦恼体。二能为分别真实两性依止。三能起人法两执名言依止。四能为人法两执粗重依止。五能为入真实性依止

释曰。一生成烦恼体者。谓依他性有体。异于分别性无体故。能为烦恼体也。二能为分别真实二性依止者。谓依他性执为人法我者。即为分别性作依止。若知依他性由分别起。分别既无性相故。依他性不生。不生故即为真实性依止也。三能起人法两执名言依止者。谓名言必有所依。依他性起故言能起人法两执名言依止也。四能为人法两执粗重依止者谓能生上。心粗重人法两执也。五能为入真实性依止者。谓依他性不生。即知分别无相。为入真实性方便也。亦得言前解分别性无相。即达依他无生。为入真实性依止也。夫入真实性。初在闻思慧中。必须具解分别性无相依他性无生。然后见真实性

论曰。约前分别依他有五事。合成十种。所以然者。能为二性五事对治依止缘缘。三乘圣道是能对治。能除前二性五事故。能除前分别性五事者。一由观分别性无相故。依他性不生。二由依他不生故名言则无依。三由名不起故。人法两执则不得生。四由两执不生。相类及粗重二惑则不起。五由二惑不起故即是见真。不劳更修方便。入真实性也。由得圣道故分别性五事永不复起也。除依他五事者。一由圣道故。依他烦恼体除灭。二由体灭故。不作分别及真实两性依止。三由体无故。不能为人法两执名言依止。四由体无故。不能为两执粗重上心依止。五已见真如故。不劳更觅。入分别性依止也

释曰。依止处缘缘者。于无分别境智中。说智为依止。说境为缘缘。即是佛菩萨转依义故。名依止缘缘

论曰。问曰。立空品中破人我执。此品中破法我。此两执并从何因生

答曰。人我执从法我执生。何以故。此人我执要由上心。人我执灭后方能觉了诸法故

释曰。身见人未能见诸阴故于诸阴上横计人我及我所。若得人我及所空时。始不见我及所。方能觉了但是诸阴法。由觉了诸法故法我即灭。觉了法者。谓见分别无相依他无生真实无性也。以法执灭故随眠我见悉灭。故知人我执从法我执生

论曰。问曰。云何未灭人法两执立不净品。两执灭已方立净品

答曰。于依他性中执我。是分别性之所熏习。名不净品。若于依他中。修真实性之所熏习。名为净品。若说不净品谓有流界。若说净品谓无流界。此无流界以转依为体也。此转依不可思惟。复有二种。言转依者。约位有五种。一者一分转依。谓二乘人依我见我爱灭故。无流相续异于凡夫。所以名转回转。异前凡夫所依有流也。二者具分转依。谓初地菩萨具得人法两空也。三者有动转依。谓七地已还有出入观故名之为动。四者有用转依。谓十地已还事未办故。不舍功用故名有用。五者究竟转依。谓如来地至得圆满故名究竟。是名转依也。言不可思惟者。自有四种。一者成就不可思惟。谓一切惑一切苦不能违害。一向清净常住无变故。名成就也。二者自性不可思惟。谓此转依即色为自性。离色为自性。皆不可思惟。如是乃至识及六入四大三界六道十方等。若即若离皆不可思惟。如佛性中广解。三者寂静不可思惟。谓此转依于乐住中不可思惟。于静住中不可思惟。如是乃至有心住无心住圣住天住梵住佛住等皆不可思惟也。四者功德不可思惟。谓此转依略说如来功德有六种。一圆满。二无垢。三无动。四无等。五利他为事。六胜能

释曰。八住中。一乐住者。谓三禅以还也。二静住者。四禅以上也。三有心住者。谓有心定也。四无心住者。谓无想定及灭尽定也。五圣住者。谓一切无流观也。六天住者。谓初禅至非想也。七梵住者。梵言无量。谓四无量定也。八佛住者。谓佛不住生死不住涅槃。住无住处涅槃也

论曰。有四种道。能得转依。何等为四。一四圣行。二四种寻思。三四种如实知。四四种境界。初四圣行者。一波罗蜜。谓十波罗蜜。总说为一波罗蜜行。趣向大乘故。此明利他因亦名缘因缘。波罗蜜义如中边论障品释也二道行。谓三十七品。总说为助道行。能觉了境界真实义故。此名自利因。亦名缘广明道品。如中边论修对治品说也。三神通行。谓六神通。总说为一神通行。能令受化众生归向尊重入真理故。此六通即是三轮。一身通。即身通轮。能轻举远至转变隐显。令众生起归向心。二记心轮谓天眼天耳他心能见彼。思惟觉观如实记说令起尊重。三正教轮。即流尽通。令离苦断集证灭修道。宿命一通通有后两轮也。四成熟众生行。谓四摄法。总说为一成熟众生行。此明为已入理众生。更以财法两施摄令成熟。财摄者是利益方便为令成熟。法摄者觉悟起行随顺方便为令成熟

释曰。布施摄令其成熟。成熟者逐位浅深也。爱语摄令其觉悟。利行摄令其起行。同利摄令其随顺

论曰。复次此四摄约五种摄。名为摄类。五者。一摄成自家。谓以财施摄怨中人。令舍憎恚成己亲属。故名一家。二令受教摄。谓以爱语摄自家人令受正教。三起正勤摄。谓以利行摄受教人。未起正行令如理勤行。四成熟善摄。谓重以利行摄正行者。令未舍令舍。未得令得。五解脱善摄。谓以同利摄第四人。令解脱惑障及一切智障

释曰。解脱惑障即二乘人。脱一切智障即大乘佛菩萨也

论曰。第二四种寻思者。一寻思名言。二寻思义类。三寻思自性假。四寻思差别假。一寻思名言者。诸菩萨于名中寻思。但见名言不见名体。何以故。名本能显色等诸义。此色等义约相约生。既不成就。此名则无所显。名既不能显义。与不名何异。故名不成名。而此名与色等类。为同为异。若同者。色等既无。名亦同无。若异者。世界则无如兔角等。何以故。有物不出分别依他二性故。是菩萨寻思。闻名言不见名体。此言体者。即指名为体也。二寻思义类者。谓菩萨寻思义类。但见唯类不见余义。何以故。菩萨寻思于义。此义如所显不如是有。但有乱识无名无相。名为见类。此类所缘既无。能缘不起故。菩萨寻思义类。但见无相无生真实义类也

释曰。寻思义类者。所言义者如五阴中各有别义。为名所显名之为义。如色以对眼为义也。所言类者。若指色等气类亦得名类。今则不尔。菩萨观此五阴是分别所作。但是乱识即名识类。若始终作语。正取此乱识家无名无相。名之为类。此类是所缘既无。能缘不起。故云菩萨寻思此类但见无相无生真实义类也

论曰。三寻思自性假者。谓菩萨寻思自性。但见唯假不见余物。何以故。此色等自性假名。于乱识中不可安立。无相无名故。于真实性亦不可安立。离相离生故。此假名者。但加增所作法。体无增无减故。菩萨寻思但见自性假。不见自性也

释曰。寻思自性假者。安立五阴名为自性。菩萨寻思惟见自性家假。不见自性。故言不见余物。余物即是自性也。何以故下。释此色阴等假名。于乱识中不可安立。即是不可安立分别故。言离相离生。离相者离分别性。离生者离依他性也。此假名但增一加所作者。若究寻阴体。唯一如如体无增减。若立为乱识。已是一重增加。就乱识中更复分别立为五阴。复是两重增加。菩萨寻思。惟见自性家假。不见假家自性也

论曰。四寻思差别假者。谓菩萨寻思。但见差别假不见余物。何以故。此假无名无相故。无相无生故。菩萨观名类相貌异亦见不异见异者谓名义俱客。不异者如十无倒中。解名句味有义无义。无倒中释也

释曰。差别假者。于五阴中更复分别立诸法名。如于色阴中开为根大等。菩萨寻思。唯见差别家假。不见假家差别。故言不见物。何以故下。释此差别。若指乱识为差别。即无名无相。若以真实性为差别。则体是无相也。菩萨观名类相貌异亦见不异。言名类者。名是能显。类是所显义类也。若名类互不相是。是名为客。此则为异。亦见不异者。如十无倒中解。若名与义相应。说依次第数数修习。此名即能显类。名为不异也。又菩萨寻思。名类若异者。一切世间法不出此名类。菩萨已各寻思。名不成名。类不成类。此二根本既不成就。合为自性亦不成就。就二自性中离为差别亦不成就

论曰。故论云。菩萨见名类异亦见不异。见异者约离名类不同。见不异者约自性及差别合。名类所成故。此四种是菩萨所寻思境界也

释曰。境界不出四种。一名二类三自性四差别。名但分别性。类及自性差别。寄通二性也。名本名类。类既不成名亦不立。合此名类以为自性。自性亦不立。离此自性以为差别。差别亦不成。依他不立也

论曰。第三四种如实智者。一寻思名得如实智。二寻思类得如实智。三寻思自性得如实智。四寻思差别得如实智。一寻思名得如实智者。菩萨寻思名。但得名不得名体。菩萨如实知此名世间于类中安立。此名凡为三义。一为想。二为见。三为说。于色等类中。世间若不立色等名者。则无人能想此物名色。若不能想则不能起增益见执。若无见无执则不能宣说。以是义故世间立名菩萨如实知此名。是名寻思名得如实智也

释曰。如实知此名者。有两种如实知。一约世间如实知。为三义故立名。二约出世如实观。此名约类故起。类不可得故名亦不可得也

论曰。二寻思类得如实智者。菩萨寻思义类。离一切言说。不可言说。见色等类离一切言说者。菩萨观依他类。但乱识不见分别性故。云离一切言说也。不可言说者。寻此乱识由分别起。分别既无乱识亦灭。即是真如绝于言语。故云不可言说。是名菩萨寻思义类得如实智也。三寻思自性得如实智者。菩萨于色等类。寻思自性假。此类无有自性。由自性假似有自性。菩萨如实见此自性。如幻化影响水月像等。体实非有而似有显现。如此等寻思自性得如实智。以甚深义为境。何以故。俱遣名类一时空故

释曰。前一寻思但遣于名此则为浅。第二寻思次遣于类可得居中。今第三寻思能名类俱遣。故言甚深义为境也

论曰。四寻思差别得如实智者。菩萨寻思差别假。于色等类中见差别假无二。何以故。此色等类非有非无故。如所言体不成就故非有。由不可言为体决成就故非无。由真谛故无色。由俗谛故非无色。于中假说色故。如有非有如色非色。如是可见不可见有碍无碍。诸余差别道理应知。菩萨若知此假离有离无二性。是名寻思义差别得如实智也。是名寻思得四种如实智在闻思慧中也。第四四种境界者。一遍满境界。二治行境界。三胜智境界。四净惑境界。遍满境界者。复有四种。一有分别相。二无分别相。三种类究竟。四正事成就。有分别相及无分别相者。谓境界类。亦名等分。是静定位。境即毗钵舍那缘缘也。境界类者。所谓唯识。何以故。一切世出世境不过唯识。是如量境界故。由此如量是故遍满。亦名等分者。此唯识由外境成。外境既无唯识亦无。境无相识无生。是一切诸法平等通以如理故。故名等分。称为遍满也。是静定境界者。过凡夫二乘所得定故名为静。非散心所缘境故名为定。若菩萨入甚深观方见此理。故言静定位境也。此中若毗钵舍那胜立名分别。若奢摩他胜立名无分别。此言分别者。非分别性但说无分别智名分别。第三种类究竟者。于前分别无分别境。如量如理二种品类。摄一切真俗究竟皆尽。故名遍满。第四正事成就者。谓菩萨诸佛转依无分别智所缘名为正事。不可更治故名成就。摄境智皆尽故名遍满境界也。第二治行境界者。自有五种。一不净观。二无量心。三因缘观。四分别界。五出入息念。初不净观者。除四种欲。谓色相貌威仪触欲也。无量心者即四无量观。除四种嗔。谓杀害逼恼嫉妒不安也。因缘观者即十二因缘观。除三世无明也。分别界者即界入观。除我我所也。出入息念者除觉观也。广解如诸义科释也。第三胜智境界者。自有五种。一阴胜智。为除聚中执一我见。阴有三义。一多谓三世不一。二异谓色等差别。三和合谓聚集一处。是故若多若异和合为一世间。说名为集。外道执我有三义。一执我常故以三世义破。二执我一以差别义破。三执我实有以和合义破。若人见此三义则于聚中不起一我执也。二者界胜智。为除执我为因。界有十八。所立界者显种子义。眼等六界是能执种子。于自类中为似分因故。如前眼等根生后眼等根也。色等六界是所执种子。于自类中生似分因故。如前色等生后色等也。眼识等六界是执种子。于自类中生似分因故。如前眼识等生后眼识等也。为除三种无明故。于身中显三种种子。三无明者。一除作者故说能执种子。二除业无明故说所执种子。何以故。但是色等为所作业。离色等无别业故三为除事无明故说执种子。何以故。但以眼等六识为作业事。离此识等无有别事。若人如是了别于界。则不执我为诸法生因故。界胜智能除执我为因也。三者入胜智。为除受者我执。入有十二种。所言入者。为受用入门义。何以故。眼等六根能为受用苦乐舍三受入门。色等六尘能为受用怨亲中人三想入门。所言受用者是因义。入门者是根尘。是故六根能为受用受门。六尘能为受用想门者也。此根尘更无别法名之为门。若人了达此入。则不执我为受者也

问曰。外道执我为受者何相。答曰。执别有一我能受用根尘觉知苦乐等故。佛破此受者。明藉内根外尘能作因缘。受用于受觉知苦乐也。四者缘生胜智。为除执我为作者见。缘生有十二种。谓无明乃至老死。缘生有两义。亦有三义。两者一不增二不减。谓于因果及事三种。不增不减也。三义者。谓无常无事有能。此三为因缘相。增因者。谓执常住法为行等因。乃至一切不平等因。谓微尘自性自在天等。能生于行乃至老死。是名增因。言不平等者。彼执因常果无常因不从他生但能生果。因果不相似故不平等也。减因者。谓执诸行自然而有不从因生是名减因。通名增减者。若论因用。决须无常无事有能三种不可增减。若外道执别有常等法乃至微尘能为行因。长此三义故名为增。又外道执行等自然而有不从因生。则三义顿阙。是名减因增果者。谓执行等本来有体缘无明等生。是名增果。减果者。谓执无有行等从无明等生。是名减果。增事者。谓执无明等由别有功用异于无明亦异于行别有此用故。无明方能生行等。是名增事。减事者。谓执无明等无有功能能生行等。何以故。但由无明在故说名行因不由功能。是名减事若离此三处增减是名无增无减十二缘生也。问曰。何故但据行由因生不由因生。不说无明由因等耶

答曰。行既有因故偏言此行义至无明也。无常无事有能为因缘相者。无常者。谓法未有有已有灭。若以此为因。能破不平等因及无因执。何以故。未有有者破无因执。已有灭者破常因执。故此无常名为有因及平等因也。无事者。谓一切有法同类因聚集。从此聚集先未有果而今得生。此同类因唯有聚集。能生后果无别功用。是名无事。以此为因。破别有事执。所言同类者。谓因果相似。因无常故果亦无常也。有能者。由此有故彼有。由此生故彼生。然彼有彼生。彼由此不由自不由他。决定由此故故此于彼决有功能。是名有能。如此无明生彼行等。行不自生。由无明生故。言彼由此不由自也。不由自在等生故。言不由他也。由此有故彼有。破无因执。由此生故彼生。破常因执。常法无生故。由此有故彼有。此生故彼生。故知此于彼不作别事。即破有别事执。离此彼不成故。此于彼不无。任运功能即破无功能执。若人得此胜智。即除作者我执也。五处非处胜智者。为除我自在执。所言处非处者。谓系属他不自在为义。是所系属说名为处非所系属。说名非处。处非处有七种。一非爱。二爱。三清净。四同生。五增上。六至得。七行众生系属。此七处不得自在也。一非爱者。谓众生系属恶道。二爱者。谓众生系属善业。虽不属生善道而必生善道。三清净者。谓众生未修七觉不除五盖。则不能得尽于苦边系属烦恼。于清净法不得自在也。四同生者。谓二如来与转轮王。决不得一时同一处生。于同生不得自在系属。无等生故。五增上者。谓女人不得作转轮王。系属自在故。六至得者。谓女人不得作缘觉及佛。是所至得系属大丈夫。故七行者。谓具正见人不作杀等恶行。但凡夫能作。何以故。系属见谛故。此七略说有三系属。谓业惑生。初两系属业。次一系属惑。后四系属生。若人了达此七处非处者。即能除我自在执。故名处非处胜智。此五名为胜智境界也。胜智者。即是人空智也。此五法门。为显五种人我空义也

第四净惑境界者有二种。一世间道境界。二出世道境界。世间道境界复有二种。一者下地有三相。谓粗动忧逼厚障。二者上地亦有三相。谓寂静微妙远离也。二出世道境界亦有二种。一为离烦恼障修四谛观。二为离一切智障修非安立谛观。此二境界能除三障。前观世间道境界。除凡夫障即皮烦恼。次观四谛。除二乘障即肉烦恼。后观非安立谛。除菩萨障即心烦恼。故名净惑境界也。如此所明圣行。四寻思。四如实智。四境界。由此四道能得转依也。复有三种转依者。三乘转依。二乘者。且约声闻自有二种。一一向寂静。二回向菩提

问曰。尽后生人。云何受得无上菩提。答曰。住于化身修菩提道。非住报身也。声闻转依。背于生死修无流道。独觉亦尔。并修习所得。菩萨转依者。由修正方便。及依止无二智。正方便何。自有五种。一通达无上法界。即般若以如如为境。二遍满法界。即大悲缘一切众生为境。三正勤功用。自有二种。一伏惑摄惑。二修智伏智。伏惑者。为异凡夫。若惑多不能自利。何况利他。故勤伏惑。摄惑者。为异二乘。若无惑人一向涅槃。则不能成熟佛法教化众生。是故菩萨勤摄留惑。修智者。为异凡夫。若无智人。则被染污入于生死。故勤修智。伏智者。为异二乘。若修偏智。则舍生死不能自利利他。故起正勤伏二乘智。是名正勤差别功用也。四由观众生事灭除生死者。若菩萨但观自利灭除生死。则同二乘。若菩萨但观众生不灭除生死。则同世间凡夫父母等。若翻此两行。则通能自他俱利。是名观众生事也。五为求无比无上智。无比者谓如来智。此智非有为以真如为体故。非无为以知见为体故

释曰。非无为知见为体故者。异于小乘教佛入涅槃后无复知见无所为作也。无上智者。于信比证至四智中最究竟故。故菩萨方便异于二乘。此五方便即有五意。第一方便真谛为体。第二方便俗谛为体。此二并据境能生智取。能生之境为方便体也。第三方便正行为体。第四方便共利为体。第五方便依止为体。虽有五意亦不出四义。前两是方便缘缘。次一是正方便。第四是方便果。由此方便得自他两利故。第五是方便依止。亦名为因因。依此智方便得成故。依止无二智者。在因位中于生死涅槃二处无碍。何以故。由爱众生不爱生死故。在果位中入涅槃有更起心。如小乘说佛入无心定还更起心也。此智于因果两位。无著不着。无在不在无著不著者。异凡夫二乘故。不着生死涅槃。无在不在者。据于果地。二乘所在有余无余涅槃涅槃故不在有更起心故非不在是故应知佛智无等。何以故。余人智者或着生死或着涅槃。佛则不尔。此智能利益一切众生。何以故。能成就自利利他故。余人智者或但自利或不两利。以是义故。佛智不可思惟。二处不着故。为利益自他功能。为解脱涅槃不般涅槃故三无性品。究竟

三无性论卷下


摄大乘论

    No. 1592 [Nos. 1593, 1594; cf. Nos. 1595-1598]

摄大乘论卷上

        阿僧伽作

        后魏世佛陀扇多于洛阳译

大乘阿毗昙经中。对如来前为欲显发大乘义故。善住菩萨说。所谓依大乘经。明诸佛如来有十种胜妙胜语。何等为十。一者智依胜妙胜语。二者智相胜妙胜语。三者入智相胜妙胜语。四者入彼因果胜妙胜语。五者入彼修因果胜妙胜语。六者还彼行中差别增上戒胜妙胜语。七者增上心胜妙胜语。八者增上慧胜妙胜语。九者灭除胜妙胜语。十者智胜妙胜语。如是此修多罗句显发。说大乘是佛语。云何显发。如是此说中小乘经不说此十种句。唯大乘中明。所谓阿犁耶识。智依事所说有三种性。一者他性。二者妄分别性。三者成就性。以智相事故。唯记说入智相事者。谓六波罗蜜。入彼因果事者。谓十菩萨地还彼修彼。差别事中受菩萨戒谓增上戒。首楞严虚。空等诸三昧增上心事。说无分别智。谓增上心事说不住涅槃。灭彼果事有三种佛身。一者真身。二者报身。三者应身。彼果智事。说如是此十种句。非小乘教故唯大乘中显胜说及胜上故。是故如来依为诸菩萨说。以是义故。依大乘教故。诸佛如来说有十种胜妙胜语应知。云何复此十种相胜妙如来胜语。明显大乘是佛语。及遮小乘是非大乘。是以此十句小乘经所不说。而大乘有说。及此十句能令得大菩提善许不相违。为得一切智智故是。中说偈

  彼依智相依　　彼因及彼果
  彼三界差别　　彼果及除灭
  智及上妙乘　　至于胜进修
  彼说余处所无有　　此见胜因上菩提
  佛语说于大乘中　　十句胜说于此经

有何义故。此诸十句如是渐次说。是以菩萨从初学已。先应诸法因果依已。应于因缘善巧成。而有于诸缘生法中应相善巧成舍离。横安谤遍善巧故。菩萨如是善学故。于彼善取相中应令证学。是故令诸障中心得解脱。于后入智相行已前修行中令修得六波罗蜜。已深净身心故。是以净心所摄。六波罗蜜故。于诸十地中分别修行三阿僧祇劫。于后令满三种菩萨戒。满已令彼果涅槃及证阿耨多罗三藐三菩提。此是诸十句渐次说。然此说中一切大乘略尽。是中初说智依胜妙胜语。如来经中说。谓阿犁耶识。以阿犁耶识语故。作阿犁耶识语说。如来于大乘阿毗昙经偈中说

  无始已来性　　一切法所依
  有彼诸道差　　及令得涅槃

还彼经所说

  一切诸法家　　彼识一切种
  故说为家识　　聪明者乘此

此是经证。然复彼何故名阿犁耶识。有生法者。依彼一切诸染法作果。于彼彼亦依诸识作因故。说为阿犁耶识。或复众生依彼为我故。名阿犁耶识。彼亦名阿陀那识。此中有何证如相续解脱经中说

  阿陀那识最微深　　喻如水波于诸子
  我不为凡言说此　　莫执取以之为我

彼以何义故名阿陀那识。依一切色相故。及取一切依身事故。如是彼依诸色等根不坏者。乃至命不尽。随顺故。未来取身彼能生取身。是故彼名阿陀那识。彼亦名心。如佛所说心意识尔。是中意有二种依。近作缘事故。近灭识依。与意识作生因。第二意杂四种烦恼。常共同身见我慢爱身及无明。彼是依识所染生。若以一身所生识第二是染境界识义故。取近义故。及不分别义故明二意。是中有偈

  杂染障无明　　同法及诸五
  三昧或胜事　　说中应诚患
  无想而起我　　生顺行无穷
  近顺起我相　　一切是不成
  离染无心事　　二三是相违
  彼无一切处　　执成我等义
  心顺正义故　　常顺不相违
  一切是同行　　说无明不离

心及身第三离阿犁耶识更余处无。以是义故。释成阿犁耶识是心事随种子行。彼意及意识。以何义故。说为心种种法。种子习熏聚义故。佛以何义故。小乘经中彼心不说为阿犁耶识及阿陀那识。摄甚微细智义故。彼诸声闻不修学行一切智人智故。是故彼中间释说智。复说释成解脱故不说。诸菩萨者修行一切智人智故。为彼说此识。若不说者离彼识不得解行一切智人智。然复异名。小乘经说彼识。如增一阿含中说。喜乐阿犁耶世间。及着阿犁耶。阿犁耶所成。并求阿犁耶。灭阿犁耶故。说法时亲近正听起随顺心。许取法及次法。如来出世间时。世间说此希有法故如来出思益经中说。以此义故。小乘经亦异名。说此阿犁耶识。大僧祇增一阿含经中亦说彼为根本。如树依根住故。弥沙塞僧中亦说言。乃至世间阴不断。如是异名亦说彼识。或有时节中色及心断时。非阿犁耶识有断义。彼是种子。是故所有彼智所依阿陀那识事。心事。阿犁耶事。根本识事。乃至世间阴事。说彼阿犁耶识。此阿犁耶识转明胜。如王大道。余者复作是言。心意识是一义唯文异。然彼义不成。意及识中义有见异故。是放逸心亦应有异义成。复有余者言。如来阿含中所说。喜乐阿犁耶世间。如是等句者。谓五阴是阿犁耶。余者复言。同贪等乐受是阿犁耶识。或复言。身见是阿犁耶。然彼于阿犁耶识迷痴故。或从闻及解释故。作如是说。依小乘经教分别安故。然彼者此分别安事不成。彼愚痴故。如是分别已。阿犁耶识转胜。成如是差别说故。云何转胜明。如是彼五阴。于恶道生处一向受苦时厌成。彼既是一向厌故不成。有厌乐事。如是彼常求厌离同贪乐受者。从四禅已上无复成厌离。如是彼众生中依止事不成。身见亦同。此法中信无我者厌离成。是故此亦彼者依止不成。然阿犁耶识至内身许事受一向苦道处生者。及苦阴并求解脱者。阿犁耶识中皆自身相彼解脱。不应有从第四禅以上生者。虽有同贪乐厌离。阿犁耶识起我相爱等。如是此诸同法信无我者。虽有厌离身见。而阿犁耶识作爱自身相。如是分别阿犁耶识已。转胜明智是阿犁耶。说傍名及异名。分别安事。然复此相分别事云何得知。彼略有三种。一自相差别处。二因事差别相。三果差别相。是中阿犁耶识自相义者。依一切染等法习故。彼有生因相种子摄取义故。是中因事差别义者。还彼染等诸法中。彼阿犁耶识如是一切种子。一切时作因事现成。是中果差别者。阿犁耶识中所有。彼诸染法依。无始以来习生事。何者是习而以习名。说此有何义。依彼法同生灭故。所有彼生相事此是说。所谓如华薰胡麻。同生灭胡麻故生。彼香因事故生。或多贪欲者有贪习。贪等同生灭。有彼心故。彼因相似生。或复多闻者有多闻习。彼闻忆念已同生灭心中。彼说因相事生故。是以有此习义故。说为法器。亦名持法。如是阿犁耶识中亦如是。何者复彼阿犁耶识中染等诸法种子。为当分别住。为不分别。彼非如物分别。彼处住非不分别。然如是生彼阿犁耶识。彼生胜力故。说为一切种子。云何彼阿犁耶识及诸染法。同时见迭互作因事。所谓如灯焰及炷生烧因同时迭互作因。及如苇束迭互人捉故同时不堕地中。此亦如是。迭互作因事。应知亦如阿犁耶识诸染法作因。诸染法与阿犁耶识。如是因缘差别事。不见有余因缘。云何无分别种种习而与有分别种种诸法因成。所谓如种种色染衣已不见种种色。若彼衣浸在器中。尔时彼诸色种种差别见。非一器中故。如是阿犁耶识种种习薰习薰时虽非种种。能生果时向色器已。无量种种相现诸法种种事。此是大乘中甚微最细因缘。有二种。一者性差别二者爱不爱果差别。是中所有依此阿犁耶识生诸法者。此是性差别种种性分别现缘故。是中迷初因缘者。于阿犁耶识中或言性因事。或言本作因事。或言自在应化因事。或言自身我因相事。或言无因无缘事。第二因缘迷者。复自身计为作者食者。譬如众生盲人彼未曾见象。为彼盲人将示象。诸生盲者或捉象鼻或牙或耳或足或尾或背。彼示已问象何相或说言如犁辕。或言如杵。或言如簸箕。或言如碓臼。或言如苕帚。或言如石山。如是不通达。不知此二种因缘故无明障故如生盲。或计为性或本因或自在或自身或无因或作者。或计为食者。阿犁耶识如象。性相自体不知故。略说阿犁耶识因事及果事报识一切种子性已。是故三界中摄一切身及一切道。是故说五偈

  内外不分明　　而说相顺事
  彼一切真实　　说为六种子
  空及同诸大　　彼亦说随顺
  定而忘诸缘　　及自果将来
  彼见而无记　　或顺彼无余
  薰彼非余处　　然彼是习相
  六无有顺义　　二别相违故
  诸念无同故　　生余随顺故
  内外诸种子　　彼说为生因
  不续取尽故　　自然坏遍故

所有余六转顺识。彼一切身道处受果报。应知如中边分别论说

  一是作缘识　　第二受果报
  分别受报者　　同发诸心尔

彼诸识迭互作缘故。大乘阿毗昙修多罗有偈

  一切诸法依　　如是彼诸识
  迭互作果事　　一切及因事

若此诸识迭互作因缘果者。初因缘及彼第二因缘有何缘。谓增上缘。然此六识有几缘所生。增上念次第等缘生。是此余三种因缘。世间者至爱不爱道。及受果报者四缘成。以分别明此阿犁耶识。傍名及相复云何得知。唯是阿犁耶识如是傍名说及如是相。而非是六种转顺识尔。如是中间差别安阿犁耶识已。是故不成染净事烦恼事及业事生染事不成。世间出世间净事不成。云何烦恼染事不成。是以六识身中烦恼染习种子作事不成如是。彼眼识贪烦恼使等同生灭彼。是彼者薰有子。及非与眼识灭已。余识中间以非习。及不见习所依。既无眼识前灭。眼境中间同贪等生无故。是故过去者不成。如过业果报生。然彼眼识贪等同生故习不成。彼贪所依故。及贪不坚。非余诸识别体故。诸识同时生灭无故非自性。余性可有同生灭。如是故。非眼识贪等烦恼及使薰成。非彼识及识所薰。如眼识。如是余六转顺识等如顺释。应知所有非想以上灭已。此处生烦恼染。彼初生识彼亦无种子生同依止。彼习过无故。以生烦恼对治识。彼余一切世间识灭已。中间阿犁耶识烦恼及使种子。彼对治识中。不成于诸烦恼性解脱故。及同生灭无故。后复更生世间识故久灭无已同依彼习应离种子生中间阿犁耶识。是故中间阿犁耶识烦恼染事不成。云何业染不成。行缘识不顺义故。彼无取缘有。亦不顺故。云何生染不成。取后身身不顺义故。不入定地中灭已在中阴。念杂染意识取后身。然彼杂染意识中阴中灭已。彼以歌啰啰故。母腹中托。若唯意识托者。托已彼依力故。母腹中应有依识行。是以二种意识从母胎应有。同有故而非彼所托意识。意识事成。上以杂染身故。及随顺意识念。虽有彼意识托既休托意识。彼为一切种子。为当随彼身依行者。若随彼所托彼是一切种子者。是故唯阿犁耶识。是傍名差别安成依识尔。然若依彼故。一切种子者。彼以何依事作因识者。彼非一切种子。若所依作果事者。彼一切种子此义不成。是故此释成。所有彼托识彼非意识。是报识。彼一切种子故。以取后身以认取余色根。何者报识而认不可见上意。意识及不坚牢固。彼诸余识取色根。无非色可成。是识及灭色迭互相依。如苇束顺义故。行彼亦不成中间报识。食事义故。不成诸大。众生非报识。中间诸六识随所三界中生诸大。众生作食所见从此灭已。虽入生定。以杂染不入定。意识取后身。然彼不入定心。彼地中杂中间报识以种子不成。然生在无色界中。中间一切种子报识杂染善根觉者。无有种子。无所可依。得杂染善根心。还彼处现出世间心。诸余世间心谢已。彼行应得回生非有想非无想生者。现不用处出世间心时应得回彼二道。彼出世间识非有想非无想。至所依非有用处行所依。涅槃道所依成。欲舍身时。或造善不善。若上若下渐次依迹。灭毒得清凉。不应成中间有阿犁耶识。是故生染中间一切种子报识中不成。云何世间净事不成。如是离诸欲者。未得色界心。唯得欲界善心。于欲生厌离。然是欲界中心。后用行色界心不共同生灭。彼不薰此种子者不成。非彼色界心。过去无量生所隔。彼入定心作种子不成。既无彼已释成此所有。彼入定色界心一切种子报识久时转转来。后因缘故。是彼善行习故。彼心增上缘。如是一切厌离地行中随顺如义应知。如是世间净事中间一切种子报识不成。云何出世间净事不成。如佛所说。外闻他声音以内寂静思量。因彼事故得生正见。以闻彼声响音念故。或薰耳识。或薰意识或薰彼二。是中彼诸法寂静思惟忆念故。耳识尔时不行。意识亦余识所隔杂故。若寂静思惟行生时。彼久灭无常意识闻习所薰同习既无。何处复彼种子心。后时寂静思惟行而生所有。彼寂静思惟修行世间心。彼正见同顺出世间心。或时同生灭。是故彼不薰。以不薰故彼种子不成。是故出世间净中间一切种子报识不成。是中间习者。彼种子摄不顺故。复云何一切种子与报识作染因成。彼对治出世间心种子事不成。出世间心是未曾有。是故彼习本无。既无彼习已有何种子生。彼应说善净法界尽唯以闻习种子生彼所有彼闻习彼为是阿犁耶识性为不。若是阿犁耶识性者。是中云何彼对治种子成。若是非如是性者。是以彼闻习种子有何依身可见。诸佛得菩提已。所有彼闻习随心身现彼共同事。报识中行亦如乳水。然非彼阿犁耶识。彼对治种子故。是中依微习故生中习依中习故上习生。多以闻思修顺义故。然彼闻思修种子虽微中上。然是法身种子应知阿犁耶识相违。非阿犁耶识所摄。出世间善净法界因气事故。世间及出世间心作种子。然彼未得出世间心时。现气烦恼对治。随恶道对治。消灭作一切恶对治。随顺亲近诸佛菩萨。世间亦诸新学者法身所摄。应知诸菩萨解脱身所摄。声闻缘觉彼阿犁耶识法解脱身所摄。随所随所微中上渐次增长。如是如是。报识亦微劣身亦转明。一切时身亦转明。一切时转身已。彼报识一切种子离种子成。及一切时灭已。彼复云何。阿犁耶识如乳水。若尔非阿犁耶识。同事而行。一切时坏如鹅水中饮乳。或入世间厌。或入定习灭故。入定习增长。如转身及入诸灭尽定。虽不着识故彼中唯执不离。成非灭尽定。彼对治可取生。非彼起已更复生。报识已断。非余处可取顺成。若复计言。灭尽定有心。彼亦是心善不善。彼无记事故。不生成彼亦不成。若复言色心后生者。诸法种子事分别前未生。亦不生色无色。灭已及从灭尽定起。彼不成。及阿罗汉后心亦不成。除唯次第缘事可成。如是一切种子报识中间无染无净成。是故释成彼无及随所相说。是中说偈

  菩萨净心　　离诸五识　　离余转事
  心云何作　　对治回转　　无量不成
  因果分别　　彼灭应顺　　离子非事
  若取转事　　彼事二无　　转事不成

何者。复此阿犁耶识差别事略有三种。及四种应知。是中三种者。以三种习差别故。一言说习差别。二身见习差别。三因缘习差别。四种习差别。一取时差别。二报差别。三念事差别。四相差别。是中取时差别者。所有诸习生彼无故。行缘识及取缘有不成。是中报差别者。所有行有缘故。诸道受报彼无故。无子后生。诸法生事不成。念事差别者。所有彼意我相念事。彼意无己身念取事不成。是中相差别者。所有彼同相不同相。离受生种子相同。受生种子相同。所有器世间。种子不同者。所有内入种子。所有同者。彼离受生种子对治生。不同者。障灭。及同者。他所妄想分别取见净。诸行人一事中种种信如种见得。是中偈

  难灭证缚　　说为同事　　行人乱心
  自念外坏　　净不相违　　真实见净
  佛戒清净　　诸佛见净

所有不同彼同受生种子。彼无故。器世间众生世间顺胜事不成。复粗涩相安相。粗涩相者。所有烦恼及使种子。安相者。有漏善法种子。彼无故报作不作胜身中不成。复受不受相。受相者。所有熟报善不善种子。不受相者。所有言道习种子。无量分别顺种子故。彼无者作不作善恶业得时不受用义不成。新语言习生事不成。复喻相幻焰梦患目等。彼阿犁耶识彼时无故。虚妄分别种子故。相事不成。彼复同相别相具有缚者同相世间。离欲者坏相。学者声闻及诸菩萨一义一处除相。阿罗汉辟支佛诸如来烦恼障具除相。烦恼障智障及具除相。如顺彼无渐次。烦恼灭事。以何义故。善不善诸法报中不定无记报。如是无记善不善不相违。善不善事迭互相违善不善事烦恼转事不成。是故唯不定无记是报识。已说智依。智相复云何知。彼略有三种。一他性相。二妄想分别相三成就相。是中何者他性相。所有阿犁耶识种子中。虚妄分别所摄识。彼复何等身与受用识。彼所受用识。受用识。时识。数识。方处差别假意识。自他分别善道恶道生灭识。是中所有身与受用识及彼所用识。及受识所有时数分别假识者。彼语言习种子因生故。所有自他分别识。彼身见习种子因故。所有善道恶道生死者。彼为因缘习种子因故。此诸识一切尘一切道烦恼所摄。说他性相者。虚妄分别现见成。此别现见成。此诸识中所有虚妄分别所摄。唯识事非有妄取义依见。此是他性相。是中何者妄分别相。若非有尘唯彼识作尘现取故。是中何者成就相若还彼他性相中微尘相永无有事。是中身与受用识等六内眼等尘应知。彼所受用识者。六外尘色等应知。彼能受用识者。六种眼识等尘应知。此诸识余识差别应知。复此诸识唯识无义故。余处有何见。梦等见应知。所谓梦中离尘唯识。如是种种色声香味触屋宅林地风诸山尘现相事故见。然彼处无尘义如是见者一切唯识。随义通达应知。言等者幻焰鹿渴患目等应知。然彼如梦觉者一切亦如是识。何以故。如梦中唯识意生。如是彼处亦不行。行真实知觉已故行真实。未觉者唯识事云何得知。从阿含及解释顺义中。是中阿含如佛十地经所说。三界唯心作。相续解脱经中弥勒菩萨问佛言。世尊。所有彼三昧境界中见像。彼为于心异为不异。佛言。弥勒不异。何以故。彼念唯识所明识我说。世尊。若是彼三昧境界形像心中不异者。云何以彼心而取彼心。佛言。弥勒。无有法而能取法。然彼心如是生。以如是生故如是见。譬如缘像故唯见像而言我见像。以是义中间不离彼像。中间像相似见。如是生彼心。如是中间而言见。如是此阿含将证成。如是入定心时随所青等知所有。见像还见彼心离尘青等。如是顺释已。菩萨于一切识中如是测量取。唯识中无彼青等忆念持识。前已彼念所见闻思修。亦随所忆事识。彼亦念过去故。彼现相唯识。得以此喻证故。菩萨虽真智未觉已应思量唯觉事随此如梦说种种诸识。彼识顺成唯识。眼识等诸识。眼等诸识复有诸色云何得知。唯识事彼亦有。阿含及顺释如前说。若是唯彼诸识者。何故色事及现见相事久住体。行颠倒等烦恼染处因故。余时非尘为尘妄不成。既无彼事烦恼障智障染事不成。彼既无净事不成。是故如是彼顺义成。是中有偈

  妄念及妄想　　说为诸色识
  及无非色识　　有彼非余者

何故时等种种如说者行无时。世间流不绝故。无量众生界因故。无量佛世界因故。无量所作事迭互假名分别因故。无量摄取受用差别因故。无量爱不爱业果报受用差别因故。无量受生死差别因故。云何复此诸识唯识作事成。略说有三种相。一者但彼无义因故。二事同念见识因故。种种事画师所生因故。如是彼一切诸识无尘故。唯如是同见相。眼识等色等念故。及彼识见乃至身识见唯意识。一切眼等法尽识同念意识。识同见分别故。于意识及一切识生现相故。是中有偈

  唯彼二种事　　行者入意识
  唯入彼心已　　彼力所成此

唯彼意识种种行故。得彼名。亦如身口等。余者行一切身中如画师。二种现相行。唯彼尘现相故。及分别现相故。一切处触现相故。行色尘身依故。彼意识彼余色相身依故。是中有偈

  远至独行故　　无身窟所依
  能调不调心　　我说为净行

如说此诸五根。意识境界缘受成。然是彼者意是依止尔。复如说十二入。经中六种识种识是意入尔。若有阿犁耶识。识尘识分别安是中。诸余一切识。彼念想识唯意识识同身彼见应知。彼如是唯念想诸识彼见生因故。如尘现相见彼生同依作事成。如是此诸识唯识住事成。云何有见尘而说无有义成。如佛所说。菩萨成就四法。一切诸识解通无义事。相违识相智故。亦如饿鬼畜生人及诸天等同事中见既别。不念见觉识故。亦如过去未来梦现相念故。加意中间颠倒同顺智故。所谓有尘念。彼念识不颠倒。应得不加真智及随顺三种智知故。如是诸菩萨及得禅定者。得心自在忆持力故。现如是事。及得舍摩他。诸行人观法顺故。唯忆念现见故。及得无分别智。彼处住已现一切义。如是此三种智随顺义故。彼义本四诸相释成无有义。若是唯识义现见依者。他性相云何。他性以何义故说为他性。自习种子生故。缘他性生已刹那后自不住。有力故说他性。彼是妄想分别非性非所依。未曾有尘见故。彼云何妄分别。以何义故彼名为妄分别。无量相妄分别颠倒相生故。妄分别者。无自相唯妄见故。说为妄想。若是成就相者。彼永无自性相彼云何成就。以何义故说为成就。不以义故说为成就。缘净念一切善根妙义因故。亦是上义故名为成就。复有分别及无分别说分别性。是中何者分别。何等分别。何等分别性。意识分别以能分别。然彼自语言习种子及一切识。语言习种子故。是无量诸相分别故。行一切处分别妄想分别故。说为分别。复他性妄想念随所有性。他性妄想者。是彼处妄想自性。以何相以何义故先已释。云何复妄分别以何分别。以何念以何念取。以何慢。以何假名。以何安义名。以念故他性中彼念取见彼慢分别起口业。见等四种世间行故。非有义而言有安故分别妄想。此诸三性为同行为别行为别不别。应说傍义故。他性相他性傍义故。彼亦是妄分别傍义故。彼亦是成就有何傍名义。是以他性他性习种子。生他性因故。有何傍名义。以是彼如是妄分别。及妄分别及诸分别因故。有何义故。随彼如是妄分别。如所分别如是彼永无义故。有几种他相。略有二种。一薰种子他相。二染净性不成他相。如是此二种他相故。说为他相。妄分别性亦有二种一者性分别。二者胜分别故。以为分别。成就性亦有二种。一者性成就故。二者净成就故。分别复有四种。一者性分别。二胜分别。三觉分别四不觉分别。觉分别者解义事善巧故。不觉分别者。不解义事不善巧故。复有五种。一名所依义分别。所谓此名有是义尔。二义所依名性分别。所谓此义有此名尔。三名依名性分别者。所谓不决定义名分别故。四所依义性分别者。未决定名义分别故。彼二依彼分别。所谓此义如是。身如是名尔。摄一切义故。复有十种分别。一根本分别。所谓阿犁耶识二相分别。所谓色等识。三念现相分别。所谓同依眼识等识。四念异分别。所谓老等。乐受贪等。他所恼时转变等。趣及欲界等异故。五念现相异事分别。所谓所说如是等异相。彼异相他所将分别。所谓不闻正法。及闻正法者所有分别。六不寂静思惟。所谓不闻正法者。谓诸外道。七寂静思惟。所谓闻正法同法者。八妒分别。所谓不正意思量。身见等六十二见。同顺彼分别散分别。谓诸菩萨有十种分别。非事相散故。事相散故。正安散故。毁谤散故。一向事散故。异事散故。性散故。随名义散故。及随义名散故。此诸十句散事中对治故说无分别智。一切诸般若波罗蜜中说如是彼障及对治。具足般若波罗蜜应知。若是傍名义他性相三种性成。云何三种性无差别不成。随彼傍义他性者。非彼妄分别。非成就随彼傍义妄分别者。非彼他性。非成就。随彼傍名成就者。如是非彼他性。非妄想。云何复知。如他性相。妄分别性事现故。非如是体性尔。本名离慧故。及自灭因故。多名故。多身相违因故。不定名秽身相违因故。是中有偈

  本名无慧故　　多及不定故
  成彼自多身　　秽身相违故
  觉见诸法事　　及见染净等
  如幻应当知　　及如虚空等

复以何义故。有如是所说事他性相一切事不成。彼无已成就性及无故。如是一切事不成。他性及成就性无故。染净无事患应见染净。是故非一切无。是中有偈

  他性既无　　成就一切　　无事常时
  于诸染净

所有此诸佛如来大乘方广中说。彼说中云何妄分别性应知。无傍名义说可知。他性相云何知。幻焰梦镜像光明响水中月应化等诸喻应知。成就性云何知有四种净法。说中知四种净法者。性净故。所谓真如空实际无相真实义及法界。是离垢净所谓如是彼离一切障垢。彼得行净。所谓一切菩提分法及波罗蜜等。彼生因念净。所谓说大乘法。如是彼净因故非妄想。净法界因气故非他性如是此诸四法摄成一切诸净法。于中有偈

  幻等说故生　　妄计无有说
  于诸四净中　　说为真实净

净性离垢行念故。彼净诸摄四种义故。复以何相故。他性相如所说幻等喻中明。余者于他性相中。回妄颠倒取意故。云何复余者于他性相中颠倒疑意成。如是余者作是意。云何无此义。现境界成。为彼除疑回义故说为如幻。云何无义诸心心数顺义成。回疑义说如焰喻。云何无此无义而受爱不爱事。回彼疑义故说如梦。云何无此义而有净不净业爱不爱果顺不顺事。回彼疑故说如镜像。云何无义而有种种识顺事。回彼疑义故说如光。云何无此义而有种种假名语言顺事。回彼疑义故说如响。云何无此义实能取三昧境界顺事。回彼疑意义故说如水中月。云何无此义而诸菩萨故取意不颠倒。作众生益义故受生。回彼疑意义故如应化事。有何义故。如梵王经中说。我不见世间不证涅槃。他相性中妄分别。及成就性因故。说世间及涅槃事。无异事故。如是彼他性相妄分别分故说为世间。成就分故说为涅槃。如佛阿毗昙中说。有三法。是染分净分。彼二分有何义故说。他性中妄想性是烦恼分。成就性是净分。还彼他性彼二分。以此义故说。此义中何者说金藏土示现。所谓如金藏土中有三事可见。一地尘二土三金。是中有地尘故见土及见有金。若入火时不见土唯见金。地尘者见土时非正见。见金时非如实见。是故地尘有二分。如是此无分别智火触彼识已。彼识虚妄分别性事见成就性事故不见。无分别智火触彼识已彼识实成就性事故见。妄分别性事故不见。是故所有妄分别识他性相二分成。如金藏泥地尘尔。如来或说一切法常或说一切法无常。或说非常非无常以何意故说常。他性相成就分别故说常。妄分别故非常。彼二分故非常非无常。以是意故说如。常无常不二。如是苦乐不二。净不净不二。空不空不二。有我无我不二。定不定不二。有性无性不二。有生不生不二。灭不灭不二。永定不永定不二。性灭不性灭不二。世间涅槃不二。如是等句差别诸佛一切密语。以此三种性句随顺应知。如常等诸句中说。于中有偈

  如诸法所无　　及如见非一
  如是法非法　　不二义所说
  彼一分事故　　亦说名为事
  二分不名事　　非事真实说
  如见非如有　　是故说为见
  如是彼亦见　　是故说为无
  自体自无故　　自事中不住
  取者本亦无　　故说为无性
  无性义故成　　上上依义故
  无生亦不灭　　永寂性灭故

然有四种意趣故。及有四种密语渐次。一切佛语随顺解释应知。一者法同意趣故。所谓我是无量无边时。号曰毗婆尸正真正觉。二者时节意趣。所谓若称多宝如来名者。即定于阿耨多罗三藐三菩提。如无量寿经说。若有众生愿取无量寿世界即生尔。三者义中间意趣。如经所说。供养若干如许恒沙等。供养亲近已得解大乘义尔。四者顺众生心意趣。所谓或有众生赞行布施彼者复谤毁。说如是布施如是持戒。及余者说修事。是以故说四种意趣。四种密语渐次。一者劝发渐次。所谓或声闻乘。或大乘中众生法性胜故。顺世谛理所说。二者相渐次。随所法相说中示现。三者对治渐次。随所说八万四千众生行。四者发愿渐次。随所异义言音声字义余说随所。有偈

  非实而作实　　颠倒中善住
  烦恼善染故　　得无上菩提

欲解释大乘经者。彼应以三种相差别故。略作解释。一者因缘说。二者因缘所生诸法相说。三者以说闻义故说。是中因缘集说者。如说言习所生法。彼如是还彼报识顺识中迭互缘故生。彼复顺识相诸法。同念见识性。然彼忆持相分别相及法体相。是以此示现三种性相成。如说同念见者。彼知三相尔。云何复彼相解释分别相者。他性中无。成就性中有。彼二有无。有觉无觉有见无见。真实同时。彼他性中依非众生分别众生成就者。行彼觉故彼不觉。如说分别他性中成就。彼处有不觉及觉故。略说彼二边所说义解释。所谓先已说句余句示现彼分别。或功德增上故。或义增故。功德增者。所谓说佛功德善觉慧。不二行无相法究竟佛行行故。得一切佛法。到无障道。不退转法无障境界。不思住达三世遍一切世界身。一切法无疑。知一切成就慧无疑。诸法知无分别知。一切菩萨正受智。不二佛行得最究竟。不离如来。解脱智尽。至无边中佛地。通达法界最虚空界尽尔。善觉佛者。此句余句所解释应知。如是善说法体成。善觉慧者。此善觉慧诸佛如来十九种诸佛功德摄成应知。智中一向无障无分别功德。事非事二相真如最净说自然佛所作不休息行功德。法身中身心业无分别功德。一切障对治功德。降伏一切外道功德。世间生世间法不能染功德。法住功德。受记功德。一切世界中示现报身应身功德。决疑功德。种种行入功德。未来生法智功德随信示现功德。无量身化众生行功德。同法成波罗蜜功德。异佛世界随信示功德。三种佛身说法不断功德。乃至世间际一切众生助成一切乐及无量功德。因此说故。义增上者。复如经所说。菩萨成就三十二法故名为菩萨。助益乐深心故。于一切众生令入一切智智。称己智灭慢故。淳厚深心故。不作恩爱怨及非怨等心故。永亲故。尽至涅槃美言悦目先应故。不断彼心故。所许之事不休息不疲倦意故。闻义无厌足故。自过见患故。见他作过不说故。一切威仪行菩萨心业故。布施中不求报故一切有道处不着修戒故。不嗔一切众生忍故。聚集一切善根法以精进故。离无色界禅故。顺方便智故。四摄法所摄方便故。破戒持戒不二心故。勤劬闻妙法故。乐住阿兰若故。不乐世间种种事故。不希乐小乘故。于大乘见大利益故。远离恶知识故。亲近善知识故。净四梵行故。五神通游戏故。依智故。住有行不住有行众生不舍故。一向定言故。重实语故。菩萨心为首故。如是等句初句中差别应知。助乐深心故。于一切众生此助乐深心故。有十六种作事差别应知。是中十六种作事者。转转行作。不退作。他所不劝而自行作。不嗔作。不望报作。三句不望报故。有益无益不嗔喜。乃至后生随逐故。彼相似口业故。有二句苦乐中不二等作事。不怯弱作事。不退转作事方便摄作事。除障作事。二句相续不断念彼心作事。胜至作事。七句六波罗蜜正修行。及摄取行正事。成就行作正事。六句亲近知识。听闻正法。乐兰若。舍恶觉心。正念功德。二句大乘功德。二句成就作事。三句无量清净得益力得证功德。彼令住作事四。将众功德除疑。教受财法摄取心故。不杂心故。如是等句与初句解释差别应知。如经说。依于初句故句别有功德。依于初句故句别义别尔。如是智相释已

摄大乘论卷上摄大乘论卷下

        阿僧伽作

        后魏世佛陀扇多于洛阳译

入智相云何。多闻薰身故。非阿犁耶识所摄。如阿犁耶识种子成。寂静思惟所摄。诸法义现相所生可取事处有见者意言处。是中谁入智相。大乘所薰多闻相续身。无量诸亲近得故。信欲一向故。善集善根故善助功德。智行菩萨何处入还。彼现见法义现相意语处。因大乘法生故。信解地中见道行修道行。及尽至一切法唯记尔。随顺闻信因故。如是彼分别证因故。一切障对治及离障故。从何处入。善根力持故。三种相心转明。种种庄处灭故。念法义定慧一切时正行。及不放逸故。诸世界无量众生类。无量念念中成阿耨多罗三藐三菩提。初转心者。随所心布施等波罗蜜助集行。彼心我已得。是故我不加用诸波罗蜜。修道能满成。第二转明者。诸禅法成就已。死后寻得随所须一切身事。得有障善根者。况我善修善根得无障善根。寻即一切诸势不成。第三转明者。是中有偈

  人类得菩提　　于念念中间
  众生无量故　　至时应舍行
  随心所行施　　清净无垢心
  彼得心止事　　勇健布施成
  善者灭身已　　自势随所心
  善者灭身已　　彼势云何不

舍声闻缘觉心灭念故。于大乘中一切有疑无疑故灭疑或。闻思诸法除我相我我所相执故。灭法慢者。前所住及安一切相。不念不分别故。及灭分别者。是中有偈

  在前随所除　　相念自住处
  智尽不分别　　得上菩提尔

以何云何入彼闻习业。寂静思惟所摄法义。现见意言四种求。名义性胜安。求等四种如实知故。名事性胜安性胜。如实知彼不觉见故。如是彼菩萨唯入记故顺修。彼名义现见意言。彼名意言唯正观。彼名所依义唯意言正观。然彼名性胜安唯观。于后唯意言不觉已有名彼义有性胜安有性胜义相不见已。此四种求及四种观。见知已彼名义现相意言中唯记入。彼记事中入已。为当唯入。彼有相见二事及种种事入。名义性胜义。六种相无义故。彼可取能取事现处故。不断种种相义。现相所生故。闇中如见绳谓蛇现相故。所谓如绳蛇不实。非众生故。如是觉义者非有。回蛇意唯住绳意。彼亦微思量色香味触相故。是中依慧绳慧亦回成。如是此诸六种相名现相。意言中如绳慧。六种相实义实处唯记慧。亦思量成就性慧故。如是此菩萨意言现相义相事入。分别性入。成唯主记入故。他性云何成就性入。回唯记想。彼者是诸意言。闻法习者。彼尔时分别义相。菩萨一切义现相生无有余成。是故唯记现相亦不生。是故一切义无分别事名住。已于法界如现见随住。尔时彼菩萨同等念已。生无分别念智。是故此菩萨名为入成就性。于中有偈

  法众生法义　　同别有性义
  不净净尽至　　分别名境界

如是此菩萨智及相唯记入故。名为入成。彼入已名为住欢喜地。善达法界。及生如来家。得一切众生平等心。得一切菩萨等心。是彼菩萨见道行。佛以何义故。入彼唯记处离法念。彼出世间定慧智。藉得种种相记智同相。一切阿梨耶识因种子灭故。法触种子增长已转身。一切佛法集故。入一切智智。藉彼所得智。一切阿犁耶识相处如幻等见故。性不颠倒行。是故彼菩萨如幻师所作。义处相同因果唯有说一切时不颠倒成。彼以记入中四种禅定所依。四种攒相法云何知。四种求故非不身无义无忍中得光明三昧。暖相依增忍中光明增长三昧。上依四种中如实观知入唯记中。以无义决定心。真实中入一切三昧依顺谛忍。自此后唯记相思量彼。是次第三昧。依世间上法见故。此诸三昧近入地应知。如是入地得见谛道。菩萨唯入记云何行修道。随所分别说十地。摄一切修多罗现事住故。以杂念出世间。及藉彼得定慧智故。无量百千亿习故。如是身转已。为得三种佛身。为得故修行。所有诸声闻证道法。及此诸菩萨此二有何差别。胜声闻证入中。菩萨证入有十。一种胜事应知。一者念胜。念大乘法故。二者淳至胜。大功德助集淳至故三者证胜。众生法无我证故。四者涅槃胜。摄取不住涅槃故。五者地胜。十地尽至故。六者净胜。烦恼习灭佛世界令清净故。七者一切众生同得记心胜。化众生行不断绝故。八者生胜。生如来家故。九者取生胜。佛世界会中一切时取生故。十者果胜。十力四无畏十八不共佛法无量功德成就故。是中有偈

  迭互作客事　　于事名所求
  唯求彼诸事　　分别二所安
  如实知见故　　离义分别三
  见彼是非事　　彼无二所执
  喻若顺分别　　复有教授偈
  镜像意于后　　菩萨在诸定
  回彼义想已　　忆持自想事
  住心如是内　　知无所可取
  于后无能取　　无分别知尔

更复有证道偈。所谓大綖庄严论中说

  助集无边行　　功德智菩萨
  法思善决定　　语言达义尽
  彼知正义已　　说住彼定心
  法界现意故　　是以离二相
  离心无有余　　善知心亦无
  知二既是无　　正住于法界
  不分知力故　　同时常同行
  彼身窟聚患　　如象灭诸毒
  牟尼说善法　　善住意思量
  根本法界处　　念至知意故
  唯分别正取　　速得功德处

如是说入智相已。彼因果说云何知。六种波罗蜜故。谓布施持戒忍辱精进禅定智慧故。云何此诸六波罗蜜唯记入成。云何彼入果六波罗蜜成。是中菩萨于施不着。于戒不毁。于苦不嗔。于修不懈怠。如是此诸乱因不行故。因不行故。一向已寂静思惟诸法。入唯记已依六波罗蜜。及入唯记故。菩萨净深心所摄故。得六波罗蜜。是以中间六波罗蜜行顺说信故。乐求随喜故。得利润离忍。菩萨自大乘中说甚深大。唯分别正觉得无分别智

  欲信净心明　　本彼觉法流
  十地近菩提　　不假自然得

有何义故唯说六波罗蜜。障对治差别安故。一切佛法集句处故。及随顺化一切众生故。不动相对治故。说檀波罗蜜及尸罗波罗蜜。不动相。谓世不着及家不着。动者。回相对治故说。谓羼提波罗蜜及毗离耶波罗蜜。回因相者。世间众生作恶行长受苦。及于修善行法中生疲倦。以发不回失相对治故。谓阇那波罗蜜及般若波罗蜜。失相者。乱心及无智。如是障对治数差别故。四波罗蜜不散相。一波罗蜜不散相成。以散依故。如实法正觉集诸佛法。如是集一切佛法。句处故数差别。以檀波罗蜜益众生。尸罗波罗蜜不作恶。能忍毗离耶波罗蜜作事尽至故。如是益相化众生。化以故调伏。于后不入定心为令入定心。已入定心为得解脱故。数劝故得解脱。如是化一切众生。句处故数差别。应知。然此诸波罗蜜相云何知。以六波罗蜜身最依菩萨心故。彼以最故。遍行不断增上意一切众生助乐故。方便善巧最故。所有无分别知摄取故。发愿最者。阿耨多罗三藐三菩提作愿故净最烦恼智障。修集无障故。所有布施彼亦名波罗蜜。所言波罗蜜。布施非波罗蜜。如是四句如布施中。如是诸余波罗蜜中皆有四句。如顺应知。此诸波罗蜜以此何义故有此渐次说。前波罗蜜后波罗蜜。随顺生故。彼复释。云何知一切世间声闻缘觉布施等。善根中增上到彼岸故。波罗蜜者。妒吝贫穷破除故。令得大势功德故。布施持戒灭恶道令得善道。三昧戒嗔恨灭除故。他者仿佯住忍。懈怠及诸恶不善法令远离故。增长无量善法出故精进破乱想。内心住将来故。禅定一切见无。智灭除真故。及相别故。知诸法故名智。云何此诸波罗蜜有修事可。知略有五种修事应知。习行因行修事。信欲修事。心正念修事。方便善巧修事。所作事忆持修事。是中四种事如前所作。忆持事修事者。所有诸佛自然作佛事。不断不休息。修诸波罗蜜令满满已。心念修喜乐随喜忆念等心。六种心所摄故。修广心不断心喜心作益心大心及真心。所有菩萨随所阿僧祇劫。得阿耨多罗三藐三菩提。如是等时念念中。舍一切自身及恒河沙等世界七宝。令满已施。诸佛如来乃至未坐道场。而菩萨行布施心无厌足。如是等时念念中三千大千世界满中火时。现四种威仪。虽少一切资用而现作。持戒忍辱精进禅定智慧心。乃至坐道场。如是菩萨不厌修持戒忍辱精进禅定智慧等心。此是菩萨广心。所有彼菩萨此无厌足心。乃至坐道场不断及不舍。是名此身。若彼菩萨喜心故。彼六波罗蜜所作众生益。非彼众生以得此益故。此是菩萨喜心。若彼菩萨作益众生。于六波罗蜜作益摄取。见如己身自身见如众生。此是菩萨作益心。若彼菩萨彼如是六波罗蜜所集善根。回发愿令一切众生得爱果报。此是菩萨大心。若彼菩萨彼如是六波罗蜜修集善根。与一切众生同发愿向阿耨多罗三藐三菩提。此是菩萨真心。如是六种心所摄故。修乐喜心。若彼菩萨六种修心行行者。彼余无量诸菩萨彼善根令随喜。如是菩萨六心所摄随喜心令修。若彼菩萨一切众生六种心所摄。六波罗蜜修事希求如记。六心所摄。六波罗蜜修不离者。乃至坐道场。如是菩萨六种心所摄希求意行修。若此六种心所摄菩萨心修故。闻已发一好心。彼功德量等功德。及一切恶作障消灭。何况菩萨。云何此诸波罗蜜有差别。以三种相应知。法施财施及无畏施。止戒。摄善法戒。作众生益戒。作恶忍羼提忍苦羼提。法思惟忍苦羼提。勇猛精进。行精进。不怯弱不嗔恨喜精进行。现相作忆持。无分别方便行。无分别及有分别。及藉彼得智。云何此诸波罗蜜摄事。应知此诸波罗蜜摄一切善根。彼相彼随顺及彼因气故。云何此诸波罗蜜诸障。一切烦恼摄事知。彼相彼因及彼果。云何此诸波罗蜜有益事可知。世间行时势力所摄同生所摄。眷属所摄大作事行成吉所摄。不恼少尘所摄。一切工巧诸论咒术处细意所摄。增长是无恶。乃至坐道场。一众生现一切义作事。是名菩萨益。云何此诸波罗蜜迭共决定分别事知。或有处一切六波罗蜜布施声说。或有持戒声。或有忍辱声。或有精进声。或有禅定声。或有智慧声说。是中有何意趣。一切波罗蜜行中。彼一切同助至故。是意如是说入因相果已。云何彼修差别事知。谓十菩萨地。何等欢喜离垢明作焰难胜现前远行不动善慧及法云。云何此诸地十事差别。应知十种无明障对治故。如是十种相智中。及法界十种障住故。云何十种相智法界。一切处义故。初地中上义故。第二地中因上义故。第三地中无所取义故。第四地中身心无差别义故。第五地中无烦恼净义故。第六地中种种法无差别义故。第七地中无胜无劣义故。第八地中相自在身义故。及世界自在依义故。第九地中依智自在义故。第十地中依业自在义故。依陀罗尼三昧门自在义故。是中有偈

  上义及因上义故　　不摄义及身相续
  无烦恼染净义故

  乃至不异义　　不胜无劣义
  依第四自在　　法界中无明
  二种及以十　　十地有障故
  对治说诸地

然此无明诸声闻不杂。诸菩萨中杂。何故初地名为欢喜。彼初故自益他益。堪能成德义故。何故第二地名为离垢。破戒垢令远作故。何故第三地名为明。作不动三昧三摩拔提依故大法光依故。何故第四地名为焰。菩提分法烧一切障故。何故第五地名为难胜地。超菩提分故。由真谛智与世间智更互相违合此难合令相应故。何故第六地名为现前。因缘智依般若波罗蜜行现作故。何故第七地名为远行。有功用行尽至故。何故第八地名为不动。一切相不动故。何故第九地名为善慧。得上辩才智故。何故第十地名为法云。杂念一切法智一切陀罗尼三昧门藏故。如云如虚空。上烦恼障灭故。法身满故。云何此诸地得智。有四种相。得信地信地行得顺地。十种法行得故。证得初地中证法界证一切地故。成就得此诸地修尽至故。云何此诸地修事知。此菩萨地地中修舍摩他毗婆舍那已。有五种相修。何等五种所谓杂修。无相修。无功用修转明修。转转修。如是此菩萨此五种修已得五种果。所谓除一切恶。身种种想离得乐法意。一切处无量不作畔在相。法光明现相。知净分别相。彼诸分别念同行。为满法身及成就故。上中上因作摄故。名以十地中十波罗蜜修事成。六中六随所说。有四方便波罗蜜。六波罗蜜所集善根。彼一切众生共故。发愿愿向阿耨多罗三藐三菩提。作愿故。愿波罗蜜者。未来种种愿现相故。波罗蜜缘牵将故。力波罗蜜者。能修力等六波罗蜜。不断同行故。智波罗蜜者。六波罗蜜差别智。法同受报化众生故。然此四波罗蜜。般若波罗蜜无分别智藉得智所摄。然复一切诸地。一切波罗蜜。非不修成波罗蜜藏所摄。此法门几时此诸地修事满成。有五种众生。三阿僧祇劫信行人。初阿僧祇净深心行无相行及有相行。有六地及七地。第二阿僧祇还彼不现相人。自此以上乃至十地。第三阿僧祇修道满足成。是中有偈

  胜上力故　　坚心胜智　　菩萨三祇
  发行尽至

如是说因果修差别已。是中云何增上戒胜事知。如菩萨地持中说。受菩萨戒品中略复有四种胜故。胜事应知。差别胜。同不同戒胜。上胜。及甚深胜。是中差别胜者。谓受戒摄善法戒。作众生益戒故。是中上戒者。二种戒住义故。知摄善法戒集佛法住义故。作众生益戒者。教化众生住义故。知声闻同戒。诸菩萨性重不同。行不同戒者。制重同行故。彼戒中随所声闻犯。于中菩萨不犯戒。随所菩萨犯戒。是中声闻不犯戒。菩萨防身口心戒。声闻唯防身口。是故菩萨起心犯戒。非诸声闻。略说所有一切众生恶。而有益身口意业。彼一切菩萨应行。及彼中学如是共不共胜。应知上胜复有四种。上故种种无量戒。上故摄取无量功德。上故一切众生助益乐心眷属。上故阿耨多罗三藐三菩提住。上故及得无量功德疾得阿耨多罗三藐三菩提。是中甚深。若菩萨如是方便善巧故。杀生等十种业修行。是以不恶。成得无量功德。速得阿耨多罗三藐三菩提。或应化身业口业。是甚深戒应知。是以作国王治国。计种种示众生恼事。是以化众生安置善处。示种种生恼。余众生示余益。余者令心以发。发已先化。化已心回。此是菩萨戒甚深胜事。如是四种胜事。略说菩萨上戒胜事应知。如是分别。复有菩萨戒差别无量。亦如比尼响方广修多罗中。如是说增上戒胜已。增上心胜事复云何知。略有六种差别应知。念差别。种种差别。业作事差别。现气差别。业差别。念大乘法故。大乘光明一切功德积聚三昧。三昧王现护首楞严等三昧无量种种故。一切法杂念智显顺故。阿犁耶识一切障诸恶使令除故。禅定乐行已随所生故。处生故。一切世界无障神通现故。动放光遍视异事作。来往略广。一切色身入同行。往上下作自在隐蔽他。神现念与乐。放光现大神通故。摄一切苦行。现十种苦行故。十种苦者。所谓受许苦行。菩提愿许故。不退苦行。世间诸苦不退故。不背向苦行。一切众生恶行苦行中彼现现事故。现苦行。作恶众生中。作一切利益义现故。不染苦行。世间生以世间法不染故。信苦行。于大乘虽无解一切甚大事信故。证苦行。众生法无我证故。顺觉知苦行。诸如来甚深密语所说顺觉知故。不寂静不染苦行。不舍世间彼不染故。行苦行。住一切障解脱诸佛如来乃至世间众生际。自然作一切众生一切义行故可者。复顺觉知苦行。所有诸佛密语说若随彼所觉。所谓云何菩萨布施成。若使无所布施。而彼无量十方世界作布施成云何布施喜心成。若一切布施不喜乐。云何布施信成。若使诸如来信不去。云何布施与意成。若使自身令与布施。云何乐布施成。若使一切时无所布施。云何布施大事成。若于布施起不坚相。云何布施增长成。若使起妒心。云何布施尽意成。若使不住于尽法时。云何布施自在成。云何布施无量成若不住无尽故。如布施如是持戒等乃至般若波罗蜜随顺应知云何杀生成。若使众生世间害。云何偷盗成若使余者未与众生而自取之云何邪淫成若使淫邪而行。云何妄语成。若使如妄语作妄语说。云何绮语成。若使常以空门行而行。云何恶口成若使到智彼岸。云何两舌成若使善知诸法而能诠说云何贪成。若使常与无常禅定法令得故修行。云何嗔心成。若使一切烦恼心中取行。云何邪见成。若使一切处到一切事如实邪见经明甚深佛法。何等法而说甚深。是中有此说。常法佛法。依法身常故。断见法佛法。灭一切障故。生法佛法者。能生应身故。有觉法佛法者。八万四千众生行有对治故。有贪法佛法者。有贪众生取如己故。如是有嗔法佛法。有痴法佛法。见有凡夫法佛法。无染法佛法。真如成就已一切障不能染故。离染法佛法者。生世间而世间法不能染故。以是义故名为甚深佛法。修诸波罗蜜化众生。令佛国清净。现一切佛法故诸菩萨三昧作事差别应知。如是说增上胜心已。增上胜慧复云何知。无分别智中性处身处因处念处相处持处伴处报处因气处出处尽至处。藉彼无分别功用行。等处差别处藉无分别得处。余处持自然作事处甚深处意。无分别智增上慧胜知。是中离五种相。无分别性智故。意离念故。果离有觉有观地故。离想受灭定舍离色性故。真实处舍种种相故。彼无分别智离如是五种相。应知此如所说。无分别智性差别安立中。说偈

  诸菩萨真实　　远离五种相
  无分别智处　　真中种种名
  诸菩萨身者　　善心正是心
  无分别智中　　义心真实说
  诸菩萨因者　　同言闻习故
  无分别智中　　意行同思惟
  诸菩萨念者　　诸法无诠事
  无分别智中　　无我及真如
  诸菩萨相者　　于彼正念处
  无分别智中　　智处无诸相
  随顺真实义　　分别无有异
  迭共随顺故　　彼义顺和成
  离智无言说　　说中有所行
  以说相违故　　彼说无有言
  诸菩萨持者　　彼智无分别
  藉彼得彼行　　彼到增长处
  诸菩萨伴者　　说为二种行
  无分别智中　　五波罗蜜性
  诸菩萨报者　　诸佛二界中
  无分别智处　　以得顺行故
  诸菩萨因者　　上上诸生处
  无分别智中　　胜到故正说
  诸菩萨出事　　为得顺义故
  无分别智中　　解知诸十地
  诸菩萨尽至　　因三净身得
  无分别智中　　得上神通故
  如空无有染　　彼智无分别
  众恶种种上　　唯信欲为正
  如空无所染　　彼智无分别
  远离一切障　　得顺成就故
  如空无有染　　彼智无分别
  常行世间故　　而世法不染
  哑义随顺故　　如哑所觉义
  非如不哑用　　说为三种智
  如痴所用受　　如痴所觉知
  非如痴所用　　说为三种智
  解通五种义　　如达五种事
  如意识所知　　说为三种智
  不通论修论　　如通法义解
  如是渐次知　　知为行创首
  如人蔽诸目　　彼智无分别
  彼后得开目　　彼智藉所得
  如空智亦尔　　彼智无分别
  彼处色现相　　彼智藉所得
  如珠伎乐等　　作事无分别
  如是离住故　　诸佛业庄严
  非彼及余处　　有智及无智
  彼智无差别　　是智无分别
  体性无分别　　明识一切法
  众生中分别　　彼智无分别

是中无分别功用行有三种。因现相取生差别故。无分别智亦有三种。少欲知足不颠倒。无分别无谤故。藉彼得智亦有五种。证得忆念差别离成就时现分别故。释成无分别智义故。复说余偈

  饿鬼畜生人　　诸天如罗汉
  等同意差别　　得成诸尘义
  过去如梦等　　无差亦有二
  非有而作念　　彼念顺义故
  义及成就义　　彼智无分别
  彼无即无佛　　得事即不成
  菩萨得神通　　彼以信力故
  地等如是无　　随善者觉见
  成就此智慧　　勇健得禅定
  一切法正依　　及见如是义
  智行分别中　　及现一切义
  应知无义事　　彼记永所无

般若波罗蜜中无分别智及无优劣。如大品经说。菩萨住般若波罗蜜中。以不住故能满修行。彼云何以不住故能满诸波罗蜜。舍无种处故。舍离外道我见处见故。舍离未得正诸菩萨妄念分别处故。舍离世间涅槃二边处故。舍离唯灭烦恼障处喜故。舍离众生益舍离无余涅槃界处。声闻乘及菩萨乘中有何胜。差别有五种。相胜故。无分别胜故。唯阴等法无分别故。非有方胜证正一切相知及依一切众生方故。不住胜因不住涅槃故。永胜无余涅槃界中住到无量故。及上胜果。此经无乘有上胜故。是中有偈

  五种胜义故　　慈悲以为身
  世间出世势　　不久当得现

若诸菩萨成就如是增上戒增上心增上慧功德。得自在于众生益处。何故复有诸众生。而复有苦缚者。示彼众生。有彼众生业障对故。诸善法受彼助得势。示现于彼生善起障故。示现开现故。示现还受彼受用势时。现彼不善法益因事故。助受彼势时还彼余众多众生。示现有障因故。而见众生众生众事有缚。是中说偈

  现烦恼障故　　患目不正视
  诸众生菩萨　　不得诸势义

如是说增上慧胜事已。灭胜事复云何。菩萨灭者。诸不着不住涅槃。彼相者舍同诸烦恼染。不舍世间。偈中转身。是中世间是他相性。是烦恼染分。涅槃彼亦是净分。身者彼是二分。他相性者。转身还彼他相性中得对治。所染分中转净分中护。然彼回略有六种。作微弱益回以信力故。住闻习故。依有惭愧烦恼行不行故。得证回入地诸菩萨现正不正现处故。乃至六地修转不现。有障念相现。善净正意故。乃至十地中满果回现无障。一切相念得一切相念。自在微小回小乘已。证众生无我故。一向背世间故。一向舍世间。上回诸菩萨已。证法无我故。还彼处见寂静灭诸烦恼使等。而不舍彼故。诸菩萨于微小回中有何患。舍众生益果。菩萨法离已。共诸小乘等同解脱是患。菩萨上回中有何利益。世间法中自身及他身得自在故。一切道一切众生视己身故。多以三乘中种种善巧方便。化众生令住故。是中说偈

  正覆迷凡夫　　不正一切现
  诸菩萨常正　　不假自然行
  不说而说知　　非义正义故
  彼身有转事　　正说为解脱
  世间及涅槃　　若生现智者
  尔时彼世间　　即说为涅槃
  不舍非不舍　　善知世间故
  无利无有衰　　善知涅槃故

如是说灭胜已。智胜云何知。以三种佛身故说智胜事。一真身。二报身。三应身。是中诸佛真身者。谓法身依一切法得自在故。报身若以种种诸佛众会中显明法身。所依佛世界清净依。受大乘法乐故。所有依法身者。从兜率天中托身生受欲出家。亲近外道。苦行成道。转法轮。示大涅槃。是中说偈

  得相自在事　　以摄受身故
  分别甚深德　　诸佛作念事

诸佛如来法身有何相。略有五种应知。一转身相一切烦恼障分。他相性回转中。一切障得解脱。现法自在处净分依转。回他相性故。白法体相能满十波罗蜜。得十自在故。是中命自在心自在及资用自在者。为满檀波罗蜜故。业自在及生自在者。为满尸罗波罗蜜故。信自在者。为满羼提波罗蜜故。愿自在者。为满毗离耶波罗蜜故。五通所摄。如意通者。为满禅波罗蜜故。智自在及法自在者。为满般若波罗蜜故。不二相事非事二相故。依一切法非事故。有为无为不二相。业烦恼无为有现相。时现得自在故。别不别是一不一相。是中一切诸佛不异身故。无量身心故。示现成佛。于中说偈

  自称无我故　　离别无有身
  是彼本顺故　　分别得立名
  性差别无异　　具足及无始
  不分别一佛　　或多依久处

常相依真如净相。本愿力取作事不尽故。不思议相彼真如净中唯内所证知。世间余未曾有。及非测量境界。云何复此法身。见觉观故。彼初得暂念大乘无分别。藉彼得智。五种相善修故。一切诸地中善集助道行。微小难坏障能令坏故。如金刚三昧。彼三昧中间坏一切障故。依彼身转故。得复有几种。自在故法身得名为自在。略说五种。世界身相好无分别无边声响音不可观顶自在故。转色阴上妙无量最乐行自在。转回受阴故。说一切名身句身字身自在。转回想阴故。应身愿显引众摄取白法自在事。转回行阴故。如镜观见作事忆持智自在事。转回识阴故。有几处意身法身。应知略说三种身。种种佛身行依故。是中说偈

  得五种爱身　　诸佛得自己
  利爱彼所得　　是彼义求得
  所作无能障　　法微义通得
  得无非最爱　　佛常不尽见

受种种报。依身化诸菩萨故。种种应身依故。多以化声闻。法身有几种。佛法所摄应知。一者净转阿犁耶识得法身故。报者转色根得报智故。行者转行欲得无量智行故。自在者。转种种业所摄自在。得一切世界无障碍神通智自在故。假用者。一切见闻解知。转假名得悦一切众生。智说自在故。去遣者。转一切诸难遣得一切众生一切难。去遣智故。如是六种佛法故。诸佛法身所摄应知。所有此诸佛法身。彼为杂为不杂。身心业差别故不杂。视无量处成正觉故杂。如法身报身亦尔。心业差别故不杂。非身差别。以转无量身故。应身者亦如报身应知。法身具几种功德。应知善净四种无量解脱。及诸有退遍净处。无诤愿知四无碍六通。三十二相八十种好。四种一切相净。十力四无所畏。三不护四念处灭习不忘法。大悲十八不共佛法。及一切相具智故。是中说偈

  愍念诸众生　　顺利及诸心
  不利世乐心　　归命彼益事
  得离一切障　　牟尼退世间
  智所知遍处　　归命心解脱
  无余一切众　　灭一切烦恼
  不杂灭烦恼　　归命有高处
  自然无有障　　不退常入定
  一切诸难中　　归命能释者
  身及所依处　　言智及说者
  心常无有退　　归命善说者
  往知彼语言　　来往知他心
  众生无实中　　归命善教诲
  赞取丈夫法　　一切生见圣
  见已即生敬　　归命分别者
  取处及诸势　　应身并愿中
  三昧智自在　　归命得彼岸
  方便归依净　　令利诸众生
  大乘出世利　　归命魔降伏
  智灭及出事　　作障并演说
  自他及外道　　归命不可退
  诸众善能说　　远离二种染
  无护不可忘　　归命将诸众
  修行一切行　　无有圣不知
  一切时悉知　　归命真实义
  众生所作中　　圣视不相违
  作事无暂停　　归命不妄者
  一日一夜中　　六时观众生
  成就大慈悲　　归命益心者
  行至及与得　　智慧并诸业
  诸声闻缘觉　　归命最上者
  三身大菩提　　具得一切相
  遍处一切众　　归命决疑者

诸佛法身成就如是诸功德。复有余性因果业顺行功德。是故诸佛如来法身名为无上功德应知。是中说偈

  成就诸真实　　超过一切地
  到一切众上　　度脱一切众
  具无量无边　　世间见功德
  世界不可见　　一切诸人天

然复甚深最甚深。诸佛法身彼甚深事云何知。是中说偈

  无生生诸佛　　不住而善住
  一切自然事　　食为四种食
  不破及无量　　无量同一业
  不见及见业　　诸佛三身成
  无有成正觉　　非一切非佛
  念念不可量　　事非事所显
  不染及至染　　并染有所依
  非染非染已　　入真正法体
  诸佛过诸阴　　住于正阴中
  彼非余非即　　彼舍中善灭
  一切是杂业　　唯离大海水
  作事竟复作　　益他无有念
  不见众生过　　如破器中月
  遍一切世间　　彼法光如日
  或时成正觉　　或涅槃如火
  无时而彼无　　诸佛常住身
  诸佛非正法　　诸人趣恶道
  非梵行法中　　真实身处行
  彼一切处行　　及以无处行
  见一切身中　　一切根无境
  除灭诸烦恼　　如咒禁毒药
  烦恼到及尽　　诸佛一切智
  烦恼到道处　　世间寂灭处
  是故大方便　　诸佛不思议

然此甚深有十二种应知。所谓生成业住甚深。差别算数业甚深。成正觉甚深。厌离甚深。灭阴甚深。教化甚深。时现甚深。成正觉示现涅槃甚深。行甚深。示现己身甚深。灭烦恼甚深。不思议甚深。义法身诸菩萨忆念诸佛时有何等念所念。略说菩萨以七种相。随念诸佛一切诸佛是得。时法自在故。修念诸佛得一切世界无障碍神通。是中说偈

  障中阙少因　　众生界中遍
  诸佛无自在　　定二随顺者

诸如来常身者。真如无间垢解脱故。诸佛如来最微恶者。远离一切烦恼智障故。诸佛自然者。自然作一切佛事无休息故。诸佛大势者。佛世界清净受大势乐故。诸佛无染者。世间生而一切世间法不能染故。诸佛如来大义者。示现成正觉及涅槃。未化众生令化。已化者为得解脱故。是中说偈

  唯在于己心　　常势净所显
  不为而大法　　报身故所得
  不急而能行　　现彼复多生
  一切一切佛　　智者彼应忆

诸佛世界清净事复云何。如佛十万偈修多罗菩萨藏序分中说。如来最光明七宝庄严。遍无量世界放大光明。无量善分别住处中间住故。不可差别界过三界境界。过出世间上善根所生善净自在识相处。如来加持处。大菩萨住处。无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人行处。大法味爱乐所润处。现一切众生作一切事处离一切烦恼所恼处离一切魔处。过一切庄严如来庄严加持处。过大念意至处。大奢摩他毗婆舍那乘处。入大空无相无愿处。无量劫庄严大莲华王处。大妙堂中住处尔。是此佛世界清净中明色世状势量。施处施因施果势。诸势伴势眷属势益势业作势润势无畏势住处势行势乘势持势门势及说家势。然彼佛世界清净中色势。一向清净一向乐一向不恶一向自在。然复彼诸佛法界一切时作五种作事应知。防护众生诸难事。见者离聋盲喑哑颠狂等诸难作事故。救济防护诸恶道作事。于不善处劝令安住善处故。无方便防难作事。诸外道无方便行解脱处。毁令住佛法故。亲同见防难作事。过三界助道行故乘防难作事。诸菩萨住异乘。及不定诸声闻令修行住大乘故。此诸五种作事中。一切诸佛等作事应知。是中说偈

  因身作事差别故　　及说诸行差别事
  彼差力故诸世间　　非彼无故诸如来

若是不共声闻缘觉。同诸佛法身成就如是功德势者。彼以何意故说为一乘。是中说偈

  别取有余者　　及持有余故
  为不定者说　　诸佛一乘理
  信于法无我　　等有性差别
  深心应化故　　尽处唯一乘

以何义故。一切诸佛如来等同法身。而说多佛事故。于中说偈

  一界无有二　　常同有作事
  次行不顺故　　释成多佛事

法身诸佛。云何不永涅槃。非不永涅槃。应知是中说偈

  远离一切障　　及作事不尽
  诸佛永已灭　　亦是不名灭

何故报身不名具真身成。有六种相故。示现色身故。及无量佛世界中分别现故。随信现故。不定见真实异种种见故。现同生事。菩萨声闻天等种种众杂见故。及阿犁耶识等转身现故。唯成报身不名真身有何义故。唯是应身不名真身。有八相故。诸菩萨远时得不动三昧。兜率天中人中生事不成。宿命知者书数算印工巧论。受欲行余事中无知不成。不善说及善说法中知已。往亲近外道处不成。善知三乘行故。苦行不成。舍百亿阎浮提一阎浮地中成正觉转轮不成。中间成正觉示方便。余处应化身作佛事。彼唯兜率天中成正觉。何故不一切阎浮提中同时成正觉事。知此知中无阿含证。复无余义可解释成。复无二佛同时一世界中现。有相违故。彼多化故。摄取四方世间。及如无二转轮圣王同时生故。是中说偈

  诸佛未应化　　同至多藏故
  一切相成觉　　见故而能行

一切众生利益事。万行修集大菩提。永入涅槃不成愿行。徒修无报故。报身应身无常故。云何诸佛常身。依常法身故。于诸因身应身报不定故。复应身者。视现功德如常受乐及如常势故。常事应知。诸佛法身虽无量无边时诸佛义处。无有假用作事。于中说偈

  诸佛德胜无异无量　　众生因弱彼不失者
  得已得彼一切无因　　有断彼不应顺成

摄大乘论卷下


摄大乘论本

    No. 1594 [Nos. 1592, 1593; cf. Nos. 1595-1598]

摄大乘论本卷上

        无著菩萨造

        三藏法师玄奘奉　诏译

    总摽纲要分第一

阿毗达磨大乘经中。薄伽梵前已能善入大乘菩萨。为显大乘体大故说。谓依大乘诸佛世尊有十相殊胜殊胜语。一者所知依殊胜殊胜语。二者所知相殊胜殊胜语。三者入所知相殊胜殊胜语。四者彼入因果殊胜殊胜语。五者彼因果修差别殊胜殊胜语。六者即于如是修差别中。增上戒殊胜殊胜语。七者即于此中增上心殊胜殊胜语。八者即于此中增上慧殊胜殊胜语。九者彼果断殊胜殊胜语。十者彼果智殊胜殊胜语。由此所说诸佛世尊契经诸句。显于大乘真是佛语

复次云何能显。由此所说十处。于声闻乘曾不见说。唯大乘中处处见说。谓阿赖耶识说名所知依体。三种自性。一依他起自性。二遍计所执自性。三圆成实自性。说名所知相体。唯识性说名入所知相体。六波罗蜜多说名彼入因果体。菩萨十地说名彼因果修差别体。菩萨律仪说名此中增上戒体。首楞伽摩虚空藏等诸三摩地说名此中增上心体。无分别智说名此中增上慧体。无住涅槃说名彼果断体。三种佛身。一自性身。二受用身。三变化身。说名彼果智体。由此所说十处。显于大乘异声闻乘。又显最胜世尊但为菩萨宣说。是故应知。但依大乘诸佛世尊有十相殊胜殊胜语复次云何由此十相殊胜殊胜如来语故。显于大乘真是佛语。遮声闻乘是大乘性。由此十处。于声闻乘曾不见说唯大乘中处处见说。谓此十处是最能引大菩提性。是善成立随顺无违。为能证得一切智智。此中二颂

  所知依及所知相　　彼入因果彼修异
  三学彼果断及智　　最上乘摄是殊胜
  此说此余见不见　　由此最胜菩提因
  故许大乘真佛语　　由说十处故殊胜

复次云何如是次第说此十处。谓诸菩萨于诸法因要先善已。方于缘起应得善巧。次后于缘所生诸法应善其相。善能远离增益损减二边过故。次后如是善修菩萨。应正通达善所取相。令从诸障心得解脱。次后通达所知相已。先加行位六波罗蜜多由证得故。应更成满增上意乐得清净故。次后清净意乐所摄六波罗蜜多。于十地中分分差别应勤修习。谓要经三无数大劫。次后于三菩萨所学应令圆满。既圆满已彼果涅槃及与无上正等菩提。应现等证故。说十处如是次第。又此说中一切大乘皆得究竟

    摄大乘论本所知依分第二

此中最初且说所知依即阿赖耶识。世尊何处说阿赖耶识名阿赖耶识。谓薄伽梵于阿毗达磨大乘经伽他中说

  无始时来界　　一切法等依
  由此有诸趣　　及涅槃证得

即于此中。复说颂曰

  由摄藏诸法　　一切种子识
  故名阿赖耶　　胜者我开示

如是且引阿笈摩证复何缘故。此识说名阿赖耶识。一切有生杂染品法。于此摄藏为果性故。又即此识于彼摄藏为因性故。是故说名阿赖耶识。或诸有情摄藏此识为自我故。是故说名阿赖耶识

复次此识亦名阿陀那识。此中阿笈摩者。如解深密经说

  阿陀那识甚深细　　一切种子如瀑流
  我于凡愚不开演　　恐彼分别执为我

何缘此识亦复说名阿陀那识。执受一切有色根故。一切自体取所依故。所以者何。有色诸根由此执受无有失坏尽寿随转。又于相续正结生时。取彼生故执受自体。是故此识亦复说名阿陀那识

此亦名心。如世尊说。心意识三此中意有二种。第一与作等无间缘所依止性。无间灭识能与意识作生依止。第二染污意与四烦恼恒共相应。一者萨迦耶见。二者我慢。三者我爱。四者无明。此即是识杂染所依。识复由彼第一依生。第二杂染了别境义故。等无间义故。思量义故。意成二种

复次云何得知有染污意。谓此若无不共无明。则不得有成过失故。又五同法亦不得有成过失故。所以者何。以五识身必有眼等俱有依故。又训释词亦不得有。成过失故。又无想定。与灭尽定差别无有成过失故。谓无想定染意所显非灭尽定。若不尔者。此二种定应无差别。又无想天一期生中应无染污。成过失故。于中若无我执我慢。又一切时我执现行。现可得故。谓善不善无记心中。若不尔者。唯不善心彼相应故。有我我所烦恼现行非善无记。是故若立俱有现行。非相应现行。无此过失。此中颂曰

  若不共无明　　及与五同法
  训词二定别　　无皆成过失
  无想生应无　　我执转成过
  我执恒随逐　　一切种无有
  离染意无有　　二三成相违
  无此一切处　　我执不应有
  真义心当生　　常能为障碍
  俱行一切分　　谓不共无明

此意染污故。有覆无记性。与四烦恼常共相应。如色无色二缠烦恼。是其有覆无记性摄。色无色缠为奢摩他所摄藏故。此意一切时微细随逐故

心体第三。若离阿赖耶识无别可得。是故成就阿赖耶识以为心体由此为种子。意及识转何因缘故亦说名心。由种种法熏习种子所积集故

复次何故声闻乘中。不说此心名阿赖耶识。名阿陀那识。由此深细境所摄故。所以者何。由诸声闻不于一切境智处转。是故于彼虽离此说然智得成。解脱成就故不为说。若诸菩萨定于一切境智处转。是故为说。若离此智不易证得一切智智

复次声闻乘中。亦以异门密意已说阿赖耶识。如彼增壹阿笈摩说。世间众生爱阿赖耶。乐阿赖耶。欣阿赖耶。喜阿赖耶。为断如是阿赖耶故。说正法时恭敬摄耳。住求解心法随法行。如来出世如是甚奇。希有正法出现世间。于声闻乘如来出现。四德经中由此异门密意已显阿赖耶识。于大众部阿笈摩中。亦以异门密意说此名根本识。如树依根。化地部中亦以异门密意说此名穷生死蕴。有处有时见色心断。非阿赖耶识中彼种有断。阿赖耶如是所知依。说阿赖耶识为性。阿陀那识为性。心为性。阿赖耶为性。根本识为性。穷生死蕴为性等。由此异门阿赖耶识成大王路。复有一类。谓心意识义一文异。是义不成意识两义差别可得。当知心义亦应有异复有一类。谓薄伽梵所说。众生爱阿赖耶。乃至广说。此中五取蕴说名阿赖耶。有余复谓。贪俱乐受名阿赖耶。有余复谓。萨迦耶见名阿赖耶。此等诸师由教及证愚于藏识故。作此执如是安立。阿赖耶名随声闻乘安立。道理亦不相应。若不愚者取此藏识安立。彼说阿赖耶名。如是安立则为最胜。云何最胜。若五取蕴名阿赖耶。生恶趣中一向苦处最可厌逆。众生一向不起爱乐。于中执藏不应道理。以彼常求速舍离故。若贪俱乐受名阿赖耶。第四静虑以上无有具。彼有情常有厌逆。于中执藏亦不应理。若萨迦耶见名阿赖耶。于此正法中信解无我者恒有厌逆。于中执藏亦不应理。阿赖耶识内我性摄。虽生恶趣一向苦处。求离苦蕴。然于藏识我爱随缚未尝求离。虽生第四静虑以上。于贪俱乐恒有厌逆。然于藏识我爱随缚。虽于此正法信解无我者厌逆我见。然于藏识我爱随缚。是故安立阿赖耶识。名阿赖耶成就最胜。如是已说阿赖耶识安立异门。安立此相云何可见。安立此相略有三种。一者安立自相。二者安立因相。三者安立果相。此中安立阿赖耶识自相者。谓依一切杂染品法。所有薰习为彼生因。由能摄持种子相应。此中安立阿赖耶识因相者。谓即如是一切种子阿赖耶识。于一切时与彼杂染品类诸法现前为因。此中安立阿赖耶识果相者。谓即依彼杂染品法无始时来所有薰习。阿赖耶识相续而生

复次何等名为薰习。薰习能诠何为所诠。谓依彼法俱生俱灭。此中有能生彼因性。是谓所诠。如苣蕂中有花薰习。苣蕂与华俱生俱灭。是诸苣蕂带能生彼香因而生。又如所立贪等行者。贪等薰习。依彼贪等俱生俱灭。此心带彼生因而生。或多闻者多闻薰习。依闻作意俱生俱灭。此心带彼记因而生。由此薰习能摄持故。名持法者。阿赖耶识薰习道理。当知亦尔

复次阿赖耶识中诸杂染品法种子。为别异住。为无别异。非彼种子有别实物。于此中住亦非不异。然阿赖耶识如是而生。有能生彼功能差别。名一切种子识

复次阿赖耶识与彼杂染诸法。同时更互为因。云何可见。譬如明灯焰炷生烧同时更互。又如芦束互相依持同时不倒。应观此中更互为因。道理亦尔。如阿赖耶识为杂染诸法因。杂染诸法亦为阿赖耶识因。唯就如是安立因缘。所余因缘不可得故

云何薰习无异无杂。而能与彼有异有杂诸法为因。如众缬具缬所缬衣。当缬之时虽复未有异杂非一品类可得。入染器后尔时衣上便有异杂非一品类。染色绞络文像显现。阿赖耶识亦复如是。异杂能薰之所薰习。于薰习时虽复未有异杂可得。果生染器现前已后。便有异杂无量品类。诸法显现如是缘起。于大乘中极细甚深。又若略说有二缘起。一者分别自性缘起。二者分别爱非爱缘起。此中依止阿赖耶识诸法生起是名分别自性缘起。以能分别种种自性为缘性故。复有十二支缘起。是名分别爱非爱缘起。以于善趣恶趣能分别爱非爱种种自体为缘性故。于阿赖耶识中。若愚第一缘起。或有分别自性为因。或有分别宿作为因。或有分别自在变化为因。或有分别实我为因。或有分别无因无缘。若愚第二缘起。复有分别。我为作者。我为受者。譬如众多生盲士夫未曾见象。复有以象说而示之。彼诸生盲有触象鼻。有触其牙。有触其耳。有触其足。有触其尾。有触脊[月*梁]。诸有问言。象为何相。或有说言象如犁柄。或说如杵。或说如箕。或说如臼。或说如帚。或有说言象如石山。若不解了此二缘起。无明生盲亦复如是。或有计执自性为因。或有计执宿作为因。或有计执自在为因。或有计执实我为因。或有计执无因无缘。或有计执我为作者我为受者。阿赖耶识自性因性及果性等。如所不了象之自性

又若略说阿赖耶识用异熟识。一切种子为其自性。能摄三界一切自体一切趣等

此中五颂

  外内不明了　　于二唯世俗
  胜义诸种子　　当知有六种
  刹那灭俱有　　恒随转应知
  决定待众缘　　唯能引自果
  坚无记可熏　　与能熏相应
  所熏非异此　　是为熏习相
  六识无相应　　三差别相违
  二念不俱有　　类例余成失
  此外内种子　　能生引应知
  枯丧由能引　　任运后灭故

为显内种非如外种。复说二颂

  外或无熏习　　非内种应知
  闻等熏习无　　果生非道理
  作不作失得　　过故成相违
  外种内为缘　　由依彼熏习

复次其余转识。普于一切自体诸趣。应知说名能受用者。如中边分别论中说。伽他曰

  一则名缘识　　第二名受者
  此中能受用　　分别推心法

如是二识更互为缘。如阿毗达磨大乘经中说。伽他曰

  诸法于识藏　　识于法亦尔
  更互为果性　　亦常为因性

若于第一缘起中。如是二识互为因缘。于第二缘起中。复是何缘是增上缘。如是六识几缘所生。增上所缘等无间缘。如是三种缘起。谓穷生死爱非爱趣。及能受用具有四缘。如是已安立阿赖耶识异门及相。复云何知如是异门。及如是相决定唯在阿赖耶识。非于转识。由若远离如是安立阿赖耶识。杂染清净皆不得成。谓烦恼杂染。若业杂染。若生杂染。皆不成故。世间清净出世清净。亦不成故。云何烦恼杂染不成。以诸烦恼及随烦恼熏习所作。彼种子体于六识身不应理故。所以者何。若立眼识贪等烦恼及随烦恼俱生俱灭。此由彼熏成种非余。即此眼识若已谢灭。余识所间如是熏习。熏习所依皆不可得。从此先灭余识所间现无有体。眼识与彼贪等俱生。不应道理。以彼过去现无体故。如从过去现无体业。异熟果生不应道理。又此眼识贪等俱生。所有熏习亦不成就。然此熏习不住贪中。由彼贪欲是能依故。不坚住故。亦不得住所余识中。以彼诸识所依别故。又无决定俱生灭故。亦复不得住自体中。由彼自体决定无有俱生灭故。是故眼识贪等烦恼。及随烦恼之所熏习不应道理。又复此识非识所熏。如说眼识所余转识亦复如是。如应当知

复次从无想等上诸地没来生此间。尔时烦恼及随烦恼所染初识。此识生时应无种子。由所依止及彼熏习并已过去。现无体故

复次对治烦恼识。若已生一切世间余识已灭。尔时若离阿赖耶识。所余烦恼及随烦恼种子。在此对治识中不应道理。此对治识自性解脱故。与余烦恼及随烦恼不俱生灭故。复于后时世间识生。尔时若离阿赖耶识。彼诸熏习及所依止久已过去。现无体故。应无种子而更得生。是故若离阿赖耶识。烦恼杂染皆不得成

云何为业杂染不成。行为缘识不相应故。此若无者。取为缘有亦不相应

云何为生杂染不成。结相续时不相应故。若有于此非等引地没已生时。依中有位意起染污意识结生相续。此染污意识于中有中灭。于母胎中识羯罗蓝更相和合。若即意识与彼和合。既和合已依止此识。于母胎中有意识转。若尔即应有二意识于母胎中同时而转。又即与彼和合之识是意识性。不应道理。依染污故。时无断故。意识所缘不可得故。设和合识即是意识。为此和合意识。即是一切种子识为依止。此识所生余意识。是一切种子识。若此和合识是一切种子识。即是阿赖耶识。汝以异名立为意识。若能依止识。是一切种子识。是则所依因识。非一切种子识能依果识是一切种子识。不应道理。是故成就此和合识非是意识。但是异熟识。是一切种子识

复次结生相续已。若离异熟识。执受色根亦不可得。其余诸识各别依故。不坚住故。是诸色根不应离识

若离异熟识。识与名色更互相依。譬如芦束相依而转。此亦不成

若离异熟识。已生有情识食不成。何以故。以六识中随取一识。于三界中已生有情。能作食事不可得故

若从此没于等引地正受生时。由非等引染污意识结生相续。此非等引染污之心。彼地所摄离异熟识。余种子体定不可得

复次生无色界。若离一切种子异熟识。染污善心应无种子。染污善心应无依持

又即于彼若出世心正现在前。余世间心皆灭尽故。尔时便应灭离彼趣。若生非想非非想处无所有处。出世间心现在前时。即应二趣悉皆灭离。此出世识不以非想非非想处为所依趣。亦不应以无所有处为所依趣。亦非涅槃为所依趣

又将没时造善造恶。或下或上所依渐冷。若不信有阿赖耶识皆不得成。是故若离一切种子异熟识者。此生杂染亦不得成

云何世间清净不成。谓未离欲缠贪。未得色缠心者。即以欲缠善心为离欲缠贪故勤修加行。此欲缠加行心与色缠心不俱生灭故。非彼所熏。为彼种子不应道理。又色缠心过去多生。余心间隔不应为今定心种子。唯无有故。是故成就色缠定心一切种子异熟果识。展转传来为今因缘。加行善心为增上缘。如是一切离欲地中如应当知。如是世间清净。若离一切种子异熟识。理不得成

云何出世清净不成。谓世尊说。依他言音及内各别如理作意。由此为因正见得生。此他言音如理作意。为熏耳识。为熏意识。为两俱熏。若于彼法如理思惟。尔时耳识且不得起。意识亦为种种散动余识所间。若与如理作意相应生时。此闻所熏意识与彼熏习。久灭过去定无有体。云何复为种子能生后时如理作意相应之心。又此如理作意相应是世间心。彼正见相应是出世心。曾未有时俱生俱灭。是故此心非彼所熏。既不被熏。为彼种子不应道理。是故出世清净。若离一切种子异熟果识。亦不得成。此中闻熏习摄受。彼种子不相应故

复次云何一切种子异熟果识为杂染因。复为出世能对治。彼净心种子又出世心。昔未曾习故。彼熏习决定应无。既无熏习从何种生。是故应答。从最清净法界等流。正闻熏习种子所生

此闻熏习为是阿赖耶识自性。为非阿赖耶识自性。若是阿赖耶识自性。云何是彼对治种子。若非阿赖耶识自性。此闻熏习种子所依。云何可见。乃至证得诸佛菩提。此闻熏习随在一种所依转处。寄在异熟识中。与彼和合俱转。犹如水乳。然非阿赖耶识是彼对治种子性故。此中依下品熏习成中品熏习。依中品熏习成上品熏习。依闻思修多分修作得相应故。又此正闻熏习种子下中上品。应知亦是法身种子。与阿赖耶识相违。非阿赖耶识所摄。是出世间最净法界等流性故。虽是世间而是出世心种子性。又出世心虽未生时。已能对治诸烦恼缠。已能对治诸崄恶趣。已作一切所有恶业朽坏对治。又能随顺逢事一切诸佛菩萨。虽是世间应知初修业菩萨所得。亦法身摄声闻独觉所得。唯解脱身摄。又此熏习非阿赖耶识。是法身解脱身摄。如如熏习下中上品次第渐增。如是如是。异熟果识次第渐减即转所依。既一切种所依转已。即异熟果识。及一切种子。无种子而转。一切种永断

复次云何犹如水乳。非阿赖耶识与阿赖耶识同处俱转。而阿赖耶识一切种尽。非阿赖耶识一切种增。譬如于水鹅所饮乳。又如世间得离欲时。非等引地熏习渐减。其等引地熏习渐增而得转依

又入灭定识不离身。圣所说故。此中异熟识应成不离身。非为治此灭定生故

又非出定此识复生。由异熟识既间断已离结相续无重生故

又若有执以意识故。灭定有心。此心不成定。不应成故。所缘行相不可得故。应有善根相应过故。不善无记不应理故。应有想受现行过故。触可得故。于三摩地有功能故。应有唯灭想过失故。应有其思信等善根现行过故。拔彼能依令离所依。不应理故。有譬喻故。如非遍行此不有故

又此定中由意识故。执有心者。此心是善不善无记。皆不得成故不应理。若复有执色心无间生。是诸法种子此不得成。如前已说。又从无色无想天没。灭定等出不应道理。又阿罗汉后心不成。唯可容有等无间缘

如是若离一切种子异熟果识。杂染清净皆不得成。是故成就如前所说相。阿赖耶识决定是有

此中三颂

  菩萨于净心　　远离于五识
  无余心转依　　云何汝当作
  若对治转依　　非断故不成
  果因无差别　　于永断成过
  无种或无体　　若许为转依
  无彼二无故　　转依不应理

复次此阿赖耶识差别云何。略说应知。或三种或四种。此中三种者。谓三种熏习差别故。一名言熏习差别。二我见熏习差别。三有支熏习差别。四种者。一引发差别。二异熟差别。三缘相差别。四相貌差别

此中引发差别者。谓新起熏习。此若无者。行为缘识。取为缘有。应不得成。此中异熟差别者。谓行有为缘。于诸趣中异熟差别。此若无者则无种子。后有诸法生应不成。此中缘相差别者。谓即意中我执缘相。此若无者。染污意中我执所缘应不得成

此中相貌差别者。谓即此识有共相。有不共相。无受生种子相。有受生种子相等。共相者。谓器世间种子。不共相者。谓各别内处种子。共相即是无受生种子。不共相即是有受生种子。对治生时唯不共相。所对治灭共相。为他分别所持但见清净。如瑜伽师。于一物中种种胜解种种所见皆得成立。此中二颂

  难断难遍知　　应知名共结
  瑜伽者心异　　由外相大故
  净者虽不灭　　而于中见净
  又清净佛土　　由佛见清净

复有别颂。对前所引种种胜解种种所见皆得成立

  诸瑜伽师于一物　　种种胜解各不同
  种种所见皆得成　　故知所取唯有识

此若无者。诸器世间有情世间生起差别应不得成

复有粗重相及轻安相。粗重相者。谓烦恼随烦恼种子。轻安相者谓有漏善法种子。此若无者。所感异熟无所堪能。有所堪能所依差别应不得成。复有有受尽相无受尽相。有受尽相者。谓已成熟异熟果善不善种子。无受尽相者。谓名言熏习种子。无始时来种种戏论流转种子故。此若无者。已作已作善恶二业。与果受尽应不得成。又新名言熏习生起应不得成。复有譬喻相。谓此阿赖耶识。幻炎梦翳为譬喻故。此若无者。由不实遍计种子故。颠倒缘相应不得成。复有具足相不具足相。谓诸具缚者名具足相。世间离欲者名损减相。有学声闻及诸菩萨名一分永拔相。阿罗汉独觉及诸如来名烦恼障全永拔相。及烦恼所知障全永拔相。如其所应。此若无者。如是次第杂染还灭应不得成

何因缘故。善不善法能感异熟。其异熟果无覆无记。由异熟果无覆无记。与善不善互不相违。善与不善互相违故。若异熟果善不善性。杂染还灭应不得成。是故异熟识唯无覆无记

摄大乘论本卷上摄大乘论本卷中

        无著菩萨造

        三藏法师玄奘奉　诏译

    所知相分第三

已说所知依所知相。复云何应观此。略有三种。一依他起相。二遍计所执相。三圆成实相。此中何者依他起相。谓阿赖耶识为种子。虚妄分别所摄诸识。此复云何。谓身身者受者识。彼所受识。彼能受识。世识。数识。处识。言说识。自他差别识。善趣恶趣死生识。此中若身身者受者识彼所受识彼能受识世识数识处识言说识。此由名言熏习种子。若自他差别识。此由我见熏习种子。若善趣恶趣死生识。此由有支熏习种子。由此诸识一切界趣杂染所摄。依他起相虚妄分别皆得显现。如此诸识皆是虚妄分别所摄。唯识为性是无所有。非真实义显现所依。如是名为依他起相

此中何者遍计所执相。谓于无义唯有识中似义显现

此中何者圆成实相。谓即于彼依他起相。由似义相永无有性

此中身身者受者识。应知即是眼等六内界。彼所受识。应知即是色等六外界。彼能受识。应知即是眼等六识界。其余诸识。应知是此诸识差别

又此诸识皆唯有识都无义故。此中以何为喻显示。应知梦等为喻显示。谓如梦中都无其义。独唯有识。虽种种色声香味触舍林地山似义影现。而于此中都无有义。由此喻显。应随了知一切时处皆唯有识。由此等言。应知复有幻诳鹿爱翳眩等喻若于觉时一切时处皆如梦等唯有识者。如从梦觉便觉梦中皆唯有识。觉时何故不如是转。真智觉时亦如是转。如在梦中此觉不转。从梦觉时此觉乃转。如是未得真智觉时此觉不转。得真智觉此觉乃转

其有未得真智觉者。于唯识中云何比知。由教及理应可比知。此中教者。如十地经薄伽梵说。如是三界皆唯有心。又薄伽梵解深密经亦如是说。谓彼经中慈氏菩萨。问世尊言。诸三摩地所行影像。彼与此心当言有异。当言无异。佛告慈氏。当言无异。何以故。由彼影像唯是识故。我说识所缘唯识所现故。世尊。若三摩地所行影像。即与此心无有异者。云何此心还取此心。慈氏。无有少法能取少法。然即此心如是生时。即有如是影像显现。如质为缘还见本质。而谓我今见于影像。及谓离质别有所见。影像显现此心亦尔。如是生时相似有异所见影现。即由此教理亦显现。所以者何。于定心中随所观见。诸青瘀等所知影像一切无别。青瘀等事但见自心。由此道理菩萨于其一切识中应可比知。皆唯有识无有境界。又于如是青瘀等中非忆持识。见所缘境现前住故。闻思所成二忆持识。亦以过去为所缘故。所现影像得成唯识。由此比量菩萨虽未得真智觉。于唯识中应可比知

如是已说种种诸识如梦等喻。即于此中眼识等识可成唯识。眼等诸识既是有色。亦唯有识云何可见。此亦如前由教及理。若此诸识亦体是识。何故乃似色性显现。一类坚住相续而转。与颠倒等诸杂染法为依处故。若不尔者。于非义中起义颠倒应不得有。此若无者。烦恼所知二障杂染应不得有。此若无者。诸清净法亦应无有。是故诸识应如是转。此中有颂

  乱相及乱体　　应许为色识
  及与非色识　　若无余亦无

何故身身者受者识所受识能受识。于一切身中俱有和合转。能圆满生受用所显故。何故如说世等诸识差别而转。无始时来生死流转无断绝故。诸有情界无数量故。诸器世界无数量故。诸所作事展转言说无数量故。各别摄取受用差别无数量故。诸爱非爱业果异熟受用差别无数量故。所受死生种种差别无数量故

复次云何安立如是诸识成唯识性。略由三相。一由唯识无有义故。二由二性有相有见二识别故。三由种种种种行相而生起故。所以者何。此一切识无有义故得成唯识。有相见故得成二种。若眼等识以色等识为相以眼识识为见。乃至以身识识为见。若意识以一切眼为最初法为最后。诸识为相。以意识识为见。由此意识有分别故。似一切识而生起故。此中有颂

  唯识二种种　　观者意能入
  由悟入唯心　　彼亦能伏离

又于此中有一类师说一意识。彼彼依转得彼彼名。如意思业名身语业。又于一切所依转时。似种种相二影像转。谓唯义影像及分别影像。又一切处亦似所触影像而转。有色界中即此意识依止身故。如余色根依止于身

此中有颂

  若远行独行　　无身寐于窟
  调此难调心　　我说真梵志

又如经言。如是五根所行境界。意各能受意为彼依

又如所说十二处中。说六识身皆名意处。若处安立阿赖耶识识为义识。应知此中余一切识是其相识。若意识识及所依止是其见识。由彼相识是此见识生缘相故。似义现时能作见识生依止事。如是名为安立诸识成唯识性

诸义现前分明显现。而非是有云何可知。如世尊言。若诸菩萨成就四法能随悟入。一切唯识都无有义。一者成就相违识相智。如饿鬼傍生及诸天人同于一事。见彼所识有差别故。二者成就无所缘识现可得智。如过去未来梦影缘中有所得故。三者成就应离功用无颠倒智。如有义中能缘义识应无颠倒。不由功用智真实故。四者成就三种胜智随转妙智。何等为三。一得心自在一切菩萨得静虑者。随胜解力诸义显现。二得奢摩他修法观者。才作意时诸义显现。三已得无分别智者。无分别智现在前时。一切诸义皆不显现。由此所说三种胜智随转妙智。及前所说三种因缘诸义无义道理成就

若依他起自性实唯有识。似义显现之所依止。云何成依他起。何因缘故名依他起。从自熏习熏子所生。依他缘起故名依他起。生刹那后无有功能。自然住故名依他起

若遍计所执自性。依依他起实无所有似义显现。云何成遍计所执。何因缘故名遍计所执。无量行相意识遍计颠倒生相故。名遍计所执。自相实无唯有遍计所执可得。是故说名遍计所执

若圆成实自性。是遍计所执永无有相。云何成圆成实。何因缘故名圆成实。由无变异性故。名圆成实。又由清净所缘性故。一切善法最胜性故。由最胜义名圆成实

复次有能遍计有所遍计。遍计所执自性乃成。此中何者能遍计。何者所遍计。何者遍计所执自性。当知意识是能遍计。有分别故。所以者何。由此意识用自名言熏习为种子。及用一切识名言熏习为种子。是故意识无边行相分别而转。普于一切分别计。度故名遍计。又依他起自性名所遍计。又若由此相令依他起自性成所遍计。此中是名遍计所执自性。由此相者是如此义。复次云何遍计能遍计度。缘何境界。取何相貌。由何执着。由何起语。由何言说。何所增益。谓缘名为境。于依他起自性中取彼相貌。由见执着。由寻起语。由见闻等四种言说而起言说。于无义中增益为有。由此遍计能遍计度

复次此三自性为异为不异。应言非异非不异。谓依他起自性由异门故。成依他起。即此自性由异门故。成遍计所执。即此自性由异门故。成圆成实。由何异门此依他起成依他起。依他熏习种子起故。由何异门即此自性成遍计所执。由是遍计所缘相故。又是遍计所遍计故。由何异门即此自性成圆成实。如所遍计毕竟不如是有故

此三自性各有几种。谓依他起略有二种。一者依他熏习种子而生起故。二者依他杂染清净性不成故。由此二种依他别故。名依他起。遍计所执亦有二种。一者自性遍计执故。二者差别遍计执故。由此故名遍计所执。圆成实性亦有二种。一者自性圆成实故。二者清净圆成实故。由此故成圆成实性

复次遍计有四种。一自性遍计。二差别遍计。三有觉遍计。四无觉遍计。有觉者。谓善名言。无觉者。谓不善名言。如是遍计复有五种。一依名遍计义自性。谓如是名有如是义。二依义遍计名自性。谓如是义有如是名。三依名遍计名自性。谓遍计度未了义。名四依义遍计义自性。谓遍计度未了名义。五依二遍计二自性。谓遍计度此名此义如是体性

复次总摄一切分别略有十种。一根本分别谓阿赖耶识。二缘相分别。谓色等识。三显相分别。谓眼识等并所依识。四缘相变异分别。谓老等变异。乐受等变异。贪等变异。逼害时节代谢等变异。奈落迦等诸趣变异。及欲界等诸界变异。五显相变异分别。谓即如前所说变异所有变异。六他引分别。谓闻非正法类及闻正法类分别。七不如理分别。谓诸外道闻非正法类分别。八如理分别。谓正法中闻正法类分别。九执着分别。谓不如理作意类。萨迦耶见为本。六十二见趣相应分别。十散动分别。谓诸菩萨十种分别。一无相散动。二有相散动。三增益散动。四损减散动。五一性散动。六异性散动。七自性散动。八差别散动。九如名取义散动。十如义取名散动。为对治此十种散动。一切般若波罗蜜多中说无分别智。如是所治能治应知。具摄般若波罗蜜多义

若由异门依他起自性有三自性。云何三自性不成无差别。若由异门成依他起。不即由此成遍计所执及圆成实。若由异门成遍计所执。不即由此成依他起及圆成实。若由异门成圆成实不即由此成依他起及遍计所执

复次云何得知。如依他起自性遍计所执。自性显现而非称体。由名前觉无称体相违故。由名有众多多体相违故。由名不决定杂体相违故。此中有二颂

  由名前觉无　　多名不决定
  成称体多体　　杂体相违故
  法无而可得　　无染而有净
  应知如幻等　　亦复似虚空

复次何故如所显现实无所有。而依他起自性非一切。一切都无所有。此若无者。圆成实自性亦无所有。此若无者。则一切皆无。若依他起及圆成实自性无有。应成无有染净过失。既现可得杂染清净。是故不应一切皆无此中有颂

  若无依他起　　圆成实亦无
  一切种若无　　恒时无染净

诸佛世尊于大乘中说方广教。彼教中言。云何应知遍计所执自性。应知异门说无所有。云何应知依他起自性。应知譬如幻炎梦像光影谷响水月变化。云何应知圆成实自性。应知宣说四清净法。何等名为四清净法。一者自性清净。谓真如空实际无相胜义法界。二者离垢清净。谓即此离一切障垢。三者得此道清净。谓一切菩提分法波罗蜜多等。四者生此境清净。谓诸大乘妙正法教由此法教清净缘故。非遍计所执自性。最净法界等流性故。非依他起自性。如是四法总摄一切清净法尽。此中有二颂

  幻等说于生　　说无计所执
  若说四清净　　是谓圆成实
  自性与离垢　　清净道所缘
  一切清净法　　皆四相所摄

复次何缘。如经所说。于依他起自性说幻等喻。于依他起自性为除他虚妄疑故。他复云何。于依他起自性有虚妄疑。由他于此有如是疑。云何实无有义而成所行境界。为除此疑说幻事喻。云何无义心心法转。为除此疑说阳炎喻。云何无义有爱非爱受用差别。为除此疑说所梦喻。云何无义净不净业爱非爱果差别而生。为除此疑说影像喻。云何无义种种识转。为除此疑说光影喻。云何无义种种戏论言说而转。为除此疑说谷响喻。云何无义而有实取诸三摩地所行境转。为除此疑说水月喻。云何无义有诸菩萨无颠倒心。为办有情诸利乐事故思受生。为除此疑说变化喻。世尊依何密意。于梵问经中说。如来不得生死不得涅槃。于依他起自性中。依遍计所执自性及圆成实自性。生死涅槃无差别密意。何以故。即此依他起自性。由遍计所执分成生死。由圆成实分成涅槃故

阿毗达摩大乘经中。薄伽梵说法有三种。一杂染分。二清净分。三彼二分。依何密意作如是说。于依他起自性中遍计所执自性是杂染分。圆成实自性是清净分。即依他起是彼二分。依此密意作如是说。于此义中以何喻显。以金土藏为喻显示。譬如世间金土藏中三法可得。一地界二土三金。于地界中土非实有而现可得。金是实有而不可得。火烧炼时土相不现金相显现。又此地界土显现时虚妄显现。金显现时真实显现。是故地界是彼二分。识亦如是。无分别智火未烧时。于此识中所有虚妄。遍计所执自性显现。所有真实圆成实自性不显现。此识若为无分别智火所烧时。于此识中所有真实圆成实自性显现。所有虚妄遍计所执自性不显现。是故此虚妄分别识依他起自性有彼二分。如金土藏中所有地界

世尊有处说一切法常。有处说一切法无常。有处说一切法非常非无常。依何密意作如是说。谓依他起自性由圆成实性分是常。由遍计所执性分是无常。由彼二分非常非无常。依此密意作如是说。如常无常无二。如是苦乐无二。净不净无二。空不空无二。我无我无二。寂静不寂静无二。有自性无自性无二。生不生无二。灭不灭无二。本来寂静非本来寂静无二。自性涅槃非自性涅槃无二。生死涅槃无二亦尔。如是等差别。一切诸佛密意语言。由三自性应随决了。如前说常无常等门。此中有多颂

  如法实不有　　如现非一种
  非法非非法　　故说无二义
  依一分开显　　或有或非有
  依二分说言　　非有非非有
  如显现非有　　是故说为无
  由如是显现　　是故说为有
  自然自体无　　自性不坚住
  如执取不有　　故许无自性
  由无性故成　　后后所依止
  无生灭本寂　　自性般涅槃

复有四种意趣四种秘密。一切佛言应随决了。四意趣者。一平等意趣。谓如说言。我昔曾于彼时彼分即名胜观正等觉者。二别时意趣。谓如说言。若诵多宝如来名者。便于无上正等菩提已得决定。又如说言。由唯发愿便得往生极乐世界。三别义意趣谓如说言。若已逢事尔所殑伽河沙等佛。于大乘法方能解义。四补特伽罗意乐意趣。谓如为一补特伽罗先赞布施后还毁訾。如于布施如是尸罗及一分修当知亦尔。如是名为四种意趣。四秘密者。一令入秘密。谓声闻乘中或大乘中。依世俗谛理说有补特伽罗及有诸法自性差别。二相秘密。谓于是处说诸法相显三自性。三对治秘密。谓于是处说行对治八万四千。四转变秘密谓于是处以其别义诸言诸字即显别义。如有颂言

  觉不坚为坚　　善住于颠倒
  极烦恼所恼　　得最上菩提

若有欲造大乘法释。略由三相应造其释。一者由说缘起。二者由说从缘所生法相。三者由说语义。此中说缘起者。如说

  言熏习所生　　诸法此从彼
  异熟与转识　　更互为缘生

复次彼转识相法。有相有见识为自性。又彼以依处为相。遍计所执为相。法性为相。由此显示三自性相。如说

  从有相有见　　应知彼三相

复次云何应释彼相。谓遍计所执相于依他起相中实无所有。圆成实相于中实有。由此二种非有及有非得及得未见已见。真者同时。谓于依他起。自性中无遍计所执故。有圆成实故。于此转时若得彼即不得。此若得此即不得。彼如说

  依他所执无　　成实于中有
  故得及不得　　其中二平等

说语义者。谓先说初句后以余句分别显示。或由德处。或由义处

由德处者。谓说佛功德最清净觉不切佛平等性到无障处。不可转法所行无碍。其所安立不可思议。游于三世平等法性。其身流布一切世界。于一切法智无疑滞。于一切行成就大觉。于诸法智无有疑惑。凡所现身不可分别。一切菩萨等所求智。得佛无二住胜彼岸。不相间杂如来解脱。妙智究竟证无中边。佛地平等极于法界。尽虚空性穷未来际。最清净觉者应知。此句由所余句分别显示。如是乃成善说法性

最清净觉者。谓佛世尊最清净觉。应知是佛二十一种功德所摄谓于所知一向无障转功德。于有无无二相真如最胜清净能入功德。无功用佛事不休息住功德。于法身中所依意乐作业无差别功德。修一切障对治功德。降伏一切外道功德。生在世间不为世法所碍功德。安立正法功德。授记功德。于一切世界示现受用变化身功德。断疑功德。令入种种行功德。当来法生妙智功德。如其胜解示现功德。无量所依调伏有情加行功德。平等法身波罗蜜多成满功德。随其胜解示现差别佛土功德。三种佛身方处无分限功德。穷生死际常现利益安乐一切有情功德。无尽功德等。复次由义处者如说。若诸菩萨成就三十二法乃名菩萨。谓于一切有情起利益安乐增上意乐故。令入一切智智故。自知我今何假智故。摧伏慢故。坚牢胜意乐故。非假怜愍故。于亲非亲平等心故。永作善友乃至涅槃为后边故。应量而语故。含笑先言故。无限大悲故。于所受事无退弱故。无厌倦意故。闻义无厌故。于自作罪深见过故。于他作罪不嗔而诲故。于一切威仪中恒修治菩提心故。不悕异熟而行施故。不依一切有趣受持戒故。于诸有情无有恚碍而行忍故。为欲摄受一切善法勤精进故。舍无色界修静虑故。方便相应修般若故。由四摄事摄方便故。于持戒破戒善友无二故。以殷重心听闻正法故。以殷重心住阿练若故。于世杂事不爱乐故。于下劣乘曾不欣乐故。于大乘中深见功德故。远离恶友故。亲近善友故。恒修治四梵住故。常游戏五神通故。依趣智故。于住正行不住正行诸有情类不弃舍故。言决定故。重谛实故。大菩提心恒为首故。如是诸句应知皆是初句差别。谓于一切有情起利益安乐增上意乐。此利益安乐增上意乐句有十六业差别。应知此中十六业者。一展转加行业。二无颠倒业。三不待他请自然加行业。四不动坏业。五无求染业。此有三句差别应知。谓无染系故。于恩非恩无爱恚故。于生生中恒随转故。六相称语身业。此有二句差别应知。七于乐于苦于无二中平等业。八无下劣业。九无退转业。十摄方便业。十一厌恶所治业。此有二句差别应知。十二无间作意业。十三胜进行业。此有七句差别应知。谓六波罗蜜多正加行故。及四摄事正加行故。十四成满加行业。此有六句差别应知谓亲近善士故。听闻正法故。住阿练若故。离恶寻思故。作意功德故。此复有二句差别应知。助伴功德故。此复有二句差别应知。十五成满业。此有三句差别应知。谓无量清净故。得大威力故。证得功德故。十六安立彼业。此有四句差别应知。谓御众功德故。决定无疑教授教诫故。财法摄一故。无杂染心故。如是诸句应知。皆是初句差别。如说

  由最初句故　　句别德种类
  由最初句故　　句别义差别

    摄大乘论本入所知相分第四

如是已说所知相。入所知相云何。应见多闻熏习所依。非阿赖耶识所摄。如阿赖耶识成种子。如理作意所摄。似法似义而生似所取事。有见意言

此中谁能悟入所应知相大乘多闻熏习相续。已得逢事无量诸佛出现于世。已得一向决定胜解。已善积集诸善根故。善备福智资粮菩萨

何处能入。谓即于彼有见似法似义意言。大乘法相等所生起胜解行地。见道修道究竟道中。于一切法唯有识性。随闻胜解故。如理通达故。治一切障故。离一切障故

由何能入。由善根力所住持故。谓三种相练磨心故。断四处故。缘法义境止观恒常殷重加行无放逸故

无量诸世界无量人有情刹那刹那证觉无上正等菩提。是为第一练磨其心。由此意乐能行施等波罗蜜多。我已获得如是意乐。我由此故。少用功力修习施等波罗蜜多当得圆满。是为第二练磨其心。若有成就诸有障善。于命终时即便可爱一切自体圆满而生。我有妙善无障碍善。云何尔时不当获得一切圆满是名第三练磨其心

此中有颂

  人趣诸有情　　处数皆无量
  念念证等觉　　故不应退屈
  诸净心意乐　　能修行施等
  此胜者已得　　故能修施等
  善者于死时　　得随乐自满
  胜善由永断　　圆满云何无

由离声闻独觉作意断作意故。由于大乘诸疑离疑。以能永断异慧疑故。由离所闻所思法中我我所执断法执故。由于现前现住安立一切相中。无所作意无所分别断分别故

此中有颂

  现前自然住　　安立一切相
  智者不分别　　得最上菩提

由何云何而得悟入

由闻熏习种类。如理作意所摄似法似义有见意言

由四寻思。谓由名义自性差别假立寻思。及由四种如实遍智。谓由名事自性差别。假立如实遍智。如是皆同不可得故。以诸菩萨如是如实。为入唯识勤修加行。即于似文似义意言。推求文名唯是意言。推求依此文名之义亦唯意言。推求名义自性差别唯是假立。若时证得唯有意言。尔时证知若名若义自性差别皆是假立。自性差别义相无故。同不可得。由四寻思及由四种如实遍智。于此似文似义意言。便能悟入唯有识性

于此悟入唯识性中。何所悟入。如何悟入。入唯识性相见二性及种种性。若名若义自性差别假。自性差别义。如是六种义皆无故。所取能取性现前故。一时现似种种相义而生起故。如闇中绳显现似蛇。譬如绳上蛇非真实。以无有故。若已了知彼义无者。蛇觉虽灭绳觉犹在。若以微细品类分析此又虚妄。色香味触为其相故。此觉为依绳觉当灭。如是于彼似文似义六相意言。伏除非实六相义时。唯识性觉。犹如蛇觉亦当除遣。由圆成实自性觉故

如是菩萨悟入意言似义相故。悟入遍计所执性悟入唯识故。悟入依他起性。云何悟入圆成实性。若已灭除意言闻法熏习种类唯识之想。尔时菩萨已遣义想。一切似义无容得生故。似唯识亦不得生。由是因缘住一切义无分别名。于法界中便得现见相应而住。尔时菩萨平等平等所缘能缘。无分别智已得生起。由此菩萨名已悟入圆成实性

此中有颂

  法补特伽罗　　法义略广性
  不净净究竟　　名所行差别

如是菩萨悟入唯识性故。悟入所知相。悟入此故入极喜地。善达法界生如来家。得一切有情平等心性。得一切菩萨平等心性。得一切佛平等心性。此即名为菩萨见道

复次为何义故入唯识性。由缘总法出世止观智故。由此后得种种相识智故。为断及相阿赖耶识诸相种子。为长能触法身种子。为转所依。为欲证得一切佛法。为欲证得一切智智入唯识性。又后得智于一切阿赖耶识所生一切了别相中。见如幻等性无倒转。是故菩萨譬如幻师。于所幻事于诸相中。及说因果常无颠倒

于此悟入唯识性时。有四种三摩地。是四种顺决择分依止。云何应知。应知由四寻思于下品无义忍中有明得三摩地。是暖顺决择分依止。于上品无义忍中有明增三摩地。是顶顺决择分依止。复由四种如实遍智已入唯识。于无义中已得决定。有入真义一分三摩地。是谛顺忍依止。从此无间伏唯识想。有无间三摩地。是世第一法依止。应知如是诸三摩地。是现观边

如是菩萨已入于地。已得见道。已入唯识。于修道中云何修行。于如所说安立十地摄一切经皆现前中。由缘总法出世后得止观智故。经于无量百千俱胝那庾多劫。数修习故而得转依。为欲证得三种佛身精勤修行。声闻现观菩萨现观有何差别。谓菩萨现观与声闻异。由十一种差别应知。一由所缘差别。以大乘法为所缘故。二由资持差别。以大福智二种资粮为资持故。三由通达差别。以能通达补特伽罗法无我故。四由涅槃差别。摄受无住大涅槃故。五由地差别。依于十地而出离故。六七由清净差别。断烦恼习净佛土故。八由于自他得平等心差别。成熟有情加行无休息故。九由生差别。生如来家故。十由受生差别。常于诸佛大集会中摄受生故。十一由果差别。十力无畏不共佛法无量功德果成满故

此中有二颂

  名事互为客　　其性应寻思
  于二亦当推　　唯量及唯假
  实智观无义　　唯有分别三
  彼无故此无　　是即入三性

复有教授二颂。如分别瑜伽论说

  菩萨于定位　　观影唯是心
  义相既灭除　　审观唯自想
  如是住内心　　知所取非有
  次能取亦无　　后触无所得

复有别五现观伽他。如大乘经庄严论说

  福德智慧二资粮　　菩萨善备无边际
  于法思量善决已　　故了义趣唯言类
  若知诸义唯是言　　即住似彼唯心理
  便能现证真法界　　是故二相悉蠲除
  体知离心无别物　　由此即会心非有
  智者了达二皆无　　等住二无真法界
  慧者无分别智力　　周遍平等常顺行
  灭依榛梗过失聚　　如大良药销众毒
  佛说妙法善成立　　安慧并根法界中
  了知念趣唯分别　　勇猛疾归德海岸

    摄大乘论本彼入因果分第五

如是已说入所知相。彼入因果云何可见。谓由施戒忍精进静虑般若六种波罗蜜多。云何由六波罗蜜多得入唯识。复云何六波罗蜜多成彼入果。谓此菩萨不着财位。不犯尸罗。于苦无动。于修无懈。于如是等散动因中。不现行时心专一境。便能如理简择诸法得入唯识。菩萨依六波罗蜜多入唯识已。证得六种清净增上意乐所摄波罗蜜多。是故于此设离六种波罗蜜多现起加行。由于圣教得胜解故。及由爱重随喜欣乐诸作意故。恒常无间相应方便修习六种波罗蜜多速得圆满

此中有三颂

  已圆满白法　　及得利疾忍
  菩萨于自乘　　甚深广大教
  等觉唯分别　　得无分别智
  悕求胜解净　　故意乐清净
  前及此法流　　皆得见诸佛
  了知菩提近　　以无难得故

由此三颂总显清净增上意乐。有七种相。谓资粮故。堪忍故。所缘故。作意故。自体故。瑞相故。胜利故。如其次第诸句伽他应知显示

何因缘故波罗蜜多唯有六数。成立对治所治障故。证诸佛法所依处故。随顺成熟诸有情故。为欲对治不发趣因故。立施戒波罗蜜多。不发趣因。谓着财位及着室家。为欲对治。虽已发趣复退还因故。立忍进波罗蜜多。退还因者。谓处生死有情违犯所生众苦。及于长时善品加行所生疲怠。为欲对治。虽已发趣不复退还而失坏因故。立定慧波罗蜜多。失坏因者。谓诸散动及邪恶慧。如是成立对治所治障故。唯立六数。又前四波罗蜜多是不散动因。次一波罗蜜多不散动成就。此不散动为依止故。如实等觉诸法真义。便能证得一切佛法。如是证诸佛法所依处故。唯立六数。由施波罗蜜多故。于诸有情能正摄受。由戒波罗蜜多故。于诸有情能不毁害。由忍波罗蜜多故。虽遭毁害而能忍受。由精进波罗蜜多故。能助经营彼所应作。即由如是摄利因缘。令诸有情于成熟事有所堪任。从此已后心未定者令其得定。心已定者令得解脱。于开悟时彼得成熟。如是随顺成熟一切有情。唯立六数应如是知

此六种相云何可见。由六种最胜故。一由所依最胜。谓菩提心为所依故。二由事最胜。谓具足现行故。三由处最胜。谓一切有情利益安乐事为依处故。四由方便善巧最胜。谓无分别智所摄受故。五由回向最胜。谓回向无上正等菩提故。六由清净最胜。谓烦恼所知二障无障所集起故。若施是波罗蜜多耶。设波罗蜜多是施耶。有施非波罗蜜多。应作四句。如于其施。如是于余波罗蜜多亦作四句。如应当知

何因缘故如是六种波罗蜜多此次第说。谓前波罗蜜多随顺生后波罗蜜多故

复次此诸波罗蜜多训释名言云何可见。于诸世间声闻独觉施等善根。最为殊胜能到彼岸。是故通称波罗蜜多。又能破裂悭吝贫穷。及能引得广大财位福德资粮。故名为施。又能息灭恶戒恶趣。及能取得善趣等持。故名为戒。又能灭尽忿怒怨仇。及能善住自他安隐故名为忍。又能远离所有懈怠恶不善法。及能出生无量善法令其增长故名精进。又能消除所有散动。及能引得内心安住故名静虑。又能除遣一切见趣诸邪恶慧。及能真实品别知法。故名为慧

云何应知修习如是波罗蜜多。应知此修略有五种。一现起加行修。二胜解修。三作意修。四方便善巧修。五成所作事修。此中四修如前已说。成所作事修者。谓诸如来任运佛事无有休息。于其圆满波罗蜜多。复更修习六到彼岸。又作意修者。谓修六种意乐所摄爱重随喜欣乐作意。一广大意乐。二长时意乐。三欢喜意乐。四荷恩意乐。五大志意乐。六纯善意乐。若诸菩萨乃至若干无数大劫。现证无上正等菩提。经尔所时一一刹那。假使顿舍一切身命。以殑伽河沙等世界盛满七宝。奉施如来乃至安坐妙菩提座。如是菩萨布施意乐犹无厌足。经尔所时一一刹那。假使三千大千世界满中炽火。于四威仪常乏一切资生众具。戒忍精进静虑般若心恒现行。乃至安坐妙菩提座。如是菩萨所有戒忍精进静虑般若意乐犹无厌足。是名菩萨广大意乐。又诸菩萨即于此中无厌意乐。乃至安坐妙菩提座常无间息。是名菩萨长时意乐。又诸菩萨以其六种波罗蜜多饶益有情。由此所作深生欢喜。蒙益有情所不能及。是名菩萨欢喜意乐。又诸菩萨以其六种波罗蜜多饶益有情。见彼于己有大恩德。不见自身于彼有恩。是名菩萨荷恩意乐。又诸菩萨即以如是六到彼岸所集善根。深心回施一切有情。令得可爱胜果异熟。是名菩萨大志意乐。又诸菩萨复以如是六到彼岸所集善根。共诸有情回求无上正等菩提。是名菩萨纯善意乐。如是菩萨修此六种意乐所摄爱重作意。又诸菩萨于余菩萨六种意乐修习相应无量善根。深心随喜。如是菩萨修此六种意乐所摄随喜意乐。又诸菩萨深心欣乐一切有情六种意乐所摄六种到彼岸修。亦愿自身与此六种到彼岸修恒不相离。乃至安坐妙菩提座。如是菩萨修此六种意乐所摄欣乐作意。若有闻此菩萨六种意乐所摄作意修已。但当能起一念信心。尚当发生无量福聚。诸恶业障亦当消灭。何况菩萨。此诸波罗蜜多差别云何可见。应知一一各有三品。施三品者。一法施。二财施。三无畏施。戒三品者。一律仪戒。二摄善法戒。三饶益有情戒。忍三品者。一耐怨害忍。二安受苦忍。三谛察法忍。精进三品者。一被甲精进。二加行精进。三无怯弱无退转无喜足精进。静虑三品者。一安住静虑。二引发静虑。三成所作事静虑。慧三品者。一无分别加行慧。二无分别慧。三无分别后得慧

如是相摄云何可见。由此能摄一切善法。是其相故。是随顺故。是等流故。如是所治摄诸杂染云何可见。是此相故。是此因故。是此果故

如是六种波罗蜜多所得胜利云何可见。谓诸菩萨流转生死富贵摄故。大生摄故。大朋大属之所摄故。广大事业加行成就之所摄故。无诸恼害性薄尘垢之所摄故。善知一切工论明处之所摄故。胜生无罪。乃至安坐妙菩提座。常能现作一切有情一切义利。是名胜利

如是六种波罗蜜多互相决择。云何可见。世尊于此一切六种波罗蜜多。或有处所以施声说。或有处所以戒声说。或有处所以忍声说。或有处所以勤声说。或有处所以定声说。或有处所以慧声说。如是所说有何意趣。谓于一切波罗蜜多修加行中。皆有一切波罗蜜多。互相助成如是意趣。此中有一嗢拖南颂

  数相及次第　　训词修差别
  摄所治功德　　互决择应知

摄大乘论本卷中摄大乘论本卷下

        无著菩萨造

        三藏法师玄奘奉　诏译

    彼修差别分第六

如是已说彼入因果。彼修差别云何可见。由菩萨十地。何等为十。一极喜地。二离垢地。三发光地。四焰慧地。五极难胜地。六现前地。七远行地。八不动地。九善慧地。十法云地。如是诸地安立为十。云何可见。为欲对治十种无明所治障故。所以者何。以于十相所知法界有十无明所治障住。云何十相所知法界。谓初地中由遍行义。第二地中由最胜义。第三地中由胜流义。第四地中由无摄受义。第五地中由相续无差别义。第六地中由无杂染清净义。第七地中由种种法无差别义。第八地中由不增不减义。相自在依止义。土自在依止义。第九地中由智自在依止义。第十地中由业自在依止义。陀罗尼门三摩地门自在依止义。此中有三颂

  遍行最胜义　　及与胜流义
  如是无摄义　　相续无别义
  无杂染净义　　种种无别义
  不增不减义　　四自在依义
  法界中有十　　不染污无明
  治此所治障　　故安立十地

复次应知。如是无明于声闻等非染污。于诸菩萨是染污

复次何故初地说名极喜。由此最初得能成办自他义利胜功能故。何故二地说名离垢。由极远离犯戒垢故。何故三地说名发光。由无退转等持等至所依止故。大法光明所依止故。何故四地说名焰慧。由诸菩提分法焚灭一切障故。何故五地名极难胜。由真谛智与世间智更互相违。合此难合令相应故。何故六地说名现前。由缘起智为所依止。能令般若波罗蜜多现在前故。何故七地说名远行。至功用行最后边故。何故八地说名不动。由一切相有功用行不能动故。何故九地说名善慧。由得最胜无碍智故。何故十地说名法云。由得总缘一切法智。含藏一切陀罗尼门三摩地门。譬如大云能覆如空广大障故。又于法身能圆满故

得此诸地云何可见。由四种相。一得胜解。谓得诸地深信解故。二得正行。谓得诸地相应十种正法行故。三得通达。谓于初地达法界时。遍能通达一切地故。四得成满。谓修诸地到究竟故。修此诸地云何可见。谓诸菩萨于地地中修奢摩他毗钵舍那。由五相修。何等为五。谓集总修。无相修。无功用修。炽盛修。无喜足修。如是五修令诸菩萨成办五果。谓念念中销融一切粗重依止。离种种相得法苑乐。能正了知周遍无量无分限相大法光明。顺清净分无所分别无相现行。为令法身圆满成办。能正摄受后后胜因。由增胜故。说十地中别修十种波罗蜜多。于前六地所修六种波罗蜜多。如先已说。后四地中所修四者。一方便善巧波罗蜜多。谓以前六波罗蜜多所集善根。共诸有情回求无上正等菩提故。二愿波罗蜜多。谓发种种微妙大愿。引摄当来波罗蜜多殊胜众缘故。三力波罗蜜多。谓由思择修习二力。令前六种波罗蜜多无间现行故。四智波罗蜜多。谓由前六波罗蜜多成立妙智。受用法乐成熟有情故。又此四种波罗蜜多。应知般若波罗蜜多无分别智后得智摄又于一切地中非不修习一切波罗蜜多。如是法门是波罗蜜多藏之所摄

复次凡经几时修行诸地可得圆满。有五补特伽罗经三无数大劫谓胜解行补特伽罗。经初无数大劫修行圆满。清净增上意乐行补特伽罗。及有相行无相行补特伽罗。于前六地及第七地经第二无数大劫修行圆满。即此无功用行补特伽罗。从此已上至第十地。经第三无数大劫修行圆满。此中有颂

  清净增上力　　坚固心升进
  名菩萨初修　　无数三大劫

    摄大乘论本增上戒学分第七

如是已说因果修差别。此中增上戒殊胜云何可见。如菩萨地正受菩萨律仪中说。复次应知略由四种殊胜故此殊胜。一由差别殊胜。二由共不共学处殊胜。三由广大殊胜。四由甚深殊胜

差别殊胜者。谓菩萨戒有三品别。一律仪戒。二摄善法戒。三饶益有情戒。此中律仪戒应知二戒建立义故。摄善法戒应知修集一切佛法建立义故。饶益有情戒应知成熟一切有情建立义故

共不共学处殊胜者。谓诸菩萨一切性罪不现行故与声闻共相。似遮罪有现行故与彼不共。于此学处有声闻犯菩萨不犯。有菩萨犯声闻不犯。菩萨具有身语心戒。声闻唯有身语二戒。是故菩萨心亦有犯非诸声闻。以要言之。一切饶益有情无罪身语意业。菩萨一切皆应现行皆应修学。如是应知说名为共不共殊胜

广大殊胜者。复由四种广大故。一由种种无量学处广大故。二由摄受无量福德广大故。三由摄受一切有情利益安乐意乐广大故。四由建立无上正等菩提广大故

甚深殊胜者。谓诸菩萨由是品类方便善巧。行杀生等十种作业。而无有罪生无量福。速证无上正等菩提。又诸菩萨现行变化身语两业。应知亦是甚深尸罗。由此因缘或作国王。示行种种恼有情事。安立有情毗柰耶中。又现种种诸本生事。示行逼恼诸余有情。真实摄受诸余有情。先令他心深生净信后转成熟。是名菩萨所学尸罗甚深殊胜。由此略说四种殊胜。应知菩萨尸罗律仪最为殊胜。如是差别菩萨学处。应知复有无量差别。如毗柰耶瞿沙方广契经中说

    摄大乘论本增上心学分第八

如是已说增上戒殊胜。增上心殊胜云何可见。略由六种差别应知。一由所缘差别故。二由种种差别故。三由对治差别故。四由堪能差别故。五由引发差别故。六由作业差别故。所缘差别者。谓大乘法为所缘故

种种差别者。谓大乘光明集福定王贤守健行等三摩地种种无量故

对治差别者。谓一切法总相缘智以楔出楔。道理遣阿赖耶识中一切障粗重故

堪能差别者。谓住静虑乐随其所欲即受生故

引发差别者。谓能引发一切世界无碍神通故。作业差别者。谓能振动炽然遍满。显示转变往来卷舒。一切色像皆入身中。所往同类或显或隐。所作自在伏他神通。施辩念乐放大光明。引发如是大神通故又能引发摄诸难行。十难行故。十难行者。一自誓难行。誓受无上菩提愿故。二不退难行。生死众苦不能退故。三不背难行。一切有情虽行邪行而不弃故。四现前难行。怨有情所现作一切饶益事故。五不染难行。生在世间不为世法所染污故。六胜解难行。于大乘中虽未能了。然于一切广大甚深生信解故。七通达难行。具能通达补特伽罗法无我故。八随觉难行。于诸如来所说甚深秘密言词能随觉故。九不离不染难行。不舍生死而不染故。十加行难行。能修诸佛安住解脱一切障碍。穷生死际不作功用。常起一切有情一切义利行故。复次随觉难行中。于佛何等秘密言词彼诸菩萨能随觉了。谓如经言

云何菩萨能行惠施。若诸菩萨无少所施。然于十方无量世界广行惠施。云何菩萨乐行惠施。若诸菩萨于一切施都无欲乐。云何菩萨于惠施中深生信解。若诸菩萨不信如来而行布施。云何菩萨于施策励。若诸菩萨于惠施中不自策励。云何菩萨于施耽乐。若诸菩萨无有暂时少有所施。云何菩萨其施广大。若诸菩萨于惠施中离娑洛想。云何菩萨其施清净。若诸菩萨殟波陀悭。云何菩萨其施究竟。若诸菩萨不住究竟。云何菩萨其施自在。若诸菩萨于惠施中不自在转。云何菩萨其施无尽。若诸菩萨不住无尽。如于布施于戒为初。于慧为后。随其所应当知亦尔。云何能杀生。若断众生生死流转。云何不与取。若诸有情无有与者自然摄取。云何欲邪行。若于诸欲了知是邪而修正行。云何能妄语。若于妄中能说为妄。云何贝戍尼。若能常居最胜空住。云何波鲁师。若善安住所知彼岸。云何绮间语。若正说法品类差别云何能贪欲。若有数数欲自证得无上静虑。云何能嗔恚。若于其心能正憎害一切烦恼。云何能邪见。若一切处遍行邪性皆如实见

甚深佛法者。云何名为甚深佛法。此中应释。谓常住法是诸佛法。以其法身是常住故。又断灭法是诸佛法。以一切障永断灭故。又生起法是诸佛法。以变化身现生起故。又有所得法是诸佛法。八万四千诸有情行。及彼对治皆可得故。又有贪法是诸佛法。自誓摄受有贪有情为己体故。又有嗔法是诸佛法。又有痴法是诸佛法。又异生法是诸佛法。应知亦尔。又无染法是诸佛法。成满真如一切障垢不能染故。又无污法是诸佛法。生在世间诸世间法不能污故。是故说名甚深佛法。又能引发修到彼岸。成熟有情净佛国土。诸佛法故。应知亦是菩萨等持作业差别

    摄大乘论本增上慧学分第九

如是已说增上心殊胜。增上慧殊胜云何可见。谓无分别智。若自性。若所依。若因缘。若所缘。若行相。若任持。若助伴。若异熟。若等流。若出离。若至究竟。若加行无分别后得胜利。若差别。若无分别后得譬喻。若无功用作事。若甚深。应知无分别智名增上慧殊胜。此中无分别智离五种相以为自性。一离无作意故。二离过有寻有伺地故。三离想受灭寂静故。四离色自性故。五离于真义异计度故。离此五相。应知是名无分别智

于如所说无分别智成立相中。复说多颂

  诸菩萨自性　　远离五种相
  是无分别智　　不异计于真
  诸菩萨所依　　非心而是心
  是无分别智　　非思义种类
  诸菩萨因缘　　有言闻熏习
  是无分别智　　及如理作意
  诸菩萨所缘　　不可言法性
  是无分别智　　无我性真如
  诸菩萨行相　　复于所缘中
  是无分别智　　彼所知无相
  相应自性义　　所分别非余
  字展转相应　　是谓相应义
  非离彼能诠　　智于所诠转
  非诠不同故　　一切不可言
  诸菩萨任持　　是无分别智
  后所得诸行　　为进趣增长
  诸菩萨助伴　　说为二种道
  是无分别智　　五到彼岸性
  诸菩萨异熟　　于佛二会中
  是无分别智　　由加行证得
  诸菩萨等流　　于后后生中
  是无分别智　　自体转增胜
  诸菩萨出离　　得成办相应
  是无分别智　　应知于十地
  诸菩萨究竟　　得清净三身
  是无分别智　　得最上自在
  如虚空无染　　是无分别智
  种种极重恶　　由唯信胜解
  如虚空无染　　是无分别智
  解脱一切障　　得成办相应
  如虚空无染　　是无分别智
  常行于世间　　非世法所染
  如哑求受义　　如哑正受义
  如非哑受义　　三智譬如是
  如愚求受义　　如愚正受义
  如非愚受义　　二智譬如是
  如五求受义　　如五正受义
  如末那受义　　三智譬如是
  如未解于论　　求论受法义
  次第譬三智　　应知加行等
  如人正闭目　　是无分别智
  即彼复开目　　后得智亦尔
  应知如虚空　　是无分别智
  于中现色像　　后得智亦尔
  如末尼天乐　　无思成自事
  种种佛事成　　常离思亦尔
  非于此非余　　非智而是智
  与境无有异　　智成无分别
  应知一切法　　本性无分别
  所分别无故　　无分别智无

此中加行无分别智有三种。谓因缘引发数习生差别故

根本无分别智亦有三种。谓喜足无颠倒无戏论无分别差别故

后得无分别智有五种。谓通达随念安立和合如意思择差别故

复有多颂成立如是无分别智

  鬼傍生人天　　各随其所应
  等事心异故　　许义非真实
  于过去事等　　梦像二影中
  虽所缘非实　　而境相成就
  若义义性成　　无无分别智
  此若无佛果　　证得不应理
  得自在菩萨　　由胜解力故
  如欲地等成　　得定者亦尔
  成就简择者　　有智得定者
  思惟一切法　　如义皆显现
  无分别智行　　诸义皆不现
  当知无有义　　由此亦无识

般若波罗蜜多与无分别智无有差别。如说菩萨安住般若波罗蜜多非处相应。能于所余波罗蜜多修习圆满。云何名为非处相应修习圆满。谓由远离五种处故。一远离外道我执处故。二远离未见真如菩萨分别处故。三远离生死涅槃二边处故。四远离唯断烦恼障生喜足处故。五远离不顾有情利益安乐住无余依涅槃界处故

声闻等智与菩萨智有何差别。由五种相应知差别。一由无分别差别。谓于蕴等法无分别故。二由非少分差别。谓于通达真如入一切种所知境界。普为度脱一切有情。非少分故。三由无住差别。谓无住涅槃为所住故。四由毕竟差别。谓无余依涅槃界中无断尽故。五由无上差别。谓于此上无有余乘胜过此故。此中有颂

  诸大悲为体　　由五相胜智
  世出世满中　　说此最高远

若诸菩萨成就如是增上尸罗增上质多增上般若。功德圆满于诸财位得大自在。何故现见有诸有情匮乏财位。见彼有情于诸财位有重业障故。见彼有情若施财位障生善法故。见彼有情若乏财位厌离现前故。见彼有情若施财位即为积集不善法因故。见彼有情若施财位即便作余无量有情损恼因故。是故现见有诸有情匮乏财位。此中有颂

  见业障现前　　积集损恼故
  现有诸有情　　不感菩萨施

    摄大乘论本果断分第十

如是已说增上慧殊胜。彼果断殊胜云何可见。断谓菩萨无住涅槃。以舍杂染不舍生死。二所依止转依为相。此中生死谓依他起性杂染分。涅槃谓依他起性清净分。二所依止。谓通二分依他起性。转依谓即依他起性。对治起时转舍杂染分转得清净分。又此转依略有六种。一损力益能转。谓由胜解力闻熏习住故。及由有羞耻令诸烦恼少分现行不现行故。二通达转。谓诸菩萨已入大地。于真实非真实显现不显现现前住故。乃至六地。三修习转。谓犹有障一切相不显现真实显现故。乃至十地。四果圆满转。谓永无障一切相不显现。最清净真实显现。于一切相得自在故。五下劣转。谓声闻等唯能通达补特伽罗空无我性。一向背生死一向舍生死故。六广大转。谓诸菩萨兼通达法空无我性。即于生死见为寂静。虽断杂染而不舍故。若诸菩萨住下劣转有何过失。不顾一切有情利益安乐事故。违越一切菩萨法故。与下劣乘同解脱故。是为过失。若诸菩萨住广大转有何功德。生死法中以自转依为所依止。得自在故。于一切趣示现一切有情之身。于最胜生及三乘中。种种调伏方便善巧。安立所化诸有情故。是为功德

此中有多颂

  诸凡夫覆真　　一向显虚妄
  诸菩萨舍妄　　一向显真实
  应知显不显　　真义非真义
  转依即解脱　　随欲自在行
  于生死涅槃　　若起平等智
  尔时由此证　　生死即涅槃
  由是于生死　　非舍非不舍
  亦即于涅槃　　非得非不得

    摄大乘论本彼果智分第十一

如是已说彼果断殊胜。彼果智殊胜云何可见。谓由三种佛身应知彼果智殊胜。一由自性身。二由受用身。三由变化身。此中自性身者。谓诸如来法身。一切法自在转所依止故。受用身者。谓依法身种种诸佛众会所显清净佛土。大乘法乐为所受故。变化身者。亦依法身从睹史多天宫现没。受生受欲踰城出家。往外道所修诸苦行。证大菩提转大法轮。入大涅槃故

此中说一嗢拖南颂

  相证得自在　　依止及摄持
  差别德甚深　　念业明诸佛

诸佛法身以何为相。应知法身略有五相。一转依为相。谓转灭一切障杂染分依他起性故。转得解脱一切障于法自在。转现前清净分依他起性故。二白法所成为相。谓六波罗蜜多圆满得十自在故。此中寿自在心自在众具自在。由施波罗蜜多圆满故。业自在生自在。由戒波罗蜜多圆满故。胜解自在。由忍波罗蜜多圆满故。愿自在。由精进波罗蜜多圆满故。神力自在五通所摄。由静虑波罗蜜多圆满故。智自在法自在。由般若波罗蜜多圆满故。三无二为相。谓有无无二为相。由一切法无所有故。空所显相是实有故。有为无为无二为相。由业烦恼非所为故。自在示现有为相故。异性一性无二为相。由一切佛所依无差别故。无量相续现等觉故。此中有二颂

  我执不有故　　于中无别依
  随前能证别　　故施设有异
  种姓异非虚　　圆满无初故
  无垢依无别　　故非一非多

四常住为相。谓真如清净相故。本愿所引故。所应作事无竟期故

五不可思议为相。谓真如清净自内证故。无有世间喻能喻故。非诸寻思所行处故

复次云何如是法身最初证得。谓缘总相大乘法境无分别智及后得智五相善修。于一切地善集资粮。金刚喻定破灭微细难破障故。此定无间离一切障故得转依

复次法身由几自在而得自在。略由五种。一由佛土自身相好无边音声无见顶相。自在由转色蕴依故。二由无罪无量广大乐住。自在由转受蕴依故。三由辩说一切名身句身文身。自在由转想蕴依故。四由现化变易引摄大众引摄白法。自在由转行蕴依故。五由圆镜平等观察成所作智。自在由转识蕴依故

复次法身由几种处。应知依止略由三处。一由种种佛住依止。此中有二颂

  诸佛证得五性喜　　皆由等证自界故
  离喜都由不证此　　故求喜者应等证
  由能无量及事成　　法味义德俱圆满
  得喜最胜无过失　　诸佛见常无尽故

二由种种受用身依止。但为成熟诸菩萨故。三由种种变化身依止。多为成熟声闻等故。应知法身由几佛法之所摄持。略由六种。一由清净。谓转阿赖耶识得法身故。二由异熟。谓转色根得异熟智故。三由安住。谓转欲行等住得无量智住故。四由自在。谓转种种摄受业。自在得一切世界无碍神通智自在故。五由言说。谓转一切见闻觉知言说戏论得令一切有情心喜。辩说智自在故。六由拔济。谓转拔济一切灾横过失。得拔济一切有情一切灾横过失智故。应知法身由此所说六种佛法之所摄持

诸佛法身当言有异当言无异。依止意乐业无别故。当言无异。无量依身现等觉故。当言有异。如说佛法身受用身亦尔。意乐及业无差别故。当言无异。不由依止无差别故。无量依止差别转故。应知变化身如受用身说应知。法身几德相应。谓最清净四无量。解脱胜处遍处无诤愿智。四无碍解六神通。三十二大士相八十随好。四一切相清净。十力四无畏。三不护三念住。拔除习气无忘失法。大悲十八不共佛法。一切相妙智等功德相应此中有多颂

  怜愍诸有情　　起和合远离
  常不舍利乐　　四意乐归礼
  解脱一切障　　牟尼胜世间
  智周遍所知　　心解脱归礼
  能灭诸有情　　一切惑无余
  害烦恼有染　　常哀愍归礼
  无功用无著　　无碍常寂定
  于一切问难　　能解释归礼
  于所依能依　　所说言及智
  能说无碍慧　　常善说归礼
  为彼诸有情　　故现知言行
  往来及出离　　善教者归礼
  诸众生见尊　　皆审知善士
  暂见便深信　　开导者归礼
  摄受住持舍　　现化及变易
  等持智自在　　随证得归礼
  方便归依净　　及大乘出离
  于此诳众生　　摧魔者归礼
  能说智及断　　出离能障碍
  自他利非余　　外道伏归礼
  处众能伏说　　迷离二杂染
  无护无忘失　　摄御众归礼
  遍一切行住　　无非圆智事
  一切时遍知　　实义者归礼
  诸有情利乐　　所作不过时
  所作常无虚　　无忘失归礼
  昼夜常六返　　观一切世间
  与大悲相应　　利乐意归礼
  由行及由证　　由智及由业
  于一切二乘　　最胜者归礼
  由三身至得　　具相大菩提
  一切处他疑　　皆能断归礼

诸佛法身与如是等功德相应。复与所余自性因果业相应。转功德相应。是故应知诸佛法身无上功德。此中有二颂

  尊成实胜义　　一切地皆出
  至诸众生上　　解脱诸有情
  无尽无等德　　相应现世间
  及众会可见　　非见人天等

复次诸佛法身甚深最甚深。此甚深相云何可见。此中有多颂

  佛无生为生　　亦无住为住
  诸事无功用　　第四食为食
  无异亦无量　　无数量一业
  不坚业坚业　　诸佛具三身
  现等觉非有　　一切觉非无
  一一念无量　　有非有所显
  非染非离染　　由欲得出离
  了知欲无欲　　悟入欲法性
  诸佛过诸蕴　　安住诸蕴中
  与彼非一异　　不舍而善寂
  诸佛事相杂　　犹如大海水
  我已现当作　　他利无是思
  众生罪不现　　如月于破器
  遍满诸世间　　由法光如日
  或现等正觉　　或涅槃如火
  此未曾非有　　诸佛身常故
  佛于非圣法　　人趣及恶趣
  非梵行法中　　最胜自体住
  佛一切处行　　亦不行一处
  于一切身现　　非六根所行
  烦恼伏不灭　　如毒咒所害
  由惑至惑尽　　证佛一切智
  烦恼成觉分　　生死为涅槃
  具大方便故　　诸佛不思议

应知如是所说甚深有十二种。谓生住业住甚深。安立数业甚深。现等觉甚深。离欲甚深。断蕴甚深。成熟甚深。显现甚深。示现等觉涅槃甚深。住甚深。显示自体甚深。断烦恼甚深。不可思议甚深。若诸菩萨念佛法身。由几种念应修此念。略说菩萨念佛法身。由七种念应修此念。一者诸佛于一切法得自在转。应修此念。于一切世界得无碍通故。此中有颂

  有情界周遍　　具障而阙因
  二种决定转　　诸佛无自在

二者如来其身常住。应修此念。真如无间解脱垢故。三者如来最胜无罪。应修此念。一切烦恼及所知障并离系故。四者如来无有功用。应修此念。不作功用一切佛事无休息故。五者如来受大富乐。应修此念。清净佛土大富乐故。六者如来离诸染污。应修此念。生在世间一切世法不能染故。七者如来能成大事。应修此念。示现等觉般涅槃等。一切有情未成熟者能令成熟。已成熟者令解脱故。此中有二颂

  圆满属自心　　具常住清净
  无功用能施　　有情大法乐
  遍行无依止　　平等利多生
  一切佛智者　　应修一切念

复次诸佛清净佛土相云何。应知如菩萨藏百千契经序品中说。谓薄伽梵住最胜光曜七宝庄严。放大光明普照一切无边世界。无量方所妙饰间列。周圆无际其量难测。超过三界所行之处。胜出世间善根所起。最极自在净识为相。如来所都诸大菩萨众所云集。无量天龙药叉健达缚阿素洛揭路荼紧捺洛莫呼洛伽人非人等常所翼从。广大法味喜乐所持。作诸众生一切义利。蠲除一切烦恼灾横。远离众魔过诸庄严。如来庄严之所依处。大念慧行以为游路。大止妙观以为所乘。大空无相无愿解脱为所入门。无量功德众所庄严。大宝花王之所建立。大宫殿中

如是现示清净佛土。显色圆满形色圆满。分量圆满。方所圆满。因圆满。果圆满。主圆满。辅翼圆满。眷属圆满。住持圆满。事业圆满。摄益圆满。无畏圆满。住处圆满。路圆满。乘圆满。门圆满。依持圆满

复次受用如是清净佛土。一向净妙。一向安乐。一向无罪。一向自在

复次应知如是诸佛法界。于一切时能作五业。一者救济一切有情灾横为业。于暂见时便能救济盲聋狂等诸灾横故。二者救济恶趣为业。拔诸有情出不善处置善处故。三者救济非方便为业。令诸外道舍非方便求解脱行。置于如来圣教中故。四者救济萨迦耶为业。授与能超三界道故。五者救济乘为业拯拔欲趣余乘菩萨及不定种性诸声闻等。安处令修大乘行故。于此五业应知诸佛业用平等此中有颂

  因依事性行　　别故许业异
  世间此力别　　无故非导师

若此功德圆满相应。诸佛法身不与声闻独觉乘共。以何意趣佛说一乘此中有二颂

  为引摄一类　　及任持所余
  由不定种性　　诸佛说一乘
  法无我解脱　　等故性不同
  得二意乐化　　究竟说一乘

如是诸佛同一法身而佛有多。何缘可见。此中有颂

  一界中无二　　同时无量圆
  次第转非理　　故成有多佛

云何应知。于法身中佛非毕竟入于涅槃。亦非毕竟不入涅槃。此中有颂

  一切障脱故　　所作无竟故
  佛毕竟涅槃　　毕竟不涅槃

何故受用身非即自性身。由六因故。一色身可见故。二无量佛众会差别可见故。三随胜解见自性不定可见故。四别别而见自性变动可见故五菩萨声闻及诸天等种种众会间杂可见故。六阿赖耶识与诸转识转依非理可见故。佛受用身即自性身。不应道理。何因变化身非即自性身。由八因故。谓诸菩萨从久远来得不退定。于睹史多及人中生不应道理。又诸菩萨从久远来常忆宿住。书算数印工巧论中。及于受用欲尘行中不能正知不应道理。又诸菩萨从久远来已知恶说善说法教。往外道所不应道理。又诸菩萨从久远来。已能善知三乘正道。修邪苦行不应道理。又诸菩萨舍百拘胝诸赡部洲。但于一处成等正觉转正法轮不应道理。若离示现成等正觉。唯以化身于所余处施作佛事。即应但于睹史多天成等正觉。何不施设。遍于一切赡部洲中同时佛出。既不施设无教无理。虽有多化而不违彼无二如来出现世言。由一四洲摄世界故。如二轮王不同出世。此中有颂

  佛微细化身　　多处胎平等
  为显一切种　　成等觉而转

为欲利乐一切有情。发愿修行证大菩提毕竟涅槃不应道理愿行无果。成遇失故

佛受用身及变化身既是无常。云何经说如来身常。此二所依法身常故。又等流身及变化身以恒受用无休废故。数数现化不永绝故。如常受乐如常施食。如来身常应知亦尔。由六因故。诸佛世尊所现化身非毕竟住。一所作究竟成熟有情已解脱故。二为令舍离不乐涅槃。为求如来常住身故。三为令舍离轻毁诸佛。令悟甚深正法教故。四为令于佛深生渴仰。恐数见者生厌怠故。五令于自身发勤精进。知正说者难可得故。六为诸有情极速成熟令自精进不舍轭故。此中有二颂

  由所作究竟　　舍不乐涅槃
  离轻毁诸佛　　深生于渴仰
  内自发正勤　　为极速成熟
  故许佛化身　　而非毕竟住

诸佛法身无始时来无别无量。不应为得更作功用。此中有颂

  佛得无别无量因　　有情若舍勤功用
  证得恒时不成因　　断如是因不应理

阿毗达磨大乘经中摄大乘品。我阿僧伽略释究竟

摄大乘论本卷下


摄大乘论释

    No. 1597 [Nos. 1595, 1596; cf. Nos. 1592-1594, 1598]

摄大乘论释卷第一

        世亲菩萨造

        三藏法师玄奘奉　诏译

    总标纲要分第一

  诸破所知障翳暗　　尽其所有如所有
  诸法真俗理影中　　妄执竞兴于异见
  斯由永离诸分别　　无垢清净智光明
  获得最胜三菩提　　惑障并习断常住
  能无功用于十方　　随诸有情意所乐
  开示殊胜极广大　　三种解脱等方便
  由无分别有大悲　　生死涅槃俱不住
  由摄妙慧巧方便　　究竟至极自他利
  如是世尊等所觉　　等所开示微妙法
  若能于此善修行　　必获寂然甘露迹
  诽谤决定没无底　　甚久无能大苦海
  学无学僧居道果　　普胜一切所余僧
  善逝无垢功德河　　真实于中而沐浴
  为世无上良福田　　虽复投于微少善
  而便广大如地空　　慧者由斯得解脱
  故我至诚身语思　　频修无倒归命礼
  轨范诸师今减少　　真法正理多浑浊
  皆由聪睿邪慢人　　依自寻思失教证
  我师于此非前后　　逢事圣者大慈尊
  依止无动出世间　　放大法光三摩地
  阐扬妙法流清誉　　如日舒光遍十方
  文光无垢最甚深　　诸了义经所随顺
  广大句义皆微妙　　悉以绮饰自庄严
  能令聪敏者融心　　无谄无憍生爱敬
  极难通法慧无滞　　不住利养称誉中
  于乐常无染着心　　故名决定称自德
  诸贤圣者常亲近　　一切世间无不知
  无著名称普皆闻　　功德显然同所赞
  无尽辩者等所雨　　甘露文义微妙法
  多从彼闻自力微　　少受犹如乞雨鸟
  从广决择集少分　　以言略释摄大乘
  愿此所作遍饶益　　怖于极大文海者

论曰。阿毗达磨大乘经中。薄伽梵前已能善入大乘菩萨。为显大乘体大故说谓依大乘。诸佛世尊有十相殊胜殊胜语

释曰。依止何义从何所因而作是说。广博所知深大法性。若离诸佛菩萨威力。谁于此中能造释论。复由何义于此论初说如是事由。若离举阿毗达磨大乘经言。则不了知论是圣教为此义故。又为显经名如言十地经。故说如是阿毗达磨大乘经言。复有余义。为显彼经是圣教故。初说如是阿毗达磨大乘经言。今造此论有所用者。为欲开晓无知者故。为显法门别名故。举阿毗达磨。为显通名故。举经言。为简声闻阿毗达磨复举大乘。由今亦有非圣所说阿毗达磨。如现有人自寻思慧。谓是佛说阿毗达磨。或声闻说或世智造。又言大乘素怛缆者。为欲显示异声闻等。为欲显示菩萨藏摄故。复举其阿毗达磨。又藏摄者。谓入自宗素怛缆藏现灭自惑。毗奈耶藏即大乘中菩萨烦恼。以诸菩萨种种分别为烦恼故。不违最胜阿毗达磨。广大甚深为其相故

此中三藏者。一素怛缆藏。二毗奈耶藏。三阿毗达磨藏。如是三藏下乘上乘有差别故则成二藏。一声闻藏。二菩萨藏。此三及二何缘名藏。由能摄故。谓摄一切所应知义

复由何缘建立三藏。由九种缘。谓为对治疑惑立素怛缆藏。若于彼彼义中有疑惑者。即为决定宣说彼彼义故。为对治二边受用立毗奈耶藏。谓遮有罪着欲乐边受用故。及开无罪不自苦边受用故。为对治自见取执立阿毗达磨藏显照诸法无倒相故。又能说三学故立素怛缆藏。能成办增上戒增上心故立毗奈耶藏。谓具尸罗即无悔等。渐次能得三摩地故。能成办增上慧故立阿毗达磨藏。谓能决择无倒义故。又能说法义故立素怛缆藏。能成满法义故立毗奈耶藏。谓为调伏烦恼勤修行者。便于此二能通达故。能于法义决择善巧故立阿毗达磨藏。由此九缘许立三藏。又此皆为解脱生死。此复云何能得解脱。熏觉寂通故得解脱。谓由闻熏习心故。由思觉悟故。由修奢摩他寂静故。由证毗钵舍那通达故。能得解脱。又若略说此素怛缆毗奈耶阿毗达磨藏各有四义。菩萨于此若具了知则能证得一切智性。声闻于此虽但解了一伽他义亦得漏尽。云何此三各有四义。谓能贯穿。依故相故法故义故名素怛缆。此中依者。谓于是处由此为此而有所说。相者。谓世俗谛相胜义谛相。法者。谓蕴界处缘起谛食静虑无量无色解脱胜处遍处菩提分无碍解无诤等。义者。谓随密意。对故数故伏故通故。应知名阿毗达磨。谓阿毗达磨亦名对法。此法对向无住涅槃能说谛菩提分解脱门等故。阿毗达磨亦名数法。于一一法数数宣说训释言词自相共相等无量差别故。阿毗达磨亦名伏法。由此具足论处所等能胜伏他论故。阿毗达磨亦名通法。由此能释通素怛缆义故。犯罪故等起故还净故出离故。应知名毗奈耶。此中犯罪者谓五众罪。等起者。谓无知故放逸故烦恼盛故不尊敬故而犯诸罪。还净者。谓由意乐不由治罚如受律仪。出离者。有七种。一各各相对说悔所犯。二誓受治罚谓授学等。三等有妨害先制学处后由异门还复开许。四别更止息谓僧和合还舍所制。五转依谓苾刍苾刍尼转男女形故舍不共罪。六由真实观谓作殊胜法嗢柁南诸行相观。七由法尔得谓由见谛法尔得无小随小罪。应知毗奈耶复有四义。一补特伽罗故。世尊依彼制所学处。二制立故。谓告曰彼补特伽罗所犯过已大师集僧制所学处。三分别故。谓制学处。已更广解释。先所略说四决择故。谓于此中决判所犯。云何有罪云何无罪

今当释本文。薄伽梵前者。显有所敬故无异言。善入大乘者。是由已得陀罗尼等胜功德义。显已得此诸功德故。于义于文能正任持能正开示。如是名菩萨。为何义故说。为显大乘体大故说。所言显者。开发大乘实有大体。依大乘者。依止大乘而起所说。有十相殊胜殊胜语者。谓即由彼十种殊胜所殊胜语。名十相殊胜殊胜语。此殊胜言是差别义。两互相待。如言此义殊胜于彼。又最上义是殊胜义。或是异类。谓义因殊胜故。语果是殊胜。今当说此十种别相

论曰。一者所知依殊胜殊胜语。二者所知相殊胜殊胜语。三者入所知相殊胜殊胜语。四者彼入因果殊胜殊胜语。五者彼因果修差别殊胜殊胜语。六者即于如是修差别中增上戒殊胜殊胜语。七者即于此中增上心殊胜殊胜语。八者即于此中增上慧殊胜殊胜语。九者彼果断殊胜殊胜语。十者彼果智殊胜殊胜语。由此所说诸佛世尊契经诸句。显于大乘真是佛语

释曰。此中所知依殊胜殊胜语者。所应可知故名所知。所谓杂染清净诸法即三自性。依是因义此所知依即是殊胜故名所知依殊胜。由此殊胜故语殊胜。此依即是阿赖耶识。如是持业释。乃至彼果智殊胜亦尔。谓彼果智即是殊胜故名彼果智殊胜等。所知相者。是所知自性义。所知即是相故名所知相。谓三自性入所知相者。谓于所知相若能入若正入即唯识性。彼入因果者。谓能入彼故名彼入。即是悟入唯识理性。因谓加行时。世间施等波罗蜜多。果谓通达时。出世施等波罗蜜多。彼因果修差别者。即彼因果故名彼因果。即于此中修之差别。修谓数习。即此数习于诸地中展转殊胜故名差别即是十地。即于如是修差别中。增上戒者。谓十地中依戒而学故名增上戒。即诸菩萨所有律仪于诸不善无复作心。增上心者。谓在内心或即依心而学故名增上心。即诸三摩地。增上慧者。谓趣证慧故名增上慧。或依慧而学故名增上慧。即是无分别智。断殊胜者。谓最胜品别自内弃舍烦恼及所知障。即是无住涅槃。智殊胜殊胜语者。谓无障智名智殊胜。彼无分别智有所对治。今此佛智已离一切障及随眠。是名于彼无分别智佛智殊胜

论曰。复次云何能显由此所说十处。于声闻乘曾不见说。唯大乘中处处见说。谓阿赖耶识说名所知依体。三种自性。一依他起自性。二遍计所执自性。三圆成实自性。说名所知相体。唯识性说名入所知相体。六波罗蜜多说名彼入因果体。菩萨十地说名彼因果修差别体。菩萨律仪说名此中增上戒体首楞伽摩虚空藏等诸三摩地说名此中增上心体。无分别智说名此中增上慧体。无住涅槃说名彼果断体。三种佛身。一自性身。二受用身。三变化身。说名彼果智体。由此所说十处显于大乘异声闻乘。又显最胜世尊但为菩萨宣说。是故应知但依大乘。诸佛世尊有十行相殊胜殊胜语

释曰。云何能显者。是问何缘义。六波罗蜜多说名彼入因果体者。谓由唯识性入三自性时。世间施等波罗蜜多名清净因。由能引发出世间故。入地已去即彼施等波罗蜜多成出世间。名清净果。菩萨十地说名彼因果修差别体者。谓菩萨十地是前所说波罗蜜多。因果二位修差别性。无分别智说名此中增上慧体者。若诸声闻离四颠倒分别名无分别。若诸菩萨离一切法分别名无分别。二无分别差别如是。无住涅槃说名彼果断体者。谓三学果故名彼果。彼果即断名彼果断。此性名为彼果断体。即是烦恼所知二障断义三种佛身说名彼果智体者彼三学果故名彼果。彼果即智名彼果智。此性名为彼果智体。此中若无自性身应无法身。譬如眼根。若无法身应无受用身。譬如眼识。应知此中所依能依为同法喻。若无受用身。已入大地。诸菩萨众应无受用法乐。若无受用法乐。菩提资粮应不圆满。譬如见色。若无化身胜解行地诸菩萨众。诸声闻等劣胜解者。最初发趣皆不应有是故决定应有三身。显于大乘异声闻乘者。声闻乘中不说此故。又显最胜者。显大乘中此亦最胜

论曰。复次云何由此十相殊胜殊胜如来语故。显于大乘真是佛语。遮声闻乘是大乘性。由此十处于声闻乘曾不见说。唯大乘中处处见说。谓此十处是最能引大菩提性。是善成立随顺无违。为能证得一切智智。此中二颂

  所知依及所知相　　彼入因果彼修异
  三学彼果断及智　　最上乘摄是殊胜
  此说此余见不见　　由此最胜菩提因
  故许大乘真佛语　　由说十处故殊胜

释曰。此复云何谓复显此所说十处。是最能引大菩提性。是善成立随顺无违。是最能引大菩提性者。是大菩提能引因义。是善成立者。谓由正理等量思择如见导师所说道相。言随顺者。谓为证得勤修行时随顺住故。如随导师所说正道随顺而住。言无违者。谓诸地中无障碍因。如随导师所说道中无劫贼等所有障难。或复生死涅槃二种互不相违。复有异门。是最能引大菩提性者。谓此能引无戏论无分别智故。是善成立者。谓与四理不相违故。言随顺者。谓与三量不相违故。言无违者。非先随顺后相违故。如有颂言

  初任持爱悲　　后随顺不善
  非黑白我见　　有益亦有损

为能证得一切智智者。谓于一切法中发生无上无间一切行相智故。善成立等复有余义。谓善成立随顺无违展转标释。云何善成立。谓能随顺故。云何能随顺。谓无违转故

论曰。复次云何如是次第说此十处。谓诸菩萨于诸法因要先善已。方于缘起应得善巧。次后于缘所生诸法应善其相。善能远离增益损减二边过故。次后如是善修菩萨应正通达善所取相令从诸障心得解脱。次后通达所知相已。先加行位六波罗蜜多。由证得故应更成满增上意乐得清净故。次后清净意乐所摄六波罗蜜多。于十地中分分差别。应勤修习谓要经三无数大劫。次后于三菩萨所学应令圆满。既圆满已彼果涅槃及与无上正等菩提。应现等证故说十处如是次第

释曰。云何如是次第说者。问谓诸菩萨于诸法因要先善已广说。乃至彼果涅槃及与无上正等菩提应现等证故者。答要先了知诸法因已。后于缘起方得善巧。必有因故果得生起非自在等。由此能得因果两智。次后于因所生诸法应了其相。何等为相。谓实无有遍计所执。定执为有名为增益。增益无故损减实有圆成实性。远离如是二边过失故名善巧。次于如是所取诸相。由唯识性应正通达得无障碍。次于随顺入唯识性。世俗所证世间六种波罗蜜多。由胜义故应更证得。是应修作清净增上意乐摄义。次于十地分分差别应勤修习。谓要经三无数大劫。非如声闻极疾三生。勤修对治便证解脱。次后即于如是修中增上戒等。菩萨三学应令圆满。最后于彼学果涅槃。烦恼水断及与无上正等菩提。三种佛身应现等证故。说十处如是次第

论曰。又此说中一切大乘皆得究竟

释曰。一切大乘齐此究竟。何以故。若欲说缘起即入阿赖耶识摄。若欲说诸相即入三自性摄。若欲说证得即入唯识性摄。若欲说波罗蜜多即入波罗蜜多摄。若欲说诸地即入诸地摄。若欲说诸学即入诸学摄。若欲说断及智即入无住涅槃及三种佛身摄。齐是名为一切佛语。是故但说如此次第

    摄大乘论释所知依分第二之一

论曰。此中最初且说所知依。即阿赖耶识。世尊何处说阿赖耶识名阿赖耶识。谓薄伽梵于阿毗达磨大乘经伽他中说

  无始时来界　　一切法等依
  由此有诸趣　　及涅槃证得

释曰。此中能证阿赖耶识。其体定是阿赖耶识。阿笈摩者。谓薄伽梵即初所说阿毗达磨大乘经中说如是颂。界者谓因。是一切法等所依止。现见世间于金矿等说界名故。由此是因故一切法等所依止因。体即是所依止义。由此有者由一切法等所依有。诸趣者。于生死中所有诸趣。趣者谓异熟果。由此果故或是顽愚喑哑种类。或有势力能了善说恶说法义。或能证得上胜证得。又为烦恼所依止性。由此故有猛利烦恼长时烦恼。如是四种异熟差别所依止故。无有堪能。应知翻此名有堪能。非唯诸趣由此而有。亦由此故证得涅槃。要由有杂染方得涅槃故

论曰。即于此中复说颂言

  由摄藏诸法　　一切种子识
  故名阿赖耶　　胜者我开示

释曰。已引阿笈摩证阿赖耶识。是所知依体。复引阿笈摩证阿赖耶识名阿赖耶识。于此颂中由第二句释第一句。胜者即是诸菩萨众

论曰。如是且引阿笈摩证复何缘故此识说名阿赖耶识。一切有生杂染品法。于此摄藏为果性故。又即此识于彼摄藏为因性故。是名说名阿赖耶识。或诸有情摄藏此识为自我故。是故说名阿赖耶识

释曰。今训此识阿赖耶名。一切有生者。诸有生类皆名有生。杂染品法者。是遮清净义于中转故名为摄藏。或诸有情摄藏此识为自我者。是执取义

论曰。复次此识亦名阿陀那识。此中阿笈摩者如解深密经说

  阿陀那识甚深细　　一切种子如瀑流
  我于凡愚不开演　　恐彼分别执为我

释曰。复引解深密经。即此阿笈摩中。佛告广慧菩萨摩诃萨曰。广慧当知。于六趣生死。彼彼有情堕彼彼有情众中。或在卵生。或在胎生。或在湿生。或在化生。身分生起。于中最初一切种子心识成熟。展转和合增长广大。依二执受。一者有色诸根及所依执受。二者相名分别言说戏论习气执受。有色界中具二执受。无色界中不具二种。广慧。此识亦名阿陀那识。何以故。由此识于身随逐执持故。亦名阿赖耶识。何以故。由此识于身摄受藏隐同安危义故。亦名为心。何以故。由此识色声香味触等积集滋长故。广慧。阿陀那识为依止为建立故。六识身转谓眼识耳鼻舌身意识。此中有识眼及色为缘生眼识。与眼识俱随行。同时同境有分别意识转。有识耳鼻舌身及声香味触为缘生。耳鼻舌身识与耳鼻舌身识俱随行。同时同境有分别意识转。广慧。若于尔时一眼识转即于此时唯有一分别意识。与眼识同所行转。若于尔时二三四五诸识身转。即于此时唯有一分别意识。与五识身同所行转。广慧。譬如大瀑水流。若有一浪生缘现前唯一浪转。若二若多浪生缘现前有多浪转。然此瀑水自类恒流无断无尽。又如善净镜面。若有一影生缘现前唯一影起。若二若多影生缘现前有多影起。非此镜面转变为影。亦无受用减尽可得。如是广慧。由似瀑流阿陀那识为依止为建立故。若于尔时有一眼识生缘现前。即于此时一眼识转。若于尔时乃至有五识身生缘现前。即于此时五识身转。广慧如是菩萨虽由法住智为依止为建立故。于心意识秘密善巧。然诸如来不齐于此施设彼为于心意识一切秘密善巧菩萨。广慧。若诸菩萨于内各别如实不见阿陀那不见阿陀那识。不见阿赖耶不见阿赖耶识。不见积集不见心。不见眼色及眼识。不见耳声及耳识。不见鼻香及鼻识。不见舌味及舌识。不见身触及身识。不见意法及意识。是名胜义善巧菩萨。如来施设彼为胜义善巧菩萨。广慧。齐此名为于心意识一切秘密善巧菩萨。如来齐此施设彼为于心意识一切秘密善巧菩萨。此伽他中重显彼义。阿陀那识者。所释异名。甚深细者。难了知故。一切种子如瀑流者。次第转故一切种子刹那展转如瀑水流相续转故。恐彼分别执为我者。一行相转故分别执可得

论曰。何缘此识亦复说名阿陀那识。执受一切有色根故。一切自体取所依故。所以者何。有色诸根由此执受。无有失坏尽寿随转。又于相续正结生时。取彼生故。执受自体。是故此识亦复说名阿陀那识

释曰。执受一切有色诸根故者。所以者何。有色诸根由此执受。尽寿随转用此为释。谓由眼等有色诸根阿赖耶识所摄受故。非如死身青瘀等位。若至死时此舍离故。彼即便有青瘀等位。是故定知此执受故乃至寿限彼不失坏。一切自体取所依故者。又于相续正结生时取彼生故。执受自体。用此为释。谓由此识是相续识故。于相续正结生时能摄受生一期自体。亦为此识之所摄受。由阿赖耶识中一期自体熏习住故。彼体起故说名彼生。受彼生故名取彼生。由能取故执受自体。以是义故阿赖耶识。亦复说名阿陀那识

论曰。此亦名心。如世尊说心意识三。此中意有二种第一与作等无间缘所依止性。无间灭识能与意识作生依止。第二染污意与四烦恼恒共相应。一者萨迦耶见。二者我慢。三者我爱。四者无明。此即是识杂染所依。识复由彼第一依生。第二杂染了别境义故。等无间义故思量义故。意成二种

释曰。此亦名心者。阿赖耶识即是心体。意识二义差别可得。当知心义亦有差别。显示此故此中与作等无间缘因性。谓无间灭识与意识为因是第一意。由四烦恼常所染污

是第二意。此中萨迦耶见者。谓执我性。由此势力便起我慢。恃我我所而自高举。于实无我起有我贪。名为我爱。如是三种无明为因。言无明者。即是无智识。复由彼第一依生。第二杂染者。谓无间灭识说名为意。与将生识容受处所故作生依。第二染污意为杂染所依。以于善心中亦执有我故。了别境义故。等无间义故思量义故。意成二种者。谓于此中由取境义说名为识。由与处义名第一意。由执我等成杂染义名第二意

论曰。复次云何得知有染污意。谓此若无不共无明则不得有成过失故。又五同法亦不得有。成过失故。所以者何。以五识身必有眼等俱有依故。又训释词亦不得有成过失故。又无想定与灭尽定差别无有成过失故。谓无想定染意所显非灭尽定。若不尔者此二种定应无差别。又无想天一期生中应无染污成过失故。于中若无我执我慢。又一切时我执现行现可得故。谓善不善无记心中。若不尔者唯不善心彼相应故。有我我所烦恼现行非善无记。是故若立俱有现行。非相应现行无此过失。此中颂曰

  若不共无明　　及与五同法
  训词二定别　　无皆成过失
  无想生应无　　我执转成过
  我执恒随逐　　一切种无有
  杂染意无有　　二三成相违
  无此一切处　　我执不应有
  真义心当生　　常能为障碍
  俱行一切分　　谓不共无明

此意染污故有覆无记性。与四烦恼常共相应如色无色二缠烦恼。是其有覆无记性摄。色无色缠为奢摩他所摄藏故。此意一切时微细随逐故

释曰。此文复以余道理成立染污意。何等名为成立道理。谓此若无不共无明即不得有。不共无明。其相云何。谓未生对治能障真智愚。此于五识理不相应。是处无容能为障故。若处有能治此处有所治。亦不得在染污意识此非有者。余惑现行名不成故。若立此烦恼在染污意识。即应毕竟成染污性。云何施等心得成善。与此烦恼恒相应故。若说有意识与善法俱转。此即与彼烦恼相应。是染意识引生能治。不应道理。若说染污意俱转有善心。即此善心引生能治此生彼灭即无过失。又五同法故。所以者何。譬如眼等五识。必有眼等五根为俱有依。如是意识亦应决定有俱有依。又训释词故。所以者何。能思量故说名为意。此训释词何所依止。非彼六识与无间识作所依止。应正道理。已谢灭故。又二定别故。所以者何。若定说有染污意者。无想定中即有此意。余定中无故有差别。若异此者。于二定中第六意识并不行故。应无差别。又无想中生应无我执故。所以者何。若彼位中无染污意。彼一期生应无我执。若尔不应圣所诃厌。既被诃厌。是故定知彼有我执。又我执随故。所以者何。施等位中亦决定有我执随故。此我执随若离无明不应道理。非此无明离所依止。此所依止离染污意无别体故。故定应许有染污意。若不许者有上过失。重显彼故说四伽他若不共无明等。乃至广说。此中不共无明者。谓于一切善不善无记烦恼随烦恼位中。染污意相应俱生无明。彼若无者成大过失。常于苦等障碍智生。是其业用。此即显无业用过失。五同法者。第六意识与五识身有相似法。彼有五根阿赖耶识为俱有依。此亦如是有染污意。阿赖耶识为俱有依。此五同法离染污意决定无有。此则显无自性过失。训词若无成过失者。取所缘相而思量故。无间灭时能取境故。说名为意。过去已灭无所思量。云何当有能思量性。训词无故成大过失。二定别者。灭尽定中无染污意。无想定中有染污意。此若无者。如是二定差别应无。成大过失。又染污意若无有者。无想身中应无我执。非异生者。于相续中暂离我执应正道理。如是诸过离染污意皆定应得。故应定许有染污意。为显此义故复说言无有二等。二者即是不共无明五相似法。三相违者。谓训释词二定差别。无想生中我执恒随离染污意。如是三事皆成相违。无此一切处我执不应有者。离染污意于一切种善等位中。我执恒随不应得有。故应定许有染污意。余文易了不复须释

论曰。心体第三若离阿赖耶识无别可得。是故成就阿赖耶识以为心体。由此为种子意及识转

释曰。心体第三若离阿赖耶识无别有性。由此为因意及转识皆得生起。见取转识当知亦即取第二意。所以者何。彼将灭时得意名故

论曰。何因缘故亦说名心。由种种法熏习种子所积集故

释曰。复欲释名故作此问。由种种法者。由各别品类法。熏习种子者。功能差别因。所积集故者。是极积聚一合相义

论曰。复次何故声闻乘中不说此心。名阿赖耶识。名阿陀那识。由此深细境所摄故。所以者何。由诸声闻不于一切境智处转。是故于彼虽离此说。然智得成解脱成就。故不为说。若诸菩萨定于一切境智处转。是故为说。若离此智不易证得一切智智

释曰。由此深细境所摄者。谓此境界即深细故名深细境。此即深细境界中摄难了知故。非诸声闻为求一切境界智。故正勤修行。唯正希求自义利故。彼由粗浅苦等正智。便能永断烦恼障故。若诸菩萨为利自他求断烦恼及所知障正勤修行。是故为说

摄大乘论释卷第一摄大乘论释卷第二

        世亲菩萨造

        三藏法师玄奘奉　诏译

    所知依分第二之二

论曰。复次声闻乘中亦以异门密意已说阿赖耶识。如彼增一阿笈摩说。世间众生爱阿赖耶。乐阿赖耶。欣阿赖耶。喜阿赖耶。为断如是阿赖耶故。说正法时恭敬摄耳。住求解心法随法行。如来出世如是甚奇希有正法出现世间。于声闻乘如来出现。四德经中由此异门密意。已显阿赖耶识。于大众部阿笈摩中亦以异门密意说此名根本识。如树依根。化地部中亦以异门密意说此名穷生死蕴。有处有时见色心断。非阿赖耶识中彼种有断

释曰。世间众生爱阿赖耶者。是总标句。如其次第复以余句约就现在过去未来三时别释。复有别义。谓于现在爱阿赖耶。于过去时乐阿赖耶。由先世乐阿赖耶故。复于今世欣阿赖耶。由乐由欣阿赖耶故。于未来世喜阿赖耶。法随法行者如教行故。大众部中名根本识。如树依根者。谓根本识为一切识根本因故。譬如树根茎等总因。若离其根茎等无有。阿赖耶识名根本识。当知亦尔。化地部中异门说为穷生死蕴。为释此因说有处等。言有处者。谓无色界无有诸色。言有时者。谓无想等诸定位中无有诸心。非阿赖耶识中彼种有断者。谓阿赖耶识中色心熏习。由此为因色心还有

论曰。如是所知依说阿赖耶识为性。阿陀那识为性心为性。阿赖耶为性根本识为性穷生死蕴为性等。由此异门阿赖耶识成大王路

释曰。由此异门阿赖耶识成大王路者。是极广义

论曰。复有一类。谓心意识义一文异。是义不成。意识两义差别可得。当知心义亦应有异。复有一类。谓薄伽梵所说众生爱阿赖耶。乃至广说。此中五取蕴说名阿赖耶。有余复谓贪俱乐受名阿赖耶。有余复谓萨迦耶见名阿赖耶。此等诸师由教及证愚阿赖耶故作此执。如是安立阿赖耶名。随声闻乘安立道理亦不相应。若不愚者取阿赖耶识安立彼说。阿赖耶名如是安立则为最胜。云何最胜。若五取蕴名阿赖耶。生恶趣中一向苦处最可厌逆。众生一向不起爱乐。于中执藏不应道理。以彼常求速舍离故。若贪俱乐受名阿赖耶。第四静虑以上无有。具彼有情常有厌逆。于中执藏亦不应理。若萨迦耶见名阿赖耶。于此正法中信解无我者。恒有厌逆。于中执藏亦不应理。阿赖耶识内我性摄。虽生恶趣一向苦处。求离苦蕴。然彼恒于阿赖耶识。我爱随缚未尝求离。虽生第四静虑以上于贪俱乐恒有厌逆。然彼恒于阿赖耶识。我爱随缚。虽于此正法信解无我者厌逆我见。然于藏识我爱随缚。是故安立阿赖耶识。名阿赖耶成就最胜

释曰。不愚者者。谓诸菩萨彼所宣说。阿赖耶识理成立故。恶趣中者。谓饿鬼傍生及那落迦诸恶趣中。一向苦处者。谓一向受非爱业果处。于彼有时乐受生者是等流果。生彼所受异熟果者。唯是其苦。第四静虑以上无有者。谓即第四静虑及上诸地。具彼有情者。谓生所得。阿赖耶识内我性摄者。谓诸众生摄取此识。为内我性。求离苦蕴者。求离苦受。然于藏识我爱随缚者。谓于阿赖耶识执我起爱随缚不离

论曰。如是已说阿赖耶识安立异门安立。此相云何可见安立。此相略有三种。一者安立自相。二者安立因相。三者安立果相。此中安立阿赖耶识自相者。谓依一切杂染品法。所有熏习为彼生因。由能摄持种子相应。此中安立阿赖耶识因相者。谓即如是一切种子阿赖耶识。于一切时与彼杂染品类诸法现前为因。此中安立阿赖耶识果相者。谓即依彼杂染品法。无始时来所有熏习。阿赖耶识相续而生

释曰。如是已说阿赖耶识安立异门。非说异门即了其相。是故次说此识自性因性果性。此中安立自相者。谓缘一切杂染品法所有熏习。能生于彼功能差别识为自性。为欲显示如是功能。故说摄持种子相应。谓依一切杂染品法所有熏习。即与彼法为能生因。摄持种子者。功能差别也。相应者。是修义。是名安立此识自相。此中安立因相者。谓即次前所说品类一切种子。阿赖耶识由彼杂染品类诸法熏习。所成功能差别为彼生因。是名安立此识因相。此中安立果相者。谓即依彼杂染品法无始熏习。此识续生而能摄持无始熏习。是名安立此识果相。此中自相是依一切杂染品法。无始熏习为彼生因。摄持种子识为自性。果性因性之所建立。此中因相。是彼杂染品类诸法熏习所成。功能差别为彼生因。唯是因性之所建立。此中果相。是依杂染品类诸法无始熏习。阿赖耶识相续而生。唯是果性之所建立。是三差别

论曰。复次何等名为熏习。熏习能诠。何为所诠。谓依彼法俱生俱灭。此中有能生彼因性。是谓所诠。如巨胜中有花熏习。巨胜与花俱生俱灭。是诸巨胜带能生彼香因而生。又如所立贪等行者。贪等熏习依彼贪等俱生俱灭。此心带彼生因而生。或多闻者多闻熏习。依闻作意俱生俱灭。此心带彼记因而生。由此熏习能摄持故。名持法者。阿赖耶识熏习道理。当知亦尔

释曰。谓依彼法俱生俱灭。此中有能生彼因性。是谓所诠者。谓即依彼杂染诸法俱生俱灭。阿赖耶识有能生彼。诸法因性是名熏习

论曰。复次阿赖耶识中诸杂染品法种子。为别异住为无别异。非彼种子有别实物。于此中住亦非不异。然阿赖耶识如是而生。有能生彼功能差别。名一切种子识

释曰。阿赖耶识中杂染法种子。为异为不异。若尔何失。若有异者彼诸种子应分分别。阿赖耶识刹那灭义亦不应成。有别异故由善不善熏习力故。种子应成善不善性。然许无记。若不异者云何有多。此不应理。是故二说俱有过失。非彼种子有别实物。于此中住亦非不异。乃至名一切种子识者。为避如前所说过失。故不定取异及不异。如是而生者。谓由如是品类而生。有能生彼功能差别者。谓有能生杂染品法。功能差别相应道理。由与生彼功能相应故。名一切种子识。于此义中有现譬喻。如大麦子于生自芽有功能故有种子性。若时陈久或火相应。此大麦果功能损坏。尔时麦相虽住如本。势力坏故无种子性。阿赖耶识亦复如是。有生杂染诸法功能。由此功能相应故。说名一切种子识

论曰。复次阿赖耶识与彼杂染诸法同时更互为因。云何可见。譬如明灯焰炷生烧同时更互。又如芦束互相依持同时不倒。应观此中更互为因道理亦尔。如阿赖耶识为杂染诸法因。杂染诸法亦为阿赖耶识因。唯就如是安立因缘。所余因缘不可得故

释曰。复次阿赖耶识与彼杂染诸法同时更互为因云何可见者。欲以喻显。故为此问。譬如明灯焰炷生烧同时更互者。谓一刹那灯炷为依发生灯焰。是则灯炷为焰生因。即此刹那焰复能烧所依灯炷。是则灯焰为炷烧因。余喻亦尔。如是显示有俱有因。由因现在住即见果生故。从如阿赖耶识为杂染诸法因。乃至所余因缘不可得故者。此言显示阿赖耶识与杂染法更互为因即是因缘

论曰。云何熏习无异无杂。而能与彼有异有杂诸法为因。如众缬具缬所缬衣。当缬之时虽复未有异杂。非一品类可得入染器后。尔时衣上便有异杂。非一品类。染色绞络文像显现。阿赖耶识亦复如是。异杂能熏之所熏习。于熏习时。虽复未有异杂可得。果生染器现前已后。便有异杂无量品类诸法显现

释曰。云何熏习无异无杂而能与彼有异有杂诸法为因者。欲以譬喻显斯道理。故为此问。如众缬具缬所缬衣。当缬之时。虽无异杂文像可见。入染器后。便有异杂文像可见。阿赖耶识如所染衣。果生即染器。故名果生染器。入者即是缘所摄义。于熏习时虽无异杂。至果熟位便有非一品类诸法因性显现如已染衣

论曰。如是缘起于大乘中极细甚深。又若略说有二缘起。一者分别自性缘起。二者分别爱非爱缘起。此中依止阿赖耶识诸法生起。是名分别自性缘起。以能分别种种自性为缘性故。复有十二支缘起。是名分别爱非爱缘起。以于善趣恶趣能分别爱非爱种种自体为缘性故

释曰。如是缘起于大乘中极细甚深者。异生觉慧难了知故名为极细。阿罗汉等难穷底故名为甚深。又若略说有二缘起者。举数。一者分别自性缘起。二者分别爱非爱缘起者。列名。此中依止阿赖耶识者。谓阿赖耶识为因诸法生起。是名分别自性缘起。由能分别异类自性为因性故。若无明等是名分别爱非爱缘起。由能分别爱非爱种种自体为因性故

论曰。于阿赖耶识中。若愚第一缘起。或有分别自性为因。或有分别宿作为因。或有分别自在变化为因。或有分别实我为因。或有分别无因无缘。若愚第二缘起。复有分别我为作者我为受者。譬如众多生盲士夫未曾见象。复有以象说而示之。彼诸生盲有触象鼻。有触其牙。有触其耳。有触其足。有触其尾。有触脊梁。诸有问言。象为何相。或有说言。象如犁柄。或说如杵。或说如箕。或说如臼。或说如帚。或有说言。象如石山。若不解了此二缘起。无明生盲亦复如是。或有计执自性为因。或有计执宿作为因。或有计执自在为因。或有计执实我为因。或有计执无因无缘。或有计执我为作者我为受者。阿赖耶识自性因性及果性等。如所不了象之自性

释曰。或有分别宿作为因者。谓彼不许有士用因故成邪执。为显此等说生盲喻。无明生盲者。谓由无明故成生盲。阿赖耶识自性因性及果性等如所不了象之自性者。谓前所立此识自相说名自性。所立因相说名因性。所立果相说名果性。由无明力不了此等。于阿赖耶识。分别自性缘起不解了故。执自性等为诸法因。于第二分别爱非爱缘起不解了故。执有我为作者受者。此中因谓阿赖耶识。诸法熏习于中持故。果者即是阿赖耶识即彼诸法所熏习故

论曰。又若略说阿赖耶识用。异熟识一切即种子为其自性。能摄三界一切自体一切趣等

释曰。阿赖耶识用异熟识一切种子为自性者。谓得自体异类熟故。诸法种子熏在中故。一切趣等者。谓五趣等。一切自体者。谓趣趣中同分异分种种差别

论曰。此中五颂

  外内不明了　　于二唯世俗
  胜义诸种子　　当知有六种
  刹那灭俱有　　恒随转应知
  决定待众缘　　唯能引自果
  坚无记可熏　　与能熏相应
  所熏非异此　　是为熏习相
  六识无相应　　三差别相违
  二念不俱有　　类例余成失
  此外内种子　　能生引应知
  枯丧由能引　　任运后灭故

为显内种非如外种。复说二颂

  外或无熏习　　非内种应知
  闻等熏习无　　果生非道理
  作不作失得　　过故成相违
  外种内为缘　　由依彼熏习

释曰。如是已说阿赖耶识。为一切法真实种子。复欲显示彼种子体说斯五颂。此中外者。谓稻谷等。内者。即是阿赖耶识。不明了者。谓外种子是无记义。言于二者。阿赖耶识于善不善二性。明了通有记故。复有别义。谓于杂染清净明了。唯世俗者。谓外种子唯就世俗说为种子。所以者何。彼亦皆是阿赖耶识所变现故。胜义即是阿赖耶识。所以者何。是一切法真种子故。应知如是一切种子复有六义。刹那灭者。谓二种子皆生无间定灭坏故。所以者何。不应常法为种子体。以一切时其性如本无差别故。言俱有者。谓非过去亦非未来。亦非相离得为种子。何以故。若于此时种子有。即于尔时果生故。恒随转应知者。谓阿赖耶识乃至治生。外法种子乃至根住。或乃至熟。言决定者。谓此种子各别决定。不从一切一切得生。从此物种还生此物。待众缘者。谓此种子待自众缘方能生果。非一切时能生一切。若于是处是时遇自众缘。即于此处此时自果得生。唯能引自果者。谓自种子但引自果。如阿赖耶识种子唯能引生阿赖耶识。如稻谷等唯能引生稻谷等果。如是且显种果生义。今当更示熏习异相。坚者。坚住方可受熏。非如动风。所以者何。风性疏动不能任持。所有熏气一踰膳那。彼诸熏气亦不随转。占博迦油能持香气百踰膳那。彼诸香气亦能随转。言无记者。是不可记极香臭义。由此道理蒜不受熏。以极臭故。如是香物亦不受熏。以极香故。若物非极香臭所记即可受熏。言可熏者。谓应受熏方可熏习。非不受熏如金石等。不应受熏名不可熏。若于此时能受熏习。即于尔时名为可熏。如可熏物。与能熏相应者。能熏相应方名可熏。非不相应。当知即是无间生义。言所熏者。阿赖耶识具上四德。应受熏习故名所熏。非转识等。非异此者。谓若离此阿赖耶识余非所熏。是故所熏即此非异。是为熏习相者。谓阿赖耶识有刹那灭等。是熏习相刹那灭故。与诸转识俱时有故。乃至对治恒随转故。或穷生死恒随转故。定与善等为因性故。待福非福不动行缘。于善恶趣异类熟故。如是等义于转识中。一切异法皆应成立。是故唯此阿赖耶识。与如是等胜德相应可受熏习。六识无相应者。谓彼诸识有动转故。三差别相违者。谓彼诸识别别所依。别别所缘别别作意。复有余义。别别行相一一转故。譬喻论师欲令前念熏于后念。为遮彼故。说言二念不得俱有。无二刹那一时而有。俱生俱灭熏习住故。若谓此识种类如是虽不相应。然同识类亦得相熏。如是例余应成过失。谓余种类例亦应尔。以眼等根同净色类。亦应展转更互相熏。此意说言眼耳两根同有净法。二净展转应互相熏。余亦如是。然汝不许。虽同净法异相续故不得相熏。识亦应尔。虽同识法何得相熏。如是所说二种种子。谓外及内。应知皆有能生能引。此中外种乃至果熟。为能生因。内种乃至寿量边际。为能生因。外种能引枯后相续。内种能引丧后尸骸。由引因故多时续住。若二种子唯有生因。此因既坏果即应灭。应无少时相续住义。若谓刹那展转相续。前念为因后念随转。是则后边不应都灭。由此决定应有引因。此二种子。譬如放弦弯弓为因。箭不堕落远有所至

论曰。复次其余转识。普于一切自体诸趣。应知说名能受用者。如中边分别论中说伽他曰

  一则名缘识　　第二名受者
  此中能受用　　分别推心法

释曰。此中受用是生起义。受用中有名受用者。为显此义故。引中边分别论颂为阿笈摩

论曰。如是二识更互为缘。如阿毗达磨大乘经中说伽他曰

  诸法于识藏　　识于法亦尔
  更互为果性　　亦常为因性

释曰。阿赖耶识与一切法。于一切时互为因果。展转相生。若于此时阿赖耶识为诸法因。即于尔时诸法为果。若于此时阿赖耶识为诸法果。即于尔时诸法为因

论曰。若于第一缘起中。如是二识互为因缘。于第二缘起中。复是何缘。是增上缘如是六识几缘所生。增上所缘等无间缘。如是三种缘起。谓穷生死爱非爱趣。及能受用具有四缘

释曰。此中第一缘起。谓阿赖耶识中所有习气。与彼诸法互为因缘。第二缘起。谓无明等为增上缘。由无明等增上势力行等生故。又六转识名受用缘起。三缘所生。谓眼识以眼为增上缘。以色为所缘缘。等无间缘。谓彼无间此识生起。所以者何。若彼不与容受处者此不生故。余识亦尔

论曰。如是已安立阿赖耶识异门及相。复云何知如是异门及如是相。决定唯在阿赖耶识非于转识。由若远离如是安立阿赖耶识。杂染清净皆不得成。谓烦恼杂染。若业杂染。若生杂染。皆不成故。世间清净出世清净。亦不成故

释曰。如是已说阿赖耶识。安立异门及安立相。今当显示。此二唯在阿赖耶识应正道理。非于余处。以理决择

论曰。云何烦恼杂染不成。以诸烦恼及随烦恼熏习所作。彼种子体于六识身不应理故。所以者何。若立眼识。贪等烦恼及随烦恼俱生俱灭。此由彼熏成种非余。即此眼识若已谢灭。余识所闻如是熏习。熏习所依皆不可得。从此先灭余识所闻现无有体。眼识与彼贪等俱生不应道理。以彼过去现无体故。如从过去现无体业。异熟果生不应道理。又此眼识贪等俱生。所有熏习亦不成就。然此熏习不住贪中。由彼贪欲是能依故。不坚住故。亦不得住所余识中。以彼诸识所依别故。又无决定俱生灭故。亦复不得住自体中。由彼自体决定无有俱生灭故。是故眼识贪等烦恼。及随烦恼之所熏习不应道理。又复此识非识所熏。如说眼识。所余转识亦复如是。如应当知

释曰。此中此者。即此眼识由彼熏者。由贪等熏。言成种者。谓成因性。言非余者。非耳识等。余识所闻者。耳等识所闻。如是熏习者。贪等熏习。熏习所依者。谓即眼识。眼识与彼贪等俱生等者。谓从过去现无体因。眼识与彼贪等俱生不应道理。如从过去现无体业异熟果生不应道理者。如彼果生不应道理。此亦如是不应道理。复有余师执彼有体。谓异论师欲令过去是实有性。然过去能诠所诠不可得。所以者何。若法是实有。云何名过去。是故从彼异熟果生不应道理。熏习无故。又此眼识者。谓与贪等俱生眼识。所有熏习亦不成就者。谓彼熏习尚不成就。何况从彼后时眼识。与贪俱生而当得成。然此熏习不住贪中者。谓眼识熏习在贪欲中不应道理。何以故。由彼贪欲依眼识故。不坚住故亦不得住所余识中者。谓此熏习不得在于耳等识中。何以故。以彼诸识所依别故。由所依别无有决定。俱生灭义。谓眼识依眼。耳识依耳。如是乃至意识依于未那。所依远故。所余熏习在所余处不应道理。亦复不得住自体中者。谓此眼识亦复不得熏习眼识。无二眼识俱时起故。以无二故决定无有俱生灭义。由此道理。是故眼识定不应为贪等烦恼及随烦恼之所熏习。亦非眼识眼识所熏

论曰。复次从无想等上诸地没来生此间。尔时烦恼及随烦恼所染初识。此识生时应无种子。由所依止及彼熏习。并已过去现无体故

释曰。所染初识者。谓来此间最初生识。此识生时应无种子者。谓初生识应无因生。所依止者谓所依止。彼熏习者。烦恼熏习

论曰。复次对治烦恼识若已生。一切世间余识已灭。尔时若离阿赖耶识。所余烦恼及随烦恼种子。在此对治识中不应道理。此对治识自性解脱故。与余烦恼及随烦恼。不俱生灭故。复于后时世间识生。尔时若离阿赖耶识。彼诸熏习及所依止。久已过去。现无体故。应无种子而更得生。是故若离阿赖耶识。烦恼杂染皆不得成

释曰。对治烦恼识若已生一切世间余识已灭者。谓六识已灭。所余烦恼及随烦恼种子在此对治识中不应道理者。谓对治识非后世间识生起因。复于后时者。谓复从此出世心后。彼诸熏习者。谓余烦恼及随烦恼所有熏习。及所依止者。谓所依识。应无种子而更得生者。谓若无有阿赖耶识。彼应无因而更得生。此中烦恼即是杂染。是故说名烦恼杂染。由上道理。烦恼杂染皆不得成

论曰。云何为业杂染不成。行为缘识不相应故。此若无者。取为缘有亦不相应

释曰。为辩业杂染不得成因缘故。次问云何业杂染不成业为缘识不相应故者。谓福非福及不动行生已谢灭。若不信有阿赖耶识。当于何处安立熏习。如六识身。不能任持所有熏习。于诸烦恼杂染事中已具显示。此若无者。谓若无有行为缘识。取为缘有亦不相应者。谓亦无有取为缘有。此复何缘。谓前诸行所熏习识。由取力故。熏习增长转成有故。此中即业是杂染性。名业杂染或依于业而有杂染。名业杂染。若不信有阿赖耶识。此业杂染亦不得成

摄大乘论释卷第二摄大乘论释卷第三

        世亲菩萨造

        三藏法师玄奘奉　诏译

    所知依分第二之三

论曰。云何为生杂染不成。结相续时不相应故

释曰。若不信有阿赖耶识。如生杂染亦不得成。今当显示。结相续时不相应故者。谓得自体不相应故

论曰。若有于此非等引地。没已生时。依中有位意起。染污意识结生相续。此染污意识。于中有中灭。于母胎中。识羯罗蓝更相和合。若即意识与彼和合。既和合已依止此识。于母胎中有意识转。若尔即应有二意识。于母胎中同时而转。又即与彼和合之识。是意识性不应道理。依染污故。时无断故。意识所缘不可得故。设和合识即是意识。为此和合意识。即是一切种子识为依止。此识所生余意识。是一切种子识。若此和合识是一切种子识。即是阿赖耶识。汝以异名立为意识。若能依止识是一切种子识。是则所依因识。非一切种子识。能依果识是一切种子识。不应道理。是故成就此和合识。非是意识但是异熟识是一切种子识

释曰。非等引地。即是欲界。没者死也。染污意识。即是烦恼俱行意识。结生相续者。谓摄受自体。此染污意识。缘生有为境。于中有中灭。言和合者。识与赤白同一安危。若和合识即是意识。依此复生所余意识。是则一时二意识转。谓所依止和合意识。及能依止所余意识。又和合识是意识性。不应道理。何以故。依染污故。时无断故。谓此意识贪等烦恼所染污。意为所依止。缘生有境故。是染污即此为依。名依染污。于此位中所依异熟不容染污。是无记故。此和合识常无间断。任业转故。意识所缘不可得故者。意识所缘明了可得。所谓诸法。此和合识无有如是明了所缘。是故此识是意识性。不应道理

论曰。复次结生相续已。若离异熟识。执受色根亦不可得。其余诸识各别依故。不坚住故。是诸色根不应离识

释曰。结生相续已者。谓已得自体。若离异熟识者。谓离阿赖耶识。其余诸识各别依故。不坚住故者。谓余六识各别处故。易动转故。且如眼识眼为别依。如是其余耳等诸识。耳等色根为各别依。由此道理。如是诸识但应执受自所依根。又此诸识易动转故。或时无有。若离阿赖耶识。尔时眼等诸根无能执受。便应烂坏

论曰。若离异熟识。识与名色更互相依。譬如芦束相依而转。此亦不成

释曰。若离异熟识者。谓离阿赖耶识如不得成。今当显示。谓世尊言识缘名色。名色缘识。此中识缘名者。谓六识中非色四蕴。识缘色者。谓羯逻蓝。若不说有阿赖耶识。何等名为名色缘识。由依名色刹那展转。相似相续流转不绝

论曰。若离异熟识。已生有情识食不成。何以故。以六识中随取一识。于三界中已生有情。能作食事不可得故

释曰。此言显示识食不成。如世尊说。食有四种。一者段食。二者触食。三者意思食。四者识食。此中段食者。是能转变。由转变故饶益所依。触食者是能取境。由暂能见色等境界。便令所依饶益生故。意思食者。是能悕望。由希望故饶益所依。如远见水虽渴不死。识食者。是能执受。由执受故所依久住。若不尔者应同死尸。不久烂坏。是故应许识亦是食。能作所依饶益事故。此中触食属六识身。意思食者属悕望意。有何别识可说为食。又若无心睡眠闷绝。入灭定等。六识身灭。谁复有余能执受身令不烂坏。若有弃舍阿赖耶识。身必烂坏

论曰。若从此没。于等引地正受生时。由非等引染污意识。结生相续。此非等引染污之心。彼地所摄。离异熟识。余种子体定不可得

释曰。如是已说非等引地结生相续。离异熟识不可得成。如等引地亦不得成。今当显示。谓于此处由染污识结生相续。于等引地。由非等引染污意识结生相续。言染污者。彼地烦恼之所染污。彼地烦恼者。谓餐定味等。此染污心在不定地。不定地没从此没已。即彼地心云何现前。既不现前。云何当得结生相续。由此道理。定应许有阿赖耶识。无始时来。恒有彼地此心熏习。由此熏习此心现行。由此心故结生相续

论曰。复次生无色界。若离一切种子异熟识。染污善心应无种子。染污善心应无依持

释曰。生无色界者。谓已解脱。色染污善心者。谓能爱味及三摩地。应无种子者。谓应无因。应无依持者。谓应无依。复有别义。谓此二心若无种子从何而生。若无依持依何而转。阿赖耶识所摄受故。从自种生为所依故。令此能依相续而转

论曰。又即于彼若出世心正现在前。余世间心皆灭尽故。尔时便应灭离彼趣

释曰。即于彼界若出世心现在前时。除此所余是世间心。彼世间心尔时皆灭。如是彼趣便应永断。不由功用自然证得无余涅槃。既无此理。不应拨无阿赖耶识

论曰。若生非想非非想处无所有处。出世间心现在前时。即应二趣悉皆灭离。此出世识不以非想非非想处为所依趣。亦不应以无所有处为所依趣。亦非涅槃为所依趣

释曰。若生非想非非想处。或时起彼无所有处出世间心。令现在前。由彼处心极明利故。又由非想非非想处心闇钝故。住于彼处极明利心起出世心。令现在前。此出世心不应以彼第一第二为所依趣。由彼二地皆世间故。又生余地起余地心现在前故。二所依趣俱不应理。又即此心不应涅槃为所依趣。有余依故。如是三种为所依趣既不得成。若不信有阿赖耶识。此出世心何所依趣

论曰。又将没时造善造恶。或下或上所依渐冷。若不信有阿赖耶识皆不得成。是故若离一切种子异熟识者。此生杂染亦不得成

释曰。将舍命时造善造恶。或下或上身分渐冷。以造善者必定上升。若造恶者必定下坠。若不许有阿赖耶识为能执受。云何得有所依渐冷。阿赖耶识能执受故。或下或上如其次第。随所舍处身即有冷

论曰。云何世间清净不成。谓未离欲缠贪。未得色缠心者。即以欲缠善心。为离欲缠贪故勤修加行。此欲缠加行心。与色缠心不俱生灭故。非彼所熏。为彼种子。不应道理。又色缠心过去多生余心间隔。不应为今定心种子。唯无有故。是故成就色缠定心。一切种子异熟果识。展转传来为今因缘。加行善心为增上缘。如是一切离欲地中如应当知。如是世间清净。若离一切种子。异熟识理不得成

释曰。如世间清净理不得成。今当显示。谓为远离欲缠贪故。以欲缠善心修加行时。即此欲缠加行善心。未曾为彼色缠善心之所熏习。不俱生灭故。今色缠心应无种子自然而生。又过去世色缠善心。多生所间余识所隔。唯无有故。已过去故。不得为今定心种子。展转传来为今因缘者。阿赖耶识持彼种故。今色缠心从自种生。加行善心非无功力。言功力者。但增上缘。非是因缘。由彼增上力生此色缠心。如是远离色缠贪等。如应当知

论曰。云何出世清净不成。谓世尊说依他言音。及内各别如理作意。由此为因正见得生。此他言音如理作意。为熏耳识。为熏意识。为两俱熏。若于彼法如理思惟。尔时耳识且不得起。意识亦为种种散动余识所间。若与如理作意相应生时。此闻所熏意识与彼熏习久灭过去。定无有体。云何复为种子。能生后时如理作意相应之心。又此如理作意相应。是世间心。彼正见相应是出世心。曾未有时俱生俱灭。是故此心非彼所熏。既不被熏。为彼种子不应道理。是故出世清净。若离一切种子。异熟果识亦不得成。此中闻熏习。摄受彼种子不相应故

释曰。如出世间清净不成。今当显示。此他言音如理作意者。谓与言音相应作意。意识亦为种种散动余识所间者。是与正见相应。出世间心被间隔义。若与如理作意相应生时者。谓于后时。此闻所熏意识与彼熏习久灭过去定无有体者。谓经长时已谢隔越。决定无体。云何复为种子能生后时如理作意相应之心者。谓彼久灭现无有体不能为因。此中闻熏习摄受彼种子不相应故者。谓在世间意识之中故。言此中闻熏习者。依他言音正闻熏习。摄受彼种子者。在意识中摄受出世清净。种子不相应故者。谓彼所计不应理故。云何可说此从彼生

论曰。复次云何一切种子。异熟果识为杂染因。复为出世能对治。彼净心种子。又出世心昔未曾习故。彼熏习决定应无。既无熏习从何种生。是故应答从最清净法界等流正闻熏习种子所生

释曰。云何等者。谓异熟识是所治因。为能治因不应道理。又出世心昔未曾习者。谓先未生故。彼熏习决定应无者。由此因故。彼出世心无有熏习。决定无疑。从最清净法界等流正闻熏习种子所生者。为显法界异声闻等。言最清净。由佛世尊所证法界。永断烦恼所知障故。从最清净法界所流经等教法。名最清净法界等流。无倒听闻如是经等故名正闻。由此正闻所起熏习。名为熏习。或复正闻即是熏习。是故说名正闻熏习。即此熏习相续住在阿赖耶识。为因能起出世间心。是故说言从最清净法界所流正闻熏习种子所生

论曰。此闻熏习为是阿赖耶识自性。为非阿赖耶识自性。若是阿赖耶识自性。云何是彼对治种子。若非阿赖耶识自性。此闻熏习种子所依云何可见。乃至证得诸佛菩提。此闻熏习。随在一种所依转处。寄在异熟识中。与彼和合俱转。犹如水乳。然非阿赖耶识。是彼对治种子性故

释曰。此闻熏习为是阿赖耶识自性为非阿赖耶识自性。若尔何过。若是阿赖耶识自性。云何即为阿赖耶识对治种子。若非阿赖耶识自性。此闻熏习种子即应别有所依。乃至证得诸佛菩提者。谓乃至得诸佛所证无上菩提。此闻熏习者。即是最清净法界等流正闻熏习。随在一种所依转处者。谓随在一相续转处。寄在异熟识中与彼和合俱转犹如水乳者。此闻熏习与异熟识。虽不同性而寄识中。犹如水乳和合俱转。然非阿赖耶识等者。虽复和合似一性转。然非即是阿赖耶识。是能对治阿赖耶识。种子性故

论曰。此中依下品熏习成中品熏习。依中品熏习成上品熏习。依闻思修多分修作。得相应故

释曰。此中下中上品者。应知依闻思修所成慧说。由彼一一有三种故。复有别义。闻所成慧是下品。思所成慧是中品。修所成慧是上品。依闻思修多分修作得相应故者。谓依闻等数数猛利而修作故。又于此中下品为因。得成中品。中品为因得成上品

论曰。又此正闻熏习种子。下中上品应知。亦是法身种子与阿赖耶识相违。非阿赖耶识所摄。是出世间最净法界等流性故。虽是世间。而是出世心种子性。又出世心虽未生时。已能对治诸烦恼缠。已能对治诸崄恶趣。已作一切所有恶业朽坏对治。又能随顺逢事一切诸佛菩萨。虽是世间。应知初修业菩萨所得。亦法身摄。声闻独觉所得。唯解脱身摄。又此熏习非阿赖耶识。是法身解脱身摄如如熏习下中上品次第渐增。如是如是异熟果识次第渐减。即转所依。既一切种所依转已。即异熟果识。及一切种子。无种子而转。一切种永断

释曰。已能对治诸烦恼缠者。谓是能断增上贪等现起转因。已能对治诸崄恶趣者。谓若能断诸烦恼缠。即能对治诸崄恶趣。已作一切所有恶业朽坏对治者。谓若虽有顺后受业应堕恶趣。而能为彼作朽坏因。举要言之此闻熏习能治一切过去未来现在恶业。又能随顺逢事一切诸佛菩萨者。谓是当来逢事善友自身得因。虽是世间应知初修业菩萨所得亦法身摄者。谓诸异生菩萨名初修业菩萨。亦是法身种子故。说亦法身摄。声闻独觉所得唯解脱身摄者。谓声闻等正闻熏习。唯是解脱因。唯得解脱身不得法身故

论曰。复次云何犹如水乳。非阿赖耶识。与阿赖耶识同处俱转。而阿赖耶识一切种尽。非阿赖耶识一切种增。譬如于水鹅所饮乳。又如世间得离欲时。非等引地熏习渐减。其等引地熏习渐增。而得转依

释曰。非阿赖耶识与阿赖耶识。虽同处俱转。而阿赖耶识尽。非阿赖耶识在。还即以前水乳和合。鹅所饮时乳尽水在。譬喻显示。又如世间得离欲时。于一阿赖耶识中。非等引地烦恼熏习渐减。其等引地善法熏习渐增。而得转依。此中转依当知亦尔

论曰。又入灭定识不离身。圣所说故。此中异熟识应成不离身。非为治此灭定生故

释曰。引入灭定识不离言。为成定有阿赖耶识。世尊说识不离身者。除异熟识余不得成。以灭定生对治转识。故观此定为极寂静

论曰。又非出定此识复生。由异熟识既间断已。离结相续无重生故

释曰。若执出定此识还生。由此意故识不离身。此不应理。以从定出识不复生异熟果识既间断已。离结相续更托余生。无重生故

论曰。又若有执。以意识故灭定有心。此心不成。定不应成故。所缘行相不可得故。应有善根相应过故。不善无记不应理故。应有想受现行过故。触可得故。于三摩地有功能故。应有唯灭想过失故。应有其思信等善根现行过故。拔彼能依令离所依不应理故。有譬喻故。如非遍行此不有故

释曰。又若有执以意识故灭定有心此心不成者。若有欲离前说自相阿赖耶识。以余转识灭定有心。此不应理。何以故。定不应成故。未曾见心离心法故。如余心法想受亦尔。俱应不灭。然此灭定俱灭所显。是故应至定不应成。若立唯有阿赖耶识。则无此过。求静住者为治彼怨。余心心法故生。此定不为对治不明了性阿赖耶识。又此定内无有余心。何以故。所缘行相不可得故。诸心心法相续不断。必不远离所缘行相。此灭定中若有心者。亦应不离所缘行相。然此二种俱不可得。是故此定无有余心。若唯立有阿赖耶识无此妨难。执受所依之所显故。又此定中若有转识。此识必有善等差别。谓或是善。或是不善。或是无记。然此中识且非是善。应有善根相应过故。此则相违亦非此识。是自性善。由此不离善根相应。成善性故。由立定心是善性故。至所不欲与无贪等善根相应。此不应许与余善心无差别故。遍一切处应成此过。又于此中亦不得有不善无记。不善无记不应理故。于离欲时。诸不善根皆永断故。不成不善亦非无记。此定善故。又不可立此心是善。应有想受现行过故。若离善根善心不有。是故应至善根现行。此中如有善根现行。想受亦尔。应至现行无别因故。然不应理。所治现行能治无故。譬如贪等正现行时。不净观等决定无有。又此定中离阿赖耶识余心不容有。必应有触可得过故。如住余定决无有疑。谓余定中善根相应。余识转时决定有触。以定所生轻安为相。或顺乐受。或有随顺非苦乐受。此触为缘或生乐受。或复生于非苦乐受。何以故。于余三摩地有此功能故。于余定中见此二触于生二受必有功能此亦应尔。无障因故。触为缘受此中应至然不应理。何以故。应有唯灭想过失故。若许此触为缘生受。于此定中唯应想灭。然不应许想受俱灭。圣所说故。又此定中若有余识。必与其触俱有相应。此不应理。何以故。若有触者应有其思信等善根现行过故。若有其识触相应转。必有与此俱生思等。圣所说故。此中应至有思现行。若此定中有思现行造作善心。必有信等善根现行。然不应许若有欲避如前所说种种过失。及阿笈摩相违过失。由但厌离诸心法故。唯拔心法。于此定中唯立有心无有心法。此亦不然。何以故。拔彼能依令离所依。不应理故。所依是心。能依是心法。所依能依心与心法。无始生死来更互不相离。由此相引。是故定应与无贪等善根相应。若言此定及定方便。与无贪等善根相违故。于定中善根不转。唯善心转。此于余处都未曾见。若于因时。彼法相应等流果时。亦有相应故不应理。又不应理。有譬喻故。谓世尊说。诸身行灭。诸语行灭。诸意行灭。此中身行。谓入出息。其语行者。谓寻与伺。其意行者。谓思想等。如寻伺灭语必不起。意亦如是。若意行灭亦应不起。若汝意谓。如身行灭安住定中。身在不灭意亦如是。虽意行灭应在不灭。此亦不然。何以故。如非遍行此不有故。如世尊说。离身行外有身住因。所谓饮食命根识等。由此虽无入息出息。而身安住。意即不尔。离意行外更无别因持心令住。由此应至无意识故名无心定。异熟果识此中有故。世尊说识不离于身。即从此识一切种子后出定时转识还生。故知定有阿赖耶识

论曰。又此定中。由意识故执有心者。此心是善不善无记。皆不得成故不应理

释曰。已广废立灭定有心。今当略显第二颂义。若有欲除阿赖耶识。以意识故灭定有心。此心是善不善无记皆不得成故不应理。何以故。由此灭定是善性故。且非不善无记亦尔。威仪工巧变化无记。定不得有。若说此是异熟无记。理即应至阿赖耶识。除此更无第五无记。又此定中心若是善。应无贪等善根相应。染污意灭唯善心在。尔时善心所依所缘。皆悉是有三事和合。云何此中不生其触。既有其触。受等心法何得不生。如是灭定应不得成。诸心心法皆不灭故。又若有执此定是善。由心所引定前方便。能引善心力所引故定中善心非无贪等善根相应。又三和合若有堪能亦能生受。若三和合无有堪能。唯生其触。是故定中虽有善心。非无贪等善根相应。亦无受等。此义不然。方便善心既无贪等善根相应。从此所引等流果心。何故不尔。又从所依拔除能依不应理故。心与心法无始已来。于一切时互不相离。今拔能依令离所依必不可得。何以故。有譬喻故。谓于世间从生至坏。于一切时互不相离。无有道理。拔除能依令离所依。譬如大种与所造色。无有道理。令其所造离于能造。心法亦尔。不可令其离所依心。是故于此无心定中。无有心法。但有善心不应道理。若有复谓。令拔能依令离所依。虽不应理。然想及受能障此定。于方便中厌患彼故。唯二不行余法不尔。亦得现行不应道理。何以故。如非遍行此不有故。非遍行者。此中可灭。二是遍行故不可灭。遍行若灭心亦随灭。无别因故。是故此中言有心者。是异熟识定非意识

论曰。若复有执色心无间生。是诸法种子此不得成。如前已说。又从无色无想天没。灭定等出不应道理。又阿罗汉后心不成。唯可容有等无间缘

释曰。若复有执色心无间生。是诸法种子者。谓若有执前刹那色能为种子。后刹那色因彼而生。前识后识相望亦尔。此前已破。又无色没色复生时。色久断灭何有种子。无想天没。或复从于灭定等出。心复生时。心久断灭何有心因。若如是者。诸阿罗汉终不应得无余涅槃。色心两因永无尽故。前刹那色望于后色。前刹那识望于后识。应知容有等无间缘。无有因缘

论曰。如是若离一切种子异熟果识。杂染清净皆不得成。是故成就如前所说相。阿赖耶识决定是有

释曰。由前所说无量道理。是故成就阿赖耶识决定是有

论曰。此中三颂

  菩萨于净心　　远离于五识
  无余心转依　　云何汝当作
  若对治转依　　非断故不成
  果因无差别　　于永断成过
  无种或无体　　若许为转依
  无彼二无故　　转依不应理

释曰。如住转识转依不成。三颂显示。菩萨于净心者。是于出世对治相应善意识义。远离于五识者。谓此远离眼等五识。言无余者。无善有漏杂染意识。已举净心复举无余。为欲遮遣善有漏识。言心转依云何作者。若汝信有阿赖耶识可作一切杂染种子。无种子义名心转依。若不尔者云何当作。若对治生名为转依。此不应理。何以故。若对治转依非断故。不成杂染。永断故名转依。非能对治即是永断。由此但是永断因故。若必尔者便至果因无差别过。果是永断说名涅槃。因是对治说名圣道。若能对治即是永断。应至果因一体之过。才生对治应即涅槃。无种或无体若许为转依者。若于转识作无种子。或即无体许为转依。无彼二无故转依不应理。杂染转识。此定位中不得有故。亦无种子可令作无。无二可无而名转依。不应道理。若决定有阿赖耶识。杂染转识。此定位中虽不得有。而彼种子一切住在阿赖耶识。可能作其无种无体。由汝转依不应道理。故应信有阿赖耶识

论曰。复次此阿赖耶识差别云何。略说应知。或三种或四种。此中三种者。谓三种熏习差别故。一名言熏习差别。二我见熏习差别。三有支熏习差别。四种者。一引发差别。二异熟差别。三缘相差别。四相貌差别

释曰。如是已成立阿赖耶识。今当显此品类差别。于三种熏习差别中。名言熏习差别者。谓眼名言熏习。在异熟识中为眼生因。异熟生眼从彼生时。用彼为因。还说名眼。如是耳等一切名言差别亦尔。我见熏习差别者。由染污意萨迦耶见力故。于阿赖耶识中我执熏习生。由此为因。谓自为我异我为他。各有差别。有支熏习差别者。由善不善不动行力故。于诸趣中流转差别。此三如后所知相初当广分别

论曰。此中引发差别者。谓新起熏习。此若无者。行为缘识。取为缘有。应不得成

释曰。引发差别者。谓能引发品类差别。谓新起熏习者。谓彼最先所起熏习。若此能引阿赖耶识差别无者。诸行生灭熏习成识。由取摄受生有现前。此所作有应不得成。能有后生故名为有。此所说取或善不善是串习果

论曰。此中异熟差别者。谓行有为缘。于诸趣中异熟差别。此若无者则无种子。后有诸法生应不成

释曰。异熟差别者。谓行有为缘。于诸趣中所引异熟。若此所引阿赖耶识差别无者。则无有因。后有诸法眼等色根。此等异熟生应不成。当知此则是异熟果

论曰。此中缘相差别者。谓即意中我执缘相。此若无者。染污意中我执所缘应不得成

释曰。缘相差别者。谓此阿赖耶识。即是染污意中能依我见我执缘相。若此缘相阿赖耶识差别无者。染污意中萨迦耶见为因我执。此所缘境应不得成。当知此则是等流果

论曰。此中相貌差别者。谓即此识有共相。有不共相。无受生种子相。有受生种子相等

释曰。相貌差别有多品类。谓于此中。有共相有不共相。无受生种子相有受生种子相等者。是略标举。后当广释

论曰。共相者。谓器世间种子。不共相者。谓各别内处种子。共相即是无受生种子。不共相即是有受生种子。对治生时。唯不共相所对治灭。共相为他分别所持。但见清净。如瑜伽师。于一物中。种种胜解。真种所见。皆得成立。此中二颂

  难断难遍知　　应知名共结
  瑜伽者心异　　由外相大故
  净者虽不灭　　而于中见净
  又清净佛土　　由佛见清净

复有别颂对前所引。种种胜解种种所见皆得成立

  诸瑜伽师于一物　　种种胜解各不同
  种种所见皆得成　　故知所取唯有识

此若无者。诸器世间。有情世间。生起差别应不得成

释曰。此中若阿赖耶识。为一切有情共器世间因体。即是无受生种子。若阿赖耶识。为不共各别色等诸处因体。即是有受生种子。若离如是品类共相阿赖耶识。一切有情共受用因。诸器世间应不得成。如是若离第二不共阿赖耶识。有情世间亦应不成。由此应如木石等生

论曰。复有粗重相及轻安相。粗重相者。谓烦恼随烦恼种子。轻安相者。谓有漏善法种子。此若无者。所感异熟无所堪能有所堪能。所依差别应不得成。复有有受尽相无受尽相。有受尽相者。谓已成熟异熟果善不善种子。无受尽相者。谓名言熏习种子。无始时来种种戏论流转种子故。此若无者。已作已作善恶二业。与果受尽应不得成。又新名言熏习生起。应不得成。复有譬喻相。谓此阿赖耶识。幻炎梦翳为譬喻故。此若无者。由不实遍计种子故。颠倒缘相应不得成。复有具足相不具足相。谓诸具缚者。名具足相。世间离欲者。名损减相。有学声闻及诸菩萨。名一分永拔相。阿罗汉独觉及诸如来。名烦恼障全永拔相。及烦恼所知障全永拔相。如其所应。此若无者。如是次第杂染还灭。应不得成

释曰。粗重相者。谓所依中无堪能性。轻安相者。谓所依中有堪能性。若无有受尽相。阿赖耶识数数已作善恶二业与果受尽应不得成。无受尽相谓名言熏习种子者。如名言熏习差别中已说。无始时来种种戏论流转种子故者。谓无始时来共言说因故。若无如是阿赖耶识。新起名言熏习生起。应不得成。何以故。若无旧熏习。今名言亦无故。若于世间本来无者。本无今有不应道理。譬喻相者。如由所作幻等因故。得有象等颠倒缘相。阿赖耶识亦复如是。由所说譬喻相。不实遍计种子故。有颠倒缘相。此若无者。颠倒缘相应不得成

论曰。何因缘故。善不善法能感异熟。其异熟果无覆无记。由异熟果无覆无记。与善不善互不相违。善与不善互相违故。若异熟果善不善性。杂染还灭应不得成。是故异熟识唯无覆无记

释曰。无覆无记者。此中无染说名无覆。即无染无记名无覆无记。非如色界生烦恼不善说为无记。若异熟果善不善性杂染还灭应不得成者。以从善更生善。从不善更生不善故。则生死流转无有边际。流转杂染通有漏善故

摄大乘论释卷第三摄大乘论释卷第四

        世亲菩萨造

        三藏法师玄奘奉　诏译

    所知相分第三之一

论曰。已说所知依。所知相复云何应见。此略有三种。一依他起相。二遍计所执相。三圆成实相

释曰。依所知相说如是言。略者要也

论曰。此中何者依他起相。谓阿赖耶识为种子。虚妄分别所摄诸识。此复云何。谓身。身者。受者识。彼所受识。彼能受识。世识。数识。处识。言说识。自他差别识。善趣恶趣死生识。此中若身身者受者识彼所受识彼能受识世识数识处识言说识。此由名言熏习种子。若自他差别识。此由我见熏习种子。若善趣恶趣死生识。此由有支熏习种子。由此诸识。一切界趣杂染所摄。依他起相虚妄分别皆得显现。如此诸识。皆是虚妄分别所摄。唯识为性。是无所有非真实义。显现所依。如是名为依他起相

释曰。虚妄分别所摄诸识者。谓此诸识虚妄分别以为自性。谓身身者受者识者。身谓眼等五界。身者谓染污意。能受者。谓意界。彼所受识者。谓色等六外界。彼能受识者谓六识界。世识者。谓生死相续不断性。数识者。谓算计性。处识者。谓器世间。言说识者。谓见闻觉知四种言说。如是诸识皆用所知依中所说。名言熏习差别为因。自他差别识者。谓依止差别。此用前说。我见熏习差别为因。善趣恶趣死生识者。谓生死趣种种差别。此由前说。有支熏习差别种子。由此诸识者。即由次前所说诸识。一切界趣杂染所摄者。谓堕三界五趣杂染。是彼自性故名所摄。依他起相者。谓依他起为体虚妄分别皆得显现。如此诸识皆是虚妄分别所摄唯识为性者。谓此诸识皆是虚妄分别自性故名所摄。是无所有非真实义显现。所依者。谓无所有非真实义显现所因。非真实故名无所有。如所执我。无所有故名非真实义者所取。谓即彼我实无所有。似我显现。言所依者。显现所依。是所因义。此即名为依他起相

论曰。此中何者遍计所执相。谓于无义唯有识中。似义显现

释曰。于无义者。谓无所取如实无我。唯有识中者。谓无实义似义识中。如唯似我显现识中。似义显现者。似所取义相貌显现。如实无我。似我显现

论曰。此中何者圆成实相。谓即于彼依他起相。由似义相永无有性

释曰。于无所有。非真实义。显现因中。由实无有似义相现。永无有性。如似我相虽永是无。而无我有

论曰。此中身身者受者识。应知即是眼等六内界。彼所受识。应知即是色等六外界。彼能受识。应知即是眼等六识界。其余诸识。应知是此诸识差别。又此诸识皆唯有识。都无义故此中以何为喻显示。应知梦等为喻显示。谓如梦中都无其义。独唯有识虽种种色声香味触舍林地山似义影现。而于此中都无有义。由此喻显应随了知。一切时处皆唯有识。由此等言。应知。复有幻诳鹿爱[(臣*殳)/目]眩等喻。若于觉时一切时处皆如梦等。唯有识者如从梦觉。便觉梦中皆唯有识。觉时何故不如是转。真智觉时亦如是转。如在梦中此觉不转。从梦觉时此觉乃转。如是未得真智觉时。此觉不转。得真智觉此觉乃转。其有未得真智觉者。于唯识中云何比知。由教及理应可比知。此中教者。如十地经薄伽梵说如是三界皆唯有心。又薄伽梵解深密经亦如是说。谓彼经中慈氏菩萨问世尊言。诸三摩地所行影像。彼与此心。当言有异。当言无异。佛告慈氏。当言无异。何以故。由彼影像唯是识故。我说识所缘唯识所现故。世尊。若三摩地所行影像。即与此心无有异者。云何此心还取此心。慈氏。无有少法能取少法。然即此心如是生时。即有如是影像显现。如质为缘还见本质。而谓我今见于影像。及谓离质别有所见影像显现。此心亦尔。如是生时。相似有异所见影现。即由此教理亦显现。所以者何。于定心中随所观见。诸青瘀等所知影像。一切无别青瘀等事。但见自心。由此道理。菩萨于其一切识中。应可比知皆唯有识无有境界。又于如是青瘀等中非忆持识见所缘境现前住故。闻思所成二忆持识。亦以过去为所缘故。所现影像得成唯识。由此比量。菩萨虽未得真智觉。于唯识中应可比知

释曰。此唯有识由教显示。如十地经言。如是三界皆唯有心故。解深密经中。我说识所缘唯识所现故者。谓识所缘唯识所现无别境义。复举识者。显我所说定识所行。唯识所现无别有体。然即此心如是生时者。谓即由此品类生时。相似有异所见影现者。谓定所行相似离识。别有所取分明显现。又于如是青瘀等中非忆持识见所缘境现前住故者。谓青瘀等是三摩地所行影像。非忆持识。由此不即在彼方处。如昔所受还如是忆。此住现前分明见故。彼忆持识所见暗昧。此现前住所见分明。若有复谓如闻思慧。由串习故境虽谢往。才作意时如昔而生。此亦尔者闻思两慧境既谢往。现无有体。于无体中若更生时。但识影现。似彼而生故。闻思慧不缘谢往曾所受境。是故唯识由此弥彰。所取义无理亦成就

论曰。如是已说种种诸识。如梦等喻。即于此中眼识等识可成唯识。眼等诸识既是有色亦唯有识云何可见。此亦如前由教及理

释曰。眼识等识皆非有色。可成唯识。眼等诸识既是有色。云何唯识。此亦如前由教及理者。此眼等识如前所引。理教显示亦成唯识

论曰。若此诸识亦体是识。何故乃似色性显现。一类坚住相续而转。与颠倒等诸杂染法为依处故。若不尔者。于非义中起义颠倒应不得有。此若无者。烦恼所知二障杂染应不得有。此若无者。诸清净法亦应无有。是故诸识应如是转。此中有颂

  乱相及乱体　　应许为色识
  及与非色识　　若无余亦无

释曰。一类坚住相续转者。由相似故名为一类。多时住故说名坚住。诸有色识。相似多时相续而转。颠倒等者。即是等取诸杂染法与烦恼障及所知障为因性故。为依处者为彼因性。若彼诸识离如是转。于非义中起义心倒应不得有。此若无者。若烦恼障诸杂染法。若所知障诸杂染法应不得有。于此颂中显如是义。乱相乱体如其次第。许为色识及非色识。此中乱相即是乱因。色识为体。乱体即是诸无色识。色识乱因若无有者。非色识果亦应无有

论曰。何故身身者受者识。所受识能受识。于一切身中俱有和合转。能圆满生受用所显故。何故如说世等诸识差别而转。无始时来生死流转无断绝故。诸有情界无数量故。诸器世界无数量故。诸所作事展转言说无数量故。各别摄取受用差别无数量故。诸爱非爱业果异熟受用差别无数量故。所受死生种种差别无数量故

释曰。为令自身圆满受用故。身身者受者三识。一切身中许彼一时俱有和合。一时转故说名俱有。所显故者是彼因性

论曰。复次云何安立如是诸识成唯识性。略由三相。一由唯识无有义故。二由二性有相有见二识别故。三由种种种种行相而生起故。所以者何。此一切识无有义故得成唯识。有相见故得成二种。若眼等识以色等识为相。以眼识识为见。乃至以身识识为见若意识以一切眼为最初。法为最后诸识为相。以意识识为见。由此意识有分别故。似一切识而生起故。此中有颂

  唯识二种种　　观者意能入
  由悟入唯心　　彼亦能伏离

释曰。此中长行及颂显示由三种相成立唯识。于长行中。由唯识者。唯有识故一切诸识皆唯有识。由所识义无所有故。由二性者。由于一识安立相见。即此一识一分成相。第二成见。眼等诸识即于二性安立种种。谓一识上如其所应。一分变似种种相生。第二变似种种能取。若就意识。即以一切眼为最初。法为最后。诸识为相。意识识为见。由此意识遍分别故。似一切识而生起故。又于三中唯就意识以为种种。所取境界不决定故。其余诸识境界决定。又无分别。意识分别故唯于此安立第三种种相见。是故于此意识具足安立唯识。于伽他中能入唯识者。悟入所取义永无有故。能入二者悟入此识。有相见故。能入种种者悟入此识。似种种相而生起故。观者意者诸瑜伽师所有意趣。问于何悟入。答由悟入唯心彼亦能伏离。若能悟入唯有其心都无有义。是则于彼亦能伏离。既无所取义。何有能取心。说入二性及入种种。皆为成立入唯识因。余义相似

论曰。又于此中有一类师。说一意识彼彼依转。得彼彼名。如意思业名身语业

释曰。一类菩萨欲令唯有一意识体。彼复次第安立显示。如意思业名身语业者。如一意思于身门转。得身业名。于语门转得语业名。然是意业。意识亦尔。虽复是一。依眼转时得眼识名。如是乃至依身转时得身识名。非离意识别有余识。唯除别有阿赖耶识

论曰。又于一切所依转时。似种种相二影像转。谓唯似义影像及分别影像。又一切处亦似所触影像而转。有色界中即此意识依止身故。如余色根依止于身

释曰。或有难言。眼等诸根无有分别。是故意识依彼转时应无分别。如染污意为杂染依令杂染转。此亦应尔。故次解言。又于一切所依转时。似种种相二影像转。谓唯义影像及分别影像。此中一切所依者。谓眼等所依。似种种相二影像转者。谓唯似义影像及分别影像二句解释。由此二句说。唯一识一分唯义影像显现。第二分别此义相生。是故前说无有过失。又一切处亦似所触影像而生。谓有色处于定位中无五识时。在色身中内领受起。如余色根依止于身者。如余眼等有色诸根依止于身。由此诸根依止身故。于自所依能起损益。意识亦尔。依止身故应知于身能作变异。复有别义。谓如身根依止于身。若有外缘所触现前。身根便似所触相起。即此起时。于自依身能作损益。意识亦尔。依止身故似彼所触影像生时。于所依身能作损益

论曰。此中有颂

  若远行独行　　无身寐于窟
  调此难调心　　我说真梵志

释曰。彼诸菩萨为成此义。引阿笈摩伽他为证。若远行者。能缘一切所缘境故。言独行者。无第二故。言无身者。远离身故。寐于窟者。于身窟中。而居止故。言调此者。作自在故。难调心者。性暴恶故

论曰。又如经言。如是五根所行境界意各能受。意为彼依

释曰。复引余教证成此义。如是五根所行境界意各能受者。诸根所行名为境界。如是境界意各能受。悉能分别一切法故。一一各各能领受故名各能受。意为彼依者。是彼诸根能生因故。以意散乱彼不生故

论曰。又如所说十二处中。说六识身皆名意处

释曰。复有圣教能证此义。谓六识身皆说名意。无余识名。由六识身皆是意处圣所说故。是故得知唯有意识

论曰。若处安立阿赖耶识识为义识。应知此中余一切识。是其相识。若意识识及所依止。是其见识。由彼相识。是此见识生缘相故。似义现时。能作见识生依止事。如是名为安立诸识成唯识性

释曰。于阿赖耶识亦得安立相见二识。谓阿赖耶识以彼意识及所依止为其见识。眼等诸识为其相识。以一切法皆是识故。由彼相识者。谓眼等诸识。是此见识生缘相故者。是见生因由所缘性名见生因。似义现时能作见识生依止事者。能于彼见故名见识。即此见识似义现时。彼诸相识与意见识。能作相续不断住因。是故说名生依止事

论曰。诸义现前分明显现而非是有。云何可知。如世尊言。若诸菩萨成就四法能随悟入。一切唯识都无有义。一者成就相违识相智。如饿鬼傍生及诸天人。同于一事。见彼所识有差别故。二者成就无所缘识现可得智。如过去未来梦影缘中有所得故。三者成就应离功用无颠倒智。如有义中能缘义识。应无颠倒不由功用。智真实故。四者成就三种胜智随转妙智。何等为三。一得心自在一切菩萨得静虑者。随胜解力诸义显现。二得奢摩他修法观者。才作意时。诸义显现。三已得无分别智者。无分别智现在前时。一切诸义皆不显现。由此所说三种胜智随转妙智。及前所说三种因缘。诸义无义道理成就

释曰。相违识相智者。谓能了知相违者识所缘义相。无所缘识现可得智者。谓现见有虽无所缘而识得生。如过去等应离功用无颠倒智者。谓能了知若如是义。如所显现即是实有。离起对治。无颠倒智任运应成。三种胜智随转妙智者。谓能了知三种胜智。境随转义。得心自在者。得心调顺有所堪能。得静虑者。谓诸声闻及独觉等已得静虑。随胜解力诸义显现者。谓若愿乐地成其水如意则成。火等亦尔。得奢摩他者。得三摩地修法观者。于契经等策勤观察。才作意时诸义显现者。随于一义如如作意。如是如是非一品类境相显现。无分别智现在前时。一切诸义皆不显现者。若如显现义即如是实有。应不得有无分别智。无分别智若是实有。决定应许诸义皆无

论曰。若依他起自性。实唯有识似义显现之所依止。云何成依他起。何因缘故名依他起。从自熏习种子所生。依他缘起故名依他起。生刹那后无有功能。自然住故名依他起

释曰。实唯有识似义显现之所依止者。谓实无义唯有其识。与彼似义显现为因即此唯识名依他起。云何成依他起者。问自摄受。何因缘故名依他起者。问为他说。从自因生。生已无能暂时安住。名依他起应自摄受亦为他说

论曰。若遍计所执自性依依他起。实无所有似义显现。云何成遍计所执。何因缘故名遍计所执。无量行相。意识遍计颠倒生相故。名遍计所执。自相实无。唯有遍计所执可得。是故说名遍计所执

释曰。依依他起者。谓依唯识实无所有者。实无自体。似义显现者。唯有似义显现可得。云何何故等者。如次前说。无量行相者所谓一切境界行相意识遍计者。谓即意识。说名遍计颠倒生相者。谓是能生虚妄颠倒所缘境相。自相实无者。实无彼体。唯有遍计所执可得者。唯有乱识所执可得

论曰。若圆成实自性。是遍计所执永无有相。云何成圆成实。何因缘故名圆成实。由无变异性故名圆成实。又由清净所缘性故。一切善法最胜性故。由最胜义名圆成实

释曰。是遍计所执永无有相者。谓遍计所执自性。无性为性。云何何故等。如前依他起中已说。由无变异性故者。谓无虚诳性。如不虚诳性。又由清净所缘性故。一切善法最胜性故。由最胜义名圆成实者。谓由清净所缘性故。最胜性故名圆成实

论曰。复次有能遍计。有所遍计。遍计所执自性乃成。此中何者能遍计。何者所遍计。何者遍计所执自性。当知意识是能遍计。有分别故。所以者何。由此意识用自名言熏习为种子。及用一切识名言熏习为种子。是故意识无边行相分别而转。普于一切分别计度故名遍计。又依他起自性名所遍计。又若由此相令依他起自性成所遍计。此中是名遍计所执自性。由此相者是如此义。复次云何遍计能遍计度。缘何境界。取何相貌。由何执着。由何起语。由何言说何所增益。谓缘名为境。于依他起自性中取彼相貌。由见执着。由寻起语。由见闻等四种言说而起言说。于无义中增益为有。由此遍计能遍计度

释曰。复次云何遍计能遍计度者。谓意识名能遍计。依他起性名所遍计。为欲显示由此品类能遍计度故。又说缘名为境等。于依他起自性中取彼相貌者。谓即于此依他起中。由眼等名取彼相貌。由取彼相能遍计度。由见执著者。如所取相如是执着。由寻起语者。如所执着由语因寻而发语言。由见闻等四种言说而起言说者。如语所说见闻觉知四种言说与余言说。于无义中增益为有者。如所言说于无义中执有义故

论曰。复次此三自性为异为不异。应言非异非不异。谓依他起自性由异门故成依他起。即此自性由异门故成遍计所执。即此自性由异门故成圆成实。由何异门此依他起成依他起。依他熏习种子起故。由何异门即此自性成遍计所执。由是遍计所缘相故。又是遍计所遍计故。由何异门即此自性成圆成实。如所遍计。毕竟不如是有故

释曰。由是遍计所缘相故者。谓彼意识名为遍计。此为所取所缘境性。能生遍计。是故亦名遍计所执。又是遍计所遍计故者。即彼意识名为遍计。缘彼相貌。为所取境为所遍计。由此义故。依他起性亦名遍计所执自性。如所遍计者。如彼意识遍计所执。毕竟不如是有故者。所遍计上遍计所执毕竟无故。由此义故即此自性成圆成实

论曰。此三自性各有几种。谓依他起略有二种。一者依他熏习种子而生起故。二者依他杂染清净性不成故。由此二种依他别故名依他起遍计所执亦有二种。一者自性遍计执故。二者差别遍计执故。由此故名遍计所执。圆成实性亦有二种。一者自性圆成实故。二者清净圆成实故。由此故成圆成实性

释曰。杂染清净性不成故者。由即如是依他起性。若遍计时即成杂染。无分别时即成清净。由二分故一性不成。是故说名依他起性。自性遍计执故者。如于眼等遍计执为眼等自性。差别遍计执故者。如即于彼眼等自性遍计执。为常无常等无量差别。自性圆成实故者。谓有垢真如。清净圆成实故者。谓无垢真如

论曰。复次遍计有四种。一自性遍计。二差别遍计。三有觉遍计。四无觉遍计。有觉者谓善名言。无觉者谓不善名言。如是遍计复有五种。一依名遍计义自性。谓如是名有如是义。二依义遍计名自性。谓如是义有如是名。三依名遍计名自性。谓遍计度未了义名。四依义遍计义自性。谓遍计度未了名义。五依二遍计二自性。谓遍计度此名此义。如是体性

释曰。善名言者。谓解名言。不善名言者。谓牛羊等。虽有分别。然于文字。不能解了

论曰。复次总摄一切分别略有十种。一根本分别。谓阿赖耶识。二缘相分别。谓色等识。三显相分别。谓眼识等并所依识。四缘相变异分别谓老等变异。乐受等变异。贪等变异。逼害时节代谢等变异。捺落迦等诸趣变异。及欲界等诸界变异。五显相变异分别谓即如前所说变异所有变异。六他引分别谓闻非正法类。及闻正法类分别。七不如理分别。谓诸外道闻非正法类分别。八如理分别。谓正法中闻正法类分别。九执着分别。谓不如理作意类。萨迦耶见为本六十二见趣相应分别。十散动分别。谓诸菩萨十种分别

释曰。总摄一切分别略有十种者。是总标举。后当别释。根本分别者。谓阿赖耶识是诸分别根本。自体亦是分别。缘相分别者。谓色等识为所缘相所起分别。显相分别者。谓眼识等并所依识。显现似彼所缘境相所起分别有所分别或能分别故。名分别缘相。变异分别者。谓即缘相所有变异。缘此缘相变异分别。故名缘相变异分别。谓老等变异者。身中大种衰朽改易。名老变异分别。此故说名缘相变异分别。等者。等取病死变异。乐受等变异亦尔。谓由乐受身体改易。等者。等取苦及不苦不乐。贪等变异亦尔。等者。等取嗔痴。逼害时节代谢等变异亦尔。谓身变异为所缘境所起分别。逼害者。谓杀缚等。时节代谢者。谓寒时等时节改易。捺落迦等诸趣变异者。等取傍生及饿鬼趣。及欲界等诸界变异亦尔。等者。等取色无色界。显相变异分别者。谓眼识等显现似彼所缘境相所有变异。缘此显相。变异分别。此亦如前所说老等种种变异。由此亦于老等位中变异起故。他引分别者。谓由他教所起分别。此复二种。一闻非正法类。二闻正法类。此复二种于法分别。谓闻正法类或善或不善。闻非正法类亦如是释。不如理分别者。谓诸外道及彼弟子闻非正法类为因分别。如理分别者。谓正法中诸佛弟子闻正法类为因分别。执着分别者。谓不如理作意为因依止我见。起六十二诸恶见趣相应分别。如经广说。散动分别者。谓诸菩萨如后所说十种分别

论曰。一无相散动。二有相散动。三增益散动。四损减散动。五一性散动。六异性散动。七自性散动。八差别散动。九如名取义散动。十如义取名散动。为对治此十种散动。一切般若波罗蜜多中说无分别智。如是所治能治。应知具摄般若波罗蜜多义

释曰。此中无相散动者。谓此散动即以其无为所缘相。为对治此散动故。般若波罗蜜多经言实有菩萨。言实有者。显示菩萨实有空体。空即是体故名空体。有相散动者谓此散动即以其有为所缘相。为对治此散动故。即彼经言不见有菩萨。此经意说不见菩萨。以遍计所执及依他起为体。增益散动者。为对治此散动故。即彼经言色自性空。由遍计所执色。自性空故。损减散动者。为对治此散动故。即彼经言不由空故谓法性色性不空故。一性散动者。为对治此散动故。即彼经言色空非色。何以故。若依他起与圆成实是一性者。此依他起应如圆成实是清净境。异性散动者。为对治此散动故。即彼经言色不离空。何以故。此二若异。法与法性亦应有异。若有异性不应道理。如无常法与无常性。若取遍计所执自性。色即是空。空即是色。何以故。遍计所执色无所有。即是空性。此空性即是彼无所有。非如依他起与圆成实。不可说一。自性散动者。为对治此散动故。即彼经言。舍利子。此但有名谓之为色。何以故。色之自性无所有故。差别散动者。为对治此散动故。即彼经言。自性无生无灭无染无净。生即有染。灭即有净。无生灭故无染无净。如是诸句有如是义。如名取义散动者。谓如其名于义散动。为对治此散动故。即彼经言。假立客名别别于法而起分别。言别别者。谓别别名。如义取名散动者。如义于名而起散动。为对治此散动故。即彼经言。假立客名随起言说。非义自性有如是名。为对治此十散动故。说般若波罗蜜多。由此说为因无分别智生

论曰。若由异门依他起自性有三自性。云何三自性不成无差别。若由异门成依他起。不即由此成遍计所执及圆成实。若由异门成遍计所执。不即由此成依他起及圆成实若由异门成圆成实。不即由此成依他起及遍计所执

释曰。此义如前道理解释

摄大乘论释卷第四摄大乘论释卷第五

        世亲菩萨造

        三藏法师玄奘奉　诏译

    所知相分第三之二

论曰。复次云何得知。如依他起自性。遍计所执自性显现而非称体。由名前觉无称体相违故。由名有众多多体相违故。由名不决定杂体相违故。此中有二颂

  由名前觉无　　多名不决定
  成称体多体　　杂体相违故
  法无而可得　　无染而有净
  应知如幻等　　亦复似虚空

释曰。如依他起自性。遍计所执分。虽显现可得。而非称彼体。为显此义故。说由名前觉无称体相违故等。若依他起遍计所执同一相者。应不待名于义觉转。如执有瓶。若离瓶名。于瓶义中无有瓶觉。若此瓶名与彼瓶义。同一相者。瓶觉应转。以非一相是故不转。由此名义。若体相称则成相违。此中安立名为依他起。义为遍计所执。以依他起由名势力成所遍计故。又于一义有众多名。若名与义同一相者。义应如名亦有多种。若尔此义应成多体。一义多体则成相违。是故两性若同一相。则成第二相违过失。又名不决定。以一瞿声。于九义转。若执名义同一相者。多义相违应同一体。则成第三相违过失。由执牛等非一相义同一性故。初一伽他重显此义。于中成者。显依他起遍计所执非一义成。法无而可得等者。此一伽他以幻等喻开悟弟子。弟子有二相违疑问。云何法无而现可得。云何无染而有清净。此中两喻释此疑问。如幻等者。譬如幻象实无所有而现可得。应知此中义亦如是。虽现可得而非实有。似虚空者。譬如虚空虽非云等所能染污。性清净故。而离彼时说名清净。当知诸法亦复如是。虽实无染。性清净故。然客障垢得灭离时。说名清净

论曰。复次何故如所显现实无所有。而依他起自性。非一切一切都无所有。此若无者。圆成实自性亦无所有。此若无者。则一切皆无。若依他起及圆成实自性无有。应成无有染净过失。既现可得杂染清净。是故不应一切皆无。此中有颂

  若无依他起　　圆成实亦无
  一切种若无　　恒时无染净

释曰。若依他起如所可得不如是有。既尔何不一切一切都无所有。此若无者圆成实性亦应无有。何以故。由有杂染清净有故。若二俱无则一切种皆无所有。今当显此。非都无有。有谤杂染清净过故。杂染清净既现可得。故此二性俱非不有。若执为无则拨现有。杂染清净言无所有

论曰。诸佛世尊于大乘中说方广教。彼教中言。云何应知遍计所执自性。应知异门说无所有。云何应知依他起自性。应知譬如幻炎梦像光影谷响水月变化。云何应知圆成实自性。应知宣说四清净法。何等名为四清净法。一者自性清净。谓真如空实际无相胜义法界。二者离垢清净。谓即此离一切障垢。三者得此道清净。谓一切菩提分法波罗蜜多等。四者生此境清净。谓诸大乘妙正法教。由此法教清净缘故。非遍计所执自性。最净法界等流性故。非依他起自性。如是四法总摄一切清净法。尽此中有二颂

  幻等说于生　　说无计所执
  若说四清净　　是谓圆成实
  自性与离垢　　清净道所缘
  一切清净法　　皆四相所摄

释曰。自性清净者。谓此自性本来清净。即是真如自性。实有一切有情平等共相。由有此故说一切法有如来藏。离垢清净者。即此真如远离烦恼所知障垢。即由如是清净真如显成诸佛。得此道清净者。谓能得此真如圣道即是清净。谓念住等菩提分法。及以一切波罗蜜多。生此境清净者。生此能证菩提分法所缘境界。生此境界即是清净故名生此境清净。即契经等十二分教。何以故。若此圣教是遍计所执应成杂染因。若是依他起应成虚妄。最净法界等流性故非是虚妄。既离二自性故成圆成实。又此四种于大乘中随说一种。应知是说圆成实性。于中初二无有变异。圆成实故名圆成实。后之二种无有颠倒。圆成实故名圆成实。后伽他中具颂此义。幻等说于生者。谓依他起此中名生。若于是处说一切法。譬如幻事乃至变化。应知此说依他起性。说无计所执者。若于是处说无有色。乃至说无一切诸法。应知此说遍计所执性

论曰。复次何缘如经所说。于依他起自性说幻等喻。于依他起自性为除他虚妄疑故。他复云何于依他起自性有虚妄疑。由他于此有如是疑。云何实无有义而成所行境界。为除此疑说幻事喻。云何无义心心法转。为除此疑说阳炎喻。云何无义有爱非爱受用差别。为除此疑说所梦喻。云何无义净不净业爱非爱果差别而生。为除此疑说影像喻。云何无义种种识转。为除此疑说光影喻。云何无义种种戏论言说而转。为除此疑说谷向喻。云何无义而有实取诸三摩地所行境转。为除此疑说水月喻。云何无义有诸菩萨无颠倒心。为办有情诸利乐事故思受生。为除此疑说变化喻

释曰。为此义故于依他起说幻等喻。今当显示。此中虚妄疑者。谓于虚妄依他起性所有诸疑。为除此疑说幻等喻显依他起。若实无义云何成境。为治此疑说幻事喻显依他起。譬如幻象虽无实义而成境界。义亦如是。他复生疑。若无有义即无所缘。诸心心法云何而转。为除此疑说阳炎喻显依他起。此中阳焰譬心心法。水喻于义。譬如阳炎有动摇故。虽无有义而生水觉。诸心心法亦复如是。由动摇故。虽无有义而生义觉。是诸愚夫于此复疑。若无有义诸爱非爱受用差别云何可得。为除此疑说所梦喻显依他起。如于梦中。虽无实义而见种种爱与非爱。受用差别现前可得。此亦如是。于此复疑。净不净业义既实无。爱非爱果义云何起。为除此疑说影像喻显依他起。譬如影像实无有义。即于本质起影像觉。然影像义无别可得。此亦如是。应知虽无爱与非爱真实果义而现可得。于此复疑。若无有义云何得有种种识转。为除此疑说光影喻显依他起。如弄影者有其种种光影可得。虽有多种光影可得。而光影义实无所有。识亦如是。无种种义而有种种义现可得。于此复疑。若无有义。无量品类戏论言说云何而转。为除此疑说谷响喻显依他起譬如谷响虽无有义而现可得。戏论言说亦复如是。虽无实义而现可得。于此复疑。若无有义。云何世间定心心法有义可得。由说定心能如实知如实见故。为除此疑说水月喻显依他起。譬如水月。其义实无。由水润滑澄清性故而现可得。定心亦尔。所缘境义虽实无有。而现可得。水喻其定。以是润滑澄清性故。于此复疑。若有情义实无所有。云何证真诸菩萨等。作彼利乐觉慧为先。彼彼趣中摄受自体。为除此疑说变化喻显依他起。譬如变化。实无有义。由化者力一切事成。非变化义而不可得。应知此中亦复如是。所受自体其义虽无。而有能作一切有情利益安乐。所受自体义现可得

复有别义世尊意说幻等八喻。今当显示。此中幻喻为除眼等六种内处。应知显示眼等六处。譬如幻象。虽实非有而现可得。说阳炎喻为除器世间。由彼大故。于阳炎中实无有水。动摇力故似水可得。说所梦喻为除色等所受用境。显如所梦。色等实无而能为因起爱非爱受用差别。说影像喻为除身业果。显善不善身业为缘。而有余色影像生起。说谷响喻为除语业果。显语业因感语业果犹如谷响。意业三种。一非等引地。二等引地。三闻种类。说光影喻为除非等引地诸意业果。显此意业所得诸果犹如光影。说水月喻为除等引地诸意业果。显等引地诸意业果犹如水月。说变化喻为除闻种类意业闻种类者。即是闻思之所熏习。此即显示闻种类意差别而转犹如变化

论曰。世尊依何密意。于梵问经中说。如来不得生死不得涅槃。于依他起自性中。依遍计所执自性及圆成实自性。生死涅槃无差别密意。何以故。即此依他起自性。由遍计所执分成生死。由圆成实分成涅槃故

释曰。如是三种自性相法。所说契经悉皆随顺。今当显示。世尊依何密意于梵问经中说如来不得生死不得涅槃者。问于依他起自性中依遍计所执自性及圆成实自性生死涅槃无差别密意者。答次当广释。依他起自性非定生死。由圆成实分成涅槃故。亦非定涅槃。由遍计所执分成生死故。是故不可定说一性。由此自性若得一分余分不异。依此意趣。于彼经中说如来不得生死不得涅槃

论曰。阿毗达磨大乘经中。薄伽梵说法有三种。一杂染分。二清净分。三彼二分。依何密意作如是说。于依他起自性中。遍计所执自性是杂染分。圆成实自性是清净分。即依他起是彼二分。依此密意作如是说。于此义中以何喻显。以金土藏为喻显示。譬如世间金土藏中三法可得。一地界二土三金。于地界中土非实有而现可得。金是实有而不可得。火烧炼时土相不现金相显现。又此地界土显现时虚妄显现。金显现时真实显现。是故地界是彼二分。识亦如是。无分别智火未烧时。于此识中所有虚妄遍计所执自性显现。所有真实圆成实自性不显现。此识若为无分别智火所烧时。于此识中所有真实圆成实自性显现。所有虚妄遍计所执自性不显现。是故此虚妄分别识。依他起自性有彼二分。如金土藏中所有地界

释曰。阿毗达磨大乘经中。由此密意说有三法。一杂染分。谓遍计所执自性是杂染故。二清净分。谓圆成实自性是清净故。三彼二分。谓依他起自性通彼二故。为显此义以金土藏为其譬喻。此中藏者是彼种子。言地界者。是坚硬性。土之与金是所造色。于此喻中三法可得。谓此藏中先时有土相貌显现。后时金相方乃可得。为显金相后方可得。说火烧炼后可得故金真实有

论曰。世尊有处说一切法常。有处说一切法无常。有处说一切法非常非无常。依何密意作如是说。谓依他起自性。由圆成实性分是常。由遍计所执性分是无常。由彼二分非常非无常。依此密意作如是说。如常无常无二。如是苦乐无二。净不净无二。空不空无二。我无我无二。寂静不寂静无二。有自性无自性无二。生不生无二。灭不灭无二。本来寂静非本来寂静无二。自性涅槃非自性涅槃无二。生死涅槃无二亦尔。如是等差别一切诸佛密意语言。由三自性应随决了。如前说常无常等门。此中有多颂

  如法实不有　　如现非一种
  非法非非法　　故说无二义
  依一分开显　　或有或非有
  依二分说言　　非有非非有
  如显现非有　　是故说为无
  由如是显现　　是故说为有
  自然自体无　　自性不坚住
  如执取不有　　故许无自性
  由无性故成　　后后所依止
  无生灭本寂　　自性般涅槃

释曰。伽他义中如法实不有如现非一种者。如其次第释非法非非法因缘。由实不有故非法。由现非一种故非非法。以非法非非法故说无二义。依一分者。谓依一边。开显者。说示也。或有或非有者。或是有性或是无性。依二分说言非有非非有者。取依他起具二分性。说为非有及非非有。如显现非有者。如现所得不如是有。是故说为无者。由此义故说之为无。由如是显现者。由唯似有相貌显现。是故说为有者。即由此义说之为有。说一切法无自性意。今当显示。自然无者。由一切法无离众缘自然有性。是名一种无自性意。自体无者。由法灭已不复更生故无自性。此复一种无自性意自性不坚住者。由法才生一刹那后无力能住故无自性。如是诸法无自性理与声闻共。如执取不有故许无自性者。此无自性不共声闻。以如愚夫所取。遍计所执自性不如是有。由此意故依大乘理。说一切法皆无自性。由无性故成者。由一切法无自性故。无生灭等皆得成就。所以者何。由无自性故无有生。由无生故亦无有灭。无生灭故本来寂静。本寂静故自性涅槃。后后所依止者。是后后因此而得有义

论曰。复有四种意趣四种秘密。一切佛言应随决了。四意趣者。一平等意趣。谓如说言我昔曾于彼时彼分。即名胜观正等觉者。二别时意趣。谓如说言若诵多宝如来名者。便于无上正等菩提已得决定。又如说言由唯发愿便得往生极乐世界。三别义意趣。谓如说言若已逢事尔所殑伽河沙等佛。于大乘法方能解义。四补特伽罗意乐意趣。谓如为一补特伽罗先赞布施后还毁呰。如于布施。如是尸罗及一分修当知亦尔。如是名为四种意趣。四秘密者。一令入秘密。谓声闻乘中或大乘中。依世俗谛理说有补特伽罗。及有诸法自性差别。二相秘密。谓于是处说诸法相显三自性三对治秘密。谓于是处说行对治八万四千四转变秘密。谓于是处以其别义。诸言诸字即显别义。如有颂言

  觉不坚为坚　　善住于颠倒
  极烦恼所恼　　得最上菩提

释曰。意趣秘密有差别者。谓佛世尊先缘此事后为他说。是名意趣。由此决定令入圣教。是名秘密。平等意趣者。谓如有人取相似法说如是言。彼即是我。世尊亦尔。平等法身置在心中。说言我昔曾于彼等。非彼昔时毗钵尸佛。即是今日释迦牟尼。依平等义所起意趣作如是说。别时意趣者。谓此意趣令懒惰者。由彼彼因于彼彼法精勤修习。彼彼善根皆得增长。此中意趣显诵多宝如来名因。是升进因。非唯诵名。便于无上正等菩提已得决定。如有说言由一金钱得千金钱。岂于一日意在别时。由一金钱是得千因故作此说。此亦如是。由唯发愿便得往生极乐世界。当知亦尔。别义意趣中。于大乘法方能解义者。谓于三种自性义理自证其相。若但解了随名言义是佛意者。愚夫于此亦应解了。故知此中言解义者。意在证解。要由过去逢事多佛。补特伽罗意乐意趣者。谓如为一先赞布施后还毁呰。此中意者。先多悭吝为赞布施。后乐行施。还复毁呰令修胜行。若无此意。于一施中先赞后毁。则成相违。由有此意赞毁应理。于尸罗等当知亦尔。一分修者。谓世间修。令入秘密者。谓若是处依世俗谛理。说有补特伽罗及一切法自性差别。为令有情入佛圣教。是故说名令入秘密。相秘密者。谓于宣说诸法相中说三自性。对治秘密者。谓于是处宣说有情诸行对治。为欲安立有情烦恼行对治故。转变秘密者。谓于是处以说余义。诸言诸字转显余义。于伽他中。觉不坚为坚者。不坚谓定由不刚强驰散难调故名不坚。即于此中起尊重觉。名觉为坚。善住于颠倒者。是于颠倒能颠倒中善安住义。于无常等谓是常等。名为颠倒。于无常等谓无常等。是能颠倒。是于此中善安住义。极烦恼所恼者。精进劬劳名为烦恼。为众生故长时劬劳精进所恼。如有诵言。处生死久恼。但由于大悲。如是等。得最上菩提者。其义易了

论曰。若有欲造大乘法释。略由三相应造其释。一者由说缘起。二者由说从缘所生法相。三者由说语义

释曰。由此三相随其所应。应造一切大乘法释

论曰。此中说缘起者。如说

  言熏习所生　　诸法此从彼
  异熟与转识　　更互为缘生

释曰。言熏习所生诸法者。由外分别熏习在阿赖耶识中。以此熏习为因一切法生。即是转识自性。此从彼者。此分别熏习用彼诸法为因。此即显示阿赖耶识。与彼转识更互为因

论曰。复次彼转识相法。有相有见识为自性。又彼以依处为相。遍计所执为相。法性为相。由此显示三自性相。如说

  从有相有见　　应知彼三相

复次云何应释彼相。谓遍计所执相。于依他起相中实无所有。圆成实相于中实有。由此二种。非有及有。非得及得。未见已见。真者同时。谓于依他起自性中。无遍计所执故。有圆成实故。于此转时。若得彼即不得此。若得此即不得彼。如说

  依他所执无　　成实于中有
  故得及不得　　其中二平等

释曰。彼转识相法有相有见识为自性者。谓彼识有相有见以为其体。又即彼相有其三种依处为相者。谓依他起相。由此所说三种自性显示彼相。于伽他中即显此义。从有相有见应知彼三相者。如释显示。由此二种非有及有非得及得未见已见真者同时者。遍计所执及圆成实名为二种。如是二种。第一非有。第二是有。未见真者。得遍计所执不得圆成实。已见真者。即此刹那得圆成实。不得遍计所执。于伽他中即显此义。谓依他所执无等平等者。谓一刹那。其中者。谓依他起中。二者。谓未见真者及已见真者。故者是由此因义。谓于依他起中。由遍计所执无故。及由圆成实有故。又诸愚夫颠倒执故如是见转。若诸圣者由正见故如是见转

论曰。说语义者谓先说初句。后以余句分别显示。或由德处。或由义处

释曰。由说语义如所造释。今当显示或摄其德或摄其义

论曰。由德处者。谓说佛功德最清净觉。不二现行趣无相法。住于佛住。逮得一切佛平等性。到无障处。不可转法。所行无碍。其所安立不可思议。游于三世平等法性。其身流布一切世界。于一切法智无疑滞。于一切行成就大觉。于诸法智无有疑惑。凡所现身不可分别。一切菩萨等所求智。得佛无二住胜彼岸。不相间杂如来解脱妙智究竟。证无中边佛地平等。极于法界。尽虚空性。穷未来际。最清净觉者。应知此句。由所余句分别显示。如是乃成善说。法性最清净觉者。谓佛世尊最清净觉。应知是佛二十一种功德所摄。谓于所知一向无障转功德。于有无无二相。真如最胜清净能入功德。无功用佛事不休息住功德。于法身中所依意乐作业无差别功德。修一切障对治功德。降伏一切外道功德。生在世间不为世法所碍功德。安立正法功德。授记功德。于一切世界示现受用变化身功德。断疑功德。令入种种行功德。当来法生妙智功德。如其胜解示现功德。无量所依调伏有情加行功德。平等法身波罗蜜多成满功德。随其胜解示现差别佛土功德。三种佛身方处无分限功德。穷生死际常现利益安乐一切有情功德。无尽功德等

释曰。此中不二现行者。谓二现行此中无有。是故说名不二现行。即是于所知一向无障转功德。非如声闻独觉智亦有障亦无障故。趣无相法者。谓清净真如名无相法。趣谓趣入。即是于有无无二相真如最胜清净能入功德。谓此真如非是有相。诸法无性以为相故。亦非无相自相有故。于此无相真如最胜清净能入。最胜能入故。清净能入故住于佛住者。谓住佛所住无所住处。即是无功用佛事不休息住功德。谓此住中常作佛事无有休息。逮得一切佛平等性者。即是于法身中所依意乐作业无差别功德。到无障处者。即是修一切障对治功德。谓一切时常修觉慧对治一切障故。不可转法者。即是降伏一切外道功德。所行无碍者。即是生在世间不为世法所碍功德。谓虽生世间行于世间所行之处。不为利等世间八法所染污故。其所安立不可思议者。即是安立正法功德。由契经等正法无量不可思议。非诸愚夫所能解故。由此故名最清净觉。此最清净觉句。于句句中皆遍相应。游于三世平等法性者。即是授记功德。其身流布一切世界者。即是于一切世界示现受用变化身功德。于一切法智无疑滞者。即是断疑功德。于一切行成就大觉者。即是令入种种行功德。于诸法智无有疑惑者。即是当来法生妙智功德。谓知当来如是法生如来妙智。凡所现身不可分别者。即是如其胜解示现功德。一切菩萨等所求智者。即是无量所依调伏有情加行功德。谓无量菩萨所依。能作调伏诸有情事。此非诸佛已得自他平等更求此智。唯有诸佛已作如是胜调伏事。得佛无二住胜彼岸者。即是平等法身波罗蜜多成满功德。谓无二法身名平等法身。即于如是无二法身得善清净波罗蜜多。不相间杂如来解脱妙智究竟者。谓于无杂如来智中胜解究竟。此中胜解名为解脱。即是随其胜解示现差别功德。证无中边佛地平等者。即是三种佛身方处无分限功德。谓佛法身不可分限。尔所方处受用变化。亦不可说尔所世界。极于法界者。谓极清净法界。是名极于法界。即是穷生死际常现利益安乐一切有情功德。尽虚空性者。即是无尽功德。谓佛智无尽如虚空故。穷未来际者。即是究竟功德等。言等此佛智究竟穷未来际无有间断。是故名为最清净觉

论曰。复次由义处者。如说若诸菩萨成就三十二法乃名菩萨。谓于一切有情起利益安乐增上意乐故。令入一切智智故。自知我今何假智故。摧伏慢故。坚牢胜意乐故非假怜愍故。于亲非亲平等心故。永作善友乃至涅槃为后边故。应量而语故。含笑先言故。无限大悲故。于所受事无退弱故。无厌倦意故。闻义无厌故。于自作罪深见过故。于他作罪不嗔而诲故。于一切威仪中恒修治菩提心故。不悕异熟而行施故。不依一切有趣受持戒故。于诸有情无有恚碍而行忍故。为欲摄受一切善法勤精进故。舍无色界修静虑故。方便相应修般若故。由四摄事摄方便故。于持戒破戒善友无二故。以殷重心听闻正法故。以殷重心住阿练若故。于世杂事不爱乐故。于下劣乘曾不欣乐故。于大乘中深见功德故。远离恶友故。亲近善友故。恒修治四梵住故。常游戏五神通故。依趣智故。于住正行不住正行诸有情类不弃舍故。言决定故。重谛实故。大菩提心恒为首故。如是诸句。应知皆是初句差别。谓于一切有情。起利益安乐增上意乐

此利益安乐增上意乐句。有十六业差别应知。此中十六业者。一展转加行业。二无颠倒业。三不待他请自然加行业。四不动坏业。五无求染业。此有三句差别应知。谓无染系故。于恩非恩无爱恚故。于生生中恒随转故。六相称语身业此有二句差别应知。七于乐于苦于无二中平等业八无下劣业。九无退转业。十摄方便业。十一厌恶所治业。此有二句差别应知。十二无间作意业。十三胜进行业。此有七句差别应知。谓六波罗蜜多正加行故。及四摄事正加行故。十四成满加行业。此有六句差别应知。谓亲近善士故。听闻正法故。住阿练若故。离恶寻思故。作意功德故。此复有二句差别应知。助伴功德故。此复有二句差别应知。十五成满业。此有三句差别应知。谓无量清净故。得大威力故。证得功德故。十六安立彼业。此有四句差别应知。谓御众功德故。决定无疑教授教诫故。财法摄一故。无杂染心故。如是诸句。应知皆是初句差别

释曰。由义处中。于一切有情起利益安乐增上意乐故者。此句义由十六业余句显示。由何等业显示利益安乐增上意乐。谓展转加行业者。即是令入一切智智故。谓令诸有情入一切智智。展转化导。譬如一灯传然千灯。此即显示利益安乐增上意乐。如是一切所余句中。皆应配属利益安乐增上意乐。无颠倒业者。即是自知我今何假智故。谓或虽有利益安乐增上意乐。仍是颠倒。如有发起利益安乐增上意乐劝饮酒等。若有正智如实自知。方能称量教导有情。非增上慢。不如实知起饶益心。劝他令作不饶益事。不待他请。自然加行业者。即是摧伏慢故。谓由摧伏憍慢心故。不待劝请自为说法。不动坏业者。即是坚牢胜意乐故。不以有情行邪行故。动坏菩萨利益安乐增上意乐坚固之心。无求染业者。即是非假怜愍故。于亲非亲平等心故。永作善友乃至涅槃为后边故。谓后三句释此三句。非为利养恭敬等因。作诸有情利益安乐。是故说名无求染业利益安乐增上意乐云何可知。谓由相称语身业者。即是应量而语故。含笑先言故。此二句中。应量而语及先言是语业。含笑是身业。应量语者。唯作法语。言含笑者。舒颜往来作饶益事。于乐于苦于无二中平等业者。即是无限大悲故。无限悲者愍三苦故。于有苦有情愍其苦苦。于有乐有情愍其坏苦。于不苦不乐有情愍其行苦。不苦不乐故名无二。无下劣业者。即是于所受事无退弱故。谓不自轻云我不能当得佛果。如此等类。无退转业者。即是无厌倦意故。谓勤精进修成佛因。心无厌倦。摄方便业者。即是闻义无厌故。谓由多闻成善巧智饶益有情。厌恶所治业者。即是于自作罪深见过故。于他作罪不嗔而诲故。由此方便乃能如实调伏有情。无间作意业者。即是于一切威仪中。恒修治菩提心故。如是句义如所行清净契经广说。胜进行业者。即是不悕异熟而行施故。乃至由四摄事摄方便故。谓即依前利益安乐增上意乐。修此加行。以为增长趣向果因。成满加行业者。即是于持戒破戒善友无二故。乃至亲近善友故。谓后六句释此八句。若有习近如是加行。速得成满以殷重心。住阿练若故者。由住此处。离恶寻思世杂事者。谓歌舞等。成满业者。即是恒修治四梵住故。常游戏五神通故。依趣智故谓后三句释此三句。此成满业所有相状。大威力者。谓六神通依趣智故者。谓依趣智。不依趣识内智生故。由此内智现见相应安住于法。安立彼业者。即是于住正行等。谓后四句释此四句。由利益安乐增上意乐故。安立有情利益安乐。御众功德故者。由于破戒亦不弃舍安立不摈。令出不善令住于善。决定无疑教受教诫故者。由能一向与彼教敕非自说已

还复说言我言不善。由是因缘其言威肃。财法摄一故者。由言诚谛以法摄取。衣服等财还如是施。无杂染心故者。由善摄受大菩提心饶益有情。非欲自求为给使故。云何有情由此善故速证无上正等菩提。如此摄受一切有情

论曰。如说

  由最初句故　　句别德种类
  由最初句故　　句别义差别

释曰。此伽他中。即为显示前所说义。说如是言

摄大乘论释卷第五摄大乘论释卷第六

        世亲菩萨造

        三藏法师玄奘奉　诏译

    入所知相分第四

论曰。如是已说所知相。入所知相云何应见。多闻熏习所依。非阿赖耶识所摄。如阿赖耶识成种子。如理作意所摄。似法似义而生。似所取事。有见意言

释曰。如能悟入如是种类所应知相今当显说。入所知相者。谓能悟入所知境义。多闻熏习所依者。谓大乘法所熏自体。非阿赖耶识所摄者。谓能对治阿赖耶识故。如阿赖耶识成种子者。谓如阿赖耶识为一切杂染法因。此为一切清净法因亦尔。如理作意所摄者。谓如理作意为自性。似法似义而生者。谓似法义相而生起时。似所取事者。谓似色等义。有见者。谓似于见此即成立有相见识

论曰。此中谁能悟入所应知相。大乘多闻熏习相续。已得逢事无量诸佛出现于世。已得一向决定胜解。已善积集诸善根故。善备福智资粮菩萨

释曰。如是品类。如此方便而能悟入今当显示。大乘多闻熏习相续者。简声闻等所有多闻熏习相续。已得逢事无量诸佛出现于世者。已得现前逢事诸佛出现世间超过数量。已得一向决定胜解者。谓于大乘所得胜解。非诸恶友所能动坏。即由无间所说三因。已善积集诸善根故。乃得名为善备福智资粮菩萨。又即如是福智资粮。云何渐次而得圆满。谓由因力。由善友力。由作意力。由依持力。此中两句即是二力如数应知。作意力者。即是一向决定胜解。此用大乘熏习为因。事佛为缘。以有一向决定胜解。能修正行。修正行故积集善根。如是名为由作意力。善修福智二种资粮。由此渐次善修福智二资粮故。能入大地。如是名为由依持力

论曰。何处能入。谓即于彼有见似法似义意言。大乘法相等所生起胜解行地。见道修道究竟道中。于一切法唯有识性。随闻胜解故。如理通达故。治一切障故。离一切障故

释曰。入如是类及入行相。今当显示。意地寻思说名意言。如是意言以大乘法为因而生。此中显示意言差别。大乘法相等所生者。是此教法为缘生义。或有即于胜解行地名能悟入。由但听闻一切诸法唯有识性。深生信解故名能入。于见道中如是悟入。今当显示。如理通达故者。谓于意言如理通达云何于此如理通达。谓此意言非法非义。非所取非能取。如是通达于修道中如是悟入。今当显示。治一切障故者。谓观此意言非法非义非所取非能取时。便能对治一切障故究竟道中如是悟入。今当显示离一切障故者。谓善清净妙智位中。最微细障亦无有故

论曰。由何能入由善根力所任持故。谓三种相练磨心故。断四处故缘法义境。止观恒常殷重加行。无放逸故

释曰。由此能入今当显示。由何能入由善根力所任持故。谓三种相练磨心故。乃至恒常殷重加行无放逸故者。谓于如是所说八句善顺相应。名善根力所任持故。言恒常者。无间修故。言殷重者。恭敬修故。若于如是品类造修。即于如是能无放逸

论曰。无量诸世界无量人。有情刹那刹那证觉无上正等菩提。是为第一练磨其心。由此意乐能行施等波罗蜜多。我已获得如是意乐。我由此故少用功力。修习施等波罗蜜多当得圆满。是名第二练磨其心。若有成就诸有障善。于命终时即便可爱。一切自体圆满而生。我有妙善无障碍善。云何尔时不当获得一切圆满。是名第三练磨其心

释曰。此中对治三种退屈心故。唯修三种练磨心。所以者何。以诸菩萨闻于无上正等菩提最胜甚深广大难可证得。心便退屈。对治此故修第一练磨心。又诸菩萨闻所修行波罗蜜多最胜甚深广大难可证得。心便退屈。对治此故修第二练磨心。由此意乐能行施等波罗蜜多者。此中意乐。谓信及欲。菩萨于诸波罗蜜多。真实有性具功德性。有堪能性深生信解是名为信。深信解已乐欲修行。是名为欲。菩萨既得如是信欲。自性意乐少用功力。修习六种波罗蜜多当得圆满。又诸菩萨于佛甚深广大言教。思议决择善巧转时。如是思量。如是无上正等菩提难可证得。隔一念心方可证得。心便退窟。对治此故修第三练磨心。我有妙善者。我有一切十种地中妙善积集福智资粮。无障碍善者。谓金刚喻定能破在骨粗重微细极难破障。此定无间得一切障离系转依。云何尔时不当获得一切圆满者。此中意说于障离系。似彼命终时一切种智如彼体圆满。又于此中三种练磨心者。谓诸菩萨善根无缺善根力持。由此力故则能三种练磨其心。心无退屈。初当显示第一练磨心。谓人趣中无量世界无量有情。刹那刹那能证无上正等菩提。云何我今独不能证。次当显示第二练磨心。谓诸菩萨作是思惟。我此意乐离诸障碍。波罗蜜多悭等障碍皆无有故。不由功用波罗蜜多当得圆满。此圆满故证佛菩提。后当显示第三练磨心。有障善者。谓由世善而成其善。此有障善尚命终时即便可爱一切自体圆满而生。况我今者由无障善而成其善。不当成佛无上菩提无有是处

论曰。此中有颂

  人趣诸有情　　处数皆无量
  念念证等觉　　故不应退屈
  诸净心意乐　　能修行施等
  此胜者已得　　故能修施等
  善者于死时　　得随乐自满
  胜善由永断　　圆满云何无

释曰。复以伽他显如是义。故不应退屈者。由上因缘策持其心令不怯弱。谓生是心。我不能证无上菩提。诸净心者。是非不善无记心义。谓或有人以其散乱无记之心而行施等。如是外道以不善心而行施等。若求无上正等菩提。是最胜善故名净心。此胜者已得故能修施等者。最胜菩萨名为胜者。此之意乐菩萨已得。是故能修施等诸度。即是已得能断悭等所治心义等者。取始从尸罗乃至般若波罗蜜多。善者于死时得随乐自满者。是乃至得非想非非想处义。胜善由永断圆满云何无者。是由永断障而成胜善圆满佛果。云何无义

论曰。由离声闻独觉作意。断作意故。由于大乘诸疑离疑。以能永断异慧疑故。由离所闻所思法中我我所执。断法执故。由于现前现住安立一切相中。无所作意无所分别。断分别故。此中有颂

  现前自然住　　安立一切相
  智者不分别　　得最上菩提

释曰。今当显示断除四处。断作意故者。谓断声闻等诸作意故。以能永断异慧疑故者。谓于大乘甚深广大。能永断除异慧及疑。此中异慧。谓鄙恶慧于理动摇。疑谓犹预。由于大乘诸疑离疑者。谓于大乘安立法相三自性教。谓若说诸法皆无自性无生无灭。本来寂静自性涅槃。诸如是等永无异门。依遍计所执自性。而说若说诸法如幻阳炎梦相光影影像谷向水月变化。诸如是等虚妄异门。依依他起自性而说。若说诸法真如实际无相胜义法界空性。诸如是等真实异门。依圆成实自性而说。于此一切异慧及疑永无复转。由离所闻所思法中我我所执者。此中意说断除法执。断法执故者。乃至所闻所思法中执我我所。终不于彼如实悟入。由于现前现住安立一切相中无所作意无所分别者。谓加行无分别智转时。如理作意住一切定心。诸相作意分别皆断。断分别故者。谓于现前色等现住。及骨锁等定所安立。一切所缘诸境界相。皆不作意无所分别。由无分别方便能入。若异分别终不能入。现前自然住等颂唯显最后所断义

论曰。由何云何而得悟入

释曰。为显由此如是悟入故为此问

论曰。由闻熏习种类。如理作意所摄。似法似义有见意言

释曰。由此悟入今当显示。此中由闻熏习种类者。谓由闻熏习为因。即前所说悟入任持大乘熏习等所生故。应知是圆成实自性所摄

论曰。由四寻思。谓由名义自性差别。假立寻思。及由四种如实遍智。谓由名事自性差别。假立如实遍智。如是皆同不可得故。以诸菩萨如是如实为入唯识勤修加行。即于似文似义意言。推求文名唯是意言。推求依此文名之义亦唯意言。推求名义自性差别唯是假立。若时证得唯有意言。尔时证知若名若义自性差别皆是假立。自性差别义相无故同不可得。由四寻思。及由四种如实遍智。于此似文似义意言。便能悟入唯有识性

释曰。如是悟入今当显示由四寻思者。谓由名义自性等文之所显说。及由四种如实遍智者。谓由名事自性差别假立等文之所显说。如实遍知若名若事自性差别。皆是假立。于中实义皆不可得。是故说言如是皆同不可得故。又先推求若名若义自性差别唯是假立。后如实知如是真实皆不可得。于推求时名为寻思。若如实知不可得时。即名四种如实遍智

论曰。于此悟入唯识性中。何所悟入。如何悟入。入唯识性。相见二性及种种性。若名若义自性差别。假自性差别义。如是六种义皆无故。所取能取性现前故。一时现似种种相义而生起故。如闇中绳显现似蛇。譬如绳上蛇非真实。以无有故。若已了知彼义无者。蛇觉虽灭绳觉犹在。若以微细品类分析。此又虚妄色香味触为其相故。此觉为依绳觉当灭。如是于彼似文似义六相意言。伏除非实六相义时。唯识性觉犹如蛇觉。亦当除遣。由圆成实自性觉故

释曰。今于此中问所悟入及悟入譬。唯识性者。唯有识性。相见二性者。显示有相有见之识。显现似因似所建立故名为相。种种性者。唯是一识显现。似有种种相生。非速疾故别别而现。于此悟入唯识性中。如是三种为所悟入。一时现似种种相义而生起故者。谓似种种名句文相而生起故。及似种种依止此义而生起故。此中绳喻。显示悟入三种自性。伏除非实六相义时者。谓于遣灭六相义时。此中遣灭名为伏除

论曰。如是菩萨悟入意言似义相故。悟入遍计所执性。悟入唯识故悟入依他起性。云何悟入圆成实性。若已灭除意言闻法熏习种类唯识之想。尔时菩萨已遣义想。一切似义无容得生。故似唯识亦不得生。由是因缘住一切义无分别名。于法界中便得现见相应而住。尔时菩萨平等平等所缘能缘无分别智已得生起。由此菩萨名已悟入圆成实性

释曰。悟入意言似义相故悟入遍计所执性者。谓知诸义唯是遍计分别所作。由是故言悟入遍计所执自性悟入唯识故悟入依他起性者。举其唯识即取意言。了知一切唯意言性。由此悟入依他起性。一切似义无容得生者谓无如是品类实义可似其生。故似唯识亦不得生者。谓唯识相亦不得起。何以故。计有识时即有义故。从是已后现证真如。此现证位不可宣说。内自证故。尔时菩萨平等平等所缘能缘无分别智已得生起者。所缘谓真如。能缘谓真智。此二平等譬如虚空。即是不住。所取能取二种性义。由不分别所取能取。是故说名无分别智。如是悟入圆成实性

论曰。此中有颂

  法补特伽罗　　法义略广性
  不净净究竟　　名所行差别

释曰。如前所说住一切义无分别名。何等为名。几品类义为答此问。以颂显示名类差别。此中法名者。谓色受眼耳等。补特伽罗名者。谓佛及随信行等。又法名者。谓契经等。义名者。谓依此法义。略名者。谓有情等。广名者。谓彼一一各别能诠。姓名者。谓诸字本母。不净名者。谓诸异生。净名者。谓有学等。究竟名者。谓一切法总相所缘。是诸菩萨所缘名类略有十种。一法名谓眼等。二补特伽罗名谓我等。三法名谓十二分教。四义名谓此十二分教所诠诸义。五略名谓一切法为无为等。六广名谓色受等及虚空等七姓名。谓阿字为初诃字为后。八不净名谓诸异生。九净名谓诸见谛。十究竟名谓一切法总相所缘。即是二智所缘境界。谓出世智及后得智。以一切法真如实际为所缘故。以一切法种种相别为所缘故。如十地等。此中意取于一切义总相缘智所缘境界。如是品类。是诸菩萨名所行别

论曰。如是菩萨悟入唯识性故悟入所知相。悟入此故入极喜地。善达法界生如来家。得一切有情平等心性。得一切菩萨平等心性。得一切佛平等心性。此即名为菩萨见道

释曰。生如来家者。由此能令诸佛种性无断绝故。得一切有情平等心性者。由作是思。如我自身欲般涅槃。一切有情亦如是故。得一切菩萨平等心性者。由得菩萨等意乐故。得一切佛平等心性者。由此位中得佛法身。证得此故得一切佛平等心性。又得一切有情平等心性者。谓证自他平等性故。如于自身欲尽众苦。于他亦尔。得一切菩萨平等心性者。谓与一切菩萨意乐加行皆平等故。得一切佛平等心性者。见彼法界与己法界无差别故

论曰。复次为何义故入唯识性。由缘总法出世止观智故。由此后得种种相识智故。为断及相阿赖耶识诸相种子。为长能触法身种子。为转所依。为欲证得一切佛法。为欲证得一切智智。入唯识性。又后得智。于一切阿赖耶识所生。一切了别相中。见如幻等性无倒转。是故菩萨譬如幻师于所幻事于诸相中。及说因果常无颠倒

释曰。由缘总法出世止观智故者。谓由止观所显智故。为断及相阿赖耶识诸相种子者。此中及相是及因义。于阿赖耶识中。诸杂染法种子。名阿赖耶识诸相种子。复举相者。为欲显示即彼种子是所缘相。如是说已。显彼种子因果俱断。若无分别智断一切障证得佛法。此后得智复何所用。无分别智不能宣说诸因果法。无分别故。由是因缘须后得智。宣说所有诸因果法常无颠倒。譬如幻师于所幻事。于一切阿赖耶识所生者。谓阿赖耶识为因。一切了别相中者。谓识为因见相分中。由后得智见如幻等。及宣说时皆无颠倒

论曰。于此悟入唯识性时。有四种三摩地。是四种顺决择分依止。云何应知。应知由四寻思。于下品无义忍中。有明得三摩地。是暖顺决择分依止。于上品无义忍中。有明增三摩地。是顶顺决择分依止。复由四种如实遍智已入唯识。于无义中已得决定。有入真义一分三摩地。是谛顺忍依止。从此无间伏唯识想。有无间三摩地。是世第一法依止。应知如是诸三摩地。是现观边

释曰。于一切处入真观时。皆有四种顺决择分。故于此中亦应显示。是顺决择分依止者。谓决择分因所依止义。于下品无义忍中有明得三摩地者。谓于无义中起下品爱乐。以其明名。显下品无义智三摩地名。显此无义智所依止定。于上品无义忍中者。谓于无义中起上品爱乐。有明增三摩地者。谓以明名。显上品无义智三摩地名。显此无义智所依止定。谛顺忍依止者。法无我理名谛。此忍顺彼名谛顺忍。此云何成。谓于外无中已决定者。于无能取亦深爱乐。应知于利顺忍转时。是现观边者。谓现观时义

论曰。如是菩萨已入于地。已得见道。已入唯识。于修道中云何修行。于如所说安立十地。摄一切经皆现前中。由缘总法出世后得止观智故。经于无量百千俱胝那庾多劫。数修习故。而得转依。为欲证得三种佛身精勤修行

释曰。于如所说安立十地者。谓于随说安立菩萨十种地中。由缘总法者。谓缘总相非分别缘。言出世者。无分别智。后得即是能成立智。此不应说唯是世间。由于世间未积习故。亦不应说唯出世间。由随世间而现前故。由是因缘不可定说而得转依者。由缘总智故得转依。为欲证得三种佛身精勤修行者。谓我当证三种佛身故勤修行

论曰。声闻现观。菩萨现观有何差别。谓菩萨现观与声闻异。由十一种差别应知。一由所缘差别。以大乘法为所缘故。二由资持差别。以大福智二种资粮为资持故。三由通达差别。以能通达补特伽罗法无我故。四由涅槃差别。摄受无住大涅槃故。五由地差别。依于十地而出离故。六七由清净差别。断烦恼习净佛土故。八由于自他得平等心差别。成熟有情加行无休息故。九由生差别。生如来家故。十由受生差别。常于诸佛大集会中摄受生故。十一由果差别。十力无畏不共佛法。无量功德果成满故

释曰。由涅槃差别者。以菩萨现观摄受无住大般涅槃。声闻不尔。由清净差别者。以菩萨现观永断烦恼及诸习气。能净佛土。声闻不尔

论曰。此中有二颂

  名事互为客　　其性应寻思
  于二亦当推　　唯量及唯假
  实智观无义　　唯有分别三
  彼无故此无　　是即入三性

释曰。将入真观故说二颂。名事互为客其性应寻思者。谓名于事为客事于名为客。非称彼体故。由定而观故名寻思。于二亦当推唯量及唯假者。应当推寻义之自性差别并无。唯有识量。唯有自性差别假立。言实智者。应知即是如实遍智。谓由四种寻思为因。发生四种如实遍智。所言观无义唯有分别三者。谓观于义本无所有。唯有三种虚妄分别谓名分别。自性分别。差别分别。彼无故此无者。谓义无故分别亦无。何以故。若有所分别义。可有能缘分别。由义无所有故。当知分别亦无。是即入三性者。谓于此中悟入三性。观见名事互为客故。即是悟入遍计所执性观见二种本无有义唯有分别量。唯有名自性差别假立故。即是悟入依他起性。亦不观见此分别故。即是悟入圆成实性。如是名为悟入三性

论曰。复有教授二颂。如分别瑜伽论说

  菩萨于定位　　观影唯是心
  义想既灭除　　审观唯自想
  如是住内心　　知所取非有
  次能取亦无　　后触无所得

释曰。为入真观授以正教。于此义中说其二颂。菩萨依定位。观影唯是心者。谓观似法似义影像。唯是其心谁能观。谓菩萨在何位于定位。义想既灭除审观唯自想者。谓此位中义想既遣。审观似法似义之想唯是自心。如是住内心者。如摄自心住于无义。即是令心住于内心。知所取非有者。谓了所取义无所有。次能取亦无者。由所取义既是非有。故能取心能取之性亦不得成。后触无所得者。谓从此后触证真如。由此真如无所得故名无所得

论曰。复有别五现观伽他。如大乘经庄严论说

  福德智慧二资粮　　菩萨善备无边际
  于法思量善决已　　故了义趣唯言类
  若知诸义唯是言　　即住似彼唯心理
  便能现证真法界　　是故二相悉蠲除
  体知离心无别物　　由此即会心非有
  智者了达二皆无　　等住二无真法界
  慧者无分别智力　　周遍平等常顺行
  灭依榛梗过失聚　　如大良药消众毒
  佛说妙法善成立　　安慧并根法界中
  了知念趣唯分别　　勇猛疾归德海岸

释曰。复有现观伽他如经庄严论说。其中难解于此显示。福德智慧二资粮菩萨善备无边际者。资粮有二种。一福德资粮。二智慧资粮。谓施等三波罗蜜多是福德资粮。第六般若波罗蜜多是智慧资粮。精进波罗蜜多二资粮摄。何以故。若为智慧而行精进。是智慧资粮。若为福德而行精进。是福德资粮。如是静虑波罗蜜多亦通二种。若缘无量而修静虑。是福德资粮。余是智慧资粮。如是资粮是谁所有。谓诸菩萨长远难度名无边际。如无边语非无有边。但以多故得无边称此亦如是。于法思量善决已者。要由定后思惟诸法。方善决定非余所能。故了义趣唯言类者。谓了知诸义唯意言为因。若知诸义唯是言即住似彼唯心理者。谓若了知似义显现唯是意言。即住似义唯心正理。便能现证真法界。是故二相悉蠲除者。谓从此后现证真如。永离所取能取二相。如入现证次当显示。体知离心无别物由此即会心非有者。体知离心无所缘义。彼无有故。即会能缘心亦非有。知者了达二皆无者。谓诸菩萨了达此二悉皆是无。等住二无真法界者。谓平等住离义离心真实法界。慧者无分别智力者。谓诸菩萨无分别智所有势力。周遍平等常顺行者。于平等中随顺而行。观契经等一切诸法犹如虚空性平等故。内外诸法皆如是观故名周遍。常者时恒。灭依榛梗过失聚如大良药消众毒者。灭谓除灭。依谓所依。即所依中杂染法因极难了故。如溪谷林榛梗难入。过失聚者。是杂染法熏习自性。佛说妙法善成立安慧并根法界中者。谓由佛教善安其慧置真如中。及能缘彼根本心中。根本心者。谓缘如来所有正教总为一相。应知即是无分别心。了知念趣唯分别者。谓彼安住根本心已。为说正教。由后得智念诸义趣。知此念趣唯是分别。勇猛疾归德海岸者。谓诸菩萨由无分别智及后得智巧方便故。速趣佛果功德海岸。如是五颂总略义者。谓第一颂显资粮道。第二初半显加行道。后半第三显于见道第四一颂显于修道。第五一颂显究竟道

摄大乘论释卷第六摄大乘论释卷第七

        世亲菩萨造

        三藏法师玄奘奉　诏译

    彼入因果分第五

论曰。如是已说入所知相。彼入因果云何可见。谓由施戒忍精进静虑般若六种波罗蜜多。云何由六波罗蜜多得入唯识。复云何六波罗蜜多成彼入果。谓此菩萨不着财位。不犯尸罗。于苦无动。于修无懈。于如是等散动因中。不现行时心专一境。便能如理简择诸法。得入唯识。菩萨依六波罗蜜多入唯识已。证得六种清净增上意乐所摄波罗蜜多。是故于此。设离六种波罗蜜多。现起加行。由于圣教得胜解故。及由爱重随喜欣乐诸作意故。恒常无间相应方便。修习六种波罗蜜多。速得圆满

释曰。若于尔时得入唯识。即于是时证得清净增上意乐波罗蜜多。现起加行者。谓波罗蜜多现行加行。由于圣教得胜解者。谓即于此波罗蜜多相应圣教。虽极甚深而能信解。爱重作意者。谓即于彼见胜功德深生爱味。欣乐作意者。谓如已到最胜彼岸。诸佛所得清净意乐。愿我及彼一切有情亦当证得

论曰。此中有三颂

  已圆满白法　　及得利疾忍
  菩萨于自乘　　甚深广大教
  等觉唯分别　　得无分别智
  希求胜解净　　故意乐清净
  前及此法流　　皆得见诸佛
  了知菩提近　　以无难得故

由此三颂。总显清净增上意乐。有七种相。谓资粮故。堪忍故。所缘故。作意故。自体故。瑞相故。胜利故。如其次第诸句伽他应知显示

释曰。如是清净增上意乐有何等相。而能摄彼波罗蜜多。为答此问。次说三颂显示其相。已圆满白法者。谓先于彼胜解行地。善备资粮故。于此中白法圆满。及得利疾忍者。忍有三品。谓软中上。此中最上名利疾忍。由是所缘而得清净。次当显示。菩萨于自乘甚深广大教者。谓于大乘名于自乘。此中宣说无量甚深广大事故。法无我性名甚深事。虚空藏等诸三摩地名广大事。由是作意而得清净。次当显示。等觉唯分别得无分别智者。谓若觉知一切诸法唯有分别。即能获得无分别智。意乐自体。次当显示。希求胜解净故意乐清净者。欲及胜解俱清净故意乐清净。应知此中欲名希求。信名胜解。意乐瑞相。次当显示。前及此法流皆得见诸佛者。前谓意乐清净位前。此谓意乐清净位中。皆得见佛是其瑞相。言法流。谓定位中。意乐胜利。次当显示。了知菩提近以无难得故者。谓此位中见菩提近得。彼能得胜方便故。得不为难。此三颂中显示清净增上意乐。有如是资粮。如是堪忍。如是所缘。如是作意。如是自体。如是瑞相。如是胜利。由此三颂。成立清净增上意乐所有体相

论曰。何因缘故波罗蜜多唯有六数。成立对治所治障故。证诸佛法所依处故。随顺成熟诸有情故。为欲对治不发趣因故。立施戒波罗蜜多。不发趣因。谓着财位。及着室家。为欲对治虽已发趣复退还因故。立忍进波罗蜜多。退还因者。谓处生死。有情违犯所生众苦。及于长时善品加行所生疲怠。为欲对治虽已发趣不复退还而失坏因故。立定慧波罗蜜多。失坏因者。谓诸散动及邪恶慧。如是成立对治所治障故。唯立六数。又前四波罗蜜多是不散动因。次一波罗蜜多不散动成就。此不散动为依止故。如实等觉诸法真义。便能证得一切佛法。如是证诸佛法所依处故唯立六数。由施波罗蜜多故。于诸有情能正摄受。由戒波罗蜜多故。于诸有情能不毁害。由忍波罗蜜多故。虽遭毁害而能忍受。由精进波罗蜜多故。能助经营彼所应作。即由如是摄利因缘。令诸有情于成熟事有所堪任。从此已后。心未定者令其得定。心已定者令得解脱。于开悟时彼得成熟。如是随顺成熟一切有情。唯立六数应如是知

释曰。成立对治所治障中。失坏因谓邪恶慧者。颠倒执取名邪恶慧。如诸外道。由邪恶慧而失坏故。余义可知。证诸佛法所依处者。谓证一切佛法因故。由此第二成立因缘。波罗蜜多其数唯六不增不减。此不散动为依止故。如实等觉诸法真义者。依止静虑波罗蜜多。能起般若波罗蜜多如实等觉诸法真义。余义可知。第三成立数因缘中。随顺成熟诸有情者。谓为随顺成熟一切有情类故。唯立六数不增不减。其心未定令得定者。谓得静虑波罗蜜多心。已得定令解脱者。谓得般若波罗蜜多。于开悟时彼得成熟者。谓教授时令彼成熟

论曰。此六种相云何可见。由六种最胜故。一由所依最胜谓菩提心为所依故。二由事最胜。谓具足现行故。三由处最胜。谓一切有情利益安乐事为依处故。四由方便善巧最胜。谓无分别智所摄受故。五由回向最胜。谓回向无上正等菩提故。六由清净最胜。谓烦恼所知二障无障所集起故。若施是波罗蜜多耶。设波罗蜜多是施耶。有施非波罗蜜多。应作四句。如于其施。如是于余波罗蜜多亦作四句如应当知

释曰。以何等相。施等得名波罗蜜多。由诸世间及声闻等。亦有施等。是故决定应说其相。谓六最胜为施等相所依最胜者。谓菩提心为所依止。事最胜者。谓无有一于内外事具足现行。唯有菩萨能具现行。处最胜者。谓以一切有情利益安乐为处。方便善巧最胜者。谓三轮清净是。此中所取方便善巧。由无施物施者受者三分别故。如是无分别智所摄。施等得名波罗蜜多。回向最胜者。谓以施等回求无上正等菩提。清净最胜者。谓至佛果施等方净。尔时解脱烦恼所知二种障碍所集起故。若施是波罗蜜多耶设波罗蜜多是施耶者。是问于答中。有施非波罗蜜多。谓离六种最胜而行布施。有波罗蜜多非施。谓六种最胜所摄。戒等有亦施亦波罗蜜多。谓六种最胜所摄。布施有非施非波罗蜜多。谓离六种最胜而行戒等。如是一切处作四句应知

论曰。何因缘故如是六种波罗蜜多此次第说。谓前波罗蜜多随顺生后波罗蜜多故

释曰。如是六种波罗蜜多依生前后说此次第

论曰。复次此诸波罗蜜多训释名言云何可见。于诸世间声闻独觉施等善根。最为殊胜能到彼岸。是故通称波罗蜜多。又能破裂悭吝贫穷。及能引得广大财位福德资粮故名为施。又能息灭恶戒恶趣。及能取得善趣等持。故名为戒。又能灭尽忿怒怨仇。及能善住自他安隐。故名为忍。又能远离所有懈怠恶不善法。及能出生无量善法。令其增长。故名精进。又能消除所有散动。及能引得内心安住。故名静虑。又能除遣一切见趣诸邪恶慧。及能真实品别知法。故名为慧

释曰。今当显示训释名言。且释总名。由此一切能到彼岸。是故说名波罗蜜多。超诸世间声闻独觉施等彼岸。是故通名波罗蜜多。次释别名。以于因时破悭惠施。果时能裂一切贫穷。及于果时引大财位广福资粮。故名为施。又于因时息诸恶戒。果时能灭一切恶趣。及于未来能取善趣。于现在世能得等持。故名为戒。如是一切波罗蜜多训释言词如应当说。及能善住自他安隐者。谓于自身不为忿怒过失所恼。不生他苦故得安隐

论曰。云何应知修习如是波罗蜜多。应知此修略有五种。一现起加行修。二胜解修。三作意修。四方便善巧修。五成所作事修。此中四修如前已说。成所作事修者。谓诸如来任运佛事无有休息。于其圆满波罗蜜多。复更修习六到彼岸。又作意修者。谓修六种意乐所摄。爱重随喜欣乐作意。一广大意乐。二长时意乐。三欢喜意乐。四荷恩意乐。五大志意乐。六纯善意乐。若诸菩萨乃至若干无数大劫。现证无上正等菩提。经尔所时一一刹那。假使顿舍一切身命。及以殑伽河沙等世界盛满七宝。奉施如来。乃至安坐妙菩提座。如是菩萨布施意乐犹无厌足。经尔所时一一刹那。假使三千大千世界满中炽火。于四威仪常乏一切资生众具。戒忍精进静虑般若心恒现行。乃至安坐妙菩提座。如是菩萨所有戒忍精进静虑般若意乐犹无厌足。是名菩萨广大意乐。又诸菩萨即于此中无厌意乐。乃至安坐妙菩提座。常无间息。是名菩萨长时意乐。又诸菩萨以其六种波罗蜜多饶益有情。由此所作深生欢喜蒙益有情。所不能及。是名菩萨欢喜意乐。又诸菩萨以其六种波罗蜜多饶益有情。见彼于己有大恩德。不见自身于彼有恩。是名菩萨荷恩意乐。又诸菩萨即以如是六到彼岸所集善根。深心回施一切有情。令得可爱胜果异熟。是名菩萨大志意乐。又诸菩萨复以如是六到彼岸所集善根。共诸有情回求无上正等菩提。是名菩萨纯善意乐。如是菩萨修此六种意乐所摄爱重作意。又诸菩萨于余菩萨六种意乐。修习相应无量善根。深心随喜。如是菩萨修此六种意乐所摄随喜意乐。又诸菩萨深心欣乐一切有情六种意乐所摄。六种到彼岸修。亦愿自身与此六种到彼岸修恒不相离。乃至安坐妙菩提座。如是菩萨修此六种意乐所摄欣乐作意。若有闻此菩萨六种意乐所摄作意修已。但当能起一念信心。尚当发生无量福聚。诸恶业障亦当消灭。何况菩萨

释曰。五种修中。现起加行修者。谓于现起加行而修。成所作事修者。谓诸如来安住法身。有无功用所作佛事。常无休息。于其六种波罗蜜多虽无现行。然为摄益诸有情故。恒常现行成所作事。于尔所时一一刹那者。假使以三无数劫量为一刹那。如是刹那积集时量。乃至菩提。经尔所时一一刹那假使顿舍一切身命等。其义易了。应随本文。如此次第积集时量乃至菩提。经尔所时一一刹那。假令为起一戒等心。处在三千大千世界满中炽火。恒乏一切资生众具。此言显示住处艰难资缘乏少。此中意乐无有厌足。当知即是广大意乐。即此长时恒无间断。当知即是长时意乐。长者久也。余义易了。诸恶业障亦当消灭者。此中意说灭彼能与异熟功能。或对治彼往恶趣力

论曰。此诸波罗蜜多差别云何可见。应知一一各有三品。施三品者。一法施。二财施。三无畏施。戒三品者。一律仪戒。二摄善法戒。三饶益有情戒。忍三品者。一耐怨害忍。二安受苦忍。三谛察法忍。精进三品者。一被甲精进。二加行精进。三无怯弱无退转无喜足精进。静虑三品者。一安住静虑。二引发静虑。三成所作事静虑。慧三品者。一无分别加行慧。二无分别慧。三无分别后得慧

释曰。于此宣说波罗蜜多品差别中。显示体性各三差别。此中何故说法施等三种差别。谓由法施故资他善根。由财施故资益他身。由无畏施故资益他心。以是因缘故说三施。三种戒中。律仪戒者是依持戒。为欲建立其余二戒。是故安住。所以者何。住律仪者。便能建立摄善法戒。由此修集一切佛法。证大菩提。复能建立益有情戒。由此故能成熟有情。三种忍中。耐怨害忍。能忍受他所作怨害。勤修饶益有情事时。由此忍力遭生死苦而不退转。安受苦忍。能正忍受所遭众苦。由此忍力。于生死中虽受众苦而不退转。谛察法忍堪能审谛观察诸法。由此忍力。建立次前所说二忍。三精进中其体差别。即薄伽梵契经中说。有势有勤有勇坚猛。不舍善轭。彼经五句即是。此中三精进体之所解释。由被甲精进故。最初有势。由加行精进故。于加行时能有精勤。由无怯弱无退转无喜足精进故。如其次第于此后时有勇坚猛。不舍善轭故。由此三释彼五句。所以者何。或有最初为求无上正等菩提。虽有势力而加行时不能策励。故说有勤。虽复有勤心或怯弱。为对治彼故说有勇。由有勇故心无退屈。应知怯弱即是退屈。心虽无怯。逢生死苦心或退转。由此退失所求佛果。为对治彼立无退转。无转退者。即是坚猛故无退转。显示坚猛。由坚猛故逢苦不退。有虽逢苦能不退转。而得少善便生喜足。由此不证无上菩提。是故次须说无喜足。是不得少生喜足义。此即显示不舍善轭。由是义故说三精进。三静虑中。安住静虑者。由此能安现法乐住。引发静虑者。由此引发六种神通。成所作事静虑者。谓依此故成立所作利有情事。是故说名成所作事。由此义故静虑有三。安立慧体有三种中。其义易了

论曰。如是相摄。云何可见。由此能摄一切善法。是其相故。是随顺故。是等流故

释曰。如是相摄云何可见者。此问如是波罗蜜多与诸善法互相摄义云何可见。由此能摄一切善法者。应知由此波罗蜜多。能具足摄一切善法。彼亦能摄波罗蜜多。应知此中一切善法。即是一切菩提分法。是其相故者。是般若相。是随顺故者。应知即是信轻安等。是等流故者。谓六神通及十力等诸余功德

论曰。如是所治摄诸杂染。云何可见。是此相故。是此因故。是此果故

释曰。如到彼岸摄诸白法。前已显示此所对治亦摄一切诸杂染法。今当显示。是此相故者。是贪等相。是此因故者。是悭等因。所谓不信及邪见等。是此果故者。谓悭犯戒忿等诸果

论曰。如是六种波罗蜜多所得胜利。云何可见。谓诸菩萨流转生死。富贵摄故。大生摄故。大朋大属之所摄故。广大事业加行成就之所摄故。无诸恼害性薄尘垢之所摄故。善知一切工论明处之所摄故。胜生无罪乃至安坐妙菩提座。常能现作一切有情一切义利。是名胜利

释曰。今当显说波罗蜜多所得胜利。胜生无罪者。非如外道虽得胜生而名有罪杂染污故。又彼胜生皆是无常。波罗蜜多果非无常。由说乃至安坐妙菩提座故。又彼胜生唯能自利。不能利他。由不说彼常能现作有情义利。波罗蜜多所得胜果。常能现作一切有情一切义利。如是名为诸到彼岸。得无罪等胜果义利

论曰。如是六种波罗蜜多互相决择。云何可见。世尊于此一切六种波罗蜜多。或有处所以施声说。或有处所以戒声说。或有处所以忍声说。或有处所以勤声说。或有处所以定声说。或有处所以慧声说。如是所说有何意趣。谓于一切波罗蜜多修加行中。皆有一切波罗蜜多互相助成。如是意趣

释曰。于三百颂般若波罗蜜多等经中。本为说一波罗蜜多。乃说一切波罗蜜多。于如是说有何意趣。于修一时一切相助。应知此中有是意趣。谓修施时防护身语。由此有戒波罗蜜多而相助成。乃至了知施之因果。由此有慧波罗蜜多而相助成。其余相助如应当知

论曰。此中有一嗢拖南曰

  数相及次第　　训词修差别
  摄所治功德　　互决择应知

释曰。次第颂前。其文易了

    摄大乘论释彼修差别分第六

论曰。如是已说彼入因果。彼修差别云何可见。由菩萨十地。何等为十。一极喜地。二离垢地。三发光地。四焰慧地。五极难胜地。六现前地。七远行地。八不动地。九善慧地。十法云地。如是诸地安立为十。云何可见。为欲对治十种无明所治障故。所以者何。以于十相所知法界有十无明所治障住。云何十相所知法界。谓初地中由遍行义。第二地中由最胜义。第三地中由胜流义。第四地中由无摄受义。第五地中由相续无差别义第六地中由无杂染清净义。第七地中由种种法无差别义。第八地中由不增不减义。相自在依止义。土自在依止义。第九地中由智自在依止义。第十地中由业自在依止义。陀罗尼门三摩地门自在依止义。此中有三颂

  遍行最胜义　　及与胜流义
  如是无摄义　　相续无别义
  无杂染净义　　种种无别义
  不增不减义　　四自在依义
  法界中有十　　不染污无明
  治此所治障　　故安立十地

复次应知。如是无明于声闻等非染污。于诸菩萨是染污

释曰。依彼因果修位差别。故问答言。云何十相所知法界。谓初地中由遍行义。乃至第十地中由业自在依止义陀罗尼门三摩地门自在依止义。由十种相法界可知。故名十相所知法界。谓地地中各有一相所知法界。由无明力不能了知。为欲对治如是无明故立十地。又所治障有其十种。故立十地。何等名为所治十障。一异生性。二于诸有情身等邪行。三迟钝性。于闻思修而有忘失。四微细烦恼现行俱生身见等摄。此最下品故。不作意缘故。远随现行故。应知是微细。五于下乘般涅槃。六粗相现行。七细相现行。八于无相作行。九于饶益有情事不作行。十于诸法中未得自在。遍行义者。谓此法界遍一切行。以无少法非无我故。若如是知得入初地。最胜义者。谓此法界一切法中最为殊胜。若如是知得入二地。胜流义者。谓大乘教。从此所流最为殊胜。若如是知得入三地。无摄受义者。谓于此中无计我所。无摄我所。如北洲人无有系属。于此法界若得证时其中都无。谓有我所。若如是知得入四地。相续无差别义者。谓于此中体无有异。非如眼等随诸有情。相续差别各各有异。若如是知得入五地。无杂染清净义者。谓于此中本无杂染。性无染故。既无杂染即无清净。若如是知得入六地。种种法无差别义者。谓于此中契经等法。虽有种种差别安立而无有异。若如是知得入七地。不增不减义者。谓于此中杂染减时而无有减。清净增时而无有增。相自在依止义者。谓此法界是相自在之所依止。于诸相中而得自在。名相自在。随所欲相即现前故。土自在依止义者。谓此法界是土自在之所依止。于所现土而得自在。名土自在。如欲令土成金等宝随意成故。若如是知得入八地。智自在依止义者。谓此法界无碍辩智自在所依。若如是知得入九地。业自在等依止义者。谓此法界是身等业自在所依。及陀罗尼三摩地门自在所依。若如是知得入十地。如是无明于声闻等非染污者。由彼不欲入诸地故。于初地中已能通达一切诸地。何故次第复立诸地。释此难者。虽初地中达一切地。然由此住而得安住。由此住力建立诸地

论曰。复次何故初地说名极喜。由此最初得能成办自他义利胜功能故。何故二地说名离垢。由极远离犯戒垢故。何故三地说名发光。由无退转等持等至所依止故。大法光明所依止故。何故四地说名焰慧。由诸菩提分法焚灭一切障故。何故五地名极难胜。由真谛智与世间智更互相违。合此难合令相应故。何故六地说名现前。由缘起智为所依止。能令般若波罗蜜多现在前故。何故七地说名远行。至功用行最后边故。何故八地说名不动。由一切相有功用行不能动故。何故九地说名善慧。由得最胜无碍智故。何故十地说名法云。由得总缘一切法智。含藏一切陀罗尼门三摩地门。譬如大云能覆如空广大障故。又于法身能圆满故

释曰。何故初地名为极喜。由于此时初得能办自他俱利胜堪能故。诸声闻等真现观时。唯得能办自利堪能。不得他利故。彼不生如是欢喜同诸菩萨。何故二地名为离垢。由此地中性戒成就。非如初地思择护戒。性戒成故诸犯戒垢已极远离。何故三地名为发光。由此地中与三摩地三摩钵底。常不相离无退转故。于大乘法能作光明。何故四地名为焰慧。由此地中安住最胜菩提分法。由住此故能烧一切根本烦恼及随烦恼。皆为灰烬。何故五地名极难胜。由此地中知真谛智是无分别。知诸世间工论等智是有分别。此二相违应修令合。能合难合令相应故名极难胜。何故六地名为现前。谓此地中住缘起智。由此智力无分别住最胜般若波罗蜜多而得现前。悟一切法无染无净。于第七地当成有行。第八地中当成无行。何故七地名为远行。谓此地中于功用行得至究竟。虽一切相不能动摇。而于无相。犹名有行。何故八地名为不动。由此地中所有诸相。及一切行皆不能动。无分别智任运流行。何故九地名为善慧。由此地中无碍解智说名为慧。此慧妙善故名善慧。何故十地名为法云。由此地中所有总缘一切法智。譬如大云。陀罗尼门三摩地门。犹如净水。此智所藏如云含水。又如大云能覆虚空。如是总缘一切法智。普能覆灭诸广大障。又于法身能圆满者。如大云起周遍虚空。如是此智于诸菩萨所依法身。悉能周遍。此中圆满意说周遍

论曰。得此诸地云何可见。由四种相。一得胜解。谓得诸地深信解故。二得正行。谓得诸地相应十种正法行故。三得通达。谓于初地达法界时。遍能通达一切地故。四得成满。谓修诸地到究竟故

释曰。得成满者。应知尔时修习诸地已至究竟

论曰。修此诸地云何可见。谓诸菩萨于地地中修奢摩他毗钵舍那。由五种相修。何等为五。谓集总修无相修无功用修炽盛修无喜足修。如是五修令诸菩萨成办五果。谓念念中消融一切粗重依止。离种种想得法苑乐。能正了知周遍无量无分限相大法光明。顺清净分无所分别无相现行。为令法身圆满成办。能正摄受后后胜因

释曰。如一一地有五相修。今当显示。修奢摩他毗钵舍那。皆由五相并得修习。诸念念中消融一切粗重依止者。谓烦恼障及所知障。无始时来熏习种子。说名粗重。此二障聚由缘总法。止观智力念念消融。此中意取障聚破坏故名消融。或令羸损故名消融。离种种想得法苑乐者。契经等法住种种性。远离如是种种性想。即是证得法苑之乐。于中可居故名为苑。复有余义。于随所受寻伺法中。不起粗显领纳观察。但由止观忆念光明。而起微细领纳观察。能正了知周遍无量无分限相大法光明者。谓正了达十方无边无分限相。如善习诵文字光明名法光明。顺清净分无所分别无相现行者。谓事成办诸相应法。名顺净分无所分别无相现行。此中意取所得佛果。名事成办。为令法身圆满成办能正摄受后后胜因者。谓第十地法身说名圆满第十一佛地法身说名成办。一切因中生佛地者最为殊胜。是故说言能正摄受后后胜因

论曰。由增胜故说十地中别修十种波罗蜜多。于前六地所修六种波罗蜜多。如先已说。后四地中所修四者。一方便善巧波罗蜜多。谓以前六波罗蜜多所集善根。共诸有情。回求无上正等菩提故。二愿波罗蜜多。谓发种种微妙大愿。引摄当来波罗蜜多殊胜众缘故。三力波罗蜜多。谓由思择修习二力。令前六种波罗蜜多无间现行故。四智波罗蜜多。谓由前六波罗蜜多。成立妙智受用法乐。成熟有情故。又此四种波罗蜜多。应知般若波罗蜜多无分别智后得智摄。又于一切地中非不修习一切波罗蜜多。如是法门是波罗蜜多藏之所摄

释曰。由增胜故说十地中别修十种波罗蜜多者。谓十地中作如是说。初地布施波罗蜜多最为增胜。其余一切波罗蜜多非不修习。随力随分。乃至第十地智波罗蜜多最为增胜。其余一切波罗蜜多非不修习。随力随分。是故说言。由增胜故说十地中别修十种波罗蜜多。若总相说。一切地中皆修一切波罗蜜多。于前六地所修六种波罗蜜多如先已说者。显示次第别修十种波罗蜜多。如次前经。先说布施波罗蜜多。最后说智波罗蜜多。今此论中如先所说少不具足。谓后四地所修四种波罗蜜多。先所未说。若于是处。唯说六种波罗蜜多。即于此处。方便善巧等四波罗蜜多摄在其中。若于是处宣说十种波罗蜜多。此中唯说无分别智。名为般若波罗蜜多。其余方便善巧等四波罗蜜多。后得智摄。是故于后四种地中。修余四种波罗蜜多。方便善巧波罗蜜多者。谓后四中先说第一。共诸有情者。谓以此善共诸有情。如所共有。今当显示。谓以此善愿求无上正等菩提。作诸有情一切义利。要证菩提。此意方遂。是故若有如是思惟。所有善根皆悉回向无上菩提。作诸有情一切义利。如是名为共诸有情。方便善巧显示般若及以大悲。谓以前六波罗蜜多所集善根。共诸有情。此由大悲回求无上正等菩提。不求帝释等富乐果。由了知故不起烦恼。此即般若。又由具足方便善巧。不舍生死而无染污。是故说名方便善巧波罗蜜多。谓发种种微妙大愿引摄当来波罗蜜多殊胜众缘者。此显示愿波罗蜜多所作事业。此愿即是波罗蜜多。是故名愿波罗蜜多。言当来者。谓为当来此是所为。第七转声。为当来故发种种愿。余契经说有二种力。谓思择力及修习力。若虽未有修习力者。由思择力精进修习波罗蜜多故。说由此波罗蜜多无间现行。此显示力波罗蜜多所作事业。谓由前六波罗蜜多成立妙智受用法乐成熟有情者。谓由般若波罗蜜多无分别智自性等故。成立如是后得妙智。复由此智成立前六波罗蜜多。由此自为与同法者。受用法乐。及为成熟一切有情。如是法门是到彼岸藏所摄者。此中一切大乘教法。皆通说名到彼岸藏。如是所引十地法门。是彼藏摄。非声闻藏。由彼摄故。一切地中皆修一切波罗蜜多。如是诸地遍于一切诸佛国土。一切诸佛同所宣说。是故最胜。由此法门是最胜故。于最初时最胜处说。此处高广殊妙坚牢。故名最胜

论曰。复次凡经几时。修行诸地可得圆满。有五补特伽罗。经三无数大劫。谓胜解行补特伽罗。经初无数大劫修行圆满。清净增上意乐行补特伽罗。及有相行无相行补特伽罗。于前六地及第七地。经第二无数大劫修行圆满。即此无功用行补特伽罗。从此已上至第十地。经第三无数大劫修行圆满。此中有颂

  清净增上力　　坚固心升进
  名菩萨初修　　无数三大劫

释曰。有五补特伽罗经三无数大劫者。谓胜解行补特伽罗。于解行地中经初无数大劫修行圆满。既圆满已通达真如故。成清净增上意乐行补特伽罗。此清净增上意乐行遍十地中。此在六地名有相行补特伽罗。在第七地名无相有功用行补特伽罗。此经第二无数大劫修行圆满。入第八地名无功用行补特伽罗。此无功用行犹未成满。若至第九第十地中。无功用行方得成满。此经第三无数大劫修行圆满。如是唯一补特伽罗。位差别故建立五种。譬如预流一来不还。如说经三无数大劫得佛菩提。无始生死数修施等。数值诸佛。齐于何时名最初修三无数劫。故以伽他显释此问。清净增上力者。谓善根力及大愿力。由善根力。应知所治不能降伏。由大愿力。应知常值诸善知识。坚固心升进者。谓发牢固心。起增进行。牢固心者。应知所发大菩提心。诸恶友力不能令舍。增进行者。应知现在及生生中。善法常增终无退减。余义易了无烦重释

摄大乘论释卷第七摄大乘论释卷第八

        世亲菩萨造

        三藏法师玄奘奉　诏译

    增上戒学分第七

论曰。如是已说因果修差别。此中增上戒殊胜云何可见。如菩萨地正受菩萨律仪中说。复次应知略由四种殊胜故此殊胜。一由差别殊胜。二由共不共学处殊胜。三由广大殊胜。四由甚深殊胜

释曰。此中问答。辩诸菩萨所学尸罗。于声闻等有大差别故名殊胜。又此增上戒等三学。即前所说波罗蜜多自性所摄。何故别立。于先所说波罗蜜多。别义建立。今当显示。为显展转相因性故别立三学。谓依尸罗发生静虑。复依静虑发生般若

论曰。差别殊胜者。谓菩萨戒有三品别。一律仪戒。二摄善法戒。三饶益有情戒。此中律仪戒。应知二戒建立义故。摄善法戒。应知修集一切佛法建立义故。饶益有情戒。应知成熟一切有情建立义故

释曰。差别殊胜。谓声闻等唯有一种律仪戒。无摄善法戒及饶益有情戒。菩萨具三。是故殊胜

论曰。共不共学处殊胜者。谓诸菩萨一切性罪不现行故。与声闻共。相似遮罪有现行故。与彼不共。于此学处。有声闻犯菩萨不犯。有菩萨犯声闻不犯。菩萨具有身语心戒。声闻唯有身语二戒。是故菩萨心亦有犯。非诸声闻。以要言之。一切饶益有情无罪身语意业。菩萨一切皆应现行。皆应修学。如是应知。说名为共不共殊胜

释曰。共不共中。一切性罪。谓杀生等说名为共。相似遮罪。为掘生地断生草等说名不共。于此学处者。谓后学处。有声闻犯菩萨不犯者。如两安居观益有情辄行经宿。有菩萨犯声闻不犯者。谓观有益而故不行。是故菩萨心亦有犯非诸声闻者。谓唯内起欲等寻思。菩萨成犯。非声闻等。一切饶益有情无罪身语意业菩萨一切皆应现行皆应修学者。谓能饶益而无有罪。如是三业。菩萨应修。或虽饶益。而非无罪。如以女等非法之物授与他人。为遮此事故说无罪

论曰。广大殊胜者。复由四种广大故。一由种种无量学处广大故。二由摄受无量福德广大故。三由摄受一切有情利益安乐意乐广大故。四由建立无上正等菩提广大故

释曰。种种无量学处广大者。谓诸菩萨所修学处。亦是种种亦是无量。由此于彼一切有情。作成熟事及摄受事故。摄受无量福德广大者。谓诸菩萨摄受无量福德资粮。非声闻故。摄受一切有情利益安乐意乐广大者。谓于诸有情劝令修善。名利益意乐。若即于此补特伽罗。愿由彼善当得胜果。名安乐意乐。建立无上正等菩提广大者。谓诸菩萨由此尸罗。建立无上正等菩提。非声闻故

论曰。甚深殊胜者。谓诸菩萨由是品类方便善巧。行杀生等十种作业而无有罪。生无量福。速证无上正等菩提。又诸菩萨现行变化身语两业。应知亦是甚深尸罗。由此因缘或作国王。示行种种恼有情事。安立有情毗奈耶中。又现种种诸本生事。示行逼恼诸余有情。真实摄受诸余有情。先令他心深生净信。后转成熟。是名菩萨所学尸罗甚深殊胜

释曰。甚深殊胜中。谓诸菩萨由是品类方便善巧者。此中显示如是菩萨如是方便善巧功能。谓诸菩萨若如是知。如是品类补特伽罗。于此不善无间等事将起加行。以他心智了知彼心。无余方便能转彼业。如实了知彼由此业定退善趣定往恶趣。如是知已生如是心。我作此业当堕恶趣。我宁自往必当脱彼。于彼现在虽加少苦。令彼未来多受安乐。是故菩萨譬如良医。以饶益心虽复杀之而无少罪。多生其福。由多福故疾证无上正等菩提。如是等戒最为甚深。又诸菩萨现起变化身语二业。当知亦是甚深尸罗。由此道理。或作国王现作种种恼有情事。安立有情毗奈耶中。变化自体名为变化。此中应说无厌足王化导善财童子等事。又现种种诸本生事者。如毗湿婆安呾罗等诸本生事。此中菩萨以其男女施婆罗门。皆是变化。示行逼恼诸余有情真实摄受诸余有情者。谓诸菩萨终不逼恼余实有情。摄受其余实有情故。如是亦名甚深殊胜

论曰。由此略说四种殊胜。应知菩萨尸罗律仪最为殊胜。如是差别菩萨学处。应知复有无量差别。如毗奈耶瞿沙方广契经中说

释曰。如是四种略说差别。于毗奈耶瞿沙经中。广说复有百千差别

    摄大乘论释增上心学分第八

论曰。如是已说增上戒殊胜。增上心殊胜云何可见。略由六种差别应知。一由所缘差别故。二由种种差别故。三由对治差别故。四由堪能差别故。五由引发差别故。六由作业差别故

释曰。为显增上心学殊胜。作此问答

论曰。所缘差别者。谓大乘法为所缘故

释曰。谓大乘法为所缘者。诸菩萨定缘于大乘。非声闻定

论曰。种种差别者。谓大乘光明集福定王贤守健行等三摩地。种种无量故

释曰。大乘光明集福定王等者。显如是等诸三摩地种种差别唯大乘有。声闻乘等一种亦无

论曰。对治差别者。谓一切法总相缘智。以楔出楔道理。遣阿赖耶识中一切障粗重故

释曰。缘总法智对治一切障碍而住。如以细楔除去粗楔住本识中。诸杂染法熏习种子说名为粗。诸对治道。能除彼故是微细义

论曰。堪能差别者。谓住静虑乐。随其所欲而受生故

释曰。由有堪能住静虑乐。随有饶益诸有情处。即往彼生不退静虑。诸声闻等无如是事

论曰。引发差别者。谓能引发一切世界无碍神通故

释曰。由此静虑引发神通一切世界皆无障碍

论曰。作业差别者。谓能振动炽然遍满显示转变往来卷舒。一切色像皆入身中。所往同类。或显或隐。所作自在。伏他神通。施辩念乐。放大光明。引发如是大神通故

释曰。作业差别。谓发神通所作事业。此中能动一切世界故名振动。即彼炽然故名炽然。言遍满者。应知即是光明普照。言显示者。由此威力。令无所能余有情类。欻然能见无量世界。及见其余佛菩萨等。言转变者。应知转变一切地等令成水等。言往来者。谓一刹那普能往还无量世界。言卷舒者。谓卷十方无量世界入一极微。极微不增。舒一极微包于十方无量世界。世界不减。一切色像皆入身中者。谓身中现无量种种一切事业。所往同类者。谓如往诣三十三天。色像言音与彼同类。为化彼故往一切处亦复如是。显谓显现。隐谓隐藏。所作自在者。如变魔王作佛身等。伏地神通者。谓能映蔽一切神通。于请问者施以辩才故名施辩。于听闻者施念施乐。令得定故名施念乐。放大光明者。为欲召集远住他方世界菩萨。引发如是大神通者。引前所说大神通故。如是一切声闻所无。是故殊胜

论曰。又能引发摄诸难行。十难行故。十难行者。一自誓难行。誓受无上菩提愿故。二不退难行。生死众苦不能退故。三不背难行。一切有情虽行邪行而不弃故。四现前难行。怨有情所现作一切饶益事故。五不染难行。生在世间不为世法所染污故。六胜解难行。于大乘中虽未能了然。于一切广大甚深生信解故。七通达难行。具能通达补特伽罗法无我故。八随觉难行。于诸如来所说甚深秘密言词。能随觉故。九不离不染难行。不舍生死而不染故。十加行难行。能修诸佛安住。解脱一切障碍。穷生死际。不作功用。常起一切有情一切义利行故

释曰。如说菩萨修诸难行。此中何等名为难行。一切难行十种所显。于中不离不染难行者。不弃舍故名为不离。谓于生死不全舍离。亦不染污。此甚为难。余九难行其义易了

论曰。复次随觉难行中。于佛何等秘密言词。彼诸菩萨能随觉了。谓如经言

释曰。为显秘密言词意趣故为此问。如经言者。总答前问。后当别释

论曰。云何菩萨能行惠施。若诸菩萨无少所施。然于十方无量世界广行惠施。云何菩萨乐行惠施。若诸菩萨于一切施都无欲乐。云何菩萨于惠施中深生信解。若诸菩萨不信如来而行布施。云何菩萨于施策励。若诸菩萨于惠施中不自策励。云何菩萨于施耽乐。若诸菩萨无有暂时少有所施。云何菩萨其施广大。若诸菩萨于惠施中离娑洛想。云何菩萨其施清净。若诸菩萨殟波陀悭。云何菩萨其施究竟。若诸菩萨不住究竟。云何菩萨其施自在。若诸菩萨于惠施中不自在转。云何菩萨其施无尽。若诸菩萨不住无尽。如于布施。于戒为初。于慧为后。随其所应当知亦尔

释曰。云何菩萨能行惠施等者。谓诸菩萨一切有情摄为自体。是故彼施即是己施。是此意趣。云何菩萨乐行惠施等者。谓诸菩萨不乐修行味着等施。但乐修行菩萨净施。言味著者。意说贪染。或有余处名来求施。云何菩萨于惠施中深生信解等者。谓诸菩萨自得施心而行惠施。不藉他缘。云何菩萨于施策励等者。谓诸菩萨性自能施。悭吝断故。不待他策亦不自策。任运能施。是此意趣。云何菩萨于施耽乐等者。谓诸菩萨常行施故无暂时施。一切施故无少所施。云何菩萨其施广大等者。谓诸菩萨依定行施。即是离欲而行施义。言娑洛者。显目坚实。密诠流散。今取密义。离流散想。依定行施故成广大。云何菩萨其施清净等者。谓诸菩萨拔除悭足而行惠施。殟波陀者。显目生起。密诠拔足。波陀名足。殟名为拔。今取密义。拔除悭足令面倾覆而行惠施。是故说名殟波陀悭。云何菩萨其施究竟等者。谓诸菩萨不住究竟。无余涅槃如声闻等。是故究竟常能行施。云何菩萨其施自在等者。谓诸菩萨令施等障不得自在而行惠施。令所治障不自在故施得自在。云何菩萨其施无尽。谓诸菩萨不住涅槃。常行惠施。此中无尽。意取涅槃。不同声闻住涅槃故。其施无尽

论曰。云何能杀生。若断众生生死流转。云何不与取。若诸有情无有与者自然摄取。云何欲邪行。若于诸欲了知是邪而修正行。云何能妄语。若于妄中能说为妄。云何贝戍尼。若能常居最胜空住。云何波鲁师。若善安住所知彼岸。云何绮间语。若正说法品类差别。云何能贪欲。若有数数欲自证得无上静虑。云何能嗔恚。若于其心能正憎害一切烦恼。云何能邪见。若一切处遍行邪性皆如实见

释曰。如经中说。苾刍。我是能杀生等者。此中显彼所说意趣。云何欲邪行者。谓知诸欲皆是其邪而修正行。云何贝戍尼者。此贝戍尼。显目离间语。密诠常胜空。贝者表胜。戍者表空。尼者表常。今取密义与答相应。是故答言。若能常居最胜空住。云何波鲁师者。此波鲁师。显目粗恶语。密诠住彼岸。波表彼岸。鲁师表住。今取密义与答相应。是故答言。善安住所知彼岸。是到所知彼岸住义。云何能邪见等者。谓色等中如实观见遍行邪性。即是于彼依他起中。如实观见遍计所执。是邪性义。于十不善业道文中。余义易了

论曰。甚深佛法者。云何名为甚深佛法。此中应释。谓常住法是诸佛法。以其法身是常住故。又断灭法是诸佛法。以一切障永断灭故。又生起法是诸佛法。以变化身现生起故。又有所得法是诸佛法。八万四千诸有情行。及彼对治皆可得故。又有贪法是诸佛法。自誓摄受有贪有情为己体故。又有嗔法是诸佛法。又有痴法是诸佛法。又异生法是诸佛法。应知亦尔。又无染法是诸佛法。成满真如一切障垢不能染故。又无污法是诸佛法。生在世间。诸世间法不能污故。是故说名甚深佛法

释曰。复有余处契经说言。谓常住法是诸佛法。广说乃至又无污法是诸佛法。此中意趣今当显示。谓佛法身体是常住故。说此法为常住法。断灭法者。所有障垢悉皆断灭。由此义故即说此法为断灭法。有所得法是佛法者。有情诸行八万四千。及彼对治皆有可得。故说此法名有所得。无染法者。清净真如。一切障垢所不能染。故说此法名无染法。余义易了无烦重释

论曰。又能引发修到彼岸。成熟有情净佛国土。诸佛法故。应知亦是菩萨等持作业差别

释曰。前所未说作业差别。今于此中。复显菩萨等持作业。谓诸菩萨依三摩地。能修一切波罗蜜多。又依此定能善成熟一切有情。发神通等种种方便。引诸有情入正法故。又由此力能善清净一切佛土。心得自在。随欲能成金银等宝诸佛土故。又由此力能正修集一切佛法。是三摩地作业差别

    摄大乘论释增上慧学分第九之一

论曰。如是已说增上心殊胜。增上慧殊胜云何可见。谓无分别智。若自性若所依。若因缘若所缘。若行相若任持若助伴。若异熟若等流。若出离若至究竟。若加行无分别后得胜利。若差别若无分别后得譬喻。若无功用作事若甚深。应知无分别智名增上慧殊胜

释曰。今正至说增上慧时。此中意说。无分别智名增上慧。此复三种。一加行无分别智。谓寻思慧。二根本无分别智。谓正证慧。三后得无分别智。谓起用慧。此中悕求慧。是第一增上慧。内证慧是第二增上慧。摄持慧是第三增上慧。今且成立无分别智。由唯此智通因果故。其寻思智是此智因。其后得智是此智果。所以成此兼成余二

论曰。此中无分别智。离五种相以为自性。一离无作意故。二离过有寻有伺地故。三离想受灭寂静故。四离色自性故。五离于真义异计度故。离此五相。应知是名无分别智

释曰。且应先说无分别智所有自性。此中体相。说名自性。谓诸菩萨无分别智。离五种相以为自性。离五相者。若无作意是无分别智。睡醉闷等应成无分别智。若过有寻有伺地是无分别智。第二静虑已上诸地应成。无分别智。若如是者。世间应得无分别智。若想受灭等位中。心心法不转是无分别智。灭定等位无有心故。智应不成。若如色自性是无分别智。如彼诸色顽钝无思。此智应成顽钝无思。复有余义。若如色性智不应成。若于真义异计度转。无分别智应有分别。谓分别言此是真义。若智远离如是五相。于真义转于真义中不异计度。此是真义无分别智。有如是相缘真义时。譬如眼识不异计度。此是其义

论曰。于如所说。无分别智成立相中。复说多颂

释曰。于上所说无分别智略成立中。广说多颂

论曰

  诸菩萨自性　　远离五种相
  是无分别智　　不异计于真

释曰。由此初颂显上所说无分别智。初自性义如是已说。此智自性依彼而转。次颂当说

论曰

  诸菩萨所依　　非心而是心
  是无分别智　　非思义种类

释曰。如是所说无分别智。当言依心为依非心。若言依心能思量故。说名为心依心而转。是无分别不应道理。若依非心则不成智。为避如是二种过失故说此颂。此智所依不名为心。不思义故。亦非非心。心所引故。此生所依是心种类。亦名为心因彼而生。次颂当显

论曰

  诸菩萨因缘　　有言闻熏习
  是无分别智　　及如理作意

释曰。诸菩萨因缘者。谓此智因。有言闻熏习者。谓由他音正闻熏习。及如理作意者。谓此熏习为因意。言如理作意。无分别智因此而生。复何所缘。次颂当显

论曰

  诸菩萨所缘　　不可言法性
  是无分别智　　无我性真如

释曰。不可言法性者。谓由遍计所执自性。一切诸法皆不可言。何等名为不可言性。谓无我性所显真如。遍计所执补特伽罗。及一切法皆无自性。名无我性。即此无性所显有性。说名真如。勿取断灭故说此言。又于所缘所作行相。次颂当显

论曰

  诸菩萨行相　　复于所缘中
  是无分别智　　彼所知无相

释曰。菩萨行相于所缘中所现无相。谓即此智于真如中平等。平等生起无异无相之相。以为行相。如眼取色见青等相。非此青等与色有异。此亦如是。智与真如无异行相。即于此中为释疑难。复说二颂

论曰

  相应自性义　　所分别非余
  字展转相应　　是谓相应义
  非离彼能诠　　智于所诠转
  非诠不同故　　一切不可言

释曰。若一切法皆不可言。复以何等为所分别。为释此故说如是言。相应自性义所分别非余。谓即相应为自性义。是所分别非离于此。故言非余。此云何成。为重成立复说是言。字展转相应是谓相应义。谓别别字相续宣传。以成其义。是相应义如言斫刍。二字不断说成眼义。是相应义为所分别。又一切法皆不可言。因何成立。故复说言非离。彼能诠智于所诠转。由若不了能诠之名。于所诠义觉知不起。故一切法皆不可言。若言要待能诠之名。于所诠义有觉知起。为遮此故复说是言。非诠不同故。以能诠名与所诠义互不相称。各异相故。能诠所诠皆不可说。由此因故说一切法皆不可言。无分别智何所任持

论曰

  诸菩萨任持　　是无分别智
  后所得诸行　　为进趣增长

释曰。由无分别后所得智。得菩萨行。此行即依无分别智。为进趣增长者。为令如是诸菩萨行得增长故。无分别智是彼任持。此智复以何为助伴

论曰

  诸菩萨助伴　　说为二种道
  是无分别智　　五到彼岸性

释曰。二种道者。一资粮道。二依止道。资粮道者。谓施戒忍及与精进波罗蜜多。依止道者。即是静虑波罗蜜多。由前所说波罗蜜多所生诸善。及依静虑波罗蜜多。无分别智即得生长。此智名慧波罗蜜多。乃至未得佛果已来。无分别智于何处所感异熟果

论曰

  诸菩萨异熟　　于佛二会中
  是无分别智　　由加行证得

释曰。于佛二会中者。谓受用身会中。及变化身会中。若无分别加行转时。于变化身会中受生。受异熟果。若已证得无分别智。于受用身会中受生。受异熟果。为显此义故。复说由加行证得。无分别智谁为等流

论曰

  诸菩萨等流　　于后后生中
  是无分别智　　自体转增胜

释曰。诸菩萨等流于后后生中者。于次前说二身大会后后生中。是无分别智自体转增胜者。即彼所修无分别智展转增胜。应知即是彼等流果。无分别智出离云何

论曰

  诸菩萨出离　　得成办相应
  是无分别智　　应知于十地

释曰。诸菩萨出离者。进趣究竟故名出离。即是进趣大涅槃义。得成办相应是无分别智者。初护此智名得相应。次后无量百千大劫成办相应。应知于十地者。谓从初地乃至第十。如是次第。此智初地唯名为得。尔后多时乃名成办。是故菩萨经无数劫乃证涅槃。由尔所时方到究竟。无分别智谁为究竟。而次前说次第获得

论曰

  诸菩萨究竟　　得清净三身
  是无分别智　　得最上自在

释曰。得清净三身者。是得如来净三身义。言清净者。谓初地中唯得三身至第十地乃善清净。得最上自在者。无分别智非唯证得清净三身以为究竟。而复获得十种自在。此如后说应知其相。无分别智有何胜利。此中三种无分别智。一者加行无分别智。二者根本无分别智。三者后得无分别智。此中加行无分别智。谓诸菩萨初从他闻无分别理。次虽未能自见此理而生胜解。次此胜解为所依止。方便推寻无分别理。是名加行无分别智。由此能生无分别智。是故亦得无分别名。如是加行无分别智无染胜利。其譬云何

论曰

  如虚空无染　　是无分别智
  种种极重恶　　由唯信胜解

释曰。为欲显示彼不能染故。说种种极重恶言。为欲显示不能染因故。说由唯信胜解。言由唯信乐无分别理而起胜解。故能对治种种恶趣。此即显示诸恶不染。此中根本无分别智无染胜利。其譬云何

论曰

  如虚空无染　　是无分别智
  解脱一切障　　得成办相应

释曰。从何解脱。谓解脱一切障。由何解脱。谓成办相应如是解脱。由于诸地唯得相应。成办相应以为因故。此即显示无分别智能治诸障。此中后得无分别智无染胜利。其譬云何

论曰

  如虚空无染　　是无分别智
  常行于世间　　非世法所染

释曰。由此智力观诸有情诸利乐事故。思往彼世间受生。既受生已。一切世法所不能染。世法有八。一利二衰三誉四毁五称六讥七苦八乐。从无分别智所生故。此智亦得无分别名。今当显此三智差别

论曰

  如哑求受义　　如哑正受义
  如非哑受义　　三智譬如是
  如愚求受义　　如愚正受义
  如非愚受义　　三智譬如是
  如五求受义　　如五正受义
  如末那受义　　三智譬如是
  如未解于论　　求论受法义
  次第譬三智　　应知加行等

释曰。此中三智如其譬喻。应知差别。譬如哑人求受境义不能言说。如是加行无分别智。应知亦尔。譬如哑人正受境义寂无言说。如是根本无分别智。应知亦尔。如非哑人受境义已。如其所受而起言说。如是后得无分别智。应知亦尔。此中意取能作文字。名为言说。如愚颂中。无所了别说名为愚。如前哑喻应正安立三智差别。如五颂中。五谓眼等五无分别。应知此中求受正受俱无分别。加行根本于真如义差别亦尔。如意受义亦能分别。如是后得亦能受义。亦能分别。如是三智如前哑喻安立差别。于论颂中。如未解论于论求解。如是加行无分别智。应知亦尔。如温习论但受于法。如是根本无分别智。应知亦尔。此中法者。意取文字如解论者。于法于义皆能领受。如是后得无分别智。应知亦尔次第之言。显示三智似于法义领受差别。次当显示根本后得譬喻差别

论曰

  如人正闭目　　是无分别智
  即彼复开目　　后得智亦尔
  应知如虚空　　是无分别智
  于中现色像　　后得智亦尔

释曰。初颂显示二智差别。其相可知。如虚空者。譬如虚空周遍无染。非能分别。非所分别。如是根本无分别智。应知亦尔。遍一切法一味空性故名周遍。一切诸法所不能染故名无染。自无分别。是故说名非能分别。亦不为他分别行相。是故说名非所分别。如是应知。无分别智譬如虚空。现色像者。譬如空中所现色像是可分别。如是后得无分别智。应知亦尔。是所分别亦能分别。若以如是无分别智修成佛果。既离功用作意分别。云何能成利益安乐诸有情事

论曰

  如末尼天乐　　无思成自事
  种种佛事成　　常离思亦尔

释曰。如离分别所作事成。于此颂中。末尼天乐譬喻。显示如如意珠虽无分别而能成办。随诸有情意所乐事。又如天乐无击奏者。随生彼处有情意乐。出种种声。如是应知。诸佛菩萨无分别智。虽离分别而能成办种种事业。次当显此无分别智所有甚深。此智为缘依他起性。分别事转为缘余境。若尔何失。若缘分别。无分别性应不得成。若缘余境余境定无。云何得缘

论曰

  非于此非余　　非智而是智
  与境无有异　　智成无分别

释曰。非于此非余者。此智不缘分别为境。无分别故。不缘余境即缘依他。诸分别法真如法性为境界故。法与法性若一若异不可说故。此说根本无分别智。不缘分别亦不缘余。又此根本无分别智为智为非。若尔何失。若是智者。云何是智而是无分别。若非智者。云何说为无分别智。答此问言。非智而是智。此显根本无分别智非定是智。似于加行分别智中此不生故。亦非非智。以从加行分别智因而得生故。复有别义。非于此非余非智而是智者。以非于此分别转故。说名非智。以非于余即于分别法性转故。而亦是智。前后二句互相解释。与境无有异智成无分别者。非如加行无分别智。有其所取能取性转名无分别。与所取境无差别转。平等平等名无分别。此智不住所取能取二种性中。如薄伽梵余契经中说。一切法皆无分别。为欲显示无分别义。复说颂言

论曰

  应知一切法　　本性无分别
  所分别无故　　无分别智无

释曰。应知一切法本性无分别者。是一切法本来自性无分别义。何以故。所分别无故。此即显示所分别事无所有故。诸法本性无有分别。若所分别无所有故。诸法本性无分别者。何故本来一切有情不得解脱。答此问言。无分别智无此显彼。无无分别智。虽一切法本来自性无有分别。而不解脱。若于诸法无分别理。真证智生。现见诸法无分别性。即得解脱。此未生故未得解脱。真证智者。应知即是无分别智。今当显此三智差别

摄大乘论释卷第八摄大乘论释卷第九

        世亲菩萨造

        三藏法师玄奘奉　诏译

    增上慧学分第九之余

论曰。此中加行无分别智有三种。谓因缘引发数习生差别故

释曰。此中加行无分别智三种差别。谓或由种姓力。或由前生引发力。或由现在数习力而得生故。或由种姓力者。种姓为因而得生故。前生引发力者。由前生中数习为因而得生故。现在数习力者。由现在生士用力为因而得生故

论曰。根本无分别智亦有三种。谓喜足无颠倒无戏论。无分别差别故

释曰。此中喜足无分别者。应知已到闻思究竟。由喜足故不复分别故。名喜足无分别智。谓诸菩萨住异生地。若得闻思觉慧究竟。便生喜足作是念言。凡所闻思极至于此。以是义故说名喜足无分别智。复有余义。应知世间亦有喜足无分别智。谓诸有情至第一有见为涅槃。便生喜足作是念言。过此更无所应至处故。名喜足无分别智。无颠倒无分别者。谓声闻等。应知彼等通达真如。得无常等四无倒智。无常等四颠倒分别。名无颠倒无分别智。无戏论无分别者。谓诸菩萨。应知菩萨于一切法。乃至菩提皆无戏论。应知此智所证真如。过名言路超世智境。由是名言不能宣说。诸世间智不能了知

论曰。后得无分别智有五种。谓通达随念安立和合如意思择差别故

释曰。此后得智五种差别。一通达思择。二随念思择。三安立思择。四和合思择。五如意思择。此中通达思择者。谓通达时如是思择。我已通达。此中思择意取觉察。随念思择者。谓从此出随忆念言。我已通达无分别性。安立思择者。谓为他说此通达事。和合思择者。谓总缘智观一切法皆同一相。由此智故进趣转依。或转依已重起此智。如意思择者。谓随所思一切如意。由此思择能变地等令成金等。为得如意起此思择。是故说名如意思择。如有说言。由思择故便得如意。虽已成立无分别智。犹未宣说成立因缘。是故复说多颂显示

论曰。复有多颂。成立如是无分别智

  鬼傍生人天　　各随其所应
  等事心异故　　许义非真实
  于过去事等　　梦像二影中
  虽所缘非实　　而境相成就
  若义义性成　　无无分别智
  此若无佛果　　证得不应理
  得自在菩萨　　由胜解力故
  如欲地等成　　得定者亦尔
  成就简择者　　有智得定者
  思惟一切法　　如义皆显现
  无分别智行　　诸义皆不现
  当知无有义　　由此亦无识

释曰。鬼傍生人天各随其所应等者。谓于傍生见有水处。饿鬼见是陆地高原。于人所见有粪秽处。猪等傍生见为净妙可居室宅。于人所见净妙饮食。诸天见为臭秽不净。如是众生于等事中心见异故。应知境义非真实有。若义实无识应无境。有无境识如缘去来。如缘梦像。如缘镜等及三摩地所行影像。为显此义说一伽他。谓于过去等。此中前半由后半释。如其次第应知其相。由无别实境。是故说言有无境识。由自变为境。是故说言境相成就。即是自缘心影像义。谓缘去来梦像二影。次第安立境相成就。若义义性成无无分别智者。若义实有义之自性。是则应无无分别智。若谓虽无无分别智。当有何失。此若无佛果证得不应理者。若汝拨无无分别智。是则不应证得佛果故。应决定许有如是无分别智。得自在菩萨者。谓已证得自在菩萨。由胜解力故者。由愿乐力。如欲地等成者。谓令地等成金等相。随欲皆成。得定者亦尔者。谓余声闻等。成就简择者者。谓已成满毗钵舍那。言有智者。谓诸菩萨。得定者者。得三摩地。思惟一切法如义皆显现者。谓菩萨等定慧成满摄心于内。如如思惟经等法义。如是如是皆得显现。若念佛时随所思念彼彼法中佛义显现。思色受等应知亦尔。无分别智行诸义皆不现者。谓无分别智正现行时。一切境义皆不显现。当知无有义者。谓由前说种种道理。当知境义实无所有。欲显其识如境亦无故。言由此亦无识。所识境义既无所有。由此应知能识亦无。此义如前所知相中分明已显

论曰。般若波罗蜜多与无分别智无有差别。如说菩萨安住般若波罗蜜多非处相应。能于所余波罗蜜多修习圆满。云何名为非处相应修习圆满。谓由远离五种处故。一远离外道我执处故。二远离未见真如菩萨分别处故。三远离生死涅槃二边处故。四远离唯断烦恼障生喜足处故。五远离不顾有情利益安乐。住无余依涅槃界处故

释曰。无分别智即是般若波罗蜜多。由彼经中说。诸菩萨安住般若波罗蜜多非处相应。能于所余波罗蜜多修习圆满。为欲令知如是义故显示彼文。远离外道我执处者。谓如外道住般若中执我我所。作如是念我能住般若。般若是我所菩萨不尔。远离如是诸外道辈我执处故。应知说名非处相应。安住般若波罗蜜多。远离未见真如菩萨分别处者。谓如未见真如菩萨。于无分别般若波罗蜜多中。分别此是般若波罗蜜多。菩萨远离如是分别。应知说名非处相应安住般若波罗蜜多。远离生死涅槃二边处者。谓如世间安住生死。诸声闻等安住涅槃。菩萨不尔。远离二边。应知说名非处相应安住般若波罗蜜多。远离唯断烦恼障生喜足处者。如声闻等唯断烦恼障便生喜足菩萨不尔。由此意趣。应知说名非处相应安住般若波罗蜜多。远离不顾有情利益安乐住无余依涅槃界处者。谓如声闻等不顾有情利益安乐。于无余依般涅槃界而般涅槃。菩萨不尔。不住声闻所住之处。应知说名非处相应安住般若波罗蜜多

论曰。声闻等智与菩萨智有何差别。由五种相应知差别。一由无分别差别谓于蕴等法无分别故。二由非少分差别。谓于通达真如。入一切种所知境界。普为度脱一切有情。非少分故。三由无住差别。谓无住涅槃为所住故。四由毕竟差别。谓无余依涅槃界中无断尽故。五由无上差别。谓于此上无有余乘胜过此故。此中有颂

  诸大悲为体　　由五相胜智
  世出世满中　　说此最高远

释曰。此中显示声闻等智与菩萨智五相差别。无分别差别者。谓声闻等缘于蕴等分别识生。非菩萨智分别蕴等。非少分差别者。谓显三种非少分性。一所达真如非少分性。二所知境界非少分性。三所度有情非少分性。所达真如非少分性者。谓菩萨智具足通达补特伽罗法无我性。声闻等智入真如时。唯能通达补特伽罗无我之性。所知境界非少分性者。谓菩萨智普缘一切所知境生。声闻等智唯缘苦等诸谛而生。所度有情非少分性者。谓菩萨智普为度脱一切有情。勤趣菩提。声闻等智唯求自利。无住差别者。谓菩萨智正为安住无住涅槃。非声闻等。是故差别。毕竟差别者。谓声闻等于无余依涅槃界中一切灭尽。菩萨于此涅槃界中功德无尽。是故差别。无上差别者。谓声闻等上有大乘。其菩萨乘无复有上。是故差别。为显此义说一伽他。世出世满中者。谓于色无色界世间满中。及于声闻乘等出世满中

论曰。若诸菩萨成就如是增上尸罗。增上质多增上般若功德圆满。于诸财位得大自在何故现见有诸有情匮乏财位见彼有情。于诸财位有重业障故。见彼有情若施财位障生善法故。见彼有情。若乏财位厌离现前故。见彼有情。若施财位即为积集不善法因故。见彼有情。若施财位即便作余无量有情损恼因故。是故现见有诸有情匮乏财位。此中有颂

  见业障现前　　积集损恼故
  现有诸有情　　不感菩萨施

释曰。此中显示。由是因缘。菩萨虽得财位自在具足大悲。而不施与有情财位。见彼有情于诸财位有重业障故者。谓诸有情有障菩萨神力恶业。由彼恶业障碍菩萨无障碍智。由见此故。虽有堪能虽彼匮乏而便弃舍。此中应引饿鬼江喻。如江有水。无障饮者。然诸饿鬼由自业过不能得饮。此亦如是。江喻菩萨。财位喻水。鬼喻有情。如彼饿鬼不合饮用江中净水。如是有情不合受用菩萨财位。见彼有情若施财位障生善法故者。谓复有余补特伽罗虽无业障。菩萨见彼于相续中当生善法。若施财位。受富乐故障彼生善。作是思惟。宁彼贫贱顺生善法。勿彼富贵障善法生。由此道理。虽得自在不施财位。见彼有情若乏财位厌离现前故者。谓复有余补特伽罗。菩萨见彼由贫贱故厌离现前。作是思惟。宁彼贫贱厌离现前随顺善法。勿彼富贵不生厌离。由此道理。虽得自在不施财位。见彼有情若施财位即为积集不善法因故者。谓复有余补特伽罗。菩萨见彼乃至贫穷常不积集诸不善法。作是思惟。宁彼贫穷不造诸恶。勿彼富贵集诸不善。由此道理。虽得自在不施财位。见彼有情若施财位即便作余无量有情损恼因故者。谓复有余补特伽罗。菩萨见彼得大财位即便苦恼无量有情。作是思惟。宁彼一身独受贫贱。勿彼富贵损恼其余无量有情。由此道理。虽得自在不施财位。为显此义复说伽他。谓见有情有业障故。障生善故。厌现前故。积集恶故。损恼他故。不感菩萨施彼财位。是故现有匮乏有情。此略显义。余广易了

    摄大乘论释果断分第十

论曰。如是已说增上慧殊胜。彼果断殊胜云何可见。断谓菩萨无住涅槃。以舍杂染不舍生死。二所依止转依为相。此中生死。谓依他起性杂染分。涅槃。谓依他起性清净分。二所依止。谓通二分依他起性。转依。谓即依他起性对治起时转舍杂染分。转得清净分

释曰。无住涅槃以舍杂染不舍生死二所依止转依为相者。谓住此转依时。不容烦恼不舍生死。是此转依相。何者生死。谓依他起杂染性分。何者涅槃。谓依他起清净性分。何者依止。谓通二分所依自性。何者转依。谓即此性对治生时。舍杂染分得清净分

论曰。又此转依略有六种。一损力益能转。谓由胜解力闻熏习住故。及由有羞耻。令诸烦恼少分现行不现行故。二通达转。谓诸菩萨已入大地。于真实非真实显现不显现现前住故。乃至六地。三修习转。谓犹有障。一切相不显现。真实显现故。乃至十地。四果圆满转谓永无障。一切相不显现。最清净真实显现。于一切相得自在故。五下劣转。谓声闻等唯能通达补特伽罗空无我性。一向背生死一向舍生死故。六广大转。谓诸菩萨兼通达法空无我性。即于生死见为寂静。虽断杂染而不舍故。若诸菩萨住下劣转有何过失不顾一切有情利益安乐事故。违越一切菩萨法故。与下劣乘同解脱故。是为过失。若诸菩萨住广大转有何功德。生死法中以自转依为所依止。得自在故。于一切趣。示现一切有情之身。于最胜生及三乘中。种种调伏方便善巧。安立所化诸有情故。是为功德

释曰。又此转依略有六种。损力益能转者。谓损减阿赖耶识中烦恼熏习力故。增益彼对治功能故得此转依。谓由胜解力闻熏习住故者。谓住胜解行地安立闻熏习力故得此转依。及由有惭羞等者。于此位中。若烦恼现行即深羞耻。或少分现行。或全不现行。通达转者。谓入地时所得转依。于真实非真实等者。谓此转依乃至六地。或时为真实显现因。或时出观为非真实显现因。修习转谓犹有障者。由所知障说名有障。一切相不显现等者。谓此转依乃至十地。一切有相不复显现。唯有无相真实显现。果圆满转谓永无障者。由无一切障说名无障。一切相不显现者。无一切障故。最清净真实显现者。即由此故。于一切相得自在者。由此为依得相自在。随其所欲利乐有情。下劣转谓声闻等。等者。等取独觉。唯能通达一空无我。不能利他故。是下劣。广大转谓诸菩萨等者。由并通达二空无我。安住此中舍诸杂染。不舍生死兼利自他故。是广大。住下劣转有何过失等者。不顾有情越菩萨法。下劣乘同。是为过失。住广大转有何功德等者。以自转依为所依止。于一切法得自在故。于一切趣示现一切同分之身。于最胜生及三乘中。种种调伏方便巧智。安立所化难调有情。是为功德。此中意取世间富贵为最胜生

论曰。此中有多颂

  诸凡夫覆真　　一向显虚妄
  诸菩萨舍妄　　一向显真实
  应知显不显　　真义非真义
  转依即解脱　　随欲自在行
  于生死涅槃　　若起平等智
  尔时由此证　　生死即涅槃
  由是于生死　　非舍非不舍
  亦即于涅槃　　非得非不得

释曰。为显转依故说多颂。如诸凡夫。由无明故覆障真实。显一切种所有虚妄。如是圣者。无明断故舍离虚妄。显一切种所有真实。由此道理。应知显不显真义非真义者。遍计所执非真不转。圆成实相真义转故。言转依者。此即转依于此位中真义现行。非真实义不现行故。即解脱者。即此转依解脱相应。随欲自在行者。谓此解脱随其所欲自在而行非如声闻所得解脱。犹如斩首。毕竟安住般涅槃故。于生死涅槃若起平等智等者。谓于生死及于涅槃起平等智。由此二种无别性故。即于此时是尔时义。又此二种云何平等。以诸杂染名为生死。即杂染法无我之性名为涅槃。菩萨通达诸法无我平等智生。见彼诸法皆无自性。诸有生死即是涅槃。以于其中见极寂静即涅槃故。若如是知复何所得。由是于生死。非舍非不舍等者。诸有生死即是涅槃。是故不舍。即是无别有可舍义。即于其中见无性故离诸杂染。名非不舍。既得如是亦即于涅槃非得非不得。离生死外无别涅槃而可证得。故名非得。复于其中见寂静故。虽无性别而证涅槃。名非不得

    摄大乘论释彼果智分第十一之一

论曰。如是已说彼果断殊胜。彼果智殊胜云何可见。谓由三种佛身。应知彼果智殊胜。一由自性身。二由受用身。三由变化身。此中自性身者。谓诸如来法身。一切法自在转所依止故。受用身者。谓依法身。种种诸佛众会所显。清净佛土大乘法乐为所受故。变化身者。亦依法身。从睹史多天宫现没受生受欲。踰城出家。往外道所修诸苦行。证大菩提。转大法轮。入大涅槃故

释曰。今当解说果智殊胜。此由诸佛三身所显。自性身者。谓诸法界所流法乐。大自在转之所依止受用身者。谓即依前所说法身。种种诸佛众会所显。于诸清净佛国土中。受用一切法界所流大乘经等种种法乐之所依止。复有余义。谓是受用清净佛土之所依止。又是受用大乘法乐之所依止。变化身者。谓依法身。从睹史多天宫现没乃至入大涅槃故者。谓现人天同分之身之所依止

论曰。此中说一嗢拖南颂

  相证得自在　　依止及摄持
  差别德甚深　　念业明诸佛

释曰。为明诸佛所得之身故。说相等嗢柁南颂

论曰。诸佛法身以何为相。应知法身略有五相

释曰。应知法身有无量相。今于此中略说五种

论曰。一转依为相谓转灭一切障杂染分。依他起性故。转得解脱一切障于法自在。转现前清净分依他起性故

释曰。转灭一切障杂染分依他起性故者。谓转灭依他起性杂染分。转得解脱一切障于法自在转现前清净分依他起性故者。谓于一切法自在转住故。转得依他起性清净分

论曰。二白法所成为相。谓六波罗蜜多圆满。得十自在故。此中寿自在心自在众具自在。由施波罗蜜多圆满故。业自在生自在。由戒波罗蜜多圆满故。胜解自在。由忍波罗蜜多圆满故。愿自在。由精进波罗蜜多圆满故。神力自在五通所摄。由静虑波罗蜜多圆满故。智自在法自在。由般若波罗蜜多圆满故

释曰。白法所成为相等者。谓由六波罗蜜多圆满故。证得法身十种自在。是彼自性故名所成。寿自在者。应知随欲齐几时住。便能如意现示己身。心自在者。谓生死中能无染污。众具自在者。谓于食等十种众具。随其所欲如意能得。如有颂言

  诸菩萨思惟　　若净若不净
  一切成美妙　　皆由意自在

应知如是三种自在。皆由布施波罗蜜多圆满为因。业自在生自在由戒波罗蜜多圆满故者。谓此能摄彼能生因及所生果故。应知此中业自在者。由身语业自在而转。随所欲生业现前故。生自在者。应知于生自在而转。于诸趣等随其所欲摄受生故。由此道理显修尸罗。于其业因及于生果皆得自在。胜解自在由忍波罗蜜多圆满故者。谓令诸法皆随心转。随逐胜解如所胜解一切事成。如随所欲。转变地等令成金等。转变水等令成火等。以修忍时随诸有情意所乐转故。令获得于一切法皆随心转。愿自在由精进波罗蜜多圆满故者。谓修精进一切所作皆能究竟。故所思事一切皆成。应知在昔修精进时。随所作事皆能究竟。中无懈废。由此为因。今随所愿如意皆成。神力自在五通所摄由静虑波罗蜜多圆满故者。谓由静虑心有堪能。引发种种神通所作。非但由此陵空往来。亦能了知他心等事。由是说言五通所摄。智自在法自在由般若波罗蜜多圆满故者。谓遍了知一切尔炎。名智自在。如其所欲能正安立契经等法。名法自在。又由慧力安立蕴等一切法体。名智自在。此后所得一切种智。名法自在

论曰。三无二为相。谓有无无二为相。由一切法无所有故。空所显相是实有故。有为无为无二为相。由业烦恼非所为故。自在示现有为相故。异性一性无二为相。由一切佛所依无差别故。无量相续现等觉故。此中有二颂

  我执不有故　　于中无别依
  随前能证别　　故施设有异
  种姓异非虚　　圆满无初故
  无垢依无别　　故非一非多

释曰。有无无二为相者。谓一切法遍计所执性相非有故非有相。空所显示圆成实性其体实有故非无相。有为无为无二为相者。是非有为自性。非无为自性义。非业烦恼之所生故。非有为相。于有为中得大自在。数数示现名有为相。由此意趣非无为相。异性一性无二为相者。所依法身无差别故。非是异相。无量依止所证得故。非是一相。俱一无故名无二相。复以伽他显如是义。我执不有故于中无别依者。谓于世间我执力故有别依身。此中我执都无有故无别依身。若所依身无有差别。云何而得许有多佛。随前能证别故施设有异者。由多依身各所证得故有差别。为显此义复说伽他。种姓异故者。谓诸菩萨种姓差别有多种故。非虚故者。种姓异故加行亦异。加行异故资粮圆满亦有多种。由是因缘。若唯一佛余者资粮。应虚无果。圆满故者。诸佛具作一切有情利益等事。谓正安立于三乘等。若执如来不安有情置于佛乘。所作佛事应不圆满。由此道理应许多佛。无初故者。如彼生死流转无初。诸佛亦尔。若唯有一即应有初。是故不一。无垢依无别者。由佛无垢法界为依无差别故。无有多种。故非一非多者。由此道理。显示诸佛非一多相

论曰。四常住为相。谓真如清净相故。本愿所引故。所应作事无竟期故

释曰。由三因缘显常住相。真如清净相故者。清净真如体是常住。显成佛故。应知如来常住为相。本愿所引故者。谓昔发愿常作一切有情利乐。所证佛身此愿所引。由此本愿非空无果。应知如来常住为相。若谓如来所作一切有情利乐已究竟者。此义不然。所应作事无竟期故。以于今时犹有无边所应作事。一切有情未涅槃故。由是因缘应知如来常住为相。如是说已。应知诸佛不可思议。由是因缘不可思议。今当显示

论曰。五不可思议为相。谓真如清净自内证故。无有世间喻能喻故。非诸寻思所行处故

释曰。自内证故者。谓诸如来自内所证。由此真如自内证故。非诸寻思所思议处。于诸世间。亦无与此相似譬喻可喻令知

论曰。复次云何如是法身最初证得。谓缘总相大乘法境无分别智。及后得智五相善修。于一切地善集资粮。金刚喻定。破灭微细难破障故。此定无间。离一切障故得转依

释曰。今次应说法身证得。最初证得者。显此法身非所生起。体无为故。若所生起应是无常。金刚喻定者。此三摩地譬如金刚能破微细难破障故。故得转依者。由金刚喻三摩地故。能证转依逮得法身

论曰。复次法身由几自在而得自在。略由五种。一由佛土自身相好无边音声无见顶相自在。由转色蕴依故。二由无罪无量广大乐住自在。由转受蕴依故。三由辩说一切名身句身文身自在。由转想蕴依故。四由现化变易引摄大众引摄白法自在。由转行蕴依故。五由圆镜平等观察成所作智自在。由转识蕴依故

释曰。今次应显法身自在。由转色等五蕴依故得五自在。此中由转色蕴依故证得示现佛土自在。由此示现金银等宝净妙佛国。亦得示现随其所欲自身自在。由此示现大集会中随诸有情胜解所乐种种色身。又随所乐能现种种相好自在。又现无边音声自在。又现无见顶相自在。由转受蕴依故。得无罪无量广大乐住自在。谓得自在能住无罪无量广大乐住。应知此中由众多故说名无量。普超一切三界乐故。说名广大乐住自在。由转想蕴依故。得于名身句身文身辩说自在。以能取相故名为想。由名身等能取其相。转染想蕴。还得如是清净想蕴。由转行蕴依故。得现化变易引摄大众引摄白法自在。应知此中随其所欲示现所作故名现化。改转地等令成金等故名变易。如意所乐能引天龙药叉等众。应知说名引摄大众。随意所乐引诸白法令现在前。应知说名引摄白法。由转识蕴依故。得大圆镜智平等性智妙观察智成所作智。此中大圆镜智者。谓无忘失法所知境界虽不现前亦能记了。如善习诵书论光明。平等性智者。谓先通达真法界时。得诸有情平等心等。应知此中究竟清净。妙观察智者。谓如藏主如其所欲。随于何等陀罗尼门三摩地门作意思惟。即得自在无碍智转。成所作智者。谓能示现从睹史多天宫而没乃至涅槃。种种佛事皆得自在

论曰。复次法身由几种处。应知依止略由三处。一由种种佛住依止。此中有二颂

  诸佛证得五性喜　　皆由等证自界故
  离喜都由不证此　　故求喜者应等证
  由能无量及事成　　法味义德俱圆满
  得喜最胜无过失　　诸佛见常无尽故

二由种种受用身依止。但为成熟诸菩萨故。三由种种变化身依止。多为成熟声闻等故

释曰。应知法身几法依止。略有三种。广说无量。由种种佛住依止者。谓佛安住圣住天住及与梵住故。言种种法身为此诸住所依。是故说名佛住依止。或谓何用诸佛涅槃。以声闻等与诸如来解脱等故。为显诸佛解脱殊胜说二伽他。诸佛证得五性喜皆由等证自界故者。谓诸如来所得五喜由证法界。离喜都由不证此者。谓声闻等离五种喜。都由不证此真法界。故求喜者应等证者。是故欲求如此喜者。应须于此勤求正证。第二伽他显此五喜。由能无量及事成法味义德俱圆满者。应知此中能无量者依止法身有众多佛成等正觉。一切功能悉皆平等故能无量。由见如是能无量故深生欢喜。及事成者。谓一如来所作利乐诸有情事。即等一切如来所作。由佛多故事亦无量。是故言及。由见此故深生欢喜。由法味者。由见契经应颂等法有胜滋味。深生欢喜。义德俱圆满者。谓义圆满及德圆满。应知此中随所思念所有诸事无不具足。名义圆满。十力无畏不共法等无不具足。名德圆满。得喜最胜无过失者。此喜超过三界喜故。名为最胜。永断烦恼并习气故。名无过失。诸佛见常无尽故者。谓诸如来见次前说四种最胜无过失喜。穷生死际常无有尽。至无余依大涅槃界亦无尽故生殊胜喜。是故世尊证得五喜。非声闻等。由种种受用身依止等者。谓佛法身与受用身为所依止。何故复须如是依止。但为成熟诸菩萨故。由若离此已入大地诸菩萨众应不成熟。由种种变化身依止等者。谓佛法身与变化身为所依止。何故复须如是依止。多为成熟声闻等故。由若离此下劣信解诸声闻等应不成熟。言多为者。应知摄取胜解行地诸菩萨众

论曰。应知法身由几佛法之所摄持。略由六种。一由清净。谓转阿赖耶识得法身故。二由异熟。谓转色根得异熟智故。三由安住。谓转欲行等住。得无量智住故。四由自在。谓转种种摄受业自在。得一切世界无碍神通智自在故。五由言说。谓转一切见闻觉知言说戏论。得令一切有情心喜辩说智自在故。六由拔济。谓转拔济一切灾横过失。得拔济一切有情一切灾横过失智故。应知法身由此所说六种佛法之所摄持

释曰。由是佛法摄持法身。今当显示。由清净者。谓由清净佛法摄持法身。如是法身证得清净由转何法。谓转阿赖耶识得法身故者。谓转灭彼阿赖耶识得法身清净。即法身清净说名清净。由异熟者。谓由异熟佛法摄持法身。转色根者。谓转眼等色根。得异熟智故者。谓转彼故得异熟智。由安住者。谓由安住佛法摄持法身。转欲行等住者。谓转世间欲行等住。得佛法住。得无量智住故者。谓由此故住种种住。由自在者。谓由自在佛法摄持法身。转种种摄受业自在等者。谓转世间殉利务农种种事业自在。得一切世界无碍神通智自在故。由言说者。谓由言说佛法摄持法身。转一切见闻觉知言说戏论等者。谓转世间见闻觉知言说戏论。得于见闻觉知自在。由此证得能令一切有情心喜智自在故。由拔济者。谓由拔济佛法摄持法身转拔济一切灾横过失等者。谓如世间有王家等逼恼事起。由亲友力财宝力等而能拔济。由转此故。证得拔济一切有情一切灾横过失智故。由此智力能除一切灾横过失

论曰。诸佛法身当言有异当言无异。依止意乐业无别故。当言无异。无量依身现等觉故。当言有异。如说佛法身受用身亦尔。意乐及业无差别故。当言无异。不由依止无差别故。无量依止差别转故。应知变化身如受用身说

释曰。无量依止差别转故者。谓受用身无量依止差别而转。是故但由意乐及业无差别故。当言无异。依身事别当言有异。此中意乐无差别者。应知皆为利益安乐一切有情。业无别者。应知皆同现等正觉般涅槃等种种作业

论曰。应知法身几德相应。谓最清净四无量。解脱胜处遍处。无诤愿智。四无碍解。六神通。三十二大士相。八十随好。四一切相清净。十力。四无畏。三不护。三念住。拔除习气。无忘失法。大悲十八不共佛法。一切相妙智等功德相应。此中有多颂

  怜愍诸有情　　起和合远离
  常不舍利乐　　四意乐归礼
  解脱一切障　　牟尼胜世间
  智周遍所知　　心解脱归礼
  能灭诸有情　　一切惑无余
  害烦恼有染　　常哀愍归礼
  无功用无著　　无碍常寂定
  于一切问难　　能解释归礼
  于所依能依　　所说言及智
  能说无碍慧　　常善说归礼
  为彼诸有情　　故现知言行
  往来及出离　　善教者归礼
  诸众生见尊　　皆审知善士
  暂见便深信　　开导者归礼
  摄受住持舍　　现化及变易
  等持智自在　　随证得归礼
  方便归依净　　及大乘出离
  于此诸众生　　摧魔者归礼
  能说智及断　　出离能障碍
  自他利非余　　外道伏归礼
  处众能伏说　　远离二杂染
  无护无忘失　　摄御众归礼
  遍一切行住　　无非圆智事
  一切时遍知　　实义者归礼
  诸有情利乐　　所作不过时
  所作常无虚　　无忘失归礼
  昼夜常六返　　观一切世间
  与大悲相应　　利乐意归礼
  由行及由证　　由智及由业
  于一切二乘　　最胜者归礼
  由三身至得　　具相大菩提
  一切处他疑　　皆能断归礼

诸佛法身与如是等功德相应。复与所余自性因果业相应。转功德相应。是故应知诸佛法身无上功德。此中有二颂

  尊成实胜义　　一切地皆出
  至诸众生上　　解脱诸有情
  无尽无等德　　相应现世间
  及众会可见　　非见人天等

释曰。诸佛法身与此所说四无量等功德相应。复与其余自性因果业相应。转功德相应。尊成实胜义者。此显诸佛法身自性。诸佛皆以成实胜义清净真如为自性故。一切地皆出者。此显其因。修一切地得成佛故。至诸众生上者。此显其果。诸有情中此最上故。解脱诸有情者。此显其业。以能无倒令诸有情得解脱故。无尽无等德相应者。此显相应。与其无尽无等功德共相应故。现世间可见者。此说变化身。及众会可见者。此说受用身。非见人天等者。此说自性身。诸人天等皆不能见。此显佛身三种差别。说名为转

摄大乘论释卷第九摄大乘论释卷第十

        世亲菩萨造

        三藏法师玄奘奉　诏译

    彼果智分第十一之余

论曰。复次诸佛法身甚深最甚深。此甚深相云何可见。此中有多颂

释曰。于大乘中诸佛法身如甚深相。今当显示。以十二颂。显示十二甚深之相

论曰

  佛无生为生　　亦无住为住
  诸事无功用　　第四食为食

释曰。此中一颂显示生住业住甚深。佛无生为生者。显生甚深。以诸如来无业烦恼同诸凡愚所造作生故名无生。然有与此相违之生。其相难了名生甚深。亦无住为住者。显住甚深。无住涅槃以为住处。如是涅槃名住甚深。诸事无功用者。显业甚深。以诸如来无功用业。一切等故名业甚深。第四食为食者。显住甚深。以佛所食是不清净依止住等。四种食中第四食故。四种食者。一不清净依止住食。谓段等四食。令欲缠有情不净依止而得住故。二净不净依止住食。谓触等三食。令色无色缠有情。净不净依止而得住故。由此依止。已离下地诸烦恼故说名为净。未离上地诸烦恼故。说名不净是故名净不净依止。如是依止由触意思识食而住除其段食。三一向净依止住食。谓段等四食令声闻等清净依止而得住故。四唯示现依止住食。谓即四食诸佛示现受之得住。是故诸佛食。此第四示现住食。为令能施诸有情类净信为因福德增长。虽现受食不作食事。如来食时诸天受取。施佛意许诸余有情。由此因故。彼有情类速证菩提。如是一切。应知总说为一甚深。又由十因。应知诸佛生无生相。一与愚痴不同法故。二与差别不同法故。三于摄受得自在故。四于住持得自在故。五于弃舍得自在故。六无二相故。七唯似光影故。八同幻化故。九住无住故。十成大事故。复由十因。应知如来不住生死及以涅槃。一非遍知故。二非永断故。三非修习故。四知非有性故。五无所得无分别故。六远离心故。七心证得故。八平等心故。九事不可得故。十可证得故。复由十因。应知诸佛无功用事而得成立。一妙断离故。二无所依故。三所作无功用故。四作者无功用故。五作业无功用故。六无所有无功用故。七本来无差别故。八所作已办故。九所作未办故。十纯熟修习一切法中得自在故。复由十因。应知诸佛实无所食而现受食。一示现以食住持身故。二令诸有情福增长故。三为欲示现有同法故。四为令随学正受用故。五为令随学廉俭行故。六为令发起精进行故。七为令成熟诸善根故。八为显自身无染着故。九为恭敬业助任持故。十为欲圆满本愿生故

论曰

  无异亦无量　　无数量一业
  不坚业坚业　　诸佛具三身

释曰。此颂显示安立数业甚深。无异亦无量者。显安立甚深。诸佛法身无差别故说名无异。无量依止现等觉故说名无量。无数量一业者。显数甚深。佛虽无量而同一业。是故甚深。不坚业坚业诸佛具三身者。谓诸如来三身相应。其受用身事业坚住。其变化身业不坚住。如是事业名为甚深

论曰

  现等觉非有　　一切觉非无
  一一念无量　　有非有所显

释曰。此颂显示现等觉甚深。现等觉非有者。补特伽罗法非有故。一切觉非无者。由假名理说一切佛现等觉故。云何知佛现等正觉。谓一一念无量佛故。此即显示一一念中有无量佛现等正觉。有非有所显者。此显真如是有非有。诸佛是此真如所显

论曰

  非染非离染　　由欲得出离
  了知欲无欲　　悟入欲法性

释曰。此颂显示离欲甚深。非染非离染者。贪欲无故说名非染。以无染故离染亦无。所以者何。贪染若有可有离染。染既是无故无离染。由欲得出离者。由伏断贪缠留贪随眠故。得究竟出离。若不留随眠。应同声闻等入般涅槃故。了知欲无欲悟入欲法性者。了知遍计所执贪欲无贪欲性。即能悟入欲法真如

论曰

  诸佛过诸蕴　　安住诸蕴中
  与彼非一异　　不舍而善寂

释曰。此颂显示断蕴甚深诸佛过诸蕴。安住诸蕴中者。谓诸如来超过色等五种取蕴。住无所得法性蕴中。与彼非一异者。虽已舍遍计所执诸蕴。而与彼非异。以即安住彼法性故。亦复不一。若是一者。遍计所执应同法性成清净境。不舍而善寂者。谓不弃舍圆成实蕴。即是妙善涅槃体故

论曰

  诸佛事相杂　　犹如大海水
  我已现当作　　他利无是思

释曰。此颂显示成熟甚深。诸佛事相杂者。谓诸如来成熟有情一切事业。悉皆平等。其喻云何。犹如大海水者。譬如大海众流所入其水相杂。为鱼鳖等同所受用。诸佛亦尔。同入法界所作事业和合无二。等为成熟有情受用。我已现当作者。于三时中随一时作。他利无是思者。不作是思。我于他利已现当作。然无功用能作一切利益安乐诸有情事。譬如世间末尼天乐

论曰

  众生罪不现　　如月于破器
  遍满诸世间　　由法光如日

释曰。此颂显示显现甚深。若诸世间不见诸佛。而说诸佛其身常住。佛身既常何故不见。众生罪不现如月于破器者。如破器中水不得住。水不住故月则不现如是。有情身中无有奢摩他水。佛月不现。水喻等持。体清润故遍满诸世间。由法光如日者。谓今世间佛虽不现。然遍一切施作佛事。由说契经应颂等法。譬如日光遍满世间。作诸佛事成熟有情

论曰

  或现等正觉　　或涅槃如火
  此未曾非有　　诸佛身常故

释曰。此颂显示示现等觉涅槃甚深。或现等正觉或涅槃如火者。谓诸如来或现成佛或现涅槃。其事如火或时烧然或时息灭。诸佛亦尔。或于未熟诸有情类。现般涅槃。或于已熟诸有情类现成佛果。为欲令彼得解脱故。譬如一火性无差别。法身亦尔。应知唯一。余半颂文其义易了

论曰

  佛于非圣法　　人趣及恶趣
  非梵行法中　　最胜自体住

释曰。此颂显示住甚深。佛于非圣法中。人趣恶趣中。非梵行法中。由最胜自体住。最胜住由圣住等而安住故。此中圣住者。谓空等住。天住者。谓诸静虑住。梵住者。谓慈等无量住。非圣法者。谓不善法。佛于其中住空等住。由此空等圣所住故。名为圣住。人趣及恶趣者。谓缘彼有情住。诸静虑所住静虑名为天住。非梵行法者。谓于彼法住慈悲等四种梵住。最胜自体住者。谓由如是最胜自体住最胜住。此显诸佛于诸住中安住最胜自体诸住

论曰

  佛一切处行　　亦不行一处
  于一切身现　　非六根所行

释曰。此颂显示自体甚深。佛一切处行亦不行一处者。谓后得智于善不善无记等中分别而转。无分别智不行一处。第二义者谓变化身一切处行。其余二身不行一处。于一切身现者。即变化身遍于一切处处可见。非六根所行者。即变化身。为欲化彼那落迦等。现于彼生。那落迦等受生有情见化身时。不如实见。不能了知。但谓即是那落迦等。是故化身决定非彼那落迦等六根所行

论曰

  烦恼伏不灭　　如毒咒所害
  留惑至惑尽　　证佛一切智

释曰。此颂显示断烦恼甚深。烦恼伏不灭如毒咒所害者。菩萨位中伏烦恼缠。未灭烦恼。有随眠故。譬如众毒咒力所害。体虽犹在而不为害。烦恼亦尔。智了知故。体虽犹在而不为害。留惑至惑尽者。以留随眠诸烦恼故。不如声闻速般涅槃得至究竟诸烦恼尽。证佛一切智者。烦恼尽时得一切智

论曰

  烦恼成觉分　　生死为涅槃
  具大方便故　　诸佛不思议

释曰。此颂显示不可思议甚深。谓诸菩萨具大方便。烦恼集谛转成觉分。生死苦谛即为涅槃。如是一切诸佛圣教。如前所说。三因缘故。不可思议。谓自内证故等

论曰。应知如是所说甚深有十二种。谓生住业住甚深。安立数业甚深。现等觉甚深。离欲甚深。断蕴甚深。成熟甚深。显现甚深。示现等觉涅槃甚深。住甚深。显示自体甚深。断烦恼甚深。不可思议甚深

释曰。此十二种皆难觉了故名甚深。一一别相如前已说

论曰。若诸菩萨念佛法身。由几种念应修此念。略说菩萨念佛法身。由七种念应修此念。一者诸佛于一切法。得自在转。应修此念。于一切世界得无碍通故。此中有颂

  有情界周遍　　具障而阙因
  二种决定转　　诸佛无自在

二者如来其身常住。应修此念。真如无间解脱垢故。三者如来最胜无罪。应修此念。一切烦恼及所知障并离系故。四者如来无有功用应修此念。不作功用一切佛事无休息故。五者如来受大富乐。应修此念。清净佛土大富乐故。六者如来离诸染污。应修此念。生在世间一切世法不能染故。七者如来能成大事。应修此念。示现等觉般涅槃等。一切有情未成熟者能令成熟。已成熟者令解脱故。此中有二颂

  圆满属自心　　具常住清净
  无功用能施　　有情大法乐
  遍行无依止　　平等利多生
  一切佛智者　　应修一切念

释曰。今当显示若诸菩萨念佛法身由七种念应修其念。于一切法得自在转者。由得神通于一切法自在而转。以诸如来于一切世界得无碍神通。非如声闻等犹有障碍故。若诸如来于一切法自在而转。何故一切有情之类不得涅槃。故今一颂显由此因诸有情类不能证得究竟涅槃。有情界周遍具障而阙因者。谓诸有情有业等障名为具障。由具障故虽无量佛出现于世。不能令彼得般涅槃。诸佛于彼无有自在。若诸有情无涅槃法名为阙因。此意说彼无涅槃因。无种性故。诸佛于彼无有自在。二种决定转者。决定有二种。一作业决定。二受异熟决定。当知此中说名决定。诸佛于此二决定中无有自在。顽愚等身名异熟障决定。当堕那落迦等名受异熟决定。应知此中二种差别如来身常住。真如无间解脱垢故者。谓真如理无间。解脱一切障垢。显成法身。是故如来其身常住。如来受大富乐者。应知如来清净佛土名大富乐。如来能成大事者。谓诸如来现等正觉般涅槃等。成大义利。已成熟者令得解脱。未成熟者令其成熟。余修念佛其义易了。复以二颂显释如是七种念佛。于此颂中宣说诸佛七种圆满。令修念佛。谓诸菩萨初念如来随属自心圆满。次念如来其身常住圆满。次念如来具足清善圆满。即是最胜无罪。次念如来无功用圆满。谓作佛事无功用故。次念如来。施大法乐圆满。应知即于清净佛土受大法乐。次念如来离诸染污圆满。即是遍行无所依止。若有所依而遍行者。即有苦难。由无所依而遍行故。佛常无苦离染遍行。后念如来平等多利圆满。即是念佛能成大事。成熟解脱诸有情故

论曰。复次诸佛清净佛土相云何。应知如菩萨藏百千契经序品中说。谓薄伽梵住最胜光曜。七宝庄严放大光明。普照一切无边世界。无量方所妙饰间列。周圆无际其量难测。超过三界所行之处。胜出世间善根所起。最极自在净识为相。如来所都。诸大菩萨众所云集。无量天龙药叉健达缚阿素洛揭路荼紧捺洛莫呼洛伽人非人等常所翼从。广大法味喜乐所持。作诸众生一切义利。蠲除一切烦恼灾横。远离众魔。过诸庄严。如来庄严之所依处。大念慧行以为游路。大止妙观以为所乘。大空无相无愿解脱为所入门。无量功德众所庄严。大宝花王之所建立大宫殿中。如是现示清净佛土。显色圆满形色圆满。分量圆满方所圆满。因圆满果圆满。主圆满辅翼圆满眷属圆满。任持圆满事业圆满。摄益圆满无畏圆满。住处圆满路圆满。乘圆满门圆满。依持圆满

复次受用如是清净佛土。一向净妙一向安乐一向无罪一向自在

释曰。如菩萨藏百千颂经序品中说清净佛土。此净佛土显示何等殊胜功德。谓初二句显净佛土显色圆满。言七宝者。一金二银三琉璃四牟娑洛宝。五遏湿摩揭婆宝。举此应知即举末啰羯多等宝。六赤真珠宝。此赤真珠赤虫中出。一切宝中最为殊胜。七羯鸡怛诺迦宝。放大光明普照一切无边世界者。谓次前说七宝所放诸大光明。此上二句皆同显示显色圆满。次有一句显形色圆满。次有一句显分量圆满。次有一句显方所圆满。次有一句显因圆满。此何所因。谓出世间无分别智及后得智。此后得智说名为胜。此后得故从此二种善根所起。即此善根名因圆满。次有一句显果圆满。谓净佛土以极自在净识为相。次有一句显主圆满。次有一句显辅翼圆满。次有一句显眷属圆满。前已举龙今此复举莫呼洛伽为摄大蟒。次有一句显任持圆满。即是饮食。次有一句显事业圆满。谓食此食已办诸众生一切义利。次有一句显摄益圆满。于净土中离诸烦恼。无诸苦故。次有一句显无畏圆满。若处无怨即无怖畏。怨谓四魔。此净土中诸烦恼魔蕴魔死魔及以天魔悉皆无有。是故无畏。次有一句显住处圆满。次有一句显路圆满。此净佛土由何路入。谓大乘中闻思修慧。如其次第大念慧行为游入路。次有一句显乘圆满。乘奢摩他毗钵舍那而游趣故。次有一句显门圆满。谓此净土由何门入。谓大乘中大空无相无愿解脱为所入门。次有一句显依持圆满。如大地等依风轮住。此净佛土何所依持。无量功德众所庄严。大红莲华之所建立。受用如是清净佛土一向清净妙者。谓净土中无有不净粪秽等事。一向安乐者。谓净土中唯有乐受。无有苦受无无记受。一向无罪者。谓净土中无有不善亦无无记一向自在者。谓净土中不待外缘。一切所欲随自心故

论曰。复次应知。如是诸佛法界。于一切时能作五业。一者救济一切有情灾横为业。于暂见时便能救济盲聋狂等诸灾横故。二者救济恶趣为业。拔诸有情出不善处置善处故。三者救济非方便为业。令诸外道舍非方便求解脱行。置于如来圣教中故。四者救济萨迦耶为业。授与能超三界道故。五者救济乘为业。拯拔欲趣余乘菩萨。及不定种性诸声闻等。安处令修大乘行故。于此五业应知诸佛业用平等。此中有颂

  因依事性行　　别故许业异
  世间此力别　　无故非导师

释曰。应知如是诸佛法界于一切时能作五业者。谓佛法身恒作五业。救济一切有情灾横为业等者。谓盲聋等暂见佛时便得眼等。救济恶趣为业等者谓拔恶处置于善处。名救恶趣。救济萨迦耶为业等者。谓为世间说能超出三界圣道。即说三界为萨迦耶。所余二句其义可知。于此五业应知诸佛诸业平等。于此义中复说一颂。谓因依等。由是因缘一切如来诸业平等。一切世间业不平等。以一伽他总略显示世间因别。故许业异者。谓诸世间由别因故生那落迦别因生天。别因生人乃至饿鬼。由因别故许业有异。世间依别故许业异者。依谓身体。由依别故许业有异。世间事别故许业异者。谓诸世间商贾事别。营农事别。此等事务有差别故许业有异。世间性别故许业异者。性谓意趣。意趣别故许业有异。世间行别故许业异者。由作行业有差别故许业有异。诸佛作业皆无功用。一切因等差别力无。是故导师非有业异

论曰。若此功德圆满相应。诸佛法身不与声闻独觉乘共。以何意趣佛说一乘。此中有二颂

  为引摄一类　　及任持所余
  由不定种性　　诸佛说一乘
  法无我解脱　　等故性不同
  得二意乐化　　究竟说一乘

释曰。此中二颂辩诸佛说一乘意趣。为引摄一类谓为者。引摄不定种性诸声闻等令趣大乘。云何当令不定种性诸声闻等。皆由大乘而般涅槃。及任持。所余者。谓为任持不定种性诸菩萨众令住大乘。云何当令不定种性诸菩萨众不舍大乘。勿声闻乘而般涅槃。为此义故佛说一乘。由不定等句义已说法无我解脱。乃至广说。此中复由别意趣力唯说一乘。何别意趣。谓法等故等。法等故者。法谓真如。诸声闻等同所归趣。所趣平等故说一乘。无我等故者。谓声闻等补特伽罗。我皆无有。由无我故。此是声闻。此是菩萨不应道理。由此无我平等意趣故说一乘。解脱等故者。谓声闻等。于烦恼障同得解脱故说一乘。如世尊言。解脱解脱无有差别。性不同故者。种性差别故。以不定性诸声闻等亦当成佛。由此意趣故说一乘。得二意乐故者。得二种意乐故。一摄取平等意乐。由此摄取一切有情。言彼即是我我即是彼。如是取已。自既成佛彼亦成佛。由此意趣故说一乘。二法性平等意乐。谓诸声闻法华会上蒙佛授记。得佛法性平等意乐。未得法身。由得如是平等意乐。作是思惟。诸佛法性即我法性。复有别义。谓彼众中有诸菩萨。与彼名同蒙佛授记。由此法如平等意乐故说一乘。言化故者。谓佛化作声闻乘等。如世尊言。我忆往昔无量百返依声闻乘而般涅槃。由此意趣故说一乘。以声闻乘所化有情由见此故。得般涅槃。故现此化究竟故者。唯此一乘最为究竟。过此更无余胜乘故。声闻乘等有余胜乘。所谓佛乘。由此意趣。诸佛世尊宣说一乘

论曰。如是诸佛同一法身而佛有多。何缘可见。此中有颂

  一界中无二　　同时无量圆
  次第转非理　　故成有多佛

释曰。今当显示。由此因缘。应知诸佛虽同法身。而或成一或复成多。应知一者法界同故。诸佛皆同法界为体。法界一故应知一佛。又一佛者。以于一时一世界中。无二佛现故知一佛。又伽他中显示诸佛或一或多。一界中无二者。此句显示唯有一佛。一世界中无有二佛俱时出现。是故说言唯有一佛。余句显示诸佛有多。同时无量圆者。无量菩萨同一时中资粮圆满。若诸菩萨福智资粮同时圆满不得成佛。如是资粮应空无果。众多菩萨修集资粮同时圆满。是故应知一时多佛。次第转非理者。无有次第转成佛义。若诸菩萨修资粮时。观待次第前后成满。可得佛时前后次第。然诸菩萨修资粮时。不待次第前后成满。故得佛时亦无次第前后成义。是故同时有众多佛

论曰。云何应知于法身中。佛非毕竟入于涅槃。亦非毕竟不入涅槃。此中有颂

  一切障脱故　　所作无竟故
  佛毕竟涅槃　　毕竟不涅槃

释曰。有余部说诸佛无有毕竟涅槃。复有别部声闻乘人说诸佛有毕竟涅槃故。此颂中显二意趣。一切障脱故者。由佛解脱一切烦恼所知障故。依此意趣说言诸佛毕竟涅槃。所作无竟故者。由佛普于一切有情。未成熟者欲令成熟。已成熟者欲令解脱。是所应作。此事无有究竟之期。故佛毕竟不入涅槃。若异此者应如声闻毕竟涅槃。是则本愿应空无果

论曰。何故受用身非即自性身。由六因故。一色身可见故。二无量佛众会差别可见故。三随胜解见自性不定可见故四别别而见自性变动可见故。五菩萨声闻及诸天等种种众会间杂可见故。六阿赖耶识与诸转识转依。非理可见故。佛受用身即自性身。不应道理

释曰。今当显示佛受用身即自性身不应正理。色身可见故者。佛受用身色身可见。非佛法身。由此非理故受用身非即法身。又受用身有佛众会差别可得。法身无有如是差别。由此非理故受用身非自性身。又受用身随胜解见。如契经说。或见佛身。唯有黄色。或见佛身唯有青色。如是广说。若受用身即自性身。此自性身应不决定体。不决定名自性身不应正理。由此非理故受用身非自性身。又受用身一类有情先见别异。即此后时复见别异。非佛法身自性变动。由此非理故受用身非自性身。又受用身有诸天等种种众会常相间杂。非自性身有此间杂。由此非理故受用身非自性身。又转阿赖耶识得自性身。若受用身即自性身。转诸转识复得何身。由此非理故受用身非自性身。由此六因不应理故二不成一

论曰。何因变化身非即自性身。由八因故。谓诸菩萨从久远来得不退定。于睹史多及人中生不应道理。又诸菩萨从久远来常忆宿住。书算数印工巧论中。及于受用欲尘行中不能正知不应道理。又诸菩萨从久远来。已知恶说善说法教。往外道所不应道理。又诸菩萨从久远来。已能善知三乘正道。修邪苦行不应道理。又诸菩萨舍百拘胝诸赡部洲。但于一处成等正觉转正法轮不应道理。若离示现成等正觉。唯以化身于所余处施作佛事。即应但于睹史多天成等正觉。何不施设。遍于一切赡部洲中。同时佛出既不施设。无教无理。虽有多化而不违彼无二如来出现世言。由一四洲摄世界故。如二轮王不同出世。此中有颂

  佛微细化身　　多处胎平等
  为显一切种　　成等觉而转

为欲利乐一切有情。发愿修行证大菩提。毕竟涅槃不应道理。愿行无果成过失故

释曰。今当显示佛变化身即自性身不应正理。由八因故。此中最初不应理者。谓诸菩萨从久远来。已无量劫得不退定。尚不应生睹史多天。况于人中。然此世间现受生者。是变化身非自性身。又诸菩萨从久远来常忆宿住。于书算等不能正知不应道理。但为调伏诸有情故化为此事。又诸菩萨三无数劫勤修福慧。不能正知恶说善说邪苦行事。于最后身证菩提时何能顿悟由此道理是变化身非自性身。又诸菩萨舍百拘胝诸赡部洲。但于一处成等正觉转正法轮不应道理。若变化身遍一切处同时现化应正道理。故变化身非自性身。若诸异部作如是执。佛唯一处真证等觉。余方现化施作佛事。若尔何故不许但住睹史多天真证等觉。遍于一切四大洲渚。示现化身施作佛事。又于一切四大洲中不现等觉。无教无理故不应说。此佛土中有四洲渚不现成佛。若有说言纵有是事。便违契经故。经中说无二如来俱时出现。应知此经同转轮王。如说轮王无二并出。依一四洲非一佛土。无二如来俱时出现当知亦尔。此中意说一四大洲名一世界。今复以颂显示诸佛化现等觉。佛微细化身等者。此中义说。若于尔时佛现安住睹史多天。示从彼没入母胎等。即于彼时化作尊者舍利子等无量眷属。亦现入胎出生等事。安立如是变化眷属。当知为显一切种觉殊胜佛事。今当显示如来毕竟入般涅槃不应道理。谓为化度一切有情。先发大愿及修大行。常自誓言。我当利乐一切有情勤修正行。若始成佛已便般涅槃。即所修愿行空无有果。由此非理是变化身非自性身

论曰。佛受用身及变化身既是无常。云何经说如来身常。此二所依法身常故。又等流身及变化身。以恒受用无休废故。数数现化不永绝故。如常受乐。如常施食。如来身常应知亦尔

释曰。经说如来其身常住。佛受用身及变化身皆是无常。云何身常。故次成立二身常义。谓此二身依法身住。法身常故亦说为常。又受用身。受用无废故说为常。其变化身恒现等觉般涅槃等。相续不断故亦名常。复以譬喻显此二身是常住义。犹如世间言常受乐。虽所受乐非唯无间。而得说言此常受乐。又如世间言常施食。非此施食恒无间断。而得说言此常施食。应知二身常义亦尔

论曰。由六因故。诸佛世尊所现化身非毕竟住。一所作究竟。成熟有情已解脱故。二为令舍离不乐涅槃。为求如来常住身故。三为令舍离轻毁诸佛。令悟甚深正法教故。四为令于佛深生渴仰。恐数见者生厌怠故。五令于自身发勤精进。知正说者难可得故。六为诸有情极速成熟。令自精进不舍轭故。此中有二颂

  由所作究竟　　舍不乐涅槃
  离轻毁诸佛　　深生于渴仰
  内自发正勤　　为极速成熟
  故许佛化身　　而非毕竟住

释曰。如是六因直说及颂。证佛化身非毕竟住。其文易了故不烦释

论曰。诸佛法身无始时来无别无量。不应为得更作功用。此中有颂

  佛得无别无量因　　有情若舍勤功用
  证得恒时不成因　　断如是因不应理

释曰。此中有难。若佛法身无始时来无别无量作证得因。能办有情诸利乐事。为证佛果不应更作正勤功用。为释此难以颂显示。诸佛证得无始时来无别无量。若是有情为求佛果舍精进因。可有此难。诸佛证得于得佛果无始时来不成因故。然佛证得无始时来无别无量。恒与有情作得佛果勤精进因。故不应难。诸佛法身无始时来无别无量作证得因。为证佛果不应更作正勤功用。是故诸佛证得法身。非是有情为求佛果舍精进因。又佛证得无始时来无别无量。作求佛果勤精进因。若诸有情舍勤功用。如是证得恒不成因故。又断此因不应道理。谓诸菩萨悲愿缠心。于诸有情愍如一子。诸有情类处大牢狱具受艰辛。是故菩萨于诸有情利益安乐。若作是心。余既能作。我当不作。不应道理。恒作是心。余于此事若作不作。我定当作。是故不应断如是因

论曰。阿毗达磨大乘经中摄大乘品。我阿僧伽略释究竟

释曰。正趣大乘制造无量殊胜。论者轨范世亲略释究竟

摄大乘论释卷第十


摄大乘论释b

    No. 1598 [cf. Nos. 1592-1594, 1595-1597]

摄大乘论释卷第一

        无性菩萨造

        三藏法师玄奘奉　诏译

    总标纲要分第一

  稽首大觉诸如来　　无上正法真圣众
  为利自他法久住　　故我略释摄大乘

论曰。阿毗达磨大乘经中。薄伽梵前已能善入大乘菩萨。为显大乘体大故说

释曰。欲以十义总摄大乘所有要义。彼义能显此论体性。是圣教故。用此为门。而开发言。阿毗达磨大乘经等。择法因故。或共了故阿毗达磨。想为幖帜。大乘经言。简别余处。若略释者。亦乘亦大故名大乘。或乘大性故名大乘。因果大故。业具运故。果谓十地。若广释者。七种大性共相应故。谓菩提分波罗蜜多。学持相等。贯穿缝缀故名为经。此中即是随堕八时。闻者识上直非直说。聚集显现以为体性。若尔云何菩萨能说非闻者识。彼能说故。彼增上生故作是说。譬如天等增上力故。令于梦中得论咒等。若离识者。佛云何说诸契经句。语为自性。且不应理。由一一字能诠显义。不应理故。次第而生不俱时住。无聚集故。如是不得彼之自性。语无有转故不应理。又非无字转有少名能诠。故诸契经名为自性。亦不应理。是故决定如所说经。自性应理。于此所说阿毗达磨大乘经中。薄伽梵者。破诸魔故。能破四种大魔怨故。名薄伽梵。四种魔者。一者烦恼魔。二者蕴魔。三者天魔。四者死魔。依空三摩地。能破烦恼魔一切粗重。转依相住。无量善根随顺证得。或复依止精进慧力。能破蕴魔。依慈等持能破天魔。依修神足能破死魔。能破如是四大魔故。名薄伽梵。又自在等功德相应。是故说佛名薄伽梵。所以者何。以当宣说佛世尊故。于彼前者。显佛开许。堪广流通。亲对大师无异言故。如十地经。已能善入大乘者。或依德迹。或共了知。谓彼已能善入大乘。或即于此已极善入。故名已能善入大乘显此已得诸陀罗尼辩才功德。于大乘义能持能阐。故依此义说如是名。言菩萨者。菩提萨埵为所缘境故名菩萨。依弘誓语立菩萨声。亦见余处用所缘境。而说其名。如不净等为所缘境。二三摩地。说名不净。说名为空。或即彼心。为求菩提有志有能。故名菩萨。为显大乘体大故者。甚深高广无上故大。体声即说自性作用。如世说言。火暖为体。毒害为体。此体大故说名体大。显者。开示他所未了。为者。欲也

论曰。谓依大乘诸佛世尊。有十相殊胜殊胜语。一者所知依殊胜殊胜语。二者所知相殊胜殊胜语。三者入所知相殊胜殊胜语。四者彼入因果殊胜殊胜语。五者彼因果修差别殊胜殊胜语。六者即于如是修差别中增上戒殊胜殊胜语。七者即于此中增上心殊胜殊胜语。八者即于此中增上慧殊胜殊胜语。九者彼果断殊胜殊胜语。十者彼果智殊胜殊胜语。由此所说。诸佛世尊契经诸句。显于大乘真是佛语

释曰。谓声即是略摽所说十胜处义。依大乘者。所为所说非声闻乘。亦非世间。复举大乘为决定义。显所依者。即此非余。以依世间由余相故。异于佛语。如有颂言。谛语而无忿。少施不悕求。如是等。若依声闻。由余相故异于大乘。如有颂言。诸行无常。有生灭法。如是等。是故重举大乘应理。有十等者。以数显数殊胜佛语。安立论体。相者。种也。即此展转差别无杂。故名殊胜。或复望彼声闻等法。极悬远故。又增上故。名为殊胜。以能引发大菩提故。由此十相是殊胜故。彼语殊胜。是故说言。有十相殊胜殊胜语。佛世尊者。染污不染污。二痴睡尽故。于一切所知智。开发义故。说名为佛。如士夫寤。如莲华开。如有说言。寤寤开发义。有时业佛界。如是等

论曰。复次云何能显由此所说十处。于声闻乘曾不见说。唯大乘中处处见说。谓阿赖耶识说名所知依体。三种自性。一依他起自性。二遍计所执自性。三圆成实自性。说名所知相体。唯识性说名入所知相体。六波罗蜜多说名彼入因果体。菩萨十地说名彼因果修差别体。菩萨律仪说名此中增上戒体。首楞伽摩虚空藏等诸三摩地。说名此中增上心体。无分别智说名此中增上慧体。无住涅槃说名彼果断体。三种佛身。一自性身。二受用身。三变化身。说名彼果智体。由此所说十处。显于大乘异声闻乘。又显最胜。世尊但为菩萨宣说。是故应知但依大乘。诸佛世尊有十相殊胜殊胜语

释曰。所应可知故名所知。依谓所依。此所依声简取能依。杂染清净诸有为法。不取无为。由彼无有所依义故。所依即是阿赖耶识。是彼因故。能引彼故。如其所应。若尔所知即所知依。由异熟识是所知性故不相违。此所知依即是殊胜。此殊胜故语亦殊胜。即前所说诸佛世尊。言一切处随转。所知相者。所知自性。是所相故。依业运说多置鲁荼所知所断所证等故。或依具运。以遍计所执。相无所相。表无性故。圆成实性是其共相。依他起性是其自相。我有情义识展转别异故。如地界等。以其坚等为能表相。虽无异性而说为相。又如宣说大士夫相。经部等师。生等诸相。由此因缘。或所知即相。或所知之相故名所知相。说无异性故。异无异性故。如其所应此亦如是。入所知相者。谓此能入所应知相。或是所知相之能入。入谓现观入所知相。即唯识性。此即殊胜。此殊胜故语亦殊胜。彼入因果者。谓唯识性。说名彼入胜解行地。修加行时。世间未净波罗蜜多名彼入因。已证入时。即出世间波罗蜜多。清净增上意乐摄故。名彼入果。彼入因果即是殊胜。此殊胜故语亦殊胜。彼因果修差别者。谓即唯识性之因果。数习此故说名为修。分分不同故名差别。彼入因果修差别性。即是十地。此即殊胜。此殊胜故语亦殊胜。即于诸地波罗蜜多修差别中。为摄取后复勤修学。即此为依。安立三学。一增上戒学。谓依止戒正勤修学。是故说名增上戒学。即诸地中菩萨律仪。远离诸恶。饶益有情。摄一切善。三种净戒。所受尸罗。防护过去已生住等身等诸业。如调御者极善调摄。故名律仪。如是即依增上尸罗。修学正行故名为学。此增上戒即是殊胜。此殊胜故语亦殊胜。二增上心学。谓依止心正勤修学。是故说名增上心学。此性即是虚空藏等诸三摩地。等者等取余贤护等三摩地王。又于增上心学中言

  即诸三摩地　　大师说为心
  由心彩画故　　如所作事业

三增上慧学。谓依止慧正勤修学。是故说名增上慧学。此性即是无分别智。对治一切戏论分别。此中加行无分别智根本依止。即此根本无分别智后得依止。如是依止。非次所说。如是三种戒定慧学是道体性。彼果二种。一断二智。此殊胜故语亦殊胜。彼果断者。彼诸学果名为彼果。彼果即断名彼果断。此性即是客障离系。真如解脱无住涅槃。见彼寂静故生死即涅槃。即彼为缘而无染着。非无余依般涅槃界。是故无住此即殊胜。此殊胜故语亦殊胜。彼果智者彼诸学果名为彼果。彼果即智名彼果智。此性即是三种佛身。一自性身。即是无垢无挂碍智。是法身义。今此与彼无分别智有何差别。如是二种所有分别俱不行故。彼有对治当有所作。此是彼果所作已办。如是差别。二受用身。即后得智。即由此智殊胜力故。与诸殊胜大菩萨众共。受不共微妙法乐。成办如是受用事故名受用身。若无如是外清净智。菩萨所作所余资粮应不圆满。三变化身。即是后得智之差别。即能变化名变化身。此增上力之所显现即智差别。谓由此故摧伏他论。与诸菩萨共受法乐。无有断绝。成办初业诸菩萨众。诸声闻等所应作事。譬如眼识了受诸色彼若无者此亦应无。此则殊胜。此殊胜故语亦殊胜。由此所说十处者。谓于此及余总大乘义。处是事义。异声闻乘者。于彼不说故。又显最胜者。究竟宣说佛果道故。世尊但为菩萨宣说者。此中应言菩萨。但为菩萨宣说。由佛现见佛所开许而宣说故。名世尊说。如十地等。是故先说薄伽梵前

论曰。复次云何由此十相殊胜。殊胜如来语故显于大乘。真是佛语遮声闻乘。是大乘性。由此十处。于声闻乘曾不见说。唯大乘中处处见说。谓此十处是最能引大菩提性。是善成立随顺无违。为能证得一切智智。此中二颂

  所知依及所知相　　彼入因果彼修异
  三学彼果断及智　　最上乘摄是殊胜
  此说此余见不见　　由此最胜菩提因
  故许大乘真佛语　　由说十处故殊胜

释曰。复次云何由此等者。犹未信解故设此难何以故。非于声闻乘中六句义等曾未见说。吠世师等论中处处见说。即令吠世师等论真是佛语。先答容他如是妨难。故后通言。谓此十处是最能引大菩提性等。亦觉亦大故名大菩提。或觉大性故名大菩提。此大菩提智断殊胜以为自相。如说烦恼所知障断。由彼断故获得无垢无挂碍智。如是四种总名菩提。是最能引者。谓此十处是能得性。非六句义。或最胜等。是故彼论非真佛语。是善成立者。谓如是十处正量所随故。如广当决择。言随顺者。是能对向是能顺义言无违者。无彼过故。非如六句义等邪智。或声闻乘有过失故佛果相违。此中二颂者。谓颂已说及当说义。此说此余见不见者。谓此十处殊胜语说。于此大乘处处见说。于余小乘曾不见说

论曰。复次云何如是次第说此十处。谓诸菩萨于诸法因要先善已。方于缘起应得善巧。次后于缘所生诸法应善其相。善能远离增益损减二边过故。次后如是善修菩萨应正通达。善所取相令从诸障心得解脱。次后通达所知相已先加行位。六波罗蜜多由证得故。应更成满增上意乐。得清净故。次后清净意乐所摄六波罗蜜多。于十地中。分分差别应勤修习。谓要经三无数大劫。次后于三菩提所学应令圆满。既圆满已彼果涅槃。及与无上正等菩提应现等证。故说十处如是次第。又此说中一切大乘皆得究竟

释曰。为辩由此趣大菩提。故复开示次第方便及所须因。谓诸菩萨要先于因得善巧已。方于缘起应得善巧。知从此因而有彼果。复知彼果要从此因。是故非离此因言教能了知彼因者。即是阿赖耶识。由说此故。便舍无因不平等因。次后于缘所生诸法。应了其相。远离增益损减边故。于无无因强立为有。故名增益。于有无因强拨为无。故名损减。如是增益及与损减俱说为边。是坠堕义。此二转时失坏中道。由善数习真实观故。于此二边远离善巧。于遍计所执唯有增益。而无损减。都无有故。以要于有方起损减。于依他起无有增益。以有体故。要于非有方有增益。亦无损减。唯妄有故。于圆成实无有增益。是实有故唯有损减。即由此故。或复于此。善能远离增益损减二边过者。谓于依他起性。增益实无遍计所执性。损减实有圆成实性。又如大般若波罗蜜多经中说。慈氏。于汝意云何。诸遍计所执中非实有性。为色非色不也世尊。诸依他起中唯有名想施设言说。性为色非色。不也世尊。诸圆成实中彼空无我性。为色非色。不也世尊。慈氏。由此门故应如是知。诸遍计所执性决定非有。诸依他起性。唯有名想施设言说。诸圆成实空无我性。是真实有。我依此故密意说言。彼无二数。谓是色等如是解脱二边过失。于三自性得善巧已由。唯识性应善通达所知之相入。者即是通达作证。或由此故能顺通达。次后即于顺唯识性。通达体入所修六种波罗蜜多。由胜义故应更证得清净意乐。应更摄受欲及胜解。名为意乐。此二尔时虽无增数。证净摄故而说清净。次后即彼于十地中。由于三学勤修学故。三无数劫数修习故应令圆满。次后彼果烦恼所知二障永断。及与无垢无有挂碍。一切智智应更证得。如是所辨次第方便。及所须因显是能顺大菩提性。即由如是所说次第。唯有十处不增不减。如是已释主随二论。是故当知声闻乘道即佛乘道不应道理。若尔其果应无差别。又于一切声闻乘中曾未有处。为诸菩萨广说佛道。又亦不许佛与声闻无有差别。师资建立应无有故。由此说有二道差别。是故说此名摄大乘尽。其所有大乘纲要无别说故

    摄大乘论释所知依分第二之一

论曰。此中最初且说所知依。即阿赖耶识。世尊何处说阿赖耶识名阿赖耶识。谓薄伽梵于阿毗达磨大乘经伽他中说

  无始时来界　　一切法等依
  由此有诸趣　　及涅槃证得

释曰。此引阿笈摩。证阿赖耶识名所知依。无始时者初际无故。界者因也。即种子也。是谁因种。谓一切法此唯杂染。非是清净故。后当言多闻熏习所依。非阿赖耶识所摄。如阿赖耶识成种子。如理作意所摄。似法似义所起等。彼一切法等所依者。能任持故非因性故。能任持义。是所依义非因性义。所依能依性各异故。若不尔者。界声已了无假依言。由此有诸趣及涅槃证得者。如决择处当广分别。谓生杂染等那落迦等。若离阿赖耶识皆不得有等生等。杂染毕竟止息名为涅槃。若离阿赖耶识不应证得

论曰。即于此中复说颂言

  由摄藏诸法　　一切种子识
  故名阿赖耶　　胜者我开示

释曰。复引圣言所说。证阿赖耶识名阿赖耶。能摄藏诸法者。谓是所熏是习气义。非如大等显了法性。藏最胜中。阿赖耶识摄藏诸法亦复如是。为简彼义。是故复言一切种子识。与一切种子俱生俱灭故。阿赖耶识与诸转识互为缘故。展转摄藏。是故说名阿赖耶识。非如最胜即显了性。显自简劣故。复说言胜者我开示。即大菩萨有堪能故名为胜者。为彼开示非余劣者

论曰。如是且引阿笈摩证。复何缘故此识说名阿赖耶识。一切有生杂染品法。于此摄藏为果性故。又即此识于彼摄藏为因性故。是故说名阿赖耶识。或诸有情摄藏此识。为自我故。是故说名阿赖耶识

释曰。一切有生者谓诸有为。杂染品法者。简清净法。非清净法是杂染性。一切杂染库藏所治。种子体性之所摄藏。能治彼故非互相违。为因果性。是正道理然得为所依。若处有所治亦有能治故。于此摄藏者。显能持习气。由非唯习气名阿赖耶识。要能持习气如彼说意识。或诸有情摄藏此识为自我者。是执取义

论曰。复次此识亦名阿陀那识。此中阿笈摩者。如解深密经说

  阿陀那识甚深细　　一切种子如瀑流
  我于凡愚不开演　　恐彼分别执为我

释曰。复引余教所说异名。开示建立阿赖耶识。令极显了。言甚深者。世聪睿者所有觉慧难穷底故。言甚细者。诸声闻等难了知故。是故不为诸声闻等开示此识。彼不求微细一切智智故。一切种子如瀑流者。刹那展转相续不断。如水瀑流。我于凡愚不开演者。怀我见者不为开示。恐彼分别计执为我。何容彼类分别计执穷生死际。行相一类无改易故

论曰。何缘此识亦复说名阿陀那识。执受一切有色根故。一切自体取所依故。所以者何。有色诸根。由此执受无有失坏尽寿随转。又于相续正结生时。取彼生故执受自体。是故此识亦复说名阿陀那识

释曰。执受一切有色根故。等者显声转因以能执受。一切眼等有色诸根。安危共同尽寿随转。是故说名阿陀那识。若不尔者应如死身即便失坏。一切自体取所依故。等者谓是一切。若一若多。所有自体取所依性。若色等根未已生起。若无色界自体生起名为相续。摄受彼故名正结生。受彼生故。精血合故。非无阿赖耶识而有执受一期自体。譬如室宅院摄光明。是一期自体习气所熏故

论曰。此亦名心。如世尊说心意识三。此中意有二种。第一与作等无间缘所依止性。无间灭识能与意识作生依止。第二染污意与四烦恼恒共相应。一者萨迦耶见。二者我慢。三者我爱。四者无明。此即是识杂染所依识。复由彼第一依生。第二杂染了别境义故。等无间义故。思量义故。意成二种

释曰。此亦名心者。复引余教安立异名。令此坚固。第二染污意者。由四烦恼萨迦耶见等所染污故。此中萨迦耶见者。谓坚执着我我所性。由此势力而起我慢。恃我我所而自高举。此二有故便起我贪。说名我爱。此三皆用无明为因。言无明者即是无智。明所治故。此即是识杂染所依。于定不定善等位中。皆不相违恒现行故。其如何等。谓善心时亦执我故。由第一依生者。由等无间灭意故。由第二杂染者。由四烦恼相应意故。以计我等能作杂染。了别境义故者。是能取境似境现义。此释识名等。无间义故思量义故意成二种者。此释意名。若离训释声义道理。终不能令他得解了

论曰。复次云何得知。有染污意。谓此若无不共。无明则不得有。成过失故。又五同法亦不得有。成过失故。所以者何。以五识身必有眼等俱有依故。又训释词亦不得有。成过失故。又无想定与灭尽定差别无有。成过失故。谓无想定染意所显。非灭尽定。若不尔者此二种定应无差别。又无想天一期生中应无染污。成过失故。于中若无我执我慢。又一切时我执现行。现可得故。谓善不善无记心中。若不尔者唯不善心彼相应。故有我我所烦恼现行。非善无记。是故若立俱有现行。非相应现行无此过失。此中颂曰

  若不共无明　　及与五同法
  训词二定别　　无皆成过失
  无想主应无　　我执转成过
  我执恒随逐　　一切种无有
  离染意无有　　二三成相违
  无此一切处　　我执不应有
  真义心当生　　常能为障碍
  俱行一切分　　谓不共无明

此意染污故。有覆无记性。与四烦恼常共相应。如色无色二缠烦恼。是其有覆无记性摄。色无色缠为奢摩他所摄藏故。此意一切时微细随逐故

释曰。为引正理成染污意故。复略举直说伽他。谓此若无不共无明不得有等。若不说有染污意者。则不得有不共无明。不共无明当说其相。谓能障碍真智生愚。此于五识无容说有。是处无有能对治故。若处有能治。此处有所治。非五识中有彼能治。于此见道不生起故。非于不染意识中有。由彼此应成染性故。亦非染污意识中有。与余烦恼共相应时。不共无明名不成故。若立意识由彼烦恼成染污者。即应毕竟成染污性。诸施等心应不成善。彼烦恼相恒相应故。若复有说善心俱转有彼烦恼。是即一向与彼相应。余不得有。此染意识引生对治不应道理。若有说言染污意俱有别善心。能引对治能治生故。所治即灭应正道理。若尔所立不共无明亦不成就。与身见等所余烦恼恒相应故。汝难不平非我说彼。与余烦恼不相应故名为不共。然说彼惑余处所无故名不共。譬如十八不共佛法。前说与余烦恼相应名不成者。观他所立显彼过故。又五同法亦不得有成过失者。此破唯立从六二缘六识转义。眼等五识与彼意识有同法性。谓从二缘而得生起。彼染污意若无有者与此相违。所谓俱生增上缘依无别有故。又眼等识各具二缘皆是识性。如是识性并有眼等俱转别依。唯增上缘非因缘等。此为能喻。意识亦尔。应有如是差别所依。阿赖耶识虽是意识俱生所依。然不应立为此别依。是共依故。因缘性故。经部所立。色为意识俱生别依。此不成就不应道理。以就思择随念分别。应一切时无分别故。由此道理余部所立。胸中色物意识别依。亦不成就。如所说过恒随逐故。譬如依止色根诸识。如是难通应广决择又训释词亦不得有成过失者。如前所说训释意名依思量性。若不立有染污意者。此何所依六识已谢不应成意。体灭无故。又无想定与灭尽定差别无有成过失者。若有定立有染污意。此有此无在凡相续。在圣相续。如其次第二定差别道理成就。若不尔者。俱想受灭等有识行应无差别。不可说在第四静虑。在第一有地差别故。出离静住欲差别故。二定差别。由二自相无差别故。心及心法俱灭何异。今此决择。对经部师少相近故。彼部所立。不相应行非实物有。何得二定实有差别。又无想天一期生中。无我执转应成过失。言无想者。谓若生在无想天中。心心法灭。初续生时有彼暂起。从此已后相续随转。若不许彼有染污意。一期生中应无我执。曾不见有具烦恼者。一期生中都无我执。又诸圣贤同诃厌故。非生刹那现起意识。我执所依为势引故。名有我执未永断故。如有痫等应正道理。我执所依俱谢灭故。势引亦无余所依故。不应道理。我执习气在身相续。亦不应理。色法受熏不应理故。无堪能故。又经部师不说唯色名为心法。等无间缘此所无故。心及心法四缘定故。若说别有常俱起心。我执所依此无过失。又一切时我执随逐不应道理。谓若不说有染污意。于一切时义不符顺。施等善位亦有我执。常所随逐自谓我能修行施等。非离无明我执随逐。非离依止而有无明。是心法故。此所依止离染污意定无所有。非即善心是无明依。应正道理如说

  如是染污意　　是识之所依
  此未灭识缚　　终不得解脱

无有二者。谓不共无明及与五同法。三成相违者。谓训释词二定差别。无想天生我执随逐。如是三种皆成相违。前已略举不共无明。今为广释故说真义。心当生等。谓能障碍真实义见。彼若现有此不生故。俱行一切分者。是善不善无记位中。常随转义

论曰。心体第三。若离阿赖耶识无别可得。是故成就阿赖耶识以为心体。由此为种子意及识转

释曰。心体第三若离阿赖耶识无别可得者。谓如意声说染污意。无间灭意识声则说六种转识。如是心声离彼二种无体可得。非无有体而有能诠。亦非异门意识二声。所诠异故。此中体声意取所诠。是故成就阿赖耶识等者。显阿赖耶识是心声所诠道理决定

论曰。何因缘故亦说名心。由种种法熏习种子所积集故

释曰。由种种法者。谓由种种品类转识。所摄诸法熏习种子者。谓所熏成功能差别。所积集者。谓杂种类积集其中。故者即是门义依义。此则显示心声转因

论曰。复次何故声闻乘中。不说此心名阿赖耶识。名阿陀那识。由此深细境所摄故。所以者何。由诸声闻不于一切境智处转。是故于彼虽离此说。然智得成解脱成就故不为说。若诸菩萨定于一切境智处转。是故为说。若离此智不易证得一切智智

释曰。由此深细境所摄故者。此显阿赖耶识亦是深细亦所知境。由深细故于诸声闻不为宣说。彼是粗浅所知境摄。所应化故深细境智。于彼无恩。由诸声闻不于一切境智处转者。此则显彼无有功能。悕愿处相。是故于彼虽离此说等者。谓于声闻虽离为说阿赖耶识。但由粗浅色等境界。苦集等性无常等行。正观察时。便能永断一切烦恼。彼为此义依世尊所。勤修梵行。言粗浅者。谓诸色法体相粗故。受等诸法所缘行相易可分别。行相粗故。与此相违如其所应阿赖耶识说名深细。如说我不说一法未达未遍知等者。此密意说。不断烦恼以别相声说总相处。非诸烦恼有各别断。或取共相无常等行故不为说。阿赖耶识亦无过失。若诸菩萨定于一切境智处转者。显菩萨有种姓势力。由与功能悕愿处相具相应故。一切智性为所期处异。此不能作他义利。所以者何。非一切智无有堪能随顺知他意乐。随眠界根胜劣有能无能。时分差别具作一切他之义利。如是等事菩萨所求。是故为说阿赖耶识。若离此智等者。若离阿赖耶识智不能永断。于义遍计彼不断故。无分别智则不得有执。有遍计所执义故。由此因缘不易证得一切智智。所以者何。能证一切所知共相。是分别智知遍计义自相分别。展转不同以无边故。决定无能具证一切。若知此唯阿赖耶识。能生习气转变力故。义有情我显现而转。尔时觉知无所取义。如是亦能知无能取。由此证得无分别智。次后得智如所串习通达法性。由一切法共相所显。真如一味知一切法。于一刹那亦易证得。一切境智非无边故。然复说言要经于三无数劫者。此显积习广大资粮方能证得广大殊胜。一切种相微妙果智。如是所说。妙智资粮不离能证法无我境。故说颂言

  非于一切所知境　　不断所执法分别
  而能证得一切智　　是故宣说法无我

不善通达如是理教故有颂言

  由彼相续有堪能　　当知如火食一切
  如是应许一切智　　能作一切知一切

是故于此阿赖耶识知不知者。易证难证一切智智。定依此宗作如是说。非知一切法无我者。名一切智彼虽一切智非一切种智

摄大乘论释卷第一摄大乘论释卷第二

        无性菩萨造

        三藏法师玄奘奉　诏译

    所知依分第二之二

论曰。复次声闻乘中。亦以异门密意。已说阿赖耶识。如彼增壹阿笈摩说。世间众生爱阿赖耶。乐阿赖耶。欣阿赖耶。喜阿赖耶。为断如是阿赖耶故。说正法时恭敬摄耳。住求解心。法随法行。如来出世如是甚奇希有正法。出现世间。于声闻乘如来出现四德经中。由此异门。密意已显阿赖耶识。于大众部阿笈摩中。亦以异门密意。说此名根本识。如树依根。化地部中亦以异门密意。说此名穷生死蕴。有处有时见色心断。非阿赖耶识中彼种有断

释曰。声闻乘中亦以异门密意。已说阿赖耶识者。此举余部共所成立显阿赖耶识如大王路故。先总序如彼增壹阿笈摩说者。是说一切有部中说。爱阿赖耶者。此句总说贪着阿赖耶识。乐阿赖耶者。乐现在世阿赖耶识。欣阿赖耶者。欣过去世。已生阿赖耶识。喜阿赖耶者。喜未来世。当生阿赖耶识。此性于彼极希愿故。由乐欣喜是故总名爱阿赖耶。为断如是阿赖耶故者。为永害彼。说正法时者。说正教法。恭敬者。乐欲闻故。摄耳者。立愿听故。此则说其闻所成智。住求解心者。如所闻义求决定故。此则说其思所成智。法随法行者。所证名法。道名随法。随顺彼故。又出世道名法。世间道名随法。行者行彼自心相续。树增彼故。令彼现前得自在故。此则说其修所成智。如来出现四德经中。由此异门密意已显阿赖耶识者。谓此经中宣说如来出现于世。有其四种可称赞德。于大众部阿笈摩等者。重成此识于彼部中。如大王路根本识者。余识因故。譬如树根是茎等因。化地部等者。于彼部中有三种蕴。一者一念顷蕴。谓一刹那有生灭法。二者一期生蕴。谓乃至死恒随转法。三者穷生死蕴。谓乃至得金刚喻定恒随转法。此若除彼阿赖耶识。余不应有。但异名说阿赖耶识。如名诸蕴决定无有穷生死故。彼问云何此答有处。有时见等有处。于界有时于分于无色界诸色间断。于无想天及二定分诸心间断。非谓于阿赖耶识中色心种子。乃至对治道未生来。有时间断不应计度。随所应有正义有故。计度傍义违越正义不应道理

论曰。如是所知依。说阿赖耶识为性。阿陀那识为性。心为性。阿赖耶为性。根本识为性。穷生死蕴为性等。由此异门。阿赖耶识成大王路

释曰。等谓圣者上座部中。以有分声亦说此识。阿赖耶识是有因故。如说六识不死不生。或由有分。或由反缘而死。由异熟意识界而生。如是等能引发者。唯是意识故作是言。五识于法无所了知。唯所引发意界亦尔。唯等寻求见唯照嘱。等贯彻者。得决定智安立。是能起语分别。六识唯能随起威仪。不能受善不善业道。不能入定。不能出定势用。一切皆能起作。由能引发从睡而觉。由势用故观所梦事。如是等分别说部亦说。此识名有。分识由如是等诸部圣教为定量故。阿赖耶识如大王路

论曰。复有一类。谓心意识义一文异。是义不成。意识两义差别可得。当知心义亦应有异。复有一类。谓薄伽梵所说众生爱阿赖耶。乃至广说。此中五取蕴说名阿赖耶。有余复谓贪俱乐受名阿赖耶。有余复谓萨迦耶见名阿赖耶。此等诸师由教及证愚于阿赖耶识故作此执。如是安立阿赖耶名随声闻乘。安立道理亦不相应。若不愚者取阿赖耶识。安立彼说。阿赖耶名。如是安立则为最胜。云何最胜。若五取蕴名阿赖耶。生恶趣中一向苦处最可厌逆。众生一向不起爱乐。于中执藏不应道理。以彼常求速舍离故。若贪俱乐受名阿赖耶。第四静虑以上无有。具彼有情常有厌逆。于中执藏亦不应理。若萨迦耶见名阿赖耶。于此正法中信解无我者。恒有厌逆。于中执藏亦不应理。阿赖耶识内我性摄。虽生恶趣一向苦处求离苦蕴。然彼恒于阿赖耶识我爱随缚。未尝求离。虽生第四静虑已上。于贪俱乐恒有厌逆。然彼恒于阿赖耶识我爱随缚。虽于此正法信解无我者。厌逆我见。然彼恒于阿赖耶识我爱随缚。是故安立阿赖耶识。名阿赖耶成就最胜

释曰。复有一类。谓心意识义一文异者。此显邪执。谓如所说心意识名皆同一义。是义不成者。是非理义。意识两义差别可得者。两声两义能诠所诠自相异故。谓六识身无间过去说名为意。了别境界说名为识。如意识名义有差别。如是心义亦应有异。复有一类谓薄伽梵所说等者。此显余师于爱阿赖耶等起异义执。言五取蕴名阿赖耶者。谓诸众生摄为我故。言贪俱乐受名阿赖耶者。谓贪受俱行总名阿赖耶。此受是贪所随增眠故。或复各别名阿赖耶。着处异故。言萨迦耶见名阿赖耶者。由此取彼为我性故。此等诸师由教及证。愚阿赖耶识故作此执者。谓彼诸师有恶教故。有恶证故。愚阿赖耶识。或彼诸师无亲教故。无自解故。愚阿赖耶识。随声闻乘安立道理亦不相应者。随彼自宗亦不应理。如胜论等所立实等彼非为胜有过失故。如是安立则为最胜者。无过失故。有胜德故。为欲显彼计执过失故。复问言。云何最胜。若立五取蕴名阿赖耶。生恶趣中一向苦处者。生捺落迦傍生饿鬼名生恶趣。唯有苦故。似苦现故名一向苦处。由彼曾无有少乐故。最可厌逆。于一切时有多苦故。众生一向不起爱乐。非不爱义而有执藏。与执藏义不相应故。于中执藏不应道理。以彼常求速舍离者。是于苦蕴恒伤叹义。云何当令我无苦蕴非求速离而复执藏应正道理以相违故。第四静虑及上无色。贪俱乐受恒无所有。常有厌逆。是厌因故可恶逆故。言具彼者。第四静虑已上有情具彼种类。是故彼处于中执藏。亦不应理。以无有故。于此正法中信解无我者。常极厌逆萨迦耶见是应断故。见无我者彼无有故。但取信解恒求断故。于中执藏亦不应理。如是已显他执过失。复当显示自宗胜德。阿赖耶识内我性摄者。众生妄执为内我体。虽然两声为重遮止他说妄计。捺落迦等名生恶趣。一向苦处虽于苦蕴常求远离。然彼恒于阿赖耶识。我爱罥索随缚不离。曾不于中起无有爱。由舍受相应非可厌逆故。所以者何。彼虽希愿。云何当令我诸苦蕴都无所有。然于自我未尝求离我见。对治未有故异趣更无故。若于诸蕴有所愿乐。此则是其阿赖耶力。非于意识有此我爱应正道理。以恶趣中与彼苦受恒相应故。由此道理于余趣中。于彼希愿亦不相应。虽生第四静虑已上。于贪俱乐恒有厌逆。然内我爱随缚不离。如是我爱依他。而转依阿赖耶。非于意识。以阿赖耶乃至对治道未生来无变易转。意识不尔。于无想定无想灭定有间断故。非有意识而无有受俱成有故。于此正法中信解无我者。虽恒厌逆分别我见。然有俱生我见随缚。此于何处。谓彼但于阿赖耶识率尔闻声。便执内我惊畏生故。何缘不许即于诸蕴而有我爱。以若于彼有我爱者。此则是其阿赖耶识。由可分别所缘行相。四无色蕴于无想天二无心定不相续故。若尔阿罗汉虽厌逆身见。亦应得有。如是我爱断故无有。以阿罗汉一切我见皆已永断故无此失。是故说言阿罗汉已转于阿赖耶识。更无此我爱。是故安立阿赖耶识。名阿赖耶识决定成就。无诸过失。有诸胜德。是故说言成就最胜

论曰。如是已说阿赖耶识安立异门。安立此相云何可见。安立此相略有三种。一者安立自相。二者安立因相。三者安立果相。此中安立阿赖耶识自相者。谓依一切杂染品法所有熏习。为彼生因由能摄持种子相应。此中安立阿赖耶识因相者。谓即如是一切种子阿赖耶识。于一切时与彼杂染品类诸法。现前为因。此中安立阿赖耶识果相者。谓即依彼杂染品法。无始时来所有熏习。阿赖耶识相续而生

释曰。如是已说安立异门。次安立相。唯由其名。未能了别此识自相故。次须说自相应。相略有三者。分析此识自相应相。以为二种因果异故。依识自相说如是言。谓依一切杂染品法所有熏习。即贪嗔等名为一切杂染品法。与彼能熏俱生灭故。得成种子。即此功能望彼当生能作生因。由能摄持种子相应者。于第五处说第三转。是能摄持种子相应义故。此中摄持种子相应。谓有生法俱生俱灭故成熏习。如是熏习摄持种子应正道理。此相应故能生于彼。非最胜等有如所说摄持种子相应。亦非等无间缘等。彼虽能摄受而非最胜因。摄持种子不相应故。最胜因者。所谓种子阿赖耶识。能摄持此。故能与彼而作生因。非唯摄受。要由摄持熏习功能。方为因故。因相即是增盛作用。熏习功能能为因性。现前能生杂染法故。果相即是由转识摄。贪等现行杂染诸法。熏习所持名为果相。阿赖耶识因果不定。故当说言

  言熏习所生　　诸法此从彼
  异熟与转识　　更互为缘生

论曰。复次何等名为熏习。熏习能诠何为所诠。谓依彼法俱生俱灭。此中有能生彼因性。是谓所诠。如苣胜中有花熏习。苣胜与花俱生俱灭。是诸苣胜带能生彼香因而生。又如所立贪等行者。贪等熏习依彼贪等俱生俱灭。此心带彼生因而生。或多闻者。多闻熏习依闻作意俱生俱灭。此心带彼记因而生。由此熏习能摄持故。名持法者。阿赖耶识。熏习道理当知亦尔

释曰。复次何等名为熏习等者。为欲决了熏习自相。郑重征责难了知故。谓依彼法俱生俱灭。此中有能生彼因性者。谓此所熏与彼能熏同时生灭。因彼此有随顺能生。能熏种类果法习气。俱言为简异时生灭。为别常住。此显熏习相异余计。依者因也。于因建立如是字缘。如言依云而有雨等。举其因性为显此中有能随顺生果因体。如苣胜中有花熏习等者。举他共成喻自宗义。由自所见苣胜与花俱心变故。如彼苣胜与诸香花俱生俱灭。由是为因随顺能生。后后无间带花香气苣胜刹那此亦如是。又如所立贪等行者。贪等熏习等者。此举余部共成熏习。喻自宗义

论曰。复次阿赖耶识中。诸杂染品法种子为别异住。为无别异。非彼种子有别实物。于此中住亦非不异。然阿赖耶识如是而生。有能生彼功能差别。名一切种子识

释曰。一切法种子是阿赖耶识功能差别。如法作用与诸法体非一非异。此亦复尔

论曰。复次阿赖耶识与彼杂染诸法。同时更互为因。云何可见。譬如明灯焰炷生烧同时更互。又如芦束互相依持同时不倒。应观此中更互为因道理亦尔。如阿赖耶识为杂染诸法因。杂染诸法亦为阿赖耶识因。唯就如是安立因缘。所余因缘不可得故

释曰。譬如明灯于一时间。灯炷灯焰生焰烧炷。互为因果。阿赖耶识与诸转识。于一时间互为因果其性亦尔。如是芦束更互依持令住不倒。若于尔时此能持彼令住不倒。即于尔时彼能持此令住不倒。唯就如是安立因缘者。谓就前说摄持种子相应非余。所余因缘不可得故者。谓所余法摄持种子不相应故。若说五因为因缘者。即异门说。阿赖耶识同类遍行异熟三因。若离任持熏习因性。不相应故。熏习若离阿赖耶识。无容有故。相应因者。心与心法更互相待。受用境界有自功能。犹如商旅非离功能。阿赖耶识能依种起俱有因义。即阿赖耶与诸转识。若离如是俱有因摄。内外种子阿赖耶识。所余因缘定不可得

论曰。云何熏习无异无杂。而能与彼有异有杂。诸法为因。如众缬具缬所缬衣。当缬之时虽复未有异杂。非一品类。可得入染器后。尔时衣上便有异杂。非一品类。染色绞络文像显现。阿赖耶识亦复如是。异杂能熏之所熏习。于熏习时虽复未有异杂。可得果生。染器现前已后便有异杂。无量品类诸法显现

释曰。云何熏习无异等者。就理为难。依理通言。如众缬具。缬所缬等。缬具即是淡涩差别。当缬衣时无异无杂。文像可得。果生即染器故名果生染器。缘所摄受故名为入。阿赖耶识如所染衣。如染众像诸法显现

论曰。如是缘起于大乘中极细甚深。又若略说有二缘起。一者分别自性缘起。二者分别爱非爱缘起。此中依止阿赖耶识诸法生起。是名分别自性缘起。以能分别种种自性为缘性故。复有十二支缘起。是名分别爱非爱缘起。以于善趣恶趣能分别爱非爱。种种自体为缘性故

释曰。如是缘起于大乘中极细者。谓诸世间难了知故。甚深者。谓声闻等难穷底故。缘起者。谓即是因有因起义。应念于因后置讫埵缘故。分别自性者。谓于分别有势力故。或于分别有所须故说名分别。即阿赖耶识能分别自性。以能分析一切有生。杂染法性令差别故。分别爱非爱者。谓无明等十二支分。于能分析善趣恶趣。若可欣乐不可欣乐。种种自体差别生中为最胜缘。从阿赖耶识诸行等生时。由无明等势力。令福非福不动等有差别故

论曰。于阿赖耶识中若愚第一缘起。或有分别自性为因。或有分别宿作为因。或有分别自在变化为因。或有分别实我为因。或有分别无因无缘。若愚第二缘起。复有分别我为作者。我为受者。譬如众多生盲士夫未曾见象。复有以象说而示之彼诸生盲有触象鼻。有触其牙。有触其耳。有触其足。有触其尾。有触脊[月*梁]。诸有问言象为何相。或有说言象如犁柄。或说如杵。或说如箕。或说如臼。或说如帚。或有说言象如石山。若不解了此二缘起。无明生盲亦复如是。或有计执自性为因。或有计执宿作为因。或有计执自在为因。或有计执实我为因。或有计执无因无缘。或有计执我为作者我为受者。阿赖耶识自性因性及果性等。如所不了象之自性

释曰。由于二种缘起义愚。譬如生盲。或有计执宿作为因者。损减士用故成邪执

论曰。又若略说阿赖耶识。用异熟识一切种子为其自性。能摄三界一切自体一切趣等

释曰。为显本生了别自性故。复说言又若略等。谓生生中。由善不善诸业熏习。所取能取分别执着。种子所生有情本事异熟为性。阿赖耶识及与杂染诸法种子为其自相。能摄三界者。能摄欲色及无色缠。一切自体者。能摄一切有情相续。一切趣等者。能摄天趣等。言能摄者。常相续相。何以故。如色转识有处有时相续间断。阿赖耶识则不如是。乃至治生恒持一切遍诸位故

论曰。此中五颂

  外内不明了　　二种唯世俗
  胜义诸种子　　当知有六种
  刹那灭俱有　　恒随转应知
  决定待众缘　　唯能引自果
  坚无记可熏　　与能熏相应
  所熏非异此　　是为熏习相
  六识无相应　　三差别相违
  二念不俱有　　类例余成失
  此外内种子　　能生引应知
  枯丧由能引　　如任运后灭

释曰。前已总说一切种子。为显如是种子差别。复说五颂。谓内外等稻谷麦等名外种子。阿赖耶识名内种子。不明了者。是无记故。言二种者。谓外及内。或果与因。此俱唯识由持因性。杂染清净二法转故。有本颂。言于二者。彼应于因于果执麦等外种说名世俗。阿赖耶识所变现故。言胜义者。阿赖耶识是实种子。是一切种子实因缘性故。及为彼体故。此二种子六种差别法差别故。刹那灭者。生已无间即灭坏故。无有常住得成种子。于一切时无差别故。虽刹那灭然非已灭。何者俱有已灭生果。不应理故。如死鸡鸣。是故应许种子与果俱时而住。以此与果不相违故。如莲华根。虽复俱有然非一二三刹那住。犹如电光。何者应知。此恒随转刹那转转。经于多时恒随转故。所以者何。其根损益枝等同故。若恒随转非许少分乐为种子。何因缘故不从一切一切俱生为避此难故说决定。虽恒随转以诸种子功能定故。不从一切一切俱生。虽尔何故不一切时常能生果。为避此失言待众缘。非一切时会遇众缘故无过失。今此种子是谁种子。答此问言。唯能引自果。所言唯者。若于此时能生自果。即于尔时说名种子。种与有种并无始故。由此唯言遮相续等为种子体。如所说种子法不相应故。要待所熏能熏相应。种与有种其性方立。为辩所熏故说坚等。若法相续随转坚住。如苣胜等乃为所熏。非不坚住。犹如声等非唯坚住。复无记性方是所熏。如平等香乃受熏习。非极香物如沉麝等。非极臭物。如蒜薤等。言可熏者。若物可熏或能受熏。分分展转更相和糅乃名可熏。非金石等能受熏习。不可分分相和糅故。非唯可熏要复与彼能熏相应乃名所熏。非别异住。同时同处不即不离名曰相应。具斯众德可名所熏。非异于此。非声为遮一切转识是所熏性。如上所说义相违故。阿赖耶识其体坚住。乃至治生相续随转。未曾断故性唯无记非善恶故。性应可熏或能受熏。非常住故。能熏相应俱生灭故。是为熏习相者。是彼法故所熏为能相。熏习为所相。又诸转识定非所熏。以彼六识无定相应。何以故。以三差别互相违故。若六转识定俱有者。不应所依所缘作意三种各别。以各别故。六种转识不定俱生。不俱生故。无定相应。无相应故。何有所熏能熏之性。若言前念熏于后念成熏习者。此义不然。以其二念不俱有故。此亦显示由二刹那。不俱有故无定相应。无相应故。无有所熏能熏之性。若言依止种类句义。六种转识。或二刹那同一识类。或刹那类无有差别。由异品故。或即彼识。或彼刹那。有相熏习非一切者。此不应理。种类例余成过失故。阿罗汉心不出识类。彼亦应是不善所熏。一类法故。或类例余成过失者。是例余类有过失义。此义云何。谓眼等根清净色性。皆根种类之所随逐。意根亦应成造色性。根义等故。且有尔所熏习异计。或说六识展转相熏。或说前念熏于后念。或说熏识刹那种类。如是一切皆不应理。是故唯说阿赖耶识是所熏习非余识者。是为善说。如是外内二种种子俱为生因。及为引因。若外种子亲望于芽为能生因。转望茎等为能引因。阿赖耶识是内种子。亲望名色为能生因。转望六处乃至老死为能引因。生因且尔。云何引因。为答此问故说枯丧。由能引言。若二种子唯作生因非引因者。收置仓等麦等种子。不应久时相似相续。丧后尸骸如青瘀等。分位随转亦不应有何者才死即应灭坏。云何譬如任运后灭。譬如射箭放弦行力为能生因。令箭离弦不即堕落。弯弓行力为箭引因。令箭前行远有所至。非唯放弦。行力能生应即堕故。亦非动势展转相推应不堕故。既离弦行远有所至。故知此中有二行力。能生能引。有颂任运后灭故者。彼直以理增益引因。非说譬喻。所以者何。油炷都尽不待外缘。灯焰任运后渐方灭。非初即灭。由此道理决定应有能引功力。于今未尽内法诸行。亦应如是有种势力。展转能引令不断绝

论曰。为显内种非如外种。复说二颂

  外或无熏习　　非内种应知
  闻等熏习无　　果生非道理
  作不作失得　　过故成相违
  外种内为缘　　由依彼熏习

释曰。如是已辩外内种子。其性粗同为显不同。复说外或无熏习等。或者分别不决定义。谓外种子。或有熏习。或无熏习。如从其炭牛粪毛等随其次第生。彼苣胜青。莲华根。及以蒲等非苣胜等。与彼炭等俱生俱灭。互相熏习而从彼生。如是外种或无熏习。如苣胜等与华鬘等俱生俱灭。由熏习故生香气等。如是外种或有熏习。如是分别外种不定。是故说或内种子。即是阿赖耶识中一切法熏习。如是种子应知定由熏习故有。何以故。若无所持闻等熏习。多闻等果不见有故。又外种子若稻谷等。或有虽种而复失坏。若稊稗等或有不种而复得生。云何内种非如外种。有作不作生得过失。故次答言。故成相违。以内种子与外种子不同法故。名曰相违。若外种子与内种子有差别者。云何不违前文所说。阿赖耶识是一切法真实种子。为避此难故说外种。内为缘等由稻谷等外法种子。皆是众生感受用业熏习种子。依阿赖耶力所变现。是故外种离内无别。如有颂言

  天地风虚空　　陂池方大海
  皆真内所作　　分别不在外

如是等类有无量颂

论曰。复次其余转识。普于一切自体诸趣。应知说名能受用者。如中边分别论中说伽他曰

  一则名缘识　　第二名受者
  此中能受用　　分别推心法

释曰。诸趣谓天等趣。能受用者即六转识为受用故。从缘而生。所缘境界可分别故。为显此义故。引中边分别论颂。为至教量。言此中者。此诸识中能受用者谓受蕴。能分别者谓想蕴。能推者谓行蕴。思能推心。于彼彼转最胜故。说如是三蕴皆能助心。受用境界故名心法

论曰。如是二识更互为缘。如阿毗达磨大乘经中说伽他曰

  诸法于识藏　　识于法亦尔
  更互为果性　　亦常为因性

释曰。此中为显阿赖耶识与诸转识。更互为缘引阿笈摩。令其坚固故。说诸法于识藏等。又如瑜伽师地论摄决择分中说。阿赖耶识与诸转识作二缘性。一为彼种子故。二为彼所依故。为种子者。谓所有善不善无记。转识转时一切皆用阿赖耶识为种子故。为所依者。谓由阿赖耶识执受色根。五种识身依之而转非无执受。又由有阿赖耶识故得有末那。由此末那为依止故意识得转。譬如依止眼等五根。五识身转非无五根。意识亦尔。非无意根。复次诸转识与阿赖耶识作二缘性。一于现法中能长养彼种子故。二于后法中为彼得生。摄殖彼种子故。于现法中长养彼种子者。谓如依止阿赖耶识。善不善无记转识转时。如是如是于一依止。同生同灭。熏习阿赖耶识。由此因缘后后转识。善不善无记性转更增长转。更炽盛转。更明了而转。于后法中为彼得生。摄殖彼种子者。谓彼熏习种类。能引摄当来异熟无记阿赖耶识。如是为彼种子故。为彼所依故。长养种子故。摄殖种子故。应知建立阿赖耶识。与诸转识互为缘性

论曰。若于第一缘起中。如是二识互为因缘。于第二缘起中。复是何缘是增上缘。如是六识几缘所生。增上所缘等无间缘。如是三种缘起。谓穷生死爱非爱趣及能受用具有四缘

释曰。若于第一缘起中者。谓于分别自性缘起中。如是二识互为因缘者。如次前说。于第二缘起中者。谓于分别爱非爱缘起中。是增上缘者。以最胜故由无明等增上力故。令其行等于善恶趣感异熟果。如是六识三缘生者。此中眼识眼为增上缘。色为所缘缘。无间灭识为等无间缘。如说眼识从三缘生。如是耳等一一转识。各从别别三缘所。生生义平等如前眼识。分别自性唯因缘生。其余三缘非正有故。如是三种缘起。谓穷生死等具有四缘者。此随所应非各具四。唯心心法具四应知

论曰。如是已安立阿赖耶识异门及相。复云何知如是异门及如是相决定。唯在阿赖耶识非于转识。由若远离如是安立。阿赖耶识杂染清净皆不得成。谓烦恼杂染。若业杂染。若生杂染皆不成故。世间清净。出世清净亦不成故

释曰。已引自他圣教成立阿赖耶识。当依正理郑重成立。故起如是略问略答。圣教正理各有能故如有颂言

  圣教及正理　　各别有功能
  为生于信慧　　无一不成故

以若离此阿赖耶识。欲于余处安立如是异门及相。杂染清净皆不得有。故知定有阿赖耶识。言杂染者。是浑是浊是不净义。言清净者。是鲜是洁是扫除义。杂染有三。一烦恼所作。二业所作。三生所作。清净有二。一世间清净。以有漏道暂时损伏现烦恼故。二出世间清净。以无漏道毕竟断灭彼随眠故

论曰。云何烦恼杂染不成。以诸烦恼及随烦恼熏习所作。彼种子体于六识身不应理故。所以者何。若立眼识。贪等烦恼及随烦恼俱生俱灭。此由彼熏成种非余。即此眼识若已谢灭。余识所间。如是熏习熏习所依皆不可得。从此先灭余识所间。现无有体眼识与彼贪等俱生不应道理。以彼过去现无体故。如从过去现无体业。异熟果生不应道理。又此眼识贪等俱生所有熏习亦不成就。然此熏习不住贪中。由彼贪欲是能依故。不坚住故。亦不得住所余识中。以彼诸识所依别故。又无决定俱生灭故。亦复不得住自体中。由彼自体决定无有俱生灭故。是故眼识贪等烦恼。及随烦恼之所熏习。不应道理。又复此识非识所熏。如说眼识所余转识亦复如是。如应当知

释曰。且依转识先辩烦恼杂染不成。故说若立眼识等言。即此眼识者。谓即贪等所熏眼识。余识所间者。耳等识所间如是熏习。及所依识已谢灭故。皆不可得。眼识与彼贪等俱生者。后时眼识与贪嗔痴相杂俱起。由无因故不应道理。以彼过去眼识无体不能为因。如从过去现无体业异熟果生不应道理者。如经部师过去无体。其异熟果是现熏习之所引发。毗婆沙师从过去业异熟果生。此不应许。所以者何。过去无故。由此譬喻贪等心生不应道理。如是已说且许贪等俱生眼识贪等所熏。余识间起。后时眼识贪等俱生不应道理。今当更辩即此贪等俱生。眼识所有熏习亦不得成。故说又此眼识等。言然此熏习不住贪中者。然声是次第义。然且此熏习不得住贪中。以贪依识故。贪系属识。识不依贪非能依贪受所依熏。应正道理是能熏故。不坚住故者。正遮贪欲是所熏性。亦不得住所余识中者。谓不得住耳等识中。所依别故者。所依谓耳等。彼别故识别。依眼根识云何能熏依耳等识。又不俱故非不俱。有得有所熏及能熏性。此则显示无熏习相又复不得住自体中者。谓非即眼识还熏于眼识。能熏所熏作者。作业相杂过故。又复此识非识所熏者。是此眼识非耳等识所熏习义。所依别故。如前已说。唯有如是可立理趣。彼一切种皆不应理。如应当知者。所余转识立破道理。随其所应一切当知

论曰。复次从无想等上诸地没。来生此间。尔时烦恼及随烦恼所染初识。此识生时应无种子。由所依止及彼熏习并已过去。现无体故

释曰。从无想等上诸地没来生此间者。从上界没来生欲界。尔时烦恼及随烦恼者。谓贪嗔等。所染初识者。谓续生时生有初识。尔时自地一切烦恼所染污故。非经部师欲缠已断烦恼及心过去。是有可得从彼今复现行。非彼没心为此所依应正道理。由彼没心亦不成故。若尔何故不即说彼。以彼不定是染污故。又此与彼无差别故。说彼说此竟有何异

论曰。复次对治烦恼。识若已生一切世间。余识已灭。尔时若离阿赖耶识。所余烦恼及随烦恼种子。在此对治识中。不应道理。此对治识自性解脱故。与余烦恼及随烦恼不俱生灭故。复于后时世间识生。尔时若离阿赖耶识。彼诸熏习及所依止。久已过去现无体故。应无种子而更得生。是故若离阿赖耶识。烦恼杂染皆不得成

释曰。对治烦恼识若已生等者。谓如最初预流果向。见断烦恼对治道生。一切世间余识已灭。尔时若无阿赖耶识。修断烦恼所有随眠何所依住。非对治识带彼种子应正道理。由此对治识自性解脱故。即是自性极清净义。与余烦恼及随烦恼不俱生灭故者。能治所治互相违故。犹如明闇。此则显示与彼种子相不相应。复于后时者。谓见道后修道位中。久已过去现无体故者。此破过去立无实义。毗婆沙师烦恼得等。经部诸师皆已破讫。故不重破。然经部师熏习所依并无有体。过失所随故不应理。是故若离阿赖耶识烦恼杂染皆不得成者。结上所论决择道理

论曰。云何为业杂染不成。行为缘识不相应故。此若无者取为缘有亦不相应

释曰。行为缘识不相应故者。此说于转识业杂染不成。谓行为缘贪等俱生。眼等诸识许为识支。此不应理。识缘名色有圣言故。所以者何。眼等诸识刹那速坏。久已谢灭为名色缘。不应道理。若畏此失许续生识为识支者。此亦不然。于续生时。福与非福及不动行久已灭故。非从久灭此复应生。又续生心非无记性。爱恚俱故既非无记。以行为缘不应道理。若说转识与行相应。由此为缘阿赖耶识。能持熏习说名识支应正道理。此若无者取为缘有亦不相应者。谓熏习。位诸业种子异熟现前转名为有。或复转得生果功能故说名有。行所熏识若不成就。何处安立彼业种子而复得言生。果现前转名为有。是故若离阿赖耶识。此业杂染亦不得成

摄大乘论释卷第二摄大乘论释卷第三

        无性菩萨造

        三藏法师玄奘奉　诏译

    所知依分第二之三

论曰。云何为生杂染不成。结相续时不相应故

释曰。今为显示若无阿赖耶识生杂染体亦不得成故。说结相续时不相应故

论曰。若有于此非等引地没已。生时依中有位意起。染污意识结生相续。此染污意识于中有中灭。于母胎中识羯罗蓝更相和合。若即意识与彼和合。既和合已依止此识。于母胎中有意识转。若尔即应有二意识。于母胎中同时而转。又即与彼和合之识。是意识性。不应道理。依染污故。时无断故。意识所缘不可得故。设和合识即是意识。为此和合意识即是一切种子识为依止。此识所生余意识。是一切种子识。若此和合识。是一切种子识即是阿赖耶识。汝以异名立为意识。若能依止识是一切种子识。是则所依因识。非一切种子识。能依果识。是一切种子识。不应道理。是故成就此和合识。非是意识。但是异熟识。是一切种子识

释曰。非等引地。所谓欲界。没即是死。依中有位意者。谓依死生二有中间。中有转心。起染污者。与爱恚俱有颠倒故。言意识者。余识尔时久已没故。连持生故名为相续。摄受生故名为结生。此染污意识者。缘生有故。于中有中灭者。此若不灭无生有故。于母胎中识羯罗蓝更相和合者。谓此灭时。于母胎中有异熟识。与其赤白同一安危。令相和杂成羯罗蓝。如世尊说阿难陀识若不入母胎者。不应和合羯罗蓝。成羯罗蓝之体性。若即意识者。谓此若非阿赖耶识。既和合已者。谓受生已。依止此识者。依异熟识有意识转者。有别转识。谓与信等贪等相应。乐苦受俱分别意识。后后位转。若尔即应有二意识。于母胎中同时而转者。谓异熟体有情本事。不待今时加行而转。无记意识及可了知所缘行相。乐苦受等相应意识。是二意识应一身中一时而转。然不应许经相违故。如是颂言

  无处无容　　非前非后　　同身同类
  二识并生

又不应许此二。是一自性别故。又异熟识不应间断。结相续已后应余处更结生故。又异熟体唯恒相续更无异趣。又即与彼和合之识是意识性。不应道理依染污故。时无断故者。由立宗门显与彼法自相相违。谓共决定若是意识非一切处。非一切种。非一切时。依于染污犹如后时所有意识。如是结生相续时识。于一切处一切种类一切时分。皆依染污即中有摄。后心为依。此所依心生有为境。于一切处一切种类一切时分是染污故。能依之识非是意识。由此越于意识法故。或有说言。与四烦恼恒相应心名染污依。已相续心应成染污。此已成立许为无记异熟性故。由异熟性时无间断。由此亦遮。是意识性。意识所缘不可得故者。此义重增遮意识因。若是意识决定可得自所缘境。谓可了知如中有位。最后意识已相续心。所缘境界不可了知故非意识。不应以彼住灭定心为此妨难。不许彼是意识性故。如是此中但说所缘为不可得难了知故。非全无有。以于尔时非无有法。虽是其有而不可知。从设和合识即是意识。乃至但是异熟识是一切种子识者。双关征责立正破邪。结归本义。其文易了不须广释

论曰。复次结生相续已。若离异熟识执受色根亦不可得。共余诸识各别依故。不坚住故。是诸色根不应离识

释曰。结生相续已者。谓已得自体。若离异熟识者。谓离阿赖耶识。言执受者。谓能摄持。言色根者。谓除意根。亦不可得者。谓余转识皆不能得执受色根。何以故。其余诸识各别依故。此则显示眼等六根。无有一法能遍执受。且如眼识唯依于眼。如是所余耳等诸识唯依耳等。若是此所依唯此能执受。若非此所依。此不能执受。不坚住故者。此数数间断彼独生起故。于无想等有间断故。尔时眼等无能执故。应无觉受。有说身根为能执受。由遍体故。此义不然。身根亦是所执受故。设此身根是能执受。更无有余执受此故。亦不得成。又佛应言舍离身根尔时名死。不应说言寿暖及与识。若舍离身时如是等。是故身根为能执受不应道理

论曰。若离异熟识。识与名色更互相依。譬如芦束相依而转。此亦不成

释曰。如世尊言。识缘名色此中名者。非色四蕴。色者即是羯罗蓝性。此二皆用识为因缘识。复依此刹那转转相续而转。识者不离阿赖耶识。所以者何。所举名言已摄转识。复举识言更何所摄。又如经说齐识退还。识者即是阿赖耶识自体。为依无间转故。是故说此名色为缘。又如经说阿难陀。或男或女。识若断坏灭者。名色得增长广大不。不也世尊。如是等此若欲离阿赖耶识。理不可成

论曰。若离异熟识已生有情。识食不成。何以故。以六识中随取一识。于三界中已生有情。能作食事不可得故

释曰。已生有情识食不成者。以诸转识是善等性。无恒长养诸有义故。又于二定及无想天皆无有故。所作食事不遍三界。非入定等诸心心法可名为食。经不说故。已灭无故。心心法灭亦非是食。段食等数已决定故

论曰。若从此没于等引地正受生时。由非等引染污意识。结生相续。此非等引染污之心。彼地所摄。离异熟识。余种子体定不可得

释曰。如是已辩于欲界中。若离阿赖耶识结生相续不成。于色无色亦不得成。今当显示。若从此没。于等引地正受生时者。是欲界死上生时义。由非等引染污意识者。谓与彼地贪定味等烦恼相应。离异熟识余种子体定不可得者。非欲缠没心。有彼种子体。生灭不俱故。非定地生心。为彼种子体。即于一心种有种性不相应故。非余生中。先所获得色缠等心为种子体。持彼熏习余识无故。非色相续为种子体。无因缘故。是故定依阿赖耶识。于中恒有无始时来彼地所摄此心熏习

论曰。复次生无色界。若离一切种子异熟识染污善心应无种子。染污善心应无依持

释曰。生无色界者。谓于彼界已得受生。染污善心者。谓能爱味及等至心。应无种子者。是无种子识义。应无依持者。是无异熟识义。尔时一切心及心法皆应无有。是故应许一切种子及异熟识决定是有。因及依持定应有故

论曰。又即于彼。若出世心正现在前。余世间心皆灭尽故。尔时便应灭离彼趣

释曰。又即于彼者。于无色界。若出世心者。谓无漏心正现在前者。谓生无漏。余世间心者是无漏。余皆灭尽者。一切永灭。尔时便应灭离彼趣者。彼趣所摄异熟无故。不由功用自然应得无余涅槃。能治现前一切所治。皆永断故

论曰。若生非想非非想处。无所有处出世间心现在前时。即应二趣悉皆灭离。此出世识不以非想非非想处为所依趣亦不应以无所有处为所依趣。亦非涅槃为所依趣

释曰。若生非想非非想处等者。谓生第一有。欲断彼地诸烦恼时。想微劣故自地无道。无所有处地明利故。起彼无漏心现在前。尔时二趣俱应灭离。谓第一有无所有处二趣灭离。尔时有情应成死灭。二趣所依俱无有故。非无漏法是趣所摄。是不系故。对治趣故。亦非涅槃为所依趣者。住有余依涅槃界故。又一切趣永灭离故。涅槃名为非趣之趣。如是都无自体异熟。可为出世识之所依

论曰。又将没时造善造恶。或下或上所依渐冷。若不信有阿赖耶识皆不得成。是故若离一切种子异熟识者。此生杂染亦不得成

释曰。将没时者。谓将死时。若造善者。即于其身下分渐冷。若造恶者与此相违。若不信有阿赖耶识此不成就。所以者何。尔时意识无处无有。阿赖耶识有处无有。以依处住变似方处相显现故

论曰。云何世间清净不成。谓未离欲缠贪。未得色缠心者。即以欲缠善心。为离欲缠贪故。勤修加行。此欲缠加行心。与色缠心不俱生灭故。非彼所熏为彼种子不应道理。又色缠心过去多生。余心间隔不应为今定心种子。唯无有故。是故成就色缠定心一切种子异熟果识展转传来。为今因缘。加行善心为增上缘。如是一切离欲地中如应当知。如是世间清净若离一切种子异熟识。理不得成

释曰。如是已辩三种杂染。于诸转识理不得成。今欲更辩世间清净亦不得成故。说未离欲缠贪等。欲色二缠加行善心无有俱生俱灭义故。所熏能熏不应道理。又欲缠心非无记故亦非所熏。系地别故非彼因缘。无始生死余生所得色缠善心。非今色缠善心种子。过去多生欲缠多心所间隔故。经部诸师过去无体现无有体。能为色缠善心种子不应道理。是故成就等者。结上微责道理功能。证决定有阿赖耶识为彼因缘。于今欲缠加行善心为增上缘。不共因故威力胜故。如其次第如是一切离欲地中如应当知者。一切上地各别离欲加行善心。皆随所应破邪立正准上当知

论曰。云何出世清净不成。谓世尊说依他言音及内各别如理作意。由此为因正见得生。此他言音如理作意。为熏耳识为熏意识。为两俱熏。若于彼法如理思惟。尔时耳识且不得起。意识亦为种种散动。余识所间。若与如理作意相应生时。此闻所熏意识与彼熏习。久灭过去定无有体。云何复为种子。能生后时如理作意相应之心。又此如理作意相应是世间心。彼正见相应是出世心。曾未有时俱生俱灭。是故此心非彼所熏。既不被熏为彼种子不应道理。是故出世清净。若离一切种子异熟果识亦不得成。此中闻熏习。摄受彼种子不相应故

释曰。今欲更辩于六转识出世清净亦不得成故说。云何出世等言。文皆易了无劳重释。摄受彼种子不相应故者。如前所说摄受出世清净种子。不应理故

论曰。复次云何一切种子异熟果识为杂染因。复为出世能对治彼净心种子。又出世心昔未曾习故。彼熏习决定应无。既无熏习从何种生。是故应答从最清净法界等流。正闻熏习种子所生

释曰。复次云何乃至净心种子者。此显毕竟无有道理。未曾见有毒为甘露。阿赖耶识犹如毒药。云何能生出世甘露清净之心。又出世心乃至从何种生者。此显净心唯未曾得。云何无因率尔得生从最清净乃至种子所生者。此显净心有别种子。决定不从阿赖耶识种子而生。云何别种谓最清净法界等流正闻熏习。最清净法界者。诸佛法界永离一切客尘障故。言等流者。谓从法界所起教法。无倒听闻如是教法故。名正闻依此正闻所起熏习。是名熏习。即此熏习能生出世无漏之心名为种子。如是种子非阿赖耶识是未曾得故

论曰。此闻熏习为是阿赖耶识自性。为非阿赖耶识自性。若是阿赖耶识自性。云何是彼对治种子。若非阿赖耶识自性。此闻熏习种子所依云何可见。乃至证得诸佛菩提。此闻熏习随在一种。所依转处寄在异熟识中。与彼和合俱转犹如水乳。然非阿赖耶识是彼对治种子性故

释曰。此闻熏习乃至所依云何可见者。翻覆征难责。别所依乃至证得诸佛菩提者。谓乃至得无垢无碍智所依趣。此闻熏习者。无倒听闻经等教法所引熏习。随在一种所依转处者。谓随一种相续转处寄在异熟识中。与彼和合俱转犹如水乳者。此闻熏习虽非彼识。而寄识中与识俱转。然非阿赖耶识者。谓此闻熏习是出世心种子。非阿赖耶识自性。亦非彼种子。但就俱转不相离性。许是唯识。是彼对治种子性故者。是阿赖耶识对治。无分别智因性故。义如种种物和杂库藏。如种种毒所杂仙药。如有众病服阿伽陀。虽与秽毒多时俱转。然此良药非彼毒自性。亦非毒种子。此闻熏习种子亦尔

论曰。此中依下品熏习。成中品熏习。依中品熏习成上品熏习。依闻思修多。分修作得相应故

释曰。下中上品熏习等言。分明易了不须重释

论曰。又此正闻熏习种子。下中上品应知亦是法身种子。与阿赖耶识相违。非阿赖耶识所摄。是出世间最净法界等流性故。虽是世间而是出世心种子性。又出世心虽未生时。已能对治诸烦恼缠。已能对治诸险恶趣。已作一切所有恶业朽坏对治。又能随顺逢事一切诸佛菩萨。虽是世间应知初修业菩萨所得。亦法身摄。声闻独觉所得唯解脱身摄。又此熏习非阿赖耶识。是法身解脱身摄。如如熏习下中上品次第渐增。如是如是异熟果识次第渐减。即转所依既一切种所依转已。即异熟果识及一切种子无种子而转。一切种永断

释曰。又此正闻乃至应知亦是法身种子者。是略摽举自下广释。与阿赖耶识相违非阿赖耶识所摄者。非彼自性故。虽是世间者。似有漏故。而是出世心种子性者。是无漏心资粮性故。此中证相说名法身。依世间生名是世间。阿赖耶识中相杂俱转故。为欲显此熏习胜能故。说出世心虽未生时等已能对治诸烦恼缠者。此同类因展转相续。刹那势力能为对治。如火焚烧。已能对治诸险恶趣者。如有颂言

  诸有成世间　　上品正见者
  虽经历千生　　而不堕恶趣

彼先所作恶行势力。或堕恶趣故次说言。已作一切所有恶业。朽坏对治无始时来所作恶业。此闻熏习损彼功能。是故说名朽坏对治。法身摄者。是彼因故。解脱身摄亦如是说。此中法身与解脱身有差别者。谓解脱身唯永远离烦恼障缚。如村邑人离枷锁等所有禁系。息除众苦而无殊胜增上自在富乐相应。其法身者。解脱一切烦恼所知二种障缚并诸习气。力无畏等无量希奇妙功德众之所庄严。一切富乐自在所依。证得第一最胜自在。随乐而行。譬如王子先蒙灌顶。少有愆犯闭在囹圄。才得解脱即与第一最胜自在富乐相应。即转所依者。如服仙药转所依身。虽无命终受生而有舍劣得胜。无种子而转者。应知异熟果识唯无一切杂染种子。是故说断一切种。永断者。一切种子品类断故

论曰。复次云何犹如水乳。非阿赖耶识与阿赖耶识同处俱转。而阿赖耶识一切种尽。非阿赖耶识一切种增。譬如于水鹅所饮乳。又如世间得离欲时。非等引地熏习渐减。其等引地熏习渐增。而得转依

释曰。譬如于水鹅所饮乳。又如世间离欲转依等。其文易了不劳重释

论曰。又入灭定识不离身。圣所说故。此中异熟识应成不离身。非为治此灭定生故

释曰。如是已说杂染清净不成道理。决定证有阿赖耶识。复引灭定不成因缘。显发前力故。说又入灭定等言。除佛独觉若阿罗汉若不还果。及不退位诸菩萨等。余不能入。为显灭定与死差别。故说此识不离身。言识者不离阿赖耶识。何以故。灭定不能对治此故。非为治此而生灭定。所缘行相难了知故。非为对治不明了识而入灭定。不寂静性难了知故。是故灭定不能对治阿赖耶识。若无对治此则不灭。为治转识故此定生。所缘行相不寂静性易了知故。是故此定唯灭转识。于中不灭阿赖耶识

论曰。又非出定此识复生。由异熟识既间断已。离结相续无重生故

释曰。有执定中诸识虽灭。而出定时识还生故言不离身。为遮此义故说。又非出定等言。其文易了不须重释

论曰。又若有执。以意识故灭定有心此心不成定不应成故。所缘行相不可得故。应有善根相应过故。不善无记不应理故。应有想受现行过故。触可得故。于三摩地有功能故。应有唯灭想过失故。应有其思信等善根现行过故。拔彼能依。令离所依。不应理故。有譬喻故。如非遍行此不有故

释曰。又若有执以意识故灭定有心此心不成者。谓此定中不离身识决非意识。定不应成故者。是想与受俱不灭义。由彼意识与诸大地决不相离。想受二种俱不灭故定不应成。又此中识决非意识。所缘行相不可得故。一切意识不离所缘行相可得。此中无故彼不成有。又此中识决非意识。应有善根现行过故。由此定心决非不善亦非无记。何者唯善。谓此善心离无贪等决不得有。相应故善是彼宗故。善根既有。想受二种何不现行。又无贪等决不离触。故触可得。定所生触轻安为相。顺乐舍受故应有受。与触俱生。有受想等圣所说故应无灭定。或谓此中厌患想受。如痈箭等故生灭定。于此定中唯想受灭。为遮此计故复说言。于三摩地有功能等。三摩地中所能厌患。非唯此灭。何以故。无想定中由前方便。三摩地力。应有唯灭想过失故。若所厌患唯此灭者。无想定前唯厌患想无想定中应唯想灭。然汝不许。又如若离所依止灭。决定无有能依止灭故。于此中心亦应灭。如是灭定心若不灭。应思信等善根现行。彼若灭者。心定应灭。是故不应唯灭能依。既有所依拔彼能依。不应理故。有譬喻故者。谓有无想定是此中譬喻。如彼拔除不应理故此应俱灭。或有大种所造譬喻。如彼更互不相离故。又善等非遍行大地是定异故。可于一切心非遍有。想受二法是大地故。决定安住遍行类中。是故有识此二不有不应道理。为显斯意故复说言。如非遍行此不有故

论曰。又此定中由意识故执有心者。此心是善不善无记皆不得成。故不应理

释曰。又此定中不离身识决非意识。以善不善及无记性皆不成故。谓若意识决定。或善或是不善或复无记。然此意识且非是善。应有善根相应过故。如前已说。云何善心离无贪等。此等云何应离于触。此复云何应离遍行。受等心法。或复有执。加行善心所引发故。定心是善不由善根相应力故。此与彼论由相应力心得成善。安立相违。又于此中有何定缘其加行心。由无贪等相应故善。非于此定等流果心。又非此心是自性善。以自性善唯善根等入其数故。又此善心非胜义善。唯有解脱是决定故。或有复谓若能和合。名和合触。非一切触。皆能和合。今此中触。于能生受无所堪能。定加行时于彼受等已厌患故。破此邪执已如前说。谓彼即应唯灭此等。是故此中意识无受不应道理。又于此中有何因缘。若寻伺语行灭语则不转。想受等意行灭而意犹转。不可例言。如身行灭其身犹住。故意行灭意亦应住。由薄伽梵离身行外说有余因。令身安住。所谓饮食命根识等。是故虽无入息出息身犹可住。离想受等曾未见说有别意行。是故此中离想受等。安立有意不应道理。故此定中识非意识。又此中识亦非不善。定是善故。无想定中尚不许有一切不善。况趣解脱次第超越定中间行。灭尽定内得有不善。又于今时工巧等事无容得有故。三无记此中皆无。若许此中有异熟识。则是成立阿赖耶识。又若有说别有一种。非异熟行转名第五无记。如是所执唯有名想。如前说过皆不能离

论曰。若复有执色心无间生。是诸法种子。此不得成如前已说。又从无色无想天没。灭定等出不应道理。又阿罗汉后心不成。唯可容有等无间缘

释曰。若复有执者。谓经部师作如是执。色心无间生者谓诸色心前后次第相续而生。是诸法种子者。是诸有为能生因性。谓彼执言从前刹那色。后刹那色无间而生。从前刹那心。后刹那心及相应法无间而生。此中因果道理成就。何用复计阿赖耶识是诸法因。为遮此执故次说言。此不得成如前已说。如说二念不俱有等。复有何过谓无色没色界生时。前色种子。能生今色。理不得成。久断灭故。从无想没心想生时。及灭定等出心生时。前心种子能生后心皆不应理。久断灭故。又若离其俱生俱灭。摄受种子相应道理。但执唯有前刹那心能为种子。引生无间后刹那心。即阿罗汉后心不成。不应得入无有余依妙涅槃界。由最后心能为种子等无间缘生余心故。如是即应无无余依妙涅槃界。是故色心前后相生。但应容有等无间缘。及增上缘无有因缘

论曰。如是若离一切种子异熟果识。杂染清净皆不得成。是故成就如前所说相。阿赖耶识决定是有

释曰。如是若离一切种子异熟果识。如前所说种种过失之所随逐。虽无欲乐自事重故。然必应许阿赖耶识决定是有。如是名为反诘道理。此中亦有顺成道理。覆相显示方便因故。以无虚诳正论总相。成立大乘真是佛语。谓大乘教真是佛语。一切不违补特伽罗无我性故。阿赖耶识能诠之教。称所诠义佛所说故。如说刹那速灭等言。如佛余言。又诸大乘定是殊胜。与法有法不相违故。如说甚深缘起等教。余广决择。释难立难如理应知

论曰。此中三颂

  菩萨于净心　　远离于五识
  无余心转依　　云何汝当作
  若对治转依　　非断故不成
  果因无差别　　于永断成过
  无种或无体　　若许为转依
  无彼二无故　　转依不应理

释曰。复次若不信有阿赖耶识。如住转识转依不成。以结句颂三颂征难。所谓菩萨于净心等于净心者。谓于善识。远离于五识者。谓于意识。言无余者。除恶无记无余有漏善意识故。谓无漏中离余有漏故说无余。非即能治中。有所治随眠。心转依者。心之转依。云何汝当作者。若不信有阿赖耶识。汝当云何。作此转依。若许对治即是转依。彼非断故理不得成。非能对治即是永断。何者断因。谓由永断是能治果。是转依体。若许能治即是永断。果之与因应无差别立。能治因即断果故。无种或无体若许为转依者。显彼许别。是故言或多杂染种积集在心。或彼无种许为转依。或种体无许为转依。无彼二无故转依不应理者。以若有彼可说无种。或说无体非无有彼。可得说言无种无体。非出世心正现前时有彼可得。云何可说彼无种子。或体断灭

论曰。复次此阿赖耶识差别云何略说。应知或三种或四种。此中三种者。谓三种熏习差别故。一名言熏习差别。二我见熏习差别。三有支熏习差别。四种者。一引发差别。二异熟差别。三缘相差别。四相貌差别

释曰。此阿赖耶识差别云何者。谓已信解阿赖耶识相成就义。复问差别。答或三种或四种等。名言熏习差别者。谓我法用名言多故。有人天等我眼色等法。去来等用熏习差别。由此我法用影显现。诸识生起功能差别。我见熏习差别者。谓四烦恼所染污意。萨迦耶见力故。于阿赖耶识中。有能执我熏习差别。有支熏习差别者。谓福非福不动行增上力故。于天等诸趣中有无明等乃至老死。熏习差别

论曰。此中引发差别者。谓新起熏习。此若无者。行为缘识。取为缘有应不得成。此中异熟差别者。谓行有为缘。于诸趣中异熟差别。此若无者则无种子。后有诸法生应不成。此中缘相差别者。谓即意中我执缘相。此若无者。染污意中我执所缘应不得成

释曰。三种当释。且释四种故说。此中引发等言。引发差别。谓新起熏习者。谓最初名言所生起熏习。是名引发差别。由此熏习引发生故。此若无者行为缘。识取为缘有应不得成者。谓即此阿赖耶识待诸烦恼随眠力故。生现前住说名为有。异熟差别谓行有为缘于诸趣中异熟差别者。谓彼所引异熟差别。此若无者则无种子后有诸法生应不成者。谓若离根即无枝等。缘相差别谓即意中我执缘相者。谓即此阿赖耶识。染污意中萨迦耶见势力所起。缘执我时我执缘相。此若无者染污意中我执所缘应不得成者。若此缘相阿赖耶识差别无者。意中我执所缘不成

论曰。此中相貌差别者。谓即此识有共相。有不共相。无受生种子相。有受生种子相等。共相者谓器世间种子。不共相者谓各别内处。种子共相即是无受生种子。不共相即是有受生种子。对治生时唯不共相。所对治灭共相为他分别所持。但见清净。如瑜伽师于一物中种种胜解。种种所见皆得成立。此中二颂

  难断难遍知　　应知名共结
  瑜伽者心异　　由外相大故
  净者虽不灭　　而于中见净
  又清净佛土　　由佛见清净

复有别颂。对前所引种种胜解种种所见皆得成立

  诸瑜伽师于一物　　种种胜解各不同
  种种所见皆得成　　故知所取唯有识

此若无者诸器世间。有情世间。生起差别。应不得成

释曰。相貌差别多种不同。谓共相等种种差别。此中共相谓器世间种子者。是器世间影现识因。又共相者所谓相似自业异熟增上力故。一切可有能受用者。皆有相似影现识生。又不共相谓各别内处种子者。我执所缘故。名各别。在内身中眼等诸处故名内处。即是各别内处因义故。名种子。共相即是无受生种子者。是能生起无苦乐等。无损无益所依之因。非器世间。有苦乐等损益事故。又不共相即是有受生种子者。是能生起苦乐受等所依因故。对治生时者。谓道谛生时。唯不共相所对治灭者。各别内处诸种子灭。以相违故。共相为他分别所持但见清净者。由此共相是器世间故。修行者虽复内处分别永灭。而他相续分别所持。但可于彼证见清净观。彼清净如净虚空非水所烂。非地所依。非火所烧。非风所吹。云何于有义而得见清净。恐容他难故次说言。如瑜伽师于一物等种种胜解者。谓随种种金银草等。差别胜解。种种所见者。唯所见事说名所见于业多说鲁吒缘故。皆得成立者。谓随所见。种种金银草木等别皆得成立。难断难遍知者。谓所应断故名为断。所应遍知故名遍知。断与遍知极大勤苦。事犹不辨故说为难。结者如结难可断故。所以者何。以共有故。是共因义。言心异者。种种胜解各不同故。由外相大故者。是器世间。大安布义。言净者者。谓已转依。虽不灭者。谓即于此。其余有情分别持故不可全灭。又清净佛土由佛见清净者。谓即于彼未断色等分别。异生所见淤泥沙石瓦砾高下。不平株杌毒刺不净。粪土诸秽土中。已断色等分别。如来见金银等众宝所成清净佛土。如处秽碛见净园林。此若无者者。谓若无此共不共相。阿赖耶识诸器世间。有情世间生起差别应不得成者。净秽差别苦乐差别皆不应成

论曰。复有粗重相及轻安相。粗重相者谓烦恼随烦恼种子。轻安相者谓有漏善法种子。此若无者所感异熟无所堪能。有所堪能所依差别应不得成。复有有受尽相无受尽相。有受尽相者。谓已成熟异熟果。善不善种子。无受尽相者。谓名言熏习种子。无始时来种种戏论流转种子故。此若无者。已作已作善恶二业。与果受尽应不得成。又新名言熏习生起应不得成。复有譬喻相。谓此阿赖耶识。幻焰梦翳为譬喻故。此若无者。由不实遍计种子故。颠倒缘相应不得成。复有具足相不具足相。谓诸具缚者名具足相。世间离欲者名损减相。有学声闻及诸菩萨名一分永拔相。阿罗汉独觉及诸如来名烦恼障全永拔相。及烦恼所知障全永拔相。如其所应。此若无者。如是次第杂染还灭应不得成

释曰。粗重相者。恶故名粗。得此沉没故名粗重。即是烦恼及随烦恼所有种子。此若无者所有粗重无堪能性不应得有。轻安相者。如说相违轻而安隐有堪能性。是轻安相。有受尽相。谓已成熟异熟果等者。善恶种子既成熟已。不可重熟受用尽故。犹如种子既生芽已不可重生。无受尽相谓名言熏习种子者。即彼种子随缘增长。能起名言戏论因故。此若无者者。若无二相阿赖耶识。已作已作者。谓已作善及已作恶。与果受尽者。是已与果受用坏义。此破若无有受尽相。又新名言熏习生起应不得成者。谓都无有本无今有世间名言。一切名言皆因本旧名言种子。此破若无无受尽相。譬喻相者。谓由幻等能譬喻事。显所喻相。如幻事等是能生起不实见因。阿赖耶识亦复如是。此若无者者。谓若无有喻所喻相。阿赖耶识应无不实颠倒缘相。唯应能作实见缘相。余文易了不须重释

论曰。何因缘故。善不善法能感异熟。其异熟果无覆无记。由异熟果无覆无记。与善不善互不相违。善与不善互相违故。若异熟果善不善性。杂染还灭应不得成。是故异熟识唯无覆无记

释曰。如是已释阿赖耶识所有句义。异门训词体相决择及与差别。复欲显此能顺正行。故起问答。何因缘等无覆无记者。是无染无记义。由异熟果等辨无记因缘。无覆无记与善不善互不相违者。是共依故作无间业等世间离欲等。皆同有故。是故异熟识非善不善。勿与此二因果相违

摄大乘论释卷第三摄大乘论释卷第四

        无性菩萨造

        三藏法师玄奘奉　诏译

    所知相分第三之一

论曰。已说所知依。所知相复云何应见。此略有三种。一依他起相。二遍计所执相。三圆成实相

释曰。已说所知依者。谓不复当说。此者此所知相。略有三种者。谓一切法要有所应知所应断所应证差别故。依他起相者。谓依业烦恼所取能取。遍计随合他而得起故。如是相者何所表知。谓依他起相。遍计所执相者。谓永无相。永无相者是遍计所执。所取能取补特伽罗。及法有性之所相故。云何非有可为所相。谓即如是而分别故。由薄伽梵说如是言。乃至实有不知实有。乃至非有不知非有。如是实有知为实有。若非实有知非实有。圆成实相者。谓即于彼遍计所执所取能取。或我或法无性之性。用彼为量所了境性。于彼遍知方能了别。遍计所执决定非有。有相违性故非为境性故

论曰。此中何者依他起相。谓阿赖耶识为种子。虚妄分别所摄诸识。此复云何。谓身身者受者识。彼所受识彼能受识。世识数识。处识言说识。自他差别识。善趣恶趣死生识。此中若身身者受者识。彼所受识彼能受识。世识数识处识言说识。此由名言熏习种子。若自他差别识。此由我见熏习种子。若善趣恶趣死生识。此由有支熏习种子。由此诸识一切界趣杂染所摄。依他起相虚妄分别皆得显现。如此诸识皆是虚妄分别所摄。唯识为性。是无所有非真实义显现所依。如是名为依他起相。此中何者遍计所执相。谓于无义唯有识中。似义显现。此中何者圆成实相。谓即于彼依他起相。由似义相永无有性

释曰。谓身身者受者识者。如后当说。眼等六内界为性。如其所应眼等五识所依意界名身者识。第六意识所依意界名受者识。彼所受识者如后当说。是色等六外界。彼能受识者如后当说。是六识界。世识者谓似三时影现。数识者。谓似一等算数影现。处识者。谓似聚落园等影现。言说识者。谓似见闻觉知言说影现。自他差别识者。谓身等识。我我所执相续不断执我我所。他他所等有差别故。善趣恶趣死生识者。谓似天人及奈落迦傍生饿鬼死生影现。此中若身身者等乃至言说识。此由名言熏习种子者。谓彼身等皆由名言熏习种子。识所变现无别事故。若自他差别识。此由我见熏习种子者。谓染污意我见熏习为因变现。若善趣恶趣死生识此由有支熏习种子者。谓由有支熏习为因变现。如此诸识皆是虚妄分别所摄者。如前所说身等诸识所取能取。虚妄分别安立为性。唯识为性者。由邪分别二分显现。实唯是识。善等法中虽无邪执。缘起力故二分显现。亦唯是识。是无所有。非真实义。显现所依者。所取色等名无所有。能取识等名非真实。此二皆是遍计所执并名为义。虚妄分别所摄诸识。是此二种显现因缘故名所依。如是名为依他起相者。如上所辨阿赖耶识为种子等。皆说名为依他起相。谓于无义。唯有识中似义显现者。实无所取及能取义。唯有虚妄分别所摄。种种识中遍计所取。似义显现。谓即于彼依他起相。由似义相。永无有性者。谓于缘起心及心法。所现影中由横计相。永无所显。真如实性。此即名为圆成实相。又一切法从因缘生。唯识为性。当知皆名依他起相。颠倒横计似义显现。当知皆名遍计所执相。依他起上遍计所执永无所显。真如实性。当知皆名圆成实相。譬如鹿爱自相续力。安立似水所取能取邪遍计性。当知名为依他起相横计实有。水事显现。当知名为遍计所执相。即于如是鹿爱事中。横计水相。毕竟无性。当知是名圆成实相。又遍计所执相即是遍计所执自性。依他起相即是依他起自性。亦名分别自性。圆成实相即是圆成实自性。亦名法性自性。如是三种即是宣说。应知应断应证三法。如大般若波罗蜜多经中亦说。佛告慈氏。若于彼彼行相事中。遍计为色为受为想为行为识。乃至为一切佛法依止。名想施设言说遍计。以为诸色自性。乃至一切佛法自性是名遍计所执。色乃至遍计所执一切佛法。若复于彼行相事中。唯有分别法性安立。分别为缘起诸戏论。假立名想施设言说。谓之为色乃至谓为一切佛法。是名分别色乃至分别一切佛法。若诸如来出现于世。若不出世。法性安立法界安立。由彼遍计所执色故。此分别色于常常时。于恒恒时是真如性。无自性性。法无我性。实际之性。是名法性色。乃至由彼遍计所执一切佛法故。此分别一切佛法于常常时。于恒恒时。乃至是名法性一切佛法。广说如经

论曰。此中身身者受者识。应知即是眼等六内界。彼所受识应知即是色等六外界。彼能受识应知即是眼等六识界。其余诸识应知是此诸识差别

释曰。此诸识者。谓如前说身等为初。能受为后。言差别者。是此诸识差别性故。谓即于此有为识中。皆有已行现行当行差别性故。依之建立世影现识。于此诸识皆有一等差别性故。依之建立数影现识。于所受识有上下等差别性故。依之建立处影现识。余类应知

论曰。又此诸识皆唯有识。都无义故。此中以何为喻显示。应知梦等为喻显示。谓如梦中都无其义。独唯有识。虽种种色声香味触舍林地山似义影现。而于此中都无有义。由此喻显应随了知。一切时处皆唯有识。由此等言应知复有幻诳鹿爱翳眩等喻。若于觉时一切时处。皆如梦等唯有识者。如从梦觉便觉梦中皆唯有识。觉时何故不如是转。真智觉时亦如是转。如在梦中此觉不转。从梦觉时此觉乃转。如是未得真智觉时此觉不转。得真智觉此觉乃转

释曰。一切唯识都无有义。举梦等喻以显示者。共成立故如梦中等。其文易了无劳重释

论曰。其有未得真智觉者。于唯识中云何比知。由教及理应可比知。此中教者。如十地经薄伽梵说。如是三界皆唯有心。又薄伽梵解深密经亦如是说。谓彼经中慈氏菩萨问世尊言。诸三摩地所行影像彼与此心当言有异。当言无异。佛告慈氏。当言无异。何以故。由彼影像唯是识故。我说识所缘唯识所现故。世尊若三摩地所行影像。即与此心无有异者。云何此心还取此心。慈氏无有少法能取少法。然即此心如是生时。即有如是影像显现。如质为缘还见本质。而谓我今见于影像。及谓离质别有所见。影像显现此心亦尔。如是生时相似有异所见影现。即由此教理亦显现。所以者何。于定心中随所观见。诸青瘀等所知影像一切无别。青瘀等事但见自心。由此道理菩萨于其一切识中。应可比知。皆唯有识无有境界。又于如是青瘀等中。非忆持识见所缘境现前住故。闻思所成二忆持识。亦以过去为所缘故。所现影像得成唯识。由此比量。菩萨虽未得真智觉。于唯识中应可比知

释曰。由教及理者。由至教量。及由比量。虽未证得唯识真智。应可比知唯识无境。十地经者。于彼经中宣说菩萨十种地义。此即安立十地行相名句文身。识所变现聚集为体。谓彼圣者。金刚藏识所变影像为增上缘。闻者身中识上影现。似彼法门。如是展转传来于今。说名为教。唯有心者心识是一。唯声为遣所取境义。由彼无故能取亦无。不遮心法由彼与心不相离故。如说若无心所有法。心未曾转。若尔灭定何故唯心。是彼宗过。我大乘宗。若处有心必定亦有心相应法。若处无有心相应法心亦定无。如是三界皆唯有心。此言显示三界唯识。言三界者。谓与欲等爱结相应。堕在三界。此唯识言成立唯有诸心心法。无有三界横计所缘。此言不遣真如所缘依他所缘。谓道谛摄。根本后得二种所缘。由彼不为爱所执故。非所治故。非迷乱故。非三界摄亦不离识故不待说。若尔应说如是二界。无色界中经部唯有心心法故。此难不然。识所取义皆无义故非但色无。说名唯识。何者亦无。余虚空等识所取义。经部诸师许无色界。诸心心法。是无色相。无体无实。所取境义显现所依。恐彼执为非心心法。故说三界皆唯有心。解深密经所明意趣。如十地释。经谓教法。三摩地者。是能令心住一境性。心法为体。此所缘境说名所行。本境名质。似彼现者。说名影像。我说识所缘唯识所现故者。我说在外识所缘境。唯是内识之所显现。即是所缘境识为自性义。此意说言识所缘境。唯是识上所现影像无别有体。云何此心还取此心者。此显作用于自相违。慈氏无有少法能取少法者。此释前难。无作用故。谓一切法作用作者皆不成故。如是生时者。缘起诸法威力大故。即一体上有二影生。更互相望不即不离。诸心心法由缘起力。其性法尔如是而生。如质为缘还见本质等者。譬如依止自面等质。于镜等中还见本质。由迷乱故谓我见影。由镜等缘威力大故。虽无异影而似别有影像显现。此心亦尔。如是生时等者。谓心心法种种忆念。分别等缘功能大故。如是生时。虽无有异三摩地等所行影像。而似别有影像显现。即由此教理亦显现者。谓此教中亦即兼显比量道理。所以者何。于定心中等者。序述教中有别理义。谓青瘀等不离于心。随所乐欲而显现故。譬如梦中所见青瘀等。又于如是青瘀等中。非忆持识等者。恐彼异计故作此说。谓若有人作如是计。由彼先于淡泊路等。见骨锁等今犹忆持。为三摩地所行影像。为遮此计故言。又于如是青瘀等中。非忆持识见所缘境现前住故。若此所缘即是昔日所忆持者。如昔所见方处决定。如昔所受应如是忆。然不如是修所成智。是真现量所见境界分明现前。非忆持识有如是事。若尔闻思所成两慧相应之识。忆持本事彼二所行。应离于识此亦不然。由彼闻等二忆持识。缘过去故。过去无故。所缘影像并唯是识。譬如忆昔自己少年。是故此识现所忆持。并唯有识所念空故。如观行者所想现前。不净骨锁女人影像。由此比量等语义分明不须重释

论曰。如是已说种种诸识。如梦等喻。即于此中眼识等识可成唯识。眼等诸识既是有色。亦唯有识。云何可见。此亦如前由教及理

释曰。教即十地解深密经。理即经中所说道理。谓三摩地所行影像。及梦等喻皆如前说

论曰。若此诸识亦体是识。何故乃似色性显现。一类坚住相续而转。与颠倒等诸杂染法为依处故。若不尔者于非义中。起义颠倒应不得有。此若无者。烦恼所知二障杂染应不得有。此若无者。诸清净法亦应无有。是故诸识应如是转。此中有颂

  乱相及乱体　　应许为色识
  及与非色识　　若无余亦无

释曰。若此诸识亦体是识等者。此问色识一类坚住相续转因。言一类者是相似义。前后一类无有变异。亦无间断故名坚住。即此说名相续而转。与颠倒等诸杂染法为依处故者。等即等取烦恼业生诸杂染法。眼等诸识与颠倒等诸杂染法。作所依处。所依处者即是因义。故者须也。观彼问意而作此答。谓无义中显现似于眼等诸识。一类坚住相续而转。由此起彼颠倒等法。若不尔者。若不如是转。于非义中起义颠倒。应不得有。若无颠倒。烦恼所知二障杂染应不得有。无因缘故。若无杂染清净亦无。要息杂染显清净故。是故诸识应如是转者。眼等诸识应如是转。为不因力诸法得生非须力耶。不尔随问兴答言故。彼问所须不问因种。由彼不执别有诸色。但问何须。阿赖耶识变作诸色。不唯作识故作此答。乱相许为似色变识。乱体许为非色变识。顺结颂法故文隔越。其义相属。若无似色所变因识。非色果识不应得有。以若无境有境亦无

论曰。何故身身者受者识。所受识能受识。于一切身中俱有和合转。能圆满生受用所显故

释曰。何故身等如前为问。能圆满等如前而答。由此五识一切身中无不具足。受用所显若阙一支即不圆满

论曰。何故如说世等诸识差别而转。无始时来生死流转无断绝故。诸有情界无数量故。诸器世界无数量故。诸所作事展转言说无数量故。各别摄取受用差别无数量故。诸爱非爱业果异熟受用差别无数量故。所受死生种种差别无数量故

释曰。何故如说世等识等如前为问。等者。等取数处言说自他差别。善趣恶趣及与死生。六变现识无始时来。乃至所受死生差别无数量故者。如数次第显世等识须说之果

论曰。复次云何安立如是诸识。成唯识性略由三相。一由唯识无有义故。二由二性有相有见二识别故。三由种种种种行相而生起故。所以者何。此一切识无有义故。得成唯识有相见故。得成二种若眼等识以色等识为相。以眼识识为见。乃至以身识识为见。若意识。以一切眼为最初。法为最后。诸识为相。以意识识为见。由此意识有分别故。似一切识而生起故。此中有颂

  唯识二种种　　观者意能入
  由悟入唯心　　彼亦能伏离

释曰。复次云何安立。如是诸识等者。谓依前理更以别理。种种征问。由唯识者。是无义义。故次说言无有义故。所说唯言专为遣义。无义之理少分已说。少分当说。由二性者。谓相及见。于一识中有相有见。二分俱转相见二分。不即不离。始从眼识乃至身识随类各别。变为色等。种种相识。说名相分眼等诸识了别。境界能见义边说名见分。又所取分名相。能取分名见。是名二性。由种种者。种种行相而生起故。于一识中一分变异似所取相。一分变异似能取见。此之二分各有种种差别行相。俱时而起。若有不许一识一时有种种相应。无一时觉种种境。若意识以一切眼为最初等者。谓彼意识有能一时取一切义。增上势力眼识为初。法识为后。所安立相是其相分。即此意识了别义边说名见分。由此意识遍分别故。似一切识而生起故。是故意识说名相名见。亦名种种。于伽陀中诸瑜伽师能入唯识二性种种。遣外境界。竟为伏离能取之心。所缘无故。能缘之识亦不得有。了别无故了者亦无。非无了别而有了者。勿境界相无分别事。亦名有境能分别心。若出世心虽离分别能取所取。然有内证圣智所依。能缘所缘平等性在

论曰。又于此中有一类师说一意识。彼彼依转得彼彼名。如意思业名身语业

释曰。又于此中有一类师说一意识等者。此显诸师所见差别。谓有一类菩提萨埵。欲令唯有一意识性。依于彼彼眼等生时。得彼彼名。所谓眼识乃至意识。此中无别余识种类。此如何等如意思业。如一意思在身处所。发动于身则名身业。在语处所发动于语则名语业。与意相应名为意业。意识亦尔

论曰。又于一切所依转时。似种种相二影像转。谓唯义影像。及分别影像。又一切处亦似所触影像而转。有色界中。即此意识依止身故。如余色根依止于身

释曰。或谓若尔如是意识应无分别所依钝故。如眼等识。夫能依者。皆顺所依如染污意为杂染依。意识俱转亦成杂染。为解此难说于一切所依转等。一切所依者。谓眼等。所依转时者。生起时。似种种相二影像转者。谓似种种所取能取二影像转。为释此故次复说言。谓唯义等唯一意识。一分似义影像显现。第二于义分别而生。是故无有无分别过。又一切处亦似所触影像而转者。谓于定中领纳分别轻重等触。而非散乱。随顺彼故。有色界中者。非于无色界。何以故。即此意识依止身故。如余色根依止于身者。如余眼等有色诸根依止身故。即于此身能作损益。意识亦尔。有色界中依止身故。即于此身领纳分别。能作损益

论曰。此中有颂

  若远行独行　　无身寐于窟
  调此难调心　　我说真梵志

释曰。说一意识菩提萨埵。引教证言。若远行等游历一切所识境故。名为远行。为证此义复说独行。无第二故。言无身者。无形质故。寐于窟者。居在内故。言调此者。于如是心作自在故。难调心者性[怡-台+龍]悷故

论曰。又如经言。如是五根所行境界。意各能受意为彼依

释曰。复引第二圣教为证。如是五根所行境界。意各能受者。谓此五根所行境界。唯是意识一一各别能领受义。意为彼依者。由此增上彼生起故

论曰。又如所说十二处中。说六识身皆名意处

释曰。复引第三圣教为证。说六识身皆名意处者。所谓宣说意识事故

论曰。若处安立阿赖耶识识为义识。应知此中余一切识是其相识。若意识识及所依止是其见识。由彼相识是此见识生缘相故。似义现时能作见识生依止事。如是名为安立诸识成唯识性

释曰。若处安立阿赖耶识识为义识者。义是因义。即是安立阿赖耶识。以为因识。余一切识者。谓身等识。是其相识者。是所缘相是所行故。若意识识及所依止者。谓第六识及所依止。无间过去意及与染污意。此二能作生起杂染所依性故。是其见识者。能分别故。由彼相识是此见识生缘相故者。谓阿赖耶识所变异相。是二见识生缘相故。似义现时者。谓意见识似义现时。能作见识生依止事者。谓眼等识能与见识。作生依事

论曰。诸义现前分明显现。而非是有。云何可知。如世尊言。若诸菩萨成就四法。能随悟入一切唯识。都无有义。一者成就相违识相智。如饿鬼傍生及诸天人。同于一事见彼所识有差别故。二者成就无所缘识。现可得智。如过去未来梦影缘中有所得故。三者成就应离功用无颠倒智。如有义中能缘义识。应无颠倒不由功用。知真实故。四者成就三种胜智随转妙智。何等为三。一得心自在一切菩萨。得静虑者。随胜解力诸义显现。二得奢摩他修法观者。才作意时诸义显现。三已得无分别智者。无分别智现在前时。一切诸义皆不显现。由此所说三种胜智。随转妙智及前所说三种因缘。诸义无义道理成就

释曰。复为成立无有境义。故引余教及余道理。谓诸菩萨成四法等。相违识相智者。更相违反故名相违。相违者识名相违识。生此识因说名为相。了知此相唯内心变外义不成。故无有义说名为智。如饿鬼傍生及诸天人等者。谓于饿鬼自业变异增上力故。所见江河皆悉充满脓血等处。鱼等傍生即见舍宅游从道路。天见种种宝庄严地。人见是处有清冷水波浪湍洄。若入虚空无边处定。即于是处唯见虚空。一物实有为互相违。非一品类智生因性不应道理。云何于此一江河中。已有脓血屎尿充满。持刀杖人两岸防守。复有种种香洁舍宅。清净街衢众宝严地。清冷美水波浪湍洄。虚空定境。若许外物。都无实性。一切皆从内心变现。众事皆成。如有颂言

  于一端严淫女身　　出家耽欲及饿狗
  臭尸昌艳美饮食　　三种分别各不同

无所缘识现可得智等者。过去未来皆非实有。此与经部共许成就。梦境实无一切共了。诸三摩地所行影像已说非有。亦非忆持。水境等中面等影像都无所有。如前已说。此中无境而识得成。应离功用无颠倒智。本文虽显而少助说。若有欲令如所得义即真实有。应不用功自然解脱。一切有情皆见实故。得心自在者。得心调顺堪有所作。得静虑者。谓诸声闻及独觉等。若已证得清净静虑心一境性。乐静思虑名静虑者。随胜解力。诸义显现者。谓随增上意解势力如所愿乐。欲令地等变成水等。皆悉显现。得奢摩他者。谓已证得奢摩他定。滋润相续令心寂静。所言修者。空境相应。或四圣谛所缘相应。止观双运故名相应。与此相应故名为修法观者。谓此后得观契经等。正法妙慧才作意时。诸义显现者。谓契经等正法教中。随于一种无常等义。如如作意思惟刹那速灭等性。如是如是非一品类境界显现。无分别智现在前时。一切诸义皆不显现者。无分别智后当广释。义若实有此智应无。非有分别。无分别成。义若是实有。无分别智生不应不显。现此智如实缘境义故。由此无间所说道理。及前所说三种因缘。诸义皆无道理成就

论曰。若依他起自性实唯有识。似义显现之所依止云何成依他起。何因缘故名依他起。从自熏习种子所生。依他缘起故名依他起。生刹那后无有功能自然住故。名依他起

释曰。云何成依他起者。问所解法。何因缘故名依他起者。问所释词解不解品。由此双关能了义故。余二自性两问亦尔。依此诸问两两酬答。从自熏习种子等者。谓从遍计所执名言熏习种生。依自种子他所生故。名依他起。此说彼体依他而生。生刹那后无有功能自然住者。此说彼体依他而住。由此二因名依他起

论曰。若遍计所执自性依。依他起实无所有。似义显现。云何成遍计所执。何因缘故名遍计所执。无量行相意识遍计。颠倒生相故名遍计所执。自相实无唯有遍计所执可得。是故说名遍计所执

释曰。依依他起者。谓依唯识依他起性。实无所有。似义显现者。谓实无体但似其义相貌显现。若体实无云何名义。为避此难。是故说言似义显现。谓由名言熏习种子。虽无实体而似有义相貌显现。是故名义如幻像等。似有显现。言显现者。是明了义无而似有明了现前故名显现。即此似义为彼自性。如自性受。无量行相者。种种我法境界影像。意识遍计者。谓即意识说名遍计。颠倒生相者。谓是乱识所取能取。义相生因故。名遍计所执者。谓即遍计所执义相。名为遍计所执自性。自相实无唯有遍计所执可得者。谓于实无我及法中。唯有遍计所执影像相貌可得。由此故名遍计所执

论曰。若圆成实自性是遍计所执永无有相。云何成圆成实。何因缘故名圆成实。由无变异性故名圆成实。又由清净所缘性故。一切善法最胜性故。由最胜义名圆成实

释曰。由无变异性故名圆成实等者。应知此性。常无变故。又由清净所缘性故。一切善法最胜性故。圆满成就真实为性

论曰。复次有能遍计。有所遍计。遍计所执自性乃成。此中何者能遍计。何者所遍计。何者遍计所执自性。当知意识是能遍计。有分别故。所以者何。由此意识用自名言熏习为种子。及用一切识名言熏习为种子。是故意识无边行相。分别而转。普于一切分别计度故名遍计。又依他起自性名所遍计。又若由此相令依他起自性成所遍计。此中是名遍计所执自性。由此相者。是如此义。复次云何遍计能遍计度。缘何境界。取何相貌。由何执着。由何起语。由何言说。何所增益。谓缘名为境。于依他起自性中取彼相貌。由见执着。由寻起语。由见闻等四种言说而起言说。于无义中增益为有。由此遍计能遍计度

释曰。复次有能遍计等者。为欲分别遍计所执故说此言。当知意识是能遍计有分别故者。由有显示随念分别所杂糅故。用自名言熏习为种子者。无始生死所有意识。戏论名言熏习种子。为此生因。及用一切识名言熏习为种子者。谓用无边色等影识名言熏习种子为因。似彼生故。是故一切无边行相分别而转。又依他起自性名所遍计者。谓此一分眼等诸相是所计业。又若由此相令依他起自性成所遍计。此中是名遍计所执自性者。谓由此品类缘相是名遍计所执自性。是如此义者。是如此品类缘相义。复次云何遍计能遍计度者。作问生起为欲宣说遍计所执自性差别。缘名为境者。谓色受等天与等名于义相应。起诸遍计。说异行相为识其名非无有名能于其义起诸分别。于依他起自性中取彼相貌者。是执自相义。由能取相说名为想。如其所想作是言说。或于依他起自性中取眼等相。由见执著者。由五品类推求行转。起诸执着。取相貌已起执着故。是于相貌坚执着义。由见推求于义决定。起执着已欲为他说。由寻起语者。如契经说。由寻由伺而说语言。非无寻伺能说语言。由见闻等四种言说而起言说者。由见闻觉知四种言说而起言说。如缘似蛇绳等相貌。取盘曲等种种相貌。自执着已为觉悟他。说如是言。我已见蛇。我已见蛇。此亦如是。他闻是已复更增益。谓为实有

论曰。复次此三自性为异为不异。应言非异非不异。谓依他起自性。由异门故成依他起。即此自性由异门故成遍计所执。即此自性由异门故成圆成实。由何异门此依他起成依他起。依他熏习种子起故。由何异门即此自性成遍计所执。由是遍计所缘相故。又是遍计所遍计故。由何异门即此自性成圆成实。如所遍计毕竟不如是有故

释曰。非异者。谓依他起性。与遍计所执有非有故。有望于有。可得言异。非望非有兔角等无。非不异者。有与非有不成一故依他起性与圆成实亦复如是。性不清净性清净故。今复依止异门意趣。此三自性或成一性。或成异性。由是遍计所缘相故。又是遍计所遍计故者。由依他起。是我色等遍计所执所依止故。又依他起。是我色等。意识遍计。所遍计故。由此意趣假说依他起。为遍计所执。如所遍计毕竟不如是有故者。于依他起如所显现。毕竟无故。如是即说三种自性不全成异。亦非不异。观待别故。若时观待熏习种子所生义边成依他起。不即由此成余二性。若时观待遍计所缘成遍计执。不即由此成余二性。若时观待遍计所执毕竟无边。成圆成实。不即由此成余二性

论曰。此三自性各有几种。谓依他起略有二种。一者依他。熏习种子而生起故。二者依他杂染清净性不成故。由此二种依他别故。名依他起。遍计所执亦有二种。一者自性遍计执故。二者差别遍计执故。由此故名遍计所执。圆成实性亦有二种。一者自性圆成实故。二者清净圆成实故。由此故成圆成实性

释曰。依他熏习种子而生起故者。由托因缘而得生故名依他起。依他杂染清净性不成故者。由分别时成杂染性。无分别时成清净性。依二分故名依他起。自性遍计者。谓总执取眼等有法事体。差别遍计者。谓别执取。常无常等义别法义。自性圆成实者。谓有垢真如。清净圆成实者。谓离垢真如

论曰。复次遍计有四种。一自性遍计。二差别遍计。三有觉遍计。四无觉遍计。有觉者谓善名言。无觉者谓不善名言

释曰。善名言者。谓自意趣在语前行。领解具足故名有觉。与此相违说名无觉

论曰。如是遍计复有五种。一依名遍计义自性。谓如是名有如是义。二依义遍计名自性。谓如是义有如是名。三依名遍计名自性。谓遍计度未了义名。四依义遍计义自性。谓遍计度未了名义。五依二遍计二自性。谓遍计度此名此义如是体性

释曰。依名遍计名自性者。谓如生在椰子洲人。闻说牛声不了其义。数数分别如是牛声。依义遍计义。自性者。谓曾未习想与有想。更互相应欻见牛身。数数分别如是牛义。依二遍计二自性者。谓依假立能诠所诠分别二种

论曰。复次总摄一切分别。略有十种。一根本分别。谓阿赖耶识。二缘相分别。谓色等识。三显相分别。谓眼识等并所依识。四缘相变异分别。谓老等变异。乐受等变异。贪等变异逼害时节代谢等变异。捺落迦等诸趣变异。及欲界等诸界变异。五显相变异分别。谓即如前所说变异。所有变异。六他引分别。谓闻非正法类。及闻正法类分别。七不如理分别。谓诸外道闻非正法类分别。八如理分别。谓正法中闻正法类分别。九执着分别。谓不如理作意类。萨迦耶见为本。六十二见趣相应分别。十散动分别。谓诸菩萨十种分别

释曰。根本分别者。谓阿赖耶识。是余分别根本自性。亦是分别故名根本分别。缘相分别者。谓分别色等有如是缘相。显相分别者。谓眼识等并所依识。显现似彼所缘相故。缘相变异分别者。谓似色等影识变异所起分别。老等变异者。谓色等识似老等相起诸变异。何以故。外内色等皆有老等转变相故。等者等取病死变异。乐受等变异者。由乐受故身相变异。如说乐者。面目端严。等者等取苦及不苦不乐受。贪等变异者。谓由贪等身相变异。等者等取嗔痴忿等。如说忿等恶形色等。逼害时节代谢等变异者。谓杀缚等令身相等生起变异。时节代谢亦令内外身树色等。形相改变。如说寒等所逼切时。身等变异。捺落迦等诸趣变异者。等即等取一切恶趣。彼处色等变异共了。及欲界等诸界变异者。等取色界无色界中。无似色等影像识故。于诸天中及静虑中。亦有有情及器色等种种变异。如末尼珠威神力故。种种净妙光色变异。显相变异分别者。谓由眼等所依根故。令似色等影像显现。眼识等识种种变异。即于此中起诸分别。即如前说老等变异。随其所应而起变异。何以故。如说眼等根有利钝识明昧故。如无表色所依变异彼亦变异。由乐受等变异亦尔。如说乐者。心安定故。如说苦者心散动故。贪等逼害时节代谢变异亦尔。捺落迦等及欲界等。依身变异识亦变异如应当知。无色界中亦有受等所作变异。诸识分别他引分别者。谓善恶友亲近所起。及与听闻正非正法为因分别。即是外道迦比罗等。及正法中诸骚揭多所有分别。名不如理如理分别。如是二种随其所应。能生邪见正见相应二种分别。萨迦耶见为因所起六十二见相应分别。即梵网经中前际后际中际分别。谓我过去为曾有耶。如是等分别名执着分别。言见趣者。是品类义。散动分别者。散乱扰动故名散动。此即分别。是故说名散动分别。此即扰乱无分别智。何以故。由此扰乱般若波罗蜜多故。无分别智即是般若波罗蜜多。谓诸菩萨十种分别者。谓诸菩萨能发语言他引而转。不称真理十种分别。何以故。证会真理若正现前不可说故

论曰。一无相散动。二有相散动。三增益散动。四损减散动。五一性散动。六异性散动。七自性散动。八差别散动。九如名取义散动。十如义取名散动。为对治此十种散动。一切般若波罗蜜多中说无分别智。如是所治能治应知。具摄般若波罗蜜多义

释曰。于一切般若波罗蜜多中。具说如是十种散动对治。且如说言。世尊。云何菩萨应行般若波罗蜜多。舍利子。是菩萨实有菩萨。不见有菩萨。何以故。色自性空不由空故。色空非色。色不离空。色即是空。空即是色。何以故。舍利子。此但有名。谓之为色。此自性无生无灭无染无净。假立客名。别别于法而起分别。假立客名随起言说。如如言说如是如是。生起执着。如是一切菩萨不见。由不见故不生执着。如说于色乃至于识当知亦尔。此中为对治无相散动故。彼经说言实有菩萨等。谓实有空为菩萨体。为对治有相散动故。即彼经言不见有菩萨等。谓遍计所执自性永无有故。为对治增益散动故。即彼经言色自性空等。谓即遍计所执自性永无有故。为对治损减散动故。即彼经言不由空故等。谓彼法性是实有故为对治一性散动故。即彼经言色空非色等。净不净境性各别故。为对治异性散动故。即彼经言。色不离空等。谓遍计所执色自性无所有。即是空故。为对治自性散动故。即彼经言此但有名谓之为色等。为对治差别散动故。即彼经言无生无灭等。为对治如名取义散动故。即彼经言假立客名别别于法而起分别等。为对治如义取名散动故。即彼经言。假立客名随起言说。如如言说如是如是生起执着。如是一切菩萨不见。由不见故不生执着。此意说言。于名于义如实了知无妄执着

论曰。若由异门。依他起自性有三自性。云何三自性不成无差别。若由异门成依他起。不即由此成遍计所执及圆成实。若由异门成遍计所执。不即由此成依他起及圆成实。若由异门成圆成实。不即由此成依他起及遍计所执

释曰。此义如前不须重释

摄大乘论释卷第四摄大乘论释卷第五

        无性菩萨造

        三藏法师玄奘奉　诏译

    所知相分第三之二

论曰。复次云何得知如。依他起自性。遍计所执自性。显现而非称体。由名前觉无称体相违故。由名有众多多体相违故。由名不决定杂体相违故。此中有二颂

  由名前觉无　　多名不决定
  成称体多体　　杂体相违故
  法无而可得　　无染而有净
  应知如幻等　　亦复似虚空

释曰。如依他起。遍计所执分虽显现可得。而非称彼体。为显此义故。说由名前觉无等。若依他起与遍计所执同一相者。离取其名于遍计所执应生其觉。如不可说自所领受。现量所得依他起中。不待于名而生其觉。既无此事。故依他起遍计所执。其体相称与理相违。由名有众多多体相违故者。由意解力。依他起中计度于义。于一义中立众多名。如尼犍荼。书一物立多名。于一牛上立种种名。非于一物有多自性。而不相违故。依他起遍计所执不同一相。由名不决定。杂体相违故者。于多物类随其所欲建立一名。又一种名。随处随时别目诸义。若名与义同一相者。义应相杂。既无此事故不如名而有其义。于伽他中。初一伽他。以句略摄上所说义。易受持故。后一伽他就遍计所执及圆成实。释通疑难

论曰。复次何故如所显现。实无所有而依他起自性非一切。一切都无所有。此若无者。圆成实自性亦无所有。此若无者。则一切皆无。若依他起及圆成实自性无有。应成无有染净过失。既现可得杂染清净。是故不应一切皆无。此中有颂

  若无依他起　　圆成实亦无
  一切种若无　　恒时无染净

释曰。非一切都无所有者。非一切种显现所依所缘根本都无所有。又一切者。谓一切时。圆成实自性亦无所有者。若无杂染清净亦无。问二性若无。圆成实性最应成就。何故言无。答自性清净。圆成实性可尔。离垢清净。圆成实性不尔。颂文易了不须重释

论曰。诸佛世尊于大乘中说方广教。彼教中言。云何应知遍计所执自性。应知异门说无所有。云何应知依他起自性。应知譬如幻焰梦像光影谷响水月变化。云何应知圆成实自性。应知宣说四清净法。何等名为四清净法。一者自性清净。谓真如空实际无相胜义法界。二者离垢清净。谓即此离一切障垢。三者得此道清净。谓一切菩提分法波罗蜜多等。四者生此境清净。谓诸大乘妙正法教。由此法教清净缘故。非遍计所执自性。最净法界等流性故。非依他起自性。如是四法总摄一切清净法尽。此中有二颂

  幻等说于生　　说无计所执
  若说四清净　　是谓圆成实
  自性与离垢　　清净道所缘
  一切清净法　　皆四相所摄

释曰。大乘教中。欲方便说三种自性。故先为问应知异门。说无所有者。说遍计所执即是异门。说无所有毕竟无故。依他起性如幻焰等义之差别次后当说。自性清净者。谓此自性异生位中亦是清净。谓真如者性无变故。是一切法平等共相。即由此故。圣教中说一切有情有如来藏。空者。谓于依他起上遍计所执。永无所显真实理性。言实际者真故名实。究竟名际。际声即是边际言故。如弓边际。言无相者。永离一切色等相故。言胜义者。即是胜智所证义故。言法界者。谓是一切净法因故。此法界声是法界因。言如金界等离垢清净。其文易了不须重释。得此道清净者。是能证得离垢真如清净道义。言菩提者。永断烦恼及所知障。无垢无碍智为自性。随顺彼故说名为分。即念住等三十七品。及与十种波罗蜜多。波罗蜜多后当广说。等者。等取一切圣道。生此境清净者。此即此前菩提分等所说圣道。余文二颂其义易了。不须重释

论曰。复次何缘如经所说。于依他起自性说幻等喻。于依他起自性。为除他虚妄疑故。他复云何于依他起自性有虚妄疑。由他于此有如是疑。云何实无有义而成所行境界。为除此疑说幻事喻。云何无义心心法转。为除此疑说阳焰喻。云何无义有爱非爱受用差别。为除此疑说所梦喻。云何无义。净不净业爱非爱果差别而生。为除此疑说影像喻。云何无义种种识转。为除此疑说光影喻。云何无义种种戏论言说而转。为除此疑说谷响喻。云何无义而有实取诸三摩地所行境转。为除此疑说水月喻。云何无义有诸菩萨无颠倒心。为辨有情诸利乐事故思受生。为除此疑说变化喻

释曰。虚妄疑者。于虚妄义所起诸疑。云何无义遍计度时。分明显现似所行境。为遮此疑说幻事喻。如实无象而有幻象所缘境界。依他起性亦复如是。虽无色等所缘六处。遍计度时似有所缘六处显现。又如阳焰于飘动时实无有水而有水觉外器世间亦复如是。又如梦中睡眠所起。心心法聚极成昧略。虽无女等种种境义有爱非爱境界受用。觉时亦尔。又如影像于镜等中。还见本质而谓我今别见影像。而此影像实无所有。非等引地善恶思业。本质为缘影像果生亦复如是。又如光影由弄影者。映蔽其光起种种影。定等地中种种诸识。于无实义差别而转。又如谷响实无有声。而令听者。似闻多种言说境界。种种言说语业亦尔。又如水月由水润滑澄清性故。虽无有月而月可取。缘实义境之所熏修润渍为性。诸三摩地相应之意亦复如是。虽无所缘实义境界。而似有转。此与影像有何差别。定不定地而有差别。有说面等众缘和合。水镜等中面等影生分明可取。如众彩力颇胝迦等种种色生。为不尔耶所取差别。如离水镜月面等影分明可得。颇胝迦等所现众色则不如是。故非同喻。又非我等许有水等。种种实义有法不成。故非比量。又如变化依此变化说名变化。虽无有实而能化者无有颠倒。于所化事勤作功用。菩萨亦尔。虽无遍计所执。有情于依他起。诸有情类由哀愍故。而往彼彼诸所生处摄受自体。应知此中唯有尔所虚妄疑事。所谓内外受用。差别身业语业三种意业非等引地。若等引地若无颠倒。于此八事诸佛世尊说八种喻。诸有智者闻是所说。于定不定二地义中能正解了

论曰。世尊依何密意于梵问经中说。如来不得生死不得涅槃。于依他起自性中。依遍计所执自性及圆成实自性。生死涅槃无差别密意。何以故。即此依他起自性。由遍计所执分成生死。由圆成实分成涅槃故

释曰。世尊依何密意乃至无差别密意者。若问若答两段本文。其义易了不须重释。何以故。下释上生死涅槃无差别密意。若遣遍计永无。复余不得生死。不得此时。便得观见寂灭涅槃。然此中说偏一不成无差别性。为遣愚夫定性差别颠倒执着。亦即显示依他起义。依二自性不决定故

论曰。阿毗达磨大乘经中。薄伽梵说法有三种。一杂染分。二清净分。三彼二分。依何密意作如是说。于依他起自性中遍计所执自性是杂染分。圆成实自性是清净分。即依他起是彼二分。依此密意作如是说。于此义中以何喻显。以金土藏为喻显示。譬如世间金土藏中三法可得。一地界。二土。三金。于地界中土非实有。而现可得。金是实有而不可得。火烧炼时土相不现金相显现。又此地界土显现时虚妄显现。金显现时真实显现。是故地界是彼二分。识亦如是。无分别智火未烧时。于此识中所有虚妄遍计所执自性显现。所有真实圆成实自性不显现。此识若为无分别智火所烧时。于此识中所有真实圆成实自性显现。所有虚妄遍计所执自性不显现。是故此虚妄分别识。依他起自性有彼。二分。如金土藏中所有地界

释曰。金土藏中三法可得。喻三自性地界者。用坚鞕为性藏者。即是金土种子。金土者。是显色形色。如其次第大种所造为三法体。土显现时虚妄显现者。非彼性故。金显现时真实显现者。是彼性故。是故地界是彼二分者。是彼土金二种分故。地界则喻依他起性。土喻遍计所执自性。金者则喻圆成实性。识亦如是者。以法合喻。由唯识性是依他起。遍计所执及圆成实是此性分。无分别智。火所烧时。真实虚妄二种性分。如其次第一则显现。一不显现

论曰。世尊有处说一切法常。有处说一切法无常。有处说一切法非常非无常。依何密意作如是说。谓依他起自性由圆成实性分是常。由遍计所执性分是无常。由彼二分非常非无常。依此密意作如是说。如常无常无二如是。苦乐无二。净不净无二。空不空无二。我无我无二。寂静不寂静无二。有自性无自性无二。生不生无二。灭不灭无二。本来寂静非本来寂静无二。自性涅槃非自性涅槃无二。生死涅槃无二亦尔。如是等差别。一切诸佛密意语言。由三自性应随决了。如前说常无常等。门此中有多颂

  如法实不有　　如现非一种
  非法非非法　　故说无二义
  依一分开显　　或有或非有
  依二分说言　　非有非非有
  如显现非有　　是故说为无
  由如是显现　　是故说为有
  自然自体无　　自性不坚住
  如执取不有　　故许无自性
  由无性故成　　后后所依止
  无生灭本寂　　自性般涅槃

释曰。世尊有处说一切法常等者。谓依他起法性真如。体是常住。遍计所执自性分边体是无常。此常无故此性常无故名无常。非有生灭故名无常。二分所依说为非常亦非无常。是无二性。乐者。即是圆成实分。苦者。即是遍计所执分。无二者。是依他起分。如是净不净。空不空。我无我。寂静不寂静。有自性无自性。生不生。灭不灭。本来寂静非本来寂静。自性涅槃非自性涅槃。生死涅槃无二等。如其所应皆依三性。以释差别。为令有情易受持故。复说如法实不有等。长行结句易可知故。如所显现。非有性故非法。而显现故非非法。由此非法非非法故。说无二义。如是应释。依一分开显或有或非有。如所显现。不如是有而有显现。故依二分说言非有亦非非有。无二性故。如前应知。如显现非有者。我性法性所取能取。如是等体皆无有性。非量所证故说为无。由如是显现者。如萨迦耶见。实无我我所。但由无始时来戏论熏习转变力故。似有显现。此亦如是故说为有。由静虑门无二声转非如异类。若尔为不同离系论。岂有相似彼依邪见。此依正见彼执非一互相违性。但不欲违一切所见故说无二。此佛法中依他起性。于二性中不定属一故说无二。是故彼此其理极远。自然自体无者。依众缘故名自然无。前生刹那已故非新。名自体无自性。不坚住者。一刹那后性灭坏故。此无自性理共声闻。如执取不有故许无自性者。此是不共无自性理。如有颠倒执有我等。如是愚夫所执诸法都无所有故。大乘中许一切法皆无自性。由无性故成者。由无自性无生灭等道理成立。后后所依止者。由无自性故无有生。由无生故即无有灭。无生灭故本来寂静。本寂静故自性涅槃。应知此中后后诸句。依前前句而得解释。如是四种方便胜行随顺。能入菩萨现观。譬如声闻无常等行

论曰。复有四种意趣四种秘密。一切佛言应随决了。四意趣者。一平等意趣。谓如说言我昔曾于彼时彼分。即名胜观正等觉者。二别时意趣。谓如说言。若诵多宝如来名者。便于无上正等菩提已得决定。又如说言。由唯发愿便得往生极乐世界。三别义意趣。谓如说言。若已逢事尔所殑伽河沙等佛。于大乘法方能解义。四补特伽罗意乐意趣。谓如为一补特伽罗。先赞布施后还毁訾。如于布施。如是尸罗及一分修当知亦尔。如是名为四种意趣。四秘密者。一令入秘密。谓声闻乘中。或大乘中。依世俗谛理。说有补特伽罗。及有诸法自性差别。二相秘密。谓于是处说诸法相显三自性。三对治秘密。谓于是处说行对治八万四千。四转变秘密。谓于是处以其别义。诸言诸字即显别义。如有颂言

  觉不坚为坚　　善住于颠倒
  极烦恼所恼　　得最上菩提

释曰。远观于他欲作摄受。名为意趣。近观于他欲令悟入。说名秘密。平等意趣者。谓一论佛由资粮等互相似故。说我昔曾于彼时等。如有意缘互相似性作如是言。彼即是我。然非昔时毗钵尸佛即今世尊释迦牟尼。别时意趣者谓观懈怠。不能于法精勤学者。故说是言。若诵多宝如来名者。便得决定。由唯发愿便得往生极乐世界。此意长养先时善根。如世间说但由一钱而得于千。别义意趣者。谓证相大乘法义。与教相大乘法义。甚有差别。由此意趣。作如是言。若已逢事尔所殑伽河沙等佛。于大乘法方能解义极悬远故。于大乘法简取圣者。自内所证简去随言所解了义。补特伽罗意乐意趣者。先为悭贪赞叹布施。后为乐施毁訾布施。先为犯戒赞叹尸罗。后为持戒毁訾尸罗。为欲令修胜品善故。一分修者。谓世间修。令入秘密者。谓有处说补特伽罗及一切法自性差别。为令悟入世俗谛理。如声闻乘中说有化生。诸有情等。如大乘中为化怖断诸有情故。说心常等。相秘密者。为令悟入所知相故。对治秘密者。谓为对治所治贪等。诸行差别八万四千。转变秘密者。谓于字义转变差别。觉不坚为坚者。刚强流散说名为坚。非此坚故说名不坚。即是调柔无散乱定。即于此中起坚固慧觉。彼为坚善。住于颠倒者。谓于四颠倒善能安住。知是颠倒决定无动。极烦恼所恼者。为化有情精进劬劳所疲倦故。如有颂言处生死久恼。但由于大悲如是等。得最上菩提者。是得诸佛三菩提义

切曰。若有欲造大乘法释。略由三相。应造其释。一者由说缘起。二者由说从缘所生法相。三者由说语义

释曰。为欲开晓诸造释者。解释道理故说略由三相等言

论曰。此中说缘起者。如说

  言熏习所生　　诸法此依彼
  异熟与转识　　更互为缘生

释曰。如是缘起及缘生法。所知依处已辨其相已解三种缘起相故。今于此中复略显示阿赖耶识。与其转识互为因果。故伽他中说言熏习所生等言

论曰。复次彼转识相法。有相有见识为自性。又彼以依处为相。遍计所执为相法性为相。由此显示三自性相。如说

  从有相有见　　应知彼三相

复次云何应释彼相。谓遍计所执相于依他起相中实无所有。圆成实相于中实有。由此二种非有及有。非得及得。未见已见。真者同时。谓于依他起自性中。无遍计所执故。有圆成实故。于此转时。若得彼即不得此。若得此即不得彼。如说

  依他所执无　　成实于中有
  故得及不得　　其中二平等

释曰。有相有见识为自性者。此如先说。相识自性。谓色识等及眼识等。见识自性谓根识识等。又彼以依处为相者。谓依他起相是二自性所依处故。遍计所执为相者。即是遍计所执自性。法性为相者。谓即于此净分安立。为显此义说半颂言。从有相有见应知彼三相。未见已见真者同时者。谓若尔时未见真者。于依他起自性中见圆成实无。遍计所执有。即于此时已见真者。见遍计所执无圆成实有。何处谁无依他所执无者。于依他起中。遍计所执无故。于中何有成实。于中有者。于依他起中圆成实有故。此中妄见愚夫。由颠倒见。非有见有。有见非有。真见圣者。由无倒见。有见为有无见为无。为显此义下半颂言

  故得及不得　　其中二平等

论曰。说语义者谓先说初句。后以余句分别显示。或由德处或由义处

释曰。如是不观说者。意趣释诸义已。今当随顺说者。意趣释说语义。或由德处或由义处者。谓由德意趣由义意趣。已得在已圆满饶益故名为德。未得在已随顺趣求故名为义

论曰。由德处者。谓说佛功德最清净觉。不二现行趣无相法。住于佛住逮得一切佛平等性。到无障处不可转法。所行无碍其所安立。不可思议游于三世平等法性。其身流布一切世界。于一切法智无疑滞。于一切行成就大觉。于诸法智无有疑惑。凡所现身不可分别。一切菩萨等所求智得佛无二。住胜彼岸不相间杂。如来解脱妙智究竟。证无中边佛地平等。极于法界尽虚空性。穷未来际最清净觉者。应知此句由所余句分别显示。如是乃成善说法性

最清净觉者。谓佛世尊最清净觉。应知是佛二十一种功德所摄。谓于所知一向无障转功德。于有无无二相真如最胜清净能入功德。无功用佛事不休息住功德。于法身中所依意乐作业无差别功德。修一切障对治功德。降伏一切外道功德。生在世间。不为世法所碍功德。安立正法功德。授记功德。于一切世界示现受用变化身功德。断疑功德。令入种种行功德。当来法生妙智功德。如其胜解示现功德。无量所依调伏有情加行功德。平等法身波罗蜜多成满功德。随其胜解。示现差别佛土功德。三种佛身方处无分限功德。穷生死际。常现利益安乐一切有情功德。无尽功德等

释曰。最清净觉者。此是初句由所余句开显其义。如是乃名善说法性。谓以多德辩说一德。谓于所知一向无障转功德者。此即开示不二现行。谓佛一向无障碍智。于一切事品类差别无著无碍故。非如声闻等智有处有障有处无障二种。或二处现行。此中无有如是所说二种现行。是故说名不二现行。由此故名最清净觉。有大功能智断满故。后诸句中皆应如是互相配属。于有无无二相真如最清净能入功德者。此即开示趣无相法。谓此真如有圆成实相。无遍计所执相。由此道理名无二相。无有无相是实有故。无有有相所执无故。最胜清净能入功德者。谓即真如最胜清净。一切法中最第一故。远离一切客尘垢故。于此真如自既能入。亦令他入。是故说为最胜清净能入功德。由此如前应当配属。自既清净亦令他净故。无功用佛事不休息住功德者。此即开示住于佛住。谓不作功用于诸佛事。有情等中能无间断。随其所应恒正安住圣天梵住。非如声闻要作功用。方能成办利有情事。非如外道虽有所住。而非殊胜天住。即是四种静虑梵住即是悲等无量。圣住即是空无相等。于法身中所依意乐作事无差别功德者。即是开示逮得一切佛平等性。所依无差别者。一切皆依清净智故。意乐无差别者。一切皆有利益安乐一切有情胜意乐故。作业无差别者。一切皆作受用变化利他事故。非如声闻等唯有所依故。修一切障对治功德者。即是开示到无障处。谓已串习一切烦恼及所知障对治圣道。一切种智定自在性。已到永离一切障气所依趣处。降伏一切外道功德者。即是开示不可转法。谓教证二法皆不为他所能动转。无有余法胜过此故。生在世间不为世法所碍功德者。即是开示所行无碍。谓若于中常所游履说名所行。虽行世间而于其中非利衰等爱恚世法所能拘碍。如有颂言

  诸佛常游于世间　　利乐一切有情类
  八法热风邪分别　　不能倾动不拘碍

安立正法功德者。即是开示其所安立不可思议。谓契经等十二分教名所安立。安立彼彼自相共相故。如是安立非诸愚夫觉所行故。出世间故不可思议。此所安立不可思议。即是功德如前配属。授记功德者。即是开示游于三世平等法性。谓于三世平等法性能遍游涉。以于三世平等性中。能随解了过去未来曾当转事。皆如现在而授记故。于一切世界示现受用变化身功德者。此即开示其身流布一切世界。谓随所化遍诸世界。示现两身利乐彼故。断疑功德者。即是开示于一切法智无疑滞。于一切境善决定故。非于诸法自不决定能决他疑。非离决定能断疑故。令入种种行功德者。即是开示于一切行成就大觉。当来法生妙智功德者。即是开示于诸法智。无有疑惑。谓圣声闻。言此全无少分善根而弃舍者。佛薄伽梵知彼后时善法当生。现证知彼余生微少善根种子所随逐故。如其胜解示现功德者即是开示凡所现身不可分别。谓随有情种种胜解。现金色等。虽现此身而无分别。如末尼珠及箫笛等广说如彼。如来密经无量所依。调伏有情加行功德者。即是开示一切菩萨等所求智。谓由无量菩萨所依。为欲调伏诸有情故。发起加行佛增上力。闻法为先获得妙智。异类菩萨摄受付嘱。展转相续无间而转。由此证得一切菩萨等所求智。平等法身波罗蜜多成满功德者。即是开示得佛无二住胜彼岸。谓无二故名为平等。依平等法身波罗蜜多果位成满故。或平等者无减无增。于法身中波罗蜜多一切成满。其中无有或增或减。非如于彼菩萨地中波罗蜜多有增有减。随其胜解示现差别佛土功德者。即是开示不相间杂如来解脱妙智究竟。谓观众生胜解差别。现金银等种种佛土。不相间杂。世尊胜解现在前时。随众所乐悉皆显现。无不了知是故说名如来解脱。妙智究竟此中胜解。说为解脱三种佛身方处无分限功德者。即是开示证无中边佛地平等。谓如世界无中无边。佛地亦尔。功德方处无有分限。或复世界方处无边。诸佛三身即于其中称世界量。平等遍满以法身等即住。如是诸世界中非余处故。或法身等于佛地中平等遍满。无中无边无有分限。此法身等遍一切处。为诸众生现作饶益。然非自性无中无边。穷生死际常现利益安乐一切有情功德者。即是开示极于法界。谓此法界最清净故。能起等流契经等法。极此法界于当来世一切有情。如其所应常能现作利益安乐。无尽功德者。即是开示尽虚空性。谓彼虚空无障为性。于有对物不障为业。性者界也。持自相故。非诸间穴明闇为性穷尽。如是虚空自性如彼虚空无边无际。无尽无减无生无灭无有变易。于一切时现前容受一切质碍。法身亦尔。常现前作一切有情利乐为相。尽一切界遍作众生诸饶益事。无有休息。等者。等取究竟功德。即是开示穷未来际。谓此功德穷未来际常无间断。穷于未来无际之际。显佛功德永无穷尽。所化有情永无尽故

由此功德之所庄严。最清净觉。显薄伽梵异诸声闻独觉菩萨觉最胜故。云何而得此最胜觉故次说言不二现行。诸声闻等于所知境有二现行。所谓正智不染无智。佛无此故智德圆满。为显如来断德圆满。故次说言趣无相法不住生死涅槃相故。以何方便得此涅槃。故次说言住于佛住。由薄伽梵于空大悲善安住故。不住生死不住涅槃。如是佛住与余为共为不共耶。故次说言。逮得一切佛平等性。诸佛一切行相展转和杂住故。如是已说自利圆满。次当广说利他圆满。为显已得一切所化障碍对治。故次说言到无障处。有诸魔等。能退转法。能转有情所作义利。今于此中无有是事。故次说言。不可转法。于诸所作有情利益安乐事中。无有高下能为拘碍。故次说言所行无碍。依此方便能作有情诸饶益事。故次说言其所安立不可思议。如是加行诸佛世尊为性平等。为各差别。不尔何者游于三世平等法性。三世诸佛利有情事皆相似故。如是所作利有情事。为于一一诸世界中次第作耶。不尔何者其身流布一切世界顿于一切诸世界中。现成佛故。为显能断于彼彼处所生起疑。故次说言于一切法智无疑滞。所化有情种性别故。如其所应方便化导。为欲显此巧方便智。故次说言于一切行成就大觉。即依如是所化有情有能无能。善巧差别。故次说言于诸法智无有疑惑。即于所化有情邪正及俱行中。所应现相不可分别。为现此事。故次说言凡所现身不可分别。引发任持不定种性声闻菩萨。故赞大乘。为显此事。故次说言。一切菩萨等所求智。为遮所化诸有情类于大师所。疑一切智非一切智。故次说言。得佛无二住胜彼岸。闻一切佛得平等言。即谓一切应同一性。为遮此疑。故次说言。不相间杂如来解脱妙智究竟。非一非异其相云何。为答此问故次说言。证无中边佛地平等常无常等。一切皆是二边相摄。云何无相为避此难。故次说言。极于法界。谓最清净离诸戏论。是法界相如是种类。利众生事。为经几时故次说言。尽虚空性穷未来际

论曰。复次由义处者。如说若诸菩萨成就三十二法乃名菩萨。谓于一切有情。起利益安乐增上意乐故。令入一切智智故。自知我今何假智故。摧伏慢故。坚牢胜意乐故。非假怜愍故。于亲非亲平等心故。永作善友乃至涅槃为后边故。应量而语故。含笑先言故。无限大悲故于所受事无退弱故。无厌倦意故闻义无厌故。于自作罪深见过故。于他作罪不嗔而诲故。于一切威仪中恒修治菩提心故。不希异熟而行施故。不依一切有趣受持戒故。于诸有情无有恚碍而行忍故。为欲摄受一切善法勤精进故。舍无色界修静虑故。方便相应修般若故。由四摄事摄方便故。于持戒破戒善友无二故。以殷重心听闻正法故。以殷重心住阿练若故。于世杂事不爱乐故。于下劣乘曾不欣乐故。于大乘中深见功德故。远离恶友故。亲近善友故。恒修治四梵住故。常游戏五神通故。依趣智故。于住正行不住正行。诸有情类不弃舍故。言决定故。重谛实故。大菩提心恒为首故。如是诸句应知皆是初句差别。谓于一切有情起利益安乐增上意乐

此利益安乐增上意乐句。有十六业差别。应知此中十六业者。一展转加行业。二无颠倒业。三不待他请自然加行业。四不动坏业。五无求染业。此有三句差别应知。谓无染系故。于恩非恩无爱恚故。于生生中恒随转故。六相称语身业此有二句差别应知。七于乐于苦于无二中平等业。八无下劣业。九无退转业。十摄方便业。十一厌恶所治业。此有二句差别应知。十二无间作意业。十三胜进行业。此有七句差别应知。谓六波罗蜜多正加行。故及四摄事正加行故。十四成满加行业。此有六句差别应知。谓亲近善士故。听闻正法故。住阿练若故。离恶寻思故。作意功德故。此复有二句差别应知。助伴功德。故此复有二句差别应知。十五成满。业此有三句差别应知。谓无量清净。故得大威力。故证得功德故。十六安立彼业。此有四句差别应知。谓御众功德故。决定无疑教授教诫故。财法摄一故。无杂染心故。如是诸句应知皆是初句差别

释曰。三十二法由十六业分别显示说彼业故。利益安乐增上意乐故者。或有利益而非安乐。如盛贪者强修梵行。或有安乐而非利益。如乐欲者。受用种种有罪境界。或有利益亦是安乐。如薄尘者乐修梵行。此中菩萨作如是心。云何皆令一切有情当得无上利益安乐。言意乐者。欲及胜解以为自性。此意乐胜故名增上意乐。令入一切智智故者。是展转加行业之所解释。譬如一灯转然千灯。由此业故。利益安乐增上意乐则得显现。如是于后一切句中。利益安乐增上意乐皆应配释。自知我今何假智故者。是无颠倒业之所解释。或有利乐增上意乐而是颠倒。故须自知。我今何假。由此智故说无倒业。谓我唯有如是闻慧。了知教证自有堪能。起随所应无倒加行。如有颂言

  诸有自称量　　勤求所求处
  彼不逮劬劳　　而能到所到

如是等颂应当广说。摧伏慢故者。是不待他请自然加行业之所解释。他虽不请自然往彼为说正法。坚牢胜意乐故者。是不动坏业之所解释。生死众苦不能动坏所发心故。非假怜愍故。于亲非亲平等心故。永作善友乃至涅槃为后边故者。是无求染业三种差别之所解释。若有染系由爱染因。假作怜愍暂时摄受。若无染系非假怜愍。于一切时恒不舍离。若依爱染而作怜愍。于亲非亲。有爱有恚心不平等。若无染心则于二品平等而转。若有爱染而作怜愍。但至命终怜愍随转。若无爱染而生怜愍。于生生中怜愍之心恒常随转。是故菩萨乃至涅槃永作善友。应量而语含笑先言故者。此是二种利益安乐增上意乐相。称语身业之所解释。无限大悲故者。是平等业之所解释。若唯于苦而起大悲。非乐非舍非平等业一分转故。菩萨大悲于乐于苦于非苦乐。所摄有情皆被生死众苦随逐。平等怜愍无有差别。是故说此名平等业。于所受事无退弱故者。是无下劣业之所解释。专为拔济一切有情。犹如重担。见此重担心无怯惧不舍勤苦。如担而办。是故说名无下劣业。无厌倦意故者。是无退转业之所解释。所化有情诸邪恶行不能退转。利益安乐增上意乐相应业故。闻义无厌故者。是摄方便业之所解释。闻谓所闻契经等法。非泛所闻。义谓即彼所诠之义。于此闻义常无厌足。此是能摄成熟有情巧方便性。是故说名摄方便业。闻义无足如所堪能。应正道理而化导故。于自作罪深见过故。于他作罪不嗔而诲故者。是厌恶所治业之所解释。此中所治谓贪嗔等。欲令远离故名厌恶。若于自罪深见过失。速疾厌离方能制他所不应作。言威肃故非余能制。如契经言

  若自住邪行　　便受他讥论
  是人终不能　　制止他过失

世俗亦言

  若自犯愆过　　经时不观察
  不如理远离　　慢不取其德

若怀嗔忿。诲他所犯以非利益非方便故。言不威肃他转违背。起诸邪行。如有颂言

  怜愍如一子　　诲举他所犯
  决定令受持　　后不复当犯

于一切威仪中。恒修治菩提心故者。是无间作意业之所解释。普于一切所作事中。无间修治菩提心故。如所行清净契经中说

  若见坐时　　发如是心　　愿诸众生
  坐菩提座

如是等颂不悕异熟而行施故。乃至由四摄事摄方便故者。是胜进行业七句差别之所解释。即六波罗蜜多及四摄事。离如所说所治过等。于极喜等后后地中。转得增胜趣向成满。因名为业是所作故。此中四种波罗蜜多易故不释。有差别者。今当略释。舍无色界修静虑故者。菩萨不生无色界中。于彼不见能作利乐有情事故。亦不数入无色等至。不见彼处。有多功德之所依故。舍是离义方便相应修般若者。大悲相应修习妙慧。能作有情诸利乐事。此若无者。于诸有情利益安乐此事应无。专为此事求佛果故。如有颂言

  双修习慧悲　　能作他利乐
  利他行正道　　一向趣菩提

四摄事者。布施爱语利行同义。由布施故能摄受他。由爱语故方便开解为说法相。由利行故随其所应劝彼修善。由同义故于最后时。令彼同得不共功德。或由布施故令成法器。由爱语故得法胜解。由利行故依法胜解发起正行。由同义故令所起行转得清净转复微妙。由此具摄方便自性。于持戒破戒善友无二故。乃至亲近善友故者。是成满加行业六句差别之所解释。由此加行能令成满。是故说名成满加行。此即是业。由亲近善士等六句释经所说八句。作意功德助伴功德。各释二故有。善尸罗故名持戒有。恶尸罗故名破戒。于此二种能说法者。为闻法故恭敬法故。起善友想无有差别。是故说言善友无二。由是因缘于破戒者不应一向。谓非善友。如有颂言

  若有戒足虽羸劣　　而能辩说利多人
  如佛大师应供养　　爱彼善说故相似

以殷重心听闻正法者。谓如所说广义等中。由十六行应听闻法。以殷重心住阿练若者。远离聚落。过俱卢舍名阿练若。于中居止说名为住。如应而住无有慢缓名殷重心。于世杂事不爱乐者。不爱世间歌笑舞等种种杂事。即是远离欲等相应不正寻思。作意功德者。舍爱声闻独觉乘故。大乘功德爱相应故。助伴功德者。远恶友故。近善友故。恒修治四梵住故。常游戏五神通故。依趣智故者。是成满业之所解释。谓成满相名成满业。此中业声是相别名。无量清净等三句。释前恒修治四梵住等三句。慈悲喜舍四种无量名四梵住。由此表知所有内德。成满清净故得相声。游戏五通名为威力。漏尽智通是解脱智名大威力。或取菩萨增上神通名大威力。如是亦名成满之相。证得功德者。谓已证得现前自在。此即解释依趣智故。各别内证名依趣智。不唯于义依趣于识非寂静故。于住正行不住正行等。是安立彼业。四句差别之所解释。由此安立利益安乐增上意乐。此即是业。是故说名安立彼业。御众功德者。谓于持戒犯戒有情驱摈摄受。俱欲令其出不善处安立善处。名不弃舍。言决定故者。谓决定无疑教授教诫。言威肃故。言若不定即不威肃。重谛实故者。谓财法二摄合成一种。积集财法无异分别。平等分布如先所许。如是施与除现所无。如有颂言

  财供养能令　　众生尽寿命
  法供养能令　　究竟天寂静

大菩提心恒为首故者。是无杂染心之所解释。由菩提心所摄受故。凡有所作终不贪求他供事等。唯求证得无上菩提

论曰。如说

  由最初句故　　句别德种类
  由最初句故　　句别义差别

释曰。此伽他中其义易解无劳重释

摄大乘论释卷第五摄大乘论释卷第六

        无性菩萨造

        三藏法师玄奘奉　诏译

    入所知相分第四

论曰。如是已说所知相入所知相云何应见。多闻熏习所依。非阿赖耶识所摄。如阿赖耶识成种子。如理作意所摄似法似义而生。似所取事有见意言

释曰。菩萨修习如是业已。如入现观所应知相。今当显说。多闻熏习所依者。谓于大乘而起多闻。闻法义已熏心心法相续所依。其少闻者无容得入此现观故。如薄伽梵教授尊者罗怙罗经。说如是言。唯愿世尊教我现观。世尊告曰。汝已受持正法藏耶。罗怙罗言。不也世尊。世尊告曰。汝今且应受持法藏。如是等非阿赖耶识所摄者。谓此所依从最清净法界流故。对治彼故。非彼性摄彼相违故。如阿赖耶识成种子者。如阿赖耶识能为一切杂染法因。此所依性能为一切清净法因。唯因性同故得为喻。非一切种。如有颂言

  为欲利益常放逸　　生盲不观自乐者
  诸佛降灵现世间　　为彼宣说微妙法
  譬如无价末尼宝　　能除众毒不思议

言似法者。谓契经等如十地等。言似义者。谓彼所诠无我性等。似彼行相而生起故。说为似法似义而生似所取事者如彼所取而显现故。言有见者。谓耳识。俱言意言者。所谓意识。或与见分俱所取能取性。此即安立所取能取所依自性。如前已说

论曰。此中谁能悟入所应知相。大乘多闻熏习相续。已得逢事无量诸佛出现于世。已得一向决定胜解。已善积集诸善根故。善备福智资粮菩萨

释曰。用及用具皆待作者。故问入者谁能悟入。答此问言大乘多闻熏习相续等。谓依大乘法而起多闻熏习。相续已得逢事无量诸佛出现于世者。由此相续故。得现前逢事诸佛出现于世。已得一向决定胜解者。由逢事佛于大乘法深生信解。非诸恶友引令犹豫。由此大乘多闻等三因缘故。能善积集无量善根。是则名为善备福智资粮菩萨

论曰。何处能入。谓即于彼有见似法似义意言。大乘法相等所生起。胜解行地见道修道究竟道中。于一切法唯有识性。随闻胜解故。如理通达故。治一切障故。离一切障故

释曰。何处能入者。问所入境及能入位。谓即于彼有见等者。谓于大乘法相所生。决定行相似法似义意言。能入于此境界。能入是用。所入境界。是业是持。于此意言或有能入。在胜解行地。于一切法唯识性中。但随听闻生胜解故。或有能入在见道中。如理通达此意言故。此中如理而通达者。谓通达彼非法非义。非所取非能取故。或有能入在修道中。由此修习对治烦恼所知障故。或有能入在究竟道中。最极清净离诸障故。如是四种是能入位

论曰。由何能入。由善根力所任持故。谓三种相练磨心故。断四处故。缘法义境止观恒常。殷重加行无放逸故

释曰。由何能入者。此问入因。谓由何因于此能入。由善根力所任持故等者。谓虽有善根力而心或退屈故。说三种相练磨心故等

论曰。无量诸世界无量人有情。刹那刹那证觉无上正等菩提。是为第一练磨其心。由此意乐能行施等波罗蜜多。我已获得如是意乐。我由此故少用功力修习施等波罗蜜多。当得圆满。是为第二练磨其心。若有成就诸有障善。于命终时即便可爱一切自体圆满而生。我有妙善无障碍善。云何尔时不当获得一切圆满。是名第三练磨其心

释曰。无量诸世界等者。此言显示初练磨心。引他例已令心增盛。无有退屈由此意乐者。显示第二练磨其心。我已获得如是意乐者。显此意乐离诸弊缚。谓此意乐远离悭吝。远离欲寻。远离恚寻。远离懈怠。远离惛沈及以睡眠。远离无明。我由此故少用功力。修习施等波罗蜜多。当得圆满者。谓已获得殊胜意乐。便能任运修行施等速令圆满。若有成就等者。显示第三练磨其心。诸有障善者。谓有成就诸世间善。未能永断所治障故。说名有障。我有妙善等者。谓我能永断所对治障。由无障善而成其善。云何当来而不证得圆满佛果。练磨心者。谓策举心令其猛利。对治退屈

论曰。此中有颂

  人趣诸有情　　处数皆无量
  念念证等觉　　故不应退屈
  诸净心意乐　　能修行施等
  此胜者已得　　故能修施等
  善者于死时　　得随乐自满
  胜善由永断　　圆满云何无

释曰。复以伽他摄如是义。人趣诸有情等者。其心怯弱名为退屈。劝彼不应心生退屈。谓我不能证觉无上正等菩提名心怯弱。令劝进彼不应于己谓无功能。故无退屈。如有颂言

  无量十方诸有情　　念念已证善逝果
  彼既丈夫我亦尔　　不应自轻而退屈

诸净心意乐能修行施等者。谓非不善及无记心。而行施等。唯是善心故名净心。如有世间不善无记散乱心中。亦行施等希愿诸有及财位故。菩萨不尔。唯求无上正等菩提。言意乐者。谓能无碍修施等因如先已说。此胜者已得故。能修施等者。谓诸菩萨名为胜者先已得此殊胜意乐。由此施等波罗蜜多任运而转。如说而修故名已得。由此决定舍所对治。舍所治故不由功用。于其施等任运而转。等者。等取戒乃至慧波罗蜜多。善者于死时者。谓由世间善而成善者。于命终时得。随乐自满者。谓得世间随所爱乐自圆满果。是乃至得有顶生义。胜善由永断者。即是由彼永断障善而成善义。圆满云何无者。是随所乐圆满佛果云何无义

论曰。由离声闻独觉作意。断作意故。由于大乘诸疑离疑。以能永断异慧疑故。由离所闻所思法中我我所执。断法执故。由于现前现住安立一切相中无所作意。无所分别断分别故此中有颂

  现前自然住　　安立一切相
  智者不分别　　得最上菩提

释曰。今当显示断除四处。断作意故者。断除二乘分引作意。以能永断异慧疑故者。谓于大乘甚深广大。不起异慧颠倒及疑。断法执故者。谓于所闻所思法中。能永断除我我所执。谓我能闻我能思觉。我所听文我所思义。如是执着一切皆无。于其胜义证现观故。断分别故者。谓于现前任运而转。色等现住及作功用。诸骨锁等净定安立一切所缘诸境界相。作意分别悉能永断。乃至一切诸佛菩萨波罗蜜多。如是等相。执着分别悉能永离。其颂义显不须重释

论曰。由何云何而得悟入

释曰。此中双问作具所作。由有作者入所作业。应知定有能入之具。自现观相是所作事。决定应有如是如是所作方便。是故今当二俱解释

论曰。由闻熏习种类。如理作意所摄似法似义有见意言

释曰。此中先辨能入之具种类之声。即因言说是为因义

论曰。由四寻。思谓由名义自性差。别假立寻思及由四种如实遍。智谓由名事自性差。别假立如实遍。智如是皆同不可得故。以诸菩萨如是如实。为入唯识勤修加行。即于似文似义意言。推求文名唯是意言。推求依此文名之义。亦唯意言。推求名义自性差别唯是假立。若时证得唯有意言。尔时证知若名若义。自性差别皆是假立。自性差别义相无故。同不可得由四寻思。及由四种如实遍智。于此似文似义意言。便能悟入唯有识性

释曰。由四寻思。及由四种如实遍智者。依如先说。能悟入具发起如实所作方便。于加行时推求行见假有实无。方便因相说名寻思。了知假有实无所得。决定行智。方便果相名如实智。此中名者。谓色受等亦摄名因。名果句等寻思此名唯意言性。唯假非实。不离意言名名寻思。义寻思者。如名身等所诠表得蕴界处等。推求此性唯假非实。如有种类种类相应差别可得。如是所诠能诠相应不应理故。推求依此文名之义亦唯意言者。寻思依名所表外事。唯意言性。思惟此义似外相转。实唯在内推求名义自性差别唯是假立者。寻思名义二种自性。唯假立相。谓色受等名义自性实无所有。假立自性。譬如假立补特伽罗。寻思名义二种差别亦假立相。谓无常等名义差别唯假立故。若名若义自性差别皆是假立者。证知四种虚妄显现依他起摄自性差别义相无故。同不可得者。了达四种遍计执义皆不可得。应知此中四种方便说名寻思。四种果智说名四种如实遍智。谓推求名唯是假立。实不可得说名寻思。若即于此果智生时决定了知。假有实无名如实智。如是于事自性差别假有实无。推求决定说亦应尔

论曰。于此悟入唯识性中。何所悟入。如何悟入。入唯识性。相见二性及种种性。若名若义自性差别。假自性差别义。如是六种义皆无故。所取能取性现前故。一时现似种种相义而生起故。如闇中绳显现似蛇。譬如绳上蛇非真实。以无有故。若已了知彼义无者。蛇觉虽灭。绳觉犹在。若以微细品类分析。此又虚妄色香味触为其相故。此觉为依绳觉当灭。如是于彼似文似义六相意言。伏除非实六相义时。唯识性觉犹如蛇觉亦当除遣。由圆成实自性觉故

释曰。于此悟入唯识性中。欲显所入及入譬喻。故为此问。若义无有于此悟入唯识性中。为何所入此意难言。此唯识性即是其义。云何义无为遮此难故先说言。入唯识性谓此识义亦无义性。非唯外义是无所有。若无义性。云何得有十二处教。云何世间有义言说。为遮此难。故次说言。相见二性虽无实义。识似内外二义显现。无始言说熏习力故。识似义转似了别用说名为见。故不相违为唯悟入似相似见。识别种类为不尔耶。为答此问故说悟入及种种性。谓唯一识。所取能取性差别故。于一时间分为二种。又于一识似三相现。所取能取及自证分名为三相。如是三相。一识义分非一非异如余处辨。于一识上有多相现。故名种种。名等六相。无有义等释前三种。为答前问如何悟入故复说言。如闇中绳显现似蛇。由此譬喻成立通达三种自性。譬如绳上蛇非真实。以无有故。如是似名似义意言。依他起上名等六种。遍计所执亦非真实。以无有故。又于此中如依绳觉舍于蛇觉。如是依止唯识显现。依他起觉舍于六义。遍计执觉如依色等。细分之觉除遣绳觉。如是依止圆成实觉。遣依他起迷乱之觉。如有颂言

  于绳谓蛇智　　见绳了义无
  证见彼分时　　知如蛇智乱

伏除非实六相义时者。是非有义。六种非实义非有为相故

论曰。如是菩萨悟入意言似义相故。悟入遍计所执性。悟入唯识故悟入依他起性。云何悟入圆成实性。若已灭除意言闻法熏习种类唯识之想。尔时菩萨已遣义想一切似义。无容得生故似唯识亦不得生。由是因缘住一切义。无分别名。于法界中便得现见相应而住。尔时菩萨平等平等。所缘能缘无分别智。已得生起。由此菩萨名已悟入圆成实性

释曰。悟入意言似义相故。悟入遍计所执性者。谓了知意言似义相现。无有遍计所执实义。由此故名悟入遍计所执自性。悟入唯识故悟入依他起性者。谓了知唯识无明解故。于无义中似义相现。由此悟入依他起性。为显悟入圆成实性故复说言。已遣义想。即是已能除义想义。一切似义无容得生者。即是都无有能似义而生起义。故似唯识亦不得生者。所取无故能取亦无。即是唯识所成之义。亦不转义。住一切义无分别名者。谓一切法是契经等。名所依行处。名一切义。名有十种。前九种名有所分别。其第十名于一切义无所分别。安住如是于一切义无分别名。如说一切唯有其名。即如是名能起一切者。此中似名显现识等假说为名。于法界中便得现见相应而住者。谓于法界内证相应而起胜解。平等平等者。谓如所缘都无所有。如是能缘亦无所有。是故所缘能缘二种平等平等。由此菩萨名已。悟入圆成实性者。悟入遍计所执自性。依他起性是有余故犹有作者。作用未息但名悟入。今于此中作者作用息灭究竟名已悟入

论曰。此中有颂

  法补特伽罗　　法义略广性
  不净净究竟　　名所行差别

释曰。如前所说住一切义无分别名。今以伽他显示此名自境差别。初法名者。谓色受等。补特伽罗名者。谓天授等。随信行等。佛教中名。后法名者。谓契经应颂等。义名者。谓此所诠杀害于父母。诛国及随行等。略名者。谓一切法皆无我等。广名者。谓色无我等。性名者。谓阿等诸字。是词句因故。不净名者。谓诸异生为诸烦恼垢所染故。净名者。谓诸贤圣垢永断故。究竟名者。谓总所缘即般若波罗蜜多。及十地等。以总略义为所缘故

论曰。如是菩萨悟入唯识性故。悟入所知相。悟入此故入极喜地。善达法界生如来家。得一切有情平等心性。得一切菩萨平等心性。得一切佛平等心性。此即名为菩萨见道

释曰。善达法界者。于此法界深作证故。生如来家者。谓佛法界名如来家。于此证会故名为生。于此所缘胜智生故。转先所依生余依故。绍继佛种令不断绝。如余续生余众同分。所生能生相续不断。托所生家如是般若波罗蜜多。证佛法界。名于中生。名真佛子。由此般若波罗蜜多。于佛法界能正作证。树自相续自在现前故名为生。如有说言

  一切雄猛　　乐利他者　　生母养母
  所生所育

得一切有情平等心性者。遍见一切等无我故。如有说言。一切诸法皆如来藏。如是等。得一切菩萨平等心性者。得彼意乐平等性故。得一切佛平等心性者。得彼法身平等性故。此即名为菩萨见道者。见先未见胜法界故。譬如声闻独觉见道

论曰。复次为何义故入唯识性。由缘总法出世止观智故。由此后得种种相识智故。为断及相阿赖耶识诸相种子。为长能触法身种子。为转所依。为欲证得一切佛法。为欲证得一切智智入唯识性。又后得智于一切阿赖耶识所生。一切了别相中。见如幻等性无倒转。是故菩萨譬如幻师于所幻事于诸相中。及说因果常无颠倒

释曰。复次为何义故等者。问入唯识所须。次应答言为欲证得一切智智。而先方便如所说者。为欲开示次第言故。为欲饶益堪受如是所化类故。由缘总法者。缘一切法总相所显真如为。境谓大乘教中所说一切法。皆真如为性故。缘真如即是解了一切法性。若不尔者虽经多时。无分别智亦应不生。言出世者。是无漏故。无分别故。止观智故者。由三摩呬多无颠倒智故。种种相识者。谓安立诸法因性果性有上无上等。即是所取能取分义。为断及相阿赖耶识诸相种子者。为断阿赖耶识中似色等相诸法种子。及能熏相。此即说断种子因果。为长能触法身种子者。为欲增长一切大乘多闻熏习。由此为先得法身故。为转所依者。通达真如。诸心心法离垢生故。或复真如善清净故。为欲证得一切佛法者。为欲生起力无畏等诸佛法故。为欲证得一切智智者。为欲证得。无垢无碍诸佛智故。又后得智者。显后得智有所作用。于一切阿赖耶识所生者。此举所生为取其因。一切了别相中者。此显其果即是能取所取分中。见如幻等性无倒转者。如实观见依他起性。如幻事等。无迷乱故。譬如幻师于所幻事者。于草木等幻惑因中。无有颠倒如实见故。于象马等幻惑相中。亦无颠倒如实见故。如是菩萨见真实者。如实现见无有所取能取自性。圆成实已起于后得。能发语言世俗净智。知因果时及说法时。常无颠倒。其听闻者虽有颠倒。而闻熏习熏相续故。次第渐渐得无颠倒。由彼成办所应作故。此后得智亦无差别无染污故

论曰。于此悟入唯识性时。有四种三摩地。是四种顺决择分依止。云何应知。应知由四寻思于下品无义忍中。有明得三摩地。是暖顺决择分依止。于上品无义忍中。有明增三摩地。是顶顺决择分依止。复由四种如实遍智。已入唯识。于无义中已得决定。有入真义一分三摩地。是谛顺忍依止。从此无间伏唯识想。有无间三摩地。是世第一法依止。应知如是诸三摩地。是现观边

释曰。于一切处入现观时。皆有四种顺决择分。是前相故。现观已显故不重释。由四寻思者。谓如前说推求名义自性差别假立为体。于下品无义忍中者。谓于下品觉慧爱乐诸义无所有中。明谓能照无有义智。所求果遂故名为得。此定创得无义智明。故得明得三摩地名。譬如最初求得火等。暖者即是暖品善根。譬如钻火暖为前相。此亦如是真智前相。言依止者。谓是因义。言决择者。即是现观。此分即是法无我忍。引此善根说名为顺。最居其上故名为顶。复由四种如实遍智者。谓如先说于名事等不可得中。已得决定。如是转时悟入唯识。似名等现决定了知。都无有义。入真义一分三摩地者。唯能通达所取无故名入一分。由于此中了达义无。未能伏彼能取行相唯识令无。是故说此名谛顺忍所依止定。顺谓亲近依所取无令能取无。应知如是诸三摩地是现观边者。当知即是近彼转义

论曰。如是菩萨已入于地已得见道。已入唯识。于修道中云何修行。于如所说安立十地。摄一切经皆现前中。由缘总法出世后得止观智故。经于无量百千俱胝那庾多劫。数修习故而得转依。为欲证得三种佛身。精勤修行

释曰。于如所说安立十地者。谓随彼彼戏论言说。自相共相十种地中。由缘总法者。相杂缘故。无缘别法而修正智。若不尔者无分别智所集资粮。不应得有。出世者是无分别智后得。即是清净世间能安立智。此后得故。清净有相境故。世间而得转依者。谓经多劫修无分别后得智故。而得转依。谓心心法相续清净。为欲证得三种佛身精勤修行者。后当广说

论曰。声闻现观菩萨现观。有何差别。谓菩萨现观与声闻异。由十一种差别应知。一由所缘差别。以大乘法为所缘故。二由资持差别。以大福智二种资粮。为资持故。三由通达差别。以能通达补特伽罗法无我故。四由涅槃差别。摄受无住大涅槃故。五由地差别。依于十地而出离故。六七由清净差别。断烦恼习净佛土故。八由于自他得平等心差别。成熟有情。加行无休息故。九由生差别。生如来家故。十由受生差别。常于诸佛大集会中摄受生故。十一由果差别。十力无畏不共佛法。无量功德果成满故

释曰。声闻菩萨现观差别。略有十种或十一种。所缘差别中。菩萨现观以大乘法为闻慧等三种所缘。声闻现观声闻乘法为其所缘。资持差别中。福资粮者。谓施戒忍三种加行。智资粮者。谓精进静虑及闻慧等。言资粮者。经无量劫所运集故。通达差别中声闻现观唯能通达补特伽罗空无我理。菩萨现观俱能通达补特伽罗法空无我。涅槃差别中菩萨现观摄受悲慧方便资粮。生死涅槃无所住着以为涅槃。声闻现观唯住无为以为涅槃。地差别中菩萨现观。依于十地而得出离。声闻乘中无有如是诸地建立。清净差别中。菩萨现观永断烦恼并诸习气。及能清净众宝佛土。声闻现观虽断烦恼。未除习气全不能净众宝佛土。言习气者。虽无烦恼。然其所作似有烦恼。自他平等心差别中。菩萨现观证得自他平等法性。成熟有情加行无绝。声闻现观分别自他。唯修自利不修他利。生差别中菩萨现观。于如来家法界中生。是佛真子。如轮王家生有相子。非如声闻同于下贱无智婢子。受生差别中菩萨现观。常于诸佛大集会中。莲花台上结加趺坐。乃至成佛恒受化生。所言诸佛大集会者。谓无漏界诸佛国土。非如声闻处母胎等。果差别者。菩萨现观。力无畏等无量功德众所庄严。能无功用起作一切利有情事。证得法身以为胜果。余用无漏转生为果

论曰。此中有二颂

  名事互为客　　其性应寻思
  于二亦当推　　唯量及唯假
  实智观无义　　唯有分别三
  彼无故此无　　是即入三性

释曰。以二伽他总摄寻思及寻思果。令易解了。名事互为客其性应寻思者。谓名于事为客。事于名亦尔。非如一类。谓声与义相称而生。互相系属于二亦当推唯量及唯假者。谓于自性及差别中。亦当推寻唯有分别唯有假立。其事云何。谓此二种唯有分别。唯有假立差别言说。都无真实自性差别。言实智者。谓从寻思所生四种如实遍智。观无义者。谓观其义本来无有。唯有分别三者。观见唯有三种分别。谓名分别。自性假立分别。差别假立分别。彼无故此无者。谓义无故观此三种分别亦无。是即入三性者。如上所说即是悟入三种自性。谓初颂前半。观名与事更互为客。即是悟入遍计所执自性。初颂后半。观彼二种自性差别。唯有分别唯有假立。即是悟入依他起自性。第二颂中即是悟入圆成实自性。此中但遣遍计所执各别心境。伏除分别不无其事。若不尔者系缚解脱俱不应成。净与不净皆无有故

论曰。复有教授二颂。如分别瑜伽论说

  菩萨于定位　　观影唯是心
  义想既灭除　　审观唯自想
  如是住内心　　知所取非有
  次能取亦无　　后触无所得

释曰。谁能如是寻思得果。如是教授当复为谁。为答此问说于二颂。菩萨于定位观影唯是心者。谓观所有似法似义。定所行影唯是内心。如经言。我说识所缘唯识所现故。言菩萨者。即说能观。于定位者。心住一境。义想既灭除者。谓由彼影遣其义想。审观唯自想者。谓审观察如是似法似义之相。唯我定心之所变现。如是住内心者。是心于尔时即住自心义。知所取非有次能取亦无者。谓先已了所取是无。如所取性既无所有。所取性上能取之性亦不得成。后触无所得者。谓从此后证无二性所得真如

论曰。复有别五现观伽他。如大乘经庄严论说

  福德智慧二资粮　　菩萨善备无边际
  于法思量善决已　　故了义趣唯言类
  若知诸义唯是言　　即住似彼唯心理
  便能现证真法界　　是故二相悉蠲除
  体知离心无别物　　由此即会心非有
  智者了达二皆无　　等住二无真法界
  慧者无分别智力　　周遍平等常顺行
  灭依榛梗过失聚　　如大良药销众毒
  佛说妙法善成立　　安慧并根法界中
  了知念趣唯分别　　勇猛疾归德海岸

释曰。福德智慧二资粮菩萨善备无边际者。谓施等三波罗蜜多名福资粮。第六般若波罗蜜多名智资粮。精进俱修故通二种。静虑亦尔。若缘无量属福资粮。其余属智。福智积集故名资粮。言善备者。是圆满义。经无数时差别圆满名无边际。于法思量善决已者。谓于一切契经等法。由定后智极善决定得无犹豫故。了义趣唯言类者。是故能了一切义趣。唯用意言分别为因。若知诸义唯是言即住似彼唯心理者。谓若了知一切义相唯是意言。即能安心住似义相种种变现唯心理中得决定故。此第二颂初半显示菩萨在顺决择分位。初颂显示此位加行。便能现证真法界是故二相悉蠲除者。由先了达义无所有。住唯心故能除所取能取二相。现证无二真实法界。善决定智依此生故。此前半颂及后第三显见道位。如所现证次当显示。体知离心无别物由此即会心非有者。谓知离心无别一切所缘境界。由彼无故能缘心性亦不得成。智者了达二皆无者。胜慧相应故名智者。于二无性能决定知故名了达遍计所执。所缘能缘本来无性名二皆无等。住二无真法界者。平等安住故名等住。所取能取悉皆远离故言二无。如是现证法界。非虚名真法界。慧者无分别智力者。谓诸菩萨无分别智所有功能。周遍平等常顺行者。谓总内外故名周遍。如所取无能取亦尔。故名平等。随顺观察契经等法其性平等。譬如虚空故名顺行。时恒故常。灭者除也。依谓一切杂染法因难可悟入。喻于榛梗。诸杂染法名为过失。习气积集故名为聚。如大良药销众毒者。其义易了。能除远入诸过失故如阿揭陀。此第四颂显示修道。佛说妙法善成立者。谓牟尼尊所说正法极善成立。安慧并根法界中者。谓安其慧置佛所说善成立法。并其根本真法界中。根者谓此是觉因故。或总缘法名为根本。谓一切经皆以十地为根本故。法依彼转故名法界。即诸法空。了知念趣唯分别者。谓后得智依法界转。了知念趣唯是分别。离分别外无所念法。谓彼所念契经等法。及所应念波罗蜜多。并彼果等。遍计所执性皆无故。勇猛疾归德海岸者。谓诸菩萨由先渐次修习现观。无分别智后得智故。速能证获一切功德圆满佛果。谓如来地超度无边因位功德。名德海岸。如有颂言

  证三菩提时　　顿成圆满果
  度无边德海　　至无等等位

疾者速也。经无量劫乃成佛果。时既长久云何言疾。此义不然。时劫长远。唯分别故。如有颂言

  处梦谓经年　　寤乃须臾顷
  故时虽无量　　摄在一刹那

又佛精进极炽然故。虽经多劫而谓少时。如有颂言

  愚修虽少时　　怠心疑已久
  佛于无量劫　　勤勇谓须臾

言勇猛者即智慧力。成无分别后得智故。无所怯惮故名勇猛。此颂显示至第一义最胜尊高究竟道位

摄大乘论释卷第六摄大乘论释卷第七

        无性菩萨造

        三藏法师玄奘奉　诏译

    彼入因果分第五

论曰。如是已说入所知相。彼入因果云何可见。谓由施戒忍精进静虑般若六种波罗蜜多。云何由六波罗蜜多得入唯识。复云何六波罗蜜多成彼入果。谓此菩萨不着财位。不犯尸罗。于苦无动。于修无懈。于如是等散动因中不现行时心专一境。便能如理简择诸法得入唯识菩萨。依六波罗蜜多入唯识已。证得六种清净增上意乐所摄波罗蜜多。是故于此设离六种波罗蜜多现起加行。由于圣教得胜解故。及由爱重随喜欣乐诸作意故。恒常无间相应方便修习六种波罗蜜多。速得圆满

释曰。入唯识因。谓加行时世间六种波罗蜜多今当显示。谓此菩萨不着财位者。无所贪求故名不着贪着。即是舍所对治。此即是施波罗蜜多所对治障。后五亦尔。不犯尸罗者。毁犯是戒波罗蜜多所对治障。于苦无动者。忿动是忍波罗蜜多所对治障。于修无懈者懈是精进波罗蜜多所对治障。心专一境者。谓于静虑波罗蜜多所对治障。散动因中远离不转持心令定。便能如理简择诸法者。即是般若波罗蜜多。由此六种波罗蜜多得入唯识。既得入已证得清净增上意乐所摄殊胜果分六种波罗蜜多。是故设离波罗蜜多现起加行恒常无间修习六种波罗蜜多。速得圆满为不尔耶。若于尸罗波罗蜜多不起加行应是犯戒。此义不然不起勉励加行故。若于尸罗不起加行应有此失。非不发起勉励加行而有此失。由于圣教得胜解等任运加行。是故无失。此中于圣教得胜解者。谓于波罗蜜多相应圣教。虽极甚深而能信解。爱重作意者。谓于已得波罗蜜多受功德味。随喜作意者。谓于十方一切世界他相续中。或于各别自相续中波罗蜜多。深心庆喜。欣乐作意者。谓于未来愿我与此恒不相离及转殊胜

论曰。此中有三颂

  已圆满白法　　及得利疾忍
  菩萨于自乘　　甚深广大教
  等觉唯分别　　得无分别智
  悕求胜解净　　故意乐清净
  前及此法流　　皆得见诸佛
  了知菩提近　　以无难得故

由此三颂总显清净增上意乐有八种相。谓资粮故。堪忍故。所缘故。作意故。对治故。自体故瑞相故。胜利故。如其次第诸句伽他应知显示

释曰。此中显说清净增上意乐。所有资粮堪忍所缘作意对治自体瑞相胜利。已圆满白法者。谓先于彼胜解行地善备资粮。白法圆满。是谓资粮。及得利疾忍者。谓简软中唯取上品。谛察法忍此忍转时即是堪忍。菩萨于自乘甚深广大教者。谓缘大乘深广圣教。其义微细名为甚深。即法无我殊胜。威德相应名为广大。即是虚空藏等诸三摩地。是谓所缘。等觉唯分别者。觉一切法唯有分别是谓作意。得无分别智者。即是对治。悕求胜解净故意乐清净者。即是自体由此意乐以信及欲为自体故。前及此法流皆得见诸佛者。即是瑞相。前谓意乐清净位前此谓于此三摩地中。法流即说在三摩地处于定中见。诸佛故了知菩提近以无难得故者。谓因见佛知菩提近。释此义言无难得故。即是胜利。于此位中见菩提近得此能得胜方便故。得不为难。修集资粮势力成熟有堪能故。如是三颂总释清净增上意乐八相差别

论曰。何因缘故波罗蜜多唯有六数。成立对治所治障故。证诸佛法所依处故。随顺成熟诸有情故。为欲对治不发趣因故。立施戒波罗蜜多。不发趣因。谓着财位及着室家。为欲对治虽已发趣复退还因故。立忍进波罗蜜多。退还因者。谓处生死有情违犯所生众苦。及于长时善品加行所生疲怠。为欲对治虽已发趣。不复退还而失坏因故。立定慧波罗蜜多。失坏因者。谓诸散动及邪恶慧。如是成立对治所治障故。唯立六数。又前四波罗蜜多是不散动因。次一波罗蜜多不散动成就。此不散动为依止故。如实等觉诸法真义。便能证得一切佛法。如是证诸佛法所依处故。唯立六数由施波罗蜜多故。于诸有情能正摄受。由戒波罗蜜多故。于诸有情能不毁害。由忍波罗蜜多故。虽遭毁害而能忍受。由精进波罗蜜多故。能助经营彼所应作。即由如是摄利因缘。令诸有情于成熟事有所堪任。从此已后心未定者令其得定。心已定者令得解脱。于开悟时彼得成熟。如是随顺成熟一切有情。唯立六数应如是知

释曰。次当开示最后颂中。数相等义先依立数说如是言。成立对治所治障等。谓三因缘波罗蜜多数唯有六不多不少。先当开示成立对治所治障故。为欲对治不发趣因故立施戒波罗蜜多。乃至为欲对治而失坏因故立定慧波罗蜜多。失坏因者。谓诸散动及邪恶慧颠倒执取诸鄙恶智名邪恶慧。如诸外道是失坏因。余句如文分明易了。证诸佛法所依处者。第二建立六数因缘。以是一切佛法因故。波罗蜜多唯有六数不增不减。其义云何。谓前四波罗蜜多是不散动因。能令所治散动无故。静虑波罗蜜多不散动成就。令不散动得圆满故。依此静虑波罗蜜多如实等觉诸法真义。能于所缘正遍知故。诸佛法者。谓十力等。证谓成办。随顺成熟诸有情者。第三成立六数因缘。由施波罗蜜多于诸有情能正摄受。由戒波罗蜜多于诸有情能不毁害。不生恼。故由忍波罗蜜多虽遭毁害而能忍受。能忍受故能饶益他。不反报故。由精进波罗蜜多。助彼所作。由静虑波罗蜜多。心未定者令其得定。由慧波罗蜜多。心已定者令得解脱。开悟时者。谓教授彼令于境界得悟入时。彼得成熟者。彼于境界已得成熟。言成熟者。谓所治障消融溃散如痈已熟。或能对治成满可用如食已熟

论曰。此六种相云何可见。由六种最胜故。一由所依最胜。谓菩提心为所依故。二由事最胜。谓具足现行故。三由处最胜。谓一切有情利益安乐事为依处故。四由方便善巧最胜。谓无分别智所摄受故。五由回向最胜。谓回向无上正等菩提故。六由清净最胜。谓烦恼所知二障无障所集起故。若施是波罗蜜多耶设波罗蜜多是施耶。有施非波罗蜜多应作四句。如于其施。如是于余波罗蜜多亦作四句。如应当知

释曰。依所立相说如是言。谓由六种最胜故等。六种最胜其言易了。不须别释。具足现行故者。于内外事一切种类皆能舍故。无分别智所摄受故者。谓三轮清净。施者受者施物。分别皆远离故。余文易了。有是施非波罗蜜多者。谓离六种最胜而修布施。有是波罗蜜多非施者。谓六种最胜所集戒等。有亦施亦波罗蜜多者。谓六种最胜所集布施。有非施非波罗蜜多者。谓离六种最胜而修戒等。如于施中作是四句。如是于余戒等五中。如其所应皆善安立。故有颂言

  麟角喻无有　　六波罗蜜多
  唯我最胜尊　　上品到彼岸

论曰。何因缘故。如是六种波罗蜜多此次第说。谓前波罗蜜多。随顺生后波罗蜜多故

释曰。随顺生后波罗蜜多故者。谓于财位不贪着已能守尸罗。具尸罗已便能忍受。能忍受已堪耐乖违故发精进。发精进已心便得定。心得定已能如实知。故此六种如是次第

论曰。复次此诸波罗蜜多训释名言。云何可见。于诸世间声闻独觉施等善根。最为殊胜能到彼岸。是故通称波罗蜜多。又能破裂悭吝贫穷。及能引得广大财位福德资粮故名为施。又能息灭恶戒恶趣。及能取得善趣等持故名为戒。又能灭尽忿怒怨仇。及能善住自他安隐故名为忍。又能远离所有懈怠恶不。善法及能出生无量善法。令其增长故名精进。又能消除所有散动。及能引得内心安住故名静虑。又能除遣一切见趣诸邪恶慧。及能真实品别知法故名为慧

释曰。释总名者。于诸世间声闻独觉施等善根最为殊胜。能到彼岸是故通名波罗蜜多。到彼岸名是最胜义。释别名者。谓于因时能破悭吝。亦能引广福德资粮。及于果时能裂贫穷得大财位故名为施。余释别名其文易了

论曰。云何应知修习如是波罗蜜多。应知此修略有五种。一现起加行修。二胜解修。三作意修四方便善巧修。五成所作事修。此中四修如前已说。成所作事修者。谓诸如来任运佛事无有休息。于其圆满波罗蜜多复更修习六到彼岸又作意修者。谓修六种意乐所摄。爱重随喜欣乐作意。一广大意乐。二长时意乐。三欢喜意乐。四荷恩意乐。五大志意乐。六纯善意乐。若诸菩萨乃至若干无数大劫。现证无上正等菩提。经尔所时一一刹那假使顿舍一切身命。以殑伽河沙等世界盛满七宝奉施如来。乃至安坐妙菩提座。如是菩萨布施意乐犹无厌足。经尔所时一一刹那假使三千大千世界满中炽火。于四威仪常乏一切资生众具。戒忍精进静虑般若。心恒现行乃至安坐妙菩提座。如是菩萨所有戒忍精进静虑般若。意乐犹无厌足。是名菩萨广大意乐。又诸菩萨即于此中无厌意乐。乃至安坐妙菩提座。常无间息。是名菩萨长时意乐。又诸菩萨以其六种波罗蜜多饶益有情。由此所作深生欢喜。蒙益有情所不能及。是名菩萨欢喜意乐。又诸菩萨以其六种波罗蜜多。饶益有情见彼于己有大恩德。不见自身于彼有恩。是名菩萨荷恩意乐。又诸菩萨即以如是六到彼岸所集善根。深心回施一切有情。令得可爱胜果异熟。是名菩萨大志意乐。又诸菩萨复以如是六到彼岸所集善根。共诸有情回求无上正等菩提。是名菩萨纯善意乐。如是菩萨修此六种意乐所摄爱重作意。又诸菩萨于余菩萨六种意乐。修习相应无量善根深心随喜。如是菩萨修此六种意乐所摄随喜意乐。又诸菩萨深心欣乐一切有情六种意乐。所摄六种到彼岸修。亦愿自身与此六种到彼岸修恒不相离。乃至安坐妙菩提座如是菩萨修此六种意乐所摄欣乐作意。若有闻此菩萨六种意乐所摄作意修已。但当能起一念信心。尚当发生无量福聚。诸恶业障亦当消灭。何况菩萨

释曰。修谓数习。现起修等差别有五。现起加行修者。谓于施等无颠倒转。如有颂言

  施者殊胜　　信等具足　　恭敬应时
  自手施等

又如颂言

  利他加行于有情　　不简有力若无力
  于一切时一切施　　随力所能广饶益

胜解修者。谓由信欲而生胜解。于佛圣教深印顺故。生乐欲故。如有颂言

  虽于利业无功用　　而于佛教生胜解
  由信及欲共相应　　意乐常修无懈废

作意修者。谓爱重随喜欣乐作意所摄修习。如前已说。方便善巧修者。谓无分别智摄受修习。亦如前说。成所作事修者。谓诸如来到彼岸法虽极圆满。为饶益他本愿力故。不作功用。随彼所能现行施等所应作事。此即是修为彼修故亦名为修。又声欲说前作意修有差别义。谓修六种意乐所摄。乃至意乐犹无厌等。其言易了。少处少说。无厌足者。谓无疲倦。经尔所时一一刹那。或有说言。经尔所时为一刹那。谓经于三无数劫量为一刹那。如是刹那积集乃至得大菩提。经尔所时一一刹那。其义易了。满中炽火者。显乏少胜处。常乏一切资生众具者。显无苦对治资生众具。为治诸苦而摄受故。于四威仪者。显志广大。虽乏胜处及资生具。而于一切四威仪中。修行戒等到彼岸心常现前故。长时意乐者。谓于久时无间息故。荷恩意乐者。谓深信解诸来求者。是善友故。此即信彼诸来求者。施己可爱妙果异熟。是故荷恩。大志意乐者。谓此意乐大志相应。为欲利益诸有情故。回已善根施与一切如是意乐最为殊胜。是故说名大志意乐。纯善意乐其义是一。立别名者。若以施等回求三有财位圆满。如是意乐悕求苦具。似有罪故不名纯善。若以施等共诸有情回求佛果。如是意乐不求苦具。都无罪故说名纯善。修此六种意乐所摄三种作意。其言易了无烦重释。诸恶业障亦当消灭者。谓令无果故或治恶趣故

论曰。此诸波罗蜜多差别云何可见。应知一一各有三品。施三品者。一法施二财施三无畏施。戒三品者。一律仪戒二摄善法戒三饶益有情戒。忍三品者。一耐怨害忍二安受苦忍三谛察法忍。精进三品者。一被甲精进二加行精进三无怯弱无退转无喜足精进。静虑三品者。一安住静虑二引发静虑三成所作事静虑。慧三品者。一无分别加行慧二无分别慧三无分别后得慧

释曰。由此一一波罗蜜多。各有三品显示差别。言法施者。谓无染心如实宣说契经等法。言财施者。谓无染心舍资生具。无畏施者。谓止损害济拔惊怖。又法施者为欲资益他诸善根。财施为欲资益他身。无畏施为欲资益他心。律仪戒者。谓于不善能远离法。防护受持。由能防护诸恶不善身语等业故名律仪。此即是戒此能建立后二尸罗。由自防护能修供养佛等善根。及能饶益诸有情故。摄善法戒能令证得力无畏等一切佛法。饶益有情戒能助有情如法所作。平等分布无罪作业。成熟有情耐怨害忍。是诸有情成熟转因安受苦忍。是成佛因。寒热饥渴种种苦事皆能忍受无退转故。谛察法忍是前二忍所依止处。堪忍甚深广大法故。被甲精进。谓最初时自励。我当作如是事。即是解释契经所说初有势句。加行精进。谓加行时如所意乐勤修加行。即是解释契经所说次有勤句。无怯弱无退转无喜足精进。谓随意乐所作善事。乃至安坐妙菩提座终不放舍。于自疲苦心不退屈名无怯弱。于他逼恼心不移动名无退转。乃至菩提于其中间。进修善品尝无懈废名无喜足。如是三句如数解释契经所说。有勇坚猛于诸善法不舍轭句。安住静虑为得现法乐住。离慢见爱得清净故。引发静虑为能引发六神通等殊胜功德成所作事静虑。为欲饶益诸有情类。以能止息饥俭疾疫诸怖畏等苦恼事故。无分别加行慧。谓真观前胜方便智。无分别慧。谓真观智。无分别后得慧。谓现观边诸世俗智。能起种种说法等事

论曰。如是相摄云何可见。由此能摄一切善法。是其相故。是随顺故。是等流故

释曰。由此能摄一切善法者。此答非理不如问故。前总问言如是相摄云何可见。无此过失说此能摄一切善法。其义已说。彼亦摄此一切善法者。谓施等信等诸念住等力等为后。是其相故者。是摄体相。谓此施等与彼施等更互相摄。是随顺故者。是摄随顺信等善法施等善心彼所修故。于施等中彼随转故。信等即是诸善。大施及念住等菩提分法。是等流故者。是摄等流。谓无诤等及十力等。是到彼岸等流果故。如有颂言

  地及到彼岸　　诸佛法所依
  转依法身等　　诸功德为果

论曰。如是所治。摄诸杂染云何可见。是此相故。是此因故。是此果故

释曰。如是所治悭吝犯戒忿恚懈怠散动恶慧。云何能摄一切杂染。是此相故者。谓摄悭等差别自性离他性故。是此因故者。谓不信等邪见为后。悭等因故

论曰。如是六种波罗蜜多。所得胜利云何可见。谓诸菩萨流转生死富贵摄故。大生摄故。大朋大属之所摄故。广大事业加行成就之所摄故。无诸恼害性薄尘垢之所摄故。善知一切工论明处之所摄故。胜生无罪乃至安坐妙菩提座。常能现作一切有情一切义利。是名胜利

释曰。今当显说波罗蜜多胜利功德富贵摄故者。是施波罗蜜多。所得胜利胜生无罪乃至是名胜利。于一切处应遍配属大生摄故者。是戒波罗蜜多所得胜利。胜善趣摄故。名大生。大朋大属之所摄故者。是忍波罗蜜多所得胜利。朋谓亲族。属谓奴婢。广大事业加行成就之所摄故者。是精进波罗蜜多所得胜利。广大事业谓轮王等。于中策励名为加行。所作皆办故名成就。由此所摄无所挂碍无诸恼害。性薄尘垢之所摄故者。是静虑波罗蜜多所得胜利。由静虑故感此威力。善知一切工论明处之所摄故者。是慧波罗蜜多所得胜利。胜生无罪者。虽同世间得最胜生。不如世间胜生有罪。既无有罪时又无边无间相续。乃至菩提非如世间唯自利益。常能现作一切有情一切义利

论曰。如是六种波罗蜜多互相决择。云何可见。世尊于此一切六种波罗蜜多。或有处所以施声说。或有处所以戒声说。或有处所以忍声说。或有处所以勤声说。或有处所以定声说。或有处所以慧声说。如是所说有何意趣。谓于一切波罗蜜多修加行中。皆有一切波罗蜜多互相助成。如是意趣

释曰。谓于一切波罗蜜多修加行中。皆有一切波罗蜜多互相助成。如是意趣者。谓于一一修加行中即有一切更互相助。谓修施时禁防忍受策励专心能善了知业果相属。如是施中即有余转。若修戒时远离悭吝忿恚懈怠散动邪见。如是戒中即有余转。修习所余波罗蜜多亦如是说。如有颂言

  施时无贪无犯戒　　无嫉无恚起慈心
  诸来求者便施与　　无惓无乱无异见

复有颂言

  施性中现有　　六波罗蜜多
  财施无畏施　　法施所摄故

论曰。此中有一嗢拖南颂

  数相及次第　　训词修差别
  摄所治功德　　互决择应知

释曰。总摄前文义如上释

    摄大乘论释彼修差别分第六

论曰。如是已说彼入因果。彼修差别云何可见。由菩萨十地。何等为十。一极喜地。二离垢地。三发光地。四焰慧地。五极难胜地。六现前地。七远行地。八不动地。九善慧地。十法云地如是诸地安立为十。云何可见。为欲对治十种无明所治障故。所以者何。以于十相所知法界有十无明所治障住。云何十相所知法界。谓初地中由遍行义。第二地中由最胜义。第三地中由胜流义。第四地中由无摄受义。第五地中由相续无差别义。第六地中由无杂染清净义。第七地中由种种法无差别义。第八地中由不增不减义。相自在依止义。土自在依止义。第九地中由智自在依止义。第十地中由业自在依止义。陀罗尼门三摩地门自在依止义。此中有三颂

  遍行最胜义　　及与胜流义
  如是无摄义　　相续无别义
  无杂染净义　　种种无别义
  不增不减义　　四自在依义
  法界中有十　　不染污无明
  治此所治障　　故安立十地

复次应知。如是无明于声闻等非染污。于诸菩萨是染污

释曰。为欲显示入所知相因果所摄波罗蜜多。随其所应善修习已能除见修所应断障。故辩因果修位差别。由菩萨十地者。谓诸菩萨于此地中修习现观。离过离贪修菩提分。观察诸谛观察缘起。于无相中。若有功用若无功用。得胜辩才逮真灌顶。除灭所知烦恼障等。故此修位有十地别。以于十相者。谓遍行等。所知法界者。谓由十相所显法界。有十无明所治障住者。谓于十相有十无明十所治障为障而住。为断此障修十相智。由十相智得入十地法无我智。分位名地。谓初地中由遍行义者。即初地中一切法空无有少法而非是空故名遍行。了知此义得入初地。第二地中由最胜义者。谓此空理一切法中最为殊胜。如说离欲最为殊胜。了知此义得入二地。第三地中由胜流义者。谓此所流教法最胜故。舍身命求此善说不以为难。了知此义得入三地。第四地中由无摄受义者。谓契经等法爱断故。不计我所观此非自非他所摄。了知此义得入四地。第五地中由相续无差别义者。谓了知此非如色等相续差别。了知此义得入五地。第六地中由无杂染清净义者。谓知自性本无杂染亦无清净。杂染为先后可净故。了知此义得入六地。第七地中由种种法无差别义者。如契经等种种法别。此不如是。了知此义得入七地。第八地中由不增不减义者。谓法外无用所以不增诸法不坏所以不减。或染法减时此无有减。净法增时此无有增。相自在依止义土自在依止义者。谓即于此第八地中。所证法界是二自在。所依止处随所求相欲令现前。如其胜解即能现前名相自在。随所希求金等宝土。如其胜解则能现前名土自在。前诸地中虽亦得此无差别住。然作功用后乃得成。于此地中能无功用随欲即成故名自在。了知此义入第八地。第九地中由智自在依止义者。谓此地中得无碍辩所依止故。分证得智波罗蜜多。于一切法不随其言。善能了知诸意趣义。如实成熟一切有情受胜法乐。了知此义得入九地。第十地中由业自在等依止义者。谓随所欲得身语意业用自在。依五神通随自作业皆能成办。得文义持诸陀罗尼自在力故。能持一切佛所宣说文义无忘。得三摩地自在力故。于诸等至能持能断。随其所欲虚空藏等诸三摩地三摩钵底。而能现前。第十地中所证法界。是如此等自在所依。了知此义得入十地。如是无明于声闻等非染污者。非所断故。非所断者不为入彼能治地。故于其涅槃不为障故。于诸菩萨是染污者。是所断故。是所断者。正为入彼能治地故。菩萨所求一切种智。如是无明能为障故。入初地时已得通达一切法界。何故复立后后差别。为欲显示诸住现行故立后后诸地差别。谓为安住如其所得法界胜住品别现行。非唯证得便生喜足坦然而住

论曰。复次何故初地说名极喜。由此最初得能成办自他义利胜功德故。何故二地说名离垢。由极远离犯戒垢故。何故三地说名发光。由无退转等持等至所依止故。大法光明所依止故。何故四地说名焰慧。由诸菩提分法焚灭一切障故。何故五地名极难胜。由真谛智与世间智更互相违。合此难合令相应故。何故六地说名现前。由缘起智为所依止。能令般若波罗蜜多现在前故。何故七地说名远行。至功用行最后边故。何故八地说名不动。由一切相有功用行不能动故。何故九地说名善慧。由得最胜无碍智故。何故十地说名法云。由得总缘一切法智。含藏一切陀罗尼门三摩地门。譬如大云能覆如空广大障故。又于法身能圆满故

释曰。依声转因故作是说。由此最初得能成办自他义利胜功能故谓如菩萨入现观时。得能成办自他义利。最胜功能生极欢喜。非声闻等入现观时唯得成办自利功能。生如是喜故不说彼名极喜地。若初地中不相应者。自后诸地亦不相应。此为先故由极远离犯戒垢者。谓此地中性戒成故。远离一切毁戒秽垢。由无退转等持等至所依止者。谓此地中证希有定。能发智光照了诸法故名发光。得已不失名无退转诸静虑定说名等持。诸无色定说名等至。或等持者心一境相。言等至者正受现前。大法光明所依止者。谓此地中与定相应无退转故。于诸大乘契经等法得智光明。此地是彼所依因故名为发光。言焰慧者。谓此地中有慧焰故名为焰慧。此即一切菩提分法皆名为焰。烧诸障故此菩提分多安住时。令诸烦恼皆成灰烬。极难胜者最难可胜。谓真谛智是无分别。世间书印工论等智是有分别。真俗谛智更互相违。难可引发令其相应。此能和合令不相违。故极难胜。言现前者。最胜般若到彼岸住现在前故。谓此地中证缘起住。缘起智力令无分别。最胜般若到彼岸住。自在现前知一切法。无染无净。言远行者。至功用行最后边故。谓此地中诸功用行最为究竟。一切法相虽不能动。而于无相犹有功用。言不动者。谓一切相及一切行皆悉不能动彼心故。第七地中虽一切相所不能动。不现行故。然不自在任运而转。有加行故。第八地中任运而转。不作加行无功用故。是名七八二地差别。言善慧者。谓得最胜四无碍解。无碍解智于诸智中最为殊胜。智即是慧故名善慧。四无碍者。法义词辩。由法无碍自在了知一切法句。由义无碍自在通达一切义理。由词无碍自在分别一切言词。由辩无碍遍于十方随其所宜自在辩说。于此地中最初证得。先未曾得无碍解智故名善慧。言法云者。由得总缘一切法智。总缘一切契经等法。不离真如。此一切法共相境智。譬如大云陀罗尼门三摩地门。犹如净水智能藏彼。如云含水有能生。彼胜功能故。又如大云覆隐虚空。如是总缘一切法智。覆隐如空广大无边惑智二障。言覆隐者。隔义断义。又如大云澍清冷水充满虚空。如是总缘一切法智。出生无量殊胜功德。充满所证所依法身

论曰。得此诸地云何可见。由四种相。一得胜解。谓得诸地深信解故。二得正行。谓得诸地相应十种正法行故。三得通达。谓于初地达法界时。遍能通达一切地故。四得成满。谓修诸地到究竟故

释曰。依得诸地说如是言。由四种相。一得胜解。谓得诸地深信解者。于地教法决定印可真实如是。二得正行。谓得诸地相应十种正法行者。得于教法。十种法行。谓于诸地相应教法书写供养转施听闻披读受持开示讽诵思惟修习。三得通达。谓于初地达法界时遍能通达一切地者。若于初地正通达时速能通达后一切地。此种类故如有颂言

  如竹破初节　　余节速能破
  得初地真智　　诸地疾当成

四得成满。谓修诸地到究竟者。谓地地中果分成满或最后满

论曰。修此诸地云何可见。谓诸菩萨于地地中修奢摩他毗钵舍那。由五相修。何等为五。谓集总修。无相修。无功用修。炽盛修。无喜足修。如是五修令诸菩萨成办五果。谓念念中销融一切粗重。依止离种种想。得法苑乐能正了知周遍无量无分限相。大法光明顺清净分。无所分别无相现行。为令法身圆满成办。能正摄受后后胜因

释曰。于地地中者。谓诸地非一故作重言。奢摩他者。谓能对治诸散动定。毗钵舍那者。谓能对治诸颠倒慧。于地地中修此二种皆由五相数数修习。五相即是集总修等。集总修者。谓集一切总为一聚简要修习。余骨锁等事境界观。亦集一切总为一聚要略修习。为简彼故说无相修。于离众相真法界中。遣事差别而修习故。虽无相修或有功用。为显此修不藉功力任运而转故。次复说无功用修。离作功用任运转故。虽无功用任运而修。或胜或劣二种不定故。复第四说炽盛修。言炽盛者即是增胜。虽炽盛修或少所得便生喜足。谓且修此余何用为。故最后说无喜足修。非但无相及无功用炽盛而修。何者为证最上佛果应勤修习。销融一切粗重依止者。阿赖耶识名粗重依止。损坏彼聚故名销融。如大良药销诸病块。离种种想得法苑乐者。离我离法佛等相想。苑谓于中可以游玩。法谓法界法即是苑故名法苑。于此喜悦名法苑乐。证此故名得法苑乐。如王宫外上妙苑园。游戏其中受胜喜乐。法界亦尔。能正了知周遍无量无分限相。大法光明者。谓正通达十方无边无分量相。显照行故名法光明。如善诵习文字光明。顺清净分无所分别无相现行者。当来佛果名清净分。此能引彼故名为顺。无所分别无相现行。如佛轮王鲜白盖等。为令法身圆满成办。能正摄受后后胜因者。谓第十地说名圆满。若在佛地说名成办。感此之因最为殊胜说名胜因。前前诸因所招集故说名后后。如是五修随其数量得五种果

论曰。由增胜故。说十地中别修十种波罗蜜多。于前六地所修六种波罗蜜多。如先已说。后四地中所修四者。一方便善巧波罗蜜多。谓以前六波罗蜜多所集善根。共诸有情回求无上正等菩提故。二愿波罗蜜多。谓发种种微妙大愿引摄当来波罗蜜多殊胜众缘故。三力波罗蜜多。谓由思择修习二力。令前六种波罗蜜多无间现行故。四智波罗蜜多。谓由前六波罗蜜多。成立妙智受用法乐。成熟有情故。又此四种波罗蜜多。应知般若波罗蜜多无分别智后得智摄。又于一切地中非不修习一切波罗蜜多。如是法门是波罗蜜多藏之所摄

释曰。由增胜故说十地中别修十种波罗蜜多者。谓决定说修差别义为不尔耶。一一地中具修十种波罗蜜多。是故不应但决定说。此地修此波罗蜜多。由增胜言无此过失。此中但说增胜修义。不遮修余。如契经说。初地布施波罗蜜多最为增胜。其余一切波罗蜜多非不修习。随力随分乃至广说。于前六地所修六种波罗蜜多如先已说者。谓极喜等前六地中。修布施等六到彼岸。后四地中所修四者。谓远行等后四地中。修方便等四到彼岸。方便善巧者。谓不舍生死而求涅槃。是则说名方便善巧。若以前六波罗蜜多所集善根。共诸有情为欲饶益诸有情故。不舍有情。当知即是不舍生死。若以此善回求无上正等菩提。为证无上佛菩提故。当知即是希求涅槃。谓发种种微妙大愿引摄当来波罗蜜多殊胜众缘者。求未来世到彼岸缘。亦为饶益诸有情故。及为速证佛果涅槃。作是愿言。若是处有到彼岸缘。愿我未来当生于彼如是等愿无量无边故言种种。谓由思择修习二力者。于此力中且说二种。其余诸力亦摄在中。谓由前六波罗蜜多成立妙智受用法乐成熟有情者。由施等六成立此智。复由此智成立六种。谓数相等种种品类是则名为受用法乐。由此妙智能正了知此施此戒此忍进等。如所闻法饶益一切有情之类。是则名为饶益有情。又此四种波罗蜜多乃至后得智摄者。谓此所说方便等四是无分别后得智摄。若立十种波罗蜜多。第六般若唯是根本无分别智。若立六种波罗蜜多第六般若无分别智及后得智二智所摄。后得智中四到彼岸亦在第六般若摄故。如是法门是波罗蜜多藏所摄者。一切大乘教法皆名波罗蜜多藏。如是十地法门是彼藏所摄。由一一地皆是一切到彼岸藏之所摄故。以此证知一切地中具修一切波罗蜜多

论曰。复次凡经几时修行诸地可得圆满。有五补特伽罗。经三无数大劫。谓胜解行补特伽罗经初无数大劫修行圆满。清净增上意乐行补特伽罗及有相行无相行补特伽罗。于前六地及第七地经第二无数大劫修行圆满。即此无功用行补特伽罗。从此已上至第十地。经第三无数大劫修行圆满。此中有颂

  清净增上力　　坚固心升进
  名菩萨初修　　无数三大劫

释曰。有五补特伽罗经三无数大劫者。应知唯一补特伽罗位差别故。建立五种。谓后所说胜解行等。胜解行者。未证真如但依胜解勤修诸行。此经第一无数大劫修行圆满。清净增上意乐行者。谓得清净增上意乐。勤修诸行。此在六地名有相行。在第七地名无相行。如是二种补特伽罗。经于第二无数大劫修行圆满。已上乃至第十地中即此转名无功用行。经于第三无数大劫修行圆满。第八地中无功用行犹未成满。第九第十地中此行方得成满。此唯是一补特伽罗异位相应差别成五。如预流等从无始来生死流转。齐何当言三无数劫最初修行。为答此问故说伽他清净增上力者。谓善根力名清净力。此即说有善根力者。若大愿力名增上力。此意说有大愿力者。有善根力故能降伏所治。有大愿力故常值善知识。坚固心升进者。虽遇恶友方便破坏。终不弃舍大菩提心。现世当来所修善法运运增长终无退减。如是若时具善根力及大愿力。大菩提心坚固不退。所修善法念念增进不生喜足。顺旧而已齐是名为最初修行三无数劫

    摄大乘论释增上戒学分第七

论曰。如是已说因果修差别。此中增上戒殊胜云何可见。如菩萨地正受菩萨律仪中说。复次应知略由四种殊胜故此殊胜。一由差别殊胜。二由共不共学处殊胜。三由广大殊胜。四由甚深殊胜

释曰。依增上戒而学故名增上戒学。如菩萨地正受菩萨律仪中说者。谓如彼尸罗波罗蜜多品中广说。复次应知略由四种殊胜故。此殊胜等如后广释

论曰。差别殊胜者。谓菩萨戒有三品别。一律仪戒。二摄善法戒。三饶益有情戒。此中律仪戒应知二戒建立义故。摄善法戒应知修集一切。佛法建立义故。饶益有情戒。应知成熟一切有情建立义故

释曰。差别殊胜。谓诸菩萨具三种戒。即律仪戒摄善法戒饶益有情戒。声闻乘等唯有一种律仪尸罗。是故菩萨望彼殊胜。律仪戒者。谓正受远离一切品类。恶不善法。摄善法戒者。谓正修集力无畏等一切佛法。饶益有情戒者。谓不顾自乐。随所堪能令入三乘。舍生死苦证涅槃乐。律仪戒应知二戒建立义故者。是二戒因故。谓若防守身语意者。便能无倒修集一切清净佛法。亦能成熟一切有情令入三乘。余则不尔

论曰。共不共学处殊胜者。谓诸菩萨一切性罪不现行故与声闻共。相似遮罪有现行故与彼不共。于此学处有声闻犯菩萨不犯。有菩萨犯声闻不犯。菩萨具有身语心戒。声闻唯有身语二戒。是故菩萨心亦有犯非诸声闻。以要言之。一切饶益有情无罪身语意业。菩萨一切皆应现行皆应修学。如是应知说名为共不共殊胜

释曰。杀盗淫等贪等所生名为性罪。断生草等非贪等生说名遮罪。菩萨于中观有利益而无罪者一切应修。声闻不尔。又诸菩萨心亦有犯非诸声闻。谓唯内起欲恚害等诸恶寻思。不为发起身语二业。一切饶益有情无罪身语意业者。谓能利益安乐有情。不发自他贪等烦恼。如是一切菩萨应修

论曰。广大殊胜者。复由四种广大故。一由种种无量学处广大故。二由摄受无量福德广大故。三由摄受一切有情利益安乐意乐广大故。四由建立无上正等菩提广大故

释曰。种种无量学处广大者。谓诸菩萨所学尸罗。种种品类无量差别。所以广大。摄受无量福德广大者。谓此尸罗能摄无量福德资粮。所以广大。摄受一切有情利益安乐意乐广大者。谓此尸罗摄诸有情。此世他世世出世间舍恶摄善。若因若果饶益意乐。所以广大。建立无上正等菩提广大者。谓此尸罗建大菩提。所以广大。诸声闻等无如是事。是故殊胜

论曰。甚深殊胜者。谓诸菩萨由是品类方便善巧。行杀生等十种作业。而无有罪。生无量福速证无上正等菩提。又诸菩萨现行变化身语两业。应知亦是甚深尸罗。由此因缘或作国王示行种种恼有情事。安立有情毗奈耶中。又现种种诸本生事。示行逼恼诸余有情。真实摄受诸余有情。先令他心深生净信后转成熟。是名菩萨所学尸罗甚深殊胜

释曰。由是品类方便善巧者。谓诸菩萨悲愿相应。后得妙智。行杀生等十种作业而无有罪等者。谓爱乐善法。憎恶不善。见诸邪性说名后三。依止此故行杀等七而无有罪。生无量福速证菩提。或行前七不起后三。大数言十。或已伏除。为试彼力故心暂起。不能招苦故无有罪。能助道故生无量福。现行变化身语两业者。谓依化身发起两业。或依实身由化心发身语二业。意业无形不可变化。或虽现有贪嗔等事。于化有情无大义利。是故不说。安立有情毗奈耶中者。谓作国王制诸法律。示行逼恼令住其中。或一切善能灭众恶。或大涅槃灭除生死名毗奈耶。又现种种诸本生事者。谓诸菩萨诸本生事化心所现。或久成佛复示现行诸本生事。饶益有情令菩萨学。故后说言是名菩萨所学尸罗

论曰。由此略说四种殊胜。应知菩萨尸罗律仪最为殊胜。如是差别菩萨学处应知复有无量差别。如毗奈耶瞿沙方广契经中说

释曰。今于此中略说四种殊胜之相。于毗奈耶瞿沙经中广说。复有无量殊胜。此经即是菩萨藏摄。故名方广

摄大乘论释卷第七摄大乘论释卷第八

        无性菩萨造

        三藏法师玄奘奉　诏译

    增上心学分第八

论曰。如是已说增上戒殊胜。增上心殊胜云何可见。略由六种差别应知。一由所缘差别故。二由种种差别故。三由对治差别故。四由堪能差别故。五由引发差别故。六由作业差别故

释曰。如增上戒与声闻异。其增上心亦应有异。故为此问。六种差别略答此问。如后别释

论曰。所缘差别者。谓大乘法为所缘故

释曰大乘法者。菩萨藏中所有甚深广大教等。声闻等定非所能缘。是故殊胜

论曰。种种差别者。谓大乘光明集福定王贤守健行等三摩地。种种无量故

释曰。菩萨所得诸三摩地差别无量。此中略说为上首者。等余一切声闻乘等尚不闻名。何况能得

论曰。对治差别者。谓一切法总相缘智以楔出楔道理遣阿赖耶识中一切障粗重故

释曰无分别智所缘真如。是一切法共相所显。故说此智名总相缘。定能发此能对治智。亦名对治。圣道微妙。故如细楔。所治种子其性粗重故。如粗楔

论曰。堪能差别者。谓住静虑乐。随其所欲而受生故

释曰。由此静虑其性调顺有所堪能。随欲饶益诸有情处。不退静虑而往受生。声闻乘中无如是事。所以殊胜

论曰。引发差别者。谓能引发一切世界无碍神通故

释曰。由此定力。引发种种一切世界无碍神通

论曰。作业差别者。谓能振动炽然遍满。显示转变往来卷舒。一切色像皆入身中。所往同类或显或隐。所作自在伏他神通。施辩念乐放大光明。引发如是大神通故

释曰。由此定力引发种种神通所作。显谓显现。隐谓隐藏。所作自在。谓变魔王作佛身等。伏他神通。谓能映夺他神通力。无辩才者施以辩才。无念乐者施以念乐。为召他方远住菩萨放大光明。引发如是大神通者。引前所说种种神通。如是等类声闻等无。是故殊胜

论曰。又能引发摄诸难行。十难行故。十难行者。一自誓难行。誓受无上菩提愿故。二不退难行。生死众苦不能退故。三不背难行。一切有情虽行邪行而不弃故。四现前难行。怨有情所现作一切饶益事故。五不染难行。生在世间不为世法所染污故。六胜解难行。于大乘中虽未能了。然于一切广大甚深生信解故。七通达难行。具能通达补特伽罗法无我故。八随觉难行。于诸如来所说甚深秘密言词。能随觉故。九不离不染难行。不舍生死而不染故。十加行难行。能修诸佛安住解脱。一切障碍穷生死际不作功用。常起一切有情一切义利行故

释曰。如说菩萨修诸难行。一切难行十种所显。自誓难行誓受无上菩提愿者。不顾自乐。誓受饶益一切有情。甚为难故。不退难行生死众苦不能退者。久处生死。风寒等苦所不能退。甚为难故。不背难行一切有情虽行邪行而不弃者。于父母等行邪恶行。或无所用戏求眼睛。双足践蹋。不观其过而作饶益。甚为难故。现前难行怨有情所现作一切饶益事者。虽有重怨而现饶益。甚为难故。不染难行生在世间不为世法所染污者。常处世间利等八法所不能染。甚为难故。胜解难行等者。于微妙义殊胜神力。虽未能了而深信解。甚为难故。通达难行等者。通达现观等觉一义能具通达。遍计所执补特伽罗一切法性皆无所有。甚为难故。随觉难行等者。于佛所说秘密言词。舍随闻义。觉不闻义。甚为难故。不离不染难行等者。不舍生死不染彼过。甚为难故。加行难行等者。已断已脱一切烦恼及所知障。而恒现前起作一切利有情事。尽未来际常无休息。欣修此行甚为难故

论曰。复次随觉难行中。于佛何等秘密言词。彼诸菩萨能随觉了。谓如经言

释曰。第八难行其义未了。故须重释

论曰。云何菩萨能行惠施。若诸菩萨无少所施。然于十方无量世界广行惠施。云何菩萨乐行惠施。若诸菩萨于一切施都无欲乐。云何菩萨于惠施中深生信解。若诸菩萨不信如来而行布施。云何菩萨于施策励。若诸菩萨于惠施中不自策励。云何菩萨于施耽乐。若诸菩萨无有暂时少有所施。云何菩萨其施广大。若诸菩萨于惠施中离娑洛想。云何菩萨其施清净。若诸菩萨殟波陀悭。云何菩萨其施究竟。若诸菩萨不住究竟。云何菩萨其施自在。若诸菩萨于惠施中不自在转。云何菩萨其施无尽。若诸菩萨不住无尽。如于布施。于戒为初于慧为后。随其所应当知亦尔

释曰。若诸菩萨无少所施等者。谓诸菩萨一切有情摄为己体。通达自他平等性故。彼行施时即菩萨施故。无少施名能行施。又以一切所有财物施于一切。是故说名无少所施。又所施物施者受者。皆不可得三轮清净。是故说名无少所施。若诸菩萨于一切施都无欲乐者。此既遮言。是不乐义。于来求施当施我施先施我施。此等一切皆无欲乐。唯乐攀缘安住涅槃而行惠施。若诸菩萨不信如来而行布施者。谓证法性自了自信而行惠施。非唯信他。若诸菩萨于惠施中不自策励者。谓能任运常行施故。不须自策而能策他劝令施故。若诸菩萨无有暂时少有所施者。是一切时一切施义。若诸菩萨于惠施中离娑洛想者。此娑洛言。显目坚实密诠流散。今取密义离流散想。即三摩地是心住定而行施义。若诸菩萨殟波陀悭者。殟波陀言。显目生起密诠拔足。今取密义拔除悭足而行惠施。若诸菩萨不住究竟者。不同一向趣寂声闻。安住究竟无余涅槃。若诸菩萨于惠施中不自在转者。谓令悭等施所治障不自在转。若诸菩萨不住无尽者。谓得圆满无尽增上究竟佛果。而不安住。何者起化为饶益他常行惠施。如于布施于戒乃至当知亦尔者。类通余五。谓如经言。云何菩萨能具尸罗。若诸菩萨不护少戒。谓见自他平等性故。他护净戒即是自己具足尸罗

论曰。云何能杀生。若断众生生死流转。云何不与取。若诸有情无有与者自然摄取。云何欲邪行。若于诸欲了知是邪而修正行。云何能妄语。若于妄中能说为妄。云何具戍尼。若能常居最胜空住。云何波鲁师。若善安住所知彼岸。云何绮间语。若正说法品类差别。云何能贪欲。若有数数欲自证得无上静虑。云何能嗔恚。若于其心能正憎害一切烦恼。云何能邪见。若一切处遍行邪性。皆如实见

释曰。如经中说苾刍我是能杀等者。此中显彼所说意趣。若断众生生死流转者。断是杀义与问相应。无有与者自然摄取者。是无他求自摄益义。若于诸欲了知是邪而修正行者。谓如实知若境界欲若分别欲唯是邪乱。如有颂言

  佛说贪恚痴　　皆从分别起
  净不净颠倒　　此亦为缘生
  净不净颠倒　　为缘而有者
  彼自性皆无　　故欲非真实

若于妄中能说为妄者。说妄为妄故名妄语。如有颂言

  一切虚妄法　　世尊如实说
  于虚妄法中　　诸行最虚妄

若能常居最胜空住者。依世训释文词道理。答上所问具戌尼言。此具戍尼。显目离间语。密诠常胜空。具表胜义。戍表空义。尼表常义。今取密义问答相应。显则不尔。波鲁师等训释文词道理亦尔。此波鲁师。显目粗恶语。密诠住彼岸。今取密义。是故说言。若善安住所知彼岸。所知彼岸是一切智。佛于其中能善安住。名波鲁师。若正说法品类差别者。释绮间语其义易了。若有数数欲自证。得无上静虑者。如上训释文词道理。诸佛身中所有静虑说为无上。若于其心能正憎害一切烦恼者。已灭已断是憎害义。若一切处遍行邪性皆如实见者。谓见一切虚妄分别邪乱为性

论曰。甚深佛法者。云何名为甚深佛法。此中应释。谓常住法是诸佛法。以其法身是常住故。又断灭法是诸佛法。以一切障永断灭故。又生起法是诸佛法。以变化身现生起故。又有所得法是诸佛法。八万四千诸有情行及彼对治皆可得故。又有贪法是诸佛法。自誓摄受。有贪有情为己体故。又有嗔法是诸佛法。又有痴法是诸佛法。又异生法是诸佛法。应知亦尔。又无染法是诸佛法。成满真如。一切障垢不能染故。又无污法是诸佛法。生在世间。诸世间法不能污故。是故说名甚深佛法

释曰。甚深佛法契经所说其义云何。谓余经说。若常住法是诸佛法。广说乃至。又无污法是诸佛法。此中密意今当显示。以其法身是常住者。法身即是转依为相。离一切障。常住真如无变易故。或无垢秽无有挂碍无上妙智。如无色界而非异熟。是无漏故。此亦常住法身所摄。无差别故。非业烦恼所能为故。八万四千诸有情行及彼对治皆可得者。八万四千法蕴能治有贪有嗔有痴等分有情行故。四种各有二万一千。又无染法是诸佛法者。善净真如。一切障垢不能染故。余义易了不须重释。佛说如是秘密言词。复有何果。谓令说者易可安立。总括义故易为他说。即此因故。能令闻者易可受持。资粮易满。受持教故。易达法性。资粮满故。得佛证净。得大我故。法僧亦尔。并最胜故。由此证得现法乐住。觉知彼故于智者前论义决择入聪敏数。为斯十利说秘密言。声闻乘中亦说杀害于父母等密意言词。十利亦尔

论曰。又能引发修到彼岸。成熟有情净佛国土。诸佛法故应知。亦是菩萨等持作业差别

释曰。菩萨所得诸三摩地。复有四种作业差别。谓依此定能修一切波罗蜜多。成熟一切诸有情类。发神通等方便引令入正法故。能净佛土随欲能成金等宝故。能正修集力无畏等一切佛法。非离如是所说等持。能办修集到彼岸等。四种作业如声闻等

    摄大乘论释增上慧学分第九

论曰。如是已说增上心殊胜。增上慧殊胜云何可见。谓无分别智。若自性若所依若因缘。若所缘若行相。若任持若助伴。若异熟若等流。若出离若至究竟。若加行无分别后得胜利。若差别若无分别后得譬喻。若无功用作事。若甚深应知无分别智。名增上慧殊胜

释曰。心既在定能如实知故。等持无间说增上慧学。为不尔耶。摄取其明即名为学。慧之与学应无有异。若如是者依同处释。谓增上慧即是其学。若尔此中应无依义。谓依余慧而起于学。是故说名增上慧学。如前二学依戒而学。依定而学。非于此中依慧而学。慧即学故。应如是说。其加行慧依根本学。其根本慧依后得学。其后得慧依二无间而起修学。何等名为增上慧学。谓无分别智。今于此中最初自性。最后甚深。广释此智

论曰。此中无分别智离五种相以为自性。一离无作意故。二离过有寻有伺地故。三离想受灭寂静故。四离色自性故。五离于真义异计度故。离此五相。应知是名无分别智

释曰。依智自性说离五相。由遮诠门说智体相。以表诠门不可说故遣分别门。无分别智其相可了。若异此智应有分别。何等分别。谓后广说。无作意等。若无作意是无分别智。熟眠醉等无所作意。应成无分别智。然不应许由离功用应得无颠倒故。若过寻伺地是无分别智。第二静虑已上诸地。一切异生及声闻等应成无分别智。然彼无有无分别智。若想受灭是无分别智。此智体相难可成立无想等中。离心无有诸心法故。由意识灭说彼无心如前已说。若如其色是无分别智。应不得成无分别智。譬如大种所造色故。若于真义异相计度是无分别智。此智不成无分别性。以于真义异相计度。言此是真是无分别。有分别故

论曰。于此所说无分别智成立相中复说多颂

释曰。依前所说无分别智。略成立相广说多颂。次第别显。为显自性。故说初颂

论曰

  诸菩萨自性　　远离五种相
  是无分别智　　不异计于真

释曰。于此颂中由前三句遮五种相。方便显示无分别智。由第四句正说自性。不异计于真者。谓于真义不异计度以为自性。自性自体义无差别。如说环钏金为自体。次后一颂说智所依

论曰

  诸菩萨所依　　非心而是心
  是无分别智　　非思义种类

释曰。智是心法故应依心。依止于心而无分别。不应道理。心声即是思量相故。若依非心譬如众色。不应成智。为解如是双结过失故说半颂。非思义种类者。谓无分别智所依非心。非思义故。亦非非心为所依止心种类故。以心为因。数习势力引得此位。名心种类。此即显示智所依心。出过一切思量分别。次有一颂显智因缘

论曰

  诸菩萨因缘　　有言闻熏习
  是无分别智　　及如理作意

释曰。因缘与能作因缘义一。有言闻熏习者。谓有于他大乘言音故名有言。闻谓听闻即彼非余。由此所引功能差别说名熏习。及如理作意者。谓此为因所生意言。如理作意顺理清净故名如理。智必有境故。次一颂说智所缘

论曰

  诸菩萨所缘　　不可言法性
  是无分别智　　无我性真如

释曰。不可言法性者。谓可言法无自性性。是离可言遍计所执自性性义。无我性真如者。为成此义令其明了。即是一切补特伽罗诸法无性所显真如。解脱增益损减二边。无分别智所缘境界。有所缘法定有行相故。次一颂显智行相

论曰

  诸菩萨行相　　复于所缘中
  是无分别智　　彼所知无相

释曰。于所缘中相似而行故名行相。无分别智于真如境相似而行。彼所知无相者。谓说此智于真如境所作行相。此意说言。无分别智缘真如境。离一切相作意行相。以为行相。次说二颂。于上所缘及智行相。释通疑难

论曰

  相应自性义　　所分别非余
  字展转相应　　是谓相应义
  非离彼能诠　　智于所诠转
  非诠不同故　　一切不可言

释曰。若实无有所分别义。何所分别故说是言。相应自性义所分别非余等。谓诸文字展转相应。宣唱不绝。遍计心等缘此假立成遍计义。为所分别。无别实义为所分别。故言非余。若无文字相续宣唱。分别无故。云何诸法皆不可言。为显此理故说是言。非离彼能诠智于所诠转等。若实有义可言说者。离能诠名于彼应有似言智起。非未解了能诠名言。于所诠义有此智起。故不可言。或谓外义虽定实有。要待能诠所诠智起。为遮此故说如是言。非诠不同故。谓相异故非实能诠。以能诠名与所诠义别相取故。其相各异。云何得成定实诠表。一切不可言者。由此道理所有一切能诠所诠。皆不可言。无分别智何所任持

论曰

  诸菩萨任持　　是无分别智
  后所得诸行　　为进趣增长

释曰。后所得诸行者。谓无分别后得智中所得种种菩萨诸行。此行皆以智为所依。为进趣增长者。谓为增长菩萨诸行。此说任持有要所用。无颠倒故能持诸行。无分别智谁为助伴。若唯有一应无所能

论曰

  诸菩萨助伴　　说为二种道
  是无分别智　　五到彼岸性

释曰。二种道者。一资粮道。二依止道。五到彼岸以为自性。此中前四波罗蜜多是资粮道。第五静虑波罗蜜多是依止道。若在定心前说四种波罗蜜多诸善资助。便能生长无分别智。此智名慧波罗蜜多。乃至未得佛果已来。无分别智当于何处感异熟果

论曰

  诸菩萨异熟　　于佛二会中
  是无分别智　　由加行证得

释曰。二会中者。谓于诸佛变化受用二身会中。由加行证得者。谓显能感异熟果义。此非异熟因。能对治彼故。即增上果假名异熟。由此资熏。余有漏业令感异熟故立此名。若修加行无分别时。生在诸佛所现变化身众会中。若时证得无分别智。便生诸佛所现受用身众会中。无分别智谁为等流

论曰

  诸菩萨等流　　于后后生中
  是无分别智　　自体转增胜

释曰。前前生中无分别智。后后生处展转增胜。是等流果。无分别智出离云何

论曰

  诸菩萨出离　　得成办相应
  是无分别智　　应知于十地

释曰。初极喜地入见道时。见一切地无分别理。初得出离。后修道中方得诸地成办相应无分别智。谁为究竟

论曰

  诸菩萨究竟　　得清净三身
  是无分别智　　得最上自在

释曰。清净三身者。谓初地中虽得三身而未清净。至第十地乃得清净。方名究竟。故说尔时得净三身。得最上自在者。谓于尔时无分别智。非但获得清净三身。亦得最上十种自在。故名究竟无分别智。如何从何由何无染

论曰

  如虚空无染　　是无分别智
  种种极重恶　　由唯信胜解

释曰。初问如何得无染者。答如虚空无染。次问从何得无染者。答种种极重恶。后问由何得无染者。答曰唯信胜解。谓唯由信由慧胜解以为因故。而得无染

论曰

  如虚空无染　　是无分别智
  解脱一切障　　得成办相应

释曰。解脱一切障者。解脱烦恼及所知障。得成办相应者。谓在初地与得相应。乃至佛地成办相应

论曰

  如虚空无染　　是无分别智
  常行于世间　　非世法所染

释曰。常行于世间非世法所染者。此显遍生一切生处利等世间八法不染。如红莲华出世间摄。如是三颂显示三智所得胜利。加行根本后得三种无分别智。有何差别

论曰

  如哑求受义　　如哑正受义
  如非哑受义　　三智譬如是
  如愚求受义　　如愚正受义
  如非愚受义　　三智譬如是
  如五求受义　　如五正受义
  如末那受义　　三智譬如是
  如未解于论　　求论受法义
  次第譬三智　　应知加行等

释曰。为显三智行相差别。说如是喻。如哑求受义者。譬如哑人求受境界。而未能受亦不能说。如是加行无分别智。求证真如而未能证。寂无言说当知亦尔。如哑正受义者。譬如哑人正受境界无所言说。如是根本无分别智。正证真如离诸戏论当知亦尔。如非哑受义者。如不哑人受诸境界。亦起言说。如是后得无分别智。反照真如现证境界。能起言教当知亦尔。由此道理释如愚颂。如五求受义者。譬如五识求受境界。虽有所求而无分别。如是加行无分别智当知亦尔。如五正受义者。譬如五识正受境界。离诸分别。如是根本无分别智当知亦尔。如末那受义者。譬如意识能受境界亦能分别。如是后得无分别智当知亦尔。如未解于论求论受法义者。如未解论求诵于论。而未能诵。如是加行无分别智当知亦尔。如温习论领受文字。如是根本无分别智当知亦尔。如已听习通达法义。如是后得无分别智当知亦尔。由如是等众多譬喻。如数次第喻加行等三智差别。次显根本后得二智譬喻差别

论曰

  如人正闭目　　是无分别智
  即彼复开目　　后得智亦尔
  应知如虚空　　是无分别智
  于中现色像　　后得智亦尔

释曰。由此二颂显示根本后得差别。闭目开目虚空色像。俱显二智是无分别。是有分别。是其平等是不平等。其加行智未有所证故略不说。又加行智是本智因。其后得智是本智果。是故且办无分别智成所作事。无分别智修成佛果既无分别。云何能作利有情事

论曰

  如末尼天乐　　无思成自事
  种种佛事成　　常离思亦尔

释曰。今此颂中引彼末尼天乐两喻。成立所得无分别智。虽无分别不作功用。成种种事如如意珠及以天乐。虽无是念我当放光。我当出声。并无思故然由生彼有情福业意乐势力。不待击奏放种种光。出种种声。诸佛菩萨无分别智。当知亦尔。虽离分别不作功用。而能随彼所化有情福力意乐。现作种种利乐事转。次当显示无分别智所有甚深。无分别智境界云何。为缘分别依他起性。为缘余境自体亦尔。为智非智。若尔何失。若缘分别依他起性。云何得成无分别智。若缘余境余境定无。当何所缘。若是其智应有所知。若是非智云何得名无分别智。为离如是一切过失故说颂言

论曰

  非于此非余　　非智而是智
  与境无有异　　智成无分别

释曰。无分别智不缘分别依他起性。无分别故。非缘分别成无分别。亦不缘余以为境界。以即缘此分别法性为境界故。法与法性若一若异俱不可说。是故此智不可定说。缘分别境非分别境。自体亦尔。不可说言决定是智。如加行智及后得智分别无故。亦不可说决定非智。以加行智为先因故。与境无有异智成无分别者。不可分别此是能知。此是所知。能取所取分别无故。此智与境无差别相。譬如虚空与虚空中所有光明。是故此智成无分别。余契经中说一切法性无分别。今当解释

论曰

  应知一切法　　本性无分别
  所分别无故　　无分别智无

释曰。所分别无故者。由所分别遍计所执义永无故。余契经中说一切法性无分别。若一切法本来自性无分别者。何不一切有情之类从本已来不作功用自然解脱。无分别智彼无有故。由彼有情于一切法无分别性。现证真智本来未生。诸菩萨等。于一切法无分别性种性为因。证智已生由此道理。诸菩萨等能得解脱。非余有情。次当显示加行智等。各有三种五种差别

论曰。此中加行无分别智有三种。谓因缘引发数习生差别故

释曰。此加行智生起差别由三种力。一因缘力。二引发力。三数习力。因缘力者。谓种性力。或有种性会遇强缘。速起加行。如是加行种性为因。而得生起。言种性者。谓无始来六处殊胜。能得佛果法尔功能。引发力者。谓前生中已习为因发起加行。数习力者。谓现在生数数修习。由士用力发起加行

论曰。根本无分别智亦有三种。谓喜足无颠倒无戏论无分别差别故

释曰。喜足无分别者。谓于下劣义而生喜足。于后胜进不悕求故。名无分别。如得世间闻思两智。于少分义。或已信解或已决了。便生喜足。或如已得世间修慧证第一有粗烦恼息。于中执为究竟解脱。便生喜足。如是等类皆名喜足无分别智。无颠倒无分别者。谓圣弟子等。彼由修慧于苦等谛起无常等四无倒行。不起常等颠倒分别。名无颠倒无分别智。无戏论无分别者。谓诸菩萨于无常等亦不分别。乃至菩提亦离戏论。由一切法无分别理。出过一切名言道故。超度一切世智境故。由戏论名是世俗声。世俗智摄。远离此故名无戏论无分别智

论曰。后得无分别智有五种。谓通达随念安立和合如意思择差别故

释曰。此后得智所作别故。有其五种。谓通达等。思择之声一一皆有。通达思择者。于真决定于真现观故名通达。由后得智思择如是所得通达。谓即于中自内审察此事如是。是故说名通达思择随念思择者。谓于后时随念通达。念言我曾通达是事。是故说名随念思择。安立思择者。谓从此出。如所通达为他宣说。是故说名安立思择。和合思择者。谓总相观缘一切法。由此观故进趣转依。或转依已重起此观。是故说名和合思择。如意思择者。谓智现前随所思惟。一切如意。如令地等变成金等。是故说名如意思择。此思择声。意说其智。前说一切法本性无分别。所分别无故。云何得知所分别义实无所有。为欲成立彼无所有。故说多颂

论曰

  鬼傍生人天　　各随其所应
  等事心异故　　许义非真实
  于过去事等　　梦像二影中
  虽所缘非实　　而境相成就
  若义义性成　　无无分别智
  此若无佛果　　证得不应理
  得自在菩萨　　由胜解力故
  如欲地等成　　得定者亦尔
  成就简择者　　有智得定者
  思惟一切法　　如义皆显现
  无分别智行　　诸义皆不现
  当知无有义　　由此亦无识

释曰。鬼傍生人天等者。谓于人等见有水处。饿鬼见是陆地高原。于人所见有粪秽处。傍生见为净妙饮食。于人所见不净物中。饿鬼畜生见为清净。于人所见净妙饮食。诸天见为臭秽不净。非相违事同一处有。故知遍计所执义无。若无有义。云何无境识得现行。何故诘问。汝经部师。过去未来境界非有。云何于中得有智转。又于梦中梦像实无。云何智起非隘室中偃卧一处容有梦智所缘真实山河象等。又未曾经自断其首。云何梦见非不得通忆宿住事。又于镜等三摩地中。所行二影非真实有。云何了然当心显现。故知自缘心之影像而境相成就者。总结过去未来等境。虽非实有而于自心境相成就。若义义性成无无分别智者。若诸境义义性成实。无分别智应不得成。分别有故。此若无佛果证得不应理者。此无分别智体若无。证得佛果不应道理。是则应成害本过失。是故应知所分别义定非成实。又此境义定非实有。何以故。得自在菩萨者。谓诸菩萨得大自在。由胜解力故者。由意解力。如欲地等成者。谓变地等令成金等。得定者亦尔者。谓除菩萨余声闻等得静虑者。成就简择者者谓慧成满者。言有智者。谓与成满正智相应。是故菩萨名有智者。得定者者。得三摩地。思惟一切法者。谓正思惟一切契经应颂等法。如义皆显现者。谓以种种无我等行。如如思惟契经等法。如是如是其义显现。是故应知即此如理作意之心。似其所取能取相现。一切外义都无所有。无分别智行诸义皆不现者。此中应续前说许义非真实言。由诸菩萨无分别智现起行时。一切境义皆不显现是故应知所有境义皆非实有。当知无有义由此亦无识者。结劝应知无有境义。由此能识亦无所有。非无所识而有能识应正道理。前于广释所知相中。已具辩析如是道理

论曰。般若波罗蜜多与无分别智无有差别。如说菩萨安住般若波罗蜜多。非处相应能于所余波罗蜜多修习圆满。云何名为非处相应修习圆满。谓由远离五种处故。一远离外道我执处故。二远离未见真如菩萨分别处故。三远离生死涅槃二边处故。四远离唯断烦恼障生喜足处。故五远离不顾有情利益安乐住无余依涅槃界处故

释曰。般若波罗蜜多与无分别智无有差别者。性相等故。谓诸所有无分别智。即是般若波罗蜜多故。彼经中作如是说。菩萨安住般若波罗蜜多。非处相应能于所余波罗蜜多修习圆满。此义云何。谓由远离五种处故。即是远离外道我执处等五处差别。此中可居故名为处。远离外道我执处者。谓诸外道安住我执。作是念言。我能了知此是我慧。菩萨远离如是处所。不计执我及以我所而起波若。菩萨远离如是处所。是故说名非处相应。远离未见真如菩萨分别处者。谓未见真诸菩萨众。于其般若波罗蜜多无分别智起诸分别。此是般若波罗蜜多。菩萨远离如是处所。是故说名非处相应。如有颂曰

  若有所见　　汝为彼缚　　若无所见
  便得解脱

远离生死涅槃二边处者。谓如世间住生死边。有我执故。如圣弟子住涅槃边。烦恼断故。菩萨不尔。是故说名远离二边非处相应。远离唯断烦恼障生喜足处者。谓声闻等计修习力断烦恼障。即为一切所作已办。菩萨远离如是处所以能障碍利益安乐诸有情故。如有颂言

  非往诸恶趣　　极障大菩提
  如住于声闻　　及以独觉地

菩萨远离如是处。所是故说名非处相应。远离不顾有情利益。安乐住无余依涅槃界处者。如声闻等不顾有情利益安乐。住无余依涅槃界中。如火烧薪。毕竟寂灭。菩萨远离如是处所。般若大悲皆具足故。能正安住无住涅槃。由舍此处是故说名非处相应

论曰。声闻等智与菩萨智有何差别。由五种相应知差别。一由无分别差别。谓于蕴等法无分别故。二由非少分差别。谓于通达真如入一切种所知境界。普为度脱一切有情非少分故。三由无住差别。谓无住涅槃为所住故。四由毕竟差别。谓无余依涅槃界中无断尽故。五由无上差别。谓于此上无有余。乘胜过此故。此中有颂

  诸大悲为体　　由五相胜智
  世出世满中　　说此最高远

释曰。此中显示声闻等智与菩萨智五相差别。无分别差别者。谓声闻。等智就四颠倒。名无分别。诸菩萨智于一切法乃至菩提皆无分别。非少分差别。复有三种。一通达真如非少分差别。谓声闻等入真观时唯能通达补特伽罗空无我理。是诸菩萨入真观时具足通达补特伽罗及一切法空无我理。二所知境界非少分差别。谓声闻等唯于苦等谛中智生。即名修习所作已办。是诸菩萨普于一切所知境界无倒智生。乃名修习所作已办。三所度有情非少分差别。谓声闻等唯求自利尽无生智。正勤修行。是诸菩萨普为济度一切有情求大菩提。于此三种非少分别。声闻菩萨智有差别。无住差别者。谓声闻等唯住涅槃。是诸菩萨具足悲慧增上力故。无住涅槃以为住处。毕竟差别者。显声闻等与诸菩萨于涅槃中有大差别。谓声闻等住无余依涅槃界中。身智永尽如灯焰灭。是诸菩萨得成佛时。所证法身穷生死际无有断尽。如无色界相续不坏。由此差别智有差别。无上差别者。谓声闻乘上有独觉。独觉乘上复有大乘。其菩萨乘即是佛乘。更无有上。由此五相应知声闻与诸菩萨智有差别。复以伽陀摄如是义。言五相者。即前所说五相差别。世出世满中者。静虑无色名世间满。声闻乘等所得涅槃名出世满。此皆胜彼故说高远

论曰。若诸菩萨成就如是。增上尸罗。增上质多。增上般若。功德圆满。于诸财位得大自在。何故现见有诸有情匮乏财位。见彼有情于诸财位有重业障故。见彼有情若施财位障生善法故。见彼有情若乏财位厌离现前故。见彼有情若施财位。即为积集不善法因故。见彼有情若施财位。即便作余无量有情损恼因故。是故现见有诸有情匮乏财位。此中有颂

  见业障现前　　积集损恼故
  现有诸有情　　不感菩萨施

释曰。今当显说。由是因缘菩萨虽有财位自在而不施他。见彼有情于诸财位有重业障故者。谓诸菩萨见彼有情于其财位。有重业障故不施与。勿令惠施空无有果。设复施彼亦不能受。何用施为。如有颂言

  如母乳婴儿　　一经月无倦
  婴儿喉若闭　　乳母欲何为

见彼有情若施财位障生善法故者。谓诸菩萨见彼有情虽于财位无重业障。而彼若得财位圆满便多放逸不起善法。作是思惟。宁彼现法少时贫贱。勿彼来生多时贫贱。故不施彼所有财位。见彼有情若乏财位厌离现前故者。谓诸菩萨见彼有情若乏财位厌生死心便现在前。求欲出离。若得富贵即生憍逸。故不施彼所有财位。作是思惟。宁彼贫贱厌离生死心常现前。勿彼富贵受乐放逸。不厌生死不起善法。见彼有情若施财位即为积集不善法因故者。谓诸菩萨见彼有情若当施彼满足财位。即便放逸积集种种恶不善业。故不施彼所有财位。如有颂言

  宁使贫乏于财位　　远离恶趣诸恶行
  勿彼富贵乱诸根　　令感当来众苦器

见彼有情若施财位即便作余无量有情损恼因故者。谓诸菩萨见彼有情若得富贵。即便损恼无量有情故。不施彼所有财位。作是念言。宁彼一身受贫贱苦。勿令损恼余多有情。复以伽他摄如是义故说见业障现前等。其文易了无烦重释

摄大乘论释卷第八摄大乘论释卷第九

        无性菩萨造

        三藏法师玄奘奉　诏译

    果断分第十

论曰。如是已说增上慧殊胜。彼果断殊胜云何可见。断谓菩萨无住涅槃。以舍杂染不舍生死。二所依止转依为相。此中生死。谓依他起性杂染分。涅槃谓依他起性清净分。二所依止。谓通二分依他起性。转依。谓即依他起性对治起时。转舍杂染分。转得清净分

释曰。无分别智。能治既生一切所治。决定应断故。彼无间说断殊胜。无住涅槃者。不同世间声闻独觉安住生死或涅槃故。以舍杂染不舍生死者。害彼势力如彼咒蛇。虽不弃舍而无染故。二所依止转依为相者。或依主释或持业释。住此转依如无色界。若依自利与殊胜慧共相应故。不容烦恼。若依利他由与大悲共相应故。现处生死而不弃舍。此中何者生死涅槃。依止转依。皆应显说。生死谓依他起性杂染分者。谓心心法烦恼迷乱。生死过失相续不绝。遍计所执分。涅槃谓依他起性清净分者。谓毕竟转遍计所执。圆成实分。二所依止谓通二分依他起性者。谓二所依。依他起性。转依谓即依他起性者。谓心心法依他起性。是诸杂染转灭所依。又是一切佛法所依。如有说言。此是一切佛法。诸地波罗蜜多果。所依等云何转依。何者转依。谓即于此依他起性对治起时者。无分别智起时。转舍杂染分者。转灭一切所取能取诸迷乱分。转得清净分者。舍彼所取能取性故。转得远离所取能取自内所证。绝诸戏论最清净分

论曰。又此转依略有六种。一损力益能转。谓由胜解力闻熏习住故。及由有羞耻。令诸烦恼少分现行。不现行故。二通达转。谓诸菩萨已入大地。于真实非真实显现不显现。现前住故。乃至六地。三修习转。谓犹有障一切相不显现真实显现故。乃至十地。四果圆满转。谓永无障。一切相不显现。最清净真实显现。于一切相得自在故。五下劣转。谓声闻等唯能通达补特伽罗空无我性。一向背生死一向舍生死故。六广大转。谓诸菩萨兼通达法空无我性。即于生死见为寂静。虽断杂染而不舍故。若诸菩萨住下劣转。有何过失。不顾一切有情利益安乐事故。违越一切菩萨法故。与下劣乘同解脱故。是为过失。若诸菩萨住广大转有何功德。生死法中以自转依为所依止。得自在故。于一切趣示现一切有情之身。于最胜生及三乘中种种调伏。方便善巧安立所化诸有情故。是为功德

释曰。损力益能转等者。谓由胜解力及闻熏习力。损减依附异熟识中。烦恼熏习增益所习净法功能。又由胜解闻熏习。住有羞耻故。令诸烦恼少分现行。或不现行。通达转等者。谓已证入菩萨大地。于真非真或现不现。无分别智有间无间而现行故。或时真现。谓入观时。或非真现谓出观时非真与真于此二时。如其次第说现不现。此现不现乃至六地。修习转等者。由所知障说名有障。此转依位乃至十地诸相不现唯真显现。果圆满转等者。由一切障说名无障。以一切障永无有故。得一切相皆不显现。得最清净真实显现。依此转依于一切相得大自在。以于诸相得自在故。随其所乐利乐有情。下劣转等其言易了。无烦重释。广大转等者。谓于杂染断而不舍。于生死中达无我故。断诸杂染。即于其中见寂静故。而不弃舍。住下劣转有何过失等。其文易解。住广大转有何功德等者。于一切法得自在故。于一切趣示显一切同分之身。种种调伏方便善巧。安立所化有感有情。置最胜生及三乘中。最胜生者。谓诸世间安乐生处。应知此是说法功德

论曰。此中有多颂

  诸凡夫覆真　　一向显虚妄
  诸菩萨舍妄　　一向显真实
  应知显不显　　真义非真义
  转依即解脱　　随欲自在行
  于生死涅槃　　若起平等智
  尔时由此证　　生死即涅槃
  由是于生死　　非舍非不舍
  亦即于涅槃　　非得非不得

释曰。为显转依复说多颂。诸凡夫覆真等者。谓如凡夫无明未断。真义不显故说名覆。无明力故一切虚妄皆悉显现。菩萨不尔无明断故。通达虚妄皆无所有故名舍妄。唯有真义一向显现。由此道理。应知显不显真义非真义者。谓圆成实真义显现。遍计所执非真实义皆不显现。言转依者。谓非真义皆不显现。所有真义皆悉显现。故名转依。即解脱者。谓即转依名为解脱。随欲自在行者。谓此转依解脱自在。于诸世间得随欲行。由随所欲所作自在故名解脱。非如斩首舍离身命。名为解脱。于生死涅槃若起平等智等者。谓遍计所执自性名为生死。此即无性。无性即空。空即涅槃。圆成实性。由是于生死非舍非不舍等者。谓即生死是涅槃故说名非舍。无复生死名想转故名非不舍。非离生死别得涅槃故名非得。即于此中证涅槃故名非不得

    摄大乘论释彼果智分第十一之一

论曰。如是已说彼果断殊胜。彼果智殊胜云何可见。谓由三种佛身应知。彼果智殊胜。一由自性身。二由受用身。三由变化身。此中自性身者。谓诸如来法身。一切法自在转所依止故。受用身者。谓依法身种种诸佛众会所显。清净佛土大乘法乐为所受故。变化身者亦依法身。从睹史多天宫现没。受生受欲踰城出家。往外道所修诸苦行。证大菩提。转大法轮。入大涅槃故

释曰。由断所断获得无垢无挂碍智故。断殊胜无间次说果智殊胜。自性身中非假所立故名自性。是所依止故名为身。法性即身故名法身。或是诸法所依止处故名法身。言一切法自在转所依止者。谓于一切法得自在转。亦所依止故名一切法自在转所依止。或依持业释。受用身中依法身者。由有彼故而得有此。种种诸佛众会所显者。谓有佛土诸大菩萨众所云集。由此了知故名所显。即是西方极乐土等。清净佛土大乘法乐为所受故者。谓于清净佛国土中。受用种种大乘法乐。领解义故。或于清净佛国土中。受用种种金银等宝。诸佛菩萨展转受用妙色身等。及受经等种种法义。安立自相及共相故。何者所依复是谁依。谓前无垢无挂碍智。由此妙智增上力故能令安住不可思议解脱。已入大地诸大菩萨。清净佛土大乘法乐。相现智生。变化身中依法身者。如前已说。谓由果智殊胜力故。从睹史多天宫现没。乃至涅槃。此即能令余相续中。与人同分识相生起

论曰。此中说一嗢拖南颂

  相证得自在　　依止及摄持
  差别德甚深　　念业明诸佛

释曰。略标总义名嗢拖南相证得等是所标义

论曰。诸佛法身以何为相。应知法身略有五相

释曰。初总标相复有五种下转依等别释五相

论曰。一转依为相。谓转灭一切障杂染分依他起性故。转得解脱一切障于法自在转。现前清净分依他起性故

释曰。转灭一切障杂染分依他起性故者。谓转杂染分依他起性。似所取相及能取相。令永不生故。转得解脱一切障。于法自在转现前清净分依他起性故者。谓转得所取能取无性所显离垢真如圆成实性。及得于一切法自在而转。现在前因极清净分依他起性故

论曰。二白法所成为相。谓六波罗蜜多圆满得十自在故。此中寿自在心自在众具自在由施波罗蜜多圆满故。业自在生自在由戒波罗蜜多圆满故。胜解自在由忍波罗蜜多圆满故。愿自在由精进波罗蜜多圆满故。神力自在五通所摄。由静虑波罗蜜多圆满故。智自在法自在由般若波罗蜜多圆满故

释曰。白法所成为相等者。谓诸声闻所得转依。唯是烦恼永断所显。无有白法所成为相。若诸菩萨所得转依修习六种波罗蜜多极圆满故。白法自性十种自在以为其相。于此时中无有一念是无记分。况染污分。此中已下释十自在寿自在者。谓随所欲能舍命故。心自在者。谓于生死无染污故。又随意乐能正为他引摄众具。于中自在运转其心名心自在。众具自在者。谓饮食等诸资生具。随意所乐能积集故。众具资财其义是一。由施波罗蜜多圆满故者。谓由法施无畏施财施圆满。如其所应得此果故。业自在者。谓于诸业得大自在。唯作善业非恶无记。及于其中劝他作故。生自在者。谓于一切应所生处。如其所欲现受生故。由戒波罗蜜多圆满故者。谓二自在是尸罗果。由具戒者唯造善业故。又具戒者所愿皆成故。胜解自在者。谓于地等发起胜解。令成金等如所胜解地等金等随胜解转。由忍波罗蜜多圆满故者。谓此自在是其忍果。如昔因时乐修忍故。随诸有情心所乐转故。今获得地等金等随胜解转。愿自在者。谓随所愿一切事成。由精进波罗蜜多圆满故者。谓此自在是精进果。由昔因时修精进故。于诸有情诸利乐事无有懈废。故于今时所愿自在。神力自在五通所摄者。谓随意乐引发种种最胜神通。由静虑波罗蜜多圆满故者。谓此自在是静虑果。由昔因时乐修定故。随诸有情所应作事。证入种种静虑等至故。于今时得定所作神通自在。智自在者。谓随所有种种言音。智现前故。法自在者。谓随意乐宣说契经应颂等故。由般若波罗蜜多圆满故者。谓此自在是般若果。由昔因时乐修慧故。随其类音为说正法故。今证得殊胜般若。妙达言音巧说正法

论曰。三无二为相。谓有无无二为相。由一切法无所有故。空所显相是实有故。有为无为无二为相。由业烦恼非所为故。自在示现有为相故。异性一性无二为相。由一切佛所。依无差别故。无量相续现等觉故。此中有二颂

  我执不有故　　于中无别依
  随前能证别　　故施设有异
  种性异非虚　　圆满无初故
  无垢依无别　　故非一非多

释曰。有无无二为相者。谓非有相以一切法遍计所执皆无有故。亦非无相。以空所显自性有故。有为无为无二为相者。以业烦恼非所为故非有为相。于能示现似有为法得大自在。数数示现似有为故非无为相。异性一性无二为相者。以佛法身体是其一故非异相。无量依止各别证得故非一相。俱一无故名无二相。复以二颂摄如是义令其易了。所谓我执不有故等。若于是处有其我执计自为我。执外为他即于其中分别自他。此彼各异。于法身中无有我执。故无分别。此彼有异。若尔云何说有多佛。随前能证有差别故。施设有异。谓随菩萨能证位别施设有异。随顺世间名言故说。此是释迦牟尼。此是胜观佛等。种性异故者。谓本因性有差别故。非唯一佛。种性有二。一本性住种性。谓无始来六处殊胜。展转相续法尔所得。二习所成种性。谓从先来善友力等数习所成。本性住性有差别故。习所成性有其多种。种性多故。执唯一佛更无余佛不应道理。非虚故者。有多菩萨依前种性。各别修集菩提资粮。若唯一佛一证菩提。余无所证。彼集资粮应空无果。不应道理。圆满故者。谓诸如来遍于各别所化有情。成立利益安乐正事。谓于三乘如应安立。若唯一佛。是则不可安立有情置于佛乘。以更无有第二佛故。是则如来所作佛事应不圆满。是故定应许有多佛。无初故者。谓诸如来前前出世。犹如生死无有最初。离集资粮自然成佛不应理故。离逢事佛能集资粮不应理故。由此决定非唯一佛。又不应执定有多佛。无垢所依无差别故。无漏法界名无垢依。由智殊胜毕竟遣除客尘垢故。于此无漏真法界中。不可定执诸佛有异。是故诸佛非一非多

论曰。四常住为相。谓真如清净相故。本愿所引故。所应作事无竟期故

释曰。恒无变易相续无断。是故说言常住为相。由三因缘成立此相。真如清净相故者。此显真如性常无变。显成佛果说为法身性。若变易即非真如。是故常住本愿所引故者。谓诸如来皆先发起如是大愿。我当度脱无量有情。令般涅槃诸有情类未般涅槃。愿所引果相续不绝。是故常住。此愿所引离相续。常道理不成。所应作事无竟期故者。谓先大愿所应作事无究竟期。诸有情类量无边故。乃至有情相续不断。佛所作事恒无断故说名为常

论曰。五不可思议为相。谓真如清净自内证故。无有世间喻能喻故。非诸寻思所行处故

释曰。言思议者。谓依道理审谛思惟。起分别智寻思所摄。譬喻所显。诸佛非此所行处故。不可思议。超过一切寻思地故。唯应信解不应思议

论曰。复次云何如是法身。最初证得。谓缘总相大乘法境无分别智。及后得智。五相善修于一切地善集资粮。金刚喻定破灭微细难破障故。此定无间离一切障故得转依

释曰。信解亦名初得法身。法行亦尔。为简彼故说现证得。但言证得非生起者。体是常故。缘总相等其义易了。五相善修者。谓无生无灭。本来寂静。自性涅槃。及无自性。名为五相。又集总等五相善修。成办五果谓念念中销融一切粗重依止。离种种想得法苑乐。能正了知周遍无量无分限相。大法光明顺清净分。无所分别无相现行。为令法身圆满成办。能正摄受后后胜因。破灭微细难破障故者。显示此定喻金刚因。譬如金刚其性坚固能破难破。如是此定超诸下类能破难破不染无知。能发无上清净智道故譬金刚。此定无间离一切障故。得转依者。由无分别及后得智故。证转依得佛法身

论曰。复次法身由几自在而得自在。略由五种。一由佛土自身相好无边音声。无见顶相自在。由转色蕴依故。二由无罪无量广大乐住自在。由转受蕴依故。三由辩说一切名身句身文身自在。由转想蕴依故。四由现化变易。引摄大众引摄白法自在。由转行蕴依故。五由圆镜平等观察成所作智自在。由转识蕴依故

释曰。由转五蕴依故。得五自在。诸声闻等怖畏苦故永断诸蕴。如愚癞人自舍身命。若诸菩萨摄巧方便。转灭有罪色等诸蕴。转起无罪色等诸蕴。如智癞人求诸良药。转有病身成无病身。此中由转色蕴依故。得能示现佛土自在。如其所欲现金银等诸佛土故。得能示现自身自在。随心所思皆能示现。于其种种大集会中。随诸所化有情机宜。各别现故。得能示现相好自在。随所爱乐示现种种妙相好故。得能示现无边音声无见顶相二种自在。现佛音声量无边故。现佛顶相无能见故。由转受蕴依故。得无罪无量广大乐住自在应知。此中离烦恼故名为无罪。有众多故名为无量。超过一切三界乐故名为广大。由转想蕴依故。得能辩说一切名身句身文身自在。以能取相是想自性。由摄如是资粮为因。转得如是功能差别。由此能于名身等事。随其所欲自在能住。由转行蕴依故得能现化变易引摄大众引摄白法自在。谓行蕴中思最为胜。由此思故于现化等自在。能转现化自在者。如其所欲能现化故。变易自在者。如其所欲转变地等成金等故。引摄大众自在者。如意所乐引摄天等诸大众故。引摄白法自在者。如意所乐令无漏法现在前故。由转阿赖耶识等八事识蕴得大圆镜智等四种妙智。如数次第或随所应。当知此中转阿赖耶识故得大圆镜智。虽所识境不现在前而能不忘不限时处。于一切境常不愚迷。无分别行能起受用。佛智影像。转染污末那故得平等性智。初现观时。先已证得。于修道位转复清净。由此安住无住涅槃。大慈大悲恒与相应。能随所乐现佛影像。转意识故。得妙观察智。具足一切陀罗尼门三摩地门。犹如宝藏。于大会中能现一切自在作用。能断诸疑能雨法雨。转五识故得成所作智。普于十方一切世界。能现变化从睹史多天宫而没乃至涅槃。能现住持一切有情利乐事故

论曰。复次法身由几种处。应知依止略由三处。一由种种佛住依止。此中有二颂

  诸佛证得五性喜　　皆由等证自界故
  离喜都由不证此　　故求喜者应等证
  由能无量及事成　　法味义德俱圆满
  得喜最胜无过失　　诸佛见常无尽故

二由种种受用身依止。但为成熟诸菩萨故。三由种种变化身依止。多为成熟声闻等故

释曰。由几种处应知依止者。此问法身与几种法为所依止。略由三处者。广即无量功德依止。今且略说但由三处。由种种佛住依止者。由诸如来所得法身。与所安住种种天住圣住梵住为所依止。诸天住中如来多住第四静虑。诸圣住中如来多住空解脱门。诸梵住中多住其悲。如是种种如来所住。胜声闻等。为显如来所证涅槃胜声闻等所得涅槃故。说诸佛证得五性喜等。证自界者。证自法界。于此修治正作证故名为等证。言离喜者。谓诸如来证自法界。安住五喜。诸声闻等证如斩首。永灭涅槃远离。如是最胜欢喜故。求喜者应等证者。谓诸菩萨勤求五喜。应正求证此真法界。何等为五。所求胜喜故次说言。由能无量及事成等。由因别故尔所喜异。能谓堪能。言无量者。谓过无量殑伽沙数。诸佛如来所有堪能。同依法身。一切和杂平等无异。由见如是能无量故。生大欢喜。及者集义。事者所作。一切有情诸利乐事。随彼所能无倒安立于三乘等。成谓成办。经无量时此所作事无碍转故。由见堪能。所应作事亦无量故生大欢喜。言法味者。谓契经等无上法味。谓证真谛所得理味。义圆满者。谓契经等法所诠义皆得圆满。随自意乐现在前故。德圆满者。谓神通等功德圆满。由见法味亦无量故。见义圆满亦无量故。见德圆满亦无量故。生大欢喜。复有说言。义谓涅槃。德谓随乐所起功德。俱圆满故并生大喜。得喜最胜无过失。诸佛见常无尽故者。谓诸如来见自身中真如一味。能无量等所生大喜。虽入涅槃亦常无尽。是故最胜无有过失。出三界故名为最胜。烦恼所知二障并习皆永断故。名无过失。由种种受用身依止等者。谓由法身为增上缘彼得转故。说名依止。非如日光依日道理。与变化身为所依止其义亦尔。言多为者。摄取胜解行地菩萨。以劣信解诸声闻等。虽见佛身不应成熟。初业菩萨当知亦尔。已入大地诸菩萨众。不由化身方得成熟。通达甚深广大法故

论曰。应知法身由几佛法之所摄持。略由六种。一由清净。谓转阿赖耶识得法身故。二由异熟。谓转色根得异熟智故。三由安住。谓转欲行等住。得无量智住故。四由自在。谓转种种摄受业自在。得一切世界无碍神通智自在故。五由言说。谓转一切见闻觉知言说戏论。得令一切有情心喜辩说智自在故。六由拔济。谓转拔济一切灾横过失。得拔济一切有情一切灾横过失智故。应知法身由此所说六种佛法之所摄持

释曰。就自性摄以显摄持法身自性。由清净者。谓由清净佛法摄持法身自性。以其法身体清净故。净谁转谁而得清净。为答此问说如是言。转阿赖耶识得法身故。由阿赖耶识执持一切杂染种子。对治起时转灭如是一切染种。转得随顺一切无罪圆满功德。譬如世间阿揭陀药。能变有毒令成无毒。故说名转。由异熟者。谓由异熟佛法摄持。法身自性转色根者。谓转眼等有色诸根。得异熟智者。谓所转舍是异熟故。假说转得亦名异熟。如昔所得异熟诸根。今得善智假名异熟。由安住者。谓由安住佛法摄持法身自性。转欲行等者。谓等取胜解行等。由转彼故证得息灭一切有情诸灾患智。由自在者。谓由自在佛法摄持法身自性。摄受业者。谓诸世间商贾营农事王等业。由转彼故证得无碍神通自在。由言说者。谓由言说佛法摄持法身自性。由转世间见等言说。证得见闻觉知自在。由此逮得一切有情心喜妙智。由拔济者。谓由拔济佛法摄持法身自性。灾横等者。谓如世间国王家等所生忧苦。或亲友力。或财宝力。而能息除。由转此故。证得息除一切有情一切灾横过失妙。智转舍如是六种世。法转得如是六种佛法

论曰。诸佛法身当言有异。当言无异。依止意乐业无别故。当言无异。无量依身现等觉故。当言有异。如说佛法身受用身亦尔。意乐及业无差别故。当言无异。不由依止无差别故无量依止。差别转故。应知变化身如受用身说

释曰。诸佛法身。依止意乐作业无别故无有异。诸佛真如无有异故。依止无别。一切皆为利益安乐一切有情。意乐同故意乐无别。一切皆同利他为胜。现等正觉般涅槃等。种种作业故业无别。无量依身现等觉故。当言有异者。谓由无量别别依身。菩提萨埵现成佛故。非无有异如前广说。如说法身受用亦尔。此说意乐及业无别。不说依止无有差别。无量依止差别转故。谓于一切别世界中。诸佛国土众会名号身量相好受法乐等各不同故。佛变化身应知亦尔

论曰。应知法身几德相应。谓最清净四无量解脱胜处遍处无诤愿智。四无碍解六神通三十二大士相八十随好。四一切相清净十力四无畏。三不护三念住拔除习气。无忘失法大悲。十八不共佛法。一切相妙智等功德相应

释曰。此中显说诸佛世尊共声闻等。所有清净殊胜功德。最清净者。显此功德永断烦恼及所知障身中起故。如是所说最清净言。应知遍在一一功德。四无量者。谓缘无量有情为境。慈悲喜舍。言解脱者。谓八解脱。所谓有色观诸色等。言胜处者。谓八胜处。言遍处者。谓十遍处。无诤愿智更无差别。四无碍解者。谓法无碍解义无碍解训词无碍解辩说无碍解。六神通者。谓如意通为初。漏尽智为后。三十二大士相者。谓妙轮相印手足等。八十随好者。谓鼻修直等。四一切相清净者。谓所依清净所缘清净。心清净智清净。言十力者。谓处非处智力。业异熟智力。静虑解脱等持等至智力。根胜劣智力。种种胜解智力。种种界智力。遍趣行智力。宿住随念智力。死生智力。漏尽智力。四无畏者。谓佛世尊自发诚言。我是真实正等觉者。若有难言。于如是法不正等觉。我于彼难正见无缘是第一无畏。又发诚言。我是真实诸漏尽者。若有难言。如是如是诸漏未尽。我于彼难正见无缘。是第二无畏。又发诚言。我为弟子说出离道。若有难言修如是道非正出苦。我于彼难正见无缘。是第三无畏。又发诚言。我为弟子说障碍法染必为障。若有难言。虽染彼法不能为障。我于彼难正见无缘。是第四无畏。于此四中皆应广说。正见彼难无有缘故。得大安隐。得安隐故都无所畏。三不护者。谓诸如来所有身业清净现行无不清净。现行身业虑恐他知可须藏护。如是名为第一不护。如说身业语业意业。亦如是说是三不护。三念住者。谓诸如来说正法时。一类弟子恭敬属耳。住奉教心精进修行。法随法行。如来于彼无悦无喜心不踊跃。一类弟子不生恭敬翻前广说。如来于彼不生恚恨。不生不忍非不保任。一类弟子亦生恭敬。亦不恭敬乃至广说。如来于彼其心无二。谓不喜悦亦不恚恨。于彼一切遍住妙舍。拔除习气者。谓永拔除虽无烦恼。而有烦恼相似所作。腾跃等事。无忘失法者。谓于利乐诸有情事。正念正知不过时分。言大悲者。谓于有情利乐意乐大义当说。十八不共佛法者。谓不同义是不共义。即诸如来无有误失如阿罗汉。虽尽诸漏为乞食故出游城邑。或于一时与恶象恶马恶牛恶狗等共同游止。或于一时足践丛刺诸恶蛇等齐足跳踯。或于一时入如是。舍与诸母邑不依正理而作语言。或于林野舍弃好道而行恶路。或与怨贼师子猛兽及他妻等同共游止。如是等类诸阿罗汉所有误失诸佛皆无。又诸如来无卒暴音如阿罗汉。或于一时游行林野迷失道路。或入空宅扬声叫唤发大暴音。或因不染习气过失。聚唇露齿而现大笑。如是等类。诸阿罗汉卒暴音声诸佛皆无。又诸如来无忘失念。如阿罗汉有不染污久远所作。久远所说诸忘失念诸佛皆无。又诸如来无种种想。如阿罗汉于有余生死。一向起极厌逆想。于无余涅槃。一向起极寂静想。如来于彼有余生死无余涅槃。无差别想住最胜舍。又诸如来无不定心。如阿罗汉敛心方定出即不定。如来于彼一切分位无不定心。又诸如来无不择舍。如阿罗汉不以智慧简择有情诸利乐事。而便弃舍。如来无有如是等类不择而舍。又诸如来无有欲等六种退失。如阿罗汉于能永净所知障中。有未得退。谓志欲退精进退念退定。退慧退解脱退。如是六退诸佛皆无。又诸如来身语意业智为前导。随智而转。如阿罗汉或于一时善身业转。或于一时无记业转。语业意业当知亦尔。如来三业智前导故。随智转故无有无记。智等起故名智前导。智俱行故名随智转。又诸如来于三世境若知若见无著无碍。如阿罗汉于三世事非暂起心即能解故。知见有着不能一切悉了知故。知见有碍。如来于彼三世事中。暂起心时即遍解知一切境界。是故知见无著无碍。由是因缘此十八种。一一皆名不共佛法。一切相妙智者。谓于一切蕴界处中善能了知。一切行相等者。等余无量功德法身相应

论曰。此中有多颂

释曰。于此法身能依不共诸功德中。以赞颂门结句道理分别开示

论曰

  怜愍诸有情　　起和合远离
  常不舍利乐　　四意乐归礼

释曰。今此颂中显四无量。怜愍诸有情者。是总句。起和合意乐者。显慈无量。欲令有情乐和合故。起远离意乐者。显悲无量。欲令有情远离苦故。起常不舍意乐者。显喜无量。欲令有情不舍乐故。起利乐意乐者。显舍无量。欲令有情获得利益及安乐故。舍谓弃舍。欲令有情舍乐受等烦恼随眠。不舍有情又处中住说名为舍。缘此功德归依敬礼诸佛法身。故名归礼。余颂准此一切应知

论曰

  解脱一切障　　牟尼胜世间
  智周遍所知　　心解脱归礼

释曰。解脱一切障者。此句显示诸佛解脱胜声闻等。牟尼胜世间者。此句显示诸佛胜处胜声闻等。智周遍所知者。此句显示诸佛遍处胜声闻等。非如声闻乘等唯有八种解脱。八种胜处。十种遍处。解脱为先而有胜处。胜处为先而有遍处。由此门故作意思惟解脱一切障。胜一切世间。智周一切境心解脱者。具上三德心离系缚

论曰

  能灭诸有情　　一切惑无余
  害烦恼有染　　常哀愍归礼

释曰。此颂显无诤。世俗智为性。不同声闻所得无诤将入城邑先审观察。若一有情当缘我身随起一种烦恼诤者。即便不入。如来观见虽诸有情当缘佛身起诸烦恼。若彼堪任受佛化者。即便往彼方便调伏。令灭烦恼。能灭诸有情一切惑无余者。非如声闻住无诤定。方便远离不令自身。作少有情生烦恼缘。唯伏欲界有事烦恼。非余烦恼。诸佛不尔方便能灭一切有情。一切烦恼令无有余。害烦恼者。唯害烦恼不害有情有染。常哀愍者。若诸有情有烦恼染。佛常哀愍而不诃害。如有颂言

  如咒鬼良医　　治诸鬼所魅
  但诃害鬼魅　　非鬼所魅者
  如是大悲尊　　治烦恼所魅
  但诃害烦恼　　不诃害有情

论曰

  无功用无著　　无碍常寂定
  于一切问难　　能解释归礼

释曰。此颂显愿智胜声闻等。由五相故。谓无功用故无著故无碍故常寂定故。一切疑难能解释故。诸声闻等所得愿智。随其所愿而入于定。唯能知此不知其余。佛即不尔。由无功用智不作功用。如末尼天乐随愿能知一切境界。由无著智于所知境皆无滞故。由无碍智断烦恼障并习气故。由常寂定定障断故。如有颂言

  那伽行寂定　　那伽住寂定
  那伽坐寂定　　那伽卧寂定

由此所发微妙愿智。于一切时善能解释一切问难

论曰

  于所依能依　　所说言及智
  能说无碍慧　　常善说归礼

释曰。此颂显示四无碍解。言所依者。谓诸教法即契经等。言能依者。谓所诠义。如是二种皆名所说。所作业故。言智二种皆是能说。作者作具等所起故。无碍慧者。谓于此中无退转智。常善说者由具四种无碍解故。常能善说。若于所依无碍觉慧名法无碍。于法异门无挂碍故。若于能依无碍觉慧名义无碍。于一切法自相共相无挂碍故。或于诸法别义意趣无挂碍故。若于其言无碍觉慧名训词无碍。于诸国土各别境界种种言词。随自展转异想随说无挂碍故。或于诸法训释言词无挂碍故。若于分析诸法智中。无碍觉慧名辩说无碍。于能辩析诸法智中无挂碍故

论曰

  为彼诸有情　　故现知言行
  往来及出离　　善教者归礼

释曰。此颂显示六种神通。为彼诸有情者。此是总句。善教者。言一一皆有。善者妙也。教者言也。为令胜进说微妙言。名善教者故。现善教者。是如意通。随所应化故往其所。现大神变善教彼故。知言善教者。是天耳通。听闻远住。有义言词一切音声。如其所应为说法故。知行善教者。是心差别通。知心胜劣。善教彼故。知往善教者。是宿住随念智通。了达过去善教彼故知来善教者。是死生智通。了达未来善教彼故。知出离善教者。是漏尽智通。知断烦恼善教彼故

论曰

  诸众生见尊　　皆审知善士
  暂见便深信　　开导者归礼

释曰。此颂显示诸相随好。法身是现相好所依故。就相好归礼法身。诸众生见尊皆审知善士者。一切世间由见世尊具相随好。皆悉审知是大善士。诸众生者。通摄当时及于后时堪受化者。暂见便深信者。暂见世尊具相随好。便深净信。知是世间善开导者

论曰

  摄受住持舍　　现化及变易
  等持智自在　　随证得归礼

释曰。此颂显示四一切相清净。摄受住持舍者。显所依清净。依止静虑如其所欲。随乐长短能于自身。摄受住持弃舍自在。现化及变易者。显所缘清净。化作种种未曾生色。名为现化。转变种种已曾生色。成金银等名为变易。于此一切变化品。类皆得自。在等持自在者。显心清净。随其所欲三摩地门自在而转。一一刹那如其意乐。能入诸定。智自在者。显智清净。如其所欲陀罗尼门任持自在。随证得者。随顺证得上四清净

论曰

  方便归依净　　及大乘出离
  于此诳众生　　摧魔者归礼

释曰。此颂显十力。谓于善趣恶趣方便诸业。归依世出世净。大乘出离四种义中。魔诳众生。此中显说能摧彼魔十力业用。言方便者。善趣方便。谓诸善业。恶趣方便。谓不善业。宣说如是趣方便时。魔于其中诳惑而住言不如是。与是相违说不善业。为善趣方便。说诸善业为恶趣方便。或说一切皆无有因。或说一切自在天等以为其因。处非处力能摧彼说。训释词者。处名所以。有所容受。若无所以。无所容受。说名非处。谓无处无容诸众生类。无因恶因而当得有。此复云何。由此有故彼有。此生故彼生。谓无明缘行等。非自在天等。令次第得生。言归依者。所谓诸业。如说世间皆由自业。业为依止业作归依。说此业时魔于其中诳惑而住。广如前说。由第二业异熟智力。能摧彼说无所挂碍谓。诸有情业所分别高下胜劣。不由无因自在天等。广如前说所言净者。谓世间净及出世净。暂时毕竟伏诸烦恼。永害随眠。由诸静虑等持等至及圣道故。说此净时魔于其中诳惑而住。广如前说。由静虑等持等至智力。能摧彼说无所挂碍。及大乘出离者。此显余力所作业用。谓说大乘究竟出离佛果德时。魔于其中诳惑而住。言此无上正等菩提极难可得。宜求声闻究竟出离。由余七力能摧彼说无所挂碍

论曰

  能说智及断　　出离能障碍
  自他利非余　　外道伏归礼

释曰。此颂显示四无所畏。能说智者。谓佛诚言我是真实正等觉者。即是遍知一切法。智能说断者。谓佛诚言我是真实诸漏尽者。即是烦恼诸漏永尽。如是二种依自利说。能说出离者。谓佛诚言我为弟子说出离法。真实出离。能说能障碍者。谓佛诚言我为弟子说能障法。真实能碍如是二种依利他说。如是四种名自他利。非余外道伏者。显离怖畏释无畏义。非余外道所能降伏。是故无畏

论曰

  处众能伏说　　远离二杂染
  无护无忘失　　摄御众归礼

释曰。此颂显示不护念住。处众能伏说者。谓处大众能伏他说。以身业等及诸威仪。皆无丑恶可须藏护。恐彼讥嫌。是故处众能伏他说。如是即明三种不护。远离二杂染者。谓恭敬听不恭敬听。弟子众中善住念故。远离爱恚。如是即明三种念住。由此无护无忘失故。能善摄御诸弟子众

论曰

  遍一切行住　　无非圆智事
  一切时遍知　　实义者归礼

释曰。此颂显示拔除习气。遍一切行住者。谓于聚落或于城邑为乞食故。往返经行于树下等。身四威仪寂然而住。无非圆智事者。谓声闻等虽尽烦恼犹有习气。随缚所作掉举等事。如彼尊者大目揵连。五百生中常作猕猴。由彼习气所随缚故。虽离烦恼而闻乐时作猕猴跳踯。有一独觉。昔多生中曾作淫女。今余习故时庄饰面。如是等类非一切智所应作事。世尊皆无。是名如来不共功德。一切时遍知实义者者。非如外道掊刺拏等。非是真实一切智者。故说如来是其实义一切智者。顺结颂法故颠倒说。或此句义前后各别。一切时遍知者。此显佛是一切智者。实义者者。此显佛是有实义者。如人有杖说为杖者

论曰

  诸有情利乐　　所作不过时
  所作常无虚　　无忘失归礼

释曰。此颂显示无忘失法。诸有情利乐所作不过时者。谓佛世尊若有所化。若于尔时应有所作。即便为彼即于尔时。作所应作终不失时。如有颂言

  譬如大海水　　奔潮必应时
  佛哀愍众生　　赴感常无失

所作常无虚者。谓佛所作不空无果。无忘失者。所作应时常无忘失

论曰

  昼夜常六返　　观一切世间
  与大悲相应　　利乐意归礼

释曰。此显大悲。利益安乐意乐为体。此言大者。福智资粮圆满证故。令脱三苦为行相故。三界有情为所缘故。于诸有情心平等故。决定无有胜此者故。昼夜常六返观一切世间者。此显大悲所作业用。谓佛世尊于昼夜分。各三时观一切世间。谁善法增谁善法减。谁善根熟谁根未熟。谁是堪受胜生法器。谁是堪受定胜法器。谁是佛乘器。谁是余乘器。如是等

论曰

  由行及由证　　由智及由业
  于一切三乘　　最胜者归礼

释曰。此显十八不共佛法。言由行者。此说行时一切事业。即是如来无有误失。乃至无有不择而舍。及由证者。即是住时六种无退。谓欲无退乃至第六解脱无退。言由智者。谓于三世无著无碍智见而转。及由业者。即是如来身语意业。智为前导随智而转。于一切三乘最胜者者。此显佛于一切声闻及独觉乘最为殊胜。由与十八不共功德具相应故

论曰

  由三身至得　　具相大菩提
  一切处他疑　　最胜者归礼

释曰。此颂显示一切相妙智性。一切行相皆正了知名一切相妙智。此妙智体名一切相妙智性。即是一切所知境界。一切行相殊胜智体。言三身者。谓自性等。由此三身至得具相无垢无碍妙智自性大菩提果。言具相者具一切相。有说无常等十六种行相名一切相。菩提用彼为先因故。有余复说。即此及余一切诸法皆无自性。无生无灭本来寂静自性涅槃无所得相名一切相。有余复说。非于此中说治所治诸品类相。然说一切义利圆满。如如意珠具一切相。我今观此一切相者。即是一切障断品类。所以者何。永断一切障品类故。谓断一切所知障品及断一切习气品故。又此具相大菩提者。即是正知一切境相。是故能断一切他疑。一切处者一切世间他疑。即是所有人天一切疑惑。于此他疑皆悉能断。由此能断一切人天疑惑作用。显一切相妙智殊胜

论曰。诸佛法身与如是等功德相应。复与所余自性因果业相应转。功德相应。是故应知诸佛法身无上功德。此中有二颂

  尊成实胜义　　一切地皆出
  至诸众生上　　解脱诸有情
  无尽无等德　　相应现世间
  及众会可见　　非见人天等

释曰。法身与此功德相应。复与余六功德相应。此略标义。二颂广释。尊成实胜义者。谓佛法身成实胜义。真如所显此即宣说法身自性功德。相应说力差别相应无失。譬如说火暖德相应。一切地皆出者。是极喜等一切十地。皆出离义。此则成实胜义之因。至诸众生上者。一切智性于诸有情最为殊胜。此即成实胜义之果。解脱诸有情者。即是成实胜义之业。无尽无等德相应者。与诸功德相属相应。无边不共力无畏等无尽无等德相应故。现世间及众会可见者。谓变化身出现世间。及受用身处大众会。二皆可见。非见人天等者。谓佛法身非人天等之所能见。此说世尊三身差别。以显转义。转谓体性转变差别。于三身中。二身可见一非可见

摄大乘论释卷第九摄大乘论释卷第十

        无性菩萨造

        三藏法师玄奘奉　诏译

    果智分第十一之余

论曰。复次诸佛法身甚深最甚深。此甚深相云何可见。此中有多颂

释曰。诸佛法身甚深者。说此法身自性。难觉世聪明者。所有觉慧尚不解故。最甚深者。说此法身差别难觉。诸声闻等所有觉慧不能行故。如是甚深以十二颂。略当显示

论曰

  佛无生为生　　亦无住为住
  诸事无功用　　第四食为食

释曰。此颂显生住业住甚深。佛无生为生者。诸佛无生而现有生。名生甚深。亦无住为住者。生死涅槃无住为住。此即安住无住涅槃名住甚深。诸事无功用者。不由功用作一切事。犹如世间末尼天乐。名业甚深。第四食为食者。食有四种。一不清净依止住食。谓具缚者。由段等食令身安住。二净不净依止住食。谓若生在色无色界。由触意思识食安住已离欲故无有段食。预流向等是有学故。亦净不净依止住食。彼由四食自体安住。三一向净依止住食。谓由四食阿罗汉等自体安住。四唯示现依止住食。谓佛世尊示现受用段等四食。如来食时实不受食。亦不假食自身安住。然顺世间示现受食。示现假食其身安住。现受第四食得住故。名住甚深

论曰

  无异亦无量　　无数量一业
  不坚业坚业　　诸佛具三身

释曰。此颂显示安立数业甚深。无异者。显安立甚深以无差别而安立故。亦无量者。显数甚深。此显安立其数无量。无数量一业者。虽有无量而无别业。何者一业变化受用业无差别。成他利故。不坚业坚业者。自性身业是其坚住。余二身业是不坚住。如是一切。名业甚深

论曰

  现等觉非有　　一切觉非无
  一一念无量　　有非有所显

释曰。此颂显示现等觉甚深。现等觉非有者。依他起中遍计所执性非有故。一切觉非无者。依他起中圆成实性是真有故。一一念无量者。谓过无量殑伽沙数诸世界中。念念俱时有无量佛现等觉故。有非有所显者。谓诸如来是有非有。空性所显成尊位故

论曰

  非染非离染　　由欲得出离
  了知欲无欲　　悟入欲法性

释曰。此颂显示离欲甚深。云何非染断贪缠故。非离染者。非速永断贪随眠故。由欲得出离者。由留如是随眠贪故。得大菩提。若断如是贪随眠者。应同声闻等疾入涅槃故。了知欲无欲者。了知遍计所执贪欲无欲性故。悟入欲法性者。悟入作证欲法真如

论曰

  诸佛过诸蕴　　安住诸蕴中
  与彼非一异　　不舍而善寂

释曰。此颂显示断蕴甚深。诸佛过诸蕴者。谓诸如来超过一切遍计所执色等诸聚。如实观见遍计所执不可得故。安住诸蕴中者。谓佛安住法性蕴中。与彼非一异者。谓法性蕴与彼遍计所执诸蕴。不可说异遍计所执性本无故。不可说一遍计所执顺杂染故。法与法性非一非异。不舍而善寂者。谓不弃舍法性诸蕴。即是妙善永寂灭故

论曰

  诸佛事相杂　　犹如大海水
  我已现当作　　他利无是思

释曰。此颂显示成熟甚深诸佛事相杂者。谓诸如来所作一切利益安乐有情事业。展转和同合成一味不可分别。问此事如何等。答犹如大海水。谓如大海众流所归水同一味不可分别。一切同作鱼等饶益。我已现当作他利无是思者。离功用心思惟他利三时差别。而能任运起利他事。如帝释等末尼天乐。虽无思虑而有作用

论曰

  众生罪不现　　如月于破器
  遍满诸世间　　由法光如日

释曰。此颂显示显现甚深。问若如来身是常住者。于一切时何故不现。答众生罪不现。如月于破器。如破器中水不得住月影。不现此非月过。是器之失。众生身中无奢摩他清润定水。佛影不现非如来过。是众生失。水喻等持清润性故。如说如来是真妙善无漏法影有感斯现。若无感者犹如生盲不能睹见。遍满诸世间由法光如日者。谓诸佛日放契经等正法言光。遍照一切有情世间。有缘斯见余不见者。是其自过非如来失。如世间日流光遍照有目者。睹盲者不见

论曰

  或现等正觉　　或涅槃如火
  此未曾非有　　诸佛身常故

释曰。此颂显示示现等觉涅槃甚深。或现等正觉或涅槃如火者。如世间火有处烧燃有处息灭。诸佛亦尔。于诸善根未成熟者现等正觉。令其成熟速得解脱。于诸善根已得成熟已解脱者现般涅槃。无所为故。此未曾非有等其义易了

论曰

  佛于非圣法　　人趣及恶趣
  非梵行法中　　最胜自体住

释曰。此颂显示住甚深。于非圣法最胜自体住者。谓于不善由最胜自体住。最胜住即空无愿及无相住。缘不善法而安住故。于人趣及恶趣最胜自体住者。谓于人趣及诸恶趣。由最胜自体住。最胜住即诸静虑诸等至住。由缘彼趣而安住故。非梵行法中最胜自体住者。谓于非梵行法中由最胜自体住最胜住。即四无量名为梵住。缘非梵行而安住故

论曰

  佛一切处行　　亦不行一处
  于一切身现　　非六根所行

释曰。此颂显示自体甚深。言自体者。即是如来常住法界及所成德总名自体。佛一切处行者。谓后得智遍行一切。于何遍行。谓善不善无记有漏无漏有为无为等差别境界。亦不行一处者。谓无分别智无分别故。不行一切差别境界。于一切身现者。谓变化身于一切处现受生故。非六根所行者。谓第一义常住法身。非诸生处。那落迦等同分有情。所能取故

论曰

  烦恼伏不灭　　如毒咒所害
  留惑至惑尽　　证佛一切智

释曰。此颂显示断烦恼甚深。烦恼伏不灭者。谓菩萨位中伏诸烦恼而未永断。如毒咒所害者。譬如众毒为神验咒之所损害。体虽未灭而不为患。烦恼亦尔由念智力伏现行缠。随眠犹在。何故烦恼随眠犹在。恐同声闻乘速般涅槃故由此道理烦恼为因。至烦恼尽得一切智。如有颂言

  念智力所制　　烦恼证菩提
  如毒咒所持　　过失成功德

论曰

  烦恼成觉分　　生死为涅槃
  具大方便故　　诸佛不思议

释曰。此颂显示不可思议甚深。谓诸烦恼转成觉分。生死苦恼即为涅槃。如是因果非世间理可得思议

论曰。应知如是所说甚深有十二种。谓生住业住甚深。安立数业甚深。现等觉甚深。离欲甚深。断蕴甚深。成熟甚深。显现甚深。示现等觉涅槃甚深。住甚深。显示自体甚深。断烦恼甚深。不可思议甚深

释曰。此十二种皆难觉了故名甚深。一一别相如前已说

论曰。若诸菩萨念佛法身由几种念。应修此念。略说菩萨念佛法身。由七种念应修此念。一者诸佛于一切法得自在转。应修此念。于一切世界得无碍通故。此中有颂

  有情界周遍　　具障而阙因
  二种决定转　　诸佛无自在

二者如来其身常住。应修此念。真如无间解脱垢故。三者如来最胜无罪。应修此念。一切烦恼及所知障并离系故。四者如来无有功用。应修此念。不作功用一切佛事无休息故。五者如来受大富乐。应修此念。清净佛土大富乐故。六者如来离诸染污。应修此念。生在世间一切世法不能染故。七者如来能成大事。应修此念。示现等觉般涅槃等。一切有情未成熟者能令成熟。已成熟者令解脱故。此中有二颂

  圆满属自心　　具常住清净
  无功用能施　　有情大法乐
  遍行无依止　　平等利多生
  一切佛智者　　应修一切念

释曰。此显菩萨修念诸佛法身功德。于一切法自在转者。谓诸如来于一切法。由串习故得自在转。暂起欲乐一切功德皆能圆满。现在前故。若诸如来普于一切无量无边诸世界中。神通无碍。何因缘故一切有情不般涅槃。由彼有障及无因故。前总明佛于一切法得自在转。今别显示佛于有情不得自在故说伽他。有情界周遍具障而阙因者。谓具烦恼业异熟障故名具障。猛利烦恼诸无间业愚戆顽嚚如其次第。无涅槃因无种性故。名为阙因。二种决定转者。谓作重业决定受异熟决定。作重业决定者。谓数串习令同类因与等流果决定相续。如未生怨害父王等。受异熟决定者。谓作决定感异熟业。决定当受诸异熟果。如诸释种决定应为毗卢宅迦王所杀害。诸佛于上所说有情。皆无自在令得涅槃。是故前虽总说如来于一切法得自在转。今须别说不得自在。如来身常住者。最清净真如为自体故。无改转故。无变异故。如来最胜无罪者。谓诸烦恼及所知障罪永断故。如来无功用者。谓如天乐其义易了。如来受大富乐者。受用广大清净佛土功德庄严大法乐故。如来离染污者。如红莲花其义易了。如来能成大事者。谓现等觉般涅槃等。成办有情广大义利。如所堪能令彼成熟得解脱故。如是七种所修念佛。复以二颂略摄其义。初圆满言贯通一切。属自心圆满者。此摄第一于一切法自在转相。具常住圆满者。此摄第二身常住相。具清净圆满者。此摄第三最胜无罪相。无功用圆满者。此摄第四无功用相。能施有情大法乐圆满者。此摄第五大法乐相。遍行无依止圆满者。此摄第六一切世法不能染相。平等利多生圆满者。此摄第七能成大事相。能作广大利乐事故。一切佛者。谓诸如来圆满功德。言智者者。谓大菩萨应修。一切念者。应修如是七种随念。忆持明记令不忘失。是其念义

论曰。复次诸佛清净佛土相。云何应知。如菩萨藏百千契经序品中说。谓薄伽梵住最胜光曜七宝庄严。放大光明普照一切无边世界。无量方所妙饰间列。周圆无际其量难测。超过三界所行之处胜出世间善根所起。最极自在净识为相。如来所都诸大菩萨众所云集。无量天龙药叉健达缚阿素洛揭路茶紧捺洛莫呼洛伽人非人等常所翼。从广大法味喜乐所持。作诸众生一切义利。蠲除一切烦恼灾横。远离众魔过诸庄严。如来庄严之所依处。大念慧行以为游路。大止妙观以为所乘。大空无相无愿解脱为所入门。无量功德众所庄严。大宝花王之所建立。大宫殿中如是显示清净佛土。显色圆满。形色圆满。分量圆满。方所圆满。因圆满。果圆满。主圆满。辅翼圆满。眷属圆满。任持圆满。事业圆满。摄益圆满。无畏圆满。住处圆满。路圆满。乘圆满。门圆满。依持圆满

复次受用如是清净佛土。一向净妙。一向安乐。一向无罪。一向自在

释曰。此依诸佛清净佛土。说薄伽梵住最胜光曜七宝庄严等。言最胜光曜七宝庄严者。谓佛净土光曜最胜。用七妙宝绮饰庄严。或即七宝最胜光曜。言七宝者。一金二银三琉璃。四牟娑洛宝。五遏湿摩揭娑宝。此复何等。所谓帝青大青等宝。六赤真珠宝。谓赤虫所出名赤真珠。七羯鸡怛诺迦宝。放大光明普照一切无边世界者。谓即最胜光曜七宝放大光明遍照一切无边世界。或净佛土放大光明。普照一切无边世界。其体亦遍无边世界。此上二句显佛净土。显色圆满。无量方所妙饰间列者。谓佛净土无量方所妙饰间列。如慧为先安布间饰。此句显示形色圆满。周圆无际其量难测者。谓佛净土其量周圆无际难测。或复其量无边际故周圆难测。此句显示分量圆满。超过三界所行之处者。谓佛净土方处超过三界行处。非三界爱之所行故。非诸系业异熟果故。此句显示方所圆满。胜出世间善根所起者。谓出世间善根为因。及后得胜善根为因。净土生起。非自在等为净土因。此句显示因圆满。最极自在净识为相者。谓佛净土最极自在清净心识以为体相。唯有识故。非离识外别有宝等。即净心识如是变现似众宝等。此句显示果圆满。如来所都者。谓佛为主都此非余。此句显示主圆满。诸大菩萨众所云集者。唯有已入大地菩萨。止住其中补翼如来非声闻等。此句显示辅翼圆满。无量天龙药叉等者。谓诸天等止住其中以为眷属。此化非实。莫呼洛伽者。此摄大蟒。此句显示眷属圆满。广大法味喜乐所持者。谓净土中大乘法味喜乐为食。此句显示任持圆满。食能任持诸身命故。作诸众生一切义利者。食此食已作诸有情诸利乐事。此句显示事业圆满。蠲除一切烦恼灾横者。谓净土中无诸烦恼所作灾横。此句显示摄益圆满。远离众魔者。谓离烦恼蕴死天魔四种怨敌。此句显示无畏圆满。过诸庄严如来庄严之所依处者。谓过一切菩萨庄严。如来庄严之所依处。此句显示住处圆满。于诸住处最为胜故。大念慧行以为游路者。思所成慧名为大念。闻所成慧名为大慧。修所成慧名为大行。此句显示路圆满。游路即是道之异名。大止妙观以为所乘者。乘奢摩他毗钵舍那。游三慧路。往所趣园。胜诸声闻独觉菩萨所乘止观故名为大。此句显示乘圆满。大空无相无愿解脱为所入门者。三解脱门为趣入处。门者通也大义如前。此句显示门圆满无量功德众所庄严。大宝花王之所建立者。譬如世间宝庄严具。众宝庄严此佛净土。所依大宝红莲花王。无量功德众所庄严。如地轮等依风轮住。如是净土无量功德。众所庄严大宝花王之所建立。此红莲花于众花中最为殊胜。是故说名大宝花王。或即如来说名大王大法王故。此红莲花是佛依处。从主为名。所建立者。谓佛净土依此花王。长时相续无有间绝。此句显示依持圆满

受用如是清净佛土一向净妙者。无不净故。离粪秽故。一向安乐者。无有苦受及处中受故。一向无罪者。无有不善及无记故。一向自在者。不待外缘故。暂起于心众事办故

论曰。复次应知如是诸佛法界。于一切时能作五业。一者救济一切有情灾横为业。于暂见时便能救济盲聋狂等诸灾横故。二者救济恶趣为业。拔诸有情出不善处置善处故。三者救济非方便为业。令诸外道舍非方便求解脱行。置于如来圣教中故。四者救济萨迦耶为业。授与能超三界道故。五者救济乘为业。拯拔欲趣余乘菩萨。及不定种性诸声闻等。安处令修大乘行故。于此五业应知诸佛业用平等。此中有颂

  因依事性行　　别故许业异
  世间此别力　　无故非导师

释曰。诸佛法界即是法身。应知恒时能作五业。救济一切有情灾横为业者。因缘所生病等忧苦。说名灾横。于暂见时便能救济盲聋狂等诸灾横者。如契经言。若见佛时盲者得眼。聋者得耳。狂者得念。如是等问如说法身非六根境。云何今说盲得眼等。能见法身为法身业。答见法身者。由昔大愿引发势力。成满法身。次第发起变化身用。由此能令盲得眼等。由昔资粮引发势力。证得法身任运起用。如机关轮以末归本。言见法身。实唯见化。救济恶趣为业等者。拔不善处置于善处。方名救济。其因若无。果亦无故。救济非方便为业等言其文显了。救济萨迦耶为业等者。迦耶名身。虚为名萨。其身虚为名萨迦耶。谓于其中为身见转。即是三界有漏诸法。于彼说授出离法故名为救济。救济乘为业等者。为令不定种性菩萨。及声闻等证大菩提。安立彼于大乘正行。应知诸佛于此五业悉皆平等。为显此义复说颂言。因依事等世间因别故许业异者。谓天因别人鬼等因各各差别。故业有异。诸佛不尔。因无别故。非业有异。世间依别故许业异者。依谓身体彼差别故。其业有异。如彼天授与彼祠授依身别故。其业各异。诸佛不尔。法身无别故业非异世间事别故许业异者。事谓所作所用差别事各别故。其业有异如彼凡夫营农事别。商贾事别。如是一切诸佛不尔。利众生事无差别故。非业有异。世间性别故许业异者。性谓意乐。如彼世间利益意乐安乐意乐。境界差别故业有异。诸佛不尔。利益安乐一切有情。意乐无别故业非异。世间行别故许业异者。行谓功用如小功用能起小业。若大功用便起大业。功用别故其业有异。诸佛不尔。一切所作皆无功用故业非异。此别力无故非导师者。此因等五别力无故非世导师五业差别

论曰。若此功德圆满相应。诸佛法身不与声闻独觉乘共。以何意趣佛说一乘。此中有二颂

  为引摄一类　　及任持所余
  由不定种性　　诸佛说一乘
  法无我解脱　　等故性不同
  得二意乐化　　究竟说一乘

释曰。依此密意佛说一乘。二颂显示。为引摄一类者。了知不定种性声闻。趣彼解脱方便引摄。令依大乘而般涅槃故说一乘。及任持所余者。为欲任持其余不定种性菩萨。恐于大乘精进退坏。故说一乘任持令住。勿彼菩萨依声闻乘而般涅槃。法等故者。法谓真如。诸声闻等乘虽差别同趣真如。所趣真如无有差别。故说一乘。无我等故者。补特伽罗无我同故。若实有异。补特伽罗可有乘别。此是声闻此是菩萨。既无实异补特伽罗故说一乘。解脱等故者。谓彼三乘于烦恼障解脱无异。如世尊言。解脱解脱无有差别。由此意趣故说一乘。性不同故者。谓诸声闻不定种性有差别故。谓回向菩提声闻身中。具有声闻种性及佛种性。由此道理故说一乘。得二意乐故者。谓得二种意乐。一者诸佛于一切有情。得同自体意乐言彼即是我。我即是彼。由是因缘此既成佛。彼亦成佛。是故名得第一意乐。二者世尊法花会上。与诸声闻舍利子等。授佛记别。为令摄得如是意乐。我等与佛平等无二。又此会上有诸菩萨与彼名同。得授记别故。佛一言含二种益。谓诸声闻摄得同佛自体意乐。及诸菩萨得授记别。由此道理故说一乘。言化故者。如世尊言。汝等苾刍我忆往昔无量百返。依声闻乘而般涅槃。云何已成佛复依声闻而般涅槃。是故此中有别意趣。谓为调伏声闻种性。所化有情自化其身。同彼乘类现般涅槃。由此义故。若声闻乘若独觉乘。即是大乘故。成一乘究竟故者。依究竟理故说一乘。非无归别。由过此外无别胜乘。唯此一乘最为胜故。佛说一乘

论曰。如是诸佛同一法身。而佛有多。何缘可见此中有颂

  一界中无二　　同时无量圆
  次第转非理　　故成有多佛

释曰。一界中无二者。一世界中无有二佛。是故当言唯有一佛。同时无量圆者。无量菩萨修集资粮同时圆满。多世界中现成佛果。是故诸佛当言有多。或有说言。一世界中前后次第。无量菩萨成等正觉。非多世界同时多佛。为破此执。复言次第转非理故。无有因缘。无量菩萨修集资粮同时圆满。展转相待次第成佛。是故诸佛同时有多

论曰。云何应知。于法身中佛非毕竟入于涅槃。亦非毕竟不入涅槃。此中有颂

  一切障脱故　　所作无竟故
  佛毕竟涅槃　　毕竟不涅槃

释曰。有大乘人。谓佛毕竟不般涅槃。就无余依涅槃界说。余复谓佛毕竟涅槃。就有余依涅槃界说。此二意趣定执非理。若正说者应言。诸佛非定毕竟入于涅槃。亦非毕竟不入涅槃。佛一切障得解脱故毕竟涅槃。所应作事无竟期故。诸佛毕竟不入涅槃

论曰。何故受用身非即自性身。由六因故。一色身可见故。二无量佛众会差别可见故。三随胜解见自性不定可见故。四别别而见自性变动可见故。五菩萨声闻及诸天等种种众会间杂可见故。六阿赖耶识与诸转识转依非理可见故。佛受用身即自性身。不应道理

释曰。色身可见故者。谓受用身有色可见。非自性身有色可见。故受用身非自性身。又受用身无量众会。受用色法差别可见。非自性身有此差别。故受用身非自性身。又受用身随胜解见自性不定。如契经言。或有一类见受用佛。或有一类见是少年。或有一类见为童子。如是广说非自性身。有此不定故受用身非自性身。又受用身自性变动差别可见。一能见者先于一时见受用身形相别异。后于一时复见别异。非自性身其体变动故。受用身非自性身。又受用身菩萨声闻及诸天等种种众会。常所间杂非自性身。应有如是众会间杂。故受用身非自性身。又见转依非道理故。谓转阿赖耶识得自性身。转诸转识得受用身。故受用身非自性身。由此六种不应正理。故受用身非自性身

论曰。何因变化身非即自性身。由八因故谓诸菩萨从久远来。得不退定。于睹史多及人中生。不应道理。又诸菩萨从久远来。常忆宿住书算数印工巧论中。及于受用欲尘行中。不能正知不应道理。又诸菩萨从久远来。已知恶说善说法教往外道所。不应道理。又诸菩萨从久远来已能善知三乘正道。修邪苦行不应道理。又诸菩萨舍百拘胝诸赡部洲。但于一处成等正觉转正法轮不应道理。若离示现成等正觉唯以化身于所余处。施作佛事即应。但于睹史多天成等正觉。何不施设遍于一切赡部洲中。同时佛出既不施设无教无理。虽有多化而不违彼无二如来出现世言。由一四洲摄世界故。如二轮王不同出世。此中有颂

  佛微细化身　　多处胎平等
  为显一切种　　成等觉而转

为欲利乐一切有情。发愿修行证大菩提。毕竟涅槃不应道理。愿行无果成过失故

释曰。由八因故证变化身。即自性身不应正理。谓诸菩萨从久远来得不退定。曾无退失。生于欲界睹史多天尚不应理。况生人中非经多劫。修不退定得欲界果应正道理。故变化身异自性身道理成就。又诸菩萨从久远来常忆宿住。广说乃至修邪苦行。不应道理。其文易了无烦重释。又诸菩萨舍百拘胝诸赡部洲但于一处成等正觉。转正法轮不应道理。此一切处皆相似故。由此道理。是变化身非自性身。若谓远离余赡部洲现成等觉。唯独于此赡部洲中真证正觉。以变化身遍于余处施作佛事。何故不许睹史多天真证等觉。化身来此诸四大洲施作佛事。若汝意谓一赡部洲成等正觉。余处现化非不应理。若唯住在睹史多天。成等正觉一切四洲赡部洲内。示现化身何不应理。若定不许一切四洲现等正觉无教无理故不可说。有赡部洲无佛出世。为不与彼契经相违。如契经说无处无容非前非后。于一世界有二如来出现于世。若许一切赡部洲中同时多佛出现于世。与彼相违为避此难。是故复言。虽有多化而不违彼。无二如来出现世等。彼契经说一四大洲。名一世界非千洲等。即彼经说如二轮王不同时出。若不许佛多四大洲同时俱出。亦不应许有多轮王多四大洲同时俱出。若许唯一四大洲中无二轮王同时并出。非千洲等。亦应许佛一四洲中无二并出。非千洲等。复以伽他现多化身。显具相觉佛微细化身等者。如佛化身现入母胎。如是化作舍利子等多声闻众其相各异。入自母胎同时平等。为欲显发一切种觉是尊胜故。佛作是化。次显如来毕竟涅槃不应道理。谓为利乐一切有情。发愿修行证大菩提。此愿此行唯欲利乐一切有情。事犹未讫即便依彼毕竟涅槃而般涅槃不应道理。行愿二种应无果故。现涅槃者是变化身。非自性身

论曰。佛受用身及变化身既是无常。云何经说如来身常。此二所依法身常故。又等流身及变化身。以恒受用无休废故。数数现化不永绝故。如常受乐如常施食。如来身常应知亦尔

释曰。有契经说如来身常。佛受用身及变化身。既是无常。云何如来其身常住。谓此二身虽是无常。然依法身。法身常故亦说为常。言身常者。或体是常。或依常身故名身常。此显等流及变化身。是异门常非自性常。又受用身。以恒受用无休废故。如常受乐。犹如世间言常受乐。虽非受乐常无间断。而得说言此常受乐。佛受用身当知亦尔。虽非常住而或言常。以于彼彼菩萨众中。受大法乐无休废故。佛变化身数数现化不永断绝。别意言常。如常施食。犹如世间言常施食。虽非施食能常无间。然数数施期心不绝。名常施食。佛变化身当知亦尔。非无生灭说名为常。随所化生数数示现。不永绝故密意言常

论曰。由六因故。诸佛世尊所现化身非毕竟住。一所作究竟成熟有情已解脱故。二为令舍离不乐涅槃。为求如来常住身故。三为令舍离轻毁诸佛。令悟甚深正法教故。四为令于佛深生渴仰。恐数见者生厌怠故。五令于自身发勤精进。知正说者难可得故。六为诸有情极速成熟。令自精进不舍轭故。此中有二颂

  由所作究竟　　舍不乐涅槃
  离轻毁诸佛　　深生于渴仰
  内自发正勤　　为极速成熟
  故许佛化身　　而非毕竟住

释曰。为令舍离不乐涅槃。为求如来常住身故者。此显如来入涅槃意。以如来身是无常故。应乐涅槃若求如来常住身时。便背涅槃世尊现灭显身无常。令乐毕竟常涅槃故。为令舍离轻毁诸佛。令悟甚深正法教故者。若谓诸佛其身常住。便于悟解甚深法教不勤方便。谓今不悟后定当悟。若数检问诸弟子众。便生轻毁自执己见作如是言。我由此故定免彼问。若不住世彼于何处当生轻毁。咸言我等未得彼意。世尊涅槃。谁能无倒开悟我等。是故于法勤求觉悟。令于自身发勤精进。知正说者难可得故者。谓知世尊将般涅槃便于自身发勤精进。佛是世间正说法者。彼若无有世间无依。如是知已发勤精进。为诸有情极速成熟。令自精进不舍轭故者。为修精进离舍善轭乃至世尊未灭度来。我诸善根定须成熟。由是六因佛变化身非毕竟住。为摄如是上所说义故说伽他。由所作等

论曰。诸佛法身无始时来。无别无量不应为得更作功用。此中有颂

  佛得无别无量因　　有情若舍勤功用
  证得恒时不成因　　断如是因不应理

释曰。此中有难。诸佛法身无始时来无别无量作证得因。为求佛果何须功用。复有难言。诸佛法身无始时来无别无量。一佛即能具足成办。一切有情诸利乐事不应为得更作功用。为答此难。说佛得等。诸佛证得无始时来无别无量。若是有情为求佛果舍正勤因。如是证得恒不成因。由佛证得非诸有情。为求佛果舍正勤因故无此难。若离正勤得佛果者。一切有情本应皆得。是故不应断正勤因。又佛法界无始时来无别无量。普为一切作证得因。令诸菩萨悲愿缠心勤求佛果。为作一切有情利乐故求佛果发勤功用

论曰。阿毗达磨大乘经中摄大乘品。我阿僧伽略释究竟

释曰。我已略释摄大乘竟。复说颂曰

  我无性已发　　求佛果妙愿
  于净境理教　　悲慧积于心
  从诸师正闻　　如实深信解
  专念现前故　　已述造斯释
  于甚深广大　　十义勤生福
  愿一切世间　　得具相妙智

摄大乘论释卷第十


摄大乘论释论

    No. 1596 [Nos. 1595, 1597; cf. Nos. 1592-1594, 1598]

摄大乘论释论卷第一

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    应知依止胜相胜语第一

    无等圣教章第一

论曰。阿毗达磨大乘修多罗中。婆伽婆前善入大乘菩萨。为显扬大乘大体故说。所谓为大乘故。诸佛世尊有十种胜相胜语

释曰。问何为造论。答为敷演。应知甚深宽大法性故。若除不承佛菩萨力。何人有能于此解释。复以何义故。此论作如此相说。若离阿毗达磨言。则不知是圣说。为此义故。又是出经名。如言十地经。今当释彼经名。为令不知者令知故。言阿毗达磨修多罗者。彼修多罗中。明此阿毗达磨法门故。亦为显修多罗名故。言大乘者。简异声闻阿毗达磨故。亦有非圣说阿毗达磨。有人自以分别慧。谓是佛说阿毗达磨。或言。声闻所说。或言。世智者所作。为此故言大乘修多罗。即显示异于声闻等故。复次言阿毗达磨者。显示菩萨藏摄故复次藏摄者。显示调伏自烦恼故。于大乘中。是菩萨烦恼。菩萨以分别为烦恼故。阿毗达磨者。甚深宽大为相。此藏有三种。谓修多罗。阿毗达磨。毗那耶。即此三上下乘别故为二。谓声闻藏。菩萨藏。复次此三及二。何故名藏。答由摄故。谓摄一切所应知义。云何成三。有九因缘故。对治诸疑者修多罗。若人于义有疑。为令彼人于彼义得决定故说。对治着二边者毗那耶。遮有罪过受用故。谓着欲乐边。听无罪过受用故。遮自疲苦边。对治自见著者。阿毗达磨。由显无倒相故。复次说三学者修多罗。具足增上戒增上心者毗那耶。由持戒故。得不悔等次第得三磨提。具足增上慧者阿毗达磨。简择无倒义故。复次说法及义者修多罗。成就法义者毗那耶。若修行人调伏烦恼。于中得通达故。于法义决定善巧者阿毗达磨。由此等九因缘故立三藏。此等皆为解脱生死故。复次云何得解脱。熏知寂通故得解脱。由闻故熏于心。由思故知于修。中奢摩他故寂静。毗钵舍那故通达。此修多罗毗那耶阿毗达磨。略说各有四义。菩萨解此则得一切智。声闻随解一偈义。则得流尽。云何各有四义。一依二相三法四义。贯穿此者修多罗。于中依者。依处依人依所为故说。相者。世谛相第一义谛相。法者。阴界入缘生谛念定无量无色。解脱胜处一切处菩提分辩才无诤等。义者随顺相续故。一向二数一伏四普集。应知此是阿毗达磨。向者。阿毗达磨是向无住处涅槃法。说谛菩提分解脱等门故。数者。阿毗达磨是数法。于一一法中决了其自相通相等差别。有无量说故。伏者。阿毗达磨是伏他法。能伏他论由具立宗等故。普集者。由阿毗达磨。普集修多罗义故。复次毗那耶四者。一罪过二缘起三还净四出离应知。于中罪过者。谓五篇罪缘起者。起罪有四。一无知二放逸三烦恼炽盛四不尊重。还净者。由净心非治罚法。如禁戒摄持故。出离者。有七种。一自说发露。二与学等治罚。三一向禁断立学句。复以别道理故听。四已解。谓众僧同意共解故。五转身。谓比丘比丘尼转男女根若不共罪。六真实观。由作法郁陀那胜观故。七法尔得。谓得见谛已。小罪及随小罪。法尔无有故。复次毗那耶有四义应知。一人。谓依此立学处。二立制。谓如所白彼人罪过。大师集众制学处。三分别。谓制学句已随更解释。令分分差别。四决判。谓于彼分中云何得罪。云何无罪。令决定知故。今当释本文婆伽婆前者。为显恭敬无异言故。善入大乘者。谓得陀罗尼等功德。显示得彼功德已。于文于义能正持正说故。此菩萨名善入大乘。何为而说。为显发大乘大体故。显发者。广说彼大体故。所谓为大乘故者。依于大乘故。十种胜相胜语者。十相胜故。所以语胜。由此故彼有十种胜相胜语。复次胜言者。两相形故如此物。胜过于彼。最上义是胜义。复次由因体胜故。彼果语胜。今当说彼十种

论曰。诸佛世尊有应知依止胜相胜语。应知胜相胜语。入应知胜相胜语。彼入因果胜相胜语。彼因果修胜相胜语。于彼修差别中。增上戒胜相胜语。增上心胜相胜语。增上慧胜相胜语。灭胜相胜语。智胜相胜语。如是等所说修多罗句显于大乘是佛语

释曰。应知依止胜相胜语者。所可知法名应知。谓彼染净等法即是三性。依止者是因义。应知依止即是胜相。故言应知依止胜相。由彼胜相故语胜。即是阿梨耶识。如是等略释义。乃至智胜相亦尔。智即胜相。故言智胜相。应知相者。谓应知自性。应知即是相故言应知相。即是三性。入应知胜相者。此应知相中。若所入及能入。俱名入。即是唯识。即此入名彼入。言彼入因果者。唯识名入。因者。谓世间施等诸波罗蜜。即是加行时。果体者。即此通达时为出世间体故。彼因果修差别者。即是前因果于此因果中。修之差别。修者。谓数习故。此数习于诸地转胜。故名差别。即是十地。于此修差别中。增上戒学者。为戒修学名增上戒。即是十地中。所有菩萨禁戒。于诸不善无复作心故。增上心学者。内观心。此心即是增上学。谓三摩提故。增上慧学者。胜得慧名增上慧。此慧即是增上学。增上慧学即是无分别智故。灭胜相者。谓最胜种类自体灭。于烦恼障智障故。即是无住处涅槃故。智胜相胜语者。无障碍智名智胜相。彼无分别智有对治。佛智者。离一切随眠障。即是无分别智之殊胜

论曰。复次云何显发。此等所说十处。声闻乘中不说。唯大乘中说故。所谓阿黎耶识。说为应知依止体。三种自性。分别依止他成就。说为应知相体。唯识说为入应知相体。六波罗蜜说为入因果体。菩萨十地说为入因果修差别体。菩萨禁戒说为增上戒体。健行及虚空器等三摩提。说为增上心体。无分别智说为增上慧体。无住涅槃说为彼果灭体。诸佛三身自性身共用身化身。说为彼果智体。由此等十处故。与声闻乘殊异。殊异者最上故。由世尊为菩萨说。是故言诸佛世尊为大乘故。有十种胜相胜语应知

释曰。云何显发者。谓有何相貌故。六波罗蜜为入彼因果体者。谓唯识观得入三性。即是清净波罗蜜因。虽是世间能引出世间故。入地已去即是清净。为出世果体故。菩萨十地为彼因果修差别体者。即是诸地中修习三学。果者。即此三学果名果。此果中灭是灭果体。谓灭烦恼障智障故。无分别智是增上慧学体者。谓声闻无四倒分别故。名无分别。诸菩萨于一切法无分别。此是二无分别差别故。三种佛身为果智体者。彼三学果名彼果。彼果即是智故。言彼果智。此体即是彼果智体。此中若离自性身即无法身。如眼若离此则无报身。如眼识此能依所依二法平等应知。若离报身。已入大地诸菩萨受用法不成。若无受用法。菩提资粮满足亦不成。如见色化身亦尔。若离此解行中诸菩萨。及诸声闻粗浅解。初发修行亦不成。是故决定应有三身。故大乘与声闻乘殊异者。声闻乘中不说故。最上者。显示于大乘中亦殊胜故

论曰。复次云何以此十种如来胜相胜语。得显大乘是佛语。亦得遮声闻乘异于大乘。由此十处于声闻乘中不见说故。唯于大乘中说故。引生大菩提。此十处成就随顺不相违。得一切智智故。此中有偈

  应知依相入　　因果修差别
  三学果灭智　　上乘中殊胜
  此说余处无　　见此胜觉因
  故大乘佛语　　由说十处胜

释曰。此义云何。能引大菩提故。显示此义。此十处成就随顺不相违者。能引生大菩提故。引生大菩提者。为因故。成就者。于三学量中思量观察。如导师显示道相故。随顺者。于胜得中起修行时。随顺相应住故。如导师所说。于中随顺而住。不相违者。于诸地中障碍事不有故。如所说道中无有贼等障碍。谓生死涅槃不相障碍故

    十义次第章第二

论曰。复次此十处。何故作如此次第说。诸菩萨最初由于如是等诸法。因中得善巧。即于缘生中得善巧故。彼等次于缘所生法中。得善知其相。善知离增益损减二边过故。菩萨于如是等相善相应已。次于彼善摄持相中应须通达。即于障碍中心得解脱故。通达彼应知相已。昔加行中六波罗蜜之胜。得应须成就。依内心清净故。此内心清净所摄。六波罗蜜于十地中。应须三阿僧祇劫。分分令净故。次菩萨三学应须圆满。既圆满已彼果涅槃。及阿耨多罗三藐三菩提应须正觉故。十处作如是次第说。于此说中。一切大乘皆得究竟

释曰。何故作如此次第说者。谓始从诸菩萨。由于如是等诸法因中。乃至彼果涅槃正觉阿耨多罗三藐三菩提等。此说由知诸法因故。得于缘生善巧。由有因故果生。非自在天等。是故得因果二智。次于因所生法应知其相。其相云何。分别性无。执以为有。名为增益。增益于无即是损减。实有成就性离此二边过失。故名善巧。次于所取应以唯识观知其相。由此观故得无障碍。次于随顺入唯识。世间六波罗蜜。依世俗得已第一义者应须得。谓应修净心所摄波罗蜜。次于十地中。经三阿僧祇劫。分分应修。非如声闻胜得于三生中。起对治便得解脱。次即于彼修中。戒等三学应令圆满。次学果涅槃烦恼障灭。阿耨多罗三藐三菩提三身应得。若大乘次第应知齐此。何以故。若欲说缘生。即入阿梨耶识中。若说相即入三性中。若说胜得即是唯识。若说波罗蜜即入诸波罗蜜中。若说地即入地中。若说学即入学处。若说灭及智即摄在无住处涅槃。及三身。佛语如此。故作如是次第说。复有别义引生大菩提等者。谓能生无戏论无分别智故。成就者相应故。随顺者不违三量故。不相违者非先随顺后相违故。如偈说

  摄持求及悲　　亦随顺诸善
  非黑白我见　　有益亦有损

得一切智智者。谓于一切法中。无间一切种智生故。此成就等复有别义。成就随顺不相违等。前句为本。后句为释。云何成就。谓随顺故。云何随顺。谓不相违故。如是展转

    众名章第三

论曰。于中即此最初。应知依止。说名阿梨耶识。世尊于何处说此阿梨耶识。名阿梨耶识。世尊于阿毗达磨经偈中说

  界体无始时　　诸法共依止
  由此有诸趣　　及涅槃胜得

释曰。世尊于阿毗达磨阿含中说阿梨耶识名。阿梨耶识者。即是此论初所说阿毗达磨修多罗。此中界者是因义。诸法共依止者。由是因故一切法同共依止。谓依止此以为因体。有此一切法依止故。诸趣果报由此得生。于无量生中有力。于善说恶说法中能解其义。若复越次得于胜得。又为烦恼依止体。由此得有极重烦恼及牢固烦恼。此等四种果报中。胜者身有堪能。翻此者无堪能。应知一切者于生死中随何趣。非唯诸趣。亦有涅槃胜得。以有烦恼即有涅槃故。此阿含显应知依止是阿梨耶识。彼阿含复说

论曰。即彼经复说偈

  诸法所依住　　一切种子识
  故名梨耶识　　我为胜人说

释曰。此偈第二句释第一句。胜人者谓诸菩萨故

论曰。有此等阿含为证。然此识何因缘故。说名阿梨耶。一切有生染法依住为果。此识亦依彼法为因故。名阿梨耶识。又众生依住以为自我故。名阿梨耶识

释曰。此识名阿梨耶者。谓诸法依住故。依住者共转故。有生者谓有生起类。皆名有生故。染法者谓异于净法故。众生依住为自我者执取故

论曰。此阿梨耶识复说名阿陀那识。于中有阿含。如世尊解节经中说

  阿陀那识甚深细　　一切种子转如流
  婴儿凡夫我不说　　不令分别谓为我

释曰。复于解节阿含中。佛告广慧。六趣生死中。彼彼众生中。随彼彼众生类。若卵生若胎生若湿生若化生中。自身转生于出生时。彼时一切种子心。最初成熟。便得和合。粗大增长圆满。有二种取。所谓有依色根取故。相名分别世俗戏论等熏习取故。于色界中有二种取。无色界中无二种取。广慧。此识或说。名阿陀那。于身普遍持故。或说名阿梨耶于身隐藏普遍同衰利安否故。或说名心。以积聚增长色声香味触法故。广慧。依阿陀那识为住处转生六识身。所谓眼识耳识鼻识舌识身识意识于中有识。眼根及色为缘生眼识。即彼眼识共行。同时共境界。有分别意识生。若一一眼识生。随一一有分别意识。与眼识共行。同时共境界生随一时。一时若二若三若四若五识身转生。即彼一时。一时一分别意识。与五识身共行。同时共境界生。如大川流。若有一起浪缘至。则一浪生。若二若多起浪缘至。则多浪生。彼川自流无断无尽。复次如净镜面。若有一起像缘至。则一像生。若二若多起像缘至。则多像生。然此镜面不转成像。亦无损减。应知如是。如是阿陀那识。犹如大川。依此而住。若有随一起眼识缘至。则随有一眼识生。若乃至随有起五识身缘至。则随有五识身生如是广慧。菩萨住法住智。得心意识秘密善巧。如来一切种一切智。不说菩萨齐此名心意识秘密善巧。广慧。若菩萨于内于外。如实不见阿陀那阿陀那识。不见阿梨耶阿梨耶识。不见滋长。不见种种(此二谓心)。不见眼色眼识。不见耳声耳识。不见鼻香鼻识。不见舌味舌识。不见身触身识。广慧。若菩萨依法住智。住法住智。得心意识善巧。又复如此义者偈中显示。阿陀那识甚深细者难知故。一切种子转如流者。谓一切种子次第转生。犹如水流。念念相续转故。阿陀那者显别名故。不令分别谓为我者。一相转故。分别谓为我

论曰。何因缘故。说此识名阿陀那。摄持一切有色诸根故。及一切自身取依处故。于彼色根摄持不失。乃至命在故。又于相续受生时。取生令得自身故。是故名阿陀那

释曰。摄持一切有色诸根故者。谓此诸色根为彼识摄持故。乃至命在者。即以此句为释。何以故。以眼等诸色根阿梨耶识摄持故。不如死身住青瘀等相。若至死时彼识舍离故。即有此诸青瘀等相。是故定知。由彼摄持乃至寿限不坏故。一切身取依处故者。即以相续受生时。取生令得自身故等。解释以相续受生。识于彼相续生处摄取故。何以故。能摄持自身具足故。由阿梨耶识中具足自身熏习住故。即彼生时。名为转生。即彼生时。取名为转生取。由此取故取得自身。以是义故阿梨耶识说名阿陀那识

论曰。亦说名心。如世尊说心意识。于中意有二种。一次第缘与作依处者。由识次第灭。意识依此生故。第二染污意。与四烦恼常相应。谓身见我慢我爱无明。此意即是余识染污依止。余识由第一依止生。由第二染污。由了境义故。次第义故。念义故。意有二种

释曰。复说名心者。阿黎耶识即名为心。意及识二种有别义可见。当知此心亦有别义。为显示此故。于中次第缘与作依处故者。谓识若次第灭已。得为意识因。此是第一意。复有第二染污意。四种烦恼故。于中身见者即是我执。由此执故则有我慢。以取我自高。由此等于实无我中。起我渴名我爱。此等三种皆以无明为因。无明者无智故。余识由第一依止生。由第二染污者。若识次第灭已名为意。与当生识处所。为彼生依止故。第二染污意。为染污依止。何以故。由善心中亦有我故。由了境义故。次第义故。念义故。意有二种者。于中取境义故名为识。与处所义故名第一意。我相等染污义故名第二意

论曰。复次云何得知有染污意。此若不有独行无明。亦不有此为过失。五识相似亦不有此为过失。如五识身有同时依止故。得眼等名。不有此为过失。无想定灭尽定无有差别。此为过失。无想定染污意得名。灭尽定不尔。故有差别。又即此无想一生无有烦恼。此为过失。若彼天中无有我及慢等者。又一切时我执得行。谓善恶无记心若不如是。唯不善心中得相应。我执是烦恼故。不应与善无记心共行。是故若俱有而共行。则无此过。若相应现行。则有此过故。此中有偈

  若独行无明　　及相似五法
  二种定差别　　得名无是过
  无想天中生　　无我则有过
  我执随顺转　　一切处不有
  离染意不有　　二三即相违
  无此即亦无　　一切处我执
  心行实义时　　常与为障碍
  一切时共行　　名独行无明

释曰。此第二染污意以何道理得成立。此意若不有。则独行无明不成。何者是独行无明。未起对治时障真如智。痴此与五识不相应。于此处不为障碍故。若起对治处。则于彼为障。亦不在染污意识。若即是染污意识。则有过失。非染污意识者。以与余烦恼共行。独行名则不成。又若欲令即是烦恼染污意识者。则有常染污过失。云何施等心得成善。以常与彼相应故。若言有意与善相应生。即建立此为引生对治。能治染污意识此不成。若言有善心与染污意共生。此善心能引生对治。治灭余识。此灭则无过。复次与五识相似故。如眼识等五识。则有眼等五根。同时为依止。此意识亦应有同时依止。二定无差别者。若言有染污意。彼无想定中则有。灭心定中则无。可得差别。此二定中意识不行无差别故。得名者。由念自身故名为意。若无体此名何所依。若六识次第过已。此识名意不应道理。以其灭故。又无想天中生。一期应无我故。若言彼处无染污意者。于彼生中则应无我。诸圣人不应厌恶。既厌恶故。是故应知彼中生者。应定有我。我执随顺转者。以施等诸善皆与我相应故。此我执若离无明则不成。无明不离依止。此依止离染污意不可得故

论曰。此意染污故。是障碍无记。恒与四烦恼相应。如色无色界烦恼。是障碍无记。为色无色界奢摩他所藏。此意一切时染着。故心体第三离阿梨耶识不可得。是故成就阿梨耶识为心。由此为种子故。意及意识等转生。何缘故说名为心。种种诸法熏习种子聚集故

释曰。以见意及转识。以阿梨耶识为因生故。心体余处不可得。佛说识者。即是次第灭意所摄。由彼识灭已说为意故。复次由种种法熏习种子聚集故。得名心。于中种种者。诸法各各相故。熏习种子者。谓有功能为彼差别因故。聚集者。密合积聚一抟相故

论曰。复次何故声闻乘中。不说此心名阿梨耶识阿陀那识。微细尔焰所摄故。诸声闻人不为知一切尔焰故。于彼虽离此说。然得成就彼智令得解脱。是故不说。诸菩萨等为欲知一切尔焰。是故为说。由离此智不可得一切智智故

释曰。微细尔焰所摄故者。此亦微细。亦尔焰故。名微细尔焰。又入在微细尔焰中以难得知故。又诸声闻不为知一切尔焰故。修行唯作自利故。彼等粗烦恼障。唯以苦等智得灭故。菩萨为除自他烦恼障智障故修行。是故为说

论曰。然于声闻乘中。亦以别道理说阿梨耶识。如增一阿含中说。众生喜阿梨耶。乐阿梨耶。集阿梨耶。求阿梨耶。为灭阿梨耶说正法时。为听闻故应摄耳。为欲知故应作意。愿灭阿梨耶故受法顺法。如来出世故。此希有难得法世间显现。如来出生四种可赞。经中以如是别名阿梨耶识声闻乘中已显现

释曰。众生乐阿梨耶者。此句为本。后以现在过去未来三时为释。余三句如文次第。复有别义喜阿梨耶者谓现在世。乐阿梨耶者谓过去世。由前世乐阿梨耶。是故复集阿梨耶。由喜阿梨耶集阿梨耶故。复希求未来世阿梨耶。顺法者如说行故

论曰。摩诃僧祇阿含中。亦以别道理说此识。名为根本识。譬如树依根

释曰。根本识如树依根者。彼根本识为一切识因体故。譬如树根为枝茎等众物因。若无根枝茎等不可得故。若有阿梨耶识。为诸识根本亦尔

论曰。弥沙塞中亦以别道理说此识。名为穷生死聚。有处有时见色心断绝。阿梨耶识中种子无有断绝

释曰。亦以别道理。说为穷生死聚者。此识是穷生死聚体。何以故。有因缘故。有处者界也。谓无色界中色断故。有时者有住定时。如无想定等。阿梨耶识中种子不断者。色心熏习为因。后时色心还从此生

论曰。由此应知依止阿陀那识。心阿梨耶识根本识穷生死聚等名。此阿梨耶识已成大王之路

释曰。成大王路者宽大故

论曰。复有余师。执心意识义一名异。是义不然。由见意及识义故。彼心义亦须有异。复有余师执。世尊所说众生喜阿梨耶等诸句者。此中五取聚是阿梨耶。复有余师执与欲俱诸受是阿梨耶。复有余师执。身见是阿梨耶。此等诸师迷阿含及修得故。于阿梨耶识起如是等执。此声闻乘中成立道理。彼等所成立道理不相应。若人不迷阿梨耶体相。以彼所成立名阿梨耶识即为最胜。云何最胜若言五取聚是阿梨耶。于恶趣一向苦受处生。即起厌恶。彼众生一向不爱。言是着处。不当道理。以其常求舍离故。若言诸乐受与欲俱是阿梨耶者。第四禅已上无有此受。已得厌恶故。是诸众生以彼为着处。不当道理。若言身见是阿梨耶者。佛法内人信解无我。于彼即生厌恶。以彼为着处。不当道理。然阿梨耶识中内我犹在故。若于一向苦受处生。唯求离苦聚。阿梨耶识中。我爱所缚故未曾求离。又四禅已上生者。虽厌恶欲俱乐受。于阿梨耶识中。我爱系缚犹在。又佛法内人虽信解无我厌恶我见。然阿梨耶识中我爱系缚亦在。是故以彼所成立阿梨耶。成就阿梨耶识体。则为最胜。是为安立阿梨耶识别道理

释曰。于中不迷者。谓诸菩萨。恶趣者。谓饿鬼畜生地狱等恶趣。一向苦者。彼趣报体一向非爱故。彼处若有乐受生。即是津液果。彼处生者其报唯苦。诸乐受与欲俱是阿梨耶者。第四禅已上。无有此受。已得厌恶故。彼处众生者。谓四禅已上及即第四禅中故。彼处者。谓于彼得生故。内我犹在者。决定取此识以为内我故。求离苦聚者。愿舍苦受故。阿梨耶识中我爱系缚者。以阿梨耶识为自我。由此渴爱故成系缚

摄大乘论释论卷第一摄大乘论释论卷第二

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    应知依止胜相胜语第一之二

    相章第四

论曰。成立此识相云何可见。略说有二种。一成立自相。二成立因相。三成立果相。于中阿梨耶识为自相。一切染法熏习。已为彼生因。摄持种子相应故。于中因相者。是诸染法。此阿梨耶识如彼一切种子。一切时现起为因故。于中成立果相者。此阿梨耶识以彼诸染法。无始已来熏习。力得生故

释曰。以如是等别名。说阿梨耶识于此别说。未知其相故。说阿梨耶识自相因相果相等。于中自相者。一切染法熏习缘故。识有生彼功能胜异。显示识体有此功能故。摄持种子相应者。彼一切染法熏习已。即为彼法生因故。言摄持种子。彼熏习与彼胜能合故名相应。即此自相一切染法熏习已。为彼得生因摄持种子相应识。为诸染法熏习已得胜功能。能为彼生因。此是阿梨耶识因相。于中始从成立果相。乃至言无始来熏习力故得生者。为诸法熏习已。此识得生。摄持无始熏习故名果相

    熏习章第五

论曰。复次何者熏习。此熏习名复何所名。与彼法共生共灭。已能为彼法生因。此是所因义。譬如胡麻。以华熏之胡麻与华同生同灭。以胡麻中有彼华香生因故能生香。又如欲等行熏习。欲等与心同生同灭。已后为欲等生因。又如多闻。有多闻熏习思念所闻与心同生同灭。已为彼记录生因。由摄持熏习故。说名持法者。应知阿梨耶识有如此道理

释曰。彼法者即前染法。同生同灭已后为彼生因者。谓还与彼染法为因体

    不一不异章第六

论曰。复次阿梨耶识中彼染法种子为分分别住。为无差别。无别物体于识中住。亦非不异。然阿梨耶识如此而生。有胜功能能生彼法。说名一切种子识

释曰。阿梨耶识中。彼染法种子为分分别住。为无差别耶。若尔何失。此诸种子若有分分差别。阿梨耶识亦应有分分差别。又阿梨耶识刹那灭义不成。由分分差别故。又善恶法所熏习即成善恶种子体。然此是无记故。若无分分云何言多。此义不成。是故二俱有过。无别物体于识中住亦非不异。乃至名一切种子识者。于中言非别非不别者。为离如前所说过失故。如此而生者。谓如其种类而生。生彼有胜能者。生诸染法时。与胜能相应故。亦以生彼有胜能故。说名一切种子识。此中有譬。如麦种子于生芽有能。得为种子。若陈久若火损能生麦果功能便坏。麦相如本。功力坏故非复种子。阿梨耶识亦尔。有生一切法功能。由与功能相应故。说名一切种子识

    更互为因果章第七

论曰。复次阿梨耶识与诸染法同时互为因。云何可见。譬如然灯焰及炷生与烧同时为因。又如芦束更互相持同时不倒故。识与诸法亦尔更互为因应知。如成立阿梨耶识为染法因。染法为阿梨耶识因亦尔。余因缘不可得故

释曰。复次阿梨耶识与诸染法同时互为因。云何可见者。以譬喻显示。犹如然灯焰。与炷一刹那同时互为因。以依炷故焰得生。即炷为焰生因。即彼刹那焰能烧炷。即焰为炷烧因。此即显示俱有因义。由因现住。即见果生故。从如阿梨耶识为染法因。染法为阿梨耶识因亦尔。乃至余因缘不可得故者。此言显示阿梨耶识与诸染法更互为因。亦即显示因缘故

    因果别不别章第八

论曰。云何熏习。无异无种种。得为有异有种种诸法作因。譬如以缕种种结衣。当时无种种可见。若入染器已。则有无量种杂色相貌。于衣上显现。阿梨耶识亦尔。为种种熏习所薰。于熏时无种种异。若生果染器现前时则有无量种种法相貌显现

释曰。云何熏习无异。无种种得为有异有种种作因者。如此道理即以譬喻显示。如衣以缕多种结时。无种种相貌可见。若置染器已。则有种种相可见。阿梨耶识亦尔。譬如衣生果。如染器故名生果。染器置者缘所摄故。熏习时未有种种。至于果时则为无量相貌因体。诸法显现如衣已染

    缘生章第九

论曰。此缘生于大乘中微细最深。略说有二种缘生。一自体分。二爱非爱分。于中由阿梨耶识故诸法生起。此是自体分缘生。与种种自体分为缘故。复有十二支缘生。是爱非爱分。为善趣恶趣可爱不可爱种种身分缘故

释曰。此于大乘中微细最深者。于中凡夫智不能知故微细。阿罗汉等不能测故最深。于中略说有二种者。此是立门自体分爱非爱分以此二种缘生。名解释。由阿梨耶识故者。谓阿梨耶识为因故诸法得生。此名自体分。谓与种种类身分为因故若说无明等此是爱非爱分。何以故。由为种种爱非爱身分因故

论曰。若于阿梨耶识中迷第一缘生。或执自性为因。或执宿作为因。或执自在天变化为因。或执我为因。或执无因缘。复次若迷第二缘生执我作者受者。譬如众多生盲丈夫未曾见象。或复有人以象示之。有触象鼻者。有触牙者。有触耳者。有触尾者。有触脚者。有触脊者。有人问之象为何相。或复答言。犹如犁柄或言如杵。或言如箕。或言如木桶。或言如帚。或言如石山。作如此说。如是如是。不解二种缘生。无明生盲者。或执自性。或说宿作。或说自在变化。或说我作。或说无因。或执作者。或执受者。由不识阿梨耶识体相及因相果相故。如不识象体若略说阿梨耶识。即果报识一切种子识是其体相。由摄持三界中一切身一切趣故

释曰。或言宿作因者。由不许有现在士夫力因故。如是等生盲众生以譬喻显示。无明生盲者。谓十二支缘生中最初无明。由无明故名为生盲。不解阿梨耶识体相。因相果相故者。如前所立阿梨耶识体相说名体相。所立因相名因相。所立果相名果相。于此不解由无明力不解阿梨耶识自体分故。执自性等五因为诸法因。由不解第二爱非爱分故。执我为作者受者。于中因者。一切法熏习。于阿梨耶识中有故。果者。即是诸法所熏故。果报识一切种子是。其体相者。由得身成熟名果报故。一切法种子者。即是熏习已名种子故。一切趣者谓五趣故。一切身者。谓趣趣中同类不同类种种身故。已说阿梨耶识为一切法种子。欲明了。彼种子体故。以偈显示

论曰。此中有偈

  外内不明二　　世数第一义
  此一切种子　　当知有六种
  刹那及俱有　　与彼相随转
  决定及待缘　　亦引生自果
  坚无记可熏　　与能熏相合
  异此不可熏　　是为熏习相
  六识无相合　　三差别相违
  二念不俱有　　余生例应尔
  此外内种子　　有生及有引
  枯死由引因　　自体后边灭

释曰。以外内不明二等五偈显之。于中外者。谓谷子等。内谓阿梨耶识。不明者。外种子不可记义故。二者阿梨耶识有善有不善故。复有别义。以染污清净为二。世数者。外法但以世数说为种子。何以故。亦以阿梨耶识变异有故。第一义者唯阿梨耶识为彼诸法种子。此诸法种子有六种。刹那者。此二种子无间生灭故。若常则不得为种子。以一切时如本无差别故。俱有者。非过去非未来非别处。若此时种子有。即此时果生故。与彼相随转者。阿梨耶识随转乃至对治道生。外种子乃至根未坏及果熟。决定者。以种子决定故。非一切故。一切得生各自决定。若此种子还此物生。待缘者。非一切时一切生故。于何处何时得其生缘。即彼处彼时生故。亦引生自果者。自种子能引生自果故。如阿梨耶识还引生阿梨耶识。谷等引生谷等。如是等六种显种子生果义。此熏习相今当显示。坚者。由坚故可熏。不如风动风不能持熏习。由熏习不能随风转至一由旬故。若瞻波迦华所熏油。香风随转至百由旬外。无记者。谓无记气。如蒜不可熏以臭故。香亦如是不可熏故。若无记物则可熏。可熏者。若可熏物则受熏非不可熏。如金银石等并不可熏。若能摄持熏习者。乃可得熏。谓衣等所应熏物。与能熏相合者。若相合则可熏。非不相合故。相合者。谓无间共生故。若异不可熏者。异者。谓异阿梨耶识。非此异识能受熏。以离阿梨耶识余识不可熏故。以是阿梨耶识中具刹那等诸义。谓刹那灭故。与生起识俱有故。乃至对治道生所有生死中相随转故。由决定为善恶等因故。福非福不动行。待缘于善恶趣成熟故。以阿梨识与如是等。功能相应故得受熏。应须成立诸生起识不合道理。六识无相合者。诸识动转故。三差别相违者。一一识各各依止生。各各攀缘各各作意。复有别义。谓诸识各别相故。譬喻者。说前念得熏后念。为遮此义故

论云。二刹那不俱。无有二刹那并起义。若同生同灭熏习乃得住。若言虽不相合。然所生之识相类而生故。得相熏者。余生例应尔故。谓诸别相者。亦应得尔。如眼等诸根同以净色为相。应得相熏。应作此说。以眼根净色与耳净色其类同故。彼诸净色应更互相熏。虽净色是同处所。各别不言相熏者。识虽同类。何得相熏。如彼所说二种种子。谓外及内俱有生因及引因。于中外种子生因者。乃至果熟。内种子生因者。乃至命尽。外种子引因者。熟已未种。内种子引因者。死后尸骸。由引因故多时住。若此二种子唯有生因。既离彼因即应失灭。无有多时相续住义。若言刹那传传转故。前刹那为后刹那因者。则无有灭时。以有灭故。当知必有引因。此二种子引因者。譬如引弓为箭远至因

论曰。此内种子不类外种子。故复说偈

  外种无熏习　　内种则不然
  闻等无熏习　　果生非道理
  已作及未作　　失得相违过
  外种内为缘　　以内熏故生

复次其余生起识。于一切身及趣。为受用者应知

释曰。于中一切身及趣为受用者者。谓于彼中受用生故。由于受用中有故。名受用者。此义以中边差别阿含显示

论曰。如中边差别论说

  第一谓缘识　　第二受用识
  诸心法所扶　　了别此受用

释曰。此二识复有更互为因果。阿含谓阿毗达磨修多罗偈说

论曰。此二种识亦更互为缘。如阿毗达磨修多罗偈说

  诸法依识住　　识依法亦尔
  各各互为因　　亦恒互为果

释曰。各各互为因者。阿梨耶识于一切时为诸法生因。亦恒互为果者。若阿梨耶识为因则诸法为果。诸法为因则阿梨耶识为果

    四缘章第十

论曰。于第一缘生中诸法与识更互为因缘者。于第二缘生中复是何缘是增上缘。又此六识几缘所生。谓增上缘缘缘次第缘。如是等三种缘生。谓穷生死爱非爱趣受用等。具有四缘

释曰。此三缘生。穷生死爱非爱受用具有四缘等者。于第一缘生中。阿梨耶识与诸熏习法为因缘。第二缘生中。无明等是增上缘。由无明增上故。行得生如是等。复次六种识说名受用缘生者。具有三缘生。于中眼识增上缘者。谓眼。缘缘者。谓色。次第缘者。谓前灭识缘。次第生识。若前识不舍处。则后识不得生。耳等诸识类尔

    烦恼染章第十一

论曰。如是成立阿梨耶识别名及相。云何得知如此别名及相。唯说阿梨耶识不说生起识。若离所成立阿梨耶识。染净皆不得成。所谓烦恼染业染生染并不成。世出世净亦不成。云何烦恼染不成。以六识身中烦恼及随烦恼所熏习种子皆不得成。如眼识与欲等烦恼随烦恼共生共灭。即此眼识为彼熏成种子非余。即此眼识若灭已。余识间生熏习及熏习所依止皆不可得。以无有故眼识先灭余识间生。无有与欲俱生义。以过去故不得成。如已谢之业果报生不成就。又修与欲俱生眼识所有熏习不成。此熏习亦不在欲中。以欲依止于识故。又不坚住亦不在余识中。以诸识各别依止故。又不同生灭故。亦不在自体中。以自体无二识俱生灭故。是故欲等烦恼随烦恼。熏习眼识不得成。识熏习识亦不成。如眼识所余转识亦不成。如其相应知

释曰。如是已说阿梨耶识众名。及成立其相。今欲成立此二。于阿梨耶识中非余识故。以道理显示。如眼识与欲等烦恼共生共灭。即此眼识为彼熏成种子非余者。于中即此者。谓眼识。彼者。谓贪等成种子者。谓为因故。非余者。谓非耳识等故。余识所闻者。谓耳识等隔绝等。熏习者。谓贪等习气故。熏习依止者。谓眼识故与贪俱生者。谓与贪等同时生起。以过去故为因不成。如已谢之业。果报更生不得成就。此亦如是不可成就。复有毗婆沙师作此执。欲令过去为有。然彼过去者但有名。所目义不可得。何以故。若法是有云何过去。是故彼执果不成以无熏习故。又彼眼识与欲俱生。熏习不成者。谓即此与欲俱生。眼识自熏习尚不得成。以此眼识持熏习生欲等。云何可成。亦不在欲中者。谓眼识熏习在于欲中无有成义。何以故。以欲依止眼识故。又不坚住故。亦不在余识中者。谓耳识等由依止别异故。正以依止别异故。则不得有同生灭眼识自依眼。耳识自依耳。如是乃至意识自依止意。以各各别处。别识熏习别识不成。亦不在自体中者。谓眼识不得即熏彼眼识。无二眼识俱生故。既无二识同生。则无同生同灭。以如是道理故。眼识中欲等烦恼随烦恼熏习不成。乃至眼识熏习眼识亦不得成

论曰。复次从无想天以上。彼地退此间生。烦恼随烦恼所染。初识生时此无种子而生。以熏习及依止并已过去无有故

释曰。初者谓最先起识。无种子而生者。谓无因生故。熏习及依止者。谓心及烦恼习气

论曰。复次对治烦恼识生时。一切世间识皆灭。若无阿梨耶识。烦恼随烦恼种子。在对治识中不成自体。解脱不得与烦恼同生同灭。若于后时世间识生。离欲心。不有彼依止及习气久已谢灭。若离阿梨耶识应无种子而生。是故离阿梨耶识。烦恼随烦恼皆不成故

释曰。对治烦恼识生时。一切世间识皆灭者。谓六识皆灭故。烦恼随烦恼种子在对治识中不成者。谓以对治识为因。生世间识不成故。彼于后时者。谓于出世心后。依止及熏习者。谓依止即是识熏习。即是烦恼随烦恼所熏习等。无种子者。谓离阿梨耶无因而生。于中烦恼即是染污。以是义故。烦恼染不得成

    业染章第十二

论曰。云何业染不成。行缘识不成。此不有故。取缘有亦不成

释曰。今复显业染不成相。云何不成。行缘识不成。故福非福不动行生已谢灭。离阿梨耶识何处安置熏习。六识身不能摄持熏习。此义烦恼染污中已说。此不有故者。谓行缘识不成故。取缘有亦不成。何以故。有因缘故。诸行熏识由取力故。熏习成满变为有故。于中业即染名为业染。又由业故有染名业染。是故业染不成

    生染章第十三

论曰。云何生染不成。结生不成故。若于不静地。堕住中有。意以染污意识结生。此染污意识于中有中灭。识于母胎中与迦罗逻和合。若唯是意识和合受生。和合生已依止此识。于母胎中意识转生。即是于母胎中二意识同处并生。彼和合受生意识。不可成立。为意识一切时依止染污故。如意识所缘境此不可得故。设令此意识与赤白和合。为即此和合意识是一切种子。为依止此识生余识。为一切种子。若即彼和合识是一切种子者。即是阿梨耶识。汝自安置别名以为意识。若以依止生识为一切种子者。不以彼所依因体为一切种子者。无有道理以是义故得成就此和合识非意识。但是果报识。是一切种子故

释曰。离阿梨耶识。生染污不成。今当显示此义。结生不成者。谓得自身不成故。不静地者谓欲界。堕者谓命终。染污意识者。意识与烦恼俱故。受生者摄取自身故。彼染污意识攀缘生有故。中有即灭。和合者一相同成坏故。谓意识与赤白和合故。依止和合意识生余意识。二识俱有者。谓一时即有和合意识。及依此所生别意识。二识一时俱有故。又彼和合意识不可成立为意识。何以故。一切时染污为依止故。彼和合意识。以欲等烦恼染污意为依止。攀缘生有。是染污故。依止于此故名染污。为依止此已住胎识。不以染污为依止。以报体无记故。如意识所攀缘。此不可得故者。意识攀缘则可得所谓诸法。此和合识无有攀缘。是故不可成就。此为意识

论曰。复次结生已摄持色根。若异果报识无可得义。其余诸识各别依止。又不坚住故。然诸色根无识不成

释曰。结生已者。谓已得身故。若异者。谓舍阿梨耶识已。余六识各别处故。动转故如眼识唯定依止眼。如是耳等余识各自依止。耳等色根亦尔。若无阿梨耶识。此诸识各各摄持自依止根者。此等诸识动转故有时不在无摄持。眼等诸根即应烂坏

论曰。识与名色更互相依。如芦束相依住。此义不成故

释曰。今欲显示此不成义。如世尊说。识为名色缘。名色为识缘。于中识为名缘者。名谓六识身。即说名非色四聚。色者即是迦罗逻。名色所缘之识。若无阿梨耶识。何者是耶。由依止名色故。得刹那传传相续。转生不断

论曰。若离果报识所有众生识食不成。离此果报识六识中随一识。于三界所有众生中。食事不成故

释曰。此言显示识食不成义。世尊说四种食。一抟二触三意思四识。抟者变成为相。既变已能作摄持身利益事。触者境界相。如色等境界唯以见等。即能为身利益事。意思者忆念为相。但以忆念为身利益事。如渴者见水得不死故。识者摄持为相。由此摄持故身得住。若无此识即同死尸臭烂。是故应知识亦名食。由能作身利益事故。于中触食者六识身。意思者忆念心。既说识食故知更有别识。又如重睡无心及闷绝灭定等。六识身灭尔。更有何者持身得不烂坏。阿梨耶识若舍离时。身则烂坏故

论曰。若从此退已于上静地生。以染污不静意识结彼生。此不静染污心。于彼地中。若离阿梨耶识。种子不可得

释曰。前已说不静地结生不成。静地不成。今当显示此处。以染污识结彼生。若于静地亦以染污不静结彼生。染污者以彼地烦恼所染故。彼地烦恼者。谓着定味等。此染污即在不静地。此人于不静地死。既死已彼上地心云何现前。既不现前云何得结彼生。是故决定应有阿梨耶识。由有无始时彼地熏习心在。由此熏习彼心现前得结彼生故

论曰。设令生无色界。所有染污及善心。若离一切种子果报识。此染污及善心。应无种子及住处故

释曰。生无色界者。谓解脱色界。染污及善心者。谓乐三摩提味。无种子及无住处者。谓无因及无依止。更有别义。若无种子何因而生。若无住处云何得依止住。彼心为阿梨耶识摄持故。从自种子生。即依止此识。由有依止故得相续住

论曰。若即于彼界中出世心现前。所余世间心灭尽。便应灭离彼趣

释曰。即于彼中若出世心现前。唯除此出世心。其余皆是世间心。彼诸世间心皆不有故。便断彼趣。即是不由功用得无余涅槃。既无此理故。离阿梨耶识不成

论曰。若生非想非非想中。依无所有处。出世间心现前。即应舍离二趣。此出世识不依止非想非非想趣。亦不依止无所有处趣。依止涅槃处亦不成

释曰。若于非想非非想处生。有时依无所有处。出世心现前。以彼处心明利故。非想非非想处心钝故。于明利心处。修出世心现前。彼出世心依止。第一第二趣并不成。以此二地皆世间故。又别地生别地心现前依止二趣亦不成。由身有余故。若此心以涅槃为依止亦不成。以如是等三种依止既不成。若离阿梨耶识。此出世心住于何处

论曰。若人造善造恶于舍命时。若离阿梨耶识。或上或下次第身冷不得成。是故若离一切种子果报识。生染污亦不成

释曰。于中造善造恶。则有从上从下。身冷不同。以造善者上升。为恶者下坠。是故若不许有阿梨耶识为摄持者。云何得如此身即随冷。由阿梨耶识为摄持者故。或上或下次第放舍。随所舍处则为死尸故。得身冷

摄大乘论释论卷第二摄大乘论释论卷第三

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    应知依止胜相胜语第一之三

    世间净章第十四

论曰。云何世间净不成。如未离欲界欲。未得色界心。即以欲界善心修行。除欲界欲。此欲界修行心与色界心。不得俱生俱灭故无熏习。种子不成。无有色界心为过去。无量。生中余心隔故。彼静心种子不得成就。已无有故是故成就彼色界静心。由一切种子果报识。次第传来得为因缘。修行善心为增上缘。如是一切离欲地。如其相应知。如是世间净离一切种子果报识亦不成

释曰。如世间净不成。今当显示。如为离淫欲起修行时。修行欲界善心。于色界心无有熏习。以不同生同灭故。彼色界心即是无种子而生。以彼过去色界心无量生中余识所隔。已过去无有不成故。彼静心种子为因缘者。从阿梨耶识中自种子生故。彼方便善心非无功力。得为增上缘则为功力。但非因缘。由彼增上故。色界心得生。如是破色欲时亦尔故

    出世间净章第十五

论曰。云何出世净不成。如世尊说。从他闻音及自正思惟。由此二因正见得生。此他音声及正思惟。为熏耳识为熏意识。为熏耳意二识。于彼法中起正思时耳识不生。意识亦为余识别攀缘所间。若于正思惟相应心生时。彼意识久灭过去。闻所熏及熏习皆不得有。何处得种子。于后时生正思惟相应心。与正思惟相应者是世间心。与正见相应者是出世间心。无有共生共灭义故不。为彼所熏。既不被熏则为种子不成。是故出世间净。离一切种子果报识亦不成。彼中摄持闻熏习种不成故

释曰。如出世净不成今当显示。于他音声及正思惟者。谓正与声相应思惟。此意识为余识别攀缘所间者。谓与正见相应出世心隔绝故。若正思惟相应心生者。谓于后时正思惟。彼久灭过去者。谓前意识已谢灭经无量时闻所熏及熏习皆不得有。云何得以此为因生后正思惟相应意识彼中者。谓世间意识中。闻熏习者由闻他音声熏习意识中。若作是念彼摄持种子不成故。谓摄持出世净种子不成故。若有种子生义可成

论曰。复次此一切种子果报识既为染法因。云何复成彼对治出世心种子。又此出世心昔未曾有故无熏习。既无熏习从何种子而生。汝今应答。善清净法界所流津液闻熏习。为种子得生

释曰。此果报识既为障碍因体。即不成彼对治因体。又此出世心初未曾有者。谓昔来未生故。无熏习者由昔来未生彼出世心熏习。决定未有故。善清净法界所流津液闻熏习为种子得生者。为别异声闻故言善清净法界所流津液闻熏习。由善清净法界灭智障烦恼障故。名善清净法界。所流津液者即是所说法。谓修多罗等。于此法界所流津液修多罗。听闻故名法界所流津液闻。即此闻熏习故名法界所流津液闻熏习。又复闻即是熏习故。名闻熏习。彼闻熏习住阿梨耶识中为因。生起出世心

论曰。此闻熏习为是阿梨耶识自性。为非若是阿梨耶识自性。云何得成对治种子。若非彼识自性。此闻熏习种子依止云何可见。乃至佛菩提位所有闻熏随在何身中。与果报识同相而生。犹如水乳然非阿梨耶识。以成彼对治种子故

释曰。所有闻熏习。为是阿梨耶识自性为非。设尔何失。若是阿梨耶识自性。云何阿梨耶识还自成对治种子。若非彼识自性此闻熏习应别有依止。乃至佛菩提位。所有闻熏习者。即是善清净法界所流津液熏习力故。随在何身中者。随于何身中同体而生。然非彼自性。犹如水乳虽复一体而生。然此闻熏习非阿梨耶识。以对治阿梨耶识故

论曰。于中依下熏习成中熏习。依中熏习成上熏习。由闻思修数习故

释曰。于中下中上者。应知闻慧思慧修慧。一一各有三等。复有别义闻慧为下思慧为中修慧为上。闻思修数习者。于闻等中增上修行。以下品为因得中品。中品为因得上品故

论曰。彼闻熏习种子。随下中上应知皆是法身种子。是阿梨耶识对治故。非阿梨耶识所摄故。出世善清净法界所流津液故。虽是世间为出世心种子。体出世心未生时。为现起烦恼对治故。恶趣对治故。一切恶业朽坏对治故。能随顺得亲近诸佛菩萨故。虽是世间初修行菩萨所得。应知皆法身摄。声闻缘觉所得解脱身摄

释曰。现起烦恼对治者。谓欲等出生为除灭因故。由除灭烦恼故。对治恶趣应受后报恶道业。为彼朽坏因。举要言之。过去未来现在。一切恶业对治故。于未来世自身得亲近善友因故。初修行者。谓凡夫法身摄者为法身种子体故。解脱身摄者。谓为诸声闻解脱因体故。何以故。由声闻唯得解脱身。不得法身故

论曰。此非阿梨耶识。法身解脱身所摄。随下中上次第增。如是果报识渐减依止。即转依止。一切转已此一切种子果报识悉无。种子即一切皆灭。复次非阿梨耶识与阿梨耶识同处而生。犹如水乳。云何一切皆灭。如鹅饮水中乳。又如世间离欲不静地熏习灭。静地熏习增依止即转

释曰。如阿梨耶识。与非阿梨耶识同处而生。然阿梨耶识尽。非阿梨耶识。在如鹅饮水中乳。乳尽水在。以此显示。应知。又如世间离欲。于一阿梨耶识中。不静地烦恼熏习灭。静地善法熏习充满依止得转。出世熏习亦尔故应知

    顺道理章第十六

论曰。如入灭尽定说识不离身。此成立果报识不离身。以灭尽定不为对治此识故生。亦非出定时此识复生。此果报识断已非结余生不得更生

释曰。灭尽定说识不离身者。此为成就有阿梨耶识。由世尊说识不离身者。若离果报识余识不成。何以故。以灭尽定对治生起识故生。见此定寂静故。若复执言出定时识更生。由此意故名为识。不离身者。此义不成。何以故。以出定时识不更生。此果报识相续断已。若离托生时不得更生

论曰。若人执以意识故。说灭尽定有心者。彼人所执心不成。定义不成故。攀缘相不可得故。善根相应过故。不善无记不相应故。想受共行过故。则有触故。三摩提中此有力故。唯灭想是过故。思惟即与信等善根俱起过故。能依离所依不可得故。有譬喻故非一切行者亦不有故

释曰。若人执以意识故说灭尽定中有心。彼人所执不成心。以定义不成故。若欲令离如先所说自相阿梨耶识。于生起识中随一识灭尽定中有此心者。此义不成。何以故。定义不成故。未曾见心离于心法。如余心法未曾离心。若想受不灭不得灭名。则此定不复成定。若存有阿梨耶识则无此过。为寂静住故。对治彼怨。其余心及心法故灭定生。阿梨耶识不分明故。不对治此识故生。是故此定不得有余心。何以故。攀缘相不可得故。心及心法若相续不断。必有所缘相。灭定若有心亦应不离所缘相。此二俱不可得故。此定无有余心。若立有阿梨耶识则无此过。此识以摄持身得名故。复次若灭定中有余识生者。余识必有善等分。谓善不善无记。此心不得为善。若善应与善根相应此即相违故。亦非识自性是善以离善根相应。无得善义。故若定心是善。则不许义至与无贪等善根相应。此不可许即与一切处余善心不异故。亦不得为不善及无记。与不善无记不相应故。离欲界欲时。一切不善根已灭不成不善。亦非无记以此定是善故。又不可以此心为善。与想受共行过故。若离善根不得为善。但善必与善根相应。如与善根相应。必与想受相应无有别因故。所治现行复有能治此义不成。如欲等现行不得有不净观。复次定中若离阿梨耶识有余心者。则有触生过。今当以住余定为例。但有其余善根。相应定心生时必与触俱。谓因定生猗为相。若乐受触若不苦不乐受触。以此触为缘故。则有乐受及不苦不乐受生。何以故。此触于定中有力故以见此触于余定中生二受有力故于灭定中亦应尔。无别障碍因故。若尔触缘受则至此义不成。何以故。唯灭想是过患故。若言有触缘受。修行此定唯为灭想此不可许。以说受想俱灭故。又复不应有触。于余识中若有触。则有相应共有思惟。信等善根共生过故。经说若有识与触相应生。则有思惟俱生是故于定中思惟现行义得成。若有思惟现行则是起作善心。此必应与信等善根俱生。此义不可许。若欲离如前所说过失。及离阿含相违过失。故言拔去心法。无有心法。唯有心在为是。此亦不成。何以故。从所依中拔除能依不可得故。心是所依心法是能依。此能依所依心及心法。无始生死已来更互相依未曾相离。由此相引故。必应与无贪等善根相应。若汝言定及定方便。并与彼相违故。无贪等不生唯善生者。余处未曾见此道理。何以故。若法相应生。必有津液果相应生。是故彼义不成。复次更有不成。如世尊说。身行灭乃至言意行灭。于中身行者。谓出入息。语言行者谓觉观。意行者谓思惟及想等。如觉观灭则语不得生。如是意行灭则意不得生。若汝言如身行灭住于定中。身得不灭。如是意行虽灭。意犹得在。此义不然。何以故。有因缘故。更有别身行。为身得住因。如世尊说。由饮食命根及识等故。虽无出入息身亦得住。意则不尔。更无余意行所持故。于彼定中不得以意识为心住。如世尊说。识不离身此说果报识。何以故。由有种子故。后出定时生起识从此而生。此能依所依一切时如是而生。虽加功用不能令其相离。何以故。有譬喻故。此于世间中从生至终。更互不相离。一切时共生。无有能拔其能依。令离所依。譬如四大及四大所造。心法亦尔。无有道理令其相离留心独在。若言从所依。拔除能依不可得。但以想受是过患故。唯此二法不现行非余。此亦不成。何以故。非一切处行者。此中不有故。经说灭尽定中识不离身者。即是成就阿梨耶识是有。以世尊说识不离身故。若离果报识余识不成何以故。由灭尽定对治生起识生以是寂静故。若有执从定起已。识还从身生故。言不离者此亦不成。以出定时识无更生义。以彼报识若相续断已。离结后生无更生义。若复执离阿梨耶识以意识故。言灭尽定中有心者。彼心不得为善不善无记。并不成故。由此定善故不可为不善。亦不得为威仪工巧变化等无记。若言是果报无记即是阿梨耶识。以无第五无记故。若言此心是善。即应与无贪等善根相应。又此心在时染污意已灭。但住善中。此善心即有所依止。及有所缘三事和合。云何不生触。既生触云何不生受等。若尔则灭尽定义不成。于中心及心法不灭故。若汝执言善心势力引此定生。由方便善心势力故。此定虽善然不与无贪等善根相应。若和合有能得名和合。是故此定虽善于三和合无有能故。此不尔如津液果生故。以彼方便心是善。是故此定即与善根相应故

论曰。若复执色心次第生。为诸法种子。此破如前复有不成。于无色界及无想天退堕。从灭尽定起此义不成。阿罗汉最后心亦不得成。唯除次第缘义得成。如是若离一切种子果报识。染污清净皆不得成。是故如前所说相阿梨耶识成就是有

释曰。若执色心相续生诸法。前刹那色为后刹那色因得为种子。初刹那识生后刹那识亦尔。若从无色界退彼色久已断绝。云何得种子复生于色。若从无想天退。及从灭定起。此心久灭云何得为后心生因。若如是阿罗汉无有得无余涅槃。以色心因不尽故。此前刹那色于后刹那色。前刹那识于后刹那识。应知但得为次第缘。不得为因缘。是故成就阿梨耶识为有。若住生起识中转依义不得成。此义今以三偈显之

论曰。此中有偈

  菩萨善心中　　则离于五识
  无复有余识　　转依何心作
  对治为转依　　未灭故不成
  果因无差别　　于灭则有过
  无种子无体　　许此为转依
  彼无二无故　　转依则不成

释曰。菩萨善心中者谓善意识中。即是出世对治相应故。则离于五识者。谓离眼识等五识。无余识者。谓离染污意识及有流善识。为离有流善识故。说善心已复说无余识。转依何心作者。谓于阿梨耶识中一切染污种子无复种子。如此作故。若言对治生为转依者对治为转依。非灭不成故。烦恼灭故名为转依。非对治即是灭。何以故。对治但是灭因故。若尔则是果因无差别。彼灭即有过故。果者谓灭名为涅槃。因者谓对治名为道。彼对治与灭则成一体。又对治生时即是涅槃故。若汝以无种子无体许此为转依者。于生起识无种子及无体。如此为转依。彼无二无故。转依则不成故。于住出世定时。诸生起识并不有故。尔时无种子无及无体无。是故转依义不成。若有阿梨耶识诸生起识虽不在。彼种子在阿梨耶识中住则能作无种子及无体。由转依不成故。应知有阿梨耶识

    差别章第十七

论曰。复次此阿梨耶识差别云何。略说或三种或四种。应知于中三种者。由三种熏习差别故。一名言熏习差别。二我见熏习差别。三有分熏习差别。四种者一引生差别。二果报差别。三缘相差别。四相貌差别。于中引生差别者。谓新生熏习。若无此行缘识。取缘有不得成。果报差别者。以行有为缘于诸趣成熟。若无此则无种子。后有诸法生不得成。缘相差别者。此即是意所取我相。若无此则我取意念。所缘不得成

释曰。如此成就阿梨耶识已。今当显示此识品类差别。于此三种熏习差别中。名言熏习分者。所谓如眼名熏习在果报识中。为彼眼生因。后果报眼根生时。由此眼名言。说为因故生。耳等诸根一切名言差别亦如是。我见熏习差别者。由染污意中身见力故。取阿梨耶识为我。熏习生已则有此我彼他差别。有分熏习差别者。由善不善不动行力故。于诸趣中受生如此差别。此义如后应知相初广说。引生差别者。谓摄聚种类差别所有。新生熏习者。谓初起熏习时。若无此阿梨耶识引生差别则诸行生灭所熏习识。由取所摄持故生有现起。此有不成。能有后生故名此为有。此有即是善不善取之数习。果报有差别者由摄聚行有为缘。于诸趣中成熟。若无此阿梨耶引摄分。则无有因。于后有中诸法眼等色根生起不成。此即是报果故。缘相差别者即此阿梨耶识分与彼依止染污意我见为我取缘相。若无此缘相阿梨耶识与染污意意俱身见为因此我执所缘境不成。此即是津液果

论曰。于中相貌差别者。此识有共相有不共相。无受生种子相。有受生种子相。共相者是器世界种子故。不共相者是各别内入种子故。此共相是无受生种子。若对治起时不共相障碍灭故。共相者他分别所持。观行者于中见清净。如于一切物中种种乐欲种种见成故。此中有偈

  难灭及难知　　所谓共相结
  观行者心异　　于外大相中
  清净者不灭　　于中见清净
  诸佛见清净　　成严净佛刹

复有别偈

  随种种欲乐　　种种见得成
  观人于一物　　随种种欲乐
  种种见得成　　所取唯有识

此不共相。是有受生种子。此等若不有器世界及众生世界转生。差别不成

释曰。相貌差别者有多种。于中谓共相不共相。有受生种子相无受生种子相。此阿梨耶识为一切众生所共器世界因体。即是无受生种子。不共相阿梨耶识者。即是各各自身色等诸入因体。即是有受生种子。若离如是相类阿梨耶识。则一切众生所共受用因。器世界则不成。如是若离第二阿梨耶识众生世界不成。即如枯木无所觉知

论曰。复有粗恶相轻安相。粗恶相者是烦恼小烦恼种子。轻安相者是有流善法种子故。若无此于果报身中。有堪能无堪能差别不成故

释曰。粗恶相者谓身无堪能故。轻安相者谓身有堪能故

论曰。复有受用相不受用相。受用相者。谓果报已熟善不善种子故。不受用相者。谓言说熏习种子。无始时戏论生起种子故。若无此数数所作善恶业。得果受用此义不成。此新言说熏习出生亦不成

释曰。受用相者若离此阿梨耶识。数数所作善恶业得果而尽不得成。无受用相。谓言说熏习种子者。如言说熏习差别中说。无始时戏论生起。种子故者。谓无始已来俗数流布因故。若无此不受用相。阿梨耶识则无本新言说熏习。生起不成。何以故。于世间中。无有现在言说离本得成。若本不有今亦不有故

论曰。复有相似相。谓似幻焰梦翳等故。若无此相似相阿梨耶识。由虚妄分别种子故成颠倒相。此义不成

释曰。相似相者如幻事为因故。即得妄见象等相。如是如是由阿梨耶识相似相。虚妄分别种子故。有颠倒相。若无此彼颠倒相不成

论曰。复有具相不具相。具缚者是具相世间。离欲者损减相。有学声闻及诸菩萨一分拔离相。阿罗汉辟支佛如来烦恼障具拔离相。烦恼障智障具拔相者。如其所应。若无此次第灭烦恼义不成。何因缘故善恶法果报唯是无障无记。此果报是无障无记故。与善恶不相违。善恶更互相违。若果报是善恶。无有道理得灭烦恼。是故果报识唯是无障无记

释曰。无障无记者。于中无障者谓无染。由无染无记故名为无障无记。非如色界生以烦恼不善为无记。此果报若是善不善。则烦恼灭不得成。何以故。若是善更生善。若是不善更生不善。则生死无有尽义。生死者即是烦恼及有流善等。释应知依止竟

摄大乘论释论卷第三摄大乘论释论卷第四

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    应知胜相胜语第二之一

    相章第一

论曰。已说应知依止。应知相云何可见。此略说有三种。谓依他相分别相成就相。此中何者是依他相。阿梨耶识为种子虚妄分别所摄诸识。何者是诸识谓身识身者识。受者识应受识正受识。世识数识处识言说识。自他差别识善恶两道生死识。此中身识身者识受者识。应受识正受识世识数识处识言说识。此等从言说熏习种子生。自他差别识从我见熏习种子生。善恶两道生死识从有分熏习种子生。此等诸识摄一切界趣。及烦恼等依他相虚妄分别故。得显现。此等诸识虚妄分别所摄。唯是识量。无所有不实义显现依止。此是依他相

释曰。今释应知相中。依他相略说者。谓总要而说故。虚妄分别所摄者虚妄分别体性故。此中身识者谓眼等五界。身者识者谓染污意。受者识者谓意界。应受识者谓色等六外界。正受识者谓六识界。世识者谓生死相续不断。数识者谓算计。处识者谓器世界言说。识者谓见闻觉知四种言说。此等九识皆是应知依止。见闻等名言熏习差别为因。自他差别识者谓依止身差别。以我见熏习为因。善恶两道生死识者谓生死趣无量种。从有分熏习种子生。此等诸识者次前所说诸识。摄一切界趣烦恼者谓三界五趣及烦恼等。摄者彼识体性故。依他相者依他为体故。此中虚妄分别所摄者。是彼体性故。无所有不实义。显现依止者。是无所有不实义显现因故。此中无所有者无实体故。如我尘无有实义。于无所有中执取譬如我。即是无所有而有我相显现。此所依止名显现依止。依止者因义故即是依他相

论曰。此中何者是分别相。于唯是识量无有义中。有义显现故

释曰。分别相中言无有义者。譬如实无有我。此唯有识量者。于无有义中而显现故。譬如我唯相似显现故。为义显现者为所取相显现。譬如无我而我相显现故

论曰。此中何者是成就相。即此依他相中。彼义相毕竟无所有故

释曰。成就相者此无所有不实义。显现因中彼不实义显现无所有故。如我相似相实无所有。然无我是有

论曰。此中身识身者识受者识。应知是眼等六内界。应受识者应知是色等六外界。正受识者应知是眼等六识界。其余识即是此等诸识差别。应知如是等识唯是识量以无义故。此中以何为譬。以梦等譬喻显示应知。譬如梦中离义独唯有识。种种色声香味触舍林地山等义相似相显现。此中实无有义。以如此譬应知一切处唯有识。以此为首。复有幻鹿渴翳等譬喻。应知犹如梦等觉时一切处唯有识。如梦唯是识者觉时何故不如是转。实智觉者亦如是转。如正梦时此觉不生。若梦觉已此智即生。如是未得真实智觉此智不生。若得真实智觉此智即生。若未有真实智觉云何于唯识得起比知。由阿含及道理。阿含者如十地经中世尊说。三界唯心故。又解节经中世尊说。时弥勒菩萨问世尊言。所有三昧境像云何与定心为可说异为不可说异。世尊言弥勒不异。何以故。定心所缘唯识所显。我说为识。世尊。若三昧境像不异定心。云何彼心还取彼心。弥勒。无有一法能取余法。然彼心即如是生亦如是显现。譬如因面见影言我见影。谓所见影异于自面。彼心亦尔如是生起。即于彼心。谓有别物可见。由此阿含及道理故得显现

释曰。此唯有识者。如十地经及解节经所说故。此攀缘唯识所显故。我说唯识者此所攀缘唯识所显。此有何义为显唯识离义故。由是识所摄故。佛言我说为识显彼三昧境界是识故。然如是生起者为彼相类而生故。于中取为别义者。于中谓于三昧境界中。取为别义者于彼识影谓有别物。为所取体故

论曰。如是于静心中。若见青等尔焰影像。即见自心无别青等义。由此道理菩萨于一切识中。应须比知唯是识量。又此青等非忆持识。以所见境界现前住故。于闻思中所有忆持识。攀缘过去但是彼影故成唯识。以此比量虽未得真如智觉于唯识中则得比知

释曰。此三昧境界。青等影像亦非忆持识何以故。以非如昔所见。即于彼方处如是念知故。以现前故。彼所有忆持识暗昧。此现前住者所见明净。若言于闻思中数习故。彼虽过去后思念时如昔而生。此亦如是者。彼闻思已过去。今则无有。于无有中若更生。此即是识似彼而生。非过去已灭闻思。是故此义于成唯识尘无所有即得成就

论曰。如前所说种种识。譬如梦等者此中眼识等识体唯识得成。眼根等识体是色。唯识道理复云何可见此等由阿含及道理已如前说。此等若是识体何故似色显现。一类坚住相续转也。颠倒等烦恼住持故。若异此于无义中义颠倒则不成。若无此烦恼障智障等染则不成。此若无此清净亦不成。是故眼等如是生起得成。此中有偈

  乱因及乱体　　所谓色识体
  及非色识体　　前无后亦无

释曰。眼识等识体非色故唯识得成。眼根等识体是色云何成唯识也。此等如前阿含及道理中已具显示。一类坚住相续转者。一类者相似故。坚住者多时住故。由烦恼障智障颠倒烦恼为因故。住持者即是因也。若离如是等生起。则无非义为义颠倒心。若无此烦恼障染智障染则不有。此义以偈显示。乱因及乱体者。谓色识体及非色识体。如其次第此中色识体为乱因。非色识为乱体。此因体色识若不有。彼果体非色识亦无

    差别章第二

论曰。何故身识身者识。受者识应受识正受识。于一切有身分共有和合生。显生分受用满足故。何故世识等诸识。如前所说种种识生。无始时生死流转不断故。无量众生界故。无量世界故。无量所作事更互言说故。无量摄取受用差别故。无量爱非爱业受用果报差别故。受无量生老死差别故。云何成立此等诸识令成唯识。略说有三相。唯量义无所有故。唯二谓有相及见识故。唯种种谓种种相生起故。此等诸识无有义故故名唯量。有相及见眼等诸识。以色等为相。以彼等识为见。乃至身识为见故。意识者以眼等一切识体乃至法识为相。以意识识为见。意识能分别故。又似一切识生起故。此中有偈

  唯量二种种　　观行人能入
  得入唯心时　　此心亦灭离

释曰。云何名具足身分受用。此身识身者识受者识等五识。应知一切有身者。一时有故。共有者一时生故。所显者因体故成立三种唯识义。如前长行及此偈显示。于长行中言唯量者。唯是识量故。一切所有诸识皆唯识量。何以故。由所识义无所有故。唯二者成立有相及见故。即此一识一分成相。第二分成见。此是眼等识二分故。成立种种者还即此一识。随所起一分种种相生。第二分为能取故。若意识所取。彼一切眼等识乃至法识为相。即此意识为见故。种种者唯意识为彼事。以不定故。其余诸识有定境界。又不分别故。是故若能分别则名为见。以如是道理得成唯识。偈言。入唯量者无有义故。入唯二者有相及见识故。入种种者由识种种相貌生故。观行人能入者。谓修行人相应故。何故得入唯心时。此心亦灭离也。由正入唯心时则义无所有。识亦不有。若无所取义。云何得有能取心也。唯二及种种者。但是说入唯量因缘。余义如前所说

论曰。一种诸师说。即此意识彼彼依止生。得彼彼名。如意思得身口业名。此意识于一切依止处。生种种相貌。似二而生唯似义故。似分别故。一切处亦似触而生。色界中意识依止身故。如余色根依止身故

释曰。有诸菩萨。欲令唯有一意识次第生起。今当显示。譬如意思得身口业名者。如意思于身门中生名身业。于口门中生名口业。意业亦尔。如是一意识若依止眼生则得眼识名。如是乃至依止身生得身识名。此中离意识外更无余识。唯除阿梨耶识。若汝言眼等根无分别。若意识依止彼生亦应无分别。如染污意依止染污故。生起亦染污。此亦应尔者。如论说于一切依止处。生种种相貌似二而生。唯似义故似分别故。是故无妨。于中一切依止处者。谓依止眼等处故。种种相貌似二而生者唯似义故似分别故。由此二句故可得了知。此二句所说即是一识一分似唯义而生。第二分于彼似义中。似分别而生。是故前说无过。又一切处亦似触而生。谓于有色处心在定中。五识不行于色身中有内受生。如余色根依止于身者。如眼等根依止于身。此诸根由依止身故即于自身能作损益。意识亦尔。依止身故令身损益。应知复有别义如身根依止于身。若有外缘来触。即于身根中似触而生。此似触生时即于自依止身中。为损为益。意识亦尔。依止身故似触生时。亦即于身为损为益

论曰。此中有偈

  远去及独行　　无身住空窟
  能伏难伏心　　我说为梵行

释曰。彼诸菩萨成就所说。故引诸阿含偈。言远去者攀缘一切境界故。独行者更无第二故。无身者离色身故。住空窟者隐在色身空窟中故。能伏者自在作用故。难调伏者鄙恶故

论曰。又如经说。此五根等所行境界。皆意能受用。彼等亦依止于意

释曰。复有阿含说。此等五根所行境界意能受用者。若根所行处名为境界。此意能分别一切法故。一一境界各各受用故名能受用。彼等亦依止于意者。为彼等诸根生时此为因体故。何以故。若意有别缘则眼等不生

论曰。又如经说十二入中。说六识身为意入

释曰。复有阿含说六识身说名为意。无别余识名故。佛说六识身名为意入。是故得知唯独有意

论曰。若有安立阿梨耶识识体为义。识体处彼中。成立所余一切识体为相。识体意识识体及所依止成立为见。应知彼等为相貌识体为彼见生因。似义显现。为彼见生依止事

释曰。亦成立阿梨耶识。为相见二识。意识及依止是阿梨耶识见分。眼等识体及一切法是相分。此等即是阿梨耶识体故。彼等为相貌识体者。谓眼等为识生因体。成彼所攀缘故。为彼见生因者于彼中起见名彼见。为彼所见义显现故。能为意识见相续住不断因故。名为能作见生依止事

论曰。如是等识体已成立为唯识。诸义既现前可见。云何得知非有。如世尊说菩萨具足四法。得随顺入一切识体无义。一知相违识相。如饿鬼畜生人天同于一切。识体见有差别。二知无境界。识生如攀缘过去未来及梦影等。三知离功用。应得无颠倒。如于实有义中攀缘义。识则应不成颠倒。由不藉功用。得真实智。四知随顺三慧故。如诸菩萨及得定者。得心自在故随其乐欲。彼义显现。如有得奢摩他观行者。修法观时唯以意念义即显现。又得无分别智者。住无分别时。一切义不显现。诸义由随顺三慧。及前因缘故。义无所有即得成就。此义中应说六偈。后于增上慧学胜相中说。谓饿鬼畜生人等

释曰。一知相违识相者。诸相违者识所缘义名为相于中知故。知无境界识生者。谓见无所攀缘而识得生。如过去等。知离功用应得无倒者。若如所显现义。即如是有者。则不须起对治无倒得成。如此解知故。随顺三智者。此智知诸义。皆随顺三智故。及得定者。谓声闻辟支佛等。得心自在者。谓已得随心所作故。随心乐欲彼义显现者。若欲令地界成水如念即成。火等亦如是故。得奢摩他者。谓已得三摩提故。修行法观者。于诸修多罗等中。观察修行故。唯以意念义则显现者。于一义中随种种作意则种种相显现故。已得无分别智者。若如所显现义是有则不得有无分别智。此智实有故。应知彼义决定非有

    分别章第三之初

论曰。若唯有识义显现。所依止名依他性者。云何依他何因缘说名依他。从自熏习种子生。是故依他依他为缘生已无功能。过一刹那自住故说名依他

释曰。若唯有识义显现所依止者。谓离义唯有识体为义。显现因即此识体是依他。若自所摄云何依他何因缘名依他。为自因所生生已无力住故。即此自摄说名为他故名依他

论曰。若分别性依止于他。实无所有而义显现者。云何成分别。何故说分别。无量相貌意识分别颠倒生因故成分别。无有自相唯见分别故名分别

释曰。依止于他者。谓依止依他性唯识故。无所有者无自体故。为义显现者有义可见故。何因缘说名分别者。如后次第说。于中无量相者。谓一切境界相故。意识分别者即意识是分别故。颠倒生因者意识妄倒生时攀缘因故。无有自相者无体故。唯见分别者唯见乱识故

论曰。若成就性分别性。毕竟无所有为相。云何成成就。何因缘说名成就。体无变异故得成就。清净境界故。一切善法中最胜等故。由是最胜义故说名成就

释曰。彼毕竟无所有为相者。以分别性无所有为性故。云何及何因缘等者。如前依他性说。体不变异者不虚诳故。如诚实臣。由是清净境界故一切善法中最胜。即此清净境界体最胜故名成就。如已成就衣

论曰。复次有能分别。有所分别。有分别性。于中何者能分别。何者所分别。何者分别性。意识为能分别。以是分别者。故此意识自名言熏习种子故。一切识体名言熏习种子故。是故有无量种分别生。一切处分别故。以是能分别故说名能分别。复次依他性是所分别。复次由此因缘故令依他性成所分别。此是分别性由此因缘故。令依他性似义显现者如义故。复次云何分别能分别。何所攀缘取何相貌。云何执着云何起言。云何流布云何增益。攀缘于名故取依他性为相故。执着于见故。因觉观起言故。见等四种流布为流布故。实无义中有义增益。如此分别

释曰。云何分别作分别者。意识名分别。依他性是所分别。由此因缘令成分别。为显示此故。论云攀缘于名如是等取。依他性为相者。即是取依他性中眼等名字为相故。何以故。取彼相已。而起分别故。见为执著者。谓于彼所取相。决定如是故。觉观起言者。如所执着以觉观为因出言语故。见等四种言说所言说者如所言说。见闻觉知等四种流布。共相流布实无有义。以为有义是增益者。如所流布实无有义。取为有义故

论曰。复次云何此等三性。为有异体为不异。应言非异非不异。此依他性别道理故成依他。别道理故。即此成分别。别道理故即此成成就。何等别道理。此成依他。依他熏习种子生故成依他。何别道理即此成分别。与分别为因缘相故。即此是分别故。何别道理即此成成就。如所分别毕竟不如是有故。何别道理于一识体为一切种种识体相貌也。阿梨耶识识体为彼余生起识。种种相貌。应知为彼缘相生起故

释曰。与分别为因缘相者。意识名能分别。为此能分别所取境界体而生故。即此是分别故者。即此意识分别彼相取为所分别境界体。以此义故依他性成分别性。如分别意识正分别。所分别时此分别毕竟无所有。由此义故依他性成成就性

论曰。依他性几种。略说有二种依他熏习种子故。依他染净性不成就故。由此二种依他故。名依他分别性亦二种。自性分别故。差别分别故。是名分别。成就性亦二种。本性成就故清净成就故。是名成就性

释曰。染净体不成就故名依他者。由此依他性为分别分成染。为无分别分成净。于此二分中一分不成就故。自性分别者如眼等有眼自性作此分别故。差别分别者如彼眼等自性有无常等差别。作此分别故。自性成就者。谓有垢真如。清净成就者。谓无垢真如

论曰。复有四种分别。谓自性分别差别分别。有觉分别。无觉分别。有觉者。谓善知言说众生。无觉者。谓不善知言说众生

释曰。善知言说者。谓有言说智。不善知言说者。如牛羊等虽有分别。然于名字无能故

论曰。复更有五种分别。一依名分别义自性。如此名有此义。二依义分别名自性。如此义有此名。三依名分别名自性。如不识义之名于中分别故。四依义分别义自性。如不识名之义于中分别故。五依名义分别名义。如此义如是体如是名。复次总摄一切分别有十种。一根本分别。所谓阿梨耶识。二所缘相分别。如色等识体。三似相分别。所谓共依止眼识等识体。四相变异分别。谓老等乐受等贪等。抂横及时节变异等。地狱趣等欲界等此诸变异。五似相变异分别。谓即前所说变异此中变异。六他授分别。谓闻非正法因缘。闻正法因缘分别。七不正分别。谓佛法外人闻非正法因缘。八正分别。谓佛法内人。闻正法因缘。九执着分别。谓不正思惟因缘身见为根本。与六十二见处相应分别。十散乱分别。谓诸菩萨十种分别

释曰。总摄一切分别有十种分别。为说此故于中根本分别者。为诸分别根本自体。亦分别即是阿梨耶识故。相分别者以相貌为相。分别即是色等识体故。似相分别者。于彼相种类中。若分别生于所分别中能分别故得此名。即是眼识等识体。及依止故。相变异分别者。谓彼缘相若变异。即此相变异体名为分别。老等者谓身衰朽四大变异。于中分别故名相变异分别。等者摄病及死等。乐受等。谓身有变异为相亦尔。等者摄苦及不苦不乐等。贪等亦如是。等者摄嗔痴等。枉横及时节变异等者。谓于如是身变异相中。若攀缘生分别故。抂横者。谓杀缚等。时变者。谓寒热等时节改变为相故。地狱等者等言谓摄畜生饿鬼等故。欲界等者等言即是摄色无色界等故。似相变异分别者似彼缘相眼识等所有变异。于此似相变异体起分别。即是如前所说老等中变异。何以故。以住彼老等时。眼识等亦变异生故。他授分别者。于他所说有二种。谓闻非正法因缘。闻正法因缘。此二种分别诸法由闻法生善不善。亦如是解释。不正分别者即是闻非正法为因。此法外者。谓诸出家外道。正分别者即是闻正法为因。此法内者。谓佛法内人。执着分别者不正思惟为因故。我见为依止六十二见等如修多罗说。与此见处相应分别故。散动分别者。谓诸菩萨十种分别

论曰。一无有相散动二有相散动三增益散动四损减散动五一执散动六异执散动七自性散动八差别散动九如名取义散动十如义取名散动。为对治此十种散动一切般若波罗蜜中说无分别智。此等障碍及对治。般若波罗蜜义中具足应知。经云菩萨云何行般若波罗蜜。舍利弗。此菩萨即于菩萨不见菩萨。不见菩萨名。不见般若波罗蜜不见修行不见色不见受想行识。何以故。色自性空非空故空。若色空即非色亦非异空故有色。色即是空空即是色。何以故。舍利弗。唯有名所谓色自性。不生不灭无染无净假立客名分别诸法。以此客名更相流布随所流布随起执着。菩萨于此名字一切不见。以不见故则无执着。如色乃至识亦尔。应知以此般若波罗蜜文句故。得通达此等十种分别义

释曰。于中无有相散动者。即缘此无有为相名为散动。为对治此散动故般若波罗蜜经中。说实有菩萨。言实有者显示菩萨实有空体。即空是体故名空体。有相散动者缘有为相名为散动。为对治此散动故彼经中说不见有菩萨。谓不见以分别依他为体由此意故。增益散动者为对治此故。彼经中说色自性空。为显分别性色空故。损减散动者为对治此故彼经中说不空。谓色法如不空故。一执散动者为对治此故经言此色空非色。何以故。若依他性与成就性是一者依他性亦应如成就性。为清净境界。异执散动者为对治此故。经言非色异空。何以故。若此二有异即法与法性亦应有异。此异不成如无常法与无常不可有异。约分别性故言色即是空空即是色。以分别性色无所有即是空。此空即是色无所有。非如依他与成就性。自性散动者为对治此故。经言舍利弗。惟有名所谓色。以色自性即是无所有故。差别散动者为对治此故。经言自性不生不灭无染无净。于中若生即有染。若灭即有净。由不生不灭故即无染无净。此等诸句其义如是。如名取义散动者。谓随名取义。即是散动为对治此故。经言假立种种名字。分别诸法种种者。谓随义取名即是散动。为对治此故。经言假立客名更相流布。谓非义自性有如是名。为对治此十种散动故。说般若波罗蜜经。由此说为因故无分别智生

论曰。若由别道理。依他性得成三性。此三性云何得不成一也。由别道理故成依他性。不由此成分别及成就。由别道理故成分别。不由此成依他及成就。由别道理故成成就。不由此成依他及分别

摄大乘论释论卷第四摄大乘论释论卷第五

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    应知胜相胜语第二之二

    分别章第三之余

论曰。复次云何得知依他性为分别性。相显现而住。然非分别性体也。于名前无智即体相违故。多名有多体此相违故。名不定杂体相违故。此中有偈

  于名前无智　　多名及不定
  同及多杂体　　成就此相违
  法无而可见　　无染而有净
  应知如幻事　　亦复似虚空

释曰。如依他性中虽分别一分可见。然不成彼性显示此故于名前无智。同体相违故者。若分别与依他是一体。则离名于义中智生。如瓶离瓶名。于瓶义中瓶智不生。若瓶名与瓶义是一相者。则应智自生。以不一相故。若言名义同体。即是相违。此中成立名是依他。义是分别。何以故。此依他由名力故成所分别又一义有多名。若名义是一相如名有众多。义亦应众多。若尔此义则应有多体。此一义有多体。即是相违。是故两性一体即是第二相违。又名不定如瞿名能目九义。若执名义是一。即诸义同体。此执是第三相违。以无量别相义皆成牛等一体故。偈中亦说此义。于偈中言成就者。明依他与分别不同体义。成就法无而可见等。此一偈为教诸弟子。幻等譬喻故。弟子有二种相违疑。难法无而可见。无染而有净。于此有疑于中如幻事者。如幻象实不有而可见。义亦如是。虽不有而亦可见。又如虚空云等。不能染污本性清净。然云等除时名为清净。诸法亦尔无有染污本性清净。然除客尘障垢时。名为清净应知

论曰。复次如所显现既不有。此依他性一切种悉无。何故不成。若无依他成就性亦无。一切无所有此义不成。若依他性及成就性俱无则无染污及清净过。现见染污及清净。是故非一切无。此中有偈

  若无依他性　　成就性亦无
  则亦恒不有　　染污及清净

释曰。依他性如所显现不如是有。今为显一切种悉无不成故。说此依他若不有成就亦不有。何以故。由有染故则有净。是故若二种俱无即一切悉无。此义不成今当显示谤无染净。此是过失。何以故。现见有染有净故。此依他成就二法现见是有。若执言无则是实有染净而谤言无

论曰。于佛世尊大乘方广经中。彼经中说云何应知分别性。若说无所有门应知。云何应知依他性。若说幻焰梦像影响水月化等譬喻应知。云何应知成就性。若说四种清净法应知。四种清净法者。一本性清净。所谓真如空实际无相第一义法界等。二离垢清净。谓即是离一切障垢。三至得道清净。谓一切菩提分法波罗蜜等。四道生境界清净。谓所说大乘正法此是清净因故。非分别性。最清净法界所流津液故非依他性。此等四法中摄得一切净法。此中有偈

  幻等说于生　　说无显分别
  四种清净法　　此说成就性
  清净有本性　　无垢道攀缘
  一切清净法　　此四种所摄

释曰。本性清净者是自体清净。此自体即是真如。一切众生皆有。以平等相故。由有此故说一切法为如来藏。离垢清净者。即此真如离烦恼障智障垢已。由此真如清净故得名为佛。至得道清净者。得彼之道亦是清净。即是菩提分。念处等波罗蜜故。道生境界清净者。是诸菩提分法胜得生缘。此生缘亦是清净故说道生境界清净。即是修多罗等十二部言教。此言教若是分别即成染污因。若是依他即成虚妄。最清净法界所流津液故非虚妄。由离此二性故得为成就。又此四种相于大乘中随说一种应知。即是说成就性。于中初二不变异成就故名成就。后二以不颠倒故名成就。于后偈中具明此义。幻等说于生者依他性说名为生。随于何处说一切法如幻。乃至如化等应知。此说依他性。说无显分别者若说无有色无所有乃至一切法无所有。应知此说分别性

论曰。复次何因缘故。如经所说。依他性譬幻事等。为除他人于依他性中虚妄疑故。又云何他人于依他性虚妄中生疑。他人作如是念。云何实无有义而成境界。为除此疑故说幻事譬。若实无有义。心及心法云何得生。为除此疑故说焰譬。若实无有义。云何爱非爱受用得成。为除此疑故说梦譬。若实无有义善不善业爱非爱果云何得生。为除此疑故说镜像譬。若实无有义种种识云何得生。为除此疑故说光影譬。若实无有义种种流布言说。云何得生。为除此疑故说向譬。若实无有义。取实三摩提中境界云何得成。为除此疑故说水月譬。若实无有义得自在菩萨以不颠倒心。为作众生利益事故生云何得成为除此疑故说变化譬

释曰。为显示依他性故。说幻等譬。于中虚妄疑者。于虚妄体中生疑故。于依他性中以幻等譬喻。显示如幻像实无有义而成境界。诸法亦尔。为除彼疑故作幻譬。若无义则无所攀缘。心及心法云何得生。为对治他人此疑故说焰譬。于中焰譬心及心法。水喻于义如焰动故。水义识生实无有水。如是心及心法亦尔。由动故实无有义而生于识。诸小凡夫又复有疑。若无有义。云何爱非爱受用得成。为除此疑故以梦譬。依他性如梦中。实无有义而爱非爱受用得成。此中亦尔受用得成。又复有疑若善不善业无义。云何爱不爱果义得成。为除此疑故以镜像譬喻。依他性如镜像。实无有义即于自面有像智生。实无有像义可得。此亦如是爱非爱果义实无所有。然亦可见应知。又复有疑若无有义。云何得有种种识生。为对治此故以光影譬。依他性如人弄影。随种种相貌则有多种影现。然无实影义可得。识亦如是实无种种义然有种种义可见。又复有疑若无有义云何无量种流布言说得生。为除此疑故以向譬。依他性如向实无有义而亦可闻。如是流布言说实无有义而亦可得。又复有疑若无有义云何得定者。心及心法得见于义。由经说得定心者如实知。如实见故。为对治此故说水月喻。如水月实无有义而亦可见。以水润滑澄清故。定心亦尔实无境界义而亦得见。三摩提如水体润滑故。又复有疑若无实众生。云何得如实智诸菩萨等。先以智慧观察为彼等众生。于诸趣受身。为对治此疑故。以变化譬喻依他性。如变化实无有义。随化者心一切事成。非无化事可见。如是虽无受身实义。然为一切众生故受身。此义可见应知。复次为何意故世尊说幻等八喻。今当显示于中说幻喻者。为对治眼等六内入。由眼等犹如幻像实无所有而亦可见应知。以此显示。焰譬喻者喻器世间以体宽大。是故如焰由动摇故。实无有水而见有水。为对治受用色等故说梦喻。如梦中色等实无所有。然以此为因爱憎等受用得成。以此显示。为对治身业故说镜像喻。由善不善身业为因缘故。有余色像生。为对治口业故说向譬。由口业为因故得口业果。犹如向以此显示。意业有三种。一欲界二静地三闻等。生于中为对治欲界意业故说光影譬。由意业果报犹如光影故。以此显示。为对治静地意业故。说水月譬。由静地意业果如水中月。实无所有然于静心中有种种果显现。为对治闻等意业故说变化譬。于中闻等者谓闻思熏习。显示此闻等意生如化

论曰。世尊依何义故于梵天问经中。说如来不见生死不见涅槃。于依他性中约分别性成就性故。生死涅槃体无差别义。彼中即此依他性。分别分成生死。成就分成涅槃

释曰。此等三性法相如修多罗所说随顺相应。今当显示。依何义故梵天问经中说。如来不见生死及涅槃。依生死涅槃无差别义故。依他性非是生死由成就分即是涅槃故。亦非涅槃由即彼分别分成生死故。是故不可偏说一分。世尊见依他中无偏一性。由此意故于彼经中。说不见生死不见涅槃

论曰。如世尊于阿毗达磨经中。说三种法。染污分清净分彼二分。依何义故作如此说。依他性中。分别性是染污分。成就性是清净分。即此依他性是彼二分。由此义故作如此说。此义以何譬显示。以金土藏为譬。如金土藏有三种可见。谓一地界二土三金于地界中。土非有而可见。金实有而不可见。若以火烧土则不现。金则显现。复次于地界中土相现时。是虚妄体现。金体现时是真实体现。是故地界有二分。如是如是此识性未为无分别智火所烧时。于识性中虚妄分别性显现。成就性不显现。此识性若为无分别智火所烧。于识性中实有成就性显现。虚妄分别性不显现。是故此虚妄分别识体。依他性有二分。如金藏土中所有地界

释曰。如是阿毗达磨修多罗中说。分别者染污性。成就者清净性。依他者彼二分体。由此义故说三种法谓染污分。清净分。彼二分以此金藏土譬喻显示。于中金藏者是金种子。地界者是坚性。土者是所造色。于土颜色中则有三种可得。彼地界中所有金。但土相显现。彼金体以后时可得故知。何以故。若以火烧金则得现。是故知金本来是有

论曰。世尊有处说一切法常或说无常。或说非常非无常。为何义故说常。于依他性中约成就性分故说常。约分别性分故说无常。约彼二分故说非常非无常。为此义故说如常无常不二。苦乐亦不二善不善亦不二。空非空不二我无我不二。寂静非寂静不二有自性无自性不二。生无生不二灭无灭不二。本寂非本寂不二。本性涅槃非本性涅槃不二。生死涅槃无二。如是等差别诸佛世尊一切密语。皆随顺三性如常无常门说。此中有偈

  如法无所有　　而现无量种
  非法非非法　　故说无二义
  依一分显示　　或有或非有
  依二分说言　　非有非非有
  如显现非有　　是故说为无
  由如是显现　　是故说为有
  自显无所有　　自体不住故
  如取既不有　　故成无自性
  由无性故成　　前为后依止
  无生灭寂静　　及本性涅槃

释曰。如法无所有而现无量种者。此上半偈如其次第即是非法非非法。何以故。以无所有故名非法。以非无显现法故名非非法。以非法非非法故。说即是无二义。一分者一边故。或有或非有者。或于有边或非有边。显示者说故。依二分说言非有非非有者由依他性具二体。取此义故说为非有非非有。如显现非有者如所见法彼是非有。以如是故说名为无。是故说为有者即以此义故说名为有。今当显示说无自性意。自不有者由一切法无有离因缘能自有者。此是一种无自性意。体不有者又是一种无自性意。若法灭已。彼体不复更生。是故无自性。自体不住故者。诸法即于生时无力能过一刹那住。此亦是无自性。此等无自性法与声闻共有。如取既不有者。此不与声闻共。如凡夫所取分别性不如是有故。此意名为大乘中无自性法。又即以此无自性故。无生等一切皆得成就。何以故。由无自性故无生。由无生故无灭。由无生无灭故本来寂静。由本来寂静故自性涅槃。前为后依止者即是前为后因故

    四意四合义章第四

论曰。复有四种意。四种合义。一切佛语应随顺入。一平等意。如言我于昔时名毗婆尸正遍知。二别时意。如言诵持多宝如来名。决定得阿耨多罗三藐三菩提。又如经说唯发愿得生极乐世界。三别义意如经说亲近恒伽河沙等诸佛。得解大乘法义。四随人心意。所谓或为此人赞叹布施。后复为此人毁訾布施。如布施戒及余修亦如是。是名四种意

释曰。如有人取同法故。言彼即是我。世尊亦尔。心在平等法身故。说我于彼时名毗婆尸等。非毗婆尸即是释迦牟尼佛。此中以平等为意故。别时意者。此意非唯称佛名决定得阿耨多罗三藐三菩提。如言以一金钱得千金钱。岂一日得耶。此意在别时得故。以彼一金钱得千金钱因故。如是如是。唯发愿得生极乐世界意亦如是。应知别义意中得解大乘法者。谓于三性道理自觉其相。若世尊意但以如文词为解义者。凡夫亦应正解。彼解义者。必由亲近无量诸佛方乃得故。此是佛意。随人心意者。或于此人赞叹布施。又于此人毁呰布施。如是意者随彼得成。若人悭吝于彼赞施。若此人于施已得胜欲。即于彼所毁呰布施。若无此意。于一施中或赞或毁。即是相违。由有此意故。若赞若毁皆悉相应。戒等亦尔。应知一分修者。谓世间修故。意与义异相者。若世尊心有所在而说者为意。由所说决定令入佛教中者名义

论曰。四种合义者。一令入义。所谓如于声闻乘中。若大乘中。依世谛道理。说人法二种自性及差别。二相义谓随所说法相中。皆以三性显示。三对治义。所谓说八万四千诸对治行门故

释曰。于中令入义者于人法二种。约世谛道理。或说自性或说差别。为令众生入佛法故。是名令入义。相义者。于中应以相义说其相。由说三性故。对治义者。谓说众生行对治。即是说诸众生烦恼对治。为安立众生对治烦恼处故

论曰。四翻义如别义语字。显示别义故。此中有偈

阿娑犁娑　罗末多耶　毗钵唎耶　斯柘素悉[肆-聿+頁](他弃)多者吉犁絁捺柘　素僧吉　利瑟吒　罗槃低菩提没答摩

释曰。于中阿娑犁者。显了义名不实。隐密义名不动。即是定以不动故名阿娑犁。娑罗末多耶者。翻名于定起尊重意。毗钵唎耶斯柘者。若显了义名颠倒。隐密义名翻倒。素悉[肆-聿+頁]多者。谓善住于翻倒中。善住故无常谓常。此为颠倒。翻彼无常谓常倒中善住故。吉犁絁捺柘者。若显了义名烦恼。隐密义名勤苦。素僧吉利瑟吒者。谓善染。是故经说于生死中久染勤苦。罗槃低菩提没答摩者。翻云当得胜菩提。此句可解

论曰。若欲解释大乘法。略说应以三种相解释。一解说缘生。二解说因缘所生法。三解说言教中义。于中解说缘生者如偈说

  言熏所生法　　此于彼亦尔

此显果报识及生起识更互为缘生故。彼因缘所生法者。生起识为相有相及见识体性。彼以住持相分别相法尔相。即此得显三性相。如偈说

  有相及有见　　是应知三相

复次云何解释彼相。谓分别相于依他相中无体。成就相于依他中是有。由此二故不有及有不可得。可得不见真实见真实此二同时。又于依他性中分别无所有。成就是有故。得彼不得此。不得彼得此。如偈说

  依他无分别　　唯成就是有
  不得及可得　　于中二平等

释曰。言熏所生法者。谓外分别熏习阿梨耶识。即于识中住。以此熏习为因生一切法。即是生起识自性。此于彼亦尔者。此分别熏习即以彼诸法为因。此显示阿梨耶识与生起识更互为因。又彼生起识性所有诸法。有相有见识体为性者。谓若识体有相及有见即是彼体。此诸法有三相所谓住持相者。即是依他相。由此等所说故。三性所有相即得显现。如是等义以偈义显现有相有见。是应知三相者此等三相如论本解释中显示。不有及有不可得可得不见真实见真实此二同时等者。以显示之。此中二者。谓分别及成就。于此二分一不有一是有故。说名有不有。若得分别则不得成就。由不见真实故。即于彼时不得分别而得成就。由见真实故。如是等义又以偈显示。偈中言平等者。谓一刹那故。于中者谓依他性中故。二者谓见真实不见真实故。故者有因缘故。由依他性中分别是无。成就是有故。彼诸凡夫颠倒取故见。诸圣人正见故见

论曰。解释言教中义者。如说初句为本以余句显示其分。或功德依止或义依止。功德依止者。如说佛功德。最清净觉无二法。行无相法为胜道。住于佛住得一切佛平等。至无障碍处不退转法。无碍境界不可思议成立。入三世平等。遍行一切世界身。一切法无碍智。一切行具足知。于法智无疑。无分别身一切菩萨所受智。到无二佛住。第一波罗蜜至究竟。无差别如来解脱智。入无边无中佛地平等法界。第一尽虚空界等。最清净觉为本。其余诸句是此句差别。应知如是等名为善解释。诸法体最清净觉者。此佛世尊最清净觉。应知摄余二十一佛功德。谓于应知中一向无障碍转功德。令入有无无二相。真如最清净功德。无功用佛事不休息佛住功德。法身为依止。心业无差别功德。修对治一切障功德。降伏一切外道功德。生在世间不为世法所碍功德。成立法功德。授记功德。一切世界中示现受用身化身功德。断疑功德。令入种种行功德。未来法生智功德。如所乐欲为显示功德。无量身为教化众生事功德。平等法身波罗蜜成就功德。佛刹无差别随所信乐显示功德。三种佛身无方所限分功德。穷生死际恒为利乐一切众生功德。无尽功德

释曰。显示其分者。如所应解释。今显示此义。或功德所摄或义所摄。于功德所摄中。最清净觉者此为初句。所余诸句显示其义。于中无二行者。二行不可得是名无二行。非如声闻辟支佛智。亦有障碍亦无障碍。有无无二相。第一清净者。谓清净真如。即是无相法。此真如非有相。由一切法无所有故。亦非无相。由有自体相故。此真如于无相法中为第一清净。入处故言令入功德。最胜故名为道。道者入处义。故名为道。无功用佛事不休息佛住功德者。谓于所有佛事常行不住故。修对治一切障功德者。以一切时恒修觉故。能对治一切障碍。生在世间不为世法所碍功德者。凡生在世间必行世境界。然虽生世间不为世间利等八法所染。成立法功德者。修多罗等诸法无量不可思议。以凡夫不能入故名最清净觉。即此最清净觉句一一句中皆相应。未来法生智功德者。谓于未来世法如是生。皆能知故。无量身为教化众生相应功德者。谓无量诸菩萨身。若作教化众生事。诸佛得自他平等智故。彼智即为佛智所摄故。即是佛教化事。平等法身波罗蜜成就功德者。谓法身无二故名平等。以此无二法身故名得最清净波罗蜜。至究竟无差别解脱智者。谓于如来无差别智中。解脱究竟故。此中解脱者。即是增上解故。三种佛身无方所限分功德者谓法身于若干方处。不能分限。如是受用身化身于诸世界亦尔。法界第一者。最清净法界第一故。名法界第一。尽虚空界者。佛智如虚空无尽故。是故名为最清净觉

论曰。复次义依止者如经说。菩萨具足三十二法者说名菩萨。于一切众生起利乐意故。令入一切智智故。知我何价故。舍憍慢故。牢固意故。非有所为作怜愍故。于亲非亲平等心故。究竟亲友乃至涅槃际故。应量而语故。微笑先言故。无限大悲故。荷负重担无退屈故。无疲惓意故。闻义无厌故。自所作罪能见其过故。于他罪失不嫌而诲故。一切威仪中修菩提心故。不求果报而行施故。不依止一切有趣生。而持戒故。于一切众生无碍行忍故。摄取一切善法而行精进故。舍离无色界而修禅故。方便相应智慧故。以四摄事为摄方便故。持戒破戒慈爱无二故。恭敬听闻正法故。恭敬住阿兰若处故。于世间杂事不乐着故。于下乘中无悕欲故。于大乘中见功德故。远离恶友故。亲近善友故。净修四梵行故。游戏五通故。随智行故。于住正行不住正行诸众生不弃舍故。一向语故重真实故。菩提心为首故。如是诸句皆初句差别应知。于一切众生中利乐意者。此利乐意句。有十六业差别应知。于中十六业者。谓展转起行业。不颠倒业。他不请作亦自行业。不动坏业。无所求业。此有三句不求返报故。于违顺众生无憎爱故。生生随逐故。即此类中身口业有二句。于苦于乐及非二中平等业。不卑劣业。不退转业。摄取方便业。厌恶障碍业。此有二句。无间思惟业。进胜业。此有七句正修行六波罗蜜。及修行四摄事修行成就方便业。此有六句亲近善丈夫故。听闻正法故。住阿兰若处故。远离恶觉故。正思惟功德有二种。共事功德有二种。成就业有三种。无量清净故。得大威德故。得胜功德故。安立彼业。此有四句。摄众功德故。决定教授故。法财二摄为一故。无染污心故。如是句皆句差别。应知如经偈说

  初句所摄故　　由功德句别
  初句所摄故　　由义别句别

释曰。义依止者。谓一切众生中利乐意。此句义有十六业。及余句显示。此中利乐意。作何等业。令入一切智智者。若令诸众生入一切智智。此是展转行。譬如一灯传然千灯。即是显示利乐意。如是等诸句皆与利乐意相应。自知我为何价者。自有利乐意。仍是颠倒。如有人意欲利乐而以饮酒与之。若如实自知称己分量教示众生。不以憍慢故自无所知。起心利益反成无利。舍憍慢者以舍憍慢心故。不待劝请自为说法。牢固意者。不以众生颠倒行故。牢固利乐心动坏。非有所为作怜愍意者。以不为利养作利益众生故。此利乐愍意云何可知。以顺行身口业故。于中应量而语及先言等是口业。微笑及无限大悲等是身业。此中应量语者谓唯作法语故。无限悲者愍三苦故。苦者苦苦故。乐者坏苦故。不苦不乐者行苦故。非二者不苦不乐故。不卑劣业者不自卑劣。云我不能成佛。如此等类。无厌惓意者。若不疲惓则能修佛道。闻义无厌者。若不多闻则无教化众生方便智。一切威仪中者。此句义如净行修多罗中说。进胜业者是利乐意。趣向增长因体故。修成就方便业有六句者。若人亲近此行即得成就。恭敬住阿兰若处者。由住彼处故能离恶。觉世间杂事者歌舞杂戏等。成就业者谓表彼成就相故。威德者谓六神通。随智慧行者。谓随智不随识自智慧生故。由此智慧正证相应。住诸法中安立彼业者。由有利乐意故。能以利乐安立众生。于中摄众者。于破戒者不舍安立亦不驱傧。令离不善令与善合。决定教授者。由一向与立教诫。不自说已后复言我前所说不善故。闻者授教。财法摄者由诚实告彼等言。以法及衣服等财利摄故。如言具摄。无染污心者由摄行菩提心作众生利益事。非为自求供养。但念云何以此善令众生正觉无上菩提。如此摄受故。偈中义亦尔释应知相竟

摄大乘论释论卷第五摄大乘论释论卷第六

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    入应知胜相胜语第三

论曰。如此已说应知相。入应知相云何可见。多闻所熏习依止。非阿梨耶所摄。如阿梨耶成种子。正思惟所摄似法似义所生。似所取物有见意言

释曰。如此等应知相如应得入。显示此故入应知相。多闻熏习为依止者。谓大乘法所熏身故。非阿梨耶所摄者。谓对治阿梨耶识故。如阿梨耶识成种子者。如阿梨耶识为染法因。此为净法因亦尔。故正思惟所摄者。谓正思惟自性故。似法似义所生者。谓为法义相而生故。似所取物者。谓如色等体故。有见者亦似见体故。即是成立相及见二识

论曰。于中何人能入应知相。大乘多闻熏习相续已故。得亲近无量出世诸佛故。一向信解善集善根故。善满足福智资粮诸菩萨

释曰。何人能入应知相者。如此相类中。若入所有方便。今当显示。大乘多闻所熏者。为离声闻乘等多闻故。得亲近无量出世诸佛者。过数量诸佛出世皆得现前亲近故。一向信解者。于大乘中决定信解。不为恶知识之所动坏故。即此次前所说三因缘中。善集善根故。名为善集福智资粮菩萨。复次福智资粮云何得次第满足。由因力善友力思惟力依持力故。于中前二句为二力。如其数应知彼正思惟力即是一向信解。此以大乘熏习为因。此一向信解即是修行正行。由修行正行故则得聚集善根。由此正思惟力故得善具足福智资粮。有此次第由此善具足福智资粮故。得入菩萨初地。此是依持力

论曰。于何处入即于彼有见似法及义意言。大乘法相所生中故

释曰。入如是相此入行相。今当显示。意地分别名意言。此意言种类以大乘法为因生故。大乘法相所生者。攀缘所说法故

论曰。信解行地中。见道中。修道中。究竟道中。一切法唯识随闻信解故。如理通达故。对治一切障故。无障碍故

释曰。何处得入于信解地中得入。由但闻一切法唯有识。即起增上信解名为得入故。于见道中得入。今当显示。如理通达者于意言分别中。如理通达故。云何如理通达。非法非义无能取无所取。若如此名通达意言分别故。于修道中得入。今当显示。对治一切障故者。观此意言非法非义无能取无所取时。能对治一切障。此名修道中得入。究竟道中得入。今当显示。无障碍故者。住最清净智处故。最微细障灭故。名究竟道中得入故

论曰。何缘得入善根力持故。三种练治心故。灭除四处故。法义为所缘故。奢摩他毗钵舍那常修正修无放逸等故。无量世界中无量人道众生。刹那刹那正觉阿耨多罗三藐三菩提。是为第一练治心

释曰。何缘得入。如所说善根力持等有八处相应。于中若常修者一切时作故。善修者恭敬作故。若作如此相类即是不放逸。于中对治三种退屈心故。有三种练治心。菩萨闻阿耨多罗三藐三菩提。第一甚深宽大难可证得心则退屈。为对治此故。有第一练治心云云。又云云故有第二练治心

论曰。由专心故能行施等诸波罗蜜。我已得此专心。由此故我修诸波罗蜜当得圆满。不足为难。是为第二练治心

释曰。由此意故施等波罗蜜即得现行者。于中意者谓信及欲。菩萨于波罗蜜中。信知实有故功德故。可得故。此是菩萨信。由信故喜乐修行名欲。菩萨得此信欲意故。修行六波罗蜜。进趣圆满不以为难

论曰。虽彼有碍善者善法具足已。即于死时随所念欲一切具足身。彼时得生。况我此最胜善无碍善。于彼时一切具足何为不得。是名第三练治心。此中有偈

  在于人道中　　无量诸众生
  念念得菩提　　故除退屈心
  善心人专意　　能行布施等
  胜人得此意　　亦能行施等
  善人于死时　　随心得果报
  既有灭位善　　果报云何无

释曰。复次菩萨于诸佛甚深宽大言教中。起推寻时作思念。阿耨多罗三藐三菩提难可证得。一刹那心断已乃得即生退屈。为对治此故修第三练治心。况我此最胜善者。况我于一切十地中。善具足福智资粮故。无障碍善者。谓心烦恼微细难破。如金刚三摩提能破此障。此三摩提后出离一切障碍。依止转已。于此云何不得。此显出离障碍。与死无异故。一切具足者。谓得一切种智故。善根力持故。三种练治心者。善根不薄少故。菩萨由有此力。则能三种练治心令不退屈。于中第二练治心如所练治今当显示。由此念故离诸障碍。悭等波罗蜜障无故。满足波罗蜜不以为难。由此满足故得成菩提。第三练治心。今当显示。于中有碍善者谓世间善故。名为有碍善。我此无碍善。此善不得成佛无有是处。此义以偈显示。偈言故除退屈心者。谓不令下劣心得住。云我不能得阿耨多罗三藐三菩提。善心者。谓非恶无记心故。由有无记施故。如有人散漫心行施。外道等以不善心行施。又复求阿耨多罗三藐三菩提者。此善最胜胜人得此意。亦能行施等者。于中得专心时。有如是相。能修施等六波罗蜜。谓得灭悭等障碍心。胜人者最上故。谓诸菩萨。施等者。谓摄取戒及智波罗蜜等。随心得果报者。乃至得非想非非想处果报故。灭善者灭障碍故。果报云何无者。谓得佛身故

论曰。远离声闻辟支佛思惟故。思惟则灭。于大乘中一切疑无疑故。邪意及疑则灭。于闻思法中离我我所执故。法执则灭。现前住安立一切相。思惟不分别故。则灭分别。此中有偈

  安立及自住　　所有现前相
  一切不分别　　智人得胜觉

释曰。此中论本为显四处灭故。于中灭思惟者谓灭声闻等思惟故。邪意及疑灭者。谓于大乘甚深宽大法中。邪意及疑应灭除故。邪意者诽嫌意及心动摇。惑者疑心故。一切疑无疑故者。于此大乘中为安立法相故。说有三性。所谓一切法无性无生无灭。本来静寂自性涅槃。如是等一切法无所有门。此就分别性故。若说幻焰梦光影像响水月变化。此就依他性故。若说真如实际无相第一义法界空等门。此依成就性故。于此诸法中一切邪意及惑不生故。于闻思法离我我所执故者。此中为显除灭法执故。灭除法执者。谓于法中若闻若思。乃至不令我我所得入故。现前住安立一切相思惟不分别故者。谓行者修无分别智时。在正思惟位。灭此等一切寂静心分别也。于现前住色等及静心所有安立骨锁等。于此一切所缘相中。不念不分别时。名入无分别方便。若分别则不得入。此现前安立偈者。为显最后灭义故

论曰。因何入云何入。闻熏习所生正思惟所摄故。似法及义。显现有见意言

释曰。此中显示以此入如此入故。于中闻熏习所生者。闻熏习为因故。即此入道理。如前所说即是大乘闻熏习所生。应知成就性所摄故

论曰。有四种求谓名义自性差别。假说相求

释曰。此中为显示如此入故。四种求者如论本说。谓名义自性差别等所说

论曰。复有四种如实知。谓名事自性差别。假相说中如实知。彼自性差别不可得故。菩萨如是如实为入意言唯识故修行。于彼似字义意言中。知彼名字。唯是意言。知彼名所依义。亦唯意言。即知彼名自性及差别唯是假相说。是时证得唯有意言。则于名及义自性差别假相说中。不见有性差别义相。故由四种求及四种如实知。于彼似名及义意言中。得入唯识

释曰。四如实知者。如论说名事自性差别假说中。如实知。其自性及差别故者。谓各有自性差别。作如是假说故。名自性差别假说者。义不可得故。即是知彼名自性及差别唯是假说者。以彼名字无有自性及差别故。即能于彼名字自性及差别唯是假说中。忍受故。若如是知是谓求。若知不可得名为如实知

论曰。此唯识观入何法。似何法入谓入唯量故。相及见为二故。种种相故。名义自性差别但假立。自性差别六种事无事故。为能取及所取体而住故。一时似种种相事生故。如闇中绳似蛇。譬如绳中蛇。是妄以不有故。若见实义则无有妄。蛇智则灭唯绳智在。若细分析绳亦不实。以色香味触相故。于中依止色等智故。绳智亦得。除灭如是如是。彼似字及义六种相意言。如蛇智以知彼六种相无实义。此唯识智亦须除灭。由成就性智故

释曰。此中问所入法及入譬。唯量者唯识量故。有相及见为二者。此显相及见二识故。此似相显现为因为住处为相为影显现故。唯是一识种种相生。非速疾故。次第而生。如此三种得入唯识。一时似种种相义生故者。谓似名句味身种种相义生故。彼亦似依名所目义种种相生故。于中入三性观以绳譬显示。六种义中自在者。谓于名等六种义中自在言。自在者谓除灭故

论曰。此菩萨如是入似义相意言故。得入分别性。入唯识故得入依他性。云何入成就性若灭离唯识想。彼闻法熏习所生意言。是时菩萨灭离义想。似一切义无有生处故。是故似唯识显现亦不得生。即住不分别一切义名中。正证法界相应而住。是时菩萨于能缘所缘平等平等无分别智生。即是菩萨入成就性

释曰。入似义相意言故者。谓所有义唯是分别故。如是即入分别性。入唯识故者。此之意言唯识所摄。得入依他性。似一切义无有生处者。谓无有似义生种类故。唯识种类亦不得生。何以故。若起唯识分别时则成义故。次后得证真如。此如不可言说。唯内自知故。是时菩萨能取所取平等。平等无分别智生者。谓能缘智所缘真如二法其体平等。犹如虚空。谓无有能取所取体而住。以不分别能取所取故。名无分别即是得入成就性。所言住无分别一切义名中者。谓有何名有几种。此名差别以偈中显示

论曰。此中有偈

  法人及法义　　若广若略性
  不净净究竟　　是名境差别

释曰。于中法名者。谓色受及眼如是等。人名者谓佛法爱。及信行法行如是等。复有法名者谓修多罗等。义名者谓依法所显义。总名者如言众生。别名者即彼众生各各有名。性名者谓字本。不净名者谓凡夫等。净名者谓学人。至究竟名者谓所缘通相法。又略说十种名字。是菩萨攀缘。所谓法名者眼等。人名者我等。复法名者十二部言教。义名者即彼十二部言教义。总名者一切法有为无为等。别名者色受等及虚空等。性名者阿字为初诃为最后。不净名者凡夫等。净名者见谛等。至究竟名者通相法为境。二智所缘。谓出世智及彼后得智缘一切法。真如故一切法种种相故。如于十地中一切义通相缘智所缘故。如是等诸名。是诸菩萨境界故

论曰。此菩萨如是入唯识故。得入应知相。由入应知相故。即得入欢喜地。善通达法界得生如来家。得一切众生平等心。得一切菩萨平等心。得一切佛平等心。此即是菩萨得见道

释曰。得生如来家者。由佛种不断故。得一切众生平等心者。如自身欲入涅槃。于一切众生亦尔。由此心故名一切众生平等心。得一切菩萨平等心者。由同得深净心故。得一切佛平等心者。由住此位时得诸佛法身。得法身故即得一切佛平等心。复次一切众生平等心者。得自他平等故。如自身欲尽诸苦。于彼亦尔。一切菩萨平等心者。谓同诸菩萨得深净心作利益众生事。得一切佛平等心者。见诸佛法界与己无差别故

论曰。复次何故入唯识观。为缘通相法故。出世奢摩他毗钵舍那智故。彼后得种种相识智故。灭有因相阿梨耶识一切因相种子故。增长得触法。身种子故。转依止故。出生一切佛法故。为得一切智智故。入唯识观

释曰。奢摩他毗钵舍那智者。即奢摩他毗钵舍那名为智故。于中有因相。阿梨耶识一切因相种子灭者于中有相者。即是因缘。谓阿梨耶识中所有一切染法种子。复言相者为显示即此种子。为所缘相故。如是说已。即得显示此诸种子因果俱灭

论曰。复次彼后得智。于阿梨耶识所生一切识性相中。由见如幻等故。自然不复颠倒。是故犹如幻师于幻事中。菩萨于诸相中设说因果。一切时亦得无倒

释曰。若无分别智灭障碍出生佛法者。此后得智复何所用。无分别智不能说彼因果法。何以故。无分别故。是故须后得智。说彼因果法。一切时不颠倒。如幻师于所幻事。阿梨耶识一切所生者。此等皆以阿梨耶识为因。一切识性相中者。谓以识性为因故。如所幻事。后得智于中不颠倒说亦不倒

论曰。于此入唯识观中。有四种三摩提。为四种通达分依止。云何可见。由四种求义故。下品无尘忍得明三摩提。为暖行通达分所依止。若增上忍增明三摩提。为顶行通达分所依止。由四种如实知故。得入唯识决定尘无所有。此入真实义一分三摩提。是顺谛忍所依止。此三摩提最后唯识想除。是无间三摩提世第一法所依止。应如是见此诸三摩提。是正位边应知

释曰。一切处入真实时得通达分。今此中亦显示通达分善根依止者。是通达分因故言依止。下品无尘忍得明三摩提者。谓于无尘中薄少乐欲。显示无尘智名明。得明三摩提者。显示无尘智所依止三摩提故。增上无尘忍者。此中忍还是彼欲故。明增三摩提者。显示增上无尘智名明。言三摩提者。显示是无尘智所依止故。顺谛忍所依止者。法无我名谛。于彼无我随顺忍故。此顺谛忍云何成。以决定无别外物故。能取亦不有。应知住疾利随顺忍时。得此乐欲正位边者谓正位时

论曰。如是入地菩萨。入唯识故得见道。云何发起修道。随所成立说十地。一切修多罗摄取现住事通相法为缘。出世间及后得奢摩他毗钵舍那智。无量百千俱胝那由他劫数习故。为转依止得三种佛身故修行

释曰。随所成立说者。谓若为成立故说。十地经中诸地故。通相法为缘者。谓一相缘非句别缘故。出世者无分别智故。彼后得者谓成立智。此亦不可说为世间。何以故。非世间积习故。亦非一向出世间。以随顺世间行故。是不可定说一相故。为转依止者。由此通相攀缘智故。得转依故。为得三种佛身者。谓令我当得三种佛身故修行

论曰。声闻入正位。菩萨入正位。此二有何差别。声闻正位有十种差别。与菩萨正位异应知。一所缘差别。大乘法为缘故。二住持差别。大福智资粮住持故。三通达差别。通达人法无我故。四涅槃差别。摄取无住着涅槃故。五地差别。依十地出离故。六清净差别。烦恼断及佛净刹故。七得一切众生与自身平等心差别。起成熟众生行不休息故。八生差别。生如来家故。九化现差别。佛集轮中一切时化现所摄故。十果差别。十力无畏不共佛法等无量功德果成就故

释曰。涅槃差别者。由菩萨摄取无住着涅槃故。声闻不尔。清净差别者。由菩萨灭烦恼及习。并净佛土故。声闻不尔

论曰。此中有偈

  推寻名及义　　各各互为客
  推寻二唯量　　二施设亦然
  从此生实知　　三分别无义
  若见彼非有　　即入三无性

释曰。如真实入。此中说偈。推寻名及义各各互为客者。名于义为客义于名亦为客各别相故。推寻者。谓应于静心中见故。推寻二唯量二施设亦然者。义无有自性及差别故。即应知自性唯是施设。差别唯是施设故。从此生实知者。谓于此中如实知故。由四种寻思为因故。得四种如实知。三分别无义中见者。于三种分别无有义中见故。谓名分别。自性分别。差别分别故。彼非有即入三无性者。义无所有故分别亦无。何以故。若所分别义是有。分别可得缘彼而生。由彼义不有故。分别亦不得有。应知此义故。入三者谓入三性。于中由见名义互为客故。得入名义各异分别性。若见名自性施设差别施设唯见分别。即得入依他性。即此能分别识亦不见。即得入成就性。此名三种入

论曰。复有教授偈。如观行差别论说

  菩萨静心中　　得见其心影
  灭除于义想　　但观于自想
  如是心住内　　知所取非有
  即无能取者　　故证无所有

释曰。为令得入观故。复说此教授偈。菩萨见心影者。见彼似法义影唯是自心。何人见谓菩萨。何处见谓静心中。灭除于义想。但观于自想者。谓于静心中义想不起。知唯是自心为法义相显现。如是心住内者。若心如是得住于义无所有中。即是心住于心中。知所取非有者。谓解知所取义无所有故。即无能取者。由所取义不有故。则能取心为能取者。亦不可得故。证无所得者。既无能取所取。已即说名为证真如。以真如不可得故

论曰。复有入正位别偈。如大乘经庄严论中所说

  菩萨具满无边际　　福德智惠之资粮
  法中思量善决已　　则了义类意言生
  彼知诸义唯意言　　即住似义唯心中
  如是正证法界已　　是故远离二种相
  以知心外无有他　　故得知心亦非有
  智者了知二俱无　　即住无二法界中
  智者无分别智力　　平等顺行常普遍
  所依稠密罪恶聚　　如大伽陀拔众毒
  牟尼善说诸正法　　安心有根法界中
  已知念行唯分别　　智者疾至德海岸

释曰。复有入正位偈。如线庄严论中说。若有最极难知者。彼中显示于中无边际者。谓极难度彼岸故。如言无边。言说非无有边。但以多故得名无边。此亦如是。何者为资粮。谓福德智慧。于中施等三波罗蜜是福德资粮。般若波罗蜜名智慧资粮。精进波罗蜜若为智慧精进是智慧资粮。若为福精进是福资粮。如是禅波罗蜜亦二种。于中若缘四无量禅名福资粮。余名智资粮。谁有此资粮。谓菩萨法中思量善决故者。由依三摩提后力故。思量诸法得善决定非余。则了义类意言生者。谓了知诸义皆以意言为因故。即住似义唯心中者。由知彼诸义唯意言故。即此自心似义而现故。如是正证法界已。是故远离二种相者。知自心似义而现已。即于离能取所取真如中得证。又复如所入证。今当显示以知心外无有他故。得知心亦非有者。谓离心外无有所攀缘义。彼不有故。能缘之心则亦不有。菩萨知彼二不有故。即住无二法界。谓离心及义故。无分别智力者。离分别智力故。平等顺行者。于平等中顺行故。见修多罗等一切诸法平等。犹如虚空故。普遍者。于若内若外诸法中。如是见故。常者一切时故。所依稠密罪恶聚者。此诸染法因名稠密。以难可观解故。罪恶聚者。即是染法熏习自性为体故。牟尼善说诸正法安心有根法界中者。谓以意安住有根心中。若攀缘彼心真如。此是有根心。谓缘如来正说。具足无阙总为一相应知此即是无分别智。已知念行唯分别者。住此有根心已。为欲正说故。于彼后得智中所忆念义。亦知此忆念行唯是分别故。由此无分别智及后得二种智故。诸菩萨疾至佛果彼岸。此等诸偈总集义者。初偈明资粮道。第二偈义明方便道。第三偈义明后见道。第四偈义明修道。第五偈义明究竟道。此释入应知相竟

摄大乘论释论卷第六摄大乘论释论卷第七

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    入因果胜相胜语第四

    因果位章第一

论曰。如是已说入应知相。说彼因果云何可见。由布施持戒忍辱精进禅定智慧等六波罗蜜。云何由六波罗蜜得入唯识。复云何六波罗蜜得成彼入果。此菩萨不着福报。不破禁戒。于苦不动。修道无懈。此等诸障碍因不行故。心得专一。即能如理简择诸法故。得入唯识。菩萨依六波罗蜜入唯识已。次第清净深心所摄六波罗蜜。是故于中虽离六波罗蜜现起方便。由信解正说故。起爱味随喜庆悦意。一切时无间相应熏修。六波罗蜜便得圆满

释曰。若入唯识已。于清净深心六波罗蜜。即得现行相应。与此现行相应故名现行相应。信解正说者。谓与六波罗蜜相应言说。于此甚深正说中起信解故。起爱味意者。于诸波罗蜜中见其功德爱味故。起愿得意者。由佛得到此净心第一彼岸故。我及一切众生亦应当得故生愿得心。此摄诸波罗蜜。清净深心有何相故。次以偈文。显示此相

论曰。此中有偈

  圆满白净法　　及得利疾忍
  菩萨由自乘　　深大正说中
  觉知唯分别　　得无分别智
  乐欲信解净　　名为清净意
  前及此法流　　皆得见诸佛
  已知菩提近　　得之不为难

释曰。于中始从信行地。善集资粮故。圆满白净法。及得利疾忍者。忍有三品谓软中上。此中住最上忍故名疾利。此心由所缘故得清净。今当显示。所谓大乘由说甚深宽大故。即是菩萨自乘。于中甚深者谓法无我。宽大者。谓虚空器等三摩提。如所思惟净。今当显示。由知一切法唯是分别故。净心体相今当显示。欲及解此二净故名净心。于中欲者。已得胜悕望故。解者信故。净心相今当显示。前者在净心前故。及此者。即此净心中故。得见诸佛此是其相。法流者。谓住定心时今当显示。此定心利益于住定时见菩提在近。以得此能得方便故。得之不足为难

论曰。此等诸偈。总显示净心有七种相。一资粮二忍三所缘四思惟五自体六胜相七利益。如偈中次第句句说应知

释曰。此等偈中显净心。有如是资粮如是忍如是攀缘如是思惟。如是体性如是表相如是利益。如偈显示。即是成立净心体

    成立六数章第二

论曰。何故唯有六波罗蜜。成立对治障碍故。一切佛法生起住处故。随顺成熟一切众生故。对治不发行因缘故。立施戒二波罗蜜。不发行因缘有二。谓着福报。及着室家。对治发行退转因缘故。立忍进二波罗蜜。退转因缘有二。谓于生死众生违背中生苦故。于长时修善分中疲倦故。对治发行不退中坏失因缘故。立定智二波罗蜜。坏失因缘有二。谓散乱及恶智故。对治此诸障碍故立六数

释曰。于坏失因缘中。恶智者颠倒取故。如诸外道以恶智故有所坏失。余成立散乱等障碍。对治义皆可知

论曰。前四波罗蜜为不散乱因缘故。一波罗蜜不散乱成就。由依止不散乱故。得如理正觉诸法实义故。一切佛法则得生起。如是一切佛法生起处故。成立六数

释曰。一切佛法住处者。一切佛法以此为因故成立。第二六数因缘波罗蜜唯六不增。由依止不散乱故。得如理正觉。诸法实义故者。由依止禅波罗蜜故。般若波罗蜜得如实觉了。诸义余诸句义可知

论曰。由施波罗蜜故摄受众生。由戒波罗蜜故不损害众生。由忍波罗蜜故能安受他损害。由精进波罗蜜故能作彼所应作事。由此等摄受因缘故。令所成熟众生得受调伏。彼等未得寂静心者。令得三摩提故。已得寂静心者。令得解脱故。于教化时即得成熟如是成熟众生住处故。成立六数。应如是知

释曰。第三成立六数因缘中。一切众生教化随顺者。一切众生中作教化成熟事。随顺相应。由此得成故。唯有六为成立。令出离故。于心未寂静者。以禅波罗蜜令得寂静心。已寂静者。以般若波罗蜜令得解脱故得成熟。于教化时者。谓教诫教授时

    相章第三

论曰。此六波罗蜜相云何可见。有六种最胜故。一依止最胜。菩提心为依止故。二事最胜。具足修行故。三所为最胜。为欲利益一切众生故。四方便善巧最胜。无分别智所摄故。五回向最胜。回向阿耨多罗三藐三菩提故。六清净最胜。烦恼障智障等灭平等出生故

释曰。此布施等以何相故。得波罗蜜名。由世间及声闻等亦有布施等。是故须说其相。波罗蜜相有六种依止最胜者。由一切处一切时依止菩提心故。事最胜者。无有一人于若内若外物具足现行。唯菩萨能具足现行者。谓行布施故。所为最胜者。凡所布施唯为利益安乐一切众生故。方便善巧最胜者。谓三轮清净名善巧方便。由无施物及施者受者等分别故。如是无分别智所摄故。得布施等名。回向最胜者。由此布施等回向无上菩提故。清净最胜者。若至佛果施等此时得清净。彼时离烦恼障智障得具足出生故

论曰。云何是施即波罗蜜。波罗蜜即是施耶。自有施非波罗蜜。应作四句。如施余波罗蜜作四句亦尔。如所应知

释曰。云何是施即是波罗蜜。波罗蜜即是施耶者。此是问分也。答中有布施非波罗蜜。谓远离六种最胜故。有波罗蜜非布施者。谓戒等波罗蜜。为六种最胜所摄故。有施即波罗蜜者。谓施是六种最胜所摄故。有非施非波罗蜜者。谓离六种最胜行。持戒等如是。一切波罗蜜中四句皆尔应知

    次第章第四

论曰。此诸波罗蜜何故如此次第说。前波罗蜜生后波罗蜜。随顺故

    立名章第五

论曰。复次此诸波罗蜜得名云何可见。为出过一切世间声闻及辟支佛施等。善趣彼岸故名波罗蜜。能破散悭吝贫穷故名陀。得大果报及福德资粮故名那。是故名陀那。能灭破戒及恶趣故名尸。得善趣及定故名罗。是故名尸罗。能尽嗔忿及怨仇故名羼。得住自及他安隐故名提。是故名羼提。能舍离懈怠及诸恶不善法故名毗。得出生无量善法令增长故名唎耶。是故名毗唎耶。能舍散乱故名地耶。得引心住内故名那。是故名地耶那。能除遣一切见处恶智故名钵逻。得知真如法及种类法故名肾穰。是名钵逻肾穰

释曰。今显示其名。诸波罗蜜通名皆以到彼岸故。名波罗蜜度一切世间及声闻辟支佛等。施等彼岸故称波罗蜜。各各名者。因时破悭。何以故。由破悭故。则能无碍布施。果时除贫穷故名陀。于果时得大果报及福德资粮故名那。是为陀那。因时息恶戒果时灭恶趣故名尸。果时得善趣及得现前三摩提故名罗。是为尸罗。如是诸波罗蜜释名如其相应。得住自他安隐者。由自身不为嗔恚过失所恼故。又不生他苦故他亦安隐

    修习章第六

论曰。修诸波罗蜜云何应见。略说有五种修应知。一方便起行修。二信解修。三思惟修。四巧便修。五作所应作修。于中四修如前说。复次作所应作修者。诸佛至诸波罗蜜圆满位已。然以无功用心。不舍佛事修诸波罗蜜

释曰。于五种修中。方便起行修者。谓于方便中发起正行故。作所应作修者。诸佛住于法身无复功用。然不舍诸佛事。已离现行诸波罗蜜。但为摄化众生故。由此修故。得作所应作事

论曰。复次思惟修者。爱味随喜愿得思惟故。有六种深心所摄修。一宽深心。二牢固深心。三欢喜深心。四荷恩深心。五大志深心。六胜益深心。若菩萨齐尔所阿僧祇劫得正觉阿耨多罗三藐三菩提。于尔所时念念中舍一切身。及以满恒伽河沙等世界七宝。奉诸如来乃至坐道场已来。菩萨施心无有厌足。亦于尔所时念念中。三千大千世界满中炽火。于中行四威仪无有一切资生之具。一心现行持戒忍辱精进禅定智慧。乃至坐道场。此菩萨持戒忍辱精进禅定智慧心无有厌足。此是菩萨宽深心。复次若此菩萨乃至坐道场不舍此无厌足心。此名牢固深心。若此菩萨以六波罗蜜摄化众生时。生胜欢喜过于所摄化众生。是名菩萨欢喜深心。若此菩萨以六波罗蜜摄化时。见众生于我有胜恩。非我于众生有恩。是名菩萨荷恩深心。若此菩萨六波罗蜜聚集善根。回与众生令得可爱果报。是名菩萨大志深心。若此菩萨以如是六波罗蜜聚集善根。与一切众生共之回向阿耨多罗三藐三菩提。是名菩萨胜益深心。此等六种深心所摄名为爱味思惟。复次若此菩萨于余无量六种深心。修习相应菩萨所有善根而生随喜。此名菩萨六种深心所摄随喜思惟修。复次若此菩萨愿令一切众生皆得六种深心所摄六波罗蜜。亦愿自身乃至坐道场。常不离六种深心所摄修六波罗蜜。是名菩萨六种深心所摄愿得思惟修。若但闻此菩萨六种深心所摄思惟修。生一念净信即得出生无量福德。朽坏一切极恶业障。何况菩萨

释曰。于尔所时念念中者。假令三阿僧祇时量为一念。以如是念。亦经尔所时得菩提。于尔所时念念中舍自身等。其义论本中次第可解。亦如此次第乃至尔所时得菩提。于尔所时。或随行尸罗等亦尔。三千大千世界满中炽火无有一切资生具者。此言显示住处艰难及无供身之具。朽坏一切极恶业障者。此中朽坏者。由善乐欲故无力能与果报故。又对治趣恶道故是名朽坏。宽大心者。即是此中无厌足心。即此等心长时不舍即是牢固心。此中牢固者。谓长时故。余心义可解

    差别章第七

论曰。此诸波罗蜜差别云何可见。各有三种应知。谓法施。财施。无畏施。守护戒。摄善法戒。作利众生戒。受恶事忍。安苦忍。法思惟忍。被铠精进。发行精进。不怯弱不退转无厌足精进。安乐住定。出生定。作所应作定。无分别方便智。无分别智。无分别后得智

释曰。说诸波罗蜜差别者。显示其体故。于中何故有法施等三种。由法施故增益他人善根。由财施故增益他身。由无畏施故增益他心。以此因缘故。显示三种施。戒三种中守护戒者。是依止戒。余二戒依止此住故。由住守护戒故。摄善法戒得出生佛法及菩提故名依止。利众生戒依止住故。得成熟众生故名依止。忍三种中受恶事忍者。若他作恶事能忍受之。菩萨作众生利益事时。由此忍力故。于生死苦不能退转。安苦忍者。由有忍力故。于生死中病等。诸苦不能退转。法思惟忍者。由此忍故。思惟法时能忍受故。此忍即是前二忍依止处。于精进中有三种体。如世尊修多罗说。是势力。是精进。是堪能是牢固超越。是不舍重轭。此等五句即是解释精进三种体。于中被铠精进故得势力。以此为初。由发行精进故。得正精进于发行时不怯弱不动转。无厌足精进等。如其次第即是堪能牢固超越不舍重轭等。以此三句释之。由有人初求无上菩提有势力。于发行时有精进。但心下劣。为对治此故。须堪能若有堪能则心不退屈。下劣。即是退屈。若人虽心不下劣。然于生死苦中心则扰动则于佛果生退屈。为对治此故。须不动精进及牢固超越。是故说此牢固超越。由牢固超越故于苦不退。有人虽于苦不退。然于少生足。不能得无上菩提。是故说无厌足精进。于少不生足故。及即显示不舍重轭精进。由此义故说三种精进。于定中亦三。乐住者。由现见法安乐而住故。名乐住。出生者。由出生六神通故。作所应作者。由依止禅那故。作众生利益事故。名作所应作。由此等义故定立三种。般若中成立三体。其义可解

    摄章第八

论曰。此诸波罗蜜摄义云何可见。此等摄一切善法故。彼体相故。彼随顺故。彼津液故

释曰。此等摄义云何可见者问。此等波罗蜜摄诸善法云何可见。由应知所修善法为波罗蜜所摄。彼所修善法摄波罗蜜亦尔。此等摄一切善法者。此中一切善法即是菩提分法。彼体相故者。是般若体相。彼津液故者。彼六神通十力等诸余功德皆是此津液。彼随顺故者。谓信猗等与此相随顺故。应如此知

    对治章第九

论曰。此诸波罗蜜障碍云何可见。摄一切烦恼应知。彼体相故。彼因缘故。彼果故

释曰。如所显示诸波罗蜜摄一切善法。如彼所治摄一切染法。今当显示。于中彼体相故者。是彼欲等体相。彼因缘故者。谓悭等因缘。如不信邪见等故生悭。彼果故者如悭吝破戒嗔恚故为果

    功德章第十

论曰。此诸波罗蜜功德云何可见。菩萨于生死流转中摄取自在故。摄取大生故。摄取大伴助大眷属故。摄取大事业方便成就故。摄取无恼害少尘垢身故。摄取善知一切工巧等明处论故。此等果报无可讥嫌。乃至坐道场。作一切众生一切利益事现前功德

释曰。诸波罗蜜功德菩萨果报无可讥嫌。非如外果报有可讥嫌。以染污故。以无常故。波罗蜜果报则非无常。何以故。由说乃至坐道场故。又彼唯是自为不为于他故。说发起利益一切众生事。波罗蜜果即是一切波罗蜜果功德。并无讥嫌

    互显章第十一

论曰。此诸波罗蜜更互相显云何可见。世尊有处一切六波罗蜜。或以施名说。或以戒名说。或以忍名说。或以精进名说。或以定名说。或以智名说。此中有何意诸波罗蜜中。修一波罗蜜时。诸余波罗蜜皆来助成。依此意故。此中有摄持偈

  数相及次第　　名字修功德
  差别摄所治　　功德更互显

释曰。于三百偈。般若波罗蜜中说一波罗蜜。即说一切波罗蜜。此有何意。行一波罗蜜一切波罗蜜皆来助成。以此意故。于布施时得守摄身口。即是戒波罗蜜事。乃至知因果智是般若波罗蜜事。余波罗蜜助成义如其相应。释入因果竟

    摄大乘论释论修差别胜相胜语第五

    对治章第一

论曰。如是说应知相入因果已彼修差别云何可见。此修有菩萨十地。何者为十。谓欢喜地。离垢地。照明地。焰地。难胜地。现前地。远行地。不动地。善慧地。法云地。此等诸地成立为十。云何可见。对治十种障碍无明故。此等十种应知。法界亦有十种无明为障住。云何应知。十种法界。初地遍行义故。二地最胜义故。三地最上津液所流义故。四地无摄义故。五地体无差别义故。六地无染净义故。七地种种法无差别义故。八地不增减义故。九地相自在依止义故。及刹自在依止义故。智自在依止义故。十地业自在依止义故。陀罗尼门三摩提门自在依止义故。此中说偈

  遍行最胜义　　最上津液流
  如是无摄义　　及体无差别
  无染无净义　　无种种差别
  不增不减义　　四自在依止
  法界中无明　　十障非染污
  于十地为障　　对治说诸地

复次此无明于声闻非染污。于菩萨是染污应知

释曰。今显修差别。云何十种应知。法界谓遍满义乃至三摩提陀罗尼自在义。此十种应知。法界于地地中各一种应知。然无明力故不能知。为对治彼无明十障故有十地。何者为十。一凡夫性。二邪行于众生身等。三闇钝故于闻思修忘失。四微细烦恼现行与身见等共生下品故。意念所缘故。远去现行微细故。应知此为微细。五下乘般涅槃。六粗相行。七微细相行。八于无相作功用。九不作众生利益事。十于诸法不得自在。今当释遍行偈义。法界一切处遍行。何以故。一切法无有一法非无我者故。最胜义者。知此义于一切法中最胜。即是二地所流津液。最胜者。若知所有大乘正说。是最胜所流津液即得三地。于中无有我所取。如郁单越人无有我所。证法界时。即得如是无有我所。由此智故。即得四地。此即是体无差别。非如眼色等随诸众生体异各各差别。由此智得入五地。亦无染本性不染故。无染即是净。由此智故。得入六地。修多罗等种种义。虽复差别成立然无有异。由此智得入七地。烦恼灭时不减。净法长时不增。相自在依止。刹自在依止故。由此智得入八地。于相中得自在由随其所欲相即现前故。于刹自在如欲令刹变为金。即得成故名自在。于中智自在者。依止辩才智自在故。得入九地身等业自在依止故。陀罗尼三摩提门自在依止义故。得入十地。复次此无明于声闻非染污由不入是诸地故。若入初地时即通达一切地者。何故复次第安立诸地。为释此难故。随所行行彼行。所入成立为地。虽于初地一切通达。然得成立诸地故

    立名章第二

论曰。复次何故初地名欢喜。由最初得自他利成就功能故。何故第二地名离垢。由远离破戒垢故。何故第三地名照明。由不退三摩地三摩钵底。所依止。大法光明所依止故。何故第四地名为焰。以菩提分法焚一切障故。何故五地名为难胜。真俗二智更互相违极难而相应故。何故六地名为现前。缘生智为依止。令般若波罗蜜行现前故。何故七地名为远行。至功用行后边故。何故八地名为不动。一切相行不动故。何故九地名为善慧。辩才智最胜故。何故十地名为法云。由总相缘一切法智。为一切陀罗尼三摩地门藏故如云。又粗重障如虚空云能覆障故。又法身圆满故

释曰。何故初地名欢喜者。由于此时最初得自他利成就功能。声闻证真实时唯得自利成就功能。非作利他。是故不得如是欢喜同诸菩萨。何故二地名离垢者。由于此地性戒成就。非如初地作意持戒。由远离破戒垢性戒成就故。何故三地名照明。由于此中与三摩地三摩钵底常不相离。以不退故即于大乘法中得大光明。何故四地名焰者。由于此地得菩提分法行。由此行故一切烦恼及随烦恼。皆为灰烬。何故五地名难胜者。由于此地出世真智是无分别。世智工巧论等是分别。应须具修此二相违极难然能具此二故名难胜。何故六地名现前者。于此地中得缘生行。由此智力故无分别行般若波罗蜜得现前故。诸法无染无净。当得七地中有功用行。八地中无功用行。何故七地名远行者。于此地中由方便行究竟故。由于一切相中得决了。有功用行故。何故八地名不动者。于一切相及一切法功用。此中皆得不动无分别心自然常流故。何故九地名善慧者。此慧善故名善慧。辩才智说名为慧。由此智故说名善慧。何故十地名法云者。一切法总相缘智如云。陀罗尼三摩提等门如水。即以此智为藏。如云藏水。又如云障覆虚空。此一切法总相缘智。覆诸粗重障亦尔。及圆满法身故者。如云普遍虚空。菩萨身中法身圆满亦尔。圆满者即是普遍义

    得相章第三

论曰。得此等诸地云何可见。有四种相。一信解得。谓信解诸地故。二行得。谓得与地相应十种法行故。三通达得。谓于初地中通达法界时。通达一切地故。四成就得。谓修此诸地得究竟故

释曰。于中成就得者。若修此诸地至究竟故。是为成就应知

    修相章第四

论曰。修此等诸地云何可见。此诸菩萨于诸地中。修奢摩他毗钵舍那时。有五种修。所谓总集修。无相修。无功用修。炽然修。无厌足修。出生菩萨五种果。所谓一念念中消灭一切染浊依止故。二得出离种种想游于法乐故。三了知一切处无量无分限相法光明故。四所有清净分因缘。不分别相而现行故。法身圆满成就。五由展转上上因所摄故

释曰。随于一地中即有五种修。今当显示。修奢摩他毗钵舍那。由五种修故并得成就。念念中消灭一切染浊依止者。何者名染浊。谓烦恼障智障。无始熏习种子彼障碍聚。由总相缘奢摩他毗钵舍那智故。得念念损减。此聚破散故名消灭。又复损减即是消灭。离种种相得法乐之乐者。于种种体相成立修多罗等。谓法中离种种想。于法乐中得乐。非谓余乐。此中乐者谓内乐故。复有别释奢摩他毗钵舍那。于法中若受若觉若观。非显著粗浅领纳顺行。然唯以忆念光明细领纳细顺行。一切处无量无分限相者。无十方分限了知。一切光明者如善诵经书。心即明了故。于清净分中无分别相现前者。谓与所应成就相应此清净分中无分别相而现前故。佛果即是所应成就。及法身圆满成就。最上上因所摄故者。于中圆满者。谓第十地。成就者。第十一佛地。此中所有法身最上上因所摄者。由此一切因出生佛地。是故得为最胜

论曰。于十地中修十波罗蜜各有增上。六地中六波罗蜜如前说。后四地中有四波罗蜜。方便善巧波罗蜜。六波罗蜜所聚集善根。与一切众生共之。回向阿耨多罗三藐三菩提故。愿波罗蜜者发起未来世种种愿。诸波罗蜜因缘此能引摄故。力波罗蜜者由思量修习等力六波罗蜜得相续现行故。智波罗蜜者此成立六波罗蜜智。得自受用法乐。及成就众生故。复次此四波罗蜜是般若波罗蜜中无分别智后所得智摄。应知。复次诸十地中一切波罗蜜非不修行。此诸地法门为诸波罗蜜藏所摄

释曰。于十地中修十波罗蜜各有增上者。于十地经中说初地檀波罗蜜增胜。乃至十地智波罗蜜增胜。是故以增胜故十地中说十波罗蜜。于一切地中一切波罗蜜亦皆修习。六地中六波罗蜜者。如次第显示。初檀波罗蜜乃至第六般若波罗蜜。如是等义如十地经中说。此中不具足如前说。后四地中有四波罗蜜者。由随于何处说六波罗蜜。即彼处方便善巧等四波罗蜜皆在其中。若说十波罗蜜。彼中唯以无分别智为般若波罗蜜。后得智摄余方便善巧等四波罗蜜。是故于后四地中修四波罗蜜得成。论说善巧方便波罗蜜中。与一切众生共者。于中所有善得与众生共。今当显示诸愿求无上菩提者。皆欲作一切众生利益事。要正觉菩提方得此欲。是故诸有思量所有善根皆回向。为作一切众生利益事。此名与一切众生共。又善巧方便者。即显悲智。六波罗蜜所聚集善根。由悲故与一切众生共。由智故不回向释梵等果报。是故由此智故不起烦恼。及不舍生死。于中不染。得成方便善巧故名方便善巧波罗蜜。由起种种愿力故得种种波罗蜜因缘。是名愿波罗蜜。未来中者未来世因相故名未来中。住此因中为彼未来故作种种愿。有修多罗中说二种力。谓思量力及修习力。虽无修习力。以思量力故与诸波罗蜜相应。故得诸波罗蜜相续现行。此是力波罗蜜业事。如所显示诸波罗蜜皆是智所建立。此是智波罗蜜即是无分别般若波罗蜜自性。若为自受用法乐。及为成就同法众生故。名成立诸波罗蜜。此法门为诸波罗蜜藏所摄者。此中波罗蜜藏者。谓一切大乘法此十地法门是波罗蜜藏所摄。非声闻藏所摄故。一切波罗蜜于诸地修习得成。此诸地法门最高大故。一切诸佛遍一切佛刹中演说。又此法门胜故。于最初时及于最胜处说。最牢固住处说。以其胜故。故言胜

    修时章第五

论曰。复次于几时修此诸地得圆满。有五种人于三阿僧祇劫中。谓信行地人初阿僧祇劫净心行有相行无相行六种地及七地。第二阿僧祇劫。即此无相中无功用行已上。乃至十地第三阿僧祇劫修行圆满此中有偈

  净妙胜上力　　牢固心转胜
  菩萨三僧祇　　说名正修行

释曰。五种人三阿僧祇者。于中信行者。谓于彼义中依信而行故。此地初阿僧祇满。此阿僧祇满已得净心地。通达真如故。即此净心行。于十地中六地已还有相行。第七地无相有功用行。即得第二阿僧祇满。若入八地得无功用行。然未成就彼无功用行。九地十地得满此无功用行。此人是第三阿僧祇劫。即此一人成立五种。如须陀洹斯陀含阿那含等。随位处差别故。如所说三阿僧祇满得菩提。于无始生死中修行施等。及逢值诸佛齐何已来。说为三阿僧祇劫。此义偈中显示。净妙胜上力者。谓得善根力及愿力。于中善根力者。散乱等不能破坏应知。愿力者。恒与善友同聚应知。牢固心转胜者。谓发起牢固心。及修行转胜。于中牢固心者。善友力故。不舍菩提心应知。行转胜者。谓现在及后生生中。善根增长无有退减应知。余句可解释。因果修差别胜相竟

摄大乘论释论卷第七摄大乘论释论卷第八

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    增上戒学胜相胜语第六

论曰。如是说因果修差别已。此中增上戒胜相云何可见。如经说。菩萨地中诸菩萨所受禁戒。若略说有四种胜相故名胜相应知。谓差别胜相。共不共学处胜相。旷大胜相。甚深胜相。此中差别胜相者。谓守护戒。摄善法戒。利益众生戒故。于中守护戒是余二戒住处应知。摄善法戒是出生佛法住处。利益众生戒是成熟众生住处应知。共学者。声闻及菩萨等。性罪不行故。不共学者。谓遮罪不行故。此学处或于声闻是犯。菩萨非犯。或有于菩萨是犯声闻非犯。菩萨学处。谓身口意。声闻学处。谓唯身口。是故菩萨心亦是犯非余声闻等。略说但是摄受一切众生无罪过身口意业菩萨一切所应行者。于彼皆应学之。即是共不共学处应知

释曰。云何得知菩萨学处与声闻差别。言品类差别者。由声闻等唯有一守护戒。无摄善法戒及利益众生戒。共不共学处戒者。于中性罪。谓杀生等是为共。掘地断草等制罪。是不共。此后学处于声闻有罪菩萨无罪。如声闻于夏中行是犯。菩萨见有众生利益事不去是犯。摄受一切众生无罪过者。摄一切众生而无罪过。非如以女色等与之。虽是摄受。然非无罪过业。为离此过故应说以无罪过摄故。心亦是犯者。如害觉等。但起觉时即是菩萨罪。非声闻故。此增上戒等三学。即是波罗蜜体性。何故复更建立三学。此与波罗蜜差别义。今当显示。由展转相因故别立诸学处。依戒故生定。依定故生慧

论曰。旷大差别者。复有四种旷大故。一种种无量学旷大。二摄无量福德旷大。三摄一切众生利乐心旷大。四阿耨多罗三藐三菩提住处旷大

释曰。种种无量学处旷大者。诸菩萨学处亦种种。亦无量。以于众生行教化及作摄事故。摄无量福德者。由摄诸菩萨福德资粮不可测量。声闻不尔。摄一切众生利乐意者。于中劝令修善。是利益意。此人以此善故。若于果时当得福报。此名安乐意。阿耨多罗三藐三菩提住处旷大者。阿耨多罗三藐三菩提住此戒而得。声闻戒不尔

论曰。甚深差别者。若菩萨以如是等方便善巧。行杀生等十种恶业。然不得罪。生无量福。疾证阿耨多罗三藐三菩提。又变化身口业。应知是菩萨甚深戒。或为国王显示种种逼恼众生事。以此成立众生于律行中。又种种本生中示现故。显示逼恼余众生摄受余众生故。先令他心生净信。然后教化成熟。此名菩萨戒甚深胜相。此四种胜相。略说菩萨守护戒胜相应知。如是等菩萨学处差别。复有无量种差别。如毗那耶瞿沙方广经中说

释曰。甚深差别中。若菩萨以如是等善巧方便者。此中如是菩萨得如是善巧方便势力。今当显示。若如是知。此人以此不善。与无间地狱相应。菩萨以知他心智知。更无余别方便。能转其恶业。令不决定堕恶道。知决定作此业已必堕地狱。如是知已即起此心。设令我作业已堕于地狱去。亦何苦杀之。虽现世少受苦恼。未来当受安乐。是故犹如医师。菩萨以利益心杀之无罪。得大胜福。由此福德故疾得阿耨多罗三藐三菩提。如是等行最为甚深。又复菩萨有变化身口业。应知是甚深戒由此故。或为国王示现种种逼恼众生事。安立众生于律行中。于中所化体相为变化。如阿那罗王为善财童子示所现事。种种本生中示现者。如毗输安恒啰王子(隋云多能即是须达拏也)。本生经中说。菩萨以儿施婆罗门。此儿是变化。何以故。论云显示不逼恼此众生。摄受余众生故。以菩萨终不以逼恼此众生。作摄受余众生事。此亦是甚深。此等四种差别。即于毗那耶瞿沙十万偈经中广说。释增上戒学竟

    摄大乘论释论增上心学胜相胜语第七

论曰。如是已说增上戒学胜相。增上心学胜相云何可见。略说有六种差别应知。一所缘差别。二种种差别。三对治差别。四功能差别。五出生差别。六作业差别。大乘法为所缘故。大乘光明一切福德聚三昧王。贤护首楞伽摩等三摩提种种无量故。一切法总相缘智如以楔出楔方便。推出阿梨耶识中染浊障故。游禅定乐随所欲受生故。于一切世界中出生无障碍神通故。谓振动故。炽然故。普遍故。显现故。转变故。往来故。延促故。聚散故。一切色像入身中故。所往同类故。隐显故。所为自在故。伏他神通故。与辩故。与念故。与乐故。放光故。出生如是等大神通故

释曰。今显增上心学胜相。于中大乘法为所缘者。由诸菩萨以大乘法为所缘。非诸声闻等。大乘光明福聚三摩提王等者。显三摩提名。以诸声闻于此种种三摩提中无有一种故。对治差别者。由能对治一切障碍故。如以细物推出粗物。如是烦恼种子于阿梨耶识中住。名为熏习。此说为粗对治。道说为细。推出彼粗故。功能差别者。由有此功能故。游禅定乐然有利益一切众生处。于彼受生亦不失禅定。声闻不尔。出生差别者。于一切世界中得无障碍神通。由禅定生故。作业差别者于中振动者振动一切世界故。烧然者。即是烧然一切世界。普遍者。应知光明遍满故。显现者。若众生随所应见。以菩萨神通力故。得见无量世界。及见彼世界中诸佛菩萨等故。转变者。如转地等为水等应知。往来者。一刹那间往无量世界。于此刹那间即还来故。聚者。以无量世界入一微尘中。然不增长故。散者。以此一微尘普遍无量世界故一切色像入身中者。如于一身中。一切无量种种色像显现故。所往同类者。如往三十三天。色像音声皆与彼同。为教化彼者。如是往一切处皆尔。隐显者。即于一切处或现或不现故。所为自在者。如变魔王令作佛身等故。伏他神通者。于一切神通中得最胜故。与辩者。令能答问故。与念及与乐者。由听菩萨说法故。得三摩提故。得念得乐放光者。放光令他世界住菩萨皆悉来集故。出生如是等大神通者。此前所说神通大故。此等神通声闻所无故

论曰。摄一切难行。由出生十种难行故。十种难行者。所谓自受难行。自受菩提愿故。不退难行。于生死苦中不退转故。不背难行。于一切颠倒行众生。不弃背故。现前难行。若诸众生触恼菩萨。亦现前作一切利益事故。不污难行。生在世间而不为世法所污故。信乐难行。于大乘中虽复未解。然于一切甚深广大生信乐故。通达难行。通达人法二无我故。随觉难行。于如来所说甚深秘密语中随顺觉知故。不离不染难行。不舍生死而不染故。起作难行。诸佛于一切障碍解脱中住。以无功用尽生死际。起作一切众生一切利益事故

释曰。如经说菩萨有难行。于中何者是难行。彼一切难行以此十种难行显示。于中不离不染难行者。不离者不舍义。若于生死不舍亦不染。此为甚难。余九种难行。论本可解

论曰。于随觉难行中诸佛何等密语中。菩萨随顺觉知。如说云何菩萨得成布施。若不施一物。然于十方世界中。成就无量布施事。云何得成布施乐欲。若于一切布施无所乐欲。云何得成施信。若于诸如来不行信向。云何得成布施策发。若自身于布施无所策发。云何得成布施游戏。若无有一时布施一物。云何得成布施广大。若于布施生不牢想。云何得成布施清净。若生悭心云何得成布施究竟。若不住于究竟中。云何得成施自在。若于施不得自在。云何得成布施无尽。若不住无尽中。如施如是持戒乃至智慧皆尔。随其相应应知

释曰。此中显示密语意。于中云何得成布施者。菩萨取一切众生为己体。是故一切众生行施。即是菩萨行施。此是密意。云何得成布施乐欲者。谓不乐欲有所得施。但乐欲菩萨净施。杂相及着相。是名有所得。是故经说。有杂相着相布施。云何得成施信者。由自得施心故不藉他为缘。云何得成施策发者。此亦显自性能施。若自身无所策发。由悭除故虽不策发自能行施。云何得成布施游戏者。非一时施常施故。不施一物一切施故。云何得成布施宽大者。于中不牢者。若取秘密义名为不乱。此为显定心施及破贪欲施。云何得成布施清净者。于中生起者。若取秘密义名为拔根。谓拔出悭根。由回悭首在下拔根在上故名生起。云何得成布施究竟者。究竟者名涅槃。于中不住故。非如声闻住究竟涅槃。云何得成施自在者。若于施障中令不得自在。故名于施得自在。以但于施障不得自在故。云何得成施无尽者。无尽即是涅槃。为显不同声闻住涅槃故

论曰。云何得成杀生。若断众生生死。云何得成不与取者。若一切众生无有与者而自取之。云何得成欲邪行。若于欲邪中行故。云何得成妄语。若于虚妄中说为虚妄。云何得成破坏语。若于第一空中行常行故。云何得成粗恶语。谓住应知彼岸故。云何得成杂乱语。若于差别种类法中如其相说故。云何得成非分贪。若于无上禅定数习令自得故。云何得成嗔害心。若于一切烦恼心已得杀害故。云何得成邪见。于一切处遍行邪体如其体见故

释曰。如经中说。佛言比丘我为杀生者。今当显示此说意。云何欲邪行者。若念知此欲是邪如是行故住应知。彼岸者。谓于应知彼岸中住故。云何邪见者。于色等遍行邪体。如其相见故。即是见依他性中分别性是邪相。余十不善业道义如论可解

论曰。甚深佛法者。何者为甚深佛法今当解说。常住法是佛法。法身常住故。断灭法是佛法。一切障皆断灭故。生起法是佛法。化身生起故。证见法是佛法众生八万四千行并对治皆证见故。欲俱法是佛法。欲俱众生摄同自体故。如是嗔俱法是佛法。痴俱法是佛法。凡夫法是佛法应知。无染法是佛法。成就真如一切不污故。不污法是佛法生在世间。不为世法所污故。是故名为甚深佛法。为修波罗蜜。为成熟众生为清净佛刹。为出生一切佛法等故。是菩萨三摩提业差别应知

释曰。复有余经中说常住法是佛法。乃至无染法是佛法等者。此中说意今当显示。常住者。谓法身以此法故说为常住法。断灭法证见法不污法者。此等为显出离一切障染真如。以此法故说不污法。前不说作业差别是故今显示。菩萨三摩提业此中菩萨依止三摩提故得修诸波罗蜜。亦以依止三摩提故成熟众生。由神通故摄引令入。亦依止三摩提力清净佛刹亦尔。若心得自在即随所欲令世界成金等。如是等由三摩提力故。出生佛法是名为业。释增上心学竟

    摄大乘论释论增上慧学胜相胜语第八之一

论曰。如是已说增上心学胜相。增上慧学胜相云何可见。谓无分别智。若自性。若依止。若因缘。若所缘。若相貌若建立。若释难若住持。若伴类若果报。若津液若出离。若至究竟若方便。无分别后得等功德。若差别若无分别智譬喻。若无功用作所应作若甚深等。此是无分别智。增上慧差别应知

释曰。今当说增上慧学胜相。此中显无分别智是增上慧。此智复有三种。一方便无分别即是寻思。二无分别。三后得。于中求欲智是初增上慧。自内智是第二增上慧。摄持智是第三增上慧。于中唯成就无分别智为正体。由于寻思因智即是彼果故。由于后得果智即是彼因故。若此智成就前后二智即得成就。今应先释无分别智自性。自性即是体相。诸菩萨无分别智自性。应须离五种相今当说

论曰。此无分别智自性离五种相。离非思惟故。离过觉观地故。离灭受想定故。离色自性故。离计度真实义种种相故。离此等五种相。是无分别智应知

释曰。五种相中。若不作意是无分别者。则重睡耽淫极醉等应是无分别智。复次若过觉观地是无分别者。则二禅已上皆应是无分别知。若尔世间人亦应得无分别智。复次若心及心法不行故。是无分别智者。住灭受想定等应是无分别智。此智不成。何以故。以住灭定等时无有心故。复次若智体性如色者。如色顽钝无知。智亦如是顽钝无知。复次若于真实义中。取种种相是无分别者。此取即是分别。以分别言此是真实故。若智离此五种相缘真实义。于真实义中。若不起种种相言。此是真实此是无分别智相故。缘真实义时。如眼识缘色无种种相此是其义

论曰。此中为成立。如所说无分别智故说偈

  诸菩萨自性　　出离五种相
  是无分别智　　于真不计度
  诸菩萨依止　　非思亦是思
  是无分别智　　非思义种类
  诸菩萨因缘　　有意言闻熏
  是无分别智　　正思惟相应
  诸菩萨所缘　　不可言说法
  是无分别智　　无我及真如
  诸菩萨相貌　　于彼所缘中
  是无分别智　　尔炎无有相
  相应自性义　　所分别非余
  字字相应故　　是为义相应
  若离于言说　　于义智不生
  言说不同故　　一切不可言
  诸菩萨住持　　即无分别智
  后得智中行　　得增长进趣
  诸菩萨助伴　　说为二种道
  是无分别智　　五度之种类
  诸菩萨果报　　诸佛二轮中
  是无分别智　　方便及正得
  诸菩萨津液　　于后生生中
  是无分别智　　自体转胜故
  诸菩萨出离　　得成就相应
  是无分别智　　应知十地中
  诸菩萨究竟　　由得三身净
  是无分别智　　得最上自在
  如虚空不染　　此无分别智
  种种极恶业　　唯信决定故
  如虚空不染　　此无分别智
  解脱一切障　　得成就相应
  如虚空不染　　此无分别智
  常行于世间　　世间法不染
  如哑求受尘　　如哑正受尘
  如非哑受尘　　三智如是说
  如愚求受尘　　如愚正受尘
  如非愚受尘　　三智如是说
  如五求受尘　　如五正受尘
  如意识受尘　　三智如是说
  如未解求解　　如知法及义
  三智次第尔　　当知方便等
  如人正闭目　　是无分别智
  即彼开目时　　是为后得智
  此无分别智　　应知如虚空
  如空中色像　　后得智亦尔
  如摩尼天乐　　作业离分别
  诸佛种种业　　亦常离分别
  非此亦非余　　非智亦是智
  与尔炎无别　　是无分别智
  由说一切法　　自性离分别
  所分别非有　　无无分别智

释曰。此初偈中即显此义。即此所说自性由依止故得生。今当说。由说此智为无分别故。此智必应依止心生。若依止心生。由能思念故名为心。若依止思念生。则无分别义不成。又若依止非心生。则不成智。为离此二过故。偈说诸菩萨依止等。于中此智所依止非思。何以故。以不思量义故。又此所依止亦非非思。何以故。以思所引生故。此所依止生时。是思种类故得说名思。又此智由因所生起故。次以偈显示其因。诸菩萨因缘。有意言闻熏者。由于他音声正闻熏习。以此熏习为因。生思惟意言。名正思惟。此智以何为所缘。复以偈显示。诸菩萨所缘等者。于中不可言法性。谓于分别性一切法不可言。复次何法不可说。谓无我真如人法体分别性无我。此无体之体名为真如。莫作断取。又此所缘有何相貌。次以偈显示。诸菩萨相貌等者。于中无相者。此智与真如平等而生。无有别相为相。此是相貌如眼取色。于中见青等相貌与色无异。此亦如是。智与真如无异相貌。若所有一切法皆不可说。何者为所分别。相应自性义所分别非余故。与彼不别故名非余。复次此云何成。为成就此故偈言字字自相应。是为义相应者。若此字与彼字相应。说此中义名和合义。如斫刍二字不断说故。即有眼义和合生(斫刍隋云眼)。是所分别。以何道理成就一切法不可说。若离于言说于义智不生故。如有人未识能说名。于所说义智则不生。若汝言但得能说名则知所说义者。此义不成。如偈言言说不同故。以能说名与所说义不同。名与义各别体故。偈言一切不可说。由此义故能说与所说俱不可说。复次此无分别智何所住持。偈言诸菩萨住持。即无分别智后得智中。行者由无分别后所得智故。菩萨得修诸行即依此智得增长进趣。菩萨所有诸行此增长义。依无分别智住持故。复次此智以何为伴。偈言诸菩萨伴助。说为二种道故。此无分别智以五波罗蜜为助伴。于中道有二种。谓资粮道。及依止道。资粮道者。谓施戒忍精进等诸波罗蜜。依止道者。谓禅波罗蜜。由如前说。诸波罗蜜所生善根。及依止禅定故。无分别智得生。此智即是般若波罗蜜。复次乃至未得佛果已来所有无分别智。能成熟果报。偈言诸菩萨果报诸佛二轮中。是无分别智者。何者诸佛二轮。谓受用身轮。及化身轮。若修方便无分别。能成熟化身果。若正得无分别。能成熟受用身果。为显示此义故。偈言方便及正得。复次何者是无分别智津液。诸菩萨津液于后生生中者。即于彼二轮中。于后后生处。此无分别智体转得胜进。即此无分别智转胜进时。此是津液果应知。复次云何出离。诸菩萨出离者。究竟出离。即是涅槃得成就相应。此无分别智者。此智初得得相应。从此经无量百千劫得成就相应。应知十地中者。从初地乃至第十地如是次第。初地中唯有得相应。尔后无量时得成就相应。是故诸菩萨于三阿僧祇劫得涅槃。由经尔所时乃得究竟故。何者无分别究竟。即次前所说得者。是偈言诸菩萨究竟。由得三身净。是无分别智。此中三身清净者。由此三身初地中唯有得。于十地中得善清净故。得最上自在者。此无分别智。非唯清净三身得究竟。复有十种自在。如后说彼亦是得应知。复次无分别智有何功德。于中有三种无分别。一方便无分别。二根本无分别。三后得无分别。此中方便无分别者。由此人初于他所。闻菩萨无分别已。自未见其方便。然生信乐。依止此信乐。修无分别观。此时名方便无分别。由此观行故无分别得生。故得无分别名。此方便无分别无染功德。譬如何等。偈言如虚空不染。此无分别智故。为显示何法。无染故说种种极恶业。为显示不染因故。说唯信决定故。由于此无分别唯信决定故。能对治恶趣。此即显示诸恶不染根本。无分别功德复何所以。偈言如虚空无染。此无分别智故。何法不染。谓一切障碍。何故不染。得成就相应故。显示于诸地中由得相应及成就相应为因故。此即显示对治一切障。无分别后得智功德。复何所以。偈言如虚空不染。此无分别智。常行于世间。世法不能染故。由此智力故。见有利益众生处。随念往生虽生世间。然不为世法所染。世法有八种。谓得利不得利好名恶名毁赞苦乐等。此即是无分别。从无分别智生故。今当显示此三智差别。其相应知。如哑求受尘。无有言说。方便无分别亦尔。如哑正受尘无有言说。根本无分别亦尔。如非哑受尘。如所受尘。即有言说。无分别后得亦尔。名字等名为言说。如愚求受尘者。未曾识知名愚。此愚等譬三智。如哑中说。如五求受尘者。无分别五种。应知是眼等五数。此等求觅及正受。此譬三智。一切如哑中说。如意识受尘者。如意识于尘能分别。亦受用。后得亦尔。于尘亦分别亦受用。如未解论求解。方便无分别亦尔。如诵习论时。但受用于法。根本无分别亦尔。法者谓文字如解。论者于法于义皆受用。后得亦尔应知。复次为摄此法及义故显示二智。如人正闭目者。此偈显示无分别及后得二种差别相。如虚空者。如虚空无染无有分别。亦不为他所分别。无分别智亦尔。遍在一切法一味。空中一切法不能污故名无染。自体无分别故名无分别。亦不为他分别成相貌故非所分别。此智如是应知。如空中色像后得智亦尔者。如色显现亦是能分别。亦是所分别。复次若以无分别智名为佛者。既离分别众生云何得成利益众生事。虽离分别如理得成故。以摩尼天乐譬喻显示。如摩尼天乐者。如如意珠离分别业。随众生所欲作利益事。又如天乐无有作者。随彼天所欲。出种种声。诸佛亦尔。离于分别而种种事成应知。此无分别甚深说中。云何为智缘依他性所分别物。为有别缘。若尔何过。若分别所攀缘则不得名无分别。若言有别攀缘。此别攀缘亦非有。非此亦非余者。于中非此者。以非分别所能缘。以无分别故亦非余者。以即于依他性法中作法。如攀缘故。此法及法如二种。不可说一不可说异故。此亦尔不可说为分别所缘。又不可说为异缘故。复云何此为是智为非智。若尔何过。若是智既名为智。云何不分别。若非智自性云何说为无分别智。故以非智亦是智偈显示。此不可为智。何以故。由方便有分别智自性中不生故。亦非非智以方便有分别智为因生故。复有别义非即亦非异非智亦是智者。由非即缘分别中生故名非智亦非异。由即缘法如中生故非非智。即以前句释后句。与尔炎无别。是无分别智者。非如方便智有能取所取生故名无分别。若于所取尔炎中。无别异平等平等生。是无分别。此智不住能取所取中。世尊于修多罗中。说一切法无分别。此中欲显示此无分别故。更说偈。由说一切法自性离分别者谓一切法即自性无分别。何故如此偈言。所分别非有。以此显示由所分别物非有故。若所分别非有故。即一切法自性无分别者。何故一切众生不即得解脱。无无分别智者。即以此句显示不得解脱。虽一切法自性无分别。由一切法自性无分别故。无有所分别。若于此中通达智生证见此无分别故得解脱。若通达智不生。即不得解脱。所说无分别智即此智有三分。今当显示

摄大乘论释论卷第八摄大乘论释论卷第九

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    增上慧学胜相胜语第八之二

论曰。于方便无分别智中有三种。谓因缘引摄数习等。出生差别故。无分别智亦有三种。谓知足不颠倒无戏论等无分别故。无分别后得智有五种。谓通达忆念成立和合如意等。显示差别

释曰。因缘引摄数习等出生差别故者。此是方便无分别三种。由或以种性力。或以现前数习力故得生。于中种性力者。即是从因得生。数习力者即是现在身丈夫力作。非从因生。知足无颠倒不戏论无分别故者。于中知足无分别者。应知是闻思体究竟。由满足故不复分别故。名知足无分别。于闻思位究竟时自知得到究竟处。此菩萨住在凡夫地。生满足心。作是念。闻思事只齐于此。以是义故说为知足无分别。复次应知。有世间知足无分别。若得于有顶处见为涅槃。生知足心。谓更无余处故名知足无分别。不颠倒无分别者应知是声闻等。由诸声闻通达真实故得无常等四无倒智。于常等四倒相中不复颠倒分别。无戏论无分别者应知。是诸菩萨由诸菩萨知一切法乃至菩提。无戏论无分别故不复分别。无戏论者。谓出语言道过世间智由此智非言语所说。亦非世智所知故。复次无分别后得智。有五种差别应知。谓通达忆念成立和合如意等。显示差别故者。于中通达显示。忆念显示。成立显示。和合显示。如意显示等五种差别。此中通达显示者。若通达已即于彼时显示云。我已通达作如是显示。显示者。谓决定知故忆念显示者若出定已忆念言。我已通达无分别也。成立显示者如所通达为他解说。和合显示者以一切法为一抟相。总相攀缘智。由此观智即得转依。如意显示者由此转依故即得如意显示。由随心所念一切自在。由此自在若以地等为金等即得成就。由显示故为此如意故。显示故名如意显示。何以故。由经说。以显示及如意故。已成立无分别智。未说成就因缘故。复以偈显示

论曰。更有别偈成就无分别智

  鬼畜人天等　　各随其所应
  一切意有异　　故知义不成
  过去等及梦　　并余二影像
  无有为攀缘　　然彼攀缘成
  若义成为境　　无无分别智
  此智若不有　　佛果无可得
  得自在菩萨　　乐欲自在故
  如念地等成　　得定者亦尔
  成就观行人　　智人得寂静
  思惟一切法　　如其义显现
  智行无分别　　一切义不现
  即知无有义　　识亦不得有

释曰。此中鬼畜人天等各随其所应者。畜生以为水。饿鬼为高原。如人见粪为秽。猪等畜生见为净妙。如人见饮食为净。于诸天见为不净。以此道理显示。于一物中各随其意见有差别。是故应知义无所有故。彼等所取既不成就。若尔义无所有故识应不缘境而生。答亦有识不缘境而生。如梦及过去未来等。无实攀缘即自体攀缘。如镜像及定境亦尔次以偈显示。过去等及梦此偈者。于中后半偈释前半偈。如其次第应知。由无实攀缘故无攀缘。非无攀缘即自攀缘故。谓自心为境而攀缘故。即是过去未来及梦并二影像等次第相应。若义成为境无无分别智者。若义有自性则无无分别智。若汝言无无分别智有何失者。此智若不有佛果无可得。若无分别智不有则不能得佛果。是故决定应有应知。得自在菩萨者。谓已得自在力故胜解自在故者。得乐欲自在故如念地等成者。谓欲以地等诸物成金等相。即能成故。得定者亦尔者。谓得定人及余声闻等故。成就观行人者。谓成就毗钵舍那故。智人者即是诸菩萨。得寂静者。谓得三摩提故。思惟一切法如其义显现者。由诸菩萨于如是如是修多罗等法。义思念时如念显现。若念佛时随所思念。于彼彼法中佛义显现。如是色受等义显现亦尔故。智行无分别一切义不现者。智正行无分别时。由一切义不现故。即知义无有。由义无所有故识亦成无所有。此识无所有今当显示。识亦不得有者。所识既不有能识则不成。是故应知无所有。此义应知。相中已具解释

论曰。般若波罗蜜与无分别智无有差别。如经说菩萨住般若波罗蜜中已。与不住相应故。修余波罗蜜得满足。云何不住相应而得满足。谓远离五种住处故。一远离外道我执处故。二远离不见真实菩萨分别处故。三远离生死涅槃二边处故。四远离唯断烦恼障生知足处故。五远离舍众生利益事。住无余涅槃界处故

释曰。此无分别智。即是般若波罗蜜。何以故。由经说住般若波罗蜜中。已与不住相应。如是等为欲令知此义故。以经文显示。如是住不住相应中满足余波罗蜜。远离外道我执处者。如外道住般若中有我执。念云。我住般若中。此是般若。菩萨远离如是外道住相故。得住无住相应般若中。远离不见真实菩萨分别处者。如不见真实。菩萨于无分别般若波罗蜜中。分别言。此是般若波罗蜜。无如是分别故。名不住相应。远离生死涅槃二边处者。如世间住生死边。声闻等住涅槃边。菩萨不如是。不住此二即是不住相应应知。远离唯断烦恼障生知足者。如声闻唯断烦恼障生知足。菩萨不如是由此意故言诸菩萨不住相应行应知。远离舍众生利益事住无余涅槃界处者。如声闻舍利益众生事。于无余涅槃而取涅槃。菩萨不尔。如是不住声闻所住。是名不住相应。声闻智与菩萨智有五种差别相。今当显示

论曰。声闻智与此菩萨智有何差别。有五种差别应知。一无分别差别。谓阴等法无分别故。二无分限差别。谓通达真如入一切种应知。为一切众生无有分限故。三无住差别。谓入无住涅槃故。四毕竟差别。谓趣无余涅槃界不尽故。五无上差别。谓最为胜上无有余乘胜过故

  五种差别智　　大悲以为体
  世出世果报　　当知不为远

释曰。于中无分别差别者。由诸声闻攀缘阴等。生分别智。诸菩萨智。于阴等不生分别故。无分限差别者通达人法二无我故应知。无有分限。由诸菩萨于一切应知中智生故。声闻唯知苦等谛为众生亦无分限。菩萨为一切众生故求菩提。声闻唯为自利故。无住差别者。诸菩萨得无住处涅槃非诸声闻此差别。毕竟差别者。于中言差别者。于无余涅槃界中。声闻涅槃则有尽灭。菩萨涅槃则不尔。无上差别者声闻乘有上。菩萨大乘则无有上。是故此为差别。此义偈中显示五种差别智等中。世出世果报者。谓色无色界是世间果报声闻等是出世果报

论曰。若菩萨如是增上戒增上心增上慧等功德果报具足。已于一切义利中得自在者。何故现见有诸众生。受诸贫苦。由见是诸众生于彼义利业障故。由见若与其乐果报。于诸善法中碍其起善故。由见其无有义利。则厌恶现前故。由见其若得果报。为聚集不善法因故。由见其若得果报。与余无量众生作逼恼因故。以是义故现见众生受诸苦恼。此中有偈

  见业碍现前　　集恶逼恼他
  当知是众生　　不得菩萨施

释曰。得自在菩萨。以此因缘虽有大悲而不与众生富乐。今显示此意。于中见诸众生业障故者。是诸众生于菩萨威力中有业障碍故。由彼等于菩萨智有障碍所碍。菩萨虽有堪能。见此事故于其贫苦即生舍心。此中显饿鬼见河水为譬。如河有水若欲饮时无人障碍。然饿鬼由自罪业故。不能得饮。此亦如是河喻菩萨。财物喻水。饿鬼喻众生。犹如彼水。是诸众生。于彼财物不能得受用。其义亦尔。由见与乐碍其起善者。复有余人虽无业障。然此人得见菩萨时。于相续中生起善法。若与此人果报以受富乐故。于起善则断绝。菩萨作是思量。宁令贫苦随顺起善。以此道理不与富乐。由见其厌恶现前故者。或复有人厌恶现前。菩萨见其贫苦。而于善不善中胜上厌恶现前思量。是已于彼众生不与富乐。由见其苦受果报。增长不善因者。又复有人于贫穷时。不得聚集不善法。菩萨见已作是思量。宁令贫穷。莫令造作不善。故于彼等不与富乐。由见其若得果报。与余无量众生作逼恼因故者。又复有人得大果报。则苦恼无量众生。是故宁令一身独受贫苦。于理为胜。莫令苦恼无量众生。是故不与富乐。如是等义偈中显示。此中业障碍故。生起善根故。善现前故。聚集不善故。逼恼余众生故。菩萨见其如此不与富乐。即是偈中业及碍现前。集恶逼恼他。以此显示余义可解。释增上慧学竟

    摄大乘论释论寂灭胜相胜语第九

论曰。如是已说增上慧学胜相。寂灭胜相云何可见。诸菩萨寂灭即是无住处涅槃。以舍离烦恼不舍生死。共依止转依为相。此中生死者是依他性染污分。涅槃者即是依他性清净分。依止者即是依他性具二分。转依者即是依他性对治起时染污分灭。清净分显

释曰。无住处涅槃相者。即是舍离烦恼不舍生死。共依止转依为相者。住此转时不令烦恼得住。然不舍生死。染分故名依他。即此净分故名涅槃。二分故即是彼依止。转依亦即此中得成。由此中对治起时。染分不行净分行故

论曰。复次此转略说有六种。一益力损能转。由信解力住闻熏习故。有惭微烦恼行不行故。二通达转。谓已入地诸菩萨。真实不真实显现在前故乃至六地。三修习转。有障碍一切相不显现。真如显现故乃至十地。四果圆满转。无障碍一切相不显现。最清净真如显现。得一切相自在故。五下劣转诸声闻等通达人无我故。一向背生死一向舍离生死。六旷大转。诸菩萨通达法无我故。见生死即是寂静。灭烦恼而不舍离故。诸菩萨于下劣转中有何过失。不念利益众生事故。菩萨法应超过下乘。同其解脱此是过失。诸菩萨于旷大转中有何功德。于生死法中以自依止转为依止故。得身自在于一切趣显示一切身故。以种种调伏方便。调伏安立于世间果报及三乘中。此为功德

释曰。此转复有六种。益力损能转者。阿梨耶识中染污熏习。损其能益对治力。是故得转住。解行地者。住闻熏习力已得转依故。若烦恼现行彼有惭愧故。现行烦恼熏习薄少。通达转中真实不真实显现者。由正入地时为真实显现因故。即于彼。时得转依。或时出观此即为不真实显现因乃至六地。修习转者。于应知障中有碍。此菩萨已一切相不复显现故。得转依。此转乃至十地。果圆满转中一切障不复障碍者。此菩萨已一切相不显现。无有一切障碍。见最清净真如故。得此于一切相中得自在故得依止。由得此相自在故。能作随意利益众生事。旷大转者。由于生死见其寂静。烦恼即灭非有所舍。但烦恼不染由处染不染故。不舍生死此有何功德此旷大转。诸菩萨以自依止转依故。于一切法得自在。于一切趣中显示同一切身[怡-台+龍]悷不调众生。以种种调伏方便智调伏。安立于富乐及三乘中。此为功德。是中富乐者是世间果报故

论曰。为转依此中有偈

  凡夫覆真实　　一切虚妄现
  诸菩萨离妄　　一切真实现
  应知现不现　　真实不真实
  此依止转已　　名解脱如意
  生死及涅槃　　若平等智生
  生死即涅槃　　彼人得如是
  即得于生死　　非舍非非舍
  亦即于涅槃　　非得非非得

释曰。为显转依故说偈。如诸凡夫由无明故。覆障真实。虚妄显现。即是众生等相。如是诸圣人真实显现故。舍离众生等相。由断虚妄无明故。得如是。应知现不现真实不真实者。虚妄分别不显现。真实成就性显现。是名转依。于转依中虚妄不现行真实现行。此即是解脱相应名解脱如意者。如意欲行皆得解脱。非如声闻毕竟涅槃犹如斩首。得如是解脱。生死及涅槃若平等智生者。于生死涅槃二种。平等智生。此二无有差别故者。若即于彼时故复次生死涅槃云何得平等。由烦恼为生死。烦恼法无我。菩萨通达此法。无我智生见彼诸法皆无所有。诸有生死即是涅槃。见生死法即是涅槃寂静。若如是有何所得。即得于生死非舍非非舍故。非舍者由诸有生死即是涅槃故。非非舍者舍故。由于此中不染故。见无所有故若得如是。亦即于涅槃非得非非得。由彼法不异涅槃是故非得。由于彼法见其寂静。与涅槃无有差别。是故非非得。释学果寂灭竟

    摄大乘论释论智胜相胜语第十之一

论曰。如是已说寂灭胜相。智胜相云何可见。三种佛身故。应知是智胜相。谓自性身。受用身变化身。此中自性身者。即是如来法身。一切法中自在依止故。受用身者此显诸佛种种大集轮。法身为依止。清净佛刹中。受用大乘法果报故。变化身者。亦以法身为依止。处兜率陀宫故。及降生受欲乐。出家往外道中。修行苦行正觉菩提转法轮入大涅槃。所显示故

释曰。智胜相此中解说。即以三身显智胜相。自性身为一切法自在依止。受用身者即以前所说。自性身为所依。种种诸佛大集轮故。得显于清净佛刹中。大乘修多罗等法为因故。得受用法乐此为依止。复有别义为受用清净佛刹故。及受用法乐故以此为依止。变化身中始从兜率陀宫。乃至入涅槃等者。为显示同天人法。以此为依止

论曰。此中有郁陀那(隋云摄持)

  相得及自在　　依止与摄持
  差别德甚深　　念业等佛身

何者为相。诸佛法身略说有五种相。应知一转依相。谓一切障染污分依他性灭处。为解脱一切障。于一切法得自在现前。清净分依他性显故。二白法自体相。六波罗蜜满足得十自在。谓命自在心自在众具自在。此陀那波罗蜜满足故。业自在生自在。尸罗波罗蜜满足故。胜解自在。羼提波罗蜜满足故。愿自在。毗离耶波罗蜜满足故。神力自在。五通所摄禅波罗蜜满足故。智自在法自在。般若波罗蜜满足故。三无二相。谓有无无二相故。一切法无所有。此空相不无故。有为无为无二为相。非业烦恼所为。然似有所为自在显示故。一异无二相。于中一切诸佛依止无差别。然无量身相续证正觉故。此中有偈

  我取无有故　　依止无差别
  前后次第证　　假名说差别
  性行别非虚　　具无初无别
  非一亦非多　　无垢依止故

四常相谓真如清净为相。本愿所引佛事不休息故。五不思议相。此真如清净唯自证知。世间譬喻不可得。非分别所行故

释曰。此郁陀那偈中。谓相得等。此中相者。即法身相有五种。应知转依相。谓一切障染污分。依他性灭。由染污分依他性灭故。于一切障得解脱。一切法中自在现前。清净分依他性显者。由于一切法得自在故。依他性一分清净性。即得显现。白法体相者。谓六波罗蜜圆满故。得法身十种自在。此是白法体。于中命自在者。欲得自身齐几许时住。即能显示。应知心自在者。于尔许时住。不为生死所染污故。众具自在者谓食等十种众具。诸佛如念即得。应知此三由陀那波罗蜜圆满为因。应知如偈说

  诸菩萨思惟　　若净若不净
  一切皆成善　　是为意自在

业自在生自在。由尸罗波罗蜜满故者。摄因及所生果故。又以此故身口业自在转应知。由随欲所生即彼业现前生自在者。谓生处自在转应知。由于善恶等趣。随意欲生即能生故。尸罗因名为业。尸罗果名为生。由此道理即得显其自在故。信解自在由忍波罗蜜圆满故者。诸法皆随心转故。得随所乐欲。如所乐欲一切事悉成就故。愿自在是毗离耶波罗蜜圆满果者。由精进一切发行皆究竟。一切思量事悉成就故。五通所摄神力自在。是禅波罗蜜圆满果者。由心有堪能出生神通故。智自在法自在。是般若波罗蜜圆满果者。般若力故安立阴等。及得此后一切种智。无二相中非有相者。一切法无有相故。非无相者有空自性故。有为无为无二相者。谓非有为自性。非无为自性故。于中非业烦恼所生故非有为相。亦是有为相者。于有为中已得自在。处处显示。由此义故名有为相。一异无二为相者。于法身中由依止无别。是故无异相。由无量身得至故不得为一相。于此二中不可偏说故。名无二相。此义以偈显示。我取无有故依止无差别者。于世中我取力故有身差别。于法身中无有我取故无差别。若身无差别云何有多佛前后次第。证假名说差别者。由此无量身得故。亦有差别。如此等义。更以偈说。性别者诸菩萨有众多。由此差别故发行亦异。由发行差别故有众多人。菩提资粮得圆满。是故若唯一佛。余人资粮则应虚。作具足者。诸佛具作一切众生利益事。谓安立于三乘中。若诸佛唯以佛乘安立众生。则所作佛事不具足。是故应有多佛。如生死无初佛亦如是。若唯一佛即是有初。是故非一。又彼依止无差别故。亦不得为多。即是此无垢法界依止无差别。此不一异相。由此道理即得显示常相者。三因缘故。此体常住为相。真如清净以为佛体。此即常住。由此道理得显如来常住。应知本愿所引者。由昔发愿作一切众生利益事。由此愿所引故。佛体显现。是故彼愿不虚。此即常住应知。若谓如来作众生利益事已竟者。此义不然。以所作未究竟故。即于今时有无边事。谓一切众生未般涅槃故。以此因缘故常住为相应知。虽如是等说已。彼亦不可思议应知。此不可思议因缘。今当显示。唯自证知者。诸佛自证彼体故。由彼体唯自证故。非彼觉观所能思量。于世间中亦无此比类。以譬喻知故

论曰。复次云何得最初证此法身。总相大乘法为所缘故。无分别智及彼后得智故。五相善修于一切地中。善集资粮故。破微细难破障故。金刚譬三摩提。次此三摩提。后离一切障即得转依

释曰。此中说得最初得者。由此体无生以无为故。若生即是无常。金刚譬三摩提者。此三摩提犹如金刚能破微细难破障故。即得转依者。谓由此金刚譬三摩提。能转依得法身

论曰。复次法身有几种自在而得至自在。略说有五种自在。一国土自身相好无边声。无见顶自在。由转色聚依故。二无讥嫌无量高大安乐行自在。由转受聚依故。三说一切名身句身味身自在。由转想聚依故。四变化变易引大众。引白法自在。由转行聚依故。五镜平等观作所应作智自在。由转识聚依故

释曰。此中显示自在。由转色等五聚依故得自在。于中由转色聚依故。得佛刹自在。谓显示金银等。随意显示身自在。谓于大众轮随诸众生乐欲。显示身应知。相好等自在谓随所乐欲为彼显示故。即是无边声。无见顶等自在。由转受聚依故。得无讥嫌无量高大安乐行自在者。谓于无讥嫌无量高大等安乐行中得自在行故。于中无量者。应知是种种故。高大者谓此乐超过三界乐故。应知由转想聚依故。于说名身等中得自在故。由取相想故。缘于名言等而取其相。转灭此想故。由转行聚依故。于变化变易引大众引白法等故得自在。于中变化自在者。谓随意变化应知。变易者谓变易地等。令成金等故。引大众者应知随其意引诸大众。谓引天夜叉等众故。引白法者谓如意所欲则白法现前应知。由转识聚依故。得镜智平等智正观智作所应作智。于中镜智者。所应知法虽不现前。无忘失如世间善习经书故。平等智者于通达时。于一切众生。得平等心。此即是净心。应知正观智者。如典库者。于陀罗尼三摩提门。随于何时何法作意思惟。于彼中智行无碍故。作所应作智者谓显示如从兜率陀乃至涅槃。于中显现佛事

论曰。应知法身为几法所依止。略说有三种。一种种佛住依止。此中有二偈

  得受五种自体喜　　诸佛由证自界故
  远离五喜由不证　　是故为喜应须证
  堪能事成无有量　　法味义利功德具
  诸佛恒常见无尽　　故得欢喜最无嫌

二种种受用身依止成熟诸菩萨故。三种种化身依止多为成熟诸声闻等故

释曰。应知有几法依止。法身于中种种佛住依止者。种种谓圣住天住梵住等诸住所依止故。或有人作是念。诸佛何须现化身。以诸声闻不证此故。离于五喜。谓诸声闻等不能证此法身。则远离五种欢喜。是故为喜。应须证者。谓若欲求此欢喜取于证者。当勤修方便也。此五种欢喜以第二偈显示。堪能事成无有量。法味义利功德具者。于中法身有堪能无量故。无量人得正觉者。皆悉堪能平等应知。由得见此堪能无量故生于欢喜。及事成亦无量者。若一佛作众生利益事。即是一切佛事。由诸佛多故事亦无量。由见此故生于欢喜。法味者由见了修多罗祇夜等十二部经法故。生胜欢喜。义利功德具者。谓财利具成及功德具成。于中财利具成者。谓随所思念即得具足应知。功德具成者。谓十力十八不共法等具成应知也。故得欢喜最无失者。最者过三界欢喜故。无失者及习气烦恼灭故。应知诸佛恒常见无尽者。见此次前所说四种欢喜。乃至穷生死后际无有灭尽。虽入无余涅槃亦无尽。是故诸佛别得最胜欢喜。非余声闻。法身亦为受用身所依止。何因缘得成受用身依止。若离此入地已上诸菩萨不得成熟。亦为化身所依止。何因缘得成化身依止。多为成熟诸声闻故由下愿乐诸声闻等。若离此不得成熟故。言多为者亦摄信行地诸菩萨应知

论曰。应知有几佛法摄法身。略说有六种。一清净摄阿梨耶识转已。得此法身故。二果报摄。色根转已得果报智故。三乐摄转欲行等乐已得无量智乐故。四自在摄。种种业所摄自在转已得一切世界无碍神通智自在故。五世流布摄。一切见闻觉。知世流布言说转已得令一切众生心喜正说智自在。故六拔济摄。拔济一切灾横过失转已得拔济一切众生灾横过失智故。此等六种佛法。摄取诸佛法身

释曰。若有法能摄法身。今当显示。转何法故得此法身。阿梨耶识转已得法身故者。谓得法身及清净故。此法身清净。名清净摄。果报摄者即是果报所摄佛法。色根转者。谓眼等色根转故。得果报智者。谓转彼色根得果报智故。乐摄中欲行等乐转者。谓世间欲行转已得佛法乐故。得无量智故者。即是游于种种乐故。自在摄中种种摄业转者。如世间种种业。谓田作兴生等。转此已得于一切世界中无障碍神通智故。世流布摄者。谓世间见闻觉知等流布转已。于见闻等中得自在。由得欢悦一切众生智故。拔济摄者。如世间王法苦恼事起。或以亲友力财物力而得拔济。转此已得拔济一切众生一切苦恼智。此拔济智离一切过失故

摄大乘论释论卷第九摄大乘论释论卷第十

        世亲菩萨造

        隋天竺三藏笈多共行矩等译

    智胜相胜语第十之二

论曰。此诸佛法身。为说差别。为说无差别。依止意用及业无异故。不可说差别。无量正觉故有差别。如法身受用身亦尔。意用及业不异故无差别。依止有差别。无量依止转故。变化身亦如受用身应知

释曰。无量依止转故者。诸菩萨有无量依止。由此受用身显现故。是故意用及业无差别。然身事有差别于中意用无差别者。谓安乐一切众生意应知。业无差别者。谓显示证正觉般涅槃等业。此业无别应知

论曰。应知法身与几功德相应。与最清净四无量解脱胜处一切处无诤愿智四辩六通三十二大丈夫相。八十种好。四一切种清净。十力四无畏。三不护三念处无忘失法。拔除习气大悲十八不共佛法。一切种胜智等相应。此中有偈

  怜愍诸众生　　舍离结缚意
  不舍安乐心　　归命利益意
  解脱一切障　　牟尼胜世间
  智遍满尔炎　　归命解脱心
  能灭诸众生　　一切惑无余
  惑者共归苦　　归命离惑人
  无功用无著　　无障碍寂静
  常解一切难　　归命释难者
  所依及能依　　说言及说智
  意常无障碍　　归命善说者
  随彼等语言　　行往还出离
  知彼诸众生　　归命善教者
  诸众生见佛　　缘彼大人相
  但见得生信　　归命生信者
  执持住处舍　　变化及变易
  三昧智自在　　归命到彼岸
  方便归依净　　及大乘出离
  障隔诸众生　　归命摧魔者
  能说智及断　　出离障碍事
  外道不能坏　　归命自他利
  说法制大众　　远离二烦恼
  无护无忘失　　归命摄众者
  利益诸众生　　所作不过时
  所作常不虚　　归命无忘失
  行住一切处　　无非圆智业
  一切时遍知　　归命实义者
  于昼夜六时　　观察诸世间
  与大悲相应　　归命利益意
  修行及证得　　智慧与作业
  胜一切二乘　　归命最胜者
  三身大菩提　　具得一切种
  归命断众生　　一切处疑惑
  无畏无过失　　无浊无住处
  于诸法无动　　归命无戏论

诸佛法身与如是等功德相应。复有自性因果业相应行事等功德。是故诸佛法身是无上功德应知。此中有偈

  成就最胜义　　出过一切地
  至诸众生上　　解脱诸众生
  无尽无等德　　相应世间见
  众轮亦不见　　一切天人等

释曰。法身与如是等功德相应。复有自性因果业相应行事等功德者。于中法身自性者。以成就最胜义显示。成就最胜义者。谓清净真如。此是佛自性故。因者显示出过一切地。谓以修一切地得彼佛体故。至诸众生上者。此显示果。显此果在一切众生上故。解脱诸众生者。此显示业。佛是救脱一切众生故。相应者。无尽无等功德相应以此显示。于中世间见者。谓见化身故。诸大众轮见者。谓见受用身故。此等诸天人亦不见者。谓此诸大众轮不见自性身。此等显示佛身行事差别

论曰。然此诸佛法身甚深最甚深此甚深云何可见此中有偈

  诸佛不生生　　无住处为处
  诸事无功用　　受用第四食
  无差别无量　　无数量一业
  不动及动业　　诸佛三身具
  无有证正觉　　非不一切觉
  念念不可量　　有非有所显
  无欲无离欲　　而亦与欲俱
  既知欲非欲　　得入欲法如
  诸佛过诸阴　　而亦住阴中
  与彼不一异　　不舍而寂灭
  诸佛同事业　　犹如大海水
  我已现当作　　他利无是思
  诸罪者不见　　如破器中月
  普遍一切世　　法光犹如日
  或显示正觉　　或涅槃如火
  不生亦不有　　如来常住身
  佛于非正法　　人及恶趣中
  于非梵行法　　自住最胜者
  行于一切处　　而亦无所行
  一切众生见　　然非六根境
  伏断诸烦恼　　如咒制诸毒
  以惑至惑尽　　佛具一切智
  烦恼即菩提　　生死寂灭体
  有大方便故　　如来不思议

此即是十二种甚深。应知所谓生成业住甚深。安立数业甚深。正遍觉甚深。离欲甚深。灭阴甚深。成熟甚深。显现甚深。显示正遍觉般涅槃甚深。住甚深。显示自体甚深。灭烦恼甚深。不思议甚深

释曰。今当显示大乘甚深。即是显示十二种甚深。于中生成业住等甚深。以一偈显示。诸佛不生生者。此显生甚深。诸佛以不生为生故。无住处为处者。此显成长甚深。诸佛不住生死涅槃处故。所作无功用者。此显业甚深。诸佛以平等为业。由无功用故所作之业一切处平等受用。第四食者。此显住甚深。由四种食是不净身依止住处。诸佛非不净身依止住处。由段等四食。是欲界众生不清净身依止而住故。净不净身依止住处者。谓色无色界众生。此等于下地烦恼则净。于上地烦恼则不净。此诸净不净身。唯有触意思识等三食。离于段食。彼身得住。彼身唯以三食得住故。净身住持者。即是段等四食。于声闻缘觉等此等净身。若住于世由此住持故。示现住持者。即彼段等四食示现。即以此住持故。诸佛食之。此为第四。由示现以此为住持故。诸佛世尊得受众生所施令生欢喜。积聚福德故。无有食事。复有说言。诸佛食时诸天接取施余众生。以此因缘令彼众生当得菩提故。此等一偈同一甚深。又诸佛生相有十因缘应知。一愚痴别异故。二种种别异故。三摄持自在故。四住自在故。五舍自在故。六无二相故。七唯影像故。八如幻故。九无住为住故。十云义成就故。有十因缘故如来不住生死涅槃应知。一非知故。二非灭故。三非有故。四非有自性智故。五无得无分别故。六离心故。七得心故。八平等心故。九不得于物故。十非不得故。有十因缘故诸佛无功用而佛事成就。一灭离故。二无依止故。三应作无功用故。四作者无功用故。五作业无功用故。六无所有无功用故。七本昔无差别故。八所作究竟故。九作事未究竟故。十由熟修一切法中自在故。有十因缘诸佛受用于食。一示现以食住持身故。二令诸众生聚集福德故。三为示现同众生作故。四为令顺学正食故。五为令顺学知足故。六为令他发起精进故。七为成熟善根故。八为显示自身无染着故。九为住持尊重业故。十为圆满本愿故

次显示安立数业甚深偈。无差别无量者。此是安立甚深。于中无差别者。法身无别异故。无量者。无量身证菩提故。无数量一业者。此是数甚深。乘虽无量诸佛一业故。不动及动业诸佛二身具者。诸佛虽三身相应。然受用身业则牢住。化身业则不牢住。此即是甚深故

次显示证正觉甚深偈。无有证正觉者。人及法无所有故。非不一切觉者。由假名说一切觉故。此正觉云何。偈言念念中无量。以此显示。由于念念中无量人得正觉故。有非有所显者。此显真如于诸有非有为义故

次显离欲甚深偈。无欲无离欲者。欲无所有故无所染。既无染故亦无离。何以故。欲若是有可有离欲故。而亦与欲俱者。由唯断上心欲留随眠欲故。若不留随眠欲。即同声闻入涅槃故。既知欲非欲得入欲法如者。谓欲分别中。了知非欲。即入欲法真如故

次显示灭阴甚深偈。诸佛过诸阴而亦住阴中者。谓已过色等五取聚。但住于无所得法如聚中故。与彼不一异者。佛已舍彼分别聚。然与彼非异。以即住彼法如中故。又非不异由虽是化身分别即成清净境界故。不舍而寂灭者。谓不舍真实性聚即是涅槃故

次显成熟甚深偈。诸佛同事业者。诸佛作业平等。皆为成熟众生故。此何所似犹如大海水。如水入海为鱼鳖等受用。如是既入法界同为成熟众生故。我已现当作他利。无是思者。无有一念思惟。我于三时利益众生。然似摩尼天乐无有功用。而作众生利益事成

次显示显现甚深偈。若世间不见诸佛。又说诸佛是常住身。既有常住身。何故不见偈言诸罪者。不见如破器中月故。如器破水则不住。以水不住故月则不现。如是诸众生等无有奢摩他滋润故。佛月不现。水譬三摩提。体滋润故。普遍一切世法光犹如日者。虽不见佛亦为作佛事。由说修多罗等法犹如日光。以此为佛事。亦于世间得成熟众生

次显显示正遍觉般涅槃甚深偈。或显示正觉或涅槃如火者。或示正遍觉。或示般涅槃。其事如火。譬如火或时然或时灭。诸佛亦尔。或有众生应以涅槃成熟。即示涅槃。应以正觉成熟。即示正觉。为解脱故如火性不异。唯一法身亦尔。应如是知。余半偈义可解

次显住甚深偈。佛于非正法人及恶趣中于非梵行法自住最胜者者。自体最胜住亦最胜。住于圣住故。此中圣住者。谓住于空故。天住者。谓住禅那故。梵住者。谓住慈等四无量故。非正法者。谓诸不善法。诸佛于诸不善法中住于空住。是故佛住圣住。于人道及恶趣众生攀缘而住。入于禅那。是为天住。于非梵行法中自体最胜住。如是等空住者即是自体

次显显现自体甚深偈。行于一切处而亦无所行者。后得智于善不善等中差别智生。若无分别智即无所行。化身于一切处行非余身也。第二义中一切众生见者。谓即此化身一切处得见故。然非六根境者。即此化身若为地狱众生所见时。为教化彼故生于彼处。非化身自性。彼地狱众生见时。谓即是地狱身。是故非彼地狱等众生六根境界

次显灭烦恼甚深偈。伏断诸烦恼如咒制诸毒者。谓现行烦恼。在菩萨位时不断烦恼。由有随眠惑在。如咒制诸毒者。譬如被毒咒力制之则不为害。烦恼亦尔。以智知故则不为恼。以惑至惑尽者。谓以留随眠惑故不同声闻入般涅槃。佛具一切智者。谓诸佛烦恼尽时。即得一切智具故

次显不思议甚深偈。此等烦恼即是彼菩提分是集谛故。生死等苦谛即是涅槃故。如来一切所说皆不可思议。如前所说三种因缘。谓唯自证知等非思量境界

论曰。诸菩萨念佛法身。以几种念而念。略说诸菩萨修习念佛有七种。一诸佛于一切法得自在应如是修习念佛。于一切世界得无障碍神通智故。此中有偈

  障碍及阙因　　众生界普遍
  二种决定故　　诸佛无自在

二如来身常住。真如无间离垢故。三如来最无讥嫌。离一切烦恼障智障故。四如来无功用。无有功用而不舍一切佛事故。五如来大受用。清净佛土为大受用故。六如来无染污。生在世间不为一切世法所染故。七如来大义利显示证正觉入涅槃等。未成熟众生而成熟之。已成熟者而解脱之。此中有偈

  随逐于自心　　常具净相应
  无复诸功用　　施与大法乐
  无依止遍行　　平等于多人
  一切一切佛　　智人如是念

释曰。诸菩萨若念诸佛法身。如七相修念。今当显示此修义。于中于一切法得自在者。以神通故于一切法得自在。由诸佛于一切世界中得无障碍神通。非如声闻等有障碍故。若诸佛于一切法得自在者。何故一切众生不得涅槃。此义以偈显示。有因缘故。不能令得涅槃故。说障碍及阙因等偈。此中障碍者。由业障等所碍故。虽无量诸佛。不能令其得涅槃。是故诸佛于彼众生无有如上自在。阙因者。谓无涅槃法性。此为阙因。由无彼性故。二种决定故者。决定有二种。一作业决定。二受报决定。然于此二种决定。诸佛无有自在。于中报障者。谓痴钝等应知。受报决定者。谓决定趣地狱等。报及受报有此差别。常住身者。即是真如无间离垢。此如常住以此为身。故名如来常住身也。如来大受用者。诸如来等即以清净佛刹为大受用应知。大义利者。诸佛大义利体。谓成熟解脱。未成熟众生以菩提涅槃而成熟之故应知。余四相念佛义可解。此七种念佛更以二偈显示。随逐于自心等偈中说七相成就。诸菩萨最初念诸佛果报。皆随逐自心。此亦即是常净相应者。谓善。是故最无讥嫌无功用者。以无功用作诸佛事故。施与大法乐者。即是清净佛土应知。无依止遍行者。若有依止作行则苦。是故诸佛无所依止而行教化。以如是故利益多人。由多人所共故诸菩萨应念此果报

论曰。复次云何应知。诸佛刹土清净相。如百千偈修多罗菩萨藏缘起中说。婆伽婆住于最胜光明。七宝庄严故。放大光明普照无量世界故。住于无量妙庄饰处故。周圆无限故。超过三界行处故。出世上上善根所生故。最清净自在识相故。如来住持故。诸大菩萨所住故。无量天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽人非人等所行故。大法味悦乐所持故。安住一切众生一切利益事故。离一切烦恼逼迫故。离一切魔故。胜过一切庄严如来庄严住持故。大念慧行出生故。大奢摩他毗钵舍那为乘故。大空无相无愿入处故。无量功德众庄严大宝莲华王所建立故。游于大宫殿中故。如是等句显清净佛刹。所谓色类具足。相貌具足。量具足。方所具足。因具足。果具足。主具足。助伴具足。眷属具足。住持具足。业具足。顺摄具足。无畏具足。住止具足。道路具足。乘具足。门具足。依持具足。故如是等皆得显现。又彼清净佛刹中所有果报一向净妙一向乐一向无嫌一向自在

释曰。如百千偈修多罗缘起中说。佛刹清净。彼清净佛刹。以何等胜功德显示。前二句显色具足。谓七宝等。七宝中金银琉璃珊瑚马瑙并是石所摄。末逻羯多(玉之类缘色)亦是石所摄。应知赤宝者谓赤真珠。从赤虫所出。由于中出珠故。此珠宝于一切宝中最胜故。光明照无量世界者。即前所说七宝出生光明故。此是色具足第二句。次一句显庄严具足。次一句显量具足。次一句显方所具足。此等以何为因。出世无分别及彼出世无分别后得二种善根所生诸善为因。此即是因具足。此亦有一句。次一句显果具足。彼佛刹中以最清净识自在转为相故。次一句显主具足。次一句显伴具足。次一句显眷属具足。于此眷属具足中。所言摩睺罗伽亦摄在龙中。于净土中若能住持身此是住持具足。亦以一句显示。以此为食已复作何业。但成就一切众生一切利益事。亦以一句显示顺摄具足。由净土中无烦恼无苦故。亦以一句显示彼中无有怨对之怖。由无魔故。于彼佛土中无阴魔烦恼魔死魔天子魔。是故无有怖畏。此一句即是无畏具足。次一句显住处具足。复以何道得入彼清净佛刹。于大乘中闻思修智为体。即是大念慧行如其次第。此一句显示道具足。以何为乘。于奢摩他毗钵舍那而趣于彼。此一句显乘具足。以何门得入彼土。谓于大乘中空无相无愿为门故。此一句显门具足次一句显依持具足。犹如大地以风轮为依持。彼清净佛土以何为依持。以无量功德大宝莲华为依持。此句显依持具足。彼净土中果报一向净妙者。由彼中无有粪秽等不净物故。一向乐者。彼中唯有乐受。无有苦及无记等受。一向无嫌者。于彼中无有不善及无记故。一向自在者。以自心力不待因缘故

论曰。复次此诸佛法界一切时有五业应知。一救护一切众生逼恼中业。谓聋盲狂等逼恼。唯见即得救护故。二救护恶道业。从不善处拔出安置善处故。三救护非方便业。外道等以非方便求于解脱。开悟安置于佛正教中故。四救护我见业。为令超过三界教示以道故。五救护乘业。谓发行余乘诸菩萨。及不定性声闻等。安立令修行大乘故。此五种业是一切诸佛平等业应知。此中说偈

  因依事念行　　别故业有异
  世间有此异　　导师无彼别

释曰。诸佛法界者。即是法身。彼有五业应知。救护一切众生逼恼业者。由见佛故盲等即得眼等故。救护恶道业者。此业为救护恶道故。谓于不善处移诸众生置于善处故。救护我见业者。说超过三界道名为救护。世间名为三界。即说此为我见。余二句义可解。此等五业是一切诸佛平等业应知。此等义以偈显示。若诸佛平等业。世间众生不平等业。此等因缘。以因依事念行等一偈显示于世间中因异。由地狱因别。人天因别。乃至饿鬼因别。是故业有异。依异者。由依止身别异故。作业有异。事异者。或有兴生或种田。此等业由此等事异故世间业体异。念异者。念名意欲。由此意欲异故。世间业亦有异。行异者。即是有为行。由所作有为行业异故名为异。谁有此异。偈言世间有此异故。导师无彼别者。谓佛一切作事无复功用。则无因等五异。是故诸佛作业无有差别故

论曰。如是诸佛法身功德具足相应。不与声闻辟支佛共。若尔者以何意故说一乘。此中有偈

  为引摄一分　　及安住余者
  于此不定性　　说正觉一乘
  法无我解脱　　等故性不同
  得二意涅槃　　究竟唯一乘

释曰。此二偈显说一乘意。为引摄一分者。谓不定性声闻。为引入大乘故。云何令彼不定性人于大乘中而般涅槃故。及安住余者。不定性菩萨。为令彼安住大乘。云何令彼不退舍大乘。于声闻乘而般涅槃。为此义故佛说一乘不定性。二句义可解。法无我解脱一偈。此中显别意说一乘。何者别意。法平等故。无我平等故。解脱平等故。于中法平等者。法即是真如。此如平等。一切声闻等同趣彼如。故名为乘。以平等故名一乘。无我平等者。无有人我。既无人我。仍言此是声闻此是菩萨者不应道理。由依此无我意故说为一乘。解脱平等者。声闻等亦同解脱烦恼。依此意故说为一乘。何以故。由世尊说解脱与解脱等无有各各相故。性别者。由根性有差别故。于乘不决定性声闻亦得成佛。由此意故说为一乘。二意得者。得二种意故。平等意者。由一切众生一体摄故。我即是彼。彼即是我。如是摄已此得正觉。即是彼得正觉。依此意故说为一乘。第二意者。如法华经中为声闻授记。得此意故。谓但得诸佛法。如平等意不得法身。由得此平等意故。作如是念。诸佛法如。即是我等法如也。复有别义。于彼大众中有诸菩萨。与诸声闻同名授记得涅槃。如佛说我念过去无量百千数。于声闻乘般涅槃。由此意故说一乘。以见诸众生。应以声闻乘而调伏者。现于彼般涅槃故。究竟者。此即是一乘。以究竟无有别趣故。然有差别。以声闻乘等异于佛乘。由此意故世尊说为一乘

论曰。如是一切诸佛同一法身而有多佛。此以何因缘可见。此中有偈

  一界无有二　　一时多成就
  次第非道理　　故成有多佛

释曰。由此因缘一切诸佛平等法身。或一或多应须了知。次当显示。于中应知一者。法界平等故。诸佛以此为体。由法界平等故诸佛是一应知。复次应知一者。于一时一世界中无有二佛并出故。是故唯一应知。复次若多若一如偈中显示。所谓一界等。一界无有二者。此一句显示一义。谓于一世界中无有二佛并出世故。余句显示众多佛一时多成就者。于一时中有无量诸菩萨。同修资粮成满此等。若已福智资粮成满。而不得佛果。此等资粮则为虚弃。由有众多菩萨同修资粮成满故。有多佛应知。次第非道理者。无有次第得正觉义。若修菩提资粮时待次第成满。可得证正觉时亦有次第。然由众多菩萨修资粮无有次第故。证正觉时亦无次第。是故有众多佛

论曰。于法身中诸佛非毕竟涅槃。非非毕竟涅槃云何可见。此中有偈

  解脱一切障　　所作未究竟
  佛毕竟涅槃　　亦不般涅槃

释曰。复有别部师说。诸佛无有毕竟涅槃。有别部声闻乘人则言。有毕竟涅槃。有如是等二意。以偈显示。解脱一切障等者。于中若解脱烦恼障智障。由此意故。言诸佛毕竟涅槃由所作事未毕竟。未成熟者成熟之。已成熟者解脱之。应作此等事。由此意故不毕竟涅槃。若异于此则同声闻涅槃。由毕竟涅槃故。所作誓愿便则无果

论曰。何故受用身不即如是成自性身。有六因缘故。一色身显示故。二无量大众轮中差别显示故。三随彼欲乐应现自体不定显示故。四随异异显现自体变动显示故。五菩萨声闻天等种种大众和杂处和杂显示故。六阿梨耶识及生起识等转依不相应显示故。是故受用身非自性身义成

释曰。今次显示由此道理故自性身不成受用身。一色身显示者。谓佛色身非即法身。由所见色非即法身故。是故受用身不是法身。又此受用身有差别。诸佛大众轮差别故。法身则无如是差别。由此道理不相应故。受用身不成自性身。又随其所欲现受用身故。如修多罗说。有人见佛黄色。有人见佛青色。如是等具说。受用身则有如是等体相不定。若言自性身体性有不定。则不应道理。自性身由有如此不相应故。非受用身。即自性身。又复受用身有一众生。初见余色。后即于彼身复见余色。若法身自性动异。则不相应。是故受用身不成自性身。又复受用身常与天等诸众和杂。自性身如是和杂。则不相应。是故受用身不即自性身。又复由阿梨耶识转依已。即得自性身。若即此自性身是受用身者。生起识转依已。复得何身。是故受用身不即自性身。由此六种不相应故。不得成一

论曰。何因缘故化身亦非自性身。有八因缘故。一诸菩萨从久远已来得不退三摩提于兜率天及人中生不成故。二于宿命书算数印工巧杂论等及受用欲行中无智不成故。三已知邪说正说法教而往诣外道所不成故。四善知三乘道而行苦行不成故。五舍万亿阎浮洲于一处证正觉转法轮不成故。六若离如是显示证正觉等方便其余皆以化身作佛事者。则应于兜率天中证正觉。七何不于一切阎浮洲中平等佛出。既不如是。以无阿含及道理可证。八与一世界中无二如来出世不相违。以有众多化佛故。言一世界者。是一四洲世界。如无二转轮王并出。此中有偈

  诸佛微细化　　平等入多胎
  一切种正觉　　为显现受生

释曰。今次显自性身即是变化身不相应义。有八种不相应。于中初不相应者。诸菩萨从久远无量劫来得不退三摩提。尚不生于兜率陀等诸天中。况复人间。是故世间所见是所化身。非自性身。复次诸菩萨已得宿命智而不知书算等事者。无有道理。是故化身为教化众生故应作此事。复次菩萨于三阿僧祇劫修行时。不知正说邪说。云何于最后证正觉时。乃能知也。是故化身非自性身。复次舍万亿阎浮洲唯于一处证正觉转法轮不应道理。若化身得成。由于一切处同时现化。是故化身非自性身。若言但一处证正觉余处显示化身摄眷属者。何故不即于兜率陀天中住证正觉。于一切四洲中示现化身也。若言一切四洲中不证正觉者。此义不成。以无有阿含及道理证说。于一佛刹中随于一四洲中不证正觉。若汝言若尔者与修多罗相违。何以故。以经说无二佛并出者应知。彼经中所说以转轮王为喻。如无二转轮王并出者。此说于一四洲中无并出。非一佛刹也。二佛不并出亦尔。所言世界者。谓一四洲也。此中有偈显示正觉。诸佛微细化等即是其义。佛于住兜率陀天宫时。若下入胎即于彼时。若与上座舍利弗等眷属俱者应知。彼等皆是化所施设。如是施设已。即得显示于一切相中证正觉

论曰。为一切众生故。发愿及修行成大菩提。毕竟涅槃不应道理。发愿及修行无果报。是过失故

释曰。此中显示毕竟涅槃不成义。诸佛为一切众生故发大誓愿及修行。既作如是利众生意已。随诸众生利益事作之。若于毕竟涅槃中而般涅槃。彼愿及行便为无果。若汝言如来法身常住者。受用身及化身无常。云何名常身。今成就此义故

论曰。受用身化身二身无常。云何言如来身常住。依止常住法身故。受用身变化身。此二身受报不舍故。数数化现故。如常受乐。如常施食。佛身常住应如是知

释曰。二身是常。由依止常住法身故。此二身是常。复次受用身者。不舍受用故是常。化身者。常显示证正觉般涅槃等。相续不断故是常。于此二身以譬喻显示其常。如世间言常受乐。非即得无间乐而得名为常受乐。又如言此人常施食。非即是常施。有时不施故。然得名为常施食者。二身常义亦尔

论曰。有六因缘故。诸佛世尊化身不毕竟住。一所作究竟。谓已成熟解脱众生故。二为转乐欲涅槃。意令求常住佛身故。三为转于佛所起修修。意令于甚深法正说中生觉了故。四为生渴仰。意若数见生无厌足故。五为生自精进。由知说者不可得故。六为令得极速成熟。自起精进不舍重轭故。此中有偈

  所作事究竟　　转彼寂灭欲
  为转轻佛意　　令生渴仰心
  为发自精进　　令其速成熟
  是故佛化身　　非毕竟住者

诸佛法身。虽无始时无量。为得彼故不应不策勤也。此中有偈

  佛得无异无量因　　众生于此舍精进
  此得一切非因果　　如是因断无道理

阿毗达磨大乘修多罗中。摄大乘品解释竟。阿阇梨阿僧伽造

释曰。此中有难。若法身无始时无差别无限量。以是故堪能利益众生者。何须为此故勤精进也。为遮彼难故。以偈显示。彼诸佛所得无异无量。以此为因应起正勤。是故言诸佛无始时者。一切有过。何以故。此得于一切时不成因过失故。如此断因无有道理。诸菩萨大悲在心。怜愍一切众生。犹如一子于利益众生事中。余人自作非我所为。此不应道理。余人作与不作我皆为之。应当如是。摄大乘释论。于大乘部中制述无量。胜论者阿阇梨婆薮槃豆造竟

摄大乘论释论卷第十


摄大乘论释序(十五卷成)

    No. 1595 [Nos. 1596, 1597; cf. Nos. 1592-1594, 1598]

    摄大乘论释序(十五卷成)

        大唐桑门道基撰

摄大乘论者。盖是希声大教。至理幽微。超众妙之门。闭邪论之轨。大士所作。其在兹乎。若夫实相宗极。言亡而虑断。真如体妙。道玄而理邈。壮哉法界。廓尔无为。信矣大方。超然域外。是以王城三止。宝殿三加。至人垂范。良有以也。佛去世后千一百余载。群机将扣。感而遂通。北天竺国有二开士。结师资而接武。连花萼以承芳。无著阐于纮纲。所以俊撰论本。婆薮扬其名理。所以克精注述。诸论宗归。所明各异。法华论旨。引三车而共辙。鞞沙幽致。开十住以同阶。至如此论。众名坦荡。似王路之无枝。藏识常流。譬洪川之长注。三性殊旨。混为一心。六度虚宗。俱迻彼岸。蹑十地之龙级。淤三学之夷路。涅槃无处。运悲慧之两融。菩提圆极。齐真应之一揆。言摄大乘者。摄谓能摄。蕴积苞含。摄藏名摄。言大乘者。理必绝待。假大称之。名曰大乘。其义郭周。体性该博。谓为大也所行功德。能至能证。名之为乘。论者无著菩萨之所制造。穷源尽理。清微朗畅。谓为论也。释者婆薮论师之所注解。清辩剖析。文理俱腾。其为释焉。以梁大清二年。南身毒优禅尼国有真谛三藏。道超世表。学冠群英。以法济时。来仪建业。属梁季将溃。旋路岭南。广州刺史阳山公欧阳頠。屈请停止。为菩萨戒师。世子衡州刺史欧阳纥复请翻译。有丹阳义学僧。僧宗慧恺传语笔受。任得其人。论本释论十有五卷。余以庸浅钻仰无坠。聊述所闻。以示来哲豫章郡守王钦。开皇元年五月奏此论。与迁持论不殊

    摄大乘论释序

        迁禅师江南将至徐州讲唱

夫至道弘旷。无思不洽。大悲平等。诱进靡穷。德被含生。理非偏漏。但迷涂易久。沦惑难息。若先谈出世。则疑性莫启。故设教立方。各随性欲。唐虞之前。图谍简少。姬周以后。经诰弘多。虽复制礼作训。并导之以俗法。而真假妙趣。尚冥然未睹。故迹隐葱岭已西。教秘沧海之外。自汉室受命。方稍东渐。爰及晋朝。斯风乃盛。梁有天下。弥具兴隆。历千祀其将半。涉七代而迄今。法兰导清源于前。童寿振芳尘于后。安睿骋壮思以发义端。生肇擅玄言以释幽致。虽并策分鏕。同澜比派。而深浅竞驰。照晦相杂。自兹以降。笃好愈广。莫不异轨同奔。传相祖习。而去取随情。开抑殊轸。慧恺志渐负槖。勤愧聚萤。谬得齿迹学徒。禀承训义。游寓讲肆。多历年所。名师胜友。备得咨询。但综涉疏浅。钻仰无术。寻波讨源。多所未悟。此盖虑穷于文字。思迷于弘旨。明发兴嗟。负心非一。每欲顺风问道。而未知厥路。有三藏法师。是优禅尼国婆罗门种。姓颇罗堕。名拘罗那他。此土翻译称曰亲依。识鉴渊旷。风表俊越。天才高杰。神辩闲纵。道气逸群。德音迈俗。少游诸国。历事众师。先习外典。备通书奥。苞四韦于怀抱。吞六论于胸衿。学穷三藏。贯练五部。研究大乘。备尽深极。法师既博综坟籍。妙达幽微。每欲振玄宗于他域。启法门于未悟。以身许道。无惮远游。跨万里犹比邻。越四海如咫尺。以梁太清二年方届建业。仍值梁季混淆。横流荐及。法师因此避地东西。遂使大法拥而不畅。末至九江及游五岭。凡所翻译卷轴未多。后适闽越。敷说不少。法师每怀慷慨。所叹知音者希。故伯牙绝弦。卞和泣璧。良由妙旨之曲难辩。盈尺之珍罕别。法师游方既久。欲旋反旧国。经涂所亘。遂达蕃禺。仪同三司广州刺史阳山郡公欧阳頠。睿表岳灵。德洞河府。经文纬武。匡道佐时。康流民于百越。建正法于五岭。钦法师之高行。慕大士之胜规。奉请为菩萨戒师。恭承尽弟子礼。恺昔尝受业。已少涤沈弊。服膺未久。便致睽违。今重奉值。倍怀蹈舞。复欲餐和禀德。访道陈疑。虽殷勤三请。而不蒙允遂。恍然失图。心魂靡托。衡州刺史阳山公世子欧阳纥。风业峻整。威武贞拔。该阅文史。深达治要。崇澜内湛。清辉外溢。钦贤味道。笃信爱奇。躬为请主。兼申礼事。法师乃欣然受请。许为翻译。制旨寺主慧智法师。戒行清白。道气宏壮。志业闲瞻。触途必举。匡济不穷。轮焕靡息。征南长史袁敬德。履行冲明。志托夷远。徽猷清兰。冰桂齐质。弼谐蕃政。民誉早闻。兼深重佛法。崇情至理。黑白二贤。为经始檀越。辰次昭阳。岁维协洽。月吕姑洗。神纪勾芒。于广州制旨寺便就翻译。法师既妙解声论。善识方言。词有以而必彰。义无微而不畅。席间函丈。终朝靡息。恺谨笔受。随出随书。一章一句。备尽研核。释义若竟。方乃著文。然翻译事殊难。不可存于华绮。若一字参差。则理趣胡越。乃可令质而得义。不可使文而失旨。故今所翻文质相半。与僧忍等同共禀学。夙夜匪懈。无弃寸阴。即以其年树檀之月。文义俱竟。本论三卷。释论十二卷。义疏八卷。合二十三卷。此论乃是大乘之宗极。正法之秘奥妙义云兴。清词海溢。深固幽远。二乘由此迷坠。旷壮该含。十地之所宗学。如来灭后将千一百余年。弥勒菩萨投适时机。降灵俯接。忘己屈应。为阿僧伽法师广释大乘中义。阿僧伽者。此言无著。法师得一会道。体二居宗。咏玄鉴极。凝神物表。欲敷阐至理。故制造论。唯识微言。因兹得显。三性妙趣。由此而彰。冠冕[彞-糸+分]伦。舟航有识。本论即无著法师之所造也。法师次弟婆薮槃豆。此曰天亲。道亚生知。德备藏性。风格峻峙。神气爽发。禀厥兄之雅训。习大乘之弘旨。无著法师所造诸论。词致渊玄。理趣难晓。将恐后生复成纰紊。故制释论以解本文。笼小乘于形内。挫外道于笔端。自斯以后。迄于像季。方等圆教。乃盛宣通。慧恺不揆虚薄。情虑庸浅。乃欲泛芥舟于巨壑。策骀足于长路。庶累毫成仞。聚爝为明。有识君子。幸宜寻阅。其道必然无失坠也

摄大乘论释卷第一

        世亲菩萨释

        陈天竺三藏真谛译

    释依止胜相中

    众名品第一

  智障极盲闇　　谓真俗别执
  由如理如量　　无分别智光
  破成无等觉　　灭心惑无余
  常住德圆智　　恒随行大悲
  如众生根性　　极解脱真道
  于十方界说　　能无功用心
  由无分别智　　不住于生死
  常起大悲故　　不入于涅槃
  由摄智方便　　至自他极利
  我以身口意　　顶礼佛世尊
  是无上正法　　如来自觉说
  若人能正行　　至甘露妙迹
  若诽谤此法　　没无底枉坑
  由智及信心　　顶礼真实法
  住道住果僧　　普胜一切众
  智道浴清净　　世无上福田
  片善投于中　　广大如空地
  成就世间乐　　及清凉涅槃
  我一心顶礼　　佛圣弟子众
  聪明邪慢人　　退阿含修得
  行说随自执　　正理非所证
  事弥勒菩萨　　依止日光定
  照了实法相　　无动及出世
  为我等宣说　　正法真道理
  如秋月日光　　文词遍于世
  甚深大种种　　句义依了经
  能令聪慧人　　下心起尊敬
  细密法难通　　智无著无碍
  利等八世法　　心常无染着
  无碍名称义　　通敏者恒诵
  天人普识知　　顶礼大师足
  辩说常无尽　　雨甘露文义
  依尊随分闻　　犹如乞雨鸟
  披阅决定藏　　以释摄大乘
  愿此言利益　　怖大文海人

    众名品第一之一

释曰。此品有三章。一无等圣教。二十义次第。三众名

    无等圣教章第一

论曰。摄大乘论即是阿毗达磨教及大乘修多罗

释曰。此言依何义。因何而起。依一切所知依甚深广大诸法实性。若离佛菩萨威力。何人有此功能能说此义。云何造论由此相说。若离阿毗达磨名则不知此论是圣教。为此义故。又为显经名。譬如十地经。今造此论其用云何。众生无知疑倒欲令得解。复次此论说阿毗达磨大乘修多罗名者。欲显如来法门别类。及显此论别名。言大乘者。欲简小乘阿毗达磨。何故不但说阿毗达磨名。复说修多罗名。有阿毗达磨非是圣教。复次说阿毗达磨名者。显此论是菩萨藏。复次立藏者。欲何所为。为灭自惑于大乘中。是菩萨烦恼。何以故。诸菩萨以分别为烦恼。阿毗达磨者。甚深广大法性为相。此菩萨藏凡有几种。亦有三种。谓修多罗。阿毗达磨。毗那耶。此三由上下乘差别故成二种。谓声闻藏菩萨藏。此三及二云何名藏。由能摄故。此摄何法一切应知义。云何成三有九种因别立。修多罗者。为对治他疑惑。若人于此义中起疑。为令得决定智故。立修多罗。为对治受用二边故。别立毗那耶。由佛遮有罪过受用立毗那耶。对治乐行边。由佛随喜无罪过受用。立毗那耶。对治苦行边。为对治自见取偏执故。别立阿毗达磨。能显无倒实法相故。复次为说三种修学故。别立修多罗。为成依戒依心学故。别立毗那耶。何以故。若人持戒则心无悔。由无悔等能次第得定。为成依慧学故。别立阿毗达磨。何以故。能简择无倒义故。复次正说法及义由修多罗。成就法义由毗那耶。何以故。若人修行惑毗那耶得通达此二法及义法义。决定胜智由阿毗达磨。由此九因缘故立三藏。此三藏通用云何。为解脱生死是其通用。云何得解脱。能熏觉寂通故得解脱。由闻思三藏故能熏。由熏故觉。由觉故寂。由寂故通。由通故得解脱。若略说三藏各有四义。菩萨若能了别此义则具一切智。若声闻能了一句一偈义则至流尽。云何一一藏各有四义。修多罗四义者。一依二相三法四义。能显示此四义故名修多罗。依者是处是人是用。依此三佛说修多罗故名依。相者谓真俗二谛相故名相。法者阴界入缘生谛食定。无量无色解脱制入遍入。助道无碍辩无诤等故名法义者所作事故名义。生道灭惑是事。阿毗达磨四义者。一对二数三伏四解。对者是法对向无住处涅槃。何以故。能显谛道门故名对。数者诸法中随一法。或以名或以别相或以通相等。数数显此一法故名数。伏者此法能伏诸说。立破二能由正说。依止等方便故故名伏。解者由阿毗达磨修多罗义易解故名解。毗那耶有四义者。一由罪过。二由缘起。三由还净。四由出离。罪过者谓五篇七聚罪。缘起者或四或八。四者一无知二放逸三烦恼炽盛四轻慢。八者一由心不由身口。二由身不由心口。三由口不由身心。四由心身不由口。五由身口不由心。六由心口不由身。七由身口心。八不由身口心。还净者由善心不由治。罚善心者如本受持对治。出离者有七事。一各各发露遮相续。二受与学罚。三先制后开先已制戒。后由别意故开。四更舍若大众聚集同意如本。更舍先犯罪人是时还净。五转依比丘比丘尼转男女二根若不共罪。六如实观由四种法郁陀那观察诸法。又如对治法相。恒观察自罪。七法尔得若见四谛小随小罪不更故犯。由法尔所得。复次毗那耶有四义应知。一人。佛世尊依此立戒。二立制。已说过失大师集众立学处。三分别。已略立制更广解释。四决判。此立制中云何犯罪。云何不犯。今当释本文

论曰。佛世尊前

释曰。欲显恭敬及无异言

论曰。善入大乘句义菩萨摩诃萨

释曰。已得陀罗尼等功德。由此功德于文句及义善能摄持。又能如理显说故名善入。何故但言菩萨摩诃萨而不说名。欲显诸菩萨摩诃萨众。通有此能。何故说两名。欲显具足二行

论曰。欲显大乘有胜功德依大乘教

释曰。唯大乘中有胜功德。余乘中无。为明大乘不共德故。言欲显大乘有胜功德依大乘教

论曰。说如是言诸佛世尊有十胜相。所说无等过于余教

释曰。此言欲何所明为显大乘有胜功德。为实有及利他故。诸佛世尊如十号中解

论曰。十胜相者

释曰。由依止等十相异故胜。十义为因言说为果。以义胜故所说无等

论曰。一应知依止胜相

释曰。应知者。谓净不净品法。即是三性。此三性依止三性因。即是胜相。由此依止胜相。如来言说亦胜。即是阿黎耶识依止。即是胜相。譬如石子乃至智果胜相亦如是

论曰。二应知胜相

释曰。应知胜相者。谓应知自性或应知即是相

论曰。三应知入胜相

释曰。应知谓三性入者。谓能成入及所成入即是唯识

论曰。四入因果胜相

释曰。入唯识因即是施等世间六波罗蜜。在愿乐位中。入果即入唯识。后六波罗蜜在通达位中。转成果名出世间

论曰。五入因果修差别胜相

释曰。入因果即世出世六波罗蜜。修者谓四德数习此修地。地不同故名差别。即是欢喜等十地

论曰。六于修差别依戒学胜相

释曰。谓于修差别诸地中戒学。依戒菩萨修观。即十地中菩萨一切戒。于诸恶法无复作心

论曰。七此中依心学胜相

释曰。学义如前解。心即是定。定以一心为体。依一心修习。谓一切菩萨定名依心学

论曰。八此中依慧学胜相

释曰。为能得果名依慧。以慧为依止。发修行心。是依慧即是无分别智

论曰。九学果寂灭胜相

释曰。谓灭差别有三种。一最胜。二品类。三自对解脱定智。障灭即是无住处涅槃

论曰。十智差别胜相

释曰。谓已离一切障智。智即无分别智。名对治道差别。即佛如来智已离一切随眠障。此智无分别智差别

论曰。由此十义胜相。如来所说过于余教。如此释修多罗文句。显于大乘真是佛说

释曰。云何能显。由此略释文句显十义。于小乘中无唯大乘说

论曰。复次云何此中略释能显大乘胜于余教。令此略释显斯十义。唯大乘有小乘中无。何者为十。谓阿黎耶识说名应知依止相三种自性。一依他性。二分别性。三真实性。说名应知相。唯识教说名应知入相。六波罗蜜说名入因果相

释曰。何以故。由唯识道得入三性愿乐位。六波罗蜜虽是世法。能引出世法。能生唯识道故。说是入三性因。菩萨已入地。出世清净六波罗蜜。即是入三性果

论曰。菩萨十地。说名入因果修差别相

释曰。出世十种菩萨地。是名入因果修差别

论曰。菩萨所受持守护禁戒。说名于修差别戒学相。首楞伽摩虚空器等定说名心学相。无分别智说名慧学相。无住处涅槃说名学果寂灭相。三种佛身。自性身应身化身。此三说名无分别智果相

释曰。于地中有三种修观。说名三种依学。此学果即是灭。谓灭三障。无分别智名依慧学。此智若约声闻无四倒分别。名无分别。若约菩萨无一切法分别。名无分别。二无分别异相。如此三种佛身是无分别智果。若离自性身法身不成。譬如眼根。若离法身应身不成。譬如眼识离根不成。应知此二由能依所依故得相应。若离应身。已入大地菩萨无受用法乐。若无受用法乐。菩提资粮不具足。譬如见色。若离应身化身不成。若无化身诸菩萨在愿乐位中。声闻瘦涩愿乐初发修行。皆不得成。是故决定应有三身

论曰。如此十种处唯大乘中有。异于小乘故说第一

释曰。此十法是无上菩提因。次第相引乃至无上菩提

论曰。佛世尊但为菩萨说此十义

释曰。大乘但是佛说。小乘则共说。大乘但为菩萨说不为二乘说。由此三义故胜小乘

论曰。故依大乘诸佛世尊有十胜相。所说无等过于余教。复次云何此十胜相所说无等能显大乘。是如来正说遮小乘决非大乘。于小乘中未曾见此十义。随释一义但见大乘中释。复次此十义能引出无上菩提。成就随顺不相违

释曰。三义证十义能引无上菩提。以是无上菩提因故。成就者若约圣教及正理。简择思惟此十义成就。不可破坏譬如已见导师所说道相。随顺者若人观行在修位中。此十义随顺修观而住。譬如导师所说道随顺而住。不相违者于十地中无障因。譬如导师所说道中无劫盗虎狼等障。复有地地中生死涅槃不相妨碍。是故十义能引无上菩提

论曰。为诸众生得一切智智

释曰。由此十义具足三德。谓无等境无等行无等果。若人闻思修此。必得无上菩提故。言为诸众生得一切智智

论曰。而说偈言

  应知依及相　　入因果修异
  三学及果灭　　智无上乘摄
  十义余处无　　见此菩提因
  故大乘佛言　　由说十义胜

    十义次第章第二

论曰。云何十义如此次第说。菩萨初学应先观诸法如实因缘。由此观故于十二缘生应生聪慧。次后于缘生法应了别其体相。由智能离增益损减二边过失。如此正修应通达所缘如实诸相。次后从诸障应解脱。次心已通达应知实相。是先所行六波罗蜜。应更成就令清净无复退失。由依意内清净故。次内清净所摄诸波罗蜜。依十地差别应修随一三阿僧祇劫。次菩萨三学应令圆满。圆满已是学果涅槃及无上菩提。次后应得修。十义次第如此。此次第说中一切大乘皆得圆满

释曰。此十义境界有次第。正行有次第。果有次第。由观此次第故。立十义次第。复次若人已了别诸法因。于十二缘生则得聪慧。何以故。由果从因生。不从自在天等不平等因生。亦不无因生。是故立因果二智。次是法从因生菩萨应识其相。何者为相。分别性实无有体。执言是有名为增益。实有真实性。执言是无名为损减。增无损有是名二边。聪慧能离此二边。次所执唯有识。由此智故是相应可通达。由此通达无复障碍。次随顺入唯识。世间六波罗蜜依俗谛。得依真谛清净意所摄。出世六波罗蜜亦应学。次于十地中随差别应修习。各三阿僧祇劫。不同声闻修得。何以故。声闻于三生中下对治种。成熟对治道。对治道成熟故。于第三生中。解脱三界得阿罗汉果。次此差别修中。戒等三学应令圆满。次三学果涅槃烦恼障智障等灭。无上菩提及三身此等应觉故。说如此次第。若立大乘不出此法。何以故。若欲释缘生义即入阿黎耶识中。若欲释法相即入三性摄。若欲释得即入唯识中。若欲释因果即入唯识观处。若欲释地即入因果处。若欲释三学即入十地处。若欲释灭即入三学处。若欲释无上菩提及三身。即入无住处涅槃摄。若说佛体及因果其数如此。故说次第复有别释。此十义能引无上菩提。生无虚无分别智故名成就。与四道理及三量不相违故名随顺。非先随顺后相违。如偈言

  能持爱及悲　　随顺于善故
  非黑白我见　　有益亦有损

故名不相违。能生一切智智者。于一切法无间如理如量智生故。复有别解以后释前

    众名章第三

论曰。此初说应知依止。立名阿黎耶识。世尊于何处说此识。及说此识名阿黎耶。如佛世尊阿毗达磨略本偈中说

  此界无始时　　一切法依止
  若有诸道有　　及有得涅槃

释曰。今欲引阿含证阿黎耶识体及名阿含。谓大乘阿毗达磨。此中佛世尊说偈。此即此阿黎耶识界。以解为性。此界有五义。一体类义。一切众生不出此体类。由此体类众生不异。二因义。一切圣人法四念处等。缘此界生故。三生义。一切圣人所得法身。由信乐此界法门故得成就。四真实义在世间不破。出世间亦不尽。五藏义。若应此法自性善故成内。若外此法虽复相应。则成[穀-禾+卵]故约此界。佛世尊说比丘。众生初际不可了达。无明为盖贪爱所缚。或流或接。有时泥黎耶。有时畜生。有时鬼道。有时阿修罗道。有时人道。有时天道。比丘。汝等如此长时受苦。增益贪爱恒受血滴。由此证故知无始时。如经言。世尊此识界是依是持是处恒相应及不相离不舍智。无为恒伽沙等数诸佛功德。世尊非相应相离舍智。有为诸法是依是持是处故。言一切法依止。如经言。世尊若如来藏有由不了故。可言生死是有故。言若有诸道有。如经言。世尊若如来藏非有。于苦无厌恶。于涅槃无欲乐愿故言及有得涅槃。复次此界无始时者。即是显因。若不立因可言有始一切法依止者。由此识为一切法因故。说一切法依止。若有诸道有及有得涅槃者。此一切法依止。若有是道则有果报。亦有由此果报众生受生。易可令解邪正两说分别有异。后后能得上品正行应得胜德。由烦恼依止故生极重烦恼及常起烦恼。是果报等四种差别名依止胜。能翻此四种名依止下劣。生死中不但道等非有。涅槃义亦非有。何以故。若有烦恼则有解脱。应知依止中复有阿含。能证阿黎耶识名

论曰。阿毗达磨中复说偈言

  诸法依藏住　　一切种子识
  故名阿黎耶　　我为胜人说

释曰。诸法依藏住者。第二句释第一句。谓一切种子识。由烦恼业故变。阿黎耶识相续。前果报后成因。故名阿黎耶者。显义证名以名目识。我为胜人说者。胜人谓诸菩萨。是菩萨境界依止及能障菩萨道故。为菩萨说

论曰。此阿含两偈证识体及名。云何佛说此识名阿黎耶

释曰。此语欲显立名之因

论曰。一切有生不净品法。于中隐藏为果故

释曰。一切谓三世。三世中取正生能生不净品法。谓翻五种净品名不净品

论曰。此识于诸法中隐藏为因故

释曰。诸法谓阿黎耶识果。即不净品等。阿黎耶识藏住此果中为因

论曰。复次诸众生。藏此识中。由取我相故。是故名阿黎耶识

释曰。藏者以执义。约阿陀那识及意识。说众生名。何以故。一切众生无无我执。我执若起。缘何境缘本识起。微细一类相续不断故

论曰。阿含云如解节经所说偈

  执持识深细　　法种子恒流
  于凡我不说　　彼勿执为我

释曰。前引阿毗达磨偈为证。此中更引经偈为证。阿毗达磨以理为胜。经以教为胜。教必有理理必顺教。此二名证。若离此二证立义不成。此证从解节经出。佛告广慧菩萨。广慧。于六道生死。是诸众生随在众生聚。或受卵生胎生湿生化生。此中得身及成就。初受生时一切种识先熟合大长圆。依二种取。谓有依色根。及相名分别言说习气。若有色界中有二种取。若无色界无二种取。广慧。此识或说名阿陀那。何以故。由此本识能执持身。或说名阿黎耶识。何以故。此本识于身常藏隐同成坏故。或说名质多。何以故。此识色声香味触等诸尘所生长故。广慧。依缘此本识。是识聚得生。谓眼识乃至意识。依有识眼根缘外色尘。眼识得生。与眼识同一时共境。有分别意识起。若一眼识生。是时一分别意识生。与眼识共境。此眼识若共二识或三四五共起。是时一有分别意识。与五识共缘境生。如大水流。若有一能起浪因至则一浪起。若二若多能起浪因至则多浪起。是水常流不废不断。复次于清净圆镜面中。若有一能起影因至则一影起。若二若多能起影因至则多影起。是圆镜面不转成影亦无损减。此本识犹如水流及镜面。依此本识。若有一能起眼识缘至。则一眼识起。乃至若有五能起识因至则五识起。广慧。如此菩萨依法如智有聪慧。能通达意心识秘密义。诸佛如来如理如量。由如此义。不记说诸菩萨能通达意识心秘密义。广慧。诸菩萨由如实不见本识。及阿陀那识等。于内于外。不见藏住不见生及长等。不见识眼色及眼识。不见耳声及耳识。乃至不见身触及身识。广慧。诸菩萨依法如智有聪慧。能通达意心识秘密义。诸佛如来如理如量。由如此义。记说诸菩萨能通达意识心秘密义。复次引偈重释经所说义。执持识深细者。云何此识或说为阿陀那识。能执持一切有色诸根。谓能报持有依五根及相等习气故。此识亦名阿陀那。深细者难灭难解故。法种子恒流者。一切不净品法能生熏习所依住。如水流念念生灭相续不断。于凡我不说者。诸凡夫人无甚深行。不求一切智。根钝故不为凡夫及二乘说。彼勿执为我者一相起相续长。若众生依经起邪分别。即执此识为我。恐起邪执故我不为说

论曰。云何此识或说为阿陀那识

释曰。前已引正理及正教。证此识名阿梨耶。云何今复说此识名阿陀那

论曰。能执持一切有色诸根。一切受生取依止故。何以故。有色诸根此识所执持。不坏不失乃至相续后际。又正受生时由能生取阴故。故六道身皆如是取是取事用识所摄持故。说名阿陀那

释曰。今立道理为成阿陀那名。道理者能执持一切有色诸根。由此识执持有色五根。不如死人身在黑胀坏等有变异位。若至死位阿梨耶识舍离五根。是时黑胀坏等诸相即起。是故定知。由为此识所执持一期中五根不破坏。一切受生取依止故者。此言重答前问。此识众生正受生时能生取阴。此取体性识所执持。由此识是正受生识。是故正受生时一切生类皆为此识所摄。一期受身亦为此识所摄。于阿梨耶识中身种子具足故。以是义故阿梨耶识亦名阿陀那

论曰。或说名心。如佛世尊言心意识

释曰。阿梨耶识及意。见此二义不同心义。亦应有异。此三异相云何

论曰。意有二种。一能与彼生次第缘依故。先灭识为意。又以识生依止为意

释曰。若心前灭后生。无间能生后心说此名意。复有意能作正生识依止。与现识不相妨。此二为识生缘故名为意。正生者名识。此即意与识异

论曰。二有染污意。与四烦恼恒相应

释曰。此欲释阿陀那识。何者四烦恼

论曰。一身见二我慢三我爱四无明

释曰。我见是执我心。随此心起我慢。我慢者由我执起高心实无我起。我贪说名我爱。此三惑通以无明为因。谓谛实因果心迷不解。名为无明

论曰。此识是余烦恼识依止。此烦恼识。由第一依止生。由第二染污

释曰。此染污识由依止第一识生。由第二识染污。次第已灭说名意。余识欲生能与生依止故。第二识名染污识。烦恼依止故。若人正起善心亦有此识

论曰。由缘尘及次第能分别故此二名意

释曰。以能取尘故名识。能与他生依止故名意。第二识是我相等。或依止能分别故名意

论曰。云何得知有染污心

释曰。以何道理能成立此义

论曰。若无此心独行无明。则不可说有

释曰。独行无明其相云何。若人未得对治道。能障实慧惑名独行无明。此无明于五识非有。何以故。若人在于五识不能为障。何以故。若是对治道生处。则是障处于染污意识此亦非有。何以故。但由此惑心应染污故。与余惑相应共行。独行名则不成。若汝说第六识由独行无明染污。则第六识一向不清净。以此无明不暂息。云何施等心成善以第六识。恒与无明相应故。若有人说心与善相应生。此人则有过失。若第六识。恒被染污则不得引对治道生。若有人说染污心相应有别善心。此善心能引生对治道故染污心即灭。若作此说则无过失

论曰。与五识相似此法应无。何以故。此五识共一时有自依止。谓眼等诸根

释曰。犹如眼识等五识。眼等五根同时为依止。意识必应有同时依止。若不立余识亦无此依止。如眼识无依止不得生。意识亦应尔

论曰。复次意名应无有义

释曰。云何无义。若立前灭心为意。此但有名无义。何以故。意以了别为义。于无中云何可立。是识随六识前已灭。此意名不可得。不能了别以无体故

论曰。复次无想定灭心定。应无有异。何以故。无想定有染污心所显。灭心定不尔。若不尔此二定应不异

释曰。若人立有染污心。此人于无想定则说有染污心。于灭心定则说无染污心。对此人二定则有差别。若不如此于二定意识不行故。二定则无异

论曰。复次于无想天一期应成无流无失。无染污故。于中若无我见及我慢等。复次一切时中起我执。遍善恶无记心中。若不如此但恶心与我执等相应故。我及我所。此惑得行。于善无记中则不得行。若立二心同时生无此过失。若立与第六识相应行。有此过失

释曰。于无想天生若无染污心。一期生中则无我执及我慢等。此生便无流失。此定不应为圣人所厌恶。既为圣人所厌恶。故知此定有染污识。由我执恒相随施等诸善常为我执所杂我执恒随。若离无明则无此事。此无明若离依止则不得有。此无明依止。若离阿陀那识无有别体

论曰

  无独行无明　　及相似五识
  二定无差别　　意名无有义
  无想无我执　　一期生无流
  善恶无记中　　我执不应起
  离污心不有　　二与三相违
  无此一切处　　我执不得生
  证见真实义　　惑障令不起
  恒行一切处　　名独行无明

论曰。此心染污故无记性摄

释曰。此心是无明所依。于三性中此心属何性。由染污故属有覆无记性。何以故。有染污故。云何有染污

论曰。恒与四惑相应

释曰。不了无我境故起我执。由我执起我爱我慢。此四惑一切处恒起

论曰。譬如色无色界惑是有覆无记。此二界烦恼奢摩他所藏故

释曰。界以生性为义。离淫欲及段食欲。由色欲生故名色界。离下二界欲由无色欲生故名无色界。此二界惑虽与第六粗识相应。不失无记性。由八定所藏故。此惑若在欲界散心应成不善。由依止粗故。若与第二识相应。虽不在定中亦非不善以依止最细故。若在色无色界。依止虽粗八定所摄。心软滑故。亦非不善。能生生死亦非是善故。属有覆无记性。第二识所起惑亦尔。依止细故非不善。是生死因故亦非是善

论曰。此心恒生不废

释曰。此染污心三性中。八定无想定无想天处。恒生不废

论曰。寻第二体离阿梨耶识不可得

释曰。第二识缘第一识起我执。若离第一识此识不得起。故知有第一识今成就第二识。为显第一识故

论曰。是故阿梨耶识成就为意。依此以为种子余识得生

释曰。离第一识无别识体为第二识。因及生起识因。佛说心名。此名目第二识。佛说识名。此名目六识。佛说意名。此名目第一识。何以故。第二识及生起识。若前已灭后识欲生。必依第一识生及能生自类故。说名意根

论曰。云何此意复说为心。多种熏习种子所聚故

释曰。第一识或名质多。质多名有何义。谓种种义及滋长义。种种者自有十义。一增上缘。二缘缘。三解相。四共作。五染污。六业熏习。七因八果。九道十地。此义中各有多种义故名种种。滋长有三义。一由此十法聚集。令心相续久住。二此心能摄持一切法种子。三是种种法熏习种子之所滋长。种子者。谓功能差别因。所滋长者。谓变异为三界。由此义故。佛说第一识亦名质多

论曰。云何于声闻乘不说此心相。及说阿梨耶阿陀那名。微细境界所摄故

释曰。问各问名体。答通答两问。此识于所知中最微细。以非二乘所缘故。此识亦是境界。若求佛果人必须通达此识。此识是应知等九义所依藏故。故名所摄。复次菩萨有微细境界藏。此识难解。故属微细境界藏摄

论曰。何以故。声闻人无有胜位。为得一切智智

释曰。何故于声闻乘不说微细境界。声闻人不作正勤求知如来境界。修行唯为自利故。诸声闻人惑障由苦等智粗浅观行。可得除灭

论曰。是故于声闻人离此说由成就智。令本愿圆满故不为说

释曰。诸佛见声闻人少欲知足。求除自惑障。此障若离此智由余智可得灭除。本愿得成。不为解脱他障不发愿求如来法身。修行微细甚深道。故不为说

论曰。诸菩萨应有胜位。为得一切智智故佛为说

释曰。诸菩萨求灭自他惑障及智障故。修行正勤故。为诸菩萨说

论曰。何以故。若离此智得无上菩提。无有是处

释曰。若离甚深微细境。十种次第修则不得成。若离此修心。烦恼易除法身易得。无有此义

论曰。复次此识于声闻乘。由别名如来曾显

释曰。复有别道理可信此识是有。何以故。于声闻乘此义由别名。处处显现

论曰。如增一阿含经言。于世间喜乐阿梨耶。爱阿梨耶。习阿梨耶。着阿梨耶。为灭阿梨耶。如来说正法

释曰。初句略说根本。后以三句约现在过去未来。更广释之。着阿梨耶者。约现在世。习阿梨耶者约过去世。爱阿梨耶者。约未来世。复有别释。喜乐阿梨耶是现在世。云何现在世。喜乐阿梨耶由过去世着阿梨耶故。由过去现在数习阿梨耶。是故未来爱阿梨耶。复次或执此四句义不异。若不异云何有四句。如决定藏论所明。有二种爱。谓有爱无有爱。有爱即三界爱。无有爱谓爱三界断。喜乐者若人生在欲界。缘已得尘生喜缘。未得尘生乐著者。若人生在色界。未离欲色界。贪着色界生及色界尘由已得色界定。于定生染。不乐所未得定。于中执为解脱故说名著。习者若人生无色界。未离欲无色界。先且观欲界过失。生色界欲。后观色界过失舍色界欲生无色界欲。此欲由习诸定所成故说名习。此三名有爱依常见起。爱者若人多行恶。畏受苦报。或执断见求不更生故。说名爱。此一即无有爱。依断见起。或约四倒释四句或约四爱释四句。即饮食衣服住处有无有爱。或欲显自法辩令弟子得法辩因。或欲显一义有多名。或欲令钝根人。若忘此义由别名还得忆。或欲令钝根人因重说名故得解。或欲令别方弟子若不解一名。由余名得解故说四句。名异义同

论曰。世间乐听

释曰。依信智两根

论曰。故属耳

释曰。显离散乱心。即是定根

论曰。作意欲知

释曰。显起恭敬不放逸。即是念根

论曰。生起正勤

释曰。因此起勇猛。舍恶取善即是精进根。此中所明是即三慧

论曰。方得灭尽阿梨耶

释曰。此明道果。即是尽无生智

论曰。乃至受行如来正法及似法

释曰。如教而行。是名受行如来所说名句味称正法。名句味所目义称似法。复次正法谓正说。似法谓正行正得。复次正法以阿含为体。似法以所得为体

论曰。由如来出世是第一希有。不可思议法于世间显现。如本识此如来出世四种功德。经由别义。于声闻乘此识已显现

释曰。别义有三种。一别意。如来欲说自出世功德。非欲显阿梨耶识。此识与功德相应故说此识。二别名。如来但说名不说义。三别义。微细境所摄于二乘不宜说。但由义相应故。说名不释义

摄大乘论释卷第一摄大乘论释卷第二

        世亲菩萨释

        陈天竺三藏真谛译

    释依止胜相众名品之二

    众名章余

论曰。复次摩诃僧祇部阿含中。由根本识别名。此识显现譬如树依根

释曰。此识为一切识因故。是诸识根本。譬如树根。芽节枝叶等所依止说名树根。若离此根芽等不成。此识为余识根本亦尔

论曰。弥沙塞部亦以别名说此识。谓穷生死阴。何以故。或色及心有时见相续断。此心中彼种子无有断绝

释曰。云何说此识为穷生死阴。生死阴不出色心。色有时有。诸定中相续断绝。如无色界。心亦有时有。诸定中相续断绝。如无想天等。于阿梨耶识中。色心种子无有断绝。何以故。由此熏习种子。于穷生死阴恒在不尽故。后时色心因此还生。于无余涅槃前。此阴不尽故名穷生死阴

论曰。是应知依止阿陀那阿梨耶。质多根本识穷生死阴等

释曰。此三是大乘中所立名质多是通大小乘所立名。根本识是摩诃僧祇部所立名。穷生死阴是弥沙塞部所立名。等者正量部立名。果报识上座部立名有分识

论曰。由此名小乘中。是阿梨耶识已成王路

释曰。由此众名广显本识。是故易见犹如王路。言王路者有三义。一直无歧。二广平熟。三光明无障。本识亦尔。直无歧譬定无疑。广平熟譬大小乘俱弘此义。光明无障譬引无量道理以证此识故譬王路

论曰。复有余师。执心意识此三但名异义同。是义不然

释曰。此义约小乘还反质小乘。小乘云。阿梨耶识阿陀那识。由自僻执于同义异名中立为异义。此说不然。何以故

论曰。意及识已见义异。当知心义亦应有异

释曰。小乘中立意及识。名义俱异能了别名识。若了别已谢能为后识生方便。名为意故。识以了别为义。意以生方便为义。如小乘中二名有二义。本识有体无名。故知心名应目本识。此义不可违

论曰。复有余师。执是如来说世间喜乐阿梨耶

释曰。小乘诸师约阿梨耶名。起执不同。阿梨耶者欲显何义。爱着境界名阿梨耶

论曰。如前所说。此中有五取阴说名阿梨耶

释曰。此爱着境其义不同。或执是五取阴取是贪爱别名。贪爱所缘自五阴名为取阴。此取阴是众生爱着处故。说名阿梨耶

论曰。复有余师。执乐受与欲相应说名阿梨耶

释曰。此五阴非爱着处。若无乐受于乐受若无颠倒。云何于五阴生爱着。是故于乐受中。由欲颠倒心未灭故。此乐受是爱着处。五阴与乐受相应故。说五取阴为爱着处。是故乐受正为爱着处

论曰。复有余师。执身见说名阿梨耶

释曰。若人说乐受是爱着处。是义不然。此受由能安乐自我。爱自我故爱此乐受。譬如人爱寿故爱寿资粮。如此爱我故爱我资粮

论曰。如此等诸师

释曰。为摄余执有说寿命是爱着处。有说道是爱着处。有说六尘是爱着处。有说见及尘是爱着处

论曰。迷阿梨耶。由阿含及修得是故作如此执

释曰。如此小乘中诸师。不了别阿梨耶识。云何不了别。不了别有二种。一由教。二由行。教谓小乘阿含是。阿含不如理决判此识义故。依阿含迷于此识。行谓粗浅道。无道理能证此识义故。由行亦迷此识

论曰。由随小乘教及行。是师所立义不中道理

释曰。诸师依小乘教。及离阿梨耶识立别名。若约小乘道推度。此义亦不中。小乘理为自悉檀所违故

论曰。若有人不迷阿梨耶识。约小乘名成立此识。其义最胜

释曰。不迷人是菩萨。由阿含及行诸佛观人根性依根性立阿含。于下品者有秘密说。于上品者无秘密说。是故具明诸识。由此阿含菩萨不迷此识。由行者若人修行能破欲界惑。则见自身为色惑所缚。乃至无色界亦尔。若修行出无色界。见身被缚在阿梨耶识中。为灭此缚故修十地。诸菩萨由甚深行故。不迷此识。若人能了别此识。以小乘名目此识。名义相称故。成立名义则为最胜

论曰。云何最胜

释曰。显示小乘义过失于大乘义中则无过失。是故大乘安立最胜。小乘过失者

论曰。若执取阴名阿梨耶。于恶趣随一道中。一向苦受处于彼受生

释曰。恶趣即四恶趣。于四恶趣中随入一道。此道定是纯恶业果报。无余受相杂故。名一向苦受处。于彼中有时生乐受。此乐受于恶趣非果报果。但名相似果。唯以苦受为果报果。是罪人处恶趣受苦报故。言于彼受生

论曰。此取阴最可恶逆

释曰。生时住时不可忍故言可恶。于此苦中恒起灭离贪欲意。谓我何时当死。何时当舍离此阴。故名为逆

论曰。是取阴中一向非可爱。众生喜乐不应道理

释曰。此恶道阴一向是苦恼资粮。于中云何生爱故喜乐乖理。若说取阴名阿梨耶。此义不成

论曰。何以故。彼中众生恒愿取阴断绝不生

释曰。彼中众生因此苦苦。愿乐灭现在阴。愿乐令后阴不更生

论曰。若是乐受与欲相应。从第四定乃至上界。皆无此受

释曰。此受不遍三界。但生死一分中有此受

论曰。若人已得此受。由求得上界则生厌恶

释曰。若人已生乐处已。得有乐定见。此乐粗动是放逸处难成易坏。起厌怖心求得上界寂静。则厌恶此乐。于乐处生离欲心。于不苦不乐中生喜乐心

论曰。是故众生于中喜乐不称道理

释曰。若乐不遍三界。若受乐人求离此乐。立此乐为爱着处。则不称道理

论曰。若是身见。正法内人信乐无我。非其所爱。于中不生喜乐

释曰。若说身见是爱着处。是亦不然。何以故。佛法内人。或约闻慧。或约思修慧。信无我及乐无我。发愿修道为灭我见。是故我见非其所爱。由求得无生智。令我见及我爱。未来不更生。是故于中不生喜乐。此身见为一分众生所爱着。一分众生不爱着故。不可说身见为爱着处

论曰。此阿梨耶识。众生心执为自内我

释曰。六道众生起执着心。谓此法是我自内我。此内我自在清净。能证为相。由外具故或乐或苦。是人若起如此我见

论曰。若生一向苦受道中。其愿苦阴永灭不起

释曰。此人若有恶业因缘故。堕一向苦受恶道。其计我清净。无变异。由外具但证变异及染污起无有爱。愿我与外具永绝相离。何以故

论曰。阿梨耶识我爱所缚故。不曾愿乐灭除自我

释曰。由不了别此识。缘此识起我执。由我执起我爱。由此我爱不求灭我。欲安乐此我故。求灭离外具

论曰。从第四定以上受生众生。虽复不乐有欲乐受。于阿梨耶识中。是自我爱随逐不离

释曰。前已明众生于恶道中。止求离苦无欲舍我心。此中明众生在舍受处。无乐受可爱乐。厌恶乐受如恶道人厌恶苦受。无因缘于阿梨耶识中。欲舍我爱故。阿梨耶识是爱着处

论曰。复次正法内人。虽复愿乐无我违逆身见。于阿梨耶识中亦有自我爱

释曰。前复次约佛法外人。此复次约佛法内人。自有三品。一在正思。二在正修。三在有学。此三品人二人伏我见。一人灭我见。何以故。前二人比知无我。后一人证知无我故。言违逆身见。于阿梨耶识中。长时数习我爱。虽复违逆身见。于本识中我爱犹恒随逐。是故身见非爱着处。不应名阿梨耶

论曰。以阿梨耶名安立此识。则为最胜。是名成立阿梨耶别名

释曰。由此爱着处名。比度诸师执名义不相称。若取此名比度第一。名义相称。故引彼所立名。成立本识则为最胜。此品中总摄诸名引道理显本识故。称众名品

    相品第二相章第一

释曰。此品有七章。一相。二熏习。三不一异。四更互为因果。五因果别不别。六缘生。七四缘

论曰。复次成立此识相。云何可见

释曰。已依众名成立阿梨耶识。由此众名。阿梨耶识体相不可了别。若不了别体相。此识则难可解。今欲令通达此识故次应示其体相

论曰。此相略说有三种。一立自相。二立因相。三立果相。立自相者。依一切不净品法习气。为彼得生。摄持种子作器。是名自相

释曰。决定藏论中。明本识有八相。异彼广说。故言略说三种。自相义云何。依一切不净品法。熏习此识最胜。为彼得生功能。此功能相复云何。谓摄持种子。云何摄持。熏习成一故言摄持

论曰。立因相者。此一切种子识。为生不净品法。恒起为因。是名因相

释曰。八识中随一识不净品法所熏习。已得功能胜异为生彼法。后转成因是名因相

论曰。立果相者。此识因种种不净品法无始习气。方乃得生是名果相

释曰。依止三种不净品法熏习。后时此识得生。为摄藏无始熏习故。是名果相

    熏习章第二

论曰。何法名习气。此习气名欲显何义

释曰。此二问有何异。前问名所目义。后问义所得名

论曰。此法与彼相应。共生共灭后变为彼生因。此即所显之义譬如于麻以花熏习。麻与花同时生灭。彼数数生为麻香生因

释曰。此谓能受熏习法。彼谓能熏习法。共谓一时一处。同生同灭若法有生灭。则有能熏所熏。若异此则不然。能熏者相续短。所熏者相续长。是故能熏已谢所熏恒在。后变为彼生因。变即当彼如彼生功能此亦复尔。此即所显之义义即名所目。名即义所成

论曰。若人有欲等行。有欲等习气

释曰。数起烦恼是名行。此行有习气。习气何相

论曰。是心与欲等同生同灭。彼数数生。为心变异生因

释曰。同生灭义如前。彼者欲等行。数数生者。或约一生或约一时。先未有熏习。今变异为彼生因能变异心是名熏习。于不净品中是一类谓烦恼浊

论曰。若多闻人有多闻习气

释曰。多闻人或在思位。或在修位。有多闻习气。此有何相

论曰。数思所闻共心生灭

释曰。如前所闻名句味。引多道理。恒思量。是思量中正思与意识共生共灭

论曰。彼数数生为心明了生因

释曰。是正思所闻。于意识中数数生灭。意识于闻中既明了。熏习阿梨耶识。此意识若灭。后更欲起。次第转胜。由此熏习成。是故聪明事不失

论曰。由此熏习得坚住故

释曰。于思慧得坚。于修慧得住

论曰。故说此人为能持法

释曰。由此熏习能不忘失。若人别缘余事。亦得说名能持法人

论曰。于阿梨耶识。应知如此道理

释曰。若善恶熏习。生起道理应如此知

    不一异章第三

论曰。此染污种子。与阿梨耶识同异云何

释曰。是不净品法种子。在阿梨耶识中。为有别体故异。为无别体故不异。若尔有何失。若异者诸种子应有分分差别。阿梨耶识亦应如是成无量分。若种子自异本识。不异刹那刹那灭义则不成。若此识与种子异。于识中善恶二业熏习。随业或善或恶。生起种子。汝许种子是无记。云何得异。此识与种子若不异彼多此一。云何不异。此难显二种过失。为离彼难二过失故。须明不一不异义

论曰。不由别物体故异如此和合虽难分别。而非不异

释曰。此阿梨耶识与种子。如此共生。虽有能依所依不由别体故异。如眼根及眼识。眼根以色为体。眼识以无色为体。此识与种子无此异体故。不可说异。既不可说异。何不说一。如此和合虽难分别。而能依是假无体。所依是实有体。假实和合异相难可分别。以无二体故。譬如苦集二谛。苦谛实有果报五阴为体。集谛是假名。依苦谛得显。无有别体。假说为因。五阴虽难分别而非不异。识与种子亦尔。何以故

论曰。阿梨耶识如此而生

释曰。若不异如先熏习未生时。此识但是果报。不能为他作因。若熏习生时。此识亦应如此而生。与本无异。既无此义故非不异。无此义者

论曰。熏习生时有功能胜异。说名一切种子

释曰。此识先未有功能熏习生。后方有功能故异于前。前识但是果报。不得名一切种子。后识能为他生因。说名一切种子。前识但生自相续。后识能生自他相续故胜于前。譬如麦种子。于生自芽有功能故。说麦是芽种子。麦若陈久或为火所损。则失功能。麦相不异。以功能坏故不名种子。此识亦尔。若有生一切法功能。由与功能相应。说名一切种子。此功能若谢无余。但说名果报识。非一切种子。是故非不异

    更互为因果章第四

论曰。云何阿梨耶识与染污。一时更互为因

释曰。阿梨耶识或为一切法因。或为一切法果。一切法于阿梨耶识亦尔。如此义云何可知。为显此义故应说譬

论曰。譬如灯光与灯炷生及烧然。一时更互为因

释曰。由炷体作依止。能生光焰故。炷是光焰生因。光焰即此生刹那中能烧然炷。光焰即为炷烧然因。此阿梨耶识与彼一切法。为共有生因。应知此义。何以故。此因现在住。未坏果生亦可见

论曰。又如芦束一时相依持故得住立

释曰。如二芦束。一一刹那中互相依互相持

论曰。应知本识与能熏习。更互为因其义亦尔。如识为染污法因。染污法为识因

释曰。此阿梨耶识为种子生因。若无此识三业生灭无可依处。如体谢灭功能亦尔。故由此识诸法体生功能亦立。是故本识为彼生因。彼法亦尔。若彼法无此识起。在现在无有道理。转后异前。此变异是彼法果

论曰。何以故

释曰。何故不别说余法相对。互为因果而唯明识与染污法互为因果。或是外道或是二乘。作如此问

论曰。离此二法。异因不可得故

释曰。于世间中离分别依他二法。更无余法。阿梨耶识是依他性。余一切法是分别性。此二法摄一切法。皆尽三界唯有识故。是故离此二法。异因不可得。若二法为共有因是功力。果随因品类。其品类亦应尔

    因果别不别章第五

论曰。云何熏习不异不多种。而能为有异多种诸法作生因

释曰。此难欲难俱有因。则不成难。以执果与因不一时故。若难果报因此可成难。果报因必是有记。果报果必与因不同时

论曰。譬如多缕结衣。衣无多色。若入染器。后于衣上种种相貌方得显现

释曰。引此譬欲明果报因果。皆得成立。如人欲于衣上作诸相貌。先以缕结衣。此衣当结时相貌无异。入染器后若解先结则有多种相现

论曰。如此阿梨耶识。种种诸法所熏

释曰。阿梨耶识为善恶不动三业所熏。如衣被结

论曰。熏时一性无有多种

释曰。熏时自有三种。一方便时。二正作时。三作后时。复有三种。一自作时。二教他作时。三随喜作时。种子与阿梨耶识。同无记性离此识无各各异体

论曰。若生果染器现前。则有不可数种类相貌。于阿梨耶识显现

释曰。若众缘已具。如衣正入染器。如此种子与本识于现生后三时。随一时现前。则有不可数种果报相貌。于此识显现。是故熏时虽复不异。果报熟时则有无量差别。譬如染衣。若汝意谓果报定以有记为因。云何以无记为因者。此义无异。何以故。彼人于果说因。大乘于果说果

    缘生章第六

论曰。此缘生于大乘。最微细甚深

释曰。欲显大乘与小乘异。大乘具有三种缘生。小乘但有二种。大乘第一缘生。于小乘则无。何故大乘有小乘无。此第一缘生最微细甚深故。于余乘不说。凡夫智不能通达故微细。阿罗汉独觉智不能穷其底故甚深。此缘生有几种。若广说有三种。若略说有二种。何者为二

论曰。若略说有二种缘生。一分别自性缘生。二分别爱非爱

释曰。由此二名。此二种缘生差别已显

论曰。依止阿黎耶识诸法生起。是名分别自性缘生

释曰。由诸法种子。依阿黎耶识诸法欲生时。外缘若具。依阿梨耶识则更得生。诸法生以阿黎耶识为通因。是名分别自性。何以故。种种诸法体性生起。分别差别。同以阿黎耶识为因故。若分别诸法缘生自性。此唯阿黎耶识

论曰。由分别种种法因缘自性故

释曰。遍三界诸法品类。若分别生起因。唯是一识。若分别诸法性。即是此识。若分别诸法差别。皆从此识生。是故诸法由此识悉同一性。二分别爱非爱者

论曰。复有十二分缘生。是名分别爱非爱

释曰。约三世。立十二分。为显因显果及显因果故。离根本八分为十二分。根本八分不出三法。谓烦恼业果报。烦恼者。譬如从种子生芽等。从烦恼生烦恼。从烦恼生业果。从烦恼生果报。又如龙在池水恒不竭。烦恼若在生续无穷。又如树根未拔时至则生。未除烦恼根六道报恒起。业者。譬如米有糠则能生芽。业若有流则能感报。又如乌沙絺。谓芭蕉竹等果熟则死。业若已熟不更生果。又如树花是生果近因。业亦如此近能生果。果报者。譬如成熟饮食。饮食若已成熟但应受用。不更成熟。果报若熟不更结后果报。若重结果报则不得解脱故。十二缘生不出此三。此十二分。能分别有二种生身无穷差别。由彼缘生故。何以故。此无明有三品业缘生。谓福非福不动行。由此行有三品。是故识等或生随福行。或生随非福行。或生随不动行。此三品中福及不动是可爱。非福是不可爱。故言分别爱非爱

论曰。于善恶道分别爱非爱。生种种异因故

释曰。善道是爱。恶道是非爱。此善恶道中有无量种差别分别。此差别不出十二缘生。即以十二缘生。为差别因故。说十二缘生分别爱非爱

论曰。若人于阿黎耶识。迷第一缘生

释曰。迷有三惑。一无知。二疑知。三颠倒知。若起此三惑。则生二种见。或执不平等因。或执无因。执不平等因者

论曰。或执自性是生死因

释曰。僧佉引五义。证立自性是实有。一由别必有总。知有自性。于世间中若是别物决定有总。譬如以一斤金用作镮钏等。镮钏等别有数量。则知金总亦有数量。由见变异别有数量。则知自性总亦有数量。二由末似本。知有自性。譬如一斤白檀分为多片。片片之中香皆似本。变异别中悉有三德。谓忧喜闇。则知自性总中亦有三德。三由事有能。知有自性譬如锻师于锻中有能故能作器。由自性于变异中有体故能作万物。此能若无依能则不成。四由因果差别。知有自性。譬如土聚为因。以瓶为果。如此以自性为因。变异为果。五由三有无分别故。知有自性。若世间坏时十一根坏变为五大。五大坏变成五唯量。五唯量坏变成我慢。我慢坏变成智。智坏变成自性故。三有于自性无复分别。若世间起时从自性起智。从智起我慢。乃至从五大起十一根。若无自性坏时。应尽无更起义。若更起无本无次第生义

论曰。或执宿作

释曰。路柯耶眂柯说。世间一切因唯有宿作。现在功力不能感果故。现在非因。如世间二人同事一主。俱有功力。一被礼遇。一则不尔。故知唯由宿作。不开现在功力

论曰。或执自在变化

释曰。如前所立皆不成因。唯有一因名为自在。使我等生善恶轮转生死。后令起厌离求得解脱。自在因论生于智慧。解诸系缚会自在体

论曰。或执八自在我

释曰。如鞞世师那耶修摩执我者。何相何德。智性为相。八自在为德。如火以热为相。我亦如此。若独存及杂住。智性无改故。以智性为相。八自在者。一于细最细。二于大最大。三遍至。四随意。五无系属。六变化。七常无变异。八清净无忧

论曰。或执无因

释曰。由不了别世间果因一分。以例余果谓皆无因

论曰。若迷第二缘生。执我作者受者

释曰。亦由三惑故不了别第二缘生。若增减因果及事。是名不了别第二缘生。增因者。除无明等因。立不平等因为因。减因者。谓行等无因。增果者。谓行等本自有体。后缘无明生。减果者。谓无行等为无明果。增事者。谓无明等生行等。离唯众缘和合。有无明等别事。能作行等别事。减事者。执无明等无有功能生行等事。无明等无动无作故。若离此三处增减。是名分别第二缘生。若不能如此分别。即迷缘生起增益执。谓我执作者受者执。先约本识起我执。后约因果起作者受者执。若我作因名为作者。若我受报名为受者

论曰。譬如众多生盲人不曾见象

释曰。众多譬一阐提及外道。生盲人譬迷阿黎耶识体性因果。三种无明。不曾见。譬不能了别。象譬阿黎耶识。生盲人于一期报中不曾见色。一阐提及外道从无始生死来。未曾了别阿黎耶识三相

论曰。有人示之令彼触证

释曰。有人譬邪师。示之譬为说邪法。令彼触证。譬令彼生不正思惟及偏见

论曰。有诸盲人。或触其鼻。或触其牙。或触其耳。或触其脚。或触其尾。或触其脊等。有人问之。象为何相。盲人答云。象如黎柄。或说如杵。或说如箕。或说如臼。或说如帚。或说如山石。若人不了二种缘生无明生盲。或说自性为因。或说宿作。或说自在变化。或说八自在我。或说无因。或说作者受者

释曰。六触譬六偏执。一自性。二宿作。三自在。四我。五无因。六作者受者。等者等六十二见等

论曰。由不了阿黎耶识体相及因果相。如彼生盲不识象体相。作种种异说

释曰。品初立自体为显自相。立因为显因相。立果为显果相。此二种人。由无明不能了别本识三相故。不能通达分别自性缘生。起自性等五执。不能通达爱非爱缘生。起第六作者受者执

论曰。若略说阿黎耶识体相。是果报识。是一切种子

释曰。阿黎耶识因相者。一切法熏习于本识中有故名为因。果相者。此识余法所熏故成诸法果。体相者。谓果报识。一切种子是其体相

论曰。由此识摄一切三界身。一切六道四生皆尽

释曰。三界身谓于六道四生中。等类不等类差别。此识若成熟能成六道体。何以故。三业所熏。是诸道种子故。由此义故。三界一切生一切道。皆入此识摄

论曰。为显此义故说偈言

  外内不明了　　于二但假名
  及真实一切　　种子有六种
  念念灭俱有　　随逐至治际
  决定观因缘　　如引显自果
  坚无记可熏　　与能熏相应
  若异不可熏　　说是熏体相
  六识无相应　　三差别相违
  二念不俱有　　余生例应尔
  此外内种子　　能生及引因
  枯丧犹相续　　然后方灭尽

释曰。已说阿黎耶识为一切法种子。今更欲显种子义故说斯偈。外内不明了于二者。种子有二种。一外二内。外谓谷麦等。于善恶二性不明了是有记故。内谓阿黎耶识于善恶二性则明了。或以染污清净为二。但假名及真实者。外种子但是假名。何以故。一切法唯有识故。内种子则是真实。何以故。一切法以识为本故。一切种子有六种者。如此内外种子不过六种。何者为六。念念灭者。此二种子刹那刹那灭。先生后灭无有间故。此法得成种子。何以故。常住法不成种子。一切时无差别故。是故一名念念灭。俱有者。俱有则成种子。非过去未来及非相离。是时种子有即此时果生。是故二名俱有。随逐至治际者。治谓金刚心道。阿黎耶识于此时功能方尽故名际。外种子至果熟及根坏时功能则尽。是故三名随逐至治际。决定者。由此决定不从一切。一切得生因果。并决定若是此果种子。此果得生。是故四名决定。观因缘者。由此种子观别因缘。方复生果。是故非一切时。非一切生。是时若有因。是时因得生。是故不恒生。若不观因而成因者。则一因为一切果因。以观因缘成故。不漫为因。是故五名观因缘。能引显自果者。是自种子能引生自果。若阿黎耶识能引生阿黎耶识果。如谷等种子能引生谷等果。是故六名能引显自果。如此六种是因果生义。如此方便令熏习相貌易见。今当更说。坚无记可熏与能熏相应者。熏义有四种。一若相续坚住难坏。则能受熏。若疏动则不然。譬如风不能受熏。何以故。此风若相续在一由旬内。熏习亦不能随逐。以散动疏故。若瞻波花所熏油。百由旬内熏习则能随逐。以坚住故。二若无记气则能受熏。是故蒜不受熏。以其臭故。沉麝等亦不受熏。以其香故。若物不为香臭所记则能受熏。犹如衣等。三可熏者。则能受熏。是故金银石等皆不可熏。以不能受熏故。若物如衣油等。以能受熏。故名为可熏。四若能所相应则能受熏。若生无间。是名相应故得受熏。若不相应。则不能受熏。若异不可熏说是熏体相者。若异此四义。则不可熏。是故离阿黎耶识余法不能受熏。以阿黎耶识具前六义。一念念生灭。二与生起识俱有。三随逐乃至治际穷于生死。四决定为善恶等因。五观福非福不动行为因。于爱憎二道成熟为道体。六能引显同类果。一切生起识。虽具六义得为种子。但与熏习四义相反。由阿黎耶识具种子六义。及熏习四义故。能受熏习转为种子。余识则不尔。何以故。六识无相应者。六识无前后相应义。以易动坏故。复次非但易动坏故无相应。复有余义。三差别相违者。随一一识。别依止生。别境界生。别觉观思惟生。别想生故名相违。六识更互不相通故差别。差别故相违。经部师说。前念熏后念。何以故。二识一刹那不并起故。不得同时。此义不然。何以故。一念二不俱者。能熏所熏若在一时。同生同灭熏习义得成。若不同时熏义不成。何以故。能熏若在。所熏未生。所熏若生。能熏已谢。前后刹那一时并起。无有是处。是故六识不并起故无熏习。若汝言有识生类。其相如此故能受熏。是义不然。余生例应尔者。若汝执不相应义亦得相熏。非汝所执义。当例汝所执。如眼等诸根与识不同故名为余。此诸根色清净同类亦应更互相熏。虽同色类不相应故。若汝不许相熏。六识亦尔。虽同识类不相应故。云何得说相熏。前已说二种种子。谓外及内。若以因义显之。成二种因。一生因二引因。为显此义故说此外内种子能生及引因。外内种子若作生因及引因。其相云何。能生芽等乃至果熟。是外生因。能生果报乃至命终。是内生因。引因者。枯丧犹相续然后方灭尽者。外种子若谷已陈。内种子若身已死。由引因故犹相续住。若此二种但有生因。生因已谢。果即应灭。不得相续住。若汝说由刹那转转相生。前刹那为后刹那作因故。犹相续住。若尔最后不应都尽。既无此二义故。知别有引因。此二种因譬如人射弯弓放箭。放箭为生因。弯弓为引因。放箭得离弦远有所至。若但以放箭为因。不以弯弓为因。则箭不得远。若言前刹那箭生后刹那箭故箭得远则箭无落义。外内种子亦尔。由生因尽故枯丧。由引因尽故灭尽

论曰

  譬如外种子　　内种子不尔

此义以二偈显之

  于外无熏习　　种子内不然
  闻等无熏习　　果生非道理
  已作及未作　　失得并相违
  由内外得成　　是故内有熏

释曰。若内种子与外种子不异。眼等根同是清净四大。何故不互相熏。为是外故。外种子有三义。异内种子。是故内熏习依止外则不尔。为显此义故说二偈。于外无熏习种子内不然者。外种子如谷麦等。由功能故成。不由熏习故成。内种子则不尔。必由熏习故成。此义非证比境界。云何可知。闻等无熏习果生非道理者。若于内无熏习。昔未学闻慧思慧不生。从学闻慧后思慧亦应不生。何以故。同无熏习故。既无此义。故知内由熏习成种子。无熏习则不成。若于内无熏习。复有何失。已作及未作失得并相违者。若内无熏习有二过失。一未作应得。二已作应失。若相续中无熏习为因。此苦乐等果非因所作。即是不作而得。若已作功用于心无熏习。则无因能得果。即是已作而失。此义于世间中相违。与道理亦相违。是故本识为三业熏习故得成因。复次云何谷麦等无熏习得成种子。由内外得成是故内有熏者。外若成种子不由自能。必由内熏习感外故成种子。何以故。一切外法离内则不成。是故于外不成熏习。一由内有熏习得成种子。二若内无种子未作应得已作应失。无如此义。三外种子由内得成故内异外。必有熏习。前已说分别自性缘生。爱非爱缘生。今当更说受用缘生。其相云何

论曰。所余识异阿黎耶识。谓生起识一切生处及道。应知是名受用识

释曰。此六识云何说名生起识。自有二义本识中种子。由此识生起故。此六识是烦恼业缘起故。一能熏习本识令成种子。种子自有二能。一能生。二能引。由此二能六识名生起。由果有二能故。因得二名。二者本识中因熟时。六识随因生起。为受用爱憎等报故。此识名生起识。亦名受用识。由宿因所生起。令受用果报故。得生起受用二名。此生起识一切受身。四生六道处。能受果报故。应知此名受用识。此受用识相貌云何

论曰。如中边论偈说

  一说名缘识　　二说名受识
  了受名分别　　起行等心法

释曰。一说名缘识者。阿黎耶识是生起识因缘故。说名缘识。二说名受识者。其余诸识前说名生起识。今说名受识。能缘尘起。于一一尘中能受用苦乐等故名受识。即是受阴。了受名分别者。此三受若有别心能了别。谓此受苦。此受乐。此受不苦不乐。此识名分别识。即是想识。起行等心法者。作意等名起行。谓此好彼恶等。思故名作意。此作意能令心舍此受彼故名起行。起行即是行阴。六识名心。从此初心生后三心故。名心法

论曰。此二识更互为因。如大乘阿毗达磨偈说

  诸法于识藏　　识于法亦尔
  此二互为因　　亦恒互为果

释曰。此言欲显本识及受用识互为因果。以阿含为证。与阿含不相违则定可信。又若不作此言。未知此证从何而出。为是圣言。为非圣言。故作此说。诸法于识藏。识于法亦尔者。若本识作识法因。诸法为果。必依藏本识中。若诸法作本识因。本识为果。必依藏诸法中。此二互为因亦恒互为果者。若本识为彼因彼为本识果。若彼为本识因。本识为彼果。如此因果理。有佛无佛法尔常住

    四缘章第七

释曰。如此三种缘生。一穷生死缘生。二爱非爱道缘生。三受用缘生。此三缘生有四种缘

论曰。若于第一缘生中。诸法与识更互为因缘

释曰。因缘已显不须重问。何以故。诸法熏习在阿黎耶识中故。得互为因果

论曰。于第二缘生中。诸法是何缘。是增上缘

释曰。由无明等增上故。行等得生。增上有二种。一者不相离。二者但有。不相离者。如眼根为眼识作增上缘。但有者。如白等能显黑等。若无明等于行等。具有二种增上缘。若无苦。下无明诸行不生。若行已生无修道无明。诸行不熟。何以故。须陀洹人不造感生报业故。阿那含人不受下界生报故

论曰。复次几缘能生六识。有三缘。谓增上缘缘缘次第缘

释曰。从根生故是增上缘。缘尘故是缘缘。前识灭后识生故。是次第缘。前识能与后识生时。中间无隔故名次第

论曰。如此三缘生。一穷生死缘生。二爱憎道缘生。三受用缘生。具足四缘

释曰。以四缘约三种缘生。有具不具。若就显了义皆不具四。若就隐密义皆具四缘

摄大乘论释卷第二摄大乘论释卷第三

        世亲菩萨释

        陈天竺三藏真谛译

    释引证品第三之一

    烦恼不净章第一

释曰。此品有六章。一烦恼不净品。二业不净品。三生不净品。四世间净品。五出世净品。六顺道理

论曰。此阿梨耶识。已成立由众名及体相

释曰。如此本识众名已说体相。已成立此二义。但于本识如理得成。非于余识。今为显此二义。于理非理与诸师共立诤

论曰。云何得知阿梨耶识以如是等众名故。如来说体相亦尔不说生起识

释曰。彼云如是等众名及体相。于我法中亦有。但无阿梨耶识。云何言众名及体相。定属阿梨耶识不属余识。为答此问故

论曰。若离此名相所立阿梨耶识。不净品净品等皆不成就

释曰。若汝离本识安立此名及体相于余识。此安立不成。何以故。为三义所违故。此三义是如来正法悉檀。谓不净品净品及正道理。此义由本识得立。若汝拨无本识。此三义无安立处义。则不成此义。如来所立坚实成就违汝所执。汝执则坏。是故众名及体相不离本识

论曰。烦恼不净品。业不净品。生不净品。世间净品。出世净品等皆不成就

释曰。为开三章为六章故。重说此名

论曰。云何烦恼不净品不成就。根本烦恼及少分烦恼所作熏习种子。于六识不得成就。何以故。眼识与欲等大小二惑俱起俱灭

释曰。欲依心起故。随心世俱起俱灭。为显欲等熏习心故

论曰。此眼识是惑所熏成立种子。余识不尔

释曰。此眼识与欲等俱起俱灭。数数被熏故成种子。耳识等则不被熏。为余识所遮故

论曰。是眼识已灭。或余识间起。熏习及熏习依止。皆不可得

释曰。若在无识地中。谓无想定等故。言是识已灭。或在有识地中耳识等间起。故眼识灭。于此二灭中熏习所生种子。及所依止眼识皆不可得

论曰。眼识前时已谢现无有体。或余识所间。从已灭无法有欲俱生。不得成就

释曰。若眼识前时已二种谢灭。现在无复眼识及欲体。则是已灭无法。眼识后若与欲俱生。用前时已灭眼识及欲。为种子生现起眼识及欲。此义不得成就。何以故。因已谢灭故

论曰。譬如从过去已灭尽业。果报不得生

释曰。过去业有二种。谓有功能及无功能。若果报已熟则无复功能。此业有二义。一已过去。二已灭尽。果报果无有从此业生义。有欲眼识亦应如此。不可说从已灭种子生。若人执前已灭识是有。以过去法是有故。如毗婆沙师所执。此执但有语无义。何以故。若法是有云何言过去诸法。由此义故果报果生不如道理。以熏习无故

论曰。复次眼识与欲等。或俱时生起熏习不成

释曰。眼识前时未入灭心定。及未为余识所间。与欲俱生。后入灭心定及为余识所间。熏习不得成

论曰。何以故。此种子不得住于欲中。以欲依止识故。又欲相续不坚住故

释曰。种子若住必依自在法。及相续坚住法。此二义于欲中并无故。欲非种子所依处

论曰。此欲于余识亦无熏习。依止别异故。所余诸识无俱起俱灭故

释曰。种子若不得住欲中。应得住余诸识中。亦无此义。何以故。依止别异。又生灭不俱故。依止别异者。眼识以眼根为依止。耳识以耳根为依止。乃至意识以意根为依止。由此诸识依止各处不得相应。是故此识熏习不得住于彼识。生灭不俱者。根尘作意悉不同故。无俱生灭义。生灭既不同时。云何得以此识熏于彼识。是故诸熏习义皆不得成。若汝说此种子住同类识中。此亦不然。何以故

论曰。同类与同类不得相熏。以无一时共生灭故

释曰。眼识不得熏习眼识。何以故。一时中二眼识不得并生。若不并生则无俱灭故。熏习义不成

论曰。是故眼识不为欲等大小诸惑所熏。亦不为同类识所熏

释曰。由前义故眼识不为别类所熏。亦不为同类所熏

论曰。如此思量眼识。所余诸识亦应如此思量。复次若众生从无想天以上退堕。受下界生大小惑所染初识。此识生时应无种子

释曰。从上界堕受下界生。初受生识必为惑所染。此识及惑从何种子生。若言从上界生。是义不然。何以故。上下二界相违不俱起故。不得相熏。若言从未得上界定前心。生下界初生心。是亦不然

论曰。何以故。此惑熏习。与依止并已过去灭无余故

释曰。此初识应但生无因。此熏习及依止。久已灭尽是故不得以此为因

论曰。复次惑对治识已生。所余世间诸识皆已灭尽。若无阿梨耶识。此对治识共小大惑种子俱在。此义不成

释曰。若汝拨无本识。则有二过失不可得离。一向中人圣道与余烦恼俱在。此义不成。若无此惑则修余道无因。应无四道三果人。但有无学人。此义与正教相违过失不可得离。二无流识已灭。世间心更欲起。无因能令此心得生。若有流心无因。从无流心后自然得生。则无无学人。此失亦不可得离。如须陀洹向人。正生见谛对治道时。世间六识与道相违。不得俱生故。世间诸识皆已灭尽。所余烦恼由依止灭故功能亦灭。故对治识与小大惑种子俱在。此义不成。若尔何用修道

论曰。何以故。自性解脱故。无流心与惑不得俱起俱灭故

释曰。同类为自性。如意识有烦恼。无流识无烦恼。虽有惑无惑异。而同是识类故名自性。解脱是离义。若烦恼识与无流识俱起。则自性不得解脱。以无流识起时余识必不得生。既其相离故名解脱

论曰。复次后时出观。正起世间心

释曰。须陀洹等学人已得道竟。后时出观为当起出世心。为当起世间心。若起出世心无出观义。若起世间心。何因得生

论曰。诸惑熏习久已谢灭

释曰。先入观时诸惑熏习已灭。云何无因得生世间心

论曰。有流意识无有种子生应得成

释曰。若如此识不由因生。则无得解脱义。无学人惑心亦应无因而生

论曰。是故离阿梨耶识。烦恼染污则不得成

释曰。若汝拨无此识。烦恼染污义云何可立

    业不净章第二

释曰。若人拨无本识。此人无道理能成立业染污义

论曰。复次业染污云何不得成。缘行生识分无得成义

释曰。行有三品。谓福非福及不动念念生灭。若离本识于何处安立功能。若汝言安立于六识中。是义不然。六识不能摄持诸业功能。前于烦恼染污中已具显此义

论曰。若无此义。缘取生有亦无成义故。业染污不成

释曰。若无有业功能识。谓行缘识。缘取生有。无道理得成。何以故。此识三行所熏。以随四取故。由熏习圆满故识成有。此识或灭或余识所间。此识体已谢功能亦随灭。当于何处安。此行有二业功能。故业染污不成。言染污者。此业与烦恼相应故名染污。又从染污生故名染污。能感六道生死染污果报。故名染污

    生不净章第三

释曰。若离本识生染污无有道理。此义不成。今当说之

论曰。复次云何生染污。此义不成。结生不成故

释曰。此生若谢由业功能。结后报接前报。此义则不成就。何以故

论曰。若人于不静地退堕心。正在中阴。起染污意识方得受生

释曰。不静地退前生堕后生故名退堕。受生有二种。或有中阴。或无中阴。今偏说受中阴者。若在中阴将欲受生。必先起染污识。方得受生

论曰。此有染污识于中阴中灭

释曰。此中阴染污识。缘生有为境。此识于中阴中灭。何以故。生阴无染污故

论曰。是识托柯罗逻。于母胎中变合受生

释曰。是识即是意识。于一时中与柯罗逻相应故。言托柯罗逻。此果报识异前染污识故言变。由宿业功能起风。和合赤白。令与识同故言合。即名此为受生

论曰。若但意识变成柯罗逻等依止。此意识于母胎中有别意识起。无如此义

释曰。若汝执此识入柯罗逻数但是意识。若是意识根尘生起。与余意识为同为异。若言是同。此识谢时柯罗逻即应坏灭。若言不同。则不应说名意识。何以故。意识通以三性识为根。此识但以染污识为根。意识缘三世为境。此识境界不可知。意识有时兴有时废。此识恒有无废故不同意识。又若同者。于无识地中应无此识。若无此识。不应言入无心定识不离身。又若无识身则应坏。是故不可说此为意识。若汝说此意识不可分别。根尘生起依止此识。于母胎中别生意识。是义不然。何以故

论曰。于母胎中。二种意识一时俱起。无此义故

释曰。此言证前无意识义。以二意识同性必不俱生。无并作意故。此意识托柯罗逻。与赤白和合同依止。此识有别意识生。一时俱起。此柯罗逻识不成意识。何以故。恒以染污识为依止。此所依止识欲等所染。缘生有境起。能依止识既是果报。但无记性。所缘境又不可知。不可立为意识。若立此为意识则无并起义。若有并起应同了别。应同灭无。若同了别无灭心定。以一了别心灭。一了别心在故。若同灭无。则无功用自然涅槃。以心不更起故

论曰。已变异意识

释曰。初受生识已变异为柯罗逻

论曰。不可成立为意识

释曰。凡有三义。不可立初受生识为意识

论曰。依止不清净故

释曰。意识从三性心生。初受生识必从染污识生。即是依止不清净

论曰。长时缘境故

释曰。初受生识。从始至终缘境无废。意识缘境易脱不定

论曰。所缘境不可知故

释曰。初受生识所缘境不可知。意识缘三世境及非三世境。此则可知。由此三义有异故不可立为意识

论曰。若此意识已变异

释曰。若已受生意识与赤白和合。变前识作后识。后识异前识

论曰。是时意识成柯罗逻

释曰。由成柯罗逻故变异

论曰。为此识是一切法种子为依止此识生余识。为一切法种子

释曰。为当以受生识为一切法种子。为当依止受生识别生余识。为一切法种子

论曰。若汝执已变异识。名一切种子识。即是阿梨耶识。汝自以别名成立谓为意识

释曰。若汝执受生识为种子识。则与我所说义同即是说阿梨耶识为种子识。汝自不说名阿梨耶识。别立名意识

论曰。若汝执能依止识。是一切种子识

释曰。依止受生识。更生余识名能依止识。为一切种子识

论曰。是故此识由依止成他因

释曰。别识既从他生。则不能自为种子。是故此识由依止受生识方成种子。得为他因

论曰。此所依止识。若非一切种子识。能依止名一切种子识。是义不成

释曰。别识不能自为种子。由依他得成种子。所依受生识既非种子。能依别识立为种子识。此义岂成

论曰。是故此识托生变异。成柯罗逻非是意识

释曰。此识即是阿梨耶识。不得名此为意识

论曰。但是果报。亦是一切种子。此义得成

释曰。从种子生故称果报识。能摄持种子故。亦名种子识。若作此说义乃得成

论曰。复次若众生已托生。能执持所余色根。离果报识则不可得

释曰。前已明正受生义。今更明受生后义。前已明众生在胎中。今明众生出胎外故。言众生已托生。众生若已托生。则定有三义。一执持无废。二通摄持诸根。三体是果报无记。若离阿梨耶识。此三义不可得

论曰。何以故。所余诸识。定别有依止

释曰。欲引道理为证故言。何以故。六识中随一识称所余诸识。眼识定以眼根为依止。乃至身识定以身根为依止。明别依止。显不能通执持

论曰。不久坚住

释曰。五识中随自所依根若能执持。此识不久坚住。以相续易坏故。或在无识地中故坏。或余识间起故坏

论曰。若此色根无执持识。亦不得成

释曰。如死人色根无识执持则便烂坏。若离执持识诸根亦应尔。此义亦不成

论曰。复次此识及名色更互相依。譬如芦束相依俱起此识不成

释曰。于经中佛世尊说。识依名色生。名色依识生。名是非色四阴。色即柯罗逻。何者是依名色。识由此名色为依止。刹那传传生相续流不断。能摄名色令成就不坏。此识名依名色。识若拨无本识。以六识为识此义不成。若离阿梨耶识。于六识中是何识。此问欲何所显。欲显余识不成识食

论曰。复次若离果报识。一切求生已生众生。识食不成

释曰。此言欲显本识能为名色作识食。何以故。佛世尊说。食有四种。为求生已生众生。相续得住故。说四食。何者为四。一段食。二触食。三思食。四识食。段食者变成为相。何以故。此段若变异。能作身利益事。是名段食。触食者依尘为相。由缘色等诸尘。能作利益身事。是名触食。思食者望得为相。此望得意能作身利益事。如人饥渴至饮食处。望得饮食令身不死。是名思食。识食者执持为相。由此识执持身故住不坏。若无识执持则同死人身即烂坏。是名识食。是故汝等亦应信受如此识食义。以能作利益身事故此四食中触食属六识。思食属意望得。段食属色不关心。识食于三义中属何义。若汝不说有阿梨耶识。依何义说此识食。复次若人眠中不梦及心闷绝。入灭心定等六识已灭。又无段思触三食。何法持此身令不坏。若无阿梨耶识执持。此身则坏故知定应以阿梨耶识为识食

论曰。何以故。若离果报识。眼识等中随有一识。于三界中受生众生。为作食事不见有能故

释曰。若离本识于六识中随于一识。于三界中已受生众生。不见此识有功能能作食事。故知说余识。为识食此义不成

论曰。若人从此生舍命生上静地。由散动染污意识于彼受生

释曰。于静地中离本识受生。此义则不成。若人受生必由染污心。若于静地受生。必由染污散动心。染污者为自静地惑所染污。此惑何相餐定味等。此惑定在静地。若人从散地死。用下散动地心。于上受生无可得义。何以故。凡受生者必在散心故。若离本识。此散动识不可得。若人者。是离欲人。从此欲界生色无色界。染污者。即中阴心。起上地惑。散动者。即正受生识。于彼受生者。即方便生及正生

论曰。是染污散动识于静地中离果报识。有余种子此义不成

释曰。若受正生必具四义。以染污为根。散动为位。果报为体。有余种子为功能。若离本识。此四义不可得故。应信有阿梨耶识。何以故。于此识中静地心熏习。无始以来有余未尽。由此功能静地中有种子。散动果报识于彼受生

论曰。复次若众生生无色界

释曰。显已解脱色界

论曰。离一切种子果报识

释曰。若无本识。若实有。汝拨言无。故名为离

论曰。若生染污心及善心

释曰。若于定中起餐定味染污心。或起上地有流善心

论曰。则无种子并依止。染污及善。二识皆不得成

释曰。无种子谓无因。由无因故则无依止。复次若无种子是则无因。若无因从何而生。若无依止。云何相续得住。何以故。此二心由本识所摄。是故从自种子生。依止本识故得相续住

论曰。于无色界若起无流心。所余世间心已灭尽。便应弃于此道

释曰。若人已于无色界受生。起出世心。世间心必灭尽。若离本识。则应舍无色界报。不由功用。即入无余涅槃。既无此义。故不可拨无此识

论曰。若众生生非想非非想中。起不用处心。及无流心。即舍二处

释曰。若圣人生非想非非想处。有时依不用处地起无流心。为不用处心明了。非想非非想心闇昧故。此人在明了地。修无流心。若得无流心。即舍非想非非想。及不用处二地

论曰。何以故。无流心是出世心故。非想非非想道。非其依止。不用处道亦非依止

释曰。第一第二道。是世间法故。不得为无流心作依止。是人于余地生。别取余地心。此二道亦非此心依止。何以故。此心明了故。不依止第一道。已舍第二道。第二道亦不得为此心作依止

论曰。直趣涅槃亦非依止

释曰。由有无流心以烦恼有余故。此三义明依止既不成。若离本识。如此无流心依止何法

论曰。复次若人已作善业。及以恶业

释曰。若人于世间中。作不杀生等十善业。决定应得人天生报。若作杀生等十恶业。决定应得四趣生报

论曰。正舍寿命离阿梨耶识。或上或下次第依止。冷触不应得成

释曰。是人于死时中。若有善业。定应向上。若有恶业。定应生下。若汝不信有本识。云何此依止身。或下冷触。或上冷触。次第得成。若无有本识。云何得成本识能执持五根。本识若舍。依止身随所舍处。冷触次第起所舍之处。则成死身

论曰。是故生染污。离一切种子果报识。不可得立

释曰。生染污即是受生得生。依止执持等是染污因果故。通名染污。又生死对涅槃故名染污。本识是集谛故名种子。是苦谛故名果报。他因故名种子。他果故名果报。若离此识生染污。此义不成

    世间净章第四

释曰。由如此道理。世间净品不得成。今当说之

论曰。云何世间净品不成。若众生未离欲欲界。未得色界心

释曰。若人为离欲欲界得色界心故修加行。是修行人有二种。一在观行人。二初发修行人。在观行人者。在闻思慧中。闻思慧各有三品。修习使增长故名加行。初发修行者。即初修闻慧。此二人并未离欲欲界。悉未得非至定。非至定即色界心

论曰。先起欲界善心。求离欲欲界。修行观心

释曰。若人未得色界心。在闻慧中。名先起欲界善心。于闻慧中求离欲欲界观心。是思修慧。为离欲欲界故修行思修慧

论曰。此欲界加行心与色界心不俱起俱灭。故非所熏

释曰。闻思慧各有三品。即是加行。何故此心与色界心。不俱起灭。一粗细异。二动静异。三自性修异。四系缚出离异故。不得俱起俱灭。若不俱有。则色界心不得熏欲界心

论曰。是故欲界善心。非是色界善心种子

释曰。欲界心既不为色界心所熏故。非色界心种子。则色界心生。无有因缘。若无因缘云何得生。若汝言无始生死中。已生色界心果报未熟。此种子未灭。能为今色界心作因。是义不然。何以故

论曰。过去色界心无量。余生及别心所隔。后时不可立为静识种子。已无有故

释曰。无始生死中先所生色界心。用此为种子。此种子既无法摄持。生即谢灭。于六道中有无量生。于一一生中有无量心。隔先所起心。此种子久已灭尽。云何得立此为色界心因

论曰。是故此义得成

释曰。由汝所立义不成故。我所立义得成。云何得成

论曰。谓色界静心一切种子。果报识次第传来。立为因缘

释曰。无始生死中所得。非至定及四定熏习。本识以为种子。为本识所摄持。次第相续传来。于今不灭故。得立此为色界静心因缘。色界静心若生。即从此自种子生。是故不同汝所执无有因缘。若以宿世种子为因缘。现在所修闻思慧。此复何用

论曰。此加行善心。立为增上缘

释曰。此加行心不无功用。由此增上力故。色界心生。若无此加行心。则不得破欲界欲。若欲界欲不灭。前色界种子不得生现在色界心故。加行但得为色界心作增上缘。不得为因缘

论曰。如此于一切离欲地中。是义应知。如此世间清净品义。离一切种子果报识。则不可立

释曰。若约四定离欲欲界。若约四空离欲色界。色界心因缘增上缘。无色界心因缘增上缘。悉应如此了别

    出世间净章第五

论曰。云何出世净品。离阿梨耶不可得立

释曰。今当说此义

论曰。佛世尊说。从闻他音及自正思惟。由此二因正见得生

释曰。清净品以正见为上首。此正见以何法为增上缘。谓从他闻音及正思惟。此二因即是正见增上缘。此两因各有四义。一有正见是闻慧摄。以从他闻音为因。有正见是思慧摄。以正思惟为因。二若声闻正见。以从他闻音为因。若独觉菩萨正见。以正思惟为因。三约钝根为第一句。约利根为第二句。四约思慧为第一句。约修慧为第二句。由此二因正见得生。此二因于正见是增上缘。今所言因是通名。即说缘为因

论曰。此闻他音及正思惟。不能熏耳识及意识。或耳意二识

释曰。他音谓佛菩萨所立法门。闻他音谓如所闻而解。即是闻慧。正思惟谓如所闻简择是非。即是思慧。此两慧无有单熏耳意二识义。亦无双熏义

论曰。何以故

释曰。此二慧何故不能熏耳等识

论曰。若人如闻而解。及正思惟法。尔时耳识不得生

释曰。若人已闻他音。后生闻思慧中。闻思慧是意识。尔时耳识不得生故。闻思慧不得熏耳识

论曰。意识亦不得生

释曰。将生正见。思慧相应之意识亦不得生

论曰。以余散动分别识所间故

释曰。何故不得生。由中间有散动分别识间起故。此思慧不得即生

论曰。若与正思惟相应生

释曰。此明将生未知欲知根时之思慧

论曰。此意识久已谢灭

释曰。初已生之思慧久已谢灭

论曰。闻所熏共熏习已无

释曰。前初得多闻所熏思慧。与熏习俱谢过去

论曰。云何后时以前识为种子。后识得生

释曰。不可以初得之思慧为种子。得生后思慧。前思慧既久灭。间中为余心所间。不得度前思慧功能。于后思慧中。后思慧薄弱。复不能引正见令起。亦不得说此为种子。生正见之识。此中明无前后相熏义。未论无同时相熏

论曰。复次世间心与正思惟相应。出世净心与正见相应。无时得共生共灭

释曰。正思正修慧。从四念处至世第一法是其位。此心未证见四谛故。名世间心。已证见四谛故。名出世离自性法。是修得法故名净心。正见即八圣道中之第一分。此正见与三十七品不相离。由修得净心故。三十七品生。由三十七品生故得出世。从无始以来。世出世心无有俱生俱灭义。以性相违故

论曰。是故此世间心。非关净心所熏

释曰。既不俱生灭。故无相熏义

论曰。既无熏习。不应得成出世种子

释曰。思慧若为出世心所熏。可得成出世种子。既无被熏义。故出世种子义不成

论曰。是故若离一切种子果报识。出世净心亦不得成

释曰。若离本识。出世心既无因缘故不得成

论曰。何以故此中闻思熏习。无有义能摄出世熏习种子

释曰。此中即思慧中。思慧中有多闻熏习。若本来已起出世心熏习。此思慧可得有义将思慧。摄持出世熏习为种子。既本来未曾起出世心。熏习思慧故。无道理得说思慧。摄持出世熏习为种子

论曰。云何一切种子果报。识成不净品因。若能作染浊对治出世净心因

释曰。本识不应得作不净品因。若立本识是染浊对治出世因。则不得以本识为不净品因。不净品即集谛及苦谛。是业烦恼种子故。是集谛能生生死。即是苦谛染浊对治即除。或为出世心因。即生道灭惑。生道与不净品相违。既立为染浊对治。及出世心因故。不应复说为不净品因

论曰。此出世心昔来未曾生习。是故定无熏习

释曰。无始来未曾生出世心。既不生。何况修习。是故出世心决定无疑。不得熏于本识

论曰。若无熏习。此出世心从何因生

释曰。若有熏习为种子。出世心可得有因。既无熏习。出世心则无因而生

论曰。汝今应答

释曰。未见有因之道理。故责令答

论曰。最清净法界所流正闻熏习为种子故。出世心得生

释曰。欲简异二乘所得法界故。名最清净法界。云何异二乘所得。此法界惑障及智障。灭尽无余故言最清净。法界者。如理如量通三无性。以为其体。所流者。正说正法。谓十二部经。正闻者。一心恭敬无倒听闻。从此正闻六种熏习。义于本识中起。出世心若生。必因此得生

论曰。此闻慧熏习。为与阿梨耶识同性。为不同性

释曰。若尔何失

论曰。若是阿梨耶识性。云何能成此识对治种子。若不同性。此闻慧种子。以何法为依止

释曰。若是本识性。云何自性能作对治。灭于自性。若不同性。此闻慧熏习。应别有依止

论曰。至诸佛无上菩提位。是闻慧熏习生。随在一依止处。此中共果报识俱生

释曰。此闻功能从何而生。相续至何位。诸菩萨从十信以上。乃至无上菩提位。此闻功能相续住不失。未有初有为生。已有未灭为住。此生及住。于六道中。随依止一道五阴身处。于六道身中与本识俱生相续不尽。虽与本识不同性。而与本识俱生

论曰。譬如水乳

释曰。水与乳虽复和合。其性不同而得俱生

论曰。此闻熏习即非本识。已成此识对治种子故

释曰。此闻功能是本识对治故。与本识不同性。虽不同性。以不相离故恒俱起。云何为本识对治

论曰。此中依下品熏习。中品熏习生。依中品熏习。上品熏习生

释曰。此中即此依止处中及本识中。闻熏习功能有三品。谓下中上。下即闻慧。中即思慧。上即修慧。复有三品。就三慧中。各开为三品。复有三品。谓解脱分品。通达分品。通达品。闻有三义。一闻资粮。谓音声所诠名句味。二闻体。谓耳识。三闻果。谓闻慧及闻慧所了法门。此三品闻熏习。随一品生。随能对治本识一品。若下品生。能对治上品本识。乃至若上品生。能对治下品本识

论曰。何以故

释曰。此有三义。一何以故有三品。二何以故相生。三何以故能对治

论曰。数数加行闻思修故

释曰。数数显恒行无间加行。显作功用非悠悠修学。由数数加行故。有三品故。得相生故得对治。若由数数加行故。成三品及相生。此义非疑。云何由数数加行成本识对治

论曰。是闻熏习若下中上品。应知是法身种子

释曰。何法名法身。转依名法身。转依相云何。成熟修习十地及波罗蜜。出离转依功德为相。由闻熏习四法得成。一信乐大乘是大净种子。二般若波罗蜜是大我种子。三虚空器三昧是大乐种子。四大悲。是大常种子。常乐我净是法身四德。此闻熏习及四法为四德种子。四德圆时本识都尽。闻熏习及四法既为四德种子故。能对治本识。闻熏习正是五分法身种子。闻熏习是行法未有。而有五分法身。亦未有而有故。正是五分法身种子。闻熏习但是四德道种子。四德道能成显四德。四德本来是有。不从种子生从因作名故称种子

论曰。由对治阿梨耶识生。是故不入阿梨耶识性摄

释曰。此闻熏习非为增益本识故生。为欲减损本识。力势故生。故能对治本识。与本识性相违故。不为本识性所摄。此显法身为闻熏习果

论曰。出世最清净法界流出故

释曰。出七种苦谛。灭三种集谛故名出世。谓三无性真如本无染污。后离三障垢故名最清净。三乘道从此法生。故名为界。是闻熏习从最清净法界流出故。不入本识性摄。此显法身为闻熏习因。闻熏习因异本识。闻熏习果亦异本识。闻熏习体与本识。为同为异

论曰。虽复世间法。成出世心

释曰。如意识虽是世间法。能通达四谛真如。对治四谛障故成出世心。闻熏习亦尔虽是世间法。以因果皆是出世法故。亦成出世心

论曰。何以故

释曰。何以故。此法但是出世。非世间法。有四种对治故

论曰。此种子出世净心未起时。一切上心惑对治

释曰。此第一为显厌恶对治。由此闻熏习明了正理。能知诸尘过患。于非理及诸尘生厌恶。此厌恶心能对治上心惑。即是闻熏习功能故。名厌恶对治种子。即是闻熏习。菩萨未知欲知根。名出世净心。此心未起之前。是闻熏习属闻思慧位。在闻思位中。昔未得闻思慧时。由见倒及想倒。见修所破烦恼。恒起上心。生四恶业感四恶道报。由得此法。未生烦恼及业果报悉不得起

论曰。一切恶道生对治

释曰。此第二为显除灭对治。由闻熏习起附相续。令相续入正定聚。闻熏习随生随灭恶法。能断塞四恶道生。引善道生。昔曾起恶业。应引四恶道生。由此法故灭不复受

论曰。一切恶行朽坏对治

释曰。此第三为显远离对治。无始生死中所造后报恶业。能令于后报时中堕四恶趣。此法能转令后报无报即。是朽坏义

论曰。能引相续。令生是处。随顺逢事诸佛菩萨

释曰。此第四为显依摄对治。能引五阴相续。令生有佛菩萨处为随顺逢事。非意相遇名逢。始终承奉不相离名事。是人依善知识。善知识为生善根故。修布施及爱语摄。为令成熟善根故。修利行摄。令得解脱善根故。修同利摄。依摄为显多闻四义。一多闻依止。谓善知识。二多闻因。谓菩提心。三多闻清净。谓如教修行。四多闻果。谓自利利他。初一是逢义。后三是事义。又前三对治依第四对治。第四对治摄前三对治。何以故。若无善知识。前三不得成故。前三依第四。前三即善知识功能故。为第四所摄

论曰。此闻熏习虽是世间法。初修观菩萨所得。应知此法属法身摄

释曰。耳识闻声引意识起。依文句了别其义。数数习之生功能。执持不忘名闻熏习。由此义故说是世间法。菩萨有二种。一在凡位。二在圣位。从初发心讫十信以还。并是凡位。从十解以上悉属圣位。初修观者即是凡夫菩萨。若初修观菩萨所得闻熏习。说名世间法。虽是世间法。而为法身至得因故。属法身摄

论曰。若声闻缘觉所得。属解脱身摄

释曰。若已得二乘究竟果人所有闻熏习。尚属解脱身摄。何况声闻缘觉菩萨。何以故。此二人但得解脱身。不能得如来法身。此二人由解脱身故。得与如来等。不由法身。如来由得法身故。于一切众生中无等。本识与闻熏习。虽相应共起共灭。而本识渐减。非本识相续渐增。此义我今当说

论曰。此闻熏习非阿梨耶识。属法身及解脱身摄。如是如是。从下中上次第渐增。如是如是。果报识次第渐减

释曰。闻熏习体是出世法。闻熏习因果属法身及解脱身摄。本识体是世间法。因是集谛。果是苦谛。故此两法自性相违。由此义故闻熏习渐增。本识渐减。闻熏习下品生本识上品减。闻熏习增至中品。本识中品减。闻熏习增至上品。本识下品减

论曰。依止即转

释曰。由道谛增集谛减道谛即是福德智慧。集谛即是本识中种子。由福慧渐增。种子渐减故得转依

论曰。若依止一向转是有种子。果报识即无种子。一切皆尽

释曰。依止即如来法身。次第渐增生道次第渐减集谛。是名一向舍。初地至二地乃至得佛。故名为转。烦恼业灭故言即无种子。此显有余涅槃。果报悉灭故言一切皆尽。此显无余涅槃。由此义故。本识与道虽复俱生。而有增减之异

论曰。若本识与非本识共起共灭。犹如水乳和合云何本识灭。非本识不灭

释曰。前举水乳和合。譬本识与非本识和合故。还举此为难。水乳和合既生灭必俱无有水乳偏灭尽义。本识非本识和合亦应尔。云何一灭一在

论曰。譬如于水鹅所饮乳

释曰。即以譬释难。水乳虽和合鹅饮之时。唯饮乳不饮水。故乳虽尽而水不竭。本识与非本识亦尔。虽复和合而一灭一在

论曰。犹如世间离欲时。不静地熏习灭。静地熏习增世间转依义得成。出世转依亦尔

释曰。前引世间所了事为譬。后引世间智人所了事为譬。如世间离欲人。于本识中。不静地烦恼及业种子灭。静地功德善根熏习圆满转下界依。成上界依。出世转依亦尔。由本识功能渐减。闻熏习等次第渐增。舍凡夫依作圣人依。圣人依者。闻熏习与解性和合。以此为依。一切圣道皆依此生

摄大乘论释卷第三摄大乘论释卷第四

        世亲菩萨释

        陈天竺三藏真谛译

    释引证品之二

    顺道理章第六

论曰。若人入灭心定。由说识不离身。是故果报识于定中应成不离身

释曰。此章复引不违道理。以显实有本识。若人谓第三第四果缘觉菩萨等。为得寂静住。及离退失过故圣人修灭心定。非灭心体称灭心。灭心法故名灭心。以能依从所依故立心名。佛世尊说。是于入定时识不离身。此识但是果报识。若离此识说六识中随一余识不离于身此义不成。何以故。修此灭心定为对治生起识。由观生起识有不寂静过失故。言过失者。六识缘外尘。有起不正思惟义。由不正思惟退失定。此是第一过失。由生起识在散动位中障。不得最细寂静处。此是第二过失。已得退失未得不得。为对治此二过失故修灭心定。若立识不离身。应知即是本识

论曰。何以故

释曰。复以何义证知。识不离身但是本识

论曰。灭心定非此识对治故

释曰。若人欲得寂静住不观此识过失不为对治此识故修灭心定。故正入灭心定时不灭此识。即说此识不离于身

论曰。云何知然

释曰。如此义云何可知。何故不言入灭心定时。实无复心。心非永灭后时更生故。说识不离身。佛世尊说。若人入第四定身行则断。若人入第二定等言行则断。若人入灭心定心行则断。如此身行断身不灭。心亦应尔。但心行灭心不灭。故说识不离身。何故不作如此说。若人执入灭心定。后出定时心则还生。由此义故说识不离身。是义不然。何以故

论曰。若从此定出。识不应更生

释曰。若在此定识相续断。无复所余故。无复从此定出及识更生义

论曰。何以故

释曰。欲更引道理以成此义

论曰。此果报识相续已断。若离托生时不复得生

释曰。如人一期报已尽。果报识相续永断。无还生义识若更生必托余生身。若离托余身。果报识还于本身中生。无有是处。故知入灭心定时。说识不离身唯是本识

论曰。若人说灭心定有心。此人所说则不成心

释曰。言有第六心名为有心。约第六心说识不离身。如彼所说则不成心

论曰。何以故

释曰。欲更引道理破第六识。立本识明不离身。若离如前所立相本识生起识中随执一识。言灭心定中有。是义不然。何以故

论曰。定义不成故

释曰。此下以十义。显灭心定中立有心义过失。此即第一过失。心与心法未曾见其相离。如余心法与余心法如想无时离受。受亦无时离想。心与心法亦尔。无时得相离。若不相离。灭受想定及灭心定悉不得成。由灭三法故此定得成。三法既不灭故此定不成。若人执有本识言识不离身。则无此过。何故余识皆灭此识独不灭。修灭心定者。求得寂静住。为对治能障寂静住心及心法故。灭心定生。不为对治不明了本识修灭心定故。余识灭此识。不灭。复次此定中若离本识。余识不成

论曰。解相及境不可得故

释曰。此第二过失。若执心及心法是有。此有必有解相及境界。解相有二种。一无分别。二有分别。无分别即是五识。意识或有分别或无分别。若无分别六识同是证知。若有分别则是比知。境界即是六尘及六尘真如故。心及心法解相及境界。皆可了别解相及境界。于此定中既不可得故。知此定中决无余识。若说此定中有本识则无此妨。此识能生依止所显故

论曰。与善根相应过故

释曰。此第三过失。复次若执此定有余识生。此识不出三性。谓善恶无记。此心不可立为善性。与善根相应过故。由此与彼相违故。若识不与善根相应。自性是善则无此义故。此心善决定与善根相应。若说由定心是善故。说定是善。是义不然。非汝所许与无贪等善根相应。此义应至以失灭心定义故。何以故。善心通无有别。一切心法皆不相离故。若不相离则受想亦不灭。是故不可立此心为善

论曰。与恶及无记不相应故

释曰。此第四过失。复次亦不可立此心为恶及无记性。此二性不成就故。离欲欲界时一切恶法皆灭。故非恶性。由此定是善故。不可立此心为无记性

论曰。想及受生起过故

释曰。此第五过失。复次不可说此心为善。有想受等生过失故。离善根善性不成。是故善心必与善根相应。如必与善根相应。亦应必与受想相应。无异因故此义不成。所对治是有。能对治亦是有。譬如欲等正生不净观等则不得有。若汝不许此义。故知不成善心

论曰。于三和合必有触故。于余定有功能故

释曰。此第六过失。复次若信受本识。此定中无有触生过患故譬如于余定。若灭心定中异本识有别善心生。此心必不离触。因定生安为相。能生乐受等。乐触。不苦不乐触应生因此安触。乐受不苦不乐受必应生。何以故。于余定为生乐舍二受。已见有功能。此定亦尔。以无遮障故。是故此定亦应依触生受。是义不然。何以故

论曰。但灭想是过患故

释曰。此第七过失。复次若信由触故此定有受。则此定唯无有想。是义不然。何以故。佛世尊说想受俱无故

论曰。作意信等善根生起过故

释曰。此第八过失。复次此触不应有。于余识处俱有相应触。生时有作意信等善根生起过故。若有触与心相应生。佛世尊说。作意受等必与触俱生。若有作意必能生善等心故。信等善根即随作意起。是义不然。以不免前所说过失。若汝欲离如前所说过失。及与阿含相违过失。由厌恶心法。是故但拔除心法故。此定唯有心无有心法。是义不然。何以故。从所依拔除能依。无道理故

论曰。拔除能依。离所依不可得故

释曰。此第九过失。复次若汝言由此定方便中厌恶触受想等故。拔除心法。但有心无触等者。是义不然。何以故。从所依拔除能依不可得故。所依是心。能依是心法。心及心法是所依能依事。从无始生死来。更互恒不相离。由此相引。是故心应成就与无贪等善根相应。若汝言定及定方便起。必与无贪等善根相违故。无贪等善根不生。但善心生。于余处未曾见有此义。诸法若因有相应。其相似果。亦有相应故。此执不然

论曰。有譬喻故

释曰。此第十过失。复次佛世尊说。于此定中一切身行语言行心行皆灭不起。身行谓出入两息。语言行谓觉观思惟。心行谓作意想受等。如觉观思惟灭尽。语言则不生。如是心行若灭心亦随灭。若汝言如身行灭时。人住定中身不坏灭。如此于定中心行虽灭而心不灭。此义亦不然。何以故

论曰。如非一切行。一切行不如是故

释曰。身行灭时有别住因。能持令此身不坏灭。如佛世尊说。若离出入两息饮食寿命识等。能持此身令不坏灭。如身行灭时。有别法持身令住。心行灭时无有别法持心令不灭。是故汝所立并此义不齐。是故此位由此道理定无有心。若无有心。云何佛世尊说识不离身。是果报心。佛世尊说名为识。若出观时。意识从此一切种子识生。由后识有因。及在定身有识食。故知本识定有。若彼本来是能依所依作大功用。拔除能依令离所依。无如此义。何以故。由譬成故。于世间中。从本以来乃至尽际。互不相离恒共生起。无道理拔除能依令离所依。犹如四大及四大所造色。无道理令所造离能造。心法亦尔。不可令离依止。是故于无心定。但有心无心法。是义不然。若汝执从所依拔除能依。此义不成。由但厌恶受及想故。唯此二法灭。于此定中二法不得行。余法不尔。是义不然。何以故。若非一切行。可得如此灭。非于一切行中得有如此灭。若遍行灭心必随灭。佛世尊不应说识不离身。由有此识故。知如来为成立。本识于此定中是有。复次经言识不离身。此言若离本识约余识则不成。何以故。此灭心定为对治生起识故生由观此生起识不寂静故。若有人执出定时心则还生。约此义故有不离之言。此亦不然。何以故。若有如此义。出定人心不更生果报识。若相续断离托后生时。无还生义。若有人离本识。由意识计灭心定有心。是人所执心则不成心。善恶无记性不成故。由说此定是善为性故非是恶。无记亦尔。威仪工巧变化心。此定中不得有故。若说有果报无记心。即是本识。以无第五无记故。若汝说此心是善则应与无贪等善根相应。何以故。染污心已灭善心正起。意根亦有境界。亦有三法和合。云何不生触。若有触云何无受。若尔灭心定义不得成。以心及心法于中不灭故。若有人执此定是善。由引因故。在方便有善心功用。能引此定心。定心是相似果。虽复是善。不与无贪等善根相应。是故如来欲显触生受故。先欲简别和合。依根缘尘生识。由三有能和合故触生受。若三和合无能。则但生触不生受。是故此定虽复是善。不能作有能和合故无受想。是方便心有三善根相应。相似果则不如此。是义不然。何以故。从所依拔除能依不可得故。此等难具如前说

论曰。若有人执色心次第生。是诸法种子。此执不然

释曰。若有人执前刹那色。是后刹那色因。能为后色作种子故。前刹那识是后刹那识因。能为后识作种子故。此执不然

论曰。何以故。已有前过。复有别失

释曰。前过谓若识相续断。后识无因应不得生。又一期报尽。离托后胎无更生义。有如此失前已具明。有作如此执者。若人从无色界退。还生下有色界。后色若应生。前种子久灭。此色从何因生

论曰。别失者。若人从无想天退。及出灭心定此中所执不成

释曰。生无想天及入灭心定。心已久灭。后若退生及出定。云何得成就先心。为后当生心因。若定如此

论曰。阿罗汉最后心亦不得成

释曰。阿罗汉无有入无余涅槃义。何以故。后色后心。为因不尽故。是故应知此义

论曰。若离次第缘此执不成

释曰。此前刹那色。由次第缘故。与后色相应。识亦如此。不由因缘故前后相应。是故此执若离次第缘立因缘义。此执不成。以违解脱故

论曰。如此若离一切种子。果报识净不净品皆不得成。是故此心有义成就应。当信知依前所说相。今当更作偈

释曰。此义具如前释。若人但在生起识。不在本识转依义则不成。为显此义故说三行偈

论曰

  菩萨于善识　　则离余五识
  无余心转依　　以何方便作
  若对治转依　　非灭故不成
  果因无差别　　于灭则有过
  无种子无法　　若许为转依
  于无二无故　　转依义不成

释曰。菩萨有二种。谓凡夫圣人。十信以还是凡夫。十解以上是圣人。今欲明转凡夫依作圣人依。此转依于何识得成。但是本识中成。若无本识于余识不得成。云何知然。此义三偈次第显之。离恶无记故言善。是第六识故言识。此善是出世心与三十七品等助道法相应。名为善识。此善识离五种散动法。尔与五识恒不相应故。言则离余五识。云何得相离生。一切时如此生故

论曰。无余心

释曰。离染污意识。及有流善识。若但说善识。不说无余心。有流善识则在其中

论曰。转依以何方便作

释曰。一切染浊种子灭离故。唯本识在。是名转依相。何方便作。如后偈说

论曰。若对治转依

释曰。若汝说由对治生故依止转异。说对治为转依。此义不然

论曰。非灭故不成

释曰。不以灭为转依。有二义不成。一若对治生而种子不灭依义如本非谓转依。二对治是转依了因。非转依体。对治是道谛。转依是解脱及法身。即是灭谛故。应以种子灭为转依。若汝执对治生。染浊种子灭。一时中有此二义。何故以灭为转依。不取道为转依。此执有过

论曰。果因无差别。于灭则有过

释曰。果是灭谛说名涅槃。因是道谛说名对治。若对治是灭谛因果则成一。若成一复有何过。若得对治即般涅槃。若有人立灭谛为转依。为当以种子灭为转依。为当以识灭为转依

论曰。无种子无法。若许为转依

释曰。若有人说能依所依灭名转依。意识中能依种子灭。能依种子既灭。所依意识亦灭。故名转依。若许此二义为转依。是则不然

论曰。于无二无故。转依义不成

释曰。第六生起识于定位中。若不在时无种子无。无作亦无故转依义不成。若有本识。生起识熏习所生种子。于本识中住。生起识虽复不在。可得令种子无。及令生起识无。说为转依。若离本识则无二无故。转依义不成。以是义故定应信有本识

    释差别品第四

    言说章第一

释曰。此品总有二章别有七章。总有二章者。一熏习。二事用。别有七章者。一言说。二我见。三有分。四引生。五果报。六缘相。七相貌。前三品已成立本识。是有品类差别今当更说

论曰。此阿梨耶识差别云何

释曰。此问本识。为性有差别。为事有差别

论曰。若略说或三种或四种差别

释曰。今就事明差别。唯一本识。其性不异。约事或三种。或四种。或七种差别

论曰。三种者。由三种熏习异故。谓言说我见有分熏习差别

释曰。论本所以不释此三者。后解应知胜相。初自分别此三义。故今不释。由言说熏习差别者。唯一本识由熏习差别故有三种。言说以名为体。名有二种。谓言说名。思惟名。此二种名以音声为本。约能见色根有声说谓眼。数习此言说。于中起爱熏习本识。此熏习是眼根生因。若果报眼根应生。从此本识中言说爱熏习生。是故立言说熏习为眼根因。如眼根于耳等根一切言说熏习生应作如此知。是本识第一差别

    我见章第二

论曰。由我见熏习差别

释曰。有染污识。由我见等依止故。于本识起我我所等熏习。由此熏习故起分别。谓自为我异我为他。是名本识第二差别

    有分章第三

论曰。由有分熏习差别

释曰。由随善恶不动业。于六道中所受六根有差别。是故本识有三有六道差别是名本识第三差别

    引生章第四

论曰。四种者。谓引生。果报。缘相。相貌差别。引生差别者。是熏习新生。若无此缘行生识。缘取生有。是义不成

释曰。引生种类差别此有何相。是熏习新生。若无引生本识差别。行生灭所熏习识。由取所摄故。对生有起此有不得成。从此有生起故说此为有法。取及善恶等是宿世所数习果

    果报章第五

论曰。果报差别者。依行于六道中此法成熟。若无此后时受生。所有诸法生起。此义不成

释曰。行有为引因。于六道中成熟是本识说名为引。若无此更生为法眼等诸根。色等诸尘更生不得成。此法即果报果

    缘相章第六

论曰。缘相差别者。于此心中有相能起我执。若无此于余心中执我相境。此义不成

释曰。此本识为第二识我执。第六识我见作缘相。是本识若无缘相差别。以身见为因。我执所缘境不得成。是名相似果

    相貌章第七

论曰。相貌差别者。此识有共相。有不共相。无受生种子相。有受生种子相

释曰。相貌差别品类有多种。若略说有四种

论曰。共相者。是器世界种子。不共相者。是各别内入种子。复次共相者。是无受生种子。不共相者。是有受生种子

释曰。本识与一切众生同功能。是众生所共用器世界生因。复次共相是无受生种子者。此本识是无觉受法。谓外四大五尘等生因。若无如此相貌本识。是器世界众生同用因则不成。不共相是各别内入种子者。各别是约自他立。境界不同种类不同取相不同。故言各别。又约自为内约他为外。是内根尘等生因为不共相。是有受生种子者。此本识是有觉受法生因。若无第二相貌。众生世界不得成。若由别因得成。如木石等无觉无受。此二种子何种子为圣道所破

论曰。若对治起时。不共所对治灭

释曰。此不共种子。若道起时。与道相违。必为道所破何以故。无一人得道余人得解脱。于共种子道有何功用

论曰。于共种子识。他分别所持正见清净

释曰。道于共种子无功用。亦有功用。如于不共种子功用。此中则无故言无功用。得道以后所见清净。与前见有异故言亦有功用。云何道于共种子不同功用。由他分别所持故。若尔道于共种子有何功用。但除分别。于境界中起无分别故。法眼于境界清净。但缘无性故。若约慈悲般若更起分别。此分别由依止真如故。则所分别成清净土。唯一境界。云何众生所见不同

论曰。譬如修观行人。于一类物种种愿乐。种种观察随心成立

释曰。由观行人变化心。于一类物众生见不同。如此境界他分别所持故。观行人于中得清净见

论曰。此中偈说

  难灭及难解　　说名为共结
  观行人心异　　由相大成外
  清净人未灭　　此中见清净
  成就净佛土　　由佛见清净

释曰。结有二种。一相结。二粗重结。相结难解。粗重结难灭。心分别诸尘名相结。由此分别起欲嗔等惑。说名粗重结。若得无分别智即解相结。相结不起粗重结即随灭。又释难灭约无间道。无间道难得故。难解约解脱道。由无间道难得故。解脱道难得。于共境界中起结故名共结。若约自相续则不名为共。云何此惑难灭难解

论曰。观行人心异。由相大成外

释曰。离识无别外境。是故观行人但观内法。是无不观外法故言心异分别相。通十方世界故言相大。观心与内种子正相违。与外不相关故言成外。由此三义故外结难解难灭。若此结有三义难灭难解。观行修道于此结有何功能

论曰。清净人未灭。此中见清净

释曰。对治道生不共种子灭时。是观行人或分分清净。或具分清净。虽复未灭外相。于中法眼慧眼清净无执

论曰。成就净佛土

释曰。若有智慧慈悲。起分别为利他。成就净佛土是其能。此净佛土何因缘得成

论曰。由佛见清净

释曰。初地是菩萨见。位初地中清净是见道清净。见道清净是名佛见清净。由此清净能得佛土清净。何况修位及究竟位。又真如观是名佛见。何以故。若至究竟位。所得真如观不异于此。故名佛见。又由依佛正教修能得此见。故名佛见。又菩萨亦得名佛。以定应得佛故。因受果名故称佛见。又菩萨对治道生不共种子灭。则具三清净。一法眼清净。二佛土清净。三见佛清净。谓见三身。菩萨缘佛起见。故名佛见

论曰。复有别偈

释曰。此偈欲何所显为显二义。一菩萨于内修观不依外。二由此观唯有识无有外尘。是二义互相显

论曰。种种愿及见观行人能成

释曰。观行人或为成自自在。或欲引他令受正教故愿。种种变异愿皆得成。若愿已成自见他见。如所愿亦皆得成。此愿为有别境为是一境

论曰。于一类物中

释曰。若多观行人别愿。同能变异一境。此变异得成。何故得成

论曰。随彼意成故

释曰。实无外境唯有识故。是故各随彼意变异得成。若实有外境。观行人愿则不成。因不成故。自他所见变异亦不得成

论曰。种种见成故所取唯有识

释曰。由观行人识为增上缘故。余人识变异。如观行人愿显现故。知定无外尘唯有本识。前已明觉受因定是不共种子。不觉受因定是共种子。今当更说共不共因同生一果

论曰。是不共本识差别。有觉受生种子。若无此众生世界生缘不成。是共阿梨耶识无受生种子。若无此器世界生缘不成

释曰。共不共二因生内五根及内五尘。为自六识作依止故。为不共因感。为他六识境界故。为共因感。若不双为二因所感。则无色阴及互相见

论曰。复次粗重相识。细轻相识

释曰。此文显本识是善恶二业相似果。亦是善恶二业生因

论曰。粗重相识者。谓大小二惑种子

释曰。于理及事心无功能故称粗重。一切未来惑及业皆从此识生故称种子

论曰。细轻相识者谓一切有流善法种子

释曰。于理及事心有功能故称细轻。一切未来信等五根善。皆从此识生故称种子

论曰。若无此由前业果有胜能。无胜能依止差别不得成

释曰。若无此识。分习果及果报果皆不得成。习果是相似果。果报果是六道本识。于本识中更有粗重相及细轻相。习果亦名相似果。胜能是相似果依止。是果报果善道中有人天异。恶道中有地狱畜生等异故。言依止差别。善道依止有胜能。恶道依止无胜能。若本识无此二相因果义皆不得成

论曰。复次有受不受相二种本识

释曰。欲显本识中功能有尽不尽

论曰。有受相者。果报已熟善恶种子识

释曰。此本识昔有善恶种子果报若皆熟用种子尽。但有本识在说。此本识为有受相

论曰。不受相者。名言熏习种子

释曰。此本识在生死中受用无尽。同业种子。由是有相续不断因故。名不受相。不受相其体云何。谓名言熏习种子。先以音声目一切法为言。后不发言直以心缘先音声为名。此名以分别为性。若以此名分别内法。或增或减。坏正理立非理名肉烦恼。若以此名分别外尘。起欲嗔等名皮烦恼。若以此名分别一切世出世法差别。离前二分别名心烦恼。是故一切烦恼皆以分别为体。障无分别境及无分别智。云何说此为不受相

论曰。无量时戏论生起种子故

释曰。四种世间言说名戏论。谓见闻觉知。但以名言分别。有此四种不缘实义故名戏论。约前后际戏论不穷。故言无量时戏论。此戏论若生若起。由名言熏习生故说名言熏习。为戏论种子。若无此二分有何过失

论曰。若无此识。有作不作善恶二业。由与果报故受用尽义不成

释曰。若无有受相本识。善恶二业数数有作及不作。由施与果报功能灭尽不更受报故名受用。此义不成。以失解脱义故。若无不受复有何失

论曰。始生名言熏习生起亦不得成

释曰。若离先名言熏习。今时未来时未曾有。而有此名言熏习则不得成。何以故。等流果若无同类因则不得生。若得生阿罗汉缘觉。断烦恼尽应更生烦恼。若不生应无根本烦恼。若无根本烦恼则无业。若无烦恼业则无有及差别。则集苦二谛自然灭尽。即入涅槃不劳修道。由此二义无。无解脱及自然解脱。故知定有受不受二相

论曰。复次有譬喻相识

释曰。譬如幻事为象马等乱心因。如此譬相本识是虚妄分别种子故。为一切颠倒乱心因

论曰。如幻事鹿渴梦相翳闇等。譬第一识似如此事

释曰。此四事譬四倒。幻事譬我执。鹿渴譬我爱。梦相譬我慢。翳闇譬无明。此四譬同譬本识。本识即似此四事。幻事能生众生邪执。鹿渴能生众生贪爱。梦相能生众生乱心。翳闇能障众生明了见境。阿陀那识若未灭。能变异本识生六识。起四种上心颠倒。故言本识似如此事

论曰。若无此虚妄分别种子故。此识不成颠倒因缘

释曰。若无本识一分与阿陀那识相应。则本识不成四颠倒因缘。何以故。如此本识。是虚妄分别种子因缘故。一切虚妄分别皆从此本识生

论曰。复有具不具相

释曰。约此譬喻相识本识。更成二相。一具缚相。二不具缚相

论曰。若具缚众生有具相

释曰。谓未离欲欲界众生。具三烦恼故名具相

论曰。若得世间离欲。有损害相

释曰。若众生离欲欲色界。肉心烦恼具足。皮烦恼有渐被损害义。此二约凡夫

论曰。若有学声闻及诸菩萨。有一分灭离相

释曰。肉烦恼一分尽。皮烦恼或被损或未被损

论曰。若阿罗汉缘觉如来。有具分灭离相。何以故。阿罗汉独觉单灭惑障。如来双灭惑智二障

释曰。阿罗汉独觉但灭离见修二道所破惑尽。故无解脱障。如来具灭离三烦恼尽。故如来本识永离一切解脱障及智障。此识或名无分别智。或名无分别后智。若于众生起利益事。一分名俗智。若缘一切法无性起。一分名真如智。此二合名应身

论曰。若无此烦恼。次第灭尽则不得成

释曰。若无此具相不具相。凡夫有学圣人无学圣人次第灭。此义不成。本识于三性中。何故但是无记性。是果报故

论曰。何因缘善恶二法果报唯是无覆无记

释曰。非烦恼染污故名无覆无记。不同上界烦恼是有覆无记。何故不同。因是善恶而果是无记

论曰。此无记性。与善恶二法俱生不相违

释曰。由无覆无记性与善恶二性不相违故。于无记果报中善恶二业得生。由业生故有善恶二道

论曰。善恶二法自互相违

释曰。若果报是善恶。善恶性互相违若是善恶不得生。应无恶道。若是恶善不得生。应无善道。善恶二道则随一无道

论曰。若果报成善恶性。无方便得解脱烦恼

释曰。若果报是善恶性。从善更生善果报。从恶更生恶果报。由报更有报。则生死不断故无得解脱义

论曰。又无方便得起善及烦恼

释曰。若定是善烦恼不得起。若定是恶善不得起

论曰。故无解脱及系缚

释曰。若无善则无解脱。若无烦恼则无系缚

论曰。无此二义故。是故果报识。定是无覆无记性

释曰。无无解脱义。无无系缚义。既定有解脱及系缚。故知本识定是无记性

摄大乘论释卷第四摄大乘论释卷第五

        世亲菩萨释

        陈天竺三藏真谛译

    释应知胜相第二之一

    相章第一

此义有四章。一相。二差别。三分别。四显了意依

论曰。如此已说应知依止胜相。云何应知应知胜相

释曰。前说次第有十义。已释第一依止胜相。次应释第二应知胜相。此义有几数。有何名有何相。此三云何可见

论曰。此应知相略说有三种

释曰。此下答前三问。明略说第二胜相数有三。即是三名三相。何等为三

论曰。一依他性相。二分别性相。三真实性相

释曰。此语先显数三及三数所目之名。三相次后文别解。一二三是数。依他分别真实是名

论曰。依他性相者

释曰。此下释三相

论曰。本识为种子。虚妄分别所摄诸识差别

释曰。由本识能变异作十一识。本识即是十一识种子。十一识既异故言差别。分别是识性。识性何所分别。分别无为有故言虚妄。分别为因。虚妄为果。由虚妄果得显分别因。以此分别性。摄一切诸识皆尽

论曰。何者为差别

释曰。此不问通性。但问诸识差别

论曰。谓身识。身者识。受者识。应受识。正受识。世识数识。处识言说识。自他差别识。善恶两道生死识。身识身者识。受者识。应受识。正受识。世识数识处识。言说识。如此等识。因言说熏习种子生。自他差别识。因我见熏习种子生。善恶两道生死识。因有分熏习种子生

释曰。身识谓眼等五界。身者识谓染污识。受者识谓意界。应受识谓色等六外界。正受识谓六识界。世识谓生死相续不断识。数识谓从一乃至阿僧祇数识。处识谓器世界识。言说识谓见闻觉知识。如此九识是应知依止。言说熏习差别为因。自他差别识者。谓自他依止差别识。我见熏习为因。善恶两道生死识者。谓生死道多种差别识。有分熏习为因

论曰。由如此等识。一切界道烦恼所摄

释曰。一切界即三界十八界。一切道即六道。于此界此道中有三烦恼。即惑业果报此三亦名烦恼。亦名为浊。俗谛不出此等法。即以前十一识摄此等法。以其同性故得相摄

论曰。依他性为相。虚妄分别即得显现

释曰。欲显虚妄分别。但以依他性为体相。乱识及乱识变异。即是虚妄分别。分别即是乱识。虚妄即是乱识变异。虚妄分别若广说有十一种识。若略说有四种识。一似尘识。二似根识。三似我识。四似识识。一切三界中所有虚妄分别。不出此义。由如此识即得显现。虽说如此识摄一切虚妄分别皆尽。执此虚妄分别中。何者为依他性。何者为分别性

论曰。如此等识。虚妄分别所摄唯识为体

释曰。如此等识即显十一识及四识。一切法中唯有识。更无余法故唯识为体。此体由有故异分别性。由虚妄分别性摄故。异真实性。此性非实有实非无故。不免虚妄。此虚妄是其性故。说虚妄分别所摄

论曰。非有虚妄尘显现依止。是名依他性相

释曰。定无所有故言非有。非有物而为六识缘缘故言虚妄尘。似根尘我识。生住灭等心变异明了故言显现。此显现以依他性为因故言依止。譬如执我为尘。此尘实无所有。以我非有故。由心变异显现似我故。说非有虚妄尘。显现此事因依他性起故。依他性为虚妄尘显现依止。说此为依他性相

论曰。分别性相者实无有尘。唯有识体显现为尘。是名分别性相

释曰。如无我等尘无有别体。唯识为体不以识为分别性。识所变异显现为我等。尘无而似有为识所取。名分别性

论曰。真实性相者。是依他性。由此尘相永无所有。此实不无。是名真实性相

释曰。虚妄义永不有显现因。由显现体不有故。亦不可得。譬如我等尘显现似实有。由此显现。依证比圣言三量。寻求其体实不可得。如我尘法尘亦尔。永无有体故人法皆无我。如此无我实有不无。由此二种尘无有体故。依他性不可得。亦实有不无。是名真实性相

论曰。由身识身者识受者识。应知摄眼等六内界。以应受识。应知摄色等六外界。以正受识。应知摄眼等六识界。由如此等识为本。其余诸识是此识差别

释曰。此言欲显何义。欲显真实性义。若不定明一切法唯有识。真实性则不得显现。若不具说十一识。说俗谛不尽。若止说前五识。唯得俗谛根本。不得俗谛差别义。若说俗谛不遍。真谛则不明了。真不明了则遣俗不尽。是故具说十一识。通摄俗谛为如十八界具有根尘识。为不尔

论曰。如此众识唯识。以无尘等故

释曰。识所变异虽有内外事相不同。实唯一识。无有尘等别体故皆以识为名。若无尘此识离尘。爱憎等受用云何得成

论曰。譬如梦等于梦中。离诸外尘一向唯识。种种色声香味触。舍林地山等诸尘。如实显现。此中无一尘是实有

释曰。梦中所见有种种差别。并无实尘。悉是识之所作。爱憎等受用此义亦成

论曰。由如此譬。一切处应知唯有识。由此等言应知幻事鹿渴翳闇等譬。若觉人所见尘。一切处唯有识。譬如梦尘如人梦觉。了别梦尘但唯有识。于觉时何故不尔不无此义。若人已得真如智觉。不无此觉。譬如人正在梦中。未觉此觉不生。若人已觉方有此觉。如此若人未得真如智觉。亦无此觉。若人已得真如智觉。必有此觉。若人未得真如智觉。于唯识中云何得起比智。由圣教及真理可得比度。圣教者。如十地经中佛世尊言。佛子。三界者唯有识。又如解节经中说

释曰。由此梦譬于十八界等处。应知唯识无尘等。何故引二阿含明圣教。前是略说。后是广说。即以前证后

论曰。是时弥勒菩萨摩诃萨问佛世尊。世尊。此色相是定心所缘境。为与心异。为与心不异

释曰。是时有三义。一平等时。谓无沉浮颠倒。二和合时。谓令闻能闻正闻。三转法轮时。谓正说正受。色相者。谓十一切入中。前八入等。此色相是定心所缘境。为心别境别。为是心是境

论曰。佛世尊言。弥勒。与心不异。何以故。我说唯有识。此色相境界识所显现

释曰。佛说唯有识。无尘故。若尔此色是观行人所见。为是何法。如经言。此色相境界识所显现实无境界。是识变异所作。先说唯识后说境界识。此二识有何异。欲显有两分。前识是定体后识是定境。此体及境本是一识。一似能分别起。一似所分别起

论曰。弥勒菩萨言。世尊。若定境界色相与定心不异。云何此识取此识为境

释曰。若有别识为识境。则唯识义不成。若缘自体为境事亦不成。以世间无此类故

论曰。佛世尊言。弥勒。无有法能取余法。虽不能取此识。如此变生显现如尘

释曰。此识如此相貌生。于定中起二种相。一由能取相起不同。二所取相起不同。此二相从一识俱时显现。此青等色相是定境。非所忆持识。由此色不在定处。如前所证后更忆持。无有此义。尘起现前分明显现。此忆持识有染污。此起现前所见分明清净。若汝言闻思二境数数所习。今时已过追更思惟。如昔所见今时重见。是义不然。何以故。此闻思二境。由过去故今则非有。此非有时若似昔起。非昔所见。则唯识之旨于此弥彰。是故唯识义及尘无所有义得成

论曰。譬如依面见面。谓我见影。此影显现相似异面

释曰。此譬为显但有自面无有别影。何以故。诸法和合道理难可思议。不可见法而令得见。犹如水镜等影实无别法。还见自面谓有别影

论曰。定心亦尔显现似尘谓异定心

释曰。定心有二分。一分似识。二分似尘。此二种实唯是识

论曰。由此阿含及所成道理。唯识义显现

释曰。阿含即前二经。道理谓忆持识过去色。及面影譬等道理。显唯识义

论曰。云何如此

释曰。此问云何言唯有识

论曰。是时观行人心正在观中。若见青黄等遍入色相。即见自心不见余境青黄等色

释曰。若在散心。五识可言缘现在外尘起。若散心意识缘过去尘起。若在观中必不得缘外色为境。色在现前又非缘过去境。当知定心所缘色即见自心不见别境

论曰。由此道理一切识中。菩萨于唯识应作如此比知。于青黄等识非忆持识。以见境在现前故。于闻思两位。忆持意识。此识缘过去境。似过去境起。是故得成唯识义。由此比知菩萨若未得真如智觉。于唯识义得生比智

释曰。前明十一识。通说十八界。十八界中有根有尘。菩萨于唯识义中应观。定中色既无别境。以定中色比定外色。应知亦无别境

论曰。是种种识前已说

释曰。十一识前已具说。将欲立难故。须先明前已说十一识

论曰。譬如幻事梦等。于中眼识等识。唯识义可成

释曰。前举幻等以譬无别根尘。今欲难唯识有成不成故。须引前所举譬。于十一识中具十八界。前明正受识即六识界。可说唯识义

论曰。眼色等识有色。唯识义云何可见

释曰。此难余十界不应说唯识。前明身识即是五根。谓眼识乃至身识。前明应受识即是五尘。谓色识乃至触识。故言眼色等识。有色有三义。一眼识未生时先已有色。二识变异为色亦是有色。三由有色境。眼识似色起。名了别色。若无色境何所了别。约此十界唯识义应不成

论曰。此等识由阿含及道理。如前应知

释曰。此答向问。由前二经及前所引譬等道理。应作如此知

论曰。若色是识。云何显现似色

释曰。此问若言无别色尘唯是本识。何故显现似色等

论曰。云何相续坚住。前后相似

释曰。此问若是识变异所作。则应乍起乍灭改转不定。云何一色于多时中相续久住。前后一类无有改转。故知应有别色

论曰。由颠倒等烦恼依止故

释曰。颠倒是烦恼根本。由识变异起诸分别。分别即是颠倒。颠倒故生诸烦恼依他性与分别性相应。即是颠倒烦恼所依止处。由颠倒烦恼。令依他性与分别性相应。颠倒烦恼又是识变异所依止处

论曰。若不尔于非义义。颠倒不得成

释曰。若无互为依止义。则识无变异。于非物中分别为物。不应有此颠倒

论曰。若无义颠倒。惑障及智障二种烦恼则不得成

释曰。若识不变异分别非义为义。岂有颠倒。若无颠倒则不生烦恼。若无烦恼声闻无解脱障。菩萨无一切智障

论曰。若无二障。清净品亦不得成。是故诸识如此生起。可信是实

释曰。若无烦恼岂有圣道。故此义亦不成。是故应信离识无别法

论曰。此中说偈

  乱因及乱体　　色识无色识
  若前识不有　　后识不得生

释曰。无中执有名乱。此乱识因何法生。因色识生。何者为色识。若约五识。五根五尘名为色识。此色识能生眼等识。识此色识即是乱因。若此识不起。不得于无中执有。何法名乱体。谓无色识。若约五根即是五识。若约意根但是意识。非法识。法识及色识无色识悉是乱因

论曰。若前识不有。后识不得生

释曰。前识是乱因。若本不有。乱体是果。即是后识。无因则不得生

    差别章第二

论曰。云何身识身者识受者识应受识正受识。于一切生处更互密合生

释曰。此五识即十八界。于三界六道四生一切生处。此十八种云何得更互密合生

论曰。具足受生所显故

释曰。于一切生处一刹那中具足有十八界。十八界既不相离能为显因。显更互密合生。又根尘识必不相离。无有受生有根而无尘及识受。余二亦尔。受一必具余二。用余二以显此一。为不相离故得更互密合生

论曰。云何世识等。如前说有种种差别生

释曰。此更问前五识。即十八界摄法已尽。何用更说生后六识

论曰。无始生死相续不断绝故

释曰。为明众生果报。无始以来三世生死相续不断故。须立世识

论曰。无量众生界所摄故

释曰。为明众生果报。有诸界多少不同。如四界六界十八界等故。须立数识摄一切数

论曰。无量器世界所摄故

释曰。为明众生所居处。如人天恶道有无量差别故。须立处处识摄一切处

论曰。无量作事。更互显示所摄故

释曰。为明见闻觉知。各有多种因。此有无量言说作事言说。与见等更互相显示故。须立言说识摄一切言说

论曰。无量摄及受用差别所摄故

释曰。摄约自他摄。受用自他所受用。为明众生各各计我有多种。我所亦然。故须立自他差别识。摄一切自他差别

论曰。无量受用。爱憎业果报所摄故

释曰。善业果为爱。恶业果为憎。众生受用此二业果有无量种

论曰。无量生及死。证得差别所摄故

释曰。此二果中有生有死。初受为生。生后相续为得。将死为证。命断为死。为明众生受用二业果。有生有死。摄一切善恶两道生死

论曰。云何正辩如此等识。令成唯识义

释曰。前说五识义已成唯识。后说六识。云何亦令成唯识

论曰。若略说有三相诸识。则成唯识

释曰。此六识若安立使成唯识有三种道理。道理即是三相。一入唯量。二入唯二。三入种种类。入者通达义。云何入唯量

论曰。唯有识量

释曰。于六识中。若如理研寻。但唯见识。不见余法。何以故

论曰。外尘无所有故

释曰。所识诸法离识实无所有故。说六识唯有识量。云何入唯二

论曰。唯有二。谓相及见识所摄故

释曰。若能通达世等六识。一分成相。一分成见。名入唯二。此义云何。诸识中随一识一分变异成色等相。一分变异成见。故名唯二。由世等六识不出此二识性故说唯二所摄。云何入种种类

论曰。由种种相生所摄故。此义云何。此一切识无尘故成唯识。有相有见眼等诸识。以色等为相故。眼等诸识以诸识为见故。意识以一切眼识乃至法识为相故。意识以意识为见故。云何如此。意识能分别故似一切识尘分生故

释曰。是一眼识。如所应成一分能起种种相。一分能取种种相。能取者即名见。若意识取意识。一切眼等识及法识为相。意识为能见。复次种种相生者。但意识是种种相生。以缘境不定故。其余诸识定缘一类尘。不能分别。能分别则成见。不能分别则成相。由此三相成立。世等六识为唯识此义显现

论曰。此中说偈

  入唯量唯二　　种种观人说
  通达唯识时　　及伏离识位

释曰。此偈显三种通达唯识义。一通达唯量外尘实无所有故。二通达唯二相及见唯识故。三通达种种色生。但有种种相貌而无体异故。如此三相何人能通达。但观行人。观行人自有二种。一入见位菩萨。二得四空定等。观行人先已通达后为他说。此通达及说何位得成

论曰。通达唯识时。及伏离识位

释曰。从初地乃至正觉地。为通达唯识位。从空处乃至非想非非想无想定灭心定。为伏离识位。所取尘若无。云何说识为能取。则唯量义不成。是义不然。何以故。唯识义不失。亦不无能取所取义。为立此义故显三相入。唯量者为显唯识无尘。所识既无。云何成唯识。为立此义故说唯二及种种。唯二谓相及见。相是所取。见是能取。种种亦尔。是故唯识及能取所取。此义悉成。后半偈如前解

论曰。诸师说此意识。随种种依止生起。得种种名

释曰。诸师谓诸菩萨。成立一意识次第生起。意识虽一。若依止眼根生得眼识名。乃至依止身根生得身识名。此中更无余识异于意识。离阿黎耶识此本识入意识摄。以同类故。此意识由依止得别名

论曰。譬如作意业得身口等业名

释曰。此作意业虽复是一。若依身门起名身业。若依口门起名口业。意识亦尔。随依止得别名。若有人说眼等五根无有分别。若意识依止此生亦无分别。譬如依止意根惑所染污。由所依止有染污。能依止识生时亦有染污。意识亦尔

论曰。此识于一切依止生

释曰。谓依止眼等诸根生

论曰。种种相貌似二种法显现。一似尘显现。二似分别显现

释曰。意识依六根生显现似二种法。一多类法。二一类法。多类法此分属尘。一类法是分别属见。由此两句识。虽一法一分似尘显现。一分似分别尘显现。是故前说无失

论曰。一切处似触显现

释曰。一切处谓有色处。有色处必有身。若有身必似触显现

论曰。若在有色界。意识依身故生

释曰。何故有身处必似触。以意识必依身生故。似触显现。由此意识依身似触生故。观行人正入观时。五识虽复不起。中间于色身有喜乐受生

论曰。譬如有色诸根。依止身生

释曰。有色诸根。即眼等根异于色身。依止于身。由诸根依止身故。因此诸根。于身或损或益。意识亦尔。依止身故。似触显现。于身亦有损益。复次譬如身根依止于身。若有外触缘。身根似触而起。若似触起。于自依止中或损或益。意识亦尔。依止身故。似触而起

论曰。此中说偈

释曰。诸菩萨说。但有意识无别五识故。引法足经偈以成立此义

论曰

  远行及独行　　无身住空窟
  调伏难调伏　　则解脱魔缚

释曰。能缘一切境界故名远行。无第二识故名独行。无身有二义。一无色身。二无生身。身内名空窟。识在身内故名住空窟。二五藏中心藏其中有孔。意识在此孔中故名住空窟。三诸法实无所有。而执为有。识在此无所有中。故名住空窟。本来鄙恶烦恼为因故名难调伏。若人能调伏此识。令不随顺惑业而得自在故名调伏。三界惑障名魔缚。此人调伏难调伏则得解脱。复有别圣言以证此义

论曰。如经言此眼等五根。所缘境界一一境界。意识能取分别。意识为彼生因

释曰。此五根所缘色等境。若识能缘色则立为眼识。一一境意识既悉能取。又能分别。是故五识无用。又意识若乱眼等识则不生。由意识变异。生眼等根及识。是故意识为彼生因

论曰。复有别说。分别说十二入中。是六识聚说名意入

释曰。此更引圣言证唯有意识。无别有余识。如来于经中分别十二入。合六识聚以为意入。以此三义故知。唯有意识无别余识

论曰。是处安立本识为义识。此中一切识说名相识。意识及依止识应知名见识。何以故。此相识由是见生因。显现似尘故作见生依止事

释曰。是本识于二识中。可得安立为相识及见识。不是安立本识为尘识。此中一切识说名相识。本识可得安立于相见二识处。此本识以意识及依止识为见识。以眼识等识及一切法为相识。为此生因由缘缘故。于彼处中是见生因故。于彼法为见。显现似尘故意识见相续住不断因故。作此识依止事

论曰。如此诸识成立唯识。云何诸尘现前显现知其非有。如佛世尊说。若菩萨与四法相应。能寻能入一切识无尘

释曰。四法是智。菩萨若与四智相应。在方便中能寻理得正解能入理。故知一切唯识无尘

论曰。何者为四。一知相违识相。譬如饿鬼畜生人天。于同境界由见识有异

释曰。于一境界分别不同。故名相违相违识境名相。此境实无所有。但随识变异故分别不同。菩萨若通达此理则解唯识故名为智

论曰。二由见无境界识。譬如于过去未来梦影尘中

释曰。有时见离境界识得生。譬如识过去等境

论曰。三由知离功用无颠倒应成。譬如实有尘中缘尘起识。不成颠倒不由功用如实知故

释曰。菩萨作如此解。若尘如所显实有。离修对治自然应成无颠倒智。由如实知故既无此义。故知实无有尘。但于无中执有故成颠倒

论曰。四由知义随顺三慧

释曰。一切尘义悉随逐三慧。菩萨能如此知

论曰。云何如此

释曰。云何一切义随逐三慧

论曰。一切圣人入观

释曰。圣人谓声闻缘觉菩萨。此等圣人正在定中名为入观

论曰。得心自在

释曰。已得心随事成。谓入住出位中

论曰。由愿乐自在故

释曰。如所愿乐。诸尘皆随愿乐变异

论曰。如愿乐尘种种显现故

释曰。若欲令地界成水界。如意即成。火等界亦尔

论曰。若观行人已得奢摩他

释曰。观行人有二种。一得正思。二得正修。今明得正修人

论曰。修法观加行

释曰。法谓修多罗等十二部经。依十二部经所显法相。熟修行毗婆舍那

论曰。随唯思惟义显现故

释曰。于一五阴中随心思惟。或显现如不净苦无常空无我等乃至十六谛相悉随思惟。显现及余一切法相亦尔

论曰。若人得无分别智。未出无分别观。一切尘不显现故。由境界等义随顺三慧。由前引证成就唯识义。故知唯识无尘。此中有六偈重显前义。此偈后依智学中当广分别说。谓饿鬼畜生人天如是等

释曰。若菩萨已得无分别智。正在观中若尘如所显现实有。无分别智则不得成。既实有无分别智。故知道理实无所有

    分别章第三

论曰。若唯识似尘显现。依止说名依他性。云何成依他何因缘说名依他

释曰。离尘唯有识。此识能生变异。显现似尘。如此体相及功能。乱识说名依他性。唯见乱识有自体。不见有他。云何成立此识为依他性。若言能生变异。变异依此识。乃是为他所依。云何说此识为依他性

论曰。从自熏习种子生故。系属因缘不得自在。若生无有功能。过一刹那得自住故。说名依他

释曰。由自因生故。生已无有自能停住。过一刹那自所取故。由约他说故名依他

论曰。若分别性依依他。实无所有似尘显现。云何成分别。何因缘说名分别

释曰。此问有三。一问依止。此分别性既依止于他。应成依他性。云何名分别。次问无所有。此分别既实无所有。无所有中有何分别。后问似尘。此分别既似尘显现。云何称分别。何因缘故。说名分别性

论曰。无量相貌。意识分别颠倒生因故成分别

释曰。一切尘相貌。是分别说名意识。意识颠倒生境界故名生因。由此道理故成分别

论曰。无有自相唯见分别故。说名分别

释曰。自体既无唯见乱识故。说名分别

论曰。若真实性分别性。永无所有为相云何成真实。何因缘说名真实

释曰。分别性于依他性一分永无。若以无所有为相。何故立为真实。不立为非真实。说亦如此

论曰。由如无不如。故成真实

释曰。此下三义答两问。此是第一以不相违义显真实。如世间说真实友

论曰。由成就清净境界

释曰。此是第二以无颠倒义显真实。由境界无颠倒故。得四种清净。如世间说真实物

论曰。由一切善法中最胜

释曰。此是第三以无分别义显真实。即五种无分别。谓五种真实。如世间说真实行

论曰。于胜义成就故说名真实

释曰。于前三胜无有坏失故说成就。由成就故真实

论曰。复次若有分别及所分别。分别性成

释曰。欲问此三种分别义。故先列出此三分别名

论曰。此中何法名分别。何法所分别。何法名分别性

释曰。一一别问。求其异相

论曰。意识是分别。具三种分别故

释曰。此下答三问此即答第一问。六识之中但以意识为分别。以意识具自性忆持显示三分别故五识则不尔

论曰。何以故

释曰。何以故。意识具三分别

论曰。此识自言熏习为种子

释曰。如说根尘名。数习此名熏习于本识。以为种子。由此种子后时意识。似根似尘而起名为色识自有二义。一如眼名熏习。唯生眼不生余法。余熏习亦尔故称自。二本无法体。言语是自分别所作故名自

论曰。及一切识言熏习为种子

释曰。如说六识名。数习此名熏习本识为种子。由此种子。意识后时似六识而起。名为识识

论曰。是故此生

释曰。由二种熏习种子故。此意识得生

论曰。由无边分别。一切处分别

释曰。意识为此二种种子所变。分别功能无边故。似一切境界起

论曰。但名分别说名分别

释曰。由此义故但意识名分别故。三种分别中说意识名分别

论曰。此依他但是所分别

释曰。此下答第二问。所分别一切法。离识无别体。故以依他为所分别

论曰。是因能成依他性。为所分别

释曰。若不藉因依他性不成。若无依他性则无所分别。由六种因成依他性。故得以依他性为所分别

论曰。此中名分别性

释曰。此中成依他性因。说此因为分别性

论曰。云何分别能计度。此依他性但如万物相

释曰。此下答第三问。先更问后次第答。此语先总问。云何意识由分别故。能计度此依他性。但如万物相貌。不但如一物相貌

论曰。缘何境界

释曰。此下别举六因为问。缘何法为境界。计度依他性

论曰。执何相貌

释曰。执何相貌。计度依他性

论曰。云何观见

释曰。先以何方便推寻。后决断计度依他性

论曰。云何缘起

释曰。藉何缘发起。计度依他性

论曰。云何言说

释曰。以何言说。计度依他性

论曰。云何增益

释曰。云何于无中执有。计度依他性。意识名分别。依他是所分别。由此六因意识能分别依他性今当显说此义

论曰。由名等境界

释曰。由依他性离一切分别。无分别为体故。立名等为境界。分别计度此性

论曰。于依他性中。由执着相

释曰。先约名分别串习此名故执着此名以为相貌。后时分别此相。谓为眼等诸根。色等诸尘。识等诸心。执相貌已

论曰。由决判起见

释曰。先思量是非。后时决判如我所见。眼等诸根乃至识等诸心。悉是实有所余妄言。由此见故意识计度依他坚实起执已

论曰。由觉观言说缘起

释曰。如自所执起觉观。思惟为自计度。或如自所执起觉观言说令他计度。云何言说令他计度

论曰。由见等四种言说

释曰。如所言说不出见等四种。此四种约根尘识成就故。摄一切所说分别品类皆尽。约此言说起颠倒

论曰。实无有尘。计实有为增益

释曰。如四种言说实无有法。此中起执谓为实有。此名增益执

论曰。由此因故能分别

释曰。由此六因意识。能分别依他性。令成所分别故。故以此因为分别性

论曰。此三种性云何

释曰。此问三性一异义云何

论曰。与他为异为不异

释曰。如依他性与余二性为一为异。余二性互论亦尔

论曰。不异非不异。应如此说

释曰。答问明亦一亦异应依此说

论曰。有别义依他性名依他

释曰。此下总标亦一亦异义唯是一识识即依他性。于依他性中以别道理成立为三性。三性互不相是。即是不异非不异义

论曰。有别义此成分别。有别义此成真实

释曰。有别道理。此依他性成。分别性真实性亦尔

论曰。何者别义说名依他。从熏习种子生系属他故

释曰。此下正释三种别义。熏习有三种。一名言熏习识熏习二色识熏习识识熏习见识熏习。三烦恼熏习业熏习果报熏习。从此三种种子生。系属于因故。成依他。非余二性

论曰。复有何义此成分别。此依他性为分别因

释曰。识以能分别为性。能分别必从所分别生。依他性即是所分别。为分别生因。即是分别缘。缘依他性有两义。若谈识体从种子生。自属依他性。若谈变异为色等相貌此属分别性。色等相貌离识无别体。今言依他性为分别因。取依他变异义为分别因。不取识体从种子生义为分别因

论曰。是所分别故成分别

释曰。变异相貌是识所分别。以此义故成立所分别。为分别性

论曰。复有何义此成真实此依他性或成真实。如所分别实不如是有故

释曰。依他性变异为色等所分别尘。此尘实不如所分别是有。约依他性明尘无所有。即以依他性成真实性。为存有道故。不明依他性。是无为真实性

论曰。复有何义。由此一识成一切种种识相貌

释曰。此更问复以何道理。唯是一识或成八识。或成十一识故。言一切。于一一识中。如眼识分别青黄等差别。有种种识相貌。唯是一识复是何识。所以更为此问者前已释异义。此下释不异义。欲显依他性具有三性。一识从种子生是依他有。种种识相貌是分别。分别实无所有是真实性

论曰。本识识

释曰。一识谓一本识。本识变异为诸识故言识识。今不论变异为根尘。故但言识识

论曰。所余生起识。种种相貌故

释曰。所余即阿陀那识。生起即六识。变异为七识。即是本识相貌

论曰。复因此相貌生故

释曰。以七识熏习本识为种子。此种子复变异本识为七识。后七识即从前相貌种子生

论曰。依他性有几种

释曰。此问体类及义。并有几种

论曰。若略说有二种。一系属熏习种子

释曰。此先明依他体类。从二种熏习生。一从业烦恼熏习生。二从闻熏习生。由体类系属此二熏习。故称依他性。若果报识体类为依他性。从业烦恼熏习生。若出世间思修慧体类。从闻熏习生

论曰。二系属净品不净品性不成就。是故由此二种系属。说名依他性

释曰。此次释依他义。若识分别此性或成烦恼。或成业或成果报。则属不净品。若般若缘此性无所分别则成净品。谓境界清净道清净果清净。若有自性不依。他则应定属一品。既无定性或属净品。或属不净品。由此二分。随一分不成就故名依他

论曰。分别性亦有二种。一由分别自性

释曰。如眼等诸界中分别一界。或眼或耳等名分别自性

论曰。二由分别差别

释曰。约无常等。更分别此眼等。名分别差别

论曰。真实性亦有二种。一自性成就

释曰。谓有垢真如

论曰。二清净成就

释曰。谓无垢真如

论曰。复有分别更成四种。一分别自性。二分别差别。三有觉。四无觉。有觉者能了别名言众生分别

释曰。若众生先了别见闻等四种言说。因名言起分别故名有觉

论曰。无觉者。不能了别名言众生分别

释曰。若众生如牛羊等。先不能了别见闻等四种言说。由彼如所分别不能由言语成立。故名无觉

论曰。复次分别有五种。一依名分别义自性

释曰。义谓名所目之法。先已知此物名。后以此名分别取此物

论曰。譬如此名目此义

释曰。此名本来主此体故。得以此名。分别此体

论曰。二依义分别名自性

释曰。先识此物体。未知其名。后闻说其名。即以先所识体。分别取此名

论曰。譬如此义属此名

释曰。此体本主此名故。得将此体分别取此名

论曰。三依名分别名自性

释曰。如异国物名。始闻未解后。以常所习名。分别此名。方解此名

论曰。譬如分别未识义名

释曰。未识此名所训之义。故不解此名

论曰。四依义分别义自性

释曰。如见此物体未识其名。以此物类分别此物方识其体

论曰。譬如分别未识名义

释曰。由未识名故以义分别义

论曰。五依二分别二自性

释曰。如金银二名有金银二体。于此名体并未了。金名为目赤体为目白体。银名亦尔赤体为主金名为主。银名白体亦尔

论曰。譬如此名此义何义何名

释曰。意如向释

论曰。若摄一切分别。复有十种

释曰。如前已有具摄义但未明品类。具摄义此十种分别。更显品类摄义。又明摄一切皆尽

论曰。一根本分别谓本识

释曰。是一切分别根本自体。亦分别即是阿黎耶识

论曰。二相分别。谓色等识

释曰。此分别以相为相。即是色等尘识

论曰。三依显示分别。谓有依止眼等识识

释曰。此分别以依。及显示为相。亦是所分别亦是能分别。即是六根及六识。六根是所依止。六识是能依止

论曰。四相变异分别

释曰。相谓六尘。此分别以相变异为相

论曰。谓老等变异

释曰。是身四大前后变异名老。若识分别此老名老相变异分别。等言摄病及死

论曰。苦乐等受

释曰。身心苦乐受。前后变异。识分别此受名受相变异分别。等言摄不苦不乐受

论曰。欲等惑

释曰。心欲前后变异。识分别此欲名。欲相变异分别。等言摄嗔痴等惑

论曰。及抂时节等变异

释曰。非理逼害缚录为抂不乖候寒热丰俭为时节。抂及时节前后变异。识分别此抂及时节名抂时节相变异分别。等言摄有因缘逼害缚录。乖候寒热丰俭

论曰。地狱等

释曰。是道变异。舍此五阴受地狱道五阴。诸道前后变异故名道变异。识分别此道故。名道相变异分别等言。摄余五道

论曰。欲界等变异

释曰。谓具缚离缚生变异。受三界生有具缚及离缚前后变异。识分别此生名生相变异分别等言。摄色无色界

论曰。五依显示变异分别

释曰。谓眼等识变异。此分别以眼等识变异相为相

论曰。谓如前所说变异

释曰。如前所说老等变异。于变异位中。如眼等识变异

论曰。起变异分别

释曰。意识亦如此依显示变异而分别故。名依显示变异分别

论曰。六他引分别

释曰。此分别因他言说生

论曰。谓闻非正法类。闻正法类分别

释曰。此分别有二种。一听闻非正法为类分别。二听闻正法为类分别。谓行恶法类分别。行善法类分别思修亦尔。此分别以闻他言说为相故。名他引分别

论曰。七不如理分别

释曰。是前分别。听闻非正法为因

论曰。谓正法外人。非正法类分别

释曰。谓九十六种外道。在正闻思修法外

论曰。八如理分别

释曰。是前分别听闻正法为因

论曰。谓正法内人。闻正法类分别

释曰。谓声闻缘觉菩萨人。在正闻思修法中

论曰。九决判执分别。谓不如理思惟种类

释曰。以不正思惟为因

论曰。身见为根本。与六十二见相应分别

释曰。依止我见如梵网经所明见类。谓六十二见相应分别

论曰。十散动分别。谓菩萨十种分别

释曰。菩萨分别不与般若波罗蜜相应。悉名散动。般若波罗蜜经说十种法对治。此十种散动初二法正是般若波罗蜜事。谓显真空遣俗有即是实有。菩萨不见有菩萨。次有五事有三解。第一解云。遣名事物初两遣名。即是不见菩萨名。不见般若波罗蜜。初遣人名后遣法名。次两遣事。即是不见行不见不行。此有三义。一不见菩萨能行二乘不能行。二不见正勤助道为行。不见懒惰等所对治为不行。三不见菩萨修道未满故行。不见菩萨修道已满故不行。后一遣物此名此事。以何物为根本。以五阴为根本。亦不见五阴。即是不见色不见受想行识。第二解云。初二明不见人法。次二明不见人行法为行。不见人不行法为不行。后一明行所对治即五阴。五阴即苦集二谛。不见集可断。不见苦可离。第三解云。初二明不见能行人及所行。道次二不见助道。后一明不见所对治。此五事中一一事皆具八法

论曰。无有相散动

释曰。无有相是散动因。为对治此散动故。经言。是菩萨实有菩萨

释曰。由说实有显有菩萨。以真如空为体

论曰。有相散动

释曰。有相是散动因。为对治此散动故。经言。不见有菩萨

释曰。不见有菩萨。以分别依他为体

论曰。增益散动

释曰。以有增益无所有。此执即是散动。为对治此散动故。经言。何以故。色由自性空

释曰。由分别色性色性空

论曰。损减散动

释曰。以无损减实有。此执即是散动。为对治此散动故。经言。不由空空

释曰。此色不由真如空故空

论曰。一执散动

释曰。谓依他分别即是空。此执即是散动。为对治此散动故。经言。是色空非色

释曰。若依他性与真实性是一真实性。是清净境界依他性亦应如此

论曰。异执散动

释曰。谓色与空异。此执即是散动为对治此散动故。经言。无色异空故色即是空空即是色

释曰。若色与空异。此空则不成色家法空。不成色通相此义不成。譬如有为法与无常相不异。若捉分别性说言色即是空。空即是色。何以故此分别色永无所有。此永无所有即是有即是空。此空即是色无所有。不如依他性于真实性不可说。一由清净不清净境界故

论曰。通散动

释曰。执色有通相为性。谓有碍。此执即是散动。为对治此散动故。经言。何以故。舍利弗。此但有名所谓色

释曰。唯有名是色通相。何以故。若离名色实无本性

论曰。别散动

释曰。已执色有通相。又分别色有生灭染净等差别。此执即是散动。为对治此散动故。经言。是自性无生无灭。无染无净

释曰。此色无所有为通相。若有生即有染。若有灭即有净。由无此四义故色无别相

论曰。如名起义散动

释曰。如名执义。于义散动。为对治此散动故。经言。对假立名。分别诸法

释曰。名是虚假所作。对诸名分别一切法

论曰。如义起名散动

释曰。如义于名起旧执。此执即是散动。为对治此散动故。经言。由假立客名。随说诸法

释曰。名不与法同相。经言。如如随。说如是如是生起执着

释曰。随假所立名说诸法。计名与法不异。经言。如此一切名菩萨不见。若不见不生执着。释曰。为对治十种散动故。说般若波罗蜜。以此说为因无分别智生。由无分别智灭诸分别惑

论曰。为对治此十种散动分别故。于一切般若波罗蜜教中。佛世尊说无分别智。能对治此十种散动。应知具足般若波罗蜜经义。如般若波罗蜜经言。云何菩萨行于般若波罗蜜。舍利弗。是菩萨实有菩萨不见有菩萨。不见菩萨名。不见般若波罗蜜。不见行不见不行。不见色不见受想行识。何以故。色由自性空不由空空。是色空非色。无色异空故。色即是空空即是色。何以故。舍利弗。此但有名。所谓色是自性无生无灭无染无净。对假立名分别诸法。由假立客名。随说诸法。如如随说如是如是生起执着。如此一切名菩萨不见。若不见不生执着。如观色乃至识亦应作如此观。由此般若波罗蜜经文句。应随顺思惟十种分别义

释曰。如八种观色阴。亦应作八种观余四阴。乃至前四事亦应作八种观

论曰。若由此别意。依他性成有三性。是三性云何性有三异。不成相杂

释曰。此问先分三性异。次明依他性有别义成三性。若于依他性中明三性有三异。则三性成相杂。不可偏说为一性。云何不相杂

论曰。无相离义

释曰。道理有异故不相杂

论曰。由此道理此性成依他。不由此成分别及真实

释曰。此即此前所明。由系属种子及系属净品不净品等道理故。成依他不可以此道理。令成分别及真实性

论曰。由此道理此性成分别。不由此成依他及真实

释曰。此即前所明。由分别自性分别差别等道理故成分别性。不可以此道理。令成依他及真实

论曰。由此道理此性成真实。不由此成依他及分别

释曰。此即此前所明。由自性成就清净成就等道理。故成真实性。不可以此道理。令成依他及分别

摄大乘论释卷第五摄大乘论释卷第六

        世亲菩萨释

        陈天竺三藏真谛译

    释应知胜相之二十五卷成

论曰。云何得知此依他性。由分别性显现似法。不与分别性同体

释曰。此问言分别性显现似法。此似法不离依他性。应与依他性同体云何言不同体

论曰。未得名前于义不应生智故。法体与名一则此义相违

释曰。依他性虽复由分别性一分所显不与分别性同体。为显此义故立三证。此即第一证。若依他与分别共一体。此执相违。若依他与分别共一体。此智不开名于义应生。譬如离瓶名于瓶义瓶智不生。若瓶义与瓶名一体此事不应成名义不同相故。若执名义共一体。此执则相违。此证显名是依他。显义是分别。何以故。此依他由名所分别故

论曰。由名多故。若名与义一。名既多义应成多。此义体相违

释曰。此即第二证。或一义有多名。若名与义共一体。如名多。义亦应成多。若尔一义应有多体。一物多体此义相违。是故若两性一体。则成第二相违

论曰。由名不定。体相杂此义相违

释曰。譬如瞿名目九义。若言名与义一体。是两体相违则成第三相违。瞿名所目诸义。相貌不同。由许一体。相违法一处得成。无如此义。是故两性不可为一体

论曰。此中说偈

释曰。重显前义。是故说偈。初偈显依他分别不共一体。此义得成由三相违故

论曰

  于名前无智　　多名及不定
  义成由同体　　多杂体相违
  法无显似有　　无染而有净
  是故譬幻事　　亦以譬虚空

论曰。义成

释曰。即明依他性与分别性。不同体义成

论曰。于名前无智。同体相违

释曰。此即第一相违

论曰。多名同体。多体相违

释曰。此即第二相违

论曰。及不定。同体杂体相违

释曰。此即第三相违。后偈为教弟子。弟子于二事生疑

论曰。法无显似有无染而有净

释曰。此明于两种相违生疑。无法显似有法是第一相违。于无染中而有净是第二相违

论曰。是故譬幻事亦以譬虚空

释曰。即以此譬。释弟子疑。譬如幻像实无显现为有。诸分别法亦尔。实无而显现似有。此有亦可见。譬如虚空非云等五障所染。自性清净。云等障后灭时。亦说空为净。诸法亦尔。本无有染自性清净。客尘障盖后灭则见清净

论曰。云何如此显现而实非有。依他性一切种非不有

释曰。此问若依他性。如所显现如此无所有。一切一切种。此性亦不无。此意云何

论曰。若无依他性。真实性亦无。一切无不成。若无依他性及真实性。则无有染污及清净品过失此二品可知非无。是故非一切皆无。此中说偈

  若无依他性　　真实性亦无
  则恒无二品　　谓染污清净

诸佛世尊于大乘中。说鞞佛略经。此经中说。云何应知分别性。由说无有品类。此性应知。云何应知依他性。由说幻事鹿渴梦相影光谷响水月变化。如此等譬应知其性。云何应知真实性。由说四种清净法。应知此性

释曰。若无此性真实性亦无。何以故。若有染污则有清净。若两法悉无则一切皆无。此一切无。由此方便能显其不成。何者为方便。拨无生死涅槃。此义不可立。由染污品及清净品可见。是故两法显现若拨言无则成邪见。亦名损减谤。是故分别性是无。依他性不可拨言无故知依他分别不得同体

论曰。四种清净法者。一此法本来自性清净。谓如如空实际无相真实法界

释曰。由是法自性本来清净。此清净名如如。于一切众生平等有。以是通相故。由此法是有故。说一切法名如来藏

论曰。二无垢清净。谓此法出离一切客尘障垢

释曰。是如来藏离惑智两障。由此永清净故。诸佛如来得显现

论曰。三至得道清净。谓一切助道法。及诸波罗蜜等

释曰。为得清净菩萨行道。此道能得清净故。亦名清净道。即般若波罗蜜。及念处等诸助道法

论曰。四道生境界清净。谓正说大乘法

释曰。道及助道法生所缘境界。谓修多罗等十二部正说。是清净资粮故。亦名清净

论曰。何以故

释曰。云何说生道境界清净。是真实性摄。非分别及依他

论曰。此说是清净因故。非分别清净法界流故。非依他由此四种清净法。摄一切清净法皆尽

释曰。此正说若属分别性。应成染污因。是清净因故。非分别性。若属依他性。如依他性亦应成虚。此清净法界流为体。是故非虚。以出二性外故属真实性。若说四清净中随一清净。此说于大乘中。应知属真实性。第一第二清净。由无变异故成真实。第三第四由无颠倒故成真实

论曰。此中说偈

释曰。欲重明此义令显了故更说偈

论曰

  幻等显依他　　说无显分别
  若说四清净　　此说属真实
  清净由本性　　无垢道缘缘
  一切清净法　　四皆摄品类

论曰。幻等显依他

释曰。是处如来说一切诸法如幻事。乃至如变化譬。应知此言是说依他

论曰。说无显分别

释曰。若说无色乃至无一切法。应知此言是说分别。为此意用如来说依他性。以幻事等为譬今当说此义

论曰。若说四清净此说属真实。清净由本性无垢道缘缘。一切清净法四皆摄品类。何因何缘是依他性。如经所说幻事等譬所显。于依他性中为除他虚妄疑惑。云何他于依他性中生虚妄疑惑。诸说于依他性中有如此虚妄疑心。若实无有物云何成境界。为决此疑故说幻事譬

释曰。于虚妄起疑谓为实有。不信是虚妄故名虚妄疑。此法若显现成境界。云何言虚妄。故以幻事譬依他性。譬如幻像尘实不有亦成境界。诸法亦尔。为除此疑故须立譬

论曰。若无境界。心及心法云何得生。为决此疑故说鹿渴譬

释曰。鹿渴譬心及心法。以水譬尘鹿渴动摇生识。缘水为境实无有水。如此心及心法起变异事。于无有尘生缘尘识

论曰。若实无尘爱非爱。受用云何得成。为决此疑故说梦相譬

释曰。譬如于梦中无有实尘。亦见有爱憎受用。此依他性中亦尔。无有实尘。亦见有爱憎受用

论曰。若实无法。善恶二业爱非爱果报云何得生。为决此疑故说影譬

释曰。譬如镜中无实影尘。于面相起影识。此影尘非不显现。爱憎两果亦尔。实非有而显现似有

论曰。若实无法云何种种智生。为决此疑故说光影譬

释曰。譬如人弄影。见影有种种相貌随影起种种识。无实影尘。种种识尘亦尔实无所有而有种种尘显现

论曰。若无实法云何种种言说起。为决此疑故说谷响譬

释曰。譬如实无响尘而显现可闻。言说事亦尔。实无所有而显现可闻

论曰。若实无法云何成缘真实法。定心境界。为决此疑故说水月譬

释曰。譬如无水月实尘而显现可见。由水润滑澄清故。若人心得定无实尘为境。亦显现可见。水譬定。以定心润滑澄清故

论曰。若实无法云何诸菩萨故作心。无颠倒心为他作利益事。于六道受生。为决此疑故说变化譬

释曰。譬如无实变化尘。随变化者所作。一切所作事皆成所化尘。非不显现。菩萨受生亦尔。实无六道受生身。作利益一切众生事及受生身亦显现。复有何义。佛世尊说幻事等譬。更有别义。今当说佛意。幻事譬为对治眼等六内根。诸根如幻像。实非有而显现似有。鹿渴譬器世界。由此大故。显现如水实无所有。而于鹿渴显现似有。以动摇故。此器世界众生执为色等可受用法。如执鹿渴中水谓为可饮。为对治此执故说梦相譬。譬如于梦中色等诸尘无所有。因此有爱憎受用。为对治身业故说影譬。依善恶身业有别色似影生。为对治口业故说谷响譬。由此譬显口业为因有口业果报由如谷响。意业有三种。一不寂静地。即是欲界散动业。二寂静地。即修慧。三闻思二慧。为对治不寂静地意业故。说光影譬。由此譬显意业果报。譬如光影。为对治寂静地意业故。说水月譬显意业果报。譬如水月。如水中月实无有月而显现似月。寂静心亦尔实无所有。于寂静心中而有动摇。现在及未来世果显现。离此寂静心无有别果。为对治闻思品类意业故。说变化譬。若是闻思熏习生业果报。譬如变化品类非有亦有显现。闻思生业果报亦尔。由此法尔三性为相如来所说经悉皆随顺。今当说随顺经义

论曰。婆罗门问经中言。世尊依何义说如此言。如来不见生死不见涅槃。于依他性中。依分别性及依真实性。生死为涅槃。依无差别义。何以故。此依他性由分别一分成生死。由真实一分成涅槃

释曰。依他性非生死。由此性因真实性成涅槃。此性非涅槃。何以故。此由分别分即是生死故。是故不可定说一分。若见一分余分性不异。是故不见生死亦不见涅槃。由此意故如来答婆罗门如此

论曰。阿毗达磨修多罗中。佛世尊说法有三种。一染污分。二清净分。三染污清净分。依何义说此三分。于依他性中。分别性为染污分。真实性为清净分。依他性为染污清净分。依如此义故说三分

释曰。阿毗达磨修多罗中。说分别性以烦恼为性。真实性以清净品为性。依他性由具两分。以二性为性故。说法有三种。一烦恼为分。二清净为分。三二法为分。依此义故作此说

论曰。于此义中以何为譬。以金藏土为譬。譬如于金藏土中见有三法。一地界二金三土。于地界中土非有而显现。金实有不显现。此土若以火烧炼。土则不现。金相自现。此地界土显现时。由虚妄相显现。金显现时由真实相显现。是故地界有二分

释曰。如来为显此义故。说金藏土譬。金为藏者。地界是金种子故说名金藏土。以坚触为地界。以所造色为土。谓色尘等。此三可了别。此地界先由土相显现。后由金相显现。何以故。此地界若为火所炼。金相则显。是故于地界实有金。此义可信

论曰。如此本识未为无分别智火所烧炼时。此识由虚妄分别性显现。不由真实性显现。若为无分别智火所烧炼时此识由成就真实性显现。不由虚妄分别性显现。是故虚妄分别性识。即依他性有二分。譬如金藏土中。所有地界。复次有处世尊说一切法常住。有处说一切法无常。有处说非常非无常。依何义说常。此依他性由真实性分常住。由分别性分无常。由二性分非常非无常。如依此义说常无常无二。如此说苦乐无二。善恶无二。空不空无二。有我无我无二。净不净无二。有性无性无二。有生无生无二。有灭无灭无二。本来寂静不寂静无二。本来涅槃非涅槃无二。生死涅槃无二。由如此等差别。诸佛如来依义密语。由此三性应随决了常无常等正说。如前解释此中说偈

  如法实不有　　如彼种种现
  由此法非法　　故说无二义

释曰。诸法非法非非法。由此法实无所有故。非法如有显现故。非非法。由非法非非法故说无二义

论曰

  依一分说言　　或有或非有
  依二分说言　　非有非非有

释曰。若依一一分。不可说诸法有及非有。如所显现不如是有故不可说有。虽实非有如有显现故。不可说非有。若捉一一分应如此判。若约依他性具有二分。说诸法非有非非有

论曰

  如显现不有　　是故说永无
  如显现实有　　是故说非无

释曰。如所显现不如此有。依不有义故说永无。虽复不有非不显现。依唯有显现义故说非无

论曰

  由自体非有　　自体不住故
  如取不有故　　三性成无性
  由无性故成　　前为后依止
  无生灭本净　　及自性涅槃

论曰。由自体非有

释曰。今当显如来所说无性意。初句一分明无性通大小乘。此正是显无性意自。非有者显通无性。由诸法离因缘和合。不关外缘自然成。无有此义故。一切法无性体非有者亦是无性。此有别意。谓约过去未来此体已灭。由此体更立法为有。无如此义。此体未有。由此体预立法为有。亦无此义。是故去来二世并无自性

论曰。自体不住故

释曰。若诸法已生过。唯生时无能住义。既不能住故现在亦无体。此三世无性。亦通大小二乘

论曰。如取不有故。三性成无性

释曰。由分别性所显现。实无所有故。无相性。分别性无体相故。依他无所依止故无生性。此二无性无无性故真实无性性。此三无性但大乘中有。余乘则无

论曰。由无性故成前为后依止。无生灭本净及自性涅槃

释曰。由诸法永实无性。一切无生等四义得成。何以故。若诸法无性是故无生。若无生则无灭。由无生无灭故本来寂静。由本来寂静故自性涅槃成者。前为后成立依止。谓无性成立。无生故为无生依止。后三亦尔

    显了意依章第四

论曰。复次有四意四依。一切佛世尊教应随决了

释曰。如来所说正法。不出四意四依。此意及依由三性故可决了。若离三性无别道理。能决了此法

论曰。一平等意

释曰。譬如有人执平等法尔说彼即是我。世尊亦尔。平等法身安置心中。说如是言

论曰。譬如有说。昔是时中我名毗婆尸。久已成佛

释曰。非昔毗婆尸即是今释迦牟尼。此说中以平等为意。是名通平等。若说别平等。谓因果恩德皆同。是名平等意

论曰。二别时意

释曰。若有众生由懒惰障不乐勤修行。如来以方便说。由此道理于如来正法中。能勤修行方便说者

论曰。譬如有说。若人诵持多宝佛名。决定于无上菩提不更退堕

释曰。是懒惰善根。以诵持多宝佛名。为进上品功德。佛意为显上品功德。于浅行中欲令舍懒惰勤修道。不由唯诵佛名。即不退堕决定得无上菩提。譬如由一金钱营觅得千金钱。非一日得千。由别时得千。如来意亦尔。此一金钱为千金钱因。诵持佛名亦尔。为不退堕菩提因

论曰。复有说言。由唯发愿。于安乐佛土得往彼受生

释曰。如前应知是名别时意

论曰。三别义意

释曰。此言显自觉了实相。由三性义道理。若但如闻觉了义。是如来意者。婴儿凡夫亦能觉了。是故如来意不如此。如来意云何

论曰。譬如有说事。如是等恒伽所有沙数。诸佛于大乘法义。得生觉了

释曰。此觉了非闻得成。若人已事恒伽沙数佛。方得成就。是名别义意

论曰。四众生乐欲意。譬如如来先为一人赞叹布施。后还毁呰

释曰。有众生如来先为赞叹布施功德。后时或为此人毁呰布施。如此意随人得成。何以故。若人于财物有悭吝心。为除此心故先为赞叹布施。若人已欲乐行施。施是下品善根。如来后时更毁呰此施。令渴仰其余胜行。若不由此意赞毁则成相违。由如来有别意故。于一施中赞毁而不相违

论曰。如施戒及余修亦尔。是名四种意

释曰。戒等亦如是。有人如来为赞毁于修。此是世间修故可毁呰。若出世间修则无可毁。义意及依异相云何如来心先缘此事。后为他说故名为意。由此因众生决定。入正定聚故名此因为依

论曰。四依者一令入依。譬如于大小乘中。佛世尊说人法二种通别。二相所摄俗谛

释曰。于正说中约世谛理说有人法及通别二相。为令众生入于正义故。名令入依

论曰。二相依。譬如随所说法相中必有三性

释曰。于正说中若应说法相必说三性。此三性是一切法总相。若欲了别一切法。必须依此三相。故名相依

论曰。三对治依。此中八万四千众生烦恼行。对治显现

释曰。于正说中若说众生行对治。不出八万四千。谓说四谛等。此说能除众生因果中身见戒取疑。以能成立众生烦恼对治故。名对治依

论曰。四翻依。此中由说别义言词以显别义。譬如偈言

释曰。于正说中由显说别义。文字但说别义。故名翻依。如偈言

论曰

阿娑离。娑罗摩多耶。毗跋耶斯者。修絺多。离施那者。僧柯履多。罗槃底菩提物多摩

论曰。阿娑离

释曰。谓定。何以故。娑离者有二义。一实二动。阿娑离谓不实不动。不实是文句明了义。不动是秘密义。不动故名定

论曰。娑罗摩多耶

释曰。名起实心。谓于定起尊重心

论曰。毗跋耶斯者

释曰。谓四念处智慧。何以故。毗跋耶斯者。亦有二义。一倒谓于无常起常倒等。二翻倒谓于常作无常解。倒是文句明了义翻倒是秘密义

论曰。修絺多

释曰。谓善住。善住于念处

论曰。离施那者

释曰。谓正勤。何以故。离施那者亦有二义。一烦恼二苦难。烦恼是文句明了义。苦难谓正勤是秘密义

论曰。僧柯履多

释曰。亦有二义。一染污二疲惓。染污是文句明了义。疲惓是秘密义。菩萨为众生于生死。长时恒行苦行。是故疲惓如罗睺罗法师言。世尊长时于生死劬劳。但由大悲不由余事

论曰。罗槃底菩提物多摩

释曰。罗槃底言得。菩提言觉。物多摩言胜。若取此偈明了义判文。则成相违。若取秘密义判文。则是正说。欲令众生依理判文。以理为依不应依文故说此偈。或有人憍慢轻蔑说者。自不能如理判义。欲破彼慢心故说此偈。是名翻依

论曰。若人欲广解释大乘法。略说由三相应。当如此解释。一广解缘生体相。二广解依因缘已生诸法实相。三广解成立所说诸义。广解缘生体相者。如偈说言。熏习所生诸法。此从彼如此果报识。及以生起识由更互因生

释曰。外尘分别所生。本识中熏习种子故。称言说熏习。一切余法以此为因得生。谓生起识为性。言说熏习以诸法为因故。言此法从彼生。由此言说已显本识。与生起识更互为因

论曰。广解释依因缘已生诸法实相者。诸法者谓生起识为相有相。及见识为自性

释曰。是诸法有相有见为自性。生起识为相。应如此知诸法有两体。若尘识以相为体。若识识以见为体。从因缘生果法。性相有三种

论曰。复次诸法依止为相

释曰。谓依他性

论曰。分别为相

释曰。谓分别性

论曰。法尔为相

释曰。谓真实性

论曰。由此言说。于三性中诸法体相则得显现

释曰。由此言说一切从因缘所生法。由法尔故虚。虚故成倒。由倒故得虚果。由有果故有分别。由分别故有法尔。是故或顺相成。或逆相成。此三种性相遍摄一切果

论曰。如偈言

释曰。为显此义故重说偈

论曰

  从有相有见　　应知法三相

释曰。诸法不出二种。一相二见。于相见中应了别三性为相。此三相如此方便应解释。今当显说

论曰。云何得解说此法相分别性。于依他性实无所有。真实性于中实有。由此二不有有故。非得及得未见已见。真如一时自然成。于依他性中分别性无故。真实性有故。若见彼不见此。若不见彼即见此

释曰。二谓分别性及真实性。此二第一无第二有故。言此二不有有。由见分别不见真实。谓未见真实人是凡夫不见时。圣人不见分别。即见真实

论曰。如偈言

释曰。为显此义故重说偈

论曰

  依他中分别　　无但真实有
  故不得及得　　于中二平等

释曰。于中谓于依他性中。此二平等。谓于依他性中分别无真实有故。故凡夫人颠倒执。如此得不得圣人正见故。于依他中亦有得不得义

论曰。广解成立所说诸义者。譬如初所说文句由所余诸句显示分别。或由功德依止。或因事义依止。功德依止者。广说佛世尊功德。最清净慧

释曰。因前二义。一切所说应如此解释。今当说此方便。此中所说或依功德义。或依因事义。依功德义中最清净慧。是初句。所余诸句各显此义

论曰。无二行谓于所知一切无障行起功德

释曰。不如声闻独觉智慧有障。无障由有障故不清净。由无障故清净。如来智慧于一切处悉无障。是故无净不净。由此义故无二

论曰。无相法为胜依意行。谓于有无无二相。真如最清净令入功德

释曰。即是无垢清净真如。说名无相法。由此一切法无所有为体故。此法离有相。由自体实有故。此法离无相。于无相法由最清净。是故自能通达。亦能令他通达故。说无相法为胜依意行

论曰。住于佛住。谓不由功用。不舍如来事。佛住功德

释曰。此显无住处涅槃。不在生死故无功用心。不在涅槃故。不舍如来利益众生事。如此二义由无住处涅槃故得成立故。说此涅槃名为佛住

论曰。至得诸佛平等。谓于法身依止及意事。无差别功德

释曰。依止即法身。意是应身。事是化身。如此三身一切十方三世如来平等无异。如此平等一切如来皆已至得

论曰。行无碍行。谓修习一切障对治功德

释曰。为对治一切三障。如来恒修对治慧。是故如来智于法体及法相皆无障碍

论曰。不可破无对转法。谓降伏一切外道功德

释曰。于世间中无有天魔及外道诸说。能如理破。如来所说正法安立自法。亦无有能以自所立法对。翻如来正法。何以故。如来所说无失本性故

论曰。不可变异境。谓生于世间。非世间法所染污功德

释曰。世间是如来出生处。如来虽复生于世间。贪爱等八法及四倒不能染污。境即四念处谓真如空

论曰。不可思惟所成立法。谓安立正法功德

释曰。修多罗等十二部正法。不可量不可思。非凡夫所能知。如来安立此法竟乃至婴儿等亦能通达。如鸠摩罗迦叶等是前清净慧句。于余句一一应知相应

论曰。至三世平等。谓四种善巧。答他问功德

释曰。如来于现在证一切法。于过去未来亦证无比。由证此智平等。若他约三世问难无不依证智。作四种答。故智答皆等如来。至此二种平等

论曰。于一切世界现身。谓于一切世界中。显现应化身功德

释曰。为化菩萨及二乘。随众生根性显现二身。为说为行

论曰。于一切法智慧无碍。谓能决他疑功德

释曰。由得四无畏故自决无疑。由得四无碍辩故能决他疑。是故能答难决疑

论曰。一切行与智慧相应。谓由种种行能令他入功德

释曰。如来欲行他利益事。此事先是智所缘。由此事他得入真位。则与他智慧相应。此事以自智慧为因。以他智慧为果。一切如来所行方便。谓神通轮记心轮说法轮。乃至出入息等。无不自与智慧相应。无不令他得智慧。无有空过

论曰。于法智无疑。谓于未来世法。生智功德

释曰。此法于未来应生能如此智。是故于未来世法无疑。为令他得此法。随众生根性能立教

论曰。不可分别身。谓随众生乐显现功德

释曰。众生界过数量。意欲及入道方便亦过数量。处所亦过数量。如来能随此事差别。示现化身数量相貌时节处所。并不可分别

论曰。一切菩萨所受智慧。谓能行无量依止众生正教化事功德

释曰。由无量菩萨依止。是众生教化事。应可作此事。由得佛无我。为胜我此智但是菩萨所受故。但佛能化菩萨。但菩萨能受佛化。无量菩萨依止者。此有二义无量。或属菩萨或属依止。若属菩萨。一切菩萨同一依止。谓以无我为胜我。若属依止显法身遍满。通为一切菩萨依止

论曰。至无二佛住波罗蜜。谓平等法身波罗蜜成就功德

释曰。如来法身名佛住。三世如来此住不异故。言无二。无二故平等。四德究竟故名波罗蜜。成就有二义。一清净佛法身。已离一切障究竟清净故名成就。二四德是法身所成就

论曰。至无差别如来解脱智究竟。谓随众生意。显现纯净佛土功德

释曰。于无相杂如来智中。至解脱究竟。如来智慧与真如无差别。随众生所愿乐。能显现清净佛土等。为生善心及成熟解脱故

论曰。已得无边佛地平等。谓是三种佛身无离无别处功德

释曰。如来三种身中。法身约处所不可度量。应化两身亦尔。不可言但此世界有。彼世界无。无有一法出法身外。无有众生界出应化两身外

论曰。法界为胜。谓穷生死际。能生一切众生利益安乐功德

释曰。如来以法界为胜。法界有二种。一有染二无染。无染清净法界为后最胜。何以故。如来穷生死际。利益安乐众生。功能无尽。所以无尽者。由体。由能体即法界。能即应化两身。因化身得如来应身。因应身后转得成如来法身。若成法身则无穷尽

论曰。虚空界为后边。谓由无尽功德

释曰。如来智慧无尽。譬如虚空虚空遍满一切色际。无有生住灭变异。如来智亦尔。遍一切所知。无倒无变异故说如虚空

论曰。最清净慧。如此初句由所余句。次第应知分别解释。若如此正说法义得成

释曰。由二十道理。成就如来智慧最清净故。如来自利满足。由智慧清净。如来所说法教理圆正故。利他得成。第一句为本。余二十句为能成就

论曰。因事义依止者。如经言。若菩萨与三十二法相应说名菩萨

释曰。因事有二义。一以意为因以十六业为事。二以诸句为因所成业为事。菩萨有二种。一在正定位。二在不定位。若入正定位者。与三十二法相应得菩萨名。若在不定位。末与三十二法相应。不得名菩萨

论曰。于一切众生。与利益安乐意相应

释曰。于一切众生求欲起真实道。有方便故名利益意。于一切众生。求欲起现在未来二世拔苦施乐方便故。名安乐意。菩萨与此意恒不相离故名相应。此初句明利益安乐意。后有十六业及十六句。合三十二法并显了初句义

论曰。令入一切智智意。谓传传行业

释曰。若菩萨有意。欲令众生入一切智智。由此意传传化度众生。令得一切智智。譬如一灯传然千灯。由此句及业。菩萨利益安乐意则得显现。如此于一切句及业各显初句悉应知之

论曰。我今于何处中。当相应如此智。谓无倒业

释曰。若菩萨有利益安乐意。菩萨不如实识自身。则不能中道理安立众生。譬如有人有利益安乐意。安立众生于饮酒。是颠倒业若如实识自身。能中道理为众生说无增上慢。安立众生令入中善处。此利益安乐名无倒业

论曰。舍高慢心。谓不由他事自行业

释曰。由此人舍离高慢心不待他请。若众生是法器则自往为说正法

论曰。坚固善意谓不可坏业

释曰。由菩萨心坚固。若众生有过失。不能破坏菩萨利益安乐心

论曰。非假作怜愍意。谓无求欲业。有三句解释应知

释曰。前有三句。后更以三句释前三句

论曰。不贪报恩

释曰。此释初句非为自求利养故怜愍他

论曰。于亲非亲所平等意。谓有恩无恩众生不生爱憎心

释曰。亲名有恩。怨及中人是非亲名无恩。若使非亲堪受利益安乐事。菩萨则舍不平等心起平等亲友心。行利益事

论曰。永作善友意。乃至无余涅槃。谓随顺行乃至余生

释曰。随顺行利益安乐事。从今生乃至穷未来生。永不舍离故名无求欲业。此无求欲意云何可知。由随处相应。身口二业是故可知

论曰。称量谈说欢笑先言。谓随处相应言说业。有二句解释应知

释曰。此二句约法及安慰以显口业。称量谈说是约法。欢笑先言是约安慰。称量有二种。一称法不离余语。二称所解离非所解及疑。如此称量谈说。欢笑令他无疑畏心。先言是引他所作之方便。此二种口业于怨亲中三人无有别异即成就无求欲业

论曰。于诸众生慈悲无异。谓有苦有乐无二众生平等业

释曰。于有苦众生由苦苦起慈悲。于有乐众生由坏苦起慈悲。于无二众生由行苦起。慈悲无二谓无苦无乐。即是舍受慈悲平等。是身口业。何以故。菩萨于众生先起意地慈悲。后随时随处行拔苦与乐行故。是身口业。此身口业于怨亲中三人无有别异。亦成就无求欲业

论曰。于所作事无退弱心谓无下劣业

释曰。若菩萨轻贱自身云。我今于无上菩提无有功能。一切所作皆不成就名退弱心。菩萨不生此心故所作皆得成就。名无退弱心

论曰。无厌倦心。谓不可令退转业

释曰。菩萨于无上菩提。起正勤无有厌倦。无厌倦有二种。一见因定。二知果希有故。于难行中心无厌倦

论曰。闻义无足。谓摄方便业

释曰。若人多闻能了别化他方便。由闻解义。则于正行无有疑心故。自能修行亦教他修行

论曰。于自作罪能显其过。于他作罪不怪诃责。谓厌恶所对治业。有二句解释应知

释曰。由智及大悲故有此能由智能了别因果故。不覆藏自所作恶。由大悲不忍见他作苦因。虽恒诃责而不嗔怪

论曰。于一切威仪中恒治菩提心。谓无间思量业

释曰。此显无间修。无间修为遮一切放逸行。譬如威仪清净品中所明。菩萨所作。无不为令众生得无上菩提

论曰。不求果报而行布施。不着一切怖畏及道生。受持禁戒。于一切众生忍辱无碍。为引摄一切善法行于精进。修三摩提灭离无色定。与方便相应智。四摄相应方便。谓行进胜位业有七句解释。应知正修加行六波罗蜜。恭敬行四摄

释曰。前有七句。后总举六度四摄结前七句。此业能增长利益安乐意。若未生由此业得生。若已生由此业得增广。即是生长之因

论曰。于持戒破戒中善友无二。谓成就方便业。有六句解释应知

释曰。前有六句。后更以六句释前六句

论曰。事善知识

释曰。此释初句。若人持戒破戒不观其过。但取其德。若未得彼德则依彼修学。若已得彼德则共彼数习令坚固。若自有德令彼修学同我所得。此彼互相事故。言为善友无二

论曰。恭敬心听法。谓听闻正法

释曰。为得未得。为修治已得。是故依善友听闻正法

论曰。恭敬心乐住阿兰若处。谓住阿兰若处

释曰。欲修行如所闻法故恭敬。住阿兰若处。若住此中一切邪觉观不得起

论曰。于世间希有。不生安乐心。谓远离邪觉观

释曰。譬如妓乐等。是世间所爱。于中不生喜乐心。是名远离邪觉观

论曰。于下品乘不生喜乐心。于大乘教观实功德。谓正思惟功德有二句

释曰。离小修大。此二句名正思惟

论曰。远离恶友敬事善友。谓显事善友功德有二句

释曰。远恶亲善。此二句名近善友功德。由治此六法故利益安乐事得成就。故名成就方便业。成就体相云何

论曰。恒治四种梵住。谓显成就业有三句解释应知

释曰。前有三句。后更以三句释前三句

论曰。治无量心清净

释曰。此释初句

论曰。恒游戏五通慧。谓得威德。恒依智慧行。谓证得功德

释曰。先于众生起无量心。由无量心欲引众生令入正位。故现五通慧。若众生已入正位。欲令修正行故。依智慧令行。不应依识。由证智生故。能了别善恶两法

论曰。于住正行。不住正行众生无舍离心。谓安立他业。有四句解释应知

释曰。前有四句。后更以四句释前四句。欲令众生离恶法住善法。为安立此二事故作安立他业

论曰。引摄大众

释曰。此释初句。于破戒人不弃舍。亦不永摈从恶处济拔安置善处。于持戒人随其根性。令进修定慧等行

论曰。一向决定言说。谓无有疑心。立正教学处

释曰。由智慧决了无疑。一向立教及学处故可信受。若先说如此教如此学处。后言先所说为非。由此事不定言说则不可信受。无不定故可信受

论曰。恭敬实事。谓法财两摄

释曰。由此人以实语。依真实道理说法。是名法摄。如法所得衣服等财物。以此摄众生。是名真实财摄

论曰。先恭敬行菩萨心。谓无染污心

释曰。由此人摄持菩萨心。能作一切众生利益事。不为众生敬事于我。云何彼众生由我利益。信受正教当来得无上菩提。为此善意故行法财二摄。是名无染污心

论曰。与如此等法相应说名菩萨。由如此文句前说初句应知。解说初句者。谓于一切众生利益安乐意。此利益安乐意文句别有十六文句。所显业应知解说。十六业者。如此等应知解释初句

释曰。初句明利益安乐。所余十六业及十六句。皆是利益安乐别义故。以别释总

论曰。此中说偈

释曰。更以一偈。显前所说德因总别义

论曰

  取如前说句　　随德句差别
  取如前说句　　由义别句别

摄大乘论释卷第六摄大乘论释卷第七

        世亲菩萨释

        陈天竺三藏真谛译

    释应知入胜相第三之一

    正入相章第一

论曰。如此已说应知胜相。云何应知应知入胜相

释曰。此品有十章。一正入相。二能入人。三入境界。四入位。五入方便道。六入资粮。七入资粮果。八二智用。九二智依止。十二智差别

一切法名应知。三性名诸法胜相。复次三性名应知。同一无性故名胜相。复次应知有二种。一净品。二不净品。净品者。谓依他性无分别。不净品者。谓依他性有分别。于依他有三种性应知。一依他性。二依他性中分别。三依他性中无分别真如。余义如分别章中说。前已显此义。若人有如此行。得入应知相。今当说此义。此问但问入体相。不问应知及胜相。复次此问问唯识观中缘何法为境。故答此问

论曰。多闻所熏习依止

释曰。于大乘法中多闻所熏习。此熏习有说即是依止。又别说依止者。谓身体相续

论曰。非阿黎耶识所摄

释曰。显此多闻熏习是阿黎耶识对治故。非阿黎耶所摄

论曰。如阿黎耶识成种子

释曰。如阿黎耶识。为一切不净品法因故成种子。多闻熏习亦尔。为一切净品法生因。如阿黎耶识成种子。何法以多闻熏习为种子。为答此问故

论曰。正思惟所摄

释曰。此下四法并以多闻熏习为种子。若觉观思惟。依大乘多闻熏习生此觉观。离邪思惟及偏思惟。以正思惟为性类故。言正思惟所摄

论曰。似法及义显相所生

释曰。似法谓十二部方等教。似义谓方等教所诠之理。心相似此理教。显现此理教为缘。缘生觉观分别

论曰。似所取种类

释曰。此觉观若起。似此所取以为体相。此二句同显识相分

论曰。有见

释曰。此觉观能了别。即是识见分。此义成立识二法。谓相识及见识

论曰。意言分别

释曰。意识觉观思惟。但缘言分别。无别有义可缘。又必依名分别诸法故。言意言分别。多闻熏习依止为此法因

    能入人章第二

论曰。何人能入应知相

释曰。此问修何观行人。能入唯识观人。是菩萨观行有四种力。菩萨者何相。善得福德智慧二种资粮。此资粮以何次第修令得圆满。有四种力。一因力。二善知识力。三正思惟力。四依止力

论曰。大乘多闻熏习相续

释曰。为离小乘多闻故云大乘。显非一生于无穷生处。数习多闻熏习心相续。是名因力

论曰。已得承事无量出世诸佛

释曰。过数量诸如来出现于世。是人依佛听受正教。如教正修行故名承事。先已得如此承事故。名善知识力

论曰。已入决定信乐正位

释曰。若人于大乘中信乐。非恶知识等所能转坏。故名决定。信有三种。一信有。二信可得。三信有无穷功德。若已有信。求修行得因故名为乐。从十信至十回向。是信乐正位。今所明位。但取十回向决定信乐。名思惟力。大乘多闻熏习为此力因

论曰。由善成熟修习增长善根。是故善得福德智慧二种资粮

释曰。若人已一向决定信乐。为得所乐法殷勤恭敬。修观行法。若修观行法增长功德善根。如此由思惟力。是善成熟福德智慧资粮。次第成熟。用此福德智慧作依止。得入初地故名依止力。此四种力显能入人

    入境界章第三

论曰。诸菩萨于何处。入唯识观

释曰。此问有二意。一问何处是唯识境界。二问何处是唯识位

论曰。有见似法义显相。意言分别大乘法相所生

释曰。此法名唯识观持。亦名境界。意言分别者。是心觉观思惟。此思惟有二相。一有见识为相故说有见。二有相识为相。谓显现似十二部大乘教。及似大乘教所诠理。说名有相。大乘法相所生者。大乘法为因故得生。此中显境界体谓意言分别。显境界相谓有见有相。显境界因谓大乘法相

    入位章第四

此意。言分别有四位。为显此四位故

论曰。于愿乐行地入。谓随闻信乐故

释曰。有意言分别。在愿乐行地中。何以故。有诸菩萨。由但听闻一切法唯有识。依此教随闻起信乐心。于一切法唯有识理中。意言分别生。由此愿乐意言分别故。说菩萨已入唯识观。作如此知名入唯识愿乐位

论曰。见道谓如理通达故

释曰。如此方便菩萨入唯识见位。今当说此方便即如理通达。此意言分别如显现相。通达实不如是有。但唯有识。此识非法非义非能取所取。如此通达名入唯识见位

论曰。修道谓能对治一切障故

释曰。意言分别显入修道中。今当说此方便。此意言分别。非法非义非能取非所取。如此观察能对治一切三障。是名入唯识修位。此修道与见道不异。由智由境故。若尔见修二道差别云何。昔未见真如今始得见名见道。先已见真如后更数观名修道。又能除三乘通障名见道。但除菩萨障名修道。又观未圆满无退出义名见道。观未圆满有退出义名修道。又但观通境名见道。备观通别境名修道。又事不成名见道。事成名修道

论曰。究竟道中。谓出离障垢最清净故

释曰。究竟道有二种。一有学究竟。二无学究竟。此位最清净智慧生处故。最微细障灭尽无余故。故名究竟位。诸地乃至如来地。皆有此究竟义。若人入此四位缘何境界

论曰。一切法实唯有识。如说随闻信乐故。如理通达故。能对治一切障故。出离障垢最清净故

释曰。此言显入四种位境界。云何得为四位境界。一切法谓有为无为有流无流。及四界三乘道果等。如此等法实唯有识。何以故。一切法以识为相。真如为体故。若方便道以识为相。若入见道以真如为体。依此境界随闻信乐。入信乐位。如理通达得入见位。能对治一切障得入修位。出离障垢得入究竟位

    入方便道章第五

因此方便菩萨得入四位。今当显说此义

论曰。云何得入

释曰。此问欲显八处持善根力为入方便。何者为善根力。何者为八处。善根力有四种。一因力。二善知识力。三正思惟力。四依止力。如前所明

论曰。由善根力持故

释曰。未有令生。已有令增长。故名持菩萨善根。或说为六波罗蜜。或说为福慧二行。能破对治非对治所遮故。名为力持善根力。应知有八处。何者为八

论曰。由有三相炼磨心故。由灭除四处障故。缘法义为境。无间修恭敬。修奢摩他毗钵舍那。无放逸故

释曰。此即三处。此三相炼磨心。能对治三种退屈心。何者为三。一轻贱自身等退屈心。为除此心故显第一炼磨心。何以故。有诸菩萨闻无上菩提广大甚深难修难得。我今云何能得如此难得无上菩提。由有此执故。于自身心则退屈。为除此心故。须修第一炼磨心

论曰。十方世界无数量故

释曰。此显无上菩提非定一处修得。随处修学悉皆可得

论曰。不可数量在人道众生

释曰。此显无上菩提等类皆得。是故此身不可轻贱

论曰。刹那刹那

释曰。此显得无上菩提无有定时。非待时修得

论曰。证得无上菩提。是名第一炼磨心

释曰。此显菩提无可与等。必假勤修方可证得。由此炼磨心。于方便中第一退屈心则灭不生。二轻贱能得方便退屈心。为除此心故显第二炼磨心。何以故。由有菩萨作如此心。此施等是菩提资粮。若离菩萨意欲则不可得。此意欲我等云何应得。故施等法非我等所能行。由有此执故。于能得方便心则退屈。为除此心故。须修第二炼磨心

论曰。由此正意

释曰。此显方便譬体相。三世诸菩萨若得如此正意。是真方便体

论曰。施等诸波罗蜜必得生长。是我信乐

释曰。此显方便譬功能。功能有三种。一平等功能。二生功能。三长功能。由此正意若生长诸波罗蜜。无不具足故名平等功能。未有令有名生功能。已有令圆满名长功能。如三世诸菩萨方便体及功能。决定无二。我等亦应同彼。何以故。我之信乐即彼正意。为所譬方便体。此体已定。何以故。无动失故

论曰。已得坚住

释曰。此即释不动失义。贪吝等所不能坏故名坚。小乘恶知识等邪化。不能令退故名住

论曰。由此正意。我修习施等波罗蜜。进得圆满则为不难。是名第二炼磨心

释曰。此显所譬三种功能。由此正意我修习施等波罗蜜。明平等功能。进得明生功能。圆满明长功能。此三功能必定可得。故说则不为难。复次由此正意者。此有何义。谓信及乐。信有三处。一信实有。二信可得。三信有无穷功德。信实有者。信实有自性住佛性。信可得者。信引出佛性。信有无穷功德者。信至果佛性。起三信已。于能得方便施等波罗蜜中。求欲修行故名为乐。此信及乐为正意体。由得此信乐。修行施等波罗蜜则不为难。能令究竟圆满。复次菩萨有正意。谓我有能生六度心。出离贪吝等诸障。能遮诸波罗蜜障。灭尽无余。是故不因大功用。六度易可圆满。由六度圆满。无上菩提自然成就。我已得此坚住正意。是故修行六度不以为难。由第二炼磨心。于方便中。第二退屈心则灭不生。三疑应得退屈心。为除此心故显第三炼磨心。何以故。有诸菩萨思量诸佛甚深广大功德。菩萨作是念。无上菩提最难可得。一刹那心所障。谓金刚心无有生死心。除此心亦应可得。此义难思。由有此执。于得无上菩提心则退屈。为除此心故。须修第三炼磨心

论曰。若人与众善法相应

释曰。人即凡夫及二乘。凡夫有施戒修三种善法。此善法或数偏修。或圆满修。若偏数数修及圆满修。施戒修则成众善。以品类多故。二乘有三十七品善法。由无间修及恭敬修。则成众善。亦以品类多故

论曰。后舍命时。于一切受生中。可爱富乐自然而成

释曰。若凡夫先修施满足。后舍命时即生人中。受可爱富乐果。此事无差。若先持戒满足。后舍命时即生天中。受可爱富乐果。此事无差。若修定满足。后舍命时。即生色无色界。受可爱富乐果。此事无差。此就死堕明得果。若二乘修三十七品满足。后舍凡夫寿得圣人寿。受六通等可爱富乐果。此事无差。此就移位明得果

论曰。是人得有碍善。此义尚应成。云何我得圆满善及无碍善。一切如意可爱富乐而当不成。是名第三炼磨心

释曰。于十地中。好生长福德智慧二品善法。故名圆满心。粗重难破障。由金刚定所破坏故。金刚定后能离一切障。转依成时名无碍善。佛果名富乐自在故称乐。具德故称富。此富乐是一切如意可爱法。若约小乘。以智断为如意。恩德为可爱。若约大乘。法身为富乐。应身为如意。化身为可爱。此三摄无上菩提尽故言一切。前言舍命者。譬离智障。智障既灭。云何我如意可爱富乐而当不成。由第三炼磨心。于方便中。第三退屈心则灭不生

论曰。此中说偈

释曰。偈中更显前三义

论曰

  人道中众生　　念念证菩提
  处所过数量　　故无下劣心
  善心人信乐　　能生施等度
  胜人得此意　　故能修施等
  若善人死时　　即得胜富乐
  灭位圆净善　　此义云何无

论曰。人道中众生

释曰。此显同类能得无等果故。不应轻贱自身

论曰。念念证菩提

释曰。此显时无定。修因及得果并无定时。是故恒须勤修。无时而不可修。修因既尔。得果亦然。是故不应谓时有障而轻贱自身

论曰。处所过数量

释曰。显处所无定。随处立因皆可得成。得果亦尔

论曰。故无下劣心

释曰。此明解前三义故退屈心不生。谓我无有功能应得无上菩提。故心不下劣

论曰。善心人信乐。能生施等度

释曰。非恶心及无记心能信乐何以故。有诸人。以散漫无记心行施等行。复有诸外道。以恶心行施等行。为离此恶无记故说善心。求得无上菩提者名善心人。复次施等是善。若无善心为因。则不成施等行。是故须胜因以生胜果。胜因即信乐。由信乐故生施等诸度。此两句显三义。一显增上缘。二显同类因。三显等流果

论曰。胜人得此意故。能修施等

释曰。诸菩萨名胜人。此意即是菩萨正意。谓信及乐。由有此意于修施等有能。是故我修施等不以为难

论曰。若善人死时

释曰。善人有二种。即凡夫及二乘。凡夫修施修戒。二乘修道品。死时亦有二种。即死堕及移位

论曰。即得胜富乐

释曰。亦有二种。凡夫得人天梵世富乐。二乘得六通等富乐。若立此因必定得果

论曰。灭位圆净善。此义云何无

释曰。我今修十地福慧及无流道品。圆约诸地。净约道品。金刚心灭后名为灭位。此即无上菩提果名胜富乐。我决定应得此。云何言无

论曰。由灭除四处障故

释曰。此即八处中第四处。此四种障菩萨皆应灭除。今当说之

论曰。由舍离声闻独觉思惟故。邪思惟灭

释曰。二乘思惟。谓数观苦无常等生死过失。及数观涅槃寂静功德。此观但爱自身。舍利益众生事。若离此观名灭邪思惟

论曰。于大乘中。生信心及决了心故。灭一切邪意及疑

释曰。于大乘甚深广大法中。于真谛生信心。于俗谛生决了心故。于真如舍非拨意。于如来所说大乘十二部经。舍如文判义意。故灭一切邪意及疑。复次于大乘中。依所安立法相。如来说三性。谓一切法无性。一切法不生不灭。本来寂静自性涅槃。如是等无有品类。是依分别性说。若说幻事鹿渴梦相光影镜像谷响水月变化。是依依他性说。若说真如实际无相真实法界空等。是依真实性说。此三性说中。不信及疑不得生故。说灭邪意及疑

论曰。是所闻思诸法中。舍离我及我所邪执故。是故灭除法执

释曰。闻思境界名所闻思诸法。文句所显义是闻慧境界。依此义如理如量推寻道理。此道理是思慧境界。于中若执法体是有。名法我执。譬如执有涅槃。谓集谛无生寂静为体。若执法体有用。名法我所执。譬如执涅槃用。谓能离三苦。如此等执名为邪执。若未灭此执。不能得入唯识四位。由灭除法执故。能得入唯识四位。复次远离所闻及所思法我及我所执。此中但执法体及用为有。说名我我所。不执人我我所。何以故。此人我执前十解中已灭除故。唯法我未除故。显入唯识方便

论曰。安立现前住。一切相思惟悉不分别。是故能灭除分别

释曰。于散乱位中。色等六尘自所证知。为现前住。于寂静位中。骨锁聚等从定心起为安立。如此等一切相。是散乱寂静二心境界。思惟谓觉观思惟。观苦无常无我等。此心缘内境。由见境无相见识无生。是故能灭分别。由无分别为方便故。得入四位。若起分别则不得入。复次现前住及所立一切相思惟。悉不分别者是人在分别。观方便道中故。作无分别意若方便已熟不须功用自然能无分别

论曰。此中说偈

释曰。此偈显最后所灭

论曰

  现住及安立　　一切相思惟
  智人不分别　　故得无上觉

论曰。现住及安立。一切相思惟

释曰。一切相有二种。谓现住及所立。散心所缘六尘名现住。定心所缘骨等为所立。复次一切相有二种。一如外显现。二如内显现。如外是相。如内是思惟

论曰。智人不分别

释曰。菩萨名智人。已闻思唯识道理。由此闻思故名智人。作意不分别乃至无功用不分别

论曰。故得无上觉

释曰。由不分别故。成就无分别智。得入初地。即初地以上为无上觉

论曰。缘法及义为境

释曰。此即八处中第五处因。及方便能令入唯识观。今当说之

论曰。何因何方便得入

释曰。此问有两意。先问因后问方便

论曰。由闻熏习种类正思惟所摄。显现似法及义。有见意言分别故

释曰。此即答第一问。因大乘十二部经所生闻慧熏习。此熏习有种类。种类即是闻慧。以此为生因。依此闻慧数起正思惟。增长令坚住故名摄摄。持令坚住正思惟为长因。有忆念摄持。或似正教显现。或似正教所诠义现。意识觉观思惟名意言分别。此意言分别有二种。谓相及见。今但取见不取相。何以故。此观缘识遣尘故

论曰。由四种寻思。谓名义自性差别。假立寻思

释曰。此即八处中第六处。若菩萨于名唯见名。于义唯见义。于名义自性言说。唯见名义自性言说。于名义差别言说。唯见名义差别言说。于此四处见度疑决了说名寻思。菩萨见名义相各异。及见相应依义相应。菩萨见自性言说及差别。言说皆属义故名与义相应。云何得知名义互为客。先于名智不生故。若名与义同体。未闻名时于义中名智应成。又名多故。若名与义同体。名多义亦应多。又名不定故。若名与义同体。名既不定义亦应尔。若不成一物相违法则应同体。又此名为当于有义中起。于无义中起。若已有及未有义中名起。则一体义不成。又若汝说先已有义。后以名显义。譬如灯照色。若尔此人先已执义。后方立名。非未执义时立名。此执即应能了义。何须后更立名显义。此执若不能了义。名岂能了。复次由此名有余人不达此义。以未了此名故。若名定能了义。则不应如此。若名定能了义。由此名不应有人有识物有不识物。复次若有执义异名异。由此名于义无有邪执。譬如凡夫人识五阴但是行聚。由数习故。于自他相续起我执。于义中不无邪执。若义与名一。此二事不应成。由如此等义。是故知。名于义为客。义于名为客亦尔

    入资粮章第六

论曰。由四种如实智。谓名义自性差别。如实智四种不可得故

释曰。此即八处中第七处。何者名寻思所引如实智。若菩萨于名已寻思唯有名。后如实知唯有名。世间为显此义故。于此义中立此名。为想见言说故。若世间不安立色等名。于色类中。无有一人能想此类。是色若不能想则不增益。若不增益不起执着。若不执着不能互相教示。若菩萨如此知名。是名名寻思所引第一如实智。何者义寻思所引如实智。若菩萨于义已寻思唯有义。如实知义离一切言说不可言说。谓色受等类。色非色不可说。法非法不可说。有非有不可说。是名义寻思所引第二如实智。何者自性寻思所引如实智。若菩萨于色名等类自性言说中。已寻思唯有言说。由自性言说此类非其自性。如其自性显现。菩萨如实通达此类。譬如变化镜像谷响光影梦想幻事等。非类似类显现。是名自性寻思所引第三如实智。以甚深义为境界。何者差别寻思所引如实智。若菩萨于差别言说中。已寻思唯有言说。于色等类中菩萨见差别言说。无有二义。此类非有非非有。由可言体不成就故。非有非非有由不可言体成就故。如此非色由真谛故非非色。由俗谛故于中有色言说故。如有非有及色非色。如此有见无见等差别言说别类。由此道理应知皆尔。若菩萨如实知差别言说无有二义。是名差别寻思所引。第四如实智。先已说名及义。后说自性及差别。此四中皆假立言说欲何所显。为显义不可得。由义不可得名亦无自性及差别。是故菩萨寻思此名。唯假立。自性差别。如此度疑决了等说名寻思。因此寻思菩萨观名义等二无所有。是名如实智

论曰。若菩萨已入已解如此等义

释曰。已入谓已得四种寻思。已解谓已得四种如实智

论曰。则修加行为入唯识观

释曰。地前六度及四种通达分善根名加行。从愿乐位乃至究竟位。通名唯识观。若欲入唯识观。修加行缘何境界

论曰。于此观中意言分别。似字言及义显现

释曰。从愿乐位乃至究竟位名观中。缘意言分别为境。离此无别外境。何以故。此意言分别。似文字言说及义显现故

论曰。此中是字言相。但意言分别得如此通达

释曰。唯有意言分别无别有名。菩萨能通达名无所有。则离外尘邪执

论曰。此义依于名言。唯意言分别亦如此通达

释曰。前已遣名。此下依名以遣义。义者即六识所缘境。离名无别此境。是故依名以遣义。名言既唯意分别故。义亦无别体。菩萨能通达义无所有。亦离外尘邪执

论曰。此名义自性差别。唯假说为量。亦如此通达

释曰。前已遣名义。名义既无名义自性及差别。云何可立。若离假说无别名义自性及名义差别。由证见此二法不可得故。名为通达

论曰。次于此位中。但证得唯意言分别

释曰。是观行人已遣外尘。于此观中复缘何境。观一切境唯是意言分别故。此观行人缘意言分别为境。未能遣于此境。若未能遣唯识境。在此位中已遣何境。皆尽无余。此位但不见四境。何者为四

论曰。是观行人不见名及义。不见自性差别假说。由实相不得有自性差别义已

释曰。名义是本。名义各有自性及差别假说。即是名不见自性差别假说。即是不见自性差别名。遣此四法永尽无余。由心缘意言分别为境。决定坚住是故不复分别余境。由四种寻思及四种如实智。已了别此四法决定无所有故。心不缘此相。不缘此相故不得此四种分别。若由二种方便遣外尘分别。复有何别方便及别境界。得入真观

论曰。由四种寻思及四种如实智

释曰。先答前问无别方便。由以四种寻思及四种如实智。四种三摩提所摄为入方便

论曰。于意言分别。显现似名及义

释曰。次答后问无别境界。凡夫从本来。意言分别有二种。一似名二似义。名义摄一切法皆尽。此名义但是意言分别所作。离此无别余法

论曰。得入唯识观

释曰。依此方便缘此境界。得入唯识真观

论曰。于唯识观中入何法。如何法得入

释曰。此下明八处中第八处。此中有两问。一问所入法。二问所入譬

论曰。但入唯量

释曰。此下先答第一问。但入唯识量。此唯识量摄几种法

论曰。相见二法

释曰。此唯识不出二法。一相识二见识。复次似尘显现名相。谓所缘境似识显现名见。谓能缘识此二法。一是因一是果。又一是所依一是能依

论曰。种种相貌

释曰。此二法由无始生死来。数习故速疾。是故于一时中有种种相貌起。如此三法。于唯识观观行人得入

论曰。名义自性差别。假说自性差别义。六种相无义故

释曰。名义各有三为六。名三者。一名二自性三差别。义三亦尔。此六种相并无义。何以故。名本自义。义无所有故名无义。此名为自有义。为当无义。若有义。义无所有故名无义。若名无义亦无。无所有故。名无义义亦无义。离识量外无别有义。故义亦无义。名既无义。名自性及名差别。亦无有义义既无义。义自性及义差别。亦无有义。明此六相无义。显入唯量观。明入唯量观已。云何入相见观

论曰。由此能取所取。非有为义故

释曰。此即此于相见相。非能取所取。何以故。似尘显现故非能取。离识无别尘故非所取。见亦非能取所取。显现似识故非所取。所取尘既无。识亦是无故非能取。既无能取所取故非有义。由不见能取所取有体。名入相见观。已明入相见观。云何入种种相貌观

论曰。一时显现。似种种相貌及生故

释曰。若菩萨见依他性显现。似种种相貌实无有相。见依他性显现似生。实无有生。于一时中。能观种种相貌。无相无生。名种种相貌观。为显入三性观故说藤譬

论曰。譬如暗中藤显现似蛇

释曰。人见藤相执言是蛇。此下答第二问。众生从本以来。不闻大乘十二部经说三无性义。未得闻慧为三烦恼所覆。譬之如闇。有人譬二乘凡夫。藤相譬依他性。蛇譬分别性。二乘凡夫不了依他性。执分别性有人法

论曰。犹如于藤中。蛇即是虚。实不有故

释曰。于依他性中。分别性是虚。实无人法故

论曰。若人已了别此藤义

释曰。譬菩萨已得闻思二慧。入唯识方便观

论曰。先时蛇乱智不缘境起。即便谢灭唯藤智在

释曰。未得闻思慧时。于凡夫位中执有人法。此执本无有境。得闻思慧后。了别依他性。此执即灭唯依他性智在

论曰。此藤智由微细分析。虚无实境

释曰。若人缘四尘相分析此藤。但见四相。不见别藤故藤智是虚。虚故是乱无有实境。妄起境执

论曰。何以故。但是色香味触相故

释曰。何以故。藤非实有。以离四尘外无别有藤故

论曰。若心缘此境。藤智亦应可灭

释曰。此明藤智虽能遣粗乱执。而自是细乱执故。应可除。在方便中虽以依他性。遣分别性粗乱执。而见有依他性。自不免是细乱执。后入真观即遣此执。故应可除

论曰。若如此见已。伏灭六相显现。似名及义意言分别

释曰。一切法但有六相。此六但是意言分别。离意言分别。有六相实无所有。由如此智。观行人得入分别性

论曰。尘智不生譬如蛇智

释曰。入分别性时尘智不得生。如了别藤时蛇智不生。此言及譬显入分别性

论曰。于伏灭六相义中。是唯识智亦应可伏灭。譬如藤智

释曰。于入分别性位中。菩萨已证无相性。此无相性能引无生性智故。唯识智应可伏灭。如了别四微时藤智不生

论曰。由依真如智故

释曰。依无相性智得入无生性。此言及譬。显入依他性及真实性

论曰。如此菩萨。由入似义显现意言分别相故。得入分别性。由入唯识义故得入依他性。云何得入真实性

释曰。若菩萨已了别一切法。但是意言分别。离此以外实无所有。由依意言分别。得了别分别无相性。若菩萨不见外尘。但见意言分别。即了别依他性。云何了别此法。若离因缘自不得生根尘。为因缘根尘既不成。此法无因缘云何得生。故菩萨能了别依他性及无生性。即是了别真实性

论曰。若舍唯识想已

释曰。若菩萨依初真观。入依他性。由第二真观除依他性。则舍唯识想

论曰。是时意言分别。先所闻法熏习种类

释曰。是入真观时。故言是时。从初修学乃至入真观前。意识觉观思惟忆持。昔所闻正教及正教所显义故。言意言分别。先所闻法数习所生。故言熏习。后时所忆持境界。犹是先时境界所流故名种类

论曰。菩萨已了别伏灭尘想

释曰。菩萨依四寻思。已了别六尘。依四如实智。已伏灭尘想

论曰。似一切义显现。无复生缘故不得生

释曰。昔意言分别显现。似所闻思一切义。乃至似唯有识想皆不得生。何以故。以无得生缘故。生缘有二种。谓分别性及依他性。分别性已灭。依他性又不得生。既无二境故。一切义乃至似唯识想。皆不得生。复次是时无一尘品类。而非菩萨所了别。犹得似此尘起意言分别。意言分别生缘皆尽。既无生缘故。此时中一切意言分别。悉不得生

论曰。是故似唯识意言分别。亦不得生

释曰。此言欲显何义。此唯识想若为心分别。此想则成境界。此境界执由一向伏灭故。乃至唯识想尚不得起。何况余意言分别而当得生

论曰。由此义故

释曰。由菩萨依依他性除分别性。依真实性除依他性。若悉被除。菩萨住在何处。菩萨心缘何境界

论曰。菩萨唯住无分别一切义名中

释曰。无分别智是名。此名其相云何。谓不分别一切义。义即是境。此智于一切境。无复能取所取二种分别。即立此智为菩萨。复次名者。谓至究竟名通一切法。于一切法无有差别。此名即是法界。此法界以通一切法。不分别一切义为相。或说名无分别境。菩萨唯于此法中住。此两复次答第一问

论曰。由无分别智。得证得住真如法界

释曰。不分别能取所取及人法。乃至相生性差别。得如此无分别智故。得证住真如法界。地地皆有三分。谓入住出。得证得住。即前二分。未得令得为证。已得令不失为住。又初得名入。得已相续名住。此即答第二问

论曰。是时菩萨平等平等

释曰。是入真观时。菩萨智依十种平等。如十地经说。又依二种平等。谓能缘所缘。能缘即无分别智。以智无分别故称平等。所缘即真如境。境亦无分别故称平等。又此境智不住能取所取义中。譬如虚空。故说平等平等。以于平等中最上无等。故作重名

论曰。能缘所缘无分别智生

释曰。无分别智生有何相貌。依十种平等。能缘所缘悉平等故。无分别智生。又无分别智依二种平等。谓智及境。能缘所缘悉平等故。无分别智生。又无分别智依最极平等。不住能缘所缘故。无分别智生

论曰。由此义故。菩萨得入真实性

释曰。如前来次第释诸方便义。及后所应说义故。言由此义故。向初地人名菩萨。由此诸义得证见真实性。此位不可言说。何以故。以自所证故。证时离觉观思惟分别故。前说菩萨唯住无分别一切义名中。此名有几种。复次以何法为名

论曰。此中说偈

释曰。为答此问故说此偈

论曰

  法人及法义　　性略及广名
  不净净究竟　　十名差别境

释曰。名有十种是菩萨境界。何等为十。一法名。谓色受等眼耳等。二人名。谓信行法行等。三法名。谓修多罗祇夜等。四义名。谓十二部经所显诸义名。五性名。谓无义文字。六略名。谓众生等通名。七广名。谓众生各有别名。八不净名。谓凡夫等。九净名。谓圣人等。十究竟名。谓通一切法真如实际等

论曰。十名差别境

释曰。此十种差别名。悉是菩萨境界。菩萨所住唯在第十。通一切法名中。复次略说名有十种是菩萨境界。法名谓眼等。人名谓我众生等。法名谓十二部正教。义名谓十二部正教义。性名谓阿阿为初。诃为最后音。字合三十七。略名谓有为无为。广名谓色受等及空等。不净名谓凡夫等。净名谓须陀洹等。究竟名谓缘极通境。出世智及出世后智所缘。一切法真如境

论曰。如此菩萨由入唯识观故。得入应知胜相

释曰。如此谓方便次第时节舍得等。菩萨由如此义得入唯识观。或入唯识方便观。或入唯识真观。由唯识观能通达三无性故。得入应知胜相

摄大乘论释卷第七摄大乘论释卷第八

        世亲菩萨释

        陈天竺三藏真谛译

    释应知入胜相第三之二

    入资粮果章第七

释曰。由入应知胜相。菩萨得何果。菩萨得资粮果有八种

论曰。由入此相得入初欢喜地

释曰。此文即显三果。一得胜时。二得胜方便。三得胜果。初即第一明得胜时果。从始发心修行求至此时。今始得之故名为初。所求之时是入真观时。此明得住真如果。又舍凡夫二乘位。始得菩萨真位故名胜时。此时是转依时故。名此初时为胜时。即是明转依果。欢喜即第二明得胜方便果。舍自爱名欢。生他爱名喜。若不惜自身。不憎恶他。于众行中无难行者。此心于方便中最胜。以为众行根本故。故初地从此立名。又未曾得大用及出世心。得时有大欣庆故名欢喜地。即明第三得胜果。住摄是地义。出离真如是地体。住于此体故名胜果。地因名摄。谓福德智慧二种资粮。又所摄名摄。谓所利益众生。又果名摄。谓无上菩提。又障名摄。谓三烦恼。如此等义说名为地。以是地所摄故

论曰。善通达法界

释曰。即明第四得胜通达果。胜通达有三义。一由得四依故。菩萨依法不依人等。由此通达如来所说一切三乘三藏。菩萨如理释文。是故由文能令自他解真如法界。二如来安立十地。约法界有十重。从初通达乃至上地。皆善通达。三约四种方便故。善通达法界。谓能通达生死苦。而能恒入是二方便。能通达涅槃。而不速求是二方便。能通达苦异凡夫。入苦而不厌怖异二乘。能通达涅槃乐异凡夫。而不速求涅槃异二乘

论曰。得生十方诸佛如来家

释曰。即明第五得胜定位果。由入此胜相。是人决定应破无明[穀-禾+卵]。不于卵中烂坏舍命。复次是人由入此胜相决定。应续十方诸佛种性令不断绝。以自应成佛。又令他成佛故。复次佛子有五义一愿乐无上乘为种子。二以般若为母。三以定为胎。四以大悲为乳母。五以诸佛为父。由此等义故说得生佛家

论曰。得一切众生心平等

释曰。即明第六得胜恩养果。恩养有四种。一广大。二最极。三无边。四无倒。由此四义故。于众生得平等恩养心。复次如菩萨于自身起般涅槃心。于一切众生平等起般涅槃心。复次由菩萨已得自他平等。求灭他苦如求灭自苦

论曰。得一切菩萨心平等

释曰。即明第七得胜意用果。菩萨若欲有所为作。必先思量故名为意。后如所思量而作故名为用。复次求得三事为意。谓未下种令下种。未成熟令成熟。未解脱令解脱。行四摄为用。由前二摄令发心。由利行令成熟。由同利令解脱

论曰。得一切诸佛如来心平等

释曰。即明第八得胜至得果。菩萨在见位中。已得如来法身。由得此法身是故与诸佛心平等。复次于自身。见法界无差别故。不见三世诸佛法界异自法界故。得诸佛心平等

论曰。此观名菩萨见道

释曰。菩萨见有三种。一除方便见。二应除见。三除灭见。除方便见者。谓四种如实智。应除见者。谓分别依他二性。除灭见者。谓三无性。此三见皆因唯识观得成。故名此观为见道相生明次第

    二智用章第八

论曰。复次何故菩萨入唯识观

释曰。此问显二义。一显唯识观难入。二显若得入有无穷利益用

论曰。由缘极通法为境

释曰。先明入前后两观方便。答第一问入唯识观道。此智有四德。一无倒。二清净。三寂静。四微细。此即明第一无倒。通法有四品。谓下中上上上。下品谓一切有流苦。中品谓一切有为无常。上品谓一切法无我。上上品谓三无性。缘三无性为境。是故无倒

论曰。出世

释曰。即第二清净。由是出世无流智故清净

论曰。奢摩他

释曰。即第三明寂静。由此智依奢摩他起。离散动地。是奢摩他智故名寂静

论曰。毗钵舍那智故

释曰。即第四微细。显是菩萨修慧。非闻思慧及二乘修慧。此即初入唯识观方便

论曰。由无分别智后所得

释曰。欲显此智从无倒智生故无倒。无倒故是如理智

论曰。种种相识为相智故

释曰。此显如量智似一切境起。以一切境识为相。于一切所知无碍。由此智得入唯识后观。此即入后观方便。由前后方便难入故。唯识观难得

论曰。为除灭共本阿梨耶识中。一切有因诸法种子

释曰。此下正明二智用。二智用有三种。一灭障。二立因。三得佛法用。此文即明第一灭障用。现在惑未灭令灭故。言除未来惑。未生遮令不生故称灭。唯识道通灭不净品种子因果。因有三种。一因缘。二增上缘。三缘缘。果即是不净品种子。既通灭种子因果故称共。阿陀那识及六识。为不净品因缘故。名本阿黎耶识。是不净品增上缘。缘缘即是六尘。六尘为种子缘缘故。一切法种子。即是一切不净品法种子。种子即是果。此果有缘缘等三因。阿黎耶识既是种子增上缘故。种子在阿黎耶识中

论曰。为生长能触法身诸法种子

释曰。即明第二立因用。诸法即是六度。菩萨所行六波罗蜜熏习。能为无上菩提因。故名种子。此种子若生若长。能证得如来法身。故名为触为生长如此福慧二因故。入唯识观故。唯识观能立因。令得无上菩提

论曰。为转依

释曰。此下明第三得佛法用。为得如来无垢清净法身。即漏尽无畏

论曰。为得一切如来正法

释曰。即是能说障道能说尽苦道二无畏。为利益他为安立正法

论曰。为得一切智智

释曰。即是一切智无畏。此三句即显三德。初明断德。次明恩德。后明智德

论曰。故入唯识观

释曰。为成就前三用故入唯识观。若由无分别智灭障立因得果。故入唯识观。入观后无分别后智其用云何。若依无分别智。正说诸法因果无有功能。以此智无分别故。由无分别后智。于诸法相中菩萨自无颠倒。如自所证。亦能为他说诸法因果。为得此两用故。菩萨修无分别后智

论曰。无分别智后所得智者。于本识及所生一切识识。及相识相中

释曰。此文显菩萨由此智。于因果中无倒本识。是依他性。即是正因所生一切识识。即是本识所生果。谓七识即是分别性相识。即是器世界及六尘。亦是本识果。亦是分别性。此文具明三相。谓内相外相及内外相。故言相中。菩萨于如此因果中无复颠倒

论曰。由观似幻化等譬。自性无颠倒

释曰。菩萨以无分别后智。观此因果相。自然无颠倒。不执有外尘内根唯识是实有法。何以故。菩萨已了别此等法似幻化等譬故。不可依见闻觉知相判诸法为实有。何以故。此心是清净本所流故

论曰。由此义故。菩萨如幻师于一切幻事自了无倒

释曰。如幻师于幻事生见闻等四识。不依此识了别幻事。如本所解了别幻事故。于幻事中无倒。菩萨亦尔。由依本智了别故。于一切相及因果中。无复颠倒。是名菩萨自利

论曰。于一切相因缘及果中。若正说时常无偏倒

释曰。若菩萨依本智。作利他事。谓正说三乘三藏及五明等义。常无偏倒相违。不实不定名偏。符理真实不可动为无偏。处时相滥名倒。随处随时随相名无倒。是名菩萨利他

    二智依止章第九

论曰。是时正入唯识观位中。有四种三摩提。是四种通达分善根依止。菩萨云何应见

释曰。此问欲显入观有三义。一真境。二奢摩他。三毗钵舍那。为明应入处故言正入。唯识观位中。唯识处即三无性真如。此真如非散动智境故。说四种三摩提为依止。是境与智不可分别故。说四种通达分善根为能证。云何应见此法

论曰。由四种寻思。于下品无尘观忍

释曰。乐观无尘义故名为忍。此忍未离三相。谓观善成就因缘惑污清净。未随意修习故是下品

论曰。光得三摩提

释曰。无尘智名光。此定以无尘智为所得。此定为无尘智依止。故名光得。定即奢摩他。智即毗钵舍那。若具五分五智。此定名三摩提

论曰。是暖行通达分善根依止

释曰。福德智慧二行为暖行体。即是三十七品。此行是能烧惑薪道火前相故名暖。此暖行已过地前四位。决定了别真如智名通达。此方便道能助成通达智故名分。能资生究竟位故名善根。此定能为通达分增上缘故名依止。又三十七品中立定为所依止。余三十六为能依止。就三十六中般若是通达。余三十五为分。三十六通名善根。又四善根即是四分

论曰。于最上品。无尘观忍光增三摩提。是顶行通达分善根依止

释曰。已离三相故。是最上品。无尘观忍如前释。无尘智名光。此智于方便中胜进故名增。此定为无尘胜进智依止故名光增。亦以福德智慧二行。为顶行体顶有三义。一如人头顶能持身命。修道者亦尔。若至此位善根则不可断。二如山顶是退际。有人至山顶而退还。修道者亦尔。或有至此位。住方便中不进故名退。三如山顶是进际。或有人至山顶而更升进。修道者亦尔。或有至此位而进入胜位故立顶名。已说菩萨于四种寻思修暖顶二种方便道。于四种如实智中修道云何

论曰。于四种如实智。菩萨已入唯识观了别无尘故

释曰。若菩萨过四种寻思度暖顶两位。则在四种如实智位中。菩萨缘何境。菩萨但缘唯识为境。缘唯识境。复何所得了别无尘义。除无明及疑惑故。名了别。此三句显位及境智

论曰。正入真义一分

释曰。由此智故。菩萨入真义一分。谓无相性。未入无生性及无性性

论曰。通行三摩提。是随非安立谛忍依止

释曰。体无尘智名通。此定以无尘智为行。即为无尘智行依止。故名通行。三无性所显。人法二空名非安立谛。何以故。此谛通一切法。无有差别故名非安立。无到无变异故名谛忍。能符从此义故名随。亦以福德智慧二行为忍体。菩萨已决了无外尘义。于无能取所取义中。心生信乐故名忍。又能安受上品谛义故名忍。于上品谛中。心无退失故名忍

论曰。此三摩提最后刹那了伏唯识想

释曰。此三摩提即是通行三摩提。取通行上上品最后一刹那定。由先了别无相性。后更思量所缘。既无所有能缘必不得生。由此了别故能伏灭唯识想。唯识想既灭。从最后刹那更进第二刹那。即入初地

论曰。转名无间三摩提

释曰。此定与初地相邻。不为余心所隔故名无间。又下地惑不能碍其入初地。不如下地道隔胜方便。不得即入初地故称无间

论曰。应知是世第一法依止

释曰。菩萨以地前为世法。登地为出世法。此无间定犹是世法。于世法中无等故名第一。何以故。世间众生无有修行能等此法者。又此定虽是世法。能为菩萨出世道增上缘。余世法则无此义故名第一。又唯一刹那故名第一

论曰。此四种三摩提。是菩萨入非安立谛观前方便

释曰。前二定是无间修。后二定是恭敬修。欲显此四定非真道故。故说是前方便

    二智差别章第十

论曰。若菩萨如此入初地已得见道。得通达入唯识

释曰。此下显见道为修道依止。由先成立见道故。修道得成。若菩萨于愿乐地中。具修诸方便得入初地。所以得入初地。由得见道故。见道即无分别智。所以得无分别智。由通达真如及俗谛。故知尘无所有是通达真如。唯有识是通达俗。复知此识无有生性。是通达真如。此识是假有为通达俗。若不通达俗。无以能得见真。以离俗无真故。若不通达真无以遣俗。以俗无别体故。所以能通达真俗。由能解唯识理故。此文即显四义。一出世果二出世行。三出世境四出世方便。初地是果。总有为无为法为体。福德智慧行是有为。真如及烦恼不生是无为。初地是假名。由是总故见道是行。所通达真俗是境。入唯识是方便。由入唯识为方便故。能通达真俗境。由通达真俗境故得无分别智行。由得胜行故得初地果

论曰。云何菩萨修习观行。入于修道

释曰。此云何凡问十义。一相二次第。三修四差别。五摄相助六摄相碍。七功德八更互观察。九名十净不净。数修所得为修习。福德智慧为行。般若为观。一切行悉是般若事。皆属般若故名观行。又六度之中般若为第一。故名观行。又见道名观。从见道后所得悉名为行。菩萨依止见道。以何相等得入初地

论曰。如佛广说所安立法相。于菩萨十地

释曰。此中先明三慧境。后明三慧功能。此文即明三慧境。佛广说是闻慧境。所安立法相。即相等十种法相。是思慧境。于菩萨十地。即修慧境。小乘亦有十地故。以菩萨标之。地地皆有十相故言十地

论曰。由摄一切如来所说大乘十二部经。故得现前

释曰。此下明三慧功能。此即明闻慧功能。闻慧能通达十二部教故言摄

论曰。由治所说通别二境

释曰。此明思慧功能。通别二境即相等十法。思慧能研习此十法故言治

论曰。由生起缘极通境

释曰。此下明修慧功能。方便为生正观为起。无间道为生解脱道为起。入分为生出分为起。见道为生修道为起。出世道为生世间道为起。如理如量智所缘为极通境

论曰。出世无分别智。及无分别智后所得

释曰。此正明修慧体

论曰。奢摩他毗钵舍那智

释曰。显此二智寂静无倒。由奢摩他故寂静。由毗钵舍那故无倒

论曰。由无量无数百千俱胝大劫中。依数数修习

释曰。此文显三慧具四种修。不可以譬类得知为无量。不可数知为无数。百亿为一俱胝。非一俱胝故言千。亦非一千故言百。非小劫故言大。此即明长时修。数数修习。即显无间恭敬无余三修

论曰。由昔及今所得转依

释曰。先于入见位时所得转依。此法是修道摄持故。一切所修皆成圣道。已过愿乐地故

论曰。为得三种佛身。更修加行

释曰。是修道摄持究竟用。由如此道理。菩萨更修加行。先修道为见真如。今重修道为得三身故言更修。复次

论曰。云何

释曰。云何是问词。凡约六义为问。一约修位境界为问。修道境界自有三种。一加行依止谓文教。二修行资粮谓依理判义。三修行所通达处谓修慧境界。后三句明三慧境界。以答此问。二约修位三慧功能为问。后三句明三慧功能。以答此问。初明闻慧是修慧方便。次明思慧是修慧资粮。后明无分别智是修慧体。三约修位修慧因果为问。后明无分别智后所得。以答此问。由修慧此智得生故。是修慧果。若无此智不得进后道故。是修慧因。四约修位四修为问。后明长时修乃至无余修。以答此问。五约修位依止为问。后明转依以答此问。若无此转依为依止。修位不成圣道。何以故。凡夫依未转故。六约修位胜用为问。后明三身以答此问。为圆满自利利他两用故修加行。复次

论曰。云何

释曰。通问修位次第。后具明次第。从初起修心乃至修位究竟。以答此问。先以三句明闻思修位即三慧境。次三句显能入三境功能。即是三慧。次显利他功能。即无分别智后所得。如自所证为他解说。次明四修显修位。由四修得成满。次明转依显自利转依。是得法身四德之本。故是自利。次明三身。三身于究竟修位得成。能平等利益自他。法身是自利。应化二身是利他。复次

论曰。如佛广说所安立法相。于菩萨十地

释曰。十地即华严经中十地品所显文句。此文句中。如来广说随所安立道理。复次

论曰。由摄一切如来所说大乘十二部经故得现前

释曰。合如来所说一切法。通为一境。复次

论曰。由治所说通别二境

释曰。所合之境为单为复。欲显双观真俗通一无相。复次

论曰。由生起缘极通境。出世无分别智。及无分别智后所得奢摩他毗钵舍那智

释曰。显道二体更互相摄。由奢摩他故智不散。由毗钵舍那故。定无啖味等染污。复次

论曰。无分别智后所得奢摩他毗钵舍那智。由无量无数百千俱胝大劫中。依数数修习。由昔所得转依。为得三种佛身更修加行

释曰。此智为是世智为出世智。不可说是世智以非世间所习故。不可说是出世智。以于世间心中起故。故此心异无分别智心。此心亦可说世出世及非世非出世。此二智于长时数习故得转依。由转依故菩萨作心云。我今必定应得三种佛身为此义故更修加行

论曰。是声闻见道。是菩萨见道。此二见道差别云何

释曰。声闻见道是他道。菩萨见道是自道。此二见道道差别及果差别。其相云何

论曰。声闻菩萨见道。应知有十一种差别

释曰。前五明道差别。后六明果差别。前五明道差别者

论曰。何者为十一。一由境界差别。谓缘大乘法为境

释曰。如来所说大乘十二部经。说修行法。缘此法为境故发道心。小乘道则无此事

论曰。二由依止差别。谓依大福德智慧资粮为依止

释曰。此道与二乘及世间道有异。世间但修福德而无智慧。二乘但修智慧而无福德。菩萨具修福德智慧。故助道得成。助道即是依止。此依止在道方便中即思修二慧

论曰。三由通达差别。谓通达人法二无我

释曰。先于方便中已得思修慧。从此得入真观。能通达人法二无我理故。于人法不生爱着。凡夫着人。二乘着法。菩萨并不着。故言离欲人法。此即明菩萨所得真修慧。是正道体异于小乘

论曰。四由涅槃差别。谓摄无住处涅槃。以为住处

释曰。此涅槃非是道果。是道住处。何以故。由菩萨行般若。观察生死过失故。修道不在生死。由菩萨行大悲。观众生苦起救济心。虽不在生死而不舍生死故。不住涅槃。由道住此处不执真俗二相生故。名无相道。小乘道则无此事

论曰。五由地差别。谓依十地为出离

释曰。道有下中上。上即是十地。此十地出离四种生死。为通功能。依此十地菩萨道。能出离异于小乘。后六明果差别者

论曰。六七由清净差别。谓灭烦恼习气。及治净土为清净

释曰。前有五事已明道差别。此下六事。次明修道所得果与二乘有异。第六明内清净。第七明外清净。内由自相续中修道。灭除烦恼习气故。名内清净。外由修净土行。所居之土无有五浊。如颇黎柯等世界故。名外清净。内为自清净。外为清净他。小乘则无此事

论曰。八由于一切众生得平等心差别。谓为成熟众生。不舍加行功德善根

释曰。菩萨如自身应般涅槃。欲般涅槃一切众生。由此平等心故。不舍加行功德善根。余度为功德般若为善根。又五度为功德精进为善根。又般若精进为善根。余度为功德。少乘则无此事

论曰。九由受生差别。谓生如来家为生故

释曰。见真如理。证佛法身。能使如来种性不绝故。称生如来家由生如来家乃至当来得成佛故。言为生故。小乘则无此事

论曰。十由显现差别。谓于佛子大集轮中。常能显现。为摄受正法

释曰。诸菩萨通称佛子。众多菩萨聚会故言大集。如来所说法有三义故名轮。一能上下。二未得能得已得能守。三能从此到彼。菩萨常于大集中显现示不破僧。常于法轮中显现示能护持正法。已得令不失为摄。未得令得为受。小乘则无此事

论曰。十一由果差别。谓十力无畏不共如来法。及无量功德生为果故

释曰。菩萨修道皆为得如来。如此等果。小乘则无此事

论曰。此中说两偈

释曰。此中即见道中说两偈。显从见道方便入真如观

论曰

  名义互为客　　菩萨应寻思
  应观二唯量　　及彼二假说
  从此生实智　　离尘分别三
  若见其非有　　得入三无性

论曰。名义互为客。菩萨应寻思

释曰。名于义中是客。义于名中亦是客。以非本性类故。菩萨入寂静位。应观此道理。此即第一寻思方便

论曰。应观二唯量及彼二假说

释曰。菩萨应观名义二法。唯无所有为量。何以故。义有二种。一自性二差别。悉无所有。但是假说。此假说若与义同。义无所有假说亦无所有。若与义不同。则自然无所有。假说即是名。名无所有故于义是客。义无所有故于名是客。无所有是名义本性故。以本性为唯量。若分别作名义。此分别本性无相故。以无相为名义唯量。此即第二如实智方便

论曰。从此生实智离尘分别三

释曰。从四种寻思生四种如实智。何人能得此四智。若人能见三种。但是分别实无外尘。此人则得一分如实智。何者是三分别。一分别名。二分别自性。三分别差别

论曰。若见其非有

释曰。前二句明了达三分别。得入无尘观。依依他性以遣分别性。此句明依真如遣依他性。云何能遣。由名义无所有。能分别亦不得是有。何以故。若所分别名义是有。能分别缘此名义。可说是有。由名义无所有。所分别因缘既是无。能分别体亦无所有。若菩萨见名义无所有故。能分别亦无所有。此菩萨得入何观

论曰。得入三无性

释曰。菩萨见名义更互为客。入异名义分别性。若菩萨见名自性假说。差别假说唯分别为体。得入分别无相性。若菩萨但见乱识无六种相。此乱识体不成故不可说。因缘不成故不可执有生起。此中分别既无。言说亦不可得。则入依他无生性。若菩萨见此二义有无无所有。则入三无性非安立谛

论曰。又正教两偈如分别观论说

释曰。今此论中显入见道境智不圆满故引分别观。论两偈显成此义。何人何位能见此心。但是影无实法义

论曰

  菩萨在静位　　观心唯是影
  舍离外尘相　　唯定观自想
  菩萨住于内　　入所取非有
  次观能取空　　后触二无得

论曰。菩萨在静位观心唯是影

释曰。唯菩萨人在寂静位。能作此观法。义实无所有。心似法义显现。故说唯是影

论曰。舍离外尘相唯定观自想

释曰。若人在寂静位中。已了别心唯是影。能除外尘相。是自心似法及义相起。作如此观

论曰。菩萨住于内

释曰。若菩萨心。如此得住实无有尘。心缘内心起。不缘外尘故住于内。若住于内此心定何所观

论曰。入所取非有

释曰。是所取义实无所有。菩萨能见所取境空

论曰。次观能取空

释曰。由所取义既实非有。世间所说心是能取。如此道理亦不得成。是故观行人亦不见有能取心。前已不见所取。后又不见能取。是时观行人有何所得

论曰。后触二无得

释曰。真如非所取非能取。以无所得为体故。说真如为二无得。是人先已入无相性。次入无生性。后入真如无性性。触以入得为义。由入得真如故名为触。前两偈与后两偈异相云何。前两偈约名义及假说。显四寻思及四如实智。为方便得入真观。后两偈明三性体及三无性。又前两偈显正教。明入三性及三无性。后两偈显所入三性及三无性

论曰。复有大乘庄严经论。所说五偈为显此道

释曰。经义深隐难解。如实显了经中正义。故名庄严经论。论解此经故得庄严名。庄严经论中有众多义。今但略取五偈。此偈欲何所显。此偈为显于修道中难觉了义

论曰

  菩萨生长福及慧　　二种资粮无量际
  于法思惟心决故　　能了义类分别因

论曰。菩萨生长福及慧

释曰。菩萨如前释生在见位。长在修位。又初刹那名生。后刹那名长。又单名生复名长。菩萨所修唯复无单故。生长一时而成。所生长何法。谓福及慧。施等三度名福。般若名慧。精进及定若为生福则属福。若为生慧则属慧。所以尔者。精进若生布施。持戒忍辱则属福。若为生闻思修慧则属慧。定若依四无量起。缘众生为境则属福。若为生尽智无生智及无分别智等则属慧。谁能生长。谓菩萨人

论曰。二种资粮无量际

释曰。此福及慧有二种功用。一能助道。二能成道体。由此二故道得成就。故说此二为道资粮。此二用几功力。凡经几时得成就道。功力无量时节无际。无言显长远。譬如说大海无量大劫无际。以长远故资粮亦尔。修一一度皆遍一切众生。故功力无量。修一一度经三阿僧祇劫。故经时无际

论曰。于法思惟心决故

释曰。由定后心观察诸法。是故于法心得决定。又菩萨备修五明。于度量方便具足自能故。于思惟心得决定

论曰。能了义类分别因

释曰。菩萨能比能证故名能了。真俗二谛名为义类。知此义类但以分别为因。是故能了

论曰

  已知义类但分别　　得住似义唯识中
  故观行人证法界　　能离二相及无二

论曰。已知义类但分别

释曰。由菩萨已于义类及分别。心决定故

论曰。得住似义唯识中

释曰。由菩萨如此思惟。但识似尘显现故。菩萨心住唯识中不缘外起

论曰。故观行人证法界

释曰。由观行人离外尘。但缘识住知尘无相。名证法界

论曰。能离二相及无二

释曰。所证法界有何相。离能取所取二相。及无人法二分别。如此法界菩萨已证

论曰

  若离于心知无余　　由此即见心非有
  智人见此二不有　　得住无二真法界

论曰。若离于心知无余

释曰。由此方便令法界可证。今显此方便。知离唯识外无别有余法

论曰。由此即见心非有

释曰。由见所缘义非有。知能缘心亦非有

论曰。智人见此二不有

释曰。智人谓诸菩萨。见境及心二皆非有

论曰。得住无二真法界

释曰。菩萨若见二皆非有。则得住真法界。真法界者。无尘无识故言无二。离颠倒及变异二虚妄故名真。是诸法第一性故名法界

论曰

  由无分别智慧人　　恒平等行遍一切
  染依稠密过聚性　　遣灭如药能除毒

论曰。由无分别智慧人恒平等行遍一切

释曰。此已见真如菩萨说名慧人。已于见道中得无分别智。此智何相。一以无退为相。不退故称恒。二以平等行为相。此智见一切法平等理。犹如虚空。于如来所说十二部修多罗三乘等法。同见一味无有差别。内外法名一切。内外诸法同一如性故名为遍。平等行显智慧体。遍一切显智慧境界。由如此无分别智菩萨。欲何所作

论曰。染依稠密过聚性

释曰。三种不净品名染。此染以过聚性为依止。从过聚性生故。此过聚性名稠密。以难解难破故。离如来正教。余教不能令解故言难解。离无分别智。余智不能破故言难破。一切染污法熏习种子。是过聚性体

论曰。遣灭如药能除毒

释曰。此性是三品不净法因。难解难破惑等熏习种子为性。由无分别智聪慧人。能遣能灭此过聚性。如阿伽陀药能除诸毒。遣约现在。灭约未来。即是菩萨尽无生智

论曰

  佛说正法善成立　　安心有根于法界
  已知忆念唯分别　　功德海岸智人至

论曰。佛说正法善成立

释曰。一切三世诸佛共说此法。所说理同不相违背。故名正法。又欲显说者胜故言佛说。由所说道理胜及所得果胜故名正法。如来成立正法有三种。一立小乘。二立大乘。三立一乘。于此三中第三最胜。故名善成立

论曰。安心有根于法界

释曰。菩萨先已得闻思二慧。安心于如来正法中。后合观如来一切正说为境界。即是无分别智。此智名有根。得此智已余智皆灭。唯此智不可动坏。故名有根。复次于三无流根中。此智为第一。谓未知欲知根。故名有根。复次解脱有三事。一能生解脱。二能持解脱。令住不失。三能用解脱。自利利他。此解脱三事即配三无流根。此无分别智通于三处得名。自体是根。又能为他作根故名有根。此有根心安住法界中

论曰。已知忆念唯分别

释曰。菩萨已住有根心中。后出观时在无分别后智心中。如前入观事皆能忆念。知此忆念非实有。唯是分别。由无分别智及无分别后智。菩萨得进何位

论曰。功德海岸智人至

释曰。如来功德因中。有十地十波罗蜜等。果中有智德断德恩德。如此诸德唯佛一人。余人所不能得。故名为海。因果究竟名之为岸。智人即是菩萨。菩萨乘前二智。能至未曾至功德海岸。此中五偈总明众义。第一偈显道资粮。第二偈显道加行。第三偈显见道。第四偈显修道。第五偈显究竟道

摄大乘论释卷第八摄大乘论释卷第九

        世亲菩萨释

        陈天竺三藏真谛译

    释入因果胜相第四

    因果位章第一

释曰。此义有十一章。一因果位。二成立六数。三相。四次第。五立名。六修习。七差别。八摄。九对治。十功德。十一互显

论曰。如此已说入应知胜相。云何应知入因果胜相

释曰。总举前所明四位入唯识观。故云如此。前已说于方便道见道修道究竟道四位中。入应知胜相。云何广说入此胜相因。及入后所得果令其开显易见

论曰。由六波罗蜜。谓陀那。尸罗。羼提。毗梨耶。持诃那。般罗若波罗蜜

释曰。此答向问。明因果胜相。易可得见六度为因果体。先以六度为因。后以六度为果

论曰。云何由六波罗蜜得入唯识。复云何六波罗蜜成入唯识果

释曰。向虽说六度为因果体。未释义意故。更问以何义故说六度为因。复以何义说六度为果。此六度能除六种入唯识障故。六度为入唯识因。第一障者。喜乐欲尘。于富财物自身受乐中。见胜功德。由此障故不得入唯识。施能除此障故。施是入唯识因。第二障者。纵心起身口意业。由此障故不得入唯识。戒能除此障故。戒是入唯识因。第三障者。不能安受轻慢毁辱寒热等苦。由此障故不得入唯识忍能除此障故。忍是入唯识因。第四障者。执不修行为乐。未得计得。于得不见功德。由此障故不得入唯识。精进能除此障故。精进是入唯识因。第五障者。乐相杂住。于世间希有事及散乱因缘。见有功德。由此障故不得入唯识。定能除此障故。定是入唯识因。第六障者。于见闻觉知计为如实。于世间戏论勤心修学。于不了义经如文判义。由此障故不得入唯识。智慧能除此障故。智慧是入唯识因

论曰。此正法内有诸菩萨

释曰。唯依正法内修行。能成立入唯识因。若依正法外二乘教及外道世间教。无有得立此因义。故先明正法内为立因之所。能立因人非二乘等所能。故言菩萨。菩萨行何法能入唯识

论曰。不着富乐心。乃至云如理简择诸法。得入唯识观

释曰。此明离布施障。乃至离智慧障。具如前释。故以六度为入因

论曰。由依止六波罗蜜。菩萨已入唯识地。次得清净信乐意所摄六波罗蜜

释曰。若菩萨由依六度除六障。已入唯识。是时菩萨更得清净信乐意所摄六波罗蜜。于六度正教中心决无疑。故名为信。如所信法求欲修行。故名为乐。此信乐意有五因缘。故称清净。一无著清净。谓不起与波罗蜜相违法。二不观清净。谓于自身及波罗蜜果报报恩中。心常不观。三无失清净。谓离与波罗蜜相杂染污法。及离非方便行。四无分别清净。谓离如言执波罗蜜相。五回向清净。谓于六度已生长及未生长中。常求得大菩提。一一波罗蜜。皆具此五种清净信乐所摄。复有清净信乐意。谓已过愿乐地。入见地等。得圣人信乐。异地前信乐故名清净。复有清净信乐意。谓由奢摩他毗钵舍那入真如观。得无分别智及无分别后智所摄信乐意。故名清净

论曰。此正法内有诸菩萨。不着富乐心。于戒无犯过心。于苦无坏心。于善修无懒惰心。于此散乱因中不住着故。常行一心如理简择诸法。得入唯识观。由依止六波罗蜜。菩萨已入唯识地。次得清净信乐意所摄六波罗蜜。是故于此中间。设离六波罗蜜加行功用

释曰。已入唯识观故言是故从见位乃至究竟位为中间假设。此人于其中间不作功用。修行六度。六度自然满足。何以故

论曰。由信乐正说。爱重随喜愿得思惟故

释曰。如来正说与六度相应。虽甚深难解。此人亦信乐无疑。由此信乐无不行义。于六度行中见无穷功德。心生爱重。由此爱重无不行义。如此信乐意何人能得。唯诸佛如来已至究竟波罗蜜位。能得此意。知是胜人所得成。于胜人深心欣赞。故名随喜。由此随喜无不行义。愿众生及我平等。得此清净信乐意。故名愿得。由此愿得无不行义。如佛所立大乘法门。依施等六度及十二部阿含。由闻思修慧数数思惟。由闻慧思惟果得圆满。由思慧思惟于所闻法。心得入理。由修慧思惟自事得成。以能入地及治地故。由此四种思惟无不行义

论曰。恒无休息行故。修习六波罗蜜究竟圆满

释曰。由此四思惟。菩萨恒无放逸。无放逸故修习六度。在因究竟至果圆满。此位能摄六度。令悉具足五种清净。故名清净意位。其相云何。为显此相故。次长行后更说三偈

论曰。此中说偈

  修习圆白法　　能得利疾忍
  菩萨于自乘　　甚深广大说

论曰。修习圆白法

释曰。先于愿行位中。善生长道资粮。为显此义故说初句。所修之行已过四十心位故名圆。施戒修三品清净法名白。复有白法。谓信根智根。精进根定根。此四根即是四位。念根通四位。能除一阐提外道声闻独觉四种黑障。能得净我乐常四德故名白法。若资粮圆满更何所得

论曰。能得利疾忍

释曰。能乐受行是忍义。于广大甚深法。难受难行而能受行故名利。数起不息故名疾。此句显忍是上上品。若菩萨在此忍位。由此境界必得清净。为显此境界故

论曰。菩萨于自乘甚深广大说

释曰。大乘唯是菩萨境界故名自。乘大乘能令菩萨清净。于此乘中有别境界。一法无我名甚深。虚空器等定名广大。前是智境。后是定境。此二境能令菩萨清净。由此思惟菩萨得清净。为显此义故说第二偈

论曰

  觉唯分别故　　得无著智故
  是乐信清净　　名清净意地

论曰。觉唯分别故

释曰。菩萨觉了大乘一切法。乃至甚深广大皆是分别所作。如此觉了名为思惟。此思惟能令菩萨清净。菩萨清净为何所得

论曰。得无著智故

释曰。菩萨见一切法但是分别。无复外境。外境不成故分别亦不成。若菩萨见内外无所有则无所著。即是无分别智。此智即是清净。此清净体性云何。为显此义故说第三句偈

论曰。是乐信清净

释曰。乐信即是无分别智体。不爱七有故名乐。于三种佛性。心决无疑故名信。离七爱故乐清净。离虚妄故信清净

论曰。名清净意地

释曰。由乐信清净故。此位得清净名。又此位是菩萨见位。无分别智境清净处。此智以乐信为体故。说此位名清净意地。清净乐信其相云何

论曰

  菩萨在法流　　前后见诸佛
  已知菩提近　　无难易得故

论曰。菩萨在法流前后见诸佛

释曰。清净乐信有二种相。一恒在寂静为相。二恒明了见佛为相。由乐舍七爱故。恒入观修道故。说恒在法流。若菩萨在法流为何所见。由信三种佛性故。先思惟法身。后证法身。先以比智见法身。后以证智见法身。此乐信有何功德

论曰。已知菩提近无难易得故

释曰。若人在清净乐信位中。明了见无上菩提已近。己身过四十心。是故无难入正方便。所以易得。由此三偈成就资粮忍境界。思惟体性相貌皆得显现

    成立六数章第二

论曰。何故波罗蜜唯有六数

释曰。此问波罗蜜何故定立六数不增不减

论曰。为安立能对治六种惑障故。为一切佛法生起依处故。为随顺成熟一切众生依止故

释曰。立波罗蜜其数有六。凡为此三义。一为除惑。二为生起佛法。三为成熟众生。除惑。现在自得利益。生起佛法。成熟众生。未来得自他利益。若惑已永灭。则于现在得安乐住。何以故。不须更起功用为灭此惑及遮此惑。令不复生故。于现在得自利益。惑障既灭。于未来世必自具足佛法。又能成熟众生故。得自他利益

论曰。为对治不发行心因故。立施戒二波罗蜜。不发行心因者。贪着财物及以室家

释曰。贪着财物障施。贪着室家障戒因此贪着不能发修行心

论曰。若已发修行心。为对治退弱心因故。立忍精进二波罗蜜

释曰。虽已能行施戒。若不忍受苦事则施戒心退弱。虽能忍苦。若不勤修诸善息一切恶。则施戒忍心皆退弱。故为对治退弱心。须立此二度

论曰。退弱心因者。谓生死众生违逆苦事

释曰。不得理者名生死众生。乖反菩萨教为违。侵毁菩萨身为逆。此并是苦事。若不能忍受此苦事。则生嗔心。嗔即是退弱心因

论曰。长时助善法加行疲怠

释曰。精进行于久远时中。修一切善。若于众生无慈悲心。爱惜自身。不见所修行有胜功德故。于所修行中生疲怠心。由有此心不能精进。即是懒惰。懒惰即是退弱心因

论曰。若已起发行及不退弱心。为对治坏失心因故。立定慧二波罗蜜。坏失心因者。谓散乱邪智

释曰。由散乱故坏静心。由邪智故失正解

论曰。是故为对治六种惑障。立波罗蜜有六数。为一切佛法生起依处故者

释曰。六度是生长佛法因

论曰。前四波罗蜜是不散乱因

释曰。有四障为散乱因。一弃舍障。二远离障。三安受障。四数治障。由贪着故不能弃舍。由贪嗔痴生十恶故不能远离。由嗔恚故不能安受。由贪嗔痴等烦恼故不能数治。由此四障故心散乱。前四度能对治此四障故。四度是不散乱因。复次以五盖为定障。四盖障定因。一盖障正定及定所发慧。贪掉悔嗔睡眠四盖。是散乱因。障前四度。四度对治此四盖故。四度是不散乱因。疑缘境不决故心散乱。定心决守一境故。疑障正定。由疑不见理故。障定所发慧故。以定慧对治于疑

论曰。次一波罗蜜是不散乱体。由依止此不散乱故。能如实觉了诸法真理。一切如来正法皆得生起。是故为一切佛法生起依处。立波罗蜜有六数。为随顺成熟一切众生依止故者。由施波罗蜜利益众生。由戒波罗蜜不损恼众生。由忍波罗蜜能安受彼毁辱。不起报怨心由精进波罗蜜生彼善根。灭彼恶根。由此利益因。一切众生皆得调伏。次彼心未得寂静。为令寂静。已得寂静为令解脱。故立定慧二波罗蜜。由此六度菩萨善教众生

释曰。善教有二义。一如理为说故名教。二恒为说故言善教

论曰。故得成熟。是故为随顺成熟一切众生依止。立波罗蜜有六数。由如此义。是故应知成立波罗蜜有六数

    相章第三

论曰。此六波罗蜜相。云何可见

释曰。何故作如此问。世间二乘菩萨皆有施等六行。若不明菩萨所行六波罗蜜相。云何得知此是波罗蜜。此非波罗蜜。是故须问波罗蜜相

论曰。由六种最胜。六波罗蜜通相有六。一由依止无等。谓依止无上菩提心起

释曰。此明所依止有异。世间及二乘行施等。不依止无上菩提心起。唯菩萨行施等。必依止无上菩提心起故。以依止无等。为菩萨所行六度相

论曰。二由品类无等。谓一一波罗蜜略说皆有三品。菩萨皆具修行

释曰。此明所缘事有异。不等世间及二乘。无有能行施等具足品类。谓外内及内外。若菩萨行施等必皆具足品类故。以品类无等。为菩萨所行六度相

论曰。三由行事无等。谓安乐利益一切众生事。菩萨所行诸度。皆为成此二事故

释曰。此明行事有异。菩萨行六度有何能。先为生众生现在未来世间乐。后随根性。生众生三乘道果。世间及二乘行施等。但为安乐利益自身尚不成就。何况能安乐利益众生。故以行事为菩萨所行六度相

论曰。四由方便无等。谓无分别智。菩萨所行诸度。皆是无分别智所摄故

释曰。此明方便有异。于三轮清净。名菩萨方便。于三轮清净即是无分别智。菩萨由此智。不分别能施受施及所施财物。世间及二乘。不能舍三轮分别。是故起我爱及着财物。于他不能平等故。以方便为菩萨所行六度相。戒三轮者。离众生事时分别。忍三轮者。离自他过失分别。精进三轮者。离众生高下事用分别。定三轮者。离境众生惑分别。般若三轮者。离境智众生分别

论曰。五由回向无等。谓回向无上菩提。菩萨所行诸度。决定转趣一切智果故

释曰。菩萨若行施等先作是心。我以此物施与一切六道众生。此是众生财物。我为彼行施。愿彼皆得无上菩提。此施由回向。令他得无上菩提故。此施行永无有尽。若行余度亦皆回向。世间及二乘无回向故。以回向为菩萨所行六度相

论曰。六由清净无等。谓惑智二障永灭无余。菩萨所行诸度分分除二障。乃至皆尽故

释曰。此中显二种清净。一显清净因。二显清净位。清净因者。因灭惑智二障故。施等事清净。清净位者。先于地前渐除惑障。后登初地渐除智障。此两处名分分清净。即是因位。若至佛果六度圆满。名具分清净。即是果位

论曰。施即是波罗蜜。波罗蜜即是施耶

释曰。此问欲何所显。欲简别是波罗蜜及非波罗蜜相

论曰。有是施非波罗蜜

释曰。谓离依止无等等六相行施。此施非六度所摄故。但是施非波罗蜜

论曰。有是波罗蜜非施

释曰。谓具依止无等等六相。行戒等余度

论曰。有是施是波罗蜜

释曰。谓具依止无等等六相行施

论曰。有非施非波罗蜜

释曰。谓离前三句。别行无记及不善等。皆是第四句摄

论曰。如施中四句。应知余度亦有四句

释曰。如施简别是非。余度亦应如此简别

    次第章第四

论曰。云何说六波罗蜜。如此次第

释曰。此或由疑故问。或由不解故问。疑故问者。一切所行必先由智知因果已方起正勤。由此二因。随其所欲则皆能行。是故应倒次第及无次第。由有此疑是故须问。由不解故问者。若人欲修众行。未知浅深难行易行。浅则易行。深则难行。易应先学。难应后学。为知此义。是故须问

论曰。前前波罗蜜。随顺次生后后波罗蜜故

释曰。菩萨不能忍见众生贫穷困苦。数习舍财以串能舍故。不欲作损恼众生事。即舍家持戒故。因施生戒。菩萨为爱护所受戒。不欲以忿恨众生事。毁破净戒。即习行忍故。因戒生忍。由烦恼不尽。或成不成。菩萨为爱护此忍。即行精进。故因忍生精进。若人恒行精进则能治心。由此精进若心沉没。则拔令起。若心掉动。则抑令不起。若心平等。则持令相续。由心调和所以得定。故因精进生定。若心得定。则能通达真如。故因定生慧。此即前能生后

论曰。复次前前波罗蜜。由后后波罗蜜所清净故

释曰。施由戒故清净。若人不持戒。身口意业则不清净。所行之施亦不清净。以依止不清净故。由能持戒依止清净故。施得清净。戒由忍故清净。若人能忍。身口意业皆得清净。忍由精进故清净。以精进能生善灭恶故。精进由定故清净。若精进不在修位。则不能除惑故。定由智慧故清净。若不了别真如。虽复得定。以有流故。即生死法。若见真如所得之定。则成无流。为涅槃道。此即后能清净前。由此二义故有次第

    立名章第五

论曰。依何义立六度名。此义云何可见

释曰。世间立名自有多因。有因生类立名。有因相立名。有因假立名。有因轻贱立名。有因敬重立名。于此五因中。六度从何义立名。从二因立名。种性异故。从生类立名。功德多故。从敬重立名。所立之名自有通别。六种皆称波罗蜜是通名。施戒等有异是别名。何故通名波罗蜜

论曰。于一切世间声闻独觉施等善根中。最胜无等故

释曰。有六种及三种最胜无等。六种如前六相中释。三种者。一时无等。二加行无等。三果无等。一一度皆三阿僧祇劫修行故。时无等。加行无等者。有四种五种。复有五种。复有六种。四种即前所明四修。五种即前所明五种清净。复有五种即五修。复有六种即六意五修六意后文自说果。无等者。谓三身所显无上菩提

论曰。以能到彼岸故。是故通称波罗蜜

释曰。到彼岸自有三种。一随所修行究竟无余为到彼岸。世间及二乘亦有应所修行。修之不尽故非到彼岸。二如众流以归海为极。施等亦尔。以入真如为究竟。即以入真如为到彼岸。世间及二乘虽修施等。不能入真如故非到彼岸。三以应得无等果为到彼岸。更无别果胜于此果。为诸果中上故名彼岸。世间及二乘虽修施等。不求此果故非到彼岸。菩萨所修彼岸皆具此三义。故通称波罗蜜。何故别名陀那等

论曰。能破灭吝惜嫉妒。及贫穷下贱苦。故称陀

释曰。吝惜是多财障。嫉妒是尊贵障。因时能灭吝惜障。果时得多财故离贫穷苦。因时能灭嫉妒障。果时得尊贵故离下贱苦。何以故。若人未破吝惜嫉妒心。则不能行施。故说能破此障。若人行施能破此障。此人后受贫穷下贱苦。无有是处

论曰。复得为大富主。及能引福德资粮。故称那

释曰。能施能用名大富主。由是主故能引福德资粮。由具此义故称陀那

论曰。能寂静邪戒及恶道。故名尸

释曰。因时能破邪戒。果时能离恶道。若人不舍恶业而能持戒。无有是处。故先破邪戒。若人破邪戒持正戒堕四趣者。无有是处。故果时能离恶道

论曰。复能得善道及三摩提。故称罗

释曰。由先持戒后受人天善道果。或在因中或在果中。由持戒故身口清净。清净故无悔。无悔。故心安。心安故得喜喜故得猗。猗故得乐。乐故得定。定故见如实。见如实故得厌离。厌离故得解脱。故因持戒得三摩提。由具此义故称尸罗

论曰。能灭除嗔恚及忿恨心。故名羼

释曰。因时由观五义故灭除嗔恚及嗔恚。所生忿恨心五义者。一观一切众生无始以来于我有恩。二观一切众生恒念念灭。何人能损何人被损。三观唯法无众生。有何能损及所损。四观一切众生皆自受苦。云何复欲加之以苦。五观一切众生皆是我子。云何于中欲生损害。由此五观故能灭嗔恚。嗔恚既灭故能除忿恨

论曰。复能生自他平和事。故称提

释曰。此事通达因果。此忍能令自身不为嗔恚过失所染。即是于自平和既不忿恨。不生他苦。即是于他平和。如经言。若行忍者。则有五德。一无恨。二无诃。三众人所爱。四有好名闻。五生善道。即此五德名平和事。由具此义故称羼提

论曰。灭除懒惰及诸恶法。故名毗

释曰。于恶处沉没故称懒惰。又不厌恶恶行故称懒惰。由懒惰故离诸善行。生诸恶法。三业恒起过故名恶法。由灭懒惰故能除懒惰所生诸恶。此名灭黑法精进

论曰。复行不放逸。生长无量善法。故称梨耶

释曰。此约信乐因果以明精进。信因可行。乐果可得。是故恒行恭敬行名不放逸。由行恭敬。未生善能令生。已生善能令增长。此即生得法精进。由具此义故称毗梨耶

论曰。能灭除散乱。故名持诃

释曰。散乱有五。一自性散乱。谓五识。二外散乱。谓意识驰动于外尘。三内散乱。谓心高下及啖味等。四粗重散乱。谓计我我所等。五思惟散乱。谓下劣心。菩萨舍大乘。思惟小乘

论曰。复能引心令住内境。故称那

释曰。引心令住五种寂静。名为内境。由具此义故称持诃那

论曰。能灭一切见行。能除邪智。故称般罗

释曰。见行谓六十二见。邪智谓世间虚妄解。见行即是惑障。邪智即是智障

论曰。能缘真相

释曰。谓缘真如即如理智

论曰。随其品类

释曰。品类有二种。谓有为无为。及名等五摄。若知此法。即如量智

论曰。知一切法故称若

释曰。真如相及品类名一切法。如理智名般若。如量智是般若果。亦名般若。此二智为三义所显。一对治。即二障。二境界。即真相。三果。即如量智。由具此义故称般罗若

    修习章第六

论曰。云何应知诸波罗蜜修习

释曰。世间及二乘。皆有施等修习。菩萨施等修习。异世间及二乘。云何可知

论曰。若略说应知修习有五种

释曰。若广说修有十二种。一显示修。二损减修。三治成修。四后行修。五相应修。六胜修。七上上修。八初际修。九中际修。十后际修。十一有上修。十二无上修。显示修者。谓修四念处。以能显示。四谛义故损减修者。谓四正勤。以能渐灭诸恶法故。治成修者。谓四如意足。以能治成定故。为除五失及持八灭资粮故。后行修者。谓修五根。以具解脱分善根故。相应修者。谓修五力。以应续见道故。胜修者。谓七觉分。以入四谛观故。上上修者。谓八分圣道。以胜见道故。初际修者。谓凡夫位。修戒乃至得不净观及数息观。以随顺颠倒故。中际修者。谓有学位。此中无倒倒所随故。后际修者。谓无学位。此中无倒非倒所倒故。有上修者。谓声闻独觉修。及等彼位故。无上修者。谓菩萨十地等。以最胜故

论曰。一加行方法修

释曰。谓身口意业能成广大清净最胜故

论曰。二信乐修

释曰。约闻教如初章释

论曰。三思惟修

释曰。思惟修中自有三种。谓爱重随喜愿得。合名思惟修。亦如初章释

论曰。四方便胜智修

释曰。即无分别智有三义。一广大。二清净。三速成。具此三义故。立方便胜智名

论曰。五修利益他事。此中前四修应知如前。利益他事修者。谓佛无功用心。不舍如来事

释曰。明大乘教中所说。诸佛虽已般涅槃犹更起心。般涅槃即法身。更起心即应化二身。诸佛已住法身。由本愿力离三业。随利益众生事。自然显现应化二身。恒不舍如来正事。及行诸波罗蜜。是故诸佛有诸波罗蜜修习

论曰。修习诸波罗蜜至圆满位中。更修诸波罗蜜

释曰。佛及菩萨或随分圆满。或具分圆满。于此圆满位。若修诸波罗蜜。自事已成故不自为。见众生由此行得离四趣入三乘道果故。更修诸波罗蜜。即是利益他事

论曰。复次思惟修习者。爱重随喜愿得思惟。六意摄所修

释曰。此章通明修习义。前明五修。未分别修位有异。云何得知愿行位修。异清净位修。若六意摄三思惟。修诸波罗蜜。应知在清净位。愿行位中则无此义。三思惟是修行本。以六意庄严摄持此三

论曰。六意者。一广大意。二长时意。三欢喜意。四有恩德意。五大志意。六善好意。广大意者。若菩萨若干阿僧祇劫能得无上菩提

释曰。总举劫数无限多少。故言若干。以大小乘经说劫数不同故。不定说劫数多少。小乘明三阿僧祇劫得成佛。大乘明或三或七或三十三阿僧祇劫得成佛

论曰。以如此时。为一刹那刹那

释曰。或合三阿僧祇劫为一刹那。或合三十三阿僧祇劫为一刹那。故再称刹那。如此从一刹那至无量刹那。为一日一月乃至一阿僧祇劫。从一阿僧祇至三十三阿僧祇。方得成佛。欲显菩萨意无厌足故。说此长时

论曰。菩萨于此时中。刹那刹那常舍身命

释曰。此时即总举长时。刹那明世间所说刹那。于向所说长时中。如世间所说刹那。于一一刹那中。常舍身命及以外财。乃至成佛。无有厌足心

论曰。及等恒伽沙数世界。满中七宝奉施供养如来。从初发心。乃至入住究竟清凉菩提

释曰。有余涅槃名清。以离烦恼浊故。无余涅槃名凉。以离众苦热恼故。又菩提以净乐为体。欲显净德故言清。欲显乐义故言凉

论曰。是菩萨施意犹不满足。如此多时刹那刹那。满三千大千世界炽火。菩萨于中行住坐卧为四威仪。离一切生生之具

释曰。此下欲明菩萨修余五度。于此长时一一刹那中。常在极苦难处。资身之具恒不供足。菩萨虽受此苦。于此时中修诸波罗蜜。未尝厌足

论曰。戒忍精进三摩提般若心。菩萨恒现前修。乃至入住究竟清凉菩提。是菩萨戒忍等意亦不满足。是无厌足心。是名菩萨广大意。若菩萨从初发心乃至成佛。不舍无厌足心。是名菩萨长时意。若菩萨由六波罗蜜所作利益他事。常生无等欢喜。众生得益其心欢喜所不能及。是名菩萨欢喜意。若菩萨行六波罗蜜利益众生已。见众生于己有大恩德。不见自身于彼有恩。是名菩萨有恩德意。若菩萨从六波罗蜜所生功德善根。施与一切众生。以无著心回向。为令彼得可爱重果报。是名菩萨大志意。若菩萨所行六波罗蜜功德善根。令一切众生平等皆得。为彼回向无上菩提。是名菩萨善好意。由此六意所摄爱重思惟。菩萨修习

释曰。为显求得心见有大功德故。求欲得之

论曰。若菩萨随喜无量。菩萨修加行六意所生功德善根。是名菩萨六意所摄随喜思惟

释曰。为显无疑心既随喜胜人所行故。决定无疑

论曰。若菩萨愿一切众生。修行六意所摄六波罗蜜。及愿自身修行六意所摄六波罗蜜。修习加行乃至成佛。是名菩萨六意所摄愿得思惟

释曰。为显大悲无独求之心。此三思惟即除三心。一除不行心。二除进退心。三除偏进心

论曰。若人得闻六意所摄菩萨思惟修习。生一念信心。是人则得无量无边福德之聚。诸恶业障坏灭无余

释曰。灭业障有二义。一能坏业令尽。二业虽在以善力大故。能遮恶道报。令永不受业。亦有坏灭义。若人但闻尚得无量无边福德。何况菩萨尽能修行

    差别章第七

论曰。云何应知诸波罗蜜差别

释曰。此问欲何所显。诸波罗蜜品类不可数量。欲显真体故作此问。由明诸波罗蜜差别故。真体显现

论曰。由各有三品。知其差别

释曰。此总标数。以答问

论曰。施三品者。一法施。二财施。三无畏施

释曰。法施利益他心。由法施故他闻慧等善根德生。财施利益他身。无畏施通利益他身心。复次由财施。有向恶者引令归善。由无畏施。摄彼令成眷属。由法施。生彼善根及成熟解脱。由具此义故说施有三品

论曰。戒三品者。一守护戒。二摄善法戒。三摄利众生戒

释曰。守护戒是余二戒依止。若人不离恶。摄善利他则不得戒。若人住守护戒。能引摄善法戒。为佛法及菩提生起依止。若住前二戒。能引摄利众生戒。为成热众生依止。复次守护戒由离恶故。无悔恼心。能得现世安乐住。由此安乐住故。能修摄善法戒。为成熟佛法。若人住前二戒。能修摄利众生戒。为成熟他。此三品戒即四无畏因。何以故。初戒是断德。第二戒是智德。第三戒是恩德。四无畏不出此三德故。言即四无畏因。由具此义故说戒有三品

论曰。忍三品者。一他毁辱忍。二安受苦忍。三观察法忍

释曰。由毁辱忍。能忍他所起过失。何以故。由菩萨为作利益他事。发心修行。虽为他毁辱。不由着此过失还退本行心。由安受苦忍。虽复堕在生死诸苦难中。不由此苦退本行心。由观察法忍。菩萨能入诸法真理。此忍即是前二忍依处。以能除人法二执故。由具此义故说忍有三品

论曰。精进三品者。一勤勇精进。二加行精进。三不下难坏无足精进

释曰。云何得知精进有此三体。由佛世尊于经中说经言。此人有贞实有胜能有勇猛。有强制力不舍善轭。为显三体说此五句。为显勤勇精进说有贞实。为显加行精进说有胜能。何以故。此人于加行时有胜能。如前所欲皆能行故。为显不下难坏无足精进。次第说有勇猛有强制力。不舍善轭三句。何以故。有人始时为得无上菩提。先有贞实加行。时有胜能。为时长远。所求果相未现。于此中间生下劣心。为对治此心显不下精进。故说勇猛。若人虽复勇猛心无退弱。若遭生死苦难。沮坏其心。则退菩提愿。为对治此心显难坏精进。故说有强制力。由有强制力。生死苦难不能令退。若人虽复遭苦不退。于少所得便生足想。由此知足不能得最上菩提。为对治此心显无足精进。故说不舍善轭。由具此义故说精进有三品

论曰。定三品者。一安乐住定。二引神通定。三随利他定

释曰。有定为现世得安乐住。何以故。能离一切染污法故。依此定为生自利。谓三明故能引成六神通。因引成通定生随利他定。利他即是三轮。一神通轮。谓身通天眼通天耳通。此轮为引向邪者令其归正。二记心轮。谓他心通天眼通天耳通。此轮为引已归正者。若未信受令其信受。三正教轮。谓宿住通漏尽通。由宿住通识其根性。由漏尽通如自所得为说正教。令得下种成熟解脱。由具此义故说定有三品

论曰。般若三品者。一无分别加行般若。二无分别般若。三无分别后得般若

释曰。从闻无相大乘教。得闻思修慧。入分别想空。通名无分别加行般若。已入三无性即无分别智。名无分别般若。得无分别智后出观。如前所证。或自思惟。或为他说。名无分别后得般若。般若复有三品。谓未知欲知根。知根。知已根。为生住用出世间事故。由具此义故说般若有三品

    摄章第八

论曰。云何应知诸波罗蜜摄义

释曰。余一切善法。与诸波罗蜜互相摄义。云何应知

论曰。一切善法皆入六波罗蜜摄

释曰。一切善法。谓愿乃至四无碍六通如来所有秘密法藏等。皆是六波罗蜜所摄

论曰。以为彼性故

释曰。由波罗蜜是愿等法性故。此愿等亦摄诸波罗蜜。由愿等是波罗蜜性故。诸波罗蜜同以无分别智为性。故得相摄

论曰。彼是六波罗蜜所流果故

释曰。彼即六通十力四无所畏。乃至不共法等诸佛法。皆是六波罗蜜所流之果。以与波罗蜜同性故

论曰。一切善法所随成故

释曰。信轻安等诸善法。是菩萨道所摄。随菩萨所欲行波罗蜜。皆能成就。波罗蜜即是彼所流果。故得相摄

    对治章第九

论曰。云何应知诸波罗蜜所对治。摄一切惑

释曰。如波罗蜜能摄一切清净品尽。波罗蜜所对治。亦应能摄一切不净品尽。云何应知

论曰。以为彼性故

释曰。如波罗蜜以无著为性故。摄一切善法尽。波罗蜜所对治以着为性。故摄一切不净品尽

论曰。为彼生因故

释曰。不信邪见身见等诸法。能生吝惜嫉妒邪行嗔恚等果。以同性故得为彼因

论曰。为彼所流果故

释曰。此吝惜嫉妒邪行嗔恚等。由着自他故生诸恶行。谓十恶等亦以同性得为彼果。由此诸义故得相摄

    功德章第十

论曰。云何应知诸波罗蜜功德

释曰。行世间施等行亦有功德。菩萨波罗蜜功德云何应知。菩萨波罗蜜功德与世间有同有异。同有六种。异有四种。同有六种者

论曰。若菩萨轮转生死大富位自在所摄

释曰。转轮王天帝梵王等为大富位。于中为主故名自在菩萨凡夫行施同得此报

论曰。大生所摄

释曰。大生有三种。一道胜二性胜三威德胜。菩萨凡夫持戒同得此报

论曰。大眷属徒众所摄

释曰。亲戚名眷属。所摄领者名徒众。眷属及徒众亦有三胜。如前所说故称为大。皆相亲爱不生憎嫉。恒共欢聚未尝违离。菩萨凡夫行忍同得此报

论曰。大资生业事成就所摄

释曰。资生业有四种。一种植二养兽三商估四事王。和同乖诤名事。如所欲为无不谐遂。故名成就。菩萨凡夫行精进同得此果

论曰。无疾恼少欲等所摄

释曰。四无量所摄定。此定得果身无诸病。心离众恼。故恒欢悦。其余诸定所得果报。虽复在家。与离欲仙人不异。以少烦恼故。等谓得好形相及长寿等。菩萨凡夫修定同得此果

论曰。一切工巧明处聪慧所摄

释曰。为立资生故须工巧明处。即十八明处能立现在未来及解脱法。此中有立破二理。若有聪慧则能成此事。菩萨凡夫若修般若同得此报。异有四种者

论曰。如意

释曰。菩萨行施等。得富乐等报。于中常离过失。谓无染污利益自他故。世间行施等。虽有功德则无此事。是名第一异相

论曰。无失富乐

释曰。菩萨行施等。得富乐等报。于中如意。谓自用及为他用。常生三种欢喜故。世间行施等。虽有功德则不如此。是名第二异相

论曰。利益众生为正事故

释曰。菩萨行施等。所生功德常为众生。作世出世利益事。不为自身。世间行施等。虽有功德则不如此。是名第三异相

论曰。菩萨修行六度功德。乃至入住究竟清凉菩提。恒在不异故

释曰。菩萨行施等所生功德。从初发心乃至极果。如本恒在利他不异。此即常住功德。世间行施等。虽有功德则不如此。是名第四异相

    互显章第十一

论曰。云何应知诸波罗蜜更互相显

释曰。如般若波罗蜜等经中说三十六句。显说一一波罗蜜即说余五波罗蜜。云何应知

论曰。世尊或以施名说诸波罗蜜。或以戒名。或以忍名。或以精进名。或以定名。或以般若名说诸波罗蜜

释曰。五波罗蜜入一波罗蜜摄。一波罗蜜中则具有六。但以施等一名说之

论曰。如来以何意作如此说。于诸波罗蜜修行方便中。一切余波罗蜜皆聚集助成故。此即如来说意

释曰。若菩萨于一一波罗蜜修加行。余波罗蜜皆助成此一。如诸菩萨正行施时。守护身口离七支恶。即持正语正业正命戒。由此戒故施得成就。故戒能成施。若菩萨正行施时。能安受受施人相违言语及相违威仪。乃至安受行施苦事。由此忍故施得成就。故忍能成施。若菩萨正行施时。由欲行施心能除贪爱。由有大悲能除嗔恚。由下身心能除憍慢。欲令受者安乐能除悭吝嫉妒。知施有因果能除无明邪见。精进能生如此善。对治如此恶。由精进施得成就。故精进能成施。若菩萨正行施时。一心相续缘利乐众生事。由此定故施得成就。故定能成施若菩萨正行施时。由了别因果不着三轮。故般若能成施。是名余波罗蜜助成一波罗蜜。故合说六波罗蜜。总名为施。如施戒等亦尔。一度具六故成三十六句

论曰。此中说郁陀那偈

  位数相次第　　名修差别摄
  对治及功德　　互显诸度义

摄大乘论释卷第九(第九张十五行。懒惰即是退弱心因之下。应有定慧二波罗蜜文。而三国本皆阙。遂令次文坏失。心因者。谓散乱邪智。及与结文为对治六种惑障故。立波罗蜜。有六数等言。皆无所从来。今捡本论。此中有云。若已起发行及不退弱心为对治坏失心因故立定慧二波罗蜜等二十五字。今依本论加之)摄大乘论释卷第十

        世亲菩萨释

        陈天竺三藏真谛译

    释入因果修差别胜相第五之一

    对治章第一

释曰。此义有五章。一对治二立名三得相四修相五修时

论曰。如此已说入因果胜相。云何应知入因果修差别

释曰。前已总说六度因果差别。在愿行位为因。在清净位为果。未约地辩修差别故。目前总说为如此。唯识智名入。三无性为胜相。六度即是唯识智。入三无性因果。欲显诸波罗蜜修习差别故。问云何应知

论曰。由十种菩萨地。何者为十。一欢喜地。二无垢地。三明焰地。四烧然地。五难胜地。六现前地。七远行地。八不动地。九善慧地。十法云地

释曰。若欲知修差别。观十地差别。即知因果修差别

论曰。云何应知。以此义成立诸地为十

释曰。此问欲显何义。若菩萨入初地。见真如即尽。何以故。真如无分数故。若见真如不尽。真如则有分数。若有分数则同有为法。若见已尽。何故说有十地

论曰。为对治地障十种无明故

释曰。真如实无一二分数。若约真如体。不可立有十种差别。真如有十种功德。能生十种正行。由无明覆故不见此功德。由不见功德故正行不成。为所障功德正行有十种故。分别能障无明亦有十种

论曰。于十相所显法界

释曰。十相谓十种功德及十种正行。此相皆能显法界

论曰。有十种无明犹在为障

释曰。此十种相虽复实有。由无明所覆不得显现。故知菩萨初入真如观障见道。无明即灭。所余无明犹在未灭故。十无明覆十功德。障十正行。何者为十种无明。一凡夫性无明。二依身业等。于诸众生起邪行无明。三心迟苦无明。闻思修忘失无明。四微细烦恼行共生身见等无明。此烦恼最下品故。随思惟起故。已远离随顺本所行事故。故名微细烦恼。五于下乘般涅槃无明。六粗相行无明。七微细相行无明。八于无相作功用心无明。九于众生利益事不由功用无明。十于众法中不得自在无明。凡夫性无明是初地障。此无明即是身见。身见有二种。一因二果。法我执是因。人我执是果。因即凡夫性迷法无我故称无明。二乘但能除果。不能断因。若不断此无明则不得入初地。故此无明为初地障。依身业等。于诸众生起邪行无明。是二地障。菩萨未入二地生如此想。谓三乘人有三行差别。迷一乘理故称无明。又释一切众生所行之善。无非菩萨大清净方便。何以故。清净既一。未至大清净位。无住义故。若悉应同归菩萨大道。云何修方便不修正道。未入二地则无此智。由迷此义故称无明。若不断此无明。则不得入二地。故此无明为二地障。心迟苦无明。闻思修忘失无明。是三地障。未至智根位为迟。未得菩萨微妙胜定为苦。以障根及修故称无明障。闻持等陀罗尼不得成就。令所闻思修有忘失故称无明。若不断此无明。不得入三地。故此无明为三地障。微细烦恼行共生身见等无明。为四地障。烦恼行者。法执分别种子为体。生住灭不停故名行。此种子为身见因。此种子体亦即是身见。以是法分别种类故。此烦恼最下品故者。此释微细义。由是最下品不能染污菩萨心。故名微细。随思惟起故者。此释共生义。虽复不能染菩萨心。随正思惟起。与正思惟相应故不可说无。以能障菩萨一切智故。已远离随顺本所行事故者。此释离伴义。昔在凡夫共位中及地前。随顺本所行一切烦恼事。今修行四地离之已远。由不了法我空故称无明。若不断此无明则不得入四地。故此无明为四地障。于下乘般涅槃无明。是五地障。若人依四谛观修行五地。见生死为无量过失火之所烧然。见涅槃最清凉寂静功德圆满。不欲舍生死。此行难行。不欲取涅槃。此行亦难行。若人修行五地。心多求般涅槃故称无明。若不断此无明不得入五地。故此无明为五地障。粗相行无明。是六地障。若人修行六地。一切诸行相续生。如量如理证已。多住厌恶诸行心中。未能多住无相心中。故称无明。若不断此无明不得入六地。故此无明为六地障。微细相行无明为七地障。若人修行七地。由心于百万大劫中。未能离诸行相续相谓生及灭故。不能通达法界无染净相。如经言。龙王十二缘生者。或生或不生。云何生。由俗谛故。云何不生。由真谛故。于十二缘生中。未能离生相住无生相。不得入七地故称无明。若不断此无明不得入七地。故此无明为七地障。于无相作功用心无明。为八地障。若人修行八地由作功用心。为除微细相行无明。及为住无相心中。未能自然恒住无间缺无相心。故称无明。若不断此无明不得入八地。故此无明为八地障。于众生利益事不由功用无明。是九地障。若人修行九地。心自然恒住无相。但于利益众生事四种自在中。未能自然恒起利益众生事。故称无明。若不断此无明不得入九地。故此无明为九地障。于众法中不得自在无明。是十地障。若人修行十地。于成就三身业及微细秘密陀罗尼三摩提门。未得自在故称无明。若不断此无明不得入十地。故此无明为十地障

论曰。何者能显法界十相

释曰。此问欲显真如有十功德相。此十功德能生十正行及十不共果。以显法界体。十功德是显法界之本故。先问十功德相

论曰。于初地由一切遍满义。应知法界

释曰。真如法界。于一切法中遍满无余。何以故。诸法中无有一法非无我故。人法二执所起分别覆藏法界一切遍满义。由此障故。愿行位人不得入初地。若除此障。即见真如遍满义。人法二执永得清净。由观此义得入初地

论曰。于二地由最胜义

释曰。人法二空摄一切法。尽是遍满义。此义于一切法中最胜清净。由观此义得入二地

论曰。于三地由胜流义

释曰。真如于一切法中最胜。由缘真如起无分别智。无分别智是真如所流。此智于诸智中最胜。因此智流出无分别后智所生大悲。此大悲于一切定中最胜。因此大悲。如来欲安立正法救济众生。说大乘十二部经。此法是大悲所流。此法于一切说中最胜。菩萨为得此法。一切难行能行。难忍能忍。由观此法得入三地

论曰。于四地由无摄义

释曰。于最胜真如及真如所流法。菩萨于中见无摄义。谓此法非我所摄。非他所摄。何以故。自他及法三义不可得故。譬如北鸠娄越人。于外尘不生自他摄想。菩萨于法界亦尔。故法爱不得生。由观此义得入四地

论曰。于五地由相续不异义

释曰。此法虽复无摄。三世诸佛于中相续不异。不如眼等诸根色等诸尘。及六道众生相续有异。何以故。如此等法分别所作故。相续有异。三世诸佛真如所显故。相续不异。若观此义得入五地

论曰。于六地由无染净义

释曰。三世诸佛于此法中。虽复相续不异。此法于未来佛无染。以本性净故。于过去现在佛无净。以本性无染故。由观此义得入六地

论曰。于七地由种种法无别义

释曰。十二部经所显法门。由种种义成立有异。由一味修行一味通达一味至得故。不见有异。由观此义得入七地

论曰。于八地由不增减义

释曰。菩萨见一切法。道成时不增。或灭时无减。如此智是相自在及土自在依止。相自在者。如所欲求相以自在故。即得现前。土自在者。若菩萨起分别愿。愿此土皆成颇梨柯等。以自在故如其所愿即成。初自在为成熟佛法。后自在为成熟众生。此二自在由不增减智得成。即以不增减智为依止。由观此义得入八地

论曰。于九地由定自在依止义。由土自在依止义。由智自在依止义

释曰。初二依止义如前释。智自在者。四无碍解所显名智。此智以无分别后智为体。何以故。遍一切法门悉无倒故。由得此智故成大法师。能令无穷大千世界众生入甚深义。如意能成故名自在。此自在以无分别智为依止。由得此自在故入九地。又释通达法界为智自在依止。故得四无碍解。由观此义得入九地

论曰。于十地由业自在依止义。由陀罗尼门三摩提门自在依止义。应知法界

释曰。通达法界。为作众生利益事若得诸佛三业。及得陀罗尼门三摩提门。则能通达如来一切秘密法藏。得入十地。又释通达法界为业自在依止。通达法界为陀罗尼门三摩提门自在依止。由此通达为化度十方众生。得三身三业故名业自在。由得陀罗尼门三摩提门。如来一切秘密法藏如意通达。故名自在。此三自在并以真如为依止。由观此义得入十地。若通达法界。真如十种功德为得何果。若通达法界遍满功德。得通达一切障空义。得一切障灭果。若通达法界最胜功德。得于一切众生最胜无等菩提果。若通达法界胜流文句功德。得无边法音及能满一切众生意欲果。何以故。此法音无边无倒故。若通达法界无摄功德。得如所应一切众生利益事果。若通达法界相续不异功德。得与三世诸佛无差别法身果。若通达十二缘生真如无染净功德。得自相续清净及能清净一切众生染浊果。若通达种种法无别功德。得一切相灭恒住无相果。若通达不增减功德。得共诸佛平等威德智慧业果。若通达四种自在依止功德。得三身果。若通达无分别依止。得法身果。若通达土及智自在依止。得应身果。由此应身于大集中。得共众生受法乐果。若通达业依止。得化身果。因于此果能作无量众生无边利益果

论曰。此中说偈

  遍满最胜义　　胜流及无摄
  无异无染净　　种种法无别
  不增减四种　　自在依止义
  业自在依止　　总持三摩提

如此二偈。依中边分别论。应当了知

复次此无明。应知于二乘非染污。于菩萨是染污

释曰。二乘修行不为入十地。此无明不障二乘。非二乘道所破故。不染污二乘。菩萨修行为入十地。此无明障菩萨十地。为菩萨道所破故。染污菩萨。若菩萨于初地。能通达一切地。云何次第制立诸地差别。由此住故。菩萨修行十度。通别二行。因此住修别行故。次第制立十地差别

    立名章第二

论曰。云何初地名欢喜由始得自他利益功能故

释曰。菩萨于初登地时。即具得自利利他功能。昔所未得此时始得。是故欢喜。声闻于初证真如时。但得自利功能。无利他功能声闻亦有欢喜义。不及菩萨故。唯菩萨初地立欢喜名。声闻初果不立此名。复次昔所未证出世法。今始得证。无量因缘有大庆悦。恒相续生故称欢喜

论曰。云何二地名无垢。此地远离犯菩萨戒垢故

释曰。菩萨于此地中有自性清净戒。非如初地由正思量所得。故称无垢。复次于此地中。一切细微犯戒过失垢离之已远。自性清净戒恒相续流故称无垢

论曰。云何三地名明焰。由无退三摩提及三摩跋提依止故。大法光明依止故

释曰。菩萨于此地中。未曾离三摩提及三摩跋提。以不退此定故。所说大乘教是此定依止。大法谓大乘法。无分别智及无分别后智名光明。菩萨亦恒不离此智。闻持陀罗尼为此智依止。以定为明。以智为焰。故称明焰。又释定为智根故名依止。智为定根故亦名依止。复次此地是无量智慧光明。无量三摩提闻持陀罗尼依止。故称明焰

论曰。云何四地名烧然。由助菩提法能焚灭一切障故

释曰。菩萨于此地中。恒住助道法故名然。由住此法焚灭大小诸惑故名烧。故称烧然。复次道火炽盛。能烧惑薪。故称烧然

论曰。云何五地名难胜。真俗二智更互相违。能合难合令相应故

释曰。真智无分别。俗智如工巧等明处。有分别。分别无分别此二互相违。合令相应此事为难。菩萨于此地中能令相应。故称难胜

论曰。云何六地名现前。由十二缘生智依止故。能令般若波罗蜜现前住故

释曰。菩萨于此地中。住十二缘生观。由十二缘生智力。得无分别住。无分别住即是般若波罗蜜。此般若波罗蜜恒明了住。故称现前

论曰。云何七地名远行。由至有功用行最后边故

释曰。菩萨于此地中。作功用心修行已。究竟思量一切相皆决了。此思量由功用得成。于加行功用心中。最在后边故称远行。复次无间缺思惟诸法相。长久入修行心。与清净地相邻接故称远行

论曰。云何八地名不动。由一切相及作意功用不能动故

释曰。于无相及一切相。作功用心及惑不能动故。菩萨于此地有二种境。一真境二俗境。真境名无相。菩萨住此境。一切相及功用所不能转。俗境名一切相。即利益众生事。菩萨于此境一切惑不能染。菩萨心由此二义故称不动。复次一切相一切法一切功用。不能转菩萨无分别心。何以故。此无分别心自然相续恒流故称不动

论曰。云何九地名善慧。由最胜无碍解智依止故

释曰。菩萨于此地中。所得四辩名慧。此慧圆满无退无垢名善。故称善慧。复次菩萨于此地中。能具足说一切法。由得无失广大智慧有此功能。故称善慧

论曰。云何十地名法云。由缘通境知一切法。一切陀罗尼门及三摩提门为藏故譬云。能覆如虚空粗障故。能圆满法身故

释曰。菩萨于此地中得如此智。能缘一切法通为一境。此智有胜功能。譬云有三义。谓能藏能覆能益。如净水在云内为云所含。即是能藏义。此智亦尔。陀罗尼门及三摩提门如净水在此智内。为此智所含故。有能藏义。云能覆空一分。此智亦尔。能覆一切粗大惑障。为能对治故。作自地灭道。作余地不生道。复次如云能遍满虚空。此智亦尔。能圆满菩萨转依法身。由此二意故有能覆义。菩萨由有此智。如大云于一切众生。随根随性常雨法雨。能除众生烦恼燋热。能脱众生三障尘垢。能生长众生三乘善种故。有能益义。法目此智。以云譬智。故称法云。通名地者有四义。一住义二处义三摄义四治义。是十一无流胜智住位故。以住为义。是受用现世安乐住。成熟佛法。成熟众生处故。以处为义。总摄一切福德智慧故。以摄为义。能对治惑流故。以治为义

    得相章第三

论曰。云何应知得诸地相

释曰。若菩萨已得欢喜地所得实相。此相能发起菩萨自精进心。能生众生信乐心。能令菩萨离增上慢心。须说所得地相。故问云何应知

论曰。由四种相

释曰。四种相中。随一相显现。即验此人已入菩萨地。何以故。此四相离登地人于余处则无

论曰。一由已得信乐相。于一一地决定生信乐故

释曰。有五种信乐。如地持论说。一无放逸。二遭苦难众生无救无依。为作救济依止之所。三于三宝起极尊重心。穷诸供养。四知所有过不一念覆藏。即皆发露。五于一切事及思修中。先发菩提心。于此五中。随一显现。即验已入菩萨地。譬如须陀洹人得四不坏信。何以故。此五是菩萨常所行法。是故能显菩萨已入地相

论曰。二由已得行相。得与地相应十种法正行故

释曰。若菩萨修行十地。不出十种正行。此十种正行是十地依止。十种法正行如十七地论说。诸菩萨于大乘中。为成熟众生有十种善法正行。与大乘相应。十二部方等经菩萨藏所摄。何等为十。一书持二供养三施他。四若他正说恭敬听受。五自读六教他令得。七如所说一心习诵。八为他如理广释。九独处空闲正思称量简择。十由修相入意。如此十种正行。几是大福德道。几是加行道。几是净障道。一切是大福德道。第九是加行道。第十是净障道

论曰。三由已得通达相。先于初地通达真如法界时。皆能通达一切地故

释曰。由四寻思四如实智。所得真如地地不异

论曰。四由已得成就相。此十地皆已至究竟修行故

释曰。成就心有四种。所缘境亦有四种。菩萨于愿乐地中善增长善根。已依菩提道出离二执。是菩萨心缘四种境起。何者为四。一缘未来世菩提资粮。速疾圆满。二缘作众生利益事圆满。三缘无上菩提果。四缘诸如来具相佛事圆满。缘此四境即有四心。一精进心。二大悲心。三善愿心。四善行心

    修相章第四

论曰。云何应知修诸地相

释曰。已说得诸地相。复以何方便修能得诸地。故问云何应知

论曰。诸菩萨先于地地中。修习奢摩他毗钵舍那。各有五相修习得成

释曰。三世菩萨修行悉同。为得未曾得为先。此显修时在清净意位。故言于地地中所修十波罗蜜。通有二体。一不散乱为体。二不颠倒为体。不散乱属奢摩他。不颠倒属毗钵舍那。诸地各各具五相修习。得成菩萨地。若无此五修不得入菩萨地

论曰。何者为五。一集总修

释曰。依佛所说。大乘正教。种种文句。种种义理。种种法门。由四寻思及四如实智。观察名义法门。自性及差别皆不可得。此不可得不可说有。离三性故。不可说无。是清净梵行果故。如来所说通是一味。故名总修。此修依智慧行

论曰。二无相修

释曰。如前所说无著等五种清净。故名无相。又于自身报恩果报不着。故名无相。此修依大悲行

论曰。三无功用修

释曰。菩萨不由作功用心。自然在菩提行。若于余事须作功用心。此修依自在及正见行

论曰。四炽盛修

释曰。菩萨不以攸攸心修道。舍下中心依止上品心。修行之时。于身命财无所吝惜。故名炽盛。此修依精进行

论曰。五不知足修

释曰。如前所说。于长时修施等行。不生疲厌故名不知足。此修依信行。如经言。若人有信则于善无厌

论曰。应知于诸地皆有此五修

释曰。诸地皆须五修有二义。一未得令得。二已得令不失

论曰。此五修生五法为果

释曰。五修是因。五法为果。果有二种。一真实果。二假名果。五法是真实果。地是假名果。以五法成地故。地是假名果

论曰。何者为五。一刹那刹那能坏一切粗重依法

释曰。惑障为粗。智障为重。本识中一切不净品熏习种子。为此二障依法。初刹那为次第道。第二刹那为解脱道。初刹那坏现在惑令灭。第二刹那遮未来惑令不生。复次由奢摩他毗钵舍那智缘总法为境。刹那刹那能破坏诸惑聚。是所对治者令灭。非所对治者令羸。此惑灭不生果。是总修所得

论曰。二能得出离种种乱想法乐

释曰。能得出离种种立相想现受法乐。何以故。如来随众生根性及烦恼行。立种种法相。若人如文判义。此种种法前后相违。若执此相不离疑惑。于正法中。现世无有得安乐住义。若依无相修。于正法中出离种种立相想。观此正说同一真如味。心无疑厌。于正法中。纵任自在故现世得安乐住。此成熟佛法果。是无相修所得

论曰。三能见一切处无量无分别相善法光明

释曰。约三乘法说一切处。又约内外法说一切处。又约真俗说一切处。如此一切处菩萨能见无量相。如佛所说法相及世间所立法相。菩萨皆能了达即是如量智。如其数量。菩萨以如理智。通达无分别相。此二智能照了真俗境。故名善法光明。此二智果是无功用修所得

论曰。四如所分别法相。转得清净分恒相续生。为圆满成就法身

释曰。如昔所闻。于思量觉观中。奢摩他毗钵舍那未满未大。未随缘行。以未有炽盛修故。得此修已由离障故。转得清净分。由相续生故得圆满。由圆满故得触法身。至究竟位故得成就。谓起时圆满时究竟时。复次如来有二种身。一解脱身二法身。由灭惑故解脱身圆满。由解脱身圆满故法身成就。此出离果是炽盛修所得

论曰。五于上品中转增。为最上上品因缘聚集

释曰。菩萨登地已得上品。由于善法不知足故。更进修习。从初地转触二地。乃至从十地转触佛果。成最上上品。先所修福德智慧资粮。无分别智为因。诸助道法为缘。一时满足故言因缘聚集。此圆满果是不知足修所得。所余诸地义。应知如十七地论说。谓有能无能等。于十地中有几种法。未灭为灭未得为得故。菩萨修十地行。菩萨先在愿行地中。于十种法行修愿忍得成。由愿忍成过愿行地。入菩萨正定位。愿者有十大愿。一供养愿。愿供养胜缘福田师法主。二受持愿。愿受持胜妙正法。三转法轮愿。愿于大集中转未曾有法轮。四修行愿。愿如说修行一切菩萨正行。五成熟愿。愿成熟此器世界众生三乘善根。六承事愿。愿往诸佛土常见诸佛恒得敬事听受正法。七净土愿。愿清净自土安立正法及能修行众生。八不离愿。愿于一切生处恒不离诸佛菩萨得同意行。九利益愿。愿于一切时恒作利益众生事无有空过。十正觉愿。愿与一切众生同得无上菩提恒作佛事。此十愿至登初地乃得成立。何以故。此愿以真如为体。初地能见真如故。忍者即无分别智。由愿忍成故有二种胜能。谓能灭能得。何者是耶。有二十二无明。十一粗重报障十一地。诸地各能灭三障。各得胜功德。初地能灭三障者。一法我分别无明。二恶道业无明。此二无明感方便生死名粗重报。为灭三障故修正勤。因修正勤灭三障已得入初地得十分圆满。一入菩萨正定位。以入菩萨初无流地故。二生在佛家。如诸菩萨生法王家。具足尊胜故。三种性无可讥嫌。以过二乘及世间种性故。四已转一切世间行。以决定不作杀生等邪行故。五已至出世行。所得诸地必无流故。六已得菩萨法如。由得自他平等故。七已善立菩萨处。由证真实菩萨法故。八已至三世平等。由觉了一切法无我真如故。九已决定在如来性中。当来必成佛故。十已离坏卵事由佛道破无明[聲-耳+卵]。于外般涅槃故。菩萨于初地。由见法界遍满义。得此十分。如声闻在初果有十分功德。由此分故初地圆满。菩萨于初地未有胜能。未能了达菩萨戒中微细犯戒过行故。所以未能者由三障故。一微细犯过无明。二种种相业行无明。此二无明感方便生死故名粗重报。为灭三障故修正勤。因修正勤灭三障。已入第二地得八种清净功德。一信乐清净。二心清净。三慈悲清净。四波罗蜜清净。五见佛事佛清净。六成熟众生清净。七生清净。八威德清净。于上上地离如来地。此八种功德转上转胜。由此分故二地圆满。菩萨于二地未有胜能。未得世间四定四空三摩跋提。及闻持陀罗尼具足念力。所以未得者由三障故。一欲爱无明。二具足闻持陀罗尼无明。此二无明所感方便生死名粗重报。为灭三障故修正勤因。修正勤灭三障已。入第三地得八种转胜清净及四定等。乃至通达法界胜流义。由此分故三地圆满。菩萨于三地未有胜能。未能随自所得助道品法中如意久住。未能舍离三摩跋提法爱心清净住。所以未能者由三障故。一三摩跋提爱无明。二行法爱无明。此二无明所感方便生死为粗重报。为灭此三障故修正勤。因修正勤灭三障。已入第四地得八种转胜清净。及于助道品法中如意久住等。乃至通达法界无摄义。由此分故四地圆满。菩萨于四地未有胜能。菩萨正修四谛观。于生死涅槃。未能舍离一向背取心。未能得修四种方便所摄菩萨道品。所以未得者由三障故。一生死涅槃一向背取思惟无明。二方便所摄修习道品无明。此二无明所感因缘生死名粗重报。为灭此三障故。修正勤。因修正勤灭三障。已入第五地得八种转胜清净。及得舍离背取心等。乃至通达法界相续不异义。由此分故五地圆满。菩萨于五地。未有胜能。诸行法生起相续如理证故。由多修行厌恶有为法相故。未能长时如意住无相思惟故。所以未能者由三障故。一证诸行法生起相续无明。二相想数起无明。此二无明感因缘生死名粗重报。为灭此三障故修正勤。由修正勤灭三障。已入第六地得八种转胜清净。及不证诸行生起相续等。乃至通达法界无染净义。由此分故六地圆满。菩萨于六地未有胜能。未能离有为法微细诸相行起。未能长时如意住无间无流无相思惟中。所以未能者由三障故。一微细相行起无明。二一向无相思惟方便无明。此二无明所感因缘生死名粗重报。为灭三障故修正勤。由修正勤灭三障。已入第七地得八种转胜清净。及离有为法微细行起诸相。乃至通达法界种种法无差别义。由此分故七地圆满。菩萨于七地未有胜能。未能离功用心得住无相修中。未能于自利利他相中心得自在。所以未能者由三障故。一于无相观作功用无明。二于相行自在无明。此二无明所感有有生死名粗重报。为灭三障故修正勤。因修正勤灭三障。已入第八地得八种转胜清净。及离功用心得住无相修中等。乃至通达法界无增减义。由此分故八地圆满。菩萨于八地未有胜能。未得于正说中具足相别异名言品类等自在。未得善巧说陀罗尼。所以未得者由三障故。一无量正说法无量名句味难答巧言自在陀罗尼无明。二依四无碍解决疑生解无明。此二无明所感有有生死名粗重报。为灭此三障故修正勤。因修正勤灭三障。已入第九地得八种转胜清净及于正说中得具足相自在等。乃至通达法界智自在依止义。由此分故九地圆满。菩萨于九地未有胜能。未能得正说圆满法身。未得无著无碍圆满六通慧。所以未得者由三障故。一六神通慧无明。二入微细秘密佛法无明。此二无明所感有有生死名粗重报。为灭此三障故修正勤。因修正勤灭三障。已入第十地得八种转胜清净。及能得正说圆满法身等。乃至通达法界业自在依止义。由此分故十地圆满。菩萨于十地未有胜能。未得清净圆满法身。未能于一切应知境得无著无碍见及智。所以未得者由三障故一于一切应知境微细着无明。二于一切应知境微细碍无明。此二无明所感无有生死名粗重报。为灭此三障故修正勤。因修正勤灭三障。已入如来地得七种最胜清净。离生清净。及得清净圆满法身无著无碍见智等。由此分故如来地圆满。十地功德皆是有上。如来地功德悉是无上。诸波罗蜜是菩萨学处。何故或说有六。或说有十。说有六者凡有二义。一前三成他世间利益。二后三成他烦恼对治。由菩萨行施。立众生资生具故。令他离贫穷苦。由菩萨行戒。离逼害损恼众生故。令他无怖畏。由菩萨行忍。不报众生逼害损恼恶事故。令他无疑安心故。此三是成他世间利益。菩萨行精进。若他未伏惑及未断惑能安立此人于善及助善处。由此精进。诸惑不能令彼退善及助善处。菩萨行定。能伏灭他烦恼。菩萨行般若。能断除他烦恼。是故后三为成他烦恼对治。或说有十。更立后四波罗蜜数者。为助成前六故立后四前三波罗蜜所利益。由四摄所显。方便波罗蜜能安立彼于善处故。方便波罗蜜是前三波罗蜜助伴。若菩萨于现世或为烦恼多。或由愿生下界。或由心羸弱。于恒修习及心住内无有功能。定缘菩萨藏文句生。无有功能引出世般若。菩萨行薄少善根功德。愿于未来世烦恼薄少无力等。是菩萨愿波罗蜜力。令烦恼薄少等。能起菩萨精进波罗蜜。自为既尔令他亦然。故愿波罗蜜是精进波罗蜜助伴。此已得精进菩萨。由事善知识得闻正法。如闻正思惟故。能除羸弱心地。于美妙境得强胜心地。是菩萨力波罗蜜。由此修力菩萨能引心。令住内境故力波罗蜜是。定波罗蜜助伴。此已得力菩萨。缘菩萨藏文句所生闻思修慧。及缘五明智。此智能如理简择真俗境。此智或在无分别智前。或在无分别智后。是菩萨智波罗蜜。由此智能生定及引出般若故。智波罗蜜是般若波罗蜜助伴。复次菩萨十种学处次第云何。前前波罗蜜能摄成后后波罗蜜。为彼依止故。若菩萨不惜六尘及自身乐。得受持禁戒。菩萨为护惜戒故。忍受他毁辱。由能忍受故精进不懈。由此精进息恶生善故。触三摩提。若定成就则能引出世般若。由般若回向前六度。为得大菩提故。施等无尽故。般若能引方便因。此方便发诸善愿。能摄随顺生处。一切生处恒值如来出世。是故常行施等故。方便能引愿。因此愿故得二种力。谓思择力及修习力。破施等对治。决定常能修行施等。是故愿能引力。因此力故如言执义。无明则灭。得受施等增上缘正说法乐。因此法乐能成熟众生善根故。力能引智。初地通达遍满义。得出世智菩萨见见道所摄法界。所谓二空故能了知自他平等。由得平等不爱自憎他。于自他利益能平等行。是故初地行施圆满。二地由通达最胜义。谓自性清净。菩萨作如此意。如经言。我等同得此清净故出离。是故应唯修真道。此经显二义。一显法界自性清净最胜无别。二显真道归趣法界。既不见法界有上中下品故。不求二乘果。但求无上菩提。此清净道即是菩萨戒是故二地行戒圆满。三地由通达胜流义故行忍。何以故。如来所说十二部经是法界胜流。从通达法界生故。若人如理依文修行。得证此希有法。菩萨作是思惟。如经言。为得此文。无有难忍而不能忍。假使三千大千世界满中盛火。菩萨为求此法能投身火中。是故三地行忍圆满。四地由通达无摄义。观法界无所系属。以是无分别智境故。如经言。由此通达陀诃那三摩提三摩跋提。及善法爱灭不更生。此地中一切定。及三十七道品法极成就。于中爱乐不可舍离。何以故。过失难见故。若无最胜正勤。此爱不可灭。此爱若灭知正勤已成。是故四地行精进圆满。五地由通达相续不异义。谓一切诸佛法身自性无别异。菩萨得十种清净意平等。此意平等即是菩萨定。何以故。菩萨定者境界平等。由缘真如及众生故。由行平等通摄六度故。由方便平等离高下心故。由道平等离有无二边故。如此等十种意平等为定体。是故五地行定圆满。六地由通达无染净义。菩萨在六地观十二缘生。此观中不见一法有净有染。何以故。法界自性清净故。无明等十二分唯分别为性。分别既无相为性故。不见法有染。染既不成故不见法有净。如经言。龙王十二缘生。或生或非生。约世谛说生。约真谛说不生。复次于十二缘生。无法名染无法名净。法性无别异故。是故六地行般若圆满。十地由通达种种法无别异义。谓如来说三乘无量法门。同一真如味十二部经所说种种相想。永不复生。由知诸法无别异义。所有真俗诸行一向回向无上菩提。即是方便回向胜智为方便。体。令他得益为方便用。施等善根不减不尽为方便事。此方便但为利他非为自利。以不尽故利他无穷。是故七地行方便行圆满。八地由通达不增减义。菩萨观烦恼灭时无减。道生时无增。法界有两位。一有垢位。二无垢位。菩萨不见法界垢位有增。不见法界无垢位有减。又不见无垢位道生为增。有垢位道不生为减。不见一法有增减故。依此法界胜愿得成。菩萨于八地缘真俗境。两智相违。若离愿力无并成义。何以故。缘真是无分别智自在。以无功用心故。缘俗是净土自在。以清净有功用心故。此二自在必依愿力得成。此愿以何法为体。未得求得。是愿体。如先所求自然而成。是愿用。一切生处恒值诸佛。常行施等善根成立不断。是愿事。此愿但为利他非为自利。以不断故。一切生处利他无穷。是故八地行愿圆满。九地由通达智自在依止义。于九地中得二种力。谓思择力及修习力。由此力故能伏一切正行对治。能令善行决定。此力以何为体。无边智能。是力体。能伏对治令不起。是力用。令所行善决定清净无杂无碍。是力事。此力但为利他非为自利。以决定故利他无穷。是故九地行力圆满十地由通达业自在依止义。菩萨观真如遍满。是应化身依止故。得随真如。于十方世界显现二身。作自他利益事。此业是应化二身所显。此智以何为体。般若及定是智体。不住生死涅槃。是智用。利益凡夫及圣人。是智事。此智但为利他非为自利。二身所显故利他无穷。是故十地行智圆满故

论曰。于十地中修十波罗蜜。随次第成。于前六地有六波罗蜜。如次第说

释曰。前六地。通达法界六种功德故各行一波罗蜜。此义如前说

论曰。于后四地有四波罗蜜

释曰。若说六波罗蜜。方便胜智等四波罗蜜。应知摄在六中。摄义如前说。若说十波罗蜜。前六波罗蜜是无分别智摄。后四波罗蜜是无分别后智摄。后四地依无分别后智。修行四波罗蜜。云何知方便胜智是无分别后智摄。此波罗蜜复以何法为体。为答此两问故

论曰。一沤和拘舍罗波罗蜜。六波罗蜜所生长善根功德。施与一切众生悉令平等。为一切众生回向无上菩提

释曰。若人求得无上菩提。先自思惟。凡是一切众生利益事我悉应作。是故求无上菩提。一切行菩萨道人。其心皆尔。由为欲利益众生故。所作善根功德悉回向无上菩提。因果皆同是名平等。此平等是方便胜智用。般若大悲以为其体。何以故。是六波罗蜜依般若生长。依大悲为众生回向无上菩提令平等皆得。由般若故不回向梵释等富乐果。由大悲故不回向二乘果。是故不舍生死。于中不被染污。是名方便胜智波罗蜜。若离分别此事不成。故是无分别后智摄。复云何知愿波罗蜜是无分别后智摄。复以何法为此波罗蜜体。为答此两问故

论曰。二波尼他那波罗蜜。此度能引摄种种善愿。于未来世感六度生缘故

释曰。此愿于现在世依诸善行。能引摄种种善愿。此愿于未来世能感随六度生缘。谓好道器及外资粮善知识正闻等。是名善愿因果事。清净意欲以为其体。依般若故得清净。依大悲故有意欲。若离分别此事不成故。是无分别后智摄。云何知力波罗蜜是无分别后智摄。此波罗蜜复以何法为体。为答此两问故

论曰。三婆罗波罗蜜。由思择修习力伏诸波罗蜜对治故。能引六波罗蜜相续生。无有间缺

释曰。于余经中说力有二种。一思择力。二修习力。思择力者。正思诸法过失及功德。此思择若增胜非自地惑所能动。坚强故名力。修习力者。心缘此法作观行。令心与法和合成一。犹如水乳。亦如熏衣。是名为修。此修若增成上上品。能断除下地惑。亦以坚强故名力。此中但取思择力。伏灭诸波罗蜜对治惑。行六波罗蜜令相续无间缺。此即是力波罗蜜事。既但取思择力故。以思慧为其体。为利益他伏恶行善故。兼属大悲。若离分别此事不成。故是无分别后智摄。云何知智波罗蜜是无分别后智摄。复以何法为此波罗蜜体。为答此两问故

论曰。四若那波罗蜜。此度是能成立前六度智。能令菩萨于大集中受法乐。及成熟众生

释曰。此度谓智波罗蜜。智有二种。一有分别。二无分别。今明有分别智。何以故。以能成立前六波罗蜜故。能成立者。如来依六波罗蜜所说一切正法。菩萨能思量简择自得通达。及令他得通达。能成立六度故。菩萨于大集中得受法乐。令自他通达。为欲成熟众生。此即智波罗蜜事。亦以思慧为体。此智既为利物故。兼属大悲。若离分别此事不成。故是无分别后智摄

论曰。后四波罗蜜应知是无分别后智。摄一切波罗蜜。于一切地中不同时修习

释曰。随别义。诸地各修一度。故不同时

论曰。从波罗蜜藏藏经。应知此法门广显诸义

释曰。一切大乘法名波罗蜜藏。为利益他故佛说大乘。摄藏诸波罗蜜。非声闻乘得此藏名。以声闻乘不为利他说故。若一切大乘皆名波罗蜜藏。此法门为从何出。此法门是十地波罗蜜藏所摄。以文摄义故名藏。部党类相摄又名藏。故有重藏名。复次佛不为二乘说。于二乘有隐秘义。故名为藏。此经中说一切波罗蜜地地各各修习。得成此地。诸佛于一切土处恒为胜行人说。此正说地义。如来法中为无等说。以无义无行得胜此地。此地能为一切义作依止故。何以故。由如来简择于胜处说故。所以胜者。以外尘及能住众生所住之处皆胜故

摄大乘论释卷第十摄大乘论释卷第十一

        世亲菩萨释

        陈天竺三藏真谛译

    释入因果修差别胜相第五之二

    修时章第五

论曰。于几时中修习十地。正行得圆满

释曰。此十地是菩萨大地。修行之时不可同于二乘。何以故。不唯为自身所济度多故。所修方便多故。所应至处最高远故。譬如王行不可同于贫人故。大小乘修行时有长短。欲显此义故问修行时

论曰。有五种人。于三阿僧祇劫修行圆满。或七阿僧祇劫。或三十三阿僧祇劫。何者为五人。行愿行地人。满一阿僧祇劫。行清净意行人。行有相行人。行无相行人。于六地乃至七地。满第二阿僧祇劫。从此后无功用行人。乃至十地满第三阿僧祇劫

释曰。何等为五。一有一人。谓愿乐行人。二有三人。谓清净意行人有相行人无相行人。三有一人。谓无功用行人。是名五人。愿乐行人自有四种。谓十信十解十行十回向。为菩萨圣道有四种方便。故有四人。如须陀洹道前有四种方便。此四人名愿乐行地。于第一阿僧祇劫修行得圆满。此地若已圆满。此观行人未得清净意。行以未证真如。未得无分别智。故无分别智即是清净意行。又犹同二乘心故。非清净意行。又未至菩萨不退位。故非清净意行。如世第一人未得无流心。说为不清净。无流心所缘法相无有忘失故。得无流心说为正定位。有流心有忘失故。不得受正定名。菩萨亦尔。未入初地不得正定名。此不清净意行人。若见真如即入清净意行地。从初地至十地同得此名。清净意行人自有四种。初一从通立名。谓清净意行。后三从别立名。谓有相行。无相行。无功用行。此清净意行人。从第六地以还说名有相行。有相行者境界相有四种。一有分别相。二无分别相。三品类究竟相。四事成就相。有分别相者。定所缘境等。分为毗钵舍那境。若无分别为奢摩他境。缘此境生舍是定相。缘定境无分别真如起。名无分别相。品类究竟相者。谓如理如量二修。事成就相者。谓菩萨地地中转依。第七地是无相行有功用。如来所说十二部法门相。乃至十二缘生相。熟思量故不缘法门相。直通达真如味。此通达离功用则不成故。说此地为无相行有功用。清净意行有相行无相行三人。第二阿僧祇劫修行得圆满。若人入八地。有无相行无功用未成就。若八地圆满。于八地无相行无功用已成。于九地十地无相行。无功用未成满。第三阿僧祇劫此无相无功用乃成。譬如须陀洹斯陀含阿那含三位制立为五人。若三位云何制立为五人。由位差别故成五人。从初方便至须陀洹为第一人。家家为第二人。斯陀含为第三人。一种子为第四人。阿那含为第五人。菩萨位亦尔。初地为第一位。从二地至七地为第二位。从第八地至第十地为第三位。亦得制立为五人。从方便至初地为第一人。从二地至四地为第二人。五地至六地为第三人。七地为第四人。八地至十地为第五人。复次由等声闻位地。应知菩萨十二地次第亦如此。如声闻性地。菩萨初位亦如此。如声闻修正定位加行。谓苦法忍等菩萨。第二位亦如此。如声闻已入正定位。菩萨第三位亦如此。如声闻已得不坏信。住圣所爱戒位。为灭上地惑。菩萨第四位亦如此。如声闻依戒学引摄依心学。菩萨第五位亦如此。如声闻已得依慧学位。菩萨第六第七第八位亦如此。如声闻不复思量境界。是无相三摩提加行。菩萨第九位亦如此。如声闻已成就无相定位。菩萨第十位亦如此。如声闻已出无相三摩提住解脱入位。菩萨第十一位亦如此。如声闻住具相阿罗汉位。菩萨第十二位亦如此。此十二人菩萨五位所摄。第一位摄第一第二第三三人。第二位摄第四第五第六三人。第三位摄第七第八两人。第四位摄第九一人。第五位摄第十第十一第十二三人。若约声闻五位。亦得摄十二人。不异菩萨位摄

论曰。复次云何七阿僧祇劫

释曰。欲显余部别执故言复次。七阿僧祇劫时与前三阿僧祇劫时。为等为有短长。此执等三阿僧祇劫。但有别义开为七数。第一大劫阿僧祇度愿行地。得行欢喜地。第二大劫阿僧祇从欢喜地。度依戒学地依心学地。得行烧然地。第三大劫阿僧祇。从烧燃地度依慧学地。得行远行地。又一大劫阿僧祇名无相不定行。度无相有功用地。又一大劫阿僧祇名无相定行。度无相无功用地。又一大劫阿僧祇名无相胜行。度无碍辩地。又一大劫阿僧祇名最胜住。度灌顶地。阿僧祇有二种。一谓阿僧祇劫。何以故。由此劫日夜半月月时行年双等时不可数故。名阿僧祇劫。二谓劫阿僧祇。何以故。于此劫中菩萨修行。若以劫为量。此劫又不可数。故名劫阿僧祇。由前阿僧祇劫中时不可数。由后阿僧祇劫又不可数。经若干大劫阿僧祇得无上菩提。今定三大劫阿僧祇得无上菩提。不过不减。若菩萨修行最上品正勤。能超无数小劫。或超无数大劫。唯不能超大劫阿僧祇。约除皮肉心三烦恼故。立三阿僧祇劫。第一劫阿僧祇菩萨心未明利。方便未成正勤犹劣。是故实经一大劫阿僧祇时。方度愿行地。此位功行与时相符。第二大劫阿僧祇。若以功行约时。应经九劫阿僧祇。由菩萨心用明利方便已成正勤又胜。经时虽少得功行多。功超八大劫阿僧祇。止经第二一大劫阿僧祇。第三大劫阿僧祇。若以功行约时。应经二十一大劫阿僧祇。由菩萨智慧方便正勤最胜。经时虽少功行弥多。功超二十大劫阿僧祇。止经第三一大劫阿僧祇

论曰。地前有三。地中有四。地前三者。一不定阿僧祇。二定阿僧祇。三授记阿僧祇

释曰。复有别部执七劫阿僧祇为行有浅深。境有真俗及第一义故。地前经三劫阿僧祇。缘此三境有三种行。一依第一境。有白法与黑法相杂。名少分波罗蜜。二依第二境。有非黑白法与白法相杂。名波罗蜜。三依第三境。有非黑白无杂法。名真波罗蜜。即约此三立三阿僧祇。一不定阿僧祇。以黑白相杂与凡夫不异故。二定阿僧祇。已得无流法与有流法相杂。已得无流法。定犹相杂故未可授记。三授记阿僧祇。但是无流法不杂余法。但无流法故定不杂余法。故可授记。故地前经三劫阿僧祇

论曰。地中有四者。一依实谛阿僧祇。二依舍阿僧祇。三依寂静阿僧祇。四依智慧阿僧祇

释曰。初地至三地名依实谛地初地发愿二地修十善法三地修习诸定并依境界故名依实谛地四地至六地名依舍地四地修道品五地观四谛。六地观十二缘生。并依道舍惑故名依舍地。七地八地名依寂静地。以七地无相有功用。八地无相无功用故。名依寂静地。九地十地名依智慧地。以九地自得解胜。十地令他得解胜故。名依智慧地。谛有三种。一誓谛二行谛三慧谛。誓谛者。从初发心立誓为利益他。行谛者。如所立誓修行与誓相应。如誓实行亦实。慧谛者。为成就此行及安立前誓。于方便中智慧与行誓相应。智慧为胜。此三皆实无倒不相违。故名为谛。菩萨如昔所立誓。今作众生利益事故依谛住。菩萨能舍六度障故依舍住。菩萨六度功德相应故依寂静住。菩萨由自行六度。善解利他方便故依智慧住。菩萨立誓不违求者之心。必皆施与。由立此誓不违誓故实能施与。随其所施悉生欢喜。故依谛行施。菩萨能舍财舍果。故依舍行施。菩萨于财物受者行施及减尽中。不生贪嗔无明怖畏。故依寂静行施。如应如时如实施与。于前三中此用最胜。故依智慧行施如昔所立誓。不违先所受戒。舍离恶戒一切恶行寂静。此中智慧为胜。故依谛等行戒。如昔所立誓。能忍能舍分别他过失嗔恚上心寂静。此中智慧为胜。故依谛等行忍。如昔所立誓。能作利益他事。能舍离忧弱心恶法寂静。此中智慧为胜。故依谛等行精进。如昔所立誓。能思修利益众生事。舍离五盖等心常寂静。此中智慧为胜。故依谛等行定。如昔所立誓。了达利益他方便。舍离偏非方便。无明焦热已得寂静。能证一切智。故依谛等行般若。随应知境及昔誓。应知是依谛义。舍离类欲惑欲。应知是依舍义。一切邪业永息。应知是依寂静义。随觉及通达。应知是依慧义。三谛所摄能违三失。是名依谛。三舍所摄能违三失。是名依舍。三寂静所摄能违三失。是名依寂静。三慧所摄能违三失。是名依智慧。依谛摄依舍寂静慧。随顺昔誓故。不相违故。依舍摄依谛寂静慧。能舍所对治故。是一切舍果故。依寂静摄依谛舍慧。惑及业焦热寂静故。依慧摄依谛舍寂静。智慧为先故。智慧所随故。是故六波罗蜜依谛所生。依舍所摄。依寂静所长。依智慧所净。何以故。依谛是彼生因。依舍是彼摄因。依寂静是彼长因。依慧是彼净因。初以谛为依。誓言真实故。中以舍为依。先已立誓。为他能舍自爱故。后以寂静为依。一切寂静为后故。初中后以慧为依。若此有彼有。若此无彼无故。四依与十地相摄云何。从初地至三地依谛为胜。何以故。此中菩萨但修治观真境。于道品等功行未成故。依谛摄三地。从四地至六地。依舍为胜。何以故。此中菩萨修治观真境。已成于真境无功用心。但为对治惑成就道品等。由修治道品观行。四谛观行。十二缘生观行。能舍一切惑故。依舍又摄二地。七地八地依寂静为胜。何以故。由菩萨道已成就。诸惑多灭多伏。不复能触心。此二地无相及无功用观行已成就。心地转细安住寂静故。依寂静又摄二地。九地十地依智慧为胜。一自解胜。二令他解胜。皆能自利利他。己度寂静位。多行利益他事。若离智慧行。无别利他方便。由此二地多行智慧故。依智慧又摄二地。为此义故。别部执有七阿僧祇

论曰。复次云何三十三阿僧祇

释曰。有诸大乘师。欲显行有下中上。欲显为得未得方便。欲显已得不失方便。欲显已得不失增上方便。欲显入住出三自在故。分阿僧祇为三十三

论曰。方便地中有三阿僧祇。一信行阿僧祇。二精进行阿僧祇。三趣向行阿僧祇

释曰。地有二种。一方便地。二正地。未入正地。于方便中有三阿僧祇。此中菩萨奉事诸佛。心发愿口立誓。信如来正说。及信如来修信根为胜。何以故。未证法明故。约修信根立一阿僧祇。名为信行。若菩萨已证法明信根转坚。决定知果必应可得。此中菩萨精进为胜。何以故。于得方便心已明了。不惜乐厌苦修精进故。约修精进又立一阿僧祇。名精进行。若菩萨精进成就心得清净。惑障已除。此中菩萨趣向为胜。何以故。于真如观。求得之心生起相续无背舍故。约此趣向。又立一阿僧祇。名趣向行

论曰。于十地中地地各三阿僧祇。谓入住出

释曰。为除皮烦恼障入初地。为除肉烦恼障住初地。为除心烦恼障出初地。何以故。地地菩萨烦恼有三品。上品名皮。中品名肉。下品名心。上品者下品道所破。中品者中品道所破。下品者上品道所破。乃至第十地其义亦尔。约此三品故各立三阿僧祇。是故异部执有三十三阿僧祇。此三十三阿僧祇。与前三阿僧祇亦等。无有短长义如前释。前已说有三种阿僧祇劫竟。菩萨经如此劫。修行得无上菩提。菩萨于无始生死中。恒行施等行。恒奉事出世诸佛。从何时修行为始。或说三阿僧祇。或说七阿僧祇。或说三十三阿僧祇。为显此义故

论曰。如此阿僧祇修行十地正行圆满。有善根愿力

释曰。菩萨有二种力。一善根力。二善愿力。善根力者。一切散乱所不能违。善愿力者。于一切时中。恒值佛菩萨为善知识

论曰。心坚进增上

释曰。由事善知识不舍菩提心。生生及现世恒增长善根。无复减失

论曰。三种阿僧祇。说正行成就

释曰。若具善根力善愿力。心坚增上四义。以此时为阿僧祇之始。诸师说不同故。有三种。经如此阿僧祇时。说修正行得成就

    摄大乘论释释依戒学胜相第六

论曰。如此已说入因果修差别。云何应知依戒学差别

释曰。前于入因果修差别中。已约诸地明修差别。未明菩萨依戒学与二乘有差别故。问云何应知

论曰。应知如于菩萨地正受菩萨戒品中说

释曰。地有二种。一十地经。二地持论。十地经于二地品中。广说正受菩萨戒法。地持论于尸罗波罗蜜品中。广说正受菩萨戒法应如此知

论曰。若略说由四种差别。应知菩萨戒有差别

释曰。若广释戒有十一种义。一名二名义三相四因五果六对治。七清净八不清净九得方便十立难十一救难。若不依此解名为略说。又若具明九品差别为广。若说四品差别为略

论曰。何者为四。一品类差别

释曰。一切菩萨戒。若以品类摄之。不出三种

论曰。二共不共学处差别

释曰。于性戒中名共学处。于制戒中名不共学处。此二中菩萨与二乘皆有差别

论曰。三广大差别

释曰。此戒与二乘一向不同

论曰。四甚深差别

释曰。如来不于二乘中说。亦非二乘所行

论曰。品类差别者有三种。一摄正护戒

释曰。谓比丘比丘尼。式叉摩尼沙弥沙弥尼。优婆塞优婆夷。此戒是在家出家二部七众所持戒

论曰。二摄善法戒

释曰。从受正护戒。后为得大菩提。菩萨生长一切善法。谓闻思修慧及身口意善。乃至十波罗蜜

论曰。三摄众生利益戒

释曰。略说有四种。谓随众生根性。安立众生于善道及三乘。复有四种。一拔济四恶道。二拔济不信及疑惑。三拔济憎背正教。四拔济愿乐下乘。云何此三与二乘有差别。二乘但有摄正护戒。无余二戒。何以故。二乘但求灭解脱障。不求灭一切智障。但求自度不求度他。不能成熟佛法及成熟众生。是故无摄善法戒及摄众生利益戒

论曰。此中摄正护戒。应知是二戒依止

释曰。若人不离恶。能生善及能利益众生。无有是处。故正护戒是余二戒依止

论曰。摄善法戒是得佛法生起依止。摄众生利益戒是成熟众生依止

释曰。摄善法戒先摄闻思修三慧。一切佛法皆从此生起。何以故。以一切佛法皆不舍智慧故。摄众生戒所谓四摄。初摄令成自眷属背恶向善。第二摄未发心令发心。第三摄已发心令成熟。第四摄已成熟令解脱。此三种戒以何法为因。三根为别因。二根为通因。三根为别因者。精进根为第一戒因。智根为第二戒因。定根为第三戒因。二根为通因者。信念二根通为三戒因。复次六法为因。一依善知识。二依正闻。三依正思。四依信根。五依厌恶生死。六依慈心。复次有四种因。一从他正受得。二从清净意得。三从厌怖对治得。四从不犯戒起。恭敬忆念得。复次有四种因。能令菩萨戒清净。一能离犯戒因。二依止破戒对治。谓念处等。三依止寂静。谓不依止胜生处。回向为一切众生得涅槃故。四由具根本十善。所成方便所随非觉观所损。忆念所摄回向佛果故。此三种戒以何法为体。不起恼害他意。生善身口意业为体。离取为类。此三种戒以何法为用。正护戒能令心安住。摄善法戒能成熟佛法。摄众生戒能成熟众生。一切菩萨正事不出此三用。由心得安住无有疲悔故。能成熟佛法。由成熟佛法故能成熟众生

论曰。共学处戒者。是菩萨远离性罪戒

释曰。杀生等名性罪。性罪必由烦恼起。染污心地后则作杀等业。又有制无制。若作此业皆悉成罪故。名性罪。又如来未出世。及出世后未制戒。若人犯此罪。于世间中王等如理治罚。外道等为离此罪。立出家法故名性罪。于性罪中。菩萨与二乘同离故名共学处

论曰。不共学处戒者。是菩萨远离制罪所立戒

释曰。谓立掘地拔草等制。菩萨远离与二乘不同。何以故

论曰。此戒中或声闻是处有罪。菩萨于中无罪。或菩萨是处有罪。声闻于中无罪

释曰。如来制戒有二种意。一为声闻自度故制戒。二为菩萨自度度他故制戒。声闻菩萨立意受戒亦复如是。故此二人持犯有异。如声闻若安居中行则犯戒。不行则不犯。菩萨见游行于众生有利益。不行则犯戒。行则不犯

论曰。菩萨有治身口意三品为戒。声闻但有治身口为戒

释曰。戒类不同。菩萨戒以三业善行为体。声闻戒以身口善行为体

论曰。是故菩萨有心地犯罪。声闻则无此事

释曰。菩萨若有七种觉观等。起菩萨心地罪。犯菩萨戒。声闻则不如此。菩萨戒通相云何

论曰。若略说所有身口意业事能生众生利益。无有过失。此业菩萨皆应受学修行

释曰。若有利益有过失不应行。譬如女人语菩萨言。汝取我。若汝不取我有是处。我应死。若我不死必当杀汝。菩萨若随其语彼则不死。又不起恶事。则有利益。但取女人则成过失故不应行。若无利益无过失亦不应行。如二乘不能利他亦无过失。有利益无过失。即是菩萨戒。应生闻慧为受。应生思慧为学。应生修慧为修行

论曰。如此应知共不共戒差别

释曰。如此菩萨与二乘于性戒中亦有差别。即心所持及非心所持。于制戒中。亦有差别。谓利他不利他故。菩萨与二乘戒有差别。菩萨与二乘戒复有差别。谓广大差别。此广大有何义复有几种

论曰。广大差别者。应知有四种。由四种广大故

释曰。广大有四义。一以最胜义。专为他不求报恩及生死果。又利益无穷。由此二义故名为胜。二长远义。三大劫阿僧祇修行故。三以圆满义。依真俗及利益他事三境。生福德智慧具足故。四以自在义。依大乘光等四种三摩提。为利益他能行种种方便故

论曰。一种种无量学处广大

释曰。菩萨学处有二义。一种种二无量。种种显多。无量显大。一切恶无不离。一切善无不修。一切众生无不度故。名种种。持此三戒。时节无际功用无余。故称无量

论曰。二能摄无量福德广大

释曰。六度四摄因果各有九品。是名无量福德。如地持论说。如此无量福德聚。悉是菩萨戒摄

论曰。三摄一切众生利益安乐意广大

释曰。善教众生令离恶处安立善处。是名利益意。此功德于未来所得果报。愿一切众生如意受用。是名安乐意。又大悲拔苦名利益意。大慈与乐名安乐意。又令得一切出世事名利益意。令得世间胜事名安乐意。又此广大以四摄为体。前二摄名安乐意。后二摄名利益意

论曰。四无上菩提依止广大

释曰。由菩萨戒有三品及九品。戒能摄如来三种胜德及九种胜德故。正护戒为如来断德因。摄善法戒为如来智德因。摄众生戒为如来恩德因。九品戒为如来九德因。此如前说。由果广大故因广大。果广大有三义。一从广大因生。谓三十三大劫阿僧祇。修行十度十地等为因。二所得广大。谓一切智一切种智所摄。如来恒伽沙数功德。三利益广大。谓利益凡夫及三乘。乃至穷生死后际。此四种广大戒。并是无上菩提依止。但菩萨能修。二乘悉无此事。故称差别

论曰。甚深差别者。若菩萨由如此方便胜智。行杀生等十事。无染浊过失生无量福德。速得无上菩提胜果

释曰。如菩萨能行如所堪行方便胜智。今显此二义。若菩萨能知如此事。有人必应作无间等恶业。菩萨了知其心。无别方便可令离此恶行。唯有断命为方便。能使不作此恶。又知此人舍命必生善道。若不舍命决行此业。堕剧难处长时受苦。菩萨知此事已作如是念。若我行此杀业必堕地狱。愿我为彼受此苦报。当令彼人于现在世受少轻苦。于未来世久受大乐。譬如良医治有病者。先加轻苦后除重疾。菩萨所行亦复如是。于菩萨道无非福德故。离染浊过失。因此生长无量福德故。能疾证无上菩提。如此方便最为甚深。行益等行亦复如是

论曰。复次有变化所作身口业。应知是菩萨甚深戒

释曰。前明实事非显通慧。此下明通慧不论实事。菩萨戒有三品。即身口意业。除意业以无变化故。身口二业有时变化所作。亦是菩萨戒。此身口戒或现为善。或现为恶。或生怖畏。或生欢喜。皆令众生远离恶处安立善处。此戒难思量故言甚深。非本身口所作云何成戒。以能成就戒事。令众生离恶生善故。又此变化从菩萨意业生。菩萨以意业为戒故

论曰。由此戒有时菩萨正居大王位。或现种种逼恼众生。为安立众生于戒律中

释曰。众生有二种。或宜欢喜教化。譬如拘物头花因凉月开敷。或宜逼恼教化。譬如莲花因烈日开敷。菩萨亦尔。如那罗王及善财童子。或现可爱事。或现可畏事。安立众生于善处

论曰。或现种种本生。由逼恼他及逼恼怨对。令他相爱利益安心

释曰。为化邪见众生不信因果。令得正信离恶修善故。化现种种本生。如毗荀陀王舍儿与婆罗门。是逼恼他。此儿是化作。何以故。菩萨无逼恼此人。生彼人安乐故。又如药藏菩萨。令眉絺罗王与毗提诃王。互相逼恼。此亦是化作。后悉令相爱利益安心。菩萨行如此事有何利益

论曰。生他信心为先。后于三乘圣道中。令彼善根成熟

释曰。先令于菩萨生信。后则能如菩萨教修行故。三乘善根皆得成熟

论曰。是名菩萨甚深戒差别

释曰。此实行及化身所行戒。非下地所能行。非二乘所能通达故。名甚深差别

论曰。由此四种差别。应知是略说菩萨受持戒差别

释曰。从他得名受自清净意得名持。又初得名受。受后乃至成佛名持。又修行戒法名受。忆念文句名持

论曰。复次由此四种差别。更有差别不可数量。菩萨戒差别。如毗那耶瞿沙毗佛略经中说

释曰。从此四种差别。更有差别不可数量。何以故。但于品类差别中。取正护一戒。依二乘教分别。则成四万二千。若以此戒及余二戒。依菩萨教分别不可数量。毗那耶瞿沙毗佛略经中广说菩萨戒有十万种差别

    摄大乘论释释依心学处胜相第七

论曰。如此已说依戒学差别。云何应知依心学差别

释曰。菩萨戒与二乘戒既有差别。戒为定依止。定依戒得成。菩萨定与二乘定亦应有差别。云何可知

论曰。略说由六种差别应知

释曰。若广说如大乘藏所立三摩跋提。体类差别有五百种。小乘清净道论所立三摩跋提。体类差别有六十七种。今略说止明六种差别。应知此义

论曰。何者为六。一境差别。二众类差别。三对治差别。四随用差别。五随引差别。六由事差别境差别者。由缘大乘法为境起故

释曰。所缘有三境。一缘一切真如境。二缘一切文言境。三缘一切众生利益事境。此三境名大乘法。但是菩萨定所缘。非二乘定境故言差别。复有十二种境如中边论说。一所成立境。谓十波罗蜜是真如十种功德所成立故。二能成立境。谓法界十种功德。能成立十波罗蜜故。三持境。谓闻慧所缘法门。闻慧能得阿含体。即说闻慧为持。四决定持境。谓思慧所缘如理如量境。思慧能简择阿含及道理。是熟慧故名决定持。五证持境。谓修慧所缘。修慧与道理一体故名证。能摄文及义故名为持。六通达境。谓初地所见真如。七相续境。谓二地以去所缘真如。已通达真如传流名相续。此相续所缘名相续境。八胜行境。谓无相无功用心所缘。即八地境。九生智境。谓九地所缘智自在依止真如。得四无碍解能生他智。又缘如来法藏能自生世出世智。十胜境。谓上上品智所缘。此智无复有上即十地境。此智以十力为体。无边智能名力。此智约十境说名十力。此十力能成就菩萨十地及如来九种正事。乃至无边化身。十一十二境。谓一切智一切种智所缘境。即如理如量境。此十二境通为奢摩他毗钵舍那所缘。一切定慧所缘不出此十二境

论曰。众类差别者

释曰。有四三摩提。是五百定品类故名众类。于小乘中乃至不闻其名。何况能修习。故言差别。此四种三摩提能破四德障。即四种生死。能得四德果。即净我乐常故。立此四定为四德道

论曰。大乘光三摩提

释曰。大乘有三义。一性二随三得。性即三无性。随即福德智慧行所摄。十地十波罗蜜随顺无性。得即所得四德果。此定缘此三为境。故名大乘。依止此定得无分别智。由无分别智照真如。及佛不异故名光。又有十五种光。功德胜于外光故名光。又此定能破一阐提习气无明闇。是闇对治故名光。此定缘真如实有易得。有无量功德故能破一阐提习气。即是方便生死障。于大净由破此障故得大净果

论曰。集福德王三摩提

释曰。一切善法唯除般若。所余悉名福德。此福德有四品。谓凡夫二乘菩萨。菩萨由此定故于四福德。未生能生未长能长。未圆能圆故名集。于生长圆三处自在故名王。由自在故能行施等十度。圆满菩提资粮福德行故。能破外道我见习气。即是因缘生死障于大我。由破此障故得大我果。复次一切善法依止真如。真如能集一切善法。名真如为集福德。此定于真如中得自在故名为王

论曰。贤护三摩提

释曰。贤有二义。一能现前安乐住。二能引摄诸功德。现前安乐住者。此定能令菩萨身不舍虚空性。免离三际故得安乐住。引摄诸功德者。能引摄不可数量诸定。非二乘所闻知。因此一一定起无量通慧。由此二义。是故菩萨能离声闻怖畏习气。即是有有生死障于大乐。由破此障故得大乐果。此定缘真如为菩萨体故。不离智能引诸定及通慧故。以定为体

论曰。首楞伽摩三摩提等

释曰。此定是十地菩萨及佛所行故得此名。何以故。十地菩萨及佛有四种胜德。故名首楞。一无怖畏。由得一切智故。二无疑。于清净众生见自身无等故。三坚实功德。恒在观无散乱故。四有胜能。能破难破无明住地障故。具四德人于此定能得能行。故称伽摩。此定多行他利益事。能破独觉自爱习气。即是无有生死障于大常。由破此障故得大常果。等言通举诸定

论曰。摄种种三摩提品类故

释曰。五百定名种种。皆是四定品类。悉为四定所摄

论曰。对治差别者。由缘一切法为通境智慧

释曰。无分别智缘一切有为无为等诸法真如。通为一境。此智与境无复分别

论曰。如以楔出楔方便故

释曰。如世间欲破木。先用细楔。后用粗楔。观行人破烦恼亦尔。先用劣道。次用中道。后用胜道

论曰。于本识中。拔出一切粗重障故

释曰。本识相续中。有烦恼业报三品染浊种子。说名习气能障四德。由此定故未灭令灭。已灭令不生。能对治所对治。及对治所得。与二乘悉不同。故言差别

论曰。随用差别者。于现世久安住三摩提乐中。如意能于胜处受生

释曰。菩萨种种方便。治心令熟。犹如金师炼金使真。已熟治心说名随用。何以故。由此定故。菩萨若欲成熟佛法缘一境。如意能得久住。未得令得。已得令满。已满令不退。于现在世有如此能。于未来世所受生处。能多行利益众生事。及值佛出世得闻正法。名胜生处。由此定故。菩萨于胜生处得取住舍三。能随意运用无退无尽。声闻乘中无如此定。故言差别

论曰。随引差别者。能引无碍通慧于一切世界

释曰。菩萨有大事定。谓于一切事及一切处。悉无有碍。引有二义。一能引。谓定势力。或随人或随境或随修。若利根人缘无为境。得入住出三种自在。二所引。谓定所成事。动地放光等于此事中胜通慧不能夺。所现事悉如心。惑不能障。业不能阻。故称无碍引。但有体无用。用即事差别。但菩萨有此定。非二乘所修。故言差别

论曰。由事差别者

释曰。由如此事。应知菩萨定与二乘定有差别。何者为事

论曰。令动

释曰。如意能动十方世界

论曰。放光

释曰。如意能照十方世界

论曰。遍满

释曰。光明法音分身。如意能遍满十方世界

论曰。显示

释曰。余众生承菩萨通慧。能见无量世界及诸佛菩萨。随所应见如意皆睹

论曰。转变

释曰。四大等性互令改异

论曰。往还

释曰。于一刹那中能往还无量世界。此通慧自有三种。一心疾通慧。如心所缘应念即至。二将身通慧。犹如飞鸟。三变异通慧。谓缩长为短

论曰。促远为近

释曰。使远成近无复中间。此有三事。谓见闻及行

论曰。转粗为细

释曰。令无数世界细于邻虚。入邻虚中邻虚如本

论曰。变细为粗

释曰。令一邻虚苞无数世界。世界如本

论曰。令一切色皆入身中

释曰。一切希有。有多种事。皆现身中

论曰。似彼同类入大集中

释曰。如诸菩萨往忉利天。同彼形饰及以音声。入大集中教化度彼

论曰。或显或隐

释曰。能于无中现一现多为显。能于有中无一。多相为隐

论曰。具八自在

释曰。八数如前说。又如佛世尊令魔王修行佛道。后得成佛等亦名自在

论曰。伏障他神力

释曰。由菩萨定力。令他通慧皆不成就

论曰。或施他辩才

释曰。若人欲问难辞情拙讷。菩萨能施其辩才

论曰。及忆念

释曰。若人邪见。令识宿命自验因果

论曰。喜乐

释曰。菩萨或入地狱。或生饥馑世。或在有疾处。如菩萨所受喜乐。令此众生平等皆尔。或但与乐。或先与定。或正闻法时。令由此喜乐经六十小劫。谓如刹那顷

论曰。或放光明

释曰。为引他方菩萨皆来集会

论曰。能引具相大通慧

释曰。如声闻圣通慧。能作百一事。菩萨通慧所现之事。不可称数。复欲显未说事故。先标此总句

论曰。能引一切难行正行

释曰。成就他事已如前说。此下更明菩萨自行。此定能引菩萨正行。非二乘所能行

论曰。以能摄十种难修正行故

释曰。此十种正行是定种类故。定能摄此正行

论曰。何者为十。一自受难修。自受菩提善愿故

释曰。若依他发十愿。此非难行。以未成立故。菩萨自有三能。一有智慧能了别方便。二有慈悲能摄众生。三有正勤能成满十愿。此三难得菩萨能得。由具此三能故。不依他自能发愿。又若为自身受善愿。此不为难。若无因缘但为他受。此则为难

论曰。二不可回难修。由生死众苦不令退转故

释曰。无始生死八苦。及发心后当受长时八苦。不能违菩萨慈悲。退菩萨菩提行。广说如地持论。是故难修

论曰。三不背难修。由众生作恶。一向对彼故

释曰。众生于生死中恒起恶行。菩萨不观过失。为令解脱恒向彼行善。是故难修

论曰。四现前难修。于有怨众生现前。为行一切利益事故

释曰。若众生对菩萨作极重恶。菩萨对彼以大恩德报之。是故难修

论曰。五无染难修。菩萨生于世间。不为世法之所染故

释曰。菩萨由爱故入生死。入生死已。不为世间八法之所染污。爱而不染。是故难修

论曰。六信乐难修。行于无底大乘。能信乐广大甚深义故

释曰。无底有三义。一教难思。二道难行。三果难得。威德圆满故。广大理微细故。甚深威德有三种。一如意。二清净。三无变异理。即三无性理。并非下地境界。是故难修

论曰。七通达难修。能通达人法二无我故

释曰。先于十解已通达人无我。今于初地又通达法无我。此二空离有无性。若能通达则与此法同。是故难修

论曰。八随觉难修。诸佛如来甚深不了义经。能如理判故

释曰。如来所说正法。不出了义及不了义。若众生但有信根。未有智根。如来为成其信根故。作不了义说。如二乘教。又欲伏憍慢众生故。作不了义说。广说如十七地论。为生闻思修慧故说了义经。不了义经其言秘密。能如理判。是故难修

论曰。九不离不染难修。不舍生死。不为生死染污故

释曰。由慈悲故不舍生死。由般若故不被染污。于生死涅槃无著无住。是故难修

论曰。十加行难修。诸佛如来于一切障解脱中住。不作功用。能行一切众生利益事。乃至穷生死后际

释曰。具显三身故言诸佛如来。一切障。谓三障四障三十障等。法身已得无垢清净。是故住于一切障解脱中。法身常住解脱中。穷生死后际。依法身起应身。于一切正事自然恒流。不作功用。依应身起化身。行一切众生利益事。随根性令下善种。乃至得解脱

论曰。乐修如此加行故

释曰。欲得为乐。起正勤为修。恒修恭敬修为加行。是故难修

论曰。于随觉难修。诸佛如来说不了义经。其义云何。菩萨应随理觉察

释曰。十难修中九义易解。故不重释。第八难解。菩萨应随觉察故。须更示其相

论曰。如经言。云何菩萨不损一物不施一人。若菩萨善能行施无量无数。于十方世界修布施行。相续生起

释曰。菩萨舍自爱。摄一切众生为自体。一切行道一切财物。悉属众生故。财非己有。用者非他。彼物彼用岂关于我。若能如此运心。则是善能行施。复次菩萨舍自爱。摄一切众生为自体。一切众生行施。即菩萨行施故菩萨起随喜心。得无量施福。亦是不损一物。不施一人。名善能行施

论曰。云何菩萨乐行布施。若菩萨不乐行一切施

释曰。若菩萨不乐行随至等八施。义至但乐行菩萨净心施。复次若菩萨不乐世间着三轮施。乐行不着三轮施。复次著名为乐。若菩萨着施因。或着施果。名乐行施。若菩萨不着行施。名不乐行施

论曰。云何菩萨行信施心。若菩萨不行诸佛如来信心

释曰。由菩萨自证施故行施。不由信他故行施。前信有根故成信。后信无根故不成信

论曰。云何菩萨发行布施。若菩萨于布施中不策自身

释曰。若菩萨自性能行施。无有贪吝嫉妒等障。非策自身方能行施

论曰。云何菩萨恒游戏布施。若菩萨无布施时

释曰。菩萨非时施。不随一物施

论曰。云何菩萨大能行施。若菩萨于施离娑罗想

释曰。娑罗名目二义。一目贞实。二目散乱。贞实是直语。散乱是密语。若取直语离贞实。则与大施相违。若取密语离散乱。则与大施相符。若离欲三界后行施时。名为大施。何以故。离欲菩萨行施。具缚凡夫行施。百千万倍所不能及。若施定互相妨不名大施。由不相妨故得大名

论曰。云何菩萨于施清净。若菩萨郁波提贪吝

释白。郁波提名目二义。一目生起。二目拔根弃背。生起是直语。拔根弃背是密语。若取直语生起贪吝。则与清净施相违。若取密语拔根弃贪背吝。则与清净施相符。拔根是除身见。身见是贪吝根本。弃背是除贪吝体。由菩萨能断身见灭贪吝故。于施清净

论曰。云何菩萨能住于施。若菩萨不住究竟后际

释曰。究竟后际有二义。一施有初中后。以最后为究竟后际。若依此义。不住施最后分。岂得言能住于施。此则相违。二若有余涅槃名究竟。无余涅槃名究竟后际。若声闻住无余涅槃不更起心。无利益众生事。则不能住施。菩萨依大悲不同声闻。住无余涅槃故。恒起六度无有穷尽。若依此义则与能住施相符

论曰。云何菩萨于施自在。若菩萨于施不得自在

释曰。若菩萨不得施障自在。菩萨于施则得自在。昔在凡夫地中。见修二惑无道对治。欲起便起故得自在。今入圣位为道对治故。菩萨于惑不得自在。于施能得自在

论曰。云何菩萨于施无尽。若菩萨不住无尽中

释曰。无余涅槃名为无尽。菩萨不同声闻入无尽中。无利益他事。是故菩萨于施无尽

论曰。如施经。于戒乃至般若。如理应知

释曰。如施经说施有不了义语。说余度亦有不了义语。皆须如理分判

论曰。复有经言。云何菩萨行杀生。若菩萨有命众生断其相续

释曰。若有命则知有业。若有业则知有惑。由具此三六道四生相续不断。若菩萨随其根性。为说三乘圣道。令彼修行断此三法。得无余涅槃果不相续。即是断命故名杀生

论曰。云何菩萨夺非他所与。若菩萨自夺非他所与众生

释曰。菩萨以大悲。摄一切众生为自眷属。令离生死崄难。非彼父母及人主等所与。故名夺非他所与

论曰。云何菩萨行邪淫。若菩萨于欲尘起邪意等

释曰。菩萨三业与淫欲相反。意知其虚妄不实为众恶本。口亦作如此说。身不行其事。亦是相反。即是于欲尘起邪意等。故名行邪淫

论曰。云何菩萨能说妄语。若菩萨是妄能说为妄

释曰。一切法皆是虚妄。菩萨如虚妄而说故。名能说妄语

论曰。云何菩萨行两舌。若菩萨恒住最极空寂处

释曰。两舌令彼此不和。菩萨思空说空。令自他不见此彼。何况和合。故名行两舌

论曰。云何菩萨能住波留师。若菩萨住所知彼岸

释曰。若依直语波留师。名目恶口。住恶口人不为他所亲近。菩萨住所知彼岸即三无性理。亦不为众生所亲近。以此理非凡夫二乘所行处故。故名能住恶口。又若依密语。波留师名目彼岸住。即以密语显于直语

论曰。云何菩萨能说不相应语。若菩萨能分破诸法随类解释

释曰。菩萨能分破诸法。谓根尘识皆无所有。此无所有非定是无。亦非定有。有无悉不可得故。名能说不相应语

论曰。云何菩萨行阿毗持诃娄。若菩萨数数令自身得无上诸定

释曰。若依直语。阿毗持诃娄名目贪欲。行贪欲者必爱乐外尘。菩萨恒乐令自身得最胜定。故名行贪欲。又若依密语。阿毗持诃娄名目数数得定。即以密语显于直语

论曰。云何菩萨起憎害心。若菩萨于自他心地能害诸惑

释曰。嗔恚以憎害为相。菩萨作意欲断自他一切烦恼故。名起憎害心

论曰。云何菩萨起邪见。若菩萨一切处遍行邪性。如理观察

释曰。大乘以有分别为邪性。分别性遍行于依他性。即是邪性。若离分别名人法空真性。小乘以身见为邪性。因此身见生诸惑故。若离身见。一切邪执皆不得起。得人空真性。菩萨能如理观察此邪性。见其是邪故名起邪见

论曰。复有经言佛法甚深

释曰。初明六度。次显十恶。此下明道及道果。故言甚深

论曰。何者甚深。此论中自广分别一切佛法。常住为性。由法身常住故

释曰。诸佛法身常住。一切佛法皆依法身以法身为上首故。法身常住为一切佛法性

论曰。一切佛法皆断为性。由一切障皆断尽故

释曰。一一佛法悉无惑障及智障故。障断尽为一切佛法性。现在烦恼灭为断。未来烦恼不生为尽。即是尽无生智

论曰。一切佛法生起为性。由化身恒生起故

释曰。由慈悲本愿生起化身。相续无尽故化身生起。为一切佛法性

论曰。一切佛法能得为性。能得共对治众生八万四千烦恼行故

释曰。一切佛法以无所得为性。此是正说。由三无性不可定说有无故。虽以无得为性。亦有能得义。若离佛法。不能得了别所对治惑。不能得安立能对治道故

论曰。一切佛法有欲为性。有欲众生爱摄令成自体故。一切佛法有嗔为性。一切佛法有痴为性。一切佛法凡夫法为性

释曰。此有二义。一菩萨摄一切有欲众生为自体。一切佛法皆依自体故。二大悲为爱爱即是欲。菩萨以大悲摄一切众生。依大悲生福德智慧行故。嗔痴及凡夫法亦尔

论曰。一切佛法无染着为性。成就真如。一切障不能染故

释曰。道后真如断一切障。尽是无垢清净故名成就。一切障所不能染。一切佛法以此真如为体性故

论曰。一切佛法不可染着。诸佛出现于世。非世法所能染故

释曰。前明真如境。此明真如智。诸佛菩萨以真如智为体。即是应身。此体是唯识真如所显。非根尘分别所起。非八种世法及世法所起。欲嗔等惑所能染着。何以故。是彼对治故。修得无分别智成就。名诸佛出现于世

论曰。是故说佛法甚深

释曰。此语结前意。示难思难行难得。具三义故甚深

论曰。为修行波罗蜜。为成熟众生。为清净佛土。为引摄一切佛法故。菩萨三摩提业差别应知

释曰。此论中明菩萨三摩提。不别说事差别。但通说业差别。诸菩萨修定有总有别。总有此四。别有五百。此四是诸定通业。何以故诸菩萨修得定已。依此定修行十度。依此定成熟众生。云何成熟众生。依此定起通慧。引令入正定位。又依此定力清净佛土。何以故。由心自在。如意能成金宝等净土故。又依此定得现在安乐住。能引摄成熟一切佛法故。此四事是一切定通差别业。应如此知

摄大乘论释卷第十一摄大乘论释卷第十二

        世亲菩萨释

        陈天竺三藏真谛译

    释依慧学差别胜相第八

论曰。如此已说依定学差别。云何应知依慧学差别

释曰。菩萨定与二乘定既有差别。定为慧依止。慧依定得成。菩萨慧与二乘慧亦应有差别。云何可知。以何法名依慧学。无分别智名依慧学。是无分别智差别。应知即是依慧学差别。此无分别智有三种。一加行无分别智谓寻思等智即是道因。二无分别智。即是道正体三无分别后智。即是出观智。谓道果。此三智悉是依慧学体。寻思智为依慧学者。观行人依当来无分别智故。修方便智。由求未来无分别智果故。现世方便得成。以是能依故名依慧学。又此方便智能引当来无分别智。无分别智起。必依此方便得成。以是所依故名依慧学。道正体为依慧学者。谓依内起智在观。离散动故名为内。此智依观起故名依慧学。又有自体为内。因已谢果未起。道体自相续。即说自体为内。依自体起故名依慧学。出观智为依慧学者。依无分别智成此智。名依慧学。何以故。入观时所缘境后得智。缘此生故。此三智中应成立何智。应但成立无分别智。若成立此智。即成立余智。若成立前智但因义显果义不显。自性等十九差别义亦不成。若成立后智。但果义显因亦不显。自性等十九差别义亦不成。何以故。此智以寻思智为因。此智是寻思智果。此智是后智因。后智是此智果。由此智成立。前后智亦得成立。是故但应成立此智。于成立中。先应说无分别智自性。自性即是体相

论曰。由无分别智自性依止。缘起境界相貌立救难。摄持伴类果报等流。出离究竟行善加行。无分别智后得智功德。无分别差别加行。无分别智及后得智。譬威德无功用作事甚深义故。应知依慧学差别。由依慧学差别。应知无分别智差别

释曰。谓由无分别智自性。应知依慧学差别。由依慧学差别。应知无分别智差别者。若是次第说十九义。悉须作此语。今为存略故。以一由无分别智标初。次列出十九义竟。后总云应知依慧学差别。由依慧学差别。应知无分别智差别。以十九义成立无分别智。此智即是慧学体。慧学差别即是此智差别。应作如此知。无分别智自性云何

论曰。无分别智自性。应知离五种相

释曰。若具离五相。则是无分别智。若不具离五相。则非无分别智

论曰。五相者。一离非思惟故。二离非觉观地故。三离灭想受定寂静故。四离色自性故。五于真实义离异分别故

释曰。此智若由离思惟故。名无分别智。熟眠放逸狂醉同离。思惟应得无分别智。若由过觉观地故。名无分别智。从二定以上已过觉观地。应得无分别智。若依此二义。凡夫应得无分别智。是处能离心及心法。应说名无分别智。谓想受灭定等。若人在此位中得无分别智。此则不成智。何以故。于灭定等位。无心及心法故。若言如色自性智自性亦如此。如色钝无知此智应钝无知。若于真实义。由已分别显现。是分别应成无分别智。何以故。此分别能分别真实义。谓此义真实

论曰。是五相所离智。此中应知是无分别智

释曰。若智离五相。缘真实义起。若不异分别真实义。谓此法真实但缘真实义。如眼识不以分别为性。是名无分别智相

论曰。于此中如所说。无分别智性中。故说偈言

释曰。于此依慧学中。如前说十九义所显无分别智性。更说偈成立此义。此偈欲何所显。欲显无分别智最胜。于所修众行中最为上首

论曰

  诸菩萨自性　　五种相所离
  无分别智性　　于真无分别

释曰。菩萨以无分别智为体。无分别智与菩萨不异。无分别智自性。即是菩萨自性。无分别智离五相。即是菩萨离五相。由于真无分别故。离五相得无分别名。众生是假名。法是实有。若离此智。无有别法应菩萨名。尽无生智是菩提。此众生以菩提为体。菩提即是无分别智。无分别智即是菩萨。欲示无分别智即是菩萨故。说菩萨自性离五相。不言无分别智后得例尔。如此说菩萨自性已。由此依止是性得生。今当说此依止。前说此智名无分别。此智为依止心生。为不依止心生。若依止心生。能思故名心。思即是分别。此智若依分别生。非谓无分别。若不依止心生。则同色等法。复不应名智。欲显离此二失故重说偈

论曰

  诸菩萨依止　　非心非非心
  是无分别智　　非思疾类故

释曰。此智不以心为依止。由此智不思议故。亦不以非心为依止。由以心疾利类相续为依止故。疾利类是心种性。既以此为依止故。不可说非心为依止。为显因缘生起此智故重说偈

论曰

  诸菩萨因缘　　有言闻熏习
  是无分别智　　如理正思惟

释曰。四缘中除三缘。但取因缘。因缘有何相。若因与果同类名因缘。譬如先善心为后善心作因。依从他所闻法音。起闻熏习因。此熏习后生正思惟。是正思惟从闻他正说起。故称有言。此智因缘。即以有言闻熏习及正思惟为体。由此因缘。无分别智因有言。未生令生已生令坚住。若无此熏习。无分别智不得生。是故说此为因缘。此智因闻熏习起。缘何法为境

论曰

  诸菩萨境界　　不可言法性
  是无分别智　　二无我真如

释曰。前偈说菩萨因缘。此偈说菩萨缘缘。境界即是缘缘。缘缘有何相。若法缘此生。犹如羸人因杖得起。若观此法彼法得生故。此为彼缘。如五尘生五识。此境有二义。一依止缘缘。二比度缘缘。如人依止心无常相。比度色等余法皆是无常。不可言法性是菩萨缘缘。一切法由分别性不可言说。何以故。诸法由自体无所有。由心分别显现故。一切法不可说有。亦不可说无。如此显现不如此有。是故不可说有。如此不有不无。显现故不可说无。如识所缘法不如此有故是故分别无体相。是分别无体相。为当有为当无。若无无体体则还有。若有无体不可言无。由此义故。法性约真俗皆不可言有无。法性以二无我真如为体。由分别性故。依他性无人无法。名二无我。为离断见此无我不无。故说名真如。此真如是菩萨境。何以故。是无分别智若起。必缘此境起故。此智缘不可言真如起。其取境相貌云何

论曰

  诸菩萨相貌　　于真如境中
  是无分别智　　无相无差别

释曰。是智于真如境中。平等平等生。无异无相为相。即是其相。譬如眼识取色。如青等相显现。不异青等色。此智与真如境亦尔。又不同眼识与色。色无体有色。眼识有体无色。此智与真如境相称。不可说异若一切法不可言说为性。何法是所分别

论曰

  相应自性义　　所分别非他

释曰。一切言说有三种相应。谓数习相续次第。此三不相离故名相应。又三法和合能目义故名相应。此相应是自性义。此义即是所分别。若离此义无别余义。是故一切法不可言说。云何知离此性无别余义。为成立此义故

论曰

  字字相续故　　由相应义成

释曰。字字相续即第一相应。由此相应即余二相应具。此三相应故得目义。由相应说此义得成。譬如眼根等。于言辞相续说中。众生执以为义故说名相应。此义是所分别。是故所分别但有言说。义亦但有言说。若一切法不可言说。此义云何成

论曰

  离言说智慧　　于所知不起

释曰。若人未了别方言。于所言境智慧不生。若汝言于言说中所言智生。此义不然。何以故

论曰

  于言不同故　　一切不可言

释曰。是言说与所言不同。以相貌异故。言相异所言相异。是故一切言及所言同不可言。何法是无分别智所摄持

论曰

  诸菩萨摄持　　是无分别智
  此后得行持　　为生长究竟

释曰。是无分别智后所得智。能得菩萨福慧二行。二行依止。此智得生长相续乃至究竟故。无分别后智能生长菩萨正行。无分别后智是能摄持。菩萨是所摄持。何法是无分别智伴类

论曰

  诸菩萨伴类　　说是二种道
  是无分别智　　五度之品类

释曰。伴类以相助为相。相助共成一事故名相助。一事是菩提果。二种道是菩萨伴类。谓资粮道及依止道。施等四波罗蜜是资粮道。定波罗蜜是依止道。何以故。从四波罗蜜所生善法。此善法生般若波罗蜜。此般若波罗蜜依止定生。般若波罗蜜即是无分别智。未得无上菩提。于其中间常能生起无分别智。乃至极果。离则有五度。合则成二道。能助第六度。共成一极果故。说为伴类。若无分别智依二道成。得何果报

论曰

  诸菩萨果报　　于佛二圆聚
  是无分别智　　由加行至得

释曰。有但果非报。有是果是报。若从因生共用者名果。若从因生独用者名果报。果是生义。报是熟义。化应二身名佛二圆聚。无分别智果报成熟。在佛二圆聚中。若果在无分别智加行中生。此果属化身。若果在无分别智至得中生。此果属应身。云何知耶

论曰

  由加行至得

释曰。前说无分别有三种。一加行。二正体。三后得。加行无分别自有二种。一在地前。二在登地以上。若依此二处加行。所得果是化身。正体无分别。从初地乃至佛果。皆名至得。若依正体无分别所得果报是应身。果报果若尔此等流果云何

论曰

  菩萨等流果　　于后后生中
  是无分别智　　由展转增胜

释曰。果或等因或胜因。此果以同类为因。是名等流果。无分别智等流果。于二圆聚中。转初地为二地。乃至转十地成佛。于后后位中转增转胜。如初地为二地同类因。二地是初地等流果。诸地悉尔。于利他为增。于自利为胜。又学位为增。无学位为胜。无分别智出离得成就义云何

论曰

  诸菩萨出离　　得成相应故
  是无分别智　　应知于十地

释曰。灭惑业为出。灭果报为离。即是有余无余二种涅槃。出是离义。离是出义。何故重说。由离有三义故作重名。一永离。二上离。三决离。无分别智于出离中与二义相应。一与得相应。二与成就相应。此二相应应知不出十地。初地始得无分别智。名得相应。从初地后乃至十地。于无数劫修无分别智。乃至究竟。名成就相应。此无分别智藉二道。于三阿僧祇劫修学。以何法为究竟

论曰

  诸菩萨究竟　　由得净三身
  是无分别智　　至胜自在故

释曰。究竟有二种。一清净究竟。二自在究竟。清净究竟者。初地始得清净。后于地地中转转清净。至十地究竟清净。譬如练金。由此清净。菩萨所得三身后后转清净。自在究竟者。不但得三种清净身究竟。复有别究竟。谓十自在如论后说。此十自在后后转胜。此二种法最后极胜。是无分别智所得究竟。名增上果。无分别智功德云何。无分别有三种。一加行无分别。二根本无分别。三后得无分别。云何加行得无分别名。先从他闻无分别智是真菩萨。菩萨自未证真道理。但于此智起信乐心。由依止此信乐心。后方得入度此无分别智理。无分别智从此信乐生起故。说此信乐为加行无分别。此加行无分别功德谓无染。其譬云何

论曰

  不染如虚空　　此无分别智
  种种重恶业　　由唯信乐故

释曰。此无分别智清净无染。譬如虚空不为四尘所染。何法不能染。谓种种重恶业从身口意生。有见修道异。有十恶差别故名种种。极重烦恼为缘起恒作。若作无悔心无对治。有伴类故名重。因此恶业不能染污。若人从闻正说。于无分别智生信乐。由此信乐破坏四恶道业。何以故。恶业依非理起。信乐从是理生。依非理起故虚。从是理生故实。虚不能对实。是故破坏。此偈显加行无分别智。能对治四恶道业。由与恶业不相杂故。此即加行功德。根本无分别智功德。及清净云何

论曰

  清净如虚空　　此无分别智
  解脱一切障　　由得及成就

释曰。如虚空离烟云等四障。世间说为清净。无分别智清净亦尔。离何法故得清净

论曰

  解脱一切障

释曰。一切障谓皮肉心三障。或一阐提外道声闻独觉四德障。由解脱如此障故清净。此解脱何因得成

论曰

  由得及成就

释曰。由与诸地至德相应。由于第十地中因成就。由于佛地中果成就。故得解脱一切障。此偈显根本无分别智。能对治一切障。此即根本功德。无分别后得智功德。及无染云何

论曰

  如虚空无染　　是无分别智
  若出现于世　　非世法所染

释曰。虚空水不能湿。火不能然。风不能动。无分别智无染亦尔。无变异故说无染。何以故。菩萨依此智。观一切众生利益事。由此智力。菩萨故作心入三界。现种种本生。虽生在世中。不为世间八法之所变异。八法谓得不得。好名恶名赞毁乐苦。因此八法故起欲嗔。欲嗔不能变异。欲嗔根本无明不能令动。何以故。虚妄不能对真实故。此智从无分别智生故名无分别。此偈为显后得智能免报障。于生死涅槃二处不住。但为利他。此即后得智功德。此三种无分别差别云何。为显此差别令不相滥。是故立譬

论曰

  如哑求受尘　　如哑正受尘
  如非哑受尘　　三智譬如此

释曰。譬如哑人求觅诸尘不能说尘。加行无分别亦尔。在方便道中寻思真如。而不能说。譬如哑人正受诸尘。虽已得尘不能说尘。根本无分别亦尔。正在真如观。如所证见亦不能说。譬如非哑人正受诸尘。又能说尘后得智亦尔。如其所见能立正教。为他解说。初未得向得离分别。无说因缘故不能说。次正得离分别。无说因缘故不能说。后已得由出观故。如前所见能说无倒。此偈显三种无言说有言说异故有差别

论曰

  如愚求受尘　　如愚正受尘
  如非愚受尘　　三智譬如此

释曰。未识物类。名之为愚。愚譬次第譬。三义如前。释此偈。显无分别有分别异故有差别。无言说以无分别为因。由无分别故无言说。有言说以有分别为因。由有分别故有言说。愚譬即显无分别。此三智境。虚实云何

论曰

  如五求受尘　　如五正受尘
  如非五受尘　　三智譬如此

释曰。五名目无分别。眼等五识。譬如人在五识中求觅五尘。或缘实或缘虚。意识与五识相间起故。加行无分别智亦尔。或证一分为实。或不证为虚。譬如人正在五识中。得真实境无分别无言说。根本无分别智亦尔。得真实境无分别无言说。譬如人在意识中。但缘先所受尘名缘虚境。有分别有言说。无分别后智亦尔。缘虚境有分别有言说。此偈显三种所缘境有实有虚故有差别

论曰

  如未识求解　　如读正受法
  如解受法义　　次第譬三智

释曰。譬如人未识论文。但求识文字。加行无分别智亦尔。未识真如。但学见真如方便。此显未解。譬如人已识文字。未了文字义。正读文字。但能受法。未能受义。根本无分别智亦尔。自利功用已成。未有利他功用。此显已解。譬如人已识文字。又已了义。正在思中。是人具有二能。能识文字。又能了义。以功用究竟故。无分别后智亦尔。已通达真如。又已出观。如前所见解说无倒。此显解已究竟。此偈显学功有异故有差别。前已明三种次第。谓未解己解及解究竟。前一无境。后二有境。谓法及义。后二有境。异相云何

论曰

  如人正闭目　　无分别亦尔
  如人正开目　　后得智亦尔

释曰。此偈但显根本智及后得智。由依止不同故有差别。根本智依止非心非非心。后得智则依止心故。二智于境有异。根本智不取境。以境智无异故。后得智取境。以境智有异故。根本智不缘境。如闭目。后得智缘境。如开目。此偈显不取境取境有异故有差别。此二智威德差别云何

论曰

  如空无分别　　无染碍异边
  如空中色现　　后得智亦尔

释曰。譬如虚空有四种德。一无染。二无碍。三无分别。四无边。根本智亦尔。一切世间八法七流等所不能染。由是彼对治故。故说无染。于一切境。如理如量无障无著故说无碍。于一切法。一味真如空遍满故。故说无分别。离一切诸边。中道不可量故。故说无边。譬如色于空中显现。空不可分别。色可分别。后得智亦尔。因不可分别。此智可分别。谓此是能分别。亦是所分别。若佛果是无分别智所显离分别众生。云何得作众生利益事。如理不倒。为显无功用作事。故重说偈

论曰

  譬摩尼天鼓　　无思成自事
  如此不分别　　种种佛事成

释曰。譬如如意宝无有分别。能作如众生所愿求事。譬如天鼓无人扣击。能随彼众生所欲之意。出四种声。谓怨来怨去受欲生厌。诸佛亦尔。已离分别。能起种种利益众生事利益事有二种。一化身利益。如如意宝。二说法利益。犹如天鼓。此无分别智甚深义云何。约境立甚深义。此智为当缘所分别依他性起。为当缘余境起。若尔何妨。若取所分别依他性为境。此智无分别义不成。若缘余境起。离此境则无别余境。缘余境义亦不成。复次若缘余境起。境智无差别义则不成

论曰

  非此非非此　　非智非非智
  与境无差别　　智名无分别

释曰。此智不缘依他性为境。何以故。此智不以分别为境故。故言非此。亦不缘余境。何以故。此智但缘依他性法如为境故。法及法如不可说一异。非清净清净境故。为通相不通相故。非不缘识故。言非非此。复次此智为当是智。为当非智。若尔何妨。若智为性。云何不分别。以智是分别性故。若非智为性。云何称智。无分别非智性故。云何说为无分别智

论曰

  非智非非智

释曰。云何说非智。于加行及后得智中不生故。言非智。若尔云何不成非智惑。此义亦不成。何以故。非智惑从不正思惟生。能起欲等流。此从无分别加行智生。能生无分别后得智。故说非非智。复次由此智于分别中不生故。说非智。由此智不于余处生。但于分别法如中生故。说非非智。此偈前句即释后句

论曰

  与境无差别　　智名无分别

释曰。若智由能取所取二相起有分别。如加行智不名无分别。若智与所取不异。平等平等起。是名无分别智。于余经中。佛说一切法自性无分别。欲显此道理故重说偈

论曰

  佛说一切法　　自性无分别
  所分别无故　　彼无无分别

释曰。一切法自性无分别。此义云何可知。为证此义故立第三句。由可分别类实不有义。至无分别法真实是有故。说一切法自性无分别。若由所分别不有故。一切法自性无分别者。云何众生不自性解脱

论曰

  彼无无分别

释曰。由诸法自性无分别。智如境无分别。若尔何故不自性解脱。实尔诸法自性无分别。智如境亦自性无分别。而不得自性解脱。修得智能证此法。由非智障故智不得起。必须修智灭障。方得解脱故。无自性解脱义。于自性无分别中。若起分别。此为非智。即是无明。于自性无分别法中。所有无分别智。今当说其差别

论曰。此中无分别有三种。一加行无分别智。二无分别智。三无分别后智

释曰。于自性无分别中。若总说有此三种。此三种即显道方便道正事道究竟。谓入方便住方便出方便。若约因约人约事。别说则有十一种

论曰。加行无分别有三种。谓因缘引通数习力。生起差别故

释曰。此三约因有差别。加行无分别由三力成。或由因缘力。或由引通力。或由数习力。由此三力成故生起有差别。若由因缘力成。即是由性力成。若由引通力成。即是由宿生力成。若由数习力成。即于现在由作功力成

论曰。无分别智亦有三种。谓知足无颠倒无戏论。无分别差别故

释曰。此三约人有差别。即凡夫二乘菩萨。知足无分别。应知由得闻思二慧究竟故。由知足故无分别。故说知足无分别。若凡夫菩萨。至闻思慧究竟事。有所应得皆悉已得。生知足心故无分别。复次世间众生有知足无分别。由此知足。彼众生上生有顶。于中计为出离究竟。过此更无行处。起知足心。不复进修故无分别。无颠倒无分别。谓二乘。由彼已通达真境。无常等四种无倒相。由常等四无倒相。永不更分别故无分别。无戏论无分别。谓诸菩萨。诸菩萨不分别一切法。乃至不分别无上菩提。何以故。诸法无言说故。于无言说中强立言说。故名戏论。言说有四种。即是四谤。若说有。即增益谤。若说无。即损减谤。若说亦有亦无。即相违谤。若说非有非无。即戏论谤。菩萨得无分别智。不可以言说显示故。称无戏论无分别。何以故。出过世间智故。又非世间智所知故

论曰。无分别后智有五种。谓通达忆持成立相杂如意。显示差别故

释曰。此五约事有差别。后得智以能显示为性。此中显示以觉了为义。由此智于通达后时。显示如此事。云我于观中知见如此如此事。故称通达显示。由此智出观后时。如所通达忆持不退失。故称忆持显示。由此智如自所通达。能立正教令他修行。故称成立显示。由此智菩萨如先缘一切法为境。谓如先杂境界智观察此境。由此观察即得转依故。称相杂显示。由此智菩萨已得转依。如菩萨所思欲。如意皆成。谓于地等诸大。转为金等故。称如意显示

论曰。为成立无分别智。复说别偈

释曰。已说无分别智差别义。更欲成立无分别义。故重说偈

论曰

  饿鬼畜生人　　诸天等如应
  一境心异故　　许彼境界成

释曰。譬如一江约四众生分别则成四境。饿鬼谓为脓血。鱼等畜生谓为住处人谓为水。天谓是地。随所分别各成一境。若境是实应互相妨。不应一处一时并成四境。当知皆是意识分别所作。若汝许四识并缘。识不离境。汝亦应许一时一处并有四境。若许并有四境。则应信一切分别皆非实有。若无实境识应自生不缘境起。若尔唯识中。四难还成。四义不成。此难如彼论释。有识无境。斯有何失。为显此义。故重说偈

论曰

  于过去未来　　于梦二影中
  智缘非有境　　此无转为境

释曰。过去未来事但有名无体。若心缘此二世。但有识无境。梦中所缘亦尔。影有二种。一镜中影。二定中影。定心所起青黄等相。离心无别此法故说名影。若心缘此二影。亦但有识无境。若无此四境。识何所缘

论曰

  此无转为境

释曰。外尘本来是无。识变异所作。识即缘此为境故。言无转为境。此义已立不应复疑。何以故。若拨无此理。无成佛义为显此义。故重说偈

论曰

  若尘成为境　　无无分别智

释曰。若尘有体为境义成。则无有无分别智。何以故。所分别境若实有。能分别则不成倒。无分别则成倒。若尔一切凡夫皆离颠倒。一切圣人皆成颠倒斯有何失

论曰

  若此无佛果　　应得无是处

释曰。无分别智是正道。若言无此智。而说应得佛果。无有是处。此执为阿含及道理所违。是故应知诸尘无体可分别。由可分别体无故。分别亦无。故无分别智如理无倒。复次有别道理。证诸尘无体可分别

论曰

  得自在菩萨　　由愿乐力故
  如意地等成　　得定人亦尔

释曰。菩萨于定得入住出自在。于通慧得变异折伏通达自在。于诸地得十自在。菩萨先发愿作众生利益事。得无分别智后出观。随菩萨意。欲有所作。一切皆成。或由现在愿。或由本愿。愿为因。乐为果。先发愿作众生利益事。后随心所欲乐无不皆成。谓转变地等。若浅行菩萨欲作众生利益事。于现在先发愿。发愿竟即入真观。出观后随所欲乐方得成遂。若深行菩萨欲作众生利益事。现在不须发愿。及入观出观。但由本愿力。随所欲作。一切皆成。若声闻等得九定自在。因此定自在得六通自在。于一物中随愿乐力。各能变异为无量种。若诸尘实有自性。此事则不得成。譬如二空一切自在所不能变异。何以故。以真实故。此偈约外境显诸尘无自性。于内境无自性。其义云何

论曰

  成就简择人　　有智得定人
  于内思诸法　　如义显现故

释曰。简择即是毗婆舍那。得三无流根名成就。从须陀洹向乃至阿罗汉果。名成就简择人。有智人谓菩萨。欲显不以闻思位为智人。但取入修位为智人。故言得定。声闻及菩萨于内思量一切法时。如如二人思惟十二部经法。所显义如此如此。其义于此二人得显现。若其思惟佛义。于种种法中佛义显现。如佛义显现。色等五阴及无常等十想。亦如此显现。此偈约内境。显诸尘无自性。云何知外内境皆无自性

论曰

  无分别修时　　诸义不显现
  应知无有尘　　由此故无识

释曰。若菩萨在无分别观中。一切义或内或外或内外不复显现。是故应知诸尘皆实非有。若无外尘则无内识。何以故。所识既不有。能识云何有。此义实尔。所识非有故能识亦非有。应知胜相中已具显此义。此智与般若波罗蜜。为一为异

论曰。此无分别智即是般若波罗蜜。名异义同

释曰。不以名不同为异。以义同为一。以一故言即是。若名异义云何同。如来立法约自性义。摄诸法为同。不以名摄为同。何以故。名于诸方不同。义于诸方则同。名是假立。为目此义故。随方不同。义有定性故义是同。行依义成。不依名成。云何知义是同

论曰。如经言。若菩萨住般若波罗蜜。由非处修行。能圆满修习所余波罗蜜

释曰。欲成就无分别智。与般若波罗蜜不异故。引般若波罗蜜经为证。菩萨修般若波罗蜜。无退失故名住。又菩萨欲修余波罗蜜。先修般若波罗蜜为方便。余波罗蜜住般若波罗蜜中成。故言住。菩萨住般若波罗蜜中。离五处修行余波罗蜜。于一一波罗蜜中经若干时修习。令得成就故称圆满

论曰。何者非处修行能圆满修习所余波罗蜜。谓离五种处。一离外道我执处

释曰。如外道住彼般若起我执。谓我今住般若。般若即是我所。诸菩萨住般若则不如是。故言离我见执处。以不应彼处故

论曰。二离未见真如菩萨分别处

释曰。如地前菩萨未见真如。分别无分别为般若波罗蜜。谓此是般若波罗蜜。若菩萨已见真如。在般若波罗蜜中。则无此分别。故言离分别处。以不应彼处故

论曰。三离生死涅槃二边处

释曰。如凡夫众生住生死边。声闻人住涅槃边。菩萨住般若波罗蜜离此二边。故言离二边处。以不应彼处故

论曰。四离唯灭惑障知足行处

释曰。如声闻于惑障灭处生知足。于余处无复欲乐。谓智障灭处。菩萨则不如是。为灭智障修学般若波罗蜜故。言离知足行处。不应彼处故

论曰。五离不观利益众生事。住无余涅槃处

释曰。如独觉不观众生利益事。住无余涅槃。菩萨则不如是。住般若波罗蜜。不舍众生利益事。般涅槃亦有余亦无余。于法身是无余。于应化身是有余故。言离住无余涅槃处。以不应彼处故。无分别智有五种差别。异前所离五处。一无倒差别。此无倒彼有倒故。二无分别差别。此无分别彼有分别故。三无住处差别。此无住处彼有住处故。四正行差别。此正行能灭惑智二障。彼正行但能灭惑障故。五至得差别。此得常住三身为果。彼得永断涅槃为果故

论曰。声闻智慧与菩萨智慧。差别云何

释曰。已说无分别智与般若波罗蜜是一。今欲更显无分别智般若波罗蜜与二乘智有差别

论曰。应知由无分别差别

释曰。声闻有分别。菩萨无分别。应知由此义故有差别

论曰。不分别阴等诸法门故

释曰。声闻由智慧取阴等诸法门为境。有分别相起。菩萨不分别阴等诸法门。无分别相起故有差别

论曰。由非一分差别。通达二空真如。入一切所知相故。依止一切众生利益事故

释曰。分有二种。一所知分。二利益众生分。所知分中复有二种。谓人法二空。利益众生分中亦有二种。谓自身他身。声闻于所知分中。但通达人空。止于苦等四谛生无流智。于利益众生分中。但依止自身利益事。发愿修行。于此二分中各有一分。菩萨于所知分中。具通达人法二空。于一切所生如理如量智。于利益众生分中。依一切众生利益事。谓自他身发愿修行。于此二分中各具二分。二分异一分故。言非一分差别

论曰。由无住差别。住无住处涅槃故

释曰。声闻住着涅槃。如凡夫住着生死菩萨不尔。见生死涅槃俱是分别所作。同无相性故不住二处

论曰。由恒差别。于无余涅槃不堕断尽边际故

释曰。二人于无余涅槃有差别故。智慧有差别。二乘于无余涅槃无应化二身。以不观他利益事故。无应身故堕断。无化身故堕尽。菩萨于无余涅槃恒起二身。无有边际。何况法身。以自利利他圆满故。有应身故不堕断。有化身故不堕尽

论曰。由无上差别。实无异乘胜此故

释曰。声闻独觉乘有上。以不及大乘故。菩萨乘无上。以无别乘胜大乘故。乘以智为体。于大乘中智为上首故。由此五义故。二乘智与菩萨智有差别

论曰。此中说偈

释曰。为摄前五义及显五义功德故。重说偈

论曰

  由智五胜异　　依大悲修福

释曰。诸菩萨智慧。由五种差别故胜二乘。不但于胜智慧知足。复依智慧修福德。福德即余五度。此句显自利胜异二乘。复有胜异义。谓为利他依大悲修福德。福德即余五度。若人具此二能。得何果报

论曰

  世出世富乐　　说此不为远

释曰。作转轮王欲界上五天王色界梵王。乃至无色界定。及菩萨独所得世间定。名世富乐。二乘解脱及无上菩提。名出世富乐。如此果如意易得故不为远。诸菩萨已至极自在位。恒行慈悲于世间贫苦众生。菩萨由此意不施财物。此意用云何

论曰。若菩萨于世间实有亦复可知

释曰。此显菩萨有体有恩。有体故言实有。有恩故言可知

论曰。若菩萨如此依戒定慧学功德聚相应。至十种自在。于一切利他事。得无等胜能

释曰。三学摄十度及世间一切功德。故名功德聚。若菩萨未得得。已得不失。名相应。即因圆满。至十种自在即果圆满。利益他事或有二种。或有四种。二种谓先思后行。复有二种。即后二无畏。或有四种如前说。得如此无等胜能。即恩德圆满。此三德中。因果二德显自利。恩德显利他。已说三学竟。欲显菩萨三德圆满。故明此义

论曰。云何于世间中见有众生遭重苦难

释曰。此次立难。若菩萨如此三德。皆为拔济一切众生。云何众生遭世苦难。若视苦不救则无胜能。若无胜能亦无菩萨。苦难有二种。谓内及外。内外此二苦难有轻有重。若可对治为轻。若不可对治为重

论曰。由菩萨见彼众生有业。能感苦报障胜乐果故

释曰。菩萨见有众生有业障。障菩萨胜能能感苦报。菩萨于彼有此业智。虽怀胜能舍而不用。此即菩萨业力。譬如有江有八功德水。随众生饮无人遮护。饿鬼由业障故不能得饮。菩萨如江。财物如水。有业障众生犹如饿鬼。由业障故不得受用菩萨财物

论曰。由菩萨见如此。若施彼乐具。则障其生善

释曰。菩萨见有众生无业障。若贫穷能生长善法。若富乐则放逸造罪。菩萨愿彼于现在世受贫穷苦。随顺成就生起善法。是故菩萨不施其乐具。此即菩萨处非处力

论曰。由菩萨见彼无乐具。能现前厌恶生死

释曰。菩萨见有众生由贫穷苦。厌恶生死心恒现前。菩萨愿彼无乐具。成就厌恶心随顺善行故。不施其乐具。此即菩萨根欲性力

论曰。由菩萨见若施彼乐具。则是生长一切恶法因缘

释曰。菩萨见有众生乃至恒受贫穷报。于此时中不长恶法。菩萨愿彼恒受贫穷报。不愿彼于一刹那中受富乐报。而作诸恶法因缘。谓自爱憎他。此二因缘能生长恶法。菩萨若施彼财物。则成就彼爱憎。是故菩萨不施其乐具。此即菩萨遍行道智力

论曰。由菩萨见若施彼乐具。则是逼害余无量众生因缘

释曰。菩萨见有众生。若得大富非止自损。复能损恼无量众生。菩萨愿彼受贫穷苦。不愿彼由大富乐。损恼众生身心及以善根。是故菩萨不施其乐具。此亦是菩萨遍行道智力

论曰。是故菩萨不无如此胜能。世间亦有如此众生显现

释曰。胜能有三。即是三德。一能得因。谓三学处。二能得果。谓十自在。三能利他。谓了别众生根欲性等。若见施有利益则施。若见不施有利益则不施。菩萨以利益为定。不以施不施为定。由施无利益故。世间有受苦众生

论曰。此中说偈

释曰。为摄前五义故重说偈

论曰

  见业障碍善　　厌现及恶增
  害他彼众生　　不感菩萨施

释曰。有众生有业障。不感菩萨施。有众生有乐具则碍善。有众生由贫穷厌恶生死心恒现前。有众生有乐具生长恶法。有众生由大富乐能逼害他。菩萨见如此事。欲令离自损损他故。不施其乐具。是故彼众生不感菩萨施

摄大乘论释卷第十二摄大乘论释卷第十三

        世亲菩萨释

        陈天竺三藏真谛译

    释学果寂灭胜相第九

论曰。如此已说依慧学差别。云何应知寂灭差别

释曰。菩萨道与二乘道既有差别。由道得灭。菩萨灭与二乘灭亦应有差别。云何可知

论曰。诸菩萨惑灭。即是无住处涅槃

释曰。二乘与菩萨同以惑灭为灭谛。二乘惑灭一向背生死趣涅槃。菩萨惑灭不背生死不背涅槃。故异二乘。菩萨此灭于四种涅槃中。是无住处。一本来清净涅槃。二无住处涅槃。三有余。四无余。菩萨不见生死涅槃异。由般若不住生死。由慈悲不住涅槃。若分别生死。则住生死。若分别涅槃。则住涅槃。菩萨得无分别智。无所分别故无所住

论曰。此相云何

释曰。无住处涅槃。以何法为相

论曰。舍离惑与不舍离生死。二所依死。转依为相

释曰。若菩萨在转依位。不与诸惑缘起处。故名舍离。惑在出观位。必起分别故。名不舍离生死。若偏观前后明此二义。亦得一时具二义。若双观二义。必在一时。此二义并以依他性为依止。无住处涅槃以转依为相。即转二着。凡夫着生死。二乘着涅槃。菩萨得无分别智。不见生死涅槃有差别。虽灭惑不住涅槃。虽起分别不住生死。故此涅槃以转依为相。此转依即依止依他性

论曰。此中生死是依他性。不净品一分为体。涅槃是依他性。净品一分为体

释曰。此释二所依止义。本识名依他性。本识若起分别。即是不净品。说此一分为生死体。如分别依他性。此性不如此有。此分别无所有即是净品。依此一分为涅槃体

论曰。本依者。是具净不净品二分依他性

释曰。分别性是生死。真实性。是涅槃。从本以来此二品以依他性为依止。即说依他性为本依

论曰。转依者。对治起时。此依他性。由不净品分永改本性。由净品分永成本性

释曰。转依亦属依他性。三乘道是对治。此依他性道未起时。如见谛等。或能起诸业感恶道报。名不净品。道起已后。如此不净品灭不更生。故言永改本性。此依他性道及道果名净品。道即戒定慧。道果有二种。谓有为无为。有为即解脱解脱知见。无为即本惑灭。及未来惑不生。道未起时。戒等净品未成立。但有本性清净。由道起故与五分法身及无垢清净相应。如此相应乃至得佛。无有变异。故言永成本性

论曰。此转依若略说有六种转

释曰。若约三乘道及道果。广说则有多转依义。今略说故但有六种

论曰。一益力损能转。由随信乐位。住闻熏习力故

释曰。由三乘圣道起阿黎耶识中。闻熏习功能更增。说名益力。于阿黎耶识中。所有诸惑熏习。由对治起故无复本用。说名损能。此二事何位何因得成。若人住愿乐位中。闻如来说广大甚深正教。于中起三信。愿乐修行。随顺不违。此损益以闻熏习力为因。闻思慧为闻熏习体。因此二慧生修慧。修慧是闻熏习力。若无修慧。本依则不得转。由此力故损益义成。若人已得如此转依。烦恼行于此人云何

论曰。由烦恼有羞行惭。弱行或永不行故

释曰。若人已得此转依。烦恼若起即生惭羞。起亦不久。又复微弱。或永不起。何以故。能羞自身。深见诸过故

论曰。二通达转谓已登地诸菩萨。由真实虚妄显现为能故

释曰。得无分别智。证真如故名通达。由此通达有别转异于地前。若已登地。有时入观。此通达为真实显现因。何以故。如初通达明证真如。后入观亦尔。有时出观。此通达为虚妄显现因。何以故。如先未入观。以散心修自利利他俗行。今出观亦尔

论曰。此转从初地至六地

释曰。此中同有出入观异故。以六地为其位

论曰。三修习转。由未离障人。是一切相不显现。真实显现依故

释曰。前位修习依相起。此位修习依无相起。已离惑障。离一切智障未尽。是有学大乘人能得此转。一切相。谓相相生相真实相。此三相体不显现。依止此转依得成。三无相得显现。亦依止此转依得成

论曰。此转从七地至十地

释曰。此中同修无相行故。以四地为其位

论曰。四果圆满转。由已离障人。一切相不显现。清净真如显现。至得一切相自在依故

释曰。三德具足名果圆满。已离一切障人。即是诸佛。能得此转。一切相不显现。即是断德。以一切相灭故。清净真如显现。即是智德。如理如量智圆满故。谓具一切智及一切种智。至得一切相自在。即是恩德。依止一切相中所得自在。由得此自在。如意能作一切众生利益事。三德并以此转为依止

论曰。五下劣转。由声闻通达人无我故。由一向背生死。为永舍离生死故

释曰。人境功能三义皆下劣。是声闻人故人下劣。但观人无我故境下劣。心求免离生死。自出三界未得究竟。又不能兼济众生。故功能下劣。身见是声闻系缚。为除此见故修人无我观。苦集通名生死。若得人无我。则能背苦舍集

论曰。六广大转。由菩萨通达法无我故

释曰。人境功能三义皆广大。是菩萨人故人广大。观法无我故境广大。自度度他又能究竟故功能广大。分别是菩萨系缚。为除此系缚故。修法无我观。法无我是本。人无我是末。若得法无我。必先得人无我。虽复先得。犹未清净。以根本未除故。证法无我后方得清净。法无我境能显四德。故观此境得离八倒

论曰。于中观寂静功德故

释曰。谓于生死中。观法无我故。称寂静功德

论曰。为舍不舍故

释曰。此显法无我观功能。于生死中由观寂静能离分别。不为惑染故舍烦恼。由见生死寂静与真如不异故。不舍生死

论曰。若菩萨在下劣转位。有何过失

释曰。欲显有三失故为此问

论曰。不观众生利益事故

释曰。此明失菩萨恩德

论曰。过离菩萨法

释曰。如理如量智。及随智所起福德是菩萨法。不行菩萨智慧法为过。舍远菩萨福德法为离。此明失智德

论曰。与下乘人同得解脱。此为过失

释曰。但灭惑障不灭智障。此明失断德

论曰。诸菩萨若在广大转位。有何功德

释曰。欲显有三德故。更为此问

论曰。于生死法中。由自转依为依故。得诸自在

释曰。得无分别智。灭智障种子。此灭即是转依。以此转依为依止。菩萨于一切法中。得十种自在

论曰。于一切道中。能现一切身

释曰。以自在为依止。于六道中。随彼形类。现种种身

论曰。于世间富乐及于三乘。由种种教化方便胜能。能安立彼于正教。是广大转功德

释曰。富乐是三界善道。先令得世间善道。后令得三乘圣道。以三轮化度令住正法。何法为大菩提自性转依。异二乘是大菩提自性。此转依应知有四相。一生起依止为相。二永不生依止为相。三成熟思量所知果为相。四法界清净为相。生起依止为相者。是佛相续所摄。出世道依止。若不尔未至此转依。佛圣道不成。不应道理。若佛道离此转依成。依未转道应先成。永不生依止为相者。一切惑及习气永不生依止。若不尔因缘已聚集。未至此转依。诸惑及习气永不生不成。不应道理。成熟思量所知果依止为相者。成熟寻思及善通达所知。真如所知实际果。若不尔诸佛自性应更寻思。应更灭障。法界清净为相者。伏灭一切相。最清净法界所显。若不尔诸佛自性应无常。应可思佛自性常住。不可思为相。亦不可说

论曰。此中说偈

释曰。为显此转依故。重说偈

论曰

  于凡夫覆真　　于彼显虚妄

释曰。见谛无明于凡夫。覆一切法人无我真空于彼。谓于凡夫此无明倒彼心。令见我相众生相等及六尘相诸虚妄法。因此显现无明为其依止

论曰

  于菩萨一向　　舍虚显真实

释曰。菩萨无分别智。由灭无明故。舍一切虚妄法。谓我相等。显二空真如。无明生是凡夫依。无明灭是菩萨依。此偈明灭为转依相

论曰

  不显现显现　　虚妄及真实

释曰。虚妄是分别性。分别不起即虚妄不显现。真实是三无性。虚妄不显故真实显现

论曰

  是菩萨转依　　解脱如意故

释曰。不显现显现是菩萨转依。此转依即菩萨解脱。得解脱已无复系缚。为利他故。如意遍行于六道中。不同二乘解脱永灭无利他义。如被斩首命必不续。此偈明解脱虚妄清净法身。此二由无分别智得成。即就三德明转依

论曰

  于生死涅槃　　若智起平等

释曰。生死涅槃并是分别所作。同一真如。若得无分别智。缘此平等起

论曰

  生死即涅槃　　二无此彼故

释曰。不净品名生死。净品名涅槃。生死虚妄无人法二我。即是涅槃。得无分别智。见生死无所有。即是见涅槃无所有。故无此彼之异。若得此智有何功能

论曰

  是故于生死　　非舍非非舍

释曰。虽观无我不离生死。是非舍义。虽在生死常观无我。是非非舍。若尔于涅槃云何

论曰

  于涅槃亦尔　　无得无不得

释曰。离生死无别法名涅槃。菩萨既不得生死。亦不得涅槃。是无得义。菩萨于生死常观胜妙寂静。是无不得义

    摄大乘论释释智差别胜相第十之初

论曰。如此已说寂灭差别。云何应知智差别

释曰。前已说菩萨解脱与二乘解脱差别。菩萨解脱知见。与二乘解脱知见。亦应有差别。云何可知

论曰。由佛三身。应知智差别

释曰。智差别是菩萨解脱知见。即菩提道究竟果。如二乘道究竟果名解脱知见。二乘解脱知见中无三身。菩萨解脱知见中有三身差别。何以故。二乘不能灭智障。无一切智故。不得圆满清净法身。无大慈悲不行利益他事故。无应化两身。菩萨具此二义故有三身。故以三身显智差别。何法名三身

论曰。一自性身。二受用身。三变化身

释曰。身以依止为义。由能持诸法。诸法随身故得成。不随则不成故。身为诸法依止。譬如身根为余根依止故得身名。法身亦尔。应化身及如来一切功德所依故名为身。又身以实为义。不破坏故名实。身即是体。体以性为义。此性于一切位中。不改故名实。实故不破坏。身有二种。一自然得。二人功得。自然得者。如经言。若佛出世若不出世法性常然。谓一切法由二空不空。二空由虚妄不空。此二法皆自然得。故说名自性。人功得者。谓六道身。由依惑起善恶不动业。由业得七种果。依果更生惑。是名人功所得。如来身亦有二种得。一自性得。是法身。二人功得。是应化两身。为显异人功所得故立自性身。依止自性身。起福德智慧二行。二行所得之果。谓净土清净及大法乐。能受用二果故名受用身。于他修行地中。由佛本愿自在力故。彼识似众生变异现故名变化身

论曰。此中自性身者。是诸如来法身

释曰。此三身中。若以自性为法身。自性有二种定。以何自性为法身。一切障灭故。一切白法圆满故。唯有真如及真智独存。说名法身。身以依止为义。何法为依止

论曰。于一切法自在依止故

释曰。一切法自在。谓十种自在。又因中十波罗蜜。果中一切不共法。皆得已不失。如意运用故名自在。自在不可数量。随诸法数量自在亦尔。云何知此法依止法身。不离清净及圆智。即如如如如智故

论曰。受用身者诸佛种种土。及大人集轮依止所显现

释曰。土有众宝差别。不可数量故称种种。此无量宝土。依佛应身得成。诸菩萨名大人集。是菩萨众亲近善友。正闻正思正修等是轮体。如圣王金轮能从此至彼。未得令得。已得令不失。能上下平行此是轮用。菩萨亦尔。若离应身则二事不成。故此二事以应身为依止。由能依止成故所依止显现

论曰。此以法身为依止

释曰。法身无依止。此身有依止。如前言于一切法自在依止故。此即明应身依止法身故二身有异

论曰。诸佛土清净大乘法受乐受用因故

释曰。菩萨于诸佛净土中。自听受大乘法受法乐。为他说大乘法亦受法乐。菩萨备受用此二法乐。若无应身则无此二受用法乐。故应身为此二受用法乐因。又释受用有二义。一受用尘。即受用净土。二受用法乐。即受用大乘法乐。若无应身则无此二受用。故以应身为此二受用因。变化身与法身应身异相云何

论曰。变化身者以法身为依止

释曰。法身无依止。此身有依止。如前言于一切法自在依止故。此即明变化身依止法身。故二身有异

论曰。从住兜率陀天。及退受生

释曰。此下明化身体异应身。应身以大智大定大悲为体。化身但以色形为体。所现色形先住兜率陀天中。后生人中。先二十年受中阴生故言退。后于释迦家受生

论曰。受学受欲尘

释曰。修习王秘密巧六十四能等。为受学纳妃等。为受欲尘

论曰。出家往外道所修苦行

释曰。舍王位往郁陀阿罗罗仙人所。备修外道一切苦行

论曰。得无上菩提。转法轮大般涅槃等事。所显现故

释曰。后舍外道法。修不苦不乐行。成无等觉。说三乘教。后方舍化。变化事非一。乃至灭后犹有遗形。为佛事故言等事。以此等事显于化身。佛何故先住兜率陀天。后生人中。欲显自身是天人类。以天人是圣道器故。欲示为天人师摄利同类故。为断外道毁谤故

论曰。诸佛如来所有法身。其相云何

释曰。欲引相等十义证成法身。法身若成。余二身亦成。故为此问

论曰。若略说其相。应知有五种

释曰。若广说如无生无灭等。有无量相。今略说故言有五相。即十义中第一相义

论曰。此中说郁陀那偈

释曰。为摄持散义故说此偈。偈中十义后次第释

论曰

  相证得自在　　依止及摄持
  差别德甚深　　念业明佛身

五相者。一法身转依为相

释曰。法身即是菩萨转依

论曰。一切障及不净品分。依他性灭已

释曰。障有二种。一具分障。二一分障。菩萨所断一切智障。通三界内外故名具分。即是一切障。二二乘所断惑障。唯在三界内名一分障。即是不净品分。并以依他性为依止。治道起时即断此二障。故言灭已

论曰。解脱一切障

释曰。由二分障已灭。依他性一分。解脱一切障

论曰。于一切法得自在为能

释曰。此依他性一分。能通达一切法同一无性。已得无失。故名自在

论曰。清净性分依他性。转依为相故

释曰。欲显异无分别后智。离一切分别故。言清净性分。此无分别智又是依他性一分。依他性有二分。前明灭障显无分别境。后明于一切法得自在。为能显无分别智。此二分是转依。转依为法身相

论曰。二白净法为相

释曰。一切法有二种。一黑二白。黑即是恶。白即是善。善中自有四种。法身是真实善故。言白净法为相

论曰。由六度圆满。于法身至得十种自在。胜能为相故

释曰。由修六度究竟。于法身得十自在。此十自在是法身胜能。即以法身为性。由六度究竟得十自在。其义云何

论曰。何者为十。一命自在

释曰。于寿命中。修短及舍如意得成

论曰。二心自在

释曰。于生死受生。不为生死染污

论曰。三财物自在

释曰。十种财物饮食为初。随时随处如意能得

论曰。此三由施度圆满得成

释曰。若人一切处施。一切物施。以大悲施则施圆满。由大悲行施为因。得心自在。由一切处施为因。得命自在。由一切物施为因。得财物自在

论曰。四业自在。五生自在。此二由戒度圆满得成

释曰。业为因生为果故。此二相应。由能制身口业故得业自在。乃至若分分断身心。无变异身口业。由此心成故戒度圆满。由戒度圆满。若欲受余生。如意能引。此业悉令现前故名业自在。由业自在。于业果生中亦得自在。随六道类如意往生利益。若竟如意能舍。取舍二事功能无碍。故名生自在

论曰。六欲乐自在。由忍度圆满得成

释曰。忍有三种。一忍辱忍。二安受忍。三通达忍。于他毁损事心不坏。名忍辱忍。于自苦事心无变异。名安受忍。于正法甚深道理心能明证。名通达忍。由此三忍诸法皆随逐心。后于诸法中。随所欲乐如意得成

论曰。七愿自在。由精进度圆满得成

释曰。由精进波罗蜜能度一切所作事。于未来世。一切所愿如意得成。故名愿自在

论曰。八通慧自在。此五通所摄。由定度圆满得成

释曰。于五通中。未得得已得不失。故名自在。又于五通能自用。亦能令他如我所用。故名自在。由菩萨能得诸菩萨诸甚深定心。随事调伏。若引五通处于自他如意皆成

论曰。九智自在。十法自在。此二由般若波罗蜜圆满得成

释曰。菩萨由般若波罗蜜圆满。以无分别智。于阴等法门。心通达无余。得一切种智。名智自在。以无分别后智。通达一切法品类。得一切智。名智自在。以无分别后智。如自所证。为他安立法门。如理得成。名法自在

论曰。三无二为相。由无有无二相故

释曰。无二谓无有无无。有为常无为断。无有无无即是不常不断。离于二边

论曰。一切法无所有。空相不无为相故

释曰。更释上语一切法皆分别所作。悉无所有。即是二空相故。无有不无二空相故。无无法身即是二空故。以无二边为法身相

论曰。复次有为无为无二为相

释曰。无二谓无有为无无为。一切有流法必以有为为相。一切无流法有二种。若道等以有为为相。择灭等以无为为相。法身与有为无为不一不异。是故不得偏以有为无为为相。由真如是有为无为通相。不可说异。真如是清净境。有为无为非清净境。不可说一。法身非有为无为为相。非非有为无为为相。何以故

论曰。非惑业集所生故

释曰。一切有为法。皆从惑业生。法身不从业惑生故非有为

论曰。由得自在能显有为相故

释曰。法身由得自在。能数数显有为相。谓应化二身故非无为

论曰。复次一异无二为相。诸佛如来依止不异故

释曰。无二谓无一无异。三世诸佛由法身无异。法身即是依止是故不异

论曰。由无量依止能证此故

释曰。由此法身无量。已成熟善根诸菩萨。无间所证故不可说一。若一余人修行则应无用

论曰。此中说偈

释曰。为显法身不一异义。故重说偈

论曰

  我执不有故　　于中无依别

释曰。于世间由随我执分别。众生依止有差别。于法身无有我执分别故。如来依止无差别。若尔云何立有多佛

论曰

  如前多依证　　假名说不一

释曰。如前因地无量依止能证故。若一一世间身无有法身。菩萨则无所证。由菩萨各各依自身证此法身故。约假名不可说一

论曰

  性行异非虚　　圆满无初故
  不一无异故　　不多依真如

释曰。诸菩萨发心多故名性异。由性异故加行亦不同。由加行异故有功力。由有功力故能得果。有因义故非虚。若但有一佛。诸余菩萨修行则空无所得。诸佛作众生利益事。无不圆满。由安立彼于三乘故。若诸佛不安立他于无上菩提。则所作佛事不圆满。由利益事圆满故佛不一。如生死无初。无量诸佛亦尔。无初无量。若唯一佛成前后佛不成。则于一佛立始立终。义则可成。由此五义故诸佛不一

论曰。无异故不多

释曰。依止不异故诸佛不多。不多故无异。何者为依止

论曰。依真如

释曰。真如即清净法界。法界无异。故诸佛依止无差别。此二偈显法身无一异相

论曰。四常住为相。真如清净相故

释曰。此下引三证立法身常住义。真如若出离一切垢。无垢清净说名佛果。此真如常住。诸佛是清净真如所显。故法身常住

论曰。昔愿引通最为极故

释曰。从初发心乃至八地。经二十七大劫阿僧祇。于中如来依法界发愿成就。愿秉持愿是名引。于一切处无碍故名通。穷生死际故名最极。由依法界起此愿故。法界若无常愿则有尽。愿既无尽故知法界常住。又由此愿引通最极。不空无果故得法身。愿既无尽故法身常住

论曰。应作正事未究竟故

释曰。若言佛作众生利益事竟。先愿应穷。不可以愿证法身常住者。是义不然。何以故由正事未究竟故。从今时乃至无穷世。正事无边。若众生未皆得佛。未悉般涅槃。此正事无息。正事由法身成。正事不尽故法身常住

论曰。五不可思议为相。是真如清净自证智所知故。无譬喻故。非觉观行处故

释曰。法身有三因缘故不可思议。一非三慧境界故不可思议。非觉观行处故非闻慧境。无譬喻故非思慧境。自证智所知故。非世间及二乘修慧境。是故不可思议。二无分别最上真实故不可思议。无分别者菩萨自证智所知。非凡夫分别境界。凡夫如生盲不能分别色。以未曾见色故。亦非二乘分别境界。此境最极非二乘所证故。不能分别。二乘如新生婴儿不见日轮。以根弱故。最上者无譬喻故。法身于一切法中最极无等。无余法可为譬喻故。非有上人所能知。真实者不可言说故。若不可言说未曾见真实。众生不能分别。一切觉观随言说起。既无言说故非觉观行处。是故不可思议。三法身是诸佛证智所知。非世间聪慧人所能分别。于世间中无物可等法身。由见此物以比知法身。于法身中一切心行皆绝。以境智无差别故。是故不可思议

论曰。复次此法身证得云何

释曰。有证不得。有得不证。有亦证亦得。有不证不得。今欲显亦证亦得。一切众生在于生死。无有众生本无法身。恒与法身相应故。此相应无始法自然成。如此相应说名为得。此得非触得。非根识所证故。为离相应得故立此问。如经言于众生聚中。无众生在法身外。如无一色在虚空外。以一切众生皆不离法身故。法身于众生本来是得。得义如此。证义云何

论曰。是触从初所得

释曰。为显触得有始。由方便成利益无穷故。如眼证见色必具五义。一有实境对根。二根不坏。三有觉观。四识不乱。五无闇等障。五义若不具则不能证色。证知法身亦尔。必须具五义

论曰。由缘相杂大乘法为境

释曰。真如是大乘法。大乘十二部经所说法门。皆共显此真如。一切正说于真如法。则同一味。故名相杂。如众流归海。相杂共为一味。智与境无差别故言缘。菩萨缘相杂大乘中真如法为境。此即第一显境实有最胜

论曰。无分别智。无分别后所得智

释曰。证智以无分别为相。由此智于真如境起。离分别故清净成证智。此即第二显智清净如根不坏。无分别后所得智。是前后助法。由此智后更入真观后后转胜。此即第三明助法如觉观。若有毗钵舍那无奢摩他。无证得义故须修奢摩他。修奢摩他有三相。一得因。二得伴类。三得功能

论曰。五相修成熟修习

释曰。此明得因。五修及五修所得五果。如因果修差别中说。得无退失名熟。得最上上品名成。数数观察名修习。此明二种因。一不失因。二圆满因。故名得因

论曰。于一切地善集资粮

释曰。此明得伴类从初地乃至十地。聚集福德智慧行为资粮故。名得伴类

论曰。能破微细难破障故

释曰。此明得功能。由前二义故能破智障。此烦恼与二乘无流道俱起。故名微细。非二乘道所能破故名难破。故名得功能。此即第四明得定如识不乱

论曰。金刚譬三摩提

释曰。有四义故。以金刚譬三摩提。一能破烦恼山。二能引无余功德。三坚实不可毁坏。四用利能令智慧通达一切法无碍

论曰。次此三摩提后灭离一切障故

释曰。得此定竟。灭一切障方尽。此即第五明灭惑如无闇等障

论曰。是时由依止转成证得应知

释曰。金刚心灭时名是时。是时第十地依止。转成佛依止名证得。应如此知

论曰。此法身有几自在。于中得自在

释曰。欲显约五阴转依。明法身自在。故为此问

论曰。若略说有五自在于中得自在

释曰。若广说有无量自在。今略说止明五种

论曰。一净土显示自身相好。无边音不可见顶自在

释曰。如意能现颇梨珂等净土。随众生类如意现身。于大集中。皆对众生无有背者。又称众生所乐见。现种种身。称众生所乐见。现种种相好。所说法音如意。遍满十方世界。于一音中。随诸众生所欲闻法各各得闻。诸梵天等见佛之时。如来身量倍高于彼故。顶不可见。于此等事皆得如意。故名自在。如此自在何因能得

论曰。由转色阴依故

释曰。一一阴皆有如灭差别中所说前四转依。色识名色阴。形碍是色体。对治起时。由分别性不净品一分永得相离。净品一分恒得相应。即是色阴转依。于此转依中。得净土等自在

论曰。二无失无量大安乐住自在

释曰。不为诸惑及习气染污。故名无失。如来安乐住不可数量故言无量。过三界乐最胜无等故。名大安乐住。于此等事皆得如意。故名自在

论曰。由转受阴依故

释曰。受识名受阴。领苦乐是受体。由转受阴依故。得此自在

论曰。三具足一切名字文句聚等中。正说自在

释曰。一切诸法名字。及诸言教文句。从偈以去一章一品。乃至一部皆名为聚。悉能了知如意正说。故名自在

论曰。由转想阴执相差别依故

释曰。想识为想阴。执相差别为想体。由转想阴依故得此自在

论曰。四变化改易引摄大集。牵白净品自在

释曰。未有现有。及分一为多。是变化。转其本性为改易。所欲见众生。随其远近如意引导。天人夜叉等来大集中。随彼所宜。以四摄摄化。有流善为白。无流善为净。牵此白净品法。生相续中。于此等事皆得如意。故名自在

论曰。由转行阴依故

释曰。行识为行阴。作意为行体。由转行阴依故得此自在

论曰。五显了平等回观作事智自在

释曰。如来于一切法无有过失。证知非现前境如对现前。譬如人忆持熟习文句。是名显了智。从通达真如以来。于一切众生得平等心。由证平等清净法故。是名平等智。能守三摩提陀罗尼门。于此法门中所欲取法。如意无碍。譬如财主守其库藏取用无碍。是名回观智。能受兜率陀天生。及般涅槃。为立声闻及下地菩萨无流善根。能显如来事。是名作事智。于此等事皆得如意。故名自在

论曰。由转识阴依故

释曰。识识为识阴。了别为识体故。转识阴依得此自在

论曰。此法身应知为几法依止

释曰。欲显如来无量功德皆从法身生。以法身为依止。故为此问

论曰。若略说唯三

释曰。若广说为无量法依止。今略说唯三

论曰。诸佛如来种种住处依止故

释曰。住有四种。谓天住梵住圣住佛住。于诸住中如来多住此四法。故偏说此四得有二种。一自在得。二现前得。初成佛时一切如来法具足皆得。名自在得。后时随所正用者。名现前得。若证法身一切如来法皆自在得故。法身为住等法依止。何以故。无离法身得此法故

论曰。此中说偈

释曰。欲显法身为住等法依止。故重说偈

论曰

  诸佛如来受五喜

释曰。菩萨亦有此五德。但未圆满。唯佛具足故言诸佛如来。喜体唯一。但以无失最胜为体。由五因所得故言五喜。诸佛自得解脱。以化身教二乘人令得解脱。何故如来自受五喜。而二乘不得

论曰

  皆因证得自界故　　二乘无喜由不证

释曰。由因有异故。得果不同。以证自界为因。五喜为果。界是如来性。即性净法身。如来自大功能所证。不由无因。不由他得。故言证自界。由证自界故得五喜果。二乘不证此界。故无五喜

论曰

  求喜要须证佛界

释曰。若人欲求五喜等法。必须修道以证法身。何以故。以果无离因得故。此偈显法身为五喜依止。由证法身故得五喜。不证法身则无五喜

论曰

  由能无量作事立　　由法美味欲德成

释曰。此偈示由五因故称五喜。何者为五。一因自能无量故生喜。一切佛同觉了法身。一切佛同得胜能。一切佛胜能即是一佛胜能。一佛胜能等一切佛胜能。何以故。诸佛同一法身为体。体既是一故。余佛胜能即是一佛胜能。诸佛胜能无量。一佛胜能亦无量。故一佛胜能得等诸佛胜能。诸佛法身同得胜能。是故生喜。由见证自界得此胜能。是故生喜。二因作事立故生喜。一佛所作众生利益事。是一切佛正事。是一切众生利益事。何以故。一切佛所作净土等利益众生正事。即是一佛所作正事。诸佛设皆不作正事。一佛所作正事通等诸佛所作正事。若利益一众生。即是利益一切众生。若一众生成佛。此众生复能教化一切众生。如此转相利益。若诸佛已证自界。则成立此正事。由见证自界作正事立。是故生喜。三因法美味故生喜。由如来昔时学三乘十二部经。后成佛时各观一切法。无不从此法身生。无不还证此法身故。一切法门同一法身为味。由见修多罗祇夜等经同一法身味。是故生喜。四因欲德成故生喜。所欲得成功德亦成。所欲成者。如佛所思无不成就。谓净土及大集等事。功德成者。谓十力四无畏等。一切如来不共法无不圆满。由见此二事成是故生喜

论曰

  得喜最胜无有失

释曰。过三界喜乐故最胜。一切惑乃至习气皆尽无余故无失

论曰

  诸佛恒见四无尽

释曰。复次如来见前四喜。乃至穷生死际无有灭尽。设入无余涅槃亦无灭尽。是故生喜。此喜何相。一最胜为相以过三界及二乘喜故。二无失为相。一切惑乃至习气灭尽无余。此显最圆满及最清净。是名第一自利依止

论曰。种种受用身依止。为成熟诸菩萨善根故

释曰。诸佛应身无量故言种种。又一一佛应身品类不可说。故言种种。此法身为应身依止。何故为依止。为生此身故。若离应身。登地菩萨善根则不得成熟。故须应身。应身由法身立故。法身为应身依止。此即第二利益菩萨依止

论曰。种种化身依止。为多成熟声闻独觉善根故

释曰。此法身不但为应身依止。亦是化身依止。何以故。若离化身下愿众生。谓声闻独觉所有善根不得成熟。多言显不止利益二乘愿乐。地中菩萨善根亦因化身成熟故。法身为化身依止。此即第三利益二乘依止

摄大乘论释卷第十三摄大乘论释卷第十四

        世亲菩萨释

        陈天竺三藏真谛译

    释智差别胜相第十之二

论曰。有几种佛法。应知摄此法身

释曰。不为显摄法身体。故为此问。为显摄法身证得故为此问

论曰。若略说有六种

释曰。若广说有无量种。今略说故止言六种

论曰。一清净类法

释曰。灭不净品尽证得法身。名为清净法。云何得此清净法

论曰。由转阿黎耶识依故

释曰。对治起时。离本识不净品一分。与本识净品一分相应。名为转依

论曰。由证得法身故

释曰。由此转依。金刚道后证得法身。灭德以外其余诸德名清净法。是证得类故名清净类法

论曰。二果报类法

释曰。有如来法是果报类。如见色等智名果报法。云何得此果报法

论曰。由转有色根依故

释曰。对治起时灭眼等五根色识。名为转依

论曰。由证得果报胜智故

释曰。由此转依。诸佛得果报类智。此智于五尘中。当十方世界众生五根所生识。此智于五尘中起故名果报类。此果报类法是证得类故。名果报类法

论曰。三住类法

释曰。如来遍证得一切法。名为住法。云何得此住法

论曰。由转受行欲尘依故

释曰。对治起时。灭世间受行欲尘识。故名转依

论曰。由无量智慧住故

释曰。由此转依。如来得无量智住。无量境皆不忘失。此智即当受行欲尘触中有忘失。识即是四不护体。此住类法是证得类故名住类法

论曰。四自在类法

释曰。于一切处胜能无碍。名为自在法。云何得此自在法

论曰。由转种种业等摄自在依故

释曰。于世间中有种种诸业。如耕种商贾等。或蓄聚财物。摄此种种事业。对治起时灭此业等识。名为转依

论曰。由此于一切十方世界。无碍六通智自在故

释曰。由此转依。于十方世界得无碍六通智。此自在法是证得类故。名自在类法

论曰。五言说类法

释曰。如来有不共得四无碍解。于正说中具足胜能。名言说法。云何得此言说法

论曰。由转一切见闻觉知言说依故

释曰。于世间中。有见闻觉知四种言说。依六识境起意识分别。由此分别生四种言说。对治起时灭此言说识。名为转依

论曰。由此能饱满一切众生心。正说智自在故

释曰。由此转依。如来于四言说中。得不共四无碍解。能称众生根性。如意说法皆令得果。此言说法是证得类故。名言说类法

论曰。六拔济类法

释曰。是诸佛利益安乐众生意即是大悲。云何得此拔济

论曰。由转一切灾横过失拔济意依故

释曰。于世间中。如王等所起灾横。菩萨昔由善友力自势力财物力等。拔济众生灾横过失。对治起时灭此拔济识。名为转依

论曰。由此一切众生灾横过失拔济。智自在故

释曰。由此转依。能如意拔济一切众生灾横过失。此拔济法。是证得类故。名拔济类法

论曰。如此六种类法所摄。诸佛如来法身应知

释曰。此六法前四是自利。后二是利他。利他有二种。一永利二暂利。永利是真实。暂利是假名。并是法身证得类故。言摄法应如此知

论曰。诸佛法身为可说有差别。为无差别

释曰。十方诸佛为同一法身。为当有异

论曰。由依止意用业无异故。应知无差别

释曰。诸佛同以法身为依止。于众生利益安乐意用亦同。于众生中现成正觉。乃至般涅槃此业亦同。由此义故。应知诸佛法身无差别

论曰。由无量正觉等事故。应知有差别

释曰。有诸佛于法身已得正觉。乃至已般涅槃。有诸佛正得正觉。有诸佛当得正觉。乃至般涅槃亦尔。如此等有无量事。前后不同。是故应知法身有差别

论曰。如法身受用身亦尔

释曰。诸佛应身无差别有差别。义如法身

论曰。由依止业不异故。应知无差别

释曰。十方诸佛应身同依止法身。依止不异故应身无差别。应身以化身为业。诸佛应身无不皆为化身依止。起于化身以业同故无有差别

论曰。不由能依止差别故无差别。无量依止转依故

释曰。无量菩萨修道转依。如菩萨数量应身亦尔。不由依止无差别说无差别。由身各异应身亦尔。故有差别

论曰。变化身。应知如受用身

释曰。由依法身故无差别。由依应身故有差别

论曰。此法身应知与几种功德相应。与最清净四无量相应。与八解脱八制入。十一切入。无诤三摩提愿智。四无碍解六通慧。三十二大人相八十小相。四种一切相清净。十力四无畏四不护三念处。拔除习气无忘失法。大悲十八不共法。一切相最胜智等。诸法相应

释曰。此身与诸功德法相应。故名法身欲显相应法故为此问

论曰。此中说偈

释曰。偈有两义。一显如来功德。二显恭敬有功德人

论曰

  于众生大悲　　离诸结缚意
  不离众生意　　利乐意顶礼

论曰。于众生大悲

释曰。此下一偈显四无量。此句即明大悲

论曰。离诸结缚意

释曰。此句明大慈。离染着意与众生乐

论曰。不离众生意

释曰。此句明大喜。众生若已离苦受乐。则恒于彼起欢喜心

论曰。利乐意顶礼

释曰。此句明大舍。舍不拔苦与乐意。常怀利乐意。又舍怨亲等相。常怀平等利乐意。由有此德。是故顶礼。复次离诸结缚意者。明离外道及二乘悲心。外道悲心缘众生起为结。二乘悲心缘法起为缚。如来大悲不缘此二起故言离。大悲既尔。慈等亦然。不离众生意者。虽离众生及法缘。如来于众生常不离四无量意。于有苦者不离拔苦意。于无乐者不离与乐意。于己离苦受乐者不离欢喜意。于如此众生不离平等意利乐意。顶礼者令得出世益为利。令得世间益为乐。四无量具有二益

论曰

  解脱一切障　　降伏世智者
  应知智遍满　　心解脱顶礼

论曰。解脱一切障

释曰。此一偈显三德。此句明八解脱。八解脱除二种障。一修习障。二胜类障。八解脱具二义。一是无流。二是究竟。是无流故除修习障。即见谛等惑是究竟故。除胜类障即下劣心

论曰。降伏世智者

释曰。此句明八制入。是无流非究竟。是究竟非无流。属八制入故。异八解脱。心能制境。使境从心。故名降伏世智者即是佛

论曰。应知智遍满

释曰。此句明十一切入。应知是十境。智缘十境遍一切处。故言遍满

论曰。心解脱顶礼

释曰。心于此三处皆得解脱

论曰

  诸众生无余　　能灭一切惑
  害惑有染污　　常怜愍顶礼

论曰。诸众生无余能灭一切惑

释曰。此偈明无诤三摩提。凡有所作。不起一切众生烦恼诤

论曰。害惑有染污常怜愍顶礼

释曰。佛能害众生惑。众生有染污。如来常起怜愍心

论曰

  无功用无著　　无碍恒寂静

释曰。此半偈明愿智。于三世一切事欲知为愿。如来皆能证知为智。修习熟故无功用。习气尽故无著。由此二义故。皆能证知于三世境。如量能知故无碍。如来恒不出观故寂静。寂静显无功用。无碍显无著

论曰

  一切众生难　　能释我顶礼
  于依及能依　　应说言及智
  于能说无碍　　说者我顶礼

论曰。一切众生难能释我顶礼

释曰。此下一偈半明四无碍解。由具四解故能释众生难

论曰。于依及能依应说言及智

释曰。于依是义。能依是诸法门。应说言是方言。及智是巧辩

论曰。能于说无碍

释曰。于此四中功能无碍。为他说亦无碍

论曰。说者我顶礼

释曰。已离惑爱所说无垢。有能说之德故名说者

论曰

  摄寿住及舍　　变化及改性
  得定智自在　　世尊我顶礼

释曰。此偈明通慧。若寿命应尽。能更摄受令长。乃至经八万大劫等。非止八万劫而已。欲住多劫亦如意能住。欲舍亦如意能舍。又于诸定中亦有此三能。从一身中。分出无量身为变化。转金土等为改性。通慧皆由定成如意无碍故。言得定智自在

论曰

  诸众生见尊　　信敬谓胜士
  由他见能生　　净心我顶礼

释曰。此一偈。合明三十二大人相。八十小相众生。见佛大小相生信心及敬心谓如来是最胜之士如来大小相并能生众生清净心

论曰

  故随彼类音　　行往还出离
  证知诸众生　　正教我顶礼

释曰。此偈明四种一切相清净。随众生形类及音辞示现。如彼众生。过去受生为往。现在受生为还。行于二世之中。得三乘道果为出离。佛皆证知此事。如所应为说正教。由四清净故有此能

论曰

  方便归依净　　于中障众生
  于大乘出离　　摧魔我顶礼

释曰。从出家受戒。乃至世第一法悉名方便。苦法忍乃至第二果为归依。以得四不坏信故。第三第四果为净。以离欲欲界乃至无色界故。魔于此中能障众生。令不得此道果。若大乘中修十地行。出离三障。魔亦于中能为障碍。由如来具十力故。能为众生摧伏众魔

论曰

  智灭及出离　　障事能显说
  于自他两利　　降邪我顶礼

释曰。此偈明四无畏。智即一切智无畏。灭即流尽无畏。出离即说尽苦道无畏。障事即说障道无畏。若有外道。难佛言非一切智。或言诸流未尽。或言如来说尽苦道。修之不能令离苦。说障道法起此障不妨得道。如来于中无畏能降邪难

论曰

  无制无过失　　无染浊无住
  于诸法无动　　无戏论顶礼

释曰。此偈明四不护。无师制止。身口意命自无十恶等过失。非但无贪嗔邪见烦恼。一切烦恼皆已灭尽。不着诸法故言无染浊无住。不作意知诸法。知诸法无复学义。离于分别。智慧遍满故言无动。过失已除故无戏论

论曰

  于众伏他说　　二惑所远离
  无护无忘失　　摄众我顶礼

释曰。此偈明三念处。若有众生。于大集中闻如来说法。生毁谤如来亦不嗔。若能信受如来亦不。爱若无毁无信如来亦不舍。于此三处常起大悲。以方便力巧说正法。令其入理。于大众中能降伏如此众生。为说正法不起嗔欲二惑。既无嗔欲即知无无明。不由守护心故不忘失。大念大悲。常自坚固故无忘失。以此大悲能摄大众

论曰

  于利益他事　　尊不过待时
  所作恒不虚　　无迷我顶礼

释曰。十方无量众生。于一刹那中应得利益。如来以大悲力。于一刹那中悉令得利益无空过者亦无一众生得道时。未至预往其所。待时至方为说法。凡有所作皆应时得益。故所作无虚。迷是无明。无明即习气体。由习气尽故利益不虚

论曰

  于一切行住　　无非圆智事
  遍知一切世　　实体我顶礼

释曰。此偈明无忘失。已受生及未受生为行。正受生为住。众生三世事皆是圆智境故。能遍知三世。真如为体故名实体。由体实智圆故无忘失。复次佛在因位修十地为行。得佛为住。圆智能通达此自因果事。遍知一切世明。能通达众生三世事。此解通明能知自他

论曰

  日夜六时观　　一切众生界
  与大悲相应　　利乐意我礼

释曰。此偈明大悲。佛常观众生。而言六时者。欲为物作轨摸示修道。有自利利他行。以六时修利他行。六时修自利行。众生界即众生性。众生性不同。或因恶生善。或因善事生善。或因怖畏事生善。或因欢喜事生善。大悲能称此性化度故。皆与大悲相应。根及欲乐亦尔

论曰

  由行及由得　　由智及由事
  于一切二乘　　无等我顶礼

释曰。此偈明十八不共法。行是因得是果。智是如理如量智。事即利益众生事。十八不共法不出四义。不与二乘等故名不共

论曰

  由三身尊至　　具相无上觉
  一切法他疑　　能除我顶礼

释曰。此偈明一切相最胜智。三身即是三德。法身是断德。应身是智德。化身是恩德。由三身故。至具三德相果。由得无上觉故最胜。众生于一切法中生疑。如来悉能为除断

论曰

  无系无过失　　无粗浊无住
  于诸法无动　　无戏论顶礼

释曰。此偈显如来六种清净。一惑障清净即无系。由灭惑等三障故。二业障清净。谓无过失。由灭二十二业障故。三报障清净。谓无粗浊。由除七种生死故。四利益清净。谓无住。由于生死涅槃无隔碍故。五自在清净。谓于诸法无动。不由功用。于一切法如意能现故。六无戏论清净。由过言语觉观思惟境界故。前三明自利。后三明利他。故言等即等此六清净

论曰。诸佛法身不但恒与如此等功德相应。复与余功德相应

释曰。前所明功德通大小乘。已说法身与此功德相应。复有大乘不共功德与法身相应

论曰。谓自性因果业相应。行事功德相应

释曰。此中略说大乘六种功德与法身相应。谓法身自性。法身因法身果法身业。法身相应。法身生起

论曰。是故应知。诸佛法身有无上功德

释曰。于大小乘中。不与他共故无有上

论曰。此中说偈

释曰。为显此六种功德。是故说偈

论曰

  尊成就真如　　修诸地出离
  至他无等位　　解脱诸众生

论曰。尊成就真如

释曰。此句明法身自性。成就真如是无垢清净。若在道前道中。垢累未尽未得名成就。道后垢累已尽故名成就。此真如为法身自性

论曰。修诸地出离

释曰。此句明法身因。在因位修真如。所显十地究竟。出离皮肉心三障。即是智断二种转依。由此转依故得法身

论曰。至他无等位

释曰。此句明法身果。若证法身果。则得净我乐常四德果。净不与阐提等。我不与外道等。乐不与声闻等。常不与独觉等

论曰。解脱诸众生

释曰。此句明法身业。若得此果解脱众生。解脱有四种。谓安立善道及三乘。业解脱凡夫及三乘人

论曰

  无尽等功德　　相应现于世
  于三轮易见　　难见人天等

论曰。无尽等功德相应现于世

释曰。此两句明法身相应。无尽等有五种功德。与法身相应。一清净为胜。二一切为胜。三无量为胜。四难思为胜。五无尽为胜。从初地至七地。嫉妒等所对治习气垢。永灭不生为依止故。诸德清净为胜。与法身相应。于第八地。无分别无间缺。自然无流道为依止故。诸佛于无流界诸功德一切为胜。与法身相应。于第九地。不可数量三摩提陀罗尼门海。能摄无量法智为依止故。从此海生一一功德。皆无量为胜。与法身相应。于第十地。一切如来所有秘密处。现前证智为依止故。难思为胜。与法身相应。次此后证得佛地时。解脱一切障智为依止故。诸功德无尽为胜。与法身相应。无尽即是常住。为显常住故言现于世。前四功德虽约诸地明其差别。同至果方究竟故。悉与法身相应

论曰。于三轮易见难见人天等

释曰。此两句明生起。三轮即是三身。于三身中应化二身易见。法身难见。又法身于深行菩萨及诸佛为易见。于四种众生为难见。一凡夫二声闻。三独觉四始修行菩萨。如经言。如来藏非堕身见众生境界。非游戏颠倒众生境界。非于空散乱菩萨境界。何以故。凡夫人于色等诸法。无如此性。执有我及我所性。不能信乐身见灭离处甘露界。何况能正觉诸佛境界如来藏。二乘人于常住最胜应修中。倒修常住相。游戏无常相。修乐我净亦尔。如此二乘人由倒修不能得诸佛法身道。于中游戏故。四德相应法身非其境界。始修行菩萨迷如来藏空道理。信乐空解脱门。计灭有物以为空。谓诸法先时是有。后则断灭即是空。复有诸菩萨。由得空相思择空义。谓离色等法有别物为空。我今修行为证此空。当来必应得。如来藏非有非无为理故。非散乱心偏执有无境界。人天等即前四众生。法身甚深非其境界故。生起此四种众生迷惑行于法身。有此四事故。自性身于三轮中。非人天能见

论曰。复次如来法身甚深最甚深

释曰。以难行难通达难得故。甚深最甚深。复次言说难了达故称甚深。义理无底故称最甚深。复次文义难量故称甚深。品类非一故称最甚深

论曰。此甚深云何可见

释曰。以何相能显此甚深。令得可见

论曰。此中说偈

释曰。如大乘中所显。法身甚深义有十二种。今以偈说此义

论曰

  佛无生为生　　以无住为住
  作事无功用　　第四食为食

论曰。佛无生为生

释曰。此下一偈明第一甚深。此甚深中复有四种甚深。一生二不住三业四住。此句明生甚深。诸佛受生无生为相。有十种因以证此义。一与无明不同相故。二种种不同故。三摄受自在故。四于住自在故。五于舍自在故。六无二相故。七唯似显现故。八同幻化譬故。九无住处为住处故。十能成就大事故

论曰。以无住为住

释曰。此句明不住甚深。诸佛于生死涅槃悉无所住。亦有十种因以证此义。一非永所离故。二灭不尽故。三由诸佛非有法故。四由知非有为性故。五无所得无分别故。六由己离心故。七由得心故。八由心平等故。九住因不可得故。十不住因不可得故

论曰。作事无功用

释曰。此句明业甚深。亦有十因为证。一一切碍灭故。二无依止故。三应作无思故。四作者不作心故。五业非运动故。六于非有无功用故。七由宿愿疾利故。八所作已办故。九应作未办故。十由熟修一切法中自在故

论曰。第四食为食

释曰。此句明住甚深。亦有十因为证。一示诸佛不资四食。以显自身由食住故。二为长众生善根故。三为显同诸人故。四欲令弟子如法学受用四种命缘故。五欲令他学知足行故。六令他起正勤方便故。七为成熟他善根故。八欲显自身无染着故。九为治正法恭敬心故。十为圆满本愿生故。若如来由此义故食。于四食中是何食。是第四食。四食者。一非清净依止住食。谓段等四食。令欲界众生身得相续住。欲界众生具见修二缚故。依止不清净。此依止由四食得住。故名非清净依止住食。二净不净依止住食。谓业识触三食。令色无色界众生身得相续住。此二界众生已离下界惑。未离自地及上界惑故。依止亦净不净。此依止由三食得住故。名净不净依止住食。三清净依止住食。谓段等四食。令声闻缘觉身得相续住。二乘人三界惑已尽故。依止清净。此依止由四食得住。故名清净依止住食。四能显依止住食。段等四食悉是诸佛食。何以故。诸佛由此食故显自身得住于世。为生长施主净信。为因功德善根故。此食不作如来食事。如来食时。诸天为受施诸众生。是如来意所许故。众生由此食当得成佛。为令众生得成佛故。如来示现以手触食。如此等义悉是甚深

论曰

  无异亦无量　　无数量一事
  最坚不坚业　　无上应三身

论曰。无异亦无量

释曰。此下一偈明第二甚深。此甚深中复有三种甚深。一安立二数三业。此句明安立甚深。诸佛法身无差别故无异。众多依止法。证得此法身故无量

论曰。无数量一事

释曰。此句明数甚深。三乘众生无有数量。于中诸佛一事

论曰。最坚不坚业无上应三身

释曰。此两句明业甚深。诸佛有三身相应。实体常住故称无上。由应身如来业坚固。不可改转。以真实故。由化身如来业不坚固。由权以方便引出二乘。后以应身。教彼修菩萨道故

论曰

  无一法能觉　　一切无不觉
  一一念无量　　有不有所显

论曰。无一法能觉

释曰。此下一偈明第三正觉甚深。人法二非有。所觉既无故能觉亦无

论曰。一切无不觉

释曰。诸佛由假名故无非是佛。是故无一非觉。觉此法云何

论曰。一一念无量

释曰。一一刹那。无量诸佛正觉真如。若尔诸佛与真如为一为异。若一则无觉。若异则无真如

论曰。有不有所显

释曰。一切法名有不有。谓一切法空。诸佛是诸法空所显。是故不可说能觉。不可说不觉

论曰

  无欲无离欲　　依欲得出离
  已知欲无欲　　故入欲法如

论曰。无欲无离欲

释曰。此下一偈明第四离欲甚深。由欲不有故如来无欲。从本无欲故亦无离欲。若欲是有可有离欲。欲既本无故无离欲

论曰。依欲得出离

释曰。由诸菩萨永除上心欲。但留随眠欲故。诸菩萨得出离成佛。何以故。苦不留此随眠欲则同二乘涅槃。若不除上心欲。则与凡夫不异。如无上依经说。菩萨作是念。诸惑本来不入众生自性清净心。诸惑唯是客尘自分别所起。我今有能。为除诸众生客尘烦恼。能说如理正教。由此念菩萨不起下劣心。菩萨由此念。于众生生贵敬心。诸菩萨复作是念。诸惑无力无能。何以故。诸惑无真实依止。但虚妄分别诸惑。如理正思惟所观。不更起乖违。是故我等应作如此如此观。由此观诸惑不更生染着。若诸惑无复染着。是为最善。非是染着。若我爱惑染着。我云何能为众生解烦恼系缚。说如理正教。此惑能令生死相续。与善根相应。成熟众生。是故我今应摄留此惑

论曰。已知欲无欲故入欲法如

释曰。菩萨见欲是分别性故欲不有。欲无相性即是欲法真如。菩萨知欲不有。得入此真如故。于欲得出离

论曰

  诸佛过五阴　　于五阴中住
  与阴非一异　　不舍阴涅槃

论曰。诸佛过五阴于五阴中住

释曰。此下一偈明第五灭阴甚深。诸佛已过色等五取阴。由不得五阴。于阴法如中住

论曰。与阴非一异

释曰。诸佛已舍阴分别。依他性与阴非一非异。何以故。佛所住五阴真如。是分别依他阴家法故不异。由此义虽一非不异。真如是清净境界。阴非清净境界故非一

论曰。不舍阴涅槃

释曰。由与阴真如永相应。无舍离义。故如来般涅槃最胜

论曰

  诸佛事相杂　　犹如大海水
  我已正应作　　他事无是思

论曰。诸佛事相杂犹如大海水

释曰。此下一偈明第六成熟甚深。诸佛于众生共同利益事。譬如众流入于大海。同为龟鱼等受用。如此诸佛共入法界。真如平等作利益事。成熟众生

论曰。我已正应作他事无是思

释曰。我已作他利益事。正作当作。于三世中并无作意思量。虽不作意。利益事如法得成。譬如摩尼宝及天鼓。无有作意而所作事成

论曰

  由失尊不现　　如月于破器
  遍满诸世间　　由法光如日

论曰。由失尊不现如月于破器

释曰。此下一偈明第七显现甚深。诸佛于世间不显现。而世间说诸佛身常住。若身常住云何不显现。譬如于破器中水不得住。由水不住故。于破器中实有月不得显现。如此诸众生无奢摩他软滑相续。但有过失相续。于彼实有诸佛亦不显现。水譬奢摩他软滑性故。若佛不显现可无佛耶

论曰。遍满诸世间由法光如日

释曰。若诸佛于非有过失众生所见。亦恒作诸佛正事。说三乘十二部经。犹如光明。定是诸佛应作下种成熟解脱等诸利益事。如世间中生盲人。虽不见日日光恒照一切色像。为令有目者得见故

论曰

  或现得正觉　　或涅槃如火
  此二实不有　　诸佛常住故

论曰。或现得正觉或涅槃如火

释曰。此下一偈明第八菩提般涅槃甚深。诸佛有处现得正觉。有处现般涅槃。譬如火性有处然有处灭。诸佛亦尔。有诸众生已成熟。如来于彼现般涅槃。于未成熟现得正觉。为令彼得成熟及解脱故。譬如火性由种类是一。法身亦尔。由真如性是一

论曰。此二实不有诸佛常住故

释曰。菩提般涅槃为二。但变异他心令他谓二体。实不有。由如来法身常住无前后故

论曰

  如来于恶事　　人道及恶道
  于非梵行法　　住第一住我

释曰。此一偈明第九住甚深。诸佛如来住最胜住。住最胜我。诸佛若住不离此二处。或住最胜住。或住最胜我。恶事谓一切不善法。如来于不善法恒住最胜住。最胜住谓真空定。即是圣住。众生若在人道中。若在恶道中。如来缘彼众生住。或由第四定。即是天住。谓最胜住。或由大悲即是梵住。谓最胜住。于非梵行法。谓六尘染着。此中佛住最胜我。最胜我即法界清净。如来恒观六尘空为体为境。即是佛住

论曰

  佛一切处行　　亦不行一处
  于一切生现　　非六根境界

论曰。佛一切处行

释曰。此下一偈明第十显现自体甚深。如来后智。于善恶无记法中遍满恒行

论曰。亦不行一处

释曰。由无分别智。离智境界不可分别。故无一处行。复次由化身无处不行。由法身应身无有行处

论曰。于一切生现非六根境界

释曰。诸佛如来由化身。于一切众生中显现具相。诸佛由化身。乃至地狱道等众生亦见。在彼受生为化度彼故。由诸佛不现似变化性。彼众生虽见不能了别。谓是已同类故。佛化身非地狱等众生六根境界

论曰

  诸惑已灭伏　　如毒咒所害
  由惑至惑尽　　佛证一切智

论曰。诸惑已灭伏如毒咒所害

释曰。此下一偈明第十一灭惑甚深。诸惑谓见修烦恼。于菩萨地中先已灭尽。余心烦恼虽复未灭。由智念所伏废其功用。譬如众毒咒力所害无复本能。心惑亦尔。智念所守。不能复生二惑染污

论曰。由惑至惑尽佛证一切智

释曰。诸菩萨留随眠惑为助道分。不同二乘速般涅槃。由此事故修道究竟。得习气灭尽及证圆智

论曰

  谛惑成觉分　　生死为涅槃
  得成大方便　　故佛难思议

论曰。谛惑成觉分

释曰。此下明第十二不可思议甚深。若由留惑故得惑尽者。二乘集谛成菩萨觉分。如二乘觉分能灭彼集谛。菩萨用彼集谛以灭心惑。故成觉分

论曰。生死为涅槃

释曰。若集谛是觉分。苦谛即是涅槃。何以故。诸菩萨在生死不被染污。起自他两利皆得圆满譬如二乘在有余涅槃。不为二惑所染污。能得自利

论曰。得成大方便故佛难思议

释曰。在因位得大方便。谓般若大悲。在果位得大方便。谓三身。法身是自利方便。余二身是利他方便。是故如来不可思议

论曰。由此义故十二种甚深。应知。谓生不住业住甚深。安立数业甚深。正觉甚深。离欲甚深。阴灭甚深。成熟甚深。显现甚深。菩提般涅槃显现甚深。住甚深。显现自体甚深。灭惑甚深。不可思议甚深

释曰。佛有三身。诸菩萨若念佛应缘何身。应缘法身

论曰。诸菩萨缘法身忆念佛。此念缘几相

释曰。法身有无量甚深道理。若缘法身应缘几相

论曰。若略。说诸菩萨依法身。修习念佛有七种相

释曰。此七相是法身正用。即是法身圆德。为显念佛须缘此圆德故。略说七相。一诸佛圆德属自心。由六通自在故。二此德常住是真实善故。三最无过失灭习气尽故。四无惓无难无功用故。五受大法乐由诸土清净故。六无苦无难无染障故。七有大事用平等利他故。若菩萨忆念此七种圆德。则能通达法身。须依法身修习念佛者。为显学一切观行门皆缘真如得成。若不缘真如则观行不清净

论曰。何等为七。一诸佛于一切法。至无等自在

释曰。三世诸佛于六通境得最极自在。同类人不能为碍。下类人非所能及。在有心无心位中恒不废。以修习成熟故。故名自在。非声闻独觉菩萨所得。又于世间无可譬。故名无等

论曰。如此修习念佛

释曰。令此念与法身成一。故名修习

论曰。于一切世界。至得无碍无边六通智故

释曰。诸佛成就六通。于十方世界无能沮损。无有限极。不同二乘有碍有边故。如来通慧自在无等

论曰。此中说偈

释曰。若诸佛于一切法有无等自在。云何一切众生不悉般涅槃。为释此难是故说偈。此偈为显此因由此因故彼不般涅槃

论曰

  被障因不具　　一切众生界
  住二种定中　　诸佛无自在

论曰。被障因不具

释曰。一切众生若有业等诸障。诸佛于此位中不能令彼般涅槃。通慧由被障故不得自在。若众生无涅槃性。名因不具。诸佛于此位中。不能令彼般涅槃。通慧亦无自在。无涅槃性。谓贪着生死不信乐大乘

论曰。一切众生界。住二种定中。诸佛无自在

释曰。众生界。谓四大空识六界是实。依此六界假立众生。众生是假名。有六道差别故言一切。如此众生若在二种定中。一所作业定。二受果报定作业定。谓凡夫所作十恶等。业决定应感四恶道报。果报定。谓极钝根颠狂众生。及正受四恶道报。如来于此众生亦无自在。何以故。以无外缘故

论曰。二如来身常住

释曰。以十种因。共证法身及众德常住三因。证法身。七因证余身。三因证法身者如论

论曰。由真如无间解脱一切垢故

释曰。此即三因中一因。真如谓道后真如。无间位即佛金刚心。能灭最后微细无明。及无有生死苦集二谛。故言解脱一切垢。此无垢清净真如是常住法。诸佛以此为身故。诸佛身常住。由此身常住。依此身有众德故。众德亦常住。此常住以真实性为相

论曰。三如来最无失一切惑障。及智障永相离故

释曰。一切有失无失众生中。如来最无失。由过失因缘已灭尽故。现在已灭未来不生。故言永相离

论曰。四一切如来事无功用成

释曰。作意名功用。缘三世起。谓我已作正作当作。离如此作意名无功用。但由本愿力。所欲作事。自然皆成

论曰。不由功用。恒起正事永不舍故

释曰。若由功用有正事。则有起不起。以不由功用。是故恒起。由本愿无尽故永不舍。以众生不尽故。本愿不尽

论曰。五如来大富乐位

释曰。大富由外财大乐由正法

论曰。一切佛土最微妙清净。为富乐故

释曰。净土中有八不可得二可得。故名最微妙清净。八不可得者。一外道。二有苦众生。三生姓家富等差别。四恶行人。五破戒人。六恶道。七下乘。八下意下行诸菩萨。二可得者。一最上品。意行诸菩萨。二诸如来显现于世。所住为最微清净。能住为最妙清净

论曰。六如来最无染着

释曰。上心惑为染。随眠惑为着。又约惑障为染。智障为着。又烦恼有二相。一以喜为相。二以忧为相。欲慢见等以喜为相嗔疑无明等以。忧为相。喜相惑为染。忧相惑为着。二惑皆灭尽故名无染着

论曰。出现世间非一切世法所染。如尘不能染空故

释曰。因立故名出世。果成故名现世。又自利圆满故名出世。利他圆满故名现世。或佛出世未现于世。如已成道未转法轮。若转法轮。世间方能了别是佛是一切智。世间所了别故名现世。如来虽受用衣食等四缘。为生长众生善根。非为资益自身。于此缘中不生忧喜。故不为世法之所染污。空以非有为体。体无碍故不为有物所染。如来亦尔

论曰。七如来于世间有大事用

释曰。如来出世以化身成道。乃至般涅槃名大事。此身所作众生利益事名用

论曰。由现成无上菩提及大般涅槃。未成熟众生令成熟。已成熟众生令解脱故

释曰。为未下种及未成熟众生令下种成熟故。现成菩提。为已成熟未解脱众生。令解脱故。现般涅槃

论曰。此中说偈

释曰。此中说二偈。重明七相。显法身七种圆德

论曰

  随属如来心　　圆德常无失
  无功用能施　　众生大法乐

论曰。随属如来心圆德

释曰。诸佛圆德。谓六通等。但属自心不关外缘

论曰。常

释曰。此圆德由依常住法身真实善为性故。众德皆常

论曰。无失

释曰。由法身离一切障。所依无失。故能依亦无失

论曰。无功用

释曰。由修因及本愿成熟。所作佛事皆自然成。无惓无难故言无功用

论曰。能施众生大法乐

释曰。由得净土自在。有大人能受大法。得弘自如理行。令他如理行故名法乐

论曰

  遍行无有碍　　平等利多人
  一切一切佛　　智人缘此念

论曰。遍行无有碍

释曰。于八世法。如来后智恒分别此事。于中无忧喜心故。遍行无碍。若有碍则有苦。无碍故安乐。诸佛虽行六尘。过于言说。以离有无执故

论曰。平等利多人

释曰。凡夫二乘新行菩萨。及深行菩萨名多人。如来能平等利益。说大富行善道行安乐行自利行二利行。此即是有大事用

论曰。一切一切佛智人缘此念

释曰。一切者即目。智人谓诸菩萨。诸菩萨缘此七相。念一切佛法身

摄大乘论释卷第十四摄大乘论释卷第十五

        世亲菩萨释

        陈天竺三藏真谛译

    释智差别胜相第十之三

论曰。复次诸佛如来净土清净。其相云何应知

释曰。前于七念中。明如来大富乐即是净土。前但说八人不可得二人可得。未明不可得及可得所在之处。今欲显示此处故。问净土相

论曰。如言百千经菩萨藏缘起中说

释曰。总举诸经故称如言。菩萨藏中有别净土经。经有百千偈。故名百千经。又华严经有百千偈。故名百千经。于此经缘起中广说净土相。如此净土文句显何功德

论曰。佛世尊在周遍光明七宝庄严处

释曰。一金二银三琉璃四摩娑罗五阿输摩竭婆六因陀罗尼罗七卢嬉胝柯目多。此一一宝光明皆周遍一切处。此处以七宝为庄严。佛住其中

论曰。能放大光明。普照无量世界

释曰。此明七宝光明所照之处。释周遍义。此两句明色相圆净

论曰。无量妙饰界处各各成立

释曰。此庄严希有无等故言妙饰。有众多妙饰故言无量。所游行地为界。所居地为处。一一界一一处。庄严具足故言成立。此句明形貌圆净

论曰。大域边际不可度量

释曰。径度为度。周围为量。一一佛净土边际。非凡夫以由旬等数所能度量。此句明量圆净

论曰。出过三界行处

释曰。三界集谛为行。三界苦谛为处。净土非二界苦集所摄。故言出过三界行处。此句明处圆净。若非苦集谛摄。以何因得生。以何法为体

论曰。出出世善法功能所生

释曰。二乘善名出世。从八地已上乃至佛地。名出出世。出世法为世法对治。出出世法为出世法对治。功能以四缘为相。从出出世善法功能。生起此净土故。不以集谛为因。此句明因圆净。何者为出出世善法。无分别智。无分别后智所生善根。名出出世善法

论曰。最清净自在唯识为相

释曰。菩萨及如来唯识智。无相无功用故言清净。离一切障无退失故言自在。此唯识智为净土体故。不以苦谛为体。此句明果圆净

论曰。如来所镇

释曰。如此相净土。如来恒居其中。最为上首故言镇。此句明主圆净

论曰。菩萨安乐住处

释曰。自受行正教。教他受行正教名安乐。菩萨于净土助佛助道。具此二事故名安乐住处。此句明助圆净

论曰。无量天龙夜叉阿修罗迦楼罗紧那罗摩睺罗伽人非人等所行

释曰。净土中实无此众生。欲令不空故。佛化作如此杂类。此句明眷属圆净。若有如此众生诸菩萨等。皆何所食

论曰。大法味喜乐所持

释曰。大乘十二部经名大法。真如解脱等为味。缘此法味生诸菩萨喜乐。长养诸菩萨五分法身。此句明持圆净。餐此法味作何等业

论曰。一切众生。一切利益事为用

释曰。凡夫三乘名一切众生。随其所能为说正教。令如说修行。离四恶道。离生死。离二乘自爱行。名一切利益。此句明业圆净。若菩萨于众生行如此业。能行及行处得何利益

论曰。一切烦恼灾横所离

释曰。三界集谛名一切烦恼。三界苦谛名一切灾横。此二悉离能行行处。此句明利益圆净。若离如此法。有余怖畏不

论曰。非一切魔所行处

释曰。净土中无阴魔烦恼魔死魔天魔故。离一切怖畏。此句明无怖畏圆净。若净土中无一切怖畏。六根所受用法悉具有不

论曰。胜一切庄严。如来庄严所依处

释曰。非唯是有一切所受用具最胜无等。是如来福德智慧行圆满因所感。如来胜报依止此处。是故最胜。此句明住处圆净。净土中以何法为出入路

论曰。大念慧行出离

释曰。大乘正法名大法。于大法中闻慧名念。思慧名慧。修慧名行。此三于净土是往还道。故名出离。此句明路圆净。若有此路为乘何法

论曰。大奢摩他毗钵舍那乘

释曰。大乘中五百定名奢摩他。如理如量智名毗钵舍那。以此二为乘。此句明乘圆净。若有此乘从何门入

论曰。大空无相无愿解脱门入处

释曰。于大乘中三解脱门。一体由无性故空。空故无相。无相故无愿。若至此门得入净土。此句明门圆净。世间世界地轮依水轮。水轮依风轮。净土为依何法

论曰。无量功德聚所。庄严大莲花王为依止

释曰。以大莲华王。譬大乘所显法界真如。莲华虽在泥水之中。不为泥水所污。譬法界真如虽在世间。不为世间法所污。又莲花性自开发。譬法界真如性自开发。众生若证皆得觉悟。又莲花为群蜂所采。譬法界真如为众圣所用。又莲花有四德。一香二净三柔软四可爱。譬法界真如总有四德。谓常乐我净。于众花中最大最胜故名为王。譬法界真如于一切法中最胜。此花为无量色相功德聚所庄严。能为一切法作依止。譬法界真如为无量出世功德聚所庄严。此法界真如能为净土作依止。复次如来愿力所感宝莲花。于诸花中最大最胜故名王。无量色相等功德聚所庄严。能为净土作依止。此句明依止圆净。净土中何法是如来住处

论曰。大宝重阁。如来于此中住

释曰。此别明如来住处。如世间受用器世界。有无量过失。若受用净土有何功德

论曰。如此净土清净显色相圆净。形貌量处因果主助眷属持业利益无怖畏住处路乘门依止圆净。由前文句。如此等圆净皆得显现。复次受用如此净土清净。一向净一向乐一向无失一向自在

释曰。恒无杂秽故言一向净。但受妙乐无苦无舍故言一向乐。唯是实善无恶及无记故言一向无失。一切事悉不观外缘。皆由自心成故名一向自在。复次依大净说一向净。依大乐说一向乐。依大常说一向无失。依大我说一向自在。菩萨若忆念如来富乐。应如此知

论曰。复次诸佛法界。恒时应见有五业

释曰。此中应明法身业。而言诸佛法界者。欲显法身含法界五义故。转名法界。五义者。一性义。以无二我为性。一切众生不过此性故。二因义。一切圣人四念处等法。缘此生长故。三藏义。一切虚妄法所隐覆。非凡夫二乘所能缘故。四真实义。过世间法。世间法或自然坏。或由对治坏。离此二坏故。五甚深义。若与此相应。自性成净善故。若外不相应。自性成[穀-禾+卵]故。由法身含法界五义。诸菩萨应见法身恒与五业相应。无时暂离

论曰。一救济灾横为业。由唯现盲聋狂等疾恼灾横能灭除故

释曰。此明大悲力。若定业报众生。如来于中则无自在。此如前释。若不定业报。或现在过失。或有对治业。如此众生若至佛所。如来作意及不作意。皆能令离此等灾横

论曰。二救济恶道为业。从恶处引拔。安立于善处故

释曰。此明正行力。如来作意及不作意。一切众生若至佛所。无不息恶行善

论曰。三救济行非方便为业。诸外道等加行非方便。降伏安立于佛正教故

释曰。此明威德力。诸外道多行非方便。若常见外道多行苦行。以计有未来生故。断见外道多行乐行。以计无未来生故。或思惟自在天为道。或思惟我为道。或思惟自性为道。或思惟我自性中间为道。如此等悉是非方便行。如来以通慧导。降伏其高慢。以记心导降伏其不信。以正教导降伏其邪见。既降伏已。随其根性安立于三乘正教中

论曰。四救济行身见为业。为过度三界。能显导圣道方便故

释曰。此明方便力。一切三界众生无离身见。身见者。若为多物所成。体是无常故名身。为五阴等和合所成故名多物。未有有。已有灭。故名无常。外道于多计一。于无常执常。谓是一是常为我。为破此见亦非一非常。故名身见。若离身见。则得过三界集度三界苦。说正教名显。生彼三慧为导。苦法忍已去乃至阿罗汉果名圣道。从出家受戒乃至世第一法。为圣道方便。显道令修方便得圣道。又如来令众生离身见出三界。此未是真实圣道。但是圣道方便先显导令修此方便圣道。为得真实圣道缘由

论曰。五救济乘为业。诸菩萨欲偏行别乘。及未定根性声闻。能安立彼为修行大乘故

释曰。此明真实教力。乘有人法。人有大乘人有小乘人。法有方便乘法有正乘法。转方便乘修治正乘故。名救济乘。摩诃般若经说。乘有三义。一性义二行义三果义。二空所显三无性。真如名性。由此性修十度十地名行。由修此行。究竟证得常乐我净四德名果。又中边论说乘有五义。一出离为体谓真如。二福慧为因能引出故。三众生为摄。如根性摄令至果故。四无上菩提为果。行究竟至此果故。五三惑为障。除此三惑。前四义成故。诸菩萨在十信位中。修大行未坚固。多厌怖生死。慈悲众生心犹劣薄。喜欲舍大乘本愿修小乘道。故言欲偏行别乘。小乘说声闻。若得信等五根不名定根以未得圣故。若得未知欲知等三根则名定根。以得圣故。若至顶位不名定性。以不免四恶道故。若至忍位名为定性。以免四恶道故。若依小乘解。未得定根性。则可转小为大。若得定根性则不可转。如此声闻。无有改小为大义。云何得说一乘。今依大乘解。未专修菩萨道。悉名未定根性故。一切声闻皆有可转为大义。安立如此大小乘人。令修行大乘

论曰。于如此五业。应知诸佛如来共同此业

释曰。世间众生于五业不同。诸佛五业无不同义

论曰。此中说偈

释曰。欲显众生不同业诸佛同业是故说偈

论曰

  因依事意及诸行　　异故世间许业异

释曰。此明众生五业不同。一因二依三事四意五行。因不同者。如别因成地狱。别因成天。别因成人。畜生饿鬼等亦尔。由因不同故作业不同。依不同者依即彼身。由身不同故作业不同。事不同者。如人道中或商估或耕种或事王。如此等事不同。故业不同。意不同者。一切众生根欲性名意。此等种种不同故业不同。诸行不同者。色等五阴名诸行。色阴中如火所作异水等所作。受所作异想等所作。故业不同。由此五事。此作非彼作。世间愚智皆许其业有异

论曰

  此五种异于佛无　　是故世将同一业

释曰。前五种事于诸佛悉无。何以故。诸佛因同。同修福德智慧行故。诸佛依同。同一法身故。诸佛事同。同有自利利他事故。诸佛意同。同有利益安乐众生意故。诸佛无诸行同。同出离有为法故。由无此五异故皆同一业。大悲引导众生。俱向涅槃故名世将

论曰。若尔声闻独觉非所共得。如此众德相应诸佛法身。诸佛以何意故。说彼俱趣一乘与佛乘同

释曰。若诸佛无前五异。由法身五业是同。二乘人有五业异。不得法身。无五业同。如来为何义故。说二乘人同趣一乘皆得成佛

论曰。此中说偈

释曰。为显说一乘意。是故说偈。前偈以了义说一乘。后偈以密义说一乘

论曰

  未定性声闻　　及诸余菩萨
  于大乘引摄　　定性说一乘

释曰。有诸声闻等。于小乘根性未定。欲引令信受大乘。摄令修行大乘。谓未得令得。已得令不退。云何彼舍小乘道。于大乘般涅槃。佛为此意故佛说一乘。引摄令入住大乘

论曰。及诸余菩萨于大乘引摄

释曰。有诸菩萨于大乘根性未定。云何安立彼于大乘。令不舍大乘于小乘般涅槃。为此意故佛说一乘。引摄令入住大乘

论曰。定性说一乘

释曰。有诸菩萨。于大乘根性已定。无退异意。为此菩萨故说一乘

论曰

  法无我解脱　　等故性不同
  得二意涅槃　　究竟说一乘

释曰。由法等无我等解脱等故说一乘。此中法即真如。一切三乘皆不离真如。是彼所应乘法。由真如法同故说一乘一切法唯法无人。若人实无云何分别。此人是声闻。此人是独觉。此人是菩萨。如此分别不称道理。由无我义同故说一乘。三乘人同解脱惑障。如佛言解脱与解脱无有差别。由灭惑义同故说一乘三义。同故名等

论曰。性不同

释曰。有二乘人。于自乘位根性不同。此人虽求二乘道。未得二乘。由二乘根性未定故。可转作大乘根性。为化此人故说一乘

论曰。得二意涅槃

释曰。二意中初名于众生平等意。诸声闻等人。于一切众生作如此意。彼即是我。我即是彼。由此意故。谓彼得正觉即是我得正觉。我得正觉即是彼得正觉。如我应解脱自身。亦应如此解脱众生。为如此意故说一乘。后名于法如平等意。诸声闻等人。如来于法华经中。为其授记已得佛意。但得法如平等意。未得佛法身。若得此法如平等意。彼作是思惟。如来法如即是我法如。由如此意故说一乘。复次于法花大集中。有诸菩萨名同舍利弗等。此菩萨得此意。佛为授记故说一乘。复次佛化作舍利弗等声闻。为其授记欲令已定根性声闻。更练根为菩萨。未定根性声闻。令直修佛道。由佛道般涅槃。如佛言曰我今觉了过去世中。已经无量无数劫依声闻乘般涅槃。欲显小乘非究竟处。令其舍小求大故。现为此事。由如此义故说一乘

论曰。究竟说一乘

释曰。若说乘义唯一乘是乘。所余非乘。若过此乘。无别行故。余乘有上所谓佛乘。由此义故。若彼乘比此乘。此乘无等。彼乘失没故名究竟。由如此义故说一乘

论曰。三世诸佛若共一法身。云何世数于佛不同

释曰。诸佛既同得一法身。云何有三世。复有众多。若有三世及众多。云何言一

论曰。此中说偈

释曰。有因证诸佛或一或多。今欲显示此义。是故说偈。云何或一

论曰

  于一界中无二故　　同时因成不可量
  次第成佛非理故　　一时多佛此义成

释曰。一法界平等。诸佛是法界所显。由法界一故诸佛是一。复次一时中于一世界。无二佛俱出故说或一。云何或多

论曰。同时因成不可量

释曰。于一时有无数诸菩萨。同时修福德智慧二行。因已成熟。若不同时得无上菩提果。则修行唐捐。以诸菩萨修因。同时成熟同时得果故。一时有多菩萨成佛不可度量。若言因虽俱成。必前后次第成佛。是义不然。何以故

论曰。次第成佛非理故

释曰。诸菩萨不作是愿。我当相待次第成佛。由此愿故因虽成熟故待次第。既无此愿。云何因俱成熟。不同时得果。云何多人俱时修因不观次第。得果之时必观次第。故此义非理

论曰。一时多佛此义成

释曰。此句明一时中。十方世界有无量佛。同时出世。若言有佛经证于世间。但一如来无俱出义。是义不然。经言无处无位非前非后。二如来阿罗诃三藐三佛陀。出现于世。有处有位。若一如来出现于世。譬如二转轮王不得同时共生一处。此经为当说大三千世界无二如来。为当说一切世界无二如来。宜应详释。此经说一切世界。何以故。不应限碍世尊胜能。唯世尊一人于一切处有胜能。若一佛不能于余处化度众生。余佛亦应不能。复有经言。舍利弗。若人至汝所作如是问。大德舍利弗。于今时有沙门婆罗门。与沙门瞿昙平等平等于无上菩提不汝得此问。当云何答。舍利弗言。若有人至我所作如是问。我当如是答。善男子。于今时无沙门婆罗门与世尊平等平等于无上菩提。何以故。世尊。我从世尊吉祥口闻。从世尊所得。无处无位。无前无后。二如来并出于世。有处有位唯一如来出现于世。若尔云何于梵王经中。佛说但大三千世界中我自在成。如此言教别有密意。若世尊不作意。但在自性中无功用心。于大三千世界。言语光明五识等事自然得成。若有功用心。无边世界是如来境。复有余部说。于余世界别有诸佛出世。何以故。有无量菩萨同时修行六度。因已成熟不可数量。无有道理诸佛于一处一时共生。无有别法能碍彼于余处出世。是故定知于余世界别有诸佛出世。此经证诸佛不同一时出世譬。如转轮王。今当详辩此经此经若说一世界一佛出世。不妨余处。若说一切世界一佛出世。余转轮王于别世界不应得生。既说转轮王不俱生。譬诸佛。汝若忍许余世界有别转轮王。云何不忍许诸佛出余世界。佛出于世是大吉祥。何故不许于多世界有多佛出世。此无过咎。世间有多众生。与最胜利益相应故。云何于一世界。二佛不俱出现。以无用故。又随宿愿故。诸菩萨昔作是愿。愿我于盲闇世界无人将导处。得成正觉。为作光明为彼将导。由此愿故无二佛俱出。若尔何故唯说一佛。不说多佛。为令众生起极尊重。及急修行故。何以故。若但于一佛则起极尊重心。谓他无如此德。亦能急修行如来正教。何以故。佛若涅槃。我等则无归依处。故偈言一时多佛此义成

论曰。云何应知。诸佛法身非一向涅槃。非非一向涅槃

释曰。有诸师说。诸佛如来不永般涅槃。别部声闻乘人说。诸佛如来永般涅槃。此二执非了义说。是密意所显

论曰。此中说偈

释曰。为显此义是故说偈

论曰

  由离一切障　　应作未竟故
  佛一向涅槃　　不一向涅槃

释曰。诸佛永解脱惑障及智障。是故一向涅槃。如来应作正事未究竟。谓未成熟令成熟。已成熟令解脱。此二事不可休废。是故如来不一向涅槃。若如二乘一向涅槃。如来本愿但有愿无果。若了义说。应言有涅槃有不涅槃

论曰。云何受用身不成自性身

释曰。应身不成法身是道理。应身成法身非道理。此是非义云何可知

论曰。由六种因故

释曰。有六种因。证是非义

论曰。一由色身及行身显现故

释曰。十入名色身。受等名行身。诸佛以真如法为身。于法身中色行不可得。应身则不尔。此义云何。一切智大定大悲等。恒河沙等如来功德。虽依法身。若显现时不离化身此化身似佛异一切众生。为应身事相。故色行于应身有。于法身无。是故应身不成法身。是道理成则非道理

论曰。二由无量大集处差别显现故

释曰。应身有差别。由佛弟子大集轮差别故。应身能集菩萨弟子众。法身不尔。何以故。大通慧能集菩萨众。大通慧即是应身。能说正法立义释疑。此是般若功用。般若即是应身。日夜六时观众生根性。往彼为作利益事。是大悲功用。大悲即是应身。若以应身即是法身。则不能集化菩萨。若法身即是应身。则诸佛非常住。由此差别显现故。应身不成法身

论曰。三随彼欲乐见。显现自性不同故

释曰。彼为无量菩萨。欲乐观如来众德。但依应身观。随其欲乐。所见众德显现不同。如此应身自性不定。以多种类故。法身不尔。是故应身不成法身。复有别经。为证应身随众生欲乐。现相不同。何以故。有诸众生于应身。欲见黄色青色等。及乐受舍受等。有识无识等。种种不同。皆悉得成。此经显应身自性不定。法身则不尔。故应身不成法身

论曰。四别异别异见。自性变动显现故

释曰。有一众生。先见此应身别异相显现。此众生后见此应身更有别异相显现。如一人见不同。余众生见亦尔。为成熟此众生善根故。初现粗相。次现中相。后现微妙相。应身有此变动相。法身不尔。故应身不成法身

论曰。五菩萨声闻天等。种种大集相杂和合时。相杂显现故

释曰。应身恒时。由菩萨等种种大集相杂听法时。应身有三相杂。一一切众生各各见佛。皆对其前故名相杂。二随无量众生色相不同。佛如其色相。故名相杂。三随其根性所宜。大智大定大悲有无量事用。故名相杂。应身有此相杂。法身不尔。若以法身为应身。佛无利益众生事。若以应身为法身。佛无现世安乐义。以恒喧动离寂静故。是故应身不成法身

论曰。六阿黎耶识及生起识见转依。非道理故

释曰。阿黎耶识及生起识。即是受用身。此二识转依名法身。若自性身即是受用身。转二识依复得何身。由此非道理故。受用身不成自性身。若受用身即是自性身。则无大智等众德。由不无众德故。自性身不成受用身

论曰。是故受用身。无道理成自性身

释曰。由此六因。证知是道理非道理义

论曰。云何变化身不成自性身

释曰。变化身不成法身。是道理。变化身成法身。非道理。是非义。云何可知

论曰。由八种因故

释曰。有八种因证是非义

论曰。一诸菩萨从久远来。得无退三摩提于兜率陀天道及人道中受生。不应道理

释曰。菩萨从得初地乃至十地。经三十大劫阿僧祇。得五百不退定。久已离欲三界。无有道理生天道中。何况有道理于人间。在释迦王种中生。为化下众生故。现受人身。此身无因而于世间是有。故非果报身及自性身。但是变化身

论曰。二诸菩萨从久远来。恒忆宿住

释曰。菩萨从初地至十地。于长时中恒忆宿命。先所修得无量伎能。悉不忘失

论曰。方书算计数量印相工巧等论。行欲尘及受用欲尘中。菩萨无知不应道理

释曰。六十四种方土异书。乘除等十六种算计法。离乘除等十六种观。聚知数多少。观聚知量多少。以印印物为相。或增或减。或守或相六十四能十八明处。六十四王伎秘巧术法。未得令得已得令长。已长付嘱善人。为行欲尘。于六尘中。如歌舞和合衣着调鼎等事。名受用欲尘。菩萨于无量劫来。常忆宿世所修一切伎能。悉无忘失。无有道理于此等事不知不忆。为化众生。示下品人可转成上品故。显自身未有此能方须修学。是故此身是变化身。非自性身及受用身

论曰。三诸菩萨从久远来。已识别邪正法教。往外道所事彼为师。不应道理

释曰。菩萨于三十三大劫阿僧祇。于正行中修正勤。福德智慧行悉已圆满。无有道理于最后身。不能了别邪正说异。若无此知。得佛之时为知何法。为欲降伏诸外道故。现为此事。是故此身是变化身。非余二身

论曰。四诸菩萨从久远来。已通达三乘圣道正理。为求道故修虚苦行。不应道理

释曰。诸菩萨从三十三大劫阿僧祇来。在十解十行。初地已通达三乘圣道正理。离断常执。不行苦乐邪行。是二乘圣道正理。舍有无执离一切分别。修无分别境智正行。是菩萨圣道正理。外道苦行能灭已得法。不能得未得法。于二世中但损无益。故名为虚。无有道理菩萨应习行此事。为化众生示修苦行。无有果报故。现行此事。是故此身是变化身。非余二身

论曰。五诸菩萨舍百拘胝阎浮提。于一处得无上菩提。及转法轮。不应道理

释曰。诸菩萨修道之时。遍满万亿阎浮提。成熟万亿阎浮提众生。成佛之时则应遍满受身。然果报身唯得有一。不得有多。若尔何故不别于一胜处受身。以化身遍一切处行化。无有道理舍万亿阎浮提。偏于一阎浮提成佛转法轮。为化众生令知佛出世故。现为此事。是故此身是变化身。非余二身

论曰。六若离显无上菩提方便。但以化身于他方作佛事。若尔则应于兜率陀天上成正觉

释曰。若汝执但于一阎浮提处。得无上菩提。余处则离入胎等方便。于余处唯现化身作佛事。云何不执如此菩萨。在兜率陀天上得无上菩提。于余处现化身作佛事。是故此身是变化身。非余二身

论曰。七若不尔。云何佛不于一切阎浮提中平等出现。若不于他方出现。无阿含及道理可证此义

释曰。若不于天中得菩提。则应遍得。而菩萨于一切四天下。不遍得无上菩提。但于一处得。无阿含及道理能证此义。是故此身是变化身。非余二身

论曰。八二如来于一世界俱现。此不相违。若许化身成多

释曰。一娑诃世界有二如来俱出世。此与义不相违。何以故。以许化身成多故。化身既多。处处有化身。此无所妨。是故此身是变化身。非余二身

论曰。由四天下摄一世界。如转轮王于一世界或一主。或别主俱生不应道理。诸佛亦尔

释曰。因此证可说。如此有一世界。在百拘胝世界中。于中不见佛。若汝说如此。则与经相违。有如此说。谓二佛不一时俱生大三千世界。譬如转轮王。此中汝应判此经。同转轮王义。如两转轮王于一世界不得俱生。不妨于余世界俱生。两如来俱生非道理。判义亦应如此

论曰。此中说偈

释曰。为显具相无上觉义故说此偈

论曰

  佛微细化身　　多入胎平等
  为显具相觉　　于世间示现

释曰。佛在兜率陀天上。下阎浮提受胎。是时中如来化作一切佛弟子。如净命舍利弗等受胎。若安立彼具相无上觉则得显现。若无下中二乘。则不得显佛是无上。若无二乘智慧浅狭。则不得显佛是具相。为显此义故化身出现于世。诸佛如来非一向涅槃。今当显示此义

论曰。有六种因。诸佛世尊于化身中不得永住

释曰。有六因证佛须舍化身

论曰。一正事究竟故。由已解脱成熟众生故

释曰。如来化身正事已究竟故。化身不永住。成熟众生令得解脱。是化身正事。众生既悉成熟解脱。故名正事究竟

论曰。二若已得解脱。求般涅槃。为令彼舍般涅槃意。欲求得常住佛身故

释曰。若已解脱惑障。求无余涅槃。为转其意欲示化身。非实有故舍化身。示别有常住法身是真实有。应转求小乘无余涅槃心。求常住法身故。化身不永住

论曰。三为除彼于佛所有轻慢心故。为令彼通达甚深真如法及正说法故

释曰。彼谓一切众生。计佛有生老病死等与已不异故。于如来起轻慢心。欲令众生识如来真实身及假名身。真身即真如法及正说法。正说法从真如法流出名正说身。此二名法身。此法最甚深难可通达。非下位人境界。若通达此身。则于如来起极尊重心。假名身即化身。示此身是分别所作非真实有故。化身不永住

论曰。四为令众生于佛身起渴仰心。数见无厌足故

释曰。若恒住一化身。众生始见生渴仰。后则歇薄。若色形改变种种希有。众生数见新新渴仰。则无厌足故。化身不永住

论曰。五为令彼向自身起极精进。由知正说者不可得故

释曰。若佛恒住化身。众生则不起难遭想。故如来舍化身。令其知佛不久住世。起极正勤。急度自身不观于他。又以自身证其是非。名向自身。故化身不永住

论曰。六为令彼速得至成熟位。向自身不舍荷负极精进故

释曰。前明为未修正勤令修正勤。此明若已修正勤令不舍正勤。修习定慧疾得圆满。故化身不永住

论曰。此中说偈

释曰。为摄前六因。令多忘失者易得忆持故。重说偈

论曰

  由正事究竟　　为除乐涅槃
  令舍轻慢佛　　发起渴仰心
  令向身精进　　及为速成熟
  诸佛于化身　　许非一向住

释曰。如来不永般涅槃。今当显示此义

论曰。为度一切众生。由发愿及修行。寻求无上菩提。一向般涅槃。此事不应道理

释曰。如来昔在愿乐地中。为度众生发诸胜愿。求无上菩提。于见等位中。为度众生修诸胜行。寻无上菩提。若得极果而舍众生般涅槃。不应道理。何以故

论曰。本愿及修行。相违无果故

释曰。菩萨昔为度众生。发愿及修行。令我当来常能利益一切众生。利益众生即愿行果。今得极果。若弃舍众生永般涅槃。则违发愿修行本意。愿行但有自利益果。无利益他果。由如来不永般涅槃。是故相应有果

论曰。复次受用身及变化身无常故。云何诸佛以常住法为身

释曰。若如来不永般涅槃。则如来以常住法为身受用身及变化身。不应是无常。若是无常。云何复言以常住法为身

论曰。由应身及化身。恒依止法身故

释曰。法身为二身本。本既常住。末依于本相续恒在。故末亦常住

论曰。由应身无舍离故

释曰。如来自圆德。及利益诸菩萨。此二事与如来恒不相离。此二事即是应身。故应常住

论曰。由化身数起现故

释曰。化身为度众生。乃至穷生死际。无一刹那时不相续。示现得无上菩提及般涅槃。何以故。所度众生恒有。如来大悲无休废故。是故化身亦是常住

论曰。如恒受乐。如恒施食。二身常住应如此知

释曰。为显二身常住故。引此二事为譬。如世间说此人恒受乐。此人恒施食。非受乐施食二事无间。名之为恒。由本及事二义不断故。名为恒。二身亦尔。由本及事二义不断故。名常住

论曰。若法身无始时。无差别无数量

释曰。若法身无始本有。于一切众生无差别。不可度量。诸佛由法身于利益他事。具足胜能。众生为得法身。何用精进修道

论曰。为得法身。不应不作功用

释曰。虽尔不应不作功用。无自然证得法身故

论曰。此中说偈

释曰。为释此难。是故说偈

论曰

  诸佛证得等无量　　是因众生若舍勤
  证得恒时不成因　　断除正因不应理

诸佛证得等无量是因

释曰。过去现在佛证得法身。证得无高下故言平等。所得功德无定齐限故言无量。如此证得。是众生求得法身正勤之因

论曰。众生若舍勤

释曰。此证得若是众生舍正勤因。如前所计。不须自作正勤由他得度故

论曰。证得恒时不成因

释曰。诸佛证得法身。一切是有。若离自正勤。此证得则不成自证得因。何以故。若是因者。从昔以来无复凡夫。皆由他得度故。既无此义。是故虽有证得。不成自因

论曰。断除正因不应理

释曰。正勤与证得相应名正因。若断除此二则不应道理。复次因有二种。一方便因。二正因。诸佛证得为方便因。以属他故。自修正勤为正因。以依自身故。若断除正因留方便因。此事不应道理。以不能成就自所愿故。复次有诸菩萨。慈悲庄饰相续。于众生起爱念心。皆如子想。不作此意。是众生利益事。愿他作我不作。常作是意。若他或作或不作。我必应作。若众生不应菩萨心作正勤。无得菩萨利益义。是故正勤。是证得法身第一正因。此因不可断除。若断除此因。由他得法身。无有是处

论曰。阿毗达磨大乘藏经中名摄大乘。此正说究竟

  由依佛言及道理　　说论为自得清净
  为利智信正行人　　为立正法令久住
  依灯电宝日月光　　如净眼人见众色
  依具智悲三解尊　　通达说论亦复尔
  若真实义应法句　　能除皮肉心烦恼
  诸显涅槃道功德　　此是圣言余悉非
  若乱心人作是说　　能显佛是无上师
  随顺涅槃道资粮　　顶戴此言如佛教
  世无慧人能胜佛　　具智通真理无余
  是佛自了法叵动　　若违正法由佛教
  若谤圣人及正法　　迷人见执之所作
  于此生智离三污　　如衣受染净非垢
  智钝离信及白法　　邪慢法灾不了执
  贪利邪见事法怨　　离胜下愿谤正法
  于火蛇怨及霹雳　　法伤可畏此非畏
  火等但断世间命　　无间可畏不由此
  若人数事诸恶友　　邪见五逆断善根
  思法速离无间苦　　谤法何因得解脱
  众宝界如觉德业　　我说句义所生善
  因此愿悉见弥陀　　由得净眼成正觉

如此十偈总义。为显此总义。重说三偈

  从此及为此　　由此是所说
  此流说四偈　　为显前五义
  守自身方便　　是故说二偈
  伤法因说一　　伤法果说二
  至大集法忍　　证无上菩提
  略明此三法　　是重说胜果

三藏法师翻讲论竟。说此三偈

  若思了义论　　智人信三宝
  由智信二根　　得入真如观
  故我依本记　　翻解摄大乘
  凡所生功德　　回向为三能
  供养佛法僧　　降伏邪行者
  救拔众苦难　　愿此能无穷

摄大乘论释卷第十五


摄大乘论序

    No. 1593 [Nos. 1592, 1594; cf. Nos. 1595-1598]

    摄大乘论序

夫至道弘旷。无思不洽。大悲平等。诱进靡穷。德被含生。理非偏漏。但迷涂易久。沦惑难息。若先谈出世。则疑性莫启。故设教立方。各随性欲。唐虞之前。图谍简少。姬周以后。经诰弘多。虽复制礼作训。并导之以俗法。而真假妙趣。尚冥然而未睹。故迹隐葱岭以西。教秘沧海之外。自汉室受命。方稍东渐爰及晋朝。斯风乃盛。梁有天下。弥具兴隆。历千祀其将半。涉七代而迄今。法兰导清源于前。童寿振芳尘于后。安睿骋壮思以发义端。生肇擅玄言以释幽致。虽并策分镳。同澜比泒。而深浅竞驰。照晦相杂。自兹以降。笃好逾广。莫不异轨同奔。传相祖习。而去取随情。开抑殊轸。慧恺志惭负槖。勤愧聚萤。谬得齿迹学徒禀承训义游寓讲肆。多历年所。名师胜友。备得咨询。但综涉疏浅。钻仰无术。寻波讨源。多所未悟。此盖虑穷于文字。思迷于弘旨。明发兴嗟。负心非一。每欲顺风问道。而未知厥路。有三藏法师。是优禅尼国婆罗门种。姓颇罗堕。名拘罗那他。此土翻译称曰亲依。识鉴渊旷。风表俊越。天才高杰。神辩闲纵。道气逸群。德音迈俗。少游诸国。历事众师。先习外典。洽通书奥。苞四韦于怀抱。吞六论于胸衿。学穷三藏。贯练五部。研究大乘。备尽深极。法师既博综坟籍。妙达幽微。每欲振玄宗于他域。启法门于未悟。以身许道。无惮远游。跨万里犹比邻。越四海如咫尺。以梁太清二年方居建邺。仍值梁季混淆。横流荐及。法师因此避地东西。遂使大法拥而不畅。未至九江。返游五领。凡所翻译。卷轴未多。后适闽越。敷说不少。法师每怀慷慨。所叹知音者希。故伯牙绝弦。卞和泣璧。良由妙旨之典难辩。盈尺之珍罕别。法师游方既久。欲旋返旧国。经涂所亘。遂达番禺。仪同三司广州刺史阳山郡公。欧阳頠。睿表岳灵。德洞河府。经文纬武。匡道佐时。康流民于百越。建正法于五岭。钦法师之高行。慕大士之胜规。奉请为菩萨戒师。恭承尽弟子之礼。恺昔尝受业。已少涤沈蔽。伏膺未久。便致暌违。今重奉值。倍怀蹈舞。复欲餐和禀德。访道陈疑。虽殷勤三请。而不蒙允遂。恍然失图。心魂靡托。衡州刺史阳山公世子欧阳纥。风业峻整。威武贞拔。该阅文史。深达治要。崇澜内湛。清辉外溢。钦贤味道。笃信爱奇。躬为请主。兼申礼事。法师乃欣然受请。许为翻译。制旨寺主慧智法师。戒行清白。道气宏壮。志业闲赡。触途必举。匡济不穷。轮奂靡息。征南长史袁敬。德履冲明。志托夷远。徽献清简。冰桂齐质。弼谐蕃政。民誉早闻。兼深重佛法。崇情至理。黑白二贤。为经始檀越。辰次昭阳。岁维协洽。月旅姑洗。神纪句芒。于广州制旨寺。便就翻译。法师既妙解声论。善识方言。词有以而必彰。义无微而不畅。席间函丈终朝靡息。恺谨笔受。随出随书。一章一句。备尽研窍。释义若竟。方乃著文。然翻译事殊难不可存于华绮。若一字参差。则理趣胡越。乃可令质而得义。不可使文而失旨。故今所翻。文质相半。与僧忍等同共禀学。夙夜匪懈。无弃寸阴。即以某年树檀之月。文义俱竟。本论三卷。释论十二卷。义疏八卷。合二十三卷。此论乃是大乘之宗旨。正法之秘奥妙义云兴。清词海溢。深固幽远。二乘由此迷坠。旷壮该含。十地之所宗学。如来灭后。将千一百余年。弥勒菩萨。投适时机。降灵俯接。忘已屈应。为阿僧伽法师。广释大乘中义。阿僧伽者。此言无著。法师得一会道。体二居宗。该玄鉴极。凝神物表。欲敷阐至理。故制造斯论。唯识微言。因兹得显。三性妙趣。由此而彰。冠冕[(雪-雨)/粉/大]伦。舟航有识。本论即无著法师之所造也。法师次弟婆薮槃豆。此曰天亲。道亚生知。德备藏性。风格峻峙。神气爽发。禀厥兄之雅训。习大乘之弘旨。无著法师所造诸论。词致渊玄。理趣难晓。将恐后学复成纰紊。故制释论。以解本文。笼小乘于形内。挫外道于笔端。自斯以后。迄于像季。方等圆教乃盛宣通。慧恺不揆虚薄。情虑庸浅。乃欲泛芥舟于巨壑。策骀足于修路。庶累毫成仞。聚爝为明。有识君子。幸宜寻阅。其道必然无失坠也

摄大乘论卷上

        无著菩萨造

        真谛三藏译

    依止胜相中众名品第一

摄大乘论。即是阿毗达磨教。及大乘修多罗。佛世尊前。善入大乘句义菩萨摩诃萨。欲显大乘有胜功德。依大乘教说如是言。诸佛世尊有十胜相。所说无等过于余教。十胜相者。一应知依止胜相。二应知胜相。三应知入胜相。四入因果胜相。五入因果修差别胜相。六于修差别依戒学胜相。七此中依心学胜相。八此中依慧学胜相。九学果寂灭胜相。十智差别胜相。由此十义胜相。如来所说过于余教。如此释修多罗文句。显于大乘真是佛说。复次云何此中略释。能显大乘胜于余教。今此略释显斯十义。唯大乘有小乘中无。何者为十。谓阿黎耶识说名应知依止相。三种自性。一依他性。二分别性。三真实性。说名应知相。唯识教说名应知入相。六波罗蜜说名入因果相。菩萨十地说名入因果修差别相。菩萨所受持守护禁戒说名于修差别戒学相。首楞伽摩虚空器等定说名心学相。无分别智说名慧学相。无住处涅槃说名学果寂灭相。三种佛身自性身应身化身。此三说名无分别智果相。如此十种处唯大乘中有。异于小乘故说第一。佛世尊但为菩萨说此十义故。依大乘诸佛世尊有十胜相。所说无等过于余教。复次云何此十胜相。所说无等能显大乘。是如来正说遮小乘决非大乘。于小乘中未曾见此十义随释一义。但见大乘中释。复次此十义能引出无上菩提。成就随顺不相违。为诸众生得一切智智。而说偈言

  应知依及相　　入因果修异
  三学及果灭　　智无上乘摄
  十义余处无　　见此菩提因
  故大乘佛言　　由说十义胜

云何十义如此次第说。菩萨初学应先观诸法如实因缘。由此观故。于十二缘生应生聪慧。次后于缘生法应了别其体相。由智能离增益损减二边过失。如此正修应通达所缘如实诸相。次后从诸障应解脱。次心已通达应知实相。是先所行六波罗蜜。应更成就令清净无复退失。由依意内清净故。次内清净所摄诸波罗蜜。依十地差别应修随一三阿僧祇劫。次菩萨三学应令圆满。圆满已是学果涅槃及无上菩提。次后应得修十义次第如此。此次第说中一切大乘皆得圆满。此初说应知。依止立名阿黎耶识。世尊于何处说此识。及说此识名阿黎耶。如佛世尊阿毗达磨略本偈中说

  此界无始时　　一切法依止
  若有诸道有　　及有得涅槃

阿毗达磨中。复说偈云

  诸法依藏住　　一切种子识
  故名阿黎耶　　我为胜人说

此阿含两偈证识体及名。云何佛说此识名阿黎耶。一切有生不净品法。于中隐藏为果故。此识于诸法中隐藏为因故。复次诸众生藏此识中由取我相故。名阿黎耶识。阿含云。如解节经所说偈

  执持识深细　　法种子恒流
  于凡我不说　　彼物执为我

云何此识或说为阿陀那识。能执持一切有色诸根。一切受生取依止故。何以故。有色诸根此识所执持不坏不失。及至相续后际。又正受生时由能生取阴故。故六道身皆如是取。是取事用识所执持故。说名阿陀那。或说名心。如佛世尊言心意识。意有二种。一能与彼生次第缘依故。先灭识为意。又以识生依止为意。二有染污意。与四烦恼恒相应。一身见。二我慢。三我爱。四无明。此识是余烦恼识依止。此烦恼识由一依止生。由第二染污。由缘尘及次第能分别故。此二名意。云何得知有染污心。若无此心独行无明则不可说有。与五识相似此法应无。何以故。此五识共一时有自依止。谓眼等诸根。复次意名应无有义。复次无想定灭心定应无有异。何以故。无想定有染污心。所显灭心定不尔。若不尔此二定应不异。复次于无想天一期。应成无流无失无染污故。于中若无我见及我慢等。复次一切时中起我执遍善恶无记心中。若不如此。但恶心与我执等相应故。我及我所此或得行。于善无记中则不得行。若立二心同时生。无此过失。若立与第六识相应行。有此过失

  无独行无明　　及相似五识
  二定无差别　　意名无有义
  无想无我执　　一期生无流
  善恶无记中　　我执不应起
  离污心不有　　二与三相违
  无此一切处　　我执不得生
  证见真实义　　或障令不起
  恒行一切处　　名独行无明

此心染污故无记性摄。恒与四惑相应。譬如色无色界惑。是有覆无记。此二界烦恼奢摩他所藏故。此心恒生不废寻。第三体离阿黎耶识不可得。是故阿黎耶识成就为意。依此以为种子余识得生。云何此意复说为心。多种熏习种子所聚故。云何于声闻乘不说此心相及说阿黎耶。阿陀那名微细。境界所摄故。何以故。声闻人无有胜位为得一切智智。是故于声闻人离此说。由成就智令本愿圆满。故不为说。诸菩萨应有胜位为得一切智智。故佛为说。何以故。若离此智得无上菩提无有是处。复次此识于声闻乘由别名如来曾显。如增一阿含经言。于世间喜乐阿梨耶爱阿黎耶习阿黎耶着阿黎耶为灭阿黎耶。如来说正法。世间乐听故。属耳作意欲知生起正勤。方得灭尽阿黎耶。乃至受行如来正法及似法。由如来出世。是第一希有不可思议法。于世间显现如本识。此如来出世四种功德经。由别义于声闻乘此识已显现。复次摩诃僧祇部阿含中。由根本识别名此识显现。譬如树依根。弥沙塞部亦以别名说此识。谓穷生死阴。何以故。或色及心有时见相续断。此心中彼种子无有断绝。是应知依止阿陀那阿黎耶质多根本识穷生死阴等。由此名小乘中是阿黎耶识已成王路。复有余师。执心意识此三但名异义同。是义不然。意及识已见义异。当知心义亦应有异。复有余师。执是如来说世间喜乐阿黎耶如前所说。此中有五取阴说名阿黎耶。复有余师。执乐受与欲相应说名阿黎耶。复有余师。执身见说名阿黎耶。如此等诸师迷阿黎耶。由阿含及修得。是故作如是执。由随小乘教及行。是师所立义不中道理。若有人不迷阿黎耶识。约小乘名成立此识其义最胜。云何最胜。若执取阴名阿黎耶。于恶趣随一道中一向苦受处于彼受生。此取阴最可恶逆。是取阴中一向非可爱。众生喜乐不应道理。何以故。彼中众生恒愿取阴断绝不生。若是乐受与欲相应。从第四定乃至上界皆无此受。若人已得此受。由求得上界则生厌恶。是故众生于中喜乐不称道理。若是身见正法内人。信乐无我非其所爱。于中不生喜乐。此阿黎耶识众生心执为自内我。若生一向苦受道中。其愿苦阴永灭不起。阿黎耶识我爱所缚故。不曾愿乐灭除自我。从第四定以上受生众生。虽复不乐有欲乐受。于阿黎耶识中是自我爱随逐不离。复次正法内人。虽复愿乐无我违逆身见。于阿黎耶识中亦有自我爱。以阿黎耶名安立。此识则为最胜。是名成立阿黎耶别名

    相品第二

复次成立此识相云何可见。此相略说有三种。一立自相。二立因相。三立果相。立自相者。依一切不净品法习气。为彼得生摄持种子依器。是名自相。立因相者。此一切种子识。为生不净品法恒起为因。是名因相。立果相者。此识因种种不净品法无始习气方乃得生。是名果相。何法名习气。此习气名欲显何义。此法与彼相应共生共灭。后变为彼生因。此即所显之义。譬如于麻以华熏习。麻与花同时生灭。彼数数生为麻香生因。若人有欲等行。有欲等习气。是心与欲等同生同灭。彼数数生为心变异生因。若多闻人有多闻习气。数思所闻共心生灭。彼数数生为心明了生因。由此熏习得坚住故。故说此人为能持法。于阿黎耶识应知如此道理。此染污种子与阿黎耶识同异云何。不由别物体故异如此和合虽难分别而非不异。阿黍耶识如此而生。熏习生时有功能胜异。说名一切种子

云何阿黎耶识与染污一时更互为因。譬如灯光与灯炷。生及烧燃一时更互为因。又如芦束一时相依持故得住立。应知本识与能熏习更互为因。其义亦尔。如识为染污法因。染污法为识因。何以故。离此二法异因不可得故

云何熏习不异不多种。而能为有异多种诸法作生因。譬如多缕结衣衣无多色。若入染器后于衣上种种相貌方得显现。如此阿黎耶识种种诸法所熏熏时一性无有多种。若生果染器现前。则有不可数种类相貌。于阿黎耶识显现此缘生。于大乘最微细甚深。若略说有二种缘生。一分别自性。二分别爱非爱。依止阿黎耶识诸法生起。是名分别自性缘生。由分别种种法因缘自性故。复有十二分缘生。是名分别爱非爱。于善恶道分别爱非爱。生种种异因故。若人于阿黎耶识迷第一缘生。或执自性是生死因。或执宿作。或执自在变化。或执八自在我。或执无因。若迷第二缘生。执我作者受者。譬如众多生盲人不曾见象。有人示之令彼触证。有诸盲人。或触其鼻。或触其牙。或触其耳。或触其脚。或触其尾。或触其脊等。有人问之象为何相。盲人答云。象如犁柄。或说如杵。或说如箕。或说如臼。或说如帚。或说如山石。若人不了二种缘生。无明生盲或说自性为因。或说宿作。或说自在变化。或说八自在我。或说无因。或说作者受者。由不了阿黎耶识体相及因果相。如彼生盲不识象体相作种种异说。若略说阿黎耶识体相。是果报识。是一切种子。由此识摄一切三界身一切六道四生。皆尽为显此义故。说偈言

  外内不明了　　于二但假名
  及真实一切　　种子有六种
  念念灭俱有　　随逐至治际
  决定观因缘　　如引显自果
  坚无记可熏　　与能熏相应
  若异不可熏　　说是熏体相
  六识无相应　　三差别相违
  二念不俱有　　余生例应尔
  此外内种子　　能生及引因
  枯丧犹相续　　然后方灭尽
  譬如外种子　　内种子不尔

此义以二偈显之

  于外无熏习　　种子内不然
  闻等无熏习　　果生非道理
  已作及未作　　失得并相违
  由内外得成　　是故内有熏

所余识异阿黎耶识。谓生起识。一切生处及道应知。是名受用识。如中边论偈说

  一说名缘识　　二说名受识
  了受名分别　　起行等心法

此二识更互为因。如大乘阿毗达磨偈说

  诸法于识藏　　识于法亦尔
  此二互为因　　亦恒互为果

若于第一缘生中。诸法与识更互为因缘。于第二缘生中。诸法是何缘。是增上缘。复次几缘能生六识。有三缘。谓增上缘所缘缘。次第缘。如此三缘生。一穷生死缘生。二爱憎道缘生。三受用缘生。具足四缘

    引证品第三

此阿黎耶识已成立。由众名及体相。云何得知阿黎耶识。以如是等众名故。如来说体相亦尔。不说生起识。若离此名相所立阿黎耶识不净品净品等皆不成就。烦恼不净品。业不净品。生不净品。世间净品。出世净品等。皆不成就。云何烦恼不净品不成就。根本烦恼及少分烦恼所作熏习种子。于六识不得成就。何以故。眼识与欲等大小二惑俱起俱灭。此眼识是惑所熏成立种子。余识不尔。是眼识已灭。或余识间起。熏习及熏习依止皆不可得。眼识前时已谢现无有体。或余识所间从已灭无法。有欲俱生不得成就。譬如从过去已灭尽业果报不得生。复次眼识与欲等或俱时生起熏习不成。何以故。此种子不得住于欲中。以欲依止识故。又欲相续不坚住故。此欲于余识亦无熏习。依止别异故所余诸识无俱起俱灭故。同类与同类不得相熏。以无一时共生灭故。是故眼识不为欲等大小诸惑所熏。亦不为同类识所熏。如此思量眼识。所余诸识亦应如此思量。复次若众生从无想天已上退堕。受下界生大小惑所染初识。此识生时应无种子。何以故。此惑熏习与依止。并已过去灭无余故。复次或对治识已生。所余世间诸识皆已灭尽。若无阿黎耶识。此对治识共小大惑种子俱在。此义不成。何以故。自性解脱故。无流心与惑不得俱起俱灭故。复次后时出观正起世间心。诸惑熏习久已谢灭。有流意识无有种子生应得成。是故离阿黎耶识。烦恼染污则不得成。复次业染污云何不得成。缘行生识分无得成义。若无此义缘取生有亦无成义。故业染污不成。复次云何生染污此义不成。结生不成故。若人于不静地退堕。心正在中阴起染污意识方得受生。此有染污识于中阴中灭。是识托柯罗逻。于母胎中变合受生。若但意识变成柯罗逻等依止。此意识于母胎中有别意识起。无如此义。于母胎中二种意识一时俱起。无此义故。已变异意识不可成立。为意识依止不清净故。长时缘境故。所缘境不可知故。若此意识已变异。是时意识成柯罗逻。为此识是一切法种子为依止。此识生余识。为一切法种子。若汝执已变异识名一切种子识。即是阿黎耶识。汝自以别名成立谓为意识。若汝执能依止识。是一切种子识。是故此识由依止成他因。此所依止识。若非一切种子识能依止。名一切种子识。是义不成。是故此识托生变异成柯罗逻。非是意识。但是果报。亦是一切种子。此义得成。复次若众生已托生。能执持所余色根。离果报识则不可得。何以故。所余诸识定别有依止不久坚住。若此色根无执持识。亦不得成。复次此识及名色更互相依。譬如芦束相依俱起。此识不成。复次若离果报识。一切求生已生众生识食不成。何以故若离果报识。眼识等中随有一识。于三界中受生众生。为作食事不见有能故。若人从此生舍命生上静地。由散动染污意识。于彼受生是染污散动识。于静地中离果报识有余种子。此义不成。复次若众生生无色界。离一切种子果报识。若生染污心及善心则无种子。并依止染污及善二识皆不得成。于无色界若起无流心。所余世间心已灭尽。便应弃于此道。若众生生非想非非想中。起不用处心及无流心。即舍二处。何以故。无流心是出世心故。非想非非想道非其依止。不用处道亦非依止。直趣涅槃亦非依止。复次若人已作善业及以恶业。正舍寿命离阿黎耶识。或上或下次第依止冷触不应得成。是故生染污离一切种子果报识不可得立。云何世间净品不成。若众生未离欲欲界。未得色界心先起欲界善心。求离欲欲界。修行观心。此欲界加行心与色界心。不俱起俱灭故非所熏。是故欲界善心。非是色界善心种子。过去色界心无量余生及别心所隔。后时不可立为静识种子。已无有故。是故此义得成谓色界静心一切种子果报识。次第传来立为因缘。此加行善心立为增上缘。如此于一切离欲地中。是义应知。如此世间清净品义。离一切种子果报识。则不可立。云何出世净品离阿黎耶识不可得立。佛世尊说。从闻他音及自正思惟。由此二因正见得生。此闻他音及正思惟。不能熏耳识及意识。或耳意二识何以故。若人如闻而解及正思惟法。尔时耳识不得生。意识亦不得生。以余散动分别识所闻故。若与正思惟相应生。此意识久已谢灭。闻所熏共熏习已无。云何后时以前识为种子后识得生。复次世间心与正思惟相应。出世净心与正见相应。无时得共生共灭。是故此世心非关净心所熏。既无熏习。不应得成出世种子。是故若离一切种子果报识。出世净心亦不得成。何以故。此中闻思熏习无有义能摄出世熏习种子。云何一切种子果报识成不净品因。若能作染浊对治出世净心因。此出世心昔来未曾生。习是故定无熏习若无熏习。此出世心从何因生。汝今应答。最清净法界所流正闻熏习为种子故。出世心得生此闻慧熏习为与阿黎耶识同性为不同性。若是阿黎耶识性。云何能成此识对治种子。若不同性。此闻慧种子以何法为依止至诸佛无上菩提位是闻慧熏习生随在一依止处。此中共果报识俱生。譬如水乳。此闻熏习即非本识。已成此识对治种子。故此中依下品熏习中品熏习生。依中品熏习上品熏习生。何以故。数数加行闻思修故。是闻熏习若下中上品应知是法身种子。由对治阿黎耶识生。是故不入阿黎耶性摄。出世最清净法界流出故。虽复世间法成出世心。何以故。此种子出世净心未起时一切上心。惑对治一切恶道生。对治一切恶行朽坏。对治能引相续令生。是处随顺逢事诸佛菩萨。此闻熏习虽是世间法初修观菩萨所得。应知此法属法身摄。若声闻独觉所得属解脱身摄。此闻熏习非阿黎耶识。属法身及解脱身摄。如是如是从下中上次第渐增。如是如是果报识次第渐减。依止即转若依止一向转。是有种子果报识即无种子一切皆尽。若本识与非本识共起共灭。犹如水乳和合。云何本识灭非本识不灭。譬如于水鹅所饮乳犹如世间离欲时。不静地熏习灭。静地熏习增世间转依义得成。出世转依亦尔。若人入灭心定。由说识不离身。是故果报识于定中应成不离身。何以故。灭心定非此识对治故。云何知然。若从此定出识不应更生。何以故。此果报识相续已断。若离托生时不复得生。若人说灭心定有心。此人所说则不成心。何以故定义不成故。解相及境不可得故。与善根相应过故。与恶及无记不相应故。想及受生起过故。于三和合必有触故。于余定有功能故。但灭想是过患故。作意信等善根生起过故。拔除能依离所依不可得故。有譬喻故。如非一切行。一切行不如是故。若有人执色心次第生是诸法种子。此执不然何以故。已有前过复有别失。别失者。若人从无想天退及出灭心定。此中所执不成。阿罗汉最后心亦不得成。若离次第缘此执不成。如此若离一切种子果报识。净不净品皆不得成。是故此心有义成就。应当信知依前所说相。今更作偈

  菩萨于善识　　则离余五识
  无余心转依　　以何方便作
  若对治转依　　非灭故不成
  因果无差别　　于灭则有过
  无种子无法　　若许为转依
  于无二无故　　转依义不成

    差别品第四

此阿黎耶识差别云何。若略说或三种或四种差别。三种者。由三种熏习异故。谓言说我见有分熏习差别。四种者。谓引生果报缘相相貌差别。引生差别者。是熏习新生。若无此缘行生识缘取生有。是义不成。果报差别者。依行于六道中此法成熟。若无此后时受生所有诸法生起此义不成。缘相差别者。于此心中有相能起我执。若无此于余心中执我相境。此义不成。相貌差别者。此识有共相。有不共相无受生种子相。有受生种子相。共相者。是器世界种子。不共相者。是各别内入种子。复次共相者。是无受生种子。不共相者。是有受生种子。若对治起时不共所对治灭。于共种子识他分别所持正见清净。譬如修观行人。于一类物种种愿乐种种观察随心成立。此中说偈

  难灭及难解　　说名为共结
  观行人心异　　由相大成外
  清净人未灭　　此中见清净
  成就净佛土　　由佛见清净

复有别偈

  种种愿及见　　观行人能成
  于一类物中　　随彼意成故
  种种见成故　　所取唯有识

是不共本识差别。有觉受生种子。若无此众生世界生缘不成。是共阿黎耶识无受生种子。若无此器世界生缘不成。复次粗重相识。细轻相识。粗重相识者。谓大小二惑种子。细轻相识者。谓一切有流善法种子。若无此由前业果有胜能。无胜能依止差别不得成

复次有受不受相二种本识。有受相者。果报已熟善恶种子识。不受相者。名言熏习种子无量时戏论。生起种子故。若无此识有作不作善恶二业因与果报故。受用尽义不成始生。名言熏习生起亦不得成。复次有譬喻相。识如幻事鹿渴梦想翳闇等譬。第一识似如此事。若无此虚妄分别种子故。此识不成颠倒因缘。复有具不具相。若具缚众生有具相。若得世间离欲有损害相。若有学声闻及诸菩萨有一分灭离相。若阿罗汉独觉如来有具分灭离相。何以故。阿罗汉独觉单灭惑障。如来双灭惑智二障。若无此烦恼次第灭尽则不得成。何因缘善恶二法果报。唯是无覆无记。此无记性与善恶二法俱生不相违。善恶二法自互相违。若果报成善恶性。无方便得解脱烦恼。又无方便得起善及烦恼故。无解脱及系缚。无此二义故。是故果报识定是无覆无记性

    摄大乘论应知胜相第二之一

如此已说应知依止。胜相云何应知。应知胜相此应知相略说有三种。一依他性相。二分别性相。三真实性相。依他性相者。本识为种子。虚妄分别所摄诸识差别。何者为差别。谓身识。身者识。受者识。应受识。正受识世识。数识。处识。言说识。自他差别识。善恶两道生死识。身识身者识受者识应受识正受识世识数识处识言说识。如此等识因言说熏习种子生。自他差别识。因我见熏习种子生。善恶两道生死识。因有分熏习种子生。由如此等识一切界道烦恼所摄依他性为相。虚妄分别即得显现。如此等识虚妄分别所摄唯识为体。非有虚妄尘显现依止。是名依他性相。分别性相者。实无有尘唯有识体显现为尘。是名分别性相。真实性相者。是依他性。由此尘相永无所有。此实不无。是名真实性相。由身识身者识受者识。应知摄眼等六内界。以应受识应知摄色等六外界。以正受识应知摄眼等六识界。由如此等识为本其余诸识。是此识差别。如此众识唯识。以无尘等故。譬如梦等于梦中。离诸外尘一向唯识。种种色声香味触舍林地山等诸尘如实显现此中无一尘是实有。由如此譬一切处应知唯有识。由此等言应知幻事鹿渴翳闇等譬。若觉人所见尘一切处唯有识。譬如梦尘。如人梦觉了别梦尘但唯有识。于觉时何故不尔。不无此义。若人已得真如智觉不无此觉。譬如人正在梦中未觉此觉不生。若人已觉方有此觉。如此若人未得真如智觉亦无此觉。若已得真如智觉必有此觉。若人未得真如智觉。于唯识中云何得起比智。由圣教及真理可得比度。圣教者如十地经中佛世尊言。佛子。三界者唯有识。又如解节经中说。是时弥勒菩萨摩诃萨问佛世尊。世尊。此色相是定心所缘境。为与心异。与心不异。佛世尊言。弥勒。与心不异。何以故。我说唯有识。此色相境界识所显现。弥勒菩萨言。世尊。若定境界色相与定心不异。云何此识取此识为境。佛世尊言。弥勒。无有法能取余法。虽不能取。此识如此变生显现如尘。譬如依面见面。谓我见影此影显现相似异面。定心亦尔显现似尘。谓异定心。由此阿含及所成道理。唯识义显现。云何如此。是时观行人心正在观中。若见青黄等遍入色相。即见自心不见余境青黄等色。由此道理一切识中。菩萨于唯识应作如此比知。于青黄等识非忆持识。以见境在现前故。于闻思两位忆持意识。此识缘过去境。似过去境起。是故得成唯识义。由此比知菩萨若未得真如智觉。于唯识义得生比知。是种种识前已说。譬如幻事梦等。于中眼识等识唯识义可成。眼色等识有色。唯识义云何可见。此等识由阿含及道理如前应知。若色是识云何显现似色。云何相续坚住前后相似。由颠倒等烦恼依止故。若不尔于非义义颠倒不得成。若无义颠倒惑障及智障二种烦恼则不得成。若无二障清净品亦不得成。是故诸识如此生起可信是实。此中说偈

  乱因及乱体　　色识无色识
  若前识不有　　后识不得生

云何身识身者识受者识应受识正受识。于一切生处更互密合生。具足受生所显故。云何世识等如前说有种种差别生。无始生死相续不断绝故。无量众生界所摄故。无量器世界所摄故。无量作事更互显示所摄故。无量摄及受用差别所摄故。无量受用爱憎业果报所摄故。无量生及死证得差别所摄故。云何正辨如此等识令成唯识义。若略说有三相。诸识则成唯识。唯有识量外尘无所有故唯有二。谓相及见。识所摄故。由种种生相所摄故。此义云何。此一切识无尘故。成唯识有相有见。眼等诸识以色等为相故。眼等诸识以诸识为见故。意识以一切眼识乃至法识为相故。意识以意识为见故。云何如此意识能分别故。似一切识尘分生故。此中说偈

  入唯量唯二　　种种观人说
  通达唯识时　　及伏离识位

诸师说。此意识随种种依止生起得种种名。譬如作意业得身口等业名。此识于一切依止生种种相貌。似二种法显现。一似尘显现。二似分别显现。一切处似触显现。若在有色界意识依身故生。譬如有色诸根依止身生。此中说偈

  远行及独行　　无身住空窟
  调伏难调伏　　则解脱魔缚

如经言。此眼等五根所缘境界。一一境界意识能取。分别意识为彼生因。复有别说分别说。十二入中是六识聚说名意入。是处安立本识为义识此中一切识说名相识。意识及依止识应知名见识。何以故。此相识由是见生因显现似尘故。作见生依止事。如此诸识成立唯识。云何诸尘现前显现知其非有。如佛世尊说。若菩萨与四法相应。能寻能入一切识无尘。何者为四。一知相违识相。譬如饿鬼畜生人天于同境界。由见识有异。二由见无境界识。譬如于过去未来梦影尘中。三由知离功用无颠倒应成。譬如实有尘中缘尘起识。不成颠倒不由功用。如实知故。四由知义随顺三慧。云何如此一切圣人入观得心自在。由愿乐自在故。如愿乐尘种种显现故。若观行人已得奢摩他修法观加行。随唯思惟义显现故。若人得无分别智未出无分别观。一切尘不显现故。由境界等义随顺三慧。由前引证成就唯识义故。知唯识无尘。此中有六偈重显前义。此偈后依智学中。当广分别说。谓饿鬼畜生人。如是等

摄大乘论卷上摄大乘论卷中

        无著菩萨造

        真谛三藏译

    应知胜相第二之二

若唯识似尘显现依止。说名依他性。云何成依他。何因缘说名依他。从自熏习种子生故。系属因缘不得自在。若生无有功能过一刹那得自住故。说名依他。若分别性依他实无所有似尘显现。云何成分别。何因缘说名分别。无量相貌意识分别。颠倒生因故成分别。无有自相唯见分别故。说名分别。若真实性分别性永无所有为相。云何成真实。何因缘说名真实。由如无不如故成真实。由成就清净境界由一切善法中最胜。于胜义成就故说名真实。复次若有分别及所分别。分别性成。此中何法名分别。何法所分别。何法名分别性。意识是分别。具三种分别故。何以故。此识自言熏习为种子。及一切识言熏习为种子。是故此生。由无边分别。一切处分别但名分别。说名分别。此依他但是所分别。是因能成依他性为所分别。此中名分别性。云何分别能计度。此依他性。但如万物相。缘何境界。执何相貌。云何观见。云何缘起。云何言说。云何增益。由名等境界于依他性中。由执着相。由决判起见。由觉观言说缘起。由见等四种言说实无有尘计实有为增益。由此因故能分别。此三种性云何。与他为异为不异。非异非不异。应如此说。有别义依他性名依他。有别义此成分别。有别义此成真实。何者别义说此名依他。从熏习种子系属他故。复有何义此成分别。此依他性为分别因。是所分别故成分别。复有何义此成真实。此依他性或成真实。如所分别实不如是有故。复有何义由此一识成一切种种识相貌。本识识所余生起识种种相貌故。复因此相貌生故。依他性有几种。若略说有二种。一系属熏习种子。二系属净品不净品性不成就。是故由此二种系属说名依他。分别性亦有二种。一由分别自性。二由分别差别真实性。亦有二种一自性成就。二清净成就。复有分别更成四种。一分别自性。二分别差别。三有觉。四无觉。有觉者。能了别名言众生分别。无觉者。不能了别名言众生分别。复次分别有五种。一依名分别义自性。譬如此名目此义。二依义分别名自性。譬如此义属此名。三依名分别名自性。譬如分别未识义名。四依义分别义自性。譬如分别未识名义。五依二分别二自性。譬如此名此义。何义何名若摄一切分别。复有十种。一根本分别。谓本识。二相分别。谓色等识。三依显示分别。谓有依止眼等识识。四相变异分别。谓老等变异。苦乐等受。欲等惑及枉。时节等变异。地狱等欲界等变异。五依显示变异分别。谓如前所说变异起变异分别。六他引分别。谓闻非正法类闻正法类分别。七不如理分别。谓正法外人非正法类分别。八如理分别。谓正法内人闻正法类分别。九决判执分别。谓不如理思惟种类身见为根本。与六十二见相应分别。十散动分别。谓菩萨十种分别。无有相散动。有相散动。增益散动。损减散动。一执散动。异执散动。通散动。别散动。如名起义散动。如义起名散动。为对治此十种散动分别故。于一切般若波罗蜜教中佛世尊说。无分别智能对治此十种散动。应知具足般若波罗蜜经义。如般若波罗蜜经言。云何菩萨行于般若波罗蜜。舍利弗。是菩萨实有菩萨。不见有菩萨。不见菩萨名。不见般若波罗蜜。不见行。不见不行。不见色。不见受想行识。何以故。色由自性空。不由空空见色空。非色无色异空故。色即是空空即是色。何以故。舍利弗。此但有名。所谓色是自性。无生无灭无染无净。对假立名分别诸法。由假立客名随说诸法如如。随说如是如是生起执着。如此一切名菩萨不见。若不见不生执着。如观色乃至识亦应作如此观。由此般若波罗蜜经文句。应随顺思惟十种分别义。若由此别意依他性成有三性。是三性云何。性有三异。不成相杂无相杂义。由此道理此性成依他。不由此成分别及真实。由此道理此性成分别。不由此成依他及真实由此道理此性成真实。不由此成依他及分别。云何得知此依他性。由分别性显现似法。不与分别性同体。未得名前于义不应生智故。法体与名一则此义相违。由名多故。若名与义一。名既多义应成多。此义体相违。由名不定体相杂此义相违。此中说偈

  于名前无智　　多名及不定
  义成由同体　　多杂体相违
  法无显似有　　无染而有净
  是故譬幻事　　亦以譬虚空

云何如此显现而实非有。依他性一切种非不有。若无依他性真实性亦无。一切无不成。若无依他性及真实性。则有无染污及清净品过失。此二品可知非无是故非一切皆无。此中说偈

  若无依他性　　真实性亦无
  则恒无二品　　谓染污清净

诸佛世尊于大乘中说鞞佛略经。此经中说。云何应知分别性。由说无有品类此性应知。云何应知依他性。由说幻事鹿渴梦相影光谷向水月变化如此等譬应知其性。云何应知真实性。由说四种清净法应知。此性四种清净法者。一此法本来自性清净。谓如如空实际无相真实法界。二无垢清净。谓此法出离一切客尘障垢。三至得道清净。谓一切助道法及诸波罗蜜等。四道生境界清净。谓正说大乘法。何以故。此说是清净因故非分别。清净法界流故非依他。由此四种清净法。摄一切清净法皆尽。此中说偈

  幻等显依他　　说无显分别
  若说四清净　　此说属真实
  清净由本性　　无垢道缘缘
  一切清净法　　四皆摄品类

何因何缘是依他性。如经所说。幻事等譬所显。于依他性中为除他虚妄疑惑。云何他于依他性中生虚妄疑惑。诸说。于依他性中有如此虚妄疑心。若实无有物。云何成境界。为决此疑故说幻事譬。若无境界。心及心法云何得生。为决此疑故说鹿渴譬。若实无尘。爱非爱受用云何得成。为决此疑故说梦相譬。若实无法。善恶二业爱非爱果报云何得生。为决此疑故说影譬。若实无法。云何种种智生。为决此疑故说光影譬。若实无法。云何种种言说起。为决此疑故说谷响譬。若实无法。云何成缘真实法定心境界。为决此疑故说水月譬。若实无法。云何诸菩萨故作心无颠倒心。为他作利益事于六道受生。为决此疑故说变化譬。婆罗门问经中言。世尊。依何义说如此言。如来不见生死不见涅槃。于依他性中依分别性及依真实性。生死为涅槃依无差别义。何以故。此依他性由分别一分成生死。由真实一分成涅槃。阿毗达磨修多罗中佛世尊说法有三种。一染污分。二清净分。三染污清净分。依何义说此三分。于依他性中分别性为染污分。真实性为清净分。依他性为染污清净分。依如此义故说三分。于此义中以何为譬。以金藏土为譬。譬如于金藏土中。见有三法。一地界二金三土。于地界中土非有。而显现金实有不显现此土。若以火烧炼土则不现金相自现。此地界土显现时由虚妄相显现。金显现时由真实相显现。是故地界有二分。如此本识未为无分别智火所烧炼时。此识由虚妄分别性显现。不由真实性显现。若为无分别智火所烧炼时。此识由成就真实性显现。不由虚妄分别性显现。是故虚妄分别性识即依他性有二分。譬如金藏土中所有地界。复次有处世尊说一切法常住。有处说一切法无常。有处说非常非无常。依何义说常。此依他性由真实性分常住。由分别性分无常。由二性分非常非无常。如依此义说常无常无二。如此说苦乐无二。善恶无二。空不空无二。有我无我无二。静不静无二。有性无性无二。有生无生无二。有灭无灭无二。本来寂静不寂静无二。本来涅槃非涅槃无二。生死涅槃无二。由如此等差别。诸佛如来依义密语。由此三性应随决了。常无常等正说如前解释。此中说偈

  如法实不有　　如彼种种现
  由此法非法　　故说无二义
  依一分说言　　或有或非有
  依二分说言　　非有非非有
  如显现不有　　是故说永无
  如显现实有　　是故说非无
  由自体非有　　自体不住故
  如取不有故　　三性成无性
  由无性故成　　前为后依止
  无生灭本静　　及自性涅槃

复次有四意四依。一切佛世尊教应随决了。一平等意。譬如有说。昔是时中我名毗婆尸久已成佛。二别时意。譬如有说。若人诵持多宝佛名。决定于无上菩提不更退堕。复有说言。由唯发愿于安乐佛土得往彼受生。三别义意。譬如有说。事如是等恒伽所有沙数诸佛。于大乘法义得生觉了。四众生乐欲意譬如如来先为一人赞叹布施后还毁呰。如施戒及余修亦尔。是名四种意。四依者。一令入依。譬如于大小乘中佛世尊说人法二种通别二相所摄俗谛。二相依。譬如随所说法相中必有三性。三对治依。此中八万四千众生烦恼行对治显现。四翻依。此中由说别义言词以显别义譬。如偈言

  阿娑离娑罗摩多耶　　毗跋耶斯者修絺多
  离施那者僧柯履多　　罗槃底菩提物多摩

若人欲广解释大乘法。略说由三相。应当如此解释。一广解缘生体相。二广解依因缘已生诸法实相。三广解成立所说诸义。广解缘生体相者。如偈说言。熏习所生诸法。此从彼如此果报识及生起识。由更互因生。广解释依因缘已生诸法实相者。诸法者。谓生起识为相。有相及见识为自性。复次诸法依止为相。分别为相。法尔为相由此言说于三性中诸法体相则得显现。如偈言

  从有相有见　　应知法三相

云何得解说此法相。分别性。于依他性实无所有。真实性于中实有。由此二不有有故。非得及得未见已见。真如一时自然成。于依他性中分别性无故。真实性有故。若见彼不见此。若不见彼即见此。如偈言

  依他中分别　　无但真实有
  故不得及得　　于中二平等

广解成立所说诸义者。譬如初所说文句。由所余诸句显示分别。或由功德依止。或因事义依止。功德依止者。广说佛世尊功德。最清净慧无二行。无相法为胜依。意行住于佛住。至得诸佛平等行无碍行。不可破无对转法。不可变异境不可思惟。所成立法。至三世平等。于一切世界现身。于一切法智慧无碍。一切行与智慧相应。于法智无疑。不可分别身。一切菩萨所受智慧。至无二佛住波罗蜜。至无差别如来解脱。智究竟已得无边佛地。平等法界为胜虚空界。为后边最清净慧。如此初句由所余句。次第应知分别解释。若如此正说法义得成最清净慧者。诸佛如来智慧。于一切法清净无不了别。如此本义应知由二十一佛功德所摄。于所知一切无障行起功德。于有无无二相真如最清净令入功德。不由功用不舍如来事佛住功德。于法身依止及意事无差别功德。修习一切障对治功德。降伏一切外道功德。生于世间非世间法所染污功德。安立正法功德。四种善巧答他问功德。于一切世界中显现应化身功德。能决他疑功德。由种种行能令他入功德。于未来世法生智功德。随众生乐显现功德。能行无量依止众生正教化事功德。平等法身波罗蜜成就功德。随众生意显现纯净佛土功德。是三种佛身无离无别处功德。穷生死际能生一切众生利益安乐功德。由无尽功德。因事义依止者。如经言。若菩萨与三十二法相应说名菩萨。于一切众生与利益安乐意相应。令入一切智智意。我今于何处中当相应如此智。舍高慢心坚固善意。非假作怜愍。意不贪报恩。于亲非亲所平等意永作善友意。乃至无余涅槃称量谈说欢笑先言于诸众生慈悲无异于所作事无退弱心无厌倦心闻义无足。于自作罪能显其过。于他作罪不怪诃责。于一切威仪中恒持菩提心。不求果报而行布施。不着一切怖畏及道生受持禁戒。于一切众生忍辱无碍。为引摄一切善法行于精进。修三摩提灭离无色定。与方便相应智。四摄相应方便于持戒破戒中。善友无二。事善知识恭敬心。听法恭敬心乐住阿兰若处。于世间希有不生安乐心。于下品乘不生喜乐心。于大乘教观实功德。远离恶友敬事善友。恒治四种梵住。治无量心清净。恒游戏五神通。恒依智慧行。于住正行不住正行众生。无舍离心引摄大众。一向决定言说恭敬实事先恭敬行。菩萨心与如此等法相应说名菩萨。由如此文句前说初句应知。解说初句者。谓于一切众生利益安乐意。此利益安乐意文句别有十六文句所显业应知。解说十六业者。一傅傅行业。二无倒业。三不由他事自行业。四不可坏业。五无求欲业。有三句解释应知。不贪报恩。有恩无恩众生不生爱憎心。随顺行乃至余生随处相应言说业。有二句解释应知。有苦有乐无二众生平等业。无下劣业。不可令退转业。摄方便业。厌恶所对治业。有二句解释应知。无间思量业。行进胜位业。有七句解释应知。正修加行六波罗蜜。恭敬行四摄成就方便业。有六句解释应知。事善知识听闻正法。住阿兰若处。远离邪觉观。正思惟功德。有二句。显事善友功德。有二句。显成就业。有三句解释应知。治无量心清净得威德。证得功德安立他业。有四句解释应知。引摄大众无有疑心。立正教学处。法财二摄无染污心。如此等句。应知解释初说文句。此中说偈

  取如前说句　　随德句差别
  取如前说句　　由义别句别

    摄大乘论应知入胜相第三

如此已说应知胜相。云何应知应知入胜相。多闻所熏习依止。非阿黎耶识所摄。如阿黎耶识成种子。正思惟所摄。似法及义显相所生。似所取种类有见意言分别。何人能入应知相。大乘多闻熏习相续已得承事。无量出世诸佛。已入决定信乐正位。由善成熟修习增长善根。是故善得福德智慧二种资粮。诸菩萨于何处入唯识观。有见似法义显相意言分别。大乘法相所生。于愿乐行地入。谓随闻信乐故。见道谓如理通达故。修道谓能对治一切障故。究竟道中。谓出离障垢最清净故。一切法实唯有识。如说随闻信乐故。如理通达故。能对治一切障故。出离障垢最清净故。云何得入。由善根力持故。由有三相练磨心故。由灭除四处障故。缘法义为境。无间修。恭敬修。奢摩他毗钵舍那。无放逸故。十方世界无数量故。不可数量在人道众生。刹那刹那证得无上菩提。是名第一练磨心。由此正意施等诸波罗蜜必得生长。是我信乐已得坚住。由此正意我修习施等波罗蜜。进得圆满则为不难。是名第二练磨心。若人与众善法相应。后舍命时于一切受生中。可爱富乐自然而成。是人得有碍善此义尚应成。云何我得圆满善及无碍善。一切如意可爱富乐而当不成。是名第三练磨心。此中说偈

  人道中众生　　念念证菩提
  处所过数量　　故无下劣心
  善心人信乐　　能生施等度
  胜人得此意　　故能修施等
  若善人死时　　即得胜富乐
  灭位圆净善　　此义云何无

由灭除四处障故。由舍离声闻独觉思惟故。邪思惟灭于大乘中生信心及决了心故。灭一切邪意及疑。是所闻思诸法中。舍离我及我所邪执故。是故灭除法执。安立现前住一切相思惟悉不分别。是故能灭除分别。此中说偈

  现住及安立　　一切相思惟
  智人不分别　　故得无上觉

缘法及义为境。何因何方便得入。由闻熏习种类正思惟所摄。显现似法及义。有见意言分别故。由四种寻思。谓名义自性差别假立寻思

由四种如实智。谓名义自性差别。如实智四种不可得故。若菩萨已入已解如此等义。则修加行为入唯识观。于此观中意言分别似字言及义显现。此中是字言相。但意言分别得如此通达。此义依名言唯意言分别。亦如此通达此名义自性差别。唯假说为量。亦如此通达。次于此位中但证得唯意言分别。是观行人不见名及义。不见自性差别假说。由实相不得有自性差别义。已由四种寻思及四种如实智。于意言分别显现似名及义。得入唯识观。于唯识观中入何法。如何法得入。但入唯量相见二法。种种相貌名义。自性差别假说自性差别义。六种相无义故。由此能取所取非有为义故。一时显现似种种相貌及生故。譬如闇中藤显现似蛇。犹如于藤中蛇即是虚实不有故。若人已了别此藤义。先时蛇乱智不缘境起。即便谢灭唯藤智在。此藤智由微细分析虚空无实境。何以故。但是色香味触相故。若心缘此境。藤智亦应可灭。若如此见已伏灭。六相显现。似名及义。意言分别尘智不生。譬如蛇智。于伏灭六相义中。是唯识智亦应可伏灭。譬如藤智。由依真如智故。如此菩萨由入似义显现意言分别相故。得入分别性由入唯识义故。得入依他性。及云何得入真实性。若舍唯识想已。是时意言分别。先所闻法熏习种类。菩萨已了别伏灭尘想。似一切义显现。无复生缘故不得生。是故似唯识意言分别亦不得生。由此义故。菩萨唯住无分别。一切义名中由无分别智。得证得住真如法界。是时菩萨平等平等能缘所缘无分别智生。由此义故菩萨得入真实性。此中说偈

  法人及法义　　性略及广名
  不净净究竟　　十名差别境

如此菩萨由入唯识观故。得入应知胜相。由入此相得入初欢喜地。善通达法界。得生十方诸佛如来家。得一切众生心平等。得一切菩萨心平等。得一切诸佛如来心平等。此观名菩萨见道

复次何故菩萨入唯识观。由缘极通法为境出世奢摩他毗钵舍那智故。由无分别智后所得种种相识为相智故。为灭除共本阿黎耶识中一切有因诸法种子。为生长能触法身诸法种子。为转依。为得一切如来正法。为得一切智智故。入唯识观。无分别智后所得智者。于本识及所生一切识识及相识相中由观似幻化等譬自性无颠倒。由此义故。菩萨如幻师于一切幻事自了无倒。于一切相因缘及果中。若正说时常无偏倒

是时正入唯识观位中。有四种三摩提。是四种通达分善根依止菩萨云何应见。由四种寻思。于下品无尘观忍光得三摩提。是暖行通达分善根。依止于最上品无尘观忍光增三摩提。是顶行通达分善根。依止于四种如实智。菩萨已入唯识观了别无尘故。正入真义一分通行三摩提。是随非安立谛忍。依止此三摩提最后刹那。了伏唯识想。转名无间三摩提。应知是世第一法依止四种三摩提。是菩萨入非安立谛观前方便。若菩萨如此入初地已得见道。得通达入唯识。云何菩萨修习观行入于修道。如佛广说。所安立法相。于菩萨十地。由摄一切如来所说大乘十二部经故得现前。由治所说通别二境。由生起缘极通境出世无分别智。及无分别智后所得奢摩他毗钵舍那智。由无量无数百千俱胝大劫中依数数修习。由昔及今所得转依。为得三种佛身更修加行。是声闻见道。是菩萨见道。此二见道差别云何。声闻菩萨见道应知有十一种差别。何者为十一。一由境界差别。谓缘大乘法为境。二由依止差别。谓依大福德智慧资粮为依止。三由通达差别。谓通达人法二无我。四由涅槃差别。谓摄无住处涅槃以为住处。五由地差别。谓依十地为出离。六七由清净差别。谓灭烦恼习气。及治净土为清净。八由于一切众生得平等心差别。谓为成熟众生不舍加行功德善根。九由受生差别。谓生如来家为生故。十由显现差别。谓于佛子大集论中常能显现为摄受正法。十一由果差别。谓十力无畏不共如来法。及无量功德生为果故。此中说两偈

  名义互为客　　菩萨应寻思
  应观二唯量　　及彼二假说
  从此生实智　　离尘分别三
  若见其非有　　得入三无性

又正教两偈。如分别观论说

  菩萨在静位　　观心唯是影
  舍离外尘相　　唯定观自想
  菩萨住于内　　入所取非有
  次观能取空　　后触二无得

复有大乘庄严经论所说五偈。为显此道

  菩萨生长福及慧　　二种资粮无量际
  于法思惟心决故　　能了义类分别因
  已知义类但分别　　得住似义唯识中
  故观行人证法界　　能离二相及无二
  若离于心知无余　　由此即见心非有
  智人见此二不有　　得住无二真法界
  由无分别智慧人　　恒平等行遍一切
  染衣稠密过聚性　　遣灭如药能除毒
  佛说正法善成立　　安心有根于法界
  已知忆念唯分别　　功德海岸智人至

    摄大乘论入因果胜相第四

如此已说入应知胜相。云何应知入因果胜相。由六波罗蜜。谓陀那尸罗羼提毗梨耶持诃那般罗若波罗蜜。云何由六波罗蜜得入唯识。复云何六波罗蜜成入唯识果。此正法内有诸菩萨。不着富乐心。于戒无犯过心。于苦无坏心。于善修无懒堕心。于此散乱因中不住着故。常行一心如理简择诸法得入唯识观。由依止六波罗蜜。菩萨已入唯识地。次得清净信乐意所摄六波罗蜜。是故于此中间设离六波罗蜜。加行功用。由信乐正说爱重随喜愿得思惟故。恒无休息行。故修习六波罗蜜究竟圆满。此中说偈

  修习圆白法　　能得利疾忍
  菩萨于自乘　　甚深广大说
  觉唯分别故　　得无著智故
  是乐信清净　　名清净意地
  菩萨在法流　　前后见诸佛
  已知菩提近　　无难易得故

何故波罗蜜唯有六数为安立。能对治六种惑障故。为一切佛法生起依处故。为随顺成熟一切众生依止故。为对治不发行心因故。立施戒二波罗蜜。不发行心因者。贪着财物及以室家。若已发修行心。为对治退弱心因故。立忍精进二波罗蜜。退弱心因者。谓生死众生违逆。若事长时助善法加行疲怠。若已起发行及不退弱心。为对治坏失心因故。立定慧二波罗蜜。坏失心因者。谓散乱邪智。是故为对治六种惑障。立波罗蜜有六数。为一切佛法生起依处故者。前四波罗蜜是不散乱因。次一波罗蜜是不散乱体。由依止此不散乱故。能如实觉了诸法真理。一切如来正法皆得生起。是故为一切佛法生起依处。立波罗蜜有六数。为随顺成熟一切众生依止故者。由施波罗蜜利益众生。由戒波罗蜜不损恼众生。由忍波罗蜜能安受彼毁辱不起报怨心。由精进波罗蜜生彼善根灭彼恶根。由此利益因一切众生皆得调伏。次彼心未得寂静为令寂静。已得寂静为令解脱。故立定慧二波罗蜜。由此六度菩萨善教众生。故得成熟。是故为随顺成熟一切众生依止。立波罗蜜有六数。由如此义。是故应知成立波罗蜜有六数

此六波罗蜜相云何可见。由六种最胜六波罗蜜。通相有六。一由依止无等。谓依止无上菩提心起。二由品类无等。谓一一波罗蜜略说皆有三品。菩萨皆具修行。三由行事无等。谓安乐利益一切众生事。菩萨所行诸度皆为成此二事故。四由方便无等。谓无分别智菩萨所行诸度。皆是无分别智所摄故。五由回向无等。谓回向无上菩提菩萨所行诸度。决定转趣一切智果故。六由清净无等。谓惑智二障永灭无余。菩萨所行诸度分分除二障。乃至皆尽故。施即是波罗蜜。波罗蜜即是施耶。有是施非波罗蜜。有是波罗蜜非施。有是施是波罗蜜。有非施非波罗蜜。如施中四句应知余度亦有四句

云何说六波罗蜜如此次第。前前波罗蜜随顺次生后后波罗蜜故。复次前前波罗蜜。由后后波罗蜜所清净故

依何义立六度名。此义云何可见。于一切世间声闻独觉施等善根中。最胜无等故。以能到彼岸故。是故通称波罗蜜。能破灭吝惜嫉妒及贫穷下贱苦故称陀。复得为大富主。及能引福德资粮故称那。能寂静邪戒及恶道故名尸。复能令得善道及三摩提故称罗。能灭除嗔恚及忿恨心故名羼。复能生自他平和事故称提。能灭除懒惰及诸恶法名毗梨。复行不放逸生长无量善法故称耶。能灭除散乱故名持诃。及能引心令住内境故称那。能灭一切见行。能除邪智故名般罗。能缘真相随其品类知一切法故称若

云何应知诸波罗蜜修习。若略说应知修习有五种。一修加行方法。二修信乐。三修思惟。四修方便胜智。五修利益他事。此中前四修应知如前。利益他事修者。诸佛无功用心。不舍如来事修习诸波罗蜜。至圆满位中。更修诸波罗蜜

复次思惟修习者。爱重随喜愿得思惟六意摄所修六意者。一广大意。二长时意。三欢喜意。四有恩德意。五大志意。六善好意广大意者。若菩萨若干阿僧祇劫能得无上菩提。以如此时为一刹那刹那。菩萨于此时中刹那刹那常舍身命。及等恒伽沙数世界满中七宝奉施供养如来。从初发心乃至入住究竟清凉菩提。是菩萨施意犹不满足。如此多时刹那刹那满三千大千世界炽火。菩萨于中行住坐卧。为四威仪离一切生生之具。戒忍精进三摩提般若心菩萨恒现前修。乃至入住究竟清凉菩提。菩萨戒忍等意亦不满足。是无厌足心。是名菩萨广大意。若菩萨从初发心乃至成佛。不舍无厌足心。是名菩萨长时意。若菩萨由六波罗蜜所作利益他事。常生无等欢喜。众生得益其心欢喜所不能及。是名菩萨欢喜意。若菩萨行六波罗蜜利益众生已。见众生于我有大恩德。不见自身于彼有恩。是名菩萨有恩德意。若菩萨从六波罗蜜所生功德善根。施与一切众生以无著心回向。为令彼得可爱重果报。是名菩萨大志意。若菩萨所行六波罗蜜功德善根。令一切众生平等皆得为彼回向无上菩提。是名菩萨善好意。由此六意所摄爱重思惟菩萨修习。若菩萨随喜无量菩萨修加行六意所生功德善根。是名菩萨六意所摄随喜思惟。若菩萨愿一切众生修行六意所摄六波罗蜜。及愿自身修行六意所摄六波罗蜜。修习加行乃至成佛。是名菩萨六意所摄愿得思惟。若人得闻六意所摄菩萨思惟修习。生一念信心。是人则得无量无边福德之聚。诸恶业障坏灭无余。若人但闻尚得无量无边福德。何况菩萨尽能修行

云何应知诸波罗蜜差别。由各有三品知其差别。施三品者。一法施。二财施。三无畏施。戒三品者。一守护戒。二摄善法戒。三摄利众生戒。忍三品者。一他毁辱忍。二安受苦忍。三观察法忍。精进三品者。一勤勇精进。二加行精进。三不下难坏无足精进。定三品者。一安乐住定。二引神通定。三随利他定。般若三品者。一无分别加行般若。二无分别般若。三无分别后得般若

云何应知诸波罗蜜摄义。一切善法皆入六波罗蜜摄以为彼性故。彼是六波罗蜜所流果故。一切善法所随成故

云何应知诸波罗蜜所对治。摄一切惑以为彼性故。为彼生因故。为彼所流果故

云何应知诸波罗蜜功德。若菩萨轮转生死。大富位自在所摄。大生所摄。大眷属徒众所摄。大资生业事成就所摄。无疾恼少欲等所摄。一切工巧明处聪慧所摄。如意无失富乐利益众生为正事故。菩萨修行六度功德。乃至入住究竟清凉菩提。恒在不异故

云何应知诸波罗蜜更互相显。世尊或以施名说诸波罗蜜。或以戒名。或以忍名。或以精进名。或以定名。或以般若名说诸波罗蜜。如来以何意作如此说。于波罗蜜修行方便中。一切余波罗蜜皆聚集助成故。此即如来说意。此中说郁陀那偈

  位数相次第　　名修差别摄
  对治及功德　　互显诸度义

摄大乘论卷中摄大乘论卷下

        无著菩萨造

        真谛三藏译

    入因果修差别胜相第五

如此已说入因果胜相。云何应知入因果修差别。由十种菩萨地。何者为十。一欢喜地。二无垢地。三明焰地。四烧然地。五难胜地。六现前地。七远行地。八不动地。九善慧地。十法云地。云何应知以此义成立诸地为十。为对治地障十种无明故。于十相所显法界有十种无明犹在为障。何者能显法界十相。于初地由一切遍满义。应知法界。于二地由最胜义。于三地由胜流义。于四地由无摄义。于五地由相续不异义。于六地由无染净义。于七地由种种法无别义。于八地由不增减义。于九地由定自在依止义。由土自在依止义。由智自在依止义。于十地由业自在依止义。由陀罗尼门三摩提门自在依止义。应知法界。此中说偈

  遍满最胜义　　胜流及无摄
  无异无染净　　种种法无别
  不增减四种　　自在依止义
  业自在依止　　总持三摩提

如此二偈依中边分别论。应当了知。复次此无明应知。于二乘非染污。于菩萨是染污。云何初地名欢喜。由始得自他利益功能故。云何二地名无垢。此地远离犯菩萨戒垢故。云何三地名明焰。由无退三摩提及三摩跋提依止故。大法光明依止故。云何四地名烧然。由助菩提法能焚灭一切障故。云何五地名难胜。真俗二智更互相违能合难合令相应故。云何六地名现前。由十二缘生智依止故。能令般若波罗蜜现前住故。云何七地名远行。由至有功用行最后边故。云何八地名不动。由一切相及作意功用不能动故。云何九地名善慧。由最胜无碍辩智依止故。云何十地名法云。由缘通境知一切法一切陀罗尼及三摩提门为藏故。譬云能覆如虚空粗障故。能圆满法身故

云何应知得诸地相。由四种相。一由已得信乐相。于一一地决定生信乐故。二由已得行相。得与地相应十种法正行故。三由已得通达相。先于初地通达真如法界时。皆能通达一切地故。四由已得成就相。此十地皆已至究竟修行故。云何应知修诸地相诸菩萨。先于地地中修习奢摩他毗钵舍那。各有五相修习得成。何者为五。一集总修。二无相修。三无功用修。四炽盛修。五不知足修。应知于诸地皆有此五修。此五修生五法为果。何者为五。一刹那刹那能坏一切粗重依法。二能得出离种种乱想法乐。三能见一切处无量无分别相善法光明。四如所分别法相转得清净分恒相续生。为圆满成就法身。五于上品中转增为最上上品因缘聚集。于十地中修十波罗蜜随次第成。于前六地有六波罗蜜如次第说。于后四地有四波罗蜜。一沤和拘舍罗波罗蜜。六波罗蜜所生长善根功德。施与一切众生悉令平等。为一切众生回向无上菩提。二波尼他那波罗蜜。此度能引摄种种愿。于未来世感六度生缘故。三婆罗波罗蜜。由思择修习力伏诸波罗蜜对治故。能引六波罗蜜相续生无有间缺。四若那波罗蜜。此度是能成立前六度智。能令菩萨于大集中受法乐。及成熟众生。后四波罗蜜应知是无分别后智。摄一切波罗蜜。于一切地中不同时修习。从波罗蜜藏藏经。应知此法门广显诸义。于几时中修习十地。正行得圆满。有五种人。于三阿僧祇劫修行圆满。或七阿僧祇劫。或三十三阿僧祇劫。何者为五人。行愿行地人满一阿僧祇劫。行清净意行人。行有相行人。行无相行人。于六地乃至七地满第二阿僧祇劫。从此后无功用行人。乃至十地满第三阿僧祇劫。复次云何七阿僧祇劫。地前有三地。中有四地。前三者。一不定阿僧祇。二定阿僧祇。三授记阿僧祇。地中有四者。一依实谛阿僧祇。二依舍阿僧祇。三依寂静阿僧祇。四依智慧阿僧祇。复次云何三十三阿僧祇。方便地中有三阿僧祇。一信行阿僧祇。二精进行阿僧祇。三趣向行阿僧祇。于十地中地地各三阿僧祇。谓入住出。如此阿僧祇修行十地正行圆满

  有善根愿力　　心坚进增上
  三种阿僧祇　　说正行成就

    摄大乘论依戒学胜相第六

如此已说入因果修差别。云何应知依戒学差别。应知如于菩萨地正受菩萨戒品中说。若略说由四种差别。应知菩萨戒有差别。何者为四。一品类差别。二共不共学处差别。三广大差别。四甚深差别。品类差别者。有三种。一摄正护戒。二摄善法戒。三摄众生利益戒。此中摄正护戒应知是二戒依止。摄善法戒是得佛法生起依止。摄众生利益戒是成熟众生依止。共学处戒者。是菩萨远离性罪戒。不共学处戒者。是菩萨远离制罪所立戒。此戒中或声闻是处有罪。菩萨于中无罪。或菩萨是处有罪。声闻于中无罪。菩萨有治身口意三品为戒。声闻但有治身口为戒。是故菩萨有心地犯罪。声闻则无此事。若略说所有身口意业事。能生众生利益无有过失。此业菩萨皆应受学修行。如此应知共不共戒差别。广大差别者。应知有四种。由四种广大故。一种种无量学处广大。二能摄无量福德广大。三摄一切众生利益安乐意广大。四无上菩提依止广大。甚深差别者。若菩萨由如此方便胜智行。杀生等十事无染浊过失。生无量福德速得无上菩提胜果。复次有变化所作身口业。应知是菩萨甚深戒。由此戒有时菩萨正居大王位。或现种种逼恼众生。为安立众生于戒律中。或现种种本生。由逼恼他及逼恼怨对。令他相爱利益安心。生他信心为先。后于三乘圣道中令彼善根成熟。是名菩萨甚深戒差别。由此四种差别。应知是略说菩萨受持戒差别。复次由此四种差别。更有差别不可数量菩萨戒差别。如毗那耶瞿沙毗佛略经中说

    摄大乘论依心学胜相第七

如此已说依戒学差别。云何应知依心学差别。略说由六种差别应知。何者为六。一境差别二众类差别。三对治差别。四随用差别。五随引差别。六由事差别。境差别者。由缘大乘法为境起故。众类差别者。大乘光三摩提。集福德王三摩提。贤护三摩提。首楞伽摩三摩提等。摄种种三摩提品类故。对治差别者。由缘一切法为通境智慧。如以楔出楔方便故。于本识中拔出一切粗重障故。随用差别者。于现世久安住三摩提乐中。如意能于胜处受生。随引差别者。能引无碍神通于一切世界。由事差别者。令动放光遍满显示转变往还。促远为近转粗为细变细为粗。令一切色皆入身中。似彼同类入大集中。或显或隐。具八自在伏障他神力。或施他辩才及忆念喜乐。或放光明能引具相大神通。能引一切难行正行。以能摄十种难修正行故。何者为十。一自受难修。自受菩提善愿故。二不可回难修。由生死众苦不令退转故。三不背难修。由众生作恶一向对彼故。四现前难修。于有怨众生现前为行一切利益事故。五无染难修。菩萨生于世间不为世法之所染故。六信乐难修。行于无底大乘。能信乐广大甚深义故。七通达难修。能通达人法二无我故。八随觉难修。诸佛如来甚深不了义经能如理判故。九不离不染难修。不舍生死不为生死染污故。十加行难修。诸佛如来于一切障解脱中住不作功用。能行一切众生利益事。乃至穷生死后际乐修如此加行故。于随觉难修诸佛如来说不了义经。其义云何。菩萨应随理觉察。如经言。云何菩萨不损一物不施一人。若菩萨善能行施无量无数。于十方世界修布施行相续生起。云何菩萨乐行布施。若菩萨不乐行一切施。云何菩萨行信施心。若菩萨不行诸佛如来信心。云何菩萨发行布施。若菩萨于布施中不策自身。云何菩萨恒游戏布施。若菩萨无布施时。云何菩萨能大行施。若菩萨于施离娑罗想。云何菩萨于施清净。若菩萨郁波提贪吝。云何菩萨能住于施。若菩萨不住究竟后际。云何菩萨于施自在。若菩萨于施不得自在。云何菩萨于施无尽。若菩萨不住无尽中如施经。于戒乃至般若如理应知。复有经言。云何菩萨行杀生。若菩萨有命众生断其相续。云何菩萨夺非他所与。若菩萨自夺非他所与众生。云何菩萨行邪淫。若菩萨于欲尘起邪意等。云何菩萨能说妄语。若菩萨是妄能说为妄。云何菩萨行两舌。若菩萨恒住最极空寂处。云何菩萨能住波留师。若菩萨住所知彼岸。云何菩萨能说不相应语。若菩萨能分破诸法随类解释。云何菩萨行阿毗持诃娄。若菩萨数数令自身得无上诸定。云何菩萨起憎害心。若菩萨于自他心地能害诸惑。云何菩萨起邪见。若菩萨一切处遍行邪性如理观察。复有经言。佛法甚深。何者甚深。此论中自广分别。一切佛法常住为性。由法身常住故。一切佛法皆断为性。由一切障皆断尽故。一切佛法生起为性。由化身恒生起故。一切佛法能得为性。能得共对治众生八万四千烦恼行故。一切佛法有欲为性。有欲众生爱摄令成自体故。一切佛法有嗔为性。一切佛法有痴为性

一切佛法凡夫法为性。一切佛法无染着为性。成就真如一切障不能染故。一切佛法不可染着。诸佛出现于世。非世法所能染故。是故说佛法甚深。为修行波罗蜜。为成熟众生为清净佛土。为引摄一切佛法故。菩萨三摩提业差别应知

    摄大乘论依慧学胜相第八

如此已说依定学差别。云何应知依慧学差别。由无分别智自性依止缘起境界相貌立救难摄持伴类。果报等流出离。究竟行善加行无分别智后得智功德。无差别加行。无分别后得智。譬威德无功用作事甚深义故。应知依慧学差别。由依慧学差别。应知无分别智差别。无分别智自性。应知离五种相。五相者。一离非思惟故。二离非觉观地故。三离灭想受定寂静故。四离色自性故。五于真实义离异分别故。是五相所离智。此中应知是无分别智。于此中如所说。无分别智性中故说偈言

  诸菩萨自性　　五种相所离
  无分别智性　　于真无分别
  诸菩萨依止　　非心非非心
  是无分别智　　非思疾类故
  诸菩萨因缘　　有言闻熏习
  是无分别智　　如理正思惟
  诸菩萨境界　　不可言法性
  是无分别智　　二无我真如
  诸菩萨相貌　　于真如境中
  是无分别智　　无相无差别
  相应自性义　　所分别非他
  字字相续故　　由相应义成
  离言说智慧　　于所知不起
  于言不同故　　一切不可言
  诸菩萨摄持　　是无分别智
  此后得行持　　为生长究竟
  诸菩萨伴类　　说是二种道
  是无分别智　　五度之品类
  诸菩萨果报　　于佛二圆聚
  是无分别智　　由加行至得
  菩萨等流果　　于后后生中
  是无分别智　　由展转增胜
  诸菩萨出离　　得成相应故
  是无分别智　　应知于十地
  诸菩萨究竟　　由得净三身
  是无分别智　　至胜自在故
  不染如虚空　　此无分别智
  种种重恶业　　由唯信乐故
  清净如虚空　　此无分别智
  解脱一切障　　由得及成就
  如虚空无染　　是无分别智
  若出现于世　　非世法所染
  如哑求受尘　　如哑正受尘
  如非哑受尘　　三智譬如此
  如愚求受尘　　如愚正受尘
  如非愚受尘　　三智譬如此
  如五求受尘　　如五正受尘
  如非五受尘　　三智譬如此
  如未识求解　　如读正受法
  如解受法义　　次第譬三智
  如人正闭目　　无分别亦尔
  如人正开目　　后得智亦尔
  如空无分别　　无染碍异边
  如空中色现　　后得智亦尔
  譬摩尼天鼓　　无思成自事
  如此不分别　　种种佛事成
  非此非非此　　非智非非智
  与境无差别　　智名无分别
  佛说一切法　　自性无分别
  所分别无故　　彼无无分别

此中无分别有三种。一加行无分别。二无分别智。三无分别后智。加行无分别有三种谓因缘引通数习力生起差别故。无分别智亦有三种。谓知足无颠倒无戏论。无分别差别故。无分别后智有五种。谓通达忆持成立相杂如意。显示差别故。为成立无分别智。复说别偈

  饿鬼畜生人　　诸天等如应
  一境心异故　　许彼境界成
  于过去未来　　于梦二影中
  智缘非有境　　此无转为境
  若尘成为境　　无无分别智
  若此无佛果　　应得无是处
  得自在菩萨　　由愿乐力故
  如意地等成　　得定人亦尔
  成就简择人　　有智得定人
  于内思诸法　　如义显现故
  无分别修时　　诸义不显故
  应知无有尘　　由此故无识

此无分别智即是般若波罗蜜。名异义同。如经言。若菩萨住般若波罗蜜。由非处修行能圆满修习所余波罗蜜。何者非处修行能圆满修习所余波罗蜜。谓离五种处。一离外道我执处。二离未见真实菩萨分别处。三离生死涅槃二边处。四离唯灭惑障知足行处。五离不观利益众生事住无余涅槃处。声闻智慧与菩萨智慧差别云何。应知由无分别差别不分别阴等诸法门故。由非一分差别通达二空真如。入一切所知相故。依止一切众生利益事故。由无住差别住无住处涅槃故。由恒差别于无余涅槃不堕断尽边际故。由无上差别实无异乘胜此故。此中说偈

  由智五胜异　　依大悲修福
  世出世富乐　　说此不为远

若菩萨于世间实有亦复可知。若菩萨如此依戒定慧学功德聚相。应至十种自在。于一切利他事得无等胜能。云何于世间中见有众生遭重苦难。由菩萨见彼众生有业能感苦报障胜乐果故。由菩萨见如此若施彼乐具则障其生善。由菩萨见彼无乐具能现前厌恶生死。由菩萨见若施彼乐具则是生长一切恶法因缘。由菩萨见若施彼乐具则是逼害余无量众生因缘。是故菩萨不无如此能。世间亦有如此众生显现。此中说偈

  见业障碍善　　厌现及恶增
  害他彼众生　　不感菩萨施

    摄大乘论学果寂灭胜相第九

如此已说依慧学差别。云何应知寂灭差别。诸菩萨惑灭即是无住处涅槃此相云何。舍离惑与不舍离生死。二所依止转依为相。此中生死是依他性。不净品一分为体。涅槃是依他性。净品一分为体本依者是具净不净品二分依他性。转依者对治起时此依他性。由不净品分永改本性。由净品分永成本性。此转依若略说有六种转。一益力损能转。由随信乐位住闻熏习力故。由烦恼有羞行惭弱行。或永不行故。二通达转。谓已登地诸菩萨。由真实虚妄显现为能故。此转从初地至六地。三修习转。由未离障人是一切相不显现真实显现依故。此转从七地至十地。四果圆满转。由已离障人一切相不显现清净真如显现至得一切相自在依故。五下劣转。由声闻通达人无我故。由一向背生死为永舍离生死故。六广大转。由菩萨通达法无我故。于中观寂静功德故。为舍不舍故。若菩萨在下劣转位有何过失。不观众生利益事故。远离菩萨法。与下乘人同得解脱此为过失。诸菩萨若在广大转位有何功德。于生死法中由自转依为依故。得诸自在于一切道中能现一切身。于世间富乐及于三乘。由种种教化方便胜能能安立彼于正教。是广大转功德。此中说偈

  于凡夫覆真　　于彼显虚妄
  于菩萨一向　　舍虚显真实
  不显现显现　　虚妄及真实
  是菩萨转依　　解脱如意故
  于生死涅槃　　若智起等等
  生死即涅槃　　二无此彼故
  是故于生死　　非舍非非舍
  于涅槃亦尔　　无得无不得

    摄大乘论智差别胜相第十

如此已说寂灭差别。云何应知智差别。由佛三身。应知智差别。一自性身。二受用身。三变化身。此中自性身者。是诸如来法身。于一切法自在依止故。受用身者。诸佛种种土。及大人集轮依止所显现。此以法身为依止。诸佛土清净。大乘法受乐受用因故。变化身者。以法身为依止。从住兜率陀天及退。受生受学受欲尘。出家往外道所修苦行。得无上菩提转法轮。大般涅槃等事所显现故。诸佛如来所有法身其相云何。若略说其相应知有五种。此中说郁陀那偈

  相证得自在　　依止及摄持
  差别德甚深　　念业明佛身

五相者。一法身转依为相。一切障及不净品分。依他性灭已解脱一切障。于一切法得自在。为能清净性分依他性转依为相故。二白净法为相。由六度圆满。于法身至得十种自在胜能为相故。何者为十。一命自在。二心自在。三财物自在。此三由施度圆满得成。四业自在。五生自在。此二由戒度圆满得成。六欲乐自在。由忍度圆满得成。七愿自在。由精进度圆满得成。八通慧自在。此五通所摄。由定度圆满得成。九智自在。十法自在。此二由般若波罗蜜圆满得成。三无二为相。由无有无二相故。一切法无所有空相不无为相故。复次有为无为无二为相。非惑业集所生故。由得自在能显有为相故。复次一异无二为相。诸佛如来依止不异故。由无量依止能证此故。此中说偈

  我执不有故　　于中无依别
  如前多依证　　假名说不一
  性行异非虚　　圆满无初故
  不一无异故　　不多依真如

四常住为相。真如清净相故。昔愿引通最为极故。应作正事未究竟故。五不可思议为相。是真如清净自证智所知故。无譬喻故。非觉观行处故

复次此法身证得云何。是触从初所得。由缘相杂大乘法为境。无分别智无分别后所得智五相修成熟修习。于一切地善集资粮。能破微细难破障故。金刚譬三摩提。即此三摩提后灭离一切障故。是时由依止转成证得。应知此法身有几自在于中得自在。若略说有五自在于中得自在。一净土显示自身相好无边音不可见顶自在。由转色阴依故。二无失无量大安乐住自在。由转受阴依故。三具足一切名字文句聚等中正说自在。由转想阴执相差别依故。四变化改易引摄大集牵白净品自在。由转行阴依故。五显了平等回观作事智自在。由转识阴依故

此法身应知为几法依止。若略说唯三。诸佛如来种种住处依止故。此中说偈

  诸佛如来受五喜　　皆因证得自界故
  二乘无喜由不证　　求喜要须证佛界
  由能无量作事立　　由法美味欲得成
  得喜最胜无有失　　诸佛恒见四无尽

种种受用身依止。为成熟诸菩萨善根故。种种化身依止。为多成熟声闻独觉善根故。有几种佛法应知摄此法身。若略说有六种。一清净类法。由转阿黎耶识依故。由证得法身故。二果报类法。由转有色根依故。由证得果报胜智故三住类法。由转受行欲尘依故。由无量智慧住故。四自在类法。由转种种业等摄自在依故。由于一切十方世界无阂六通智自在故。五言说类法。由转一切见闻觉知言说依故。由能饱满一切众生心正说智自在故。六拔济类法。由转一切灾横过失拔济意依故。由一切众生灾横过失拔济智自在故。如此六种类法所摄诸佛如来法身。应知诸佛法身为可说有差别。为无差别。由依止意用业无异故。应知无差别。由无量正觉等事故。应知有差别。如法身受用身亦尔。由依止业不异故。应知无差别。不由依止差别故无差别。无量依止转依故。变化身应知如受用身。此法身应知与几种功德相应与最清净四无量相应。与八解脱八制入十一切入。无诤三摩提愿智四无阂解六通慧。三十二大人相八十小相。四种一切相清净十力四无畏。四无护三念处。拔除习气无忘失法大悲十八不共法。一切相最胜智等诸法相应。此中说偈

  于众生大悲　　离诸结缚意
  不离众生意　　利乐意顶礼
  解脱一切障　　降伏世智者
  应知智遍满　　心解脱顶礼
  诸众生无余　　能灭一切惑
  害惑有染污　　常怜愍顶礼
  无功用无著　　无碍恒寂静
  一切众生难　　能释我顶礼
  于依及能依　　应说言及智
  于能说无碍　　说者我顶礼
  故随彼类音　　行往还出离
  证知诸众生　　正教我顶礼
  诸众生见尊　　信敬调胜士
  由他见能生　　净心我顶礼
  摄受住及舍　　变化及改性
  得定智自在　　世尊我顶礼
  方便归依净　　于中障众生
  于大乘出离　　摧魔我顶礼
  智灭及出离　　障事能显说
  于自他两利　　降邪我顶礼
  无制无过失　　无染浊无住
  于诸法无动　　无戏论顶礼
  于众伏他说　　二惑所远离
  无护无忘失　　摄众我顶礼
  于利益他事　　尊不过待时
  所作恒无虚　　无迷我顶礼
  于一切行住　　无非圆智事
  遍知一切世　　实体我顶礼
  日夜六时观　　一切界众生
  与大悲相应　　利乐意我礼
  由行及由得　　由智及由事
  于一切二乘　　无等我顶礼
  由三身尊至　　具相无上觉
  一切法他疑　　能除我顶礼
  无系无过失　　无粗浊无住
  于诸法无动　　无戏论顶礼

诸佛法身不但恒与如此等功德相应。复与余功德相应。谓自性因果业相应。行事功德相应。是故应知诸佛法身有无上功德。此中说偈

  尊成就真如　　修诸地出离
  至他无等位　　解脱诸众生
  无尽等功德　　相应现于世
  于三轮易现　　难见人天等

复次如来法身甚深最甚深。此甚深云何可见此中说偈

  佛无生为生　　以无住为住
  作事无功用　　第四食为食
  不异亦无量　　无数量一事
  最坚不坚业　　无上应三身
  无一法能觉　　一切无不觉
  一一念无量　　有不有所显
  无欲无离欲　　依欲得出离
  已知欲无欲　　故入欲法如
  诸佛过五阴　　于五阴中住
  与阴非一异　　不舍阴涅槃
  诸佛事相杂　　犹如大海水
  我已正应作　　他事无是思
  由失尊不现　　如月于破器
  遍满诸世间　　由法光如日
  或现得正觉　　或涅槃如火
  此二实不有　　诸佛常住故
  如来于恶事　　人道及恶道
  于非梵行法　　住第一住我
  佛一切处行　　亦不行一处
  于一切生现　　非六根境界
  诸惑已灭伏　　如毒咒所害
  留惑至惑尽　　佛证一切智
  诸惑成觉分　　生死为涅槃
  得成大方便　　故佛难思议

由此义故十二种甚深应知。谓生不住业住甚深。安立数业甚深正觉甚深。离欲甚深。阴灭甚深。成熟甚深。显现甚深。菩提般涅槃显现甚深。住甚深。显自体甚深。灭惑甚深。不可思议甚深

诸菩萨缘法身忆念佛。此念缘几相。若略说诸菩萨依法身修习念佛有七种相。何等为七。一诸佛于一切法至无等自在。如此修习念佛。于一切世界至得无碍无边六通智。故此中说偈

  被障因不具　　一切众生界
  住二种定中　　诸佛无自在

二如来身常住。由真如无间解脱一切垢故。三如来最无失。一切惑障及智障永相离故。四一切如来事无功用成。不由功用恒起正事永不舍故。五如来大富乐位。一切佛土最微妙清净为富乐故。六如来最无染着。出现世间非一切世法所染。如尘不能染空故

七如来于世间有大事用。由现成无上菩提及大般涅槃。未成熟众生令成熟。已成熟众生令解脱故。此中说偈

  随属如来心　　圆德常无失
  无功用能施　　众生大法乐
  遍行无有碍　　平等利多人
  一切一切佛　　智人缘此念

复次诸佛如来净土清净其相云何应知。如言百千经菩萨藏缘起中说。佛世尊在周遍光明七宝庄严处。能放大光明普照无量世界无量妙饰界处。各各成立大城。边际不可度量。出过三界行处。出出世善法。功能所生最清净自在唯识为相。如来所镇菩萨安乐住处。无量天龙夜叉阿修罗迦楼罗紧那罗摩睺罗伽人非人等所行。大法味喜乐所持。一切众生一切利益事为用。一切烦恼灾横所离。非一切魔所行处。胜一切庄严。如来庄严所依处。大念慧行出离大奢摩他毗钵舍那乘。大空无相无愿解脱门入处。无量功德聚所庄严。大莲花王为依止。大宝重阁如来于此中住。如此净土清净显色相圆净形貌量处。因果主助眷属持业利益无怖畏住处路乘门依止圆净。由前文句如此等圆净皆得显现。复次受用如此净土清净。一向净一向乐。一向无失一向自在

复次诸佛法界恒时应见有五业。一救济灾横为业。由唯现盲聋狂等疾恼灾横能灭除故。二救济恶道为业。从恶处引拔安立于善处故。三救济行非方便为业。诸外道等加行非方便。降伏安立于佛正教故。四救济行身见为业。为过度三界能显导圣道方便故。五救济乘为业。诸菩萨欲偏行别乘。未定根性声闻能安立彼为修行大乘故。于如此五业应知诸佛如来共同此业。此中说偈

  因依事意及诸行　　异故世间许业异
  此五种异于佛无　　是故世将同一业

若尔声闻独觉非所共得如此众德相应诸佛法身。诸佛以何意故。说彼俱趣一乘与佛乘同。此中说偈

  未定性声闻　　及诸余菩萨
  于大乘引摄　　定性说一乘
  法无我解脱　　等故性不同
  得二意涅槃　　究竟说一乘

三世诸佛若共一法身。云何世数于佛不同。此中说偈

  于一界中无二故　　同时因成不可量
  次第成佛非理故　　一时多佛此义成

云何应知诸佛法身非一向涅槃。非非一向涅槃。此中说偈

  由离一切障　　应作未竟故
  佛一向涅槃　　不一向涅槃

云何受用身不成自性身。由六种因故。一由色身及行身显现故。二由无量大集处差别显现故。三随彼欲乐见显现自性不同故。四别异别异见自性变动显现故。五菩萨声闻天等种种大集相杂和合时。相杂显现故。六阿黎耶识及生起识见。转依非道理故。是故受用身无道理成自性身。云何变化身不是自性身。由八种因故。一诸菩萨从久远来。得无退三摩提。于兜率陀天道及人道中受生。不应道理。二诸菩萨从久远来恒忆宿住。方书算计数量印相工巧等论。行欲尘及受用欲尘中菩萨无知不应道理。三诸菩萨从久远来。已识别邪正法教。往外道所事彼为师。不应道理。四诸菩萨从久远来。已通达三乘圣道正理。为求道故修虚苦行。不应道理。五诸菩萨舍百拘胝阎浮提。于一处得无上菩提及转法轮。不应道理。六若离显无上菩提方便。但以化身于他方作佛事。若尔则应于兜率陀天上成正觉。七若不尔。云何佛不于一切阎浮提中平等出现。若不于他方出现。无阿含及道理可证此义八二如来于一世界俱现此不相违。若许化身成多。由四天下摄一世界。如转轮王。于一世界或一主或别主俱生。不应道理。诸佛亦尔。此中说偈

  佛微细化身　　多入胎平等
  为显具相觉　　于世间示现

有六种因。诸佛世尊于化身中不得永住。一正事究竟故。由已解脱成熟众生故。二若已得解脱求般涅槃。为令彼舍般涅槃意。欲求得常住佛身故。三为除彼于佛所有轻慢心故。为令彼通达甚深真如法及正说法故。四为令众生于佛身起渴仰心数见无厌足故。五为令彼向自身起极精进。由知正说者不可得故。六为令彼速得至成熟位向自身不舍荷负极精进故。此中说偈

  由正事究竟　　为除乐涅槃
  令舍轻慢佛　　发起渴仰心
  令向身精进　　及为速成熟
  诸佛于化身　　许非一向住

为度一切众生。由发愿及修行寻求无上菩提。一向般涅槃。此事不应道理。本愿及修行相违无果故

复次受用身及变化身无常故。云何诸佛以常住法为身。由应身及化身恒依止法身故。由应身无舍离故。由化身数起现故。如恒受乐。如恒施食。二身常住应如此知。若法身无始时。无差别无数量。为得法身不应不作功用。此中说偈

  诸佛证得等无量　　是因众生若舍勤
  证得恒时不成因　　断除正因不应理

阿毗达磨大乘藏经中名摄大乘。此正说究竟

摄大乘论卷下


十八空论(亦十六亦十八亦十四亦十七)

    No. 1616

十八空论(亦十六亦十八亦十四亦十七)

        龙树菩萨造

        陈天竺三藏真谛译

问空无分别。云何得有十八种耶。答为显人法二无我。是一切法通相。今约诸法。种类不同。开为十八。何者。一内空。二外空。三内外空。四大空。五空空。六真实空。七有为空。八无为空。九毕竟空。十无前后空。十一不舍离空。十二佛性空。十三自相空。十四一切法空。十五无法空。十六有法空。十七无法有法空。十八不可得空。合此十八为十六空。凡有两义故。立十六空。一体二用。第一内空。亦名受者空。凡夫二乘谓六入为受者。以能受六尘果报故。今明但有六根。无有能执。以无执故。言受者空也

第二外空。亦名所受空。离六外入无别法为可受者也。若诸众生所受所用。但是六尘。内既无人能受。外亦无法可受。即人法俱空。唯识无境。故名外空。以无境故。亦无有识。即是内空。六入无识。即是无人。无有根尘。即是无法。故内外二空。两义相成也

第三内外空。谓身空也。此身四大为内外所依。内依即六根若五根。皆有净色及意根。并依此身。故名内依。外依者。谓外六尘。若己身四大。唯除五根净色。所余色香等。属外六尘。摄持于五根故称为外。非谓离身之外也。此身能持根尘。故名为依。根尘所依也。此根及非根。皆悉是空故。名内外空也

第四大空。谓身所迻托。即器世界。十方无量无边。皆悉是空。故名大空

第五空空。能照真之相。会前四空。从境得名。呼为空智。空智亦空。故立空空

第六真实空。谓真境空。行者见内外皆空。无人无法。此境真实。立真实名。由分别性。性不可得。名分别性。性空即真实空也。此六空辩。空体自成次第。一受者空。二所受空。三自身空。四身所住处空。五能照空。六所观境空也。前四皆是所观境空。第五能观智空。第六所分别境界相貌空。又前四所知。第五能知。第六所知相貌。第五智空治前四境。四境是空。第六真空。治第五智故智成空。若无第五智空治前四境。则有人有法。是分别性。由此智见前境。是无人无法。即治前境。若无第六境空治第五智。此智既但真解。还成分别性故。言第六真实空。名为治智也

第二义明空自有十二。一者行空。二非行空。菩萨学此两空为得二种善法。一谓善道。二谓善果。道即三十七品等。善果即是菩提等也。行空者。明三乘诸道无人法。非真实。非虚妄。离此四种心。是名善因。为得此善因。是故菩萨学观行空。非行空者。谓二种善果。即余无余涅槃。若有余除集。此果则离四种颠倒。非是常乐我净。若无余灭苦。即是常乐我净。此第七第八两空。是净菩萨自度。初得道后一得果

第三毕竟空。为恒利益他菩萨修空。毕竟恒欲利他。至众生尽。誓恒教化。此心有着。今此观心。此心定令舍毕竟之心。自然利益。方是真实智名毕竟空也。若作毕竟心。能为利益。不作不益。不复自然。恒利益不空。此毕竟之心。是智第九名毕竟空

第四无前后空。亦名无始空。为成毕竟空利益他故。不前后即无始终。菩萨若不解其是空。则生疲厌之心舍弃生死。既见生死是空。则不分别前之与后。及以始终既不分别始终。则于短于长心无忧喜。于长不忧。闻短不喜。既离忧喜。则能不舍生死。以不舍故。毕竟利益乃得成也。是故第十观无始空

第五不舍离空。菩萨修学此定止。为功德善根无尽。何以故。一切诸佛于无余涅槃中。亦不舍功德善根门。有流果报已尽。功德善根本为化物故。恒有此用。如来虽入涅槃。犹随众生机缘。现应化两身。导利含识。即是更起心义。故众生不尽应化之用亦不尽。故言虽入无余而不舍功德善根也。若二乘入灭。无更起心。以慈悲薄少。不化众生。若佛入无余而更起心者。以诸佛菩萨三身利物无穷故。如来法身即是一切无流法之依处故。言散灭不舍离功德也。所以得知涅槃之中犹有法身者。以用终体。既睹应化之用不尽。故知此身之体。常自湛然。永无迁坏。如毗婆沙师说。无涅槃无有自相。而不可言无。何以故。为能显事用故。若不依涅槃不成智慧。智慧不成则烦恼不灭。涅槃既能生道。道能灭惑。即是涅槃家事。既见有事。则知应有体故。不得言无也。如来法身在涅槃中。即义亦尔。为除分别涅槃不舍功德。即是分别性。真实义中。无此分别。故名不舍离空。语言说涅槃不舍功德。而涅槃中亦无不舍之意。故名不舍空。即成不舍生死之意。前明不舍生死毕竟利他。异于二乘不能永利。今明虽在生死及涅槃并皆化物。此义不异故。前来至此。凡有三空。名利他事。此即第十一不舍空。亦名不散空也六性空。七相空。八一切法空。此三明自利利他因。问空何所为。答为清净佛性即空故名性空。问何故名性空

答佛性者。即是诸法自性。何以故。自然有故。但自性有两义。一无始。二因。譬如无始生死中。有心无心两法自然无因。若心有因。此因为本。有为始有。若本有因。此因即是自然。既是自然。亦应许心是自然。昔未有因。应无众生。有时有因。方有众生。如土石等。若有因时应成众生。故知自然一分作有心。一分作无心。故言譬如无始生死中。有心无心两法自然无因也。佛性亦尔。自然无因。虚妄尚有自然义。何况真实而不自然。故由无始佛性为因。所以六入欲求解脱。若无佛性。解脱之果。不得成就。譬如净珠能清浊水。以佛性无始故。生死无始一异空。净不净空等如上说。此空性为离五失显五种功德。人法是分别性从人法生分别。是依他性。就分别性觅法不可得。就依他性觅所分别之人法。亦不可得。即真实性。真实无体。无体故无相。无相故无生。无生故无灭。无灭故寂静。寂静即是自性涅槃。此自性空除五种过失。一除下劣心。不薄信佛性是有可得。得之有无量功德。则不能发菩提心。不发此心。常守下劣。佛性令其发心。故言能除下劣心也。二除高心。若人不解佛性平等。谓我有佛性。我已发心。他无佛性。不能发心故高慢。若体此理。无有此彼。高心即灭。故言能除高心也。三除着虚妄弃舍真实。虚妄所以是生死过失者。如人来打拍骂詈毁辱等事。一非本有。二由心所作。虚妄所起。非是自然。即是虚妄。若不体真实道理。谓此是真实。则取着虚妄。皆弃真实。故生三毒利等烦恼。若识生死虚妄非是实有则不见能拍所骂。不见众生过失。不生烦恼。即弃虚妄。但见众生皆有佛性。功德圆同。即是能取真实。由此即生慈悲成菩萨者。四能除我见。诸法本来自性真实。若有若无。二皆平等。若人能作此解。即舍我见执相之心也。五除怖畏。能令众生信受甚深正法。正法有相与无相体解佛性则能信受。无相正法则不谤大乘也。次明此性空能引五种功德者。一除下劣生正勤。二除高慢生平等。三除虚妄生慈悲。四除见生般若。五除怖畏受正法故言性空。显佛性理有五种功德。离五过失。治护性令得清净。即是自利因故。此第十二名为性空。佛性即是空也

七自相空。为得三十二大相。八十小相。相又有二种。一者色相。谓四大五尘。二无色相。谓一切四阴心法也。化身非生死。非涅槃。何以故。生死是虚妄颠倒。不过苦集两谛。化身不尔。依法应身而有体非颠倒。复能除众生颠倒。故言非生死。非涅槃者。有始终故以非生死。则无生死虚妄之相。以非涅槃。亦无涅槃真实之相。故名相空。若菩萨能修此相空。则令三十二相。八十种好。即修治化身之相貌。令得清净故。第十三名为相空

八一切法空者。谓一切如来法无量恒河沙。如十力无畏等。明相离不相离空。若以法身望应身。有离不离。但应身没不离法身。何以故。一为法身是本。应身为末。末不离本。本为离末。问法身若不离应身者。有何过咎

答若尔则一人得佛。一切人皆应得。以一切人不同得故。故知法身有不即应身义。法身亦不离应身。何以故。以法身无有差别。常不离三世诸佛功德故。若能如此。亦离亦不离。道理而修行者。此则能得应身之果。但应化两身悉能利物。化身正为下种。应身为成熟。令此一切法空为清净一切佛法。一切佛法复有两义。一则无离无不离。以不可偏执。二则无执及所执。以境智无差别故也。此即第十四辨一切法空。至此凡有三空。明自利利他因竟。第十五有法空。第十六无法空。此两空通出前十四空体。言有法空者。谓人法二无所有。为除增益谤。言无法空者。谓真实有。此无人无法之道理。除众生妄执。谓无此道理故名无法空。为除损减谤。离增离减。则非有无。故名为空体也。故此两空还属前十四空所摄也

第十七有法无法空。此一空出诸空相。所言有法无法空者。明此空体相。决定无法。即名决定无。有此无人法之道理故。名决定有。此无此有。是空体相。体明理无增减。相明其体决定。决定是无。决定是有。即是真实无。真实有。真实无人无法。真实有此道理。此论所以但明十六空者。正以此两空属前六空体所摄也。亦为十四空者。即后四空还辨前诸体相故。此后空并属前十四摄故。有十四十六十八广略不同

第十八出空果。所言不可得空者。明此果难得。何以故。如此空理。非断非常。而即是大常。常义既不可得。故断义亦不可得。无有定相可得故名难得。何以故。此之空理。非苦非乐。而是大乐。非我无我。而是大我。非净非不净。而是大净。此空属八空事用所摄。以见无人法正是空体故名随事用不同离张成异。如上所辩。初六空明空体即十空明空用。用中后两空。为十四空所摄。第十七一空。为六空体所摄。第十八一空。为八空用所摄。故十八成十六。十六还十四。或先广后略。或先略后广。理事不同。体相差别。若离若合。其义如此也。此下第四分别空道理有三。一净不净。若言空。定是不净。则一切众生不得解脱。何以故。以定不净不可令净故也。若言定是净。则修道无用。何以故。未得解脱无漏道时。空体本已自然清净故。则无烦恼为能障智慧。又能除则不依功力一切众生自得解脱。现见离功力众生不得解脱。知此空非是定净。复由功用而得解脱。故知此空非定不净。是名净不净不净净道理也。又释。若言空理定是不净。一切功力则无果报。何以故。以空界自性是不净。虽复生道俗不可除。道则无用。无此义故。故知此空非性不净

问若尔既无自性不净。亦应无有自性净。云何分判法界非净非不净

答阿摩罗识是自性清净心。但为客尘所污故名不净。为客尘尽故立为净

问何故不说定净定不净。而言或净或不净耶

答为显法界与五入及禅定等义异。所以不说净者。为明眼等诸根虽为烦恼所覆而不为烦恼所染。又非是净。又非自性净故不说为净。若是法界虽为烦恼所覆。而不为烦恼所染故非不净。而是自性净。以是自性净故。不说为不净。故知法界与五入体异也。问何故不说定是不净。答为明与禅定有异。何以故。若言法界定有烦恼。即自性不净。而此法界虽为烦恼所覆。而非自性不净故。不得说定是不净非不净。正是法界之道理定有。问何故不说如如定净。而言净不净耶。答为令众生修道故。说为净不净。即显如如与五根有异。何以故。如如及五根。同为烦恼所覆。而并不为烦恼所染。同皆是净而净义有异。何以故。五根体离烦恼。非烦恼性故。五根唯净。非是不净。若如如不离烦恼。而是烦恼自性。故知净而复有不净之义。又如如及禅定。同为烦恼所覆。并有不净义而不净义不同。若是禅定。为烦恼所覆。而复被染一向失于自性。举体成烦恼亦成不善。若是如如。虽复不离烦恼。名为不净。而犹不失自性。亦不转成烦恼及以不善故。言即不净而复有净义。可为三句。一五根离烦恼。不为烦恼所染。则但是净。非是不净。二禅定成烦恼。为烦恼所染。但是不净。无复有净。三如如以异五根故。不为烦恼所染。是净而不离烦恼。即是不净。故言净而复有不净义也。又如如以异禅定故。不离烦恼。故言不净而犹不失自性。亦不转成烦恼及以不善。故言即不净而复有净义。二明非有非无道理。无人无法。故言非有实有。无人无法之道理。故言非无。亦言真实有真实无。即非有非无也。三明不一不异道理。诸净不净。净则离断离常。常义异我故言不一。我体常故言不异。此明如如具三德也就此十六空。作四科料简。初有六空。辩空之自相。次有八空。辩空事用。三有两空。辩净不净。四明此十六空理。能除四种过失。一除戏论。二除怖畏。三除懈怠。四除疑惑。一除戏论者。有两。一世间众生。于内外法中。起无量戏论。谓有我无我等。皆依人道果等。是名戏论。若见道及道果皆悉空。则能除此等戏论。若是内空．外空．内外空．大空。此之四空。能除世间人法二我之戏论。若是空空。及第一义真实空。此之两空。能除出世间因果境智等戏论也。二除怖畏者。众生闻人皆空。则生怖畏。不肯修道故。如来为说此空有事用。何以故。若人能修八空事用。则能得道及以道果。乃至三身等一切功德也。三除懈怠者。若观定净不劳修道。若言定是不净。则永不可除灭。亦不假修道。唯处生死。永无解脱也。是故须辨是有净不净。何以故。有惑之时。则不净。除惑已后。即清净故。应须修道。四除疑惑者。惑者之心。既闻如如是有是无。则生犹豫。不能决断。谓如见杌谓人。呼人为杌故。佛为分判明人法二我决定是无。无人无法之道理。决定是有故空。有无两义存焉。如此道理能除疑之心也。第三明唯识真实。辨一切诸法唯有净识。无有能疑。亦无所疑。广释如唯识论。但唯识义有两。一者方便。谓先观唯有阿梨耶识。无余境界。现得境智两空。除妄识已尽。名为方便唯识也。二明正观唯识。遣荡生死虚妄识心。及以境界。一皆净尽。唯有阿摩罗清净心也

第四明依处真实。所谓苦依谛。第五邪行真实。谓集谛。第六清净真实。即是灭谛。第七正行真实。即是道谛。四谛各有三种。已如别解也。解节经明。佛说有七种真如。一生。二相。三识。四依止。五邪行。六清净。七正行。第一生真如者。谓有为诸法并皆无如。二相真如者。谓人法二无我。三识真如者。谓一切有为唯有识。四依止真如者。谓如所说苦谛。五邪行真如者。谓如所说集谛六清净真如者。谓如所说灭谛。七正行真如者。谓如所说道谛。此之七种真如。即第一义谛。第一义谛即真实性摄。是故名为七种真如。即是前明七种真实。具如三无性论中广释也

问云何知此之七种皆是第一义谛。即真实性摄耶

答。由两义故。知此七种皆是最胜最极。谓即是二智境界。所言最胜者。即是如如第一义谛。此第一义谛。即为如理智所照故名最胜。最极者。即是一切智境界。即是俗谛。此俗谛为如量智所照。如理智者。即无分别智。如量智。即是无分别后智。又如如理是一切种智。如量智即是一切智。唯是一智通真即有通俗。即空即真义。而取名如理智。亦名一切种智。若俗义有义。取名如量智。亦名如一切智故。言最胜最极。而是二智境界。即如理如量两智所知也。复有别义。知此七种真如。是真实性摄。何以故。明一切真实法。皆离一异等妄想谓非一非异。离四谤故。明此七种真如不可得。说异于诸相。亦不可说。不异于诸相故。言异于诸相。不可得说。不异于诸相。亦不可说。亦异不异。非异非不异。皆不可说。明此七种真如。于诸相中不可说。其有亦不可说。其是无。亦有亦无。非有非无。皆不可说。离四谤故。复有别得信有。何以故。即是清净境界故。故知是有。若有人能心缘此法。心即清净。是故应知。此七种真如。皆是常住。于一切时。性不异故。以是清净境界。是故应知。是真实善性由此理常是善。是故应知。是乐谛。何以故。常故所以而乐。善故所以是净。如此七种真如。即是一切法之体性。以是体性故。故说为我。即是常乐净我四德也。又释。所以名此七种为真如。第一义谛真实性者。为其同是一味故也

一生真如者。谓因果体一。而名字有异。何故言一。同是依他故有。因既依他。果亦依他。此之因果体即五阴。五阴无记。说名为果。五阴善恶有记之义。说名为因。取其能生为因所生为果。亦是对前为果。对后为因。故知只是一念五阴。而有因有果之名。体实未尝有异。故言一体为名字有异也。此因此果。既并依他。则无有自性。无自性故体不真实。故名一味。即是同无真实故名生真如。二言一味者。此生真如既是依他性。则无真实生故名生真如。即是无生性空。以无生故。即是一味。三此依他性。则必有分别性。分别性既是无相性。无相性即是无相真如。即相真如即是一味。是故以此三义。名生真如也。二相真如者。以显法通相故。是人法二无我。即二空之理。名一切法通相。即名相真如也。三识真如者。但唯有识。无有境界。境界不成故。识亦不成。此则能缘所缘。同是不可得性故名识真如也。四依止真如者。所谓苦五阴为体。此五阴者。为众生依处。托此为我人众生寿者等故名依止。苦谛有四相。谓苦无常空无我。此之四义同是无倒。皆名真实。即是依止真如。二者此下四相皆是空。无所有故。皆名真实。亦依止真如也。五邪行真如者。所谓集谛。集有两义故称真如。一无倒真如。谓能生之义。此义真实。即是集真如。二能生所生。皆无所有。以无所有故。故名邪行真如。六清净真如者。所谓灭谛。亦有两义。一无倒真如。谓四德皆是无倒故称真如。二灭谛。与生死无有差别。同一如如。皆无所有。故名清净真如。七正行真如者。所谓道谛。道即般若。般若与无明。体性相乖。道即无倒。真如如道。及烦恼体同故。于二空皆是无所有故。是一味如如故。名正行真如也。亦名真如。亦名如如。亦名真实。皆尽得也。十胜智真实者。有十种胜智。为除十种我见。一一者执。二因者执。三受者执。四作者执。五自在者执。六增上者执。七常者执。八不净净者执。九修行者执。十系缚解脱者执。一一者执。谓合集诸法。共立一名。则堕断见。何以故。如七入论偈所说。譬如岸崩。不更还本。乃至冢间体不再来。唯根境界。是名众生。若圣教说。有如空鸟迹会可见。此谓世入外道显一者执。其谓即身是人。身灭我亡。相堕断见。为破此执故立五阴。胜智虽有三义。谓多合集别异。三世色心并名为阴。故名为多合集。三世色心同名为阴故。谓合集色聚异受。受聚异于想等故名别异。是名五阴。若解了五阴有此三义。则无一者之执。言三世者。过去已谢。未来未有。现在不住。而以一切内外诸色同名阴也。以三义对治三种无明。谓一假说及以相杂。一无明者。如世入外道等。谓身是一物。一物是我。人不知但有三世五阴故堕断见。此是即阴计我。阴灭我亡故。佛为说三世五阴是多非一。即破其一者之执也。二假说无明者。如优娄佉等外道。谓身异分。即执有人异法。此是离阴执我故堕常见。何以故。人法既异。则谓阴灭我存。由其不解。合集诸阴。假说为人。但名无体。迷此假说故。名假说无明。故佛为说合集假说为法。体即是空。即破其此执故言能除假说无明也。三相杂无明者。如一切有部所执。谓八圣道中。正思正见。同是般若所摄。以其不能分别两异故生此执。故经部大乘师说。正思故者。欲求前理未决断犹属作意。作意即是意业故非是般若所收。唯有正见。是名般若。通而论一切知见。能通达选择。皆属般若。五阴亦尔。若不能分别受异想。想异行等。谓想受只一物。则失其体性故名相杂无明。相杂无明故失正见。失正见则不能得解脱。故佛为说五阴体不同。分别受想等异。为立通别二相。别相生证见。通相生比见也。问五阴云何为根本真实所摄。答色有三种。一分别色。亦有长短大小方圆等义。皆属分别假。以无别体故也。二种类色。谓各有种类。如从因生果。以火生为因生火家种类。种类既其相似。即是实法相生属依他假。以其种类依因得成。非是自性之力也。三如如色。若是分别假名一向无体。即是法空。若是依他假。虽复有体。体非真实。依他而有。即有法空。此两空之体。既是真实故名如如色。以如是色之自性故。以色目于如如。此是如如家色故。言如如色也。以末从本为名。亦可得言以本来目于末。此之真实名真实假。假体即空故名真实。假空即如如。真实之相。亦不可得也。色阴既即三假。为三假所摄者。受等四阴理自皆然。并为三假所摄者。受苦受乐是分别假。分别体从因缘生。有因有果。即依他假。如如名真实假。若能分别通相别相。此心是想。若受领苦乐。无有别执。则名为受也

二因者执。为断此执。成十八界胜智。诸外道辈。通执一切法因我得生。名因者执。我有九法。谓知．乐．苦．欲．嗔．功力．念．法．非法。我既本有。从我生法非法。法非法令心共我和合。和合故能有所知。知故有乐。乐故有苦。由乐故生欲。由苦生嗔。欲得于乐所以厌苦。而修功力。功力故有正念。欲得解脱故。须除法非法。法非法不生。则无有知。以无知故。无苦乐等。若求解脱。当修四法。一真实语。即持戒。二施。三苦行。四者定。若能修此四种正法。则得生善道。善道得乐。乐有智慧。智慧则厌法非法。厌法非法。则得解脱。大乘破言。若说先有我而未有法非法。后时无有因缘而生者。解脱亦尔。得解脱已。亦应无有因缘。更生法及非法。如此则无解脱时也。界者种子义。自分种类是名种子。种子亦是一义。以种类同一故也。但分张果。遂成十八界。而种子有三。一者能执。二者所执。三者执。眼等六根能执种子名自种。种类即是能生。但随因缘胜负有异生果。优劣不同故。由过去贪。六尘生业熏阿梨耶识。令种子既同。是一贪故言种子。是一能得六根异果。故说因有六种也。而言根能执者。根现既非心法。实不能执。但为外道言根中别有人。是能执者故方便说根为能执。色等六尘是所执。种子由自种生故说由过去贪。内根欲用外尘故。以贪根与贪生于此尘。又由贪六尘故有六根。复以贪尘之贪生于六根也。六识是执种子。从贪内根外尘生。此十八从因名界。界是种子。假说此界。有三种义。一能作。二所作。三作为。破俱絺罗在外道时。谓我是能作。而来问佛佛方便假说眼等是能作。其执眼等为我作。又破一阴示云。离根之外。无有别我。但是眼等。从因缘生。谓为能作。实非能作。假说六尘。名为所作。为破僧佉外道所立两种常我。一谓有知我。是常我。既是常故。非是能作。二执无知我。即一切法。是有知我用自性成就智非所作是佛假说六尘。名为所作。非性有既非实有能作。故知尘亦非所作。是故假说作是六识。一破外道谓一切事皆由我意。此是增益谤。二邪见外道谓我常。以我常故诸法亦常。既两种并常故。无有能作及与所作。即损减谤。为离此二边故。假说六尘为作。根尘不作意故无有作。若离根尘亦无有识。何以故。以识必依根尘方得生故。则无有不作。正为破外道能作所作等三种无明故立此三义。为显种子有能执所执等故立十八界。若解十八界从四缘生。则不执我为能生等也。根名能作者。能作有二种。一能生识识。二能为尘作缘。尘为所作者。为眼作缘。为识所依。识是作者。作是生起有事义界义。从根本真实。眼有三。一分别眼。二种类眼。三如眼。乃至行非行胜智。例如五阴中释。四为破作者执故。说十二缘生因果事。三义无增减。言增减者。谓于行识等十一支。立因不平等。何以故。以无常法立常为因故名不平等。如僧佉等外道。立无知我为因。亦如优娄佉。立于常我为因。及执自在天为常等。而能作业。亦是立常为因。能作无常果。因果即不相类故言立因不平等理。而为论无常之果。自以有无明为因。而彼谓有常因。即是增益于因。义也损减因者。如尼揵子等外道。谓诸法自然而有。无有因缘实有谓无故。言损减因也。增果者。如僧佉等所立之义。谓因中已有果。果虽本有由因显果。此既是本有则不从因生。而理实由因缘聚集方有此果。而其执言本有故名增果。损果者。如断见等外道立义。谓一切业皆感果无未来生。实有感实有生。而邪执立无。故名损果。增事者。如自在天所执。谓一切事皆从我意心而有。如无明体别有作意能生于行。而无明体实无别有作意而生行也。又如优娄佉所执。于法体别有动转等事业。事业有五种。谓上下屈伸等执以动转为体。离体之外实无别事业。而邪执为有故名增事。损事者外道所执。谓无明无力能生行。无明若在若不在。自然有行故。知无明无力生行。若解十二有分展转相生能离因果事等增减六种邪执。略明十二有分因果之义自有三种。一明无常。二明无动转之意。三辨因果体相。若心是常则无因果。以心是无常故因果义立。若言别有动转意者。则因应作意生果。果应作意方从因生。便是自在。非谓依他。则生依他义。因依果果藉因成。互相须待。并皆依他。所以是假无有实性。若不相似则失因果之义。如豆不生麦。以非因故不互相生。若令果不似因。因不类果者。作恶便应生天。为善则堕地狱。乃至有流应感解脱。无流更增生死。是故无常生无常。此任自然之理。不劳执有作意。因果相似名十二有分。此义为破三种烦恼。谓贪爱皮我见肉无明心。此十二缘体中。若是果报分者。实若厌离以破贪爱显无愿解脱门。若是因分者。以破我见显果由因生。非我常作明空解脱门。以无明还显无明。若能解了诸业行从无明生者。无明显闇之心。即灭无明即是四谤执相之故。破此无明以显无相解脱门也。若体十二有分无增无减。则除我见离作者执故。以十二有分。正破此执也。三本所摄者。无明有三义。一者分别所显。即分别假。二有因果道理。即依他假。此两皆无所有。即真实假。无明一支既尔所余行等十一。其例皆然。不复具释。五破自在者执故。说处非处胜智。外道计自在天。如意能作善得恶道果报。生恶能招善道。作有流得解脱。作无流感生死。何以故。以得自在故。为破此执。说处非处。皆是依他。并无自在。无自在有三义。一依业处非处。二依烦恼处非处。三依果报处非处。如寿量义中。广明七种是处非处义。依业处非处者。依恶业名恶道。名为是处。无自在力入也。若依恶业不入恶道。名为非处。无有是处。善业亦然。依烦恼者。若人未舍五盖。未修习七觉。终不能得尽于苦际。依烦恼不得至解脱。故知无自在业也。凡夫依烦恼能作杀等业无烦恼为依处故并无自在力也。依果报者。土无二王。世无两佛。若令二王两佛同时俱兴。无有是处。如女人为转轮王。亦无是处。小乘声闻及辟支佛。得作佛者。亦无是处。转轮王及佛。同有不共之业。此业最胜一切依因缘果报等力。虽复作意欲同一处终不得从心也。女人有两业。一心善故感得人身。二由恶业所以为女。恒隶属于人。不得自在。皆是依他果报也。二乘之人小欲知足。依因此业故得今果。已得此果。欲求菩萨。无自在力。终不能得。如此义有两。一依业。二依果。若得此七种处非处胜智。则离我见。后得自在。如意能为也。属三性根本义。已如前释。例难可得。不复重记

十八空论一卷


王法正理论

    No. 1615

王法正理论

        弥勒菩萨造

        三藏法师玄奘奉　诏译

如佛世尊为出爱王所说经言。彼王一时往诣佛所顶礼佛足。白言。世尊。有一沙门若婆罗门来至我所。以不真实过失现前呵谏于我。我于尔时。其心不生悔恼忧戚。何以故。观此过失。于我自身都不见故。又有沙门若婆罗门来至我所。以不真实功德现前赞劝于我。我于尔时。心亦不生欢喜踊跃。何以故。观此功德。于我自身都不见故。彼诸沙门及婆罗门既退还已。我便独处空闲静室。生如是心筹量寻伺。我当云何了知诸王真实过失真实功德。若我知者当舍其失爰修其德。谁有沙门或婆罗门。能了诸王真实过失真实功德。亦能为我广开示者。既寻伺已。便作是念唯我世尊一切知者。一切见者。定当了知诸王所有真实过失真实功德。我今当往佛世尊所请问斯义。故我今者来至佛所。请决是义。唯愿如来。为我开示。世尊。云何诸王真实过失。云何诸王真实功德。作是请已

尔时世尊告出爱王曰。大王。大王。今者应当了知王之过失。王之功德。王衰损门。王方便门。王可爱法及能引发王可爱法

云何名为王之过失。大王当知。王过失者。略有九种。王若成就如是过失。虽有大府库有大辅佐有大军众不可归仰。何等为九。一不得自在。二立性暴恶。三猛利愤发。四恩惠奢薄。五受邪佞言。六所作不思不顺仪则。七不顾善法。八不知差别忘所作恩。九一向纵任专行放逸

云何名王不得自在。谓有国王。志性不强所为软弱。为诸大臣辅相国师群官所制。不随所欲作所应作锡赉群臣。于妙五欲欢娱游戏。亦不如意。如是名王不得自在

云何名王立性暴恶。谓有国王。诸群臣类或余人等。随于一处现行少小不如意事。即便对面摈黜。发粗恶言咆勃忿恚。颦蹙而住时生愤发。设不对面背彼向余。而作于前摈骂等事。设不对面亦不背彼向余而作于前黜骂等事。然唯内意愤恚郁快。怀恼害心怀怨恨心。然不长时持愤恚心相续不舍。复有内意愤恚郁快。怀恼害心怀怨恨心。亦于长时持愤恚心相续不舍。由如是相对面暴恶。背面暴恶。懊恚暴恶暂时暴恶。长久暴恶。如是名王立性暴恶。大王当知。长久暴恶名为大过。非是余者

云何名王猛利愤发谓有国王诸群臣等。有小[億-音+(夫*夫)]过有少违越便削封禄夺去妻妾。或以重罚而刑罚之。如是名王猛利愤发

云何名王恩惠奢薄。谓有国王诸群臣等供奉侍卫。虽极清净善称其心。而以微劣软言而慰喻之。颁赐爵禄酬赏勋庸。不能圆满不顺常式。或损耗已。或稽留已。或推注已。或怨恨已。然后方与如是名王恩惠奢薄

云何名王受邪佞言。若有国王诸群臣等。实非聪睿诈现聪睿。贪浊偏党不闲宪式。情怀谋叛不修善政。听受信用如是辈人所进谏议。由此因缘王务财宝。名称善政并皆衰损。如是名王受邪佞言

云何名王所作不思不顺仪则。谓有国王。不能究察不审究察。不能思择不审思择。诸群臣辈于彼彼务机密事中。不堪委任而委任之。堪委任者而不委任。堪驱役者而不驱役。不堪役者乃驱役之。应赏赉者而刑罚之。应刑罚者而赏赉之。又于群臣不善安处先王仪则。由此群臣处大朝会。余论未终发言间绝。不敬不惮而兴谏诤。不如旨教而善奉行。不正安住王之教命。如是名王所作不思不顺仪则

云何名王不顾善法。谓有国王。不信他世亦不晓悟。由于他世不信不悟。便于当来善不善业爱非爱果不能信解。不信解故无有羞耻。随情造作身语意业三种恶行。不能时时布施修福受斋学戒。如是名王不顾善法。云何名王不知差别忘所作恩。谓有国王。于诸大臣辅相国师及群官等。其心颠倒不善了知忠信技艺智慧差别。以不知故。非忠信所生忠信想。于忠信所非忠信想。无技艺所生技艺想。有技艺所无技艺想。于恶慧所生善慧想。于善慧所生恶慧想。彼由如是心颠倒故。于非忠信无有技艺恶慧臣所敬重爱养。忠信技艺善慧臣所反生轻贱。又诸臣等年耆衰迈。曾于长夜供奉侍卫。知其无势无力无勇。遂不敬爱不赐爵禄不酬其赏。设被陵蔑舍而不问。如是名王不知差别忘所作恩

云何名王一向纵任专行放逸。谓有国王。于妙五欲一向沉没。耽着嬉戏爱乐受行。不能时时勖励方便作所应作劳赉群臣。如是名王一向纵任专行放逸。若有国王成就如是九种过失。虽有大府库有大辅佐有大军众而不可归仰。大王当知。此九过失。是王自性之过失也

云何名为王之功德。大王当知。王功德者。略有九种。王若成就如是功德。虽无大府库无大辅佐无大军众而可归仰。何等为九。一得大自在。二性不暴恶。三愤发轻微。四恩惠猛利。五受正直言。六所作谛思善顺仪则。七顾恋善法。八善知差别知所作恩。九不自纵任不行放逸

云何名王得大自在。谓有国王。自随所欲作所应作劳赉群臣。于妙五欲欢娱游戏。于诸大臣辅相国师群臣等。所凡出教命宣布无碍。如是名王得大自在

云何名王性不暴恶。谓有国王。诸群臣等随于何处。虽行增上不如意事。性能容忍不现摈黜。不发。言亦不咆勃。广说乃至不生愤发亦不对面。亦不背面而作前事。亦不内意秘匿忿缠。亦不长夜蓄恶愤心相续不舍。不现暴恶不背暴恶。不匿暴恶不久暴恶。如是名王性不暴恶

云何名王愤发轻微。谓有国王。诸群臣等虽有大愆有大违越。而不一切削其封禄夺其妻妾。不以重罚而刑罚之。随过轻重而行黜罚。如是名王愤发轻微

云何名王恩惠猛利。谓有国王诸群臣等。正直现前供奉侍卫。其心清净其心调顺。于时时中以正圆满软言慰喻。具足颁锡爵禄勋庸而不令彼损耗稽留劬劳怨恨。易可供奉不难承事。如是名王恩惠猛利

云何名王受正直言。谓有国王。诸群臣等实有聪睿无聪睿慢。无浊无偏善闲宪式。情无违叛乐修善法。听受信用如是辈人所进言议。由此因缘国务财宝。名称善法皆悉增盛。如是名王受正直言

云何名王所作谛思善顺仪则。谓有国王性能究察能审究察。性能思择能审思择。诸群臣等于彼彼务机密事中。不堪委任而不委任。堪委任者而委任之。不堪役者而不驱役。堪驱役者乃驱役之。应赏赉者而正赏赉。应刑罚者而正刑罚。凡有所为审思审择。然后方作而不卒暴。又于群臣能善安处先王仪则。由此群臣虽处宴会终不发言间绝余论。要待言终恭敬畏惮而兴谏诤。如其旨教而善奉行。能正安住王之教命。如是名王所作谛思善顺仪则

云何名王顾恋善法。谓有国王信知他世。由信善故。便于当来净不净业爱非爱果能善信解。由信解故具足惭耻而不纵情作身语意三种恶行。时时思择布施修福受斋学戒。如是名王顾恋善法

云何名王善知差别知所作恩。谓有国王于诸大臣辅相国师及群臣等。心无颠倒能善了知忠信技艺智慧差别。若诸群臣忠信技艺及与智慧。若有若无并如实知。于其无者轻而远之。于其有者敬而爱之而正摄受。又诸臣等年耆衰迈。曾于长夜供奉侍卫。虽知无势无力无勇。然念昔恩转怀敬爱而不轻贱。爵禄勋庸分赏无替。如是名王善知差别知所作恩。云何名王不自纵任不行放逸。谓有国王。于妙五欲而不沉没。耽着嬉戏爱乐受行。能于时时勖励方便作所应作劳赉群臣。如是名王不自纵任不行放逸。若王成就如是功德。虽无大府库无大辅佐无大军众而可归仰。大王当知。如是九种王之功德。是王自性之功德也

云何名为王衰损门。大王当知。王衰损门略有五种。一不善观察而摄群臣。二虽善观察而摄群臣。无恩妙行纵有非时。三专行放逸不思机务。四专行放逸不守府库。五专行放逸不修法行。如是五种。皆悉名为王衰损门。云何名王不善观察而摄群臣。谓有国王。于群臣等不能究察不审究察。不能思择不审思择。忠信技艺智慧差别。摄为亲侍加以宠爱。厚赐爵禄重赏勋庸。最机密处而相委任。数以软言现为慰喻然此群臣所付财宝多有损费。若遇怨敌恶友军阵。彼先退败。恐惧破散为他所胜。迟留人后奔北无恋。矫行恶策动亏王政。如是名王不善观察而摄群臣。云何名王虽善观察而摄群臣。无恩妙行纵有非时谓有国王。虽于群臣性能究察能审究察。性能思择能审思择。忠信技艺智慧差别。摄为亲侍而不宠爱。不如其量具赐爵禄。最机密处亦不委任。不数软言现相慰喻。彼于一时王遇怨敌恶友军阵。广说乃至大怖畏事命难现前。尔时于臣方行宠爱。广说乃至数以软言而相慰喻。时群臣等共相谓曰。王于今者危迫因缘。方于我等暂行妙行非长久心。知此事已。虽有忠信技艺智慧隐而不现。如是名王虽善观察而摄群臣无恩妙行纵有非时

云何名王专行放逸不思机务。谓有国王。于应和好所作所成机务等事。而不时时独处空闲。或与智者共正思惟。称量观察和好方便。如是于应乖绝所作所成机务等事。于应惠施所作所成机务等事。于应军阵所作所成机务等事。于应摄受大力朋党所作所成机务等事。皆不时时独处空闲。或与智者共正思惟。称量观察乖绝方便。乃至摄受强党方便。如是名王专行放逸不思机务

云何名王专行放逸不守府库。谓有国王。寡营事业。拙营事业。不持事业不观事业。不禁王门。不禁宫门。不禁府库。或于俳优技乐笑弄倡逸等所。或复耽乐博弈戏等。非量损费所有财宝。如是名王专行放逸不守府库。云何名王专行放逸不修法行。谓有国王。于世所知柔和淳质。聪慧辩才得理解脱。巧便无害乐无害法。所有沙门若婆罗门不能数往礼敬咨询。云何为善。云何不善。云何有罪。云何无罪。作何等业能致吉祥远离诸恶。设得闻已亦不勖励如说修行。不能时时惠施树福受斋学戒。如是名王专行放逸不修法行。若有国王。成就如是五衰损门。当知此王退失现法后法义利。谓前四门退现法利。最后一门退后法利

云何名为王方便门。大王当知。王方便门略有五种。何等为五。一善观察摄受群臣。二能以时行恩妙行。三无放逸专思机务。四无放逸善守府库。五无放逸专修法行

云何名王能善观察摄受群臣。谓有国王。于群臣等性能究察能审究察性。能思择能审思择。忠信技艺智慧差别摄为亲侍。如是名王能善观察摄受群臣

云何名王能善以时行恩妙行。谓有国王。于诸群臣善观察已。摄为亲侍加以宠爱。随其度量厚赐爵录重赏勋庸。最机密处而相委任。数以软言现相慰喻。彼于一时王遇怨敌恶友军阵大怖畏事命难现前。即便罄竭显示忠信技艺智慧。如是名王能善以时行恩妙行

云何名王无有放逸专思机务。谓有国王。于应和好所作所成机务等事。能于时时独处空闲。或与智者共正思惟。称量观察和好方便。如是于应乖绝所作所成机务等事。于应惠施所作所成机务等事。于应军阵所作所成机务等事。于应摄受大力朋党所作所成机务等事。皆能时时独处空闲。或与智者共正思惟。称量观察乖绝方便。乃至摄受强党方便。如是名王无有放逸专思机务

云何名王无有放逸善守府库。谓有国王。广营事业。巧营事业。善持事业。善观事业。善禁王门。善禁宫门。善禁府库。又于俳优技乐笑弄倡逸等所。不以非量而费财宝。亦不耽乐博弈戏等。如是名王无有放逸善守府库。云何名王无有放逸专修法行。谓有国王于世所知柔和淳质。聪慧辩才得理解脱。巧便无害乐无害法。所有沙门若婆罗门而能数往礼敬咨问。云何为善。云何不善。何等有罪。何等无罪。作何等业能致吉祥远离诸恶。既得闻已善能勖励如说修行。亦能时时惠施树福受斋学戒。如是名王无有放逸专修法行。若有国王。成就如是五方便门。当知此王不退现法后法义利。略前四门不退现法所有义利。最后一门不退后法所有义利。云何名为王可爱法。大王当知。略有五种诸王可爱可乐可欣可意之法。何等为五。一世所敬爱。二自在增上。三能摧怨敌。四善摄养身。五能往善趣。如是五种是王可爱可乐可欣可意之法

云何能引王可爱法。大王当知。略有五种能引诸王可爱之法。何等为五。一恩养世间。二英勇具足。三善权方便。四正受境界。五勤修法行

云何名王恩养世间。谓有国王。性本知足。于财宝门为性谨慎不邪贪着。如其所应积集财宝不广营求。又有国王。性无贪吝。成就无贪白净之法。以自所有库藏珍财。随力随能给施一切贫穷孤露。又有国王。柔和忍辱。多以软言晓喻国界。于时时间随其所应颁赏爵禄。终不以彼非所能业恶业重业役任群臣。诸有违犯可矜恕罪。即便矜恕。诸有违犯不可恕罪。以实以时如理治罚。如是名王以正化法恩养世间。由王受行如是恩养世间法故。遂感世间之所敬爱

云何名王英勇具足。谓有国王。计策无惰武略圆满。未降伏者而降伏之。已降伏者而摄护之。广营事业如前。乃至。不甚耽乐博弈戏等。又善观察应与不应勤于僚庶。应刑罚者正刑罚之。应摄养者正摄养之。如是名王英勇具足。由王受行如是英勇具足法故。遂能感得自在增上

云何名王善权方便。谓有国王。于应和好所作所成机务等事。如前乃至于应摄受大力朋党所作所成机务等事。能正了知和好方便。乃至摄受强党方便。如是名王善权方便。由王受行如是善权方便法故。遂能摧伏所有怨敌

云何名王正受境界。谓有国王善能筹量府库增减。不奢不吝平等自处清正受用。众杂受用胜妙受用。随其时候所宜受用。与诸臣佐亲属受用。在于胜处而为受用。奏诸伎乐而为受用。无有[億-音+(夫*夫)]失而为受用。无[億-音+(夫*夫)]失者。谓疾恼时应食所宜。避所不宜于康豫时。消已方食若食未消。或食而利。皆不应食。应共食者。正现在前不应独食。精妙上味诡摈余人。如是名王正受境界。由王受行如是正受境界法故。遂能善巧摄养自身

云何名王勤修法行。谓有国王。具足净信戒闻舍慧

云何名王具足净信。谓有国王。信解他世信解当来净不净业及爱非爱果与异熟。如是名王具足净信

云何名王具足净戒。谓有国王。远离杀生及不与取淫欲邪行妄语饮酒诸放逸处。如是名王具足净戒

云何名王具足净闻。谓有国王。于现法义于后法义及于现法后法等义众妙法门。善听善受习诵通利。专意研究善见善达。如是名王具足净闻。云何名王具足净舍。谓有国王。虽在悭垢所缠众中心恒清净。远离悭垢而处居家。常行弃舍舒手乐施。好兴祠福惠舍圆满。于布施时常乐平等。如是名王具足净舍

云何名王具足净慧。谓有国王。如实了知善不善法。有罪无罪。修与不修。胜劣黑白。于广分别诸缘生法。亦如实知。纵令失念生恶贪欲嗔恚忿恨覆恼悭嫉幻诳谄曲无惭无愧恶欲恶见。而心觉悟并不坚住。如是名王具足净慧。如是名王勤修法行。由王受行此法行故能往善趣。如是五种能引发王可爱之法。能引诸王现法后法所有利益。谓初四种能引发王现法利益。最后一种能引发王后法利益

复次大王当知。我已略说王之过失。王之功德。王衰损门。王方便门。王可爱法及能引发王可爱法。是故大王。应当修学。王之过失宜当远离。王之功德宜当修习。王衰损门宜当远离。王方便门宜当修学。王可爱法宜当希慕。能引发王可爱之法宜当受行。大王。若能如是修学。当获一切利益安乐

复次依行差别建立三士。谓下中上。无自利行无利他行名为下士。有自利行无利他行有利他行无自利行名为中士。有自利行有利他行名为上士

复有四种补特伽罗。或有行恶而非乐恶。或有乐恶而非行恶。或有行恶亦复乐恶。或非行恶亦非乐恶。若信诸恶能感当来非爱果报。由失念故。或放逸故。近恶友故。造作恶行是名行恶而非乐恶。若先世来串习恶故。喜乐诸恶恶欲所牵。彼由亲近善丈夫故。闻正法故。如理作意为依止故。见诸恶行能感当来非爱果报。自勉自励远离诸恶。是名乐恶而非行恶。若性乐恶而不远离。是名行恶亦复乐恶。若有为性不乐诸恶亦能远离。名非行恶亦非乐恶。此中行恶亦乐恶者是名下士。若有行恶而非乐恶。或有乐恶而非行恶是名中士。若非行恶亦非乐恶是名上士

复有三士一重受欲。二重事务。三重正法。初名下士。次名中士。后名上士

复有三种补特伽罗。一以非事为自事。二以自事为自事。三以他事为自事。若行恶行以自存活。名以非事为自事。若怖恶行修行善行。名以自事为自事。若诸菩萨以他事为自事等。初名下士。次名中士。后名上士

又诸国王有三圆满。谓果报圆满。士用圆满。功德圆满。若诸国王生富贵家。长寿少病有大宗叶。成就俱生。聪利之慧。是王名为果报圆满。若诸国王善权方便所摄持故。恒常成就圆满英勇。是王名为士用圆满。若诸国王任持正法。名为法王安住正法。名为大王。与内宫王子群臣英杰豪贵国人共修惠施。树福受斋坚持禁戒。是王名为功德圆满。果报圆满者。受用先世净业果报。士用圆满者。受用现法可爱之果。功德圆满者。亦于当来受用圆满净业果报。若有国王三种圆满皆不具足。名为下士。若有果报圆满或士用圆满或俱圆满。名为中士。若三圆满无不具足。名为上士。复有三臣。一有忠信无伎能智慧。二有忠信伎能无智慧。三具忠信伎能智慧。初名下士。次名中士。后名上士。若不忠信无有伎能亦无智慧。当知此臣下中之下

又有四语。一非爱似爱。二爱似非爱。三非爱似非爱。四爱似爱。诸有语言辞句善顺。然非所宜。是名初语。或有语言辞句勃逆。然是所宜。是第二语。或有语言辞句勃逆。亦非所宜。是第三语。或有语言辞句善顺。亦是所宜。是第四语。若有宣说非爱似非爱。非爱似爱语者。是下士。若有宣说爱似非爱语者。是中士。若有宣说爱似爱语者。是上士

复有三种。受诸欲者。或有受欲。非法猛浪积集财宝不能安乐。正养己身及与妻子广说乃至不于沙门婆罗门所修殖福田。或有受欲。以法或非法猛浪或非积集财宝能以安乐。正养己身妻子眷属及知友等。不于沙门婆罗门所修殖福田。或有受欲。一向以法及不猛浪积集财宝能以安乐。正养己身。广说乃至能于沙门婆罗门所修殖福田。此三种中。初名下士。次名中士。后名上士

复有三人。一者有人。贪染而食爱着饕餮。乃至耽湎不见过患。不知出离。二者有人。思择而食不染不着亦不饕餮。吞吸迷闷坚住耽湎。深见过患善知出离。而于此食未断未知。三者有人。思择而食不生贪染。广说乃至深见过患善知出离。又于此食已断已知。初名下士。次名中士。后名上士。复依施物说有三人。一者有人。所施之物但具妙香不具美妙味之与触。二者有人。所施之物具妙香味而无妙触。三者有人所施之物具足美妙香味与触。初名下士。次名中士。后名上士

又依施田说有三人。一者有人。于爱于恩而行惠施。二者有人。于贫苦田而行惠施。三者有人。于具功德最胜福田而行惠施。初名下士。次名中士。后名上士。复有差别。施于所爱名为下士。施于有恩名为中士。施于贫苦具德胜田名为上士

又依施心说有三人。一者有人。将欲惠施先心欢喜。正惠施时心不清净。惠施已后寻复追悔。二者有人。先心欢喜。施时心净。施已追悔。三者有人先心欢喜。施时心净。施已无悔。初名下士。次名中士。后名上士

复于受持戒福业事建立三人。一者有人。但离一分非一切时。常能远离。唯自远离。不劝他离亦不赞美。见同法者心不欢喜是名下士。二者有人。离一切分一切时离。唯自远离不劝他人亦不赞美。见同法者心不欢喜。是名中士。三者有人。一切俱现。是名上士

又于受持禁戒处所建立三人。一者有人。住恶说法毗奈耶中受持禁戒。二者有人。住善说法毗奈耶中受持禁戒而有缺漏。三者有人。即住于此受持禁戒而不缺漏。初名下士。次名中士。后名上士

又于受持戒心建立三人。一者有人。为活命故受持禁戒。二者有人。为生天故受持禁戒。三者有人。为涅槃故受持禁戒。初名下士。次名中士。后名上士

又于受持别解脱律仪说有三人。一者有人。唯能受持近住律仪。二者有人。亦能受持近事律仪。三者有人。亦能受持苾刍律仪。初名下士。次名中士。后名上士

又于受持苾刍律仪说有三人。一者有人。唯能成就受具足支。无受随法诸学处支。亦无随护他人心支。亦无随护如先所受诸学处支。二者有人。成前三支。无后一支。三者有人。具成四支。初名下士。次名中士。后名上士。又有三人。一者有人。唯成就别解脱律仪。二者有人。成别解脱静虑律仪。三者有人。成别解脱静虑无漏三种律仪。初名下士。次名中士。后名上士。又有三人。一者有人。唯能成就非律仪非不律仪摄所受戒律仪。二者有人。亦能成就声闻等相应所受戒律仪。三者有人。亦能成就菩提萨埵所受戒律仪。初名下士。次名中士。后名上士

复依修习思惟方便建立三人。一者有人。唯得励力运转思惟。二者有人。有间运转设得无间要作功用方能运转。三者有人。已得成就任运思惟。初名下士。次名中士。后名上士。又依已得修差别故建立三人。一者有人。已得内心奢摩他定未得增上慧法毗钵舍那。二者有人。已得增上慧法毗钵舍那未得内心奢摩他定。三者有人。俱得二种。初名下士。次名中士。后名上士

又有三人。一者有人。已得有寻有伺三摩地。二者有人。已得无寻唯伺三摩地。三者有人。已得无寻无伺三摩地。初名下士。次名中士。后名上士

又依住修差别建立三人。一者有人。住染污静虑。二者有人。住世间清净静虑。三者有人。住无漏静虑。初名下士。次名中士。后名上士

王法正理论一卷


唯识二十论

    No. 1590 [Nos. 1588, 1589; cf. No. 1591]

唯识二十论一卷

        世亲菩萨造

        大唐三藏法师玄奘奉　诏译

安立大乘三界唯识。以契经说三界唯心。心意识了名之差别。此中说心意兼心所。唯遮外境不遣相应。内识生时似外境现。如有眩翳见发蝇等。此中都无少分实义。即于此义有设难言。颂曰

  若识无实境　　则处时决定
  相续不决定　　作用不应成

论曰。此说何义。若离识实有色等外法。色等识生不缘色等。何因此识有处得生非一切处。何故此处有时识起非一切时。同一处时有多相续。何不决定随一识生。如眩翳人见发蝇等。非无眩翳有此识生。复有何因。诸眩翳者所见发等无发等用。梦中所得饮食刀杖毒药衣等无饮等用。寻香城等无城等用。余发等物其用非无。若实同无色等外境。唯有内识。似外境生。定处定时不定相续有作用物皆不应成。非皆不成。颂曰

  处时定如梦　　身不定如鬼
  同见脓河等　　如梦损有用

论曰。如梦意说如梦所见。谓如梦中虽无实境。而或有处见有村园男女等物非一切处。即于是处或时见有彼村园等非一切时。由此虽无离识实境。而处时定非不得成。说如鬼言。显如饿鬼。河中脓满故名脓河。如说酥瓶其中酥满。谓如饿鬼同业异熟。多身共集皆见脓河。非于此中定唯一见。等言显示或见粪等。及见有情执持刀杖遮捍守护不令得食。由此虽无离识实境。而多相续不定义成。又如梦中境虽无实而有损失精血等用。由此虽无离识实境。而有虚妄作用义成。如是且依别别譬喻。显处定等四义得成。复次颂曰

  一切如地狱　　同见狱卒等
  能为逼害事　　故四义皆成

论曰。应知此中一地狱喻。显处定等一切皆成。如地狱言。显在地狱受逼害苦诸有情类。谓地狱中虽无真实。有情数摄狱卒等事。而彼有情同业异熟增上力故。同处同时众多相续。皆共见有狱卒狗乌铁山物等来至其所为逼害事。由此虽无离识实境。而处定等四义皆成。何缘不许狱卒等类是实有情。不应理故。且此不应那落迦摄。不受如彼所受苦故。互相逼害应不可立彼那落迦。此狱卒等。形量力既等。应不极相怖。应自不能忍受铁地炎热猛焰恒烧然苦。云何于彼能逼害他。非那落迦不应生彼。如何天上现有傍生。地狱亦然。有傍生鬼为狱卒等。此救不然。颂曰

  如天上傍生　　地狱中不尔
  所执傍生鬼　　不受彼苦故

论曰。诸有傍生生天上者。必有能感彼器乐业生彼定受器所生乐。非狱卒等受地狱中器所生苦。故不应许傍生鬼趣生那落迦。若尔应许彼那落迦业增上力生异大种。起胜形显量力差别。于彼施设狱卒等名。为生彼怖。变现种种动手足等差别作用。如羝羊山乍离乍合。刚铁林刺或低或昂。非事全无然不应理。颂曰

  若许由业力　　有异大种生
  起如是转变　　于识何不许

论曰。何缘不许识由业力如是转变而执大种。复次颂曰

  业熏习余处　　执余处有果
  所熏识有果　　不许有何因

论曰。执那落迦由自业力生差别大种起形等转变。彼业熏习理应许在识相续中不在余处。有熏习识汝便不许有果转变。无熏习处翻执有果。此有何因。有教为因。谓若唯识似色等现无别色等。佛不应说有色等处。此教非因有别意故。颂曰

  依彼所化生　　世尊密意趣
  说有色等处　　如化生有情

论曰。如佛说有化生有情。彼但依心相续不断能往后世密意趣说。不说实有化生有情。说无有情我但有法因故。说色等处契经亦尔。依所化生宜受彼教。密意趣说非别害有。依何密意说色等十。颂曰

  识从自种生　　似境相而转
  为成内外处　　佛说彼为十

论曰。此说何义。似色现识从自种子缘合转变差别而生。佛依彼种及所现色。如次说为眼处色处。如是乃至似触现识从自种子缘合转变差别而生。佛依彼种及所现触。如次说为身处触处。依斯密意说色等十。此密意说有何胜利。颂曰

  依此教能入　　数取趣无我
  所执法无我　　复依余教入

论曰。依此所说十二处教受化者能入数取趣无我。谓若了知从六二法有六识转。都无见者乃至知者。应受有情无我教者。便能悟入有情无我。复依此余说唯识教。受化者能入所执法无我。谓若了知唯识现似色等法起。此中都无色等相法。应受诸法无我教者。便能悟入诸法无我。若知诸法一切种无。入法无我。是则唯识亦毕竟无何所安立。非知诸法一切种无乃得名为入法无我。然达愚夫遍计所执自性差别诸法无我。如是乃名入法无我。非诸佛境离言法性亦都无故名法无我。余识所执此唯识性其体亦无。名法无我。不尔余识所执境有。则唯识理应不得成。许诸余识有实境故。由此道理。说立唯识教。普令悟入一切法无我。非一切种拨有性故。复云何知佛依如是密意趣说有色等处。非别实有色等外法为色等识各别境耶。颂曰

  以彼境非一　　亦非多极微
  又非和合等　　极微不成故

论曰。此何所说。谓若实有外色等处。与色等识各别为境。如是外境或应是一。如胜论者执有分色。或应是多。如执实有众多极微各别为境。或应多极微和合及和集。如执实有众多极微皆共和合和集为境。且彼外境理应非一。有分色体异诸分色不可取故。理亦非多。极微各别不可取故。又理非和合或和集为境。一实极微理不成故。云何不成。颂曰

  极微与六合　　一应成六分
  若与六同处　　聚应如极微

论曰。若一极微六方各与一极微合。应成六分。一处无容有余处故。一极微处若有六微。应诸聚色如极微量。展转相望不过量故。则应聚色亦不可见。加湿弥罗国毗婆沙师言。非诸极微有相合义。无方分故离如前失。但诸聚色有相合理有方分故此亦不然。颂曰

  极微既无合　　聚有合者谁
  或相合不成　　不由无方分

论曰。今应诘彼所说理趣。既异极微无别聚色。极微无合聚合者谁。若转救言聚色展转亦无合义。则不应言极微无合无方分故。聚有方分亦不许合故。极微无合不由无方分。是故一实极微不成。又许极微合与不合。其过且尔。若许极微有分无分。俱为大失。所以者何。颂曰

  极微有方分　　理不应成一
  无应影障无　　聚不异无二

论曰。以一极微六方分异。多分为体。云何成一。若一极微无异方分。日轮才举光照触时云何余边得有影现。以无余分光所不及。又执极微无方分者。云何此彼展轮相障。以无余分他所不行。可说此彼展转相碍。既不相碍。应诸极微展转处同。则诸色聚同一极微量。过如前说。云何不许影障属聚不属极微。岂异极微许有聚色发影为障。不尔。若尔聚应无二。谓若聚色不异极微。影障应成不属聚色。安布差别立为极微。或立为聚俱非一实。何用思择极微聚为。犹未能遮外色等相。此复何相。谓眼等境亦是青等实色等性。应共审思。此眼等境青等实性。为一为多。设尔何失。二俱有过。多过如前。一亦非理。颂曰

  一应无次行　　俱时至未至
  及多有间事　　并难见细物

论曰。若无隔别所有青等。眼所行境执为一物。应无渐次行大地理。若下一足至一切故。又应俱时于此于彼无至未至。一物一时。理不应有得未得故。又一方处。应不得有多象马等有间隙事。若处有一亦即有余。云何此彼可辩差别。或二如何可于一处有至不至中间见空。又亦应无小水虫等难见细物。彼与粗物同一处所量应等故。若谓由相此彼差别即成别物不由余义。则定应许此差别物。展转分析成多极微。已辩极微非一实物。是则离识眼等色等。若根若境皆不得成。由此善成唯有识义。诸法由量刊定有无。一切量中现量为胜。若无外境宁有此觉。我今现证如是境耶。此证不成。颂曰

  现觉如梦等　　已起现觉时
  见及境已无　　宁许有现量

论曰。如梦等时虽无外境。而亦得有如是现觉。余时现觉应知亦尔。故彼引此为证不成。又若尔时有此现觉。我今现证如是色等。尔时于境能见已无。要在意识能分别故。时眼等识必已谢故。刹那论者有此觉时。色等现境亦皆已灭。如何此时许有现量。要曾现受意识能忆。是故决定有曾受境。见此境者许为现量。由斯外境实有义成。如是要由先受后忆。证有外境理亦不成。何以故。颂曰

  如说似境识　　从此生忆念

论曰。如前所说虽无外境。而眼识等似外境现。从此后位与念相应。分别意识似前境现。即说此为忆曾所受。故以后忆。证先所见实有外境。其理不成。若如梦中虽无实境。而识得起觉时亦然。如世自知梦境非有。觉时既尔何不自知。既不自知觉境非有。宁如梦识实境皆无。此亦非证。颂曰

  未觉不能知　　梦所见非有

论曰。如未觉位。不知梦境非外实有。觉时乃知。如是世间虚妄分别串习惛熟如在梦中。诸有所见皆非实有。未得真觉不能自知。若时得彼出世对治无分别智。乃名真觉。此后所得世间净智现在前位。如实了知彼境非实。其义平等。若诸有情。由自相续转变差别。似境识起。不由外境为所缘生。彼诸有情。近善恶友闻正邪法。二识决定。既无友教此云何成。非不得成。颂曰

  展转增上力　　二识成决定

论曰。以诸有情自他相续诸识展转为增上缘。随其所应二识决定。谓余相续识差别故。令余相续差别识生各成决定不由外境。若如梦中境虽无实而识得起。觉识亦然。何缘梦觉造善恶行。爱非爱果当受不同。颂曰

  心由睡眠坏　　梦觉果不同

论曰。在梦位。心由睡眠坏势力羸劣。觉心不尔。故所造行当受异熟。胜劣不同非由外境。若唯有识无身语等。羊等云何为他所杀。若羊等死不由他害。屠者云何得杀生罪。颂曰

  由他识转变　　有杀害事业
  如鬼等意力　　令他失念等

论曰。如由鬼等意念势力。令他有情失念得梦。或着魅等变异事成。具神通者意念势力。令他梦中见种种事。如大迦多衍那意愿势力。令娑刺拏王等梦见异事。又如阿练若仙人意愤势力。令吠摩质呾利王梦见异事。如是由他识转变故。令他违害命根事起。应知死者谓众同分。由识变异相续断灭。复次颂曰

  弹咤迦等空　　云何由仙忿
  意罚为大罪　　此复云何成

论曰。若不许由他识转变增上力故他有情死。云何世尊为成意罚是大罪故。返问长者邬波离言。汝颇曾闻何因缘故。弹咤迦林。末蹬伽林。羯陵伽林。皆空闲寂。长者白佛言。乔答摩。我闻由仙意愤恚故。若执神鬼敬重仙人。知嫌为杀彼有情类。不但由仙意愤恚者。云何引彼。成立意罚为大罪性过于身语。由此应知。但由仙忿彼有情死理善成立。若唯有识。诸他心智知他心不。设尔何失。若不能知何谓他心智。若能知者。唯识应不成。虽知他心然不如实。颂曰

  他心智云何　　知境不如实
  如知自心智　　不知如佛境

论曰。诸他心智云何于境不如实知。如自心智。此自心智云何于境不如实知。由无知故。二智于境各由无知所覆蔽故。不知如佛净智所行不可言境。此二于境不如实知。由似外境虚妄显现故。所取能取分别未断故。唯识理趣无边决择品类差别难度甚深。非佛谁能具广决择。颂曰

  我已随自能　　略成唯识义
  此中一切种　　难思佛所行

论曰。唯识理趣品类无边。我随自能已略成立。余一切种非所思议。超诸寻思所行境故。如是理趣唯佛所行。诸佛世尊于一切境及一切种智无碍故

唯识二十论一卷


唯识论(一名破色心论)

    No. 1588 [Nos. 1589, 1590; cf. No. 1591]

唯识论一卷(一名破色心论)

        天亲菩萨造

        后魏瞿昙般若流支译

  唯识无境界　　以无尘妄见
  如人目有翳　　见毛月等事
  若但心无尘　　离外境妄见
  处时定不定　　人及所作事
  处时等诸事　　无色等外法
  人梦及饿鬼　　依业虚妄见
  如梦中无女　　动身失不净
  狱中种种主　　为彼所逼恼
  畜生生天中　　地狱不如是
  以在于天上　　不受畜生苦
  若依众生业　　四大如是变
  何故不依业　　心如是转变
  业熏于异法　　果云何异处
  善恶熏于心　　何故离心说
  说色等诸入　　为可化众生
  依前人受法　　说言有化生
  依彼本心智　　识妄取外境
  是故如来说　　有内外诸入
  观虚妄无实　　如是入我空
  观于诸异法　　入诸法无我
  彼一非可见　　多亦不可见
  和合不可见　　是故无尘法
  六尘同时合　　尘则有六厢
  若六唯一处　　诸大是一尘
  若微尘不合　　彼合何所成
  言微尘无厢　　能成则有厢
  有法方所别　　彼不得言一
  影障若非大　　则彼二非彼
  若一行不次　　取舍亦不同
  差别无量处　　微细亦应见
  现见如梦中　　见所见不俱
  见时不分别　　云何言现见
  先说虚妄见　　则依彼虚忆
  见虚妄梦者　　未寤则不知
  迭共增上因　　彼此心缘合
  无明覆于心　　故梦寤果别
  死依于他心　　亦有依自心
  及种种因缘　　破失自心识
  经说檀拏迦　　迦陵摩灯国
  仙人嗔故空　　是故心业重
  诸法心为本　　诸法心为胜
  离心无诸法　　唯心身口名
  他心知于境　　不如实觉知
  以非离识境　　唯佛如实知
  作此唯识论　　非我思量义
  诸佛妙境界　　福德施群生

问曰。此初偈者明何等义。答曰。凡作论者皆有三义。何等为三。一者立义。二者引证。三者譬喻。立义者。如偈言。唯识无境界故。引证者。如偈言。以无尘妄见故。譬喻者。如偈言。如人目有翳见毛月等事故。又复有义。如大乘经中说三界唯心。唯是心者。但有内心无色香等外诸境界。此云何知。如十地经说。三界虚妄但是一心作故。心意与识及了别等。如是四法义一名异。此依相应心说。非依不相应心说。心有二种。何等为二。一者相应心。二者不相应心。相应心者。所谓一切烦恼结使受想行等诸心相应。以是故言。心意与识及了别等义一名异故。不相应心者。所谓第一义谛常住不变自性清净心故。言三界虚妄但是一心作。是故偈言。唯识无境界故。已明立义。次辩引证。问曰。以何事验得知色等外境界无。但有内心能虚妄见前境界也。答曰。偈言以无尘妄见故。无尘妄见者。明毕竟无色等境界。但有内心妄生分别。能见色等外诸境界。已明引证。次显譬喻

问曰。若无色等外境界者。为但有言说。为亦有譬况。答曰。偈言如人目有翳见毛月等事故。此明何义。譬如人目或有肤翳热气病等。是故妄见种种诸事。于虚空中睹见毛炎等见第二月。及以梦幻乾闼婆城。如是等法实无前事。但虚妄见而有受用色香味等。外诸境界皆亦如是。无始世来内心倒惑妄见有用。实无色等外诸境界。问曰。偈言

  若但心无尘　　离外境妄见
  处时定不定　　人及所作事

此偈明何义。若离色等外诸境界虚妄见者。以何义故。于有色处眼则见色。余无色处则不见色。又复有难。若无色等外诸境界虚妄见者。以何义故。即彼见处于有色时眼则见色。于无色时则不见色。又复有难。若无色等外诸境界虚妄见者。如是则应一切时见。若不如是应一切时悉皆不见。是故偈言。若但心无尘离外境妄见处时定不定故。又复有难。若无色等外诸境界虚妄见者。以何义故。多人共集同处同时。于有色处则同见色。于无色处则同不见。又复有难。若无色等外诸境界虚妄见者。以何义故。眼翳之人。妄见日月毛轮蝇等。净眼之人。则不妄见。又复有难。若等无有色香味等外诸境界虚妄见者。以何义故。眼翳之人。所见日月毛轮蝇等皆悉无用。净眼之人。有所见者皆悉有用。又复有难。若等无有色香味等外诸境界虚妄见者。以何义故。梦中所见饮食饥饱刀杖毒药。如是等事皆悉无用。寤时所见饮食饥饱刀杖毒药。如是等事皆悉有用。又复有难。若等无有色香味等外诸境界虚妄见者。以何义故。乾闼婆城实无有城而无城用。自余城者皆实有城而有城用。以是义故。色香味等外诸境界皆悉实有。不同翳梦乾闼婆城等。是故处时人所作业皆是实有。不同梦等。是故偈言。处时定不定人及所作事故。答曰。偈言

  处时等诸事　　无色等外法
  人梦及饿鬼　　依业虚妄见

此偈明何义。汝言。以何义故。于有色处眼则见色。余无色处不见色者。此义不然。何以故。以彼梦中于无色处则见有色于有色处不见色故。又汝言。以何义故。即彼见处于有色时眼则见色。若无色时不见色者。汝以何义故。于彼梦中一处见有聚落城邑及男女等。或即彼处聚落城邑及男女等皆悉不见。或时有见。或时不见。非是常见。又汝言。若无色等外诸境界虚妄见者。如是则应。一切时见。若不如是应一切时不见者。此义不然。何以故。有于处时无色香等外诸境界。亦有同处同时同见。亦有同处同时不见。是故偈言。人梦及饿鬼依业虚妄见故。此明何义。以汝向言若无色等外诸境界。云何有时处等见不见者。此义不成。是虚妄说。何以故。以应离色等外诸境界。时处等事皆悉成故。又汝言。以何义故。多人共集同处同时。于有色处则同见色。于无色处则同不见。又汝言。眼翳之人妄见日月毛轮蝇等。净眼之人不妄见者。此义不然。何以故。如饿鬼等离色香等外诸境界。处时人等一切皆成。此义云何。如饿鬼等。或百同业。或千同业。同见河中皆悉是脓。或皆见血。或见小便。或见大便。或见流铁。或见流水。而两岸边多有众人。执持刀杖守掌防护不令得饮。此则远离色声香等外诸境界而虚妄见。是故偈言。人梦及饿鬼依业虚妄见故。又汝言。以何义故。眼翳之人所见日月毛轮蝇等皆悉无用。净眼之人皆悉有用。梦中所见饮食饥饱刀杖毒药。如是等事皆悉无用。寤时所见饮食饥饱刀杖毒药。如是等皆悉有用。又汝言。以何义故。乾闼婆城实无有城而无城用。自余城者皆实有城而有城用者。此义不然。何以故。又偈言

  如梦中无女　　动身失不净
  狱中种种主　　为彼所逼恼

此偈明何义。如人梦中实无女人而见女人与身交会漏失不净。众生如是。无始世来。虚妄受用色香味等外诸境界。皆亦如是实无而成。以如是等种种譬喻。离色香等外诸境界。有处时人所作业等四种事成。又复更有一种譬喻。离色香等外诸境界四种事成。皆虚妄不实。是故偈言。狱中种种主为彼所逼恼故。此明何义。彼四种事离色香等外诸境界。一切皆成。云何皆成。如地狱中无地狱主。而地狱众生依自罪业见地狱主。彼地狱主与种种苦。而起心见。此是地狱。此是地狱处此是地狱时。此是夜时此是昼时。此中前时此中后时。彼是地狱主。我是作罪人。以恶业故见狗见乌。或见铁钩或见两羊。或见两山从两边来逼罪人身。或见剑树罪人上时剑刃向下罪人下时刃剑向上周匝而有。何以故。以业同故。同共聚集皆悉同见同受果报。若业不同。则不同集亦不同见不同受苦。以是义故。汝言处时定不定人及所作事。应有色等外诸境界。处时及人所作业等皆是实者。彼亦虚妄。以是义故。处时及身所作业等此四种事。唯以一种地狱譬喻皆成虚妄。应如是知。问曰。地狱中主乌狗羊等。为是众生为非众生。答曰。非是众生

问曰。以何义故非是众生。答曰以不相应故。此以何义。有五种义。彼地狱主及乌狗等非是众生。何等为五。一者如地狱中罪众生等受种种苦。地狱主等若是众生。亦应如是受种种苦。而彼一向不受如是种种苦恼。以是义故。彼非众生。二者地狱主等若是众生。应迭相杀害。不可分别此是罪人此是主等。而实不共递相杀害。可得分别此是罪人此是狱主。以是义故。彼非众生。三者地狱主等若是众生。形体力等应递相杀害。不应偏为受罪人畏。而实偏为罪人所畏。以是义故。彼非众生。四者彼地狱地常是热铁。地狱主等是众生者。不能忍苦。云何能害彼受罪人。而实能害彼受罪人。以是义故。彼非众生。五者地狱主等若是众生。非受罪人不应于彼地狱中生。而实生于彼地狱中。以是义故。彼非众生此以何义。彼地狱中受苦众生。造五逆等诸恶罪业于彼中生。地狱主等不造恶业云何生彼。以如是等五种义故。名不相应

问曰。若彼主等非是众生。不作罪业不生彼者。云何天中得有畜生。此以何义。如彼天中有种种鸟诸畜生等生在彼处。于地狱中何故不尔。畜生饿鬼种种杂生令彼为主。答曰偈言

  畜生生天中　　地狱不如是
  以在于天上　　不受畜生苦

此偈明何义。彼畜生等生天上者。彼于天上器世间中有少分业。是故于彼器世间中受乐果报。彼地狱主及乌狗等不受诸苦。以是义故。彼地狱中无有实主及乌狗等。除罪众生

问曰。若如是者。地狱众生依罪业故外四大等种种转变。形色力等胜者名主及乌狗等。云何名为四大转变。彼处四大种种转变。动手脚等及口言说。令受罪人生于惊怖。如有两羊从两边来共杀害彼地狱众生。见有诸山或来或去杀害众生。见铁树林见棘林等。罪人上时树刺向下。罪人下时树刺向上。以是义故。不得说言唯有内心无外境界。答曰。偈言

  若依众生业　　四大如是变
  何故不依业　　心如是转变

此偈明何义。汝向言依罪人业。外四大等如是转变。何故不言依彼众生罪业力故内自心识如是转变。而心虚妄分别说言外四大等如是转变。又偈言

  业熏于异法　　果云何异处
  善恶熏于心　　何故离心说

此偈明何义。以汝虚妄分别说言。依彼众生罪业力故。外四大等如是转变。生彼罪人种种怖等。以何义故。不如是说。依彼众生罪业力故。内自心识如是转变。是故偈言。业熏于异法果云何异处故。此以何义。彼地狱中。受苦众生所有罪业。依本心作还在心中。不离于心。以是义故。恶业熏心还应心中受苦果报。何以故。以善恶业熏于心识。而不熏彼外四大等。以四大中无所熏事。云何虚妄分别说言四大转变。于四大中受苦果报。是故偈言

  善恶熏于心　　何故离心说

问曰。如汝向说。何故不言依彼众生罪业力故内自心识如是转变。而心虚妄分别说言外四大等如是转变者。此以何义。以有阿含证验知故。言阿含者。谓佛如来所说言教。此以何义。若但心识虚妄分别见外境界。不从色等外境界生眼识等者。以何义故。如来经中说眼色等十二种入。以如来说十二入故明知应有色香味等外境界也。答曰。偈言

  说色等诸入　　为可化众生
  依前人受法　　说言有化生

此偈有何义。以汝向言。以有阿含证验知故。色香味等十二入外诸境界皆悉是有。若如是者。彼所引经义则不然。何以故。以复有余修多罗中如来依彼心业相续不断不绝。是故说有化生众生又复有余修多罗中说言。无我无众生无寿者。唯因缘和合有诸法生。是故偈言。依前人受法说言有化生故。如来如是。说色等入。为令前人得受法故。以彼前人未解因缘诸法体空。非谓实有色香味等外诸境界。是故偈言。说色等诸入为可化众生故

问曰。若实无有色等入者。以何义故。如来经中作如是说。答曰。偈言

  依彼本心智　　识妄取外境
  是故如来说　　有内外诸入

此偈明何义。唯是内心虚妄分别。见有色等外诸境界。此依无始心意识等种子转变。虚妄见彼色香味等外诸境界。是故如来依此虚妄二种法故。作如是说。何者为二。一者本识种子。二者虚妄外境界等。依此二法。如来说有眼色等入。如是次第乃至身触。以虚妄心依无始来心意识等种子转变。虚妄见彼色香味等外诸境界。是故如来依此虚妄二种法故。作如是说。何者为二。一者本识种子。二者虚妄外境界等。依此二法。如来说有身触等入。如是次第。是故偈言。依彼本心智识妄取外境。是故如来。说有内外诸入故

问曰。若依如是义。说有何功德利益。答曰。偈言

  观虚妄无实　　如是入我空
  观于诸异法　　入诸法无我

此偈明何义。为令声闻解知因彼六根六尘生六种识。眼识见色。乃至身识觉触。无有一法是实见者。乃至无有一法是实觉者。为令可化诸众生等作是观察入人无我空。是故偈言。观虚妄无实如是入我空故。观于诸异法入诸法无我者。此下半偈复明何义。观于诸异法者。菩萨观察唯有内识。云何观察。谓菩萨观无外六尘唯有内识。虚妄见有内外根尘。而实无有色等外尘一法可见。乃至实无一触可觉。如是观察。得入因缘诸法体空

问曰。若一切法毕竟无者。何故向言。唯有识等。若尔彼识等。亦应是无。何故说言唯有内识。答曰。我不说言一切诸法皆毕竟无。如是则入诸法无我

问曰。若尔云何入法无我。答曰。为遮虚妄法故。遮虚妄法者。以诸外道一切凡夫虚妄分别。实有色等一切法体。为欲遮彼虚妄分别故。说色等一切诸法毕竟空无。非无言处皆悉空无。无言处者。所谓诸佛如来行处。如是唯有真识更无余识。不能如是分别观察入于识空。如是依识说入一切诸法无我。非谓一向谤真识我。说言无有佛性实识

问曰。如汝向言。唯有内识无外境界。若尔内识为可取为不可取。若可取者。同色香等外诸境界。若不可取者。则是无法。云何说言。唯有内识无外境界。答曰。如来方便渐令众生得入我空及法空故说有内识。而实无有内识可取。若不如是。则不得说我空法空。以是义故虚妄分别。此心知彼心。彼心知此心

问曰。又复有难。云何得知。诸佛如来依此义故。说有色等一切诸入。而非实有色等诸入。又以识等能取境界。以是义故。不得说言无色等入。答曰。偈言

  彼一非可见　　多亦不可见
  和合不可见　　是故无尘法

此偈明何义。汝向说言。色等诸入皆是实有。何以故。以识能取外境界者。此义不然。何以故。有三义故无色等入。何等为三。一者为实有一微尘。如彼外道卫世师等虚妄分别。离于头目身分等外。实有神我。微尘亦尔。离色香等实有不耶。二者为实有多微尘差别。可见不耶。三者为多微尘和合。可见不耶。此明何义。若实有彼一微尘者。则不可见。如彼外道卫世师等虚妄分别。离于头目身分等外。有一神我不可得见。微尘亦尔。离色香等不可得见。是故无一实尘可见。是故偈言。彼一非可见故。若实有多微尘差别者。应一一微尘历然可见。而不可见。以是义故多尘差别亦不可见。是故偈言。多亦不可见故。若多微尘和合可见者。此亦不然。何以故。以一微尘实无有物故。云何和合。是故不成。是故偈言。和合不可见是故无尘法故。问曰。云何不成。答曰。偈言

  六尘同时合　　尘则有六厢
  若六唯一处　　诸大是一尘

此偈明何义。若诸微尘从六方来六尘和合。若如是者尘有六方。若有六方则有六厢。又若微尘有六处所者不容余尘。是故偈言。六尘同时合尘则有六厢故。若六微尘唯一处者。一微尘处有六微尘。若如是者。六尘一处。若一处者则六微尘不可得见。何以故。彼此微尘无差别故。若如是者。一切粗物山河等事亦不可见。是故偈言。若六唯一处诸大是一尘故。一尘者无物如向前答。一多和合不可得见故。罽宾国毗婆沙问曰。我无如是过失。何以故。以我微尘无六方厢。以离色香味触而与粗物和合成四大等一切粗物。答曰。偈言

  若微尘不合　　彼合何所成
  言微尘无厢　　能成则有厢

此偈明何义。为微尘和合成四大等。为离微尘别成四大。此明何义。若以微尘成四大者。不得说言微尘无厢不相和合。若离微尘成四大者。彼四大是谁家四大。若如是者。不得说言微尘无六厢。是故偈言。若微尘不合彼合何所成故。此明何义。若彼微尘不相和合成四大者。不得说言尘无六厢与粗物合成四大等。汝言与粗物合成四大者。但有言说都无实事。是故微尘不成一物。若彼微尘不成一物。说言成彼四大等物。悉皆虚妄。是故偈言。微尘无六厢能成则有相故。又偈言

  有法方所别　　彼不得言一
  影障若非大　　则彼二非彼

此偈明何义。汝向说言微尘和合。此义不然。何以故。偈言有法方所别彼不得言一故。有法方所别者。东方所有微尘方处。异于西方微尘方处。西方所有微尘方处。异于东方微尘方处。如是乃至上方下方微尘方处皆亦如是。若微尘体如是差别。云何言一。是故偈言。有法方所别彼不得言一故。影障若非大者。此明何义。若一一微尘无方处者。以何义故。东方日出西方有影。日在西方东方有影。若微尘无东西方相。以何义故。日照一厢不照余厢。是故微尘不成诸大。是故偈言。影障若非大故。则彼二非。彼者何者为二。一光照处。二影障处。此明何义。若彼微尘不障此尘。则不得言尘有方所。何以故。以微尘无方所分处十方差别。以彼东方微尘来者。不能障于西方微尘。西方微尘亦不能障于东方微尘。若彼此尘不相障者。则一切尘聚在一处。若一切尘聚在一处者。是则无处。以是义故。一切四大皆是微尘。皆微尘者。则不可见。如向所说

问曰。何故不说四大影障。乃言微尘有影障耶。答曰。我还问汝。为离微尘别有四大。但说四大有影障耶。问曰。难者释云。不离微尘而有影障。答曰。不离微尘有四大者。则非四大有影障也。以何义故。不言微尘自有影障非四大等有影障耶

问曰。为是微尘有影障。为是四大有影障耶。且置是事不须分别。而色等入相不全令无。答曰。我还问汝。以何等法是诸入相

问曰。难者释言。眼等境界青黄赤白。如是等法此是诸入相。答曰。我意正为思惟此事欲益众生。何故眼等内入取青黄等外诸境界。为是一物为是多物。若是多物向已说多不可得见。若是一物亦不可取。偈言

  若一行不次　　取舍亦不同
  差别无量处　　微细亦应见

此偈明何义。若纯一青物不杂黄等。若人分别眼境界者。行于地中不得说言有次第行。是故偈言。若一行不次故。此句明何义。若纯一青是一物者。举一足时即应遍蹑一切青处。以不遍蹑是故非一。取舍亦不同者。此句明何义。若纯一青物者。举足步时。何故唯当足所蹑处足未蹑处及步中间所有空处。以何义故。不一时蹑而有到处。有不到处。又若一物。则不得言足蹑此处不摄彼处。是故偈言。取舍亦不同故。差别无量处者。此句明何义。若纯青一段是一物者。以何义故。有多差别。象马车等不共一处。若是一者。白象住处亦应有马住。若尔不应有象马等住处差别。又若一者以何义故。象所到处马等不到。又若一者。象马中间何故有空。是故偈言。差别无量处故。微细亦应见者。此句明何义。若彼青等是一物者。于彼水等诸青物中。有青色等粗细诸虫。以何义故。但见粗虫不见细虫。是故偈言。微细亦应见故

问曰。以何义故。意识思惟彼青黄等。答曰。以汝向言虚妄分别诸入等相青等境界以为实有。是故我观微尘差别。而彼微尘不成一物。不成一故色等境界眼等不取。是故成我。唯有内识无外境界。问曰。依信说有。信者有四种。一者现见。二者比知。三者譬喻。四者阿含。此诸信中现信最胜。若无色等外境界者。云何世人言我现见此青等物。答曰。偈言

  现见如梦中　　见所见不俱
  见时不分别　　云何言现见

此偈明何义。我已先说梦见虚妄。诸凡夫人烦恼梦中有所见事皆亦如是。是故偈言。现见如梦中故。见所见不俱者。此句明何义。如现见色不知色义。此明何义如彼现见青色等时。作如是念。我虽现见青黄色等。彼时不见青色等义。何以故。以于后时意识分别然后了知。意识分别时无眼等识。以眼等识于先灭故。云何说言。我现见彼青黄色等。于佛法中无如是义。何以故。以一切法念念不住故。以见色时。无彼意识及以境界。意识起时。无彼眼识及以境界。以是义故。不得说言于四信中现信最胜。是故偈言。见所见不俱见时不分别云何言现见故

问曰。此义不然。何以故。以凡所见外境界者。先眼识见。后时意识忆念了知。是故必有色香味等外诸境界。以是义故。不得言无彼外境界。何以故。以见青等外诸境界。名为现见青等境界。答曰。此义不然。何以故。汝向说言。先眼识见。后时意识忆念了知。此义不成。何以故。我已先说。内自心识虚妄分别有外境界。而无色等外诸境界。向说眼识虚妄分别。如说梦中一切所见。依彼前时虚妄分别。后时意识思惟忆念。此以何义。依彼前时虚妄分别色等境界。虚妄眼识起心相应。虚妄意识虚妄分别。作是思惟。我分别知青等境界故。不得言眼见境界意识分别。以是义故。眼识见色后时忆念。此义不成

问曰。如梦见色虚妄忆念。寤时亦尔虚妄分别。若如是者以何义故。世人见梦皆知虚妄。寤时所见皆不虚妄。是故寤时所见色等。不同梦时虚妄所见。答曰偈言

  先说虚妄见　　则依彼虚忆
  见虚妄梦者　　未寤则不知

此偈明何义。汝向说言。如梦见色皆是虚妄。寤时所见皆不如是。此比决者义不相应。何以故。以梦见者当未寤时皆谓为实。及至寤时方知虚妄。是故偈言。见虚妄梦者未寤则不知故。如是世间诸凡夫人。为无始来虚妄颠倒分别集熏无明睡梦。梦中不实虚妄分别。见外境界谓以为实。以梦寤者见彼境界皆是虚妄。此以何义。以得出世对治实智无有分别。如实觉知一切世间色等外法皆是虚妄。依彼出世清净实智。便得世间及出世间胜智现前。如实知见一切境界皆悉虚妄。如是义者与梦不异。问曰。若但自心如是转变。虚妄分别见外境界。彼无实者。以何义故。遇善知识闻说善法。值恶知识闻说恶法。若无一切外境界者。彼云何说。若不说者云何得闻。若不闻者此云何成。答曰。偈言

  迭共增上因　　彼此心缘合
  无明覆于心　　故梦寤果别

此偈明何义。一切众生虚妄分别思惟忆念彼说我闻。依彼前人说者意识。于此听人闻者意识。起如是心。彼说我闻。而实无有彼前境界。是故偈言迭共增上因彼此心缘合故。问曰。若如梦中虚妄心识无实境界。寤亦尔者。以何义故。梦中寤中行善恶法爱与不爱果报不等

答曰。偈言无明覆于心故梦寤果别故。此明何义我已先说。唯有内心无外境界。以梦寤心差别不同。是故不依外境界等。成就善业不善业故。问曰。若彼三界唯是内心。无有身口外境界者。以何义故。屠猎师等杀害猪羊及牛马等。若彼非是屠猎师等杀害猪羊牛马等者。以何义故。屠猎师等得杀生罪。是故应有外色香等身口境界。答曰。偈言

  死依于他心　　亦有依自心
  依种种因缘　　破失自心识

此偈明何义。如人依鬼毗舍阇等是故失心。或依自心是故失心。或有忆念爱不爱事是故失心。或有梦见鬼着失心。或有圣人神通转变前人失心。如经中说。大迦旃延比丘。令娑罗那王见恶梦等。又毗尼中有一比丘。夜蹈瓜皮谓杀虾蟆死入恶道。是故偈言。依种种因缘破失自心识故。死依于他心亦有依自心者。此云何知。以依仙人嗔心嗔毗摩质多罗阿修罗王故杀余众生。此依他心他众生心。虚妄分别命根谢灭。以彼身命相续断绝。应如是知。又偈言

  经说檀拏迦　　迦陵摩灯国
  仙人嗔故空　　是故心业重

此偈明何义。若有死者不依他心不依自心。若如是者。以何义故。如来欲成心业为重。是故经中问优波离长者言。长者。汝颇曾闻。以何因缘檀挐迦国。迦陵迦国。摩灯伽国。旷野空寂无有众生及草木等。优波离长者白佛言。瞿昙。我昔曾闻。依仙人嗔心。杀害如是无量众生。是故得知唯有意业。若不尔者。如来何故于诸经中作如是说。是故偈言。经说檀拏迦迦陵摩灯国仙人嗔故空故

问曰。依仙人嗔心。信仙人鬼杀害如是三国众生。非依仙人嗔心而死。答曰。如来于汝外道经中。问久学尼干子言。于三业中何业为重。久学尼干子答如来言。身业为重。佛言尼干子。此彼城中所有众生为多为少。久学外道言。无量无边不可数知。佛言。尼干子。若有恶人欲杀害此诸众生者。几日可杀。尼干子言。非是一年二年可杀。佛告久学尼干子言。摩灯伽等三国众生。汝颇曾闻云何而死。为身业杀为意业杀。尼干子言。瞿昙。我昔曾闻。仙人嗔心以意业杀尔数众生。佛言。尼干子。若如是者。云何而言身业为重。尼干子言。如是如是。我不审谛谬闻而说。以是义故证成我义。三界唯心无身口业。此以何义。如世人言。贼烧山林聚落城邑不言火烧。此义亦尔。唯依心故善恶业成。以是义故。经中偈言

  诸法心为本　　诸法心为胜
  离心无诸法　　唯心身口名

唯心身口名者。但有心识无身口业。身口业者但有名字。实是意业身口名说。闻曰。若但有心无外境界。此义不然。何以故。他心智者。观察他心他众生心。是外境界。云何说言无外境界。又复有难。他心智者。为实知心为不实知。若不知者。云何说言知于他心。若实知者。云何说言无外境界。答曰。偈言

  他心知于境　　不如实觉知
  以非离识境　　唯佛如实知

此偈明何义。他心智者不如实知。何以故。以自内心虚妄分别。以为他心不能了知。何以故。以自心意意识杂故。是故偈言。他心知于境不如实觉知以非离识境故

问曰。为一切圣人皆不能知他众生心。为有知者。答曰。偈言。唯佛如实知故。此明何义。如彼佛地如实果体无言语处胜妙境界。唯佛能知余人不知。以彼世间他心智者于彼二法不如实知。以彼能取可取境界虚妄分别故。彼世间人虚妄分别此唯是识。无量无边甚深境界。非是心识可测量故。偈言

  作此唯识论　　非我思量义
  诸佛妙境界　　福德施群生

此偈明何义。此是诸佛甚深境界。非是我等思量所知。何以故。以彼非是心意意识思量境界故。若如是者。是谁境界。偈言诸佛妙境界故。此明何义。唯诸佛如来。以一切种智。于一切所知境界。皆如实而知故

唯识论一卷


唯识三十论颂

    No. 1586 [No. 1587; cf. No. 1585]

唯识三十论颂

        世亲菩萨造

        大唐三藏法师玄奘奉　诏译

护法等菩萨。约此三十颂造成唯识。今略标所以。谓此三十颂中。初二十四行颂明唯识相。次一行颂明唯识性。后五行颂明唯识行位。就二十四行颂中。初一行半略辩唯识相。次二十二行半广辩唯识相。谓外问言。若唯有识。云何世间及诸圣教说有我法。举颂詶答颂曰

  １由假说我法　　有种种相转
    彼依识所变　　此能变唯三
  ２谓异熟思量　　及了别境识

次二十二行半广辩唯识相者。由前颂文略标三能变。今广明三变相。且初能变其相云何。颂曰

    初阿赖耶识　　异熟一切种
  ３不可知执受　　处了常与触
    作意受想思　　相应唯舍受
  ４是无覆无记　　触等亦如是
    恒转如瀑流　　阿罗汉位舍

已说初能变。第二能变其相云何。颂曰

  ５次第二能变　　是识名末那
    依彼转缘彼　　思量为性相
  ６四烦恼常俱　　谓我痴我见
    并我慢我爱　　及余触等俱
  ７有覆无记摄　　随所生所系
    阿罗汉灭定　　出世道无有

如是已说第二能变。第三能变其相云何。颂曰

  ８次第三能变　　差别有六种
    了境为性相　　善不善俱非
  ９此心所遍行　　别境善烦恼
    随烦恼不定　　皆三受相应
  １０初遍行触等　　次别境谓欲
      胜解念定慧　　所缘事不同
  １１善谓信惭愧　　无贪等三根
      勤安不放逸　　行舍及不害
  １２烦恼谓贪嗔　　痴慢疑恶见
      随烦恼谓忿　　恨覆恼嫉悭
  １３诳谄与害憍　　无惭及无愧
      掉举与惛沈　　不信并懈怠
  １４放逸及失念　　散乱不正知
      不定谓悔眠　　寻伺二各二

已说六识心所相应。云何应知现起分位。颂曰

  １５依止根本识　　五识随缘现
      或俱或不俱　　如涛波依水
  １６意识常现起　　除生无想天
      及无心二定　　睡眠与闷绝

已广分别三能变相为自所变。二分所依云何应知依识所变假说我法非别实有。由斯一切唯有识耶。颂曰

  １７是诸识转变　　分别所分别
      由此彼皆无　　故一切唯识

若唯有识都无外缘。由何而生。种种分别。颂曰

  １８由一切种识　　如是如是变
      以展转力故　　彼彼分别生

虽有内识而无外缘。由何有情生死相续。颂曰

  １９由诸业习气　　二取习气俱
      前异熟既尽　　复生余异熟

若唯有识。何故世尊处处经中说有三性。应知三性亦不离识。所以者何。颂曰

  ２０由彼彼遍计　　遍计种种物
      此遍计所执　　自性无所有
  ２１依他起自性　　分别缘所生
      圆成实于彼　　常远离前性
  ２２故此与依他　　非异非不异
      如无常等性　　非不见此彼

若有三性。如何世尊说一切法皆无自性。颂曰

  ２３即依此三性　　立彼三无性
      故佛密意说　　一切法无性
  ２４初即相无性　　次无自然性
      后由远离前　　所执我法性
  ２５此诸法胜义　　亦即是真如
      常如其性故　　即唯识实性

后五行颂明唯识行位者。论曰。如是所成唯识性相。谁依几位如何悟入。谓具大乘二种种性。一本性种性。谓无始来依附本识法尔。所得无漏法因。二谓习所成种性。谓闻法界等流法已。闻所成等熏习所成。具此二性方能悟入。何谓五位。一资粮位。谓修大乘顺解脱分。依识性相能深信解。其相云何。颂曰

  ２６乃至未起识　　求住唯识性
      于二取随眠　　犹未能伏灭

二加行位。谓修大乘顺决择分。在加行位能渐伏除所取能取。其相云何

  ２７现前立少物　　谓是唯识性
      以有所得故　　非实住唯识

三通达位。谓诸菩萨所住见道。在通达位如实通达。其相云何

  ２８若时于所缘　　智都无所得
      尔时住唯识　　离二取相故

四修习位。谓诸菩萨所住修道。修习位中如实见理数数修习。其相云何

  ２９无得不思议　　是出世间智
      舍二粗重故　　便证得转依

五究竟位。谓住无上正等菩提。出障圆明能尽未来化有情类。其相云何

  ３０此即无漏界　　不思议善常
      安乐解脱身　　大牟尼名法

唯识三十论颂


无相思尘论

    No. 1619

无相思尘论

        陈那菩萨造

        陈西印度三藏法师真谛译

  若说邻虚　　是根本因　　不似起故
  非境如根　　识似聚起　　不从彼生
  聚无有体　　譬如二月　　由此二义
  外物非尘　　有说邻虚　　聚成万物
  识似彼起　　故立为尘　　邻虚体相
  若是实有　　识不似故　　非境如尘
  邻虚若尘　　则识无别　　若言相异
  则识不同　　异相在假　　故体非真
  邻虚体量　　众处无别　　若除邻虚
  万识不起　　是故万物　　悉是假名
  于内尘相　　如外而显　　立为识尘
  识似现故　　是识缘缘　　随生决定
  共立功能　　令次第起　　二根共生
  胜能为根　　于识无碍　　更互为因
  胜能为尘　　互生无始

若有人执眼等六识。缘外境起。是人或分别邻虚为境。是识因故。或分别邻虚聚为境。似聚识起故尘者何相。若识能了别其体相。如其体相识起。是故说此名尘。邻虚无此事。若邻虚实是识因譬如五根。是故邻虚非尘。若尔邻虚聚应是境。如聚识起故。虽复如此如其相起。识不从此生。是故聚亦非尘。何以故。若尘能生识。似其体相可信为尘。何以故。可说此尘为识生缘故。聚者则不如此。非实有故。譬如二月由眼根乱。识似二月起二月非。识境界实无有故。聚亦如此。离邻虚无有实体故。聚非识境界。是故外尘。由此二义非识境界。一一分不具故。有诸师说。是邻虚聚集成万物。有多种相具足。立此为境界。何以故。有别相能生证智。非但邻虚及邻虚聚。是故于邻虚及邻虚聚中。有相为六识作境邻虚相者非尘。譬如坚等。邻虚中有坚湿热动触。此物实有非眼识境界。眼识不如其起故。邻虚中万物亦如此。何以故。邻虚者于万物中若生识。是识则无差别。以万物中邻虚无有异故。若汝言由相差别故生识异。瓶等诸物相貌不同。缘此相故起识有异。是义不然。何以故。如此相貌差别。于瓶等假名物中。不无于邻虚。实物中则无邻虚。体量不异故。于万物中邻虚体量。所谓圆细无有差别。是故万物相貌非是实有。是假名有。是假名相者。谓瓶等诸物。若除邻虚。似瓶等识不生故。实物者。若析相应法似实物识不灭。如未析时。于瓶中五尘识生。析竟五尘识亦不灭故。五尘等是实有由此邻虚及聚。万物不能生识。是故外尘非识境界。若尔何法名尘。于内尘相如外显现。是名识尘外尘实无所有。于内识中众生乱心分别故。起六尘分别。此分别如在于外。如此显现。是四缘中名识缘缘。以是识体相故由此识生故。所以者何。是识作内尘相。从内尘生。具二法故。是故内尘名境界。问曰。如尘起识是亦可然。内尘是识一分共一时起。云何得作缘缘。答曰。立缘缘者。识缘此生无有二故。缘者或一时共起。能成余法从他生。决定随逐生不生故。问若次第生所缘能缘相云何。答曰。若因在前果在后。果随因因不随果。若因有果必有。若因无果必无。果随因或有或无。是名因果相。复次为安置功能次第故。立所缘能缘。是似尘识次第起为生。似果起功能生识相续。问曰。若内尘是识。缘缘是缘生。经当云何释经言依根缘色眼识得生。广说如经。答曰。功能体相能共造果。说名为根。问根者体用云何答胜能为体。此体因何法可比度知。有由生自果故。是其胜能可得了别。非有四大色此功能于识中无有妨碍。此功能在识中离识。其体不可显示。如我所立根与汝所立根。同功能为体。此有何异。如此功能及似尘相。更互为因。如此功能及似尘相生从无始来悉尔。依功能说名根缘内尘相名境。是乱识不可言其相。得生此法更互为因亦无有始。何以故。或功能成熟故起似尘识。或似尘识故功能得成。识者或异二或不异二或不可说。如此内尘具二法故可为识境

无相思尘论


显识论(从无相论出)

    No. 1618

显识论一卷(从无相论出)

        真谛三藏译

一切三界但唯有识。何者是耶。三界有二种识。一者显识。二者分别识。显识者。即是本识。此本识转作五尘四大等。何者分别识。即是意识。于显识中分别作人天长短大小男女树藤诸物等。分别一切法。此识聚分别法尘。名分别识。譬如依镜色影色得起。如是缘显识。分别识得起。是分别若起。安立熏习力于阿梨耶识。由此熏力本识未来得生。缘此未来显识。未来分别识得起。以此因义。是故生死无有前后。为显此义。佛于解节经中。说偈言

  显识起分别　　分别起熏习
  熏习起显识　　故生死轮转

所言熏习者。一执着分别性。二观习真实性。以此二义故名熏习。第一熏习者。增长阿梨耶识。阿梨耶识被增长。具足诸能。能生六道受生诸识。以是义故生死圆满。第二熏习者。名观习真实性。此熏习能除执着分别性。是第一熏习被损坏故。阿梨耶识亦被损。阿梨耶识既被损。受生识亦被损。以阿梨耶识能生三界。由被损故得三界转。依此转依义具五种。如灭差别相中解说。显识者有九种。一身识。二尘识。三用识。四世识。五器识。六数识。七四种言说识。八自他异识。九善恶生死识。其次分别识有二种。一有身者识。二受者识前九识中

第一身识者。谓转作似身。是故识名身识。所言似者。如所执身相貌似身而非真实故名似身。此识能作相似身。名为身识。即是五根。余尘等八种识亦如是。即是唯识义也。所言身识者有五种。即眼根界等。是名身识通是五根

第二尘识有六种。色界等乃至识尘。通名应受识

第三用识者。六种眼识界等即是六识。大论名为正受识

第四世识者有三种即三世。过去未来现在也。又生死相续不断故名世

第五器识者。大论名处识也略即器世界。谓外四大五尘。广即十方三界等

第六数识者。算计量度

第七四种言说识者。谓见闻觉知四种。一切言说不出此四。若不说见即说闻。觉知亦尔

第八自他异识者。谓依处各异六趣不同。依处者身也。六趣身谓自他异识

第九善恶趣生死识者。一切生死不离两道。善者人天。恶者四趣。此善恶道不离生死。即生即灭无停住故

又有身者。识者我见所覆。此识为我见贪爱所覆故受六趣生。此识为生死身。若有此识即有身识。此识若尽则生死身尽。我见生一切肉惑。贪爱生一切皮惑。故有生死身。若离爱我见即无皮肉烦恼。若无皮肉烦恼即无三界身故。身识受生死也。二受者识。意界名受者。识即三种意识。一谓阿梨耶识。是细品意识。恒受果报。不通善恶但是无覆无记。二陀那识。是中品意识。但受凡夫身果报。三者谓常所明意识。是粗品意识。通受善恶无记三性果

五识亦尔。此三品意识。通能受用果报。但今据兴废为言故。呼梨耶识为受者识。又梨耶识是凡夫所计我处。由陀那执梨耶识作我境。能执正是陀那故。七识是我见体故。分别识有二种。一有身识。二身者识。合名意根。大本染污根即陀那识。二次第缘意根体。即缘本识作我境。自出彼缘相彰。显识有九种。如上显识唯是梨耶。若是分别识则是陀那及意识。陀那分别我。意识分别万法。意识有三种分别。五识但有自性分别。熏习有四种方便。一忍二名三相四世第一法。一忍有二。一广二略。一切众生皆迷真实性。今修习先作广观次作略观。得入真实。所言广者即观四谛。苦集即是凡夫俗谛。灭道即圣人真谛。各有九种。观苦九分。即三界各有三世成九。又欲界一有。色界四有。无色界四有。故为九种。集谛九分。即是九结分者。灭此九结为九灭谛。道谛九分者。九次第三摩提即九次第定。次略观先观苦谛为八种者。观四大四名四大。即色阴四名即四阴。以为八种苦集有八者。即八邪乖八圣道。灭谛八种者。灭八邪即名八种灭。道谛八者。修八圣道以为道谛。次复略观苦为七。六趣及中阴。集七者。即是七使。七使者贪嗔痴慢疑见欲界。欲名欲使。色无色界名为有使。合为七种使。灭七使名七种灭。道谛七者。即七觉分。次略观苦为六种。谓六种内入。集六种。谓六种贪爱即六尘生六种贪。灭六贪为六灭。道六者。六种出离界。一出离杀。他嗔修慈界。二出离逼恼嗔修悲界。三出离嫉妒嗔修喜界。四出离贪欲修舍界。五出离觉观熏修念出入息界。六出离无明惑修无我界。修此六种名出离界

次略观苦为五即五阴。集为五即五盖。灭此五盖为五种灭。道五者。即五根五即五力等。次略观苦四种即四念处。谓身受心法。集四者。即四取亦即四流。四取者。取只是贪。有四种贪。即是取有四种。一欲取二见取三戒取四我语取。我语取者。是内取缘内五阴。贪色无色八禅定内法。名我语取。于中取名我语取。若贪欲界尘名外法名为欲取。欲取者是断见众生。我语取是常见众生。此两法缘事起见取戒取。取常见缘理起此四取。是受资粮。明受爱有三种。一远离贪爱。即一切三涂众生。二求得贪爱。即人天至三空三安住贪爱。即非想非非想。谓为涅槃。如四种取名集谛。灭四取名四灭谛。道谛四者谓四念处。即是四种般若。观身通达苦谛。观受通达集谛。观心通达灭谛。观法通达道谛。观身为粗。观三界身粗为苦。观欲界身寒热等为苦。观色界身四威仪为苦。观无色界心念念不住苦。观受通达集谛者。众生一切贪爱缘受故起。若无受贪不生故。观受通达集谛。若观心通达灭谛者。一切众生安立我见于心中。是故众生执我见则不信有灭。只由陀那识执梨耶是一是常故。我体非灭。观心非我故信有灭。以舍我见。观人法二无我故。观心通达灭谛。观法通达道谛者。法有二。一净品二不净品。观不净品为苦集。净法为灭道。又不净品即一切诸惑。净品者一切治道故。应须通达道谛。次略观苦三种。即观三界为苦。观欲界为苦苦。观色界为坏苦。生住不停乐坏时即苦故坏苦。观无色界为行苦。生住坏三时皆苦。但众生有二道。恶道为苦善道为乐。舍此二边谓为涅槃。此心有行有动。是故无常故苦也。集有三者即三毒。又三种身见戒取疑。身见者。众生着身见。执有常乐我净故住生死。不修出世道。戒取者。不肯修正道。疑者疑不决了灭谛灭。此三种烦恼即为三灭道。三者谓戒定慧

次略观苦为二。谓身心又名色亦是。集二者。十二因缘中谓无明贪爱。灭此二种为二种灭。道谛二者即定慧。次略观苦为一。谓无常为苦。集者谓不正思惟。灭此思惟为灭。道谓身念处。即总观四念处名为身念处。又义若自思惟为道谛。不正思惟为集谛。欲令实慧分明故。作广略二种观观苦。一切法作九分乃至一分。余三谛亦然。语言及分别熏习有四种方便处。语言熏习者。从忍名。乃至自性法处。所言处者即名为所。及境界为处。分别熏习从相至第一一切修得法。一切修得法处者。从下品至上品相第一一切为处。若人依名为思择。是名语言熏习。若人离名句等直思择义。是名分别熏习。是显识显后两识。两识者。一四种言说识。二自他差别识。显此两识。余七种识及分别识。此八种识。缘语言熏习得起。又两识。一身识。二受者识。及自他异识。此三识缘身见熏习得生。又善恶生死识。缘有分熏习得起。如是诸识。是名一切三界唯有识也(义疏九识第三合简文义有两一明识体二明识用一识体者出唯识论)

论曰。一切三界唯有识

问曰。一切法只是三界。何用二言。答两义。一者分段是三界变易是界外。四种生死是一切也。二者广言一切是。何谓十方。十方非三界故。云一切三界也。今唯有识者。上七种死唯识所显现。离识无别体故。言三界唯有识也。界者自性义。自性有两。一者不杂义。欲性异色。色非无色也。二者性是不改不转为义。欲为欲色为色无色为无色。善恶亦尔。三性不改为义。唯有识者。离识无有别境也。由识见有似尘。离识尘无体也

论曰。何者为识。所谓三界

释曰。前明离识无三界。此明离三界无识。又前明二识用

论曰。识有二种。一显识。二分别识

释曰。初一是本识。本识显六尘也。次一是六识。六识分别此异彼也。又前一明所缘。后一明能缘。就显识有二种回转。一回转作六尘。二回转作五根。次分别识回转作似我。如是意执二识计我也。即陀那与意识共作我见。陀那执本识起我体相。意识分别计我有种种差别用故。一切法不有不无。由六尘有六识不可定无也。离六识无六尘不可定有。又一切法不可定说有。亦不可定说无也。人法二我不实故不可说有有。人法二空真实故不可言无。又义一切法决定有决定无。人法决定无。此人法二空是决定有。此三悉共显俗是有。显真是无。二明识用

论曰。此分别识若起。安立熏习力于阿梨耶识中

释曰。熏习力者。譬如烧香熏习衣。香体灭而香气犹在衣中名为熏衣。此香不可言有。香体灭故。不可言无。香气在故。故名为熏。如六识起善恶。留在熏力于本识中。能得未来报。名为种子。若小乘义正量部名为无失。譬如券约。故佛说偈

  诸业不失　　无数劫中　　至聚集时
  与众生报

摩诃僧祇柯部。名为摄识。即是不相应行。譬如诵经。初一遍未得。第二遍诵摄前第一。如是乃至第十遍诵通利时。即通摄前九。如是初识能变异在第一。如是乃至第九变异在第十中。第十能摄前九。即此第十变异之用。名为摄识。有前九用故不失前九也萨婆多部。名同随得。同者与数处时等相应长。随者与三性不相妨。而得者不失义。同亦不失。随亦不失。譬如摩斗楼。此言榆华。取洛柯汁谓赤色汁。点摩斗楼华须。华须与赤色俱。后结实成熟。则有赤色出。是名同时修得。赤色至果不失故名同同前有赤色出。是名同修得。赤色至果不失故名同。前来至后不失名随。随最后显故名得也。若是他毗梨部。名有分识有者三有。即三界也。亦有七有。一中有二生有。三业有。四死有。通前三有为七有也。欲色二界具四有。若无色界无中有。中有者。正辩名为向生处。处者。有因缘名处也。如十二因缘有支。是事有故是事有。是事生故是事生。有者是因。因有二。一前因。二同时因。如橘子生芽。是前时因。芽生则有并橘。同时因。行缘识。识缘名色。名色缘六入。六入缘触受等。是同时。所以言。是事有故是事有者。为破外道生有义。外义云。一切众生从自在天我有故生死是有。言内义同。今破由前因生故得生。汝自在天无有。非生生死。有是生故。不得是有。故不得是有故是有也。故佛立义是事有即有生。汝自在天是有。非是生生不同内义。乃至从世性微尘等生亦尔。又外道立无因有果。果自然生故破外道。此物有是因有故果事是也。所以明二义者。为明因缘具故得生。若此物有故此物有是缘。若此物生故此物生。是明因义。有分者。生处即是生因生缘。此有分识体。是果报法决。是自性无记也

四有者。从识支至六岁是生有。从七岁已上能分别生熟起贪至未舍命是业有。死有者。唯一念中有即中阴。就业有中。六识起三种业。善不善不动等三业。有为有为有分识。所摄持六识自谢灭。由有分识摄持力用在。问曰。何故立有分识。一期生中常缘一境。若生人天。此识见楼观。等事报。若起六识用粗覆障。则不觉此识用。若生恶道。此识但缘火车等。若报起六识用强则不觉此识缘也。若欲界六识缘欲境。凡夫不能觉。乃至无色亦然。若无色诸识灭。此有分识用则显。如梨耶及意识也

言种子者。此相续变异。能感未来果报。是名种子。相续无变异亦非种子。若但变异无相续亦非种子。相续变异不相离故成种子。如螺白色非一非异。若白色是螺。螺则无三尘。若白色异螺。则见白色不得螺故。不可言定异以不异故名白螺也。相续变异亦尔。故成种子。缘此熏习力。本识未来得生者

释曰。缘熏习力。种子若成。本识得生。缘未来显识。未来分别六识得生也。是故生死无前后者。若离烦恼业则不得生。若生死有前分。则别有前分众生处起烦恼业感前分处。既无前分众生起业。则无有前分生死故。知生死无始无初。四义明无。初一非本。若众生初无后有者。此无不作有本。有二种过失。一者若无不能生后。若能生有则非无。二者平等过失。若虚空花生有事者。可得从无生有。二者不见离欲众生生故。生死无初也。若生死初无贪欲等。后方有贪欲等者。离欲阿罗汉等无欲。亦应生欲。以是罗汉更不生欲故。知生死无初。三者修行梵行无用故。故生死无初。一切圣人修八圣行。为灭令不生修梵行。离欲人更不生灭故。故知生死无初。四者生死有二种。一恶报二善道。是善恶由善恶二因。不得无因。是生死初为善道为恶道。若善道者未有善因。若恶道者未有恶因。离善恶二道更无第三道故。知无初也。难曰。初者自然不用因缘。后者须因缘。若尔者。是义不然。有二过。一即理不平等故二因果不相似。若汝说生死不由因后由因者。则不平等。初后皆是生死。何故一由因一不由因。二不相似者。果亦有因因亦有因。因果皆有因故得相似。若相似能生同类。汝若前无因故。后亦应无因。若前无因后有因者。则不能生。若能生者。豆应生麦麦亦应生豆。而不然者。故知汝前为后果作因前因不成因也。佛说偈初句显识。即是梨耶。梨耶则果报识。分别识即是烦恼识。是从果报识起烦恼识。烦恼识即陀那等。次句明从烦恼起识识起熏习。熏习即是业功能。能转变本识成种子识也。次句从。业起果报。次句总结生死轮转。轮转者以不定故。或因转作果。或果转作因也

所言熏习有二种者。下为显二义。一显生死方便名为邪。亦名违逆。二显涅槃方便名正。亦名随顺执着。分别性者。一切诸法有三种性。一分别性。二依他性。三真实性。分别性者。名言所显诸法。依他性者。一切诸法因果道理所显真实性者。一切诸法如如性。分别者无相为其性。依他者。无生是其性。所言性者。自有五义。一者自性种类义。一切瓶衣等不离四大种类义。同是四大性。是自性义。二者因性义。一切四念处圣法所缘道理缘此道理能生圣法。亦是因义。三者生义。若物无生则性不可见。生义可见故性训生。五分法身是生性义。如来正说众生信乐生三种信。一信有真实道理。二信得五分法身功德。三自利利他德备修五分身。五分身生则显至得性故。故五分法身生以此为性义。四不坏义。此性在凡夫不染在圣不净。故名不坏。五秘密藏义。亲近则行净。乖违则远离。此法难得幽隐故名秘密。即名藏义。生有四种。一触生。如男女交会有子。二嗅生。如牛羊等类。雌雄有欲心。雄以鼻嗅雌等根则便有子。三沙生。如鸡雀等。雌雀起欲心。以身坌尘沙之中。而有卵等生子。四声生。如鹤孔雀等类。有欲心闻雄鸣声。亦生卵生子。一切出卵不可食。皆有子也。分别性是无有空。分别无法可得故。依他性是不如空。如是破所执。真实性是自性空。无人法二我。是自性空也。复次分别性如空花是极无。依他性异空花。似幻化非空有无。观依他性不有不无故。能得道成圣空无是断观。空无不能得道成圣。一切烦恼别执着分别性。一切诸法欲乐观习真实性。执着观习此二属依他性。此二种法是名熏习。一烦恼种子熏习。二道种子熏习也。第二熏习增长本识者。以同类故。本识缘如如起四谤。是虚妄熏习种子烦恼同是虚妄。是故熏习能增长本识。譬如甜物能增长淡。淡亦是甜性。同性故能增长。具足诸能者。明业有四种。一被作不被长。如利智人遇恶知识起不善业是作。复即追悔故不被长。二被长不被作。如羞惭人随人修行。此善被增转广。不能自起若心故不作。三亦作亦长者。如人作善业。复恒数习。此善业转广大也。四不作不长者。即无漏善业若转增长生死报。名为作者。无漏能除生死作者故不长。前三是业后一分非。就前三中。取第三句亦作亦长。故云具足诸法。能生六趣者。即能得六趣生死果报。生阿梨耶识因。此生死圆满身因熏习方便故生死得成。故云此因义生死圆满。第二观习真实性。观三种无性。是名观习真实性。观有四用。一者除观。二灭观。三证观。四修观。观如如是苦谛性性。三谛亦然。观四谛如如具四用。观如如灭苦灭集。观如如即证灭。会如如即修道也能除执着分别性者。分别于无中作有。真实观者。显有无与自性相违故云除。分别性是第一熏习被损坏者。现在被损。未来被坏。若损集谛。苦亦被损。阿梨耶识被损者。本有七重苦谛。三界即为三重。三重被损竟。阿梨耶识是受果报本。虽无惑业所引。不复入三界生。而在无流界中四种生死内受生。如是乃至无有生死位也。梨耶被损故受生亦被损何以故。显识是分别识。因显识被损故。知分别识亦被损。此分别人我及六尘等识。又已灭尽何止被损耶。今言被损者。据净品为语。此与本识俱尽也。是阿梨耶能下者可灭除也

显识论


显扬圣教论

    No. 1602 [cf. No. 1603]

显扬圣教论卷第一

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄事品第一

  善逝善说妙三身　　无畏无流证教法
  上乘真实牟尼子　　我今至诚先赞礼
  稽首次敬大慈尊　　将绍种智法王位
  无依世间所归趣　　宣说瑜伽师地者
  昔我无著从彼闻　　今当错综地中要
  显扬圣教慈悲故　　文约义周而易晓
  摄事净义成善巧　　无常苦空与无性
  现观瑜伽不思议　　摄胜决择十一品
  一切界杂染　　谛依止觉分
  补特伽罗果　　诸功德九事

论曰。一切者有五法总摄菩萨藏。何等为五。颂曰

  心心所有色　　不相应无为

论曰。心者谓心意识差别名也。问何等为识。答识有八种。谓阿赖耶识眼耳鼻舌身识意及意识

阿赖耶识者。谓先世所作增长业烦恼为缘。无始时来戏论熏习为因。所生一切种子异熟识为体。此识能执受了别色根根所依处及戏论熏习。于一切时一类生灭不可了知。又能执持了别外器世界与不苦不乐受等相应一向无覆无记与转识等作所依因与染净转识受等俱转能增长有染转识等为业及能损减清净转识等为业。云何知有此识。如薄伽梵说。无明所覆爱结所系。愚夫感得有识之身。此言显有异熟阿赖耶识。又说如五种子。此则名为有取之识。此言显有一切种子阿赖耶识。又说阿陀那识甚深细一切种子如暴流。我于凡愚不开演。恐彼分别执为我。眼识者谓从阿赖耶识种子所生。依于眼根与彼俱转。缘色境界了别为性。如薄伽梵说。内眼处不坏外色处。现前及彼所生作意正起如是所生眼识得生。又说缘眼及色眼识得生。如是应知。乃至身识。此中差别者。谓各依自根各缘自境。各别了别一切应引。如前二经

意者。谓从阿赖耶识种子所生还缘彼识。我痴我爱我我所执我慢相应。或翻彼相应。于一切时恃举为行。或平等行与彼俱转。了别为性。如薄伽梵说。内意处不坏外法处。现前及彼所生作意正起。如是所生意识得生。意识者。谓从阿赖耶识种子所生。依于意根与彼俱转。缘一切共不共法为境了别为性。心所有法者。谓若法从阿赖耶识种子所生。依心所起与心俱转相应。彼复云何谓遍行有五。一作意二触三受四想五思。别境有五。一欲二胜解三念四等持五慧。善有十一。一信二惭三愧四无贪五无嗔六无痴七精进八轻安九不放逸十舍十一不害。烦恼有六。一贪二嗔三慢四无明五见六疑。随烦恼有二十。一忿二恨三覆四恼五嫉六悭七诳八谄九憍十害十一无惭十二无愧十三惛沈十四掉举十五不信十六懈怠十七放逸十八失念十九心乱二十不正。知不定有四。一恶作二睡眠三寻四伺

作意者。谓从阿赖耶识种子所生。依心所起与心俱转相应。动心为体引心为业。由此与心同缘一境。故说和合非不和合。如经中说。若于此作意即于此了别若于此了别即于此作意。是故此二恒和合非不和合。此二法不可施设离别殊异。复如是说。心心法行不可思议。又说由彼所生作意正起如是所生眼等识生

触者。谓三事和合分别为体受依为业如经说。有六触身。又说眼色为缘能起眼识。如是三法聚集合故能有所触。又说触为受缘。受者谓领纳为体。爱缘为业。如经说有六受身。又说受为爱缘

想者。谓名句文身熏习为缘。从阿赖耶识种子所生。依心所起与心俱转。相应取相为体。发言议为业。如经说有六想身。又说如其所想而起言议。思者谓令心造作得失俱非。意业为体。或为和合。或为别离。或为随与。或为贪爱。或为嗔恚。或为弃舍。或起寻伺。或复为起身语二业。或为染污。或为清净行。善不善非二为业。如经说有六思身。又说当知我说。今六触处即前世思所造故业

欲者。谓于所乐境希望为体。勤依为业。如经说欲为一切诸法根本

胜解者。谓于决定境如其所应印解为体。不可引转为业。如经说我等今者心生胜解。是内六处必定无我

念者。谓于串习境令心明记不忘为体。等持所依为业。如经说诸念与随念别念及忆不忘不失法心明记为性

等持者。谓于所观境专住一缘为体。令心不散智依为业。如经说诸令心住与等住安住近住及定住不乱不散摄寂止等持心住一缘性

慧者。谓即于所观境简择为体。如理不如理非如理非不如理悟入所知为业。如经说简择诸法最极简择极简择法遍了近了黠了通达审察聪睿觉明慧行毗钵舍那

信者。谓于有体有德有能心净忍可为体。断不信障为业。能得菩提资粮圆满为业。利益自他为业。能趣善道为业。增长净信为业。如经说于如来所起坚固信

惭者谓依自增上及法增上羞耻过恶为体。断无惭障为业。如前乃至增长惭为业。如经说惭于所惭。乃至广说。愧者。谓依世增上羞耻过恶为体。断无愧障为业。如前乃至增长愧为业。如经说愧于所愧。乃至广说

无贪者。谓于有有具厌离无执不藏不爱无著为体。能断贪障为业。如前乃至增长无贪为业。如经说无贪善根。无嗔者。谓于诸有情心无损害慈愍为体。能断嗔障为业。如前乃至增长无嗔为业。如经说无嗔善根

无痴者。谓正了真实为体。能断痴障为业。如前乃至增长无痴为业。如经说无痴善根。精进者。谓心勇无惰不自轻贱为体。断懈怠障为业。如前乃至增长精进为业。如经说起精进住有势有勤有勇坚猛不舍善轭

轻安者。谓远离粗重身心调畅为体。断粗重障为业。如前乃至能增长轻安为业。如经说适悦于意身及心安。不放逸者。谓总摄无贪无嗔无痴精进为体。依此能断恶不善法。及能修彼对治善法断放逸障为业。如前乃至增长不放逸为业。如经说所有无量善法生起一切皆依不放逸根

舍者。谓总摄无贪无嗔无痴精进为体。依此舍故得心平等得心正直心无发动断发动障为业。如前乃至增长舍为业。由不放逸除遣染法。由彼舍故于已除遣不染污住。如经说为除贪忧心依止舍

不害者。谓由不恼害诸有情故悲哀恻怆愍物为体。能断害障为业。如前乃至增长不害为业。如经说由不害故知彼聪睿乃至广说。贪者。谓于五取蕴爱乐覆藏保着为体。或是俱生或分别起能障无贪为业。障得菩提资粮圆满为业。损害自他为业。能趣恶道为业。增长贪欲为业。如经说诸有贪爱者为贪所伏蔽

嗔者。谓于有情欲兴损害为体。或是俱生或分别起能障无嗔为业。如前乃至增长嗔恚为业。如经说诸有嗔恚者为嗔所伏蔽

慢者。谓以他方己计我为胜我等我劣令心恃举为体。或是俱生或分别起能障无慢为业。如前乃至增长慢为业。如经说三种慢类我胜慢类我等慢类我劣慢类。无明者。谓不正了真实为体。或是俱生或分别起能障正了为业。如前乃至增长无明为业。如经说诸有愚痴者无明所伏蔽

见者。谓五见为体。一萨迦耶见。谓于五取蕴计我我所染污慧为体。或是俱生或分别起能障无我无颠倒解为业。如前乃至增长萨迦耶见为业。如经说如是知见永断三结。谓身见戒禁取疑。二边执见。谓于五取蕴执计断常染污慧为体。或是俱生或分别起能障无常无颠倒解为业。如前乃至增长边执见为业。如经说迦多衍那一切世间依止二种或有或无。三邪见。谓谤因谤果或谤功用或坏实事染污慧为体。唯分别起能障正见为业。如前乃至增长邪见为业。如经说有邪见者所执皆倒。乃至广说。四见取。谓于前三见及见所依蕴计最胜上及与第一染污慧为体。唯分别起能障苦及不净无颠倒解为业。如前乃至增长见取为业。如经说于自所见取执坚住。乃至广说。五戒禁取。谓于前诸见及见所依蕴计为清净解脱出离染污慧为体。唯分别起能障如前无颠倒解为业。如前乃至增长戒禁取为业。如经说取结所系。疑者。谓于诸谛犹豫不决为体。唯分别起能障无疑为业。如前乃至增长疑为业。如经说犹豫者疑

忿者。谓于现在违缘令心愤发为体。能障无嗔为业。乃至增长忿为业

恨者。谓于过去违缘结怨不舍为体。能障无嗔为业。乃至增长恨为业

覆者。谓于过犯若他谏诲若不谏诲秘所作恶为体。能障发露悔过为业。乃至增长覆为业

恼者。谓于过犯若他谏诲便发粗言心暴不忍为体能障善友为业。乃至增长恼为业

嫉者。谓于他所有功德名誉恭敬利养心妒不悦为体。能障慈仁为业。乃至增长嫉为业

悭者。谓积聚吝着为体。能障无贪为业。乃至增长悭为业

诳者。谓为惑乱他现不实事心诡为体。能障爱敬为业。乃至增长诳为业

谄者。谓为欺彼故诈现恭顺心曲为体。能障爱敬为业。乃至增长谄为业。如经说忿恨覆恼嫉悭诳谄

憍者。谓暂获世间兴盛等事心恃高举无所忌惮为体。能障厌离为业。乃至增长憍为业。如经说无正闻愚夫见少年无病寿命等暂住而广生憍逸。乃至广说

害者。谓逼恼有情无悲无愍无哀无怜无恻为体。能障不害为业。乃至增长害为业。如经说诸有害者必损恼他

无惭者。谓于自及法二种增上不耻过恶为体。能障惭为业。乃至增长无惭为业。如经说不惭所惭无惭生起恶不善法。乃至广说。无愧者。谓于世增上不耻过恶为体。能障愧为业。乃至增长无愧为业。如经说不愧所愧无愧生起恶不善法。乃至广说

惛沈者。谓依身粗重甘执不进以为乐故令心沉没为体。能障毗钵舍那为业。乃至增长惛沈为业。如经说此人生起身意惛沈。掉举者。谓依不正寻求或复追念曾所经见戏乐等事心不静息为体。能障奢摩他为业。乃至增长掉举为业。如经说汝为掉动亦复高举。乃至广说

不信者。谓于有体有德有能心不净信为体。障信为业。乃至增长不信为业。如经说若人不住不净信心终无退失所有善法乃至广说

懈怠者。谓耽着睡眠倚卧乐故怖畏升进自轻蔑故心不勉励为体。能障发起正勤为业。乃至增长懈怠为业。如经说若有懈怠必退正勤。乃至广说

放逸者。谓总贪嗔痴懈怠为体。由依此故心不制正恶不善法及不修习彼对治法障不放逸为业。乃至增长放逸为业。如经说夫放逸者是生死迹。乃至广说

失念者。谓于久所作所说所思若法若义染污不记为体。障不忘念为业乃至增长失念为业。如经说谓失念者无所能为。乃至广说。心乱者。谓于所修善心不喜乐为依止故驰散外缘为体。能障等持为业乃至增长心乱为业。如经说若于五欲其心散乱流转不息。乃至广说

不正知者。谓于身语意行不正了住染污慧为体。能障正知为业。乃至增长不正知为业。如经说有失念者住不正知。乃至广说

恶作者。谓于已作未作善不善事若染不染怅怏追变为体能障奢摩他为业。乃至增长恶作为业。如经说若怀追悔则不安隐。乃至广说

睡眠者。谓略摄于心不自在转为体。能障毗钵舍那为业。乃至增长睡眠为业。如经说贪着睡眠味如大鱼所吞。寻者。谓或时由思于法造作或时由慧于法推求散行外境令心粗转为体。障心内净为业。乃至增长寻为业

伺者。谓从阿赖耶识种子所生依心所起与心俱转相应于所寻法略行外境令心细转为体余如寻说。乃至增长伺为业。由此与心同缘一境故。说和合非不和合。如薄伽梵说。若于此伺察即于此了别。若于此了别即于此伺察。是故此二恒和合非不和合。此之二法不可施设离别殊异。复如是说。心心法行不可思议

证有此二阿笈摩者。如薄伽梵说。由依寻伺故发起言说。非无寻伺

诸心法中略不说者如其所应。广说应知。如识与心法不可思议。是诸心法展转相望应知亦尔

色者有十五种。谓地水火风眼耳鼻舌身色声香味触一分及法处所摄色。地有二种。一内二外。内谓各别身内眼等五根及彼居处之所依止。坚鞕所摄有执受性。复有增上积集。所谓发毛爪齿尘垢皮肉筋骨脉等诸不净物。是内地体形段。受用为业。外谓各别身外色等五境之所依止。坚鞕所摄非执受性。复有增上积集。所谓砾石丘山树林甎等。水等灾起彼寻坏灭。是外地体形段。受用为业。依持受用为业。破坏受用为业。对治资养为业

水亦二种。一内二外。内谓各别身内眼等五根及彼居处之所依止。湿润所摄有执受性。复有增上积集。所谓洟泪涎汗膏髓痰等诸不净物。是内水体。润泽聚集受用为业。外谓各别身外色等五境之所依止。湿润所摄非执受性。复有增上积集。所谓泉源溪沼巨壑洪流等。火等灾起彼寻消竭。是外水体。依持受用为业。变坏受用为业。对治资养为业。火亦二种。一内二外。内谓各别身内眼等五根。及彼居处之所依止。暖热所摄有执受性。复有增上积集。所谓能令有情遍温增热。又能消化凡所饮啖。诸如是等是内火体。成熟和合受用为业。外谓各别身外色等五境之所依止。暖热所摄非执受性。复有增上积集。所谓炎燎村城蔓延洲渚。乃至空迥。无依故灭。或钻木击石种种求火。此火生已不久灰烬。是外火体。变坏受用为业。对治资养为业。风亦二种。一内二外。内谓各别身内眼等五根及彼居处之所依止。轻动所摄有执受性。复有增上积集。所谓上下横行入出气息。诸如是等是内风体。发动作事受用为业。外谓各别身外色等五境之所依止。轻动所摄非执受性。复有增上积集所谓摧破山崖偃伏林木等。彼既散坏。无依故静。若求风者动衣摇扇。其不动摇无缘故息。诸如是等是外风体。依持受用为业变坏受用为业。对治资养为业

眼谓一切种子阿赖耶识之所执受。四大所造色为境界缘色境。识之所依止。净色为体。色蕴所摄。无见有对性。如眼如是耳鼻舌身亦尔。此中差别者。谓各行自境缘自境识之所依止

色谓眼所行境。眼识所缘四大所造若显色若形色若表色为体。色蕴所摄。有见有对。此复三种。谓妙不妙及俱相违。彼复云何。谓青黄赤白如是等显色。长短方圆粗细高下正及不正。烟云尘雾光影明闇。若空一显色。若彼影像之色。是名为色

声谓耳所行境。耳识所缘四大所造可闻音为体。色蕴所摄。无见有对。此复三种谓可意不可意及俱相违。或因手等相击出声。或由寻伺扣弦拊革。或依世俗。或为养命。或宣畅法义而起言说。或依托崖谷而发响声。如是若自相若分别若响音。是名为声

香谓鼻所行境。鼻识所缘四大所造可嗅物为体色蕴所摄。无见有对性。此复三种谓好香恶香及俱非香。彼复云何。所谓根茎皮叶花果烟末等香。若俱生若和合若变异是名为香。味谓舌所行境。舌识所缘四大所造可尝物为体。色蕴所摄。无见有对性。此复三种。谓甘不甘及俱相违。彼复云何。所谓酥油沙糖石蜜熟果等味。若俱生若和合若变异。是名为味。触一分谓身所行境。身识所缘四大所造可触物为体。色蕴所摄。无见有对性。此复三种。谓妙不妙及俱相违。彼复云何。所谓涩滑轻重缓急软冷饥渴饱闷强弱痒病老死疲息粘勇。或缘光泽。或不光泽。或缘坚实。或不坚实。或缘执缚。或缘增聚。或缘乖违。或缘和顺。若俱生若和合若变异。是名触一分

法处所摄。色谓一切时意所行境。色蕴所摄。无见无对。此复三种。谓律仪色不律仪色及三摩地所行境色。律仪色云何。谓防护身语业者由彼增上造作心心法故。依彼不现行法建立色性。不律仪色云何。谓不防护身语业者。由彼增上造作心心法故。依彼现行法建立色性。三摩地所行境色云何。谓由下中上三摩地俱转。相应心心法故。起彼所缘影像色性。及彼所作成就色性。是名法处。所摄色心不相应行者。谓诸行与心不相应。于心心法及色法分位。假施设性不可施设。与心等法若一若异。彼复差别有二十四种。谓得无想定。灭尽定。无想天。命根。众同分。生。老。住。无常。名身。句身。文身。异生性流转。定异。相应。次第。势速。时。方。数。和合。不和合。复有诸余如是种类差别。应知。得者。此复三种。一诸行种子所摄相续差别性。二自在生起相续差别性。三自相生起相续差别性。无想定者。谓已离遍净欲。未离上地欲。观想如病如痈如箭。唯无想天寂静微妙。由于无想天起出离想。作意前方便故。不恒现行心心法灭性。灭尽定者。谓已离无所有处欲。或入非想非非想处定。或复上进。或入无想定。或复上进由起暂息想作意前方便故。止息所缘。不恒现行诸心心法。及恒行一分诸心心法灭性。无想天者。谓先于此间得无想定。由此后生无想有情天处。不恒现行诸心心法灭性。命根者。谓先业所引异熟六处住时决定性。众同分者。谓诸有情互相似性。异生性者。此有二种。一愚夫异生性。二无闻异生性。愚夫异生性者。谓无始世来有情身中愚夫之性。无闻异生性者。谓如来法外诸邪道性。生者。谓诸行自相发起性。老者。谓诸行前后变异性。住者。谓诸行生时相续不断性。无常者。谓诸行自相生后灭坏性。名身者。谓诠诸行等法自体想号假立性。句身者。谓聚集诸名显染净义言说所依性。文身者。谓前二所依字性。流转者。谓诸行因果相续不断性。定异者。谓诸行因果各异性。相应者。谓诸行因果相称性。势速者。谓诸行流转迅疾性。次第者。谓诸行一一次第流转性。时者。谓诸行展转新新生灭性。方者。谓诸色行遍分齐性。数者。谓诸行等各别相续体相流转性。和合者。谓诸行缘会性。不和合者。谓诸行缘乖性

无为者。此有八种。谓虚空。非择灭。择灭不动。想受灭。善法真如。不善法真如。无记法真如。虚空者。谓诸心心法所缘外色对治境界性。非择灭者。谓因缘不会于其中间诸行不起灭而非离系性。择灭者。谓由慧方便有漏诸行毕竟不起灭而是离系性。不动者。谓离遍净欲得第四静虑。于其中间苦乐离系性。想受灭者。谓离无所有处欲入灭尽定于其中间不恒现行心心法及恒行一分心心法灭而离系性。善不善无记法真如者。谓于善不善无记法中清净境界性

复次如是五法复有三相应知。一增益相。二增益所起相。三法性相。增益相者。谓诸法中遍计所执自性。增益所起相者。谓诸法中如其所应依他起自性。法性相者。谓诸法中圆成实自性。如是已说。一切界今当说颂曰

  界谓欲色等　　及与三千界

论曰。界有二种。一欲等三界。二三千世界。欲等三界者。一欲界。谓未离欲地杂众烦恼诸蕴差别。二色界。谓已离欲地杂众烦恼诸蕴差别。三无色界。谓离色欲地杂众烦恼诸蕴差别。如是三界复有五种差别应知。一相差别。二粗重差别。三方处差别。四受用差别。五任持差别。相差别者。谓欲界中色多相不鲜净相种种杂相。色界中色少相鲜净相非种种杂相。无色界中虽无业。所生色而有定所生色无见无对。又欲界中有苦受相应相。嗔恚相应相。多随烦恼相应相。色无色界中有苦受不相应相。嗔恚不相应相。少随烦恼相应相。粗重差别者。谓欲界中粗重粗而损害。色无色界中粗重细而不损害。方处差别者。谓欲界居下方。色界居上方。无色界无方处。受用差别者。谓欲界受用外门境界。色无色界受用内门境界。任持差别者。谓欲廛诸蕴依四食住。色无色廛诸蕴依三食住。三千世界者。一小千世界。二中千世界。三大千世界。谓一日月之所照临。名一世界。如是千世界中。有千日月千苏迷卢山王千南赡部洲千东毗提诃洲千西瞿陀尼洲千北拘卢洲千四大王众天千三十三天千夜摩天千睹史多天千乐变化天千他化自在天千梵世天。合名第一小千世界。复千小千世界名为第二中千世界。复千中千世界名为第三大千世界。问何因缘故。小千世界名为卑小。答犹如特牛断去两角。以缺减故名为卑小。如是梵世已下。其中所有千世界不如上地。故名卑小。如是三千世界三灾所坏。谓火水风。灾复有三种。三灾之顶。谓第二第三第四静虑。彼第四静虑诸天法尔与所居宫俱起俱灭。复有中三劫起。所谓饥馑疫病刀兵。二十中劫世间正坏。二十中劫坏已而住。二十中劫世间正成。二十中劫成已而住。如是合有八十中劫。名为大劫。譬如天雨[泳-永+適]犹车轴。无有间断从空而注。如是东方无边世界无有间断。或成或坏。或有正坏或坏已住。或有正成或成已住。如是乃至十方世界如是已说。界杂染今当说颂曰

  烦恼业生性　　杂染相应知

论曰。杂染性有三种。一烦恼杂染。二业杂染。三生杂染。烦恼杂染者。谓一切烦恼及随烦恼。合名烦恼杂染。烦恼者略有十种。一萨迦耶见。二边执见。三邪见。四见取。五戒禁取。六贪。七嗔。八无明。九慢。十疑。或复二种。一见所断。二修所断。或复三种。一欲界系。二色界系。三无色界系。复有七种颠倒行。一邪解行。二不解行。三非解非不解行。四执邪解行五彼因依处行。六彼怖生行。七任运起行。邪解行者。所谓萨迦耶见边执见邪见。于所知事起邪执故。不解行者。所谓无明非解。非不解行者。所谓疑也。执邪解行者。所谓见取戒禁取。及于诸见所起贪等。彼因依处行者。谓见苦集所断。彼怖生行者。谓见灭道所断。任运起行者。谓修所断见所断。见所断有百一十二烦恼。修所断有十六烦恼。如是见修所断。合有一百二十八烦恼。如是烦恼杂染。种种义差别故。立种种名。所谓结缚随眠随烦恼缠暴流轭取系盖株杌垢烧害箭所有恶行漏匮热恼斗诤炽然火稠林拘碍。如是等义名差别

业杂染者。谓或因烦恼所生。或因烦恼缘助善法所生。如其所应三界所摄。身业语业意业。此复二种。一思二思所起。此业差别复有多种。欲界所摄名福非福。色无色界所摄名为不动。复有引业。谓作及增长能引种种有情世间及器世间果及异熟。复有生业。谓前所引助令生故

生杂染者。谓因烦恼及业故生因生故苦。苦复多种。谓胎藏所迫苦。老病死苦。怨憎会苦。爱别离苦。求不得苦。与粗重行俱生长苦。数死生苦。生诸难苦。是名为生

显扬圣教论卷第一显扬圣教论卷第二

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄事品第一之二

如是已说杂染谛今当说颂曰

  诸谛有六种

论曰。谛有六种。一世俗谛。二胜义谛。三苦谛。四集谛。五灭谛。六道谛。世俗谛者。谓名句文身。及依彼义一切言说。及依言说所解了义。又曾得世间心及心法。及彼所行境义

胜义谛者。谓圣智及彼所行境义。及彼相应心心法等

苦谛者。此有二种。一世俗谛所摄。二胜义谛所摄。世俗谛所摄者。如经中说。生苦老苦病苦死苦怨憎会苦爱别离苦求不得苦。胜义谛所摄者。如经中说。略摄一切五取蕴苦

集谛者。此有四种。一全摄。二胜摄。三世俗谛摄。四胜义谛摄。全摄者。谓一切三界烦恼及业。皆名集谛。胜摄者。谓缘已得未得自体及境所起爱后有爱喜俱行爱处处喜爱。皆名集谛。世俗谛摄者。若因能感世俗谛所摄苦谛。胜义谛摄者。若因能感胜义谛所摄苦谛。灭谛者。亦有四种如前所说。全摄者。谓全摄集谛无余断弃。吐尽离欲灭没寂静。胜摄者。谓胜摄集谛无余断弃。如是广说。世俗谛摄者。谓于世俗谛所摄集谛无余断弃。如是广说。胜义谛摄者。谓于胜义谛所摄集谛无余断弃。如是广说

道谛者。亦有四种。如前所说。全摄者。谓一切觉分。胜摄者。谓八圣道支。世俗谛摄者。谓于世俗谛所摄苦谛集谛灭谛。为遍知故。为永断故。为作证故。一切圣道胜义谛摄者。谓于胜义谛所摄苦谛集谛灭谛。为遍知故。如是广说

苦集灭道圣谛义者。若于此处圣智所行。此处苦集灭道。是谛由诸圣者。咸谓此是谛。是故说名圣谛。如是已说谛。依止今当说。颂曰

  依止八与二

论曰。依止有八种。何等为八。谓四静虑及四无色。复有二种。何等为二。谓初静虑有二种。世及出世。乃至无所有处有二种。世及出世。非想非非想处唯是世间

世间初静虑者。谓或缘离欲界欲增上教法。或缘离彼增上教授为境界。已由世间道作意观察炽然修习等故而得转依。然不深入所知义故。不能永害随眠。自地烦恼之所依处。是退还法。自地三摩地心及心法之所依止。如世间初静虑。如是乃至世间非想非非想处。各缘离下地欲增上教法。广说如前。出世间初静虑者。谓先以如是行如是状如是相。作意入初静虑。今不以如是行如是状如是相作意。然或于色受想行识所摄诸法。思惟如病如痈如箭。障碍无常苦空无我。或复思惟苦是苦集是集灭是灭道是道。或复思惟真如法性实际。如是于诸法中。思惟如病乃至实际。已于如是法心生厌怖。生厌怖已。于不死界摄心而住。或于真如法性实际摄心而住。此处无分别智。及彼相应心及心法。及彼所依止转依。由深入所知义故。则能永害随眠。非一切烦恼之所依处。不退转法。如是名为出世间初静虑乃至无所有处。应当广说。于诸静虑及与无色。复有四种应知。一杂染。二洁白。三建立。四清净。杂染者谓于上静虑起深爱味见慢及疑。爱味者。谓有十种。一俱生作意爱味。二分别所起作意爱味。三自地作意爱味。四异地作意爱味。五过去爱味。六未来爱味。七现在爱味。八下爱味。九中爱味。十上爱味

洁白者。谓净及无漏。净者复有三种。一引发故。二上练故。三除垢所摄堪任故。无漏者。此亦三种。一出世间无漏。二此等流无漏。三离系无漏

建立者。此复四种。一建立近分。二建立根本。三建立定。四建立生

建立近分及根本者。如经中说。所谓此身离生喜乐之所滋润。遍滋润遍适悦遍流布者。是谓初静虑近分。如经又说。即此身中一切处无有少分离生喜乐所不遍满者。是谓初静虑根本

如经中说。即于此身等持所生喜乐之所滋润。遍滋润遍适悦遍流布者。是谓第二静虑近分。如经又说。即此身中一切处。无有少分等持所生喜乐所不遍满者。是谓第二静虑根本。如经中说。即于此身离喜之乐之所滋润。遍滋润遍适悦遍流布者。是谓第三静虑近分。如经又说。即此身中一切处。无有少分离喜之乐所不遍满者。是谓第三静虑根本。如经中说。即于此身清净心及洁白心意解遍满具足住者。是谓第四静虑近分。如经又说即此身中一切处无有少分清净心及洁白心所不遍满者。是谓第四静虑根本

如经中说。一切色想出过故。一切有对想灭没故。一切种想不作意故。入无边虚空虚空无边处者。是谓虚空无边处近分。如经又说。具足住者。是谓虚空无边处根本

如经中说。出过一切虚空无边处。入无边识识无边处者。是谓识无边处近分。如经又说。具足住者。是谓识无边处根本

如经中说。超过一切识无边处。入无少所有无所有处者。是谓无所有处近分。如经又说。具足住者。是谓无所有处根本

如经中说。超过一切无所有处。入非有想非无想非想非非想处者。是谓非想非非想处近分。如经又说。具足住者。是谓非想非非想处根本

建立定者。如经中说。离欲恶不善法故。有寻有伺离生喜乐。初静虑具足住。离欲者。谓或缘离欲界欲增上教法。或缘彼教授为境界已。断欲界烦恼杂染。离恶不善法者。谓断欲界业。杂染法能堕恶趣故。名为恶。能障于善故名不善。寻者谓能对治二种杂染。出离寻无恚寻无害寻。伺者谓能对治二种杂染。出离伺无恚伺无害伺。离者谓由修习对治断所治障所得转依。生者谓从此所生。喜者谓已转依者依于转识心悦心勇心适心调安适受受所摄。乐者谓已转依者依阿赖耶识能摄所依。令身怡悦安适受受所摄。初者谓次第定中。此数最先故。静虑者谓已断欲界杂染之法寻伺喜乐所依。依于转依心住一境性。具足者谓修习。圆满住者。谓于入住出随意自在

又如经说。寻伺寂静故。内等净故。心定一趣故。无寻无伺三摩地生喜乐。第二静虑具足住。寻伺寂静者。谓或缘离初静虑欲增上教法。或缘彼教授为境界已。初静虑地寻伺寂静。不复现行。内等净者。谓为对治寻伺故摄念正知。于自内体其心舍住。远离寻伺尘浊法故名内等净。心定一趣者。谓如是入时多相续住。诸寻伺法恒不现行。无寻无伺者。谓证得寻伺断法。三摩地者。谓已转依者。心住一境性生者。谓从三摩地所生喜及乐。已如前说。第二静虑者。谓寻伺寂静内体遍净。三摩地所生喜乐所依。依于转依心住一境性。余如前说

又如经说。由离喜故住舍念正知及乐身正受。圣者宣说成就舍念乐住。第三静虑具足住。离喜者。谓或缘离第二静虑欲增上教法。或缘彼教授为境界已。见第二静虑喜相过失。住舍者。谓于已生喜想及作意。不忍可故。有厌离故。不染污住心。平等心。正直心。无转动而安住性。念者谓于已观察喜不行相中。不忘明了令喜决定不复现行。正知者。谓或时失念喜复现行。于现行喜相分别正知。乐者谓已转依者。离喜离勇安适受受所摄。身者谓已转依者。若转识。若阿赖耶识。心性无别总名为身。正受者谓已转依者。能摄受身令身怡悦。总集说为乐。身正受此处乐受深极寂静。最胜微妙。上下所无。圣者者。谓佛及佛弟子。宣说者。谓显示施设。成就舍念乐住者。谓此地已上无妙乐故。下地亦无。如是胜乐及无舍念以为对治。第三静虑者。谓离喜已舍念正知乐所依止。依于转依心住一境性。余如前说

又如经说。由断乐故。及先已断苦喜忧故。不苦不乐舍念清净。第四静虑具足住。断乐者。谓入第四静虑时。先已断苦者。谓入第二静虑时。先已断喜者。谓入第三静虑时。先已断忧者。谓入初静虑时。不苦不乐者。谓已转依者。非安适非不安适。受受所摄色界最极增上寂静。最胜摄受无有动摇舍清净者。谓超过寻伺喜乐三地一切动故。心平等性心正直性。心无转动而安住性。念清净者。谓超过寻伺喜乐三地一切动故。心不忘失而明了性。第四者。由次第定中第四数故。静虑者。谓乐断故。不苦不乐舍念清净之所依止。依于转依心住一境性。余如前说

又如经说。一切色想出过故。有对想灭没故。种种想不作意故。入无边虚空虚空无边处。具足住一切者。谓诸行相。色想者。谓显色想。出过者。谓离彼欲故。如出过义。有对想灭没种种想不作意。如是应知。有对想者。谓彼所依四大想。及余所造色想。种种想者。谓即于四大及造色中长短粗细方圆高下。正及不正光影明闇。如是等类假色所摄种种想。若正入无边虚空处时。有对之想不现前故。灭及种种想不起作意。由如是故超彼能依一切色想。无边者。谓十方诸相不可分别。虚空者。谓色对治所缘境界。虚空无边处者。谓此处转依及能依定。余如前说

又如经说。超过一切虚空无边处。入无边识。识无边处。具足住。超过一切虚空无边处者。谓超过近分及与根本。无边识者。谓缘无边虚空之识。今缘此为境界。识无边处者。谓此处转依及能依定。余如前说

又如经说超过一切。识无边处。入无少所有无所有处具足住。超过一切识无边处者。谓超过近分及与根本。无少所有者。谓于识处上境界推求之时无少所得。除无所有无别境界。由唯见此境极寂静故无所有处者。谓此处转依及能依定。余如前说

又如经说。超过一切无所有处。入非有想非无想非想非非想处具足住。超过一切无所有处者。谓超过近分及与根本。非有想者。谓超过无所有想。非无想者。谓于无所有处上境界推求之时。唯得缘无所有极细心及心法。由唯见此境极寂静故。非想非非想处者。谓此处转依及能依定。余如前说

建立生者。谓先于此间修下中上。初静虑者。后生彼处受三天果。谓梵身天。梵辅天。大梵天。若善修习无寻有伺初静虑者。生大梵天果。更无异所胜彼处故。若先于此间修下中上第二静虑者。后生彼处受三天果。谓少光天。无量光天。极净光天。若先于此间修下中上第三静虑若。后生彼处受三天果。谓少净天。无量净天。遍净天。若先于此间修下中上第四静虑者。后生彼处受三天果。谓无云天。福生天。广果天。从是已上离色贪故。无方处差别。虽有修习下中上因。然不建立生果差别。若下中上修虚空无边处者。受虚空无边处天生果。若下中上修识无边处者。受识无边处天生果。若下中上修无所有处者。受无所有处天生果。若下中上修非想非非想处者。受非想非非想处天生果。由定寂静有差别故。及由住时满不满故。彼有差别。又由多住爱味初静虑乃至非想非非想处故。不尽寿命而有中夭。若杂修下品世间及无漏第四静虑者。受无烦净宫天生果。若杂修中品者。受无热净宫天生果。若杂修上品者。受妙现净宫天生果。若杂修上胜品者。受妙见净宫天生果。若杂修上极品者。受无碍究竟净宫天生果。若善修习菩萨无量不思议三摩地所引第十地中第四静虑者。受出过净宫大自在天生果。清净者。谓边际初静虑。依此引生一切胜德及速疾神通。如初静虑清净之相。余静虑及诸无色。应如是知。此中无色差别者。谓发彼地解脱等功德。如是彼诸静虑及无色定杂染洁白建立清净差别。应知如是。已说依止。觉分今当说。颂曰

  觉分有众多　　最初三十七

论曰。菩提分法品类多种。最初胜者有三十七。谓四念住等。广说如经

四念住者。一身念住。谓或缘于身。或复缘身增上教法。或缘彼教授为境界已。由闻思修之所生慧。或唯影像或事成就。于身境处善安住念。为令于身得离系故。如于身念住。如是于受心法念住应知亦尔。此中差别者。谓各于自境如其所应。乃至为令于法得离系故。又一切处应说。与念相应心及心法。如是发起观察心时。所缘之境有四种事。一心所执事。二心领纳事。三心了别事。四心染净事。四正断者广说如经。一已生恶不善法。为令断故。生欲策励发起正勤策心持心。已生者。谓粗缠所摄。恶不善法者。谓能起恶行欲界烦恼及随烦恼。恶不善义已如前说。为令断故者。谓修彼对治令微薄故。生欲者。谓起证断乐。欲策励者。谓不忍受恶及归趣断故。发起正勤者。谓多种坚固修彼对治。此上三句显不定地中闻思两慧下品对治。策心者。谓修彼对治修慧现行。若心沉没烦恼染污。策心令举故。持心者。谓即此对治现行之时。若心浮举烦恼染污。持心令下故。二未生恶不善法为不生故。乃至广说。未生者。谓增盛随眠所摄。能起粗缠之因。为不生故者。谓令粗缠不现行故。生欲者。谓起为证不现行。欲策励者。谓由不忘住为令不现行。善住念故。发起正勤策心持心皆如前说。三未生善法为令生故。乃至广说。未生者。谓所未得。善法者。谓闻思修所生三慧。由无过义故名为善。为令生故者。谓令彼得故生。欲者。谓起证得。欲策励者。谓求彼摄受正方便故。发起正勤者。谓长时殷重多坚修习。此上三句显得不定地对治。恶不善法闻思两慧所摄善法。策心持心者。谓为得修慧故。余如前说。四已生善法令住。令不忘令修满令倍修令增长令广大。生欲策励乃至广说。已生者。谓已得故令住者谓闻慧。令不忘者。谓思慧。令修满者。谓修慧。此上三句显唯守护已所得善。令倍修令增长令广大者。如其次第不唯于彼生知足故。生欲者。谓起证得欲。余如前说

四神足者。广说如经。一欲增上故得三摩地。如有行者先世修习上品善根。于大师所或于有智同梵行处。生信生欲听闻正法。如所信欲闻正法已。展转证得心住一境性。由此欲故三摩地成就。已生未生恶不善法令断令不起故。生欲乃至持心。若未生。彼对治善法令其生故。若已生者。令住令不忘令修满令倍修令增长令广大故。生欲乃至持心。如是行者。复修欲策励信安正念正知思舍八种断行。由此欲故三摩地成就者。谓于此中而得自在。已生未生恶不善法者。谓彼下品诸缠所摄及彼微薄。未损未害随眠所摄。令断令不起者。谓为离已生软品缠故。及为损害微薄随眠故。生欲乃至持心。如前广说。若未生。彼对治善法令其生故。若已生者。令住令不忘令修满令倍修令增长令广大故。生欲乃至持心。如前广说应知。如是行者者。谓如是修行多时住者。复修欲者。谓欲证彼不现行及损害故。策励者。谓欲为因于奢摩他毗钵舍那发起正勤故。信者。谓生欲之因于彼损害及所得中。决定信故。安者。谓因策励除身心粗重令身心堪任故。正念者。谓于防护沉下浮举随烦恼中。令心不忘故。正知者。谓或时失念。随烦恼现行之时。分别正知故。思者。谓于止举中。造作心故。舍者。谓于不染住心平等心正直心无转动性。如是一切诸神足中。八种断行应知。此中差别者。第二勤增上故得三摩地。如有行者依于教授及教诫法。或在空闲或居林树或止静室。于如是处长时勇猛纯熟炽然正勤。证得心住一境性。由正勤故三摩地成就。余如前说。第三心增上故得三摩地。如有行者先已修习奢摩他行。由此因缘思惟内法。速疾证得心住一境性。由修心故三摩地成就。余如前说。第四观增上故得三摩地。如有行者多闻闻持其闻积集独处闲静。即于彼法以慧简择。极细简择遍觉观察。因此证得心住一境性。由观察故三摩地成就。余如前说

五根者。广说如经。一信根。由世间道令心清净鲜白无秽。离随烦恼得住不动。从是已后求谛现观修习方便。为永断随眠故。为得彼对治故。起增上信。二正勤根。谓依信根增进勇猛与信俱行。三念根。谓依正勤明了不忘与彼俱行。四等持根。谓依念根心住一境与彼俱行。五慧根。谓依等持根简择诸法与彼俱行

五力者。广说如经。即信根等由善修习多修习故。不复为彼不信等法之所杂乱。复能对治诸杂乱法。不可伏义说名为力

七遍觉支者。广说如经。一念遍觉支。谓由世间道得备善力见道现前。由先修习世间念遍觉支。引得出世无功用无分别。于谛明了于谛不忘。二择法遍觉支谓由先所引无功用无分别依止。于念与念俱行于谛解了于谛觉悟。如是一切诸遍觉支由先所引无功用无分别。后依止前与彼俱行。皆应了知。是中差别者。第三正勤遍觉支于谛心勇。第四喜遍觉支。于谛心悦。第五安遍觉支。于真谛中身心堪任。第六三摩地遍觉支。于真谛中心住一境。第七舍遍觉支。于真谛心平等心正直心无转动性

又如经说。即于是中复善修习寂静依止。乃至广说。寂静依止者。谓欲界寂静依故。离欲依止者。谓色无色界离欲依故。灭依止者。谓已得蕴界处无余永断依故。趣向弃舍者。谓未来蕴界处不相续故

八圣道支者。广说如经。一正见。谓于见道中得遍觉支时见清净。及于修道中安立后得遍觉支见清净。总合此二名为正见。二正思惟。谓依正见与彼俱行。离欲思惟。无恚思惟。无害思惟。于修道中相续作意思惟诸谛。与无漏作意相应。令心趣入极趣入。寻求极寻求。现前寻求觉了计算。观察思惟思惟性三正语。谓于修道中依正思惟。由相续无漏作意思惟诸谛故。得四种语业。圣爱戒所摄。不乐离乐除灭种种离。澄净防护不作离作。不行不毁不犯。桥梁船筏。远离不违越不种种违越性。四正业。谓于修道中。由相续无漏作意思惟诸谛故。得三种身业圣爱戒所摄不乐离乐除灭种种离。广说如前。五正命。谓于修道中乃至思惟诸谛故。远离所作邪命恶法圣爱戒所摄。广说如前。六正策励谓于修道中乃至思惟诸谛故。于所修习念住正断神足根力之中。欲乐正勤策励勇猛堪任难制心正奋发相续精进性。七正念。谓于修道中乃至思惟诸谛故。或依奢摩他道。或依毗钵舍那道。或依双道。于所修习择法正勤喜安等持舍遍觉支中。念及正念随念诸念不忘念心明了性。及不忘失极不忘失极不忘失诸法性。八正等持。谓于修道中乃至思惟诸谛故。又依三道。于所修中正念摄故。心住安住近住等住不乱不散正摄持奢摩他心住一境性。此诸道支后依于前相应俱起应知。复次颂曰

  智与解脱门　　行迹及止观

论曰。智者谓十种智。广说如经。一法智。谓于共了现见所知诸义境界无漏之智。二种类智。谓于不共了不现见所知义境无漏之智。三他心智。谓修所生修果能知他心及心法智及诸如来。知诸众生随其意解随其随眠教授教诫转起妙智。四世俗智。谓世间慧由依此故。如来为诸众生随其意解随其随眠宣说妙法。五苦智。谓于有漏诸行之中。无常苦空离我思惟。若智若见明了觉悟慧观察性。六集智。谓于有漏诸行因中。因集生缘思惟。若智若见。余如前说。七灭智。谓于有漏诸行灭中。灭静妙离思惟。若智若见。余如前说。八道智。谓于能断有漏诸行无漏道中。道如行出思惟。若智若见。余如前说。九尽智。谓苦已知集已断灭已证道已修。或缘尽境或复为尽。若智若见。余如前说。十无生智。谓苦已知不复当知。集已断不复当断灭已证不复当证。道已修不复当修。或缘无生境或为无生。若智若见。余如前说

解脱门者。谓三解脱门。一空解脱门。二无相解脱门。三无愿解脱门。空有二种。一所知。二智。所知者。谓于众生遍计性所执法中。及法遍计性所执法中。此二遍计性俱离无性及彼所余无我有性。于诸法中遍计性无。即是无我性有。于诸法中无我性有。即是遍计性无。即于此中有及非有无二之性无分别境。智者。谓缘彼境如实了知。无相亦有二种一所知。二智。所知者。谓即所知空境。由此境相一切诸相之所不行。智者。谓如前说。无愿亦有二种。一所知。二智。所知者。谓由无智故颠倒所起诸行相貌。智者。谓缘彼境厌恶了知。空行者。谓于诸行我不可得。及诸相中世俗分别法不可得。无相行者。谓即于诸行中众生无我性可得。及诸相中世俗分别法无我性可得。及于灭中灭静妙离行。无愿行者。谓无常苦不净如病如痈如箭。因集生缘行缘智空道作道如行出行。此亦是空行。缘智无相道作道如行出行。此亦是无相行。缘智无愿道作道如行出行。此亦是无愿行。若无差别总名空无相无愿者。此通闻思修所生之慧世及出世应知。若名空无相无愿三摩地者。唯是修所生慧通世出世应知。若名空无相无愿解脱门者。此唯出世应知

行者谓四种行。广说如经。一苦迟通。谓钝根者。未得现法乐住为尽诸漏若道若行。二苦速通。谓利根者。余如前说。三乐迟通。谓钝根者。已得现法乐住为尽诸漏若道若行。四乐速通。谓利根者。余如前说

迹者谓四法迹。广说如经。一无贪迹。谓能持尸罗蕴法义。故名迹。若未受者令进受。若已受者令守护令增长令广大。如无贪第二无嗔亦尔。三正念迹。谓能持三摩地蕴法义。故名迹。未生者令生。已生者令增广。四正等持迹。谓能持慧蕴解脱解脱智见蕴法义。故名迹。若未生未证者令生令证。若已生已证者令增令广

止者。谓于如所闻思法中正修行时。由缘三摩地影像境作意故。得安三摩地故。住心于内

观者。谓于如所闻思法中正修行时。由缘三摩地影像境作意故。得安三摩地故。简择诸法复次颂曰

  居处及所依　　发心与悲愍
  诸行通达性　　地波罗蜜多

论曰。居处者。谓四居处。广说如经。一慧居处。谓谛观方便世间之慧为安立。证谛出世智义故。二谛居处谓已得谛观出世慧为安立。有事颠倒断义故。三舍居处。谓有事颠倒断为安立。无余烦恼息灭义故。四寂静居处。谓无余烦恼寂静为安立。一切苦不生义故。所依者。谓四种依。广说如经。一依法不依众生。谓若法是如来所说或弟子说十二分教随学随转。不随众生所行行学亦不随转。二依义不依文。谓若法非饰词者。所造绮文字句。唯能显了独满清净鲜白梵行。于此法中恭敬信解。非于能显颠倒梵行。及不显了梵行。但饰词者。所造绮文字句。三依了义经不依不了义经。谓于如来所说相似甚深空性相应随顺诸缘缘起法中不妄执着。如言浅义亦不住自内见取心。唯勤寻究显了义经。四依智不依识。谓不唯听闻而生知足。便不进修法随法行。然为尽诸漏勤求自内证真谛智

发心者。谓诸菩萨发菩提心。若诸菩萨住菩萨法性。为欲利益十方世界所有有情。依彼行相强胜因缘。于阿耨多罗三藐三菩提发大誓愿。受发心法。谓我必定当证阿耨多罗三藐三菩提。为度十方一切有情令离诸烦恼故。及离诸苦难故。此受发心复有二种。一世俗发心。二证法性发心。世俗发心者。谓如有一随智者前恭敬而住。起增上意发誓愿言。长老忆念。或言圣者忆念。或言邬波拖耶。我如是名。从今日始发阿耨多罗三藐三菩提心。为欲饶益诸有情故。从今已往凡我所修布施持戒忍辱正勤静虑及慧。一切皆为证得阿耨多罗三藐三菩提故。我今与诸菩萨摩诃萨和合出家。愿尊证知。我是菩萨。第二第三亦复如是。证法性发心者。谓如有一已过第一劫阿僧企耶。已证菩萨初极喜地。已入菩萨定无生位。已如实知无上菩提及菩提方便。已悟自身将近等近大菩提果。证解自他悉平等故得大我意。已至不住流转寂灭菩萨道故。得广大意。由如是故。于大菩提愿不退转。是谓证法性发心

悲愍者。谓如是已发心菩萨。于十方世界。或三种退堕苦有情。或五趣定苦有情。或四种极苦有情。或六种重苦苦有情。或三种相苦苦有情。诸如是所令离苦。行不害为性

诸行者。谓十种法行。广说如经。一于菩萨藏法若多若少尊重恭敬书持法行。二若劣若胜诸供养具供养法行。三若自书已由矜愍心施他法行。四若他发意恭敬尊重以微妙声宣扬阐读由宗仰故谛听法行。五发净信解恭敬重心披读法行。六为欲修习法随法行从师受已讽诵法行。七既讽诵已为坚持故以广妙音温习法行。八悲愍他故传授与彼随其广略开演法行。九独处闲静极善研寻称理观察思惟法行。十如所思惟修行奢摩他毗钵舍那为欲趣入乃至为令诸所求义成就法行

显扬圣教论卷第二显扬圣教论卷第三

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄事品第一之三

通达者。谓七种通达。广说如经。一字通达。谓于三十二字无分别故。所行相义如实觉了。先已于心增上法行善修治故。二字相通达。谓于师子之形诸字相等有分别故。所行相义如实觉了。余如前说。三能取通达。谓于所缘相应心法。唯了别相如实觉了。余如前说。四所取通达。谓于一切诸识境界。唯识影相如实觉了。余如前说。五系缚通达。谓于相缚及粗重缚如实觉了。余如前说。六解脱通达。谓于相缚解脱及粗重缚解脱如实觉了。余如前说。七法性通达。谓于系缚解脱无始世来诸行缘起。及彼寂灭真如法性。如实觉了。先已于心增上法行善修治故

地者。谓菩萨十地。广说如经。一极喜地。谓诸菩萨住此地中。先已于心增上法行善修治故。超过一切声闻独觉现观。得诸菩萨现观。由正证得无上现观故。诸大菩萨于此地中住增上喜。是故此地名为极喜。二离垢地。谓诸菩萨住此地中。先善修治初地行故。超过一切声闻独觉地。证得极净妙尸罗蕴。对治一切微犯戒垢。是故此地名为离垢。三发光地。谓诸菩萨住此地中。先善修治第二地故。超过一切声闻独觉地。证得极净三摩地蕴。大智光明之所依止。是故此地名为发光。四焰慧地。谓诸菩萨住此地中。先善修治第三地故。超过一切声闻独觉地。证得极净缘诸觉分。能取法境微妙慧蕴。能现前烧一切烦恼。是故此地名为焰慧。五极难胜地。谓诸菩萨住此地中。先善修治第四地故。超过一切声闻独觉地。证得极净缘谛所知诸法微妙慧蕴。成极难成不住流转寂灭圣道。是故此地名极难胜。六现前地。谓诸菩萨住此地中。先善修治第五地故。超过一切声闻独觉地。证得极净缘智非智二种所作诸行流转止息法境微妙慧蕴。多分有相任运相续妙智现前。是故此地名为现前。七远行地。谓诸菩萨住此地中。先善修治第六地故。超过一切声闻独觉地。证得极净微妙解脱解脱智见蕴。由已远入一切现行诸相解脱。是故此地名为远行。八不动地。谓诸菩萨住此地中。先善修治第七地故。超过一切声闻独觉地。证得极净微妙解脱解脱智见蕴。解脱一切相自在障故。得无功用任运相续道之所依止。是故此地名为不动。九善慧地。谓诸菩萨住此地中。先善修治第八地故。超过一切声闻独觉地。证得极净微妙解脱解脱智见蕴。解脱一切无碍辩障。无过广慧之所依止。是故此地名为善慧。十法云地。谓诸菩萨住此地中。先善修治第九地故。超过一切声闻独觉地。证得极净微妙解脱解脱智见蕴。解脱发起大神通智障。如云法身圆满所依。是故此地名为法云

波罗蜜多者。谓十波罗蜜多。广说如经。一施波罗蜜多。谓依菩提心悲为导首。十种法行助善修治。七种通达为坚固根。或因资财或因正法或因无畏。五种功德大我所摄性。一无著故舍。二不观故舍。三无失故舍。四无分别故舍。五回向故舍。由此行故。而诸菩萨以资生具摄诸有情。及由亲近多修习故。令彼资粮圆满当成无上正遍知果。如施波罗蜜多。如是戒乃至慧应知。此中差别者。第二戒波罗蜜多。谓或因息离不善。或因摄受善法。或因利益有情律仪戒所摄身语意业性。由此行故。诸菩萨以不恚不恼摄诸有情。第三忍波罗蜜多。谓或因忍受他不饶益不恚性。或因安受诸苦不乱性。或因审察诸法正慧性。由此行故。诸菩萨以忍受一切不饶益事及损害事摄诸有情。第四勤波罗蜜多。谓或因被发心铠。或因方便加行。或因利益有情相续纯熟心勇猛性。为欲引生一切善根。由此行故。而诸菩萨虽未伏惑而能一向专修诸善。第五静虑波罗蜜多。谓或因对治烦恼。或因发起功德。或因利益有情心住一缘性。由此行故。而诸菩萨伏诸烦恼令住不现行法。第六慧波罗蜜多。谓或因对治烦恼。或因发起功德。或因利益有情简择诸法性。由此行故。而诸菩萨永断一切烦恼障所知障种子。第七善巧方便波罗蜜多。谓诸菩萨以此方便。或由随顺。或由违逆。或由不同意乐。或由作恩报恩。或由威逼。或由清净。以三种利益摄诸有情。于种种善处令受令调令安住令成立。第八愿波罗蜜多。谓诸菩萨中随有其一为性。懈怠烦恼多故。遂发正愿而修诸善。令我未来获得自性勇猛正勤烦恼微薄。由此因故。于余生中如所发求咸果其愿。于修善法得强盛力。第九力波罗蜜多。谓诸菩萨由于所修善法得强盛力。依此力故速疾发起静虑波罗蜜多。第十智波罗蜜多。谓诸菩萨于菩萨藏静虑波罗蜜多所摄法则智所引世间慧。依此慧故。而诸菩萨速能发起出世无分别不住流转寂灭道所摄慧波罗蜜多

如是十波罗蜜多。于一切地中皆具修习。若增上者。施波罗蜜多唯在初地。如其次第乃至智波罗蜜多在第十地应知。复次颂曰

  菩萨行摄事　　及彼陀罗尼
  三摩地等门　　诸无量作意

论曰。菩萨行者。谓四种菩萨行。广说如经。一到彼岸行。谓十波罗蜜多总摄说为到彼岸行。皆是大乘出离义故。二遍觉分行。谓三十七菩提分法总摄说为遍觉分行。如实觉了一切所知义故。三神通行。谓六神通总摄说为神通行。皆为引摄所化有情界。令生恭敬入圣教义故。四成熟有情行。谓四摄事总摄说为成熟有情行。若已入圣教所化有情界。以财法二种摄受义故。此中财摄者。谓助摄受。方便令成熟故。法摄者。谓正摄受。转及随转方便令成熟故。如是四摄事依五种摄行说为摄事。五摄行者。一令附已摄。二令受善摄。三令起善正勤摄。四令善成熟摄。五令善解脱摄。摄事者。谓四摄事广说如经。若安立彼如安立成熟有情行。应知

陀罗尼门者。谓诸菩萨无量陀罗尼门。广说如经。若欲略说陀罗尼相者。谓诸菩萨成就字类通达于名句文身如意自在。得如是种类念持之力。由念力故随一字中而能显示。分别开演一切种染净之义。是故说名陀罗尼门

三摩地门者。谓诸菩萨无量三摩地门。广说如经。若欲略说复有八种。谓初静虑乃至非想非非想处。诸菩萨摩诃萨依此一一三摩地门出生无量三摩地。诸声闻独觉不达其名。此诸三摩地悉能建立十方世界一切三摩地所作之事。是故说名三摩地门。无量作意者。谓五无量作意。广说如经。一有情无量作意。谓诸菩萨以增上法行所善修治微妙作意。思惟十方无量世界所摄一切有情世间不可言说种种业报差别之相。或一足二足四足多足。或有色无色。或有想无想非有想非无想。或欲界色界无色界。或那洛迦傍生鬼趣人天。或卵生湿生胎生化生。既思惟已如实了知。如是有情转。如是有情还。如是染污。如是清净。如是邪行。如是正行。如是如是行差别故。如是如是诸异熟生。二世界无量作意。谓诸菩萨乃至思惟十方无量世界器世间相。既思惟已如实了知。此世界染此世界净。如实了知。皆如幻化。唯是虚妄分别影像。虚伪不实随相流转。或成或坏种种形貌差别建立。或胜或劣。或粗或细。或远或近。或复分析至于极微。或于广略。或于现化。或于变异。或于远近。或于隐显。如是等事而得自在如实了知。三法界无量作意。谓诸菩萨乃至思惟十方无量世界一切诸法自相共相。既思惟已如实了知。此法是色。此法非色如色非色。如是有见无见。有对无对。有漏无漏。有为无为。善不善无记。有过失无过失。欲系色系无色系。学无学非学非无学。见断修断无断。转法还法染法净法。流转法寂灭法异生法贤圣法声闻法独觉法如来法。如是等法如实了知。四所调伏无量作意。谓诸菩萨乃至思惟十方无量世界所化有情种种行种种性。或声闻种性。或独觉种性。或如来种性。诸如是等所调种性。既思惟已如实了知。所调伏者。此软根此中根此利根。此下劣胜解此广大胜解。此贪行贪阿世耶。此嗔行嗔阿世耶。此痴行痴阿世耶。此等分行等分阿世耶。此升进阿世耶。此不升进阿世耶。此微薄尘垢贤善阿世耶。此增盛随眠此微薄随眠此极细随眠。此羸损随眠此不羸损随眠。此全随眠此不全随眠。此广说方解此略闻即解。此摈遣所调伏此摄受所调伏。此软所调伏此粗所调伏此粗软俱调伏。此应舍置方乃调伏。如是等处如实了知。五调伏方便无量作意。谓诸菩萨乃至思惟十方无量世界所化有情调伏方便。既思惟已如实了知。此因说秘密之法方能调伏。此因说显了之法方能调伏。此因摄受方便此因折伏方便。此转方便此随转方便。此应随顺此应违逆。此因不同分阿世耶。此应作恩报恩。此应示威奋威。此因清净。此因示现奇特神变。此因示现奇特记别。此因示现奇特教诫。此因示现种种威势。此因善诱种种教授。此因粗相。此因软相。此因粗软俱相。此因舍置。此因略说法要能令调伏。此因广演法要方令谓伏。如是等方便如实了知。复次颂曰

  真如作意相　　信解不思议
  广大阿世耶　　应知诸自数

论曰。真如作意相者。谓缘七种遍满真如作意。广说如经。一流转真如作意。谓已见谛诸菩萨以增上法行善修治。作意于染净法时思惟诸行无始世来流转实性。既思惟已。离无因见及不平等因见。二实相真如作意。谓如前说。乃至于染净法因思惟诸法。众生无我性及法无我性。既思惟已。一切身见及思惟分别众相作意不复现行。三唯识真如作意。谓如前说。乃至于染净法所依。思惟诸法唯识之性。既思惟已如实了知。唯心染故众生染。唯心净故众生净。四安立真如作意。谓如前说。乃至于染污法体思惟苦谛。既思惟已。欲令知故为有情说。五邪行真如作意。谓如前说。乃至于染污法因思惟集谛。既思惟已。欲令断故为有情说。六清净真如作意。谓如前说。乃至于清净法体思惟灭谛。既思惟已。欲令证故为有情说。七正行真如作意。谓如前说。乃至于清净行思惟道谛。既思惟已。欲令修故为有情说

信解不思议者。谓诸菩萨于难思处已得信解。广说如经。若欲略说此信解相。谓于最极甚深所知之义。已入地诸菩萨及诸如来所行境界。及于诸佛菩萨最极广大威德。起淳直信此难思议非拟度境界。既了达已而生信解

广大阿世耶者。谓大我阿世耶及广普阿世耶。大我阿世耶者。谓诸菩萨由得自他平等解故。为诸有情皆得解脱。清净信欲。广普阿世耶者。谓诸菩萨于流转寂灭得无分别平等解故。为利有情二俱不住。清净信欲

应知。诸自数者。谓应知种种觉分自数。如是已说。觉分补特伽罗今当说。颂曰

  随信行等七　　复八种应知
  及极七返等　　退法等有六

论曰。补特伽罗当知多种。今最初释七种贤圣。谓随信行等七广说如经。一随信行。谓如有一性。是软根纯熟相续。自昔已来恒信解行。由此因缘今于诸谛随信解行趣向谛观。二随法行。谓如有一性是利根纯熟相续。自昔已来恒择法行。由此因缘今于诸谛随择法行趣向谛观。三信解。即随信行已见圣谛。四见至。即随法行已见圣谛。五身证。谓于八解脱身证具足住。未得诸漏无余尽灭。六慧解脱。谓已得诸漏无余尽灭。未得八解脱身证具足住。七俱解脱。谓已得诸漏无余尽灭。及于八解脱身证具足住。八种者谓预流果向等八。广说如经。一预流向。谓如有一纯熟相续。超过一切外异生地。入正性离生。若未证得初预流果终无中夭。二预流果。若随胜摄永断三结。若全摄者永断一切见所断惑。由此圣者已见谛故。最初证得逆流行果。三一来向。谓如有一或世间道。倍离欲界贪已。趣入正性离生。或预流果。为断欲界上中品惑。修对治行。四一来果。或倍离欲已。入正性离生。然后证得。或预流果。进断欲界上中品惑故得。即依此断。说名微薄欲贪嗔痴。此云何知。谓以筹虑作意观察境时。心生于舍无习向心无习趣心无习着心。应知是人三毒微薄。五不还向。谓如有一或世间道。先离欲界贪已。趣入正性离生。或一来果。进断欲界余烦恼故。修对治行。六不还果。或先离欲入正性离生。然后证得。或一来果。尽断欲界余烦恼故得。七阿罗汉向。谓如有一学。已见迹为断非想非非想地烦恼故。修对治行。八阿罗汉果。谓永断一切非想非非想地烦恼故得

极七返等者。谓极七返等。八依生建立。广说如经。一极七返。谓即预流果。由善修圣道故。或于天上或于人间。或天上人间受七有生已得尽苦际。二家家。谓即预流果。由善修圣道故。或生天上或生人间。从家至家得尽苦际。三一间。谓即一来果。由善修圣道故。或生天上。即于彼处定证寂灭。或生人间。即于此处定证寂灭。四中间证寂灭。谓即不还果。已断根本生结。未断趣向生结。上品修习圣道力故。生中有中即证寂灭。或有不进向生处而证寂灭。或有进向生处未至本生而证寂灭。五生证寂灭。谓即不还果。中品修习圣道故。未断二种生结。随生一处意生天中。初生之时即证寂灭。六无行证寂灭。即此圣者行少行已。及少精进而证寂灭。余悉如前。七有行证寂灭。谓即不还果。下品修习圣道故。未断二结。随生一处意。生天中。行多行已。及多精进而证寂灭。八上流。谓即不还果。随生一处意生天中。于彼不能得诸漏尽。复进生上于余身中方证寂灭

退法等有六者。谓退法等六无学果。广说如经。一退法。谓成就如是软根。若思自害不思自害。若放逸若不放逸。俱可退失现法乐住及世间功德。不能练根不能发起胜品功德。二思法。谓成就如是软根。若思自害即能不退。不思害时即可退失。此人作是思惟。宁使我胜诸魔。不令诸魔胜我。如是思已而思自害。此亦不能练根。不能发起胜品功德。三护法。谓成就如是软根。虽不思自害。不放逸故能不退失。若心放逸即可退失。不能练根。不能发起胜品功德。四住不动。谓成就如是软根。虽不思自害及行放逸。然皆不退。不能练根。不能发起胜品功德。五堪能通达。谓成就如是软根堪能不退。能练诸根及能发起胜品功德。六不动法。谓从先来自性成就利根。此人于诸善根不为已得退法之所摇动。亦不为发胜功德及上练根之所动摇。是故说名为不动法。复次颂曰

  软根等七种　　在俗及出家
  声闻乘等三　　可救不可救

软根等七种者。一软根谓成就信等五根。或自性软或未增长。求胜进时加行迟钝。第二利根。应知反此。三贪行。谓于前世久习贪欲。及不修习贪欲对治。是因缘故。于此生中虽逢下劣可爱境界。亦起猛利相续贪爱。难离难厌。于修善法加行迟钝如贪行。第四嗔行第五痴行亦尔。此中差别者。虽逢微小可嗔境界。亦起猛利相续嗔恚。虽逢粗浅可痴境界。亦起猛利相续愚痴。六等分行。谓于前世不习上品贪欲嗔痴。设有习者复已修习彼对治法。是因缘故。于此生中逢可爱等三种境界。随境品类起贪嗔痴三种缠惑。非难离非易离。非难厌非易厌。于修善法不迟不速。七薄尘行。谓如有一于过去生不久数习贪欲嗔痴。然已修习彼对治法。是因缘故。于此世中虽逢胜上可爱等境。而能不起猛利相续贪恚痴缠。虽或时起下品中品。然易离易厌。于修善法加行速疾

在俗者。谓处家白衣。受用五欲营构俗业。以自活命

出家者。谓持出家威仪相貌。弃舍俗境受持禁戒。如法乞求清净自活

声闻乘等。三者一声闻乘。谓住声闻法性。为令自身证寂灭故。发正愿已修方便行。二独觉乘。谓住独觉法性。为令自身证寂灭故。不由师教。发正愿已修方便行。三大乘。谓住大乘法性。为令自他证寂灭故。不由师教。发正愿已修方便行

可救者。谓有三乘寂灭法性

不可救者。谓无三乘寂灭法性。复次颂曰

  入方便等九　　生差别故二
  复由诸界别　　应知十三种

论曰。入方便等九者。一已入方便。谓于如来自觉自说法毗奈耶得坚净信。已受尸罗已闻正法。已增长舍已直正见。第二未入方便。应知反此。三有障。谓有三障。一烦恼障。二业障。三报障。由能障碍修习善法。第四无障。应知反此。五未成熟。谓未得善根资心相续不能现法证见谛理。不得现法下中上乘所证寂灭。第六已成熟。应知反此。七具缚。所谓异生。八不具缚。谓彼六种有学圣者。从预流果乃至第六阿罗汉向。九无缚。谓彼无学阿罗汉果。生差别故二者。一人趣。谓生人趣。得人种类。二非人趣。谓生余趣那洛迦傍生及与鬼趣天龙药叉阿素洛揭路荼紧捺洛牟呼洛伽等生类差别

复由诸界别应知十三种者。一欲界异生。谓生欲界未见谛者。二欲界有学。谓生欲界已见圣谛六种有学。谓从预流果乃至第六阿罗汉向。三欲界无学。谓生欲界阿罗汉果。四色界异生。谓生色界未见谛者。五色界有学。谓生色界已见圣谛二种有学。一不还果。二阿罗汉向。六色界无学。谓生色界阿罗汉果。七无色异生。谓生无色未见谛者。八无色有学。谓生无色已见圣谛二种有学。一不还果。二阿罗汉向。九无色无学。谓生无色阿罗汉果。十欲界独觉。谓住独觉法性。于前生中或未见谛或已见谛。今生欲界。不由师教依先因力。修觉分法证得。一切诸结永尽。此复二种。一如朅伽独一而行。二独胜部众而行。十一欲界菩萨。谓生欲界住菩萨法性。为令自他证寂灭故。已发正愿修习一切无上菩提诸方便行。十二色界菩萨。谓生色界中住菩萨法性。远离无色修诸静虑。为令自他证寂灭故。已发正愿修习一切无上菩提诸方便行。十三不可思议诸佛如来。谓依修习不住流转。及与寂灭无分别道。证得诸佛共有解脱法身所摄无上转依遍行。十方一切世界作一切有情一切利益事无有断尽。如是已说。补特伽罗果今当说。颂曰

  果断有五种　　遍知及清净
  净果界菩提　　无学由自数

论曰。果断有五种者。谓诸果中断有五种。一诸缠断。谓由四种对治故。远离现行诸烦恼缠。四对治者。一散乱对治。二显了对治。三羸劣对治。四摧伏对治。散乱对治者。谓于前八妙法行中方便修习。或复于余定地善法方便修习。显了对治者谓于第九法行方便修习。羸劣对治者。谓由先善根资助心故烦恼羸弱。摧伏对治者。谓由世间道随力制伏烦恼种子。二随眠断。谓由出世间道随力永断烦恼种子。三永尽贪断。谓由永断随眠惑故。贪烦恼断。如永尽贪断。如是第四永尽嗔断第五永尽痴断。应知由极净善通达见力。诸事烦恼毕竟断故。名永尽断

遍知者。谓九遍知。诸果所摄依断遍知。说一欲系见苦集所断烦恼断遍知。由此二谛有漏摄故。二色无色系见苦及集所断烦恼断遍知。由此二界定地摄故。三欲系见灭所断烦恼断遍知。由此无漏无为摄故。四色无色系见灭所断烦恼断遍知。由此定地增上摄故。五欲系见道所断烦恼断遍知。由此无漏有为摄故。六色无色系见道所断烦恼断遍知。由此定地增上摄故七五顺下分结断遍知。由出过下界故。八色贪尽遍知由出过中界故。九无色贪尽遍知由出过妙界故

清净者。谓九种清净。广说如经。一尸罗清净。谓如有一善住尸罗及善守护别解脱戒。如法威仪行处具足。于小罪中见大怖畏受学学处。二心清净。谓如有一依戒清净远离欲恶不善法。如前所说。初静虑第二第三第四静虑具足住。三见清净。谓如有一具心清净鲜白无秽。离诸烦恼得住不动。为欲证得漏尽智故。观察诸谛如实了知。此苦圣谛。此苦集圣谛。此苦灭圣谛。此趣苦灭行道圣谛。四度疑清净。谓如有一依见清净。于佛法僧无惑无疑。五道非道智见清净。谓如有一依度疑清净得妙智见。唯佛所说僧所行道。能得出离。此复云何。谓能尽苦及证苦边。若诸外道所说之道。不能尽苦及证苦边。六行智见清净。谓如有一依道非道智见清净。得妙智见。知出离道有下中上。下者。苦迟通行所摄。中者。苦速通行乐迟通行所摄。上者。乐速通行所摄。七行断智见清净。谓如有一依行智见清净得妙智见。谓我应断下中之行。及为发起上妙圣行。八无缘寂灭清净。谓如有一依行断智见清净。证得无余诸漏永尽。九国土清净。谓诸佛共有无上功能果能示现不可思议国土庄严极净佛思及极净菩萨思及思眷属法

净者。谓四证净广说如经。一佛证净。谓已见谛者。于如来所善住出世间信。及后所得善住世间信。如佛证净。如是第二法证净第三僧证净应知。四圣所爱戒证净。谓已见谛者。于已得决定不作律仪圣所爱戒所善住出世间信。及后所得善住世间信

果者谓四沙门果。广说如经。一预流沙门果。若随胜摄三结永断。谓身见戒禁取及疑。若全分摄。一切见道所断烦恼永断。由彼断故。得预流果不堕落法。或极七返或复家家。二一来沙门果。若随胜摄三结永断。薄贪嗔痴。若全分摄。一切见道所断烦恼永断。及欲界系修道所断上品中品烦恼永断。由彼断故得一来果。或复一间。三不还沙门果。若随胜摄五顺下分结永断。所谓身见戒禁取疑贪欲嗔恚。若全分摄。一切见道所断烦恼永断。及欲界系修道所断烦恼永断。或色界系烦恼永断。或无色界一分烦恼永断。由彼断故得不还果。或中间寂灭。或生寂灭。或无行寂灭。或有行寂灭。或复上流。四阿罗汉沙门果。若随胜摄贪欲嗔痴无余永断。若全分摄。见修所断一切烦恼永断无余。由彼断故得阿罗汉诸漏永尽。乃至广说。阿罗汉。六恒住法界者。谓三种界。广说如经。一断界。谓断见道所断诸行二离界。谓离修道所断诸行三灭界。谓灭所依所摄诸行

菩提者。谓三种菩提。如经广说。一声闻菩提。谓声闻乘转依所得寂灭及趣寂灭道。二独觉菩提。谓独觉乘转依所得寂灭及趣寂灭道。三无上正等菩提。所谓大乘转依所得寂灭趣寂灭道。及作一切有情利益安乐道。无学者。谓十无学法。广说如经。一无学正见。谓阿罗汉于苦思惟苦乃至于道思惟道。无漏作意相应择法极简择等。如前广说。如无学正见。如是乃至第八正三摩地。如前应知。九无学正解脱。谓离一切烦恼粗重。无学心上离烦恼障调堪任法。十无学正智。谓阿罗汉尽智及无生智

由自数者。前所说果各由自数差别应知。复次颂曰

  断多因故断　　建立断所从
  由作意依修　　及得断次第

论曰。断多因故断者。断果多因故烦恼断。谓四种因诸烦恼断。一所依灭故。二所依转故。三知所缘故。四乐所缘故。复有五因断诸烦恼。一知彼体故。二知彼事故。三知彼过故。四避彼缘故。五修彼对治作意法故。复有四因烦恼已断。一依无余灭故。二依无余转故。三对治无余修故。四心无余解脱故

建立断所从者。谓从所缘境断诸烦恼。于所缘境断烦恼已无系缚故。诸相应法亦复随断。未来现在烦恼可断永害粗重说烦恼断。由作意者。谓由总缘谛修作意故断诸烦恼。由依者。谓由依止七依定故断诸烦恼。谓初静虑乃至第七无所有处

由修者。谓修四念住及四正断乃至修习八圣道支故。断烦恼

及得断。次第者。有五种次第诸烦恼断。一先断见道所断烦恼。二后断修道所断烦恼三先渐调伏诸现烦恼。四然后永断一切烦恼。五最后超过一切烦恼。复次颂曰

  断差别应知　　及断相利益
  如是如所说　　复应知多种

论曰。断差别应知。多种者。诸烦恼断多种差别。谓有诸缠断。有随眠断。有由世间道。有由出世间道。有由声闻乘作意。有由独觉乘作意。有由菩萨乘作意。有暂时断。有毕竟断。诸如是等烦恼断灭差别应知

断相利益复应知。多种者。诸烦恼断有多种相利益应知。如经广说。谓不坠堕法定趣菩提。已至正法临至正法。证解正法。得证源底得遍证源底。圣智见成就。不复能计苦乐等法。自作他作及自他作。及非自他二种共作。亦不复计诸苦及乐。无因而生不复故。断傍生等命不复故。越诸所学处不复能起五无间业。不复求请诸外道师。亦不以彼为真福田。不复瞻仰观察余沙门婆罗门等邪众颜面。不复于彼三世法中生疑生惑。不复受彼第八有报。如是证得阿罗汉果永尽诸漏。已作所作。所作已办得阿罗汉。六恒住法。广说如经。谓成就六种相续住法。若眼见色心不忧喜舍念正知。如是耳鼻舌身若意识法心不忧喜舍念正知。诸所行行为自利益。为利益他。为利众生。为乐众生。为愍世间。为诸天人得义利乐。诸如是等烦恼永断。有多种相利益应知

显扬圣教论卷第三显扬圣教论卷第四

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄事品第一之四

如是已说。果诸功德今当说。颂曰

  无量诸解脱　　胜处与遍处
  无诤妙愿智　　无碍解神通

论曰。无量者。谓四无量。广说如经。一慈无量。谓慈心俱。无怨无憎无有损害。广大无量极善修习。于一方面如是次第乃至十方一切无边世界。意解遍满具足住。慈心俱者。于无苦无乐众生欲施乐具阿世耶心相应故。无怨者。即彼对治欲加苦具嗔故。无憎者。即彼对治障碍乐具嗔故。无损害者。即彼对治欲与不宜嗔故。广者。于见所行作意故。大者。于闻所行作意故。无量者。于觉知所行作意故。极善修习者。由串习相应离诸盖故。于一方面如是次第乃至十方一切无边世界者。遍缘器世间及有情世间故。意解者。缘意解思惟境界故。遍满者。缘无间有情境界故。具足住者。如前静虑中说。二悲无量谓悲心俱。乃至广说。悲心俱者。于有苦众生欲拔苦具阿世耶心相应故。无怨者。即彼对治与苦害故。无憎者。即彼对治障碍拔苦害故。无损害者。即彼对治欲与不宜不喜乐故。余如前说。三喜无量。谓喜心俱。乃至广说。喜心俱者。于有乐众生随喜彼乐阿世耶心相应故。无怨者。即彼对治欲与苦具不喜乐故。无憎者。即彼对治障碍乐具不喜乐故。无损害者。即彼对治欲与不宜不喜乐故。余如前说。四舍无量。谓舍心俱。乃至广说。舍心俱者。欲令不染阿世耶心相应故。无怨者。即彼对治令染贪嗔故。无憎者。即彼对治障碍除染贪嗔故。无损害者。即彼对治颠倒不染贪及嗔故。余如前说

此四无量体性云何。谓慈以无嗔善根为体。悲以不害善根为体。喜以不嫉善根为体。舍以无贪无嗔善根为体。皆是怜愍众生法故。于此四中慈唯无嗔。次二无量无嗔一分。舍是无贪无嗔一分。又复与彼相应等持诸心心法。并彼眷属皆是四无量体。当知先由增上法行善修治心。复依清净静虑。方得清净无量应知

诸解脱者。谓八解脱广说如经。一有色诸色观解脱。有色者。依有色定意解思惟故。诸色者。若色如胜处中广自分别。观者。于诸色中为变化自在故。意解思惟显示彼相故。二内无色想外诸色观解脱。内无色想者。依无色定意解思惟故。外者。除眼等根意解思惟余色故。诸色观者。如前说。三净解脱。身作证具足住。解脱净者。一向意解思惟净妙色为得增上安乐住故。解脱者。解脱净不净色功用障碍心故。身者意身故。作证者。由智断得作证故。具足住者。如前说。无色诸解脱如前分别。此中差别者。为欲证得一切种身业自在故。及为解脱彼障故。复除光色作无边虚空意解思惟故。名第四无边虚空处解脱。为欲发起圣神通无诤愿智无碍辩等诸功德故。又为证得能助发起彼诸功德心自在故。又为解脱彼障故。复作无边识意解思惟故。名第五无边识处解脱。行者作如是发起功德方便。已令第四静虑起。现在前发诸功德。为欲证得最胜无漏住自在故。又为解脱彼障故。复作无所有意解思惟故。名第六无所有处解脱。为欲证得最第一有住自在故。又为解脱彼障故。复作非想非非想意解思惟故。名第七非想非非想处解脱。为欲证得最胜寂静住自在故。又为解脱彼障故。复从非想非非想处心进止出入息灭攀缘故。名第八想受灭解脱

胜处者。谓八胜处。广说如经。一内有色想。外诸色观少。若好若恶若劣若胜。于彼诸色胜知胜见得如是想名初胜处。内有色想者。如解脱中说。外者。谓除眼等根显余色故。诸色观者。如前说。少者。谓资具摄色意解思惟故。若好若恶者。谓净不净色之所摄色意解思惟故。若劣若胜者。谓净不净声香味触之所摄色意解思惟故。于彼诸色胜者。谓能治所治作意思惟。障碍功用所不恼故。知者。用奢摩他道。见者。用毗钵舍那道。得如是想者。谓于实胜中得实胜无慢想故。于不胜中得实不胜无慢想故。二内有色想。外诸色观多。乃至名第二胜处。内无色想中观少观多二种亦尔。内有色想外诸色观者如前说。多者。显示有情世间器世间色遍思惟故。余如前说。五内无色想外诸色观青。青显青可见。青光犹如乌莫迦花。或如婆罗痆斯染青衣色。如是黄赤白色皆应广说。此中差别者。黄色如羯尼迦罗花。或如婆罗痆斯染。黄衣色赤色如槃豆时缚迦花。或如婆罗痆斯染赤衣色白色如乌奢那星。或如婆罗痆斯鲜白衣色。青者。谓总句。青显者谓俱生青。青可见者。谓和合成青。青光者。谓彼二所出鲜净光青。如青色黄赤白色亦复如是。广说应知。余如前说。于一处说二譬喻者。此显俱生和合二种色故。此八胜处与修三种缘色解脱作所依止。后四胜处意解思惟。欲界天色及色界色。又复应知。是诸胜处为治下地种子。随逐作意思惟。非为对治。自地所治作意思惟。遍处者。谓十遍处。广说如经。谓地遍处。一能解了上下及傍无二无量。如是水火风遍。青黄赤白虚空识遍。上下及傍无二无量。地遍处者。由色所依遍满故。彼能依色亦遍满。由彼增长故。一能解了者。谓能证此观补特伽罗。上下及傍者。谓遍满诸方及四维故。无二者。离余诸界及不杂显色遍满故。无量者。无有分齐相遍满故。如地遍处余水火风青黄赤白亦复如是。如其所应。虚空遍处者。谓对治一切色相作意思惟遍满故。余如前说。识遍处者。谓缘无量识作意思惟遍满故。余如前说

此中由三解脱故得胜色自在。由得彼已方可说言胜色自在极成就故。识处已上无有遍满。所缘无量形段依止分别远离故。应知胜处及与遍处。是诸解脱能清净道。由诸胜处胜所缘故。由诸遍处所缘遍故。能令解脱清净应知

无诤者。谓能守护他烦恼行之所引摄无痴智见性。及彼相应等持诸心心法。由此行多所行故

妙愿智者。谓于三世及非世摄所知法中无余如实了知之所引摄无痴智见性。及彼相应等持诸心心法。由此行多所行故

无碍解者。谓四无碍解。广说如经。一法无碍解。谓于一切种一切法差别名中。如实觉悟之所引摄无痴智见性。及彼相应等持诸心心法。二义无碍解。谓于一切种一切法种种相中。如实觉悟之所引摄无痴智见性。余如前说。三训词无碍解。谓于一切种一切法训释词中。如实觉悟之所引摄无痴智见性。余如前说。四辩才无碍解。谓于一切种一切法通达中。如实觉悟之所引摄无痴智见性。及彼相应等持诸心心法。由此行多所行故。神通者。谓六神通。如经广说。一神境智见作证通。谓为示现一切种身业自在无痴智见性。及彼相应等持诸心心法。由此行行多决定境界故。二天耳智见作证通。谓为随闻一切种语业无痴智见性。余如前说。三心差别智见作证通。谓为入一切种他心行无痴智见性。余如前说。四宿住随念智见作证通。谓为入一切种前际趣行无痴智见性。余如前说。五死生智见作证通。谓为入一切种有情趣行无痴智见性。余如前说。六漏尽智见作证通。谓为入出离一切烦恼及无余苦无痴智见性。及彼相应等持诸心心法。由此行行多决定境界故。复次颂曰

  诸相好清净　　及诸力无畏
  不护与念住　　永断诸习气

论曰。诸相者。谓三十二大丈夫相。广说如经。一善安立足大丈夫相。由如来菩提资粮善圆满故。具足受持平等行故。感得此相。由此相故。有暂见者。即信如来是大丈夫足相足幖帜足形貌。如善安立足相。如是诸余大丈夫相如其所应尽当知。谓于手中应说手相手幖帜手形貌。如是于头顶等所余支节。各随其名应当广说。好者。谓八十种好。广说如经。是诸好等若具足相摄。如菩萨地中说。若随众生所宜随胜相摄。如大慧度经说。若广分别诸好应知。如广分别相中说。清净者。谓四一切相清净。广说如经。一依止清净。谓由如来证得一切相清净智及一切相清净断故。于依止取住舍中。究竟无上自在。二境界清净。谓由如来证得一切相清净智及一切相清净断故。于一切事变化境界中。究竟无上自在。三心清净。谓由如来证得一切相清净智及一切相清净断故。于一切相世出世善根增长心中。究竟无上自在。四智清净。谓由如来证得一切相清净智及一切相清净断故。于一切相所知中。无著无碍智究竟无上自在

诸力者。谓如来十力。广说如经。一处非处智力。谓于一切相因果中能如实问记无碍智性及彼相应等持诸心心法。二自业智力。谓于一切相各别处所相续所起业及所得报中无碍智性。余如前说。三静虑解脱三摩地三摩钵底智力。谓于摄受一切相世间清净功德方便中无碍智性。余如前说四根上下智力。谓于出世间功德所依一切相所化有情根差别中无碍智性。余如前说五种种胜解智力。谓于一切相所化有情阿世耶差别中无碍智性。余如前说。六种种界智力。谓于一切相所化有情随眠差别中无碍智性。余如前说。七遍趣行智力。谓于一切相乘出离差别中无碍智性。余如前说。八宿住随念智力。谓于一切相前际趣差别中无碍智性。余如前说。九死生智力。谓于一切相后际趣差别中无碍智性。余如前说。十漏尽智力。谓于一切相趣非趣出离方便差别中无碍智性。及彼相应等持诸心心法。又诸力中一切应说能如实问记

无畏者。谓四无畏。广说如经。一佛作诚言我是正等觉者。若有难言于是法中不正等觉。我于此难正见无缘。是故无畏。谓如来证得妙善清净一切种智故。二佛作诚言。我诸漏已尽。若有难言如是如是诸漏未尽。我于此难正见无缘。是故无畏。谓如来证得妙善清净一切种断故。此二无畏依自利德。三佛作诚言。我为弟子说障碍法染必为障。若有难言染习此法不能为障。我于此难正见无缘。是故无畏。谓依如来为所化有情说一切种所对治法。四佛作诚言。我为弟子说出离道修定出离。若有难言虽修此道不能出离不正尽苦及证苦边。我于此难正见无缘是故无畏。谓依如来为所化有情说一切种能对治法。此二无畏依利他德

不护者。谓三不护。广说如经。一如来现行身业妙善清净无不清净。现行身业可须覆藏。是故不护。谓如来一切种一切时身业妙善清净故。为所化有情正说法时。能以胜力折伏摄受一切徒众。如身业不护。如是第二语业不护第三意业不护应知

念住者。谓三念住。广说如经。此即摄受所化众时于三种徒众行差别中住最胜舍不爱不恚不染心性

永断诸习气者。谓诸如来出离无始无量无数大劫生死。为证自性不随转故。证得如来妙净智断。复次颂曰

  无忘失妙法　　及如来大悲
  佛不共德法　　一切种妙智

论曰。无忘失妙法者。谓为证一切种一切所化有情一切所作事不过时故。证得如来妙净智断

及如来大悲者。谓如来悲由四种因缘。说名大悲。一依止一切种妙善清净转依所作成就故。二长时修习所得故。三妙善清净智所引故。四缘极深固种种坚牢一切相苦境界故

佛不共德法者。谓十八不共佛法。广说如经。超过一切声闻独觉地故。彼建立应知。一如来无误失业。谓无不染污误犯失故。二无卒暴音。谓无不染污高笑暴音故。三无忘失念。谓无不染污久作久说不随念故。四无不定心。谓于一切威仪行住等中。作意等持恒随转故。五无种种想。谓于流转寂灭中。证得无分别无差别智故。六无不择已舍。谓究竟不舍有情事故。七欲无退。谓得所知障清净故。如欲无退如是。八正勤无退。九念无退。十等持无退。十一慧无退。十二解脱解脱智见无退应知。十三于过去世无著无碍智谓欲作意顷一切种知故。如于过去如是。十四于未来。十五于现在无著无碍智应知。十六如来一切身业智为导首随智而行。谓由智发起摄受于一切时善方便故。如身业如是。十七语业。十八意业应知

一切种妙智者。谓证得如来最极清净智断故。谓于染污清净二法一切种数相差别中。无碍智性及彼相应等持诸心心法。又复如来住无漏界。为作一切有情所作事故。于十方土示佛生有现身言说。心有所行有所宣说。成等正觉转妙法轮。入大寂灭无碍智性。及彼相应等持诸心心法。是亦名为一切种妙智

又相好等诸佛功德。为释经义略已示现。若广分别如菩萨地应知如是已别说。九事总分别今当说颂曰

  当知前九事　　初为二所依
  次二后六种　　摄杂染清净
  染依差别故　　清净所缘故
  心不流散故　　正修方便故
  彼位差别故　　言说等因故
  彼果功德故　　数次第唯尔

论曰。前九事中。初一切事为二所依。一杂染所依。二清净所依。由次二事摄诸杂染。一由界事。二由杂染事。由后六事摄诸清净。一由谛事。二由依止事。三由觉分事。四由众生事。五由果事。六由功德事。由二种事摄杂染中杂染所依故。杂染差别故。由六种事摄清净中清净境界故。于境界中心不流散故。由不散乱于所缘境正方便故。正方便者位差别故。及言说等因故。正方便果故。彼果功德故。此中位差别故。言说等因故。此二建立众生事应知。言说等因故者。为言说易故。为随顺世间故。为避怖畏故。为令信知自他功德过恶成就故。由是因缘此九种事数。决定及次第决定。应知为欲思量。如此九事复应广说。颂曰

  欲思量无量　　诸问答差别
  由诸佛语言　　事与想摄故

论曰。若欲思量如上九事无量问答差别者。由二种摄故应可思量。一由一切佛语言事摄故。二由一切佛语言想摄故。此中一切佛语言事摄者。谓由三种经应知。一由增十经。二由广义经。三由集异门经。一切佛语言想摄者。由四种嗢拖南伽他。何者为四。颂曰

  句迷惑戏论　　住真实净妙
  寂静性道理　　假施设现观
  方所位分别　　作执持增减
  闇语所觉上　　远离转藏护
  简择与现行　　睡眠及相属
  诸相摄相应　　说任持次第
  所作境瑜伽　　奢摩他与观
  诸作意教授　　德菩提圣教

论曰。句者。所谓六处。无量境界无量方所无量时节。复有三界一欲界二色界三无色界。复有三界。一小千世界二中千世界三大千世界。复有四辈。一在家辈二出家辈。三邬波索迦辈四非人辈。复有三受。谓苦受乐受不苦不乐受。复有三世。谓过去世未来世现在世。复有三宝。谓佛宝法宝僧宝。复有三法。谓善法不善法无记法。复有三种杂染。谓烦恼杂染业杂染生杂染。复有四圣谛。谓苦集灭道。复有九次第定。谓初静虑乃至灭受想定。复有三十七菩提分法。谓念住正断神足根力觉支道支。复有四种沙门果。谓预流果一来果不还果最胜阿罗汉果。复有众多最胜功德。谓无量解脱胜处遍处无诤愿智无碍辩六神通等。复依广乘有五种事。一相二名三分别四真如五正智。复有二种空性。一众生空性二法空性。复有二种无我性。一众生无我性二法无我性。复有远离二边处中之行。谓远离增益边及损减边。复有四种真实。一世间所成。二道理所成。三烦恼障净智所行处。四所知障净智所行处。复有四种寻思。谓名寻思。事寻思。自性假立寻思差别假立寻思。复有四种如实遍智。谓名寻思所引如实遍智。事寻思所引如实遍智。自性假立寻思所引如实遍智。差别假立寻思所引如实遍智。复有三种自性。一遍计所执自性。二依他起自性。三圆成实自性。复有三种无自性性。一相无自性性。二生无自性性。三胜义无自性性。复有五相大菩提。谓自性故功用故方便故转故还故。复有五种大乘。一种子二趣入三次第四正转五正转果。谓最初发心故。于诸有情起大悲故。波罗蜜多故。摄事故。自他相续成熟故。复有五无量想。一有情界无量想。二世界无量想。三法界无量想。四所调伏界无量想。五所调伏方便界无量想。复有真实义随至。谓于一切无量法中随至真如及此中智。复有不思议威德信解。复有无障碍智。复有三十二大丈夫相及八十种随形好。复有四种一切相清净。十力。四无所畏。三念住。三不护。大悲。无忘失法。永断习气。一切种妙智。如上所说。略唯二种。一声闻乘中所释句。二大乘中所释句。迷惑者。谓四颠倒。一于无常中计常颠倒。二于苦中计乐颠倒。三于不净中计净颠倒。四于无我中计我颠倒。戏论者。谓诸烦恼及杂烦恼。诸蕴住者。谓四识住及七识住。真实者。谓真如及四圣谛。净者。谓三种净性。一自体净性。二境界净性。三阶位净性。妙者。所谓三宝处胜建立故名为妙。寂静者。谓自善法欲乃至一切菩提分法及所证果。皆名寂静。性者。谓诸法相若自相若共相若假立相若因相若果相。总名为性。道理者。谓诸缘起及四道理。假施设者。谓唯于法假立众生及唯于相假立。诸法现观者。谓六种现观。如成现观品当说

方所者。所谓色蕴。位者。所谓受蕴。分别者。所谓想蕴。作者。谓诸行蕴。执持者。所谓识蕴。增者。此有二种应知。一烦恼增二业增。如增减亦二种。谓烦恼减业减。闇者。谓无明疑。语者。谓十二分语趣说名为语。所觉者。谓种种所说法义名为所觉。上者。谓沙门果。远离者。谓五种远离。一恶行远离。二淫欲远离。三众具远离。四聚会远离。五烦恼远离。转者。所谓三界及与五趣。藏护者。所谓恋过去希未来着现在。简择者。所谓一行。顺前句顺后句。事句无事句。色法非色法。有见无见有对无对。有漏无漏有为无为。有诤无诤。有味着无味着。依耽嗜依出离。世间出世间。摄属不摄属。内外粗细胜劣远近。有所缘无所缘。相应不相应。有行无行。有所依无所依。因非因果非果。异熟非异熟。有因无因有果无果。有异熟无异熟。有执受无执受。四大种造非四大种造。同分彼同分。有上无上。过去未来现在。善不善无记。欲系色系无色系。学无学非学非无学。见断修断无断。复有四缘。一因缘二等无间缘三所缘缘。四增上缘。复有四依。一依法不依众生。二依义不依文。三依了义经不依不了义经。四依智不依识。复有四无量。四念住。四正断。四神足。五根。五力。七遍觉支。八圣道支。四种行。四法迹。奢摩他。毗钵舍那。增上戒。增上心。增上慧。解脱。胜处。遍处等。现行者。谓烦恼缠。睡眠者。谓烦恼随眠。相属者。所谓六处。同一依止相属应知。复有诸法能引摄法。彼亦展转相属应知。复有诸根境界能取所取相属应知。诸相摄者。有十一种相摄。一更互摄。二界摄。三相摄四种类摄。五分位摄。六不相离摄。七时摄。八方摄。九一分摄。十全分摄。十一胜义摄。相应者。所谓五种应知。一与他性相应非自性。二于他性相应中与不相违法相应非相违法。三于不相违相应中下中上品相似相应非不相似。四于下中上品相似相应中同时相应非不同时。五于同时相应中同地相应非不同地。说者。所谓四种言说。一见言说二闻言说。三觉言说四知言说。任持者。所谓四种食。一段食二触食三意思食四识食。次第者。所谓五种次第。一流转次第。二成所作次第。三说次第。四生次第。五现观次第。所作者。谓八种所作。一依止灭二依止转。三遍知所缘四喜乐所缘。五得果六离欲。七转根八发起神通。境者。谓四种所缘。一遍所缘。二令行净所缘。三善巧所缘。四令烦恼净所缘。瑜伽者。此或四种或九种。四种者。一信二欲三正勤四方便。九种者。一世间道二出世间道。三方便道四无间道。五解脱道六升进道。七下品道八中品道九上品道。奢摩他者。谓九种心住。观者。谓三种事观。或四种观。或六事差别所缘观。应知。三事观者。一有相观二寻求观三审察观。四种者。一简择诸法观。二极简择诸法观。三遍筹量观。四遍审察观。六事差别所缘观者。一义所缘观二事所缘观。三相所缘观四分所缘观。五时所缘观。六道理所缘观。诸作意者。谓七种作意。一了相作意二胜解作意三远离作意。四摄乐作意五观察作意。六方便究竟作意。七方便究竟果作意。教授者。谓五种教授。一教教授二证教授三随次教授。四不颠倒教授五神变教授。德者。谓如前所说。无量解脱等诸功德法。菩提者。谓三种菩提。一声闻菩提二独觉菩提三无上正等菩提。圣教者。谓授归依制立学处。施设听者。建立师资施论。戒论。生天之论。诃欲爱味示欲过失。显说杂染及清净法。教导出离称赞功德。广说一切清净分法。复次颂曰

  若欲正修行　　遍知等功德
  由十种法行　　及六种理趣

论曰。若诸行者。于前九事欲正修行。遍知永断作证修集诸功德等。由十法行及六理趣。应当修学。十种法行。已如前说。六种理趣者。一真义理趣。二证得理趣。三教导理趣。四离二边理趣五不思议理趣。六意乐理趣

显扬圣教论卷第四显扬圣教论卷第五

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之一

如是已说。九事净义今当说。颂曰

  诸论中胜论　　亦善入瑜伽
  清净义应知　　由具四净德

论曰。此显扬圣教论。于诸论中最为殊胜。何者诸论。略有四种。一像正法论谓依圣教倒显法相。二外医治论。谓外医方。三诘诤论。谓诸外道虚妄推度。四矫诳论。谓婆罗门诸恶咒术。云何此论能胜诸论由此论中能显无倒诸法相故。究竟能治内心病故。对治诘诤恶咒术故。又此论中四论可得非于余论。是故最胜。何者四论。一非二边论。二非一向论。三一切取断遍知论。四立正相论。非二边论者。谓非有非无非异非不异非我非无我非常非断。如是等论。非一向论者。非一切乐悉应习近。谓能引无义利者。非一切乐悉不习近谓能引有义利者。如乐苦亦尔。如是等论。一切取断。遍知论者。谓欲取见取戒禁取我语取断遍知论。立正相论者。谓无倒施设一切诸法。自相共相因相果相。如是等论

亦善入瑜伽者。有四种瑜伽。一信二欲三正勤四方便。此论善顺彼故名善入瑜伽

清净义应知者。应知建立能显不共德第二名

由具四净德者。欲显此名如义建立。云何此论。具四净德。颂曰

  摄一切义故　　彼外不坏故
  易入故入已　　行不失坏故

论曰。摄一切义故者。由此论中摄一切义。谓九种义或十种义或五种义或四种义或三种义。九种义者。已如摄事品中说

十种义者。一尽所知义二如所知义。三能取义四所取义。五所依住义六所受用义。七颠倒义八不颠倒义。九杂染义十清净义。此中尽所知义者。谓于杂染清净法中。穷一切种差别边际。是名尽所知义。如五数蕴六数内处如是等。如所知义者。即于杂染清净法中真如实性。是名如所知义。此复七种。谓流转真如乃至正行真如。能取义者。谓五内色处心意识及诸心法。所取义者。谓外六处又能取义。亦是所取。所依住义者。谓外世界依此所住有情界可得。所谓村田百村田千村田百千村田如是广说。乃至三千大千世界。乃至无数百千世界极微尘等十方无量无数世界。所受用义者。谓所摄受众具。颠倒义者。谓即于能取等义中。于无常常想颠倒心颠倒见颠倒。如是乃至于无我我想颠倒心颠倒见颠倒。不颠倒义者。谓对治如前所说颠倒应知。杂染义者。有三种。于三界中烦恼杂染业杂染生杂染。清净义者。谓为证三种杂染离系故。所修一切菩提分法。此十种义摄一切义应知

五种义者。一所遍知事。二所遍知义。三应知遍知。四得遍知果。五受用遍知果。所遍知事者。谓一切所知事。若诸蕴事。若内处事。若外处事如是等。所遍知义者。谓尽一切种如所应知。若世俗谛若胜义谛。若功德若过失。若诸缘若三世。若起住坏相若如病等。若苦集若真如实际法性。若广若略。若一向记若分别记。若反问记若置记。若隐若显。如是等所遍知义应知。遍知者。谓能取前二境菩提分法。得遍知果者。谓永灭贪欲嗔恚愚痴及无遗余贪嗔痴断。四沙门果。及诸声闻独觉如来共不共世出世功德。具足作证。受用遍知果者。谓即于所证法中解脱智及广为他开示演说分别。此五种义亦摄一切义应知

四种义者。一心所执义。二领纳义。三了别义。四杂染清净义。此四种义亦摄一切义应知三种义者。一文义。二义义。三界义。文义者。谓名身等。义义者。谓十种义应知。一真实相。二遍知相。三永断相。四作证相。五修习相。六即于真实等相种种差别相。七所依能依相属相。八能障碍遍知等法相。九能随顺遍知等法相。十于不遍知等及遍知等过失功德相。界义者。谓五种界。一器世界。二有情世界。三法界。四所调伏界。五所调伏方便界。此三种义亦摄一切义。应知

彼外不坏故者。彼上诸义一切外道所不能坏。正道理论不可制伏故。一切外道。略有五种。一说我外道。二说常外道。三说断外道。四说现法涅槃外道。五说无因外道

易入故者。由此论中文圆显故。其义易入。非如婆罗门诸恶咒论文阙隐故义难可入。入已行不失坏故者。由此论中义圆正故。若已入者如说修行自义不失。非如外道邪论彼自入已虽如说行空无自义

如是此论摄义净故。不可坏净故。易入净故。行清净故。名清净义应知。今此论中显薄伽梵所说何法。颂曰

  诸佛说妙法　　正依于二谛
  一者名世俗　　二者名胜义

论曰。世俗及胜义二谛之相。如前已说。复次颂曰

  初说我法用　　为随余故说
  七种及四种　　真如名胜义

论曰。初世俗谛说我说法及说作用。说我者。谓说有情命者生者补特伽罗人天男女佛友法友如是等。说法者。谓说色受如是等。说作用者。谓说能见能闻能生能灭如是等。是谓世俗谛应知。此虽非实有。然依世俗故说有。问若世俗谛非胜义故有为。何义故说。答为随余故说。谓为欲随顺胜义谛故说世俗谛。问何等为胜义谛。答七种及四种真如名胜义。如摄事品中说

如是已略说二谛。此中如来复有广说。颂曰

  自性义建立　　数次第善巧
  想差别应知　　显蕴世俗义

论曰。自性者。谓变坏领纳了置造作了别。是诸蕴自性

义者。谓聚积义。是蕴义。此聚积义有四种。如成善巧品当说

建立者。谓于色蕴有四种建立。一相建立。二生建立。三损减建立。四差别建立

相建立者。色蕴相略有五种。一自相。二共相。三所依能依相属相。四受用相。五业相。自相者。谓坚等是地等相。各别清净是眼等相。共相者。谓一切色变坏相所依能依相属相者。谓大种是所依。造色是能依

受用相者。谓内处受用增上力故。各别外色境界得生。或有色聚。唯有坚生。或唯有湿。或唯有暖。或唯有动。或复杂生。由随顺内处受用故。业相者。如地等大种有依持摄受成熟增长相如是等

生建立者。有五种生。一依止生。二种子生。三势引生。四顺益生。五违损生。依止生者。谓依止大种。即于大种处所有余所造色生。由是因故。说四大种造。所造色摄在一处是造义。种子生者。谓从自种子生如坚鞕聚。或时遇缘变生流湿。或流湿聚变生坚鞕。或不暖聚变生暖热。或有暖聚变生于冷。或从不动变生于动。或复从动变生不动。如是好色恶色等。展转相生差别应知。如是若就自相则互无。若就其种则互有。是故从彼彼聚如是如是差别色法生。如是等类名种子生应知。势引生者。谓内色根增上力故。现常相续外物得生。如器世间。又先业势引故。诸内处生若乐欲现前。诸天及北洲人所有众具多分。由势引生故流转应知。若人中器世间。唯常相续。如是等类势引生应知。顺益生者。谓得自顺益缘彼彼色法展转滋长展转增胜而生。犹如水等润洽芽等。如是等类名顺益生。翻此故名违损生应知

损减建立者。谓建立极微。复由五种极微建立应知。一由分析故。二由差别故。三由独一故。四由助伴故。五由无分性故。由分析故者。谓由慧分析诸粗色法。渐渐转减至最细边建立极微。非由体故。由如是因故说极微无起无灭。又亦非谓集诸极微以成粗色。由差别故者。略有十五种极微。谓眼等根极微有五种。色等境极微有五种。地等界极微有四种。法处所摄实有色极微有一种。由独一故者。谓建立实极微自相。由助伴故者。谓建立聚极微由于地等一极微处。有余色法同处不相离故。建立聚极微。由无分性故者。非一极微复有余细分。由非聚故。若聚极微可有众分。若一极微所住之处。此处不可分析更立余分。是故极微无有细分

差别建立者。有二十六种色。一欲界系色。谓具诸色。二色界系色。谓除香味。三无色界系色。谓等持自在色。非业异熟色。四清净界色。谓出世法增上所生。如静虑解脱色及佛菩萨色。五内色。谓根及根所居处色。六外色。谓除根及根所居处余色声香味触。七所依色。谓眼等五根八所缘色。谓五境界及法处所摄色。九能取色。谓即所依色。十所取色。谓即所缘色。十一执受色。谓受起所依如诸色。根及根所居处色。心及心法所居处故。同一损益是执受义。十二无执受色。谓此外余色。十三同分色。谓自识不共根色。由与识同境转故。十四彼同分色。谓自识共根色。唯自类相续相似转故。十五有见有对色。谓色处色。十六无见有对色。谓余九处色。十七无见无对色。谓法处所摄色。十八清净色。谓五内处。十九清净所取色。谓五外处。二十意所取色。谓法处所摄色。二十一所依住色。谓风轮乃至大地。二十二覆护色。谓宅舍等。二十三资具色。谓十种资具。一饮食。二衣及庄严具。三众具。四戏笑。五鼓舞。六歌咏。七音乐。八香鬘涂饰。九众明。十男女承事。二十四根所居色。谓五种色根之所居处。二十五根色。谓五种色根。二十六等持境界色。已如摄事品中说。受蕴建立有六种。一差别建立。二出离建立。三观察建立。四生建立。五相建立。六师句建立

差别建立者。或立一受。如说诸所有受。悉皆是苦。或立二受。谓身受及心受。或立三受。谓乐受苦受不苦不乐受。或立四受。谓欲系色系无色系及不系受。或立五受。谓乐根苦根喜根忧根舍根。或立六受。谓眼触所生受。乃至意触所生受。或立十八受。谓十八意近行六喜近行六忧近行六舍近行。或立三十六受。谓六依耽嗜喜六依出离喜如喜忧舍亦尔。或立一百八受。谓三十六受。各依三世或开无量受。如其所受起无数受

出离建立者。谓初静虑出离忧根。第二静虑出离苦根。第三静虑出离喜根。第四静虑出离乐根。无相心法三摩地出离舍根。观察建立者。谓八种观察。于受何者是受。何者是受集。何者是受灭。何者是趣受集行。何者是趣受灭行。何者是受味。何者是受过。何者是受出离

生建立者。谓从十六触诸受生。何等十六。一眼触。二耳触。三鼻触。四舌触。五身触。六意触。七有对触。八增语触。九顺乐受触。十顺苦受触。十一顺不苦不乐受触。十二爱触。十三恚触。十四明触。十五无明触。十六非明非无明触。相建立者。谓八种相。一异熟相。二非异熟相。三有味着相。四无味着相。五依耽嗜相。六依出离相。七动相。八住相。异熟相者。谓阿赖耶识相应受。非异熟相者。谓转识相应受。有味着相者。谓欲系受。无味着相者。谓色无色系及不系受。依耽嗜相者。谓欲贪相应受。依出离相者。谓出家所引不定地善法相应受。动相者。谓经中风喻所显受。不久相续住义故。住相者。谓经中客舍喻所显受。暂相续住义故

师句建立者。谓三十六师句。六依耽嗜喜。六依出离喜。六依耽嗜忧。六依出离忧。六依耽嗜舍。六依出离舍

依耽嗜喜云何。谓于眼所识色可喜可乐可意可爱能引起欲深可染着。或由得现所得。或由随念先时所得而生于喜。如是相喜名依耽嗜喜

依出离喜云何。谓即于诸色了知无常苦变。离欲灭静没已。又于先及今所有诸色。了知无常苦变等法已而生于喜。如是相喜名依出离喜

如是于耳所识声鼻所识香舌所识味身所识触意所识法。可喜可乐可意可爱能引起欲深可染着。或由得现所得。或由随念先时所得而生于喜。如是相喜名依耽嗜喜。如是即于耳所识声乃至意所识法。了知无常苦变。离欲灭静没已。又于先及今所有诸法。了知无常苦变等法已而生于喜。如是相喜名依出离喜

依耽嗜忧云何。谓于眼所识色可喜可乐乃至可染。或由不得现所得。或由随念先时所得。若已过去若尽若灭若离若变而生于忧。如是相忧名依耽嗜忧

依出离忧云何。谓即于诸色了知无常乃至没已。又于先及今所有诸色。了知无常苦变等法已。于胜解脱起欲证愿。谓我何时当具足住如诸圣者所具足住处。如是于胜解脱欲证求愿惧虑之忧。是名依出离忧。如是于耳所识声乃至意所识法。可喜可乐乃至可染。或由不得现所得。或由随念先时所得。若已过去乃至若变而生于忧。如是相忧名依耽嗜忧

如是即于耳所识声乃至意所识法。了知无常乃至没已。又于先及今所有诸法。了知无常苦变等法已。于胜解脱起欲证愿。谓我何时当具足住如诸圣者所具足住处。如是于胜解脱欲证求愿惧虑之忧。是名依出离忧。依耽嗜舍云何。谓愚痴无智无闻异生。于眼所识色顾恋。于舍执着诸业趣。向于色依止于色。不舍于色不超过色。于此中舍。是名依耽嗜舍。依出离舍云何。谓即于诸色了知无常乃至没已。又于先及今所有诸色。了知无常苦变等法已简择修舍。是名依出离舍。如是愚痴无智无闻异生。于耳所识声乃至意所识法顾恋。于舍执着诸业趣向。于法乃至不超过法。于此中舍。是名依耽嗜舍。如是即于耳所识声乃至意所识法。了知无常乃至没已。又于先及今所有诸法。了知无常苦变等法已。简择修舍。是名依出离舍。是中六依耽嗜喜。六依出离喜。六依耽嗜忧。六依出离忧。六依耽嗜舍。六依出离舍。总摄为三十六师句

是中依止六依出离喜住故。舍除吐害六依耽嗜喜。如是依止六依出离忧住故。舍除吐害六依耽嗜忧。如是依止六依出离舍住故。舍除吐害六依耽嗜舍。又此中依止六依出离喜住故。舍除吐害六依出离忧。依止六依出离舍住故。舍除吐害六依出离喜。复有二种舍。一依种种性。二依一种性。依种种性舍者。谓依于色乃至依于法。依一种性舍者。谓依虚空无边处。乃至依非想非非想处。此中依止依一种性舍住故。舍除吐害依种种性舍

想蕴建立有三种。一依差别。二作意差别。三境界差别

依差别者。谓六想。身眼触所生想。乃至意触所生想

作意差别者。有二种。一有相想。二无相想。有相想者。谓除欲界中未善言说者想。第一有想及出世间想。余有相作意相应想。无相想者。谓前所除无相作意相应想

境界差别者。有四种。一小想。二大想。三无量想。四无所有想。如其次第缘欲界缘色界缘无色界缘无所有处想。应知

行蕴建立有三种。一胜差别。二依差别。三诸行施设差别

胜差别者。唯思最胜行蕴所摄。由造作心令成杂染及清净法转故

依差别者。谓六思。身眼触所生思。乃至意触所生思

诸行施设差别者有三种。一杂染施设。二清净施设。三分位施设。杂染施设者。谓烦恼及随烦恼。清净施设者。谓信等。分位施设者。谓生等心不相应行。即此三蕴法处所摄色及与无为。总名法界亦名法处

识蕴建立有三种。一种类差别。二依差别。三杂染清净差别

种类差别者有二种。一阿赖耶识。二转识。依差别者。谓六识身。问阿赖耶识于六识中何识所摄。答通六识所摄。藏彼种故由此识密记摄故。薄伽梵不为一切说。若善巧者。即由此随解。杂染清净差别者。如经中说。有贪心如实知有贪心。离贪心如实知离贪心。如是有嗔离嗔。有痴离痴。乃至广说

此中有三品心。一未发趣三摩地心。二已发趣而未得三摩地心。三已得三摩地心此复二种。一不清净心。二极清净心。第一品心者。谓或时起染污心。由贪等缠所缠故。或时起善无记心。远离贪等缠故。第二品心者。谓或时系心内静。或时失念驰散五欲。或时摄令静故。复为惛沉睡眠之所缠覆。或时为断彼故。复策心安置于胜净境。或时复于彼境不正安故。其心掉动。或正安故。心不掉动。或时未断沉掉盖故。于二分中俱不寂静。或断彼故。其心寂静。能得根本静虑作意故名定心。未得彼故名不定心。道究竟故名极修心。断究竟故名极解脱心翻彼二种。名不修心不解脱心始从定心。乃至于此是第三品心。应知。数者。由五种事总摄一切流转事故。何等五事。一所受用事。二能受用事。三受用执取事。四受用杂染事。五彼所依遍行法事。所受用者。谓色蕴。五种色根依执门故为所受用。诸色境界所缘门故为所受用。能受用者。谓受蕴。受用执取者。谓想蕴。受用杂染者。谓行蕴。彼所依遍行法者。谓识蕴。由计此识是受用者乃至是所杂染者故。即由是义次第得成。复由余五因缘建立次第。一由生起故。二由对治故。三由流转故。四由识住故。五由显了故

由生起故者。如经说。缘眼及色眼识得生。乃至缘意及法意识得生。此中初说色蕴次说识蕴。此二种蕴是诸心法之所依止。依此故起受等心法故。次经言。三事合故触。触为缘故受等法生。由此生起因缘说诸蕴次第。由对治故者。为对治四颠倒故。说四念住。四颠倒者。一于不净计净颠倒。二于苦计乐颠倒。三于无常计常颠倒。四于无我计我颠倒。此中先说色蕴。次后受蕴。次后识蕴。最后想行二蕴。如是由对治故说诸蕴次第

由流转故者。诸根境界为所依故能起二蕴。谓领纳境界及彩画境界。由此因缘能起受用。现法境界诸恼乱法。及能造作善不善业。由此因故能感后世生等苦恼。识蕴一种是所恼乱故最后说

由识住故者。谓四识住由彼次第起能住识。由显了故者。谓见补特伽罗已。先记识其色。是故先说色蕴。次由受蕴显彼贵贱苦乐。次由想蕴显彼如是名如是姓如是种类等。次由行蕴显彼如是愚痴如是聪慧。后由识蕴显彼内我差别。谓于前诸蕴中。所记识者。有苦乐者。所言说者。愚痴聪慧者。是名由显了故说诸蕴次第

复由依止二种事故建立次第。一资助我事。二自内我事。谓初依止身于诸境界。次受苦乐。次随说自他如是名如是姓如是种类等。次依此二集起一切法非法行。如是等名助我事。最后一蕴是内我事。应知

善巧者。成善巧品中当广说

想差别者。谓有色无色。有见无见。有对无对。有漏无漏。有为无为如是等。问何义几种是有色。答即以有色自体义故。一蕴是有色。问何义几种是有见。答眼所行义故。一少分是有见。问何义几种是有对。答更相触对各据处所及粗义故。一少分是有对。言粗义者。离三种细。何者为三。一损减细。二种类细。三心自在转细。问何义几种是有漏。答粗重随逐故与诸烦恼互依生义故。一切少分是有漏。复有余有漏义。谓若处烦恼于中能起四种过。是处名有漏。何等为四。一不寂静过。二内外变异过。三发起恶行过。四因摄受过。此中初过。谓诸缠现行所作。应知。第二过。谓烦恼所依缘事随顺烦恼所作。应知。第三过。谓由烦恼所作。应知。第四过。谓牵引后有。应知问何义几种是有为。答从因已生正生可生义故。一切是有为。问何义几种是有诤。答嗔多分自在转义故。一切少分是有诤。问何义几种是有味着。答爱见多分自在转义故。一切少分是有味着。问何义几种是依耽嗜。答欲贪多分自在转义故。一切少分是依耽嗜。问何义几种是世间。答言论所依义故。一切少分是世间。问何义几种是界摄。答三界中世间义故。一切少分是界摄。问何义几种是过去。答因果已受用尽义故。一切少分是过去。问何义几种是未来。答因果未受用尽义故。一切少分是未来。问何义几种是现在。答因已受用尽果未受用尽义故。一切少分是现在。问何义几种是内。答内六处及彼不相离义故。四全一少分是内。问何义几种是外。答翻内义故。一少分是外。问何义几种是粗。答不细滑聚集充满相义故。一切少分是粗。问何义几种是细。答翻粗义故。一切少分是细。问何义几种是劣。答无常苦不净染污义故。一切少分是劣。问何义几种是胜。答翻劣义故。一切少分是胜。问何义几种是远。答处所及过去未来时遥义故。一切少分是远。问何义几种是近。答翻远义故。一切少分是近。问何义几种是欲界系。答若生于此未得对治。或得已出三时现行义故。一切少分是欲界系。问何义几种是色界系。答已得色界对治。若住彼定若生于彼。未得上地对治。或得已出三时现行义故。一切少分是色界系。问何义几种是无色系。答已得无色对治。若住彼定若生于彼。未得上地对治。或得已出三时现行义故。一切少分是无色系。复有余义。谓安俱定不相应共有法及彼果法所摄义故。是欲界系依色烦恼及翻前所摄义故。是色界系。已离色界所余烦恼。及如前所摄义故。是无色系。应知。问何义几种是善。答感后乐果义。烦恼苦断义。及彼对治义故。一切少分是善。问何义几种是不善。答感后苦果义。及起恶行义故。一切少分是不善。问何义几种是无记。答彼俱相违义故。一切少分是无记。复有余义。谓无过失义。对治过失义。随顺功德义故是善。与此相违义故是不善。彼俱相违义故是无记。问何义几种是学。答方便修学善义故。一切少分是学。问何义几种是无学。答修学究竟善义故。一切少分是无学。问何义几种是非学非无学。答除前二种余善染污无记所摄义故。一切少分是非学非无学。问何义几种是见所断。答由现观智现观谛所断。义故。一切少分是见所断。问何义几种是修所断。答由现观智现观谛后修道所断义故一切少分是修所断。问何义几种是无断。答究竟对治一切染污义及一切染污永断义故。一切少分是无断。问何义几种是无色乃至广说。答翻前所说色等义故。是无色等义。应知

显扬圣教论卷第五显扬圣教论卷第六

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之二

论曰。如是广说世俗谛已。胜义谛云何。颂曰

  五三法真实　　彼复四应知
  及四种寻思　　四种如实智

论曰。五法者。一相二名三分别四真如五正智。相者。若略说。谓一切言说所依处。名者。谓于诸相中依增语。分别者。谓三界所摄诸心心法。真如者。谓法无我所显圣智所行一切言说。所不依处。正智者。略有二种。一唯出世间。二世间出世间。唯出世间正智者。谓由正智声闻独觉诸菩萨等通达真如。又诸菩萨以世出世智。于五明处精勤学时。由遍满真如智多现在前故。速疾证得所知障净。世间出世间正智者。谓诸声闻及独觉等初通达真如已。由初一向出世间正智力。后所得世间出世间正智故。于诸安立谛中起厌怖三界心。及爱味三界寂静处。又由彼正智多现在前故。速疾证得烦恼障净

三法者。谓三自体。一遍计所执自体。二依他起自体。三圆成实自体。遍计所执自体者。谓依名言假立自体为欲。随顺世间言说故。依他起自体者。谓从缘所生法自体。圆成实自体者。谓诸法真如圣智所行圣智境界。圣智所缘为欲。证得极清净故。为令一切相及粗重二缚得解脱故。为欲引发诸功德故

彼复四应知者。彼真实复有四种。一世间真实。二道理真实。三烦恼障净智所行真实。四所知障净智所行真实

世间真实者。谓一切世间于诸事中由串习所得悟入智见。共施设世俗性。如于地谓唯是地非火等。如是于水火风色声香味触饮食服乘诸庄严具及诸什物香鬘涂饰歌舞音乐众朋男女威仪诸行田宅财物及苦乐等。于苦谓苦非乐。于乐谓乐非苦。又若略说者。谓此是此非彼。如是谓彼是彼非余。若事世间有情决定胜解所行。一切世间自昔传来名言决定自他分别。共为真实非邪思构。观察所取。是名世间真实

道理真实者。谓正智者有道理义。诸聪睿者。诸黠慧者。诸推求者。诸审察者。住寻思地者。具自辩才者。处异生位者。随观察行者。依现比至教三量。极善决择智所行所知事。以证成。道理所建立故。是名道理真实

烦恼障净智所行真实者。谓一切声闻独觉无漏方便智。无漏正智。无漏后所得世间智等所行境界。是名烦恼障净智所行真实。由缘此故。于烦恼障智得清净。及后证住无障碍性。是故说为烦恼障净智所行真实。问此中何者是真实。答谓苦集灭道名之所显四种圣谛。由简择如是四圣谛故。得入现观位。于现观位中真实智生

所知障净智所行真实者。谓于所知中能碍智故名所知障。若真实性是解脱所知障智所行境界。是名所知障净智所行真实。应知。此复云何。谓诸菩萨佛薄伽梵为入法无我及已入极清净者。依一切法。离言说自性。假说自性。无分别平等智所行境界。谓最胜真如无上所知究竟性。此性一切正法简择。不能回转不能过越。是名所知障净智所行真实

四种寻思者。一名寻思。二事寻思。三自体假立寻思。四差别假立寻思。名寻思者。谓诸菩萨于名唯见名。事寻思者。谓诸菩萨于事唯见事。自体假立寻思者。谓诸菩萨于假立自体唯见假立自体。差别假立寻思者。谓诸菩萨于差别假立唯见差别假立。是名差别假立寻思。此诸菩萨于名事二种。或离相观。或合相观。依名事合观故。通达自体假立差别假立

四种如实智者。一名寻思所引如实智。二事寻思所引如实智。三自体假立寻思所引如实智。四差别假立寻思所引如实智

名寻思所引如实智者。由诸菩萨于名寻思唯有名已。于名如实了知。谓此名为此义故。于此事中建立。为令世间起想见言说故。若于色等所想事中。不为建立色等名者。一切世间无有能想此事。是色等若无想者。无有能起增益执着。若不执着则无言说。若如是如实了知。是名第一名寻思所引如实智。事寻思所引如实智者。由诸菩萨于事寻思唯有事已。如实了知色等所想事性。离一切言说不可言说。是名第二事寻思所引如实智

自体假立寻思所引如实智者。由诸菩萨于色等所想事假立自体中寻思唯假立。故如实通达假立自体。非实彼事自体而似彼事自体显现。又能了知彼事自体犹如变化影像响应光影水月焰水梦幻似有体性。是名第三自体假立寻思所引甚深义所行境如实智

差别假立寻思所引如实智者。由诸菩萨于差别假立寻思唯假立性故。于色等所想事差别假立中。善能通达不二之义。谓彼诸事非有性非无性。由可言说自体不成就故。非有性由不可言说自体成就故。非无性如是非有色犹胜义谛故。非无色由世俗谛中假立色故。如有性无性有色无色。如是有见无见等诸差别假立法门。彼一切由是理趣尽应知。若能如实了知差别假立如是不二之义。是名第四差别假立寻思所引如实智。如是显了所入事能入因及能入已。复次颂曰

  三自体成立　　差别业隐密
  方便摄别异　　是各有多种

论曰。彼三种自体成立差别业用隐密方便摄别异。应知各有多种。成立多种者。如成无性品中当广说

差别者。问遍计所执自体有几种。答如依他起自体中所有假立自体差别。如是遍计所执自体。是故遍计所执自体无有限量。应知。复次于依他起自体中有二种遍计所执自体分别。谓随胜觉及随数习习气随眠。问依他起自体有几种。答即如诸相多种差别。应知。谓色相心相心法相心不相应相如是等。复次若略说有二种。依他起自体谓遍计所执自体分别所起及非分别所起。问圆成实自体有几种。答圆成实自体于一切处一味故。不可建立。差别

业者。问遍计所执自体能作几业。答有五种。一能生依他起自体。二即于是中起诸言说。三能生众生执。四能生法执。五能摄受二执习气粗重。问依他起自体能作几业。答有五种。一能生诸杂染体。二能为遍计所执自体及圆成实自体所依。三能为众生执所依。四能为法执所依。五能为二执习气粗重所依。问圆成实自体能作几业。答有五种。谓能为二种。五业对治生起所缘性故

隐密者。谓当随三种自体义解释一切不了义经。由无量经中一切如来隐密语言。及一切菩萨隐密语言。皆随三种自体方可悟入彼义故。问如经中说。三解脱门彼云何建立。答由三自体故。谓由遍计所执自体故建立空解脱门。由依他起自体故建立无愿解脱门。由圆成实自体故建立无相解脱门。问如经中说无生法忍。彼云何建立。答由三自体故。谓由遍计所执自体故说本来无生忍。由依他起自体故说自然无生忍。由圆成实自体故说烦恼苦垢无生忍。此三种忍在不退转地。应知。由如是等差别义故。于余一切隐密语言。皆应随三自体解释。应知

方便者。谓了知如是三种自体。能作一切声闻独觉无上正等菩提方便

摄者。谓三种自体及相名分别等五事相摄。问如是五事初自体几事摄。答无。问第二自体几事摄。答四。问第三自体几事摄。答一。别异者。谓遍计所执自体。唯正应知。依他起自体。应知及应断。圆成实自体。应知及应作证。如是悟入俗谛胜义谛已。复次颂曰

  闻十二分教　　三最胜归依
  三学三菩提　　为有情净说

论曰。闻十二分教者。谓闻契经应颂记别讽颂自说缘起譬喻本事本生方广未曾有法论议圣教。契经者。谓诸经中佛薄伽梵于种种时处。依种种所化有情调伏行差别。或说蕴所摄法。界所摄法。处所摄法。或说缘起所摄法。或说食所摄法。谛所摄法。或说声闻独觉如来所摄法。或说念住正断神足根力觉支道支所摄法。或说不净息念学证净等所摄法

如来说是语已。诸结集者。欢喜敬受。为令圣教得久住故。以诸善妙名句字身。如其所应次第结集。次第安置。以能缀缉引诸义利引诸梵行种种善义。故名契经

应颂者。谓诸经中。或于中间。或于最后。以颂重显。及诸经中不了义说。是为应颂

记别者。谓诸经中记诸弟子命终之后生处差别。及诸经中显了义说。是为记别

讽颂者。谓诸经中非长行直说。然以句结成。或二句或三句或四句或五句或六句。是为讽颂

自说者。谓诸经中不列请者姓名。为令正法久住故。及为圣教久住故。自然宣说。是为自说

缘起者。谓诸经中列请者姓名已而为宣说。及诸所有毗柰耶摄有缘起教别解脱戒经等。是为缘起

譬喻者。谓诸经中有譬喻说。由譬喻故本义明白。是为譬喻

本事者。谓宣说前世诸相应事。是为本事。本生者。谓诸经中宣说如来于过去世处种种生死行菩萨行。是为本生

方广者。谓诸经中宣说能证无上菩提诸菩萨道。令彼证得十力无障智等。是为方广。未曾有法者。谓诸经中宣说诸佛及诸弟子比丘比丘尼式叉摩那沙弥沙弥尼邬波索迦邬波私迦等共不共功德。及余最胜殊特惊异甚深之法。是为未曾有法

论议者。谓一切摩怛履迦阿毗达磨。研究解释诸经中义。是为论议

如是十二分教中具有经律阿毗达磨藏。此中所说契经应颂记别讽颂自说譬喻本事本生方广未曾有法是为经藏。此中所说缘起是为律藏。此中所说论议是为阿毗达磨藏

三最胜归依者。谓佛法僧三种归趣。三学者。谓增上戒学。增上心学。增上慧学。三菩提者。谓声闻菩提。独觉菩提。无上正等菩提

为有情净说者。为令有情得清净故。次第宣说是三种法。谓能持方便果。能持者。谓闻及归依。方便者。谓三学。果者。谓三菩提。复次如是闻等。云何分别。应知。颂曰

  闻归学菩提　　六三十二五
  随名数次第　　如应广分别

论曰。闻六种分别者。一依处。二依摄。三依清净。四依行。五依理趣。六依义。依处者。谓依五明处。一内明处。二因明处。三声明处。四医方明处。五工业明处

依摄者。有二种。谓声闻藏摄。菩萨藏摄

依清净者。谓十种清净说清净有五。一善说者说故。二显了文句说故。三尽所知义如所知义说故。四易方便修行说故。五能出离一切苦说故。听清净有五。一不以求过意听故。二以求涅槃意听故。三极善谛听故。四依名句字身义极善分别听故。五以正修行意听故

依行者。谓十种法行

依理趣者。有六种理趣。谓真义理趣。乃至意乐理趣。此中前三理趣由后三理趣随释。应知。谓由离二边理趣随释真义理趣。由不思议理趣随释证得理趣。由意乐理趣随释教导理趣。此中真义即是理趣。故名真义理趣。乃至意乐即是理趣。故名意乐理趣。于彼彼处无颠倒性。是理趣义

真义理趣者。略有六种。应知。谓世间真实。乃至所知障净智所行真实。及安立真实非安立真实。此中前四种真实。如前分别。应知。安立真实者。谓四圣谛。苦真苦。故安立为苦。乃至道真道。故安立为道。问何因缘故名为安立。答由三种俗所安立故。一由世间俗。二由道理俗。三由证得俗。世间俗者。谓安立田宅瓶盆军林数等。及安立我有情等。道理俗者。谓安立蕴界处等。证得俗者。谓安立预流果等。及安立彼所依住法。复有四种安立。谓前三种及由胜义俗安立胜义谛性不可安立。由内自所证故。为欲随顺引生彼智。依俗安立。非安立真实者。谓一切法真如实性

证得理趣者。略有四种。一一切有情业报证得。二声闻乘证得。三独觉乘证得。四大乘证得

一切有情业报证得者。谓一切有情造作净不净业。依自业故于五趣流转中。感种种异熟。受种种异熟

声闻乘证得者。谓初受三归乃至依止。闻庄严故得五证得。一地证得。二智证得。三净证得。四果证得。五功德证得。地证得者。谓得三地。一见地。二修地。三究竟地。智证得者。谓得九智。一法智。二种类智。三苦智。四集智。五灭智。六道智。七此后所得俗智。八尽智。九无生智。净证得者。谓四证净果。证得者。谓四沙门果。功德证得者。谓无量解脱胜处遍处无诤愿智无碍解神通等功德。复次声闻乘证得中证得依止者。谓先修世间道离欲。次修顺解脱分善根。后修顺决择分善根

独觉乘证得者。略有三种。一由先已得顺决择分善根故。二由先已得无漏真证故。三由次第得故。此中由前二证得者。名非独胜觉。由后证得者。名犀角喻觉

大乘证得者。谓大悲证得。发心证得。波罗蜜多证得。摄事证得。地证得。于五无量中随至真如证得。不思议威德证得。不共佛法证得。彼一切如前分别应知

教导理趣者。谓略有三处所摄。一藏所摄。二摩怛履迦所摄。三彼俱所摄。藏所摄者。谓声闻乘藏及大乘藏。摩怛履迦所摄者。谓十七本地及四种摄彼俱所摄者。谓略有十种。如前分别义中十种义。应知。此为摄。前一切藏所摄。及摩怛履迦所摄。故名为总。略摩怛履迦

复有十二种教。一事教。谓宣说各别色等眼等一切法教二想差别教。谓宣说蕴界处缘起是处非处诸根诸谛念住有色无色有见无见有对无对等。如是广说。无量佛薄伽梵想差别教。三自宗观察教。谓契经应颂记别等教。依摄释中之所显示。四他宗观察教。谓依七种因明摧伏他论成立自论教。七种因明者。谓论体论处所等。后当分别。五不了义教。谓契经应颂记别等中。薄伽梵略摽其义。未广分别。应更开示教。六了义教。谓翻前应知。七俗谛教。谓诸所有言路显示。彼一切皆名俗谛。又依名想言说增上所起相名分别。亦是俗谛。八胜义谛教。谓四圣谛教。及真如实际法性教。九隐密教。谓多分声闻藏教。十显了教。谓多分大乘藏教。十一可记事教。如四种法嗢拖南教。谓一切行无常乃至涅槃寂静。如是等教。十二不可记事教。谓有问言。世间为常为无常耶。如来尔时默然不记。但告彼言。我说此事不可记别。乃至问言。如来灭后为非有非无耶。如来尔时默然不记。但告彼言。我说此事不可记别。此中四因缘故。宣说不可记事。应知。一无体性故不可记别。如有问言。我与诸蕴为异不异为常无常如是等。二能引无义利故不可记别。如升摄波叶经说。有无量法我已证觉。而不宣说。何以故。彼法能引无义利故。三甚深故不可记别。谓有问言。我为有为无耶。此不可记别。何以故。若如来记别我有者。彼人或执蕴中有我。或执离蕴有我。若记别我无者。彼人或谤世俗言说。我亦是无乃至有问。如来灭后为有为无亦有亦无非有非无等。由甚深故皆不记别。四彼相法尔故不可记别。谓诸法真如与彼诸法若一若异不可记别。由彼如相法尔不可安立。若异性若不异性故。复有四种因缘如来宣说不可记别事。应知。一由此事外道所说故。二不如理故。三不引义利故。四唯能发起诤论缠故。有二因缘不引义利。应知。一远离因果思惟故。二远离杂染清净思惟故

离二边理趣者。略有六种。应知。一远离于不实有增益边。二远离于真实有损减边。三远离执常边。四远离执断边。五远离受用欲乐边。六远离受用自苦边

不可思议理趣者。略有六种不可思议事。一我不可思议。二有情不可思议。三世间不可思议。四一切有情业报不可思议。五证静虑者及静虑境界不可思议。六诸佛及诸佛境界不可思议

意乐理趣者。略有十六种意乐。一开示意乐。二离欲意乐。三劝导意乐。四奖励意乐。五赞悦意乐。六令入意乐。七除疑意乐。八成熟意乐。九安定意乐。十解脱意乐。十一依别义意乐。十二发证行者无过欢喜意乐。十三令闻行者于说法师起尊重意乐。十四法眼流布意乐。十五善增广意乐。十六摧坏一切相意乐

依义者谓不了义及了义

归三种分别者。一成就。二建立。三差别。成就者。唯佛法僧是真归依。非余天等。何以故。由二因故。一无所能为故。二不现见故

云何无所能为。谓诸天神不能为诸众生作利益事。此诸天神或无能故。或待敬事故。或不忍疲苦故。或无慈悲故。或有障碍故。如是一切非真归处。谓无能故。堕偏党故。避自疲苦无自在故。无哀愍故。德微劣故

云何不现见。谓诸天神非现证见。世间未见不现见主能为所依。除可依信现摄受他。余现见依所不见故。问梦中见故应是归依。答欲想所见或实不实。又复觉时何不现见。虽于梦中少见实相。此亦欲想所作。又众缘现前令处梦者少有所见。此亦多虚。复次由五种因诸天神等非归依处。何等为五。一由相故。二由体故。三由业故。四由法尔故。五由因果故

由相故者。谓诸天神世不现见无谈论故。容色奋发有怖畏故。染习放逸有贪爱故。舍他利益无悲愍故。不能解了作与不作不达实义故。不可归依。云何相故佛可归依。谓世间现见有谈论故。容色和静无怖畏故。远离放逸无贪爱故。不舍利他有大悲故。善能解了作与不作通达实义故。复由五相佛可归依。何等为五。为利有情证大菩提故。现处大众开正法眼故。怨亲有情平等利益故。于诸家室摄受。舍离贪着诸根寂静故。善除一切众生疑网故

由体故者。谓由如来永断诸漏。自既调御亦调御他故可归依。诸天神等具诸漏故。尚不自调御。况调御他。故非归处

由业故者。谓如来安住广大无垢静虑等业。又复能为利众生业故可归依。诸天神等安住秽下受用欲业。又有杀害诸众生业。故非归处

由法尔故者。谓一切世间及出世间功德胜利。皆依自己功用所得。若离自己功用。虽于天神起深敬信亦不能证设于天神不生敬信。但自用功必能证得。是故天神非归依处。由因果故者。今问事天神者。天神体性。为由天业感得。为由供养天得。为无因得。若天业得者。即应归业。非天若无因得者。应归无因。非天若供养天神得者。为唯因供养感天神体为唯因天神为因二种。若唯因供养者。即徒事天神随处供养。皆应能感天报。若唯因天神者。即徒设供养。虽不供养。但由天神应得天报。若俱因二种者。但设供养天神摄受。诸所祈愿悉应果遂。又于七种所祈愿事不定果遂。是故不然。一于供养缘摄受。二于信解缘摄受。三于信解彼者。发起信解能感最胜天神自体。四于能感最胜所受富乐。五于摧坏阿素洛等怨敌。六于出生。七于终没建立者。问有几种归趣。答三种归趣。谓佛法僧。问何因唯有三种归趣。答由四因故。唯有如来是可归趣。谓善自调故。善解一切种调伏方便故。以财供养不悦意故。以行供养悦可意故。由具此德彼所说法及弟子众亦可归依。问齐何当名能归趣耶。答具四因故。名能归趣。一善知有德故。二善知差别故。三自誓受故。四更不余归趣故。问归趣行云何。答有四种归趣正行。应知。一亲近善人。二听闻正法。三如理作意。四法随法行。复有四种正行。应知。一善摄诸根令不掉动。二受正学处。三悲愍众生。四时时如法供养三宝。问归趣三宝有何利益。答有四种利益。一得广大功德。二得广大欢喜。三得胜等持。四得善清净。复有四种利益。一大护具足。二一切邪解障碍渐得微薄遍尽灭没。三得入聪慧正至善人众中。所谓大师同梵行众。四为信圣教诸天之所爱乐。彼诸天等若见有受三归趣者。生大欢喜展转相告。我等往昔皆由成就三归趣故。从彼命终来生此间。是善男子等今亦成就此三归趣多住不舍。不久当来为我等伴

差别者。谓由六种因故三宝差别应知。一由相故。二由业故。三由信解故。四由行故。五由随念故。六由生福故。由相故。差别者。自证觉相是佛宝。证觉果相是法宝。由随他教正修行相是僧宝。由业故差别者。转正说业是佛宝。烦恼苦断所缘境业是法宝。增勤勇业是僧宝。由信解故差别者。谓于佛宝应亲近敬事。于正法宝应信敬作证。于诸僧宝应同法共住敬信亲近。由行故差别者。谓于佛宝应起延请迎接承事供养行。于正法宝应起如理方便修习行。于诸僧宝应起互共受用财法行。由随念故差别者。于三宝所应各起别行随念。如经中说。此薄伽梵如来应正等觉。乃至广说。由生福故差别者。谓于佛宝依一有情生最胜福。于正法宝依增上法生最胜福。于诸僧宝依多有情生最胜福

显扬圣教论卷第六显扬圣教论卷第七

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之三

论曰。学十二种分别者。一差别分别。二生起分别。三转异分别。四能治所治分别。五能引胜生定胜分别。六顺法分别。七补特伽罗分别。八下中上分别。九瑜伽分别。十作意分别。十一引发分别。十二问答分别

差别分别者。谓分别三学差别增上戒学。差别者如经中说。若诸比丘尸罗成就住。守别解脱律仪轨则所行悉皆具足。于微细罪深见怖畏。受学学处名具戒者

此中尸罗成就住者。谓于所受学处身业无犯语业无犯不破不穴。如是尸罗成就住

守别解脱律仪者。谓七众尸罗名别解脱律仪。即此尸罗众差别故。建立多种律仪。此中义者。唯依比丘律仪相说。是名守别解脱律仪

轨则具足者。谓或于威仪。或于所作。或于方便。修善品中轨则具足。随顺世间不违世间。随顺毗柰耶不违毗柰耶

云何于威仪中轨则具足。随顺不违世间及毗柰耶。谓若是时是处应行。及如是应行。即于是时是处如是正行。不为世间诃责讥毁。及不为聪慧正至善人同法者持律者学律者诃责讥毁。如行住坐卧亦如是知

云何于所作中轨则具足。随顺不违世间及毗柰耶。谓着衣服大小便利用水齿木入村乞食回还受用洗钵安置洗足敷具。又复略作钵业衣。及余所有如法作业。是名所作。如其所应。若是时是处。应作及如是应作。即于是时是处如是正作。不为世间诃责讥毁。及不为聪慧正至善人同法者持律者学律者诃责讥毁。是名于所作中轨则具足随顺不违世间及毗柰耶

云何于方便修善品中轨则具足。随顺不违世间及毗奈耶。谓读诵经典和敬师长。修承事业瞻侍疾患。互起慈心与欲宣说。方便修习。请问听法精勤无堕。于诸聪慧同梵行者躬自供事。奖劝他人修行善品。及为宣说深妙之法。入静密处结加趺坐。诸如是等及余善法。是名方便修诸善品。如是于方便修习。如所说善品中。若是时是处应修及如是应修。即于是时是处如是正修。由如是修故。不为世间诃责讥毁。及不为聪慧正至善人同法者持律者学律者诃责讥毁。是名方便修善品中轨则具足随顺不违世间及毗柰耶。若如是相轨则具足。是名轨则具足

所行具足者。谓五处非比丘所行。何等为五。一唱令家。二淫女家。三酤酒家。四王宫。五旃荼罗羯耻那家。及如来余所制不应行处。除此余是所行。如是以时行无过处。是名所行具足

于微细罪深见怖畏者。谓犯小随小学处犯已可出者。皆名微细罪。复次若犯已少用功出者。名微细罪。若于此中深见怖畏。谓勿令我因此犯故便不堪任得所未得悟所未悟证所未证。勿复令我堕于恶趣起恶趣行。勿复令我后自悔责。勿为大师诸天聪慧同梵行者以法诃责。又勿令我恶名称等流布十方。因见如是现法后法。不可乐事深生怖惧。为如是故。于小随小学处乃至命难因缘。终不故犯。设复失念。或时犯已。疾疾悔过如法而出。如是名为于微细罪深见怖畏

受学学处者。谓先受别解脱律仪时。由白四羯磨受具足故。略已得闻学处体性及于别解脱经所说过一百五十学处。唯自誓受我当尽学一切学处。复从邬波柁耶阿遮利耶及诸共谈论者。互问难者。数习近者。善同意者所。数数闻已。又半月半月闻说别解脱经。由如是受一切学处故。名得别解脱律仪。从是已后于诸所善学处无有毁犯。设有毁犯即如法出。若于先所誓受学处不善不达者。应如先所受。复于邬波柁耶阿遮利耶等所。数数请问听受令善达解。如尊所说不增不减。善修学已又无倒受持。若文若义。如是名为受学学处

如是广说尸罗律仪差别已。若略说彼义者。谓此中薄伽梵以三种相显了戒蕴。一无失坏相。二自体相。三自体功德相。此中如前所说。尸罗成就住者。此显尸罗律仪无失坏相。次言守别解脱律仪者。此显自体相。复言轨则所行悉具足者。此显如所受别解脱律仪观他增上功德名称相。何以故。由他见此轨则所行具足相故。未信者信。已信者增长。由未信者依此信故。心无轻毁无恶名闻。若不尔者。虽具足尸罗。由越轨则所行故。则无观他增上德称。若翻于此则无过失。后言于微细罪深见怖畏受学学处者。此显观自增上功德名称相。何以故。虽复轨则所行具足故得观他增上功德名称。然毁尸罗已。由此因缘或生恶趣。或不堪任得所未得悟所未悟证所未证。若能于微细罪尚见怖畏。何况上品。又受学学处。由此因缘。身坏命终生于善趣。又复堪任得所未得悟所未悟证所未证。以是缘故。名尸罗律仪观自增上功德名称相

复次此中薄伽梵显三种尸罗性。一受尸罗性。二出离尸罗性。三修习尸罗性。初说尸罗成就住者。此显受尸罗性。次说守别解脱律仪者。此显出离尸罗性。何以故。由别解脱律仪所摄尸罗。说名增上戒学。依增上戒学故。能修增上心学及增上慧学。由依此故。能令一切苦永尽出离。如是出离。先依尸罗行然后方得。是故别解脱律仪。说为出离尸罗性。后说轨则所行悉皆具足。于微细罪深见怖畏。受学学处者。此显修习尸罗性。若依如是相修习别解脱律仪尸罗者。是名修习善修习。如是名为增上戒学差别分别

增上心学差别分别者。若比丘离欲恶不善法有寻有伺离生喜乐初静虑具足住。复寻伺寂静内遍净心一趣性无寻无伺三摩地生喜乐第二静虑具足住。复离喜故住舍念正知身受乐圣者宣说有舍念乐住第三静虑具足住。复断乐先已断苦及喜忧没不苦不乐舍念清净第四静虑具足住。此差别义如前已说。是名增上心学差别分别。增上慧学差别分别者。若比丘于苦圣谛如实知苦。于集圣谛如实知集。于苦灭圣谛如实知灭。于苦灭趣行圣谛如实知趣行。是名增上慧学差别分别

生起分别者。谓由尸罗成就故。无悔由无悔故。生悦生悦故。心喜心喜故。身安身安故。受乐受乐故。心定心定故。观如实观如实故。起厌起厌故。离欲离欲故。解脱解脱故。自谓我证解脱。复起如是智见。我生已尽梵行已立所作已办不受后有

转以分别者。谓或有增上戒学无增上心无增上慧。或有增上戒学增上心学无增上慧。若有增上慧学。必有增上戒及增上心

能治所治分别者。谓增上戒学是烦恼缠。止息对治。增上心学是烦恼缠。制伏对治。增上慧学是烦恼随眠。永断对治。能引胜生定胜分别者。谓增上戒学增上心学能引清净地及清净胜生。增上慧学能引出世决定胜德

顺法分别者。谓十种随顺学法。一先因。二顺教。三如理方便。四无间殷重修。五猛利乐欲。六修持力。七身心粗重安息。八数数观察。九无怯怖。十无增上慢。先因者。谓先世根熟及根成满。顺教者。谓无倒次第之教。如理方便者。谓如教修行。如是修时能生正见。无间殷重修者。谓如是方便时无空过。修习善品及至诚。速疾引发善品。猛利乐欲者。谓于增上解脱起证乐欲念。我何时证于众圣具足住处。修持力者。谓二因缘得修持力。一性利根故。二长时纯熟修故。身心粗重安息者。若由身疲倦起身心粗重。则易夺威仪令得安息。若由极寻伺起身心粗重。则内修寂静令得安息。若由励意极摄敛心及沉下心惛沉睡眠缠起身心粗重。则修慧观及净胜作意令得安息。若由自性未断烦恼顺烦恼品身心粗重随逐不离。则正修圣道令得安息。数数观察者。谓依尸罗数数观察。恶作善作如实了知。若于恶作不为不应舍离。若于善作不为则应舍离。若于恶作为之则应舍离。若于善作为之不应舍离。如是观察作意增上力故数数观察。一切烦恼已断未断。若知已断应深庆悦。若知未断数数应修此对治道。无怯怖者。谓于时时中应知应观。于法由不知不观不证入故。生于怯怖。心有萎悴心有虚乏。如是数数生时。心不执着除断弃舍。无增上慢者。谓于所得所悟所证中。离增上慢不颠倒执。于已得中起已得想。于已悟中起已悟想。于已证中起已证想。如是十法乐正修行诸学处者。由初中后随顺学处。是故名为随顺学法。此十法中先因一种随顺增上戒学最胜。余之九种随顺增上心学增上慧学最胜

补特伽罗分别者。谓此三学通诸异生及见谛者。下中上品分别者。谓由行故。及方便故。由行故者。谓苦迟通行名下品学。苦速通行及乐迟通行名中品学。乐速通行名上品学。由方便故者。不殷重方便及不无间方便修者。名下品学。随一方便修者。名中品学。具二方便修者。名上品学

瑜伽分别者。谓依四种瑜伽正学学处。一信。二欲。三正勤。四方便

信者。谓二行相及二依处。二行相者。一忍可行相。二清净行相。二依处者。一观法道理依处。二信解人威德依处。欲者有四种欲。一为证得欲。二为问论欲。三为证资粮欲。四为方便修欲。为证得欲者。如一行者于上解脱起证乐欲。广说如前。为问论欲者。如一行者起证欲已。趣僧伽蓝中。诣有识者。同梵行者。正行智者所。为闻所未闻。及已闻者明净故。为证资粮欲者。如有行人于尸罗律仪清净中。饮食知量中。觉悟方便中。正知住中。及进上中。起证乐欲。为方便修欲者。谓于无间方便中。殷重方便中。修圣道中。生希求作证乐欲

正勤者。谓四种正勤。一为闻法故。二为思惟故。三为修习故。四为障净故。为闻法故者。谓为闻所未闻。及已闻者明净故。策励于心方便修习所未委处。为思惟故者。如所闻法独在静处。思惟称量观察其义。为修习故者。谓处静室数修止观。为障净故者。谓为净诸盖昼夜精勤经行宴坐。策励于心方便修习所未委处

方便者。亦有四种。谓守护尸罗及守护诸根增上力故。令根律仪清净善住于念。由善住念故得不放逸。守护于心修习善法。由不放逸故。令其内心与止相应。及得增上慧观察诸法。如是四种瑜伽分为十六行。此中由信故。信当得义。由信当得义故。于诸善法起修作欲。由修作欲故。昼夜精勤。住于策励坚固勇猛。由正勤故。摄修方便为令得所未得义故。悟所未悟义故。证所未证义故。是故此四种法。说名瑜伽

作意分别者。谓了相等七种作意。了相作意者。由作意故。了达欲界粗相及初静虑静相。云何了达欲界粗相。谓六种寻思诸欲过失。一义。二事。三相。四品类。五时。六道理

寻思义者。谓寻思诸欲多诸过患多诸累恼多诸疫疠多诸灾横如是诸欲多诸过患。乃至多诸灾横。是为粗义寻思。事者。谓或于内诸欲起于贪欲。或于外诸欲起于贪欲

寻思相者。谓寻思自相及共相。寻思自相者。谓此是烦恼欲。此是事欲。如是诸欲或随顺乐。或随顺苦。或复随顺不苦不乐。随顺乐者。是贪欲依处及想心颠倒依处。随顺苦者。是嗔恚依处及忿恨依处。随顺不苦不乐者。是覆恼诳谄无惭无愧依处及见倒依处。如是诸欲或暴恶受之所随行。或不暴恶受之所随行。如是名为寻思诸欲自相寻思。共相者。谓寻思诸欲生苦乃至求不得苦。平等平等随逐随缚。受用欲者。虽复诸欲广备。亦应解了是生苦等法。此广备欲须臾变坏。如是名为寻思诸欲共相

寻思品类者。谓寻思诸欲堕黑品类。如连锁枯骨。如秽段肉。如草炬火。如一分炭火。如蟒毒蛇如梦所见。犹如假借庄严之具。如树抄果。又复寻思一切有情受追求所作苦。受亲爱离坏所作苦。受无厌足所作苦。受不自在所作苦。受恶行所作苦。又薄伽梵言。我说习近诸欲有五过患。一诸欲。少味。二习近欲者。多诸苦恼多诸过患。三习近欲者。无厌无足无休无息。四习近欲者。诸结增长。五习近欲者。无恶不造。又复聪慧正至善人。以无量门诃责诸欲。谓此诸欲增染无厌。众所共有非法颠倒。诸恶行因增长欲爱。智者舍远速疾散坏。依于诸缘放逸之地。其性无常为空为虚。诳失之法如幻如化诱诳愚夫。若现法欲。若后法欲。若天上欲。若人间欲。一切皆是魔之所行魔所住处。又依彼欲能令心生无量种种恶不善法。谓贪嗔恨等诸障碍法。诸圣弟子学学处时能为障碍。由如是等差别过失多分寻思诸欲堕黑品类。如是名为寻思品类

寻思时者。谓于去来今世常恒相续。寻思诸欲多诸累恼多诸灾横多诸过患。如是名为寻思于时

寻思道理者。谓此诸欲由大资具由大追求由大劳倦。复由种种杂功业处方得圆备成立增长。虽复如是外资生物增长成满。然其法尔速疾散灭。又复父母妻子奴婢诸作业者朋友官僚兄弟亲族等。虽暂集会不久散坏。又复内身粗色。四大所生。糜饭所长。常弃秽恶澡浴按摩等。虽复暂治所生苦恼。终是离散坏灭之法。为治饥渴苦故受诸饭食。为治寒热苦恼及为覆障可羞惭处。受畜衣服。为治惛睡逼苦及为对治行住疲苦。受诸卧具。为治诸疾病苦。受诸医药。如是诸欲皆为治苦。不应贪着。唯除应如重病所执治病之药。或依圣教寻思如是如是诸欲粗相。或复内自智见发起或复寻思随顺道理或复寻思诸欲自性。无始世来法尔成就。不思议法不应思议不应分别。如是名为寻思道理。如是六种了知诸欲粗相已。又复了知初静虑静相。谓于初静虑中无如欲界极粗重相。由离如是欲粗相故。名初静虑静相。如是名为了知初静虑静相。由定地作意故。了知欲界粗相及初静虑静相。是名了相作意。此中犹有闻思间杂。应知

胜解作意者。谓如其所应寻思了达欲界粗相及初静虑静相。不为闻思之所间杂。纯起修行胜解缘粗静相。修习止观修习之时。如所寻思粗静之相数起胜解。是故名为胜解作意

远离作意者。谓多修习此种类故。为欲断除初分烦恼。起对治道与断烦恼。能对治道俱生作意。名远离作意。摄乐作意者。谓已断欲界初分烦恼。及已远离彼品粗重。于后胜品断及远离起于喜乐。又于断处见胜功德。证于少分远离喜乐。于时时中以净胜作意而自庆悦。为欲断除惛沉睡眠掉举缠故。是名摄乐作意。观察作意者。谓如是正修乐断乐修已善品方便之所扶持。令欲界系诸烦恼缠。若行若住不复现行。如是行者复自思惟。我此身中为有贪欲为无贪欲。而于诸欲境不执受耶。为自观察故。随于一境思惟胜妙清净之相。而彼行者。由未尽断诸随眠故。思惟如是净妙相时。随顺染习趣向染习临至染习。不住于舍亦不厌毁遮止违逆。行者尔时如是自知。我于诸欲未正远离心未解脱故。诸欲行系摄我心。犹如持水法尔摄伏。我今定当倍修治道。令余随眠无余断故。倍复欣乐胜断胜修。是名观察作意

方便究竟作意者。谓倍修习止品乐断乐修故。双修止观数数观察。如是行者修习对治。时时观察断与未断。令心远离欲界烦恼系缚。此暂时伏离非是究竟永拔种子。行者尔时得初静虑方便道。究竟一切烦恼对治作意。是名方便究竟作意

方便究竟果作意者。谓从此后无间由前因缘故。证入根本初静虑定。此根本初静虑俱生作意。是名方便究竟果作意。如初静虑有七种作意。如是第二第三第四静虑乃至非想非非想处定如其所应。尽当知

复次粗相者。谓于一切下地。从欲界乃至无所有处。略有三种。诸下地法而可厌离。应知。一极苦住性。二极不寂静住性。三极短寿住性

引发分别者。谓四种引发。一果引发。二离欲引发。三转根引发。四胜德引发

问答分别者。谓无量门问答分别今少显示。问增上戒学云何不清净云何清净。答有十种因戒不清净。何者为十。一初不如法受尸罗律仪。二极沉下。三极浮散。四放逸懈怠所摄。五发起邪愿。六犯轨则摄。七犯邪命摄。八堕于二边。九不能出离。十违越所受

初不如法受尸罗律仪者。如有一人或避王逼恼。或避强贼之所逼恼。或避债主逼恼。或因恐怖逼恼。或怖不活等故。出家受戒。不为营修圣道不为清净梵行。不为自调伏。不为自寂静。不为自涅槃。诸如是等是为不如法受尸罗律仪

极沉下者。如有一人无惭无愧。悔心微劣其性慢缓。于诸学处慢缓修习。如是名极沉下。极浮散者。如有一人僻执所受非处生悔。于不应悔处而生悔。故于他人所非处而生陵蔑之心及损害心。数习不舍。如是名极浮散。放逸懈怠所摄者。如有一人于过去世已有违犯。由忘念故而不如法起于对治。如是于未来现在起于违犯。由忘念故而不如法起于对治。先亦不起猛励乐欲。当于禁戒终不违犯。谓我当如是如是行如是如是住。如所应行如所应住令无所犯。又复如是行如是住应可犯者而有毁犯。此人于前中后际及先时所作俱随行时。皆现成就于放逸故。又执睡眠及与偃息。以之为乐。慢缓懒堕不乐修营。于梵行智人身不供侍。如是名为放逸懈怠所摄

发起邪愿者。如有一人发起邪愿行于梵行。谓我今所修戒禁梵行。当为天主。或作余天。或复乐欲利养尊敬。谓从他人求诸利养及与尊敬。或唯愿证利养尊敬。如是名为发起邪愿。犯轨则摄者。如有一人于诸威仪。或于所作。或于方便。修善品中如前所说。凡有所行违于世间越毗柰耶。如是名为犯轨则摄

犯邪命摄者。如有一人为性大欲及不知足。难养难满。又以非法求觅一切衣服饮食诸坐卧具病缘医药及余资具。不以法故。此人为求衣服饮食等因显己功德。故于他人前诈现非其自性及非串习威仪。又现诸根寂静无有掉动。意令他人谓己有德。当有所施及以供事。谓衣服饮食诸坐卧具病缘医药及余资具身业给使。又复此人形貌躁恶发言粗犷无所忌惮。严饰其身称扬己名及与种姓。或复多闻。或广持法。为得利养及恭敬故。而为他人宣说诸佛及佛弟子所演之法。或自说己实有功德。或少增益。或令他人称显异相。为求多胜衣服饮食及余沙门种种资具。虽复衣服无所阙少。故现受用弊坏衣服。意令信我长者居士知阙少故。便多施与上妙衣服。如衣服余沙门资命之具亦复如是。又于信敬婆罗门诸长者所不得如所欲物。或是所无或是受用不可与故。而便逼切诃骂求索。或得下劣之物。轻毁退还。对施主前说如是语。咄善男子。有余善男子善女人。若比于汝族姓下劣资财贫匮。尚能舍施如是如是妙可意物。况汝于彼族姓高胜富有财产。而以如是鄙可恶物施于我耶。诸如是等。或依诈现威仪。或依非法言说。或依称显异相。或依逼切诃骂。或依以利比引于利非法求觅衣服饮食坐卧之具。病缘医药及余资具。不以法求。是谓邪命。如是名为犯邪命摄

堕二边者。如有一人乐着受用。诸欲妙乐从他而得衣服等具。或如法或不如法。不见过患不知出离。而受用之。此谓一边。又如一人修自苦行。无量种种苦事煎迫其身。受行种种极苦禁戒。或依处棘刺。或依处灰。或依于杵。或依于板。或依髑髅。或复蹲住。或修蹲定。或复事火乃至日三。或复处水乃至日三。或翘一足视日随转。诸如是等及余修自苦行。是第二边。如是名为堕于二边

不能出离者。如有一人执见尸罗及余禁戒。谓唯修习尸罗禁戒。当得清净解脱出离。又复执见善守善净诸外道戒。当得清净解脱出离。如是二种非究竟净故。不能出离。如是名为不能出离。违越所受者。如有一人都无羞耻。曾不顾惜沙门仪范。违毁禁戒行诸恶法。内怀朽烂随顺下流。如秽蜗虫螺音狗行。非沙门称沙门。无梵行称梵行者。如是名为违越所受。由是十因增上戒学而不清净。若翻此者。是则清净

增上心学。净不净义者。如摄事品清净静虑中说。又由此清净故。增上慧学清净应知。如是等类问答分别无量无边准义应知

菩提五种分别者。一种性。二方便。三时。四证觉。五解脱

种性者。声闻菩提依钝根种性。独觉菩提依中根种性。无上正等菩提依利根种性

方便者。声闻菩提由行六处善巧方便。独觉菩提由多分行甚深缘起善巧方便。无上正等菩提由五明处善巧方便

时者。声闻菩提极少三生修行而得。独觉菩提由百大劫修行而得。无上正等菩提由三大劫阿僧企耶修行而得

证觉者。声闻菩提由师证觉。独觉菩提唯誓自利无师证觉。无上正等菩提自利利他无师证觉

解脱者。声闻菩提。独觉菩提所证转依。解脱烦恼障解脱身摄。无上正等菩提所证转依。解脱一切烦恼障及所知障。解脱身摄及法身摄

显扬圣教论卷第七显扬圣教论卷第八

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之四

如是分别闻归等已。复次颂曰

  圣行无上乘　　大菩提功德
  异论论法释　　应知各多种

论曰。圣行多种者。谓四圣行。一到彼岸行。二菩提分行。三神通行。四成熟有情行

到彼岸行者。谓如前所说。十波罗蜜多是名到彼岸行

菩提分行者。谓如前所说。四念住等一切三十七觉分法及四种寻思四种如实遍智。是名菩提分行

神通行者。谓如前所说。六种神通名神通行。成熟有情行者。谓如前所说。二种无量。一所调伏无量。二调伏方便无量。复有六种成熟。一成熟自体。二所成熟者。三成熟差别。四成熟方便。五能成熟者。六已成熟者相。如是名为成熟有情行应知

无上乘多种者。谓五种大乘。一种子。二趣入。三次第。四正行。五正行果。如其次第。菩萨地中种性品发心品住品余诸品大菩提建立二品所摄应知。大菩提多种者。谓五种大菩提。一自性。二功用。三方便。四转。五灭

自性者。谓超过一切声闻独觉所得转依。此有四种应知。一生起依止。二不生依止。三善观察所知果。四法界净相

生起依止者。谓佛相续出世间道。依此转依方得生起非不生起。若离此转依亦生起者。未转依前应已生起。不生依止者。谓一切烦恼及彼习气。依此转依不复生起若不尔者。未转依前众缘和合。一切烦恼及彼习气。永更不生已应可得

善观察所知果者。谓此转依是善通达所知实际所知真如果。若不尔者。诸佛自体应更了知。应更断灭

法界净相者。谓此转依无众相故。极善清净法界所显。若不尔者。应是无常可思议法。然此转依是常住相不可思议无二所显

此不可思议性复有五种应知。一自性。二处所。三住。四一性异性。五成立所作

自性者。此转依性即色离色不可思议。如是即受想行识离受想行识不可思议。地界水界火界风界若即若离不可思议。眼处耳处鼻处舌处身处意处等。若即若离不可思议。若有若无等不可思议

处所者。此转依性若在欲界若离欲界不可思议。若在色无色界若离色无色界不可思议。人间天上若在若离不可思议。十方世界若在若离不可思议

住者。谓此转依住如是如是状貌安乐住不可思议住。如是如是状貌奢摩他住不可思议住。有心住不可思议住。无心住不可思议住。如是如是状貌圣住不可思议住。如是如是状貌天住梵住不可思议

一性异性者。一切诸佛同处一无漏界中。一性异性不可思议

成立所作者。谓诸佛如来其性平等。智慧势力威德平等。住无漏界依止转依。为利一切诸有情故。成立如是如是利有情事不可思议。此复二因缘故不可思议应知。一以离言说义过言语道故不可思议。二以出世间义世无比故不可思议

功用者。略而言之。十种自在名为功用。何者为十。一寿自在。二心自在。三众具自在。四业自在。五生自在。六愿自在。七胜解自在。八神变自在。九智自在。十法自在

方便者。略而言之。四种变化名为方便。一未成熟者令成熟故。现诸菩萨所行行变化。二已成熟者令解脱故。于三千大千世界百拘胝赡部洲同时显现如来变化。三方便摄受声闻变化。四为彼所调伏有情显现一切独觉变化。佛薄伽梵于此四种变化法中。十方世界无碍作用应知

转者。有二种应知。一暂时转。二究竟转。暂时转者。谓乃至有情未成熟未解脱。诸佛如来化转不息。究竟转者。如无尽不可思议诸佛威德明转。为诸有情作利益事。流转不息故。灭者。有二种应知。一暂时灭。二究竟灭。暂时灭者。于已成熟已解脱有情。诸佛如来暂时示现入般涅槃非是究竟。究竟灭者。谓一切烦恼及彼习气及所依苦。究竟永尽。应知。功德多种者。嗢拖南曰

  殊特非殊特　　平等心利益
  报恩与欣赞　　不虚方便行

论曰。殊特者。谓诸菩萨修学无上正等觉乘时。有五种殊特之法应知。何等为五。一于一切有情非有因缘而起亲爱。二唯为利益诸有情故。常处流转忍受大苦。三于多烦恼难调有情。善能解了调伏方便。四于极难解真实义理。能随悟入。五具足不思议威德。如是五法非余有情所共有。故名为殊特

非殊特者。谓诸菩萨修学无上正等觉乘时。有五种非殊特法。菩萨摩诃萨由成就此五种法故。则五种殊特法成就显现。何等为五。谓诸菩萨以因利他苦即为己乐。是故菩萨恒遍受行利他因苦。是名第一非殊特法。又诸菩萨虽善了知生死涅槃过失功德。而乐令有情毕竟清净即为己乐。是故菩萨为净有情增上力故。恒誓受行处生死法。是名第二非殊特法。又诸菩萨虽善了知默然乐味。而乐令有情毕竟清净即为己乐。是故菩萨为净有情增上力故。恒勤方便而为说法。是名第三非殊特法。又诸菩萨虽已积集六波罗蜜多善根。而乐令有情毕竟清净即为己乐。是故菩萨为净有情增上力故。以清净意而施与之。又不期彼施果异熟。是名第四非殊特法。又诸菩萨以他利益事即为自利益事。是故菩萨恒现受行一切有情利益之事。是名第五非殊特法。菩萨摩诃萨由成就此五种法故。则五种殊特法成就显现应知。平等心者。谓诸菩萨于一切有情所有五种平等心。一菩萨摩诃萨初发心时。如为得大菩提故起大誓愿。如是亦为利益诸有情故起平等心。二菩萨摩诃萨于诸有情起悲愍俱平等之心。三菩萨摩诃萨于诸有情起如一子爱俱平等之心。四菩萨摩诃萨于从众缘已生诸行。知是所想有情事已。了达一有情法性。即是一切有情法性。于一切有情所起平等法性智俱平等之心。五菩萨摩诃萨如于一有情行利益行。如是于一切有情亦行利益行。故于一切有情所起欲作利益事俱平等之心。如是名为菩萨摩诃萨于诸有情起于五种平等之心

利益者。谓菩萨摩诃萨于诸有情作一切利益事。有五种相。应知。何等为五。一于违损事说正命法而引摄之。二于不随顺能饶益事说随顺法而引摄之。三无依苦恼贫匮无怙有情为作依怙而引摄之。四宣说趣于善趣之道而引摄之。五宣说三乘趣涅槃道而引摄之

报恩者。谓菩萨摩诃萨于有恩有情所起于五种反报利益。何等为五。一安处有情令学己德。二方便安处令学他德。三无依无怙苦恼贫匮者为作依怙。四劝令供养诸佛如来。五令自书写佛所说法。及受持供养

欣赞者。有五种处。菩萨摩诃萨常应欣赞。何等为五。一值佛出世而得承事。二于如来所常闻六波罗蜜多相应菩萨藏法。三于成熟一切有情行堪任修习。四速证无上正等菩提。五证菩提已菩萨声闻大众和合

不虚方便行者。谓菩萨摩诃萨于诸有情有五种不虚利益方便胜行。何等为五。一菩萨摩诃萨于诸有情以利益安乐意为先。二菩萨摩诃萨成就不颠倒觉。于利益安乐事如实了知。三以随宜方便说种种法。令诸有情随所堪任悉得调伏。此唯如来究竟堪能。四菩萨摩诃萨于一切时心无厌倦。五菩萨摩诃萨平等大悲于下中上诸有情所心无偏党。复次嗢拖南曰

  不颠倒方便　　退堕与胜进
  相似实功德　　善调伏有情

论曰。不颠倒方便者。谓菩萨摩诃萨有五种方便。摄一切正方便。应知。何等为五。一随护方便。二无过方便。三择力方便。四净胜意乐方便。五入决定方便。随护方便者。谓菩萨摩诃萨善护聪睿。以俱生智速摄受法。又善护忆念。由忆念故所摄受法持不忘失。又善护智慧。由智慧故于所摄受法善观察义正慧通达。由远离随顺聪睿忆念智慧退分因故。及由亲近修习随顺住分胜分因故。又善护自心。由善防护诸根门故。又善护他心。由正方便护他心故。无过方便者。谓菩萨摩诃萨于诸善法无倒勇猛。无量无间回向菩提。择力方便者。谓即此一切住胜解行地中应知。净胜意乐方便者。谓住净胜意乐地及行正行地应知。入决定方便者。谓住决定地决定行地到究竟地应知。如是五种方便。总摄菩萨一切正方便应知。退堕者。谓诸菩萨五退分法应知。一不敬正法及说法者。二放逸懈怠。三习近烦恼。四习近恶行。五与余菩萨校量胜劣起增上慢。及于法颠倒起增上慢

胜进者。谓诸菩萨五胜分法。即如其次第。翻前五种黑品应知

相似功德者。谓诸菩萨五种相似功德。实是过失。应知。一于暴恶犯戒诸有情所。以是因缘作不饶益。二诈现具足威仪。三于随顺世间矫饰文词及外道书论相应诸法。得预智者聪睿者数。四修行有罪施等善行。五宣说建立相似正法。广令流布

实功德者。谓诸菩萨五种真实功德。应知。一于暴恶犯戒诸有情所。以是因缘起增上悲心。二自性具足威仪。三于如来所说清净真实。若教若证得预智者聪睿者数。四修习无罪施等善行。五开示正法遮彼相似

善调伏有情者。谓诸菩萨略于十处无倒调伏所化有情。一于离恶行处。二于离爱欲处。三于无违犯犯已出处。四于守护一切诸根门处。五于正知住处。六于离愦闹处。七于远离一切恶寻思处。八于离障处。九于离烦恼缠处。十于离烦恼品粗重处。复次嗢拖南曰

  诸菩萨受记　　堕于决定数
  定作常应作　　最胜法应知

论曰。诸菩萨受记者。谓诸菩萨于六种位蒙诸如来授无上正等菩提记。一于种性位未发菩提心。二已发菩提心。三现前住。四不现前住五有时限。谓齐尔所时当证无上正等菩提。六无时限。谓不说决定时限

堕于决定数者。谓诸菩萨有三种堕决定位。一种性堕决定。二发心堕决定。三不虚行堕决定

种性堕决定者。谓诸菩萨住种性位。便堕菩萨决定之数。何以故。由诸菩萨成就种性。若遇胜缘必定堪任证阿耨多罗三藐三菩提故。发心堕决定者。谓诸菩萨于阿耨多罗三藐三菩提起决定心。乃至证于无上正等觉。不复退转

不虚行堕决定者。谓诸菩萨已得自在。如其所欲随所造修。诸菩萨行无有空过。依此最后堕决定位故。如来为诸菩萨授堕决定记。定作者。谓诸菩萨于五种处。决定应作。若不作者。必不堪任证于无上正等菩提。云何为五。一发菩提心。二于诸有情起于怜愍。三勇猛精勤。四于五明处方便修习。五心无厌倦。常应作者。谓诸菩萨于五种处常应修作。一常应修作不放逸行。二无依无怙苦恼有情为作依怙。三常应修作供养佛行。四常应遍知误失不误失。五于一切所作若行若住诸作意中。常应修作。大菩提心以为导首

最胜法者。谓诸菩萨于十种同意最胜法。应受持应建立。以为最上。云何为十。一菩萨种性。于诸种性最为殊胜。二初发菩提心。于诸正愿最为殊胜。三正勤般若。于一切度最为殊胜。四爱语。于诸摄法最为殊胜。五如来。于诸有情最为殊胜。六悲。于诸无量最为殊胜。七第四静虑。于诸静虑最为殊胜。八空三摩地。于三三摩地最为殊胜。九灭尽定。于九次第定最为殊胜。十清净方便善巧。于诸方便善巧最为殊胜。复次嗢拖南曰

  诸施设建立　　一切法寻思
  及如实遍智　　并及诸无量
  宣说果利益　　大乘性与摄
  菩萨十应知　　建立诸名号

论曰。诸施设建立者。谓诸菩萨四种施设建立。唯有如来及诸菩萨能正施设建立。非余一切若天若人若沙门若婆罗门所能施设建立。除窃佛法安置己论。何等为四。一法施设建立。二谛施设建立。三道理施设建立。四乘施设建立

法施设建立者。谓素怛缆等十二分教次第撰集次第安置次第制造。是名法施设建立。谛施设建立者。谓或立一谛以不虚妄义。唯是一更无第二。或立二谛。一世俗谛。二胜义谛。或立三谛。一相谛。二诠谛。三用谛。或立四谛。一苦谛。二集谛。三灭谛。四道谛。或立五谛。一因谛。二果谛。三能知谛。四所知谛。五不二谛。或立六谛。一真谛。二妄谛。三应知谛。四应断谛。五应证谛。六应修谛。或立七谛。一爱味谛。二过患谛。三出离谛。四法性谛。五胜解谛。六圣谛。七非圣谛。或立八谛。一行苦谛。二坏苦谛。三苦苦谛。四流转谛。五流息谛。六杂染谛。七清净谛。八正方便谛。或立九谛。一无常谛。二苦谛。三空谛。四无我谛。五有爱谛。六无有爱谛。七彼断方便谛。八有余依涅槃谛。九无余依涅槃谛。或立十谛。一逼切苦谛二所受用不具足苦谛。三界性乖违苦谛四爱坏苦谛。五粗重苦谛。六业谛。七烦恼谛。八听闻正法如理作意谛。九正见谛。十正见果谛。如是名为菩萨谛施设建立。若广分别无量应知

道理施设建立者。有四种道理。一观待道理。二作用道理。三证成道理。四法尔道理。是名道理施设建立应知。乘施设建立者。谓声闻独觉无上大乘。各有七种施设建立应知

声闻乘七种施设建立者。一于四圣谛诸无倒慧。二此慧所依。三此慧所缘。四此慧伴类。五慧所作业。六助慧资粮。七慧所证果。如声闻乘如是七种施设建立。独觉乘亦尔

无上大乘七种施设建立者。一缘离言说一切法真如无分别平等出离慧。二此慧所依。三此慧所缘。四此慧伴类。五慧所作业。六助慧资粮。七慧所证果。是名三乘七种施设建立应知。如是三世诸佛菩萨。皆由此四正施设正建立无增无减

一切法寻思者。谓诸菩萨于一切法为欲证得如实遍智。起四寻思。如前已说

如实遍智者。谓诸菩萨于一切法起四种如实遍智。如前已说

诸无量者。谓诸菩萨依五无量。能起一切善巧作用。何者为五。一有情界无量。二世界无量。三法界无量。四所调伏界无量。五调伏方便界无量

有情界无量者。谓六十四种有情众。一那洛迦。二傍生。三鬼趣。四天。五人。六刹帝利。七婆罗门。八吠舍。九戍达罗。十女。十一男。十二非男非女。十三下品。十四中品。十五上品。十六在家。十七出家。十八苦行。十九律仪。二十不律仪。二十一非律仪非不律仪。二十二已离欲。二十三未离欲。二十四邪定聚。二十五正定聚。二十六不定聚。二十七苾刍。二十八苾刍尼。二十九式叉摩那。三十勤策男。三十一勤策女。三十二邬波索迦。三十三邬波斯迦。三十四习三摩地者。三十五温诵经者。三十六供侍病者。三十七长宿。三十八中年。三十九少年。四十阿遮利耶。四十一邬波柁耶。四十二共住。四十三近住。四十四宾客。四十五监僧事者。四十六乐利养者。四十七乐恭敬者。四十八乐远离者。四十九多闻者。五十有智者。五十一大福者。五十二法随法行者。五十三持素恒缆者。五十四持毗柰耶者。五十五持摩怛理迦者。五十六异生者。五十七见谛者。五十八学者。五十九无学者。六十声闻。六十一独觉。六十二菩提萨埵。六十三转轮圣王。六十四如来若依身相续差别则无量无边。世界无量者。谓十方无量世界无量名差别。如此世界名曰索诃。此界梵王名索诃主。如是等无量差别应知

法界无量者。谓善法不善法无记法。如是等差别门无量应知

所调伏界无量者。或立一种所调伏。谓一切有情中可调伏者是一类故。或立二种。一具缚。二不具缚。或立三种。一钝根。二中根。三利根。或立四种。一刹帝利。二婆罗门。三吠舍。四戍达罗。或立五种。一贪行。二嗔行。三痴行。四慢行。五觉行。或立六种。一在家。二出家。三成熟。四未成熟。五解脱。六未解脱。或立七种。一信敬。二轻毁。三中庸。四广说。五略开智。六常所调伏。七随缘。所引。谓遇如是如是缘即如是如是转变。或立八种。谓八部众。从刹帝利众乃至梵众。或立九种。一如来所化。二声闻所化。三独觉所化。四菩萨所化。五难调伏。六易调伏。七软语调伏。八诃摈调伏。九或远或近调伏。或立十种。一那落迦。二傍生。三鬼趣。四欲界天。五人。六中有。七色有。八无色有。九有想无想。十非有想非无想。如是略说五十五种。若依相续差别则有无量应知。问有情界无量。所调伏界无量。有何差别。答有情界者。谓无差别。一切有情若有种性若无种性。所调伏界者。谓唯有种性诸位差别。调伏方便界无量者。已如前说。应知。此亦差别分别有无量种。问何故唯略说此五无量。答诸菩萨摩诃萨专为修习利众生行。是故初立有情界无量。是诸有情依于处所可得受化。是故第二立世界无量。是诸有情于多世界由种种法得有染净差别。是故第三立法界无量。观有情中堪能究竟解脱苦者。建立第四所调伏界无量。若诸方便善巧能令有情证于解脱。建立第五调伏方便界无量。是故诸菩萨摩诃萨依是五无量能起一切善巧作用。宣说果利益者。谓诸菩萨摩诃萨为诸有情宣说正法。有五种广大果利益。应知。云何为五。一或有有情闻说正法时。远尘离垢于诸法中得法眼生。二或有有情即说是正法时得诸漏尽。三或有有情因说此法发于无上正等觉心。四或有有情闻说此法即得菩萨最胜法忍。五或有有情闻佛菩萨说正法已。受持修行展转宣说。令正法眼久住不灭。是名五种宣说广大果利益。应知

大乘性者。谓菩萨乘与七大性相应故。说名大乘。云何为七。一法大性。谓十二分教中菩萨藏所摄方广之教。二发心大性。谓已发无上正等觉心。三胜解大性。谓于前所说法大性境起胜信解。四胜意乐大性。谓已超过胜解行地入净胜意乐地。五资粮大性。谓已成就福智二种大资粮故能证无上正等菩提。六时大性。谓三大劫阿僧企耶时。能证无上正等菩提。七成满大性。谓即无上正等菩提。此所成满菩提自体。比余成满自体尚无与等。何况超胜此中法大性乃至时大性。此之六种是成满大性之因。成满大性一种。是前六之果。应知

摄者。谓八种法。能具足摄一切大乘。一菩萨藏教。二于菩萨藏中显示诸法真实义教。三于菩萨藏中显示一切诸佛菩萨不可思议最胜广大甚深威德教。四于上所说如理听闻。五先如理思趣胜意乐。六得胜意乐入初修行。七由入修行为先故修果成就。八由修果成就故究竟出离。菩萨摩诃萨由如是修学。证得无上正等菩提

菩萨。十应知者。谓如是修学能证无上正等菩提。诸菩萨略有十种。应知。一安住种性。二趣入。三不净胜意乐。四净胜意乐。五未成熟。六已成熟。七未得决定。八已得决定。九一生所系。十住最后有。此中安住种性菩萨。若方便修学发菩提心。即名趣入。既趣入已。乃至未入净胜意乐地。即名不净胜意乐。若得入者。名净胜意乐。即净胜意乐菩萨乃至未入到究竟地。名未成熟。若得入者。名已成熟。即未成熟中乃至未入决定行地。名不决定。若得入者。名得决定。已成熟中复有二种。一一生所系。谓此生后无间证得阿耨多罗三藐三菩提。二住最后有。谓即在此生证得无上正等菩提。如是从住种性乃至无上正等菩提。如前所说。十种菩萨尽摄一切菩萨。如前所说。菩萨学处尽摄菩萨所有学处

建立诸名号者。谓诸菩萨无有差别随德众名。所谓菩提萨埵摩诃萨埵成就觉慧。最上明照。最胜之子。最胜所依。最胜所使。最胜萌芽。亦名猛健。亦名上轨范师亦名商主。亦名具大名称。亦名成就慈悲。亦名大福。亦名富自在。亦名大法师。如是等十方无边世界中。依无量内德差别。施设无数名号。应知。是中若诸菩萨自称我是菩萨。而不正勤修诸菩萨所有学处。当知此是相似菩萨非实菩萨。若诸菩萨自称菩萨。亦复勤修菩萨学处。当知此即真实菩萨

显扬圣教论卷第八显扬圣教论卷第九

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之五

异论多种者。谓十六种异论。何等十六。嗢柁南曰

  执因中有果　　显了有去来
  我常宿作因　　自在等害法
  边无边矫乱　　见无因断空
  计胜净吉祥　　名十六异论

论曰。十六异论者。一因中有果论。二从缘显了论。三去来实有论。四计我论。五计常论。六宿作因论。七自在等作者论。八害为正法论。九有边无边论。十不死矫乱论。十一无因见论。十二断见论。十三空见论。十四妄计最胜论。十五妄计清净论。十六妄计吉祥论

因中有果论者。谓如有一若沙门若婆罗门。起如是见立如是论。因中常恒具有果性。谓雨众外道作如是计。问何因缘故。彼诸外道于诸因中起如是见立如是论显示有果。答由教及理故。教者。谓彼先师所造教藏。随闻传授展转至今。宣说因中先已有果。理者。谓即如彼沙门及婆罗门。为性寻思。为性观察。住寻思地。住自办地。住异生地。住随思惟观察行地。彼如是思。若从彼体此体得生。一切世间共知共立。彼是此因非余。又诸世间欲求此果。唯取此因不取余因。又即于彼彼事中。如是如是加功营造。非于余事。又若彼果即从彼生不从余生。是故因中定已有果。若不尔者。应立一切是一切因。又应求一一果取一切因。又应于一切事加功营造为求一果。又应从一切一切果生。如是由建立故。取故。作事故。生故。彼见因中常有果性

我今问汝。随汝意答。因果两相为异不异。若不异者。即无决定因果二体。由此二相无差别故。而言因中有果。不应道理。若异相者。汝意云何。因中果体为未生相为已生相。若未生相者。于彼因中果犹未生而说是有。不应道理。若已生相者。则果体已生复从因生。不应道理。是故因中非先有果。然要有因故待缘而生

彼有相法于有相法中由五种相可得了知。一于处所可得了知。谓如瓮中水。二于所依止可得了知。如眼中眼识。三即于自相可得了知。如因自体不由比决。四于自作业可得了知。五由因变故果变可得。或由缘变故果变可得。是故常时恒时说因中有果。不应道理。由此义故。彼所立论非如理说。谓不异相故。异相故不生相故。生相故。不应道理

从缘显了论者。谓如有一若沙门若婆罗门。起如是见立如是论。一切诸法体自本有。从众缘显非缘所生。谓即因中有果论者及声相论者。作如是计

问何因缘故。因中有果论者。见诸因中先有果性从缘显了。答由教及理故。教如前说。理者。谓如有一。为性寻思。为性观察。广说如前。彼如是思。果先是有复从因生。不应道理。然非不用功为成于果。复以何缘而作功用。岂非唯为显了果故。彼作如是妄思惟已。说显了论

我今问汝。随汝意答。为无障缘故障。为有障缘故障。若无者。无有障缘而有障者。不应道理。若有者。属果之因何故不障。同是有故。譬如黑闇障瓮中水亦能障瓮。若言亦障因者。亦应显了。俱是所障。而但显因中先有果性而不显因。不应道理

汝又应说。为有性是障缘。为果性是障缘。若有性是障缘者。是则有性。常不显了。不应道理。又因亦是有。何故不是障缘。若果性是障缘者。如是一法亦因亦果。如芽是种子果是茎等。因果即一法亦显不显。不应道理

又今问汝。随汝意答。显与本法为一为异。若言一者。彼本有法常显已显复显。不应道理。若言异者。此显为无因耶。为有因耶。若无因者。无因而显。不应道理。若有因者。果性可显。非是因性不显之因能显于果。不应道理。如是无障缘故。有障缘故。有相故。果相故。显了一故。显了异故。不应道理。是故汝言。若法性无是则无相。若法性有是则有相。若性是无不可显了。若性是有则可显了者。不应道理

今当略说。虽实是有而不可取相。或有远故不可取。或由四种障因之所障故不可取。或极微细故不可取。或心散乱故不可取。或根损坏故不可取。或未得彼相应智故不可取。如因中有果从缘显论。不应道理。当知声相论亦尔。此中差别者。外声论师起如是见立如是论。声相本有无生无灭。然由数宣吐方得显了。而声体是常。是故从缘显了论。非如理说

去来实有论者。谓如有一若沙门若婆罗门。或在此法。由不正思惟起如是见立如是论。有过去有未来。自相成就犹如现在。实有非假

问何因缘故。彼起如是见立如是论。答由教及理故。教如前说

又于此法有不如理思惟所引经教。如经中说。一切有者。谓十二处。是十二处自相故有。又如薄伽梵说。有过去业。又经中说。有过去色有未来色。乃至识亦如是

理者。谓如有一。为性寻思。为性观察。广说如前。彼如是思。若法自相安住此法。真实是有。此若未来无者。彼时应未受自相。此若过去无者。彼时应退失自相。若如是者。诸法自相应不成就。由是诸法应性不真实。若如是者不应道理。由如是思故。起如是见立如是论。过去未来性相实有

我今问汝。随汝意答。去来两相与现在相。为不异相为是异相。若不异相者。立三世相。不应道理。若异相者。性相实有。不应道理

又汝应说。自意所欲堕三世法。为是常相为无常相。若常相者。堕于三世。不应道理。若无常相者。于三世中恒是实有。不应道理

又汝应说。自意所欲。为计未来法来至现在世。为计未来死灭生现在世。为计法住未来以此为缘生现在世。为计本无业用今有业用。为计本相不圆满今相圆满。为计本相异今相异。为计未来有现在分相

若言即未来法来至现在者。此应有方所。又未来现在应无差别。又应是常。不应道理。若言未来死灭生现在者。是则未来法不生于今现在法本无今生。又未来未生而言死灭。不应道理

若言法住未来以此为缘生现在世者。此应是常。又应本无。今生非未来法生。不应道理。若本无业用今有业用者。是则本有今有便有。如前所说过故。不应道理。又此业用汝意云何。与彼本法为有异相为不异相。若异相者。此业用相未来无故。不应道理。若不异相者。本无业用今有业用。不应道理

如无业用有此过失。如是不圆满相异相未来分相亦尔。此中差别者。复有自体杂乱过失。不应道理。如未来向现在。如是现在往过去如其所应有过失应知。谓如前所计诸因缘及所说破道理

如是自相故。共相故。来故。死灭故。生故。业故圆满相故。异相故。未来分故。说过去未来实有论。不应道理

如是破已复有难言。若过去未来是无。云何缘无而有觉转。若言缘无而觉转者。云何不有违教过失。如说一切有者谓十二处

我今问汝。随汝意答。世间取无之觉为起不起。若不起者。能取无我。兔角石女儿等觉。皆应是无。此不应道理。又薄伽梵说。我诸无谄声闻如我所说正修行时。若有知有若无知无。如是不应道理。若言起者。汝何所欲此取无觉。为作有行为作无行。若作有行者。取无之觉而作有行。不应道理。若作无行者。此无行觉汝何所欲。为缘有事转为缘无事转。若缘有事转者。无行之觉缘有事转。不应道理若缘无事转者。无有缘无之觉。不应道理

虽说一切有者谓十二处。然于有法密意说有有相。于无法密意说有无相。所以者何。若有相法能持有相。若无相法能持无相。是故俱名为法。俱名为有。若异者。诸修行人。但知于有不知于无。应非无间观所知法。此不应道理。又虽说言有过去业由此业故众生受。有损害受无损害受。此亦依彼习气密意假说彼法为有。谓于诸行中曾有净不净业生灭。由此因缘故。彼行胜异相续而转。是名习气。由此相续所摄习气故。爱不爱果生。是故于我无过。而汝不应道理

又虽说言有过去色有未来色有现在色。如是乃至识亦尔者。此亦依三种行相密意故说。谓因相自相果相。依彼因相密意说有未来。依彼自相密意说有现在。依彼果相密意说有过去。是故无过

又复不应说过去未来是实有相。何以故。应知。未来有十二种相故。一因所显相。二体未生相。三待缘相。四已生种类相。五应生法相。六不生法相。七未生杂染相。八未生清净相。九应可求相。十不应求相。十一应观察相。十二不应观察相。应知。现在亦有十二种相。一果所显相。二体已生相。三缘会相。四已生种类相。五刹那相。六不复生法相。七现杂染相。八现清净相。九可喜乐相。十不可喜乐相。十一应观察相。十二不应观察相。应知。过去亦有十二种相。一已度因相。二已度缘相。三已度果相。四体已坏相。五已灭种类相。六不生法相。七静息杂染相。八静息清净相。九应顾恋处相。十不应顾恋处相。十一应观察相。十二不应观察相

计我论者。谓如有一若沙门若婆罗门。起如是见立如是论。有我有萨埵有命者有生者有养者有数取趣者。如是等是实是常。诸外道等作如是计。问何故彼诸外道。起如是见立如是论。答由教及理故。教如前说。理者。谓如有一。为性寻思。为性观察。广说如前。由二种因故。一先不思觉率尔而得有萨埵觉故。二先已思觉得有作故。彼如是思。若无我者。见于五事不应起于五种有我之觉。一见色形已唯应起于色觉。不应起于萨埵之觉。二见顺苦乐行已。唯应起于受觉。不应起于胜劣萨埵之觉。三见已立名者名相应行已。唯应起于想觉。不应起于刹帝利婆罗门吠舍戍达罗佛授德友等萨埵之觉。四见作净不净相应行已。唯应起于行觉。不应起于愚者智者萨埵之觉。五见于境界识随转已。唯应起于心觉。不应起于我能见等萨埵之觉。由如是先不思觉。于此五事唯起五种萨埵之觉。非诸行觉。是故先不思觉见已率尔而起有萨埵觉。如是决定知有实我

又彼如是思。若无我者。不应于诸行中先起思觉得有所作。谓我以眼当见诸色。正见诸色。已见诸色。或复起心。我不当见如是等用皆由我觉行为先导。如于眼见如是于耳鼻舌身意应知亦尔。又于善业造作善业止息。不善业造作不善业止息。如是等事。皆由思觉为先方得作用。如是等用唯于诸行。不应道理。由如是思故说有我

我今问汝。随汝意答。为即于所见事起萨埵觉。为异于所见事起萨埵觉耶。若即于所见事起萨埵觉者。汝不应言即于色等计有萨埵计有我者是颠倒觉。若异于所见事起萨埵觉者。我有形量。不应道理。我有胜劣。或刹帝利等。或愚或智。或能取彼色等境界。不应道理

又汝何所欲。为唯于此法自体起此觉耶。为亦于余体起此觉耶。若唯于此法自体起此觉者。即于所见起彼我觉。不应说名为颠倒觉。若亦于余体起此觉者。即一切境界各是一切境界觉因。不应道理

又汝何所欲。于无情数有情觉。于有情数无情觉。于余有情数余有情觉。为起为不起耶。若起者。是则无情应是有情。有情应是无情。余有情应是余有情。此不应道理。若不起者。则诽拨现量。不应道理

又汝何所欲。此计我觉为取现量义。为取比量义耶。若取现量义者。唯色等蕴是现量义。我非现量义故。不应道理。若取比量义者。如愚稚等未能思度。不应率尔起于我觉

又我今问汝。随汝意答。如世间所作。为以觉为因。为以我为因。若以觉为因者。执我所作。不应道理。若以我为因者。先已思觉得有所作。不应道理

又汝何所欲。所作事因。为是无常为是常耶。若无常者。此所作因体是变异而执我有所作。不应道理。若是常者。则无变异无变异法执有所作。不应道理

又汝何所欲。为有动作之我能有所作。为无动作之我能有所作耶。若有动作之我能有所作者。是则常作不应复作。若无动作之我能有所作者。无动作性而有所作。不应道理

又汝何所欲。为有因故我有所作。为无因耶。若有因者。此我应由余因策发方有所作。不应道理。若无因者。应一切时作一切事。不应道理

又汝何所欲。此我为依自故能有所作。为依他故能有所作。若依自者。此我自作老病死苦杂染等事。不应道理。若依他者。计我所作不应道理

又我今问汝。随汝意答。为即于蕴施设有我。为于诸蕴中为蕴。外余处为非蕴性耶。若即于蕴施设我者。是我与蕴无有差别。而计有我是实是常。不应道理。若于诸蕴中者。此我为常为无常耶。若是常者。常住之我。为诸苦乐之所损益。不应道理。若无损益起法非法。不应道理。若不生起法及非法。应诸蕴身毕竟不起。又应不由功用我常解脱。若无常者。离蕴体外有生有灭相续流转法不可得故。不应道理。又于此灭坏后于余处不作而得有大过失故。不应道理。若蕴外余处者。汝所计我应是无为。若非蕴性者。我一切时应无染污。又我与身不应相属。此不应道理

又汝何所欲。所计之我。为即见者等相。为离见者等相。若即见者等相者。为即于见等上假立。有能见者等相。为离于见等上别立有能见者等相。若即于见等上假立有能见者等相者。即应见等是能见者等。而汝立我。为能见者等不应道理。以见者等与见等相无差别故。若离于见等上别立有能见者等相者。彼见等法为是我所成业。为是我所执具。若是我所成业者。此我若如种子应是无常。若言如陶师等假立士夫。此我应是无常应是假立。而汝言是常是实。不应道理。若言如具神通假立士夫。此我亦应是无常假立。于诸所作随意自在。此亦如前。不应道理。若言如地应是无常。又所计我无如地大显了作业故。不应道理。何以故。世间地大。所作业用显了可得故。谓能持万物令不坠下。我无是业显了可得。若如虚空应是无法。此不应道理。何以故。唯于色无假立空故。虚空虽是假有。而有业用分明可得。非所计我故。不应道理。世间虚空。所作业用分明可得者。谓由虚空故得起往来屈伸等业。是故见等是我所成业。不应道理。若是我所执具者。若言如镰如离镰外余物亦有能断作用。如是离见等外于余物上见等业用不可得故。不应道理。若言如火。则徒计于我。不应道理。何以故。如世间火离能烧者。亦自能烧故。若言离见者等相别有我者。即所计我相乖一切量。不应道理。又我今问汝。随汝意答。汝所计我。为与染净相相应而有染净。为不与染净相相应而有染净耶。若与染净相相应而有染净者。即于诸行中有疾疫灾横及彼止息顺益可得。即彼诸行虽无有我。而说有染净相相应。如于外物内身亦尔。虽无有我染净义成。故汝计我。不应道理。若不与染净相相应而有染净者。离染净相我有染净。不应道理

又我今问汝。随汝意答。汝所计我。为与流转相相应而有流转及止息耶。为不与流转相相应而有流转及止息耶。若与流转相相应而有流转及止息者。于诸行中有五种转相可得。一有因。二可生。三可灭。四展转相续生起。五有变异。若诸行中此流转相可得。如于身牙河灯乘等。流转作用中虽无有我。即彼诸行得有流转及与止息。何须计我。若不与彼相相应而有流转及止息者。即所计我无流转相而有流转止息。不应道理

又我今问汝。随汝意答。汝所计我为由境界所生若苦若乐。及由思业并由烦恼随烦恼等之所变异。说为受者。作者及解脱者。为不由彼变异说为受者等耶。若由彼变异者。是即诸行是受者作者及解脱者。何须计我。设是我者我应无常。不应道理。若不由彼变异者。我无变异。而是受者作者及解脱者。不应道理

又汝今应说自意所欲。为唯于我说为作者。为亦于余法说为作者。若唯于我者。世间不应说火为烧者光为照者。若亦于余法者。即于见等诸根说为作者。徒分别我。不应道理。又汝应说自意所欲。为唯于我建立为我。为亦于余法建立为我耶。若唯于我者。世间不应于假说士夫身呼为德友佛授等。若亦于余法者。是则唯于诸行假说名我。何须更执别有我耶。何以故。诸世间人。唯于假设士夫之身。起有情想立有情名。及说自他有差别故。又汝何所欲。计我之见。为善为不善耶。若是善者。何为极愚痴人深起我见。又不由方便率尔而起。又能令众生怖畏解脱。又能增长诸恶过失。不应道理。若言不善。不应说正及非颠倒。若是颠倒所计之我。体是实有。不应道理

又汝何所欲无我之见。为善为不善耶。若言是善。于彼常住实有我上见无有我而是善性非颠倒见。不应道理。若言不善。而一切智者之所宣说。精勤方便之所生起。令诸众生不怖解脱。能速证得白净之果。诸恶过失如实对治。不应道理

又汝意云何。为即我性自计有我。为由我见耶。若即我性自计有我者。应一切时无无我觉。若由我见者。虽无实我。由我见力故。于诸行中。妄谓有我。是故汝计定实有我。不应道理

如是不觉为先而起彼觉故。思觉为先见有所作故。于诸蕴中建立是有故。由于彼相安立为有故。建立杂染及清净故。建立流转及止息故。建立受者作者及解脱者故。施设有作者故。施设言说故。施设见故。计实有我。皆不应道理

又我今当说第一义我相。所言我者。唯于诸法假立为有。非实有我。然此假我。不可说言与彼诸法异不异性。勿谓此我是实有体。或彼诸法即我性相。又此假我是无常相。是非恒相。非安保相。是变坏相。生起法相。老病死法相。唯诸法相。唯苦恼相。故薄伽梵说。苾刍当知。于诸法中假立有我。此我无常无恒。不可安保。是变坏法。如是广说。当知由四因故。于诸行中假设有我。一为令世间言说易故。二为欲随顺诸世间故。三为欲断除谓定无我诸怖畏故。四为宣说自他成就功德成就过失令起决定信解心故。是故执有我论。非如理说

计常论者。谓如有一若沙门若婆罗门。起如是见。立如是论。我及世间皆是常住。非作非作所作。非化非化所作。不可损害积聚而住如伊师迦。谓计前际。说一切常者。说一分常者。及计后际。说有想者。说无想者。说非想非非想者。复有计诸极微是常住者。作如是计。问何故彼诸外道。起如是见。立如是论。我及世间是常住耶。答彼计因缘。如经广说。随其所应尽当知。此中计前际者。谓或依下中上静虑。起宿住随念。不善缘起故。于过去诸行但唯忆念。不如实知计过去世。以为前际。发起常见。或依天眼。计现在世以为前际。于诸行刹那生灭流转。不如实知。又见诸识流转相续。从此世间至彼世间。无断绝故。发起常见。或见梵王随意成立。或见四大种变异。或见诸识变异。计后际者。于想及受虽见差别。然不见我自相差别。是故发起常见。谓我及世间皆悉常住。又计极微是常住者。以依世间静虑。起如是见。由不如实知缘起故。计有为先有果集起。离散为先有果坏灭。由此因缘。彼谓从众微性粗物果生。渐析粗物乃至微住。是故粗物无常。极微常住

此中计前际后际常住论者。是执我论。差别相所摄故。我论已破。当知我差别相论亦已破讫

又我今问汝。随汝意答。宿住之念。为取诸蕴。为取我耶。若取蕴者。执我及世间是常。不应道理。若取我者。忆念过去如是名等诸有情类。我曾于彼。如是名。如是姓。乃至广说。不应道理

又汝意云何。缘彼现在和合色境眼识起时。于余不现不和合境。所余诸识为灭为转。若言灭者。灭坏之识而计为常。不应道理。若言转者。由一境界于一切时一切识起。不应道理

又汝何所欲所执之我由。想所作及受所作。为有变异为。无变异若言有者计彼世间及我常住。不应道理。若言无者。有一想已复有种种想生。复有小想及无量想。不应道理

又先纯有乐已后纯有苦。复有苦有乐有不苦不乐。不应道理

又若计命即是身者。彼见我是色。若计命异于身者。彼见我非色。若计我俱遍无二无缺者。彼见我亦色非色。若为对治此故。即于此义中由异句异文而起执者。彼见我非色非非色。又若见少色少非色者。彼见有边。若见彼无量者。彼见有无边。若复遍见而色分少非色无量。或色无量非色分少者。彼见亦有边亦有无边。若为对治此故。但由文异不由义异而起执者。彼见非有边非有无边。或见解脱之我。远离二种

显扬圣教论卷第九显扬圣教论卷第十

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之六

复次计诸极微常住论者。我今问汝。随汝意答。汝为观察已计极微常。为不观察计彼常耶。若不观察者。离慧观察而定计常。不应道理。若言已观察者。违诸量故。不应道理

又汝何所欲。诸极微性为由细故计彼是常。为由与粗果物其相异故计彼常耶。若由细者。离散损减其性羸劣。而言是常。不应道理。若言由相异故者。是则极微。超过地水火风之相。不同种类相故。而言能生彼果。不应道理。又彼极微亦无异相可得。故不中理

又汝何所欲。从诸极微所起粗物。为不异相为异相耶。若言不异相者。由与彼因无差别故。亦应是常。是则应无因果决定。若异相者。汝意云何。为从离散极微粗物得生。为从聚集耶。若言从离散者。应一切时一切果生。是则应无因果决定。若从聚集者。汝意云何。彼粗果物从极微生时。为不过彼形质之量。为过彼量耶。若言不过彼形质量者。从形质分物生形质有分物。不应道理。若言过者。诸极微体无细分故不可分析。所生粗物亦应是常。此不中理。若复说言有诸极微本无今起者。是则计极微常。不应道理

又汝何所欲。彼诸极微造作粗物。为如种子等。为如陶师等耶。若言如种子等者。应如种子体是无常。若言如陶师等者。彼诸极微应有思虑如陶师等。若言不如种等及陶师等者。是则相似喻不可得故。不应道理

又汝意云何。诸外物起。为由有情为不尔耶。若言由有情者。彼外粗物由有情生。所依细物不由有情。不应道理。谁能于彼制其功能。若言不由有情者。是则无用而外物生。不应道理。如是随念诸蕴及众生故。由一境界一切识流不断绝故。由想及受变异不变异故。计彼前际及计后际常住论者。不应道理

又由观察不观察故。由共相故。由自相故。由造作故。根本所用故。极微常论。不应道理。是故计常论者。非如理说

复次我今当说常住之相。若一切时无变异相。若一切种无变异相。若自然无变异相。若由他亦无变异相。又无生相。当知是常住相。皆宿作因论者。谓如有一若沙门若婆罗门。起如是见。立如是论。广说如经。凡诸世间士夫所受者。谓现所受苦。皆由宿作为因者。谓由宿恶为因。由勤精进吐旧业故者。谓由现法极自苦行。现在新业由不作因之所害故者。谓诸不善业。如是于后不复有漏者。谓一向是善性故说后无漏。由无漏故业尽者。谓诸恶业。由业尽故苦尽者。谓宿因所感及现法方便所招苦恼。由苦尽故得证苦边者。谓证余生相续苦尽。谓无系外道作如是计。问何因缘故。彼诸外道。起如是见。立如是论

答由教及理故。教如前说。理者。谓如有一。为性寻思。为性观察。广说如前。由见现法所作功用不决定故。所以者何。彼见世间虽具正方便而招于苦。虽具邪方便而致于乐。彼如是思。若由现法所作功用为彼因者。彼应颠倒。由彼所见非颠倒故。是故彼皆以宿作为因。由此理故。彼起如是见。立如是论

今应问彼。汝何所欲。现法方便所招之苦。为用宿作为因。为用现法方便为因。若用宿作为因者。汝先所说由勤精进吐旧业故。现在新业由不作因之所害故。如是于后不复有漏。乃至广说。不应道理。若用现法方便为因者。汝先所说凡诸世间士夫所受。皆由宿作为因。不应道理

如是现法方便苦宿作为因故。现法功用为因故。皆不应道理。是故此论非如理说

复次我今当说如实因相。或有诸苦唯用宿作为因。谓如有一。自业增上力故生诸恶趣。或于贫贱家生。或有苦等杂因所生。谓如有一因邪事王。不获乐果而反致苦。如事于王如是由诸言说商贾等业。由事农业。由劫盗业。或于他有情作损害事。若有福者。获得富乐。若无福者。虽设功用而无果遂。或复有法纯由现在功用因得如新所造引余有业。或听闻正法于法觉悟。或复发起威仪业路。或复修学工巧业处。如是等类唯因现在方便功用

自在等作者论者。谓如有一若沙门若婆罗门。起如是见。立如是论。凡诸世间士夫所受。彼一切或以自在变化为因。或余丈夫变化为因。诸如是等谓说自在等。不平等因论者作如是计

问何因缘故。彼诸外道起如是见。立如是论。答由教及理故。教如前说。理者。谓如有一。为性寻思。为性观察。广说如前。彼由现见于因果中。世间有情不随意转。故作此计。所以者何。现见世间有情。于彼因时欲修净业不遂本心反更为恶。于彼果时愿生善趣不遂本心反堕恶趣。意为受乐不遂所欲反受诸苦。由见如是故。彼作是思。世间诸物必应别有作者生者及变化者为彼物父。谓自在天。或复其余

今当问彼。嗢柁南曰

  功能无体性　　摄不摄相违
  有用及无用　　为因成过失

论曰。汝何所欲。大自在天变化功能为用。业方便为因为无因耶。若用业方便为因者。唯此功能用业方便为因。非余世间。不应道理。若无因者。唯此功能无因。非世间物。不应道理

又汝何所欲。此大自在为堕世间。摄为不摄耶。若言摄者。此大自在即同世法。而能遍生世间。不应道理。若不摄者。即是解脱。而言能生世间。不应道理

又汝何所欲。为须用故变生世间。为不须用耶。若须用者。是则于彼须用无有自在。而于世间有自在者。不应道理。若不须用者。无有所须。而生世间。不应道理

又汝何所欲。此所出生。为唯大自在为因。为亦取余因耶。若唯大自在为因者。是则若时有大自在。是时即有出生。若时有出生。是时即有大自在而言出生。用大自在为因者。不应道理。若言亦取余因者。此为唯取乐欲为因。为除乐欲更取余因。若唯取乐欲为因者。此乐欲。为唯取大自在为因。为取余因耶。若唯大自在为因者。若时有大自在。是时即有乐欲。若时有乐欲。是时即有大自在。便应无始常有出生。此亦不应道理。若言亦取余因者。此因不可得故。不应道理。又于彼欲无有自在。而言于世间物有自在者。不应道理

如是由功能故。摄不摄故。用无用故。为因性故。皆不应道理。是故此论非如理说

执害为正法论者。谓如有一若沙门若婆罗门。起如是见。立如是论。若于彼祠中咒术为先害诸生命。若能祀者。若所害者。若诸助伴。彼一切皆得生天

问何因缘故。彼诸外道起如是见。立如是论。答此违理论谄诳所起。不由观察道理建立。然于诤竞恶劫起时。诸婆罗门违越古昔婆罗门法。为欲食肉妄起此计

又应问彼。汝何所欲。此咒术方为是法自体。为是非法自体。若是法自体者。离彼杀生不能感得自所爱果。转彼非法以为正法。不应道理。若是非法自体者自是不爱果法而能转余不爱果法者。不应道理

如是破已。复有救言。如世间毒。咒术所摄不能为害。当知此咒术方亦复如是

今应问彼。汝何所欲。如咒术方能息外毒。亦能息内贪嗔痴毒为不尔耶。若能息者。无处无时无有一人贪嗔痴等静息可得。故不中理。若不能静息者。汝先所说如咒术方。能息外毒亦能息除非法业者。不应道理

又汝何所欲。此咒术方。为遍一切为不遍耶。若言遍者。自所爱亲不先用祀者。不应道理。若不遍者。此咒功能便非决定。不应道理

又汝何所欲此咒功能。为但转因亦转果耶。若但转因者。于果无能。不应道理。若亦转果者。应如转变即令羊等成可爱妙色。然舍羊等身已方取天身。不应道理

又汝何所欲。造咒术者。为有力能及悲愍不。若言有者。离杀彼命不能将彼往生天上。不应道理。若言无者。彼所造咒能有所办。不应道理

如是由因故。譬喻故。不决定故。于果无能故。咒术者故。不应道理。是故此论非如理说

又我今说非法之相。若业损他而不治现过。是名非法。又若业诸修道者。共知此业感不爱果。又若业一切智者。决定说为不善。又若业自所不欲。又若业染心所起。又若业待邪咒术方备功验。又若业自性无记。诸如是等皆非法相

边无边论者。谓如有一若沙门若婆罗门。依止世间诸静虑故。于彼世间住有边想无边想俱想不俱想。广说如经。是故起如是见。立如是论。世间有边。世间无边。世间亦有边亦无边。世间非有边非无边。当知此中已说因缘及能计者

是中若依断边际求世边时。若忆念坏劫。即于世间起有边想。若忆念成劫。即于世间起无边想。若依方域周广求世边时。若下过无间。更无所得上过第四静虑。更无所得。傍一切处不得边际。尔时即于上下起有边想。于傍处所起无边想。若为治此执依于异文义无差别。即于世间起非有边想非无边想。今应问彼。汝何所欲。从前坏劫已来。为更有世间生起。为无起耶。若言有者。汝计世间有边。不应道理。若言无者。汝今依此世间而住念世间边。不应道理

如是从彼来有故。从彼来无故。皆不应道理。是故此论非如理说

不死矫乱论者。谓四种不死矫乱外道。如经广说。应知。彼诸外道若有人来。依世间道问善不善。依出世道问苦集灭道。尔时便自称言。我是不死乱者。随于处所依不死净天不乱诘问。即于彼所问以言矫乱。或托余事方便避之。或但随问者言词而转

是中第一不死乱者觉未开悟。第二于所证法起增上慢。第三觉已开悟而未决定。第四羸劣愚钝。又复第一怖畏妄语及怖畏他人。知其无智故。不分明答言我无所知。第二于自所证未得无畏。惧他诘问怖畏妄语怖畏邪见故。不分明说我有所证。第三怖畏邪见怖畏妄语。惧他诘问故。不分明说我不决定。如是三种假托余事以言矫乱。第四唯惧他诘问。于世间道及出世道皆不了达。于世文字亦不善知。而不分明说言我是愚钝都无所了。但反问彼随彼言词而转以矫乱。彼此四种论发起因缘及能计者。并破彼执。皆如经说。由彼外道多怖畏故。依此见住。若有人来有所诘问。即以谄曲而行矫乱。当知此见是恶见摄。是故此论非如理说

无因见论者。谓依止静虑及不正思惟建立二种。如经广说。应知

问何因缘故。彼诸外道依不正思惟起如是见。立如是论。我及世间无因而起。答略而言之。见不相续以为先故。诸内外事无量差别。种种生起。或复有时见诸因缘空无果报。谓见世间无有因缘。或时欻尔大风卒起。于一时间寂然止息。或时忽尔暴河弥漫。于一时间宛然空竭。或时郁尔果木敷荣。于一时间飒然衰悴。由如是故。起无因见。立无因论

今应问彼。汝宿住念。为念无体。为念自我。若念无体者。无体之法未曾串习。未曾经识而能随念。不应道理。若念自我者。而计我先无后欻然生。不应道理

又汝何所欲一切世间内外诸物种种生起。或欻然而起。为无因耶为有因耶。若无因者。种种生起欻然而起忽复不生。不应道理。若有因者。汝计我及世间无因而生。不应道理。如是念无体故。念自我故。内外诸物不由因缘种种异故。由彼因缘种种异故。不应道理。是故此论非如理说

断见论者。谓如有一若沙门若婆罗门。起如是见。立如是论。乃至我有粗色四大所造之身住持未坏。尔时有病有痈有箭。若我死后断坏无有。尔时我善断灭如是欲廛诸天色廛诸天无色空处所摄。乃至非想非非想处所摄。广说如经。谓说七种断见。论者作如是计。问何因缘故。彼诸外道起如是见。立如是论

答由教及理故。教如前说。理者。谓如有一为性寻思。为性观察。广说如前。彼如是思。若我死后复有身者。应不作业而得异熟。若我体性一切永无。是则所受业果亦应无有。观此二种理俱不可。是故起如是见。立如是论。我身死已断灭无有。犹如瓦石。若一破已不可还合。彼亦如是应知

今应问彼。汝何所欲。为蕴断灭。为我断耶若言。蕴断灭者。蕴体无常因果展转。生起不绝。而言断灭。不应道理。若我断者。汝先所说粗色四大所造之身。有病有痈有箭。欲廛诸天色廛诸天无色空处所摄。乃至非想非非想处所摄。不应道理

如是若蕴断灭。若我断灭。皆不应理。是故此论非如理说

空见论者。谓如有一若沙门若婆罗门。起如是见。立如是论。无有施与。无有爱养。无有祠祀。广说乃至世间无有真阿罗汉。复有起如是见立如是论。无有一切诸法体相

问何因缘故。彼诸外道起如是见。立如是论。答由教及理故。教如前说。理者。谓如有一为性寻思。为性观察。广说如前。又依世间诸静虑故。见世施主一期寿命。恒行布施无有断绝。从此命终生下贱家贫穷匮乏。彼作是思。定无施与爱养祠祀。复见有人一期寿命。恒行妙行。或行恶行。见彼命终堕于恶趣生诸那落迦。或往善趣生于天上乐世界中。彼作是思。定无妙行及与恶行。亦无妙行恶行二业异熟。复见有一刹帝利种命终之后。生婆罗门吠舍戍达罗诸种姓中。或婆罗门命终之后。生刹帝利吠舍戍达罗诸种姓中。吠舍戍达罗等亦复如是。彼作是思。定无此世刹帝利等从彼世间刹帝利等种姓中来。亦无彼世刹帝利等从此世间刹帝利等种姓中去。又复观见诸离欲者生于下地。又见母命终已生而为女。女命终已还作其母。父终为子子还作父彼见父母不决定已。作如是思。世间必定无父无母。或复见人身坏命终。由彼或生无想。或生无色。或入涅槃故。求彼生处不能得见。彼作是思。决定无有化生众生。以彼处所不可知故。或于自身起阿罗汉增上慢已。临命终时自见生相。彼作是念。世间必无真阿罗汉。如是广说

问复何因缘。或有起如是见立如是论。无有一切诸法体相。答以于如来所说甚深经中。相似甚深离言说法。不能如实正觉了故。又于安立法相。不如道理而思惟故。起于空见。彼作是念。决定无有诸法体相

今应问彼。汝何所欲。为有生所受业及有后所受业。为一切皆是生所受耶。若俱有者。汝先所说。无有施与。无有爱养。无有祠祀。无有妙行。无有恶行。无有妙行恶行诸业异熟。无此世间。无彼世间。不应道理。若言无有后所受者。诸有造作净与不净种种行业。彼命终已。于彼生时顿受一切净与不净诸业异熟。不应道理

又汝何所欲。凡从彼胎藏及从彼种子而生者。彼等于此为是父母。为非父母耶。若言是父母者。汝言无父无母。不应道理。若言彼非父母者。从彼胎藏及彼种子所生。而言非父非母。不应道理。若时为父母。是时非男女。若时为男女。是时非父母。无不定过

又汝何所欲。为有彼处受生众生天眼不见为无有耶。若言有者。汝言无有化生众生。不应道理。若言无者。是则拨无离想欲者。离色欲者。离三界欲者。不应道理

又汝何所欲。为有阿罗汉性而于彼起增上慢。为无有耶。若言有者。汝言世间必定无有真阿罗汉。不应道理。若言无者。若有发起不正思惟颠倒。自谓是阿罗汉此亦应是真阿罗汉。不应道理

又应问彼。汝何所欲。圆成实相法。依他起相法。遍计所执相法。为有为无。若言有者。汝言无有一切诸法体相。不应道理。若言无者。应无颠倒。所执亦无杂染及无清净。此不应理。如是若生后所受故。非不决定故。有生处故。有增上慢故。有三种相故。不应道理。是故此论非如理说

妄计最胜论者。谓如有一若沙门若婆罗门。起如是见。立如是论。婆罗门是最胜种类。刹帝利等是下劣种类。婆罗门是白色类。余种是黑色类。婆罗门种可得清净。非余种类。诸婆罗门是梵王子。腹口所生。从梵所出。梵所变化。梵王体胤。谓斗诤劫。诸婆罗门作如是计

问何因缘故。诸婆罗门起如是见。立如是论。答由教及理故。教如前说。理者。谓如有一为性寻思。为性观察。广说如前。以见世间真婆罗门性具戒故。又贪名利及恭敬故。作如是计

今应问彼。汝何所欲。为唯余种类从母产生。为婆罗门亦尔耶。若唯余种类者。世间现见诸婆罗门从母产生汝谤现事。不应道理。若婆罗门亦尔者。汝先所说诸婆罗门是最胜种类。刹帝利等是下劣种类。不应道理。如从母产生如是造不善业造作善业。造身语意恶行。造身语意妙行。于现法中受不爱果。若受爱果。于彼后世生诸恶趣。若生善趣。若三处现前。是彼是此。由彼由此。入于母胎。从是而生。若世间工巧处。若作业处。若善不善。若王若臣。若机捷若增进满足。若为王顾录以为给侍。若不顾录。若是老病死法。若非老病死法。若修梵住已生于梵世。若复不尔。若修菩提分法。若不修习。若悟声闻菩提独觉菩提无上菩提。若复不尔

又汝何所欲。为从胜种类生。此名为胜。为由戒闻等耶。若由从胜类生者。汝论中说。于祠祀中。若闻胜若戒胜。取之为量。此言应不中理。若由戒闻等者。汝先所说。诸婆罗门是最胜类。余是下劣。不应道理

如是产生故。作业故。受生故。工巧业处故。增上故。彼所顾录故。梵住故。修觉分故。证菩提故。戒闻胜故。不应道理。是故此论非如理说。妄计清净论者。谓如有一若沙门若婆罗门。起如是见。立如是论。若我解脱心得自在。瑜伽自在名为清净。谓于诸天微妙五欲坚着摄受。嬉戏娱乐随意受用。是则名得现法涅槃第一清净

又若离欲恶不善法。于初静虑得具足住。乃至第四静虑得具足住。是亦名得现法涅槃第一清净

复有外道起如是见。立如是论。若有众生于孙陀利迦河中沐浴支体。所有罪障一切除灭。如于孙陀利迦河。如是于婆胡陀河伽耶河萨罗萨伐底河殑伽河等中沐浴支体。所有罪障一切除灭。第一清净

复有外道计持狗戒以为清净。或持牛戒。或持油墨戒。或持露形戒。或持灰戒。或持自苦戒。或持粪秽戒等。计为清净。谓说现法涅槃外道及说水等清净。外道作如是计

问何因缘故。彼起如是见。立如是论。答由教及理故。教如前说。理者。谓如有一为性寻思。为性观察。广说如前。彼谓得诸纵任自在欲自在瑜伽自在。名胜清净。然不如实知纵任自在等相

又如有一计由自苦身故自恶解脱。或造过恶过恶解脱

今应问彼。汝何所欲。诸有于妙五欲嬉戏受乐者。为离欲贪。为未离贪耶。若已离贪者。于世五欲嬉戏受乐。不应道理。若未离贪者。计为解脱清净。不应道理

又汝何所欲诸得初静虑乃至具足住第四静虑者。彼为已离一切贪欲。为未离耶。若言已离一切贪欲者。但具足住乃至第四静虑。不应道理。若言未离一切贪者。计为究竟解脱清净。不应道理

又汝何所欲。为由内清净故究竟清净。为由外清净故究竟清净。若由内者。计于河中沐浴而得清净。不应道理。若由外者。内具贪嗔痴等一切秽垢。但除外垢计究竟净。不应道理

又汝何所欲。为执受净物故而得清净。为执受不净物故得清净耶。若由执受净物故得清净者。世间共许狗等不净。而汝计执受狗等戒得清净者。不应道理。若由执受不净物者。自体不净而能令他净。不应道理

又汝何所欲。诸受狗等戒者。为行身等邪恶行故而得清净。为行身等正妙行故得清净耶。若由行邪恶行者。行邪恶行而计清净。不应道理。若由行正妙行者。持狗等戒则为唐捐。而汝计彼能得清净。不应道理

如是离欲不离欲故。内外故。受净不净故。邪行正行故。不应道理。是故此论非如理说

妄计吉祥论者。谓如有一若沙门若婆罗门。起如是见。立如是论。若世间日月薄蚀星宿失度所欲为事。皆不成就。若彼随顺所欲皆成。为此义故精勤供养日月星等祠火诵咒安置茅草。满瓮毗罗婆果及饷佉等。谓历算者作如是计

问何因缘故。彼起如是见。立如是论答由教及理故。教如前说。理者。谓如有一为性寻思。为性观察。广说如前。彼由获得世间静虑。世间同谓是阿罗汉。若有欲得自身富贵快乐所祈果遂者便往请问。然彼不如实知业果相应缘生道理。但见世间日月薄蚀星度行时。尔时众生净不净业异熟成熟。彼即计为日月等作。复为信乐此事者。建立显说

今应问彼。汝何所欲。世间兴衰等事。为是日月薄蚀星度等作。为净不净业之所作耶。若言日等作者。现见尽寿随造福非福业。感于兴衰苦乐等果。不应道理。若净不净业之所作者。汝言由日等作。不应道理

如是日等作故。净不净业作故。不应道理。是故此论非如理说

如是十六种异论由二种门发起观察。由正道理推逐观察。彼一切种皆不应理

显扬圣教论卷第十显扬圣教论卷第十一

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之七

论法多种者嗢柁南曰

  论体论处所　　论据论庄严
  论负论出离　　论多所作法

论曰。论法有七种。一论体性。二论处所。三论所依。四论庄严。五论堕负。六论出离。七论多所作法

论体性者。复有六种。一言论。二尚论。三诤论。四毁谤论。五顺正论。六教导论

言论者。谓一切言说言音言词

尚论者。谓世所乐闻语论

诤论者。谓或依诸欲所起。若自所摄诸欲他所逼夺。若他所摄诸欲自行逼夺。若于自他所爱有情所摄诸欲互相侵夺。谓歌舞戏笑等所摄。若倡女仆从等所摄。或为观看。或为受用。于如是等诸欲差别事中。未离欲者。为欲界贪现所染者。因坚执故。因缚着故。因耽嗜故。因贪爱故。发愤现威互相斗诤。异诤乖诤违害诤论。或依恶行所起若自所作身语恶行他所讥毁。若他所作身语恶行自行讥毁。若自他所爱有情所作身语恶行互相讥毁。于如是事中为作未作。诸恶行者。重贪嗔痴所拘执者。因坚执故。因摄受故。因贪爱故。更相发愤。以染污心现威斗诤。异诤乖诤违害诤论。或依诸见所起。谓身见断常无因恶因雨种外道等所起邪见。及余种种诸恶见类。于如是诸见中。或于自所执他所遮断。或于他所执自行遮断。或为令他离所执见。或为摄受所未执见。于此事中未离欲者。如前乃至违害诤论。是名诤论

毁谤论者。谓更相愤怒。以染污心振发威势互相谤毁。谓粗语所摄。或妄语所摄。或绮语所摄。乃至恶说法律中。若为有情宣说彼法。若铨量刊定。若教授教诫等。皆名毁谤论。何以故。非拨实相故。引恶道故。徒设功劳无义利故。是故此论名毁谤论

顺正论者。谓于善说法律中。若为有情宣说正法。若铨量刊定。若教授教诫等。为断有情所起疑故。为善通达甚深义故。为令智见毕竟净故。皆名顺正论。何以故。顺正行故。顺正义故。是故此论名顺正论

教导论者。谓于顺正论中为令修习增上心学增上慧学故。所有教诲心未定者。令心得定。心已定者令心解脱。未得真实智者开悟令得。已得真实智者令其修满。名教导论。何以故。分明委悉教导有情故。是故此论名教导论

问如实观察此六种论。几论真实能引义利。所应修习。几不真实能引无义。所应远离。答最后二论。是真实引义利。应修习。中间二论。不真实引无义。应远离。初二种论应分别

论处所者。当知亦有六种。一于国王前。二于执理者前。三于大众中。四于善解法义者前。五于沙门婆罗门前。六于乐法义者前

论所依者。有十种应知。谓所成义有二种能成法有八种

所成义二种者。一自性。二差别所成。自性者。谓有立为有。无立为无。所成差别者。谓有上立有上。无上立无上。常立为常。无常立无常。如是有色无色。有见无见。有对无对。有漏无漏。有为无为。如是等无量差别义门。是名所成差别应知

能成法八种者。一立宗。二辩因。三引喻。四同类。五异类。六现量。七比量。八至教

立宗者。谓依二种所成义各别摄受。自宗所许。若论教所摄。若自辩所立。若从他所闻。或为成立自宗。或为显他宗过。或为折伏憍慢。或为摧屈陵侮。或为悲愍有情

辩因者。谓为成就所立宗故。依所引喻同类异类现量比量及与至教辩道理因

引喻者。亦为成就所立义故。引因所依诸余世间串习共许易了之法以为比况

同类者。谓或于现在。或先所见相貌相属递互相似。此复四种。一自体。二业。三法。四因果。自体相似者。谓彼相貌更互相似。业相似者。谓彼作用更互相似。法相似者。谓自体上法门差别展转相似。如无常法与苦法。苦法与无我法。无我法与生法。生法与老法。老法与死法。如是有色无色。有见无见。有对无对。有漏无漏。有为无为。如是等无量法门差别更互相似。因果相似者。谓彼因果能成所成更互相似。是名同类

异类者。所谓诸法随其异义互不相似。此亦四种翻上应知

现量者有三种相。一非不现见相。二非思构所成相。三非错乱所见相

非不现见相者。复有四种应知。谓由诸根不坏作意现前时。同类生异类生无障碍不极远。同类生者。谓欲缠诸根于欲缠境。上地诸根于上地境已生已等生。若生若起。是名同类生。异类生者。谓上地诸根于下地境若已生等。是名异类生。无障碍者。复有四种。一非覆障所碍。二非隐障所碍。三非映障所碍。四非惑障所碍。覆障所碍者。谓黑闇无明闇不澄净色之所覆隔。隐障所碍者。谓或药草力。或咒术力。或神通力之所隐蔽。映障所碍者。谓少为多物之所映夺故不可见。或饮食等为诸毒药之所映夺。或发毛端为余粗物之所映夺。如是等类无量无边。且如小光为大光所映不可得见所谓日光映星月等。又如能治映夺所治令不可得。谓不净观映夺净相。无常苦无我观映夺常乐我相无相观力映夺众相。惑障所碍者。谓幻化所作。或相貌差别。或复相似。或内所作目眩惛梦。闷乱酒醉放逸癫狂。如是等类名为惑障。若不为此四障所碍名无障碍。不极远者。谓非三种极远。一处极远。二时极远。三推折极远。如是总名非不现见。由非不现见故名现量

非思构。所成相者。复有二种。一才取便成取所依境。二建立境界取所依境。才取便成取所依境者。谓若境能作才取便成取之所依。犹如良医授病者药。色香味触悉皆具足。有大势力成熟威德。当知此药色香味触才取便成取所依境药之所有大势熟德。病若未愈思构所成。若病愈时便非思构。如是等类名为才取便成取所依境。建立境界取所依境者。谓若境能为建立境界取之所依。如瑜伽师假想思构地界水界火界风界。若于地界假为水解。即依地想建立水想。若于地界假为火风二解。即依地想建立火风二想。此中地想即是建立境界。取地界即是建立境界取之所依。如于地想如是于水火风想如其所应。尽当知。是名建立境界取所依境。此中建立境界取所依境非是思构所成假想所解地等诸界。若解未成是名思构所立。解若成就即非思构。如是名为非思构所成。由非思构之所成故。名为现量

非错乱所见相者。当知或五种。或七种。五种者。谓非五种错乱所见。五种错乱者。一想错乱。二数错乱。三形错乱。四显错乱。五业错乱。七种者谓非七种错乱所见。七种错乱者。即此五种错乱。及余二种遍行错乱。合为七种。二种错乱者。一心错乱。二见错乱。想错乱者。谓于非彼相起彼相想。如于阳焰鹿渴想起于水想。数错乱者。谓于少数起多增上慢。如[(臣*殳)/目]眩者于一月处见多月像。形错乱者。谓于余形起余形增上慢。如于旋火见彼轮形。显错乱者。谓于余显色起余显色增上慢。如为迦末罗病损坏眼根。于非黄色悉见黄相。业错乱者。谓于无业起有业增上慢。如执拳驰走见树奔流。心错乱者。谓即于五种所错乱义心生喜乐。见错乱者。谓即于五种所错乱义忍受显说。安立宝重妄想坚执。若非如是错乱所见名为现量

问如是现量谁所有耶。答略说四种所有。一色根现量。二意受现量。三世间现量。四清净现量。色根现量者。谓色相五根所行境界。如前所说。现量体相。意受现量者。谓诸意根所行境界。如前所说。现量体相。世间现量者。谓即前二种总名世间现量。清净现量者。谓若世间现量亦是清净现量。有清净现量非世间现量。谓出世智于所行境。有知为有。无知为无。有上知有上。无上知无上。不共世间名清净现量

比量者。谓与思择俱推度境界。此复五种。一相。二体。三业。四法。五因果

相比量者。谓随其所有相貌相属。或由现在及先所见推度境界如以见幢故比知有车。以见烟故比知有火。如是以王比国。以夫比妻。以角犎比牛。以形软发黑轻举色美比知是少。以面皱发白等比知是老。以执自相比道比俗。以乐见圣者乐闻正法远离憍慢比正信者。以善思所思善说所说善作所作比聪睿者。以慈悲爱语勇猛乐施善能解释甚深义意比知菩萨。以掉动轻转嬉戏歌笑等比未离欲。以诸威仪恒寂静故比知离欲。以具如来微妙相好智慧寂静胜行辩才比知如来应正等觉具一切智。见彼幼年所有相貌比知老时。当有是事。诸如是等名相比量。体比量者。由现见彼自体性故。比类彼物不现见体。或现见彼一分自体比类余分。如以现在比类去来。或以过去比未来事。或以现近事比现远事。又如衣服饮食严具车乘等事观见少分得失之相比知一切。又以一分成熟比余熟分。如是等类名体比量

业比量者。谓以作用比业所依。如见远物无有动摇鸟集其上。如是等事比知是杌。若有动摇等事比知是人。若见迹步宽长比知是象。身曳地行比知是蛇。若闻嘶声比知是马。哮吼比师子。咆吼比牛王。见比于眼。闻比于耳。嗅比于鼻。尝比于舌。触比于身。识比于意。以杖寻水碍杖比地。若见是处草木滋润茎叶青翠比知有水。若见热灰比知有火。若见草木摇动比知有风。若见瞑目执杖蹎蹶失路等比知是盲。高声侧听比知是聋。以所作业比知正信聪睿菩萨未离欲离欲如来。如前应知

法比量者。谓于一切相属着法。以一比余。如属无常比知有苦。以属苦故比空无我。以属生故比有老法。以属老故比有死法。以属有色有见有碍比有处所及有形质。属有漏故比知有苦。属无漏故比知无苦。属有为故比知生住异灭之法。属无为故比知反彼。如是等类名法比量

因果比量者。谓因果相比如见物行比有所至。见有所至比先有行。若见有人如法事王比知当获广大禄位。见大禄位比知先已如法事王。若见有人备善作业比知必当获大财富。见大财富比知先已备善作业。见善恶行比当兴衰。见有兴衰比先善恶。若见丰饶饮食比知饱满。见有饱满比丰饮食。若见有人食不平等比知有病。若见有病比知食不平等。见有静虑比知离欲。见离欲者比有静虑。若见修道比知必获四沙门果。若见有获四沙门果比知修道。如是等类当知。是名因果比量。如是总名比量

至教者。谓一切智人所设言教。或从彼闻法随法行。此复三种。一圣言所摄。二对治离染。三不违法相

圣言所摄者。所谓如来及诸弟子所说经教。展转流布传来至今。不违正法不违正义

对治杂染者。谓依此法善修习时。能永调伏贪嗔痴等一切烦恼及随烦恼

不违法相者。谓翻违法相当知。是名不违法相。何等名为违法相耶。谓于无相增为有相。如执有我有情命者生者等。或常或断有色无色如是等类。或于有相减为无相。或于决定立为不定。如一切行皆是无常。一切有漏皆性是苦。一切诸法皆是无我。而妄建立一分是常一分无常。一分是苦一分非苦。一分有我一分无我。如是于佛所立不可记法。一向记别。又复推求。谓应立记。或于不定建立为定。如执一切乐受皆贪所随眠。一切苦受嗔所随眠。一切不苦不乐受痴所随眠。一切苦乐皆是有漏。思已造业唯受苦报。如是等类或于有相法中。无差别相建立差别。有差别相立为无别。如依有为差别之相于无为法亦别建立。依无为法无差别相于有为法亦不别立。如于有为无为。如是于有色无色。有见无见。有对无对。有漏无漏等。随其所应尽当了知。又于有相不如正理立因果相。如立妙行感不爱果。立诸恶行能感爱果。计于恶说法律之中习诸邪行能得清净。于佛善说法律之中修行正行不得清净。又于杂染立为清净。于清净法立为杂染。于不实相以假言说立为真实。于真实相以假言说立不真实。如于永离言说法中以言戏论建立胜义。如是等类名违法相。翻此违相名不违相。是名至教

问若一切法自相成就自义差别法尔建立。复何因缘立有二种所成义耶。答为欲生成他信解故。非为生成诸法相貌。问为欲成就所成立义。何故先说立宗耶。答为先显示自所爱乐义故。问何故次辩因耶。答为欲开显依现见法决定道理。即于所立宗义不舍离故。问何故次引喻耶。答为欲显现能成道理之所依止现见法故。问何故后说同类异类现量比量至教等耶。答为欲开示因喻二种相违不相违智故。又相违者由二种因。一由不决定故。二由同所成故。不相违者亦由二因。一由决定故。二由异所成故。此中相违者为成所立宗义不能为量故不名量。不相违者为成所立宗义能为正量故名为量。是名论所依

论庄严者。有五种应知。一善自他宗。二语具圆满。三无畏。四敦肃。五应供。善自他宗者。谓如有一于此正法及毗柰耶深生爱乐。即于自论宗本读诵受持正闻审虑纯熟修行。已善已说已明。复于彼法彼毗柰耶不爱不乐。但于彼论宗本读诵受持闻思纯熟而不修行。然已善已说已明。是名善自他宗

语具圆满者。谓如有一音声圆满不犯音声。音声者谓具五德。一不鄙陋。二轻易。三雄朗。四相应。五义善。云何不鄙陋。谓离诸边国鄙俚词故。云何轻易。谓世间共立非余说故。云何雄朗。所谓于义建立言词为成彼义巧妙雄壮故。云何相应。所谓前后功德法义相符顺故。云何义善。谓能引发世出世利无颠倒故。又此相应论者。复由九种差别相故。语具圆满应知。一不杂乱。二不粗矿。三辩了。四限量。五与义相应。六以时。七决定。八显了。九相续。以此足前总名语具圆满。无畏者。谓如有一处在多众异众大众胜众谛众善众等中。其心无有下劣怯惧。身无战汗面无怖色。声不动掉语不怯弱。如是等类名为无畏

敦肃者。谓如有一性不忿毒面无变改身不掉动。如是等类名为敦肃

应供者。谓如有一性善可乐性不恼他。寻常住善可乐地者。随顺他心而发言语。知时如实为益自他能引义利。言词柔软如对亲友。是名应供

若有依五论庄严相兴言论者。当知复有二十七种称赞功德。何等名为二十七种。一众所敬重。二言必信受。三于大众中转加无畏。四于他所宗深知过隙。五于自所宗知决定德。六无有僻执。七于所受论情无偏党。八于自正法及毗柰耶无能引夺。九于他所说速能了悟。十于他所说速能领受。十一于他所说速解理趣。十二能以语德胜伏大众。十三悦可信解因明论者。十四能善宣释义句文字。十五身不劳倦。十六心不劳倦。十七言不謇涩。十八辩才无尽。十九身不顿瘁。二十念无忘失。二十一心无损害。二十二咽喉无损。二十三凡所宣吐分明易了。二十四善护自心令无忿怒。二十五善顺他心令无愤恚。二十六令对论者心生净信。二十七凡有所行不招怨对广大名称声流十方世咸传唱。此大法师处大师数。如受欲者以末尼真珠琉璃等宝厕环钏等宝庄严具以自庄严。威德炽盛光明普照。如是论者以二十七种称赞功德。厕此五种论庄严具以自庄严。威德炽盛光明普照。是故名此为论庄严

论堕负者。谓有三种应知。一舍言。二言屈。三言过

舍言者。谓立论者以十三种词谢对论者舍所言论。何等名为十三种词。谓立论者谢对论者曰。我论不善。汝论为善。我不善观。汝为善观。我论无理。汝论有理。我论无能。汝论有能。我论屈伏。汝论成立。我之辩才唯极于此。过此已上更善思量当为汝说。且置是事我不复言。以如是等十三种词谢对论者舍所言论。舍所论故。当知摧破为他所胜。堕在他后屈伏于彼。是故舍言名堕负处

言屈者。如立论人为对论者之所屈伏。或假余事方便而退。或引外言。或现愤发。或现嗔恚。或现高慢。或显彼所覆。或现恼害。或现不忍。或现不信。或复默然。或复忧戚。或竦肩伏面。或沉思词穷。假托余事方便而退者。谓舍前所立更托余宗。舍先因喻同类异类现量比量及至教量。更托余因乃至至教。引外言者。谓舍所论事。或论饮食。或论王臣盗贼衢路倡秽等事。假托外缘舍本所立。现愤发者。谓以粗言摈对论者。现嗔恚者。谓以怨报之言责对论者。现高慢者。谓以卑贱种族等言毁对论者。显彼所覆者。谓以发他所覆恶行之言举对论者。现恼害者。谓以害酷怨言骂对论者。现不忍者。谓发怨言怖对论者。现不信者。谓以破戒行言谤对论者。或默然者。谓语业顿尽。或忧戚者。谓意业焦恼。竦肩伏面者。谓威勇身业而顿萎瘁沉思词穷者。谓才辩俱竭。如是十三种事。当知言屈。前二妄行矫乱。中七发起邪行。后四计行穷尽。是名言屈堕在负处

言过者。谓立论人有九种过。故名言过。何等为九。一杂乱。二粗犷。三不辩了。四无限量。五非义相应。六非时七不决定。八不显了。九不相续。杂乱者。谓舍所论事。杂说异语。粗犷者。谓愤发卒暴。言词躁急。不辩了者。谓若法若义。众及对论所不领悟。无限量者。谓于所说义。言词复重或复减少。非义相应者。当知十种。一无义。二违义。三损理。四与所成等。五招集过难。六不得义利。七义无次序。八义不决定。九成立已成。十顺不称理诸邪恶论。非时者。谓所应说前后不次。不决定者。谓立已复毁。毁而复立。速疾转换难可了知。不显了者。谓犯声明相不领而答。或先为典语后作俗语。或复翻此。不相续者。谓于中间言词断绝。凡所言论犯此九失。是名言过

论出离者。谓立论者。三种观察兴废言论。云何名为三种观察。一观察德失。二观察众会。三观察善不善

云何观察德失。谓立论者。方欲立论应如是观。我立是论。将无自损损他及俱损耶。不生现法后法及俱罪耶。勿起身心所有诸忧苦耶。莫由此故执持刀杖斗骂诤讼谄言妄语而发起耶。将无种种恶不善法而生长耶。非不利益安乐自及他耶。非不利益安乐多众生耶。非不怜愍于世间耶。不因此故诸天世人无义无利不安乐耶。彼立论者如是观时。若自了知我所立论能为自损。乃至天人无义无利及不安乐。便自思择。不应立论。若如实知我所立论不为自损。乃至能引天人义利安乐。便自思择。应当立论。是名第一论出离相

云何观察众会。谓立论者。应当观察现前众会。为有执着为无执耶。为有贤正为无有耶。为有善解为无解耶。如是观时。若知众会有所执着非无执着。唯不贤正无有贤正。唯不善解无善解者。便自思择。于是众中不应立论。若知众会无所执着非有执着。唯有贤正无不贤正。唯有善解无不解者便自思择。于是众中应当立论。是名第二论出离相

云何观察善不善。谓立论者。应自观察善与不善。我于论体论处论依论严论负论出离等。为善为不善耶。我为有力建立自论摧伏他论于彼负处解脱不耶。如是观时。若自了知我为不善非善解了我无力能非有力能。便自思择。与对论者不应立论。若自了知我善非不善有力非无力。便自思择与对论者应共立论。是名第三论出离相

论多所作法者。谓有三种。于所立论多所作法。一善自他宗。二无畏。三辩才。问如是三法。何故名为于所立论多有所作。答由善了达自他宗故。于一切法能起谈论。由无畏故。于一切众能起谈论。由辩才故。于诸问难能善酬答。是故此三名为于所立论多所作法

显扬圣教论卷第十一显扬圣教论卷第十二

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之八

释应知多种者。嗢柁南曰

  体释文义法　　起义难次师
  说众听赞佛　　略广学胜利

论曰。体者。诸经体性略有二种。谓文及义。当知文是所依。义是能依。如是二种总名所知境界

释者。略有五种应知。一法。二等起。三义。四释难。五次第

文者。略有六种。一名身。二句身。三字身。四语。五相。六机请

名身者。谓共了增语。此复略说有十二种。一假名。二实名。三总名。四别名。五随义名。六戏论名。七易名。八难名。九显名。十隐名。十一略名。十二广名。假名者。谓于内诸蕴。立我有情命者等名。于外诸色。立瓶衣车乘等名。实名者。谓于眼等色等立根义等名。总名者。谓有情色受大种等名。别名者。谓佛友德友青黄等名。随义名者。谓质碍故名色。领纳故名受。能照能烧故名为日。如是等名。戏论名者。如呼贫名富。如是等类不观于义施设彼名。易名者。谓共所知想。难名者。谓翻于彼。显名者。谓其义易晓。隐名者。谓其义难晓。如达罗弭荼明咒。略名者。谓一字名。广名者。谓多字名

句身者。谓依名字释义满足。此复六种。一不满句。二满句。三所成句。四能成句。五序句。六释句。不满句者。谓文不究竟义不究竟。更加余句方得成满。如说诸恶者莫作。诸善者奉行。善调伏自心。是诸佛圣教。若唯言诸恶则于文未足。若复言诸恶者。又于义未足。若具言诸恶者莫作。则二俱满足。是即名为第二满句。所成句者。所谓前句待后句成。如说诸行无常。有起尽法。生必灭故。彼寂为乐。此中诸行无常是所成句。由有起尽法句之所成立。能成句者。谓第二句以能成立第一句故。序句者。如言善人。释句者。如言谓趣正丈夫

字身者。谓若究竟若不究竟。名之与句二种所依四十九字

此中欲为名首名为句。首句必有名。若唯一字则不成句。又若有字名所不摄。则唯字无名。问何因缘故。建立名等三种身耶。答为领增语触所生受故。问名者何义。答目种种事。令世共知故。又能令意作种种相故。又由语言所传述故。谓之为名。问句者何义。答摄受于名。究竟显了不现见义。故名为句。问文者何义答显发名句。故谓之文

如薄伽梵说增语增语路。如是广说。增语者。谓一切众类共所立名增语。路者。谓众类之欲能起彼故。词者。谓彼相应语及与各别彼彼方言。彼所依故名为彼路。施设者。谓分析一法建立多种。彼所依处名为彼路。欲即是词无有别欲。此词即是增语施设之路。彼名身等略有六种依处。一法。二义。三补特伽罗。四时。五数。六处所。彼广分别。如闻所成地

语者当知略有八分。谓上首美妙等由彼语言具足相应。乃至常委分资粮等德故能说正法。上首语者。趣涅槃宫为先首故。美妙语者。清美音故。显了语者。文辞善故。易解语者。巧辩说故。乐闻语者。引法义故。无依语者。不依希望他信己故。不逆语者。言知量故。无边语者。善巧多故。是八种语当知略具三德。一趣处德。谓初一种。二自体德。谓次二种。三加行德。谓所余种。相应者。谓名句文身次第善安立故。又依四种道理共相应故。助伴者。能成次第故。随顺者。解释次第故。清亮者。文句显了清净故。有用者。善入众心故。相称者。如众会故。应顺者。称法故。引义故。顺时故。常委分资粮者。常修委修故。名常委。彼分者。谓正见等。资粮者。是彼资粮故

相者。谓诸蕴相应。诸界相应。诸处相应。缘起相应。处非处相应。念住相应。如是等相应言说。或声闻说。或菩萨说。或如来说。是名为相。机请者。谓因机请问起于言说。此复根等差别有二十七种补特伽罗。应知。此中由根差别故分成二种。谓钝根利根。行差别有七种。谓贪行等。如声闻地说。品类差别有二种。谓在家出家。愿差别有三种。谓声闻独觉菩萨。可救不可救差别有二种。谓涅槃法不涅槃法。方便差别有九种。谓已入正法。未入正法。有障碍。无障碍。已熟。未熟。具缚。不具缚。无缚种类差别有二种谓人及非人

如是六文总摄为四。一所说。谓名身等及相一分。二所为。谓机请摄二十七种补特伽罗。三能说。谓语言。四说者。谓佛菩萨及与声闻。如是一切六种相貌总显于文。若减一种义不显了。由能显义是故名文

义者略有十种。一地义。二相义。三作意义。四处所义。五过患义。六胜利义。七所治义。八能治义。九略义。十广义

地义者。略有五地。谓资粮地。方便地。见地。修地。究竟地。又广分别有十七地。谓五识身相应地。意地。有寻有伺地。无寻唯伺地无寻无伺地。三摩呬多地。非三摩呬多地。有心地。无心地。闻所成地。思所成地。修所成地声闻地。独觉地。菩萨地。有余依地。无余依地

相义者。当知五种。一自相。二共相。三假立相。四因相。五果相。如是五相若广分别如思所成地。复有五相。一差别相。二瑜伽相。三转异相。四染污相。五清净相。此五种相当知。如前处处分别复有五相。一所诠相。二能诠相。三此二相属相。四执着相。五不执着相。所诠相者。谓相等五法如五法藏说。能诠相者。谓即于彼法依止名等。为诠诸法自体差别所有言说。此亦能显遍计所执自体。应知。此遍计所执自体有多种名。所谓亦名遍分别所计。亦名和合所成。亦名所增益相。亦名虚妄所执。亦名言说所显。亦名文字方便。亦名唯有音声。亦名无有体相。如是等类差别应知。此二相属相者。谓能诠所诠互相属着。遍计所执自体执所依止。执着相者。谓无始流转一切愚夫遍计所执自体执及此随眠。不执着相者。谓已见谛者如实了知。遍计所执相及彼习气解脱。正分别知。随其所应分别。如思所成地等

作意义者。有七种作意。谓了相等。如前说。若广分别如声闻地复有十智。谓苦智。集智。灭智。道智。法智。种类智。他心智。世俗智。尽智。无生智。若广分别如声闻地。复有六识身。所谓眼识乃至意识。如前略释。若广分别如五识身相应地及意地。复有九种遍知。谓欲系见苦集所断断初遍知。色无色系见苦集所断断二遍知。欲系见灭所断断三遍知。色无色系见灭所断断四遍知。欲系见道所断断五遍知。色无色系见道所断断六遍知。顺下分结断七遍知色爱尽八遍知。无色爱尽九遍知。若广分别如三摩呬多地。又有三解脱门。谓空无愿无相。此亦如三摩呬多地广说。是中诸法应当观察。几种作意之所思惟。几智所知。几识所识。几种遍知之所遍知。几解脱门之所解脱。以如是等无量观门。应观诸法。处所义者略有三种。一事依处。二时依处。三补特伽罗依处

事依处者。复有三种。一根本事依处。二得方便事依处。三愍他事依处。根本事依处有六种。一善趣。二恶趣。三退堕。四升进。五流转。六寂灭。得方便事依处者。有十二种。谓十二种行。一欲行。二离行。三善行。四不善行。五苦行。六非苦行。七顺退分行。八顺进分行。九染污行。十清净行。十一自义行。十二他义行。愍他事依处者有五种。一令离欲。二示现。三教导。四赞励。五庆慰

此中善趣者。谓人天。恶趣者。谓那洛迦等。退堕者。复有二种。谓不方他及方他。不方他者。所谓自然寿命退减。如寿命当知色力安乐辨等亦尔。方他者。谓族姓退减。自在增上退减。少枝属言不肃弊恶慧。不能证获微妙广大色香味触。于诸胜妙所受用具心不喜乐。如是等类名为退堕。翻此退堕如其所应。即名升进。流转者。谓即此善趣恶趣退堕升进。寂灭者。谓有余依无余依寂灭界

欲行者。如十种欲所引中说。离行者。谓即于彼所受用事。知无常已厌欲出家。受持禁戒守护根门等。善行者。谓施戒修有漏善行。不善行者。谓三种恶行。苦行者。谓露形无衣。如是等乃至广说。非苦行者。谓受用如法所得资具。弃舍乐行远离二边。所谓受用欲乐行边及与受用自苦行边。勤行中道依止于法。求衣钵等及正受用。顺退分行者。谓若行能障升进分等。顺进分行者。谓与上相违。染污行者。如鹦鹉经说。略有三种。谓业杂染。烦恼杂染。流转杂染。当知此等有九根本句。谓业杂染有三句。一贪二嗔三痴。烦恼杂染有四句。谓四颠倒。流转杂染有二句。谓无明及有爱。所以者何。由三不善根生起种种业杂染故。由四颠倒能发种种烦恼杂染故。由无明门引生种种诸出家者流转杂染故。由有爱门引生种种诸在家者流转杂染故。清净行者。略有三学五地。此三学等。当知亦有九根本句。谓增上戒学增上心学所摄无贪无嗔无痴在资粮地及方便地。增上慧学所摄四无颠倒明及解脱在见地修地及究竟地。自义行者。谓自利行如声闻独觉。彼虽或时起利他行。然本期愿为自利故亦名自义。他义行者。谓利他行如佛菩萨。究竟利益无量众生。乃至广说

令离欲者。诃毁六种黑品诸行示现过患令离爱欲。示现者。为令受学白品行故示现四种真实道理。教导者。谓示现已得。信解者。令于学处正受正行。由已于彼得自在故。而告之曰。汝等今者于如是如是事。应正作应随学。赞励者。谓彼有情若于所知所行所得中心生退屈。尔时称赞策发彼心。令于所知所行所得中堪有势力。庆慰者。谓彼有情于法随法勇猛正行。即应如实赞说令其欣喜

复次令离欲。示现者。或有令离欲而不示现。如教导他令其离欲。而谓彼曰。如某所言不应作者。汝今必定不应复作。或怖彼言。汝若作者我当解作或复求彼。汝若是我亲爱友者必不应作。或复示现不令离欲如处中者。示现有情功德过失。而不遮彼令不造过。或有亦示现亦离欲。如示彼过令其远离教导者。初未受学令其受学。赞励者。学已未进令其升进。庆慰者。有五种胜利。一令彼于已所证心得决定。二令余于彼所证胜德起心趣求。三令诽谤者心处中住。四令不信者心生净信。五令已信者倍复增长。若有庆慰他人善事。当知是人造作增长能感悦意众天生业。若命终已。彼彼所生常闻悦意美妙音声无不悦意

复次欲行或有能感善趣。如为欲故造后善业。或有能感恶趣。如以非法摄受诸欲离行。行若毁犯能感恶趣。若无毁犯能感善趣。及作寂灭资粮善行。能感善趣及为寂灭资粮。不善行能感恶趣苦行。由依邪见苦自身故能感恶趣。非苦行能为寂灭资粮及感善趣。顺退分行能感退堕。顺进分行能感升进。染污行能感流转。清净行能证寂灭。自义行唯令自己感善趣引升进证寂灭。他义行俱令自他生善趣引升进证寂灭

如是三事根本事有六种。所谓善趣乃至涅槃。得方便事有十二种谓十二行。悲愍他事有五种。所谓五种悲愍众生。此中由根本事增上力故。依十二行如其所应令他离欲。乃至庆慰时

依处者。略有三种。一过去言依。二未来言依。三现在言依。如经广说

补特伽罗依处者。谓钝根等二十七种数取趣应知

如上所说。事时补特伽罗。佛薄伽梵。依此三处流布圣教。故名依处

过患义者。谓于应毁厌义而起毁厌。或法或众生

胜利义者略而言之。于可称赞义而起称赞。或法或众生

所治义者。略而言之。一切杂染行

能治义者。谓一切清净行。如贪是所治不净是能治。嗔是所治慈为能治。如是等尽当知略义者。谓说诸法通种类义

广义者。谓说诸法别种类义

复次说不了义经故。说了义经故

复次略义有二种。一名略。二义略。广义亦二种。谓名广。及义广。如薄伽梵说。舍利子。我能广略宣说正法。然悟解者甚难可得。于彼经中长行文广义略伽他义广文略

为摄十义故说中间。嗢柁南曰

  诸地相作意　　依处德非德
  所对治能治　　略广义应知

复次如是略说佛教体性十种义已。诸说法者。应依圣教寻求十种。若具不具既自求已。应为他说

如是建立文义体性已。诸说法者。应以五相随顺解释一切佛经。谓初应略说法要。次应说等起。次应释义。次应释难。后应辩次第。法者略有十二种。谓契经等十二分教

契经者。谓缝缀义。多分长行直说摄诸法体。应颂者。谓长行后讽颂及略举所说不了义经

记别者。谓广分别略所举义及记命过弟子生处

讽颂者。谓以一句说。或二句说。或三四五六句等说

自说者谓不请而说。为令弟子得胜解故。为令上品所化众生安住胜理。自然而说名为自说。如经言。世尊今者自然宣说

因缘者。谓因请问说。如经言。世尊于一时中因没力伽罗子。为诸苾刍宣说法要。又依别解脱增上道毗奈耶所有言说。谓依如是如是因缘。依如是如是事。世尊说如是如是语。是名因缘

譬喻者。谓有譬喻经。由譬喻故隐义明了。本事者。谓除本生宣说前际诸所有事

本生者。谓宣说己身于过去世行菩萨行时诸本生事

方广者。谓说菩萨道如说十地四菩萨行等。及说如来百四十不共佛法。谓四一切种清净乃至一切种妙智。如菩萨地广说。又法无量故。义深广故。时长远故。谓极勇猛经三大劫阿僧企耶方得成满故名方广

希法者。谓佛及诸弟子说希奇法。如诸经中。因希有事故起于言说

论议者。谓诸经所摄摩怛履迦。且如诸了义经皆名摩怛履迦。所谓如来自广分别诸法体相。又诸弟子已见圣迹。依自所证无倒显示诸法体相。亦名摩怛履迦。摩怛履迦亦名阿毗达磨。犹如世间一切书算诗论。皆有本母当知经中研究法相。所有言说亦复如是。又如世间若无诸字本母字不显了。如是十二分教中若不建立诸法体相法不明了。若建立已。诸法自相共相皆得显现。又复能显无杂法相故。即此摩怛履迦名阿毗达磨。依此摩怛履迦所余解释诸经义者亦名邬波第铄

等起者。略有三种。谓事时补特伽罗。依处别故。如经中说。于如是时。为如是补特伽罗。依如是行。令彼离欲乃至庆慰

义者。略有二种。一总义。二别义。当知总义复有四种。一引了义经。二分别事究竟。三行。四果。行复二种。谓邪行正行。果亦二种。谓邪行果正行果。当知别义亦有四种。一分别差别名。二分别自体相。三训释名言。四义门差别。训释名言复由五种方便。一由相。二由自体。三由业。四由法。五由因果。义门差别亦有五种。应知。一自体差别。二界差别。三时差别。四位差别。五补特伽罗差别。自体差别者。谓色自体有十色处差别。受自体有三受差别。想自体有六想差别。行自体有三行差别。识自体有六识差别。如是等类自体差别应知。界差别者。谓欲界色界无色界。时差别者。谓去来今。位差别者。当知差别二十五种。谓下中上三位。苦乐不苦不乐三位。善不善无记三位。闻思修三位。增上戒增上心增上慧三位。内外二位。所取能取二位。所治能治二位。现前不现前二位。及因果二位。补特伽罗差别者。如前所说二十七种。应知

释难者。若自设难若他设难。皆应解释。当知设难略有五因。一为未了义得显了故。如言此文有何义耶。二语相违故如言。何故薄伽梵前后说异。三理相违故。如有显示与。四道理相违之义四不定显示故。如言何故薄伽梵于一种义种种异门差别显示。五究竟不可见故。如言内我之体有何相貌而常恒不变自性正住。如是等类

于此五难。如其次第应当解释。谓于不了义难方便显了于语相违难随顺会通。如于语相违难随顺会通。如是于不定显示难究竟不可见难亦尔。于理相违难。或以黑教道理而判决之。或复显示四种道理。或显因果相应道理。谓此言显果。或复显因。又于问难应设四记。决定记者。谓为如理问者无倒建立诸法体相故。分别记者。谓为如理不如理问者开示差别相故。反诘记者。谓为止息戏诤论故。默置记者。有四种因。谓无体性故。乃至彼相法尔故。如前已说。若广分别如思所成地。又如有问如来灭后为有为无等。此于世俗谛及胜义谛理趣皆不可记。是故默置。以约胜义无如来故。不可记别。若约世俗所依能依。道理违故。及断灭果非真实故。亦不可记。如来灭后是有无等

次第者。略有三种。一圆满次第。二解释次第。三能成次第。为显此三次第略引圣教。如世尊言。我出家时盛美第一盛美最极盛美。此言即显盛美。圆满次第。又复说言。曾处我父净饭王宫颜容端正。乃至广说。此言即显盛美。解释次第。又言。为何义故盛美出家。由见老病死等法故。此言即显能成次第。又复经中略说诸法。如言三受苦乐不苦不乐。如是等。此中唯显圆满次第。由所余句圆满此受。故名圆满。如受应知四圣谛中。先说初句。后后次第随顺分析亦尔。能成次第有二种。或以前句成立后句。或以后句成立前句。当知解释次第亦尔

师者。谓成就十法。名说法师众相圆满。一善于法义。谓于六种法十种义善能解了。二能广宣说。谓多闻闻持其闻积集。三具足无畏。谓于刹帝利等胜大众中宣说正法无有怯惧。又因此故声不嘶破腋不流汗念无忘失。四言词善巧。谓语工圆满八分成就言词具足处众说法。语工圆满者。谓文句相应助伴等。乃至广说。八分成就者。谓上首美妙等。乃至广说。五善方便说。谓二十种善方便说如以时殷重等相。六具足成就法随法行。谓不唯听闻语言为极要如说行七威仪具足。谓说正法时。手足不乱不摇头动眉。口面支节无有改变。进止去来端严庠序。八勇猛精勤。谓常乐听闻所未闻法。于已闻法转令明净。不舍瑜伽不舍作意心不舍离内奢摩他。九无有疲厌。谓为四众广宣妙法身心无倦。十具足忍力。谓骂弄诃责终不反报。若被轻蔑不生忿戚。乃至广说

说众者。谓处于五众宣八种言。何等为八。一可喜乐言。二善开发言。三善释难言。四善分析言。五善顺入言。六引余证言。七胜辩才言。八随宗趣言

五众者。一在家众。二出家众。三清净信众。四邪怨众。五中平众

可喜乐言者。有五种相应知。一有证因。二有譬喻。三语业具足。四文字句美。五言词显了。善开发言者。开深隐义令显现故。辩粗显义令深邃故

善释难言者。能善解释五种难故。如前应知。善分析言者。析一一法衣增一道理乃至十种。或复过此善分别故。如依一法建立。二种三种四念住等。乃至广说

善顺入言者。唯善显释契经应颂等十二分教终不引摄邪道异论

引余证言者。谓引余经成立所说

胜辩才言者。随自所忍善分别义

随宗趣言者。谓依摩怛履迦分别显示。或依余无倒说者所说言教如理解释

复次处在家众。应依毁诸恶行称赞善行现前说法。令其止息及进修故。处出家众。应依增上戒等三学现前说法。令彼速疾修圆满故。处净等众。应依圣教广大威德现前说法如其次第令倍增长。令处中住。令生净信故

显扬圣教论卷第十二显扬圣教论卷第十三

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄净义品第二之九

听者。谓说法师说正法要。安处听者。令住恭敬无倒听闻。问何故安处。答谓或由一因或乃至十

一因者。所谓恭敬听闻正法。现证利益及安乐故。此中或利益非安乐。或安乐非利益。乃至四句。如菩萨地法受中说

二因者。谓善建立。一切法故。善建立者。当知离过失故。具大义故。又为说者听者速疾获得沙门果故。若不尔。诸说法者徒废己业虚设言论。诸听法者空自疲劳无所证获

三因者。正法能令舍恶趣故。得善趣故。速能引摄涅槃因故。如是三事。恭敬听闻方可证得

四因者。一恭敬听时能善了达契经等法。二如是正法能令有情舍诸不善摄受诸善。若善听者即能精勤若舍若受。三由舍受故舍离恶因所招后苦。四由此受舍善恶因故。速证寂灭。五因者。谓薄伽梵所说正法。有由序有出离有依趣有勇猛有神变。如是五种。若广分别如摄异门分

复有五因听闻正法。谓我当闻所未闻。我当闻已研究。我当除断疑心。我当调伏诸见。我当于深义句以慧通达。佛薄伽梵说。此五因显闻思修三种妙慧究竟方便。初二种因显闻慧。中二种因显思慧。后一种因显修慧

六因者。一为欲敬报大师恩德。谓佛世尊为我等故行于无量难行苦行求得此法。云何今者而不听闻。二观自义利。谓佛正法有现义利。三究竟远离一切热恼。四善顺正理。五易可了见。六诸聪慧者内证所知

七因者。谓七正法如经言。我当修习七种正法。谓知法知义乃至知补特伽罗尊卑

八因者。一佛法易得乃至为旃荼罗等而开示故。二易可修学。行住坐卧皆得习故。三引发义利。谓能引世间出世间果故。四初善。五中善。六后善。七感现乐果。八引后乐果

九因者。谓能脱九种逼迫事故。一能出生死大牢狱故。二永断贪等坚牢缚故三摧破七种大贫本故。及建立七种大财富故。四超度善行听闻正法。诸饥俭故及建立彼诸丰足故。五灭无明闇起慧明故。六度四暴流登涅槃岸故。七对治烦恼诸内病故。八解脱一切贪爱网故。九能度无始流转旷野稠林杂染行故。诸牢狱中生死牢狱最为第一。是故初说

十因者。一恭敬听闻如来法已得思择力。由此能受闻法义利。如法求财不以非法。虽复受用深见过患。二善知出离。谓退失财宝无忧无戚亦不嗟怨。乃至广说眷属离丧不深悲叹。若遭重病亦不愁恼。三深见诸欲多有过患。及见出离最胜功德舍家入道。离卧具等所有贪着。乃至证得诸妙静虑。四恭敬无倒听闻正法。能顺证解广大甚深相似甚深诸缘起法。又能引发广大善根出离欢喜。如薄伽梵说。我圣弟子专心属耳听闻正法。能断五法能修七法速疾圆满。五诸圣弟子恭敬听法。所有集起皆转成灭。六解正法已远离尘垢。于诸法中生正法眼。七能善引摄证预流果最胜资粮。乃至证得阿罗汉果及能引摄阿罗汉果最胜资粮。八能善引摄独觉资粮。九能善引摄无上正等菩提资粮。十引发一切世出世间静虑等持等至等定

赞佛略广者。诸说法者说正法时。应先赞佛赞有二种谓略及广

略者有五种。一妙色。二寂静。三胜智。四正行。五威德妙色者。谓三十二大丈夫相。及八十种随形好。寂静者。谓善能守护诸根门等。及能永拔烦恼习气。胜智者。谓于过去未来现在世法及非世法无有挂碍。正行者。谓自他利乐正行圆满。威德者。所谓如来神通游戏。复有六种略赞如来。谓德圆满故。离垢染故。无浊秽故。无与等故。唯利众生以为业故。于此业用得自在故。此广分别。如摄决择分。广者。谓广赞如来无边功德。如说是薄伽梵无边名称。德无量故。能施光明。发智明故。能除黑闇。永灭一切无智闇故。成就明眼。具三眼故。见胜义谛。了达无等诸圣谛故。成就禁戒。具足增上净尸罗故

又说是薄伽梵两足中尊。调御中胜。沙门众中最为殊美。是诸世间难得珍宝

又说是薄伽梵为愍物者。悲有情者。乐为义者。求利物者。悲现前者

又说是薄伽梵为眼为智。了达真理。于甚深义决定显了。凡有所作皆依义转

又说是薄伽梵能证一切所未证义。以先证圣八支道故。自然证故。立未曾立圣梵行故。又说是薄伽梵知圣道者。显圣道者。说圣道者。导圣道者。又说是薄伽梵人中师子。离怖畏故。人中牛王。御大众故。人中御者。众上首故。人中龙王。无误失故。人中良马。心调顺故。人中最胜。家姓色等超诸众故。人中最上。戒行智慧最胜威德越诸人故。人中莲花。世间八法所不染故。无等无与等故。无等等等去来今无有与等诸善逝故。第一于诸有情为最上故。大仙上尸罗故。长时积集诸梵行故。证古大仙所证法故。最胜者。调伏一切天魔外道烦恼等故。牟尼无有一切掉慢等故。与三寂静具相应故。不可引夺一切生等及诸异论不能夺故。沐浴离诸恶故。到彼岸越度一切萨迦耶故

又说如来应正等觉明行圆满善逝世间解无上丈夫善调御士天人师佛薄伽梵

又说白法圆满一切智者正法之主无忘失法有情坚胜。一切苦乐不缠扰心

又说善调者密护根门。善满足故。寂静者净尸罗受。善满足故。安隐者已入决定地故。般涅槃者已证菩提故。拔毒箭者永拔一切有爱箭故

又说调伏一切不调伏者。寂静一切不寂静者。如前已说。安隐一切不安隐者善能建立诸凡夫等。令证预流一来果故

又说无杻械者。出火坑者。度深堑者。制求欲者。不倾动者。摧慢幢者。大常住者

又说大阿罗汉诸漏永尽。如前广说。乃至尽诸有结

又说永断五分成就六分。如是广说乃至纯善积聚无上丈夫

又说善知法者乃至善知补特伽罗尊卑者。又说大沙门大婆罗门离垢无垢良医商主胜观察世间依众生尊。此中离垢者。烦恼障断故无垢者。所知障断故。又永拔习气故名无垢日夜六返观察世间故名胜观察。又说是一切种善清净者。大丈夫相及随形好。庄严身者具足十力。为大力者。具四无畏。无所畏者。成就大悲。于三念住。安住念者。成就三种不护及无忘失法。永害一切烦恼习气。具足一切种妙智者。此中大悲者。长时积集故。谓经三大劫阿僧企耶方乃证得。又复依缘一切众生故。缘一切种苦为境界故。得诸众生一切损恼变异事等所不能转故。于一切有情起平等行故

学胜利者。谓说法师应依如是建立释经法相。先应寻求若文若义。次应解了如先所说五种。为他说正法时解释道理。次应如是安立自身于先所说说法者相谓善法义等十种圆满。如是自安立已。然后依如先所说差别道理应起言说。谓处五大众以如前所说可喜乐等八种言词为众说法。又安处他令于恭敬无倒听闻。又应先赞大师功德。若有具足如是五分说正法者。当知犹如五分音乐能令自他生大欢喜。又能引发自他利益。又若能如是善修学者。当知具足五种胜利。一于佛言义解了不难。二能善圆满说诸法相。三能善起发自他相续广大欢喜。四引善出离天上人中广大名称。五生起无量最胜功德

复次如佛所说住学胜利经。此经体性。谓文及义。文者。谓此经言。汝等苾刍应当安住修学胜利。此中有十二字四名一句。如是则摄名句字身。此中言说是学处相故则摄于相。如来言说本为苾刍请问即摄机请。如来所说言音即摄于语。是故此经一句具摄六文。如是慧为上首等诸句中。随相应知

复次义者谓地义中但说声闻地义。或具五地。经言学胜利者。是资粮地。慧为上首者。是方便地。解脱坚固念为增上者。是见修等地。是名地义

相义中学胜利者。是戒自相。慧为上首者具二种相。谓慧所依助伴等中。唯慧自体是自相。慧之眷属及所缘等。名为共相。解脱坚固者。谓永离一切烦恼粗重。是解脱自相。念为增上者。是念自相。如是等是名相义

作意义中学胜利者。非作意体唯显作意建立处所。慧为上首者。显示了相胜解二种作意应知。解脱坚固者。当知显示远离摄乐方便究竟方便究竟果四种作意。念为增上者。当知此显观察作意。如是等是作意义。由此道理于智等中亦应随相分别

处所义中依于涅槃摄受学处。依清净行。如其所应起教导等。所谓教导乃至庆慰。当知此中亦通有善等行。随其最胜唯说清净行。唯依出家补特伽罗。又于下根等一切众生中。应当发起庆慰等事。谓依过去现在时起于庆慰。已证得故。正证得故。依现在时起于示现。依未来时起于教导及赞励。是名处所义

过患义中谓夫出家者。不应行于异行。不应贮余财物

胜利义中谓修三学满足是可称赞。所治义中谓犯尸罗无智烦恼及忘失念。当知护尸罗等即是能对治义。又一切杂染行皆是所治义。三学行等是能治义

略义中谓住学胜利乃至念为增上。此略序宗名为略义。广义中谓广分别此。应知是名广义更无过上

复次于解释中法者。谓于十二分教中契经所摄及记别摄。了义说故

等起者。谓为开示遍行行智力自体故发起此经。又为显示精勤修习清净行者及示爱重世财利者。令信解此所化众生依住学胜利等精勤修习。速得圆满三学胜利故。又为显示四种苾刍体故。经言。学胜利者。为令远离种性形相苾刍体故。及令远离诈现密护轨则威仪苾刍体故。又言慧为上首者。为令远离计着虚妄名称苾刍体故。解脱坚固念增上者。劝彼修习真实行苾刍体故。所以者何。若有爱乐名称等人。但为名等励己。听受正法不为增长智慧。若有远离前所说过。是名真实行摄于正解脱乐欲证得。又为于下劣法生知足者。劝令修学增上法故。谓为乐求随顺世间文章咒术。于戒慢缓者。说学胜利为唯守尸罗。舍多闻者。说慧为上首。为唯于闻思生知足者。说解脱坚固。为于戒慧解脱起增上慢者。说念为增上。如是等类是名等起

义者总义中当知。此经宣说正行及正行果。如是戒等三学名学分量。经言。如是住者此显正方便行所摄四种瑜伽。又言。如是住三学者此显正行果。此中信欲为先故摄受尸罗。听受法时由正勤力修习慧等要假方便。别义中所谓学者。是精进如教行若习若修名差别也。身语及命清净现行是学自相。由戒忍等显发正行。故名为学。又为求寂静清凉之果进习除灭。故名为学。如是等类训释名言。如前应说。相故。自体故。业故。法故。因果故。义门差别中先辩自体差别学者。显示七品尸罗。或过一百五十学处。界差别者。谓欲缠中唯有别解脱律仪静虑律仪。唯在色无色缠无漏律仪是不系。时差别者。谓过去世已学。未来世当学。现在世正学。位差别者。谓已入正法补特伽罗。学未成熟是下位。学正成熟是中位。学已成熟是上位。心不喜乐励力修行诸梵行者。是苦位。其心喜乐不励力修行诸梵行者。是乐位。任运修行诸梵行者。是不苦不乐位。唯是善位非不善位。若听受者是闻位。若审察者。是思位。得定修者。是修位。若未证得增上心慧者。是增上戒位。若已证得者。名增上心慧位。如是等类是位差别。补特伽罗差别者。此中意说出家补特伽罗。或钝根或利根。或贪等行或等分行或薄尘行。唯是声闻非独觉非菩萨。由彼独觉各别觉悟。诸菩萨等解脱坚固。是故如来不为彼说共住修学。又复此中唯说般涅槃。为法者。已入正法者。无有障碍者。具缚者。不具缚者。非无缚者。唯人非天。是名补特伽罗。差别如于学如是分别当知。于胜利性慧上首性。解脱坚固性。念增上性。随其所应五种差别。应广分别。此中胜利者。是功德增进圆满名之差别。如经说。观十胜利者。是其体性。释名者是法于身随摄利益及应称赞。故名胜利。又如是法随生有情之所随逐。故名胜利。又如是法称赞随逐。故名胜利。义门差别者。当知十种差别。谓能摄僧伽令僧精恳。乃至广说

经言。苾刍者是沙门舍家趣非家等。名之差别。具足别解脱律仪众同分是苾刍体。释名者于色形等精勤守护近恶趣等又能摄引不坏功德。故名苾刍。义门差别者。谓刹帝利等差别。上族下族差别。少中老等差别应知。经言。住者。是俯就于时精勤修习。名之差别。此住自体。离所说学无别有法。释名者。由种种威仪摄受时分。故名为住。义门差别者。谓威仪差别。朝中后分差别。日夜差别。应知。经言慧者是智见。明现观等。名之差别。简择法相心所有法为体。释名者。简择为体。非智对治故名为慧。又各各差别能了知此故名为慧。又能显了识所了别故名为慧。义门差别者。随其所应。如前分别

经言。解脱者。是永断离系清净。尽灭离欲如是等。名之差别。粗重永除烦恼断灭为体。释名者。能脱种种贪等系缚故名解脱。又复世尊为种种牟尼说。此以为牟尼体性故名解脱。义门差别者。谓待时解脱。不动解脱。见所断烦恼解脱。修所断烦恼解脱。欲缠解脱。色缠解脱。无色缠解脱。如是等类如前差别应知

经言。念者是不忘失。心明记忆等。名之差别。心所有法为体。释名者。追忆诸法故名为念。又如所经事随所作意令心明记故名为念。义门差别者。谓念佛念法乃至广说六念应知。又念住差别等。随其所应当广说

复次释难中。问学胜利者义何谓耶。答此言欲显于增上戒学见胜功德勤修习住。问慧为上首者义何谓耶。答此言显示于诸根中慧根第一。问解脱坚固者义何谓耶。答此言显示见修所断烦恼永断。问念为增上者义何谓耶。答此言显示于少下劣所得功德不生知足

问于余经中三学次第世尊异说。何故此中增上戒后即说增上慧。又复不说增上心学胜利耶。答此言总摄闻思修等所成诸慧。欲显由无悔等次第发三摩地。即是显示增上心学。如薄伽梵说。于是五根最能摄受所摄受者。所谓慧根。以诸苾刍成就如是胜慧根故乃至能修三摩地根。是故由慧根力乃至三摩地根皆得成就。今此经中薄伽梵显示智慧是三摩地引因及能引断烦恼。由说增上慧学故。当知兼说慧俱增上心学

问若尔余经中说三学修习进趣圆满。何故不说增上心学修习满耶。答如前所说道理此中应知

问何故此中但说学胜利住不说慧胜利住解脱胜利住。答但劝摄受下劣胜利。当知亦令所化有情摄受一切增上胜利。又摄僧等十种胜利明显易入。是故但说学胜利住。问夫解脱者于诸法中最为上首。何故但说慧上首住不说解脱上首住。答于下劣中尚令所化有情取增上性。当知亦令所化于增上法取为增上。又于解脱显差别故。何者差别。谓望无常上首之慧解脱最为常住坚实。问何等名为学胜利住。答由于随所建立众多学处观十胜利故。常守尸罗坚守尸罗恒作恒转。如是名为住学胜利。问摄受僧等诸句何义。答摄受僧伽者是总句。余是别句令僧精恳者。令离受用欲乐边故。令僧安乐者。令离受用自苦边故。未信令信者。未入正法令趣入故。已信令增长者。已入正法令成熟故。难调伏令调伏者。犯尸罗者善驱摈故。令惭愧者安乐住者。净持戒者令无悔恼故防护现法漏者。顺伏烦恼缠故。损害后法漏者。止息邪愿住梵行故。随顺永断惑随眠故。为令多人梵行久住增广。乃至为诸天人正善开示者。为令圣教相续不断绝故

如是十种胜利。略说则为三种胜利。广开三种则为十种。三种者。一令僧不染污住。二令僧得安乐住。三令圣教长时随转。此中由七种随护显示不染污住及安乐住。七种随护者。一敬养随护。二自苦行随护。三众具乏少随护。四展转众随护。五心追变随护。六烦恼缠随护。七邪愿随护。最后一句显示圣教长时随转

云何名为常守尸罗。谓不舍学处故。云何名为坚守尸罗。谓不犯学处故。云何恒作。谓学处不穿穴故。云何恒转。谓穿穴尸罗复转还故。云何受学学处。谓具足随学诸学处故。如是行者。常守尸罗坚守尸罗。闻正法已独于静处。系念思惟筹量观察。为欲发起增上心慧故。又此行者。依闻思修所生智慧能证解脱。此解脱性不退法故。说名为坚。出世智果故不可退转。又此行者。由念力故审自观察。我尸罗蕴为圆满不。我于诸法为通达不。我于解脱为善证不。如是依止忆念力故。具学胜利发上首慧证坚解脱。又复此念略有三种。谓或因说法。或依教授。或复观察作与不作

问薄伽梵宣说尸罗有无量种。谓邬波索迦尸罗。苾刍尸罗。邬波婆娑尸罗。静虑尸罗。三摩钵底尸罗。圣爱尸罗。如是等今于此中依何尸罗而说住学胜利。答苾刍尸罗由最胜故

问如薄伽梵说。慧亦多种。所谓闻所生慧。思所生慧。修所生慧。今于此中依何等慧而说住慧上首。答具说三慧。问佛说解脱亦有多种。谓世间解脱。出世间解脱。有学解脱无学解脱。可动解脱。不动解脱。如是等今于此中依何解脱而说解脱坚住。答依彼出世不动解脱

问如来说念亦有多种。谓于身等境界住念久作久说等随念。读诵等随念。教授等随念。应作不应作随念。念佛等随念。今于此中依何等念说念增上。答从胜为论说应作不作观察随念

复次次第中。谓先依苾刍尸罗住已。次听受正法。次应如理作意。如是行者。由净持戒故无有忧悔。由无悔等次第能发正三摩地。谓由方便所摄慧如理思惟故增上心学成就。是名圆满次第。前前为因后后得圆满故。又住学胜利为得慧上首故。住慧上首为证解脱坚固故。云何能得住学胜利乃至解脱坚固。谓由念增上力故。是名能成次第。又经言。若如是住修习三学速得圆满。是亦名为能成次第

解释次第者。如经言。大师者。谓能善教诫声闻弟子应作不应作事。故名大师。又能化导无量众生证苦寂灭。故名大师。又为摧灭邪秽外道出现于世。故名大师。声闻者。谓从他听闻正法音声。故名声闻。又能令他闻正法声。故名声闻

问复何因缘唯为声闻说住学胜利等。答由声闻众是薄伽梵随顺修学真实弟子故。法者。所谓宣说名句文身学处者。所谓宣说五犯聚事。成就怜愍者。于处长夜诸众生等。恒住慈等四种无量。成就悲者。能拔众生多苦法故。乐义利者。能授众生无量乐法故。求利益者。欲令众生摄受种种妙善法故。恒悲愍者。能拔众生种种诸恶不善法故。又言。为令多人梵行久住者依刹帝利等大种姓说。增广者。谓即此等诸众生类。后后众会渐渐广大。乃至为诸天人者。谓即于如是增广种类中有势力者。此显世尊大悲普覆非唯一分。正善开示者。谓如诸所有及尽诸所有一切诸法。说正法者。谓十二分教听受研寻住持读诵处静思惟。如是境界是名为法。为利益者。依增上戒说。为安乐者。谓不依止苦难不自在行。为利益安乐者。谓诸离欲者增上心增上慧行此行善故名利益。顺摄故名安乐。又若处世尊赞说杜多功德。是名利益。若处世尊听受百味饮食百千衣服。是名安乐。若处世尊建立三学。是名利益安乐。如来于诸法中以种种慧善观察者。谓若为利益。若为安乐。若为利益安乐。依增上戒学增上心学增上慧学说。此中有二因缘名善观察。谓于长夜遍了知故。不颠倒觉故。彼彼解脱善证得者依增上心增上慧说此中有二因缘名善证得。谓究竟行故。不退转法故。我尸罗蕴不圆满者。谓或于尸罗一分修习。或不依止。如是尸罗圆满修习诸等持戒。我于诸法不善观察者。由二种观察如前说。我于解脱不善证得者。由二种证得如前说。我所应说如是已说者。谓总结前略说及广分别应知

复次由六种相应当解释一切佛经。一由遍知诸法故。二由舍恶行大小惑故。三由受善行故。四由智遍知通达病等行故。五由彼果故。六由自他受彼果故。由如是六相及由如前建立诸相应。善解释一切佛经。此中法者。谓蕴界处缘起念住正断等。彼果者。谓厌离欲解脱般涅槃。自他受彼果者。谓我生已尽等。如是总名摄释分。今此品中显示此论有四种相。一最胜相。二自体相。三清净相。四辩教相。此中最胜相由二颂。自体相由五颂。清净相由二颂。辩教相由一颂

显扬圣教论卷第十三显扬圣教论卷第十四

        无著菩萨造

        三藏法师玄奘奉　诏译

    成善巧品第三

复次于此论体九事等中应善了知七种善巧。何等为七。颂曰

  于诸蕴界处　　及众缘起法
  处非处根谛　　善巧事应知

论曰。住正法者。应善了达如是七种善巧之事。问何故唯立七种善巧。答世间愚夫多如是计。颂曰

  身者自在等　　无因身者住
  流转作诸业　　及增上二种

论曰。于诸蕴中不善巧故。执诸蕴体为我身者。于诸界中不善巧故。执自在等为身生因或执无因身自然起。以不了达从自种因身得生故。所以者何。界者功能种子族姓因等名差别故。于诸处中不善巧故。执有身者依身而住取外境界。于缘起中不善巧故。执有身者流转生死。由不善知处非处故。执有身者能造诸业。由不善知诸根诸谛。执有二种增上身者。谓爱非爱业果增上者。及染污清净增上者。由不善知苦集两谛。计有染污增上者。由不善知灭道两谛。计有清净增上者。颂曰

  于身者等起　　实我所住持
  流转者作者　　及诸增上义
  染污若清净　　起七种愚痴
  对治此应知　　摄七种善巧

论曰。如前总说二种增上分别显示二种愚痴。谓增上义愚痴及染污清净愚痴。谁依七种身等愚转。颂曰

  妄计我身者　　依止诸根住
  于境界回转　　受用爱非爱
  言说所依住　　作者有觉者
  由于差别蕴　　总见一身者

论曰。身者愚者。由不了知色蕴体故。计有一我依止五根于境界转。由不了知受蕴体故。计有受者受用一切爱非爱事。由不了知想蕴体故。别计有我言说依住。不知想是言说依故。如薄伽梵说。如其所想起于言说。由不了知行蕴体故。计有作者。由不了知识蕴体故。计有觉者。非唯有识以诸世间于识蕴体起觉想故。如是愚夫。于诸差别蕴自相中。总起一种身者。愚痴即计身者。以之为我。复次等起愚者。颂曰

  迷惑初因故　　计常因无因

论曰。世间愚夫。或于身所有初因而生迷惑故。执不平等因。谓有常住自在天毗瑟弩天自性等因。或说无因。谓拨无一切能生因体。复次实我所住持愚者。颂曰

  我住持诸根　　能触及能受

论曰。计我住持诸根能触。顺苦受触顺乐受触。及能领受若乐若苦

复次流转作者增上义及染污清净愚者。谓计有各别住持身者我已。颂曰

  从此死生处　　计有流转者
  法非法作者　　及彼果增上
  于修习邪行　　计为染污者
  于修习正行　　妾计解脱者

论曰。彼愚痴者。于彼彼死生处。计有实我生死流转即此实我。造作后世法非法因即为此实我。于彼果自在受用故。彼果法生即此实我。依于果法习行邪行计为染者。修行正行计为解脱者。颂曰

  佛未出于世　　如是愚痴转
  由佛现世间　　说七种善巧

论曰。此中显示依如是时。如其所应外道愚痴众生还灭。由此七种善巧言说。不共一切诸外道故。此中蕴善巧者。颂曰

  知世等别故　　能除一合想
  即离与解脱　　众生不可得
  多种及总略　　共有差别转
  增益损减智　　蕴善巧应知

论曰。世等别者。谓诸蕴去来等体性差别。如薄伽梵说。诸所有色若过去若未来若现在若内若外若粗若细若劣若胜若远若近等。乃至广说。由胜智慧如实知故。于诸蕴中舍一合想。即是还灭。又于诸蕴中补特伽罗性不可得。何以故。即于诸蕴众生不可得。离于诸蕴众生亦不可得。解脱诸蕴众生亦不可得。如薄伽梵告西尔迦。汝于色蕴见如来耶。乃至汝于识蕴见如来耶。西尔迦答。不也乔答摩。如是乃至广说。于彼经中说色等蕴。若总若别补特伽罗皆不可得。今于此中但略说。总于五蕴是不可得。如是已说。了知色等相差别故。及能远离彼所对治增益执故。于诸蕴中自相共相皆得善巧。又复蕴者。是积聚义。能善了知是积聚义。名蕴善巧。此积聚义复有四种。谓多种义。总略义。共有转义。增益损减义。此中显示诸蕴自体及彼障断胜利。是名蕴善巧。云何界善巧。颂曰

  见三因生故　　说名界善巧
  从无始自种　　多种种生起
  由此及于此　　取者不可得
  依自智成故　　能除下劣性

论曰。由观根境识三法。从自因而生。名界善巧。所以者何。由彼诸法无始流转从自种生多生起及种种生起。当知多生起者。如经言。非一界故。种种生起者。如经言。种种界故。复次由依诸根于诸境界能取之我不可得故。能知所作依自成立。不由大自在天等。是故凡所欲为不生下劣自在修习。此中显示界善巧自体及彼障断胜利。是名界善巧。云何处善巧颂曰

  知诸触诸受　　由二种生门
  依止于触故　　当知处善巧
  如法处天处　　后后所依止
  由世俗谛故　　了知二种性

论曰。由善了知触生门体建立二处。谓根及境。如是由能生义故名为处。犹如世间修善法所名为法处。又善了知诸受依触。是故建立触为彼处。如是所居住义故名为处。犹如世间天像住所名为天处。又复触受二法生时。依世俗故了知二性。谓触者受者由触能触对受能领纳。此中显示就胜义谛。触者受者皆不可得。就世俗谛二皆可得。是名处善巧。云何缘起善巧。颂曰

  知未断无常　　因能生诸果
  自相续相似　　名缘起善巧
  众生不可得　　而有舍续者
  由了达甚深　　四种缘起故

论曰。能善了知从未永断无常之因能生诸果。名缘起善巧。谓如经说。此有故彼有。此生故彼生。如其次第。又能善知由从此因于自相续生诸果法。谓如经说。非缘余生而有老死等。又善了知从相似因生诸果法。谓如经说。身恶行者能感不喜不乐不爱不可意异熟身。妙行者。能感与上相违可意等异熟。如是等。复次即诸蕴相续名舍命者及续生者补特伽罗性不可得。由善了知四种甚深缘起故。谓不从自生。不从他生。非自他生。非无因生。此中显示缘起自体及彼障断胜利。是名缘起善巧。云何处非处善巧。颂曰

  不作不趣得　　二余体不转
  净见无余业　　非我自在二
  如是智能知　　处非处善巧
  于自果定处　　异此说非处

论曰。若不见我于因果二处而得自在。名处非处善巧。谓不作故。不趣故。不得故。二体不转故。余体不转故。净见无余业故。云何不作。谓不纯作妙善行故。是故无有自在之我。云何不趣谓离妙行不往善趣故。如经言。无处无容行身恶行。乃至得生天上。必无是处。乃至广说。云何不得。谓离善方便无漏圣道。定不能得道果所摄毕竟清净。如经言。无处无容不永断五盖。乃至不修七遍觉支能正证得苦尽边际必无是处。云何二体不转。谓无处无容非前非后。有二如来出现于世。乃至广说。云何余体不转。谓离丈夫身外余身必无有作转轮王等。如经言。无处无容女人得作转轮圣王。乃至广说。云何净见无余业。谓如经言。无处无容圣见具足补特伽罗故断物命。乃至受第八有。必无是处。有是处者。谓诸异生

今于此中言不作者。谓所计我于因不得自在。不得者通于因果。净见无余业亦尔。余唯于果。又处非处者。于自果决定名之为处。当知于余名为非处。由无倒慧于此善巧是名处非处善巧。此中显示处非处善巧自体及彼障断胜利。云何根善巧。颂曰

  于能取生住　　及染污清净
  无理我观余　　于彼果增上
  于如是方便　　名为根善巧
  谓于取生住　　染净增上故

论曰。若不见我于能取等是增上故名根善巧。何以故。非所计我观余因缘。于能取等增上自在。即余因缘于能取等是增上故。是故计我。不应道理。所言诸根于能取等是增上者。谓眼等六根于取六境是增上。男女二根于能生相续是增上。命根一种于相续住是增上。五受根于染污是增上。信等八根于清净是增上。此中显示根善巧自体及彼障断胜利。是名根善巧。云何谛善巧。颂曰

  二自性苦故　　合故不应理
  由无因有因　　及五种譬喻
  如是随觉故　　应知谛善巧
  随觉未曾见　　未受义因缘

论曰。由能善观我于染净二法非顺道理名谛善巧。何等为二。谓自性苦故。与苦合故。云何自性苦故。谓若我自性是苦者。为无因为有因。若无因者。常应染污。若有因者。应先清净后方染污。故不顺理。云何与苦合故。谓引五喻皆不顺理。何以故。若言苦与我合者。不应如两木共合。有不摄出离性过故。亦非如有情与木共合。有出离过故。亦非如火与薪共合。有性坏过故。亦非如衣与染色共合。于我体上如白净色少分亦不可得故。亦非如心心法合。何以故。心是能取与此同缘一境等可名相应。于我无此义故。不顺道理。又由观见未曾见义及彼因缘。又复观见未曾受义及彼因缘。名谛善巧。谓从昔来未曾了见苦集二谛及彼因缘。从昔已来未曾了见。未曾经受灭道两谛及彼因缘。此中显示出世智自体及彼障断胜利。是名谛善巧。颂曰

  当知诸善巧　　差别二十三
  异摄论为先　　后最极清净

论曰。应知蕴等善巧差别复有二十三种。谓异摄论善巧。闻所生智善巧。思所生智善巧。修所生智善巧。顺决择分智善巧。见道智善巧。修道智善巧。究竟道智善巧。练根智善巧发神通智善巧。不善清净世俗智善巧。善清净世俗智善巧。胜义智善巧。不善清净相有分别智善巧。善清净相有分别智善巧。善清净相无分别智善巧。成所作前行智善巧。成所作智善巧。成所作后智善巧。声闻智善巧。独觉智善巧。菩萨智善巧。最极清净智善巧。此中异摄论善巧复有二种。一种种摄善巧。二种种论善巧

种种摄善巧者有十一种。所谓界摄乃至更互摄。界摄者。谓诸蕴等自种子所摄。相摄者。谓诸蕴等自相共相所摄。种类摄者。谓诸蕴等遍自种类所摄。分位摄者。谓诸蕴等顺乐受等分位所摄。不相离摄者。谓诸蕴等由一法摄一切蕴等。以彼眷属不相离故。时摄者。谓诸蕴等过去未来现在各别相摄。方摄者。谓诸蕴等依方而转。若依此方所生即此方所摄。全摄者。谓诸蕴等具足五十八十二等所摄。一分摄者。谓诸蕴等各别少分所摄。胜义摄者。谓诸蕴等真如相所摄。更互摄者。谓诸蕴等更互相摄

种种论善巧者。谓于蕴等种种问答方便善巧。如以一行为。问应以顺前句顺后句四句无事句。答如有。问言若有界摄即有相摄耶。设有相摄复有界摄耶。且应依眼以四句。答或有界摄无相摄。谓生有色界不得眼。设得已失。若诸异生生无色界。或有相摄无界摄。谓阿罗汉最后眼。或有界摄亦有相摄。谓除上所说余有眼位。或有无界摄亦无相摄。谓阿罗汉眼坏失者。生无色界。已见谛者。及已入无余般涅槃界。如于眼如是分别。于余一切随其所应当广分别。如以界摄对相摄。如是以界摄对余摄。展转一行应广分别。如是以余摄对余摄除前前对后后。皆应以一行道理如其所应当广分别。复次若法蕴所摄此法界所摄耶。设法界所摄此法蕴所摄耶。此应以顺前句答。若法蕴所摄此法亦界所摄。或法界所摄非蕴所摄。谓无为法。如以蕴对界如是以蕴乃至对谛应依一行道理广辩相摄。如蕴对余如是以界对处等乃至以根对谛应广分别

此中不善清净世俗智善巧者。即是顺决择分智善巧。善清净世俗智善巧者。即是出世后得世间智善巧。胜义智善巧者。即是见道智善巧。如是三种即是不善清净相有分别智善巧。善清净相有分别智善巧。善清净相无分别智善巧。如是三种即是成所作前行智善巧。成所作智善巧。成所作后智善巧。又前三种差别者。未断烦恼生非烦恼对治。已断烦恼生非烦恼对治。已断烦恼生是烦恼对治差别故。中三种差别者。即此三种由有分别无分别世俗胜义智性差别故。后三种差别者。谓即此三种显示断前行智性正断道智性彼后时智性差别故。如是九智依相续。补特伽罗差别复建立四种应知

    显扬圣教论成无常品第四

复次如先所说。若欲正修行遍知等功德者。谓遍知苦等。云何于苦遍知。谓于苦谛遍知无常苦空无我。今随次第应广成立。此中成无常者。谓应显示无常体性及无常差别。云何无常。何等差别。颂曰

  无常谓有为　　三相相应故
  无常义如应　　六八种应知

论曰。无常性者。谓有为法与三有为相共相应故。一生相。二灭相。三住异相。又无常义差别者。如其所应或六或八应知。何等六八。颂曰

  无性坏转异　　别离得当有
  刹那续病等　　心器受用故

论曰。六种无常者。一无性无常。二失坏无常。三转异无常。四别离无常。五得无常。六当有无常。八种无常者。一刹那门。二相续门。三病门。四老门。五死门。六心门。七器门。八受用门。此中刹那相续二种无常遍一切处。病等三无常在于内色。心无常唯在于名。器受用二无常在于外色。此中无性无常者。谓性常无故。名曰无常。余变异无常有十五种颂曰

  变异应当知　　十五种差别
  所谓分位等　　八缘所逼故
  下界具一切　　中界离三门
  具三种变异　　上界复除器

论曰。十五种变异者。谓分位变异。乃至一切种不现尽变异。分位变异者。谓从婴儿位乃至老时前后不相似各别变异。显变异者。谓从妙色鲜肌润泽肤体乃至变为恶色粗肌枯瘁肤体。形变异者。谓肥瘦等变异。兴盛变异者。谓眷属资财及戒见等兴盛。与此相违名衰退变。异支节变异者。谓先具诸支节后变为不具。寒热变异者。谓于寒时踡局战栗。热则舒适流汗希求冷暖等变异。他所损害变异者。谓手足蹴搏蚊虻触等。身体变异。疲倦变异者。谓因走跳腾踯等。身劳变异。威仪变异者。谓四威仪前后易脱。损益变异。触对变异者。谓由顺苦乐等触变异故苦乐等受变异。染污变异者。谓心所有贪嗔等大小两惑娆乱变异。病等变异者。谓先无病苦后为重疾所逼身体变异。死变异者。谓先有寿命后空无识前后变异。青瘀等变异者。谓命终后身色青瘀胀烂乃至骨锁等变异。一切种不现尽变异者。谓骨锁位烧坏离散彼一切种都无所见变异

又此十五种变异由与八缘相应。八缘者。一积时贮畜。二他所损害。三受用亏减。四时节推谢。五火所烧。六水所坏。七风所燥。八异缘合。积时贮畜者。谓经时久故。有色之法不离本处自然朽败。他所损害者。谓由他种种逼恼因缘前后变异。受用亏减者。谓于种种所受用物为各别主宰之所食用损减变异。时节推谢者。谓冬时寒雪夏日暑雨。丛林药草或盛或衰。火所烧者。谓大火纵逸国城聚落悉为灰烬。水所坏者。谓大水漂漫闬里邑居并随沦没。风所燥者。谓大风飘鼓润衣湿地速令干[韅-革+日]。异缘合者。谓多贪者与嗔缘合时贪缠止息发起嗔缠。如是多嗔多痴者与余烦恼缘合应知亦尔。如是诸识异境现前亦尔。复次是无常义于欲界中一切具有。于色界中除病老受用三门无常。又有触染死三种变异。如色界所说诸无常义。当知无色界亦尔。唯除器门。颂曰

  无性义无常　　遍计之所执
  所余无常义　　依他起应知

论曰。无性义所摄无常义。当知遍计所执相摄。余无常义依他起相摄。圆成实相中无无常义。如是已显无常义差别及三相所摄。又如世尊说。诸无常者皆悉是苦。有何意耶。颂曰

  诸无常皆苦　　众苦所杂故
  迷法性愚夫　　得为害不觉

论曰。由粗重若所杂无常。此无常性是行苦故苦。及由变坏苦所依止故苦。是故道谛非苦。以非苦相所杂无常义故。于此法性迷惑愚夫。不能了达常无常义。又为已得现前无常之所恼害。前说刹那无常遍行一切。此无常义非世间现证故应成立颂曰

  由彼心果故　　生已自然灭
  后变异可得　　念念灭应知

论曰。彼一切行是心果故。其性才生离灭因缘自然灭坏。又复后时变异可得。当知诸行皆刹那灭。云何应知诸行是心果耶。颂曰

  心熏习增上　　定转变自在
  影像生道理　　及三种圣教

论曰。由道理及圣教证知诸行是心果性。道理者。谓善不善法熏习于心。由心习气增上力故诸行得生。又脱定障心清净者。一切诸行随心转变。由彼意解自在力故种种转变。又由定心自在力故。随其所欲定心境界影像而生。是名道理。圣教者。谓三种圣言。如经中说。心将引世间心力所防护随心生起已自在皆随转。又说。是故苾刍。应善专精如正道理观察于心。乃至广说。又说。苾刍当知。言城主者。即是一切有取识蕴。是名圣教。问彼诸行自然灭坏道理。云何应知。答由四种因缘。颂曰

  生因相违故　　无住灭两因
  自然住常过　　当知任运灭

论曰。非彼生因能灭诸行。生灭两种互相违故。又无住因令诸行住。若必有者应成常住。行既不住何用灭因。又余灭因性不可得。若行生已自然住者。彼应常则住成大过。如是有住灭因及自然住并有过故。当知诸行任运坏灭。颂曰

  非水火风灭　　以俱起灭故
  彼相应灭已　　余变异生因

论曰。若水火风是灭因者。不应道理。由俱生灭故。若彼水等是灭因者。烂烧燥物不应前相续灭已复变异相续生。何以故。即无体因为有体因。不应理故。然水火风与烂等物相应灭时。能为彼物后变生因。除此功能。水等于彼更无余力。复次若执灭相为灭因者。此能灭相与所灭法为俱时有为不俱耶。若尔何过。颂曰

  相违相续断　　二相成无相
  违世间现见　　无法及余因

论曰。彼能灭相与所灭法。若言俱有者不应道理。有相违过故。若言不俱亦不应理。有彼相续断过失故。又此灭因能灭法者。为体是灭为体非灭。若体是灭即应一法有二灭相。若体非灭应无灭相。有如是过故不应理。又违世间现见相故。不应执灭是灭坏因。何以故。世间共见余有体法是灭坏因。不见灭法是灭因故。又若灭法是灭因者。为唯有灭即能灭法为更待余事耶。此两种因俱有过失。若唯有灭即能灭法者。若时有灭。尔时法体毕竟应无。若更待余事者。应即余事为灭坏因。不应计灭为灭坏因。复次云何应知。后变异可得故诸法刹那灭。颂曰

  非身乳林等　　先无有变异
  亦非初不坏　　最后时方灭

论曰。一切世间身乳林等内外诸法。于最后时变异可得。是故先时体无变易。不应道理。又非先时无有灭坏。最后方灭无异因故。如是先不变异后不变故。先无灭坏后不灭故。当知诸行念念变灭。是故彼法刹那义成。如是成立无常性已。一切外道邪分别所计我自在自性极微觉等常住之法皆不成立。云何我常不得成立。颂曰

  位思烦恼分　　非常变异故
  此若无变异　　受作脱非理

论曰。由所计我有苦乐等位善恶等思贪嗔等烦恼时分差别。是故无常。所以者何。此所计我由乐等故。有少变异者不应是常。若都不变不应计为受者作者及解脱者。彼法有无我无别故。复次亦无自在体性常住能生世间。何以故。颂曰

  功能无有故　　摄不摄相违
  有用及无用　　为因成过失

论曰。所计自在无有功能出生世间。所以者何若此自在生世功能无有因缘自然有者。汝何不许一切世间无因自有。若此功能业为因者。何不信受一切世间以业为因。若此功能以求方便为因生者。何不信受一切世间以自功力为因得生

又若自在世间所摄堕在世间而言能生一切世间。是则道理相违。若此自在非世间摄。是则解脱解脱之法能生世间。不应道理。又若自在须有用故诸生世间离生世间用不成者。是则自在。于此须用无有自在自成过失。若此自在虽生世间无所须者。不应化生一切世间。或此自在有如颠狂愚夫之过。又此自在生世间者。为唯自在为因生诸世间。为亦更待其余因耶。若唯自在体为因者。如自在体本来常有世间亦尔。不应更生。若亦少待其余因者。此所待因若无有因。一切世间亦应如是。若有余因世间亦尔。从余因生何须自在。故立自在有多过失。复次执有自性常住为因。不应道理。何以故。颂曰

  自性变异相　　有无不应理
  无差别无常　　有差别五失
  无相亦无因　　非自性恒变
  先无有变异　　我应常解脱

论曰。若计自性是常则应非变异因。所以者何。所计自性。非有变异相。亦非无变异相。故不应理。若此自性与余变异相无差别者。应是无常。若有差别成五种过。一无相过。离变异相余自性相少分亦不可得故。二非因过。世间不见常住之法是生因体故。三非自性过。世间不见非彼种类为彼自性故。四常住自性于一切时起变异过。以不待余因故。五此自性未生变异之前我解脱过。若如是者后时不应起诸变异。复次计极微常不应道理。何以故。颂曰

  常造不应理　　由二三因故
  财有情增上　　极微非常住

论曰。所计极微常性造作俱不应理。云何常性不应道理。由二因故。汝极微性为由细故性是常住。为由异类性是常耶。若由细者。细羸劣故不应常住。若由异类者此相不可得。从非地等造地等物。不应道理云何造作不应道理。由三因故。一由方所。二由因缘。三由自体云何由方所故造作不应道理。谓从极微造作粗物。为过彼量为不过耶。若不过者。粗质碍物应如极微不可执取。又复世间不见质碍不明净物同在一处故不应理。若过彼量者。过量之处粗质碍物非极微成应是常住。若复计有余极微生。是则极微应非常住。云何由因缘故。谓若汝计由和合性为因缘故建立余物令和合者。此和合性为生已能作因缘为未生耶。若生已者。所和合物和合已后无有少异和合性可得故。不应理。若未生者。则无体性无体为因。不应道理。云何由自体故。此极微性造粗物时。不应如种生芽。如种极微应灭坏故。不应如乳极微应变异故。不应如陶师极微勤劬不可得故。是故造作不应道理。虽无常住极微而有劫初器世间等受用物生诸有情业增上力故不由极微。是故极微常住不应道理。复次执有常觉不应道理。何以故。颂曰

  无常为彼依　　次第差别转
  诸受等异故　　当知觉无常

论曰。眼识等觉依止无常眼等起故。于色等义次第转故。众多相貌差别转故。乐等诸受贪等诸惑施等善思位分异故。于一常觉如是转异。不应道理。何因缘故世间有情无常性有而不取执常住性无而种种执耶。颂曰

  于无常无智　　四颠倒根本
  当知世上进　　愚痴力转增

论曰。以于无常无智起故。实有无常而不取执。实无常性种种执生。非唯常倒无智为因然。四颠倒皆以无智为其根本。何以故。以于无常不如实知故。于无常法起常颠倒。于苦起乐颠倒。于不净起净颠倒。于无我起我颠倒。由有如是次第义故。薄伽梵说。若法无常彼必是苦。若法是苦彼必无我。当知由世间道得上进时。不断无智渐进上地。于无常性愚痴之力转更增上。何以故。如欲界中破坏变易及别离等诸无常相现可了知。上地无有。复次何因缘故。于无常性无智起耶。颂曰

  由放逸懈怠　　见昧乏资粮
  恶友非正法　　当知无智因

论曰。无常无智有七种因。一放逸。二懈怠。三倒见。四愚昧。五未多积集菩提资粮。六由恶友。七闻非正法。以于境界乐及静虑乐起。放逸故于无常性不如实知。设不放逸而复懈怠。设不懈怠而复倒见。设无倒见而复愚昧。设不愚昧而未积集菩提资粮。设已修习菩提资粮而随恶友。又复从彼闻非正法故。于无常不如实知。复有何因不了无常妄执常转。颂曰

  不如理作意　　忆念前际等
  相似相续转　　于无常计常

论曰。由二种因起于常执。一由不如理作意。二由忆念前际等事。由前际等事相似相续转故。于余世间亦计常住。复次如前所说。三有为相非唯刹那。何以故。颂曰

  生初后中间　　取三有为相

论曰。三有为相由众同分一生所摄。谓初生时取为生相。最后死时取为灭相。于二中间相续住时取为住异。如是建立三有为相应知。颂曰

  无常调伏智　　当知由二因

论曰。于无常性如实智入由二种因。一由念住。二由缘起。由念住故于诸境界系心令住。由缘起故达彼法性。如经中说。见集起法于身念住。乃至广说。颂曰

  彼见有六种　　及缘起四种

论曰。无常性见当知六种。一世俗智。谓乃至顺决择分位。二胜义智。谓乃至出世道位。三声闻智。谓除无性无常义。四菩萨智。谓于一切无常义。五不善清净。谓彼二学智。六善清净谓彼二无学智。又缘起法当知有四种道理。何等为四。颂曰

  自种故非他　　待缘故非自
  无作故非共　　用故非无因

论曰。由四道理入无常性。谓诸行法不从他生。自种起故。亦非自生。待外缘故。亦非俱生。俱无作故。亦非无因。彼二于生有功用故

显扬圣教论卷第十四显扬圣教论卷第十五

        无著菩萨造

        三藏法师玄奘奉　诏译

    成苦品第五

如是成立无常相已。云何成立苦相。颂曰

  生为欲离因　　灭生和合欲
  倒无倒厌离　　彼因为苦相

论曰。若法生时为远离欲因。若法灭时为和合欲因。若不了知是颠倒因。若善通达是无倒因。于一切时生厌离欲。如是应知是苦通相。复次颂曰

  依三受差别　　建立三苦相
  故说一切受　　体性皆是苦

论曰。由依三受相差别故建立三苦相。谓苦苦相坏苦相行苦相。由此相故佛说诸受皆名为苦。谓于苦受及顺苦受处法。当知建立最初苦相。于乐受及顺乐受处法。当知建立第二苦相。于不苦不乐受及顺此受处法。当知建立第三苦相。由不了知此第三相能为常等颠倒生因。若能了知为无常等无倒生因。及能发起涅槃乐欲。又由了知不了知第三苦故。于前二苦亦了不了应知

复次前二苦相世间共成。第三苦相不共成立。今当成立诸行性。是行苦。颂曰

  当知行性苦　　皆粗重随故
  乐舍不应理　　同无解脱过

论曰。诸行性乐及性是舍不应道理。何以故。于一切位粗重所随故。是故诸行体性是苦。若不尔如其次第于彼性乐及不苦不乐乐欲应无。应无苦及不苦不乐觉应无苦乐觉。问汝亦同然若唯一行苦性者应无乐及不苦不乐觉。答由不了故谓有。问我亦同然由不了故谓有。答不然。无解脱过故。若于性乐及不苦不乐诸行了知。是苦名苦谛现观。由此次第乃至证得究竟解脱。若不了故。谓为苦者即是颠倒。不应能证究竟寂灭。复次颂曰

  利深等障碍　　依进住乘空
  执着性下劣　　颠倒及染污

论曰。又诸行性苦少苦加之苦相猛利。乐等不尔。又苦相深重难为对治。乐等不尔。又苦相平等遍一切处。乃至证得广大法者。亦被损恼又执常乐我净。名为颠倒能障圣法。又执乐等。能为贪等大小诸惑所依止处。又苦等行能引胜进上地功德。又复久处住等威仪即生大苦不可堪忍。又执空者亦大苦随逐。又执着乐者其性下劣。又于诸行执计为乐颠倒所摄。又缘世乐所起乐欲多是染污。是故诸行皆性是苦。复次颂曰

  如痈疥癞等　　三受之所依
  彼能发三触　　取乐等随转

论曰。诸行性苦当知犹如痈疥癞等三受所依。何以故。世间痈疥癞等能发随顺苦乐舍等三种触故。由依此触世间有情取为苦乐不苦不乐。如是于诸性苦诸行发起三触。由此触故乐等受转。此若无者。诸受不转。如是显示苦相立宗及因喻已。复何因缘建立诸行。唯有三苦不多不少。颂曰

  自相自分别　　不安隐苦性
  五十五应知　　三苦之所摄

论曰。由苦自性唯有三种。一由自相故。谓苦苦性。二由自分别故。谓坏苦性。若无分别虽有变坏已解脱者苦不生故。三由不安隐故。谓行苦性。烦恼粗重等所随逐故。如是三苦差别复有五十五种应知。云何五十五种。颂曰

  界缘身等趣　　种类谛三世
  时命品异故　　引众苦差别

论曰。界差别故有三苦。谓欲界系色界系无色界系。缘差别故有六种苦。谓欲根本苦。愚痴报苦。先业缘苦。现因缘苦。净业缘苦。不净业缘苦。身差别故有四种苦。谓受重担等苦。位变坏苦。粗重苦。死生苦。趣差别故有五种苦。谓那落迦苦。乃至天趣苦。种类差别故有五种苦。谓逼恼苦。匮乏苦。大乖违苦。爱变坏苦。粗重苦。谛差别故有八种苦。谓生苦老苦病苦死苦。怨憎会苦。爱别离苦。求不得苦。五取蕴苦。世缘差别故有九种苦。谓过去苦。因过去未来现在缘所生。如是未来现在苦亦尔。时差别故有四种苦。谓时节变异苦饥苦渴苦威仪屈伸入息出息闭目开目等所引苦。养命差别故有四种苦。谓所求无厌足苦。追求苦。守护苦。不自在苦。品差别故有七种苦。一损减苦。谓在家品。二增益苦。谓出家品。三忧恼苦。四离有苦。又依善说法律。出家者有三种苦。一愚痴苦。谓希望未来追味过去故。二嫉妒苦。三不胜他苦。依恶说法律。出家者亦有三苦。一愚痴苦。谓于所知法颠倒执故。二嫉妒苦。谓于佛及佛弟子所得名利心不忍故。三他所胜苦。谓为名利故起诤论时堕负处故。颂曰

  未离欲色等　　三种地应知
  欲界一切种　　色无色除二

论曰。如是五十五种苦三地所摄。一未离欲地。谓欲界所系。二已离欲地。谓色界所系。三离欲色地。谓无色界系。即此三种如其次第立三种苦。谓上中下。又欲界中具一切种苦。色无色界中无二种苦。所谓苦苦坏苦所摄二。及欲根本苦愚痴报苦所摄二。然有余苦。颂曰

  世俗有二种　　胜义谓遍行
  二缘通上地　　当知无现染

论曰。如是诸苦略有二种。谓世俗胜义别故。世俗谛所摄苦有二种。谓苦苦及坏苦。胜义谛所摄有一种谓行苦。此亦名遍行苦。遍至欲等三界故。欲界上地有二缘所生苦。谓有先业缘苦。无现在因缘苦。有净缘苦。无不净缘苦颂曰

  非无色重担　　遍行天粗重
  及谛最后边　　余七上随缚

论曰。无色界中无身重担苦有天趣苦。粗重苦。谛最后边诸取蕴苦。此通欲等三界故名遍行苦。余生等七苦欲界所摄。上地虽有随缚复可退还故。然无苦自体。颂曰

  当知生等苦　　各五种差别
  苦粗重相应　　三苦所依止

论曰。生等七苦当知一一各有五种。谓苦相应故。粗重相应故。及三苦所依止故。生者。为老等苦所依。烦恼所依。不可乐欲行坏所依。老者色衰退等所依。病者。习所不欲所依。不习所欲所依。顺死大种乖违所依。死者。自体别离所依。财宝别离所依。所爱离别怨憎合会苦之所依。怨憎会等三苦身逼迫所依。心逼迫所依。及彼所作衰损所依。颂曰

  最后与最后　　各四苦所依
  谓生生根本　　及苦性变坏

论曰。于八苦中最后所摄诸取蕴苦。及三苦中最后行苦。各为四苦所依故苦。一生苦所依。二生根本苦所依。三苦自性苦所依。四变坏苦所依。颂曰

  三世之所摄　　二缘苦非上
  所说余诸苦　　皆欲界应知

论曰。欲界上地三世苦中。当知无有去来缘苦。何以故。非于上地缘过去未来虚妄分别生诸苦故。唯有现缘粗重所随。除上所说。所余诸苦当知唯在欲界所系

复次何因缘故。于实有苦境诸愚痴转。颂曰

  失念无功用　　乱不正思惟
  不正了愚痴　　及由放逸等

论曰。于苦愚痴由五种因。及由前所说放逸等法五种因者。一于过去苦念忘失故。二于未来苦不作功用推求故。三于现在苦起四倒乱故。四由不正思惟于粗重苦计为我故。五由不正了于诸性苦不了知故。复次由四种因起念忘失。颂曰

  昧故羸劣故　　及起放逸故
  相续断绝故　　忘念转应知

论曰。昧故者。谓愚昧种类。羸劣者。谓于死等位。放逸者。谓于境耽着。相续断绝者。谓于余生前众同分相续断故。复次由四种因无功用转。颂曰

  昧故放逸故　　保重现法故
  不信当苦故　　无功用发趣

论曰。昧及放逸已如前说。保重现法者。由彼保重现在法故。于未来苦不作功用。不信当苦者。由不信有未来苦故。不作功用。复次由四种因起四颠倒。颂曰

  相似相续转　　对治妄分别
  串习总取故　　起四种颠倒

论曰。以见相似相续转故起于常倒。对治分别故起于乐倒。妄分别乐为苦对治故由串习故起于净倒。由总执故起于我倒。复次于苦愚痴由不了别五因故起。何等为五。颂曰

  界别缘起别　　位别次第别
  及相续差别　　当知各多种

论曰。界差别有三种苦。谓欲界色界无色界。缘差别有七种苦。一福缘。二非福缘。此二在欲界。三不动缘。在色无色界。四缠随眠缘。谓异生者。五随眠缘。谓见谛者。六有行缘。谓非菩萨。七智行缘。谓诸菩萨。位差别有十二种苦。一纯乐俱。谓诸天。二纯苦俱。谓那洛迦。及鬼傍生一分。三杂苦乐俱。谓人及鬼傍生一分。四不苦不乐俱。谓从第四静虑乃至有顶。五不净净处。谓欲界中无难生处。六净不净处。谓色无色界中诸异生者。七净净处。谓色无色界中诸见谛者。八不净不净处。谓欲界中有难生处及四种入胎苦。一不正知入母胎不正知住不正知出。二正知入母胎不正知住不正知出。三正知入母胎正知而住不正知出。四正知入母胎正知而住正知而出。次第差别有十二种苦。谓依十二支缘起次第相续。差别有无量种有情相续无边差别故。复次于一切苦能遍了知。当知有十八种。何等是耶。颂曰

  信解与思择　　不乱心厌离
  见修及究竟　　又如前十一

论曰。一信解遍智。谓闻所生智。二思择遍智。谓思所生智。三不散乱遍智。谓世间修所生智。四厌心摄遍智。谓暖等顺决择分智。由此智观自心相总厌离转故。五见道遍智。谓依止见道智。六修道遍智。谓依止修道智。七究竟道遍智。谓无学道所摄智。及如前所说十一种智。一不善清净世俗智。二善清净世俗智。三胜义智。四不善清净相有分别智。五善清净相有分别智。六善清净相无分别智。七成所作前行智。八成所作智。九成所作后智。十声闻智。十一菩萨智。如是总为十八种如实了知苦遍智。复次如是遍智为尽众苦。由何遍智尽何等苦。颂曰

  缠疑不乐离　　沉恶趣余趣
  下劣行所起　　遍独众苦尽

论曰。信解遍智能灭缠苦。思择遍智能灭疑苦。不散乱遍智能灭不乐远离苦。厌心摄遍智能灭惛沈苦。见道遍智能灭恶趣苦。修道遍智能灭余趣苦。究竟道遍智能灭下劣行所起苦。谓除乐速通行。所余诸行皆名下劣应知。菩萨遍智遍灭一切自他诸苦。声闻遍智独灭自苦应知

    显扬圣教论成空品第六

如是已成立苦相。云何成立空相。当知空相有三种。一自相。二甚深相。三差别相

云何自相。颂曰

  若于此无有　　及此余所有
  随二种道理　　说空相无二

论曰。空自相者。非定有无非定有者。谓于诸行中众生自性及法自性毕竟无所有故。非定无者。谓于此中众生无我及法无我有实性故。随二种道理者。谓即于此中无二种我道理。及有二种无我道理。随此二种故说空性无有二相。一非有相。二我无故。二非无相。二无我有故。何以故。此二我无即是二无我有。此二无我有即是二我无故。是故空性非定有相非定无相。云何甚深相。颂曰

  甚深相应知　　取舍无增减

论曰。随前所说无二道理。虽舍诸法而无所减。虽取诸法而无所增。无取无舍无增无减。是甚深空相。云何差别相。颂曰

  差别有众多　　如彼彼宣说

论曰。即此空性薄伽梵于处处经中显示多种差别。谓胜义空内空外空如是等今且分别。胜义空以胜义故空无所有故名胜义空。此显四种义。何者为四。一离我因义。二离我相义。三离无因义。四离非自业得义。由六处生时不从我来亦不聚集依止于我。如是名为离我因义。若执六处以我为因应无分别五趣别异。又由六处本无今有。有已散灭故离我相。以如是相非我有故。又由有业为因异熟生起都无作者亦无有情舍续诸蕴。如是名为离无因义。又由于有分法假立有情相续一类流至现在异熟法上非异相续。是故名为离非自业得义。复次云何应知补特伽罗我无所有。若有我者为即蕴相为住蕴中为住余处为非蕴相。颂曰

  唯假过失故　　蕴无我过故
  我无身过故　　三我不应理

论曰。若所计我即是蕴相应唯是假违。汝自宗故成过失。以即于诸蕴假立我故。若离诸蕴住余处者。我应无蕴。是亦有过。于诸蕴中无有我故。若非蕴相者。所计之我有无身过。无身之我不应理故。是故三种不应道理。复次若计实我住诸蕴中。是亦不然。何以故。颂曰

  如主火明空　　形异依他过
  无常无业用　　非因非有我

论曰。所计实我住诸蕴中。为如主住舍为如火在薪。为如明依灯。为如虚空处种种物。如是一切皆不应理。何以故。有五种过失故。何者为五。若如主住舍中者。形段应异舍主与舍形貌异故。若如火在薪者。有依他过。火依薪力不自在故。若如明依灯者。有无常过。随灯有无明起灭故。又前二种亦有无常过失。不见舍主有常住者。舍虽久住而彼舍主或往余处或死灭故。火随薪力有无不定无常性故。若如虚空者。应有业用显然过失。虚空业用显然可得。谓去来等业无障碍故。我即不尔。故成过失。又所计我与果为因亦不可得。何以故。无我外物诸种子等与果为因亦可得故。是故计我住诸蕴中与果为因。不应道理。亦无所计实我体性。问若唯有蕴无别我者谁见谁闻。乃至谁能了别。答若见闻等即是我体。或是我业。或是我具。执我以为见闻者等。皆不应理。何以故。颂曰

  我唯应是假　　譬喻不可得
  七喻妄分别　　无见者等三

论曰。若汝执我即是见等。又名见者。乃至了别者。所计之我唯应是假。即于见等法上假立我故。若执见等是业是具。此亦不然。无譬喻故。虽妄分别七种譬喻。然有多过。是故三种皆不应理。云何多过。颂曰

  若如种无常　　作者应成假
  如成就神通　　应世俗自在

论曰。若汝计我于见闻等业如种于芽者。我应无常。种非常故。若汝计我于见闻业等如陶师于器者。我应是假。何以故。世间现见假名士夫有造器用。不见余故。若汝计我于见等业犹如世间有神通者。能起变化。即应同彼世俗假立及自在过。何以故。离假者外余成神通者所不见故。又复现见成神通者。于变化事随意自在。我于见等不假异缘。应得自在。复次颂曰

  我如地如空　　应无常无性
  应如二无作　　分明业可得

论曰。若汝计我于见等业犹如大地能持万物者。我应无常。地非常故。若如虚空无障碍故容所作业。我亦如是容见等业者。我应无体。犹如虚空唯色无体是虚空故。又如大地虚空于任持等无动作用。我亦如是于彼见等应无作用。既无作用执见者等。不应道理。又大地虚空任持无障二种功能分明可得。我于见等诸所作业无别可得。故不应理。复次若执见等是我具者。是亦不然。何以故。颂曰

  能烧及能断　　唯火等所作
  我于见等具　　非如刀火等

论曰。若汝计我执见等具能见能闻乃至了别。如人执火能烧。执刀能断者。不应道理。何以故。世间现见离能执人。火自能烧刀自能割。见等亦尔。虽无有我亦应自有见等作用。而汝不许故此非喻。又复世间诸蕴共合假想立为我人众生执持镰等能刈能断无别实我故此非喻。复次颂曰

  如光能照用　　离光无异体
  是故于内外　　空无我义成

论曰。现见世间即于光体有能照用。说为照者。离光体外无别照者。如是眼等有见等用。说为见者。乃至了别者无别见者等。是故内外诸法等无有我。问若实无我云何世间有染有净。答染净诸法从因缘生不由实我。何以故。颂曰

  如世间外物　　离我有损益
  内虽无实我　　染净义应成

论曰。如世外物虽无有我而有种种灾横顺益事业成就。如是内法虽无有我而有种种染净义成。是故无过。复次若无我者。谁受果报谁能作业谁脱众苦。颂曰

  位思烦恼分　　无常变异故
  我常无转易　　受作脱应无

论曰。汝所计我于苦乐等位善恶等思。贪等烦恼一切时分常无变异。无变异故受者作者及解脱者。皆不应理。如前已说。虽无实我而有世俗假者三时变异。受者作者及解脱者。时分差别皆得成就。复次若无我者谁转谁还。颂曰

  法性从缘生　　展转现相续
  有因而不住　　变异故名转
  如身牙河灯　　有种种作用
  我常无变异　　转还不应理

论曰。不由有我而有转还。何以故。现见转者必有生相。前后相续展转不断。恒现在前显了可见。有因不住而复变异。说名流转。相续断绝。说名还灭。犹如身牙河灯有往来等种种作用及有还灭。非汝所计常无变我有流转用。流转尚无。何况还灭。复次若唯诸行无有我者。世间现见彼彼有情。若名若想差别应无。颂曰

  依我起名想　　见二种过失
  是故遍一切　　实我性都无

论曰。不由名想实我得成。何以故。见二种过失故。若世间人于实我上起佛救等种种名想者。于身等法彼解应无。若于身等起名想者。不应说我有诸作用。所以者何。世间现见起诸言说。谓佛友能见德友能闻等。又见二种过失者。若执我见体性是善。任运现前能生染法。不应道理。若是染污能证实我。不应道理。又计我者。执取我时为我能执。为见能执。若言我执我者。不应世间执我之人有起疑惑。谓为有为无为是何等。何以故。现见我故。若言见执我者。汝今不应说我能取。由如是等种种过失。是故世间无真实我。复次若尔何故于正法中建立名想种种差别。颂曰

  为言说易故　　随顺世间故
  断除怖畏故　　显德失二故

论曰。虽无实我而立有情名想别者有四种因。一为令言说易故。二顺世间故。三令初学者离怖畏故。四为显自他功德过失有差别故。复次若无我者。世间不应才见形相率尔便起有情之觉。又亦不应思觉为先起诸作业。颂曰

  率尔觉乱起　　世间现可得
  觉为先作业　　有十种过失

论曰。率尔生觉非证我因。何以故。错乱觉心率尔而起现可得故。如于女身起男子觉。于男子身起女人觉。杌起人觉。人起杌觉。又汝计我思觉为先起诸作业有十种过。何等为十。颂曰

  觉我因功用　　自在等各二
  有因及无因　　当知十种过

论曰。若汝执觉为因起诸作业。是即非我能起诸业。若我为因思觉非因。是则应无思觉为先起诸作业。又若汝执以我为因能起作业。即应常起一切作业。若我非因是即我无所作。又若汝执有余因法能为因故起诸作业。即所计我无所造作。若更无因即应常起一切作业。又若汝执由内功用能有所作。此亦如前有二种过失。又若汝执我于作业得自在者。即应常作一切所爱不作不爱。若不自在即非我相。如是已说空相及成立。今当显示观空真智所治萨迦耶见差别。颂曰

  不审决遍行　　增益及无事
  于事怖妄见　　譬喻五应知

论曰。萨迦耶见当知五种。一不审事见。如于绳见蛇。二遍行见。谓染污意相应妄有身见。于一切时常随行故。如于梦中见所受用。所以者何。犹如贫者。于睡梦中自见受用可爱境界。如是愚夫未起真如正觉已来。常起妄计我见随逐。三增益事见。犹如希望随属他女。四无实事见。犹如小儿见幻化事。五于事怖见。如人怖畏自画药叉。如是已说所治差别。今当显示能治差别。颂曰

  无体及远离　　除遣依三种
  对治诸缚想　　十六种差别

论曰。依止遍计所执等三种自体。如其次第立三种空。一无体空。二远离空。三除遣空。又此三空对治诸缚诸想差别有十六种。诸缚者有十四种相缚粗重缚应知。一根缚。二有情互染缚。三所依缚。谓依器世间诸根流转。四于智无智缚。五于境妄境缚。六后有爱缚。七无有爱缚。八执无因不平等因缚。九得上慢缚。十遍计所执自体执缚。十一诸法自体执缚。十二诸法遍智自体执缚。十三补特伽罗自体执缚。十四补特伽罗遍智执缚。诸想者。谓六种想缚。厌此想故菩萨依空勤修念住令心解脱。云何名为六种想缚。谓依身受心法发起内想名初想缚。即依身等发起外想是名第二。即依身等起内外想是名第三。为欲度脱十方无量无数有情界故。发起大愿修诸念住。此分别想是名第四。于身等境谓有智慧正观察住。此分别想是名第五。于身等境谓有我人正观住者。此分别想是名第六。又观身等后后相成有十一种想缚差别应知。何等十一。谓于身等起随身等正观察住。及于染净二谛第一义中起分别想名初想缚。即于染污第一义中起有作想。是名第二。即于清净第一义中起无作想。是名第三。即于有作第一义中起流转想。是名第四。即于无作第一义中起于常想。是名第五。即于流转由苦变异故起于苦想。是名第六。即于常法起无变想。是名第七。即于流转由生灭住异自相故。及由自相有变异故。起自相想。是名第八。即于有变无变染污清净第一义中起能摄受一切法想。是名第九。即于染净一切法所起染污清净我所有想。是名第十。即于染污清净诸法起于自体自相之想。是名第十一。菩萨摩诃萨于如是后后相成想缚差别及彼境界。正观察已依止于空修诸念住令心解脱。若于如是诸妄想缚得解脱时。当知解脱一切想缚

十六空者。所谓内空外空内外空大空空空胜义空有为空无为空毕竟空无初后空无损尽空性空相空一切法空无性空无性自性空。复次于此空境有六种愚无始流转。何等为六。颂曰

  自性与执着　　不开解失念
  一切遍一分　　愚差别流转

论曰。自性愚者。谓一切有情无始流转无智。自体执着愚者。谓诸外道倒见相应所起无智。不开解愚者。谓无闻异生所起无智。失念愚者。谓有闻异生及诸圣者所起无智。一切遍愚者。谓诸异生于众生空及与法空所起无智。一分愚者。谓声闻等唯于法空所起无智。云何证得如是空理。谓由八种智。何等为八。颂曰

  法住求自心　　住自心除缚
  怖无二染净　　证得真空理

论曰。一法住智。谓依素怛缆等安立法门智。二求自心智。谓于顺决择分位寻自心智。三住自心智。谓于见道位证真如智。四除心缚智。谓于修道位对治障智。五怖行相应智。谓圣弟子智。怖畏流转大苦恼故。六无二分别智。谓菩萨智。流转寂灭过恶功德不分别故。七不善清净智。谓有学智八善清净智。谓无学智

显扬圣教论卷第十五显扬圣教论卷第十六

        无著菩萨造

        三藏法师玄奘奉　诏译

    成空品第六之余

论曰。如是空理。依修故证。云何为修。颂曰

  修差别十八　　或有毒无毒
  对治五种执　　略二种应知

论曰。修相差别有十八种

一声闻相应作意修。谓如有一是声闻住声闻法性。或未入正性无生。或已入正性无生。唯观自利不观利他。依安立谛作意门入真如理。自内缘有分量法。起厌离无欲解脱行。为尽自爱作意修习。是名声闻相应作意修

二菩萨作意修。谓如有一是菩萨住菩萨法性。或未入正性无生。或已入正性无生。观自他俱利依安立非安立谛作意门入真如理。自内缘无分量法大悲增上故起利益他摄受方便行。履无上迹。因为尽自他爱作意修习。是名菩萨作意修

三影像作意修。谓或思惟有分别毗钵舍那品三摩地所行本境界法同分影像。或复思惟无分别奢摩他品三摩地所行本境界法同分影像。如是修习名为影像作意修

四事究竟作意修。谓思惟诸法若过去若未来若现在。若内若外。若粗若细。若远若近。或复思惟诸法真如尽诸所有。如诸所有如是修习。是名事究竟作意修

五事成就修。谓已证得根本静虑及世出世三摩钵底。如是修习是名事成就修

六得修。谓如有一依初静虑。或修习无常想。或乃至修习死想时。此人所有不现在前所余善想。若自地摄若下地摄。及彼所引世及出世所有功德。皆悉修习令其转增。猛利清净当得生起。证得彼法自在成就。是名得修

七习修。谓如有一现前思惟彼彼诸法起无常等所有善想。及现修习诸余善法。如是修习是名习修

八除遣修。谓如有一思惟三摩地所行影像相故除遣诸法根本性相。令不复现依以榍出榍道理。犹如有人以其细榍除遣粗榍。或以身安遣身粗重。如前已说。是名除遣修

九对治修。谓思惟修习。厌坏对治。断对治。持对治。远分对治。是名对治修。此中闻思所生道是厌坏对治。出世间道是断对治。彼果转依是持对治。世间修慧道是远分对治

十身修。十一戒修。十二心修。十三慧修。如其次第依根防护修习三学。当知是名身等修性

十四少分修。谓思惟诸法起无常等一一善想及修所余少分善法。是名少分修

十五遍行修。谓思惟一切法一味真如。如是修习名遍行修

十六有动修。谓勤方便修无相时。于中间起诸有相修。是名有动修

十七功行修。谓勤方便修无相时。由功用行无有间缺起无相修。是名功行修

十八成满修。谓或依声闻乘。或依独觉乘。或依大乘。一切依已转得一切法自在。如是修习是名成满修

如是诸修略有二种。谓有毒修。无毒修。我我所执。杂不杂故

又此诸修当知对治五种邪执。一众生邪执。二法邪执。三损减邪执。四差别邪执。五变异邪执。众生邪执者。谓于诸蕴执有有情作者受者。法邪执者。谓如所言说执有色等自体差别。损减邪执者。谓执诸法一切相。无差别邪执者。谓执诸法我无我等有别体性。变异邪执者。谓执诸法先实有我后成无我。又此诸修略有二种。谓世间修。出世间修。复次颂曰

  修果应当知　　三菩提功德
  依止转依性　　所作事成就

论曰。因修空故证得妙果。谓依止转依证三菩提。及得无诤愿智无碍解等无量功德。及所作事圆满成就。谓即转依究竟成满

    显扬圣教论成无性品第七

论曰。成空品中已成立众生无我非法无我。今为成立法无我故说成无性。颂曰

  三自性应知　　初遍计所执
  次依他起性　　最后圆成实

论曰。当知无性不离自性。是故先说三自性义。如是即显三种无性密意故。说三自性者。谓遍计所执自性。依他起自性。圆成实自性。遍计所执者。所谓诸法依因言说所计自体。依他起者。所谓诸法依诸因缘所生自体。圆成实者。所谓诸法真如自体。颂曰

  三无性应知　　不离三自性
  由相无生无　　及胜义无性

论曰。如是三种自性。当知由三无自性故说三无性。一相无性。谓遍计所执自性。由此自性体相无故。二生无性。谓依他起自性。由此自性缘力所生非自然生故。三胜义无性。谓圆成实自性。由此自性体是胜义。又是诸法无性。故已说三种自性及三无性相。今当显示成立道理。云何应知。遍计所执皆无自体相。颂曰

  非五事所摄　　此外更无有
  由名于义转　　二更互为客

论曰。遍计所执自相是无。何以故。五事所不摄故。除五事外更无所有。何等为五。一相二名三分别四真如五正智。问若遍计所执相无有自体。云何能起遍计执耶。答由名于义转故。谓随彼假名于义流转。世间愚夫执有名义决定相称真实自性。问云何应知此是邪执。答以二更互为客故。所以者何。以名于义非称体故。说之为客。义亦如名无所有故。说之为客。云何知然。颂曰

  于名前无觉　　多名及不定
  于有义无义　　转非理义成

论曰。若义自体如名有者未得名前。此觉于义应先已有。又名多故。一义应有多种自体又名不定故。义之自体亦应不定。何以故。即此一名于所余义亦施设故。又复此名为于有义转为于无义转耶。若于有义转者。不应道理。即前所说三因缘故。若于无义转者。即前所说二互为客。道理成就。复次若执义是实有。由名显了如灯照色。不应道理。何以故。颂曰

  取已立名故　　余即不能取
  如众生邪执　　增益为颠倒

论曰。先取义已。然后立名。非未取义能立名字。已取得义复须显了。不应道理。又即由此名。余未解者不取得义。灯照了物即不如是。非由此灯余不能取所照了物。又不应执义异名异。由唯依名起义执故。譬如唯有诸行无始流转自性异生。数习力故于自他相续起众生邪执。如是于长夜中串习言说熏修心故。由此方便起妄遍计执有诸法。此法邪执犹如众生妄增益故。当知颠倒。如是颠倒云何与杂染法展转生起。颂曰

  由熏起依他　　依此生颠倒
  如是互为缘　　展转生相续

论曰。由此颠倒熏习力故。后依他果自性得生。又依此果后时复生。法执颠倒。如是二法更互为缘。生死展转相续不断。已说成立道理。今当显示遍计所执自性差别。颂曰

  自性与差别　　有觉悟随眠
  加行名遍计　　又当知五种

论曰。由有六种遍计差别故。遍计所执自性亦有六种。何等名为六种遍计。一自性遍计。谓遍计色等实有自相。二差别遍计。谓遍计色等决定实有有色无色有见无见等诸差别相。三觉悟遍计。谓善名言者所有遍计。四随眠遍计。谓不善名言者所有遍计。五加行遍计。此复五种。一贪爱加行。二嗔恚加行。三合会加行。四别离加行。五随舍加行。六名遍计。此复二种。一文字所起。二非文字所起。非文字所起者。如有计执。此为何物。云何此物。此物是何。此物云何。文字所起者。如有计执。此为此物。此物如是。或色或乃至识。或有为或无为。或常或无常。或善或不善或无记如是等

复次遍计所执自性。当知复由五种遍计。何等为五。一依名遍计。义自性。二依义遍计。名自性。三依名遍计。名自性。四依义遍计。义自性。五依二遍计。二自性。依名遍计。义自性者。如有计执。此物既名为色。必应定有色体真实。此物既名为受想行识必应定有受想行识体性真实。依义遍计。名自性者。如有计执。此物名色。为不名色。此物名受想行识。为不名受想行识。依名遍计。名自性者。如有计执。不了物体但知种种分别色名。不了物体但知种种分别受想行识。名依义遍计。义自性者。如有计执。不了色名但于色体种种分别。不了受想行识名但于受想行识体性种种分别。依二遍计。二自性者。如有计执。此物是色体性。名之为色。此物是受想行识体性。名受想行识。已说遍计所执自性差别。此遍计执由妄分别故生。此分别差别今当更说。颂曰

  分别有八种　　能生于三事
  分别体应知　　二界心心法

论曰。八种分别能生三事。何等为三。一分别戏论所依缘事。二见我慢事。三贪爱等事

八种分别者。一自性分别。谓于色等想事分别色等所有自性。二差别分别。谓即于色等想事起诸分别。此有色此无色。此有见此无见。此有对此无对。如是等无量差别。以自性分别为依处故。分别种种差别之义。三总执分别。谓即于色等想事所立我及有情命者生者等。假想施设所引分别。由于积聚多法总执为因分别转故。又于舍军林等及于饮食衣乘等想事。所立舍等假想施设所引寻思。四我分别。谓若事有漏有取。长时数习我执所聚。由数习邪执自见处事为缘所起虚妄分别。五我所分别。谓若事有漏有取。长时数习我所执所聚。由数习邪执自见处事为缘所起虚妄分别。六爱分别。谓缘净妙可意事境分别。七不爱分别。谓缘不净妙不可意事境分别。八爱不爱俱相违分别。谓缘净不净可意不可意俱离事境分别

如是略说有二种。谓分别自体。及分别所依所缘事。此中自性分别。差别分别。总执分别。此三分别能生分别戏论所依事。分别戏论所缘事。谓色等想事为依缘故。名想言说所摄名想言说所显分别戏论。即于此事分别计度无量种种众多差别。此中我分别。我所分别。此二分别能生余见根本及慢根本身见及能生余慢根本我慢。此中爱分别。不爱分别。俱相违分别。如其所应生贪嗔痴。是故如是八种分别为起此三种事。若欲略说分别体性。所谓三界诸心心法。复次颂曰

  由二缚所缚　　坚执二自性
  故二缚解脱　　正无得无见

论曰。起前所说诸分别时。即为二缚所缚。所谓相缚及粗重缚。由此二缚执二自性。谓执依他起自性及遍计所执自性。是故解脱二种缚已。于二自性正无所得及无所见。所以者何。由遍计所执自性毕竟无故。不可得依他起自性。虽复是有不取相故无所见。如是成立遍计所执自性已。为欲成立依他起自性故。当说成立道理。颂曰

  假有所依因　　若异坏二种
  杂染可得故　　当知依他有

论曰。不应宣说诸法唯是假有。何以故假法必有所依因故。非无实物假法成立。若异此者。无实物故假亦是无。即应破坏二法。二法坏故。杂染之法应不可得。由杂染法现可得故。当知必有依他起自性。复次此依他起自性有何相貌。颂曰

  相粗重为体　　此更互缘生
  非自然是有　　故说生无性

论曰。此依他起自性以相及粗重为体。云何说为依他起。由此二种更互为缘而得生故。谓相为缘起于粗重。粗重为缘又能生相。若尔何故名生无性。谓缘力所生非自然有故。复次此依他起自性。为决定有为决定无。颂曰

  非决定有无　　一切种皆许
  通假实二性　　世俗说为有

论曰。依他起自性非如施设决定是有。亦非一切决定是无。故一切种非有非无。然许一切种皆可言说。谓若有若无。亦有亦无。非有非无。问此依他起自性。为是实有为是假有。答应知此性通假实有。问为由世俗故有。为由胜义故有。答当知由世俗故说之为有。复次颂曰

  宣说我法用　　皆名为世俗
  当知胜义谛　　谓七种真如

论曰。世俗谛者。当知宣说我法作用已。如摄净义品中说。胜义谛者。谓七种真如。已如摄事品中说。复次颂曰

  圆成实自性　　二最胜智义
  无有诸戏论　　远离一异性

论曰。此胜义谛。当知即是圆成实自性。问何因缘故七种真如名胜义谛。答由是二最胜智所行故。谓出世间智及此后得世间智。由此胜义无戏论故。非余智境。又此胜义无戏论故。于有相法离一异性。何以故。由此真如于有相法不可说异亦非不异故。复次颂曰

  清净之所缘　　常无有变异
  善性及乐性　　一切皆成就

论曰。由胜义谛离一异性故。当知即是清净所缘性。何以故。由缘此境得心清净故。当知亦是常。于一切时性无变异故。又由清净所缘故。当知是善。以是常故当知是乐。复次颂曰

  实胜义无性　　戏论我无故
  依他无彼相　　此胜义无性

论曰。圆成实自性。由胜义无性故说为无性。何以故。由此自性即是胜义亦是无性。由无戏论我法性故。是故圆成实自性。是胜义故。及无戏论性故。说为胜义无性。应知于依他起自性。由异相故。亦得建立为胜义无性。何以故。由无胜义性故。复次如前所说有五种相。谓能诠相。所诠相。此二相属相。执着相。不执着相。又有三相。谓遍计所执相。依他起相。圆成实相。为五摄三。为三摄五耶。颂曰

  依三相应知　　建立五种相
  彼如其所应　　别别有五业

论曰。当知依三自相建立五相。所以者何。初及第二依三自相。第三依遍计所执相。第四依依他起相。第五依圆成实相。又三自性一一各有五业。已如摄净义品中说。复次前成空品所遮众生执。今此品中所遮法执。此二种执谁从谁生。颂曰

  法执故愚夫　　起彼众生执
  彼除觉法性　　觉法我执断

论曰。由法执故世间愚夫起众生执。除众生执现起缠故觉法实性。觉法性故法执永断。法执断时当知亦断众生执随眠。复次于何未断而成杂染。于何断灭得成清净。颂曰

  于依他执初　　熏习成杂染
  无执圆成实　　熏习成清净
  杂染有漏性　　清净则无漏
  此当知转依　　不思议二种

论曰。于依他起自性执着初自性故。起于熏习则成杂染。当知圆成实自性无执着故。起于熏习则成清净。杂染即是有漏性。清净即是无漏性。此无漏性当知即是转依相。又此转依不可思议及有二种。云何不可思议。颂曰

  真实及自体　　寂静与功德
  一切不思议　　当知由四道

论曰。如是转依不可思议由四道理。一由真实。谓是常故。二由自体。谓非有色非无色如是等故。三由寂静谓寂静住故。四由功德谓此转依有威德故。又此转依不可思议由四种道方乃证得。谓四种正行。四种寻思。四如实智。四种境事。何等为四。一遍满境。二净行境。三善巧境。四净惑境。此中遍满境复有四种。一有分别影像。二无分别影像。三事究竟四所作成就。有分别影像者。谓所知事同分三摩地所行毗钵舍那境。无分别影像者。谓所知事同分三摩地所行奢摩他竟。事究竟者。谓尽所有性及如所有性。所作成就者。谓转依及依此无分别智。净行境有五种。一不净。二慈悲。三缘起。四界差别。五入出息念。善巧境有五种。谓蕴善巧。界善巧。处善巧缘起善巧。处非处善巧。净惑境。谓世间道有二。下地粗性。上地静性等。出世间道有四圣谛等。复次如前所说有二种转依。何等为二。谓声闻菩萨转依差别。颂曰

  声闻有二种　　趣寂趣菩提
  依止变化身　　趣无上正觉
  诸声闻转依　　厌皆修所得
  菩萨方便修　　无二智依止
  不住生灭故　　诸佛智无上
  利乐诸有情　　不思议无二

论曰。声闻转依当知复有二种。一趣寂灭。二趣菩提。问声闻无学永尽后有。云何能证阿耨多罗三藐三菩提。答依变化身住能证菩提非业报身又声闻转依以于流转背修故得。菩萨转依以方便修及无二智为依止故得。云何以方便修。谓由无间达法性故。所缘大故。发起最胜勤精进故。顾有情故。了诸行故。云何无二智为依止。谓不住流转及以寂灭。不顾流转故。顾诸有情故。由此因缘当知佛智最胜无上。所以者何。余有情智。或住流转。或住寂灭。故非无上。又诸佛智利益安乐一切有情。善能成满自他利故。最胜无上。余有情智。或唯自利或不俱利。故非无上。以是因故诸佛智慧不可思议。不住二边能作一切众生利益事故。又无有二。谓般涅槃不涅槃等。性无二故

    显扬圣教论成现观品第八之一

论曰。如是正勤了知无常苦空无我已。欲何所观。颂曰

  当知现所观　　下中上品事
  有漏及无漏　　未见未受遍

论曰。为现观察欲色无色三界所系下中上品所知事故。有漏者。谓即此苦集谛摄。无漏者。谓此增上灭道谛摄。未见者。谓四谛所摄。未受者。谓灭道所摄。遍者。谓现见不现见法智种类智所行境界。复次以何现观。颂曰

  出世间胜智　　能除见所断
  无分别证得　　唯依止静虑

论曰。出世间智能为现观非世间智为断见所。断惑唯是见道非修道故。问彼复何行。答无分别证得。谓现前证得无分别行非未现证。问彼何所依。答唯依止静虑不依无色。复次何处现观。颂曰

  极戚非恶趣　　极欣非上二
  处欲界人天　　佛出世现观

论曰。于恶趣中不起现观。苦受恒随极忧戚故。不能证得三摩地故。色无色界亦无现观。欣掉重故。厌羸劣故。是故二界三趣不起现观。唯一欲界人天二趣。有佛出世能起现观。复次谁能现观。颂曰

  未离欲倍离　　及已离欲者
  独一证正觉　　最胜我所生

论曰。有五种补特伽罗能入现观。或无入者以无我故。何等为五。一未离欲者。二倍离欲者。三已离欲者。四独觉。五菩萨。云何应知唯心能入现观非我能入。颂曰

  非我为智因　　亦非自取境
  我非自现观　　执爱自我故
  无常有境界　　待缘智生起
  断粗重等三　　故依心现观

论曰。若计有我能入现观。不应道理。何以故。我为智因。不应理故。若离于智自然不能取故。所以者何。若我能为智因。即是无常。或应智是常有。若我自能取境界者。智未生前亦应能取。又若计我能入现观。此我亦应自观我性。若如是者。应无解脱。以缘执我及起爱故。所以者何。无有取我不起我执及我爱者。若说依心。能入现观。斯有道理。何以故。心是无常。有境待缘能生智故。又依止心若粗重若我执及与我爱。皆可断灭。所以者何。心无常故。为智生因。有所缘故与智俱时同取境界。待众缘故智不常有。又心是粗重之所依故。性离我故。若证遍智即能远离粗重而生。永除我执及与我爱。云何次第能入现观。颂曰

  已成熟相续　　或听闻正法
  自然极如理　　作意故现观
  系念于所缘　　精勤修静定
  增上善根力　　证圣觉道分

论曰。修现观者。先当成熟自相续已。或复听闻正法。谓声闻乘。或复自然。谓菩萨及独觉。于自内心极善作意故能入现观。次系念于所缘者。谓四念住。精勤者。谓四正断修静定者。谓四神足。增上善根者。谓先证得增上资粮信等。善根力者。谓彼所治不信等障所不能杂。证圣觉分者。谓依彼故证遍觉支。证圣道分者。谓证八圣道支。如是次第得入现观。复次齐何当言正入现观。颂曰

  从是入见道　　无漏正见起
  永断于三结　　证现观应知

论曰。从前所修如理作意故。于见道位出世间正见得生。由正见故三结永断。谓萨迦耶见戒禁取及疑齐如是位当知已入现观。然此位中一切恶趣杂染之法皆悉遣除。云何但言三结永断颂曰

  虽恶趣杂染　　计所起惑断
  境见导师等　　随生三所摄

论曰。由萨迦耶见于境迷失。由戒禁取于见迷失。由彼疑故于佛导师所说正法及正行僧而生迷惑。是故随强唯说永断三结。复次现观有何相貌。颂曰

  由先世间智　　简择谛究竟
  于谛无加行　　决定生起相
  智境和合相　　于所知究竟
  当知谛现观　　于十种决定

论曰。由先世间智者。谓从闻所生智乃至世间第一法智。简择谛究竟者。谓已于诸谛究竟简择于谛无加行。决定生起相者。谓于所观察诸谛境中不由加行功用决定生起相是现观相。又此决定智与境和合相究竟到所知故。所以者何。除是以外更无异境可须求故。是故此观名为现观。当知此决定相复有十种。何等为十。颂曰

  我性无三有　　不灭无有二
  无分别无怖　　自断中决定

论曰。十种决定者。一于众生无中决定。二于遍计所执自性无中决定。三于无我有。四于相有。五于粗重有。是中并决定。六于不灭中决定。谓或无故不灭。谓众生我及法我或有故不灭。谓二无我。七于无二中决定。谓法及法空无有差别。八于空无分别决定。九于法性无怖决定。谓诸愚夫于此性处生诸怖畏。智者于此无有怖畏是故决定。十于自在能断决定。谓我不复从于他人求断方便。是故决定。复次如是现观。云何次第修习。应知颂曰

  发起证等流　　成满次第四
  又法住智等　　次第八应知

论曰。现观次第或四或八或复七种。何等为四。一发起。谓从闻所生智乃至世第一法。二证得。谓见道。三等流。谓修道。四成满。谓究竟道。云何为八。谓法住智乃至善清净智。如前所说。云何七种。颂曰

  无悔住所缘　　如实见境界
  道所依无惑　　纯差别行断

论曰。七种次第者。谓尸罗净乃至行断智见净。由尸罗清净故无有变悔。由无悔故心定住境。由心定故于所知境得如实见。次于如实智见道所依止佛法僧宝。远离疑惑得四证净俱生智。次于善逝所证所说得决定智。谓唯佛法中有纯净。出离苦道非于余法。次于此道得行差别智。谓苦迟通行是下品乐。速通行是上品。余二行是中品。次依上品正行于余断灭生胜智见。复次此尸罗等七清净。若略说三学所摄当知亦是三净所摄。云何三净。颂曰

  三净摄应知　　戒净及心净
  境界依止道　　说为慧清净

论曰。三种净者。所谓戒净心净慧净。慧清净中复有三种。一于境界。二于道所依止。三于道体。于道体中当知复有三种。谓纯故。差别故。断故。复次于如是次第中。以何次第入于现观。颂曰

  知身等因缘　　善达于三世
  次了知四苦　　复八苦应知

论曰。先于四念住位应善了知身受心法四种因缘。谓由食集故身集。触集故受集。名色集故识集。作意集故法集。次此身等于三世中应善了知。谓于未来世集法随观。于过去世灭法随观。于现在世集灭法随观。次应了知即此身等四苦所苦。谓受重担苦。位变异苦。粗重苦。及死生苦。以善不善法为因能感流转死及生苦。是故了知死生二苦。即是了知法苦。从此无间将观诸谛。故先了知八种苦法。所谓生苦乃至略说五取蕴苦。复次颂曰

  从是正观谛　　起十六行智
  为治四颠倒　　后后之所依

论曰。知八苦后。次正观察四种谛理起十六行智。前为后后之所依止。谓为对治四颠倒故起苦谛四行。一为对治常颠倒故起无常行。二为对治乐净倒故起于苦行。三为对治我颠倒故起于空行。四即为治此起无我行。所以者何。离诸行外余我空故。即诸行体非我性故。次于常乐净我四爱集谛起因集生缘四行。次于此断灭谛起灭静妙离四行。次于此能证道谛起道如行出四行。复次颂曰

  从是转修习　　于心总厌离
  谛简择决定　　究竟觉生起

论曰。从十六行智后复转修习。先缘自心总厌心智生此说名暖。从此已上谛简择智生。此说名顶从此已上决定觉智生。此说名忍。复从此已上究竟觉智生。此说名为世第一法

显扬圣教论卷第十六显扬圣教论卷第十七

        无著菩萨造

        三藏法师玄奘奉　诏译

    成现观品第八之余

论曰。如是已得暖等善根。当知从此入于现观。颂曰

  从此无加行　　解脱智三心
  一百一十二　　烦恼断十摄

论曰。从此无间无有加行。解脱见道所断随眠三心智生。一内遣有情假缘智。二内遣诸法假缘智。三遍遣一切有情诸法假缘智。此中前二是法智。第三是种类智。如是三智能断一百一十二烦恼。如是烦恼十种所摄。一百一十二烦恼者。谓欲界见苦谛等所断各有十种。色无色界见苦谛等所断各有九种。谓各除嗔。如是名为一百一十二烦恼。何等十烦恼所摄。谓五见自性五非见自性。如前已说。复次颂曰

  此证菩提分　　六种净智相
  行无分别故　　随所作建立

论曰。当知此智真证觉分非方便位。亦是六种清净智相。所谓法智种类智苦智集智灭智道智相。此智无分别故但随所作建立六智相貌。不由行差别故建立六种。应知。复次颂曰

  菩萨在此位　　先修胜因力
  于自他身苦　　起平等心性

论曰。在此现观位中诸菩萨。由先修习胜资粮力故。于自他相续苦中起五种平等心。谓粗重平等心。无我平等心。断精进平等心。无爱味精进平等心。一切菩萨现观平等心。复次颂曰

  是大我意乐　　于自性无得
  广意乐当知　　二性无分别

论曰。当知此平等心性即是大我阿世耶。及广大阿世耶。于遍计所执自性无所得故。于有漏无漏二性过失功德亦无所得。由无分别故。复次颂曰

  次上十六行　　清净世间智
  对治界地故　　究竟事成就

论曰。从此谛现观已上。于修道中有十六行。世出世清净智生。谓于欲系苦谛生二智。一现观审察智。二现观决定智。于色无色系苦谛亦有如是二智。如于苦谛有四智。如是于集灭道谛亦各有四智。如是总有十六种智。复次如是现观智。若声闻等所得。为对治欲色无色三界杂染。若诸菩萨所得。为对治十种地障。如是当知诸所作事成就究竟。所谓转依究竟亦是现观智究竟。亦名究竟现观。复次颂曰

  此现观差别　　或六或十八
  相胜利众多　　随经论所说

论曰。当知现观差别复有六种。一思现观二信现观三戒现观四现观智谛现观。五现观边智谛现观六究竟现观。问思现观以何为体答以上品思所生慧为体。或彼俱行菩提分法为体。问信现观以何为体。答以上品世出世缘三宝净信为体。或彼俱行菩提分法为体。问戒现观以何为体。答以圣所爱身语等业为体。或彼俱行菩提分法为体。问现观智谛现观以何为体。答以缘非安立谛圣慧为体。或彼俱行菩提分法为体。问现观边智谛现观以何为体。答以缘安立谛圣慧为体或彼俱行菩提分法为体问究竟现观以何为体答以尽智无生智等为体。或彼俱行菩提分法为体

又此现观差别有十八种。谓闻所生智现观。思所生智现观。修所生智现观。顺决择分智现观。见道现观。修道现观。究竟道现观。不善清净世俗智现观。善清净世俗智现观。胜义智现观。不善清净行有分别智现观。善清净行有分别智现观。善清净行无分别智现观。成所作前行智现观。成所作智现观。成所作后智现观。声闻等智现观。菩萨等智现观。复次如是现观相貌胜利。随诸经论多种应知。问思现观有何相貌。答若有成就思现观者。能正了知诸行无常。诸行皆苦。诸法无我。涅槃寂静。虽住异生位已能如是决定解了一切。沙门婆罗门诸天魔梵及余世间。决定无能如法引夺。问信现观有何相貌。答若有成就信现观者。或住异生位或住非异生位。若于现法若现后法终不宣说。于异众中别有大师。别有善说法别有正行僧。问戒现观有何相貌。答若有成就戒现观者。乃至畜生终不故害其命。及不与取行邪佚行。知而妄语饮窣罗迷隶耶末陀放逸处酒。问现观智谛现观有何相貌。答若有成就现观智谛现观者。终不依止异见起所作业。及于自所证起疑起惑。及染着一切生处计行吉相而得清净。诽谤三乘造恶趣业。况复能起害父害母等诸无间业。乃至终不生第八有。问现观边智谛现观有何相貌。答若有成就现观边智谛现观者。于自所证。若他问难终不怯怖。问究竟现观有何相貌。答若有成就究竟现观者。终不堕于五种犯处。终不故害众生之命。及不与取习近淫佚非梵行法。故说妄语贮积财物受用诸欲。又终不怖畏不可记论事。终不计执自作苦乐他作苦乐自他作苦乐。非自非他作无因生苦乐。诸如是等名为现观相貌。当知此即现观胜利。若随经随论如前广说

    显扬圣教论成瑜伽品第九

论曰。前说菩萨于此位中先修因力等。云何名为先因力耶。颂曰

  般若度瑜伽　　等至无分别
  一切一切种　　无有分别故

论曰。依止三摩钵底发起般若波罗蜜多瑜伽胜行。即此正慧能到彼岸。是大菩提最胜方便。故名瑜伽。此所依止等至无有分别。于一切法及一切种无分别故。云何一切及一切种。颂曰

  一切一切种　　三相与三轮
  谓名相染净　　及俱非二种

论曰。一切者。谓三轮。一所知境。二能知智。三能知者。一切种者。谓三相。一名相。二染净。三俱非。名者。谓假立等十二种。名相者。谓自相及共相。染者。谓染污法。净者。谓诸善法。俱非者。谓无覆无记法。复次如是所说无分别者。于何等法说无分别耶。颂曰

  于法及法空　　无二种戏论
  无分别无穷　　此上非应理

论曰。法与法空俱无二种戏论。故名无分别。云何为二。谓有及无。何以故。色非是有。遍计所执相无故。亦非是无。彼假所依事有故。色空亦非有。遍计所执相无所显故。亦非是无。诸法无我有所显故。如于色色空。如是于余一切法及一切法空。当知亦尔。非离诸法及法空外更有余境是可得者。是故但说二无分别非无分别。更无分别有无穷过。此上更无所知境故。复次颂曰

  若都无所取　　无慧亦无度
  俱成取离言　　为顺非无用

论曰。此若无有二种分别。即无有取。都无取故慧体尚无。况到彼岸。是故必有离言相取。由此取故慧到彼岸二俱成就。所以者何。由此圣慧虽不取如所言相性。而取离言相性故。问若此圣慧不取如言相性者。宣说正法应无所用。答不然。为随顺故。所以者何为欲随顺离言相取。是故如来宣说正法

    显扬圣教论成不思议品第十

论曰。要先思惟方入现观。是故应离不可思议处方便思惟。云何名为不可思议处。颂曰

  九事不思议　　由依止五处
  有五种因故　　得失俱三种

论曰。有九种事不可思议。一我。二有情。三世界。四业报。五静虑者境界。六诸佛境界。七十四不可记事。八非正法。九一切烦恼之所引摄。若有思惟如是九事。必定依止五种处所方起思惟。一见。二忍。三推寻。四利养。五散乱。依止于见思惟我及有情。依止于忍思惟世界。依止推寻思惟业报。静虑者境界诸佛境界及十四种不可记事。依止利养思惟非正法。依止散乱思惟。一切烦恼之所引摄。问何因缘故。如是九事不应思议。答五因缘故。一我及有情无自相故。不应思议。二世界现成相故。不应思议。三业报及二境界甚深相故。不应思议。四不可记事非一定相故。不应思议。五非正法及诸烦恼之所引摄能引无义相故。不应思议若有思议如是等事。当知能引三种过失。一起心乱过失。二生非福过失。三不得善过失。若不思议能引三种功德。翻此应知。复次颂曰

  不应思不记　　当知由四因
  非定一甚深　　引无义相住

论曰。又若略说。由四种因于不可思议事自不应思惟。亦不应为他记别。一我及有情若有若无非一定故。不可思惟不可记别。二业报及二境界皆甚深故。不可思惟不可记别。三世界不可记事非正法。一切烦恼之所引摄。引无义故。不可思惟不可记别。四真如于行等法不即不离。其相法尔安住故。不可思惟不可记别。复次颂曰

  不思我有无　　成二过失故
  于他亦二失　　不应思一异

论曰。不应思我若有若无。何以故。成二过失故。若思为有。即于非实有义起增益执过。若思为无。即于假有义起损减执过于他有情。若执一异亦成二过。若执为一。有情多过。若执为异。非六处过。复次颂曰

  二虽不依见　　成故不应思
  不思如是生　　三过所随故

论曰。有情世界器世界。此之二种虽不依见亦不应思。何以故。世共了知现成相故问何故不思此事如是生非不如是耶。答若如是思者。或谓即如是。或谓异如是。或谓无如是。此三种过所随逐故。复次颂曰

  善趣与恶趣　　二作者非定
  过去善恶业　　处事等难思

论曰。于业报中不应思议。修福行者定往善趣。为恶行者定往恶趣。不决定故。又过去世净不净业。若处若事若因若报等。不可思议。复次颂曰

  真如无漏性　　成所作义利
  静虑者如来　　无譬自在故

论曰。静虑者及佛二种境界中。真如及无漏性皆不可思议。又诸佛等成所作义。谓所作利益众生事亦不可思议。何以故。无譬喻故。一切世间无有少事能譬甚深二种境界。又自在故诸如来等由内证得心自在故起所作事世间所有一切作用。若离因缘和合所不见故。复次颂曰

  外道所宣说　　能引无义利
  非理远四处　　无记不应思

论曰。一切不应记事不应思议。诸邪外道之所说故。能引诸无义利故。不如正理故。远离四种正思惟处故。谓因思惟处。果思惟处。杂染思惟处。清净思惟处。复次如前所说。若思惟彼有三种过。云何而有。颂曰

  非处勤功用　　毁谤于大我
  不修清净善　　故成三过失

论曰。由于非处勤功用故起心乱过失。由于得静虑者及佛世尊毁谤最胜功德故生非福过失。由不发起净善法故。有不得善过失。复次颂曰

  远离不思议　　思可思议处
  具八种功德　　故如理应思

论曰。由于不可思议处强思议者有如是过失。故应远离。于可思议处如理思惟。若如是思具八功德。何等为八。所谓能善了知。闇说大说。依义思惟不依文字。少以净信信解。少以慧观观察。坚固思惟。审谛思惟。常勤思惟。于所思惟善能究竟中。无懈退。复次颂曰

  诸佛之所说　　遍知等无违
  五因二因故　　于此不应思

论曰。由五因故于不可思议处不应欣乐思惟。谓诸佛所说故。及于四谛中遍知断证修不相违故。又略由二因故谓教及证教。谓诸佛所说证谓遍知苦等

    显扬圣教论摄胜决择品第十一之一

论曰。如是远离不思议处方便思已。于九种事应以十相发起种种最胜决择。何等为十。颂曰

  数相别有处　　边际与生起
  想善巧摄等　　胜决择诸事

论曰。十种相者。一数二相。三差别。四有性。五处所。六边际。七生起。八想。九善巧。十摄等。此中数者。谓色数。有十五如是等相者。谓假立相自相共相。此中事亦名相。是所相故。名亦名相。相应亦名相。俱是能相具故。如与火色相应表知有暖。如是等众生亦名相。是相者故。取亦名相。是能相体故。差别者。谓有色无色有见无见等差别。有性者。谓假有性实有性胜义有性。处所者。如四大展转及与造色同一处住又色心等同一处所。又依欲界身色界等心展转安住。边际者。如色至色界及与极微。是其边际乐受。乃至第三静虑。是其边际如是等。生起者。谓由如是因缘如是法生。如引势生等。想者。谓句迷惑等。善巧者。谓蕴善巧等。摄等者。谓若摄若相应若依若缘若问论。如是问论复有多种。谓一行顺前句顺后句四句无事句。若能如是善了知者。名善问记。复次于一切事应起种种最胜决择。心事决择今当先说。颂曰

  心性有二种　　异熟及与转
  初阿赖耶识　　种子二应知

论曰。略说心性有二种。一名异熟心。二名转心。异熟心者。即是阿赖耶识。亦名一切种子识。此复二种应知。一证成。二建立。云何证成。颂曰

  执受初明了　　种子业身受
  无心定命终　　无皆不应理

论曰。由八种相证阿赖耶识决定是有。谓若无阿赖耶识依止执受应不可得。最初生起定不可得。明了生起应不可得。诸法种子应不可得。四种业用应不可得。种种身受应不可得。二无心定应不可得。命终时识应不可得。问何故若无阿赖耶识依止执受不可得耶。答由五因故。何等为五。谓阿赖耶识先行因生。眼等转识现缘因起。如经言。根境作意力故诸转识生乃至广说。是名初因。又六识身善不善可得。是名第二因。又六识身一类异熟无记。所摄必不可得。是名第三因。又六识身各别依转。若依彼彼所。依彼彼识。转彼彼所依。应有执受。余无执受不应道理。虽许能执。亦不应理。识远离故。是名第四因。又所依止应成数数执受过失。所以者何。眼识一时转一时不转。余识亦尔。是名第五因。如是先业因现缘因所生故。善不善故。一类不可得故。各别所依故。数数执受过故不应道理。问何故最初生起不可得耶。答设有难言。若有阿赖耶识应有二识同时生起。应告彼言。汝于无过妄生过想。容有二识同时转故。所以者何。谓如有一俱时欲见乃至欲识。随别一识最初生起。不应道理。何以故。尔时作意无有差别。根及境界不坏现前。何因缘故识不俱转。问何故明了生起不可得耶。答若有定执识不俱生。与眼等识同行一境。明了意识应不可得。所以者何。若时缘过去境生起忆念。尔时不明了意识现在前行。非于现境意识现行。得有如是不明了相。是故应许诸识俱转。或应许彼第六意识无明了性。是即有过。问何故种子不可得耶。答六转识身各别异故。所以者何。是六转识从善无间不善性生。不善无间善性复生。从二无间无记性生。劣界无间中界生。中界无间妙界生。如是妙界无间乃至劣界生。有漏无间无漏生。无漏无间有漏生。世间无间出世生。出世无间世间生。非如是相为种子体。应正道理。又彼诸识长时间断。相续经久流转不息。是故转识能持种子。不应道理

问何故诸业不可得耶。答若无诸识同时生起诸业俱转。不应道理。所以者何。若略说业有四种。一器了别业。二依了别业。三我了别业。四境了别业。如是四种了别业用。刹那刹那俱现可得。非于一识一刹那中有如是等差别业用。是故必有诸识俱起

问何故若无阿赖耶识。身受不可得耶。答谓如有一或如理思惟。或不如理思惟。所有推寻。若心在定若不在定。身受生起非一众多。若无此识应不可得如是身受既现可得。是故定有阿赖耶识

问何故若无阿赖耶识。诸无心定不可得耶。答如薄伽梵说。入无想定及灭尽定。当知尔时识不离身。若无此识尔时识应离身。识若离身便应舍命。非谓在定

问何故若无阿赖耶识命终时识不可得耶。答谓如有一临命终时。或从身上分识渐舍离冷触渐发。或从身下分非彼意识有时不转。故知唯有阿赖耶识能执持身。此识若舍于彼身分冷触可得身无觉受。意识不尔。是故若无此识。不应道理。如是已说阿赖耶识证成道理。云何建立。颂曰

  所缘境相应　　更互二因性
  识等俱流转　　杂染污还灭

论曰。略说此识建立由五种相。一所缘境相。二相应相。三互为因相。四俱转相。五杂染还灭相。当知前四种相建立流转杂染还灭相。一种当知建立还灭

问所缘境相建立云何。答若略说此识由了别二种所缘境故转。一由了别内执受故。二由了别外无分别相器故。了别内执受者。谓了别遍计所执自性。妄执习气及诸色根根所依处。谓在有色界若无色界。唯有妄执习气执受。了别外无分别相器者。谓了别依止缘内执受阿赖耶识故。于一切时无有间断。器世界相。譬如灯焰生时。内执炷腻外发光明。如是阿赖耶识。内缘执受境。外缘器世界境。生起道理应知亦尔。又即此识缘境微细。世聪慧者难了知故。又即此识缘境无废时无变易。从初执受刹那乃至命终一味了别而流转故。又即此识于所缘境念念生灭。当知刹那相续流转非常非一。又即此识于欲界中缘狭小执受境。于色界中缘广大执受境。于无色界中空无边处识无边处缘无量执受境。无所有处缘微细执受境。非想非非想处缘极微细执受境。如是了别二种所缘境故。微细了别所缘境故。相似了别故。刹那了别故。了别狭小执受所缘境故。了别广大执受所缘境故。了别无量执受所缘境故。了别微细执受所缘境故。了别极微细执受所缘境故。是名建立阿赖耶识所缘境相

问相应转相建立云何。答此阿赖耶识恒与遍行五种心法相应。所谓作意触受想思。如是五法亦异熟摄。最极微细。世聪慧者亦难了故。如是心法亦常一类缘境而转。又即此识相应受一向不苦不乐无记性摄。当知余心所法行相亦尔。如是遍行心法相应故。一类异熟相应故。最极微细相应故。恒常一类缘境而起相应故。不苦不乐相应故。一向无记相应故。是名建立阿赖耶识相应转相

问互为因相建立云何。答阿赖耶识与彼转识为二种因。一为种子生因。二为所依止因。种子生因者。谓诸所有善不善无记转识生时。一切皆因阿赖耶识种子而生。所依止因者。谓由阿赖耶识所执色根为依止故。五识身转非无执受又由有此识故得有意根。由此意根为依止故意识得生。譬如依止眼等五种色根五识身转非无五根意识亦尔。非无意根。复次转识与阿赖耶识为二种因。一于现法中长养彼种子故。二于后法中为彼得生摄殖彼种子故。于现法中长养彼种子者。谓随依止阿赖耶识。如是如是善不善无记转识生时。于一依止同生同灭。如是如是熏习此识。由是为因缘故后后转识善不善无记性转。复增上转复炽然转。复明了而得生起。于后法中摄殖彼种子者。谓彼熏习种类能引摄未来即此异熟阿赖耶识。如是种子因故。依止因故。长养种子故。摄殖种子故。是名建立阿赖耶识转识互为因相

问诸识俱转相建立云何。答阿赖耶识或于一时唯与一转识俱起谓与意根。所以者何。由此意根恒与我见我慢等相应。高举行相。若有心位若无心位。恒与此识俱时生起。又此意根恒缘阿赖耶识为其境界。执我及慢高举行相而起。又即此识于一时间或与二转识俱起。谓意及意识于一时间或与三转识俱起。谓五识身随一起时前二及此一。于一时间或与四转识俱起。谓五识身随二起时前二及此二。如是于一时间或乃至与七转识俱起。谓五识身和合起时前二及此五复次前说意识依染污意生。意未灭时于相了别缚不得解脱。若意灭已相缚解脱。又此意识能缘他境及缘自境。缘他境者。谓或总或别缘五识身境。缘自境者。谓缘法境。复次阿赖耶识或于一时与苦受乐受不苦不乐受俱转。此受与转识相应依转识起。从此识种子生。又于人趣若于欲缠天中及于一分鬼畜趣中。俱生不苦不乐受。与彼苦乐不苦不乐转识身相应。杂相续受一时俱转。若于地狱趣中他所映夺不苦不乐受与彼转识相应纯苦无杂相续受俱转。当知此受被映夺故。相难可了。如于地狱一向与苦受俱转。如是于下三静虑地。一向与乐受俱转。于第四静虑地乃至有顶地中。一向与不苦不乐受俱转

复次阿赖耶识于一时间或与转识相应善不善无记诸心法俱转。如是阿赖耶识与诸转识一时俱转。亦与客受及客善不善无记心法俱转。然不应说与彼相应。何以故。由不与彼同一缘转故。犹如眼识与眼。虽复俱转。然不相应。此亦如是。由与彼法少分相似故得为喻。喻之道理应如是知又如诸心法。心法体义虽无差别。然相异故一身俱转。互不相违。如是此识与诸转识。当知俱转亦不相违。又如依止暴流有多波浪种种俱起互不相违。又如依止清净镜面种种影像同时俱起互不相违。如是依止阿赖耶识有多转识。当知俱起亦不相违。又如一眼识于一时间于一事境。唯取一类无异相色。或于一时顿取非一种种相色。如眼识于色如是乃至身识于触于一时一事境。或取一相。或复顿取多种境相。如是分别意识于一时间或取一境或复顿取众多境界。当知亦不相违

复次如前所说意根常与此识俱转。于一切时乃至未断。当知恒与任运俱生。四种烦恼相应。所谓萨迦耶见我慢我爱无明。此四烦恼。若在定地若不定地。当知恒行不与善等相违。是有覆无记性。如是与转识俱转故。诸受俱转故。善等俱转故。是名建立阿赖耶识俱转相

问阿赖耶识杂染还灭相建立云何。答若略说阿赖耶识。当知是一切杂染法根本。所以者何。此阿赖耶识亦是有情世间生起根本。能生诸根根所依处及转识等故。亦是器世间生起根本。能生器世间故。又即此识亦是一切有情互相生起根本。一切有情互为增上缘故。所以者何。无有众生于余众生见闻等时不受用彼起苦乐等受。由此义故。当知众生界互为增上缘

复次阿赖耶识具一切种子故。于现在世是苦谛体。是未来世苦谛生因。亦是现在世集谛生因。如是有情世间生根本故。器世间生根本故。是现在世苦谛体故。能生未来苦谛故。能生现在集谛故。当知阿赖耶识是一切杂染根本

复次阿赖耶识所有摄持顺解脱分及顺决择分等善根种子。此非集谛因由。顺解脱分善根等违流转故。所余世间所有善根因此生故转复明净。所以者何。由是缘故。彼所摄受自类种子。转有功能转有势力。增长种子而得成立。由此种子故。彼诸善法转明净生。又复能感后世增上可爱异熟。又依此一切种子阿赖耶识故。薄伽梵说。眼界色界眼识界。乃至意界法界意识界。由于阿赖耶识中有种种界故。又如经说恶叉聚喻。由于阿赖耶识中有非一界故。是故当知即此杂染根本阿赖耶识以修习善法故即得转灭。又此善法修习。若诸异生以缘转识为境作意故。方便住心为欲入初谛现观故非未见谛者。于诸谛中未得法眼。而能通达一切种子阿赖耶识。此未见谛者修如是行已。或入声闻正性离生。或入菩萨正性离生。通达一切法界已。亦能通达阿赖耶识。当于尔时总观各别自内一切杂染。又复了知自身外为相缚所缚内为粗重缚所缚

又此行者由阿赖耶识是一切戏论所摄诸行界故。略彼诸行于阿赖耶识总为一团一积一聚。为一聚已。以缘真如境智。修习多修习故。所依止转转依无间。当知已断阿赖耶识。由此断故。当知已断一切杂染

又此转依以相违故。当知能治阿赖耶识。又阿赖耶识体是无常有取受性。转依是常无取受性。以缘真如境圣道能转故。又阿赖耶识粗重所随转依。究竟远离一切粗重。又阿赖耶识是烦恼生因。圣道不生因。转依是烦恼不生因。圣道生因。此是建立因体非生因体。又阿赖耶识令于善净无记法中不得自在。转依令于一切善净无记法中得大自在。复次此阿赖耶识断灭相者。谓此阿赖耶识正断灭故。便舍二种取。其身虽住犹如变化。所以者何。未来后有苦因断故。便舍未来后有之取于现法中一切烦恼因断故。便舍现法一切杂染所依之取。一切粗重远离故。唯有命缘暂住。由有此故。佛经中说。尔时但受身边际受命边际受。广说乃至即于现法一切所受究竟灭尽。如是建立杂染根本故。趣入通达修习作意故。建立转依故。是名建立阿赖耶识杂染还灭相。如是由胜义道理。建立心意识已。随此所说道理故。于三界中一切心意识一切杂染道理及清净道理。应随显了。若于余处所显心意识道理。此由所化有情差别故。但依具愚夫慧所化有情而说方便令彼易入法故

问若成就阿赖耶识。亦成就转识耶。设成就转识。亦成就阿赖耶识耶。答此应为四句。谓或成就阿赖耶识非转识。谓无心睡眠者。无心闷绝者。入无想定者。入灭尽定者。生无想天者。或有成就转识非阿赖耶识。谓住有心位阿罗汉独觉不退转菩萨及与如来。或有俱成就。谓所余住有心位者。或有俱不成就。谓阿罗汉独觉不退转菩萨及与如来入灭尽定。若处无余依涅槃界

显扬圣教论卷第十七显扬圣教论卷第十八

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄胜决择品第十一之二

复次心差别相建立应知。颂曰

  所依境界力　　建立心差别
  复由七种行　　难了相应知

论曰。心差别相当知。复由所依所缘力而得建立。由所依力者。谓立眼识乃至意识。所缘力者。谓立色识乃至法识。青识黄识乃至苦识乐识。如是等复由七种行相。了知诸心难知差别。一不可知相续久住器差别相。二多种相境差别相。三俱有差别相。四能治所治速疾回转差别相。五习气差别相。六续生差别相。七解脱心差别相。复次颂曰

  所缘无自在　　住恶所依止
  随缘力所转　　心系缚应知

论曰。由三因故说心被缚。一于所缘境不自在故。二安住秽恶所依止故。三随众缘力而转变故。此中于所缘境不自在者。谓于制伏相于化于变等。不如所欲住境自在。复次颂曰

  散乱及安住　　六种十五种
  缘境界六等　　所治心非一

论曰。当知心散乱有六种心安住。有十五种心缘境。有六种等众多差别。所对治心亦非一种。应知

心散乱有六种者。一作意心散乱。谓诸菩萨弃舍大乘相应作意。退习声闻独觉相应下劣作意。二外心散乱。谓于外妙五欲中及愦闹相貌寻思随烦恼外境界中纵心流散。三内心散乱。谓或由惛沉睡眠下劣。或由味着诸定。或由种种定中随烦恼故。恼乱其心。四相心散乱。谓依止外相作意思惟内境相貌。五粗重心散乱。谓内作意为缘生起诸受。由粗重身故计我我所。六自性心散乱。谓五识身心安住有十五种者。一初发安住心。谓修三摩地方便。二证得安住心。谓已得未至三摩地。三圆满安住心。谓已得根本静虑三摩地。四自在安住心。谓即于此得随所欲。五有动安住心。谓于下三静虑。六无动安住心。谓于第四静虑。七此上寂静安住心。谓于寂静无色解脱。八最胜寂静安住心。谓于想受灭解脱。九信解安住心。谓于闻所生智。十决定安住心。谓于思所生智。十一影像安住心。谓于世间修所生智。十二成实安住心。谓出世间修所生智。十三有增上慢出离安住心。谓于世间静虑无色。十四无增上慢出离安住心。谓于出离世间静虑无色。十五三行杂染安住心。谓识随色而住。缘色而住。依色而住。如是乃至随行而住。缘行而住。依行而住。此中随色而住者。谓执受所依故。缘色而住者。谓取境界故。依色而住者。谓由粗重故。如是乃至随行等三。当知识非识住。缘自心心能尽爱故。复次缘境界六等者。谓常缘境非常缘境。遍满缘境。净行缘境。善巧缘境。净惑缘境。如是为先复有多种余缘境界。谓欲界系心缘欲色无色及不系境。如是色无色界系心及不系心各缘四种境。又依欲界系心起欲色无色界系心及不系心。依色界系心起色无色界系心及不系心。依无色界系心起无色界系心及不系心。又过去心缘过去未来现在。如是未来现在心各缘三种。又善心缘善不善无记。如是不善无记心各缘三种。又乐俱行心缘乐俱行等三种境界。如是苦俱行心。不苦不乐俱行心。各缘三种。又贪嗔痴相应心。各缘贪等相应三种境界

复次所治心非一者。谓欲界系有五种心。谓见苦所断心。乃至修道所断心。如是色无色界系心。各有五种。及无漏心合为十六种心复有二十种心。谓欲界系心有八种。一生得善心。二方便善心。三不善心。四有覆无记心。及无覆无记心。分为四种。谓异熟生心。威仪路心。工巧处心。变化心。色界系有六心。除不善工巧处心。无色界系有四心。谓除不善威仪路工巧处变化心。不系心有二种。谓学心无学心。复次心所有事胜决择。今当说。颂曰

  依多境了别　　各为自业生
  心法不应思　　相似境转故

论曰。心所有法依止。能缘多境八种识故。各各造作自业而起。依心而有故名心所有法。不应更思。彼所缘境。由彼与识等缘转故。如经言若于此受即于此思若于此思即于此想若于此想即于此了别。复次今当略说作意触受想思五种遍行心法作业。颂曰

  引心三分别　　领位审了相
  得失等营为　　名作意等业

论曰。引发于心是作意业。三和分别是触业。领纳违顺俱相违位是受业。审了位相是想业。为造功德过失俱非是思业。余心法业如前广说。复次色事决择今当说。颂曰

  上界无香味　　大造随可得
  极微无自体　　非实有七事

论曰。上界无香味者。欲界已上香味无故。大造随可得者。四大及所造色随于聚中现。可得者即自相有。不可得者此中即无。极微无自体者。谓诸极微但假想立自体实无。非实有七事者。谓七种事无有实体。一表色。二形色。三影像。四响音。五触处造色。六律仪色。七不律仪色。复次颂曰

  微和合不离　　善恶无自然
  三相想外无　　法处色十二

论曰。微和合不离者。谓于大极微能依造色处不相离。余异处色若和若合亦不相离。善恶无自然者。色非自体有善恶性。随能发心假说善恶故。三相想外无者。三相色外无别有色。谓有见有对色无见有对色。无见无对色。三想所行色外亦无别色。谓色想有对想种种别异想。法处色十二者。谓法处所摄色。略说有十二种相。一影像相。二所作成就相。三无见相。四无对相。五非实大种所生相。六属心相。七世间相。八不可思议相。九世间三摩地果相。十出世间三摩地果相。十一自地下地境界相。十二诸佛菩萨随心自在转变不可思议相。复次心不相应行胜决择。今当说。颂曰

  当知不相应　　皆假施设有
  假有性六种　　彼皆三过故

论曰。当知心不相应行皆是假有。假有之性略有六种。云何为六。谓若事能起六种言论。何等名为六种言论。一属主相应言论。二远离此彼言论。三众共施设言论。四众法聚集言论。五不遍一切言论。六非常言论。属主相应言论者。谓诸言论配属于主方解其相。非不属主。如说生时。此谁之生。观所属主起此言论。所谓色之生。受想行识之生。非说色时。此谁之色。观所属主起此言论。如生如是住异无常等心不相应行类。如其所应尽当知。是名属主相应言论。若事能起如是言论。当知此是假相

远离此彼言论者。谓诸言论非以此显此。亦非以彼显彼。此说名为远离此彼言论。若以此显此言论。此言论亦于实相处起。亦于假相处起。若以彼显彼言论。此言论亦于实相处起。亦于假相处起。若非以此显此。亦非以彼显。彼言论此言论。一向于假相处起。云何以此显此言论。于实相处起。如言地之坚。云何此复于假相处起。如言石之圆。如地之坚石之圆。如是水之湿油之滑火之暖毁之焰风之动飘之鼓当知亦尔。云何以彼显彼言论。于实相处起。如言眼之识身之触。如是等云何此复于假相处起。如言佛救德友之食饮衣服严具。如是等云何非以此显此。亦非以彼显彼言论一向于假相处起。如舍之门舍之壁瓮之口瓮之腹军之车林之树百之十十之三。如是等是名远离此彼言论。众共施设言论者。谓六种相貌言说自体施设言论。六种相貌者。谓事相。应识相。好等相。益等相。言说状相。邪行等相。事相者。谓若相识所取。应识相者。谓若相由作意故能起于识。好等相者。谓若相触所取。益等相者。谓若相受所取。言说状相者。谓若相想所取。邪行等相者。谓若相思所取

众法聚集言论者。谓于众多和合安立自体言论。如于内色受想行识说我等言论。于外色香味触安立差别说舍瓮军林等言论

不遍一切言论者。谓诸言论有处随转有处退还。如于舍舍言唯随舍转。于村亭等即便退还。于瓮瓮言于余瓶器等即便退还。军言于别男女等退还。林言于别树根茎叶花果等退还

非常言论者。当知四种因。谓破坏故。不破坏故。加行故。转变故。破坏故者。如瓶坏已瓶言舍瓦等言生。不破坏故者。如种种药物共和合已或丸或散种种药言舍药物丸散等言生。加行故者。如于金段起诸加行造作环钏等异庄严具尔时金段之言舍异物环钏等言生。转变故者。如饮食等转变时饮食等言舍粪秽等言生。如是等类应知。非常言论随于诸物。发起如是六种言论。当知此物皆是假有。问诸心不相应行皆是假有。云何应知。答由二种过失故。一因过失。二体过失。因过失者。若言生是生因。能生生故说名为生。是即无别果生可得。此生为谁。能生因故说之为生。若言生是生体。是即从他生故。不应说为能生。如是余心不相应行。如理应知。复次彼心等乃至心不相应行。诸有为法是因性故。此因决择今当说。颂曰

  三过因非五　　因相略系合
  相依处差别　　建立有多种

论曰。有一异计立六种因。谓同类因。遍行因。俱有因。相应因。异熟因。能作因。如是六种。除异熟因余五因性。不应道理。由有三种过失故。何等为三。旦如同类因有三过失。若言同类之因。名同类因。有已成过。何以故。若善等法善等体性。先已成就。彼何用因。若言同类即因。名同类因。是即无果。有不定过。何以故。不示其果。是谁因耶。又非决定因体同类不相似法亦为因故。若言非同类即因亦非同类之因是即言名有虚设过。同类因言无有所主浪施设故。如是于余四因三种过失。亦应如理广说

复次已破不如理因。今当建立如理因相。若略说有二种因。一系缚相因。二和合相因。系缚相因者。谓烦恼随眠。此依能生后有而说。和合相因者。谓因缘和合彼彼法生。此依能生现在时说

又应知此略所说因相。及依处差别。建立复有多种

相者。谓若由此为先。此为建立。此和合故。彼彼诸法。或生或得。或成立或成办。或起作用。当知说此即是彼因

问以谁为先。谁为建立。谁和合故。何法生耶。答自种子为先。除所依种外。所余若色非色所依及业以为建立。伴及所缘境为和合故。如其所应欲系色系无色系及不系诸法生。问以谁为先。谁为建立。谁和合故。得何法耶。答声闻独觉及与如来种性为先。内因力为建立。外因力为和合故。证得烦恼离系涅槃。此中内因力者。谓如理作意少欲知足等内分善法。又得人身生在圣处。诸根无缺无诸业障。于如来所具净信心。如是等法是名内因力。外因力者。谓诸佛出世宣说妙法。住正法者共为伴侣。具悲信者以为施主。如是等法名外因力

问以谁为先。谁为建立。谁和合故何法成立。答于所知法胜解欲乐为先。宗因譬喻以为建立。不相违众及对论者为和合故。所欲立义方得成立

问以谁为先。谁为建立。谁和合故。何法成办。答工巧智为先。随彼勤劳为建立。工巧业处众具为和合故。彼彼工巧业处成办。又爱为先。由食住者依止为建立。四食为和合故。已生有情存养得住

问以谁为先。谁为建立谁和合故。何法作用。答自种为先。即彼前生为建立。彼生缘为和合故。自作业者自所作用而得成办。自所作业者。如眼之见业。如是所余诸根当知各别作业。又如地能持水能烂火能烧风能燥。如是等类是名外法。各别作业

依处者有十五种因缘所依处。一语。二领受。三习气。四有润种子。五无间灭。六境界。七根。八作用。九士夫用。十真实见。十一随顺。十二差别功能。十三和合。十四障碍。十五不障碍。差别者。谓十因四缘五果十因者。谓随说因。观待因。牵引因。生起因。摄受因。引发因。定别因。同事因。相违因。不相违因。四缘者。谓因缘。等无间缘。所缘缘。增上缘。五果者。谓异熟果。等流果。离系果。士用果。增上果

此中随一切法名为先故想。想为先故说。是谓彼诸法随说因。若观待此故。若因此故。于彼诸事若求若取。是谓观待因。如观待手故。手为因故。起执取业。观待足故。足为因故。起往来业。观待节故。节为因故。起屈伸业。观待饥渴故。饥渴为因故追求饮食。随如是等类无量所受。当知皆名观待因。若种子于最后自果是牵引因。即此种子是自果生起因。除种子外。所余缘是摄受因。即此种子果生已后。是种所牵引果引发因。能作种种异类各别之因。是名定别因。若观待因。若牵引因。若生起因。若摄受因。若引发因。若定别因。总摄如是等因。名同事因。若果生已能为障碍。是名相违因。若离障碍。是名不相违因

诸法种子是因缘。等无间缘者。若从此识等无间。诸识等决定生。此是彼等无间缘。若诸心心所有法所缘境。是所缘缘增上缘者。除种子外。余所依如眼及诸共有法于眼识等。如是所余诸根等。于余识等又善不善法摄受爱不爱果。如是等类是增上缘。诸不善法所招恶趣报。有漏善法所招善趣报。是名异熟果。若由习不善故。乐住不善不善增多。修习善故。乐住于善善法增多。又与前业相似后果随转。是名等流果。若由圣八支道诸烦恼灭。是离系果。若诸异生由世间道诸烦恼灭。非究竟转故非离系果。若诸世间于现法中随依一种工巧业处起士夫用。谓营农商贾事王书算计数造印等。由依此故苗稼成满。获商利等果法成就。是名士用果。眼识是眼根增上果。如是乃至意识是意根增上果。又诸众生身不散坏是命根增上果。又二十二根一切各别增上力故彼果得生。应知彼果皆名增上果

问建立云何。答依语因依处建立随说因。何以故。由于欲界系法色无色界系法及不系法建立。名为先故想转。想为先故起语。由语故随见随闻随觉随知起诸言说。是故依语依处建立随说因

依领受因依处建立观待因。何以故。诸有欲求欲界系乐者。彼观此故。于诸欲具或为求得。或求积集或求受用。诸有欲求色无色系乐者。彼观此故。于彼诸缘或为求得。或求受用。诸有欲求不系乐者。彼观此故。于彼诸缘或为求得。或求受用。诸有不欲苦者。彼观此故。于得彼缘于断彼缘。或求远离或求受用。是故依领受依处建立观待因

依习气因依处建立牵引因。何以故。由净不净业熏习三界诸行。于爱不爱趣中能感爱不爱自身。又即由此增上力故。诸外资具或成满或损减。是故依诸行净不净业习气依处建立牵引因

依有润种子因依处建立生起因。何以故。欲系诸法及色无色系诸法。各从自种而得生起。爱名能润种是所润。由此所润诸种子故。先所牵引各别自身今得生起。如经言。业为感生因。爱为生起因。是故依有润种子依处建立生起因

依无间灭因依处及境界根作用士用真实见因依处建立摄受因。何以故。由欲系诸法无间灭摄受故。境界摄受故。根摄受故。作用摄受故。士用摄受故。彼诸行转。如欲系诸行。如是色无色系诸行亦尔。真实见摄受故。余不系诸行转。是故依无间灭境界根作用士用真实见依处建立摄受因

依随顺因依处建立引发因。何以故。欲系善法能引欲系诸胜善法如是欲系善法能引色无色系诸胜善法随顺彼故。如欲系善法。如是色系善法能引色系诸胜善法及无色系若不系诸胜善法。如色系善法。如是无色系善法能引无色系诸胜善法及不系善法。如无色系善法。如是不系善法能引不系诸胜善法及能引无为作证之法。又不善法能引胜不善法。谓如欲贪能引嗔痴慢见疑身恶行语恶行意恶行。如欲贪如是嗔痴慢见疑。如其所应尽当知。如是无记之法能引善不善无记法。所谓能持善不善无记种子阿赖耶识。又无记法能引同类胜无记法。谓诸段食能引已生有情令住不坏。及能引彼适悦势力令其增长。随顺彼故。是故依随顺因依处建立引发因

依差别功能因依处建立定别因。何以故。由欲系法自体功能有差别故。能生种种体差别法。如欲系法如是色系法无色系法及不系法亦尔。是故依差别功能依处建立定别因。依和合因依处建立同事因。何以故。要由获得自生和合故欲系法生。如欲系法如是色系法无色系法及不系法亦尔。如生和合如是得和合成立和合成办和合作用和合亦尔。是故依和合依处建立同事因

依有障碍因依处建立相违因。何以故。若欲系法将生时。若有障碍现前便不得起。如欲系法如是色无色系法及不系法亦尔。如为欲生如是为欲得为欲成立为欲成办为欲作用亦尔。是故依障碍依处建立相违因。依无障碍因依处建立不相违因。何以故。若欲系法将生时。若无障碍现前便得生起。如欲系法如是色无色系法及不系法亦尔。如生如是得成立成办作用亦尔。是故依无障碍依处建立不相违因

复次依种子缘依处建立因缘。依无间灭缘依处建立等无间缘。依境界缘依处建立所缘缘。依所余缘依处建立增上缘

复次依习气及随顺因。依处缘依处建立异熟果及等流果。依真实见因依处缘依处建立离系果。依士用因依处缘依处建立士用果。依所余因依处缘依处建立增上果

复次顺益义是因义。建立义是缘义。成办义是果义。复次建立因有五种相。谓能生因。方便因。俱有因。无间灭因。久远灭因。能生因者。谓生起因。方便因者。谓所余因。俱有因者。谓摄受因一分。如眼于眼识。如是耳等于所余识。无间灭因者。谓生起因。久远灭因者。谓牵引因。又建立因有五种相。谓可爱因。不可爱因。增长因。流转因。还灭因。又建立因有七种相。谓无常法是因相。无有常法得名为因。谓若生因若得因。若成立因。若成办因。若作用因。又无常法为无常法因时。与他性为因。非己性。亦与后自性为因。非即此刹那。又与他性为因。及后自性为因时。必已生未灭。非未生已灭。又已生未灭为因时。必得余缘。非不得。又得余缘时。必成变异。非未成变异。又成变异时。必有功能相应。非功能退失。又功能相应时。必相称随顺。非不相称不随顺。如是七种因相。如其所应建立应知。复次无为决择今当说。颂曰

  心所缘等故　　清净所缘故
  四种离系故　　建立八无为

论曰。八种无为。如摄事品已说。虚空无为者由心所缘境相相似故立为常。非缘彼心缘彼境界有时变异故。由清净所缘故建立真如。由此真如如清净时所缘体相。常如是住故。由四种离系故。建立余四无为。谓非择灭等四种。离系者。谓缘差脱毕竟离系。简择烦恼究竟离系。苦乐暂时离系。心心法暂时离系。如是已说一切决择界事。决择今当说。颂曰

  三界应当知　　十二相差别
  所治及能治　　唯能损伏种

论曰。当知欲色无色三界有十二种相差别。一多种差别。此复六种应知。谓多种所依。多种相貌。多种处所。多种境界。多种烦恼。多种作业。二趣差别。三苦乐不苦不乐俱行差别。四有难无难差别。谓欲界或有难或无难。上二界唯有难少功能故。五不清净处不清净身等差别。谓或有处。不清净身清净。谓欲界无难处生。或有处清净非身清净。谓色无色界异生或有处不清净身不清净。谓欲界有难处生。或有处清净身清净。谓色无色界已见谛者。六受用差别。谓欲界受用外门境界及受用四食。上二界受用内门境界及受用三食。七善根胜劣差别。八杂恶行不杂恶行善根差别。九粗重厚薄差别。十生差别。十一得自体差别。谓于欲界具四种得自体。上二界唯有一种。由彼界无故。自害亦无他害故。十二言说差别。谓欲界中具四种言说。色界无觉无推度故。无色界中一切无有。又此三界能治所治差别应知。谓欲界是所治。色界是能治。色界是所治。无色界是能治。又下地是所治。上地是能治。如是对治唯损伏种。令其微劣。非是永害以更生故。复次颂曰

  法王海碱味　　欲恶趣长寿
  多世界共一　　各二种因缘

论曰。何因缘故焰魔鬼王。说名法王。谓由摄益彼众生故。由二种因能为摄益。一令彼忆念。前生所作。令自诃厌先世恶业故。二令于地狱卒所不造余恶业故。从彼地狱速得出离。何因缘故诸大海水皆悲碱味。谓由二因故。一水生众生福力增上故。令余众生不能趣入。二陆生众生非福增上故。令彼不得入取珍宝。何因缘故。于地狱畜生趣一分众生寿量长远非于欲界所摄善趣。谓恶趣长寿由二因故。一欲界善法思择励力方能起故。二诸不善法不由思择任运起故。何因缘故。此三千大千世界中。有多世界乃至色究竟天。而同说为一世界但至梵世。谓亦由二因故。一同成坏故。二建立众会故

显扬圣教论卷第十八显扬圣教论卷第十九

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄胜决择品第十一之三

论曰。如是已说界事决择。于杂染事胜决择中。烦恼杂染胜决择。今当先说。颂曰

  意相应四惑　　遍行而俱起
  无记最后灭　　随所生彼性

论曰。当知意相应烦恼遍行一切位与一切有漏善等心。俱时现行不相违故。又此烦恼皆是俱生。非分别起。是有覆无记性。非不善性。最后金刚喻定之所顿断。又此烦恼有四种。所谓无明萨迦耶见我慢我爱。若生此界中补特伽罗当知。此意相应烦恼。即是此界体性所摄。复次颂曰

  一切生相续　　现起及与缘
  随眠境粗重　　各差别二十

论曰。若生此界。此地即此界地。一切烦恼令生相续。又此烦恼杂染。若现行若缘若随眠若所缘境若粗重。当知各有二十种相烦恼。现行有二十种者。一随所欲缠现行。谓在家者。二不随所欲缠现行。谓出家者。三无所了别。谓处恶说法者。四有所了别。谓处善说法者。五互增上。谓贪等行者。六皆平等。谓等分行者。七微薄。谓薄尘行者。八外门缠现行。谓未离欲者。九内门缠现行。谓由世间道离欲者。十增上缠现行。谓诸异生。十一失念缠现行。谓诸有学。十二分别缠现行。谓坚执著者。十三俱生缠现行。谓不坚执著者。十四观察现行。谓喜观察者。十五不自在现行。谓睡眠者。十六自在现行。谓觉悟者。十七不可救现行。谓无涅槃法者。十八可救现行。谓有涅槃法者。十九取相现行。谓寻思彼随法而取相貌者。二十不取相貌现行。谓不寻思彼随法不取相貌者。烦恼缘有二十种者。一乐。二苦。三不苦不乐。四欲。五寻。六触。七先所串习。八随眠。九不亲近善友。十不听闻正法。十一不如理作意。十二不信。十三懈怠。十四失念。十五散乱。十六不正知。十七放逸烦恼。十八异生性。十九由离欲。二十由受生

烦恼随眠。有二十种者。一不定地随眠。二定地随眠。三随自境随眠。四随他境随眠。五被损随眠。六未被损随眠。七随顺随眠。八不随顺随眠。九具满随眠。十缺减随眠。十一可害随眠。十二不可害随眠。十三增上随眠。十四平等随眠。十五微薄随眠。十六有觉随眠。十七无觉随眠。十八生多苦随眠。十九生少苦随眠。二十不生苦随眠

烦恼所缘境有二十种者。一缘有事境。二缘无事境。三缘自相境。四缘共相境。五缘现见境。六缘不现见境。七缘外门境八缘内门境。九缘自类烦恼境。十缘他类烦恼境。十一缘自境。十二缘他境。十三缘无境。十四缘有漏境。十五缘无漏境。十六缘有为境。十七缘无为境。十八缘自心分别境。十九缘忆念分别境。二十缘事相境。粗重有二十种者。一性执粗重。二性烦恼粗重。三性业粗重。四烦恼障粗重。五所知障粗重。六定障粗重。七业障粗重。八报障粗重。九盖障粗重。十不正寻思粗重。十一愁恼粗重。十二怖畏粗重。十三劳倦粗重。十四食粗重。十五眠梦粗重。十六淫欲粗重。十七大种乖违粗重。十八时分变异粗重。十九死粗重。二十遍行粗重。又若略说了知烦恼由五种相。谓自体相。因相。品类相。于境心乱相。及果相。复次齐何当说烦恼随眠及不善。颂曰

  随顺自生故　　种子故事故
  生四过失故　　不净三因故

论曰。由四种因故说名随眠。一随顺自生故。谓若烦恼事随顺。此烦恼二种子随缚故。三彼增上事故。四生四过失故。四过失者。一不寂静过失。二差别过失。三发行过失。四摄因过失。此中前一由二所显。三种由四所显。问齐何当知不善烦恼相。答由三因故。谓猛盛故。恼乱有情故。能障碍善故。复次业杂染胜决择今当说。颂曰

  业思及思已　　差别有十三
  彼果六三位　　业决定五种

论曰。若略说业有二种。谓思及思已。此业差别复有十三种。一身业。二语业。三意业。四律仪所摄业。五不律仪所摄业。六俱非所摄业。七福业。八非福业。九不动业。十黑黑异熟业。十一白白异熟业。十二黑白黑白异熟业。十三非黑白无异熟业。能尽诸业。如是等业当知有六种果三种位。六种果者。谓可爱果。不可爱果。清净果。异熟果。等流果。增上果。三位者。谓作用位。习气位。与果位。又如是业有五种决定。一现法受决定。二生受决定。三后差别受决定。四受报决定。五作业决定。复次颂曰

  自业等四种　　此先熟亦四
  复九种当知　　即二种差别

论曰。如薄伽梵说。摩纳婆当知。一切有情自业所作业为诤本。从业所生业为依趣。如是此业自所作业。四种应知。于自相续能与果故。能治所治现在前故。从过去世生现世故。为未来有故。为业尽故名业依趣。又此业报当知四种先后报熟。所谓最先重业报熟。次最近者。次串习者。后先作者。又不可断业当知异熟决定若不定报业。于离欲断不能为碍。又诸外道起如是见说如是论。随诸众生造作诸业。或乐俱行或苦俱行。所受异熟亦复如是。彼诸外道皆是妄执。何以故。具二受故。谓诸善业亦受苦报亦受乐报。不善之业亦复如是。又当知业依二根故成善不善性。谓依善根故起诸善业。依不善根故起不善业。又善不善业差别之相。当知由九种因。一由因及田故。谓由善不善根及尊重等田有差别。二由事故。谓由圆满不圆满事。三由方便故。谓由无间殷重方便。四由依止故。谓由依止或净不净。五由作意故。谓由猛利净信及增上缠。六由欲解故。谓由回向愿求胜劣果报。七由助伴故。谓由所余善不善法之所摄受。八由多修习故。谓自修行亦教他作赞叹随喜。见同法者心生喜悦。九由多人故。谓与多人共行此业。复次生杂染胜决择今当说。颂曰

  命终定不定　　中夭由六因
  明了位三心　　中有或有无

论曰。有二种命终。一决定。谓北胜上洲。二不决定。谓余处。又复中夭由六种因。一不避不平等故。二念忘失故。三意嗔忿故。四寿尽故。五业尽故。六福尽故。又命终时有三种心。谓善心。不善心。无记心。此在分明心位。若至不分明位。定唯无记。又命终后。或有中有。谓将生有色界者。或无中有。谓将生无色界者。复次颂曰

  依余有所缘　　染污心生起
  于四种生中　　及三界五趣

论曰。依止余中有缘生处为境。染污心生起令生有相续。又于四种生中受诸生死。谓卵生胎生湿生化生。又于欲色无色三界中及于地狱等五趣中受诸生死。如是若死若生若处所已显生杂染胜决择。谛事决择今当说。颂曰

  当知世俗谛　　意解义及说
  净所缘彼性　　方便名胜义

论曰。一切言说及因彼意解所得义。皆名世俗谛。若清净所缘。若清净性。若彼方便。皆名胜义谛。清净所缘者。谓四圣谛及真如。清净性者。谓灭谛清净。方便者。谓道谛。复次颂曰

  当知是四种　　染净之所摄
  未见未经受　　如病病灭因

论曰。当知四谛染污清净二法所摄。染污二种。若果若因清净亦尔。如是四谛从无始来一切有情。未如实见灭道二谛。亦未经受。又如病病灭及彼二因建立四谛。苦谛如病。集谛如病因。灭谛如病灭。道谛如病灭因。复次颂曰

  当知是四谛　　各四相四行
  遍知等四种　　因果性差别

论曰。当知四圣谛一一有四种相。苦谛有四相者。一起苦。二内缘苦。三外缘苦。四粗重苦。初谓生苦。第二谓老病死苦。第三谓怨憎会苦爱别离苦所欲匮苦。第四谓五取蕴苦。集谛有四相者。一总爱。二后有爱。三喜贪俱行爱。四彼彼处喜爱。灭谛有四相者。一爱尽。二离欲。三灭。四涅槃。道谛有四相者。谓苦迟通等四种行迹前已说。又一一谛各有四行当知。如成现观品已说。又于诸谛有遍知永断作证修道因果体性应知。前三是果。修道是因。谓遍知苦因。永断集因。及证灭因

云何世俗等说名为谛。颂曰

  彼觉无乖诤　　法尔证亦然
  谛三种唯善　　复二种应知

论曰。彼觉无乖诤法尔者。谓世间愚夫等。由法尔故。于彼诸法觉无乖诤名世俗谛法尔。证亦然者。谓诸已见谛者。如其法性证无乖诤。名胜义谛由此道理。薄伽梵说。一切圣者。以此为谛故名圣谛。又苦等四谛当知。初二通善不善无记三性。余唯是善。又善有二种谓世间出世间。此复二种谓断及道所摄。如是已说谛事决择。依止决择今当说。颂曰

  当知七依止　　三种所依性
  彼善巧二种　　四句等广说

论曰。当知由三种所依性故。薄伽梵说七种依止。何等名为三种所依。一漏尽所依。二功德发起所依。三现法乐住所依。又此依止有二种善巧应知。一三摩地善巧。二三摩钵底善巧。此有四句等广分别。如薄伽梵说嗢柁南伽他曰

  或有静虑者　　三摩地善巧
  或三摩钵底　　或俱不俱等

云何三摩地善巧非三摩钵底善巧。谓于空等三三摩地善巧故。非于胜处遍处灭尽定等善巧故。云何三摩钵底善巧非三摩地善巧。谓于胜处遍处无想定等。若入若出三摩钵底善巧故。非于三三摩地善巧故。云何俱善巧。谓于所说三摩地三摩钵底差别俱善巧故。云何俱非善巧。谓于所说三摩地三摩钵底差别俱不善巧故。复次三摩地善巧非三摩钵底善巧者。谓善了知所入三摩地名句文差别。故不善了知能入三摩地诸行状相故。三摩钵底善巧非三摩地善巧者。谓如有一能善了知所入三摩地诸行状相。而入彼定不善了知此三摩地名句文差别。谓我今入如此如此名三摩地。又有菩萨能入若百三摩地。若千三摩地等。然彼不能了知彼定名句文身差别。谓我今入如此如此名三摩地。乃至未从诸佛及得第一究竟菩萨摩诃萨所闻。或自未得第一究竟

问云何住定。答谓如有一于能入定诸行状相善能了取善了取故。随其所欲住所入定。又于所入诸三摩地无有退失。如是有二种住。一安住于定故名为住。二能不退失故名为住。问云何起定。答谓如有一于能入定诸行状相不复思惟。但以不定地分别相所摄定地同分作意思惟诸法故。从此三摩地起。或因随所作故起。或因决定所作故起。或因期愿所作故起。随所作者。谓衣钵众具业。决定所作者。谓大小便利供事师长乞食等行。期愿所作者。谓如有一期许为他随有所作。或为更入余定故从定起。问云何为行。答行所缘境而入于定故名为行。谓依三摩地所起粗静病痈箭无常等行。问云何名状。答若有将入定者。尔时必有定相生起。由此相故行者自知。我当不久将入如是如是相定。或复已入。又教授师亦知。此行者有如是如是相起。不久当入如是如是定

问云何名相。答相有二种一者境相。二者因相。境相者。谓分别相由缘此故而入于定。因相者。谓能入定所有资粮。如随顺言教定具积集修俱乐欲厌离之心。极善了知乱不乱相。及不为他之所触恼。或人非人或声所作或用所作

问云何名调顺。答若三摩地为诸行相之所拘执。犹如持水法尔被执。不静不妙非安隐道。不能证得心定一趣。当知尔时此三摩地不名调顺。不随意住与此相违名为调顺

闻云何名所行。答谓三摩地境界若过此境定不能知。如入初静虑不能知见第二静虑等事。如是根度及补特伽罗度亦不知见

问云何引发。答谓能略摄广文句义。及能发起诸胜功德

问何等三摩地名为可爱。答谓具惭愧爱敬净信如理作意忆念正知守护诸根持戒无悔等。乃至乐为最后如其所乐入三摩地。当知翻此名非可爱

问云何可爱不可爱谓惭愧等少分成就少分不成就。谓具惭愧非爱敬相应等。乃至广说

问云何为增。答谓三摩地已得增长。问云何为减。答谓三摩地得已退失。问云何方便。答谓趣二之道

问云何奢摩他。答谓无分别影像作意相

问云何执受。答谓由随一若清净相或光明相起执取相

问云何弃舍。答谓于善品已得平等增上舍相。复次依诸静虑胜决择今当说。颂曰

  静虑数障分　　及彼广建立
  远离于苦动　　后后分胜异

论曰。如上所说四种静虑。云何唯四不多不少。由出苦乐事究竟故。所以者何。渐次乃至第四静虑忧苦喜乐得超度故

问初静虑所治障云何。答有五种应知。一贪恚害寻。二苦。三忧。四犯戒。五散乱

问第二静虑所治障云何。答亦有五种应知。一初静虑贪。二寻伺。三苦。四掉。五定下劣性

问第三静虑所治障云何。答有四种应知。一第二静虑贪。二喜。三踊跃。四定下劣性

问第四静虑所治障云何。答亦有五种应知。一入出息。二第三静虑贪。三乐。四乐作意。五定下劣性

问于诸静虑有几支耶。答初有五支。何等为五。谓寻伺喜乐心一境性。第二静虑有四支。谓内等净喜乐心一境性。问内等净以何法为体。答以念正知及舍为体。第三静虑有五支。谓念正知舍乐心一境性。第四静虑有四支。谓舍清净念清净不苦不乐心一境性。问念正知舍一切处有何故于初静虑等不说耶。答初静虑中由寻伺门所引发故。虽有不说。第二静虑中有踊跃自体之所作业。及心所有少分烦恼所缠覆故。总以内等净名显之。第三静虑中彼心所有少分烦恼皆远离故显彼自相。故经中说远离喜贪。初静虑中虽离欲贪未离喜贪。第二静虑中虽离寻伺贪未离喜贪。第四静虑中即此舍念极善清净显了。是故于诸静虑中如其所应彼差别应知

问何故于四静虑建立四支五支耶答住所依故。住顺益故。住自体故。复次思惟境界故。受用境界故。于境不散故。复次顺益所依故。增上心所依故。增上慧所依故复次为对治三种恼乱住障故三种恼乱住者。谓染污住苦住迷乱住。复次如受用五欲者有三种正所作事显彼受用诸欲。一以正方便求所受用。二求得已正受用。三自在随转。如是修静虑者。依三种正所作事。如其所应建立支分应知。复次为对治自苦行故。修静虑者建立支分应知。此复三种对治。一离欲对治。二止息身心逼恼对治。三外心散乱寂静对治。问何故初静虑中说离欲已复说远离恶不善法。答为显诸欲自相及显过患相故。过患相者。谓彼诸欲起恶行已堕极下处。故名为恶。违善法生故名不善复次为显能断烦恼杂染故。及显能断先所积集业杂染故。复次为显断在家者受用事门所生欲故。及显断出家者于寻伺门所生法故。复次为显断欲寻故。及显断恚寻害寻故。复次为显同彼外仙所得相故。及显断彼退已起恶咒故

问何故苦根初静虑中说未断耶。答彼品粗重未远离故。若初静虑已断苦根粗重品者。与住第二静虑时应无差别。是故当知初静虑中未断粗重苦品。问寻伺等法于初静虑等中能为顺益。摄受自地令得清净。何故如来说彼名动。答望他地故说名为动。非望自地

问何故从欲界及于初静虑等中建立后后支耶。答略有三因谓能治所治故。证利益故。证自体故。如是三因于四静虑中五支所摄。如其所应当知。问第二静虑望初静虑有何胜异。答三摩地圆满胜异。问第三静虑望第二静虑有何胜异。答顺益圆满胜异。问第四静虑望第三静虑有何胜异。答清净圆满胜异。复次颂曰

  近分喜有动　　唯初能尽漏
  亦二种缘声　　八等至舍八

论曰。初静虑近分喜有动。非如根本静虑喜。又初近分未至所摄定能尽诸漏非余。又初近分有二种。谓世间出世间。余近分唯世间。由已得初根本无漏静虑故。非于上地诸近分定无漏现前。又处定中取外声时。当知由二种取。一由了别定所缘境及种种所缘境意识故。二由此俱生耳识故。八等至舍八者。谓八种三摩钵底能舍八事舍。何等八。谓舍语寻喜乐故。证四静虑三摩钵底。舍色空识无所有处想故。证四无色三摩钵底。复次颂曰

  现法安乐住　　能入于现观
  赞说想解脱　　四种因当知

论曰。唯诸静虑是现法安乐住性。具有身心二种安故。非无色定无身安故。又依静虑能入现观。非无色定。以诸静虑毗钵舍那极猛利故。又修静虑及诸定者。于无色解脱数入数出赞说彼相。极寂静故。又诸外道于无色定起解脱想故数数赞说。又依有想三摩地解脱能尽诸漏。乃至无所有处三摩地极猛利故。是故薄伽梵说。唯依有想三摩钵底领解通达。非于余地。四种因者。谓诸三摩钵底能为现法安乐住等四种依因。如其次第应知。复次颂曰

  爱味等当知　　十种六三种
  退相续障治　　各多种差别

论曰。爱味相应清净无漏三种静虑。如其次第有十种六种三种应知。云何十种。谓如摄事品已说。云何六种。谓六种清净。一引发清净。二上练清净。三后得清净。四垢染清净。五摄清净。六堪任清净。云何三种。谓出世间无漏。离系无漏。后得无漏

又从离欲退彼相续彼障治应知。各有多种。谓或由依止不平等故退。谓如有一遭于重疾退失于定。如尊者伐勒迦梨说。我今于此三摩地不能证入。将无于此三摩地由多粗重故而退失耶。又如有一为性多粗重。由宿习故。由此多粗重故退三摩地。或由境界胜妙故退。谓如有一得胜妙境界现前故退失定。如闻有外道仙人乃至得非想非非想处定。由触可爱妙色少女身故退失彼定。或由敬养故退。谓如有一现前获得胜妙敬养便退失定。如天与等或由轻毁故退。谓如有一被他嗔毁诃责便退失定。如诸外仙嗔忿退已行诸恶咒或由憍慢故退。谓如有一因所得定自举陵他退失于定。或由增上慢故退。谓如有一于所未得定起。已得增上慢故退所得定。或由不作意故退。谓如有一先由如是诸行状相得入诸定。彼于后时更不思惟此行状相故退失于定。或由不纯熟故退。谓如有一修习始业创发善品。或由自烦恼多现在前故退失定。谓如有一爱上静虑乃至疑上静虑故退失定。或由寿尽福尽业尽故退。谓如有一从上地生处舍命堕下地生。复次若下品烦恼下品善根补特伽罗。由多刹那用功方退。由多刹那用功方得入定。若下品烦恼上品善根补特伽罗。由多刹那用功方退。由一刹那速得入定。若上品烦恼下品善根补特伽罗。由一刹那速退失定。多念用功方能入定。若上品烦恼上品善根补特伽罗。由一刹那速退失定。由一刹那速能入定。复次颂曰

  利根及生转　　当知无有退
  依下地发定　　离欲后生故

论曰。如是退定利根者无。若转易生虽钝根者亦无有退。又静虑等定必先依下地发起。以先于此间入定然后生彼。何以故。要先离欲者后时得生彼故。如是已说依止决择。觉分决择今当说。颂曰

  依二乘大乘　　由二十七相
  正方便当知　　建立于觉分

论曰。依声闻独觉二乘及依大乘建立觉分。由二十七种相正方便应知。何等名为二十七种正方便。谓系属所缘正观方便。舍离染污摄净方便。修治内心调顺方便。引发出世正法方便。彼无间缺方便。真实现觉方便。证余寂灭方便。入所知方便。入断方便。通达不净无乐有苦方便。学圆满方便。于境无散观察方便。圣教不坏方便。摄智所知彼果方便。愿方便。悲愍有情方便。修治智方便。法现观方便。能治所治进趣方便。福德资粮积集方便。成熟有情方便。摄一切菩萨道方便。引发威德方便。引发言教方便。广大甚深心积习方便。远离匮法业方便。安住有情涅槃二界方便。复次颂曰

  身等三差别　　彼影像随观
  由闻等三智　　念法无迷惑

论曰。当知身等各有三种差别。身三种者。或有身分自性不净如身内分。或有身分相似清净如身皮分。或有身分变坏不净。如命终已青瘀等身分。受有三种者。所谓苦乐不苦不乐。心有三种者。谓乐等。受相应法有三种者。谓黑白杂彼影像随观者。如寻思经说于彼身等影像随观。与所知事同分类故。名为影像。所言随者。是相似义。又此随观即是三智。谓闻所生智。思所生智修所生智。如是三智由念力故。于彼增上缘修多罗等法无有迷惑。是故说名念住于身受心法。由念力住故。复次颂曰

  彼所治九种　　作意当知二
  修差别有三　　二种无失坏

论曰。当知诸念住有九种所治障。一不厌离。二不作意。三止观随烦恼。四沉下。五不能堪忍。六于少劣知足。七忘失教授。八违犯戒行。九弃舍欲乐增上猛利诸妙善轭。又于修念住有二种作意。谓不缓作意。不染作意。经言。炽盛者此显第一。正智忆念除世间贪忧者此显第二。又此第二能除三种杂染。何者名为三种杂染。一犯戒因缘心生变悔。由此障故能令初时心不得定二内心惛略。由此障故虽已得定心于所缘忘失沉没。三外心散乱。由此障故虽证胜法而着世间名闻利养。或未能证胜进之法心生忧恼。修差别有三者。修诸念住各有三种。谓于内外俱身等随观。又复于身或唯观影像。或以影像比类于身。或复和合总观。如于身三种如是乃至于法亦尔。又有二种于诸念住无有失坏。一初无失坏。谓不散乱。由此力故能善发起。二后无失坏。谓无增上慢。由此力故善修究竟。复次颂曰

  为断于沉掉　　相应道二种
  观察舍烦恼　　及为尽三爱

论曰。于念住修位中。为断沉掉故应修二种相应道。如比丘尼经及取自心相经说。云何比丘尼经说。如彼经言。为断沉没故应当思惟少分可爱清净相貌。为断掉动故复应略摄。云何取自心相经说。如彼经言。由不取自心相故令心沉没。由取少分可爱外相故沈随烦恼暂时断息。然心未得定复更略摄其心。见沉没过复取外相。见掉动过后复更取自心之相。尔时能断沉掉随烦恼心得正定。略摄其心取自心相。离沉掉故

复次由相应道观察故。能舍烦恼应知。如鷃经说。故彼经言。所言鷃者。喻行者心行非所行处者。喻彼行者思惟可爱境界。被鹞所执者。喻彼行者为贪缠所执。鷃怨诉者。喻彼行者心生变悔。暂放舍者。喻彼行者贪缠暂息。土块者。喻五取蕴。大场垄者喻无常观。窟穴者喻通达真如观。唤鹞子者喻观察作意鹞迅来者喻彼贪缠将现在前。入窟穴者喻思惟真如观。鹞自苦害者喻随眠断

复次此相应道当知能尽三爱。谓助伴爱。利养爱。后有爱。为对治此故显我与法无有差别。复次颂曰

  为断增上慢　　味所依颠倒
  及三心趣入　　修习于念住

论曰。为欲对治增上慢故。为欲对治爱味所依定故。及为对治四颠倒故。修习念住。为对治增上慢者。如经说。唯应于此身受心法若住忆念。乃至或唯有智。或唯有见。或唯系念。此增上慢有二种。谓于未断身等粗重障起。及于未圆满止观俱品治起。为对治爱味所依定者。如经说。无所依止故。为对治颠倒故者。如经说。于诸世间无少执取。由颠倒断故。更不复执少五取蕴为常为乐为我为净。又为三心趣入修习念住应知。谓游行聚落时心趣于出。住愦闹时心趣远离。处于静室心趣涅槃。又趣出生死趣离烦恼乐寂灭故心趣涅槃

显扬圣教论卷第十九显扬圣教论卷第二十

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄胜决择品第十一之四

如是已说觉分决择。补特伽罗胜决择今当说。颂曰

  由根等差别　　建立五唯二
  假设五应知　　三事成圆满

论曰。当知由根等差别故建立五种唯二。如经中说。由缘唯二根故唯二作意可知。缘唯二作意故唯二修可知。缘唯二修故唯二行可知。缘唯二行故唯二补特伽罗可知。行者谓修所引习气。又假设补特伽罗应知。由五种因。一由种性故。谓可救不可救。二由趣入故。谓声闻乘等。三由学故。谓学无学。四由得故。谓住四果及三向。五由过失功德故。谓有障无障具缚不具缚。又由三事故建立三满。一根满。谓不动法。二定满。谓得灭定。三果满。谓阿罗汉

如是已说补特伽罗决择。果事决择今当说。颂曰

  证转依不起　　二因果无退
  三因故断常　　三果三因记

论曰。由证转依故诸烦恼不起。当知转依说名为断。又由二种因故果无有退。谓若未永害烦恼种子证阿罗汉。不应道理故。若已永害烦恼种子即应烦恼必定不生。种因无故。又三因缘故断是常性。一无戏论故现见戏论。是无常性二清净真如之所显故。犹如真金调柔之性。三烦恼不生性。前后无别故。又三种果由三因故如来记别。一证净记别。谓预流果。由得见道四证净故。二喜处记别谓一来果。将得根本定已受少喜故。三随念记别。谓不还果。已得根本定现见诸天众与梵众等共兴言论随念所求自乘功德。未圆满故。如是已说果事决择。功德决择今当说。颂曰

  建立诸功德　　由十七增上
  彼差别无边　　治所治障故

论曰。当知由十七种增上力故建立功德。一由愍有情增上故。谓四无量。二由六障净增上故。谓解脱胜处遍处。此中解脱为方便由余故成满。六障净者。一变化障清净。由前二解脱。二最极现法乐住障清净。由第三解脱净与不净皆清净显现故。三往还障清净。由第四解脱。四引无诤等圣功德障清净。由第五解脱。五诸漏及有障清净。由第六第七解脱。六寂静最极住障清净。当知由第八解脱。三由知时往增上故。谓无诤功德。四由观察所知增上故。谓愿智。五由言教增上故。谓无碍解。六由六处善巧增上故。谓六神通六处善巧者。一引摄善巧。二审听语言善巧。由此善巧以彼语言论难折伏为说正法。三欲解随眠善巧。四来善巧。五往善巧。六解脱善巧。七由他信增上故。谓诸相好。八由三障清净增上故。谓四种遍清净。三障者。谓所依障。所缘障。心智障。九由一切问记增上故。谓诸力。十由摧伏一切他论增上故。谓诸无畏。十一由于所摄众无偏党增上故。谓诸不护。十二由能摄化徒众增上故。谓诸念住。十三由于一切时显现一切智者所作增上故。谓永拔习气。十四由于所应化不过时增上故。谓无忘失法。十五由日夜六反观察世间增上故。谓大悲。十六由超过声闻独觉增上故。谓诸不共佛法。十七由成诸如来所作事增上故。谓一切种妙智。又此诸功德对治所治障差别故。当知无边差别。复次颂曰

  思惟义乐苦　　作意及安住
  艰难与相貌　　殊特非殊特

论曰。彼诸功德。若所对治。若能对治。皆应思惟。云何思惟。所谓若义若乐若苦若作意若安住若艰难若相貌若殊特非殊特

此中思惟义者。谓慧到彼岸义所摄诸句有五种所为义。一为于说者起恭敬义。二为摄众义。三为于言教起尊重义。四为叙述事义。五为于真实义教起多所作义

又一切法有三种义。谓能增益义。所增益义。及法性义。如色有三种能增益色所增益色及色法性。如是一切处应知

复有三轮理趣义宣说诸法。谓依世俗谛理趣。宣说作者。宣说作具。宣说作业。如施者施行受施物者。谓能行施者由此行施及施物受者。如是一切处应知

复有四种理趣言教义。一差别理趣言教。二建立理趣言教。三无异理趣言教。四无作用理趣言教。此中差别理趣者。谓色乃至一切种智性差别。建立理趣者。谓五种建立。一趣入建立。二教授建立。三学建立。四证得建立。五过失功德建立。无异理趣者。有六种。一有非有无异。谓色与色空性。如是一切处应知。二更互无异。谓诸蕴更互相望。如是一切处应知。三世无异。谓于前际观中后际。如是一切处应知。四补特伽罗无异。谓诸有情展转相望。五障治无异。谓常无常乃至流转寂灭。六文字无异。谓名身等。无作用理趣者。谓三轮清净。随于诸处无有作者真实可得。无有作具亦无作业。无有补特伽罗能说无法可说。无补特伽罗能学无法可学。无补特伽罗能证无法可证。无补特伽罗能住过失及与功德。亦无所住无取无法。如是一切

复有二种无量义。一发起问论无量。二回向无所得无量

又为对治三种处所故。说不应住色义。乃至不应住一切法义。三种处所者。一执着处所。二随转处所。三戏论慧行处所

复有三种无相义。一无体无相。二非彼体无相。三不显现无相。如无相。如是无性无自体不生不灭无所执着无所为作无所摄受应知亦尔

复有三种有所得义。一事有所得。二有所得有所得。三无所得有所得。如有所得。如是有执着为作戏论取见计执应知亦尔

复有三种有所得义。一自体有所得。二不远离有所得。三不推析有所得。复有三种无所得义。一自体无所得。二远离无所得。三推析无所得。如无所得。如是空无执着无为作无戏论无取无见无计执应知亦尔。复有三种无所得义。一有性无所得。二彼体无所得。三不显现无所得。无所得者。推求诸法不见自性。非一切种都无所得。然于遍计所执自性无所得时亦不观彼依他自相

又复经言。无所得相应故者。若无所得彼相应耶。应作四句。或无所得非相应者。谓如有一于广大事都无所得。或有相应非无所得者。谓由世间道修诸善法。或无所得亦相应者。谓由出世间道修诸善法。或非无所得亦非相应者。谓染污及无记法现在前

复有五种不正取义。谓补特伽罗不正取。法不正取。变异不正取。损减不正取。差别不正取

复有四种言教义。一言定意不定。二意定言不定。三言意俱定。四言意俱不定

复有二种所对治义。一解脱门所对治。谓分别相愿。二到彼岸所对治。谓悭吝犯戒忿恚懈怠散乱恶慧

复有二种空所对治义。谓十六种邪想现行及十四种相缚

复有二种到彼岸行义。谓世间有所得行。及出世间无所得行。又复世间到彼岸行但是相似非真实。如相似。如是有毒有障无方便应知亦尔。当知出世间到彼岸行与此相违

复次若略说慧到彼岸自体义。当知由三种相。一所依相。二所缘相。三行相。所依相者。谓菩提心。所缘相者。谓色等法。行相有二种。谓世间出世间。世间行者。谓无常苦空无我如病如痈等行。出世间行者。谓无所得相应行。复有三种波罗蜜多善积集修义一以一切智性相应作意与一切有情同共回向阿耨多罗三藐三菩提。二以诸波罗蜜多安住实际。三于实际而不作证

复次如说此心不可思议故者。何因缘故不可思议。谓由此所依由此所缘令心安住。此俱无性故。若是无性即是清净亦不可思议。此不可思议若有性若无性。及与彼心若是异性若不异性故

又复一切戏论行相。三因缘故令心流转。一由亲近故。二由所缘故。三由建立故。亲近故者。谓得报时执持所依所缘故者。谓领受种种境界。及起作种种加行。建立故者。谓无始时来妄想熏习

复有四种分别义。一有分别。二无分别。三二分别四不二分别

复有四种无分别义。一愚痴无分别。二非情无分别。三无作用无分别。四法性无分别

复有二种言教义。谓世俗言教。胜义言教。世俗言教者。谓差别建立二种理趣。胜义言教者。谓无异无作用二种理趣

复次于胜义谛中不可宣说。于言说中当知有三种相。一相相。二杂染相。三清净相

又由三种遍知相现观诸法。三种相者。一假立。二了别。三彼唯量。诸菩萨等以何为乐。谓众生摄益为乐。以何为苦。谓众生损恼为苦。以何为作意。谓思惟一切众生利益事为作意。以何为住。谓以无所分别为住

复次菩萨摩诃萨有十二种艰难之事。聪睿菩萨应当了知。一者于违越法式众生。若罚若舍。是诸菩萨艰难之事。二者方便现行苦逼恼事。防护自心令不起烦恼。是诸菩萨艰难之事。三者无量众生现前求索现在所有非法财物。是诸菩萨艰难之事。四者菩萨唯有一身。无量众生诸所作事。同时现前请为助伴。是诸菩萨艰难之事。五者处放逸处。若处世间可爱妙定。若生天上令心调顺。是诸菩萨艰难之事。六者常求遍作利众生事。而于此事无力无能。是诸菩萨艰难之事。七者愚钝谄诈刚强众生。若为说法若复弃舍。是诸菩萨艰难之事。八者常于生死见大过失。为利众生而不应舍。是诸菩萨艰难之事。九者未证增上清净意乐多分失念命终。是诸菩萨艰难之事。十者未证增上清净意乐。他来求索最极第一所珍爱事。是诸菩萨艰难之事。十一者种种意见种种乐欲众生现前。若教示若弃舍。是诸菩萨艰难之事。十二者常行最极不放逸行。而不尽断一切烦恼。是诸菩萨艰难之事

若诸菩萨遭遇如是艰难之事。或应观其轻重。如其所应建立方便。或应简择补特伽罗。或应励力摄受随因缘转。若发正愿或复制心令不纵逸。或应住心猛利观察。不生厌倦而自安忍。或慈悲故心生放舍。或应发起炽然精进。或复思惟善权方便。如是正对治善巧。菩萨摩诃萨虽遇如是诸艰难事正现在前。而无怯怖自正能免

复次有五种真实菩萨相。由成就此故入菩萨数。云何为五。谓哀愍众生常说爱语。所作勇决。舒手惠施能善剖析甚深义节哀愍者。有二种性。一者乐欲。二者正行。言乐欲者所谓菩萨于诸众生起利益意及安乐意。言正行者。谓诸菩萨于众生所如其欲乐随力随能以身语业而行摄化。是名哀愍。爱语者。欢喜慰喻宣布恩德。是名菩萨于诸众生常说爱语。所作勇决者。谓威猛无怯成就胜力。是名菩萨所作勇决。舒手惠施者。若诸菩萨行广大施行无染施是名菩萨舒手惠施。若诸菩萨善能发起四无碍解正方便智。是名菩萨能善剖析甚深义节自体

复有五种殊特五种非殊特菩萨相。如前摄净义品中说

又于功德事中依止大乘胜决择。今当说。颂曰

  种性如来说　　多佛与一乘
  五种及十种　　六六种道理

论曰。种性差别大乘言教是如来说。于一时间多佛出世及一乘性。如其次第五种十种六种六种道理应知

问云何种性差别五种道理。答谓一切界差别可得故。无根有情不应理故。同类譬喻不应理故。异类譬喻不应理故。唯现在世非般涅槃法不应理故

云何一切界差别可得故。谓佛所说诸有情界。有种种非一有情界。有下劣胜妙有情界。有声闻乘等般涅槃种性有情界。有不般涅槃种性有情界

云何无根有情不应理故。谓不可说由此道理亦应得有无根有情。何以故。以无根者。如外地等非有情故

云何同类譬喻不应理故。谓不应言如刹帝利非刹帝利等种类可转。及那落迦非那落迦等趣性可转。如是般涅槃不般涅槃种性亦应可转。何以故。刹帝利等及那落迦等。具足一切种类界性及诸趣界性故。般涅槃不般涅槃二种种性更互相违故。彼若无有诸界性者。彼应毕竟不可回转。是故同类譬喻不应道理

云何异类譬喻不应理故。谓不可说如于彼彼地方所。或先有彼彼金银铜铁盐等物类种性后便无有或先无后有。如是般涅槃法种性亦应先有后无先无后有。何以故。若有此理顺解脱分应空无果。是故异类譬喻亦不应理

云何唯现在世非般涅槃法不应理故。谓不应言于现在生虽非般涅槃法于余生中复可转为般涅槃法。何以故。无般涅槃种性法故。又若于此生先已积集顺解脱分善根。何故不名般涅槃法。若于此生都未积集顺解脱分善根。云何后生能般涅槃。是故定有非般涅槃种性有情

问云何应知大乘言教是佛所说。答由十种因故。一先不记别故。二今不可知故。三多有所作故。四极重障故。五非寻伺境界故。若不先闻不能如是寻思计度。是故若言是余所说。不应道理。六证大觉故。若未成佛能说佛教不应道理。七无第三乘过失故。八此若无有应无一切智者成过失故。九缘此为境如理思惟对治一切诸烦恼故。十不应如言取彼意故

问云何应知于一时间有多如来出现于世。答由六因故。一无量有情同于一时发大觉愿现可得故。二无量有情同修方便菩提资粮现可得故。三更相障碍不应理故。四菩提资粮同时圆满俱出世间。应道理故。五次第出现不应理故。六毕竟不成不应理故

问何故如来宣说一乘。答由六因故。一即彼诸法约无差别相说故。二约无分别行相说故。三众生无我及法无我平等故。四解脱平等故。谓差别求者有事虚妄分别烦恼对治所缘法性不相违故。五善能变化住故。六行究竟故。复次颂曰

  诸佛妙功能　　彼果土清净
  解脱与法身　　等不思无上

论曰。一切如来于一切所作事功能平等。又彼功能果。佛国土清净解脱身及法身一切诸佛皆平等。皆不可思议。皆无有上应知。复次颂曰

  虽不用加行　　先愿力所引
  依无为发起　　所作无二相

论曰。依止无为法身。虽无加行功用。由本愿力之所引故。任运发起一切如来所作佛事。譬如行者从灭定起。又此所起佛事当知是无尽相。非生死相亦非涅槃相

云何素怛缆藏。云何毗奈耶藏。云何摩怛履迦藏。颂曰

  宣说诸事法　　别解脱分别
  诸法相十一　　是经律本藏

论曰。诸佛世尊唯依摄事显了诸法。是名素怛缆藏。问何等名摄事。答谓四事九事二十九事何等四事。谓闻事归趣事学事菩提事。九种事者。一假立有情事。二彼所受用事。三彼受生事。四彼生已住事。五彼染污清净事。六彼种种差别事。七能说者事。八所说法事。九众会事。二十九种事者。谓于遍摄九事经中依杂染品说有四事。一摄诸行事。二即于此中次第转事。三即于此中立众生想后转因事。四即于此中建立法想后转因事。又依清净品说有二十五事。一于所缘境安住事。二即于此中劬劳事。三心安住事。四现法乐住事。五出一切苦所缘方便事。六彼遍知事。此有三种。谓颠倒依处遍知故依有情想于外有情邪行依处遍知故。内离增上慢依处遍知故。七修依处事。八作证事。九修习事。十彼坚固事。十一彼行相事。十二彼所缘事。十三观断未断善巧事。十四彼散乱事。十五彼不散乱事。十六不散乱依处事。十七修习无倦方便不远离事。十八修习胜利事。十九此坚固事。二十摄贤圣品事。二十一摄贤圣品所远离事。二十二真实通达事。二十三证涅槃事。二十四于善说法律中所得世间正见超过一切外正见事。二十五不修习此退减事。此由于善说法律中不修习故名为退减。不由邪见过失故

复次佛世尊为诸声闻及诸菩萨说别解脱及广分别别解脱相应法。是名毗奈耶藏。此中由七种相略摄菩萨别解脱应知。一者宣说受持轨则。二者宣说波罗阇已迦处事。三者宣说毁犯处事。四者宣说毁犯体性。五者宣说无犯体性。六者宣说出所毁犯。七者宣说舍律仪事

复次佛世尊以十一种相显了分别开示诸法。是名摩怛履迦藏。云何名为十一种相。一世俗谛相。二胜义谛相。三菩提分法所缘相。四此行相。五此自体相。六得此果相。七此领受显了相。八此障碍法相。九此随顺法相。十此过患相。十一此称赞相

世俗相者。当知宣说补特伽罗。宣说遍计所执自性。宣说诸法作用业具等相。胜义相者。当知宣说七种真如相菩提分法。所缘相者。当知宣说一切种所知事

此行相者。当知宣说八观察行。何等为八。一观察谛行。二观察建立行。三观察过失行。四观察功德行。五观察理趣行。六观察流转行。七观察道理行。八观察广略行。谛者。谓真如。建立者。谓若建立补特伽罗。若建立遍计所执自性。若建立一向分别反问置记论。若建立隐密显了记论。过失者。谓佛所说诸杂染法非一种种差别过失。功德者。如佛所说诸清净法非一种种差别胜利。理趣者。有六种理趣。如摄事品已说。流转者。谓三世三有为相及与四缘。道理者。谓四种道理。一观待道理。二作用道理。三证成道理。四法尔道理。若由诸因诸缘故。诸行生起及随显说。是名观待道理。若由诸因诸缘故。诸法若证得若成满。若彼已生能起业用。是名作用道理。若由诸因诸缘故。所立所说所摽举义。得成立得正解。是名证成道理。此复略有二种。一清净。二不清净。清净者。由五种相。不清净者。由七种相。五种清净相者。一现量所得相。二依止现量所得相。三引自类譬喻相。四成就相。五善清净言教相。此中一切行无常性。一切行苦性。一切法无我性是诸世间现量所得。如是等类是名现量所得相。若一切行刹那性。后世有性。净不净业不失坏性。此依粗无常现量所得。依有情种种差别业现量所得。及依苦乐有情净不净业现量所得。由此现量所得故。比类所不现见法。是名依止现量所得相。若于内外诸行中引一切世间共知共得生灭相。引一切世间共知共得生等苦相。引一切世间共知共得不自在相。及于外事中引一切世间共知共得兴盛衰坏相。如是等类是名引自类譬喻相。即现量所得相及引自类譬喻相。此二于所成立一向决定故。当知即名成就相。若诸言教是一切智者所说。如言涅槃寂静。如是等类是名善清净言教相。此中有五种相。能表真实一切智者。何等为五。一者若有出现世间一切智者。正实声名流布世界。二者具三十二大丈夫相。三者成就十力断诸有情所有疑网。四者自称具足四无所畏。不为一切他论难屈。又能摧伏一切外论。五者于其法律八支圣道及四沙门果等可得。如是出现故。妙相故断疑故。立破故。道果故。由此五相表是真实一切智者。如是于证成道理中。由现量故。由比量故。譬喻故。成就故。至教量故。由此五相名为清净。七种不清净相者。一余分同类所得相。二余分异类所得相。三一切同类所得相。四一切异类所得相。五引异类譬喻相。六不成就相。七不清净言教相。若一切法意识所识性。是名一切同类所得相。若相貌若自体若业若法。若因若果等。同异之相。或随一分更互同异之相。是名余分同异类所得相。或决定更互异相。是名一切异类所得相。若并譬喻有余分同类所得相。及有一切异类所得相。由此相于所成立义不决定故。说名不成就相。若并譬喻有余分异类所得相。及有一切同类所得相。由此相于所成立义不决定故。亦名不成就相。由不成就故。名不清净道理观。此观不清净故不应修习。不清净。言教相者。谓诸言教自性不清净应知。法尔道理者。谓若如来出世若不出世法性法界安住无变。是名法尔道理。略广者。谓先说一句法。后后以无量句展转分别显了究竟

此自体相者。所谓能取若行若缘菩提分法四念住等。是名此自体相。得此果相者。谓若世间出世间烦恼断果。及所引发世间出世间功德。是名得此果相

此领受显了相者。谓由解脱智故。即领受此所得果相。及广为他显说其相。是名此领受显了相

此障碍法相者。谓若修菩提分法时。能为障碍染污之法。是名此障碍法相。此随顺法相者。谓即于此菩提分法能为随顺多所作法。是名此随顺法相

此过患相者。谓能障碍所有过失。是名此过患相

此称赞相者。谓随顺法所有功德。是名此称赞相。随所有处。诸佛世尊以如是等十一种相。显了分别开示诸法。是名摩怛履迦。复次颂曰

  诸相与断灭　　无失坏方便
  彼二果差别　　是诸经略义

论曰。当知诸经义略说有五种。一相。二断灭。三无失坏方便。四彼二果。五相等差别。此五略说如善生经。佛告善生。族姓子。有二种事俱为美妙者。是美妙相断灭有二种。谓欲取断灭及依事。取断灭者。此言兼显二种无失坏方便。二种无失坏方便者。谓若落须发乃至趣于非家。若尽诸漏乃至觉受。我生已尽。乃至广说。彼二果者。谓无失坏方便果。寂静性差别者。谓五种寂静差别。一诸缠寂静。二世间离欲寂静。三顺下分寂静。四顺上分寂静。五依事寂静。为显此故。于彼经中说伽他曰

  诸比丘美妙　　寂静离诸漏
  离欲离系缚　　无执受涅槃
  任持最后身　　摧伏魔所使

复次颂曰

  略说瑜伽道　　缘所闻正法
  奢摩他与观　　依影像成就

论曰。若略说瑜伽道。当知多闻所摄。正法为境界。奢摩他毗钵舍那为自体。依止影像及依止事成就。如薄伽梵说。有五种法能摄一切瑜伽行者诸瑜伽地。谓持住明镜及与转依。当知闻正法是持所缘。是住止观。是明影像。是镜事成就。是转依

显扬圣教论卷第二十


显扬圣教论颂

    No. 1603 [cf. No. 1602]

显扬圣教论颂

        无著菩萨造

        三藏法师玄奘奉　诏译

    摄事品第一

  善逝善说妙三身　　无畏无流证教法
  上乘真实牟尼子　　我今至诚先赞礼
  稽首次敬大慈尊　　将绍种智法王位
  无依世间所归趣　　宣说瑜伽师地者
  昔我无著从彼闻　　今当错综地中要
  显扬圣教慈悲故　　文约义周而易晓
  摄事净义成善巧　　无常苦空与无性
  现观瑜伽不思议　　摄胜决择十一品
  一切界杂染　　谛依止觉分
  补特伽罗果　　诸功德九事
  心心所有色　　不相应无为
  界谓欲色等　　及与三千界
  烦恼业生性　　杂染相应知
  诸谛有六种　　依止八与二
  觉分有众多　　最初三十七
  智与解脱门　　行迹及止观
  居处及所依　　发心与悲愍
  诸行通达性　　地波罗蜜多
  菩萨行摄事　　及彼陀罗尼
  三摩地等门　　诸无量作意
  真如作意相　　信解不思议
  广大阿世耶　　应知诸自数
  随信行等七　　复八种应知
  及极七反等　　退法等有六
  软根等七种　　在俗及出家
  声闻乘等三　　可救不可救
  入方便等九　　生差别故二
  复由诸界别　　应知十三种
  果断有五种　　遍知及清净
  净果界菩提　　无学由自数
  断多因故断　　建立断所从
  由作意依修　　及得断次第
  断差别应知　　及断相利益
  如是如所说　　复应知多种
  无量诸解脱　　胜处与遍处
  无诤妙愿智　　无碍解神通
  诸相好清净　　及诸力无畏
  不护与念住　　永断诸习气
  无忘失妙法　　及如来大悲
  佛不共德法　　一切种妙智
  当知前九事　　初为二所依
  次二后六种　　摄杂染清净
  染依差别故　　清净所缘故
  心不流散故　　正修方便故
  彼位差别故　　言说等因故
  彼果故德故　　数次第唯尔
  欲思量无量　　诸问答差别
  由诸佛语言　　事与相摄故
  句迷惑戏论　　住真实净妙
  寂静性道理　　假施设现观
  方所位分别　　作执持增减
  闇语所觉上　　远离转藏护
  简择与现行　　睡眠及相属
  诸相摄相应　　说任持次第
  所作境瑜伽　　奢摩他与观
  诸作意教授　　德菩提圣教
  若欲正修行　　遍知等功德
  由十种法行　　及六种理趣

    摄净义品第二

  诸论中胜论　　亦善入瑜伽
  清净义应知　　由具四净德
  摄一切义故　　彼外不坏故
  易入故入已　　行不失坏故
  诸佛说妙法　　正依于二谛
  一者名世俗　　二者名胜义
  初说我法用　　为随余故说
  七种及四种　　真如名胜义
  自性义建立　　数次第善巧
  想差别应知　　显蕴世俗义
  五三法真实　　彼复四应知
  及四种寻思　　四种如实智
  三自性成立　　差别业隐密
  方便摄别异　　是各有多种
  闻十二分教　　三最胜归依
  三学三菩提　　为有情净说
  闻归学菩提　　六三十二五
  随名数次第　　如应广分别
  圣行无上乘　　大菩提功德
  异论论法释　　应知各多种
  殊特非殊特　　平等心利益
  报恩与欣赞　　不虚方便行
  不颠倒方便　　退堕与胜进
  相似实功德　　善调伏有情
  诸菩萨受记　　堕于决定数
  定作常应作　　最胜法应知
  诸施设建立　　一切法寻思
  及如实遍智　　并及诸无量
  宣说果利益　　大乘性与摄
  菩萨十应知　　建立诸名号
  执因中有果　　显了有去来
  我常宿作因　　自在等害法
  边无边矫乱　　见无因断空
  计胜净吉祥　　名十六异论
  功能无体性　　摄不摄相违
  有用及无用　　为因成大过
  论体论处所　　论据论庄严
  论负论出离　　论多所作法
  体释文义法　　起义难次师
  说众听赞佛　　略广学胜利
  诸地相作意　　依处德非德
  所对治能治　　略广义应知

    成善巧品第三

  于诸蕴界处　　及众缘起法
  处非处根谛　　善巧事应知
  身者自在等　　无因身者住
  流转作诸业　　及增上二种
  于身者等起　　实我所住持
  流转者作者　　及诸增上义
  染污若清净　　起七种愚痴
  对治此应知　　摄七种善巧
  妄计我身者　　依止诸根住
  于境界回转　　受用爱非爱
  言说所依住　　作者有觉者
  由于差别蕴　　总见一身者
  迷惑初因故　　计常因无因
  我住持诸根　　能触及能受
  从此死生处　　计有流转者
  法非法作者　　及彼果增上
  于修习邪行　　计为染污者
  于修习正行　　妄计解脱者
  佛未出于世　　如是愚痴转
  由佛现世间　　说七种善巧
  知世等别故　　能除一合想
  即离与解脱　　众生不可得
  多种及总略　　共有差别转
  增益损减智　　蕴善巧应知
  见三因生故　　说名界善巧
  从无始自种　　多种种生起
  由此及于此　　取者不可得
  依自智成故　　能除下劣性
  知诸触诸受　　由二种生门
  依止于触故　　当知处善巧
  知法处天处　　后后所依止
  由世俗谛故　　了知二种性
  知未断无常　　因能生诸果
  自相续相似　　名缘起善巧
  众生不可得　　而有舍续者
  由了达甚深　　四种缘起故
  不作不趣得　　二余体不转
  净见无余业　　非我自在二
  如是智能知　　处非处善巧
  于自果定处　　异此说非处
  于能取生住　　及染污清净
  无理我观余　　于彼果增上
  于如是方便　　名为根善巧
  谓于取生住　　染净增上故
  二自性苦故　　合故不应理
  由无因有因　　及五种譬喻
  如是随觉故　　应知谛善巧
  随觉未曾见　　未受义因缘
  当知诸善巧　　差别二十三
  异摄论为先　　后最极清净

    成无常品第四

  无常谓有为　　三相相应故
  无常义如应　　六八种应知
  无性坏转异　　别离得当有
  刹那续病等　　心器受用故
  变异应当知　　十五种差别
  所谓分位等　　八缘所逼故
  下界具一切　　中界离三门
  具三种变异　　上界复除器
  无性义无常　　遍计之所执
  所余无常义　　依他起应知
  诸无常皆苦　　众苦所杂故
  迷法性愚夫　　得为害不觉
  由彼心果故　　生已自然灭
  后变异可得　　念念灭应知
  心熏习增上　　定转变自在
  影像生道理　　及三种圣教
  生因相违故　　无住灭两因
  自然住常过　　当知任运灭
  非水火风灭　　以俱起灭故
  彼相应灭已　　余变异生因
  相违相续断　　二相成无相
  违世间现见　　无法及余因
  非身乳林等　　先无有变异
  亦非初不坏　　最后时方灭
  位思烦恼分　　非常变异故
  此若无变异　　受作脱非理
  功能无有故　　摄不摄相违
  有用及无用　　为因成过失
  自性变异相　　有无不应理
  无差别无常　　有差别五失
  无相亦无因　　非自性恒异
  先无有变异　　我应常解脱
  常造不应理　　由二三因故
  财有情增上　　极微非常住
  无常为彼依　　次第差别转
  诸受等异故　　当知觉无常
  于无常无智　　四颠倒根本
  当知世上道　　愚痴力转增
  由放逸懈怠　　见昧乏资粮
  恶友非正法　　当知无智因
  不如理作意　　忆念前际等
  相似相续转　　于无常计常
  生初后中间　　取三有为相
  无常调伏智　　当知由二因
  彼见有六种　　及缘起四种
  自种故非他　　待缘故非自
  无作故非共　　用故非无因

    成苦品第五

  生为欲离因　　灭生和合欲
  倒无倒厌离　　彼因为苦相
  依三受差别　　建立三苦相
  故说一切受　　体性皆是苦
  当知行性苦　　皆粗重随故
  乐舍不应理　　同无解脱过
  利深等障碍　　依进住乘空
  执着性下劣　　颠倒及染污
  如痈疥癞等　　三受之所依
  彼能发三触　　取乐等随转
  自相自分别　　不安隐苦性
  五十五应知　　三苦之所摄
  界缘身等趣　　种类谛三世
  时命品异故　　引众苦差别
  未离欲色等　　三种地应知
  欲界一切种　　色无色除二
  世俗有二种　　胜义谓遍行
  二缘通上地　　当知无现染
  非无色重担　　遍行天粗重
  及谛最后边　　余七上随缚
  当知生等苦　　各五种差别
  苦粗重相应　　三苦所依止
  最后与最后　　各四苦所依
  谓生生根本　　及苦性变坏
  三世之所摄　　二缘苦非上
  所说余诸苦　　皆欲界应知
  失念无功用　　乱不正思惟
  不正了愚痴　　及由放逸等
  昧故羸劣故　　及起放逸故
  相续断绝故　　忘念转应知
  昧故放逸故　　保重现法故
  不信当苦故　　无功用发起
  相似相续转　　对治妄分别
  串习总取故　　起四种颠倒
  界别缘起别　　位别次第别
  及相续差别　　当知各多种
  信解与思择　　不乱心厌离
  见修及究竟　　又如前十一
  缠疑不乐离　　沉恶趣余趣
  下劣行所起　　遍独众苦尽

    成空品第六

  若于此无有　　及此余所有
  随二种道理　　说空相无二
  甚深相应知　　取舍无增减
  差别有众多　　如彼彼宣说
  唯假过失故　　蕴无我过故
  我无身过故　　三我不应理
  如主火明空　　形异依他过
  无常无业用　　非因非有我
  我唯应是假　　譬喻不可得
  七喻妄分别　　无见者等三
  若如种无常　　作者应成假
  如成就神通　　应世俗自在
  我如地如空　　应无常无性
  应如二无作　　分明业可得
  能烧及能断　　唯火等所作
  我于见等具　　非如刀火等
  如光能照用　　离光无异体
  是故于内外　　空无我义成
  如世间外物　　离我有损益
  内虽无实我　　染净义应成
  位思烦恼分　　无常变异故
  我常无转易　　受作脱应无
  法性从缘生　　展转现相续
  有因而不住　　变异故名转
  如身牙河灯　　有种种作用
  我常无变异　　转还不应理
  依我起名想　　见二种过失
  是故遍一切　　实我性都无
  为言说易故　　随顺世间故
  断除怖畏故　　显得失二故
  率尔觉乱起　　世间现可得
  觉为先作业　　有十种过失
  觉我因功用　　自在等各二
  有因及无因　　当知十种过
  不审决遍行　　增益及无事
  于事怖妄见　　譬喻五应知
  无体及远离　　除遣依三种
  对治诸缚想　　十六种差别
  自性与执着　　不开解失念
  一切遍一分　　愚差别流转
  法住求自心　　住自心除缚
  怖无二染净　　证得真空理
  修差别十八　　或有毒无毒
  对治五种执　　略二种应知
  修果应当知　　三菩提功德
  依止转依性　　所作事成就

    成无性品第七

  三自性应知　　初遍计所执
  次依他起性　　最后圆成实
  三无性应知　　不离三自性
  由相无生无　　及胜义无性
  非五事所摄　　此外更无有
  由名于义转　　二更互为客
  于名前觉无　　多名及不定
  于有义无义　　转非理义成
  取己立名故　　余即不能取
  如众生邪执　　增益为颠倒
  由熏起依他　　依此生颠倒
  如是互为缘　　展转生相续
  自性与差别　　有觉悟随眠
  加行名遍计　　又当知五种
  分别有八种　　能生于三事
  分别体应知　　三界心心法
  由二缚所缚　　坚执二自性
  故二缚解脱　　正无得无见
  假有所依因　　若异坏二种
  杂染可得故　　当知依他起
  相粗重为体　　此更互缘生
  非自然是有　　故说生无性
  非决定有无　　一切种皆许
  通假实二性　　世俗说为有
  宣说我法用　　皆名为世俗
  当知胜义谛　　谓七种真如
  圆成实自性　　二最胜智义
  无有诸戏论　　远离一异性
  清净之所缘　　常无有变异
  善性及乐性　　一切皆成就
  实胜义无性　　戏论我无故
  依他无彼相　　亦胜义无性
  依三相应知　　建立五种相
  彼如其所应　　别别有五业
  法执故愚夫　　起彼众生执
  彼除觉法性　　觉法我执断
  于依他执初　　熏习成杂染
  无执圆成实　　熏习成清净
  杂染有漏性　　清净则无漏
  此当知转依　　不思议二种
  真实及自体　　寂静与功德
  一切不思议　　当知由四道
  声闻有二种　　趣寂趣菩提
  依止变化身　　趣无上正觉
  诸声闻转依　　厌背修所得
  菩萨方便修　　无二智依止
  不住生灭故　　诸佛智无上
  利乐诸有情　　不思议无二

    成现观品第八

  当知现所观　　下中上品事
  有漏及无漏　　未见未受遍
  出世间胜智　　能除见所断
  无分别证得　　唯依止静虑
  极戚非恶趣　　极欣非上二
  处欲界人天　　佛出世现观
  未离欲倍离　　及已离欲者
  独一证正觉　　最胜我所生
  非我为智因　　亦非自取境
  我非自现观　　执爱自我故
  无常有境界　　待缘智生起
  断粗重等三　　故依心现观
  已成熟相续　　或听闻正法
  自然极如理　　作意故现观
  系念于所缘　　精勤修静定
  增上善根力　　证圣觉道分
  从是入见道　　无漏正见起
  永断于三结　　证现观应知
  虽恶趣杂染　　计所起惑断
  境见导师等　　随生三所摄
  由先世间智　　简择谛究竟
  于谛无加行　　决定生起相
  智境和合相　　于所知究竟
  当知谛现观　　于十种决定
  我性无三有　　不灭无有二
  无分别无怖　　自断中决定
  发起证等流　　成满次第四
  又法住智等　　次第八应知
  无悔住所缘　　如实见境界
  道所依无惑　　纯差别行断
  三净摄应知　　戒净及心净
  境界依止道　　说为慧清净
  知身等因缘　　善达于三世
  次了知四苦　　复八苦应知
  从是正观谛　　起十六行智
  为治四颠倒　　后后之所依
  从是转修习　　于心总厌离
  谛简择决定　　究竟觉生起
  从此无加行　　解脱智三心
  一百一十二　　烦恼断十摄
  此证菩提分　　六种净智相
  行无分别故　　随所作建立
  菩萨在此位　　先修胜因力
  于自他身苦　　起平等心性
  是大我意乐　　于自性无得
  广意乐当知　　二性无分别
  次上十六行　　清净世间智
  对治界地故　　究竟事成就
  此现观差别　　或六或十八
  相胜利众多　　随经论广说

    成瑜伽品第九

  般若度瑜伽　　等至无分别
  一切一切种　　无有分别故
  一切一切种　　三相与三轮
  谓名相染净　　及俱非二种
  于法及法空　　无二种戏论
  无分别无穷　　此上非应理
  若都无所取　　无慧亦无度
  俱成取离言　　为顺非无用

    成不思议品第十

  九事不思议　　由依止五处
  有五种因故　　得失俱三种
  不应思不记　　当知由四因
  非定一甚深　　引无义相住
  不思我有无　　成二过失故
  于他亦二失　　不应思一异
  二虽不依见　　成故不应思
  不思如是生　　三过所随故
  善趣与恶趣　　二作者非定
  过去善恶业　　处事等难思
  真如无漏性　　成所作义利
  静虑者如来　　无譬自在故
  外道所宣说　　能引无义利
  非理远四处　　无记不应思
  非处勤功用　　毁谤于大我
  不修清净善　　故成三过失
  远离不思议　　思可思议处
  具八种功德　　故如理应思
  诸佛之所说　　遍知等无违
  五因二因故　　于此不应思

    摄胜决择品第十一

  数相别有处　　边际与生起
  想善巧摄等　　胜决择诸事
  心性有二种　　异熟及与转
  初阿赖耶识　　种子二应知
  执受初明了　　种子业身受
  无心定命终　　无皆不应理
  所缘境相应　　更互二因性
  识等俱流转　　杂染污还灭
  所依境界力　　建立心差别
  复由七种行　　难了相应知
  所缘无自在　　住恶所依止
  随缘力所转　　心系缚应知
  散乱及安住　　六种十五种
  缘境界六等　　所治心非一
  依多境了别　　各为自业生
  心法不应思　　相似境转故
  引心三分别　　领位审了相
  得失等营为　　名作意等业
  上界无香味　　大造随可得
  极微无自体　　非实有七事
  微和合不离　　善恶无自然
  三相想外无　　法处色十二
  当知不相应　　皆假施设有
  假有性六种　　彼皆二过故
  三过因非五　　因相略系合
  相依处差别　　建立有多种
  心所缘等故　　清净所缘故
  四种离系故　　建立八无为
  三界应当知　　十二相差别
  所治及能治　　唯能损伏种
  法王海碱味　　欲恶趣长寿
  多世界共一　　各二种因缘
  意相应四惑　　遍行而俱起
  无记最后灭　　随所生彼性
  一切生相续　　现起及与缘
  随眠境粗重　　各差别二十
  随顺自生故　　种子故事故
  生四过失故　　不净三因故
  业思及思已　　差别有十三
  彼果六三位　　业决定五种
  自业等四种　　此先熟亦四
  复九种当知　　即二种差别
  命终定不定　　中夭由六因
  明了位三心　　中有或有无
  依余有所缘　　染污心生起
  于四种生中　　及三界五趣
  当知世俗谛　　意解义及说
  净所缘彼性　　方便名胜义
  当知是四种　　染净之所摄
  未见未经受　　如病病灭因
  当知是四谛　　各四相四行
  遍知等四种　　因果性差别
  彼觉无乖诤　　法尔证亦然
  谛三种唯善　　复二种应知
  当知七依止　　三种所依性
  彼善巧二种　　四句等广说
  静虑数障分　　及彼广建立
  远离于苦动　　后后分胜异
  近分喜有动　　唯初能尽漏
  亦二种缘声　　八等至舍八
  现法安乐住　　能入于现观
  赞说想解脱　　四种因当知
  爱味等当知　　十种六三种
  退相续障治　　各多种差别
  利根及生转　　当知无有退
  依下地发定　　离欲后生故
  依二乘大乘　　由二十七相
  正方便当知　　建立于觉分
  身等三差别　　彼影像随观
  由闻等三智　　念法无迷惑
  彼所治九种　　作意当知二
  修差别有三　　二种无失坏
  为断于沉掉　　相应道二种
  观察舍烦恼　　及为尽三爱
  为断增上慢　　味所依颠倒
  及三心趣入　　修习于念住
  由根等差别　　建立五唯二
  假设五应知　　三事成圆满
  证转依不起　　二因果无退
  三因故断常　　三果三因记
  建立诸功德　　由十七增上
  彼差别无边　　治所治障故
  思惟义乐苦　　作意及安住
  艰难与相貌　　殊特非殊特
  种性如来说　　多佛与二乘
  五种及十种　　六六种道理
  诸佛妙功能　　彼果土清净
  解脱与法身　　等不思无上
  虽不用加行　　先愿力所引
  依无为发起　　所作无二相
  宣说诸事法　　别解脱分别
  诸法相十一　　是经律本藏
  诸相与断灭　　无失坏方便
  彼二果差别　　是诸经略义
  略说瑜伽道　　缘所闻正法
  奢摩他与观　　依影像成就

显扬圣教论颂


业成就论

    No. 1608 [No. 1609]

    业成就论翻译之记

大国将宁。必感灵瑞以为嘉兆邺隍方盛。圣降神宝以为祥征。天亲菩萨造业成就论。出于今世以示太平。此乃大魏都邺安固之兆也

法行有时。寄必得人。兴和三年岁次大梁。七月辛未朔二十五日。骠骑大将军开府仪同三司御史中尉。渤海高仲密。众圣加持。法力资发。诚心敬请三藏法师乌苌国人毗目智仙。共天竺国婆罗门人瞿昙流支释昙林等。在邺城内金华寺译。四千八百七十二字

业成就论

        天亲菩萨造

        元魏天竺三藏毗目智仙译

业有三种。所谓身业口业意业。此是修多罗。有人说言。身所作业是名身业。口言说业是名口业。此二皆有作与无作。意相应业是名意业。此业是思。彼今思量。意是何法。所有身意皆有形相彼缘身生。是何形相。是身形相若身形相何用说名身所作业。是身总分为身摄故。缘身大生名身作业。别中之语于总中说。譬如人言于城中住于林中住

彼攀缘生。何故言彼遮唇等动及形相故。彼心非缘唇等动生。非缘形生缘语生故

不取前愿。彼心不缘前愿而生。异报因缘是故心生。何故言意起业心转他人知故

何者形相所谓长等。何者长等谓见长等。是何入摄色入所摄

长等为是微尘色耶。为如微尘共聚集耶。为是一物遍色等耶。长等若是微尘色者。则彼长等可分分取。如色分取。若如微尘共聚集者。彼色微尘与彼聚集为有何异。彼微尘集无异长者。若是一物遍色等者。则彼一物遍在长等。若一物遍于分分中。皆应可取。以一切处皆具有故。若非一者应分分取。阿含十入微尘和集佛法则坏。又迦那陀异法则成微尘取集。一面见长则生长知。局见短知。正见方知。周见圆知。中出而见则生高知。卑见下知。齐见正知。种种面见则参差知。见[毯-炎+瞿][毯-炎+叟]锦如如而见。则生彼彼形相等知。彼异异物不得一见如色差别

若复意谓一切方处一切形相。是义不然。如是形相无有异物。色亦如是。于方处住见长短等。如树鸟蚁义成无过

若如是者。云何闇远而不见色见集形相。云何皆见未见形相如树行等。见彼行聚不见形相彼无异物

于聚集中若闇若远不见二种。虽见不了为是何物彼见何物。虽见彼色。而不明了。应如是知此意形相义不成就

复有人言。心缘彼生。往故名意。攀缘彼生。为是何义。遮唇等动。何故名往。谓向彼方。是何入摄谓色入摄

云何知此往彼方去。以不异见。如彼火雪苦酒日等变熟因缘入已即出。未见变异然非不异。如然可然佣草木等不见异焰焰非不异。初入之时若不变者后亦不变。以彼因缘不别异故。若薪草等粗细不均。焰量明热皆异不同。以不同见。向彼方义则不相应

若无灭因何故不得心心数法。声灯等灭有何因缘。余亦如是。彼灭因缘自因缘坏。余法因缘何故不尔。又如彼法无有因缘。余亦如是。若初入火草木等色如本不异。后亦如是。不应有异。云何灯明铃等音声。风手初触即灭即止。非此能灭非此能止。若如火等木等烧等色等灭等。初入出时何故不异。以外因缘不别异故。熟物不应有微中上。初变熟物何因得变。因缘唯一能生能灭。此非道理。非以一因能成二法。如是中间更有灭因。如前取舍异相续转。应如是知。若灭有因无法无因如心等生

灭法不成。以一切法皆有因故。灭则无因。如彼火雪苦酒日等熟变因缘。若灭有因。灭如色。如是无法有因缘灭。生亦无因。见彼异法谓是此法生实有因。前心后心如心中间熟变。熟变如乳为酪蒲萄汁酒酒为苦酒。如是无有少法住相。住物无行无行则住。若如是见彼见何物。见此处物岂非见彼处方新彼处方新。而见如草然影。非彼方影于此处见。如日所住。如是日者近远回转。如影增减回转而见。日在方处映障不见

若复有人。如是难言。此何处物。是彼前物转向此方。答彼人曰。此何处物。向义今说。如是住物则无有行。若不行物则是住等外因缘坏。后则异见念念异知。若不异知彼物不别知非彼物何不言异。如是二种俱不可见。如是行往义则不成

实无行往。有为法体念念自坏。方中生因起心为因。手足等动得言行意。日出弟子作如是说。是何入摄色入所摄。彼何以故。眼所不见如青等色。若他人见可得言意。他人不见云何言意。云何知有。云何身中异处动行心风界生。此风界动所谓异方因缘而生。云何草叶随风界倾。行亦如是。异方处生。行力不成何用分别

彼如是身方生因者。心生风界如是名意。云何非意而得言意。释迦子法触入非善亦非不善。彼如是心异方身生。此生名意。若如是者意唯相貌无有实物。身则多分。意亦非意味等他人。释迦子法则不如是。味等非善亦非不善。心生色故彼得言意。非彼心生自风种生。释迦子法则不如是。色入非善亦非不善

色彼方生意不可得。若有彼物供养天得若彼物无天不能与则不可得。生物无异谁能成异。彼不可得如是色等。如眼能见生则不尔。既不可见云何言意。是先已说。如生不尔色亦已说

唯有无作是身之业。何名无作。法入所摄。怖畏等色。云何无作得言无作。若是欲界与心合转则知色界。是则异心及无心时。怖与不怖共心俱失。若受时势力后常不失。戒经中说。比丘默然。云何妄语。又无记业则不可成。无作二种谓善不善。彼刹那间无作合转。如彼分别身口业色。若善不善二俱不成。何以故。舍身则断于未来世爱不爱果则不可得。复有人言。过去业有何故不成。若过去业于未来世得爱不爱二种果报。此则痈上复生疖子。过去业有过去者。名前有后无。若如来说

  虽复经百劫　　而业常不失
  得因缘和合　　尔时果报熟

此偈云何。能与果报。是不失义。如是已释初半偈竟。何人不信久远得果。得果何义。若相续转如稻种子。若住自相应如是知。若住自相能与果者则不失坏。应常与果彼无自相故名失坏。又不如是作已不作。云何不作。果不重与。何故不与。以与竟故。不可与已复更重与。如物生已不复更生。彼同类果何不更与。云何果报皆悉与竟生法因缘无如是力。尽漏之人后念尽漏不与果报。云何后时而得言灭。非如是力能成果报。若种子因于果有力。得言因力能与果报。若何等人有过去者则有未来。何故未来不与果报一切时有有何等物于何时无。彼如是说。若得和合果报则熟。此则不然。若何人力于何时力是何物力。此人此果究竟不成有过去业。于未来世得果报者如是不成

复有人言。彼善不善身口等业。阴相续中离心法熏。若说名集。若名不失。后世则得爱不爱果。若意业异心生灭转。若不熏心。云何后世而得果报。若人读诵久时忆念彼见等物。如是习者。以何法熏。若念何物。彼见诵等后时何处忆念心生灭尽三昧。初心既灭后时何处有心生起。以紫矿汁涂彼摩登隆伽树华。彼二共灭。如是中间何物染果后赤瓤生。法中闻思亦复如是。心相续力熏力转变后世得果。应如是知。如紫矿汁染彼摩登隆伽树华果中赤瓤

身业如是相续熏心故。故不得如是彼心与善不善而共相对。若其此人作善不善。彼人如是爱不爱果与力相应非异相应。若复业灭心相续故后世得果。云何无心灭尽三昧。及无想心相续心断。前业果报即彼身上于后时生

复有人言。彼熏于心相续而得。彼灭三昧何处相续。三摩跋提初心因缘。云何久灭云何因缘。我先已说。过去得果何处如是心中间生。复有人言。色根种子。彼种上得心心数种二处依止。谓心身中色根身中。如是次第如心缘法而生意识。中间无心彼云何生。复有种子得言意相。应如是知。说因为果。如饥渴触。心心数法云何皆有二种种子。一种子中无二种芽。不见如是一因缘中不见多生。彼过亦尔。无心三昧无想心断。云何业果于后时得。此一箱过。是何物箱。随何等人无心三昧。复有人言。有心三昧。若毗婆沙五百罗汉和合众中。婆修蜜多大德说言。若何等人灭定无心。彼得此过。我灭三昧是有心故。引修多罗以为证言。身行则灭诸根不转识不离身。又复彼人。信受何识。有人意识。如来说。意因缘法而生意识。三种和合故名为触。触共受想思等俱生。云何有意识非三事和合。或有和合而非是触。或复有触而非受想。若想受灭得言灭尽。云何如来修多罗说。受皆缘爱。非一切受皆因缘爱。触亦应尔。非一切触皆因缘受。如来亦于修多罗中。别说彼义。无明生触。触生于受。受因缘爱。无处说触离于受想。如是不说。彼过则成而不可遮三事具足得言和合。无彼三事想受不生。若不如是三摩提中尚无彼触何处受想。复有人言唯一意识。彼何者识。为善为染秽污无记。此义今说。若是善者则无贪等善根相应。善无贪等云何无触。若善即时因缘势力。若是善者与善等心则不相离。三种心生善等势力心回无因。若是染者云何不与烦恼相应。若染烦恼云何无触。又复如来于彼十难修多罗说。若有受阴想阴行阴。彼一切阴皆触因缘。无想三昧犹尚无染。况灭三昧

如其彼是不秽污无记。彼复云何。为是报生。为是威仪。为是工巧。为是变化。今当问彼。若是报生。云何有顶三摩提心。下至八地中间悬绝。欲界报识与心相续。如是复有不动心起。云何相续。如摩诃拘絺罗修多罗中问如来言。起灭三昧几触所触。如来答言。慧命拘絺罗。三触所触。所谓无动。无相。无所有。前要期力入灭三昧。前心要期不过时起。此义云何。云何皆缘灭尽三昧有顶心终前欲界业熏心得报。何故非是前心得报。何以故。若前报色于彼断绝。不相续者。云何后心而复相续。若威仪等彼处无触。云何以心缘威仪等。彼有为善九次第定及八解脱则不相应。彼无染心及无记心则不相续。有顶三昧依止灭定忆念攀缘入想受灭。若入灭定有心识者何所攀缘。若缘灭定云何非善。若善则与不贪相应。若相应者云何不得是触因缘。若异攀缘入灭三昧。云何中间乱心相应。自心分别谓是无记。如是二种皆不相应。如是不知阿含实义。彼论师者踊跃而言。灭三昧中犹有意识如是分别

云何彼是有心三昧。如修多罗法师信说。修多罗师云何信说。说彼报识一切种子密系缚业行不断绝。彼彼处生报识坏相相续而行。乃至涅槃而不断绝。彼若如是得言有心异六识身。是故不转。初入灭定。心增上力彼时种子皆悉隐闭故名无心。有二种心。一者聚集诸种子心。二者种种攀缘坏心。离第二心故名无心。如一脚床以无余脚名无脚床。彼种子闭报识念转有濡中上如水如热放箭等势从此到彼。彼种子识期至复生。随何因缘后时别异种种种子。报识是藏。彼彼异识对法共生善不善熏。如彼次第种子力熏若相续转。如彼力熏于未来身。则得彼彼爱不爱果。此识因缘故如是说

  此心识种子　　无边相续行
  自心中因缘　　彼彼种力生
  彼次第不失　　时至则得果
  如摩登隆伽　　涂花瓤时现

如是之义。如来于彼深密解脱大乘经中。有偈说言

  阿陀那种子　　深细稠雨行
  不为愚夫说　　畏分别我故

此偈明何义。彼复有中密缚取身。是故名为阿陀那识。是一切法种子依处。是故名为阿梨耶识。前生业报故名报识。若无彼识。身以何觉。身未尽来。遍身不离。更无异识。若更无对。何物对治烦恼根本。烦恼根合云何对治。无二法故

染行善行无漏心行。如是相续无色界生。彼何者行依何物报。若尔无报亦应得行彼不相应

如彼修集有顶漏尽阿那含人。无所有处无漏现前。有何我所有顶不退。众分和合名为命根。更无异物。彼法唯有报阴相似势力。转行非有异物。相似势力犹如稻秆相似势力。应如是知。更有异识。如说有识

彼何所缘不决定缘。云何识缘言不决定。复说异识如灭三昧。如彼大德铜色弟子。说有分识。复有人言是根本识。何取阴摄。如是之义识取阴摄。此修多罗文字章句云何而说。何识取阴谓六识身。如行缘识是何者识六识身故。忆此法说。如彼行阴。何者行阴六思身故。不摄异法。复何所忆。深密解脱修多罗等如来皆说。愚凡夫我不为说。畏分别我

复何因缘如是分别。彼有为行处处流转恐人不知。若说如是依止攀缘种种了知增上胜心。若彼烦恼对治相应。染净等说彼种子识。若以果比说如是识不说因识。彼颠倒说。如是意故此有身识。复有身识如次第说。此义相应。非见一切修多罗说义相应故。如是非诸修多罗说。莫以一切修多罗中皆不说故。便谓无有阿梨耶识

如是二种心识。并流一处皆有。所谓报识及以异识。若如是者有何等过。若有二种识身相续。如是则应有二众生如身中识

不得如是彼种子果共相应转报识流故。能熏异识。身识中间不如是法。若如是者此则无过。复有种子种子所生异异坏见。如奢卢迦优钵罗等根根所生。若见不见如是不尔。若如是说彼则无过。如是实有阿梨耶识。六识何故不依止我得何者识。若如阿梨耶识相续因缘而转。彼有何异。彼若是一毕竟不动。云何识等而得成熏。如紫矿汁熏彼摩登隆伽树华。若无熏者无转胜法。云何先知如习欲等。久时忆知欲等生长。我中无心而于何处后时心生。若无我者心有何力而于彼我依止分别。若有我者彼心云何次第而生。若共因缘彼异生力。云何可知。若是彼力生住念转。为是何法。若如是者不相似物而共依止。则违阿含说一切法皆无我义。如是非理自意分别思量计我。是故思熏阿梨耶识相续不断后身得果义则成就。非如说相身口之业

又复如是身口业。无违修多罗有三业说。此义云何。此义不违如来所说。如是无过。如是能说云何无过。此义今说。以何义故说三种业。何者为身。何者为业。何义名身。何义名业。何者身业。如是口业亦如是说

以何义故说身等业。不说眼业。以何义故说如是义。十善业道三业摄示。多说恐人如毗离支子。学三种戒为说三种。是身所作非口非意唯分别一复为余人说。身业相身复摄根大大所成集故。名身业者是思集义。名身大大所成微尘聚集

复有人言。不净名身。以不净物和合集故。彼天人身不得言身

意所作行是名意业。身动集业是名身业。思有三种。所谓思量决定进趣。若以身动彼身相续方中生因风界所吹是名身业。除中间句。如娑罗油。或如风尘。说三业道杀盗邪行。彼云何思。彼身数摄。彼身业动杀盗邪行。彼身动转身相续作。彼得言作如贼烧村薪草熟饭

思复云何得言业道。行恶道业故言业道。或身动转故名业道。三种思业得说为业。彼思住持则得杀生窃盗邪行。复依世谛而说身业有善不善。复说彼门以彼思故世间往返相应之义。若思如是善不善业。修多罗中云何说言。身三种作。思业集。作不善生苦。得苦报故。彼门住持彼攀缘者佛如是意

彼思异故说思意业。唯意相应身口不转。何故如来说思思业。如前所说。思有三种。彼二种思。第三进趣

彼思是业。语言是响。响若可解。彼业趣思名字相说故名言语。忆念义说故名言语。业如前说。言语起业故名口业。除中间语。识意名意。意处处生。境界亦心。余如前说

若身业中要有思者异心无心。尔时无思云何而得有怖不怖。思熏不坏得怖不怖思议最胜。若怖不怖意起分别

彼意所熏云何破坏。如自证知遮与不遮。思复无因。彼何者坏。若舍怖畏舍不怖畏。思是其因。意起分别。复有舍因眼语等业

已说觉业非造作业。何者觉业。谓作意行。何者造作。眼等何处。次第力转

  如来说三业　　依法义成就
  我解业成福　　愿众生成佛

业成就论


瑜伽师地论

    No. 1579 [cf. Nos. 1580-1584]

瑜伽师地论卷第一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中五识身相应地第一

云何瑜伽师地。谓十七地。何等十七嗢拖南曰

  五识相应意　　有寻伺等三
  三摩地俱非　　有心无心地
  闻思修所立　　如是具三乘
  有依及无依　　是名十七地

一者五识身相应地。二者意地。三者有寻有伺地。四者无寻唯伺地。五者无寻无伺地。六者三摩呬多地。七者非三摩呬多地。八者有心地。九者无心地。十者闻所成地。十一者思所成地。十二者修所成地。十三者声闻地。十四者独觉地。十五者菩萨地。十六者有余依地。十七者无余依地。如是略说十七。名为瑜伽师地

云何五识身相应地。谓五识身自性。彼所依彼所缘。彼助伴彼作业。如是总名五识身相应地。何等名为五识身耶。所谓眼识耳识。鼻识舌识身识。

云何眼识自性。谓依眼了别色。彼所依者。俱有依谓眼。等无间依谓意。种子依谓即此一切种子。执受所依。异熟所摄阿赖耶识。如是略说二种所依。谓色非色。眼是色余非色。眼谓四大种所造。眼识所依净色。无见有对。意谓眼识无间过去识。一切种子识。谓无始时来乐着戏论。熏习为因。所生一切种子异熟识。彼所缘者。谓色。有见有对。此复多种。略说有三。谓显色形色表色。显色者。谓青黄赤白。光影明闇。云烟尘雾。及空一显色。形色者。谓长短方圆。粗细正不正高下色。表色者。谓取舍屈伸。行住坐卧。如是等色。又显色者。谓若色显了眼识所行。形色者。谓若色积集长短等分别相。表色者。谓即此积集色生灭相续。由变异因于先生处不复重生转于异处。或无间或有间。或近或远差别生。或即于此处变异生。是名表色。又显色者。谓光明等差别。形色者。谓长短等积集差别。表色者。谓业用为依转动差别。如是一切显形表色。是眼所行。眼境界。眼识所行。眼识境界。眼识所缘。意识所行。意识境界。意识所缘。名之差别。又即此色复有三种。谓若好显色。若恶显色。若俱异显色。似色显现。彼助伴者。谓彼俱有相应诸心所有法。所谓。作意触受想思。及余眼识俱有相应诸心所有法。又彼诸法同一所缘。非一行相。俱有相应一一而转。又彼一切各各从自种子而生。彼作业者。当知有六种。谓唯了别自境所缘。是名初业。唯了别自相。唯了别现在。唯一刹那了别。复有二业。谓随意识转。随善染转。随发业转。又复能取爱非爱果。是第六业

云何耳识自性。谓依耳了别声。彼所依者俱有依。谓耳。等无间依。谓意。种子依。谓一切种子阿赖耶识。耳谓四大种所造。耳识所依净色。无见有对。意及种子如前分别。彼所缘者谓声。无见有对。此复多种。如螺贝声大小鼓声。舞声歌声诸音乐声。俳戏叫声女声男声。风林等声。明了声不明了声。有义声无义声。下中上声。江河等声。斗诤諠杂声。受持演说声。论义决择声。如是等类有众多声。此略三种。谓因执受大种声。因不执受大种声。因执受不执受大种声。初唯内缘声。次唯外缘声。后内外缘声。此复三种。谓可意声。不可意声。俱相违声。又复声者。谓鸣音词吼。表彰语等差别之名。是耳所行。耳境界。耳识所行。耳识境界。耳识所缘。意识所行。意识境界。意识所缘。助伴及业如眼识应知

云何鼻识自性。谓依鼻了别香。彼所依者。俱有依。谓鼻。等无间依。谓意。种子依。谓一切种子阿赖耶识。鼻谓四大种所造。鼻识所依净色。无见有对。意及种子如前分别。彼所缘者谓香。无见有对。此复多种。谓好香恶香平等香。鼻所嗅知。根茎华叶果实之香。如是等类有众多香。又香者。谓鼻所闻。鼻所取。鼻所嗅等差别之名。是鼻所行。鼻境界。鼻识所行。鼻识境界。鼻识所缘。意识所行。意识境界。意识所缘。助伴及业如前应知

云何舌识自性。谓依舌了别味。彼所依者。俱有依。谓舌。等无间依。谓意。种子依。谓一切种子阿赖耶识。舌谓四大种所造。舌识所依净色。无见有对。意及种子如前分别。彼所缘者谓味。无见有对。此复多种。谓苦酢辛甘咸淡。可意不可意。若舍处所舌所尝。又味者。谓应尝应吞应啖。应饮应舐应吮应受用。如是等差别之名。是舌所行。舌境界。舌识所行。舌识境界。舌识所缘。意识所行。意识境界。意识所缘。助伴及业如前应知

云何身识自性。谓依身了别触。彼所依者。俱有依。谓身。等无间依。谓意。种子依。谓一切种子阿赖耶识。身谓四大种所造。身识所依净色。无见有对。意及种子如前分别。彼所缘者。谓触。无见有对。此复多种。谓地水火风。轻性重性滑性涩性。冷饥渴饱。力劣缓急病老死蛘。闷粘疲息软怯勇。如是等类有众多触。此复三种。谓好触恶触。舍处所触。身所触。又触者。谓所摩所触。若鞕若软若动若暖。如是等差别之名。是身所行。身境界。身识所行。身识境界。身识所缘。意识所行。意识境界。意识所缘。助伴及业如前应知。

复次虽眼不坏。色现在前。能生作意。若不正起。所生眼识必不得生。要眼不坏。色现在前。能生作意。正复现起。所生眼识。方乃得生。如眼识生。乃至身识应知亦尔

复次由眼识生。三心可得。如其次第。谓率尔心。寻求心。决定心。初是眼识。二在意识。决定心后。方有染净。此后乃有等流眼识。善不善转。而彼不由自分别力。乃至此意不趣余境。经尔所时。眼意二识。或善或染相续而转。如眼识生。乃至身识。应知亦尔

复次应观五识所依。如往余方者所乘。所缘如所为事。助伴如同侣。业如自功能。复有差别。应观五识所依。如居家者家。所缘如所受用。助伴如仆使等。业如作用

    本地分中意地第二之一

已说五识身相应地。云何意地。此亦五相应知。谓自性故。彼所依故。彼所缘故。彼助伴故。彼作业故。

云何意自性。谓心意识。心谓一切种子所随依止性。所随(依附依止)性。体能执受。异熟所摄阿赖耶识。意谓恒行意及六识身无间灭意。识谓现前了别所缘境界。

彼所依者。等无间依。谓意。种子依。谓如前说一切种子阿赖耶识。

彼所缘者。谓一切法如其所应。若不共者所缘。即受想行蕴无为。无见无对色。六内处及一切种子。

彼助伴者。谓作意触受想思。欲胜解念三摩地慧。信惭愧无贪无嗔无痴。精进轻安不放逸舍不害。贪恚无明慢见疑。忿恨覆恼嫉悭诳谄憍害。无惭无愧。惛沉掉举。不信懈怠放逸。邪欲邪胜解忘念散乱不正知。恶作睡眠寻伺。如是等辈。俱有相应心所有法。是名助伴。同一所缘非同一行相。一时俱有。一一而转。各自种子所生。更互相应。有行相。有所缘。有所依。

彼作业者。谓能了别自境所缘。是名初业。复能了别自相共相。复能了别去来今世。复刹那了别。或相续了别。复为转随转发净不净一切法业。复能取爱非爱果。复能引余识身。又能为因发起等流识身。

又诸意识望余识身。有胜作业。谓分别所缘。审虑所缘。若醉若狂。若梦若觉。若闷若醒。若能发起身业语业。若能离欲若离欲退。若断善根若续善根。若死若生等

云何分别所缘。由七种分别。谓有相分别。无相分别。任运分别。寻求分别。伺察分别。染污分别。不染污分别。有相分别者。谓于先所受义诸根成就。善名言者所起分别。无相分别者。谓随先所引。及婴儿等不善名言者所有分别。任运分别者。谓于现前境界。随境势力任运而转所有分别。寻求分别者。谓于诸法观察寻求所起分别。伺察分别者。谓于已所寻求已所观察。伺察安立所起分别。染污分别者。谓于过去顾恋俱行。于未来希乐俱行。于现在执着俱行。所有分别。若欲分别。若恚分别。若害分别。或随与一烦恼随烦恼相应。所起分别。不染污分别者。若善若无记。谓出离分别。无恚分别。无害分别。或随与一信等善法相应。或威仪路工巧处。及诸变化所有分别。如是等类名分别所缘。云何审虑所缘。谓如理所引。不如理所引。非如理非不如理所引。如理所引者。谓不增益非真实有。如四颠倒。谓于无常常倒。于苦乐倒。于不净净倒。于无我我倒。亦不损减诸真实有。如诸邪见。谓无施与等诸邪见行。或法住智。如实了知诸所知事。或善清净出世间智。如实觉知所知诸法。如是名为如理所引。与此相违当知不如理所引。非如理非不如理所引者。谓依无记慧审察诸法。如是名为审虑所缘。云何醉。谓由依止性羸劣故。或不习饮故。或极数饮故。或过量饮故。便致醉乱。云何狂。谓由先业所引。或由诸界错乱。或由惊怖失志。或由打触末摩。或由鬼魅所著。而发癫狂。云何梦。谓由依止性羸劣。或由疲倦过失。或由食所沉重。或由于闇相作意思惟。或由休息一切事业。或由串习睡眠。或由他所引发。如由摇扇。或由明咒。或由于药。或由威神。而发惛梦。云何觉。谓睡增者不胜疲极故。有所作者要期睡故。或他所引从梦而觉。云何闷。谓由风热乱故。或由捶打故。或由泻故。如过量转痢及出血。或由极勤劳而致闷绝

云何醒。谓于闷已而复出离

云何发起身业语业。谓由发身语业智前行故。次欲生故。次功用起故。次随顺功用为先。身语业风转故。从此发起身业语业

云何离欲。谓随顺离欲根成就故。从他获得随顺教诲故。远离彼障故。方便正修。无倒思惟故。方能离欲

云何离欲退。谓性软根故。新修善品者。数数思惟彼形状相故。受行顺退法故。烦恼所障故。恶友所摄故。从离欲退

云何断善根。谓利根者。成就上品诸恶意乐现行法故。得随顺彼恶友故。彼邪见缠极重圆满到究竟故。彼于一切恶现行中得无畏故。无哀愍故。能断善根。此中种子亦名善根。无贪嗔等亦名善根。但由安立现行善根。相违相续名断善根。非由永拔彼种子故

云何续善根。谓由性利根故。见亲朋友修福业故。诣善丈夫闻正法故。因生犹豫证决定故。还续善根

云何死。谓由寿量极故而便致死。此复三种。谓寿尽故。福尽故。不避不平等故。当知亦是时非时死。或由善心或不善心或无记心

云何寿尽故死。犹如有一随感寿量满尽故死。此名时死

云何福尽故死。犹如有一资具阙故死。云何不避不平等故死。如世尊说九因九缘。未尽寿量而死。何等为九。谓食无度量。食所不宜。不消复食。生而不吐。熟而持之。不近医药。不知于己若损若益。非时非量行非梵行。此名非时死

云何善心死。犹如有一将命终时。自忆先时所习善法。或复由他令彼忆念。由此因缘。尔时信等善法现行于心。乃至粗想现行。若细想行时。善心即舍唯住无记心。所以者何。彼于尔时。于曾习善亦不能忆。他亦不能令彼忆念

云何不善心死。犹如有一命将欲终。自忆先时串习恶法。或复由他令彼忆念。彼于尔时贪嗔等俱诸不善法现行于心。乃至粗细等想现行。如前善说。又善心死时安乐而死。将欲终时无极苦受逼迫于身。恶心死时苦恼而死。将命终时极重苦受逼迫于身。又善心死者见不乱色相。不善心死者见乱色相

云何无记心死。谓行善不善者或不行者。将命终时自不能忆。无他令忆。尔时非善心非不善心死。既非安乐死亦非苦恼死又行善不善补特伽罗将命终时。或自然忆先所习善及与不善。或他令忆。彼于尔时于多曾习力最强者。其心偏记余悉皆忘。若俱平等曾串习者。彼于尔时。随初自忆或他令忆。唯此不舍不起余心。彼于尔时由二种因增上力故而便命终。谓乐着戏论因增上力。及净不净业因增上力。受尽先业所引果已。若行不善业者。当于尔时。受先所作诸不善业所得不爱果之前相。犹如梦中见无量种变怪色相。依此相故薄伽梵说。若有先作恶不善业。及增长已。彼于尔时如日后分或山山峰影等悬覆遍覆极覆。当知如是补特伽罗从明趣闇。若先受尽不善业果而修善者与上相违。当知如是补特伽罗从闇趣明。此中差别者。将命终时。犹如梦中见无量种非变怪色。可意相生。若作上品不善业者。彼由见斯变怪相故。流汗毛竖手足纷乱遂失便秽。扪摸虚空翻睛咀沫。彼于尔时有如是等变怪相生。若造中品不善业者。彼于尔时变怪之相或有或无。设有不具。又诸众生将命终时。乃至未到惛昧想位。长时所习我爱现行。由此力故谓我当无。便爱自身。由此建立中有生报。若预流果及一来果。尔时我爱亦复现行。然此预流及一来果。于此我爱由智慧力数数推求制而不着。犹壮丈夫与羸劣者共相捔力能制伏之。当知此中道理亦尔。若不还果。尔时我爱不复现行。又解肢节。除天那落迦。所余生处一切皆有。此复二种。一重二轻。重谓作恶业者。轻谓作善业者。北拘卢洲一切皆轻。又色界没时皆具诸根。欲界没时随所有根或具不具。又清净解脱死者。名调善死。不清净不解脱死者。名不调善死。又将终时。作恶业者。识于所依从上分舍。即从上分冷触随起。如此渐舍乃至心处。造善业者。识于所依从下分舍。即从下分冷触随起。如此渐舍乃至心处。当知后识唯心处舍。从此冷触遍满所依

云何生。由我爱无问已生故。无始乐着戏论因已熏习故。净不净业因已熏习故。彼所依体由二种因增上力故。从自种子即于是处中有异熟无间得生。死生同时如秤两头低昂时等。而此中有必具诸根。造恶业者所得中有。如黑羺光或阴闇夜。作善业者所得中有。如白衣光或晴明夜。又此中有。是极清净天眼所行。彼于尔时先我爱类不复现行。识已住故。然于境界起戏论爱。随所当生即彼形类中有而生。又中有眼犹如天眼无有障碍。唯至生处所趣无碍如得神通。亦唯至生处。又由此眼。见己同类中有有情。及见自身当所生处。又造恶业者。眼视下净伏面而行。往天趣者上。往人趣者傍。又此中有。若未得生缘极七日住。有得生缘即不决定。若极七日未得生缘死而复生。极七日住。如是展转未得生缘。乃至七七日住。自此已后决得生缘。又此中有七日死已。或即于此类生。若由余业可转。中有种子转者。便于余类中生。又此中有有种种名。或名中有。在死生二有中间生故。或名健达缚。寻香行故。香所资故。或名意行。以意为依往生处故。此说身往。非心缘往。或名趣生。对生有起故。当知中有除无色界一切生处。又造恶业者。谓屠羊鸡猪等。随其一类由住不律仪。众同分故作感那落迦。恶不善业及增长已。彼于尔时犹如梦中。自于彼业所得生处。还见如是种类有情及屠羊等事。由先所习喜乐驰趣。即于生处境色所碍。中有遂灭生有续起。彼将没时如先死有见纷乱色。如是乃至生灭道理。如前应知。又彼生时唯是化生。六处具足。复起是心而往趣之。谓我与彼嬉戏受乐习诸伎艺。彼于尔时颠倒谓造种种事业及触冷热。若离妄见。如是相貌尚无趣欲。何况往彼。若不往彼便不应生。如于那落迦。如是于余似那落迦鬼趣中生。当知亦尔。如瘿鬼等。又于余鬼傍生人等及欲色界天众同分中。将受生时。于当生处见己同类可意有情。由此于彼起其欣欲。即往生处便被拘碍。死生道理如前应知。又由三处现前。得入母胎。一其母调适而复值时。二父母和合俱起爱染。三健达缚正现在前

复无三种障碍。谓产处过患所作。种子过患所作。宿业过患所作

云何产处过患。谓若产处。为风热癊之所逼迫。或于其中有麻麦果。或复其门如车螺形。有形有曲有秽有浊。如是等类产处过患应知

云何种子过患。谓父出不净非母。或母非父。或俱不出。或父精朽烂。或母或俱。如是等类。种子过患应知

云何宿业过患。谓或父或母。不作不增长感子之业。或复俱无。或彼有情。不作不增长感父母业。或彼父母。作及增长感余子业。或彼有情。作及增长感余父母业。或感大宗叶业。或感非大宗叶业。如是等类宿业过患应知。若无如是三种过患。三处现前得入母胎。彼即于中有处。自见与己同类有情为嬉戏等。于所生处起希趣欲。彼于尔时见其父母共行邪行所出精血而起颠倒。起颠倒者。谓见父母为邪行时。不谓父母行此邪行。乃起倒觉见己自行。见自行已便起贪爱。若当欲为女。彼即于父便起会贪。若当欲为男。彼即于母起贪亦尔。乃往逼趣。若女于母欲其远去。若男于父心亦复尔。生此欲已。或唯见男或唯见女。如如渐近彼之处所。如是如是渐渐不见父母余分。唯见男女根门。即于此处便被拘碍。死生道理如是应知。若薄福者。当生下贱家。彼于死时及入胎时。便闻种种纷乱之声。及自妄见入于丛林竹[竺-二+韋]芦[竺-二+狄]等中。若多福者。当生尊贵家。彼于尔时便自闻有寂静美妙可意音声。及自妄见升宫殿等可意相现。尔时父母贪爱俱极。最后决定各出一滴浓厚精血。二滴和合住母胎中合为一段。犹如熟乳凝结之时。当于此处。一切种子异熟所摄。执受所依阿赖耶识和合依托。云何和合依托。谓此所出浓厚精血合成一段。与颠倒缘中有俱灭。与灭同时即由一切种子识功能力故。有余微细根及大种。和合而生。及余有根同分精血和合抟生。于此时中说识已住结生相续。即此名为羯罗蓝位。此羯罗蓝中有诸根大种。唯与身根及根所依处大种俱生。即由此身根俱生诸根大种力故。眼等诸根次第当生。又由此身根俱生根所依处大种力故。诸根依处次第当生。由彼诸根及所依处具足生故。名得圆满依止成就。又此羯罗蓝色与心心所。安危共同故名依托。由心心所依托力故。色不烂坏。色损益故彼亦损益。是故说彼安危共同。又此羯罗蓝。识最初托处。即名肉心。如是识于此处最初托。即从此处最后舍

后序　　　　中书令臣许敬宗制

原夫。三才成位。爰彰开辟之端。六羽为君。犹昧尊卑之序。讯余轨于襄陆。沦胥靡征。考陈迹于怀英。寂寥无纪。暨乎黄轩振武。玄顼疏功。帝道盛于唐虞。王业着于殷夏。葳蕤玉册。照耀金图。茂范曾芬。详诸历选。然则基神袭圣衍庆摛和。轶三代而孤标。掩百王而迥秀。我

大唐皇帝。无得而称矣。断鳖初载。万有于是宅心。飞龙在辰。六幽于是仰德。偃洪流而恢地络。练清气而缉天维。散服韬戈。扇无为之道。移浇反璞。弘不言之化。悠悠庶类。协梦于华胥。蠢蠢怀生。遂性于仁寿。大礼大乐。包曲台而掩宣榭。宏谟宏典。澄璧水而藻环林。瑞露祯云。翊紫空而表贶。祥鳞庆翼。绕丹禁而呈符。岁精所记之州。咸为疆场。暄谷所谟之县。并入堤封。广辟辕宫。被文轨于殊俗。还开姬弈。均正朔于王会。大业成矣。大化清矣。于是游心羽陵。寓情延阁。总万箧于天纵。资一贯于生知。洞照神襟。深穷性道。俯同小伎。则绚发三辰。降习微毫。则妙逾八体。居域中之大宝。毕天下之能事。虽则甲夜观书。见称优洽。华旦成曲。独擅风猷。仰挍鸿徽。岂可同年而语矣。有玄奘法师者。胎彰辩慧。蹑身子之高踪。生禀神奇。嗣摩什之芳轨。奚初束发。即事抽簪。迥出盖缠。深悟空假。研求四谛。嗟谬旨于真宗。钻仰一乘。鉴讹文于实相。遂乃发弘誓愿。起大悲心。思拯迷途。亲寻正教。幸属时康道泰。远安迩肃。裂裳裹足。直趣迦维。阐皇泽于遐方。征释教于前域。越葱岭之外。犹跬步而忘远。遵竹园之左。譬亲受而何殊。访道周游十有七载。经途所亘百有余国。异方之语。资一音而并贯。未译之经。罄五财而毕写。若诵若阅。喻青莲之受持。半句半偈。随白马而俱返。以贞观十九年。持如来肉舍利一百五十粒。佛像七躯。三藏圣教要文凡六百五十七部。二月六日还至长安。奉敕于弘福寺安置。令所司供给。召诸名僧二十一人学通内外者。共译持来三藏梵本。至二十一年五月十五日。肇译瑜伽师地论。论梵本四万颂。颂三十二字。凡有五分。宗明十七地义。三藏法师玄奘。敬执梵文译为唐语。弘福寺沙门灵会。灵隽。智开知仁。会昌寺沙门玄度。瑶台寺沙门道卓。大总持寺沙门道观。清禅寺沙门明觉烝义笔受。弘福寺沙门玄暮。证梵语。大总持寺沙门玄应。正字。大总持寺沙门道洪。实际寺沙门明琰。宝昌寺沙门法祥。罗汉寺沙门惠贵。弘福寺沙门文备。蒲州栖岩寺沙门神泰。廓州法讲寺沙门道深。详证大义。本地分中。五识身相应地意地。有寻有伺地。无寻唯伺地。无寻无伺地。凡十七卷。普光寺沙门道智。受旨证文。三摩呬多地。非三摩呬多地。有心无心地。闻所成地。思所成地。修所成地。凡十卷。蒲州普救寺沙门行友。受旨证文。声闻地初。瑜伽种姓地尽第二瑜伽处。凡九卷。玄法寺沙门玄赜。受旨证文。声闻地第三瑜伽处尽独觉地。凡五卷。汴州真谛寺沙门玄忠。受旨证文。菩萨地。有余依地。无余依地。凡十六卷。简州福众寺沙门靖迈。受旨证文。摄决择分。凡三十卷。大总持寺沙门辩机。受旨证文。摄异门分。摄释分。凡四卷。普光寺沙门处衡。受旨证文。摄事分。十六卷。弘福寺沙门明浚。受旨证文。银青光禄大夫。行太子左庶子。高阳县开国男。臣许敬宗。奉

诏监阅。至二十二年五月十五日。绝笔。总成一百卷。佛灭度后。弥勒菩萨自睹史多天宫。降于中印度阿瑜他国。为无著菩萨之所说也。斯固法门极地。该三藏之遗文。如来后心。畅五乘之奥旨。玄宗微妙不可思议。僧徒并戒行圆深。道业贞固。欣承嘉召。得奉

高人。各罄幽心。共禀新义。随毕奏上。有感宸衷。爰降殊恩。亲裁鸿序。情超系象。理绝名言。皇太子。分耀黄离。缵基青陆。北摇传乐。仰金声而窃愧。东明御辩。瞻玉裕而多惭。九载勤经。汉储斯陋。一朝成赋。魏两韬英。既睹天文。顶戴无已。爰抽秘藻。赞叹功德。纡二圣之仙词。阐三藏之幽键。载扬佛日。式导玄津。开夏景于莲华。法流逾洁。泛春光于贝叶。道树增辉。冀夫圣藻长悬。与天地而无极真如广被。随尘沙而不穷。凡厥含灵。知所归矣

瑜伽师地论卷第一瑜伽师地论卷第二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中意地第二之二

复次此一切种子识。若般涅槃法者。一切种子皆悉具足。不般涅槃法者。便阙三种菩提种子。随所生处自体之中。余体种子皆悉随逐。是故欲界自体中。亦有色无色界一切种子。如是色界自体中。亦有欲无色界一切种子。无色界自体中。亦有欲色界一切种子。又羯罗蓝渐增长时。名之与色平等增长俱渐广大。如是增长乃至依止圆满。应知此中由地界故依止造色渐渐增广。由水界故摄持不散。由火界故成熟。坚鞕由无润故。由风界故分别肢节各安其所。又一切种子识。于生自体虽有净不净业因。然唯乐着戏论为最胜因。于生族姓色力寿量资具等果。即净不净业为最胜因。又诸凡夫于自体上。计我我所及起我慢。一切圣者观唯是苦。又处胎分中有自性受。不苦不乐依识增长。唯此性受异熟所摄。余一切受。或异熟所生。或境界缘生。又苦受乐受。或于一时从缘现起。或时不起。又种子体无始时来相续不绝。性虽无始有之。然由净不净业差别熏发。望数数取异熟果。说彼为新。若果已生。说此种子为已受果。由此道理生死流转相续不绝。乃至未般涅槃。又诸种子未与果者。或顺生受。或顺后受。虽经百千劫。从自种子。一切自体复圆满生。虽余果生要由自种。若至寿量尽边。尔时此种名已受果。所余自体种子未与果故。不名已受果。又诸种子。即于此身中应受异熟。缘差不受。顺不定受摄故。然此种子亦唯住此位。是故一一自体中。皆有一切自体种子。若于一处有染欲。即说一切处有染欲。若于一处得离欲。即说于一切处得离欲。又于诸自体中所有种子。若烦恼品所摄。名为粗重亦名随眠。若异熟品所摄。及余无记品所摄。唯名粗重不名随眠。若信等善法品所摄种子。不名粗重亦非随眠。何以故。由此法生时所依自体唯有堪能非不堪能。是故一切所依自体。粗重所随故。粗重所生故。粗重自性故。诸佛如来安立为苦。所谓由行苦故。又诸种子。乃有多种差别之名。所谓名界。名种姓。名自性。名因。名萨迦耶。名戏论。名阿赖耶。名取名苦。名萨迦耶见所依止处。名我慢所依止处。如是等类差别应知。又般涅槃时已得转依。诸净行者转舍一切染污法种子所依于一切善无记法种子。转令缘阙。转得内缘自在。又于胎中经三十八七日。此之胎藏一切支分皆悉具足。从此已后。复经四日方乃出生。如薄伽梵于入胎经广说。此说极满足者。或经九月或复过此。若唯经八月。此名圆满。非极圆满。若经七月六月。不名圆满。或复缺减。又此胎藏六处位中。由母所食。生粗津味而得资长。于羯罗蓝等微细位中。由微细津味资长应知

复次此之胎藏八位差别。何等为八。谓羯罗蓝位。遏部昙位。闭尸位。键南位。钵罗赊佉位。发毛爪位。根位形位。若已结凝箭内仍稀。名羯罗蓝。若表里如酪未至肉位。名遏部昙若已成肉仍极柔软。名闭尸。若已坚厚稍堪摩触。名为键南。即此肉抟增长支分相现。名钵罗赊佉。从此以后。发毛爪现即名此位。从此以后。眼等根生名为根位。从此以后。彼所依处分明显现。名为形位。又于胎藏中。或由先业力。或由其母不避不平等力所生随顺风故。令此胎藏或发或色。或皮及余支分变异而生。发变异生者。谓由先世所作。能感此恶不善业。及由其母多习灰盐等味若饮若食。令此胎藏发毛稀鲜。色变异生者。谓由先业因如前说。及由其母习近暖热现在缘故。令彼胎藏黑黯色生。又母习近极寒室等。令彼胎藏极白色生。又由其母多啖热食。令彼胎藏极赤色生。皮变异生者。谓由宿业因如前说。及由其母多习淫欲现在缘故。令彼胎藏或癣疥癞等恶皮而生。支分变异生者。谓由先业因如前说。及由其母多习驰走跳踯威仪及不避不平等现在缘故。令彼胎藏诸根支分缺减而生。又彼胎藏若当为女。于母左胁倚脊向腹而住。若当为男。于母右胁倚腹向脊而住。又此胎藏极成满时。其母不堪持此重胎。内风便发生大苦恼。又此胎藏业报所发生分风起。令头向下足便向上。胎衣缠裹而趣产门。其正出时胎衣遂裂。分之两腋。出产门时名正生位。生后渐次触生分触。所谓眼触乃至意触。次复随堕施设事中。所谓随学世事言说。次复耽着家室。谓长大种类故。诸根成就故。次造诸业。谓起世间工巧业处。次复受用境界。所谓色等。若可爱不可爱。受此苦乐。谓由先业因。或由现在缘。随缘所牵或往五趣或向涅槃

又诸有情。随于如是有情类中自体生时。彼有情类于此有情作四种缘。谓种子所引故。食所资养故。随逐守护故。随学造作身语业故。初谓父母精血所引。次彼生已知其所欲。方求饮食而用资长。次常随逐专志守护。不令起作非时之行及不平等行。次令习学世俗言说等事。由长大种类故。诸根成就故。此复于余此复于余。如是展转诸有情类。无始时来受苦受乐。未曾获得出苦乐法。乃至诸佛未证菩提。若从他闻音。及内正思惟。由如是故方得漏尽。如是句义甚为难悟。谓我无有若分若谁若事。我亦都非若分若谁若事。如是略说内分死生已

云何外分若坏若成。谓由诸有情所作能感成坏业故。若有能感坏业现前。尔时便有外坏缘起。由彼外分皆悉散坏。非如内分由寿量尽。何以故。由一切外分所有粗色四大。所成恒相续住。非如内分。又感成器世间业。此业决定能引劫住不增不减。若有情数时无决定。所以者何。由彼造作种种业故或过一劫。或复减少。乃至一岁。又彼坏劫由三种灾。一者火灾能坏世间。从无间狱乃至梵世。二者水灾能坏一切。乃至第二静虑。三者风灾能坏一切。乃至第三静虑。第四静虑无灾能坏。由彼诸天身与宫殿俱生俱没故。更无能坏因缘法故。复有三灾之顶。谓第二静虑第三静虑第四静虑。又此世间二十中劫坏。二十中劫坏已空。二十中劫成。二十中劫成已住。如是八十中劫。假立为一大劫数。又梵世间寿量一劫。此最后坏亦最初成。当知此劫异相建立。谓梵众天。二十中劫合为一劫。即依此劫施设寿量。梵前益天。四十中劫合为一劫。即依此劫施设寿量。若大梵天。六十中劫合为一劫。即依此劫施设寿量

云何火灾能坏世间。谓有如是时。世间有情寿量无限。从此渐减。乃至寿量经八万岁。彼复受行不善法故。寿量转减乃至十岁。彼复获得厌离之心受行善法。由此因缘寿量渐增乃至八万。如是寿量一减一增合成一中劫。又此中劫复有三种小灾出现。谓俭病刀。俭灾者。所谓人寿三十岁时。方始建立。当尔之时。精妙饮食不可复得。唯煎煮朽骨共为宴会。若遇得一粒稻麦粟稗等子。重若末尼。藏置箱箧而守护之。彼诸有情多无气势。蹎僵在地不复能起。由此饥俭有。情之类亡没殆尽。此之俭灾。经七年七月七日七夜方乃得过。彼诸有情复共聚集起下厌离。由此因缘寿不退减俭灾遂息。又若人寿二十岁时。本起厌患今乃退舍。尔时多有疫气障疠。灾横热恼相续而生。彼诸有情遇此诸病多悉殒没。如是病灾。经七月七日七夜方乃得过。彼诸有情复共聚集起中厌离。由此因缘寿量无减病灾乃息。又人寿十岁时。本起厌患今还退舍。尔时有情展转相见。各起猛利杀害之心。由此因缘随执草木及以瓦石。皆成最极锐利刀剑。更相残害死丧略尽。如是刀灾。极经七日方乃得过。尔时有情复有三种最极衰损。谓寿量衰损。依止衰损。资具衰损。寿量衰损者。所谓寿量极至十岁。依止衰损者。谓其身量极至一搩或复一握。资具衰损者。尔时有情唯以粟稗为食中第一。以发毼为衣中第一。以铁为庄严中第一。五种上味悉皆隐没。所谓酥蜜油盐等味及甘蔗变味。尔时有情展转聚集起上厌离不复退减又能弃舍损减寿量恶不善法。受行增长寿量善法。由此因缘寿量色力富乐自在皆渐增长。乃至寿量经八万岁。如是二十减二十增。合四十增减便出住劫。于最后增已。尔时那落迦有情唯没不生。如是渐渐乃至没尽。当知说名那落迦世间坏。如那落迦坏。傍生饿鬼坏亦如是。尔时人中随一有情自然法尔所得第二静虑。其余有情展转随学亦复如是。皆此没已生极净光天众同分中。当知尔时说名人世间坏。如人趣既尔。天趣亦然。当于此时五趣世间居住之处。无一有情可得。所有资具亦不可得。非唯资具不可复得。尔时天雨亦不可得。由无雨故大地所有药草丛林皆悉枯槁。复由无雨之所摄故。令此日轮热势增大。又诸有情能感坏劫业增上力故。及依六种所烧事故。复有六日轮渐次而现。彼诸日轮望旧日轮。所有热势踰前四倍。既成七已热遂增七

云何名为六所烧事。一小大沟坑。由第二日轮之所枯竭。二小河大河。由第三日轮之所枯竭。三无热大池。由第四日轮之所枯竭。四者大海。由第五日轮及第六一分之所枯竭。五苏迷卢山及以大地体坚实故。由第六一分及第七日轮之所烧然。即此火焰为风所鼓。展转炽盛极至梵世。又如是等略为三事。一水所生事。谓药草等。由初所槁。二即水事。由五所涸。三恒相续住体坚实事。由二所烧。如是世界皆悉烧已。乃至灰墨及与余影皆不可得。广说如经。从此名为器世间已坏。满足二十中劫。如是坏已复二十中劫住

云何水灾。谓过七火灾已。于第二静虑中有俱生水界起。坏器世间如水消盐。此之水界与器世间一时俱没。如是没已。复二十中劫住

云何风灾。谓七水灾过已。复七火灾。从此无间于第三静虑中有俱生风界起。坏器世间。如风干支节复能消尽。此之风界与器世间一时俱没。所以者何。现见有一由风界发。乃令其骨皆悉消尽从此坏已复二十中劫住。如是略说世间已坏

云何世间成。谓过如是二十中劫已。一切有情业增上力故世间复成。尔时最初于虚空中。第三静虑器世间成。如第三静虑。第二及初亦复如是。尔时第三灾顶有诸有情。由寿尽故业尽故福尽故。从彼没已生第三静虑。余一切处渐次亦尔。复从第二灾顶。生第二静虑。余一切处应知亦尔。复从第一灾顶。有一有情由寿等尽故从彼没已生初静虑。梵世界中为最大梵。由独一故而怀不悦便有希望。今当云何令余有情亦来生此。当发心时。诸余有情由寿等尽故。从第二静虑没已。生初静虑彼同分中。如是下三静虑。器及有情世间成已。于虚空中欲界四天宫殿渐成。当知彼诸虚空宫殿皆如化出。又诸有情从极净光天众同分没。而来生此诸宫殿中。余如前说。自此以后有大风轮。量等三千大千世界。从下而起。与彼世界作所依持。为欲安立无有宫殿诸有情类。此大风轮有二种相。谓仰周布。及傍侧布。由此持水令不散坠。次由彼业增上力故。于虚空界金藏云兴。从此降雨注风轮上。次复起风鼓水令坚。此即名为金性地轮。上堪水雨之所激注。下为风颷之所冲薄。此地成已即由彼业增上力故。空中复起诸界藏云。又从彼云降种种雨。然其雨水。乃依金性地轮而住。次复风起鼓水令坚。即由此风力所引故。诸有清净第一最胜精妙性者。成苏迷卢山。此山成已四宝为体。所谓金银颇胝琉璃。若中品性者。成七金山。谓持双山。毗那矺迦山。马耳山。善见山。朅达洛迦山。持轴山。尼民达罗山。如是诸山其峰布列。各由形状差别为名。绕苏迷卢次第而住。苏迷卢量高八万踰缮那。广亦如之。下入水际量亦复尔。又持双山等彼之半。从此次第余六金山。其量渐减各等其半。若下品性者。于苏迷卢四边七金山外。成四大洲及八中洲并轮围山。此山轮围四洲而住。量等尼民达罗之半。复成非天宫殿。此宫在苏迷卢下。依水而居。复成大雪山及无热池周围崖岸。次成最下八大那洛迦处诸大那洛迦及独一那洛迦寒那洛迦近边那洛迦。复成一分鬼傍生处。四大洲者。谓南赡部洲。东毗提诃洲。西瞿陀尼洲。北拘卢洲。其赡部洲形如车箱。毗提诃洲形如半月。瞿陀尼洲其形圆满。北拘卢洲其形四方。赡部洲量。六千五百踰缮那。毗提诃洲量。七千踰缮那。瞿陀尼洲量。七千五百踰缮那。拘卢洲量。八千踰缮那。又七金山其间有水具八支德。名为内海。复成诸龙宫。有八大龙并经劫住。谓持地龙王。欢喜近喜龙王。马骡龙王。目支邻陀龙王。意猛龙王。持国龙王。大黑龙王。黳罗叶龙王。是诸龙王由帝释力数与非天共相战诤。其诸龙众类有四种。谓卵生胎生湿生化生。妙翅鸟中四类亦尔。复有余水在内海外故名外海。又依苏迷卢根有四重级。从苏迷卢初级傍出一万六千踰缮那量。即从此量半半渐减。如其次第余级应知有坚手神住最初级。血手神住第二级。常醉神住第三级。持鬘神住第四级。苏迷卢顶四隅之上有四大峰。各高五百踰缮那量。有诸药叉。谓金刚手止住其中

又持双山于其四面有四王都。东南西北随其次第。谓持国增长丑目多闻。四大天王之所居止。诸余金山是彼四王村邑部落。又近雪山有大金崖名非天胁。其量纵广五十踰缮那。善住龙王常所居镇。又天帝释时来游幸。此中有树名曰善住。多罗树行七重围绕。复有大池名漫陀吉尼。五百小池以为眷属。善住大龙与五百牝象前后围绕游戏其池。随欲变现。便入此池采莲花根以供所食。即于此侧有无热大池。其量深广各五十踰缮那。微细金沙遍布其底。八支德水弥满其中。形色殊妙端严喜见。从此派流为四大河。一名殑伽。二名信度。三名私多。四名缚刍

复次于苏迷卢顶处中建立帝释天宫。纵广十千踰缮那量。所余之处是彼诸天村邑聚落。其山四面对四大洲。四宝所成。谓对赡部洲琉璃为面。对毗提诃白银为面。对瞿陀尼黄金为面。对拘卢洲颇胝为面。又赡部洲循其边际有轮王路真金所成。如四大王天。有情膝量没住大海。若轮王出世。如彼膝量海水减焉。又无热池南有一大树。名为赡部。是故此洲从彼得名。次于此北。有设拉末梨大树丛林。四生种类妙翅诸鸟栖集其中。此四大洲各二中洲以为眷属。复有一洲罗刹所住

如是器世间成已。有诸有情。从极净光天众同分没来生此中。余如前说。此皆由彼感劫初业。此业第一最胜微妙。欲界所摄。唯于此时此业感果。非于余时。尔时有情名劫初者。又彼有色从意所生。如是一切如经广说。彼于尔时未有家宅及诸聚落。一切大地面皆平正。自此以后由诸有情福业力故有地味生。如是渐次地饼林藤。不种粳稻自然出现。无糠无[禾*乞]。次有粳稻。有[禾*乞]有糠。次复处处粳稻丛生。于是有情方现摄受。次由受用味等资缘。有情之类恶色便起光明遂灭。其多食者恶色逾增身极沉重。此诸有情互相轻毁恶法现行。由此因缘所有味等渐没于地。如经广说。复从此缘诸有情类更相顾眄便起爱染。次由能感男女业故。一分有情男根生起。一分有情女根生起。递相陵犯起诸邪行。遂为他人之所诃呰。方造室宅以自隐蔽。复由摄受粳稻因故。遂于其地复起摄受。由此缘已更相争夺。不与取法从此而生。即由此缘立司契者。彼最初王名大等意。如是便有刹帝利众婆罗门众吠舍众戍陀罗众。出现世间。渐次因缘如经广说。又彼依止光明既灭。世间便有大黑闇生。日月星宿渐渐而起。其日轮量五十一踰缮那。当知月轮其量减一。日轮以火颇胝所成。月轮以水颇胝所成。此二轮中。月轮行速及与不定。又彼日轮恒于二洲俱时作明。复于二洲俱时作闇。谓于一日中。于一日出于一夜半于一日没。又一切所有日月星宿。历苏迷卢处半。而行。与持双山高下量等。又复日行时有远近。若远苏迷卢立为寒分。若近苏迷卢立为热分。即由此故没有迟速。又此月轮于上稍欹便见半月。由彼余分障其近分遂令不见。如如渐侧。如是如是渐现圆满。若于黑分如如渐低。如是如是渐现亏减。由大海中有鱼鳖等影现月轮。故于其内有黑相现。诸星宿中其量大者十八拘卢舍量。中者十拘卢舍量。最小者四拘卢舍量

复次于世间四姓生已。方乃发起顺爱不爱五趣受业。从此以后随一有情。由感杂染增上业故。生那洛迦中作静息王。从此无间有那洛迦卒。犹如化生。及种种苦具谓铜铁等。那洛迦火起然后随业有情于此受生。及生余趣

如是百拘胝四大洲。百拘胝苏迷卢。百拘胝六欲天。百拘胝梵世间。三千大千世界俱成俱坏。即此世界有其三种。一小千界。谓千日月乃至梵世总摄为一。二中千界。谓千小千。三大千界。谓千中千。合此名为三千大千世界。如是四方上下无边无际三千世界正坏正成。犹如天雨注如车轴无间无断。其水连注堕诸方分。如是世界遍诸方分。无边无际正坏正成。即此三千大千世界名一佛土。如来于中现成正觉。于无边世界施作佛事。如是安立。世界成已于中五趣可得。谓那洛迦傍生饿鬼人天及四生可得。谓卵生胎生湿生化生。复有六种依持。复有十种时分。谓时年月半月日夜刹那怛刹那腊缚目呼剌多。复有七摄受事。复有十种身资具。复有十种受欲者。此如中阿笈摩说。复有八数随行。复有八世法。谓得不得若誉若毁称讥苦乐。复有三品。谓怨亲中。复有三种世事。复有三种语言。复有二十二种发愤。复有六十二种有情之类。又有八位。复有四种入胎。复有四种威仪。复有六种活命。复有六种守护。复有七种苦。复有七种慢。复有七种憍。复有四种言说。复有众多言说句

云何那落迦趣。谓种果所摄。那洛迦诸蕴。及顺那洛迦受业。如那洛迦趣。如是傍生饿鬼人天。如其所应尽当知。云何卵生。谓诸有情破[穀-禾+卵]而出。彼复云何。如鹅雁孔雀鹦鹉舍利鸟等。云何胎生。谓诸有情胎所缠裹。剖胎而出。彼复云何。如象马牛驴等。云何湿生。谓诸有情随因一种湿气而生。彼复云何。如虫蝎飞蛾等。云何化生。谓诸有情业增上故。具足六处而生。或复不具。彼复云何。如天那洛迦全。及人鬼傍生一分

云何六种依持。一建立依持。谓最下风轮及水轮地轮。令诸有情不坠下故起。是名依持。二藏覆依持。谓屋宇等。为诸有情离流漏等所损故起。是名依持。彼屋宇等略有三种。或由造作。或不由造作。或宫殿化起。三丰稔依持。为诸有情段食故起。是名依持。四安隐依持。为诸有情离刀仗等所害故起。是名依持。五日月依持。为诸有情见色故起。是名依持。六食依持。谓四食。一段食。二触食。三意思食。四识食。为诸有情任持身故起。是名依持。云何七种摄受事。一自父母事。二妻子事。三奴婢仆使事。四朋友官僚兄弟眷属事。五田宅邸肆事。六福业事。及方便作业事。七库藏事。云何十种身资具。一食二饮。三乘四衣。五庄严具。六歌笑舞乐。七香鬘涂末。八什物之具。九照明。十男女受行

云何八数随行。谓诸世间数数随所行事。一蔽覆事。二莹饰身事。三威仪易夺事。四饮食事。五睡眠事。六交会事。七属彼勤劬事。八属彼言说事

云何三种世事。一语言谈论更相庆慰事。二嫁娶宾主更相饮啖事。三于起作种种事中更相营助事

云何三种语言。谓有法语言。无法语言。及余语言。有法语言者。谓宣说厌舍离诸缠盖趣可爱乐等。广说如经。无法语言者。谓染污心说饮食等。余语言者。谓无记心所起言说

云何二十二种发愤。一伪斗。二伪称。三伪函。四邪业方便。五拒斗。六轻调。七违反。八诤讼。九骂詈。十忿怒。十一诃责。十二迫胁。十三捶打。十四杀害。十五系缚。十六禁闭。十七割截。十八驱摈。十九谄曲。二十矫诳。二十一陷逗。二十二妄语

云何六十二种有情之类。一那洛迦。二傍生。三鬼。四天。五人。六刹帝利七婆罗门。八吠舍。九戍陀罗。十女。十一男。十二非男非女。十三劣。十四中。十五妙。十六在家。十七出家。十八苦行。十九非苦行。二十律仪。二十一不律仪。二十二非律仪非不律仪。二十三离欲。二十四未离欲。二十五邪性聚定。二十六正性聚定。二十七不定聚定。二十八苾刍。二十九苾刍尼。三十正学。三十一勤策男。三十二勤策女。三十三近事男。三十四近事女。三十五习断者。三十六习诵者。三十七净施人。三十八宿长。三十九中年。四十少年。四十一轨范师。四十二亲教师。四十三共住弟子及近住弟子。四十四宾客。四十五营僧事者。四十六贪利养恭敬者。四十七厌舍者。四十八多闻者。四十九大福智者。五十法随法行者。五十一持经者。五十二持律者。五十三持论者。五十四异生。五十五见谛。五十六有学。五十七无学。五十八声闻。五十九独觉。六十菩萨。六十一如来。六十二转轮王。此转轮王复有四种。或王一洲。或二三四。王一洲者有铁轮应。王二洲者有铜轮应。王三洲者有银轮应。王四洲者有金轮应。云何八位。谓处胎位。出生位。婴孩位。童子位。少年位。中年位。老年位。耄熟位。处胎位者。谓羯罗蓝等。出生位者。谓从此后乃至耄熟。婴孩位者。谓乃至未能游行嬉戏。童子位者。谓能为彼事。少年位者。谓能受用欲尘乃至三十。中年位者。谓从此位乃至五十。老年位者。谓从此位乃至七十。从此以上名耄熟位。云何四种入胎。一正知而入。不正知住出。二正知入住。不正知而出。三俱能正知。四俱不正知。初谓轮王。二谓独觉。三谓菩萨。四谓所余有情

云何六种活命。一营农。二商贾。三牧牛。四事王。五习学书算计数及印。六习学所余工巧业处

云何六种守护。谓象军马军车军步军藏力友力

云何七种苦。谓生苦老苦。病苦死苦。怨憎会苦。爱别离苦。求不得苦

云何七种慢。谓慢过慢。慢过慢我慢。增上慢卑慢邪慢

云何七种憍。谓无病憍。少年憍。长寿憍。族性憍。色力憍。富贵憍。多闻憍

云何四种言说。谓依见闻觉知所有言说。依见言说者谓依眼故现见外色。由此因缘为他宣说。是名依见言说。依闻言说者。谓从他闻。由此因缘为他宣说。是名依闻言说。依觉言说者。谓不见不闻。但自思惟称量观察。由此因缘为他宣说。是名依觉言说。依知言说者。谓各别于内所受所证所触所得。由此因缘为他宣说。是名依知言说

云何众多言说句。谓即此亦名释词句。亦名戏论句。亦名摄义句。如是等类众多差别。又诸字母能摄诸义。当知亦名众多言说句。彼复云何。所谓地根境法。补特伽罗自性差别。作用自他有无。问答取与。正性邪性句。又有听制功德过失得不得毁誉苦乐称讥坚妙智退沈量助伴示现教导赞励庆慰句

又有七言论句。此即七例句。谓补卢沙。补卢衫。补卢崽拏。补卢沙耶。补卢沙[多*頁]。补卢杀娑。补卢铩。如是等。复有施设教敕标相静息表了轨则安立积集决定配属惊骇初中后句。族姓等。立宗言说成办受用寻求守护羞耻怜愍堪忍怖畏简择句。又有父母妻子等一切所摄资具。应当广说。及生老等乃至所求不得。愁叹少年无病长寿爱会怨离所欲随应若不随应。往来顾视若屈若申。行住坐卧警悟语默解睡解劳句。又有饮啖咀味。串习不串习。放逸不放逸。广略增减。寻伺烦恼随烦恼。戏论离戏论。力劣所成能成。流转定异相应势速。次第时方数。和合不和合。相似不相似句。又有杂糅共有现见不现见隐显句。又有能作所作法律世事资产真妄利益非利益骨体疑虑惊怪句。又有怯弱无畏显了不显了杀害系缚禁闭割截驱摈句。又有骂詈忿怒捶打迫胁诃责烧烂燥暑。摧伏浑浊圣教随逐比度句

瑜伽师地论卷第二瑜伽师地论卷第三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中意地第二之三

复次即前所说自性。乃至业等五事当知。皆由三处所摄。谓由色聚故。心心所品故。及无为故。除余假有法。今当先说色聚诸法。问一切法生。皆从自种而起。云何说诸大种能生所造色耶。云何造色依彼。彼所建立。彼所任持。彼所长养耶。答由一切内外大种又所造色种子皆悉依附内相续心。乃至诸大种子未生诸大以来。造色种子终不能生。造色要由彼生。造色方从自种子生。是故说彼能生造色。要由彼生为前导故。由此道理。说诸大种为彼生因。云何造色依于彼耶。由造色生已不离大种处而转故。云何彼所建立。由大种损益。彼同安危故。云何彼所任持。由随大种等量不坏故。云何彼所长养。由因饮食睡眠修习梵行三摩地等依彼造色倍复增广。故说大种为彼养因。如是诸大种望所造色。有五种作用应知

复次于色聚中。曾无极微生。若从自种生时唯聚集生。或细或中或大。又非极微集成色聚。但由觉慧分折诸色极量边际。分别假立以为极微。又色聚亦有方分。极微亦有方分。然色聚有分非极微。何以故。由极微即是分。此是聚色所有非极微。复有余极微。是故极微非有分。又不相离有二种。一同处不相离。谓大种极微与色香味触等。于无根处有离根者。于有根处有有根者。是名同处不相离。二和杂不相离。谓即此大种极微与余聚集能造所造色处俱故。是名和杂不相离。又此遍满聚色。应知如种种物石磨为末以水和合互不相离。非如胡麻绿豆粟稗等聚。又一切所造色。皆即依止大种处。不过大种处量乃至大种所据处所。诸所造色还即据此。由此因缘说所造色依于大种。即以此义说诸大种名为大种。由此大种其性大故为种生故

复次于诸色聚中。略有十四种事。谓地水火风。色声香味触。及眼等五根。除唯意所行色。一切色聚。有色诸根所摄者。有一切。如所说事界。如有色诸根所摄聚。如是有色诸根所依大种所摄聚亦尔。所余色聚除有色诸根唯有余界。又约相摄有十四事。即由相摄施设事极微。若约界摄。随于此聚有尔所界。即说此聚尔所事摄。若约不相离摄。或内或外所有诸聚。随于此聚中。乃至有尔所法相可得。即说此聚尔所事摄应知。所以者何。或有聚中唯一大种可得。如石末尼真珠琉璃珂贝璧玉珊瑚等中。或池沼沟渠江河等中。或火焰灯烛等中。或四方风轮有尘无尘风等中。或有聚中二大种可得。如雪湿树叶花果等中。或热末尼等中。或有聚中三大种可得。如即热树等中。或动摇中。或有聚中四大种可得。谓于内色聚中。如薄伽梵说。于各别内身。若发毛等乃至粪秽是内地界。若小便等是内水界。若于身中所有暖等是内火界。若上行等风是内风界。如是若于此聚。彼相可得说彼相为有。若不可得说彼相为无。复次声于一切色聚中界故说有。相即不定。由现在方便生故。风有二种。谓恒相续又不恒相续。恒相续者。谓于彼彼聚有恒旋转风。不恒相续者。谓旋风及空行风。又闇色明色。说名空界及孔隙。又诸闇色恒相续者。谓世界中间。不恒相续者。谓于余处加是。明色恒相续者。谓于自然光明天中。不恒相续者。谓于余处。又明闇色。谓于显色增聚应知。又由依止色聚种子功能故若遇相似缘时。或小聚无间大聚生。或大聚无间小聚生。由此因缘施设诸聚有增有减。如经言。若坚坚摄近摄非近摄执受乃至广说。坚云何谓地。坚摄云何谓彼种子。又坚者即彼界坚。摄者谓发毛等或土块等。近摄云何谓有执受。执受云何谓内所摄。非近摄云何谓无执受。无执受云何谓外所摄。又心心所。所执种子名近摄名执受。与此相违名非近摄名非执受。又随逐自身故名近摄。执受如前说。如是水等界如理应知。又于一切色聚中。一切时具有一切大种界。如世间现见干薪等物钻即火生。击石等亦尔。又铜铁金银等极火所烧即销为水。从月爱珠水便流出。又得神通者。由心胜解力。变大地等成金银等。又色聚有三种流转。一者长养。二者等流。三者异熟生。长养有二种。一处遍满长养。二相增盛长养。等流有四种。一长养等流。二异熟等流。三变异等流。四自性等流。异熟生有二种。一异熟体生名异熟生。二从异熟生名异熟生。又诸色聚略说依六处转。谓建立处。覆藏处。资具处。根所依处。根处。三摩地所行处

复次于心心所品中。有心可得及五十三心所可得。谓作意等。乃至寻伺为后边如前说。问如是诸心所。几依一切处。心生一切地一切时一切耶。答五谓作意等。思为后边。几依一切处。心生一切地非一切时非一切耶。答亦五。谓欲等。慧为后边。几唯依善非一切处。心生然一切地非一切时非一切耶。答谓信等。不害为后边。几唯依染污非一切处。心生非一切地非一切时非一切耶。答谓贪等。不正知为后边。几依一切处。心生非一切地非一切时非一切耶。答谓恶作等。伺为后边。复次根不坏。境界现前能生作意正起。尔时从彼识乃得生。云何根不坏。谓有二种因。一不灭坏故。二不羸劣故。云何境界现前。谓或由所依处故。或由自性故。或由方故。或由时故。或由显了不显了故。或由全分及一分故。若四种障所不障碍亦非极远。谓覆蔽障。隐没障。映夺障。幻惑障。极远有二种。谓处所极远。损减极远。云何能生作意正起。由四因故。一由欲力。二由念力。三由境界力。四由数习力。云何由欲力。谓若于是处心有爱着。心则于彼多作意生。云何由念力。谓若于彼已善取其相已极作想。心则于彼多作意生。云何由境界力。谓若彼境界或极广大。或极可意正现在前。心则于彼多作意生。云何由数习力。若于彼境界。已极串习已极谙悉。心即于彼多作意生。若异此者。应于一所缘境唯一作意一切时生。又非五识身有二刹那相随俱生。亦无展转无间更互而生。又一刹那五识身生已。从此无间必意识生。从此无间或时散乱或耳识生。或五识身中随一识生。若不散乱。必定意识中第二决定心生。由此寻求决定二意识故。分别境界。又由二种因故。或染污或善法生。谓分别故。又先所引故。意识中所有由二种因。在五识者唯由先所引故。所以者何。由染污及善意识力所引故。从此无间于眼等识中。染污及善法生。不由分别。彼无分别故。由此道理说眼等识随意识转。如经言。起一心若众多心。云何安立此一心耶。谓世俗言说一心刹那非生起刹那。云何世俗言说一心刹那。谓一处为依止。于一境界事。有尔所了别生。总尔所时名一心刹那。又相似相续亦说名一。与第二念极相似故。又意识任运散乱缘不串习境时。无欲等生。尔时意识名率尔堕心。唯缘过去境。五识无间所生意识。或寻求或决定。唯应说缘现在境。若此即缘彼境生。又识能了别事之总相。即此所未了别所了境相。能了别者说名作意。即此可意不可意俱相违相。由触了别。即此摄受损害俱相违相。由受了别。即此言说因相。由想了别。即此邪正俱相违行因相。由思了别。是故说彼作意等思为后边。名心所有法遍一切处一切地一切时一切生。作意云何谓心回转。触云何谓三和合。受云何谓领纳。想云何谓了像。思云何谓心造作。欲云何谓于可乐事。随彼彼行欲有所作性。胜解云何谓于决定事。随彼彼行印可随顺性。念云何谓于串习事。随彼彼行明了记忆性。三摩地云何谓于所观察事。随彼彼行审虑所依心一境性。慧云何谓即于所观察事。随彼彼行简择诸法性。或由如理所引。或由不如理所引。或由非如理非不如理所引

又作意作何业。谓引心为业。触作何业。谓受想思所依为业。受作何业。谓爱生所依为业。想作何业。谓于所缘令心发起种种言说为业。思作何业。谓发起寻伺身语业等为业。欲作何业。谓发勤为业。胜解作何业。谓于所缘任持功德过失为业。念作何业。谓于久远所思所作所说忆念为业。三摩地作何业。谓智所依为业。慧作何业。谓於戏论所行染污清净随顺推求为业

云何建立三世。谓诸种子不离法故。如法建立。又由与果未与果故。若诸果法。若已灭相是过去。有因未生相是未来。已生未灭相是现在

云何建立生老住无常谓于一切处识相续中一切种子相续俱行建立。由有缘力故。先未相续生。法今最初生。是名生有为相。即此变异性。名老有为相。此复二种。一异性变异性。二变性变异性。由有相似生故。立异性变异性。由有不相似生故。立变性变异性。即已生时唯生。刹那随转故名住有为相。生刹那后。刹那不住故名无常有为相。如是即约诸法分位差别。建立四相

又有四缘。一因缘。二等无间缘。三所缘缘。四增上缘。因缘者。谓种子。等无间缘者。谓若此识无间诸识决定生。此是彼等无间缘。所缘缘者。谓诸心心所所缘境界。增上缘者。谓除种子余所依。如眼及助伴法望眼识。所余识亦尔

又善不善性。能取爱非爱果。如是等类名增上缘。又由种子故建立因缘。由自性故立等无间缘。由所缘境故立所缘缘。由所依及助伴等故立增上缘。如经言。诸因诸缘能生识者。彼即此四因缘。一种亦因亦缘。余唯是缘。

又如经言。善不善无记者。彼差别云何。谓诸善法或立一种。由无罪义故。或立二种。谓生得善。及方便喜或立三种。谓自性善。相应善。等起善。或立四种。谓顺福分善。顺解脱分善。顺决择分善。及无漏善。或立五种。谓施性善。戒性善。修性善。爱果善。离系果善。或立六种。谓善色受想行识及择灭。或立七种。谓念住所摄善。正勤所摄善。神足所摄善。根所摄善。力所摄善。觉支所摄善。道支所摄善。或立八种。谓起迎合掌问讯礼敬业所摄善。赞彼妙说称扬实德所摄善。供承病者所摄善。敬事师长所摄善。随善所摄善。劝请所摄善。回向所摄善。修无量所摄善。或立九种。谓方便无间解脱胜进道所摄善。及软中上世出世道所摄善。或立十种。谓有依善。无依善。闻所生善。思所生善。律仪所摄善。非律仪非不律仪所摄善。根本眷属所摄善。声闻乘所摄善。独觉乘所摄善。大乘所摄善。又立十种。谓欲界系善。初二三四静虑系善。空无边处识无边处。无所有处非想非非想处系善。无漏所摄善。又有十种。谓十善业道。又有十种。谓无学正见乃至正解脱正智。又有十种。谓能感八福生及转轮王善。及趣不动善。如是等类诸善差别。略说善有二种义。谓取爱果义善。了知事及彼果义。不善法者。谓与善法相违。及能为障碍。由能取不爱果故。及不正了知事故。无记法者略有四种。谓异熟生。及一分威仪路。工巧处及变化。若诸工巧。但为戏乐不为活命。非习业想非为简择。此工巧处业是染污余是无记。如工巧处。威仪路亦尔。变化有二种。谓善及无记。

复次眼有一种。谓能见色。或立二种。谓长养眼。异熟生眼。或立三种。谓肉眼天眼慧眼。或立四种。谓有瞚眼。无瞚眼。恒相续眼。不恒相续眼。恒相续者。谓色界眼。或立五种。谓五趣所摄眼。或立六种。谓自相续眼。他相续眼。端严眼。丑陋眼。有垢眼。无垢眼。或立七种。谓有识眼。无识眼。强眼弱眼。善识所依眼。不善识所依眼。无记识所依眼。或立八种。谓依处眼。变化眼。善业异熟生眼。不善业异熟生眼。食所长养眼。睡眠长养眼。梵行长养眼。定所长养眼。或立九种。谓已得眼。未得眼。曾得眼。未曾得眼。得已失眼。应断眼。不应断眼。已断眼。非已断眼。或立十种者无。或立十一种。谓过去眼。未来眼。现在眼。内眼外眼。粗眼细眼。劣眼妙眼。远眼近眼。如眼如是。耳等亦尔。是中差别者。谓增三增四。三种耳者。谓肉所缠耳。天耳。审谛耳。四种耳者。谓恒相续耳。不恒相续耳。高听耳。非高听耳。三种鼻舌者。谓光净。不光净。及被损。四种鼻舌者。谓恒相续。不恒相续。有识无识。三种身者。谓滓秽处。非滓秽处。及一切遍诸根所随逐故。四种身者。谓恒相续。不恒相续。有自然光。无自然光

或立一种意。谓由识法义故。或立二种。谓堕施设意。不堕施设意。初谓了别名言者意。后谓婴儿意。又初谓世间意。后谓出世间意。或立三种。谓心意识。或立四种。谓善不善。有覆无记。无覆无记。或立五种谓五位差别。一因位。二果位。三乐位。四苦位。五不苦不乐位。或立六种。谓六识身。或立七种。谓依七识住。或立八种。谓增语触。相应有对触。相应依。耽嗜依。出离有爱味。无爱味。世间。出世间。或立九种。谓依九有情居。或立十种者无。或立十一种如前说。或立十二种。即十二心。谓欲界善心不善心。有覆无记心。无覆无记心。色界有三心除不善。无色界亦尔。出世间心有二种。谓学及无学

或立一种色。谓由眼所行义故。或立二种谓内色外色。或立三种。谓显色形色表色。或立四种。谓有依光明色。无依光明色。正不正光明色。积集住色。或立五种。谓由五趣差别故。或立六种。谓建立所摄色。覆藏所摄色。境界所摄色。有情数色。非有情数色。有见有对色。或立七种。谓由七种摄受事差别故。或立八种。谓依八世杂说。一地分杂色。二山杂色。三园林池沼等杂色。四宫室杂色。五业处杂色。六彩画杂色。七锻业杂色。八资具杂色。或立九种。谓若过去。若未来。若现在。若粗若细。若劣若妙。若远若近。或立十种。谓十种资具。或立一种声。谓由耳所行义故。或立二种。谓了义声。不了义声。或立三种。谓因受大种声。因不受大种声。因俱大种声。或立四种。谓善不善。有覆无记。无覆无记。或立五种。谓由五趣差别故。或立六种。一受持读诵声。二请问声。三说法声。四论议决择声。五展转言教若犯若出声。六喧杂声。或立七种。谓男声女声。下声中声上声。鸟兽等声。风林丛声。或立八种。谓四圣言声。四非圣言声。四非圣言者。一不见言见。见言不见。非圣言。二不闻言闻。闻言不闻。非圣言。三不觉言觉。觉言不觉。非圣言。四不知言知。知言不知。非圣言。四圣言者。一见言见不见言不见圣言。二闻言闻不闻言不闻圣言。三觉言觉不觉言不觉圣言。四知言知不知言不知圣言。又有八种。谓四善语业道。四不善语业道。或立九种。谓过去未来现在。乃至若远若近。或立十种。谓五乐所摄声。此复云何。一舞俱行声。二歌俱行声。三弦管俱行声。四女俱行声。五男俱行声。六螺俱行声。七腰等鼓俱行声。八冈等鼓俱行声。九都昙等鼓俱行声。十俳叫声

或立一种香。谓由鼻所行义故。或立二种。谓内及外。或立三种。谓可意不可意及处中香。或立四种。谓四大香。一沉香。二窣堵鲁迦香。三龙脑香。四麝香。或立五种。谓根香茎香叶香花香果香。或立六种。谓食香饮香衣香庄严具香乘香宫室香。或立七种。谓皮香叶香素泣谜罗香栴檀香三辛香熏香末香。或立八种。谓俱生香。非俱生香。恒续香。非恒续香。杂香纯香。猛香非猛香。或立九种。谓过去未来现在等如前说。或立十种。谓女香男香。一指香二指香。唾香洟香。脂髓脓血香肉香。杂糅香淤埿香

或立一种味。谓由舌所行义故。或立二种。谓内及外。或立三种。谓可意等如前说。或立四种。谓大麦味。粳稻味。小麦味。余下谷味。或立五种。谓酒饮味。非酒饮味。蔬菜味。林果味。所食味。或立六种。谓甘苦等。或立七种。谓酥味油味蜜味甘蔗变味乳酪味盐味肉味。或立八种。如香说。或立九种。亦如香说。或立十种。谓可嚼味。可啖味。可尝味。可饮味。可吮味。可爆干味。充足味。休愈味。荡涤味。常习味。后五谓诸药味

或立一种触。谓由身所行义故。或立二种。如香说。或立三种。谓可意等。或立四种。谓摩触搦触打触揉触。或立五种。谓五趣差别。又有五种。谓蚊虻风日蛇蝎等触。或立六种。谓苦乐不苦不乐。俱生所治摄能治摄。或立七种。谓坚鞭触。流湿触。暖触动触。跳堕触。摩按触。身变异触。谓湿滑等。或立八种。谓手触触。块触触。杖触触。刀触触。冷触触。暖触触。饥触触。渴触触。或立九种。如香说。或立十种。谓食触饮触。乘触衣触。庄严具触。床坐触。机橙台枕及方座触。女触男触。彼二相事受用触

略说法界。若假若实有八十七法。彼复云何。谓心所有法有五十三。始从作意。乃至寻伺为后边。法处所摄色有二种。谓律仪不律仪所摄色。三摩地所行色。不相应行有二十四种。谓得。无想定。灭尽定。无想异熟。命根。众同分。异生性。生老住无常。名身句身文身。流转。定异相应。势速。次第。时方数。和合不和合。无为有八事。谓虚空。非择灭。择灭。善不善。无记法。真如不动想受灭。如是无为广八略六。若六若八平等平等

复次法界或立一种。谓由意所行义。或立二种。谓假所摄法。非假所摄法。或立三种。谓有色无色及有为无为。或立四种。谓有色假所摄法。无色心所有所摄法。无色不相应假所摄法。无色无为假非假所摄法。或立五种。谓色心所法。心不相应行。善无记无为。或立六种。谓受想。相应行。不相应行。色无为。或立七种。谓受想思。染污不染污。色无为。或立八种。谓善不善无记受想行色无为。或立九种。谓由过去未来等差别。或立十种。谓由十种义。一随逐生义。二领所缘义。三取所缘相义。四于所缘造作义。五即彼诸法分位差别义。六无障碍义。七常离系义。八常非离系义。九常无颠倒义。十苦乐离系义。非受离系义及受离系义如是。若内若外六处所摄法。差别分别有六百六十

复次屡观众色。观而复舍。故名为眼。数数于此声至能闻。故名为耳。数由此故能嗅诸香。故名为鼻。能除饥羸数发言论表彰呼召。故名为舌诸根所随周遍积聚。故名为身。愚夫长夜莹饰藏护。执为己有计为我所。我及我所又诸世间。依此假立种种名想。谓之有情。人与命者生者意生及儒童等。故名为意。数可示现在其方所质量可增。故名为色。数宣数谢随增异论。故名为声。离质潜形屡随风转。故名为香。可以舌尝屡招疾苦。故名为味。数可为身之所证得。故名为触遍能任持唯意境性故名为法。如是等类诸法差别应知。此中重说嗢拖

南曰

  自性及所依　　所缘助伴业
  由此五种门　　诸心差别转

此中显由五法六识身差别转。谓自性故。所依故。所缘故。助伴故。业故

又复应知蕴善巧摄。界善巧摄。处善巧摄。缘起善巧摄。处非处善巧摄。根善巧摄。

又复应知诸佛语言九事所摄。云何九事。一有情事。二受用事。三生起事。四安住事。五染净事。六差别事。七说者事。八所说事。九众会事。有情事者谓五取蕴。受用事者谓十二处。生起事者谓十二分事。缘起及缘生。安住事者谓四食。染净事者谓四圣谛。差别事者谓无量界。说者事者谓佛及彼弟子。所说事者谓四念住等菩提分法。众会事者所谓八众。一刹帝利众。二婆罗门众。三长者众。四沙门众。五四大天王众。六三十三天众。七焰摩天众。八梵天众。又嗢拖南曰

  色聚相应品　　世相及与缘
  善等差别门　　巧便事为后

瑜伽师地论卷第三瑜伽师地论卷第四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中有寻有伺等三地之一

已说意地。云何有寻有伺地。云何无寻唯伺地。云何无寻无伺地。总嗢拖南曰

  界相如理不如理　　杂染等起最为后

如是三地。略以五门施设建立。一界施设建立。二相施设建立。三如理作意施设建立。四不如理作意施设建立。五杂染等起施设建立。

云何界施设建立。别嗢拖南曰

  数处量寿受用生　　自体因缘果分别

当知界建立由八种相。一数建立。二处建立。三有情量建立。四有情寿建立。五有情受用建立。六生建立。七自体建立。八因缘果建立。

云何数建立。略有三界。谓欲界色界无色界。如是三种名堕摄界。非堕摄界者。谓方便。并萨迦耶。灭及无戏论。无漏界。此中欲界及色界初静虑。除静虑中间若定若生。名有寻有伺地。即静虑中间若定若生。名无寻唯伺地随一有情由修此故。得为大梵。从第二静虑。余有色界及无色界。全名无寻无伺地。此中由离寻伺欲道理。故说名无寻无伺地。不由不现行故。所以者何。未离欲界欲者。由教导作意差别故。于一时间亦有无寻无伺意现行。已离寻伺欲者。亦有寻伺现行。如出彼定及生彼者。若无漏界有为定所摄初静虑。亦名有寻有伺地。依寻伺处法。缘真如为境入此定故。不由分别现行故。余如前说。

处所建立者。于欲界中有三十六处。谓八大那落迦。何等为八。一等活。二黑绳。三众合。四号叫。五大号叫。六烧热。七极烧热。八无间。此诸大那落迦处。广十千踰缮那。此外复有八寒那落迦处。何等为八。一疱那落迦。二疱裂那落迦。三喝哳詀那落迦。四郝郝凡那落迦。五虎虎凡那落迦。六青莲那落迦。七红莲那落迦。八大红莲那落迦。从此下三万二千踰缮那。至等活那落迦。从此复隔四千踰缮那。有余那落迦。如等活大那落迦处。初寒那落迦处亦尔。从此复隔二千踰缮那。有余那落迦应知。又有饿鬼处所。又有非天处所。傍生即与人天同处。故不别建立。复有四大洲如前说。复有八中洲。又欲界天有六处。一四大王众天。二三十三天。三时分天。四知足天。五乐化天。六他化自在天。复有摩罗天宫。即他化自在天摄。然处所高胜。复有独一那落迦近边那落迦。即大那落迦及寒那落迦。以近边故不别立处。又于人中亦有一分独一那落迦可得。如尊者取菉豆子说。我见诸有情。烧然。极烧然。遍极烧然总一烧然。聚如是等三十六处。总名欲界

复次色界有十八处。谓梵众天梵前益天大梵天。此三由软中上品。熏修初静虑故。少光天无量光天极净光天。此三由软中上品。熏修第二静虑故。少净天无量净天遍净天。此三由软中上品。熏修第三静虑故。无云天福生天广果天。此三由软中上品。熏修第四静虑故。无想天即广果摄无别处所。复有诸圣住止不共五净宫地。谓无烦无热善现善见。及色究竟由软中上。上胜上极品。杂熏修第四静虑故复有超过净宫大自在住处。有十地菩萨。由极熏修第十地故得生其中

复次无色界有四处所或无处所。有情量建立者。谓赡部洲人身量不定。或时高大或时卑小。然随自肘三肘半量。东毗提诃身量决定。亦随自肘三肘半量。身又高大。如东毗提诃。如是西瞿陀尼北拘卢洲身量亦尔。转复高大。四大王众天身量。如拘卢舍四分之一。三十三天身量复增一足。帝释身量半拘卢舍。时分天身量亦半拘卢舍。此上一切如欲界天身量。当知渐渐各增一足。梵众天身量半踰缮那。梵前益天身量一踰缮那。大梵天身量一踰缮那半。少光天身量二踰缮那。此上一切余天身量各渐倍增。除无云天。应知彼天减三踰缮那。又大那落迦身量不定。若作及增长极重恶不善业者。彼感身形其量广大。余则不尔。如大那落迦。如是寒那落迦独一那落迦近边那落迦傍生饿鬼亦尔诸非天身量大小如三十三天。当知无色界无有色故无有身量。

寿建立者。谓赡部洲人。寿量不定。彼人以三十日夜为一月。十二月为一岁。或于一时寿无量岁。或于一时寿八万岁。或于一时寿量渐减乃至十岁。东毗提诃人寿量决定二百五十岁。西瞿陀尼人寿量决定五百岁。北拘卢洲人寿量决定千岁。又人间五十岁是四大王众天一日一夜。以此日夜三十日夜为一月。十二月为一岁。彼诸天众寿量五百岁。人间百岁是三十三天一日一夜。以此日夜如前说。彼诸天众寿量千岁。如是所余乃至他化自在天日夜及寿量。各增前一倍。又四大王众天满足寿量。是等活大那落迦一日一夜。即以此三十日夜为一月。十二月为一岁。彼大那落迦寿五百岁。以四大王众天寿量。成等活大那落迦寿量。如是以三十三天寿量。成黑绳大那落迦寿量。以时分天寿量。成众合大那落迦寿量。以知足天寿量。成号叫大那落迦寿量。以乐化天寿量。成大号叫大那落迦寿量。以他化自在天寿量。成烧热大那落迦寿量。应知亦尔。极烧热大那落迦有情寿半中劫。无间大那落迦有情寿一中劫。非天寿量如三十三天。傍生饿鬼寿量不定。又寒那落迦于大那落迦。次第相望寿量近半。应知又近边那落迦独一那落迦受生有情寿量不定。梵众天寿二十中劫一劫。梵前益天寿四十中劫一劫。大梵天寿六十中劫一劫。少光天寿八十中劫二劫。自此以上余色界天寿量相望各渐倍增。唯除无云。当知彼天寿减三劫。空无边处寿二万劫。识无边处寿四万劫。无所有处寿六万劫。非想非非想处寿八万劫。除北拘卢洲。余一切处悉有中夭。又人鬼傍生趣有余滓身。天及那落迦。与识俱没无余滓身

受用建立者。略有三种。谓受用苦乐受用饮食。受用淫欲。

受用苦乐者。谓那落迦有情多分受用极治罚苦。傍生有情多分受用相食啖苦。饿鬼有情多分受用极饥渴苦。人趣有情多分受用匮乏追求种种之苦。天趣有情多分受用衰恼坠没之苦。又于等活大那落迦中。多受如是极治罚苦。谓彼有情多共聚集业增上生。种种苦具次第而起。更相残害闷绝躄地。次虚空中有大声发。唱如是言。此诸有情可还等活可还等活。次彼有情欻然复起。复由如前所说苦具。更相残害。由此因缘长时受苦。乃至先世所造一切恶不善业未尽未出故。此那落迦名为等活。又于黑绳大那落迦中。多受如是治罚重苦。谓彼有情多分为彼所摄。狱卒以黑绳拼之。或为四方或为八方。或为种种图画文像。彼既拼已。随其处所若凿若斲若斫若剜。由如是等种种因缘。长时受苦。乃至先世所造一切恶不善业未尽未出故。此那落迦名为黑绳。又于众合大那落迦中。多受如是治罚重苦。谓彼有情或时展转聚集和合。尔时便有彼摄狱卒。驱逼令入两铁羺头大山之间。彼既入已两山迫之。既被迫已一切门中血便流注。如两铁羺头如是。两铁羝头。两铁马头。两铁象头。两铁师子头。两铁虎头亦尔。复令和合置大铁槽中。便即压之如压甘蔗。既被压已血便流注。复和合已有大铁山从上而堕。令彼有情躄在铁地。若斫若刺或捣或裂。既被斫刺及捣裂已。血便流注。由此因缘长时受苦。乃至先世所作一切恶不善业未尽未出故。此那落迦名为众合。又于号叫大那落迦中。多受如是治罚重苦。谓彼有情寻求舍宅。便入大铁室中彼才入已即便火起。由此烧然。若极烧然遍极烧然。既被烧已苦痛逼切发声号叫。由此因缘长时受苦。乃至先世所造一切恶不善业未尽未出故。此那落迦名为号叫。又于大号叫大那落迦中。所受苦恼与此差别。谓彼室宅其如胎藏故此那落迦名大号叫。又于烧热大那落迦中。多受如是治罚重苦。谓彼所摄狱卒以诸有情。置无量踰缮那热极热遍极烧然大铁[金*敖]上。左右转之表里烧煿。又如炙鱼。以大铁丳从下贯之彻顶而出。反覆炙之。令彼有情诸根毛孔及以口中悉皆焰起。复以有情。置热极热遍极烧然大铁地上。或仰或覆以热极热遍极烧然大铁椎棒。或打或筑遍打遍筑。令如肉抟。由此因缘长时受苦。乃至先世所造一切恶不善业未尽未出故。此那落迦名为烧热。又于极烧热大那落迦中。所受苦恼与此差别。谓以三支大热铁丳从下贯之。彻其两膊及顶而出。由此因缘。眼耳鼻口及诸毛孔猛焰流出。又以热极热遍极烧然大铜铁鍱。遍裹其身。又复倒掷置热极热遍极烧然弥满灰水大铁镬中。而煎煮之。其汤涌沸令此有情随汤飘转或出或没令其血肉及以皮脉悉皆销烂。唯骨琐在。寻复漉之置铁地上。令其皮肉及以血脉复生如故。还置镬中。余如烧热大那落迦说。由此因缘长时受苦。乃至先世所造一切恶不善业未尽未出故。此那落迦名极烧热。又于无间大那落迦中。彼诸有情恒受如是极治罚苦。谓从东方多百踰缮那烧热极烧热遍极烧然大铁地上。有猛炽火腾焰而来。刺彼有情穿皮入肉断筋破骨复彻其髓。烧如脂烛。如是举身皆成猛焰。如从东方。南西北方亦复如是。由此因缘。彼诸有情与猛焰和杂。唯见火聚从四方来。火焰和杂无有间隙。所受苦痛亦无间隙。唯闻苦逼号叫之声。知有众生。又以铁箕。盛满烧然极烧然遍极烧然猛焰铁炭。而簸剪之。复置热铁地上。令登大热铁山。上而复下下而复上。从其口中拔出其舌。以百铁钉钉而张之。令无皱襵如张牛皮。复更仰卧热铁地上。以热烧铁钳钳口令开。以烧然极烧然遍极烧然大热铁丸。置其口中。即烧其口及以咽喉彻于府藏。从下而出。又以洋铜而灌其口。烧喉及口彻于府藏。从下流出。所余苦恼如极热说。由此因缘长时受苦。乃至先世所造一切恶不善业未尽未出故。此那落迦名为无间。多是造作无间之业来生是中。此但略说粗显苦具。非于如是大那落迦中。所余种种众多苦具而不可得又于近边诸那落迦中。有情之类受用如是治罚重苦。谓彼一切诸大那落迦。皆有四方四岸四门铁墙围绕从其四方四门出已。其一一门外有四出园。谓煻煨齐膝。彼诸有情出求舍宅游行至此。下足之时皮肉及血并即消烂。举足还生。次此煻煨无间即有死尸粪泥。此诸有情为求舍宅从彼出已。渐渐游行陷入其中首足俱没。又尸粪埿内多有诸虫。名娘矩吒。穿皮入肉断筋破骨取髓而食。次尸粪埿无间有利刀剑。仰刃为路。彼诸有情为求舍宅。从彼出已游行至此。下足之时皮肉筋血悉皆消烂。举足之时还复如故。次刀剑刃路无间有刃叶林。彼诸有情为求舍宅。从彼出已往趣彼荫才坐其下微风遂起刃叶堕落。斫截其身一切支节。便即躄地有黑厘狗。摣掣脊胎而啖食之。从此刃叶林无间有铁设拉末梨林。彼诸有情为求舍宅。便来趣之遂登其上。当登之时一切刺锋悉回向下。欲下之时一切刺锋复回向上。由此因缘贯刺其身遍诸支节。尔时便有铁[此/朿]大乌。上彼头上或上其髆。探啄眼睛而啖食之。从铁设拉末梨林无间有广大河沸热灰水弥满其中。彼诸有情寻求舍宅。从彼出已来堕此中。犹如以豆置之大镬。然猛炽火而煎煮之。随汤腾涌周旋回复。于河两岸有诸狱卒。手执杖索及以大网。行列而住。遮彼有情不令得出。或以索罥。或以网漉。复置广大热铁地上。仰彼有情而问之言。汝等今者欲何所须。如是答言。我等今者竟无觉知。然为种种饥苦所逼。时彼狱卒即以铁钳钳口令开。便以极热烧然铁丸。置其口中。余如前说。若彼答言。我今唯为渴苦所逼。尔时狱卒。便即洋铜以灌其口。由是因缘长时受苦。乃至先世所造一切能感那落迦恶不善业未尽未出。此中若刀剑刃路。若刃叶林。若铁设拉末梨林。总之为一故有四园。又于寒那落迦受生有情。多受如是极重塞苦。谓疱那落迦中受生有情。即为彼地极重广大寒触所触。一切身分悉皆卷缩犹如疮疱。故此那落迦名疱那落迦。疱裂那落迦与此差别。犹如疱溃脓血流出其疮卷皱。故此那落迦名为疱裂。又喝哳詀。郝郝凡。虎虎凡。此三那落迦由彼有情苦音差别。以立其名。青莲那落迦中。由彼地极重广大寒触所触。一切身分悉皆青瘀。皮肤破裂或五或六。故此那落迦名曰青莲。红莲那落迦与此差别。过此青已色变红赤。皮肤分裂或十或多。故此那落迦名曰红莲。大红莲那落迦与此差别。谓彼身分极大红赤。皮肤分裂或百或多。故此那落迦。名大红莲。又独一那落迦中受生有情。各于自身自业所感。多受如是种种大苦。如吉祥问采菉豆子经中广说。故此那落迦名为独一

又傍生趣更相残害如羸弱者为诸强力之所杀害。由此因缘受种种苦。以不自在他所驱驰多被鞭挞。与彼人天为资生具。由此因缘。具受种种极重苦恼

又饿鬼趣略有三种。一者由外。障碍饮食。二者由内障碍饮食。三者饮食无有障碍。云何由外障碍饮食。谓彼有情由习上品悭故生鬼趣中。常与饥渴相应。皮肉血脉皆悉枯槁犹如火炭。头发蓬乱其面黯黑。唇口干焦常以其舌舐略口面。饥渴慞惶处处驰走。所到泉池为余有情手执刀杖及以罥索。行列守护令不得趣。或强趣之。便见其泉变成脓血自不欲饮。如是等鬼。是名由外障碍饮食。云何由内障碍饮食。谓彼有情口或如针。口或如炬。或复颈瘿其腹宽大。由此因缘。纵得饮食无他障碍。自然不能若啖若饮。如是等鬼。是名由内障碍饮食。云何饮食无有障碍。谓有饿鬼名猛焰鬘。随所饮啖皆被烧然。由此因缘。饥渴大苦未尝暂息。复有饿鬼名食粪秽。或有一分食粪饮溺。或有一分唯能饮啖极可厌恶生熟臭秽。纵得香美而不能食。或有一分自割身肉而啖食之。纵得余食竟不能啖。如是等鬼。是名饮食无有障碍

又人趣中受生有情。多受如是匮乏之苦。所谓俱生饥渴匮乏苦。所欲不果匮乏苦。粗疏饮食匮乏苦。逼切追求摄受等匮乏苦。时节变异若寒若热匮乏苦。无有舍宅覆障所作淋漏匮乏苦。黑闇等障所作事业皆悉休废匮乏苦。又受变坏老病死苦。由那落迦中谓死为乐。故于彼趣不立为苦。又天趣中无解支节苦。而有死堕苦。如经中说。有诸天子将欲没时。五相先现。一衣无垢染有垢染现。二鬘旧不萎今乃萎瘁。三两腋汗流。四身便臭秽。五天及天子不乐本座。时彼天子偃卧林间所有婇女与余天子共为游戏。彼既见已由此因缘生大忧苦。复受陵蔑悚栗之苦。所以者何。由有广大福聚成就及广大五欲。天子生时所余薄福诸旧天子见已惶怖。由此因缘受大忧苦。又受斫截破坏驱摈残害之苦。所以者何。由天与非天共战诤时天与非天互相违拒。即执四仗。所谓金银颇胝琉璃。共相战斗。尔时诸天及与非天。或断支节或破其身或复致死。若伤身断节续还如故。若断其首即便殒没。天与非天互有他胜。然天多胜力势强故。然其彼二若为他胜即退入自宫。己之同类竟不慰问。由此因缘便怀忧戚。若天得胜便入非天宫中。为悦其女起此违诤。若非天得胜即入天宫。为求四种苏陀味故共相战诤。又诸非天当知天趣所摄。然由意志多怀诈幻谄诳多故。不如诸天为净法器。由此因缘。有时经中说为别趣。实是天类由不受行诸天法故说为非天。复有强力天子才一发愤。诸劣天子便被驱摈出其自宫。是故诸天受三种苦。谓死堕苦。陵蔑苦。斫截破坏残害驱摈苦。又色无色界有情无有如是等苦。由彼有情非苦受器故。然由粗重苦故说彼有苦。有烦恼故。有障碍故。于死及住不自在故。

又无漏界中一切粗重诸苦永断。是故唯此是胜义乐。当知所余一切是苦。又于四种那落迦中无有乐受。如那落迦中。三种饿鬼中亦尔。诸大力鬼傍生人中。有外门所生资具乐可得。然为众苦之所相杂。又人趣中转轮王乐最胜微妙。由彼轮王出现世时有成就七宝自然出现故。说彼王具足七宝。何等为七。所谓轮宝象宝马宝末尼珠宝女宝主藏臣宝主兵臣宝。尔时轮宝等现。其相云何。七宝现相如经广说。若彼轮王王四洲者。一切小王望风顺化。各自白言。某城邑聚落天之所有。唯愿大王垂恩教敕。我等皆当为天仆隶。尔时轮王便即敕令。汝等诸王各于自境以理奖化。当以如法勿以非法。又复汝等于国于家勿行非法行。勿行不平等行。若彼轮王王三洲者。先遣使往然后从化。若彼轮王王二洲者。兴师现威后乃从化。若彼轮王王一洲者。便自往彼奋戈挥刃然后从化

复次诸天受其广大天之富乐。形色殊妙多诸适悦。于自宫中而得久住。其身内外皆悉清洁无有臭秽。又人身内多有不净。所谓尘垢筋骨脾肾心肝。彼皆无有。又彼诸天有四种宫殿。所谓金银颇胝琉璃所成。种种文彩绮饰庄严种种台阁种种楼观。种种层级种种窗牖种种罗网皆可爱乐。种种末尼以为绮钿。周匝放光共相照曜。复有食树。从其树里出四食味。名曰苏陀。所谓青黄赤白。复有饮树。从此流出甘美之饮。复有乘树。从此出生种种妙乘。所谓车辂辇舆等。复有衣树。从此出生种种妙衣。其衣细软妙色鲜洁杂彩间饰。复有庄严具树。从此出生种种微妙庄严之具。所谓末尼臂印耳珰环钏。及以手足绮饰之具。如是等类诸庄严具。皆以种种妙末尼宝。而间饰之。复有熏香鬘树。从此出生种种涂香种种熏香种种花鬘。复有大集会树。最胜微妙。其根深固五十踰缮那。其身高挺百踰缮那。枝条及叶遍覆八十踰缮那。杂花开发。其香顺风熏百踰缮那。逆风熏五十踰缮那。于此树下三十三天。雨四月中以天妙五欲共相娱乐。复有歌笑舞乐之树。从此出生歌笑舞等种种乐器。又有资具之树。从此出生种种资具。所谓食饮之具。坐卧之具。如是等类种种资具。又彼诸天欲受用时。随欲随业应其所须来现手中

又诸非天随其所应。受用种种宫殿富乐应知。又北拘卢洲有如是相树。名曰如意。彼诸人众所欲资具。从树而取不由思惟。随其所须自然在手。复有粳稻不种而获无有我所。又彼有情竟无系属决定胜进。又天帝释有普胜殿。于诸殿中最为殊胜。仍于其处有百楼观。一一楼观有百台阁。一一台阁有七房室一一房室有七天女。一一天女有七侍女。又彼诸天所有地界。平正如掌竟无高下。履触之时便生安乐。下足之时陷便至膝。举足之时随足还起。于一切时自然而有曼陀罗华遍布其上。时有微风吹去萎华复引新者。又彼天宫四面各有大街。其形殊妙轨式可观。清净端严度量齐整。复于四面有四大门。规模宏壮色相希奇。观之无厌实为殊绝。多有异类妙色药叉。常所守护。复于四面有四园苑。一名缋车。二名粗涩。三名和杂。四名喜林。其四园外有四胜地。色相殊妙形状可观。端严无比。其宫东北隅有天会处。名曰善法。诸天入中思惟称量观察妙义。近此园侧有如意石。其色黄白形质殊妙。其相可观严丽无比。又彼天身自然光曜。闇相若现乃知昼去夜分方来。便于天妙五欲游戏之中懒堕睡眠。异类之鸟不复和鸣。由此等相以表昼夜。又彼诸天众妙五欲甚可爱乐。唯发喜乐。彼诸天众恒为放逸之所持行。常闻种种歌舞音乐鼓噪之声。调戏言笑谈谑等声。常见种种可意之色。常嗅种种微妙之香。恒尝种种美好之味。恒触种种天诸婇女最胜之触。恒为是乐。牵引其意以度其时。又彼诸天多受如是众妙欲乐。常无疾病亦无衰老。无饮食等匮乏所作俱生之苦。无如前说于人趣中有余匮乏之苦

瑜伽师地论卷第四瑜伽师地论卷第五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中有寻有伺等三地之二

复次于色界中。初静虑地受生诸天。即受彼地离生喜乐。第二静虑地诸天。受定生喜乐。第三静虑地诸天。受离喜妙乐。第四静虑地诸天。受舍念清净寂静无动之乐无色界诸天。受极寂静解脱之乐。又由六种殊胜故。苦乐殊胜应知。一形量殊胜。二柔软殊胜。三缘殊胜。四时殊胜。五心殊胜。六所依殊胜。何以故。如如身量渐增广大。如是如是苦转殊胜。如如依止渐更柔软。如是如是苦转殊胜。如如苦缘渐更猛盛众多差别。如是如是苦转殊胜。如如时分渐远无间。如是如是苦转殊胜。如如内心无简择力渐渐增广。如是如是苦转殊胜。如如所依苦器渐增。如是如是苦转殊胜。如苦殊胜。如是乐殊胜义。随其所应广说应知。又乐有二种。一非圣财所生乐。二圣财所生乐。非圣财所生乐者。谓四种资具为缘得生。一适悦资具。二滋长资具。三清净资具。四住持资具。适悦资具者。谓车乘衣服诸庄严具。歌笑舞乐涂香花鬘种种上妙珍玩乐具。光明照曜男女侍卫种种库藏。滋长资具者。谓无寻思轮石。椎打筑蹋。按摩等事。清净资具者。谓吉祥草。频螺果。螺贝满瓮等事。住持资具者。谓饮及食。圣财所生乐者。谓七圣财为缘得生。何等为七。一信二戒三惭四愧五闻六舍七慧

复次由十五种相。圣非圣财所生乐差别。何等十五。谓非圣财所生乐能起恶行。圣财所生乐能起妙行。又非圣财所生乐有罪喜乐相应。圣财所生乐无罪喜乐相应。又非圣财所生乐微小不遍所依。圣财所生乐广大遍满所依。又非圣财所生乐非一切时有。以依外缘故。圣财所生乐一切时有。以依内缘故。又非圣财所生乐非一切地有。唯欲界故。圣财所生乐一切地有。通三界系及不系故。又非圣财所生乐不能引发后世圣非圣财。圣财所生乐能引发后世圣非圣财。又非圣财所生乐若受用时有尽有边。圣财所生乐若受用时转更充盛增长广大。又非圣财所生乐为他劫夺。若王若贼怨及水火。圣财所生乐无能侵夺。又非圣财所生乐不可从今世持往后世。圣财所生乐可从今世持往后世。又非圣财所生乐受用之时不可充足。圣财所生乐受用之时究竟充满。又非圣财所生乐有怖畏。有怨对。有灾横。有烧恼。不能断后世大苦。有怖畏者。谓惧当生苦所依处故。有怨对者。谓斗讼违诤所依处故。有灾横者。谓老病死所依处故。有烧恼者。谓由此乐性不真实。如疥癞病虚妄颠倒所依处故。愁叹忧苦种种热恼所依处故。不能断后世大苦者。谓贪嗔等本随二惑所依处故。圣财所生乐无怖畏。无怨对。无灾横。无烧恼。能断后世大苦。随其所应与上相违。广说应知。又外有欲者受用欲尘。圣慧命者受用正法。由五种相故有差别。由此因缘。说圣慧命者以无上慧命清净自活。何等为五。一受用正法者不染污故。二受用正法者极毕竟故。三受用正法者一向定故。四受用正法者与余慧命者不共故。五受用正法者有真实乐故。摧伏魔怨故。此中诸受欲者所有欲乐。是随顺喜处贪爱所随故。是随顺忧处嗔恚所随故。是随顺舍处无简择舍之所随故。圣慧命者受用正法则不如是。又诸有欲者受用欲尘。从不可知本际以来以无常故。舍余欲尘得余欲尘。或于一时都无所得。圣慧命者受用正法则不如是。又受欲者受用欲时。即于此事一起喜爱一起忧恚。复即于彼或时生喜或时生忧。圣慧命者受用正法则不如是。又诸离欲外慧命者。于种种见趣自分别所起邪胜解处。其心猛利种种取着。恒为欲染之所随逐。虽已离欲复还退起。圣慧命者受用正法则不如是。又受欲者及诸世间已离欲者。所有欲乐及离欲乐。皆非真实。皆为魔怨之所随逐。如幻如响如影如焰如梦所见。犹如幻作诸庄严具。又着乐愚夫诸受欲者。及诸世间已离欲者。凡所受用犹如癫狂如醉乱等。未制魔军而有受用。是故彼乐为非真实。亦不能制所有魔事。圣慧命者受用正法则不如是

复次三界有情所依之身当云何观。谓如毒热痈粗重所随故。即于此身乐受生时当云何观。谓如毒热痈暂遇冷触。即于此身苦受生时当云何观。谓如毒热痈为热灰所触。即于此身不苦不乐受生时当云何观。谓如毒热痈离冷热等触。自性毒热而本住故。薄伽梵说。当知乐受坏苦故苦。苦受苦苦故苦。不苦不乐受行苦故苦。又说有有爱味喜。有离爱味喜。有胜离爱味喜。如是等类如经广说。应知堕二界摄。又薄伽梵建立想受灭乐为乐中第一。此依住乐非谓受乐。又说有三种乐。谓离贪离嗔离痴。此三种乐唯无漏界中可得。是故此乐名为常乐。无漏界摄。

复次饮食受用者。谓三界将生已生有情寿命安住。此中当知触意思识三种食故。一切三界有情寿命安住。段食一种唯令欲界有情寿命安住。又于那落迦受生有情。有微细段食。谓腑藏中有微动风。由此因缘彼得久住。饿鬼傍生人中有粗段食。谓作分段而啖食之。复有微细食。谓住羯罗蓝等位有情及欲界诸天。由彼食已。所有段食流入一切身分支节。寻即消化无有便秽

复次淫欲受用者。诸那落迦中所有有情皆无淫事。所以者何。由彼有情长时无间多受种种极猛利苦。由此因缘。彼诸有情若男于女不起女欲。若女于男不起男欲。何况展转二二交会。若鬼傍生人中所有依身。苦乐相杂故有淫欲。男女展转二二交会不净流出。欲界诸天虽行淫欲无此不净。然于根门有风气出烦恼便息。四大王众天。二二交会热恼方息。如四大王众天。三十三天亦尔。时分天。唯互相抱热恼便息。知足天。唯相执手热恼便息。乐化天。相顾而笑热恼便息。他化自在天。眼相顾视热恼便息。又三洲人。摄受妻妾施设嫁娶。北拘卢洲无我所故无摄受故。一切有情无摄受妻妾亦无嫁娶。如三洲人。如是大力鬼及欲界诸天亦尔。唯除乐化天及他化自在天。又一切欲界天众无有处女胎藏。然四大王众天于父母肩上或于怀中。如五岁小儿欻然化出。三十三天如六岁。时分天如七岁。知足天如八岁。乐化天如九岁。他化自在天如十岁

复次生建立者谓三种欲生。或有众生现住欲尘。由此现住欲尘故富贵自在。彼复云何。谓一切人及四大王众天乃至善知足天。是名第一欲生。或有众生变化欲尘。由此变化欲尘故富贵自在。彼复云何。谓乐化天。由彼诸天为自己故化为欲尘。非为他故。唯自变化诸欲尘故富贵自在。是名第二欲生。或有众生他化欲尘。由他所化诸欲尘故富贵自在。彼复云何谓他化自在天。由彼诸天为自因缘亦能变化为他因缘亦能变化。故于自化非为希奇用他所化欲尘为富贵自在。故说此天为他化自在。非彼诸天唯受用他所化欲尘。亦有受用自所化欲尘者。是名第三欲生。复有三种乐生。或有众生用离生喜乐灌洒其身。谓初静虑地诸天。是名第一乐生。或有众生由定生喜乐灌洒其身。谓第二静虑地诸天。是名第二乐生。或有众生以离喜乐灌洒其身。谓第三静虑地诸天。是名第三乐生。问何故建立三种欲生三种乐生耶。答由三种求故。一欲求。二有求。三梵行求。谓若诸沙门或婆罗门堕欲求者。一切皆为三种欲生。更无增过。若诸沙门或婆罗门堕有求者。多分求乐。由贪乐故。一切皆为三种乐生。由诸世间为不苦不乐寂静生处起追求者极为鲜少故。此以上不立为生。若诸沙门或婆罗门堕梵行求者。一切皆为求无漏界。或复有一堕邪梵行求者。为求不动空无边处识无边处无所有处非想非非想处。起邪分别。谓为解脱。当知此是有上梵行求。无上梵行求者。谓求无漏界

复次自体建立者。谓于三界中所有众生有四种得自体差别。或有所得自体。由自所害不由他害。谓有欲界天。名游戏忘念。彼诸天众。或时耽着种种戏乐。久相续住。由久住故忘失忆念。由失念故从彼处没。或复有天名曰意愤。彼诸天众。有时展转角眼相视。由相视故意愤转增。意愤增故从彼处没。或有所得自体。由他所害不由自害。谓处羯罗蓝遏部昙闭尸键南位。及在母腹中所有众生。或有所得自体。亦由自害亦由他害。谓即彼众生处已生位。诸根圆满诸根成就。或有所得自体。亦非自害亦非他害。谓色无色界诸天。一切那落迦。似那落迦鬼。如来使者。住最后身。慈定灭定若无诤定若处中有。如是等类

云何因缘果建立。谓略说有四种。一由相故。二由依处故。三由差别故。四由建立故。

因等相者。谓若由此为先此为建立。此和合故彼法生。或得或成或办或用。说此为彼因。

问以谁为先谁为建立。谁和合故何法生耶。答自种子为先。除种子依所余若有色若无色依及业为建立。助伴所缘为和合故。随其所应欲系色系无色系及不系诸法生。

问以谁为先谁为建立。谁和合故得何法耶。答声闻独觉如来种性为先。内分力为建立。外分力为和合故。证得烦恼离系涅槃。内分力者。谓如理作意少欲知足。等内分善法及得人身生在圣处。诸根无缺无事业障。于其善处深生净信。如是等法名内分力。外分力者。谓诸佛兴世宣说妙法教法犹存。住正法者随顺而转。具悲信者以为施主。如是等法名外分力。

问以谁为先谁为建立。谁和合故何法成耶。答所知胜解爱乐为先。宗因譬喻为建立。不相违众善敌论者为和合故。所立义成。

问以谁为先谁为建立。谁和合故何法办耶。答工巧智为先。随彼勤劬为建立。工巧业处众具为和合故。工巧业处办。又爱为先。由食住者依止为建立。四食为和合故。受生有情安住充办。

问以谁为先谁为建立。谁和合故何法用耶。答即自种子为先。即此生为建立。即此生缘为和合故。自业诸法作用可知。何等名为自业作用

谓眼以见为业。如是余根各自业用应知。又地能持水能烂火能烧风能燥。如是等类当知外分自业差别。

因等依处者。谓十五种。一语。二领受。三习气。四有润种子。五无间灭。六境界。七根。八作用。九士用。十真实见。十一随顺。十二差别功能。十三和合。十四障碍。十五无障碍

因等差别者。谓十因四缘五果十因者。一随说因。二观待因。三牵引因。四生起因。五摄受因。六引发因。七定异因。八同事因。九相违因。十不相违因。四缘者。一因缘。二等无间缘。三所缘缘。四增上缘。五果者。一异熟果。二等流果。三离系果。四士用果。五增上果。

因等建立者。谓依语因依处。施设随说因。所以者何。由于欲界系法色无色界系法及不系法施设。名为先故想转。想为先故语转。由语故随见闻觉知起诸言说。是故依语依处施设随说因。依领受因依处。施设观待因。所以者何。由诸有情。诸有欲求欲系乐者。彼观待此。于诸欲具或为求得或为积集或为受用。诸有欲求色无色系乐者。彼观待此。于彼诸缘或为求得或为受用。诸有欲求不系乐者。彼观待此。于彼诸缘或为求得或为受用。诸有不欲苦者。彼观待此。于彼生缘于彼断缘。或为远离或为求得或为受用。是故依领受依处。施设观待因。依习气因依处。施设牵引因。所以者何。由净不净业熏习三界诸行。于爱不爱趣中牵引爱不爱自体。又即由此增上力故外物盛衰。是故依诸行净不净业习气依处。施设牵引因。依有润种子因依处。施设生起因。所以者何。由欲色无色界系法各从自种子生。爱名能润种是所润。由此所润诸种子故。先所牵引各别自体当得生起。如经言。业为感生因。爱为生起因。是故依有润种子依处。施设生起因。依无间灭因依处。及依境界根作用士用真实见因依处。施设摄受因。所以者何。由欲系诸法。无间灭摄受故。境界摄受故。根摄受故。作用摄受故。士用摄受故诸行转。如欲系法。如是色无色系法亦尔。或由真实见摄受故。余不系法转。是故依无间灭境界根作用士用真实见依处。施设摄受因。依随顺因依处。施设引发因。所以者何。由欲系善法。能引欲系诸胜善法。如是欲系善法。能引色无色系及不系善法。由随顺彼故。如欲系善法。如是色系善法。能引色系诸胜善法及无色系善法不系善法。如色系善法。如是无色系善法。能引无色系诸胜善法及不系善法。如无色系善法。如是不系善法。能引不系诸胜善法。及能引发无为作证。又不善法能引诸胜不善法。谓欲贪能引嗔痴慢见疑身恶行语恶行意恶行。如欲贪。如是嗔痴慢见疑。随其所应尽当知。如是无记法。能引善不善无记法。如善不善无记种子阿赖耶识。又无记法。能引无记胜法。如段食能引受生有情令住令安势力增长。由随顺彼故。是故依随顺依处。施设引发因。依差别功能因依处。施设定异因。所以者何。由欲系诸法自性功能有差别故能生种种自性功能。如欲系法。如是色无色系及不系法亦尔。是故依差别功能依处。施设定异因。依和合因依处。施设同事因所以者何。要由获得自生和合故。欲系法生如欲系法。如是色无色系及不系法亦尔。如生和合。如是得成办用和合亦尔。是故依和合依处。施设同事因。依障碍因依处。施设相违因。所以者何。由欲系法将得生。若障碍现前便不得生。如欲系法。如是色无色系及不系法亦尔。如生如是得成办用亦尔。是故依障碍依处。施设相违因。依无障碍因依处。施设不相违因。所以者何。由欲系法将得生。若无障碍现前尔时便生。如欲系法。如是色无色系及不系法亦尔。如生。如是得成办用亦尔。是故依无障碍依处。施设不相违因。复次依种子缘依处。施设因缘。依无间灭缘依处。施设等无间缘。依境界缘依处。施设所缘缘。依所余缘依处。施设增上缘

复次依习气随顺因缘依处。施设异熟果及等流果。依真实见因缘依处。施设离系果。依士用因缘依处。施设士用果。依所余因缘依处。施设增上果。

复次顺益义是因义。建立义是缘义。成办义是果义。

又建立因有五种相。一能生因。二方便因。三俱有因。四无间灭因。五久远灭因。能生因者。谓生起因。方便因者。谓所余因。俱有因者。谓摄受因。一分。如眼于眼识。如是耳等于所余识。无间灭因者。谓生起因。久远灭因者。谓牵引因。又建立因有五种相。一可爱因。二不可爱因。三增长因。四流转因。五还灭因。又建立因有七种相。谓无常法是因。无有常法能为法因。谓或为生因。或为得因。或为成立因。或为成办因。或为作用因。又虽无常法为无常法因。然与他性为因。亦与后自性为因。非即此刹那。又虽与他性为因。及与后自性为因。然已生未灭方能为因。非未生已灭。又虽已生未灭。能为因然得余缘方能为因。非不得。又虽得余缘。然成变异方能为因。非未变异。又虽成变异。必与功能相应方能为因。非失功能。又虽与功能相应。然必相称相顺方能为因。非不相称相顺。由如是七种相。随其所应诸因建立应知

云何相施设建立。嗢拖南曰

  体所缘行相　　等起与差别
  决择及流转　　略辩相应知

应知此相略有七种。一体性。二所缘。三行相。四等起。五差别。六决择。七流转。寻伺体性者。谓不深推度所缘。思为体性。若深推度所缘。慧为体性应知。寻伺所缘者。谓依名身句身文身义为所缘。寻伺行相者。谓即于此所缘寻求行相是寻。即于此所缘伺察行相是伺。寻伺等起者。谓发起语言。寻伺差别者。有七种差别。谓有相无相乃至不染污。如前说。寻伺决择者。若寻伺即分别耶。设分别即寻伺耶。谓诸寻伺必是分别。或有分别非寻伺。谓望出世智。所余一切三界心心所。皆是分别而非寻伺。寻伺流转者若那落迦寻伺。何等行。何所触。何所引。何相应。何所求。何业转耶。如那落迦。如是傍生饿鬼人欲界天初静虑地天所有寻伺。何等行。何所触。何所引。何相应。何所求。何业转耶。谓那落迦寻伺唯是戚行。触非爱境。引发于苦与忧相应。常求脱苦娆心业转。如那落迦寻伺一向受苦。饿鬼寻伺亦尔。傍生人趣大力饿鬼所有寻伺。多分戚行少分欣行。多分触非爱境。少分触可爱境。多分引苦少分引乐。多分忧相应。少分喜相应。多分求脱苦。少分求遇乐。娆心业转。欲界诸天所有寻伺。多分欣行少分戚行。多分触可爱境。少分触非爱境。多分引乐少分引苦。多分喜相应。少分忧相应。多分求遇乐少分求脱苦。娆心业转。初静虑地天所有寻伺。一向欣行。一向触内可爱境界。一向引乐。一向喜相应。唯求不离乐。不娆心业转

云何如理作意施设建立。嗢拖南曰

  依处及与事　　求受用正行
  二菩提资粮　　到彼岸方便

应知建立略由八相。谓由依处故事故。求故。受用故。正行故。声闻乘资粮方便故。独觉乘资粮方便故。波罗蜜多引发方便故。如理作意相应。寻伺依处者。谓有六种依处。一决定时。二止息时。三作业时。四世间离欲时。五出世离欲时。六摄益有情时。如理作意相应。寻伺事者。谓八种事。一施所成福作用事。二戒所成福作用事。三修所成福作用事。四闻所成事。五思所成事。六余修所成事。七简择所成事。八摄益有情所成事。如理作意相应。寻伺求者。谓如有一不以非法及不凶险追求财物。如理作意相应。寻伺受用者。谓如即彼追求财已。不染不住不耽不缚。不闷不着亦不坚执。深见过患了知出离而受用之。如理作意相应。寻伺正行者。谓如有一了知父母沙门婆罗门及家长等。恭敬供养利益承事。于今世后世所作罪中见大怖畏。行施作福受斋持戒。声闻乘资粮方便者。声闻地中我当广说。独觉乘资粮方便者。独觉地中我当广说。波罗蜜多引发方便者。菩萨地中我当广说

复次施主有四种相。一有欲乐。二无偏党。三除匮乏。四具正智。具尸罗者亦有四相。一有欲乐。二结桥梁。三不现行。四具正智。成就修者亦有四相。一欲解清净。二引摄清净。三胜解定清净。四智清净。

又受施者有六种。一受学受施。二活命受施。三贫匮受施。四弃舍受施。五羁游受施。六耽着受施。复有八种损恼。一饥损恼。二渴损恼。三粗食损恼。四疲倦损恼。五寒损恼。六热损恼。七无覆障损恼。八有覆障损恼。复有六种损恼。一俱生。二所欲匮乏。三逼切。四时节变异。五流漏。六事业休废。

复有六种摄益。一任持摄益。二勇健无损摄益。三覆护摄益。四涂香摄益。五衣服摄益。六共住摄益。复有四种非善友相。一不舍怨心。二引彼不爱。三遮彼所爱。四引非所宜。与此相违当知即是四善友相。复有三种引摄。一引摄资生具。二引摄有喜乐。三引摄离喜乐。复有四种随转供事。一随转供事非知旧者。二随转供事诸亲友者。三随转供事所尊重者。四随转供事具福慧者。由此四种随转供事。依止四处获得五果应知。何等四处。一无摄受处。二无侵恼处。三应供养处。四同分随转处。依此四处能感五果。一感大财富。二名称普闻。三离诸烦恼。四证得涅槃。五或往善趣。又聪慧者有三种聪慧相。一于善受行。二于善决定。三于善坚固。复有三相。一受学增上戒。二受学增上心。三受学增上慧

瑜伽师地论卷第五瑜伽师地论卷第六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中有寻有伺等三地之三

复次云何不如理作意施设建立。嗢拖南曰

  执因中有果　　显了有去来
  我常宿作因　　自在等害法
  边无边矫乱　　计无因断空
  最胜净吉祥　　由十六异论

由十六种异论差别。显不如理作意。应知何等十六。一因中有果论。二从缘显了论。三去来实有论。四计我论。五计常论。六宿作因论。七计自在等为作者论。八害为正法论。九有边无边论。十不死矫乱论。十一无因见论。十二断见论。十三空见论。十四妄计最胜论。十五妄计清净论。十六妄计吉祥论

因中有果论者。谓如有一若沙门若婆罗门。起如是见立如是论。常常时恒恒时。于诸因中具有果性。谓雨众外道作如是计。问何因缘故彼诸外道起如是见立如是论。显示因中具有果性。答由教及理故。教者。谓彼先师所造教藏。随闻转授传至于今。显示因中先有果性。理者。谓即如彼沙门若婆罗门。为性寻思为性观察。住寻思地。住自办地。住异生地。住随思惟观察行地。彼作是思。若从彼性。此性得生。一切世间共知共立。彼为此因非余。又求果者唯取此因非余。又即于彼加功营构诸所求事非余。又若彼果即从彼生不从余生。是故彼果因中已有。若不尔者应立一切是一切因。为求一果应取一切。应于一切加功营构。应从一切一切果生。如是由施设故求取故。所作决定故。生故。彼见因中常有果性。

应审问彼。汝何所欲。何者因相。何者果相。因果两相。为异不异。若无异相。便无因果二种决定。因果二种。无差别故。因中有果。不应道理。若有异相。汝意云何。因中果性。为未生相。为已生相。若未生相。便于因中。果犹未生。而说是有。不应道理。若已生相。即果体已生。复从因生。不应道理。是故。因中非先有果。然要有因待缘果生。又有相法。于有相法中。由五种相。方可了知。一于处所可得。如瓮中水。二于所依可得。如眼中眼识。三即由自相可得。如因自体不由比度。四即由自作业可得。五由因变异故。果成变异。或由缘变异故。果成变异。是故彼说常常时。恒恒时。因中有果。不应道理。由此因缘。彼所立论。非如理说。如是不异相故。异相故。未生相故。已生相故。不应道理。

从缘显了论者。谓如有一若沙门若婆罗门。起如是见。立如是论。一切诸法性本是有。从众缘显。不从缘生。谓即因中有果论者。及声相论者。作如是计。问何因缘故。因中有果论者。见诸因中先有果性从缘显耶。答由教及理故。教如前说。理者谓如有一为性寻思。为性观察。广说如前。彼如是思。果先是有。复从因生。不应道理。然非不用功为成于果。彼复何缘而作功用。岂非唯为显了果耶。彼作如是妄分别。已立显了论。

应审问彼。汝何所欲。为无障缘而有障碍。为有障缘耶。若无障缘者。无障碍缘。而有障碍。不应道理。若有障缘者。属果之因。何故不障。同是有故。不应道理。譬如黑闇障盆中水亦能障盆。若言障缘亦障因者。亦应显因俱被障故。而言但显因中先有果性不显因者。不应道理。复应问彼。为有性是障缘。为果性耶。若有性是障缘者。是即有性。常不显了。不应道理。因亦是有。何不为障。若言果性是障缘者。是则一法亦因亦果。如芽是种子果是茎等。因是即一法。亦显不显。不应道理。又今问汝。随汝意答。本法与显为异不异。若不异者。法应常显。显已复显。不应道理。若言异者。彼显为无因耶。为有因耶。若言无因。无因而显。不应道理。若有因者。果性可显非是因性。以不显因。能显于果。不应道理。如是无障缘故。有障缘故。有相故。果相故。显不异故。显异故。不应道理。是故汝言若法性无是即无相。若法性有是即有相。性若是无不可显了。性若是有方可显了者。不应道理。我今当说。虽复是有不可取相。谓或有远故虽有而不可取。又由四种障。因障故而不可取。复由极微细故而不可取。或由心散乱故而不可取。或由根损坏故而不可取。或由未得彼相应智故而不可取。如因果显了论。不应道理。当知声相论者亦不应理。此中差别者。外声论师起如是见立如是论。声相常住无生无灭。然由宣吐方得显了。是故此论如显了论非应理说

去来实有论者。谓如有一若沙门若婆罗门。若在此法者。由不正思惟故。起如是见立如是论。有过去有未来。其相成就犹如现在实有非假。问何因缘故彼起如是见立如是论。答由教及理故。教如前说。又在此法者。于如来经不如理分别故。谓如经言。一切有者即十二处。此十二处实相是有。又薄伽梵说有过去业。又说有过去色有未来色。广说乃至识亦如是。理者。谓如有一为性寻思。为性观察。广说如前。彼如是思。若法自相安住此法真实是有。此若未来无者。尔时应未受相。此若过去无者。尔时应失自相。若如是者。诸法自相应不成就。由此道理亦非真实故。不应理。由是思惟起如是见。立如是论。过去未来性相实有。

应审问彼。汝何所欲。去来二相与现在相为一为异。若言相一。立三世相不应道理。若相异者。性相实有不应道理。又汝应说自意所欲。堕三世法为是常相为无常相。若常相者。堕在三世不应道理。若无常相。于三世中恒是实有不应道理。又今问汝。随汝意答。为计未来法来至现在世耶。为彼死已于此生耶。为即住未来为缘生现在耶。为本无业今有业耶。为本相不圆满今相圆满耶。为本异相今异相耶。为于未来有现在分耶。若即未来法来至现在者。此便有方所。复与现在应无差别。复应是常不应道理。若言未来死已现在生者是即未来。不生于今现在世法本无今生。又未来未生而言死没。不应道理。若言法住未来以彼为缘生现在者。彼应是常。又应本无今生非未来法生。不应道理。若本无业用今有业用。是则本无今有便有如前所说过失不应道理。又汝何所欲。此业用与彼本法。为有异相为无异相。若有异相。此业用相未来无故。不应道理。若无异相。本无业用今有业用。不应道理。如无业用有此过失如是。相圆满。异相。未来分相应知亦尔。此中差别者。复有自性杂乱过失故。不应道理。如未来向现在。如是现在往过去。如其所应过失应知。谓即如前所计诸因缘及所说破道理如是。自相故共相故。来故死故。为缘生故业故。相圆满故相异故。未来有分故。说过去未来体实有论。不应道理。如是说已复有难言。若过去未来是无。云何缘无而有觉转。若言缘无而有觉转者。云何不有违教过失。如说一切有者。谓十二处。我今问汝。随汝意答。世间取无之觉。为起耶为不起耶。若不起者。能取无我。兔角。石女儿。等觉皆应是无。此不应理。又薄伽梵说。我诸无谄声闻。如我所说正修行时。若有知有若无知无。此不应道理。若言起者。汝意云何。此取无觉。为作有行为作无行。若作有行。取无之觉而作有行。不应道理。若作无行者。汝何所欲。此无行觉。为缘有事转。为缘无事转若缘有事转者。无行之觉缘有事转。不应道理。若缘无事转者。无缘无觉不应道理。又虽说一切有者谓十二处。然于有法密意说有有相。于无法密意说有无相。所以者何。若有相法能持有相。若无相法能持无相。是故俱名为法俱名为有。若异此者。诸修行者唯知于有不知于无应非无间观所知法。不应道理。又虽说言有过去业。由此业故诸有情受有损害受无损害受。此亦依彼习气。密意假说为有。谓于诸行中。曾有净不净业。若生若灭由此因缘彼行胜异相续而转是名习气。由此相续所摄习气故。爱不爱果生。是故于我无过。而汝不应道理复虽说言有过去色有未来色有现在色如是乃至识亦尔者此亦依三种行相。密意故说。谓因相自相果相。依彼因相密意说有未来。依彼自相密意说有现在依彼果相密意说有过去。是故无过。又不应说过去未来是实有相。何以故。应知未来有十二种相故。一因所显相。二体未生相。三待众缘相。四已生种类相。五可生法相。六不可生法相。七未生杂染相。八未生清净相。九应可求相。十不应求相。十一应观察相。十二不应观察相。当知现在亦有十二种相。一果所显相。二体已生相。三众缘会相。四已生种类相。五一刹那相。六不复生法相。七现杂染相。八现清净相。九可喜乐相。十不可喜乐相。十一应观察相。十二不应观察相。当知过去亦有十二种相。一已度因相。二已度缘相。三已度果相。四体已坏相。五已灭种类相

六不复生法相。七静息杂染相。八静息清净相。九应顾恋处相。十不应顾恋处相。十一应观察相。十二不应观察相。

计我论者。谓如有一若沙门若婆罗门。起如是见立如是论。有我萨埵命者生者。有养育者数取趣者。如是等谛实当住。谓外道等作如是计。问何故彼外道等起如是见立如是论。答由教及理故。教如前说。理者。谓如有一为性寻思为性观察。广说如前。由二种因故。一先不思觉率尔而得有萨埵觉故。二先已思觉得有作故。彼如是思。若无我者见于五事。不应起于五有我觉。一见色形已。唯应起于色形之觉。不应起于萨埵之觉。二见顺苦乐行已。唯应起于受觉。不应起于胜劣萨埵之觉。三见已立名者名相应行已。唯应起于想觉。不应起于刹帝利。婆罗门。吠舍。戍陀罗。佛授。德友。等萨埵之觉。四见作净不净相应行已。唯应起于行觉。不应起于愚者智者萨埵之觉。五见于境界识随转已。唯应起于心觉。不应起于我。能见。等萨埵之觉。由如是先不思觉。于此五事唯起五种萨埵之觉。非诸行觉。是故先不思觉见已率尔而起有萨埵觉故。如是决定知有实我。又彼如是思若无我者。不应于诸行中先起思觉得有所作。谓我以眼当见诸色。正见诸色。已见诸色。或复起心。我不当见。如是等用。皆由我觉行为先导。如于眼见如是。于耳鼻舌身意应知亦尔。又于善业造作善业止息。不善业造作不善业止息。如是等事。皆由思觉为先。方得作用。应不可得如是等用。唯于诸行。不应道理。

由如是思故。说有我。我今问汝。随汝意答。为即于所见事起萨埵觉。为异于所见事起萨埵觉耶。若即于所见事起萨埵觉者。汝不应言即于色等计有萨埵。计有我者是颠倒觉。若异于所见事起萨埵觉者。我有形量。不应道理。或有胜劣。或刹帝利等。或愚或智。或能取彼色等境界。不应道理。又汝何所欲。为唯由此法自体起此觉耶。为亦由余体起此觉耶。若唯由此法自体起此觉者。即于所见起彼我觉。不应说名为颠倒觉。若亦由余体起此觉者。即一切境界。各是一切境界觉因故。不应理。又汝何所欲。于无情数有情觉。于有情数无情觉。于余有情数余有情觉。为起为不起耶。若起者。是即无情应是有情。有情应是无情。余有情应是余有情。此不应理。若不起者。则非拨现量。不应道理。又汝何所欲。此萨埵觉。为取现量义。为取比量义耶。若取现量义者。唯色等蕴是现量义。我非现量义。故不应理。若取比量义者。如愚稚等。未能思度。不应率尔起于我觉。又我今问汝。随汝意答。如世间所作。为以觉为因。为以我为因。若以觉为因者。执我所作。不应道理。若以我为因者。要先思觉得有所作。不应道理。又汝何所欲。所作事因。常无常耶。若无常者。此所作因体是变异。执我有作不应道理。若是常者。即无变异。无变有作不应道理。又汝何所欲。为有动作之我能有所作。为无动作之我有所作耶。若有动作之我能有所作者。是即常作。不应复作。若无动作之我有所作者。无动作性而有所作。不应道理。又汝何所欲。为有因故我有所作。为无因耶。若有因者。此我应由余因策发方有所作。不应道理。若无因者。应一切时作一切事。不应道理。又汝何所欲。此我为依自故能有所作。为依他故能有所作。若依自者。此我自作老病死苦杂染等事。不应道理。若依他者。计我所作不应道理。又我今问汝。随汝意答。为即于蕴施设有我。为于诸蕴中。为蕴外余处。为不属蕴耶。若即于蕴施设我者。是我与蕴无有差别。而计有我谛实常住。不应道理。若于诸蕴中者。此我为常为无常耶。若是常者。常住之我为诸苦乐之所损益。不应道理。若无损益起法非法。不应道理。若不生起法及非法。应诸蕴身毕竟不起。又应不由功用我常解脱。若无常者。离蕴体外有生有灭。相续流转法不可得故。不应理。又于此灭坏。后于余处不作而得。有大过失。故不应理。若蕴外余处者。汝所计我应是无为。不应道理。若不属蕴者。我一切时应无染污。又我与身不应相属。此不应理。又汝何所欲。所计之我。为即见者等相。为离见者等相。若即见者等相者。为即于见等假立见者等相。为离于见等别立见者等相。若即于见等假立见者等相者。则应见等是见者等。而汝立我为见者等。不应道理。以见者等与见等相。无差别故。若离于见等别立见者等相者。彼见等法。为是我所成业。为是我所执具。若是我所成业者。若如种子应是无常。不应道理。若言如陶师等假立丈夫。此我应是无常。应是假立。而汝言是常是实。不应道理。若言如具神通假立丈夫。此我亦应无常。假立于诸所作随意自在。此亦如前不应道理。若言如地。应是无常。又所计我无如地大。显了作业故不应理。何以故。世间地大所作业用显了可得。谓持万物令不坠下。我无是业显了可得。若如虚空应非实有。唯于色无假立空故。不应道理。虚空虽是假有。而有业用分明可得。非所计我故。不应理。世间虚空所作业用分明可得者。谓由虚空故得起往来屈伸等业。是故见等是我所成业。不应道理。若是我所执具者。若言如镰。如离镰外余物。亦有能断作用。如是离见等。外于余物上。见等业用不可得故。不应道理。若言如火。则徒计于我。不应道理。何以故。如世间火。离能烧者亦自能烧故。若言离见者等相别有我者。则所计我相乖一切量。不应道理。又我今问汝。随汝意答。汝所计我。为与染净相应而有染净。为不与染净相应而有染净耶。若与染净相应而有染净者。于诸行中有疾疫灾横及彼止息顺益可得。即彼诸行虽无有我。而说有染净相应。如于外物。内身亦尔。虽无有我。染净义成。故汝计我不应道理。若不与染净相应而有染净者。离染净相我有染净。不应道理。又我今问汝。随汝意答。汝所计我为与流转相相应而有流转。为不与流转相相应。而有流转及止息耶。若与流转相相应。而有流转及止息者。于诸行中有五种流转相可得。一有因。二可生三可灭。四展转相续生起。五有变异。若诸行中此流转相可得。如于身芽河灯乘等。流转作用中虽无有我。即彼诸行得有流转及与止息何须计我。若不与彼相相应。而有流转及止息者。则所计我无流转相而有流转止息。不应道理。又我今问汝。随汝意答。汝所计我。为由境界所生。若苦若乐及由思业。并由烦恼随烦恼等之所变异。说为受者作者及解脱者。为不由彼变异。说为受者等耶。若由彼变异者。是即诸行是受者作者及解脱者。何须计我。设是我者。我应无常。不应道理。若不由彼变异者。我无变异而是受者作者及解脱者。不应道理。又汝今应说自所欲。为唯于我说为作者。为亦于余法说为作者。若唯于我。世间不应说火为烧者光为照者。若亦于余法。即于见等诸根。说为作者徒分别我。不应道理。又汝应说自意所欲。为唯于我建立于我。为亦于余法建立于我。若唯于我者。世间不应于彼假说士夫身呼为德友佛授等。若亦于余法者。是则唯于诸行假说名我。何须更执别有我耶。何以故。诸世间人唯于假设士夫之身。起有情想立有情名及说自他。有差别故。又汝何所欲。计我之见为善为不善耶。若是善者。何为极愚痴人深起我见。不由方便率尔而起。能令诸生怖畏解脱。又能增长诸恶过失。不应道理。若不善者。不应说正及非颠倒。若是邪倒所计之我体是实有。不应道理。又汝何所欲。无我之见。为善为不善耶若言是善。于彼常住实有我上。见无有我。而是善性非颠倒计。不应道理。若言不善。而一切智者之所宣说。精勤方便之所生起。令诸众生不怖解脱能速证得白净之果。诸恶过失如实对治。不应道理。又汝意云何。为即我性自计有我。为由我见耶。若即我性自计有我者。应一切时无无我觉。若由我见者。虽无实我。由我见力故于诸行中妄谓有我。是故汝计定实有我不应道理。如是不觉为先而起彼觉故。思觉为先见有所作故。于诸蕴中假施设故。由于彼相安立为有故。建立杂染及清净故。建立流转及止息故。假立受者作者解脱者故。施设有作者故。施设言说故。施设见故。计有实我皆不应理。

又我今当说第一义我相。所言我者。唯于诸法假立为有。非实有我。然此假我。不可说言与彼诸法异不异性。勿谓此我是实有体。或彼诸法即我性相。又此假我。是无常相。是非恒相。非安保相。是变坏相。生起法相。老病死相。唯诸法相。唯苦恼相故。薄伽梵说。苾刍当知。于诸法中假立有我。此我无常无恒不可安保。是变坏法。如是广说。由四因。故于诸行中假设有我。一为令世间言说易故。二为欲随顺诸世间故。三为欲断除谓定无我诸怖畏故。四为宣说自他就成功德成就过失。令起决定信解心故。是故执有我论非如理说

计常论者。谓如有一若沙门若婆罗门。起如是见立如是论。我及世间皆实常住。非作所作。非化所化。不可损害积聚而住。如伊师迦。谓计前际说一切常者。说一分常者。及计后际说有相者。说无相者。说非想非非想者。复有计诸极微是常住者。作如是计。问何故彼诸外道。起如是见立如是论。我及世间是常住耶。答彼计因缘如经广说。随其所应尽当知。此中计前际者。谓或依下中上静虑。起宿住随念。不善缘起故。于过去诸行。但唯忆念不如实知。计过去世以为前际。发起常见。或依天眼计现在世以为前际。于诸行刹那生灭流转不如实知。又见诸识流转相续从此世间至彼世间。无断绝故。发起常见。或见梵王随意成立。或见四大种变异。或见诸识变异。计后际者。于想及受虽见差别。然不见自相差别。是故发起常见。谓我及世间皆悉常住。又计极微是常住者。以依世间静虑起如是见。由不如实知缘起故。而计有为先有果集起。离散为先有果坏灭。由此因缘彼谓从众微性粗物果生。渐析粗物乃至微住。是故粗物无常极微是常。

此中计前际后际常住论者。是我执论。差别相所摄故。我论已破。当知。我差别相论亦已破讫。又我今问汝。随汝意答。宿住之念。为取诸蕴为取我耶。若取蕴者。执我及世间是常。不应道理。若取我者。忆念过去如是名等诸有情类。我曾于彼如是名如是姓。乃至广说。不应道理。又汝意云何。缘彼现前和合色境眼识起时。于余不现不和合境所余诸识。为灭为转。若言灭者。灭坏之识而计为常。不应道理。若言转者。由一境界。依一切时。一切识起。不应道理。又汝何所欲。所执之我。由想所作及受所作。为有变异为无变异。若言有者。计彼世间及我常住。不应道理。若言无者。有一想已复种种想。复有小想及无量想。不应道理。又纯有乐已复纯有苦。复有苦有乐有不苦不乐。不应道理。又若计命即是身者。彼计我是色。若计命异于身者。彼计我非色。若计我俱遍。无二无缺者。彼计我亦是色亦非色。若为对治此故。即于此义中。由异句异文。而起执者。彼计我非色非非色。又若见少色少非色者。彼计有边。若见彼无量者。彼计有无边。若复遍见而色分少非色分无量。或色分无量。非色分少者。彼计亦有边亦无边若为对治此故。但由文异不由义异。而起执者。彼计非有边非无边。或计解脱之我远离二种。又计极微常住论者。我今问汝。随汝意答。汝为观察计极微常。为不观察计彼常耶。若不观察者。离慧观察而定计常。不应道理。若言已观察者。违诸量故不应道理。又汝何所欲。诸微尘性。为由细故计彼是常。为由与粗果物其相异故计彼常耶。若由细者。离散损减转复羸劣。而言是常不应道理。若言由相异故者。是则极微。超过地水火风之相。不同种类相故。而言能生彼类果。不应道理。又彼极微。更无异相可得故。不中理。又汝何所欲。从诸极微所起粗物。为不异相为异相耶。若言不异相者。由与彼因无差别故。亦应是常。是则应无因果决定。不应道理。若异相者。汝意云何。为从离散极微粗物得生。为从聚集耶。若言从离散者。应一切时一切果生。是则应无因果决定。不应道理。若从聚集者。汝意云何。彼粗果物从极微生时。为不过彼形质之量。为过彼形质量耶。若言不过彼形质量者。从形质分物。生形质有分物。不应道理。若言过者。诸极微体无细分故不可分析。所生粗物亦应是常。亦不中理。若复说言有诸极微本无今起者。是则计极微常。不应道理。又汝何所欲。彼诸极微起造粗物。为如种子等。为如陶师等耶。若言如种子等者。应如种子体是无常。若言如陶师等者。彼诸极微应有思虑。如陶师等。不应道理。若不如种等及陶师等者。是则同喻不可得故。不应道理。又汝意云何。诸外物起为由有情为不尔耶。若言由有情者。彼外粗物由有情生。所依细物不由有情。不应道理。谁复于彼制其功能。若言不由有情者。是则无用而外物生。不应道理。如是随念诸蕴有情故。由一境界一切识流不断绝故。由想及受变不变故。计彼前际及计后际常住论者。不应道理。又由观察不观察故。由共相故。由自相故。由起造故。根本所用故。极微常论不应道理。是故计常论者。非如理说。我今当说常住之相。若一切时。无变异相。若一切种无变异相。若自然无变异相。若由他无变异相。又无生相当知是常住相

瑜伽师地论卷第六瑜伽师地论卷第七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中有寻有伺等三地之四

宿作因论者犹如有一若沙门若婆罗门。起如是见立如是论。广说如经。凡诸世间所有士夫补特伽罗所受者。谓现所受苦。皆由宿作为因者。谓由宿恶为因。由勤精进吐旧业故者。谓由现法极自苦行现在新业。由不作因之所害故者。谓诸不善业。如是于后不复有漏者。谓一向是善性故。说后无漏。由无漏故业尽者谓诸恶业。由业尽故苦尽者谓宿因所作及现法方便所招苦恼。由苦尽故得证苦边者。谓证余生相续苦尽。谓无系外道作如是计。问何因缘故彼诸外道起如是见立如是论。答由教及理故教如前说。理者犹如有一为性寻思。为性观察。广说如前。由见现法士夫作用不决定故。所以者何。彼见世间虽具正方便而招于苦。虽具邪方便而致于乐。彼如是思。若由现法士夫作用为彼因者。彼应颠倒。由彼所见非颠倒故。是故彼皆以宿作为因。由此理故。彼起如是见立如是论。

今应问彼汝何所欲。现法方便所招之苦。为用宿作为因。为用现法方便为因。若用宿作为因者。汝先所说由勤精进吐旧业故现在新业由不作因之所害故。如是于后不复有漏。乃至广说。不应道理。若用现法方便为因者。汝先所说。凡诸世间所有士夫补特伽罗所受皆由宿作为因不应道理。如是现法方便苦。宿作为因故现法士夫用为因故。皆不应道理。是故此论非如理说。我今当说如实因相。或有诸苦唯用宿作为因。犹如有一自业增上力故生诸恶趣或贫穷家。或复有苦杂因所生。谓如有一因邪事王不获乐果而反致苦。如事于王。如是由诸言说商贾等业。由事农业。由劫盗业。或于他有情作损害事。若有福者获得富乐。若无福者虽设功用而无果遂。或复有法纯由现在功用因得。如新所造引余有业或听闻正法于法觉察。或复发起威仪业路。或复修学工巧业处。如是等类。唯因现在士夫功用

自在等作者论者。由如有一或沙门或婆罗门。起如是见立如是论。凡诸世间所有士夫补特伽罗所受彼一切。或以自在变化为因。或余丈夫变化为因。诸如是等谓说自在等不平等因论者作如是计。问何因缘故起如是见立如是论。答由教及理。教如前说。理者。犹如有一为性寻思。为性观察。广说如前。彼由现见于因果中世间有情不随欲转故作此计。所以者何。现见世间有情。于彼因时欲修净业。不遂本欲。反更为恶。于彼果时愿生善趣乐世界中。不遂本欲。堕恶趣等。意谓受乐不遂所欲。反受诸苦。由见此故。彼作是思。世间诸物必应别有作者生者及变化者为彼物父。谓自在天或复其余。

今当问彼汝何所欲嗢拖南曰

  功能无体性　　摄不摄相违
  有用及无用　　为因成过失

自在天等变化功能。为用业方便为因。为无因耶。若用业方便为因者。唯此功能用业方便为因。非余世间。不应道理。若无因者。唯此功能无因而有。非世间物。不应道理。又汝何所欲。此大自在为堕世间摄。为不摄耶。若言摄者。此大自在则同世法。而能遍生世间。不应道理。若不摄者。则是解脱。而言能生世间。不应道理。又汝何所欲。为有用故变生世间。为无用耶。若有用者。则于彼用无有自在。而于世间有自在者。不应道理。若无用者。无有所须。而生世间。不应道理。又汝何所欲。此所出生为唯大自在为因。为亦取余为因耶。若唯大自在为因者。是则若时有大自在。是时则有出生。若时有出生是时则有大自在。而言出生用大自在为因者。不应道理。若言亦取余为因者。此唯取乐欲为因。为除乐欲更取余为因。若唯取乐欲为因者。此乐欲为唯取大自在为因。为亦取余为因耶。若唯取大自在为因者。若时有大自在是时则有乐欲。若时有乐欲是时则有大自在。便应无始常有出生。此亦不应道理。若言亦取余为因者。此因不可得故。不应道理。又于彼欲无有自在。而言于世间物有自在者。不应道理。如是由功用故。摄不摄故。有用无用故。为因性故。皆不应理。是故此论非如理说。

害为正法论者。谓如有一若沙门若婆罗门。起如是见立如是论。若于彼祠中。咒术为先害诸生命。若能祀者。若所害者。若诸助伴。如是一切皆得生天。问何因缘故。彼诸外道起如是见立如是论。答此违理论。谄诳所起。不由观察道理建立。然于诤竞恶劫起时。诸婆罗门违越古昔婆罗门法。为欲食肉妄起此计。

又应问彼。汝何所欲。此咒术方为是法自体。为是非法自体。若是法自体者。离彼杀生。不能感得自所爱果。而能转彼非法以为正法。不应道理。若是非法自体者。自是不爱果法。而能转舍余不爱果法者。不应道理。如是记已。复有救言。如世间毒咒术所摄不能为害。当知此咒术方亦复如是。今应问彼。汝何所欲。如咒术方能息外毒。亦能息内贪嗔痴毒。为不尔耶。若能息者。无处无时无有一人贪嗔痴等静息可得故不中理。若不能息者。汝先所说。如咒术方能息外毒。亦能息除非法业者。不应道理。又汝何所欲。此咒术方为遍行耶。不遍行耶。若遍行者。自所爱亲不先用祠。不应道理。若不遍者。此咒功能便非决定。不应道理。又汝何所欲。此咒功能为唯能转因亦转果耶。若唯转因者。于果无能。不应道理。若亦转果者。应如转变即令羊等成可爱妙色。然舍羊等身。已方取天身。不应道理。又汝何所欲。造咒术者。为有力能及悲愍不。若言有者。离杀彼命。不能将彼往生天上。不应道理。若言无者。彼所造咒能有所办。不应道理。如是由因故。譬喻故。不决定故。于果无能故。咒术者故。不应道理。是故此论非如理说。我今当说非法之相。若业损他而不治现过是名非法。又若业诸修道者共知此业感不爱果。又若业一切智者决定说为不善。又若业自所不欲。又若业染心所起。又若业待邪咒术方备功验。又若业自性无记。诸如是等皆是非法

边无边论者。谓如有一若沙门若婆罗门。依止世间诸静虑故。于彼世间住有边想无边想。俱想不俱想。广说如经。由此起如是见立如是论。世间有边。世间无边。世间亦有边亦无边。世间非有边非无边。当知此中已说因缘及能计者。是中若依断边际求世边时。若忆念坏劫于世间起有边想。若忆念成劫则于世间起无边想。若依方域周广求世边时。若下过无间更无所得。上过第四静虑亦无所得。傍一切处不得边际。尔时则于上下起有边想。于傍处所起无边想。若为治此执。但依异文义无差别。则于世间起非有边非无边想。

今应问彼。汝何所欲。从前坏劫以来为更有世间生起。为无起耶。若言有者。世间有边不应道理。若言无者。非世间住念世间边。不应道理。如是彼来有故。彼来无故。皆不应理。是故此论非如理说。

不死矫乱论者。谓四种不死矫乱外道。如经广说。应知彼诸外道若有人来。依最胜生道。问善不善。依决定胜道。问苦集灭道。便自称言。不死乱者随于处所依不死净天不乱。诘问即于彼所问以言矫乱。或托余事方便避之。或但随问者言辞而转。是中第一不死乱者。觉未开悟。第二于所证法。起增上慢。第三觉已开悟。而未决定。第四羸劣愚钝。又复第一怖畏妄语。及怖畏他人知其无智故。不分明答言我无所知。第二于自所证未得无畏。惧他诘问。怖畏妄语。怖畏邪见故。不分明说我有所证。第三怖畏邪见。怖畏妄语。惧他诘问故。不分明说我不决定。如是三种。假托余事以言矫乱。第四唯惧他诘。于最胜生道及决定胜道。皆不了达。于世文字。亦不善知。而不分明说言我是愚钝都无所了。但反问彼。随彼言辞。而转以矫乱彼。

此四论发起因缘。及能计者。并破彼执。皆如经说。

由彼外道多怖畏故。依此见住。若有人来有所诘问。即以谄曲而行矫乱。当知此见是恶见摄。是故此论非如理说

无因见论者。谓依止静虑。及依止寻思。应知二种。如经广说。问何因缘故。彼诸外道依止寻思。起如是见立如是论。我及世间。皆无因生。答略而言之。见不相续以为先故。诸内外事无量差别。种种生起。或复有时。见诸因缘空无果报。谓见世间无有因缘。或时欻尔大风卒起。于一时间寂然止息。或时忽尔瀑河弥漫。于一时间顿则空竭。或时郁尔果木敷荣。于一时间飒然衰瘁。由如是故起无因见立无因论。

今应问彼。汝宿住念为念无体。为念自我。若念无体。无体之法。未曾串习。未曾经识。而能随念。不应道理。若念自我。计我先无后欻然生。不应道理。又汝何所欲。一切世间内外诸物。种种生起。或欻然生起。为无因耶。为有因耶。若无因者。种种生起。欻然而起。有时不生。不应道理。若有因者。我及世间。无因而生。不应道理。如是念无体故。念自我故。内外诸物不由因缘种种异故。由彼因缘种种异故。不应道理。是故此论非如理说

断见论者。谓如有一若沙门若婆罗门。起如是见立如是论。乃至我有粗色。四大所造之身。住持未坏。尔时有病。有痈有箭。若我死后。断坏无有。尔时我善断灭。如是欲界诸天。色界诸天。若无色界空无边处所摄。乃至。非想非非想处所摄。广说如经。谓说七种断见论者。作如是计。问何因缘故。彼诸外道。起如是见立如是论。答由教及理故。教如前说。理者谓如有一为性寻思。乃至广说。彼如是思若我死后复有身者。应不作业而得果异熟。若我体性一切永无。是则应无受业果异熟。观此二种。理俱不可。是故起如是见立如是论。我身死已断坏无有。犹如瓦石若一破已不可还合。彼亦如是。道理应知

今应问彼。汝何所欲。为蕴断灭。为我断灭耶。若言蕴断灭者。蕴体无常。因果展转生起不绝。而言断灭。不应道理。若言我断。汝先所说。粗色四大所造之身。有病有痈有箭。欲界诸天。色界诸天。若无色界空无边处所摄。乃至。非想非非想处所摄。不应道理。如是若蕴断灭故。若我断灭故。皆不应理。是故此论非如理说

空见论者。谓如有一若沙门若婆罗门。起如是见立如是论。无有施与无有爱养。无有祠祀。广说乃至。世间无有真阿罗汉。复起如是见立如是论。无有一切诸法体相

问何因缘故。彼诸外道。起如是见立如是论。答由教及理故。教如前说。理者谓如有一为性寻思。乃至广说。又依世间诸静虑故。见世施主一期受命恒行布施无有断绝。从此命终生下贱家贫穷匮乏。彼作是思。定无施与爱养祠祀。复见有人一期寿中恒行妙行。或行恶行。见彼命终堕于恶趣生诸那落迦。或往善趣。生于天上乐世界中。彼作是思。定无妙行及与恶行。亦无妙行恶行二业果异熟。复见有一刹帝利种。命终之后。生婆罗门吠舍戍陀罗诸种姓中。或婆罗门。命终之后。生刹帝利吠舍戍陀罗诸种姓中。吠舍戍陀罗等亦复如是。彼作是思。定无此世刹帝利等从彼世间刹帝利等种姓中来。亦无彼世刹帝利等从此世间刹帝利等种姓中去。又复观见诸离欲者生于下地。又见母命终已生而为女。女命终已还作其母。父终为子。子还作父。彼见父母不决定已作如是思。世间毕定无父无母。或复见人身坏命终。或生无想。或生无色。或入涅槃。求彼生处不能得见。彼作是念。决定无有化生众生。以彼处所不可知故。或于自身起阿罗汉增上慢已临命终时遂见生相。彼作是念。世间必无真阿罗汉。如是广说。问复何因缘。或有起如是见立如是论。无有一切诸法体相。答以于如来所说甚深经中相似甚深离言说法。不能如实正觉了故。又于安立法相。不如正理而思惟故。起于空见。彼作是念。决定无有诸法体相。今应问彼。汝何所欲。为有生所受业及后所受业。为一切皆是生所受耶。若俱有者。汝先所说。无有施与。无有爱养。无有祠祀。无有妙行。无有恶行。无有妙行恶行业果异熟。无此世间。无彼世间。不应道理。若言无有后所受者。诸有造作净与不净种种行业。彼命终已。于彼生时。顿受一切净与不净业果异熟。不应道理。又汝何所欲。凡从彼胎藏。及从彼种子而生者。彼等于此为是父母。为非父母耶。若言是父母者。汝言无父无母。不应道理。若言彼非父母者。从彼胎藏及彼种子所生。而言非父非母。不应道理。若时为父母。是时非男女。若时为男女。是时非父母。无不定过。又汝何所欲。为有彼处受生众生天眼不见。为无有耶。若言有者。汝言无有化生众生。不应道理。若言无者。是则拨无离想欲者。离色欲者。离三界欲者。不应道理。又汝何所欲。为有阿罗汉性而于彼起增上慢。为无有耶。若言有者。汝言世间必定无有真阿罗汉。不应道理。若言无者。若有发起不正思惟颠倒。自谓是阿罗汉。此乃应是真阿罗汉。亦不中理。又应问彼。汝何所欲。圆成实相法。依他起相法。遍计所执相法。为有为无。若言有者。汝言无有一切诸法体相。不应道理。若言无者。应无颠倒亦无染净。不应道理。如是若生后所受故。非不决定故。有生处故。有增上慢故。有三种相故。不应道理。是故此论非如理说

妄计最胜论者。谓如有一若沙门若婆罗门。起如是见立如是论。婆罗门是最胜种类。刹帝利等是下劣种类。婆罗门是白净色类。余种是黑秽色类。婆罗门种可得清净。非余种类。诸婆罗门是梵王子。从大梵王口腹所生。从梵所出。梵所变化。梵王体胤谓斗诤劫诸婆罗门。作如是计。问何因缘故。诸婆罗门。起如是见立如是论。答由教及理故。教如前说。理者谓如有一。为性寻思。乃至广说。以见世间真婆罗门性具戒故。有贪名利及恭敬故。作如是计。

今应问彼。汝何所欲。为唯余种类从父母产生。为婆罗门亦尔耶。若唯余种类者。世间现见诸婆罗门。从母产生。汝谤现事。不应道理。若婆罗门亦尔者。汝先所说。诸婆罗门是最胜种类。刹帝利等是下种类。不应道理。如从母产生。如是造不善业。造作善业。造身语意恶行。造身语意妙行。于现法中受爱不爱果。便于后世生诸恶趣。或生善趣。若三处现前是彼是此。由彼由此。入于母胎从之而生若世间工巧处。若作业处。若善不善。若王若臣。若机捷。若增进满足。若为王顾录以为给侍。若不顾录。若是老病死法。若非老病死法。若修梵住已生于梵世。若复不尔。若修菩提分法。若不修习若悟声闻菩提独觉菩提。无上菩提。若复不尔。又汝何所欲为从胜种类生此名为胜。为由戒闻等耶。若由从胜种类生者。汝论中说。于祠祀中。若戒闻等胜取之为量。如此之言。应不中理。若由戒闻等者。汝先所说。诸婆罗门是最胜类。余是下类。不应道理。如是产生故。作业故。受生故。工巧业处故。增上故。彼所顾录故。梵住故。修觉分故。证菩提故。戒闻胜故。不应道理。是故此论非如理说。

妄计清净论者。谓如有一若沙门若婆罗门。起如是见立如是论。若我解脱心得自在。观得自在。谓于诸天微妙五欲。坚着摄受。嬉戏娱乐。随意受用。是则名得现法涅槃第一清净。又有外道。起如是见立如是论。若有离欲恶不善法。于初静虑得具足住。乃至得具足住第四静虑。是亦名得现法涅槃第一清净。又有外道。起如是见立如是论。若有众生。于孙陀利迦河沐浴支体。所有诸恶皆悉除灭。如于孙陀利迦河。如是于婆湖陀河伽耶河萨伐底河殑伽河等中。沐浴支体。应知亦尔。第一清净。复有外道。计持狗戒以为清净。或持牛戒。或持油墨戒。或持露形戒。或持灰戒。或持自苦戒。或持粪秽戒等。计为清净。谓说现法涅槃外道。及说水等清净外道。作如是计。问彼何因缘。起如是见立如是论。答由教及理故。教如前说。理者谓如有一为性寻思。乃至广说。彼谓得诸纵任自在欲自在观行自在名胜清净。然不如实知纵任自在等相。又如有一计由自苦身故。自恶解脱。或造过恶。过恶解脱。

今应问彼。汝何所欲。若有于妙五欲嬉戏受乐者。为离欲贪。为未离耶。若已离者于世五欲。嬉戏受乐。不应道理。若未离者。计为解脱清净。不应道理。又汝何所欲。诸得初静虑。乃至具足住第四静虑者。彼为已离一切贪欲。为未离耶。若言一切离者。但具足住乃至第四静虑。不应道理。若言未离一切欲者。计为究竟解脱清净。不应道理。又汝何所欲。为由内清净故究竟清净。为由外清净故究竟清净。若由内者。计于河中沐浴而得清净。不应道理。若由外者。内具贪嗔痴等一切垢秽。但除外垢便计为净。不应道理。又汝何所欲。为执受净物故而得清净。为执受不净物故得清净耶。若由执受净物得清净者。世间共见狗等不净。而汝立计执受狗等得清净者。不应道理。若由执受不净物者。自体不净而令他净。不应道理。又汝何所欲。诸受狗等戒者。为行身等邪恶行故而得清净。为行身等正妙行故得清净耶。若由行邪恶行者。行邪恶行而计清净。不应道理。若由正妙行者。持狗等戒。则为唐捐。而计于彼能得清净。不应道理。如是离欲不离欲故。内外故。受净不净故。邪行正行故。不应道理。是故此论非如理说

妄计吉祥论者。谓如有一若沙门若婆罗门。起如是见立如是论。若世间。日月薄蚀。星宿失度。所欲为事。皆不成就。若彼随顺。所欲皆成。为此义故。精勤供养日月星等。祠火诵咒。安置茅草。满盆频螺果。及饷佉等。谓历算者。作如是计。问彼何因缘起如是见立如是论。答由教及理故。教如前说。理者谓如有一为性寻思。乃至广说。彼由获得世间静虑。世间皆谓是阿罗汉。若有欲得自身富乐所祈果遂者。便往请问。然彼不如实知业果相应缘生道理但见世间日月薄蚀。星度行时。尔时众生净不净业果报成熟。彼则计为日月等作。复为信乐此事者。建立显说。

今应问彼。汝何所欲。世间兴衰等事。为是日月薄蚀。星度等作。为净不净业所作耶。若言日等作者。现见尽寿随造福非福业。感此兴衰苦乐等果。不应道理。若净不净业所作者。计日等作。不应道理。如是日等作故。净不净业作故。不应道理。是故此论非如理说。如是十六种异论。由二种门。发起观察。由正道理。推逐观察。于一切种皆不应理

瑜伽师地论卷第七瑜伽师地论卷第八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中有寻有伺等三地之五

复次云何杂染施设建立。谓由三种杂染应知何等为三。一烦恼杂染。二业杂染。三生杂染。

烦恼杂染云何。嗢拖南曰

  自性若分别　　因位及与门
  上品颠倒摄　　差别诸过患

当知烦恼杂染。由自性故。分别故。因故。位故。门故。上品故。颠倒摄故。差别故。过患故。解释应知

烦恼自性者。谓若法生时其相自然不寂静起。由彼起故。不寂静行相续而转。是名略说烦恼自性

烦恼分别者。或立一种。谓由烦恼杂染义故。或分二种。谓见道所断。修道所断。或分三种。谓欲系色系无色系。或分四种。谓欲系记无记。色系无记。无色系无记。或分五种。谓见苦所断。见集所断。见灭所断。见道所断。修道所断。或分六种。谓贪恚慢无明见疑。或分七种。谓七种随眠。一欲贪随眠。二嗔恚随眠。三有贪随眠。四慢随眠。五无明随眠。六见随眠。七疑随眠。或分八种。谓贪恚慢无明疑见及二种取。或分九种。谓九结。一爱结。二恚结。三慢结。四无明结。五见结。六取结。七疑结。八嫉结。九悭结。或分十种。一萨迦耶见。二边执见。三邪见。四见取。五戒禁取。六贪。七恚。八慢。九无明。十疑。或分一百二十八烦恼。谓即上十烦恼。由迷执十二种谛建立。应知

何等名为十二种谛。谓欲界苦谛集谛。色界苦谛集谛。无色界苦谛集谛。欲界增上彼遍智果彼遍智所显灭谛道谛。色界增上彼遍智果彼遍智所显灭谛道谛。无色界增上彼遍智果彼遍智所显灭谛道谛。此中于欲界苦集谛。及于欲界增上灭道谛。具有十烦恼迷执。于色界苦集谛。及于彼增上灭道谛。除嗔有余烦恼迷执。如于色界。于无色界亦尔。于欲界对治修中。有六烦恼迷执。谓除邪见见取戒禁取疑。于色界对治修中。有五烦恼迷执。谓于上六中除嗔。如于色界对治修中。于无色对治修中亦尔。如迷执。障碍亦尔。萨迦耶见者。谓由亲近不善丈夫闻非正法不如理作意故。及由任运失念故。等随观执五种取蕴。若分别不分别染污慧为体。边执见者谓由亲近不善丈夫闻非正法不如理作意故。及由任运失念故。执五取蕴为我性已等随观执为断为常。若分别若不分别染污慧为体。邪见者。谓由亲近不善丈夫闻非正法不如理作意故。拨因拨果或拨作用。坏真实事。唯用分别染污慧为体。见取者。谓由亲近不善丈夫闻非正法不如理作意故。以萨迦耶见边执见邪见及所依所缘所因俱有相应等法。比方他见等随观执为最为上胜妙第一。唯用分别染污慧为体

戒禁取者。谓由亲近不善丈夫闻非正法不如理作意故。即于彼见。彼见随行。若戒若禁。及所依所缘。所因。俱有相应等法。等随观执为清净。为解脱为出离。唯用分别染污慧为体。贪者。谓由亲近不善丈夫闻非正法不如理作意故。及由任运失念故。于外及内可爱境界。若分别不分别。染着为体。恚者。谓由亲近不善丈夫闻非正法不如理作意故。及由任运失念故。于外及内非爱境界。若分别不分别。憎恚为体。慢者谓由亲近不善丈夫闻非正法不如理作意故。及由任运失念故。于外及内高下胜劣。若分别不分别。高举为体。无明者。谓由亲近不善丈夫闻非正法不如理作意故。及由任运失念故。于所知事若分别不分别。染污无知为体。疑者。谓由亲近不善丈夫闻非正法不如理作意故。即于所知事。唯用分别异觉为体

烦恼因者。谓六种因。一由所依故。二由所缘故三由亲近故。四由邪教故。五由数习故。六由作意故。由此六因。起诸烦恼。所依故者。谓由随眠起诸烦恼。所缘故者。谓顺烦恼境界现前。亲近故者。谓由随学不善丈夫。邪教故者。谓由闻非正法。数习故者。谓由先殖数习力势。作意故者。谓由发起不如理作意故诸烦恼生

烦恼位者。略有七种。一随眠位。二缠位。三分别起位。四俱生位。五耎位。六中位。七上位。由二缘故。烦恼随眠之所随眠。一由种子随逐故。二由彼增上事故

烦恼门者。略由二门烦恼所恼谓由缠门及随眠门。缠门有五种。一由不寂静住故。二由障碍善故。三由发起恶趣恶行故。四由摄受现法鄙贱故。五由能感生等苦故。云何随眠门所恼。谓与诸缠作所依故。及能引发生等苦故。又由七门。一切烦恼于见及修能为障碍应知。谓邪解了故。不解了故。解了不解了故。邪解了迷执故。彼因依处故彼怖所生故。任运现行故。

云何烦恼上品相。谓猛利相。及尤重相。此相略有六种。一由犯故。二由生故。三由相续故。四由事故。五由起恶业故。六由究竟故。由犯故者。谓由此烦恼缠故。毁犯一切所有学处。由生故者。谓由此故。生于欲界苦恶趣中。由相续故者。谓贪等行诸根成熟。少年盛壮无涅槃法者。由事故者。谓缘尊重田。若缘功德田。若缘不应行田而起。由起恶业故者谓由此烦恼缠故。以增上适悦心起身语业。由究竟故者。谓此自性上品所摄。最初耎对治道之所断故

烦恼颠倒摄者。谓七颠倒。一想倒。二见倒。三心倒。四于无常常倒。五于苦乐倒。六于不净净倒。七于无我我倒。想倒者。谓于无常苦。不净无我中。起常乐净我妄想分别。见倒者。谓即于彼妄想所分别中。忍可欲乐建立执着。心倒者。谓即于彼所执着中贪等烦恼。当知烦恼略有三种。或有烦恼。是倒根本。或有烦恼。是颠倒体。或有烦恼是倒等流。倒根本者。谓无明。颠倒体者。谓萨迦耶见。边执见一分。见取戒禁取及贪。倒等流者。谓邪见边执见一分。恚慢及疑。此中萨迦耶见。是无我我倒。边执见一分。是无常常倒。见取是不净净倒。戒禁取是于苦乐倒。贪通二种。谓不净净倒。及于苦乐倒

烦恼差别者。多种差别应知。谓结。缚。随眠。随烦恼。缠。暴流。轭。取。系。盖。株杌。垢。常害。箭。所有。根。恶行。漏。匮。烧。恼。有诤。火。炽然。稠林。拘碍。如是等类烦恼差别当知。此中能和合苦故。名为结。令于善行不随所欲故名为缚。一切世间增上种子之所随逐故名随眠。倒染心故名随烦恼。数起现行故名为缠。深难渡故。顺流漂故故名暴流。邪行方便故名为轭。能取自身相续不绝故名为取。难可解脱故名为系。覆真实义故名为盖。坏善稼田故名株杌。自性染污故名为垢。常能为害故名为常害。不静相故远所随故。故名为箭。能摄依事故名所有。不善所依故名为根。邪行自性故名恶行。流动其心故名为漏。能令受用无有厌足故名为匮。能令所欲常有匮乏故名为烧。能引衰损故名为恼。能为斗讼诤竞之因故名有诤。烧所积集诸善根薪故名为火。如大热病故名炽然。种种自身大树聚集故名稠林。能令众生乐着种种妙欲尘故。能障证得出世法故名为拘碍。诸如是等烦恼差别。佛薄伽梵随所增强。于彼种种烦恼门中。建立差别。结者九结。谓爱结等。广说如前。缚者三缚。谓贪嗔痴。随眠者七种随眠。谓欲贪随眠等。广说如前。随烦恼者。三随烦恼。谓贪嗔痴。缠者八缠。谓无惭无愧。惛沉睡眠。掉举恶作。嫉妒悭吝暴流者四暴流。谓欲暴流。有暴流。见暴流。无明暴流。如暴流轭亦尔。取者四取。谓欲取。见取。戒禁取。我语取。系者四系谓贪身系。嗔身系。戒禁取身系。此实执取身系。盖者五盖。谓贪欲盖。嗔恚盖。惛沉睡眠盖。掉举恶作盖。疑盖。株杌者三株杌。谓贪嗔痴。如株杌如是垢常害箭。所有恶行亦尔。根者三不善根。谓贪不善根。嗔不善根。痴不善根。漏者三漏。谓欲漏有漏无明漏。匮者三匮。谓贪嗔痴。如匮如是烧恼有诤。火炽然稠林亦尔拘碍者有五拘碍。一顾恋其身。二顾恋诸欲。三乐相杂住。四阙随顺教。五得微少善便生喜足。

烦恼过患者。当知。诸烦恼有无量过患。谓烦恼起时先恼乱其心。次于所缘发起颠倒。令诸随眠皆得坚固。令等流行相续而转。能引自害。能引他害。能引俱害。生现法罪。生后法罪。生俱法罪。令受彼生身心忧苦。能引生等种种大苦。能令相续远涅槃乐。能令退失诸胜善法。能令资财衰损散失。能令入众不得无畏悚惧无威。能令鄙恶名称流布十方。常为智者之所诃毁。令临终时生大忧悔。令身坏已堕诸恶趣生那落迦中。令不证得自胜义利。如是等过无量无边

云何业杂染。嗢拖南曰

  自性若分别　　因位及与门
  增上品颠倒　　差别诸过患

当知业杂染。由自性故。分别故。因故。位故。门故。上品故。颠倒故。差别故。过患故。解释应知。业自性云何。谓若法生时。造作相起。及由彼生故。身行语行于彼后时造作而转。是名业自性。

业分别云何。谓由二种相应知。一由补特伽罗相差别故。二由法相差别故。此复二种。即善不善十种业道。所谓杀生离杀生。不与取离不与取。欲邪行离欲邪行。妄语离妄语。离间语离离间语。粗恶语离粗恶语。绮语离绮语。贪欲离贪欲。嗔恚离嗔恚。邪见离邪见。

补特伽罗相差别建立者。谓如经言。诸杀生者。乃至广说。杀生者者。此是总句。最极暴恶者。谓杀害心正现前故。血涂其手者。谓为成杀身相变故。害极害执者。谓断彼命故。解支节故。计活命故。无有羞耻者。谓自罪生故。无有哀愍者。谓引彼非爱故。有出家外道名曰无系。彼作是说。百踰缮那内所有众生。于彼律仪若不律仪。为治彼故。说如是言一切有情所。即彼外道复作是说。树等外物亦有生命。为治彼故。说如是言真实众生所。此即显示真实福德远离对治。及显示不实福德远离对治。如是所说诸句。显示加行杀害乃至极下捃多蚁等诸众生所者。此句显示无择杀害。于杀生事若未远离者。此显遇缘容可出离。谓乃至未远离。来名杀生者。又此诸句略义者。谓为显示杀生相貌。杀生作用。杀生因缘。及与杀生事用差别。又略义者。谓为显示杀生如实。杀生差别。杀所杀生。名杀生者。又此诸句显能杀生补特伽罗相。非显杀生法相

复次不与取者者。此是总句。于他所有者。谓他所摄财谷等事。若在聚落者。谓即彼事于聚落中。若积集若移转。若闲静处者。谓即彼事于闲静处。若生若集。或复移转。即此名为可盗物数者。谓所不与不舍不弃物。若自执受者。谓执为己有。不与而取者。谓彼或时资具阙少执为己有。不与而乐者。谓乐受行偷盗事业。于所不与不舍不弃而生希望者。谓劫盗他。欲为己有。若彼物主。非先所与。如酬债法。是名不与。若彼物主。于彼取者而不舍与。是名不舍。若彼物主。于诸众生不随所欲受用而弃。是名不弃。自为而取者。谓不与而取故。及不与而乐故。饕餮而取者。谓所不与不舍不弃而希望故。不清而取者。谓于所竞物为他所胜不清雪故。不净而取者。谓虽胜他而为过失。垢所染故。有罪而取者。谓能摄受现法后法非爱果故。于不与取若未远离者。如前杀生相说。应知所余业道亦尔。此中略义者。谓由盗此故。成不与取。若于是处。如其差别如实劫盗。由劫盗故。得此过失。是名总义。又此中亦显不与取者相非不与取法相。当知余亦尔

复次欲邪行者者。此是总句。于诸父母等所守护者。犹如父母于己处女。为适事他故。勤加守护。时时观察。不令与余共为鄙秽。若彼没已。复为至亲兄弟姊妹之所守护。此若无者。复为余亲之所守护。此若无者。恐损家族。便自守护。或彼舅姑。为自儿故勤加守护。有治罚者。谓诸国王。若执理者。以治罚法。而守护故。有障碍者。谓守门者。所守护故。此中略显未适他者三种守护。一尊重至亲眷属自己之所守护。二王执理家之所守护。三诸守门者之所守护。他妻妾者。谓已适他。他所摄者。谓即未适他。为三守护之所守护。若由凶诈者。谓矫乱已。而行邪行。若由强力者。谓对父母等。公然强逼。若由隐伏者。谓不对彼。窃相欣欲而行欲行者。谓两两交会。即于此事非理欲心而行邪行者。谓于非道非处非时。自妻妾所。而为罪失。此中略义者。谓略显示若彼所行。若行差别。若欲邪行。应知

复次诸妄语者者。此是总句。若王者。谓王家。若彼使者谓执理家。若别者谓长者居士。若众者谓彼聚集。若大集中者。谓四方人众聚集处。若已知者。谓随前三所经语言。若已见者。谓随曾见所经语言。若由自因者。谓或因怖畏。或因味着。如由自因。他因亦尔。因怖畏者。谓由怖畏杀缚治罚黜责等故。因味著者。谓为财谷珍宝等故。知而说妄语者。谓覆想欲见而说语言。此中略义者。谓依处故。异说故。因缘故。坏想故。而说妄语应知

复次离间语者者。此是总句。若为破坏者。谓由破坏意乐故。闻彼语已向此宣说闻此语已向彼宣说者。谓随所闻顺乖离语。破坏和合者。谓能生起喜别离故。随印别离者。谓能乖违喜更生故。喜坏和合者。谓于已生喜别离中心染污故。乐印别离者。谓于乖违喜更生中心染污故。说能离间语者。谓或不闻或他方便故。此中略义者。谓略显示离间意乐。离间未坏方便。离间已坏方便。离间染污心。及他方便应知

复次粗恶语者者。此是总句。此中尸罗支所摄故。名语无扰动。文句美滑故。名悦耳。增上欲解所发起故。非假伪故。非谄媚故名为称心。不增益故。应顺时机引义利故。名为可爱。趣涅槃宫故名先首。文句可味故名美妙。善释文句故名分明。显然有趣故名易可解了。摄受正法故名可施功劳。离爱味心之所发起故名无所依止。不过度量故名非可厌逆。相续广大故名无边无尽。又从无扰动语。乃至无边无尽语。应知略摄为三种语。一尸罗律仪所摄语。谓一种。二等欢喜语。谓三种。三说法语。谓其所余。即此最后又有三种应知。一所趣圆满语谓初一。二文词圆满语谓次二。三方便圆满语谓其所余。又于未来世可爱乐故名可爱语。于过去世可爱乐故名可乐语。于现在世事及领受可爱乐故。名可欣语及可意语。应知即等欢喜语名无量众生可爱可乐可欣可意语。即说法语名三摩呬多语。即尸罗支所摄语。名由无悔等渐次能引三摩地语。此中毒螫语者。谓毁摩他言纵嗔毒故。粗犷语者。谓恼乱他言发苦触故。所余粗恶语。翻前白品应知

复次诸绮语者者。此是总句。于邪举罪时。有五种。邪举罪者言不应时故名非时语者。言不实故名非实语者。言引无义故名非义语者。言粗犷故名非法语者。言挟嗔恚故名非静语者。又于邪说法时。不正思审而宣说故。名不思量语。为胜听者而宣说故名不静语。非时而说前后义趣不相属故名杂乱语。不中理因而宣说故名非有教语。引不相应为譬况故名非有喻语。显秽染故名非有法语。又于歌笑嬉戏等时。及观舞乐戏笑俳说等时。有引无义语。此中略义者。谓显如前说三时绮语

复次诸贪欲者者。此是总句。由猛利贪者。谓于他所有。由贪增上。欲为己有。起决定执故。于财者。谓世俗财类。具者。谓所受用资具。即此二种总名为物。凡彼所有定当属我者。此显贪欲生起行相。此中略义者。当知显示贪欲自性贪欲所缘贪欲行相

复次嗔恚心者者。此是总句。恶意分别者。谓于他有情所。由嗔恚增上力。欲为损害起决定执故。当杀者。谓欲伤害其身。当害者。谓欲损恼其身。当为衰损者。谓欲令彼财物损耗。彼当自获种种忧恼者。谓欲令彼自失财物。此中略义如前应知

复次诸邪见者者。此是总句。起如是见者。此显自心忍可欲乐当所说义。立如是论者。此显授他当所说义。无有施与无有爱养。无有祠祀者。谓由三种意乐非拨施故。一财物意乐。二清净意乐。三祀天意乐。供养火天名为祠祀。又显非拨戒修所生善能治所治故。及显非拨施所生善能治所治故说如是言。无有妙行无有恶行。又显非拨此三种善能治所治所得果故。说如是言。无有妙行恶行二业果及异熟。又显非拨流转依处缘故。说如是言。无有此世。无有他世。又显非拨彼所托缘故。及非拨彼种子缘故。说如是言。无母无父。又显非拨流转士夫故。说如是言。无有化生有情。又显非拨流转对治还灭故。说如是言。世间无有真阿罗汉。乃至广说。已趣各别烦恼寂静故名正至。于诸有情远离邪行行无倒行故名正行。因时名此世间。果时名彼世间。自士夫力之所作故。名为自然。通慧者。谓第六。已证者谓由见道。具足者谓由修道。显示者自所知故。为他说故。我生已尽等。当知如余处分别。此中略义者。谓显示谤因谤果。诽谤功用谤真实事。功用者。谓殖种功用。任持功用。来往功用。感生业功用。又有略义差别。谓显示诽谤若因若果。若流转缘。若流转士夫。及显诽谤彼对治还灭。又诽谤流转者。应知谤因不谤自相。谤还灭者。应知谤彼功德。不谤补特伽罗

复次白品一切翻前应知。所有差别我今当说。谓翻欲邪行中。诸梵行者者。此是总句。当知此由三种清净而得清净。一时分清净。二他信清净。三正行清净。尽寿行故。久远行故者。此显时分清净。诤处雪故名清。无违越故名净。此二总显他信清净。此中或有清而非净。应作四句。初句者。谓实毁犯于诤得胜。第二句者。谓实不犯于诤堕负。第三句者。谓实不犯于诤得胜。第四句者。谓实毁犯于诤堕负。不以爱染身触母邑故。名远离生臭。不行两两交会鄙事故。名远离淫欲。不以余手触等方便而出不净故。名非鄙爱愿受持梵行故。名远离猥法。如是名为正行清净具足。当知略义即在此中。又翻妄语中。可信者。谓可委故。可委者。谓可寄托故。应可建立者。谓于彼彼违诤事中应可建立为正证故。无有虚诳者。于委寄中不虚诳故。不欺誷故。此中略义者。谓显三种摄受。一欲解摄受。二保任摄受。三作用摄受

复次法相差别建立者。谓即杀生离杀生等。云何杀生。谓于他众生起杀欲乐。起染污心。若即于彼起杀方便。及即于彼杀究竟中所有身业。云何不与取。谓于他摄物。起盗欲乐。起染污心。若即于彼起盗方便。及即于彼盗究竟中所有身业。云何欲邪行。谓于所不应行非道非处非时。起习近欲乐。起染污心。若即于彼起欲邪行方便。及于欲邪行究竟中所有身业。云何妄语。谓于他有情起覆想说欲乐。起染污心。若即于彼起伪证方便。及于伪证究竟中所有语业。云何离间语。谓于他有情起破坏欲乐起染污心。若即于彼起破坏方便。及于破坏究竟中所有语业。云何粗恶语。谓于他有情。起粗语欲乐。起染污心。若即于彼起粗语方便。及于粗语究竟中所有语业。云何绮语。谓起绮语欲乐。起染污心。若即于彼起不相应语方便。及于不相应语究竟中所有语业。云何贪欲。谓于他所有。起己有欲乐起染污心。若于他所有。起己有欲乐决定方便。及于彼究竟中所有意业。云何嗔恚。谓于他起害欲乐。起染污心。若于他起害欲乐决定方便。及于彼究竟中所有意业。云何邪见。谓起诽谤欲乐。起染污心。若于起诽谤欲乐决定方便。及于彼究竟中所有意业。云何离杀生。谓于杀生。起过患欲解。起胜善心。若于彼起静息方便。及于彼静息究竟中所有身业。如离杀生。如是离不与取。乃至离邪见。应知亦尔。此中差别者。谓于不与取起过患欲解。乃至于邪见起过患欲解。起胜善心。若于彼起静息方便。及于彼静息究竟中所有意业。如是十种。略为三种。所谓身业语业意业。即此三种广开十种应知。

业因云何。应知有十二种相。一贪二嗔。三痴四自。五他六随他转。七所爱味八怖畏。九为损害十戏乐。十一法想十二邪见。

业位云何。应知略说有五种相。谓耎位中位上位生位习气位。由耎不善业故。生傍生中。由中不善业故。生饿鬼中。由上不善业故。生那落迦中。由耎善业故。生人中。由中善业故。生欲界天中。由上善业故。生色无色界。何等名为耎位不善业耶。谓以耎品贪嗔痴为因缘故。何等名为中位不善业耶。谓以中品贪嗔痴为因缘故。何等名为上位不善业耶。谓以上品贪嗔痴为因缘故。若诸善业。随其所应。以无贪无嗔无痴为因缘。应知。何等生位业。谓已生未灭。现在前业。何等习气位业。谓已生已灭。不现前业

瑜伽师地论卷第八瑜伽师地论卷第九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中有寻有伺等三地之六

复次业门云何。此略有二种。一与果门。二损益门。与果门者。有五种应知。一与异熟果。二与等流果。三与增上果。四与现法果。五与他增上果。与异熟果者。谓于杀生亲近修习多修习故。于那洛迦中受异熟果。如于杀生。如是于余不善业道亦尔。是名与异熟果。与等流果者。谓若从彼出来生此间。人同分中寿量短促。资财匮乏。妻不贞良。多遭诽谤。亲友乖离。闻违意声。言不威肃。增猛利贪。增猛利嗔。增猛利痴。是名与等流果。与增上果者。谓由亲近修习多修习诸不善业增上力故。所感外分光泽鲜少。果不充实果多朽败。果多变改。果多零落。果不甘美。果不恒常。果不充足。果不便宜。空无果实。当知善业与此相违。与现法果者。有二因缘。善不善业与现法果。一由欲解故。二由事故。应知欲解复有八种。一有顾欲解。二无顾欲解。三损恼欲解。四慈悲欲解。五憎害欲解。六净信欲解。七弃恩欲解。八知恩欲解。有顾欲解。造不善业受现法果者。谓如有一由增上欲解。顾恋其身。顾恋财物。顾恋诸有。造不善业。无顾欲解。所造善业受现法果者。谓如有一以增上欲解。不顾其身。不顾财物。不顾诸有。造作善业。损恼欲解。造不善业受现法果者。谓如有一于他有情补特伽罗。以增上品损恼欲解。造不善业。慈悲欲解。所造善业受现法果者。谓如有一于他有情补特伽罗。以增上品慈悲欲解造作善业。憎害欲解。造不善业受现法果者。谓如有一于佛法僧。及随一种尊重处事。以增上品憎害欲解。造不善业。净信欲解。所造善业受现法果者。谓如有一于佛法僧等。以增上品净信欲解。造作善业。弃恩欲解。造不善业受现法果者。谓如有一于父母所。及随一种恩造之处。以增上品背恩欲解。欺诳欲解。酷暴欲解。造不善业。知恩欲解。所造善业受现法果者。谓如有一于父母等。以增上品知恩欲解。报恩欲解。所作善业。由事故者。若不善业。于五无间及彼同分中。亦有受现法果者。五无间业者。一害母二害父。三害阿罗汉。四破僧。五于如来所恶心出血。无间业同分者。谓如有一于阿罗汉尼及于母所。行秽染行。打最后有菩萨。或于天庙衢路市肆。立杀羊法。流行不绝。或于寄托得极委重亲友同心耆旧等所。损害欺诳。或于有苦贫穷困乏无依无怙。为作归依施无畏已。后返加害。或复逼恼。或劫夺僧门。或破坏灵庙。如是等业名无间同分。若诸善业。由事重故。受现法果者。谓如有一母无正信。劝进开化安置建立于具信中。如无正信于具信中。如是犯戒于具戒中。悭吝于具舍中。恶慧于具慧中亦尔。如母父亦尔。或于起慈定者供养承事。如于起慈定者。如是于起无诤定。灭尽定。预流果。阿罗汉果。供养承事亦尔。又亲于佛所供养承事。如于佛所如是于学无学僧所亦尔。若即于此尊重事中。与上相违。由损害因缘。起不善业。受现法果。与他增上果者。谓亦由受现法果业。犹如如来所住国邑必无疾疫灾横等起。佛神力故。无量众生无疾无疫。无有灾横。得安乐住。如佛世尊。如是。转轮圣王及住慈定菩萨亦尔。若诸菩萨以大悲心。观察一切贫穷困苦业天所恼众生。施以饮食财谷库藏。皆令充足。由此因缘。彼诸众生得安乐住。如是等类是他增上所生现法受业应知。损益门者。谓于诸有情。依十不善业道。建立八损害门。何等为八。一损害众生。二损害财物。三损害妻妾。四虚伪友证损害。五损害助伴。六显说过失损害。七引发放逸损害。八引发怖畏损害。与此相违。依十善业道。建立八利益门应知。

业增上云何。谓猛利极重业。当知此业由六种相。一加行故。二串习故。三自性故。四事故。五所治一类故。六所治损害故。加行故者。谓如有一由极猛利贪嗔痴缠。及极猛利无贪无嗔无痴加行。发起诸业。串习故者。谓如有一于长夜中。亲近修习若多修习不善善业。自性故者。谓于绮语。粗恶语为大重罪。于粗恶语。离间语为大重罪。于离间语。妄语为大重罪。于欲邪行。不与取为大重罪。于不与取。杀生为大重罪。于贪欲嗔恚为大重罪。于嗔恚邪见为大重罪。又于施性戒性无罪为胜。于戒性修性无罪为胜。于闻性思性无罪为胜。如是等。事故者。谓如有一于佛法僧及随一种尊重处事。为损为益名重事业。所治一类故者。谓如有一一向受行诸不善业。乃至寿尽无一时善。所治损害故者。谓如有一断所对治诸不善业。令诸善业离欲清净。

业颠倒云何。此有三种应知。一作用颠倒。二执受颠倒。三喜乐颠倒。作用颠倒者。谓如有一于余众生思欲杀害。误害余者。当知此中虽有杀生。无杀生罪。然有杀生种类杀生相似同分罪生。若不误杀其余众生。然于非情加刀杖已谓我杀生。当知此中无有杀生。无杀生罪。然有杀生种类杀生相似同分罪生。如杀生业道。如是不与取等一切业道。随其所应作用颠倒应知。执受颠倒者。谓如有一起如是见立如是论。无施无爱乃至广说。一切邪见。彼作是执。毕竟无有能杀所杀若不与取乃至绮语。亦无施与受斋修福受学尸罗。由此因缘。无罪无福。又如有一起如是见立如是论。若有众生。憎梵憎天。憎婆罗门。若彼憎恶唯应杀害。杀彼因缘唯福无罪。又于彼所起不与取乃至绮语唯获福德。无有非福。喜乐颠倒者。谓如有一不善业道现前行时如游戏法极为喜乐

业差别云何。谓有作业有不作业。有增长业有不增长业。有故思业有不故思业。如是定异熟业不定异熟业。异熟已熟业。异熟未熟业。善业不善业无记业。律仪所摄业。不律仪所摄业。非律仪非不律仪所摄业。施性业戒性业修性业。福业非福业不动业。顺乐受业。顺苦受业。顺不苦不乐受业。顺现法受业。顺生受业。顺后受业。过去业未来业现在业。欲系业色系业无色系业。学业无学业。非学非无学业。见所断业修所断业无断业。黑黑异熟业。白白异熟业。黑白黑白异熟业。非黑非白无异熟业能尽诸业。曲业。秽业。浊业。清净业。寂静业。作业者。谓若思业。若思已所起身业语业。不作业者。谓若不思业。若不思已不起身业语业。增长业者。谓除十种业。何等为十。一梦所作业。二无知所作业。三无故思所作业。四不利不数所作业。五狂乱所作业。六失念所作业。七非乐欲所作业。八自性无记业。九悔所损业。十对治所损业。除此十种。所余诸业名为增长。不增长业者。谓即所说十种业。故思业者。谓故思已若作业若增长业。不故思业者。谓非故思所作业。顺定受业者。谓故思已若作若增长业。顺不定受业者。谓故思已作而不增长业。异熟已熟业者。谓已与果业。异熟未熟业者。谓未与果业。善业者。谓无贪无嗔无痴为因缘业。不善业者。谓贪嗔痴为因缘业。无记业者。谓非无贪无嗔无痴为因缘。亦非贪嗔痴为因缘业。律仪所摄业者。谓或别解脱律仪所摄业。或静虑等至果断律仪所摄业。或无漏律仪所摄业。不律仪所摄业者。谓十二种不律仪类所摄诸业。何等十二不律仪类。一屠羊。二贩鸡。三贩猪。四捕鸟。五罝兔。六盗贼七魁脍。八守狱九谗刺。十断狱十一缚象。十二咒龙。非律仪非不律仪所摄业者。谓除三种律仪业及不律仪类业。所余一切善不善无记业施性业者。谓若因缘。若等起。若依处。若自性。彼因缘者。谓以无贪无嗔无痴为因缘。彼等起者。谓无贪无嗔无痴俱行能舍所施物。能起身语业思。彼依处者。谓以所施物及受者为依处。彼自性者。谓思所起能舍所施物身业语业。如施性业。如是戒性业修性业。随其所应应知。此中戒性业因缘等起如前。自性者。谓律仪所摄身语业等。依处者。谓有情非有情数物。修性因缘者。谓三摩地因缘。即无贪无嗔无痴。等起者。谓彼俱行引发定思。自性者谓三摩地。依处者谓十方无苦无乐等有情界。又具施戒修者。所有相貌应知。一切如余处说。福业者。谓感善趣异熟。及顺五趣受善业。非福业者。谓感恶趣异熟。及顺五趣受不善业。不动业者。谓感色无色界异熟。及顺色无色界受善业。顺乐受业者。谓福业及顺三静虑受不动业。顺苦受业者。谓非福业。顺不苦不乐受业者。谓能感一切处阿赖耶识异熟业。及第四静虑以上不动业。顺现法受业者。谓能感现法果业。顺生受业者。谓能感无间生果业。顺后受业者。谓能感彼后生果业。过去业者。谓住习气位。或已与果。或未与果业。未来业者。谓未生未灭业。现在业者。谓已造已思未谢灭业。欲系业者。谓能感欲界异熟。堕欲界业。色系业者。谓能感色界异熟。堕色界业。无色系业者。谓能感无色界异熟。堕无色界业。学业者。谓若异生若非异生。学相续中所有善业。无学业者。谓无学相续中所有善业。非学非无学业者。谓除前二。余相续中所有善不善无记业。见所断业者。谓受恶趣不善等业。修所断业者。谓受善趣善不善无记业。无断业者。谓世出世诸无漏业。黑黑异熟业者。谓非福业。白白异熟业者。谓不动业。黑白黑白异熟业者。谓福业有不善业为恶对故。由约未断非福业时所有福业而建立故。非黑非白无异熟业能尽诸业者。谓出世间诸无漏业。是前三业断对治故。曲业者。谓诸外道善不善业。秽业者。谓即曲业亦名秽业。又有秽业。谓此法异生于圣教中。颠倒见者。住自见取者。邪决定者。犹预觉者所有善不善业。浊业者。谓即曲业秽业。亦名浊业。又有浊业。谓此法异生于圣教中。不决定者。犹预觉者。所有善不善业。又有差别。唯于外道法中。有此三业。由邪解行义故名曲。由此为依。能障所起诸功德义故名秽。能障通达真如义故。名浊应知。清净业者。谓此法异生于圣教中。正决定者。不犹预觉者。所有善业。寂静业者。谓住此法非异生者。一切圣者所有学无学业

业过患云何。当知略说有七过患。谓杀生者。杀生为因。能为自害。能为他害。能为俱害。生现法罪。生后法罪。生现法后法罪。受彼所生身心忧苦。云何能为自害。谓为害生发起方便。由此因缘。便自被害。若被系缚。若遭退失。若被诃毁。然彼不能损害于他。云何能为他害。谓即由此所起方便。能损害他。由此因缘。不自被害乃至诃毁。云何能为俱害。谓即由此所起方便。能损害他。由此因缘。复被他害。若被系缚乃至诃毁。云何生现法罪。谓如能为自害。云何生后法罪。谓如能为他害。云何生现法后法罪。谓如能为俱害。云何受彼所生身心忧苦。谓为害生发起方便。而不能成六种过失。又不能办随欲杀事。彼由所欲不会因缘。便受所生身心忧苦。又有十种过患。依犯尸罗。如经广说应知。又有四种不善业道。及饮诸酒以为第五。依犯事善男学处。佛薄伽梵说多过患。应知。广说如阐地迦经。

云何生杂染。谓由四种相应知。一由差别故。二由艰辛故。三由不定故。四由流转故。

生差别者。当知复有五种。一界差别。二趣差别。三处所差别。四胜生差别。五自身世间差别。界差别者。谓欲界及色无色界生差别。趣差别者。谓于五趣四生差别。处所差别者。谓欲界中有三十六处生差别。色界中有十八处生差别。无色界中有四处生差别。如是总有五十八生。胜生差别者。谓欲界人中。有三胜生。一黑胜生生。谓如有一生旃荼罗家。若卜羯娑家。若造车家。若竹作家。若生所余下贱贫穷乏少财物饮食等家。如是名为人中薄福德者二白胜生生。谓如有一生刹帝利大富贵家。若婆罗门大富贵家。若诸长者大富贵家。若生所余豪贵大富多诸财谷库藏等家。如是名为人中胜福德者。三非黑非白胜生生。谓如有一非前二种生处中家者。又欲界天中。亦有三种胜生。一非天生。二依地分生。三依虚空宫殿生。又色界中有三种胜生。一者异生无想天生。二者有想天生。三者净居天生。又无色界中有三胜生。一无量想天生。二无所有想天生。三非想非非想天生。自身世间差别者。谓于十方无量世界中。有无量有情无量生差别应知

生艰辛者。如薄伽梵说。汝等长时驰骋生死。身血流注过四大海。所以者何。汝等长夜或生象马驼驴。牛羊鸡鹿等众同分中。汝等于彼。多被斫截身诸支分。令汝身血极多流注。如于象等众同分中。人中亦尔。又复汝等于长夜中。丧失无量父母兄弟姊妹亲属。又复丧失种种财宝诸资生具。令汝洟泪极多流注。如前血量。如血洟泪。如是当知。所饮母乳其量亦尔。如是等类生艰辛苦。无量差别应知。

生不定者。如薄伽梵说。假使取于大地所有一切草木根茎枝叶等。截为细筹。如四指量。计算汝等长夜展转所经父母。如是众生曾为我母。我亦长夜曾为彼母。如是众生曾为我父。我亦长夜曾为彼父。如是算计。四指量筹速可穷尽。而我不说汝等长夜所经父母其量边际。又复说言。汝等有情。自所观察。长夜展转。成就第一极重忧苦。今得究竟。汝等当知。我亦曾受如是大苦。如苦乐亦尔。又复说言。我观大地。无少处所可得汝等长夜于此处所未曾经受无量生死。又复说言。我观世间有情。不易可得长夜流转不为汝等若母若父。兄弟姊妹。若轨范师。若亲教师。若余尊重。若等尊重。又如说言。若一补特伽罗于一劫中所受身骨。假使有人。为其积集不烂坏者。其聚量高王舍城侧广博胁山。

云何生流转。谓自身所有缘起。当知此即说为流转。云何缘起。嗢拖南曰

  体门义差别　　次第难释词
  缘性分别缘　　摄诸经为后

云何缘起体。若略说由三种相建立缘起。谓从前际中际生。从中际后际生。中际生已若趣流转。若趣清净究竟。云何从前际中际生。中际生已复趣流转。谓如有一不了前际无明所摄。无明为缘。于福非福及与不动身语意业。若作若增长。由此随业识。乃至命终流转不绝。能为后有相续识因。此识将生果时。由内外贪爱正现在前。以为助伴。从彼前际既舍命已。于现在世自体得生。在母腹中。以因识为缘。相续果识。前后次第而生。乃至羯罗蓝等位差别而转于母胎中。相续果识与名色俱。乃至衰老渐渐增长。尔时感生受业名已与异熟果。又此异熟识。即依名色而转。由必依托六依转故。是故经言。名色缘识。俱有依根曰色。等无间灭依根曰名。随其所应为六识所依。依止彼故。乃至命终。诸识流转。又五色根。若根所依大种。若根处所。若彼能生大种曰色。所余曰名。由识执受。诸根堕相续法。方得流转。故此二种依止于识。相续不断。由此道理。于现在世。识缘名色。名色缘识。犹如束芦。乃至命终。相依而转。如是名为从前际中际诸行缘起生。中际生已流转不绝。当知此中依胎生者。说流转次第。若卵生湿生者。除处母胎。余如前说若于有色有情聚中。谓欲色界受化生者。诸根决定圆满而生。与前差别。若于无色界。以名为依。及色种子为依。识得生起。以识为依名及色种子转。从此种子。色虽断绝。后更得生。与前差别。又由福业生欲界人天。由非福业生诸恶趣。由不动业生色无色界

云何不生。由不生故。趣清净究竟。云何从中际后际诸行缘起生。谓中际已生补特伽罗。受二种先业果。谓受内异熟果。及境界所生受增上果。此补特伽罗或闻非正法故。或先串习故。于二果愚。由愚内异熟果故。于后有生苦不如实知。由迷后有。后际无明增上力故。如前于诸行若作若增长。由此新所作业故。说此识。名随业识。即于现法中。说无明为缘故行生。行为缘故识生。此识于现法中名为因识。能摄受后生果识故。又总依一切识。说名六识身。又即此识。是后有名色种子之所随逐。此名色种子。是后有六处种子之所随逐。此六处种子是后有触种子之所随逐。此种子触是后有受种子之所随逐。如是总名于中际中后有引因。应知由此能引识。乃至受一期身。故由先异熟果愚。引后有已。又由第二境界所生受果愚故。起缘境界受爱。由此爱故。或发欲求。或发有求。或执欲取。或执见戒及我语取。由此爱取和合资润。令前引因转名为有。即是后有生因所摄。从此无间命既终已。随先引因。所引识等。受最为后。此诸行生或渐或顿。如是于现法中。无明触所生受为缘故爱。爱为缘故取。取为缘故有。有为缘故生。生为缘故。老病死等诸苦差别。或于生处次第现前。或复种子随逐。应知如是于中际中。无明缘行等。受缘爱等。为因缘故。后际诸行生

复有先集资粮。于现法中从他闻音。及于二果诸行。若于彼因彼灭。彼趣灭行。如理作意。由此如理作意为缘。正见得生。从此次第得学无学清净智见。由此智见。无明及爱。永断无余。由此断故。于彼所缘。不如实知。无明触所生受。亦复永断。由此断故。永离无明。于现法中。证慧解脱。若于无明触所生受相应心中所有贪爱。即于此心得离系故。贪爱永灭。于现法中。证心解脱。设彼无明不永断者。依于识等受最为后。所有诸行。后际应生。由无明灭故。更不复起。得无生法。是故说言无明灭故行灭。次第乃至。异熟生触灭故异熟生受灭。于现法中。无明灭故无明触灭。无明触灭故无明触所生受灭。无明触所生受灭故爱灭。爱灭故如前得无生法。由此故说取等恼最为后诸行永灭。如是于现法中。诸行不转。由不转故。于现法中。于有余依界。证得现法涅槃。彼于尔时唯余清净识缘名色。名色缘识。乃至有识身在。恒受离系受。非有系受。此有识身乃至先业所引寿量。恒相续住。若寿量尽。便舍识所持身。此命根后所有命根。无余永灭更不重熟。又复此识与一切受。任运灭故。所余因缘先已灭故。不复相续。永灭无余。是名无余依涅槃界究竟寂静处。亦名趣求涅槃者。于世尊所。梵行已立。究竟涅槃。如是已说由三种相建立缘起。谓从前际中际生。从中际后际生。又于中际。若流转若清净。是名缘起体性

缘起门云何。谓依八门缘起流转。一内识生门。二外稼成熟门。三有情世间死生门。四器世间成坏门。五食任持门。六自所作业增上势力受用随业所得爱非爱果门。七威势门。八清净门。

缘起义云何。谓离有情义。是缘起义。于离有情。复无常义。是缘起义。于无常。复暂住义。是缘起义。于暂住。复依他义。是缘起义。于依他。离作用义。是缘起义。于离作用复因果相续不断义。是缘起义于因果相续不断。复因果相似转义。是缘起义。于因果相似转。复自业所作义。是缘起义。问为显何义。建立缘起耶。答为显因缘所摄染污清净义故。

缘起差别云何。谓于前际无知等。如经广说。于前际无知云何。谓于过去诸行。起不如理分别。谓我于过去为曾有耶。为曾无耶。曾何体性。曾何种类。所有无知。于后际无知云何。谓于未来诸行。起不如理分别。谓我于未来为当有耶为当无耶。当何体性。当何种类。所有无知。于前后际无知云何。谓于内起不如理犹豫。谓何等是我。我为何等。今此有情。从何所来。于此没已。当往何所。所有无知。于内无知云何。谓于各别诸行。起不如理作意。谓之为我。所有无知。于外无知云何。谓于外非有情数诸行。起不如理作意。谓为我所。所有无知。于内外无知云何。谓于他相续诸行。起不如理分别。谓怨亲中所有无知。于业无知云何。谓于诸业。起不如理分别。谓有作者。所有无知。于异熟无知云何。谓于异熟果所摄诸行。起不如理分别。谓有受者。所有无知。于业异熟无知云何。谓于业及果。起不如理分别。所有无知。于佛无知云何。谓于佛菩提。或不思惟。或邪思惟。或由放逸。或由疑惑。或由毁谤。所有无知。于法无知云何。谓于正法善说性。或不思惟。或邪思惟。或由放逸。或由疑惑。或由毁谤。所有无知。于僧无知云何。谓于僧正行。或不思惟。或邪思惟。或由放逸或由疑惑。或由毁谤。所有无知。于苦无知云何。谓于苦是苦性。或不思惟。或邪思惟。或由放逸。或由疑惑。或由毁谤。所有无知。如于苦。当知于集灭道无知亦尔。于因无知云何。谓起不如理分别。或计无因。或计自在世性士夫中间等不平等因。所有无知。如于因无知。于从因所生诸行亦尔。又彼无罪故名善。有罪故名不善。有利益故名应修习。无利益故名不应修习。黑故名有罪。白故名无罪。杂故名有分。于六触处如实通达无知云何。谓增上慢者。于所证中。颠倒思惟。所有无知。如是略说十九种无知

复有七种无知。一世愚。二事愚。三移转愚。四最胜愚。五真实愚。六染净愚。七增上慢愚。前十九无知。今七无知。相摄云何。谓初三无知摄初一。次三无知摄第二。次三无知摄第三。次三无知摄第四。次四无知摄第五。次二无知摄第六。后一无知摄第七

复有五种愚。一义愚。二见愚。三放逸愚。四真实义愚。五增上慢愚。前十九愚。今五种愚。相摄云何。谓见愚。摄前六及于因所生法无知。放逸愚。摄于业异熟俱无知。真实义愚。摄于佛等乃至道谛无知。增上慢愚摄最后无知。当知义愚通摄一切。复次。无知。无见。无有现观。黑闇。愚痴。及无明闇。如是六种无明差别。随前所说七无知事。次第应知。于后二无知事。总合为一。起此最后无明黑闇。复有差别。谓闻思修所成三慧所治差别。如其次第。说前三种。即此所治软中上品差别。说后三种。如是所治差别故。自性差别故。建立六种差别应知。身行云何。谓身业。若欲界若色界。在下名福非福。在上名不动。语行云何。谓语业。余如前应知。意行云何。谓意业。若在欲界。名福非福。在上二界。唯名不动。眼识云何。谓于当来依止眼根。了别色境识。所有福非福不动行所熏发种子识。及彼种子所生果识。如眼识如是。乃至意识。应知亦尔。由所依及境界所起了别差别应知。此于欲界具足六种。色界唯四。无色界唯一。受蕴云何。谓一切领纳种类。想蕴云何。谓一切了像种类。行蕴云何。谓一切心所造作意业种类。识蕴云何谓一切了别种类。如是诸蕴。皆通三界。四大种云何。谓地水火风界。此皆通二界。四大种所造色云何。谓十色处。及法处所摄色。欲界具十及法处所摄假色。色界有八及法处所摄色。然非一切。此亦二种。谓识种子所摄受种子名色。及于彼所生果名色

眼处云何。谓眼识所依净色。由此于色已见现见当见。如眼处如是。乃至意处。随其所应。尽当知。于一切处。应说三时业用差别。此亦二种。谓名色种子所摄受种子六处。及彼所生果六处。五在欲色界。第六通三界。眼触云何。谓三和所生。能取境界净妙等义。如是余触各随别境说相应知。此复二种。谓六处种子所摄受种子触。及彼所生果触。欲界具六。色界四。无色界一

乐受云何。谓顺乐诸根境界为缘所生。适悦受。受所摄

苦受云何。谓顺苦二为缘所生。非适悦受。受所摄

不苦不乐受云何。谓顺不苦不乐二为缘所生。非适悦非不适悦受。受所摄。欲界三。色界二。第四静虑以上。乃至非想非非想处。唯有第三不苦不乐。此亦二种。谓触种子所摄受种子受。及彼所生果受

瑜伽师地论卷第九瑜伽师地论卷第十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中有寻有伺等三地之七

欲爱云何。谓欲界诸行为缘所生。于欲界行染污希求。由此能生欲界苦果。色爱云何。谓色界诸行为缘所生。于色界行染污希求。由此能生色界苦果。无色爱云何。谓无色界诸行为缘所生。于无色界行染污希求。由此能生无色界苦果。欲取云何。谓于诸欲所有欲贪。见取云何。谓除萨迦耶见。于所余见所有欲贪。戒禁取云何。谓于邪愿所起戒禁所有欲贪。我语取云何。谓于萨迦耶见所有欲贪。初唯能生欲界苦果。余三通生三界苦果。欲有云何。谓欲界前时有。业有。死有。中有。生有。及那落迦傍生饿鬼人天有。总说名欲有。此复由先所作诸行烦恼摄受之所熏发。色有云何。谓除那落迦傍生饿鬼人有。所余是色有应知。无色有云何。谓复除中有。所余是无色有应知。问依何义故建立七有。所谓那落迦傍生饿鬼人天有。业有中有。答依三种所作故。一能引有。谓一。二趣有有。谓一。三受用果有。谓五。生云何。谓于胎卵二生。初托生时。等生云何。谓即于彼身分圆满。仍未出时。趣云何。谓从彼出。起云何。谓出已增长。出现云何。谓于湿化二生。身分顿起。蕴得云何。谓即于彼诸生位中。五取蕴转。界得云何。谓即彼诸蕴因缘所摄性。处得云何。谓即彼诸蕴余缘所摄性。诸蕴生起云何。谓即彼诸蕴日日饮食之所资长命根。出现云何。谓即彼诸蕴余寿力故。得相续住。此生支略义者。谓若生自性。若生处位。若所生。若因缘所摄。若任持所引。若俱生依持。是名略义

衰云何。谓依止劣故。令彼掉动。老云何。谓发色衰变。摄云何。谓皮肤缓皱。熟云何。谓火力衰减。无复势力受用欲尘。气力损坏云何。谓性多疾病故。无有势力能作事业。黑黡间身云何。谓黯黑出现损其容色。身脊伛曲喘息奔急云何。谓行步威仪。身形所显。由此发起极重喘嗽。形貌偻前云何。谓坐威仪位。身首低曲。凭据杖策云何。谓住威仪位。依杖力而住。昏昧云何。谓卧威仪位。数重睡眠。羸劣云何。谓即于此位无力速觉。损减云何。谓念慧衰退。衰退云何。谓念慧劣故。至于善法不能现行。诸根耄熟云何。谓身体尪羸。功用破坏云何。谓彼于境不复明利。诸行朽故云何。谓彼于后将欲终时。其形腐败云何。谓寿量将尽。身形临坏。于诸事业。无复功能。此老略义者。谓依止变坏须发变坏。充悦变坏。火力变坏。无病变坏。色相变坏。威仪变坏。无色诸根变坏。有色诸根变坏。时分已过。寿量将尽。略义应知。彼彼有情云何。谓那落迦等。有情种类云何。谓即彼一切。终云何。谓诸有情离解支节而死。尽云何。谓诸有情由解支节而死。坏云何。谓识离身。没云何。谓诸色根灭。舍寿云何。谓气将尽位。舍暖云何。谓不动位弃舍诸蕴。命根谢灭云何。谓时死。死云何。谓遇横缘非时而死。时运尽云何。谓初死未久位。又死魔业名时运尽。此死略义者。谓若死若死法。若死差别。若死后位。是名略义。如是名为缘起差别应知

问何因缘故。无明等诸有支。作如是次第说。答诸愚痴者。要先愚于所应知事。次即于彼发起邪行。由邪行故。令心颠倒。心颠倒故。结生相续。生相续故。诸根圆满。根圆满故。二受用境。受用境故。若耽着若希求。由希求故。于方觅时。烦恼滋长。烦恼滋长故。发起后有爱非爱业。由所起业滋长力故。于五趣生死中苦果生。苦果生已。有老死等苦。谓内身变异所引老死苦。及境界变异所引忧叹苦。热恼之苦。是故世尊。如是次第说十二支。复有次第差别。谓依二种缘。建立缘起次第。一内身缘。二受用境界缘。内身缘。前六支所摄。受用境界缘。后六支所摄。先于内身起我执等愚。由此不了诸业所引苦果异熟故。发起诸业。既发起已。即随彼业。多起寻思。由业与识为助伴故。能感当来三种苦果。谓根初起所摄苦果。根圆满所摄苦果。受用境界所摄苦果。即名色为先。触为最后。又于现法中。依触缘受。发起于爱。由受用境界缘。广起追求。或由事业门。或由利养门。或由戒禁门。或由解脱门。发起欲求内身求。邪解脱求。如是求时。令先所起烦恼及业所引五趣生死果生。既得生已。老死随逐。复有次第差别。谓由三种有情聚。一乐出世清净。二乐世间清净。三乐着境界。由初聚故。灭诸缘起。增白净品。由第二有情聚故。不如实知诸谛道理。若住正念。或作福业。或作有漏修所引不动业。若不住正念。便发非福业。或起追悔所引。或不追悔欢喜所引心。相续住。彼又如前于下中上生处次第。能感当来三种苦果。谓名色为先。触为最后。由第三有情聚故。依现受用境所生受。于现法中如前次第。起后六支。谓受为先。老死为后。

问何因缘故。逆次第中。老死为先。说诸缘起。答依止宣说谛道理故。以生及老死能显苦谛。如世尊言。新名色灭为上首法

问何故不言诸无明灭为上首耶。答依心解脱者。而施设故。由彼于现法中。种子苦。及当来苦果。不生而灭。故说名色为先。受为最后。得究竟灭。又于现法中。受诸受时。爱及随眠。永拔不起。说名为灭。由彼灭故。以彼为先。余支亦灭。如是等类。宣说缘起次第应知。

问何故缘起说为缘起。答由烦恼系缚往诸趣中数数生起故。名缘起。此依字释名。复次依托众缘。速谢灭已。续和合生。故名缘起。此依刹那义释。复次众缘过去而不舍离。依自相续而得生起故。名缘起。如说此有故彼有。此生故彼生。非余。依此义故。释名应知。复次数数谢灭。复相续起故。名缘起。此依数坏数灭义释。复次于过去世觉缘性已。等相续起故。名缘起。如世尊言。我已觉悟。正起宣说。即由此名展转传说。故名缘起。

问无明望行为几种缘。答望诸色行。为增上缘。望无色行。为三缘。谓等无间缘。所缘缘。增上缘。如是余支为缘多少。应如此知。谓有色支望有色支为一增上缘。望无色支为二缘。谓所缘缘。及增上缘。若无色支望有色支唯为一缘。望无色支为三缘。谓等无间缘。所缘缘。增上缘。问何故诸支相望无因缘耶。答因缘者。自体种子缘所显故。问若诸支相望无因缘者。何故说言依因果体性建立缘起耶。答依增上缘所摄。引发因。牵引因。生起因故。说名为因。问几支是引因所摄。答从无明乃至受。问几支是生因所摄。答从爱乃至有。问几支是生引二因果所摄耶。答于现法后法中。识等乃至受。于生老死位。所摄诸支。

问若说无明以不如理作意为因。何因缘故。于缘起教中。不先说耶。答彼唯是不断因故。非杂染因故。所以者何。非不愚者起此作意。依杂染因说缘起教。无明自性是染污。不如理作意自性。非染污。故彼不能染污无明。然由无明力所染污。又生杂染业烦恼力之所熏发业之初因。谓初缘起。是故不说不如理作意。问何故不说自体。为自体缘耶。答由彼自体若不得余缘。于自体杂染不能增长。亦不损减。是故不说。问何因缘故。福行不动行。由正简择功力而起。仍说用无明为缘耶。答由不了达世俗苦因为缘。起非福行。由不了达胜义苦因为缘。生福及不动行。是故亦说彼以无明为缘。问如经中说诸业以贪嗔痴为缘。何故此中唯说痴为缘耶。答此中通说福非福不动业缘。贪嗔痴缘唯生非福业故。问身业语业。思所发起。是则行亦缘行。何故但说无明缘行。答依发起一切行缘而说故。及依生善染污思缘而说故。问识亦以名色为缘。何故此中但说行为缘耶。答行为识杂染缘。能引能生后有果故。非如名色但为所依所缘生起缘故。问名色亦由大种所造。及由触生。何故但说识为缘耶。答识能为彼新生因故。彼既生已。或正生时。大种及触。唯能与彼为建立因

问如经中说。六界为缘得入母胎。何故此中唯说识界。答若有识界。决定于母胎中。精血大种。腹穴无阙故。又识界胜故。又依一切生一切有生时而说故。问六处亦以饮食为缘。何故此中但说名色为缘耶。答此中说名色是彼生因故。彼既生已。亦以饮食为任持因。问触以三和为缘。何故此中但说六处为缘。答若有六处。定有余二无阙故。又六处胜故。由六处摄二种故。问若自所逼迫。若他所逼迫。若时候变异。若先业所引。皆得生受。何故此中但显触为彼缘。答触是彼近因故。由触所引故。余缘所生受。亦从触生故。必不离触。是故偏说。问经中亦说无明为缘生爱。顺爱境界。亦得为缘。何故此中但说受为缘耶。答以受力故。于相似境。或求和合。或求乖离。由愚痴力。但于诸受起尽等相。不如实知。由此不能制御其心。问由随眠未断。顺彼诸法。取皆得生。何故此中但说爱为取缘。答由希望生故。于追求时。能发随眠。及能引彼随顺法故。问前已说无明为缘发起业有。何故今者说取缘有。答由取力故。即令彼业于彼彼生处能引识名色等果。问生亦以精血等为缘。何故此中唯说有缘生耶。答由有有故。定有余缘无阙。又有胜故。唯说彼为缘。问亦由远行。不避不平等。他所逼迫为缘。老死可得。何故此中但说生缘老死耶。答虽由彼诸缘。必以生为根本故。纵阙彼缘。但生为缘。定有老死故

问此十二支几是烦恼道。几是业道。几是苦道。答三是烦恼道。二是业道。余是苦道。问几唯是因。几唯是果。几通因果。答初一唯因。后一唯果。余通因果。又即于此问。更作余答。三唯是因。二唯是果。当知所余亦因亦果。问几是独相。几是杂相。答三是独相。行等是杂相。问何故行有是杂相。答由一种说故。谓能引爱非爱果故。及能生趣差别故。问何故识与名色六处一分有杂相。答由三种说故。谓依杂染时故。依润时故。依转时故。问何故识乃至受与老死有杂相。答由二种说故。谓别显苦相故。及显引生差别故。复次于缘起中。云何数往义。谓生已不住义。云何和合义。谓诸缘聚集义。云何起义。谓诸缘和合之所引摄新新生义。云何缘起。云何缘生。谓诸行生起法性是名缘起。即彼生已说名缘生。问几支苦谛摄及现法为苦。答二。谓生及老死。问几支苦谛摄。当来为苦。答识乃至受种子性。问几支集谛摄。答所余支。问无明与行为作俱有缘。为作无间灭缘。为作久远灭缘。答当知具作三缘。谓由无知。于随顺诸行法中。为俱有覆障缘。为彼彼事。发起诸行。又由恶见放逸俱行无知。为无间灭生起缘。发起诸行。又由无知。为久远灭引发缘故。建立顺彼当生相续。问云何应知诸行望识为三种缘。答由能熏发彼种子故。为俱有缘。次后由彼势力转故。为无间灭生起缘。由彼当来果得生故。为久远灭引发缘。如行望识。如是识望名色。名色望六处。六处望触。触望受亦尔

问云何应知受望爱为三种缘。答当知由彼起乐着故。为俱有缘。从此无间由彼势力。起追求等作用转故。为无间灭生起缘。建立当来。难可解脱彼相续故。为久远灭引发缘。问云何爱望取为三种缘。答由欲贪俱行。于随顺取法中欲乐安立故。为俱有缘。由无间灭势力转故。为生起缘。建立当来。难可解脱彼相续故。为久远灭引发缘。问云何取望有为三种缘。答由与彼俱令业能招诸趣果故。为俱有缘。又由彼力。于此生处能引识等故。为无间灭生起缘。又能引发彼界功能故。为久远灭引发缘。问云何有望生为三种缘。答熏发彼种子故。为俱有缘。由彼势力无间随转故。为生起缘。虽久远灭。而果转故。为引发缘。如有望生。当知生望老死。为缘亦尔。复次建立有支有二种。一就胜分建立。谓取所摄受业。如前已说。二全分建立。谓业及识。乃至受所有种子。取所摄受。建立为有应知。问是诸有支。唯有次第与行为缘。乃至老死更有余业用耶。答即此业用及于各别所行境中。如其所应。所有业用当知。是名第二业用

问无明唯与行为缘。亦与余支为缘耶。答无明乃至亦与老死为缘。前言唯与行为缘者。但说近缘义。如是所余尽应当知。复次后支非前支缘。何以故。如为断后支故。勤作功用断于前支。由前断故后亦随断。非为断前故勤作功用断于后支。是故当知。唯此为彼缘。问云何说言此有故彼有。答由未断缘。余得生义故。问云何此生故彼生。答由无常缘。余得生义故。问何故说言有生故有老死。要由生缘而有老死。如是乃至无明望行。答由此言教道理。显从无实作用缘余得生义故。问何故说言有生故有老死。非离生缘而有老死。如是乃至无明望行。答由此言教道理。显从自相续缘。即自相续余得生义故。问若法无明为缘。彼法是行耶。设是行者。彼无明为缘耶。答应作四句。或有行非无明为缘。谓无漏及无覆无记身语意行。或无明为缘而非是行。谓除行所摄有支。所余有支。或有亦无明为缘亦是行。谓福非福不动身语意行。除如是相是第四句。问若行为缘彼亦识耶。设是识者行为缘耶。答应作四句。或行为缘非识。谓除识所余有支。或识非行为缘。谓无漏识及无覆无记识。除异熟生。或亦识亦行为缘。谓后有种子识及果识。除如是相。是第四句。由此道理。乃至触缘受。随其所应。四句应知。问若受为缘皆是爱耶。设是爱者皆受为缘耶。答应作四句。或有是爱非受为缘。谓希求胜解脱。及依善爱而舍余爱。或受为缘而非是爱。谓除无明触所生受为缘。所余有支法生。或有受为缘亦是爱。谓无明触所生受为缘。染污爱生。除如是相是第四句。问若爱为缘皆是取耶。设是取者皆爱为缘耶。答当知此中是顺后句。谓所有取皆爱为缘。或爱为缘而非是取。谓除取所余有支。及缘善爱勤精进等诸善法生。问若取为缘皆是有耶。设是有者皆取为缘耶。答亦应作顺后句。谓所有有皆取为缘。或取为缘而非是有。谓除有所余有支。问若有为缘皆是生耶。设是生者皆有为缘耶。答诸所有生皆有为缘。或有为缘而非是生。谓除生所余老死最后有支。问若生为缘皆老死耶。设是老死皆生为缘耶。答所有老死皆生为缘。或生为缘而非老死。所谓疾病。怨憎合会。亲爱别离。所求不遂。及彼所起愁叹忧苦。种种热恼。问是诸有支几与道支所摄正见为胜障碍。答无明及彼所起意行。若有一分能为胜障。如于正见。如是于正思惟。及正精进亦尔。若正语正业正命。以身行语行。及有一分。为胜障碍。若正命正定。以余有支。为胜障碍应知。问是诸有支几唯杂染品。几通杂染清净品。答四唯杂染品。余通杂染清净品。问云何生支通二品耶。答若生恶趣及有难处。唯是杂染品。若生人天诸无难处。此通染净品。当知余支。随其所应。皆通二品。问何等无明不有故行不有。何等无明灭故行灭耶。答有三种发起缠。随眠。无明。由此无明灭故。彼无明灭。由彼灭故。行亦随灭

问何等行不有故识不有。何等行灭故识灭耶。答诸行于自相续中。已作已灭。及未起对治。又由意行有故。起身语行。由此有故。彼有。彼无故彼缘识亦无。此若全灭。当知识亦随灭。问何等识不有故名色不有。何等识灭故名色灭耶。答种子识不有故。果识不有。此俱灭故。俱名色灭。如识望名色道理。如是余支乃至受。随其所应。当知亦尔。如无明缘行道理如是爱缘取。取缘有道理。当知亦尔。如行缘识道理。如是有缘生。当知亦尔。如识缘名色道理。生缘老死。当知亦尔。问何等受不有故爱不有。何等受灭故爱灭耶答如行缘识道理。当知亦尔。问如前所说八缘起门。几门是十二支缘起所显。几门非耶。答三门是彼所显。谓二一分所显。一全分所显。余门非。何等为二一分所显。谓内识生门。自业所作门。何等为一全分所显。谓有情世间转门。问不如实知缘起道理者。有几种过患耶。答有五。谓起我见。及能发起前际俱行见。如前际俱行见。如是后际俱行见。前后际俱行见亦尔。又于彼见猛利坚执。有取有怖。于现法中。不般涅槃。是名第五过患。问如实知者有几种胜利耶。答翻前五过应知胜利亦有五种。复次是十二支缘起。几支是实有。谓九。几支非实有。谓余。几一事为自性。谓五。几非一事为自性。谓余。几是所知障因。谓一。几能生苦。谓五。几苦胎藏。谓五。几唯是苦。谓二。几说为因分。谓前六。无明乃至触。及爱取有三说为因分。几说为果分。谓后二说为果分。几说为杂因果分。谓所余支说为杂分。所以者何。有二种受。名为杂分。一谓后法以触为缘因受。二谓现法与爱为缘果受。此二杂说为触缘受。复次几支能生爱非爱境界果。几支能生自体果。谓前六支能生前果。后三支能生后果。一支俱生二果。复次几支乐受俱行。谓除二所余支。几支苦受俱行。谓即彼及所除中一。几支不苦不乐受俱行。谓如乐受道理应知。几支不与受俱行。谓所除中一。复次几支坏苦摄。谓乐受俱行支。及非受俱行支一分。几支苦苦摄。谓苦受俱行支。及非受俱行支一分。几支行苦摄。谓所有坏苦。苦苦支。亦是行苦支。或有行苦所摄。非余二苦。谓不苦不乐受俱行支。及非受俱行支一分。问于一切生处及三摩钵底中。皆有一切支现行可得耶。答不可得。谓无想天中。及灭尽定。无想定中。有色支可得。非无色支。若生无色界。无色支可得。非有色支。问颇有依支得离支耶。答有。谓依上地支。离下地支。此但一分非全。唯暂时非究竟。问几支染污。几支不染污。答三染。余通二种。若不染污。善及无覆无记别故。分为二种应知。问几支欲界系。答一切支。和合等起故。问几支色界系。答一切一分。问云何应知。彼有老耶。答彼诸行有朽坏腐败性故。如色界系。当知无色界系亦尔。问几支是学。答无。问几支是无学。答亦无。问几支是非学非无学。答一切。问所有善有漏支。彼何故非学耶。答堕流转故。若学所有善有漏法。彼与流转相违故。及用明为缘故非支。问预流果当言几支已断耶。答一切一分无全断者。如预流果。如是一来果亦尔。问不还果当言几支已断耶。答欲界一切。色无色界不定。

问阿罗汉当言几支已断耶。答三界一切。复次于彼彼经中。由几种言说道理说缘起耶。谓略说由六种言说道理。一由顺次第说。二由逆次第说。三由一分支说。四由具分支说。五由黑品说。六由白品说。问如世尊说缘起甚深。此甚深义。云何应知。答由十种相。应知缘起甚深义。谓依无常义。苦义。空义。无我义说。依无常义者。谓从自种子生。亦待他缘。又从他缘生。亦待自种子。又从自种子又从他缘生。而种及缘于此生事。无作无用。亦无运转。又复此二因性功能。非不是有。又诸有支。虽无始来其相成就。然刹那刹那新新相转。又缘起支虽刹那速灭。然似停住运动相现。依苦义者。谓缘起支。一味苦相而似三种相现。依空义者。谓缘起支。虽离有情作者受者。然似不离。显现而说。依无我义者。谓缘起支。虽不自在实无有我相。然似我相显现。依胜义谛。诸法自性虽不可说。而言诸法自性可说。问应以几智知缘起耶。答二。谓以法住智。及真实智。云何以法住智。谓如佛施设开示。无倒而知。云何以真实智。谓如学见迹观甚深义。问如世尊言。是诸缘起。非我所作亦非余作。所以者何。若佛出世。若不出世。安住法性法住法界。云何法性。云何法住。云何法界。答是诸缘起。无始时来。理成就性是名法性。如成就性。以无颠倒文句安立。是名法住。由此法住以彼法性为因。是故说彼名为法界。问如经言。生若无者。无处无位。生可是有。若一切种生非有者。生缘老死。应不可得。何故此中说彼自性缘自性耶。答依自种子果生说故。谓识乃至受支。是生种子故。义说为生。由此有故。后时即此果支。名有缘生。如是余支。如经所说。随其所应。尽当知

问已说一切支非更互为缘。何故建立名色与识互为缘耶。答识于现法中。用名色为缘故。名色复于后法中。用识为缘故。所以者何。以于母腹中。有相续时。说互为缘故。由识为缘。于母腹中。诸精血色。名所摄受。和合共成羯罗蓝性。即此名色为缘。复令彼识于此得住。问何故菩萨观黑品时。唯至识支。其意转还。非至余支耶。答由此二支更互为缘故。如识缘名色。如是名色亦缘识。是故观心至识转还。于余支中。无有如是转还道理。于此一处。显示更互为缘道理。故名转还。于还灭品中。名色非是后有识还灭因。由此因缘复过观察。问何因缘故说缘起支非自作。非他作。非俱作。亦非无因生耶。答生者非有故。缘无作用故。缘力所生故。问于缘起中。何等是苦芽。谁守养苦芽。何等为苦树。答无明行缘所引识乃至受是苦芽。受缘所引爱。乃至有是守养苦芽。生与老死。当知是苦树。问几缘起支当知如炷。答识乃至受。问几支如膏。答元明行。爱取有。问几支如焰。答生老死应知。问何因缘故。于缘起黑品教中。说名增益。答一切有支纯大苦聚为后果故。又诸有支前前为缘。后后所随故。问何因缘故。于白品教中。说名损减。答由一切支前前永断后后减故。又是纯大苦聚损减因故。问几缘起支名有因法。答谓前七。问几缘起支名有因苦。答余五。问几支灭是漏尽所显。答三。问几支灭是缘尽所显。答即此三是余支缘故。问几支灭是受尽所显。答一。谓由烦恼已断故。所依灭时。此一切受。皆永息灭故。问何因缘故。依止缘起。建立七十七智耶。答为显有因杂染智故。又复为显于自相续自已所作杂染智故。又复为显前际诸支无始时故。又复为显后际诸支容有杂染还灭义故。又复为显支所不摄诸有漏慧遍知义故。于一一支。皆作七智。当知总有七十七智。问何因缘故。于缘起中。建立四十四智耶。答为显于一一支依四圣谛观察道理。是故总有四十四智。复次若生欲界。依欲界身。引发上地若眼若耳。由此见闻下地自地所有色声。又依此身。起三界意及不系意。而现在前。若生色无色界。除其下地。一切现前。如在欲界

复次此三种杂染。谓烦恼杂染。业杂染。生杂染。为欲断故。修六种现观。应知何等为六。谓思现观。信现观。戒现观。现观智谛现观。现观边智谛现观。究竟现观

瑜伽师地论卷第十瑜伽师地论卷第十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中三摩呬多地第六之一

已说有寻有伺等三。云何三摩呬多地。嗢拖南曰

  总标与安立　　作意相差别
  摄诸经宗要　　最后众杂义

若略说三摩呬多地。当知由总标故。安立故。作意差别故。相差别故。略摄诸经宗要等故。

云何总标。谓此地中略有四种。一者静虑。二者解脱。三者等持。四者等至。静虑者。谓四静虑。一从离生有寻有伺静虑。二从定生无寻无伺静虑。三离喜静虑。四舍念清净静虑。解脱者。谓八解脱。一有色观诸色解脱。二内无色想观外诸色解脱。三净解脱身作证具足住解脱。四空无边处解脱。五识无边处解脱。六无所有处解脱。七非想非非想处解脱。八想受灭身作证具足住解脱。等持者。谓三三摩地。一空。二无愿。三无相。复有三种。谓有寻有伺。无寻唯伺无寻无伺。复有三种。谓小大无量。复有二种。谓一分修。具分修。复有三种。谓喜俱行。乐俱行。舍俱行。复有四种。谓四修定。复有五种。谓五圣智三摩地。复有五种。谓圣五支三摩地。复有有因有具圣正三摩地。复有金刚喻三摩地。复有有学无学。非学非无学等三摩地。等至者。谓五现见三摩钵底。八胜处三摩钵底。十遍处三摩钵底。四无色三摩钵底。无想三摩钵底。灭尽定等三摩钵底

云何安立。谓唯此等名等引地。非于欲界心一境性。由此定等。无悔欢喜安乐所引。欲界不尔。非欲界中于法全无审正观察

复次初静虑中。说离生喜。由证住此断除五法。谓欲所引喜。欲所引忧。不善所引喜。不善所引忧。不善所引舍。又于五法修习圆满。谓欢喜安乐。及三摩地。欲所引喜者。于妙五欲。若初得时。若已证得。正受用时。或见或闻。或曾领受。由此诸缘。忆念欢喜。欲所引忧者。于妙五欲。若求不遂。若已受用更不复得。或得已便失。由此诸缘多生忧恼。不善所引喜者。谓如有一与喜乐俱而行杀业乃至邪见。不善所引忧者。谓如有一与忧苦俱而行杀业乃至邪见。不善所引舍者。谓如有一或王王等或余宰官或尊尊等自不乐为杀等恶业。然其仆使作恶业时。忍而不制。亦不安处毗奈耶中。由纵舍故。遂造恶业。彼于此业。现前领解非不现前。又住于舍。寻求伺察。为恶方便。又于诸恶。耽着不断。引发于舍。又于不善现前转时。发起中庸非苦乐受。欢者。谓从本来清净行者观资粮地所修净行无悔为先。慰意适悦心欣踊性。喜者。谓正修习方便为先。深庆适悦心欣踊性安者。谓离粗重身心调适性。乐者。谓由如是心调适故。便得身心无损害乐及解脱乐。以离彼品粗重性故。于诸烦恼而得解脱。三摩地者。谓于所缘。审正观察。心一境性。世尊于无漏方便中。先说三摩地。后说解脱。由三摩地善成满力。于诸烦恼。心永解脱故。于有漏方便中。先说解脱。后说三摩地。由证方便究竟作意果烦恼断已方得根本三摩地故。或有俱时说三摩地及与解脱。谓即于此方便究竟作意。及余无间道三摩地中。由三摩地与彼解脱俱时有故。

复次于诸静虑等至障中。略有五盖。将证彼时能为障碍。何等为五。一贪欲盖。二嗔恚盖三惛沉睡眠盖。四掉举恶作盖。五疑盖。贪欲者。谓于妙五欲。随逐净相。欲见。欲闻乃至欲触。或随忆念。先所领受。寻伺追恋。嗔恚者。谓或因同梵行等举其所犯。或因忆念昔所曾经不饶益事嗔恚之相。心生恚怒。或欲当作不饶益事。于当所为嗔恚之相。多随寻伺。心生恚怒。惛沈者。谓或因毁坏净尸罗等随一善行。不守根门。食不知量不勤精进减省睡眠。不正知住。而有所作。于所修断不勤加行随顺。生起一切烦恼。身心惛昧。无堪任性。睡眠者。谓心极昧略。又顺生烦恼坏断加行。是惛沈性。心极昧略。是睡眠性。是故此二合说一盖。又惛昧无堪任性。名惛沈。惛昧心极略性名睡眠。由此惛沉生诸烦恼随烦恼时。无余近缘如睡眠者。诸余烦恼及随烦恼。或应可生。或应不生。若生惛昧。睡眠必定皆起。掉举者。谓因亲属寻思。国土寻思。不死寻思。或随忆念昔所经历戏笑欢娱所行之事。心生諠动腾跃之性。恶作者。谓因寻思亲属等故。心生追悔。谓我何缘离别亲属。何缘不往如是国土。何缘弃舍如是国土来到于此。食如是食。饮如是饮。唯得如是衣服卧具。病缘医药。资身众具。我本何缘少小出家。何不且待至年衰老。或因追念昔所曾经戏笑等事。便生悔恨。谓我何缘于应受用戏乐严具朋游等时。违背宗亲朋友等意。令其悲恋涕泪盈目。而强出家。由如是等种种因缘。生忧恋心。恶作追悔。由前掉举与此恶作处所等故。合说一盖。又于应作不应作事。随其所应。或已曾作。或未曾作。心生追悔。云何我昔应作不作。非作反作。除先追悔所生恶作。此恶作缠犹未能舍。次后复生相续不断忧恋之心。恶作追悔。此又一种恶作差别。次前所生非处恶作。及后恶作虽与掉举处所不等。然如彼相腾跃諠动。今此亦是忧恋之相。是故与彼杂说一盖。疑者。谓于师于法于学于诲及于证中。生惑生疑。由心如是怀疑惑故。不能趣入勇猛方便正断寂静。又于去来今及苦等谛。生惑生疑。心怀二分。迷之不了。犹豫猜度。

问此贪欲盖以何为食。答有净妙相。及于彼相。不正思惟。多所修习。以之为食。净妙相者。谓第一胜妙诸欲之相。若能于此远离染心。于余下劣亦得离染。如制强力余劣自伏。此复云何。谓女人身上八处所摄可爱净相。由此八处。女缚于男。所谓歌舞笑睇。美容进止。妙触就礼。由此因缘。所有贪欲。未生令生。生已增长。故名为食。问此贪欲盖谁为非食。答有不净相。及于彼相如理作意。多所修习。以为非食。此复云何。谓青瘀等。若观此身种种不净杂秽充满。名观内身不净之相。复观于外青瘀等相种种不净。名观外身不净之相。由观此二不净相故。未生贪欲令其不生。生已能断故。名非食。由于彼相如理作意故。遮令不生。多所修习故。生已能断。前黑品中。由于彼相不正思惟故。未生令生。多所修习故。倍更增广。问嗔恚盖以何为食。答有嗔恚性。有嗔恚相。及于彼相。不正思惟。多所修习。以之为食。依于种种不饶益事心生恼害。名嗔恚性。不饶益事。名嗔恚相。于九恼事。不正作意。名不正思惟。如是等事皆名为食。问此嗔恚盖谁为非食。答有仁慈贤善。及于彼相。如理作意。多所修习。以为非食。又此慈善恒欲与他安乐为相。修力所摄。由思择力所摄作意。调伏九恼。以能断除嗔恚盖故。经中唯说此为非食。问惛沉睡眠盖以何为食。答有黑暗相。及于彼相。不正思惟。多所修习。以之为食。问此盖谁为非食。答有光明相。及于彼相。如理作意。多所修习。以为非食。明有三种。一治暗光明。二法光明。三依身光明。治暗光明。复有三种。一在夜分。谓星月等。二在昼分。谓日光明。三在俱分。谓火珠等。法光明者。谓如有一随其所受所思所触。观察诸法。或复修习。随念佛等。依身光明者。谓诸有情自然身光。当知初明。治三种暗。一者夜暗。二者云暗。三者障暗。谓窟宅等。法明能治三种黑暗。由不如实知诸法故。于去来今多生疑惑于佛法等亦复如是。此中无明及疑俱名黑暗。又证观察。能治惛沉睡眠黑暗。以能显了诸法性故。问掉举恶作盖以何为食。答于亲属等。所有寻思。于曾所经戏笑等念。及于彼相。不正思惟。多所修习。以之为食。亲属寻思者。谓因亲属或盛或衰。或离或合。发欣戚行。心生筹虑等。国土寻思者。谓因国土盛衰等相。广如前说。不死寻思者。谓因少年及衰老位诸有所作或利他事。发欣戚行。心生筹虑等。笑者。谓随有一或因开论。或因合论。现齿而笑欢聚哑哑。戏者。谓双陆摴蒱弄珠等戏。或有所余种类欢乐。谓互相受用受用境界。受诸快乐。或由同处。或因戏论。欢娱而住。所行事者。谓相执持手臂发等。或相摩触。随一身分。或抱或呜。或相顾眄。或作余事。问此盖谁为非食。答有奢摩他。及于彼相。如理作意。多所修习。以为非食。奢摩他者。谓九种住心。及奢摩他品所摄诸法。谓于自他若衰若盛可厌患法。心生厌离惊恐恶贱。安住寂静。问疑盖以何为食。答有去来今。及于彼相。不正思惟。多所修习。以之为食。谓我于过去。为有为无。广说如上。不正思惟者。谓不可思处所摄思惟。不可思处者。谓我思惟。有情思惟。世间思惟。若于自处。依世差别。思惟我相。名我思惟。若于他处。名有情思惟。若于有情世间。及器世间处。名世间思惟。谓世间常。或谓无常。亦常亦无常非常非无常等。问此盖谁为非食。答有缘缘起。及于彼相。如理作意。多所修习。以为非食。由彼观见。唯有于法及唯法因。唯有于苦及唯苦因故。所有一切不正思惟为缘。无明于三世境。未生者不生。已生者能断。若不如理而强作意。其如理者而不。作意。总说此二。名不正思惟。若于是中应合道理。应知是处名为如理。谓于闇中作光明想。由此方便。如理作意。非不如理。于余处所。亦有所余如理作意

复次于初静虑。具足五支。一寻。二伺。三喜。四乐。五心一境性。第二静虑有四支。一内等净。二喜。三乐。四心一境性。第三静虑有五支。一舍。二念。三正知。四乐。五心一境性。第四静虑有四支。一舍清净。二念清净。三不苦不乐受。四心一境性。初静虑中。寻伺为取所缘。三摩地为彼所依。喜为受境界。乐为除粗重。第二静虑中。内等净为取所缘。三摩地为彼所依。余如前说。第三静虑中。舍念正知为取所缘。三摩地为彼所依。余如前说。第四静虑中。舍净念净为取所缘。三摩地为彼所依。余如前说。诸静虑中。虽有余法。然此胜故。于修定者为恩重故。偏立为支

问何因缘故。初静虑中有寻有伺耶。答由彼能厌患欲界入初静虑。初静虑中。而未能观寻伺过故。第二静虑。能观彼过。是故说为寻伺寂静。如第二静虑见彼过故名寻伺寂静。如是第三静虑。见喜过故名喜寂静。第四静虑见乐过故名乐寂静。舍念清净差别应知

复次是诸静虑名差别者。或名增上心。谓由心清净增上力。正审虑故。或名乐住。谓于此中受极乐故。所以者何。依诸静虑。领受喜乐安乐舍乐身心乐故。又得定者。于诸静虑。数数入出。领受现法安乐住故。由此定中现前领受现法乐住。从是起已。作如是言。我已领受如是乐住。于无色定无如是受。是故不说彼为乐住。然彼起已。应正宣说。何以故。若有阿练若苾刍来就彼问。彼若不答。便生讥论。此阿练若苾刍。云何名为阿练若者。我今问彼超色无色寂静解脱。而不能记。是故为说应入彼定非为乐住。或复名为彼分涅槃。亦得说名差别涅槃。由诸烦恼一分断故。非决定故。名彼分涅槃。非究竟涅槃故。名差别涅槃。复次此四静虑。亦得名为出诸受事。谓初静虑。出离忧根。第二静虑。出离苦根。第三静虑。出离喜根。第四静虑出离乐根。于无相中出离舍根。如薄伽梵无倒经中说如是言。苾刍忧根生已。应当如实了知。生者此于何位。谓即于此断方便位。若为忧根间心相续。尔时应知又应并此因缘及序若相若行皆如实知者。云何知因。谓了知此种子相续。云何知缘。谓了知此种所不摄所依助伴。云何知序。谓知忧根托此事生。即是能发忧根之相。及无知种子。云何知相。谓了知此是戚行相。云何知行。谓了知此能发之行。即不如理作意相应思也。如是知已。于出离中。极制持心者。云何制持。谓于染污行。制摄其心。于思惟修。任持坚住。又于是中无余尽灭。乃至究竟者。谓灭随眠故。灭诸缠故。世间静虑。但能渐舍彼品粗重。不拔种子。若异此者。种永拔故。后不应生。无漏静虑。二种俱舍。如是于余随应当知。问以何等相了知忧根。答或染污相。或出离欲俱行善相。苦根者。或由自等增上力故。或由身劳增上力故。或火烧等增上力故。或他逼等增上力故。诸离欲者。犹尚生起。喜根者。谓第二静虑中。即第二静虑地摄。乐根者。谓第三静虑中。即第三静虑地摄。问何故苦根。初静虑中。说未断耶。答彼品粗重犹未断故。问何缘生在初静虑者。苦根未断。而不现行。答由其助伴相对。忧根所摄诸苦。彼已断故。若初静虑。已断苦根。是则行者入初静虑及第二时。受所作住差别应无。由二俱有喜及乐故。而经中说。由出诸受。静虑差别。又此应无寻伺寂静。粗重断灭。所作差别。如是余根彼品粗重渐次断故。上诸静虑断有差别。又无相者。经中说为无相心定。于此定中舍根永灭。但害随眠。彼品粗重。无余断故。非灭现缠。住无相定。必有受故。于此定中。容有三受。谓喜乐舍。非彼诸受得有随眠。烦恼断。故说以为断。彼品粗重。说名随眠。又此舍根乃至何处。当知始从第四静虑。乃至有顶。复次此五根出离无相。为后与彼五种顺出离界展转相摄此中由欲恚害出离。即说乃至乐根出离。由色出离。即说第四静虑舍根出离。由萨迦耶灭。即说无色界一切舍根出离。顺出离言。有何等义。由住此者能出离故。名顺出离。不说由此出离于彼。为离欲者说此界故。问诸欲恚害。定同时断。何缘建立别出离耶。答彼诸出离虽复同时。约修对治有差别故。宣说三种出离差别。对治差别者。谓不净慈悲。如其次第。或有唯修不净出离一切。或慈或悲。是故别说三种出离。此上唯有一类对治故。后出离无有差别。云何猛利见者。等随念欲。谓由观察作意于胜事作意故。猛利功用作意故。云何于诸欲中心不趣入。谓于彼处。不见胜功德故。云何不美。谓于彼处。喜悦不生故。云何不住。谓于彼处不乐受用为欣悦故。云何无有胜解。谓于彼处不乐取着。不如理相故。云何萎瘁。谓虽纵任。而不舒泰故。云何坏散。谓取境已寻复弃舍故。云何而不舒泰。谓于所缘虽强令住。而不爱乐故。云何等住于舍。谓行平等位。于平等位中。心游观故。何等为厌。谓由于彼深见过患。弃背为性。此复三种。谓无常故。苦故。变坏法故。何等为恶。谓由于彼初见过患。弃背为性。何等为违。谓由于彼中见过患。弃背为性。何等为背。谓由于彼后见过患。弃背为性。与此相违。即于离欲作意趣入者谓于是处。见胜功德故。美者。谓于是处生清净信而证顺故。住者。谓于所缘不流散故。胜解者。由于是处不染污转于诸烦恼得离系故。以于厌等弃背行中正流转时心无挂碍。又复于舍无有功用。云何其心善逝。谓住方便究竟作意故。云何善修。谓善修习余作意故。当知此说断位及断方便道位。解者。谓解脱诸缠故。脱者。谓解脱所缘相故。离系者。谓解脱随眠故。从诸欲缘所生诸漏者。谓除欲贪。于欲界中。所余烦恼。损匮者。谓因此生执器仗等恶行差别。于此若作若增长故。生诸恶趣。烧者。谓由此因欲爱啖食烧身心故。恼者。谓由此因。若事变坏便生愁叹忧苦恼故。于彼解脱超出离系者。谓如前次第。解脱诸缠所缘随眠故。云何终不领纳缘彼诸受。谓依将得正得。随念诸欲境界。染污诸受。不复现行。其所依身。不为众惑染污而住。如红莲花水滴不着

复有六种顺出离界。如经广说。谓我已修慈。乃至我已离诸我慢。然我犹为疑惑毒箭。闷乱其心。是故慈等。于恚害等。非正对治。当知为舍如是邪执。建立此界。是中恚等离欲对治有差别故。建立前四对治相故。观察圣住得道理故。建立无相观察究竟正道理故。建立第六。慈对治恚。无损行转故。悲对治害。为除他苦。胜乐行转故。喜治不乐。于他乐事。随喜行转故。舍治贪恚。俱舍行转故。无相对治一切众相。相相违故。若离我慢。于自解脱或所证中。定无疑惑故。离我慢是彼对治。此诸出离定。能出离一切恚等。不善修故。恚等过失容可现行。又前五种顺出离界。初之四种天住所摄。第五一种圣住所摄。今此六种顺出离界。前之四种梵住所摄。第五第六圣住所摄

复次能超恚等诸过失故。名为出离。于出离时。正可凭仗故名为依。世尊说依。略有四种。一法是依。非数取趣。二义是依。非文。三了义经是依。非不了义经。四智是依。非识。此四种依。因何建立。补特伽罗四种别故。谓因谄诈补特伽罗差别故。建立初依。因顺世间补特伽罗差别故。建立第二。因住自见取补特伽罗差别故。建立第三。因闻为极补特伽罗差别故。建立第四。因其谄诈说法。是依非数取趣。要与彼论。分别决择方证正智。非唯由彼现威仪故。即于此中复有差别。谓佛宣说补特伽罗。及与诸法。唯法是依。非数取趣。世俗言辞。不应执故。法又二种。谓文及义。唯义是依非文。何以故。不应但闻即为究竟。要须于义思惟筹量审观察故。佛所说经。或有了义或不了义。观察义时。了义是依。非不了义。世尊或时宣说依趣福不动识。为往善趣故。或时宣说四圣谛智为向涅槃故。于修法随法行时。唯智是依非识。略于四时。失不失故。建立四种补特伽罗。谓得法时。住持时。观察义时。修法随法行时。依四时故。建立四依

复次已说安立。当知于此静虑等中。作意所缘二种差别。

作意差别者。谓七种根本作意。及余四十作意。云何七种作意。谓了相作意。胜解作意。远离作意。摄乐作意。观察作意。加行究竟作意。加行究竟果作意。云何四十作意。谓缘法作意。缘义作意。缘身作意。缘受作意。缘心作意。缘法作意。胜解作意。真实作意。有学作意。无学作意。非学非无学作意。遍知作意。正断作意。已断作意。有分别影像所缘作意。无分别影像所缘作意。事边际所缘作意。所作成办所缘作意。胜解思择作意。寂静作意。一分修作意。具分修作意。无间作意。殷重作意。随顺作意。对治作意。顺清净作意。顺观察作意。力励运转作意。有间运转作意。有功用运转作意。自然运转作意。思择作意。内摄作意。净障作意。依止成办所行清净作意。他所建立作意。内增上取作意。广大作意。遍行作意

缘法作意者。谓闻所成慧相应作意。缘义作意者。谓思修所成慧相应作意。缘身受心法作意者。谓修念住者。如理思惟身等作意。胜解作意者。谓修静虑者。随其所欲。于诸事相增益作意。真实作意者。谓以自相共相。及真如相。如理思惟诸法作意。有学作意。略有二种。一者自性。二在相续。自性者。谓有学无漏作意。在相续者谓有学一切善作意。如有学作意。当知无学作意二种亦尔。非学非无学作意者。谓一切世间作意。遍知作意者。谓由此故遍知所缘而不断惑。正断作意者。谓由此故。俱作二事。已断作意者。谓断烦恼后所有作意。有分别影像所缘作意者。谓由此故。修缘分别体境毗钵舍那。无分别影像所缘作意者。谓由此故。修缘分别体境奢摩他。事边际所缘作意者。谓由此故。了知一切身受心法所缘边际。过此更无身受心法。所作成办所缘作意者。谓我思惟如此如此。若我思惟如是如是。当有如此如此。当办如是如是。及缘清净所缘作意。胜解思择作意者。谓由此故。或有最初思择诸法。或奢摩他而为上首。寂静作意者。谓由此故。或有最初安心于内。或毗钵舍那而为上首。一分修作意者。谓由此故。于奢摩他毗钵舍那。随修一分。具分修作意者。谓由此故。二分双修。无间作意者。谓一切时无间无断。相续而转。殷重作意者。谓不慢缓加行方便。此中由胜解思择作意故。净修智见。由寂静作意故。生长轻安。由一分具分修作意故。于诸盖中。心得解脱。由无间殷重作意故。于诸结中。心得解脱。又由无间作意故。终不徒然而舍身命。由殷重作意故。速证通慧。随顺作意者。谓由此故。厌坏所缘。顺断烦恼。对治作意者。谓由此故。正舍诸惑任持于断。令诸烦恼远离相续。顺清净作意者。谓由此故。修六随念。或复思惟随一妙事。顺观察作意者。谓由此故。观诸烦恼断与未断。或复观察自己所证。及先所观诸法道理。力励运转作意者。谓修始业未得作意者所有作意。有间运转作意者。谓已得作意。于上慢缓修加行者所有作意。有功用运转作意者。谓即于此勇猛精进无有慢缓。修加行者所有作意。自然运转作意者。谓于四时决定作意。一得作意时。二正入已入根本定时。三修现观时。四正得已得阿罗汉时。思择作意者。谓毗钵舍那品作意。内摄作意者。谓奢摩他品作意。净障作意者。谓由此故。弃舍诸漏永害粗重。依止成办所行清净作意者。谓由此故。依离一切粗重之身。虽行一切所缘境界。而诸烦恼不复现行。他所建立作意者。谓诸声闻所有作意。要从他音。乃能于内如理作意故。内增上取作意者。谓诸独觉及诸菩萨所有作意。以不从师而觉悟故。广大作意者。谓诸菩萨为善了知生死过失。出离方便发弘誓愿。趣大菩提所有作意。遍行作意者。谓佛世尊现见一切无障碍智相应作意。若诸菩萨遍于三乘及五明处方便善巧所有作意

此中了相作意。摄缘法缘义。余六作意。唯摄缘义。缘身等境四种作意。遍在七摄。了相胜解加行究竟果作意。通摄胜解真实作意。观察作意。唯摄胜解。余三作意。唯摄真实。此就前门。就余门者。当知随应七种作意皆摄。有学及非学非无学二种作意。亦摄无学作意。谓清净地了相作意。及加行究竟果作意。了相胜解观察作意。摄遍知作意。余三作意。摄正断作意。加行究竟果作意。摄已断作意。观察作意。唯摄有分别影像所缘作意。余六作意。通摄二种。事边际所缘作意。遍一切摄。所作成办所缘作意。若就初门。遍一切摄。就第二门。唯加行究竟果作意所摄。最初胜解思择作意。皆所不摄。若奢摩他而为上首。遍一切摄。若最初寂静。若毗钵舍那而为上首。当知亦尔。前六作意。通摄一分及具分修。加行究竟果作意。唯摄具分修。无间作意。殷重作意。遍一切摄。随顺作意。初二所摄。对治作意。远离。加行。究竟。二作意摄。及摄乐作意一分所摄。顺清净作意。唯摄乐一分所摄。顺观察断未断作意。唯观察作意所摄。此就断对治说。若就所余随应当知。力励运转作意。皆所不摄。有间有功用运转作意。乃至摄乐作意所摄。自然运转作意。加行究竟。及此果二作意摄。思择作意。了相所摄。内摄作意。胜解所摄净障作意。远离摄乐。观察加行究竟作意所摄。依止成办所行清净作意。唯加行究竟果作意所摄。他所建立内增上取作意。一切作意所摄。广大作意。皆所不摄。初遍行作意。加行究竟果摄。第二一切所摄。又了相作意。若他所建立作意摄者。以闻他音及内如理作意定为其缘。若内增上取作意摄者。唯先资粮以为其缘。所余作意。前前后后传为其缘。

复次云何所缘差别。谓相差别。何等为相。略有四种。一所缘相。二因缘相。三应远离相。四应修习相。所缘相者。谓所知事分别体相。因缘相者谓定资粮。应远离相。复有四种。谓沈相掉相。乱相着相。应修习相。当知对治此四种相。何等沈相。谓不守根门。食不知量。初夜后夜。不常觉寤勤修观行。不正知住。是痴行性。耽着睡眠。无巧便慧。恶作俱行。欲勤心观。不曾修习正奢摩他。于奢摩他未为纯善。一向思惟奢摩他相。其心惛闇。于胜境界不乐攀缘。何等掉相。谓不守根门等四。如前广说。是贪行性。乐不寂静。无厌离心。无巧便慧。太举俱行。如前欲等。不曾修举。于举未善唯一向修。由于种种顺随掉法亲里寻等动乱其心。何等乱相。谓不守根门等四。如前应知。是钝根性。多求多务。多诸事业。寻思行性。无巧便慧。无厌离心。不修远离。于胜境界。不乐攀缘。亲近愦闹方便间缺。不审了知乱不乱相。何等着相。谓不守根门等四。如前应知。是钝根性。是爱行性。多烦恼性。不如理思。不见过患。又于增上无出离见。对治如是应远离相。随其所应。当知即是应修习相

复有三十二相。谓自心相。外相。所依相。所行相。作意相。心起相。安住相。自相相。共相相。粗相。静相。领纳相。分别相。俱行相。染污相。不染污相。正方便相。邪方便相。光明相。观察相。贤善定相。止相。举相。观相。舍相。入定相。住定相。出定相。增相。减相。方便相。引发相。云何自心相。谓有苾刍。先为烦恼染污心故。便于自心极善取相。如是如是心有染污。或无染污。由此方便。心处沈等。由此方便。不处沈等。言沈等者。谓沈等四。乃至令心碍着之相。或复于彼被染污心。云何外相。谓即于彼被染污心。了知自心被染污已。便取外相。谓光明相。或净妙相。或复余相。为欲除遣诸烦恼故。或令彼惑不现行故。云何所依相。谓分别体相。即是一切自身所摄五蕴。并种子相。云何所行相。谓所思惟彼彼境界。色乃至法。分别体相。云何作意相。谓有能生作意故。于彼彼境界。所生识生。作是思惟。今我此心由作意故。于境界转。非无作意。此所思惟。名作意相。云何心起相。谓即次前所说是一相。第二相者。谓心缘行缘名色相。此所思惟。名心起相。云何安住相。谓四识住。即识随色住等。如经广说。此所思惟。名安住相。云何自相相。谓自类自相。或各别自相。此所思惟。名自相相。云何共相相。谓诸行共相。或有漏共相。或一切法共相。此所思惟。名共相相。云何粗相。谓所观下地一切粗相。云何静相。谓所行上地一切静相。云何领纳相。谓随忆念过去曾经诸行之相。云何分别相。谓思未来诸行之相。云何俱行相。谓分别现在诸行之相。云何染污相。谓于有贪心。思惟有贪心相。乃至。于不善解脱心。思惟不善解脱心相。云何不染污相。谓与此相违。当知即是不染污相。此中已出离于断。不修方便者。观有贪等。修方便者。观略下等。有贪心者。谓贪相应心。或复随逐彼品粗重。如是由缠及随眠故。一切染污心。如应当知。以能对治缠及随眠故。成不染污。云何正方便相。谓所思惟白净品因缘相相。云何邪方便相。谓所思惟染污品因缘相相。既是思惟如是如是。不守根门住故。乃至。不正知住故。如是如是心被染相。云何光明相。谓如有一于暗对治。或法光明殷勤恳到。善取其相。极善思惟。如于下方。于上亦尔。如是一切治暗相故。建立此相。云何观察相。谓有苾刍。殷勤恳到。善取其相。而观察之。住观于坐者。谓以现在能取。观未来所取法。坐观于卧者。谓以现在能取。观过去所取。或法在后行观察前行者。谓以后后能取。观前前能取法。此则略显二种所取能取法观。云何贤善定相。谓所思惟青瘀等相。为欲对治欲贪等故。何故此相说名贤善。诸烦恼中。贪最为胜。于诸贪中。欲贪为胜。生诸苦故。此相是彼对治所缘故名贤善。云何止相。谓所思惟。无分别影像之相。云何举相。谓策心所取随一净妙。或光明相相。云何观相。谓闻思修慧所思惟诸法相。云何舍相。谓已得平等心。于诸善品增上舍相。云何入定相。谓由因缘所缘应修习相故。入三摩地。或复已得而现在前。云何住定相。谓即于彼诸相。善巧而取。由善取故。随其所欲。于定安住。又于此定得不退法。云何出定相。谓分别体所不摄。不定地相。云何增相。谓轻安定。倍增广大。所思惟相。云何减相。谓轻安定。退减陜小。所思惟相。云何方便相。谓二道相。或趣倍增广大。或趣退减陜小故。云何引发相。谓能引发略诸广博文句义道。若无诤无碍妙愿智等。若依三摩地。诸余力无畏等最胜功德。及能通达甚深句义微妙智慧。如是等相

复次如是诸相。即前根本四相所摄。谓所缘相。具摄一切。因缘相亦尔。前与后为因缘故。为令后后得明净故。正方便相一切种别皆因缘相。如正方便。邪方便亦尔。一是白品相。第二黑品相。诸染污相。唯应远离。所余诸相。唯应修习。于彼彼时应修习故

瑜伽师地论卷第十一瑜伽师地论卷第十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中三摩呬多地第六之二

复次。云何修习所缘诸相作意。谓即于彼彼诸相。作意思惟。以思惟故。能作四事。谓即修习如是作意。又能远彼所治烦恼。又能练此作意及余。令后所生转更明盛。又即修习此作意时。厌坏所缘。舍诸烦恼。任持断灭。令诸烦恼远离相续。是故修习如是所缘诸相作意

复次由四因缘。入初静虑乃至有顶。谓因力。方便力。说力。教授力。云何因力。谓曾邻近入静虑等。云何方便力。谓虽不邻近入静虑等。然由数习无间修力。能入诸定。云何说力。谓于静虑等增上缘法多闻任持。乃至广说。即依此法。独处空闲。离诸放逸。勇猛精进。自策励。住法随法行。由此能入静虑等定。云何教授力。谓于亲教轨范师所。成于随一余尊长所。获得随顺初静虑等。无倒教授。从此审谛作意思惟。能入静虑及诸余定。如是显示四观行者。谓具因力者。方便力者。若利根者。及钝根者

复次有四得静虑者。一爱上静虑者。二见上静虑者。三慢上静虑者。四疑上静虑者。云何爱上静虑者。谓如有一先闻静虑诸定功德。而不闻彼出离方便。于彼一向见胜功德。勇猛精勤。由此因缘。入初静虑或所余定。如是入已。后生爱味。云何见上静虑者。谓如有一。从自师所或余师所。闻诸世间皆是常等。如是方便入初静虑乃至有顶。能得清净解脱出离。彼依此见。勇猛精勤。由是因缘。入初静虑或所余定。如是入已。能自忆念过去多劫。遂生是见。我及世间皆是常等。从定起已。即于此见。坚执不舍。复于后时。审思审虑。审谛观察。谓由此故当得清净解脱出离。云何慢上静虑者。谓如有一闻如是名诸长老等入初静虑乃至有顶。闻是事已。遂生憍慢。彼既能入静虑等定。我复何缘。而不当入。依止此慢。勇猛精勤。由是因缘。入初静虑及所余定。如是入已。后生憍慢。或入定已。作是思惟。唯我能得如是静虑。余不能得。彼依此慢。复于后时。于诸静虑。审思审虑。审谛观察。云何疑上静虑者。谓如有一为性暗钝。本尝乐习奢摩他行。由此因缘。入诸静虑或所余定。如是入已。复于上定勤修方便。为得未得。于四圣谛。勤修现观。性暗钝故不能速证圣谛现观。由此因缘。于余所证。便生疑惑。依此疑惑。复于胜进。审思审虑。审谛观察。

复次。云何爱味相应静虑等定。谓有钝根。或贪行故。或烦恼多故。彼唯得闻初静虑等所有功德。广说如前。爱上静虑于上出离。不了知故。便生爱味。恋着坚住。其所爱味。当言已出。其能爱味。当言正入。云何清净静虑等定。谓有中根或利根性等。烦恼行或薄尘行。彼从他闻初静虑等爱味过患及上出离。勇猛精进。入初静虑或所余定。如是入已。便能思惟诸定过患。于上出离。亦能了知。不生爱味。云何无漏静虑等定。谓如有一是随信行。或随法行。薄尘行类。彼或先时于四圣谛。已入现观。或复正修现观方便。彼先所由诸行状相。入初静虑或所余定。今于此行此状此相。不复思惟。然于诸色乃至识法。思惟如病如痈等行。于有为法。心生厌恶。怖畏制伏。于甘露界。系念思惟。如是方能入无漏定

复次。云何顺退分定。谓有钝根下劣。欲解勤精进故。入初静虑或所余定。于喜于乐。于胜功德。不堪忍故。从静虑退。如如暂入诸定差别。如是如是还复退失。乃至。未善调练诸根。云何顺住分定。谓有中根或利根性。彼唯得闻诸定功德。广说如前。爱味相应。于所得定。唯生爱味。不能上进。亦不退下。云何顺胜分定。谓有亦闻出离方便。于所得定。不生喜足。是故于彼不生爱味。更求胜位。由此因缘。便得胜进。云何顺决择分定。谓于一切萨迦耶中。深见过患。由此因缘。能入无漏。又诸无漏名决择分。极究竟故。犹如世间珠瓶等物。已善简者名为决择。自此已后。无可择故。此亦如是。过此更无可简择故。名决择分

复次。云何无间入诸等至。谓如有一得初静虑乃至有顶。然未圆满清净鲜白。先顺次入乃至有顶。后逆次入至初静虑

复次。云何超越入诸等至。谓即于此已得圆满清白故。从初静虑无间超入第三静虑。第三无间超入空无边处。空处无间超入无所有处。乃至广说。逆超亦尔。以极远故。无有能超第三等至。唯除如来及出第二阿僧企耶诸大菩萨。彼随所欲入诸定故

复次。云何薰修静虑。谓如有一已得有漏及与无漏四种静虑。为于等至得自在故。为受等至自在果故。长时相续入诸静虑。有漏无漏更相间杂。乃至有漏无间无漏现前。无漏无间还入有漏。当知齐此薰修成就。若于是处是时是事。欲入诸定。即于此处此时此事能入诸定。是名于诸等至获得自在。等至自在果者。谓于现法乐住。转更明净。又由此故。得不退道。又净修治解脱胜处及遍处等胜品功德能引之道。若有余取而命终者。由此因缘。便入净居。由软中上品修诸静虑有差别故。于一切处受三地果。如前有寻有伺地已广分别。修习无寻唯伺三摩地故。得为大梵。由软中上。上胜上极品。薰修力故。生五净居。当知因修清净静虑定故。生静虑地。不由习近爱味相应。既生彼已。若起爱味。即便退没。若修清净。还生于彼。或生下定。或进上定。先于此间。修得定已。后往彼生。何以故。非未离欲得生彼故。非诸异生未修得定能离欲故。又非此间及在彼处入诸等至乐有差别。唯所依身而有差别

复次。已说修习作意相差别。云何摄诸经宗要。谓八解脱等。如经广说。

八解脱者。谓如前说。有色观诸色等。前七解脱。于已解脱。生胜解故。名为解脱。第八解脱。弃背想受故名解脱。云何有色观诸色。谓生欲界。已离欲界欲。未离色界欲。彼于如是所解脱中。已得解脱。即于欲界诸色。以有光明相。作意思惟。而生胜解。由二因缘。名为有色。谓生欲界故。得色界定故。又于有光明。而作胜解故。问观诸色者。观何等色。复以何行。答欲界诸色。于诸胜处所制少色。若好若恶若劣若胜。如是于多。乃至广说。何故修习如是观行。为净修治能引最胜功德方便。何等名为最胜功德。谓胜处。遍处。诸圣神通。无诤愿智。无碍解等。虽先于彼欲界诸色已得离欲。然于彼色未能证得胜解自在。为证得故。数数于彼思惟胜解。云何内无色想观外诸色。谓生欲界。已离色界欲。无色界定不现在前。又不思惟彼想明相。但于外色而作胜解。若于是色已得离欲。说彼为外。由二因缘。名内无色想。谓已证得无色等至。亦自了知得此定故。不思惟内光明相故。余如前说。云何净解脱身作证具足住。谓如有一已得舍念圆满清白。以此为依。修习清净圣行圆满名净解脱。何以故。三因缘故。谓已超过诸苦乐故。一切动乱已寂静故。善磨莹故。身作证者。于此住中。一切贤圣多所住故。云何空无边处解脱。谓如有一于彼空处已得离欲。即于虚空思惟胜解如是。识无边处解脱。于彼识处已得离欲。即于是识思惟胜解。无所有处解脱者。谓已得无所有处。于识无边处思惟胜解。有顶解脱。更不于余而作胜解。乃至遍于想可生处。即于是处应作胜解

复次。先已修治作意胜解。后方能起胜知胜见故名胜处。此胜当知复有五种。一形夺卑下故名为胜。谓如有一以己胜上工巧等事形夺他人置下劣位。二制伏羸劣故名为胜。谓如有一以己强力摧诸劣者。三能隐蔽他故名为胜。谓瓶盆等能有覆障。或诸药草咒术神通有所隐蔽。四厌坏所缘故名为胜。谓厌坏境界舍诸烦恼。五自在回转故。名为胜。谓世君王随所欲为处分臣仆。于此义中。意显隐蔽及自在。胜前解脱中胜解自在。今于胜处制伏自在。观色少者。谓诸有情资具等色。观色多者。谓诸宫殿房舍等色。言好色者。谓美妙显色。一向净妙故。与此相违。名为恶色。言劣色者。谓声香味触不可意色。与此相违。当知胜色。此四显色。有情资具宫殿等摄。言胜知者。谓数数隐蔽所缘胜解。有如是想者。谓有制伏想也

复次。由诸遍处于胜解事生遍胜解故名遍处。言无二者。谓诸贤圣无我我所二差别故。言无量者。遍一切故。何故遍处。唯就色触二处建立。由此二种共自他身遍有色界常相续故。眼等根色。唯属自身。香味二尘。不遍一切。声声有间。是故不说。如是有色诸遍处。定色界后边。于无色中。空遍一切故立遍处。识所行境遍一切故。亦立遍处

复次修观行者。先于所缘思惟胜解。次能制伏。既于制伏得自在。已后即于此遍一切处。如其所欲而作胜解。是故此三如是次第。八色遍处。善清净故。能引贤圣胜解神通。及于诸事转变神通。如其胜解。随所转变。皆能成就。又能变作金银等物。堪有所用。由识遍处善清净故。便能引发无诤愿智无碍解等诸胜功德。由空遍处善清净故。随其所欲皆转成空。譬如世间凡铁金师。初和泥等未善调练。解脱位亦尔。如善调练。胜处位亦尔。如调练已随欲转变。遍处位亦尔

复次。三三摩地者。云何空三摩地。谓于远离有情命者及养育者数取趣等。心住一缘。当知空性略有四种。一观察空。谓观察诸法空无常乐。乃至。空无我我所等。二彼果空。谓不动心解脱。空无贪等一切烦恼。三者内空。谓于自身空。无计我我所及我慢等一切僻执。四者外空。谓于五欲空无欲爱。如说我已超过一切有色想故。于外空身作证具足住。乃至广说。此中缘妙欲想。名为色想。此想所起贪欲断故。说为外空。又修行者。由彼果空。或时作意思惟外空。或时作意思惟内空。由观察空或时思惟内外空性。由此力故。心俱证会。设复于此内外空性。不证会者。便应作意思惟无动。言无动者。谓无常想。或复苦想。如是思惟。便不为彼我慢等动。由彼不为计我我慢乃至广说动其心故。便于二空心俱证会。云何无愿心三摩地。谓于五取蕴。思惟无常。或思惟苦。心住一缘。云何无相心三摩地。谓即于彼诸取蕴灭。思惟寂诤。心住一缘。如经言。无相心三摩地。不低不昂。乃至广说。云何名为不低不昂。违顺二相不相应故。又二因缘入无相定。一不思惟一切相故。二正思惟无相界故。由不思惟一切相故。于彼诸相不厌不坏。惟不加行作意思惟。故名不低。于无相界正思惟故。于彼无相不坚执着。故名不昂。此三摩地略有二种。一者方便。二方便果。言方便者。数数策励。思择安立。于彼诸相。未能解脱。由随相识。于时时中。扰乱心故。彼复数数自策自励。思择安立。方能取果。解脱随相。于此解脱又解脱。故不自策励思择而住。是故名为极善解脱。若数策励。思择安立。方得住者。虽名解脱。非善解脱。又晓了果。晓了功德者。谓烦恼断究竟故。现法乐住究竟故。又复灭道俱应晓了。即此二种。随其次第。名晓了果晓了功德。又谛现观阿罗汉果。俱应晓了。于见道位中。名晓了果。于阿罗汉果。名晓了功德。若于此处无有彼物。由此道理观之为空。故名空性。即所观空。无可希愿。故名无愿。观此远离一切行相故名无相。何故此中先说空性。余处宣说无常故苦。苦故无我。后方说空。谓若无无我。无常苦观终不清净。要先安住无我之想。从此无间方得无愿。是故经言。诸无常想。依无我想。而得安住。乃至广说。彼于无常。观无我已。不生希愿。唯愿无相专求出离。故此无间宣说无相

复次云何有寻有伺三摩地。谓三摩地。寻伺相应。云何无寻唯伺三摩地。谓三摩地唯伺相应。大梵修已为大梵王。云何无寻无伺三摩地。谓三摩地。寻伺二种。俱不相应。修习此故。生次上地乃至有顶。唯除无漏诸二摩地。云何无寻无伺三摩地相。谓于寻伺。心生弃舍。唯由一味。于内所缘。而作胜解。又唯一味平等显现

复次云何小三摩地。谓或由所缘故。小观少色故。或由作意故小。小信小欲小胜解故。云何大三摩地。谓或由所缘故大。观多色故。而非无边无际观诸色故或由作意故大。上信上欲上胜解故。而非无边无际信欲胜解故。云何无量三摩地。谓或由所缘故。无量无边无际观诸色故。或由作意故。无量无边无际信欲胜解故。此中大心三摩地者。谓于一树下想诸天光而生胜解。乃至广说。无量三摩地者。谓四无量。云何于一树下想诸天光而生胜解。谓于欲界极厌坏已得初静虑。为令此定善清净故。更修方便。又闻诸天身带光明。便思惟彼身光明相遍一树下乃至大地大海边际。发生胜解。由三摩地。后后转增。有差别故。令所生起而有差别。云何作意得成唯二。谓随胜解分齐。施设作意故。云何作意唯二为缘修成唯二。谓即由此作意力故。施设所修定有差别。圆满清净转增胜故。云何以修唯二为缘行成唯二。谓如如善修定转增胜。如是如是施设所感生有差别。云何以行唯二为缘补特伽罗建立唯二。谓此因缘所生有情。施设高下胜劣差别。问初二静虑诸天光明有何差别。答如末尼珠外有光明内无光明。初静虑身亦复如是。外放光明内则不尔。譬如明灯外发光明内自照了。第二静虑身亦如是。若内若外俱有光明。是故经说彼地已上唯一种身。非于下地

复次云何建立四无量定。谓诸有情有三品故。一者无苦无乐。二者有苦。三者有乐。如其次第。欲与其乐。欲令离苦。欲令其乐永不相离。于彼作意。有四种故。如其次第。建立四种。谓由与乐作意故。拔苦作意故。乐不相离随喜作意故。建立前三。即于此三欲与乐等。为欲令彼不乐思慕不染污作意故。嗔恚不染污作意故。贪欲不染污作意故。建立于舍。经言以慈俱心。乃至广说。现前饶益故名慈俱。饶益相故名慈善友。其饶益相略有二种。一欲利益。二欲安乐。此二种相。一切无量之所显示。无怨者。离恶意乐故。无敌者。离现乖诤故。无恼害者。离不饶益事故。广者。所缘广大故。大者。利益安乐思惟最胜故。无量者。果无量故。如四大河众流杂处。善修习者。极纯熟故。设有问言。慈俱等心有何等相。故次答言。胜解遍满具足而住。胜解遍满者。增上意乐胜解周普。义具足者。圆满清白故。住者。所修观行日夜专注时专注故。问如经言。善修习慈极于遍净。乃至广说。此何密意。答第三静虑。于诸乐中其乐最胜。忆念此乐。修习慈心。慈最第一故。说修慈极于遍净。忆念空处。修习悲心。亦最第一。以修悲者乐欲拔苦。无色界中。远离众苦断坏等苦。彼都无故。是故忆念无边空处。修悲等至。作如是念。当令一切有苦有情。到无众苦及所依处。修喜定者。亦常忆念无边识处。庆诸有情所得安乐。作如是念。当令一切有情之类受无量乐。犹如识处。识无限量。是故忆念识无边处。修习喜定。为最第一。修舍定者。亦常忆念无所有处。作如是念。无所有处无漏心地最为后边。舍最第一。如阿罗汉苾刍一切苦乐不苦不乐现行位中皆无染污。当令一切有情之类得如是舍。是故忆念无所有处。修习舍定为最第一。如是一切皆是圣行。唯圣能修。故经宣说觉分俱行

复次。云何一分修三摩地。谓于此中。或唯作意思光明相。或唯作意思惟色相。而入于定。如是二种随其次第。或了光明或睹众色。云何具分修三摩地。谓俱思惟而入于定。亦了光明亦见众色。如是修习光明定者。定难差别。有十一种。所谓疑等。如经广说。问此谁难耶。答三摩地相。相有二种。谓所缘相。及因缘相。用彼为依住三摩地。若退彼相便不能住。此中最初于所显现光明色相。不善知故。便觉有疑。方便缓故。有不作意。如于众色不欲见者。或闭于目。或复背面。此观行者。于诸色中不欲作意。亦复如是。由不善守根门等故。有身粗重。多习睡眠。或多觉悟。便增惛睡不见众色。设有所见而不圆满。为此二事极作功用。力励思惟。故有太过勇猛精进。由有太过策励过故。还极下劣。如急捉持斥鷃鸟者。彼唯思求光明之相。此与见色若俱生时。悕一得二。便生踊跃。犹如有人得二伏藏。遍于诸方欻然并见不祥之色便生大怖。犹如有人两边旋转卒起。彼于行时或复住时。于世杂类起种种想。如是外想。与定为难。或复因其所修习定。谓己为胜。观他为劣。便自高举。如是亦得名种种想。或多言论。或久寻思。令身疲劳。心不得定。如是多言与定为难。若从定生光明之相及见色时。便舍内修相续作意愿乐。于外谛视众色故。极思察与定为难。如是诸难。随其所应障三摩地。所缘境相及因缘相。或有遇此退失所缘因缘相故。如其次第二相俱没

复次云何喜俱行三摩地。谓初二静虑诸三摩地。云何乐俱行三摩地。谓第三静虑诸三摩地。云何舍俱行三摩地。谓第四静虑已上诸三摩地

复次云何修定为得现法乐住。谓于四种现法乐住。方便道中所有修定。及未圆满清净鲜白诸根本地所有修定。为显修习未曾得定。是故世尊说初静虑前方便道。云何修定为得智见。谓诸苾刍。于光明相。殷勤恳到审谛而取。如经广说。当知此在能发天眼前方便道所有修定。此中天眼于诸色境能照能观说名为见。能知诸天如是名字如是种类。乃至广说。如胜天经。是名为智。云何修定生分别慧。谓谛现观预流果向方便道中所有修定。或为修习诸无碍解。云何修定为尽诸漏。谓阿罗汉果方便道中所有修定

复次云何五圣智三摩地。谓我此三摩地是圣无染无执。广说如经。此中示现五行相智。谓自体智。补特伽罗智。清净智。果智。入出定相智。圣者。善故名圣。又无漏故名圣。无染者。显善圣性。无执者。显无漏圣性。非凡夫所近者。谓诸佛及圣弟子所亲近故。是聪睿所赞者。谓即彼所称赞故。是诸聪睿同梵行者。常不诃毁者。谓一切时常称赞故。非如世间初静虑等为背下地修方便故。先以静相而称赞之。为趣上地修方便故。后以粗相而复呵毁。寂静者。所治烦恼永寂静故。微妙者。自地烦恼不爱味故。得安隐道者。所得之道无退转故。证心一趣者。已得无寻无伺地故。现在安乐者。能得现法乐住故。后乐异熟者。引无余依涅槃乐故。正念而入者。善取能入三摩地相。无忘失故。正念而出者。善取能出三摩地相。无忘失故

复次云何圣五支三摩地。谓诸苾刍。即此身内离生喜乐。广说如经。离生喜乐者。谓初静虑地所摄喜乐。所滋润者。谓喜所润。遍滋润者。谓乐所润。遍充满者。谓加行究竟作意位。遍适悦者。谓在已前诸作意位。由彼位中亦有喜乐时时间起。然非久住。亦不圆满。于此身中。无有少分而不充满者。谓在加行究竟果作意位。譬如黠慧能沐浴人。或彼弟子者。当知喻于修观行者。铜器瓦器或蚌蛤器者。喻为离欲生喜乐故教授教诫。细沐浴末者。喻能顺彼出离寻等。水浇灌者。当知喻于寻清净道。沐浴抟者。以喻于身。带津腻者。喻喜和合。腻所随者。喻乐和合。遍内外者。喻无间隙喜乐和合。不强者。喻无散动。不弱者。喻无染污亦无爱味。又于第二喻有差别。山者喻于无寻伺定。尖顶者。喻于第二静虑。无寻无伺于所缘境一味胜解。泉者。喻于内等净支。水轴者。谓水傍流出。水索者。谓水上涌出。此二种喻。如其次第。显示喜乐。滋润等言。如前解释。无不充满者。当知喻于无间相应。又于第三喻有差别。如嗢钵罗等。离喜之乐。彼相应法。及所依身。当知亦尔。水喻离喜无寻伺定。喜发踊跃。由无彼故。喻花胎藏没在水中。又于第四喻有差别。清净心者。谓与舍念清净相应。超过下地诸灾患故。鲜白者。谓性是善。自地烦恼无爱味故。何故复以长者为喻。谓彼所作皆审悉故。不放逸故。思惟筹量观察胜故。于增减门无不知故。证得清净第四静虑者。亦复如是。凡有所为审谛圆满无诸放逸。于一切义无不了知。其性捷利。八经九经以为喻者。由坚致故。显蚊虻等不能侵损。首足皆覆者。若有二失容可侵损。谓衣薄故。有露处故。今此显示二失俱无。此定亦尔。其心清净鲜白周遍。一切散动所不能侵。堪忍寒暑乃至他所呵叱恶言。及内身中种种苦受。又于第五喻有差别。于所观相殷勤恳到等。当知已如前释。谓审观察三世诸行。于能观察又复观察。是此中总义。何等名为圣三摩地。云何建立五支差别。谓四静虑中所有圣贤心一境性。及于安立审谛观察。如是名为圣三摩地。依于四种现法乐住。建立四支。依审观察缘起法故。又为断除余结缚故。建立第五。当知此由二因缘故。建立五支。

复次。云何有因有具圣正三摩地。当知善故。及无漏故。说名为圣。有五道支名此定因。所谓正见。正思惟。正语。正业。正命。具有三种。所谓正见正精进正念。此中薄伽梵总说。前七道支与圣正三摩地。为因为具随其所应。差别当知。谓由前导次第义故。立五为因。于三摩地资助义故。立三为具。云何正见等前导次第义。谓先了知世间实有真阿罗汉正行正至。便于出离。深生乐欲。获得正见。次复思惟。何当出离居家迫迮。乃至广说。从此出家受学尸罗。修治净命。是名正语正业正命。此正见等。于所对治邪见等五。犹未能断。还即依止此五善法。从他闻音。展转发生闻慧正见。为欲断除所治法故。又为修习道资粮故。方便观察。次依闻慧。发生思慧。复依思慧。发生修慧。由此正见。于诸邪见。如实了知此是邪见。于诸正见。如实了知此是正见。乃至正命。如实知已。为欲断除邪见等故。及为圆满正见等故。发勤精进。若由此故。能断所治。集能治法。令其圆满。是名正念。此念即是三摩地分故。亦兼说正三摩地。若是时中。舍邪见等。令不复生。修正见等。令得圆满。即于如是方便道中。亦能弃舍邪精进念。兼能修满正精进念。若于是时。于彼诸法。能断能满。即于此时。圣正三摩地。亦得圆满。此中由慧为导首。于增上戒。先自安处。次闻他音。如理作意。及增上戒学。二为依止。于方便道中。发生增上心学。及增上慧学。此中正念。名增上心学。正见正精进。名增上慧学。如是三学。于修圣正三摩地时。皆得圆满

复次。云何金刚喻三摩地。谓最后边学三摩地。此三摩地最第一故。最尊胜故。极坚牢故。上无烦恼能摧伏故。摧伏一切诸烦恼故。是故此定名金刚喻。譬如金刚其性坚固。诸末尼等不能穿坏。穿坏一切末尼宝等。此定亦尔。故喻金刚

复次。云何五现见三摩钵底。谓诸苾刍。即于此身等。广说如经。已见谛者修此等至。是故名为现见等至。是诸修道所断烦恼制伏对治。断灭对治。及观察断。当知此中总略体性。初不净观。方便念住。以为依止。为令欲贪不现行故。观察内身种种不净。第二不净观。即彼念住以为依止。乃至。观察骨人之相。为令彼贪不现行故。观察此身种种不净。当知齐此名具观察一切不净。最极通达者。是青瘀等观。品类次第极逾越义。初不净观观察内身现前安住种种不净。后不净观。通达法性。观察此身有如是法有如是性。乃至广说。观识流转者。观察此识生灭相续。或观生身展转相续。谓粗观察行缘识等。或观刹那展转相续。谓细观察若有贪心离贪心等品类差别。荏苒过度彼彼日夜。刹那腊缚。牟呼栗多。于其中间。非一众多种种心识异生异灭。观察有学未离欲者俱住二世。已离欲者惟住他世。阿罗汉果俱无所住。如是名为观察。

于断胜处等至遍处等至。如前已说

复次。云何无想三摩钵底。谓已离遍净欲。未离上欲。求出离想作意为先。诸心心法灭。问以何方便入此等至。答观想如病如痈如箭。入第四静虑。修背想作意。于所生起种种想中。厌背而住。唯谓无想寂静微妙。于无想中持心而住。如是渐次离诸所缘。心便寂灭。于此生中。亦入亦起。若生于彼。唯入不起。其想若生便从彼没

复次。云何灭尽三摩钵底。谓已离无所有处欲。暂安住想作意为先。诸心心法灭。问以何方便。入此等至。答若诸圣者。已离无所有处欲。或依非想非非想处相而入于定。或依灭尽相而入于定。依非想非非想处相而入定者。谓于此上心深生厌舍。非想非非想处进趣所缘皆灭尽故。心便寂灭。依灭尽相而入定者。亦复如是。将欲趣入灭尽定时。有二种法。多有所作。谓奢摩他。毗钵舍那。云何奢摩他。云何毗钵舍那。云何此二多有所作。谓于此义中八次第定名奢摩他。所有圣慧名毗钵舍那。于此二中随阙一种即不能入灭尽等至。要具此二方能趣入。是故此二多有所作。问入灭定时云何次第灭三种行。答此有二种。谓行时住时。若于行时。亦起言说。于初静虑有此作用。有语行故。若于住时。从第二静虑已上次第定力。彼三种行次第而灭。当知出时。由逆次第次第而起。问灭尽定中。诸心心法并皆灭尽。云何说识不离于身。答由不变坏诸色根。中有能执持转识种子阿赖耶识。不灭尽故。后时彼法从此得生。问入灭定时。无有分别。我当入定。我当出定。正在定时。心寂灭故。远离加行。将出定时。心先灭故。亦无作意。云何能入云何能出。答先于其心善修治故。若有诸行诸状诸相。能入于定。能出于定。于彼修习极多修习。由修习故。任运能入。任运能出。云何出灭定时。触三种触。一不动触。二无所有触。三无相触。谓出定时。多由三境而出于定。一由有境。二由境境。三由灭境。由此三境。于出定时。如其次第。触三种触。缘于有境。而出定时。无有我慢扰动其心。谓此为我而起我慢。或计未来我当有等。乃至广说。是故说言触不动触。缘于境境而出定时。无贪所有无嗔所有无痴所有。是故言触无所有触。缘于灭境而出定时。于一切相不思惟故缘无相界。是故说言触无相触。如是已说静虑解脱等持等至

瑜伽师地论卷第十二瑜伽师地论卷第十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中三摩呬多地第六之三

复次。如世尊言。汝等苾刍。当乐空闲勤修观行内心安住正奢摩他者。谓能远离卧具贪着。或处空闲。或坐树下。系念现前。乃至广说。名乐空闲。当知此言显身远离。若能于内九种住心。如是名为内心安住正奢摩他。当知此言显心远离。若乐处空闲。便能引发内心安住正奢摩他。若内心安住正奢摩他。便能引发毗钵舍那。若于毗钵舍那善修习已。即能引发于诸法中如实觉了

复次。如世尊言。汝等苾刍。于三摩地。当勤修习无量常委安住正念者。谓先总标。于三摩地。勤修习已后。以三事别显修相。无量者。谓四无量。常委者。谓常有所作。及委悉所作故名常委。安住正念者。显于四念住。安住其心。何故说此三种修相。谓依二种圆满故。一者世间圆满。二者出世圆满。修无量故。便能引发世间圆满。修正念故。便能引发出世圆满。常委修故。于此二种速得通达。由此因缘。处二中说。是故但说三种修相。又无量者。显奢摩他道。住正念者。显毗钵舍那道。常委者。显此二种速趣证道。又无量者。显趣福德行。住正念者。显趣涅槃行。常委者。显趣二种速圆满行。先于奢摩他善修习已后与毗钵舍那方得俱行。修此二种三摩地故。如实觉了所知境界

复次。如世尊言。修静虑者。或有等持善巧。非等至善巧。广说如经。嗢柁南颂。云何等持善巧。谓于空等三三摩地得善巧故。云何非等至善巧。谓于胜处遍处灭尽等至不善巧故。云何等至善巧非等持善巧。谓于十种遍处等至及无想等至。若入若出俱得善巧。非于三三摩地。云何俱善巧。谓于彼二俱善巧故。云何俱不善巧。谓于彼二俱不善巧故。如是于先所说等持等至中。随其所应当善建立。又说等持善巧非等至善巧者。谓于等持名句文身。善知差别。非于能入等至诸行状相差别。云何等至善巧非等持善巧。谓如有一善知能入随一等至诸行状相。亦能现入。而不善知此三摩地名句文身差别之相。亦不能知我已得入如是如是等持差别。有诸菩萨。虽能得入若百若千诸三摩地。而不了知彼三摩地名句文身。亦不能知我已得入如是如是等持差别。乃至。未从诸佛所闻。及于已得第一究竟诸菩萨所而得听闻。或自证得第一究竟。云何为住。谓善取能入诸三摩地诸行状相。善取彼故。随其所欲能住于定。于三摩地无复退失。如是若住于定。若不退失。二俱名住。云何为出。谓如有一于能入定诸行状相。不复思惟。于不定地。分别体相所摄定地不同类法。作意思惟出三摩地。或随所作因故。或定所作因故。或期所作因故。而出于定。随所作者。谓修治衣钵等诸所作业。定所作者。谓饮食便利。承事师长等诸所作业。期所作者。谓如有一先立期契。或许为他当有所作。或复为欲转入余定。由此因缘出三摩地。何等为行。谓如所缘作种种行而入于定。谓粗行静行。病行痈行。箭行无常行等。若于彼彼三摩地中。所有诸行。何等为状。谓于诸定临欲入时便有此定相状先起。由此状故。彼自了知我于如是如是相定。不久当入。或复正入。彼教授师由此状故。亦了知彼不久当入如是如是相定。何等为相。谓二种相。一所缘相。二因缘相。所缘相者。谓分别体。由缘此故。能入诸定。因缘相者。谓定资粮。由此因缘。能入诸定。谓随顺定教诫教授。积集诸定所行资粮。修俱行欲厌患有心。于乱不乱审谛了知。及不为他之所逼恼。或人所作。或非人所作。或音声所作。或功用所作。云何调善。谓若三摩地犹为有行之所拘执。如水被持。或为法性之所拘执。不静不妙非安隐道。亦非证得心一趣性。此三摩地不名调善。不随所乐安隐而住。与此相违名为调善。云何犹为有行拘执。谓由誓愿俱行思故。制伏外缘持心。于定又于作意要由功用方能运转。不令内心于外流散。故作是说如水被持。云何法性之所拘执。谓观下地为粗法性。观于上地为静法性。寂静微妙得安隐道。及能证得心一趣性。如五圣智三摩地中已略解释。云何所行。谓三摩地所行境界。由所得定。过此已上不能知故。如初静虑不能观见第二静虑。如是根度。数取趣度。亦不能知。云何引发。谓能略摄广文句义。及能成办诸胜功德。云何等爱。谓惭愧爱敬信。正思惟。正念。正知。根护。戒护。及无悔等。乐为最后。由随乐故。心便得定。与此相违。名不等爱。云何等爱亦不等爱。谓如有一于惭愧等少分成就。少不成就。谓具惭愧。而无爱敬。乃至广说。云何为增。谓所得定转复增长。云何为减。谓所得定还复退失。云何方便。谓趣彼二道。又止举舍。当知如前止等相中已具分别

复次如分别静虑经言。有静虑者。即于兴等。谓之为衰。乃至广说。此中四转。当知二时颠倒。谓于三摩地。若退堕时。若胜进时。趣退及退。俱名为衰。趣胜进道及与胜进。俱名为兴。云何应知于三摩地进时颠倒。彼谓我今退失离生喜乐。我今退失胜三摩地。谓静虑者。勤修习故。心趣寂静随舍行故。从初静虑入于第二静虑近分。然于此事不善了知。于此位中初静虑地喜乐已过。第二静虑地中所有喜乐犹未能得。便作是念。于今退失离生喜乐。遂还从彼退摄其心。当知如是修静虑者。其心颠倒。云何应知于三摩地退时颠倒。谓如有一得初静虑。为涅槃故。积集资粮。彼于涅槃。已得所修资粮圆满。由此因缘。或由功用。或复任运。起如是想作意现前。由如是想作意故。于诸色中乃至识中。了知如病乃至无我。由如是想作意故。从此无间因世间定所生喜乐不复现行。便作是念。我今退失定生利益及所依止。遂还从彼退摄其心。如是当知修静虑者。于三摩地退失颠倒。云何当知于三摩地退失无倒。谓如有一得初静虑。便生喜足。不求上进。唯起爱味。由起如是欲俱行想作意故。遂便退失近欲界定。彼于此衰能了是衰。由此因缘。当知无倒。又由所得静虑定故。自誉毁他。谓我所得此静虑定非余能得。由起如此欲俱行想作意故。所有盖缠。转增转厚。便从定退。彼于此衰能了是衰。又以所得静虑诸定。显示于他。为诸国王及王臣等当供养我。从定起已。寻思此事。由如是欲俱行想作意故。所有盖缠。转增转厚。余如前说。如是当知修静虑者。于三摩地。退失无倒。第二无倒。翻初无倒。应知其相。此二无倒。亦于二时。应知其相。由依如是倒无倒处。安立四转

复次如分别四捡行定经中。由四种相。捡行一切三摩地等。谓此等持是顺退分。乃至。此是顺决择分。云何捡行。谓此是劣分。此是胜分。此殊胜分。此最胜分。如其次第。此复云何。谓修定者。从初静虑还退出已。于诸静虑。不复乐入。亦不思惟此行状相。然欲俱行诸想作意。数数现前。如先所说。从彼起已。随念爱味。当于尔时。修静虑者。应自捡行。我三摩地。今成退劣。又修定者。从初静虑还退出已。得闻随顺此定教法。谓初静虑诸行状相。殷勤恳到。善取其相。令所得定坚住不忘。如是随念顺定法故。成顺住分。当于尔时。应自捡行。我三摩地。已成其胜。我三摩地。已得安住。非退非进。非趣决择。又静虑者。从初静虑还退出已。得闻随顺第二静虑教授之法。既得闻已。第二静虑道俱行诸想作意。数数现前。当于尔时。应自捡行。我三摩地。已成殊胜。非退非住。唯是胜进。非趣决择。又修定者。从初静虑还退出已。闻苦谛等相相应教法。既得闻已。苦谛等俱行诸想作意。顺决择分数数现前。彼于尔时。当自捡行。我三摩地。已成最胜。非退非住。亦非胜进。然趣决择

复次如经言。有眼有色。乃至。有意有法。而诸苾刍。于此诸法。若实若有。都不领受。尚不受想。何况无想。此复云何。谓诸苾刍。于初静虑具足安住。由此因缘。厌坏眼色乃至意法。由厌坏故。威势映夺。遂于眼中。无有眼想。然有其想。乃至。于法无有法想。然有其想。云何有想。谓于眼等作意思惟。是苦是集。或是病等。彼于诸法不受自相。如是。乃至无所有处。此中正说无漏作意。云何名为不受无想。谓不思惟一切相故。于尽灭中。思惟寂静。此中意说离诸相想。名为无想。又说安住灭尽定者。一切诸想皆不生起

复次。如经中说四种趣道。云何宴坐于诸法中思惟简择。谓有苾刍。先已证得初静虑等。而未见谛。由听正法。及多闻故。而能宴坐。依三摩地。于苦等谛。发起现观。如是行者。依增上心。修增上慧。又有苾刍。如实知苦。乃至知道。而未证得初静虑等。彼便宴坐。思惟诸法。如是行者。依增上慧。修增上心。第三行者。名为俱得。奢摩他毗钵舍那。双杂转故。第四行者。先已证得初静虑等。未听正法。未习多闻。后从大师。或余尊所。闻见谛法。或复得闻断余结法。由此得入真谛现观。或复证得阿罗汉果。彼既证得出离所引。大善喜悦。由能制伏诸掉举心。复还宴坐。如是坐已。安心住于静虑等至。最初趣道。引见道故。第二第三。引修道故。第四趣道。为俱引故

复次。如经中说。有四净胜。为求清净。此最为胜。故名净胜。云何为净。云何为胜。谓所得所证所引戒等。若圆满若摄受。是名为净。发勤精进。未满令满。是名为胜。云何尸罗圆满摄受。谓若有一虽住具戒。亦能守护别解脱律仪。而于轨则及所行中。未能具足。未于小罪深见怖畏。此于尸罗。未名圆满。若于一切皆悉满足。乃名圆满。如是名为尸罗圆满。若于长时串修习故。便于根门善守而住。广说乃至。即于尸罗摄成自体自性安住。如是名为尸罗摄受。云何三摩地圆满。谓若已得加行究竟果。或第四静虑。乃名圆满。于此下位。皆未圆满。云何三摩地摄受。谓彼所得三摩地等。后时清净。又三摩地。不为有行之所拘执。乃至广说。云何见圆满。谓闻他音。及如理作意故。正见得生。由此正见。虽能知苦乃至知道。若未如实。犹不得名正见圆满。若能于彼。如实了知。尔时方名正见圆满。云何见摄受。谓于后时诸漏永尽。乃至广说。云何解脱圆满。谓若由有学智见。解脱贪等。未名圆满。若由无学智见。得解脱者。乃名圆满。云何解脱摄受。谓若行若住。常不退失现法乐住。如是名为解脱摄受

复次。如经言。心清净行苾刍。于时时间。应正作意思惟五相。乃至广说。方便勤修。增上心者。乃得名为心清净行。诸恶不善欲等寻思。及亲里等所有寻思。皆于此行。能为障碍。略有三种补特伽罗。由软中上寻思。行者有差别故。初由正思惟所余相故。令彼寻思不复现行。第二由见寻思深过患故。或复不念不思惟故。令彼寻思不复现行。云何不念及不思惟。由善于内安心等故。第三补特伽罗。非初即能令彼一切皆不现行。要当方便令寻思行渐渐歇薄。粗既息已。渐当制伏。若犹未能于寻思路寻思所缘深生厌怖。当以厌患俱行之心。多思惟力。于彼寻思俱行之心。调练制伏。如是三种补特伽罗。分为五种

复次。荡尘经中。佛世尊言。当如陶炼生金之法陶炼其心。乃至广说。如是等义云何应知。谓陶炼生金。略有三种。一除垢陶炼。二摄受陶炼。三调柔陶炼。除垢陶炼者。谓从金性中。渐渐除去粗中细垢。乃至惟有净金沙在。摄受陶炼者。谓即于彼郑重销煮。调柔陶炼者。谓销煮已。更细炼治瑕隙等秽。如金性内所有生金。种性位中。心净行者。当知亦尔。谓堪能证般涅槃者。问从何位名心净行者。答从得净信。求出家位。此于在家及出家位。有粗中细三种垢秽。其在家者。由二为障。不令出家。一不善业。谓常乐安处身语恶行。二邪恶见。谓拨无世间真阿罗汉正行正至。此于已得净信位。前能为障碍。欲等寻思障出家者。令其不能心生喜乐。亲等寻思。障喜乐者。令其不能恒修善法。由断彼故。恒修善法。速得圆满纯净之心。有寻有伺。如净金沙。是名为心除垢陶炼。犹如生金仍未销煮。若有复能止息寻思。乃至。具足安住第四静虑。是名为心摄受陶炼。由能摄受无寻无伺三摩地故。犹如生金已被销煮。若三摩地。不为有行之所拘执。乃至广说。是名为心调柔陶炼。于神通法。随其所欲。能转变故。如彼生金已细炼治瑕隙等秽

复次。如经言。应于三相作意思惟。乃至广说。应时时间作意思惟奢摩他等差别之相。不应一向为欲对治沉掉等故。若于止举未串习者。惟一向修是沉掉相。如此修者。当知住在方便道位。若时时间思惟舍相。如是在于成满道位。亦由于此一向修故。于缘起法及圣谛中。不思择故。心不正定。不尽诸漏。于诸谛中。若未现观。不能现观。或已现观。不得漏尽。初之二种。是三摩地能成办道。第三一种。依三摩地。尽诸漏道。是名略显此中要义。于时时间。作意思惟。遍一切故

复次。有四正法。摄持圣教。何等为四。一者远离。二者修习。三者修果。四者于圣教中无有乖诤。远离者。谓山林树下。空闲静室。修习者。谓住于彼勤修二法。谓奢摩他毗钵舍那。云何已习奢摩他。依毗钵舍那而得解脱。谓如有一先已得初静虑乃至第四静虑。彼即依此三摩地故。如实知苦。乃至知道。彼即依此毗钵舍那。于见所断诸烦恼中。心得解脱。云何已习毗钵舍那。依奢摩他心得解脱。谓如有一如实知苦。乃至知道。彼依如是增上慧故。发生静虑。即由如是奢摩他故。于修所断诸烦恼中。心得解脱。如是修习奢摩他毗钵舍那已。于诸界中而得解脱。见道所断诸行断故。名为断界。修道所断诸行断故。名离欲界。一切有执皆永灭故。名为灭界。是名修果。于圣教中无乖诤者。所谓大师及诸弟子。若义若句若文。于文句义。平等润洽。互相随顺。非如异道施设见解种种非一差别不同。第一句者。所谓前句。若以此句。问于初一。即以此句而问第二。设于初一。依蕴而问。复于第二。依余问者。便不得名与第一句平等润洽互相随顺

    本地分中非三摩呬多地第七

已说三摩呬多地。云何非三摩呬多地。当知此地相略有十二种。或有自性不定故名非定地。谓五识身。或有阙轻安故名非定地。谓欲界系诸心心法。彼心心法虽复亦有心一境性。然无轻安含润转故。不名为定。或有不发趣故名非定地。谓受欲者。于诸欲中。深生染着。而常受用。或有极散乱故名非定地。谓初修定者。于妙五欲。心随流散。或有太略聚故名非定地。谓初修定者。于内略心。惛睡所蔽。或有未证得故名非定地。谓初修定者。虽无散乱及以略聚娆恼其心。然犹未得诸作意故。诸心心法不名为定。或有未圆满故名非定地。谓虽得作意。然未证得加行究竟及彼果故。不名为定。或有杂染污故名非定地。谓虽证得加行究竟果作意。然为种种爱味等惑。染污其心。或有不自在故名非定地。谓虽已得加行究竟果作意其心亦无烦恼染污。然于入住出诸定相中。未得自在。未随所欲硬涩艰难。或有不清净故名非定地。谓虽自在随其所欲无涩无难。然唯修得世间定故。未能永害烦恼随眠诸心心法。未名为定。或有起故名非定地。谓所得定虽不退失。然出定故。不名为定。或有退故名非定地。谓退失所得三摩地故。不名为定

    本地分中有心无心二地第八第九

已说非三摩呬多地。云何有心地。云何无心地。谓此二地。俱由五门。应知其相。一地施设建立门。二心乱不乱建立门。三生不生建立门。四分位建立门。五第一义建立门

地施设建立者。谓五识身相应地。意地。有寻有伺地。无寻唯伺地。此四一向是有心地。无寻无伺地中。除无想定并无想生及灭尽定。所余一向是有心地。若无想定。若无想生。及灭尽定是无心地

心乱不乱建立者。谓四颠倒颠倒其心。名为乱心。若四颠倒不颠倒心。名不乱心。此中乱心亦名无心。性失坏故。如世间见心狂乱者便言此人是无心人。由狂乱心失本性故。于此门中。诸倒乱心名无心地。若不乱心名有心地

生不生建立者。八因缘故。其心或生。或复不生。谓根破坏故。境不现前故。阙作意故。未得故。相违故。已断故。已灭故。已生故。心不得生。由此相违诸因缘故。心乃得生。此中若具生因缘故。心便得生。名有心地。若遇不生心因缘故。心则不生。名无心地

分位建立者。谓除六位。当知所余名有心地。何等为六。谓无心睡眠位。无心闷绝位。无想定位。无想生位。灭尽定位。及无余依涅槃界位。如是六位。名无心地

第一义建立者。谓唯无余依涅槃界中。是无心地。何以故。于此界中。阿赖耶识亦永灭故。所余诸位。转识灭故。名无心地。阿赖耶识未永灭尽。于第一义。非无心地

    本地分中闻所成地第十之一

已说有心无心地。云何闻所成地。谓若略说。于五明处名句文身无量差别。觉慧为先。听闻领受。读诵忆念。又于依止名身句身文身义中。无倒解了。如是名为闻所成地。何等名五明处。谓内明处。医方明处。因明处。声明处。工业明处

云何内明处。当知略说由四种相。一由事施设建立相。二由想差别施设建立相。三由摄圣教义相。四由佛教所应知处相

云何事施设建立相。谓三种事总摄一切诸佛言教。一素怛缆事。二毗奈耶事。三摩怛履迦事。如是三事。摄事分中当广分别

云何想差别施设建立相。嗢拖南曰

  句迷惑戏论　　住真实净妙
  寂静性道理　　假施设现观

云何句。谓内六处。无量境界。无量方所。无量时分。复有三界。谓欲界色界无色界。又有三界。谓小千世界。中千世界。三千大千世界。复有四众。谓在家众。出家众。邬波索迦众。非人众。复有三受。谓苦受乐受不苦不乐受。复有三世。谓过去世未来世现在世。复有三宝。谓佛宝法宝僧宝。复有三法。谓善法不善法无记法。复有三杂染。谓烦恼杂染。业杂染。生杂染。复有四圣谛。谓苦圣谛。集圣谛。灭圣谛。道圣谛。复有九次第等至。谓初静虑等至。乃至。灭想受等至。复有三十七菩提分法。谓四念住。四正断。四神足。五根。五力。七觉支。八道支。复有四沙门果。谓预流果。一来果。不还果。最胜阿罗汉果。复有众多胜妙功德。谓无量解脱。胜处遍处。无诤愿智。无碍解六神通等。复有方广大乘五事。谓相名分别真如正智。复有二空性。谓补特伽罗空性。及法空性。复有二无我性。谓补特伽罗无我性。及法无我性。复有远离二边处中观行。谓离增益边。离损减边。复有四种真实。谓世间所成真实。道理所成真实。烦恼障净智所行真实。所知障净智所行真实。复有四寻思。谓名寻思。事寻思。自性假立寻思。差别假立寻思。复有四如实遍智。谓名寻思所引如实遍智。事寻思所引如实遍智。自性假立寻思所引如实遍智。差别假立寻思所引如实遍智。复有三种自性。谓遍计所执自性。依他起自性。圆成实自性。复有三无性性。谓相无性性。生无性性。胜义无性性。复有五相大菩提。谓自性故。功能故。方便故。转故。还故。复有五种大乘。一种子。二趣入。三次第。四正行。五正行果。最初发心。悲愍有情。波罗蜜多。摄众生事。自他相续成熟。复有五无量想。谓有情界无量想。世界无量想。法界无量想。所调伏界无量想。调伏方便界无量想。复有真实义随至。谓于一切无量法中。遍随至真如及于彼智。复有不思议威德胜解无障碍智。三十二大士夫相。八十种随形相。四种一切相清净。十力四无所畏。三念住三不护。大悲无忘失法。拔除习气一切相妙智等。如是诸句。略唯二句。谓声闻乘中所说句。及大乘中所说句

云何迷惑。谓四颠倒。一于无常计常颠倒。二于苦计乐颠倒。三于不净计净颠倒。四于无我计我颠倒

云何戏论。谓一切烦恼及杂烦恼诸蕴。云何住。谓四识住或七识住

云何真实。谓真如及四圣谛

云何净。谓三清净性。一自体清净性。二境界清净性。三分位清净性

云何妙。谓佛法僧宝名最微妙。堕最第一施设中故

云何寂静。谓从善法欲。乃至。一切菩提分法。及所得果。皆名寂静

云何性。谓诸法体相。若自相。若共相。若假立相。若因相。若果相等

云何道理。谓诸缘起及四道理

云何假施设。谓于唯法。假立补特伽罗。及于唯相。假立诸法

云何现观。谓六现观。如有寻有伺地已说。复次嗢拖南曰

  方所位分别　　作执持增减
  冥言所觉上　　远离转藏护

云何方所。谓色蕴

云何位。谓受蕴

云何分别。谓想蕴

云何作。谓行蕴

云何执持。谓识蕴

云何增。谓有二种。一烦恼增。二业增。如增

有二种。当知减亦尔

云何冥。谓无明及疑

云何言。谓诸如来十二分教。说名为言。云何

所觉。谓彼彼言音所说之义。名为所觉云何上。谓四沙门果

云何远离。谓五种远离。一恶行远离。二欲远离。三资具远离。四愦闹远离。五烦恼远离云何转谓三界五趣云何藏护。谓追恋过去。希慕未来。耽着现在。复次嗢拖南曰

  思择与现行　　睡眠及相属
  诸相摄相应　　说任持次第

云何思择。谓一行。顺前句。顺后句。四句。无事句。复有有色法无色法。有见法无见法。有对法无对法。有漏法无漏法。有为法无为法。有诤法无诤法。有味着法无味着法。依耽嗜法依出离法。世间法出世间法。有系属法无系属法。内法外法。粗法细法。劣法胜法。远法近法。有所缘法无所缘法。相应法不相应法。有行法无行法。有依法无依法。因法非因法。果法非果法。异熟法非异熟法。有因法非有因法。有果法非有果法。有异熟法非有异熟法。有执受法无执受法。大种造法非大种造法。同分法彼同分法。有上法无上法。又有过去法未来法现在法。善法不善法无记法。欲系法色系法无色系法。学法无学法非学非无学法。见所断法修所断法无断法。又有四缘。谓因缘。等无间缘。所缘缘。增上缘。又有四依。一法是依。非补特伽罗。二义是依。非文。三了义经是依。非不了义。四智是依。非识。又有四无量法。四念住法。四正断法。四神足法。五根法。五力法。七觉支法。八支圣道法。四行迹法。四法迹法。奢摩他法。毗钵舍那法。增上戒法。增上心法。增上慧法。解脱法。胜处法。遍处法。如是等法。无量无边。应当思择

云何现行。谓诸烦恼缠

云何睡眠。谓诸烦恼随眠

云何相属。谓内六处。于一身中。当知展转互相系属。又若此法能引彼法。当知此彼互相系属。又诸根境。当知能取所取互相系属

云何摄。谓十六种摄。一界摄。二相摄。三种类摄。四分位摄。五不相离摄。六时摄。七方摄。八一分摄。九具分摄。十胜义摄。十一蕴摄。十二界摄。十三处摄。十四缘起摄。十五处非处摄。十六根摄

云何相应。当知此相略有五种。一与他性相应非自性。二于他性中。与不相违相应非相违。三于不相违中软中上品与软中上品自相应非余品。四于软中上品中。同时相应非异时。五于同时中。同地相应非异地

云何说。谓四种言说。一见言说。二闻言说。三觉言说。四知言说

云何任持。谓四食。一段食。二触食。三意思食。四识食

云何次第。谓六种次第。一流转次第。二成所作次第。三宣说次第。四生起次第。五现观次第。六等至次第

复次嗢拖南曰

  所作及所缘　　亦瑜伽止观
  作意与教授　　德菩提圣教

云何所作。谓八种所作。一灭依止。二转依止。三遍知所缘。四喜乐所缘。五得果。六离欲。七转根。八引发神通

云何所缘。谓四种所缘。一遍满所缘。二净行所缘。三善巧所缘。四净烦恼所缘

云何瑜伽。谓或四种。或九种。四种瑜伽者。一信二欲三精进四方便。九种瑜伽者。一世间道。二出世道。三方便道。四无间道。五解脱道。六胜进道。七软品道。八中品道。九上品道

云何止。谓九种住心

云何观。谓或三事观。或四行观。或六事差别所缘观。三事观者。一有相观。二寻求观。三伺察观。四行观者。谓于诸法中。简择行观。极简择行观。遍寻思行观。遍伺察行观。六事差别所缘观者。一义所缘观。二事所缘观。三相所缘观。四品所缘观。五时所缘观。六道理所缘观

云何作意。谓七种作意。了相等如前说。云何教授。谓五种教授。一教教授。二证教授。三次第教授。四无倒教授。五神变教授

云何德。谓无量解脱等。如句中已说。云何菩提。谓三种菩提。一声闻菩提。二独觉菩提。三阿耨多罗三藐三菩提

云何圣教。谓授以归依。制立学处。施设说听。建立师徒。施论戒论。生天之论。诃欲爱味。示欲过失。显说杂染及清净法。教导出离及与远离。称赞功德。乃至广说。无量无边清净品法

云何摄圣教义相。此中有能修习法。谓于诸善法专志所作相续。所作方便勤修。有所修习法。谓所有诸善法。有有过患法。谓应遍知法。有有染污法。谓应不着制伏初应断法。有障碍法。谓违逆现观究竟法。有随顺法。谓随顺现观究竟法。有真如所摄法。谓应觉悟法。有胜德所摄法。谓所应引发法。有随顺世间法。谓应习应断及断已现行法。有得究竟法。谓究竟自义所应证法

云何佛教所应知处相。当知此中一切有情住有三种。谓日别住。尽寿住。善法可爱生展转住。初由食增上力。第二由命行增上力。第三由于诸善法不放逸增上力。于诸不善无记法中。亦有相似不放逸法。如于杀生等事及威仪工巧等中审谛而作。然于善法不放逸者。于现法中。乃至。能得般涅槃故。于后法中往善趣故。多有所作

复次依有情世间及器世间。有二种法。能摄一切诸戏论事。谓能取法。及彼所依所取之法

又诸世间。略有二种杂染根本能引无义无利杂染。谓于真实无正解行。及彼为先悕求无义

又正法外。若诸沙门若婆罗门。略有二种杂染根本。谓萨迦耶见增上力故。杂求我常。推求我断

又诸有情。略有二种众苦根本。谓于有漏法喜爱俱行所有期愿。及非理所引厌离俱行所有期愿

又有二种师及弟子。教授教诫相违之法。谓诸弟子。不能堪忍教诲语言。及师倒见习行邪行。与此相违。当知即是白品二法又有二法。甚能违越世出世间正行境界。谓于自非法增上所生不可爱果。无有顾虑。于所作罪。无有羞耻。及于现法他所杀缚衰退等事。无有顾虑。于所作罪。无有羞耻。与此相违。当知即是白品二法

又有二种无倒建立。能令行者少用功力住于梵行终不唐捐。一正立学处。若有违越。便获大罪。若不违越。便生大福。二正立出离。令违越者速复出离

又有二法。能令作者得自他利。一居远离者。心常安定。现法乐住。二居愦闹者。有来求法。时时为说能令正法相续久住

又有二法。能令有情内正作意。外闻他音。二因缘故。于现法中。入谛现观。或令当来诸根成熟。一于因所生法。正通达因。二于如来所说所有甚深。相似甚深空相应经。一切缘性。及诸缘起。随顺作意。数数思惟

又有二法。能令根熟补特伽罗速证通慧。一于教授教诫。远离谄诳。二厌离为先。身语意行。离诸调戏

又有二法。令居一处。同梵行者。展转皆得安乐而住。一者堪忍他所逼恼。二者自不逼恼于他

又有二法。令居一处同梵行者。未生违诤。遮令不生其已生者。速令止息。无斗无讼。无诤无竞。一者展转互起慈心。二者平等受用财法

又有二法。速令心住得三摩地清净梵行。一者忆持久远所作所说增上力故。若有所犯如法悔除。若无所犯便生欢喜。昼夜随学尝无懈废。二者于身语意一切事业。能正了知增上力故。于诸过失终无违犯。由此因缘。亦无忧悔。随生欢喜。广说乃至。解脱智见。又有二法能越众苦谓能超越诸恶趣苦。及能超越生死大苦。一者深见现法当来诸过患故。远离恶行。二者心常安定。精勤修习菩提分法。又有二法。能令修断居远离者得安乐住。一者于诸境界。不生杂染。无恶寻伺扰乱其心。二者凡所啖食。要为利益。称量消化。能随顺断令身调适。又有二法。令修善品诸苾刍等时无虚度。一者于诸根境。正勤方便。研究法相。二者知时知量。少习睡眠

又有二法。能坏增上心学慧学。一者建立邪学。违越正学。及怀犹豫。二者增益损减邪见决定。与此相违。当知即是白品二法又有二法。能令已集菩提资粮。未入现观补特伽罗速入现观。一者思惟现在过去自他衰盛。二者勤修谛行所摄。无倒作意

又有二法。令观行者。最极究竟离垢梵行速得圆满。一者修谛现观。二者于后离欲。方便勤修。于诸等至。无有爱味。离诸障难

又有二法。令观行者速能引发世出世间一切胜德。一者九相住心。二者由六种事。以正定心思择诸法。如声闻地当广分别

又观行者。有二种净。谓作意净。及所依净。于三世中。远离愚痴。智清净故。名作意净。远离三界诸烦恼品粗重法。故名所依净

又有二法。心善解脱诸阿罗汉。内自所证。一者于现法中。苦因永尽。二者由此为先。

当来世苦毕竟不生

瑜伽师地论卷第十三瑜伽师地论卷第十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中闻所成地第十之二

已说二种佛教所应知处。次说三种。谓依十相三门三种及与三根。于诸有情发起邪行。能令有情堕诸恶趣。言十相者。谓坏生命。财物。妻妾。若坏实义。善友。赞美。所为事业。若意三浊。谓执受他财欲为己有。欲令他遭所不爱事。诽谤真实。所有恶见。言三门者。一作业毁坏门。二意乐毁坏门。三方便毁坏门。于十相中。前之七种。作业毁坏。其次二种。意乐毁坏。最后一种。方便毁坏。所谓恶见。由恶见故。羞耻慈悲离诸恶行。悉皆毁坏。无有羞耻。无有慈悲。广造众恶。言三种者。一身所作。二语所作。三意所作。言三根者。一为自饶益相。二为损害他相。三于他颠倒相。谓于非法而作法想。于不应作作应作想。坚执现行

复有三法。能令有情不护诸根。一于依止中邪法种子。二于诸境界取不正相。三于私隐处不正思惟。如是三种。当知即是欲贪嗔恚。及与害品。依四处所。发生三种不正寻思。谓于自己利等四种白品法处。为欲获得。或为不失。生欲寻思。于能障彼怨中二品有情处所。生恚寻思。于亲友品有情处所。生害寻思。所以者何。若亲友品。或时违犯于彼不生全断灭欲。唯有轻微苦楚方便训罚之欲。与此相违。所有白品。如应当知。略有四种内法种子。遍摄一切诸法种子。一世间种子。二出世种子。三不清净种子。四清净种子。世间种子者。谓欲色无色界系诸行种子。出世种子者。谓能证三乘及三乘果。八圣道等清净种子。不清净种子者。谓欲界系诸行种子。清净种子复有二种。一世间净。二出世间净。色无色系诸行种子名世间净。能证三乘及三乘果。八圣道等所有种子名出世净

复有三种从因所生有漏法因。若于此中。不如正理修方便者。能生诸苦。若能如理修方便者。于苦于因。能知能断。谓于欲界系法。染污希求。于色无色界系法亦尔。又有三种诸烦恼趣。令诸有情流转生死。谓于胜欲。发意悕求。名初烦恼趣。于色无色界胜自体中。发意悕求。名第二烦恼趣。于邪解脱。发意悕求。名第三烦恼趣。又有三种诸有情类。欲为根本作业方便。一为得胜欲。二为得胜自体。三为证胜解脱道。又有三种诸有情类。于三界中。摄受自体诸行威势。一牵引威势。二能得威势。三成满威势。牵引威势者。谓能引之业。能得威势者。谓健达缚正现在前。成满威势者。谓住于此受净不净诸业异熟。又有三种无明蕴。诸有情类住无明者。由此因缘。能生三世自体差别。谓于过去世前际等无知。能生现在自体。于现在世前际等无知。能生未来自体。于未来世前际等无知。即于未来能生后后当来自体。又有三种未究竟圣。共诸异生生死灾患。若有于彼深厌怖者。当速断除三种憍逸。修习现法涅槃方便。一无病衰退。二少年衰退。三寿命衰退。其有智者。应观未来如是三事定当随逐。又有三种有情之类。贪嗔痴缚所依处所身分差别。能急系缚诸有情类。闭在大苦生死牢狱。一能饶益。二能损害。三者平等。二种俱离。又有三处所生诸苦。遍摄有情所有众苦。一合会所生苦。二乖离所生苦。三平等相续苦。初由损害位和合故。第二由饶益位变坏故。第三于一切位相续而转。粗重所摄诸行所生。唯众贤圣觉之为苦。非诸异生。又有三种心高举法。违害欲求沙门果证修方便者预流果支。能障沙门令不得证。一者以己校量于他。谓我为胜心生高举。二者以己校量于他。谓我相似心生高举。三者以己挍量于他。谓我为劣心生高举

复有三种种子。当知能生一切诸行。一已与果。二未与果。三果正现前。又有三种诸行言说所依处所。谓去来今。又有三相。能摄一切色法自相。谓显形作用。安立眼识所取之色。于自处所障碍余色。行住安立根色。若一切境界色。当知一切总有十色及定地色。若得净定为引变化修方便者所有诸色。当知是内化心境界。亦是未满变化心果。又有三种为诸烦恼所随逐心。一诸异生心。二未满学心。三已满学心。又有三种听闻法者。一于法于义不能受持。二唯能领受不能任持。三能受能持。又有三法是修行者观身语意无常性观趣入上首。一者入出息。二者寻伺。三者想思。又有三种尊胜应受敬养。一年齿增上。二族姓增上。三功德增上。又有三种住定不定因。二是定因。一不定因。一恶趣定因。谓无间业。二善趣涅槃定因。谓无漏有为法。三不定因。谓所余法。又有三法。为令圣教得久住故。展转举罪。一者现见身语现行违犯学处。二从他闻。三以余相比度了知。又诸如来自说具足三不护德。为显外道诸师内怀众恶自称一切智者实非一切智者。又欲令彼于如来所发起真实一切智信

复有三种邪执所生大火所起有情烧恼。一贪爱烧恼。二愁忧烧恼。三颠倒烧恼。又有三火。为化乐福邪事外火。胜解有情示无虚诳所应事火。虽实非火假立火名。一者父母。二者妻子。三者真实应供福田。又有三种为诸乐欲增上生者所说真实增上生道。一者布施。得大财富。二者持戒。得住善趣。三者修定。远离苦受。得生一向无有恼害乐世界中。又有三种。诸受欲者。劣中胜欲。观待诸欲所生乐故。一多用功力依缘诸欲。谓现前住所有诸欲。二少用功力依心诸欲。谓乐化天所有诸欲。三极少功力依心诸欲。谓他化天所有诸欲。又有三种。超过诸欲劣中胜乐。一有寻伺喜。二无寻伺喜。三离喜之乐。又有三种。觉悟所知。能令三乘出离众苦。一从他闻音种类。二内正思惟种类。三长时修习止观种类。又有三种。觉悟所知。一者具缚。二不具缚。三全无缚。又有三种所应作事。修观行者。由此三事增上力故。修习信等一切善法。一者永断见道所断诸烦恼已。证预流果。二者永断修道所断诸烦恼已。渐次证得一来不还阿罗汉果。三者证得阿罗汉已。现法乐住。又由三分照了一切所知境界。增上力故。建立三眼。一者肉眼。能照显露无有障碍有见诸色。二者天眼。能照显露不显露。有障无障有见诸色。三者慧眼。照一切种若色非色所有诸法。又有三法。能害现行烦恼怨敌。一者信顺善友。二者不与在家出家诸众杂住。三者内正作意觉悟所知真实道理

复有三种正教诫方便。能展转证后后所证。及得涅槃。一于尸罗正教诫方便。二于心住正教诫方便。三于觉悟所知真实道理正教诫方便。如正教诫方便有三种。当知数习正教诫方便亦尔。又于正教诫方便。现修习时。由三种法得安隐住。一者空无愿无相灭尽等至。二者四静虑。三者四无量。又略有三种心一境性。能令证得如实智见。一于意言中种种差别所缘行相。二意言无间种种差别所缘行相。三超度意言专注一境无种种无差别所缘行相。又有三处。能善摄受于恶邪处妄计尊胜及处中庸所化有情。引入圣教。一现己所有最胜神通。二于他所有染净诸行。遮止开许。三宣说妙法正教正诫。又有三净。为欲断除乐净外道以外事水暂除外垢。自谓已得第一清净。所起邪慢故建立此三。第一义净不净处生超越因故。又有三种牟尼。为欲断除持牟尼戒诸外道等。暂息语言。自谓已得真实寂静所起邪执故。又为显说无倒牟尼故。建立三种真实牟尼。即是圣所爱戒所摄身语二业。及无漏心。又有三法。能令处远离者断除现行不正寻思。谓由他所诽毁自所诽毁。退失大利增上力故。所起愧惭。及与爱敬。又依道及道果。当知有三种最胜无上。谓无常智。苦智。无我智。乐速通等四种行迹。一切世间出世间。有学无学。时解脱不动心解脱。最胜无上。修观行者。先得其智。由此智故。为断烦恼。次修行迹。修行迹已。心得解脱。又有三明。当知为显于前后中际。断常二边邪执。现法涅槃愚痴。沙门婆罗门无明性故。建立三明。已说三种佛教所应知处。

次说四种。谓有四法。能摄一切所知及智。谓身及闻思修增上念住。以为依止。缘身境慧。如身及缘身境慧。当知受心法。及缘受心法境慧亦尔。复有差别。谓四种缚。一执取缚。二领受缚。三了别缚。四执着缚。当知心于身。由执取缚所缚。于受。由内领受缚所缚。于色等境界相。由了别缚所缚。即于所说身等。由贪嗔等大小烦恼执着缚所缚。对治如是四种缚故。立四念住。又有四种。欲勤为先。观察过患及与对治。以为依止。能断现行诸不善法。及断彼系。能得善法。及能增长。又有四种为欲住心。为得胜定。修方便者。心住如意。能生长门。一乐出离欲。二受持读诵。悔过精进。三能取贤善定相之心。四住空闲处。观察诸法。又有四种心定心住。一有寻有伺有喜心住。二无寻无伺有喜心住。三无寻无伺离喜心住。四舍念清净超度一切苦乐心住。又有四种所知真实。染污清净二品别故。建立四种。若能了知。善了知者。能断见修所断一切烦恼。一染污品果真实。二彼品因真实。三清净品果真实。四彼品因真实。又有四种想为先戏论缚。一于小欲中想为先戏论缚。二于大色中想为先戏论缚。三于无量空识无边处想为先戏论缚。四于无所有处想为先戏论缚。又有四法。于诸有情对治恚害。不乐欲贪。善修习时。能生大福。能趣离欲。一慈。二悲。三喜。四舍。又有四法。超过色界。令成远分。谓空处。识处。无所有处。非想非非想处。又有四种。为令解脱速得圆满。勤修行者圣解脱欲胜任持法。为断四爱。增上力故。谓为衣服饮食卧具少有所求。无作无乱。时无虚度。勤修方便。心离散乱。乐断烦恼。乐修正道。又有四种修习道果诸烦恼断。一见所断烦恼断。二修所断下分结上中品断。三即此无余断。四上分结无余断

复有四种。证预流支。能令行者于佛圣教及善趣中毕竟不动。谓于大师所。真觉所生无动心净。如于大师所。当知于所证法及为证法修证行者所亦尔。如是三种。名心清净。第四一种。名色清净。圣所爱戒所摄故。前之三种令于圣教无有动摇。最后一种。令于善趣无有动摇。又有四种证预流支。一于说法师及教授者。能善承事无所违犯。二无倒听闻师所说法及教授法。三于所闻法。能正思惟。及善通达。四成办所修。又有四智。摄一切智。一唯无漏。于诸法中能现见智。二一向无漏。于诸法中非现见智。三一向有漏。或如理所引。或不如理所引。或非如理非不如理所引世间智。四通有漏无漏。他心差别智。又有四种。于转还品真实能取智。能尽诸漏。一转品果真实智。二转品因真实智。三还品果真实智。四还品因真实智。又有四法。能令信者为断烦恼修正方便。一相续殷重作用精进。二正知行念。三奢摩他。四毗钵舍那又有四种。能通达法。能尽上漏所依足迹。谓为得圣道。修有漏慧。既得道已。缺诸烦恼。及缺诸事无余。永断诸烦恼事。如所得道。转更修习。又有四法。展转相应。有行有缘和合而转。同一缘转。谓受想行识。又有四护。能令已入佛圣教者爱乐圣教。一者命护。二者力护。三者心烦恼护。四者正方便护。又有四种。能得正见无倒义行所依处所。由前三种。行时清净。由后一种。住时清净。谓守根门者。于诸境界。不顺不违。为守根门。念增上力。正智而行。住远离者。心无染污。专注一缘。又由四行。当知能证明及解脱。由念眼慧。能证于明。又由身故。能证不动及时解脱

复有四法。能为广大种种差别诸所造色生起依止。一者坚性二者湿性。三者暖性。四者轻等动性。又有四法。能持已生诸有情类。令得久住及能摄益。寻求有者。摄事分中。当广分别。又有四种。于生死中。诸识流转所依足迹。谓于诸色见已趣向。由贪爱故。取为所缘。所依境界。俱有建立。如于诸色。于受想行。当知亦尔。又诸苾刍。顾恋现法身命。为依止故。而于衣服饮食卧具。生希求爱。顾恋后法身命。为依止故。而于后有。生悕求爱。愚于涅槃。为依止故。而于无有。生悕求爱。如是略有四种悕求之爱。谓依服爱。饮食爱。卧具爱。有无有爱。又有四法。能令有情现行造作所不应作。谓随顺可爱事。违逆不可爱事。怖畏强敌。其心颠倒。愚于现法及后法果。又有四种请问记论。能断所疑。能悟未悟。又能任持胜决择力。谓于法实相。应一向记。于诸有情业果异熟。应分别记。于隐密说。非一向问应诘问记。于不如理应当置记。于此问中。云何名记。谓记彼问言。佛世尊于斯不记。又有四种惠舍。或清净或不清净。三种清净。谓唯自身戒见具足。或复唯他戒见具足。或自及他戒见具足。一不清净。谓自及他戒见二种俱不具足。其清净者。当生善趣资产丰饶。不清净者。当生恶趣资产无匮。又有四种摄众方便。能正摄化一切大众。一饶益方便二摄受方便。三引导方便。四修治方便。又有四种。从业所生诸有情类。于彼彼趣生依止门。一由业及卵[穀-禾+卵]。二由业及胎膜。三由业及润污。四唯由业。又彼彼处受生有情有四种死。一者由自故死。谓於戏忘意忿天中而受生者。二由他故死。谓于羯罗蓝。頞部昙。闭尸。键南。母腹中者。三俱由故死。谓在欲界所余有情。四俱不由故死。谓色无色界有顶为后所有有情。复有四清净道。一非功用根圆满。亦非喜乐圆满。二功用根圆满。非喜乐圆满。三喜乐圆满。非功用根圆满。四喜乐圆满。亦功用根圆满。又有四清净道。一背恶说法及毗奈耶。二向善说法及毗奈耶。三资粮道。四清净道。此中最初。谓如有一于外道见及引无义苦切行中。心不爱乐。亦不忍可。第二。谓如有一于蕴界处缘起处非处等诸善巧中。爱乐忍可。又能堪忍寒热等苦。第三。谓净尸罗守根门等。诸善资粮所摄正法。第四。谓奢摩他毗钵舍那断诸烦恼。现法乐住。又有四种学增上心方便。谓未离欲者。为得不还果。或不还果依未至定求现法乐住。又为令他断诸恶法及往善趣。又为自己断诸烦恼得胜决择。又有二业四相差别。谓转所摄业差别有三。还所摄业。总立一种。当知初业一向能感不可爱果恶趣异熟。第二业一向能感可爱乐果色无色界异熟。第三业能感爱非爱果欲界天人异熟。第四业能断前三业。又有四种诸有情类增上勤务。一乐而非利益。二利益而非乐。三亦乐亦利益。四非乐非利益。又有四门。起诸烦恼。能令有情与生等苦和合不离。一染着诸欲门。二染着色无色等至门。三外道诸见门。四住此法中未得眼者无智门。又修圣道令此四门所生众苦速得离系。如能令有情与苦和合。能令顺流取后有业。难可解说。当知亦尔。复有四种补特伽罗。当知遍摄一切补特伽罗。一者异生。二者未离欲有学。三者已离欲有学。四者超萨迦耶见一切无学。又有四种补特伽罗。一自住律仪。不能为他宣说正法。二自不住律仪。而能为他宣说正法。三俱能作。四俱不能作。又有四种补特伽罗。一族姓卑下。现行白法。二族姓尊高。现行恶法。三族姓卑下。现行恶法。四族姓尊高。现行白法。此中最初现法有苦非于后法。第二后法有苦非于现法。第三二世俱苦。第四二世俱乐。又有四种补特伽罗。一以苦自任。不任于他而生非福。谓受外道自苦戒者。二以苦任他不任于自而生非福。谓随有一不律仪者。三以苦俱任。而生非福。谓诸国王及祠祀主马祠祀等。四不以苦任。于自他而生大福。谓住静虑者。及离诸恶补特伽罗。又略有四种语失。一不实。二乖离三毁德。四无义。兴此相违。当知即是四种语德。又略有四种非圣妄语。谓于见不见颠倒而说。于闻不闻。于觉不觉。于知不知。当知亦尔。与此相违。当知即是贤圣谛语

已说四种佛教所应知处。次说五种。谓有五种诸欲贪品粗重。随逐流转杂染所摄行聚。一所依所缘自性行聚。二能领纳自性行聚。三能分别言说分位。取诸法相自性行聚。四能作用自性行聚。五能了别自性行聚。此五相违。当知即是离欲贪品粗重还灭清净所摄自性行聚。又有五种受用欲者所爱境界。诸乐欲者常所追求。常所受用。诸背欲者恒正观察。谓色声香味触。当知此中依所追求所寻思所染着事。有四种爱乐。谓未来所爱乐事。即所追求。过去所爱乐事。即所寻思。现在所爱乐事。即所染着。此复二种。一所爱乐事。二从彼所生所爱乐受。又有五种有情所得受爱非爱业果异熟自体。谓天人那落迦傍生鬼趣。又有五种失利养因行。亦是背涅槃因行。谓若于是处受用利养。若从彼得。若所得物。若所为得。若如是得。于此诸处。心生吝惜。又有五法。令修行者先毁净戒多闻。后亏止观善轭。谓于诸欲中。心生爱染。于能觉发忆念教授教诫者所。心生嗔恚。未受尸罗。令其不受。虽先受得。后令弃舍。或使穿穴。耽着惛睡。恒不寂静。染污追悔。常怀疑惑。于所闻法。不能领受。虽初领受。寻即忘失。虽不忘失。不证决定。又有二种下分。谓见道是修道下分。欲界是色无色界下分。约此二种下分。说五下分结。依初下分。说萨迦耶见戒禁取疑。依第二下分。说贪欲嗔恚。又有二种上分。谓色界及无色界。依此二种上分。说五上分结。或有无差别结。谓色贪无色贪。或有有差别结。谓爱上静虑者掉。慢上静虑者慢。无明上静虑者无明。又为五种不信敬所执持者。心不调柔。不能生长诸善根本。谓于大师所说正法增上戒学。增上心学。增上慧学。正觉发者。正教授者。正教诫者。同梵行所。无有信敬。又有五种为断烦恼正精进障。一者耽着等至及生。二者耽着利养恭敬。三者放逸。四者恶慧。五者其心下劣。或增上慢

复有不能堪忍补特伽罗。于他怨敌所。起五种邪行。谓不堪忍者。于他怨敌。先起嗔心怨嫌意乐。于彼亲友。乐欲破坏。常欲令彼发生忧苦广作一切不饶益事。坏自所受清净尸罗。由身语意多行恶行。由此五种恶邪行故。能感后世还来此中三种等流过患。一种现法等流过患。一种后法异熟过患。谓此生中多诸怨敌。亲友乖离。由他发起种种忧苦。不可爱事。恒现在前。临命终时。多生忧悔。命终已后。颠坠恶趣。与此相违。能堪忍者。于他怨敌。发起五种正行。由此所感胜利差别。如应当知。又有五法。能生现法后法一切忧苦。一亲属灭亡。二所有财宝非理丧失。三疾病缘身。此三能生现法忧苦。四毁犯尸罗。五毁谤一切。诸恶邪见。此二能生后法忧苦。与此相违五法。当知能生现法后法所有喜乐。又阿罗汉。虽现追求供身财物亦常受用。而能超度三邪追求二邪受用。谓能超过杀生偷盗妄语所引三邪追求。亦能超过妻妾畜积二邪受用。又修断者。成就五法。随其所欲。于诸善品。方便修行。亦能速证究竟通慧。一者于所修断。猛利乐欲。如教奉行。二者于自所有如实发露。三者身力康强。四者相续无间修方便中其心勇锐。五者成就通达止举舍相时分智慧。又有五种。能圆满解脱。厌离所对治法。谓于诸法中。有三种愚。以为依止。起三颠倒。三种愚者。一时节愚。二分位愚。三自性愚。三颠倒者。一于无常计常颠倒。二者于苦计乐颠倒。三于无我计我颠倒。及规求利养。希望寿命。为治如是五所治法。起五取相。谓于诸行。取无常相。亦取苦相。于诸法中。取无我相。于饮食中。取恶逆相。于其命根。取中夭相。又有五种修定修智二胜行者。正心解脱生长之门。定胜行者。因闻依谛圣言论故。正解法义。如因听闻因广大音。读诵经典。因为他人。开阐妙义。在空闲处。审谛思惟。正解法义。当知亦尔。智胜行者。于上品乱贪欲。对治无倒思惟。又有五种修观行者意乐方便悉皆具足。谓于涅槃菩提。起猛利信解。名意乐具足。无间殷重。修习正智。而行奢摩他毗钵舍那。名方便具足。又有五法。令诸有情受爱非爱业果异熟。烦恼身心。具摄众苦。谓苦乐忧喜舍。又由成就如前所说意乐方便。悉皆具足不退转故。令观行者。堪能速证圣谛现观。亦善安住诸胜善品。又有五种离欲界欲。未尽余结学生差别。一住中有。便能究竟得般涅槃。二于初静虑。初受生已。得般涅槃。三受生已后。少用功力。圣道现前。得般涅槃。四多用功力。圣道现前。得般涅槃。五或色界边际。乃至。色究竟得般涅槃。或无色界边际。乃至。有顶方能究竟得般涅槃。又有五种杂修第四静虑果得不还者生地差别。一下品静虑果生地。二中品静虑果生地。三上品静虑果生地。四上胜品静虑果生地。五上极品静虑果生地。又有五种修观行者观察作意。能令三界烦恼永断究竟决定。谓虽深厚忆念分别思惟欲相。于诸欲中。仍不趣入。任运舍心。于离欲相。率尔思惟。便能任运其心趣入。如于欲离欲相如是。于恚无恚相。害无害相。色等至生相。无色等至生相。及涅槃相。当知亦尔。已说五种佛教所应知处。

次说六种。谓依六相。宣说八种有情事差别。为令堕在我及有情命者见等众生趣入无我故。谓我所依事差别。境界事差别。自性事差别。受用因事差别。受用事差别。随说事差别。作用事差别。希望事差别。于如是等事差别中。未善纯熟修观行者。便谓有我。依眼等根。于色等境。由触及受。种种受用。有如是名。如是种。如是姓。如是食等。于自于他。随起言说。造作一切法非法行。于可爱事。希望和合。久住增益。于非爱事。悕望不合。不住捐减。若于如是事差别中。已善纯熟修观行者。尔时妄计皆不得生。又于宝学有六轻懱能令善法或未得退。或已得退。舍佛圣教。乃至微信。亦皆退失。谓于佛法僧宝。增上戒学。增上心学。增上慧学。由恶友故。于增上心慧。令得邪僻教诫教授。由恶语故。全无所得。彼由邪僻及无所得故。退失一切所有善法。与此相违。当知即是白品六法。又有情心。与不如理作意俱行。于色等境。有六种贪所依处平等分位。如贪所依处平等分位。如是嗔所依处不平等分位。痴所依处非平等。非不平等分位。当知亦尔。又有六种最极清净。转自所依。第一究竟。无间无缺。无有染污。恒平等住。谓若行若住。于眼所识色乃至意所识法中。恒平等住。又有六法。是诸色根及所依处。随其所应之所依止。无有障碍。引导安养。于彼彼生自在而转。谓四大种。空界识界。如是识界。能于现在。积集任持福非福业。能引当来爱非爱果。亦能执持识所依止五种色根及所依处。令不烂坏。又由现法后后所生识自在力。令诸有情于善不善无记业中。差别而转

复有三处诸修行者难可超越。一者超越欲贪恚害不乐所摄下界。二者超越一切行相现行。三者超越有顶。超越此三难超越处。当知由六种无上对治。四无量是初对治。无相心三摩地是第二对治。我慢永尽是第三对治。永害如是所对治故。诸三摩地皆悉成满。善修对治故。害所对治。令彼决定不复现行。已断我慢者。终不为彼我。为究竟为不究竟。如是疑惑缠扰其心。当知有疑惑者。必不离我慢。若离我慢。必无疑惑。又有六种诤根本处。一展转相违。作不如意。二覆藏诸恶。三于等类中剩受利养。执为己有。四于衣服等。更相欺诳。五违越学处。六于法于义颠倒执着。又有六法。能断如是诤根本处。慈心所发身语意业。能断初二。同受利养。能断三四。同趣尸罗。能断第五。同趣正见。能断第六。又有六法。能摄一切诸修行者威德究竟。谓神境。天耳。宿住。他心。生死智通。能摄威德。漏尽智通。能摄究竟。又于圣谛未得现观补特伽罗。略有六种能障谛现观法。谓如前说。三种愚痴增上力故。起三颠倒。规求利养。悕望寿命。此中差别者。于顺恶见恶闻恶说恶分别处法中。喜乐恶见恶闻恶说恶分别事。如是喜乐。于未得圣谛现观异生心。最能漂动。极为障碍。非于圣者。是故说此在明分中。非在解脱成熟分中。对治如是能障碍法。当知即是六种正取相。谓如前说五种取相。及一切世间不可乐取相。又有二种具足随念六行差别。能令心没诸修行者。正策其心。令生欢喜。谓归依具足随念。有三种行。证具足随念。有三种行。于佛法僧随念之行。名归依随念。于趣涅槃行。趣资财行。趣生天行。随念之行。名证随念。又有六法。于善说法毗奈耶中。立为无上。不与一切诸外道共。谓见大师。闻正法。得净信。随学一切所有学处。于大师所。起随念行。谓佛世尊。是正等觉者。能说一切法。乃至广说。又于大师。以身语行。承事供养。又有六法。能令为尽贪爱修观行者。决定证知我于今者犹有贪爱。非无贪爱。谓于色境乃至法境。系摄其心。又六因缘故。应知诸业是实可依。非种家姓是实可依。谓下劣种性补特伽罗。亦生不善。往于恶趣。亦生善业。往于善趣。亦于现法能般涅槃。贵胜种姓三种亦尔。已说六种佛教所应知处。

次说七种。谓有七法。能于诸谛。如实觉了。圆满解脱。谓毗钵舍那品有三。一择法。二精进。三喜。奢摩他品亦有三。一安。二三摩地。三舍。念通二品。又由根故。果故。解脱故。建立七种补特伽罗。于向道中。依钝根利根故。建立随信随法行。于果道中。即此二种名信解脱见到。定障解脱。非烦恼障解脱故。建立身证。烦恼障解脱。非定障解脱故。建立慧解脱。定障烦恼障俱解脱故。建立俱分解脱。又三因缘七种行故。令修行者心得内定心正一缘。谓趣入。安住。摄受因缘。若世间正见。了知定有施与等行及此为依。了知居家迫迮。居家尘染等行。出离所引正思惟。名趣入因缘。既趣入已。受持正语正业正命。名安住因缘。于趣入因缘。安住因缘。及后方便作意随行中。所有正精进正念。名摄受因缘。又诸世间乐求财者。为得乐故。虽乐积集一切凡财。而未能得七种圣财所生之乐。谓与信俱行清净之乐。生于善趣所起之乐。顾自妙好不行诸恶。无有追悔所生之乐。顾他诽毁不行诸恶。无有追悔所生之乐。于法于义正解俱行所生之乐。后世资财无所匮乏所生之乐。于胜义谛如实觉悟所生之乐。诸如是等无量无边无罪之乐。乐求积集世间财者。皆所未得。惟得现法资财无匮所生有罪妄想之乐。又有七种魔惑品力。一憎嫉圣教。二现行能往恶趣恶行。三乐习不顾自妙好障法。四乐习不顾他诽毁障法。五于善不善。有罪无罪。若劣若胜。若黑若白。及广分别缘起法中。不能解了。六悭垢弊心。积集众具。七智慧陜劣。愚痴增广。若能降伏如是七种魔惑品力。当知即是圣法律中信等七力。又有七种第一义法涅槃所对治法。能令正法衰退隐没。如是七法三衰损摄。谓受用衰损。增上意乐衰损。方便衰损。于衣服等。乐求妙好。乐欲多求。及彼所起种种受用。名受用衰损。于道及道果涅槃。心不信解。名增上意乐衰损。懈怠。失念。心乱。恶慧。名方便衰损。受用衰损。是贪不善根品类。意乐方便衰损。是痴不善根品类。与此相违。当知即是白品七法。又有七种第一义法涅槃品法。能令正法无退久住。一闻所成慧。二思所成慧。三修所成慧。四不为恶缘侵损依止。五正求财法。六无增上慢。七于可供养不可供养补特伽罗。能善简择此可供养此不可供养。此中由闻慧故。于未了义能正解了。由思慧故。于未善决定义能善思惟。由修慧故。断诸烦恼。由无恶缘侵损依止故。堪能修断正求财法故。速证通慧。无增上慢故。于下品所证。不生喜足。能善拣择补特伽罗故。于诸世智大福者等。不乐亲近。亦不供养。唯乐亲近供养少欲者等。又有七种诸有情类受生处所。于彼处所受生有情。诸识现前相续而住。于三界中唯除恶趣。无想有情。及非想非非想处。由恶趣中极可厌故。不立识住。无想有情。一向转识不现行故。不立识住。非想非非想处。行与不行不决定故。不立识住。身异类故。名种种身。想异类故。名种种想。当知与此相违。名一种身一种想。梵世已下。身形异类。所生身形种种色相有差别故。于梵世中。初受生时。彼诸梵众。咸作是念。我等皆是大梵所生。尔时梵王亦作是念。是诸梵众皆吾所生。如是彼想非有异类。第二静虑已上一切诸天。身光等照故。名一种身。光音天众先后生者。由睹梵世猛焰烧然。尔时便有怖不怖想。是故于彼有异类想。又诸有情有七种粗重。遍摄一切烦恼品粗重。谓劣界贪嗔品粗重。中界妙界贪品粗重。劣中妙界慢无明见疑品粗重。又于外道恶说法律中。当知有七种过失。谓解过失。行过失。依止过失。思惟过失。功用过失。增上心过失。增上慧过失。彼诸外道虽少于法听闻受持。而常随顺四颠倒故。凡兴言论。专为毁他免脱征难。为胜利故。其所生解。皆有过失。所受禁戒。邪范邪命所摄受故。不能令自得出离故。亦有过失。所事师友。唯能宣说颠倒道故。亦有过失。所有思惟。邪求出离损坏心故。亦有过失。所有功用。离方便故。亦有过失。彼增上心。忘念爱慢及与无明疑上静虑之所摄故。亦有过失。彼增上慧。六十二见所损坏故。亦有过失。与此相违。当知善说法律中。亦有七种无过失事。又有七法。令诸苾刍所起违犯诤事止息。余如摄事分中。当说当知。此中有七种违犯诤事。一开悟现前犯诤事。二开悟过去失念犯诤事。三开悟不自在犯诤事。四寻思犯诤事。五决择犯诤事。六自悔犯诤事。七忍愧建立二众展转举罪诤事

瑜伽师地论卷第十四瑜伽师地论卷第十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中闻所成地第十之三

已说七种佛教所应知处。次说八种。谓有八支圣道所摄。令诸苾刍究竟断结。三种修法。谓修戒修定修慧。正语正业正命。名为修戒。正念正定。名为修定。正见正思惟正精进。名为修慧。又由正方便及果增上力故。建立清净品八种补特伽罗。谓行四向住四果者。又有二种施八相差别。一有过失施。二无过失施。前七种施名有过失。最后一种名无过失。谓有布施。懈怠所损故有过失。或有布施。不随所欲故有过失。谓有染心者怖畏贫穷悕求富乐而行布施。或有布施。顾恋过去故有过失。或有布施。悕望未来故有过失。或有布施。有轻慢过故有过失。或有布施悕求富乐故有过失。或有布施求他知闻故有过失。无过失施者。谓回向涅槃故。为彼资粮故。无染污心为往善趣故。为得大财故。而行布施。又依四处于八时中。趣入懈怠。不发精进。当知如是补特伽罗。是懈怠类非精进类。谓依乞食处。依所作处。依游行处。依界不平等处。依此四处。八时差别多食精美身沉重时。少食粗恶身劣顿时。将欲所作护惜力时。已有所作身疲倦时。将欲游行护惜力时。已涉长涂身疲倦时。正为病苦所缠扰时。所病已愈恐更发时。此懈怠类补特伽罗。乃至。未遇懈怠所依。少似精进。若得遇已。速发懈怠。是故名为懈怠种类。与此相违亦依四处。于八时中。发勤精进。当知如是补特伽罗。能伏懈怠勤精进类。虽遇懈怠所依。亦能发勤精进。何况不遇。是故名为勤精进类。又有八种正愿所摄可爱生因。能令于诸欲中乐增上生。不求永离一切欲者。当生八种可爱生处。谓愿人中卑恶种类。修小施戒二福业事。如是愿乐人中尊贵种类。四大王天。三十三天。夜摩天。睹史多天。乐化天。他化自在天。修小施戒二福业事。又四因缘故。于人趣中。建立如来四众。三因缘故。于天趣中。建立四众。最增上故。世间共许为福田故。受用资财不由他故。弃舍一切世资财故。由此四缘。于人趣中。建立四众。依地边际故。欲界边际故。语行边际故。由此三缘。于天趣中建立四众。又于世间三处转时。恒常世间八法所触。谓乐欲处。功用处。众缘处。于乐欲处转时。或触于利或触非利。于功用处转时。或称他意或不称意。于背面位触于毁誉。于现前位触于称讥。于众缘处转时。或由先世。或由现法苦乐众缘。触于苦乐。又八胜解能引不还或阿罗汉诸圣神通及最胜住。谓未伏内色想。外无染污色胜解。是名第一。已伏内色想。是名第二。净不净非二。色第一舍胜解。是名第三。此三解脱。于一切色得自在故。便能引发诸圣神通。谓诸神通不与一切异生共有。空无边胜解。识无边胜解。无所有胜解。非想非非想胜解。微微任运心胜解。此五胜解。次第善修治故。能引想受灭等至最胜住。又若观诸色。若如所观于初三解脱中而修习者。谓三解脱方便道所摄三胜处也。此中观外诸色。若小若大。若好若恶。若劣若胜者。谓观非三摩地所行现所得色。由缘三摩地所行作意不种种现前故名为胜。于三摩地所行中。奢摩他行名知。毗钵舍那行名见。如于三摩地所行若知若见。如于彼色已寻思已了别。如是于外所想非三摩地所行中。观诸色亦尔

已说八种佛教所应知处。次说九种。谓有九结。如摄事分当广建立。又有九种生处。受生有情。于彼彼处同所居止。谓三界中。除诸恶趣可厌处故。如前已说

已说九种佛教所应知处。次说十种。谓十遍处。当知即诸解脱所作成就。余解脱。胜处。遍处。如摄事分。当广分别。又有十无学支。当知无学五蕴所摄。谓戒蕴。定蕴。慧蕴。解脱蕴。解脱知见蕴。如是已说十种佛教所应知处。及前所说佛教所应知处等。当知皆是内明处摄

云何医方明处。当知此明略有四种。谓于病相善巧。于病因善巧。于已生病断灭善巧。于已断病后更不生方便善巧。如是善巧广分别义。如经应知。已说医方明处。

云何因明处。谓于观察义中。诸所有事。此复云何。嗢拖南曰

  论体论处所　　论据论庄严
  论负论出离　　论多所作法

当知此中略有七种。一论体性。二论处所。三论所依。四论庄严。五论堕负。六论出离。七论多所作法

云何论体性。谓有六种。一言论。二尚论。三诤论。四毁谤论。五顺正论。六教导论

言论者。谓一切言说。言音。言词。是名言论。

尚论者。谓诸世间随所应闻。所有言论

诤论者。谓或依诸欲所起。若自所摄诸欲他所侵夺。若他所摄诸欲自行侵夺。若所爱有情所摄诸欲。更相侵夺。或欲侵夺。若无摄受诸欲。谓歌舞戏笑等所摄。若倡女仆从等所摄。或为观看。或为受用。于如是等诸欲事中。未离欲者。为欲界贪所染污者。因坚执故。因缚着故。因耽嗜故。因贪爱故。发愤乖违。喜斗诤者。兴种种论。兴怨害论。故名诤论。或依恶行所起。若自所作身语恶行。他所讥毁。若他所作身语恶行。自行讥毁。若所爱有情所作身语恶行。互相讥毁。于如是等行恶行中。愿作未作诸恶行者。未离欲界贪嗔痴者。重贪嗔痴所拘蔽者。因坚执故。因缚着故。因耽嗜故。因贪爱故。更相愤发。怀染污心。互相乖违。喜斗诤者。兴种种论。兴怨害论。故名诤论。或依诸见所起。谓萨迦耶见。断见。无因见。不平等因见。常见。两众见等。种种邪见。及余无量诸恶见类。于如是诸见中。或自所摄他所遮断。或他所摄自行遮断。或所爱有情所摄。他正遮断。或已遮断。或欲摄受所未摄受。由此因缘。未离欲者。如前广说。乃至兴种种论。兴怨害论。是名诤论。

毁谤论者。谓怀愤发者。以染污心。振发威势。更相摈毁。所有言论。谓粗恶所引。或不愻所引。或绮言所引。乃至恶说法律中。为诸有情。宣说彼法。研究决择。教授教诫。如是等论。名毁谤论。

顺正论者。谓于善说法律中。为诸有情宣说正法。研究决择。教授教诚。为断有情所疑惑故。为达甚深诸句义故。为令知见毕竟净故。随顺正行。随顺解脱。是故此论名顺正论。

教导论者。谓教修习增上心学。增上慧学。补特伽罗心未定者。令心得定。心已定者。令得解脱。所有言论。令彼觉悟真实智故。令彼开解真实智故。是故此论名教导论

问此六论中。几论真实。能引义利。所应修习。几不真实。能引无义。所应远离。答最后二论。是真是实。能引义利。所应修习。中间二论。不真不实。能引无义。所应远离。初二种论。应当分别。

云何论处所。当知亦有六种。一于王家。二于执理家。三于大众中。四于贤哲者前。五于善解法义沙门婆罗门前。六于乐法义者前

云何论所依。当知有十种。谓所成立义有二种。能成立法有八种

所成立义有二种者。一自性。二差别所成立。自性者。谓有立为有。无立为无所成立。差别者。谓有上立有上。无上立无上。常立为常。无常立无常。如是有色无色。有见无见。有对无对。有漏无漏。有为无为。如是等无量差别门。当知名所成立差别

能成立法有八种者。一立宗。二辩因。三引喻。四同类。五异类。六现量。七比量。八正教量

立宗者。谓依二种所成立义。各别摄受自品所许。或摄受论宗。若自辩才。若轻蔑他。若从他闻。若觉真实。或为成立自宗。或为破坏他宗。或为制伏于他。或为摧屈于地。或为悲愍于他。建立宗义

辩因者。谓为成就所立宗义。依所引喻。同类异类。现量比量。及与正教。建立顺益道理言论

引喻者。亦为成就所立宗义。引因所依。诸余世间串习共许易了之法比况言论

同类者。谓随所有法望所余法。其相展转少分相似。此复五种。一相状相似。二自体相似。三业用相似。四法门相似。五因果相似。相状相似者。谓于现在。或先所见相状。相属展转相似。自体相似者。谓彼展转其相相似。业用相似者。谓彼展转作用相似。法门相似者。谓彼展转法门相似。如无常与苦法。苦与无我法。无我与生法。生法与老法。老法与死法。如是有色无色。有见无见。有对无对。有漏无漏。有为无为。如是等类。无量法门展转相似。因果相似者。谓彼展转。若因若果。能成所成。展转相似。是名同类

异类者。谓所有法望所余法。其相展转。少不相似。此亦五种。与上相违。应知其相

现量者。谓有三种。一非不现见。二非已思应思。三非错乱境界

非不现见现量者。复有四种。谓诸根不坏。作意现前。相似生故。超越生故。无障碍故。非极远故。相似生者。谓欲界诸根。于欲界境。上地诸根。于上地境。已生已等生。若生若起。是名相似生。超越生者。谓上地诸根。于下地境。已生等如前说。是名超越生。无障碍者。复有四种。一非覆障所碍。二非隐障所碍。三非映障所碍。四非惑障所碍。覆障所碍者。谓黑闇。无明闇。不澄清色闇。所覆障。隐障所碍者。谓或药草力。或咒术力。或神通力之所隐障。映障所碍者。谓少小物。为广多物之所映夺故不可得。如饮食中药。或复毛端。如是等类。无量无边。且如小光大光所映故不可得。所谓日光映星月等。又如月光映夺众星。又如能治映夺所治令不可得。谓不净作意。映夺净相。无常苦无我作意。映夺常乐我相。无相作意。映夺一切众相。惑障所碍者。谓幻化所作。或色相殊胜。或复相似。或内所作。目眩惛梦。闷醉放逸。或复颠狂。如是等类。名为惑障。若不为此四障所碍。名无障碍。非极远者。谓非三种极远所远。一处极远。二时极远。三损减极远。如是一切。总名非不现见。非不现故。名为现量

非已思应思现量者。复有二种。一才取便成取所依境。二建立境界取所依境。才取便成取所依境者。谓若境能作才取便成取所依止。犹如良医授病者药。色香味触。皆悉圆满。有大势力。成熟威德。当知此药色香味触。才取便成取所依止。药之所有大势威德。病若未愈名为应思。其病若愈名为已思。如是等类。名才取便成取所依境。建立境界取所依境者。谓若境能为建立境界取所依止。如瑜伽师于地思惟水火风界。若住于地。思惟其水。即住地想。转作水想。若住于地。思惟火风。即住地想。转作火风想。此中地想。即是建立境界之取。地者即是建立境界取之所依。如住于地。住水火风。如其所应。当知亦尔。是名建立境界取所依境。此中建立境界取所依境。非已思惟。非应思惟。地等诸界。解若未成。名应思惟。解若成就。名已思惟。如是名为非已思应思现量。非错乱境界现量者。谓或五种或七种。五种者。谓非五种错乱境界。何等为五。一想错乱。二数错乱。三形错乱。四显错乱。五业错乱。七种者。谓非七种错乱境界。何等为七。谓即前五。及余二种遍行错乱。合为七种。何等为二。一心错乱。二见错乱。想错乱者。谓于非彼相。起彼相想。如于阳焰鹿渴相中起于水想。数错乱者。谓于少数起多数增上慢。如医眩者于一月处见多月像。形错乱者。谓于余形色。起余形色增上慢。如于旋火见彼轮形。显错乱者。谓于余显色。起余显色增上慢。如迦末罗病损坏眼根。于非黄色悉见黄相。业错乱者。谓于无业事。起有业增上慢。如结拳驰走见树奔流。心错乱者。谓即于五种所错乱义。心生喜乐。见错乱者。谓即于五种所错乱义。忍受显说生吉祥想。坚执不舍。若非如是错乱境界。名为现量

问如是现量谁所有耶。答略说四种所有。一色根现量。二意受现量。三世间现量。四清净现量。色根现量者。谓五色根所行境界。如先所说现量体相。意受现量者。谓诸意根所行境界。如先所说现量体相。世间现量者。谓即二种总说。为一世间现量。清净现量者。谓诸所有世间现量。亦得名为清净现量。或有清净现量。非世间现量。谓出世智于所行境。有知为有。无知为无。有上知有上。无上知无上。如是等类。名不共世间清净现量

比量者。谓与思择俱已思应思所有境思。此复五种。一相比量。二体比量。三业比量。四法比量。五因果比量

相比量者。谓随所有相状相属。或由现在。或先所见推度境界。如见幢故比知有车。由见烟故比知有火。如是以王比国。以夫比妻。以角犎等比知有牛。以肤细软发黑轻躁容色妍美。比知少年。以面皱发白等相。比知是老。以执持自相。比知道俗。以乐观圣者。乐闻正法。远离悭贪。比知正信。以善思所思。善说所说。善作所作。比知聪睿。以慈悲爱语。勇猛乐施。能善解释甚深义趣。比知菩萨。以掉动轻转。嬉戏歌笑等事。比未离欲。以诸威仪恒常寂静。比知离欲。以具如来微妙相好智慧寂静正行神通。比知如来应等正觉具一切智。以于老时见彼幼年所有相状。比知是彼。如是等类。名相比量

体比量者。谓现见彼自体性故。比类彼物不现见体。或现见彼一分自体。比类余分。如以现在比类过去。或以过去比类未来。或以现在近事比远。或以现在比于未来。又如饮食衣服严具车乘等事。观见一分得失之相。比知一切。又以一分成熟。比余熟分。如是等类。名体比量

业比量者。谓以作用比业所依。如见远物无有动摇鸟居其上。由是等事比知是杌。若有动摇等事。比知是人。广迹住处比知是象。曳身行处比知是蛇。若闻嘶声比知是马。若闻哮吼比知师子。若闻咆勃比知牛王。见比于眼。闻比于耳。嗅比于鼻。尝比于舌。触比于身。识比于意。水中见碍比知有地。若见是处草木滋润茎叶青翠比知有水。若见热灰比知有火。丛林掉动比知有风。暝目执杖进止问他。蹎蹶失路。如是等事比知是盲。高声侧听比知是聋。正信聪睿。离欲未离欲。菩萨如来。如是等类。以业比度。如前应知

法比量者。谓以相邻相属之法。比余相邻相属之法。如属无常比知有苦。以属苦故比空无我。以属生故比有老法。以属老故比有死法。以属有色有见有对比有方所及有形质。属有漏故比知有苦。属无漏故比知无苦。属有为故比知生住异灭之法。属无为故比知无生住异灭法。如是等类名法比量

因果比量者。谓以因果展转相比。如见有行比至余方。见至余方比先有行。若见有人如法事王比知当获广大禄位。见大禄位比知先已如法事王。若见有人备善作业比知必当获大财富。见大财富比知先已备善作业。见先修习善行恶行比当兴衰。见有兴衰。比先造作善行恶行。见丰饮食比知饱满。见有饱满比丰饮食。若见有人食不平等。比当有病。现见有病比知是人食不平等。见有静虑比知离欲。见离欲者比有静虑。若见修道比知当获沙门果证。若见有获沙门果证。比知修道。如是等类。当知总名因果比量。是名比量

正教量者。谓一切智所说言教。或从彼闻。或随彼法。此复三种。一不违圣言。二能治杂染。三不违法相

不违圣言者。谓圣弟子说。或佛自说经教。展转流布。至今不违正法。不违正义

能治杂染者。谓随此法善修习时。能永调伏贪嗔痴等一切烦恼及随烦恼。不违法相者。谓翻违法相。当知即是不违法相。何等名为违法相耶。谓于无相增为有相。如执有我有情命者生者等类。或常或断。有色无色。如是等类。或于有相减为无相。或于决定立为不定。如一切行皆是无常。一切有漏皆性是苦。一切诸法皆空无我。而妄建立一分是常一分无常。一分是苦一分非苦。一分有我一分无我。于佛所立不可记法。寻求记别。谓为可记。或安立记。或于不定建立为定。如执一切乐受皆贪所随眠。一切苦受嗔所随眠。一切不苦不乐受痴所随眠。一切乐受皆是有漏。一切乐俱故思造业。一向决定受苦异熟。如是等类。或于有相法中。无差别相建立差别。有差别相立无差别。如于有为无差别相。于无为中亦复建立。于无为法无差别相。于有为法。亦复建立。如于有为无为。如是于有色无色。有见无见。有对无对。有漏无漏。随其所应。皆当了知。又于有相不如正理立因果相。如立妙行感不爱果。立诸恶行感可爱果。计恶说法毗奈耶中。习诸邪行能得清净。于善说法毗奈耶中。修行正行谓为杂染。于不实相以假言说立真实相。于真实相以假言说种种安立。如于一切离言法中建立言说说第一义。如是等类名违法相。与此相违当知即是不违法相。是名正教

问若一切法自相成就。各自安立己法性中。复何因缘建立二种所成义耶。答为欲令他生信解故。非为生成诸法性相。问为欲成就所成立义。何故先立宗耶。答为先显示自所爱乐宗义故。问何故次辩因耶。答为欲开显依现见事决定道理。令他摄受所立宗义故。问何故次引喻耶。答为欲显示能成道理之所依止现见事故。问何故后说同类异类。现量比量。正教等耶。答为欲开示因喻二种相违不相违智故。又相违者。由二因缘。一不决定故。二同所成故。不相违者。亦二因缘。一决定故。二异所成故。其相违者。于为成就所立宗义。不能为量故。不名量。不相违者。于为成就所立宗义。能为正量故名为量。是名论所依

论庄严者。略有五种。一善自他宗。二言具圆满。三无畏。四敦肃。五应供。善自他宗者。谓如有一若于此法。毗奈耶中深生爱乐。即于此论宗旨。读诵受持。听闻思惟。纯熟修行。已善已说已明。若于彼法毗奈耶中不爱不乐。然于彼论宗旨。读诵受持。闻思纯熟。而不修行。然已善已说已明。是名善自他宗

言具圆满者。谓如有一凡有所说。皆以其声不以非声。何等为声。谓具五德。乃名为声。一不鄙陋。二轻易。三雄朗。四相应。五义善。不鄙陋者。谓离边方边国鄙俚言词。轻易者。谓有所说皆以世间共用言词。雄朗者。所谓依义建立言词能成彼义巧妙雄壮。相应者。谓前后法义相符不散。义善者。谓能引发胜生定胜无有颠倒。又此声论由九种相言具圆满。一不杂乱。二不粗犷。三辩了。四限量。五与义相应。六以时。七决定。八显了。九相续。如是一切相总名言具圆满

无畏者。谓如有一处在多众杂众大众执众谛众善众等中。其心无有下劣恒惧。身无战汗。面无怖色。音无謇吃。语无怯弱。如是说者。名为无畏

敦肃者。谓如有一待时方说而不嚵速。是名敦肃

应供者。谓如有一为性调善不恼于他。终不违越诸调善者调善之地。随顺他心而起言说。以时如实能引义利。言词柔软如对善友。是名应供

若有依此五论庄严兴言论者。当知。复有二十七种称赞功德。何等名为二十七种。一众所敬重。二言必信受。三处大众中都无所畏。四于他宗旨深知过隙。五于自宗旨知殊胜德。六无有僻执于所受论情无偏党。七于自正法及毗奈耶无能引夺。八于他所说速能了悟。九于他所说速能领受。十于他所说速能酬对。十一具语言德令众爱乐。十二悦可信解此明论者。十三能善宣释义句文字。十四令身无倦。十五令心无倦。十六言不謇涩。十七辩才无尽。十八身不顿瘁。十九念无忘失。二十心无损恼。二十一咽喉无损。二十二凡所宣吐分明易了。二十三善护自心令无忿怒。二十四善顺他心令无愤恚。二十五令对论者心生净信。二十六凡有所行不招怨对。二十七广大名称声流十方。世咸传唱此大法师处大师数。如受欲者以末尼真珠琉璃等宝。厕环钏等宝庄严具以自庄严。威德炽盛光明普照。如是论者以二十七称赞功德。厕此五种论庄严具以自庄严。威德炽盛光明普照。是故名此为论庄严。是名论庄严

论堕负者。谓有三种。一舍言。二言屈。三言过。

舍言者。谓立论者。以十三种词。谢对论者舍所言论。何等名为十三种词谓。立论者谢对论者曰。我论不善汝论为善。我不善观。汝为善观。我论无理汝论有理。我论无能汝论有能。我论屈伏汝论成立。我之辩才唯极于此。过此已上更善思量当为汝说。且置是事我不复言。以如是等十三种词。谢对论者舍所言论。舍所论故。当知。被破为他所胜。堕在他后。屈伏于彼。是故舍言名堕负处

言屈者。如立论者。为对论者之所屈伏。或托余事方便而退。或引外言。或现愤发。或现嗔恚。或现憍慢。或现所覆。或现恼害。或现不忍。或现不信。或复默然。或复忧戚。或竦肩伏面。或沉思词穷。假托余事方便而退者。谓舍前所立更托余宗。舍先因喻同类异类现量比量及正教量。更托余因乃至正教。引外言者。谓舍所论事。论说饮食王臣盗贼衢路倡秽等事。假托外缘舍本所立。以遣他难。现愤发者。谓以粗犷不逊等言。摈对论者。现嗔恚者。谓以怨报之言。责对论者。现憍慢者。谓以卑贱种族等言。毁对论者。现所覆者。谓以发他所覆恶行之言。举对论者。现恼害者。谓以害酷怨言。骂对论者。现不忍者。谓发怨言怖对论者。现不信者。谓以毁坏行言。谤对论者。或默然者。谓语业顿尽。或忧戚者。谓意业焦恼。竦肩伏面者。谓身业威严而顿萎瘁。沉思词穷者。谓才辩俱竭。由如是等十三种事。当知言屈。前二妄行矫乱。中七发起邪行。后四计行穷尽。是名言屈堕在负处

言过者。谓立论者为九种过污染其言。故名言过。何等为九。一杂乱。二粗犷。三不辩了。四无限量。五非义相应。六不以时。七不决定。八不显了。九不相续。杂乱者。谓舍所论事杂说异语。粗犷者。谓愤发掉举及躁急掉举。不辩了者。谓若法若义众及对论所不领悟。无限量者。谓所说义言词复重或复减少。非义相应者。当知有十种。一无义。二违义。三损理。四与所成等。五招集过难。六不得义利。七义无次序。八义不决定。九成立能成。十顺不称理诸邪恶论。非时者。谓所应说前后不次。不决定者。谓立已复毁。毁而复立。速疾转换难可了知。不显了者。谓言招讥弄不领而答。先为典语后为俗语。或先俗语后复典语。不相续者。谓于中间言词断绝。凡所言论犯此九失。是名言过堕在负处

论出离者。谓立论者。先应以彼三种观察。观察论端。方兴言论。或不兴论。名论出离。三种观察者。一观察得失。二观察时众。三观察善巧及不善巧

观察得失者。谓立论者。方兴论端。先当观察。我立是论。将无自损损他及俱损耶。不生现法后法及俱罪耶。勿起身心诸忧苦耶。莫由此故执持刀杖斗骂。诤讼谄诳妄语而发起耶。将无种种恶不善法而生长耶。非不利益安乐若自若他及多众耶。非不怜愍诸世间耶。不因此故诸天世人无义无利不安乐耶。彼立论者如是观时。若自了知我所立论能为自损。乃至天人无义无利亦无安乐。便自思勉不应立论。若如是知我所立论不为自损。乃至能引天人义利及与安乐。便自思勉当立正论。是名第一或作不作论出离相

观察时众者。谓立论者方起论端。应善观察现前众会。为有僻执为无执耶。为有贤正为无有耶。为有善巧为无有耶。如是观时。若知众会唯有僻执非无僻执。唯不贤正无有贤正。唯不善巧无善巧者。便自思勉。于是众中不应立论。若知众会无所僻执非有僻执。唯有贤正无不贤正。唯有善巧无不善巧。便自思勉。于是众中应当立论。是名第二或作不作论出离相。

观察善巧不善巧者。谓立论者。方起论端。应自观察善与不善。我于论体论处。论依论严。论负论出离等。为善巧耶。不善巧耶。我为有力能立自论摧他论耶。于论负处能解脱耶。如是观时。若自了知我无善巧非有善巧。我无力能非有力能。便自思勉。与对论者不应立论。若自了知我有善巧非无善巧。我有势力非无势力。便自思勉。与对论者当共立论。是名第三或作不作论出离相

论多所作法者。谓有三种。于所立论多所作法。一善自他宗。二勇猛无畏。三辩才无竭。问如是三法于所立论何故名为多有所作。答能善了知自他宗故。于一切法能起谈论。勇猛无畏故。处一切众能起谈论。辩才无竭故。随所问难皆善酬答。是故此三于所立论多有所作

已说因明处。

云何声明处。当知。此处略有六相。一法施设建立相。二义施设建立相。三补特伽罗施设建立相。四时施设建立相。五数施设建立相。六处所根栽施设建立相。嗢拖南曰

  法义数取趣　　时数与处所
  若根栽所依　　是略声明相

云何法施设建立。谓名身句身文身。及五德相应声。一不鄙陋。二轻易。三雄朗。四相应。五义善

云何义施设建立。当知略有十种。一根建立。二大种建立。三业建立。四寻求建立。五非法建立。六法建立。七兴盛建立。八衰损建立。九受用建立。十守护建立。嗢拖南曰

  眼等与地等　　身等及寻求
  非法法兴盛　　衰损受用护

根建立者。谓见义闻义。嗅义尝义。触义知义。大种建立者。谓依持等义。浇润等义。照了等义。动摇等义。业建立者。谓往来等义。宣说等义。思念觉察等义。寻求建立者。谓追访等义。非法建立者。谓杀盗等义。法建立者。谓施戒等义。兴盛建立者。谓证得喜悦等义。衰损建立者。谓破坏怖畏忧戚等义。受用建立者。谓饮食覆障抱持受行等义。守护建立者。谓守护育养盛满等义

又复略说有六种义。一自性义。二因义。三果义。四作用义。五差别相应义。六转义。嗢拖南曰

  自性与因果　　作用相应转

云何补特伽罗施设建立。谓建立男女非男非女声相差别。或复建立初中上士声相差别

云何时施设建立。谓有三时声相差别。一过去过去殊胜。二未来未来殊胜。三现在现在殊胜

云何数施设建立。谓有三数声相差别。一者一数。二者二数。三者多数

云何处所根栽施设建立。当知处所略有五种一相续。二名号。三总略。四彼益。五宣说。若界颂等名为根栽。如是二种总名处所根栽建立

已说声明处。

云何工业明处。谓于十二处。略说工业所有妙智。名工业明处。何等十二工业处耶。谓营农工业。商估工业。事王工业。书算计度数印工业。占相工业。咒术工业。营造工业。生成工业。防那工业。和合工业。成熟工业。音乐工业

瑜伽师地论卷第十五瑜伽师地论卷第十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中思所成地第十一之一

已说闻所成地。云何思所成地。当知。略说由三种相。一由自性清净故。二由思择所知故。三由思择诸法故

云何自性清净。谓九种相应知。一者谓如有一独处空闲审谛思惟如其所闻如所究达诸法道理。二者远离一切不思议处审谛思惟所应思处。三者能善了知黑说大说。四者凡所思惟唯依于义不依于文。五者于法少分唯生信解。于法少分以慧观察。六者坚固思惟。七者安住思惟。八者相续思惟。九者于所思惟能善究竟终无中路厌怖退屈。由此九相名为清净善净思惟

云何思择所知。谓善思择所观察义。何等名为所观察义。谓于有法了知有相。于非有法了知无相。如是名为所观察义

何等名为所观有法。当知。此法略有五种。一自相有法。二共相有法。三假相有法。四因相有法。五果相有法

何等名为自相有法。当知此法略有三种。一胜义相有。二相状相有。三现在相有。胜义相有者。谓诸法中离言说义出世间智所行境界非安立相。相状相有者。谓由四种所观相状。一于是处名可得。二于是处事可得。三此名于此事非不决定。谓或迷乱不决定故。或无常不决定故。四此名于此事无碍随转。非或于是处随转。或于是处退还。现在相有者。谓若已生及因果性。如是一切总说为一自相有法。

何等名为共相有法。当知。此相复有五种。一种类共相。二成所作共相。三一切行共相。四一切有漏共相。五一切法共相。种类共相者。谓色受想行识等各别种类。总名为一种类共相。成所作共相者。谓善有漏法。于感爱果。由能成办所作共相。说名共相。如善有漏法于感爱果。如是不善法于感非爱果。念住正断。神足根力。觉支道支。菩提分法。于得菩提。由能成办所作共相。说名共相。当知亦尔。一切行共相者谓一切行无常性相。一切有漏共相者谓有漏行者皆苦性相。一切法共相者谓一切法空无我性相。如是一切总说为一共相有法

何等名为假相有法。谓若于是处。略有六种言论生起。当知。此处名假相有。何等名为六种言论。谓属主相应言论。远离此彼言论。众共施设言论。众法聚集言论。不遍一切言论。非常言论。属主相应言论者。谓诸言论。配属于主方解其相。非不属主。如说生时。此谁之生。待所属主起此言论。谓色之生。受想行识之生。非说色时此谁之色待所属主起此言论。如生如是。老住无常等。心不相应行。随其所应尽当知。是名属主相应言论。若于是处起此言论。当知。此处是假相有。远离此彼言论者。谓诸言论。非以此显此。亦非以彼显彼。是说名为远离此彼言论。若以此显此。言论。是言论亦于实相处转。亦于假相处转。若以彼显彼言论。是言论亦于实相处转。亦于假相处转。若非以此显此亦非以彼显彼言论。是言论一向于假相处转。云何以此显此言论。于实相处转。如言地之坚。云何此复于假相处转。如言石之圆。如地之坚石之圆。如是水之湿。油之滴。火之暖。毁之焰。风之动。飘之鼓亦尔。云何以彼显彼言论。于实相处转。如言眼之识。身之触。如是等。云何此复于假相处转。如言佛授德友之所饮食。车乘衣服。庄严具等。云何非以此显此亦非以彼显彼言论。一向于假相处转。如言宅之门。舍之壁。瓶之口。瓮之腹。军之车。林之树。百之十。十之三。如是等是名远离此彼言论。众共施设言论者。谓于六种相状言说自性假立言论。六种相状者。一事相状。二所识相状。三净妙等相状。四饶益等相状。五言说相状。六邪行等相状。事相状者。谓识所取。所识相状者。谓作意所取。能起于识。净妙等相状者。谓触所取。饶益等相状者。谓受所取。言说相状者。谓想所取。邪行等相状者。谓思所取。众法聚集言论者。谓于众多和合建立自性言论。如于内色受想行识建立种种我等言论。于外色香味触等事和合差别。建立宅舍瓶衣车乘军林树等。种种言论。不遍一切言论者。谓诸言论。有处随转。有处旋还。如于舍宅舍宅言论。于诸舍宅处处随转。于村聚落亭逻国等。即便旋还。于盆瓮等。盆等言论于盆瓮等处处随转。于瓶器等即便旋还。于军军言随诸军转。于别男女幼少等类即便旋还。于林林言随诸林转。于别树根茎枝条叶华果等类即便旋还。非常言论者。由四种相应知。一由破坏故。二由不破坏故。三由加行故。四由转变故。破坏故者。谓瓶等破已。瓶等言舍。瓦等言生。不破坏故者。谓种种物共和合已。或丸或散。种种杂物差别言舍。丸散言生。加行故者。谓于金段等。起诸加行。造环钏等异庄严具。金段等言舍。环钏等言生。转变故者。谓饮食等于转变时。饮食等言舍。便秽等言生。如是等类。应知名为非常言论。随于诸物发起如是六种言论。当知。此物皆是假有。是名假相有法。

何等名为因相有法。当知此因略有五种。一可爱因。二不可爱因。三长养因。四流转因。五还灭因。可爱因者。谓善有漏法。不可爱因者。谓不善法。长养因者。谓前前所生善不善无记法。修习善修习。多修习故。能令后后所生善不善无记法展转增胜。名长养因。流转因者。谓由此种子。由此薰习。由此助伴。彼法流转。此于彼法名流转因。还灭因者。谓诸行还灭。杂染还灭。所有一切能寂静道。能般涅槃。能趣菩提。及彼资粮。并其方便能生能办。名还灭因。如是总名因相有法。若广分别。如思因果中。应知其相。

何等名为果相有法。谓从彼五因。若生若得。若成若办若转。当知。是名果相有法

何等名为所观无法。当知。此相亦有五种。一未生无。二已灭无。三互相无。四胜义无。五毕竟无。未生无者。谓未来诸行。已灭无者。谓过去诸行。互相无者。谓诸余法由所余相。若远离性。若非有性。或所余法与诸余法不和合性。胜义无者。谓由世俗言说自性。假设言论所安立性。毕竟无者。谓石女儿等。毕竟无类。

复有五种有性五种无性。何等名为五种有性。一圆成实相有性。二依他起相有性。三遍计所执相有性。四差别相有性。五不可说相有性。此中初是胜义相。第二是缘生相相。第三是假施设相。第四是不二相。生相老相。住相无常相。苦相空相。无我相事相。所识相所取相。净妙等相。饶益等相。言说相相。邪行等相相。如是等相。应知名差别相。第五由四种不可说故名不可说相。一无故不可说。谓补特伽罗于彼诸蕴不可宣说若异不异。二甚深故不可说。谓离言法性不可思议。如来法身不可思议。诸佛境界。如来灭后若有若无等。不可宣说。三能引无义故不可说。谓若诸法非能引发法义梵行。诸佛世尊虽证不说。四法相法尔之所安立故不可说。所谓真如于诸行等不可宣说异不异性。

何等名为五种无性。一胜义相无性。二自依相无性。三毕竟自相无性。四无差别相无性。五可说相无性

云何思择诸法。此复二种应知。一思择素呾缆义。二思择伽他义。

思择素呾缆义。如摄事分及菩萨藏教授中当广说。

思择伽他义。复有三种。一者建立胜义伽他。二者建立意趣义伽他。三者建立体义伽他。

建立胜义伽他者。如经言

  都无有宰主　　及作者受者
  诸法亦无用　　而用转非无
  唯十二有支　　蕴处界流转
  审思此一切　　众生不可得
  于内及于外　　是一切皆空
  其能修空者　　亦常无所有
  我我定非有　　由颠倒妄计
  有情我皆无　　唯有因法有
  诸行皆刹那　　住尚无况用
  即说彼生起　　为用为作者
  眼不能见色　　耳不能闻声
  鼻不能嗅香　　舌不能尝味
  身不能觉触　　意不能知法
  于此亦无能　　任持驱役者
  法不能生他　　亦不能自生
  众缘有故生　　非故新新有
  法不能灭他　　亦不能自灭
  众缘有故生　　生已自然灭
  由二品为依　　是生便可得
  恒于境放逸　　又复邪升进
  愚痴之所漂　　彼遂邪升进
  诸贪爱所引　　于境常放逸
  由有因诸法　　众苦亦复然
  根本二惑故　　十二支分二
  自无能作用　　亦不由他作
  非余能有作　　而作用非无
  非内亦非外　　非二种中间
  由行未生故　　有时而可得
  设诸行已生　　由此故无得
  未来无有相　　过去可分别
  分别曾所更　　非曾亦分别
  行虽无有始　　然有始可得
  诸色如聚沫　　诸受类浮泡
  诸想同阳焰　　诸行喻芭蕉
  诸识犹幻事　　曰亲之所说
  诸行一时生　　亦一时住灭
  痴不能痴痴　　亦不能痴彼
  非余能有痴　　而愚痴非无
  不正思惟故　　诸愚痴得生
  此不正思惟　　非不愚者起
  福非福不动　　行又三应知
  复有三种业　　一切不和合
  现在速灭坏　　过去住无方
  未生依众缘　　而复心随转
  毕竟共相应　　不相应亦尔
  非一切一切　　而说心随转
  于此流无断　　相似不相似
  由随顺我见　　世俗用非无
  若坏于色身　　名身亦随灭
  而言今后世　　自作自受果
  前后差别故　　自因果摄故
  作者与受者　　一异不可说
  因道不断故　　和合作用转
  从自因所生　　及摄受所作
  乐戏论为因　　若净不净业
  诸种子异熟　　及爱非爱果
  依诸种异熟　　我见而生起
  自内所证知　　无色不可见
  无了别凡夫　　计斯为内我
  我见为依故　　起众多妄见
  总执自种故　　宿习助伴故
  听闻随顺故　　发生于我见
  贪爱及与缘　　而生于内我
  摄受希望故　　染习外为所
  世间真可怖　　愚痴故摄受
  先起爱藏已　　由兹趣戏论
  彼所爱藏者　　贤圣达为苦
  此苦逼愚夫　　刹那无暂息
  不平等缠心　　积集彼众苦
  积集是愚夫　　计我苦乐缘
  诸愚夫固着　　如大象溺泥
  由痴故增上　　遍行遍所作
  此池派众流　　于世流为暴
  非火风日竭　　唯除正法行
  于苦计我受　　苦乐了知苦
  分别此起见　　从彼生生彼
  染污意恒时　　诸惑俱生灭
  若解脱诸惑　　非先亦非后
  非彼法生已　　后净异而生
  彼先无染污　　说解脱众惑
  其有染污者　　毕竟性清净
  既非有所净　　何得有能净
  诸种子灭故　　诸烦恼尽故
  即于此无染　　显示二差别
  自内所证故　　唯众苦尽故
  永绝戏论故　　一切无戏论
  众生名相续　　及法想相中
  无生死流转　　亦无涅槃者

此中依止补特伽罗无我胜义。宣说如是胜义伽他。为欲对治增益损减二边执故于所摄受说为宰主。于诸业用说为作者。于诸果报说为受者。如是半颂。遮遣别义所分别我。诸法亦无用者。遮遣即法所分别我。由此远离增益边执。而用转非无者。显法有性。由此远离损减边执。用有三种。一宰主用。二作者用。三受者用。因此用故。假立宰主作者受者

虽言诸法而未宣说。何等为法。故次说言唯有十二支等半颂。如有支次第。诸蕴等流转。此显不取微细多我。便能对治宰主作者及受者执。眼色为缘生眼识果。无别受者。此中显示即十八界说受者。性虽言无主。而未宣说无何等主。为欲显示故。次说言审思此一切众生不可得。言审思者。由依三量审谛观察

此若无者。云何建立内外成就。故次说言于内及于外是一切皆空。此显内外唯假建立。云何建立能观所观二种成就。故次说言其能修空者亦常无所有

云何建立圣者异生二种成就。故次说言我我定非有由颠倒妄计。此显圣者及异生我决定无有真实我性。唯由颠倒妄计为有。云何建立彼此成就。故次说言有情我皆无。云何建立染净成就。故次说言唯有因法有。染者净者皆不可得

虽说诸法皆无作用。而未宣说云何无用。故次说言诸行皆刹那住尚无况用。如前已说。用转非无。云何无用而有用转。故次说言即说彼生起为用为作者。果故名为用。因故名作者。彼生起者。显从诸处诸识得生。彼得生者。非离眼等彼成就故

如前所说诸法无用。此显无用略有七种。一无作用用。谓眼不能见色等。二无随转用。谓于此亦无能任持驱役者。如其次第宰主作者俱无所有故。无有能随转作用。三无生他用。谓法不能生他。四无自生用。谓亦不能自生。五无移转用。谓众缘有故生。非故新新有。六无灭他用。谓法不能灭他。七无自灭用。谓亦不能自灭问如众缘有故生。亦众缘有故灭耶。答众缘有故生。生已自然灭

如前所说。有因法有。欲显在家及与出家杂染自性有因法有。故次说言由二品为依是生便可得等。由此二颂。显无明爱有因法有。次后五颂。显杂染品差别所依因及时分。此中有因诸法者。谓无明乃至受有因。众苦者。谓爱乃至老死。此言显示烦恼业生三种杂染。根本二惑故者。此言显示烦恼杂染唯取最胜烦恼杂染。自无能作用等言。复重别显业杂染义。由彼所作有差别故。彼果异熟不思议故。自无能作用者。待善恶友他所引故。亦不由他作者。待自功用所成办故。非余能有作者。要待前生因差别故。方有所作。非内亦非外等颂中。显依未来不生杂染依止现在过去诸行能生杂染。设行已生。即由此相无有分别。未来无相故。无分别如此。如是当来决定不可知故。若不如是分别异类或时可得。若于过去即可分别如此。如是曾有相貌可分别故。非唯曾更而可分别。未曾更者。虽不分明取其相貌。然随种类亦可分别。此则显示依现在行分别为因生诸杂染。行虽无始。然始可得者。显示杂染时分差别。无始时来常随逐故。刹那刹那新所起故

自此已后显清净品。如实观时得清净故。或由自相故。谓观色等如聚沫等。或由共相故。谓观有为同生住灭所有共相。或由世俗及胜义谛故。谓虽无痴者非无愚痴众缘所生。世俗谛故说痴能痴。又复显示非不愚者不正思惟。是故彼为愚痴所痴。又由世俗。宣说诸识随福等行。若就胜义无所随逐。又三应知者。谓去来今。三种业者。谓身等业。一切不和合者。更互相望不和合故。所以者何。现在速灭坏。过去住无方。未生。依众缘。而复心随转。若彼与此更互相应。如福等行无有和合。彼心相应道理亦尔。云何当有实随转性。何以故。若心与彼诸行相应。或不相应。非此与彼。或时不相应。或时非不相应。又非一切心。或相应或不相应。如是由胜义故。心随转性不得成就。今当显示。由世俗故。说心随转所有因缘。于此流无断者。今此颂中。显世俗谛非无作用及与随转。又由胜义无有作者及与受者由世俗故而得宣说自作自受。又作者受者。若一若异。皆不可说。为显此义故。次说言前后差别等颂

如是由胜义故无有宰主作者受者。唯有因果。于因果相释通疑难。略由五颂显示于此起我颠倒。初颂显示虽无有我而有后有无有断绝。又诸因果非顿俱有。非从一切一切得生。又此因道无有断绝。颂中四句。如其次第。释此四难。由第二颂。显因果相。由后三颂。显于无我诸因果中起我颠倒。此中显示彼所缘境。彼所依止。彼因彼果。初颂显示彼所缘境。自内所证。无色难见难可寻思。故名无色。经说色相为寻思故。难说示他故不可见。由第二颂。显彼依果。凡夫是依。众见是果。由第三颂。显示彼因。俱生我见。由总执计自种随眠之所生起。诸外道等分别我见。由宿习等之所生起。此外道见。要由数习故。不正寻思故。又得随顺从他听闻非正法故。而得生长。此中显示由所依止作意所缘诸过失故。分别我见方得生起。次后五颂。显彼我见由集次第发生于苦。又即此苦并及我见二苦因缘。又于解脱能为障碍。此中初颂显示于集。第二第三显示行苦所摄阿赖耶识爱藏此已而趣戏论。谓我当有非当有等。言爱藏者。摄为己体故。又复此苦于一切时恒常随逐。无一刹那而暂息者。由第四颂。显示此苦是能计我及苦乐缘。由第五颂。显示计我。由愚痴故障碍解脱。言增上者。望余二苦故。言遍行者。随逐诸受故。遍所作者。遍善恶无记故

今当显示阿赖耶识所摄行苦共他相似。又显差别。由正法行方能竭故。于世众流最为暴恶。言众流者。譬眼等六五趣三界等。又法行者。显示解了解脱遍知及缚遍知。解了缚遍知者。即了知苦。谓了知我受苦受乐皆依于苦。又此分别能起诸见。从彼所生亦能生彼。显示解了缚遍知已。余有六颂。显示解了解脱遍知。谓染污意。恒时诸惑俱生灭。若解脱诸惑。非先亦非后等。非先者。与诸烦恼恒俱生故。非后者即与彼惑俱时灭故。又显所说解脱之相。谓非即彼生已后方清净。别有所余清净意生。即彼先来无染污故说为解脱。为成此义故。复说言其有染污者毕竟性清净等。颂又复显示二种解脱。谓烦恼解脱。及事解脱。诸种子灭故诸烦恼尽故者。显示烦恼解脱。即于此无染者。显示事解脱。如经言。苾刍当知。若于眼中贪欲永断。如是此眼亦当永断。乃至广说。如是显示有余依解脱已。次当显示无余依解脱。自内所证者。显彼不思议故。唯众苦尽者。为遣妄计唯无性执。谓有余依。永寂灭故。说为寂灭。非全无性。无戏论者。此解脱性。唯内所证。若异不异。死后当有。或当无等。一切戏论不能说故。为显补特伽罗及法俱非流转生死或般涅槃故。复颂言众生名相续。及法想相中。无生死流转。亦无涅槃者

已释胜义圣教伽他。次当建立意趣义伽他。

如经言。一时索诃世界主大梵天王。往世尊所。顶礼佛足退坐一面。以妙伽他而赞请曰

  于学到究竟　　善断诸疑网
  今请学所学　　修学为我说
  大仙应善听　　学略有三种
  增上戒心慧　　于彼当修学
  应圆满六支　　四乐住成就
  于四各四行　　智慧常清净
  初善住根本　　次乐心寂静
  后圣见恶见　　相应不相应
  先净乐静虑　　及于谛善巧
  即于诸谛中　　应生远增长
  于诸学处中　　有四趣三所
  远离于二趣　　于二趣证得
  二安住二种　　一能趣涅槃
  渐次为因缘　　纯杂而修习
  最先离恶作　　最后乐成满
  诸学是为初　　于此学聪睿
  由此智修净　　净生乐成满
  诸学是为中　　于此学聪睿
  从此心解脱　　永灭诸戏论
  诸学是为尊　　于此学聪睿
  若行趣不净　　亦趣于善趣
  是行说为初　　当知此非共
  若行趣清净　　非诸趣究竟
  是行说为中　　当知亦非共
  若行趣清净　　于诸趣究竟
  是行说为尊　　当知此必共
  若有学无学　　当知并聪睿
  若有学无学　　当知并愚夫
  若弃舍摄受　　亦断除粗重
  及现见所知　　是受持三学
  若有缘无缘　　亦细粗显现
  由受持远离　　言发悟所引
  初学唯有一　　第二学二种
  第三学具三　　慧者皆超越
  不毁坏尸罗　　于学誓能顺
  轨范无讥论　　于五处远离
  若无犯出离　　无恶作恶作
  于彼学寻求　　及勤修彼行
  终无有弃舍　　命难亦无亏
  常住正行中　　随毗柰耶转
  修治誓为先　　亦修治净命
  二边皆远离　　亦弃舍邪愿
  于诸障碍法　　终无有耽染
  乱心法才生　　寻当速远离
  非太沉太浮　　恒善住正念
  根本眷属净　　而修行梵行
  应发勤精进　　常坚固勇猛
  恒修不放逸　　五支善安住
  当隐自诸善　　亦发露众恶
  得诸衣服等　　粗妙皆欢喜
  少随于世务　　粗弊亦随转
  受杜多功德　　为寂离烦恼
  当具足威仪　　应量而摄受
  终无有所为　　诈现威仪相
  不自说实德　　亦不令他说
  虽有所方求　　而非现异相
  从他边乞求　　终不强威逼
  以法而获得　　得已不轻毁
  不耽着利养　　及所有恭敬
  亦不执诸见　　增益与损减
  不着顺世间　　无义文咒术
  亦不乐畜积　　无义长衣钵
  恐增诸烦恼　　不染习居家
  为净修智慧　　当亲近贤圣
  不畜朋友家　　恐发忧悲乱
  能生苦烦恼　　才起寻远离
  不受于信施　　恐加害疮疱
  于如来正法　　尝无有弃舍
  于他愆犯中　　无功用安乐
  常省自过失　　知已速发露
  若犯于所犯　　当如法出离
  所应营事中　　能勇励自作
  于佛及弟子　　威德与言教
  一切皆信受　　观大罪不谤
  于极甚深法　　不可思度处
  能舍旧师宗　　不坚执自见
  常乐居远离　　及边际卧具
  恒修习善法　　坚精进勇猛
  无有欲生欲　　不憎恶憎恶
  离睡眠睡眠　　时不居寂静
  离恶作恶作　　无希虑希虑
  一切种恒时　　成就正方便
  引发与觉悟　　及和合所结
  有相若亲昵　　亦多种喜乐
  侵逼极亲昵　　名虚妄分别
  能生于欲贪　　智者当远离
  诸欲令无饱　　众多所共有
  是非法因缘　　能增长贪欲
  贤圣所应离　　速趣于坏灭
  仗托于众缘　　危逸所依地
  诸欲如枯骨　　亦如软肉段
  如草炬相似　　犹如大火坑
  譬如蟒毒蛇　　亦如梦所见
  如借庄严具　　如树端熟果
  如是知诸欲　　都不应耽乐
  当听闻正法　　常思惟修习
  先观见粗静　　次于修一向
  舍烦恼粗重　　于断生欣乐
  于诸相观察　　得加行究竟
  能离欲界欲　　及离色界欲
  入真谛现观　　能离一切欲
  证现法涅槃　　及余依永尽

于学到究竟。善断诸疑网。今请学所学修学为我说者。于此颂中。大梵天王先赞世尊。后兴请问。赞世尊者。谓于一切学中已得第一究竟。此依自利行圆满不共德说。又能善断展转所生一切疑网。此依利他行圆满不共德说。兴请问者。何等为学。学有几种。云何于彼当修学耶

是故世尊意。为策励怖多所作懈怠众生。总摄一切。略说三学。故次告曰大仙应善听。学略有三种。增上戒心慧。于彼当修学。此中显示。依戒心慧。若散乱者。令不散乱。方便为说增上戒学。心未定者。为令得定方便为说增上心学。心已得定未解脱者。为令解脱方便为说增上慧学。由此因缘。诸修行者。一切所作皆得究竟。此显世尊密意宣说一切诸学无不摄在此三学中

又为显示于诸学中由此方便成办所学。故次说言应圆满六支四乐住成就。于四各四行。智慧常清净。今此颂中。如其次第显示成办三学方便。应圆满六支者。应依增上戒学方便修学。何等六支。一安住净尸罗。二守护别解脱律仪。三轨则圆满。四所行圆满。五于诸小罪见大怖畏。六受学学处。如是六支显示四种尸罗清净。安住净尸罗者。是所依根本。守护别解脱律仪者。显示出离。尸罗清净。为求解脱而出离故。轨则所行俱圆满者。此二显示无所讥毁尸罗清净。于诸小罪见大怖畏者。显无穿缺尸罗清净。受学学处者。显无颠倒尸罗清净。如是六支极圆满故。增上戒学。与余方便作所依止。四乐住成就者。显示增上心学方便。四种静虑名四心住。现法乐住故名为乐。于四各四行智慧常清净者。依增上慧学说。谓于苦集灭道四圣谛中。一一皆有四行。即无常等。增上慧学由此净智之所显故

初善住根本。次乐心寂静。后圣见恶见。相应不相应者。此颂显示增上三学次第生起。根本者。谓增上戒。由后二种是此初学所流类故。既具尸罗由无悔等。次第修习能得第二心乐静定。心得定者见如实故。能得第三成就圣见远离恶见

先净乐静虑。及于谛善巧。即于诸谛中。应生远增长者。此颂显示三学次第清净差别。先净者是初学。乐静虑者是第二学。于谛善巧者是第三学。又于如是谛善巧中。应生者。谓道谛。应生起故。应远者。谓苦集谛。应远离故。应增长者。谓灭谛。软中上品烦恼次第。数数渐断。增长灭故

于诸学处中。有四趣三所。远离于二趣。于二趣证得者。此颂显示于增上戒心慧学处。由所修学有成败故。随其所应。所得果报四趣差别。谓于欲界人天所摄所有善趣。是增上戒成所得果。即于欲界余趣所摄所有恶趣。是增上戒败所得果。色无色界天趣所摄所有上趣。是增上心果。三界所不摄涅槃趣。是增上慧果。于如是诸趣中。远离前二善趣恶趣已。应证后二上趣及涅槃趣。此言显示世出世间二道所得

二安住二种。一能趣涅槃。渐次为因缘。纯杂而修习者。于此颂中。显示最初增上戒学增上心学。渐次能为增上心学增上慧学安住因缘。显示中间增上慧静虑律仪所摄增上戒学能为二种安住因缘。显示最上一种能为涅槃安住因缘。当知。此中显示修习若别若总随其所应

最先离恶作。最后乐成满。诸学是为初。于此学聪睿者。此颂显示由增上戒学以无悔等渐次修习为后转因。由此智修净。净生乐成满。诸学是为中。于此学聪睿者。此颂显示由增上心学修所成慧最胜善根渐次生故为最上学因

从此心解脱。永灭诸戏论。诸学是为尊。于此学聪睿者。此颂显示由增上慧学能为最胜涅槃果因

若行趣不净。亦趣于善趣。是行说为初。当知此非共者。此颂显示增上戒学若有败毁为恶趣因。若能成立为善趣因。此是不共离后二学亦能成立故。若行趣清净。非诸趣究竟。是行说为中。当知亦非共者。此颂显示中间学行离欲界欲得清净故名趣清净。未能尽离上界欲故。亦未永拔欲随眠故。不得名为于诸趣中究竟清净。此离最上。亦能成办故名不共。非离最初。若行趣清净。于诸趣究竟。是行说为尊。当知此必共者。此颂显示最上学行三界诸欲皆远离故。亦能永拔诸随眠故。于诸趣中最为究竟。不离前二能为独成办故。名必共

若有学无学。当知并聪睿者。此初半颂。显示于三学中聪睿者相。有正学故无邪学故

若有学无学。当知并愚夫者。此后半颂。显示于三学中愚夫之相。有邪学故无正学故

若弃舍摄受。亦断除粗重。及现见所知。是受持三学者。此颂显示若能弃舍家亲属等所摄受故。若能断除三摩地障诸粗重故。若能现见四圣谛相所知理故。如其次第三学成满

若有缘无缘。亦细粗显现者。此初半颂。显后二学及最初学。如其次第有缘无缘细粗差别。由受持远离。言发悟所引者。此后半颂。显初中后如其次第引发因缘。谓誓期所引故。身心远离所引故。由他言音内正思惟所引故。初学唯有一。第二学二种。第三学具三。慧者皆超越者。此颂显示初一不共。中不离初。上不离二。超彼一切。当知无学是阿罗汉。不毁坏尸罗。于学誓能顺。轨范无讥论。于五处远离者。此后显示受持戒相。不毁坏尸罗于学者。谓安住净戒。誓能顺者。谓守护别解脱律仪。轨范无讥论者。谓轨则无犯。于五处远离者。谓所行无犯。略有五处。诸苾刍等。非所应行。谓王家。唱令家。酤酒家。倡秽家。旃茶罗及羯耻那家。唱令家者。谓屠羊等。由遍宣告。此屠羊等。成极重罪。多造恶业。杀害羊等故

若无犯出离。无恶作恶作者。显示于诸小罪见大怖畏。如其出离亦无恶作。如其恶作亦无有犯。于彼学寻求。及勤修彼行者。显示受学学处终无有弃舍。命难亦无亏。常住正行中。随毗柰耶转者。此颂四句。如其次第显示常尸罗性。坚尸罗性。恒所作性。恒随转性。修治誓为先。亦修治净命者。此初半颂。显示轨范及命清净。由诸轨范先发誓愿。方乃修行。故名为誓。二边皆远离。亦弃舍邪愿者。此后半颂。显示远离受用欲乐自苦二边。及弃舍生天等愿故尸罗清净

于诸障碍法。终无有耽染。乱心法才生。寻当速远离者。此颂显示于诸根门不守护等障碍清净。所学法中不见功德。无耽染故。于诸不善欲恚寻等扰乱意法。虽暂生已即除遣故学得清净

非太沉太浮。恒善住正念。根本眷属净。而修行梵行者。此颂显示远离微劣恶作故。远离非处恶作故。远离失念故。于究竟时及方便时。修行梵行皆得清净

瑜伽师地论卷第十六瑜伽师地论卷第十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中思所成地第十一之二

应发勤精进。常坚固勇猛。恒修不放逸。五支善安住者。此颂显示由被甲方便。无退精进故。修习五支。不放逸故。令所修学清净殊胜。五支不放逸者。谓去来今先时所作及俱所行

当隐自诸善。亦发露众恶。得诸衣服等。粗妙皆欢喜。少随于世务。粗弊亦随转。受杜多功德。为寂离烦恼者。此二颂中显示远离眷属贪欲多欲不知足因故。及远离多欲不知足障。净学因故。学得清净

当具足威仪。应量而摄受。终无有所为诈现威仪相者。此颂显示具足威仪故。不于他前诡现相故。凡所摄受善知量故。为修梵行资持寿命。有所受故。学得清净

不自说实德。亦不令他说。虽有所方求。而非现异相。从他边乞求。终不强威逼。以法而获得。得已不轻毁者。此二颂中显示远离绮言说故。诡现相故。强威逼故。以所得利转招利故。令所修学清净殊胜

不耽着利养。及所有恭敬。亦不执诸见。增益与损减者。此颂显示不耽着利养恭敬故。不执着五种恶见故。令所修学清净殊胜

不着顺世间。无义文咒术。亦不乐畜积。无义长衣钵者。此颂显示不执着诸恶见因。外道邪论以能障碍取蕴解脱。彼所制造名顺世间。及远离耽着利养恭敬因。长衣钵等因。清净故学得清净

恐增诸烦恼。不染习居家。为净修智慧。当亲近贤圣者。此颂显示远离所治因。亲近能治因故。学得清净

不畜朋友家恐发忧悲乱。能生苦烦恼。才起寻远离者。此颂显示若亲近居家。生忧悲散乱。增长诸烦恼。能为众苦因。由亲近彼。能生众苦。烦恼才生。寻即除遣。如是显示对治之因

不受于信施。恐加害疮疱。于如来正法。尝无有弃舍者。此颂显示不贪着利养恭敬。不坚执诸恶邪见。不虚受用信施。不毁谤正法。亦能远离贪着后世诸欲。及能生起诸恶见因。如是所学清净殊胜

于他愆犯中。无功用安乐。常省自过失。知已速发露者。此颂显示远离作意求觅他人所有过失。于自善品无有散乱常生欢喜。于自过失如实了知。发露悔除离增上慢。由此因缘学得清净

若犯于所犯。当如法出离。所应营事中。能勇励自作者。此颂显示出离所犯。及能远离贪受他人恭奉侍卫。由此因缘学得清净

于佛及弟子。威德与言教。一切皆信受。观大罪不谤者。此颂显示信圆满故于能诽谤见大罪故学得清净

于极甚深法不可思度处。能舍旧师宗。不坚执自见者。此颂显示远离安住自见取故清净殊胜

常乐居远离。及边际卧具。恒修习善法。坚精进勇猛者。此颂显示若身若心皆远离故。习近顺定诸卧具故。远离一切不善寻思。纯修白净诸善法故。非沉掉等诸随烦恼所摧蔽故。能善圆满正加行故。增上心学方便殊胜。无有欲生欲。不憎恶憎恶。离睡眠睡眠。时不居寂静。离恶作恶作。无希虑希虑。一切种恒时。成就正方便者。此二颂中。显示远离贪欲嗔恚。惛沉睡眠。掉举恶作。及疑盖故。于诸善法生起欲故。于诸欲中极憎厌故。为修善品方便加行。有所堪任。及心安静。于时时间习睡眠故。若心沉没。或虑彼生于净妙相。思惟作意。及游行时。不居静故。于先所犯便生忧悔。于所不犯无忧悔故。后后殊胜生希虑故。殷重无间正方便故。增上心学转得清净。引发与觉悟。及和合所结。有相若亲昵。亦多种喜乐。侵逼极亲昵。名虚妄分别。能生于欲贪。智者当远离者。此二颂中。显示八种处妄分别。能生淫欲。所有贪爱。从初方便次第生起。乃至究竟。由远离故。诸所修学清净殊胜。引发分别者。谓能引发于可爱事不正思惟相应之心所有分别。觉悟分别者。谓即于彼可爱事中。觉悟贪缠相应分别。和合所结分别者。谓即于彼可爱事中所有分别。有相分别者。谓即于彼可爱事中。执取种种净妙相状所有分别。亲昵分别者。谓于已得所爱事中。勇励相应所有分别。喜乐分别者。谓即于彼所得事中。种种受用悕慕爱乐种种门转所有分别。侵逼分别者。谓两根会时所有分别。极亲昵分别者。谓不净出时所有分别。诸欲令无饱众多所共有。是非法因缘。能增长贪爱。贤圣所应离。速趣于坏灭。仗托于众缘危逸所依地者。此二颂中显示八种现法后法如其所应诸欲过患。若能观见即是断除欲爱方便

诸欲如枯骨。亦如软肉段。如草炬相似。犹如大火坑。譬如蟒毒蛇。亦如梦所见。如借庄严具。如树端熟果。如是知诸欲都不应耽乐者。此中广引如前所说令无饱等。于诸欲中。八种过患。一切世间共成譬喻。显示诸欲过患深重。又为显示于诸欲中具有如是众多过患。分明可了。何有智者于彼耽乐。又彼诸欲如枯骨故。令无饱满。如段肉故。众多共有。犹如草炬。正起现前极烧恼故。非法因缘。如大火坑生渴爱故。增长贪爱。如蟒毒故。贤圣远离。如梦见故。速趣坏灭。犹如假借庄严具故。仗托众缘。犹如树端烂熟果故。危亡放逸所依之地

当听闻正法。常思惟修习。先观见粗静。次于修一向舍烦恼粗重。于断生欣乐。于诸相观察。得加行究竟。能离欲界欲。及离色界欲。入真谛现观。能离一切欲。证现法涅槃。及余依永尽者。此中显示由了相等七种作意世出世道皆清净故。证得有余及无余依二涅槃果。增上慧学究竟清净。听闻正法常思惟言。显示了相作意。常修习言。显示胜解作意。由起胜解而修习故。先观见粗静言。显示远离作意。于修习一向等言。显示摄乐作意。于诸相观察言。显示观察作意。加行究竟言。显示加行究竟作意。能离欲界欲及离色界欲入真谛现观能离一切欲等言。显示世间出世间加行究竟果作意

已释意趣义圣教伽他。今当建立体义伽他。如颂言

  于身语意诸所有　　一切世间恶莫作
  由念正知离诸欲　　勿亲能引无义苦

今此颂中所言恶者。谓诸恶行。于一切种。一切因缘。一切处。所所有恶行皆不应作。云何于一切种不作恶耶。谓由身语意不造众恶故。云何于一切因缘不作恶耶。谓由贪嗔痴所生诸恶。终不造作故。云何于一切处所不作恶耶。谓依有情事处及非有情事处不造众恶故。云何由念正知远离诸欲。谓断事欲及断烦恼欲故。云何断事欲。谓如有一于如来所证正法毗柰耶中。得清净信。了知居家迫迮犹如牢狱思求出离。广说乃至。由正信心舍离家法。趣入非家。然于欲贪犹未永离。如是名为断除事欲。云何断烦恼欲。谓彼既出家已。为令欲贪无余断故。往趣旷野山林。安居边际卧具。或住阿练若处。乃至或在空闲静室。于诸事欲所起一切烦恼欲摄妄分别贪为对治故。修四念住。或复还出依近聚落村邑而住。善护其身。善守诸根。善住正念而入聚落。或复村邑游行。旋反。去来。进止。恒住正知。为解睡眠及诸劳倦。彼即于是四念住中善安正念为依止故。为欲永断欲贪随眠。修习对治。又即以彼正知而住。为依止故。远离诸盖。身心调畅有所堪能。炽然方便修断寂静。彼由如是念及正知为依止故。便能证得烦恼欲断。远离诸欲。乃至于初静虑具足而住。如是能于受用欲乐行边。劣鄙秽性诸异生法。若断若知。何等名为引无义苦。谓如有一若诸沙门或婆罗门。行自苦行。于现法中以种种苦自逼自切。周遍烧恼。自谓。我今由现法苦所逼恼故。解脱当苦。虽求是事而自煎逼。彼于此事终不能得。然更招集大损恼事。如是名为引无义苦。诸圣弟子能于如是受用自苦行边。能引非圣无义苦法善了知已。远而避之不亲不近。亦不承事。复次今当略辩上所说义。云何略辩。谓诸有情有二种满。一增上生满。二决定胜满。增上生满者。谓往善趣。决定胜满者。谓爱尽离欲寂灭涅槃。于此二满及与障碍能断能证。是名略义。若于一切种。一切因缘。一切处所。不作恶行。彼便能断增上生满所有障碍。亦能证得增上生满。若于受用欲乐行边。及于受用自苦行边。决定远离彼便能断决定胜满所有障碍。亦能证得决定胜满。当知是名此中略义

  应说想众生　　依应说安住
  不了知应说　　而招集生死
  若了知应说　　于说者无虑
  由无有此故　　他不应讥论
  若计等胜劣　　彼遂兴诤论
  于三种无动　　等胜劣皆无
  断名色爱慢　　无著烟寂静
  无恼悕不见　　此彼天人世

此四颂中。初言应说者。谓一切有为法。所以者何。诸有为法皆三种言事之所摄故。今此义中说妙五欲以为应说。又妙五欲诸余沙门婆罗门等。从施主边以言求索故。名应说。又诸君主于妙五欲从仆使等。以言呼召而受用之。由是因缘亦名应说。又诸受欲者。于妙五欲不能自然善知过患。惟除诸佛及佛弟子。为其宣说彼过患已乃能了知。由是因缘亦名应说。诸受欲者。于诸欲中不正思惟而取其相。亦取随好即于彼欲便生爱染。受用耽嗜。乃至坚着。又于诸欲不如实知有众过患。所谓诸欲无常虚伪。空无有实败坏之法。犹如幻事诳惑愚夫。甚少爱味多诸过患。亦不如实了知如是少味多患。诸欲出离。所谓于彼欲贪调伏。乃至超越。是其出离。彼既如是不见过患。不知出离而受诸欲。由是因缘。便于欲界生为根本所有诸行。深起乐着。又复造作生为根本所有业已。受欲界生。生已死灭。生已殒殁。如是故言应说想众生。依应说安住。不了知应说而招集生死。若遇善士得闻正法。如理作意。则于诸欲如实了知过患出离。所谓诸欲无常虚伪。广说乃至。欲贪超越。彼于如来所证正法毗奈耶中。得清净信。便于诸欲深见过患转复增胜。遂能舍离若少若多财宝。库藏。眷属游从。以正信心舍离家法。趣于非家。所谓一切生老病死皆悉永灭。如是出家。无所愿求。修行梵行。谓我由此持戒精进修梵行故。当得生天或异天处。彼无如是邪祈愿故。于己不见不恐不虑他所讥论。谓他不应如是讥论。怨尤呵责告言。贤首汝今何为成就盛年舍现妙欲。不随亲戚之所愿乐。而更悕求待时诸欲誓修梵行耶。如是故言若了知应说于说者无虑。由无有此故。他不应讥论

此即成就清净尸罗及清净见。何以故。由见颠倒发起于慢慢所持故与余沙门婆罗门等共兴诤论。由此因缘。说如是见为诤根本。若有沙门或婆罗门。依等胜劣诤根本见心现高举。由此因缘。遂与余沙门婆罗门等递相诤论。依止我胜我等我劣三种慢类。立己为胜或等或劣。若圣弟子。非我我所我慢所动。乃至亦非我当非有想非无想所动。了知诸行皆众缘生。于诸行中惟见法性。尚不以己校量于他为胜等劣。况起见慢而兴诤论。彼圣弟子。虽我他所显扬自宗摧伏他论。然于诸法惟为法性缘于慈悲。谓当云何。若有于我所说妙义一句领解。如是如是正修行者。令彼长夜获得大义利益安乐。亦令如来正法久住。不依见慢及为利养恭敬因缘而兴诤论。如是不为悕求现法诸妙欲故誓修梵行。彼由如是修梵行故。远离邪愿及诸邪见。弃舍贪求利养恭敬。于一切种皆得清净。晖光炽然无不普烛。诸天世人惟当赞美。不应讥论。又能超度生老病死。如是故言若计胜等劣彼遂兴诤论。于三种无动等胜劣皆无

言名色者。谓五取蕴。若有于彼观见为苦。当谛现观。于五取蕴尽见苦时。于五取蕴所有贪爱由意乐故。皆说为断。非随眠故。彼若即如己所得道转更修习。于其我慢无余断灭成阿罗汉。诸漏永尽。由已证得阿罗汉果。心善解脱。便于自身自身众具。缠及随眠。皆悉永断。离爱离憍离诸放逸。彼由如是离爱离憍离放逸故。名烟寂静。无有烧恼亦无悕望。云何名为烟寂静耶。烟名为爱。何以故。如世间烟是火前相。能损眼根便为扰乱令不安住。爱亦如是是贪嗔痴火之前相。能损慧眼乱心相续。谓能引发无义寻思。彼于此爱已断已知。乃至令其于当来世成不生法。名烟寂静。彼既如是烟静离着。虽复追求命缘众具非不追求。然能解脱贪爱追求。所求无染。云何无恼。谓彼如是现追求时。若他自施或劝余施。施时殷重非不殷重。精而非粗。多而非少。速而非缓。然不爱味。于所得物无染受用。不生耽吝乃至坚着。如是受用命资具时。不为贪恼之所烧恼。若彼施主自不能施。或障余施。设有所施。现不殷重不现殷重。乃至迟缓而不急速。然不嫌恨。由此因缘不生恚恼。又于受用所得物时。不戚不念。无损害心及嗔恚心。如是不为嗔恼所恼。又于所得若精若粗。于受用时。深见过患。善知出离。安住正念。远离愚痴。如是不为痴恼所恼。云何无悕。悕名悕望。系心有在。彼不擎鼻内怀贪愿往趣居家。谓刹帝利大宗叶家。或婆罗门长者居士大宗叶家我当从彼获得上妙应所啖食。乃至。财宝。衣服。肴膳。诸坐卧具。病缘医药。供身什物。如是追求及与受用。于此财物都无悕望。又彼恒常安住死想。谓过夜分入昼分中。复过昼分还入夜分。于其中间我有无量应死因缘。如经广说。所谓发风。乃至。非人之所恐怖。由此因缘所为追求所为受用所有财物。于此寿命亦无悕望。如是无著烟寂静。无烧恼无悕望故。于此天人帝释自在世主天等。所有因中都不可见。于彼天人诸因果中亦不可见。又于此四洲天人世间及彼余处都不可见。又于此世界天人世间及彼余处都不可见。如是故言断名色爱慢。无著烟寂静无恼悕不见此彼天人世

复次初颂显示待时诸欲。于欲邪行。及邪行果。第二颂中。显示舍欲应正道理。净修梵行仍被讥论不应道理。及待时欲。如第二颂第三亦尔。第四颂中。世尊显示现所证法永离炽燃。乃至智者内自所证。又初颂中宣说诸欲是应说相显待时欲。由彼诸欲非才须时即便称遂。要以言说为先。然后追求受用。又显于彼由想安住不了知故起于邪行及招生死邪行果报。第二颂中。显于诸欲能了知故。离邪愿故。修梵行故。离邪见故。离见根本我慢种故。远离耽着利养恭敬故弃舍诸欲应正道理。由此因缘。他所讥论不应道理。又显诸欲是待时性。所以者何。若于先世不作福者。今虽用功。于所乐欲不能果遂。或惟今世造作福者。即于此时其所乐欲亦不谐偶。由此因缘后方成办。所以诸欲名曰待时。第四颂中。显示见断烦恼断故。即于现在证初沙门及沙门果。又修所断烦恼断故。即于现在证后沙门及沙门果。断贪爱故。断我慢故。如是显示现所证法。又离着故。烟寂静故。显示永离炽燃及至智者自内所证。彼得如是内所证法。云何令他当得了知。由无烧恼无所悕望。相所表故。此中前三颂。显示世尊为诸天说。苾刍不能显扬如来圣教大义。而我独能。说是语时彼既领悟。于苾刍所生陵蔑心。及于自身心生憍慢皆得除灭。第四颂中。广显如来圣教大义

  欲贪所摧蔽　　我心遍烧然
  惟大仙哀愍　　为说令寂静
  由汝想颠倒　　令心遍烧燃
  是故常远离　　引贪净妙相
  汝当修不净　　常定于一境
  为贪火速灭　　数数应浇灌
  观非妙诸行　　为苦为无我
  亦系念于身　　多修习厌离
  修习于无相　　坏慢及随眠
  由于慢现观　　当证苦边际

云何想颠倒。谓于不净境舍不净相。不正思惟。取净妙相及取随好。云何远离引贪净相。谓如有一见少盛色应可爱乐诸母邑已。便摄诸根而不随念。云何常定一境修习不净。谓如有一先以巧便取于贤善三摩地相。所谓青瘀乃至白骨。或骨琐相。即以此相于现所得可爱境界系念思惟。如前所取后亦如是。又于内身或自或他。观察种种不净充满。谓此身中有发有爪。乃至便利种种不净。云何观察非妙诸行以之为苦。谓如有一作是思惟。见少盛色应可爱乐诸母邑已。所生贪爱受用悕望。即是集谛为众苦因。由此故生。生已老死愁叹忧苦种种扰恼从此而生。云何观察非妙诸行以为无我。谓如有一作是思惟。于我身形女身形中。都无有我及有情等。谁能受用谁所受用。唯是诸行。唯是诸法。从众缘生。云何系念于身多修厌离。谓如有一性是猛盛欲贪种类。由是猛盛欲贪类故。虽摄诸根。然被贪欲损坏其心。虽复作意思惟不净苦及无我。亦为欲贪损坏其心。由此因缘。彼依不净或苦无我。作意思惟。权时厌毁违逆不顺。于身念住系念在前亲近修习。若多修习。彼由多住如是行故。便能断此猛盛欲贪。若摄诸根不为欲贪损坏其心。若复作意思惟不净苦及无我。亦不贪欲损坏其心。彼由修习如是行故。诸欲贪缠但现行断。非随眠断。又此欲贪缠及随眠。略于二种补特伽罗相续可得。一于异生相续可得。二于有学相续可得。虽有一分有学身中亦不可得。然于下贪由永断故。已得安隐。上贪未断。不得安隐。无学身中中界妙界所有贪欲尚不可得。何况劣界。以无学者下上贪断。于一切分已得安隐。了知是已未离欲贪一分学者。于后无学心生愿乐。见般涅槃寂静功德。不复思惟一切相故。恒正思惟无相界故。于无相定勤修学故。又即于此多修习故。永断三界修断我慢。由此断故。说名无学离三界欲。上下贪断已得安隐。一切苦因皆舍离故。证得一切众苦边际。如是故。言修习于无相。坏慢及随眠。由于慢现观当证苦边际复次今当略辨上所说义。谓显贪欲由是而生由是寂静及彼寂静。当知是名此中略义。云何贪欲由是而生。谓五因故。一由净妙想。二由欣乐乐。三由有情想。四由猛盛贪。五由随眠有余未尽。云何贪欲生已由是寂静。谓五因故。一由作意思惟不净。二由作意思惟于苦。三由作意思惟无我。四由系念多修厌离。五由随眠无余永灭。云何寂静。谓此寂静略有二种。一者现行寂静。二者永断随眠当来不起。由前四种寂静因缘。成初寂静。由第五因第二成就

  云何苾刍多所住　　越五暴流当度六
  云何定者能度广　　欲爱而未得腰舟
  身轻安心善解脱　　无作系念不倾动
  了法修习无寻定　　愤爱惛沈过解脱
  如是苾刍多所住　　越五暴流当度六
  如是定者能度广　　欲爱而未得腰舟

此因天女所问伽他。暴流有六。谓眼暴流。能见诸色。乃至意暴流。能了诸法。佛圣弟子。有学见迹。于随顺喜眼所识色。不住于爱。于随顺忧眼所识色。不住于恚。于随顺舍眼所识色。数数思择安住于舍。彼设已生。或欲贪缠。或嗔恚缠。或愚痴缠三身为缘。所谓喜身忧身舍身而不坚着。乃至变吐由是因缘。于属三身诸烦恼缠。得不现行轻安而住。如是名为得身轻安。而未能得心善解脱。由彼随眠未永断故。彼于后时又能永断属彼随眠。即于属彼诸烦恼中。远离随缚。如是乃名即于三身贪嗔痴所心善解脱。如于眼所识色。乃至于身所识触当知亦尔。如是已断五下分结。越五暴流。谓越眼暴流能见诸色。乃至越身暴流能觉诸触。如是越度五暴流已。余有第六意暴流在。为当越度复修无作无动系念。云何无作。谓于涅槃心生愿乐。不为我慢之所倾动。无所思惟亦无造作。又不为彼计我我所当来是有。乃至我当非想非非想等之所倾动。无所思惟亦无造作。云何无动。谓不为彼上分诸结缠绕其心。无动无变亦无改转。又于随一寂静诸定。不生爱味恋慕坚着。云何系念。谓为断彼上分诸结。于其内身住循身观。如是乃至广说念住。彼由如是修无作故。断诸生爱。修无动故。断诸定爱。此离现行。说名为断。修系念故。为令一切上分诸结无余永断。修习对治。如是修习无作系念不倾动故。能令一切上分诸结无余永断。是名越度第六暴流。谓意暴流能了诸法。复有差别。云何无动。言无动者。是慈善根无嗔性故。由此因缘诸圣弟子。于萨迦耶断除邪愿。修奢摩他毗钵舍那。由彼慈故。修奢摩他。由念住故。修毗钵舍那。如是正修行者。于能随顺断上分结三心修习。速得圆满。谓于上身无耽染心。于下有情无愤恚心。不放逸者。于上下境无染污心。余如前说。如是名为越五暴流当度第六。云何了法。谓于苦法能了能观。于集灭道法能了能观。云何修习于无寻定。谓能了知如是法已。又复安住居家诸欲依持断灭及弃出中。或于阿练若处。或于树下空闲。于随顺喜眼所识色所有喜身。于随顺忧眼所识色所有忧身。于随顺舍眼所识色所有舍身。于此所缘无欲寻缠。心多安住。乃至亦无所生家世相应寻缠。心多安住。设起欲寻乃至家世相应寻等。即能如实了知出离。不为欲寻之所障碍。乃至不为家世相应寻所障碍。而能静虑审虑谛虑。由此方便。由此道修能断喜身染爱过失。能断忧身愤恚过失。能断舍身惛沈过失。诸缠断故。身得轻安。随眠断故。于欲界系三身染污心善解脱。彼于尔时名已越度广大欲爱。谓于诸色乃至诸触。遍流行爱。若和合爱。若增长爱。若不离爱。若不合爱。若退减爱。若别离爱。或于欲界复受生爱。复有差别。云何修习于无寻定。谓已得无寻无伺静虑。余如前说

复次今当略辨上所说义。谓彼天女略问世尊三种要义。一者下分结断。二者上分结断方便。三者即彼下分结断方便及如彼善断。如是问已。尔时世尊随应而答。谓由身轻安心善解脱。答彼所问下分结断非断方便。由无作系念不倾动。答彼所问上分结断方便非断。而于彼断天女类前亦即领解。惟余下分结断方便及如彼善断。尔时世尊先以修无寻定。广说差别。答断方便。谓若能断如断所断。此中了法说名能断。修无寻定说名如断。所断愤过谓嗔恚品。所断爱过谓贪欲品。所断惛沈过谓愚痴品。如是名为能如所断。如是广答断方便已。唯有所余如善断在。复由第二修无寻定差别因缘。答其善断。言善断者。谓毕竟断。远分断一切杂染断。由了知法故。释毕竟断。由修无寻定故。释远分断。由贪嗔痴缠及随眠一切断故。释一切杂染断。当知是名此中略义。又彼天女依诸有学未得胜意。已离欲贪未离上贪。而兴请问。意名腰舟。如经说惭轴意腰舟。于此腰舟犹未得者。说彼名为未得腰舟。此中何等名为腰舟。谓于诸结善解脱心

  常有怖世间　　众生恒所厌
  于未生众苦　　或复已生中
  若有少无怖　　今请为我说
  天我观解脱　　不离智精进
  不离摄诸根　　不离一切舍
  我观极久远　　梵志般涅槃
  已过诸恐怖　　超世间贪着

今此颂中。始从欲界乃至有顶诸萨迦耶。皆名世间。此中义者。意在欲界有乐有苦有情世间。若诸有情十资身具之所摄养无所匮乏。身康无病。年未衰老名为有乐有情世间。与此相违。当知有苦有情世间世间众生少分有乐。多分有苦。诸有有乐有情世间。常怀恐怖。勿我财宝王所侵夺。广说乃至。勿由此缘遭诸苦难。勿或风热于内发动。乃至或人或非人等侵损我耶。如是惧虑未来财宝变坏之苦及身坏苦。心常怖畏。诸有有苦有情世间。现为众苦逼切身心。有苦有忧有愁有箭。有诸扰恼恒不安住。如是故言常有怖世间众生恒所厌于未生众苦或复已生中。由是因缘彼天现见诸有有乐有情世间乐非决定。请问如来有决定乐无怖畏处。尔时世尊即为彼天方便示现。惟圣教中有如是处。非诸外道。谓如有一住正法外所有沙门或婆罗门。于现法中及当来世诸欲过患。不如实知。由不知故。悕求未来诸欲差别舍现法欲求后法欲。精勤受学所有禁戒。虽复安住如是禁戒。然无智慧。不护根门。不守正念。无常委念。乃至广说。彼不调摄诸根门故。于他所惠少小利养及与恭敬。尚生爱味。随起恋着何况广大。如是精勤受禁戒者。远离智慧密护根门。于现法欲尚不能断。况后法欲。又即于彼有一沙门若婆罗门。于欲过患。粗了知故。能越现法后法诸欲。而复欣求上离欲地。于非解脱起解脱想。断弃诸欲便臻远离。彼由精勤数多修习正思惟故。离欲欲界乃至离欲无所有处。由此因缘。舍下自体爱上自体。由爱彼故。于当来世尚不解脱下地自体。何况上地。如是弃舍财宝自体迷失道者。虽复安住勇猛精勤。而不能得一向快乐无怖畏处。何以故。彼外道师尚于是处不见不识。况能为彼诸弟子等当广开示。如是外道师及弟子所制论中。决定无有众苦边际。与此相违。善说正法毗柰耶中。当知具足一切义利。乃至定有众苦边际。依此密意佛为彼天说如是言。天我观解脱不离智精进。不离摄诸根。不离一切舍

复次今当略辨上所说义。谓为显示恶说邪法毗柰耶中师及弟子皆有衰损。善说正法毗柰耶中。皆具吉祥。于一切苦能证边际。当知是名此中略义。尔时彼天闻佛世尊答所请问。欢喜踊跃即以四种无上功德赞叹如来。谓佛世尊难出现故。出已能成利他行故。亦能建立自利德故。于自他利离染心故。我观极久远梵志般涅槃者。此赞世尊难出现德。已过诸怨者。此赞世尊利他行德。已过诸怖者。此赞世尊建自利德。超世间贪欲者。此赞世尊于自他利离染心德。如是四种功德差别当知。复有三种差别谓难出现故。难可见故。建立自利利他行故。见者则能成就大义成大义者。离染心故。遍一切生亦无众罪。如是众德诸佛世尊最为殊胜故。以此相赞叹如来

瑜伽师地论卷第十七瑜伽师地论卷第十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中思所成地第十一之三

  谁奖胜类生　　及开出离道
  于何住何学　　不惧后世死
  戒慧自薰修　　具定念正直
  断诸愁炽燃　　正念心解脱
  能奖胜类生　　及开出离道
  住此于此学　　不惧后世死

今此颂中言胜类者。即是四种胜上姓类。一婆罗门。二刹帝利。三吠舍。四戍达罗。以法以正以制以导教胜类生故。名为奖。此中显示唯佛世尊能以法以正以制以导教胜类生。由此因缘。世尊自显唯我独为真奖导者。故为彼天作如是说。具戒具慧以自薰修。又唯世尊能为四种胜上类生。宣说出离一切众苦圣八支道。此中世尊亦自显示是真说者。云何具戒。谓佛世尊昔菩萨时。弃上妙欲舍离居家。受持身语所有律仪。云何具慧。谓即于彼受持身语律仪。住者。起如是相。内正思惟。深心筹量。审谛观察。今此世间多遭艰苦。所谓若生若老。如经广说。云何自薰修。谓于往昔无量余生。经三大劫阿僧企耶。于六波罗蜜多修习善修习。由彼因缘。今无师自然心趣出离。又于众缘所生诸行。以微妙智能随悟入。云何具定。谓能乃至离无所有处欲。证得非想非非想处。云何具念。谓依如是所得胜定。为断见断诸烦恼故。修四念住。即以如是所修念住为其导首。乃至修习三十七种菩提分法。云何正直。谓彼生起逆流正直圣八支道。能断见断所有烦恼。于逆流道得预随流。云何永断一切愁忧炽燃。谓从谛现观俱得成不还者。又能永断五下分结嗔恚似顺愁忧。贪欲似顺炽燃。于如是等皆已永断。云何正念。谓为永断上分诸结。复更修习四种念住。乃至修习三十七种菩提分法。云何心解脱。谓已永断上分结。故于二种障心善解脱。谓烦恼障及所知障。其心如是善解脱故。得成如来应正等觉。广说如经。由此故能奖胜类生。开出离道。诸有四种胜类随一。于此圣教爱乐正行。为欲证得圣八支道于三学中勤修学者。彼定能证圣八支道及涅槃果由证彼故。不惧当来生老病死

复次今当略办上所说义。谓略显示唯佛世尊能令四类速得清净。彼若于此能正修行。不唐捐故。又复示现如来圣教。善说正法及毗柰耶。又复示现佛是天人无上大师。当知是名此中略义

  云何擅名誉　　云何具珍财
  云何获美称　　云何摄亲友
  持戒擅名誉　　布施具珍财
  谛实获美称　　惠舍摄亲友

云何持戒能擅名誉。谓如有一或男或女。具足尸罗及贤善法。乃至命终断除杀罪远离杀生。如经广说。乃至十方所有沙门婆罗门等常所称叹。由是因缘。为诸国王群臣长者乃至城邑聚落人民。恭敬供养。云何布施能具珍财。谓如有一昔余生中作及增长施福业事。由此因缘。今生巨富大财宝家。乃至众多府库盈积。云何谛实能获美称。谓如有一不以假伪斗秤函等谄诳陵蔑妄言等事而致财宝。但以如法作业伎能。依法不暴而致财宝。彼既如是众咸唱言。贤哉儒士。乃能如法作业伎能引致财宝。云何惠舍能摄亲友。谓如有一现前多有种种家产。远离悭垢不吝资具。以正安乐而自欢娱乃至友朋。亲戚。耆长。彼诸人等便相佐助。引致财宝守护滋息

复次今当略辨上所说义。谓略显示恭敬利养二种因缘。持戒擅名誉者。显恭敬因缘。所余诸句显利养因缘。谓因力故。士用力故。助伴力故。当知是名此中略义

  齐何泉止息　　于何迳不通
  世间诸苦乐　　何处无余灭
  若于是处所　　眼耳及与鼻
  舌身意名色　　永灭尽无余
  齐此泉止息　　于斯迳不通
  世间诸苦乐　　是处无余灭

云何为泉。谓六触处。何以故。譬如泉池能生诸水。水所系属堪任触用。又能存养男女大小。下及禽兽。乃至一切未尽枯竭。六内触处亦复如是。一切愚夫六境界触之所触用。又能存养。乃至是中诸贪爱水未尽枯竭。云何为迳。迳有二种。一烦恼迳。二者业迳。此中迳者。意明因义。云何苦乐。谓或于现法六种触处为缘所生。或安受受所摄。或不安受受所摄。或于后法烦恼摄持妙行恶行为缘所生。或安受受所摄。或不安受受所摄。于何处所如是六处及名色等无余灭尽。谓无余依涅槃界中。若诸异生泉迳苦乐一切无缺亦未有舍。若诸有学缺而未舍若诸无学迳及当来所有苦乐。亦缺亦舍不复现行。泉及现法所有苦乐。亦缺亦舍。有余依故犹复现行。是故无余涅槃界中。说彼一切无余尽灭

复次今当略辨上所说义。谓略显示于现法中因及苦乐。于后法中因及苦乐。于无余依涅槃界中。皆悉永灭。当知是名此中略义

  谁能越暴流　　谁能超大海
  谁能舍众苦　　谁能得清净
  正信越暴流　　无逸超大海
  精进舍众苦　　智慧得清净

今此颂中。云何正信能越暴流。谓如有一为欲了知诸欲过患。听佛所说若弟子说所有正法。闻是法已获得正信便生欲乐。为断事欲及烦恼欲。遂能弃舍居家事欲。正信出家往趣非家。既出家已为欲断除烦恼诸欲。远离而住。彼由炽燃勤精进故。乃至修习正思惟故。断烦恼诸欲。得离欲定地如是正信为依为导。便能越度诸欲暴流。云何无逸能超大海。谓于彼定终不爱味。乃至亦无坚着安住。唯除为证诸漏尽智专注其心。由此定心清净鲜白正直调柔。于四圣谛能入现观。乃至证得诸漏永尽。如是由不放逸为依为导。能断色无色系二有暴流及断一切无明与见二种暴流。是故名为超渡大海。云何精进能舍众苦。谓如有一有学见迹作是思惟。我应当证三界离欲。诸结永尽。便臻远离于彼勇猛精勤而住。不多安止贪欲缠心。又能如实了知现在诸欲贪缠所有出离。于贪欲盖净修其心。遂能断灭诸贪欲缠及贪欲缠为缘所生心诸忧苦。如贪欲盖乃至疑盖当知亦尔。如是精进为依为导能舍众苦。云何智慧能得清净。谓彼除灭能染污心乃至能障究竟涅槃五种盖已。即依未至安住未至。如先所得苦集灭道诸无漏智。于诸苦中思惟真苦。乃至于道思惟真道。便得无余三界离欲诸漏永尽。如是由先所得智慧为依为导。能证清净

复次今当略辨上所说义。谓薄伽梵于此颂中。略显异生先已离欲。后于圣谛现观清净。及显有学于诸圣谛现观为先。离欲清净。当知是名此中略义

  谁超越暴流　　昼夜无惛昧
  于无攀无住　　甚深无减劣
  圆满众尸罗　　具慧善安定
  内思惟系念　　能度极难度
  诸欲想离染　　亦超色界结
  彼无攀无住　　甚深无减劣

今此颂中。云何暴流。所谓四流。欲流。有流。见流无明流。云何无攀无住。所谓诸爱永尽离欲。寂灭涅槃。及灭尽定。所以者何。所言攀者。诸烦恼缠。所言住者。烦恼随眠。于彼处所二种俱无是故说言无攀无住。此谓涅槃无攀无住。又想名攀受名为住若于是处二种俱无。即说彼处无攀无住。如是显示灭想受定无攀无住。今此义中意取灭定。云何圆满众尸罗。谓善安住身语律仪。修治净命。云何具慧。谓于苦圣谛如实了知。乃至于道圣谛亦复如是。云何善安定。谓远离诸欲。乃至具足安住第四静虑。或第一有三摩钵底。云何内思惟。谓于二十二处数数观察。言我今者容饰改常。去俗形好。广说如经。云何系念。谓于二十二处数观察时。依沙门想恒作恒转而现在前。由此因缘为断余结修四念住。云何能度极难度。谓一切结无余断故。能度最极难度有顶。彼非一切愚夫异生可能度故。云何于诸欲想而得离染。谓于下分诸结已断已知。云何超于色界诸结。谓于色系上分诸结已断已知。云何于无攀无住甚深中无有减劣。谓于无色界。或已离欲。或未离欲。已得非想非非想处。堪能有力入灭尽定。学与无学俱容有此故。不定言超无色结

复次今当略辨上所说义。谓薄伽梵于此颂中。略显能得最究竟道。及显能证第一住道。当知是名此中略义

  贪恚何因缘　　由何故欣戚
  毛竖意寻思　　如孩依乳母
  润所生自生　　如诺瞿陀树
  别缚于诸欲　　犹摩迦处林
  是贪恚因缘　　由斯故欣戚
  毛竖意寻思　　如孩依乳母
  知彼彼因缘　　生已寻除灭
  超昔未超海　　暴流无后有

今此颂中。云何贪恚。谓如有一处在居家。于可意境可意有情。共相会遇而生贪着。于不可意境及有情。共相会遇而生嗔恚。云何欣戚。谓如有一于佛所证法毗奈耶。率尔得生须臾正信不善观察前后得失忽然自励便弃家法往趣非家。既出家已与凡道俗共相杂住。遂于去来货财亲友追念思慕忧戚缠心。或复有一非由正信。亦非自励往趣非家。然或为王之所驱迫。乃至或为不活邪畏之所恐怖舍离居家。既出家已于其正信诸婆罗门居士等边。时时多获利养恭敬。深生爱味。窃作念言。吾此一方善哉奇要。无劳稼穑。不事商贾。少致艰辛足堪活命。彼缘如是利养恭敬。便自欣悦。安然而住。云何毛竖及意寻思。谓如有一非由自励。不为活命舍离居家。然由正信捐弃家法。往趣非家。既出家已不与道俗共相杂住。便臻远离寂静闲居。彼闲居时。或于尘雾或昏夜分。见大云气闻震雷音。或逢雹雨师子虎豹。或遭凶猾窃劫抄虏。或遇非人来相娆逼。便生惊怖身毛为竖。或至昼分。于彼去来妙欲亲友。发依耽嗜所有寻思。谓欲寻思如经广说。乃至家世相应寻思。如是已说贪恚等事。云何润生及与自生。犹如世间诺瞿陀树。润名爱水。由此为缘能生诸取。彼贪恚等一切皆用此为共缘。自者。即是贪恚为先寻思为后。各各差别种子界性。云何贪恚乃至寻思别缚诸欲。犹如世间摩鲁迦条缠绕林树。谓略说有六种别欲。或有身手力所引致现在事欲。谓居家者所有诸欲于此境界用此为缘发生贪恚。或有从他所得种种现在事欲。谓为活命而出家者所有诸欲。于此境界用此为缘发生欣悦。或有过去未来事欲。谓忽自励而出家者所有诸欲。于此境界用此为缘发生忧戚。或有所余诸烦恼欲。略有二种。谓于欲界自体及资身命。或有未断妄分别贪。谓由正信而出家者。寂静闲居于尘夜分所遭众事。于此境界用此为缘便生惊怖身毛为竖。或有未断妄分别贪。所谓即此补特伽罗至昼日分。于外色声香味触境。用此为缘发生意地所有寻思。又有沙门若婆罗门。如实了知如前所说贪与恚等及彼因缘。又能了知众缘生法无常性已。随其所生不起贪着。即便弃舍变吐断灭。离色无色二界贪故。度有暴流。离欲贪故。度欲暴流。如是暴流昔所未度。今既度已终无有退。复次今当略办上所说义。谓薄伽梵于此颂中略显三位。一在家位。二出家位。三远离位。又略显示共与不共。因缘所生。若爱若恚。于诸欲中二种别缚。及断方便并断胜利。当知是名此中略义。又于此中若贪若欣若依耽嗜所有寻思。当知爱品。若恚若戚。及与惊怖。当知恚品

  应作婆罗门　　谓断无纵逸
  求弃舍诸欲　　不悕望此有
  若更有所作　　非真婆罗门
  当知婆罗门　　于所作已办
  诸身分劬劳　　未极底未度
  已得度住陆　　无勤到彼岸
  天汝今当知　　此喻真梵志
  谓永尽诸漏　　得常委静虑
  彼永断一切　　愁忧及炽燃
  恒住于正念　　亦常心解脱

今此颂中。显示彼天依于世俗诸婆罗门为世尊说。谓有种姓诸婆罗门。自号我为真实梵志。计梵世间为最究竟。悕求梵世安住于色常勤精进。心无懈倦。恒乐远离寂静闲居。减省睡眠修习静定。为断事欲及烦恼欲。由彼种姓诸婆罗门计梵世间以为究竟。悕望梵世不求欲有。又显如来依第一义诸婆罗门而报彼天。若婆罗门作所作已数复应作。更有胜上所应作事。当知此非真婆罗门。若婆罗门证婆罗门所应作事。超登一切萨迦耶岸。安住陆地。当知此是真婆罗门。由此显示学与无学皆婆罗门。学有二种。谓于欲界或未离欲或已离欲。未离欲者。未得源底未到彼岸。于二种法犹未具足。一未得内心胜奢摩他。二虽已得增上慧法毗钵舍那未善清净。由阙内心奢摩他故。乘如所得圣道浮囊。为证内心奢摩他故。运动如足勇猛精进。又复为令增上慧法毗钵舍那善清净故。运动如手勇猛精进。彼于如是勤精进时。离欲界欲如得源底。证阿罗汉如到彼岸。已离欲者。证得内心胜奢摩他。亦得善净毗钵舍那。唯为进断上分诸结。发勤精进非诸身分。若已越度成阿罗汉。所作已办离勤功用。名住陆地已到彼岸。此则显示诸婆罗门依第一义略有三种。二是有学。一是无学。若已究竟到于彼岸诸婆罗门。名永尽漏。若未离欲一切身分勤精进者。名得常委。若已离欲得源底者。名得静虑。得静虑者。永断一切下分结故。已断贪欲及嗔恚品所有一切愁忧炽燃。永尽漏者。永断修断诸烦恼故。已善修习四种念住。恒住正念及心解脱。彼非作已数数更作。亦无增胜所应作事。是故说彼名第一义真婆罗门

苾刍苾刍已度暴流耶。告言。如是天。无攀无住。已度暴流耶。告言。如是天。苾刍汝今。犹如何等。无攀无住。已度暴流

  如如我劬劳　　如是如是劣
  如如我劣已　　如是如是住
  如如我住已　　如是如是漂
  天我如如舍劬劳　　如是如是无减劣
  如是广说鲜白品　　此中只焰颂应知

今此颂中。无攀无住者。谓涅槃灭定。如前已说。世尊依昔示现修习菩萨行时所有最极难行苦行非方便摄勇猛精进。又依示现坐菩提座非方便摄勇猛精进。断遍知故。说如是言。天汝当知我昔如如虚设劬劳。如是如是我便减劣。如如减劣如是如是我便止住如如止住。如是如是又被漂溺。与此相违。应知白品。此中显示修苦行时非方便摄勇猛精进。名曰劬劳。行邪方便善法退失。名为减劣。既知退失诸善法已息邪方便。说名止住。舍诸苦行更求余师。遂于嗢达洛迦。阿逻茶等邪所执处。随顺观察故名漂溺。复于后时坐菩提座。弃舍一切非方便摄勇猛精进。所有善法遂得增长。如如善法既增长已。如是如是于诸善法不生知足。不遑止住。于所修断展转寻求胜上微妙。既由如是不知足故。遂不更求余外道师。无师自然修三十七菩提分法。证得无上正等菩提。名大觉者。此中四义舍劬劳等四句经文如其次第配释应知云何复依涅槃无依无住以显差别。谓不能度诸烦恼缠随眠暴流。略由四因。何等为四。谓最初有依耽嗜寻。依耽嗜寻为依止故。便有懈怠。又由懈怠为依止故。住异生分。住异生分为依止故。顺生死流贪爱势力。令于五趣生死河中顺流漂溺。与此相违四种因故。能度暴流。如应当知。云何复依想受灭定以显差别。谓如有一先已证得想受灭定复住放逸。多住想受。而不多住诸想受灭。由此因缘。退失灭定。由退失故。还复止住下地生因。住彼因故心便定趣彼所得果。与此相违。应知白品四句差别

  独臻阿练若　　静虑弃珍财
  为别有方求　　为穷窬封邑
  何不与人交　　而绝无徒侣
  得义心寂静　　摧妙色魔军
  我独处思惟　　受最胜安乐
  故不与人交　　而绝无徒侣

此因天女所问伽他。言得义者。略有二种。一者证得沙门果义。二者证得圣神通义。由初得义。超越一切生死大苦。第二得义证八解脱寂静思惟现法乐住。又初得义降伏可爱妙色魔军第二得义独处思惟受胜安乐。此中意辩圣神通义所以者何。谓如有一为欲成办圣神通义为令解脱清净圆满依十遍处方便修行。由此因缘。令遍处定清净圆满。亦令解脱转得清净圆满鲜白。亦能成办圣神通义。彼既了知此成办已。便自通达我义已办。沙门果义亦得成就。是真沙门。于求财者深修厌毁。于诸城邑交游等处。了知其初。了知过患。了知出离。亦能了知趣出离行。生彼因缘说名为初。无常众苦变坏法性。是名过患。欲贪调伏断除超越。名为出离。圣八支道名趣出离行。若有于彼不见其初。乃至不见趣出离行。由是因缘。于具珍财有情等处。不能厌毁。城邑交游周旋不绝。而谓彼为心得寂静。于出居家证八解脱静虑定者内心寂静。反生诽谤。由是彼于内心寂静。则不堪能善见善知善鉴善达。若第一义内心寂静与此相违。则能善见乃至善达

复次今当略辨上所说义。谓薄伽梵于此略示诸受欲者乐杂住者。非第一义内心寂静若有证得八解脱定。离诸爱味。名第一义内心寂静。当知是名此中略义

  诸行无常　　有生灭法　　由生灭故
  彼寂为乐

今此颂中。蕴及取蕴皆名诸行。此中义者意在取蕴。是五取蕴略有三种。谓去来今。诸行无常者。谓彼诸行本无而生生已寻灭。若过去生。过去所得诸自体中所有诸蕴。皆过去故。已谢灭故。生已没故。体是无常。若未来生。未来所得诸自体中所有诸蕴。皆未生故。非已起故未灭没故。可生起故。是有生法。若现在生。现在所得诸自体中所有暂住支持存活。有情诸蕴皆死法故可为殒灭之所灭故。是有灭法。若彼诸蕴。在于未来所得自体是有生法。于中都无所得自体。是常是恒。乃至即当如是正住。唯除才生生已寻灭。若诸有情于现法中永尽未来诸蕴因者。一切未来自体诸蕴皆不生故。说名彼寂。又复此寂由二因缘说之为乐。一者一切苦因灭故。一切粗重永止息故。于现法中安乐住。故说之为乐。二者当来生老病等所有众苦永解脱故。说之为乐

复次今当略辨上所说义。谓薄伽梵此中略说正见依处及正见果。复有差别。谓略显示遍知依处及彼断灭。又略显示所遍知法及与遍知。又略显示三世诸行所有杂染及彼寂故所有清净。又略显示诸缘起法及缘起灭。又略显示苦谛灭谛。又略显示空与无愿二解脱门所依处所。及显无相一解脱门所依处所。又略显示圣谛现观相违二法断所依处。言二法者。一随顺戏论。二怖无戏论。又略显示不共外道二对治法。何等为二。一者所知无颠倒性。二者所证无颠倒性

  无逸不死迹　　放逸为死迹
  无逸者不死　　纵逸者常死

今此颂中。云何无放逸是不死迹耶。谓如有一依四所依立四种护。谓命护。身护。心杂染护。正方便护。是名不放逸。此不放逸为依为持。涅槃资粮未圆满者。令速圆满。已圆满者。令于现法得般涅槃。云何放逸为死迹耶。谓如有一居家白衣于诸欲境耽着受用造不善业。或有出家现四无护。谓命无护乃至正方便无护。如是放逸通于二品。谓在家品及出家品。即此放逸为依为持。乐生本行造生本业。因此故生。生已寿终。生已夭没。云何无纵逸者不死。纵逸者常死耶。谓死有五种。一者调善死。二者不调善死。三者过去死。四者现在死。五者未来死。若善修习此无纵逸补特伽罗。于现在世由调善死而正死时。由过去死已死。于过去世亦由不调善死。于现在世不由不调善死而死。于未来世不由调善死。不由不调善死而死。故名不死。若有纵逸补特伽罗。于现在世由不调善死而正死时。于过去世亦由不调善死已死。于现在世即由不调善死而死。于未来世亦由不调善死当死。故名常死

复次今当略办上所说义。谓薄伽梵此中略示无纵逸者道谛灭谛。有纵逸者集谛苦谛。又略显示处非处性自业作性。前半显示处非处性。后半显示自业作性。又前半显示师于弟子作所应作。后半显示诸弟子等自所作义

  众生寻思所钻摇　　猛利贪欲随观妙
  倍增染爱而流转　　便能自为坚固缚

今此颂中云何寻思之所钻摇。谓如有一于先所得先所受用诸欲境界。不正作意。发生不善依于耽嗜诸恶寻思。云何猛利贪欲。谓如有一于昔余生修习贪欲。亦多修习。由是因缘。令此生中于先所得先所受用诸欲境界虽正作意。而被贪欲散坏其心。云何随观净妙。谓如有一不善护身。不摄诸根。不住正念。游行聚落。见甚少年可爱美色诸母邑已。便不如理取净妙相。由此因缘。身心烧恼。云何倍增染爱。谓由五种相貌。当知染爱增长。何等为五。谓如有一虽于下劣诸欲境界。尚生猛利诸贪欲缠。耽着不舍。何况上妙。又以非法多分凶暴积集珍财。不以正法。亦常摄受增上众具。又于轻贱无所用物尚不欲舍。何况贵重。虽为追求少劣财物。尚行众多身语意恶。何况多胜。又于受持少小妙行。其心尚无趣向爱乐。何况广大。又于涅槃尚不乐闻。何况欲得。云何坚固缚。谓由三种相知坚固缚。一坚牢故。二苦所触故。三长时随逐故。于现法中由恶行根贪嗔痴故。知缚坚牢。于当来世由生那落迦傍生鬼趣。知苦所触及长时随逐

复次今当略辨上所说义。谓略显示依二失坏因有二种失坏。何等名为二失坏因。谓不正思惟力及因力。云何名为二种失坏。谓方求失坏及受用失坏。云何不正思惟力。谓随念先所受用境界因缘所生不正思惟。或邪分别现前境界因缘所生不正思惟。或邪取相不正思惟。或即于彼若住若行不正思惟。云何因力。谓于可爱境界宿习欲贪云何方求失坏。谓如有一成就二种失坏因故。以非正法或以凶暴追求积集所有邪财。云何受用失坏。谓如有一于先所得顺乐顺苦顺非苦乐诸境界中。或有于一生染生着。广说乃至。不知出离而受用之。或有于一发生憎恚憎恚所蔽。或有于一发生愚痴愚痴所蔽。彼由如是贪染所蔽。乃至愚痴之所蔽故。行身语意种种恶行。为贪嗔痴三坚固缚之所缠缚。亦为那落迦傍生鬼等诸缚所缚。又有差别。谓爱结所系。补特伽罗略有七种杂染。当知皆是贪爱所作。谓随念杂染。不自在杂染。境界杂染。热恼杂染。善趣相应杂染。恶趣相应杂染。诸见杂染。云何随念杂染。谓如有一不正随念先所受用可爱境界。悕望追求令心散坏。云何不自在杂染。谓如有一宿世串习贪欲法故。今世贪欲为性猛利。虽复如理于可爱境随念作意。而有悕望追求贪欲散坏其心。彼由贪欲极猛利故。心不自在。云何境界杂染。谓如有一游城邑等。现前会遇容色端严可爱境界。由彼境界极端严故。随美妙相心识缠绵。因此发生悕望追求种种贪爱。云何热恼杂染。谓如有一由是三种能长贪爱诸杂染故。令已贪爱展转增盛。追恋过去已受用境。悕求未来当受用境。耽着现在正受用境。乃令身心周遍热恼。云何善趣相应杂染。谓即由彼贪爱集谛增上力故。行身语意种种妙行。得生善趣或天或人。彼于乐受耽着不舍。醉闷而住专行放逸。云何恶趣相应杂染。谓即由彼贪爱集谛增上力故。行身语意种种恶行。身坏命终堕诸恶趣。生那落迦等。于彼生已便为种种极重忧苦恶心愤心之所扰恼。云何诸见杂染。谓即由彼贪爱集谛增上力故。会遇恶友说颠倒法为令杂染得解脱故。彼虽悕求杂染解脱。由遇如是倒说法故。不证解脱。于六十二诸见趣中。随令一种邪见增长。于诸缘起法愚痴增上故。彼由如是见结所系。于五趣等生死大海不得解脱

  住法具尸罗　　有惭言谛实
  能保爱自身　　亦令他所爱

今此颂中。云何住法。谓于如来所证善说正法毗奈耶中。净信出家乐修梵行。云何具尸罗。谓如是出家如是爱乐故。于戒无缺。乃至无杂相续而作相续而转。于诸学处能受能学。云何有惭谓惭于可惭。惭于能生恶不善法。谓能顺恶戒穴戒因缘。即不正相。不正寻思。若诸烦恼。及随烦恼。云何言谛实。谓发露诸恶不藏诸恶。若有所犯即于智者同梵行边。如实自举。如法对治复次今当略辨上所说义。谓薄伽梵于此颂中略显四因所摄尸罗清净。谓能正受故。受已不穴故。远离穴因故。虽由无知放逸穴已。即便如法而对治故。当知是名此中略义

  若见他恶业　　能审谛思惟
  自身终不为　　由彼业能缚

今此颂中。云何见他恶业审谛思惟谓如有一或善男子或善女人。为性聪慧成就如理谛观法忍。见他现行恶行因故。便遭种种挫辱楚挞。又为王人执至王所。广说如经。乃至断命。见已便作如是思惟。观观是人于现法中造作如是恶不善业。即于现法还受如是辛楚果报。乃至止止如是恶不善业。终不应为终不应作。终不应行终不应犯。即彼又见屠羊鸡猪广说一切不律仪众。不由如是作业伎能活命方术。而乘象马车乘辇舆。又不因此能致广大财宝库藏令不散失。然为世间之所诃毁。凡在佣俗尚不以身暂相触受。而远避之。况余贤哲。见已便作如是思惟。余如前说。即彼又见他人巨富饶大财宝。然由懒惰多住纵逸。经过日夜淹积岁月。所有珍财僮仆基业及诸善法渐渐衰退。见已便作如是思惟。余如前说。即彼又见种种有情身相差别。或有生盲生聋生哑。或瞎或跛或癣或癞。或复短寿或恶形色。或多疾病或贫贱家。或少支属或弊恶慧。或扇宅迦或半宅迦或丑形类。余即不尔见已便作如是思惟。观观是人先作种种恶不善业。今受如是苦恶果报。乃至止止如是恶不善业。余如前说。即彼又见他人黠慧无有懒惰具足翘勇。所谓能作营农商贾行船等业。及能正作言论事业。彼虽具足如是翘勇。所作事业数渐衰损终无成办。见已便作如是思惟。余如前说。即彼又见二人出家趣于非家。同修梵行。一于衣服饮食等利有所匮乏。一则不尔。见已便作如是思惟。余如前说。即彼又见或有国王或是王等大地封疆咸皆克伏坚着不舍。但为一身一具骸骨。唯为现在少小安乐。身语意门现行无量广大恶行。损坏多生多身安乐。当受多生多身大苦。见已便作如是思惟。观观是王或是王等。甚为愚弊。唯知保爱一生一身。不知保爱多生多身。唯爱现在少时小乐。不爱当来多时大乐。亦非不爱多生重苦。乃至止止如是恶不善业。终不应为终不应作。终不应行终不应犯。复有或善男子或善女人。为性聪慧获得天眼。用此天眼见诸有情死时生时。如经广说。乃至生在大那落迦中。见已便作如是思惟。观观是人于现法中造作如是恶不善业。令受后法辛楚果报。乃至止止如是恶不善业。余如前说。如是或善男子或善女人。见他所作诸恶业已。由四种行谛善思惟谛善观察。何等为四。一者观察或因违越或邪活命或放逸懈怠。于现法中造作种种恶不善业。即现法受非爱果报。二者观察或有有情依身差别。或有所作而不果遂。或有所求而不果遂。皆由先造恶不善业故。现法中各受如是非爱果报。三者观察或有国王或与王等。因现法中行诸恶业。比知当来定受种种非爱果报。四者观察诸有情类死时生时。因现法中造作种种恶不善业。后法中受非爱果报。彼由如是如实知故。终不自作。云何业缚。谓乐诸业故。由业重故。于业果报不自在故。乐诸业者。谓如有一串习恶故。爱乐诸恶。由此因缘。于诸善法心不能入。是初业缚。由业重者。谓如有一于无间业。或有具造或不具造。由此因缘。虽有欣乐于佛所证善说正法毗柰耶中。暂时出家。尚不能得。况当能获沙门果证。如是名为第二业缚。于业果报不自在者。谓如有一由身语意恶行因缘。生诸恶趣。生彼处已不得自在。不能自任长夜受苦。或生边地。于彼绝无四贤善众。所谓苾刍广说乃至邬波斯迦。如是名为第三业缚

复次今当略辨上所说义。谓薄伽梵于此略示依诸有情业业果报。如理思惟。及显如理思惟为先法随法行。当知是名此中略义

瑜伽师地论卷第十八瑜伽师地论卷第十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中思所成地第十一之四

  贤圣常说最善语　　爱非不爱语第二
  谛非不谛语第三　　法非非法语第四

今此颂中。言善语者。所谓善说善言善论。当知善说有三种相。所谓悦意无染唯善。由第一语令他庆悦。由第二语令自尸罗终无穿缺。由第三语能令他人出不善处。安住善处。因此引摄利益安乐。或有爱语非谛非法。谓如有一以美妙言。称赞他人非真实德。或有谛语非爱非法。谓如有一以染污心发粗恶言。诃责他人真实过恶。或有法语亦爱亦谛。谓如有一善知称赞及与诃责。知可称赞可诃责已。然不称赞亦不诃责。唯善方便为说正法。能令彼人出不善处安住善处

复次今当略辨上所说义。谓薄伽梵此中略示所有善语若标若释。当知是名此中略义

  信惭戒施法　　善人所称赞
  是名趣天道　　能往天世间

此颂所明。谓如有一于佛所证法毗奈耶。获得正信。耻在居家。受持净戒趣得衣服饮食卧具。便生喜足。减除器物。俭约资缘。凡所获得如法利养终无私隐。必与智人同梵行者而共受用。所有正法初中后善称扬梵行。所谓契经乃至论议。皆能受持研寻究达。传授他人广为开阐。彼既成就是诸善法。当知必获三种胜利。一者诸佛诸佛弟子真实善人之所称赞。二者若彼尸罗财施之所摄引。福德资粮。法施摄引智慧资粮善圆满者。便得趣入证解脱处清净诸天众同分中。三者若彼二种资粮犹未圆满。便能令彼速得圆满。身坏已后定生善趣。多往天上乐世界中。复有差别。谓如有一于佛所证法毗奈耶。获得正信。信恶尸罗当堕恶趣信悭贪者得贫穷报。如是信已。于现法中恶戒悭贪深生羞耻。以羞耻故。弃恶尸罗受清净戒。弃舍悭贪以无垢心安处居家。广说乃至。善行布施。由此因缘。于现法中圣贤所赞。身坏已后乃至当生善趣天上乐世界中

复次今当略辨上所说义。谓薄伽梵此中略示在家出家二种正行及正行果所有胜利。当知是名此中略义

  多闻能知法　　多闻能远恶
  多闻舍无义　　多闻得涅槃

此颂所明。谓如有一于依先时正所应作施论戒论生天之论无倒教法。恭敬听闻。闻已遂能了知其义。谓现法中种种恶行及当恶趣苦无义因。诸恶行所应速远离。及往善趣舍生恶趣苦无义因。彼由了知如是法义。法随法行能远苦因。能引乐因。由此因缘。得乐舍苦。若于增上四圣谛等相应教法。恭敬听闻。闻已遂能了知其义。谓一切有生死大苦寂静涅槃。彼由了知如是法义。若根已熟资粮已满便能获得如是义。识心清净故。才闻法已于诸圣谛未现观者。能入现观。已现观者便得漏尽。若根未熟资粮未满。即由如是远离诸恶。依增上戒起增上心。依增上心发增上慧。由此能舍一切苦本烦恼无义。证得涅槃。复次今当略辨上所说义。谓薄伽梵此中略示先闻正法如理思惟。先如理思法随法行。法随法行为先因故得胜利果。当知是名此中略义

  智者如空无染污　　不动犹如天帝幢
  如泛清凉盈满池　　不乐淤泥生死海

今此颂中。辩阿罗汉苾刍心善解脱超诸戏论犹如虚空。何以故。譬如虚空离诸戏论。净与不净皆不能染。诸阿罗汉亦复如是。一切世法若顺若违皆不能染。所谓利衰乃至苦乐。又诸有学已离欲贪。向阿罗汉。于四念住善住其心。修无相心三摩地时。如天帝幢。于其一切动发憍举戏论营为生愿俱行所有贪爱。不能倾动。又诸有学已离欲贪得不还果。于上解脱心生欲乐。譬如游泛清冷泉池。于爱味定上分诸结热淤泥中终不欣乐。由于此中不欣乐故。亦不欣乐生死大海。复有差别。谓阿罗汉所有饮食言说游行处无相住。有余依苦之所随逐。如其次第三处应知。复有差别。谓慧解脱诸阿罗汉。有学身证。及俱解脱诸阿罗汉。如其次第三处应知。复次今当略辨上所说义。谓薄伽梵此中略示离三界欲于佛圣旨犹有余依。离欲界贪胜进道摄及不还果。复有差别。谓略显示解脱胜利等持胜利智慧胜利。复有差别。谓略显示增上心慧学所得果。及显增上心慧二学

  若以色量我　　以音声寻我
  欲贪所执持　　彼不能知我
  若于内了知　　于外不能见
  由内果观察　　彼音声所引
  若于内无知　　于外而能见
  由外果观察　　亦音声所引
  若于内无知　　于外不能见
  彼普障愚夫　　亦音声所引
  若于内了知　　于外亦能见
  英雄出离慧　　非音声所引

此颂所明。谓如有一体是异生。未断虚妄分别欲贪。观见世尊具三十二大丈夫相遂便测量。此薄伽梵定是如来应正等觉。其所说法决定微妙。其弟子众所行必善。彼于后时近不善人闻不正法。随逐他论及他音声。信顺于他他所引摄。他所引故于佛法僧还生毁谤。如是皆由不如实知如来法身故。致如此。复有异生。由内静虑果天眼通。远见世尊便作是解。此薄伽梵定是如来应正等觉。余如前说。复有由外欲界系业果报肉眼见已测量。当知彼亦随逐他论及他音声。信顺于他他所引摄。复有异生于尔所见都无所有。彼普被障。长时为他音声所引。若诸贤圣除断调伏。超越欲贪得圣慧眼。彼由如是圣慧眼故。于内证解如来法身。虽于外见如来色身。或见制多或图画等而能了知。非第一义应正等觉。彼由如是于内正知于外正观。不随他论及他音声。不信顺他非他所引。于佛法僧决定信受。如是皆由如实了知如来法身故。致如此

复次今当略辨上所说义。谓薄伽梵。此中略示若唯世俗见如来者则不决定。若以胜义见如来者是则决定。当知是名此中略义

  第六增上王　　染时染自取
  于无染不染　　染者名愚夫

今此颂中。第六增上王者。谓心意识。若有已渡五暴流未渡第六意暴流。尔时其心随逐诸定所有爱味故名染时。复有补特伽罗。于长夜染取为己有。于可爱法执藏不舍。是故说彼为染自取。贪名为染。因贪所生当来世苦亦名为染。若染自取于所染心不随功用。摄受遮止修意对治作意故。如是彼心于现法中无有染污。于无染心此染自取。当来世中因彼诸苦亦无有染。若有于彼随作功用。而不摄受亦不遮止。不修意对治作意。故依此苦因长夜受苦。于此苦因不能远离故名愚夫复次今当略辨上所说义。谓薄伽梵此中略示远离苦因所有胜利。及显苦因能感自苦是愚夫性。当知是名此中略义

  有城骨为墉　　筋肉而涂饰
  其中有贪恚　　慢覆所任持

今此颂中。所言城者。谓心意识。此城唯以骨充甎石。筋代蝇纴肉当涂漫。为形骸墉周匝围绕。此城中有违害善说法毗柰耶所有善法四种恶法之所任持。二是在家诸受欲者。谓贪与嗔。二是恶说法毗柰耶中而出家者。谓慢与覆。由着诸欲悕求诸欲。与鄙秽行不相违背。于善说法及毗柰耶尚不信受。况当修善。恃恶说法而生憍慢。不能自然趣佛世尊或弟子所。设佛世尊或佛弟子由悲愍故。自往其所。然彼由覆随烦恼缠染污其心。尚不如实发露己过。况能信解修诸善法。如是当知于彼善说法毗柰耶相应善法二种心城。皆不能入。何况复能取为己有复次今当略辨上所说义。谓薄伽梵。此中略示在家出家总由四种杂染因缘失坏善说法毗柰耶。当知是名此中略义

  如龟藏支于自[穀-禾+卵]　　苾刍善摄意寻思
  无所依止不恼他　　证般涅槃无所谤

此颂所明。谓如有一依初静虑舍三恶寻。所谓欲寻。恚寻。害寻。又能弃舍初静虑地诸善寻思。安住无寻无伺定中。如龟藏支于其自[穀-禾+卵]。略摄寻思亦复如是。无寻无伺定者。应知此上乃至有顶。彼于此定正安住时不生爱味。出已成就可爱乐法。调顺柔和易可共住。不恼有智同梵行者。又为智人同梵行者欣乐共住。又复成就无违诤法。彼由如是正方便故。于诸圣谛能入现观及得漏尽。彼于诸法不由他信。获得善净胜智见故。如实了知法真是法。毗柰耶真是毗柰耶。由如是知故。终不依止诸见颠倒于法谤法。及于非法亦谤非法。终不显示非法为法。法为非法。非毗柰耶为毗柰耶。或毗柰耶为非毗柰耶

复次今当略辨上所说义。谓薄伽梵此中略示善说法者四种扰乱断对治道。何等名为四种扰乱。一染不染寻思扰乱。二于胜定爱味扰乱。三互相违诤讼扰乱。四于正道诽谤扰乱。当知是名此中略义

  等不等而生　　牟尼舍有行
  内乐定差别　　如俱舍卵生

此颂所明。谓佛示现住最后有菩萨位时。先所获得三十有二大丈夫相。八十随好圆满庄严妙色身生。于后证得阿耨多罗三藐三菩提时。其色身生。与前正等。其名身生由胜无漏不相似故。与前不等。又佛示现内寂静乐及妙门乐为依止故。得定自在。如定心力舍诸寿行及诸有行。彼舍边际妙色身生。与前正等其名身生。与前不等故有差别。如因其[穀-禾+卵]卵生鸡等依卵而生。即此生已渐渐增长。种类相似破[穀-禾+卵]而出。如是如来色身名身差别道理当知亦尔。此中差别。谓佛世尊若不弃舍诸寿行者。应满寿量方般涅槃。定力所持舍寿行故。不满寿量而般涅槃

复次今当略辨上所说义。谓薄伽梵此中略示舍诸寿行色身名身二种差别。及显弃舍所依因缘。当知是名此中略义

  无淤泥等欲　　无魑魅等嗔
  无罗网等痴　　无江河等爱

此颂所明。谓有四种。能为世俗不自在法。世间现见能令有情不自在转。一者陷溺淤泥。二者鬼魅所著。三者入于罗网。四者堕驶流河随流漂溺。复有四种。能为真实不自在法。能令有情不自在转当知亦尔何等为四。谓如有一生长欲界。陷溺不净腥臊生臭诸欲淤泥。不能自在引发守护增长善法。又如有一弃舍诸欲。于善说法毗奈耶中而得出家。心怀忿怒性多恶言。由忿所持不得自在。不数学处。动生违越。于诸智者同梵行所。屡以粗言击刺诃摈侵恼毁辱。又如有一弃舍诸欲。于恶说法毗奈耶中而得出家。入诸恶魔大痴见网。彼既入已流转生死不得自在。又如有一生长上分诸离欲地。于诸爱结未能永断。亦未遍知不得自在。还生下界顺流而住。难可出离

复次今当略辨上所说义。谓薄伽梵此中略示诸界诸品愚夫缠缚

复有差别。谓如有一陷欲淤泥不能自在。于善说法毗奈耶中清净出家。又如有一为性忿怒。忿怒所蔽愤恚缠心。尚于自身或害或损。何况于他。又如有一成就痴品诸恶邪见。谓无父母毁谤父母。于父母所反悕敬养。况自能为。又如有一广集诸欲。贪爱所漂不得自在。尚不欲自食。况能惠于他。如是四法。当知能障诸聪慧者。四应知法。谓善说法毗奈耶中清净出家。远离恚害。敬事父母。乐行慧施

  虚空无鸟迹　　外道无沙门
  愚夫乐戏论　　如来则无有

此颂所明。谓有众生悕乐胜欲欲求所摄。又有众生悕乐胜身有求所摄。又有众生悕乐沙门及婆罗门所有解脱梵行求摄。此中欲求有求摄者。谓我因少分布施少分持戒。当得往生善趣天上乐世界中。以妙五欲而自赏纳欢娱游戏。彼既修习如是愿已。得最胜欲及最胜身。譬如众鸟翱翔虚空。遍虚空中无安足处。如是众生于其所得无常诸欲及身分中都无安住。当知亦尔。若乐沙门及婆罗门所有解脱梵行求摄。复有二种。或依善说法。或依恶说法。依恶说法诸外道辈并无沙门。依善说法邪梵行求所摄受者亦无沙门。正梵行求所摄受者得有沙门。又此一切三门所摄。或欲求门。或有求门。或梵行求门。如是皆名乐着戏论。当知如来弃舍一切所有悕求故无戏论。即以此义类知如来诸弟子众正梵行求所摄受者亦无戏论

复次今当略辨上所说义。谓薄伽梵此中略示离善说法及毗奈耶勤精进者皆空无益。当知是名此中略义

  住戏论皆无　　踰墙堑离爱
  牟尼游世间　　天人不能识

此颂所明。谓阿罗汉苾刍永离贪爱。由四种相。于恶魔怨一切愚夫所系属主。解脱自在随意游行空闲聚落。有诸愚夫遇见如是真阿罗汉于最究竟自在游行。不如实知。便于二处妄生轻毁。云何此善男子。弃舍自属养命珍财。乃求属他资生众具。何故弃舍生天方便。苦勤精进求有断灭。是诸愚夫见生天上有胜功德。见处居家有多财产故。于牟尼妄生轻忽。彼所事天于此牟尼广大功德。尚不能了。况能事者而能识知。云何离爱诸阿罗汉。由四种相。于恶魔怨一切愚夫所系属主。解脱自在。谓诸愚夫由四识住。为魔怨主之所驱役。令生死中往还五趣非阿罗汉。又诸愚夫如由重过。为魔怨王之所驱役谓或增益或复损减诸恶见故。发起种种执刀杖等恶不善法。堕诸戏论生诸恶趣。令造种种诸恶业缘。非阿罗汉。又诸愚夫如由中过为魔怨主之所驱役。令处欲爱系缚垣墙。不能出离欲界生苦。非阿罗汉。又诸愚夫如由轻过。为魔怨主之所驱役。令生色界及无色界。无明深堑周匝围绕闭在生死众苦牢狱。于生等苦不得出离非阿罗汉

复次今当略辨上所说义。谓薄伽梵此中略示一切愚夫羞不应羞。应羞不羞。于不应怖而生怖见。于应怖中生无怖见。当知是名此中略义

  若有熏除诸寻思　　于内无余离分别
  超过碍着诸色想　　四轭蠲除不往生

此颂所明。谓如有一已入有学位。未离欲界欲。依初静虑。熏除欲界诸恶寻思。依第二静虑内等清净心一趣性。初静虑地所有分别。无余永离无复分别。依第三静虑。超过第二静虑地诸喜碍着。依第四静虑。超过第三静虑地诸乐碍着。依无色定。超过一切所有色想。如是渐次因依诸定乃至有顶。若定若生蠲除四轭。何等为四。一蠲除染污寻思轭。二蠲除不染污寻思轭。三蠲除喜乐系缚轭。四蠲除一切色想轭。由此因缘。于诸下地不复往生。当知异生虽到有顶若定若生犹为四轭所系缚故。于诸下地还复往生

复次今当略辨上所说义。谓薄伽梵此中略示到有边际有学异生二种差别。当知是名此中略义

  惠施令福增　　防非灭怨害
  修善舍诸恶　　惑尽得涅槃

此颂所明。谓如有一于佛所证法毗奈耶。获得正信。虽处居家。而心远离悭垢缠缚。受持七种依福业事。由此因缘。若行若住广说如经。乃至生长如是福德。若有复能于善说法毗奈耶中。清净出家。既出家已具足忍力。为护尸罗。虽遭他骂侵恼诃责。或以身手瓦砾刀杖欧击伤害。恐坏尸罗当为障碍。心无恶念不出恶言。唯缘彼境与慈俱心。于一切方遍满而住。由此因缘。于现法中自他相续所有怨害并皆止息。当生无恼乐世界中。无多怨敌。为世欣仰。众所乐见。如是善修正方便已。依增上戒起增上心。依增上心发增上慧。当于圣谛入现观时。则能永舍趣恶趣业及诸恶趣。又修如先所得道故。渐次永除所有诸结。于有余依涅槃界中而般涅槃。如是后时于无余依涅槃界中复般涅槃

复次今当略辨上所说义。谓薄伽梵此中略示得净信者四种正行。一感财富行。二感善趣行。三离恶趣苦清净修行。四离一切苦清净修行。当知是名此中略义

  诸恶者莫作　　诸善者奉行
  自调伏其心　　是诸佛圣教

此颂所明。谓如有一于佛所证法毗奈耶。获得正信。于一切种一切因缘一切处所所有恶行。皆能断灭。于善说法毗奈耶中。能善受学尸罗律仪。彼由三相奉行众善。谓善住尸罗。守别解脱清净律仪。乃至受学所有学处。依增上戒学发增上心学。依增上心学发增上慧学。彼由此故于所知境如实知见。如是具足诸善法已。复由三相调伏自心。谓如实知故能起厌患。由厌患故能得离染。由离染故能得解脱

复次今当略辨上所说义。谓薄伽梵此中略示三学学果。显自圣教不与他共。当知是名此中略义

  难调伏轻躁　　沦坠于诸欲
  善调伏其心　　心调引安乐

此颂所明。谓宣说心若意若识长夜爱乐愦闹杂处。于愦闹处难得远离难可调伏。虽强安处无间修习。诸善法中而不一向能住离贪离嗔离痴。亦不一向能住策举无掉寂静。然复疾疾还生有贪有嗔有痴下劣掉举及不寂静。虽强安处内寂止中。长夜爱乐色声香味触故。于五欲境驰趣沦没。诸圣弟子于如是等乐着杂染能生苦心。终不纵其令自在转。亦不随顺数数思择成办远离。恒修善法心一境性。彼由如是正定心故能如实知。如实知故能起厌患。由厌患故能得离染。由离染故能得解脱。彼既如是善调伏心尽苦因故。于现法中得安乐住。当来众苦亦得永尽复次今当略辨上所说义。谓薄伽梵此中略示能不随顺长夜流转左道之心。及不随顺所得胜利。当知是名此中略义

  于心相善知　　能餐远离味
  静虑常委念　　受无染喜乐

此颂所明。谓如有一有学见迹。能善了知止举舍相。由此因缘得四功德。谓心住一缘远离粗重。能善受用身心安乐。是初功德。又净定心尽所修故。如所修故。能正审虑诸法道理。获得内法毗钵舍那。是第二功德。彼由如是清净止观为依止故。于所修习菩提分法。勇猛无间能常修习。能委修习无懈无惮。是第三功德。彼由如是无懈惮心。获得第一正念正知。心善解脱。又能受用解脱喜乐及无染乐。于现法中得安乐住。是第四功德。复次今当略辨上所说义。谓薄伽梵此中略示于相善巧四种功德。谓奢摩他所作。毗钵舍那所作。无懈惮所作。到究竟所作。当知是名此中略义

  无工巧活轻自己　　乐胜诸根尽解脱
  无家无所无悕望　　断欲独行真苾刍

此颂所明。谓成就五支永断五支。当知得名真实苾刍。何等为五。谓不依止矫设方便邪活命法。亦不恃赖有势之家。亦不修治名称族望。亦不诈受诸佛所说圣弟子说。犹如依止工巧处所非法悕求衣服饮食。是名初支。又复减省器物众具善弃珍财。衣仅蔽身食才充腹知足欢喜。凡所游行必持衣钵。是第二支。又悕慕沙门爱乐沙门。悕慕学处爱乐学处命难因缘尚不违越所学禁戒。何况少小利养因缘。是第三支。又彼如是正修方便。净命喜足爱乐学处。于诸圣谛未现观者。能入现观得清净见。或时夫念暂尔发生。恶不善寻引起贪欲嗔恚愚痴迟缓忘念。速复除遣。是第四支。又彼修习如先得道。于诸结缚一切随眠随烦恼缠。心得解脱。是第五支。如是名为成就五支。云何复名永断五支。谓阿罗汉苾刍。于五处所不复能犯。所谓不能舍所学处而复退还。又复不能有所贮积执为己有而受用之。亦不受用诸欲境界。又复不能为财为命知而妄语。又复不能弃舍诸欲行不与取。亦不复能永离贪欲独住独行。而更习近非梵行法两两交会。或计自作而招苦乐。或计他作或自他作。或非自作亦非他作。不由因生而招苦乐。如是名为五支永断

  心远行独行　　无身寐于窟
  能调伏难伏　　我说婆罗门

今此颂中所言心者。亦名为意亦名为识。此于过去一切愚夫无量差别自体展转。及因展转虽无作者。而流生死前际叵知。故名远行。此于现在一一而转。第二伴心所远离故。一切种心不顿转故。名为独行。又此现在随其自体初起现前。或由贪性或由嗔性或由痴性。或由一一所余烦恼随烦恼性。即彼自体不毕竟转如五色根。或同或异或劣或胜。随其自体初起现前。即此自体毕竟而转。心不如是。何以故。心经彼彼日夜刹那腊缚等位。非一众多种种品类。异生时生异灭时灭。由心自性染污之体不成实故。名为无身。此未来世居四识住而有随眠。可于后生有往来义。名寐于窟。若有总慧由此四相。能于过现未来世心。如实了知修厌离灭及心解脱。彼能超度诸萨迦耶。到于彼岸安住陆地。名婆罗门

复次今当略辨上所说义。谓薄伽梵此中略示心于过去长时染污无作者性。于现在世性是刹那自性清净。于未来世由有放逸不放逸故染污清净。当知是名此中略义

  谁能覆世间　　谁能令不显
  谁复能涂染　　谁为大怖畏
  无明覆世间　　放逸令不显
  戏论能涂染　　苦为大怖畏
  诸流处处漏　　是漏谁能止
  当说谁防护　　众流谁所偃
  世间诸流漏　　是漏念能止
  我说能防护　　由慧故能偃
  念慧与名色　　今问是一切
  何当永灭尽　　唯愿为我说
  念慧与名色　　我说是一切
  若诸识永灭　　于斯永灭尽
  云何念所行　　诸识当永灭
  今请垂方便　　为释令无疑
  于内外诸受　　都不生欣乐
  如是念所行　　诸识当永灭
  若诸善说法　　及有学异类
  彼常委能趣　　请大仙为说
  不耽着诸欲　　其心无浊染
  于诸法巧念　　是苾刍能趣

此是波罗延中。因阿氏多所请问颂。言世间者。略有三种。一欲世间。二色世间。三无色世间。今此义中意辨出家在家二种世间。出家世间复有二种。一恶说法。二善说法。恶说法者。无明所覆。善说法者。由有明故应可显了。由放逸故令不显了。若诸在家异类白衣。为诸戏论之所涂染。当知戏论略有三种。谓三种言事名为戏论。于四种言说有所宣谈亦名戏论。能发语言所有寻伺亦名戏论。若于过去未来现在三种言事。依四言说发起异类分别思惟。或违或顺是名涂染。若前戏论若后涂染。诸在家者多分可得。是故说彼为诸戏论之所涂染。此中恶说法者无明所覆。善说法者放逸不显。诸在家者戏论涂染。彼于现法苦因转时。于此苦因不能如实知是苦因。于此苦因爱乐而住。由此因缘。生当来苦。即说此苦名大怖畏。又恶说法者由无明门。从六处流漏泄众苦。诸在家者由戏论门。从六处流漏泄众苦。善说法者由放逸门。从六处流漏泄众苦。如是无明放逸戏论诸门流漏。由闻他音内正作意。于诸行中了知过患。此相应念逆流而转。故能遮止。如是方便名伏对治。若出世间正见所摄诸无漏慧。于三种流皆能偃塞。如是方便名断对治。于此流漏若伏若永。二种对治皆能断故。俱名防护。又恶说法者及在家者。一向堕于染污品摄。若善说法毗奈耶中二种可得。诸纵逸者堕杂染品非显了摄。不纵逸者堕清净品显了所摄。又若已显了若应显了。当知二种皆无放逸诸阿罗汉。斯已显了于不放逸无更须作不放逸事。于四念住若念若慧已善修故。已善证得清净识故唯有决定。于无余依涅槃界中善清净识当永灭故。若念若慧亦随永灭。余依所摄先业所引一切名色亦随灭尽。乃至彼法未永灭来。于六恒住常善安住。于离欲地所有内受。及于诸欲相应外受。不生欣乐。如是名为诸阿罗汉正念现行乃至寿尽识方永灭。若诸有学斯应显了。于不放逸应更须作不放逸事。彼复二种。于不放逸不放逸事。谓常所作。委悉所作。有学异类若诸有学极七反有。或复家家一来果等。及于现法堪般涅槃。于下分结及上分结心无染污。为断彼故修习对治。又于诸欲不耽着故。诸下分结不能染污。心无浊故诸上分结不能染污。又于一切有苦法中。如实知集乃至出离。于四念住善住其心。修习如先所得圣道。能趣究竟。如是修习对治道故。彼于一切不放逸中诸所应作不放逸事。皆得究竟

复次今当略辨上所说义。谓薄伽梵此中略示诸在家者及于外法而出家者决定杂染。及显于善说法毗奈耶中而出家者。若行放逸堕染污品。若不放逸堕清净品。当知是名此中略义

  于诸欲悕求　　或所期果遂
  得已心定喜　　至死而保爱
  诸乐欲众生　　若退失诸欲
  其色便变坏　　如毒箭所中
  若远离诸欲　　犹如毒蛇首
  彼于爱世间　　正念能超度
  田事与金银　　牛马珠环钏
  女仆增诸欲　　是人所耽乐
  攀缘沉下劣　　变坏生诸漏
  从此集众苦　　如船破水溢
  若永绝诸欲　　如断多罗顶
  弃舍诸愁忧　　犹莲华水滴

此是义品中依诸欲颂。谓如有一悕求未来所有诸欲。为获得故发勤方便。得已现前耽着受用。如是悕求及正受用所得诸欲。由此因缘生喜生乐。如是总名诸欲爱味。又彼悕求及正受用所有诸欲。于其所得所受用事若退失时。随彼诸欲恋着爱味。爱箭入心如中毒箭。受大忧苦或致殒殁。如是名为诸欲过患。又复毒蛇譬诸欲境。毒蛇首者。譬诸欲中所有爱味。若诸愚夫爱味诸欲贪着受用。如蛇所螫。若有多闻诸圣弟子。远离诸欲所有爱味。如毒蛇首。终不爱染而受用之。广说乃至。不生耽着。彼于诸色所有贪爱。乃至于触所有贪爱。皆能调伏断灭超度。如是名为诸欲出离。又诸欲自性略有二种。一者事欲。二者烦恼欲。事欲有二。一者谷彼所依处。谓田事。二者财彼所依处。谓金银等事。何以故。诸求谷者必求田事。诸求财者必求金银等事。求金银等复有二种。一者事王。二者商贾。求谷求田方便须牛。求财事王方便须马。求财商贾所有方便。若金银等共相应者。谓诸宝珠。金银异类不相应者。谓环钏等。此举最胜。若买卖言说事务当知亦尔。积集如是财谷事已。受用戏乐所有助伴。谓诸女色。若未积集招集守护。及息利中所有助伴。谓诸僮仆。如是财谷积集广大。于此处所耽乐不舍。如是一切皆名事欲。烦恼欲者。谓于事欲随逐爱味。依耽着识发生种种妄分别贪。又于事欲由烦恼欲。令心沉没成下劣性。若彼事欲变坏散失便生诸漏。愁叹忧悲种种苦恼缠绕其心。彼由如是于现法中诸漏蔽伏无有对治。犹如船破水渐盈溢。招集当来生老病等种种苦恼。若于诸欲已得出离。便能永绝随欲爱味发起贪着诸染污识。犹如断截多罗树顶不复生长。又彼事欲可爱可乐乃至可意。若变坏时于清净识诸忧愁等一切苦恼皆不得住。如莲华叶水滴不着。复次今当略辨上所说义。谓薄伽梵此中略示诸欲爱味过患出离三种自性。又显爱味能为过患及彼出离所有功德。当知是名此中略义

  于过去无恋　　不悕求未来
  现在诸法中　　处处遍观察
  智者所增长　　无夺亦无动

此是造贤善颂。谓如有一于佛所证法毗奈耶。获得净信。以正信心弃舍家法趣于非家。由五种相。修行梵行令善清净。谓能舍离居家诸行无所顾恋。亦不缘彼心生追恋还起染着。是名初相。又于现法利养恭敬未来种类所有诸行。不生悕望。亦不愿求当来人天所有诸行修行梵行。是第二相。又于现在五取蕴摄色等诸法及彼安立。能正观察。又于现法及当来世诸身恶行及恶果报。谓我于身不应发起所有恶行。广说如经。乃至应断身诸恶行修身善行。语意善行当知亦尔。又于色等诸蕴能随观察。去来今世皆是无常。无常故苦。苦故无我。由无我故于彼一切不执我所。乃至于彼不执为我。如是如实正慧观察。是第三相。又依初法毗钵舍那诸根成熟。福德智慧二种资粮于当来世通达增长。非诸王等所能劫夺。是第四相。又依第二法毗钵舍那。于现法中涅槃功德能善增长。非诸烦恼及随烦恼所能倾动。是第五相。由此五相。修行梵行令善清净。若依如是一日一夜。亦为贤善第一贤善。当知超度此余一切所有梵行

复次今当略辩上所说义。谓薄伽梵此中略示于善说法毗奈耶中所修梵行。于一切相皆善清净不与他共。当知是名此中略义。嗢拖南曰

  恶说贪流怖　　类与池流贪
  作劬劳得义　　论议十四种

瑜伽师地论卷第十九瑜伽师地论卷第二十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中修所成地第十二

已说思所成地。云何修所成地。谓略由四处。当知普摄修所成地。何等四处。一者修处所。二者修因缘。三者修瑜伽。四者修果。如是四处七支所摄。何等为七。一生圆满。二闻正法圆满。三涅槃为上首。四能熟解脱慧之成熟。五修习对治。六世间一切种清净。七出世间一切种清净。如此四处七支所摄。普圣教义广说应知。依善说法毗奈耶中。一切学处皆得圆满

云何生圆满。当知略有十种。谓依内有五。依外有五。总依内外合有十种。云何生圆满中依内有五。谓众同分圆满。处所圆满。依止圆满。无业障圆满。无信解障圆满。众同分圆满者。谓如有一生在人中。得丈夫身男根成就。处所圆满者。谓如有一生在人中。又处中国不生边地。谓于是处有四众行。谓苾刍苾刍尼近事男近事女。不生达须篾戾车中。谓于是处无四众行。亦无贤圣正至正行诸善丈夫。依止圆满者。谓如有一生处中国。不缺眼耳随一支分。性不顽嚣亦不喑哑。堪能解了善说恶说所有法义。无业障圆满者。谓如有一。依止圆满。于五无间随一业障。不自造作不教他作。若有作此于现身中必非证得贤圣法器。无信解障圆满者。谓如有一必不成就五无间业。不于恶处而生信解。不于恶处发清净心。谓于种种邪天处所。及于种种外道处所。由彼前生于佛圣教善说法处修习净信长时相续。由此因缘。于今生中唯于圣处。发生信解起清净心云何生圆满中依外有五。谓大师圆满。世俗正法施设圆满。胜义正法随转圆满。正行不灭圆满。随顺资缘圆满。大师圆满者。谓即彼补特伽罗具内五种生圆满已。复得值遇大师出世。所谓如来应正等觉。一切知者。一切见者。于一切境得无障碍。世俗正法施设圆满者。谓即彼补特伽罗值佛出世。又广开示善不善法有罪无罪。广说乃至诸缘生法及广分别。谓契经。应颂。记别。讽诵。自说。缘起。譬喻。本事。本生。方广。希法。及与论议。胜义正法随转圆满者。谓即大师善为开示俗正法已。诸弟子众依此正法。复得他人为说随顺教诫教授。修三十七菩提分法。得沙门果。于沙门果证得圆满。又能证得展转胜上增长广大所有功德。正行不灭圆满者。谓佛世尊虽般涅槃。而俗正法犹住未灭。胜义正法未隐未断。随顺资缘圆满者。谓即四种受用正法。因缘现前受用正法。诸有正信长者居士婆罗门等。知彼受用正法而转恐乏资缘退失如是所受正法。是故殷勤奉施种种衣服饮食诸坐卧具病缘医药供身什物。如是十种名依内外生圆满。即此十种生圆满名修瑜伽处所。由此所依所建立处为依止故。证得如来诸弟子众所有圣法。如是圣法略有二种一有学法。二无学法。今此义中意取无学所有圣法。谓无学正见。广说乃至。无学正智。何以故。由诸有学虽有圣法。而相续中非圣烦恼之所随逐现可得故。如是初支生圆满广圣教义有此十种。除此更无余生圆满若过若增。

云何闻正法圆满。谓若正说法若正闻法。二种总名闻正法圆满。又正说法略有二种。所谓随顺及无染污。广说当知有二十种。如菩萨地当说。又正闻法略有四种。一远离憍傲。二远离轻蔑。三远离怯弱。四远离散乱。远离如是四种过失而听法者。名正闻法。当知广说有十六种。亦如菩萨地中当说

云何涅槃为上首。谓如来弟子依生圆满转时。如先所说相而听闻正法。唯以涅槃而为上首。唯求涅槃唯缘涅槃而听闻法。不为引他令信于己。不为利养恭敬称誉。又缘涅槃而听法者。有十法转。涅槃为首。谓依止有余依涅槃界及无余依涅槃界。当知依止有余依涅槃界。有九法转。涅槃为首。依止无余依涅槃界。有一法转。涅槃为首。谓以闻所成慧为因。于道道果涅槃起三种信解。一信实有性。二信有功德。三信己有能得乐方便。如是信解生已。为欲成办思所成智。身心远离愦闹而住。远离障盖诸恶寻思。依止此故便能趣入善决定义思所成智。依止此故又能趣入无间殷重二修方便。由此次第乃至证得修所成智。依止此故见生死过失发起胜解。见涅槃功德发起胜解。由串修故入谛现观。先得见道有学解脱已。得见迹。于上修道由数习故。更复证得无学解脱。由证此故解脱圆满。即此解脱圆满名有余依涅槃界。即此涅槃以为上首。令前九法次第修习而得圆满。当知即此解脱圆满。以无余依涅槃界而为上首。如是涅槃为首听闻正法。当知获得五种胜利。何等为五。谓听闻法时饶益自他。修正行时饶益自他。及能证得众苦边际。若说法师为此义故宣说正法。其听法者即以此意而听正法。是故此时名饶益他。又以善心听闻正法。便能领受所说法义甚深上味。因此证得广大欢喜。又能引发出离善根。是故此时能自饶益。若有正修法随法行大师。为欲建立正法。方便示现成正等觉。云何令彼正修行转。故彼修习正法行时。即是法尔供养大师。是故说此名饶益他。因此正行堪能证得寂静清凉。唯有余依涅槃之界。是故说此能自饶益。若无余依涅槃界中般涅槃时。名为证得众苦边际。是名涅槃以为上首听闻正法所得胜利。如是名为涅槃为首。所有广义除此更无若过若增

云何能熟解脱慧之成熟。谓毗钵舍那支成熟故。亦名慧成熟。奢摩他支成熟故。亦名慧成熟。所以者何。定心中慧于所知境清净转故。又毗钵舍那支最初必用善友为依。奢摩他支尸罗圆满之所摄受。又依善友之所摄受。于所知境真实性中有觉了欲。依尸罗圆满之所摄受。于增上尸罗毁犯净戒现行非法坏轨范中。若诸有智同梵行者。由见闻疑或举其罪。或令忆念或令随学。于尔所时堪忍讥论。又依所知真实觉了欲故。爱乐听闻。依乐闻故便发请问依请问故。闻昔未闻甚深法义。数数听闻无间断故。于彼法义转得明净。又能除遣先所生疑。如是觉慧转明净故。于诸世间所有盛事。能见过患深心厌离。如是厌心善作意故。于彼一切世间盛事不生愿乐。彼由如是于诸世间增上生道无愿心故。为欲断除诸恶趣法。心生正愿。又为修集能对治彼所有善法。修集一切烦恼对治所有善法。为欲证得彼对治果。亦为自心得清净故。心生正愿。如是十种能熟解脱慧成熟法。如先所说渐次能令解脱圆满。又随次第已说三支。谓闻正法圆满。涅槃为上首。能熟解脱慧之成熟。如是三支广圣教义。谓十十种。除此更无若过若增。又此三支当知即是修瑜伽因缘。何以故。由依此次第此因此缘。修习瑜伽方得成满。谓依闻正法圆满。涅槃为上首。能熟解脱慧成熟故

云何修习对治。当知略说于三位中有十种修习瑜伽所对治法。云何三位。一在家位。二出家位。三远离闲居修瑜伽位。云何十种修习瑜伽所对治法。谓在家位中于诸妻室有淫欲相应贪。于余亲属及诸财宝有受用相应爱。如是名为处在家位所对治法。由此障碍于一切种不能出离。设得出家由此寻思之所扰动。为障碍故不生喜乐。如是二种所对治法。随其次第修不净想修无常想。当知是彼修习对治。又出家者于出家位中。时时略有四种所作。一常方便修善法所作。谓我于诸法常方便修为依止故。当能制伏随爱味乐一切心识。又能如实觉了苦性。二于无戏论涅槃信解爱乐所作。谓我当于无戏论涅槃心无退转不生忧虑。谓我我今者何所在耶。三于时时中游行聚落乞食所作。谓我乞食受用为因。身得久住有力调适。常能方便修诸善法。四于远离处安住所作。谓若爱乐与诸在家及出家众杂居住者。便有种种世间相应见闻受用诸散乱事。勿我于彼正审观察。心一境位当作障碍。于此四种所作事中。当知有四所对治法。于初所作有懒堕懈怠。于第二所作有萨迦耶见。于第三所作有爱味贪。于第四所作有世间种种乐欲贪爱。如是四种所对治法。如其次第亦有四种修习对治。一于无常修习苦想。二于众苦修无我想。三于饮食修厌逆想。四于一切世间修不可乐想。又于远离闲居方便作意位中。当知略有四种所治。何等为四。一于奢摩他毗钵舍那品。有闇昧心。二于诸定有随爱味。三于生有随动相心。四推后后日顾待余时。随不死寻不能炽然勤修方便。如是四种所对治法。当知亦有四种修习对治。一修光明想。二修离欲想。三修灭想。四修死想。又不净想略有二种。一思择力摄。二修习力摄。思择力摄不净想中。当知五法为所对治。何等为五。一亲近母邑。二处显失念。三居隐放逸。四通处隐显由串习力。五虽勤方便修习不净而作意错乱。谓不观不净随净相转。如是名为作意错乱。修习力摄不净想中。当知七法为所对治。何等为七。谓本所作事心散乱性。本所作事趣作用性。方便作意不善巧性。由不恭敬勤请问故。又由不能守根门故。虽处空闲犹有种种染污寻思。扰乱其心。又于饮食不知量故。身不调适。又为寻思所扰乱故。不乐远离内心寂静奢摩他定。又由彼身不调适故。不能善修毗钵舍那。不能如实观察诸法。如是一切所对治法。当知总说一门十二一门十四。又即如是所对治法。能治白法还有尔所。于修二种不净想中。当知多有所作。又于无常所修苦想。略有六种所对治法。何等为六。一于未生善法最初应生。而有懒堕。二于已生善法应住。不忘修习圆满倍令增广所有懈怠。三于恭敬师长往请问中。不恒相续。四于恒修善法常随师转。远离净信。五由远离净信不能常修。六于内放逸。由放逸故于常修习诸善法中。不恒随转。如是六种所对治法。还有六法能为对治多有所作。与此相违。应知其相。又光明想缘多光明以为境界。如三摩呬多地中已说。今此义中意辩缘法光明以为境界修光明想。谓如所闻已得究竟不忘念法。名法光明。与彼俱行彼相应想。应知名光明想。何以故。真实能令心闇昧者。谓方便修止观品时。于诸法中所有忘念。与此相违。当知即是光明。又第一义思所成慧及修所成慧俱光明想。有十一法为所对治。云何十一。谓思所成慧俱光明想有四法。修所成慧俱光明想有七法。如是所治合有十一。思所成慧俱光明想有四法者。一不善观察故。不善决定故。于所思惟有疑随逐。二住于夜分懒惰懈怠故。多习睡眠故虚度时分。三住于昼分习近邪恶食故身不调柔。不能随顺谛观诸法。四与在家出家共相杂住。于随所闻所究竟法。不能如理作意思惟。如是疑随逐故。障碍能遣疑因缘故。此四种法是思所成慧俱光明想之所对治。令思所成若智若见不得清净。何等名为修所成慧俱光明想所治七法。一依举相修。极勇精进所对治法。二依止相修。极劣精进所对治法。三依舍相修。贪着定味与爱俱行所有喜悦。四于般涅槃心怀恐怖。与嗔恚俱其心怯弱二所治法。五即依如是方便作意。于法精勤论议决择。于立破门多生言论相续不舍。此于寂静正思惟时能为障碍。六于色声香味触中。不如正理执取相好。不正寻思令心散乱。七于不应思处强摄其心思择诸法。如是七种是修所成慧俱光明想所对治法。极能障碍修所成慧俱光明想。令修所成若知若见不清净转。此所治法还有十一。与此相违。能对治法。能断于彼。当知亦令思修所成若知若见清净而转。又正方便修诸想者。有能断灭所治法欲。又于所治现行法中。心不染着速令断灭。又能多住能对治法。断灭一切所对治法。如是三法随逐一切对治修故。名多所作。如是名为修习对治。此修对治当知即是修习瑜伽。此第五支修习对治广圣教义。当知唯有如是十相。除此更无若过若增

云何世间一切种清净。当知略有三种。一得三摩地。二三摩地圆满。三三摩地自在。此中最初有二十种得三摩地所对治法。能令不得胜三摩地。何等二十。一有不乐断同梵行者为伴过失。二伴虽有德然能宣说修定方便。师有过失。谓颠倒说修定方便。三师虽有德然于所说修定方便。其能听者欲乐羸劣心散乱故。不能领受过失。四其能听者虽有乐欲属耳而听。然闇钝故。觉慧劣故。不能领受过失。五虽有智德。然是爱行多求利养恭敬过失。六多分忧愁难养难满不知喜足过失。七即由如是增上力故。多诸事务过失。八虽无此失然有懈怠懒惰故。弃舍加行过失。九虽无此失然有为他种种障碍生起过失。十虽无此失然有于寒热等苦不能堪忍过失。十一虽无此失然有慢恚过故。不能领受教诲过失。十二虽无此失然有于教颠倒思惟过失。十三虽无此失然。于所受教有忘念过失。十四虽无此失然有在家出家杂住过失。十五虽无此失然有受用五失相应卧具过失。五失相应卧具。应知如声闻地当说。十六虽无此失然于远离处不守护诸根故。有不正寻思过失。十七虽无此失然由食不平等故。有身沉重无所堪能过失。十八虽无此失然性多睡眠。有多睡眠随烦恼现行过失。十九虽无此失然不先修行奢摩他品故。于内心寂止远离中有不欣乐过失。二十虽无此失然先不修行毗钵舍那品故。于增上慧法毗钵舍那如实观中有不欣乐过失。如是二十种法。是奢摩他毗钵舍那品证得心一境性之所对治。又此二十种所对治法。略由四相于所生起三摩地中。堪能为障。何等为四。一于三摩地方便不善巧故。二于一切修定方便全无加行故。三颠倒加行故。四加行缦缓故。此三摩地所对治法有二十种白法对治。与此相违。应知其相。由此能断所对治法多所作故。疾疾能得正住其心证三摩地。又得此三摩地。当知即是得初静虑近分定。未至位所摄。又此得三摩地相违法。及得三摩地随顺法。广圣教义当知唯有此二十种。除此更无若过若增。由此因缘依初世间一切种清净。于此正法补特伽罗得三摩地。已善宣说已善开示

复次如是已得三摩地者。于此少小殊胜定中。不生喜足。于胜三摩地圆满。更起求愿。又即于彼见胜功德。又由求愿见胜功德。为求彼故勇猛精进策励而住。又彼于色相应爱味俱行烦恼。非能一切皆永断故。名非得胜。又非于彼诸善法中皆勤修故。名他所胜。又于广大净天生处无有沉没。又彼无能陵篾于己下劣信解增上力故。又彼如是心无沉没。于定所缘境界法中。即先所得止举舍相。无间殷重方便修故。随顺而转。又彼如是随法相转数入数出。为欲证得速疾通慧。依定圆满乐闻正法。故于时时中殷勤请问。又依如是三摩地圆满故。于正方便根本定摄内心奢摩他。证得远离爱乐。又证得法毗钵舍那。如是观察炽然明净所有爱乐。当知齐此已能证入根本静虑。如是名为三摩地圆满。又此三摩地圆满广圣教义。当知唯有如是十相。除此更无若过若增

复次虽已证得根本三摩地故。名三摩地圆满。其心犹为三摩地生爱味。慢见疑无明等诸随烦恼之所染污。未名圆满清净鲜白。为令如是诸随烦恼不现行故。为练心故为调心故。彼作是思。我应当证心自在性定自在性。于四处所以二十二相应善观察。谓自誓受下劣形相威仪众具。又自誓受禁制尸罗。又自誓受精勤无间修习善法。若有为断一切苦恼受此三处。应正观察众苦随逐。由剃除须发故。舍俗形好故。着坏色衣故。应自观察形色异人。如是名为观察誓受下劣形相。于行住坐卧语默等中。不随欲行制伏憍慢往趣他家。审正观察游行乞食。如是名为观察誓受下劣威仪。又正观察从他获得。无所畜积诸供身具。如是名为观察誓受下劣众具。由此五相。当知是名初处观察。又善说法毗奈耶中。诸出家者所受尸罗。略舍二事之所显现。一者弃舍父母妻子。奴婢仆使。朋友眷属。财谷珍宝等所显。二者弃舍歌舞倡伎。笑戏欢娱。游从掉逸。亲爱聚会。种种世事之所显现。又彼安住尸罗律仪。不由犯戒私自恳责。亦不为彼同梵行者以法呵摈。有犯尸罗而不轻举。若于尸罗有所缺犯。由此因缘。便自恳责。若同梵行以法呵摈。即便如法而自悔除。于能举罪同梵行者。心无恚恨无损无恼而自修治。由此五相。是名于第二处观察。如是尸罗善圆满已。应以五相精勤方便修诸善品。谓时时间咨受读诵论量决择勤修善品。如是乃应受他信施。又乐远离以正方便修诸作意。又复昼夜于退分胜分二法。知断修习。又于生死见大过失。又于涅槃见胜功德。由此五相。是名第三处观察。如是精勤修善品者。略为四苦之所随逐。谓于四沙门果。未能随有所证故。犹为恶趣苦所随逐。体是生老病死法故。为内坏苦之所随逐。一切所爱离别法故。为爱坏苦之所随逐。自业所作故一切苦因之所随逐。彼为如是四苦随逐。应以七相审正观察。由此七相是名第四处观察。彼于如是四处。以二十二相正观察时。便生如是如理作意。谓我为求如是事故。誓受下劣形相威仪及资身具。誓受禁戒。誓受精勤。常修善法。而我今者于四种苦为脱何等。若我如是自策自励誓受三处。犹为四苦常所随逐未得解脱。我今不应为苦随逐。未于胜定获得自在。中路止息或复退屈。如是精勤如理作意。乃得名为出家之想及沙门想。彼于圆满修多方便以为依止。由世间道证得三摩地圆满故。于烦恼断犹未证得。复依乐断常勤修习。又彼已得善世间道。数数为得三摩地自在故。依止乐修无间而转。又于正信长者居士婆罗门等。获得种种利养恭敬。而不依此利养恭敬而生贪着。亦不于他利养恭敬。及余不信婆罗门等对面背面诸不可意身业语业现行事中。心生愤恚。又复于彼无损害心。又爱慢见无明疑惑种种定中诸随烦恼不复现行。善守念住。又非证得胜奢摩他。即以如是奢摩他故。谓己一切所作已办。亦不向他说己所证。彼由如是乐断乐修。心无贪恚。正念现前离增上慢。于诸衣服随宜获得便生喜足。如于衣服。于余饮食卧具等喜足。当知亦尔。又正了知而为受用。谓如是等诸资生具。但为治身令不败坏。暂止饥渴摄受梵行。广说乃至。于食知量。彼由如是正修行故。于三摩地获得自在。依止彼故其心清白。无有瑕秽离随烦恼。广说乃至。获得不动。能引一切胜神通慧。是名三摩地自在。此三摩地自在广义。当知唯有如所说相。除此更无若过若增。又先所说得三摩地。若中所说三摩地圆满。及今所说三摩地自在。总名无上世间一切种清净。当知此清净唯在正法非诸外道

云何出世间一切种清净。当知略有五种。何等为五。一入圣谛现观。二入圣谛现观已离诸障碍。三入圣谛现观已为欲证得速疾通慧。作意思惟诸欢喜事。四修习如所得道。五证得极清净道及果功德

云何入圣谛现观。谓有如来诸弟子众。已善修习世间清净。知长夜中由妙五欲积集其心。食所持故长养其心。于彼诸欲生爱乐故。而于诸欲深见过患。于上胜境见寂静德。彼於戏论界易可安住。谓于世间一切种清净。于无戏论界。难可安住。谓于出世间一切种清净。是故于彼厌恶而住。非不厌恶。又此住正法者。于无戏论涅槃界中。心乐安住乐欲证得。由阙沙门果证增上力故。于己杂染相应。心生厌患。于己清净不相应。心生厌患。于己杂染相应过患。心生厌患。于己清净不相应过患。心生厌患。于己清净见难成办。心生厌患。此中略有三种杂染相应。一未调未顺而死杂染相应。二死已当堕烦恼大坑杂染相应。三由彼烦恼自在力故。现行种种恶不善业。往有怖处杂染相应。彼观己身阙沙门果证。由彼阙故与三种杂染相应。如是观已心生厌患。当知清净不相应亦有三种。一诸烦恼断究竟涅槃名无怖处。二能证此。谓依增上心学善心三摩地。三能证此。于增上慧学正见所摄微妙圣道。彼观己身与此三种清净不相应故。心生厌患。当知杂染相应过患亦有三种。一老病死苦根本之生。二自性苦生无暇处。三一切处生无常性。彼观己身有此三种杂染相应过患。心生厌患。当知清净不相应过患有五种。一于边地生未能止息。二于恶道生未能止息。三于在家众诸无间业未能偃塞。四于出家众无量见趣未不相应。五虽由世间道乃至有顶若定若生。而于无初后际生死流转。未作边际。彼观自身有此五种清净不相应过患。心生厌患。于己清净见难成办。当知亦有五种。一若舍不为不能自作故。二于所余事非请他为能成办故。三决定应作故由于自心未令清净必于众苦不得解脱成吉祥性。四非于恶业现在不作。即说彼为已作清净。即名已得于现见法永离炽燃无对治道。先所造作恶不善业必不坏故。五由彼清净学无学道证得所显故。彼观清净。由此五相难可成办。心生厌患。又复发起坚固精进。为欲证得。彼由观见杂染清净相应不相应故。心生厌患。又由观见杂染清净相应不相应过患故。心生怖畏。又于清净证得及杂染断灭中。有懒惰懈怠故。心便遮止。又由作意思惟彼相故心生厌患。即于此相多所作故。心极厌患。如厌患极厌患。怖畏极怖畏遮止极遮止。当知亦尔。如是彼以由厌俱行想。于五处所。以二十种相作意思惟故。名善修治。复有五因。二十种相之所摄受。令于爱尽寂灭涅槃速疾多住。心无退转亦无忧虑。谓我我今者为何所在。何等五因。一由通达作意故。谓由如是通达作意。无间必能趣入正性离生。入谛现观证圣智见。二由所依故。谓由依此所依无间必能趣入正性离生。余如前说。三由入境界门故。谓由缘此入境界门。必能趣入正性离生。余如前说。四由摄受资粮故。谓由此摄受资粮。必能趣入正性离生。余如前说。五由摄受方便故。谓由摄受如是方便。必能趣入正性离生。乃至广说。如是五因当知依谛现观逆次因说。非顺次因。依最胜因。如先说事。逆次说故。谓于空无愿无相加行中。于随入作意。微细现行有间无间随转我慢俱行心相。能障现观作意正通达故。既通达已于作意俱行心任运转中。能善弃舍令无间灭。依无间灭心由新所起作意。以无常等行如实思惟。由此作意修习多修习故。所缘能缘平等平等智生。彼于尔时能障现观我慢乱心便永断灭。证得心一境性。便自思惟。我已证得心一境性。如实了知。当知是名由通达作意故入谛现观。又若先以世间道得三摩地亦得圆满。亦得自在。彼或于入三摩地相。谓由此故入三摩地。或于住三摩地相。谓由此故住三摩地。或于出三摩地相。谓由此故出三摩地。于此诸相作意思惟。安住其心入谛现观。若得三摩地而未圆满。亦未自在。彼或思惟止相。或思惟举相。或思惟舍相。安住其心入谛现观。如是当知由所依故其心安住。又有二法。于修现观极为障碍。何等为二。一不正寻思所作扰乱心不安

静。二于所知事其心颠倒。为欲对治如是障碍。当知有二种于所缘境安住其心。谓为对治第一障故。修阿那波那念。为对治第二障故。修诸念住。如是当知由入境界门故其心安住。又于妙五欲乐习近者。于圣法毗奈耶非所行处。若于随宜所得衣服饮食诸坐卧具。便生喜足。随所获得利养恭敬。制伏其心。谓依妙五欲。不由所得利养恭敬。心便坚住。由此因缘。远离一切非所行处。既远离已依诸念住乐断乐修。于昼夜分时时观察自他所有衰盛等事。心生厌患。又复修习佛随念等令心清净。又复安住诸圣种中。如是当知由资粮故。其心安住。此依最胜资粮道说。又彼如是资粮住已。为修相应作意加行故。有二种加行方便。何等为二。一自于契经阿毗达磨。读诵受持修正作意。于蕴等事令极善巧。二依地师教。所谓大师。邬波柁耶。阿遮利耶。于时时间教授教诫摄受依止。又正加行作意思惟。当知是名第三方便。此正加行作意思惟。名正加行。此中义者。谓尸罗净所有作意。名正加行作意思惟。彼自思惟尸罗清净。故。无悔恼。无悔恼故。便生欢喜。广说乃至。心入正定。是故宣说此正加行作意思惟。名心住方便。由如是方便故心速安住。彼于尔时由此五因二十种相。摄持其心。于爱尽寂灭涅槃界中。令善安住。无复退转心无惊怖。谓我我今者何所在耶。当于如是心安住时。应知已名入谛现观。如是名入圣谛现观。又此圣谛现观义广说应知。谓心厌患相有二十种。心安住相亦二十种。除此更无若过若增

云何入圣谛现观已离诸障碍。当知此障略有二种。一行处障。二住处障。行处障者。谓如圣弟子或与众同居。随其生起僧所作事。弃舍善品数与众会。或复安住常乞食法而爱重饮食。或兼二处。好乐营为衣钵等事。或为读诵经典而好乐谈话。或居夜分而乐着睡眠。或居昼分乐王贼等杂染言论。或于是处有亲戚交游谈谑等住。而于是处不乐远离。谓长夜数习与彼共居增上力故。或复乐与第二共住。诸如是等名行处障。住处障者。谓处空闲修奢摩他毗钵舍那。总名为住。依奢摩他毗钵舍那。当知复有四种障碍。一毗钵舍那支不随顺性。二奢摩他支不随顺性。三彼俱品念不随顺性。四处所不随顺性。若谓己聪明而生高举。不从他闻顺观正法。是名毗钵舍那支不随顺性。若不安静身语意行。躁动轻举数犯尸罗生忧悔等。乃至不得心善安住。当知是名奢摩他支不随顺性。若有忘念增上力故。于沉掉等诸随烦恼心不遮护。当知是名彼俱品念不随顺性。若有习近五失相应诸坐卧具。当知是名处所不顺随性。或于昼分多诸諠逸。于夜分中多蚊虻等众苦所触。又多怖畏多诸灾厉。众具匮乏不可爱乐。恶友摄持无诸善友。诸如是等名住处障。又此二障当知总有二种因缘能为远离。一多诸定乐。二多诸思择。多诸定乐应知略有六种。谓若有已得三摩地而未圆满未得自在。彼应修习止举舍三种善巧。由此发生多诸定乐。若有于三摩地已得圆满亦得自在。彼应修习入住出定三种善巧。由此发生多诸定乐。云何名为多诸思择。谓胜善慧名为思择。由此慧故。于昼夜分自己所有善法增长如实了知。不善法增长如实了知。善法衰退如实了知。不善法衰退如实了知。又彼如于昼夜。若行若住。习近衣服饮食命缘。由习近故。不善法增长善法衰退。或善法增长不善法衰退。皆如实了知。即此思择为依止故。于所生起诸不善法。由不坚着方便道理。驱摈远离。于诸善法能勤修习如是二处十种善巧。于二处所十一种障能令断灭。随所生起即便远离。如是名为远离障碍。又此远离障碍义。广说应知如所说相。除此更无若过若增

云何入圣谛现观已。为欲证得速疾通慧。作意思惟诸欢喜事。谓圣弟子已见圣谛已得证净。即以证净为依止故。于佛法僧胜功德田作意思惟发生欢喜。又依自增上生事及决定胜事。谓己身财宝所证盛事。作意思惟发生欢喜。又依无嫉。如于自身于他亦尔。又依知恩。谓有恩者。念大师恩作意思惟。发生欢喜。由依彼故。远离众苦及与苦因。引发众乐及与乐因。如是思惟随顺修道欢喜事故。便能证得速疾通慧。又此思惟随顺修道欢喜事义。广说应知如所说相。除此更无若过若增

云何修习如所得道。谓彼如是所生广大无罪欢喜溉灌其心。为趣究竟于现法中心极思慕。彼由如是心生思慕。出离乐欲数数现行。谓我何当能具足住如是圣处。如阿罗汉所具足住。如是欲乐生已。发勤精进无间常委。于三十七菩提分法方便勤修。又彼如是勤精进故。不与在家出家众相杂住。习近边际诸坐卧具。心乐远离。又彼如是发生欲乐。发勤精进。乐远离已不生喜足。谓于少分殊胜所证。心无喜足。于诸善法转上转胜转微妙处悕求而住。由此四法摄受修道。极善摄受。即此四种修道为依。如先所说诸欢喜事所生欢喜。彼于尔时修得圆满最极损减方便道理。烦恼断故。获得殊胜所证法故。亦令喜悦修得圆满。又修所断惑品粗重已远离故。获得轻安。轻安故。生身心清凉。极所摄受。如是二种修得圆满。又此有学金刚喻定到究竟故。修得圆满。是名修习如所得道。又此修习如所得道义。广说应知。谓四种法为依止故。能令五法修习圆满。除此更无若过若增

云何证得极清净道及果功德。谓于三位。乐位苦位不苦不乐位。为诸烦恼之所随眠有二种补特伽罗。多分所显。一者异生。二者有学。又有二种能发起杂染品。一者取杂染品。二者行杂染品。即为断此二杂染品。入善说法毗奈耶时。能为障碍所有烦恼。此诸烦恼能为随眠。深远入心。又能发生种种诸苦。若能于此无余永断。名为证得极净道果。又十无学支所摄五无学蕴。所谓戒蕴。定蕴。慧蕴。解脱蕴。解脱。知见蕴。名极清净道。又由证得此极净道。离十过失住圣所住。云何名为十种过失。所谓依外诸欲所有愁叹。忧苦。种种恼乱。苦苦相应过失。又有依内不护诸根过失。由不护诸根故。生愁叹等。又有爱味乐住过失。又有行住放逸过失。又有外道不共即彼各别邪见所起语言。寻思。追求三种过失。又有依静虑边际过失。又有缘起所摄发起取杂染品过失。又有发起行杂染品过失。若于如是十种过失永不相应。唯有最后身所任持。第二余身毕竟不起。于最寂静涅槃界中。究竟安住。一切有情乃至上生第一有者。于彼一切所有有情得为最胜。是故说名住圣所住。以能远离十种过失。又能安住圣所住处故。名功德。又若彼果若极净道若彼功德。如是一切总略说名证得极清净道及果功德。又此证得极清净道及果功德义。广说应知如所说相。除此更无若过若增。若得如是最上无学诸圣法者。如是圣法相应之心。于妙五欲极为厌背。无异熟故后更不续。若世间心虽复已断犹得现行。彼于后时任运而灭。又烦恼道后有业道。于现法中已永断绝。由彼绝故当来苦道更不复转。由此因果永灭尽故。即名苦边。更无所余无上无胜。此中若入圣谛现观。若离障碍。若为证得速疾通慧。作意思惟诸欢喜事。若修习如所得道。若证得极清净道及果功德。如是名为出世间一切种清净。又此出世间一切种清净义。广说应知如所说相。除此更无若过若增。如是若先所说世间一切种清净。若此所说出世间一切种清净。

总略为一说名修果。如是如先所说。若修处所若修因缘。若修瑜伽若修果。一切总说为修所成地

瑜伽师地论卷第二十瑜伽师地论卷第二十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三初瑜伽处种姓地第一

如是已说修所成地。云何声闻地。一切声闻地总嗢拖南曰

  若略说此地　　姓等数取趣
  如应而安立　　世间出世间
  此地略有三　　谓种姓趣入
  及出离想地　　是说为声闻

云何种姓地。谓嗢拖南曰

  若略说一切　　种姓地应知
  谓自性安立　　诸相数取趣

谓若种姓自性。若种姓安立。若住种姓者所有诸相。若住种姓补特伽罗。如是一切总略为一名种姓地。

云何种姓。谓住种姓补特伽罗。有种子法由现有故。安住种姓补特伽罗。若遇胜缘便有堪任便有势力。于其涅槃能得能证。问此种姓名有何差别。答或名种子或名为界或名为性。是名差别。问今此种姓以何为体。答附在所依有如是相。六处所摄。从无始世展转传来法尔所得。于此立有差别之名。所谓种姓种子界性。是名种姓

云何种姓安立。谓应问言。今此种姓为当言细为当言粗。应答言细。何以故。由此种子未能与果未习成果故名为细。若已与果已习成果。尔时种姓若种若果俱说名粗。

问如是种姓当言堕一相续堕多相续。答当言堕一相续。所以者何。若法异相俱有而转。见彼各别种种相续种种流转。如是种子非于六处有别异相。即于如是种类分位六处殊胜。从无始世展转传来法尔所得。有如是想及以言说。谓为种姓种子界性。是故当言堕一相续。

问若住种姓补特伽罗有涅槃法。此住种姓有涅槃法补特伽罗。何因缘故有涅槃法。而前际来长时流转不般涅槃。答四因缘故不般涅槃。何等为四。一生无暇故。二放逸过故。三邪解行故。四有障过故。云何生无暇。谓如有一生于边国及以达须蔑戾车中。四众贤良正至善士不往游涉。是名生无暇。云何放逸过。谓如有一虽生中国或非达须非蔑戾车。四众贤良正至善士皆往游涉。而生贵家财宝具足。于诸妙欲耽着受用。不见过患不知出离。是名放逸过。云何邪解行。谓如有一虽生中国。乃至广说而有外道种种恶见。谓起如是见立如是论。无有施与广说乃至我自了知无诸后有。复由如是外道见故。不值诸佛出现世间。无诸善友说正法者。是名邪解行。云何有障过。谓如有一虽生中国。广说如前亦值诸佛出现于世。遇诸善友说正法者。而性愚钝顽騃无知。又复喑哑以手代言。无力能了善说恶说所有法义。或复造作诸无间业。或复长时起诸烦恼。是名有障过。如是名为四种因缘。由此因缘故虽有般涅槃法而不般涅槃。彼若值遇诸佛出世听闻正法。获得随顺教授教诫。无彼因缘尔时方能善根成熟。渐次乃至得般涅槃。无涅槃法补特伽罗住决定聚。彼若遇缘若不遇缘。遍一切种毕竟不能得般涅槃。

问何等名为涅槃法缘。而言阙故无故不会遇故不般涅槃。答有二种缘。何等为二。一胜二劣

云何胜缘。谓正法增上他音。及内如理作意。云何劣缘。谓此劣缘乃有多种。谓若自圆满若他圆满。若善法欲。若正出家。若戒律仪。若根律仪。若于食知量。若初夜后夜常勤修习觉寤瑜伽。若正知而住。若乐远离。若清净诸盖若依三摩地。

云何自圆满。谓善得人身。生于圣处。诸根无缺。胜处净信。离诸业障。云何名为善得人身。谓如有一生人同分。得丈夫身男根成就。或得女身。如是名为善得人身。云何名为生于圣处。谓如有一生于中国广说如前。乃至善士皆往游涉。如是名为生于圣处。云何名为诸根无缺。谓如有一性不愚钝。亦不顽騃又不喑哑。乃至广说支节无减。彼由如是支节无缺耳无缺等。能于善品精勤修集。如是名为诸根无缺。云何名为胜处净信。谓如有一于诸如来正觉所说法毗奈耶得净信心。如是名为胜处净信。言胜处者。谓诸如来正觉所说法毗奈耶。能生一切世出世间白净法故。此中所起前行增上诸清净信。名胜处净信。能除一切所有烦恼垢秽浊故。云何名为离诸业障。谓能远离五无间业。所谓于彼害母害父害阿罗汉破和合僧于如来所恶心出血。随一所有无间业障。于现法中不作不行。如是名为离诸业障。若有于此五无间业造作增长。于现法中竟不能转得般涅槃生起圣道。故约彼说离诸业障。唯由如是五种支分自体圆满。是故说此名自圆满。云何他圆满。谓诸佛出世。说正法教。法教久住。法住随转。他所哀愍。云何名为诸佛出世。谓如有一普于一切诸有情类。起善利益增上意乐。修习多千难行苦行。经三大劫阿僧企耶。积集广大福德智慧二种资粮。获得最后上妙之身。安坐无上胜菩提座。断除五盖。于四念住善住其心。修三十七菩提分法。现证无上正等菩提。如是名为诸佛出世。过去未来现在诸佛。皆由如是名为出世。云何名为说正法教。谓即如是诸佛世尊出现于世。哀愍一切诸声闻故。依四圣谛宣说真实苦集灭道无量法教。所谓。契经应颂。记别讽诵。自说因缘。譬喻本事。本生方广。希法论议。如是名为说正法教。诸佛世尊及圣弟子。一切正士皆乘此法而得出离。然后为他宣说称赞。是故说此名为正法宣说。此故名正法教。云何名为法教久住。谓说正法已转法轮已。乃至世尊寿量久住。及涅槃后经尔所时。正行未减正法未隐。如是名为正法久住。如是久住当知说彼胜义正法作证道理。云何名为法住随转。谓即如是证正法者。了知有力能证如是正法众生。即如所证随转随顺教授教诫。如是名为法住随转。云何名为他所哀愍。他谓施主。彼于行者起哀愍心。惠施随顺净命资具。所谓如法衣服饮食诸坐卧具病缘医药。如是名为他所哀愍。云何善法欲。谓如有一或从佛所或弟子所。闻正法已获得净信。得净信已应如是学。在家烦扰若居尘宇。出家闲旷犹处虚空。是故我今应舍一切妻子眷属财谷珍宝。于善说法毗奈耶中。正舍家法趣于非家。既出家已勤修正行令得圆满。于善法中生如是欲名善法欲。云何正出家。谓即由此胜善法欲增上力故。白四羯磨受具足戒。或受劳策所学尸罗是名正出家。云何戒律仪谓彼如是正出家已。安住具戒坚牢防护。别解律仪轨则所行皆得圆满。于微小罪见大怖畏。受学一切所有学处。是名戒律仪。云何根律仪。谓即依此尸罗律仪。守护正念修常委念。以念防心行平等位。眼见色已而不取相不取随好。恐依是处由不修习眼根律仪防护而住其心。漏泄所有贪忧恶不善法。故即于彼修律仪行防护眼根。依于眼根修律仪行。如是行者。耳闻声已鼻嗅香已舌尝味已身觉触已意了法已。而不取相不取随好。恐依是处由不修习意根律仪防护而住其心。漏泄所有贪忧恶不善法。故即于彼修律仪行防护意根。依于意根修律仪行。是名根律仪。云何于食知量。谓彼如是守诸根已。以正思择食于所食。不为倡荡不为憍逸。不为饰好不为端严。食于所食然食所食为身安住为暂支持。为除饥渴为摄梵行为断故受为令新受当不更生。为当存养力乐无罪安隐而住。如是名为于食知量。云何初夜后夜常勤修习觉寤瑜伽。谓彼如是食知量已。于昼日分经行宴坐二种威仪。从顺障法净修其心。于初夜分经行宴坐二种威仪。从顺障法净修其心。过此分已出住处外洗濯其足。右胁而卧重累其足住光明想。正念正知思惟起想。于夜后分速疾觉寤。经行宴坐二种威仪。从顺障法净修其心。如是名为初夜后夜常勤修习觉寤瑜伽。云何正知而住。谓彼如是常勤修习觉寤瑜伽已。若往若来正知而住。若睹若瞻正知而住。若屈若伸正知而住。持僧伽胝及以衣钵正知而住。若食若饮若啖若尝正知而住。若行若住若坐若卧正知而住。于觉寤时正知而住。若语若默正知而住。如解劳睡时正知而住。如是名为正知而住。云何乐远离。谓由如是所修善法。无倒修治初业地已。远离一切卧具贪着。住阿练若。树下空室。山谷峰穴。草藉迥露。冢间林薮。虚旷平野。边际卧具。是名乐远离。云何清净诸盖。谓彼如是住阿练若或复树下或空室等。于五种盖净修其心。所谓贪欲嗔恚惛沉睡眠掉举恶作及以疑盖。从彼诸盖净修心已。心离诸盖安住贤善胜三摩地。如是名为清净诸盖。云何依三摩地。谓彼如是断五盖已。便能远离心随烦恼。远离诸欲恶不善法。有寻有伺。离生喜乐入初静虑具足安住。寻伺寂静于内等净心一趣性。无寻无伺。定生喜乐第二静虑具足安住。远离喜贪安住舍念。及以正知身领受乐。圣所宣说舍念具足安乐而住。第三静虑具足安住。究竟断乐。先断于苦。喜忧俱没不苦不乐。舍念清净。第四静虑具足安住。如是名为依。三摩地。

彼由如是渐次修行。后后转胜转增转上修集诸缘。初自圆满依三摩地以为最后。得如是心清净鲜白。无诸瑕秽。离随烦恼。质直堪能安住无动。若复获得依四圣谛为令遍知永断作证。修习他音教授教诫。便有如是堪能势力。发生如理所引作意。及彼为先所有正见。由此便能于四圣谛入真现观。圆满解脱。于无余依般涅槃界而般涅槃。

当知此中始从正见圆满解脱。于无余依般涅槃界而般涅槃。是名种性真实修集。从自圆满乃至最后依三摩地。当知是名修集劣缘。若依四谛法教增上所有教授教诫他音。若如正理所引作意。当知是名修集胜缘如是名为种性安立。

云何住种性者所有诸相。谓与一切无涅槃法补特伽罗诸相相违。当知即名安住种性补特伽罗所有诸相。

问何等名为无涅槃法补特伽罗所有诸相。成就彼故应知说名无涅槃法补特伽罗。答无涅槃法补特伽罗有众多相。我今当说彼相少分。谓彼最初不住种性无涅槃法补特伽罗。阿赖耶爱遍一切种。皆悉随缚附属所依。成无量法不可倾拔。久远随逐毕竟坚固依附相续。一切诸佛所不能救。是名第一不住种性。补特伽罗无种姓相。复有所余不住种姓补特伽罗无种姓相。谓彼听闻以无量门呵毁生死众多过失。又复听闻以无量门称赞涅槃众多功德。而于生死不见少分戏论过失。不见少分所有过患。亦复不能少分厌离。如是见厌于过去世不能已生。于未来世不能当生。于现在世不能正生。又于爱尽寂灭涅槃。不见少分下劣功德。不见少分所有胜利。亦复不能少分欣乐。如是见乐于过去世不能已生。于未来世不能当生。于现在世不能正生。是名第二不住种姓补特伽罗无种姓相。复有所余不住种姓补特伽罗无种姓相。谓彼本性成就上品无惭无愧。由是因缘无有厌恶心无怯畏。以欢喜心现行众恶。由是因缘未尝追悔唯观现法。由是因缘自身财宝衰退过患。是名第三不住种姓补特伽罗无种姓相。复有所余不住种姓补特伽罗无种姓相。谓一切种圆满分明称当道理。美妙殊胜易可解了。或依苦谛。或依集谛。或依灭谛。或依道谛。宣说开示正法教时。不能获得微小发心微小信解。况能获得身毛为竖悲泣堕泪。如是亦依过去未来现在世别。是名第四不住种姓补特伽罗无种姓相。复有所余不住种姓补特伽罗无种姓相。谓彼或时于善说法毗奈耶中暂得出家。或为国王所逼迫故。或为狂贼所逼迫故。或为债主所逼迫故。或为怖畏所逼迫故。或不活畏所逼迫故。非为自调伏。非为自寂静。非为自涅槃。非为沙门性。非为婆罗门性。而求出家。既出家已乐与在家及出家众共諠杂住。或发邪愿修诸梵行。谓求生天或余天处。或乐退舍所学禁戒或犯尸罗。内怀朽败外现真实。如水所生杂秽蜗牛螺音狗行。实非沙门。自称沙门。非行梵行自称梵行。如是亦依过去未来现在世别。当知如是不住种姓补特伽罗假相出家。非不乐学补特伽罗名真出家。受具足戒成苾刍性。由此异门由此意趣义显于彼。本非出家。唯有任持出家相状堕出家数。是名第五不住种姓补特伽罗无种姓相。复有所余不住种姓补特伽罗无种姓相。谓彼少有所作善业。或由于身或语或意。一切皆为希求诸有。或求当来殊胜后有。或求财宝。或求殊胜所有财宝。是名第六不住种姓补特伽罗无种姓相。如是等类有众多相。成就彼故堕在不般涅槃法数

云何安住种姓补特伽罗。谓住种姓补特伽罗。或有唯住种姓而未趣入亦未出离。或有安住种姓亦已趣入而未出离。或有安住种姓亦已趣入及已出离。或有软根或有中根或有利根。或有贪行或有嗔行或有痴行。或生无暇或生有暇。或有纵逸或无纵逸。或有邪行或无邪行。或有障碍或无障碍。或远或近或未成熟或已成熟。或未清净或已清净。

云何名为安住种姓补特伽罗唯住种姓而未趣入亦未出离。谓如有一补特伽罗。成就出世圣法种子。而未获得亲近善士听闻正法。未于如来正觉正说法毗奈耶获得正信。未受持净戒。未摄受多闻。未增长慧舍。未调柔诸见。如是名为唯住种姓而未趣入亦未出离补特伽罗。云何名为安住种姓亦已趣入而未出离补特伽罗。谓前所说所有黑品相违白品。当知即名安住种姓亦已趣入补特伽罗。而差别者。谓犹未得所有圣道及圣道果烦恼离系。云何名为安住种姓亦已趣入及已出离补特伽罗。谓如前说。而差别者。已得圣道及圣道果烦恼离系。云何软根补特伽罗。谓有如是补特伽罗。于所知事所缘境界。所有诸根极迟运转微劣运转。或闻所成。或思所成。或修所成。作意相应。谓或信根或精进根或复念根或复定根或复慧根。无有堪能无有势力通达法义速证真实。是名软根补特伽罗。云何中根补特伽罗。谓有如是补特伽罗。于所知事所缘境界。所有诸根少迟运转。一切如前应当广说。是名中根补特伽罗。云何利根补特伽罗。谓有如是补特伽罗。于所知事所缘境界。所有诸根不迟运转与不微劣运转。或闻所成。或思所成。或修所成。作意相应。谓或信根或精进根或复念根或复定根或复慧根。有所堪能有大势力通达法义速证真实。是名利根补特伽罗。云何贪行补特伽罗。谓有如是补特伽罗。于可爱事可染着事所缘境界。有猛利贪有长时贪。是名贪行补特伽罗。云何嗔行补特伽罗。谓有如是补特伽罗。于可憎事可嗔恚事所缘境界。有猛利嗔。有长时嗔。是名嗔行补特伽罗。云何痴行补特伽罗。谓有如是补特伽罗。于所知事所缘境界。有猛利痴有长时痴。是名痴行补特伽罗。若生无暇。若有纵逸。若有邪行。若有障碍补特伽罗。如是一切如前应知。与此相违。应知即是生于有暇。无有纵逸。无有邪行。无有障碍补特伽罗。云何名远补特伽罗。谓有如是补特伽罗。由时远故去涅槃远。或有复由加行远故说名为远。云何名为由时远故去涅槃远。谓有如是补特伽罗。经多百生或多千生多百千生。然后方能值遇胜缘得般涅槃。云何名为加行远故说名为远。谓有如是补特伽罗。唯住种姓而未趣入。不能速疾值遇胜缘得般涅槃。彼于涅槃未能发起胜加行故。由加行远说名为远。不由时远。如是二种总略为一。说名为远补特伽罗。云何名近补特伽罗。谓有如是补特伽罗。由时近故去涅槃近。或有复由加行近故说名为近。云何名为由时近故去涅槃近。谓有如是补特伽罗。住最后生住最后有住最后身。即由此身当得涅槃。或即由此刹那无间。于烦恼断当得作证。如是名为由时近故去涅槃近。云何名为由加行近说名为近。谓有如是补特伽罗。安住种姓亦已趣入。如是二种总略为一。说名为近补特伽罗。云何未成熟补特伽罗。谓有如是补特伽罗。未能获得最后有身。谓住于此能般涅槃。或能趣入正性离生。是名未成熟补特伽罗。云何已成熟补特伽罗。谓有如是补特伽罗。已能获得最后有身谓住于此能般涅槃。或能趣入正性离生。是名已成熟补特伽罗。云何未清净补特伽罗。谓有如是补特伽罗。未生圣道。于圣道果烦恼离系未能作证。是名未清净补特伽罗。云何已清净补特伽罗。谓与上相违应知其相。如是名为安住种姓补特伽罗所有差别。

为度彼故诸佛世尊出现于世。谓若未趣入令其趣入。若未成熟令其成熟。若未清净令其清净。转正法轮制立学处

    本地分中声闻地第十三初瑜伽处趣入地第二

如是已说种姓地。云何趣入地嗢拖南曰

  若略说一切　　趣入地应知
  谓自性安立　　诸相数取趣

谓若趣入自性。若趣入安立。若趣入者所有诸相。若已趣入补特伽罗。如是一切总略为一。名趣入地

云何趣入自性。谓安住种姓补特伽罗。本性成就涅槃种子。若于尔时有佛出世。生于中国不生达须蔑戾车中。乃至广说。初得见佛及佛弟子。往诣承事从彼闻法得初正信。受持净戒摄受多闻。增长惠舍调柔诸见。从是已后由此法受由此因缘。身灭坏已度此生已。获得六处异熟所摄殊胜诸根。能作长时转胜正信。生起依止亦能与彼受持净戒摄受多闻。增长惠舍调柔诸见。转上转胜转复微妙为所依止。复由如是转上转胜转复微妙信等诸法。更得其余殊胜异熟。由此异熟复得其余随顺出世转胜善法。如是展转互为依因互与势力。于后后生转转胜进。乃至获得最后有身。谓住于此得般涅槃。或能趣入正性离生。是名趣入。何以故。若道若路若正行迹。能得涅槃能趣涅槃。彼于尔时能升能入能正行履。渐次趣向至极究竟。是故说此名已趣入。如是名为趣入自姓

云何建立趣入。谓或有种姓。或有趣入。或有将成熟或有已成熟。或有唯趣入非将成熟非已成熟。或有亦趣入亦将成熟非已成熟。或有亦趣入亦已成熟非将成熟。或有非趣入非将成熟非已成熟。

云何有种姓。谓如前说。云何有趣入。谓住种姓补特伽罗。最初获得昔所未得。于诸如来正觉正说法毗奈耶所有正信。受持净戒摄受多闻。增长惠舍调柔诸见。是名趣入。云何将成熟。谓即如是已得趣入补特伽罗。除所获得最后有身。谓住于此得般涅槃。或能趣入正性离生。从趣入后。于后后生修集诸根转上转胜转复微妙。是名将成熟。云何已成熟。谓所获得最后有身。若住于此得般涅槃。或能趣入正性离生。是名已成熟。云何唯趣入非将成熟非已成熟。谓初获得于诸如来正觉正说法毗奈耶所有正信。广说乃至调柔诸见。未从此后复经一生。是名唯趣入非将成熟非已成熟。云何亦趣入亦将成熟非已成熟。谓初获得于诸如来正觉正说法毗奈耶所有正信。广说乃至调柔诸见。从此已后复经一生或二或多。而未获得最后有身。谓住于此得般涅槃。余如前说。是名亦趣入亦将成熟非已成熟。云何亦趣入亦已成熟非将成熟。谓即如是已得趣入补特伽罗。复已获得最后有身。若住于此得般涅槃。余如前说。是名亦已趣入亦已成熟非将成熟。云何非已趣入非将成熟非已成熟。谓即如是有涅槃法补特伽罗。唯住种姓而未趣入。是名非已趣入非将成熟非已成熟补特伽罗。然有堪能定当趣入当得成熟。复有一类补特伽罗定无堪能当得趣入当得成熟。谓离种姓无涅槃法补特伽罗。当知如是补特伽罗无种姓故。定无堪能当得趣入及当成熟。何况当能得般涅槃。

当知此中如是一切补特伽罗。六位所摄。何等为六。一有堪能补特伽罗。二成就下品善根补特伽罗。三成就中品善根补特伽罗。四成就上品善根补特伽罗。五究竟方便补特伽罗。六已到究竟补特伽罗。

云何堪能补特伽罗。谓安住种姓补特伽罗。而未获得最初于佛正觉正说法毗奈耶。所有正信广说乃至调柔诸见。是名堪能补特伽罗。云何成就下品善根补特伽罗。谓安住种姓补特伽罗。已能获得最初于佛正觉正说法毗奈耶。所有正信广说乃至调柔诸见。是名成就下品善根补特伽罗。云何成就中品善根补特伽罗。谓安住种姓补特伽罗。已能获得最初于佛正觉正说法毗奈耶。所有正信广说乃至调柔诸见。从是已后或经一生或二或多。展转胜进而未获得最后有身。谓住于此能般涅槃。或能趣入正性离生。是名成就中品善根补特伽罗。云何成就上品善根补特伽罗。谓即如是展转胜进补特伽罗。已能获得最后有身。若住于此能般涅槃。或能趣入正性离生。是名成就上品善根补特伽罗。云何名为究竟方便补特伽罗。谓已获得最后有身补特伽罗。为尽诸漏听闻正法。或得无倒教授教诫。正修加行而未能得遍一切种诸漏永尽。未到究竟。如是名为究竟方便补特伽罗。云何名为已到究竟补特伽罗。谓即如是补特伽罗。为尽诸漏听闻正法。获得无倒教授教诫。如是如是正修加行。已能获得遍一切种诸漏永尽所作已办。究竟获得第一清凉。如是名为已到究竟补特伽罗。

当知此中堪能种类补特伽罗。即以种姓为依为住。便能获得下品善根。及能趣入。既趣入已下品善根为依为住。复能获得中品善根。以此善根而自成熟。彼于如是自成熟时。中品善根为依为住。复能获得上品善根。已得成熟。彼由如是上品善根。修集为因所得自体。复能修集转胜资粮。由是触证心一境性。复能趣入正性离生。证预流果或一来果或不还果。而未能证最胜第一阿罗汉果。如是名为究竟方便补特伽罗。若已证得一切烦恼皆悉永断阿罗汉果。尔时名为已到究竟补特伽罗。此则显示由初中后一切声闻所修正行。所立六种补特伽罗。由有种姓声闻正行。显示最初补特伽罗。由到究竟声闻正行。显示最后补特伽罗。由余声闻所修正行。显示中间补特伽罗。

问已得趣入补特伽罗。为有定量一切时等得般涅槃。为无定量一切时分而不齐等得般涅槃。答无有定量。亦非一切时分齐等得般涅槃。然随所应如所遇缘有差别故而般涅槃。当知此中或有一类极经久远。或有一类非极久远。或有一类最极速疾得般涅槃。谓住种姓补特伽罗最极速疾般涅槃者。要经三生。第一生中最初趣入。第二生中修令成熟。第三生中修成熟已。或即此身得般涅槃。或若不得般涅槃者必入学位。方可夭没极经七有得般涅槃。如是名为趣入安立

云何名为已趣入者所有诸相。谓安住种姓补特伽罗才已趣入设转余生。于自大师及善说法毗奈耶中。虽复妄念。若遇世间现有恶说法毗奈耶及有善说法毗奈耶。虽久听闻以无量门赞美恶说法毗奈耶有胜功德。而不信解爱乐修行。亦不于彼而求出家。设暂出家才得趣入。寻复速疾弃舍退还。为性于彼不乐安住。如蜜生虫置之酽酢。或如爱乐受妙欲者置淤泥中。彼由宿世妙善因力所任持故。若暂听闻赞美善说法毗奈耶少分功德。或全未闻。虽暂少闻或全未闻。而能速疾信解趣入爱乐修行或求出家。既出家已毕竟趣入终无退转。为性于此爱乐安住。如蜜生虫。置之上蜜。或如爱乐受妙欲者置胜欲中。彼由宿世妙善因力所任持故。是名第一已得趣入补特伽罗已趣入相。复有所余已得趣入补特伽罗已趣入相。谓虽未得能往一切恶趣无暇。烦恼离系而能不生恶趣无暇。世尊依此已得趣入补特伽罗。蜜意说言。若有世间上品正见。虽历千生不堕恶趣。彼若已入上品善根惭向成熟。尔时便能不生无暇及余恶趣。是名第二已得趣入补特伽罗已趣入相。复有所余已得趣入补特伽罗已趣入相。谓暂闻佛或法或僧胜功德已。便得随念清净信心。引发广大出离善法。数数缘念融练净心。身遂毛竖悲泣雨泪。是名第三已得趣入补特伽罗已趣入相。复有所余已得趣入补特伽罗已趣入相。谓性成就猛利惭愧。于所现行诸有罪处。深生羞耻。是名第四已得趣入补特伽罗已趣入相。复有所余已得趣入补特伽罗已趣入相。谓于受持读诵请问思惟观行求善法中。有深欲乐猛利欲乐。是名第五已得趣入补特伽罗已趣入相。复有所余已得趣入补特伽罗已趣入相。谓于一切无罪事业。修集一切善品加行。正方便中能善修集。坚固发起长时发起决定发起。是名第六已得趣入补特伽罗已趣入相。复有所余已得趣入补特伽罗已趣入相。谓彼为性尘垢微薄烦恼羸劣。虽起诸缠而不长时相续久住。无谄无诳能制憍慢我我所执。好取功德憎背过失。是名第七已得趣入补特伽罗已趣入相。复有所余已得趣入补特伽罗已趣入相。谓能善巧藏护其心。于诸广大所应证处不自轻蔑。不自安处。无力能中。其所信解增多猛盛。是名第八已得趣入补特伽罗已趣入相。如是等类已得趣入补特伽罗已趣入相。

当知无量。我于是中已说少分。如是诸相若有安住下品善根而趣入者。当知下品名有间隙。未能无间。未善清净。若有安住中品善根而趣入者。当知中品。若有安住上品善根而趣入者。当知上品。无有间隙已能无间已善清净。

如是名为已得趣入补特伽罗已趣入相。成就如是趣入相者。当知堕在已趣入数。应知如是安住种姓。已得趣入补特伽罗所有众多吉祥士相。唯佛世尊及到第一究竟弟子。以善清净胜妙智见现见现证。随其种姓随所趣入如应救济

云何名为已得趣入补特伽罗。谓或有已得趣入补特伽罗。唯已趣入未将成熟未已成熟未得出离。或有亦已趣入亦将成熟未已成熟未得出离。或有亦已趣入亦已成熟未得出离。随欲而行。如是差别应知如前已办其相。

复有所余。如种姓地说软根等补特伽罗所有差别。今于此中如其所应亦当了知所有差别。如是所说若趣入自性。若趣入安立。若已趣入者所有诸相。若已趣入补特伽罗。一切总说名趣入地

瑜伽师地论卷第二十一瑜伽师地论卷第二十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三初瑜伽处出离地第三之一

如是已说趣入地。云何出离地。嗢拖南曰

  若世间离欲　　如是出世间
  及此二资粮　　是名出离地

谓若由世间道而趣离欲。若由出世道而趣离欲。若此二道所有资粮。总略为一名出离地。

云何名为由世间道而趣离欲。谓如有一于下欲界观为粗相。于初静虑离生喜乐。若定若生观为静相。彼由多住如是观时便于欲界而得离欲。亦能证入最初静虑。如是复于初静虑上。渐次如应一切下地观为粗相。一切上地观为静相。彼由多住如是观时便于乃至无所有处而得离欲。亦能证入乃至非想非非想处

如是名为由世间道而趣离欲。除此更无若过若增

云何名为由出世道而趣离欲。谓如有一亲近善士。于圣法中已成聪慧。于圣法中已得调顺。于苦圣谛如实知苦。于集圣谛如实知集。于灭圣谛如实知灭。于道圣谛如实知道。既得成就有学智见。从此已后渐修圣道。遍于三界见修所断一切法中。自能离系自得解脱。如是便能超过三界。如是名为由出世道而趣离欲

云何名为二道资粮。嗢拖南曰

  自他圆满善法欲　　戒根律仪食知量
  觉寤正知住善友　　闻思无障舍庄严

谓若自圆满。若他圆满。若善法欲。若戒律仪。若根律仪。若于食知量。若初夜后夜常勤修习觉寤瑜伽。若正知而住。若善友性。若闻正法若思正法。若无障碍。若修惠舍。若沙门庄严。如是等法是名世间及出世间诸离欲道趣向资粮

当知此中若自圆满若他圆满若善法欲。此

三如前修集种子诸劣缘中已辨其相

云何戒律仪。嗢拖南曰

  戒律仪当知　　辨三亏满十
  六异门三诤　　胜功德十种

戒律仪者。谓如有一安住具戒。广说乃至受学学处。

云何名为安住具戒。谓于所受学所有学处。不亏身业。不亏语业。无缺无穿。如是名为安住具戒。云何名为善能守护别解脱律仪。谓能守护七众所受别解脱律仪。即此律仪众差别故成多律仪。今此义中唯依苾刍律仪处。说善能守护别解脱律仪。云何名为轨则圆满。谓如有一或于威仪路。或于所作事。或于善品加行处所。成就轨则。随顺世间不越世间。随顺毗奈耶。不越毗奈耶。云何名为于威仪路。成就轨则。随顺世间不越世间。随顺毗奈耶。不越毗奈耶。谓如有一于所应行于如所行。即于此中如是而行。由是行故不为世间之所讥毁。不为贤良正至善士。诸同法者。诸持律者。诸学律者。之所呵责。如于所行。于其所住所坐所卧当知亦尔。如是名为于威仪路成就轨则。随顺世间不越世间随顺毗奈耶不越毗奈耶。云何名为于所作事成就轨则。随顺世间不越世间。随顺毗奈耶不越毗奈耶。谓如有一于其所作。若衣服事若便利事。若用水事若杨枝事。若入聚落行乞食事。若受用事若荡钵事。若安置事若洗足事。若为敷设卧具等事。即此略说。衣事钵事复有所余如是等类诸所应作名所作事。如其所应于所应作于如所作。即于此中如是而作。由是作故不为世间之所讥毁。不为贤良正至善士。诸同法者。诸持律者。诸学律者。之所呵责。如是名为于所作事成就轨则。随顺世间不越世间。随顺毗奈耶不越毗奈耶。云何名为于诸善品加行处所成就轨则。随顺世间不越世间。随顺毗奈耶不越毗奈耶。谓于种种善品加行。若于正法受持读诵。若于尊长修和敬业参觐承事。若于病者起慈悲心殷重供侍。若于如法宣白加行。住慈悲心展转与欲。若于正法请问听受翘勤无堕。于诸有智同梵行者。尽其身力而修敬事。于他善品常勤赞励。常乐为他宣说正法。入于静室结跏趺坐系念思惟。如是等类诸余无量所修善法。皆说名为善品加行。彼于如是随所宣说善品加行。如其所应于所应作于如所作。即于此中如是而作。由是作故不为世间之所讥毁。不为贤良正至善士。诸同法者。诸持律者。诸学律者。之所呵责。如是名为于诸善品加行处所。成就轨则。随顺世间不越世间。随顺毗奈耶不越毗奈耶。若于如是所说行相轨则差别悉皆具足。应知说名轨则圆满。云何名为所行圆满。谓诸苾刍略有五种非所行处。何等为五。一唱令家。二淫女家。三酤酒家。四国王家。五旃荼罗羯耻那家。若于如是如来所制非所行处能善远离。于余无罪所有行处知时而行。如是名为所行圆满。云何名为于微小罪见大怖畏。谓于诸小随小学处。若有所犯可令还净。名微小罪。于诸学处现行毁犯。说名为罪。既毁犯已少用功力而得还净。说名微小。由是因缘名微小罪。云何于中见大怖畏。谓作是观。勿我于此毁犯因缘无复堪能。得所未得触所未触证所未证。勿我由此近诸恶趣往诸恶趣。或当自责。或为大师诸天有智同梵行者以法呵责。勿我由此遍诸方维恶名恶称恶声恶颂遐迩流布。彼于如是现法当来毁犯因生诸非爱果见大怖畏。由是因缘于小随小所有学处。命难因缘亦不故犯。或时或处失念而犯。寻便速疾如法发露令得还净。如是名为于微小罪见大怖畏。云何名为受学学处。谓于先受别解脱戒白四羯磨。受具戒时从戒师所得闻少分学处体性。复从亲教轨范师处。得闻所余别解脱经。总略宣说过于二百五十学处。皆自誓言一切当学。复从所余恒言议者同言议者常交往者有亲爱者闻所学处。复于半月常所宜说别解脱经。闻所学处一切自誓皆当修学。以于一切所应学处皆受学故。说名获得别解律仪。从此以后于诸学处。若已善巧便能无犯。设有所犯寻如法悔。若诸学处未得善巧未能晓悟。由先自誓愿受持故。得于今时求受善巧欲求晓悟。于如前说诸所学处。从亲教师或轨范师如先请问。既得善巧及晓悟已。随所教诲无增无减。复能受学。又于尊重及等尊重所说学处。若文若义能无倒受。如是名为受学学处。如是广辨戒律仪已。云何应知此中略义。谓于是中世尊显示戒蕴略义有三种相。一者无失坏相。二者自性相。三者自性功德相。此复云何。谓若说言安住具戒。由此显示尸罗律仪无失坏相。若复说言能善守护别解律仪。由此显示尸罗律仪自性相。若复说言轨则所行皆悉圆满。由此显示别解律仪如其所受观他增上自性功德相。所以者何。由他观见如是轨则所行圆满。未信者信信者增长。由是发生清净信处。心无厌恶言不讥毁。若异于此具足尸罗轨则所行皆圆满者。观他增上所有功德胜利应无。与此相违过失应有。若复说言于微小罪见大怖畏受学学处。由此显示别解律仪如其所受观自增上自性功德相。所以者何。虽由如是轨则所行皆悉圆满获得如前观他增上功德胜利。然由毁犯净戒因缘当生恶趣。或无堪能得所未得。如前广说。若能于彼微小罪中见大怖畏。于先所受上品学处能正修学。由是因缘身坏已后当生善趣。亦有堪能得所未得。如前广说。由是因缘说此名为别解律仪。如其所受观自增上功德胜利。复有异门。谓佛世尊此中略显三种戒性。一受持戒性。二出离戒性。三修习戒性。谓若说言安住具戒。由此显示受持戒性。若复说言能善守护别解律仪。由此显示出离戒性。所以者何。别解律仪所摄净戒。当知说名增上戒学。即依如是增上戒学。修增上心增上慧学。由此能得一切苦尽究竟出离。如是出离用增上戒以为前行所依止处。是故说此别解律仪名出离戒性。若复说言轨则所行皆悉圆满。于微小罪见大怖畏受学学处。由此显示修习戒性。所以者何。若由如是所说诸相别解律仪修习净戒。名善修习极善修习。如是一种尸罗律仪现前宣说。当知六种又即如是。

尸罗律仪由十因缘当知亏损。即此相违十因缘故当知圆满。云何十种亏损因缘。一者最初恶受尸罗律仪。二者太极沉下。三者大极浮散。四者放逸懈怠所摄。五者发起邪愿。六者轨则亏损所摄。七者净命亏损所摄。八者堕在二边。九者不能出离。十者所受失坏。云何名为最初恶受尸罗律仪。谓如有一王所逼迫而求出家。或为狂贼之所逼迫。或为债主之所逼迫。或为怖畏之所逼迫。或不活畏之所逼迫而求出家。不为沙门性。不为婆罗门性。不为自调伏。不为自寂静。不为自涅槃。而求出家。如是名为最初恶受尸罗律仪。云何名为大极沉下。谓如有一性无羞耻恶作羸劣。为性慢缓于诸学处所作慢缓。如是名为太极沉下。云何名为太极浮散。调如有一坚执恶取非处恶作。于不应作诸恶作中浪作恶作非处。于他起轻蔑心或恼害心。于其非处强生晓悟。如是名为太极浮散。云何放逸懈怠所摄。谓如有一由过去世毁犯所犯。于此毁犯由失念故。一类不能如法还净。如由过去。由未来世由现在世当知亦尔。谓毁犯所犯。于此毁犯由失念故。一类不能如法还净。又非先时于所毁犯发起猛利无犯乐欲。谓我定当如如所行如如所住。如是如是行于所行。如是如是住于所住。于所毁犯终不毁犯。由是因缘随所行住。如是如是毁犯所犯。由此成就前际俱行后际俱行中际俱行先时所作及俱随行所有放逸。又自执取睡眠为乐偃卧为乐胁卧为乐。性不翘勤为性懒惰不具起发。于诸有智同梵行者。不能时时觐问供事。是名放逸懈怠所摄。云何名为发起邪愿。谓如有一依止邪愿修行梵行。言我所有若戒若禁。若常精勤若修梵行。当得生天或余天处。或复爱乐利养恭敬而修梵行。谓因此故从他希求利养恭敬。即于如是利养恭敬深生染着。如是名为发起邪愿。云何轨则亏损所摄。谓如有一于威仪路或所作事或诸善品加行处所所有轨则。不顺世间违越世间。不顺毗奈耶违越毗奈耶。如前广说。是名轨则亏损所摄。云何净命亏损所摄。谓如有一为性大欲不知喜足难养难满。常以非法追求衣服饮食卧具病缘医药及诸资具。不以正法。又为贪求种种衣服饮食卧具病缘医药资具因缘。方便显己有胜功德。矫诈构集非常威仪。为诳他故恒常诈现诸根无掉诸根无动诸根寂静。由是令他谓其有德。当有所施当有所作。所谓承事供给衣服饮食卧具病缘医药及诸资具。又多凶悖强口矫傲。修饰其名执恃种姓。或求多闻或住持法。为利养故亦复为他宣说正法。或佛所说或弟子说。或自宣说己实有德。或少增益。或于他前方便现相为求衣服。或求随一沙门资具。或为求多或求精妙。虽无匮乏而现被服故蔽衣裳。为令净信长者居士婆罗门等知其衣服有所匮乏。殷重承事给施众多上妙衣服。如为衣服。为余随一沙门资生众具亦尔。或于净信长者居士婆罗门所。如其所欲不得称遂。或彼财物有所阙乏。求不得时即便强逼。研磨粗语而苦求索。或彼财物无所阙乏。得下劣时便对施主。现前毁弃所得财物。如是告言。咄哉男子。某善男子。某善女人。方汝族姓及以财宝。极为下劣又极贫匮。而能惠施如是如是多妙悦意资产众具。汝望于彼族姓尊贵财宝丰饶。何为但施如是少劣非悦意物。彼由如是或依矫诈或邪妄语。或假现相或苦研逼。或利求利种种状相。而从他所非法希求所有衣服饮食卧具病缘医药诸资生具。非以正法而有所求。由非法故说名邪命。如是名为尸罗净命亏损所摄。云何名为堕在二边。谓如有一耽着受用极乐行边从他所得。或法非法所有衣服饮食卧具病缘医药及诸资具。爱玩受用不观过患不知出离。是名一边。复有一类好求受用自苦行边。以无量门而自煎迫受极苦楚。谓依棘刺或依灰坌或依木杵或依木板。或狐蹲住或狐蹲坐修断瑜伽。或复事火。谓乃至三承事于火。或复升水。谓乃至三升上其水。或一足住随日而转。或复所余如是等类修自苦行。是第二边。如是名为堕在二边。云何名为不能出离。谓如有一或戒或禁由见执取。谓我因此若戒若禁当得清净解脱出离。一切外道所有禁戒。虽善防护虽善清净。如其清净不名出离。如是名为不能出离。云何名为所受失坏。谓如有一都无羞耻不顾沙门。毁犯净戒习诸恶法。内怀腐败外现贞实。犹如净水所生蜗牛螺音狗行。实非沙门自称沙门。实非梵行自称梵行。如是名为所受失坏。略由如是十种因缘名戒亏损。世尊或说尸罗亏损。或时复说尸罗艰难。当知于彼诸因缘中由二因缘。谓不能出离。及所受失坏。由余因缘当知唯说尸罗亏损。

与此安立黑品因缘。相违白品所有因缘。当知说名尸罗圆满尸罗清净。

有处世尊宣说尸罗名为根本。如伽他说

  若善住根本　　其心便寂静
  因圣见恶见　　相应不相应

有处世尊宣说尸罗名庄严具。如伽他说

  苾刍苾刍尼　　戒庄严圆满
  于不善能舍　　于善能修习

有处世尊宣说尸罗名为涂香。如伽他说

  苾刍苾刍尼　　戒涂香圆满
  于不善能舍　　于善能修习

有处世尊宣说尸罗名为薰香。如伽他说

  阿难有香类　　顺风善能薰
  逆风亦能薰　　顺逆薰亦尔

有处世尊宣说尸罗名为妙行。如伽他说

  身妙行能感　　可爱诸异熟
  于现法当来　　语妙行亦尔

有处世尊宣说尸罗名为律仪。如伽他说

  诸有惠施主　　具戒住律仪
  有阿笈摩见　　及有果正见

复有说言。安住具戒。善能守护别解律仪。乃至广说。问何缘世尊宣说尸罗名为根本。答能建立义能任持义。是根本义。由此尸罗建立任持一切世间及出世间。能引无罪最胜第一快乐功德。令生令证。是故尸罗说名根本。譬如大地建立任持一切药草卉木丛林令生令长。如是尸罗如前广说。问何缘世尊宣说尸罗名庄严具。答诸余世间耳环指环腕钏臂钏及以宝印金银鬘等妙庄严具。若有成就幼稚黑发少年盛壮姝妙形色而服饰之少增妙好。非有成就朽老衰迈齿落发白年逾八十或九十者而服饰之当有妙好。唯除俳戏令众欢笑。若遭病苦财货匮乏亲戚丧亡。当尔服之亦无妙好。戒庄严具于一切类于一切时若有服者皆为妙好。是故尸罗名庄严具。问何缘世尊宣说尸罗名为涂香。答由此所受清净无罪妙善尸罗。能正除遣一切所受恶戒为因身心热恼。譬如最极炎炽热时涂以栴檀龙脑香等一切郁蒸皆得除灭。是故尸罗说名涂香。问何缘世尊宣说尸罗名为薰香。答具戒士夫补特伽罗遍诸方域。妙善称誉声颂普闻。譬如种种根茎香等随风飘扬遍诸方所悦意芬馥周流弥远。是故尸罗名为薰香。问何缘世尊宣说尸罗名为妙行。答由此尸罗清净善行。能趣妙药往妙天趣。向妙安隐故名妙行。问何缘世尊宣说尸罗名为律仪。答由此尸罗清净善法。是防护性。是息除相。是远离体故名律仪。

又戒律仪有三种观清净因相。何等为三。一观身业。二观语业。三观意业。云何观察如是诸业。令戒律仪皆得清净。谓希当造及欲正造。身作业时如是观察。我此身业为能自损及以损他是不善性能生众苦招苦异熟。为不自损亦不损他是其善性能生诸乐招乐异熟。如是观已。若自了知我此身业自损损他。是不善性能生众苦招苦异熟。即于此业摄敛不作亦不与便。若自了知我此身业不损自他是其善性。余如前说。即于此业而不摄敛造作与便。复于过去已造身业。亦数观察我此身业为能自损。余如前说。如是观已。若自了知我此身业自损损他。余如前说。便于有智同梵行所。如实发露如法悔除。若自了知我此身业不损自他。余如前说。便生欢喜昼夜安住多随修学。如是彼于去来今世所造身业。能善观察能善清净。如于身业。于其语业当知亦尔。由过去行为缘生意。由未来行为缘生意。由现在行为缘生意。即于此意数数观察我此意业。为能自损。余如前说。如是观已。若自了知我此意业是其黑品即于此业摄敛不起不与其便。若自了知我此意业是其白品。即于此业而不敛摄发起与便。如是于彼去来今世所起意业。能善观察能善清净。所以者何。去来今世所有沙门若婆罗门。于身语意三种业中。或已观察或当观察或正观察。或已清净或当清净或正清净。或已多住或当多住或正多住。一切皆由如是观察如是清净。如佛世尊曾为长老罗怙罗说

  汝今罗怙罗　　于身语意业
  应数正观察　　念诸佛圣教
  罗怙罗汝应　　学是沙门业
  若能于此学　　唯胜善无恶

若于如是身语意业审正思择。诸此诸业为能自损。广说如前。是名观察。若于一分摄敛不作亦不与便。广说乃至发露悔除。复于一分而不敛摄造作与便。广说乃至便生欢喜。昼夜安住多随修学。是名清净。

如是清净尸罗律仪。应知有十功德胜利。何等为十。谓诸所有具戒士夫补特伽罗。自观戒净便得无悔。无悔故欢欢故生喜。由心喜故身得轻安。身轻安故便受胜乐。乐故心定。心得定故能如实知能如实见。实知见故便能起厌。能起厌故便得离染。由离染故证得解脱。得解脱故便自知见我已解脱乃至我能于无余依般涅槃界当般涅槃。如是所有具戒士夫补特伽罗。尸罗清净增上力故获得无悔。渐次乃至能到涅槃。是名第一尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。于临终时起如是念。我已善作身语意行。非我恶作身语意行。乃至广说。若有其趣作福业者作善业者作能救济诸怖畏者之所应往。我于斯趣必定当往。如是获得能往善趣。第二无悔由无悔恨所有士夫补特伽罗。名贤善死贤善夭逝贤善过往。是名第二尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。遍诸方域妙善称誉声颂普闻。是名第三尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。寝安觉安远离一切身心热恼。是名第四尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。若寝若觉诸天保护是名第五尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。于他凶暴不虑其恶。无诸怖畏心离惊恐。是名第六尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。诸喜杀者怨仇恶友虽得其隙。亦常保护了知此是具戒士夫补特伽罗。或为善友或住中平。是名第七尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。一切魍魉药叉宅神非人之类。虽得其便虽得其隙。而常保护。谓具尸罗增上力故。是名第八尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。法无艰难从他获得种种利养。所谓衣服饮食卧具病缘医药及诸资具。由依尸罗增上因力。国王大臣及诸黎庶饶财长者及商主等恭敬尊重。是名第九尸罗律仪功德胜利。复有所余具戒士夫补特伽罗。一切所愿皆得称遂。若于欲界愿乐当生或刹帝利大族姓家或婆罗门大族姓家或诸居士大族姓家或诸长者大族姓家或四大王众天或三十三天或夜摩天或睹史多天或化乐天或他化自在天众同分中。由戒净故即随所愿当得往生。若复愿乐入诸静虑现法乐住或有色天众同分中若住若生。由戒净故便得离欲所愿皆遂。若复愿乐寂静胜解。超过色定入无色定具足安住。或无色天众同分中当得往生。余如前说。若复愿乐当证最极究竟涅槃。由戒净故便证一切究竟离欲。是名第十尸罗律仪功德胜利。如是已说戒蕴。广辨戒蕴亏损。戒蕴圆满。戒蕴异门。戒蕴观察及以清净戒蕴所有功德胜利。于此宣说明了开示一切种相最极圆满资粮所摄尸罗律仪。若有自爱乐沙门性婆罗门性诸善男子。应勤修学

瑜伽师地论卷第二十二瑜伽师地论卷第二十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三初瑜伽处出离地第三之二

云何根律仪。谓如有一能善安住密护根门。防守正念常委正念。乃至广说。云何名为密护根门。谓防守正念常委正念。广说乃至防护意根。及正修行意根律仪。如是名为密护根门。云何名为防守正念。谓如有一密护根门增上力故。摄受多闻。思惟修习。由闻思修增上力故获得正念。为欲令此所得正念无忘失故。能趣证故。不失坏故。于时时中即于多闻若思若修正作瑜伽。正勤修习不息加行。不离加行。如是由此多闻思修所集成念。于时时中善能防守正闻思修瑜伽作用。如是名为防守正念。云何名为常委正念。谓于此念恒常所作委细所作。当知此中恒常所作名无间作。委细所作名殷重作。即于如是无间所作殷重所作。总说名为常委正念。如其所有防守正念。如是于念能不忘失。如其所有常委正念。如是即于无忘失念得任持力。即由如是功能势力。制伏色声香味触法。云何名为念防护意。谓眼色为缘生眼识。眼识无间生分别意识。由此分别意识。于可爱色色将生染着。于不可爱色色将生憎恚。即由如是念增上力。能防护此非理分别起烦恼意。令其不生所有烦恼。如是耳鼻舌身广说当知亦尔。意法为缘生意识。即此意识有与非理分别俱行能起烦恼。由此意识于可爱色法将生染着。于不可爱色法将生憎恚。亦由如是念增上力。能防护此非理分别起烦恼意。令其不生所有烦恼。如是名为念防护意。云何名为行平等位。平等位者。谓或善舍或无记舍。由彼于此非理分别起烦恼意善防护已。正行善舍无记舍中。由是说名行平等位。如是名为行平等位。云何于此非理分别起烦恼意能善防护。谓于色声香味触法。不取其相不取随好。终不依彼发生诸恶不善寻思令心流漏。若彼有时忘失念故。或由烦恼极炽盛故。虽离取相及取随好。而复发生恶不善法令心流漏。便修律仪。由是二相故。能于此非理分别起烦恼意能善防护。云何此意由是二相善防护已。正行善舍或无记舍。谓即由是二种相故。云何二相。谓如所说防护眼根。及正修行眼根律仪。如说眼根防护律仪。防护耳鼻舌身意根。及正修行意根律仪当知亦尔。由是二相。于其善舍无记舍中。令意正行。云何于眼所识色中不取其相。言取相者。谓于眼识所行色中。由眼识故取所行相。是名于眼所识色中执取其相。若能远离如是眼识所行境相。是名于眼所识色中不取其相。如于其眼所识色中。如是。于耳鼻舌身意所识法中当知亦尔。云何于眼所识色中不取随好。取随好者。谓即于眼所识色中。眼识无间俱生分别意识。执取所行境相。或能起贪或能起嗔或能起痴。是名于眼所识色中执取随好。若能远离此所行相。于此所缘不生意识。是名于眼所识色中不取随好。如于其眼所识色中。如是。于耳鼻舌身意所识法中当知亦尔。复有余类执取其相执取随好。言取相者。谓色境界。在可见处能生作意。正现在前眼见众色。如是名为执取其相。取随好者。谓即色境在可见处能生作意。正现在前眼见色已。然彼先时从他闻有如是如是眼所识色。即随所闻名句文身。为其增上为依为住。如是士夫补特伽罗。随其所闻种种分别眼所识色。如是名为执取随好。如于其眼所识色中。如是。于耳鼻舌身意所识法中当知亦尔。又此取相及取随好。或有由此因缘。由此依处。由此增上。发生种种恶不善法令心流漏。或有由此因缘。由此依处。由此增上。不生种种恶不善法令心流漏。若于此中执取其相。执取随好。不如正理。由此因缘。由此依处。由此增上。发生种种恶不善法令心流漏。彼于如是色类境界。远离取相及取随好。云何名为恶不善法。谓诸贪欲及贪所起诸身恶行。诸语恶行。诸意恶行。若诸嗔恚若诸愚痴及二所起诸身恶行。诸语恶行。诸意恶行。是名种种恶不善法。云何由彼令心流漏。谓若于彼彼所缘境界。心意识生游行流散。即于彼彼所缘境界。与心意识种种相应。能起所有身语恶行。贪嗔痴生游行流散。是名由彼令心流漏。如是于眼所识色中。乃至于意所识法中。执取其相及取随好。由是发生种种杂染。彼于取相及取随好能远离故。便不发生种种杂染。若由忘念或由烦恼极炽盛故。虽独闲居由先所见眼所识色增上力故。或先所受耳鼻舌身意所识法增上力故。发生种种恶不善法。随所发生而不执着。寻便断灭除弃变吐。是名于彼修行律仪。若于其眼所识色中应策眼根。及于其耳鼻舌身意所识法中应策意根。即便于彼作意策发。如是策发令不杂染。由是因缘于此杂染防护眼根。广说乃至防护意根。如是名为防护眼根。广说乃至防护意根。若于其眼所识色中。不应策发所有眼根。及于其耳鼻舌身意所识法中。不应策发所有意根。即便于彼遍一切种而不策发。不策发故令不杂染。由是因缘于此杂染修根律仪。如是名为能正修行眼根律仪。广说乃至能正修行意根律仪。如是应知已广分别根律仪相。

云何当知此中略义。此略义者。谓若能防护。若所防护。若从防护。若如防护。若正防护。如是一切总略为一名根律仪。今于此中谁能防护。谓防守正念及所修习常委正念。是能防护。何所防护。谓防护眼根。防护耳鼻舌身意根。是所防护。从何防护。谓从可爱不可爱色。广说乃至从其可爱不可爱法而正防护。如何防护。谓不取相不取随好。若依是处发生种种恶不善法令心流漏。即于此处修行律义防守根故。名修律仪。如是防护。何者正防护。谓由正念防护于意行平等位。是名正防护。又略义者。谓若防护方便。若所防护事。若正防护。如是一切总略为一名根律仪。此中云何防护方便。谓防守正念常委正念。眼见色已不取其相不取随好。广说乃至意知法已不取其相不取随好。若依是处发生种种恶不善法令心流漏。即于是处修行律仪防守根故。名修律仪。如是名为防护方便。云何名为所防护事。所谓眼色乃至意法。如是名为所防护事。此中云何名正防护。谓如说言由其正念。防护于意。行平等位。名正防护。又根律仪略有二种。一者思择力所摄。二者修习力所摄。思择力所摄根律仪者。谓于境界深见过患。不能于此所有过患除遣断灭。修习力所摄根律仪者。谓于境界深见过患。亦能于此所有过患除遣断灭。又由思择力所摄根律仪故。于所缘境令烦恼缠不复生起。不复现前。而于依附所依随眠。不能断除不能永拔。由修习力所摄根律仪故。于所缘境烦恼随眠不复生起。不复现前。一切时分依附所依所有随眠亦能断除。亦能永拔。如是思择力所摄根律仪。修习力所摄根律仪。有此差别。有此意趣。有此殊异。当知此中思择力所摄根律仪。是资粮道所摄。修习力所摄根律仪。当知堕在离欲地摄。

云何名为于食知量。谓如有一由正思择食于所食。不为倡荡。不为憍逸。不为饰好不为端严。乃至广说。云何名为由正思择食于所食。正思择者。如以妙慧等随观察段食过患。见过患已深生厌恶。然后吞咽。云何名为观见过患。谓即于此所食段食。或观受用种类过患。或观变异种类过患。或观迫求种类过患。云何受用种类过患。谓如有一将欲食时。所受段食色香味触皆悉圆满甚为精妙。从此无间进至口中。牙齿咀嚼。津唾浸烂。涎液缠裹。转入咽喉。尔时此食先曾所有悦意妙相一切皆舍。次后转成可恶秽相。当转异时状如变吐。能食士夫补特伽罗。若正思念此位秽相。于余未变一切精妙所受饮食。初尚不能住食欣乐。况于此位。由如是等非一相貌。渐次受用增上力故。令其饮食净妙相没过患相生。不净所摄。是名于食受用种类所有过患。云何转变种类过患。谓此饮食既啖食已。一分消变至中夜分或后夜分。于其身中便能生起养育增长。血肉筋脉。骨髓皮等。非一众多种种品类诸不净物。次后一分变成便秽。变已趣下展转流出。由是日日数应洗净或手或足或余支节。误触着时若自若他皆生厌恶。又由此缘发生身中多种疾病。所谓痈痤干癣。湿癣疥癞。疸疔上气。疨嗽疱浆。哕噎干消。癫痫寒热。黄病热血。阴[病-丙+追]。如是等类无量疾病。由饮食故身中生起。或由所食不平和故。于其身中不消而住。是名饮食变异种类所有过患。云何追求种类过患。谓于饮食追求种类有多过患。或有积集所作过患。或有防护所作过患。或坏亲爱所作过患。或无厌足所作过患。或不自在所作过患。或有恶行所作过患。云何名为于食积集所作过患。谓如有一为食因缘。寒时为寒之所逼恼。热时为热之所逼恼。种种策励劬劳勤苦。营农牧牛商估计算。书数雕印及余种种工巧业处。为得未得所有饮食或为积聚。如为饮食。为饮食缘当知亦尔。如是策励劬劳勤苦方求之时。所作事业若不谐遂。由是因缘愁忧燋恼。拊胸伤叹悲泣迷闷。何乃我功唐捐无果。如是名为于食积集所作过患。云何名为于食防护所作过患。谓所作业若得谐遂。为护因缘起大忧虑。勿我财宝当为王贼之所侵夺。或火焚烧或水漂荡。或宿恶作当令灭坏。或现非理作业方便当令散失。或诸非爱或宿共财当所理夺。或即家中当生家火。由是当令财宝亏损。如是名为于食防护所作过患。云何于食能坏亲爱所作过患。谓诸世间为食因缘多起斗诤。父子母女兄弟朋友尚为饮食互相非毁。况非亲里为食因缘而不展转更相斗讼。所谓大族诸婆罗门刹帝利种长者居士。为食因缘迭兴违诤。以其手足块刀杖等互相加害。是名于食能坏亲爱所作过患。云何于食无有厌足所作过患。谓诸国王刹帝利种位登灌顶。亦于自国王都聚落不住喜足。俱师兵戈互相征讨。吹以贝角扣击钟鼓挥刀槃槊放箭[矛*(替-曰+貝)]矛。车马象步交横驰乱。种种戈仗伤害其身。或便致死或等死苦。复有所余如是等类。是名于食无有厌足所作过患。云何因食不得自在所作过患。谓如一类为王所使讨固牢城。因遭种种极热脂油。热牛粪汁。及镕铜铁而相注洒。或被戈杖伤害其身。或便致死或等死苦。复有所余如是等类。是名因食不得自在所作过患。云何因食起诸恶行所作过患。谓如有一为食因缘。造作积集身诸恶行。如身恶行语意亦尔。临命终时。为诸重病苦所逼切。由先所作诸身语意种种恶行增上力故。于日后分见有诸山或诸山峰垂影悬覆近覆极覆。便作是念。我自昔来依身语意所造诸业唯罪非福。若有其趣诸造恶者当生其中。我今定往。如是悔已寻即舍命。既舍命已随业差别生诸恶趣。谓那洛迦傍生饿鬼。如是名为因食恶行所作过患。如是段食于追求时。有诸过患。于受用时。有诸过患。于转变时。有诸过患。又此段食有少胜利。此复云何。谓即此身由食而住依食而立。非无有食。云何名为有少胜利。谓即如是依食住身。最极久住或经百年。若正将养或过少分。或有未满而便夭没。若唯修此身暂住行非为妙行。若于如是身暂时住而生喜足非妙喜足。亦非领受饮食所作圆满无罪功德胜利。若不唯修身暂住行。亦不唯于身暂时住而生喜足。而即依此暂时住身修集梵行令得圆满。乃为妙行亦妙喜足。又能领受饮食所作圆满无罪功德胜利。应自思惟。我若与彼愚夫。同分修诸愚夫同分之行。非我所宜。我若于此下劣段食少分胜利。安住喜足。亦非我宜。若于如是遍一切种段食过患。圆满知已。以正思择。深见过患而求出离。为求如是食出离故。如子肉想食于段食。应作是念。彼诸施主甚大艰难积集财宝。具受广大追求所作种种过患。由悲愍故求胜果故。如割皮肉及以刺血而相惠施。我得此食宜应如是方便受用。谓应如法而自安处。无倒受用报施主恩。令获最胜大果大利大荣大盛。当随月喻往施主家。荡涤身心安住惭愧。远离憍傲不自高举。不轻蔑他。如自获得所有利养心生喜悦。如是于他所得利养。心亦喜悦。又应如是自持其心往施主家。岂有出家往诣他所。要望他施。非不惠施。要望他敬非不恭敬。要多非少要妙非粗。要当速疾而非迟缓。应作是心。往施主家。设不惠施终不于彼起怨害心及嗔恚心而相嫌恨。勿我由此起怨害心及嗔恚心。增上缘力。身坏已后生诸恶趣多受困厄。设不恭敬而非恭敬。设少非多设粗非妙。设复迟缓而非速疾。亦不于彼起怨害心及嗔恚心而相嫌恨。如前广说。又我应依所食段食发起如是如是正行。及于其量如实了达。谓我命根由此不灭。又于此食不苦耽着。才能随顺摄受梵行。如是我今住沙门性。住出家性。受用饮食。如法清净远离众罪。由是诸相以正思择食于所食。云何所食。谓四种食。一者段食。二者触食。三者意等思食。四者识食。今此义中意说段食。此复云何。谓饼糗饭羹。臛糜粥酥油糖蜜鱼肉。葅鲊乳酪。生酥姜盐酢等种种品类。和杂为抟段段吞食。故名段食。所言食者。所谓餐啖咀嚼。吞咽尝啜饮等。名之差别。云何名为不为倡荡。谓如有一乐受欲者。为受诸欲食于所食。彼作是思。我食所食令身饱满令身充悦。过日晚时至于夜分。当与姝妙严饰女人共为嬉戏欢娱受乐倡掉纵逸。言倡荡者。于此圣法毗奈耶中。说受欲者。欲贪所引。淫逸所引。所有诸恶不善寻思由此食啖。所食啖时令其诸根皆悉掉举。令意躁扰令意不安令意不静。若为此事食所食者。名为倡荡食于所食。诸有多闻圣弟子众。以思择力深见过患。善知出离而食所食。非如前说诸受欲者食于所食。是故名为不为倡荡。云何名为不为憍逸。不为饰好。不为端严。谓如有一乐受欲者。为受诸欲食于所食。彼作是思。我今宜应多食所食饱食所食。随力随能食啖肥腻。增房补益色香味具精妙饮食。过今夜分至于明日。于角武事当有力能。所谓按摩拍鞠托石跳踯蹴蹋。攘臂扼腕挥戈击剑。伏弩控弦投轮掷索。依如是等诸角武事。当得勇健肤体充实。长夜无病久时少壮。不速衰老寿命长远。能多啖食数数食已。能正消化除诸疾患。如是为于无病憍逸。少壮憍逸。长寿憍逸而食所食。既角武已复作是思。我应沐浴。便以种种清净香水沐浴其身。沐浴身已梳理其发。梳理发。已种种妙香用涂其身。既涂身已复以种种上妙衣服。种种花鬘种种严具。庄饰其身。此中沐浴理发涂香名为饰好。既饰好已复以种种上妙衣服花鬘严具。庄饰其身名为端严。如是总名为饰好故为端严故食于所食。彼既如是憍逸饰好身端严已。于日中分或日后分。临欲食时饥渴并至。于诸饮食极生悕欲。极欣极乐不见过患不知出离。随得随食复为数数倡荡憍逸饰好端严。多食多饮令身充悦。诸有多闻圣弟子众。以思择力深见过患。善知出离而食所食。非如前说诸受欲者食于所食。唯作是念。我今习近所不应习所应断食。为欲永断如是食故。云何名为为身安住食于所食。谓饮食已寿命得存。非不饮食寿命存故名身安住。我今受此所有饮食。寿命得存当不夭没。由是因缘身得安住。能修正行永断诸食。云何名为为暂支持食于所食。谓略说有二种存养。一有艰难存养。二无艰难存养。云何名为有艰难存养。谓受如是所有饮食。数增饥羸困苦重病。或以非法追求饮食。非以正法。得已染爱耽嗜饕餮。迷闷坚执湎着受用。或有食已令身沉重。无所堪能不任修断。或有食已令心迟钝不速得定。或有食已令入出息来往艰难。或有食已令心数为惛沉睡眠之所缠扰。如是名为有艰难存养。云何名为无艰难存养。谓受如是所有饮食。令无饥羸。无有困苦及以重病。或以正法追求饮食。不以非法。既获得已不染不爱。亦不耽嗜饕餮。迷闷坚执湎着而受用之。如是受用身无沉重有所堪能。堪任修断令心速疾得三摩地。令入出息无有艰难。令心不为惛沉睡眠之所缠扰。如是名为无艰难存养。若由有艰难存养。寿命得存身得安住。此名有罪亦有染污。若由无艰难存养。寿命得存身得安住。此名无罪亦无染污。诸有多闻圣弟子众。远离有罪有染存养。习近无罪无染存养。由是故说为暂支持。问云何习近如前所说无罪无染所有存养。以自存活。答若受饮食为除饥渴为摄梵行。为断故受。为令新受当不更生。为当存养力乐无罪安隐而住。如是习近无罪无染所有存养。而自存活。云何名为为除饥渴受诸饮食。谓至食时多生饥渴。气力虚羸希望饮食。为欲息此饥渴缠逼气力虚羸。知量而食。如是食已令于非时不为饥羸之所缠逼。谓于日晚或于夜分乃至明日未至食时。如是名为为除饥渴受诸饮食。云何名为为摄梵行受诸饮食谓知其量受诸饮食。由是因缘修善品者。或于现法或于此日。饮食已后身无沉重有所堪能。堪任修断令心速疾得三摩地。令入出息无有艰难。令心不为惛沉睡眠之所缠扰。由是速疾有力有能。得所未得。触所未触。证所未证。如是名为为摄梵行受诸饮食。云何名为为断故受受诸饮食。谓如有一由过去世食不知量。食所匪宜不消而食。由是因缘于其身中。生起种种身诸疾病。所谓疥癞疱浆嗽等。如前广说。由此种种疾病因缘。发生身中极重猛利炽然苦恼不可意受。为欲息除如是疾病。及为息除从此因缘所生苦受。习近种种良医所说饶益所宜。随顺医药及受种种悦意饮食。由此能断已生疾病。及彼因缘所生苦受。如是名为为断故受受诸饮食。云何名为为令新受当不更生受诸饮食。谓如有一由现在世安乐无病气力具足。不非量食不食匪宜。亦非不消而更重食。令于未来食住身中成不消病。或于身中当生随一身诸疾病。所谓疥癞疱浆嗽等。如前广说。由是因缘当生身中如前所说种种苦受。余如前说。如是名为为令新受当不更生受诸饮食。云何名为为当存养力乐无罪安隐而住受诸饮食。谓饮食已寿命得存是名存养。若除饥羸是名为力。若断故受新受不生是名为乐。若以正法追求饮食不染不爱。乃至广说而受用之。是名无罪。若受食已身无沉重。有所堪能堪任修断如前广说。如是名为安隐而住。是故说言由正思择食于所食。不为倡荡。不为憍逸。不为饰好。不为端严。乃至广说。是名广辨于食知量。

云何应知此中略义。谓若所受食若如是食。当知总名此中略义。何者所食。谓诸段食即饼糗饭羹臛糜粥。如前广说。云何而食。谓正思择食于所食。不为倡荡。不为憍逸。不为饰好。不为端严。乃至广说。复次应知此中略义。谓为摄受对治。为远离欲乐行边。为远离自苦行边。为摄受梵行。受诸饮食。云何为摄受对治受诸饮食。谓如说言由正思择食于所食。云何为远离欲乐行边受诸饮食。谓如说言不为倡荡。不为憍逸。不为饰好。不为端严。食于所食。云何为远离自苦行边受诸饮食。谓如说言为除饥渴。为断故受。为令新受当不更生为当存养若力若乐。食于所食。云何为摄受梵行受诸饮食。谓如说言为摄梵行。为得无罪安隐而住。食于所食。复次应知此中略义。谓有二种。一无所食。二有所食。无所食者。谓一切种都无所食。无所食故即便夭没。有所食者。有其二种。一平等食。二不平等食。平等食者。谓非极少食。非极多食。非不宜食。非不消食。非染污食。不平等食者。谓或极少食。或极多食。或不宜食。或不消食。或染污食。当知此中由平等食非极少食。令身饥羸未生不生已生断灭。由平等食非极多食。身无沉重有所堪能堪任修断。如前广说。由平等食非不宜食。非不消食。能断故受不生新受。由是因缘当得存养若力若乐。由平等食非染污食。当得无罪安隐而住。由极少食。虽存寿命而有饥羸亦少存活。由极多食。如极重担镇压其身。不能以时所食消变。由不消食或住身中。成不消病。或生随一身诸病苦。如不消食。由不宜食当知亦尔。此不宜食有差别者。谓于身中集诸过患。由此复触极重病苦。由染污食。非法追求诸饮食已。有染有爱耽嗜饕餐。如前广说而受用之。由此受用平等所食。及以远离不平等食。故说于食平等所作。即此于食平等所作。广以诸句宣示开显。所谓说言由正思择食于所食。不为倡荡。不为憍逸。不为饰好。不为端严。如前广说。此中说言。由正思择食于所食。不为倡荡。不为憍逸。不为饰好。不为端严。为身安住为暂支持。由此遮止都无所食。若复说言为除饥渴。为摄梵行。广说乃至安隐而住。由此遮止不平等食。云何遮止不平等食。谓若说言为除饥渴。由此遮止所食极少。若复说言为摄梵行。由此遮止所食极多若复说言为断故受。为令新受当不更生。由此遮止不消而食食所匪宜。若复说言为当存养为当得力。由此显示不极少食不极多食。若复说言为当得乐。由此显示消已而食及食所宜。若复说言为当无罪安隐而住。由此显示无染污食。所以者何。若以非法追求饮食。得已染爱如前广说而受用之。名染污食亦名有罪。若于善品勤修习者。于住空闲瑜伽作意。受持读诵思惟义中。由彼诸恶不善寻思。令心流漏令心相续。随顺趣向临入而转。由是因缘不安隐住。此安隐住复有二种。一者远离所食极多。由是因缘身无沉重。有所堪能堪任修断。如前广说。二者于食不生味着。由是因缘远离诸恶寻思扰动不安隐住。

是故如此一切诸句皆为宣示开显于食平等所作如是名为广略宣说于食知量

瑜伽师地论卷第二十三瑜伽师地论卷第二十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三初瑜伽处出离地第三之三

复次初夜后夜常勤修习觉寤瑜伽者。云何初夜云何后夜。云何觉寤瑜伽。云何常勤修习觉寤瑜伽。

言初夜者。谓夜四分中过初一分是夜初分。言后夜者。谓夜四分中过后一分是夜后分。觉寤瑜伽者。谓如说言于昼日分经行宴坐。从顺障法净修其心。于初夜分经行宴坐。从顺障法净修其心。净修心已出住处外洗濯其足。还入住处右胁而卧重累其足。住光明想正念正知思惟起想巧便而卧。至夜后分速疾觉寤经行宴坐。从顺障法净修其心。常勤修习觉寤瑜伽者。谓如有一世尊弟子。听闻觉寤瑜伽法已。欲乐修学。便依如是觉寤瑜伽。作如是念。我当成办佛所听许觉寤瑜伽。发生乐欲精进勤劬。超越勇猛势力发起。勇悍刚决不可制伏。策励其心无间相续。此中云何于昼日分经行宴坐。从顺障法净修其心。言昼日者。谓从日出时至日没时。言经行者。谓于广长称其度量一地方所。若往若来相应身业。言宴坐者。谓如有一或于大床或小绳床。或草叶座结加趺坐。端身正愿安住背念。所言障者。谓五种盖。顺障法者。谓能引盖随顺盖法。云何五盖。谓贪欲盖嗔恚盖。惛沉睡眠盖掉举恶作盖。及以疑盖。云何顺障法。谓净妙相嗔恚相黑闇相亲属国土不死。寻思追忆昔时笑戏喜乐承事随念及以三世。或于三世非理法思。问于经行时从几障法净修其心。云何从彼净修其心。答从惛沉睡眠盖及能引惛沉睡眠障法。净修其心。为除彼故。于光明想善巧精恳。善取善思善了善达。以有明俱心及有光俱心。或于屏处或于露处往返经行。于经行时随缘一种净妙境界。极善示现劝导赞励庆慰其心。谓或念佛或法或僧。或戒或舍或复念天。或于宣说惛沉睡眠过患相应所有正法。于此法中为除彼故。以无量门诃责毁呰惛沉睡眠所有过失。以无量门称扬赞叹惛沉睡眠永断功德。所谓。契经应颂。记别讽诵。自说因缘。譬喻本事。本生方广。希法及以论议。为除彼故。于此正法听闻受持。以大音声若读若诵。为他开示思惟其义。称量观察。或观方隅。或瞻星月诸宿道度。或以冷水洗洒面目。由是惛沉睡眠缠盖。未生不生已生除遣。如是方便从顺障法净修其心。问于宴坐时从几障法净修其心。云何从彼净修其心。答从四障法净修其心。谓贪欲嗔恚。掉举恶作。疑盖及能引彼法。净修其心。为令已生贪欲缠盖速除遣故。为令未生极远离故。结加趺坐端身正愿安住背念。或观青瘀或观脓烂。或观变坏或观膖胀。或观食啖或观血涂。或观其骨或观其锁。或观骨锁。或于随一贤善定相。作意思惟。或于宣说贪欲过患相应正法。于此法中为断贪欲。以无量门。诃责毁呰欲贪欲爱。欲藏欲护。欲着过失。以无量门。称扬赞叹一切贪欲永断功德。所谓契经应颂记别乃至广说。为断贪欲。于此正法听闻受持。言善通利。意善寻思。见善通达。即于此法如是宴坐如理思惟。由是因缘贪欲缠盖未生不生已生除遣。如是方便从顺障法净修其心。于嗔恚盖法有差别者。谓如是宴坐以慈俱心。无怨无敌。无损无恼。广大无量极善修习。普于一方发起胜解具足安住。如是第二如是第三如是。第四上下傍布。普遍一切无边世界。发起胜解具足安住。余如前说。于掉举恶作盖法有差别者。谓如是宴坐。令心内住成办一趣得三摩地。余如前说于疑盖法有差别者。谓如是宴坐。于过去世非不如理作意思惟。于未来世于现在世非不如理作意思惟。我于过去为曾有耶。为曾无耶。我于过去为曾何有。云何曾有。我于未来为当何有。云何当有。我于现在为何所有。云何而有。今此有情从何而来。于此殒没当往何所。于如是等不如正理作意思惟应正远离。如理思惟。去来今世唯见有法。唯见有事。知有为有知无为无。唯观有因唯观有果。于实无事不增不益。于实有事不毁不谤。于其实有了知实有。谓于无常苦空无我一切法中。了知无常苦空无我。以能如是如理思惟。便于佛所无惑无疑。余如前说。于法于僧。于苦于集。于灭于道。于因及因所生诸法。无惑无疑。余如前说。又于嗔恚盖应作是说。为断嗔恚及嗔恚相。于此正法听闻受持乃至广说。于掉举恶作盖应作是说。为断掉举恶作及顺彼法。于此正法听闻受持乃至广说。于其疑盖应作是说。为断疑盖及顺彼法。于此正法听闻受持乃至广说。如是方便从贪欲嗔恚。惛沉睡眠。掉举恶作。疑盖及顺彼法。净修其心。是故说言经行宴坐从顺障法净修其心。如是已说由法增上从顺障法。净修其心。复有由自增上及世增上。从顺障法。净修其心。云何名为由自增上。谓如有一于诸盖中随起一种。便自了知此非善法。于所生盖不坚执着。速疾弃舍摈遣变吐。又能自观此所生盖甚可羞耻。令心染恼令慧羸劣是损害品。如是名为由自增上。从顺障法。净修其心。云何名为由世增上。从顺障法。净修其心。谓如有一于诸盖中随一已生或将生时。便作是念。我若生起所未生盖。当为大师之所诃责。亦为诸天及诸有智同梵行者。以法轻毁。彼由如是世增上故。未生诸盖能令不生。已生诸盖能速弃舍。如是名为由世增上。从顺障法。净修其心。又为护持诸卧具故。顺世仪故。尽夜初分经行宴坐。从顺障法。净修其心。从顺障法。净修心已。出住处外洗濯其足。洗濯足已还入住处如法寝卧。为令寝卧长养大种。得增长已长益其身。转有势力转能随顺。无间常委善品加行。问以何因缘右胁而卧。答与师子王法相似故。问何法相似。答如师子王一切兽中勇悍坚猛最为第一。比丘亦尔。于常修习觉寤瑜伽。发勤精进勇悍坚猛最为第一。由是因缘与师子王卧法相似。非如其余鬼卧天卧受欲者卧。由彼一切懒堕懈怠下劣。精进势力薄弱。又法应尔。如师子王右胁卧者。如是卧时身无掉乱念无忘失。睡不极重不见恶梦。异此卧者与是相违。当知具有一切过失。是故说言右胁而卧重累其足。云何名为住光明想巧便而卧。谓于光明想善巧精恳。善取善思善了善达。思惟诸天光明俱心。巧便而卧。由是因缘虽复寝卧心不惛闇。如是名为住光明想巧便而卧。云何正念巧便而卧。谓若诸法已闻已思已熟修习。体性是善能引义利。由正念故乃至睡梦亦常随转。由正念故于睡梦中亦常记忆令彼法相分明现前。即于彼法心多随观。由正念故随其所念。或善心眠或无记心眠。是名正念巧便而卧。云何正知巧便而卧。谓由正念而寝卧时。若有随一烦恼现前染恼其心。于此烦恼现生起时。能正觉了令不坚着。速疾弃舍。既通达已令心转还。是名正知巧便而卧。云何名为思惟起想巧便而卧。谓以精进策励其心。然后寝卧。于寝卧时时时觉寤。如林野鹿不应一切纵放其心。随顺趣向临入睡眠。复作是念。我今应于诸佛所许觉寤瑜伽。一切皆当具足成办。为成办故。应住精勤最极浓厚加行欲乐。复作是念。我今为修觉寤瑜伽。应正发起勤精进住。为欲修习诸善法故。应正翘勤离诸懒堕起发具足。过今夜分至明清旦。倍增发起勤精进住起发具足。当知此中由第一思惟起想。无重睡眠。于应起时速疾能起终不过时。方乃觉寤。由第二思惟起想。能于诸佛共所听许师子王卧。如法而卧无增无减。由第三思惟起想。令善欲乐常无懈废。虽有失念而能后后展转受学令无断绝。如是名为思惟起想巧便而卧。云何至夜后分速疾觉寤经行宴坐。从顺障法净修其心。夜后分者。谓夜四分中过后一分名夜后分。彼由如是住光明想。正念正知思惟起想巧便而卧。于夜中分夜四分中过于一分。正习睡眠。令于起时身有堪能。应时而起。非为上品惛沉睡眠缠所制伏。令将起时闇钝薄弱懒堕懈怠。由无如是闇钝薄弱懒堕懈怠。暂作意时无有艰难。速疾能起。从诸障法净修心者。如前应知。如是广辩初夜后夜常勤修习觉寤瑜伽已。

复云何知此中略义。谓常勤修习觉寤瑜伽所有士夫补特伽罗。略有四种正所作事。何等为四。一者乃至觉寤常不舍离所修善品。无间常委修善法中勇猛精进。二者以时而卧不以非时。三者无染污心而习睡眠非染污心。四者以时觉寤起不过时。是名四种常勤修习觉寤瑜伽。所有士夫补特伽罗正所作事。依此四种正所作事。诸佛世尊为声闻众宣说修习觉寤瑜伽。云何宣说。谓若说言于昼日分经行宴坐。从顺障法净修其心。于初夜分经行宴坐。从顺障法净修其心。由此言故宣说第一正所作事。谓乃至觉寤常不舍离所修善品。无间常委修善法中勇猛精进。若复说言出住处外洗濯其足。还入住处右胁而卧重累其足。由此言故宣说第二正所作事。谓以时而卧不以非时。若复说言住光明想。正念正知思惟起想巧便而卧。由此言故宣说第三正所作事。谓无染污心而习睡眠非染污心。若复说言于夜后分速疾觉寤经行宴坐。从顺障法净修其心。由此言故宣说第四正所作事。谓以时觉寤起不过时。此中所说住光明想。正念正知思惟起想巧便卧者。显由二缘无染污心而习睡眠非染污心。谓由正念。及由正知。复由二缘以时觉寤起不过时。谓由住光明想。及由思惟起想。此复云何由正念故。于善所缘摄敛而卧。由正知故于善所缘若心退失起诸烦恼。即便速疾能正了知。如是名为由二缘故无染污心。而习睡眠非染污心。由住光明想及思惟起想。无重睡眠非睡眠缠能远随逐。如是名为由二缘故以时觉寤起不过时。

如是宣说常勤修习觉寤瑜伽。所有略义。及前所说广辩释义。总说名为初夜后夜常勤修习觉寤瑜伽。

云何名为正知而住。谓如有一。若往若还正知而住。若睹若瞻正知而住。若屈若伸正知而住。持僧伽胝及以衣钵正知而住。若食若饮若啖若尝正知而住。若行若住若坐若卧正知而住。于觉寤时正知而住。若语若默正知而住。解劳睡时正知而住。若往若还正知住者。云何为往。云何为还。云何往还正知而住。所言往者。谓如有一往诣聚落往聚落间。往诣家属往家属间。往诣道场往道场间。所言还者。谓如有一从聚落还聚落间还。从家属还家属间还。从道场还道场间还。所言往还正知住者。谓于自往正知我往。及于自还正知我还。于所应往及非所往能正了知。于所应还及非所还能正了知。于应往时及非往时能正了知。于应还时及非还时能正了知。于其如是如是应往及不应往能正了知。于其如是如是应还及不应还能正了知。是名正知。彼由成就此正知故。自知而往自知而还。往所应往非非所往。还所应还非非所还。以时往还不以非时。如其色类动止轨则礼式威仪应往应还。如是而往如是而还。如是名为若往若还正知而住。若睹若瞻正知住者。云何为睹。云何为瞻。云何睹瞻正知而住。所言睹者。谓于如前所列诸事。若往若还先无觉慧。先无功用。先无欲乐。于其中间眼见众色是名为睹。所言瞻者。谓于如前所列诸事。若往若还。觉慧为先。功用为先。欲乐为先。眼见众色。谓或诸王或诸王等。或诸僚佐或诸黎庶。或婆罗门或诸居士。或饶财宝长者商主。或余外物房舍屋宇殿堂廊庙。或余世间众杂妙事。观见此等是名为瞻。若复于此睹瞻自相能正了知。于所应睹于所应瞻能正了知。于应睹时于应瞻时能正了知。如所应睹如所应瞻能正了知。是名正知。彼由成就此正知故。自知而睹自知而瞻。睹所应睹瞻所应瞻。于应睹时于应瞻时而正瞻睹。如所应睹如所应瞻。如是而睹如是而瞻。如是名为若睹若瞻正知而住。若屈若申正知住者。云何为屈。云何为申。云何名为若屈若申正知而住。谓彼如是睹时瞻时。若往为先若还为先。或屈申足或屈申臂。或屈申手。或复屈申随一支节。是名屈申。若于屈申所有自相能正了知。若所屈申能正了知。若屈申时能正了知。若如是屈。及如是申能正了知。是名正知。彼由成就此正知故。于屈于申自知而屈自知而申。于所应屈于所应申而屈而申。于应屈时于应申时而屈而申。如所应屈如所应申如是而屈如是而申。如是名为若屈若申正知而住。持僧伽胝及以衣钵正知住者。云何持僧伽胝。云何持衣。云何持钵。云何持僧伽胝及以衣钵正知而住。谓有大衣或六十条或九条等。或两重刺名僧伽胝。被服受用能正将护。说名为持。若有中衣若有下衣。或持为衣或有长衣。或应作净或已作净。如是一切说名为衣。被服受用能正将护。说名为持。若堪受持或铁或瓦乞食应器。说名为钵。现充受用能正将护。说名为持。若于如是或僧伽胝或衣或钵。所有自相能正了知。于所应持或僧伽胝或衣或钵。或净不净能正了知。若于此时或僧伽胝或衣或钵。已持应持能正了知。若于如是或僧伽胝或衣或钵。应如是持能正了知。是名正知。彼由成就此正知故。于所应持或僧伽胝或衣或钵。自知而持。于所应持。于应持时而能正持。如所应持如是而持。如是名为持僧伽胝及以衣钵正知而住。若食若饮若啖若尝正知住者。云何为食。云何为饮。云何为啖。云何为尝。云何若食若饮。若啖若尝正知而住。谓诸所有受用饮食总名为食。此复二种。一啖二尝。云何为啖。谓啖饼糗或饭或糜或羹或臛。或有所余造作转变可啖可食。能持生命。如是等类皆名为啖。亦名为食。云何为尝。谓尝乳酪生酥熟酥油蜜。沙糖鱼肉醯鲊。或新果实。或有种种咀嚼品类。如是一切总名为尝亦名为食。云何为饮。谓沙糖汁或石蜜汁。或饭浆饮或钻酪饮。或酢为饮或抨酪饮。乃至于水总名为饮。若于如是若食若饮若啖若尝。所有自相能正了知。若于一切所食。所饮所啖所尝能正了知。若于尔时应食应饮。应啖应尝能正了知。若于如是应食应饮。应啖应尝能正了知。是名正知。彼由成就此正知故。于自所有若食若饮若啖若尝。自知而食自知而饮。自知而啖自知而尝。于所应食于所应饮。于所应啖于所应尝。正食正饮正啖正尝。应时而食应时而饮。应时而啖应时而尝。如所应食乃至如所应尝。如是而食乃至如是而尝。如是名为若食若饮。若啖若尝正知而住。若行若住广说乃至若解劳睡正知住者。云何为行。云何为住。云何为坐。云何为卧。云何觉寤。云何为语云何为默。云何名为解于劳睡。云何于行广说乃至于解劳睡正知而住。谓如有一于经行处来往经行。或复往诣同法者所或涉道路。如是等类说名为行。复如有一。住经行处。住诸同法阿遮利耶邬波拖耶及诸尊长等尊长前。如是等类说名为住。复如有一或于大床或小绳床。或草叶座或诸敷具。或尼师檀结加趺坐。端身正愿安住背念。如是等类说名为坐。复如有一出住处外洗濯其足。还入住处。或于大床或小绳床。或草叶座或阿练若。或在树下或空闲室。右胁而卧重叠其足。如是等类说名为卧。复如有一于昼日分经行宴坐。从顺障法净修其心。于初夜分于后夜分经行宴坐。从顺障法净修其心。说名觉寤。复如有一常勤修习如是觉寤。于未受法正受正习令得究竟。所谓契经应颂记别广说如前。即于如是已所受法。言善通利。谓大音声若读若诵。或复为他广说开示。于时时间。与诸有智同梵行者。或余在家诸贤善者。语言谈论共相庆慰。为欲劝励及求资具。如是等类说名为语。复如有一随先所闻随先所习。言善通利究竟诸法。独处空闲。思惟其义。筹量观察。或处静室令心内住等住安住及与近住。调伏寂静最极寂静一趣等持。或复于彼毗钵舍那修瑜伽行。如是等类说名为默。复如有一于其热分极炎暑时。或为热逼或为劬劳便生疲倦。非时惛寐乐着睡眠是名劳睡。若复于行广说乃至于解劳睡所有自相能正了知。于所应行乃至于应所解劳睡能正了知。于应行时乃至于应解劳睡时能正了知。如所应行乃至如所应解劳睡能正了知。是名正知。彼由成就此正知故。于其自行乃至于其自解劳睡正知而行。乃至正知而解劳睡。若所应行乃至若所应解劳睡。即于彼行乃至于彼解于劳睡。若时应行乃至若时应解劳睡。即此时行乃至此时解于劳睡。如所应行乃至如所应解劳睡。如是而行乃至如是而解劳睡。如是名为于行于住。于坐于卧。于其觉寤于语。于默于解劳睡。正知而住。复次如是正知而住。云何次第为显何事。谓如有一依止如是村邑聚落亭逻而住。作是思惟。我今应往如是村邑聚落亭逻。巡行乞食。如是乞已出还本处。又于如是村邑等中。或有居家我不应往。何等居家。谓唱令家。或酤酒家。或淫女家。或国王家。或旃荼罗羯耻那家。或复有家。一向诽谤不可回转。或有居家我所应往。谓刹帝利大族姓家。或婆罗门大族姓家。或诸居士大族姓家。或僚佐家。或饶财家。或长者家。或商主家。又有居家。我虽应往。不应太早太晚而往。若施主家有遽务时亦不应往。若戏乐时若有营构严饰事时。若为世间弊秽法时。若忿竞时亦不应往。又如所往如是应往不与暴乱恶象俱行。不与暴乱众车恶马恶牛恶狗而共同行。不入闹丛不蹈棘刺。不踰垣墙。不越坑堑。不堕山岸不溺深水。不履粪秽。应随月喻往施主家。具足惭愧远离憍傲荡涤身心。不求利养不希恭敬。如自获得所有利养心生喜悦。如是于他所得利养心亦喜悦。不自高举不轻蔑他心怀哀愍。又应如是自持其心往施主家。岂有出家往诣他所要望他施。非不惠施广说乃至要当速疾而非迟缓。又作是心。我于今假往施主家。所受施物应知其量。又我不应利养因缘矫诈。虚诳现惑乱相以利求利。得利养已无染无爱。亦不耽嗜饕餮。迷闷坚执湎着而受用之。复于已往或正往时观见众色。于此众色一分应观。或有一分所不应观。于不应观所有众色。当摄其眼善护诸根。于所应观所有众色。应善住念而正观察何色类色。所不应观。谓诸伎乐戏笑欢娱。或余游戏所作歌舞音乐等事。如是复有母邑殊胜幼少盛年美妙形色。或复有余所见众色能坏梵行。能障梵行。能令种种诸恶不善寻思现行。如是色类所有众色不应观。视何色类色是所应观。谓诸所有衰老朽迈上气者。身伛偻凭杖。战掉者身或诸疾苦。重病者身脚肿手肿腹肿面肿。肤色萎黄疮癣疥癞。众苦逼迫身形委顿。身形洪烂诸根闇钝。或有夭丧死经一日。或经二日或经七日。被诸乌鹊饿狗。鸱鹫狐狼。野干种种暴恶傍生禽兽之所食啖。或命终已出置高床上施幰帐。前后大众或哀或哭。以其灰土尘坌身发。生愁生苦生悲。生怨生忧生恼。如是等类所有众色。我应观察观是众色。能顺梵行能摄梵行。能令诸善寻思现行。不应摇身摇臂。摇头跳踯。携手叉腰竦肩入施主家。不应辄坐所不许座。不应不审观座而坐。不应放纵一切身分。不应翘足不应交足。不太狭足不太广足。端严而坐。不应开纽不轩不磔。亦不褰张而被法服。所服法衣并皆齐整。不高不下不如象鼻。非如多罗树间房穗。非如龙首非如豆抟。而被法服不应持钵预就其食。不应持钵在饮食上。不应置钵在杂秽处若坑涧处若崖岸处。又应次第受用饮食。不应以饭覆羹臛上。不以羹臛覆其饭上。不应饕餮受诸饮食。不应嫌恨受诸饮食。不太粗食不太细食。不应圆抟食。不应舐手不应舐钵。不振手食。不振足食。不应啮断而食其食。从施主家还归住处。于昼夜分在自别人所经行处往反经行。非于他处非不委处。非不恣处非不与处而辄经行。非身劬劳非身疲倦。非心掉举所制伏时而习经行。为修善品为善思惟。内摄诸根心不外乱而习经行。不太驰速不太躁动。亦非一向专事往来而习经行。时时进步时时停住而习经行。如是于自所居住处自院自房自别人处僧分与处。非于他处非不委处。非不恣处习经行已。复于大床或小绳床或草叶座。或尼师坛或阿练若树下冢间。或空闲室结加趺坐。端身正愿安住背念而习宴坐。于夜中分如法寝息。于昼日分及夜初分。修诸善品不应太急。如是寝时应如前说住光明想。正念正知思惟起想。于夜后分速疾觉寤。或于语论或于读诵勤修加行。或为修断闲居宴默思惟法时。应当远离顺世典籍绮字绮句绮饰文词能引无义。不能令证神通等觉究竟涅槃。复于如来所说正法。最极甚深相似甚深空性相应随顺缘性。及诸缘起。殷重无间善摄善受。令坚令住令无失坏。为成正行不为利养恭敬称誉。又于是法言善通利。慧善观察。于諠杂众不乐习近。不乐多业不乐多言。于时时间安住正念。与诸有智同梵行者。语言谈论。共相庆慰乐兴请问。乐求诸善无违诤心。言词称量言词合理。言词正直言辞寂静。乐勤为他宣说正法。又应宴默于恶不善所有寻思不乐寻思。又于非理所有诸法不乐思惟。于自所证离增上慢。于少下劣差别证中不生喜足。于上所证中无退屈。善能远离不应思处。时时修习止观瑜伽。乐断乐修无间修习殷重修习。又于热分极炎暑时。勇猛策励发勤精进。随作一种所应作事。劳倦因缘遂于非时发起惛睡。为此义故暂应寝息。欲令惛睡疾疾除遣。勿经久时损减善品障碍善品。于寝息时或关闭门。或令苾刍在傍看守。或毗奈耶隐密轨则。以衣蔽身在深隐处。须臾寝息令诸劳睡皆悉除遣。如是名为正知而住。先后次第。谓依行时及依住时。又于善品先未趣入。心兴加行如理作意俱行妙慧说名正知。即此正知行时住时一切成办无所减少。如是名为正知而住。当知此中若往若还。若睹若瞻。若屈若申。持僧伽胝及以衣钵。若食若饮若啖若尝正知而住。由是名为于村邑等如法行时正知而住。若行若住若坐若卧。若习觉寤若语若默若解劳睡正知而住。由是名为于其住处如法住时正知而住。如是应知已广分别正知而住。

复云何知此中略义。谓于行时有五种业。于其住时有五种业。行时住时正知而住有四种业。如是名为正知而住。所有略义云何。行时有五种业。一者身业。二者眼业。三者一切支节业。四者衣钵业。五者饮食业。如是名为行时五业。谓若说言若往若还。此言显示行时身业。若复说言若睹若瞻。此言显示行时眼业。若复说言若屈若申。此言显示行时一切支节业。若复说言持僧伽胝及以衣钵。此言显示行时衣钵业。若复说言若食若饮若啖若尝。此言显示行时饮食业。云何名为住时五业。一者身业。二者语业。三者意业。四者昼业。五者夜业。谓若说言若行若住若坐。此言显示住时身业。若复说言若语。此言显示住时语业。若复说言若卧若默若解劳睡。此言显示住时意业。若复说言若习觉寤。此言显示住时昼业夜业身业语业。又若卧者。此言显示住时夜业。当知是名住时五业。云何名为行时住时正知而住所有四业。谓初依彼行业住业起如是业。即于彼业安守正念不放逸住。当知此业正念所摄不放逸摄。若于是事是处是时。如量如理如其品类所应作者。即于此事此处此时。如量如理如其品类正知而作。彼由如是正知作故。于现法中无罪无犯。无有恶作无变无悔。于当来世亦无有罪。身坏死后不堕恶趣。不生一切那落迦中。为得未得积习资粮。

如是名为正知而住。所有略义前广分别。今此略义一切总名正知而住

瑜伽师地论卷第二十四瑜伽师地论卷第二十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三初瑜伽处出离地第三之四

云何名善友性。谓八因缘故。应知一切种圆满善友性。何等为八。谓如有一安住禁戒。具足多闻。能有所证。性多哀愍心无厌倦。善能堪忍无有怖畏语具圆满。云何名为安住禁戒。谓安住具戒善能守护别解律仪。如前广说。乐沙门性乐婆罗门性。为自调伏为自寂静。为自涅槃修行正行。如是名为安住禁戒。云何名为具足多闻。谓若有法宣说开示。初中后善文义巧妙。独一圆满清白梵行。于如是类众多妙法能善受持。言善通利。意善寻思。见善通达。如是名为具足多闻。云何名为能有所证。谓能证得胜无常想无常苦想。苦无我想厌逆食想。一切世间不可乐想有过患想。断想离想。灭想死想。不净想青瘀想。脓烂想破坏想。膖胀想啖食想。血涂想离散想。骨锁想观察空想。复能证得最初静虑。第二静虑。第三静虑。第四静虑空无边处。识无边处。无所有处。最后非想非非想处。又能证得慈悲喜舍。或预流果。或一来果。或不还果。或神境通。或宿住通。或天耳通。或死生通。或心差别通。或阿罗汉。具八解脱静虑等定。有大堪能具大势力。能善为他现三神变教授教诫。三神变者。一神力神变。二记说神变。三教导神变。如是名为能有所证。云何名为为性哀愍。谓于他所常起悲怜。乐与其义。乐与其利。乐与其乐。乐与猗触。乐与安隐。如是名为为性哀愍。云何名为心无倦厌。谓善能示现善能教导。善能赞励善能庆慰。处于四众宣说正法不辞劳倦。翘勤无堕起发圆满。为性好乐发勤精进。如是名为心无厌倦。云何名为善能堪忍。谓骂不报骂嗔不报嗔。打不报打弄不报弄。堪耐椎杵。于诸逼迫缚录禁闭捶打毁辱迫胁斫截众苦事中。自推己过以业异熟为所依趣。终不于他发生愤恚。亦不怀恨随眠不舍。如是虽遭轻陵毁辱。而其本性都无变改。唯常于彼思为义利。又能堪忍寒热饥渴蚊虻。风日蛇蝎恶触。他所干犯碜毒语言。身内所生猛利坚劲。辛楚切心夺命苦受。为性堪忍能有容纳。如是名为善能堪忍。云何名为无有怖畏。谓处大众说正法时。心无怯劣声无战掉辩无误失。终不由彼怯惧因缘为诸怖畏之所逼切。腋不流汗身毛不竖。如是名为无有怖畏。云何名为语具圆满。谓彼成就最上首语极美妙语。甚显了语易悟解语。乐欲闻语无违逆语。无所依语无边际语。如是名为语具圆满。言词巧妙。成就如是八种因缘。善能谏举善作忆念。善能教授善能教诫。善说正法。云何名为善能谏举。谓若有余于增上戒毁犯尸罗。于增上轨毁犯轨则。由见闻疑能正谏。举真实不以虚妄。应时不以非时。饶益不以衰损。柔软不以粗犷。善友不以憎嫉。如是名为善能谏举。云何名为善作忆念。谓令忆念先所犯罪或法或义。云何名为令其忆念先所犯罪。谓若有余先起毁犯而不能忆。善作方便令彼忆念。告言长老。曾于某处某事某时。毁犯如是如是色类。如是名为令其忆念先所犯罪。云何名为令忆念法。谓若有余于先所闻所受正法独处思念。所谓契经应颂记别广说如前。彼若不忆令其忆念。或复称述授与令忆。成兴请问诘难令忆。如是名为令忆念法。云何名为令忆念义。谓若有余于先所闻所受正义。有所忘失为作忆念。宣说开示令新令显。又若有善能引义利能引梵行久时所作久时所说。彼若忘失亦令忆念。如是名为善作忆念。云何名为善能教授。谓于远离寂静瑜伽作意止观。时时随顺教授而转。时时宣说与彼相应无倒言论。所谓能趣心离障盖甚可爱乐。尸罗言论等持言论。圣慧言论解脱言论。解脱智见言论少欲言论。喜足言论永断言论。离欲言论寂灭言论。损减言论无杂言论。随顺缘性缘起言论。如是名为善能教授。云何名为善能教诫。谓于大师所说圣教。能以正法以毗奈耶平等教诲。或轨范师或亲教师或同法者。或余尊重等尊重者。如实知彼随于一处违越毁犯。便于时时如法呵责。治罚驱摈令其调伏。既调伏已如法平等受诸利养。和同晓悟收敛摄受。于所应作及不应作。为令现行不现行故。于其积习及不积习。教导教诲。如是名为善能教诫。云何名为善说正法。谓于时时能善宣说初时所作无倒言论。所谓施论戒论生天之论。于诸欲中能广开示过患出离清净品法。又于时时宣说超胜四种圣谛相应言论。所谓苦论集论灭论道论。为诸有情得成熟故。为诸有情得清净故。为令正法得久住故。宣说相应助伴。随顺清亮。有用相称。应顺名句文身所有言论。又此言论应时而发殷重。渐次相续俱有令其欣庆。令其爱乐。令其欢喜。令其勇悍。无所诃摈。相应助伴。无乱如法称顺众会。有慈怜心。有利益心。有哀愍心。不依利养恭敬赞颂。不自高举。不陵蔑他。如是名为善说正法。由彼成就如是八支。于时时间善能谏举善作忆念。善能教授。善能教诫。善说正法。是故说彼名为善友。如是广辩善友性已。

复云何知此中略义。谓若善友心善稠密为性哀愍。最初于彼乐为利益。乐为安乐。又即于此利益安乐。如实了知。无有颠倒离颠倒见。又即于此利益安乐。有大势力方便善巧。能令积集能令引发。又即于此利益安乐。翘勤无堕起发圆满。为性好乐发勤精进。当知由此四因缘故摄一切种。总略圆满善知识性。如是名为此善友性所有略义。

若前所说广分别义。若此所说所有略义。一切总说为善友性。

云何名为闻思正法。谓正法者。若佛世尊若佛弟子。正士正至正善丈夫。宣说开显分别照了。此复云何。所谓契经应颂记别广说如前。十二分教是名正法。云何契经。谓薄伽梵于彼彼方所。为彼彼所化有情。依彼彼所化诸行差别。宣说无量蕴相应语处相应语。缘起相应语食相应语。谛相应语界相应语。声闻乘相应语独觉乘相应语。知来乘相应语念住正断神足根力觉支道支等相应语。不净息念诸学证净等相应语。结集如来正法藏者。摄聚如是种种圣语。为令圣教久住世故。以诸美妙名句文身。如其所应次第安布次第结集。谓能贯穿缝缀种种能引义利。能引梵行。真善妙义。是名契经。云何应颂。谓于中间或于最后宣说伽他。或复宣说未了义经。是名应颂。云何记别。谓于是中记别弟子命过已后当生等事。或复宣说已了义经。是名记别。云何讽颂。谓非直说是结句说。或作二句或作三句或作四句或作五句或作六句等。是名讽颂。云何自说。谓于是中不显能请补特伽罗名字种姓。为令当来正法久住圣教久住。不请而说。是名自说。云何因缘。谓于是中显示能请补特伽罗名字种姓。因请而说。及诸所有毗奈耶相应有因有缘别解脱经。是名因缘。云何譬喻。谓于是中有譬喻说。由譬喻故本义明净。是名譬喻。云何本事。谓诸所有宿世相应事义言教。是名本事。云何本生。谓于是中宣说世尊在过去世彼彼方分。若死若生行菩萨行行难行行。是名本生。云何方广。谓于是中广说一切诸菩萨道。为令修证阿耨多罗三藐三菩提十力无畏无障智等一切功德。是名方广。云何希法。谓于是中宣说诸佛诸佛弟子比丘比丘尼。式叉摩那。劳策男劳策女。近事男近事女等。若共不共胜于其余胜诸世间。同意所许甚奇希有最胜功德。是名希法。云何论议。所谓一切摩呾履迦阿毗达磨。研究甚深素呾缆义。宣畅一切契经宗要。是名论议。如是所说十二分教。三藏所摄。谓或有素怛缆藏摄。或有毗奈耶藏摄。或有阿毗达磨藏摄。当知此中若说契经应颂。记别讽颂。自说譬喻。本事本生。方广希法。是名素怛缆藏。若说因缘是名毗奈耶藏。若说论议是名阿毗达磨藏。是故如是十二分教。三藏所摄。如是一切正士正至正善丈夫共所宣说。故名正法。

听闻此故名闻正法。此复云何。谓如有一或受持素呾缆。或受持毗奈耶。或受持阿毗达磨。或受持素怛缆及毗奈耶。或受持素怛缆及阿毗达磨。或受持毗奈耶及阿毗达磨。或具受持素怛缆毗奈耶阿毗达磨。

如是一切名闻正法。此闻正法复有二种。一闻其文。二闻其义。

云何思正法。谓如有一即如所闻所信正法。独处空闲远离六种不应思处。谓思议我思议有情思议世间。思议有情业。果异熟。思议静虑者静虑境界。思议诸佛诸佛境界。

但正思惟所有诸法自相共相。如是思惟复有二种。一者以算数行相。善巧方便算计诸法。二者以称量行相。依正道理观察诸法功德过失。谓若思惟诸蕴相应所有言教。若复思惟如前所说所余随一所有言教。皆由如是二种行相方便思惟。此复云何。谓言色者。即十色处及堕法处所摄众色。是名色蕴。所言受者。即三种受。是名受蕴。所言想者。即六想身。是名想蕴。所言行者。即六思身等。是名行蕴。所言识者。即六识身等。是名识蕴。如是名为以算数行相思惟诸蕴相应言教。或复由此算数行相。别别思惟展转差别当知即有无量差别。云何以称量行相。依正道理思惟诸蕴相应言教。谓依四道理无倒观察。何等为四。一观待道理。二作用道理。三证成道理。四法尔道理。云何名为观待道理。谓略说有二种观待。一生起观待。二施设观待。生起观待者。谓由诸因诸缘势力生起诸蕴。此蕴生起要当观待诸因诸缘。施设观待者。谓由名身句身文身。施设诸蕴。此蕴施设要当观待名句文身。是名于蕴生起观待施设观待。即此生起观待施设观待。生起诸蕴施设诸蕴。说名道理瑜伽方便。是故说为观待道理。云何名为作用道理。谓诸蕴生已由自缘故。有自作用各各差别。谓眼能见色耳能闻声。鼻能嗅香舌能尝味。身能觉触意能了法。色为眼境为眼所行。乃至法为意境为意所行。或复所余如是等类。于彼彼法别别作用当知亦尔。即此诸法各别作用。所有道理瑜伽方便。皆说名为作用道理。云何名为证成道理。谓一切蕴皆是无常。众缘所生苦空无我。由三量故如实观察。谓由至教量故由现量故。由比量故。由此三量证验道理。诸有智者心正执受安置成立。谓一切蕴皆无常性众缘生性。苦性空性。及无我性。如是等名证成道理。云何名为法尔道理。谓何因缘故即彼诸蕴。如是种类。诸器世间。如是安布。何因缘故地坚为相水湿为相。火暖为相风用轻动以为其相。何因缘故诸蕴无常诸法无我涅槃寂静。何因缘故色变坏相受领纳相。想等了相行造作相。识了别相。由彼诸法本性应尔。自性应尔。法性应尔。即此法尔说名道理瑜伽方便。或即如是或异如是或非如是。一切皆以法尔为依。一切皆归法尔道理。令心安住令心晓了。如是名为法尔道理。如是名为依四道理。

观察诸蕴相应言教。如由算数行相及称量行相。观察诸蕴相应言教。如是即由二种行相。观察其余所有言教。如是总名审正观察。思惟一切所说正法。如是名为闻思正法

云何无障。谓此无障略有二种。一者依内。二者依外。我当先说依内外障。与彼相违当知即是二种无障。云何名依内障。谓如有一于其先世不曾修福。不修福故。不能时时获得随顺资生众具。所谓衣食诸坐卧具病缘医药及余什具。有猛利贪及长时贪。有猛利嗔及长时嗔。有猛利痴及长时痴。或于先世积集造作多疾病业。由彼为因多诸疾病。或由现在行不平等。由是因缘风热痰癊数数发动。或有宿食住在身中。或食粗重多事多业。多有所作多与众会。乐着事业乐着语言。乐着睡眠乐着諠众。乐相杂住乐着戏论。乐自举恃掉乱放逸居止非处。如是等类应知一切名依内障。云何名依外障。谓如有一依不善士。由彼因缘不能时时获得随顺教授教诫。或居恶处于此住处。若昼日分多有种种諠杂众集诸变异事。若于夜分多有种种高声大声大众諠杂。复有种种猛利辛楚风日恶触。或有种种人及非人怖畏惊恐。如是等类应知一切名依外障。如是广辩内外障已。

复云何知此中略义。谓于此中略有三障。一加行障。二远离障。三寂静障。云何加行障。谓若此障会遇现前。于诸善品所有加行。皆无堪能亦无势力。此复云何。谓常疹疾困苦重病。风热痰癊数数发动。或有宿食住在身中。或被蛇蝎百足蚰蜒之所蛆螫。或人非人之所逼恼。又不能得衣食卧具病缘医药及余什具。如是等类应知一切名加行障。云何远离障。谓食粗重多事多业多有所作或乐事业。由此因缘爱乐种种所作事业。后彼事中其心流散或乐语言。由此因缘虽于远离断寂静修有所堪能有大势力。然唯读诵便生喜足或乐睡眠。由此因缘惛沉睡眠常所缠绕。为性懈怠执睡为乐。执倚为乐执卧为乐。或乐諠众。由此因缘乐与在家及出家众。谈说种种王论贼论。食论饮论。妙衣服论淫女巷论。诸国土论大人传论。世间传论大海传论。如是等类能引无义。虚绮论中乐共谈说抂度时日。又多爱乐数与众会。彼彼事中令心散动。令心扰乱或乐杂住。由此因缘诸在家众及出家众。若未会遇思慕欲见。若已会遇不欲别离或乐戏论。由此因缘乐着世间种种戏论。于应趣向好乐前行。于远离中喜舍善轭。如是等类众多障法。应知一切名远离障。若有此障会遇现前。难可舍离阿练若处山林旷野边际卧具所有贪着。亦不能居阿练若处冢间树下空闲静室。云何寂静障。谓寂静者。即奢摩他毗钵舍那。有奢摩他障。有毗钵舍那障。云何奢摩他障。谓诸放逸及住非处。由放逸故或惛沉睡眠缠绕其心。或唯得奢摩他便生爱味。或于下劣性心乐趣入。或于闇昧性其心乐着。由住如是非处所故。人或非人諠杂扰乱。他所逼恼心外驰散。如是名为奢摩他障。当知此障能障寂静。云何毗钵舍那障。谓乐自恃举及以掉乱。乐自恃举者。谓如有一作是思惟。我生高族净信出家非为下劣。诸余比丘则不如是。由此因缘自高自举陵蔑于他。如是我生富族净信出家非为贫匮。我具妙色喜见端严多闻闻持。其闻积集善巧言词语具圆满。诸余比丘则不如是。由此因缘自高自举陵蔑于他。彼由如是自高举故。诸有比丘耆年多智积修梵行。不能时时恭敬请问。彼诸比丘亦不时时为其开发未开发处。为其显了未显了处。亦不为其殷到精恳以慧通达甚深句义。方便开示乃至令其智见清净。如是名为乐自恃举毗钵舍那障。又如有一唯得少分下劣智见安隐而住。彼由如是少分下劣智见安住。便自高举。自高举故。便生喜足更不上求。是名乐自恃举所住毗钵舍那障。言掉乱者。谓如有一根不寂静。诸根掉乱诸根嚣举。于一切时恶思所思恶说所说恶作所作。不能安住思惟诸法。不能坚固思惟诸法。由此因缘毗钵舍那不能圆满。不得清净。是名掉乱毗钵舍那障。如是二法障奢摩他。谓多放逸及住非处二法。能障毗钵舍那。谓乐自恃举及以掉乱。如是若奢摩他障若毗钵舍那障。总名寂静障。如是名为障之略义。

即此略义及前广辨。总略为一说名为障。此障相违当知无障。谓即此障无性远离。不合不会说名无障。

云何惠舍。谓若布施其性无罪为庄严心为助伴心。为资瑜伽为得上义而修布施。是名惠舍。

问谁能施。谁所施。用何施何相施。云何施何故施。由此因缘施性无罪。答谁能施者。谓施者施主是名能施。云何施者云何施主。谓若自手施名为施者。若自物施若欣乐施非不乐施。名为施主。谁所施者。谓四种所施。一有苦者。二有恩者。三亲爱者。四尊胜者。云何有苦者。谓贫穷者或乞丐者。或行路者或悕求者。或盲瞽者或聋騃者。或无依者或无趣者。匮乏种种资生具者。复有所余如是等类名有苦者。云何有恩者。谓或父母或乳饮者。或养育者或成长者。或于旷野沙碛等中能济度者。或饥俭时能赈恤者。或怖怨敌而救援者。或被执缚而能解者。或遭疾病而救疗者。教利益者教安乐者。引利益者引安乐者。随所生起诸事务中。为助伴者。同欢喜者同忧愁者。遭厄难时不相弃者。复有所余如是等类名有恩者。云何亲爱者。谓诸亲友或于其处有爱有敬。或信顺语。或数语言谈论交往。或有亲昵。复有所余如是等类说名亲爱。云何尊胜。谓若沙门若婆罗门。世间同许为贤善者。离损害者极离害者。离贪欲者。为调伏贪而修行者。离嗔恚者。为调伏嗔而修行者。离愚痴者。为调伏痴而修行者。复有所余如是等类名尊胜者。用何施者。谓若略说。或用有情数物而行惠施。或用无情数物而行惠施。云何有情数物持用惠施。谓或妻子奴婢作使。或象马猪牛羊鸡鸭驼骡等类。或有诸余大男大女小男小女。或复所余如是等类所用施物。或复内身头目手足血肉骨髓。随愿施与。此亦名为有情数物持用布施。是诸菩萨所现行事。非此义中意所许施。若有于彼诸有情类或得自在。或有势力或能制伏。若应持彼惠施于他。若惠施时自无有罪。若不由彼惠施因缘他心嫌恨。若施于他。知彼有情不为损恼。是名无罪有情数物持用惠施。云何无情数物持用惠施。谓略说有三种物。一者财物。二者谷物。三者处物。言财物者。谓末尼真珠琉璃螺贝璧玉珊瑚马瑙彩石生色可染赤珠右旋。复有所余如是等类。或诸珍宝或金或银。或诸衣服或诸什物。或香或鬘是名财物。云何谷物。谓诸所有可食可饮。大麦小麦。稻谷粟谷。糜黍胡麻。大小豆等。甘蔗蒲桃乳酪果汁。种种浆饮。复有所余如是等类是名谷物。云何处物。谓诸田宅邸店廛肆。建立福舍及寺馆等。复有所余如是等类是名处物。是名无罪无情数物持用惠施。当知此中有情数物无情数物。一切总说名所用施。何相施者。谓无贪俱行思造作心意业。及此所起身业语业舍所施物。或自相续或他相续是名施相。云何施者。谓由净信而行惠施。由正教见而行惠施。由有果见而行惠施。由极殷重而行惠施。由恭敬心自手行施。而不轻慢应时而施。济他要用不损恼他而行惠施。如法平等。不以凶暴积集财物而行惠施。以鲜洁物而行惠施。以精妙物而行惠施。以清净物而行惠施。由此自他俱无有罪。数数惠施制伏悭垢积集势力而行惠施。先心欢喜而行惠施。于正施时其心清净施已无悔。如是而施。何故施者。或慈悲故而行惠施。谓于有苦。或知恩故而行惠施。谓于有恩。或爱或敬或信顺故而行惠施。谓于亲爱。或为悕求世出世间殊胜功德。而行惠施。谓于尊胜。

由是因缘故修惠施。由是行相。或在家者或出家者修行布施。为庄严心为助伴心。为资瑜伽。为得上义。而行布施。由此因缘施性无罪。是名惠舍

云何名为沙门庄严。嗢拖南曰

  正信而无谄　　少病精进慧
  具少欲喜足　　易养及易满
  杜多德端严　　知量善士法
  具聪慧者相　　忍柔和贤善

谓如有一具足正信无有谄曲。少诸疾病性勤精进成就妙慧。少欲喜足易养易满。具足成就杜多。功德端严。知量具足成就贤善士法。具足成就聪慧者相。堪忍柔和为性贤善。

云何名为具足正信。谓多净信多正敬顺。多生胜解多善欲乐。于诸善法及大师所。深生净信无惑无疑。于大师所恭敬尊重承奉供养。既修如是恭敬尊重承奉供养。专心亲附依止而住。如于大师。如是于法同梵行者。于诸所学教授教诫。于修供养于无放逸。于三摩地当知亦尔。如是名为具足正信。云何名为无有谄曲。谓有纯质为性正直。于其大师及诸有智同梵行所。如实自显。如是名为无有谄曲。云何名为少诸疾病。谓性无病顺时变熟。平等执受不极温热不极寒冷。无所损害随时安乐。由是因缘。所食所饮。所啖所尝。易正变熟。如是名为少诸疾病。云何名为性勤精进。谓能安住有势。有勤有勇坚猛。于善法中能不舍轭。翘勤无惰起发圆满。能有所作。于诸有智同梵行者躬自承奉。如是名为性勤精进。云何名为成就妙慧。谓聪念觉皆悉圆满。根不闇钝。根不顽愚。亦不喑哑。非手代言。有力能了善说恶说所有法义。具足成就俱生觉慧。具足成就加行觉慧。如是名为成就妙慧。云何少欲。谓虽成就善少欲等所有功德。而不于此欲求他知。谓他知我具足少欲成就功德。是名少欲。云何喜足。谓于随一衣服饮食卧具等事。便生欢喜生正知足。于所未得所有衣服或粗或妙。更无悕望更无思虑。于所已得不染不爱。如前广说而受用之。如于衣服于其饮食卧具等事当知亦尔。是名喜足。云何易养。谓能独一自得怡养不待于他。或诸僮仆或余人众。又不追求余长财宝。令他施者施主等类。谓为难养。是名易养。云何易满。谓得微少便自支持。若得粗弊亦自支持。是名易满。云何成就杜多功德。谓常期乞食次第乞食。但一坐食先止后食。但持三衣但持毳衣持粪扫衣。住阿练若常居树下。常居迥露常住冢间。常期端坐处如常坐。如是依止。若食若衣若诸敷具杜多功德。或十二种或十三种。于乞食中分为二种。一者随得乞食。二者次第乞食。随得乞食者。谓随往还家随获随得而便受食。次第乞食者。谓入里巷巡家而乞。随得随现而便受食。不高举手越趣余家。愿我当获精妙饮食。乃至期愿多有所得。当知此中若依乞食无差别性。唯有十二。若依乞食有差别性。便有十三。云何名为但一坐食。谓坐一座乃至应食悉皆受食。从此座起必不重食。如是名为但一坐食。云何名为先止后食。谓为食故坐如应座。乃至未食先应具受诸所应食。应正了知。我今唯受尔所饮食当自支持。又正了知我过于此定不当食。如是受已然后方食。如是名为先止后食。云何名为但持三衣。谓但三衣而自支持。何者三衣。一僧伽胝。二嗢怛啰僧伽。三安怛婆参。除此三衣终不贮畜。过此长衣。如是名为但持三衣。云何名为但持毳衣。谓所持衣或三衣数或是长衣。一切皆用毛毳而作。终不贮畜余所作衣。如是名为但持毳衣。云何名为持粪扫衣。谓所有衣他舍。弃掷或街或巷。或市或廛。或道非道。或杂便秽。或为便秽脓血洟唾之所涂染。取如是等不净衣物。除去粗秽坚执洗浣缝染受持。如是名为持粪扫衣。云何名为住阿练若。谓住空闲山林坰野。受用边际所有卧具。远离一切村邑聚落。如是名为住阿练若。云何名为常居树下。谓常期愿住于树下依止树根。如是名为常居树下。云何名为常居迥露。谓常期愿住于迥露无覆障处。如是名为常居迥露。云何名为常住冢间。谓常期愿住冢墓间。诸有命过送尸骸处。如是名为常住冢间。云何名为常期端坐。谓于大床或小绳床或草叶座。端身而坐推度时日。终不以背或以其胁依倚大床或小绳床或壁或树草叶座等。如是名为常期端坐。云何名为处如常座。谓所坐卧或诸草座或诸叶座。如旧敷设草座叶座。而常坐卧。一敷设后终不数数翻举修理。如是名为处如常座。问何故名为杜多功德。答譬如世间或毛或[疊*毛]。未鞭未弹未纷未擘。尔时相着不软不轻。不任造作缕线毡褥。若鞭若弹若纷若擘。尔时分散柔软轻妙。堪任造作缕线毡褥。如是行者。由饮食贪于诸饮食令心染着。由衣服贪于诸衣服令心染着。由敷具贪于诸敷具令心染着。彼由如是杜多功德。能净修治令其纯直。柔软轻妙有所堪任。随顺依止能修梵行。是故名为杜多功德。于饮食中有美食贪及多食贪。能障修善。为欲断除美食贪故。常期乞食次第乞食。为欲断除多食贪故。但一坐食先止后食。于衣服中。有三种贪能障修善。一多衣贪。二软触贪。三上妙贪。为欲断除多衣贪故。但持三衣。为欲断除于诸衣服软触贪故。但持毳衣。为欲断除于诸衣服上妙贪故。持粪扫衣。于诸敷具。有四种贪能障修善。一諠杂贪。二屋宇贪。三倚乐卧乐贪。四敷具贪。为欲断除諠杂贪故。住阿练若。为欲断除屋宇贪故。常居树下迥露冢间。又为断除淫佚贪故。常住冢间。为欲断除倚乐卧乐贪故。常期端坐。为欲断除敷具贪故。处如常座。是名成就杜多功德。云何端严。谓能成就若往若还若睹若瞻。若屈若伸持僧伽胝持衣持钵。端严形相。是名端严。云何知量。谓于净信诸婆罗门长者居士。极恣衣服饮食敷具。病缘医药诸什物中。知量而聚。是名知量。云何成就贤善士法。谓生高族净信出家。或生富族净信出家。颜容殊妙喜见端严。具足多闻语具圆满。或随获得少智少见少安乐住。由是因缘不自高举不陵蔑他。能知唯有法随法行。是其谛实。既了知已精进修行法随法行。是名成就贤善士法。云何成就总慧者相。谓由作业相表知愚夫。由作业相表知聪慧。其事云何。谓诸愚夫。恶思所思恶说所说恶作所作。诸聪慧者。善思所思善说所说善作所作。是名成就聪慧者相。云何堪忍。谓如有一骂不报骂嗔不报嗔打不报打弄不报弄。又彼尊者堪能忍受寒热饥渴。蚊虻风日。蛇蝎毒触。又能忍受他所干犯粗恶语言。又能忍受身中所有猛利坚劲辛楚切心夺命苦受。为性堪忍有所容受。是名堪忍。云何柔和。谓如有一于大师等。具足成就慈愍身业。具足成就慈愍语业。具足成就慈愍意业。与诸有智同梵行者。和同受用应所受用。凡所饮食无有私密。如法所获如法所得。堕在钵中为钵所摄而为受用。同戒同见成就如是六种。可乐可爱可重。无违诤法易可共住性不恼他。与诸有智同梵行者。共住一处常令欢喜。是名柔和。云何贤善。谓如有一远离颦蹙舒颜平视。含笑先言常为爱语。性多摄受善法同侣。身心澄净。是名贤善。

若有成就如是诸法。爱乐正法爱乐功德。不乐利养恭敬称誉。亦不成就增益损减二种邪见。于非有法未尝增益。于实有法未尝损减。于诸世间事文绮者。所造顺世种种字相绮饰文句相应诗论。能正了知。无义无利远避弃舍。不习不爱亦不流传。不乐贮畜余长衣钵。远离在家共諠杂住。增烦恼故。乐与圣众和合居止。净修智故。不乐摄受亲里朋友。勿我由此亲友因缘。当招无量扰乱事务。彼或变坏当生种种愁戚伤叹悲苦忧恼。随所生起本随二惑。不坚执着寻即弃舍除遣变吐。勿我由此二惑因缘。当生现法后法众苦。终不虚损所有信施。终不毁犯清净禁戒。受用信施终不毁呰他人信施。终不弃舍所受学处。常乐省察己之过失。不喜伺求他所愆犯。隐覆自善发露己恶。命难因缘亦不故思毁犯众罪。设由忘念少有所犯。即便速疾如法悔除。于应作事翘勤无堕。凡百所为自能成办。终不求他为己给使。于佛世尊及佛弟子不可思议威德神力甚深法教。深生信解终不毁谤。能正了知唯是如来所知所见非我境界。终不乐住自妄见。取非理僻执恶见。所生言论咒术。若与如是功德相应。如是安住如是修学。以正沙门诸庄严具。而自庄严甚为微妙。譬如有人盛壮端正好自庄严。乐受诸欲沐浴身首。涂以妙香服鲜白衣。饰以种种妙庄严具。所谓璎珞耳环。指环腕钏。臂钏诸妙宝印。并金银等种种华鬘。如是庄严极为奇妙。如是行者以正沙门种种功德妙庄严具。而自庄严。其德炽然威光遍照。是故说为沙门庄严。是名沙门庄严具义

瑜伽师地论卷第二十五瑜伽师地论卷第二十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第二瑜伽处之一

问于如前所举所开示出离地中。有几品类补特伽罗。能证出离。云何建立补特伽罗。云何所缘。云何教授。云何学。云何随顺学法。云何瑜伽坏。云何瑜伽。云何作意。云何瑜伽师所作几种瑜伽师。云何瑜伽修。云何修果。几种补特伽罗异门。几种补特伽罗。几种建立补特伽罗因缘。有几种魔几种魔事。云何发趣空无有果。嗢柁南曰

  诸补特伽罗　　建立所缘教
  学随顺学法　　坏瑜伽作意
  瑜伽师作修　　果门数取趣
  因魔事无果　　是皆当广说

补特伽罗品类差别有二十八种。云何二十八。谓钝根者。利根者。贪增上者。嗔增上者。痴增上者。慢增上者。寻思增上者。得平等者。薄尘性者。行向者。住果者。随信行者。随法行者。信胜解者。见至者。身证者。极七返有者。家家者。一间者。中般涅槃者。生般涅槃者。无行般涅槃者。有行般涅槃者。上流者。时解脱者。不动法者。慧解脱者。俱分解脱者。

云何钝根补特伽罗。谓有补特伽罗成就钝根。于所知事迟钝运转微劣运转。如前已说。此复二种。应知其相。一者本来钝根种姓。二者未善修习诸根。云何利根补特伽罗。谓有补特伽罗成就利根。于所知事不迟钝运转不微劣运转。如前已说。此亦二种。应知其相。一者本来利根种姓。二者已善修习诸根。云何贪增上补特伽罗。谓有补特伽罗。先余生中于贪烦恼。已修已习已多修习。由是因缘今此生中于所爱事。有猛利贪有长时贪。是名贪增上补特伽罗。云何嗔增上补特伽罗。谓有补特伽罗。先余生中于嗔烦恼。已修已习已多修习。由是因缘今此生中于所憎事。有猛利嗔有长时嗔。是名嗔增上补特伽罗。云何痴增上补特伽罗。谓有补特伽罗。先余生中于痴烦恼。已修已习已多修习。由是因缘今此生中于所愚事。有猛利痴有长时痴。是名痴增上补特伽罗。云何慢增上补特伽罗。谓有补特伽罗。先余生中于慢烦恼。已修已习已多修习。由是因缘今此生中于所慢事。有猛利慢有长时慢。是名慢增上补特伽罗。云何寻思增上补特伽罗。谓有补特伽罗。先余生中于其寻思。已修已习已多修习。由是因缘今此生中于所寻思事。有猛利寻思有长时寻思。是名寻思增上补特伽罗。云何得平等补特伽罗。谓有补特伽罗。先余生中虽于贪嗔痴慢寻思。不修不习不多修习。而于彼法未见过患。未能厌坏未善推求。由是因缘于所爱所憎所愚所慢所寻思事。无猛利贪无长时贪。然如彼事贪得现行。如贪嗔痴慢寻思亦尔。是名得平等补特伽罗。云何薄尘性补特伽罗。谓有补特伽罗。先余生中于贪烦恼。不修不习不多修习。已能于彼多见过患。已能厌坏已善推求。由是因缘今此生中于所爱事。会遇现前众多美妙上品境中起微劣贪。于其中品下品境中贪全不起。如贪嗔痴慢寻思应知亦尔。是名薄尘性补特伽罗。云何行向补特伽罗。谓行四向补特伽罗。何等为四。一预流果向。二一来果向。三不还果向。四阿罗汉果向。是名行向补特伽罗。云何住果补特伽罗。谓住四果补特伽罗。何等为四。一预流果。二一来果。三不还果。四阿罗汉果。是名住果补特伽罗。云何随信行补特伽罗。谓有补特伽罗。从他求请教授教诫。由此力故修证果行。非如所闻所受所究竟。所思所量所观察法。自有功能自有势力随法修行。唯由随他补特伽罗信而修行。是名随信行补特伽罗。云何随法行补特伽罗。谓有补特伽罗。如其所闻所受所究竟。所思所量所观察法。自有功能自有势力随法修行。不从他求教授教诫修证果行。是名随法行补特伽罗。云何信胜解补特伽罗。谓即随信行补特伽罗。因他教授教诫。于沙门果得触证时。名信胜解补特伽罗。云何见至补特伽罗。谓即随法行补特伽罗。于沙门果得触证时。说名见至补特伽罗。云何身证补特伽罗。谓有补特伽罗。于八解脱顺逆入出。身作证多安住。而未能得诸漏永尽。是名身证补特伽罗。云何名为极七返有补特伽罗。谓有补特伽罗。已能永断萨迦耶见戒禁取疑三种结故。得预流果成无堕法定趣菩提。极七返有天人往来。极至七返证苦边际。如是名为极七返有补特伽罗。云何家家补特伽罗。谓有二种家家。一天家家。二人家家。天家家者。谓于天上从家至家。若往若来证苦边际。人家家者。谓于人间从家至家。若往若来证苦边际。当知此二俱是预流补特伽罗。云何一间补特伽罗。谓即一来补特伽罗。行不还果向已。能永断欲界烦恼上品中品。唯余下品。唯更受一欲界天有。即于彼处得般涅槃。不复还来生此世间。是名一间补特伽罗。云何中般涅槃补特伽罗。谓有三种中般涅槃补特伽罗。一有一种中般涅槃补特伽罗。从此没已中有续生。中有生已便般涅槃。如小札火微星才举即便谢灭。二有一种中般涅槃补特伽罗。从此没已中有续生。中有生已少时经停。未趣生有便般涅槃。如铁抟铤炎炽赫然锤锻星流未下便灭。三有一种中般涅槃补特伽罗。从此没已中有续生。中有生已往趣生有。未得生有便般涅槃。如彼热铁椎锻星流下未至地即便谢灭。如是三种中般涅槃补特伽罗。总说为一中般涅槃补特伽罗。云何生般涅槃补特伽罗。谓才生彼已便般涅槃。是名生般涅槃补特伽罗。云何无行般涅槃补特伽罗。谓生彼已不起加行不作功用。不由劳倦道现在前而般涅槃。是名无行般涅槃补特伽罗。云何有行般涅槃补特伽罗。谓彼生已发起加行作大功用。由极劳倦道现在前而般涅槃。是名有行般涅槃补特伽罗。云何上流补特伽罗。谓有不还补特伽罗。从此上生初静虑已。住于彼处不般涅槃。从彼没已展转上生诸所生处。乃至或到色究竟天。或到非想非非想处。是名上流补特伽罗。云何时解脱补特伽罗。谓有补特伽罗。钝根种姓于诸世间现法乐住容有退失。或思自害或守解脱。励力勤修不放逸行。谓防退失增上力故。或唯安住自分善品。或经彼彼日夜刹那瞚息须臾励力胜进。乃至未证最极猛利。是名时解脱补特伽罗。云何不动法补特伽罗。谓有补特伽罗。与上相违。当知是名不动法补特伽罗。云何慧解脱补特伽罗。谓有补特伽罗。已能证得诸漏永尽。于八解脱未能身证具足安住。是名慧解脱补特伽罗。云何俱分解脱补特伽罗。谓有补特伽罗。已能证得诸漏永尽。于八解脱身已作证具足安住。于烦恼障分及解脱障分。心俱解脱。是名俱分解脱补特伽罗

云何建立补特伽罗。谓由十一差别道理。应知建立补特伽罗。云何十一差别道理。一根差别故。二众差别故。三行差别故。四愿差别故。五行迹差别故。六道果差别故。七加行差别故。八定差别故。九生差别故。十退不退差别故。十一障差别故。

云何由根差别建立补特伽罗。谓根差别故建立二种补特伽罗。一者钝根。二者利根。云何由众差别建立补特伽罗。谓众差别故建立七种补特伽罗。谓比丘比丘尼式叉摩那。劳策男劳策女。近事男近事女。云何由行差别建立补特伽罗。谓行差别故建立七种补特伽罗。谓若贪增上补特伽罗名贪行者。若嗔增上补特伽罗名嗔行者。若痴增上补特伽罗名痴行者。若慢增上补特伽罗名慢行者。若寻思增上补特伽罗名寻思行者。若得平等补特伽罗名等分行者。若薄尘性补特伽罗名薄尘行者。问贪行补特伽罗应知何相。答贪行补特伽罗。于诸微劣所爱事中。尚能生起最极厚重上品贪缠。何况中品上品境界。又此贪缠住在身中。经久相续长时随缚。由贪缠故为可爱法之所制伏。不能制伏彼可爱法。诸根悦怿诸根不强。诸根不涩。诸根不粗。为性不好以恶身语损恼于他。难使远离难使厌患。下劣胜解。事业坚牢。事业久固。禁戒坚牢。禁戒久固。能忍能受。于资生具。为性耽染深生爱重。多喜多悦远离颦蹙。舒颜平视含笑先言。如是等类应知是名贪行者相。问嗔行补特伽罗应知何相。答嗔行补特伽罗。于诸微劣所憎事中。尚能生起最极厚重上品嗔缠。何况中品上品境界。又此嗔缠住在身中。经久相续长时随缚。由此嗔缠为可憎法之所制伏。不能制伏彼可憎法。诸根枯槁诸根刚强。诸根疏涩诸根粗燥。为性好乐以恶身语损恼于他。易令远离易令厌患。凶暴强口形相棱层无多胜解。事业不坚事业不固。禁戒不坚禁戒不固。不忍不受多忧多恼。性好违背所取不顺。性多愁戚性好粗言。多怀嫌恨意乐惨烈。悖恶尤蛆好相拒对。得少语言多恚多愤。憔悴而住喜生忿怒。眉面颦蹙恒不舒颜邪精下视。于他荣利多憎多嫉。如是等类应知是名嗔行者相。问痴行补特伽罗应知何相。答痴行补特伽罗。于诸微劣所愚事中。尚能生起最极厚重上品痴缠。何况中品上品境界。又此痴缠住在身中。经久相续长时随缚。由此痴缠为可痴法之所制伏。不能制伏彼可痴法。诸根闇钝诸根愚昧诸根羸劣。身业慢缓语业慢缓。恶思所思恶说所说恶作所作。懒堕懈怠起不圆满。词辩薄弱性不聪敏念多忘失。不正知住所取左僻。难使远离难使厌患。下劣胜解。顽騃喑哑以手代言。无有力能领解善说恶说法义。缘所牵缠他所引夺他所策使。如是等类应知是名痴行者相。问慢行补特伽罗应知何相。答慢行补特伽罗。于诸微劣所慢事中。尚能生起最极厚重上品慢缠。何况中品上品境界。又此慢缠住在身中。经久相续长时随缚。由慢缠故为可慢法之所制伏。不能制伏彼可慢法。诸根掉动诸根高举。诸根散乱勤乐严身。言语高大不乐谦下。于其父母眷属师长。不能时时如法承事。多怀憍傲不能以身礼敬问讯。合掌迎逆修和敬业。自高自举陵蔑他人。乐着利养乐着恭敬。乐着世间称誉声颂。所为轻举喜作嘲调。难使远离难使厌患。广大胜解微劣慈悲。计我有情命者养者补特伽罗生者等见。多分上品多怨多恨。如是等类应知是名慢行者相。问寻思行补特伽罗应知何相。答寻思行补特伽罗。于诸微劣所寻思事。尚能发起最极厚重上品寻思缠。何况中品上品境界。此寻思缠住在身中。经久相续长时随缚。由此缠故为可寻思法之所制伏。不能制伏可寻思法。诸根不住诸根飘举。诸根掉动诸根散乱。身业误失语业误失。难使远离难使厌患。喜为戏论乐着戏论。多惑多疑多怀乐欲。禁戒不坚禁戒不定。事业不坚事业不定。多怀恐虑念多忘失。不乐远离多乐散动。于诸世间种种妙事。贪欲随流翘勤无惰起发圆满。如是等类应知是名寻思行者相。如是名为由行差别建立补特伽罗。云何由愿差别建立补特伽罗。谓或有补特伽罗。于声闻乘已发正愿。或有补特伽罗。于独觉乘已发正愿。或有补特伽罗。于其大乘已发正愿。当知此中若补特伽罗于声闻乘已发正愿。彼或声闻种姓。或独觉种姓。或大乘种姓。若补特伽罗于独觉菩提已发正愿。彼或独觉种姓。或声闻种姓。或大乘种姓。若补特伽罗于其大乘已发正愿。彼或大乘种姓。或独觉种姓。或声闻种姓。若声闻种姓补特伽罗。于独觉菩提。或于无上正等菩提。已发正愿。彼是声闻种姓故。后时决定还舍彼愿。必唯安住声闻乘愿。独觉乘种姓。大乘种姓补特伽罗应知亦尔。此中所有补特伽罗愿可移转愿可舍离。决定不可移转种姓舍离种姓。今此义中当知唯说声闻乘愿。声闻种姓补特伽罗。如是名为由愿差别建立补特伽罗。云何由行迹差别建立补特伽罗。谓如所举如所开示补特伽罗。依四行迹而得出离。何等为四。谓或有行迹是苦迟通。或有行迹是苦速通。或有行迹是乐迟通。或有行迹是乐速通。当知此中若钝根性补特伽罗。未得根本静虑。所有行迹。名苦迟通。若利根性补特伽罗。未得根本静虑。所有行迹名苦速通。若钝根性补特伽罗。已得根本静虑所有行迹名乐迟通。若利根性补特伽罗。已得根本静虑。所有行迹名乐速通。如是名为由行迹差别建立补特伽罗。云何由道果差别建立补特伽罗。谓行四向及住四果。行四向者。一预流果向补特伽罗。二一来果向补特伽罗。三不还果向补特伽罗。四阿罗汉果向补特伽罗。住四果者。一预流果。二一来果。三不还果。四阿罗汉果。若于向道转彼名行向者。由向道故建立四种补特伽罗。若得沙门果彼名住果者。由道果故建立四种补特伽罗。如是名为由道果差别建立补特伽罗。云何由加行差别建立补特伽罗。谓随信行及随法行补特伽罗。若随补特伽罗信勤修正行。名随信行补特伽罗。若于诸法不待他缘。随毗柰耶勤修正行。名随法行补特伽罗。如是名为由加行差别建立补特伽罗。云何由定差别建立补特伽罗。谓身证补特伽罗。于八解脱身已作证具足安住。而未获得诸漏永尽。当知如是补特伽罗于有色观诸色解脱。内无色想观外诸色解脱。净解脱身作证具足住。空无边处解脱。识无边处解脱。无所有处解脱。非想非非想处解脱。想受灭解脱。已能顺逆入出自在。如是名为由定差别建立补特伽罗。云何由生差别建立补特伽罗。谓极七返有。家家。一间。中般涅槃。生般涅槃。无行般涅槃。有行般涅槃。及以上流补特伽罗。如是名为由生差别建立补特伽罗。云何由退不退差别建立补特伽罗。谓由退故建立时解脱阿罗汉。彼于现法乐住容有退失。由不退故建立不动法阿罗汉。彼于现法乐住定无退失。如是名为由退不退差别建立补特伽罗。云何由障差别建立补特伽罗。谓慧解脱及俱分解脱阿罗汉。慧解脱阿罗汉者。谓已解脱烦恼障未解脱定障。俱分解脱阿罗汉者。谓已解脱烦恼障及已解脱定障。是故说名俱分解脱。如是名为由障差别建立补特伽罗。

由此所举及所开示差别道理。如其次第应知建立补特伽罗

云何所缘。谓有四种所缘境事。何等为四。一者遍满所缘境事。二者净行所缘境事。三者善巧所缘境事。四者净惑所缘境事。

云何遍满所缘境事。谓复四种。一有分别影像。二无分别影像。三事边际性。四所作成办。云何有分别影像。谓如有一或听闻正法。或教授教诫为所依止。或见或闻或分别故。于所知事同分影像。由三摩呬多地毗钵舍那行。观察简择极简择遍寻思遍伺察。所知事者。谓或不净。或慈愍。或缘性缘起。或界差别。或阿那波那念。或蕴善巧。或界善巧。或处善巧。或缘起善巧。或处非处善巧。或下地粗性上地静性。或苦谛集谛。灭谛道谛。是名所知事。此所知事或依教授教诫。或听闻正法为所依止。令三摩呬多地作意现前。即于彼法而起胜解。即于彼所知事而起胜解。彼于尔时。于所知事。如现领受胜解而转。虽彼所知事非现领受和合现前。亦非所余彼种类物。然由三摩呬多地胜解领受相似作意领受。彼所知事相似显现。由此道理名所知事同分影像。修观行者。推求此故。于彼本性所知事中。观察审定功德过失。是名有分别影像。云何无分别影像。谓修观行者。受取如是影像相已。不复观察简择极简择遍寻思遍伺察。然即于此所缘影像。以奢摩他行寂静其心。即是九种行相令心安住。谓令心内住等住。安住近住。调伏寂静。最极寂静。一趣等持。彼于尔时成无分别影像所缘。即于如是所缘影像。一向一趣安住其念。不复观察简择极简择遍寻思遍伺察。是名无分别影像。即此影像亦名影像。亦名三摩地相。亦名三摩地所行境界。亦名三摩地口。亦名三摩地门。亦名作意处。亦名内分别体。亦名光影。如是等类当知名为所知事同分影像诸名差别。云何事边际性。谓若所缘尽所有性如所有性。云何名为尽所有性。谓色蕴外更无余色。受想行识蕴外更无有余受想行识。一切有为事皆五法所摄。一切诸法界处所摄。一切所知事四圣谛摄。如是名为尽所有性。云何名为如所有性。谓若所缘是真实性是真如性。由四道理具道理性。谓观待道理。作用道理。证成道理。法尔道理。如是若所缘境尽所有性如所有性。总说为一事边际性。云何所作成办。谓修观行者。于奢摩他毗钵舍那。若修若习若多修习为因缘故。诸缘影像所有作意皆得圆满。此圆满故便得转依。一切粗重悉皆息灭。得转依故超过影像。即于所知事有无分别。现量智见生。入初静虑者得初静虑时。于初静虑所行境界。入第二第三第四静虑者。得第二第三第四静虑时。于第二第三第四静虑所行境界。入空无边处。识无边处。无所有处。非想非非想处者。得彼定时。即于彼定所行境界。如是名为所作成办。如是四种所缘境事。遍行一切。随入一切所缘境中。去来今世正等觉者共所宣说。是故说名遍满所缘。又此所缘遍毗钵舍那品。遍奢摩他品。遍一切事。遍真实事。遍因果相属事。故名遍满。谓若说有分别影像。即是此中毗钵舍那品。若说无分别影像。即是此中奢摩他品。若说事边际性。即是此中一切事真实事。若说所作成办。即是此中因果相属事。如佛世尊曾为长老颉隶伐多说如是义。曾闻长老颉隶伐多问世尊言。大德。诸有比丘勤修观行是瑜伽师。能于所缘安住其心。为何于缘安住其心。云何于缘安住其心。齐何名为心善安住。佛告长老颉隶伐多。善哉善哉。汝今善能问如是义。汝今谛听极善思惟。吾当为汝宣说开示。颉隶伐多。诸有比丘勤修观行是瑜伽师。能于所缘安住其心。或乐净行或乐善巧。或乐令心解脱诸漏。于相称缘安住其心。于相似缘安住其心。于缘无倒安住其心。能于其中不舍静虑。云何比丘勤修观行是瑜伽师。于相称缘安住其心。谓彼比丘若唯有贪行。应于不净缘安住于心。如是名为于相称缘安住其心。若唯有嗔行。应于慈愍安住其心。若唯有痴行。应于缘性缘起安住其心。若唯有慢行。应于界差别安住其心。若唯有寻思行。应于阿那波那念安住其心。如是名为于相称缘安住其心。颉隶伐多。又彼比丘若愚诸行自相。愚我有情命者生者能养育者补特伽罗事。应于蕴善巧安住其心。若愚其因。应于界善巧安住其心。若愚其缘。应于处善巧安住其心。若愚无常苦空无我。应于缘起处非处善巧安住其心。若乐离欲界欲。应于诸欲粗性诸色静性安住其心。若乐离色界欲。应于诸色粗性无色静性安住其心。若乐通达。及乐解脱遍一切处萨迦耶事。应于苦谛集谛灭谛道谛安住其心。是名比丘勤修观行是瑜伽师于相称缘安住其心。颉隶伐多。云何比丘勤修观行是瑜伽师于相似缘安住其心。谓彼比丘于彼彼所知事。为欲简择极简择遍寻思遍伺察故。于先所见所闻所觉所知事。由见闻觉知增上力故。以三摩呬多地作意思惟分别。而起胜解。彼虽于其本所知事。不能和合现前观察。然与本事相似而生。于彼所缘有彼相似。唯智唯见唯正忆念。又彼比丘于时时间令心寂静。于时时间依增上慧法毗钵舍那勤修观行。是名比丘勤修观行是瑜伽师于相似缘安住其心。颉隶伐多。云何比丘勤修观行是瑜伽师于缘无倒安住其心。谓若比丘勤修观行是瑜伽师于所缘境安住其心。随应解了所知境界。如实无倒能遍了知。是名比丘勤修观行是瑜伽师于缘无倒安住其心。颉隶伐多。云何比丘勤修观行是瑜伽师能于其中不舍静虑。谓若比丘勤修观行是瑜伽师如是于缘正修行时。无间加行殷重加行。于时时间修习止相举相舍相。由修由习由多修习为因缘故。一切粗重悉皆息灭。随得触证所依清净。于所知事由现见故。随得触证所缘清净。由离贪故随得触证心遍清净。离无明故。随得触证智遍清净。是名比丘勤修观行是瑜伽师能于其中不舍静虑。颉隶伐多。为此比丘于所缘境安住其心。如是于缘安住其心。如是于缘安住心已名善安住。世尊此中重说颂曰

  行者行诸相　　知一切实义
  常于影静虑　　得证遍清净

此中说言行者行诸相者。由此宣说修观行者于止举舍相。无间修行殷重修行。若复说言知一切实义者。由此宣说事边际性。若复说言常于影静虑者。由此有宣说分别影像无分别影像。若复说言得证遍清净者。由此宣说所作成办。此中世尊复说颂曰

  于心相遍知　　能受远离味
  静虑常委念　　受喜乐离染

此中说言于心相遍知者。谓有分别影像。无分别影像以心相名说。事边际性以遍知名说。若复说言能受远离味者。由此宣说于其所缘正修行者乐断乐修。若复说言静虑常委念者。由此宣说于奢摩他毗钵舍那。常勤修习委练修习。若复说言受喜乐离染者。由此宣说所作成办。当知如是遍满所缘。随顺净教契合正理。如是名为遍满所缘。

云何名为净行所缘。谓不净慈愍缘性缘起界差别。阿那波那念等所缘差别。云何不净所缘。谓略说有六种不净。一朽秽不净。二苦恼不净。三下劣不净。四观待不净。五烦恼不净。六速坏不净。云何名为朽秽不净。谓此不净略依二种。一者依内二者依外。云何依内朽秽不净。谓内身中发毛爪齿。尘垢皮肉。骸骨筋脉。心胆肝肺。大肠小肠。生藏熟藏。肚胃髀肾。脓血热痰。肪膏肌髓。脑膜洟唾。泪汗屎尿。如是等类名为依内朽秽不净。云何依外朽秽不净。谓或青瘀或复脓烂。或复变坏或复膖胀。或复食啖或复变赤。或复散坏或骨。或锁或复骨锁。或屎所作或尿所作。或唾所作或洟所作。或血所涂或脓所涂。或便秽处。如是等类名为依外朽秽不净。如是依内朽秽不净。及依外朽秽不净。总说为一朽秽不净。云何名为苦恼不净。谓顺苦受触为缘所生。若身若心不平等受受所摄。如是名为苦恼不净。云何名为下劣不净。谓最下劣事最下劣界。所谓欲界。除此更无极下极劣最极鄙秽余界可得。如是名为下劣不净。云何名为观待不净。谓如有一劣清净事。观待其余胜清净事便似不净。如待无色胜清净事。色界诸法便似不净。待萨迦耶寂灭涅槃。乃至有顶皆似不净。如是等类一切名为观待不净。云何名为烦恼不净。谓三界中所有一切结缚随眠随烦恼缠。一切名为烦恼不净。云何名为速坏不净。谓五取蕴无常无恒不可保信变坏法性。如是名为速坏不净。如是不净是能清净贪行所缘。贪有五种。一于内身欲欲欲贪。二于外身淫欲淫贪。三境欲境贪。四色欲色贪。五萨迦耶欲萨迦耶贪。是名五贪。为欲令此五种欲贪断灭除遣不现行故。建立六种不净所缘。谓由依内朽秽不净所缘故。令于内身欲欲欲贪心得清净。由依外朽秽不净所缘故。令于外身淫欲淫贪心得清净。淫相应贪复有四种。一显色贪。二形色贪。三妙触贪。四承事贪。由依四外不净所缘。于此四种相应淫贪。心得清净。若于青瘀或于脓烂。或于变坏或于膖胀。或于食啖作意思惟。于显色贪令心清净。若于变赤作意思惟。于形色贪令心清净。若于其骨若于其锁。若于骨锁作意思惟。于妙触贪令心清净。若于散坏作意思惟。于承事贪令心清净。如是四种名于淫贪令心清净。是故世尊乃至所有依外朽秽不净差别。皆依四种憺怕路而正建立。谓若说言由憺怕路见彼彼尸死。经一日或经二日或经七日。乌鹊饿狗。鸱鹫狐狼。野干禽兽之所食啖。便取其相以譬彼身。亦如是性亦如是类。不能超过如是法性。此即显示始从青瘀乃至食啖。若复说言由憺怕路见彼彼尸。离皮肉血筋脉缠裹。此即显示所有变赤。若复说言由憺怕路见彼彼骨或骨或锁。此即显示或骨或锁或复骨锁。若复说言由憺怕路见彼彼骨。手骨异处。足骨异处。臗骨异处膝骨异处。臂骨异处肘骨异处。脊骨异处髆骨异处。肋骨异处。颔轮齿鬘顶髑髅等各各分散。或经一年或二或三乃至七年。其色鲜白犹如螺贝或如鸽色。或见彼骨和杂尘土。此即显示所有散坏。如是依外所有朽秽不净所缘。令于四种淫相应贪心得清净。由苦恼不净所缘及下劣不净所缘故。令于境相应若欲若贪心得清净。由观待不净所缘故。令于色相应若欲若贪心得清净。由烦恼不净所缘。及速坏不净所缘故。令于从欲界乃至有顶诸萨迦耶若欲若贪心得清净。是名贪行净行所缘。如是且约能净贪行。总说一切。通治所摄不净所缘。今此义中本意。唯取朽秽不净。所余不净亦是其余净行所缘。云何慈愍所缘。谓或于亲品或于怨品。或于中品。平等安住利益意乐。能引下中上品快乐定地胜解。当知此中亲品怨品及以中品。是为所缘。利益意乐能引快乐定地胜解。是为能缘。所缘能缘总略为一。说名慈愍所缘。若经说言。慈俱心者。此即显示于亲怨中三品所缘利益意乐。若复说言无怨无敌无损害者。此则显示利益意乐有三种相。由无怨故名为增上利益意乐。此无怨性二句所显。谓无敌对故无损恼故。不欲相违诤义是无敌对。不欲不饶益义是无损害。若复说言广大无量。此则显示能引下中上品快乐。欲界快乐名广。初二静虑地快乐名大。第三静虑地快乐名无量。若复说言胜解遍满具足住者。此则显示能引快乐定地胜解。又此胜解。即是能引快乐利益。增上意乐所摄胜解作意俱行。若于无苦无乐亲怨中三品有情。平等欲与其乐。当知是慈。若于有苦或于有乐亲怨中三品有情。平等欲拔其苦欲庆其乐。当知是悲是喜。有苦有情是悲所缘。有乐有情是喜所缘。是名慈愍所缘。若有嗔行补特伽罗。于诸有情修习慈愍令嗔微薄。名于嗔恚心得清净

瑜伽师地论卷第二十六瑜伽师地论卷第二十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第二瑜伽处之二

云何缘性缘起所缘。谓于三世唯行唯法唯事唯因唯果堕正道理。谓观待道理。作用道理。证成道理。法尔道理。唯有诸法能引诸法。无有作者及以受者。是名缘性缘起所缘。于此所缘作意思惟。痴行增上补特伽罗所有痴行皆得微薄。于诸痴行心得清净。是名缘性缘起所缘

云何界差别所缘。谓六界差别。一地界二水界三火界。四风界五空界六识界。云何地界。地界有二。一内二外。内地界者。谓此身中内别坚性。坚鞭所摄地地所摄。亲附执受。外地界者。谓外坚性。坚鞭所摄地地所摄。非亲附非执受。又内地界其事云何。谓发毛爪齿。尘垢皮肉。骸骨筋脉。肝胆心肺。脾肾肚胃。大肠小肠。生藏熟藏。及粪秽等。名内地界。又外地界其事云何。谓瓦木块砾树石山岩。如是等类名外地界。云何水界。水界有二。一内二外。内水界者。谓此身中内别湿性。湿润所摄水水所摄。亲附执受。其事云何。谓泪汗洟唾。肪膏脂髓。热痰脓血。脑膜尿等。名内水界。外水界者。谓外湿性。湿润所摄水水所摄。非亲附非执受。其事云何。谓井泉池沼陂湖河海。如是等类名外水界。云何火界。火界有二。一内二外。内火界者。谓此身中内别温性。温热所摄暖暖所摄。亲附执受。其事云何。谓于身中所有温暖。能令身热等热遍热。由是因缘所食所饮所啖所尝易正消变。彼增盛故堕蒸热数。如是等类名内火界。外火界者。谓外温性。温热所摄暖暖所摄。非亲附非执受。其事云何。谓于人间依钻燧等牛粪末等以求其火。火既生已能烧牛粪。或草或薪或榛或野或山或渚。或村村分或城城分或国国分。或复所余如是等类名外火界。云何风界。风界有二。一内二外。内风界者。谓此身中内别风性。风飘所摄轻性动性。亲附执受。其事云何。谓内身中有上行风有下行风。有胁卧风。有脊卧风。有腰间风有臗间风。有小刀风。有大刀风。有针刺风有毕钵罗风。有入出息风有随支节风。如是等类名内风界。外风界者。谓外风性。风飘所摄轻性动性。非亲附非执受。其事云何。谓在身外有东来风有西来风。有南来风有北来风。有有尘风有无尘风。有狭小风有广大风。有毗湿婆风有吠蓝婆风。有风轮风有时大风。卒起积集折树颓墙崩山荡海。既飘鼓已无所依凭自然静息。若诸有情欲求风者。动衣摇扇及多罗掌。如是等类名外风界。云何空界。谓眼耳鼻口咽喉等所有孔穴。由此吞咽。于此吞咽既吞咽已。由此孔穴便下漏泄。如是等类说名空界。云何识界。谓眼耳鼻舌身意识。又心意识三种差别是名识界。若诸慢行补特伽罗。于界差别作意思惟。便于身中离一合想得不净想。无复高举憍慢微薄。于诸慢行心得清净。是名慢行补特伽罗。由界差别净行所缘。云何阿那波那念所缘。谓缘入息出息念。是名阿那波那念。此念所缘入出息等。名阿那波那念所缘。当知此中入息有二。何等为二。一者入息二者中间入息。出息亦二。何等为二。一者出息。二者中间出息。入息者。谓出息无间内门风转乃至脐处。中间入息者。谓入息灭已乃至出息未生。于其中间在停息处。暂时相似微细风起。是名中间入息。如入息中间入息。出息中间出息当知亦尔。此中差别者。谓入息无间外门风转。始从脐处乃至面门。或至鼻端或复出外。入息出息有二因缘。何等为二。一牵引业。二脐处孔穴。或上身分所有孔穴。入息出息有二所依。何等为二。一身二心。所以者何。要依身心入出息转如其所应。若唯依身而息转者。入无想定入灭尽定。生无想天诸有情类彼息应转。若唯依心而息转者。入无色定生无色界。彼息应转。若唯依身心而转非如其所应者。入第四静虑若生于彼诸有情类。及羯罗蓝頞部昙闭尸等位诸有情类。彼息应转。然彼不转。是故当知要依身心。入出息转如其所应。入息出息有二种行。何等为二。一者入息向下而行。二者出息向上而行。入息出息有二种地。何等为二。一粗孔穴。二细孔穴。云何粗孔穴。谓从脐处孔穴乃至面门鼻门。复从面门鼻门乃至脐处孔穴。云何细孔穴。谓于身中一切毛孔。入息出息有四异名。何等为四。一名风。二名阿那波那。三名入息出息。四名身行。风名一种是风共名。余之三种是不共名。修入出息者有二过患。何等为二。一太缓方便。二太急方便。由太缓方便故生起懈怠。或为惛沉睡眠缠扰其心。或令其心于外散乱。由太急方便故。或令其身生不平等。或令其心生不平等。云何令身生不平等。谓强用力持入出息。由入出息被执持故。便令身中不平风转。由此最初于诸支节皆生战掉。名能战掉。此战掉风若增长时能生疾病。由是因缘于诸支节生诸疾病。是名令身生不平等。云何令心生不平等。谓或令心生诸散乱。或为极重忧恼逼切。是名令心生不平等。又此阿那波那念。应知略有五种修习。何等为五。一算数修习。二悟入诸蕴修习。三悟入缘起修习。四悟入圣谛修习。五十六胜行修习。云何名为算数修习。谓略有四种算数修习。何等为四。一者以一为一算数。二者以二为一算数。三者顺算数。四者逆算数。云何以一为一算数。谓若入息入时由缘入。出息住念数以为一。若入息灭出息生。出向外时数为第二。如是展转数至其十。由此算数非略非广故唯至十。是名以一为一算数。云何以二为一算数。谓若入息入而已灭。出息生而已出。尔时总合数以为一。即由如是算数道理。数至其十。是名以二为一算数。入息出息说名为二。总合二种数之为一。故名以二为一算数。云何顺算数。谓或由以一为一算数。或由以二为一算数。顺次展转数至其十。名顺算数。云何逆算数。谓即由前二种算数。逆次展转从第十数。次九次八次七次六次五次四次三次二。次数其一名逆算数。若时行者。或以一为一算数为依。或以二为一算数为依。于顺算数及逆算数已串修习。于其中间心无散乱。无散乱心善算数已。复应为说胜进算数。云何名为胜进算数。谓或依以一为一算数。或依以二为一算数。合二为一而算数之。若依以一为一而算数者。即入息出息二合为一。若依以二为一而算数者。即入息出息四合为一。如是展转数乃至十。如是后后渐增乃至以百为一而算数之。由此以百为一算数。渐次数之乃至其十。如是勤修数息念者。乃至十十数以为一。渐次数之乃至满十。由此以十为一算数。于其中间心无散乱。齐此名为已串修习。又此勤修数息念者。若于中间其心散乱。复应退还从初数起或顺或逆。若时算数极串习故。其心自然乘任运道。安住入息出息所缘。无断无间相续而转。先于入息有能取转。入息灭已于息空位有能取转。次于出息有能取转。出息灭已于息空位有能取转。如是展转相续流注。无动无摇。无散乱行。有爱乐转。齐此名为过算数地不应复数。唯于入息出息所缘令心安住。于入出息应正随行。应审了达。于入出息及二中间若转若还分位差别。皆善觉了。如是名为算数修习。又钝根者应为宣说如是息念算数修习。彼由此故于散乱处。令心安住令心爱乐若异算数入出息念。彼心应为惛沉睡眠之所缠扰。或应彼心于外驰散。由正勤修数息念故彼皆无有。若有利根觉慧聪俊。不好乘此算数加行。若为宣说算数加行。亦能速疾无倒了达然不爱乐。彼复于此入出息缘。安住念已。若是处转若乃至转。若如所转若时而转。于此一切由安住念。能正随行。能正了达如是加行有如是相。于此加行若修若习若多修习。为因缘故起身轻安及心轻安。证一境性。于其所缘爱乐趣入。如是彼于算数息念。善修习已。复于所取能取二事。作意思惟悟入诸蕴。云何悟入。谓于入息出息及息所依身。作意思惟悟入色蕴。于彼入息出息能取念相应领纳。作意思惟悟入受蕴。即于彼念相应等了。作意思惟悟入想蕴。即于彼念若念相应思及慧等。作意思惟悟入行蕴。若于彼念相应诸心意识。作意思惟悟入识蕴。如是行者。于诸蕴中乃至多住名已悟入。是名悟入诸蕴修习。若时无倒能见能知。唯有诸蕴唯有诸行。唯事唯法。彼于尔时能于诸行悟入缘起。云何悟入。谓观行者。如是寻求此入出息。何依何缘。既寻求已如实悟入。此入出息依身缘身依心缘心。复更寻求此身此心何依何缘。既寻求已如实悟入。此身此心依缘命根。复更寻求如是命根何依何缘。既寻求已如实悟入。如是命根依缘先行。复更寻求如是先行何依何缘。既寻求已如实悟入。如是先行依缘无明。如是了知无明依缘先行。先行依缘命根。命根依缘身心。身心依缘入息出息。又能了知无明灭故行灭。行灭故命根灭。命根灭故身心灭。身心灭故入出息灭。如是名为悟入缘起。彼于缘起悟入。多住名善习修。是名悟入缘起修习。如是彼于缘起悟入善修习已。复于诸行如实了知从众缘生。悟入无常。谓悟入诸行是无常故本无而有。有已散灭。若是本无而有。有已散灭。即是生法老法病法死法。若是生法老法病法死法。即是其苦。若是其苦即是无我不得自在远离宰主。如是名为由无常苦空无我行。悟入苦谛。又彼如是能正悟入。诸所有行众缘生起。其性是苦如病如痈。一切皆以贪爱为缘。又正悟入即此能生众苦贪爱。若无余断即是毕竟寂静微妙。我若于此如是了知如是观见如是多住。当于贪爱能无余断。如是名能悟入集谛灭谛道谛。于此悟入能多住已。于诸谛中证得现观。是名悟入圣谛修习。如是于圣谛中善修习已。于见道所断一切烦恼皆悉永断。唯余修道所断烦恼。为断彼故复进修习十六胜行。云何名为十六胜行。谓于念入息我今能学念于入息。于念出息我今能学念于出息。若长若短。于觉了遍身入息我今能学觉了遍身入息。于觉了遍身出息我今能学觉了遍身出息。于息除身行入息我今能学息除身行入息。于息除身行出息我今能学息除身行出息。于觉了喜入息我今能学觉了喜入息。于觉了喜出息我今能学觉了喜出息。于觉了乐入息我今能学觉了乐入息。于觉了乐出息我今能学觉了乐出息。于觉了心行入息我今能学觉了心行入息。于觉了心行出息我今能学觉了心行出息。于息除心行入息我今能学息除心行入息。于息除心行出息我今能学息除心行出息。于觉了心入息我今能学觉了心入息。于觉了心出息我今能学觉了心出息。于喜悦心入息我今能学喜悦心入息于喜悦心出息我今能学喜悦心出息。于制持心入息我今能学制持心入息。于制持心出息我今能学制持心出息。于解脱心入息我今能学解脱心入息。于解脱心出息我今能学解脱心出息于无常随观入息我今能学无常随观入息。于无常随观出息我今能学无常随观出息。于断随观入息我今能学断随观入息。于断随观出息我今能学断随观出息。于离欲随观入息我今能学离欲随观入息。于离欲随观出息我今能学离欲随观出息。于灭随观入息我今能学灭随观入息。于灭随观出息我今能学灭随观出息。问如是十六差别云何。答有学见迹已得四念住等。于入出息所缘。作意复更进修。为断余结。是故念言。于念入息我今能学念于入息。于念出息我今能学念于出息。若缘入息出息境时便作念言。我今能学念长入息念长出息。若缘中间入息中间出息境时便作念言。我今能学念短入息念短出息。如入息出息长转及中间入息中间出息短转。即如是了知。如是名为若长若短。若缘身中微细孔穴入息出息周遍随入诸毛孔中。缘此为境起胜解时便作念言。我于觉了遍身入息出息。我今能学觉了遍身入息出息。若于是时或入息中间入息已灭。出息中间出息未生。缘入息出息空无位。入息出息远离位为境。或出息中间出息已灭。入息中间入息未生。缘出息入息空无位。出息入息远离位为境。即于此时便作念言。于息除身行入息。我今能学息除身行入息。于息除身行出息。我今能学息除身行出息。又即于此若修若习若多修习为因缘故。先未串习入出息时。所有刚强苦触随转。今已串习入出息故皆得息除。有余柔软乐触随转。便作念言。于息除身行入息。我今能学息除身行入息。于息除身行出息。我今能学息除身行出息。又于如是阿那波那念勤修行者。若得初静虑或得第二静虑时。便作念言。于觉了喜入息出息。我今能学觉了喜入息出息。若得离喜第三静虑时。便作念言。于觉了乐入息出息。我今能学觉了乐入息出息。第三静虑已上。于阿那波那念。无有更修加行道理。是故乃至第三静虑宣说息念。加行所摄。又即如是觉了喜者觉了乐者。或有暂时生起忘念。或谓有我我所。或发我慢。或谓我当有或谓我当无。或谓我当有色或谓我当无色。或谓我当有想或谓我当无想。或谓我当非有想非无想。生起如是愚痴。想思俱行种种动慢。戏论造作贪爱才生起已。便能速疾以慧通达不深染着。方便断灭除遣变吐。由是加行便作念言。于觉了心行入息出息。我今能学觉了心行入息出息。于息除心行入息出息。我今能学息除心行入息出息。又若得根本第一第二第三静虑。彼定已得初静虑近分未至依定。依此观察所生起心。谓如实知如实觉了。或有贪心或离贪心。或有嗔心或离嗔心。或有痴心或离痴心。略心散心下心举心。有掉动心无掉动心。有寂静心无寂静心。有等引心无等引心。善修习心不善修习心。善解脱心不善解脱心。于如是心皆如实知如实觉了。是故念言。于觉了心入息出息。我今能学觉了心入息出息。彼若有时见为惛沉睡眠盖覆障其心。由极于内住寂止故。尔时于外随缘一种净妙境界。示现教导赞励庆喜策发其心。是故念言。于喜悦心入息出息。我今能学喜悦心入息出息。彼若有时见为掉举恶作盖覆障其心。由极于外住嚣举故。尔时于内安住寂静制持其心。是故念言。于制持心入息出息。我今能学制持心入息出息。若时于心善修善习。善多修习为因缘故。令现行盖皆得远离。于诸盖中心得清净。是故念言。于解脱心入息出息。我今能学解脱心入息出息。彼于诸盖障修道者心已解脱。余有随眠复应当断。为断彼故起道现前。谓于诸行无常法性。极善精恳如理观察。是故念言。于无常随观入息出息。我今能学无常随观入息出息。又彼先时或依下三静虑。或依未至依定。已于奢摩他修瑜伽行。今依无常随观。复于毗钵舍那修瑜伽行。如是以奢摩他毗钵舍那熏修心已。于诸界中从彼随眠而求解脱。云何诸界。所谓三界。一者断界。二者离欲界。三者灭界。见道所断一切行断名为断界。修道所断一切行断名离欲界。一切依灭名为灭界。思惟如是三界寂静。安隐无患修奢摩他毗钵舍那。彼由修习多修习故。从余修道所断烦恼心得解脱。是故念言。于断随观离欲随观灭随观入息出息。我今能学断随观离欲随观灭随观入息出息。如是彼于见修所断一切烦恼皆永断故。成阿罗汉。诸漏永尽。此后更无所应作事。于所决择已得究竟。是名十六胜行。修习如是名为五种修习阿那波那念。多寻思行补特伽罗。应于是中正勤修学爱乐乘御。若于所缘有思遽务有散乱者。于内各别应当亲近如是观行。若于此中勤修习者。寻思散动皆无所有。心于所缘速疾安住深生爱乐。是名第五多寻思行补特伽罗净行所缘。如是总名净行所缘。

云何名为善巧所缘。谓此所缘略有五种。一蕴善巧。二界善巧。三处善巧。四缘起善巧。五处非处善巧。蕴善巧者。云何蕴。云何蕴善巧。谓蕴有五。则色蕴。受蕴。想蕴。行蕴。识蕴。云何色蕴。谓诸所有色。一切皆是四大种及四大种所造。此复若过去若未来若现在。若内若外若粗若细。若劣若胜若远若近。总名色蕴。云何受蕴。谓或顺乐触为缘诸受。或顺苦触为缘诸受。或顺不苦不乐触为缘诸受。复有六受身。则眼触所生受。耳鼻舌身意触所生受。总名受蕴。云何想蕴。谓有相想无相想。狭小想广大想。无量想无诸所有无所有处想。复有六想身。则眼触所生想。耳鼻舌身意触所生想。总名想蕴。云何行蕴。谓六思身。则眼触所生思。耳鼻舌身意触所生思。复有所余除受及想。诸心法等总名行蕴。云何识蕴。谓心意识。复有六识身。则眼识耳鼻舌身意识。总名识蕴。前受想行蕴及此识蕴。皆有过去未来现在内外等差别。如前广说。是名为蕴。云何蕴善巧。谓善了知如所说蕴种种差别性非一众多性。除此法外更无所得无所分别。是名略说蕴善巧义。云何名蕴种种差别性。谓色蕴异。受蕴异。乃至识蕴异。是名种种差别性。云何名蕴非一众多性。谓色蕴非一众多品类。大种所造差别故。去来今等品类差别故。是名色蕴非一众多性。如是余蕴随其所应皆当了知。云何除此法外更无所得无所分别。谓唯蕴可得唯事可得。非离蕴外有我可得有常恒住。无变易法是可得者。亦无少法是我所有。故除此外更无所得无所分别。云何界。云何界善巧。谓界有十八。则眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。是名为界。若复于彼十八种法。从别别界别别种子别别种姓。生起出现。如实了知忍可审察。名界善巧。如实了知十八种法从别别界别别而转。即于因缘而得善巧。是故说此名界善巧。云何处。云何处善巧。谓处有十二。则眼处色处。耳处声处。鼻处香处。舌处味处。身处触处。意处法处。是名为处。处善巧者。谓眼为增上缘。色为所缘缘等无间灭。意为等无间缘。生起眼识及相应法。耳为增上缘。声为所缘缘等无间灭。意为等无间缘。生起耳识及相应法。如是乃至意为等无间缘。此生作意为增上缘。法为所缘缘。生起意识及相应法。如是六识身及相应法。皆由三缘而得流转。谓增上缘。所缘缘。等无间缘。若于如是诸内外处。缘得善巧名处善巧。云何缘起。云何缘起善巧。谓无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死。乃至招集如是纯大苦蕴。是名缘起。若复了知唯有诸法滋润诸法。唯有诸法等润诸法。唯有诸行引发诸行。而彼诸行因所生故缘所生故本无而有。有已散灭体是无常。是无常故即是生法老法病法死法。愁悴悲叹忧苦恼法。是生法故乃至是恼法故。则名为苦。由是苦故不得自在其力羸劣。由是因缘定无有我。若于如是缘生法中。由如是等种种行相善巧。了达或无常智或苦智或无我智。是名缘起善巧。又处非处善巧。当知即是缘起善巧差别。此中差别者。谓由处非处善巧故。能正了知非不平等因果道理。则善不善法有果异熟。若诸善法能感可爱果异熟法。诸不善法能感非爱果异熟法。若能如是如实了知。名处非处善巧。此五善巧略则为二。一自相善巧。二共相善巧。由蕴善巧显自相善巧。由余善巧显共相善巧。如是总名善巧所缘。

云何净惑所缘。谓观下地粗性上地静性。如欲界对初静虑乃至无所有处对非想非非想处。云何粗性。谓粗性有二。一体粗性。二数粗性。体粗性者。谓欲界望初静虑。虽皆具五蕴。而欲界中过患深重苦住增上。最为鄙劣甚可厌恶。

是故说彼为体粗性。初静虑中则不如是。极静极妙。是故说彼为体静性。数粗性者。谓欲界色蕴有多品类。应知应断。如是乃至识蕴亦尔。是故说彼为数粗性。如是上地展转相望。若体粗性若数粗性。随其所应当知亦尔。如是粗性。于诸上地展转相望。乃至极于无所有处。一切下地苦恼增多寿量减少。一切上地苦恼减少寿量增多。非想非非想处唯静唯妙。更无上地胜过此故。以要言之有过患义。是粗性义。若彼彼地中过患增多。即由如是过患增多性故。名为粗性。若彼彼地中过患减少。即由如是过患减少性故。名为静性。此是世间由世俗道净惑所缘。何以故。彼观下地多诸过患。如病如痈犹如毒箭。不安隐性以为粗性。观于上地与彼相违以为静性。断除下地所有烦恼。始从欲界乃至上极无所有处。此是暂断非究竟断。以于后时更相续故。出世间道净惑所缘复有四种。一苦圣谛。二集圣谛。三灭圣谛。四道圣谛。云何苦圣谛。谓生苦老苦病苦死苦。怨憎会苦。爱别离苦。求不得苦。略说一切五取蕴苦。名苦圣谛。云何集圣谛。谓若爱若后有爱。若喜贪俱行爱。若彼彼喜乐爱等。名集圣谛。云何灭圣谛。谓即此爱等无余断灭。名灭圣谛。云何道圣谛。谓八支等圣道。名道圣谛。当知此中依黑品白品果因建立。故建立四圣谛。谓苦谛是黑品果。集谛是黑品因。灭谛是白品果。道谛是白品因。能得能证故。又苦谛如病初应遍知。集谛如病因缘次应远离。灭谛如无病次应触证。道谛如良药复应修习及多修习。又苦谛苦义。乃至道谛道义。是如是实非不如实。是无颠倒非是颠倒。故名为谛。又彼自相无有虚诳及见。彼故无倒觉转。是故名谛。问何故诸谛唯名圣谛。答唯诸圣者于是诸谛同谓为谛。如实了知如实观见。一切愚夫不如实知不如实见。是故诸谛唯名圣谛。又于愚夫唯由法尔说名为谛不由觉悟。于诸圣者俱由二种。又生苦者。谓于生时发生种种身心苦受。非生自体即是其苦。为苦因缘。故名为苦。广说乃至求不得苦。谓由所求不得因缘。发生种种身心苦受。非求不得体即是苦。为苦因缘。故名为苦。如是当知略说一切五取蕴苦。谓由生等异门唯显了苦苦。由此五取蕴苦。亦显了所余坏苦行苦。所以者何。如五取蕴具摄三受。如是能与如前所说苦苦为器。当知此中亦即具有前所未说坏苦行苦。问何故世尊苦苦一种以自声说。坏苦行苦以异门说。答于苦苦中若凡若圣一切等有苦觉慧转。又苦苦性极可厌患。又从先来未习慧者。才为说时则便易入。又于诸谛令所调伏可化有情易得入故。云何建立三种苦性。谓先所说生苦。乃至求不得苦。即显苦受及所依处为苦苦性。如是名为建立苦苦性。诸有是彼所对治法。谓少是老所治。无病是病所治。命是死所治。亲爱合会是怨憎会所治。非爱别离是爱别离所治。所求称遂是求不得所治。复有苦受及所依处所起烦恼。复有无病等顺乐受处等。及彼所生受所起烦恼。如是总说为坏苦性。此中乐受及所依处由无常故若变若异。受彼增上所生众苦。若诸烦恼于一切处正生起时。缠缚其心令心变坏即生众苦故名坏苦。如世尊言入变坏心执母邑手。乃至广说。又如说言住贪欲缠领受。贪欲缠缘所生身心忧苦。如是住嗔恚惛沈。睡眠掉举。恶作疑缠领受。彼缠缘所生身心忧苦。由此至教第一至教。诸烦恼中苦义可得。坏义可得。故说烦恼为坏苦性。如是名为建立坏苦性。若行苦性遍行一切五取蕴中。以要言之。除苦苦性。除烦恼摄。变坏苦性除乐受摄及所依处。变坏苦性诸余不苦不乐受俱行。若彼所生若生彼缘。若生住器所有诸蕴。名行苦性。由彼诸蕴其性无常。生灭相应有一切取。三受粗重之所随逐。不安隐摄。不脱苦苦及以坏苦。不自在转由行苦故说名为苦。如是名为建立行苦性。又即彼爱亦名希求。亦名欣欲亦名喜乐。即此希求由三门转。谓希求后有。及希求境界。若希求后有名后有爱。希求境界复有二种。谓于已得境界。有喜着俱行爱。若于未得境界。有希求和合俱行爱。当知此中于已得境界。喜着俱行爱。名喜贪俱行爱。于未得境界希求和合俱行爱。名彼彼喜乐爱。灭有二种。一烦恼灭。二所依灭。道有二种。一有学道。二无学道。如是当知名出世道净惑所缘。如是已说四种所缘。一遍满所缘。二净行所缘。三善巧所缘。四净惑所缘。

云何教授。谓四教授。一无倒教授。二渐次教授。三教教授。四证教授。云何无倒教授。谓无颠倒宣说法义。令其受持读诵修学。如实出离正尽众苦作苦边际。如是名为无倒教授。云何渐次教授。谓称时机宣说法义。先令受持读诵浅近后方令彼学深远处。又为令入初谛现观先教苦谛后集灭道。又为令得静虑等至。先教最初静虑等至。后教其余静虑等至。如是等类应知名为渐次教授。云何教教授。谓从尊重若似尊重达解瑜伽轨范亲教。或诸如来或佛弟子所。闻正教。即如其教不增不减教授于他名教教授。云何证教授。谓如自己独处空闲。所得所触所证诸法。为欲令他得触证故。方便教授名证教授。

复有诸相圆满教授。其事云何。谓由三种神变教授。三神变者。一神境神变。二记说神变。三教诫神变。由神境神变。能现种种神通境界。令他于己生极尊重。由彼于己生尊重故。于属耳听瑜伽。作意极生恭敬。由记说神变。能寻求他心行差别。由教诫神变。如根如行如所悟入。为说正法于所修行能正教诫。故三神变能摄诸相圆满教授

瑜伽师地论卷第二十七瑜伽师地论卷第二十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第二瑜伽处之三

云何为学。谓三胜学。一增上戒学。二增上心学。三增上慧学。云何增上戒学。谓安住具戒等。如前广说。是名增上戒学。云何增上心学。谓离欲恶不善法。有寻有伺离生喜乐。入初静虑具足安住乃至能入第四静虑具足安住。是名增上心学。又诸无色及余所有等持等至。亦皆名为增上心学。然依静虑能最初入圣谛现观正性离生。非全远离一切静虑能成此事。是故静虑最为殊胜。故偏说为增上心学。云何增上慧学。谓于四圣谛等所有如实智见。是名增上慧学。问何缘唯有三学非少非多。答建立定义故。智所依义故。辨所作义故。建立定义者。谓增上戒学。所以者何。由戒建立心一境性。能令其心触三摩地。智所依义者。谓增上心学。所以者何。由正定心念一境性。于所知事有如实智如实见转。辨所作义者。谓增上慧学。所以者何。由善清净若智若见。能证究竟诸烦恼断。以烦恼断。是自义利是胜所作。过此更无胜所作故。由是因缘唯有三学。问何缘三学如是次第。答先于尸罗善清净故便无忧悔。无忧悔故欢喜安乐。由有乐故心得正定。心得定故能如实知能如实见。如实知见故能起厌。厌故离染。由离染故便得解脱。得解脱故证无所作究竟涅槃。如是最初修习净戒。渐次进趣后证无作究竟涅槃。是故三学如是次第。问何缘三学名为增上戒心慧耶。答所趣义故最胜义故名为增上。云何所趣义。谓为趣增上心而修净戒。名增上戒学。为趣增上慧而修定心。名增上心学。为趣烦恼断而修智见。名增上慧学。如是名为所趣义故名为增上。云何最胜义。谓若增上戒学。若增上心学。若增上慧学。唯于圣教独有此三不共外道。如是名为最胜义故。名为增上。又或有增上心学能引发增上慧学。或有增上慧学能引发增上心学。谓圣弟子未得根本静虑。先学见迹。后为进断修道所断一切烦恼。正勤加行修念觉支。乃至修舍觉支。是名增上慧学引发增上心学。增上心学引发增上慧学者。如前已说。又或有增上戒学无增上心无增上慧。或有增上戒学亦有增上心唯无增上慧。非有增上慧学而无增上戒及无增上心。是故若有增上慧学。当知必定具足三学。于此建立三种学中。诸瑜伽师当勤修。学复有三种补特伽罗。依此三学入谛现观。何等为三。一未离欲。二倍离欲。三已离欲。当知此中于一切欲全未离者。勤修加行入谛现观。既于诸谛得现观已证预流果。倍离欲者。当于尔时证一来果。

已离欲者。当于尔时证不还果。复有三根。一未知欲知根。二已知根。三具知根。云何建立如是三根。谓于诸谛未现观者。加行勤修诸谛现观。依此建立未知欲知根。若于诸谛已得现观而居有学。依此建立已知根。若阿罗汉所作已办住无学位。依此建立具知根。

复有三解脱门。一空解脱门。二无愿解脱门。三无相解脱门。云何建立三解脱门。谓所知境略有二种。有及非有。有有二种。一者有为。二者无为。于有为中且说三界所系五蕴。于无为中且说涅槃。如是二种有为无为合说名有。若说于我或说有情命者生者等。是名非有。于有为中见过失故。见过患故无所祈愿。无祈愿故依此建立无愿解脱门。于有为中无祈愿故。便于涅槃深生祈愿。见极寂静见甚微妙见永出离。由于中见永出离故。依此建立无相解脱门。于其非有无所有中。非有祈愿非无祈愿。如其非有还则如是。知为非有。见为非有。依此建立空解脱门。是名建立三解脱门

云何随顺学法。谓有十种违逆学法。对治彼故应知十种随顺学法。云何十种违逆学法。一者所有母邑少年盛壮可爱形色。是正修学善男子等上品障碍。二者于萨迦耶所摄诸行生起爱着。三者懒堕懈怠。四者萨迦耶见。五者依于段食贪着美味。六者于诸世闻种种戏论非一众多别别品类所思念中发欲贪爱。七者思惟诸法瑜伽作意所有过患。此复云何。谓十一种。一于诸谛宝蕴业果中犹预疑惑。二乐修断者身诸粗重。三有慢缓者于修止观。过患作意惛沉睡眠。映蔽其心令心极略。四太猛精进者身疲心恼。五太劣精进者不得胜进善品衰退。六于少利养名誉称赞。随一乐中深生欣喜。七掉举不静踊跃躁扰。八于萨迦耶永灭涅槃而生惊恐。九于诸言说非量加行言论太过。虽说法论而好折伏起诤方便。十于先所见所闻所受非一众多别别品类诸境界中。心驰心散。十一不应思处而强沉思。应知是名思惟诸法瑜伽作意所有过患。八者于诸静虑等至乐中深生爱味。九者乐欲证入无相定者。于诸行中随顺流散。十者触身苦受乃至夺命苦受时。贪爱寿命希望存活。随此希望伤叹迷闷。是名十种违逆学法。云何对治如是十种违逆学法随顺学法。谓有十种。一不净想。二无常想。三无常苦想。四苦无我想。五厌逆食想。六一切世间不可乐想。七光明想。八离欲想。九灭想。十死想。如是十想善修善习善多修习。能断十种障碍学法违逆学法。当知此中有四光明。一法光明。二义光明。三奢摩他光明。四毗钵舍那光明。依此四种光明增上立光明想。今此义中意。取能断思惟诸法瑜伽作意障碍法者。

当知此中复有十种随顺学法。何等为十。一者宿因。二者随顺教。三者如理加行。四者无间殷重所作。五者猛利乐欲。六者持瑜伽力。七者止息身心粗重。八者数数观察。九者无有怯弱。十者离增上慢。云何宿因。谓先所习诸根成熟诸根积集。云何随顺教。谓所说教无倒渐次。云何如理加行。谓如其教无倒修行。如是修行能生正见。云何无间殷重所作。谓由如是正加行故。于诸善品不虚舍命。速能积习所有善品。云何猛利乐欲。谓如有一于上解脱发生希慕。谓我何时当于是处能具足住。如诸圣者于是处所具足而住。云何持瑜伽力。谓二因缘能令获得持瑜伽力。一者本性是利根故。二者长时串修习故。云何止息身心粗重。谓如有一或由身劳身乏。发身粗重发心粗重。此因易脱威仪而便止息。或由太寻太伺。发身粗重发心粗重。此因内心寂止方便而便止息。或由心略心劣惛沉睡眠之所缠绕。发身粗重发心粗重。此因增上慧法毗钵舍那顺净作意而便止息。或由本性烦恼未断有烦恼品。身心粗重未能舍离。此因相续勤修正道而便止息。云何数数观察。谓依尸罗数数观察恶作不作。数数观察善作而作。于其恶作不作不转。于其善作不作不退。于其恶作作而弃舍。于其善作作而不舍。又于烦恼断与未断观察作意。增上力故数数观察。若知已断便生欢喜。若知未断则便数数勤修正道。云何无有怯弱。谓于后时应知应见应证得中。未知未见未证得故发生怯弱。其心劳倦其心匮损。彼既生已而不坚执速能断灭。云何离增上慢。谓于所得所触所证。无增上慢离颠倒执。于真所得起于得想。于真所触起于触想。于真所证起于证想。如是十法。于乐修学诸瑜伽师所应修学。初中后时恒常随顺无有违逆。是故名为随顺学法。

云何瑜伽坏。谓坏瑜伽略有四种。何等为四。一者毕竟瑜伽坏。二者暂时瑜伽坏。三者退失所得瑜伽坏。四者邪行所作瑜伽坏。

毕竟瑜伽坏者。谓无种姓补持伽罗。何以故。由彼身中无能趣向涅槃法故。毕竟失坏出世瑜伽。暂时瑜伽坏者。谓有种姓补特伽罗。何以故。由彼身中有能趣向涅槃法故。虽阙外缘时经久远。定当缘会修习瑜伽令其现起。善修习已当般涅槃。是故说彼所有瑜伽暂时失坏。退失所得瑜伽坏者。谓如有一退失所得所触所证。若智若见若安乐住。邪行所作瑜伽坏者。谓如有一不如正理精勤修行。虽多用功无所成办。不能成办一切瑜伽。亦非善法。又如有一多诸烦恼性多尘秽。而识聪锐觉慧猛利成俱生觉。善摄所闻于闻究竟。或少或多或住空闲。有在家者及出家者。为性质直来至其所。因为说法令心欢喜。又行矫诈。妄现种种身语相应调善所作。由是因缘招集利养恭敬称颂大福德想。及得种种衣食卧具病缘医药资身什物。为诸国王大臣居士乃至商主恭敬尊重。咸共谓之是阿罗汉。或于随彼回转弟子。若诸出家若在家众。恋着亲爱随顺而转为多招引。复生是念。此诸出家在家弟子信顺于我。咸共谓我是阿罗汉。彼若依于瑜伽作意止观等处来请问我。我得彼问或不能对。彼因是事当于我所舍信向心。不复谓我是阿罗汉。由斯退失利养恭敬。我于今者应自思惟筹量观察安立瑜伽。彼由是事增上力故。耽着利养恭敬名誉。独处空闲自谛思惟筹量观察安立瑜伽。然此瑜伽不顺契经不现戒律违逆法性。若诸比丘善持三藏。彼于其所覆自瑜伽不欲开示。若诸在家出家弟子。于此瑜伽私窃教示不令彰显。所以者何。恐有善持三藏教者。闻彼如是瑜伽处已。以经捡验不顺契经。以律显照不现戒律。以法观察违逆法性。由是因缘便不信受。以不信言诘难于我诤竞举发。由是国王大臣居士乃至饶财长者商主不复恭敬尊重于我。更不获得衣食卧具病缘医药资身什物。彼由贪着利养恭敬增上力故。于非法中起于法想。起覆藏想。起恶欲乐显发开示非法为法。诸有忍许彼所见者。亦于非法起是法想。愚昧顽钝于非法中起法想故。虽如其教精进修行。当知一切皆是邪行。如是名为邪行所作瑜伽失坏。像似正法非真正法能障正法。诸有比丘勤修静虑。是瑜伽师于此四种瑜伽坏法。应正遍知当远舍离

云何瑜伽。谓四瑜伽。何等为四。一信。二欲。三精进。四方便。

当知其信有二行相及二依处。二行相者。一信顺行相。二清净行相。二依处者。一观察诸法道理依处。二信解补特伽罗神力依处。欲有四种。何等为四。一为证得欲。二为请问欲。三为修集资粮欲。四为随顺瑜伽欲。为证得欲者。谓如有一于上解脱发生希慕。如前广说。为请问欲者。谓如有一生希慕已往僧伽蓝。诣诸有识同修梵行成就瑜伽妙智者所。为听未闻为闻究竟。为修集资粮欲者。谓如有一为戒律仪清净。为根律仪清净故。于食知量减省睡眠。正知住中展转增胜发生希慕。为随顺瑜伽欲者。谓于无间加行殷重加行。修习道中发生希慕发生欣乐。欲有所作精进有四。何等为四。一为闻精进。二为思精进。三为修精进。四为障净精进。为闻精进者。谓为听未闻闻已究竟。勤心勇猛审决加行。为思精进者。谓如所闻法独处空闲。思惟其义筹量观察。为修精进者。谓入寂静于时时间勤修止观。为障净精进者。谓于昼夜策励精勤经行宴坐。从诸障法净修其心。勤心勇猛审决。精进方便有四。谓尸罗律仪增上力故善守其念。善守念故能无放逸。防护其心修诸善法。无放逸故心正于内修奢摩他增上慧法毗钵舍那。此四瑜伽有十六种。

当知此中初由信故于应得义深生信解。信应得已于诸善法生起乐欲。由乐欲故昼夜策励安住精勤。坚固勇猛发精进已。摄受方便能得未得。能触未触。能证未证。故此四法说名瑜伽

云何作意。谓四作意。何等为四。一力励运转作意。二有间运转作意。三无间运转作意。四无功用运转作意。云何力励运转作意。谓初修业者令心于内安住等住。或于诸法无倒简择。乃至未得所修作意。尔时作意力励运转。由倍励力折挫其心令住一境。故名力励运转作意。云何有间运转作意。谓得所修作意已后。世出世道渐次胜进。了相作意由三摩地思所间杂。未能一向纯修行转。故名有间运转作意。云何无间运转作意。谓从了相作意已后。乃至加行究竟作意。是名无间运转作意。云何无功用运转作意。谓加行究竟果作意。是名无功用运转作意。复有所余四种作意。一随顺作意。二对治作意。三顺清净作意。四顺观察作意。云何随顺作意。谓于所缘深生厌坏起正加行。而未断惑。云何对治作意。谓能断惑。云何顺清净作意。谓心下蹙取净妙相策令欢悦。云何顺观察作意。谓观察作意。由此作意增上力故。顺观烦恼断与未断。

问于所缘境正作意时。思惟几相。答四。何等为四。一所缘相。二因缘相。三应远离相。四应修习相。所缘相者。谓所知事同分影像明了显现。因缘相者。谓三摩地资粮积集。随顺教导与修俱行猛利乐欲。于可厌法深生厌患。能审遍知乱与不乱。他不恼触。或人所作或非人作。或音声作或功用作。若毗钵舍那而为上首。内略其心极猛盛观后因缘相。若奢摩他而为上首。发起胜观极猛盛止后因缘相。应远离相复有四种。一者沈相。二者掉相。三者着相。四者乱相。沈相者。谓由所缘相因缘相故令心下劣。掉相者。谓由所缘相因缘相故令心高举。着相者。谓由所缘相因缘相故。令心于境起染起著作诸恼乱。乱相者。谓由所缘相因缘相故令心于外驰散扰动。如是诸相如前等引地中已说。

问如是作意于所缘境起胜解时有几胜解。答九。何等为九。一有光净胜解。二无光净胜解。三迟钝胜解。四捷利胜解。五狭小胜解。六广大胜解。七无量胜解。八清净胜解。九不清净胜解。有光净胜解者。谓于光明相澄心善取与光明俱所有胜解。无光净胜解者。谓于光明相不能善取与闇昧俱所有胜解。迟钝胜解者。谓钝根身中所有胜解。捷利胜解者。谓利根身中所有胜解。狭小胜解者。谓狭小信欲俱行胜解。及狭小所缘意解胜解。如是作意狭小故。及所缘狭小故。名狭小胜解。广大胜解者。谓广大信欲俱行胜解。及广大所缘意解胜解。如是作意广大故。及所缘广大故。名广大胜解。无量胜解者。谓无边无际信欲俱行胜解。及无边无际所缘意解胜解。如是作意无量故及所缘无量故。名无量胜解。清净胜解者。谓已善修已成满已究竟俱行胜解。不清净胜解者。谓未善修未成满未究竟俱行胜解。

问修瑜伽者。凡有几种瑜伽所作。答四。何等为四。一所依灭。二所依转。三遍知所缘。四爱乐所缘。所依灭及所依转者。谓勤修习瑜伽作意故。所有粗重俱行所依渐次而灭。所有轻安俱行所依渐次而转。是名所依灭及所依转瑜伽所作。遍知所缘及爱乐所缘者。谓或有遍知所缘爱乐所缘与所依灭转而为上首。由此遍知所缘爱乐所缘增上力故。令所依灭及所依转。或有遍知所缘爱乐所缘。用所依清净而为上首。由此所依清净增上力故。令遍知所缘得善清净。及爱乐所缘得善清净。于其所作成办时转。是名四种修瑜伽者瑜伽所作

问修瑜伽师凡有几种。答三。何等为三。一初修业瑜伽师。二已习行瑜伽师。三已度作意瑜伽师。云何初修业瑜伽师。谓有二种初修业者。一于作意初修业者。二净烦恼初修业者。云何于作意初修业者。谓初修业补特伽罗安住一缘勤修作意。乃至未得所修作意。未能触证心一境性。云何净烦恼初修业者。谓已证得所修作意。于诸烦恼欲净其心。发起摄受正勤修习了相作意名净烦恼初修业者。云何已习行瑜伽师。谓除了相作意。于余乃至加行究竟五作意中已善修习。云何已度作意瑜伽师。谓住加行究竟果作意位中。由此超过加行方便所修作意安住修果。是故说名已度作意。

又始从修习善法欲已去。乃至未起顺决择分善根。于尔所时名初修业。若已起顺决择分善根。所谓暖顶随顺谛忍世第一法名已习行。若已证入正性离生得谛现观。不由他缘于佛圣教。不为余缘之所引夺。当于尔时名度作意。由彼超过他缘作意。住非他缘所有作意。是故名为已度作意。

云何瑜伽修。谓有二种。一者想修。二者菩提分修

云何想修。谓或修世间道时。于诸下地修过患想。或修涅槃道时。于断界离欲界灭界。观见最胜寂静功德。修习断想离欲想灭想。或修奢摩他时。修习止品上下想。或修毗钵舍那时。修习观品前后想。上下想者。谓观察此身如其所住如其所愿。上从顶上下至足下。种种杂类不净充满。谓此身中所有种种发毛爪齿。如前广说。前后想者。谓如有一于所观相殷勤恳到。善取善思善了善达。谓住观于坐坐观于卧。或在后行观察前行。此则显示以毗钵舍那行。观察三世缘生诸行。谓若说言住观于坐。此则显示以现在作意观察未来所知诸行。所以者何。现在作意位已现生故说名为住。未来所知位未现生故。临欲起故说名为坐。若复说言坐观于卧。此则显示以现在作意观察过去所知诸行。所以者何。现在作意位临欲灭故说名为坐。过去所知位已谢灭故说名为卧。若复说言或在后行观察前行。此则显示以现在作意观无间灭现行作意。所以者何。若已生起无间谢灭所取作意说名前行。若此无间新新生起能取作意。取前无间已谢灭者。说名后行。当知此中为修止观。修彼二品胜光明想。是名想修。

云何菩提分修。谓于三十七菩提分法亲近积集。若修若习若多修习。是名菩提分修。何等名为三十七种菩提分法。谓四念住。四正断。四神足。五根五力。七觉支。八圣道。四念住者。一身念住。二受念住。三心念住。四法念住。四正断者。一于已生恶不善法为令断故。生欲策励发勤精进。策心持心正断。二于未生恶不善法为不生故。生欲策励发勤精进。策心持心正断。三于未生善法为令生故。生欲策励发勤精进。策心持心正断。四于已生善法为欲令住令不忘失。令修圆满令倍修习。令其增长令其广大。生欲策励发勤精进。策心持心正断。四神足者。一欲三摩地断行成就神足。二勤三摩地断行成就神足。三心三摩地断行成就神足。四观三摩地断行成就神足。五根者。一信根。二精进根。三念根。四定根。五慧根。五力者。一信力。二精进力。三念力。四定力。五慧力。七觉支者。一念等觉支。二择法等觉支。三精进等觉支。四喜等觉支。五安等觉支。六定等觉支。七舍等觉支。八支圣道者。一正见。二正思惟。三正语。四正业。五正命。六正精进。七正念。八正定

今于此中云何为身。云何于身住循身观。云何为念。云何念住。略说身相有三十五。谓内身外身。根所摄身非根所摄身。有情数身非有情数身。粗重俱行身轻安俱行身。能造身所造身。名身色身。那落迦身傍生身。祖父国身人身天身。有识身无识身。中身表身。变异身不变异身。女身男身半择迦身。亲友身非亲友身。中庸身劣身。中身妙身。幼身少身老身。如是名为身相差别。住循身观略有三种。谓依身增上闻思修慧。由此慧故于一切身一切相。正观察正推求。随观随觉念。谓依身增上受持正法。思惟法义修习作证。于文于义修作证中心无忘失。若审思惟。我于正法为正受持为不尔耶。于彼彼义慧善了达为不尔耶。善能触证彼彼解脱为不尔耶。如是审谛安住其念。名为念住。又为守护念。为于境无染。为安住所缘。名为念住。为守护念者。谓如说言先守护念。若常委念。为于境无染者。谓如说言念守护心行平等位。不取其相不取随好。广说乃至守护意根修意根律仪。为安住所缘者。谓如说言于四所缘安住其念。谓于遍满所缘净行所缘善巧所缘净惑所缘。由此三相善住其念故名念住。云何为受。谓乐受苦受。不苦不乐受。乐身受苦身受。不苦不乐身受。如说身受心受亦尔。乐有爱味受。苦有爱味受。不苦不乐有爱味受。无爱味受。依耽嗜受。当知亦尔。乐依出离受。苦依出离受。不苦不乐依出离受。如是总有二十一受。或九种受。云何为心。谓有贪心离贪心。有嗔心离嗔心。有痴心离痴心。略心散心。下心举心。掉心不掉心。寂静心不寂静心。定心不定心。善修心不善修心。善解脱心不善解脱心。如是总有二十种心。云何为法。谓若贪贪毗奈耶法。若嗔嗔毗奈耶法。若痴痴毗奈耶法。若略若散法。若下若举法。若掉不掉法。若寂静不寂静法。若定不定法。若善修不善修法。若善解脱不善解脱法。如是当知建立黑品白品染品净品二十种法。又乐受者。谓顺乐受触为缘所生平等受受所摄。是名乐受。此若五识相应名身受。若意识相应名心受。如顺乐受触。如是顺苦受触。顺不苦不乐受触为缘所生。不平等受受所摄。非平等非不平等受受所摄。是名苦受不苦不乐受。此若五识相应名身受。若意识相应名心受。如是诸受若随顺涅槃。随顺决择毕竟出离毕竟离垢毕竟。能令梵行圆满名无爱味受。若堕于界名有爱味受。若色无色界系若随顺离欲。名依出离受。若欲界系若不顺离欲。名依耽嗜受。又有贪心者。谓于可爱所缘境事贪缠所缠。离贪心者。谓即远离如是贪缠。有嗔心者。谓于可憎所缘境事嗔缠所缠。离嗔心者。谓即远离如是嗔缠。有痴心者。谓于可愚所缘境事痴缠所缠。离痴心者谓即远离如是痴缠。如是六心当知皆是行时所起三烦恼品。及此三品对治差别。略心者。谓由正行于内所缘系缚其心。散心者。谓于外五妙欲随顺流散。下心者。谓惛沉睡眠俱行。举心者。谓于净妙所缘明了显现。掉心者。谓大举故掉缠所掉。不掉心者。谓于举时及于略时得平等舍。寂静心者。谓从诸盖已得解脱。不寂静心者。谓从诸盖未得解脱言。定心者。谓从诸盖得解脱已。复能证入根本静虑。不定心者。谓未能入。善修心者。谓于此定长时串习。得随所欲得无艰难得无梗涩。速能证入。不善修心者。与此相违应知其相。善解脱心者。谓从一切究竟解脱。不善解脱心者。谓不从一切不究竟解脱。如是十四种心当知皆是住时所起。依净盖地住时所起有八种心。谓从略心散心乃至寂静不寂静心。依净烦恼地住时所起有六种心。谓定心不定心乃至善解脱不善解脱心。又于内有盖能自了知我有诸盖。于内无盖能自了知我无诸盖。如彼诸盖未生而生亦能了知。如彼诸盖生已散灭亦能了知。于眼有结乃至于意有结。能自了知我有眼结乃至我有意结。于眼无结乃至于意无结。能自了知我眼无结乃至我意无结。如彼眼结乃至意结未生而生亦能了知。如彼诸结生已散灭亦能了知。于内有念等觉支能自了知我有念等觉支。于内无念等觉支能自了知我无念等觉支。如念等觉支未生而生亦能了知。如生已住不忘修满倍复修习增长广大。亦能了知。如念等觉支。如是择法精进喜安定舍等觉支当知亦尔。若能如是如实遍知诸杂染法自性因缘过患对治。是为法念住体。如说于身住循身观念及念住。如是于受于心于法随其所应当知亦尔。云何于内身等住循身等观。云何于外身等住循身等观。云何于内外身等住循身等观。谓若缘内自有情数身色为境住循身观。是名于内身住循身观。若缘外非有情数色为境住循身观。是名于外身住循身观。若缘外他有情数身色为境住循身观。是名于内外身住循身观。若缘依内自有情数身色所生受心法为境住循三观。是名于内受心法住循受心法观。若缘依外非有情数色所生受心法为境住循三观。是名于外受心法住循受心法观。若缘依外他有情数身色所生受心法为境住循三观。是名于内外受心法住循受心法观。复有差别。谓若缘根所摄有执有受色为境。是名于内身住循身观。若缘非根所摄无执无受色为境。是名于外身住循身观。若缘非根所摄有执有受色为境。是名于内外身住循身观。如是若缘依前三色所生受心法为境。随其所应当知即是住循三观。复有差别。谓若缘自内定地轻安俱行色为境。是名于内身住循身观。若缘自内不定地粗重俱行色为境。是名于外身住循身观。若缘他轻安俱行粗重俱行色为境。是名于内外身住循身观。如是若缘依前三色所生受心法。为境。随其所应当知即是住循三观。复有差别。谓若缘内能造大种色为境。是名于内身住循身观。若缘外能造大种色为境。是名于外身住循身观。若缘依能造大种色所生根境所摄造色为境。是名于内外身住循身观。如是若缘依前三色所生受心法为境。随其所应当知即是住循三观。复有差别。谓若缘有识身内色为境。是名于内身住循身观。若缘无识身有情数青瘀等位色为境。是名于外身住循身观。若缘无识身色于过去时有识性。有识身色于未来时无识性。相似法性平等法性为境。是名于内外身住循身观。如是若缘依前三色所生受心法为境。随其所应当知即是住循三观。复有差别。谓若缘自中身发毛爪齿等相为境。是名于内身住循身观。若缘他中身发毛爪齿等相为境。是名于外身住循身观。若缘内表身变异不变异青瘀等相。及缘外表身变异不变异青瘀等相相似法性平等法性为境。是名于内外身住循身观。如是若缘依前三色所生受心法为境。随其所应当知即是住循三观。如是等类身受心法诸差别门当知多种。今于此中且显少分诸门差别。又为对治四颠倒故。世尊建立四种念住。谓为对。治于不净中计净颠倒立身念住。以佛世尊于循身念住中宣说不净相。应四憺怕路。若能于此多分思惟。便于不净断净颠倒。为欲对治于诸苦中计乐颠倒。立受念住。以于诸受住循受观。如实了知诸所有受皆悉是苦。便于诸苦断乐颠倒。为欲对治于无常中计常颠倒。立心念住。以能了知有贪心等种种差别。经历彼彼日夜刹那瞬息须臾非一众多种种品类心生灭性。便于无常断常颠倒。为欲对治于无我中计我颠倒。立法念住。由彼先来有有我见等诸烦恼故。无无我见等诸善法故。于诸蕴中生起我见。以于诸法住循法观。如实了知所计诸蕴自相共相。便于无我断我颠倒。复有差别。谓诸世间多于诸蕴唯有蕴性唯有法性。不如实知横计有我依止于身。由依身故受用苦乐。受苦乐者由法非法有染有净。为欲除遣我所依事愚故。立身念住。为欲除遣我所领受事愚故。立受念住。为欲除遣于心意识执我愚者我事愚故。立心念住。为欲除遣所执我心能染净事愚故。立法念住。复有差别。谓若依此造作诸业。若为此故造作诸业。若造业者若由此故造作诸业。为总显示如是一切立四念住。当知此中依止于身造作诸业。为求受故造作诸业。心能造业由善不善法能造诸业。复有差别。谓若依此有染有净。若为此故起染起净。若染净者若由此故成染成净。总为显示如是一切立四念住。当知此中依止于身有染有净。为求受故起染起净。心染净者由诸法故成染成净。问念住何义。答若于此住念。若由此住念皆名念住。于此住念者。谓所缘念住。由此住念者。谓若慧若念摄持于定。是自性念住。所余相应诸心心法。是相杂念住。又由身受心法增上所生善有漏无漏道皆名念住。此复三种。一闻所成。二思所成。三修所成。闻思所成唯是有漏。修所成者通漏无漏

瑜伽师地论卷第二十八瑜伽师地论卷第二十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第二瑜伽处之四

如是于四念住串习行故。已能除遣粗粗颠倒。已能了达善不善法。从此无间于诸未生恶不善法为不生故。于诸已生恶不善法为令断故。于其未生一切善法为令生故。于其已生一切善法为欲令住令不忘失。广说如前。乃至摄心持心。云何名为恶不善法。谓欲缠染污身语意业。是身语意恶行所摄。及能起彼所有烦恼。若未和合。未现在前。说名未生。若已和合已现在前说名已生。云何名为一切善法。谓若彼对治若盖对治若结对治。未生已生应知如前。恶不善法若时未生。恶不善法先未和合。为令不生发起希愿。我当令彼一切一切皆不复生。是名于诸未生恶不善法为不生故生欲。若时已生恶不善法先已和合。为令断故发起希愿。我当于彼一切一切皆不忍受断灭除遣。是名于诸已生恶不善法为令断故生欲。又彼一切恶不善法。或缘过去事生。或缘未来事生。或缘现在事生。如是彼法。或缘不现见境。或缘现见境。若缘过去未来事境是名缘不现见境。若缘现在事境。是名缘现见境。当知此中于缘不现见境。恶不善法其未生者欲令不生。其已生者欲令永断自策自励。是名策励。于缘现见境。恶不善法其未生者欲令不生。其已生者欲令永断勇猛正勤。是名发勤精进。所以者何。要当坚固自策自励。勇猛正勤。方能令彼或不复生或永断灭。又于下品中品诸缠。其未生者欲令不生。其已生者欲令永断故自策励。于上品缠其未生者欲令不生。其已生者欲令永断发勤精进。又若行于过去境界。如是行时不令烦恼缘彼生起。设复失念暂时生起而不忍受。速能断灭除遣变吐。如缘过去。若行未来当知亦尔。如是未生恶不善法能令不生。生已能断。是名策励。若行现在所缘境界。如是行时不令烦恼缘彼生起。设复失念暂时生起而不忍受。速能断灭除遣变吐。如是未生恶不善法能令不生。生已能断。是名发勤精进。又或有恶不善法。唯由分别力生非境界力。或有恶不善法。由分别力生亦境界力。唯由分别力生非境界力者。谓于住时。思惟过去未来境界而生于彼。由思惟力生亦境界力者。谓于行时。缘现在境界而生于彼。当于尔时决定亦有非理分别。当知此中恶不善法唯由分别力生。非境界力者。彼若未生能令不生。生已能断。是名策励。若由分别力生亦境界力者。彼若未生能令不生。生已能断。是名发勤精进。于其未生一切善法。为令生故生欲者。谓于未得未现在前所有善法。为欲令得令现在前。发心希愿发起猛利。求获得欲求现前欲而现在前。是名于其未生一切善法为令生故生欲。于其已生一切善法。为欲令住令不忘失令修圆满生欲者。谓已获得已现在前所有善法。是名已生善法。于此善法已得不失已得不退。依是说言为欲令住。于此善法明了现前无闇钝性。依是说言令不忘失。于此善法已得现前。数数修习成满究竟。依是说言令修圆满。于此善法发心希愿发起猛利。求坚住欲求不忘欲求修满欲而现在前。是名于其已生一切善法为欲令住令不忘失令修圆满生欲。策励者。为于已得令现前故。发勤精进者。为于未得令其得故。又策励者。于已生善为欲令住令不忘故。发勤精进者。令修满故。又于下品中品善法。未生令生生已令住令不忘失。是名策励。于上品善法。未生令生生已乃至令修圆满。是名发勤精进。言策心者。谓若心于修奢摩他一境性中正勤方便。于诸未生恶不善法为令不生。广说乃至于其已生一切善法。为欲令住令不忘失令修圆满。由是因缘其心于内极略下劣或恐下劣。观见是已尔时随取一种净妙举相。殷勤策励庆悦其心。是名策心。云何持心。谓修举时其心掉动或恐掉动。观见是已尔时还复于内略摄其心。修奢摩他。是名持心。如是四种亦名正胜。谓于黑品诸法其未生者为令不生。其已生者为令断灭。生欲策励发勤精进策心持心。是二正胜。于白品诸法其未生者为欲令生。如前黑品广说。应知是二正胜如是四种亦名正断。一名律仪断。谓于已生恶不善法。为令断故生欲策励。乃至广说。二名断断。谓于未生恶不善法。为不生故生欲策励。乃至广说。由于已生恶不善事。应修律仪令其断灭。不应忍受。由是因缘名律仪断。于其未生恶不善事。为欲令彼不现行断。为欲令彼不现前断。为断故断故名断断。三名修断。谓于未生一切善法为令生故。广说乃至策心持心。由于善法数修数习。先所未得能令现前。能有所断故名修断。四名防护断。谓于已生一切善法为欲令住广说乃至策心持心。由于已得已现在前诸善法中。远离放逸修不放逸。能令善法住不忘失修习圆满。防护已生所有善法。能有所断故。名防护断。如是广辨四正断已。复云何知此中略义。谓为显示于黑白品舍取事中。增上意乐圆满及加行圆满。是故宣说四种正断。当知此中由生欲故增上意乐圆满。由自策励发勤精进策心持心故加行圆满。修瑜伽师唯有尔所正应作事。谓为断灭所应断事。及为获得所应得事。先当生起希愿乐欲。为断诸缠。复应时时正勤修习止举舍相。为断诸缠及随眠故。更应修集对治善法。为现如是一切所作。说四正胜及四正断。是名略义。从此复修四三摩地。谓欲三摩地。勤三摩地。心三摩地。观三摩地。当知由欲增上力所得三摩地。名欲三摩地。由勤增上力所得三摩地。名勤三摩地。由心增上力所得三摩地。名心三摩地。由观增上力所得三摩地。名观三摩地。若于是时纯生乐欲。生乐欲已于诸所有恶不善法自性因缘过患对治。正审思察起一境念。于诸善法自性因缘功德出离。正审思察住一境念。即由如是多修习故触一境性。于诸所有恶不善法现行诸缠能令远离。而未永害烦恼随眠。是名欲增上力所得三摩地。若于过去未来现在所缘境界。能顺所有恶不善法。能顺所有下中上品烦恼缠中。其未生者为令不生。其已生者为令断灭。自策自励发勤精进行彼所缘。于彼境界自性因缘过患对治。正审思察住一境念。即由如是多安住故。能正生起心一境性。于诸所有恶不善法现行诸缠能令远离。而未永害烦恼随眠。是名勤增上力所得三摩地。若复策发诸下劣心。或复制持诸掉举心。又时时间修增上舍。由是因缘于诸所有恶不善法。若能随顺恶不善法及诸善法。若能随顺所有善法自性因缘过患功德对治出离。正审思察住一境念。即由如是多安住故。能正生起心一境性。广说乃至是名心增上力所得三摩地。若于能顺恶不善法。作意思惟为不如理。复于能顺所有善法。作意思惟以为如理。如是远离彼诸缠故。及能生起诸缠对治定为上首诸善法故。能令所有恶不善法皆不现行。便自思惟。我今为有现有恶不善法不觉知耶。为无现无恶不善法不觉知耶。我令应当遍审观察。彼由观察作意增上力故。自正观察断与未断。正审思察住一境念。即由如是多安住故。能正触证心一境性。由是因缘离增上慢。如实自知我唯于缠心得解脱。未于一切一切随眠心得解脱。我唯获得及已修习诸缠对治定为上首所有善法。而未获得及未修习随眠对治。是名观增上力所得三摩地。彼由如是四三摩地增上力故。已远诸缠。复为永害一切一切恶不善法诸随眠故。及为修集能对治彼诸善法故。便更生起乐欲策励。广说如前修四正断加行道理。彼于如是正修习时有八断行。为欲永害诸随眠故。为三摩地得圆满故。差别而转。何等名为八种断行。一者欲。谓起如是希望乐欲。我于何时修三摩地。当得圆满。我于何时当能断灭恶不善法所有随眠。二者策励。谓乃至修所有对治不舍加行。三者信。谓不舍加行正安住故。于上所证深生信解。四者安。谓清净信而为上首心生欢喜。心欢喜故渐次息除诸恶不善法品粗重。五者念。谓九种相。于九种相。安住其心奢摩他品能摄持故。六者正知。谓毗钵舍那品慧。七者思。谓心造作。于断未断正观察时造作其心。发起能顺止观二品身业语业。八者舍。谓行过去未来现在。随顺诸恶不善法中心无染污心平等性。由二因缘于随眠断分别了知。谓由境界不现见思。及由境界现见舍故。如是名为八种断行。亦名胜行。如是八种断行胜行。即是为害随眠瑜伽。此中欲者。即是彼欲。此中策励即彼精进。此中信者。即是彼信。此中安念正知思舍。即彼方便。如是此中若先欲等四三摩地。若今所说八种断行。于为永断所有随眠圆满成辨三摩地时。一切总名欲三摩地断行成就神足。勤三摩地断行成就神足。心三摩地断行成就神足。观三摩地断行成就神足。问何因缘故说名神足。答如有足者能往能还腾跃勇健能得能证世间所有殊胜之法。世殊胜法说名为神。彼能到此故名神足。如是若有如是诸法有三摩地圆满成辨。彼心如是清净鲜白无诸瑕秽。离随烦恼安住正直。有所堪能获得不动能往能还腾跃勇健。能得能证出世间法。由出世法最胜自在。是最胜神彼能证此故名神足。彼由如是胜三摩地为所依持。胜三摩地为所依止。能进修习增上心学增上慧学所有瑜伽。由进修习此瑜伽故。于他大师弟子所证。深生胜解深生净信。此清净信增上义故说名信根。问于何增上。答于能生起出世间法而为上首。及于能起精进念定慧。为其增上。余精进等于能生起出世间法。及于能起展转乃至慧为其增上。乃至其慧唯于能起出世间法为其增上。是故信等说名五根。若复了知前后所证而有差别。随此能于后后所证出世间法。深生胜解深生净信。此清净信难伏义故说名信力。问谁不能伏。答此清净信。若天若魔若诸沙门。若婆罗门若余世间。无有如法能引夺者。诸烦恼缠亦不能屈。故名难伏。此为上首此为前行余精进等亦名为力。由此诸力具大威势摧伏一切魔军势力。能证一切诸漏永尽。是故名力。当观此中信根信力。即四证净中所有净信。何以故。以其证入正性离生所有证净。皆由此因此缘此序由。彼即是此增上果。是故世尊就其因果相属道理。说言当观即彼证净。非即彼体非即彼相。当观此中精进根力。即四正断中所有精进。此何正断。谓能永断见道所断一切烦恼。方便正断。此中意说如是正断。由此正断毕竟能断所有诸恶不善法故。当观此中念根念力。即四念住中所有正念。谓四念住能无余断一切颠倒。当观此中定根定力。即四静虑中所有正定。谓诸静虑能为方便证不还果。当观此中慧根慧力。即四圣谛中所有正智。谓圣谛智于四圣谛能证现观得沙门果。即由如是诸根诸力。渐修渐习渐多修习为因缘故。便能发起下中上品顺决择分四种善根。何等为四。一暖二顶三顺谛忍四世第一法。譬如有人欲以其火作火所作。为求火故下安干木上施钻燧。精勤策励勇猛钻求。彼于如是精勤策励勇猛钻时。于下木上最初生暖。次暖增长热气上冲。次倍增盛其烟遂发。次无焰火欻然流出。火出无间发生猛焰。猛焰生已便能造作火之所作。如钻火人精勤策励勇猛钻求。五根五力渐修渐习渐多修习当知亦尔。如下木上初所生暖。其暖善根当知亦尔。烧诸烦恼无漏法火生前相故。如暖增长热气上冲。其顶善根当知亦尔。如次烟发。其顺谛忍当知亦尔。如无焰火欻然流出。世第一法当知亦尔。如火无间发生猛焰。世第一法所摄五根五力无间所生出世无漏圣法当知亦尔

此复云何。谓七觉支。诸已证入正性离生补特伽罗。如实觉慧用此为支故名觉支。即此七种如实觉支。三品所摄。谓三觉支奢摩他品摄。三觉支毗钵舍那品摄。一觉支通二品摄。是故说名七种觉支。谓择法觉支。精进觉支。喜觉支。此三观品所摄。安觉支。定觉支。舍觉支。此三止品所摄。念觉支一种俱品所摄。说名遍行。彼于尔时最初获得七觉支故名初有学。见圣谛迹已永断灭见道所断一切烦恼。唯余修道所断烦恼。为断彼故修习三蕴所摄八支圣道。此中正见正思惟正精进。慧蕴所摄。正语正业正命。戒蕴所摄。正念正定。定蕴所摄。问何因缘故名八支圣道。答诸圣有学已见迹者由八支摄行迹正道。能无余断一切烦恼。能于解脱究竟作证。是故名为八支圣道。当知此中若觉支时所得真觉。若得彼已以慧安立如证而觉。总略此二合名正见。由此正见增上力故。所起出离无恚无害分别思惟名正思惟。若心趣入诸所寻思。彼唯寻思如是相状所有寻思。若心趣入诸所言论。即由正见增上力故起善思惟。发起种种如法言论。是名正语。若如法求衣服饮食诸坐卧具病缘医药供身什物。于追求时若往若还正知而住。若睹若瞻若屈若伸。若持衣钵及僧伽胝。若食若饮若啖若尝正知而住。或于住时于已追求衣服等事。若行若住若坐若卧。广说乃至若解劳睡正知而住。是名正业。如法追求衣服饮食乃至什物。远离一切起邪命法。是名正命。若远离摄正语业命。彼于证得无漏作意诸觉支时先已获得。问何故此名圣所爱戒。答以诸圣者贤善正至。长时爱乐欣慕悦意。我于何时当正获得诸语恶行诸身恶行诸邪命事。不作律仪。由彼长夜于此尸罗深心爱乐欣慕悦意。故获得时名圣所爱。获得如是圣爱戒已。终不正知而说妄语。终不故思害众生命。终不故思不与而取。终不故思行欲邪行。终不非法求衣服等。即由如是圣所爱戒增上力故。于修道时乃至所有语业身业养命事转。亦得名为正语业命。依止正见及正思惟正语业命勤修行者。所有一切欲勤精进出离勇猛势力发起策励其心。相续无间名正精进。成就如是正精进者。由四念住增上力故。得无颠倒九种行相所摄正念能摄九种行相心住。是名正念及与正定。如是一切八支圣道。总立二种。谓无所作及住所作。无所作者。谓正语正业正命。住所作者。复有二种。谓奢摩他毗钵舍那。正见正思惟正精进是毗钵舍那。正念正定是奢摩他。如是清净正语业命为所依止。于时时间修习止观。能断诸结无余永断。能得最上阿罗汉果。长时相续名为修道。多时串习断烦恼故。率尔智生名为见道。暂时智起即能永断诸烦恼故。由是因缘。正语业命于修道中方始建立

由如是等渐次修习三十七种菩提分法加行方便。是名菩提分修

云何修果。谓四沙门果。一预流果。二一来果。三不还果。四最上阿罗汉果。

此中云何名沙门。云何名果。谓圣道名沙门。烦恼断名果。又后生道或中或上。是前生道所生之果。问何故建立如是四果。答对治四种诸烦恼故。谓诸无事能感恶趣往恶趣因。烦恼断故。及能断彼对治生故。立预流果。而薄伽梵说永断三结立此果者。谓依三品有三种结障碍圣道令不生故。一在家品。二恶说法毗奈耶品。三善说法毗奈耶品。依在家品有萨迦耶见。由此见故先生怖畏。最初不欲发趣圣道。依恶说法毗奈耶品有戒禁取。由此取故虽已发趣而行邪僻。由是不能生起圣道。依善说法毗奈耶品有疑。由此疑故虽已发趣不行邪僻。而于正道未串习故。于如实见所知事中犹预疑惑。障碍圣道不令生起。由是因缘唯说断此立预流果。此预流果极余七有。由是因缘多生相续。若断再生相续烦恼生无重续。立一来果。谓若永断天有所摄人有所摄再生相续所有烦恼。极唯更受天有一生人有一生。故于尔时立一来果。若已永断能感还来生此烦恼。唯于天有当可受生。即于尔时立不还果。若已永断一切能感生有烦恼。建立最上阿罗汉果。而薄伽梵说永断三结。缚贪嗔痴立一来果。永断能顺五下分结立不还果。永断一切烦恼究竟建立最上阿罗汉果。是名修果。

又于此中贪嗔痴慢寻思行者。彼先应于净行所缘净修其行。然后方证心正安住。彼于各别所缘境界。定由所缘差别势力。勤修加行。若等分行补特伽罗。随所爱乐攀缘彼境勤修加行。如是勤修唯令心住非净其行。如等分行补特伽罗。薄尘行者当知亦尔。而彼诸行有其差别。谓贪等行者勤修行时。要经久远方证心住。等分行者勤修行时。不甚久远能证心住。薄尘行者勤修行时。最极速疾能证心住。问前已广说有贪等行补特伽罗行相差别。其等分行及薄尘行补特伽罗。有何行相。答等分行者。如贪等行补特伽罗所有行相一切具有。然彼行相非上非胜。如贪等行。随所遇缘有其差别施设。此行与彼相似。其薄尘行补特伽罗行相差别者。谓无重障。最初清净。资粮已具。多清净信。成就聪慧。具诸福德。具诸功德。无重障者。谓无三障。何等为三。一者业障。二烦恼障。三异熟障。言业障者谓。五无间业及余所有故思造业诸尤重业。彼异熟果若成就时。能障正道令不生起。是名业障。烦恼障者。谓猛利烦恼长时烦恼。由此烦恼于现法中。以其种种净行所缘不能令净。是名烦恼障。异熟障者。谓若生处圣道依彼不生不长。于是生处异熟果生。或有生处圣道依彼虽得生长。而于其中异熟果生。聋騃愚钝盲瞽喑哑以手代言。无有力能解了善说恶说法义。是名异熟障。最初清净者。谓善净戒及正直见。由十因缘戒善清净。如前应知。正直见者。谓若有见净信相应故。胜解相应故。远离诳谄故。善思法义无惑无疑加行出离故。名为正直。如是正直见。净信相应故。于佛正法及毗奈耶不可引夺。胜解相应故。于诸如来及圣弟子不可思议威德神力不可思议生处差别甚深法教不可记事。深生胜解无惊无恐无有怖畏。远离诳谄故。其见正直。是正直类如其圣教而正修行。如其真实而自现发。善思法义无惑无疑加行出离故。于一切法无常苦空无我等义。善正思惟善正筹量善正观察。由是为因无惑无疑。远离二路逮得升进。由此四相先所说见名正直见。资粮已具者。广说资粮如前应知。略有四种。一福德资粮。二智慧资粮。三先世资粮。四现法资粮。福德资粮者。谓由此故于今获得随顺资具丰饶财宝。遇真福田为善知识。离诸障碍能勤修行。智慧资粮者。谓由此故成就聪慧有力有能。解了善说恶说法义。获得随顺法教义教教授教诫。先世资粮者。谓由宿世积集善根。于今获得诸根成就。现法资粮者。谓于今世有善法欲诸根成熟。具戒律仪及根律仪。如前广说。多清净信者。谓于大师所无惑无疑。深生净信及以胜解。如于大师。于法于学亦复如是。其余广说如前应知。成就聪慧者。谓由此故于法于义速能领受经久远时。于法于义能无忘失。于法于义速能通达。具诸福德者。谓由此故形色端严众所乐见。发清净信无病长寿。言辞敦肃具大宗叶。众所知识成就大福。多获衣等诸资生具。为诸国王及大臣等。供养恭敬尊重赞叹。具诸功德者。谓本性成就。极少欲等种种功德。如前所说沙门庄严应知其相。如是等类应知是名诸薄尘行补特伽罗行相差别

云何补特伽罗异门。谓有六种。何等为六。一沙门。二婆罗门。三梵行。四苾刍。五精勤。六出家。第一沙门复有四种。

何等为四。一胜道沙门。二说道沙门。三活道沙门。四坏道沙门。当知诸善逝名胜道沙门。诸说正法者名说道沙门。诸修善行者名活道沙门。诸行邪行者名坏道沙门。诸善逝者。谓已证得贪嗔痴等无余永尽。说正法者。谓为调伏贪嗔痴等宣说正法。修善行者。谓为调伏贪嗔痴等勤修正行。行邪行者。谓犯尸罗行诸恶法。又学无学名胜道沙门。以无漏道摧灭一切见修所断诸烦恼故。若无如来及诸菩萨。为菩提故勤修正行。诸声闻众持三藏者。名说道沙门。任持世俗法毗奈耶。转正法眼令不断故。若诸异生补特伽罗其性调善。为自利益勤修正行。有羞有悔爱乐正学。为得未得。为触未触。为证未证。勤修加行。有力有能堪得未得。堪触未触。堪证未证。名活道沙门。由彼现有诸善法暖。堪能生长圣慧命根。名活非死。是故名为活道沙门。若诸犯戒补特伽罗多行恶法。广说乃至实非梵行自称梵行。名坏道沙门。由彼破坏最初所有正道根本。无力无能非生道器。虽现前有说正道教及现前有证正道者。而彼不得。是故名为坏道沙门。世尊依彼作如是说。此初沙门广说乃至第四沙门。于外沙门婆罗门教空无所有。若于是处八支圣道安立可得。即于是处有初沙门广说乃至第四沙门。第二婆罗门复有三种。一种姓婆罗门。二名想婆罗门。三正行婆罗门。种姓婆罗门者。谓若生在婆罗门家。从母产门之所生出。父母圆备名婆罗门。名想婆罗门者。谓诸世间由想等想。假立言说名婆罗门。正行婆罗门者。谓所作事决定究竟。已能驱摈恶不善法。如说当知。婆罗门更无有所作。所作事已辨。是谓婆罗门。第三梵行复有三种。一受远离梵行。二暂时断梵行。三毕竟断梵行。受远离梵行者。谓能受学远离一切行非梵行习淫欲法。暂时断梵行者。谓诸异生由世间道离欲界欲。毕竟断梵行者。谓诸圣者得不还果。复得最上阿罗汉果。第四苾刍复有五种。一乞丐苾刍。二自称苾刍。三名想苾刍。四破坏烦恼苾刍。五白四羯磨受具足戒苾刍。第五精勤复有三种。一止息犯戒精勤。谓能远离一切不善身业语业。二止息境界精勤。谓密护根门修防守念及常委念。如前广说。三止息烦恼精勤。谓能永断见修所断一切烦恼。及于一切先所生起。或欲寻思或恚寻思或害寻思。或贪或嗔或诸邪见。或忿恨覆恼诳谄等。能往恶处那洛迦等诸险恶趣。非沙门法。随所生起能不忍受。寻即断灭除遣变吐。当知此中略有二种止息烦恼。一止息随眠。二止息诸缠。第六出家复有二种。一于善说法毗奈耶中而出家者。二于恶说法毗奈耶中而出家者。于善说法毗奈耶中而出家者。谓苾刍苾刍尼式叉摩那沙弥沙弥尼。又若自能出离身中所有一切恶不善法。当知是名真实出家。于恶说法毗奈耶中而出家者。谓诸外道或全无衣或坏色衣。或涂灰等增上外道。复有所余如是等类众多外道。是故说言若诸沙门。若婆罗门。若修梵行若诸苾刍。若精勤者若出家者。如是一切是数取趣所有异门

补特伽罗。略有八种建立因缘。略有四种。云何八种补特伽罗。一有堪能者。二无堪能者。三善知方便者。四不善知方便者。五有无间修者。六无无间修者。七已串修习者。八未串修习者。云何四种补特伽罗建立因缘。谓由四种差别因缘。建立八种补特伽罗。一由根差别故。有根已成熟及根未成熟。二由瑜伽差别故。有善知瑜伽及不善知瑜伽。三由加行差别故。有有无间殷重修及无无间殷重修。四由时差别故。有已长时修道及未长时修道。云何如是四种差别能为前八补特伽罗建立因缘。谓根已成就即有堪能者。根未成就即无堪能者。善知瑜伽即善知方便者。不善知瑜伽即不善知方便者。有无间殷重修即有无间修者。此亦名为有常委修。无无间殷重修即无无间修者。此亦名为无常委修。已长时修道即已串修习者。未长时修道即未串修习者。如是名为由根差别。瑜伽差别。加行差别及时差别。建立八种补特伽罗。若诸所有补特伽罗根未成就。彼于所有善知方便有无间修已串修习。如理如法如其善巧皆不能辨。若诸所有补特伽罗根虽成熟。而未善知善巧方便。于诸所有亦不能辨。若诸所有补特伽罗根已成熟。善知方便无无间修。即不能得速疾通慧。若诸所有补特伽罗根已成熟。善知方便有无间修未串修习。即于所有自所作事未得成辨。若诸所有补特伽罗根已成就。善知方便有无间修已串修习。彼于所有皆能成辨。亦能获得速疾通慧。于其所有自所作事已得成辨

当知诸魔略有四种。魔所作事有无量种。勤修观行诸瑜伽师应善遍知当正远离。云何四魔。一蕴魔。二烦恼魔。三死魔。四天魔。蕴魔者。谓五取蕴。烦恼魔者。谓三界中一切烦恼。死魔者。谓彼彼有情从彼彼有情众夭丧殒殁。天魔者。谓于勤修胜善品者求欲超越蕴烦恼死三种魔时。有生欲界最上天子得大自在。为作障碍发起种种扰乱事业。是名天魔。当知此中若死所依。若能令死。若正是死。若于其死作障碍事不令超越。依此四种建立四魔。谓依已生已入现在五取蕴故方有其死。由烦恼故感当来生生。已便有夭丧殒殁。诸有情类命根尽灭夭丧殒殁。是死自性。勤修善者为超死故正加行时。彼天子魔得大自在能为障碍。由障碍故或于死法令不能出。或经多时极大艰难方能超越。又魔于彼或有暂时不得自在。谓世间道离欲异生。或在此间或生于彼。或魔于彼得大自在。谓未离欲。若未离欲在魔手中随欲所作。若世间道而离欲者。魔缚所缚未脱魔罥。由必还来生此界故。云何魔事。谓诸所有能引出离善法欲生耽着诸欲增上力故。寻还退舍。当知此即是为魔事。若正安住密护根门。于诸所有可爱色声香味触法。由执取相执取随好。心乐趣入。当知此即是为魔事。若正安住于食知量。于诸美味不平等食。由贪爱欲心乐趣入。当知此即是为魔事。若正安住精勤修习。初夜后夜觉寤瑜伽。于睡眠乐于偃卧乐于胁卧乐。由懈怠力心乐趣入。当知此即是为魔事。若正安住正知而住。于往来等诸事业时。若见幼少盛年美色诸母邑等。由不如理执取相好心乐趣入。或见世间诸妙好事心乐趣入。或于多事多所作中心乐趣入。或见在家及出家众欢娱杂处。或见恶友共相杂住。便生随喜心乐趣入。当知一切皆是魔事。于佛法僧苦集灭道此世他世若生疑惑。当知一切皆是魔事。住阿练若树下冢间空闲静室。若见广大可怖畏事惊恐毛竖。或见沙门婆罗门像人非人像欻尔而来。不如正理劝舍白品劝取黑品。当知一切皆是魔事。若于利养恭敬称誉心乐趣入。或于悭吝广大希欲不知喜足。忿恨覆恼及矫诈等。沙门庄严所对治法心乐趣入。当知一切皆是魔事。如是等类无量无边诸魔事业。一切皆是四魔所作。随其所应当正了知。

由三因缘正修行者。精勤发趣空无有果。何等为三。一由诸根未积集故。二由教授不随顺故。三由等持力微劣故。若有诸根犹未积集。虽复获得随顺教授强盛等持。精勤发趣空无有果。若有诸根虽已积集其等持力亦复强盛。而不获得随顺教授。精勤发趣空无有果。若有诸根虽已积集。亦复获得随顺教授。而等持力若不强盛。精勤发趣空无有果。若有诸根已得积集教授随顺等持强盛。精勤发趣决定有果。如是名为由三因缘空无有果。由三因缘决定有果

瑜伽师智论卷第二十九瑜伽师地论卷第三十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第三瑜伽处之一

如是已说补特伽罗品类建立。及所缘等乃至趣修有果无果。如应安立我今当说。总嗢柁南曰

  往庆问寻求　　方安立护养
  出离一境性　　障净修作意

若有自爱补特伽罗初修业者。始修业时为随证得自义利故。先应四处安住正念。然后往诣善达瑜伽。或轨范师或亲教师。或余尊重似尊重所。云何四处。一专求领悟无难诘心处。二深生恭敬无憍慢心处。三唯求胜善非显己能处。四纯为安立自他善根非求利养恭敬名闻处。如是正念到师处已。先求开许请问时分。然后安详躬申请问。将请问时偏覆左肩右膝着地。或居下坐曲躬而坐。合掌恭敬深生愧畏。低颜软语请问瑜伽。我于如是瑜伽行中欲求受学。唯愿慈悲为我宣说

如是请已善达瑜伽诸瑜伽师。为欲安立初修业者瑜伽作意。应以慈愍柔软言词赞励庆慰。又应称扬修断功德。叹言善哉善哉。贤首。汝今乃能于堕放逸乐着放逸。沉没境界乐着境界。众生类中。独不放逸乐修出行。汝今乃能于久堕在种种忧苦险恶牢狱众生类中。独求解脱如是牢狱。汝今乃能于被种种贪嗔痴等杻械枷锁常所固缚众生类中。独求断坏如是固缚。汝今乃能于入生死旷野险道众生类中。独求超度旷野险道。汝今乃能于遭穷俭种种善根众生类中。独求获得丰饶善根。汝今乃能于堕种种烦恼怨贼广大怖畏众生类中。独求证得究竟安隐常乐涅槃。汝今乃能于为烦恼重病吞食众生类中。独求证得第一无病常乐涅槃。汝今乃能于为四种瀑流漂溺众生类中。独求越度如是瀑流。汝今乃能于入广大无明黑闇众生类中。独求获得大智光明。长老当知。汝若定能如是精勤修瑜伽行。乃得名为不虚受用国人信施。真实奉行如来圣教不舍。静虑成就胜观增长乐居空闲。法侣精勤修学自义瑜伽。不辱有智同梵行者。汝今为欲勤修自利利他正行。汝今为欲利益安乐无量众生。哀愍世间及诸天人阿素洛等。为令获得义利安乐故来问尔

以如是等柔软言词赞励庆慰。称扬修断诸功德已。复于四种审问处法应审问之。告言长老。汝已一向归佛法僧。非外道师及彼邪法弟子众不。汝已最初净修梵行善净尸罗正直见不。汝已于其总摽别辩诸圣谛法。若少若多闻受持不。汝于涅槃深心信解为证寂灭而出家不

如是问已。彼若云尔。次后复于四种处所。以四因缘应正寻求。何等名为四种处所一应寻求其愿。二应寻求种姓。三应寻求其根。四应寻求其行。云何名为四种因缘。一应以审问而正寻求。二应以言论而正寻求。三应以所作而正寻求。四应以知他心差别智而正寻求。云何名为应以审问寻求其愿。谓如是问。长老于何以发正愿。声闻乘耶独觉乘耶。无上正等菩提乘耶。彼得此问。随自所愿当如是答。如是名为应以审问寻求其愿。云何名为应以审问寻求种姓及以根行。谓如是问。长老。于自种姓根行能审察不。谓我本来有何种姓。声闻乘耶独觉乘耶。大乘等耶。有何等根。为钝为中为利根。耶。有何等行。为贪行耶为嗔行耶。广说乃至。寻思行耶。彼若黠慧能自了知前后差别种姓根行。善取其相如问而答。若性愚钝不能自知前后差别。乃至不能善取其相。由是不能如问而答。从此已后应以言论寻求彼三。谓对其前应以显了正理相应众杂美妙易解言词。说声闻乘相应言论。彼闻宣说此言论时。若身中有声闻种姓。于此言论便发最极踊跃欢喜深生信解。若身中有独觉种姓大乘种姓。于此言论不发最极踊跃欢喜不生信解。次复为其说独觉乘相应言论。彼闻宣说此言论时。若身中有独觉种姓。于此言论便发最极踊跃欢喜深生信解。若身中有声闻种姓大乘种姓则不如是。后复为其宣说大乘相应言论。彼闻宣说此言论时。若身中有大乘种姓。于此言论便发最极踊跃欢喜深生信解。若身中有声闻种姓独觉种姓则不如是。若有钝根。虽闻宣说粗浅言论。而于法义励力审思方能领受解了通达。若有利根。虽闻宣说深细言论。而于法义速能领受解了通达。若有中根。则不如是。若有贪行。彼闻为说净妙言论。便发最极净信爱乐悟入其趣。身毛皆竖悲涕堕泪。其身外现润滑相状。其心内怀柔软怡悦。若有嗔行。当知一切与上相违。若有痴行。彼闻为说决定通达涅槃离染相应言论。便生最极惊恐怖畏。如说钝根。如是痴行当知亦尔。若有慢行。彼闻为说正法言论不甚恭敬。属耳乐闻不极安住求欲领解奉教行心。虽作方便引发其心令受正化。而不分明发言称善。若寻思行。彼闻为说正法言论。虽摄耳听而心散乱恶受所受。凡所领受不坚不住。随受随失数重请问。如是名为应以言论寻求种姓及以根行。云何名为应以所作寻求。彼三谓如前说。声闻种姓及贪等行补特伽罗所有相状是名所作。由此所作如其所应。当正寻求种姓根行。云何名为应以知他心差别智寻求种姓及以根行。谓如有一善达瑜伽。修瑜伽师以得知他心差别智。彼由如是他心智故。如实了知种性根行

于四种处以四因缘正寻求已。复于五处如应安立。云何五处。一护养定资粮处。二远离处。三心一境性处。四障清净处。五修作意处。云何护养定资粮。谓若成就戒律仪者。即于是处为令不退住不放逸。如佛所诫如佛所许。圆满戒蕴学处差别。精进修行常无懈废。如是能于己所证得尸罗相应学道无退。亦能证得先所未证尸罗相应殊胜学道。如说成就戒律仪。如是成就根律仪。于食知量。初夜后夜觉寤瑜伽正知而住。如是乃至成就所有沙门庄严。随所获得资粮所摄善法差别。皆能防护令不退失。于后胜进善法差别。为速圆满为如所说无增无减。平等现行。发生乐欲增上欣慕。恒常安住勇猛精进。是名护养定资粮。如是远离顺退分法。修习能顺胜分法时乐住远离

云何远离。谓处所圆满。威仪圆满。远离圆满。是名远离。云何处所圆满。谓或阿练若或林树下或空闲室。山谷岩穴稻秆积等名空闲室。大树林中名林树下。空迥冢间边际卧坐名阿练若。当知如是山谷岩穴。稻秆积等。大树林中。空迥冢间边际卧坐。或阿练若或林树下或空闲室。总名处所。处所圆满复有五种。谓若处所从本已来形相端严众所喜见清净无秽。园林池沼悉皆具足。清虚可乐。地无高下处无毒刺。亦无众多甎石瓦砾。能令见者心生清净。乐住其中修断加行。心悦心喜任持于断。是名第一处所圆满。又若处所昼无愦闹夜少音声。亦少蚊虻风日蛇蝎诸恶毒触。是名第二处所圆满。又若处所无恶师子虎豹豺狼。怨敌盗贼。人非人等诸恐怖事。于是处所身意泰然都无疑虑安乐而住。是名第三处所圆满。又若处所随顺身命众具易得。求衣服等不甚艰难。饮食支持无所匮乏。是名第四处所圆满。又若处所有善知识之所摄受。及诸有智同梵行者之所居止。未开晓处能正开晓。已开晓处更令明净。甚深句义以慧通达。善巧方便殷勤开示。能令智见速得清净。是名第五处所圆满。云何威仪圆满。谓于昼分经行宴坐。于初夜分亦复如是。于中夜分右胁而卧。于后夜分疾疾还起经行宴坐。即于如是圆满卧具。诸佛所许大小绳床草叶座等结加趺坐。乃至广说。何因缘故结加趺坐。谓正观见五因缘故。一由身摄敛速发轻安。如是威仪顺生轻安最为胜故。二由此宴坐能经久时。如是威仪不极令身速疲倦故。三由此宴坐是不共法。如是威仪外道他论皆无有故。四由此宴坐形相端严。如是威仪令他见已极信敬故。五由此宴坐佛佛弟子共所开许。如是威仪一切贤圣同称赞故。正观如是五种因缘。是故应当结加趺坐。端身正愿者。云何端身。谓策举身令其端直。云何正愿。谓令其心离谄离诈调柔正直。由策举身令端直故。其心不为惛沉睡眠之所缠扰。离谄诈故其心不为外境散动之所缠扰

安住背念者。云何名为安住背念。谓如理作意相应念名为背念。弃背违逆一切黑品故。又缘定相为境念名为背念。弃背除遣一切不定地所缘境故。如是名为威仪圆满。云何违离圆满。谓有二种。一身远离。二心远离。身远离者。谓不与在家及出家众共相杂住。独一无侣是名身远离。心远离者谓远离一切染污无记所有作意。修习一切其性是善能引义利定地作意及定资粮加行作意。是名心远离。如是此中若处所圆满。若威仪圆满。若身远离。若心远离。总摄为一说名远离

云何心一境性。谓数数随念同分所缘流注无罪适悦相应令心相续。名三摩地。亦名为善心一境性。何等名为数数随念。谓于正法听闻受持。从师获得教诫教授增上力故。令其定地诸相现前。缘此为境。流注无罪适悦相应。所有正念随转安住。云何名为同分所缘。谓诸定地所缘境界。非一众多种种品类。缘此为境令心正行。说名为定。此即名为同分所缘。问此所缘境是谁同分说为同分。答是所知事相似品类故名同分。复由彼念于所缘境。无散乱行无缺无间。无间殷重加行适悦相应而转。故名流注适悦相应。又由彼念于所缘境无有染污。极安隐住熟道。适悦相应而转。故名无罪适悦相应。是故说言数数随念同分所缘流注。无罪适悦相应令心相续名三摩地。亦名为善心一境性。复次如是心一境性。或是奢摩他品。或是毗钵舍那品。若于九种心住中心一境性。是名奢摩他品。若于四种慧行中心一境性。是名毗钵舍那品

云何名为九种心住。谓有苾刍令心内住等住。安住近住。调顺寂静最极寂静。专注一趣。及以等持。如是名为九种心住。云何内住。谓从外一切所缘境界。摄录其心系在于内令不散乱。此则最初系缚其心。令住于内不外散乱。故名内住。云何等住。谓即最初所系缚心。其性粗动未能令其等住遍住故。次即于此所缘境界。以相续方便澄净方便。挫令微细遍摄令住。故名等住。云何安住。谓若此心虽复如是内住等住。然由失念于外散乱。复还摄录安置内境。故名安住。云何近住。谓彼先应如是如是亲近念住。由此念故数数作意内住其心。不令此心远住于外。故名近住。云何调顺。谓种种相令心散乱。所谓色声香味触相。及贪嗔痴男女等相故。彼先应取彼诸相为过患想。由如是想增上力故。于彼诸相折挫其心不令流散。故名调顺。云何寂静。谓有种种欲恚害等诸恶寻思贪欲盖等诸随烦恼。令心扰动。故彼先应取彼诸法为过患想。由如是想增上力故。于诸寻思及随烦恼。止息其心不令流散。故名寂静。云何名为最极寂静。谓失念故即彼二种暂现行时。随所生起诸恶寻思及随烦恼能不忍受。寻即断灭除遣变吐。是故名为最极寂静。云何名为专注一趣。谓有加行有功用。无缺无间三摩地相续而住。是故名为专注一趣。云何等持。谓数修数习数多修习为因缘故。得无加行无功用任运转道。由是因缘不由加行不由功用。心三摩地任运相续无散乱转。故名等持。当知此中由六种力。方能成办九种心住。一听闻力。二思惟力。三忆念力。四正知力。五精进力。六串习力。初由听闻思惟二力。数闻数思增上力故。最初令心于内境住。及即于此相续方便澄净方便等遍安住。如是于内系缚心已。由忆念力数数作意。摄录其心令不散乱安住近住。从此已后由正知力调息其心。于其诸相诸恶寻思诸随烦恼不令流散调顺寂静。由精进力设彼二种暂现行时能不忍受。寻即断灭除遣变吐。最极寂静专注一趣。由串习力等持成满。即于如是九种心住。当知复有四种作意。一力励运转作意。二有间缺运转作意。三无间缺运转作意。四无功用运转作意。于内住等住中。有力励运转作意。于安住近住。调顺寂静。最极寂静中。有有间缺运转作意。于专注一趣中。有无间缺运转作意。于等持中。有无功用运转作意。当知如是四种作意。于九种心住中是奢摩他品。又即如是获得内心奢摩他者。于毗钵舍那勤修习时。复即由是四种作意。方能修习毗钵舍那。故此亦是毗钵舍那品

云何四种毗钵舍那。谓有苾刍依止内心奢摩他故。于诸法中能正思择最极思择。周遍寻思周遍伺察。是名四种毗钵舍那。云何名为能正思择。谓于净行所缘境界。或于善巧所缘境界。或于净惑所缘境界。能正思择尽所有性。云何名为最极思择。谓即于彼所缘境界。最极思择如所有性。云何名为周遍寻思。谓即于彼所缘境界。由慧俱行有分别作意。取彼相状周遍寻思。云何名为周遍伺察。谓即于彼所缘境界。审谛推求周遍伺察。又即如是毗钵舍那。由三门六事差别所缘。当知复有多种差别。云何三门毗钵舍那。一唯随相行毗钵舍那。二随寻思行毗钵舍那。三随伺察行毗钵舍那。云何名为唯随相行毗钵舍那。谓于所闻所受持法。或于教授教诫诸法。由等引地如理作意。暂尔思惟未思未量未推未察。如是名为唯随相行毗钵舍那。若复于彼思量推察。尔时名为随寻思行毗钵舍那。若复于彼既推察已。如所安立复审观察。如是名为随伺察行毗钵舍那。是名三门毗钵舍那。云何六事差别所缘毗钵舍那。谓寻思时寻思六事。一义。二事。三相。四品。五时。六理。既寻思已复审伺察。云何名为寻思于义。谓正寻思如是如是语有如是如是义。如是名为寻思于义。云何名为寻思于事。谓正寻思内外二事。如是名为寻思于事。云何名为寻思于相。谓正寻思诸法二相。一者自相。二者共相。如是名为寻思于相。云何名为寻思于品。谓正寻思诸法二品。一者黑品。二者白品。寻思黑品过失过患。寻思白品功德胜利。如是名为寻思于品。云何名为寻思于时。谓正寻思过去未来现在三时。寻思如是事曾在过去世。寻思如是事当在未来世。寻思如是事今在现在世。如是名为寻思于时。云何名为寻思于理。谓正寻思四种道理。一观待道理。二作用道理。三证成道理。四法尔道理。当知此中由观待道理寻思世俗以为世俗。寻思胜义以为胜义。寻思因缘以为因缘。由作用道理寻思诸法所有作用。谓如是如是法有如是如是作用。由证成道理寻思三量。一至教量。二比度量。三现证量。谓正寻思如是如是义。为有至教不。为现证可得不。为应比度不。由法尔道理。于如实诸法成立法性。难思法性安住法性应生信解不应思议不应分别。如是名为寻思于理。如是六事差别所缘毗钵舍那。及前三门毗钵舍那。略摄一切毗钵舍那。问何因缘故建立如是六事差别毗钵舍那。答依三觉故如是建立。何等三觉。一语义觉。二事边际觉。三如实觉。寻思义故起语义觉。寻思其事及自相故起事边际觉。寻思共相品时理故起如实觉。修瑜伽师唯有尔所所知境界所谓语义及所知事。尽所有性如所有性

云何勤修不净观者。寻思六事差别所缘毗钵舍那。谓依不净增上正法。听闻受持增上力故。由等引地如理作意解了其义。知此不净实为不净深可厌逆。其性朽秽恶臭生臭。由如是等种种行相。于先所闻依诸不净所说正法。解了其义。如是名为于诸不净寻思其义。云何名为寻思彼事。谓彼如是解了义已。观不净物建立二分。谓内及外。如是名为寻思彼事。云何名为寻思自相。谓且于内身中所有秽朽不净发起胜解。了知身中有发毛等广说乃至脑膜小便。复于如是身中所有多不净物。摄为二界发起胜解。所谓地界及以水界。始于发毛乃至大便起地胜解。始于泪污乃至小便起水胜解。如是名为依内不净寻思自相。复于其外诸不净物。由青瘀等种种行相发起胜解。谓先发起青瘀胜解。或亲自见或从他闻。或由分别所有死尸。如是死尸。或男或女或非男女。或亲或怨或是中庸。或劣或中或复是胜。或是少年或是中年或是老年。取彼相已若此死尸死经一日。血流已尽未至脓烂。于是发起青瘀胜解。若此死尸死经二日。已至脓烂未生虫蛆。于是发起脓烂胜解。若此死尸死经七日。已生虫蛆身体已坏。于是发起烂坏胜解[月*逄]胀胜解。若此死尸为诸狐狼鸱枭雕鹫乌鹊饿狗之所食啖。于是发起食啖胜解。即此死尸既被食已。皮肉血尽唯筋缠骨。于是发起异赤胜解。若此死尸或被食啖。支节分离散在处处。或有其肉或无其肉或余少肉。于是发起分散胜解。若此死尸骨节分散。手骨异处。足骨异处。膝骨异处。髀骨异处。髋骨异处。髆骨异处。臂骨异处。脊骨异处。颔轮异处。齿鬘异处。髑髅异处。见是事已起骨胜解。若复思惟如是骸骨共相连接而不分散。唯取粗相不委细取支节屈曲。如是尔时起锁胜解。若委细取支节屈曲。尔时发起骨锁胜胜。又有二锁。一形骸锁。二支节锁。形骸锁者。谓从血镬脊骨乃至髑髅所住。支节锁者。谓臂髆等骨连锁及髀膞等骨连锁。此中形骸锁说名为锁。若支节锁说名骨锁。复有二种取骨锁相。一取假名彩画木石泥等所作骨锁相。二取真实骨锁相。若思惟假名骨锁相时。尔时唯名起锁胜解。不名骨锁。若思惟真实骨锁相时。尔时名起骨锁胜解。又即此外造色色相三种变坏。一自然变坏。二他所变坏。三俱品变坏。始从青瘀乃至[月*逄]胀。是自然变坏。始从食啖乃至分散。是他所变坏。若骨若锁及以骨锁。是俱品变坏。若能如是如实了知外不净相。是名寻思外诸所有不净自相。云何寻思不净共相。谓若内身外净色相未有变坏。若在外身不净色相已有变坏。由在内身不净色相平等法性相似法性发起胜解。能自了知我净色相亦有如是同彼法性。若诸有情成就如是净色相者。彼净色相亦有如是同彼法性。譬如在外不净色相。是名寻思不净共相。云何名为寻思彼品。谓作是思。若我于彼诸净色相不净法性不如实知。于内于外诸净色相发起贪欲便为颠倒。黑品所摄。是有诤法有苦有害。有诸灾患有遍烧恼。由是因缘发起当来生老病死愁叹忧苦种种扰恼。若我于彼诸净色相不净法性。如实随观便无颠倒。白品所摄。是无诤法无苦无害。广说乃至由此因缘能灭当来生老病死乃至扰恼。若诸黑品。我今于彼不应忍受应断应遣。若诸白品。我今于彼未生应生。生已令住增长广大。如是名为寻思彼品。云何名为寻思彼时。谓作是思。若内所有诸净色相在现在世。若外所有不净色相亦现在世。诸过去世曾净色相。彼于过去虽有净相。而今现在如是次第种种不净。诸现在世我之所有似净色相。此净色相于现在世虽有净相。于未来世不当不净如今现在外不净色。无有是处。我此色身去来今世。曾如是相当如是相现如是相。不过如是不净法性。如是名为寻思彼时。云何名为寻思彼理。谓作是思。若内若外都无有我有情可得。或说为净或说不净。唯有色相唯有身形。于中假想施设言论。谓之为净或为不净。又如说言寿暖及与识。若弃舍身时离执持而卧无所思如木。既死没已渐次变坏分位可知。谓青瘀等乃至骨锁。今我此身先业烦恼之所引发。父母不净和合所生。糜饭等食之所增长。此因此缘此由借故。虽暂时有诸净色相似。可了知而内身中若内若外。于常常时种种不净皆悉充满。如是名依世俗胜义及以因缘观待道理。寻思彼理。复作是思。于此不净若能如是善修善习善多修习能断欲贪。如是欲贪定应当断。如是名依作用道理寻思彼理。复作是思。如世尊说。若于不净善修善习善多修习能断欲贪。是至教量。我亦于内自能现见于诸不净。如如作意思惟修习如是如是。令欲贪缠未生不生生已除遣。是现证量。比度量法亦有可得。谓作是思。云何今者作意思惟能对治法。可于能治所缘境界烦恼当生。如是名依证成道理寻思彼理。复作是思。如是之法成立法性。难思法性安住法性。谓修不净能与欲贪作断对治。不应思议不应分别唯应信解。如是名依法尔道理寻思彼理。是名勤修不净观者。寻思六事差别所缘毗钵舍那

云何勤修慈愍观者。寻思六事差别所缘毗钵舍那。谓依慈愍增上正法听闻受持增上力故。由欲利益安乐意乐。于诸有情作意与乐发起胜解。是慈愍相。若能如是解了其义。如是名为于诸慈愍寻思其义。彼既如是解了义已复能思择。此为亲品此为怨品此中庸品是一切品。皆他相续之所摄故。于中发起外事胜解。又若亲品名为内事。怨中庸品名为外事。如是名为于诸慈愍寻思其事。复能思择如是三品。若无苦乐欲求乐者愿彼得乐。今于此中有饶益相名为亲品。不饶益相名为怨品。俱相违相名中庸品。如是三品若无苦乐欲求乐者。略有三种欲求乐心差别可得。一者欲求欲界诸乐。二者欲求色界有喜勇悦诸乐。三者欲求离喜诸乐。如是若于欲乐匮乏。愿彼皆得无罪欲乐。若于有喜离喜诸乐有所匮乏。当知亦尔。是名寻思慈愍自相。复审思择若诸亲品若诸怨品若中庸品。我于其中皆当发起相似性心平等性心。何以故。我若作意与亲品乐此未为难。于中庸品作意与乐亦未甚难。若于怨品作意与乐乃甚为难。我于怨品尚应作意愿与其乐。何况亲品及中庸品而不与乐。何以故。此中都无能骂所骂。能嗔所嗔。能弄所弄。能打所打。唯有音声唯有名字。又我此身随所生起。有色粗重四大所造。随所住处便为如是触所逼恼。略有二触。谓音声触。及手足块刀杖等触。是身及触皆是无常。能为如是不饶益者亦是无常。又复一切有情之类皆有生老病死等法。本性是苦。故我不应于本性苦诸有情上。更加其苦而不与乐。又亦不应不与怨家作善知识不摄一切有情之类以为自体。又世尊言。我不观见如是种类有情可得。无始世来经历生死长时流转。不互相为或父或母兄弟姊妹。若轨范师若亲教师。若余尊重似尊重者。由是因缘一切怨品无不皆是我之亲品。又怨亲品无有决定真实可得。何以故。亲品余时转成怨品。怨品余时转成亲品。是故一切无有决定。故我今者应于一切有情之类。皆当发起平等性心平等性见。及起相似利益意乐安乐意乐与乐胜解。是名寻思慈愍共相。复审思择。我若于彼不饶益者。发生嗔恚便为颠倒。黑品所摄。是有诤法。广说如前。我若于彼不起嗔恚便无颠倒。白品所摄。是无诤法。广说如前。如是名为寻思慈愍黑品白品。复审思择。诸过去世求欲得乐有情之类。彼皆过去。我当云何能与其乐。诸现在世有情之类。我今愿彼尽未来世于一切时常受快乐。是名寻思诸慈愍时。复审思择。此中都无我及有情或求乐者或与乐者。唯有诸蕴唯有诸行。于中假想施设言论。此求乐者。此与乐者。又彼诸行业烦恼等以为因缘。如是名依观待道理寻思慈愍。若于慈愍善修善习善多修习能断嗔恚。如是名依作用道理寻思慈愍。如是之义有至教量。我内智见现转可得。比度量法亦有可得。如是名依证成道理寻思慈愍。又即此法成立法性。难思法性安住法性。谓修慈愍能断嗔恚。不应思议不应分别应生胜解。如是名依法尔道理寻思慈愍。是名勤修慈愍观者。寻思六事差别所缘毗钵舍那

瑜伽师地论卷第三十瑜伽师地论卷第三十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第三瑜伽处之二

云何勤修缘起观者。寻思六事差别所缘毗钵舍那。谓依缘性缘起增上正法听闻受持增上力故。能正了知如是如是诸法生故彼彼法生。如是如是诸法灭故彼彼法灭。此中都无自在作者生者化者能造诸法。亦无自性。士夫中间能转变者转变诸法。若能了知如是等义。是名寻思诸缘起义。复审思择十二有支若内若外而起胜解。是名寻思诸缘起事。复审思择无明支等前际无知后际无知。如是广说如前分别缘起支中。是名寻思缘起自相。复审思择如是一切缘生诸行。无不皆是本无今有有已散灭。是故前后皆是无常皆有生老病死法故其性是苦不自在故。中间士夫不可得故。性空无我。是名寻思缘起共相。复审思择我若于彼无常苦空无我诸行如实道理。发生迷惑便为颠倒。黑品所摄。广说如前。若不迷惑便无颠倒。白品所摄。广说如前。是名寻思诸缘起品。复审思择于过去世所得自体无正常性如是已住。于现在世所得自体无正常性如是今住。于未来世所得自体无正常性如是当住。是名寻思诸缘起时。复审思择唯有诸业及异熟果。其中主宰都不可得。所谓作者及与受者。唯有于法假想建立。谓于无明缘行乃至生缘老死中。发起假相施设言论。说为作者及与受者。有如是名如是种。如是姓如是饮食。如是领受。若苦若乐。如是长寿。如是久住。如是极于寿量边际。又于此中有二种果及二种因。二种果者。一自体果。二受用境界果。二种因者。一牵引因。二生起因。自体果者。谓于今世诸异熟生六处等法。受用境界果者。谓爱非爱业增上所起六触所生诸受。牵引因者谓于二果发起愚痴。愚痴为先生福非福及不动行。行能摄受后有之识令生有芽。谓能摄受识种子故。令其展转摄受后有名色种子六处种子触受种子。为令当来生支想所摄识名色六处触受次第生故。今先摄受彼法种子。如是一切名牵引因。生起因者。谓若领受诸无明触所生受时。由境界爱生后有爱及能摄受爱品痴品所有诸取。由此势力由此功能润业种子。令其能与诸异熟果。如是一切名生起因。由此二因增上力故。便为三苦之所随逐。招集一切纯大苦蕴。如是名依观待道理。寻思缘起所有道理。复审思择于是缘性缘起观中。善修善习善多修习能断愚痴。又审思择如是道理有至教量有内现证有比度法。亦有成立法性等义。如是名依作用道理。证成道理。法尔道理。寻思缘起所有道理。是名勤修缘起观者寻思六事差别所缘毗钵舍那。云何勤修界差别观者。寻思六事差别所缘毗钵舍那。谓依界差别增上正法听闻受持增上力故。能正解了一切界义。谓种姓义及种子义因义性义。是其界义。如是名为寻思界义。又正寻思地等六界内外差别发起胜解。如是名为寻思界事。又正寻思地为坚相。乃至风为轻动相。识为了别相。空界为虚空相遍满色相无障碍相。是名寻思诸界自相。又正寻思此一切界以要言之皆是无常乃至无我。是名寻思诸界共相。又正寻思于一合相界差别性不了知者。由界差别所合成身。发起高慢便为颠倒。黑品所摄。广说如前。与上相违便无颠倒。白品所摄。广说如前。如是名为寻思界品。又正寻思去来今世六界为缘得入母胎。如是名为寻思界时。又正寻思如草木等众缘和合围绕虚空。数名为舍。如是六界为所依故。筋骨血肉众缘和合围绕虚空。假想等想施设言论。数名为身。复由宿世诸业烦恼及自种子以为因缘。如是名依观待道理寻思诸界差别道理。又正寻思若于如是界差别观。善修善习善多修习能断憍慢。又正寻思如是道理有至教量。有内证智。有比度法。有成立法性。难思法性。安住法性。如是名依作用道理。证成道理。法尔道理。寻思诸界差别道理。是名勤修界差别观者。寻思六事差别所缘毗钵舍那。云何勤修阿那波那念者寻思六事差别所缘毗钵舍那。谓依入出息念增上正法听闻受持增上力故。能正了知于入出息所缘境界。系心了达无忘明记是阿那波那念义。如是名为寻思其义。又正寻思入息出息在内可得。系属身故外处摄故内外差别。如是名为寻思其事。又正寻思入息有二出息有二。若风入内名为入息若风出外名为出息。复正了知如是为长入息出息。如是为短入息出息。如是息遍一切身分。是名寻思诸息自相。又正寻思入息灭已有出息生。出息灭已有入息生。入出息转系属命根及有识身。此入出息及所依止皆是无常。是名寻思诸息共相。又正寻思若于如是入息出息。不住正念。为恶寻思扰乱其心便为颠倒。黑品所摄。是有诤法。广说如前。与上相违便无颠倒。白品所摄。是无诤法。广说如前。如是名为寻思其品。又正寻思去来今世入出息转系属身心。身心系属入息出息。如是名为寻思其时。又正寻思此中都无持入息者。持出息者。入息出息系属于彼。唯于从因从缘所生诸行。发起假想施设言论。说有能持入出息者。如是名依观待道理寻思其理。又正寻思若于如是入出息念。善修善习善多修习能断寻思。又正寻思如是道理有至教量。有内证智。有比度法。有成立法性。难思法性。安住法性。不应思议。不应分别。唯应信解。如是名依作用道理。证成道理。法尔道理。寻思其理。是名勤修阿那波那念者。寻思六事差别所缘毗钵舍那。如是依止净行所缘。寻思六事差别观已。数数于内令心寂静。数数复于如所寻思。以胜观行审谛伺察。彼由奢摩他为依止故。令毗钵舍那速得清净。复由毗钵舍那为依止故。令奢摩他增长广大。若依止善巧所缘及净惑所缘。寻思六事差别所缘毗钵舍那。于其自处我后当说

复次此中有九种白品所摄加行。与此相违当知即是九种黑品所摄加行。云何名为白品所摄。九种加行。一相应加行。二串习加行。三无倒加行。四不缓加行。五应时加行。六解了加行。七无厌足加行。八不舍轭加行。九正加行。由此九种白品所摄加行故。能令其心速疾得定。令三摩地转更胜进。又由此故于所应往地。及随所应得。速疾能往能得无有稽迟。黑品所摄九种加行。不能令心速疾得定。不令三摩地转更胜进。又由此故于所应往地及随所应得。极大稽迟不能速疾往趣获得。云何名为相应加行。谓若贪行者。应于不净安住其心。若嗔行者。应于慈愍安住其心。若痴行者。应于缘起安住其心。若憍慢行者。应于界差别安住其心。若寻思行者。应于阿那波那念。安住其心。若等分行者。或薄尘行者。应随所乐攀缘一境安住其心。勤修加行。如是名为相应加行。云何名为串习加行。谓于奢摩他毗钵舍那。已曾数习乃至少分。非于一切皆初修业。所以者何。初修业者。虽于相应所缘境界勤修加行。而有诸盖数数现行身心粗重。由是因缘不能令心速疾得定。如是名为串习加行。云何名为不缓加行。谓无间方便殷重方便勤修观行。若从定出或为乞食。或为恭敬承事师长。或为看病。或为随顺修和敬业。或为所余如是等类诸所作事。而心于彼所作事业。不全随顺不全趣向不全临入。唯有速疾令事究竟。还复精勤宴坐寂静修诸观行。若有苾刍苾刍尼。邬波索迦。刹帝利。婆罗门等。种种异众共相会遇。虽久杂处现相语仪。而不相续安立言论。唯乐远离勤修观行。又能如是勇猛精进。谓我于今定当趣证。所应证得。不应慢缓。何以故。我有多种横死因缘。所谓身中或风或热或痰发动。或所饮食不正消化。住在身中成宿食病。或为于外蛇蝎蚰蜒百足等类诸恶毒虫。之所蛆蠚。或复为人非人类等之所惊恐。因斯夭没。于如是等诸横死处。恒常思惟修无常想住不放逸。由住如是不放逸故。恒自思惟。我之寿命傥得更经七日六日五日四日三日二日一日一时半时须臾或半须臾。或经食顷。或从入息至于出息。或从出息至于入息。乃至存活经尔所时。于佛圣教精勤作意修习瑜伽。齐尔所时于佛圣教。我当决定多有所作。如是名为不缓加行。云何名为无倒加行。谓如善达修瑜伽行诸瑜伽师之所开悟。即如是学于法于义不颠倒取。无有我慢。亦不安住自所见取。无邪僻执。于尊教诲终不轻毁。如是名为无倒加行。云何名为应时加行。谓于时时间修习止相。于时时间修习观相。于时时间修习举相。于时时间修习舍相。又能如实了知其止止相止时。了知其观观相观时。了知其举举相举时。了知其舍舍相舍时。云何为止。谓九相心住。能令其心无相无分别。寂静极寂静等住寂止。纯一无杂故名为止。云何止相。谓有二种。一所缘相。二因缘相。所缘相者。谓奢摩他品所知事同分影像。是名所缘相。由此所缘。令心寂静。因缘相者。谓依奢摩他所熏习心。为令后时奢摩他定皆清净故。修习瑜伽毗钵舍那所有加行。是名因缘相。云何止时。谓心掉举时。或恐掉举时。是修止时。又依毗钵舍那所熏习心。为诸寻思之所扰恼及诸事业所扰恼时。是修止时。云何为观。谓四行三门六事差别所缘观行。云何观相。谓有二种。一所缘相。二因缘相。所缘相者。谓毗钵舍那品所知事同分影像。由此所缘令慧观察。因缘相者。谓依毗钵舍那所熏习心。为令后时毗钵舍那皆清净故。修习内心奢摩他定所有加行。云何观时。谓心沉没时。或恐沉没时。是修观时。又依奢摩他所熏习心。先应于彼所知事境如实觉了。故于尔时是修观时。云何为举。谓由随取一种净妙所缘境界。显示劝导庆慰其心。云何举相。谓由净妙所缘境界。策励其心。及彼随顺发勤精进。云何举时。谓心沉下时。或恐沉下时。是修举时。云何为舍。谓于所缘心无染污心平等性。于止观品调柔正直任运转性及调柔心有堪能性。令心随与任运作用。云何舍相。谓由所缘令心上舍。及于所缘不发所有太过精进。云何舍时。谓于奢摩他毗钵舍那品所有掉举心已解脱。是修舍时。如是名为应时加行。云何名为解了加行。谓于如是所说诸相。善取善了善取了已。欲入定时即便能入。欲住定时即便能住。欲起定时即便能起。或时弃舍诸三摩地所行影像作意思惟。诸不定地所有本性所缘境界。如是名为解了加行。云何名为无厌足加行。谓于善法无有厌足修断无废。于展转上展转胜处。多住希求。不唯获得少小静定便于中路而生退屈。于余所作常有进求。如是名为无厌足加行。云何名为不舍轭加行。谓于一切所受学处无穿无缺。虽见少年颜容端正可爱母邑。而不取相不取随好。于食平等勤修觉寤。少事少业少诸散乱。于久所作久所说等。能自随忆令他随忆。如是等法说名不舍轭加行。由此诸法能正随顺心一境性。不舍其轭令心不散。不令其心驰流外境。不令其心内不调柔。如是名为不舍轭加行。云何名正加行。谓于所缘数起胜解。数正除遣是名正加行。如有勤修不净观者。数正除遣于诸不净。作意思惟诸不净相。由随相行毗钵舍那而起作意。于所缘境数数除遣数数现前。其正除遣复有五种。一内摄其心故。二不念作意故。三于余作意故。四对治作意故。五无相界作意故。当知此中由九相心住。毗钵舍那而为上首。故名内摄其心。由于最初背一切相无乱安住。故名不念作意。由缘余定地境思惟余定地。故名于余作意。由思惟不净对治于净。乃至思惟阿那波那念对治寻思。思惟虚空界对治诸色。故名对治作意。由于一切相不作意思惟。于无相界作意思惟。故名无相界作意。虽遍安立一切所缘。正除遣相总有五种。然此义中正意。唯取内摄其心不念作意。初修业者始修业时。最初全不于所缘境系缚其心。或于不净或复余处唯作是念。我心云何得无散乱无相无分别。寂静极寂静。无转无动无所希望。离诸作用于内适悦。如是精勤于所生起一切外相。无所思惟不念作意。即由如是不念作意除遣所缘彼于其中修习瑜伽摄受适悦。复行有相有分别不净等境云何而行谓由随相行。随寻思行。随伺察行。毗钵舍那行。彼境界而非一向精勤修习毗钵舍那还舍观相复于所缘思惟止行。由是因缘彼于尔时。于所缘境。不舍不取。由于所缘止行转故。不名为舍。即于所缘不作相故。无分别故。不名为取。即由如是内摄其心除遣所缘。又于其中不取观相故于缘无乱。取止行故。而复缘于所知事相。若于所缘唯数胜解不数除遣。即不令彼所有胜解后后明净究竟而转。不能往趣乃至现观所知境事。由数胜解数除遣故。后后胜解展转明净究竟而转。亦能往趣乃至现观所知境事。譬如世间画师弟子初习画业。先从师所受所学样。谛观谛观作彼形相。作已作已寻即除毁。既除毁已寻复更作。如如除毁数数更作。如是如是后后形相转明转净究竟显现。如是正学经历多时。世共推许为大画师或堕师数。若不数除所作形相。即于其上数数重画。便于形相永无明净究竟显期。此中道理当知亦尔。若于此境起胜解已。定于此境复正除遣。非于此境正除遣。已定于此境复起胜解。于狭小境起胜解已。即于狭小而正除遣。广大无量当知亦尔。于狭小境正除遣已。或于狭小复起胜解。或于广大复起胜解。或于无量复起胜解。于其广大及于无量当知亦尔。若诸色法所有相貌影像显现。当知是粗变化相似。诸无色法假名为先。如所领受增上力故影像显现。如是一切名正加行。如是九种白品加行。于奢摩他毗钵舍那当知随顺。与是相违九种加行。于奢摩他毗钵舍那当知违逆。如是黑品白品差别建立加行有十八种。如是名为心一境性

云何净障。谓即如是正修加行诸瑜伽师。由四因缘能令其心净除诸障。何等为四。一遍知自性故。二遍知因缘故。三遍知过患故。四修习对治故。云何遍知诸障自性。谓能遍知障有四种。一怯弱障。二盖覆障。三寻思障。四自举障。怯弱障者。谓于出离及于远离勤修行时所有染污思慕不乐希望忧恼。盖覆障者。谓贪欲等五盖。寻思障者。谓欲寻思等染污寻思。自举障者。谓于少分下劣智见。安隐住中而自高举。谓我能得余则不尔。乃至广说如前。应知是名遍知诸障自性。云何遍知诸障因缘。谓能遍知。初怯弱障有六因缘。一由先业增上力故。或由疾病所扰恼故。其身羸劣。二太过加行。三不修加行。四初修加行。五烦恼炽盛。六于远离犹未串习。遍知盖覆寻思自举障因缘者。谓于随顺盖覆寻思及自举障处所法中。非理作意多分串习。是名盖覆寻思自举障之因缘。若不作意思惟不净。而于净相作意思惟。是名此中非理作意。若不作意思惟慈愍而于嗔相作意思惟。是名此中非理作意。若不作意思惟明相。而于闇相作意思惟。是名此中非理作意。若不作意思惟奢摩他相。而于亲属国土不死昔所。曾更欢娱戏笑承奉等事诸恶寻思。作意思惟。是名此中非理作意。若不作意思惟缘性缘起。而于三世诸行计我我所。不如理想作意思惟。是名此中非理作意。云何遍知诸障过患。谓遍了知此障有故于其四种未证不证已证退失。败坏瑜伽所有加行。有染污住有苦恼住自毁毁他。身坏命终生诸恶趣。是名遍知诸障过患。云何名为修习对治。谓诸怯弱总用随念以为对治。由随念作意庆悦其心。令诸怯弱已生除遣未生不生其身羸劣。太过加行。初修加行用于精进平等通达以为对治。不修加行。用恭敬听闻勤加请问以为对治。烦恼炽盛。用不净等所缘加行以为对治。若未串习。即用如是思择方便以为对治。谓我昔于远离不串习故。今于修习远离生起怯弱。我若于今不习远离。于当来世定复如是。故我今者应正思择于其远离舍不喜乐修习喜乐。余盖覆等非理作意。用彼相违如理作意以为对治。应知是名修习对治。又遍了知诸障自性是能障碍。是能染污。是黑品摄。是应远离。能遍了知如是诸障远离因缘。方可远离故。应寻求诸障因缘能遍了知于应远离。不远离者有何过患。故应寻求诸障过患。既远离已更复寻思如是诸障。云何来世当得不生。故应寻求修习对治。由是因缘能令其心净除诸障

当如此中由随顺教有众多故。毗钵舍那亦有众多。毗钵舍那有众多故。令奢摩他亦有众多。又复即此毗钵舍那由所知境无边际故。当知其量亦无边际。谓由三门及六种事。一一无边品类差别悟入道理。正修行者如如毗钵舍那串习清净增上力故。增长广大如是如是能生身心所有轻安。奢摩他品当知亦得增长广大如如身心获得轻安。如是如是于其所缘心一境性转得增长。如如于缘心一境性转复增长。如是如是转复获得身心轻安。心一境性身心轻安。如是二法展转相依展转相属。身心轻安心一境性。如是二法若得转依方乃究竟。得转依故于所知事现量智生。问齐何当言究竟获得不净观耶乃至齐何当言究竟获得阿那波那念耶。答以要言之。修观行者于不净观正加行中。亲近修习。多修习故。若行若住虽有种种境界现前。虽复观察所有众相。而住自性不由加行。多分不净行相显现非诸净相。由于不净善修习故于能随顺贪欲缠处法。心不趣入心不爱乐心不信解。安住于舍深生厌逆。当于尔时修观行者应自了知。我今已得不净观。我今已得所修果。齐此名为于不净观已得究竟。与此相违当知名为未得究竟。如不净观如是。慈愍缘性缘起界差别阿那波那念念。当知亦尔。于中差别者。谓多分慈心行相显现非嗔恚相于能随顺嗔恚缠处法。心不趣入乃至广说。多分无常苦空无我行相显现。非彼常乐身见俱行愚痴行相。于能随顺愚痴缠处法。心不趣入乃至广说。多分种种界性非一界性。身聚差别相想显现非身聚想。于能随顺憍慢缠处法。心不趣入乃至广说。多分内寂静想奢摩他想显现非戏论想。于能随顺寻思缠处法。心不趣入乃至广说。问齐何当言奢摩他毗钵舍那二种和合平等俱转。由此说名双运转道。答若有获得九相心住中第九相心住。谓三摩呬多。彼用如是圆满三摩地为所依止。于法观中修增上慧。彼于尔时由法观故任运转道。无功用转不由加行。毗钵舍那清净鲜白。随奢摩他调柔摄受。如奢摩他道摄受而转。齐此名为奢摩他毗钵舍那二种和合平等俱转。由此名为奢摩他毗钵舍那双运转道。中嗢柁南曰

  相寻思伺察　　随行有三门
  义事相品时　　理六事差别
  初相应加行　　次串习无缓
  无颠倒应时　　解了无厌足
  不弃舍善轭　　最后正加行
  是九应当知　　有二品差别
  知自性因缘　　见彼诸过患
  正修习对治　　令障得清净

云何修作意。谓初修业者始修业时。于如是所安立普遍相中。由一境性及净诸障。离邪加行学正加行。彼应最初作如是念。我今为证心一境性及断喜乐。当勤修习四种作意。何等为四。一调练心作意。二滋润心作意。三生轻安作意。四净智见作意。云何调练心作意。谓由此作意于可厌患法令心厌离。是名调练心作意。云何滋润心作意。谓由此作意于可欣尚法令心欣乐。是名滋润心作意。云何生轻安作意。谓由此作意于时时间于可厌法令心厌离。于时时间于可欣法令心欣乐。已安住内寂静无相无分别中一境念转。由是因缘对治一切身心粗重。能令一切身心适悦。生起一切身心轻安。是名生轻安作意。云何净智见作意。谓由此作意于时时间即用如是内心寂静为所依止。由内静心数数加行。于法观中修增上慧。是名净智见作意。彼修行者。于时时间于可厌法令心厌离。如是于漏及漏处法。能令其心生热等热生厌等厌。何等名为可厌患处。略有四种可厌患处。谓自衰损及他衰损。现在会遇正现前时。如理作意数思惟故成可厌处。若自兴盛及他兴盛。过去尽灭离变坏时。如理作意数思惟故成可厌处即彼行者于时时间于可欣法令心欣乐。如是于彼生欣乐故。能令其心极成津润融适澄净。何等名为可欣尚处。略有三种可欣尚处。一者三宝。二者学处清净尸罗清净。三者于自所证差别深生信解心无怯弱。云何随念三宝令心欣乐。谓作是念。我今善得如是大利。谓蒙如来应正等觉为我大师。我今善得如是大利。谓善说法毗柰耶中我得出家。我今善得如是大利。谓我与诸具戒具德。忍辱柔和成贤善法。同梵行者共为法侣。我今当得贤善命终贤善殒没。当得贤善趣于后世。如是名为随念三宝令心欣乐。云何随念学处清净。尸罗清净令心欣乐。谓作是念。我今善得如是大利谓于如来应正等觉大师善说法毗柰耶善修正行声闻众中。我得与彼同梵行者。同戒同学同修慈仁身语意业。同其所见同所受用。如是名为随念学处清净尸罗清净令心欣乐。谓无悔为先发生欢喜。云何于自所证差别深生信解心无怯弱处令心欣乐。谓作是念。我今有力有所堪能尸罗清净堪为法器。得与如是同梵行者同清净戒。得与有智正至善士同其所见。我有堪能精勤修习如是正行。于现法中能得未得。能触未触能证未证。由是令心生大欢喜。如是名为于自所证差别。深生信解心无怯弱处令心欣乐。又由前后勇猛精进。已得安住所证差别。由随念此复于后时所证差别。深生信解令心欣乐。是名异门。彼修行者于可厌法调练其心。于能随顺诸漏处法令心不向。违逆弃背离隔而住于可欣法。悦润其心。于出于离所生诸法有亲爱故。令心趣向附着喜乐和合而住。如是彼心由厌由欣二种行相。背诸黑品向诸白品易脱而转。其心如是。背诸黑品。由调练心作意故。向诸白品。由滋润心作意故。于时时间依奢摩他内摄持心由生轻安作意故。于时时间于法思择最极思择周遍寻思周遍伺察。由净智见作意故。如是彼心于时时间为奢摩他毗钵舍那之所摄受堪能。与彼一切行相一切功德作摄受因。经历彼彼日夜刹那腊缚须臾逮得胜进。譬如黠慧锻金银师或彼第子。于时时间烧炼金银。令其弃舍一切垢秽。于时时间投清冷水。令于彼彼庄严具业有所堪任调柔随顺。于是黠慧锻金银师或彼弟子。以其相似妙工巧智。善了知已用作业具。随其所乐庄严具中种种转变。如是勤修瑜伽行者。为令其心弃背贪等一切垢秽。及令弃背染污忧恼。于可厌法深生厌离。为令趣向所有清净善品喜乐。于可欣法发生欣乐。于是行者随于彼彼欲自安立或奢摩他品或毗钵舍那品。即于彼彼能善亲附。能善和合无转无动。随其所乐种种义中。如所信解皆能成办

瑜伽师地论卷第三十一瑜伽师地论卷第三十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第三瑜伽处之三

云何初修业者始修业时。于修作意如应安立。随所安立正修行时最初触证。于断喜乐心一境性。谓善通达修瑜伽师。最初于彼依瑜伽行初修业者。如是教诲。善来贤首。汝等今者应依三种取相因缘。或见或闻或心比度。增上分别取五种相。一厌离相。二欣乐相。三过患相。四光明相。五了别事相。问若依瑜伽行初修业者是其贪行。由不净观方可调伏。云何教彼取五种相。答应如是教诲。善来贤首。汝等随所依止彼彼聚落村邑而住于中。若闻所余彼彼村邑聚落。或男或女先受安乐后遭苦厄。或彼男女自遭重病命终殒没。或彼勇女所有知识亲戚眷属遭如是苦。或彼聚落村邑边际丧失财宝。或是他来强敌所作。或火所烧或水所漂。或由恶作而有丧失。或由不善修营事业而有丧失。或由不善处分事业而有丧失。或为非爱共财得便而有丧失。或由家火而有丧失。若汝现见非是传闻。或即于此村邑聚落。非是所余村邑聚落。或非是此村邑聚落。亦非他人。即汝自身先所触证猛利乐受。后还退失。广说如前。汝既如是闻已见已。应当生起深心厌患。如是生死甚为重苦。所得自体极大艰辛。而于其中有如是等自他衰损差别可得。谓病衰损寿命衰损。眷属衰损财宝衰损。病病法性死死法性。复有一类净戒衰损正见衰损。由是因缘彼诸众生于现法中住诸苦恼。于当来世往诸恶趣。诸兴盛者虽现法中住诸安乐于当来世往诸善趣。而是无常。于彼无常现可证得。若有领受兴盛事者。后时衰损定当现前。诸有领受衰损事者。后时兴盛难可现前。诸兴盛事皆是难得易失。坏法如是汝应深心厌患。极善作意如理受持。如是处所难可保信。我今于是生死流转。未般涅槃未解脱心。难可保信。如是衰损兴盛二法勿现我前。勿彼因缘令我堕在如是处所。生起猛利刚强辛楚不适意苦。即由此事增上力故。我当至诚喜乐于断修不放逸。又我如是多安住故。当于无义能作边际。如是汝应善极作意如理受持。汝取如是厌离相已。复应精勤取欣乐相。当自观察所受尸罗。为善清净为不清净。我或失念或不恭敬或多烦恼。或由无知于诸学处有所违犯。既违犯已我当如法以其本性增上意乐。于诸学处发起深心更不毁犯。我于所作当正应作。于非所作不复当作。以要言之。于诸学处当令增上意乐圆满。亦令所有加行圆满。汝于如是正观察时。若自了知戒蕴清净。虽不作思我当发起清净无悔。然其法尔。尸罗净者定生如是清净无悔。若起如是清净无悔。虽不作思我起欢悦。然其法尔无有悔者定生欢悦。如是且于一种欢悦所依处所。汝应生起清净无悔为先欢悦。复于除障喜悦处所当生喜悦。谓我今者尸罗清净。有力有能安住世尊所制学处。于现法中能得未得能触未触。能证未证。由是处所生喜悦意。若汝获得前后所证少分差别。即由如是增上力故。于他圆满。所证差别。谓诸如来或圣弟子及自后时所证差别。当生信解发喜悦意。如是行相诸适悦意。先名欢悦今名喜悦。总名悦意。如是名为取欣乐相。取是相已复应教授告言。贤首。汝由如是厌离相故调练其心。复由如是欣乐相故滋润其心。汝于断灭世间贪忧应多安住。随于彼彼所缘境界勤修加行。或奢摩他品或毗钵舍那品。即于彼彼所缘境界。当令心住内住等住。汝当获得身心轻安及一境住。汝若如是背诸黑品向诸白品。由调练心滋润心故。复应数数取过患相。谓于所有诸相寻思及随烦恼取过患相。言诸相者。谓色等十相。言寻思者。谓欲等八。随烦恼者。谓贪欲等五。汝应于彼取过患相。如是诸相能令其心作用遽务。如是寻思能令其心思慕躁扰。如是随烦恼能令其心恒不寂静。若心作用诸相所作。思慕躁扰寻思所作。恒不寂静随烦恼所作。由是令心苦恼而住。是故如是诸相寻思及随烦恼。是苦非圣能引。无义令心散动。令心躁扰。令心染污。汝应如是取过患相。又汝应依心一境性心安住性心无乱性。以六种行正取其相。何等为六。一无相想。二于无相中无作用想。三无分别想。四于无分别中无所思慕无躁扰想。五寂静想。六于寂静中离诸烧恼寂灭乐想。汝取如是过患相已。复应数数取光明相。谓或灯明或大火明。或日轮明或月轮明。既取如是光明相已。复诸冢间取青瘀相。广说乃至取骨锁相。汝若不能往诣冢间。当取彩画木石所作如是诸相。取是相已还所住处。或阿练若或林树下或空闲室。或在大床或小绳床或草叶座。先洗足已结跏趺坐。端身正愿安住背念。先于一境令心不散系念在前。复于其中依六种想作意思惟。谓无相想无分别想。寂静想。无作用想。无所思慕无躁扰想。离诸烧恼寂灭乐想。又于其中汝当审谛周遍了知乱不乱相。分明现前如如审谛。周遍了知乱不乱相。如是如是汝能了知诸相寻思随烦恼中所有乱相。及能了知心一境性随六想修诸不乱相。又汝于此乱不乱相。如是如是审谛了知。便能安住一所缘境亦能安住内心寂止。诸心相续诸心流注。前后一味无相无分别寂静而转。又若汝心虽得寂止。由失念故。及由串习诸相寻思随烦恼等诸过失故。如镜中面所缘影像数现在前。随所生起。即于其中当更修习不念作意。谓先所见诸过患相增上力故。即于如是所缘境相。由所修习不念作意。除遣散灭当令毕竟不现在前。贤首当知。如是所缘甚为微细难可通达。汝应发起猛利乐欲。为求通达发勤精进。世尊依此所缘境相密意说言。汝等苾刍当知众善。言众善者。谓于大众共集会中盛壮美色。即此众善最殊胜者。谓于多众大集会中歌舞倡伎。假使有一智慧丈夫。从外而来告一人曰。咄哉男子。汝于今者可持如是平满钵油勿令滟溢。经历如是大众中过当避其间所有众善及诸最胜歌舞倡伎大等生等。今有魁脍露拔利剑随逐汝行。苦汝钵油一滴堕地。此之魁脍即以利剑。当斩汝首断汝命根。苾刍汝等于意云何。是持钵人颇不作意专心油钵拔剑。魁脍不平地等。而能作意观视众善及诸最胜歌舞倡伎大等生耶。不也。世尊。何以故。是持钵人既见魁脍露拔利剑随逐而行。极大怖畏专作是念。我所持钵油既弥满。经是众中极难将度。脱有一滴当堕地者。定为如是拔剑魁脍。当斩我首断我命根。是人尔时于彼众善及诸最胜歌舞倡伎大等生等。都不作意思念观视。唯于油钵专心作意而正护持。如是苾刍。我诸弟子恭敬殷重专心忆念。修四念住当知亦尔。言众善者。瑜能随顺贪欲缠等随烦恼法。于中最胜歌舞倡伎。喻能随顺寻思戏论躁扰处法。大等生等喻色相等十种相法。智慧丈夫。喻瑜伽师。平满油钵。喻奢摩他所安住心能令身心轻安润泽。是奢摩他义。露拔利剑随行魁脍。喻先所取诸相寻思随烦恼中诸过患相。专心将护不令钵油一滴堕地。喻能审谛周遍了知乱不乱相之所摄受奢摩他道。由是能令诸心相续诸心流注。由精进力无间策发。前后一味无相无分别寂静而转。不起一心。复缘诸相。或缘寻思及随烦恼。是瑜伽师复应如是殷勤教诲于奢摩他初修业者告言。贤首。汝若如是精勤修习奢摩他道。如是方便摄受。正念正知俱行。有喜乐心乃名善修奢摩他道。若复串习诸过失故。不能于中深心喜乐。极大艰辛励力策发方现前者。还应速疾出无分别所缘境相。于有分别所缘境相系念在前。如先所取诸不净相。汝今复应作意思惟。先应用彼唯随相行毗钵舍那。或观青瘀或观脓烂。广说乃至观骨观锁或观骨锁。汝于如是初修观时。于一青瘀广说乃至于一骨锁当起胜解。若于其中已串修习观道明净。于所缘相明了胜解相续转时。复应于二于三于四于五于十二十三十四十五十。或百青瘀或千青瘀。乃至一切诸方诸维所有青瘀。起无量行遍一切处无间胜解。于中乃至无有容受一杖端处。如于青瘀如是。乃至骨锁亦尔。汝依如是胜解作意。应当趣入真实作意。于趣入时应作是念。如我今者胜解所作。无量青瘀广说乃至无量骨锁。真实青瘀乃至骨锁。其量过此不可数知。所以者何。从前际来于彼彼有彼彼趣中轮回生死。我所曾经命终夭没。所弃尸骸所起青瘀。广说乃至所起骨锁无量无边。如是所起推其前际不可知故。假使有能摄聚如是所弃尸骸令不坏烂。一切大地亦不容受。于一劫中所弃尸骸乃至骨锁。假使有能敛在一处。其聚量等广大胁山。如从前际后际亦尔。乃至未能作苦边际。如是汝依胜解作意。应当趣入真实作意。又非修习如是青瘀乃至骨锁毗钵舍那。应顿观察。才应于一尸骸青瘀起胜解已。寻复令心于内寂静。乃至于此所缘境相喜乐明净。无诸扰恼不强励力。齐尔所时应于如是尸骸青瘀发起胜解。若才于此乃至励力方现在前。尔时于内应修寂静。如于青瘀。乃至骨锁当知亦尔。由此道理乃至无量当知亦尔。如是令心内寂静已。复应发起寂静胜解。谓从最后无量青瘀。乃至最后无量骨锁。内略其心方便除遣安置众相不显现。中不全弃舍有分别相。亦不分别。唯即于此所缘境界安住其心。无相无分别寂静而转。彼瑜伽师复应教授告言。贤首。汝先所取诸光明相。于奢摩他品加行中。及于毗钵舍那品加行中。皆应作意如理思惟。若汝能以光明俱心。照了俱心。明净俱心。无闇俱心。修奢摩他毗钵舍那。如是乃为于奢摩他毗钵舍那道修光明想。若有最初于所缘境多不分明。数习胜解。其相闇昧。由是因缘后所修习所有胜解。亦不分明。虽多串习而相闇昧。若有最初于所缘境多分分明。数习胜解其相明了。由是因缘后所修习转复分明。虽少串习而相明了。如是汝由善取如是厌离相故。善取如是欣乐相故。善取如是奢摩他相故。善取如是毗钵舍那相故。善取如是光明相故。于时时中内以寂静。于时时中由随相行毗钵舍那。思择诸法。即于不净正修加行增上力故。于诸念住渐次趣入。将趣入时汝应先于内身所有三十六物。始从发毛乃至小便。善取其相。汝应于是自内身中诸不净物。先当发起不净胜解。数数发起此胜解已。复令其心于内寂静。如是名为于内身中修循身观。依自身内而发起故。次应于外诸不净物善取其相。汝当发起青瘀胜解。广说乃至骨锁胜解。或狭小胜解。或广大胜解。或无量胜解。数数发起此胜解已。复令其心于内寂静。如是名为于外身中修循身观。依他外身而发起故。后复应于自身内外诸不净物。善取其相令心明了。又于他身内外不净。善取其相。令心明了。于自所爱汝当发起如是胜解。复于死已出送冢间。至冢间已弃之在地。弃在地已至青瘀位。至脓烂位。广说乃至至骨锁位。发起胜解。数数发起此胜解已。复令其心于内寂静。如是名为于内外身修循身观。依自他身若内若外而发起故。汝复应于四无色蕴由闻思增上力分别取相。于其三分发起胜解。一于奢摩他品。二于无散乱品。三于毗钵舍那品。于奢摩他品者。谓若汝心于内略时。起无相无分别寂静想行。及无作用无思慕无躁动。离诸烧恼寂灭乐想行。于所缘境无乱受等四无色蕴。刹那刹那展转别异。唯是新新而非故故相续流转。汝应于此如理思惟发起胜解。如是名为于内受心法修循受心法观。于无散乱品者。谓汝于先取诸境界缘诸境界堕不定地。过去尽灭及今失念。心乱所生诸相寻思随烦恼境。增上受等四无色蕴。汝应于此如理作意。如是诸法其性皆是诳幻所作。暂时而有率尔现前。多诸过患。其性无常不可保信。汝应如是发起胜解。如是名为于外受心法修循受心法观。于毗钵舍那品者。谓汝善取毗钵舍那相已。住有相有分别作意。于有分别有相所缘。增上内所生受等四无色蕴。如理作意思惟此法刹那刹那展转别异。唯是新新而非故故相续流转。如前所说发起胜解。如是名为于内外受心法修循受心法观。如是汝田依不净观正修加行增上力故。于四念住当得趣入。又汝应于念住加行时时修习胜奢摩他毗钵舍那。汝于如是四念住中安住正念。随依彼彼村邑聚落边际而住。于心随顺趣向临入所缘境界。汝应舍此所缘境相入彼村邑聚落乞食。应当善避恶象恶马。恶牛恶狗。恶蛇恶兽。坑涧濠堑。株杌毒刺。泥水粪秽。及应远离诸恶威仪秽坐卧具。汝应如是善护己身。若于如是诸境界相。不应策发诸根。汝应于彼不作功用善守诸根。若于如是诸境界相。应当策发诸根。汝应于彼正作功用善住正念。令诸烦恼不起现行。汝应如是善护己身善守诸根。善住正念于彼作意。善知其量受用饮食。又汝应与在家出家。说应量语。说应理语说应时语说正直语。说寂静语。一切世间非法言论皆当远离。虽复宣说如法言论不应诤竞。何以故。若诸士夫补特伽罗。住诤竞语互相难诘。其心便住多戏论中。多戏论故其心掉举。心掉举故心不寂静。不寂静故便令其心远三摩地。如是行已。汝应速疾不舍所缘结跏趺坐。于奢摩他毗钵舍那如所取相。由恒常作及毕竟作修瑜伽行。犹如世间钻火方便。起无间加行及殷重加行。汝应如是恒常修作毕竟修作。又汝应起如是愿心。假使一切赡部洲人。尽赡部洲曾经寿量。今皆总集在我一身。我亦尽此无量寿命。决定于断瑜伽作意胜奢摩他毗钵舍那。精勤修习时无暂舍。由正了知如是所修瑜伽加行有大胜果大胜利故。何况如是小分寿量少时存活。虽极远去不过百年。委悉算计但须臾顷。如是汝应随所教诲恒常修作毕竟修作。若为此义受习于断。汝于此义必当获得。汝当最初证得下劣身心经安心一境性。后当证得世出世间广大圆满。初修业者始修业时。善达瑜伽诸瑜伽师。依不净观如是教诲名正教诲。如是修行名正修行。如说贪行是不净观之所调伏。如是嗔行是慈愍观之所调伏。乃至最后寻思行是阿那波那念之所调伏。如其所应皆当了知其中差别。余趣入门我当显示。依慈愍观初修业者。于外亲品怨品及中庸品。善取相已处如法坐。由利益安乐增上意乐俱行定地作意。先于一亲一怨一中庸所。发起胜解。于此三品。由平等利益安乐增上意乐俱行作意。欲与其乐。如是念言。愿彼求乐诸有情类皆当得乐。谓或无罪欲乐。或无罪有喜乐。或无罪无喜乐。次后或于二亲或于三亲。或于四亲或于五亲十亲二十三十。如前乃至遍诸方维。其中亲品充满无间发起胜解。于中乃至无有容受一杖端处。如于亲品。如是于怨及中庸品当知亦尔。又彼不舍慈愍加行。即由修习如是慈愍。于诸念住能正趣入。云何趣入。谓趣入时应当发起如是胜解。如彼于我谓亲谓怨谓中庸品。我既欲乐厌背其苦。如是名为于其内身修循身观。余亦于彼谓亲谓怨谓中庸品。如我彼亦欲乐背苦。如是名为于其外身修循身观。如我既尔。彼诸有情亦复如是。如我自欲求得胜乐。彼诸有情亦复如是。彼诸有情与己平等与己相似。我当与彼利益安乐。如是名为于内外身修循身观。此四念住总缘诸蕴为境界故。当知说名坏缘念住。若修行者但取色相。谓取显相形相表相。于亲品怨品及中庸品而起胜解。由此建立唯身念住。彼复依止胜解作意。能正趣入真实作意。谓趣入时起是胜解。我于乃至无量有情发起胜解。利益安乐增上意乐。如是我从先际已来。所有亲品怨品及中庸品。落谢过去诸有情类。其数无量甚过今者。胜解所作。如是过去诸有情类。为我亲已复为我怨。为我怨已复为我亲。为怨亲已复为中庸。为中庸已复为怨亲。由是义门一切有情平等。平等无有少分亲性怨性及中庸性。而非真实。由是因缘遍于三品起平等心。平等应与利益安乐。如从先际。如是后际。于生死中当复流转。应知亦尔。又我于彼先际已来。诸有情类未曾发起慈愍之心。彼皆过去。今起慈愍复有何益。但为除遣自心垢秽。令得清净故起念言。当令过去诸有情类皆得安乐。诸未来世非曾有者。亦皆令彼当得安乐。如是趣入真实作意。慈愍住中诸福滋润诸善滋润。望前所修胜解作意。慈愍住中所获福聚。彼于百分不及此一。彼于千分不及此一。彼于数分算分计分邬波尼杀昙分不及此一。余如前说。又于缘性缘起观中初修业者。由闻思慧增上力故。分别取相。谓诸有情由有种种无智愚痴。现见无常妄计为常。现见不净妄计为净。现见其苦妄计为乐。现见无我妄计为我。彼诸有情有如是等种种颠倒。颠倒为因于现法受及后所生诸自体中发起贪爱。由贪爱故造作种种生根本业。此烦恼业为因缘故。感得当来纯大苦蕴。彼既善取如是相已。复于其内发起胜解。谓我今此纯大苦蕴亦如是生。又我自体无边无际从先际来初不可知亦如是生。彼诸有情去来现在一切自体苦蕴所摄。亦皆如是已生当生。如是缘性缘起正观。一切皆是真实作意。更无所余胜解作意。若于自身现在诸蕴缘性缘生作意思惟。是名于内身受心法住彼循观。若于他身现在诸蕴缘性缘生。作意思惟。是名于外身受心法住彼循观。若于自他过去未来所有诸蕴缘性缘生。作意思惟。名于内外身受心法住彼循观。余如前说。又于界差别观初修业者。先取其外所有坚相。所谓大地。山林草木塼石瓦砾。末尼真珠。琉璃螺贝。珊瑚玉等。取彼相已复于内坚而起胜解。次取其外诸大水相。所谓江河众流。陂湖池沼井等。取彼相已复于内湿而起胜解。次取其外诸大火相。所谓热时烈日。炎炽焚烧。山泽灾火蔓莚窑室等中所有诸火。取彼相已复于内暖而起胜解。次取其外诸大风相。所谓东西南北等风乃至风轮。取彼相已复于内风而起胜解。次取其外诸大空相。所谓诸方无障无碍诸聚色中孔隙窟穴有所容受。善取如是空界相已。于内空界而起胜解。后由闻思增上力故。起细分别取识界相。所谓内眼处不坏。外色处现前。若无能生作意正起。所生眼识亦不得生。与是相违眼识得生。如是乃至意法意识当知亦尔。取是相已次起胜解。了知如是四大身中有一切识诸种子界种性自性。又于如是四大种中。先起支节粗大胜解。后起分析种种细分微细胜解。如是渐次分析乃至向游尘量。如是渐渐乃至极微而起胜解。一一支分尚起无量最极微尘积集胜解。何况身中一切支分。如是名为界差别观中分析诸色界差别边际微细胜解。次于空界先当发起所有粗大空界胜解。所谓眼耳鼻喉筒等种种窍穴。由是吞咽于是吞咽。既吞咽已由是下分不净流出。次后渐渐发起种种微细胜解。乃至身中一切微细诸毛孔穴皆悉了知。后于识界渐渐发起所依所缘。及以作意三世时分品类差别无量胜解。即于识界起胜解时。由诸所依所缘胜解分析识界。亦于十种所造诸色而起胜解。如诸大种微细分析。此亦如是。若于自身各别诸界而起胜解。是名于内诸念住中住彼循观。若于其余非有情数。所有诸界而起胜解。是名于外住彼循观。若于其余诸有情数所有诸界而起胜解。名于内外住彼循观。复有异门。谓于己身而起胜解。临舍命时如前广说。至青瘀位或复脓烂。即于脓烂发起种种流出胜解。渐渐脓流展转增广。乃至大海大地边际脓悉充满。发起如是脓胜解已。次复发起火烧胜解。谓此身分无量无边品类差别。为大火聚无量无边品类烧烬。火既灭已复起余骨余灰胜解。复起无量无边胜解。碎此骨灰以为细末。复起无量大风胜解。飘散此末遍诸方维。既飘散已不复观见所飘灰骨及能飘风。唯观有余眇茫空界。如是由其胜解作意。依于内外不净加行入界差别。于其身相住循身观。从是趣入真实作意。谓由如是胜解作意。于内外身住循身观。由胜解力我此所作无量无边水界火界地界风界虚空界相。我从无始生死流转。所经诸界无量无边甚过于此。谓由父母兄弟姊妹眷属丧亡。及由亲友财宝禄位离散失坏。悲泣雨泪。又饮母乳。又由作贼拥逼劫掠穿墙解结。由是因缘。遭无量度截手刖足。斩头劓鼻。种种解割身诸支节。由是因缘血流无量。如是所有泪乳血摄水界水聚。四大海水皆悉盈满。于百分中不及其一。广说如前。又于诸有诸趣死生。经无量火焚烧尸骸。如是火聚亦无比况。又经无量弃舍骸骨狼籍在地亦无比况。又经无量风界生灭分析尸骸亦无比况。又经无量诸尸骸中眼等窍穴。又经无量诸识流转。后后尸骸新新发起。乃至今者最后尸骸诸识流转。如是安立后际诸趣期限无定。如是乃至无量识界。又于阿那波那念正加行中。初修业者。先于舍宅前后窗门或打铁师。或锻金银师。吹筒[橐-木+棐]袋。或风外聚入出往来。善取相已。由缘于内入出息念。于入出息而起胜解。彼复先于微细息风经心胸处。粗穴往来而起胜解。然后渐渐于众多风而起胜解。所谓乃至一切毛孔风皆随入而起胜解。如是所有一切身分。风聚所随风聚所摄风聚藏隐无量风聚于中积集。如妒罗绵或叠絮等。诸轻飘物于是诸相而起胜解。彼若于内入息出息流转不绝作意思惟。尔时名为于其内身住循身观。若复于他死尸骸中青瘀等位入息出息流转断绝作意思惟。尔时名为于其外身住循身观。若复于自临欲死时而起胜解。或于已死入息出息无有流转而起胜解。或于未死入息出息无有流转而起胜解。由法尔故。尔时名为于内外身住循身观。遍于一切正加行中。应修如是止品助伴止品所摄无倒加行。所余一切如前应知。如是所有初修业者。蒙正教诲修正行时。安住炽然正知具念。调伏一切世间贪忧。若于如是正加行中。恒常修作毕竟修作无倒作意。非諠闹等所能动乱。是名炽然。若于如是正加行中。修奢摩他毗钵舍那。审谛了知乱不乱相。如是名为正知具念。若能善取诸厌离相诸欣乐相。如是乃名调伏一切世间贪忧。由是因缘宣说彼能安住炽然。乃至调伏世间贪忧。先发如是正加行时。心一境性身心轻安微劣而转难可觉了。复由修习胜奢摩他毗钵舍那。身心澄净身心调柔身心轻安。即前微劣心一境性身心轻安。渐更增长能引强盛易可觉了。心一境性身心轻安。谓由因力展转引发方便道理。彼于尔时不久当起强盛。易了身心轻安心一境性。如是乃至有彼前相。于其顶上似重而起非损恼相。即由此相于内起故。能障乐断。诸烦恼品心粗重性皆得除灭。能对治彼。心调柔性心轻安性皆得生起。由此生故有能随顺起身轻安。风大偏增众多大种来入身中。因此大种入身中故。能障乐断。诸烦恼品身粗重性。皆得除遣。能对治彼。身调柔性身轻安性。遍满身中状如充溢。彼初起时令心踊跃令心悦豫。欢喜俱行令心喜乐。所缘境性于心中现。从此已后彼初所起轻安势力渐渐舒缓有妙轻安随身而行在身中转。由是因缘心踊跃性渐次退减。由奢摩他所摄持故。心于所缘寂静行转。从是已后于瑜伽行。初修业者名有作意。始得堕在有作意数。何以故。由此最初获得色界定地所摄少分微妙正作意故。由是因缘名有作意。得此作意初修业者有是相状。谓已获得色界所摄少分定心。获得少分身心轻安心一境性。有力有能善修净惑所缘加行。令心相续滋润而转。为奢摩他之所摄护能净诸行。虽行种种可爱境中。猛利贪缠亦不生起。虽少生起依止少分微劣对治。暂作意时即能除遣。如可爱境。可憎可愚可生憍慢可寻思境。当知亦尔。宴坐静室暂持其心。身心轻安疾疾生起。不极为诸身粗重性之所逼恼。不极数起诸盖现行。不极现行思慕。不乐忧虑俱行诸想作意。虽从定起出外经行。而有少分轻安余势随身心转。如是等类当知是名有作意者清净相状

瑜伽师地论卷第三十二瑜伽师地论卷第三十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第四瑜伽处之一

复次此嗢拖南曰

  七作意离欲　　及诸定广辩
  二定五神通　　生差别诸相
  观察于诸谛　　如实而通达
  广分别于修　　究竟为其后

已得作意诸瑜伽师。已入如是少分乐断。从此已后唯有二趣更无所余。何等为二。一者世间。二出世间。彼初修业诸瑜伽师。由此作意或念我当往世间趣。或念我当往出世趣。复多修习如是作意。如如于此极多修习。如是如是所有轻安心一境性。经历彼彼日夜等位转复增广。若此作意坚固相续强盛而转。发起清净所缘胜解。于奢摩他品及毗钵舍那品善取其相。彼于尔时或乐往世间道发起加行。或乐往出世道发起加行。

问此中几种补特伽罗。即于现法乐往世间道发起加行。非出世道。答略有四种补特伽罗。何等为四。一一切外道。二于正法中根性羸劣先修止行。三根性虽利善根未熟。四一切菩萨乐当来世证大菩提非于现法。如是四种补特伽罗。于现法中乐往世间道发起加行。此乐往世间道发起加行者。复有二种。一者具缚。谓诸异生。二不具缚。谓诸有学。此复云何。谓先于欲界观为粗性。于初静虑若定若生观为静性。发起加行离欲界欲。如是乃至发起加行离无所有处欲。当知亦尔。又依静虑等能引无想定等及发五神通等。

又即依此若生若相皆当广说。为离欲界欲勤修观行诸瑜伽师。由七作意方能获得离欲界欲。何等名为七种作意。谓了相作意。胜解作意。远离作意。摄乐作意。观察作意。加行究竟作意。加行究竟果作意。云何名为了相作意。谓若作意能正觉了欲界粗相初静虑静相。云何觉了欲界粗相。谓正寻思欲界六事。何等为六。一义。二事。三相。四品。五时。六理。云何寻思诸欲粗义。谓正寻思如是诸欲有多过患有多损恼。有多疫疠有多灾害。于诸欲中多过患义。广说乃至多灾害义。是名粗义。云何寻思诸欲粗事。谓正寻思于诸欲中有内贪欲。于诸欲中有外贪欲。云何寻思诸欲自相。谓正寻思此为烦恼欲此为事欲。此复三种。谓顺乐受处。顺苦受处。顺不苦不乐受处。顺乐受处是贪欲依处。是想心倒依处。顺苦受处是嗔恚依处。是忿恨依处。顺不苦不乐受处是愚痴依处。是覆恼诳谄无惭无愧依处。是见倒依处。即正寻思如是诸欲极恶诸受之所随逐。极恶烦恼之所随逐。是名寻思诸欲自相。云何寻思诸欲共相。谓正寻思此一切欲。生苦老苦广说乃至求不得苦等所随逐等所随缚。诸受欲者于圆满欲驱迫而转。亦未解脱生等法故。虽彼诸欲胜妙圆满而暂时有。是名寻思诸欲共相。云何寻思诸欲粗品。谓正寻思如是诸欲皆堕黑品。犹如骨锁如凝血肉。如草炬火如一分炭火。如大毒蛇如梦所见。如假借得诸庄严具。如树端果。追求诸欲诸有情类。于诸欲中受追求所作苦。受防护所作苦。受亲爱失坏所作苦。受无厌足所作苦。受不自在所作苦。受恶行所作苦。如是一切如前应知。如世尊说。习近诸欲有五过患。谓彼诸欲极少滋味。多诸苦恼多诸过患。又彼诸欲于习近时。能令无厌能令无足能令无满。又彼诸欲常为诸佛及佛弟子。贤善正行正至善士。以无量门呵责毁呰。又彼诸欲于习近时。能令诸结积集增长。又彼诸欲于习近时。我说无有恶不善业而不作者。如是诸欲令无厌足多所共有。是非法行恶行之因增长欲爱。智者所离速趣消灭依托众缘。是诸放逸危亡之地。无常虚伪妄失之法。犹如幻化诳惑愚夫。若现法欲若后法欲。若天上欲若人中欲。一切皆是魔之所行魔之所住。于是处所能生无量依意所起恶不善法。所谓贪嗔及愤诤等。于圣弟子正修学时能为障碍。由如是等差别因缘。如是诸欲多分堕在黑品所摄。是名寻思诸欲粗品。云何寻思诸欲粗时。谓正寻思如是诸欲去来今世。于常常时于恒恒时。多诸过患多诸损恼。多诸疫疠多诸灾害。是名寻思诸欲粗时。云何寻思诸欲粗理。谓正寻思如是诸欲。由大资粮由大追求由大劬劳。及由种种无量差别工巧业处。方能招集生起增长。又彼诸欲虽善生起。虽善增长。一切多为外摄受事。谓父母妻子奴婢作使亲友眷属。或为对治。自内有色粗重四大。糜饭长养常须覆蔽沐浴按摩。坏断离散消灭法身。随所生起种种苦恼。食能对治诸饥渴苦。衣能对治诸寒热苦。及能覆蔽可惭羞处。卧具能治诸劳睡苦。及能对治经行住苦。病缘医药能治病苦。是故诸欲唯能对治随所生起种种苦恼。不应染着而受用之。唯应正念。譬如重病所逼切人。为除病故服杂秽药。又彼诸欲有至教量证有粗相。又彼诸欲如是如是所有粗相。我亦于内现智见转。又彼诸欲有比度量知有粗相。又彼诸欲从无始来本性粗秽成就。法性难思。法性不应思议。不应分别。是名寻思诸欲粗理。如是名为由六种事觉了欲界诸欲粗相。复能觉了初静虑中所有静相。谓欲界中一切粗性。于初静虑皆无所有。由离欲界诸粗性故。初静虑中说有静性。是名觉了初静虑中所有静相。即由如是定地作意。于欲界中了为粗相。于初静虑了为静相。是故名为了相作意。即此作意当言犹为闻思间杂。彼既如是如理寻思。了知诸欲是其粗相。知初静虑是其静相。从此已后超过闻思唯用修行。于所缘相发起胜解。修奢摩他毗钵舍那。既修习已如所寻思。粗相静相数起胜解。如是名为胜解作意。即此胜解善修善习善多修习为因缘故。最初生起断烦恼道。即所生起断烦恼道俱行作意。此中说名远离作意。由能最初断于欲界先所应断诸烦恼故。及能除遣彼烦恼品粗重性故。从是已后爱乐于断爱乐远离。于诸断中见胜功德。触证少分远离喜乐。于时时间欣乐作意而深庆悦。于时时间厌离作意而深厌患。为欲除遣惛沉睡眠掉举等故。如是名为摄乐作意。彼由如是乐断乐修。正修加行善品任持。欲界所系诸烦恼缠。若行若住不复现行。便作是念。我今为有于诸欲中贪欲烦恼不觉知耶。为无有耶。为审观察如是事故随于一种可爱净相作意思惟。犹未永断诸随眠。故思惟如是净妙相时。便复发起随习近心趣习近心临习近心。不能住舍。不能厌毁制伏违逆。彼作是念。我于诸欲犹未解脱其心。犹未正得解脱。我心仍为诸行制伏。如水被持。未为法性之所制伏。我今复应为欲永断余随眠故。正勒安住乐断乐修。如是名为观察作意。从此倍更乐断乐修修奢摩他毗钵舍那。郑重观察修习对治。时时观察先所已断。由是因缘从欲界系一切烦恼心得离系。此由暂时伏断方便。非是毕竟永害种子。当于尔时初静虑地前加行道已得究竟一切烦恼对治。作意已得生起。是名加行究竟作意。从此无间由是因缘证入根本初静虑定。即此根本初静虑定俱行作意。名加行究竟果作意。又于远离摄乐作意现在转时。能适悦身离生喜乐。于时时间微薄现前。加行究竟作意转时。即彼喜乐转复增广。于时时间深重现前。加行究竟果作意转时。离生喜乐遍诸身分。无不充满无有间隙。彼于尔时远离诸欲。远离一切恶不善法。有寻有伺离生喜乐。于初静虑圆满五支具足安住。名住欲界对治修果。名随证得离欲界欲。又了相作意。于所应断能正了知。于所应得能正了知。为断应断为得应得。心生希愿胜解作意。为断为得正发加行。远离作意。能舍所有上品烦恼。摄乐作意。能舍所有中品烦恼。观察作意。能于所得离增上慢安住其心。加行究竟作意能舍所有下品烦恼。加行究竟果作意。能正领受彼诸作意善修习果。又若了相作意。若胜解作意。总名随顺作意厌坏对治俱行。若远离作意。若加行究竟作意。总名对治作意断对治俱行。若摄乐作意。名对治作意及顺清净作意。若观察作意。名顺观察作意。如是其余四种作意当知摄入六作意中。谓随顺作意。对治作意。顺清净作意。顺观察作意如初静虑定有七种作意。如是第二第三第四静虑定。及空无边处。识无边处。无所有处。非想非非想处定。当知各有七种作意。若于有寻有伺初静虑地觉了粗相。于无寻无伺第二静虑地觉了静相。为欲证入第二静虑。应知是名了相作意。谓已证入初静虑定。已得初静虑者。于诸寻伺观为粗性能正了知。若在定地。于缘最初率尔而起。匆务行境。粗意言性。是名为寻。即于彼缘随彼而起随彼而行。徐历行境。细意言性。是名为伺。又正了知如是寻伺是心法性。心生时生。共有相应同一缘转。又正了知如是寻伺依内而生外处所摄。又正了知如是一切过去未来现在所摄。从因而生。从缘而生。或增或减不久安住暂时而有率尔现前。令心躁扰令心散动不静行转。求上地时若住随逐。是故皆是黑品所摄随逐诸欲。离生喜乐少分胜利。随所在地自性。能令有如是相。于常常时于恒恒时。有寻有伺心行所缘。躁扰而转不得寂静。以如是等种种行相。于诸寻伺觉了粗相。又正了知弟二静虑无寻无伺。如是一切所说粗相皆无所有。是故宣说第二静虑有其静相。彼诸粗相皆远离故。为欲证入第二静虑。随其所应其余作意如前应知。如是乃至为欲证入非想非非想处定。于地地中随其所应。当知皆有七种作意。又彼粗相遍在一切下地皆有。下从欲界展转上至无所有处。当知粗相略有二种。谓诸下地苦住增上。望上所住不寂静故。及诸寿量时分短促。望上寿量转减少故。此二粗相由前六事。如其所应当正寻思。随彼彼地乐离欲时。如其所应于次上地寻思静相。渐次乃至证得加行究竟果作意

复次此中离欲者。欲有二种。一者烦恼欲。二者事欲。离有二种。一者相应离。二者境界离。离恶不善法者。烦恼欲因所生种种恶不善法。即身恶行语恶行等。持杖持刀斗讼诤竞。谄诳诈伪起妄语等。由断彼故说名为离恶不善法。有寻有伺者。由于寻伺未见过失。自地犹有对治欲界诸善寻伺。是故说名有寻有伺。所言离者。谓已狱得加行究竟作意故。所言生者。由此为因由此为缘。无间所生故名离生。言喜乐者。谓已获得所希求义。及于喜中未见过失。一切粗重已除遣故。及已获得广大轻安。身心调畅有堪能故。说名喜乐。所言初者。谓从欲界最初上进。创首获得依顺次数。说名为初。言静虑者。于一所缘系念寂静正审思虑。故名静虑。言具足者。谓已获得加行究竟果作意故。言安住者。谓于后时由所修习多成办故。得随所乐得无艰难得无梗涩。于静虑定其心昼夜能正随顺。趣向临入随所欲乐。乃至七日七夜能正安住。故名安住。复次于有寻有伺三摩地相。心能弃舍。于无寻无伺三摩地相。系念安住。于诸匆务所行境界。能正远离。于不匆务所行境界安住。其心一味寂静极寂静转。是故说言寻伺寂静故。内等净故。又彼即于无寻无伺三摩地中。串修习故。超过寻伺有间缺位。能正获得无间缺位。是故说言心一趣故。无寻无伺者。一切寻伺悉皆断故。所言定者。谓已获得加行究竟作意故。所言生者。由此为因由此为缘无间所生故。名定生。言喜乐者。谓已获得所希求义。又于喜中未见过失有欣有喜。一切寻伺初静虑地诸烦恼品所有粗重皆远离。故能对治彼广大轻安。身心调柔有堪能乐所随逐故。名有喜乐。依顺次数此为第二。如是一切如前应知。复次彼于喜相深见过失。是故说言于喜离欲。又于尔时远离二种乱心灾患。能于离喜第三静虑摄持其心。第二静虑已离寻伺。今于此中复离于喜。是故说言安住于舍。如是二法能扰乱心障无间舍。初静虑中有寻伺故。令无间舍不自在转。第二静虑由有喜故。令无间舍不自在转。是故此舍初二静虑说名无有。由是因缘修静虑者。第三静虑方名有舍。由有舍故。如如安住所有正念。如是如是彼喜俱行想及作意不复现行。若复于此第三静虑不善修故。或时失念。彼喜俱行想及作意时复现行。寻即速疾以慧通达能正了知。随所生起能不忍受。方便弃舍除遣变吐。心住上舍。是故说有正念正知。彼于尔时住如是舍。正念正知亲近修习。多修习故令心踊跃。俱行喜受便得除灭。离喜寂静最极寂静。与喜相违心受生起。彼于尔时色身意身领纳受乐及轻安乐。是故说言有身受乐。第三静虑已下诸地。无如是乐及无间舍。第三静虑已上诸地。此无间舍虽复可得而无有乐。下地乐舍俱无有故。上地有舍而无乐故。是故说言于是处所谓第三静虑。诸圣宣说谓依于此已得安住。补特伽罗。具足舍念及以正知。住身受乐。第三静虑具足安住。言诸圣者。谓佛世尊及佛弟子

复次此中对治种类势相似故。略不宣说乐断对治。但说对治所作乐断。何等名为此中对治。所谓舍念及以正知。由即于此数修习故。便能弃舍令不出离第三静虑。第三静虑地中胜乐。是故说言由乐断故。修静虑者即于尔时所有苦乐皆得超越。由是因缘若先所断若今所断。总集说言乐断苦断。先喜忧没。谓入第四静虑定时乐受断故。入第二静虑定时苦受断故。入第三静虑定时喜受没故。入初静虑定时忧受没故。今于此中且约苦乐二受断故。说有所余非苦乐受。是故说言彼于尔时不苦不乐。从初静虑一切下地灾患已断。谓寻伺喜乐入息出息。由彼断故此中舍念清净鲜白。由是因缘正入第四静虑定时心住无动。一切动乱皆悉远离。是故说言舍念清净。第四等言如前所说初静虑等。应知其相。复次以于虚空起胜解故。所有青黄赤白等。相应显色想。由不显现故。及厌离欲故。皆能超越。是故说言色想出过故。由不显现超越彼想以为因故。所有种种众多品类。因诸显色和合积集。有障碍想皆得除遣。是故说言有对想灭没故。由远离彼想以为因故。所有于彼种种聚中差别想转。谓饮食瓶衣乘庄严具城舍军园山林等想。于是一切不作意转。是故说言种种想不作意故。除遣如是有色有对种种想已。起无边相虚空胜解。是故说言入无边空。由已超过近分加行究竟作意。入上根本加行究竟果作意定。是故说言空无边处具足安住。当知此中依于近分乃至未入上根本定。唯缘虚空。若已得入上根本定。亦缘虚空。亦缘自地所有诸蕴。又近分中亦缘下地所有诸蕴。复次若由此识于无边空发起胜解。当知此识无边空相胜解相应。若有欲入识无边处。先舍虚空无边处想。即于彼识次起无边行相胜解

尔时超过近分根本空无边处。是故说言超过一切空无边处入无边识。由彼超过识无边处所有近分乃至加行究竟作意。入上根本加行究竟果作意定。是故说言识无边处具足安住。复次从识无边处求上进时。离其识外更求余境都无所得。谓诸所有或色非色相应境性。彼求境界无所得时。超过近分及以根本识无边处。发起都无余境胜解。此则名为于无所有假想胜解。即于如是假想胜解多修习故。便能超过无所有处一切近分乃至加行究竟作意。入彼根本加行究竟果作意定。是故说言超过一切识无边处。无少所有无所有处具足安住。复次从无所有处求上进时。由于无所有处想起粗想故。便能弃舍无所有处想。由是因缘先入无所有处定时。超过一切有所有想。今复超过无所有想。是故说言非有想。谓或有所有想。或无所有想非无想。谓非如无想及灭尽定一切诸想皆悉灭尽。唯有微细想缘无相境转。是故说言非想非非想。即于此处起胜解时。超过一切近分根本无所有处。及非想非非想处近分乃至加行究竟作意。入彼根本加行究竟果作意定。是故说言超过一切无所有处。于非想非非想处具足安住。复次此中入静虑定时。其身相状如处室中。入无色定。时其身相状如处虚空。当知此中由奢摩他相。安住上舍勤修加行

复次依静虑等当知能入二无心定。一者无想定。二者灭尽定。无想定者。唯诸异生由弃背想作意方便能入。灭尽定者。唯诸圣者由止息想受作意方便能入。如是二定。由二作意方便能入。谓无想定。由弃背想作意以为上首。勤修加行渐次能入。若灭尽定。由从非想非非想处。欲求上进暂时止息所缘作意以为上首。勤修加行渐次能入。若诸异生作如是念。诸想如病诸想如痈诸想如箭。唯有无想寂静微妙摄受。如是背想作意。于所生起一切想中。精勤修习不念作意。由此修习为因缘故。加行道中是有心位。入定无间心不复转。如是出离想作意。为先已离遍净贪未离广果贪诸心心法灭。是名无想定。由是方便证得此定。若诸圣者已得非想非非想处。复欲暂时住寂静住。从非有想非无想处心求上进。心上进时求上所缘竟无所得。无所得故灭而不转。如是有学已离无所有处贪。或阿罗汉求暂住想作意。为先诸心心法灭。是名灭尽定。由是方便证得此定。复次依止静虑发五通等。

云何能发。谓静虑者。已得根本清净静虑。即以如是清净静虑为所依止。于五通增上正法。听闻受持令善究竟。谓于神境通。宿住通。天耳通。死生智通。心差别通等。作意思惟。复由定地所起作意。了知于义了知于法。由了知义了知法故。如是如是修治其心。由此修习多修习故。有时有分发生修果五神通等。又即如是了知于义了知于法。为欲引发诸神通等修十二想。何等十二。一轻举想。二柔软想。三空界想。四身心符顺想。五胜解想。六先所受行次第随念想。七种种品类集会音声想。八光明色相想。九烦恼所作色变异想。十解脱想。十一胜处想。十二遍处想。轻举想者。谓由此想于身发起轻举胜解。如妒罗绵或如叠絮或似风轮。发起如是轻胜解已。由胜解作意于彼彼处飘转其身。谓从床上飘置几上。复从几上飘置床上。如是从床飘置草座。复从草座飘置于床。柔软想者。谓由此想于身发起柔软胜解。或如绵囊或如毛毳或如熟练。此柔软想长养摄受前轻举想。于摄受时。令轻举想增长广大。空界想者。谓由此想先于自身发起轻举柔软二胜解已。随所欲往若于中间有诸色聚能为障碍。尔时便起胜解作意。于彼色中作空胜解能无碍往。身心符顺想者。谓由此想或以其心符顺于身。或以其身符顺于心。由此令身转转轻举。转转柔软。转转堪任。转转光洁。随顺于心系属于心依心而转。胜解想者。谓由此想远作近解近作远解。粗作细解细作粗解。地作水解水作地解。如是一一差别大种展转相作。广如变化所作胜解。或色变化或声变化。由此五想修习成满。领受种种妙神境通。或从一身示现多身。谓由现化胜解想故。或从多身示现一身。谓由隐化胜解想故。或以其身于诸墙壁垣城等类厚障隔事。直过无碍或于其地出没如水。或于其水断流往返履上如地。或如飞鸟结加趺坐腾扬虚空。或于广大威德势力日月光轮以手扪摸。或以其身乃至梵世自在回转。当知如是种种神变。皆由轻举柔软空界身心符顺想所摄受胜解想故。随其所应一切能作。此中以身于其梵世。略有二种自在回转。一者往来自在回转。二于梵世诸四大种一分造色如其所乐随胜解力自在回转。先所受行次第随念想者。谓由此想从童子位迄至于今。随忆念转自在无碍。随彼彼位若行若住若坐若卧。广说一切先所受行。随其粗略次第无越忆念了知。于此修习多修习故证得修果。于无量种宿世所住。广说乃至所有行相所有宣说皆能随念。种种品类集会音声想者。谓由此想遍于彼彼村邑聚落。或长者众或邑义众或余大众。或广长处或家或室。种种品类诸众集会。所出种种杂类音声。名諠噪声。或于大河众流激湍波浪音声。善取其相。以修所成定地作意。于诸天人若远若近圣非圣声。力励听采。于此修习多修习故。证得修果清净天耳。由是能闻人间天上若远若近一切音声。光明色相想者。谓于如前所说种种诸光明相。极善取已。即于彼相作意思惟。又于种种诸有情类善不善等业用差别。善取其相。即于彼相作意思惟。是名光明色相想。于此修习多修习故。证得修果死生智通。由是清净天眼通故。见诸有情广说乃至身坏已后往生善趣天世间中。烦恼所作色变异想者。谓由此想于贪恚痴忿恨覆恼诳谄悭嫉。及以憍害无惭无愧诸余烦恼。及随烦恼缠绕其心。诸有情类种种色位色相变异。解了分别。如是色类有贪欲者。有色分位色相变异。谓诸根躁扰诸根掉举言常含笑。如是色类有嗔恚者。有色分位色相变异。谓面恒颦蹙语音謇涩言常变色。如是色类有愚痴者。有色分位色相变异。谓多分喑哑事义闇昧言不辩了语多下里。由如是等行相流类。广说乃至无惭愧等所缠绕者。有色分位色相变异。善取其相。复于彼相作意思惟。于此修习多修习故。发生修果心差别智。由此智故于他有情。补特伽罗随所寻思随所伺察心意识等皆如实知。解脱胜处遍处想者。如前三摩呬多地应知修相。由于此想亲近修习多修习故。能引最胜诸圣神通。若变事通若化事通若胜解通。及能引发无诤愿智四无碍解。谓法无碍解。义无碍解辞无碍解。辩无碍解等种种功德。又圣非圣二神境通有差别者。谓圣神通随所变事。随所化事。随所胜解。一切皆能如实成办。无有改异堪任有用。非圣神通不能如是。犹如幻化唯可观见不堪受用。当知如是十二种想。亲近修习多修习故。随其所应便能引发五种神通。及能引发不共。异生如其所应诸圣功德

复次此中于初静虑下中上品善修习已。随其所应当生梵众天梵辅天大梵天众同分中。于第二静虑下中上品善修习已。随其所应当生少光天无量光天极光净天众同分中。于第三静虑下中上品善修习已。随其所应当生少净天无量净天遍净天众同分中。于第四静虑下中上品善修习已。随其所应当生无云天福生天广果天众同分中。若不还者。以无漏第四静虑。间杂熏修有漏第四静虑。即于此中下品中品上品上胜品上极品善修习已。随其所应当生五净居天众同分中。谓无烦无热善现善见色究竟天。若于空处识处无所有处非想非非想处下中上品。善修习已。当生空处识处无所有处非想非非想处随行天众同分中。由彼诸天无有形色。是故亦无处所差别。然住所作有其差别。于无想定善修习已。当生无想有情天众同分中

复次此中云何应知离欲者相。谓离欲者。身业安住诸根无动。威仪进止无有躁扰。于一威仪能经时久不多惊惧。终不数数易脱威仪。言词柔软言词寂静。不乐諠杂不乐众集。言语安详。眼见色已唯觉了色。不因觉了而起色贪。如是耳闻声已。鼻嗅香已舌尝味已身觉触已。唯觉了声乃至其触。不因觉了而起声贪乃至触贪。能无所畏。觉慧幽深轻安广大身心隐密。无有贪婪无有愤发。能有堪忍。不为种种欲寻思等诸恶寻思扰乱其心。如是等类当知名为离欲者相

瑜伽师地论卷第三十三瑜伽师地论卷第三十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中声闻地第十三第四瑜伽处之二

如是已辩往世间道。若乐往趣出世间道。应当依止四圣谛境渐次生起七种作意。所谓最初了相作意。最后加行究竟果作意。乃至证得阿罗汉果。

修瑜伽师于四圣谛略摽广辩增上教法。听闻受持。或于作意已善修习或得根本静虑无色。由四种行了苦谛相。谓无常行苦行空行无我行。由四种行了集谛相。谓因行集行起行缘行。由四种行了灭谛相。谓灭行静行妙行离行。由四种行了道谛相。谓道行如行行行出行。如是名为了相作意。

由十种行观察苦谛。能随悟入苦谛四行。何等为十。一变异行。二灭坏行。三别离行。四法性行。五合会行。六结缚行。七不可爱行。八不安隐行。九无所得行。十不自在行。如是十行依证成道理能正观察。此中且依至教量理。如世尊说诸行无常。又此诸行略有二种。一有情世间。二器世间。世尊依彼有情世间说如是言。苾刍当知。我以过人清净天眼。观诸有情死时生时广说乃至身坏已后当生善趣天世界中。由此法门显示世尊以净天眼现见。一切有情世间是无常性。又世尊言。苾刍当知。此器世间长时安住。过是已后渐次乃至七日轮现。如七日经广说。乃至所有大地诸山大海。及苏迷卢大宝山王。乃至梵世诸器世界皆被焚烧。灾火灭后灰烬不现。乃至余影亦不可得。由此法门世尊显示诸器世间是无常性。如是且依至教量理。修观行者净信增上作意力故。于一切行无常之性获得决定。得决定已即由如是净信增上作意力故。数数寻思观察。一切现见不背不由他缘。无常之性。云何数数寻思观察。谓先安立内外二事。言内事者。谓六处等。言外事者。有十六种。一者地事。谓城邑聚落舍市廛等。二者园事。谓药草丛林等。三者山事。谓种种山安布差别。四者水事。谓江河陂湖众流池沼。五者作业事。六者库藏事。七者食事。八者饮事。九者乘事。十者衣事。十一者庄严具事。十二者舞歌乐事。十三者香鬘涂饰事。十四者资生具事。十五者诸光明事。十六者男女承奉事。如是名为十六种事。安立如是内外事已。复于彼事现见增上作意力故。以变异行寻思观察无常之性。此中内事有十五种所作变异。及有八种变异因缘。云何内事有十五种所作变异。一分位所作变异。二显色所作变异。三形色所作变异。四兴衰所作变异。五支节具不具所作变异。六劬劳所作变异。七他所损害所作变异。八寒热所作变异。九威仪所作变异。十触对所作变异。十一杂染所作变异。十二疾病所作变异。十三终没所作变异。十四青瘀等所作变异。十五一切不现尽灭所作变异。云何八种变异因缘。一积时贮畜。二他所损害。三受用亏损。四时节变异。五火所焚烧。六水所漂烂。七风所鼓燥。八异缘会遇。积时贮畜者。谓有色诸法。虽于好处安置守护。而经久时自然败坏其色衰损变异可得。他所损害者。谓种种色法。若为于他种种捶打种种损害。即便种种形色变异。受用亏损者。谓各别属主种种色物。受者受用增上力故损减变异。时节变异者。谓秋冬时丛林药草华叶果等萎黄零落。于春夏时枝叶华果青翠繁茂。火所焚烧者。谓大火纵逸焚烧村邑国城王都悉为灰烬。水所漂烂者。谓大水洪漫漂荡村邑国城王都悉皆沦没。风所鼓燥者。谓大风飘扇。湿衣湿地稼穑丛林干[韅-革+日]枯槁。异缘会遇者。谓缘乐受触受乐受时。遇苦受触。缘苦受触。受苦受时。遇乐受触。缘不苦不乐受触。受不苦不乐受时。遇乐受触或苦受触。又有贪者会遇嗔。缘贪缠止息。发起嗔缠。如是有嗔痴者。会遇异分烦恼生缘当知亦尔。如是眼识正现在前。会遇声香味触境等。余境余缘起异分识。其余一切如理应知。是名八种变异因缘。一切有色及无色法所有变异。皆由如是八种因缘。除此更无若过若增。云何寻思内事分位所作变坏无常之性。谓由观见或自或他从少年位乃至老位诸行相续前后差别。互不相似。见是事已便作是念。如是诸行其性无常。何以故。此内分位前后变异现可得故。云何寻思内事显色所作变异无常之性。谓由观见或自或他先有妙色肌肤鲜泽。后见恶色肌肤枯槁。复于后时还见妙色肌肤鲜泽。见是事已便作是念。如是诸行其性无常。何以故。此内显色前后变异现可得故。云何寻思内事形色所作变异无常之性。谓如说显色。如是形色由肥瘦故。应知亦尔。云何寻思内事兴衰所作变异无常之性。谓由观见或自或他先时眷属财位。戒见悉皆兴盛。后见一切皆悉衰损。复于后时还见兴盛。见是事已便作是念。如是诸行其性无常。何以故。兴衰变异现可得故。云何寻思内事支节所作变异无常之性。谓由观见或自或他先时支节无有缺减。后时观见支节缺减。或王所作或贼所作。或人所作或非人作。见是事已便作是念。如是诸行其性无常。余如前说。云何寻思内事劬劳所作变异无常之性。谓由观见或自或他身疲劳性身疲极性。或驰走所作。或跳踊所作。或趒踯所作。或骗骑所作。或作种种迅疾身业。复于余时见彼远离疲劳疲极。见是事已便作是念。如是诸行其性无常。余如前说。云何寻思内事他所损害所作变异无常之性。谓由观见或自他。他所损害其身变异。或由刀杖鞭革皮绳矛槊等坏。或由种种蚊虻蛇蝎诸恶毒触之所损害。复于余时见不变异。见是事已。便作是念。如是诸行其性无常。余如前说。云何寻思内事寒热所作变异无常之性。谓由观见或自或他于正寒时身不舒泰。踡局战栗寒冻缠逼希遇温阳。于正热时身体舒泰。奋身干语霡霂流汗。热渴缠逼希遇清凉。复至寒时还见。如前所说相状。见是事已。便作是念。如是诸行其性无常。余如前说。云何寻思内事威仪所作变异无常之性。谓由观见或自或他。行住坐卧随一威仪。或时为损或时为益。见是事已。便作是念。如是诸行其性无常。余如前说。云何寻思内事触对所作变异无常之性。谓由触对顺乐受触领乐触。缘所生乐时自能了别乐受分位。如能了别乐受分位。如是了别苦受分位不苦不乐受分位。应知亦尔。彼由了别如是诸受前后变异。是新新性非故故性。或增或减暂时而有。率尔现前寻即变坏。知是事已。便作是念。如是诸行其性无常。余如前说。云何观察内事杂染所作变异无常之性。谓能了知先所生起。或有贪心或离贪心。或有嗔心或离嗔心。或有痴心或离痴心。又能了知随一一种诸随烦恼所染污心。又能了知随一一种诸随烦恼不染污心。又能了知彼心相续由诸烦恼及随烦恼。于前后位趣入变坏不变坏性。见是事已便作是念。如是诸行其性无常。何以故。心由杂染所作变异现可得故。云何观察内事疾病所作变异无常之性。谓由观见或自或他。先无疾病安乐强盛。后时观见或自或他遭重病苦。触对猛利身诸苦受。如前广说。复于余时还见无病安乐强盛。见是事已。便作是念。如是诸行其性无常。余如前说。云何观察内事终没所作变异无常之性。谓由观见今时存活安住支持。复于余时观见死没唯有尸骸空无心识。见是事已。便作是念。如是诸行其性无常。余如前说。云何观察内青瘀等所作变异无常之性。谓由观见死已尸骸。或于一时至青瘀位。或于一时至脓烂位。如是乃至骨锁之位。见是事已。便作是念。如是诸行其性无常。余如前说。云何观察内事一切不现尽灭所作变坏无常之性。谓由观见彼于余时此骨锁位。亦复不现皆悉败坏离散磨灭遍一切种眼不复见。见是事已。便作是念。如是诸行其性无常。何以故。如是色相数数改转。前后变异现可得故。如是且由现见增上作意力故。十五种行观察内事种种变异无常之性。观察是已。复更观察十六外事种种变异无常之性。云何观察地事变异无常之性。谓由观见此地方所。先未造立道场天寺宅舍市廛城墙等事。后见新造善作善饰。复于余时见彼朽故圮坼。零落颓毁穿缺。火所梵烧水所漂荡。见是事已。便作是念。如是诸行其性无常。何以故。如是色相前后转变现可得故。云何观察园事变异无常之性。谓先观见诸园苑中药草丛林。华果枝叶。悉皆茂盛。青翠丹晖甚可爱乐。复于后时见彼枯槁无诸华果。柯叶零落。火所焚烧水所漂荡。见是事已便作是念。如是诸行其性无常。余如前说。云何观察山事变异无常之性。谓于一时观见其山丛林蓊郁耸石巉岩。复于一时见彼丛林巉岩耸石。雕残颓毁高下参差。火所焚烧水所漂荡。见是事已便作是念。如是诸行其性无常。余如前说。云何观察水事变异无常之性。谓先一时见诸河渎池泉井等。涛波涌溢醴水盈满后于一时见彼一切枯涸干竭。见是事已便作是念。如是诸行其性无常。余如前说。云何观察业事变异无常之性。谓先一时见彼种种殉利牧农工巧正论行船等业皆悉兴盛。复于一时见彼事业皆悉衰损。见此事已便作是念。如是诸行其性无常。余如前说。云何观察库藏变异无常之性。谓由观见种种库藏。一时盈满一时灭尽。见此事已便作是念。如是诸行其性无常。余如前说。云何观察饮食变异无常之性。谓由观见种种饮食。一时未办一时已办。一时入口牙齿咀嚼。和杂涎唾细细吞咽。一时入腹渐渐消化。一时变为屎尿流出。见此事已便作是念。如是诸行其性无常。余如前说。云何观察乘事变异无常之性。谓于一时见种种乘新妙庄严甚可爱乐。复于一时见彼朽故离诸严饰。见此事已便作是念。如是诸行其性无常。余如前说。云何观察衣事变异无常之性。谓由观见种种衣服。一时新成一时故坏。一时鲜洁一时垢腻。见此事已便作是念。如是诸行其性无常余如前说云何观察严具变异无常之性。谓由观见诸庄严具。一时未成一时已成。一时坚固一时破坏。见此事已便作是念。如是诸行其性无常。余如前说。云何观察舞歌乐事所有变异无常之性。谓由观见舞歌伎乐现在。种种音曲差别异起异谢。见此事已便作是念。如是诸行其性无常。余如前说。云何观察香鬘涂饰所有变异无常之性。谓先观见种种香鬘鲜荣芬馥。后时见彼萎悴臭烂。见此事已便作是念。如是诸行其性无常。余如前说。云何观察资具变异无常之性。谓观见彼未造已造成满破坏前后变异。见此事已便作是念。如是诸行其性无常。余如前说。云何观察光明变异无常之性。谓由观见种种明闇生灭变异见此事已便作是念。如是诸行其性无常。余如前说。云何观察男女承奉所有变异无常之性。谓观见彼或衰或盛不久坚住。见此事已便作是念。如是诸行其性无常。余如前说。如是一切外事诸行。前之六种是所摄受事。后之十种是身资具事。以要言之。当知其性皆是无常。何以故。形相转变现可得故。由如是等如前所说。诸变异行现见增上作意力故。于内外事如其所应。以变异行观察一切是无常性。由是因缘于诸变异无常之性。现见不背不由他缘非他所引。随念观察审谛决定。即由如是所说因缘。说名现见增上作意。即由如是现见增上作意力故。观察变异无常性已。彼诸色行虽复现有。刹那生灭灭坏无常。而微细故非现所得故。依现见增上作意应正比度。云何比度。谓彼诸行要有刹那生灭。灭坏方可得。有前后变异。非如是住得有变异。是故诸行。必定应有刹那生灭。彼彼众缘和合有故。如是如是诸行得生。生已不待灭坏因缘自然灭坏。如是所有变异因缘。能令诸行转变生起。此是变异生起因缘。非是诸行灭坏因缘。所以者何。由彼诸行与世现见灭坏因缘。俱灭坏已后不相似生起可得。非彼一切全不生起。或有诸行既灭坏已一切生起全不可得。如煎水等。最后一切皆悉消尽。灾火焚烧器世间。已都无灰烬。乃至余影亦不可得。彼亦因缘。后后展转渐减尽故。最后一切都无所有。不由其火作如是事。是故变异由前所说八种因缘。令变生起自然灭坏。如是比度作意力故。由灭坏行于彼诸行刹那生灭灭坏无常而得决定。于如是事得决定已。复于他世非所现见。诸行生起。应正比度。云何比度。谓诸有情现有种种差别可得。或好形色或恶形色。或上族姓或下族姓。或富族姓或贫族姓。或大宗叶或小宗叶。或长寿命或短寿命。言或威肃或不威肃。或性利根或性钝根。如是一切有情差别。定由作业有其差别方可成立。非无作业如是有情色类差别。定由先世善不善业造作增长种种品类。由彼因缘于今自体差别生起。不应自在变化为因。何以故。若说自在变化为因能生诸行。此所生行。为唯用彼自在为缘。为待余缘。如是自在方能变化。若唯用彼自在为缘。是则诸行与彼自在俱应本有。何须更生。若言先有自在体性然后行生。是则诸行不唯自在为缘生起。若言自在随其所欲。功用祈愿方能造化。是故亦用欲为因缘。非唯自在。若尔此欲为有因耶。为无因耶。若言有因。即用自在以为因者。此则同前所说过失。不应道理。若言此欲更有余因。是则如欲功用祈愿离自在外余法为因。如是亦应一切诸行皆用余法以为其因。何须妄计无用自在。由如是等比度增上作意力故。于有他世诸行生起获得决定。如是略由三种增上作意力故。寻思观察内外诸行是无常性。谓净信增上作意力故。现见增上作意力故。比度增上作意力故。于前所举能随顺修无常五行已。辩变异灭坏二行。云何复由别离行故观无常性。谓依内外二种别离。应知诸行是无常性。依内别离无常性者。谓如有一先为他主。非奴非使能自受用。能驱役他作诸事业彼于后时退失主性非奴使性。转得他奴及所使性。于主性等名为别离无常之性。依外别离无常性者。谓现前有资生财宝先未变异。未为别离无常灭坏。后时为王盗贼非爱及共财等之所劫夺。或由恶作加行失坏。或方便求而不能得。如是等类应知。是名由别离行知无常性。云何复由法性行故观无常性。谓即所有变异无常。灭坏无常。别离无常。于现在世犹未合会。于未来世当有法性。如实通达如是诸行。于未来世当有法性。如是等类名为通达法性无常。云何复由合会行故观无常性。谓即如是变异无常。灭坏无常。别离无常。于现在世合会现前。如实通达如是诸行。于现在世现前合会。如是等类名为通达合会无常。彼于如是内外诸行五无常性。由五种行如其所应作意修习。多修习故获得决定。如是由证成道理及修增上故。于无常行得决定已。从此无间趣入苦行。作是思惟。如是诸行皆是无常。是无常故决定应是有生法性。如是诸行既是生法即有生苦。既有生苦。当知亦有老病死苦。怨憎会苦。爱别离苦。求不得苦。如是且由不可爱行趣入苦行。如是复于有漏有取能顺乐受一切蕴中。由结缚行趣入苦行。所以者何。以于爱等结处生爱等结。于贪等缚处生贪等缚。便能招集生老病死愁悲忧苦一切扰恼纯大苦蕴。如是复于有漏有取顺非苦乐一切蕴中。由不安隐行趣入苦行。所以者何。有漏有取顺非苦乐一切诸蕴粗重俱行苦乐种子之所随逐苦苦坏苦不解脱故。一切皆是无常灭法。如是行者。于能随顺乐受诸行及乐受中。由结缚行趣入坏苦。于能随顺苦受诸行及苦受中。由不可爱行趣入苦苦。于能随顺不苦不乐受诸行。及不苦不乐受中。由不安隐行趣入行苦。如是由结缚行不可爱行不安隐行增上力故。于三受中作如是说。诸所有受皆悉是苦。如是名为由无常行作意。为先趣入苦行。复作是念。我于今者唯有诸根唯有境界。唯有从彼所生诸受。唯有其心唯有假名我我所法。唯有其见唯有假立。此中可得。除此更无若过若增。如是唯有诸蕴可得。于诸蕴中无有常恒坚住主宰。或说为我或说有情。或复于此说为生者老者病者及以死者。或复说彼能造诸业能受种种果及异熟。由是诸行皆悉是空无有我故。如是名为由无所得行趣入空行。复作是念。所有诸行与其自相。及无常相苦相相应。彼亦一切从缘生故不得自在。不自在故皆非是我。如是名为由不自在行入无我行。如是行者。以其十行摄于四行。复以四行了苦谛相。谓无常行五行所摄。一变异行。二灭坏行。三别离行。四法性行。五合会行。苦行三行所摄。一结缚行。二不可爱行。三不安隐行。空行一行所摄。谓无所得行。无我行一行所摄。谓不自在行。彼由十行悟入四行。复由四行于苦谛相正觉了已。次复观察如是苦谛。何因何集何起何缘。由断彼故苦亦随断。如是即以集谛四行了集谛相。谓了知爱能引苦故。说名为因。既引苦已复能招集令其生故。说名为集。既生苦已令彼起故。说名为起。复于当来诸苦种子能摄受。故次第招引诸苦集。故说名为缘。复有差别。谓了知爱是取因故。复能招集。即以其取为因有故。复能生起有为上首。当来生故。又能引发以生为缘老病死等诸苦法故。随其所应当知说名因集起缘复有差别。谓正了知烦恼随眠附属所依爱随眠等。是当来世后有生因。又正了知彼所生缠随其所应是集起缘。谓后有爱能招引故。即是其集此后有爱。复能发起喜贪俱行爱。此喜贪俱行爱复与多种彼彼喜爱为缘。如是依止爱随眠等及三种缠。能生后有及能发起诸爱差别。是故说名因集起缘。如是行者。由四种行了集谛相。于集谛相正觉了已。复正觉了如是集谛无余息灭故。名为灭。一切苦谛无余寂静。故名为静。即此灭静是第一故。是最胜故。是无上故。说名为妙。是常住故。永出离故。说名为离。如是行者。由四种行了灭谛相。于灭谛相正觉了已。复正觉了真对治道于所知境。能通寻求义故。能实寻求义故。由于四门随转义故。一向能趣涅槃义故。所以说名道如行出。如是行者。由四种行了道谛相。如是名为于四圣谛。自内现观了相作意。彼既如是于其自内现见诸蕴。依诸谛理无倒寻思正观察已。复于所余不同分界不现见蕴。比度观察。谓彼所有有为有漏。遍一切处遍一切种。于一切时皆有如是法。皆堕如是理。皆有如是性。彼所有灭皆永寂静常住安乐。彼所有道皆能永断究竟出离。当知此中若于现见诸蕴谛智。若于所余不同分界不现见境比度谛智。即是能生法智类智种子依处。又即如是了相作意。当知犹为闻思间杂。若观行者于诸谛中。

如是数数正观察故。由十六行于四圣谛证成道理已得决定。复于诸谛尽所有性。如所有性超过闻思间杂。作意一向发起修行胜解。此则名为胜解作意。如是作意。唯缘谛境一向在定。于此修习多修习故。于苦集二谛境中得无边际智。由此智故了知无常。发起无常无边际胜解。如是了知苦等。发起苦无边际胜解。空无我无边际胜解。恶行无边际胜解。往恶趣无边际胜解。兴衰无边际胜解。及老病死愁悲忧苦一切扰恼无边际胜解。此中无边际者。谓生死流转。如是诸法无边无际。乃至生死流转不绝。常有如是所说诸法。唯有生死无余息灭此可息灭。更无有余息灭方便。即于如是诸有诸趣死生法中。以无愿行。无所依行。深厌逆行。发起胜解。精勤修习胜解作意。复于如是诸有诸生增上意乐深心厌怖。及于涅槃随起一行深心愿乐。彼于长夜其心爱乐世间色声香味触等。为诸色声香味触等滋长积集。由是因缘虽于涅槃深心愿乐。而复于彼不能趣入。不能证净。不能安住不能胜解。其心退转于寂静界未能深心生希仰故。有疑虑故其心数数厌离惊怖。虽于一切苦集二谛数数深心厌离惊怖及于涅槃数数发起深心愿乐。然犹未能深心趣入。何以故。以彼犹有能障现观粗品我慢。随入作意间无间转作是思惟。我于生死曾久流转。我于生死当复流转。我于涅槃当能趣入。我为涅槃修诸善法。我能观苦真实是苦。我能观集真实是集我能观灭真实是灭。我能观道真实是道。我能观空真实是空。我观无愿真是无愿。我观无相真是无相。如是诸法是我所有。由是因缘虽于涅槃深心愿乐。然心于彼不能趣入。彼既了知如是我慢是障碍已。便能速疾以慧通达。弃舍任运随转作意。制伏一切外所知境。趣入作意随作意行。专精无间观察圣谛。随所生起心谢灭时。无间生心作意观察。方便流注无有间断。彼既如是以心缘心专精无替。便能令彼随入作意。障碍现观粗品我慢无容得生。如是勤修瑜伽行者。观心相续。展转别异。新新而生或增或减。暂时而有率尔现前。前后变易是无常性。观心相续入取蕴摄。是为苦性观心相续。离第二法是为空性观心相续。从众缘生不得自在是无我性。如是名为悟入苦谛。次复观察此心相续。以爱为因以爱为集。以爱为起以爱为缘。如是名为悟入集谛。次复观察此心相续。所有择灭是永灭性。是永静性是永妙性是永离性。如是名为悟入灭谛。次复观察此心相续。究竟对治趣灭之道。是真道性是真如性。是真行性是真出性。如是名为悟入道谛。如是先来未善观察。今善作意方便观察。以微妙慧于四圣谛能正悟入。即于此慧亲近修习多修习故。能缘所缘平等平等正智得生。由此生故能断障碍爱乐涅槃所有粗品现行我慢。又于涅槃深心愿乐。速能趣入心无退转离诸怖畏。摄受增上意乐适悦。如是行者。于诸圣谛。下忍所摄。能缘所缘平等平等智生。是名为暖。中忍所摄。能缘所缘平等。平等智生。是名为顶。上忍所摄。能缘所缘平等。平等智生名谛顺忍。彼既如是断能障碍粗品我慢。及于涅槃摄受增上意乐适悦。便能舍离后后观心所有加行。住无加行无分别心。彼于尔时其心似灭而非实灭。似无所缘而非无缘。又于尔时其心寂静虽似远离而非远离。又于尔时非美睡眠之所覆盖。唯有分明无高无下奢摩他行。复有一类闇昧愚痴。于美睡眠之所覆盖其心似灭非实灭中。起增上慢。谓为现观。此不如是。既得如是趣现观心。不久当入正性离生。即于如是寂静心位最后一念无分别心。

从此无间于前所观诸圣谛理起内作意。此即名为世第一法。从此已后出世心生非世间心。此是世间诸行最后界畔边际。是故名为世第一法

从此无间于前所观诸圣谛理起内作意。作意无间随前次第所观诸谛。若是现见若非现见诸圣谛中。如其次第有无分别决定智现见智生。由此生故。三界所系见道所断附属所依诸烦恼品一切粗重皆悉永断。此永断故。若先已离欲界贪者。彼于今时既入如是谛现观已得不还果。彼与前说离欲者相。当知无异。然于此中少有差别。谓当受化生。即于彼处当般涅槃不复还来生此世间。若先倍离欲界贪者。彼于今时既入如是谛现观已得一来果。若先未离欲界贪者。彼于今时既入如是谛现观已。粗重永息得预流果。由能知智与所知境和合无乖现前观察故名现观。如刹帝利与刹帝利和合无乖现前观察名为现观。婆罗门等当知亦尔。此亦成就众多相状。谓证如是谛现观故获得四智。谓于一切若行若住诸作意中善推求故。得唯法智得非断智得非常智。得缘生行如幻事智。若行境界由失念故。虽起猛利诸烦恼缠。暂作意时速疾除遣。又能毕竟不堕恶趣。终不故思违越所学。乃至傍生亦不害命。终不退转弃舍所学。不复能造五无间业。定知苦乐非自所作非他所作。非自他作非非自他无因而生。终不求请外道为师。亦不于彼起福田想。于他沙门婆罗门等终不观瞻口及颜面。唯自见法得法。知法证法源底越度疑惑。不由他缘。于大师教非他所引。于诸法中得无所畏。终不妄计世瑞吉祥以为清净。终不更受第八有生。具足成就四种证净。如是行者。乃至世第一法已前名胜解作意。于诸圣谛现观已后。乃至永断见道所断一切烦恼名远离作意

复从此后为欲进断修所断惑。如所得道更数修习。永断欲界上品中品诸烦恼已得一来果。如预流果所有诸相。今于此中当知亦尔。然少差别。谓若行境界。于能随顺上品猛利烦恼缠处。由失念故暂起微劣诸烦恼缠。寻能作意速疾除遣。唯一度来生此世间。便能究竟作苦边际。得不还果及不还相。如前已说。当知此中由观察作意。于一切修道数数观察已断未断。如所得道而正修习。又于此中云何名修自性。云何名修业。云何名修品类差别。谓由定地作意。于世出世善有为法修习增长。无间所作殷重所作。令心相续会彼体性。如是名为修之自性。当知修业略有八种。一有一类法由修故得。二有一类法由修故习。三有一类法由修故净。四有一类法由修故遣。五有一类法由修故知。六有一类法由修故断。七有一类法由修故证。八有一类法由修故远。若先未得殊胜善法。修习令得名修故得。若先已得令转现前。名修故习。若先已得未令现前。但由修习彼种类法。当令现前。令转清净鲜白生起。名修故净。若有失念染法现行。修善法力令不忍受断除变吐。名修故遣。若未生起所应断法。修善法力了知如病深心厌坏。了知如痈如箭障碍无常苦空及以无我深心厌坏。名修故知。如是知已数修习。故无间道生断诸烦恼。名修故断。烦恼断已证得解脱。名修故证。如如进趣上地善法。如是如是令其下地已断。诸法转成远分乃至究竟。名修故远。当知是名八种修业。应知此修品类差别有十一种。一奢摩他修。二毗钵舍那修。三世间道修。四出世道修。五下品道修。六中品道修。七上品道修。八加行道修。九无间道修。十解脱道修。十一胜进道修。奢摩他修者。谓九种行令心安住。如前已说。毗钵舍那修亦如前说。世间道修者。谓于诸下地见粗相故。于诸上地见静相故。乃至能趣无所有处一切离欲。出世道修者。谓正思惟苦真是苦。集真是集。灭真是灭。道真是道。由正见等无漏圣道。乃至能趣非想非非想处一切离欲。下品道修者。谓由此故能断最粗上品烦恼。中品道修者。谓由此故能断所有中品烦恼。上品道修者。谓由此故能断所有最后所断下品烦恼。加行道修者。谓由此故为断烦恼发起加行。无间道修者。谓由此故正断烦恼。解脱道修者。谓由此故或断无间证得解脱。胜进道修者。谓由此故从是已后修胜善法。乃至未起余地烦恼能治加行。或复未起趣究竟位。当知是名十一种修品类差别。如是于修勤修习者。于时时间应正观察所有烦恼已断未断。

于时时间于可厌法深心厌离。于时时间于可欣法深心欣慕。如是名为摄乐作意。

彼即于此摄乐作意。亲近修习多修习故。有能无余永断修道所断烦恼。最后学位喻如金刚三摩地生。由此生故便能永断修道所断一切烦恼。问何因缘故此三摩地名金刚喻。答譬如金刚望余一切末尼真珠琉璃螺贝璧玉珊瑚等诸珍宝。最为坚固。能穿能坏所余宝物。非余宝物所能穿坏。如是此三摩地于诸有学三摩地中最上最胜最为坚固。能坏一切所有烦恼。非上烦恼所能蔽伏。是故此三摩地名金刚喻。

从此金刚喻三摩地。无间永害一切烦恼品粗重种子。其心于彼究竟解脱。证得毕竟种姓清净。于诸烦恼究竟尽中发起尽智。由因尽故当来苦果毕竟不生。即于此中起无生智。彼于尔时成阿罗汉诸漏已尽。所作已办无复所作。证得自义尽诸有结。已正奉行如来圣教心。善解脱。已具成就十无学法。谓无学正见正思惟乃至无学正解脱正智。于诸住中及作意中。能随己心自在而转。随所乐住或圣或天或梵住中即能安住。随乐思惟所有正法能引世间或出世间诸善义利即能思惟。言圣住者。谓空住无愿住无相住灭尽定住。言天住者。谓诸静虑诸无色住。言梵住者。谓慈住悲住喜住舍住。又于尔时至极究竟毕竟无垢毕竟。证得梵行边际离诸关键。已出深坑已度深堑。已能摧伏彼伊师迦。是为真圣。摧灭高幢已断五支成就六支。一向守护四所依止。最极远离。独一谛实弃舍希求。无浊思惟身行猗息。心善解脱慧善解脱。独一无侣正行已立。名已亲近无上丈夫具足成就六恒住法。谓眼见色已无喜无忧。安住上舍正念正知。如是耳闻声已鼻嗅香已舌尝味已身觉触已意了法已。无喜无忧安住上舍正念正知。彼于尔时领受贪欲无余永尽。领受嗔恚无余永尽。领受愚痴无余永尽。彼贪嗔痴皆永尽故。不造诸恶习近诸善。其心犹如虚空净水如妙香檀。普为一切天帝天王恭敬供养。住有余依般涅槃界。度生死海已到彼岸。亦名任持最后有身。先业烦恼所引诸蕴自然灭。故余取无故不相续故。于无余依般涅槃界而般涅槃。此中都无般涅槃者。如于生死无流转者。唯有众苦永灭寂静清凉灭没。唯有此处最为寂静。所谓弃舍一切所依爱。尽离欲永灭涅槃。当知此中有如是相。阿罗汉苾刍诸漏永尽。不能习近五种处所。一者不能故思杀害诸众生命。二者不能不与而取。三者不能行非梵行习淫欲法。四者不能知而妄语。五者不能贮畜受用诸欲资具。如是不能妄计苦乐自作他作自他俱作非自他作无因而生。又亦不能怖畏一切不应记事。又亦不能于云雷电霹雳灾雹及见种种怖畏事已深生惊怖。当知此中金刚喻定所摄作意。名加行究竟作意。最上阿罗汉果所摄作意。名加行究竟果作意。由如是等多种作意。依出世道证得究竟

如是一切名声闻地。此是一切正等觉者所说。一切声闻相应教法根本。犹如一切名句文身。是所制造文章咒术异论根本

    本地分中独觉地第十四

如是已说声闻地。云何独觉地。当知此地有五种相。一者种姓。二者道三者习。四者住。五者行

云何独觉种姓。谓由三相应正了知。一者本性独觉先未证得彼菩提时有薄尘种姓。由此因缘于愦闹处心不爱乐。于寂静处深心爱乐。二者本性独觉先未证得彼菩提时有薄悲种姓。由是因缘于说正法利有情事心不爱乐。于少思务寂静住中深心爱乐。三者本性独觉先未证得彼菩提时有中根种姓。是慢行类。由是因缘深心希愿无师无敌而证菩提

云何独觉道。谓由三相应正了知。谓有一类安住独觉种姓。经于百劫值佛出世。亲近承事成熟相续。专心求证独觉菩提。于蕴善巧于处善巧。于界善巧于缘起善巧。于处非处善巧于谛善巧。勤修学故。于当来世速能证得独觉菩提。如是名为初独觉道。复有一类。值佛出世亲近善士。听闻正法如理作意。于先所未起顺决择分善根引发令起。谓暖顶忍而无力能即于此生证法现观得沙门果。复修蕴善巧修处善巧。修界善巧修缘起善巧。修处非处善巧修谛善巧故。于当来世能证法现观得沙门果。是名第二独觉道。复有一类。值佛出世亲近善士。听闻正法如理作意。证法现观得沙门果。而无力能于一切种至极究竟毕竟离垢毕竟证得梵行边际阿罗汉果。复修蕴善巧修处善巧。修界善巧修缘起善巧。修处非处善巧修谛善巧故。依出世道于当来世。至极究竟毕竟离垢毕竟证得梵行边际阿罗汉果。是名第三独觉道。

云何独觉习。谓有一类依初独觉道。满足百劫修集资粮。过百劫已出无佛世。无师自能修三十七菩提分法。证法现观得独觉菩提果。永断一切烦恼成阿罗汉。复有一类或依第二或依第三独觉道。由彼因缘出无佛世。无师自能修三十七菩提分法。或证法现观乃至得阿罗汉果。或得沙门果。至极究竟毕竟离垢毕竟证得梵行边际。证得最上阿罗汉果。当知此中由初习故成独觉者名麟角喻。由第二第三习故成独胜者名部行喻。

云何独觉住。谓初所习鳞角喻独觉。乐处孤林乐独居住。乐甚深胜解。乐观察甚深缘起道理。乐安住最极空无愿无相作意。若第二第三所习部行喻独胜。不必一向乐处孤林乐独居住。亦乐部众共相杂住。所余住相如麟角喻。

云何独觉行。谓一切独觉随依彼彼村邑聚落而住。善护其身善守诸根善住正念。随入彼彼村邑聚落或为乞食。或济度他下劣愚昧以身济度。不以语言。何以故。唯现身相为彼说法不发言。故示现种种神通境界。乃至为令心诽谤者生归向故。又彼一切应知本来一向趣寂

瑜伽师地论卷第三十四瑜伽师地论卷第三十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处种姓品第一

如是已说独觉地。云何菩萨地。嗢拖南曰

  初持次相分　　增上意乐住
  生摄受地行　　建立最为后

有十法具摄大乘菩萨道及果。何等为十。一者持。二者相。三者分。四者增上意乐。五者住。六者生。七者摄受。八者地。九者行。十者建立。

云何名持。谓诸菩萨自乘种姓最初发心。及以一切菩提分法。是名为持。何以故。以诸菩萨自乘种姓。为所依止故为建立故。有所堪任有大势力。能证无上正等菩提。是故说彼自乘种姓。为诸菩萨堪任性持。以诸菩萨最初发心。为所依止为建立故。于施戒忍精进静虑慧。于六波罗蜜多。于福德资粮智慧资粮。于一切菩提分法。能勤修学。是故说彼最初发心。为诸菩萨行加行持。以诸菩萨一切所行菩提分法。为所依止为建立故。圆满无上正等菩提。是故说彼一切所行菩提分法。为所圆满大菩提持。住无种姓补特伽罗无种姓故。虽有发心及行加行为所依止。定不堪任圆满无上正等菩提。由此道理虽未发心未修菩萨所行加行。若有种姓当知望彼而得名持。又住种姓补特伽罗。若不发心不修菩萨所行加行虽有堪任而不速证无上菩提。与此相违当知速证。又此种姓已说名持。亦名为助亦名为因。亦名为依亦名阶级。亦名前导亦名舍宅。如说种姓最初发心。所行加行应知亦尔

云何种姓。谓略有二种。一本性住种姓。二习所成种姓。本性住种姓者。谓诸菩萨六处殊胜有如是相。从无始世展转传来法尔所得。是名本性住种姓习所成种姓者。谓先串习善根所得是名习所成种姓。此中义意二种皆取。又此种姓亦名种子亦名为界亦名为性。又此种姓未习成果说名为细。未有果故已习成果说名为粗。与果俱故。若诸菩萨成就种姓。尚过一切声闻独觉。何况其余一切有情。当知种姓无上最胜。何以故。略有二种净。一烦恼障净。二所知障净。一切声闻独觉种姓。唯能当证烦恼障净。不能当证所知障净。菩萨种姓亦能当证烦恼障净。亦能当证所知障净。是故说言望彼一切无上最胜。复由四事。当知菩萨胜于一切声闻独觉。何等为四。一者根胜。二者行胜。三者善巧胜。四者果胜。言根胜者。谓诸菩萨本性利根独觉中根声闻软根。是名根胜。言行胜者。谓诸菩萨亦能自利亦能利他。利益安乐无量众生。哀愍世间令诸天人获得胜义利益安乐。声闻独觉唯行自利。是名行胜善巧胜者。声闻独觉于蕴界处缘起处非处中能修善巧。菩萨于此及于其余一切明处能修善巧。是名善巧胜。言果胜者。声闻能证声闻菩提。独觉能证独觉菩提。菩萨能证阿耨多罗三藐三菩提。是名果胜

又诸菩萨有六波罗蜜多种姓相。由此相故令他了知真是菩萨。谓施波罗蜜多种姓相。戒忍精进静虑慧波罗蜜多种姓相。云何菩萨施波罗蜜多种姓相。谓诸菩萨本性乐施于诸现有堪所施物。恒常无间性能于他平等分布。心喜施与意无追悔。施物虽少而能均布。惠施广大而非狭小无所惠施深怀惭耻。常好为他赞施劝施。见能施者心怀喜悦。于诸尊重耆宿福田应供养者。从座而起恭敬奉施。于其彼彼此世他世有情无罪利益事中。若请不请如理为说。若诸有请怖于王贼及水火等。施以无畏。能于种种常极怖中随力济拔。受他寄物未尝差违。若负他债终不抵诳。于共财所亦无欺罔。于其种种末尼真珠琉璃螺贝壁玉珊瑚金银等宝资生具中心迷倒者。能正开悟尚不令他欺罔于彼。况当自为。其性好乐广大财位。于彼一切广大资财心好受用。乐大事业非狭小门。于诸世间酒色博戏歌舞倡伎种种变现耽着事中。速疾厌舍深生惭愧。得大财宝尚不贪着。何况小利。如是等类当知名为菩萨施波罗蜜多种姓相。云何菩萨戒波罗蜜多种姓相。谓诸菩萨本性成就软品不善。身语意业不极暴恶。于诸有情不极损恼。虽作恶业速疾能悔。常行耻愧不生欢喜。不以刀杖手块等事恼害有情。于诸众生性常慈爱。于所应敬时起奉迎。合掌问讯现前礼拜修和敬业。所作机捷非为愚钝。善顺他心。常先含笑舒颜平视。远离颦蹙先言问讯。于恩有情。知恩知报。于来求者常行质直。不以谄诳而推谢之。如法求财不以非法不以卒暴。性常喜乐修诸福业。于他修福尚能奖助。况不自为。若见若闻他所受苦。所谓杀缚割截捶打诃毁迫胁。于是等苦过于自受。重于法受。及重后世。于少罪中尚深见怖。何况多罪。于他种种所应作事。所谓商农放牧事王书印算数。善和诤讼。追求财宝。守护储积。方便出息。及以舍施。婚姻集会。于是一切如法事中。悉与同事。于他种种斗讼诤竞。或余所有互相恼害。能令自他无义无益受诸苦恼。如是一切非法事中不与同事。善能制止所不应作谓十种恶不善业道。不违他命善顺于他同忍同戒。于他事业随彼所欲。废己所作而为成办。其心温润其心纯净。恚心害心不久相续。随生随舍起贤善心。尊重实语不诳惑他。不离他亲。亦不好乐不轻尔说无义无利不相应语言。常柔软无有粗犷。于己僮仆尚无苦言。况于他所敬爱有德。如实赞彼。如是等类当知名为菩萨戒波罗蜜多种姓相。云何菩萨忍波罗蜜多种姓相。谓诸菩萨性。于他所遭不饶益。无恚害心亦不反报。若他谏谢速能纳受。终不结恨不久怀怨。如是等类当知名为菩萨忍波罗蜜多种姓相。云何菩萨精进波罗蜜多种姓相。谓诸菩萨性。自翘勤夙兴晚寐不深耽乐睡眠倚乐。于所作事勇决乐为不生懈怠。思择方便要令究竟。凡所施为一切事业坚固决定。若未皆作未皆究竟。终不中间懈废退屈。于诸广大第一义中心无怯弱。不自轻蔑发勇猛心。我今有力能证于彼。或入大众或与他人共相击论。或余种种难行事业皆无畏惮能引义利。大事务中尚无深倦。何况小事。如是等类当知名为菩萨精进波罗蜜多种姓相。云何菩萨静虑波罗蜜多种姓相。谓诸菩萨性。于法义能审思惟无多散乱。若见若闻阿练若处山岩林薮边际。卧具人不狎习离恶众生。随顺宴默。便生是念。是处安乐出离远离。常于出离及远离所深生爱慕。性薄烦恼诸盖轻微粗重羸弱至远离处思量自义。心不极为诸恶寻思之所缠扰。于其怨品尚能速疾安住慈心。况于亲品及中庸品。若见若闻有苦众生为种种苦之所逼恼。起大悲心。于彼众生随能随力。方便拔济令离众苦。于诸众生性自乐施利益安乐。亲属衰亡丧失财宝杀缚禁闭。及驱摈等诸苦难中悉能安忍。其性聪敏于法能受能持能思成就念力。于久所作所说事中。能自记忆亦令他忆。如是等类当知名为菩萨静虑波罗蜜多种姓相。云何菩萨慧波罗蜜多种姓相。谓诸菩萨成俱生慧。能入一切明处境界。性不顽钝性不微昧性不愚痴。遍于彼彼离放逸处有力思择。如是等类当知名为菩萨慧波罗蜜多种姓相。应知是名能比菩萨种姓粗相。决定实义唯佛世尊究竟现见

由诸菩萨所有种姓性与如是功德相应。成就贤善诸白净法。是故能与难得最胜不可思议无动无上如来果位。为证得因应正道理。

余不应理种姓菩萨。乃至未为白法相违四随烦恼。若具不具之所染污性与如是白法相应。若被染污如是白法皆不显现。或于一时生诸恶趣。

菩萨虽生诸恶趣中。由种姓力应知与余生恶趣者有大差别。谓彼菩萨久处生死。或时时间生诸恶趣。虽暂生彼速能解脱。虽在恶趣而不受于猛利苦受。如余有情生恶趣者。虽触微苦而能发生增上厌离。于生恶趣受苦有情深起悲心。如是等事皆由种姓。佛大悲因之所熏发。是故当知种姓菩萨离生恶趣。然与其余生恶趣者有大差别。

何等名为种姓菩萨白法相违四随烦恼。谓放逸者由先串习诸烦恼故。性成猛利长时烦恼。是名第一随烦恼姓。又愚痴者不善巧者依附恶友。是名第二随烦恼性。又为尊长夫主王贼及怨敌等所拘逼者。不得自在其心迷乱。是名第三随烦恼性。又资生具有匮乏者顾恋身命。是名第四随烦恼性

又诸菩萨虽具种姓。由四因缘不能速证阿耨多罗三藐三菩提。何等为四。谓诸菩萨先未值遇诸佛菩萨真善知识为说菩提无颠倒道。如是名为第一因缘。又诸菩萨虽遇善友为说正道。而颠倒执于诸菩萨正所学中颠倒修学。如是名为第二因缘。又诸菩萨虽遇善友为说正道。于诸菩萨正所学中无倒修学。而于加行方便慢缓懈怠懒惰。不成勇猛炽然精进。如是名为第三因缘。又诸菩萨虽遇善友为说正道。于诸菩萨正所学中无倒修学。亦于加行勇猛精进。然诸善根犹未成熟。菩提资粮未得圆满。未于长时积习所有菩提分法。如是名为第四因缘。如是菩萨虽有种姓。因缘阙故不能速证无上菩提。若具因缘便能速证。若无种姓补特伽罗。虽有一切一切一切种当知决定不证菩提

    本地分中菩萨地第十五初持瑜伽处发心品第二

复次菩萨最初发心于诸菩萨所有正愿。是初正愿普能摄受其余正愿。是故发心以初正愿为其自性。

又诸菩萨起正愿心求菩提时。发如是心说如是言。愿我决定当证无上正等菩提。能作有情一切义利。毕竟安处究竟涅槃及以如来广大智中。如是发心定自希求无上菩提。及求能作有情义利。是故发心以定希求为其行相。

又诸菩萨缘大菩提。及缘有情一切义利发心希求。非无所缘。是故发心以大菩提及诸有情一切义利为所缘境。

又诸菩萨最初发心。能摄一切菩提分法殊胜善根为上首。故是善极善是贤极贤是妙极妙。能违一切有情处所三业恶行。功德相应。

又诸菩萨最初发心所起正愿。于余一切希求世间出世间义妙善正愿。最为第一最为无上。如是应知最初发心有五种相。一者自性。二者行相。三者所缘。四者功德。五者最胜

又诸菩萨初发心已。即名趣入无上菩提预在大乘诸菩萨数。此据世俗言说道理。是故发心趣入所摄。

又诸菩萨要发心已。方能渐次速证无上正等菩提。非未发心。是故发心能为无上菩提根本

又诸菩萨悲愍一切有苦众生。为欲济拔发菩提心。是故发心是悲等流。

又诸菩萨以初发心为所依止为建立故。普于一切菩提分法及作一切有情义利菩萨学中。皆能修学。是故发心是诸菩萨学所依止。如是应知最初发心是趣入摄菩提根本大悲等流学所依止

又诸菩萨最初发心略有二种。一者永出。二不永出。言永出者。谓发心已毕竟随转无复退还。不永出者。谓发心已不极随转而复退还。此发心退复有二种。一者究竟。二不究竟。究竟退者。谓一退已不能复发求菩提心。不究竟者。谓退已后数数更发求菩提心。

当知菩萨最初发心由四种缘四因四力。云何四缘。谓善男子或善女人。若见诸佛及诸菩萨有不思议甚奇希有神变威力。或从可信闻如是事。既见闻已便作是念。无上菩提具大威德。令安住者及修行者成就如是所见所闻不可思议神变威力。由此见闻增上力故。于大菩提深生信解。因斯发起大菩提心。是名第一初发心缘。或有一类。虽不见闻如前所说神变威力。而闻宣说依于无上正等菩提微妙正法菩萨藏教。闻已深信。由闻正法及与深信增上力故。于如来智深生信解。为得如来微妙智故发菩提心。是名第二初发心缘。或有一类。虽不听闻如上正法。而见一切菩萨藏法将欲灭没。见是事已便作是念。菩萨藏法久住于世。能灭无量众生大苦。我应住持菩萨藏法发菩提心。为灭无量众生大苦。由为护持菩萨藏法增上力故。于如来智深生信解。为得如来微妙智故发菩提心。是名第三初发心缘。或有一类。虽不观见正法欲灭。而于末劫末世末时。见诸浊恶众生身心十随烦恼之所恼乱。谓多愚痴多无惭愧。多诸悭嫉多诸忧苦。多诸粗重多诸烦恼。多诸恶行多诸放逸。多诸懈怠多诸不信。见是事已便作是念。大浊恶世于今正起。诸随烦恼所恼乱时。能发下劣声闻独觉菩提心者尚难可得。况于无上正等菩提能发心者。我当应发大菩提心。令此恶世无量有情随学于我起菩提愿。由见末劫难得发心增上力故。于大菩提深生信解。因斯发起大菩提心。是名第四初发心缘。云何四因。谓诸菩萨种姓具足。是名第一初发心因。又诸菩萨赖佛菩萨善友摄受。是名第二初发心因。又诸菩萨于诸众生多起悲心。是名第三初发心因。又诸菩萨于极长时种种猛利无间无缺生死大苦难行苦行。无有怯畏。是名第四初发心因。若诸菩萨六处殊胜从无始世展转传来法尔所得。当知是名种姓具足。由四种相。当知菩萨善友具足。谓诸菩萨所遇善友。性不愚钝聪明黠慧不堕恶见。是名第一善友具足。又诸菩萨所遇善友。终不教人行于放逸。亦不授与诸放逸具。是名第二善友具足。又诸菩萨所遇善友。终不教人行于恶行。亦不授与诸恶行具。是名第三善友具足。又诸菩萨所遇善友。终不劝舍增上信欲受学精进方便功德。而复劝修下劣信欲受学精进方便功德。所谓终不劝舍大乘劝修二乘。劝舍修慧劝修思慧。劝舍思慧劝修闻慧。劝舍闻慧。劝修福业。劝舍尸罗劝修慧施。终不劝舍如是等类增上功德。而复劝修如是等类下劣功德。是名第四善友具足。由四因缘当知菩萨于诸众生多起悲心。谓诸菩萨虽有十方无量无边无苦世界。而生有苦诸世界中。于中恒有众苦可得非无众苦。或时见他随遭一苦触对逼切。或时见自随遭一苦触对逼切。或见自他随遭一苦触对逼切。或见二种俱遭长时种种猛利无间大苦触对逼切。然此菩萨依自种姓性自仁贤。依四境处虽不串习。而能发起下中上悲无有断绝。由四因缘当知菩萨于诸众生先起悲心。于极长时种种猛利无间无缺生死大苦难行苦行尚无怯畏。何况小苦。谓诸菩萨性自勇健堪忍有力。当知是名第一因缘。又诸菩萨性自聪敏能正思惟具思择力。当知是名第二因缘。又诸菩萨能于无上正等菩提成就上品清净信解。当知是名第三因缘。又诸菩萨于诸众生成就上品深心悲愍。当知是名第四因缘。云何四力。一者自力。二者他力。三者因力。四者加行力。谓诸菩萨由自功力能于无上正等菩提深生爱乐。是名第一初发心力。又诸菩萨由他功力能于无上正等菩提深生爱乐。是名第二初发心力。又诸菩萨宿习大乘相应善法。今暂得见诸佛菩萨。或暂得闻称扬赞美。即能速疾发菩提心。况睹神力闻其正法。是名第三初发心力。又诸菩萨于现法中亲近善士听闻正法谛思惟等。长时修习种种善法。由此加行发菩提心。是名第四初发心力。若诸菩萨依上总别四缘四因。或由自力或由因力。或总二力而发心者。当知此心坚固无动。或由他力或加行力。或总二力而发心者。当知此心不坚不固亦非无动

有四因缘能令菩萨退菩提心。何等为四。一种姓不具。二恶友所摄。三于诸众生悲心微薄。四于极长时种种猛利无间无缺生死大苦难行苦行。其心极生怯畏惊怖。如是四种心退因缘。与上发心四因相违。广辩其相如前应知

最初发心坚固菩萨略有二种不共世间甚希奇法。何等为二。一者摄诸众生皆为眷属。二者摄眷属过所不能染。摄眷属过有其二种。谓于眷属饶益损减染污违顺。如是二事菩萨皆无。最初发心坚固菩萨。于诸众生发起二种善胜意乐。一者利益意乐。二者安乐意乐。利益意乐者。谓欲从彼诸不善处拔济众生安置善处安乐意乐者。谓于贫匮无依无怙诸众生所离染污心。欲与种种饶益乐具。最初发心坚固菩萨有二加行。一意乐加行。二正行加行。意乐加行者。谓即利益安乐意乐日夜增长。正行加行者。谓于日夜能自成熟佛法加行。及于众生随能随力依前所说意乐加行。起与利益安乐加行。最初发心坚固菩萨有二增长大善法门。一者自利加行。能证无上正等菩提。二者利他加行。能脱一切有情众苦。如二增长大善法门。如是二种大善法聚二种无量大善法藏当知亦尔。最初发心坚固菩萨。由初发心求菩提故所摄善法。比余一切所摄善法。有二种胜。一者因胜。二者果胜。谓诸菩萨所摄善法。皆是无上正等菩提能证因。故所证无上正等菩提是此果。故比余一切声闻独觉所摄善法尚为殊胜。何况比余一切有情所摄善法。是故菩萨所摄善法。比余一切所摄善法。因果俱胜。最初发心坚固菩萨略有二种发心胜利。一者初发菩提心已。即是众生尊重福田。一切众生皆应供养。亦作一切众生父母。二者初发菩提心已。即能摄受无恼害福。由此菩萨成就如是无恼害福。得倍轮王护所守护。由得如是护所护故。若寝若寤若迷闷等一切魍魉药叉宅神人非人等不能娆害。又此菩萨转受余生。由如是福所摄持故少病无病。不为长时重病所触。于诸众生所作义利。能以身语勇猛而作。常为众生宣说正法。身无极倦念无忘失心无劳损。菩萨本性住种姓时。一切粗重性自微薄。既发心已所有粗重转复轻微。谓身粗重及心粗重。若余众生为欲息灭疾疫灾横。所用无验咒句明句。菩萨用之尚令有验。何况验者。成就增上柔和忍辱。能忍他恼不恼于他。见他相恼深生悲。恼忿嫉谄等诸随烦恼。皆能摧伏令势微薄。或暂现行速能除遣。随所居止国土城邑。于中所有恐怖斗诤饥馑过失非人所作疾疫灾横。未起不起设起寻灭。又此最初发心菩萨。或于一时生极恶趣那落迦中。多分于此那落迦趣速得解脱。受小苦受生大厌离。于彼受苦诸众生等起大悲心。如是一切皆因摄受无恼害福。最初发心坚固菩萨。由能摄受无恼害福。便得领受如是等类众多胜利

    本地分中菩萨地第十五初持瑜伽处自他利品第三之一

如是菩萨即发心已。云何修行诸菩萨行。略说菩萨若所学处若如是学若能修学。如是一切总摄为一名菩萨行

是诸菩萨于何处学。谓七处学。云何七处。嗢拖南曰

  自他利实义　　威力熟有情
  成熟自佛法　　第七菩提处

一自利处。二利他处。三真实义处。四威力处。五成熟有情处。六成熟自佛法处。七无上正等菩提处

云何自利利他处。谓自利利他略有十种。一纯自利利他。二共自利利他。三利益种类自利利他。四安乐种类自利利他。五因摄自利利他。六果摄自利利他。七此世自利利他。八他世自利利他。九毕竟自利利他。十不毕竟自利利他

云何菩萨纯共自利利他。谓诸菩萨于纯自利利他。应知应断违越不顺菩萨仪。故于其所余应勤修学不越随顺菩萨仪。故此中菩萨于纯自利应知应断者。谓为己乐求财受用。或为吝法于佛菩萨所说教法追访受持。或为生天受天快乐受持禁戒。发勤精进修习定慧。或求世间有染果报。为世财食恭敬供养诸佛制多。或贪利养。为利养故自说种种无有义利不实功德。诳惑于他招集利养。或欲贪他作己僮仆为驱使故。非法摄众不如正法。矫设方便拔济有情。令于他所免为僮仆。还自摄受为己僮仆。拔济有情令脱系缚。还自拘执成己事业。拔济有情令于他所解脱种种治罚怖畏。还自摄伏令惧于己。若诸菩萨耽着诸定现法乐住。弃舍思惟利众生事。当知此等名纯自利。菩萨于是纯自利行。应知应断。若诸菩萨或悲为首。或为回向无上菩提及为生天。于一切时修施忍等。当知是名自利共他。又除如前所说诸相。其余一切与彼相违所有自利诸菩萨行。当知皆名自利共他。菩萨于此应勤修学。此中菩萨于纯利他应知应断者。谓以邪见修行施等。以无因见及无果见毁犯尸罗。远离正行为他说法。若诸菩萨于诸静虑善巧回转。已超下地而更摄受下地白法。谓彼已能安住静虑。由悲愿力舍诸静虑。随其所乐还生欲界。又诸菩萨已得自在。于十方界种种变化。作诸众生种种义利。又诸牟尼自事已办。依止如来力无畏等所有一切不共佛法。遍于十方无量众生。能作无量大利益事。当知此等名纯利他。如是所说纯利他行。菩萨于前所说二种应知应断。于余所说纯利他行多应修学。又除如前所说诸相。其余一切与彼相违所有利他诸菩萨行。当知皆名利他共自。菩萨于此应勤修学

云何菩萨利益种类自利利他。略说应知有五种相。一无罪相。二摄受相。三此世相。四他世相。五寂灭相。若诸菩萨所有自能若少若多摄受善法增长善法。或复令他若少若多摄受善法增长善法。劝勉调伏安置建立。是名菩萨利益种类自利利他无有罪相。若诸菩萨能引所有若自若他无染污乐。或众具乐或住定乐。是名菩萨利益种类自利利他能摄受相。若诸菩萨自利利他。或有此世能为利益非于他世。或有他世能为利益非于此世。或有此世及于他世俱为利益。或有此世及于他世俱非利益。如是四种自利利他。于四法受随其次第如应。当知云何名为四种法受。或有法受现在受乐于当来世受苦异熟。或有法受现在受苦于当来世受乐异熟。或有法受现在受乐于当来世受乐异熟。或有法受现在受苦于当来世受苦异熟。此四广辩如经应知。是名菩萨利益种类自利利他此他世相。若诸菩萨所有涅槃。及得涅槃世出世间涅槃分法。是名菩萨利益种类自利利他寂灭略相。当知此相望余一切无上最胜

云何菩萨安乐种类自利利他。略说应知五乐所摄。何等五乐。一者因乐。二者受乐。三者苦对治乐。四者受断乐。五者无恼害乐。言因乐者。谓二乐品诸根境界。若此为因顺乐受触。若诸所有现法当来可爱果业。如是一切总摄为一名为因乐。除此更无若过若增。言受乐者。谓待苦息。由前所说因乐所摄三因缘故。有能摄益身心受生名为受乐。略说此乐复有二种。一者有漏。二者无漏。无漏乐者。学无学乐。有漏乐者。欲色无色三界系乐。又此一切三界系乐。随其所应六处别故有其六种。谓眼触所生乃至意触所生。如是六种复摄为二。一者身乐。二者心乐。五识相应名为身乐。意识相应名为心乐。若对治乐者。谓因寒热饥渴等事生起非一众多品类种种苦受。由能对治息除寒热饥渴等苦。即于如是苦息灭时生起乐觉。是则名为苦对治乐。灭想受定名受断乐。无恼害乐应知略说复有四种。一出离乐。二远离乐。三寂静乐。四三菩提乐。正信舍家趣于非家。解脱烦笼居家迫迮种种大苦。名出离乐断除诸欲恶不善法。证初静虑离生喜乐。名远离乐。第二静虑已上诸定寻伺止息。名寂静乐。一切烦恼毕竟离系。于所知事如实等觉。此乐名为三菩提乐。此中因乐是乐因故说名为乐。非自性故。此中受乐乐自性故说名为乐。非乐因故。苦对治乐息众苦故遣众苦故说名为乐。非乐因故。非自性故。其受断乐非乐因故非自性故。亦非息遣种种苦故。说名为乐。然依胜义。诸所有受皆悉是苦。住灭定时此胜义苦暂时寂静。故名为乐。无恼害乐所摄最后三菩提乐。由当来世此胜义苦永寂灭故。于现法中附在所依诸烦恼品一切粗重永寂灭故。说名为乐。诸余所有无恼害乐。于最后乐能随顺故。是彼分故。能引彼故。当知亦名无恼害乐

此中菩萨念与众生有利益品所有安乐。终不念与无利益品所有安乐。菩萨于此无利益品所有安乐。以无倒慧如实了知。劝诸众生令悉舍离。随力所能方便削夺。若苦所随有利益事。众生于此虽无乐欲。菩萨依止善权方便。设兼忧苦应授与之。若乐所随无利益事。众生于此虽有乐欲。菩萨依止善权方便。设兼喜乐应削夺之。何以故。当知如是善权方便。与兼忧苦有利益事。夺兼喜乐无利益事。令彼众生决定于后得安乐故。是故菩萨于诸众生若乐利益。当知义意即乐安乐。于诸众生若与利益。当知义意即与安乐。所以者何。利益如因安乐如果。是故当知于诸众生若与利益必与安乐。当知所有现法当来可爱果业所摄因乐苦对治乐。及受断乐无恼害乐。菩萨于此不应思量。于诸众生一向授与。以能饶益及无罪故。于彼受乐及根尘触所摄因乐。若能生染若性是染。有罪无益非所宜者。于诸众生不应授与。若不生染若性非染。无罪有益是所宜者。于诸众生即应授与。菩萨于此随自力能。亦应如是修行受学。当知是名菩萨利益安乐种类自利利他。除此无有若过若增

瑜伽师地论卷第三十五瑜伽师地论卷第三十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处自他利品第三之余

云何菩萨因摄果摄自利利他。略说应知三因三果。何等为三。一者异熟因异熟果。二者福因福果。三者智因智果。云何异熟。谓略有八。一者寿量具足。二者形色具足。三者族姓具足。四者自在具足。五者信言具足。六者大势具足。七者人性具足。八者大力具足。若诸菩萨长寿久住。是名菩萨寿量具足。形色端严众所乐见颜容殊妙。是名菩萨形色具足。生豪贵家。是名菩萨族姓具足。得大财位有大朋翼具大僚属。是名菩萨自在具足。众所信奉断讼取则。不行谄诳伪斗秤等。所受寄物终不差违。于诸有情言无虚妄。以是缘故凡有所说无不信受。是名菩萨信言具足。有大名称流闻世间。所谓具足勇健精进刚毅敏捷。审悉善戒。种种伎艺工巧业处展转妙解出过余人。由此因缘世所珍敬。为诸大众供养恭敬尊重赞叹。是名菩萨大势具足。具丈夫分成就男根。是名菩萨人性具足。为性少疾或全无病有大堪能。是名菩萨大力具足。云何异熟因。谓诸菩萨于诸众生不加伤害。远离一切伤害意乐。是名菩萨寿量具足因。惠施光明鲜净衣物。是名菩萨形色具足因。于诸众生舍离憍慢。是名菩萨族姓具足因。于资生具有所匮乏游行乞丐诸众生所。随欲惠施。是名菩萨自在具足因。所言诚谛亦不好习乖离粗犷不相应语。是名菩萨信言具足因。摄持当来种种功德。于自身中发弘誓愿。供养三宝及诸尊长。是名菩萨大势具足因。乐丈夫体厌妇女身深见过患。由二因缘施他人性。一者女人乐女身者。劝令厌离解脱女身。二者丈夫将失男根。方便护摄令不失坏。及说正法令得男身。是名菩萨人性具足因。于诸众生以身供事。随其所作如法事业皆往营助。如己力能以其正法不以卒暴。用能增长身心势力饼饭糜等种种饮食。施诸众生。是名菩萨大力具足因。当知前说八种异熟。以此所说八种为因。又此诸因略由三缘而得增长。能感圆满增上广大异熟令起。何等三缘。一心清净。二加行清净。三田清净。若于无上正等菩提清净意乐。用彼善根决定回向。猛利意乐纯厚广大净信修行。见同法者深生欢喜。日夜刹那于多随法随寻随伺。名心清净。即于其中长时数习。无间所作常委所作。他于此善若未受行赞美令受。若已受行赞美令喜。即于如是所有善根安处建立。名加行清净。当知略说能正发起如是加行。及正安住此加行果。名田清净。云何异熟果。谓诸菩萨寿量具足故。能于长时修习善品。依自他利积集增长无量善根。是名菩萨寿量具足果。若诸菩萨形色具足故。大众爱乐。众爱乐故咸共归仰。如是形色可爱乐故。一切大众咸归仰。故凡所发言无不听用。是名菩萨形色具足果。若诸菩萨族姓具足故。大众尊敬供养称赞。众所尊敬供养称赞故。于彼彼事劝诸众生。精勤修学无不敬用速疾修行无违无犯。是名菩萨族姓具足果。若诸菩萨自在具足故。能以布施摄诸众生速令成熟。是名菩萨自在具足果。若诸菩萨信言具足故。能以爱语利行同事。摄诸众生速令成熟。是名菩萨信言具足果。若诸菩萨大势具足故。于诸众生种种事业。皆能营助施布恩德。由此恩德感众生心。彼知恩故咸来归仰。所出言教速疾随转恭敬信用。是名菩萨大势具足果。若诸菩萨人性具足故成就男根。堪为一切胜功德器。能于一切所作事业。思择一切所知境界。都无所畏无碍而行。一切有情于一切时。皆来臻赴同共集会。屏处露处言论同止受用饮食皆无嫌碍。是名菩萨人性具足果。若诸菩萨大力具足故。于能引摄善法加行及能饶益有情加行。皆无厌倦。勇猛精进坚固精进速证通慧。是名菩萨大力具足果。若诸菩萨成就如是八种异熟。具八种果。能善饶益一切有情。随顺生起一切佛法。菩萨安住异熟果中。于诸有情种种众多利益事业自有力能。及善安处所化有情。彼于自事随顺而作。如是乃名随其所欲所作成办。若诸菩萨自有力能。不善安处所化有情。彼于自事不随顺作。如是于他所作利益。不名炽盛不名随顺。由是因缘不名能作他利益事。若诸菩萨自无力能。而善安处所化有情。彼于自事随顺而作。如是于他所作利益。不名炽盛不名随顺。由是因缘不名能作他利益事。是故菩萨要具二事。方于有情所作利益。名为炽盛名为随顺。由是因缘乃名能作他利益事。如是菩萨住异熟果。自能成熟一切佛法。亦能令他于三乘道随其所应速得成熟。又能令自速证无上正等菩提。亦能令他已成熟者速得解脱。由诸菩萨安住八种异熟果中。能使有情利益安乐。是故一切有情所处空无义利无始生死。菩萨处之能令不空有大义利

云何为福。云何为智。谓略说福即是三种波罗蜜多。一施波罗蜜多。二戒波罗蜜多。三忍波罗蜜多。智唯一种波罗蜜多。谓慧波罗蜜多。精进静虑波罗蜜多应知通二分。一者福分。二者智分。若依精进修行布施。受护净戒。及修慈等四种无量。如是等类所有精进名为福分。若依精进习闻思修所成三慧。修蕴善巧修界善巧。修处善巧修缘起善巧。修处非处善巧。修能观察。苦为真苦集为真集。灭为真灭道为真道。及于一切善不善法有罪无罪。若劣若胜。若黑若白。并广分别缘生法中。皆能如实思择观察。如是等类所有精进名为智分。若依静虑修习慈等四种无量。如是等类所有静虑名为福分。若依静虑能修如前精进中说蕴善巧等。如是等类所有静虑名为智分。如是福智略有六种。一一分别应知无量。云何福因。云何智因。略说应知福因智因总有三种。一者于福于智能得能住能增长欲。二者于福于智善能随顺无违背缘。三者于福于智先已串习。此中随顺无违背缘者。谓颠倒缘不现在前不会遇性。不颠倒缘正现在前正会遇性。若遇恶友倒说福智。或倒作意颠倒而取。名颠倒缘现前会遇。与此相违所有白品当知名为不颠倒缘现前会遇。若于福智能得能住。及能增长勤修习障远离不起。当知是名无违背缘。若诸菩萨于此三种福智因中。随有所阙当知不能生福生智。云何福果。云何智果。谓诸菩萨依止福故虽复长时流转生死。不为极苦之所损恼。又随所欲能摄众生为作义利。依止智故所摄受福是正非邪。又能起作种种无量善巧事业。乃至究竟当证无上正等菩提。如是略说福果智果。如其所应当知四种品类差别复有无量

应知此中若异熟体。若异熟因。若异熟果。如是一切皆依于福从福所生。福复依智从智所起。是故二种于证无上正等菩提虽俱是胜。而于其中福为最胜智为无上。若诸菩萨于福于智随阙一种。决定不能证于无上正等菩提。是名菩萨因摄果摄自利利他

云何菩萨现法后法自利利他。谓诸菩萨以如正理工巧业处士夫作用。积集财物。即于如是所集财物知量受用。又先所造可爱果业异熟果熟。于现法中受用彼果。又诸菩萨于诸静虑善回转者。为欲获得现法乐住。于现法中依此静虑。不为成立利他事故依此静虑。又诸如来现法涅槃所有世间。及出世间一切能得现法涅槃诸有为法。是名菩萨现法自利。如诸菩萨现法自利。如是菩萨所化有情。由此获得现法利益。当知即是现法利他。若于欲界能获他世财宝具足自体具足。及能当生静虑无色。若生静虑及无色中。能获他世财宝具足自体具足。若现法中与忧苦俱数数思择修习善因。是名菩萨修习后法自利利他。若诸菩萨于现法中与喜乐俱修习当来财宝具足自体具足所有善因。及非退分静虑无色一切等至。是名菩萨现法后法自利利他

云何毕竟及不毕竟自利利他。谓于欲界财宝具足自体具足。若因若果。及诸异生世间清净若因若果。是不毕竟自利利他。若诸烦恼一切永断。若诸所有八支圣道。若此为依获得一切世间善法。是名毕竟自利利他。由三因缘应知毕竟及不毕竟。一由自性故。二由退不退故。三由受用果有尽无尽故。由自性故者。究竟涅槃名为毕竟。一切有为名不毕竟。由退不退及受用果有尽无尽故者。八支圣道无有退故。及受用果无有尽故。名为毕竟。其余一切善有漏法。由有退故。及受用果有终尽故。名不毕竟。

如是菩萨十种自利利他。若略若广。菩萨随力随能当勤修学。除此无有若过若增。过去未来所有一切已学当学自利利他。亦皆唯有如此十种自利利他。除此无有若过若增

    本地分中菩萨地第十五初持瑜伽处真实义品第四

云何真实义。谓略有二种。一者依如所有性诸法真实性。二者依尽所有性诸法一切性。如是诸法真实性一切性。应知总名真实义。此真实义品类差别复有四种。一者世间极成真实。二者道理极成真实。三者烦恼障净智所行真实。四者所知障净智所行真实

云何世间极成真实。谓一切世间于彼彼事随顺假立。世俗串习悟入觉慧所见同性。谓地唯是地非是火等。如地如是。水火风。色声香味触。饮食衣乘。诸庄严具。资产什物。涂香华鬘歌舞伎乐种种光明。男女承事。田园邸店宅舍等事当知亦尔。苦唯是苦非是乐等。乐唯是乐非是苦等。以要言之。此即如此非不如此。是即如是非不如是。决定胜解所行境事。一切世间从其本际展转传来。想自分别共所成立。不由思惟筹量观察然后方取。是名世间极成真实

云何道理极成真实。谓诸智者有道理义。诸聪睿者诸黠慧者。能寻思者能伺察者。住寻伺地者具自辩才者。居异生位者随观察行者。依止现比及至教量极善思择决定智所行所智事。由证成道理所建立所施设义。是名道理极成真实

云何烦恼障净智所行真实。谓一切声闻独觉。若无漏智。若能引无漏智。若无漏后得世间智所行境界。是名烦恼障净智所行真实。由缘此为境。从烦恼障智得清净。于当来世无障碍住。是故说名烦恼障净智所行真实。此复云何。谓四圣谛。一苦圣谛。二集圣谛。三灭圣谛。四道圣谛。即于如是四圣谛义。极善思择证入现观。入现观已如实智生。此谛现观。声闻独觉能观唯有诸蕴可得。除诸蕴外我不可得。数习缘生诸行生灭相应慧故。数习异蕴补特伽罗无性见故。发生如是圣谛现观

云何所知障净智所行真实。谓于所知能碍智故名所知障。从所知障得解脱智所行境界。当知是名所知障净智所行真实。此复云何。谓诸菩萨诸佛世尊入法无我。入已善净于一切法离言自性假说自性。平等平等无分别智所行境界。如是境界为最第一真如无上所知边际。齐此一切正法思择皆悉退还不能越度

又安立此真实义相。当知即是无二所显。所言二者。谓有非有。此中有者。谓所安立假说自性。即是世间长时所执。亦是世间一切分别戏论根本。或谓为色受想行识。或谓眼耳鼻舌身意。或复谓为地水火风。或谓色声香味触法。或谓为善不善无记。或谓生灭。或谓缘生。或谓过去未来现在。或谓有为或谓无为。或谓此世或谓他世。或谓日月。或复谓为所见所闻所觉所知。所求所得意随寻伺。最后乃至或谓涅槃。如是等类是诸世间共了诸法假说自性。是名为有。言非有者。谓即诸色假说自性。乃至涅槃假说自性。无事无相假说所依。一切都无假立言说。依彼转者皆无所有。是名非有。先所说有今说非有。有及非有二俱远离法相所摄真实性事。是名无二。由无二故说名中道。远离二边亦名无上。佛世尊智于此真实已善清净。诸菩萨智于此真实学道所显。又即此慧是诸菩萨能得无上正等菩提广大方便。何以故。以诸菩萨处于生死。彼彼生中修空胜解。善能成熟一切佛法及诸有情。又能如实了知生死。不于生死以无常等行深心厌离。若诸菩萨不能如实了知生死。则不能于贪嗔痴等一切烦恼深心弃舍。不能弃舍诸烦恼故。便杂染心受诸生死。由杂染心受生死故。不能成熟一切佛法及诸有情。若诸菩萨于其生死以无常等行深心厌离。是则速疾入般涅槃。彼若速疾入般涅槃。尚不能成熟一切佛法及诸有情。况能证无上正等菩提。又诸菩萨由习如是空胜解故。则于涅槃不深怖畏。亦于涅槃不多愿乐。若诸菩萨深怖涅槃。即便于彼涅槃资粮不能圆满。由于涅槃深怖畏故不见涅槃胜利功德。由不见故便于涅槃远离一切清净胜解。若诸菩萨于其涅槃多住愿乐。是则速疾入般涅槃。彼若速疾入般涅槃。则便不能成熟佛法及诸有情。

当知此中若不如实了知生死。即杂染心流转生死。若于生死深心厌离。即便速疾入般涅槃。若于涅槃深心怖畏即于能证涅槃资粮不能圆满。若于涅槃多住愿乐。即便速疾入般涅槃。是诸菩萨于证无上正等菩提无大方便。若能如实了知生死。即无染心流转生死。若于生死不以无常等行深心厌离。即不速疾入般涅槃。若于涅槃不深怖畏。即能圆满涅槃资粮。虽于涅槃见有微妙胜利功德。而不深愿速证涅槃。是诸菩萨于证无上正等菩提有大方便。是大方便依止最胜空性胜解。是故菩萨修习学道所摄最胜空性胜解。名为能证如来妙智广大方便

又诸菩萨由能深入法无我智。于一切法离言自性。如实知已达无少法及少品类可起分别。唯取其事唯取真如。不作是念。此是唯事是唯真如。但行于义。如是菩萨行胜义故。于一切法平等。平等以真如慧如实观察。于一切处具平等见具平等心得最胜舍。依止此舍于诸明处一切善巧勤修习时。虽复遭遇一切劬劳一切苦难。而不退转。速疾能令身无劳倦。心无劳倦。于诸善巧速能成办得大念力。不因善巧而自贡高。亦于他所无有秘吝。于诸善巧心无怯弱。有所堪能所行无碍。具足坚固甲胄加行。是诸菩萨于生死中如如流转遭大苦难。如是如是于其无上正等菩提堪能增长。如如获得尊贵殊胜。如是如是于诸有情憍慢渐减。如如证得智慧殊胜。如是如是倍于他所难诘诤讼諠杂语论本惑随惑犯禁现行。能数观察深心弃舍。如如功德展转增长。如是如是转覆自善不求他知。亦不希求利养恭敬。如是等类菩萨所有众多胜利。是菩提分随顺菩提皆依彼智。是故一切已得菩提当得今得。皆依彼智。除此更无若劣若胜。

又诸菩萨乘御如是无戏论理。获得如是众多胜利。为自成熟诸佛法故。为成熟他三乘法故。修行正行。彼于如是修正行时。于自身财远离贪爱。于诸众生学离贪爱能舍身财。唯为利益诸众生故。又能防护极善防护。由身语等修学律仪。性不乐恶性极贤善。又能忍他一切侵恼。于行恶者能学堪忍性薄嗔忿不侵恼他。又能勤修一切明处令其善巧。为断众生一切疑难。为惠众生诸饶益事。为自摄受一切智因。又能于内安住其心令心善定。于心安住常勤修学。为净修治四种梵住。为能游戏五种神通。为能成立利众生事。为欲除遣精勤修学一切善巧所生劳倦。又性黠慧成极真智。为极真智常勤修学。为自当来般涅槃故修习大乘。又诸菩萨即于如是修正行时。于具功德诸有情所。常乐现前供养恭敬。于具过失诸有情所。常乐现前发起最胜悲心愍心。随能随力令彼除断所有过失。于己有怨诸有情所常起慈心。随能随力无谄无诳。作彼种种利益安乐。令彼怨者意乐加行所有过失及怨嫌心自然除断。于己有恩诸有情所。善知恩故若等若增现前酬报。随能随力如法令其意望满足。虽无力能彼若求请。即于彼彼所作事业。示现殷重精勤营务。终不顿止彼所希求。云何令彼知我无力非无欲乐。如是等类当知名为菩萨乘御无戏论理。依极真智修正加行

以何道理应知诸法离言自性。谓一切法假立自相。或说为色或说为受。如前广说。乃至涅槃当知一切唯假建立非有自性。亦非离彼别有自性。是言所行是言境界。如是诸法非有自性如言所说。亦非一切都无所有。如是非有。亦非一切都无所有。云何而有。谓离增益实无妄执。及离损减实有妄执。如是而有。即是诸法胜义自性。当知唯是无分别智所行境界。若于诸法诸事随起言说。即于彼法彼事有自性者。如是一法一事应有众多自性。何以故。以于一法一事制立众多假说而诠表故。亦非众多假说诠表决定可得。谓随一假说于彼法彼事有体有分有其自性。非余假说。是故一切假说若具不具。于一切法于一切事皆非有体有分有其自性。又如前说色等诸法。若随假说有自性者。要先有事然后随欲制立假说。先未制立彼假说时。彼法彼事应无自性。若无自性无事制立假说诠表。不应道理假说诠表既无所有。彼法彼事随其假说而有自性。不应道理。又若诸色未立假说诠表。已前先有色性。后依色性制立假说摄取色者。是则离色假说诠表。于色想法于色想事应起色觉。而实不起。由此因缘由此道理。当知诸法离言自性。如说其色。如是受等如前所说。乃至涅槃应知亦尔。有二种人。于佛所说法毗奈耶。俱为失坏。一者于色等法于色等事。谓有假说自性自相。于实无事起增益执。二者于假说相处于假说相依离言自性胜义法性。谓一切种皆无所有。于实有事起损减执。于实无事起增益执。妄立法者所有过失已具如前显了开示。于色等法实无事中。起增益执有过失故。于佛所说法毗奈耶甚为失坏。于色等法实有唯事起损减执。坏诸法者所有过失。由是过失。于佛所说法毗奈耶甚为失坏。我今当说。谓若于彼色等诸法实有唯事起损减执。即无真实亦无虚假。如是二种皆不应理。譬如要有色等诸蕴方有假立补特伽罗。非无实事而有假立补特伽罗。如是要有色等诸法实有唯事。方可得有色等诸法假说所表。非无唯事而有色等假说所表。若唯有假无有实事。既无依处假亦无有。是则名为坏诸法者。如有一类闻说难解大乘相应空性相应未极显了密意趣义甚深经典。不能如实解所说义。起不如理虚妄分别。由不巧便所引寻思。起如是见立如是论。一切唯假是为真实。若作是观名为正观。彼于虚假所依处所实有唯事。拨为非有。是则一切虚假皆无。何当得有一切唯假是为真实。由此道理彼于真实及以虚假二种俱谤都无所有。由谤真实及虚假故。当知是名最极无者。如是无者一切有智同梵行者不应共语不应共住。如是无者能自败坏。亦坏世间随彼见者。世尊依彼密意说言。宁如一类起我见者。不如一类恶取空者。何以故。起我见者。唯于所知境界迷惑。不谤一切所知境界。不由此因堕诸恶趣。于他求法求苦解脱。不为虚诳不作稽留。于法于谛亦能建立。于诸学处不生慢缓。恶取空者亦于所知境界迷惑。亦谤一切所知境界。由此因故堕诸恶越。于他求法求苦解脱。能为虚诳亦作稽留。于法于谛不能建立。于诸学处极生慢缓。如是损减实有事者。于佛所说法毗奈耶甚为失坏

云何名为恶取空者。谓有沙门或婆罗门。由彼故空亦不信受。于此而空亦不信受。如是名为恶取空者。何以故。由彼故空彼实是无。于此而空此实是有。由此道理可说为空。若说一切都无所有。何处何者何故名空。亦不应言由此于此即说为空。是故名为恶取空者。云何复名善取空者。谓由于此彼无所有。即由彼故正观为空。复由于此余实是有。即由余故如实知有。如是名为悟入空性如实无倒。谓于如前所说一切色等想事。所说色等假说性法。都无所有。是故于此色等想事。由彼色等假说性法。说之为空。于此一切色等想事何者为余。谓即色等假说所依。如是二种皆如实知。谓于此中实有唯事。于唯事中亦有唯假。不于实无起增益执。不于实有起损减执。不增不减不取不舍。如实了知如实真如离言自性。如是名为善取空者。于空法性能以正慧妙善通达。如是随顺证成道理。应知诸法离言自性

复由至教。应知诸法离言自性。如佛世尊转有经中为显此义而说颂曰

  以彼彼诸名　　诠彼彼诸法
  此中无有彼　　是诸法法性

云何此颂显如是义。谓于色等想法。建立色等法名。即以如是色等法名诠表。随说色等想法。或说为色或说为受或说为想。广说乃至说为涅槃。于此一切色等想法色等自性。都无所有。亦无有余色等性法。而于其中色等想法离言义性。真实是有。当知即是胜义自性亦是法性。又佛世尊义品中说

  世间诸世俗　　牟尼皆不着
  无著孰能取　　见闻而不爱

云何此颂显如是义。谓于世间色等想事所有色等种种假说。名诸世俗。如彼假说于此想事有其自性。如是世俗牟尼不着。何以故。以无增益损减见故。无有现前颠倒见故。由此道理名为不着。如是无著谁复能取。由无见故于事不取增益损减。于所知境能正观察。故名为见。听闻所知境界言说。故名为闻。依此见闻贪爱不生亦不增长。唯于彼缘毕竟断灭。安住上舍故名不爱。又佛世尊为彼散他迦多衍那作如是说。散他苾刍。不依于地而修静虑。不依于水不依于火不依于风。不依空处不依识处。不依无所有处不依非想非非想处。不依此世他世。不依日月光轮。不依见闻觉知。不依所求所得。不依意随寻伺。不依一切而修静虑。云何修习静虑苾刍。不依于地而修静虑。广说乃至不依一切而修静虑。散他苾刍。或有于地除遣地想。或有于水除遣水想。广说乃至或于一切除一切想。如是修习静虑苾刍。不依于地而修静虑。广说乃至不依一切而修静虑。如是修习静虑苾刍。为因陀罗为伊舍那。为诸世主并诸天众。遥为作礼而赞颂曰

  敬礼吉祥士　　敬礼士中尊
  我今不知汝　　依何修静虑

云何此经显如是义。谓于一切地等想事。诸地等名施设假立。名地等想。即此诸想于彼所有色等想事。或起增益或起损减。若于彼事起能增益有体自性执。名增益想。起能损减唯事胜义执。名损减想。彼于此想能正除遣能断能舍。故名除遣。如是等类无量圣言。名为至教。由此如来最胜至教。应知诸法离言自性

问若如是者。何因缘故于一切法离言自性而起言说。答若不起言说。则不能为他说一切法离言自性。他亦不能闻如是义。若无有闻则不能知此一切法离言自性。为欲令他闻知诸法离言自性。是故于此离言自性而起言说

又诸愚夫由于如是所显真如不了知故。从是因缘八分别转能生三事。能起一切有情世间及器世间。云何名为八种分别。一者自性分别。二者差别分别。三者总执分别。四者我分别。五者我所分别。六者爱分别。七者非爱分别。八者彼俱相违分别。云何如是八种分别能生三事。谓若自性分别。若差别分别。若总执分别。此三分别能生分别戏论所依分别戏论所缘事。谓色等想事为依缘故。名想言说所摄。名想言说所显分别戏论。即于此事分别计度。非一众多品类差别。若我分别若我所分别。此二分别能生一切余见根本。及慢根本萨迦耶见。及能生一切余慢根本所有我慢。若爱分别。若非爱分别。若彼俱相违分别。如其所应能生贪欲嗔恚愚痴。是名八种分别能生如是三事。谓分别戏论所依缘事。见我慢事。贪嗔痴事。当知此中分别戏论所依缘事为所依止。生萨迦耶见及以我慢。萨迦耶见我慢为依生贪嗔痴。由此三事普能显现一切世间流转品法。云何名为自性分别。谓于一切色等想事。分别色等种种自性所有寻思。如是名为自性分别。云何名为差别分别。谓即于彼色等想事。谓此有色谓此无色。谓此有见谓此无见。谓此有对谓此无对谓此有漏谓此无漏。谓此有为谓此无为。谓此是善谓此不善。谓此无记。谓此过去谓此未来谓此现在。由如是等无量品类差别道理。即于自性分别依处。分别种种彼差别义。如是名为差别分别。云何名为总执分别。谓即于彼色等想事我及有情命者生者等。假想施设所引分别。于总多法总执为因分别而转。于舍军林饮食衣乘等。假想施设所引分别。如是名为总执分别。云何名为我我所分别。谓若诸事有漏有取。长时数习我我所执之所积聚。由宿串习彼邪执故。自见处事为缘所生虚妄分别。如是名为我我所分别。云何名为爱分别。谓缘净妙可意事境所生分别。云何名为非爱分别。谓缘不净妙不可意事境所生分别。云何名为彼俱相违分别。谓缘净妙不净妙可意不可意俱离事境。所生分别。此中所说略有二种。一者分别自性。二者分别所依分别所缘事。如是二种无始世来应知展转更互为因。谓过去世分别为因。能生现在分别所依及所缘事。现在分别所依缘事既得生已。复能为因生现在世由彼依缘所起分别。于今分别不了知故。复生当来所依缘事。彼当生故决定当生依彼缘彼所起分别

云何了知如是分别。谓由四种寻思四种如实智故。云何名为四种寻思。一者名寻思。二者事寻思。三者自性假立寻思。四者差别假立寻思。名寻想者。谓诸菩萨于名唯见名。是名名寻思。事寻思者。谓诸菩萨于事唯见事。是名事寻思。自性假立寻思者。谓诸菩萨于自性假立唯见自性假立。是名自性假立寻思。差别假立寻思者谓诸菩萨于差别假立唯见差别假立。是名差别假立寻思。此诸菩萨于彼名事。或离相观或合相观。依止名事合相观故。通达二种自性假立差别假立。云何名为四如实智。一者名寻思所引如实智。二者事寻思所引如实智。三者自性假立寻思所引如实智。四者差别假立寻思所引如实智。云何名寻思所引如实智。谓诸菩萨于名寻思唯有名已。即于此名如实了知。谓如是名为如是义于事立假。为令世间起想起见起言说故。若于一切色等想事不假建立色等名者。无有能于色等想事起色等想。若无有想则无有能起增益执。若无有执则无言说。若能如是如实了知。是名名寻思所引如实智。云何事寻思所引如实智。谓诸菩萨于事寻思唯有事已。观见一切色等想事。性离言说不可言说。若能如是如实了知。是名事寻思所引如实智。云何自性假立寻思所引如实智。谓诸菩萨于自性假立寻思。唯有自性假立已。如实通达了知色等想事中所有自性假立。非彼事自性而似彼事自性显现。又能了知彼事自性犹如变化影像。向应光影。水月焰水梦幻。相似显现而非彼体。若能如是如实了知最甚深义所行境界。是名自性假立寻思所引如实智。云何差别假立寻思所引如实智。谓诸菩萨于差别假立寻思。唯有差别假立已。如实通达了知色等想事中差别假立不二之义。谓彼诸事非有性非无性。可言说性不成实故非有性。离言说性实成立故非无性。如是由胜义谛故非有色。于中无有诸色法故由世俗谛故非无色。于中说有诸色法故。如有性无性有色无色。如是有见无见等差别假立门。由如是道理一切皆应了知。若能如是如实了知差别假立不二之义。是名差别假立寻思所引如实智。愚夫于此四如实智有所阙故不现前故。便有八种邪分别转。能生三事。能起一切有情世间及器世间。谓由如是邪分别故起诸杂染。起杂染故流转生死。于生死中常流转故。恒有无量随逐生死种种生老病死等苦流转不息

菩萨依此四如实智。能正了知八种分别。于现法中正了知故。令当来世戏论所摄所依缘事不复生起。不生起故于当来世从彼依缘所起分别亦不复生。如是分别及依缘事二俱灭故。当知一切戏论皆灭。菩萨如是戏论灭故。能证大乘大般涅槃。于现法中胜真实义所行处智极清净故。普能获得一切自在。谓诸菩萨于种种化获得能化神通自在。于种种变获得能变神通自在。普于一切所知境智皆得自在。若欲久住随其所乐自在能住。若欲终殁不待害缘自在能殁。由诸菩萨得如是等无量自在。于诸有情最胜无上。菩萨如是普于一切得自在故。获得五种最上胜利。一者获得心极寂静。由住最静故不由烦恼寂静故。二者能于一切明处无所挂碍。清净鲜白妙智见转。三者为利诸有情故。流转生死无有厌倦。四者善入一切如来密意言义。五者所得大乘胜解。不可引夺不从他缘。当知如是五种胜利有五种业。一者菩萨成就最胜现法乐住。能灭一切为趣菩提精勤加行所生身心种种劳倦。当知是名心极寂静胜利之业。二者菩萨普能成熟一切佛法。当知是名于诸明处无碍清白微妙智见胜利之业。三者菩萨普能成熟一切有情。当知是名流转生死无有厌倦胜利之业。四者菩萨能正除遣所化有情随所生起一切疑惑。护持如来妙正法眼令得久住。于能隐没如来圣教像似正法。能知能显能正除灭。当知是名善入如来密意言义胜利之业。五者菩萨能摧一切外道异论。精进坚牢正愿无动。当知是名大乘胜解不可引夺不从他缘胜利之业。如是菩萨所有一切菩萨所作。皆为如是五胜利业之所摄受。

云何一切菩萨所作。谓自安乐而无杂染。普能成熟一切佛法。普能成熟一切有情。护持如来无上正法摧伏他论。精进勇猛正愿无动

当知如是四真实义。初二下劣。第三处中。第四最胜

瑜伽师地论卷第三十六瑜伽师地论卷第三十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处威力品第五

云何诸佛菩萨威力。当知略有三种。一者圣威力。谓佛菩萨得定自在。依定自在随其所欲一切事。成心调柔故善修心。故是名圣威力。二者法威力。谓诸胜法有广大果有大胜利。是名法威力。此中法者。即是六种波罗蜜多。所谓布施乃至般若。如是诸法有大威力。名法威力。三者俱生威力。谓佛菩萨先集广大福德资粮。证得俱生甚希奇法。是名俱生威力

又佛菩萨如是威力品类差别复有五种。一者神通威力。二者法威力。三者俱生威力。四者共诸声闻独觉威力。五者不共声闻独觉威力

云何诸佛菩萨神通威力。谓六神通。一者神境智作证通。二者随念宿住智作证通。三者天耳智作证通。四者见死生智作证通。五者知心差别智作证通。六者漏尽智作证通。是名神通威力

云何诸佛菩萨神境智通。谓佛菩萨神境智通略有二种。一者能变通二者能化通。如是二种品类差别各有多种。云何能变神境智通品类差别。谓十八变。一者振动。二者炽然。三者流布。四者示现。五者转变。六者往来。七者卷。八者舒。九者众像入身。十者同类往趣。十一者显。十二者隐。十三者所作自在。十四者制他神通。十五者能施辩才。十六者能施忆念。十七者能施安乐。十八者放大光明。如是等类皆名能变神境智通。振动者。谓佛菩萨得定自在心调柔故。善修心故。依定自在普能振动寺馆舍宅。村邑聚落。城郭国土那落迦世界傍生世界。祖父世界人世界。天世界一四大洲。一千世界二千世界。三千大千世界。百三千大千世界。千三千大千世界。百千三千大千世界。乃至无量无数三千大千世界皆能振动。是名振动。炽然者。谓佛菩萨依定自在。从其身上发猛焰火。于其身下注清冷水。从其身下发猛焰火。于其身上注清冷水。入火界定举身洞然。遍诸身分出种种焰青黄赤白红紫碧绿颇胝迦色。是名炽然。流布者。谓佛菩萨依定自在。流布光明遍满一切寺馆舍宅。乃至无量无数世界无不充满。如前振动。是名流布。示现者。谓佛菩萨依定自在。如其所乐示彼一切诸来会众沙门婆罗门声闻菩萨。天龙药叉健达缚。阿素洛揭路荼紧捺洛牟呼洛伽人非人等。令悉现见。下诸恶趣上诸人天复令现见。诸余佛土及于其中诸佛菩萨。乃至超过殑伽沙等诸佛国土种种名声所表佛土。及彼土中某名如来悉令现见。亦为宣说彼佛土名及如来名齐彼至此。若复过彼诸佛国土及诸如来。随其所欲乃至所欲。皆令现见亦为宣说。是名示现。转变者。谓佛菩萨依定自在。若于其地。起水胜解即令成水。如实非余。火风胜解亦复如是。若于其水起地胜解即令成地。如实非余。火风胜解亦复如是。若于其火起地胜解即令成地。如实非余。水风胜解亦复如是。若于其风起地胜解即令成地。如实非余。水火胜解亦复如是。若于一切起余胜解。即随胜解如实非余。如于大种互相转变。色香味触当知亦尔。若于草叶牛冀泥等。起于饮食车乘衣服严饰资具种种涂香华鬘胜解。即随胜解如实非余。若于沙石瓦砾等物。起于末尼真珠琉璃螺贝壁玉珊瑚胜解。即随胜解如实非余。若于诸山雪山王等起金胜解。即随胜解如实非余。若于一切起余胜解。即随胜解如实非余。若于好色有情起恶色胜解。于恶色有情起好色胜解。于俱非有情起好色恶色胜解。于俱有情起俱非胜解。即随胜解如实非余。如于好色恶色。于具支节不具支节及肥瘦等当知亦尔。如是于余所有自相可变色物起余胜解。皆随胜解一切转变。如实非余。是名转变。往来者。谓佛菩萨依定自在。随其所乐于诸墙壁山石等中。纵身往来无有滞碍。广说乃至往于梵世。乃至上至色究竟天还来无碍。或复傍于无量无数三千大千世界。若往若来皆无滞碍。或运粗重四大种身。或于远处作近胜解。或如意势速疾往来。是名往来。卷舒者。谓佛菩萨依定自在。能卷一切雪山王等如一极微。舒一极微令如一切雪山王等。是名卷舒。众像入身者。谓佛菩萨依定自在。能以种种现前大众。及以一切村邑聚落。草木丛林。诸山大地一切色像内己身中。令诸大众各各自知入其身内。是名众像入身。同类往趣者。谓佛菩萨依定自在。或能往趣刹帝利众。同其色类如彼形量似彼言音。彼若以此名如是义。亦即以此名如是义。彼不以此名如是义。亦不以此名如是义。然后为其演说正法。示现教导赞励庆慰。化事既终欻然隐没。没后时众迭相顾言。不知没者天耶人耶。如能往趣刹帝利众。如是往趣婆罗门众。若沙门众。若长者众若居士众。四大王天三十三天。夜摩天睹史多天。乐变化天他化自在天。梵众天梵先益天。大梵天少。光天。无量光天光音天。少净天无量净天。遍净天无云天。福生天广果天。无烦天无热天。善现天善见天。色究竟天。当知亦尔。是名同类往趣。隐显者。谓佛菩萨依定自在。于大众前百度千度或过于是。隐没自身复令显现。是名隐显。所作自在者。谓佛菩萨依定自在。普于一切诸有情界往来住等所作事中皆自在转。令去即去令住即住。令来即来令语即语。是名所作自在。制他神通者。谓佛菩萨依定自在。能制伏他所现神通。如来神通普能制伏其余一切具神通者所现神通。如其所欲令事成办究竟。菩萨一生所系。或最后有所有神通。除诸如来等类菩萨。悉能制伏其余一切具神通者所现神通。诸余菩萨所有神通。除入上地等类菩萨。悉能制伏其余一切具神通者所现神通。是名制他神通。能施辩才者。谓佛菩萨依定自在。若诸有情辩才穷尽能与辩才。是名能施辩才。能施忆念者。谓佛菩萨依定自在。若诸有情于法失念能与忆念。是名能施忆念。能施安乐者。谓佛菩萨依定自在。说正法时与听法者饶益身心轻安之乐。令离诸盖专心听法。暂时方便而非究竟。又令诸界互相违变能为损害。非人所行灾疠疾疫皆得息灭。是名能施安乐。放大光明者。谓佛菩萨依定自在。以神通力身放光明。或有一光往十方面无量无数诸世界中。令恶趣等一切有情息彼众苦。或有一光往诸天界。令大威德天龙药叉健达缚阿素洛揭路荼紧捺洛牟呼洛伽等。住自宫中。蒙光觉悟皆来集会。或有一光往十方面无量无数诸世界中。令住他方世界菩萨蒙光觉悟皆来集会。以要言之。诸如来等能放无量无数品类种种光明。能作无量无数世界无量无数诸有情类无量无数利益之事。是名放大光明。当知如是一切能变神境智通品类差别。一一分别无量无数。由此神通能转所余有自性物。令成余物。故名能变神境智通

云何能化神境智通品类差别。谓若略说。无事而有。是名为化。能以化心随其所欲。造作种种未曾有事。故名能化神境智通。此复多种。或化为身及化为境。或化为语。或化为身及化为境者。化似自身或不相似。化似他身或不相似。又所化身若自若他或似不似。唯能化作与根相似。根所依处而非实根。复能化作相似境界。谓饮食等。末尼真珠琉璃宝等。所有色香味触所摄外资生具。若彼相似若异于彼。随其所欲一切能化。又所化身与己同类。非一众多种种差别。或作天龙药叉健达缚。阿素洛揭路荼紧捺洛牟呼洛伽色像。或作人傍生鬼那洛迦色像。或作声闻独觉菩萨如来色像。若所化身与菩萨身极相似者。名所化身与自相似。若不尔者名所化身非自相似。又所化身与他同类亦有多种。若作天身与彼天身极相似者。名所化身与他相似。若不尔者名所化身非他相似。如作天身。乃至佛身当知亦尔。云何此中化作多身。谓佛菩萨于十方面无量无数诸世界中。一时化作种种形类。能为无量无数有情作利益事。如是所化种种形类。于中或有诸佛菩萨虽灭度后由住持力而故随转。或有暂时作利益已化事便息。又佛菩萨或作化事。唯令众生睹见而已。如幻所作不堪受用。或复化作饮食衣服末尼真珠琉璃螺贝壁玉珊瑚车乘等事与实无异。如是所作财食众具。令诸众生常得受用。是名化身及化境界。或化为语者。或有化语妙音相应。或有化语广音具足。或有化语系属于目。或有化语系属于他。或有化语无所系属。或有化语宣说正法言词所摄。或有化语诲责放逸言词所摄。妙音相应者。谓佛菩萨所说化语。其声深远如云雷音。其声和雅如频迦音。能感众心甚可爱乐。又此化语圆上微妙显了。易解乐闻无逆无依无尽。广音具足者。谓佛菩萨所说化语其声广大。随其所乐无量种类。天龙药叉健达缚。阿素洛揭路荼紧捺洛牟呼洛伽。声闻菩萨人非人等。无量众会。一踰缮那皆悉充满。以妙圆音随类遍告。又随所乐小千世界二千世界三千世界。乃至十方无量无数诸世界中。若近若远所有众会。以妙圆音随类遍告。于此声中出种种音。为诸众生。说种种法。随其所应各得义利。系属于自者。谓佛菩萨所说化语。于化自身出种种音。宣说正法诲责放逸。系属于他者。谓佛菩萨所说化语。于化他身宣说正法诲责放逸。无所系属者。谓佛菩萨所说化语。或于空中或于所化非情法上而有所说。宣说正法言词所摄者。谓佛菩萨所说化语。开示正理令诸愚痴于种种法皆得悟解。诲责放逸。言词所摄者。谓佛菩萨所说化语。为不愚痴获得净信。而放逸者责其放逸令生惭愧。诲不放逸令勤修学。如是所说众多化事略有三种。化身化境及以化语。当知如是一切。能化神境智通品类差别。一一分别无量无数

如是二种诸佛菩萨神境智通能办二事。一者示现种种神通。引诸众生入佛圣教。二者示现种种神通。惠施无量受苦众生。众多品类利益安乐。云何诸佛菩萨随念宿住智通。谓佛菩萨以宿住智。自能随念己之宿住。曾于如是有情类中我如是名。如经广说。亦能随念他诸有情身等一切品类差别。如自随念己事无异。又能令他得宿住智。能自随念前际所经若自若他身等一切品类差别。曾于如是有情类中。我如是名。乃至广说。如是有情转复令他得宿住智。能自随念一切宿住。如前无异。如是展转令忆宿住。皆如自己于现法中。又能随念诸微细事所有一切若少若多先所造作先所思惟。皆无忘失。又能随念无间刹那。次第所作无间断故。又能随念有量有数宿住差别。所知时劫可算数故。又能随念无量无数宿住差别。所知时劫不可数故。以要言之。此宿住智于如是处于如是类于如是量。随其所欲皆无碍转。如是名为诸佛。菩萨随念宿住所摄威力。又由随念宿住智故忆念本生。为诸有情开示先世种种品类第一希有菩萨所行难行苦行。令于佛所生净信故。起恭敬故。令于生死深厌离故。又由此智忆念本事。为诸众生开示种种先世相应业果异熟。为令妄计前际常论一分常论常见众生破常见故

云何诸佛菩萨天耳智通。谓佛菩萨以净天耳。能于种种天声人声。圣声非圣声。大声小声。辩声非辩声。化声非化声。远声近声。皆悉得闻。闻天声者。若不作意。下从欲界上至色究竟宫。其中受生诸有情类种种音声皆悉能闻。若作意时。过是已上诸世界声皆亦能闻。闻人声者。遍于一切傍四大洲受生有情种种音声皆悉能闻。闻圣声者。于诸如来声闻独觉及诸菩萨。若从彼闻展转为余诸有情类。宣说种种示现教导赞励庆慰。劝修诸善劝舍诸恶。所有音声皆悉能闻。又于一切无染污心。受持读诵论议决择。无倒谏诲为作忆念教授教诫。及余所有善言善说能引义利种种音声皆悉能闻。如是等类名闻圣声。闻非圣声者。于诸有情虑妄离间邪绮粗犷。生下恶趣。生上天趣。生傍人趣种种音声。皆悉能闻。闻大声者。谓于大众生声大集会。声种种苦具所逼切声。大号哭声相呼召声。大雷吼声诸螺贝声。诸鼓角等种种音声。皆悉能闻。闻小声者。下至耳语诸微细声皆悉能闻。闻辩声者。于义易了种种音声皆悉能闻。闻非辩声者。于义难了种种音声谓达罗弭荼种种明咒。风铃树响鹦鹉鸲鹆。百舌鹂黄命命鸟等所出音声皆悉能闻。闻化声者。谓于一切得心自在具神通者。依神通力所化音声。皆悉能闻。闻非化声者。谓于种种异彼音声。皆悉能闻。闻远声者。除佛菩萨所住聚落城邑等中所有音声。于余乃至无量无数世界中声。皆悉能闻。闻近声者。闻所除声。云何诸佛菩萨见死生智通。谓佛菩萨以超过人清净天眼。见诸有情死时生时妙色恶色若劣若胜。及于后际生已增长诸根。成熟身诸所作善恶无记差别而转。又现见知诸光明色诸微细色诸变化色诸净妙色。下至无间上至色究竟宫。不由作意皆能见知。若作意时能见上下无量无数余世界色。亦能见傍无量无数诸世界中一切诸色。乃至能见彼彼佛土彼彼如来安坐彼彼异类大会宣说正法。显然无乱

又佛菩萨以净天眼。普见十方无量无数诸有情类身之所作净不净业。既见彼已随其所应随其所宜。施作种种利益安乐。以净天耳。普闻十方无量无数诸有情类语之所作净不净业。既闻彼已随其所应随其所宜。施作种种利益安乐。是名略说诸佛菩萨天眼天耳之所作业

云何诸佛菩萨知心差别智通。谓佛菩萨以他心智。遍知十方无量无数诸世界中他有情类。若有缠烦恼心。若离缠烦恼心。若有随缚有随眠烦恼心。若离随缚离随眠烦恼心。又遍了知有染心邪愿心。谓诸外道心及有爱染心。又遍了知无染心正愿心。谓与上相违心。又遍了知劣心。谓生欲界诸有情类。下至一切禽兽等心。又遍了知中心。谓生色界诸有情类诸所有心。又遍了知胜心。谓生无色界诸有情类诸所有心。又遍了知乐相应心苦相应心不苦不乐相应心。又能以一知他心智。于一有情如是所有。如是体性。如是品类。如是行相。如是分齐心起现前。于一念顷并如实知。又能以一知他心智。于多有情如是所有。如是体性。如是品类。如是行相。如是分齐心起现前。于一念顷并如实知。又佛菩萨此他心通。知诸有情诸根胜劣。知诸有情种种胜解。知诸有情种种界行。随其所应能正安处趣涅槃宫种种正行。当知是名此所作业

云何诸佛菩萨漏尽智通。谓佛菩萨如实了知烦恼尽。得如实了知若自若他于诸漏尽已得未得。如实了知若自若他所有能得漏尽方便。如能如实了知方便。于非方便亦如实知。如实知他于漏尽得有增上慢。如实知他于漏尽得离增上慢。又诸菩萨虽能如实了知一切漏尽功德能证方便。而不作证。是故菩萨于有漏事及与诸漏不速舍离。虽行种种有漏事中而不染污。如是威力于诸威力最为殊胜。又佛菩萨由漏尽智自无染污。亦善为他广分别说坏增上慢。当知是名此所作业

云何法威力。谓布施威力乃至般若威力。此布施等诸法威力。应知一一略有四相。一者断所对治相。二者资粮成熟相。三者饶益自他相。四者与当来果相。布施四相者。谓诸菩萨修行惠施能断悭吝。施所对治。是名第一。即此惠施能作自己菩提资粮。亦即能作布施摄事成熟有情。是名第二。施先意悦施时心净施已无悔。于三时中心常欢喜。以自饶益亦能除他饥渴寒热种种疾病。所欲匮乏怖畏众苦以饶益他。是名第三。于当来世在在生处恒常富乐。得大禄位得大财宝。得大朋党得大眷属。是名第四。是名布施威力四相。此外无有若过若增。持戒四相者。谓诸菩萨受持清净身语律仪能断犯戒。戒所对治。是名第一。即所受持清净尸罗。能为自己菩提资粮。亦即能作同事摄事成熟有情。是名第二。受持净戒。舍离犯戒。为缘所生怖畏众罪怨敌等事。寝寤安乐以自饶益。又由净戒无悔欢喜。乃至心定以自饶益。受持净戒不损恼他。普施一切有情无畏以饶益他。是名第三。由是因缘身坏已后。生于善趣天世界中。是名第四。是名持戒威力四相。此外无有若过若增。忍辱四相者。谓诸菩萨修行忍辱能断不忍。忍所对治。是名第一。即此忍辱能作自己菩提资粮。亦即能作同事摄事成熟有情。是名第二。由此忍辱济[打-丁+犬]自他大怖畏事饶益自他。是名第三。由是因缘能令菩萨于当来世。无多怨敌。无多离隔。无多忧苦。于现法中。临命终时心无忧悔。身坏已后生于善趣天世界中。是名第四。是名忍辱威力四相。此外无有若过若增。精进四相者。谓诸菩萨住勤精进。能断解怠。精进所治。是名第一。即此精进能作自己菩提资粮及所依止。亦即能作同事摄事成熟有情。是名第二。勤精进故得安乐住。不为一切恶不善法之所杂乱。后后所证转胜于前倍生观喜。以自饶益勤修善品。不以身语损恼于他。令他发生精进乐欲以饶益他。是名第三。由此因力于当来世。爱乐殊胜士夫功业。是名第四。是名精进威力四相。此外无有若过若增。静虑四相者。谓诸菩萨入静虑时。能断烦恼语言寻伺喜乐色想等随烦恼。静虑所治。是名第一。即此静虑能作自己菩提资粮及所依止。亦即能作同事摄事成熟有情。是名第二。现法乐住以自饶益。其心寂静最极寂静远离贪爱。于诸有情无损无恼以饶益他。是名第三。由此因缘智得清净能发神通。于当来世生净天处得静虑果。是名第四。是名静虑威力四相。此外无有若过若增。般若四相者。谓诸菩萨具足妙慧能断无明。慧所对治。是名第一。即此般若能作自己菩提资粮。能以布施爱语利行同事摄事成熟有情。是名第二。于所知事如义觉了。能引广大清净欢喜。以自饶益。普为有情称理说法。令其获得现法当来利益安乐。以饶益他。是名第三。由是因缘摄诸善根能正所作。于当来世能证二障离系。谓烦恼障离系。及所知障离系。是名第四。是名般若威力四相。此外无有若过若增。是名法威力

云何诸佛菩萨俱生威力。谓性能忆念诸本生事。为欲利益诸有情故不由思择。于极长时种种猛利无间大苦悉能堪忍。为欲利益诸有情故欣乐领受。能办有情利益事。苦为欲利益诸有情故。上生第四睹史多天。尽睹史多寿量而住。有三胜事映彼受生诸天子众。一天寿量。二天形色。三天名称。将欲下生入母胎时。放大光明普照世界。于降母胎入住出位皆正了知。既出胎已即于地上不待扶侍。而行七步自称德号。于初生时有大威德天龙药叉健达缚。阿素洛揭路荼。紧捺洛牟呼洛伽等。散以种种天妙华香。持天伎乐上妙衣服幢幡宝盖殊胜供具而为供养。又以无上三十二大丈夫相等庄严其身。住最后有最后生中。一切怨敌一切魔军一切灾横不能侵害。坐菩提座以慈定力摧伏众魔。一一支节皆悉备足那罗延力。于稚童时不由习学。自然善巧于诸世间工巧业处疾疾能入。无师自然独处三千大千世界。证得无上正等菩提。索诃界主大梵天王自然来下。殷勤劝请哀愍世间宣说正法。其定寂静。设大云雷曾无觉受安然不起。为菩萨时。一切禽兽蠕动之类。皆极仰信常来归趣。随其所欲亲附而住。既成佛已下至傍生亦来供养。如彼猕猴献清净蜜。世尊哀受欢喜舞跃。龙云常候洗便降雨。若出游行止而不落。菩萨如是。若坐树下一切枝条并皆垂影。随荫其身曾无亏舍。证菩提已于六年中魔求其便竟不能得。常俱行念每恒现前。由此念故受想寻思生住灭等无不觉了。又佛成就俱生威力。或有见便饶益所摄。或有贤圣行住所摄。见便饶益所摄俱生威力者。谓诸世间若见如来。癫痫心乱还得本心。逆胎得顺。盲者得视聋者能听。怀贪欲者得离贪缠。怀嗔恚者得离嗔缠。怀愚痴者得离痴缠。如是等类当知是名见便饶益所摄俱生威力。贤圣行住所摄俱生威力者。谓佛菩萨常右胁卧如师子王。虽现安处草叶等蓐。一胁而卧曾无动乱。一切如来应正等觉虽现睡眠而无转侧。大风卒起不动身衣。行如师子步若牛王。先举右足方移左足。随所行地高处便下。下处遂高坦然如掌。无诸砾石塼瓦等物。心专远离而入聚落。随所入门门若狭小自然高广。食所食时有粒皆碎无口不殚。如是等类当知。是名贤圣行住所摄俱生威力。般涅槃时大地振动。众星晃耀交流而陨。诸方一时欻然大热。遍满虚空奏天大乐。如是无量甚希有事。皆是如来俱生威力。非是神通威力所作。如是名为诸佛菩萨俱生威力

云何诸佛菩萨威力。与声闻独觉有共不共。略由三相应知不共。一者微细故。二者品类故。三者界故。诸佛菩萨于无量无数诸有情类。及无量无数威力方便如所应作诸利益事。皆如实知无不能作。是名微细。一切品类神通威力法威力俱生威力悉皆成就。是名品类。以一切世界一切有情界为威力境。是名为界。声闻但以二千世界及有情界为神通境。独觉但以三千世界为神通境。何以故。由彼唯为调伏一身而修正行。非诸有情。是故最极唯以一界为神通境。除上所说。所余诸佛菩萨威力。当知粗相与诸声闻独觉等共。如是诸佛菩萨威力。声闻独觉尚不能及。何况所余一切天人异生外道

诸佛菩萨略有三种神变威力。一者神境神变所摄。二者记说神变所摄。三者教诫神变所摄。当知此三如其所应摄入三种神通威力。谓神境智通威力。心差别智通威力。漏尽智通威力

    本地分中菩萨地第十五初持瑜伽处成熟品第六

云何成熟。当知成熟略有六种。一者成熟自性。二者所成熟补特伽罗。三者成熟差别。四者成熟方便。五者能成熟补特伽罗。六者已成熟补特伽罗相

云何成熟自性。谓由有善法种子及数习诸善法故。获得能顺二障断净增上。身心有堪任性极调善性。正加行满安住于此。若遇大师不遇大师。皆有堪任有大势力。无间能证烦恼障断所知障断。譬如痈痤熟至究竟无间可破。说名为熟。又如瓦器熟至究竟无间可用。说名为熟。又如众果熟至究竟无间可啖。说名为熟。如是由有善法种子及数修习诸善法故。获得能顺。广说乃至正加行满。无间能证二障清净。说名成熟。如是名为成熟自性

云何所成熟补特伽罗。谓所成熟补特伽罗略有四种。一者住声闻种姓。于声闻乘应可成熟补特伽罗。二者住独觉种姓。于独觉乘应可成熟补特伽罗。三者住佛种姓。于无上乘应可成熟补特伽罗。四者住无种姓。于住善趣应可成熟补特伽罗。诸佛菩萨于此四事。应当成熟如是四种补特伽罗。是名所成熟补特伽罗

云何成熟差别。谓此差别略有六种。一诸根成熟。二善根成熟。三智慧成熟。四下品成熟。五中品成熟。六上品成熟。诸根成熟者。谓寿量具足形色具足。族姓具足自在具足。信言具足大势具足。人性具足大力具足。此依身果异熟具足为所依故。堪任发起勇猛精进修诸善法。于勤修集一切明处心无厌倦。善根成熟者。谓性薄尘垢为所依止。性于诸恶不善法中心不乐入。诸盖轻微寻思薄弱。柔和正直随顺而取。智慧成熟者。谓具足正念为性聪敏。有所堪任有大势力。能解善说恶说法义。能受能持能正通达。具足成熟俱生妙慧。依此妙慧有所堪任有大势力。能令其心究竟解脱一切烦恼。当知此中诸根成熟故解脱异熟障。善根成熟故能解脱业障。智慧成熟故解脱烦恼障下品成熟者。谓二因缘下品成熟。一者未久修习诸根善根。智慧成熟因缘未极增长。二者串习下劣因缘。中品成熟者。谓即于此二种因缘。随一阙减随一具足。上品成熟者。谓二因缘俱无阙减。

云何成熟方便。当知此有二十七种。一者界增长。二者现缘摄受。三者趣入。四者摄乐。五者初发处。六者非初发处。七者远清净。八者近清净。九者加行。十者意乐。十一者财摄受。十二者法摄受。十三者神通引摄。十四者宣说正法。十五者隐密说法。十六者显了说法。十七者下品加行。十八者中品加行。十九者上品加行。二十者听闻。二十一者思惟。二十二者修习。二十三者摄受。二十四者降伏。二十五者自成熟。二十六者请他成熟。二十七者俱成熟界。增长者。谓本性善法种子具足为所依止。先来串习诸善法故。后后位中善法种子转增转胜生起坚住。是名界增长。现缘摄受者。谓于现法中无倒说法无倒受持。如理修行法随法行。当知界增长由先世因现在成熟。现缘摄受由现在因现在成熟。趣入者。谓得净信增上力故。或有在家远离恶行受持学处。或趣非家远离诸欲受持学处。摄乐者谓依出离众苦行迹。及依远离欲乐自苦二边行迹。于佛善说法毗奈耶真实圣教深生爱乐。初发处者。谓即最初于可厌法深生厌离于能成办真实理义。如实了知有胜功德而创趣入。名初发处。非初发处者。谓已趣入补特伽罗现成熟时。常不舍离诸佛菩萨诸明了处转转明了。由此成熟转转增进。远清净者。谓由懈怠或由违缘经极长时。或经多生或经多劫方能清净。近清净者。当知一切与此相违。加行者。谓为获得自胜义利。猛利乐欲为所依故。或怖当来堕诸恶趣。或怖现法他所讥毁。于诸学处常勤护持。无间所作殷重所作。意乐者。谓于诸法正观察忍为所依故。于佛善说法毗奈耶不可引夺。于他所证深生信解。信有功德为所依故。于三宝所及于获得自义利所。深信无动财摄受者。谓于一切饮食等物有匮乏者。施与一切饮食等物。或于随顺饮食等物有匮乏者。施与随顺饮食等物。法摄受者。谓或宣说正法施诸有情。或开显正义施诸有情。神通引摄者。谓具神通者。哀愍有情故。或为有情意乐清净。或为有情加行清净增上力故。示现种种神通变化。欲令有情见已闻已于佛圣教。或当获得意乐清净。或当修行无倒加行。彼诸有情由此神变引摄心故。或有获得意乐清净。或有修行无倒加行。宣说正法者。谓于获得自胜义利。若无堪能为说正法。伴助令彼发生正行。若有堪能为说正法。随顺令彼速证通慧。隐密说法者。谓于婴儿智慧有情。隐覆广大甚深义法。为说粗浅易可悟入。易为方便趣入处法。显了说法者。谓于广大智慧有情已善悟入圣教理者。为其开示广大甚深道理处法。下品加行者。谓若远离。间加行及殷重加行。中品加行者。谓或远离无间加行。或复远离殷重加行。于二加行随阙一种。上品加行者。谓无间加行及殷重加行。二俱相应。听闻者。谓于佛语深生信解。精勤听闻受持读诵契经等法。思惟者。谓居远离乐思惟法。推度其义解了决定。修习者。谓于止举舍相正审观察为先。深心欣乐修止举舍。摄受者。谓无染心。以亲教师及轨范师。道理方便无有颠倒。与作依止。又即于彼发起种种别供事行。谓看病行。给施如法衣服饮食诸坐卧具病缘医药资生具行。除遣忧愁及恶作行。除遣烦恼随烦恼行。如是等类当知皆名别供事行。降伏者。谓深防护自身杂染。于毁犯者若犯下品慈心谏诲。若犯中品慈心诃罚。若犯上品慈心驱摈。当知此中谏诲诃罚。令彼及余利益安乐。驱摈一种若重摄受。令彼及余利益安乐。若驱摈已不重摄受。但令其余利益安乐。何以故。余若见彼毁犯因缘既被驱摈。便自防护不超毁犯故。自成熟者。谓自宣说随顺正法。令诸有情出不善处安立善处。如自所说。亦自修行法随法行。令诸有情同分随转。勿使他人作如是说。汝自不能出不善处安立善处。云何于他教授谏举为作忆念。他应于汝教授谏举为作忆念。请他成熟者。谓若有余无量有情。于彼发起上品爱敬。或复有余善知方便。于说正法已善修学。即应劝请殷勤营助令其成熟无量有情。俱成熟者。谓具二种。若自成熟。若劝请他令其成熟由此所说二十七种成熟方便。当知令前六种成熟差别圆满。所谓诸根成熟。善根成熟智慧成熟。下品成熟。中品成熟。上品成熟。

云何能成熟补特伽罗。谓略有六种菩萨。住菩萨六地能成熟有情。一切胜解行菩萨住胜解行地。二者净胜意乐菩萨住净胜意乐地。三者行正行菩萨住行正行地。四者堕决定菩萨住堕决定地。五者决定行正行菩萨住决定行正行地。六者到究竟菩萨住到究竟地。住无种姓补特伽罗。于往善趣而成熟时。有数退转有数应作。安住种姓补特伽罗。于往三乘而成熟时。无数退转无数应作。

云何已成熟补特伽罗相。谓诸声闻先已串习诸善法故。若时安住下品成熟。尔时便有下品欲乐下品加行。犹往恶趣。非于现法证沙门果。非于现法得般涅槃。若时安住中品成熟。尔时便有中品欲乐中品加行。不往恶趣。于现法中证沙门果。非于现法得般涅槃。若时安住上品成熟。尔时便有上品欲乐上品加行。不往恶趣。于现法中证沙门果。即于现法得般涅槃。如说声闻。独觉亦尔。何以故。道与声闻同种类故。而此独觉与诸声闻有差别者。谓住最后有最后所得身。无轨范师宿习力故。修三十七菩提分法。究竟断灭一切烦恼。证阿罗汉故名独觉。若诸菩萨住胜解行地名下品成熟。住净胜意乐地名中品成熟。住堕决定到究竟地名上品成熟。若时菩萨住下品成熟。尔时便有下品欲乐下品加行。犹往恶趣。此尽第一无数劫边际。炽然。无动。极善清净。觉品善法。当知一切皆未相应。若时菩萨住中品成熟。尔时便有中品欲乐中品加行。不往恶趣。此尽第二无数劫边际。炽然。无动。觉品善法。已得相应。极善清净。觉品善法。未得相应。若时菩萨住上品成熟。尔时便有上品欲乐上品加行。不往恶趣。此尽第三无数劫边际。炽然无动极善清净。觉品善法。当知一切皆悉成就。今于此中性淳厚故极猛盛故。能有上品广大果故大胜利故。名为炽然。不转还故不退堕故常胜进故。名为无动。菩萨地中最无上故。当知说名极善清净。

当知此中若财摄受所作成熟。若神通引摄所作成熟。若隐密说法所作成熟。若下品加行所作成熟。若唯听闻所作成熟。如是五种所作成熟。若于长时修习彼法。尚为下品。况于少时修习彼法。其余一切成熟因缘所作成熟。当知皆有三品道理。谓若于彼下品修习成下成熟。中品修习成中成熟。上品修习成上成熟。此下中上三品成熟。当知一一复有三品。于下品中。有下下下中下上三品成熟。于中品中。有中下中中中上三品成熟。于上品中。有上下上中上上三品成熟。如是等类诸佛菩萨成熟有情。当知展转差别道理有无量品。

此中菩萨由前所说成熟因缘。为欲成熟自佛法故。精勤修集诸根成熟。善根成熟。智慧成熟。下品成熟。中品成熟。上品成熟。又欲令他诸有情类补特伽罗。乘三乘法而出离故。往善趣故。修集如是六种成熟

瑜伽师地论卷第三十七瑜伽师地论卷第三十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处菩提品第七

云何菩提。谓略说二断二智。是名菩提。二断者。一烦恼障断。二所知障断。二智者。一烦恼障断故。毕竟离垢一切烦恼不随缚智。二所知障断故。于一切所知无碍无障智。复有异门。谓清净智一切智无滞智。一切烦恼并诸习气无余永害。遍一切种不染无明无余永断。是名无上正等菩提。一切烦恼并诸习气毕竟断故。名清净智。于一切界一切事一切品一切时智无碍转。名一切智。界有二种。一者世界。二者有情界。事有二种。一者有为。二者无为。即此有为无为二事无量品别。名一切品。谓自相展转种类差别故。共相差别故。因果差别故。界趣差别故。善不善无记等差别故。时有三种。一过去。二未来。三现在。即于如是一切界一切事一切品一切时如实知故。名一切智。无滞智者。暂作意时。遍于一切无碍速疾无滞智转。不由数数作意思惟。依一作意遍了知故。复有异门。谓百四十不共佛法。及如来无诤愿智无碍解等。是名无上正等菩提。百四十不共佛法者。谓三十二大丈夫相。八十随好。四一切种清净。十方。四无所畏。三念住。三不护。大悲。无忘失法。永害习气。一切种妙智。是诸佛法建立品中当广分别。如是菩提名为最胜。

七种最胜共相应故。由是因缘于诸菩提最为殊胜。云何名为七种最胜。一者所依最胜。二者正行最胜。三者圆满最胜。四者智最胜。五者威力最胜。六者断最胜。七者住最胜。由诸如来以三十二大丈夫相等庄严其身故。名所依最胜。由诸如来自利利他利益安乐无量众生。哀愍世间令诸天人获得义利利益安乐而行正行故。名正行最胜。由诸如来无上无等四种圆满。谓戒圆满。见圆满。轨则圆满。净命圆满。皆悉成就故。名圆满最胜。由诸如来无上无等四无碍解。谓法无碍解。义无碍解。训词无碍解。辩说无碍解。皆悉成就故。名智最胜。由诸如来无上无等如前所说六种神通皆悉成就故。名威力最胜。由诸如来无上无等一切烦恼习气永断。及一切所知障永断。皆悉成就故。名断最胜。由诸如来多住无上无等三住。谓圣住天住梵住。故名住最胜。当知此中空无愿无相住及灭尽定住。是名圣住。四种静虑四无色定。是名天住。四种无量。是名梵住。于此三住中。如来多住四最胜住。谓于圣住中多住空住灭尽定住。于天住中多住无动第四静虑住。于梵住中多住大悲住。由是如来昼夜六时昼三夜三。常以佛眼观察世间。谁增谁减。我应令谁未起善根而种善根。广说乃至我应令谁建立最胜阿罗汉果。又诸如来所依最胜故名大丈夫。正行最胜故名大悲者。圆满最胜故名大戒者及大法者。智最胜故名大慧者。威力最胜故名大神通者。断最胜故名大解脱者。住最胜故名多安住广大住者

又诸如来略有十种功德名号随念功德。何等为十。谓薄伽梵号为如来。应正等觉。明行圆满。善逝。世间解。无上丈夫。调御士。天人师。佛。薄伽梵。言无虚妄故名如来。已得一切所应得义。应作世间无上福田。应为一切恭敬供养。是故名应。如其胜义觉诸法故。名正等觉。明谓三明。行如经说。止观二品极善圆满。是故说名明行圆满。上升最极永不退还。故名善逝。善知世界及有情界一切品类染净相故。名世间解。一切世间唯一丈夫。善知最胜调心方便。是故说名无上丈夫调御士。为实眼故为实智故。为实义故为实法故。与显了义为开导故。与一切义为所依故。与不了义为能了故。与所生疑为能断故。与甚深处为能显故。令明净故。与一切法为根本故。为开导故为所依故。能正教诫教授天人。令其出离一切众苦。是故说佛名天人师。于能引摄义利法聚。于能引摄非义利法聚。于能引摄非义利非非义利法聚。遍一切种现前等觉。故名为佛。能破诸魔大力军众。具多功德。名薄伽梵。

或有多劫无有一佛出现于世。或有一劫有众多佛出现于世。彼彼十方无量无数诸世界中。应知同时有无量佛出现于世。何以故。于十方界现有无量无数菩萨。同时发愿。同勤修集菩提资粮。若一菩萨于如是日于如是分。于如是月于如是年。发菩提心愿趣菩提。即于此日即于此分。即于此月即于此年。一切亦尔。如一菩萨勇悍策励炽然精进。一切亦尔。于今现见此世界中多百菩萨。同时发愿。同修惠施同修净戒。同修忍辱同修精进。同修静虑同修智慧。况于十方无量无边诸佛世界。又于十方现有无量无数三千大千佛土。无二菩萨同时修集菩提资粮。俱时圆满。于一佛土并出于世一时成佛。况有无量无数菩萨。于一世界一时成佛。又不应言众多菩萨同时修集菩提资粮。俱时圆满。前后相避次第成佛。亦不应言一切菩萨皆不成佛。是故当知众多菩萨同时修集菩提资粮。俱圆满者。于十方面无量无数随其所净空无如来诸佛国土。各别出世同时成佛。由此道理多世界中决定应有众多菩萨同时成佛。决定无有一佛土中有二如来俱时出世。何以故。菩萨长夜起如是愿随令增长。我当独一于无导首诸世界中。为作导首。调伏有情令脱众苦令般涅槃。如是长夜所起大愿随令增长。摄受正行得成满故。无二如来于一世界俱时出现。又一如来于一三千大千佛土。普能施作一切佛事。是故第二如来出世无所利益。又一如来于一佛土出现于世。令诸有情成办自义极为炽盛极为随顺。何以故。彼作是思。一切世间唯一如来更无第二。若于此土化事已讫。或往余方或入灭度。我等何从当修梵行。我等何从当闻正法。如是思已发起深厚欲勤精进。速修梵行速闻正法。若一佛土多佛出世。彼于所作不能速疾。故一佛土一佛出世。令诸有情成办自义极为炽盛极为随顺。一切如来一切功德。平等平等无有差别。

唯除四法。一者寿量。二者名号。三者族姓。四者身相。一切如来于此四法有增减相。非余功德。又非女身能证无上正等菩提。何以故。一切菩萨于过第一无数劫时已舍女身。乃至安坐妙菩提座。曾不为女一切母邑性多烦恼性多恶慧。非诸禀性多烦恼身多恶慧身能证无上正等菩提。如是无上正等菩提。

如说自性应如实知。如说最胜应如实知。如说十种功德名号随念功德。应如实知如说出现应如实知。如说差别应如实知。

又此菩提为不思议超过一切寻思道故。为无有量无边功德所集成故。为无有上生成一切声闻独觉及与如来诸功德故。是故唯佛所证菩提。最上最尊最妙最胜

    本地分中菩萨地第十五初持瑜伽处力种姓品第八

已说菩萨所应学处。如是应学。我今当说。嗢拖南曰

  胜解多求法　　说法修法行
  正教授教诫　　方便摄三业

若诸菩萨欲于菩萨所应学处精勤修学。最初定应具多胜解。应求正法应说正法。应正修行法随法行。应正教授应正教诫。应住无倒教授教诫方便所摄身语意业

云何菩萨具多胜解。谓诸菩萨于其八种胜解依处。具足成就净信为先。决定喜乐。一者于三宝功德胜解依处。具足成就净信为先。决定喜乐。谓于佛法僧真实功德。具多胜解。二者于佛菩萨威力胜解依处。具足成就净信为先。决定喜乐。谓于如前所说威力。具多胜解。三者于真实义胜解依处。具足成就净信为先。决定喜乐。谓于如前所说真实义。具多胜解。四者于因缘解依处。具足成就净信为先。决定喜乐。谓于种种如应所摄无颠倒因。具多胜解。五者于果胜解依处。具足成就净信为先。决定喜乐。谓于种种如应所摄无颠倒果。具多胜解。六者于应得义胜解依处。具足成就净信为先。决定喜乐。谓于无上正等菩提所应得义。我有堪任定当能得。具多胜解。七者于得方便胜解依处。具足成就净信为先。决定喜乐。谓于一切菩萨学道能得方便。有此方便得应得义。具多胜解。八者于善言善语善说胜解依处。具足成就净信为先。决定喜乐。谓于契经应颂记别等法。具多胜解。于此八种胜解依处。应知菩萨由二因缘具多胜解。一者多修胜解故。二者积集猛利忍故

彼诸菩萨求正法时。当何所求云何而求何义故求。谓诸菩萨以要言之。当求一切菩萨藏法声闻藏法一切外论一切世间工业处论。当知于彼十二分教。方广一分唯菩萨藏。所余诸分有声闻藏。一切外论略有三种。一者因论。二者声论。三者医方论。一切世间工业处论。非一众多种种品类。谓金师铁师末尼师等工业智处。如是一切明处所摄有五明处。一内明处。二因明处。三声明处。四医方明处。五工业明处。菩萨于此五种明处若正勤求。则名勤求一切明处。诸佛语言名内明论。此几相转。如是乃至一切世间工巧业处名工业明论。此几相转。谓内明论略二相转。一者显示正因果相。二者显示已作不失未作不得相。因明论亦二相转。一者显示摧伏他论胜利相。二者显示免脱他论胜利相。声明论亦二相转。一者显示安立界相能成立相。二者显示语工胜利相。医方明论四种相转。一者显示病体善巧相。二者显示病因善巧相。三者显示断已生病善巧相。四者显示已断之病当不更生善巧相。一切世间工业明论。显示各别工巧业处所作成办种种异相。云何内明论显示因果相。谓有十种因。当知建立无颠倒因摄一切因。或为杂染或为清净。或为世间彼彼稼穑等无记法转。云何十因。一随说因。二观待因。三牵引因。四摄受因。五生起因。六引发因。七定别因。八同事因。九相违因。十不相违因。谓一切法名为先故想。想为先故说。是名彼诸法随说因。观待此故此为因故。于彼彼事若求若取。此名彼观待因。如观待手故手为因故有执持业。观待足故足为因故有往来业。观待节故节为因故有屈申业。观待饥渴故饥渴为因故于诸饮食若求若取。随如是等无量道理。应当了知观待因相。一切种子望后自果。名牵引因。除种子外所余诸缘。名摄受因。即诸种子望初自果。名生起因。即初种子所生起果。望后种子所牵引果。名引发因。种种异类各别因缘。名定别因。若观待因。若牵引因。若摄受因。若生起因。若引发因。若定别因。如是诸因总摄为一。名同事因。于所生法能障碍因。名相违因。此障碍因若阙若离。名不相违因。当知相违略有六种。一语言相违。谓有一类或诸沙门或婆罗门所造诸论前后相违。二道理相违。谓为成立。诸所成立诸所知义。建立比量不与证成道理相应。三生起相违。谓所生法能生。缘阙障生缘会。四同处相违。谓明闇贪嗔苦乐等法。五怨敌相违。谓毒蛇鼠狼猫狸鼷鼠互为怨敌恶知识等。六障治相违。谓修不净与诸贪欲。修慈与嗔。修悲与害。修七觉支八圣道支与三界系一切烦恼。于此义中正意唯取生起相违。此一切因二因所摄。一能生因。二方便因。当知此中牵引种子生起种子名能生因。所余诸因名方便因。复有四缘。一因缘。二等无间缘。三所缘缘。四增上缘。当知此中若能生因是名因缘。若方便因是增上缘。等无间缘及所缘缘。唯望一切心心法说。由彼一切心及心法前生开导所摄受故。所缘境界所摄受故。方生方转。是故当知等无间缘及所缘缘。摄受因摄。如是十因。云何能令一切世间种种事转。云何能令杂染事转。云何能令清净事转。谓于世间种种稼穑。堕诸谷数世资生物。所有种种名想言说。谓大麦小麦稻谷胡麻大小豆等。即此望彼种种稼穑。为随说因。如言大麦持去持来若磨若置。如是等类种种随说。如说大麦。余小麦等当知亦尔。观待饥渴。羸劣身住观待。段食所有爱味。于彼追求执取受用。即说彼法为观待因。由彼各别自种子故。种种稼穑差别而生。即说彼种子为此牵引因。地雨等缘能生于芽。名摄受因。即彼种子望所生芽。名生起因。芽茎叶等展转相续。望彼稼穑若成若熟。为引发因。从大麦种生大麦芽大麦苗稼。不生余类。如是所余当知亦尔。即说彼为此定别因。即彼一切从观待因至定别因。同为稼穑而得成熟。名同事因。非彼稼穑随阙一因而得成熟。是故一切和合。说为此同事因。霜雹灾等诸障碍法。望彼滋稼。为相违因。彼阙无障是诸滋稼。不相违因。如是十因。于余世间种种事物。随其所应当知。广如摄谷论说。又于一切杂染。缘起所有种种名想言说。谓无明行识名色。广说乃至老死愁悲忧苦扰恼。即此望彼诸杂染法。为随说因。如言无明缘行乃至生缘老死。如是等类种种随说。观待境界所有爱味。于诸有支相续流转。即彼望此诸杂染法。为观待因。于现法中无明等法。所有已生已长种子。今此种子望于余生生老死等。为牵引因。近不善士闻不正法非理作意。及先串习所引势力生无明等。名摄受因。无明等法各别种子。名生起因。从无明支乃至有支。展转引发后后相续。望于余生生老死等。为引发因。余无明支及自种子乃至有支。能生那洛迦。余无明支及自种子乃至有支。能生傍生饿鬼人天当知亦尔。即此望彼诸杂染法。名定别因。即彼一切从观待因至定别因。名同事因。此杂染法相违因者。谓出世间种姓具足。值佛出世演说正法。亲近善士听闻正法如理作意。法随法行及与一切菩提分法。即如所说种种善法若阙若离。是杂染法不相违因。如是十因。应知能起一切有情一切杂染。又于一切清净品法及灭涅槃。所有种种名想言说。即此望彼诸清净法。为随说因。如言念住正断乃至八圣道支无明灭故行灭。广说乃至生灭故老死灭。如是等类种种随说。观待诸行多过患故。乐求清净摄受清净。成满清净。彼望于此。为观待因。安住种姓补特伽罗。种姓具足能为上首。证有余依及无余依二涅槃界。彼望清净。为牵引因。亲近善士听闻正法如理作意。及先所作诸根成熟。名所受因。种姓所摄一切无漏菩提分法所有种子。望彼一切菩提分法。为生起因。即自种子所生一切菩提分法。渐次能证若有余依若无余依二涅槃界。名引发因。声闻种姓以声闻乘能般涅槃。独觉种姓以独觉乘能般涅槃。大乘种姓以无上乘能般涅槃。彼望清净。为定别因。若清净品观待因乃至定别因。彼望清净。为同事因。种姓不具足。不值佛出世。生诸无暇处。不亲近善士。不听闻正法。不如理作意。数习诸邪行。彼望清净。为相违因。此相违因若阙若离。是名清净不相违因。若杂染品诸相违因。当知即是清净法因。若清净品诸相违因。当知即是杂染法因。如是现有杂染十因清净十因。过去未来曾当染净皆亦如是。一切唯有如是十因。除此无有若过若增。于此相中云何为果。谓略有五。一者异熟果。二者等流果。三者离系果。四者士用果。五者增上果。诸不善法于诸恶趣受异熟果。善有漏法于诸善越受异熟果。是名异熟果。习不善故乐住不善不善法增。修习善故乐住善法善法增长。或似先业后果随转。是名等流果。八支圣道灭诸烦恼。名离系果。若诸异生以世俗道灭诸烦恼不究竟故。非离系果。诸有一类于现法中。依止随一工巧业处起士夫用。所谓农作商贾事。王书画算数占卜等事。由此成办诸稼穑等财利等果是。名士用果。若眼识等是眼根增上果。乃至意识等是意根增上果。众生身分不散不坏。是命根增上果。二十二根各各能起自增上果。当知一切名增上果。二十二根增上作用。如摄事分应知其相。菩萨于是内明所显正因果相。如实知已精勤修习。令处非处智力种姓渐得清净渐得增长。云何内明论显示已作不失未作不得相。谓诸有情自所作业。虽复作已经多百劫。与果功能终无失坏亦无不作。或复异作而有异熟或异果熟。菩萨于是内明所显已作不失未作不得相。如实知已精勤修习。令其自业智力种姓渐得清净渐得增长。菩萨云何求闻正法。谓诸菩萨于善说法。应当安住猛利爱重求闻正法如是略说于善说法安住猛利爱重之相。谓诸菩萨为欲听闻一善说法。假使路由猛焰炽然大热铁地。无余方便可得闻是善说法者。即便发起猛利爱重欢喜而入。何况欲闻多善言义。又诸菩萨于自身分。及于一切资身众具饮食等事所有爱重。于欲听闻诸善说法所有爱重。以前爱重方后爱重。于百分中不及其一。于千分中亦不及一。于数分中亦不及一。于算分中亦不及一。乃至邬波尼杀昙分亦不及一。菩萨如是于善说法深生敬重。常乐听闻诸善说法。无有劳倦亦无厌足。净信淳厚其性柔和心直见直。爱敬德故爱敬法故。往法师所无难诘心。有敬重心无高慢心。专为求善非显己德。为欲安立自他善根。不为利养恭敬因缘。菩萨具足如是功德。往法师所无杂染心无散乱心听闻正法。云何菩萨无杂染心听闻正法。谓听法时其心远离贡高杂染其心。远离轻慢杂染其心。远离怯弱杂染。由六种相其心远离贡高杂染。由四种相其心远离轻慢杂染。由一种相其心远离怯弱杂染。谓听法时。应时而听殷重而听恭敬而听。不为损害不为随顺不求过失。由此六相其心远离贡高杂染。又听法时。恭敬正法恭敬说法补特伽罗。不轻正法不轻说法补特伽罗。由此四相其心远离轻慢杂染。又听法时。不自轻蔑。由此一相其心远离怯弱杂染。菩萨如是无杂染心听闻正法。云何菩萨无散乱心听闻正法。谓由五相。一者求悟解心听闻正法。二者专一趣心听闻正法。三者聆音属耳听闻正法。四者扫涤其心听闻正法。五者摄一切心听闻正法。菩萨如是求闻正法。菩萨何故求闻正法。谓诸菩萨求内明时。为正修行法随法行。为广开示利悟于他

若诸菩萨求因明时。为欲如实了知外道所造因论是恶言说。为欲降伏他诸异论。为欲于此真实圣教未净信者。令其净信。已净信者。倍令增广。若诸菩萨求声明时。为令信乐典语众生于菩萨身深生敬信。为欲悟入诂训言音文句差别于一义中种种品类殊音随说。若诸菩萨求医明时为息众生种种疾病。为欲饶益一切大众。若诸菩萨求诸世间工业智处。为少功力多集珍财。为欲利益诸众生故。为发众生甚希奇想。为以巧智平等分布饶益摄受无量众生。菩萨求此一切五明。为令无上正等菩提大智资粮速得圆满。非不于此一切明处次第修学能得无障一切智智。如是已说一切菩萨正所应求。如是而求为此义求

菩萨为他说正法时。当何所说。云何而说。何义故说。谓诸菩萨正所应求即是所说。为此义求即为此义而为他说。依二种相应为他说。一者依随顺说应为他说。二者依清净说应为他说。云何依随顺说应为他说。谓诸菩萨应当安住如法威仪而为他说。非不安住如法威仪。不为无病处高座者而说正法。不为坐者立说正法。不应居后为前行者而说正法。不为覆头而说正法。如别解脱经广说应知。何以故。诸佛菩萨敬重法故。又于正法生尊重时。令他于法起极珍贵恭敬听闻而不轻毁。又为一切说一切法无间而说。又于正法不生悭吝不作师拳。又于正法如其文句次第而标。如其文句次第而释。如其次第分别其义。又若引摄义利法义。应标应释应广分别。非不引摄义利法义。又应示现所应示现。又应教导所应教导。又应赞励所应赞励。又应庆慰所应庆慰。又依现比至教道理而说正法。非不依彼三量道理。又所宣说顺往善趣。又所宣说无乱易入而不隐密。又所宣说应四圣谛。又处一切众说正法时。随众所应而为宣说。菩萨依此十五种相。诸随顺说普为利他。应如是说。云何依清净说应为他说。谓诸菩萨于己有怨诸有情类。应住慈心为说正法。于行恶行诸有情类。住利益心应说正法。于诸有乐有苦放逸下劣有情。应当安住利益安乐哀愍之心为说正法。不以嫉缠增上力故自赞毁他。以无染心不希利益恭敬赞颂为他说法。菩萨依止此五种相。诸清净说普为利他。应如是说。如是菩萨说正法相。略有二十。一者以时。二者重法。三者次第。四者相续。五者随顺。六者欢喜。七者爱乐。八者悦豫。九者欣勇。十者不摈。十一者应理。十二者称顺。十三者无乱。十四者如法。十五者顺众。十六者慈心。十七者利益心。十八者哀愍心。十九者不自赞毁他。二十者不依利养恭敬赞颂。菩萨如是应常为他宣说正法

云何菩萨法随法行。当知此行略有五种。谓如所求如所受法。身语意业无倒随转。正思正修。若佛世尊于彼诸法制身语意令不造作。于此诸法开身语意令其造作。即于如是二种法中。身语意业无倒远离无倒修证。是名菩萨于诸法中身语意业无倒随转法随法行。云何菩萨于法正思。谓诸菩萨独居闲静。随所闻法乐欲思惟。乐欲称量乐欲观察。先当远离不思议处思惟彼法。恒常思惟无间加行殷重加行而无慢缓。是诸菩萨勇猛精进思惟法时。于其少分以理观察而随悟入。于其少分但深信解。凡所思惟但依其义不依其文。如实了知黑说大说。正能悟入最初思惟。既悟入已数数作意令得坚固。是诸菩萨由能远离不应思议而思惟故。其心不堕迷闷错乱。由能恒常无间殷重加行无缓而思惟故。先未知义得正了知得正决了。先已知义得无失坏得不忘失。由于少分以理观察随悟入故。于随正理观察法中不由他缘。由于少分但信解故。于极甚深自少觉慧不能达法。仰推如来言如是法是佛所行非我境界。如是于法不生诽谤不自损害。远离衰患无诸过罪。由诸菩萨思惟法时但依其义不依文故。于佛世尊一切所说密意语言。能随悟入。由诸菩萨普于一切黑说大说得善巧故。于真实义无物无法能倾能动。是诸菩萨正能悟入初思惟故。能得先来所未得忍。是诸菩萨由即于此已所得忍数数作意令坚牢故。能于其修随顺趣入。菩萨由是八种相故。能正修行正思所摄法随法行。云何菩萨于法正修。当知此修略有四相。一者奢摩他。二者毗钵舍那。三者修习奢摩他毗钵舍那。四者乐修习奢摩他毗钵舍那。云何奢摩他。谓诸菩萨由八种思善依持故。于离言说唯事唯义所缘境中系心令住。离诸戏论离心扰乱想作意故。于诸所缘而作胜解。于诸定相令心内住安住等住。广说乃至一趣等持。是名奢摩他。云何毗钵舍那。谓诸菩萨由奢摩他熏修作意。即于如先所思惟法思惟其相。如理简择最极简择。极简择法广说乃至觉明慧行。是名毗钵舍那。云何修习奢摩他毗钵舍那。谓诸菩萨于奢摩他毗钵舍那。无间加行殷重加行恒常修习。是名修习奢摩他毗钵舍那。云何乐修习奢摩他毗钵舍那。谓诸菩萨即于如是止观相中。其心无动。于无功用离诸加行。任运转处摄受无乱。是名乐修习奢摩他毗钵舍那。当知此中是诸菩萨如如修习奢摩他毗钵舍那。如是如是乐住奢摩他毗钵舍那。如如乐住奢摩他毗钵舍那。如是如是奢摩他毗钵舍那清净。如如奢摩他清净。如是如是身安心安增长广大。如如毗钵舍那清净。如是如是若智若见增长广大。齐此名为修所应作。谓于所依中应除遣粗重。及于一切所知应修清净智见。如是一切修所作业。菩萨由前四种修相皆能成办。

云何教授。当知教授略有八种。谓诸菩萨或三摩地为依止故。或于长时共彼住故。于彼慈悲欲为教授。或由其余诸菩萨众。或由如来为作教授。于教授时先当审谛寻思其心。如实了知寻思。如实了知心已寻思其根。如实了知寻思。如实了知根已寻思意乐。如实了知寻思。如实知意乐已寻思随眠。如实了知寻思。如实知随眠已。如其所应随其所宜。示现种种所趣入门令其趣入。谓或修不净。或复修慈。或修种种缘性缘起。或修界差别。或修阿那波那念。如其所应随其所宜。示现种种所趣入门令趣入已。为说能治常边邪执处中之行。为说能治断边邪执处中之行。令其除舍未作谓作。未得谓得。未触谓触。未证谓证。诸增上慢。如是菩萨八种教授。当知略说三处所摄。云何三处。一未住心者为令住故。令于所缘无倒系念。二心已住者为令获得自义利故。为其宣说正方便道。三于自所作未究竟者。令舍中间所有留难。若知彼心根意乐随眠已。如其所应随其所宜。示现种种所趣入门令其趣入。当知是名未住心者为令住故令于所缘无倒系念。若为宣说能治断常二边邪执处中之行。当知是名心已住者为令获得自义利故为其宣说正方便道。若令除舍未作谓作广说乃至未证谓证诸增上慢。当知是名于自所作未究竟者令舍中间所有留难。如是三处。当知能摄八种教授。如是菩萨或由从他得正教授。或由施他无倒教授。能令所余八力种姓渐得清净渐得增长。谓静虑解脱等持等至智力种姓。诸根胜劣智力种姓。种种胜解智力种姓。种种界智力种姓。遍趣行智力种姓。宿住随念智力种姓。死生智力种姓。漏尽智力种姓。

云何教诫。当知教诫略有五种。一者遮止有罪现行。二者开许无罪现行。三者若有于所遮止开许法中暂行犯者。如法谏诲。四者若有于彼法中数数轻慢而毁犯者。以无染浊无有变异亲善意乐。如法呵摈与作忆念。五者若有于所遮止开许法中能正行者。慈爱称叹真实功德。令其欢喜。当知是名略说菩萨五种教诫。所谓遮止。开许。谏诲。呵摈。庆慰。

云何菩萨方便所摄身语意业。当知略说菩萨所有四种摄事。是名方便。如世尊言。菩萨成就四种摄事所摄方便。方名菩萨。复何因缘惟四摄事说名方便。谓诸菩萨略由如是摄事所摄四种方便。于诸有情普能摄受调伏成熟。除此无有若过若增。何等名为四种方便。一随摄方便。二能摄方便。三令入方便。四随转方便。若诸菩萨先行布施。当知是名随摄方便。何以故。先以种种财物布施饶益有情。为欲令彼听受所说奉教行故。若诸菩萨次行爱语。于彼彼处有愚痴者。为欲除彼所有愚痴令无余故。令其摄受瞻察正理。如是爱语。当知名为能摄方便。若诸菩萨知彼有情摄受瞻察正道理已。次行利行拔彼有情出不善处。于其善处劝导调伏安处建立。如是利行。当知名为令入方便。若诸菩萨如是方便。令诸有情得趣入已。最后与其于正事业同共修行令彼随转。由是因缘令所化者不作是说。汝自无有圆满净信。圆满尸罗。圆满惠舍。圆满智慧。何赖于善劝导于他谏诲呵摈与作忆念。是故菩萨所行第四同事摄事。当知是名随转方便。如是菩萨四种方便若总若别所摄身业语业意业。是名方便所摄三业于诸有情能正摄受调伏成熟

瑜伽师地论卷第三十八瑜伽师地论卷第三十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处施品第九

复次菩萨次第圆满六波罗蜜多已。能证无上正等菩提。谓施波罗蜜多。戒波罗蜜多。忍波罗蜜多。精进波罗蜜多。静虑波罗蜜多。慧波罗蜜多

云何菩萨施波罗蜜多。嗢拖南曰

  自性一切难　　一切门善士
  一切种遂求　　二世乐清净
  如是九种相　　是名略说施

谓九种相施名为菩萨施波罗蜜多。一自性施。二一切施。三难行施。四一切门施。五善士施。六一切种施。七遂求施。八此世他世乐施。九清净施

云何菩萨自性施。谓诸菩萨于自身财无所顾惜。能施一切所应施物。无贪俱生思。及因此所发。能施一切无罪施物。身语二业安住律仪阿笈摩见定有果见。随所希求即以此物而行惠施。当知是名菩萨自性施

云何菩萨一切施。谓一切者略有二种。一内所施物。二外所施物。若诸菩萨但舍己身。是名唯施内所施物。若诸菩萨为愍食吐活命众生。数数食已吐所饮食而施与之。是名杂施内外施物。若诸菩萨除上所说施。余一切所应施物。是名唯施外所施物。又诸菩萨略由二相。以自内身施来求者。一总求身者以身施彼。随所欲为系属于彼随顺于彼。譬如有人为衣食故强自为他而作仆使。如是菩萨无爱染心。但为速证最胜菩提。但为众生利益安乐。但为布施波罗蜜多速圆满故。以身施彼随所欲为系属于彼随顺于彼。二别求手足头目支节血肉筋骨乃至髓者。随其所欲一切施与。又诸菩萨亦由二相。以外施物施诸众生。一求受用者。恣彼所须如其所乐随意受用。二求自在者。一切断心并皆施与。又诸菩萨非无差别。以一切种一切内外所有施物施诸众生。是诸菩萨以其种种内外施物。于诸众生或有施与或不施与。云何施与云何不施。谓诸菩萨若知种种内外施物。于彼众生唯令安乐不作利益。或复于彼不作安乐不作利益。便不施与。若知种种内外施物于彼众生定作利益不定安乐。或复于彼定作利益定作安乐。即便施与如是略说菩萨应施不应施已。次当广辩。谓诸菩萨若有来求共为伴侣欲作非理逼迫损害诳惑。于他便不以身而施于彼。随所欲为系属于彼随顺于彼。由诸菩萨宁于百反千反或百千反。舍自身命施诸众生。终不随他教命称悦彼情于诸众生非理逼迫损害诳惑。若诸菩萨于所行施意乐清净。见有无量利众生事正现在前。设有来求自身支节。不应施与。何以故。非彼菩萨于所行施意乐不净心生退弱。作是念言。此应可施此不可施。此应施与此不应与故。彼菩萨为令意乐得清净故。须舍现前利众生事而施身分。由彼意乐已清净故。不应弃舍正现在前利众生事而施身分。又诸菩萨若魔众天怀恼乱心。现前来乞身分支节。不应分碎支节施与。何以故。勿彼当获上品过罪及损害故。如魔众天。如是于彼所使众生当知亦尔。或有众生痴狂心乱。来求菩萨身分支节。亦不应碎支节施与。何以故。由彼不住自性心故。不为义利而求乞故。其心狂乱不自在故。空有种种浮妄言说。是故不应施彼身分。除上所说与上相违。来求菩萨身支节者。随其所欲应施彼身。随所欲为系属于彼。随顺于彼。或分支节而施与之。当知是名菩萨于内所可施物。或应施与或不应与。又诸菩萨于外施物。若有众生来求毒火刀酒等物。或为自害或为害他。即不应施。若有众生来求毒火刀酒等物或自饶益或饶益他。是即应施。又诸菩萨不以属他非同意物而行惠施。又诸菩萨不行媒媾以他妻妾而行布施。又诸菩萨不以有虫饮食等物而行惠施。又诸菩萨若有众生来求种种能引戏乐能引无义所施之物。不应施与。何以故。若施彼时。虽暂令彼于菩萨所心生欢喜。而复令彼广作种种不饶益事。谓因施故令彼多行憍逸恶行。身坏已后堕诸恶趣。若有种种戏乐等具虽复施与。不令众生堕诸恶趣。亦不增长诸不善根。菩萨为欲令彼众生因此所施戏乐等具。摄受饶益心生净信易可化导易可成熟。随彼所求悉皆施与。是诸菩萨若有来求诸戏乐事。何者应施何者不施。谓诸菩萨终不施人捕猎等法。又于杂秽诸祠祀中。作大方便多集众生。损害其命获无量罪。于彼祠祀终不自作亦不教他。亦不于彼诸天寺中杀羊祠祀。若有来求或水或陆无量众生所依止处。为欲杀害彼生命故。菩萨知已终不施与。若有来求罩罗罝弶。为害众生及为习学。皆不施与。若有怨家来求酬隙。为欲呵骂缚录杀害夺财治罚。终不施与。以要言之。所有一切逼追损害他诸有情戏乐等具。有来求者。是诸菩萨皆不施与。若复种种象马车舆。衣服庄严。珍妙饮食。习歌舞等。及诸乐器涂饰香鬘珍玩。众具园林楼观舍宅。侍女习学种种工巧业处。如是一切戏乐等具。为欲令其于菩萨所因此发起清净信心。有来求者。悉皆施与。又诸菩萨若有病者。来求非量非宜饮食亦不施与。若有众生食饱满已性多馋嗜。数复来求珍妙饮食。亦不施与。若诸众生愁忧所逼。求欲杀害欧击自身。食毒坠岩投渊赴火。皆悉不应施其所欲。又诸菩萨若有来求父母师长。定不应施。何以故。以诸菩萨于其父母尊重师长乳哺养育微有恩者。于长夜中常思顶戴不生厌倦。恒持自身系属随顺任所屠害捶缚货卖。尚自不敢窃怀施心。何况显然施来求者。又诸菩萨若作国王灌顶。自在统领方域。于自国界所有寮庶。终不抑夺取余妻子而转施余。唯持村邑聚落川土。或全或分以用布施。而告彼曰。如我恩化。汝亦宜然。又诸菩萨于自妻子奴婢仆使亲戚眷属。若不先以正言晓喻令其欢喜。终不强逼令其忧恼施来求者。虽复先以正言晓喻令其欢喜生乐欲心。而不施与怨家恶友药叉罗刹凶暴业者。不以妻子形容软弱族姓男女施来求者令作奴婢。又诸菩萨若有上品逼恼众生乐行种种暴恶业者来求王位。终不施与。若彼暴恶补特伽罗先居王位。菩萨有力尚应废黜。况当施与。又诸菩萨终不侵夺父母妻子。奴婢仆使。亲戚眷属。所有财物持用布施。亦不逼恼父母妻子。奴婢仆使。亲戚眷属。以所施物施来求者。又诸菩萨以其正法。以无卒暴积集财物。而行惠施。不以非法不以卒暴。亦不逼迫损恼于他而行惠施。又诸菩萨若在诸佛圣教出家。终不违越所有学处。而行惠施。又诸菩萨行布施时。普于一切有情之类。起平等心住福田想。而行惠施。终不分别怨亲中庸有德有失劣等胜品有苦有乐品类差别。又诸菩萨如先所说如先所许。终无减少施来求者。唯有施彼或等或增。又诸菩萨终无先许胜妙财物后施下劣。唯有先许下劣财物若有胜妙后施胜妙。又诸菩萨不以异意。不以愤怒挠浊之心而行惠施。又诸菩萨终不施已而自称赞数数告。言我于汝所曾行如是如是惠施。摄受长养济拔于汝。又诸菩萨于卑贱者行布施时。尚无不敬撩掷而与。况于有德。又诸菩萨若来求者。安住种种毁犯邪行掉举躁扰不自防护。专行骂詈嗔忿呵责。终不于彼暂起邪行带厌倦心而行惠施。谁即于彼了知为诸烦恼所媚令改本性。深更安住怜愍之心而行惠施。又诸菩萨不由恶见妄有执取而行惠施。谓如广大暴恶祠祀。不计杀生布施为法。亦不妄取吉祥瑞应相应相状而行布施。又诸菩萨终不妄计唯一切种极善清净而行惠施。即是世间及出世间离欲清净。唯审了知所行布施但是离欲清净资粮。又诸菩萨不观其果而行布施。一切布施皆为回向速证无上正等菩提。又诸菩萨如实了知一切品类所行布施一切品类施果异熟。深生信解。不由他缘非他所引而行布施。谓施饮食能感大力。施诸衣服能感妙色。施诸车乘能感快乐。施诸灯明能感净眼。如是等类广说应知。又诸菩萨不为怖畏自身贫穷而行布施。唯由悲愍众生意乐而行布施。又诸菩萨于来求者。终不施与不合仪物。谓施出家者。余残饮食。或诸便秽洟唾变吐脓血。不净所杂所染。又不告白不令觉知。如弃舍法施糜饭等。谓不食葱者。施以葱杂葱染饮食。不食肉者。施以肉杂肉染饮食。不饮酒者。施以酒杂酒染饮食。或复处置不合仪式所有事业而行布施。如是等类不合仪施。菩萨不为。又诸菩萨不令求者数数来求往还亲附随顺系属稽留疲倦然后方施。唯暂来求即便施与。又诸菩萨不依世间名声赞颂而行布施。不依于他反报恩德而行布施。不依帝释魔王轮王自在等果而行布施。亦复不为诳诱他故而行惠施。谓欲令他国王大臣。城邑聚落。诸婆罗门多饶财宝长者居士。大富商主施者施主知我行施。定当恭敬尊重赞叹供养于我故行惠施。又不狭劣而行惠施。谓财虽少尚广心施。何况财多。又不诳他而行惠施。谓先于彼少行惠施。令起爱著令亲附己。然后倾灭。又复不为乖离于他而行惠施。谓我以施乖离村邑。村邑一分乖离国土。国土一分令背其主而来属我。又诸菩萨翘勤无惰。起策具足勇锐自严。先自行施后劝他施。非自懈怠策他勤施。又无量众问集来乞。如实了知持戒犯戒。随其长幼以次而坐。从上至下周旋往返。穷诸施物分布与之。又诸菩萨现有无量广多财物。终不行于有量之施。又诸菩萨不损恼他而行惠施。谓不诃骂捶打恐怖毁辱。缚害拘禁。斫刺驱摈于此而施于彼。又诸菩萨施前意悦施时心净施后无悔。又诸菩萨不以谄诡而行惠施。谓终不以非实末尼真珠。琉璃珂贝。璧玉珊瑚等宝。而施希望真实宝者。又诸菩萨所有财物若少若多无不运心。先施一切后来求者如取自财。菩萨与时如还彼物。又诸菩萨应时而施不以非时。自他净施非不清净。合仪而施不以非仪。无乱心施不以散乱。又诸菩萨见来求者终不嗤笑亦不轻弄。亦不令其而生赧愧。亦不颦蹙。舒颜平视前笑先言。终不稽留疾疾而施。又诸菩萨他虽不求自恣求者。必有所求称须而与。常开求者欢情自取

又诸菩萨不以恶慧而行布施。常以巧慧而行布施。云何菩萨巧慧布施。谓诸菩萨现有种种可施财物。求者未至先发是心。设二求者俱来我所。一是安乐。非贫非贱有依有怙。二是危苦。是贫是贱无依无怙。我于尔时应自揆量所有财物。若堪于二充足满愿。即应俱施满愿充足。如其财物不堪于二充足满愿。即应方便发遣安乐非贫非贱有依有怙。尽己所有施彼危苦是贫是贱无依无怙。发是心已如所思惟。即便成办如是事业。于安乐等诸来求者。既无力能足满其愿。先当方便发意思惟辞谢发遣。我此施物于危苦等先舍先许。故今与之非我于汝无乐施心。但更无力。唯愿贤首。勿于我所嫌恨弃背。又诸菩萨现有种种可施财物。知有悭家最极悭家吝执财宝悭固兢战。于其家中曾未惠施一切沙门婆罗门等。菩萨即便往诣其舍。慰问安不恭顺方便。告言汝来。我不令汝库藏减尽。而于现前作大饶益。我家现有广多财宝广多施物。为满我施波罗蜜多。若有求者来到汝所勿令空返。可至我家取诸财宝随意施与。或有求者来至我所。我行施时汝于此施当生随喜。彼闻是已便生欣悦。于我库藏既无所减。复得称彼善男子心。故应随顺成辩所作。菩萨如是令彼渐种当来调伏悭吝种子。由慧为先善巧方便。令渐修习自舍少财。依下无贪进得中品。依中无贪进得上品。又诸菩萨若亲教师及轨范师。共住弟子同梵行者。性是悭贪是悭贪类。或性虽非悭贪种类。而阙资财所欲匮乏。菩萨欲寄佛法僧田树修布施福业事时。舍所施物与彼令作已自不为。菩萨如是巧慧方便。自所生福弥更弘多。复令一类同梵行者调伏所有悭贪烦恼。亦令一类乐善法者所愿满足。摄受有情成熟有情。又诸菩萨现有众多可施财物。见诸来者有希求相。知其心已随彼所乐悉皆施与。复有商人为性矫诈欲行欺诳。菩萨知已尚掩其过不令他知。况触于彼。称满其愿令无羞愧。踊跃无畏欢喜而去。复有矫诈欺诳。菩萨初不觉知后时乃觉。虽复觉知不以此事举发彼人。亦不诃责。为作忆念但生悲愍。彼于我所误行如是不与取事。我今随喜令彼无罪。如是等类。当知名为菩萨现有可施财物巧慧而施。又诸菩萨若现无有可施财物。先所串习彼彼世间工巧业处作意现前。少用功力多集财宝施诸众生。是诸菩萨或复为他种种美妙善巧言词。宣说正法。令贫苦者尚乐行施。况富乐者。令悭贪者犹能惠施。况习施者。或有净信多饶财宝常乐施家。数教乞者往彼求索令其布施。或彼惠舍修福业时。躬诣其所翘勤无惰。起策具足深心欢喜。随力随能身助语助。令施求者得善满足。以彼施时事力阙鲜。或恶供瞻。或堕朋党。或不恭敬。或念忘失。由善助故。斯过皆无。如是菩萨现无财宝。巧慧方便而行布施。此说乃至未证增上清净意乐。若诸菩萨已证增上清净意乐。如已获得超诸恶趣。如是生生必定获得无尽财宝。又诸菩萨终不口授求过外道。所有正法亦不施彼。所写经典知性多贪求欲炫卖经卷等者。亦不施与。知欲秘藏亦不施与。不求胜智亦不施与。必求胜智。若自了知于经卷等。其义已辩。即随所乐如应施与。若自了知于经卷等其义未辩。为辩义故恒自披转。如是菩萨若见其余有经卷等。即应方便转求施与。或更书写而施与之。若不见余有经卷等。亦无力能更为书写。即应审谛观察自心。勿我于法悭垢缠心不能施耶。勿我于法别意所碍不欲施耶。为我于法有胜所须不应施耶。如是审谛观察心已。若自了知我于此法少有悭缠别意所碍而不施者。即作是心。我今决定应行法施。设我由此行法施故。于现法中即成痴哑。不忍烦恼尚应法施。况令阙乏妙智资粮。又观察已。若自了知我于此法无少悭缠。亦无别意。但为成办胜所须义不应施者。菩萨尔时应更思忖。我持此法施于彼者。为为损害自烦恼耶。为为圆满智资粮耶。为为爱念诸众生耶。既思忖已。便正了知我都不见自有烦恼见。不施彼此经卷等。现法当来我智资粮展转增胜。非施于彼建此功德。但于当来薄饶法利非丰觉慧。若不施彼便能修集利益安乐一切众生巧方便智。即为爱念此一众生及余一切。若施于彼唯成爱念此一众生。非余一切。菩萨如是如实知已不施彼者。无罪无悔。亦不违越菩萨净戒。云何菩萨方便不施。谓诸菩萨不忍直言遣来求者。谓我不能惠施于汝。要当施设方便善巧晓喻发遣。云何施设方便善巧。谓诸菩萨先于所畜一切资具一切施物。为作净故以净意乐舍与十方诸佛菩萨。譬如苾刍于己衣物为作净故。舍与亲教轨范师等。如是菩萨净施因缘。虽复贮畜种种上妙一切资具一切施物。犹得名为安住圣种。生无量福常于此福多思惟故。于一切时随逐增长。恒于一切作净施物。如佛菩萨所寄护持。见来求者即应观察。若随所欲作净施物惠施彼时。称当正理应作是念。诸佛菩萨无有少物于诸众生而不施者。如是知已取净施物。施来求者令所愿满。若观施时不称正理。即应念先作净施法。告言贤首。如是等物是他所有不许施汝。软言晓喻方便发遣。或持余物。二倍三倍恭敬施与。然后发遣。令彼了知菩萨于此非悭贪故不欲施我。定当于此经卷等法。不自在故不施于我。当知是名菩萨巧慧而行法施

又诸菩萨于一切施。谓法施财施无畏施。若异门。若体相。若释名。若因果差别。如实了知而行惠施。当知亦名菩萨巧慧而行布施。又诸菩萨于诸有怨。以慈意乐而行惠施。于诸有苦。以悲意乐而行惠施。于诸有德。以喜意乐而行惠施。于诸有恩亲善同意。以舍意乐而行惠施。当知亦名菩萨巧慧而行布施

又诸菩萨于其施障及彼对治如实了知。此中施障略有四种。一先未串习。二施物鲜阙。三耽着上妙悦意财物。四观见当来具足财果而深欣乐。若诸菩萨现有种种可施财物。虽见求者正现在前。而于惠施心不趣入。菩萨尔时即以正慧。速疾通达是我于施先未串习所作过失。复以妙慧。如是通达我于先世决定于施曾未串习。致令今世现有种种可施财物。虽见求者正现在前。而于惠施心不趣入。若于今世不强思择而行施者。复于来世定当憎背所应行施。菩萨如是正通达已。用此施障对治为依。力励思择而行惠施。能不随逐先未串习所作过失。自在而行。又诸菩萨若见求者正现在前。由诸财物有鲜阙故。于其惠施心不趣入。菩萨尔时即以正慧速疾通达。如是匮乏障施因缘。忍受匮乏所作众苦。力励思择起悲愍心而行慧施。作如是念。或由宿业有过失故。或由现在系属他故。令我具受众多猛利饥渴等苦。不能饶益一切众生。设我今者由行惠施因饶益他。于现法中受种种苦乃至殒殁。如是行施犹为最胜。非空发遣诸来求者。况当更有诸菜叶等可以活命。菩萨如是忍受匮乏所作众苦而行惠施。又诸菩萨若见求者正现在前。由可施物极悦意故最上妙故。于行惠施心不趣入。菩萨尔时即以正慧。速疾通达是我耽着所作过失。我今于苦发起虚妄乐想颠倒。由此能生当来众苦。于此颠倒遍了知故。为欲断除力励思择。用此财物而行惠施。又诸菩萨若行施已。于当施果广大财利。见胜功德深生欣乐。不求无上正等菩提。菩萨尔时即以正慧。速疾通达是邪果见所作过失。如实观察。一切诸行皆不坚牢。一切诸行皆念念灭。所受用果速疾灭尽速疾离散。如是观时即能断灭能生欣乐邪果之见。诸所行施一切回向无上菩提。如是菩萨四种施障。当知四种能对治智对治于彼。一者觉悟。二者忍受众苦。三者遍知颠倒。四者见一切行性不坚牢。是诸菩萨由前三种能对治智。决定堪能正行惠施。由后一种能对治智。能正摄受施福胜果。当知亦名菩萨巧慧而行布施

又诸菩萨内居闲静。由净意乐淳厚净信分别胜解。数数缘念种种上妙无量财宝以胜解力于诸众生乐行惠施。由此因缘是诸菩萨以少功用生无量福。当知亦名菩萨巧慧而行布施

如是妙慧大慧菩萨巧慧行施。总略义者。由有财无财财施所摄故。如是由法施故。由无碍解施故。由胜意乐施故。由施障对治智慧施故。由增上意乐胜解施故当知是名唯诸菩萨不共行施

如是广说于内外事菩萨所行一切施差别相已。自斯已后即于一切施差别相中。分出所余难行施等一切差别。应当了知

云何菩萨难行施。当知此施略有三种。谓若诸菩萨财物鲜少。自忍贫苦惠施于他。是名菩萨第一难行施。若诸菩萨所可爱物。或性深爱着。或长时串习。或有上品恩或最上妙物极生耽着能自开解惠施于他。是名菩萨第二难行施。若诸菩萨极大艰辛所获财物惠施于他。是名菩萨第三难行施

云何菩萨一切门施。当知此施略有四相。谓诸菩萨或自财物。或劝化他所得财物。或施亲属父母妻子。奴婢作使善友。大臣亲戚眷属。或复施与他来求者。如是四相。是名菩萨一切门施

云何菩萨善士所行名善士施。当知此施略有五相。谓诸菩萨净信而施。恭敬而施。自手而施。应时而施。不损恼他而行惠施。如是五相。是名菩萨善士所行名善士施

云何菩萨一切种施。当知此施有十三相。一无依施。二广大施。三欢喜施四数数施。五田器施。六非田器施。七一切物施。八一切处施。九一切时施。十无罪施。十一有情物施。十二方土物施。十三财谷物施如是十三种相。当知是名菩萨一切种施

云何菩萨遂求施。当知此施有八种相。谓诸菩萨匮乏饮食而求乞者。施以饮食。匮乏车乘而求乞者。施以车乘匮乏衣服而求乞者。施以衣服匮乏严具而求乞者。施以严具。匮乏种种资生什物而求乞者。施以种种资生什物匮乏种种涂饰香鬘而求乞者。施以种种涂饰香鬘。匮乏舍宅而求乞者。施以舍宅。匮乏光明而求乞者。施以光明。如是八相是名菩萨遂求施

云何菩萨此世他世乐施。当知此施略有九相。谓财施无畏施法施。总说名为能令众生此世他世乐施。财施者。谓以上妙清净如法财物而行惠施。调伏悭吝垢而行惠施。调伏积藏垢而行惠施。调伏悭吝垢者。谓舍财物执着。调伏积藏垢者。谓舍受用执着。无畏施者。谓济拔师子虎狼鬼魅等畏。拔济王贼等畏。拔济水火等畏。法施者。谓无倒说法称理说法劝修学处。如是一切总说九相。是名菩萨能令众生此世他世乐施。此中财施无畏施及此差别。能令众生此世安乐。法施及此差别。能令众生后世安乐。

云何菩萨清净施。当知此施有十种相。一不留滞施。二不执取施。三不积聚施。四不高举施。五无所依施。六不退弱施。七不下劣施。八不向背施。九不望报恩施。十不希异熟施。云何不留滞施。谓诸菩萨见来求者正现在前。速疾惠施不作留滞。非来求者疾望得财。如诸菩萨速希惠施。云何不执取施。谓诸菩萨不以妄见执取于施。或执此施空无有果。或执杀害而行惠施以为正法。或执唯施极净圆满是世出世究竟清净。云何不积聚施。谓诸菩萨不于长时渐渐积集聚多财物然后顿施。何以故。非诸菩萨现有施物。见来求者正现在前。堪能不施。不见不施是称正理。云何积财而不速施。又诸菩萨不见积财。后方顿施。是能生长多福之门。又正观见若别若总求者。相似渐施顿施财物平等。何缘而执福有差别。又诸菩萨见积聚施其施有罪。见随得施其施无罪。何以故。若积聚已然后顿施。是则先时有来求者。其数或百而不施与。令生嫌恨不忍不信。后有一类或不希求。畜积珍财强而顿施。是故菩萨不积聚施。云何不高举施。谓诸菩萨于来求者。谦下心施。亦不与他竞胜而施。亦不施已而生憍慢。谓我能施我是施主余则不尔。云何无所依施。谓诸菩萨不依称誉声颂而施。体达世间称誉声颂虚妄分别。文字所起唯是虚音。系属妄向。譬如世间[禾*肙][麥*弋]叶聚。云何不退弱施。谓诸菩萨施先意悦施时心净施已无悔。闻诸菩萨广大第一最胜施时。不自轻蔑恐怖退弱。云何不下劣施。谓诸菩萨于诸施物。勤数简择最胜最妙饮食车乘衣服等物。持用布施。云何不向背施。谓诸菩萨其心平等不随朋党。于怨亲中悲心等施。云何不望报恩施。谓诸菩萨悲心愍心而行惠施。终不于他希望反报。但观求乐爱火所烧。无有势力。性苦众生。深心悲愍而行惠施。云何不希异熟施。谓诸菩萨修行惠施。终不希望当来所得财宝圆满自身圆满施果异熟。观一切行性是虚伪。观大菩提最胜功德。由此十相菩萨所行布施清净最极清净

如是菩萨依止九相所行惠施。圆满施波罗蜜多已。能证无上正等菩提

瑜伽师地论卷第三十九瑜伽师地论卷第四十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处戒品第十之一

云何菩萨戒波罗蜜多。嗢拖南曰

  自性一切难　　一切门善士
  一切种遂求　　二世乐清净
  如是九种相　　是名略说戒

谓九种相戒名为菩萨戒波罗蜜多。一自性戒。二一切戒。三难行戒。四一切门戒。五善士戒。六一切种戒。七遂求戒。八此世他世乐戒。九清净戒

云何菩萨自性戒。谓若略说具四功德。当知是名菩萨自性戒。何等为四。一从他正受。二善净意乐。三犯已还净。四深敬专念无有违犯。由诸菩萨从他正受故。于所学戒若有违犯。即外观他深生愧耻。由诸菩萨善净意乐故。于所学戒若有违犯。即内自顾深起惭羞。由诸菩萨于诸学处犯已还净。深敬专念初无违犯。二因缘故。离诸恶作。如是菩萨从他正受善净意乐。为依止故生起惭愧。由惭愧故能善防护所受尸罗。由善防护所受戒故离诸恶作。又于是中。从他正受。善净意乐。此二是法。犯已还净。深敬专念无有违犯。此二是前二法所引。又于是中。从他正受。善净意乐。深敬专念无有违犯。由此三法应知能令不毁菩萨所受净戒。犯已还净。由此一法应知能令犯已还出。如是菩萨具四功德自性尸罗。应知即是妙善净戒。正受随学。能利自他。利益安乐无量众生。哀愍世间诸天人等。令得义利利益安乐故。应知即是无量净戒。摄受无量菩萨所学故。应知即是饶益一切有情净戒。现前能作一切有情利益安乐故。应知即是能获大果胜利净戒摄受随与无上正等菩提果故。是名菩萨自性戒

云何菩萨一切戒。谓菩萨戒略有二种。一在家分戒。二出家分戒是名一切戒

又即依此在家出家二分净戒。略说三种。一律仪戒。二摄善法戒。三饶益有情戒

律仪戒者。谓诸菩萨所受七众别解脱律仪。即是苾刍戒。苾刍尼戒。正学戒。勤策男戒。勤策女戒。近事男戒。近事女戒。如是七种。依止在家出家二分。如应当知。是名菩萨律仪戒

摄善法戒者。谓诸菩萨受律仪戒后。所有一切为大菩提。由身语意积集诸善。总说名为摄善法戒。此复云何。谓诸菩萨依戒住戒。于闻于思于修止观于乐独处。精勤修学。如是时时于诸尊长。精勤修习合掌起迎问讯礼拜恭敬之业。即于尊长勤修敬事。于疾病者悲愍殷重瞻侍供给。于诸妙说施以善哉。于有功德补特伽罗。真诚赞美。于十方界一切有情一切福业。以胜意乐起净信心发言随喜。于他所作一切违犯思择安忍。以身语意已作未作一切善根。回向无上正等菩提。时时发起种种正愿以一切种上妙供具供佛法僧。于诸善品恒常勇猛精进修习。于身语意住不放逸。于诸学处正念正知正行。防守密护根门。于食知量。初夜后夜常修觉悟。亲近善士依止善友。于自愆犯审谛了知深见过失。既审了知深见过已。其未犯者专意护持。其已犯者于佛菩萨同法者所。至心发露如法悔除。如是等类所有引摄护持。增长诸善法戒。是名菩萨摄善法戒

云何菩萨饶益有情戒。当知此戒略有十一相。何等十一。谓诸菩萨于诸有情能引义利。彼彼事业与作助伴。于诸有情随所生起疾病等苦。赡侍病等亦作助伴。又诸菩萨依世出世种种义利。能为有情说诸法要。先方便说先如理说。后令获得彼彼义利。又诸菩萨于先有恩诸有情所善守知恩。随其所应现前酬报。又诸菩萨于堕种种师子虎狼鬼魅王贼水火等畏诸有情类。皆能救护。令离如是诸怖畏处。又诸菩萨于诸丧失财宝亲属诸有情类。善为开解令离愁忧。又诸菩萨于有匮乏资生众具诸有情类。施与一切资生众具。又诸菩萨随顺道理。正与依止如法御众。又诸菩萨随顺世间。事务言说。呼召去来。谈论庆慰。随时往赴。从他受取饮食等事。以要言之。远离一切能引无义违意现行。于所余事心皆随转。又诸菩萨若隐若露。显示所有真实功德。令诸有情欢言进学。又诸菩萨于有过者。内怀亲昵利益安乐增上意乐调伏诃责治罚驱摈。为欲令其出不善处安置善处。又诸菩萨以神通力。方便示现那落迦等诸趣等相。令诸有情厌离不善。方便引令入佛圣教欢喜信乐生希有心勤修正行。云何菩萨住律仪戒。住摄善法戒。住饶益有情戒。善护律仪戒。善修摄善法戒善行一切种饶益有情戒

谓诸菩萨住别解脱律仪戒时。舍转轮王而出家已。不顾王位如弃草秽。如有贫庶为活命故。弃下劣欲而出家已不顾劣欲。不如菩萨清净意乐舍轮王位而出家已不顾一切人中最胜转轮王位。又诸菩萨住律仪戒。于未来世天魔王宫所有妙欲。不生喜乐。亦不愿求彼诸妙欲修行梵行。于彼妙欲尚如实观。犹如趣入广大种种恐畏稠林。况余诸欲。又诸菩萨既出家已。于现在世尊贵有情种种上妙利养恭敬。正慧审观。尚如变吐曾不味着。何况于余卑贱有情所有下劣利养恭敬。又诸菩萨常乐远离若独静处。若在众中。于一切时心专远离寂静而住。不唯于是尸罗律仪而生喜足。依戒住戒勤修无量菩萨等持。为欲引发证得自在。又诸菩萨虽处杂众。而不乐为乃至少分不正言论。居远离处。不起少分诸恶寻思。或时失念暂尔现行。寻便发起猛利悔愧。深见其过数数悔愧。深见过故虽复暂起不正言论诸恶寻思。而能速疾安住正念。于彼获得无复作心。由此因缘则能拘检。习拘检故渐能如昔。于彼现行深生喜乐。于今安住彼不现行。喜乐亦尔。又能违逆令不现起。又诸菩萨于诸菩萨一切学处。及闻已入大地菩萨广大无量不可思议长时最极难行学处。心无惊惧亦不怯劣。唯作是念。彼既是人。渐次修学于诸菩萨一切学处广大无量不可思议净身语等诸律仪戒。成就圆满。我亦是人。渐次修学决定无疑。当得如彼净身语等诸律仪戒成就圆满。又诸菩萨住律仪戒常察己过不伺他非。普于一切凶暴犯戒诸有情所。无损害心无嗔恚心。菩萨于彼由怀上品法大悲故。现前发起深怜愍心欲饶益心。又诸菩萨住律仪戒。虽复遭他手足块石刀杖等触之所加害。于彼尚无少恚恨心。况当于彼欲出恶言欲行加害。况复发言毁辱诃责。以少苦触作不饶益。又诸菩萨住律仪戒。具足成就五支所摄不放逸行。一前际俱行不放逸行。二后际俱行不放逸行。三中际俱行不放逸行。四先时所作不放逸行。五俱时随行不放逸行。谓诸菩萨于菩萨学正修学时。若于过去已所违犯如法悔除。是名菩萨前际俱行不放逸行。若于未来当所违犯如法悔除。是名菩萨后际俱行不放逸行。若于现在正所违犯如法悔除。是名菩萨中际俱行不放逸行。若诸菩萨先于后时当所违犯发起猛利自誓欲乐。谓我定当如如所应行。如如所应住。如是如是行。如是如是住。令无所犯。是名菩萨先时所作不放逸行。若诸菩萨即以如是先时所作不放逸行为所依止。如如行所应行。如如所应住。如是如是行。如是如是住。不起毁犯。是名菩萨俱时随行不放逸行。又诸菩萨住律仪戒。覆藏自善发露己恶。少欲喜足堪忍众苦。性无忧戚不掉不躁威仪寂静。离矫诈等一切能起邪命之法。菩萨成就如是十支。名住律仪戒善护律仪戒。谓不顾恋过去诸欲。又不希求未来诸欲。又不耽着现在诸欲。又乐远离不生喜足。又能扫涤不正言论诸恶寻思。又能于己不自轻蔑。又性柔和。又能堪忍。又不放逸。又能具足轨则净命

又诸菩萨已能安住摄善法戒。若于身财少生顾恋。尚不忍受。何况其多。又于一切犯戒因缘根本烦恼少分烦恼忿恨等生。亦不忍受。又于他所发生恚害怨恨等心。亦不忍受。又于所起懈怠懒惰。亦不忍受。又于所起等至味着等至烦恼。亦不忍受。又于五处如实了知。谓如实知善果胜利。又能如实了知善因。又能如实知善因果倒与无倒。又如实知摄善法障。是诸菩萨能于善果见大胜利寻求善因。为摄善故如实了知倒与无倒。由此菩萨获得善果。不于无常妄见为常。不于其苦妄见为乐。不于不净妄见为净。不于无我妄见为我。如实了知摄善法障。为摄善故速疾远离。菩萨由此十种相故。名住摄善法戒。速能摄善一切种相。谓施渐次。若戒渐次。若忍渐次。若精进渐次若静虑渐次及五种慧。又诸菩萨由十一相。名住一切种饶益有情戒。于一一相中成就一切种谓诸菩萨于诸有情彼彼事业。皆为助伴。谓于思量所作事业。及于功用所作事业悉能与彼而作助伴或于道路若往若来。或于无倒事业加行。或于守护所有财物。或于和合展转乖离。或于义会或于修福。皆为助伴。于诸救苦亦为助伴。谓于遭遇疾疫有情。瞻侍供给。盲者启导。聋者撝义。手代言者晓以想像。迷方路者示以遇途。支不具者惠以荷乘。其愚騃者诲以胜慧。为贪欲缠所苦有情。开解令离贪欲缠苦。如是若为嗔恚惛沈。睡眠掉举。恶作疑缠。所苦有情。开解令离疑缠等苦。欲寻思缠所苦有情。开解令离欲寻思苦。如欲寻思。恚害亲里国土不死轻侮相应族姓相应所有寻思当知亦尔。他蔑他胜所苦有情。开解令离被蔑胜苦。行路疲乏所苦有情。施座施处调身按摩。令其止息劳倦众苦。又诸菩萨为诸有情如理宣说。谓于乐行恶行有情。为欲令断诸恶行故。以相应文句助伴随顺。清亮有用相称应顺。常委分资粮法而为宣说。或复方便善巧宣说。如于乐行恶行有情为欲令断诸恶行故如是。于行悭行有情。为欲令彼断悭行故。于现法中求财宝者。为欲令彼正少功力集多财宝守护无失。于佛圣教怀憎嫉者。为欲令彼得清净信证清净见。超诸恶趣尽一切结。越一切苦。应知亦尔

又诸菩萨于其有恩诸有情所。深知恩惠常思酬报。暂见申敬赞言善来。怡颜欢慰。吐诚谈谑祥处设座正筵令坐。若等若增助利供养现前酬答。非以下劣。于彼事业虽不求请。尚应伴助。况于有命。如于事业如是。于苦。于如理说。于方便说。于济怖畏。于衰恼处开解愁忧。于惠资具。于与依止。于随心转于显实德令深欢悦。于怀亲爱方便调伏。于现神通惊恐引摄。如应广说当知亦尔。又诸菩萨于遭怖畏诸有情类能为救护。谓于种种禽兽水火。王贼怨敌。家主宰官。不活恶名。大众威德。非人起尸。魍魉等畏皆能救护令得安隐。又诸菩萨于处衰恼诸有情类。能善开解令离愁忧。或依亲属有所衰亡所谓父母兄弟。妻子奴婢。僮仆宗长。朋友内外族因。亲教轨范。及余尊重。时有丧亡。善为开解令离忧恼。或依财宝有所丧失。谓或王贼之所侵夺。或火所烧或水所溺。或为矫诈之所诳诱。或由事业无方损失。或为恶亲非理横取。或家生火之所耗费。于如是等财宝丧失。善为开解令离忧恼。由是因缘诸有情类生软中上三品愁忧。菩萨皆能正为开解。又诸菩萨备资生具。随有来求即皆施与。谓诸有情求食与食求饮与饮。求乘与乘求衣与衣。求庄严具施庄严具。求诸什物施以什物。求鬘涂香。施鬘涂香。求止憩处施止憩处。求诸光明施以光明。又诸菩萨性好摄受诸有情类。如法御众方便饶益。以无染心先与依止。以怜愍心现作饶益。然后给施如法衣服饮食卧具病缘医药资身什物。若自无有应从净信长者居士婆罗门等求索与之。于己以法所获如法衣服饮食诸坐卧具病缘医药资身什物。与众同用自无隐费。于时时间以其随顺八种教授而正教授。五种教诫而正教诫。此中所说教授教诫。当知如前力种性品已广分别。又诸菩萨于有情心性好随转。随心转时先知有情若体若性。知体性已。随诸有情所应共住。即应如是与其共住。随诸有情所应同行。即应如是与彼同行。若诸菩萨欲随所化有情心转。当审观察。若于如是如是相事现行身语。生他忧苦。如是忧苦若不令其出不善处安立善处。菩萨尔时于如是事现行身语。护彼心故方便思择励力遮止。令不现行如是忧苦。若能令其出不善处安立善处。菩萨尔时于如是事现行身语住哀愍心。不随如是有情心转。方便思择励力策发要令现行。复审观察。若于如是他有情事现行身语。令余有情发生忧苦。如是忧苦若不令他或余有情或不令二出不善处安立善处。菩萨尔时于如是事现行身语。护余心故方便思择励力遮止。令不现行如是忧苦。若能令他或余有情或能令二出不善处安立善处。菩萨尔时于如是事现行身语。住哀愍心。不随如是有情心转。方便思择励力策发要令现行。复审观察。若于如是菩萨自事现行身语生他忧苦。如是现行身语二业。非诸菩萨学处所摄。不顺福德智慧资粮。如是忧苦不能令他出不善处安立善处。菩萨尔时于如是事现行身语。护他心故方便思择励力遮止令不现行。与此相违现行身语如前应知。如生忧苦。如是广说生于喜乐随其所应当知亦尔。又随他心而转菩萨。知他有情忿缠所缠现前忿缠难可舍离。尚不赞叹。何况毁呰。即于尔时亦不谏诲。又随他心而转菩萨。他虽不来谈论庆慰。尚应自往谈论庆慰。何况彼来而不酬报。又随他心而转菩萨。终不故意恼触于他。唯除诃责诸犯过者。起慈悲心诸根寂静。如应诃责令其调伏。又随他心而转菩萨。终不嗤诮轻弄于他令其赧愧。不安隐住。亦不令其心生忧悔。虽能摧伏得胜于彼。而不彰其堕在负处。彼虽净信。生于谦下终不现相而起自高。又随他心而转菩萨。于诸有情非不亲近不极亲近。亦不非时而相亲近。又随他心而转菩萨。终不现前毁他所爱。亦不现前赞他非爱。非情交者不吐实诚。不屡希望知量而受。若先许应他饮食等。终无假托不赴先祈。为性谦冲如法晓谕。又诸菩萨性好赞扬真实功德令他欢喜。于信功德具足者前。赞扬信德令其欢喜。于戒功德具足者前。赞扬戒德令其欢喜。于闻功德具足者前。赞扬闻德令其欢喜。于舍功德具足者前。赞扬舍德令其欢喜。于慧功德具足者前。赞扬慧德令其欢喜。又诸菩萨性好悲愍。以调伏法调伏有情。若诸有情有下品过下品违犯。内怀亲爱无损恼心。以软诃责而诃责之。若诸有情有中品过中品违犯。内怀亲爱无损恼心。以中诃责而诃责之。若诸有情有上品过上品违犯。内怀亲爱无损恼心。以上诃责而诃责之。如诃责法。治罚亦尔。若诸有情有下中品应可驱摈过失违犯。菩萨尔时为教诫彼及余有情。以怜愍心及利益心。权时驱摈后还摄受。若诸有情有其上品应可驱摈过失违犯。菩萨尔时尽寿驱摈。不与共住不同受用。怜愍彼故不还摄受。勿令其人于佛圣教多摄非福。又为教诫利余有情。又诸菩萨为欲饶益诸有情故。现神通力。或为恐怖。或为引摄。谓为乐行诸恶行者。方便示现种种恶行诸果异熟。谓诸恶趣小那落迦。大那落迦。寒那落迦。热那落迦。既示现已而告之言。汝当观此先于人中造作增长诸恶行故。今受如是最极暴恶辛楚非爱苦果异熟彼见是已恐怖厌患离诸恶行。复有一类无信有情。菩萨众中随事故问。彼作异思拒而不答。菩萨尔时或便化作执金刚神。或复化作壮色大身巨力药叉。令其恐怖。由是因缘舍慢生信恭敬正答。其余大众闻彼正答亦皆调伏。或现种种神通变化。或一为多或多为一。或以其身穿过石壁山岩等障往还无碍。如是广说乃至梵世身自在转。现无量种神变差别。或复现入火界定等。或复示现共声闻等种种神通。方便引摄令诸有情踊跃欢喜。诸未信者。方便安处信具足中。诸犯戒者。方便安处戒具足中。诸少闻者。方便安处闻具足中。多悭吝者。方便安处舍具足中。诸恶慧者。方便安处慧具足中。如是菩萨成就一切种饶益有情戒

是名菩萨三种戒藏。亦名无量大功德藏。谓律仪戒所摄戒藏。摄善法戒所摄戒藏。饶益有情戒所摄戒藏

若诸菩萨欲于如是菩萨所学三种戒藏。勤修学者。或是在家或是出家。先于无上正等菩提发弘愿已。当审访求同法菩萨。已发大愿有智有力。于语表义能授能开。于如是等功德具足胜菩萨所。先礼双足。如是请言。我今欲于善男子所或长老所或大德所。乞受一切菩萨净戒。唯愿须臾不辞劳倦哀愍听授。既作如是无倒请已。偏袒右肩。恭敬供养十方三世诸佛世尊。已入大地得大智慧得大神力诸菩萨众。现前专念彼诸功德。随其所有功德因力。生殷净心或少净心。有智有力胜菩萨所。谦下恭敬膝轮据地。或蹲跪坐对佛像前。作如是请。唯愿大德或言长老或善男子。哀愍授我菩萨净戒。如是请已惠念一境长养净心。我今不久当得无尽无量无上大功德藏。即随思惟如是事义。默然而住。尔时有智有力菩萨。于彼能行正行菩萨。以无乱心若坐若立而作是言。汝如是名善男子听。或法弟听。汝是菩萨不。彼应答言是。发菩提愿未。应答言已发。自此已后应作是言。汝如是名善男子或法弟。欲于我所受诸菩萨一切学处受诸菩萨一切净戒。谓律仪戒摄善法戒饶益有情戒。如是学处如是净戒。过去一切菩萨已具。未来一切菩萨当具。普于十方现在一切菩萨今具。于是学处于是净戒。过去一切菩萨已学。未来一切菩萨当学。现在一切菩萨今学。汝能受不。答言能受。能授菩萨第二第三亦如是说。能受菩萨第二第三亦如是答。能授菩萨作如是问。乃至第三授净戒已。能受菩萨作如是答。乃至第三受净戒已。能受菩萨不起于坐。能授菩萨对佛像前。普于十方现住诸佛及诸菩萨。恭敬供养顶礼双足。作如是白。某名菩萨今已有我某菩萨所。乃至三说受菩萨戒。我某菩萨已为某名菩萨作证。唯愿十方无边无际诸世界中诸佛菩萨第一真圣。于现不现一切时处。一切有情皆现觉者。于此某名受戒菩萨。亦为作证。第二第三亦如是说。如是受戒羯磨毕竟。从此无间普于十方无边无际诸世界中现住诸佛已入大地诸菩萨前。法尔相现。由此表示。如是菩萨已受菩萨所受净戒。尔时十方诸佛菩萨。于是菩萨法尔之相。生起忆念。由忆念故正智见转。由正智见如实觉知。某世界中某名菩萨。某菩萨所正受菩萨所受净戒。一切于此受戒菩萨。如子如弟生亲善意眷念怜愍。由佛菩萨眷念怜愍。令是菩萨希求善法倍复增长无有退减。当知是名受菩萨戒。启白请证

如是已作受菩萨戒羯磨等事。授受菩萨俱起供养。普于十方无边无际诸世界中诸佛菩萨。顶礼双足恭敬而退。如是菩萨所受律仪戒。于余一切所受律仪戒。最胜无上无量无边大功德藏之所随逐。第一最上善心意乐之所发起。普能对治于一切有情一切种恶行。一切别解脱律仪。于此菩萨律仪戒。百分不及一。千分不及一。数分不及一。计分不及一。算分不及一。喻分不及一。邬波尼杀昙分亦不及一。摄受一切大功德故

又此菩萨安住如是菩萨净戒。先自数数专谛思惟。此是菩萨正所应作。此非菩萨正所应作。既思惟已然后为成正所作业。当勤修学。又应专励听闻菩萨素怛缆藏及以解释。即此菩萨素怛缆藏摩怛履迦。随其所闻当勤修学

又诸菩萨不从一切。唯聪慧者求受菩萨所受净戒。无净信者不应从受。谓于如是所受净戒。初无信解不能趣入不善思惟。有悭贪者悭贪弊者。有大欲者无喜足者。不应从受。毁净戒者。于诸学处无恭敬者。于戒律仪有慢缓者。不应从受。有忿恨者。多不忍者。于他违犯不堪耐者。不应从受。有懒惰者。有懈怠者。多分耽着日夜睡乐倚乐卧乐好合徒侣乐喜谈者。不应从受。心散乱者下至不能构牛乳顷善心一缘住修习者。不应从受。有闇昧者。愚痴类者。极劣心者。诽谤菩萨素怛缆藏及菩萨藏摩怛履迦者。不应从受

又诸菩萨于受菩萨戒律仪法。虽已具足受持究竟。而于谤毁菩萨藏者无信有情。终不率尔宣示开悟。所以者何。为其闻已不能信解大无知障之所覆蔽。便生诽谤。由诽谤故。如住菩萨净戒律仪。成就无量大功德藏。彼诽谤者。亦为无量大罪业藏之所随逐。乃至一切恶言恶见及恶思惟。未永弃舍终不免离

又诸菩萨欲授菩萨菩萨戒时。先应为说菩萨法藏摩怛履迦菩萨学处及犯处相。令其听受。以慧观察自所意乐。堪能思择受菩萨戒。非唯他劝非为胜他。当知是名坚固菩萨。堪受菩萨净戒律仪。以受戒法如应正授。如是菩萨住戒律仪。有其四种他胜处法。何等为四。若诸菩萨为欲贪求利养恭敬。自赞毁他。是名第一他胜处法。若诸菩萨现有资财性悭财故。有苦有贫无依无怙正求财者来现在前。不起哀怜而修惠舍。正求法者来现在前。性悭法故虽现有法而不给施。是名第二他胜处法。若诸菩萨长养如是种类忿缠。由是因缘不唯发起粗言便息。由忿蔽故加以手足块石刀杖。捶打伤害损恼有情。内怀猛利忿恨意乐。有所违犯他来谏谢不受不忍不舍怨结。是名第三他胜处法。若诸菩萨谤菩萨藏。爱乐宣说开示建立像似正法。于像似法或自信解或随他转。是名第四他胜处法。如是名为菩萨四种他胜处法

菩萨于四他胜处法。随犯一种况犯一切。不复堪能于现法中增长摄受菩萨广大菩提资粮。不复堪能于现法中意乐清净。是即名为相似菩萨。非真菩萨。菩萨若用软中品缠。毁犯四种他胜处法。不舍菩萨净戒律仪。上品缠犯。即名为舍。若诸菩萨毁犯四种他胜处法。数数现行都无惭愧。深生爱乐见是功德。当知说名上品缠犯。非诸菩萨。暂一现行他胜处法。便舍菩萨净戒律仪。如诸苾刍犯他胜法即便弃舍别解脱戒。若诸菩萨由此毁犯。弃舍菩萨净戒律仪。于现法中堪任更受非不堪任。如苾刍住别解脱戒犯他胜法。于现法中不任更受

略由二缘舍诸菩萨净戒律仪。一者弃舍无上正等菩提大愿。二者现行上品缠犯他胜处法。若诸菩萨虽复转身遍十方界在在生处。不舍菩萨净戒律仪。由是菩萨不舍无上菩提大愿。亦不现行上品缠犯他胜处法。若诸菩萨转受余生忘失本念。值遇善友。为欲觉悟菩萨戒念。虽数重受。而非新受亦不新得

瑜伽师地论卷第四十瑜伽师地论卷第四十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处戒品第十之二

如是菩萨安住菩萨净戒律仪。于有违犯及无违犯是染非染软中上品。应当了知。若诸菩萨安住菩萨净戒律仪。于日日中若于如来或为如来造制多所。若于正法或为正法造经卷所。谓诸菩萨素怛缆藏摩怛理迦。若于僧伽。谓十方界已入大地诸菩萨众。若不以其或少或多诸供养具而为供养。下至以身一拜礼敬。下至以语一四句颂赞佛法僧真实功德。下至以心一清净信随念三宝真实功德。空度日夜。是名有犯有所违越。若不恭敬懒惰懈怠而违犯者。是染违犯。若误失念而违犯者。非染违犯。无违犯者。谓心狂乱。若已证入净意乐地常无违犯。由得清净意乐菩萨。譬如已得证净苾刍恒时法尔于佛法僧以胜供具承事供养。若诸菩萨安住菩萨净戒律仪。有其大欲而无喜足。于诸利养及以恭敬生着不舍。是名有犯有所违越。是染违犯。无违犯者。谓为断彼生起乐欲。发勤精进摄彼对治。虽勤遮遏而为猛利性惑所蔽。数起现行。若诸菩萨安住菩萨净戒律仪。见诸耆长有德可敬同法者来。憍慢所制怀嫌恨心怀恚恼心。不起承迎不推胜座。若有他来语言谈论庆慰请问。憍慢所制怀嫌恨心怀恚恼心。不称正理发言酬对。是名有犯有所违越。是染违犯。非憍慢制无嫌恨心无恚恼心。但由懒惰懈怠忘念无记之心。是名有犯有所违越。非染违犯。无违犯者。谓遭重病。或心狂乱。或自睡眠。他生觉想而来亲附。语言谈论庆慰请问。或自为他宣说诸法论义决择。或复与余谈论庆慰。或他说法论义决择属耳而听。或有违犯说正法者。为欲将护说法者心。或欲方便调彼伏彼出不善处安立善处。或护僧制。或为将护多有情心而不酬对皆无违犯

若诸菩萨安住菩萨净戒律仪。他来延请。或往居家或往余寺。奉施饮食及衣服等诸资生具。憍慢所制怀嫌恨心怀恚恼心。不至其所不受所请。是名有犯有所违越。是染违犯。若由懒惰懈怠忘念无记之心。不至其所不受所请。是名有犯有所违越。非染违犯。无违犯者。或有疾病。或无气力。或心狂乱。或处悬远。或道有怖。或欲方便调彼伏彼出不善处安立善处。或余先请。或为无间修诸善法欲护善品令无暂废。或为引摄未曾有义。或为所闻法义无退。如为所闻法义无退。论义决择当知亦尔。或复知彼怀损恼心诈来延请。或为护他多嫌恨心。或护僧制不至其所不受所请。皆无违犯

若诸菩萨安住菩萨净戒律仪。他持种种生色可染末尼真珠琉璃等宝。及持种种众多上妙财利供具。殷勤奉施。由嫌恨心或恚恼心违拒不受。是名有犯有所违越。是染违犯。舍有情故。若由懒惰懈怠忘念无记之心违拒不受。是名有犯有所违越。非染违犯。无违犯者。或心狂乱。或观受已心生染着。或观后时彼定追悔。或复知彼于施迷乱。或知施主随舍随受由是因缘定当贫匮。或知此物是僧伽物窣堵波物。或知此物劫盗他得。或知此物由是因缘多生过患。或杀或缚或罚或黜或嫌或责。违拒不受。皆无违犯

若诸菩萨安住菩萨净戒律仪。他来求法。怀嫌恨心怀恚恼心。嫉妒变异不施其法。是名有犯有所违越。是染违犯。若由懒惰懈怠忘念无记之心不施其法。是名有犯有所违越非染违犯。无违犯者。谓诸外道伺求过短。或有重病或心狂乱。或欲方便调彼伏彼出不善处安立善处。或于是法未善通利。或复见彼不生恭敬无有羞愧以恶威仪而来听受。或复知彼是钝根性于广法教得法究竟深生怖畏。当生邪见增长邪执衰损恼坏。或复知彼法至其手转布非人。而不施与皆无违犯

若诸菩萨安住菩萨净戒律仪。于诸暴恶犯戒有情。怀嫌恨心怀恚恼心由彼暴恶犯戒为缘。方便弃舍不作饶益。是名有犯有所违越。是染违犯。若由懒惰懈怠弃舍。由忘念故。不作饶益。是名有犯有所违越。非染违犯。何以故。非诸菩萨于净持戒身语意业寂静现行。诸有情所起怜愍心欲作饶益。如于暴恶犯戒有情于诸苦因而现转者。无违犯者。谓心狂乱。或欲方便调彼伏彼。广说如前。或为将护多有情心。或护僧制方便弃舍不作饶益。皆无违犯

若诸菩萨安住菩萨净戒律仪。如薄伽梵。于别解脱毗奈耶中。将护他故建立遮罪。制诸声闻令不造作。诸有情类未净信者令生净信。已净信者令倍增长。于中菩萨与诸声闻。应等修学无有差别。何以故。以诸声闻自利为胜。尚不弃舍将护他行。为令有情未信者信。信者增长学所学处。何况菩萨利他为胜。若诸菩萨安住菩萨净戒律仪。如薄伽梵。于别解脱毗奈耶中。为令声闻少事少业少悕望住建立遮罪。制诸声闻令不造作。于中菩萨与诸声闻不应等学。何以故。以诸声闻自利为胜不顾利他。于利他中少事少业少悕望住可名为妙。非诸菩萨利他为胜。不顾自利于利他中少事少业少悕望住得名为妙如是菩萨为利他故。从非亲里长者居士婆罗门等及恣施家。应求百千种种衣服。观彼有情有力无力。随其所施如应而受。如说求衣求钵亦尔。如求衣钵。如是自求种种丝缕令非亲里为织作衣。为利他故应畜种种憍世耶衣诸坐卧具。事各至百。生色可染百千俱胝。复过是数亦应取积。如是等中少事少业少悕望住制止遮罪。菩萨不与声闻共学。安住净戒律仪菩萨。于利他中怀嫌恨心怀恚恼心。少事少业少悕望住。是名有犯有所违越。是染违犯。若有懒惰懈怠忘念无记之心。少事少业少悕望住。是名有犯有所违越。非染违犯

若诸菩萨安住菩萨净戒律仪。善权方便为利他故。于诸性罪少分现行。由是因缘于菩萨戒无所违犯生多功德。谓如菩萨见劫盗贼为贪财故欲杀多生。或复欲害大德声闻独觉菩萨。或复欲造多无间业。见是事已发心思惟。我若断彼恶众生命堕那落迦。如其不断。无间业成当受大苦。我宁杀彼堕那落迦。终不令其受无间苦。如是菩萨意乐思惟。于彼众生或以善心或无记心。知此事已为当来故深生惭愧。以怜愍心而断彼命。由是因缘于菩萨戒无所违犯生多功德。又如菩萨见有增上增上宰官上品暴恶于诸有情无有慈愍专行逼恼。菩萨见已起怜愍心。发生利益安乐意乐。随力所能若废若黜增上等位。由是因缘于菩萨戒无所违犯生多功德。又如菩萨见劫盗贼夺他财物。若僧伽物窣堵波物。取多物已执为己有纵情受用。菩萨见已起怜愍心。于彼有情发生利益安乐意乐。随力所能逼而夺取。勿令受用如是财故。当受长夜无义无利。由此因缘所夺财宝。若僧伽物还复僧伽。窣堵波物还窣堵波。若有情物还复有情。又见众主或园林主。取僧伽物窣堵波物言是己有纵情受用。菩萨见已思择彼恶起怜愍心。勿令因此邪受用业当受长夜无义无利。随力所能废其所主。菩萨如是虽不与取。而无违犯生多功德。又如菩萨处在居家。见有母邑现无系属习淫欲法继心菩萨求非梵行。菩萨见已作意思惟。勿令心恚多生非福。若随其欲便得自在。方便安处令种善根。亦当令其舍不善业。住慈愍心行非梵行。虽习如是秽染之法。而无所犯多生功德。出家菩萨为护声闻圣所教诫令不坏灭。一切不应行非梵行。又如菩萨为多有情解脱命难囹圄缚难刖手足难劓鼻刵耳剜眼等难。虽诸菩萨为自命难亦不正知说于妄语。然为救脱彼有情故。知而思择故说妄语。以要言之。菩萨唯观有情义利非无义利。自无染心唯为饶益诸有情故。覆想正知而说异语。说是语时于菩萨戒无所违犯生多功德。又如菩萨。见诸有情为恶朋友之所摄受亲爱不舍。菩萨见已起怜愍心。发生利益安乐意乐。随能随力说离间语。令离恶友舍相亲爱。勿令有情由近恶友当受长夜无义无利。菩萨如是以饶益心说离间语。乖离他爱无所违犯生多功德。又如菩萨见诸有情为行越路非理而行。出粗恶语猛利诃摈。方便令其出不善处安立善处。菩萨如是以饶益心。于诸有情出粗恶语。无所违犯生多功德。又如菩萨见诸有情信乐倡伎吟咏歌讽。或有信乐王贼饮食淫荡街衢无义之论。菩萨于中皆悉善巧。于彼有情起怜愍心。发生利益安乐意乐。现前为作绮语。相应种种倡伎吟咏歌讽王贼饮食淫衢等论。令彼有情欢喜。引摄自在随属。方便奖导出不善处安立善处。菩萨如是现行绮语。无所违犯生多功德

若诸菩萨安住菩萨净戒律仪。生起诡诈虚谈现相。方便研求假利求利。味邪命法无有羞耻坚持不舍。是名有犯有所违越。是染违犯。无违犯者。若为除遣生起乐欲发勤精进。烦恼炽盛蔽抑其心时时现起

若诸菩萨安住菩萨净戒律仪。为掉所动心不寂静不乐寂静。高声嬉戏諠哗纷聒。轻躁腾跃望他欢笑。如此诸缘。是名有犯有所违越。是染违犯。若忘念起。非染违犯。无违犯者。若为除遣生起乐欲。广说如前。若欲方便解他所生嫌恨令息。若欲遣他所生愁恼若他性好如上诸事。方便摄受敬慎将护。随彼而转。若他有情猜阻菩萨。内怀嫌恨恶谋憎背。外现欢颜表内清净。如是一切皆无违犯。若诸菩萨安住菩萨净戒律仪。起如是见立如是论。菩萨不应忻乐涅槃。应于涅槃而生厌背。于诸烦恼及随烦恼。不应怖畏而求断灭。不应一向心生厌离。以诸菩萨三无数劫流转生死求大菩提。若作此说。是名有犯有所违越。是染违犯。何以故。如诸声闻于其涅槃忻乐亲近。于诸烦恼及随烦恼深心厌离。如是菩萨于大涅槃忻乐亲近。于诸烦恼及随烦恼深心厌离。其倍过彼百千俱胝。以诸声闻唯为一身证得义利勤修正行。菩萨普为一切有情证得义利。勤修正行。是故菩萨当勤修集无杂染心。于有漏事随顺而行。成就胜出诸阿罗汉无杂染法

若诸菩萨安住菩萨净戒律仪。于自能发不信重言。所谓恶声恶称恶誉不护不雪。其事若实而不避护。是名有犯有所违越。是染违犯。若事不实而不清雪。是名有犯有所违越。非染违犯。无违犯者。若他外道若他憎嫉若自出家。因行乞行因修善行谤声流布。若忿蔽者若心倒者谤声流布。皆无违犯

若诸菩萨安住菩萨净戒律仪。见诸有情应以种种辛楚加行猛利加行而得义利护其忧恼而不现行。是名有犯有所违越。非染违犯。无违犯者。观由此缘于现法中少得义利多生忧恼

若诸菩萨安住菩萨净戒律仪。他骂报骂他嗔报嗔。他打报打他弄报弄。是名有犯有所违越。是染违犯

若诸菩萨安住菩萨净戒律仪。于他有情有所侵犯。或自不为彼疑侵犯。由嫌嫉心由慢所执。不如理谢而生轻舍。是名有犯有所违越。是染违犯。若由懒惰懈怠放逸。不谢轻舍。是名有犯有所违越。非染违犯。无违犯者。若欲方便调彼伏彼出不善处安立善处。若是外道。若彼悕望要因现行非法有罪方受悔谢。若彼有情性好斗诤。因悔谢时倍增愤怒。若复知彼为性堪忍体无嫌恨。若必了他因谢侵犯深生羞耻。而不悔谢。皆无违犯。若诸菩萨安住菩萨净戒律仪。他所侵犯。彼还如法平等悔谢。怀嫌恨心欲损恼彼不受其谢。是名有犯有所违越。是染违犯。虽复于彼无嫌恨心不欲损恼。然由禀性不能堪忍故不受谢。亦名有犯有所违越。是染违犯。无违犯者。若欲方便调彼伏彼。广说一切如前应知。若不如法不平等谢。不受彼谢亦无违犯

若诸菩萨安住菩萨净戒律仪。于他怀忿相续坚持生已不舍。是名有犯有所违越。是染违犯。无违犯者。为断彼故生起乐欲。广说如前

若诸菩萨安住菩萨净戒律仪。贪着供事增上力故。以爱染心管御徒众。是名有犯有所违越。是染违犯。无违犯者。不贪供侍无爱染心管御徒众。若诸菩萨安住菩萨净戒律仪。懒惰懈怠耽睡眠乐卧乐倚乐。非时非量。是名有犯有所违越。是染违犯。无违犯者。若遭疾病若无气力行路疲极。若为断彼生起乐欲。广说一切如前应知

若诸菩萨安住菩萨净戒律仪。怀爱染心谈说世事虚度时日。是名有犯有所违越。是染违犯。若由忘念虚度时日。是名有犯有所违越。非染违犯。无违犯者。见他谈说护彼意故。安住正念须臾而听。若事希奇或暂问他或答他问。无所违犯

若诸菩萨安住菩萨净戒律仪。为令心住欲定其心。心怀嫌恨憍慢所持。不诣师所求请教授。是名有犯有所违越。是染违犯。懒惰懈怠而不请者。非染违犯。无违犯者。若遇疾病若无气力。若知其师颠倒教授。若自多闻自有智力能令心定。若先已得所应教授而不请者。无所违犯

若诸菩萨安住菩萨净戒律仪。起贪欲盖忍受不舍。是名有犯有所违越。是染违犯。无违犯者。若为断彼生起乐欲发勤精进。烦恼猛利蔽抑心故时时现行。如贪欲盖如是。嗔恚惛沉睡眠掉举恶作。及与疑盖当知亦尔。若诸菩萨安住菩萨净戒律仪。贪味静虑于味静虑见为功德。是名有犯有所违越。是染违犯。无违犯者。若为断彼生起乐欲。广说如前

若诸菩萨安住菩萨净戒律仪。起如是见立如是论。菩萨不应听声闻乘相应法教。不应受持不应修学。菩萨何用于声闻乘相应法教听闻受持精勤修学。是名有犯有所违越。是染违犯。何以故。菩萨尚于外道书论精勤研究。况于佛语。无违犯者。为令一向习小法者舍彼欲故。作如是说

若诸菩萨安住菩萨净戒律仪。于菩萨藏未精研究。于菩萨藏一切弃舍。于声闻藏一向修学。是名有犯有所违越。非染违犯

若诸菩萨安住菩萨净戒律仪。现有佛教于佛教中未精研究。于异道论及诸外论精勤修学。是名有犯有所违越。是染违犯。无违犯者。若上聪敏若能速受。若经久时能不忘失。若于其义能思能达。若于佛教如理观察。成就俱行无动觉者。于日日中常以二分修学佛语。一分学外。则无违犯。若诸菩萨安住菩萨净戒律仪。越菩萨法。于异道论及诸外论研求善巧。深心宝玩爱乐味着。非如辛药而习近之。是名有犯有所违越。是染违犯

若诸菩萨安住菩萨净戒律仪。闻菩萨藏。于甚深处最胜甚深真实法义诸佛菩萨难思神力。不生信解憎背毁谤。不能引义不能引法非如来说。不能利益安乐有情。是名有犯有所违越。是染违犯。如是毁谤或由自内非理作意。或随顺他而作是说

若诸菩萨安住菩萨净戒律仪。若闻甚深最甚深处心不信解。菩萨尔时应强信受。应无谄曲应如是学。我为非善盲无慧目。于如来眼随所宣说于诸如来密意语言而生诽谤。菩萨如是自处无知仰推如来于诸佛法无不现知。等随观见。如是正行无所违犯。虽无信解然不诽谤

若诸菩萨安住菩萨净戒律仪。于他人所有。染爱心有嗔恚心。自赞毁他。是名有犯有所违越。是染违犯。无违犯者。若为摧伏诸恶外道。若为住持如来圣教。若欲方便调彼伏彼。广说如前。或欲令其未净信者发生净信。已净信者倍复增长

若诸菩萨安住菩萨净戒律仪。闻说正法论议决择。憍慢所制怀嫌恨心怀恚恼心而不往听。是名有犯有所违越。是染违犯。若为懒惰懈怠所蔽而不往听。非染违犯。无违犯者。若不觉知。若有疾病。若无气力。若知倒说。若为护彼说法者心。若正了知彼所说义。是数所闻所持所了。若已多闻具足闻持其闻积集。若欲无间于境住心。若勤引发菩萨胜定。若自了知上品愚钝其慧钝浊。于所闻法难受难持难于所缘摄心令定。不往听者。皆无违犯

若诸菩萨安住菩萨净戒律仪。于说法师故思轻毁。不深恭敬嗤笑调弄。但依于文不依于义。是名有犯有所违越。是染违犯

若诸菩萨安住菩萨净戒律仪。于诸有情所应作事。怀嫌恨心怀恚恼心不为助伴。谓于能办所应作事。或于道路若往若来。或于正说事业加行。或于掌护所有财宝。或于和好乖离诤讼。或于吉会或于福业不为助伴。是名有犯有所违越。是染违犯。若为懒惰懈怠所蔽不为助伴。非染违犯。无违犯者。若有疹疾若无气力。若了知彼自能成办。若知求者自有依怙。若知所作能引非义能引非法。若欲方便调彼伏彼。广说如前。若先许余为作助伴。若转请他有力者助。若于善品正勤修习不欲暂废。若性愚钝于所闻法难受难持。如前广说。若为将护多有情意。若护僧制不为助伴。皆无违犯

若诸菩萨安住菩萨净戒律仪。见诸有情遭重疾病。怀嫌恨心怀恚恼心不往供事。是名有犯有所违越。是染违犯。若为懒惰懈怠所蔽不往供事。非染违犯。无违犯者。若自有病若无气力。若转请他有力随顺令往供事。若知病者有依有怙。若知病者自有势力能自供事。若了知彼长病所触堪自支持。若为勤修广大无上殊胜善品。若欲护持所修善品令无间缺。若自了知上品愚钝其慧钝浊于所闻法难受难持。难于所缘摄心令定。若先许余为作供事。如于病者。于有苦者为作助伴。欲除其苦当知亦尔

若诸菩萨安住菩萨净戒律仪。见诸有情为求现法后法事故广行非理。怀嫌恨心怀恚恼心。不为宣说如实正理。是名有犯有所违越。是染违犯。若由懒惰懈怠所蔽不为宣说。非染违犯。无违犯者。若自无知若无气力。若转请他有力者说。若即彼人自有智力。若彼有余善友摄受。若欲方便调彼伏彼。广说如前。若知为说如实正理起嫌恨心若发恶言若颠倒受若无爱敬。若复知彼性弊[怡-台+龍]悷。不为宣说。皆无违犯

若诸菩萨安住菩萨净戒律仪。于先有恩诸有情所。不知恩惠不了恩惠。怀嫌恨心不欲现前如应酬报。是名有犯有所违越。是染违犯。若为懒惰懈怠所蔽不现酬报。非染违犯。无违犯者。勤加功用无力无能不获酬报。若欲方便调彼伏彼。广说如前。若欲报恩而彼不受。皆无违犯

若诸菩萨安住菩萨净戒律仪。见诸有情堕在丧失财宝眷属禄位难处。多生愁恼。怀嫌恨心不往开解。是名有犯有所违越。是染违犯。若为懒惰懈怠所蔽不往开解。非染违犯。无违犯者。应知如前。于他事业不为助伴

若诸菩萨安住菩萨净戒律仪。有饮食等资生众具。见有求者来正悕求饮食等事。怀嫌恨心怀恚恼心而不给施。是名有犯有所违越。是染违犯。若由懒惰懈怠放逸不能施与。非染违犯。无违犯者。若现无有可施财物。若彼悕求不如法物所不宜物。若欲方便调彼伏彼。广说如前。若来求者王所匪宜将护王意。若护僧制而不惠施皆无违犯

若诸菩萨安住菩萨净戒律仪。摄受徒众怀嫌恨心。而不随时无倒教授无倒教诫。知众匮乏。而不为彼从诸净信长者居士婆罗门等。如法追求衣服饮食诸坐卧具病缘医药资身什物随时供给。是名有犯有所违越。是染违犯。若由懒惰懈怠放逸。不往教授。不往教诚。不为追求如法众具。非染违犯。无违犯者。若欲方便调彼伏彼。广说如前。若护僧制若有疹疾。若无气力不任加行。若转请余有势力者。若知徒众世所共知有大福德。各自有力求衣服等资身众具。若随所应教授教诫。皆已无倒教授教诫。若知众内有本外道为窃法故。来入众中无所堪能不可调伏。皆无违犯

若诸菩萨安住菩萨净戒律仪。怀嫌恨心于他有情不随心转。是名有犯有所违越。是染违犯。若由懒惰懈怠放逸不随其转。非染违犯。无违犯者。若彼所爱非彼所宜。若有疾病若无气力不任加行。若护僧制。若彼所爱虽彼所宜。而于多众非宜非爱。若为降伏诸恶外道。若欲方便调彼伏彼。广说如前不随心转。皆无违犯

若诸菩萨安住菩萨净戒律仪。怀嫌恨心。他实有德不欲显扬。他实有誉不欲称美。他实妙说不赞善哉。是名有犯有所违越。是染违犯。若由懒惰懈怠放逸不显扬等。非染违犯。无违犯者。若知其人性好少欲。将护彼意。若有疾病若无气力。若欲方便调彼伏彼。广说如前。若护僧制。若知由此显扬等缘起彼杂染憍举无义。为遮此过。若知彼德虽似功德而非实德。若知彼誉虽似善誉而非实誉。若知彼说虽似妙说而实非妙。若为降伏诸恶外道。若为待他言论究竟。不显扬等。皆无违犯

若诸菩萨安住菩萨净戒律仪。见诸有情应可诃责。应可治罚应可驱摈。怀染污心而不诃责。或虽诃责而不治罚如法教诫。或虽治罚如法教诫。而不驱摈。是名有犯有所违越。是染违犯。若由懒惰懈怠放逸。而不诃责乃至驱摈。非染违犯。无违犯者。若了知彼不可疗治。不可与语。喜出粗言多生嫌恨。故应弃舍。若观待时。若观因此斗讼诤竞。若观因此令僧諠杂令僧破坏。知彼有情不怀谄曲成就增上猛利惭愧。疾疾还净。而不诃责乃至驱摈。皆无违犯若诸菩萨安住菩萨净戒律仪。具足成就种种神通变现威力。于诸有情应恐怖者能恐怖之。应引摄者能引摄之。避信施故不现神通恐怖引摄。是名有犯有所违越。非染违犯。无违犯者。若知此中诸有情类多着僻执。是恶外道诽谤贤圣。成就邪见。不现神通恐怖引摄。无有违犯

又一切处无违犯者。谓若彼心增上狂乱。若重苦受之所逼切。若未曾受净戒律仪。当知一切皆无违犯

复次如是所起诸事菩萨学处。佛于彼彼素怛缆中随机散说。谓依律仪戒摄善法戒饶益有情戒。今于此菩萨藏摩呾履迦综集而说。菩萨于中应起尊重住极恭敬专精修学。是诸菩萨从他正受戒律仪已。由善清净求学意乐菩提意乐饶益一切有情意乐。生起最极尊重恭敬。从初专精不应违犯。设有违犯即应如法疾疾悔除令得还净。又此菩萨一切违犯。当知皆是恶作所摄。应向有力于语表义能觉能受小乘大乘补特伽罗。发露悔灭。若诸菩萨以上品缠违犯。如上他胜处法失戒律仪。应当更受。若中品缠违犯。如上他胜处法应对于三补特伽罗。或过是数。应如发露除恶作法。先当称述所犯事名。应作是说。长老专志。或言大德。我如是名违越菩萨毗奈耶法。如所称事犯恶作罪。余如苾刍发露悔灭恶作罪法。应如是说。若下品缠违犯。如上他胜处法及余违犯。应对于一补特伽罗发露。悔法当知如前。若无随顺补特伽罗可对发露悔除所犯。尔时菩萨以净意乐起自誓心。我当决定防护当来终不重犯。如是于犯还出还净。又诸菩萨欲受菩萨净戒律仪。若不会遇具足功德补特伽罗。尔时应对如来像前自受菩萨净戒律仪。应如是受。遍袒右肩右膝着地。或蹲跪坐作如是言。我如是名。仰启十方一切如来已入大地诸菩萨众。我今欲于十方世界佛菩萨所。誓受一切菩萨学处。誓受一切菩萨净戒。谓律仪戒摄善法戒饶益有情戒。如是学处如是净戒。过去一切菩萨已具。未来一切菩萨当具。普于十方现在一切菩萨今具。于是学处于是净戒。过去一切菩萨已学。未来一切菩萨当学。普于十方现在一切菩萨今学。第二第三亦如是说。说已应起。所余一切如前应知

又于菩萨犯戒道中。无无余犯。如世尊说。是诸菩萨多分应与嗔所起犯。非贪所起。当知此中所说密意。谓诸菩萨爱诸有情。怜诸有情增上力故。凡有所作一切皆是菩萨所作。非非所作。非作所作可得成犯。若诸菩萨憎诸有情嫉诸有情。不能修行自他利行。作诸菩萨所不应作。作不应作可得成犯。又诸菩萨软中上犯。如摄事分应当了知

如是菩萨依止一切自毗奈耶。勤学所学。便得成就三种圆满安乐而住。一者成就加行圆满。二者成就意乐圆满。三者成就宿因圆满。云何名为加行圆满。谓诸菩萨于净戒中行无缺犯。于身语意清净现行。不数毁犯发露自恶。如是名为加行圆满。云何名为意乐圆满。谓诸菩萨为法出家不为活命。求大菩提非为不求。为求沙门为求涅槃非为不求。如是求者不住懈怠下劣精进。不杂众多恶不善法杂染后有有诸炽然众苦异熟。当来所有生老病死。如是名为意乐圆满。云何名为宿因圆满。谓诸菩萨昔余生中修福修善。故于今世种种衣服饮食卧具病缘医药资身什物。自无匮乏。复能于他广行惠施。如是名为宿因圆满。菩萨如是依毗奈耶勤学所学。成就如是三种圆满安乐而住。与此相违当知成就三种衰损危苦而住

如是略广宣说菩萨若在家品若出家品一切戒已。自斯已后即于如是一切戒中。分出所余难行戒等差别之相。应当了知

瑜伽师地论卷第四十一瑜伽师地论卷第四十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处戒品第十之三

云何菩萨难行戒。当知此戒略有三种。谓诸菩萨现在具足大财大族自在增上。弃舍如是大财大族自在增上。受持菩萨净戒律仪。是名菩萨第一难行戒。又诸菩萨受净戒已。若遭急难乃至失命。于所受戒尚无少缺。何况全犯。是名菩萨第二难行戒。又诸菩萨如是如是遍于一切行住作意。恒住正念常无放逸。乃至命终于所受戒无有误失。尚不犯轻。何况犯重。是名菩萨第三难行戒

云何菩萨一切门戒。当知此戒略有四种。一者正受戒。二者本性戒。三者串习戒。四者方便相应戒。正受戒者。谓诸菩萨受先所受三种菩萨净戒律仪。即律仪戒摄善法戒饶益有情戒。本性戒者。谓诸菩萨住种性位。本性仁贤于相续中身语二业恒清净转。串习戒者。谓诸菩萨昔余生中曾串修习如先所说三种净戒。由宿因力所住持故。于现在世一切恶法不乐现行。于诸恶法深心厌离乐修善行。于善行中深心欣慕。方便相应戒者。谓诸菩萨依四摄事。于诸有情身语善业恒相续转

云何菩萨善士戒。当知此戒略有五种。谓诸菩萨自具尸罗。劝他受戒。赞戒功德。见同法者深心欢喜。设有毁犯如法悔除

云何菩萨一切种戒。当知此戒以要言之。六种七种。总十三种。言六种者。一回向戒。回向大菩提故。二广博戒。广摄一切所学处故。三无罪欢喜处戒。远离耽着欲乐自苦二边行故。四恒常戒。虽尽寿命亦不弃舍所学处故。五坚固戒。一切利养恭敬他论本随烦恼不能伏故不能夺故。六尸罗庄严具相应戒。具足一切戒庄严故。尸罗庄严如声闻地应知其相。言七种者。一止息戒。远离一切杀生等故。二转作戒。摄一切善故饶益有情故。三防护戒。随护止息转作戒故。四大士相异熟戒。五增上心异熟戒。六可爱趣异熟戒。七利有情异熟戒

云何菩萨遂求戒。当知此戒略有八种。谓诸菩萨自谛思惟。如我悕求勿彼于我现行断命。不与而取。秽欲。邪行。虚妄。离间。粗恶。绮语。手块杖等。诸非爱触加害于我。我求是已。他若相违而现行者。我求不遂我意不悦。如我悕求他亦如是。勿我于彼现行断命广说乃至恶触加害。彼求是已。我若相违而现行者。彼求不遂彼意不悦。我之所作若有令他所求不遂意不悦者。何现行为。菩萨如是审思惟已。命难因缘亦不于他现行八种所求不遂不悦意事。如是八种说名菩萨遂求戒。

云何菩萨此世他世乐戒。当知此戒略有九种。谓诸菩萨为诸有情。于应遮处而正遮止。于应开处而正开许。是诸有情应摄受者正摄受之。应调伏者正调伏之。菩萨于中身语二业常清净转。是则名为四种净戒。复有所余施忍精进静虑般若波罗蜜多俱行净戒。则为五种。总说名为九种净戒。如是菩萨所有净戒。能令自他现法后法皆得安乐。是故说名菩萨此世他世乐戒

云何菩萨清净戒。当知此戒略有十种。一者初善受戒。唯为沙门三菩提故。非为命故。二者不太沉戒。于违犯时远离微薄生悔愧故。及不太举戒。远离非处生悔愧故。三者离懈怠戒。于睡眠乐倚乐卧乐不耽着故。昼夜勤修诸善品故。四者离诸放逸所摄受戒。修习如前所说。五支不放逸故。五者正愿戒。远离利养恭敬贪故。不愿生天而自要期修梵行故。六者轨则具足所摄受戒。于诸威仪所作众事善品加行妙善圆满。如法身语正现行故。七者净命具足所摄受戒。离矫诈等一切邪命过失法故。八者离二边戒。远离受用欲乐自苦二边法故。九者永出离戒。远离一切外道见故。十者于先所受无损失戒。于先所受菩萨净戒。无缺减故。无破坏故。如是十种。是名菩萨清净戒

如是菩萨大尸罗藏。能起当来大菩提果。谓依此故菩萨净戒波罗蜜多得圆满已。现证无上正等菩提。乃至未证无上菩提。依此无量菩萨戒藏正勤修习。常能获得五种胜利。一者常为十方诸佛护念。二者将舍命时住大欢喜。三者身坏已后在在所生。常与净戒若等若增诸菩萨众。为其同分为同法侣为善知识。四者成就无量大功德藏。能满净戒波罗蜜多。五者现法后法常得成就自性净戒。戒成其性。

如是如上所说一切自性戒等九种尸罗。当知三种净戒所摄。谓律仪戒摄善法戒饶益有情戒。如是三种菩萨净戒。以要言之。能为菩萨三所作事。谓律仪戒能安住其心。摄善法戒能成熟自佛法。饶益有情戒能成熟有情。如是总摄一切菩萨所应作事。所谓欲令现法乐住安住其心。身心无倦成熟佛法成熟有情

如是菩萨唯有尔所菩萨净戒。唯有尔所净戒胜利。唯有尔所净戒所作。除此无有若过若增。过去菩萨求大菩提已于中学。未来菩萨求大菩提当于中学。普于十方无边无际诸世界中。现在菩萨求大菩提今于中学

    本地分中菩萨地第十五初持瑜伽处忍品第十一

云何菩萨忍波罗蜜多。嗢拖南曰

  自性一切难　　一切门善士
  一切种遂求　　二世乐清净
  如是九种相　　是名略说忍

谓九种相忍。名为菩萨忍波罗蜜多。一自性忍。二一切忍。三难行忍。四一切门忍。五善士忍。六一切种忍。七遂求忍。八此世他世乐忍。九清净忍

云何菩萨自性忍。谓诸菩萨或思择力为所依止。或由自性堪忍怨害。遍于一切皆能堪忍。普于一切皆能堪忍。由无染心纯悲愍故能有堪忍。当知此则略说菩萨忍之自性

云何菩萨一切忍。当知此忍略有二种。一依在家品忍。二依出家品忍。当知依此二种品忍各有三种。一耐他怨害忍。二安受众苦忍。三法思胜解忍。云何菩萨耐他怨害忍。谓诸菩萨猛利无间种种长时。从他怨害所生众苦现在前时。应如是学。如此是我自业过耳。由我先世自造种种不净业故。今受如是种种苦果。我今于此无义利苦若不忍者。复为当来大苦因处。我若于此大苦因法随顺转者。便为于己自作非爱。便为于己自生结缚。便为于己自兴怨害。非是于他。又自他身所有诸行。一切皆用性苦为体。彼无知故。于我身中性苦体上更增其苦。我既有知何宜于彼性苦体上重加其苦。多诸声闻多分唯修自义利行。尚不应起能生自他众苦不忍。何况我今正为勤修他义利行而生不忍。菩萨如是正思择已勤修五想。于怨亲中劣等胜品有乐有苦具德具失诸有情所。能忍一切怨害之苦。云何五想。一宿生亲善想。二随顺唯法想。三无常想。四苦想。五摄受想。云何菩萨于有怨害诸有情所。修习宿生亲善之想。谓诸菩萨应如是学。非易可得少分有情经历长世。昔余生中未曾为我若父若母兄弟姊妹亲教轨范尊似尊等。如是如理正思惟故。于有怨害诸有情所。舍怨憎想住亲善想。依亲善想于诸怨害悉能堪忍。云何菩萨于有怨害诸有情所。修习随顺唯法之想。谓诸菩萨应如是学。依托众缘唯行唯法。此中都无我及有情命者生者。是其能骂能嗔能打能弄能诃。或是所骂所嗔所打所弄所诃。如是如理正思惟故。于有怨害诸有情所。舍有情想住唯法想。依唯法想于诸怨害悉能堪忍。云何菩萨于有怨害诸有情所。修无常想。谓诸菩萨应如是学。诸有有情若生若长。一切无常皆是死法。极报怨者谓断彼命。是诸有情命念念断。智者何缘复欲更断如是生死性无常法。诸有情上其有智者。尚不应起有染浊心。况当以手块杖加害。何况一切永断其命。如是如理正思惟故。舍常坚想安住无常不坚固想。依无常想于诸怨害悉能堪忍。云何菩萨于有怨害诸有情所。修习苦想。谓诸菩萨应如是观。若诸有情大兴盛者。尚为三苦常所随逐。所谓行苦坏苦苦苦。况诸有情住衰损者。如是观已应如是学。我今于此苦常随逐诸有情所。应勤方便令离众苦。不应于彼重加其苦。如是如理正思惟故。断灭乐想生起苦想。依此苦想于诸怨害悉能堪忍。云何菩萨于有怨害诸有情所。修摄受想。谓诸菩萨应如是学。我为一切有情之类发菩提心。摄受一切有情之类皆为亲眷。我应为彼作诸义利。我今不应本于有情欲作义利而当于彼不忍怨害作非义利。如是如理正思惟故。于有怨害诸有情所。灭除他想住摄受想。依摄受想于诸怨害悉能堪忍。云何名忍。自无愤勃不报他怨。亦不随眠流注恒续故名为忍。是名菩萨耐他怨害忍云何菩萨安受众苦忍。谓诸菩萨应如是学。我从昔来依欲行转。常求诸欲故。意思择为诸苦因。追求种种苦性诸欲。于追求时忍受无量猛利大苦。所谓种种殉利务农勤王等事。如是追求无义苦时。令我具受种种大苦。皆由无智思择过失。我今为求能引安乐最胜善品。尚应思择忍受百千俱胝大苦。况少小苦而不忍受。如是如理正思惟故。为求菩提悉能忍受一切事苦。云何名为一切事苦。当知此苦略有八种。一依止处苦。二世法处苦。三威仪处苦。四摄法处苦。五乞行处苦。六勤劬处苦。七利他处苦。八所作处苦。依止处苦者。依谓四依。由依此故于善说法毗奈耶中。出家受具成苾刍分。所谓衣服饮食卧具病缘医药供身什物。菩萨于此若得粗弊鲜少稽留轻蔑不敬。不生忧悒。不由此缘精进懈废。如是名为菩萨忍受依止处苦。世法处苦者。当知世法略有九种。一衰。二毁。三讥。四苦。五坏法坏。六尽法尽。七老法老。八病法病。九死法死。如是世法若总若别。会遇现前能生众苦。此即名为世法处苦。菩萨触对如是众苦思择忍受。不由此缘精进懈废。如是名为菩萨忍受世法处苦。威仪处苦者。当知即是行住坐卧四种威仪。菩萨于中若行若坐。昼夜恒时从诸障法净修其心。终不非时胁着床座草敷叶敷。菩萨于此疲所生苦悉能忍受。不由此缘精进懈废。如是名为菩萨忍受威仪处苦。摄法处苦者。当知摄法略有七种。一供事三宝。二供事尊长。三咨受正法。四既咨受已广为他说。五以大音声吟咏赞诵。六独处空闲无倒思惟称量观察。七修习瑜伽作意所摄若止若观。菩萨于此七种摄法。勇猛劬劳所生众苦。悉能忍受。不由此缘精进懈废。如是名为菩萨忍受摄法处苦。乞行处苦者。当知此苦略有七种。一者自誓毁形剃须发等。弃舍世俗诸相好故。二者自誓毁色。受持改变坏色衣故。三者进止云为皆不纵任游涉世间。一切行住自兢摄故。四者依他活命舍商农等世间事业。从他所得而存济故。五者尽寿从他求衣服等。于所获得非法珍财久所贮积。不受用故。六者尽寿遮止人间诸欲。离非梵行淫欲法故。七者尽寿遮止人间嬉戏。舍离观听歌舞笑戏倡伎等故。及离与己亲友同龄笑戏欢娱携从等故。如是等类。因乞求行所有艰辛所生众苦。菩萨一切皆能忍受。不由此缘精进懈废。如是名为菩萨忍受乞行处苦。勤劬处苦者。谓诸菩萨勤修善品劬劳因缘。发生种种身心疲恼。悉能忍受。不由此缘精进懈废。如是名为菩萨忍受勤劬处苦。利他处苦者。谓诸菩萨修十一种利有情业。如前应知。由彼所生种种忧苦。菩萨一切皆能忍受。不由此缘精进懈废。如是名为菩萨忍受利他处苦。所作处苦者。谓诸菩萨或是出家。便有营为衣钵等业。或是在家便有无倒商估营农仕王等业。由此发生种种勤苦。菩萨一切皆能忍受。不由此缘精进懈废。如是名为菩萨忍受所作处苦。又诸菩萨虽触众苦。而于无上正等菩提。未正勤修能正勤修。已正勤修。能无退转常勤修习。无变异意无杂染心。是名菩萨安受众苦忍

云何菩萨法思胜解忍。谓诸菩萨于一切法。能正思择。由善观察胜觉慧故。能于八种生胜解处善安胜解。云何八种生胜解处。一三宝功德处。二真实义处。三诸佛菩萨大神力处。四因处。五果处。六应得义处。七自于彼义得方便处。八一切所知所应行处。又此胜解由二因缘。于彼诸处能善安立。一长时串习故。二证善净智故。是名菩萨法思胜解忍。如是菩萨依此二品一切忍故。当知广开难行忍等诸相差别

云何菩萨难行忍当知此忍略有三种。谓诸菩萨能于羸劣诸有情所。忍彼所作不饶益事。是名第一难行忍。若诸菩萨居尊贵位。于自臣隶不饶益事。堪能忍受。是名第二难行忍。若诸菩萨于其种姓卑贱有情所作增上不饶益事。堪能忍受。是名第三难行忍。

云何菩萨一切门忍。当知此忍略有四种。谓诸菩萨于亲所作不饶益事。于怨所作不饶益事。于中所作不饶益事。悉能堪忍。及于彼三劣等胜品不饶益事。皆能忍受

云何菩萨善士忍。当知此忍略有五种。谓诸菩萨先于其忍见诸胜利。谓能堪忍补特伽罗。于当来世无多怨敌无多乖离有多喜乐。临终无悔。于身坏后。当生善趣天世界中。见胜利已。自能堪忍劝他行忍赞忍功德。见能行忍补特伽罗慰意庆喜

云何菩萨一切种忍。当知此忍六种七种。总十三种。云何六种。谓诸菩萨了知不忍非爱异熟。由怖畏故勤修行忍。于诸有情有哀怜心有悲愍心有亲爱心。由亲善故勤修行忍。于其无上正等菩提猛利欲乐。为圆满忍波罗蜜多。由是因缘勤修行忍。如世尊说。夫出家者具忍辱力。由是因缘不应出家受具足戒而行不忍。由法受故勤修行忍。种姓具足先串习忍。于今现在安住自性故能修忍。知一切法远离有情。唯见诸法无戏论性。谛察法故能修行忍。云何七种。谓于一切不饶益忍。从一切忍。一切处忍。谓于屏处及大众前皆能修忍。一切时忍。谓昼初分若昼中分若昼后分。若夜若日若去来今。若病不病若卧若起。常能修忍。由身行忍不捶打故。由语行忍不出一切非爱言故。由意行忍不愤发故。不持污浊恶意乐故。

云何菩萨遂求忍。当知此忍略有八种。谓诸菩萨于诸有苦来求索者恶逼能忍。于极凶暴上品恶业诸有情所。依法大悲不损恼忍。于诸出家犯戒者所。依法大悲不损恼忍

复有五种耐勤苦忍。谓能堪耐除遣有苦有情众苦所有勤苦。又能堪耐求法勤苦。又能堪耐法随法行所有勤苦。又能堪耐即于彼法广为他说所有勤苦。又能堪耐于诸有情所为所作正与助伴所有勤苦。如是八种名遂求忍。若于有情有损恼者。由忍故离若于有情是所求者。由忍故与。是故说此名遂求忍。

云何菩萨此世他世乐忍。当知此忍略有九种。谓诸菩萨住不放逸。于诸善法悉能堪忍。于诸寒热悉能堪忍。于诸饥渴悉能堪忍。于蚊虻触悉能堪忍。于诸风日悉能堪忍。于蛇蝎触悉能堪忍。于诸劬劳所生种种若身若心疲惓忧恼悉能堪忍。于堕生死生老病死等苦有情现前。哀愍而修行忍。如是菩萨修行忍故。能令自身于现法中得安乐住。不为一切恶不善法之所陵杂。能引后世安乐因缘。亦能令他修行种种现法后法安乐正行。是名此世他世乐忍

云何菩萨清净忍。当知此忍略有十种。谓诸菩萨遇他所作不饶益事损恼违越。终不返报。亦不意愤亦无怨嫌意。乐相续恒常现前。欲作饶益先后无异。非一益己舍而不益。于有怨者自往悔谢。终不令他生疲厌已然后受谢。恐其疲厌才谢便受。于不堪忍。成就增上猛利惭愧。依于堪忍于大师所。成就增上猛利爱敬。依不损恼诸有情故。于诸有情成就猛利哀愍爱乐。一切不忍并助伴法皆得断故。离欲界欲。由此十相。

当知菩萨所修行忍清净无垢当知此中初自性忍。广说乃至后清净忍。如是能生广博无量大菩提果。忍为依止。是诸菩萨能圆满忍波罗蜜多。能证无上正等菩提

    本地分中菩萨地第十五初持瑜伽处精进品第十二

云何菩萨精进波罗蜜多。嗢拖南曰

  自性一切难　　一切门善士
  一切种遂求　　二世乐清净
  如是九种相　　名略说精进

谓九种相精进。名为菩萨精进波罗蜜多。一者自性精进。二者一切精进。三者难行精进四者一切门精进。五者善士精进。六者一切种精进。七者遂求精进。八者此世他世乐精进。九者清净精进

云何菩萨自性精进。谓诸菩萨其心勇悍。堪能摄受无量善法。利益安乐一切有情。炽然无间无有颠倒。及此所起身语意动。当知是名菩萨所行精进自性

云何菩萨一切精进。谓此精进略有二种。一者依在家品精进。二者依出家品精进。当知依此二品精进各有三种。一擐甲精进。二摄善法精进。三饶益有情精进

云何菩萨擐甲精进。谓诸菩萨于发加行精进之前。其心勇悍先擐誓甲。若我为脱一有情。苦以千大劫等一日夜。处那洛迦不在余趣。乃至菩萨经尔所时。证得无上正等菩提。假使过此百千俱胝倍数时劫。方证无上正等菩提。我之勇悍亦无退屈。于求无上正等菩提非不进趣。既进趣已勤勇无懈。何况所经时短苦薄。是名菩萨擐甲精进。若有菩萨于如是相菩萨所有擐甲精进。少起胜解少生净信。如是菩萨尚已长养无量勇猛。发勤精进大菩提性。何况菩萨成就如是擐甲精进。如是菩萨于求菩提饶益有情。无有少分难行事业可生怯劣难作之心

云何菩萨摄善法精进。谓诸菩萨所有精进。能为施戒忍精进静虑慧波罗蜜多加行。能成办施戒忍精进静虑慧波罗蜜多。当知此复略有七种。一无动精进。一切分别种种分别。根本烦恼少分烦恼。一切异论一切苦触。不倾动故。二坚固精进。是殷重加行故。三无量精进。能现证得一切明处故。四方便相应精进。所应得义无颠倒道随顺而行故。平等通达故。五无倒精进。为欲证得能引义利所应得义愿所引故。六恒常精进。是无间加行故。七离慢精进。由勤精进离高举故。由此七种摄善法精进勤加行故。令诸菩萨速能圆满波罗蜜多疾证无上正等菩提。由此精进是能修证能成菩提。一切善法最胜因缘。余则不尔。是故如来以种种门。称赞精进能证无上正等菩提

云何菩萨饶益有情精进。谓此精进有十一种。如戒品说。彼说尸罗此说精进。当知是名彼此差别

云何菩萨难行精进。谓此精进略有三种。若诸菩萨无间远离诸衣服想诸饮食想诸卧具想及己身想。于诸善法无间修习曾无懈废。是名第一难行精进。若诸菩萨如是精进。尽众同分于一切时曾无懈废。是名第二难行精进。若诸菩萨平等通达功德相应。不缓不急无有颠倒。能引义利精进成就。是名第三难行精进。如是菩萨难精进力。当知即是缘。有情悲及与般若能摄之因

云何菩萨一切门精进。谓此精进略有四种。一离染法精进。二引白法精进。三净除业精进。四增长智精进。离染法精进者。谓诸菩萨所有精进。能令一切结缚随眠随烦恼缠未生不生已生断灭。引白法精进者。谓诸菩萨所有精进。一切善法未生令生已生令住。令不忘失增长广大。净除业精进者。谓诸菩萨所有精进。能令三业皆悉清净。能摄妙善身语意业。增长智精进者。谓诸菩萨所有精进。能集能增闻思修慧

云何菩萨善士精进。谓此精进略有五种。一无所弃舍精进。谓诸菩萨所有精进。不舍一切。欲加行故。二无退减精进。谓诸菩萨所有精进。如先所受若等若增。发勤精进随长养故。三无下劣精进。谓诸菩萨所有精进。勇猛炽然。长时无间精勤策励。心无怯弱无退屈故。四无颠倒精进。谓诸菩萨所有精进。能引义利。方便善巧所摄持故。五勤勇加行精进。谓诸菩萨所有精进。能于无上正等菩提达进趣故

云何菩萨一切种精进。谓此精进六种七种。总十三种。云何菩萨六种精进。一无间精进。谓一切时修加行故。二殷重精进。谓能周备修加行故。三等流精进。谓先因力所任持故。四加行精进。数数思择种种善品正加行故。五无动精进。一切苦触不能动故。亦不转成余性分故。六无喜足精进。少分下劣差别证中不喜足故。菩萨成就如是六种。一切种精进发勤精进故。所以说言有势有勤有勇坚猛。于诸善法不舍其轭。云何菩萨七种精进。一与欲俱行精进。谓诸菩萨所有精进。数于无上正等菩提。猛利欲愿随长养故。二平等相应精进。谓诸菩萨所有精进。能令随一根本烦恼及随烦恼。不染污心亦不缠心由此精进。能令菩萨于诸善法等习而住。三胜进精进。谓诸菩萨若为随一根本烦恼及随烦恼染心缠心。为断如是诸烦恼故。精进勇猛如灭头然。四勤求精进。谓诸菩萨勇猛勤求一切明处无厌倦故。五修学精进。谓诸菩萨于所学法如应如宜。普于一切法随法行能成办故。六利他精进。谓诸菩萨所有精进。于如前说十一种相。应知其相。七善护精进。谓诸菩萨所有精进。起正加行善自防守。若有所犯如法悔除。如是菩萨十三种精进名一切种精进。

菩萨所有遂求精进。此世他世乐精进。如忍应知。其差别者。彼说堪忍。此说菩萨精进勇悍。

云何菩萨清净精进。谓此精进略有十种。一相称精进。二串习精进。三无缓精进。四善摄精进。五应时修习精进。六通达众相精进。七不退弱精进。八不舍轭精进。九平等精进。十回向大菩提精进。若诸菩萨或为彼彼诸随烦恼极所逼切。为断彼彼随烦恼故。修习种种相称对治。谓为对治诸贪欲故修习不净。为欲对治诸嗔恚故修习慈愍。为欲对治诸愚痴故修习观察缘性缘起。为欲对治诸寻思故修习息念。为欲对治诸憍慢故修界差别。如是等类。是名菩萨相称精进。若诸菩萨非唯成就始业。初业所有精进。谓为住心教授教诫。非不亦由串习加行积习加行。是名菩萨串习精进。若诸菩萨亦非唯有串习加行积习加行。为住其心教授教诫。然此始业初业菩萨。于此加行不缓加行无间加行殷重加行。是名菩萨无缓精进。若诸菩萨从师长所。或自多闻力所持故无倒而取。为住其心发勤精进。是名菩萨善摄精进。若诸菩萨无倒取已。于应止时能正修止。于应举时能策其心。于应舍时能正修舍。是名菩萨应时修习相应精进。若诸菩萨于其种种止举舍相入住出相。能善了知能无忘失。能善通达无间修作殷重修作。是名菩萨通达众相相应精进。若诸菩萨闻说种种最极广大最极甚深不可思议不可度量菩萨精进。不自轻蔑心不怯弱。不于所有少分下劣差别证中而生喜足不求上进。是名菩萨不退弱精进。若诸菩萨于时时间。密护根门饮食知量。初夜后夜常勤修习觉寤瑜伽。正知而住。于如是类等持资粮。能摄受转。即于其中炽然修习。于能引摄无倒义利。于一切时勤加功用。是名菩萨不舍轭精进。若诸菩萨发勤精进。不缓不急平等双运。普于一切应作事中。亦能平等殷重修作。是名菩萨平等精进。若诸菩萨一切精进有所为作。无不皆为回向无上正等菩提。是名菩萨回向大菩提精进

如是最初自性精进。乃至最后清净精进。皆得菩萨大菩提果。菩萨依此所有精进。圆满精进波罗蜜多。能于无上正等菩提。速疾已证当证今证

瑜伽师地论卷第四十二瑜伽师地论卷第四十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处静虑品第十三

云何菩萨静虑波罗蜜多。嗢拖南曰

  自性一切难　　一切门善士
  一切种遂求　　二世乐清净
  如是九种相　　名略说静虑

谓九种相静虑。名为菩萨静虑波罗蜜多。一者自性静虑。二者一切静虑。三者难行静虑。四者一切门静虑。五者善士静虑。六者一切种静虑。七者遂求静虑。八者此世他世乐静虑。九者清净静虑

云何菩萨自性静虑。谓诸菩萨于菩萨藏闻思为先。所有妙善世出出间心一境性。心正安住或奢摩他品或毗钵舍那品或双运道。俱通二品。当知即是菩萨所有静虑自性

云何菩萨一切静虑。谓此静虑略有二种。一者世间静虑。二者出世间静虑。当知此二随其所应复有三种。一者现法乐住静虑。二者能引菩萨等持功德静虑。三者饶益有情静虑。若诸菩萨所有静虑。远离一切分别。能生身心轻安最极寂静远离憍举。离诸爱味泯一切相。当知是名菩萨现法乐住静虑。若诸菩萨所有静虑。能引能住种种殊胜不可思议不可度量十力种姓所摄等持。如是等持。一切声闻及独觉等不知其名。何况能入。若诸菩萨所有静虑。能引能住一切菩萨解脱胜处遍处无碍解无诤愿智等。共诸声闻所有功德。当知是名能引菩萨等持功德静虑。菩萨饶益有情静虑有十一种。如前应知。谓诸菩萨依止静虑。于诸有情能引义利彼彼事业。与作助伴于有苦者能为除苦。于诸有情能如理说。于有恩者知恩知惠现前酬报。于诸怖畏能为救护。于丧失处能解愁忧。于有匮乏施与资财。于诸大众善能匡御。于诸有情善随心转。于实有德赞美令喜。于诸有过能正调伏。为物现通恐怖引摄。如是一切总名菩萨一切静虑。此外无有若过若增

云何菩萨难行静虑。谓此静虑略有三种。若诸菩萨已能安住广大殊胜。极善成熟多所引发诸静虑住。随自欲乐舍彼最胜诸静虑乐。愍有情故。等观无量利有情事。为诸有情义利成熟故。意思择还生欲界。当知是名菩萨第一难行静虑。若诸菩萨依止静虑。能发种种无量无数不可思议。超过一切声闻独觉所行境界菩萨等持。当知是名菩萨第二难行静虑。若诸菩萨依止静虑。速证无上正等菩提。当知是名菩萨第三难行静虑。

云何菩萨一切门静虑。谓此静虑略有四种。一者有寻有伺静虑。二者喜俱行静虑。三者乐俱行静虑。四者舍俱行静虑

云何菩萨善士静虑。谓此静虑略有五种。一者无爱味静虑。二者慈俱行静虑。三者悲俱行静虑。四者喜俱行静虑。五者舍俱行静虑

云何菩萨一切种静虑。谓此静虑六种七种。总十三种。言六种者。一者善静虑。二者无记变化静虑。三者奢摩他品静虑。四者毗钵舍那品静虑。五者于自他利正审思惟静虑。六者能引神通威力功德静虑。言七种者。一者名缘静虑。二者义缘静虑。三者止相缘静虑。四者举相缘静虑。五者舍相缘静虑。六者现法乐住静虑。七者能饶益他静虑。如是十三种名为菩萨一切种静虑

云何菩萨遂求静虑。谓此静虑略有八种。一者于诸毒药霜雹毒热鬼所魅等种种灾患。能息能成咒术所依静虑。二者于界互违所生众病。能除静虑。三者于诸饥馑大灾旱等现在前时。兴致甘雨静虑。四者于其种种人非人作水陆怖畏。能正拔济静虑。五者于乏饮食堕在旷野诸有情类。能施饮食静虑。六者于乏财位所化有情。能施种种财位静虑。七者于十方界放逸有情。能正谏诲静虑。八者于诸有情随所生起所应作事。能正造作静虑

云何菩萨此世他世乐静虑。谓此静虑略有九种。一者神通变现调伏有情静虑。二者记说变现调伏有情静虑。三者教诫变现调伏有情静虑。四者于造恶者示现恶趣静虑。五者于失辩者能施辩才静虑。六者于失念者能施正念静虑。七者制造建立无颠倒论微妙赞颂摩怛理迦。能令正法久住静虑。八者于诸世间工巧业处。能引义利饶益有情。种种书算测度数印床座伞屧。如是等类种种差别资生众具。能随造作静虑。九者于生恶趣所化有情。为欲暂时息彼众苦。放大光明照触静虑

云何菩萨清净静虑。谓此静虑略有十种。一者由世间净离诸爱味清净静虑。二者由出世净无有染污清净静虑。三者由加行净清净静虑。四者由得根本净清净静虑。五者由根本胜进净清净静虑。六者由入住出自在净清净静虑。七者舍静虑已复还证入自在净清净静虑。八者神通变现自在净清净静虑。九者离一切见趣净清净静虑。十者一切烦恼所知障净清净静虑

如是静虑无量无边。能得菩萨大菩提果。菩萨依此圆满静虑波罗蜜多。能于无上正等菩提。速疾已证当证今证

    本地分中菩萨地第十五初持瑜伽处慧品第十四

云何菩萨慧波罗蜜多。嗢拖南曰

  自性一切难　　一切门善士
  一切种遂求　　二世乐清净
  如是九种相　　是名略说慧

谓九种相慧。名为菩萨慧波罗蜜多。一者自性慧。二者一切慧。三者难行慧。四者一切门慧。五者善士慧。六者一切种慧。七者遂求慧。八者此世他世乐慧。九者清净慧

云何菩萨自性慧。谓能悟入一切所知。及已悟入一切所知简择诸法。普缘一切五明处转。一内明处。二因明处。三医方明处。四声明处。五工业明处。当知即是菩萨一切慧之自性

云何菩萨一切慧。当知此慧略有二种。一者世间慧。二者出世间慧。此二略说复有三种。一能于所知真实随觉通达慧。二能于如所说五明处及三聚中决定善巧慧。三能作一切有情义利慧。若诸菩萨于离言说法无我性。或于真谛将欲觉悟。或于真谛正觉寤时。或于真谛觉寤已后所有妙慧。最胜寂静明了现前。无有分别离诸戏论。于一切法悟平等性。入大总相究达一切所知边际。远离增益损减二边顺入中道。是名菩萨能于所知真实随觉通达慧。若诸菩萨于五明处决定善巧。广说如前力种性品应知其相。及于三聚中决定善巧。谓于能引义利法聚。能引非义利法聚。能引非义利非非义利法聚。皆如实知。于是八处所有妙慧善巧摄受。能速圆满广大无上妙智资粮。速证无上正等菩提。能作一切有情义利。慧有十一种如前应知。即于彼位所有妙慧。当知是名饶益有情慧

云何菩萨难行慧。当知此慧略有三种。若诸菩萨能知甚深法无我智。是名第一难行慧。若诸菩萨能了有情调伏方便智。是名第二难行慧。若诸菩萨了知一切所知境界无障碍智。是名第三最难行慧

云何菩萨一切门慧。当知此慧略有四种。谓于声闻藏及菩萨藏所有胜妙闻所成慧思所成慧。于能思择菩萨所应作应随转中。及菩萨所不应作应止息中。思择力所摄慧。及修习力所摄三摩呬多地无量慧

云何菩萨善士慧。当知此慧略有五种。一听闻正法所集成慧。二内正作意俱行慧。三自他利行方便俱行慧。四于诸法法住法安立无颠倒中善决定慧。五舍烦恼慧。复有异门一微细慧。悟入所知如所有性故。二周备慧。悟入所知尽所有性故。三俱生慧。宿智资粮所集成故。四具教慧。能于诸佛已入大地诸菩萨众所闻法义具受持故。五具证慧。从净意乐地乃至到究竟地所摄受故

云何菩萨一切种慧。当知此慧六种七种。总十三种。六种慧者。谓于诸谛苦智集智灭智道智。于究竟位尽智无生智。是名六慧。七种慧者。谓法智。类智。世俗智。神通智。相智。十力前行智。四道理中正道理智

云何菩萨遂求慧。当知此慧略有八种。一依法异门智。所谓菩萨法无碍慧。二依法相智。所谓菩萨义无碍慧。三依法释词智。所谓菩萨释词无碍慧。四依法品类句差别智。所谓菩萨辩才无碍慧。五菩萨一切摧伏他论慧。六菩萨一切成立自论慧。七菩萨一切正训营为家属家产慧。八菩萨一切善解种种王正世务慧

云何菩萨此世他世乐慧。当知此慧略有九种。谓诸菩萨于内明处。能善明净善安住慧。于医方明处。因明处。声明处。世工业明处。能善明净非安住慧。一切菩萨即用如是于五明处善明净慧以为依止。于他愚痴放逸怯弱勤修正行所化有情。如其次第示现教导赞励庆慰慧

云何菩萨清净慧。当知此慧略有十种。于真实义有二种慧。谓由尽所有性。及如所有性取真实义故。于流转义有二种慧。谓取正因果故。于执受义有二种慧。谓颠倒不颠倒如实了知故。于方便义有二种慧。谓一切所应作。所不应作。如实了知故。于究竟义有二种慧。谓杂染如实了知杂染故。清净如实了知清净故。如是菩萨五义十种差别净慧。当知是名最胜净慧

如是菩萨极善决定无量妙慧。能证菩萨大菩提果。菩萨依此能圆满慧波罗蜜多。速证无上正等菩提

复次如是六种波罗蜜多。世尊彼彼素怛缆中处处散说。今于此中摄在一处略说应知。谓佛所说素怛缆中所有施波罗蜜多。乃至慧波罗蜜多。或标或释彼皆于此。或自性施广说乃至或清净施趣入摄受。如其所应皆当了知。如是所余如所宣说。戒乃至慧趣入摄受。如其所应亦当了知。又诸如来为菩萨时。所行一切菩萨行中。所有无量本生相应难行苦行。当知一切与施相应依止于施。如说其施。如是戒忍精进静虑慧。相应依止戒忍精进静虑慧。当知亦尔。或唯依施广说乃至或唯依慧。或杂依二或杂依三。或杂依四或杂依五。或杂依一切。六波罗蜜多皆应了知。

如是六种波罗蜜多。菩萨为证无上正等菩提果故。精勤修集是大白法溟。名大白法海。是一切有情一切种类圆满之因。名为涌施大宝泉池。又即如是所集无量福智资粮。更无余果可共相称。唯除无上正等菩提

    本地分中菩萨地第十五初持瑜伽处摄事品第十五

云何菩萨四种摄事。嗢拖南曰

  自性一切难　　一切门善士
  一切种遂求　　二世乐清净
  如是九种相　　名略说摄事

谓九种相摄事。名为菩萨四种摄事。一者自性摄事。二者一切摄事。三者难行摄事。四者一切门摄事。五者善士摄事。六者一切种摄事。七者遂求摄事。八者此世他世乐摄事。九者清净摄事。

云何菩萨自性爱语。谓诸菩萨于诸有情。常乐宣说悦可意语谛语法语引摄义语。当知是名略说菩萨爱语自性

云何菩萨一切爱语。谓此爱语略有三种。一者菩萨设慰喻语。由此语故菩萨恒时对诸有情。远离颦蹙先发善言。舒颜平视含笑。为先或问安隐吉祥。或问诸界调适。或问昼夜怡乐。或命前进善来。以是等相慰问有情。随世仪转顺睹人性。二者菩萨设庆悦语。由此语故菩萨若见有情妻子眷属财谷其所昌盛而不自知。如应觉悟以申庆悦。或知信戒闻舍慧增亦复庆悦。三者菩萨设胜益语。由此语故菩萨宣说一切种德圆满法教相应之语。利益安乐一切有情。恒常现前以胜益语而为饶益。是名菩萨一切爱语差别应知

云何略说如是菩萨一切爱语。当知此语略为二种。一随世仪轨语。二顺正法教语。若慰喻语若庆悦语。当知是名随世仪轨语。若胜益语。当知是名顺正法教语

云何菩萨难行爱语。当知此语略有三种。若诸菩萨于能杀害怨家恶友。以善净心无秽浊心。思择为说。若慰喻语若庆悦语若胜益语。当知是名菩萨第一难行爱语。若诸菩萨于其上品愚痴钝根诸有情所。心无疑虑。思择为说种种法教。誓受疲劳。如理如法如善摄取。当知是名菩萨第二难行爱语。若诸菩萨于其谄诈欺诳亲教轨范尊长真实福田。行邪恶行诸有情所。无嫌恨心无恚恼心思择为说。若慰喻语若庆悦语若胜益语。当知是名菩萨第三难行爱语

云何菩萨一切门爱语。当知此语略有四种。一欲断诸盖向善趣者。为说先时所应作法。二远离诸盖心调善者。为说增进四圣谛等相应正法。三在家出家多放逸者。无倒谏诲。方便令其出离放逸行住不放逸行。四于诸法中多疑惑者。为令当来离疑惑故。为说正法论义决择

云何菩萨善士爱语。当知此语略有五种。谓诸菩萨为所化生。能说如来及诸菩萨有因缘法。有出离法。有所依法。有勇决法。有神变法。若所说法得处有因。制立学处。是故此法名有因缘。若所说法于所受学有毁犯者。施设还净。是故此法名有出离。若所说法四依所摄。施设无倒法律正行。是故此法名有所依。若所说法能正显示出一切苦不退还行。是故此法名有勇决。若所说法作三神变。一切所说终不唐捐。是故此法名有神变。

云何菩萨一切种爱语。当知此语六种七种。总十三种。言六种者。一于应听法开听爱语。二于应制法遮制爱语。三开示诸法法门爱语。四开示无倒法相爱语。五开示无倒训释诸法言词爱语。六开示无倒法句品类差别爱语。言七种者。一慰喻爱语。二庆悦爱语。三于他有情一切资具少希欲中一切所作及以正至少希欲中广恣爱语。四安慰种种惊怖爱语。五如理宣说所摄爱语。六为欲令他出不善处安住善处正见闻疑举呵爱语。七请他有力饶益爱语。如是菩萨十三种语。当知名为一切种爱语

云何菩萨遂求爱语。当知此语略有八种。谓诸菩萨依四净语起八圣语。是名菩萨遂求爱语。四净语者。谓离妄语及以离间。粗恶。绮语。八圣语者。谓见言见。闻言闻。觉言觉。知言知。不见言不见。不闻言不闻。不觉言不觉。不知言不知。

云何菩萨此世他世乐爱语。当知此语略有九种。一说正法断亲属难愁忧爱语。二说正法断财位难愁忧爱语。三说正法断无病难愁忧爱语。四说正法断净戒难众苦爱语。五说正法断正见难众苦爱语。六说正法赞美净戒圆满爱语。七说正法赞美正见圆满爱语。八说正法赞美轨则圆满爱语。九说正法赞美正命圆满爱语。

云何菩萨清净爱语。当知此语有二十种。谓二十相宣说正法。应知如前力种性品

云何菩萨利行。谓此利行。广如爱语应知其相。于利行中余差别义。我今当说。谓诸菩萨由一切品差别爱语。随说彼彼趣义利行。饶益有情故名利行

云何菩萨自性利行。谓诸菩萨由彼爱语。为诸有情示现正理。随其所应于诸所学。随义利行法随法行。如是行中安住悲心无爱染心。劝导调伏安处建立。是名略说利行自性

云何菩萨一切利行。当知此行略有二种。一未成熟有情能成熟利行。二已成熟有情令解脱利行。即此利行复由三门。一于现法利劝导利行。二于后法利劝导利行。三于现法后法利劝导利行。于现法利劝导利行者。谓正劝导以法。业德招集。守护增长财位。当知是名于现法利劝导利行。由此能令从他获得广大名称及现法乐。由资具乐摄受安住。于后法利劝导利行者。谓正劝导弃舍财位。清净出家受乞求行以自存活。当知是名于后法利劝导利行。由此能令决定获得后法安乐。不必获得现法安乐。于现法后法利劝导利行者。谓正劝导令在家者或出家者渐次修行趣向离欲。当知是名于现法后法利劝导利行。由此能令于现法中得身轻安。得心轻安。安乐而住。于后法中或生净天。或无余依涅槃界中而般涅槃

云何菩萨难行利行。当知此行略有三种。若诸菩萨于先未行胜善根因。诸有情所能行利行。是名第一难行利行。何以故。彼诸有情难劝导故。若诸菩萨于有善因现前执着广大财位众具圆满诸有情所。能行利行。是名第二难行利行。何以故。彼于广大极放逸迹极放逸处。耽着转故。若诸菩萨于诸外道着本异道邪见邪行诸有情所。能行利行。是名第三难行利行。何以故。彼于自宗愚痴执故。于正法律憎背执故

云何菩萨一切门利行。当知此行略有四种。谓诸菩萨不信有情。于信圆满殷勤劝导乃至建立。犯戒有情。于戒圆满殷勤劝导乃至建立。恶慧有情。于慧圆满殷勤劝导乃至建立。悭吝有情。于舍圆满殷勤劝导乃至建立。

云何菩萨善士利行。当知此行略有五种。谓诸菩萨于真实义劝导有情。于应时宜劝导有情。于能引摄胜妙义利劝导有情。于诸有情柔软劝导。于诸有情慈心劝导

云何菩萨一切种利行。当知此行六种七种。总十三种。云何六种。谓诸菩萨若诸有情应摄受者正摄受之。若诸有情应调伏者正调伏之。若诸有情憎背圣教除其恚恼。若诸有情处中住者令入圣教。若诸有情已入圣教。正于三乘令其成熟。若诸有情已成熟者令得解脱。云何七种。谓诸菩萨安处一分所化有情。于善资粮守护长养。所谓或依下乘出离。或复依于大乘出离。如令所化于善资粮守护长养。如是或于远离。或于心一境性。或于清净诸障。或于修习作意。正安处之。若有声闻独觉种性。即于声闻独觉乘中而正安处。若有如来种姓有情。即于无上正等菩提最上乘中而正安处

云何菩萨遂求利行。当知此行略有八种。谓诸菩萨见诸有情。于应惭处为无惭缠之所缠绕。方便开解令离彼缠。如无惭缠如是。见有于应愧处为无愧缠之所缠绕。若惛沈缠若睡眠缠。若掉举缠若恶作缠嫉缠悭缠之所缠绕。方便开解令离彼缠

云何菩萨此世他世乐利行。当知此行略有九种。谓诸菩萨于他有情。依净身业。劝令远离一切杀生。劝令远离诸不与取。劝令远离诸欲邪行。劝令远离一切窣罗若迷隶耶及以末陀放逸处酒。依净语业。劝令远离一切妄语劝令远离诸离间语。劝令远离诸粗恶语。劝令远离一切绮语。依净意业。劝令远离一切贪欲嗔恚邪见。

云何菩萨清净利行。当知此行略有十种。谓诸菩萨于诸有情。依外清净有五利行。依内清净有五利行。云何菩萨于诸有情依外清净有五利行。一无罪利行。二不转利行。三渐次利行。四遍行利行。五如应利行。谓诸菩萨于诸有情杂恶行者。先恶行者。有罪行者。杂染行者。于诸善中能正安处。是名菩萨于诸有情无罪利行。又诸菩萨于诸有情。不于非解脱非定清净处求为真解脱求为定清净者即于其中能正劝导。是名菩萨于诸有情不转利行。又诸菩萨于诸有情先审观察。知劣慧者为说浅法。随转粗近教授教诫。知中慧者为说中法随转处中教授教诫。知广慧者为说深法随转幽微教授教诫。令其渐次修集善品。是名菩萨于诸有情渐次利行。又诸菩萨于诸四姓乃至天人一切有情。随力随能行义利行求利乐者。即于其中随类劝导。是名菩萨于诸有情遍行利行。又诸菩萨于诸有情。若于自义诸善法品。随下中上功能差别。可劝导者。及由方便功能差别。可劝导者。随其所应。于彼如彼方便劝导。是名菩萨于诸有情如应利行。是名菩萨于诸有情。依外清净五种利行。云何菩萨于诸有情依内清净五种利行。谓诸菩萨于诸有情起广大悲意乐。现前而行利行。又诸菩萨于诸有情。所作义利。虽受一切大苦劬劳。而心无倦深生欢喜。为诸有情而行利行。又诸菩萨虽现安处最胜第一圆满财位。而自谦下如奴如仆。亦如孝子旃荼罗子。其心卑屈离憍离慢及离我执。于诸有情而行利行。又诸菩萨于诸有情。心无爱染无有虚伪。真实哀怜而行利行。又诸菩萨于诸有情。生起毕竟无复退转慈愍之心。而行利行

是名菩萨于诸有情依内清净五种利行。如是依于内外清净各五利行。总有十种。是名菩萨清净利行

云何菩萨同事。谓诸菩萨若于是义于是善根劝他受学。即于此义于此善根。或等或增自现受学。如是菩萨与他事同。故名同事。所化有情知此菩萨所修同事。便于自己受学善根。坚固决定无有退转。何以故。彼作是思。菩萨劝我所受学者。定能为我利益安乐。由此菩萨所授我者。即于其中自现行故。无有知无利益安乐自现行者。非诸菩萨如是同事劝导有情。他得诘言汝自于善不能受学。

云何以善殷勤劝导数数教授教诫于他。汝应从他殷勤咨受教授教诫。有诸菩萨是他同事。而不自显与他同事。有诸菩萨非他同事。而自显现与他同事。有诸菩萨是他同事。亦自显现与他同事。有诸菩萨非他同事。亦不自显与他同事。第一句者。谓有菩萨与诸菩萨功德威力皆悉平等。于菩萨道自谓为师功德威力与等。菩萨隐自善故而不显己功德威力。第二句者。谓诸菩萨见有下劣信解有情于甚深处心生怖畏便正思择为欲方便化导彼故。自现己身与其同法。所谓下于旃茶罗类乃至狗类。欲作饶益欲除灾患欲调欲化。故思于彼旃茶罗狗同分中生。第三句者。谓诸菩萨见所化者所受善根犹可摇动。为令坚住现与同事或等或增。第四句者。谓诸菩萨自行放逸弃舍他事

如是已说多种施戒。广说乃至最后同事。其中所有波罗蜜多。能自成熟一切佛法。所有摄事。能成熟他一切有情。当知略说菩萨一切善法作业。

又如前说。多种施戒广说乃至最后同事。如是众多助菩提分无量善法。由三因缘应知现行。由二因缘应知最胜。由三因缘应知清净。谓由身语意三因缘故。应知现行。彼诸善法由广大故无杂染故。应知最胜。亦名无上亦名不共。当知此中由有情无别故。事无别故时无别故。名为广大。有情无别者。谓诸菩萨普于一切有情处所。普为一切法界有情。修行如是施等善根。非专为己。事无别者。谓诸菩萨普于一切及一切种施等善根。精勤受学。时无别者。谓诸菩萨恒常无间不离加行不舍善轭。若昼若夜现法后法。即由此因施等善根常行无替。当知此中由四种相成无杂染。谓诸菩萨怀欢喜心修诸善法。由是因缘无苦无忧无诸变悔。又诸菩萨不损恼他不着见趣不杂恶行。修行施等无量善根。又诸菩萨殷重遍体。于其施等无量善法。唯见功德唯见真实唯见寂静。极善决定不从他缘非余引夺而正受学。又诸菩萨不因所修施等善法悕异熟果。或转轮王或天帝释或魔或梵。亦不于他悕求返报。无所依止。不依一切利养恭敬世俗名誉。乃至不依养活身命。由如是相净欢喜俱无不平等。殷重无依修行施等。广说乃至同事。为后无量善法。名无杂染。由炽然故无动转故善清净故。应知清净。若诸菩萨已入清净意乐地者。一切善根炽然无动。言炽然者。谓此菩萨意乐净故。一切善法不由思择炽盛现前。言无动者。谓此菩萨意乐净故。随所获得随所积集。所有善法皆无退转。于当来世能无退减。如是菩萨随所经历彼彼日夜。随所过度彼彼自身。所有善法如明分月唯增无减。若诸菩萨住到究竟地。或系属一生最后有者。所有善法。名善清净。此上更无菩萨地摄胜净法故。如是施等同事。为后无量善法。三因缘故应知现行。二因缘故应知最胜。三因缘故应知清净

此中所有一切施一切戒。广说乃至一切同事。若多修习若善清净若具圆满。能感无上正等菩提金刚坚固身正法久住果。此中所有难行施难行戒。广说乃至难行同事。若多修习若善清净若具圆满。能感如来成就无等希奇法果。此中所有一切门施一切门戒。广说乃至一切门同事。若多修习若善清净若具圆满。能感如来一切最胜有情天人所供养果。此中所有善士施善士戒。广说乃至善士同事。若多修习若善清净若具圆满。能感如来于诸有情无足二足四足多足。有色无色有想无想。及以非想非非想处。于此一切有情类中最尊胜果。此中所有一切种施一切种戒。广说乃至一切种同事。若多修习若善清净若具圆满。能感如来无量殊胜福德所摄三十有二大丈夫相八十随好庄严身果。此中所有遂求施遂求戒。广说乃至遂求同事。若多修习若善清净若具圆满。能感如来坐菩提座一切魔怨不能恼触不倾动果。此中所有此世他世乐施此世他世乐戒。广说乃至此世他世乐同事。若多修习若善清净若具圆满。能感如来最胜静虑解脱等持等至乐果。此中所有清净施清净戒。广说乃至清净同事。若多修习若善清净若具圆满。能感如来四一切种清净果。谓所依净所缘净心净智净。亦感如来三不护十力四无所畏。三念住一切不共佛法极清净果。如是菩萨施等善法。能感无上到究竟果。当知亦感生死流转顺菩萨行所余无量无边可爱无罪胜果

瑜伽师地论卷第四十三瑜伽师地论卷第四十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处供养亲近无量品第十六

云何菩萨供养亲近修习无量。嗢拖南曰

  供三宝　　亲善友　　修无量　　最为后

云何菩萨于如来所供养如来。当知供养略有十种。一设利罗供养。二制多供养。三现前供养。四不现前供养。五自作供养。六教他供养。七财敬供养。八广大供养。九无染供养。十正行供养。若诸菩萨亲现供养如来色身。是名设利罗供养。若诸菩萨于为如来所造一切若窣堵波。若龛若台若故。制多新制多所。设诸供养。是名制多供养。若诸菩萨于如来身或制多所。亲面对前现瞩现见而设供养。是名现前供养。若诸菩萨于如来所若制多所。现前施设供养具时。发起增上意乐俱心净信俱心。作是思惟。若一如来法性。即是去来今世一切如来法性。若一如来制多法性。即是十方无边无际一切世界所有如来制多法性。是故我今供现如来。即是供养其余三世一切如来。供现制多。即是供养其余十方无边无际一切世界若窣堵波。若龛若台。若故制多若新制多。当知是名菩萨俱供现不现前一切如来及以制多。若诸菩萨于不现前一切如来。及以制多。作如来想。普为三世一切如来一切十方如来制多。施设供养。当知是名菩萨唯供不现前佛及以制多。若诸菩萨佛涅槃后。为如来故造立形像若窣堵波若龛若台。随力随能或一或二或复众多。乃至百千俱胝等数。如是菩萨于如来所。设不现前弘广供养。当获无量大福德果。摄受无量广大梵福。菩萨由此能于无量劫大劫中不堕恶趣。由是因缘非不圆满无上正等菩提资粮。此中菩萨唯供现前佛及制多。应知获得广大福果。若唯供养不现前佛及以制多。应知获得大大福果。若俱供养现不现前佛及制多。应知获得最大福果。为无有上

若诸菩萨于如来所若制多所。欲设供养。唯自手作。不使奴婢作使朋友僚庶亲属。不依懈惰诸放逸处而设供养。是名菩萨自作供养。若诸菩萨于如来所若制多所。欲设供养。非唯自作。亦劝父母妻子奴婢作使朋友僚庶亲属及他国王王子大臣长者居士。若婆罗门国邑聚落饶财商主。下至一切男女大小贫匮苦厄旃荼罗等及以亲教轨范诸师共住近住一切弟子。同梵行者诸出家者外道等众。令于如来若制多所。随力随能作诸供养。当知是名菩萨自他咸共供养。若诸菩萨现有少分可供财物。兴悲愍心。故思施与贫苦少福无力有情。令于如来若制多所。持用供养。愿彼当来多受安乐。彼得此物供养如来及以制多。菩萨于斯自无所供。当知是名菩萨唯教他设供养。此中菩萨若唯自供佛及制多。应知获得广大福果。若唯教他。应知获得大大福果。若能自他俱共供养。应知获得最大福果。为无有上。若诸菩萨于如来所若制多所。以诸衣服饮食卧具病缘医药供身什物。敬问礼拜奉迎合掌。种种熏香末。香涂香。华鬘伎乐。幢盖幡灯。歌颂称赞。五轮归命趋绕右旋而为供养。或复奉施无尽财供。或复奉施末尼真珠琉璃蠡贝璧玉珊瑚车磲马瑙虎魄金银赤珠右旋。如是等宝。或复奉施末尼环玔宝璩印等诸庄严具。乃至奉施种种宝铃。或散珍奇或缠宝缕而为供养。是名菩萨于如来所若制多所。财敬供养。若诸菩萨于如来所若制多所。长时施设即上所陈财敬供养。若多供具。若妙供具。若现在前不现在前。若自造作教他造作。若淳净心猛利胜解现前供养。即以如是所种善根。回向无上正等菩提。如是七种。说名菩萨广大供养。若诸菩萨于如来所若制多所。自手供养不怀轻慢。令他供养。不住放逸懈惰不敬而为供养。不轻弃掷。不散慢心。无杂染心而为供养。不于信佛国王大臣诸贵胜前。为财敬故诈设种种虚事供养。不雌黄涂不酥灌洗。不以种种局崛罗香遏迦花等余不净物。而为供养。如是六种。说名菩萨无染供养。又诸菩萨如是财敬广大无染。供养如来及制多时。或自臂力所集财宝。或从他求所获财宝。或得众具自在财宝。能为如是种种供养已。得众具自在。菩萨化作化身。或一或二或复众多。乃至百千俱胝等数。此一切身皆于如来及制多所。恭敬礼拜。复从如是一一化身化出多手。或百或千或过是数。此一切手皆持无量出过诸天上妙华香殊胜可爱种种珍宝。奉散如来及制多所。复从如是一切化身。化出无量上妙音声。歌赞如来广大甚深真实功德。复从如是一切化身。化出无量最上最妙环玔璩印宝庄严具。幢盖幡灯种种供具。供养如来及以制多如是等类已。得众具自在。菩萨所设供养皆属自心。如是菩萨不更希求如来出世。何以故。由此菩萨已得证入不退转地。一切佛土往来供养皆无碍故。又诸菩萨若无自力所集财宝。亦无从他求得财宝。及无菩萨所获众具自在财宝可设供养。然于所有或赡部洲。或四大洲。或千世界二千世界。或复三千大千世界。乃至十方无边无际诸世界中下中上品供养如来一切供具。菩萨于彼以净信俱胜解俱心。周遍思惟一切随喜。如是菩萨少用功力而兴无边广大供养。摄受菩提广大资粮。菩萨于此恒常无间起真善心。起欢喜心当勤修学

若诸菩萨少时少时须臾须臾。乃至下如构牛乳顷。普于一切蠢动有情。修习慈悲喜舍俱心。于一切行修无常想无常苦想苦无我想。于其涅槃修胜利想。于佛法僧波罗蜜多修习随念。少时少时须臾须臾。于一切法发生少分下劣忍智信解。离言法性真如起无分别无相心住。何况于此若过若增。如是守护菩萨所受尸罗律仪。于奢摩他毗钵舍那菩提分法精勤修学。亦于一切波罗蜜多及诸摄事正勤修学。是名菩萨于如来所正行供养。如是供养为最第一最上最胜最妙无上。如是供养。过前所说具一切种财敬供养。百倍千倍乃至邬波尼杀昙倍

由此十相。应知是名具一切种供养如来。如供养佛。如是供养若法若僧。随其所应当知亦尔

如是菩萨于三宝所由十种相兴供养时。应缘如来发起六种增上意乐。一者无上大功德田增上意乐。二者无上有大恩德增上意乐。三者一切无足二足及多足等有情中尊增上意乐。四者犹如邬昙妙华极难值遇增上意乐。五者独一出现三千大千世界增上意乐。六者一切世出世间功德圆满一切义依增上意乐由是六种增上意乐。于如来所若于如来法所僧所。少分思惟而兴供养。尚获无量大功德果。何况其多

复次菩萨成就几相能为善友。由几种相善友不虚。成就几相令善友性作信依处

复有几种善友菩萨于所化生为善友事。菩萨几种亲近善友。由几种想于善友所听闻正法。由几种处于善友所听闻法时。于说法师不作异意当知菩萨成就八支能为善友众相圆满。一者住戒。于诸菩萨律仪戒中。妙善安住无缺无穿。二者多闻。觉慧成就。三者具证。得修所成随一胜善。逮奢摩他毗钵舍那。四者哀愍。内具慈悲能舍自己现法乐住。精勤无怠饶益于他。五者无畏。为他宣说正法教时。非由恐怖忘失念辩。六者堪忍。于他轻笑调弄鄙言违拒等事。非爱言路种种恶行。皆悉能忍。七者无倦。其力充强能多思择。处在四众说正法时。言无謇涩心不疲厌。八者善词。语具圆满不坏法性言词辩了

若诸菩萨具五种相。众德相应能为善友所作不虚。一者于他先欲求作利益安乐。二者于彼利益安乐。如实了知无颠倒觉。三者于彼善权方便顺仪说法随众堪受调伏事中。有能有力。四者饶益心无厌倦。五者具足平等大悲。于诸有情劣中胜品心无偏党

若诸菩萨成就五相。令善友性作信依处。令他远闻极生净信。何况亲睹。一者胜妙。威仪圆满威仪寂静威仪具足。一切支分皆无躁动。二者敦肃。三业现行无掉无扰。三者无矫。不为诳他故思诈现严整威仪。四者无嫉。终不于他说法所得利养恭敬生不堪忍。而常自励请他说法。复恒劝余于彼广施利养恭敬。无谄伪心。又常于他其心纯净。见彼说法及得财敬深生随喜。如自所获利养恭敬心生欢喜。见他所得利养恭敬其心欢喜。复过于是。五者俭约。鲜储器物随得随舍

善友菩萨由五种相。于所化生为善友事。一能谏举。二能令忆。三能教授。四能教诫。五能说法。如是诸句广辩应知如声闻地教授教诫。广说如前力种性品

当知菩萨由四种相。方得圆满亲近善友。一于善友有病无病随时供侍。恒常发起爱敬净信。二于善友随时敬问礼拜奉迎合掌。殷勤修和敬业而为供养。三于善友如法衣服饮食卧具病缘医药资身什物。随时供养。四于善友若正依止于如法义若合若离。随自在转无有倾动。如实显发作奉教心。随时往诣恭敬承事请问听受

若诸菩萨欲听法时作五种想。应从善友听闻正法。一作宝想。难得义故。二作眼想。能得广大俱生妙慧。因性义故。三作明想。已得广大俱生慧眼。于一切种如实所知。等照义故。四作大果胜功德想。能得涅槃及三菩提无上妙迹。因性义故。五作无罪大适悦想。于现法中未得涅槃及三菩提。于法如实简择止观无罪大乐。因性义故

若诸菩萨欲从善友听闻法时。于说法师由五种处不作异意。以纯净心属耳听法。一于坏戒不作异意。谓不作心此是破戒不住律仪。我今不应从彼听法。二于坏族不作异意。谓不作心此是卑姓。我今不应从彼听法。三于坏色不作异意。谓不作心此是丑陋。我今不应从彼听法。四于坏文不作异意。谓不作心此于言词不善藻饰。我今不应从彼听法。但依于义不应依文。五于坏美不作异意。谓不作心此语粗恶多怀忿恚不以美言宣说诸法。我今不应从彼听法。如是菩萨欲听法时。于是五处不应作意。但应恭敬摄受正法。于说法师未尝见过。若有菩萨其慧微劣。于说法师心生嫌鄙。不欲从其听闻正法。当知此行不求自利退失胜慧

云何菩萨修四无量慈悲喜舍。谓诸菩萨略有三种修四无量。一者有情缘无量。二者法缘无量。三者无缘无量。若诸菩萨于其三聚一切有情安立。以为无苦无乐有苦有乐。于其最初欲求乐者。发起与乐增上意乐。普缘十方安住无倒有情胜解。修慈俱心。当知是名有情缘慈。若诸菩萨住唯法想增上意乐。正观唯法假说有情。修慈俱心。当知即此名法缘慈。若诸菩萨复于诸法远离分别。修慈俱心。当知即此名无缘慈。如有情缘法缘无缘三慈差别。悲喜舍三当知亦尔。若诸菩萨于有苦者。发起除苦增上意乐。普缘十方修悲俱心。是名为悲。若诸菩萨于有乐者。发起随喜增上意乐。普缘十方修喜俱心。是名为喜。若诸菩萨即于如是无苦无乐有苦有乐三种有情。随其次第发起远离痴嗔贪惑增上意乐。普缘十方修舍俱心。是名为舍。此中菩萨慈等无量有情缘者。当知其相与外道共。若法缘者。当知其相与诸声闻及独觉共。不共外道。若无缘者。当知其相不共一切声闻独觉及诸外道。又诸菩萨三种无量应知安乐意乐所摄。谓慈悲喜。一种无量应知利益意乐所摄。是谓为舍。如是菩萨一切无量。名为哀愍。以诸菩萨成就此故。名哀愍者。此中菩萨于有情界。观见一百一十种苦。于诸有情修悲无量。何等名为百一十苦

谓有一苦。依无差别流转之苦。一切有情无不皆堕流转苦故。复有二苦。一欲为根本苦。谓可爱事若变若坏所生之苦。二痴异熟生苦。谓若猛利体受所触。即于自体执我我所。愚痴迷闷生极怨嗟。由是因缘受二箭受。谓身箭受及心箭受。复有三苦。一苦苦。二行苦。三坏苦。复有四苦。一别离苦。谓爱别离所生之苦。二断坏苦。谓由弃舍众同分死所生之苦。三相续苦。谓从此后数数死生展转相续所生之苦。四毕竟苦。谓定无有般涅槃法诸有情类。五取蕴苦。复有五苦。一贪欲缠缘苦。二嗔恚缠缘苦。三惛沉睡眠缠缘苦。四掉举恶作缠缘苦。五疑缠缘苦。复有六苦。一因苦。习恶趣因故。二果苦。生诸恶趣故。三求财位苦。四勤守护苦。五无厌足苦。六变坏苦。如是六种总说为苦。复有七苦。一生苦。二老苦。三病苦。四死苦。五怨憎会苦。六爱别离苦。七虽复希求而不得苦。复有八苦。一寒苦。二热苦。三饥苦。四渴苦。五不自在苦。六自逼恼苦。谓无系等诸外道类。七他逼恼苦。谓遭遇他手块等触蚊虻等触。八一类威仪多时住苦。复有九苦。一自衰损苦。二他衰损苦。三亲属衰损苦。四财位衰损苦。五无病衰损苦。六戒衰损苦。七见衰损苦。八现法苦。九后法苦。复有十苦。一诸食资具匮乏苦。二诸饮资具匮乏苦。三骑乘资具匮乏苦。四衣服资具匮乏苦。五庄严资具匮乏苦。六器物资具匮乏苦。七香鬘涂饰资具匮乏苦。八歌舞伎乐资具匮乏苦。九照明资具匮乏苦。十男女给侍资具匮乏苦。当知复有余九种苦。一一切苦。二广大苦。三一切门苦。四邪行苦。五流转苦。六不随欲苦。七违害苦。八随逐苦。九一切种苦。一切苦中复有二苦。一宿因所生苦。二现缘所生苦。广大苦中复有四苦。一长时苦。二猛利苦。三杂类苦。四无间苦。一切门苦中亦有四苦。一那落迦苦。二傍生苦。三鬼世界苦。四善趣所摄苦。邪行苦中复有五苦。一于现法中犯触于他他不饶益所发起苦。二受用种种不平等食界不平等所发起苦。三即由现法苦所逼切自然造作所发起苦。四由多安住非理作意所受烦恼随烦恼缠所起诸苦。五由多发起诸身语意种种恶行所受当来诸恶趣苦。流转苦中复有六种轮转生死不定生苦。一自身不定。二父母不定。三妻子不定。四奴婢仆使不定。五朋友宰官亲属不定。六财位不定。自身不定者。谓先为王后为仆隶。父母等不定者。谓先为父母乃至亲属。后时轮转反作怨害及恶知识。财位不定者。谓先大富贵后极贫贱。不随欲苦中复有七苦。一欲求长寿不随所欲生短寿苦。二欲求端正不随所欲生丑陋苦。三欲生上族不随所欲生下族苦。四欲求大富不随所欲生贫穷苦。五欲求大力不随所欲生羸劣苦。六欲求了知所知境界。不随所欲愚痴无智现行生苦。七欲求胜他不随所欲反为他胜而生大苦。违害苦中复有八苦。一诸在家者妻子等事损减生苦。二诸出家者贪等烦恼增益生苦。三饥俭逼恼之所生苦。四怨敌逼恼之所生苦。五旷野崄难迫迮逼恼之所生苦。六系属于他之所生苦。七支节不具损恼生苦。八杀缚斫截捶打驱摈逼恼生苦。随逐苦中复有九苦。依世八法有八种苦。一坏法坏时苦。二尽法尽时苦。三老法老时苦。四病法病时苦。五死法死时苦。六无利苦。七无誉苦。八有讥苦。是名八苦。九希求苦。如是总说名随逐苦。一切种苦中复有十苦。谓如前说。五乐所治有五种苦。一因苦。二受苦。三唯无乐苦。四受不断苦。五出离远离寂静菩提乐所对治家欲界结寻异生苦。是名五苦。复有五苦。一逼迫苦。二众具匮乏苦。三界不平等苦。四所爱变坏苦。五三界烦恼品粗重苦。是名五苦。前五此五总十种苦。当知是名一切种苦

前五十五今五十五。总有一百一十种苦。是菩萨悲所缘境界。缘此境故。诸菩萨悲生起增长修习圆满

又诸菩萨于大苦蕴。缘十九苦发起大悲。何等名为十九种苦。一愚痴异熟苦。二行苦所摄苦。三毕竟苦。四因苦。五生苦。六自作逼恼苦。七戒衰损苦。八见衰损苦。九宿因苦。十广大苦。十一那落迦苦。十二善趣所摄苦。十三一切邪行所生苦。十四一切流转苦。十五无智苦。十六增长苦。十七随逐苦。十八受苦。十九粗重苦

由四缘故悲名大悲。一缘甚深微细难了诸有情苦为境生故。二于长时积习成故。谓诸菩萨经于无量百千大劫积习所成。三于所缘猛利作意而发起故。谓诸菩萨由是作意悲所执持。为息有情众苦因缘。尚能弃舍百千身命。况一身命及以资财。于一切种治罚大苦。为诸有情悉能堪忍。四极清净故。谓诸菩萨已到究竟菩萨清净。若诸如来已到佛地如来清净。又诸菩萨由前所说百一十苦。于诸有情修悲心时。则为修习一切菩萨所有悲心。复能速证悲意乐净。证入菩萨净意乐地。于诸有情。获得菩萨极亲厚心。极爱念心。欲作恩心。无厌惓心。代受苦心。调柔自在有堪能心。诸圣声闻已得证入。苦谛现观已到究竟。于苦深远厌俱行心相续而转。不如菩萨于诸有情悲前行心正观堕在百一十种极大苦蕴

菩萨如是以所修悲熏修心故。于内外事无有少分而不能舍。无戒律仪而不能学。无他怨害而不能忍。无有精进而不能起。无有静虑而不能证。无有妙慧而不能入。是故如来若有请问菩萨菩提谁所建立。皆正答言菩萨菩提悲所建立

如前所说。一一无量皆有无量。菩萨如意圆德随转。皆能摄受无量爱果。皆无量种一向妙善无罪随转。当知菩萨精勤修习如是无量。能得四种功德胜利。谓由修习此无量故。先得最胜现法乐住。摄受增长无量最胜福德资粮。能于无上正等菩提意乐坚固。为欲饶益诸有情故。于生死中堪能忍受一切大苦

    本地分中菩萨地第十五初持瑜伽处菩提分品第十七之一

云何菩萨菩提分法。嗢拖南曰

  惭愧坚力持　　无厌论世智
  正依无碍解　　资粮菩提分
  止观性巧便　　陀罗尼正愿
  三摩地有三　　法嗢拖南四

云何名为菩萨惭愧。当知惭愧略有二种一者自性。二者依处。言自性者。谓诸菩萨于罪现行。能正觉知我为非法。内生羞耻。是名为惭。即于其中能正觉知。于他敬畏外生羞耻。是名为愧。菩萨羞耻本性。猛利。况复修习如是。应知名为菩萨惭愧自性。言依处者。略有四种。若诸菩萨于所应作不随建立而生羞耻。当知是名第一依处。若诸菩萨于不应作随顺建立而生羞耻。当知是名第二依处。若诸菩萨于覆己恶而生羞耻。当知是名第三依处。若诸菩萨于自所生恶作有依随逐不舍而生羞耻。当知是名第四依处。如是应知名为菩萨惭愧依处。

云何菩萨坚力持性。当知此性略有二种。一者自性。二者依处。言自性者。谓能禁制染污心性。不随烦恼自在行性。堪忍苦性。种种众多猛利怖畏虽现在前。而正加行无倾动性。性勇相应能正思择。是故得成坚力持性。如是名为坚力持性自性。如是菩萨坚力持性略说应知有五依处。一者会遇生死轮转种种大苦所化有情种种邪行。二者为益诸有情故。誓受长时生死流转。三者遭遇异论朋党诤竞难诘。及处大众宣扬法义。四者誓受一切菩萨所应学处。五者听闻广大甚深难思议法。是名坚力持性依处

云何菩萨心无厌倦。当知菩萨由五因缘普于一切正加行中心无厌倦。一者菩萨性自有力故无厌倦。二者菩萨即于如是无厌倦心。数数串习故无厌倦。三者菩萨方便摄受精进勇猛能正随观。前后所得展转殊胜故无厌倦。四者菩萨成就猛利增上妙慧。正思择力故无厌倦。五者菩萨于诸有情。猛利悲心极哀愍心。恒常现前故无厌倦

云何菩萨善知诸论。谓诸菩萨于五明处名句文身相应诸法。从他善受言善通利。即于如是诸法妙义。或从他所善听善决。或自专精善择善思。如是知法知义菩萨。于法于义为不忘失。恒常精勤不舍加行。又为了知所余新新后后法义殊胜差别。虽复闻思已到究竟。而由此故渐次成熟于此法义。获得净信。由是行相当知菩萨知诸论智无量圆满无有颠倒。

云何菩萨善知世间。谓诸菩萨普于一切有情世间。如实了知。如是世间极为艰崄甚为愚闇。所谓虽有生老及死数数死生。而诸有情于老死等上升出离不如实知。又诸菩萨如实了知有情世间有诸秽浊浊世增时。无诸秽浊浊世减时。谓依五浊。一者寿浊。二者有情浊。三者烦恼浊。四者见浊。五者劫浊。如于今时人寿短促。极长寿者不过百年。昔时不尔。是名寿浊。如于今时有情多分不识父母。不识沙门若婆罗门。不识家长可尊敬者作义利者作所作者于今世罪及后世罪不见怖畏。不修惠施不作福业。不受斋法不受净戒。昔时不尔。是名有情浊。如于今时有情多分习非法贪不平等贪。执持刀剑执持器仗斗讼诤竞。多行谄诳诈伪妄语摄受邪法。有无量种恶不善法现可了知。昔时不尔。是名烦恼浊。如于今时有情多分为坏正法为灭正法。造立众多像似正法。虚妄推求邪法邪义以为先故。昔时不尔。是名见浊。如于今时渐次趣入饥馑中劫。现有众多饥馑可得。渐次趣入疫病中劫。现有众多疫病可得。渐次趣入刀兵中劫。现有众多互相残害刀兵可得。昔时不尔。是名劫浊。是名菩萨如实了知有情世间。又诸菩萨如实了知诸器世间破坏成立。如器世间破坏成立差别而知。又诸菩萨于其世间。于世间集于世间灭。于能往趣世间集行。于能往趣世间灭行。于其世间爱味过患及与出离。皆如实知。又诸菩萨如实了知。眼乃至意诸无色蕴四大造色成士夫身。唯有尔所假名人性。于中所有想。或我或有情。此唯有想。于中所有自号言说。我眼见色广说乃至我意知法。此亦唯有自号言说。于中所有世俗语言。谓此长老。有如是名如是种类如是族姓。如是饮食如是领纳。若苦若乐。如是长寿如是久住。如是尽其寿量边际。此亦唯有世俗言说。菩萨于此皆如实知。由诸菩萨如实了知有情世间流转差别。若器世间流转差别。若八种相观世间义若诸世间所有胜义。是故说名善知世间

复次菩萨若见年德俱尊胜者。能正奉迎敷座延坐。敬问礼拜合掌殷勤修和敬业。若见年德俱相似者。能正问讯。酬对欢慰。以软美言共兴谈论。不依等慢而自格量。若见年德俱卑劣者。随力随能劝修胜德显实。少德覆实多过终不举发令其耻愧。亦不轻陵令心退没。知有希求若财若法。终不背面亦不颦蹙。不讥误失不蔑退荣。于是一切劣等胜品诸有情类。若见彼时先意慰问赞言善来。无倒安处能正随力摄以财法。虽处尊胜而于有情终不乖戾。不自珍奇亦不憍傲。所摄有情纵怀资给。有病无病终不弃捐。身业语业无不随顺。若识不识一切等心。为友为朋无怨无隙。于无依怙一切有情。随力随能作依作怙。不托异门发他忧苦令彼须臾住不安乐。若有因缘须现谈谑。称理而为非不称理。虽遇情交极相亲密年事斯等无乖隔者。亦不共谈匪仁言论。终不于他久怀忿恨。设复暂起不斥其讳。若复为他身语訾辱。或善思择。或依正法。或省己过而自开解。不谴于他。其心安静而不轻躁。身语意业起必审详。普能远离十四垢业。藏隐六方。远四恶友摄四善友。如是一切应知具如尸佉络迦契经中说。或为现法利益事义财位相应。起策具足守护具足平等养命。于诸世间工巧业处皆得善巧。无谄无幻性不诳他。于罪现行深怀惭耻。正行具足尊重正行守护正行。有所寄付深可倚信。于他财物无所规度。举贷他物终不违捍。分所。共财平等无矫。共知真宝。卖者不识称宝酬价。无枉毫厘。于世时务令仪轨范。为益世间辩正机捷。于所应作彼彼事中。他正来求皆为助伴。敦质无动不托余缘。善营事业非为不善。若为帝王以法治世。不以非法不好责罚。若御大众劝舍恶戒令修善戒。成就八种贤圣语言。谓于所见问答言见。于闻觉知问答言知。于所不见问答不见。于所不闻不觉不知问。答不知

菩萨成就如是等法。如其世间正所应知。如其世间正所应转。于彼一切皆如实知。是故名为善知世间

瑜伽师地论卷第四十四瑜伽师地论卷第四十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处菩提分品第十七之二

云何菩萨修正四依。谓诸菩萨为求义故从他听法。不为求世藻饰文词。菩萨求义不为求文。而听法时虽遇常流言音说法。但依于义恭敬听受。又诸菩萨如实了知闇说大说。如实知已以理为依。不由耆长众所知识补特伽罗。若佛若僧所说法故即便信受。是故不依补特伽罗。如是菩萨以理为依。补特伽罗非所依故。于真实义心不动摇。于正法中他缘匪夺。又诸菩萨于如来所。深殖正信深殖清净。一向澄清净唯依如来了义经典。非不了义。了义经典为所依故。于佛所说法毗奈耶不可引夺。何以故。以佛所说不了义经依种种门辩本性义。犹未决定尚生疑惑。非了义故。若诸菩萨于了义经不决定者。于佛所说法毗奈耶犹可引夺。又诸菩萨于真证智见为真实。非于闻思。但识法义非真证智。是诸菩萨如实了知修所成智所应知者。非唯闻思所成诸识所能了达。如实知已闻如来说最极甚深所有法义。终不诽毁。是名菩萨修正四依。依正四依善修习。故略显四量。谓所说义。正理。大师修所成慧。真实证智。又诸菩萨一切四依为所依止。精勤发起正加行。故于出要道明了开示无有迷惑

云何菩萨所修菩萨四无碍解。谓诸菩萨于一切法一切异门。尽所有性如所有性。依修所成无所滞碍无退转智。是名菩萨法无碍解。又诸菩萨于一切法一切异相。尽所有性如所有性。依修所成无所滞碍无退转智。是名菩萨义无碍解。又诸菩萨于一切法一切释词。尽所有性如所有性。依修所成无所滞碍无退转智。是名菩萨词无碍解。又诸菩萨于一切法一切品别。尽所有性如所有性。依修所成无所滞碍无退转智。是名菩萨辩无碍解。若诸菩萨依是菩萨四无碍解。应知获得无量最胜五处善巧。一蕴善巧。二界善巧。三处善巧。四缘起善巧。五处非处善巧。菩萨由此四种行相。于一切法自能妙善现正等觉。亦善为他无倒开示。此上无有自能妙善现正等觉。况善为他无倒开示。

云何菩萨菩提资粮。当知如是菩提资粮略有二种。一者福德资粮。二者智慧资粮。此二资粮广分别义。如前所说自他利品。应知其相。又此福德智慧资粮。菩萨于初无数大劫所修习者。应知名下。若于第二无数大劫所修习者。应知名中。若于第三无数大劫所修习者。应知名上

云何菩萨于三十七菩提分法精勤修习。谓诸菩萨依止菩萨四无碍解。由善方便所摄妙智。于三十七菩提分法。如实了知而不作证。是诸菩萨普于一切二乘理趣三十七种菩提分法。皆如实知。谓于声闻乘理趣。及于大乘理趣三十七种菩提分法。皆如实知。于声闻乘理趣三十七种菩提分法。如实了知。如声闻地如前所说一切应知。云何菩萨于大乘理趣三十七种菩提分法。如实了知。谓诸菩萨能于其身住循身观。不于其身分别有性。亦不分别一切种类都无有性。又于其身远离言说自性法性。如实了知。当知名依胜义理趣能于其身住循身观修习念住。若诸菩萨随顺无量。安立理趣妙智而转。当知名依世俗理趣能于其身住循身观修习念住。如于其身住循身观修习念住。如是所余一切念住。所余一切菩提分法当知亦尔。如是菩萨于身等法。不分别苦不分别集。不分别此所作断灭。不分别此得灭因道。又即于此远离言说自性法性。若苦法性若集法性。若灭法性若道法性。如实了知。当知名依胜义理趣修菩提分为所依止缘谛修习。若诸菩萨随顺无量。安立理趣妙智而转。当知名依世俗理趣缘谛修习

此中菩萨即于诸法无所分别。当知名止。若于诸法胜义理趣如实真智。及于无量安立理趣世俗妙智。当知名观。此中菩萨略有四行。当知名止。一胜义世俗智前行。二胜义世俗智果。三普于一切戏论想中无功用转。四即于如是离言唯事。由无有相无所分别。其心寂静趣向一切法平等性一味实性。由此四行。是诸菩萨止道运转。渐次乃至能证无上正等菩提。智见圆满。此中菩萨略有四行。当知名观。谓即四行止道前行。于一切法远离增益不正执边。远离损减不正执边。及与随顺无量诸法差别。安立理趣妙观。由此四行。是诸菩萨观道运转。渐次乃至能证无上正等菩提。智见圆满。是名略说菩萨止观

云何菩萨方便善巧。当知略说有十二种。依内修证一切佛法。有其六种。依外成熟一切有情。亦有六种

云何依内修证一切佛法六种方便善巧。一者菩萨于诸有情。悲心俱行顾恋不舍。二者菩萨于一切行。如实遍知。三者菩萨恒于无上正等菩提所有妙智。深心欣乐。四者菩萨顾恋有情为依止故。不舍生死。五者菩萨于一切行。如实遍知为依止故。轮转生死而心不染。六者菩萨欣乐佛智为依止故。炽然精进。当知是名菩萨依内修证一切佛法六种方便善巧。云何依外成熟一切有情六种方便善巧。一者菩萨方便善巧。能令有情以少善根感无量果。二者菩萨方便善巧。能令有情少用功力引摄广大无量善根。三者菩萨方便善巧。于佛圣教憎背有情除其恚恼。四者菩萨方便善巧。于佛圣教处中有情令其趣入。五者菩萨方便善巧。于佛圣教已趣入者令其成熟。六者菩萨方便善巧。于佛圣教已成熟者令得解脱。云何菩萨方便善巧令诸有情以少善根感无量果。谓诸菩萨方便善巧。劝诸有情。舍微劣物乃至最下唯一糗团。施鄙秽田乃至蠢动傍生之类。作是施已回求无上正等菩提。如是善根物田虽下。由回向力感无量果

云何菩萨方便善巧。令诸有情以少功力引摄广大无量善根。谓诸菩萨方便善巧。若有信解受邪斋戒乃至一月都不食等诸有情类。为说八支圣斋戒法。令其弃舍最极艰辛感非爱果受邪斋戒。劝令修学无极艰辛感大爱果受正斋戒。若诸有情修自苦行精勤无懈。起邪方便欲求解脱。为说中道令离二边使其趣入。若诸有情求欲生天起邪方便。投岩赴火断饮食等。为其宣说无倒静虑。令彼获于现法乐住。逮得当来无诸艰苦与喜乐俱生天胜果。若诸有情信婆罗门吠地迦咒妄计。精勤受持读诵得究竟。净方便劝令于佛圣教受持读诵思惟其义。又正为他如是如是宣扬开示如来所说甚深空性相应妙法。令彼发生勇决厌离猛利净信。但由如是一刹那顷厌离净信俱行善心。尚能摄受不可称数广大善根。况其相续。又诸菩萨世间所有种种上妙珍宝香鬘诸供养具。起净信俱增上意乐。于佛法僧胜解供养。亦劝导他令行如是胜解供养。又于十方一切世界一切供养佛法僧所。即以如是净信俱行增上意乐。周匝普缘深生随喜。亦劝导他作是随喜。又诸菩萨恒常修习念佛念法乃至念天。亦劝导他令修六念。又诸菩萨意言分别礼佛法僧。乃至命终时无虚度。亦劝导他行此礼业。又诸菩萨普于十方一切有情一切福业悉皆随喜。亦劝导他作是随喜。又诸菩萨普于十方一切有情。入广大悲增上意乐。愿以自身皆代彼受一切忧苦。亦劝导他兴此悲愿。又诸菩萨过去现在一切误失一切违犯。以净调柔爱乐。随顺所学戒。心。想对十方佛世尊所。至诚发露悔往修来。亦劝导他令行是事。如是数数发露所犯。少用功力一切业障皆得解脱。又诸菩萨已具神通得心自在。普于十方佛法僧所及有情处。化作众多种种化事。摄受无量大福德聚。又诸菩萨恒常修习慈悲喜舍。亦劝导他作此修习。如是菩萨以少功力引摄广大无量善根诸胜妙果

云何菩萨方便善巧。于佛圣教憎背有情。除其恚恼。处中住者令其趣入。已趣入者令其成熟。已成熟者令得解脱。谓诸菩萨为欲成办如是四种有情义利。当知略说复有六种方便善巧。一者随顺会通方便善巧。二者共立要契方便善巧。三者异分意乐方便善巧。四者逼迫所生方便善巧。五者施恩报恩方便善巧。六者究竟清净方便善巧

云何菩萨随顺会通方便善巧。谓诸菩萨于彼有情将为说法。先当方便随顺。现行软美身语。亦复现行近施随转。除彼于己所生恚恼。彼恚恼除便生爱敬。爱敬生已于法起乐。然后为其宣说正法。所说正法如其所宜易入易解。应时渐次无有颠倒。能引义利堪任难击。于彼有情调伏事中成就最胜欲作饶益哀愍之心。为现神通记心显说如理正法。或劝请他。或为化作种种众多殊特化事。令彼有情皆悉调伏。若引义利。极略诸论能为广辩。若引义利。极广诸论能为略说。令其受持为作忆念施其问难。彼既于法能受能持。复进为其广开正义。又于趣入遍缘一切三摩地门。能为随顺教授教诫。摄益有情令修利行。若诸有情于佛所说甚深空性相应经典。不解如来密意义趣。于此经中说一切法皆无自性皆无有事无生无灭。说一切法皆等虚空皆如幻梦。彼闻是已如其义趣不能解了。心生惊怖。诽谤如是一切经典言非佛说。菩萨为彼诸有情类。方便善巧如理会通如是经中如来密意甚深义趣。如实和会摄彼有情。菩萨如是正会通时。为彼说言。此经不说一切诸法都无所有。但说诸法所言自性都无所有。是故说言一切诸法皆无自性。虽有一切所言说事。依止彼故诸言说转。然彼所说可说自性。据第一义非其自性。是故说言一切诸法皆无有事。一切诸法所言自性理既如是。从本已来都无所有。当何所生当何所灭。是故说言一切诸法无生无灭。譬如空中有众多色色业可得容受一切诸色色业。谓虚空中现有种种若往若来若住起堕屈伸等事。若于尔时诸色色业皆悉除遣。即于尔时唯无色性。清净虚空其相显现。如是即于相似虚空离言说事。有其种种言说所作邪想分别随戏论著。似色业转。又即如是一切言说邪想分别随戏论著似众色业。皆是似空离言说事之所容受。若时菩萨以妙圣智。遣除一切言说所起邪想分别随戏论著。尔时菩萨最胜圣者。以妙圣智证得诸法离言说事。唯有一切言说自性。非性所显。譬如虚空清净相现。亦非过此有余自性应更寻求。是故宣说一切诸法皆等虚空。又如幻梦非如显现如实是有。亦非一切幻梦形质都无所有。如是诸法非如愚夫言说串习势力所现如实是有。亦非一切诸法胜义离言自性都无所有。由此方便悟入道理。一切诸法非有非无。犹如幻梦其性无二。是故宣说一切诸法皆如幻梦。如是菩萨普于一切诸法法界。不取少分不舍少分。不作损减不作增益。无所失坏。若法实有知为实有。若法实无知为实无。如其所知如是开示。当知是名菩萨随顺会通方便善巧

云何菩萨共立要契方便善巧。谓诸菩萨若见有情求饮食等十资身具。即便共彼立要契言。汝等若能知父母恩恭敬供养。及诸沙门婆罗门等。广说如前。乃至若能受持净戒。如是我当随汝所欲施饮食等诸资身具。如其不能我不施汝。如是菩萨若见有情来求种种田事宅事。诸阛阓事。王事域事。财事谷事。或有来求诸工业处及诸明处。或有来求共为朋友。或有来求共结婚媾。或有来求共作邑会。或有来求助营事业。菩萨共彼立要契言。汝等若能知父母恩恭敬供养。如前广说。如是我当施汝田宅广说乃至助营事业。又诸菩萨若见有情有诸愆犯或被举讼。或作种种不饶益事为他所拘。将欲刑缚断截。挝打毁辱。迫胁驱摈流移。或他所执欲捶缚卖。菩萨尔时随能随力立要契言。汝等若能知父母恩恭敬供养。如前广说。如是我当方便救汝令脱斯难。又诸菩萨若见有情遭遇种种王贼水火人。及非人不活恶名诸怖畏等。尔时菩萨立要契言。汝等若能知父母恩恭敬供养。如前广说。如是我当方便救汝令免斯畏。又诸菩萨若见有情欲所爱会求非爱离。尔时菩萨立要契言。汝等若能知父母恩恭敬供养。如前广说。如是我当遂汝所愿。令所爱会及非爱离。又诸菩萨若见有情为疾所苦。立要契言。汝等若能知父母恩恭敬供养。如前广说。如是我当救汝病苦令得安乐。彼诸有情既为菩萨如是立要。于诸善品速疾受学。于诸恶品速疾除断。菩萨皆能遂其所愿。当知是名菩萨共立要契方便善巧。云何菩萨异分意乐方便善巧。谓诸菩萨与诸有情立要契已。彼诸有情于上所说彼彼事中。不如所欲速疾修行。菩萨尔时于如上说彼所求事。皆不施与。唯为利益彼有情故。非余意乐而不施彼。如是于其诸厄难处。诸怖畏处。欲所爱会求非爱离。病苦所恼诸有情类。权时弃舍。唯为利益彼有情故。非异意乐而弃舍之。非异意乐而不救拔。如是菩萨于诸有情。方便现行刚捍业时。唯为利益非余意乐。渐令余时如其所欲断除诸恶。修学诸善。是故方便权时弃舍。若诸有情于菩萨所。虽无所求亦无众难。广说乃至无诸病苦。而与菩萨先为亲厚。菩萨于彼随宜劝导。断诸恶法修诸善法。所谓令彼知父母恩恭敬供养。广说乃至于净尸罗随顺受学。若彼有情虽蒙菩萨如是劝导。故肆轻躁而不奉行。菩萨尔时自现愤责。唯欲利益非愤意乐。于诸所作悉现乖背。唯为利益非背意乐。或于一类现与世间不饶益事。唯为利益非损意乐。如是菩萨于诸有情现外所作。与内意乐相不同分。由是因缘方便安处。令彼有情渐断诸恶渐修诸善。是故菩萨如是调伏有情方便。名为菩萨异分意乐方便善巧。云何菩萨逼迫所生方便善巧。谓诸菩萨或为家主或作国王得增上力。于自亲属于自臣民能正教诫。如应告言。诸我亲属诸我臣民。若于父母不知恩报。广说乃至毁犯戒者。我当断其常所给赐衣服饮食。或当捶罚。或我亲属当与乖离。或我臣民当永驱摈。立一善巧机捷士夫。于彼事业常令伺察。由是因。故彼诸有情怖畏治罚。勤断诸恶勤修诸善。彼于修善虽无乐欲。由是方便强逼令修。是故名为逼迫所生方便善巧

云何菩萨施恩报恩方便善巧。谓诸菩萨先于有情。随力多少施作恩惠。或施所须或济厄难。或除恐怖或会所爱。或离非爱。或疗病苦令得安乐。彼诸有情深知恩惠欲报德者。菩萨尔时劝令修善以受报恩。告言。汝等非余世财来相酬遗为大报恩。汝等若能知父母恩恭敬供养。广说乃至受持净戒。如是乃名大报恩德。菩萨如是于诸有情先施恩惠劝赞修善。名大报恩。由此方便令他于善精勤修学。是故名为施恩报恩方便善巧。云何菩萨究竟清净方便善巧。谓诸菩萨安住菩萨到究竟地。于菩萨道已善清净。先现往生睹史多天众同分中。无量有情如是念言。某名菩萨今已生处睹史多天众同分中。不久当下生赡部洲证得无上正等菩提。愿令我等当得值遇非不值遇。随是菩萨所生之处。愿令我等亦当往生。如是为令无量有情生正欲乐。为多修习此欲乐故。又是菩萨从睹史多天众中没来下人间。生于高贵或族望家。所谓王家若国师家。弃舍世间上妙欲乐无所顾恋清净出家。令诸有情起尊敬故。又现誓受难行苦行。为令信解苦行有情舍所乐故。又证无上正等菩提。令余有情于所同趣菩提解脱欣殊胜故。又证无上正等觉已。未为有情即说正法。待梵天王躬来启请。为诸有情于正法所起尊敬故。作是念言。当所说法定应殊妙故。今梵王悕望。世尊说是法故躬自来请。又以佛眼观察世间。勿使有情作如是谤。但由梵王躬来启请。敬梵王故宣说正法。非于有情自起悲心。乃是为他之所激发。非自能了机宜可否。为欲坏彼一类有情如是邪执。先以佛眼观察世间。然后为转无上法轮。一切世间所未曾转。如是更复宣说正法制立学处。是名菩萨究竟清净方便善巧。由此所说方便善巧。更无有余方便善巧在于此上若过若妙。是故说名究竟清净﹂

如是菩萨所说六种若略若广方便善巧。能除憎背圣教有情所有恚恼。处中住者令其趣入。已趣入者令其成熟。已成熟者令得解脱。除此无有若过若增。是名菩萨方便善巧。

云何菩萨妙陀罗尼。当知如是妙陀罗尼略有四种。一者法陀罗尼。二者义陀罗尼。三者咒陀罗尼。四者能得菩萨忍陀罗尼。云何菩萨法陀罗尼。谓诸菩萨获得如是念慧力持。由此力持闻未曾闻言。未温习未善通利。名句文身之所摄录次第错综。次第结集无量经典。经无量时能持不忘。是名菩萨法陀罗尼。云何菩萨义陀罗尼。谓如前说。此差别者。即于彼法无量义趣。心未温习未善通利。经无量时能持不忘。是名菩萨义陀罗尼。云何菩萨咒陀罗尼。谓诸菩萨获得如是等持自在。由此自在加被。能除有情灾患。诸咒章句。令彼章句悉皆神验。第一神验无所唐捐。能除非一种种灾患。是名菩萨咒陀罗尼。云何菩萨能得菩萨忍陀罗尼。谓诸菩萨成就自然坚固因行。具足妙慧。独处空闲寂无言说。曾无有物见路而行。知量而食不杂秽食一类而食。常极静虑于夜分中少眠多寤。于佛所说得菩萨忍诸咒章句。能谛思惟。其咒词曰

壹胝　蜜胝　吉胝　毗羼底(丁里反)　钵陀腻　莎诃

即于如是咒章句义。审谛思惟筹量观察。彼于如是咒章句义。如是正行。不从他闻自然通达。了知如是诸咒章句都无有义是圆成实。但唯无义。如实了知此章句义。所谓无义。是故过此不求余义。齐此名为妙善通达咒章句义。彼于如是咒章句义正通达已。即随此义不从他闻。自正通达一切法义。谓于此义如是通达。一切言说所说诸法自性之义皆不成实。唯有诸法离言自性。是自性义彼于诸法此自性义正通达已。过此更无余义可求。由于此义善通达故。获得最胜广大欢喜。由是菩萨得陀罗尼。当言已得此陀罗尼章句所立菩萨胜忍。得此忍故。是诸菩萨不久当得净胜意乐已依上品胜解行地胜忍而转。当知是名菩萨所有能得菩萨忍陀罗尼。此中菩萨法陀罗尼义陀罗尼。若过第一无数大劫。已入清净胜意乐地。所得决定坚住广大。从此以下或以愿力或依静虑。虽有获得而不决定。亦不坚住亦不广大。如说法义二陀罗尼。咒陀罗尼当知亦尔。能得菩萨忍陀罗尼。如前所释。即如是得

若诸菩萨具四功德。方获如是诸陀罗尼。非随阙一。何等名为四种功德。一者于诸欲中无所贪着。二者于他胜事不生姤忌不嫉他荣。三者一切所求等施无悔。四者于正法中深生忻乐。忻乐法者。于菩萨藏及菩萨藏摩怛理迦深心爱乐

云何菩萨所修正愿。当知此愿略有五种。一者发心愿。二者受生愿。三者所行愿。四者正愿。五者大愿。若诸菩萨于其无上正等菩提最初发心。是名发心愿。若诸菩萨愿于当来往生随顺饶益有情诸善趣中。是名受生愿。若诸菩萨愿能无倒思择诸法。愿于境界修无量等殊胜善法。是名所行愿。若诸菩萨愿于当来摄受一切菩萨善法。摄受一切所有功德。若总若别所有正愿。是名正愿。菩萨大愿当知即从正愿所出。此复十种。若诸菩萨愿于当来。以一切种上妙供具。供养无量无边如来。当知是名第一大愿。若诸菩萨愿于当来。摄受防护诸佛世尊所有正法。传持法眼令无断坏。当知是名第二正愿。若诸菩萨愿于当来。从睹史多天宫降下如前乃至入大涅槃。当知是名第三大愿。若诸菩萨愿于当来。行一切种菩萨正行。当知是名第四大愿。若诸菩萨愿于当来。普能成熟一切有情。当知是名第五大愿。若诸菩萨愿于当来。一切世界皆能示现。当知是名第六大愿。若诸菩萨愿于当来。普能净修一切佛土。当知是名第七大愿。若诸菩萨愿于当来。一切菩萨皆同一种意乐加行趣入大乘。当知是名第八大愿。若诸菩萨愿于当来。所有一切无倒加行皆不唐捐。当知是名第九大愿。若诸菩萨愿于当来。速证无上正等菩提。当知是名第十大愿

云何菩萨空三摩地。谓诸菩萨观一切事远离一切言说自性唯有诸法离言自性。心正安住。是名菩萨空三摩地。云何菩萨无愿三摩地。谓诸菩萨即等随观离言自性所有诸事。由邪分别所起烦恼及以众苦所摄受故。皆为无量过失所污。于当来世不愿为先心正安住。是名菩萨无愿三摩地。云何菩萨无相三摩地。谓诸菩萨即正思惟离言自性所有诸事一切分别戏论众相。永灭寂静。如实了知。心正安住。是名菩萨无相三摩地。问何故唯立三三摩地。无过无增。答法有二种。谓有非有。有为无为名之为有。我及我所名为非有。于有为中有无愿故可厌逆故。当知依此建立无愿三摩地。于无为中愿涅槃故正乐摄故。当知依此建立无相三摩地。于非有事菩萨不愿亦无无愿。然于非有菩萨如实见为非有。依此见故当知建立空三摩地。如是菩萨于此三种三摩地中。精勤修学。于是建立如实了知。于余行相三三摩地。如实悟入。安立理趣。如实悟入。修习理趣如实了知。谓于其中诸声闻众。精勤修学及圆满证

瑜伽师地论卷第四十五瑜伽师地论卷第四十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五初持瑜伽处菩提分品第十七之三

复有四种法嗢拖南。诸佛菩萨欲令有情清净故说。何等为四。一切诸行皆是无常。是名第一法嗢拖南。一切诸行皆悉是苦。是名第二法嗢拖南。一切诸法皆无有我。是名第三法嗢拖南。涅槃寂静。是名第四法嗢拖南。诸佛菩萨多为有情宣说如是法相应义。是故说名法嗢拖南。又从曩昔其心寂静诸牟尼尊。于一切时展转宣说。是故说此名嗢拖南。又此行迹能趣大生。亦复能趣出第一有。是故说此名嗢拖南

云何菩萨等随观察一切诸行皆是无常。谓诸菩萨观一切行言说自性于一切时常无所有。如是诸行常不可得。故名无常。又即观彼离言说事。由不了知彼真实故。无知为因生灭可得。如是诸行离言自性有生有灭。故名无常。又诸菩萨观过去行已生已灭。由彼诸行无因可得亦无自性。是故观彼因性自性皆无所有。观现在行已生未灭。由彼诸行因不可得已与果故。自性可得犹未灭故。是故观彼自性是有而无有因。观未来行未生未灭。由彼诸行有因可得未与果故。无有自性犹未生故。是故观彼唯有因性而无自性。菩萨如是见三世中分段诸行相续转已。等随观见一一刹那有为诸行。皆有三种有为之相。于刹那后复有第四有为之相。即于此中前刹那行自性灭坏。无间非先诸行刹那自性生起。正观为生。诸行生已即时未坏。正观为住。此已生行望前已灭诸行。刹那自性别异。正观为老。从此诸行生刹那后。即此已生诸行刹那自性灭坏。正观为灭。菩萨观此已生刹那诸行自性。即是生住老之自性。不见生等别有自性。如实观见生刹那后即此生等诸行刹那自性灭坏无别有性。如是四种有为之相。总摄诸行。以要言之。二分所显。一者有分所显。二者无分所显。此中世尊依于有分建立一种有为之相。依于无分建立第二有为之相。住异二种俱是诸行有分所显。建立第三有为之相。此中菩萨观一切时唯有诸行除此更无生住老灭。恒有实物自性成就。何以故。诸行生时唯即如是诸行可得。无别有余生住老灭。如是诸行住老灭时。唯即如是诸行可得。无别有余生住老灭

又诸菩萨以理推求生等实物。亦不可得。如是推求不可得者。谓若离彼色等诸行别有生法。是即应如色等诸行自体有生。如是此生亦应有生。如是即应有二种生。一者行生。二者生生。如是行生与彼生生。为一为异。若言一者计生实有。即为唐捐。言别有生。是实物有不应道理。若言异者。如是即应非行生生。是行生生不应道理。如说生相。如是广说住。老灭相当知亦尔。谓若灭法别有自性是实成就。即应此灭有生有灭。若灭生时一切诸行皆应同灭。如是即应少用功力如入灭定诸心心所一切皆灭。若灭灭时一切诸行虽皆已灭。复应还生。以灭无故。是故言灭有生有灭。不应道理。又善男子或善女人。于一切时恒有实物自性成就。观为假有。而能修厌离欲解脱。不应道理。与此相违是应道理。由此行相是诸菩萨如实了知一切诸行皆是无常

又诸菩萨观无常行相续转时。能为三种苦所依止。一者行苦。二者坏苦。三者苦苦。如是菩萨如实了知一切诸行皆悉是苦又诸菩萨如实了知有为无为一切诸法二无我性。一者补特伽罗无我性。二者法无我性。于诸法中补特伽罗无我性者。谓非即有法是真实有补特伽罗。亦非离有法别有真实补特伽罗。于诸法中法无我性者。谓于一切言说事中。一切言说自性诸法都无所有。如是菩萨如实了知一切诸法皆无有我

又诸菩萨观一切行。先因永断后无余灭。其余毕竟不起不生。说名涅槃。当知涅槃其体寂静。一切众苦毕竟息故。一切烦恼究竟灭故。如是未得清净增上意乐菩萨。未见圣谛。诸声闻乘虽于涅槃发起胜解如是说言涅槃寂静。而于涅槃未如实解。未能如实正智见转。然彼亦有如理作意。譬如王子或长者子。生育已来未出王宫长者内室。王及长者各为幼童假作种种诸戏乐具鹿车牛车马车象车。而赐与之。尔时王子及长者子。用为嬉戏欢娱游佚。即于如是假所造作鹿牛马象。发起真实鹿想牛想马想象想。后于一时王及长者。各知其子渐已长大诸根成熟。赞说真实鹿牛马象。尔时王子及长者子。闻父赞说作是念言。今者父王及父长者。将非赞说我等所有鹿牛马象四种车耶。复于后时王及长者知子转大。从内宫室引出外游。示其真实鹿牛马象。时彼见已内自发生如实慧解。此为实义鹿车牛车马车象车。父于长夜尝为我等赞说斯事。然唯我等以无智故。于不如实唯彼相似唯彼影像。发起真实鹿等胜解。由是因缘于先胜解追起羞愧。如是宫室。喻于生死。其所生育诸幼童子。喻未证得清净增上意乐菩萨。及未见谛诸声闻乘。父喻诸佛及已证入大地菩萨。先为假作鹿牛等车。喻为宣说涅槃鹿相。次为赞说真实鹿等。喻佛菩萨自现证见真实涅槃。如其所见于彼菩萨及声闻前。赞说涅槃真实功德。所余喻彼既闻是已但用随顺音声觉慧于涅槃德长夜胜解。若于是时资粮成熟。渐次增长成净增上意乐。菩萨见谛。声闻于真涅槃生现证智。即于尔时发生自内如实慧解。如是涅槃。一切声闻独觉所证。诸佛菩萨先所赞说。我等先以愚夫觉慧。于不如实唯彼相似唯彼影像。发起真实涅槃胜解。由是因缘于先胜解追生羞愧。依止于后如实胜解。又如病者往大医所。为除病故求随顺药得已常服。彼于是药深生胜解深生爱乐唯见为实。由是因缘先病除愈。复起余病应服余药。尔时大医知先病愈后病复生。更须余药。劝舍前药令服余药。时彼病者愚痴无识。于前所服深生胜解。起所宜想不肯弃舍。时大良医为其宣说前后药性于现所病前药匪宜后药为胜。时有病者虽闻是语不生胜解。犹未深信良医所言。如是病者。喻诸凡夫菩萨声闻为烦恼病之所执持。大良医者喻诸如来。其良药等。喻为宣说若上上胜及以上极。若深深胜及以深极。若劣若胜。及以胜极法教正教。教授教诫。彼虽闻已不能悟入不生胜解。不能修行法随法行诸有净信。菩萨声闻于佛所说不生疑惑。乘佛所说喻如一切支具圆满妙庄严车。无上法乘如善御者。随所行地随所应到。疾疾进趣无所稽留

    本地分中菩萨地第十五初持瑜伽处菩萨功德品第十八

云何菩萨所有功德。嗢拖南曰

  希奇不希奇　　平等心饶益
  报恩与欣赞　　不虚加行性

谓诸菩萨于其无上正等觉乘勤修学时。应知有五甚希奇法。何等为五。一者于诸有情。非有因缘而生亲爱。二者唯为饶益诸有情故。常处生死忍无量苦。三者于多烦恼难复有情。善能解了调伏方便。四者于极难解真实义理。能随悟入。五者具不思议大威神力。如是五种。菩萨所有甚希奇法。不与一切余有情共

又诸菩萨成就五种不希奇法。而名成就甚希奇法。何等为五。谓诸菩萨以因利他苦。即为自己乐。是故菩萨恒遍受行因利他苦。是名菩萨成就第一不希奇法。而名成就甚希奇法。又诸菩萨虽善了知生死过失涅槃功德。而乐普令有情清净。即为己乐。是故菩萨为净有情增上力故誓受生死。是名菩萨成就第二不希奇法。而名成就甚希奇法。又诸菩萨虽善了知默然乐味而乐普令有情清净。即为己乐。是故菩萨为净有情增上力。故恒勤方便为说正法。是名菩萨成就第三不希奇法而名成就甚希奇法。又诸菩萨虽积集六波罗蜜多所有善根而乐普令有情清净。即为己乐。是故菩萨为净有情增上力故。以净意乐施诸有情。然不希求施果异熟。是名菩萨成就第四不希奇法而名成就甚希奇法。又诸菩萨以利他事为自利事。是故菩萨恒现受行一切有情利益之事。是名菩萨成就第五不希奇法而名成就甚希奇法。

又诸菩萨由五种相。当知普于一切有情其心平等。何等为五。一者菩萨最初发心愿大菩提。如是亦为利益一切诸有情故。起平等心。二者菩萨于诸有情。住哀愍俱平等之心。三者菩萨于诸有情。深心发起一子爱俱平等之心。四者菩萨于从众缘已生诸行。知是所想有情事已。知一有情所有法性即是一切有情法性。以法平等俱行之心。于诸有情住平等心。五者菩萨如于一有情行利益行。于一切有情行利益行亦复如是。以利俱心于诸有情住平等心。由此五相。是诸菩萨于诸有情其心平等

又诸菩萨由五种相。于诸有情能作一切饶益之事。何等为五。一者说授正命以为饶益。二者于不随顺能引义利所作事业。说授随顺以为饶益。三者无依无怙有苦有贫。善能为彼作依怙等以为饶益。四者说授能往善趣之道以为饶益。五者说授三乘以为饶益

又诸菩萨由五种相。于其有恩诸有情所现前酬报。何等为五。一者安处有情令学己德。二者方便安处令学他德。三者无依无怙有苦有贫。随力随能作依怙等。四者劝令供养诸佛如来。五者令于如来所说正法受持读诵书写供养

又诸菩萨于五种处常当欣赞。何等为五。一者值佛出世常得承事。二者于诸佛所常闻六种波罗蜜多菩萨藏法。三者于一切种成熟有情常有势力。四者能于无上正等菩提堪任速证。五者证菩提已诸弟子众常和无诤

又诸菩萨由五因缘于诸有情能作不虚饶益加行。何等为五。谓诸菩萨于诸有情先欲求作利益安乐。于诸有情利益安乐如实了知无颠倒觉。如是一切如前供养亲近无量品中所说。应知其相

复次嗢拖南曰

  无颠倒加行　　退堕与胜进
  相似实功德　　善调伏有情

谓诸菩萨有五加行。当知普摄一切菩萨无倒加行。何等为五。一随护加行。二无罪加行。三思择力加行。四清净增上意乐加行。五堕决定加行。云何菩萨随护加行。当知此复略有五种。一者随护聪睿。谓由俱生智速疾摄法。二者随护正念。谓由此正念随所摄法持令不忘。三者随护正智。谓由此正智于所持法善观察义。正慧通达远离随顺聪睿正念觉慧退分诸因缘故。习近随顺住分胜分诸因缘故。四者随护自心。能善防守诸根门故。五者随护他心。能于他心正随转故。云何菩萨无罪加行。谓诸菩萨于诸善法。无倒炽然无量无间回向菩提。云何菩萨思择力加行。谓诸菩萨即此一切在胜解行地。应知其相。云何菩萨清净增上意乐加行。谓诸菩萨即此一切在净胜意乐地及行正行地。应知其相。云何菩萨堕决定加行。谓诸菩萨即此一切在决定地决定行地到究竟地。应知其相。如是五种菩萨加行。普摄一切无倒加行

又诸菩萨顺退分法当知有五。何等为五。一者不敬正法及说法师。二者放逸懈怠。三者于诸烦恼亲近执着。四者于诸恶行亲近执着。五者与余菩萨校量胜劣起增上慢。及于法颠倒起增上慢

又诸菩萨顺胜分法当知有五。何等为五。谓与前五黑品诸法。次第相违应知其相

又诸菩萨略有五种相似功德。当知实是菩萨过失。何等为五。一者于其暴恶毁犯净戒诸有情所。由是因缘作不饶益。二者诈现种种具足威仪。三者于顺世间文词咒术外道书论相应法中。得预智者聪睿者数。四者修行有罪施等善行。五者宣说建立像似正法。广令流布

又诸菩萨略有五种真实功德。何等为五。一者于其暴恶毁犯净戒诸有情所。由是因缘起胜悲心。二者本性成就具足威仪。三者于佛所说净妙真实若教若证。得预智者聪睿者数。四者修行无罪施等善行。五者开示正法遮灭一切像似正法

又诸菩萨略于十处。无倒调伏所化有情。何等十处。一者远离恶行处。二者远离诸欲处。三者专精无犯犯已能出处。四者密护一切诸根门处。五者正知住处。六者离愦闹处。七者于远离处远离一切恶寻思处。八是远离障处。九者远离一切烦恼缠处。十者远离一切诸烦恼品诸粗重处

复次嗢拖南曰

  诸菩萨受记　　堕于决定中
  定作常应作　　最胜最为后

谓诸菩萨略由六相。蒙诸如来于其无上正等菩提授与记别。何等为六。一者安住种性未发心位。二者已发心位。三者现在前位。四者不现前位。五者有定时限。谓尔所时当证无上正等菩提。六者无定时限。谓不宣说决定时限而与授记

又诸菩萨略有三种堕于决定。何等为三。一者安住种性堕于决定。二者发菩提心堕于决定。三者不虚修行堕于决定。安住种性堕决定者。谓诸菩萨住种性位。便名为堕决定菩萨。何以故。由此菩萨若遇胜缘必定堪任证于无上正等觉故。发菩提心堕决定者。谓有一类诸菩萨众。已于无上正等菩提起决定心。此后乃至证于无上正等菩提。无复退转。不虚修行堕决定者。谓诸菩萨已得自在。普于一切利有情行。如其所欲随所造修终无空过。于此三种堕决定中。依于最后堕决定位。诸佛如来授诸菩萨堕决定记

又诸菩萨略有五处定所应作。若不作已终不堪任证于无上正等菩提。何等为五。一者发菩提心。二者于诸有情深生哀愍。三者炽然精进。四者于诸明处方便修习。五者无有厌倦。

又诸菩萨于其五处常所应作。何等为五。一者于不放逸常所应作。二者无依无怙有苦有贫诸有情所。常应为作依怙等事。三者于诸如来常应供养。四者常应遍知有失无失。五者一切所作若行若住诸作意中。大菩提心恒为导首。如是五种是诸菩萨常所应作

又诸菩萨有十种法。一切菩萨许为最胜特为第一。建立在于最上法中。何等为十。一者菩萨种性。诸种性中最为殊胜。二者最初发心。于诸正愿最为殊胜。三者精进般若。普于一切波罗蜜多最为殊胜。四者爱语摄事。于诸摄事最为殊胜。五者如来世尊。于诸有情最为殊胜。六者悲愍有情。于诸无量最为殊胜。七者第四静虑。于诸静虑最为殊胜。八者空三摩地。于三等持最为殊胜。九者灭尽等至。于诸等至最为殊胜。十者如前所说所有清净方便善巧。普于一切方便善巧最为殊胜

复次嗢拖南曰

  诸施设建立　　一切法寻思
  及如实遍智　　如是诸无量
  说法果胜利　　大乘性与摄
  菩萨十应知　　建立诸名号

谓诸菩萨略有四种施设建立。唯有如来及诸菩萨。能正施设能正建立。非余一切若天若人若诸沙门若婆罗门。唯除闻已。何等为四。一者法施设建立。二者谛施设建立。三者理施设建立。四者乘施设建立

云何名法施设建立。谓佛所说素呾缆等十二分教。次第结集次第安置次第制立。是名为法施设建立

云何名谛施设建立。谓无量种。或立一谛。谓不虚妄义。唯有一谛无第二故。或立二谛。一世俗谛。二胜义谛。或立三谛。一相谛。二语谛。三用谛。或立四谛。一苦谛。二集谛。三灭谛。四道谛。或立五谛。一因谛。二果谛。三智谛。四境谛。五胜谛。或立六谛。一谛谛。二妄谛。三应遍知谛。四应永断谛。五应作证谛。六应修习谛。或立七谛。一爱味谛。二过患谛。三出离谛。四法性谛。五胜解谛。六圣谛。七非圣谛。或立八谛。一行苦性谛。二坏苦性谛。三苦苦性谛。四流转谛。五还灭谛。六杂染谛。七清净谛。八正加行谛。或立九谛。一无常谛。二苦谛。三空谛。四无我谛。五有爱谛。六无有爱谛。七彼断方便谛。八有余依涅槃谛。九无余依涅槃谛。或立十谛。一逼切苦谛。二财位匮乏苦谛。三界不平和苦谛。四所爱变坏苦谛。五粗重苦谛。六业谛。七烦恼谛。八听闻正法如理作意谛。九正见谛。十正见果谛。如是等类名菩萨谛施设建立。若广分别当知无量

云何名理施设建立。谓四道理。此广分别如前应知

云何名乘施设建立。谓声闻乘及独觉乘无上大乘。如是三种一一各由七种行相施设建立。是名为乘施设建立。初声闻乘七行相者。一于四圣谛无颠倒慧。二此慧所依。三此慧所缘。四此慧伴类。五此慧作业。六此慧资粮。七此慧得果。当知由此七种行相施设建立。诸声闻乘无不周备。如声闻乘七种行相施设建立。其独觉乘当知亦尔。无上大乘七行相者。一缘离言说事一切法中所有真如无分别平等性出离慧。二此慧所依。三此慧所缘。四此慧伴类。五此慧作业。六此慧资粮。七此慧得果。当知由此七种行相施设建立。无上大乘无不周备

过去未来现在诸佛。及诸菩萨所有无倒施设建立。若曾所作若当所作若今所作。一切皆由如是四事。除此无有若过若增

又诸菩萨为得四种如实遍知。于一切法起四寻思。何等为四。一名寻思。二事寻思。三自性假立寻思。四差别假立寻思。如是四种若广分别应知如前真实义品

又诸菩萨略有四种。于一切法如实遍知。一名寻思所引如实遍知。二事寻思所引如实遍知。三自性假立寻思所引如实遍知。四差别假立寻思所引如实遍知。如是四种若广分别。应知如前真实义品

又诸菩萨于五无量。能起一切善巧作用。何等为五。一有情界无量。二世界无量。三法界无量。四所调伏界无量。五调伏方便界无量。云何有情界无量。谓六十四诸有情众名有情界。如前意地已具条列。若依相续差别无边。云何世界无量。谓于十方无量世界无量名号各各差别。如此世界名曰索诃。此界梵王名索诃主。如是一切皆当了知。云何法界无量。谓善不善无记诸法。如是等类差别道理。应知无量。云何所调伏界无量。谓或有一种所调伏界。一切有情可调伏者同一类故。或有二种所调伏界。一具缚。二不具缚。或有三种所调伏界。一钝根。二中根。三利根。或有四种所调伏界。一刹帝利。二婆罗门。三吠舍。四戍达罗。或有五种所调伏界。一贪行。二嗔行。三痴行。四慢行。五寻思行。或有六种所调伏界。一在家。二出家。三未成熟。四已成熟。五未解脱。六已解脱。或有七种所调伏界。一轻毁。二中庸。三广显智。四略开智。五现所调伏。六当所调伏。七缘引调伏谓遇如是如是缘。即如是如是转变。或有八种所调伏界。谓八部众。从刹帝利乃至梵众。或有九种所调伏界。一如来所化。二声闻独觉所化。三菩萨所化。四难调伏。五易调伏。六软语调伏。七诃摈调伏。八远调伏。九近调伏。或有十种所调伏界。一那落迦。二傍生。三琰摩世界。四欲界天人。五中有。六有色。七无色。八有想。九无想。十非想。非非想。如是略说品类差别有五十五。若依相续差别道理。当知无量。问有情界无量。所调伏界无量。有何差别。答一切有情若住种性不住种性。无有差别。总名有情界无量。唯住种性彼彼位转。乃得名为所调伏界无量。云何调伏方便界无量。谓如前说。当知此中亦有无量品类差别

问何故总说此五无量如是次第。答以诸菩萨专精修习饶益有情。是故最初说有情界无量。是诸有情依于处所可得受化。是故第二说世界无量。是诸有情在彼彼界由种种法。或染或净差别可得。是故第三说法界无量。即观如是有情界中。有诸有情有所堪任有大势力。堪能究竟解脱众苦。是故第四说所调伏界无量。要由如是方便善巧。令诸有情究竟解脱。是故第五说调伏方便界无量。是故说言菩萨于此五种无量。能起一切善巧作用

诸佛菩萨为诸有情宣说正法。当知有五大果胜利。何等为五。一者一类有情闻佛菩萨说正法时。远尘离垢。于诸法中法眼生起。二者一类有情闻佛菩萨说正法时。得尽诸漏。三者一类有情闻佛菩萨说正法时。便于无上正等菩提发正愿心。四者一类有情闻佛菩萨说正法时。证得菩萨最胜法忍。五者一类有情闻佛菩萨说正法已。受持读诵修习正行。展转方便令正法眼久住不灭。如是五种。当知名为诸佛菩萨所说正法大果胜利。

诸菩萨乘与七大性共相应故说名大乘。何等为七。一者法大性。谓十二分教中菩萨藏。摄方广之教。二者发心大性。谓有一类于其无上正等菩提发正愿心。三者胜解大性。谓有一类于法大性生胜信解。四者增上意乐大性。谓有一类已过胜解行地。证入净胜意乐地。五者资粮大性。谓福德资粮智慧资粮。修习圆满能证无上正等菩提。六者时大性。谓经于三无数大劫。方证无上正等菩提。七者圆证大性。谓即所证无上菩提。由此圆证菩提自体。比余圆证功德自体。尚无与等。何况得有若过若增。当知此中若法大性若发心大性。若胜解大性若增上意乐大性。若资粮大性若时大性。如是六种。皆是圆证大性之因。圆证大性。是前六种大性之果

有八种法能具足摄一切大乘。一者菩萨藏教。二者即于如是菩萨藏中。显示诸法真实义教。三者即于如是菩萨藏中。显示一切诸佛菩萨不可思议最胜广大威力之教四者于上所说如理听闻。五者如理思为先。趣胜意乐。六者趣胜意乐为先。入修行相。七者入修行相为先修果成满。八者即由如是修果成满究竟出离

如是菩萨勤修学已。能证无上正等菩提。何等菩萨勤修学已能证无上正等菩提。当知菩萨略有十种。一住种性。二已趣入。三未净意乐。四已净意乐。五未成熟。六已成熟。七未堕决定。八已堕决定。九一生所系。十住最后有。此中即住种性菩萨发心修学。名已趣入。即已趣入。乃至未入净意乐地。名未净意乐。若已得入名已净意乐。即净意乐。乃至未入到究竟地。名未成熟。若已得入名已成熟。未成熟中乃至未得入决定地决定行地。名未决定。若已得入名已决定。已成熟中复有二种。一者一生所系。谓此生无间当证无上正等菩提。二住最后有。谓即住此生能证无上正等菩提。

如是如说从初种性。广说乃至能证无上正等菩提。十种菩萨于菩萨学能正修学。此上更无能正修学。若于中学若如是学。非如所说诸菩萨。上更有菩萨于菩萨学能正修学

如是所说。一切菩萨当知复有如是等类无有差别随德假名。所谓名为菩提萨埵摩诃萨埵。成就觉慧最上照明最胜真子最胜任持普能降伏最胜萌芽。亦名勇健亦名最圣。亦名商主亦名大称。亦名怜愍亦名大福。亦名自在亦名法师。如是十方无边无际诸世界中无边菩萨。当知乃有内德。各别无量无边假立想号。若诸菩萨现前自称我是菩萨。于菩萨学不正修行。当知是名相似菩萨。非真菩萨。若诸菩萨现前自称我是菩萨。于菩萨学能正修行当知是名真实菩萨

瑜伽师地论卷第四十六瑜伽师地论卷第四十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五第二持随法瑜伽处菩萨相品第一

云何真实诸菩萨相。嗢拖南曰

  真实诸菩萨　　五种相应知
  自性依处果　　次第摄五转

谓诸菩萨有五真实菩萨之相。若成就者堕菩萨数。何等为五。一者哀愍。二者爱语。三者勇猛。四者舒手惠施。五者能解甚深义理密意。如是五法。当知一一各有五转。一者自性。二者依处。三者果利。四者次第。五者相摄。

应知此中哀愍自性略有二种。一在意乐。二在正行。在意乐者。谓诸菩萨于诸有情。利益意乐安乐意乐。是名哀愍。在正行者。谓诸菩萨于诸有情。如所意乐随力随能身语饶益。是名哀愍。爱语自性。谓如前说。若慰喻语若庆悦语若胜益语。当知如前摄事品说。勇猛自性。谓诸菩萨刚决坚固。无所怯劣有大势力。若诸菩萨广大施性无染施性。是名舒手惠施自性。若诸菩萨四无碍解。及即于彼无倒引发正加行智。是名能解甚深义理密意自性

当知菩萨哀愍依处略有五种。何等为五。一有苦有情。二恶行有情。三放逸有情。四邪行有情。五烦恼随眠有情。那落迦等所有有情。皆为苦受连绵相续逼切而转。如是名为有苦有情。或复有情虽非定苦。而多现行诸身恶行诸语恶行诸意恶行。于诸恶中喜乐安住。所谓屠养羊猪鸡等不律仪辈。如是名为恶行有情。或复有情虽非定苦及行恶行。而于诸欲耽着受用常乐安住。种种俳优歌舞笑睇以自娱乐。所谓一类受欲尘者。如是名为放逸有情。或复有情虽非定苦行恶放逸。而依妄见修行种种苦解脱行。谓舍诸欲。于恶说法毗柰耶中而出家者。如是名为邪行有情。或复有情虽非定苦广说乃至非修邪行。而或具缚或不具缚。为诸烦恼之所随眠。谓正修行贤善异生及诸有学。是名烦恼随眠有情。是名菩萨所有哀愍五种依处。由此依处由此所缘哀愍而转。除此无有若过若增。当知菩萨爱语依处亦有五种。何等为五。一正言论语。二正庆悦语。三正安慰语。四正广恣语。五如理说语。如是广辩应知如前摄事品说。是名菩萨所有爱语五种依处。由此依处由此所缘爱语而转。除此无有若过若增。当知菩萨勇猛依处亦有五种。何等为五。谓即如前菩提分品所说菩萨坚力持性五种依处。当知此是菩萨勇猛五种依处。由此依处由此所缘勇猛而转。除此无有若过若增。当知菩萨舒手惠施亦五依处。何等为五。一数数惠施。二欢喜惠施。三殷重惠施。四无染惠施。五无依惠施。如是五种。如前施品广辨。应知由此依处由此所缘。菩萨舒手惠施而转。除此无有若过若增。当知菩萨能解甚深义理密意亦五依处。何等为五。谓于如来所说契经。随顺甚深甚深显现。空性相应缘性缘起。应知是名第一依处。于毗奈耶毁犯善巧。还净善巧。当知是名第二依处。于摩怛理迦。施设建立无倒法相。当知是名第三依处。能正显除意趣难解诸法相义。当知是名第四依处。于一切法法义释词品类差别。当知是名第五依处由此依处由此所缘。菩萨能解甚深义理密意而转。除此无有若过若增

菩萨哀愍于诸有情。最初能断怨害嫌恨。菩萨哀愍普于一切利有情事。皆能修作心无怯劣。于此加行尝无厌倦。多住哀愍能摄无罪。现法乐住及饶益他。又如世尊所说修慈所得胜利。谓于现身毒药刀杖不加害等。如是一切菩萨哀愍。皆当了知。是名菩萨哀愍果利。菩萨爱语。于现法中断语四过。所谓妄语。离间。粗恶。及以绮语。由此爱语。于现法中能自摄受能摄受他。安隐而转。菩萨爱语。于当来世其言敦肃言必信用。是名菩萨爱语果利。菩萨勇猛。于现法中能离一切懒惰懈怠心。常欢喜能受菩萨净戒律仪。受已终无毁犯退屈。能正堪忍摄受自他。于当来世一切菩萨所起事业。禀性坚固。凡所造修若未成办终无懈退。是名菩萨勇猛果利。当知菩萨舒手惠施。能解甚深义理密意所得果利。如威力品惠施威力般若威力差别。应知是名菩萨舒手惠施。能解甚深义理密意。二种果利。是名菩萨五相果利

云何五相如是次第。谓诸菩萨先修哀愍摄受有情。于彼顾念欲作饶益。次修爱语。为彼有情出不善处安立善处。宣说正理摄受教诲。次修勇猛。于已趣入诸有情类。若诸有情起诸邪行种种烦恼变异事中皆能堪忍。为不弃舍安住种种正行邪行诸有情故。是诸菩萨修勇猛已。一类有情以财摄受能令成熟。一类有情以法摄受能令成熟。一类有情以财以法二种摄受能令成熟。是故菩萨次后修习舒手惠施。能解甚深义理密意。当知是名菩萨五相前后次第

问菩萨五相六到彼岸。何到彼岸摄。何等相。答菩萨哀愍。当知静虑到彼岸摄。菩萨爱语。尸罗般若到彼岸摄。菩萨勇猛。进忍般若到彼岸摄。菩萨所有舒手惠施。当知即施到彼岸摄。菩萨所有能解甚深义理密意。静虑般若到彼岸摄

如是真实菩萨五相。当知一一皆有五转。所谓自性。依处。果利。次第。相摄。已广分别应如实知

    本地分中菩萨地第十五第二持随法瑜伽处分品第二

在家出家二分菩萨。有几种法正修学时。速证无上正等菩提嗢拖南曰

  二分诸菩萨　　初事业善修
  善巧饶益他　　回向最为后

谓诸菩萨或在家分或出家分差别转时。略有四法。当知令此在家出家二分菩萨正勤修学速证无上正等菩提。何等为四。一者善修事业。二者方便善巧。三者饶益于他。四者无倒回向

云何菩萨善修事业。谓诸菩萨于六波罗蜜多。决定修作委悉修作。恒常修作无罪修作。云何菩萨于施波罗蜜多决定修作。谓诸菩萨现有种种可施财法。诸乞求者正现在前有恩无恩有德有失无有差别。要当施与。若人非人若诸沙门。若婆罗门及余世间无有如法。能令施心有所倾动。云何菩萨于施波罗蜜多委悉修作。谓诸菩萨现有种种可施财法。诸乞求者正现在前。一切施与无有少物于诸有情而不能舍。于内身命尚能惠施。何况外物。云何菩萨于施波罗蜜多恒常修作。谓诸菩萨于修惠施。无有厌倦。恒常无间于一切时。随有所得即随惠施无所吝惜。云何菩萨于施波罗蜜多无罪修作。谓诸菩萨远离如前施品所说诸杂染施。修行所余无杂染施。如是菩萨于施波罗蜜多。能善修作。如于施波罗蜜多能善修作。如是于戒忍精进静虑慧波罗蜜多。如其所应当知亦尔。是名菩萨由四行相于其六种波罗蜜多。决定修作委悉修作。恒常修作无罪修作

云何菩萨方便善巧。当知如是方便善巧略有十种。何等为十。一者憎背圣教有情除其恚恼方便善巧。二者处中有情令其趣入方便善巧。三者已趣入者令其成熟方便善巧。四者已成熟者令得解脱方便善巧。五者于诸世间一切异论方便善巧。六者于诸菩萨净戒律仪受持毁犯能正观察方便善巧。七者于诸正愿方便善巧。八者于声闻乘方便善巧。九者于独觉乘方便善巧。十者于其大乘方便善巧。如是一切方便善巧。如前即此菩萨地中随彼彼处已广分别。如应当知。如是十种菩萨所有方便善巧能作五事。谓由前四种方便善巧。令诸菩萨能正安立所化有情于自义利。由于世间一切异论方便善巧。令诸菩萨善能摧伏一切异论。由于菩萨净戒律仪受持毁犯。能正观察方便善巧。令诸菩萨不犯所犯。犯已速疾如法悔除。于善清净菩萨所受净戒律仪。能善修莹。由于正愿方便善巧。令诸菩萨能证当来一切所爱事义圆满。由于三乘方便善巧。令诸菩萨于诸有情随其种性根及胜解说相称法说顺正理。是名十种方便善巧。令诸菩萨能作五事。由此五事能令菩萨现法当来一切事义皆得究竟

云何菩萨饶益于他。谓诸菩萨依四摄事。即布施爱语利行同事。能与一分有情利益。能与一分有情安乐。能与一分所化有情利益安乐。是名略说菩萨所有饶益于他。广说如前自他利品。应知其相

云何菩萨无倒回向。谓诸菩萨三门积集所有善根。即善修事业。方便善巧饶益于他。去来今世一切摄取。以淳一味妙净信心。回求无上正等菩提。终不用此所集善根希求世间余果异熟。唯除无上正等菩提

世尊所有为在家分或出家分诸菩萨说所应学法。当知一切此四所摄。谓善修事业。方便善巧饶益于他。无倒回向。是故如是善修事业方便善巧饶益于他无倒回向诸菩萨众。亲近邻逼难得难证无上菩提。当知过去未来现在所有菩萨。或在家分或出家分。精勤修学于其无上正等菩提曾当现证。一切皆由如是四法。除此无有若过若增

又诸菩萨或在家分或出家分。虽复同于如是四法正勤修学。而出家者于在家者。甚大殊异甚大高胜。所以者何。当知一切出家菩萨。于其父母妻子亲属摄受过患皆得解脱。在家菩萨则不如是。又复一切出家菩萨。于为摄受父母亲属。营农商估事王业等种种艰辛遽务忧苦。皆得解脱。在家菩萨则不如是。又复一切出家菩萨。一向能行钩锁梵行。在家菩萨则不如是。又复一切出家菩萨。普于一切菩提分法速证通慧。随所造修彼彼善法。皆能疾疾到于究竟。在家菩萨则不如是。又复一切出家菩萨。安住决定清净律仪。凡所发言众咸信奉。在家菩萨则不如是。如是等类无量善法。当知一切出家菩萨于在家者。甚大殊异甚大高胜

    本地分中菩萨地第十五第二持随法瑜伽处增上意乐品第三

云何菩萨增上意乐。嗢拖南曰

  智者于有情　　有七相怜愍
  十五胜意乐　　作十事应知

谓诸菩萨于诸有情。深心发起七相怜愍。以诸菩萨具怜愍故。名善意乐极善意乐。何等名为七相怜愍。一者无畏怜愍。二者如理怜愍。三者无倦怜愍。四者无求怜愍。五者无染怜愍。六者广大怜愍。七者平等怜愍。谓诸菩萨于诸有情。非怖畏故而起怜愍现行随顺身语意业。适可其心利益安乐。是名菩萨无畏怜愍。又诸菩萨于诸有情。非不如理怜愍而转。谓终不以非法非律非贤善行。及以非处劝授有情。是名菩萨如理怜愍。又诸菩萨于诸有情。如是怜愍随其所宜。发起一切饶益事业曾无厌倦。是名菩萨无倦怜愍。又诸菩萨于诸有情。不待求请自起怜愍为作饶益。是名菩萨无求怜愍。又诸菩萨于诸有情。无爱染心而起怜愍。谓饶益他不祈恩报。亦不悕望当来可爱诸果异熟。是名菩萨无染怜愍。亦名菩萨无缘怜愍。又诸菩萨于诸有情。所起怜愍。唯是广大而非狭小。言广大者。谓于一切诸有情所。虽遭一切不饶益事而不弃舍。菩萨自身宁受非爱。终不以恶欲加于彼。是名菩萨广大怜愍。又诸菩萨如是相状如是功德相应怜愍。普于一切诸有情类平等平等。于有情界无有分限。是名菩萨平等怜愍。菩萨与此七种行相怜愍相应。名善意乐极善意乐

当知此中净信为先择法为先。于诸佛法所有胜解。印解决定。是名菩萨增上意乐。如是菩萨增上意乐。当知略说有十五种。何等十五。一最上意乐。二遮止意乐。三波罗蜜多意乐。四真实义意乐。五威力意乐。六利益意乐。七安乐意乐。八解脱意乐。九坚固意乐。十无虚妄意乐。十一不清净意乐。十二清净意乐。十三善清净意乐。十四应调伏意乐。十五俱生意乐。谓诸菩萨于佛法僧最上真实。起胜意乐。是名菩萨最上意乐。又诸菩萨于所受持净戒律仪。起胜意乐。是名菩萨遮止意乐。又诸菩萨于所修证施忍精进静虑般若。起胜意乐。是名菩萨波罗蜜多意乐。又诸菩萨于法无我补特伽罗无我甚深胜义诸法真如。起胜意乐。是名菩萨真实义意乐。又诸菩萨于佛菩萨不可思议神通威力或俱生威力。起胜意乐。是名菩萨威力意乐。又诸菩萨于诸有情。欲以善法而授与之。是名菩萨利益意乐。又诸菩萨于诸有情。欲以饶益而授与之。是名菩萨安乐意乐。又诸菩萨即于如是诸有情所无爱染心。又于当来可爱异熟其心无系。是名菩萨解脱意乐。又诸菩萨于其无上正等菩提。其心专注曾无变易。是名菩萨坚固意乐。又诸菩萨于诸有情饶益方便。于大菩提趣证方便无颠倒智俱行胜解。是名菩萨无虚妄意乐。又诸菩萨胜解行地所有一切增上意乐。是名菩萨不清净意乐。又诸菩萨从净胜意乐地乃至决定行地。所有一切增上意乐。是名菩萨清净意乐。又诸菩萨到究竟地。所有一切增上意乐。是名菩萨善清净意乐。又诸菩萨不清净意乐。是则名为应调伏意乐。由此意乐应思择故。又诸菩萨清净意乐善清净意乐。是则名为俱生意乐。由此意乐性成就故。于所依中善安立故

如是菩萨十五妙善增上意乐。随一切地。以要言之。能作十事。何等为十。谓诸菩萨最上意乐。能于三宝修一切种最胜供养。普于一切菩提资粮为最第一。又诸菩萨遮止意乐。能于所受净戒律仪。命难因缘亦不故思犯于所犯。设有所犯疾疾悔除。又诸菩萨波罗蜜多意乐。能于善法常勤修习无放逸住。常住最胜无放逸住。又诸菩萨真实义意乐。能为有情以无染心流转生死。不舍涅槃增上意乐。又诸菩萨威力意乐。能于圣教觉受淳净上妙法味。复能于修起坚固想欣乐多住。不唯闻思便生喜足。又诸菩萨利益意乐。安乐意乐。解脱意乐。能于一切饶益有情所作事业精勤修习。虽常修习而无厌倦。又诸菩萨坚固意乐。能于种种炽然精进广大精进。发起安住无缓加行无断加行。又诸菩萨无虚妄意乐。能于所引彼彼善法速证通慧。不于少分下劣薄弱差别证中而生喜足。又诸菩萨应调伏意乐。能引俱生意乐。又诸菩萨俱生意乐。能于无上正等菩提速疾趣证。能与天人作诸义利。利益安乐。应调伏意乐。即不清净意乐。俱生意乐。即清净意乐。善清净意乐故不别说

世尊所有为诸菩萨。于彼彼处种种宣说。施设开示增上意乐。当知一切即此十五意乐所摄。是故过去未来现在妙善意乐。诸菩萨众于其无上正等菩提。曾当现证。一切皆由如是所说十五意乐。除此无有若过若增。如是菩萨十五意乐。能得最大菩提果利。是故菩萨依此意乐速证无上正等菩提

    本地分中菩萨地第十五第二持随法瑜伽处住品第四之一

如是始从种性具足。广说乃至于如所说菩萨所学。正勤修学。于如所说菩萨诸相。正等显现。于诸菩萨分加行中。正勤修学。于如所说菩萨意乐。能净修治。诸菩萨众略有菩萨十二种住。由此菩萨十二种住。普摄一切诸菩萨住。普摄一切诸菩萨行。复有如来第十三住。由此住故现前等觉广大菩提。名无上住。云何菩萨十二住等。嗢拖南曰

  种性胜解行　　极喜增上戒
  增上心三慧　　无相有功用
  无相无功用　　及以无碍解
  最上菩萨住　　最极如来住

谓菩萨种性住。胜解行住。极欢喜住。增上戒住。增上心住。增上慧住。复有三种。一觉分相应增上慧住。二诸谛相应增上慧住。三缘起流转止息相应增上慧住。谓诸菩萨如实了知能观真实所观真实。及于真实诸有情类。由无智故众苦流转。由有智故众苦止息。如是菩萨由于三门以慧观察故。有三种增上慧住。及有加行有功用无间缺道运转无相住无加行无功用无间缺道运转无相住无碍解住最上成满菩萨住。是名菩萨十二种住。如是菩萨十二种住。普摄一切诸菩萨住。普摄一切诸菩萨行。如来住者。谓过一切诸菩萨住。现前等觉大菩提住。此中最后如来住者。于后究竟瑜伽处最后建立品。当具演说。菩萨所有十二种住如所安立。我今当说。

云何菩萨种性住。云何菩萨住种性住。谓诸菩萨住种性住。性自仁贤。性自成就菩萨功德菩萨所应众多善法。于彼现行亦有显现。由性仁贤逼遣方便令于善转。非由思择有所制约有所防护。若诸菩萨住种性住。任持一切佛法种子。于自体中于所依中。已具足有一切佛法一切种子。又诸菩萨住种性住。性离粗垢。不能现起上烦恼缠。由此缠故。造无间业或断善根。如种性品所说种种住种性相。于此菩萨种性住中。亦应广说应如实知。是名菩萨种性住

云何菩萨胜解行住。谓诸菩萨从初发心乃至未得清净意乐。所有一切诸菩萨行。当知皆名胜解行住。又诸菩萨种性住中。于余十一诸菩萨住及如来住。唯有因转。摄受彼因。于余所有诸菩萨住。尚未发趣未得未净。况如来住。若诸菩萨胜解行住。普于一切余菩萨住及如来住。皆名发趣。未得未净。即于如是胜解行住。亦名发趣。亦名为得为令清净而修正行。胜解行住既清净已。极欢喜住先已发趣。今复名得为令清净而修正行。极欢喜住既清净已。增上戒住先已发趣。今复名得为令清净而修正行。如是广说展转乃至最上成满菩萨住。即此最上成满菩萨住既清净已。从此无间其如来住先已发趣。当知于今顿得顿净。是如来住。于菩萨住当知此中如是差别

云何菩萨极欢喜住。谓诸菩萨净胜意乐住。云何菩萨增上戒住。谓诸菩萨净胜意乐为缘。所得性戒相应住。云何菩萨增上心住。谓诸菩萨增上戒住清净为缘。所得世间静虑等持等至住。云何菩萨觉分相应增上慧住。谓诸菩萨以世间净智所依等持为所依止。为觉诸谛于正念住等三十七菩提分法。妙简择住。云何菩萨诸谛相应增上慧住。谓诸菩萨觉分简择为所依止。于诸谛中如实觉住。云何菩萨缘起流转止息相应增上慧住。谓诸菩萨于谛能觉增上力故。简择显示由无智故苦及因起。简择显示由有智故苦及因灭住。云何菩萨有加行有功用无相住。谓诸菩萨即由三种增上慧住增上力故。有加行有功用无缺无间。于一切法真如无分别慧。修俱行住。云何菩萨无加行无功用无相住。谓诸菩萨即于前无相住多修习已。任运自然无缺无间运转道随行住。云何菩萨无碍解住。谓诸菩萨即以善清净无动慧等持。为所依止。得广大慧为他说法。无上为依能于诸法异门义趣释词差别。妙简择住。云何菩萨最上成满菩萨住。谓诸菩萨安住于此。于菩萨道已到究竟。于阿耨多罗三藐三菩提已得大法灌顶。或一生所系。或居最后有。从此住无间即于尔时证觉无上正等菩提。能作一切佛所作事又诸菩萨胜解行住。于菩萨修。所作狭小。所作有缺所作不定。所得有退。极欢喜住。于菩萨修所作广大。所作无缺所作决定。随所获得无复退转。如极欢喜住。乃至三种增上慧住应知亦尔。从初无相住。乃至最上成满菩萨住。于菩萨修。所作无量所作无缺所作决定。随所获得终无退转

又诸菩萨胜解行住。于菩萨无相修。当知发趣极欢喜住。增上戒住。增上心住。增上慧住。于菩萨无相修。当知获得初无相住。于菩萨无相修。当知圆证第二无相住。于菩萨无相修。当知清净无碍解住。最上成满菩萨住。于菩萨无相修果。当知领受

问胜解行住菩萨转时。应知何行何状何相。答胜解行住菩萨转时。思择力胜。于诸菩萨所作加行。以分别慧数数思择方能修作。未能任性成办所作。未得坚固相续无退菩萨胜修如于胜修。于胜修果种种无碍胜解神通解脱等持等至。亦未能得。未能超越五种怖畏。谓不活畏。恶名畏。死畏。恶趣畏。处众怯畏。于所应作利有情事。策励思惟方能修作。未能任性哀愍爱念。或于一时于诸有情。由身语意发起邪行。或于一时于诸境界。发起贪着。或于一时于资生具现有悭吝。信他诸佛菩萨而行。未能自内了知真实。谓于如来或法或僧。或真实义或有情事。或佛菩萨神通威力。或因或果。或应得义。或得方便。或于所行皆随他信。成就狭小闻所成智思所成智而非无量。又即于此或时忘失。有忘失法成就菩萨苦迟通行。于大菩提无猛利乐欲。无炽然精进。无有甚深牢固净信。于其三处有忘失念。一于境界可意不可意色声香味触法中。或于一时其心颠倒忘失正念。二于受生彼彼身中。既受生已忘失前生。三于所受所持诸法久作久说。或于一时有所忘失。于是三处有忘失念。或于一时具足聪慧。于其诸法能受能持。于其义理堪能悟入。或于一时则不如是。或于一时具足忆念。或于一时成忘念类。于诸有情未能了知如实调伏善巧方便。于自佛法亦未了知如实引发善巧方便。为他说法教授教诫勉励而转。勉励转故不如实知。或时虚弃或不虚弃。如闇中射或中不中。随欲成故。或于一时于大菩提虽已发心而复退舍。或于一时弃舍菩萨先所受学净戒律仪不能受学。或于一时虽勤修习利有情事。而于中间生厌倦故。复还弃舍利有情事。由意乐故欲令自乐。由思择故欲令他乐。于诸菩萨所有违犯。多分遍知非数遍知。无余永断。由于毁犯数现行故。或于一时于菩萨藏法毗奈耶。他所引夺。或于一时闻说甚深广大法教而生惊怖。其心摇动犹豫疑惑。于诸有情远离一切现行大悲。于诸有情少分现前利益安乐。未能广大未能无量。于如上说一切圆满菩萨学中。未能普学。于如上说一切圆满菩萨诸相未皆成就。于如上说一切圆满二分菩萨正加行中未等显现。于如上说菩萨意乐。犹未清净。于其无上正等菩提自谓为远。未于涅槃增上意乐安立深固。如于生死长时流转。于其炽然无动妙善菩提分法。未能成就。如是等类当知是名胜解行住菩萨转时诸行状相。是诸菩萨胜解行住下忍转时。如上所说诸行状相。当知上品中忍转时。如上所说诸行状相。当知中品上忍转时。如上所说。当知下品其性微薄。即于如是上忍转时。于上所说诸行状相。渐次能令无余永断。从此无间当知菩萨入极喜住。由得方便极喜住中。胜解行住所说诸法皆无所有。与彼相违所有一切白品诸法皆悉显现。由诸菩萨成就此故。转得名为净胜意乐。胜解行住菩萨转时。虽有少分软中上品方便展转清净胜解。而未得名净胜意乐。何以故。由此胜解。为彼多种诸随烦恼染污而转。极欢喜住菩萨住时一切胜解。诸随烦恼皆悉永断。离随烦恼净胜解转。问极欢喜住菩萨转时。应知何行何状何相。答若诸菩萨从胜解行住入极欢喜住。先于无上正等菩提。菩萨弘愿。未善通达菩提自性。未善通达菩提方便。多分随顺他缘而转。不善决定除舍彼故发起六相。新善决定内证修性。菩萨大愿超过一切余白净愿。无等不共果。是世间超过一切世间境界。随救一切有情苦故。不共一切声闻独觉。虽一刹那生起此愿。法性自尔能得菩萨无量白法可爱之果。又此大愿无变无尽自性得已。无异因缘令其退转变异可得。又是胜分堕后边际极大菩提。如此菩萨善决定愿。亦名发心。又即如是菩萨发心。略由四相应当了知。何等为四。一者何相菩萨发心。二者发心何所缘虑。三者发心何状。何相。何自性起。四者发心有何胜利。由此四相应当了知菩萨发心。谓诸菩萨胜解行住。已善积集一切善根。于菩萨行已正超出。略说是相菩萨发心。又诸菩萨缘当来世无倒速疾一切菩提资粮圆满。一切菩萨利有情事圆满。无上正等菩提一切种一切佛法圆满。诸佛所作事业圆满。略说缘虑如是发心。又诸菩萨无倒速疾发起一切菩提资粮。随顺于诸有情一切菩萨所作。随顺获得无上正等菩提。无师自然妙智。随顺遍一切种诸佛所作事业。随顺广大愿心。又诸菩萨发是心已。超过菩萨凡异生地。证入菩萨正性离生。生如来家成佛真子。决定趣向正等菩提。决定绍继如来圣种。又正获得如实证净极多欢喜。于他有情远离多分忿害斗诤。于一切种菩萨所作利众生事。于一切种菩提资粮圆满。于一切种无上菩提一切佛法。于一切种佛所作事。以净增上意乐。攀缘胜解趣入。于是诸法速疾圆证。自观己身能正随顺如是解了。极多欢喜。又自观见妙善。广大能引出离无染无等摄受饶益。身心欢喜。于此无量炽然善法皆悉成就。又自了知我于无上正等菩提今已邻近。于大菩提我胜意乐已得清净。我今已离一切怖畏。由是因缘极多欢喜。由诸菩萨已能发起善决定心。于五怖畏皆悉除断。由善修习无我妙智。分别我想尚不复转。况当得有分别我爱或资生爱。由是因缘无不活畏。由于他所无所悕望。常自发起如是欲乐。我当饶益一切有情。非于有情有所求觅。由是因缘无恶名畏。由离我见于我无有失坏想转。故无死畏。自知死后于当来世决定值遇诸佛菩萨。由此决定无恶趣畏。由意乐见一切世间。尚无有一与我齐等。何况殊胜。是故无有处众怯畏。菩萨如是远离一切五种怖畏。远离一切闻说甚深正法惊怖。远离一切高慢憍傲。远离一切他不饶益种种邪行所起嗔恚。远离一切世财贪喜。无染污故无所憎背。有炽然故无俗意乐。能圆满证一切善法。又现法中能起菩萨一切精进。信增上力为前导故。于当来世如前所说菩提分品十种大愿。今即于此极欢喜住。能具引发。由得清净胜意乐故。为欲供养最胜有情真实福田大师法主。是故引发第一大愿。为欲受持彼所宣说无上正法。是故引发第二大愿。为欲劝请转未曾有妙正法轮。是故引发第三大愿。为欲顺彼行菩萨行。是故引发第四大愿。为欲成熟彼器有情。是故引发第五大愿。为欲往趣诸佛国土。奉见如来。承事供养听受正法。是故引发第六大愿。为净修治自佛国土。是故引发第七大愿。为于一切在所生处常不远离诸佛菩萨。与诸菩萨常同一味意乐加行。是故引发第八大愿。常为利益一切有情曾不空过。是故引发第九大愿。为证无上正等菩提作诸佛事。是故引发第十大愿。作是愿言。如有情界展转相续终无断尽。亦如世道展转相续终无断尽。我此大愿生生相续乃至究竟菩提边际。常不远离常不忘失常不乖离。如是自誓心发正愿。当知此中前就所应愿事起愿。后即就愿以起于愿。如是菩萨十种大愿以为上首。能生无数百千正愿。如是菩萨于当来世具诸大愿。于现法中发大精进

复有十种净修住法。由是能令极欢喜住速得清净。一者于诸佛法深生净信。二者观诸有情缘起道理。证得唯有纯大苦蕴。发起大悲。三者观见彼已自誓愿言。我当令彼诸有情类解脱如是纯大苦蕴得第一乐。发起大慈。四者为欲救拔一切忧苦自无顾恋。无顾恋故。能舍内外一切身财。于诸有情而行惠施。五者为欲利益诸有情故。从他勤求世出世法。曾无厌倦。六者无厌倦故。证得一切论智清净。善知诸论。七者善知论故。于劣中胜诸有情所。如应如宜而修正行。善解世间。八者即于如是正加行中。依应时分量等正行。而修惭愧。九者即于如是正加行中得无退转。坚力持性。十者以诸上妙利养恭敬及与正行。供养如来。是名十种净修住法。由此能令极欢喜住速得清净。所谓净信。慈悲惠舍。无有厌倦。善知诸论。善解世间。修习惭愧。坚力持性。供养如来

又诸菩萨于此十法。受学随转多修习已。复于余九增上戒等诸菩萨住。从佛菩萨专精访求一切种道功德过失及神通乐无失坏道。善取其行得等流相。于一切住自然升进。证大菩提为大导师。率领一切有情商侣。超度生死旷野崄道。当知此中诸行能入说名为行。若正入时说名为得。入已果利成办圆证说名等流

又诸菩萨住此住中。由二因缘现见诸佛。或由听闻菩萨藏说。或由内心发起胜解。信有十方种种异名诸世界中种种异名诸佛如来。由粗净信俱行之心求欲现见。如是求已如实称遂。当知是名第一因缘。又心发起如是正愿。随于彼彼诸世界中有佛出现。我当往生。如是愿已如实称遂。当知是名第二因缘。菩萨如是由粗净信现见诸佛。由正愿力现见诸佛。既得见已随力随能兴一切种恭敬供养。奉施种种上妙乐具。及于僧众恭敬供养。于如来所听闻正法。无倒受持精进修行法随法行。以四摄事成熟有情。一切善根悉皆回向无上菩提。由是三种清净因缘。彼诸善根倍复明净。谓于佛法僧供养摄受故。以四种摄事成熟有情故。以一切善根回向菩提故。如是乃至无量俱胝那庾多百千大劫。譬如世间黠慧工匠。以矿性金置于火中如如烧炼。如是如是转得明净。如是净胜意乐菩萨所有善根。由是三种清净因缘缘转复明净当知亦尔

又住于此在在生处多作轮王。王赡部洲得大自在。远离一切所有悭垢。威被有情调伏悭吝。诸四摄事所作业中。一切不离佛法僧宝。证一切种菩提。作意恒发愿言。我当一切有情中尊作诸有情一切义利所依止处。若乐发起如是精进。弃舍一切家属财位。归佛圣教净信出家。一刹那顷瞬息须臾能证菩萨百三摩地。以净天眼能于种种诸佛国土见百如来。又即于彼变化住持菩萨住持。皆能解了。以神通力动百世界。身亦能往放大光明周匝遍照。普令他见化为百类成熟百种所化有情。若欲留命能住百劫。于前后际各百劫事智见。能入蕴界处等诸法门中。于百法门能正思择化作百身。身身皆能现百菩萨。眷属围绕。自兹以去是诸菩萨由愿力故。当知无量威力神变。安住如是极欢喜住诸菩萨众。愿力增上能引无量殊胜正愿。所作神变如是正愿。乃至俱胝那庾多百千大劫不易可数

当知是名略说菩萨极欢喜住。谓善决定故。四相发心故。发起精进引发正愿故。净修住法故。开晓余住故。修治善根故。受生故。威力故。若广宣说如十地经极喜地说。彼十地经广所宣说菩萨十地。即是此中菩萨藏摄。摩怛理迦略所宣说菩萨十住。如其次第从极欢喜住乃至最上成满菩萨住。应知此中由能摄持菩萨义故。说名为地。能为受用居处义故。说名为住

瑜伽师地论卷第四十七瑜伽师地论卷第四十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五第二持随法瑜伽处住品第四之二

问增上戒住菩萨转时。当知何行何状何相。答若诸菩萨先于极欢喜住。由十种心意乐。已得意乐清净。何等为十。一者于一切师长尊重福田不行虚诳意乐。二者于同法菩萨忍辱柔和易可共住意乐。三者胜伏一切烦恼及随烦恼众魔事业心自在转意乐。四者于一切行深见过失意乐。五者于大涅槃深见胜利意乐。六者于诸妙善菩提分法常勤修习意乐。七者即于彼修为随顺故乐处远离意乐。八者于诸世间有染尊位利养恭敬无所顾恋意乐。九者远离下乘趣证大乘意乐。十者欲作一切有情一切义利意乐。如是十种无倒意乐依心而转。是故说为意乐清净。即由如是十种意乐。成上品故极圆满故。是诸菩萨入证第二增上戒住。于此住中性戒具足。极少邪恶业道所摄诸恶犯戒。尚不现行。况中上品。又于十种圆满业道。自性显现。菩萨如是性戒具足。能以妙慧于染不染恶趣善趣。及诸乘中诸业现行。若因若果修证安立。如实了知。于异熟果及等流果如是诸业。如实了知。自能现断诸不善业。自能现受一切善业。即于其中乐劝导他能正劝导。于其种种不平等业现行过失之所染污诸有情界。若兴若衰等无差别。一切皆堕第一义苦并住艰辛。种种艰辛之所逼切甚可哀愍。于彼获得广大哀愍如实观照。是诸菩萨安住如是增上戒住。广见诸佛善根清净。如前应知。此差别者。谓如世间善巧工匠。以所炼金置迦肆娑置于火中数数烧炼转更明净。如是菩萨善根清净当知亦尔。于此住中净心意乐成满。趣入在所生处多作轮王王四大洲。以自在力令多有情止息犯戒不善业道。劝彼受行诸善业道。当知威力过前十倍。当知是名略说菩萨增上戒住。谓意乐净故。性戒具足故离一切种毁犯戒垢故。一切业道一切因果了知通达故。于诸净业能自受行。亦乐劝他令其受行故。于有情界诸业所生众苦艰辛得大哀愍。如实观照故。善根清净故。受生故威力故。若广宣说如十地经离垢地说。远离一切犯戒垢故。名离垢地。由离一切犯戒垢故。即此名为增上戒住。彼离垢地当知即此增上戒住

问增上心住菩萨转时。当知何行何状何相。答若诸菩萨先于增上戒住。已得十种清净意乐。作意思惟解了通达。复由余十净心意乐作意思惟。成上品故极圆满故。过增上戒住入增上心住。何等为十。一者作意思惟。我于十种净心意乐已得清净。二者作意思惟。我于十种净心意乐。已清净故能不退失。三者作意思惟。我于一切漏有漏法心不趣入。于违背中能正安住。四者作意思惟。我能于彼修对治中识正安住。五者作意思惟。我能于彼所修对治不复退失。六者作意思惟。我于如是坚固对治。不为一切漏有漏法一切魔军之所胜伏。七者作意思惟。我今能于一切佛法。其心无有怯劣而转。八者作意思惟。我今能于一切苦行无有怯弱。九者作意思惟。我心一向于大乘中深生信解。终不爱乐余下劣乘。十者作意思惟。我于一切利有情事深心爱乐。由此十种净心意乐作意思惟。能入菩萨增上心住。菩萨安住增上心住。能以种种过患行相坏一切行。于彼诸行深心厌离。于佛妙智能以种种胜利行相。见大胜利。又于其中能以淳净一味欲乐。深生爱慕。于有情界能以种种苦恼行相观为有苦。于诸有情兴悲恋心。生依义心于一切行无有放逸。为大菩提炽然精进。于诸有情能起广大悲愍意乐。观诸有情解脱众苦究竟方便。唯是一切烦恼诸缠无障碍智。观彼解脱能圆证者。唯于法界一切分别现行杂染生起对治无分别慧。观能成办彼智光明唯是无倒胜三摩地。观所引发一切静虑等持等至皆菩萨藏。听闻为先皆闻正法以为缘起。观见是已发大精进访求多闻。为闻正法不惜身命。无有资财内外爱物而不能舍。无有师长不誓承事。无有尊教不誓奉行。无有身苦而不誓受。若闻佛法一四句颂。欢喜勇跃胜得三千大千世界充满其中大珍宝聚。闻一句法是佛所说。能引正等觉能净菩萨行。欢喜踊跃胜得一切释梵护世转轮王等极尊贵位。设有告言。善男子听。我有一句佛所说法。能引正等觉能净菩萨行。汝欲闻不。汝今若能投大火坑受大苦者。当为汝说。菩萨闻已欢喜踊跃。答言我能。我若得闻如前所说一句法义。正使火坑量等三千大千世界满中炽火。我从梵天尚投身入。况小火坑。为求佛法尚应久处大那落迦受大苦恼。况余小苦而不应受。菩萨发起如是精进。求正法已复能如实如理思惟。要正修行法随法行。方得名为随顺佛法。非但听闻文字音声而得清净。如是知已即依所闻正缘法相。远离诸欲恶不善法。广说乃至能得世俗四种静虑四无色定。及四无量五种神通。具足安住。既多住已复还弃舍诸静虑等等持等至。愿自在力还来欲界观彼彼处。若为有情能作义利。若能圆满菩提分法。即便往生。非但自在而生彼处。如是菩萨离欲贪故名断欲缚。弃舍静虑等持等至故名断有缚。菩萨先从胜解行地。于法真如修胜解故。已断见缚。邪贪恚痴毕竟不转。广见诸佛善根清净。如前应知。此差别者。谓如世间善巧工匠先所烧炼手中真金垢秽斯尽称量等住。如是菩萨善根清净当知亦尔。受生多分作释天帝。善化有情令离欲贪。所有威力于前住中已说千数。当知此中有百千数。当知是名略说菩萨增上心住。谓心意乐作意思惟成满趣入故。于一切行诸有情界及大菩提。能正通达故。于诸有情脱苦方便。能正推求故。于正法中起大恭敬访求无倦故。能正修行法随法行。于其世俗诸静虑等等持等至无量神通。能引能住故。弃舍于彼愿自在力随乐受生故。善根清净故。受生故。神力故。若广宣说如十地经发光地说。由发闻行。正法光明等持光明之所显示。是故此地名发光地。由内心净能发光明。是故说名增上心住。由此义故名发光地。即由此义当知复名增上心住

云何菩萨觉分相应增上慧住。谓诸菩萨先于增上心住。以求多闻增上力故。已得十法明入。由此十法明入。成上品故极圆满故。超过增上心住入初增上慧住。如是十法明入文词。如契经说。应知其相。谓若彼假设。若于中假设。若由此假设。若平等胜义。若染恼故清净故成染成净。若由系缚烦恼所染。若由无上清净所净。当知是名十法明入略所说义。是诸菩萨住此住中。如契经说。不坏意乐而为上首。所有十种能成熟智。智成熟法。皆悉成就。长如来家得彼体法。观一切种菩提萨埵增上力故。修四念住而为上首。三十七种菩提分法。如契经说。由于此法方便摄受勤修习故。最极微细萨迦耶见执着一切蕴界处等一切动乱。皆得毕竟不现行断。由彼断故一切如来所呵毁业皆不现行。一切如来所赞美业如实随转。既如是已其心转复滋润。柔和有所堪能。其心转复种种行相皆善清净。又善知恩知报恩等随顺意乐种种白法皆悉成就。寻求上地能修治业。发大精进逮得安住。由此因缘所有意乐增上意乐胜解界性皆得圆满。由是因缘一切外道种种魔军圣教怨敌。不能映夺不能倾动。广见诸佛善根清净。广说如前应知其相。此差别者。谓如世间善巧工匠以所炼金作庄严具。非余未作庄严具金之所映夺。如是此中菩萨善根。非余安住凡住菩萨所有善根所能映夺。如末尼宝所放光明。非余宝珠所能映夺。一切世间风水雨等不能断灭。所放光明如是。此中菩萨所有智慧光明。一切声闻及独觉等不能映夺。一切魔怨不能断灭。受生多作苏夜摩天王。善化有情令其除灭萨迦耶见。所有威力。于前住中说百千数。当知此中说俱胝数。当知是名略说菩萨觉分相应增上慧住。谓法明入成满得入故。成就智故。修习菩提分法故。萨迦耶见等一切执着动乱断故。制业开业远离习近故。由是因缘心调柔故。随顺功德皆隆盛故。依所寻求修治地业发大精进故。由是因缘所有意乐增上意乐胜解界性净修治故。由是因缘一切圣教所有怨敌不能映夺及倾动故。善根清净故。受生故。威力故。若广宣说如十地经焰慧地说。于此地中。菩提分法如实智焰。能成正法教慧照明。是故此地名焰慧地。又即彼地此中说名觉分相应增上慧住

云何菩萨诸谛相应增上慧住。谓诸菩萨先于觉分相应增上慧住。已得十种平等清净意乐。由彼平等清净意乐。成上品故极圆满故。超过第一增上慧住证入第二增上慧住。十种平等清净意乐所有文词。如契经说。应知其相。谓无等觉与诸觉等。超过所余诸有情界及以诸法。如其平等当知是名十种平等清净意乐略所说义。如是菩萨住此住中。多分希求智殊胜性。于四圣谛由十行相。如实了知一切文词。如契经说。应知其相。谓依晓悟他依自内智依俱处所。名为此说。依于契经调伏本母。名由此说。依于现在众苦自性。依于未来苦因生性。依于因尽彼尽无生性。依于修习彼断方便性。名如此说。当知是名十种行相四圣谛智所有略义。如是于谛善巧菩萨。于一切行以慧正毁。于有情界增悲意乐。于前后际愚痴有情所有邪行。能正通达。为欲令彼得解脱故。摄受广大福智资粮心发正愿。及即于彼意乐引摄正念慧行而为上首。所有众多殊胜功德皆悉增盛。诸余作意皆悉远离。以其种种成熟方便成熟有情。如契经说。所有种种能益有情世俗书论印算计等工业明处。于是一切皆能引发于诸有情深悲愍故。渐次乃至方便安立妙菩提故。随顺世间言说事故。为欲方便坏贫穷故。为令世间诸界错乱人非人等所起灾患皆息灭故。为施无罪诸戏乐具除彼非法诸戏乐故。诸有希求种种居处资生具者。为少用功皆能施与种种居处资生具故。为欲拔济诸王贼等逼恼事故。为欲开制是处非处诸加行故。为欲安立吉非吉事令取舍故。为正劝奖于现法中令其展转不相谋略。及为宣说当来无倒胜生道故。当知是名能益有情工业明处略所说义。其余一切如前应知。此差别者。谓如世间善巧工匠以所炼金作庄严具。牟裟罗宝莹饰厕钿。所有余金无与等故不能映夺。如是此中菩萨善根。一切声闻及诸独觉余地菩萨不能映夺。又如日月诸宿光明一切风轮不能映夺。然其回转共彼风同。如是此中菩萨妙慧。一切声闻诸独觉等不能映夺。然其所作与世共同。受生多作珊睹史多天王。善化有情令舍一切外道邪法。所有威力当知此说千俱胝数。当知是名略说菩萨诸谛相应增上慧住。谓十平等清净意乐成满得入故。善巧方便观察诸谛渐增长故。毁坏诸行悲愍有情渐增长故。即为是义长养广大福智资粮。心发正愿勤加行故。念慧行等德增长故。无余作意以一切种成熟有情勤加行故。引发世间工巧业故。善根清净故。受生故。威力故。若广宣说如十地经极难胜地。今此地中显示菩萨于诸圣谛决定妙智极难可胜。是故此地名极难胜。即由此义应知此中诸谛相应增上慧住

云何菩萨缘起相应增上慧住。谓诸菩萨先于诸谛相应增上慧住。已得十种法平等性。当知文词如经广说。如是十种法平等性。成上品故极圆满故。超过前住得入此住。谓于一切法。由有胜义自性无相平等性故。言说造作影像无相平等性故。即由此相自然不生平等性故。因亦不生平等性故。自然与因皆不生故。毕竟本寂平等性故。现有体事能取正智。离诸戏论平等性故。远离一切取舍造作平等性故。即此烦恼众苦杂染离系解脱平等性故。分别所执境界自性如幻化等平等性故。无分别智所行自性有无无二平等性故。当知是名此中十种法平等性略分别义。如是菩萨住此住中于诸有情增长悲愍。于大菩提生起猛利欲乐悕求。于诸世间合散生灭。以一切种缘起正观。观察了知。依缘起智能引发空无相无愿三解脱门。由是因缘所有自他作者受者有无等想皆不复转。菩萨如是善于胜义顾念有情。如理通达烦恼系故。缘和合故。有为诸法自性羸劣。离我我所无量过失污染而转。非离一切烦恼系缚众缘和合。是故我今为自防护。应令一切烦恼系缚众缘和合皆悉断坏。为益有情不应永灭一切有为。如是菩萨住此住中智悲随逐。名无著智现前。般若波罗蜜多住现前。由此住故。于一切世间行无染而行。又即此住有猛利忍。于第七地有加行。行边际菩萨忍。当知是彼随顺忍摄。又此无著智现前。般若波罗蜜多住现前。能引能引菩提众缘。于诸世间有为诸行住而不住虽于寂灭见寂静德而亦不住。如是菩萨方便般若智所随逐。能入空三摩地。令十百千上首三摩地门皆现在前。如空三摩地如是。无愿无相三摩地当知亦尔。由此上首三摩地门现在前故。意乐不坏。于一切种诸佛圣教一切外道及诸魔军圣教怨敌。不能引夺。余如前说。此差别者谓如世间善巧工匠以所炼金作庄严具。琉璃宝珠莹饰厕钿。一切余金不能映夺。如是此中菩萨善根清净殊胜。如先所说不能映夺。又如月光于有情身能令悦豫。非四风轮所能断坏。如是此中菩萨慧光。一切有情烦恼郁蒸皆能息灭。一切外道魔军怨敌不能断坏。受生多作妙化天王。善化有情令除一切增上慢等。所有威力当知此中说百千俱胝数。当知是名略说菩萨缘起相应增上慧住。谓十法平等性成满得入故。觉悟缘起生解脱门故。一切邪想不现行故。方便摄受生死故。无著智现前。般若波罗蜜多住现在前故。证得无量三摩地故。证得不坏意乐故。于佛圣教不可引夺故。广见诸佛善根清净故。受生故。威力故。若广宣说如十地经现前地说。由此地中无著智现前般若波罗蜜多住现在前故。名现前地。即由此义当知亦名缘起相应增上慧住

云何菩萨有加行有功用无相住。谓诸菩萨于前第六缘起相应增上慧住。已得十种妙方便慧所引世间不共一切有情而共一切世间进道胜行。即由如是妙方便慧所引不共进道胜行。成上品故极圆满故。超过第六住得入第七住。如是文词。如经广说应知其相。谓依能起世间兴盛摄受福德。依于有情利益安乐增上意乐。依为菩提福德资粮菩提分法后后胜进。依不共声闻。依不共独觉。依有情界。依诸法界。依诸世界依诸如来身语心智。当知是名妙方便慧所引不共进道胜行处所略义。菩萨与彼共相应故。便能通达无量无数如来境界。及为彼起无功用无相无分别无异分别。观无量佛境界。起无间无缺精勤修学一切威仪行住作意。一切分位不远离道。彼于一一心刹那中。十波罗蜜多而为上首。一切菩提分法圆满殊胜。诸余下住则不如是。谓于第一极欢喜住。正以大愿为胜所缘。于第二住。正能除遣毁犯戒垢。于第三住。正愿增长得法光明。于第四住。正趣入道。于第五住。正入一切世间事业。于第六住。正入甚深缘起道理今即于此第七住中。具足发起一切佛法。觉支圆满。此住菩萨加行行圆满所摄故。妙智神通行清净能入第八住故由是菩萨此住无间能入第八极清净住。彼第八住一向清净。此第七住犹名为杂。与清净住为前导故。当言此住名不染污。犹未得故当言此住堕杂染污。今此住中一切贪等上首烦恼皆悉除断。当知此住非有烦恼非离烦恼。一切烦恼不现行故。悕求佛智犹未得故。如是行者。增上意乐已得清净。无量身语意业随转。于诸如来所赞毁业。如前广说。于第五住所引世间工巧业智转得圆满。三千世界共许为师。唯除安住上住菩萨及诸如来意乐加行无与等者。于一切静虑等菩提分法皆能现前。由修行相现在前故。非由安住异熟分位。如第八住此诸菩萨如是方便。能善思择诸三摩地。引发菩萨三摩地上首十百千种三摩地门。由得如是三摩地故。超过一切声闻独觉三摩地境。菩萨如是一切烦恼皆悉远离难可了知。一切分别现行随逐。身语意业皆悉安住。而不舍离寻求胜进勇猛加行。顾念有情。为大菩提速圆满故离一切相。无量身语意业随转。妙善修治。无生法忍之所显发。于此住中由自觉慧境界故。超过一切声闻独觉境界。余六住中但由佛法增上所缘故。超过一切声闻独觉境界。又诸菩萨第六住中所入灭定。今此住中念念能入。然此菩萨甚希奇业不可思议。谓常安住实际住中。而于寂灭能不作证。彼由如是妙方便智之所引发增上力故。能行一切有情不共菩萨妙行。虽与世间相似显现而非彼性。如经广说。此中总义。谓依福业事。摄受种种亲属徒众求生差别。发起胜进三解脱住。信解劣乘方便调伏。受用诸欲求欲差别转。诸外道随他心转。随大众转。余如前说。此差别者。谓如世间善巧工匠以所炼金作庄严具。诸末尼宝莹饰厕钿甚为光丽。余赡部洲一切金宝不能映夺。如是此中菩萨善根转复清净。一切声闻独觉善根。及余下住菩萨善根不能映夺。又如日光多分干竭赡部洲中所有秽湿。余一切光不能映夺。如是此中菩萨慧光。多分干竭一切有情烦恼诸毒。如前所说。诸声闻等所有智光不能映夺。受生多作他化自在天王。于能授与一切声闻独觉现观方便善巧所有威力。当知此说俱胝百千数。当知是名略说菩萨有加行有功用无相住。谓妙方便慧所引世间进道胜行成满得入故。通达如来佛境界起无间无缺勤加行故。一一刹那圆证一切菩提分法故。安立染污不染污故。有加行行圆满摄故。依于意乐清净业转一切世间工巧业等皆圆满故。逮得无量不共一切声闻独觉三摩地故。刹那刹那入灭定故。现行一切有情不共世间行故。善根清净故。受生故。威力故。若广宣说如十地经远行地说。此地菩萨有加行行圆满摄故。名远行地。即由此义当知亦名有加行有功用无相住

云何菩萨无加行无功用无相住。谓诸菩萨于初无相住中。已得十种入一切法第一义智。如经广说。谓依三世如其所应本来无生无起无相。依余因性无成无坏。依第一义毕竟离言诸自性事。言说造作影像自性。由体相故及因性故都无所有。即由如是杂染体性。无流转性无止息性。依此无智邪执为因。于彼离言诸有体事初中后位一切时分。染平等性。依于真如无倒证入无有分别平等性故能除杂染。是名此中略所说义。如是十种入一切法第一义智。成上品故极圆满故。超过第七杂清净住。得入第八纯清净住。住此住中于无生法。证得菩萨第一最胜极清净忍。此复云何。谓诸菩萨由四寻思。于一切法正寻思已。若时获得四如实智。如实了知一切诸法。尔时一切邪分别执皆悉远离。观一切法。于现法中随顺一切杂染无生观。彼先时一切所有邪分别执因所生法。于当来世一切无余永不复生。此四寻思四如实智。广说如前真实义品。此如实智。始从胜解行住。乃至有加行有功用无相住。未极清净。今此住中已极清净。是故说言于无生法证得菩萨第一最胜极清净忍。是诸菩萨得此忍故得甚深住。先于第一无相住中。四种灾患今悉除断。一者除断于无相中有加行有功用事。二者除断于上清净住精勤思慕。三者除断于一切种利有情事有大堪能精勤思慕。四者除断有微细想现在前行。是故此住名极清净。又此菩萨于甚深住极生爱乐。即于如是法门流中。蒙诸如来觉悟劝导授与无量引发门智神通事业。如是蒙佛觉悟劝导。引发无量分身妙智。得十自在。如经广说应知其相。得自在故随所欲住。如意能住随乐安住。静虑解脱等诸心住。如意能住。若暂思惟一切食等诸资生具悉皆成办。一切世间工业明处如其所欲悉能现行。普于一切能感生业。及于一切受生处所。皆随所欲自在往生。随所爱乐一切神通所作事业皆能起作。一切妙愿随其所欲皆得称遂。随于事物发起胜解。如所欲为皆成无异。随所欲知所知境界皆如实知。普于一切名句文身得随所欲。于一切法正安立中皆得善巧。如是菩萨获得自在。从是已去所得自在所作胜利。广说如经。应知其相。又能弃舍粗见诸佛。恒常无间不离见佛。其余所有善根清净金喻光喻。如经应知。此住菩萨受生威力诸殊胜事。皆如经说。应知其相。当知是名略说菩萨无加行无功用无相住。谓入一切法第一义智成满得入故。得无生法忍故。除断一切灾患故。逮得菩萨甚深住故。于法门流蒙佛授与无量引发门智神通事业故。悟入无量分身智故。得自在故。领受所得自在胜利故。善根清净故。受生故。威力故。若广宣说如十地经不动地说。于此地中舍先所有有加行有功用道。其心升上无加行无功用。任运而转不动胜道。是故此地名不动地。即由此义当知说名无加行无功用无相住

云何菩萨无碍解住。谓诸菩萨于甚深住不生喜足。复于增上智殊胜性爱乐随入。是诸菩萨于诸法中起智加行。应为他说一切种法。普于一切说法所作皆如实知。当知此中说法所作。谓于一切近稠林行。如此杂染如此清净。由此杂染由此清净。若所杂染若所清净。若非一向若是一向若通二种。如是一切皆如实知。如是菩萨于说法中方便善巧。于说所作方便善巧。于一切种成大法师。获得无量陀罗尼门。于一切种音词。支具剖析。善巧辩才无尽。成就如是法陀罗尼。领受堪能。菩萨由此胜无碍解引发言词。能坐如是微妙法座。若于是中若于是处。宣说正法尽所有门。若由此故于诸有情劝导慰喻安处事业。此等堪能皆悉成就。如是一切广说如经应知其相。善根清净受生威力诸殊胜事。亦广如经应知其相。当知是名略说菩萨无碍解住。谓于甚深寂静解脱不生喜足。入胜进故。于诸法中起智加行。宣说法故。此所作事如实知故。得不思议。大法师故。善根清净故。受生故。威力故。若广宣说如十地经善慧地说。由此地中一切有情利益安乐意乐清净。逮得菩萨无碍解慧。由此善能宣说正法。是故此地名善慧地。即由此义当知复名无碍解住

云何菩萨最上成满菩萨住。谓诸菩萨无碍解住。一切行相遍清净已。堪为法王受法灌顶。得离垢等无量无数胜三摩地。作彼所作一切智智。殊胜灌顶后三摩地现在前故。得一切佛相称妙座身诸眷属。得大光明往来普照。一切行相一切智智。灌洒其顶。既灌顶已。普能引导所化有情。于彼解脱方便佛事。得如实智。逮得无量无边解脱陀罗尼门。大神通力。及此增上大念大智。增上引发训词安立。及大神通。增上引发善根清净。受生威力。诸殊胜事。一切如经应知其相。当知是名略说最上成满菩萨住。若广宣说如十地经法云地说。是诸菩萨住此地中。诸菩萨道皆得圆满。菩提资粮极善周备。从诸如来大法云所。堪能领受其余一切有情之类难可领受最极广大微妙法雨。又此菩萨自如大云未现等觉无上菩提。若现等觉无上菩提。能为无量无边有情。等雨无比微妙法雨。殄息一切烦恼尘埃。能令种种善根稼穑生长成熟。是故此地名法云地。即由此义当知复名最上成满菩萨住

如是所说后后住中支分功德。非前前住一切都无。然下品故不堕其数。当知即彼展转修习成中上品。于余后地证得成满。方乃建立。又即于此一一住中。经多俱胝百千大劫。或过是数方乃证得及与成满。然一切住总经于二无数大劫方得圆证。谓经第一无数大劫。方乃超过胜解行住。次第证得极欢喜住。此就恒常勇猛精进。非不勇猛勤精进者。复经第二无数大劫。方乃超过极欢喜住。乃至有加行有功用无相住。次第证得无加行无功用无相住。此即决定以是菩萨得净意乐。决定勇猛勤精进故。复经第三无数大劫。方乃超过无加行无功用无相住及无碍解住。证得最上成满菩萨住

当知此中略有二种无数大劫。一者日夜月半月等算数方便。时无量故。亦说名为无数大劫。二者大劫算数方便。超过一切算数之量。亦说名为无数大劫。若就前说无数大劫。要由无量无数大劫。方证无上正等菩提。若就后说无数大劫。但经于三无数大劫。便证无上正等菩提。不过此量。若正修行最上上品勇猛精进。或有能转众多中劫。或有乃至转多大劫。当知决定无有能转无数大劫。又由如是所说十二诸菩萨住。经三无数大劫时量。能断一切烦恼障品所有粗重。及断一切所知障品所有粗重。于三住中当知能断烦恼障品所有粗重。谓于极欢喜住中。一切恶趣诸烦恼品所有粗重皆悉永断。一切上中诸烦恼品皆不现行。于无加行无功用无相住中。一切能障一向清净无生法忍诸烦恼品所有粗重皆悉永断。一切烦恼皆不现前。于最上成满菩萨住中。当知一切烦恼习气随眠障碍皆悉永断入如来住。当知一切所知障品所有粗重亦有三种。一者在皮粗重。二者在肤粗重。三者在肉粗重。当知此中在皮粗重。极欢喜住皆悉已断。在肤粗重。无加行无功用无相住皆悉已断。在肉粗重。如来住中皆悉已断。得一切障极清净智。于三住中烦恼所知二障永断。所余诸住如其次第。修断资粮。

即于如是十三住中。当知略有十一清净。谓于第一种性住中。种性清净。于其第二胜解行住。信胜解净。于其第三极欢喜住。胜意乐净。于其第四增上戒住。增上戒净。于其第五增上心住。增上心净。于其第六第七第八增上慧住。无颠倒智发起清净。于其第九有加行有功用无相住。有加行行圆满清净。于其第十无加行无功用无相住。真智神通引发清净。于第十一无碍解住。能正为他宣说法义无碍解净。于第十二最上成满菩萨住中。入一切种一切所知妙智清净。于第十三如来住中。一切烦恼及所知障并诸习气究竟清净如前菩萨功德品中所说八法能摄大乘。当知在此十三住摄。谓于第一第二住中。于菩萨藏生信胜解听受思惟。第三住中。得胜意乐趣向前行胜修行相。于余一切乃至有加行有功用无相住中。得修广大。于上三种净行所摄。菩萨住中修果成满。如来住中当知获得究竟出离。当知菩萨十二种住。随其次第类声闻住。如诸声闻自种性住。当知菩萨初住亦尔。如诸声闻趣入正性离生加行住。当知菩萨第二住亦尔。如诸声闻已入正性离生住。当知菩萨第三住亦尔。如诸声闻已得证净圣所爱味为尽上漏增上戒学住。当知菩萨第四住亦尔。如诸声闻依增上戒学引发增上心学住。当知菩萨第五住亦尔。如诸声闻如其所得诸圣谛智增上慧学住。当知菩萨第六第七第八住亦尔。如诸声闻善观察所知无相三摩地加行住。当知菩萨第九住亦尔。如诸声闻成满无相住。当知菩萨第十住亦尔。如诸声闻从此出已入解脱处住。当知菩萨第十一住亦尔。如诸声闻具一切相阿罗汉住。当知菩萨第十二住亦尔

    本地分中菩萨地第十五第三持究竟瑜伽处生品第一

诸菩萨生略有五种摄一切生。于一切住一切菩萨受无罪生。利益安乐一切有情。何等为五。一者除灾生。二者随类生。三者大势生。四者增上生。五者最后生

云何菩萨除灾生。谓诸菩萨或大愿力或自在力。于诸饥馑厄难旷野正现前时。为令众生少用功力而得存济。于大鱼等种类中生。身形广大随所生处。以自身肉普给一切饥饿众生。皆令饱满。于诸有情众多疾疫正现前时。以大愿力得自在力。持有神验诸明咒力摄受广大良药王身。息除一切有情疾疫。于诸有情邻国战诤互相逼恼正现前时。以大愿力得自在力。作大地主具大势力。以法正治方便善巧。息除邻国战诤逼恼。于诸有情互相违诤正现前时。以大愿力得自在力。发诚信言往返和好除其怨结。于诸众生遭遇恶王非理缚录治罚逼迫身心扰乱正现前时。以大愿力得自在力。生彼王家作如法王。哀愍众生息除一切逼恼苦事。若诸有情起诸邪见造诸恶行。随一天处深生信解。哀愍彼故以大愿力得自在力。生彼天处方便断除邪见恶行。是名略说菩萨除灾生。若广宣说。以大愿力得自在力哀愍为先。于彼彼处受种种生当知无量

云何菩萨随类生。谓诸菩萨以大愿力得自在力。生于种种傍生趣类天龙药叉阿素洛等展转谋害违诤类中。或生邪见婆罗门中。或生乐行恶行类中。或生喜乐邪命类中。或生最极耽着诸欲信解诸欲有情类中。为欲除彼诸过失故。往彼有情同分中生而为上首。为上首已方便化导彼所行恶。菩萨不行彼不行善。菩萨现行为欲令彼现行善故。为说正法。由是菩萨与彼现行不同分故说正法故。方便善巧除彼有情所有过失。是名略说菩萨随类生。广说如前。当知无量

云何菩萨大势生。谓诸菩萨禀性生时。所感寿量形色族姓自在富等。诸异熟果。一切世间最为殊胜。此异熟果所作事业。自他利品已广宣说。是名略说菩萨大势生。若广宣说。彼彼类中受大势生当知无量

云何菩萨增上生。谓诸菩萨始从第一极欢喜住。乃至第十最上成满诸菩萨住。如前所说差别受生。今于此中名增上生。谓最初住作转轮王。王赡部洲得大自在。乃至第十最上成满诸菩萨住。作大自在。过色究竟一切生处最为殊胜。唯有已得最上成满诸菩萨住摩诃萨众得生其中。彼诸菩萨即由此业增上所感。是名略说菩萨增上生。若广宣说当知无量。

云何菩萨最后生。谓诸菩萨于此生中。菩提资粮已极圆满。或生婆罗门大国师家。或生刹帝利大国王家。能现等觉阿耨多罗三藐三菩提。广作一切佛所作事。是名略说菩萨最后生。若广宣说。当知无量

若诸菩萨于去来今清净仁贤妙善生处。曾当现生一切皆此五生所摄。除此无有若过若增。唯除凡地菩萨受生。何以故。此中意取有智菩萨诸所受生为五生故。如是诸生大菩提果之所依止。令诸菩萨疾证无上正等菩提

    本地分中菩萨地第十五第三持究竟瑜伽处摄受品第二

于一切住菩萨行中。当知菩萨略有六种。于诸有情无倒摄受。何等为六。一者顿普摄受。二者增上摄受。三者摄取摄受。四者长时摄受。五者短时摄受。六者最后摄受

云何菩萨于诸有情顿普摄受。谓诸菩萨初发心时。摄受一切诸有情界皆为眷属。作是思惟。我当于彼随能随力作一切种利益安乐饶益之事。随所思惟皆如是作。是名菩萨于诸有情顿普摄受

云何菩萨于诸有情增上摄受。谓诸菩萨或为家主摄受父母妻子奴婢僮仆作使。或为国王摄受一切所统僚庶。菩萨如是发起增上摄受想已。于所摄受随摄受仪。随菩萨仪业用而转。若为家主于其父母。种种方便劝修诸善。随时供养曾无懈废。善识其恩善知酬报。于父母心善能随顺。于法于义随自在转。于其妻子奴婢等类。随时恣与如法衣食。于诸事业终不逼切。虽有违犯而能堪忍。彼若疾病正能瞻疗。于诸善事劝令修习。随时赐与殊胜财物。爱语慰喻不生奴婢作使等想。瞻敬养育。其若自身若为国王。不行黜罚不用刀杖。而能正化。以法以财用作饶益。依本土田而自食用。不以凶力侵掠他境。随能随力于诸有情。劝止诸恶教修诸善。视诸众生如父于子。于他有情尚好等施。况自亲属而不均济。不行欺诳所言诚谛。远离一切杀缚捶打治罚逼迫断截等事。是名菩萨于诸有情增上摄受

云何菩萨于诸有情摄取摄受。谓诸菩萨正御徒众。当知是名略说菩萨于诸有情摄取摄受。若广说者。由二因缘正摄徒众。说名菩萨于诸有情摄取摄受。何等为二。一者以无染心正摄徒众。二者于自义利正教修习。非邪加行而陷逗之。又于一切应摄受中。其心平等不堕偏党。亦不于彼悭吝正法。不作师卷。不于彼所悕求承事恭敬供养。彼乐善故自求作者亦不遮止。为欲令其福德资粮得增长故。或遇余时亦于彼所承事供养。若于其义未解了者开悟令解。已解了者转令明净。生起疑惑随为除断。若生恶作善为开解。甚深义句以慧通达。于时时间正为开显。于苦于乐与彼共同。于他所为财利因缘。成就上品经营遽务过于自事。于他毁犯随时正举令其觉悟。应时如理诃责摈罚。彼有疹疾或有愁忧终不弃舍。善权方便救疗疹疾开解愁忧。于诸下劣形色。忆念精进智等。终不轻陵。于时时间随入劳倦。如其所宜为说正法。于时时间为令系念。于所缘境与正教授。堪忍问难不生愤发。于彼戒行或等或增终无减劣。亦不悕求利养恭敬。具足悲愍无掉无动。戒见轨则正命圆满。舒颜平视远离颦蹙。柔和美语先言问讯含笑为先。于诸善品恒常修习。不行放逸离诸懈怠。即以是事教习徒众。亦令自行转更胜进。菩萨不应于一切时摄取徒众。亦非不摄亦非变异。是名菩萨于诸有情摄取摄受

云何菩萨于诸有情长时摄受。谓诸菩萨于住下品成熟有情摄受饶益。当知说名长时摄受。以经久时方堪净故

云何菩萨于诸有情短时摄受。谓诸菩萨于住中品成熟有情摄受饶益。当知说名短时摄受。非经久时方堪净故

云何菩萨于诸有情最后摄受。谓诸菩萨于住上品成熟有情摄受饶益。当知说名最后摄受。即于此生堪任净故

是名菩萨于诸有情略有六种无倒摄受。由此摄受。过去未来现在菩萨。于诸有情曾正摄受当正摄受现正摄受。除此无有若过若增

菩萨如是于诸有情六种摄受无倒转时。当知遭遇略十二种艰难之事。聪睿菩萨于彼十二艰难之事当正觉了。何等十二。一者于多安住违犯有情。若罚若舍。是名菩萨遭艰难事。二者于恶有情为调伏故。方便现行辛楚加行。防自意乐不生烦恼。是名菩萨遭艰难事。三者现可施物极为鲜少。现来求者其数弥多。是名菩萨遭艰难事。四者唯有一身。众多有情种种事业并现在前。同时来请共为助伴。是名菩萨遭艰难事。五者居放逸处。若住世间可爱妙定。若生天上乐世界中。令心调善。是名菩萨遭艰难事。六者常求遍作利有情事。而于此事无力无能。是名菩萨遭艰难事。七者于其愚痴谄诈刚强诸有情所。若为说法若复弃舍。是名菩萨遭艰难事。八者常于生死见大过失。为度有情而不弃舍。是名菩萨遭艰难事。九者未证清净增上意乐。多分虑恐失念命终。是名菩萨遭艰难事。十者未证清净增上意乐。他来求乞第一最胜所可爱物。是名菩萨遭艰难事。十一者种种异见种种胜解诸有情类。若别教诲若总弃舍。是名菩萨遭艰难事。十二者常行最极不放逸行。而不应断一切烦恼。是名菩萨遭艰难事。

若诸菩萨遭遇如是诸艰难事。或于其中应观轻重。如其所应而作方便。或于其中应审简择补特伽罗。或于其中攀缘。勇猛摄受因转。若发正愿。或于其中制御其心不令流散。或于其中安住其心。猛利思择不生厌倦而自安忍。或于其中而行放舍。或于其中发勤精进炽然无懈。或于其中善巧方便而正修行。菩萨如是于正对治方便善巧。虽遭一切诸艰难事正现在前。而无怯弱自正能免

瑜伽师地论卷第四十八瑜伽师地论卷第四十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五第三持究竟瑜伽处地品第三

如前所说十三住中。应知随彼建立七地前之六种唯菩萨地。第七一种菩萨。如来。杂立为地。何等为七。一种性地。二胜解行地。三净胜意乐地四行正行地。五决定地。六决定行地。七到究竟地。如是七种菩萨地中。最后一种名为杂地。前种姓住名种性地。胜解行住名胜解行地。极欢喜住名净胜意乐地。增上戒住。增上心住。三种增上慧住。有加行有功用无相住。名行正行地。无加行无功用无相住名决定地。此地菩萨堕在第三决定中。故无碍解住名决定行地。最上成满菩萨住。及如来住。名到究竟地。如来住地于后建立佛法品中。当广演说。

问菩萨从胜解行地。随入净胜意乐地时。云何超过诸恶趣等。答是诸菩萨依止世间清净静虑。于胜解行地已善积集菩提资粮。于如前说百一十苦诸有情类。修习哀愍无余思惟。由此修习为因缘故。于彼色类诸有情所。得哀愍意乐及悲意乐。由是因缘为利恶趣诸有情故。誓居恶趣如己舍宅。作是誓言。我若唯住如是处所。能证无上正等菩提。亦能忍受。为除一切有情苦故。一切有情诸恶趣业。以净意乐。悉愿自身代彼领受苦异熟果。为令毕竟一切恶业永不现行一切善业常现行故心发正愿。彼由修习如是世间清净静虑悲愿力故。一切恶趣诸烦恼品所有粗重。于自所依皆得除遣。由此断故菩萨不久获得转依。于诸恶趣所有恶业毕竟不作。于诸恶趣决定不往。齐此菩萨说名超过一切恶趣。亦名超过胜解行地。亦名已入净胜意乐地

如前住品所说信等。能净修治诸住十法。今于此中当知亦能净修治地。如是十法所有安立。所治能治略义次第皆应了知。

谓彼十种净修地法能对治。彼所对治法故得安立。何等为十。谓一切种全未发心。全未受持菩萨学处。是名为信所对治法。对治彼故安立于信。于诸有情有损害心。是名为悲所对治法。对治彼故安立于悲。于诸有情。有嗔恚心。是名为慈所对治法。对治彼故安立于慈。于身命财有所顾恋。是名为舍所对治法。对治彼故安立于舍。于诸有情悕求报恩。见彼邪行贪着利养多有所作。是无厌倦所对治法。对治彼故安立无倦。无有方便善巧加行。是善知论所对治法。对治彼故立善知论。性不柔和。不于他心随顺而转。是名善知一切世间所对治法。对治彼故安立善知一切世间。于修善法放逸懈怠。是名惭愧所对治法。对治彼故安立惭愧。于其长时种种猛利无间无断生死大苦。深生怯弱。当知是名坚力持性所对治法。对治彼故所以安立坚力持性。于大师所犹豫疑惑。当知是名供养如来所对治法。对治彼故所以安立供养如来如是且说所治能治安立十法。

云何复名如是略义。谓此十法略显二义。一者显示意乐清净。二者显示加行清净。当知前三显示菩萨意乐清净。其余七种显示菩萨加行清净。

如是十法次第云何。谓诸菩萨于大菩提先深净信。次于有苦诸有情类发起悲愍。起悲愍时如是誓愿。我应拔济一切有情令其安乐。而起慈心。起慈心已一切能舍于身命财。无所顾恋。无顾恋已即为彼义精勤加行无有厌倦。无厌倦已善知诸论。善知论已如世间转。即如是知知世间已。若自烦恼率尔现行深生惭愧。生惭愧已不随烦恼自在而行。便能获得坚力持性。由正获得坚力持性。于正加行能无退转。无量善法运运增长。能于如来奉献上妙正行供养财敬供养。是故最后供养如来。是名十法次第修证。当知如是十种善法。于一切地能净修治

    本地分中菩萨地第十五第三持究竟瑜伽处行品第四

菩萨始从胜解行地。乃至最后到究竟地。于此一切菩萨地中。当知略有四菩萨行。何等为四。一者波罗蜜多行。二者菩提分法行。三者神通行。四者成熟有情行。

前说六种波罗蜜多。及方便善巧波罗蜜多。愿波罗蜜多。力波罗蜜多。智波罗蜜多。如是十种波罗蜜多。总名波罗蜜多行。如前所说十二行相方便善巧。当知说名方便善巧波罗蜜多。如前所说五种大愿。当知名愿波罗蜜多。所有十力加行清净。当知名力波罗蜜多。于一切法如实安立清净妙智。当知名智波罗蜜多。今于此中能取胜义。无分别转清净妙慧。当知名慧波罗蜜多。能取世俗有分别转清净妙智。当知名智波罗蜜多。如是名为二种差别。复有异门。谓无量智。当知说名方便善巧波罗蜜多。悕求后后智殊胜性。当知名愿波罗蜜多。一切魔怨不坏道性。当知名力波罗蜜多。如实觉了所知境性。

当知名智波罗蜜多。四念住等所有一切三十七种菩提分法。四种寻思四如实智。皆如前说。总名菩萨菩提分法行。

如前所说威力品中菩萨所有六种神通。是名神通行。

如前所说二种无量。一所调伏界无量。二调伏方便界无量。及成熟品中所说。一切成熟有情。总名菩萨成熟有情行。如是四种菩萨妙行。当知普摄一切菩萨所行善行

应知此中施等十法。经三大劫阿僧企耶。长时修习乃圆证。故自性清净体殊胜。故过余一切世间声闻独觉善根。摄受最胜菩提果。故如是十法最极长时乃能圆证。自性最极清净殊胜。能得最极菩提妙果。是故说名波罗蜜多

应知如是波罗蜜多。由三因缘次第建立。何等为三。一由对治故。二由生起故。三由异熟果故。云何如是波罗蜜多由对治故次第建立。谓悭恶行。于诸有情怨恨逼恼懈怠散乱闇钝愚痴。如是六法能障菩提。施等六法能为对治。如其所应建立六种波罗蜜多。当知所余波罗蜜多即此所摄。如是名为由对治故次第建立。云何如是波罗蜜多由生起故次第建立。谓诸菩萨先于财位无所顾恋。弃家诸欲受净尸罗。敬重戒故能忍他恼不恼于他。受持净戒修习忍已。戒净无动无间无断。于诸善品勤修加行。如是修习勤精进故离诸放逸。能触妙善心一境性。心得定故如实了知。观见一切所知境界。当知是名由生起故次第建立。云何如是波罗蜜多由异熟果次第建立。谓诸菩萨于现法中精勤修学施等善法。由是因缘于当来世。获得种种外妙珍财无不圆满。当知是施波罗蜜多因力所作。获得内五自体圆满。是余戒等波罗蜜多因力所作。云何内五自体圆满。谓善趣摄若天若人。于余有情寿等殊胜。当知是名第一圆满。若有俱生。于善加行常无厌倦。堪忍他恼不乐恼他。当知是名第二圆满。若有俱生。普于一切所作事业坚固勇猛。当知是名第三圆满。若有俱生。性薄尘秽于其自心能自在转。心有堪能于一切义速证通慧。当知是名第四圆满。若有俱生。于一切义其慧广大聪敏捷利。当知是名第五圆满。应知是名由异熟果如是六种波罗蜜多次第建立。

由前四种波罗蜜多资粮自性眷属守护。当知圆满修诸菩萨增上戒学。由其静虑波罗蜜多。当知圆满修诸菩萨增上心学。由其般若波罗蜜多。当知圆满修诸菩萨增上慧学。过此三上更无菩萨学道可得。是故此三普摄一切菩萨学道。由此建立波罗蜜多。唯有六种。除此无有若过若增

又诸菩萨略有四种所应作事。由是普摄一切所作。何等为四。一者为证菩提修诸善行。二者由此为先达真实义。三者圆证威力。四者成熟有情。如是四种菩萨所作。当知是先所说四行。如其次第所为所立。是故过此更不建立有诸余行

    本地分中菩萨地第十五第三持究竟瑜伽处建立品第五之一

依如来住。及依如来到究竟地。诸佛世尊有百四十不共佛法。谓诸如来三十二大丈夫相。八十随好。四一切种清净。十力。四无所畏。三念住。三不护。大悲无忘失法。永害习气。及一切种妙智。

云何如来三十二种大丈夫相。一者具大丈夫足善安住等案地相。是大丈夫大丈夫相。二者于双足下现千辐轮。毂辋众相无不圆满。三者具大丈夫纤长指相。四者足跟趺长。五者手足细软。六者手足网缦。七者立手摩膝。八者瑿泥耶踹。九者身不偻曲。十者势峰藏密。十一者身相圆满如诺瞿陀。十二者常光一寻。十三者身毛上靡。十四者身诸毛孔一一毛生。如绀青色螺文右旋。十五者身皮金色。十六者身皮细滑尘垢不着。十七者于其身上两手两足两肩及项七处皆满。十八者其身上半如师子王。十九者肩善圆满。二十者髆间充实。二十一者身分洪直。二十二者具四十齿皆悉齐平。二十三者其齿无隙。二十四者其齿鲜白。二十五者颔如师子。二十六者其舌广薄。若从口出普覆面轮及发边际。二十七者于诸味中得最上味。二十八者得大梵音。言词哀雅能悦众意。譬若羯罗频迦之音。其声雷震犹如天鼓。二十九者其目绀青。三十者睫如牛王。三十一者其顶上现乌瑟腻沙。三十二者眉间毫相其色光白螺文右旋。是大丈夫大丈夫相

云何如来八十随好。谓两手足具二十指及以节爪。并皆殊妙。是即名为二十随好。两手两足表里八处。手四足四并皆殊妙。是即名为八种随好。两踝膝股六处殊妙。是即名为六种随好。两臂肘腕六处殊妙。是即名为六种随好。腰缝殊妙各一随好。两核殊妙为二随好。阴藏殊妙为一随好。两臀殊妙为二随好。臗胪脐三并皆殊妙各一随好。两胁腋乳并皆殊妙为六随好。腹胸项脊各一随好。如是所说。除颈已上。于下身分六十随好。上下齿鬘并皆殊妙为二随好。[齒*(虎-儿+丘)]齶殊妙为一随好。两唇眷属并皆殊妙为二随好。颐善圆满为一随好。两颊圆满善安其所为二随好。两目眷属并皆殊妙为二随好。两眉殊妙为二随好。其鼻二孔并皆殊妙为二随好。其额殊妙为一随好。角鬓两耳并皆殊妙为四随好。头发殊妙为一随好。如是所说。从颈已上二十随好。前有六十后有二十。总合说为八十随好。如是诸相及诸随好。若诸菩萨始入净胜意乐地时已得异熟。从此已上诸相随好展转获得殊胜清净。当知乃至坐菩提座。方乃证得其余所有四一切种妙清净等不共佛法。善净圆满。若下劣者先菩萨时亦已成就。始从清净胜意乐地。一切所有菩提资粮无有差别。能感一切相及随好。又此一切菩提资粮略有二种。谓去菩提若远若近。此中远者。谓未获得诸相随好异熟果时。所言近者。谓初获得诸相随好异熟果时。或从此上展转获得殊胜清净

又薄伽梵由所化力。为众宣说造种种业感得如是相随好果。何以故。所化有情于其种种恶业现行深生喜乐。如是种种现行恶业是所对治。感相随好种种善业是能对治。彼闻如是种种殊胜大果胜利。便于如是大果胜利深生爱乐。由是因缘当离诸恶。当修诸善。是故为说广如诸相素呾缆说。谓诸菩萨于戒禁忍及惠舍中善安住故。感得足下善安住相。于其父母种种供养。于诸有情诸苦恼事种种救护。由往来等动转业故。感得足下千辐轮相。于他有情远离损害及不与取。于诸尊长先语省问。恭敬礼拜合掌起迎修和敬业。于他有情深心所喜所爱财位不令乏短。及能摧伏自憍慢故。感大丈夫纤长指相。即上所说感三相业。总能感得足跟趺长。是前三相所依止故。由四摄事摄诸尊长。是故感得手足网缦。奉施尊长涂身按摩沐浴衣服。是故感得手足细软。修诸善法不生喜足。令诸善法展转增长。是故感得立手摩膝。自于正法如实摄受令得究竟。广为他说及正为他善作给使。是故感得瑿泥耶[跳-兆+專]。于其正法渐次等显。续索转故。于身语意种种恶业皆能止息。于疾病者卑屈瞻侍给施良药。病力羸顿能正策举。饮食知量于诸欲中曾不低下。是故感得身不偻曲。于被他摈无依有情。以法以正慈悲摄受。修习惭愧施他衣服。是故感得势峰藏密。于身语意能自防禁。于自摄受及诸饮食皆善知量。施病医药于不平等事业摄受。及不平等所受用中皆不随转。于界互违能令随顺。是故感得身相圆满如诺瞿陀由业感得立手摩膝。即能感得身毛上分。自善观察亲近明智能思微义。尊所居处能净修治敷举沐浴。唯一住故依一支故入微义故。草叶等秽能蠲除故。又能除去客尘垢故。感身毛孔一一毛生如绀青色螺文右旋。能施悦意发喜饮食骑乘衣服庄严具等资身什物。离诸忿恚。是故感得身皮金色常光一寻。由此业感身诸毛孔一一毛生。当知即此复能感得身皮细滑尘垢不着。以其广多上妙清净肴馔饮食。惠施大众皆令充足。由此感得于其身上七处皆满。于诸有情随所生起。如法所作能为上首而作助伴。离于我慢无诸犷悷。能为有情遮止无利安立有利。由此感得其身上半如师子王。于一切事禀性勇决如师子故。即由此业当知复感肩善圆满髆间充实。由此业感纤长指相。复即感得身分洪直。远离一切破坏亲友离间语言。若诸有情已乖离者能令和合。由此感得具四十齿皆悉齐平其齿无隙。修欲界慈思惟法义。由此感得其齿鲜白。若诸有情有所悕冀。随其所乐正舍珍财。由此感得颔如师子。视诸有情犹如己子。爱念救护净信哀愍。给施医药澄净无秽。由此感得于诸味中得最上味。施法味故尝法味故。能净修治变坏味故。于离杀等五种学处能自受护。亦劝他受修悲心故。于大法受能正行故。由此感得其顶上现乌瑟腻沙其舌广薄普覆面轮。常修谛语爱语时语及以法语。由是因缘得大梵音言词哀雅能悦众意譬若羯罗频迦之音其声雷震犹如天鼓。普于世间恒常修习慈心悲哀如父如母。由此感得其目绀青睫如牛王。于有德者如实赞叹称扬其美。由此感得眉间毫相其色光白螺文右旋。如是一切三十二种大丈夫相无有差别。当知皆用净戒为因而能感得。何以故。若诸菩萨毁犯净戒。尚不能得下贱人身。何况能感大丈夫相。当知此中其顶上现乌瑟腻沙。及以如来无见顶相。合立一种大丈夫相。离此更无别可得故。如是且说能感相似三十二相种种业因。广建立已

复次略说在家出家二分菩萨所有四种善修事业。当知能感一切相好。谓于此中决定修作。能感足下善安住相委悉修作。能感足下千辐轮相。立手摩膝。手足网缦。身皮细滑。于其身上七处皆满。肩善圆满膞间充实。身分洪直。其舌广薄。恒常修作感纤长指。足跟趺长。身不偻曲。其身圆满如诺瞿陀。其齿无隙。无罪修作。能感余相。当知此中于诸有情无损加行。由此能感手足细软身皮细滑。于诸善中次第加行。应时加行。由此感得瑿泥耶[跳-兆+專]。深生欢喜极光净心现行诸善。由此感得常光一寻身皮金色其齿鲜白眉间白毫。不依称誉声颂修善覆藏己德。由此能感势峰藏密。所修善根回向菩提。由此感得身毛上靡具四十齿皆悉齐平于诸味中得最上味其顶上现乌瑟腻沙。修善无厌无劣加行。由此感得其身上分如师子王颔如师子。于诸有情以利益心平等瞻视。得齿齐平目绀青色睫如牛王。于下劣善不生喜足起胜加行由此因缘得大梵音言词哀雅能悦众意。譬若羯罗频迦之音其声雷震犹如天鼓。如是四种善修事业。能得菩萨三十二种大丈夫相殊胜清净

当知如是三十二种大丈夫相八十随好。菩萨若在种性地中。唯有种子依身而住。菩萨若在胜解行地。始能修彼能得方便。菩萨若在清净增上意乐地中。乃名为得。菩萨若在诸余上地。如是相好转胜清净。若在如来到究竟地。当知相好善净无上

如是诸相是有色故劣中胜品。诸有情类易了知故。虽有一切不共佛法皆得名为大丈夫相。唯立此为大丈夫相。又即如是三十二种大丈夫相。由所依性能任持故。由极殊妙令端严故。说名随好

又于此中以要言之。一切有情福聚量等。尔所福聚能感如来一毛孔处。乃至一切所有毛孔随入福聚。尔所福聚能感如来一种随好。乃至一切所有随好随入福聚增至百倍。尔所福聚能感如来相中一相。乃至一切所有诸相随入福聚。除白毫相乌瑟腻沙。增至千倍。尔所福聚能感如来眉间白毫。乃至白毫随入福聚。增至百千倍。尔所福聚能感如来其顶上现乌瑟腻沙无见顶相。乃至白毫随入福聚。增至俱胝百千倍数。尔所福聚能感如来诸相随好所不摄余大法螺相。由此法螺随如来欲发大音声。普能遍告无边无际诸世界中所化有情。如是无量福德资粮修证圆满。能感如来不可思议无上无等遍一切种最极圆满所摄自体。又此能感诸相随好无量善业。当知略由三因缘故说名无量。谓经于三无数大劫。无间修习乃圆证。故名时无量。于诸有情无量利益安乐意乐增上缘力所集成故。名为妙善意乐无量。无量善业差别品类所集成故。名品无量。故言无量福德资粮修习圆证能起如来诸相随好。

云何如来四一切种清净。一者一切种所依清净。二者一切种所缘清净。三者一切种心清净。四者一切种智清净。云何一切种所依清净。谓一切烦恼品粗重并诸习气。于自所依无余永灭。又于自体如自所欲。取住舍中自在而转。是名一切种所依清净。云何一切种所缘清净。谓于种种若化若变若所显现一切所缘皆自在转。是名一切种所缘清净。云何一切种心清净。谓如前说一切心粗重永灭离故。又于心中一切种善根皆积集故。是名一切种心清净。云何一切种智清净。谓如前说一切无明品粗重永灭离故。又遍一切所知境中。智无障碍智自在转。是名一切种智清净

云何如来十力。一者处非处智力。二者自业智力。三者静虑解脱等持等至智力。四者根胜劣智力。五者种种胜解智力。六者种种界智力。七者遍趣行智力。八者宿住随念智力。九者死生智力。十者漏尽智力。如是十种如来智力。当知广如十力经说

当知此中诸有所言所说所宣。一切如实皆无虚妄故名如来。净不净果非不平等。如实转因。是名为处。亦名建立。亦名为依亦名为起。净不净果不平等因。与上相违是名非处。远离一切增上慢智说名如实。若一切智若无滞智若清净智。当知说名远离一切增上慢智。如是一切智等诸句。当知如前最极无上菩提品说。数之次第最居其首故名第一。以无上故。与一切种饶益一切有情功能具相应。故毕竟胜伏一切魔怨大威力故说名为力。摄受如实圆证因故。如其所欲皆能现行自在转。故说名成就最上涅槃。以无上故说名为大。八支圣道所证得故。远离一切灾患畏故。名仙尊位。能自了知自所证故。说名自知。既自证已由哀愍心广为有情等开示。故名转梵轮。何以故。谓诸如来有是增语。说名为梵名为寂静。亦名清凉。最初能转。从此已后余复为余。如是展转梵所推运。周旋一切有情众中故名梵轮。自显堕在最上施设无上大师圆满摄故。能说彼道对治一切余邪道故。于道怨敌异论现前无怯弱故。为欲胜伏一切他论。宣扬广大无上论故。名大众中正师子吼。以要言之。当知此中显发辩了施设开示自利行满利他行满自利利他圆满不共。复有异门此中略义。谓所应得得胜方便。此胜方便一切众会随所乐欲。或天或人一切皆从我所。获得此胜方便。如病除愈。当知此显自知已得大安隐处。如彼疾病除愈方便。当知此显转于梵轮。如遮一切邪医。自称显已。决定能愈众疾。当知此显于大众中正师子吼

若有诸业已作已增已灭名为过去。若有诸业非是已作已增已灭。亦非正作而是当作名为未来。若有诸业非是已作已增已灭而是正作正造正为名为现在。如是诸业品类差别复有三种。所谓身业语业意业。法受分别复有四种。如前广说。谓有法受得现世乐后苦异熟。乃至广说。又此诸业现法当来有益无益加行差别。如应当知。若所造业依此方所是名为处。若所造业以有情数非有情数为所依事。是名为事。若所造业以不善根或以善根为因缘起。是名为因。若所造业感爱非爱过失功德相应诸果。是名异熟。如是略说一切时分。一切品类。一切分位加行差别。一切方所。一切依处。一切因缘。一切过患。及与功德。于此一切种类差别。皆如实知。是名如来自业智力。除此无有若过若增

有四静虑有八解脱。即由如是静虑解脱。心有堪能心得自在。随所乐事皆能成办。若随彼彼色类差别三摩地相而入定时。当知说名等持等至。如说世尊随此色类三摩地相而入定时。如其定心大光普照一切梵世妙音说法。但闻其声都无所见。乃至广说。如是如来随欲显示彼彼事义。或共世间不共世间。随此色类三摩地相而入定时。速疾能办。当知此中即由静虑解脱势力。心得自在。心自在故依止于心。随所乐事一切成办。齐此名为修静虑者一切所作。除此无有若过若增。如来于此静虑所作一切种类。皆如实知。是故唯说静虑解脱等持等至。又若略说此静虑等有二杂染。一者为得所未得中障碍杂染。谓无方便善巧加行。及以诸盖随一现行。二者已得所应得中自地杂染。谓烦恼缠及以随眠。如是清净复有四种。与上相违应知其相。又即如是诸静虑等种种引发假立名字。随其色类如应安立。是名建立。又即如是诸静虑等具证得已。后更胜进修习圆满。得随所欲得无艰难得无梗涩。是名清净。如来于此如其未得如其已得。于所得中若劣若胜。若彼假名若彼所有增进边际。如是一切皆如实知。故说如来普于一切静虑解脱等持等至。得无上智

如所成熟修证圆满。信等五根成软中上。当知是名诸根胜劣。若从他信以为其先。或观诸法以为其先。成软中上爱乐印解。当知是名种种胜解。若广建立种种种性。或诸声闻所有种性。或诸独觉所有种性。或诸如来所有种姓。或有种种不定种性。或贪等行差别道理。乃至有情八十千行。当知此中名种种界。若即如是诸趣入门随顺正行。如贪行者修不净观。如声闻地已广宣说。当知此等名遍趣行。复有异门。谓趣一切五趣之行。当知此等名遍趣行。复有异门。谓依种种党类差别。更互相违各各异见。异欲诤论互相违背。诸外道类即诸沙门或婆罗门所有诸行。或余一切品类差别。此世他世无罪趣行。当知此等名遍趣行。如迦罗摩经等广说

若于种种有情众中。谓于东方南西北方。种种名字假设安立品类差别。随先过去所有自体。八言说句差别类中。随念六种略所行行。有无量种宿住随念。何等名为八言说句。谓如是名如是生类。如是种性如是饮食。如是领受苦乐差别。如是长寿如是久住。如是所有寿量边际。何等名为随言说句。六种略行。一者呼召假名。二者刹帝利等色类差别。三者父母差别。四者饮食方轨。五者兴盛衰损。六者寿量差别。由诸世间依凭如是八言说句六种略行。于自于他起言起说。此是我名此是彼名。我是刹帝利彼是刹帝利。我是婆罗门吠舍戍达罗。彼是婆罗门吠舍戍达罗。此是我母此是彼母。如说其母父亦如是。我食如是色类饮食。所谓酪浆羹饭糜等。彼食如是色类饮食。乃至广说。我有如是色类兴衰差别而转。彼有如是色类兴衰差别而转。我住如是色类年齿。所谓或少或中或老。彼住如是色类年齿。乃至广说。唯有尔所随先过去所有自体。八言说句差别类中六种略行。过此无有余言说句及以略行。是故唯于如是品类。发起随念更无有增。即于此中若言说行所有行相。若言说句所有标说。及即于此随起忆念。是故说言并相并说皆能随念

此中静虑说名天住眼。依彼故是彼果故。彼摄受故。名为天眼。是极圆满是善清净静虑果故。名极清净。于其人中所有名字皆不相似。是故说言超过于人。欲界天中亦有生得名相似转。清净天眼人中亦无。诸有情类临欲终没名为死时。住在中有名为生时。趣黑闇者。由二种相起。如是类意生中有。如黑羺光及阴闇夜故。名恶色。趣明白者。由二种相起。如是类意生中有。如晴明夜及婆罗痆斯极鲜白衣。故名好色。诸恶色者。说名为劣。诸好色者。说名为妙。诸下劣者。名往恶趣。诸胜妙者名往善趣。所有坏戒及彼等起。说名成就诸身语意三种恶行。有二邪见。谓坏见者所成邪见。诽谤一切及住彼意。异品类者所成邪见。诽谤贤圣。如是皆名谤贤圣者。由邪见故计着邪因及以邪果。由此为缘造作邪业。造邪业故所有法受或现受乐。于当来世受苦异熟。或现受苦于当来世受苦异熟。是故复说起诸邪见业法受因。彼虽成就其余所有种种善法。而但由此往于恶趣。是故说言由此因缘。名色二种更互乖离。故名身坏。一切死中如是死者。最极下劣故。名极死。为欲开示那落迦想。是故说言堕险恶趣。为欲开示自性体事。是故复须说那落迦由非法行不平等行往趣于彼。故名为险。于此趣中触诸苦触。长时种种猛利无间受诸苦恼。平等出现故名恶趣。堕下分故。大深坑故。难救拔故。甚可悲故。极下贱故。以大绮言常悲怨故。说名为堕。由能发起上品厌离。是故唯说堕那落迦。当知此中若由此生。若得生已受诸苦恼。若受苦已复起所余自业所作种种众苦。如是一切由此诸想之所显示。与上相违随其所应一切白品。皆当了知。此差别者。善行为先所有诸趣名为善趣。受极乐故名乐。世界

一切诸漏所有随眠无余永断。逮得能治胜无漏心胜无漏慧。是其最胜增上心摄增上慧摄。由漏尽故说名无漏心慧解脱。即此心慧二种解脱。于最后有说名内证。第六神通由依见道及依修道内所证故。既自证已如实了知。随其所欲能为他说。是故说言于现法中自证通慧具足。开觉我生尽等诸句差别。广说如后摄异门分。应知其相

瑜伽师地论卷第四十九瑜伽师地论卷第五十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    本地分中菩萨地第十五第三持究竟瑜伽处建立品第五之二

如是别释佛十力已。今当总辨。嗢拖南曰

  自性与分别　　不共亦平等
  作业及次第　　差别最为后

如是所说如来十力所有自性应当了知。所有分别应当了知。所有不共应当了知。所有平等应当了知。所有作业应当了知。所有次第应当了知。所有差别应当了知。由是七相应知如来十力略义

云何如来十力自性。谓总五根为其自性。由慧胜故且说十力慧为自性。所以但言处非处智力。不言信力不言余力。如处非处智力如是。余力当知亦尔。是名如来十力自性

云何如来十力分别。谓若略说由三分别当知无量。一者由时分分别。谓于堕在过去未来及现在世一切所知。随悟入故。二者由品类分别。谓于一一诸有为事自相共相一切行相。随悟入故。三者由相续分别。谓于十方一切有情界各各差别一切相续一切事义。随悟入故。即由如是三种。分别如来十力。当知无量。是名如来十力分别

云何如来十力不共。谓唯如来有此十力。不共一切声闻独觉。是名如来十力不共云何如来十力平等。谓此十力一切如来悉皆平等具足成就。故说平等无有差别。若就如来多所安住。是则如来如是十力展转差别。谓余如来多住余力。其余如来复住余力。是名如来十力平等

云何如来十力作业。谓如来所有处非处智力。于诸因中如实知因。于诸果中如实知果。及能降伏无因恶因种种诤论一切沙门婆罗门等。如来所有自业智力。于自所作受用果业如实了知。及能降伏施福移转种种诤论一切沙门婆罗门等。如来所有静虑解脱等持等至智力。能现三种神变。无到教授所化有情。及能降伏安住种种相违异品怨害诤论一切沙门婆罗门等。如来所有根胜劣智力。于诸有情软中上根部分差别。如实了知。及能于彼如应如宜为说正法。如来所有种种胜解智力。于诸有情软中上品净与不净胜解差别如实了知。其净胜解令渐增长。不净胜解令渐舍离。如来所有种种界智力。于诸有情劣中妙界部分差别。如实了知。于诸有情能如其根如其意乐如其随眠。依于彼彼趣入门中。无倒教授如应安立。此中如来为诸声闻。依于彼彼趣入门中与正教授。如声闻地。尽一切种无间宣说显发辩了施设开示。云何如来教授一切始业初业等持资粮摄受安住欲住其心诸菩萨众。令心得住。谓诸如来为无谄曲恭敬爱重等持资粮始业初业诸菩萨众。最初施设无倒教授。如是告言。善男子来。汝当安处远离卧具独一无二于内寂静如理思惟。汝之父母所为立名。或汝亲教轨范师等所为立名。如是思惟。我今为有离六处法自性真实。或内或外或两中间。于此有中如是名想施设假立言说转耶。汝既如是正思惟已。当于此法都无所得。唯当如是如实了知但于客法有客想转。汝善男子。若于尔时于自己名。唯有客想已生已得。复应在内如理思惟。于汝眼中所有制立眼名。眼想眼假施设。如是思惟。我此眼中唯二可得。谓此制立眼名。眼想眼假施设。及此唯事于中假立名想施设。除此无有若过若增。于此眼中所有制立眼名。眼想眼假施设。且非是眼此唯有事。于中假立眼名想等。当知自性亦非是眼。何以故。非于此中远离所立眼名眼想眼假施设。少有眼觉而能转故。若有此事体是真实。称名所说不应于中更待眼名方有如是眼觉而转。唯应自性不由听闻。不由分别。彼所立名但于此事有眼觉转。然无如是不待名言觉转可得。是故此中唯于客法。而有其客眼名眼想眼假施设。汝既如是于其内眼如理思惟。复于眼想唯有客想当生当得。如于其眼。如是于耳鼻舌身等。广说乃至见闻觉知已得已求。若已作意随寻随伺。以要言之。普于一切诸法想中。唯有客想当生当得。如是汝于自己身中所有假想。能尽除遣勤加行道当正摄受。广说乃至一切法中所有假想。能尽除遣勤加行道当正摄受。汝由如是一切所知善观察觉。普于一切诸法想中起唯客想。于一切法所有一切戏论之想。数数除遣。以无分别无相之心唯取义转。于此事中多修习住。汝若如是。当依如来妙智清净等持种性。获得无倒心一境性。如是汝等若于不净作意思惟。于此作意勿当舍离。若于慈愍。若于缘性缘起。若于界差别。若于阿那波那念。若于初静虑。广说乃至若于非想非非想处无量菩萨静虑神通等持等至。作意思惟。于此作意勿当舍离。汝若如是修此菩萨无倒作意。渐次乃至当得无上正等菩提究竟出离。当知是名一切菩萨遍趣正行。过去如来亦为始业诸菩萨众。已正施设如是教授。未来如来亦为始业诸菩萨众。当正施设如是教授。现在如来亦为始业诸菩萨众。现正施设如是教授。诸声闻等于此作意勤修习时。亦能速疾得胜通慧。若能于此无倒作意如实通达。便能获得诸法现观。如来所有遍趣行智力。于一切苦能出离行。不出离行。如实了知。及令舍离不出离行。能正授与能出离行。如来所有宿住随念智力。于其前际本事本生数数念已。为令所化诸有情类心生厌离心生净信。正为宣说。及能降伏执着常论一切沙门婆罗门等。如来所有死生智力。于诸弟子过往迁谢当所受生。能正记莂。及能降伏执着断论一切沙门婆罗门等。如来所有漏尽智力。于自解脱无惑无疑。及能降伏于阿罗汉起增上慢一切沙门婆罗门等。是名如来十力作业

云何如来十力次第。谓诸如来于其无上正等菩提初证得时。即便顿得一切十力。顿证得已后时次第方现在前。谓诸如来初成佛时。先起处非处智力。观察诸法建立一切无倒因果。既观察已次起自业智力。若有希求即于欲界同分界中可爱殊胜异熟果者。方便为说令其远离诸不善业。令其现行所有善业。次起静虑解脱等持等至智力。若诸有情希求世间离欲法者。与其教授令彼趣向世间离欲。令彼获得如实之道。次起所余如来七力。若诸有情希求出世离欲法者。如应为说趣出世间离欲之道。谓于此中先起根胜劣智力。如实观察希求出世离欲者根。次起种种胜解智力。如实观察彼根为先所有意乐。次起种种界智力。如实观察意乐为先所有随眠。如是了知彼根意乐及随眠已。次起遍趣行智力。如其所应令于所缘趣入门中而得趣入。次起宿住随念智力及死生智力。彼由如应所缘趣入门加行。摄住心已净修行已。为说中道。令其远离萨迦耶见以为根本常断边执。为令永断一切烦恼。从此后起漏尽智力。若有如是正修方便奢摩他力之所任持。虽未永断一切烦恼。而由获得不现行故起不作。作增上慢者。令其舍离此增上慢。是名十力一门次第。复有异门十力次第。谓诸如来于其无上正等菩提初证得时。最初发起处非处智力。令现在前。普于一切缘生法中。观察最胜妙法住智。即依如是妙法住智。次起自业智力。观在家分。由彼彼业种种差别。依在家分曾当现时修证差别。如是观察在家分已。次起静虑解脱等持等至智力。观出家分。谓于如是出家分中。为有能说出苦离苦正道者耶。为无有耶。如是观已正知都无。观诸世间无有救护无所归依。由大悲故以其佛眼如实观照一切世间。既观照已次起根胜劣智力。现前了知住在世间种种有情生在世间长在世间。或有钝根或有中根或有利根。现前知已便于说法其心趣入。次后如前一切所余种种胜解智力等事次第。应知是第二门十力次第。复有异门十力次第。谓诸如来于其无上正等菩提。初证得时。最初发起处非处智力。令现在前。观察一切缘生法界。次起自业智力。即于如是缘生法中。观察假立有情名想诸有情界。如是有情自造如是色类诸业。还受如是色类诸果。如实观察如是法界有情界已。次起静虑解脱等持等至智力。即为如是诸有情类解脱苦故。示现三种无倒神变而教授之。既教授已次起余力。如前次第知根等已。于其正道令趣入已。然后方便令彼有情解脱众苦。是第三门十力次第

云何如来十力差别。谓此十力展转相望。亦有差别亦无差别。处非处智力等与自业智力等。有何差别。若正了知善不善业能感所有爱非爱果。当知此由处非处智力故。若正了知诸有能造善不善业。即彼能受爱非爱果而非所余。当知此由自业智力故。若正了知诸有能修静虑解脱等持等至。即彼能入静虑等定而非所余。当知此由自业智力故。若正了知即依如是静虑等定。现三神变无倒教授所化有情。当知此由静虑解脱等持等至智力故。若正照取信等俱生相应之心。当知此由静虑解脱等持等至智力故。若正分别即彼诸根软中上品种种差别。当知此由根胜劣智力故。若正照取诸根为先彼彼法中种种意乐。当知此由根胜劣智力故。若正分别即彼意乐种种差别。当知此由种种胜解智力故。即彼意乐当知分别略有六种。一者不出离意乐。谓于各别大自在天那罗延天梵世间等。起信解者所有意乐。二者出离意乐。谓于三乘起信解者所有意乐。三者远清净意乐。谓安住下品中品成熟者所有意乐。四者近清净意乐。谓安住上品成熟者所有意乐。五者即于现法得涅槃意乐。谓由声闻乘所得涅槃起信解者所有意乐。六者于当来世得涅槃意乐。谓由大乘所得涅槃起信解者所有意乐。若正照取胜解所起相似种子。当知此由种种胜解智力故。若正照取即彼种子差别。分别无量品类。当知此由种种界智力故。又即彼界当知分别略有四种。一者本性住种子。二者先习起种子。三者可修治种子。谓有般涅槃法者所有种子。四者不可修治种子。谓无般涅槃法者所有种子。若正了知如界种类行迹趣入。当知此由种种界智力故。若正分别即彼行迹一切品类。如是行迹能令离染。如是行迹能令毕竟清净。如是行迹能令不毕竟清净。当知此由遍趣行智力故。若如实知前际随念一切趣因前际俱行。当知此由遍趣行智力故。若正了知如前分别种种随顺八言说句六种略行。当知此由宿住随念智力故。若正了知依于前际有情死生。当知此由宿住随念智力故。若正观见后际种种有情死生。当知此由死生智力故。若正了知于自事义未得究竟。有情后际受生相续。当知此由死生智力故。若正了知于自事义已得究竟心善解脱于现法中证得涅槃。当知此由漏尽智力故。当知是名如来十力展转相望亦有差别亦无差别

如来所有四无畏文。如契经说应知其相。谓诸如来于其四处。在大众中而自称叹。谓所知障永解脱故。于一切种一切法中。现等正觉不共声闻。是第一处。诸烦恼障永解脱故。证得漏尽共诸声闻。是第二处。为求解脱诸有情类超过众苦。说出离道。是第三处。即于能出道得为碍。说诸障法应当远离。是第四处。如来既于如是四处。如其实义自称叹已。次后他于自所称叹前之二处所有相违身语意业而兴谤难。复于后二自称叹处所有相违前后乖反堕非理相而兴谤难。谓于世间有眼见者无眼见者。有他心智者无他心智者。如来于此自称叹处能为对治诸谤难中。都不见有如实因相。由是因缘于此四处能自了知。坦然无畏心无怯劣。无所疑虑都无惊惧。又佛大师唯有尔所正应称叹。谓自利行及利他行俱善圆满。当知此中前二称叹自利行满。后二称叹利他行满。此中如来若自称叹。于一切法现等觉故成正等觉。当知正为等趣大乘诸菩萨故。若自称叹一切漏尽。当知正为等趣声闻及独觉乘诸有情故。若复称叹能出离道及诸障法。当知俱为等趣诸乘诸有情故。如是如来所说经句。谓我为诸菩萨声闻说出离道。乃至广说。诸结集者。于所结集声闻藏中。除菩萨言。于所结集菩萨藏中。但唯诵此菩萨之言。

如来所有三念住文。如契经说应知其相。谓诸如来于其长夜有如是欲。如何当令诸有情类于我善说法毗柰耶无倒行中。如实随住。如是长夜欲乐法主化御众时。若所希欲或遂不遂不生杂染。由三念住略所显故。此三念住复由三众差别建立。云何三众。若彼一切一向正行。是第一众。若彼一切一向邪行。是第二众。若彼众中一分正行一分邪行。是第三众

如来所有三不护文。如契经说应知其相。谓诸如来以要言之。于一切种鄙恶所作覆藏永断。由三不护之所显示。诸阿罗汉由忘念故。于时时间片有无记鄙恶所作。如来于此一切。一切皆无所有。是故如来于诸弟子如所立要即如自性。切切诫勖显显呵摈。时复现行率尔敦逼。于诸弟子无所防虑。所谓勿彼共住多时。知我所行三业不净。因于前事意怀不悦。由斯不顺乃事乖违。或面讥我或向他说

当知如来所有大悲一切种相。皆悉如前供养亲近无量品说。当知如是如来大悲无量无上

云何如来无忘失法。谓诸如来常随记念。若事若处若如若时有所为作。如来即于此事此处此如此时。皆正随念。是名如来无忘失法。所谓如来普于一切所作事业。普于一切方处差别。普于一切所作方便。普于一切时分差别。念无忘失常住正念。当知是名无忘失法

云何如来永害习气。谓诸如来或于动转或于瞻视。或于言论或于安住。似有烦恼所起作业多不现行。是名如来永害习气。诸阿罗汉虽断烦恼。而于动转瞻视言论及安住中。而有种种似有烦恼所起作业

云何如来一切种妙智。谓诸如来以要言之。于三聚法现等正觉。何等为三。一者能引有义聚法。二者能引无义聚法。三者非能引有义聚法非能引无义聚法。当知此中若诸如来或于能引无义聚法。或于非能引有义聚法非能引无义聚法。总于如是一切法中。无颠倒智。是名如来一切种智。若诸如来于其能引有义聚法一切法中。无颠倒智。当知是名如来妙智。即于此中若一切种智若妙智。总合为一。名一切种妙智

如是一切。总名如来百四十种不共佛法。即于此中诸相随好。在菩萨位最后有中。皆已证得极善清净。若时菩萨坐菩提座住最后有。于菩萨道菩提资粮极善圆满。尔时无师修三十七菩提分法。得一刹那名无障碍智三摩地。是其菩萨学道所摄金刚喻定。

从此无间第二刹那。顿得其余不共佛法。谓如来十力为初。一切种妙智为后。皆极清净悉为无上。由得此故普于一切所知境界。无滞无障。最极清净无垢智转依。暂发悟思惟圆满意车圆满。超过一切菩萨行菩萨地。证入一切如来行如来地。一切在肉所知障品所有粗重无余断故。得胜转依。如是转依最为无上。其余一切乃至最上成满住中菩萨转依。当知有上

问一切安住到究竟地菩萨智等。如来智等。云何应知此二差别。答如明眼人隔于轻縠睹众色像。一切安住到究竟地菩萨妙智。于一切境当知亦尔。如明眼人无所障隔睹众色像。如来妙智于一切境当知亦尔。如画事业圆布众彩唯后妙色未净修治。到究竟地菩萨妙智。当知亦尔。如画事业圆布众彩最后妙色已净修治。如来妙智当知亦尔。如明眼人于微闇中睹见众色。到究竟地菩萨妙智当知亦尔。如明眼人离一切闇睹见众色。如来妙智当知亦尔。如明眼人远睹众色。到究竟地菩萨妙智当知亦尔。如明眼人近睹众色。如来妙智当知亦尔。如轻医眼观视众色。到究竟地菩萨妙智当知亦尔。如极净眼观视众色。如来妙智当知亦尔。如处胎身。到究竟地诸菩萨身当知亦尔。如出胎身。诸如来身当知亦尔。如阿罗汉梦中心行。到究竟地菩萨心行当知亦尔。如阿罗汉觉时心行。如来心行当知亦尔。如昧灯体。到究竟地菩萨智体当知亦尔。如明灯体。如来智体当知亦尔。是故当知一切安住到究竟地诸菩萨众。与诸如来妙智。身心有大差别

如是如来证菩提已。遍于十方一切佛土。普能施作一切佛事。云何名为一切佛事。谓诸如来如来事业如来所作。略有十种。如是一一如来事业如来所作。能成无量利有情事。此外无有若过若增。何等为十。谓诸如来最初自现大丈夫身。欲令有情心发净信。大丈夫身于生净信为最胜故。是名如来第一作事。如是作事。诸相随好所能成办。又诸如来普为一切有情之类。起一切种教授加行。是名如来第二作事。如是作事。四一切种清净所能成办。又诸如来能作一切利有情事。能断一切所生疑惑。是名如来第三作事。如是作事。如来十力所能成办。由前所说如来十力。于能成办一切有情一切义利。有堪能故。又于如来所证十力所兴问难。唯有如来能知能见能解能了。唯有如来于彼问难能正答故。又诸如来普能降伏一切他论。普能成立一切自论。是名如来第四作事。如是作事。四无所畏所能成办。又诸如来所化有情。于佛教敕若正安住不正安住。如来于彼心无杂染。是名如来第五作事。如是作事。三种念住所能成办。又诸如来如自所言即如是作。是名如来第六作事。如是作事。三种不护所能成办。又诸如来常以佛眼于昼夜分遍观世间。是名如来第七作事。如是作事。如来大悲所能成办。又诸如来顿于一切一切作事皆无退舍。是名如来第八作事。如是作事无忘失法所能成办。又诸如来所行仪轨。如实随转无越作用。是名如来第九作事。如是作事。永害习气所能成办。又诸如来于其能引无义聚法。于不能引有义聚法亦不能引无义聚法。简择舍离。于其能引有义聚法。为众宣说开示显发。是名如来第十作事。如是作事。一切种妙智所能成办。如是如来由前所说百四十种不共佛法。能作如来一切所作一切佛事。如是佛事若广分别不易可数。乃至俱胝那庾多百千大劫说不能尽

如是所说诸如来住诸如来地。名为建立。何以故。依此住此希求品类。诸菩萨众。于菩萨学能正修学。亦依住此而有所证。即依住此普能成办一切有情一切义利。是故说此名为建立。又此一切所说佛法。于利他事最为随顺。一切如来是利他事之所显现。声闻独觉则不如是。是故说名不共佛法。又于如是诸佛法中自有佛法。声闻独觉一切一切皆所不得。所谓大悲。无忘失法。永害习气。一切种妙智。自有佛法。虽分似得而一切种皆不圆满。如来于彼一切。一切悉皆证得。于一切种无不圆满。最极超过最极殊妙。是故皆说名为不共。

当知此中独一有义。是不共义。如是圆满显示一切菩萨学道及学道果。名菩萨地。具说一切菩萨学道及学道果。一切种教实依处故。又此菩萨地亦名菩萨藏摩怛理迦。亦名摄大乘。亦名开示坏不坏路。亦名无障智净根本。若诸所有天人世间。或天或人。若诸沙门婆罗门等。于此所说菩萨地中起坚信解。乐闻受持精勤修学广为他说。下至书持供养恭敬深心爱重。所得福聚以要言之。如薄伽梵于菩萨藏所摄一切微妙经典。乐闻等业宣说显了分别施设开示称赞所获福聚。等无有异。何以故。此菩萨地显示一切菩萨藏中略标广释诸门摄故。于此地中能广开示法毗柰耶。乃至众多所化有情。于此正法受持读诵法随法行。安住增长广大胜进。于尔所时像似正法不得兴盛正法不灭。若于尔时像似正法当得兴盛。即于尔时能引实义所有正法当速灭没。是故于此菩萨地中起坚信解。乐闻受持乃至广说。所得福聚无量无边

    本地分中菩萨地第十五第四持次第瑜伽处发正等菩提心品

如是已说菩萨地义。云何应知此中次第。

谓诸菩萨要先安住菩萨种性。乃能正发阿耨多罗三藐三菩提心。既发心已方正修行自他利行。于自他利正修行时。得无杂染方便。无杂染故得无厌倦方便。无厌倦故得诸善根增长方便。于诸善根得增长已。能证无上正等菩提。又于如是自他利加行无杂染方便。无厌倦方便。善根增长方便。得大菩提中。将修行时。先于甚深广大正法安立信解。立信解已访求正法。求正法已广为他说。亦于正行自能成办。于成办时若由此于此为此应行。即由此于此为此而行。由此于此为此行时。如令福德智慧增长。所应行者即如是行。福德智慧既增长已。于不舍离生死方便能正修行。即于此中正修行时。能行生死无杂染行。即于此中正修行时。能于自乐行无著行。即于此中正修行时。能于无量生死大苦。能正修行无厌倦行。由于生死无厌倦故。能正访求种种异论。于一切论得无所畏。善知论已复能了知所应为说所可宣说应如是说。由此智故善知世间。如是菩萨善知诸论及世间已。复能如理访求正法。既访求已堪能善断一切有情一切疑惑。如是堪能断他疑惑。令自福德展转增长。福德资粮渐得圆满。令自智慧亦转增长。智慧资粮渐得圆满。二种资粮既圆满已。于谛行相菩提分法无倒修中能勤修行。于修方便能正了知。即持如是正勤所修。回向大乘般涅槃果。不求声闻及独觉乘般涅槃果。既得如是方便善巧。能于一切菩萨语言听闻受持。依修力故。于昔未闻所有诸法一切种相皆能辨了。于陀罗尼无碍辩才皆得圆满。为欲永断一切障故。精勤修习三解脱门。即于此中正修行时。为断自他一切颠倒增上慢故。勤修正行。如是能于一切种相。正行圆满。如是正行得圆满已。于一切有情及声闻独觉皆为殊胜。所谓正行功德殊胜。及可称赞功德殊胜。当知此中正行功德殊胜菩萨。为利自他勤修正行。用利他事以为自事。声闻独觉则不如是。由诸菩萨用利他事为自事故。于一切有情起如自己平等之心。由起如是平等心故。于诸有情常施恩惠不望其报。菩萨如是勤修行时。常于有情发起希望。欲令彼得利益安乐。由是利益安乐意乐。常能起作不虚加行。当知是名展转引发正行功德殊胜。当知此中称赞功德殊胜菩萨。于诸佛所获得授记。非诸声闻亦非独觉。得授记已便能安住不退转地。安住此中能于一切决定所作。恒常所作。获得坚固无忘失法。如是坚固无忘失法。诸佛菩萨施设。在于一切有情最上施设。普于一切所应作事能无退失。于未得退亦无退失。无退失时恒常无间一切善法运运增长如明分月。由诸善法转增长故。菩萨尔时得名真实不名相似。由得真实菩萨名故。于一切种一切有情调伏方便。如实了知。如实知故。一切安立皆得善巧。从此寻求于此寻求由此寻求。既寻求已由此究竟皆正安立。如是名为一切安立皆得善巧。于诸安立得善巧故。复于教授能得善巧。于其教授得善巧故。复能获得无量所缘三摩地王。获得如是三摩地已能不唐捐。宣说正法种种行相。说正法时皆有胜果。能于大乘究竟出离。以依大性而出离故能摄大乘。由此复于彼彼大乘出离位中。得彼彼名。一切菩萨同共。此名一切世间诸佛菩萨皆共安立皆共称叹。当知是名所可称赞功德殊胜。由得如是殊胜名故。当知获得诸菩萨相。诸相所相成就其相如是。正行一切种相在家出家二分菩萨所能成办。于二分中能成办已。正行坚固于诸善品。获得一向增上意乐。如是意乐或在家品所应摄受。或出家品所应摄受。或于善品能正安立乃至安住。从此已上。故作意思受诸有生。于彼生处常得值遇诸佛菩萨。及能起作一切有情诸饶益事。恒常无间蒙佛菩萨无倒教授。任持善品领受殊胜证得分位。由领受故于可称赞摄受殊胜证得分位。能正安处如己舍宅。住此位已能于后后殊胜分位一切种相。觉慧升进。渐次乃至到于究竟。于其中间不生喜足。如是升进证得究竟。从此不求其余上地。已到究竟极边际故名得无上。

是名菩萨地义次第

    本地分中有余依地第十六

如是已说菩萨地。云何有余依地。当知此地有三种相。一者地施设安立。二者寂静施设安立。三者依施设安立。

云何地施设安立。谓有余依地。除五地一分。谓无心地。修所成地声闻地。独觉地。菩萨地。除一地全。谓无余依地。所余诸地名有余依地。是名地施设安立

云何寂静施设安立。谓由四种寂静。施设安立有余依地。一由苦寂静故。二由烦恼寂静故。三由不损恼有情寂静故。四由舍寂静故。云何苦寂静。谓阿罗汉苾刍。诸漏永尽。所有当来后有众苦皆悉永断。已得遍知。如多罗树断截根顶不复现前。由得当来不生法故。是名苦寂静。云何烦恼寂静。谓阿罗汉苾刍。贪欲永断。嗔恚永断。愚痴永断。一切烦恼皆悉永断。由得毕竟不生法故。是名烦恼寂静。云何不损恼有情寂静。谓阿罗汉苾刍。贪欲永尽。嗔恚永尽。愚痴永尽。一切烦恼皆悉永尽。不造诸恶修习诸善。是名不损恼有情寂静。云何舍寂静。谓阿罗汉苾刍。诸漏永尽。于六恒住。恒常无间多分安住。谓眼见色已不喜不忧。安住上舍正念正知。如是耳闻声已鼻嗅香已舌尝味已身觉触已意了法已。不喜不忧安住上舍正念正知。是名舍寂静。即依如是四种寂静说有余依地。最极寂静最极清凉。是名寂静施设安立

云何依施设安立。谓有八种依。一施设依。二摄受依。三住持依。四流转依。五障碍依。六苦恼依。七适悦依。八后边依。云何施设依。谓五取蕴由依此故。施设我及有情命者生者能养育者。补特伽罗意生儒童等诸想等。想假用言说。及依此故。施设如是名字如是生类。如是种姓如是饮食。如是领受苦乐如是。长寿如是久住。如是寿量边际等诸想等想。假用言说。云何摄受依。谓七摄受事。即自己父母妻子。奴婢作使僮仆。朋友眷属。七摄受事。如前意地已广分别。依此了知诸有情类有所摄受。云何住持依。谓四种食。即叚食。触食。意思食。识食。由依此故已生有情住立支持。又能摄养诸求有者。云何流转依。谓四种识住及十二缘起。即色趣识住。受趣识住。想趣识住。行趣识住。及无明缘行行缘识。广说乃至生缘老死。由依此故。诸有情类于五趣生死随顺流转。云何障碍依。谓诸天魔随有彼彼修善法处。即往其前为作障碍。云何苦恼依。谓一切欲界皆名苦恼依。由依此故令诸有情领受忧苦。云何适悦依。谓静虑等至乐名适悦依。由依此故。诸有情类若即于此现入彼定。若生于彼长夜领受静虑等至所有适悦。云何后边依。谓阿罗汉相续诸蕴。由依此故说诸阿罗汉任持最后身。问阿罗汉苾刍诸漏永尽住有余依地。当言与几种依共相应耶。答当言与一种依一向相应。谓后边依。与六摄受事不共相应。与流转依与障碍依。一向全不相应。与所余依非相应非不相应。是名依施设安立

    本地分中无余依地第十七

如是已说有余依地。云何无余依地。当知此地亦有三相。一者地施设安立。二者寂灭施设安立。三者寂灭异门安立

云何地施设安立。谓先所除五地一分。当知即此无余依地所摄。谓无心地。修所成地。声闻地。独觉地。菩萨地

云何寂灭施设安立。谓由二种寂灭。施设安立如是无余依地。一由寂静寂灭故。二由无损恼寂灭故。云何寂静寂灭。谓先于有余依地。获得触证四种寂静。今无余依涅槃界中。亦有最胜四种寂静。一数教寂静。二一切依寂静。三依依苦寂静。四依依苦生疑虑寂静。如说

  由无下劣心　　能忍受勤苦
  彼所趣解脱　　譬如灯尽灭

云何无损恼寂灭。谓与一切依不相应。违背一切烦恼诸苦流转生起。转依所显真无漏界。如说苾刍永寂灭名真安乐住。又如说言实有无生无起无作无为无等生起。亦有有生有起有作有为有等生起。若当无有无生无起无作无为无等生起。我终不说有生有起有作有为有等生起有永出离。由实有无生无起无作无为无等生起。是故我说有生有起有作有为有等生起有永出离。世尊依此密意说言甚深广大无量无数是谓寂灭。由于此中所具功德难了知故名为甚深。极宽博故名为广大。无穷尽故名为无量。数不能数无二说故名为无数。云何此中数不能数。谓有非有不可说故。即色离色不可说故。即受离受不可说故。即想离想不可说故。即行离行不可说故。即识离识不可说故。所以者何。由此清净真如所显一向无垢。是名无损恼寂灭。如是二种。总说为一寂灭施设安立

云何寂灭异门施设安立。当知此中寂灭异门有无量种。谓名为常亦名为恒。亦名久住亦名无变。亦名有法。亦名舍宅。亦名洲渚亦名救护。亦名归依亦名所趣。亦名安隐亦名淡泊。亦名善事亦名吉祥。亦名无转亦名无垢。亦名难见亦名甘露。亦名无忧亦名无没。亦名无炽亦名无热。亦名无病亦名无动。亦名涅槃亦名永绝一切戏论。如是等类应知说名寂灭异门。是名寂灭异门施设安立

瑜伽师地论卷第五十　本地分竟瑜伽师地论卷第五十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中五识身相应地意地之一

如是已说本地。次说诸地决择善巧。由此决择善巧为依。于一切地善能问答。今当先说五识身地意地决择。

问前说种子依。谓阿赖耶识。而未说有有之因缘广分别义。何故不说。何缘知有广分别义。云何应知。答由此建立是佛世尊最深密记。是故不说。如世尊言

  阿陀那识甚深细　　一切种子如瀑流
  我于凡愚不开演　　恐彼分别执为我

复次嗢拖南曰

  执受初明了　　种子业身受
  无心定命终　　无皆不应理

由八种相。证阿赖耶识决定是有。谓若离阿赖耶识依止执受不应道理。最初生起不应道理。有明了性不应道理。有种子性不应道理。业用差别不应道理。身受差别不应道理。处无心定不应道理。命终时识不应道理。何故若无阿赖耶识依止执受不应道理。由五因故。何等为五。谓阿赖耶识先世所造业行为因。眼等转识于现在世众缘为因。如说根及境界。作意力故诸转识生。乃至广说是名初因。又六识身有善不善等性可得。是第二因。又六识身无覆无记异熟所摄类不可得。是第三因。又六识身各别依转。于彼彼依彼彼识转。即彼所依应有执受。余无执受不应道理。设许执受亦不应理。识远离故。是第四因。又所依止应成数数执受过失。所以者何。由彼眼识于一时转一时不转。余识亦尔。是第五因。如是先业及现在缘以为因故。善不善等性可得故。异熟种类不可得故。各别所依诸识转故。数数执受依止过故。不应道理。何故若无阿赖耶识。最初生起不应道理。谓有难言。若决定有阿赖耶识。应有二识俱时生起。应告彼言。汝于无过妄生过想。何以故。容有二识俱时转故。所以者何。且如有一俱时欲见。乃至欲知。随有一识最初生起。不应道理由彼尔时作意无别。根境亦尔。以何因缘识不俱转

何故若无诸识俱转。与眼等识同行意识。明了体性不可得耶。谓或有时忆念过去曾所受境。尔时意识行不明了。非于现境意现行时得有如是不明了相。是故应许诸识俱转或许意识无明了性

何故若无阿赖耶识。有种子性不应道理。谓六识身展转异故。所以者何。从善无间。不善性生。不善无间复善性生。从二无间无记性生。劣界无间中界生。中界无间妙界生。如是妙界无间乃至劣界生。有漏无间无漏生。无漏无间有漏生。世间无间出世生。出世无间世间生。非如是相有种子性应正道理。又彼诸识长时间断。不应相续长时流转。是故此亦不应道理。何故若无诸识俱转。业用差别不应道理。谓若略说有四种业。一了别器业。二了别依业。三了别我业。四了别境业。此诸了别刹那刹那俱转可得。是故一识于一刹那。有如是等业用差别不应道理

何故若无阿赖耶识。身受差别不应道理。谓如有一或如理思或不如理。或无思虑或随寻伺。或处定心或不在定。尔时于身诸领受。起非一众多种种差别。彼应无有然现可得。是故定有阿赖耶识

何故若无阿赖耶识。处无心定不应道理。谓入无想定或灭尽定。应如舍命识离于身。非不离身。如世尊说当于尔时识不离身故

何故若无阿赖耶识。命终时识不应道理。谓临终时或从上身分。识渐舍离冷触渐起。或从下身分。非彼意识有时不转。故知唯有阿赖耶识能执持身。此若舍离。即于身分冷触可得。身无觉受。意识不尔。是故若无阿赖耶识不应道理

复次嗢拖南曰

  所缘若相应　　更互为缘性
  与识等俱转　　杂染污还灭

若略说阿赖耶识。由四种相建立流转。由一种相建立还灭。云何四相建立流转。当知建立所缘转故。建立相应转故。建立互为缘性转故。建立识等俱转转故。云何一相建立还灭。谓由建立杂染转故。及由建立彼还灭故。云何建立所缘转相。谓若略说阿赖耶识。由于二种所缘境转。一由了别内执受故。二由了别外无分别器相故。了别内执受者。谓能了别遍计所执自性妄执习气。及诸色根根所依处。此于有色界。若在无色。唯有习气执受了别。了别外无分别器相者。谓能了别依止。缘内执受阿赖耶识故。于一切时无有间断。器世间相譬如灯焰生时内执膏炷外发光明。如是阿赖耶识缘内执受缘外器相。生起道理应知亦尔

复次阿赖耶识缘境微细。世聪慧者亦难了故

复次阿赖耶识缘境。无废时无变易。从初执受刹那乃至命终。一味了别而转故复次阿赖耶识于所缘境念念生灭。当知刹那相续流转非一非常。复次阿赖耶识。当言于欲界中缘狭小执受境。于色界中缘广大执受境。于无色界空无边处识无边处缘无量执受境。于无所有处缘微细执受境。于非想非非想处缘极微细执受境。如是了别二种所缘故。于所缘境微细了别故。相似了别故。刹那了别故。了别狭小执受所缘故。了别广大执受所缘故。了别无量执受所缘故。了别微细执受所缘故。了别极微细执受所缘故。应知建立阿赖耶识所缘转相

云何建立相应转相。谓阿赖耶识。与五遍行心相应所恒共相应。谓作意触受想思。如是五法。亦唯异熟所摄最极微细。世聪慧者亦难了故。亦常一类缘境而转。又阿赖耶识相应受。一向不苦不乐无记性摄。当知余心法行相亦尔。如是遍行心所相应故。异熟一类相应故。极微细转相应故。恒常一类缘境而转相应故。不苦不乐相应故。一向无记相应故。应知建立阿赖耶识相应转相

云何建立互为缘性转相。谓阿赖耶识。与诸转识作二缘性。一为彼种子故。二为彼所依故。为种子者。谓所有善不善无记转识转时。一切皆用阿赖耶识为种子故。为所依者。谓由阿赖耶识执受色根。五种识身依之而转。非无执受。又由有阿赖耶识故得有末那。由此末那为依止故意识得转。譬如依止眼等五根五识身转。非无五根。意识亦尔非无意根。复次诸转识。与阿赖耶识作二缘性。一于现法中。能长养彼种子故。二于后法中。为彼得生摄殖彼种子故。于现法中长养彼种子者。谓如依止阿赖耶识善不善无记转识转时。如是如是于一依止同生同灭。熏习阿赖耶识。由此因缘后后转识善不善无记性转。更增长转更炽盛转更明了而转。于后法中为彼得生摄殖彼种子者。谓彼熏习种类。能引摄当来异熟无记。阿赖耶识如是为彼种子故。为彼所依故。长养种子故。摄殖种子故。应知建立阿赖耶识与诸转识互为缘性转相。云何建立阿赖耶识与转识等俱转转相。谓阿赖耶识。或于一时唯与一种转识俱转。所谓末那。何以故。由此末那。我见慢等恒共相应思量行相。若有心位若无心位。常与阿赖耶识一时俱转。缘阿赖耶识以为境界。执我起慢思量行相。或于一时与二俱转。谓末那及意识。或于一时与三俱转。谓五识身随一转时。或于一时与四俱转。谓五识身随二转时。或时乃至与七俱转。谓五识身和合转时。又复意识染污末那以为依止。彼未灭时相了别缚不得解脱。末那灭已相缚解脱。又复意识能缘他境及缘自境。缘他境者。谓缘五识身所缘境界或顿不顿缘自境者。谓缘法境

复次阿赖耶识。或于一时与苦受乐受不苦不乐受俱时而转。此受与转识相应依彼而起。谓于人中若欲界天。若于一分鬼傍生中。俱生不苦不乐受与转识相应。苦受乐受不苦不乐受相杂俱转。若那落迦等中他所映夺。不苦不乐受与纯苦。无杂受俱时而转。当知此受被映夺故难可了知。如那落迦等中一向苦受俱转。如是于下三静虑地。一向乐受俱转。于第四静虑地乃至有顶。一向不苦不乐受俱转

复次阿赖耶识。或于一时与转识相应善不善无记诸心所俱时而转

如是阿赖耶识。虽与转识俱时而转。亦与客受客善不善无记心所俱时而转。然不应说与彼相应。何以故。由不与彼同缘转故。如眼识虽与眼根俱转然不相应。此亦如是。应知此中依少分相似道理故得为喻。又如诸心所虽心所性无有差别。然相异故于一身中一时俱转互不相违。如是阿赖耶识与诸转识。于一身中一时俱转。当知更互亦不相违。又如于一瀑流有多波浪一时而转互不相违。又如于一清净镜面有多影像一时而转互不相违。如是于一阿赖耶识。有多转识一时俱转。当知更互亦不相违。又如一眼识于一时间于一事境。唯取一类无异色相。或于一时顿取非一种种色相。如眼识于众色。如是耳识于众声。鼻识于众香。舌识于众味亦尔。又如身识或于一时于一事境唯取一类无异触相。或于一时顿取非一种种触相。如是分别意识。于一时间或取一境相。或取非一种种境相。当知道理亦不相违。又前说末那恒与阿赖耶识俱转乃至未断。当知常与俱生任运四种烦恼一时相应。谓萨迦耶见。我慢。我爱。及与无明。此四烦恼。若在定地若不定地。当知恒行不与善等相违。是有覆无记性。如是阿赖耶识。与转识俱转故。与诸受俱转故。与善等俱转故。应知建立阿赖耶识俱转转相

云何建立阿赖耶识杂染还灭相。谓略说阿赖耶识是一切杂染根本。所以者何。由此识是有情世间生起根本。能生诸根根所依处及转识等故。亦是器世间生起根本。由能生起器世间故。亦是有情互起根本。一切有情相望互为增上缘故。所以者何。无有有情与余有情互相见等时。不生苦乐等更相受用。由此道理当知有情界互为增上缘。又即此阿赖耶识。能持一切法种子故。于现在世是苦谛体。亦是未来苦谛生因。又是现在集谛生因。如是能生有情世间故。能生器世间故。是苦谛体故。能生未来苦谛故。能生现在集谛故。当知阿赖耶识是一切杂染根本

复次阿赖耶识所摄持顺解脱分。及顺决择分等善法种子。此非集谛因。由顺解脱分等善根与流转相违故。所余世间所有善根。因此生故转更明盛。由此因缘彼所摄受自类种子。转有功能转有势力。增长种子速得成立。复由此种子故彼诸善法转明盛生。又复能感当来转增转胜可爱可乐诸异熟果。复次依此一切种子阿赖耶识故。薄伽梵说。有眼界色界眼识界。乃至有意界法界意识界。由于阿赖耶识中有种种界故。又如经说恶叉聚喻。由于阿赖耶识中有多界故

复次此杂染根本阿赖耶识。修善法故方得转灭。此修善法若诸异生。以缘转识为境作意方便住心。能入最初圣谛现观。非未见谛者于诸谛中。未得法眼。便能通达一切种子阿赖耶识。此未见谛者修如是行已。或入声闻正性离生。或入菩萨正性离生。达一切法真法界已。亦能通达阿赖耶识。当于尔时能总观察自内所有一切杂染。亦能了知自身外为相缚所缚。内为粗重缚所缚

复次修观行者。以阿赖耶识是一切戏论所摄诸行界故。略彼诸行。于阿赖耶识中总为一团一积一聚。为一聚已由缘真如境智。修习多修习故而得转依。转依无间当言已断阿赖耶识。由此断故当言已断一切杂染。当知转依由相违故。能永对治阿赖耶识。又阿赖耶识体是无常。有取受性。转依是常。无取受性。缘真如境圣道方能转依故。又阿赖耶识。恒为一切粗重所随。转依究竟远离一切所有粗重。又阿赖耶识。是烦恼转因。圣道不转因。转依是烦恼不转因。圣道转因。应知但是建立因性。非生因性。又阿赖耶识。令于善净无记法中不得自在。转依令于一切善净无记法中得大自在。又阿赖耶识断灭相者。谓由此识正断灭故舍二种取。其身虽住犹如变化。所以者何。当来后有苦因断故。便舍当来后有之取。于现法中一切烦恼因永断故。便舍现法一切杂染所依之取。一切粗重永远离故。唯有命缘暂时得住。由有此故契经中言。尔时但受身边际受命边际受。广说乃至即于现法一切所受究竟灭尽

如是建立杂染根本故。趣入通达修习作意故。建立转依故。当知建立阿赖耶识杂染还灭相

如是已依胜义道理。建立心意识名义差别。由此道理。于三界等诸心意识一切杂染清净道理。应随决了。余处所显心意识理。但随所化有情差别。为婴儿慧所化。权说方便令彼易得入故

问若成就阿赖耶识亦成就转识耶。设成就转识亦成就阿赖耶识耶。答应作四句。或有成就阿赖耶识非转识。谓无心睡眠无心闷绝。入无想定入灭尽定生无想天。或有成就转识非阿赖耶识。谓阿罗汉若诸独觉。不退菩萨及诸如来住有心位。或有俱成就。谓余有情住有心位。或有俱不成就。谓阿罗汉若诸独觉不退菩萨及诸如来。入灭尽定处无余依般涅槃界

问内外诸法自性各别各住自相。何因缘故十八界中唯六识界自性建立。所余诸界为彼所依所缘助伴而建立耶。答由六识界于彼彼念。瞬息须臾日夜等位速疾转变。托彼彼缘依眼等根缘色等境。用诸心所以为助伴。非一众多种种生起。由彼彼依之所生故得彼彼名。如火依附彼彼缘故而得烧然尔时便得彼彼名数。由诸草木牛粪糠札等为缘故。火方得然。尔时便数名为草火乃至札火。如是眼色以为缘故眼识得生数名眼识。如是乃至数名意识。广说应知。余眼等界若彼自性从初生已。即彼自性相似生起。展转相续究竟随转。又一识类藉彼彼缘种种差别自性生起。是故识界自性建立。所余诸界为彼所依所缘助伴而得建立

复次当辩识身遍知。问心清净行苾刍。由几种相遍知其心。答若略说由三种相。一杂染爱乐相。二杂染过患相。三杂染还灭方便善巧相

云何心清净行苾刍遍知自心杂染爱乐相。谓心清净行苾刍作如是念。今我此心于诸杂染长夜爱乐。自知爱乐诸杂染已。便从有贪性出。于离贪性安止其心。尔时其心于离贪性。不能安住亦不爱乐。更无异缘唯有速疾还来趣入流散驰骋有贪性中。如从有贪性如是。从有嗔有痴下劣掉举不寂静散乱性出。广说乃至从放逸爱乐住性出。于常勤修习诸善法中安止其心。尔时其心于常勤修习诸善法中。不能安住亦不爱乐。更无异缘唯有速疾还来趣入流散驰骋乃至放逸爱乐性中。如是名为心清净行苾刍遍知自心杂染爱乐相。

如是遍知自心杂染爱乐相已。此心清净行苾刍。复能遍知自心杂染过患相。谓作是念。今我此有贪心。能为自害能为他害能为俱害能生现法罪能生后法罪能生现法后法罪。又能为缘生彼所生身心忧苦。如于有贪性如是。乃至于放逸爱乐性。当知亦尔。复作是念。此有贪心乃至放逸爱乐心。有过患故有疫有横有灾有恼。

如是遍知自心杂染过患相已。复能遍知自心杂染还灭方便善巧相。谓我今不应随自杂染有诸过患有疫有横有灾有恼。心自在转。必令自心随我势力自在而转。彼既如是了知。我今不应随顺自心而转。当令自心随我转。已数数思择。令有贪心舍有贪性。无贪性中安住爱乐。又复于彼见胜功德。如是乃至令舍放逸爱乐住性。乃至于常勤修习诸善法中安住爱乐。又复于彼见胜功德彼多安住。如是行已尔时其心不由思择。于常勤修习诸善法中自然安住爱乐。于前杂染爱乐性中深生厌责。由此因缘心清净行苾刍。如实了知自心杂染爱乐。速疾回转无譬喻性。又能善知如是杂染心有过患性。又能善知如是杂染心还灭方便。由如是故心清净行苾刍。速能证得无上心清净性。所谓诸漏永尽。

复次当辩心善巧差别及心转善巧差别。谓依遍计所执自性。当知心善巧差别。依依他起自性。当知心转善巧差别

复次若能善巧熏修心者得二胜利。一于果时触证安乐。二于因时自在而转复次心混浊者有三过失。一不如理作意过失。二随眠过失。三起缠过失。

问如世尊言。唯当于心深善勇猛如理观察。念住中说。要当于身住身循观乃至于法住法循观。此何密意。答为显四念住唯观察心故。谓观心执受观心领纳观心了别观心染净。唯为观察心所执受心所领纳心了别境心染净故。说四念住

复次有诸苾刍。住三种住行六正行。于大师教多有所作。谓住解脱住。住解脱门住。及住能引解脱门法住。行无间行。行善受思惟行。行修所引善根生起行。行离诸爱味简择谛行。行即于此无增上慢行。行正清净受用行。复次有二种舍施。一受者舍施。二施者舍施。施果亦有二种。一得大财富。二得此等流受用胜解

复次当辨证成道理。问依何道理。应知宣说唯从未来非实非有诸行相生。答若未来法行相实有而得生者。此法为转而说生耶。谓从未来世处转向现在世处。为死生耶。谓未来世死生现在世。为彼为缘而得生耶。谓于未来法住不变用彼为缘于现在世有余法生。为有业用而说生耶。谓于未来本无业用至现在世方有业用。为圆满相而说生耶。谓于未来相未圆满至现在世相乃圆满。为由异相而说生耶。谓于未来有未来分及有因分。由此二种其相有异。来至现在有现在分及有果分。由此二种其相有异。如是六种诸法生起皆不应理。何以故。非无方无处。法有从异方转趣异方义。亦非未生未已生法而有死义。若彼为缘而得生者。便异法生非未来生。此于未来便为未有。又一切法第一义中无作用故。业用离相异不可得。唯即于相而假建立。设有异者。未来现在同实有相。唯说现在独有业用。理不可得。又此业用。便应本无而今得生。又与世尊微妙言说即成相违。如说诸行非常非恒汝显诸行业用无常。由此义故行应是常又等于一相。若相异分得是有者。相之异分何故不有。又相异分本无今有。相之异分何故不成本无今有。又离色等一切行相。余未来分必不可得。又应未来无有果相现在方有果相生起。如是已辨证成道理。依此道理应知。宣说未来诸法一切行相非实非有本无今有。如于未来如是。过去随其所应。由此道理当知。宣说非实非有。复次过去行云何。谓相已灭没自性已舍。现在行云何。谓相未灭没自性未舍生时暂住。未来行云何。谓因现有自相未生未得自性。问若彼诸行未来本无而得生者。空华兔角石女儿等何故不生。答由空华等无生因故。一切诸行各各差别定有生因。问若一切行各各差别有生因者。何因缘故诸行俱时不顿生耶。答诸行虽有各别生因。然必待缘方得生起。若彼彼行生缘现前。彼彼行因生彼彼行。是故诸行虽现有因。然无俱时顿生起过

复次此中云何名诸行因。何等名缘。谓薄伽梵说。诸行生缘略有四种。一因缘。二等无间缘。三所缘缘。四增上缘。因缘一种亦因亦缘。余之三种唯缘非因。云何因缘。谓诸色根根依及识。此二略说。能持一切诸法种子。随逐色根有诸色根种子及余色法种子一切心心所等种子。若随逐识有一切识种子及余无色法种子诸色根种子。所余色法种子。当知所余色法自性。唯自种子之所随逐。除大种色。由大种色二种种子所随逐故。谓大种种子及造色种子。即此所立随逐差别种子相续。随其所应望所生法。是名因缘

复次若诸色根及自大种。非心心所种子所随逐者。入灭尽定入无想定生无想天。后时不应识等更生。然必更生。是故当知心心所种子随逐色根。以此为缘彼得更生

复次若诸识非色种子所随逐者。生无色界异生。从彼寿尽业尽没已还生下时。色无种子应不更生。然必更生。是故当知诸色种子随逐于识。以此为缘色法更生复次若诸异生由世间道入初静虑。若得生彼尔时欲界诸染污法。及余欲界诸法种子。但被损伏不能永害。何以故。由此异生从彼定退欲界染法复现前故。从初静虑没已。复还生欲界故

复次损伏略有三种。一远离损伏。二厌患损伏。三奢摩他损伏。云何远离损伏。谓如有一弃舍家法趣于非家。远离种种受用欲具。受持禁戒。于所受持远离禁戒。亲近修习若多修习。由亲近修习多修习相续不断故。于诸欲具心不趣入。心不流散。心不安住。心不爱乐。亦不发起彼增上力缘彼境界所起烦恼。如是名为远离损伏。云何厌患损伏。谓如有一或由过患想。或由不净想。或由青瘀等想。或由随一如理作意。如是如是厌患诸欲。离未离欲然于诸欲修厌逆故。心不趣入乃至广说。如是名为厌患损伏。云何奢摩他损伏。谓如有一由世间道。得离欲界欲或离色界欲。彼由奢摩他任持心相续故。于欲色中心不趣入。乃至广说。如是名为奢摩他损伏。若圣弟子由出世道离欲界欲。乃至具得离三界欲。尔时一切三界染污诸法种子皆悉永害。何以故。由圣弟子于现法中不复堪任从离欲退更起下地烦恼现前。或生上地。亦不堪任从彼没已还生下地。如谷麦等诸外种子安置空迥或于干器。虽不生芽非不种子。若火所损尔时毕竟不成种子。内法种子损伏永害道理亦尔。若圣弟子将入无余涅槃界时。所有一切善及无记诸法种子皆被损害。由染污法种子灭故。不复能感当来异熟果。亦不复能生自类果。当知是名第四损伏。所谓永害助伴损伏

复次具缚者所有心起。若乐俱行或苦俱行。或不苦不乐俱行。此一切心。皆乐种子。苦种子。不苦不乐种子之所随逐。若起善心或染污心或无记心。此一切心。皆善种子染污种子无记种子之所随逐。又诸有学不具缚者所有心生。若世间善心或出世心。或染污心或无记心。此一切心。皆为一切修道所断烦恼种子之所随逐。由未断故有时得生。亦为所余诸法种子之所随逐。又诸无学一切烦恼已永断者所有心生。若世间善心。若出世心。若无记心。此一切心。皆已永离染法种子。但为一切善无记法种子随逐相续而生。复次此所建立种子道理。当知且依未建立阿赖耶识圣教而说。若已建立阿赖耶识。当知略说诸法种子。一切皆依阿赖耶识。又彼诸法若未永断。若非所断。随其所应所有种子随逐应知

问如世尊言。我说阿罗汉苾刍于四种增上心法现法安乐住中随一而退。若彼一切染污种子皆已永害。云何复起下地烦恼。若不复起彼云何退。答退有二种。一者断退。二者住退。言断退者唯是异生。言住退者。是诸圣者亦是异生。若世间道断诸烦恼复起现前。当知尔时断退故退。亦是住退。若出世道断烦恼已心营世务。不专修习如理作意。由此不能于其中间。现法乐住数起现前如先所得后亦如是。然其下地已断烦恼不复现前。如是名为住退故退。非是断退。又若已断一切烦恼成阿罗汉。而彼一切染法种子未永害者。云何名为心善解脱阿罗汉果诸漏永尽。若已永害。于相续中永无一切染法种子。尚不应起不正思惟。况诸烦恼。是故当知由出世道断烦恼者。定无有退

瑜伽师地论卷第五十一瑜伽师地论卷第五十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中五识身相应地意地之二

复次云何等无间缘。谓此诸心心所无间。彼诸心心所生。说此为彼等无间缘。若此六识为彼六识等无间缘。即施设此名为意根。亦名意处亦名意界。云何所缘缘。谓五识身以色等五境。如其次第为所缘缘。若意识以一切内外十二处为所缘缘

云何增上缘。谓眼等处为眼识等俱生增上缘。若作意于所缘境。为诸识引发增上缘。若诸心心所。展转互为俱生增上缘。若净不净业。与后爱非爱果及异熟果为先所作增上缘。若田粪水等。与诸苗稼为成办增上缘。若彼彼工巧智。与彼彼世间工巧业处为工业增上缘

复次是四缘中。因缘一种望所生法能为生因。余三种缘望所生法。当知但为方便因。是故彼彼诸行生。方便缘现在前时。彼彼诸行种子便能生起彼彼诸行。是故诸行无有同时顿生起义。当知依止如是四缘建立十因。如菩萨地等中已说

问如世尊言。过去诸行为缘生意。未来诸行为缘生意。过去未来诸行非有。何故世尊宣说彼行为缘生意。若意亦缘非有事境而得生者。云何不违微妙言说。如世尊言。由二种缘诸识得生。何等为二。谓眼及色。如是广说乃至意法。答由能执持诸五识身所不行义故。佛世尊假说名法。是故说言缘意及法意识得生。问何因缘故知佛世尊有是密意。答由彼意识亦缘去来识为境界世现可得。非彼境识法处所摄。又有性者安立有义能持有义。若无性者安立无义能持无义。故皆名法。由彼意识于有性义。若由此义而得安立。即以此义起识了别。于无性义。若由此义而得安立。即以此义起识了别。若于二种不由二义起了别者。不应说意缘一切义取一切义。设作是说。便应违害自悉弹多。又不应言如其所有非有亦尔。是如理说。是故意识如去来事非实有相。缘彼为境。由此故知意识亦缘非有为境

复有广大言论道理。由此证知有缘无识。谓如世尊微妙言说。若内若外及二中间都无有我。此我无性非有为摄非无为摄。共相观识非不缘彼境界而转。此名第一言论道理。又于色香味触。如是如是生起变异。所安立中施设饮食车乘衣服严具室宅军林等事。此饮食等离色香等都无所有。此无有性非有为摄非无为摄。自相观识非不缘彼境界而转。是名第二言论道理。又拨一切都无所有邪见。谓无施无爱亦无祠祀。广说如前。若施爱祠等无性是有。即如是见应非邪见。何以故。彼如实见如实说故。此若是无诸邪见者。缘此境界识应不转。是名第三言论道理。又诸行中无常无恒无不变易。此诸行中常恒不变无性。非有为摄非无为摄。共相观识非不缘此境界而转。若缘此境识不转者。便于诸行常恒不变无性之中。不能如实智慧观察。若不观察应不生厌。若不生厌应不离欲。若不离欲应无解脱。若无解脱应无永尽究竟涅槃。若有此理。一切有情应皆究竟随逐杂染无出离期。是名第四言论道理。又未来行尚无有生。何况有灭。然圣弟子于未来行非不随观生灭而住。是名第五言论道理。由此证有缘无意识。复有所余如是种类言论道理。证成定有缘无之识。如应当知

问如世尊言。有过去业。若过去业体是无者。不应今时有一领纳有损害受。或复不应有一领纳无损害受。此何密意。答过去生中净不净业已起已灭。能感当来爱不爱果。此业种子摄受熏习。于行相续展转不断。世尊为显如是相续。是故说言有过去业。又佛世尊观二义故作如是说。一为遮止不平等因论者意故。显此道理。谓彼妄见从大自在帝释梵王自性丈夫及所余等。一切有情净不净转。二为遮止一切无因论者意故。显此道理。谓彼妄见都无有因一切有情净不净转

问如世尊言。有过去行。于彼行中我具多闻圣弟子众无顾恋住。有未来行。于彼行中我具多闻圣弟子众无希望住。此何密意。答过去诸行与果故有。未来诸行摄因故有。所以者何。现在诸行三相所显。一是过去果性故。二是未来因性故。三自相相续不断故。为显此理故佛世尊说如是言。又观二义故作是说。一为遮断于去来法实有执故。显此道理。谓若去来诸行性相是实有者。不应由彼去来之性说言是有。二为遮断拨无执故。显此道理。谓彼妄计如去来世现在亦尔都无所有。问如世尊言。有过去界有未来界有现在界。此何密意。答若已与果种子相续。名过去界。若未与果当来种子相续。名未来界。若未与果现在种子相续。名现在界。当知此中如是密意。若苾刍等于如是种子相续中而得善巧。名于彼彼一切法中证得无量种种自性诸界善巧

复次云何应知生老住无常离色等蕴无别实有。谓已遮未来诸行实有性。当知亦遮生实有性。所以者何。未来世生自无所有。云何能生所余诸行。亦非现在生能生现在诸行。由此生相有差别名。所谓诸行若生若起。若现在性。离此差别生之异相定不可得。诸聪慧者不应说言。即由现在令彼诸行成现在性。所以者何。若作是说。生生诸行。当知义显即现在性能成现在。又一切法各各别有自种子因。何须计有异生能生。又此生相为即诸行生耶。为是诸行生因耶。若即诸行生者。计此生相能生诸行由有生故诸行得生。不应道理。若是诸行生因者。诸行生时于一一行便有二生。谓生能生。不应道理。如生如是。老住无常由此道理如应当知。故知生等于诸行中假施设。有由有因故诸行非本自相始起说名为生。后起诸行与前差别说名为老。即彼诸行生位暂停说名为住。生刹那后诸行相尽说名为灭。亦名无常

问若有为法。生老住灭四有为相具足可得。何故世尊但说三种。一生。二灭。三住异性。答由一切行三世所显故。从未来世本无而生。是故世尊由未来世于有为法。说生有为相。彼既生已落谢过去。是故世尊由过去世于有为法。说灭有为相。现在世法二相所显。谓住及异。所以者何。唯现在时有住可得。前后变异亦唯现在。是故世尊由现在世于有为法。总说住异为一有为相

问佛圣弟子应观有为具足三相。何故但说圣弟子众于诸蕴中随观生灭而住。不说随观住异性耶。答生及住异俱生所显。是故二相合为一分建立生品。即说随观一生相住。于第二分建立灭品。即说随观一灭相住。又若由此相起厌思惟。今于此中但说此相。谓于诸行中观无常相。能起厌患离欲解脱。故但思惟无常性相。无常性相本无今有。有已还无所显。本无今有。是名为生。有已还无是名为灭

复次生差别有多种。谓刹那生。相续生。增长生。心差别生。不可爱生。可爱生。下劣生。处中生。胜妙生。有上生。无上生。此中诸行刹那刹那新新而起。名刹那生。若具诸结或不具结。从彼彼有情聚没往彼彼有情聚。诸蕴续生名相续生若从婴孩童子等位。乃至往趣衰老等位。名增长生。若缘彼彼境界。于彼彼昼夜彼彼刹那腊缚牟呼栗多等位。数数迁谢非一众多种种心起。或乐相应或苦相应。或不苦不乐相应。或有贪心或离贪心。广说乃至或善解脱心或不善解脱心。如是名为心差别生。若那落迦傍生饿鬼苦趣中生。如是名为非可爱生。若于人天乐趣中生。名可爱生。若于下劣欲界中生。名下劣生。若于处中色界中生。名处中生。若于胜妙无色界生。名胜妙生。复有差别。谓最初入胎者。名下劣生。中二入胎者。名处中生。最后入胎者。名胜妙生。复有差别。谓染污法及染污果生。名下劣生。若诸善法及善果生。名胜妙生。除善不善果无记法。所余无记法生名处中生。若依堕界生说。始从欲界乃至无所有处生。名有上生。非想非非想处生。名无上生。若依堕续生刹那相续生说。除阿罗汉等最后终位。所有诸蕴余一切位所有行生。名有上生。若阿罗汉等最后终位所有行生。名无上生

复次老差别当知亦有多种。所谓身老心老寿老。变坏老自体转变老。此中衰变等乃至身坏。广说如经。是名身老。若乐受相应心变。苦受相应心转。或善心变。染污心转。或于可爱事中希望心变。希望不果心转。是名心老。若于彼彼昼夜彼彼刹那腊缚牟呼栗多等位。数数迁谢寿量损少。渐渐转减乃至都尽。是名尽老。若诸富贵兴盛退失。无病色力充悦等变。名变坏老。若从善趣增盛聚中自体没已。往于恶趣下劣聚中。自体生起。名自体转变老。复有一老为缘。能成如上所说一切种老。所谓诸行刹那刹那转异性老

复次住差别当知亦有多种。谓刹那住。相续住。缘相续住。不散乱住。立轨范住。若已生诸行生时暂停。名刹那住。若诸众生于彼彼处彼彼自体。由彼彼食为依止故。乃至寿住。外器世间大劫量住。名相续住。若乐受苦受不苦不乐受。若善不善无记法等。乃至各别缘现在前尔所时住。是名缘相续住。若诸定心由三摩地正起现前。名不散乱住。若于彼彼异方异域。国城村逻。王都王宫。若执理家商估邑义诸大众中。古昔轨范建立随转。如是名为立轨范住

复次无常差别当知亦有多种。谓坏灭无常。生起无常。变易无常。散坏无常。当有无常。现堕无常。若一切行生已寻灭。名坏灭无常。若一切行本无今有。名生起无常。若可爱诸行异相行起。名变易无常。若不变坏可爱众具及增上位离散退失。名散坏无常。即四无常在未来时。名当有无常。即现在世正现前时。名现堕无常。若受用欲尘多放逸者。但能思惟变易无常散坏无常现堕无常。广起悲叹愁愦忧悴。然于诸行不能厌离。若诸外道即于如是诸无常性。多起思惟。少能方便厌患离欲。但于诸行一分厌离不能究竟。若圣弟子圆满思惟诸无常性。于一切行究竟厌患乃至解脱

复次云何得获成就。谓若略说。生缘摄受增盛之因说名为得。由此道理当知得是假有。若言得是实有。此为是诸行生因。为是诸法不离散因。若是诸行生因者。若从先来未得此法。此既无有生因之得。应常不生。由此亦应毕竟不得。若是诸法不离散因者。一切善不善无记法得既俱有。彼虽相违应顿现行。是故二种俱不应理。又生因者。所谓各别缘所摄受诸法自种。不离散因者。谓由余缘现在前故余缘离散。若于引发缘中势力自在假立为得。以此自在为依止故。所有士夫补特伽罗。虽彼彼法已起已灭。若欲希彼复现在前。便能速疾引发诸缘令得生起。是故亦说此名为得。当知此得略有三种。一种子成就。二自在成就。三现行成就。若所有染污法诸无记法生得。善法不由功用而现行者。彼诸种子若未为奢摩他之所损伏。若未为圣道之所永害。若不为邪见损伏诸善如断善根者。如是名为种子成就。所以者何。乃至此种子未被损伏。未被永害。尔时彼染污等法。若现行若不现行皆说名成就。故若加行所生善法。及一分无记法生缘所摄受增盛因种子。名自在成就。若现在诸法自相现前转。名现行成就

复次云何命根。谓由先业于彼彼处。所生自体所有住时限量势分。说名为寿生气命根。此复多种差别。谓定不定。随转不随转。若少若多。若有边际若无边际。若自势力转若非自势力转。除赡部洲人寿分量。所余生处寿量决定。此赡部洲或时寿命广无有量。或时短促寿量不定。北拘卢洲人寿量随转。如决定量毕竟随转。无中夭故。余一切处名不随转。赡部洲人十岁时寿名为少寿。傍生一分亦名少寿。所以者何。一分傍生或一日夜寿量可得。或有一分若二若三。乃至极多十日十夜寿量可得。非想非非想处受生有情。名为多寿。经于八万大劫数故。阿罗汉等名有边际寿。若诸有学于现法中定般涅槃。若诸异生住最后有。亦名有边际寿。当知所余寿无边际。若阿罗汉等若诸如来若诸菩萨。于寿行中延促自在所有命根。名自势力转。当知所余名非自势力转

复次云何众同分。谓若略说。于彼彼处受生有情。同界同趣同生同类位性形等。由彼彼分互相似性。是名众同分。亦名有情同分。此中或有有情由界同分说名同分。谓同生一界。或有有情由趣同分说名同分。谓同生一趣。或有有情由生同分说名同分。谓同生一生。或有有情由类同分说名同分。谓同一种类。或有有情由分位体性容色形貌音声覆蔽养命同分说名同分。或有有情由过失功德同分说名同分。如杀生者望杀生者。广说乃至诸邪见者望邪见者。离杀生者望离杀生者。乃至正见者望正见者。从预流者乃至阿罗汉独觉望预流等。菩萨望菩萨。如来望如来。如是更互说名同分

复次云何异生性。谓三界见所断法种子。唯未永害量名异生性。此复略有四种。一无般涅槃法种性所摄。二声闻种性之所随逐。三独觉种性之所随逐。四如来种性之所随逐。

复次云何和合。谓能生彼彼诸法诸因诸缘。总略为一说名和合。即此亦名同事因。又此差别者。或有领受和合。谓六处缘触。或色等缘或作意等缘。或触缘受。或有引生后有和合。谓无明缘行等。受缘爱爱缘取。广说乃至生缘老死。或有六处住和合。谓四食及命根。或有工巧处成办和合。谓工巧智及彼相应业具士夫作用。或有清净和合。谓十二种无杂集会。即自他圆满等。又有世俗和合。谓诸有情依等意乐增上力故互不相违。无诤无讼亦不乖离

复次云何名身。谓依诸法自性施设自相施设。由遍分别为随言说唯建立想。是谓名身。云何句身。谓即依彼自相施设所有诸法差别施设。建立功德过失杂染清净戏论。是谓句身。云何文身。谓名身句身所依止性所有字身。是谓文身。又于一切所知所诠事中。极略相是文。若中是名。若广是句。若唯依文但可了达音韵而已。不能了达所有事义。若依止名。便能了达彼彼诸法自性自相。亦能了达所有音韵。不能了达所简择法深广差别。若依止句。当知一切皆能了达。又此名句文身。当知依五明处分别建立。所谓内明。因明。声明。医方明。世间工巧事业处明

复次云何流转。谓诸行因果相续不断性。是谓流转。又此流转差别多种。或有种子流转。谓有种子不现前诸法。或有自在势力流转。谓被损种子现行诸法。或有种果流转。谓有种子种不被损现行诸法。或有名流流转。谓四非色蕴。或有色流流转。谓诸内外十有色处及与法处所摄诸色。又有欲界流流转。谓欲缠诸行。又有色界流流转。谓色缠诸行。又有无色流流转。谓无色缠诸行。又有乐流流转。谓乐受及彼所依处。如是苦流流转不苦不乐流流转当知亦尔。又有善流流转。谓诸善行。又有不善流流转。谓诸不善行。又有无记流流转。谓诸无记行。又有顺流流转。谓顺缘起。又有逆流流转。谓逆缘起

复次云何定异。谓无始时来种种因果决定差别无杂乱性。如来出世若不出世。诸法法尔。又此定异差别多种。或有流转还灭定异。谓顺逆缘起。或有一切法定异。谓一切法十二处摄无过无增。或有领受定异。谓一切受三受所摄无过无增。或有住定异。谓一切内分乃至寿量。一切外分经大劫住。或有形量定异。谓诸有情于彼彼有色生处。所受生身形量决定。及诸外分四大洲等形量决定

复次云何相应。谓彼彼诸法为等言说为等建立为等开解诸胜方便。是谓相应。又此相应差别分别有四道理。谓观待道理。作用道理。因成道理。法尔道理。此诸道理当知如声闻地等已广分别

复次云何势速。谓诸行生灭相应速运转性。是谓势速。又此势速差别多种。或有诸行流转势速。谓诸行生灭性。或有地行有情轻健势速。谓人象马等。或有空行有情势速。谓诸飞禽空行药叉及诸天等。或有言音势速。谓词韵捷利。或有流润势速。谓江河等迅速流注。或有烧然势速。谓火焚燎猛焰飙转。或有引发势速。谓放箭转丸等。或有智慧势速。谓修观者简择所知迅速慧性。或有神通势速。谓大神通者所有运身意势等速疾神通

复次云何次第。谓于各别行相续中。前后次第一一随转。是谓次第。又此次第差别多种。或有流转次第。谓无明缘行。广说乃至生缘老死。或有还灭次第。谓无明灭故行灭。乃至生灭故老死灭。或有在家出家行住次第。谓陵旦而起澡饰其身。被带衣服修营事业。调畅沐浴涂饰香鬘。习近食饮方乃寝息。是在家者行住次第。若整衣服为乞食故入聚落等巡次而行。受如法食还出安坐。食讫澡手荡钵洗足。入空闲室读诵经典如理思惟。昼则宴坐经行。净修其心断灭诸障。至夜中分少当寝息。于夜后分速复还起。整服治身归所习业。是出家者行住次第。或入僧中随其长幼修和敬业。敷设床座次第受筹分其卧具。处所利养及营事业。或有增长次第。谓婴孩童子等八位次第生起。或有现观次第。谓于苦等四圣谛中次第现观。或有入定次第。谓次第入九次第定。或有修学次第。谓增上戒学为依。次生增上心学。增上心学为依。后生增上慧学

复次云何时。谓由日轮出没增上力故。安立显示时节差别。又由诸行生灭增上力故。安立显示世位差别。总说名时。此时差别复有多种。谓时年月半月昼夜刹那腊缚牟呼栗多等位。及与过去未来现在

复次云何数。谓安立显示各别事物。计算数量差别。是名为数。此数差别复有多种。谓一数二数。从此已去皆名多数。又数边际名阿僧企耶。自此已去一切算数所不能转。是故数之边际名不可数

复次种子云何非析诸行别有实物名为种子。亦非余处。然即诸行如是种性如是等生如是安布。名为种子亦名为果。当知此中果与种子不相杂乱。何以故。若望过去诸行即此名果。若望未来诸行即此名种子。如是若时望彼名为种子。非于尔时即名为果。若时望彼名果。非于尔时即名种子。是故当知种子与果不相杂乱。譬如谷麦等物所有芽茎叶等种子。于彼物中磨捣分析求异种子了不可得。亦非余处。然诸大种。如是种性如是等生如是安布。即谷麦等物能为彼缘令彼得生。说名种子。当知此中道理亦尔

问前已说损伏染法种子。善法种子损伏云何。答若常殷重习善。相违诸染污法。是初损伏。若执取邪见多习邪见如诸外道。是第二损伏。若多修习邪见诽谤。如断善根者。是第三损伏。若能永害染法种子。如前已说。是第四损伏

复次若略说一切种子。当知有九种。一已与果。二未与果。三果正现前。四果不现前。五软品。六中品。七上品。八被损伏。九不被损伏。若已与果。此名果正现前。若果正现前。此名已与果。若未与果。此名果不现前。若果不现前。此名未与果。若住本性。名软品。若修若练善不善法未到究竟。名中品。若修若练已到究竟。名上品。损及不损如前应知

复次我当略说安立种子。云何略说安立种子。谓于阿赖耶识中。一切诸法遍计自性妄执习气。是名安立种子。然此习气是实物有。是世俗有。望彼诸法不可定说异不异相。犹如真如。即此亦名遍行粗重。

问若此习气摄一切种子。复名遍行粗重者。诸出世间法从何种子生。若言粗重自性种子为种子生。不应道理。答诸出世间法从真如所缘缘种子生。非彼习气积集种子所生。问若非习气积集种子所生者。何因缘故建立三种般涅槃法种性差别补特伽罗。及建立不般涅槃法种性补特伽罗。所以者何。一切皆有真如所缘缘故。答由有障无障差别故。若于通达真如所缘缘中。有毕竟障种子者。建立为不般涅槃法种性补特伽罗。若不尔者。建立为般涅槃法种性补特伽罗。若有毕竟所知障种子布在所依。非烦恼障种子者。于彼一分建立声闻种性补特伽罗。一分建立独觉种性补特伽罗。若不尔者。建立如来种性补特伽罗。是故无过。若出世间诸法生已即便随转。当知由转依力所任持故。然此转依与阿赖耶识互相违反。对治阿赖耶识。名无漏界离诸戏论

瑜伽师地论卷第五十二瑜伽师地论卷第五十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中五识身相应地意地之三

复次云何表业。谓略有三种。一染污。二善。三无记。若于身语意十不善业道。不离现行增上力故。所有身语表业。名染污表业。若即于彼誓受远离。所有身语表业。名善表业。若诸威仪路工巧处一分所有身语表业。名无记表业。若有不欲表示于他。唯自起心内意思择不说语言。但发善染污无记法现行意表业。名意表业。此中唯有身余处灭于余处生或即此处唯变异生。名身表业。唯有语音名语表业。唯有发起心造作思名意表业。何以故。由一切行皆刹那故。从其余方徙至余方。不应道理。又离唯诸行生余实作用由眼耳。意皆不可得。是故当知一切表业皆是假有。

复次若有生不律仪家有所了别自发期心。谓我当以此活命事而自活命。又于此活命事重复起心欲乐忍可。尔时说名不律仪者。由不律仪所摄故。极重不如理作意。损害心所摄故。但成广大诸不善根。然未成就杀生所生。及余不善业道所生诸不善业。乃至所期事未现行。后若现行。若少若多随其所应。更复成就诸不善业。如生不律仪家如是。随是何人。随由何事起决猛心。广说应知。此人乃至不律仪思未舍已来。常得说名不律仪者。于日日分彼不善思广积集故。彼不善业多现行故。当知非福运运增长

复次此邪恶愿思。恒与不信懈怠忘念散乱恶慧俱行。能受彼业能发彼业。从此已后由种子故及现行故。处相续中现在转时名不律仪者。乃至由舍因缘未舍未弃。此中若于恶业后不爱果。不信不解亦不随入。是名不信。若随所欲于彼恶业喜乐而转。不能勤励息灭彼业。是名懈怠。若与过失相应。于有罪法不能如实明记有罪。是名忘念。若散乱染污心相续不安住转。是名散乱。若颠倒心相续而转。于诸过失见胜功德。是名恶慧。由恶尸罗增上力故。所有不善思俱行不善不信等现在转时。名恶戒者。若与此相违。如其所应当知得有律仪。随转差别者。谓有堪受律仪方可得受。此中或有由他由自而受律仪。或复有一唯自然受。除苾刍律仪。何以故。由苾刍律仪非一切堪受故。若苾刍律仪。非要从他受者。若堪出家若不堪出家。但欲出家者。便应一切随其所欲自然出家。如是圣教便无。轨范亦无。善说法毗柰耶而可了知。是故苾刍律仪无有自然受义

问若除苾刍律仪。所余律仪有自然受者。何因缘故复从他受。答由有二种远离恶戒受随护支。所谓惭愧。若于他处及于自处现行罪时深生羞耻。如是于离恶戒受随护支。乃能具受。故从他受。若有惭正现前必亦有愧。非有愧者必定有惭。是故惭法最为强胜。若有如自所受而深护持。当知所生福德等无差别。又若起心往趣师所殷勤劝请。方便发起礼敬等业。以正威仪在师前住。又以语言表宣所欲造作胜义。是名身表语表业。意表业者。谓二前行。若自然受者唯有意表业。若远离思与不律仪相违。由远离增上力故与五根俱行说名律仪。复次当知由百行所摄而受律仪。谓于十种不善业道少分离杀。乃至少分远离邪见。是名初十行。若多分离杀生。乃至多分离邪见。是名第二十行。若全分离杀生。乃至全分离邪见。是名第三十行。若少时离杀生乃至离邪见。谓或一日一夜。或半月一月。或至一年。是名第四十行。若多时离杀生乃至离邪见。谓过一年不至命终。是名第五十行。若尽寿离杀生乃至离邪见。是名第六十行。若自离杀生乃至离邪见。是名第七十行。若于此事劝进他人。是名第八十行。若即于彼以无量门称扬赞述。是名第九十行。若见离杀生者乃至离邪见者。深心庆悦生大欢喜。是名第十十行。如是十十行总说为百行。所生福量当知亦尔

复次律仪当知略有八种。一能起律仪。二摄受律仪。三防护律仪。四还引律仪。五下品律仪。六中品律仪。七上品律仪。八清净律仪。若未正受先作是心我当定受。如是远离。是名能起律仪。若正摄受远离戒时。名摄受律仪。从是已后此远离思五根摄受增上力故。恒与彼种子俱行。于时时间亦与现行俱行。即由五根所摄善思。如先所受律仪防护而转。由此思故或因亲近恶友。或因烦恼增多。随所生起恶现行欲。即便惭羞速能舍离。勿彼令我违越所受当堕恶趣。是名防护律仪。若时失念诸恶现行。即便速疾令念安住。自恳自责发露所犯蠲除忧悔。后坚守护所受律仪。是名还引律仪。若于杀等诸恶业道。少分远离少时远离。唯自远离不劝进他。不无量门称扬赞述。亦不见彼诸同法者深心庆悦多生欢喜。是名下品律仪。若于诸恶多分远离多时远离不至命终。自能远离亦劝进他。然于远离不以无量门称扬赞述。见同法者不深心庆悦生大欢喜。是名中品律仪。若于诸恶一切分一切时自能远离亦劝进他。以无量门称扬赞述。见同法者深心庆悦生大欢喜。是名上品律仪。若即于此所受律仪能无缺犯以为依止修无悔等。乃至具足入初静虑。由奢摩他能损伏力。损伏一切犯戒种子。是名静虑律仪。如初静虑如是。第二第三第四静虑当知亦尔。此中差别者。由远分对治所摄奢摩他道转深。损伏恶戒种子。当知此名初清净力所引清净律仪。若即于此尸罗律仪无有缺犯。又复依止静虑律仪。入谛现观得不还果。尔时一切恶戒种子皆悉永害。若依未至定证得初果。尔时一切能往恶趣恶戒种子皆悉永害。此即名为圣所爱戒。当知此名第二清净力所引清净律仪。即此亦名无漏律仪。此无漏律仪若得阿罗汉果时。但由能治清净胜故胜。不由所治断胜故胜。如是八种总立唯三。一受律仪。二持律仪。三清净律仪。前二是受。防护还引是持。下中上三通受持二。静虑无漏是清净摄

问何故世尊建立苾刍近事近住三种律仪。答由三因故。谓佛所化有三种类。或有能行离恶行行及离欲行。或有能行离恶行行非离欲行。或不能行离恶行行及离欲行。依初所化类建立苾刍律仪。依第二所化类建立近事律仪。何以故。非居家迫迮现处尘俗。而能一向相续圆满护众学处。依第三所化类建立近住律仪。何以故。由此不能究竟行俱离行。但当劝进摄受。二因勿彼自谓重担所镇。谓前三支修离恶行。其后四支修离欲行。离非梵行俱修二种

问苾刍近事近住律仪。当知各由几支所摄。答苾刍律仪四支所摄。何等为四。一受具足支。二受随法学处支。三随护他心支。四随护如所受学处支。若作表白第四羯磨。及略摄受。随粗学处。是名受具足支。由具此支故。名初苾刍具苾刍戒。自此以后于毗奈耶别解脱中所有随顺苾刍尸罗。若彼所引众多学处。于彼一切守护奉行。由此得名守护别解脱律仪者。是名受随法学处支。由成就此二支者所有轨范具足所行具足。是名随护他心支。轨范具足所行具足。如声闻地已说。若于微细罪中深见怖畏。于所受学诸学处中能不毁犯。设犯能出。谓由深见怖畏及聪睿故。是名随护如所受学处支。近事律仪由三支所摄。何等为三。一受远离最胜损他事支。二违越所受重修行支。三不越所受支。若永远离损害他命损坏他财损他妻妾。是名初支远离妄语。是第二支。远离诸酒众放逸处。是第三支。略说近住律仪。由五支所摄。何等为五。一受远离损害他支。二受远离损害自他支。三违越所受重修行支。四不越所受正念住支。五不坏正念支。若能远离损害他命损坏他财。是名初支。离非梵行。是第二支。所以者何。由离此者不染习自妻妾故不自损害。亦不染习他妻妾故不损害他。远离妄语是第三支。除离诸酒众放逸处离余三处。是第四支。何以故。由歌舞伎乐涂冠香鬘升高大床非时饮食常所串习。若远离彼数数自忆。我今安住决定斋戒。于一切持坚守正念。远离诸酒众放逸处。是第五支。何以故。彼虽安住正忆念支。谓我今住决定斋戒。若为诸酒所醉便发狂乱不自在转。今于此中若苾刍尼律仪。若正学勤策勤策女律仪。皆在出家品所摄故。当知摄属苾刍律仪。若近事女律仪堕在家品故。相似学所显故。当知摄属近事律仪。问何故世尊于苾刍律仪中。制立苾刍勤策二众律仪。于苾刍尼律仪中制立苾刍尼正学勤策女三众律仪。答由彼母邑多烦恼故。令渐受学苾刍尼律仪。若于勤策女少分学处深生喜乐。次应授彼正学所有学处。若于正学多分学处深生爱乐。不应率尔授彼具足。必更二年久处习学。若深爱乐然后当授彼具足戒。如是长时于少学处积修学已。次方有力能受广大众多学处。然后于苾刍尼律仪能具修学。问何故于勤策律仪中增离金银。非于近住律仪耶。答由彼勤策在出家众摄。夫出家者于二种处极非净妙。一者堕欲乐边。嬉戏严身所行所受皆随所乐。二者蓄积财宝。为除断初非净妙处。施设远离歌舞伎乐乃至非时而食。为断第二非净妙处。施设远离执受金银。由彼金银一切财宝之根本故。又最胜故。问何故于勤策律仪中。远离歌舞伎乐及涂冠香鬘。制立二支。于近住律仪中合为一支耶。答诸在家者于此处所非不如法。诸出家者极不如法。是故于在家者就轻总制为一学处。云何令彼若暂违犯寻自恳责合一发露不由二种。诸出家者于此一处就重别制以为两支。云何令彼若起违犯便自恳责二种发露不但由一

问何故不许扇搋迦半择迦出家及受具足戒耶。答由此二种若置苾刍众中便参女过。若置苾刍尼众中因摩触等便参男过。由不应与二众共居。是故不许此类出家及受具足。又由此二烦恼多故。性烦恼障极覆障故。不能发起如是思择。彼尚不能思择。思择令其戒蕴清净现行。何况当证胜过人法。是故不许彼类出家及受具戒。又彼众中好人难得亦难观察。问何故此二虽受归依亦能随受诸近事男所有学处。而不得名近事男耶。答近事男者。名能亲近承事苾刍苾刍尼众。彼虽能护所受律仪。而不应数亲近承事苾刍苾刍尼众。苾刍苾刍尼等亦复不应亲近摄受若摩若触。如是种类又亦不应如近事男而相亲善。是故彼类不得名近事男。然其受护所有学处。当知福德等无差别。

复次云何非律仪非不律仪。谓除如先所说律仪不律仪业。所有善不善等身语意业。当知一切皆是非律仪非不律仪业所摄。

问诸有律仪若由自受。若由他受。若从他受若自然受。如是所受律仪所获福德。为有胜劣差别不耶。答若等心受亦如是持。当知无有差别。

问由几因缘虽乐欲受苾刍律仪。而不应授。答苾刍律仪略由六因。一意乐损害。二依止损害。三男形损害。四白法损害五系属于他六为护他故。若有为王之所逼录。或为强贼之所逼录。或为债主之所逼迫。或由怖畏之所逼迫。或畏不活。彼如是思我处居家难可存活。是诸苾刍活命甚易。我今应往苾刍众中。诈现自身与彼同法易当活命。彼由如是谄诈意乐既出家已。虽怀恐怖守护奉行随一学处。勿诸苾刍与我同止。知我犯戒便当驱摈。然彼意乐被损害故。不名出家受具足戒。如是名为意乐损害。若复有人作如是思。我处居家难可活命。要当出家方易存济。如诸苾刍所修梵行我亦如是。乃至命终当修梵行。如是出家者不名意乐损害。虽非纯净非不说名出家受具。若有身带痈肿等疾。如遮法中所说病状。如是名为依止损害。由彼依止被损害故。虽复出家然无力能供事师长。彼由如是无力能故。所受师长同梵行者供事之业。及受纯信施主衣服饮食等净信施物。此之二种净信所施。彼极难消不应受用。令彼退减诸善法故。是故依止被损害者。不应出家受具足戒。若扇搋迦及半择迦。名男形损害。不应出家受具足戒。当知因缘如前已说。又半择迦略有三种。一全分半择迦。二一分半择迦。三损害半择迦。若有生便不成男根。是名全分半择迦。若有半月起男势用。或有被他于己为过。或复见他行非梵行男势方起。是名一分半择迦。若被刀等之所损害。或为病药若火咒等之所损害。先得男根今被断坏。既断坏已男势不转。是名损害半择迦。初半择迦名半择迦亦扇搋迦。第二唯半择迦非扇搋迦。第三若不被他于己为过。唯扇搋迦非半择迦。若有被他于己为过。名半择迦亦扇搋迦。若造无间业污苾刍尼。外道贼住若别异住若不共住。是名白法损害。不应为授具足戒。所以者何。彼由上品无惭无愧极垢染法。令惭愧等所有白法极成劣薄。若诸王臣若王所恶。若有造作王不宜业。若被债主之所拘执。若他仆隶若他劫引若他所得若有诤讼。若为父母所不开许。是名系属于他。不应为授具戒。若变化者为护他故不应为授具戒。所以者何。或有龙等为受法故自化己身为苾刍像求受具戒。若便为彼授具戒者。彼睡眠时便复本形。既睡悟已作苾刍像假想苾刍。若守园者若近事男。率尔往趣见彼身形如是变已。便于一切真苾刍所起憎恶心。谓诸苾刍皆非人类。谁能敬事施彼衣食。勿令他人得此恶见。是故为随护他。不应为彼受具足戒。由此六因不应授彼苾刍律仪。又除阙减能作羯磨。阿遮利耶邬波拖耶住清净戒圆满僧众。问由几因缘不应授彼近事男律仪。答略由二因。一意乐损害故。二男形损害故。若意乐损害者。当知一切不应为受。若男形损害者。或有为受。然不得说名近事男。不说因缘前已具辩。若近住律仪。当知唯由意乐损害不应为受。何以故。或有随他转故。或有为得财利恭敬诈称。欲受近住律仪。然彼实无求受意乐。当知是名意乐损害。若无如所说不应受因缘。当知应受如前所说所有律仪

问有几因缘苾刍律仪受已还舍。答或由舍所学处故。或由犯根本罪故。或由形没二形生故。或由善根断故。或由弃舍众同分故。苾刍律仪受已还舍。若正法毁坏正法隐没。虽无新受苾刍律仪。先已受得当知不舍。所以者何。由于尔时秽劫正起。无一有情不损意乐能受具戒。况当有证沙门果者。若近事男律仪。当知由起不同分心故。善根断故。弃舍众同分故。受已还舍。若正法隐没时。如苾刍律仪道理。当知近事男律仪亦尔。若近住律仪。当知由日出已后。或由发起不同分心。或于中间舍众同分。虽已受得必复还舍

复次云何无想定。谓已离遍净贪未离上贪。由出离想作意为先故。诸心心所唯灭静唯不转。是名无想定。此是假有非实物有。当知差别略有三种。一下品修。二中品修。三上品修。若下品修者。于现法退不能速疾还引现前。若生无想有情。天中所得依身。不甚清净。威光赫奕形色广大如余天众。定当中夭。若中品修者。虽现法退。然能速疾还引现前。若生无想有情。天中所感依身。虽甚清净光明赫奕形色广大。然不究竟最极清净。虽有中夭而不决定。若上品修者。必无有退。若生无想有情。天中所感依身。甚为清净威光赫奕形色广大。又到究竟最极清净必无中夭。穷满寿量后方殒没

复次若由此因此缘。所有生得心心所灭。是名无想

复次云何灭尽定。谓已离无所有处贪未离上贪。或复已离由止息想作意为先故。诸心心所唯灭静唯不转。是名灭尽定。此定唯能灭静转识。不能灭静阿赖耶识。当知此定亦是假有非实物有。此定差别略有三种。下品修等如前已说。若下品修者于现法退。不能速疾还引现前。中品修者虽现法退。然能速疾还引现前。上品修者毕竟不退。有学圣者能入此定。谓不还身证。无学圣者亦复能入。谓俱分解脱。前无想定非学所入亦非无学。何以故。此中无有慧现行故。此上有胜寂静住及生故。又复此定不能证得所未证得诸胜善法。由是稽留诳幻处故

复次虚空云何。谓唯诸色非有所显。是名虚空。所以者何。若处所行都无所得。是处方有虚空想转。是故当知此唯假有非实物有

复次云何非择灭。谓若余法生缘现前。余法生故余不得生。唯灭唯静名非择灭。诸所有法此时应生。越生时故彼于此时终不更生。是故此灭亦是假有非实物有。所以者何。此无有余自相可得故。此法种类非离系故。复于余时遇缘可生。是故非择灭非一向决定。若学见迹。于卵湿二生北拘卢洲无想天。若女若扇搋迦若半择迦无形二形等生。及于后有若爱若愿所得非择灭。当知一向决定。由学见迹。尝不于后有起希愿缠发生后有。唯除未无余永害爱种子故。

问何因缘故名心不相应耶。答此是假想。于诸事中为起言说。于有色等二种俱非。于有见等二种俱非。如是广说安立道理一切当知

如是已说六种善巧。谓蕴善巧乃至根善巧。云何应知是诸善巧广建立义

复次嗢柁南曰

  自性义差别　　次第摄依止

问何等是色自性。答略有十一。谓眼等十色处及法处所摄色。又总有二。谓四大种及所造色。如是一切皆变碍相

问何等是受自性。答略有六种。谓依眼等六触所生。此复二种。若色为依名身受。无色为依名心受。何以故。由前五根皆色性故。问若前五根皆是色性依眼等受名身受者。何故眼等非唯是身。答由相异故。所以者何。眼等五根展转相异。问若眼等根其相异故非皆身相。依彼诸受由是因缘应非身受。答余有色根不离身故就彼为名。此复何过。问若不离身故无过者。意根亦尔不离身转。依意根受应名身受。是即一切皆是身受无心受耶。答诸有色根定不离身。意即不尔故无有过。所以者何。生无色界有情意根离身而转。是故五根所生诸受合名身受。唯依意者独名心受。故总说二。谓身心受。又一切受皆领纳相。问何等是想自性。答此亦六种。如前应知。又想有六。一有相想。二无相想。三狭小想。四广大想。五无量想。六无所有想。又略有二。一世间想。二出世想。狭小想者。谓欲廛想。广大想者。谓色廛想。无量想者。谓空识无边处廛想。无所有想者。谓无所有处廛想。即此一切名有相想。无相想者。谓有顶想及一切出世间学无学想。又一切想皆等了相

问何等是行自性。答此亦六种。如前应知。又此行相由五种类令心造作。一为境随与。二为彼合会。三为彼别离。四能发杂染业。五令心自在转。又此行相略有三种。一者善行。二不善行。三无记行。又一切行皆造作相

问何等是识自性。答略有六种。所谓眼识乃至意识。是识自性差别。又识有三种。一领受差别。二采境差别。三分位差别。领受差别有三。采境差别有六。分位差别有三。如是识蕴差别总有十八自性。应知是名诸蕴自性。复次蕴义云何。为显何义建立诸蕴。谓所有色若去来今乃至远近。如色乃至识亦尔。如是总略摄一切蕴。积聚义是蕴义。又由诸蕴唯有种种名性诸行。当知为显无我性义建立诸蕴

复次云何色蕴差别。略由六种。一由事故。二由相故。三由识执不执故。四由识空不空故。五由想所行故。六由边际故。事者。谓所有诸色皆是四大种及四大种所造。相者。略有三种。一清净色。二清净所取色。三意所取色。又变碍相是色共相。识执不执者。若识依执名执受色。此复云何。谓识所托安危事同和合生长。又此为依能生诸受。与此相违非执受色。识空不空者。若识不空名同分色。由此与识等义转故。若识空者名彼同分色。似自相续而随转故。想所行者。谓缘色想略有三种。一者色想。二有对想。三别异想。色想亦三。一有光影相。二据方处相。三积集住相。如是三相随其次第。三想所行取青等相。名为色想。能取行碍名有对想。能取男女舍田等假名别异相。是名想所行差别。边际者。谓色边际略有二种。一堕下界。谓欲廛色。二堕中界。谓色廛色。当知此中就业增上所生诸色。说无色界无有诸色。非就胜定自在色说。何以故。由彼胜定于一切色皆得自在诸定加行令现前故。当知此色名极微细定所生色

复次云何受蕴差别。略由五种。一由事故。二由相故。三由生故。四由观察故。五由出离故。事者。谓领纳及顺领纳法。相者。谓自相及共相。自相有三。乐受苦受不苦不乐受。乐受坏苦故苦。苦受。苦苦故苦。不苦不乐受。行苦故苦。由此因缘诸所有受皆说名苦。是名受共相。生者。谓一切受。十六触所生。何等十六。谓眼触耳触。鼻触舌触。身触意触。有对触增语触。顺乐受触。顺苦受触。顺不苦不乐受触。爱触。恚触。明触。无明触。非明非无明触。由所依及所取境故。建立六触及有对触。由分别境故建立增语触。由领纳境故建立顺乐受等触。由染净故建立爱恚明无明非明非无明触。是名受生差别。观察差别者。一切如来应正等觉出现世间。皆于诸受起八种观。谓受有几种。谁为受集。谁是受灭。谁是受集趣行。谁是受灭趣行。谁是受爱味。谁是受过患。谁是受出离。如是观时如实了知受有三种。触集故受集。应知如经分别广说。如是八种观察诸受。当知略显自相。观现法转因观彼灭。观后法转因观彼灭。观彼二转因。观彼二转灭。因观及清净观。是名观察差别。出离者。谓初静虑出离忧根。第二静虑出离苦根。第三静虑出离喜根。第四静虑出离乐根。于无想界出离舍根。是名出离差别

复次云何想蕴差别。略由五种。一由事故。二由相故。三由颠倒故。四由无颠倒故。五由分别故。事者谓取所缘相及随顺彼法。相者。自相有六种。如前应知。等了相是共相。是名相差别。颠倒差别者。谓诸愚夫无所知晓。随逐无明起不如理作意。于所缘境无常计常取相而转。是名想倒。如于无常计常。如是于苦计乐于不净计净于无我计我。此想颠倒。诸在家者能发心倒。一分出家者能发见倒。是名颠倒差别。此想颠倒复有差别。谓于四事邪取其相是名想倒。若由如是等了相故于境贪着。是名心倒。若由如是等了相故有执著者。于颠倒事坚执忍可开示建立。是名见倒。无颠倒差别者。谓诸聪睿有所晓了。随智慧明起如理作意。于所缘境无常知无常。苦知是苦。不净知不净。无我知无我。正取相转。是名想无颠倒。心无颠倒。见无颠倒。是名无颠倒差别。分别差别者。略有五种想分别相。一境界分别。二领纳分别。三假设分别。四虚妄分别。五实义分别。若于境界取随味相。名境界分别。执取境界所生诸受。名领纳分别。若于自他取如是名如是类如是姓等种种世俗言说相。名假设分别。于诸境界取颠倒相。名虚妄分别。于诸境界取无倒相。名实义分别。如是总名想蕴分别差别。复次云何行蕴差别。亦由五相。一由境界故。二由分位故。三由杂染故。四由清净故。五由造作故。由境界者。谓于行蕴立六思身。由分位者。谓立生等不相应行由彼生等唯有分位所显现故。由杂染者。谓于杂染诸行建立烦恼及随烦恼。由清净者。谓于清净诸行建立信等。由造作者。谓如前说五造作相为境随与等

瑜伽师地论卷第五十三瑜伽师地论卷第五十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中五识身相应地意地之四

复次云何识蕴差别。此亦五种应知。一由安住故。二由杂染故。三由所依故。四由住故。五由异相故

云何安住。谓习欲者欲界诸识执外色尘。名色安住。若清净天色界诸识执内名色。名俱安住。无色界识唯执内名。名名安住。是名识安住差别

云何杂染差别。谓诸愚夫由二种门识被染污。一于现法中由受用境界门。二于后法中由生老等门。是名识杂染差别

云何所依差别。谓六所依诸识随转。谓依眼等六处六识身转。如世间火依糠牛粪薪札等转。是名识所依差别

云何住差别。谓四识住。如经言。有四依取以为所缘令识安住。谓识随色住缘色为境。广说如经。乃至我终不说此识往于东方乃至四维。然我唯说于现法中必离欲影寂灭寂静清凉清净。如是已显经中如来所说诸识住相。从此以后我当宣说此相差别。谓此经中略显识住及因缘相。识住因缘二种边际。识住因缘二种寂止。当知此中若诸烦恼事。若属彼烦恼。说名依取。应知此二亦名所缘。所缘性故有所缘故。由彼贪爱为烦恼缘。名趣所执事。由贪欲等四种身系。为发业缘名缘。所缘事彼二随眠所随逐故。名建立事。若诸异生补特伽罗。未得厌离对治喜爱。由所润识能取能满当来内身。由此展转能取能满。不能弃舍诸异生性。以于内身能取能满故。于流转中相续决定。是名为住。余住因缘如前应知。是名略说住及因缘相。有色界识有来有去。无色界识有死有生。又此二住乃至寿尽。又复此二生长增益及广大义。如前应知。齐是名为识住边际及住因缘边际。若复异此而施设者。当知唯有文字差别非义差别。由所余义境界无故。若他正诘不知何答。亦由余义境界无故。或复有能于后自然如理观察。便自迷闷谓我愚痴作如是说。若聪慧者于诸色爱乃至行爱所摄贪缠能永断离。于烦恼分所摄发业四身系缠亦能永断。所以者何。由在家众依贪欲嗔恚二系。发起诸业摄受境界为因故。损害有情为因故。若出家众依戒禁取。此实执取二系发起诸业。以戒禁取犹如贪欲求生天故。此实执取犹如嗔恚傍涅槃故当知四身系唯在意地分别所生故。从此以后由多修习胜对治故。复能永断贪爱身系二种随眠。由此断故烦恼所缘色受等境亦不相续。以究竟离系故。由此所缘不相续故。有随眠识究竟寂灭。于色受等诸识住中不复安住。由对治识永清净故。是名识住因缘寂止。又由当来因缘灭故。于内身分不取不满。决定无有流转相续。是名识住寂止。又复对治所摄净识名无所住。由彼因缘故名不生长。由善修习空解脱门故。名无所为。由善修习无愿解脱门故。名为知足。由善修习无相解脱门故。名为安住。如是不生长故。乃至安住故。名极解脱。又于行等都不执着我及我所。由此因缘色等坏时亦不恐怖。由此相貌显彼自体已得清净。又由彼识永清净故。不待余因任运自然入于寂灭。此识相续究竟断故。于十方界不复流转。于命及死不希求故。名永离欲。又所有受是识树影。彼于尔时不复有故。名永离影。诸有漏识于现法中毕竟灭尽故。名寂灭。诸无漏识随其次第有学解脱。名为寂静。无学解脱。名曰清凉。余依永灭故。说清净。又复诸识自性非染。由世尊说一切心性本清净故。所以者何。非心自性毕竟不净能生过失。犹如贪等一切烦恼亦不独为烦恼因缘如色受等。所以者何。以必无有独于识性而起染爱如于色等。是故唯识不立识住。是名识蕴由住差别。云何异相差别。谓有贪心离贪心有嗔心离嗔心等如经广说。乃至不解脱心极解脱心。是名一门异相差别。复有约界异相差别。谓欲界有四心。善心不善心。有覆无记心。无覆无记心。色界有三心。除不善。无色界有三心。亦除不善。无漏有二心。有学及无学。又欲界善心有二种。谓加行及生得。无覆无记心有四种异熟生心。威仪路心。工巧处心。及变化心。此唯是生得。谓天龙药叉等然无修果心。于色界中无工巧处心。无色界亦尔。当知善心如下上亦尔。一切处有。又有约种异相差别。谓欲界有五心。一见苦所断心。二见集所断心。三见灭所断心。四见道所断心。五修道所断心。如欲界有五心。如是色无色界各有五心并无漏心。总为十六。初异相心差别义。我当分别。一切有情略有三品。一未发趣定品。二虽已发趣未得定品。三已得定品。此复二种。一不清净。二极清净。于初品中或时起染污心。由贪等缠绕彼心故。或时起善无记心。由贪等缠暂远离故。第二品中或时令心于内静息。或时失念于五妙欲其心驰散。或时极静息故。便为惛沉睡眠缠覆其心。或时为断彼故。于净妙境安处其心。或时于彼不正安处心便掉举。若正安处便不掉举。由沉掉盖未断灭故。于彼二品俱不寂静。由断灭故心得寂静。若由如理作意。已得根本静虑。名定心。若未得者名不定心。道究竟故。名善修心。断究竟故。名极解脱心。与此相违。名不善修心及不解脱心。从定心已来当知是第三品。是名识蕴异相差别。复次云何诸蕴次第。谓说差别此复五种应知。一生起所作。二对治所作。三流转所作。四住所作。五安立所作。生起所作者。谓眼色为缘能生眼识。乃至意法为缘能生意识。此中先说色蕴次说识蕴。此则是诸心所所依。由依彼故受等心所生故次。经言三和故触。触缘受等。是名诸蕴生起所作宣说次第。对治所作者。为欲对治四颠倒故说四念住。谓于不净计净颠倒。于苦计乐颠倒。于无我计我颠倒。于无常计常颠倒。此中先说色蕴。次说受蕴。次说识蕴。后说想行二蕴。是名对治所作宣说次第。流转所作者。根及境界为依止故。于现法中由二种蕴受用境界起诸杂染。谓领纳境界及彩画境界。由一种蕴造作一切善不善业。于后法中起生老等一切杂染。一是所染故最后说。住所作者。由四识住及识次第而说。是名住所作。安立所作者。谓诸世间互相见已先了其色。是故先立色蕴。次由受蕴知彼进退或苦或乐。是故次立受蕴。次由想蕴知彼如是名如是类如是性等。是故次立想蕴。次由行蕴知彼如是愚痴如是聪睿。是故次立行蕴。后由识蕴安立内我。谓于诸蕴中安立所了有苦有乐。随起言说及愚智等。是名诸蕴安立所作宣说次第。又复依止我众具事及我事故。应知诸蕴宣说次第。谓我依身于诸境界受用苦乐。于己于他随起言说。谓如是名如是种类如是性等。此之二种依法非法方得积集。如是应知我众具事。当知最后蕴是我事

复次色蕴摄几蕴几界几处几有支几处非处几根耶。如色蕴如是乃至识蕴。谓色蕴摄一蕴全。十界十处全。一界一处少分。六有支少分。处非处少分。七根全。受蕴摄一蕴全。一界一处少分。一有支全。三有支少分。处非处少分。五根全。三根少分。想蕴摄一蕴全。一界一处少分。三有支少分。处非处少分。不摄诸根。行蕴摄一蕴全。一界一处少分。四有支全。五有支少分。处非处少分。六根全。三根少分。识蕴摄一蕴全。七界全。一处全。一有支全。四有支少分。处非处少分。一根全。三根少分。如是有六种摄。所谓蕴摄乃至根摄。由此相摄道理。展转相摄如应当知

复有余十种摄应当了知一者界摄。谓诸蕴等各自种子所摄。二者相摄。谓诸蕴等自相共相所摄。三种类摄。谓诸蕴等遍自种类所摄。四分位摄。谓诸蕴等顺乐受等分位所摄。五不相离摄。谓诸蕴等由一一法及诸助伴摄一切蕴等。六者时摄。谓诸蕴等过去未来现在各自相摄。七者方摄。谓诸蕴等在此方转或依此生即此方摄。八者全摄。谓诸蕴等五等所摄。九少分摄。谓诸蕴等各各差别少分所摄。十胜义摄。谓诸蕴等真如相所摄如是诸蕴一切摄义总有十六。如蕴乃至根亦尔。又由三法摄一切法。谓色蕴法界意处。复次依止几处色蕴转耶。依止几处名所摄四蕴转耶。谓依止六处色蕴转。一建立处。二覆藏处。三资具处。四根处。五根住处。六有威德定所行处。依止七处名所摄四蕴转。一乐欲。二希望。三境界。四寻伺。五正知。六清净方便。七清净。诸受用欲者。依止四处。住律仪者精进行者。依止一处。已得近分定者。依止一处。安住根本定者。依止一处。如是七处略有四位应知。复次我当先说分别色蕴一一别义。然后分别名四蕴义。云何分别色蕴。嗢拖南曰

  物极微生起　　安立与流业
  刹那独所行　　余相杂最后

问色蕴中眼几物所摄。答若据相摄唯有一物。谓眼识所依清净色。若据不相离摄则有七物。谓即此眼及与身地色香味触。若皆据界摄则有十物。即此七物界及水火风界。如眼耳鼻舌当知亦尔。此中差别者。谓耳耳识所依清净色。鼻鼻识所依清净色。舌舌识所依清净色。余如前说。若身当除眼等四。何以故。由远离彼独可得故。此相者谓身识所依清净色。若于外色香味触彼所行相中。除一切根余一切如前应知。声及声界不恒有故。今当别说。若于是处有声。当知此处复增其一。应知声界一切处增。复次色等所缘境界。如本地分已广分别。若触处中所说造色滑乃至勇。当知即于大种分位假施设有。谓于大种清净性假立滑性。于大种坚实性假立重性。于大种不清净不坚实性假立涩性及轻性。于大种不清净慢缓性假立软性。由水与风和合生故假立有冷。由阙任持不平等故假立饥渴及弱力。由无所阙无不平等故假立强力及饱。由不平等变异错乱不平等故假立病。由时分变异不平等故假立老。由命根变异不平等故假立死。由血有过患不平等故假立痒。由恶饮食不平等故假立闷绝。由地与水和合生故假立黏。由往来劳倦不平等故假立疲极。若远离彼由平等故假立憩息。由除垢等离萎瘁故假立勇锐。如是一切说诸大种总有六位。谓净不净位。坚不坚位。慢缓位。和合位。不平等位。平等位。如是六位复开为八。若八若六平等平等。复次一切色乃至触。皆二识所识。谓自识所识及意识所识。或渐或顿。眼等五根一意识所识

复次色界中无现香味然有彼界。何以故。此二皆是叚食摄故。由无此二鼻舌二识亦无。此就现行说非就界说

如是一切色蕴所摄色中。九种是实物有。触所摄中四大种是实物有。当知所余唯是假有。堕法处色亦有二种。谓实有假有。若有威德定所行境犹如变化。彼果彼境及彼相应识等境色是实物有。若律仪色不律仪色皆是假有。又定所行色若依此系定。即由此系大种所造。又此定色但是世间有漏无漏由定而生。非出世间由此定色有戏论行定为因故。又非一切所有定心皆有能生此色功能。唯一类有如能起化。谓不思惟。但由先时作意所引。离诸闇昧极善清净明了现前。当知是定乃能生色。若定力励数数思惟。假胜解力而得见者。当知不能生起此色。又复此色虽非出世定之所行。然由彼定增上力故有一能现。当知此事不可思议

问欲色二界实物有色何差别耶。答色界诸色清净最胜能发光明。又极微细下地诸根所不行故又无有苦。依彼诸色苦受不生故。欲界不尔。是名差别

复次色蕴略由六相应知。一自相。二共相。三能依所依相属相。四受用相。五业相。六微细相。自相者。谓地等以坚等为相。眼等以各别清净色为相。共相者。谓一切色皆变碍相。能依所依相。属相者。大种为所依。造色是能依。受用相者。为内色处有所受用增上力故。外色境界差别而生。或有色聚唯有坚生。或唯有湿或唯有暖。或唯有动或和合生。为欲随顺内诸色处受用差别故。业相者。谓地等诸大种。以依持摄受成熟增长为相。复有余业后当广说。微细相者。谓极微相

复次微细性略有三种。一损减微细性。二种类微细性。三心自在转微细性。损减微细性者。谓分析诸色至最细位。名曰极微。种类微细性者。谓风等色及中有色。心自在转微细性者。谓色无色二界诸色。如经说。有等心诸天。曾于人中如是如是资熏磨莹其心。随此修力住一毛端空量地处。展转更互不相妨碍。如是等辈应当思惟观察色蕴物类差别。问诸极微色由几种相建立应知。答略说由五种相。若广建立如本地分。何等为五。一由分别故。二由差别故。三由独立故。四由助伴故。五由无分故。分别建立者。谓由分别觉慧分析诸色。至极边际建立极微。非由体有。是故极微无生无灭。亦非色聚集极微成。差别建立者。略说极微有十五种。谓眼等根有五极微。色等境界亦五极微。地等极微复有四种。法处所摄实物有色极微有一。独立建立者。谓事极微建立自相故。助伴建立者。谓聚极微。所以者何。于一地等极微处。所有余极微同聚一处不相舍离。是故依此立聚极微。问何因缘故诸有对法同处一处不相舍离。而不说名无对性耶。答随顺转故。由彼展转相随顺生不相妨碍。又由如是种类之业增上所感如是而生。何以故。一切色聚一切色根共受用故。若异此者。一切聚中非有一切地等诸色不相舍离。若尔眼等诸识境界。便不遍满一切聚中。如是应无遍满受用。是故当知定有诸色同一处所不相舍离。又有诸色。或于是处互相妨碍。或于是处不相妨碍。如中有色等。而彼诸色非无对性。此中道理当知亦尔。无分建立极微者。谓非彼极微更有余分。非聚性故。诸聚极微可有细分。若极微处即唯此处。更无细分可以分析

问如是所说五相极微复有五眼。所谓肉眼。天眼。圣慧眼。法眼。佛眼。当言几眼用几极微为所行境。答当言除肉眼天眼所余眼用一切极微为所行境。何以故。以彼天眼唯取聚色中表上下前后两边若明若闇。必不能取极微处所。由极微体以慧分析而建立故

问何故说极微无生无灭耶。答由诸聚色最初生时全分而生。最后灭时不至极微位。中间尽灭犹如水滴

复由五相应知名不如理思议极微。谓于色聚中有诸极微自性而住。应知名初不如理思议极微。或谓极微有生有灭。或谓极微与余极微或合或散。或谓众色于极微量积集而住。或谓极微能生别异众多色聚。应知名后不如正理思议极微。故应方便以如理思思议极微。断此五种非理思议

复次建立极微当知有五种胜利。谓由分析一合聚色安立方便。于所缘境便能清净广大修习。是初胜利。又能渐断萨迦耶见。是第二胜利。如能渐断萨迦耶见。如是亦能渐断憍慢。是第三胜利。又能渐伏诸烦恼缠。是第四胜利。又能速疾除遣诸相。是第五胜利。如是等类应当如理思惟极微复次略说色物生当知有五种。何等为五。一依止生。二种子生。三势引生。四摄受生。五损减生

云何依止生。谓于所依大种处所。有余所造色生。故如是说由四大种造所造色是同一处摄持彼义。又若于此色积聚中。有彼大种及所造色自相可得。当知此中即有彼法。若于此处彼法自相都不可得。当知此处无有彼法。是名总建立有非有相。若有说言于此处所彼法自相虽不可得然必有者。今应问彼。此不可得与可得者。为物是等为不等耶。若物等者。物既是等而不可得。不应道理。若不等者。为即此量说物不等。为据威势说不等耶。若即此量说不等者。少分自相亦不可得。不应道理。若据威势说不等者。离彼自相有余威势不可得故。不应道理。如是等类当知名依止生

云何种子生。谓所有色各从自种子所生如坚硬聚。或时遇缘便生流湿。流湿遇缘复生坚硬。不暖生暖暖复生冷。不动生动动生不动。如是好色恶色等差别应知。由如是等虽无自相然有其界。从彼彼聚彼彼色法差别而生。如是等类当知名种子生

云何势引生。谓内色根增上力故。外分差别相续而生。谓器世界等。又由先业势所引故。内诸色处差别而生。又复诸天或现前欲或不现前欲。及北拘庐洲所有资具。当知多分势引而生差别而转。人中相续生者唯有器世界。如是等类当知名势引生

云何摄受生。谓遇彼彼摄受缘故。彼彼色法展转增益胜上而生。犹如水等润萌茅等。如是等类名摄受生。与此相违应知名损减生

复次诸聚色生时。如种种物石磨为末以水和合团杂而生。非如苣蕂麦豆等聚。何以故。随彼生因增上力故。如是而生为有用故

问若一切行皆自种子所生。何因缘故说诸大种造所造色。答由彼变异而变异故。彼所建立及任持故。由三因缘大种变异令所造色变异而转。一士夫用故。二业所作故。三由胜定故。士夫用者。谓由地大所打触故。器差别故。田差别故。令所造色变异可得。或由水所润等火所熟等风所燥等。令所造色变异可得。当知是名由彼大种士夫用故令所造色变异而生。业所作者。随业势力先大种生。后随彼力色变异生。是名业所作故。由胜定者。胜定力故先起大种。然后造色变异而生。当知是名由胜定故大种变异因此造色变异而生

复次略由五缘所有大种令其异果转成异果。何等为五。一大种力故。二士夫用力故。三明咒力故。四神通力故。五业所作力故

问从此没已。何因何缘。中有色聚续得生耶。答当知此色用自种子为因。感生业为缘

问何因得知有中有耶。答从此没已。若无所依诸心心所。无有道理转至余方故。不应如响唯惑乱故。不应如影彼不灭故。亦不应说如取所缘。非行往故。由如是等所说譬喻。不应道理。是故当知定有中有。如是等类应当思惟色蕴生起复次色蕴生时谁为先首据其处所。依此处所余色转耶。当知大种先据处所。后余造色依此处转。唯诸大种于此处所现前。障碍所余造色自相遍满。当知由彼势力任持有所据碍

复次地等诸四大种。随其次第粗显应知。谓地界及果。能持最胜水火风等流润烧然动摇等业。依止彼。故方得流转

复次诸声才宣发已寻即断灭。故于色聚中不恒相续。又此音声依质生时。质处及外俱顿可得。随所闻处于此处所。遍满顿起如焰光明。非渐渐生展转往趣

复次风有二种。谓恒相续不恒相续。诸轮行风名恒相续。在空行者名不恒相续。在物行者名恒摄受。又当知风机关运转名恒相续。所余当知非恒相续

问何等名空界。答明闇所摄造色说名空界。此亦二种。一恒相续。二不恒相续。若诸有情所居处所常闇常明名恒相续。余不尔处非恒相续。当知此亦依止色聚。又此空界光明摄者名为清净。隙穴摄者名不清净

问诸长短等所说形色。当言实有为假有耶。答当言假有。何以故。积集而住故名为形。唯有众色积集可得。余形色相不可得故。又必相待。相待之法有自性者。彼法便有杂乱过失。又如车等。彼觉可坏故。复次法处所摄胜定果色中。当知唯有显色等相。何以故。于彼香等生因阙故。又无用故。如是于空行风中。无有俱生香等。唯有假合者。又离轮外所发光明。所余大种及与香等皆不可得。又法处所摄胜定果色。当知此色唯依胜定不依大种。然从缘彼种类影像三摩地发故。亦说彼大种所造。非依彼生故名为造

问于色蕴中几法由有见有对故住。几法由无见有对故住。几法由无见无对故住。答一由二种。谓眼所行。余唯有对。除法处所摄色。当知此色无见无对。如是等类应当思惟色蕴安立。复次色蕴由几种流而相续转。谓由三种。一等流流。二异熟生流。三长养流。初等流流复有四种。一异熟等流流。二长养等流流。三变异等流流。四本性等流流。异熟流者。复有二种。一者最初。二者相续。谓业生异熟及异熟所生。谓即从彼业力所引异熟后时转者。长养流者。亦有二种。一处宽遍长养流。二相增盛长养流。初长养流唯色长养。当知由食睡眠梵行等至长养诸色。余长养流当知亦由食故。彼所依故。修胜作意故。长时淳熟故。而得长养。诸有色法由二长养之所长养。诸无色法唯相增盛说名长养。又欲界色具由四食及余一切长养因缘而得长养。色界诸色不由段食睡眠梵行而得长养。又诸色根当知由二种流而得流转。以诸色根离异熟长养。相续流外无别等流流。问异熟相续有时亦有增长广大可得。何故异熟摄流非即长养耶。答由别有长养相续能摄能持异熟等流流故。现有增长等若非根所摄色。当知具三种流。诸心心所有等流流异熟生流第二长养所长养流。法处所摄色无异熟生流余如心心所应知。又欲界中具有内外诸色成熟。于色界中远离香味。又欲界中诸色根成熟或具不具。于色界中必具诸根。又诸声界亦有异熟非声。如是等类应当思惟色蕴流义。复次色蕴所摄地界能为几业。乃至风界能为几业。当知一切皆为五业。谓地界能为打触变坏业。建立业。与依止业。违损业。摄受业。水界能为流润业。摄持业。溉灌业。违损业。摄受业。火界能为照了业。成熟业。烧然业。违损业摄受业。风界能为发动业。随转业。消燥业。违损业。摄受业。又诸大种于所生造色。当知能作五业。谓生起业。依止业。建立业。任持业。增长业。于彼变异生时能为导首故。变异生已与彼为处不相舍离能为依止故。摄受损害安危共同能建立彼故。持彼本量令不损减故能任持。令彼积集增进广大故能增长。问眼耳所行善不善色。彼何因缘成善等性非余色耶。答若略说由软中上品三种思差别故。一加行思。二决定思。三等起思。由此能起若善不善身语表业。当知上品思为依止故能发善不善业

问依止聚色而有运动。当言与彼异不异耶。答当言不异。何以故。于彼处所若生不生或灭不灭而有运动。皆有过失可得故。问有何过失。答若言生而有动便越刹那相。若言不生便应无动。若言灭者应与余等。若言不灭便越行相。又于异处生起因缘分明可得。是故当知无别运动实物可得。如是等类应当思惟色蕴作业

复次一切色蕴当言皆是刹那灭性。何以故。诸行才生寻即坏灭。现可得故。又不应谓能生之因即是灭因。其相异故。又法生已余停住因不可得故。是故当知一切诸行皆任运灭。由此道理刹那义成。若谓火等是灭坏因。不应道理。何以故。由彼火等与彼诸行俱生俱灭现可得故。唯能为彼变异生缘说有作用。又谓坏灭是坏灭因。不应道理。何以故。与彼俱生不应理故。若彼生时即有坏灭。便成相续断坏过失。又唯自性灭坏说名为灭。而言能为灭因。不应道理。若言别有灭坏自性离彼法外别有灭相。毕竟不可得故。不应道理。若谓火等为灭助伴方能灭者。于灯电等及心心所任运灭中不可得故。不应道理。若谓生彼有别别功能。此差别不可得故。不应道理。若谓二种于一处所有灭功能。即应二种俱于两分有灭功能或无功能有过失故。不应道理。如是等类应当思惟色蕴刹那灭义。谓由任运坏灭因故。遮计火等为灭因故。遮计灭相为灭因故。遮计二种为灭因故。如是等类尽当了知。又一切行是心果故。当知如心皆刹那灭

复次所造色于诸大种。当言有异相耶。当言无异相耶。谓有异相。何以故。异相可得故。此中异相者。谓异根所行故。所以者何。由余色根能取大种。复由余根取所造色故。又可运转不可运转。现可得故。谓从众花运转香气置苣蕂中世现可得。非彼坚等而可运转。又变异不变异现可得故。谓煎酥等中有色味等变异差别可得。非彼坚等。是故当知大种造色其相有异。若于异相而执为一。于诸大种亦应尔耶。由诸大种其相展转互相异故。若许尔者。应当唯有一大种耶。是故当知诸所造色望彼大种定有异相。如是等类应当思惟诸大种色独非独相

复次诸色所摄法。几是根性。几是所行性。谓五是根性。六是所行性。问何等所行境。是根所行耶。答若根不坏等。如本地分中已广说。谓由依处故。或由相故。或由方故。或由时故。或由明了不明了故。或由全事一分事故。问由几因缘说诸根坏及不坏耶。答由二因缘。一由羸损故。二由全坏故。与此相违当知不坏。又略由四缘诸根变异。一由外缘所生。谓由受用摄受损坏外境界故。或由他辈所损益故。二由内缘所生。谓由各别不如理作意所生贪等诸缠烦恼故。或由如理作意所生三摩钵底等故。三由业缘所生。谓由先业增上缘力感得端正丑陋等故。四由自体变异所生。谓彼诸根自相差别故。问由几因缘意根坏耶。答由四因缘。一由盖所作。谓于五盖中随由一盖覆蔽其心。二由散乱所作。谓由鬼魅娆乱其心。三由未证所作。谓彼内心犹未证得静虑无色胜品功德。然于其中强发作意。四由未解所作。谓于多闻工巧等事。心未纯熟强施方便

云何色等境界望彼诸根名为现前谓色于眼非合非闇非极细远。亦非有障名为现前。要唯有见有明无障在可行处乃名现前。又于一眼虽闇障色亦名现前。声于耳根亦必非合非极细远得名现前。有障无障若明若闇在可行处皆名现前。香味触三于鼻舌身。唯合能取在可行处。乃名现前。所行境界。若诸天眼唯照有见有障无障。若明若闇若近若远。皆名现前。然在可行处非不可行处。若圣慧眼一切种色皆是所行

问如本地分说六种所行性。此何差别耶。答初所行性。谓有情世间所摄色及器世间所摄色。第二所行性。谓由三自性。自性差别故。相差别故。作用差别故。分位差别故。色相差别者。谓青黄赤白等乃至广说。作用差别者。谓有表无表。律仪不律仪。非律仪非不律仪所摄作用。分位差别者。谓可意不可意色及顺舍处色。声相差别者。谓执受大种为因。非执受大种为因。执受非执受大种为因。作用差别者。谓语表业。分位差别者。如前应知。香相差别者。谓根茎皮实华叶果香。作用差别者。谓香味触皆无作用分位差别。如前应知。味相差别者。谓甘苦等如前已说。触相差别亦如前说多种应知。第三所行性。谓东南西北等方维差别。应知第四所行性。谓过去未来现在差别应知。第五所行性。谓取实不实差别应知。第六所行性。谓取一分事或遍满事差别应知。如是等类是名诸色境界现前差别应知

云何名为能生作意。谓由所依不坏故。境界现前故。所起能引发心所。如是等类应当思惟色蕴所行相

复次在欲界者依欲界身。发起色界大种。现前彼诸大种。云何与下界色共住。为异处耶非异处耶。当言如水处沙非住异处。如是等类应当思惟色蕴互相杂住

瑜伽师地论卷第五十四瑜伽师地论卷第五十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中五识身相应地意地之五

如是已思择色蕴。我次当说名所摄四无色蕴。随所应建立相。如本地分立一心相。今先显示。如世尊言。若有众生于如来所。但发一心及一言说善逝大师善逝大师。如是发心。我尚说彼于诸善法多有所作。何况身语如其心量随顺奉行。又如是言由一净心当往善趣。如是等类当知此中依转所摄相续一心。由世俗道名发一心。又依世俗相续道理。名发一语及发身业。问有分别心无分别心。当言同缘现在境耶。为不同耶。答当言同缘现在境界。何以故。由三因故。谓极明了故。于彼作意故。二依资养故。问染心生时。当言自性故染。为相应故。为随眠故。答当言相应故随眠故。非自性故。若彼自性是染污者。应如贪等毕竟不净。若尔大过。由彼自性不染污故。说心生时自性清净。问诸烦恼缠于心二种染污因中当言何等。答当言相应。问此中何等说名随眠。答诸烦恼品所有粗重不安隐性。又持诸行令成苦性。是故圣者由行苦故现观为苦。于诸行中安住苦观。云何观耶。如毒热痈乃至广说。如有寻有伺地应如是观

复有三种染恼心法。当知普摄一切染恼。所谓业染恼受染恼烦恼染恼。初二染恼唯欲界系。最后染恼通三界系。问何等名为心烦恼缚。答一切随眠。问何等名业缚。答乐着事业名为业缚。又于三处为障碍业亦名业缚。谓于出离心。于得出离喜乐。于得圣道。又顺异熟障业亦名业缚。又邪愿业亦名业缚。如是四种别开有六总合为四

问诸识生时。与几遍行心法俱起。答五。一作意。二触。三受。四想。五思。问复与几不遍行心法俱起。答不遍行法乃有多种。胜者唯五。一欲。二胜解。三念。四三摩地。五慧

作意云何。谓能引发心法触云何。谓三和合故能摄受义。受云何。谓三和合故能领纳义。想云何。谓三和合故施设所缘假合而取。此复二种。一随觉想。二言说随眠想。随觉想者。谓善言说人天等想。言说随眠想者。谓不善言说婴儿等类乃至禽兽等想。思云何。谓三和合故令心造作。于所缘境随与领纳和合乖离。欲云何。谓于彼彼境界随趣希乐。胜解云何。谓于彼彼境界随趣印可。念云何。谓于彼彼境界随趣明记。三摩地云何。谓于彼彼境界随顺趣向。为审虑依心一境性。慧云何。谓于彼彼境界随顺趣向简择诸法。或如理观察。或不如理观察。或非如理非不如理观察。复次作意为何业。谓于所缘引心为业。触为何业。谓受想思所依为业。受为何业。谓爱生所待为业。想为何业。谓于所缘令心彩画言说为业。思为何业。谓发起寻伺身语业为业。欲为何业。谓发生勤励为业。胜解为何业。谓于所缘功德过失或俱相违印持为业。念为何业。谓于久所思所作所说记忆为业。三摩地为何业。谓智所依为业。慧为何业。谓于言论所行染污清净随顺考察为业

问此不遍行五种心法。于何各别境事生耶。答如其次第于所爱决定串习观察四境事生。三摩地慧于最后境。余随次第于前三境。问诸名所摄与心相应所余蕴法。当言率尔起耶。寻求耶决定耶。答若依彼类心。当言即彼类

问如经言。此四无色蕴当言和合非不和合。不可说言如是诸法可分可析令其差别。何故彼法异相成就而说和合无差别耶。答众多和合。于所缘境受用领解方圆满故。若不尔者。随阙一种于所为事应不圆满

问诸心心法。凡有几种差别名耶。答有众多名。谓有所缘。相应。有行。有所依等无量差别。问何故眼等亦有境界。而但说彼名有所缘。非眼等耶。答由彼眼等离所取境亦得生起。心与心法则不如是。问何故名相应。答由事等故。处等故。时等故。所作等故。问何故名有行。答于一所缘作无量种差别行相转故。问何故名有所依。答由一种类托众所依差别转故。虽有为法无无依者。然非此中所说依义。唯恒所依为此量故

问何故乐望苦受苦望乐受。若乐若苦望非苦乐说互相对。答由自种类而不同分。互相对故。问何故不苦不乐受望彼无明说互相对。答由与诸受一切烦恼皆为助伴。互相对故。问何故明与无明说互相对。答能治所治互相对故。问何故明与涅槃说互相对。答因果相属互相对故。云何建立四无色蕴。为善不善无记性耶。谓一切无差别。嗢拖南曰

  依处与自由　　相应世俗等
  软等事差别　　德失能所治

问善法依处有几种。答略说有六。一决定时。二止息时。三作业时。四世间清净时。五出世清净时。六摄受众生时。问何等为自性。答谓信惭愧。无贪无嗔。无痴精进。轻安不放逸。舍不害。如是诸法名自性善。问如是诸法互相应义云何应知。答于决定时有信相应。止息杂染时有惭与愧顾自他故。善品业转时有无贪无嗔无痴精进。世间道离欲时有轻安。出世道离欲时有不放逸。及舍摄受众生时有不害。此是悲所摄故。问是诸善法几世俗有几实物有。答三世俗有。谓不放逸舍及不害。所以者何。不放逸舍是无贪无嗔无痴精进分故。即如是法离杂染义建立为舍。治杂染义立不放逸。不害即是无嗔分故无别实物

问何等名软善根。答诸不定地所有善根。或在定地而能对治上品烦恼。问何等名中品善根。答若在定地世间善根。或能对治中品烦恼。问何等名上品善根。答谓出世间所有善根。或能对治下品烦恼。又诸善法或由加行力。或由串习力。或由自性力。或由田士力。或由清净力。当知成上品

问善根生时依几种事而得生耶。答若略说依八种事。一施所成福业事。二戒所成福业事。三修所成福业事。四闻所成事。五思所成事。六余修所成事。七简择所成事。八摄受有情所成事。当知此中随其所应依所说事。或于现法或于后法。随为一种贪嗔恶见于心相续。先成秽染。既被染已。由彼对治令于是处不复相应

问何等名为善法差别。答或有一种乃至十种。如本地分已广宣说。又诸善法或有对治杂染故。或有杂染静息故。或有摄受可爱果故。或有相续清净故。或有供养灵庙故。或有摄受有情故。如是等类善法差别应当了知。复次善法无有过失有何功德。善法功德有无量种。谓能净治心令离烦恼缠及随眠。令于所缘无有颠倒。能令善根坚固不退。令等流行相续而转。不为自害不为他害。不为俱害。不生现法罪。不生后法罪。不生现法后法罪。能令受彼所生喜乐能尽生为上首所有众苦。又能增长涅槃胜解。能亲近彼。能令财位无有退失。处众勇猛无惧无畏。广大名称流布十方。为众圣贤之所称赞。临命终时不生忧悔。身坏已后生诸善趣。于诸善法令无退失。能速随证自所求义。如是等类诸善功德无边无量。当尽了知

云何建立诸善对治由十五种。谓厌患对治故。断对治故。持对治故。远分对治故。所欲趣缠对治故。非所欲趣缠对治故。随眠对治故。软品烦恼对治故。中品烦恼对治故。上品烦恼对治故。散乱对治故。谏悔对治故。羸劣对治故。制伏对治故。离系对治故

复次诸染污法二相所显。一本烦恼。二随烦恼。今当先说本烦恼。后当分别随烦恼

问本烦恼有几种依处。答六。一与无明俱可意杂染境界。二与无明俱不可意杂染境界。三与不如理作意俱杂染境界。四与无明俱劣等胜有情各别五取蕴得未得颠倒功德颠倒。五与无明不如理作意俱听闻不正法。六与无明不如理作意俱于听正法而生懈怠。当知最初欣乐和合依处。第二欣乐别离依处。第三于境颠倒依处。第四陵蔑上慢依处。第五邪执法行依处。第六不修正行不为还灭依处

问烦恼自性有几种。答有六种。一贪。二嗔。三无明。四慢。五见。六疑

问何烦恼与何烦恼相应。答无明与一切疑都无所有。贪嗔互相无。此或与慢见。谓染爱时或高举或推求。如染爱憎恚亦尔。慢之与见或更相应。谓高举时复邪推构

问是诸烦恼几世俗有几实物有。答见世俗有是慧分故。余实物有别有心所性

问是诸烦恼云何建立软中上品。答最后所断名软品。中间所断名中品。最初所断名上品。复由六因诸烦恼成上品。一淫欲所生烦恼性多上品。二串习所生烦恼性多上品。三安足处烦恼。谓根熟者性多上品。四不可治烦恼。谓无涅槃法者性多上品。五非处加行烦恼。谓于尊重福田等所性多上品。六有业烦恼。谓正发业者性多上品

问烦恼生时由几烦恼事而得生耶。答贪由十事生。一取蕴。二诸见。三未得境界。四已得境界。五已所受用过去境界。六恶行。七男女。八亲友。九资具。十后有及无有

问何贪于何事生耶。答随其次第十贪于十事生。何等为十。谓事贪见贪。贪贪悭贪。盖贪恶行贪。子息贪亲友贪。资具贪有无有贪

嗔事亦有十种。一己身。二所爱有情。三非所爱有情。四过去怨亲。五未来怨亲。六现在怨亲。七不可意境。八嫉妒。九宿习。十他见。嗔亦有十。如其次第依彼而生。依前六事立九恼事。缘彼一切嗔皆名有情嗔。余名境界嗔。若不忍为先亦有情嗔。若宿习嗔若见嗔。如是十嗔略有三种。一有情嗔。二境界嗔。三见嗔。无明依七事起。一世事。二世间安立事。三运转事。四最胜事。五真实事。六杂染清净事。七增上慢事。依此七事起七无知。或复十九当知于初事由三种门生疑惑。于第二事由内六处若外若俱生我我所怨亲等见。于第三事由业异熟及俱生作者受者无因恶因见。于第四事诽谤三宝。于第五事诽谤诸谛。于第六事起邪解行。于第七事依得自义起增上慢

慢依六事生。一劣有情。二等有情。三胜有情。四内取蕴。五已得未得颠倒。六功德颠倒。依此六事生七种慢。谓慢过慢等。当知二慢依胜有情事生。余各依一事

见依二事生。一增益事。二损减事。增益事有四种。一我有性增益。二常无常性增益。三增上生方便增益。四解脱方便增益。损减事亦有四种。一谤因。二谤果。三谤作用。四谤善事。当知此中谓无施与乃至无妙行恶行。是名谤因。谓无妙行恶行业果异熟。是名谤果。谓无此世间乃至无化生有情。名谤作用。所以者何。诸士夫用是此中作用义。此士夫用复有四种。一往来用。二持胎藏用。三置种子用。四后有业用。若谓世间无阿罗汉等。名谤善事。依此广略八事二事。生于五见。谓萨迦耶见。边执见。见取。戒禁取。邪见。又依六十二事生边执见及邪见。谓计前际事计后际事。如经广说。依此事差别有六十二见。疑依六事生。一闻不正法。二见师邪行。三见所信受意见差别四性自愚鲁。五甚深法性。六广大法教

问何等名为烦恼差别。答一切差别略有十五。一内门烦恼。二外门烦恼。三见断烦恼。四修断烦恼。五可爱趣缠所摄烦恼。六非可爱趣缠所摄烦恼。七随眠所摄烦恼。八软品烦恼。九中品烦恼。十上品烦恼。十一散乱位烦恼。十二谏悔位烦恼。十三羸劣位烦恼。十四制伏位烦恼。十五离系位烦恼复次烦恼无有功德有多过失。谓于缠位污心相续。广说如有寻有伺地。复次烦恼非能对治。虽复经言依爱断爱依慢断慢。然非烦恼。但是善心加行希求高举行相与彼相似。假说爱慢

复次如前说十五种心对治差别。当知烦恼是彼所治亦十五种

复次随烦恼依处当知略有九种。一展转共住。二展转相举。三利养。四邪命。五不敬尊师。六不忍。七毁增上戒。八毁增上心。九毁增上慧

复次随烦恼自性云何。谓忿恨覆恼。嫉悭诳谄。憍害无惭。无愧惛沈。掉举不信。懈怠放逸。忘念散乱。不正知恶作。睡眠寻伺。如本地分已广诠说。如是等类名随烦恼自性

此中初二依初依处而生。第三第四依第二。第五第六依第三。第七第八依第四。第九依第五。第十依第六。十一十二依第七。所余十二依后二依处而生

当知此中毁增上心毁增上慧由三门转。一由毁止相门。二由毁举相门。三由毁舍相门。惛沉睡眠由初依处生。掉举恶作由第二依处生。不信乃至寻伺由第三依处生

复次随烦恼云何展转相应。当知无惭无愧与一切不善相应。不信懈怠放逸忘念散乱恶慧与一切染污心相应。睡眠恶作与一切善不善无记相应所余当知互不相应

复次随烦恼几世俗有几实物有。谓忿恨恼嫉害是嗔分故皆世俗有。悭憍掉举是贪分故皆世俗有。覆诳谄惛沉睡眠恶作是痴分故皆世俗有。无惭无愧不信懈怠是实物有。放逸是假有。如前说。忘念散乱恶慧是痴分故一切皆是世俗有。寻伺二种是发语言心加行分故及慧分故俱是假有

复次随烦恼云何成软中上品。当知如本烦恼说。如是随烦恼若事若差别若过失若所治。随其所应皆如烦恼应知复次诸无记法依处当知略有四种。谓业所引生。生已若行住。若养命。若三摩地差别。复次彼自性云何。谓异熟生蕴若中庸加行所摄威仪路及工巧处。若为嬉戏加行所摄变化

问彼云何展转相应耶。答威仪路工巧处或于一时展转相应如说。或有事业行时易作非住非坐亦非偃卧。乃至或有事业若行若住若坐若卧皆悉易作。如经广说。所余无有展转相应

问是诸无记几实物有几是假有。答于异熟所摄诸蕴及心加行差别中而施设故。当知一切皆世俗有

云何彼成软中上品。谓异熟生及威仪路不猛利故俱是软品。诸工巧处性猛利故说名中品。当知变化性极猛利故是上品。又四种类各有差别。谓无色界异熟是软品。色界异熟是中品。欲界异熟是上品。若坐若卧是软。威仪住是中。威仪行是上。威仪初习业者是下工巧。已串习者是中工巧。堪为师者是上工巧。下品修三摩地所得是软变化。中品修三摩地所得是中变化。上品修三摩地所得是上变化。如是等类软中上品差别应知。问是诸无记依何事生。答当知略说依十二事。如闻所成地已说

云何诸无记差别。谓异熟生五趣别故。五种差别。若威仪路威仪别故四种差别。若工巧处十二事差别故即十二种差别。异生声闻独觉菩萨如来差别故。为嬉戏为利他身语变化差别故。当知变化八种差别。由此差别即摄余事故不别说。又异熟生一向无记。二三可得一有二种。若依伎乐以染污心发起威仪。是染污性。若依寂静即是善性。若依染着发起工巧是染污性。若善加行所起工巧。即是善性。为引导他或为利益诸有情故。而起变化当知是善此无染污

复次如是五蕴几谛所摄。又此诸谛几蕴所摄。当知三谛五蕴更互相摄。灭谛诸蕴互不相摄。由灭谛性是彼寂静所显故

问如声闻地已说于四谛中有十六行观。何故于苦谛为四行观。答为欲对治四颠倒故。谓初一行对治初一颠倒。次一行对治次二颠倒。后二行对治后一颠倒。问何故于集谛为四行观。答由有四种爱故。此四种爱当知由常乐净我爱差别故。建立差别。初爱为缘建立后有爱。第二第三爱为缘建立喜贪俱行爱及彼彼希乐爱。最后爱为缘建立独爱。当知此爱随逐自体。又爱云何。谓于自体亲昵藏护。后有爱云何。谓求当来自体差别。喜贪俱行爱云何。谓于现前或于已得可爱色声香味触法起贪着爱。彼彼希望爱云何。谓于所余可爱色等起希求爱。问何故于灭谛为四行观。答由四种爱灭所显故。问何故于道谛为四行观。答由能证彼四爱灭故

复次如声闻地已说坏等十种行相。此中无所得云何。谓唯有根唯有境界。唯有彼所生受。唯有彼所生心。唯有计我我想。唯有计我我见。唯有我我言说戏论。除此七外余实我相了不可得。不自在云何。谓众缘生无常苦相所摄。诸行离我相故

问此十行相由何行相摄坏苦耶。答由结行相及变坏增上所起忧恼。当知是坏苦性。非唯变坏。已离忧者虽复遇彼不为害故。问何等行相摄苦苦耶。答由不可爱行相。问何等行相摄行苦耶。答由不安隐行相

复次如经言。生苦乃至略摄五取蕴苦。如是诸苦相几苦苦摄。谓初五。几坏苦摄。谓中二。几行苦摄。谓后一。复次初七苦苦摄。彼所对治净妙烦恼。坏苦摄。最后一行苦摄。由世尊言入变坏心。又作是言由盖缠故领彼所生心诸忧苦。故知烦恼坏苦。故苦道理成执。复次如经言有四种苦。一者生苦。二缘内苦。三缘外苦。四粗重苦。问此中何行摄何苦何苦摄何行。答初行初苦展转相摄。次有三行。与第二苦展转相摄。次有三行。与第三苦展转相摄。最后一行与最后苦展转相摄。前所说爱自性差别建立集谛四种行相。当知为生今果差别四种苦故

复次此十六行几是空行。谓二。即苦谛后二行。几是无愿行。谓六。即苦谛前二行及集谛一切。几是无相行。谓灭谛一切。几是清净因所显行。谓道谛一切

问要由无常想能住无我想。何故此中先说空耶。答此约无我观已生由无常观建立无愿。以此二观前后展转互修治故

复次四圣谛说次第者。谓由此故苦此最为初。如此故苦此为第二。此二摄黑品究竟。由此故乐此为第三。如此故乐是为第四。此二摄白品究竟。譬如重病病因病愈良药又有差别。谓如世间遭苦次第。当知建立圣谛次第。所以者何。如诸世间曾所遭苦。即于此处先发作意。次于遭苦因。次于苦解脱。后于解脱方便发起作意。问谛义云何。答如所说相不舍离义。由观此故到清净究竟义。是谛义。问苦谛义云何。答烦恼所生行义。问集谛义云何。答能生苦谛义。问灭谛义云何。答彼俱寂静义。问道谛义云何。答能成三谛义

问如是四圣谛为世俗谛摄。为胜义谛摄。答胜义谛摄。何以故。于顺苦乐不苦不乐诸行中。由自相差别故建立世俗谛。由彼共相一味苦故当知建立胜义谛

问何缘故说遍知苦谛。永断集谛。触证灭谛。修习道谛。答由彼苦谛是四颠倒所依处故。为除颠倒故遍知苦。既遍知苦即遍知集。由彼集谛苦谛摄故。虽遍知苦仍为集谛之所随逐。故须更说永断集谛。言触证者。是现见义。由于灭谛现前见故不生怖畏爱乐摄受。是故次说触证灭谛。若勤修道乃能成办所说三义。是故后说修习道谛

问谛现观有几种。此复何相。答决定义是现观义。此则于诸谛中决定智慧及彼因彼相应彼共有法为体。是名现观相。此复六种应知如有寻有伺地说

此中云何名初现观。谓于诸谛决定思惟。云何名为第二现观。谓三宝所三种净信。由于宝义已决定故。及闻所成决定智慧

云何名为第三现观。谓圣所爱戒。于恶趣业已得决定不作律仪故

云何名为第四现观。谓于加行道中先集资粮极圆满故。又善方便磨莹心故。从世间顺决择分边际善根。无间。有初内遣有情假法缘心生。能除软品见道所断烦恼粗重。从此无间第二内遣诸法假法缘心生。能除中品见道所断烦恼粗重。从此无间第三遍遣一切有情诸法假法缘心生。能除一切见道所断烦恼粗重。又此现观即是见道。亦名双运道。此中虽有毗钵舍那品三心及奢摩他品三心。然由双运合立三心。以于一刹那中止观俱可得故。当知此诸心唯缘非安立谛境。又前二心法智相应。第三心类智相应。又即由此心势力故。于苦等安立谛中。有第二现观位清净无碍苦等智生。当知依此智故苦集灭道智得成立。即前三心并止观品能证见断烦恼寂灭。能得永灭一切烦恼及所依事。出世间道。是名现观智谛现观

云何名为现观边智谛现观。谓此现观后所得智。名现观边智。当知此智第三心无间从见道起方现在前。缘先世智曾所观察下上二地及二增上安立谛境。似法类智世俗智摄通世出世。是出世间智后所得。如其次第于一一谛二种智生。谓忍可欲乐智及现观决定智。如是依前现观起已。于下上诸谛中二二智生。是名现观边智谛现观。此中前智遣假法缘故是无分别。后智随逐假法缘故是有分别。又前智于依止中能断见断烦恼随眠。后智思惟所缘故令彼所断更不复起。又前智能进趣修道中出世断道。第二智能进趣世出世断道。无有纯世间道能永害随眠。由世间道是曾习故。相执所引故。如相执所引如是。亦不能泯伏诸相。如不能泯伏诸相。如是亦不能永害粗重。是故彼道无有永害诸随眠义

云何名为究竟现观。谓由永断修所断故。所有尽智无生智生。或一向出世。或通世出世。于现法中一切烦恼永断决定故。于当来世一切依事永灭决定故。名究竟现观。何等名为出世尽智。谓若智于尽无分别。何等名为世出世尽智。谓若智于尽有分别。何等名为出世无生智。谓即此依事灭因义故。于当来世依事不生中所有无分别智。何等名为世出世无生智。谓于当来世依事不生中。所有有分别智

复次有种姓婆罗门。建立三处为实为谛。然彼种姓诸婆罗门于此三处住三过失污其心故。依第一义彼皆堕在非梵志数。何等三处。一为养命。二为修福。三安立果。为养命者。谓彼种姓诸婆罗门为活命故。于施主前或咒愿或赞美或序述。咒愿者谓彼种姓诸婆罗门。希求随一资生具故。往诣王所或王大臣或婆罗门长者居士商主等所。矫设咒愿。当愿汝等所有怨敌皆悉殄灭横遭殃祸摧屈缚录又愿汝等所有吉祥常无转动不可侵夺。赞美者。为希求故往到彼所矫设赞美言。汝勇健多诸计策善害怨敌。又于害怨假兴赞述唱言。汝曹如是如是害除怨敌甚为希有。如汝等辈世间难得。又于财位久兴盛者矫施赞述言。诸世间如汝吉祥成就无动甚为难有。序述者。谓彼为希求故往到他所妄兴序述言。汝成就善丈夫相。不久定当一切怨敌皆悉殄灭横遭殃祸摧屈缚录。又若成就如是相者。定当吉祥无有退转。又如汝等诸亲友家若施主家。常无有余沙门婆罗门于中受施执为己有。唯我常得恭敬供养衣服饮食诸卧具等。彼由如是方便所获利养深生染着。耽嗜迷闷坚固保执而受用之。为修福者。谓彼种姓诸婆罗门。宣说。杀害无量众生兴祠祀福。宣说祠祀获常处果。又兴祠祀时召命无量国王大臣长者居士。为欲摄受上妙众多资生具故。彼既获已执为我所。展转互起凌蔑之心。当知彼有如是三失。安立果者。谓彼种姓诸婆罗门。说阿素洛身应可杀害天身是常。唯婆罗门最上种姓。余姓下劣。广说乃至诸婆罗门大梵所生大梵所化大梵支胤。彼种姓婆罗门作如是计立如是论。当知是名安立果。如是种姓婆罗门于此三处猛利取执随兴言论。唯此是实是谛余并愚妄。何等名为由三过失染污其心。谓语言过失。憍慢过失。胜解过失。若即于此三处邪语业转。当知是名语言过失。若复于此三处施设建立。及随发起不正言论。方比于他谓己为胜或等或劣。当知是名憍慢过失。若复于此三处不观德失一向信受。虽遇诸佛及佛弟子正教诲时。于处非处不能正住。于遍分别不能正住。于诸正行不能正住。于智者论不能正住。当知是名胜解过失。此三过失当知皆是恶见所起。若有住此三处成就三种过失。虽是种姓诸婆罗门依第一义。彼皆堕在非梵志数

复次若有建立三处为谛为实。又于三处无三过失染污其心。彼虽非种姓婆罗门然堕第一义婆罗门数。何等三处。谓不应害一切众生。是名初处。此所说处唯谛唯实无有虚妄。是故于此初处。无语言过失染污其心。又彼于是处。不由谛实言论方比于他谓己为胜若等若劣。是故彼于此处。无憍慢过失染污其心。又彼于此处审观德失。观彼所缘能增善法。又能摄益身心无罪现法乐住。于诸有情多住慈想昼夜修学。又于此处非信他行。内自正觉为谛为实。然于谛实不妄执着。是故当知彼于此处无胜解过失染污其心。如是一切行无常。是名第二处。余如前说。一切法无我。是名第三处。余如前说。此中差别者。于第二谛。应言于一切行多住生灭观昼夜修学。于第三谛。应言于一切法多住无我我所想昼夜修学。若有于此三处无三过失染污其心。彼虽非种姓婆罗门然堕第一义婆罗门数。如是三处成婆罗门谛实之法。离三过失唯有如来是真觉者

瑜伽师地论卷第五十五瑜伽师地论卷第五十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中五识身相应地意地之六

问诸蕴分位有几种。答有多种。谓得无想定等心不相应行。广说如前

问依何分位建立。得此复几种。答依因自在现行分位建立。得此复三种。谓种子成就自在成就。现行成就

问依何分位建立无想定灭尽定及无想天。此三各有几种。答依已离遍净贪未离上贪出离想作意为先。名灭分位。建立无想定。此复三种。自性者唯是善。补特伽罗者在异生相续。起者先于此起。后于色界第四静虑当受彼果。依已离无所有处贪止息想作意为先。名灭分位。建立灭尽定。此复三种。自性者唯是善。补特伽罗者在圣相续。通学无学。起者先于此起。后于色界重现在前。托色所依方现前故。此据未建立阿赖耶识教。若已建立于一切处皆得现前。依已生无想有情天中名灭分位。建立无想此亦三种。自性者无覆无记。补特伽罗者唯异生性。彼非诸圣者。起者谓能引发无想定思。能感彼异熟果。后想生已是诸有情便从彼没

问依何分位建立命根。此复几种。答依业所引异熟住时决定分位建立命根。此复三种。谓定不定故。爱非爱故。岁劫数等所安立故。问依何分位建立众同分。此复几种。答依诸有情相似分位立众同分。此复三种。所谓种类同分。自性同分。工巧业处养命同分

问依何分位建立生。此复几种。答依现在分位建立生。此复三种。所谓刹那生。相续生。分位生。问依何分位建立老。此复几种。答依前后分位建立老。此复三种。谓异性老。转变老。受用老。问依何分位建立住。此复几种。答即依生分位建立住。此复三种。谓刹那住。相续住。立制住。问依何分位建立无常。此复几种。答依生已坏灭分位建立无常。此复三种。谓坏灭无常。转变无常。别离无常

问依何分位建立名身。此复几种。答依假言说分位建立名身。此复三种。谓假设名身。实物名身。世所共了不了名身。如名身。句身文身当知亦尔。此中差别者。谓标句释句。音所摄字所摄

问依何分位建立异生性。此复几种。答依未生起一切出世圣法分位。建立异生性。此复三种。谓欲界系。色界系。无色界系

问依何分位建立流转。此复几种。答依因果相续分位建立流转。此复三种。谓刹那展转流转。生展转流转。染污清净展转流转。问依何分位建立定异。此复几种。答依法别相分位建立定异。此复三种。谓相定异。因定异。果定异。问依何分位建立相应。此复几种。答依因果相称分位建立相应。此复三种。谓和合相应。方便相应。称可道理所作相应。问依何分位建立势速。此复几种。答依迅疾流转分位建立势速。此复三种。谓诸行势速。士用势速。神通势速。问依何分位建立次第。此复几种。答依一一行流转分位建立次第。此复三种。谓刹那流转次第。内身流转次第。成立所作流转次第。问依何分位建立时。此复几种。答依行相续不断分位建立时。此复三种。谓去来今。问依何分位建立方。此复几种。答依所摄受诸色分位建立方。此复三种。谓上下傍。问依何分位建立数。此复几种。答依法齐量表了分位建立数。此复三种。谓一数二数多数。问依何分位建立和合。此复几种。答依所作支无阙分位建立和合。此复三种。谓集会和合。一义和合。圆满和合。问依何分位建立不和合。此复几种。答与和合相违。应知不和合若分位若差别

问于诸蕴中。何义几蕴是有色。答即以此性还说此性。色自性义是有色义。一蕴是有色。问何义几蕴是有见。答眼所行义一蕴一分是有见。问何义几蕴是有对。答展转相触据处所义。及粗大义。是有对义。粗大义者。当知远离三种微细。此三微细如前应知一蕴一分是有对。问何义几蕴是有漏。答粗重所随非彼对治烦恼所生义。一切一分是有漏。复有有漏义。谓若是处烦恼能生四种过失是有漏义。何等名为四种过失。一不寂静过失。二内外变异过失。三发起恶行过失。四摄受因过失。当知初过失缠现行所作。第二过失诸烦恼事随逐烦恼所作。第三过失烦恼因缘所作。第四过失引发后有所作。问何义几蕴是有为。答从因已生及应生义。一切是有为。问何义几蕴是有诤。答多随嗔恚自在转义。一切一分是有诤。问何义几蕴是有爱味。答多随爱见自在转义。一切一分是有爱味。问何义几蕴是依耽嗜。答多随欲贪自在转义。一切一分是依耽嗜。问何义几蕴是世间。答戏论依义。一切一分是世间。问何义几蕴是堕界。答三界所摄世间义。一切一分是堕界。问何义几蕴是过去。答已受用因果义。一切是过去。问何义几蕴是未来。答未受用因果义。一切是未来。问何义几蕴是现在。答已受用因义及未受用果义。一切是现在。问何义几蕴是内。答六处并属彼义。一蕴一分四蕴全是内。问何义几蕴是外。答内相违义。一蕴一分是外。问何义几蕴是粗。答不光洁积聚相增长义。一切一分是粗。问何义几蕴是细。答粗相违义。一切一分是细。问何义几蕴是劣。答无常苦不净染污义。一切一分是劣。问何义几蕴是妙。答劣相违义。一切一分是妙。问何义几蕴是远。答处所去来时方隔越义。一切一分是远。问何义几蕴是近。答远相违义。一切一分是近

问何义几蕴是欲界系。答于此间生未得对治。或得已出三时现行义。一切一分是欲界系。问何义几蕴是色界系。答已得色界系对治。若入彼定或复生彼。未得上对治。或得已出三时现行义。一切一分是色界系。问何义几蕴是无色界系。答已得无色界系对治。若入彼定或复生彼。未得上对治。或得已出三时现行义。一切一分是无色界系。复有差别。谓轻安俱三摩地。及彼眷属并彼果法所不摄义。是欲界系属色烦恼。与彼相违所摄义。是色界系。离色烦恼彼所摄义。当知是无色界系

问何义几蕴是善。答能感当来乐果报义。及烦恼苦永断对治义。一切一分是善。问何义几蕴是不善。答能感当来苦果报义。及能发起诸恶行义。一切一分是不善。问何义几蕴是无记。答彼俱相违义。一切一分是无记。复有差别。谓离过失义。及过失功德对治随顺义。是善。与此相违义。是不善。彼俱相违义。是无记

问何义几蕴是学。答学方便善义。一切一分是学。问何义几蕴是无学。答学究竟善义。一切一分是无学。问何义几蕴是非学非无学。答离前二种所有善染污无记法义。一切一分是非学非无学。问何义几蕴是见所断。答现观智谛现观所应断义。一切一分是见所断。问何义几蕴是修所断。答从现观后修道所断义。一切一分是修所断。问何义几蕴是无断。答一切染污永断对治义。及已断义。一切一分是无断。问何义几蕴是无色等。答如前所说色等相违义。当知是无色等义。如是等类应当分别诸蕴差别。问如说积聚义是蕴义。何等名为积聚义耶。答种种所召体义。更互和杂转义。一类总略义。增益损减义。是积聚义

问何缘色蕴说名为色。答于彼彼方所种殖增长义。及变碍义故名为色。此变碍义复有二种。一手等所触便变坏义。二方处差别种种相义

问何缘四无色蕴总说名名。答顺趣种种所缘境义。依言说名分别种种所缘境义故说为名

问诸蕴谁所摄。为何义故建立摄耶。答自性所摄非他性。为遍了知种种自类。是故建立。问诸法谁相应。为何义故建立相应。答他性相应非自性。为遍了知依自性清净心有染不染法若增若减是故建立

有一沙门若婆罗门。欲令名中唯心实有非诸心所。此不应理。何以故。且说诸蕴有五种性不成就故。又若彼计分位别故有五性者。分位别计亦有过失。何以故。是诸分位展转相望作用差别。若有若无皆成失故。若言有者。由相异故便应有异实物体性。若言无者。计分位别则为唐捐。又不应谓如六识身分位差别。何以故。由六识身所依所缘有差别故。是诸分位一处可得故不应理。若谓转变亦不应理。何以故。于有色物可转变故。得有分位前后差别。非于无色有如乳酪生酥等异。又心因缘无差别故。行别分位不应道理。于一刹那必不可得差别因缘令彼分位而有差别。是故汝计分位差别不应道理。又违教故。唯心实有不应道理。违何等教。谓如经言贪嗔痴等恼染其心令不解脱。问此中何所相违。答若唯有心二不俱有。是即贪等应不依识。若汝复谓以识为先亦不应理。无差别过前已说故。又复经言与触俱生受想思等。又余经说如是诸法恒共和合非不和合。不可说言如是诸法而可分析令别殊异。又佛世尊为欲成立此和合义说灯明喻。是故不可离彼俱生而说和合。虽复经言如是六界说名士夫。然密意说故无过失。问此中有何密意。答唯欲显说色动心所最胜所依。当知是名此经密意。复有违彼圣教。可得何等圣教。谓世尊言乳酪生酥三譬喻故。或有处所粗四大种以之为我。或有处所有色意生。或有处所无色想生。如是经意。岂唯大种。或唯有心。唯有想耶。是故当知如是等经皆有密意。故名所摄四无色蕴心与心所。更互相应道理成就。中嗢拖南曰

  五种性不成　　分位差过失
  因缘无别故　　与圣教相违

如是已决择蕴事善巧。界事善巧今当决择。问何等是眼界。答若眼未断。或复断已命根摄受。如眼界乃至意识界及法界一分当知亦尔。问何等是色界。答若色根增上所生。若彼于此为增上。是名色界。如色界乃至触界当知亦尔

问此十八界几是实有几是假有。答实有者或十七或十二。六为一故一为六故。此约世俗安立道理

问若有眼亦眼界耶。设有眼界亦眼耶。答应作四句。或有眼非眼界。谓阿罗汉最后眼。是名初句。或有眼界非眼。谓生有色界若眼未生或生已失。或不得眼或眼无间灭。若诸异生生无色界。是第二句。或有眼亦眼界。谓除尔所相。是第三句。或有无眼亦无眼界。谓阿罗汉眼已失坏或不生眼。若生无色界或于无余依涅槃界已般涅槃。是第四句。如眼界。一切内界随其所应当知亦尔。身界应分别。谓无先来不生身者。余随所应当具宣说。于四外界随其所应亦当具说。若声声界正宣击时当言俱有。若不宣击当言随逐余界唯界非声

问此十八界几是同分几彼同分。答有识眼界名为同分。所余眼界名彼同分。如眼界乃至身界亦尔。唯根所摄内诸界中。思量同分及彼同分。非于色等外诸界中。当知法界诸有所缘如心界说。诸无所缘如色等说

问几界合而能取。几界不合能取。答六合能取。四不合能取。五及一少分非能取。一界若合不合二俱能取。问几唯所取非能取。几亦所取亦能取耶。答一切皆所取。谓五及一少分唯所取。十二及一少分亦是能取。问几由助伴故能取。几独能取耶。答十及一少分由助伴故能取。一及一少分独能取。问几唯欲界系。答四。问几唯色界系。答无。问几唯无色界系。答亦无。问几唯欲色界系。答十一。问几唯色无色界系。答无。问几通三界系。答三

问几执受几非执受。答五执受。五执受非执受。所余一向非执受。何以故。以离于彼余能执受。执受于彼不可得故

云何种种界。谓即十八界展转异相性。云何非一界。谓即彼诸界无量有情种种差别所依住性。云何无量界。谓总彼二名无量界。如佛世尊于恶叉聚喻中说。我于诸界终不宣说界有边际中。嗢拖南曰

  何等实有性　　四句与同分
  取界执受非　　种种等非一

问何等是界义。答因义。种子义。本性义。种性义。微细义。任持义。是界义。问以何义故涅槃虚空亦说名界。答由彼能持苦不生义。持身眼等运动用义

问为显何义建立界耶。答为显因缘义。及显根境受用义

问此十八界由谁分别。答若略说当知由六种。一法界。谓眼等法有眼等界。二净界。谓住种性补特伽罗所有诸界。三本性界。谓即如所说十八界无始时来于后后生其性成就。及住种性不住种性补特伽罗。无始时来涅槃非涅槃法其性成就。四熏习界。谓即此诸界净不净法先所熏习。于生死中得胜劣生涅槃因性。五已与果界。谓即此诸界感果已灭。六未与果界。谓即此诸界未感得果或灭未灭。如是略说诸界有六种若广说者其数无量

问此十八界几有色几无色。乃至几无断耶。答如前所说相应随顺建立。问如说眼见诸色乃至意了诸法。此为眼等是见者乃至是了者耶。为彼识耶。答约胜义道理。非是眼等亦非彼识。何以故。诸法自性众缘生故。刹那灭故。无作用故。约世俗道理。眼等最胜故可于彼立见者等。何以故。若有眼等诸根。识决定生无所缺减。或有识流非眼等根。若缺不缺俱可得故。此中实义唯于见等说见者等

问此十八界几种次第宣说因缘。此复何等。答略有二种。一三种次第宣说因缘。二六种次第宣说因缘。云何三种次第宣说因缘。谓所依境界俱依差别故。所以者何。由识与根同一处义故说名依境界。是所缘义故亦名依。云何六种次第宣说因缘。谓彼所行众多差别数数行故先说眼等。是初因缘。又随世间俗事转故说彼次第。由诸世间先互相见。次相慰问次设饮食。次过昼分夜分现前。敷设种种软妙卧具毡褥被枕。触习侍女。是第二因缘。又喜乐差别为依止故次第宣说。是第三因缘。又严饰差别所摄受故次第宣说。诸受欲者必以安缮那等先庄眉眼。次以耳珰耳轮等庄严其耳。非于余根如是严饰。是第四因缘。又依作业饮食习欲等事次第宣说。由诸众生皆先依止身语二业若净不净方便勤求。次食段食。既饱醉已习近诸欲。是第五因缘。又由作业差别摄受故次第宣说。所以者何。由眼能见种种诸色。往还无失威仪不乱。记识他身曾见不见及怨亲中。了悟方所宣示于他起想言说。睹众舞乐角力戏等。广受种种世间喜乐长养依身。如是等类有无量种眼界作业。由耳能闻种种音声。因此了悟善说恶说种种义理起诸言论。因闻种种微妙乐音。广受种种世间喜乐长养依身。如是等类耳界作业。比前狭劣。鼻界能嗅种种诸香。寻香而往。受诸喜乐长养依身。如是等类鼻界作业。方前狭劣。舌界能尝种种诸味。受诸喜乐长养依身。如是等类舌界作业。方前狭劣。身界能触种种所触受诸喜乐。虽能长养依身。然彼乐具或于一时复为损害。如是等类身界作业。最为狭劣。是名第六次第宣说因缘。于此眼等六种因缘差别中。意遍行故最后宣说。为摄如是次第因缘中。嗢拖南曰

  众多顺世俗　　喜乐与庄严
  随二种作业　　故次第宣说

复次此十八界。当知能摄一切经中所说余界

问生色界者已于境界而得离欲。何缘复生鼻舌两界。答为令所依身端严故。又色界中于此二种未离欲故。问生第二静虑或生上地。若有寻有伺眼等识现在前。云何此地无寻无伺若不现前。云何于彼有色诸根。而能领受彼地境界。答由有寻有伺诸识种子随逐无寻无伺三摩地故。从彼起已此得现前。又此起已识现行时。复为无寻无伺三摩地种子之所随逐。是故此地非是一向无寻无伺。由彼有情于诸寻伺以性离欲而离欲故。彼地虽名无寻无伺。此复现行亦无过失。问何缘眼界耳界鼻界。各生二分非余。答为令依止得端严故。问眼耳与鼻。诸识生时为依二分。当言一耶当言二耶。答当言唯一。何以故。若彼一分无障不坏。识明了生。若彼有障或复失坏。识不明了生故。又识非色故。无有如色由方所别成二分义

问眼与眼识若是因果云何俱有。若俱有者云何得成因果两性。答识依眼生。非如种芽因果道理。何以故。眼与眼识非正生因。唯建立因。是故此二俱时而有因果性成。犹如灯焰光明道理。如眼与眼识。耳鼻舌身与彼诸识当知亦尔。若异此者。虽有自种无所依故。眼等诸识应不得生

问若于欲界或生或长。当言眼界决定转耶。答此非一向。如眼界。耳鼻舌界及彼识界当知亦尔。身界决定转。如是身识界意界法界意识界色声香味触界亦尔

问若于色界或生或长。当言眼界决定转耶。答决定转。如眼界如是。耳鼻舌身界眼耳身识界亦尔。除香味界及彼识界。余一切界亦决定转。于无色界或生或长。除意界法界意识界。余定不转。唯除自在所获诸色。当知三界于彼定转

界事善巧。如蕴善巧亦应宣说嗢拖南颂。如界善巧。处事善巧嗢拖南颂当知亦尔

云何眼处。谓若眼已得不舍。于无间体非断灭法。如眼处相。余处自性当知亦尔

问处触处何差别。答处如前说。触处者。谓与触俱或能无间引发诸触。随顺于触所有诸处

问若眼亦处耶。设处亦眼耶。答有眼非处。谓若眼已得不舍。然是无间断灭之法。有处非眼。谓所余处安住处相。有亦眼亦处。谓若眼已得不舍。亦非无间断灭之法。有非眼非处。谓若眼不得或得已舍。及余耳等不住处相。

问若处亦触处耶。设触处亦处耶。答诸触处必是处。有处非触处。谓眼等不与触合。亦复不能引无间触。然非无间断灭之法。若于色界或生或长所有鼻舌。若生无想有情天中所有诸根。于一切时当知必定非处

问处名何义。为显何义建立处耶。答诸心心所生长门义。缘义。方便义。和合性义。所依止义。居住处义。是名处义。为欲显示等无间所缘增上三种缘义故。建立处。广分别处及次第。随其所应如界当知

又世尊言有八胜处。广说如经。如是十遍处又有四处。谓空无边处等。又有二处。谓无想处。非想非非想处。如是等法处名说者。如所说相随其所应当知皆在十二处摄。又处依止如界应知

复次云何名缘生法。谓无主宰无有作者无有受者。无自作用不得自在。从因而生托众缘转。本无而有有已散灭。唯法所显唯法能润。唯法所润堕在相续。如是等相名缘生法。

当知此中因名缘起果名缘生。此无明随眠不断有故。彼无明缠有。此无明缠生故。彼诸行转。如是诸行种子不断故。诸行得生。诸行生故得有识转。如是所余诸缘起支流转道理。如其所应当知亦尔

当知有生及老死支是假有法。所余有支是实有法

复由五相建立缘起差别。何等为五。一众苦引因依处。二众苦生因依处。三众苦引因。四众苦生因。五众苦生起。众苦引因依处者。谓于现法中名色为缘六处生起不断不知。此为所缘及依处故。一切愚夫于内自体愚痴生起。是名无明。无明缘故次后诸行。乃至后时有触缘受。此中六处名无明等。引因依处。众苦生因依处者。谓诸愚夫触为缘故。于现法中诸受生起。此为依处。于外境界发起诸爱。由爱为缘次后有取。取为缘故次后有有。如是爱等三种生因。用触缘受为所依处众苦引因者。谓无明缘行乃至触缘受。现法中识为福非福及不动业之所熏习。后后种子之所随逐。能引当来余身识等生老死苦。是故说此为彼引因。众苦生因者。谓受缘爱爱缘取取缘有。是名当来众苦生因。即先所作业为烦恼摄受。未来世生将现前故。当知名有。众苦生起者。谓有缘生生缘老死。如是名为众苦生起即识名色六处触受。先种子性随所依时。曾得众苦引因之名。今已与果名生老死。复得苦名

复次当知无明智所对治。别有心所覆蔽为性。非唯明无亦非邪智。何以故。若彼无明唯明无者。应不可立软中上品。由无性法都无软中上品异故。又不可立无明随眠与缠差别。由无性法于一切时其相相似现行随转不可建立。又异生心善染无记。于一切处常离慧明。若此无性是无明者。应一切心皆成染污

又无性法非有为摄非无为摄。既非有为无为所摄。不能为染亦不为净。又于离明心相续中。应一切时明不得起。又不应说无明灭故明得生起。所以者何。无有无法而可灭故。若唯邪智是无明者。为除慧明所摄诸智。余一切智皆邪智耶。为唯染污邪执性智是邪智耶。为诸烦恼相应邪智是邪智耶。若言初智是邪智者。一切异生相续中智皆应邪智。若善若无记此不应道理。若唯染污邪执性智是邪智者。唯应五见萨迦耶等名染性智。此中如实不了行相。是名无明。由有如实不了行故。邪执事相。是名为见。谓萨迦耶见由无明力执我我所。如是余见各于自事邪执行转。然彼诸见不离愚痴。由痴与见行相各别。是故此五染污性智名为无明。不应道理

又若无明与诸见相无差别者。世尊不应七随眠中于无明外立见随眠。又佛世尊曾无一处于诸见上示无明名。若诸烦恼相应邪智是无明者。萨迦耶等五种邪见智为自性。无二智体俱有相应。是则诸见应与无明常不相应。又若贪等烦恼力故令相应智成愚痴性。即应贪等增上力故得有愚痴。非痴增上。痴为导首故有贪等一切烦恼。又应可说如余烦恼相应之慧。由相应故得成染污非彼自性。非愚痴体可成痴性。又如诸余烦恼相应。非烦恼性诸心心所。是故当知别有无明。是心所性与心相应。如世尊言。行有三种。谓身行语行意行。当知此中入出息风名为身行。风为导首身业转故。身所作业亦名身行。由愚痴者先起随顺身业风已。然后方起染污身业。如入出息能起身业故名身行。如是寻伺与诸语业俱名语行。受想与意业俱名意行。如是一切总说身行语行意行

诸有随生何界何地。当知有支即此所摄。

复次十二支中。二业所摄。谓行及有。三烦恼摄。谓无明爱取。当知所余皆事所摄。又二业中。初是引业所摄。谓行。后是生业所摄。谓有。三烦恼中一能发起引业。谓无明。二能发起生业。谓爱取。余事所摄支中。二是未来苦支所摄。谓生老死。五是未来苦因所摄。谓现法中从行缘识乃至触缘受。又即五支亦是现在苦支所摄。由先世因今得生起。果异熟摄。谓识名色六处触受。又现在果所摄五支。及未来果所摄二支。总名果所摄缘起。当知余支是因所摄缘起

复次无知略于五处为能生因。一能生疑。二能生爱。三能生非处信。四能生见。五能生增上慢。于前际等所有无知是能生疑。谓如是疑。我于过去为曾有耶为曾无耶。如是等疑于三世转。如经广说。过去名前际。未来名后际。现在名前后际。待过去世是后际。待未来世是前际故。若疑过去当知此疑前际无知所生。若疑未来当知此疑后际无知所生。若于内疑惑此谁所有我为是谁。今此有情从何而来于此没已当往何所。当知此疑是前后际无知所生。又于内无知。于外无知。于内外无知。当知能生内外等爱。及后有爱。喜贪俱行爱。彼彼喜乐爱。又若于业无知。于异熟无知。于业异熟无知。是诸有情由于业自造无知为缘故。于鲁达罗天。毗瑟笯天。世主天等非正处中。生妄胜解归依敬信。又若于佛等无知。乃至于道无知。当知能生诸见。所以者何。由于三宝及四谛中不正通达故。乃至能生六十二见。及起如是见立如是论。无施无爱。乃至广说所有邪见。又若于因无知。于因所生法善不善等无知。广如经说。由此无知故。于往善趣道往善趣方便中。生增上慢。所以者何。由于善不善等法爱非爱果不如实知故。于自饿投火坠高岩等。非方便中起方便想。行如是事以求生天。又于六触处中所有无知。于不如实通达。得沙门果中起增上慢。所以者何。由实无有于六触处如实通达智。而生增上慢故。当知此中若生天方便增上慢。若沙门果增上慢。总合此二名增上慢。如是无明能生五种杂染。谓疑杂染。爱杂染。信解杂染。见杂染。增上慢杂染。由疑杂染所杂染故。一切愚夫获得疑惑。信顺于他引趣异路。于现法中多受苦恼。不安隐住。由爱杂染所杂染故。引生后有生老病等一切大苦。由信解杂染所杂染故。或谓无因或计自在天等。不平等因谓为正因。拨无一切士用而住。由见杂染所杂染故。随意造作一切恶行。能感当来诸恶趣苦。由增上慢杂染所杂染故。令士夫用异果无果

复此缘起善巧如本地分已广分别。所余缘善起巧决择文不复现

瑜伽师地论卷第五十六瑜伽师地论卷第五十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中五识身相应地意地之七

如是已说缘起善巧。处非处善巧我今当说。总嗢拖南曰

  体显现初　　门差别后

问何等为处。答于彼彼事理无相违。问何等非处。答于彼彼事理有相违。是名处非处体。

问何故世尊显示处非处善巧耶。答为欲显示染污清净正方便智无失坏故

问应以几门观察处非处耶。答四。由佛世尊但以四门宣说一切处非处故。何等为四。一成办门。二合会门。三证得门。四现行门。问何缘以此四门说处非处。答为欲示现遍一切种差别门故。云何一切种差别。谓依初成办门。彼所不摄余差别相。我当显示。当知此差别略说有三种。一诸根越所作故。二大种越所作故。三资生越所作故。诸根越所作者。谓无处无位。眼能闻声嗅香尝味觉诸触等必无是处。能见诸色斯有是处。如眼根如是。所余色根一一相望。越用差别如应当知。大种越所作者。谓无处无位。地能造作水火风用必无是处。能作地用斯有是处。如是所余大种展转相望。越用差别如应当知。资生越所作者。谓无处无位。从余类种余类芽生必无是处。唯自种类斯有是处。无处无位构牛角等而出于乳。必无是处。构彼乳房斯有是处。无处无位。钻摇水瓶而出生酥必无是处。钻摇于酪斯有是处。无处无位。压沙出油必无是处。压苣蕂等斯有是处。无处无位。钻湿木等而出于火。必无是处。钻于干木斯有是处。如是等类应当观察初处非处门差别之相。云何第二处非处门差别。谓无处无位。光明黑闇一时合会无有是处。若有一处无第二生斯有是处。无处无位。粗分水火一时合会无有是处。随有一种斯有是处。无处无位。二粗色聚同据一处无有是处。若一极微斯有是处。无处无位。同一种类二心心法俱时合会无有是处。一一而生斯有是处。无处无位。同一种类。若善不善。若善无记不善无记。若苦若乐俱时合会无有是处。随有一种斯有是处。无处无位。爱非爱果俱时合会无有是处。若随有一斯有是处。如是等类应当观察第二处非处门差别之相。云何第三处非处门差别。谓无处无位。石女生儿无有是处若非石女斯有是处。无处无位。生半择迦能生男女无有是处。若诸丈夫斯有是处。无处无位。盲眼见色聋耳闻声。鼻舌坏者嗅香尝味无有是处。诸根不坏斯有是处。无处无位。未具资粮于现法中证学无学究竟解脱。无有是处。已具资粮斯有是处。无处无位。未得圣道能证涅槃。及证声闻独觉菩提。若证无上正等菩提无有是处。已得圣道斯有是处。无处无位。人趣有情以傍生趣草等饮食以充节会。若诸天众食人饮食。色无色界食诸段食无有是处。与此相违斯有是处。无处无位。不舍那落迦所有身形而得人身。如是不舍所余身形而得余身无有是处。舍已方得斯有是处。如是等类应当观察第三处非处门差别之相。云何第四处非处门差别。谓无处无位。地舍自相成余界相无有是处。不舍自相斯有是处。如地如是余大种如应当知。无处无位。生长欲界不得天眼见诸天色无有是处。见人中色斯有是处。如是余根如应当知。无处无位。有贪爱者贪爱覆蔽。贪爱未断而于财利心离染着无有是处。如是嗔痴随应当知。无处无位。不断贪等一切烦恼随烦恼缠修四念住。无有是处。与此相违斯有是处。如修念住如是。所余菩提分法当知亦尔。无处无位。于如来所不舍诤见诤欲诤心。若不开许而能正面睹于如来无有是处。若舍若许斯有是处。无处无位。一切智者一切见者有所知境而不了知。或复失念作非一切智者所作无有是处。与此相违斯有是处。无处无位。已入大地诸菩萨等于诸有情起故害心。或菩提心当有退转无有是处。与此相违斯有是处。如是等类应当观察第四处非处门差别之相

复次略有四处四非处。依前所说观待道理。作用道理。证成道理。法尔道理。应正观察。若于如是所说道理不相违背。示现宣说。是名为处。若此相违示现宣说。是名非处。如是四处并前所说。合成八种处非处善巧

问缘起善巧处非处善巧何差别。答唯于因果生起道理正智显了。名缘起善巧。若于一切无颠倒理正智显了。名处非处善巧。所余处非处善巧决择文不复现。如是已说处非处善巧。

根善巧我今当说。总嗢拖南曰

  初义意建立　　广分别为后

问何等是根义。答增上义是根义。问为显何义。答为显于彼彼事彼彼法最胜义

云何建立二十二根。谓能取境增上义故建立六根。安立家族相续不断增上义故建立二根。为活性命事业方便增上义故建立一根。受用业果增上义故建立五根。世间清净增上义故建立五根。出世清净增上义故建立三根

复次受用显境增上义故建立六根。受用隐境增上义故建立二根。受用境界时分边际增上义故建立一根。受用境界发生杂染增上义故建立五根。安立清净增上义故建立八根。复次显于内门受用境界增上义故建立六根。显于外门受用境界增上义故建立二根。受用内身增上义故建立一根。受用外境及与内身发生杂染增上义故建立五根。对治杂染安立清净增上义故建立八根。复次依止端严增上义故建立五根。能令依止随自在转增上义故建立一根。依止安住增上义故建立一根。依止出生增上义故建立二根。依止损益增上义故建立五根。依止解脱增上义故建立八根

复次显有情事增上义故建立六根。生有情事增上义故建立二根。令有情事若住若没增上义故建立一根。显诸有情受用境界增上义故建立五根。显诸有情胜生方便增上义故建立五根。显诸有情定胜方便增上义故建立三根

复次显有情事增上义故建立六根。显了有情增长增上义故建立二根。显了有情寿渐损减增上义故建立一根显了有情兴盛衰损增上义故建立五根。显了有情功德过失增上义故建立八根

复次依如是名建立六根。依如是种如是姓建立二根。依如是食如是受苦乐建立五根。依如是长寿如是久住如是寿量边际建立一根。当知此诸根依在家品施设建立。依如是信如是精进。乃至如是慧如是向如是果。建立八根。当知此诸根依出家品施设建立。复次依修行者防护根门增上义故建立六根。堪得出家证沙门果增上义故建立二根。积集善品增上义故建立一根。正知而行增上义故建立五根。证沙门果诸方便道增上义故建立五根。证沙门果增上义故建立三根

中嗢拖南曰

  随境界转等　　由显及内门
  庄严二有情　　假设防护等

问眼根作何等业。答于诸色境已见今见当见为业。如是耳根乃至意根所有作业如应当知。问男根女根作何等业。答父母妻子亲戚眷属互相摄受显现为业。问命根作何等业。答令诸有情堕在存活住持数中为业。问受所摄根作何等业。答令诸有情领纳一切兴盛衰损为业。问信等诸根作何等业。答能生善趣及能圆满涅槃资粮为业。问最后三根作何等业。答能于现法趣证涅槃为业。问如是诸根几是实有几非实有。答十六实有。余非实有

问几色所摄。答七。问几心所摄答一三少分。问几心法所摄。答十三少分。问几心不相应行所摄。答一。问几有为所摄。答一切是有为。无有根是无为。问男女二根何等根分。答是身根分。问最后三根何等根分。答是九根分。所谓意根信等五根乐喜舍根。问命根何等根分。答此无所属。依先业所引时量决定而建立故唯说假有

问几善。答或八或五及六少分。问几不善。答六少分。问几无记。答八五少分。问几有异熟。答一十少分。问几无异熟。答十一十少分。问几有异熟助伴。答最后三能助有可爱异熟法令转明盛。能感决定人天异熟。问几是异熟。答一九少分。问几有种子异熟。答一切皆有。问几非异熟。答十二九少分。问几是异熟生。答亦一切种子所摄异熟所生故

问几欲界系。答四十五少分。问几色界系。答十五少分。问几无色界系。答八少分。问几不系。答三九少分

问未至地几可得。答十一。问若未至地有喜根者。何故不如初静虑地建立喜耶。答由于彼地喜可动故。问喜于彼有何教为证。答如世尊言。如是苾刍离生喜乐滋润其身。周遍滋润遍流遍悦。无有少分不充不满。如是名为离生喜乐。此中初门说未至位。后门说根本位。问初静虑地几根可得。答十八。第二静虑地亦尔。问第三静虑地几根可得。答十七。问第四静虑地几根可得。答十六。问空无边处地几根可得。答十一。如空无边处地。识无边处地。无所有处地。应知亦尔。问非想非非想处地几根可得。答八。问初静虑地所摄诸根当言有漏。当言无漏。答当言二种。如初静虑所摄诸根。乃至无所有处地所摄诸根当知亦尔。非想非非想处地所摄诸根。当言有漏。此约种类。若约相续当言二种。又由烦恼解脱故。令彼诸根成无漏性。如有漏无漏如是。应断不应断世间出世间。当知亦尔

问若生欲界当言成就几根。答容有一切。问生那落迦成就几根。答八。现行种子皆得成就。除三所余或成就或不成就。三约现行不成就。约种子或成就。谓般涅槃法。或不成就。谓不般涅槃法。余三现行故不成就。种子故成就。如生那落迦趣于一向。苦傍生饿鬼当知亦尔。若苦乐杂受处。后三种亦现行成就。问若生人趣成就几根。答容有一切。如生人中生天亦尔。问诸缺根者成就几根。答除五容有余。问诸具根者成就几根。答容有一切。问诸半择迦。成就几根。答除五容有余。问女成就几根。答容有二十一。问男成就几根。答亦容有二十一。问诸二形者成就几根。答容有十九。问断善根者成就几根。答除八容有余。问不断善根者成就几根。答容有一切。问诸异生成就几根。答十九除后三。问诸见谛者成就几根。答容有一切。问有学成就几根。答容有二十一。问无学成就几根。答容有十九。问预流果向成就几根。答容有二十。问预流果成就几根。答亦容有二十。如预流果一来果向。一来果不还果向当知亦尔。问不还果成就几根。答容有十九。如不还果阿罗汉向亦尔。问阿罗汉果成就几根。答容有十九。问若生色界成就几根。答容有十八。问生无色界成就几根。答容有十一

问若欲界没欲界生时。当言舍几根得几根。答且约色根容有而说。或舍缺诸根得缺诸根。或舍缺诸根得具诸根。或舍具诸根得具诸根。或舍具诸根得缺诸根。或舍劣诸根得劣诸根。或舍劣诸根得胜诸根。或舍胜诸根得劣诸根。或舍胜诸根得胜诸根。意根命根胜劣得舍当知亦尔。若诸受根胜劣得舍。随其所应亦尔。此约异熟果故有差别。若诸善根约等流果。舍前前劣得后后胜。非由生故舍胜得劣。后邪方便乃有斯义。最后三根于一切位与生相违。是故不说。问从欲界没色界生时。舍几根得几根。答容舍下地一切。容得上地一切。如欲界没色界生时。从欲界没无色生时。从色界没无色生时。当知亦尔

最后三根由证沙门果方便而得不由没生。先修习力所任持故。后等流果转盛而生。又能为缘生异熟果令转明盛

中嗢拖南曰

  业实有色等　　善等异熟等
  若界若诸地　　及死生得舍

问几根由境界义名有义几非耶。答二十一名有义。一非。问几于非色助伴义转。答七色根。问几色非色为助伴耶。答余有义根。问五色根何义。答色等五各别境。问第六根何义。答一切法。问男女根何义。答因欲相应即触所摄。问五受根何义。答随顺苦乐忧喜舍处。即六根义。问信根何义。答应得应舍所有境界。问精进根何义。答即于二种若得若舍俱无所惮。问念根何义。答于闻思修忆持不忘。问定根何义。答奢摩他毗钵舍那。问慧根何义。答所知真实。问未知欲知根何义。答修谛现观者从善法欲已去。于一切方便道中即彼五根义。当知是此义。问已知根何义。答从预流果乃至金刚喻定。即彼五根义当知是此义。问具知根何义。答从初无学道乃至无余涅槃界。即彼五根义当知是此义

问几有色有色为义。答七。问几无色。有色无色为义。答除命根余一切。问几非有色非无色。非有色非无色为义。答即此命根是假法故。问几有见。有见为义。答一切非有见。一有色以有见为义。及余非有色一分问几有对。有对为义。答七有色及余无色无对一分

问几有漏。有漏为义。答唯七。除最后二及苦忧根。余有漏无漏以有漏无漏为义。当知苦根。有漏无漏以有漏为义忧根。有漏以有漏无漏为义未知欲知根。若远沙门果世间行所摄是有漏。若近沙门果出世行所摄是无漏

问几有为。有为为义。答一切是有为。八有为为义。余有为。无为为义

问几有诤。有诤为义。答如说有漏。当知此亦尔。如说有诤。当知有爱味依耽嗜世间出世间等亦尔

问几过去。过去为义。答除有色根及苦根。余有义一分。若有色根及苦根在过去。非过去为义。问几过去现在为义。答即如所说一分。当知即此在过去。以未来为义。又即此在现在以过去未来为义。问几现在。现在为义。答一切有色根及苦根。并前所说一分。又此一分在未来。以过去未来现在为义。若诸色根在未来。非未来为义。苦根亦尔

问几欲界系。欲界系为义。答四。二欲色界系。欲界系为义。三欲色界系。欲色界系为义。二欲色界系及不系。欲色无色界系及不系为义。七欲色无色界系及不系彼义亦尔。一色界系及不系。一切系不系为义。二不系一切系。不系为义

问几善。善为义。答八唯善。善不善无记为义。五善不善无记。善不善无记为义。一善不善。善不善无记为义。五无记。无记为义。二无记。善不善无记为义

问几学。学为义。如是等。答九学无学非学非无学。以三种为义。七非学非无学。即以此为义。一通三种。非学非无学为义。一学非学非无学。以三种为义。二学。以三种为义。一无学。以三种为义

问几见所断。见所断为义。如是等。答十四一分见所断。一分修所断。十二一分修所断。一分非所断。谓即十四中六及余六余二非所断。此中有色诸根见修所断为义。无色诸根三种为义。谓见修所断非所断义

问几根于义杂染舍所显。答除诸善根。以诸善根于义清净舍所显故

问几根颠倒义。答除诸善根。所有六根义。问几根颠倒所依。答七色根。问几根颠倒自性。答六少分。问几根颠倒对治。答八物

问几根观义过失。答或八或五或一。问若彼诸行亦有四德相应可得。云何唯观为过失耶。何者四德。一坚住德。谓如一蕴住经百年。若正将御或有过者。二势力德。谓能生乐及现清净。三转变德。谓牵引修治受用弃舍自在转故。四可乐德。谓依彼处生种种着故。是名诸行有四德相。答虽有世间于彼诸法取为功德。然彼一切皆诸过失之所随逐。问何等名为诸过失耶。答虽少时住非究竟故。爱变无常现可得故。死没无常现可得故。当观诸行离初功德。又能发生种种苦恼现可得故。种种不净现可得故。当观诸行离第二德。又于老病死等不随所欲现可得故。当观诸行离第三德。又诸粪虫及猪犬等亦极乐着粪秽不净现可得故。当观诸行离第四德。由彼诸行离诸功德。是故一切过失相应。故应观彼具诸过失

问眼根谁所依处。答见色依处。问乃至意根谁所依处。答各取自境之所依处。问男女二根谁所依处。答习欲依处。问命根谁所依处。答乃至死有为前时有之所依处。问诸受根谁所依处。答于诸境界可意不可意。若爱若恚等之所依处。问信根谁所依处。答趣入善法之所依处。问精进根谁所依处。答已入善法恒常修习之所依处。问念根谁所依处。答正知而行之所依处。问定根谁所依处。答智见清净之所依处。问慧根谁所依处。答烦恼永断之所依处。问未知欲知根谁所依处。答证初第二第三沙门果之所依处。问已知根谁所依处。答乃至金刚喻定无学沙门果证之所依处。问具知根谁所依处。答无间烦恼永断作证现法乐住所依永灭之所依处

问世尊依何根处说如是言。此身有色粗滓所成。四大所造。父母不净和合所生。种种饮食之所长养。常假覆蔽沐浴按摩。断截。破坏散灭之法。答依七色根作如是说。当知此中略说欲界有色诸根。初句说彼共相。第二句说彼自相。次有三句说彼因相。所谓依因生因生已增长因。次有三句说彼转变相。谓寒所作热所作劳倦所作。后有四句说彼变坏相。谓初二句活位逼损所作。后二句死后所作。他故自然故变坏应知

问世尊依何根处说如是言。远行及浊行无身寝于窟耶。答依意根处。由于前际无始时故。遍缘一切所知境故。名为远行。诸心相续一一转故。无主宰故。名为独行。无色无见亦无对故。名为无身。依止色故。名寝于窟

问依何根处说如是言。由八处所男为女缚。谓舞歌笑睇美颜妙触只奉成礼。答依男女二根。于游戏时由四处缚。于受用时亦由四处。于游戏时。身证面门眼目舒悦。于受用时。妍容软滑恭事童分

问依何根处说如是言。众生存活住持安隐。答依命根说。有诸气息故名众生。思虑相应故名存活。等余而住故名为住。增上而转故说名持。无有病恼故名安隐

问依何根处说如是言。平正受受所摄。答依喜乐根说。望所余受自相共相依止相所显故。如平正等如是。不平正等非平正非不平正等。如应当知。问世尊依何根处说如是言。于如来所净信深固根生建立。一切世间若诸沙门。若婆罗门。若天魔梵。无有如法能引脱者。答依信根说。此显其信于闻思修胜解坚固义。又此坚固随所信解方便显示。谓智生主净最胜之者尚不能动。何况凡流。又坚固义复有差别。谓其信深固。由世间善决定胜解为出世胜解根本故。又由出世清净胜解所建立故。当知最初是标句。后二是释句

问世尊依何根处。说如是言

  住有势有勤　　有勇健坚猛
  于诸善法中　　常不舍善轭

答依精进根说。此精进根略显其相差别有五。谓被甲精进。方便精进。不下精进。无动精进。无喜足精进问世尊依何根处。说如是言

  念等念随念　　别念不忘念
  心明记无失　　无忘无失法

答依念根说此差别义。如摄异门分应知。问世尊依何根处。说如是言

  令心住等住　　安住与近住
  调寂静寂止　　一趣等持性

答依定根说此差别义。如声闻地应知。问世尊依何根处。说如是言

  简择法　　极简择　　遍寻求　　遍伺察

答依慧根说此差别义。亦如声闻地应知。所余善根信等摄故。其差别义无复可得

问于几根处立身念住。答七。问于几根处立受念住。答五。问于几根处立心念住。答一。问于几根处立法念住。答最后八及命根

问几根最胜苦谛依处。答九。问几根最胜集谛依处。答五。问几根灭谛依处。答一切。问几根道谛依处。答最后八。问依几根处善思所思。答九。问依几根处善说所说。答十。问依几根处善作所作。答十六。如是恶思所思。恶说所说。恶作所作。如应当知问几根最胜惑业依处。答九。问依几根处起烦恼业。答五。问依几根处断烦恼业。答最后八

问由几根故领纳一切世出世间所有吉祥。答除二。问由几根故领纳一切吉祥败坏。答十一。问几根能引所有吉祥。答最后八。复次如世尊言。诸受欲者略有五种作吉祥法。谓忍辱。柔和。观人而舍。行贤善行。及不放逸。云何忍辱。谓由三种行相应知。一不忿怒。二不报怨。三不怀恶。若别分别乃有十种。一已受怨害忍。二现前怨害忍。三虑恐怨害忍。四饶益怨憎忍。五损害亲友忍。六一切怨害忍。七一切因怨害忍。八受教怨害忍。九择力怨害忍。十自性怨害忍。如是一切总说名为耐违害忍。云何柔和。谓性贤善。由身语意将护于他令无恼害。若他所有无罪喜乐未生令生。生已随护。有罪忧苦若未生者遮令不生。若已生者方便令脱。此中忍辱耐他违害。柔和于他不作违损。如是名为二种差别。当知观人二时差别。一摄受时。二处置时。于摄受时应以五相观察其人然后摄受。一由归诚。二由技能。三由智慧。四由行迹。五由廉俭。于处置时亦以五相观察其人然后处置。一堪处事业置事业中。二堪处思业置思业中。三堪处和业置和业中。四堪处护身财业置护身财业中。五堪处法业置法业中。舍略有五。一田地舍。二财物舍。三随宜舍。四饮食舍。五最胜舍。此中舍相舍具名舍。贤善行者。为性于他无所违负。无所欺诳无所违负。复有五种。一无颠倒违负。二无委信违负。三无承事违负。四无契约违负。五无他方便违负。不放逸者。谓修习诸善法。防护不善心。因果相属故俱应为彼相。此复有五种应知。一求财不放逸。二守财不放逸。三护身不放逸。四护名不放逸。五行法不放逸。如是一切总有五力能生吉祥。一善尸罗力。二善朋友力。三无弊吝力。四可委信力。五法力。当知吉祥亦有五种。一众所爱乐。二富贵自在。三怨敌退伏。四饶益所依。五往诸善趣。前四种力总能生起四种吉祥。第五一力能生第五

问几根先烦恼业之所感得。答八。问几根名色为缘。答一。问几根触为缘。答五。问几根策励为缘。答八。问几根应防护。答八。问几根应调静。答一。问几根应寂止。答五。问几根自性调顺寂静寂止。复能调伏寂静寂止。答八。云何诸根舍。谓同分界地诸根灭余生起。云何诸根弃。谓不同分界地诸根灭余生起。云何诸根断。谓断彼系缚一切烦恼。云何诸根退。谓世间兴盛若定若生所有失坏。问声闻独觉菩萨诸根有何差别。答当知差别略有五种。一品类差别。二任持差别。三罥索差别。四正行差别。五证得差别。品类差别者。诸菩萨根其性上品。声闻独觉所有诸根软品中品。任持差别者。诸菩萨根一切明处善巧任持。声闻独觉所有诸根一分明处善巧任持。罥索差别者。诸菩萨根大悲所罥。声闻独觉根不如是。正行差别者。诸菩萨根自利利他正行现前。声闻独觉所有诸根自利现前。证得差别者。诸菩萨根证得无上大菩提果。声闻独觉所有诸根证得下中二菩提果。问若补特伽罗依未至定修谛现观。彼得果时起初静虑喜根现前。为不起耶。答有一能起。有一不起。若有利根众多善本之所资助。彼能现起。非余。问几根入初静虑。答八。后三一分能入。一分不能。如初静虑第二亦尔。第三亦八。然非即彼第四静虑及无色定。七根能入。后三有一能入。有一不能。问几根得预流果。答或一或八或二或九得一来果。忧根虽道所依非道摄故。此中不取。喜根非坚住故此亦不取。若通取者当增其数。问几根得不还果。答或十一或二忧根道理如前应知。问几根得阿罗汉果。答或一或十

如经言。于上解脱希求忧戚。云何希。谓修行者作如是念。是处众圣能具足住。求云何。谓修行者作如是念。我于是处当具足住。戚云何。谓于下劣不生喜足。忧云何。谓于无上心生思慕。此中预流一来于一切种皆圆满。故建立忧根。若不还果虽有初二余二无故。不立忧根。唯善法欲

问颇有依止喜根能舍喜根忧根舍根耶。答有谓依出离喜根为依止故。舍依耽嗜三根。问颇有依止忧根舍忧根耶。答有。谓依出离为依止故。舍依耽嗜。问颇有依止舍根舍舍根耶。答有。谓依一性舍为依止故。舍依种种性舍。无所依舍为依止故。舍依一性舍。得预流果时未知欲知根。亦灭亦舍。非起而弃非断非退。得阿罗汉果时已知根道理。应知亦尔

问几补特伽罗有练根耶。答一切有学及无学五退思护住堪达种性。非诸独觉亦非菩萨。性利根故。问若预流者修练根时。既得练根亦证一来果耶。答证。问亦证不还果耶。答不证。对治难得故。所应得义极广大故。问若不还者修练根时。既得练根亦进离欲耶。答进。问亦证阿罗汉果耶。答不证。由前因故。转根已后一切皆证。问何故转根。答于薄少升进不生喜足故。为植引发胜定力故。为植多闻力故。为植论议决择力故。为植观察甚深法忍力故

问诸菩萨未知欲知等三根云何建立。答于胜解行地建立初根。于净增上意乐地等立第二根。于如来地立第三根

问由几种满名学满耶。答由三种满。一根满。谓利根。二定满。谓八解脱定。三果满。谓不还果。若诸无学得有二满。一根满。谓不动法。二定满。如前应知。一切无学皆由果满说名为满

问如说诸根不调不守不护不防亦不修习。此差别名有何义耶。答略说由四因缘。诸根名不调伏。谓简择力为依止故。于诸境界若不应纵诸根之者。便起加行令不纵逸。若应纵者便起加行纵彼诸根。护诸烦恼令不现起。断对治力为依止故。即于如前所说境界。为性无著为性烦恼不复现行。若无是四调诸根者。当知彼根名不调伏。由不守故不护故不防故不修故。若有是四调诸根者。当知与彼四种相违。名为调伏乃至修习。云何不调伏者能引众苦。谓能生六种苦故。一扰恼住所生苦。二他所摈黜苦。三他所讥毁苦。四追悔所生苦。五往生恶趣苦。六生等诸苦。若有诸根善调伏者。当知与此相违断六种苦引诸快乐。问十四种根三聚有情。为十四摄三。三摄十四耶。答三摄十四。非十四摄三。不摄何等。谓外处少分。三聚有情者。谓欲界色界无色界。问五根三受。为五摄三。三摄五耶。答更互相摄

问五根三十七觉品法。为五摄三十七。三十七摄五耶。答三十七摄五。非五摄三十七。不摄何等。谓语业命喜安舍。如是或六或四彼所不摄

问五根三根。为五摄三。三摄五耶。答三摄五。非五摄三。不摄何等。谓意乐喜舍根问九遍知几根摄。答此九遍知断遍知摄故。非根所摄。何等为九。谓欲系苦集见所断断。是初遍知。色无色系苦集见所断断。第二遍知。欲系灭见所断断。第三遍知。色无色系灭见所断断。第四遍知。欲系道见所断断。第五遍知。色无色系道见所断断。第六遍知。下分结断。第七遍知。色爱尽第八遍知。无色爱尽第九遍知。当知遍知略由二缘而得建立。一通达谛断故。二永度界断故。由相同分界不同分及同分故。立二遍知。相不同分界不同分及同分故立四遍知。永度劣界故立一遍知。永度中界故立一遍知。永度妙界故立一遍知

问诸相随好力无畏等不共佛法几根摄耶。答诸相随好。舌根及四根依处所摄。何等为四。谓身根。男根。眼根。舌根。诸佛十力。如来身中慧根所摄。及具知根四无所畏。五根所摄。及即此一。如无所畏不护亦尔。三种念住非根所摄。然六根所引无贪无嗔所摄。大悲亦彼所引无嗔无痴所摄。非根所摄。无忘失法如力应知。佛一切种妙智亦尔。永断习气非根所摄。然是六根所证烦恼永断所摄。问诸烦恼品所有粗重。阿罗汉等永断无余。复有何品粗重。阿罗汉等所未能断。由断此故说名如来永断习气。答异熟品粗重。阿罗汉等所未能断。唯有如来名究竟断

问如经言。有四种食皆能长养诸根大种。云何四食。云何长养诸根大种。答段食。触食意思食识食。由此四种长养五色根及意根并根所依所有大种。问云何段食。答诸所食啖。若能长养诸根大种。与此相违当知非食。如段食余食非食应知亦尔

问段食云何能作食事。乃至识食亦尔。答若诸段食能摄益识令其强盛。由此长养诸根大种亦令强盛。触能摄受若喜若乐若舍一分。由此复能摄益诸识。由摄益故复能长养诸根大种。意思为欲证得可爱境界相故。依正方便起染不染希望喜根。缘未来境摄益于识。由此长养诸根大种。如是三食摄益其识。由体增盛及缘现在未来生故。识复长养诸根大种故立四食。问云何识与意根为食。答由三资持所任持故。能与后后为增盛因。令彼得生。问何故眠梦梵行等至。皆能长养诸根大种而不立食。答有二种长养。一摄受别义长养。二令无损害长养。眠梦等法于后长养虽能长养。于前即非。是故不立。问何故命根能任持身而不立食。答若离于食彼终不能长养身故。问何等段食名粗。答若非天所食。问何等名细。答诸天所食。由彼食已即于身中便自消化非渐次故。问何等触意思识食名粗。答若在欲界。问何等名细。答若在色无色界。问何等名为已生有情。答若于现在已生增长。问何等名为求有有情。答若有希求未来诸有。问何等名住。答若无损害长养。问何等名安。答若摄受长养。问已生有情云何由食而得安住。答如前所说道理应知。问求有有情云何由食摄受。答由三门故二种杂染增长。谓业烦恼二种杂染依识而有。由三门杂染资长识故。诸求有者于无间生摄受余有。问段食何时建立为食。答于变坏时若受用时建立。触食由彼摄受方得增益。是故段食三处所摄。谓香味触建立为食。不立色处由彼要至味势熟等变坏之位方损益故。或有段物于受用时有所损害。于变坏时方能摄益。如苦辛等。或有段物于受用时暂为摄益。于变坏时乃为损害。如有甘美所不宜物。故变坏时方立为食。非受用时。问更有所余众多行法住因可得。谓生先业神通因缘合会离障。何故但说此四为食。答以多分故。易觉知故。于诸念住易趣入故。于日日分易资养故。唯此四种应显为食。那落迦中无有段食。定地诸天亦复如是。诸那落迦多由先业力所任持而得久住。虽有广大诸根大种损害因缘而不能死。然彼亦有诸微细风。随入身分以之为食。难可了知。是故不说。问诸根依身转。亦依境界耶。设依境界者亦依身转耶。答若根依境界必依身而转。或有依身转而不依境界。谓诸有色彼同分根。以诸大种为依止故。说彼依身。问若诸根有所依而转者。彼一切皆一依耶。答或有一依。谓诸有色彼同分根。或有二依。谓即有色同分诸根。或有三依。所谓意根及余无色心法诸根在有色界。若于无色即此诸根唯有二依。问诸根是苦者。一切苦相合耶。设苦相合者。一切是苦耶。答或诸根是苦而非苦相合。谓乐根喜根。或有是苦亦苦相合。谓苦根忧根。或有是苦非苦乐相。谓舍根。或有非苦亦非苦相。谓后三根苦对治故

问诸根是善。彼根引乐耶。设根引乐。彼根是善耶。答或根是善而不引乐谓忧苦俱而修梵行。彼诸善根于现法中。不能引乐。或根引乐而非是善。谓诸无记及不善根。于现法中能引无记及染污乐。或根是善亦能引乐。谓喜乐俱修诸梵行所有善根。于现法中能引其乐。或根非善亦不引乐。谓诸无记及不善根。于现法中能引诸苦

中嗢柁南曰

  义依处证得　　摄食由诸句

复次具足摄持一切行义。具足摄持一切行义。是故名蕴。又有别义。常能增长诸业烦恼。常能增长诸业烦恼。是故名蕴。又有别义。常有所为及速灭坏。当有所为及速灭坏。是故名蕴。发起诸法发起诸法。是故名界。是牵引义。能生能广诸心心法能生能广诸心心法。是故名处。由众缘故速坏集起。由众缘故速坏集起。故名缘起。等起理趣。等起理趣。是故名处。若非理趣说名非处。于见等事自在相应。于见等事自在相应。是故名根

当知蕴等略由六因而得建立。谓身体建立。彼因建立。身者建立。彼转方便建立。即于彼转胜劣方便建立。即彼受用增上建立复略显示六种善巧。当知为遣六种邪执。何等为六。一依止邪执。二自性自在等不平等因邪执。三能持依止我邪执。四彼死生转邪执。五彼净不净方便邪执。六彼爱非爱境界受用主宰邪执

问观几胜利分别建立。简择诸法修习善巧。答略有十种。谓当遍知萨迦耶见分析一合之想。于有法现有谛故住故便不诽谤。自无疑惑善答他问。未信令信已信令增。亦令如来圣教久住。又当悟入缘起道理。能了释梵世主自性及士夫等非作者无实性。又令慧根增长广大。于善不善如实了知。广说乃至缘生差别。又于善不善法广说乃至缘生差别。当善住念。由有法随法行故。即以住念为依止为建立。当证善心一境之性。又即以此心一境性为依止为建立。令圣慧根当得生起。依圣慧根永断颠倒随证漏尽。由观如是诸胜利故。分别建立简择诸法。修习善巧。

已略决择五识身地意地。于二地中余决择文更不复现

瑜伽师地论卷第五十七瑜伽师地论卷第五十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中有寻有伺等三地之一

如是已说五识身相应地意地决择。有寻有伺等三地决择我今当说。

问何故焰摩名为法王。为能损害诸众生故。为能饶益诸众生故。若由损害众生。名为法王。不应道理。若由饶益众生。今应当说云何饶益。答由能饶益不由损害。何以故。若诸众生执到王所。令忆念故遂为现彼相似之身。告言。汝等自所作业当受其果。由是因缘彼诸众生各自了知自所作业还自受果。便于焰摩使者众生业力增上所生。犹如变化非众生所。无反害心无嗔恚心不怀怨恨。乃由此故感那落迦。新业更不积集。故业尽已脱那落迦趣。是故焰摩由能饶益诸众生故。名为法王。若诸众生生那落迦忆宿命者。焰摩法王更不教诲。若有生已不忆宿命。王便教诲。略有三种补特伽罗生那落迦。不忆宿命。一极愚痴。谓生边地不解观察。随诸恶转。二极放逸。谓受欲者于诸欲中增上耽着不解观察。随诸恶转。三极邪见。谓成就一切诽谤邪见不解观察。随诸恶转。由彼不能自然忆念故令忆念。

复次二因缘故大海水碱。一生彼众生福增上故。二陆地众生一分非福增上故。所以者何。由水碱故非人所涉。生彼无量微细众生不被采害。又大海中种种珍宝差别可得。由水碱故陆地众生一分难得

复次烦恼杂染决择。我今当说。如先所说烦恼杂染义。当知此烦恼由五种相建立差别。何等为五。一自性故。二自性差别故。三染净差别故。四迷断差别故。五对治差别故。

云何自性。略有二种。一见性烦恼。二非见性烦恼。

云何自性差别。略有十种。见性烦恼五种差别。非见性者亦有五种。总此十种名为烦恼自性差别。见性五者。谓萨迦耶见。边执见。邪见。见取。戒禁取。非见性五者。谓贪。恚。慢。无明。疑。萨迦耶见者。于五取蕴心执增益见我我所名萨迦耶见。此复二种。一者俱生。二分别起。俱生者。一切愚夫异生乃至禽兽并皆现行。分别起者。诸外道等计度而起

边执见者。于五取蕴萨迦耶见增上力故。心执增益见我断常。名边执见。常见所摄边执见者。谓六十二诸见趣中。计度前际诸遍常论一分常论。及计后际诸有想论无想论非想非非想论。断见所摄边执见者。谓诸沙门若婆罗门七事断论。此边执见唯分别起无有俱生。唯除即此先世已来串习随逐边执见等。若有分别若无分别差别之相。如本地分已广分别。邪见者。一切倒见于所知事颠倒而转。皆名邪见。当知此见略有二种。一者增益。二者损减。萨迦耶见。边执见。见取。戒禁取。此四见等一切。皆名增益邪见。谤因谤用谤果坏实事等。心执增益所有诸见一切。皆名损减邪见。无施无爱亦无祠祀。是名谤因。无有妙行亦无恶行。是名谤用。无有妙行恶行诸业果及异熟。是名谤果。无父无母无化生有情。亦无世间真阿罗汉诸漏永尽。乃至广说。如是一切名坏实事。又此邪见即计前际诸无因论。边无边论。不死矫乱论。及计后际现法涅槃等论。所有沙门若婆罗门。当知如是萨迦耶见以为根本。六十二见三见所摄。谓常见所摄诸边执见。断见所摄诸边执见及诸邪见。见取者。于六十二诸见趣等。一一别计为最为上为胜为妙。威势取执随起言说。唯此谛实余皆虚妄。由此见故能得清净解脱出离。是名见取

戒禁取者。谓所受持随顺见取。见取眷属见取随法。若戒若禁于所受持诸戒禁中。妄计为最为上为胜为妙。威势执取随起言说。唯此谛实余皆虚妄。由此戒禁能得清净解脱出离。是名戒禁取

贪者。谓能耽着心所为性。此复四种。谓着诸见欲色无色

恚者。谓能损害心所为性。此复四种。谓于损己他。见他有情所。及于所爱不饶益所。于所不爱作饶益所。所有嗔恚

慢者。谓令心举心所为性。此复四种。谓于诸见。于诸有情。于受用欲。于诸后有处起。又此慢略有二种。一惑乱慢。二不惑乱慢。于有情处慢者。谓三慢类。已如前说。于受用欲处慢者。谓由大财大族大徒众等现在前故心遂高举。于后有处慢者。谓由计我当有不有。广说乃至我当非想非非想等。若动不动戏论造作诸爱趣中。现前转故心遂高举。不惑乱慢者。谓于下劣计己为胜。于等计等而生憍慢。惑乱慢者。谓余六慢。又由受用鄙劣资具自谓富乐。名惑乱慢。若由受用胜妙资具自谓富乐。名不惑乱慢。又由邪行谓后有胜。名惑乱慢。若由正行谓后有胜。名不惑乱慢

无明者。谓于所知真实觉悟能覆能障心所为性。此略四种。一无解愚。二放逸愚。三染污愚。四不染污愚。若于不见闻觉知所知义中所有无智。名无解愚。若于见闻觉知所知义中。散乱失念所有无智。名放逸愚。于颠倒心所有无智。名染污愚。不颠倒心所有无智。名不染污愚。又此无明总有二种。一烦恼相应无明。二独行无明。非无愚痴而起诸惑。是故贪等余惑相应所有无明。名烦恼相应无明。若无贪等诸烦恼缠。但于苦等诸谛境中。由不如理作意力故。钝慧士夫补特伽罗诸不如实简择覆障缠裹闇昧等心所性。名独行无明

疑者。犹豫二分不决定心所为性。当知此疑略由五相差别建立。谓于他世作用因果诸谛宝中。心怀犹豫

如是所说十种烦恼。亦缘事转亦缘烦恼。谓十烦恼皆与自地一切烦恼展转相缘。亦缘自地诸有漏事。下地烦恼能缘上地烦恼及事。非上地惑能缘下地烦恼及事。如是烦恼展转相缘及下地惑能缘上地。于此处所余决择文更不复现

复次俱生萨迦耶见唯无记性。数现行故。非极损恼自他处故。若分别起萨迦耶见由坚执故与前相违。在欲界者唯不善性。若在上地。奢摩他力所制持故。多白净法所摄受故。成无记性。由染污故体是隐没。所余烦恼由此道理随应当知。欲界烦恼为诸恶行安足处故。多不善性。又不善者。具三因缘能往恶趣。余则不定。何等为三。谓极多修习殷重无间计为功德。不见其失不见其患。纵情而起。是初因缘。用此烦恼以为依处。由身语意于诸恶行作及增长。是第二因缘。由此烦恼断他善品授不善品。是第三因缘。除先所作能往恶趣顺后受业。又十烦恼。七唯意地。贪恚无明亦通五识。又于欲界四见及慢喜舍相应。贪乐喜舍相应。恚苦忧舍相应。邪见喜忧舍相应。疑忧舍相应。无明一切五根相应。此据多分相应道理。其余深细后当广说。于上诸地随所有根。即与彼地烦恼相应。又十烦恼见所断者。名曰无事。彼所缘事非成实故。所余烦恼有事。无事彼相违故。又贪与慢缘有漏一分可意事生。恚缘一分非可意生。是故此三烦恼一分所生名取。一分所余烦恼通缘内外若爱非爱。及俱相违有漏事生。是故说彼名曰遍行。取一切事若有随顺如是烦恼烦恼俱行烦恼品类。名随烦恼

云何名随烦恼。略由四相差别建立。一通一切不善心起。二通一切染污心起。三于各别不善心起。四善不善无记心起。非一切处非一切时。谓无惭无愧名通一切不善心起。随烦恼放逸掉举。惛沈不信。懈怠邪欲。邪胜解邪念。散乱不正知。此十随烦恼通一切染污心起。通一切处三界所系。忿恨覆恼嫉悭诳谄憍害。此十随烦恼各别不善心起。若一生时必无第二。如是十种皆欲界系。除诳谄憍。由诳及谄至初静虑憍通三界。此并前二若在上地唯无记性。寻伺恶作睡眠。此四随烦恼通善不善无记心起。非一切处非一切时。若有极久寻求伺察。便令身疲念失心亦劳损。是故寻伺名随烦恼。此二乃至初静虑地。恶作睡眠唯在欲界。又有定地诸随烦恼。谓寻伺诳谄。惛沉掉举。憍放逸懈怠等。初静虑地有初四种。余通一切地。若杂事中世尊所说诸随烦恼。广说乃至愁叹忧苦随扰恼等。及摄事分广所分别。如是一切诸随烦恼。皆是此中四相差别。随其所应相摄应知

复次诸随烦恼若在欲界略于十二处转。何等十二。谓执着恶行处。斗讼诤竞处。毁犯尸罗处。受学随转非善人法处。邪命处。耽着诸欲处。如所闻法义心谛思惟处。于所思义内心寂止方便持心处。展转受用财法处。不相杂住处。远离卧具房舍处。众苦所集处。此十二处以为依止。如先所说贪着。乃至随扰恼等诸随烦恼差别而转。谓贪着嗔恚愚痴依初处转。忿等乃至谄依第二处转。无惭无愧依第三处转。诳等乃至谋害依第四处转。矫诈等乃至恶作依第五处转。不忍耽嗜等乃至不平等贪着依第六处转。萨迦耶见有见无有见依第七处转。贪欲等乃至不作意依第八处转。顾悦缠绵依第九处转。不质直。性不柔和性不随同分转性依第十处转。欲寻思等乃至家生系属寻思依第十一处转。愁叹等依第十二处转

复次此五见是慧性故互不相应。自性自性不相应故。贪恚慢疑更相违故互不相应。贪染令心卑下。憍慢令心高举是故贪慢更互相违

复次如所说诸随烦恼。当知皆是烦恼品类。且如放逸是一切烦恼品类。所以者何。于染爱时多生放逸。乃至疑时亦有放逸。贪着悭吝憍高掉举等。皆贪品类皆贪等流。忿恨恼嫉害等是嗔品类是嗔等流。诳谄是邪见品类邪见等流。覆是谄品类。当知即彼品类等流。余随烦恼是痴品类是痴等流。唯除寻伺当知寻伺。慧思为性犹如诸见。若慧依止意言而生。于所缘境慞惶推究。虽慧为性而名寻伺。于诸境界遽务推求。依止意言粗慧名寻。即于此境不甚遽务而随究察。依止意言细慧名伺。是名建立烦恼杂染自性差别

云何建立烦恼杂染染净差别。谓如所说本随二惑。略二缘故染恼有情。一由缠故。二随眠故。现行现起烦恼名缠。即此种子未断未害。名曰随眠亦名粗重。又不觉位名曰随眠。若在觉位说名为缠。若诸具缚补特伽罗生在欲界。成就三界烦恼随眠。若生色界所有异生。成就欲界被奢摩他之所损伏烦恼随眠。成就色界及无色界所未损伏烦恼随眠。若生无色所有异生。成就欲界及与色界被奢摩他之所损伏烦恼随眠。成就无色所未损伏烦恼随眠。如界道理随地亦尔。诸烦恼缠未离自地烦恼欲者自地现起。已离欲者即不现起。若在下地。上地诸缠亦得成就。非在上地得说成就下地诸缠

问具一切缚补特伽罗。诸烦恼缠起灭未舍是诸烦恼于何事系。过去耶未来耶现在耶。答过去已系故不名系。但于现在由此种类烦恼随眠。说名为系。若诸烦恼正起现前亦由缠故。说名为系。于未来世随眠及缠以当系故。亦不名系。如此种类。当知诸余烦恼亦尔。如具缚者不具缚者亦复如是。差别者。所余烦恼说名为系。问诸修行者伏烦恼缠当云何伏。答以修三种对治力故伏烦恼缠。一了知烦恼自性过患。二思惟对治所缘境相。三以胜善品滋心相续。当知此是永断正见前行之道。问诸修行者断烦恼时。为舍缠耶舍随眠耶。由断何故说名为断。答但舍随眠。以烦恼缠先已舍故。断随眠故说名为断。何以故。虽缠已断未断随眠。诸烦恼缠数复现起。若随眠断。缠与随眠毕竟不起。问为断过去为断未来为断现在。答非断去来今。然说断三世。何以故。若在过去有随眠心。任运灭故其性已断。复何所断。若在未来有随眠心。性未生故体既是无。当性所断。若在现在有随眠心。此刹那后性必不住。更何须断。又有随眠离随眠心二不和合。是故现在亦非所断。然从他音内正作意二因缘故。正见相应。随所治惑能治心生。诸有随眠所治心灭。此心生时彼心灭时平等平等。对治生灭道理应知。正见相应能对治心。于现在世无有随眠。于过去世亦无随眠。此刹那后离随眠心。在未来世亦无随眠。从此已后于已转依已断随眠身相续中。所有后得世间所摄善无记心去来今位皆离随眠。是故三世皆得说断。是名烦恼杂染染净差别

云何建立烦恼杂染迷断差别。当知略说有十五种。谓欲界系见苦集灭道谛所断及修所断诸漏有五。如欲界系。色无色系各五亦尔。欲界迷苦有十烦恼。迷集有八。除萨迦耶及边执见。如迷集谛灭道亦尔。上界诸谛并除嗔恚。随迷次第如欲界说

云何迷苦有十随眠。略五取蕴总名为苦。愚夫于此五取蕴中起二十句萨迦耶见。五句见我。余见我所。是名迷苦萨迦耶见。即用如是萨迦耶见以为依止。于五取蕴见我断常。故边执见亦迷于苦。又诸邪见谓无施等乃至妙行恶行业果及与异熟。是迷苦谛。又有邪见拨无父母化生有情。如是邪见一分迷苦。一分迷集。又诸外道诽谤苦谛起大邪见。彼谓沙门乔答摩种。为诸弟子施设苦谛。此定无有。如是邪见亦迷苦谛。又有诸见妄计自在世主释梵及余物类。为常为恒无有变易。如是邪见亦迷苦谛。又有诸见计边无边。如是亦名迷苦邪见。又有沙门若婆罗门不死矫乱邪见。一分亦迷苦谛。若有见取。妄取迷苦所有诸见以为第一。谓能清净解脱出离。如是名为迷苦见取。若有妄取随顺此见此见随法所受戒禁。以为第一能得清净解脱出离。此戒禁取是迷苦谛。若有外道于此诸见不定信受。亦不一向诽谤如来所立苦谛。但于苦谛心怀犹豫。此及所余于苦犹豫是迷苦疑。若于如是自所起见。宝爱坚着如此见贪。是迷苦贪。若于异分他所起见。心怀违损是迷苦恚。若恃此见心生高举。是迷苦慢。若有无智与此诸见及疑贪等烦恼相应。若唯于苦独行无智。如是并名迷苦无明。此十烦恼皆迷苦谛见苦所断

云何迷集有八随眠。谓诸沙门若婆罗门谤因邪见。又有沙门若婆罗门。计自在等是一切物生者化者及与作者。此恶因论所有邪见。又有邪见。无施无爱亦无祠祀。无有妙行亦无恶行。又有邪见不死矫乱。外道沙门若婆罗门所起一分。又有邪见诽谤集谛。谓诸外道作如是计。如彼沙门乔答摩种为诸弟子所说集谛。此定无有。如是等见是迷集谛所起邪见。若有见取取彼诸见以为第一能得清净解脱出离。是迷集谛所起见取。若于随顺此见诸法所受戒禁。取为第一能得清净。广说如前。是迷集谛戒禁取。余疑贪等如前应知。如是八种烦恼随眠。迷于集谛见集所断

云何迷灭有八随眠。谓诸沙门若婆罗门。计边无边不死矫乱诸见一分。又有沙门若婆罗门。谓说现法涅槃论者所有邪见。又有邪见拨无世间真阿罗汉。乃至广说。彼阿罗汉二德所显。谓断及智。此中但取谤断邪见。又有邪见诽谤灭谛。谓诸外道广说如前。又有横计诸邪解脱所有邪见。如是诸见是迷灭谛所起邪见。若有见取取彼诸见以为第一。广说如前。是迷灭谛所起见取。若于随顺彼见诸法所受戒禁。取为第一。广说如前。是迷灭谛戒禁取。所余贪等如前应知。唯除嗔恚。谓于灭谛起怖畏心起损害心起恚恼心。如是嗔恚迷于灭谛。余如前说。如是八种烦恼随眠。迷于灭谛见灭所断

云何迷道有八随眠。谓拨无世间真阿罗汉。乃至广说。此中所有诽谤。一切智为导首有为无漏。当知此见是迷道谛所起邪见。又诸沙门若婆罗门不死矫乱邪见一分亦迷于道。又诸外道谤道邪见。彼谓沙门乔答摩种为诸弟子说出离道。实非出离。由此不能尽出离苦。佛所施设无我之见。及所受持戒禁随法。是恶邪道非正妙道。如是亦名迷道邪见。又彼外道作如是计。我等所行若行若道是真行道。能尽能出一切诸苦。如是亦名迷道邪见。若有见取取彼邪见以为第一能得清净解脱出离。如是名为迷道见取。若于随顺彼见诸法所受戒禁。取为第一能得清净解脱出离。是名迷道戒禁取。所余贪等迷道烦恼。如迷灭谛道理应知。如是八种烦恼随眠。迷于道谛见道所断

如是已说见断诸漏。云何修道所断诸漏。谓欲界嗔恚。三界三种贪慢无明。由彼长时修习正道方能得断。是故名为修道所断。又彼烦恼界界地地皆有三品。谓下中上。能断之道亦有三品。下品之道能断上品修断诸漏。中能断中。上道断下。又彼修道所断诸漏。于有漏事任运而转。长时坚固于自所迷事难可解脱。是名建立烦恼杂染迷断差别

复次即如所说见修所断诸漏烦恼。当知略有五种所缘。一缘邪分别所起事境。二缘见境。三缘戒禁境。四缘自分别所起名境。五缘任运坚固事境。此中若缘苦集事境所有诸漏。是缘邪分别所起事境。见取贪等见断诸漏除疑。是缘见境。戒禁取。是缘戒禁境。缘灭道境及缘不同分界境所有诸漏。是缘自分别所起名境。何以故。非此烦恼能缘灭道。亦不能缘不同分界。非无所缘故。修所断漏。是缘自任运坚固事境

云何建立烦恼杂染对治差别。谓略四种。一相续成熟对治。二近断对治。三一分断对治。四具分断对治。如声闻地已具说。十三种资粮道。名相续成熟对治。如声闻地已具说。暖顶忍世第一法决择分善根。名近断对治。见道名一分断对治。修道名具分断对治。问升见道圣者智行有何相由几心故见道究竟。云何当舍见所断惑。顿耶渐耶。答升见道者所有智行远离众相。尔时圣智虽缘于苦。然于苦事不起分别谓此为苦取相而转。如于苦谛。于集灭道亦复如是。尔时即于先世俗智所观谛中一切想相。皆得解脱。绝戏论智。但于其义缘真如理离相而转。其于尔时智行如是。建立见道由二道理。一广布圣教道理。有戏论建立。二内证胜义道理。离戏论建立。依初建立增上力故。说法智品有四种心。种类智品亦有四心。随尔所时八种心转。即尔所时总说名一无间所入纯奢摩他所显之心。如是总说有九种心。见道究竟。随尔所时如所施设苦谛之相了别究竟。即尔所时说名一心。第二建立增上力故说有一心。谓唯依一证真如智相应心类。见道究竟。此中亦有奢摩他道。如前应知。又立二分见道所断烦恼随眠。一随逐清净色。二随逐心心所。由见道中止观双运故。圣弟子俱时能舍止观二道所断随眠。第一观所断。第二止所断。是故见道说名究竟。若言观品所摄诸智见断随眠随逐生者。应不得名对治体性。由此因缘薄伽梵说。随信行者随法行者入见道时。名为第六。行无相行补特伽罗。非信胜解。见得。身证。慧脱。俱脱五得其名。由彼于灭住寂静想。是故说彼名住无相。譬如良医拔毒箭者。知痈熟已利刀先剖。脓虽渐出犹未顿尽。后更广开周回[(ㄇ@人)/齊]搦。脓出漉尽未能甚净。疮门尚开为令敛故。或以腻团或以腻帛而帖塞之。如是渐次肌肉得敛。令义易了故作此喻。此中义者如已熟痈。当知随顺见道所断诸漏处事亦尔。如利刀剖。当知毗钵舍那品所摄见道亦尔。如周[(ㄇ@人)/齊]搦。当知奢摩他品所摄见道亦尔。如脓。当知一切见道所断随眠漏亦尔。如疮未净未敛。当知修道所断诸漏漏事亦尔。如腻团帛。当知修道亦尔。若诸异生离欲界欲或色界欲。但由修道无有见道。彼于欲界得离欲时。贪欲嗔恚及彼随法邻近憍慢。若诸烦恼相应无明不现行故皆说名断。非如见道所断萨迦耶见等由彼诸惑住此身中。从定起已有时现行。非生上者彼复现起。如是异生离色界欲。如其所应除嗔恚余烦恼当知亦尔。自地所有见断诸漏。若定若起若生。于一切时若遇生缘便现在前。复次略有二种粗重。一漏粗重。二有漏粗重。漏粗重者。阿罗汉等修道所断烦恼断时皆悉永离。此谓有随眠者有识身中不安隐性无堪能性。有漏粗重者。随眠断时从漏所生漏所熏发。本所得性不安隐性。苦依附性与彼相似无堪能性。皆得微薄。又此有漏粗重名烦恼习。阿罗汉独觉所未能断。唯有如来能究竟断。是故说彼名永断习气不共佛法。是名烦恼杂染由五种相差别建立

问如世尊言。妄分别贪名士夫欲。以何因缘唯烦恼欲说名为欲非事欲耶。答以烦恼欲性染污故。又唯烦恼欲能欲事欲故。又烦恼欲发动事欲。令生种种杂染过患。谓诸所有妄分别贪未断未知故。先为欲爱之所烧恼。欲爱烧故追求诸欲。追求欲故便受种种身心疲苦。虽设功劳。若不称遂。便谓我今唐捐其功。乃受劬劳无果之苦。设得称遂便深恋着。守掌因缘受防护苦。若受用时贪火所烧。于内便受不寂静苦。若彼失坏受愁忧苦。由随念故受追忆苦。又由是因发起身语及意恶行。又出家者弃舍欲时。虽复舍离烦恼欲。因欲复还起。又唯烦恼欲因缘故。能招欲界生老病死恶趣等苦。如是等辈杂染过患。皆烦恼欲以为因缘。是故世尊唯烦恼欲说名为欲非于事欲

问能生欲贪虚妄分别凡有几种。答略有八种。一引发分别。二觉悟分别。三合结分别四有相分别五亲昵分别。六喜乐分别。七侵逼分别。八极亲昵分别。如梵问经言

  引发与觉悟　　及余和合结
  有相若亲昵　　亦多种喜乐
  侵逼极亲昵　　名虚妄分别
  能生于欲贪　　智者当远离

引发分别者。谓舍善方便心相续已。于诸欲中发生作意。觉悟分别者。谓于不和合不现前境。由贪欲缠之所缠缚。合结分别者。谓贪欲缠所缠缚故追求诸欲。有相分别者。谓于和合现前境界。执取其相执取随好。亲昵分别者。谓于和合现前境界。由贪欲缠之所缠缚。喜乐分别者。谓由如是贪欲缠故。希求无量所受欲具。侵逼分别者。谓由一向见其功德而受诸欲倍更希求。乐亲昵分别者。谓为最极诸贪欲缠之所缠缚。问何故欲界诸烦恼中。唯显示贪以为欲相。答若由是因显示贪爱为集谛相。即以此因当知此相。问何故显示分别俱贪以为欲相。答若此因缘令贪现前发起于贪。若此因缘受用事欲。总显为一妄分别贪。又有一分弃舍诸欲而出家者仍于诸欲起妄分别。为令了知虚妄分别亦是欲已寻复弃舍故。显分别亦是欲相。问何故唯说贪爱为集谛相。答由二因缘。一者贪爱是愿不愿所依处故。二者贪爱遍生起故。所以者何。由彼贪爱于身财等所应期愿。为现摄受故便起期愿。于非愿处对治善中为非所愿。现摄方便故便起不愿。由此愿不愿故生死流转无有断绝。当知遍起复有三种。一者位遍。依一切受差别转故。谓由五门喜和合故。喜不离故。喜不合故。喜乖离故。常随自身而藏爱故。二者时遍。谓缘去来今三世境故。三者境遍。谓缘现法后法内身而起。亦缘已得未得境界而起。问何故唯说离贪嗔痴心得离欲。不说离色受等烦恼事耶。答由离于此亦离彼故。又诸烦恼性染污故。又即由此多过患故。所以者何。若于其事起诸过患。当知皆是烦恼所作。是诸过患如前蕴善巧中观察不善所有过患。又可避故。所以者何。于诸事中一切烦恼皆可避脱。非一切事。又由修习不净观等诸世俗道。虽厌其事入离欲地。然离欲地烦恼随逐。烦恼于心未得离欲。由此道理唯离烦恼。心善离欲非离其事。于此处所余决择文更不复现。问何因缘故于诸经中。从余烦恼简取我我所见我慢执着随眠。说为染污烦恼品耶。答由三因故。一向邪行故。谓我我所见二种故。所以者何。依止身见以为根本。便能生起六十二见。依托此故于非解脱计为解脱而起邪行。二背正行故。谓我慢执着二种。所以者何。依止我慢执着故。于此正法毗柰耶中所有善友。所谓诸佛及佛弟子真善丈夫。不往请问云何为善云何不善。设彼来问亦不如实显发自己。三退胜位故。谓随眠一种。所以者何。虽到有顶。下地随眠所随逐故复还退堕。复有差别。谓通达所知于灭作证。有二种法极为障碍。一邪行因缘。二苦生因缘。邪行因缘者。谓六十二见。因此执故于诸有情由身语意起诸邪行。苦生因缘者。谓不断随眠故。又此二业有二因缘。邪行因缘因缘者。谓计我我所萨迦耶见。苦生因缘因缘者。谓初后两位不起正行。由我慢故初不闻正法。由增上慢故后不修正行。复有差别。谓于善说法毗柰耶中。有四种法为最为上。胜极胜妙不共外道。何等为四。一者于谛简择。二者于己同梵行所修可乐法。三者于异论所不生憎嫉。四于清净品能不退失。于恶说法毗柰耶中有四种法。于此四法极为障碍。一计我我所萨迦耶见。二我慢。三妄执谛取。四不断随眠。由此因缘虽到有顶必还堕落。又有二执。一根境执。谓执我我所。二展转有情执。谓我慢。计我为胜等。问自有贪爱为众苦因。何故余处世尊复说欲为苦因。答以是现法苦因缘故。所以者何。若于有情有欲有贪或有亲昵。彼若变异便生忧恼等苦。问何故五盖说名为龟。答五支相似故。能障修习如理作意故。问何缘故忿说名母驼。答似彼性故。由恶语者于他言词不能堪忍增上力故。能障得彼教授教诫。问何故悭嫉说名凝血。答由于虚薄无味利养而现行故。能障可爱乐法故。问何故诸欲说名屠机上肉。答系属主宰无定实故。能障无间修善法故。问何故无明说名浪耆。答似彼性故。障闻智故。问何缘故疑说名岐路。答似彼性故。障思智故。问何故我慢说名轮围。答似彼性故。障修智故。问更有所余能发恶行无量烦恼何故简取贪嗔痴立不善根。答发业因缘略有三种。谓爱味因缘故。损他因缘故。执着建立邪法因缘故。此贪嗔痴于上因缘如应配释

中嗢拖南曰

  欲爱离欲　　计我等欲　　龟驼母等
  及贪嗔等

瑜伽师地论卷第五十八瑜伽师地论卷第五十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中有寻有伺等三地之二

问贪等十烦恼。几能发业几不能发。答一切能发。若诸烦恼猛利现行。方能发起往恶趣业。非诸失念而现行者。又分别起能发此业。非任运起

问诸烦恼有几相。答略有三相。一自相。二共相。三差别相。自相者。谓贪嗔等各各自性所摄相。共相者。谓诸烦恼无有差别。一切皆同不寂静相。差别相者。复有二种。一门差别相。二转差别相。门差别相者。谓结缚随眠随烦恼缠等。如本地分已说。转差别相者。谓随眠转故。所缘转故。现行转故。品差别转故。力无力转故。因果转故。迷行转故

复次随眠转相略有十八。一随逐自境随眠。二随逐他境随眠。三被损随眠。四不被损随眠。五随增随眠。六不随增随眠。七具分随眠。八不具分随眠。九可害随眠。十不可害随眠。十一增上随眠。十二平等随眠。十三下劣随眠。十四觉悟随眠。十五不觉悟随眠。十六能生多苦随眠。十七能生少苦随眠。十八不能生苦随眠。随逐自境随眠者。谓三界中自地所摄随眠。随逐他境随眠者。谓生上下地下上烦恼所逐随眠。被损随眠者。谓世间离欲下地随眠。不被损随眠者。谓已离欲或未离欲自地随眠。随增随眠者。谓自地随眠。不随增随眠者。谓他地随眠。具分随眠者。谓诸异生所有随眠。不具分随眠者。谓诸有学非异生者所有随眠。可害随眠者。谓般涅槃法所有随眠。不可害随眠者。谓不般涅槃法所有随眠。增上随眠者。谓贪等行所有随眠。平等随眠者。谓等分行所有随眠。下劣随眠者。谓薄尘行所有随眠。觉悟随眠者。谓诸缠果与缠俱转随眠。不觉悟随眠者。谓离诸缠而恒随逐随眠。能生多苦随眠者。谓欲界随眠。能生少苦随眠者。谓色无色界随眠。不能生苦随眠者。谓得自在菩萨所有随眠

问如说粗重体性名随眠。此烦恼品粗重望彼诸行。当言有异为不异耶。答当言有异。何以故。由阿罗汉永害一切烦恼粗重而诸行相续犹未断绝故。问有几粗重摄诸粗重。答略有十八。一自性异熟粗重。二自性烦恼粗重。三自性业粗重。四烦恼障粗重。五业障粗重。六异熟障粗重。七盖粗重。八不正寻思粗重。九愁恼粗重。十怖畏粗重。十一劬劳粗重。十二饮食粗重。十三眠梦粗重。十四淫欲粗重。十五界不平等粗重。十六时分变异粗重。十七终没粗重。十八遍行粗重。如是粗重如前应知。复次所缘现行二转。于其自处当广宣说。品差别转当知如前蕴善巧说。力无力转当知如前本地分说。因果转者。谓烦恼业生皆以烦恼为因果。亦如是随应当知。欲界一分不善烦恼有异熟果。应知所余无异熟果。迷行转者。如本地分。七种已列义别云何。谓萨迦耶见。边执见。邪见。此三于所知境。起邪了行。于四圣谛迷行转故。无明一种是不了行。疑是了不了行。见取戒禁取及贪嗔等。缘见为境。见所断者。彼一切皆是执邪了行。即此一切迷苦集谛者。是迷彼因缘所依处行。即此一切迷灭道谛者。是迷彼怖畏生行。即彼一切任运所起修道断者。是任运现行迷执行。复次如前所说一切烦恼障治差别。但依化宜显示粗相。建立烦恼迷执邪行。为令所化有情于种种烦恼诸行过失易生解故。今当总辩一切烦恼如实巨细之相。建立迷执诸行差别。问如是诸烦恼几有事几无事。答诸见与慢是无事。于诸行中实无有我。而分别转故。贪恚是有事。无明疑通二种

问是诸烦恼几与乐根相应。乃至几与舍根相应。答若任运生一切烦恼。皆于三受现行可得。是故通一切识身者。与一切根相应。不通一切识身者。与意地一切根相应。不任运生一切烦恼随其所应诸根相应。我今当说。贪于一时乐喜相应。或于一时忧苦相应。或于一时与舍相应。问如何等。答如有一或于乐受起会遇爱不乖离爱。而现在前遂于乐受不会遇非会遇。若乖离非和合。或于苦受起不会爱若乖离爱。而现在前遂于苦受合会非不合会。不乖离非乖离。由是因缘贪于一时忧苦相应。与此相违喜乐相应。若于不苦不乐位而生味着。当知此贪舍根相应。恚于一时忧苦相应。或有一时喜乐相应。问如何等。答如有一自然为苦逼切身心。遂于内苦作意思惟发恚恨心。或于非爱诸行有情及诸法所。作意思惟发恚恨心。由是故恚忧苦相应。问恚与喜乐相应如何等。答如有一于怨家等非爱有情起恚恼心。作意思惟愿彼没苦。没已不济。或不得乐得已还失。若遂所愿便生喜乐。由是故恚喜乐相应。萨迦耶见及边执见。若于乐俱行蕴观我我所。或观为常。喜根相应。若于苦俱行蕴观我我所。或观为常。忧根相应。若于舍俱行蕴观我我所。或观为常。舍根相应。断见摄边执见。当知一切与彼相违。见取戒禁取。取彼见故随其所应如彼相应。邪见一种。先作妙行忧根相应。先作恶行喜根相应。慢于一时喜根相应。或于一时忧根相应。问如何等。答略有二慢。一高举慢。二卑下慢。又高举慢有三高举。何等为三。谓称量高举。解了高举。利养高举。此高举慢喜根相应。若卑下慢与彼相违忧根相应。疑若于利养恭敬称誉乐善趣等决定事中。他所导引令犹豫者。忧根相应。于无利养不敬讥毁苦恶趣等决定事中。他所导引令犹豫者。喜根相应。无明通与五根相应。所余相应引事指斥文不复现。先辩烦恼诸根相应。但约粗相道理建立。令初行者解无乱故。今约巨细道理建立。令久行者了自他身种种行解差别转故

复次诸烦恼略有三聚。一欲界系。二色界系。三无色界系。问如是三聚。几不善几无记。答初聚一分是不善。余二聚是无记。诸不善者。是有异熟非余。问几多性几少性。答初多性余不尔。如多性少性如是。猛利长时染恼性。非猛利长时染恼性。发起外门杂染性。发起内门杂染性。发起恶行性。发起非恶行性。能生多苦性。能生少苦性。大有罪性。小有罪性。迟离欲性。速离欲性。不离欲所显性。离欲所显性。三摩地相违性。非三摩地相违性。非一种相生决定性。一种相生决定性等。当知亦尔。中嗢拖南曰

  多染恼内门　　恶行生诸苦
  有罪迟离欲　　三摩地生等

复次云何能断烦恼。齐何当言已断烦恼。从何烦恼而可说断。断诸烦恼为顿为渐。云何次第断诸烦恼。诸烦恼断复有几种。烦恼断已有何等相。诸烦恼断有何胜利

谓善法资粮已积集故。已得证入方便地故。证得见地故。积习修地故。能断烦恼得究竟地。当言已断一切烦恼。复有差别。谓由修习四种瑜伽能断烦恼。若善修习如是四种。当言已断一切烦恼。四种瑜伽如声闻地已说其相。复有差别。谓相续成熟故。得随顺教故。内正作意故。对治道生故。能断烦恼。修对治道已到究竟。当言已断一切烦恼。复有差别。谓了知烦恼事故。了知烦恼自性故。了知烦恼过患故。烦恼生已不坚着故。摄受对治故。能断烦恼。对治已生当言已断一切烦恼。复有差别。修奢摩他故。修毗钵舍那故。能断烦恼。若诸相缚已得解脱。诸粗重缚亦得解脱。当言已断一切烦恼。如世尊言

  相缚缚众生　　亦由粗重缚
  善双修止观　　方乃俱解脱

复有差别。谓了知所缘故。喜乐所缘故。能断烦恼所依已灭故。已得转依故。当言已断一切烦恼

复次从彼相应及所缘故烦恼可断。所以者何。对治道生烦恼不起得无生法。是故说名断。彼相应相应断。已不复缘境故。从所缘亦说名断

复次见断烦恼顿断非渐。所以者何。由现观智谛现观故能断见道所断烦恼。然此现观与坏缘谛作意相应。是故三心顿断一切迷苦谛等见断烦恼。修断烦恼渐次而断。数数修道方能断故

复次最初应断不善事业及诸恶见。谓在家者。次复应断乐出家障。谓欲寻思。恚寻思。害寻思。次复应断不定心者三摩地障。谓眷属寻思。国土寻思。不死寻思。次复应断得作意障。谓乐远离品身诸粗重。次复应断见断烦恼。次复应断修断烦恼。次复应断属苦属忧属乐属喜。及属诸舍诸定障品障碍烦恼。次复有一补特伽罗。应断所知障品诸障。由此次第应断烦恼

复次诸烦恼断当知多种。略则为二。一诸缠断。二随眠断。诸缠断者。谓贪嗔断乃至疑断。萨迦耶见断乃至邪见断。见苦所断断乃至修道所断断。欲界所系断。乃至无色界所系断。散乱断晓悟断。羸劣断制伏断离系断。当知离系断即是随眠断

复次烦恼断已。于可爱法若劣若胜若现在前若不现前。虽猛利见而观察之亦不染着。如于可爱而不生爱如是。于可嗔法亦不生嗔。于可痴法亦不生痴。又眼见诸色不喜不忧。但住于舍正念正知。如眼见。色乃至意知法亦尔。又性少欲成就第一真实少欲。如少欲如是。喜足远离。勇猛精进。安住正念。寂定聪慧亦尔。于无戏论任性好乐。于有戏论策励其心方能缘虑。如是等辈当知烦恼已断之相。复次烦恼断者有多胜利。谓随证得超越忧苦超越喜乐。超越色想及与有对种种性想。超恶趣苦。超越生等一切种苦。又证安隐第一安隐。又证清凉第一清凉。又得第一现法乐住。随其自心自在而转。若行若住随所欲乐所证之法。无复退转。于自义利圆满究竟。于诸所作无复希望。或复有一修利他行。为欲利益安乐众生哀愍世间。令诸天人利益安乐。当知烦恼断者。有如是等众多胜利。复次烦恼缘境略有十五。一具分缘。谓身见等。二一分缘。谓贪嗔慢等。三有事缘。谓诸有事烦恼。四无事缘。谓诸无事烦恼。五内缘。谓缘六处定不定地所有烦恼。六外缘。谓缘妙五欲所有烦恼。七现见缘。谓缘现在所有烦恼。八不现见缘。谓缘去来所有烦恼。九自类缘。谓缘自类烦恼所有烦恼。十他类缘。谓缘异类烦恼及缘烦恼事所有烦恼。十一有缘。谓缘后有所有烦恼。十二无有缘。谓缘断无有所有烦恼。十三自境缘。谓欲界于欲行烦恼。色界于色行烦恼。无色界于无色行烦恼。十四他境缘。谓色界于欲行烦恼。无色界于色行烦恼。又复下地于上地烦恼。所以者何。生上地者于彼下地诸有情所。由常恒乐净具胜功德自谓为胜故。十五无境缘。谓缘分别所计灭道及广大佛法等所有烦恼

复次烦恼现行有二十种。谓二十种补特伽罗。依二十缘起。二十种现行烦恼云何二十补特伽罗。一在家。二出家。三住恶说法。四住善说法。五增上烦恼行。六等分行。七薄尘行。八世间离欲。九未离欲。十见圣迹。十一未见圣迹。十二执着。十三不执着。十四观察。十五睡眠。十六觉悟。十七幼少。十八根成熟。十九般涅槃法。二十不般涅槃法

云何二十烦恼现行。一随所欲缠现行。二不随所欲缠现行。三无所了知烦恼现行。四有所了知烦恼现行。五粗烦恼现行。六等烦恼现行。七微烦恼现行。八内门烦恼现行。九外门烦恼现行。十失念烦恼现行。十一猛利烦恼现行。十二分别所起烦恼现行。十三任运所起烦恼现行。十四寻思烦恼现行。十五不自在烦恼现行。十六自在烦恼现行。十七非所依位烦恼现行。十八所依位烦恼现行。十九可救疗烦恼现行。二十不可救疗烦恼现行。云何二十烦恼现行缘。一乐缘。二苦缘。三不苦不乐缘。四欲缘。五寻思缘。六触缘。七随眠缘。八宿习缘。九亲近恶友缘。十闻不正法缘。十一不正作意缘。十二不信缘。十三懈怠缘。十四失念缘。十五散乱缘。十六恶慧缘。十七放逸缘。十八烦恼缘。十九未离欲缘。二十异生性缘。依此诸缘故烦恼现行

问于彼彼界结生相续彼彼身中。当言全界一切烦恼皆结生耶。为不全耶。答当言全非不全。何以故。若未离欲。于自生处方得受生。非离欲故。又未离欲者。诸烦恼品所有粗重。随缚自身。亦能为彼异身生因。由是因缘当知一切烦恼皆结生相续。又将受生时。于自体上贪爱现行。于男于女若爱若恚亦互现行。又疑现行彼作是思。此男此女今为与我共行事不。又于内外我我所见及我慢等皆亦现行。由此因缘当知一切烦恼皆得结生相续

复次结生相续略有七种。一缠及随眠结生相续。谓诸异生。二唯随眠结生相续。谓见圣迹。三正知入胎结生相续。谓转轮王。四正知入住结生相续。谓诸独觉。五于一切位不失正念结生相续。谓诸菩萨。六业所引发结生相续。谓除菩萨结生相续。七智所引发结生相续。谓诸菩萨。又有引无义利结生相续。谓即业所引发结生相续。又有能引义利结生相续。谓智所引发结生相续。如是总说结生相续。或七或九

复次于此处。所有余一切顺前句顺后句。及四句等如理决择文更不复现。

后嗢拖南曰

  业相事乐等　　不善等及断
  所缘与现行　　续生最为后

如是已说烦恼杂染决择。业杂染决择。我今当说。如先所说业杂染义。当知此业亦由五相建立差别。谓根本业道所摄身语意业。及彼方便后起所摄诸业。如先所说不善业道。名根本业道所摄不善身语意业。

云何建立彼杀生等不善业道自相。谓染污心起彼欲乐。即于是处彼业现行而得究竟。当知总名杀生等一切业道自相

染污心者。谓贪者贪所蔽。嗔者嗔所蔽。痴者痴所蔽。设有染污心不起彼欲乐。虽于是处彼业现行而得究竟。然此恶业非是圆满业道所摄。设有染污心及起彼欲乐。而颠倒心设于余事彼业现行而得究竟。此业亦非圆满业道所摄。设有染污心及起彼欲乐。即于是处业不现行而得究竟。此业亦非圆满业道所摄。设有染污心及起彼欲乐。即于是处彼业现行而不究竟。此业亦非圆满业道所摄。若有染污心及起彼欲乐。即于是处彼业现行而得究竟。具一切支此业乃名圆满业道所摄。由此略说业道自相。一切不善业道自相应随决了。复次若广建立十恶业道自性差别。

复由五相。何等为五。一事。二想。三欲乐。四烦恼。五方便究竟。事者。一一业道各别决定所依处事。或有情数或非有情数。随其所应十恶业道依之而转。想者有四。谓于彼非彼想。非于彼彼想。于彼彼想。非于彼非彼想。欲乐者。或有倒想或无倒想乐所作欲。烦恼者。或贪或嗔或痴。或贪嗔或贪痴或嗔痴。或贪嗔痴一切皆具。方便究竟者。即于所欲作业随起方便。或于尔时或于后时而得究竟。由此五相于杀生乃至邪见诸业道中。随其所应当广建立圆满自性十种差别。杀生业道以有情数众生为事。若能害者于众生所。作众生想起害生欲。此想即名于彼众生名不颠倒想。依此想故作如是心。我当害生。如是名为杀生欲乐。此能害者或贪所蔽。或嗔所蔽。或痴所蔽。或二所蔽。或三所蔽。而起作心。是名烦恼。彼由欲乐及染污心。或自或他发起方便加害众生。若害无间彼便命终。即此方便当于尔时说名成就究竟业道。若于后时彼方舍命。由此方便彼命终时。乃名成就究竟

业道

不与取业道事者。谓他所摄物。想者。谓于彼彼想。欲乐者。谓劫盗欲。烦恼者。谓三毒或具不具。方便究竟者。谓起方便移离本处。欲邪行业道事者。谓女所不应行。设所应行非支非处非时非量。若不应理一切男及不男。想者。于彼彼想。欲乐者。谓乐行之欲。烦恼者。谓三毒或具不具。方便究竟者。谓两两交会妄语业道事者。谓见闻觉知。不见不闻不觉不知。想者。谓于见等或翻彼想。欲乐者。谓覆藏想乐说之欲。烦恼者。谓贪嗔痴或具不具。方便究竟者。谓时众及对论者领解。离间语业道事者。谓诸有情或和不和。想者。谓俱于彼若合若离随起一想。欲乐者。谓乐彼乖离若不和合欲。烦恼者。谓三毒或具不具。方便究竟者。谓所破领

解

粗恶语业道事者。谓诸有情能为违损。想者。谓于彼彼想。欲乐者。谓乐粗言欲。烦恼者。谓三毒或具不具。方便究竟者。谓呵骂彼。绮语业道事者。谓能引发无利之义。想者。谓于彼彼想。欲乐者。谓乐说之欲。烦恼者。谓三毒或具不具。方便究竟者。谓才发言

贪欲业道事者。谓属他财产。想者。谓于彼彼想。欲乐者。谓即如是爱欲。烦恼者。谓三毒或具不具。方便究竟者。谓于彼事定期属己

嗔恚业道事之与想。如粗恶语说。欲乐者。谓损害等欲。烦恼者。谓三毒或具不具。方便究竟者。谓损害等期心决定

邪见业道事者。谓实有义。想者。谓于有非有想。欲乐者。谓即如是爱欲烦恼者。谓三毒或具不具。方便究竟者。谓诽谤决定

复次杀生有三种。一有罪增长。二有罪不增长。三无有罪。生罪因缘亦略有三。一烦恼所起。二能生于苦。三希望满足。初具三缘。次有二种无希望满。后唯生苦

复次略由五相建立贪欲嗔恚邪见圆满自相。何等名为贪欲五相。一有耽着心。谓于自财所。二有贪婪心。谓乐积财物。三有饕餮心。谓于属他资财等事计为华好深生爱味。四有谋略心。谓作是心。凡彼所有何当属我。五有覆蔽心。谓贪欲缠之所覆故不觉羞耻。不知过患及与出离。设于自财有耽着心无余心现。当知此非圆满贪欲意恶行相。如是有耽着心及贪婪心无余心现。亦非圆满贪欲之相。如是广说乃至如前所说诸相。随阙一种即非圆满贪欲之相。若全分摄乃名圆满贪欲之相。何等名为嗔恚五相。一有增恶心。谓于能损害相随法分别故。二有不堪耐心。谓于不饶益不堪忍故。三有怨恨心。谓于不饶益数不如理随忆念故。四有谋略心。谓于有情作如是意。何当捶挞。何当杀害。乃至广说故。五有覆蔽心。谓如前说于此五相随阙一种。即非圆满嗔恚之相。若具一切方名圆满。何等名为邪见五相。一有愚痴心。谓不如实了所知故。二有暴酷心。谓乐作诸恶故。三有越流行心。谓于诸法不如理分别推求故。四有失坏心。谓无施与爱养祠祀等。诽谤一切妙行等故。五有覆蔽心。谓邪见缠之所覆蔽。不觉羞耻不知过患及出离故于此五相随阙一种。即非圆满邪见之相。具一切分乃名圆满。

复次若以手等害诸众生。说名杀生。如是以块杖刀缚录断食。折挫。治罚。咒药。厌祷。尸。半尸等害诸众生。皆名杀生。为财利等害诸众生。亦名杀生。或怨为损或为除怨。或谓为法乃至或为戏乐害诸众生。亦名杀生。若自杀害若令他害皆得杀罪

复次若有显然劫他财物。名不与取。如是窃盗攻墙解结伏道窃夺。或有拒债受寄不还。或行诳谄矫诈而取。或现怖畏方便而取。或现威德而取彼物。或自劫盗或复令他。如是一切皆不与取。或有自为或有为他。或怖畏故。或为杀缚。或为折伏。或为受用。或为给侍。或憎嫉故不与而取。此等皆名不与取罪。复次若行不应行名欲邪行。或于非支非时非处非量非理。如是一切皆欲邪行。若于母等母等所护。如经广说。名不应行。一切男及不男属自属他皆不应行。除产门外所有余分皆名非支。若秽下时胎圆满时。饮儿乳时受斋戒时。或有病时。谓所有病匪宜习欲。是名非时。若诸尊重所集会处。或灵庙中或大众前。或坚鞭地高下不平令不安隐。如是等处说名非处。过量而行名为非量。是中量者。极至于五。此外一切皆名过量。不依世礼故名非理。若自行欲若媒合他。此二皆名欲邪行摄。若有公显或复隐窃。或因诳谄方便矫乱。或因委托而行邪行。如是皆名欲邪行罪。复次若自因故而说妄语。或他因故或因怖畏。或因财利而说妄语。皆名妄语。若不见闻觉知言见闻觉知。或见闻觉知言不见闻觉知。皆名妄语。若书陈说。或以默然表忍斯义。或动支体以表其相。或为证说。或有自说或令他说。如是一切皆妄语罪。复次若以实事毁呰于他。为乖离故而发此言。名离间语。或以不实假合方便以为依止。为损坏他而有陈说。或依亲近施与。或依知友给侍而有陈说。名离间语。若自利缘或损他缘。或由他教。或现破德或现怖畏。为乖离故或自发言或令他发。如是皆名离间语罪。复次若有对面发辛楚言。名粗恶语。或不现前或对大众或幽僻处。或随实过不随实过。或书表示或假现相。或依自说或依他说。或因掉举或因不静。或依种族过失。或依依止过失。或依作业禁戒现行过失。或自发起辛楚之言或令他发。如是皆名粗恶语罪

复次若有依舞而发歌词。名为绮语。或依作乐。或复俱依或俱不依而发歌词。皆名绮语。若佛法外能引无义所有书论。以爱乐心受持赞美。以大音声而为讽颂。广为他人开示分别。皆名绮语。若依斗讼诤竞发言。或乐处众宣说王论臣论贼论广说乃至国土等论。皆名绮语。若说妄语或离间语或粗恶语。下至不思不择发无义言。皆名绮语。又依七事而发绮语。谓斗讼诤竞语。诸婆罗门恶咒术语。苦所逼语戏笑游乐之语。处众杂语。颠狂语。邪命语。如是一切名绮语罪。复次若于家主起如是欲。云何我当同于家主领诸仆使随欲所作。是名贪欲。又起是欲。即彼家主所有父母妻子奴婢及诸作使。广说乃至七摄受事十资身事。谓饮食等。皆当属我。又起是欲。云何令他知我少欲知足。远离勇猛。精进安住。正念寂定。聪慧诸漏永尽。施戒多闻。又起是欲。云何令他供养于我。谓诸国王乃至商主。若苾刍苾刍尼。邬波索迦邬波斯迦等。皆当恭敬尊重承事供养于我。又起是欲。云何令我当得利养衣服饮食诸坐卧具病缘医药及资生具。又起是欲。云何令我当生天上天妙五欲以为游戏。又起是欲。云何令我当生鲁达罗世界。毗瑟笯世界人中希有众同分中。乃至令我当生他化自在众同分中。又起是欲。云何令我乃至当得父母妻子。奴婢作使。朋友宰官。亲戚兄弟。同梵行等。所有资产。如是一切皆名贪欲业道所摄

若作是思。彼于我所有无义欲。故我于彼当作无义。是名嗔恚。又作是思。彼于我所已作正作当作无义。我亦于彼当作无义。亦名嗔恚。如是广说九恼害事当知亦尔。又作是思。云何令我于能损害怨家恶友而得自在。缚害驱摈。或行鞭挞。或散财产。或夺妻妾朋友眷属及家宅等。此恼害心亦名嗔恚。又起是思。云何令彼能损于我怨家恶友。于他处所。遭如上说诸苦恼事。此损害心亦名嗔恚。又作是思。愿彼自然发起如是如是身语意行。由此丧失资财朋友。眷属名称。安乐受命及诸善法。身坏当生诸恶趣中。如是一切恼害之心。皆名嗔恚根本业道

复次若作是思。决定无施是名邪见。广说乃至谤因谤用谤果坏真善事。如是一切皆名邪见根本业道。问一切倒见皆名邪见。何故世尊于业道中但说如是诽谤之见。名为邪见。答由此邪见诸邪见中最为殊胜。何以故。由此邪见为依止故。有一沙门若婆罗门断诸善根。又此邪见最顺恶业。怀邪见者于诸恶法随意所行。是故此见偏说在彼恶业道中。当知余见非不邪见自相相应

瑜伽师地论卷第五十九瑜伽师地论卷第六十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中有寻有伺等三地之三

复次由五因缘杀生成重。何等为五。一由意乐。二由方便。三由无治。四由邪执。五由其事。若由猛利贪欲意乐所作。猛利嗔恚意乐所作。猛利愚痴意乐所作。名重杀生。与此相违名轻杀生。若有念言。我应当作正作已作。心便踊跃心生欢悦。或有自作或复劝他。于彼所作称扬赞叹。见同法者意便欣庆长时思量。长时蓄积怨恨心已方有所作。无间所作殷重所作。或于一时顿杀多类。或以坚固发业因缘而行杀害。或令恐怖无所依投方行杀害。或于孤苦贫穷哀戚悲泣等者而行杀害。如是一切由方便故名重杀生。若唯行杀。不能日日乃至极少持一学处。或亦不能于月八日十四十五及半月等受持斋戒。或亦不能于时时间惠施作福。问讯礼拜迎送合掌和敬业等。又亦不能于时时间获得猛利增上惭愧。悔所作恶。又不证得世间离欲。亦不证得真法现观。如是一切由无治故。名重杀生。若诸沙门或婆罗门。继邪祠祀随忍此见。执为正法而行杀戮。由邪执故名重杀生。又作是心杀羊无罪。由彼羊等为资生故世主所化。诸如是等依止邪见而行杀害。皆邪执故名重杀生。若有杀害大身众生。此由事故名重杀生。或有杀害人或人相或父或母及余尊重。或有杀害归投委信或诸有学。或诸菩萨。或阿罗汉。或诸独觉。或于如来作杀害意恶心出血。如来性命不可杀故。如是一切由其事故名重杀生。与如上说因缘相违而杀生者。名轻杀生。复次当说不与取等由其事故轻重差别。余随所应。如杀应知

复次若多劫盗名重不与取。如是若劫盗妙好。劫盗委信。劫盗孤贫。劫盗佛法出家之众。若入聚落而行劫盗。劫盗有学或阿罗汉或诸独觉。或复僧祇或佛灵庙所有财物。如是一切由其事故名重不与取

复次行不应行中。若母母亲委信他妻。或住禁戒或苾刍尼或勤策女或复正学。如是一切由其事故名重欲邪行。非支行中若于面门。由其事故名重欲邪行。非时行中若受斋戒若胎圆满若有重病由其事故名重欲邪行。非处行中若佛灵庙若僧伽蓝。由其事故名重欲邪行

复次若为诳惑多取他财若妙若胜而说妄语。由事重故名重妄语。若于委信若父若母。广说如前乃至佛所而说妄语。由事重故名重妄语。或有妄语令他杀生损失财物及与妻妾。此若成办极重杀生。重不与取。重欲邪行。此由事重名重妄语。或有妄语能破坏僧。于诸妄语此最尤重复次若于长时积习亲爱而行破坏。此由事重名重离间语。或破坏他令离善友父母男女。破和合僧。若离间语能引杀生或不与取或欲邪行。如前所说道理应知。如是一切由事重故名重离间语

复次若于父母及余师长。发粗恶言。由事重故名重粗恶语。或以不实不真妄语。现前毁骂呵责于他。由事重故名重粗恶语

复次凡诸绮语随妄语等。此语轻重如彼应知。若依斗讼诤竞等事而发绮语亦名为重。若以染污心于能引无义外道典籍。承诵赞咏广为他说。由事重故名重绮语。若于父母眷属师长调弄轻笑。现作语言不近道理。亦由事重名重绮语

复次若于僧祇佛灵庙等所有财宝。起贪欲心。由事重故名重贪欲。若于己德起增上慢自谓智者。乃于国王大臣豪贵所尊师长。及诸聪睿同梵行等。起增上欲贪求利养。名重贪欲。复次若于父母眷属师长。起损害心。由事重故名重嗔恚。又于无过贫穷孤苦可伤愍者起损害心。由事重故名重嗔恚。又于诚心来归投者及有恩所。起损害心。由事重故名重嗔恚。复次若于一切余邪见中。诸有能谤一切邪见。此谤一切事门转故名重邪见。又若有见谓无世间真阿罗汉正至正行。乃至广说。如是邪见。由事重故名重邪见。除如上说所有诸事。随其所应与彼相违。皆名为轻

复次杀生所引不善诸业。或有是作而非增长。或有增长而非是作。或有亦作亦复增长。或有非作亦非增长。初句谓无识别童稚所作。或梦所作或不思而作。或自无欲他逼令作。或有暂作续即还起猛利悔心及厌患心。恳责远离正受律仪令彼微薄。未与果报便起世间离欲之道损彼种子。次起出世永断之道。害彼种子令无有余。增长而非作者。谓如有一为害生故于长夜中数随喜伺。由此因缘彼遂增长杀生所引恶不善法。然不能作杀生之业。亦作亦增长者。谓除先所说作非增长增长非作。所余一切杀生业相。非作非增长者。谓除上尔所相。如是所余不与取等乃至绮语。随其所应如杀应知。于贪欲嗔恚邪见中。无有第二增长而非作句。于初句中无有不思而作及他逼令作。余如前说

复次若于杀生亲近数习多所作故。生那落迦。是名杀生异熟果。若从彼没来生此间人同分中。寿量短促。是名杀生等流果。于外所得器世界中。饮食果药皆少光泽势力。异熟及与威德并皆微劣。消变不平生长疾病。由此因缘无量有情未尽寿量非时中夭。是名杀生增上果。所余业道。异熟等流二果差别。如经应知。增上果今当说。若器世间众果鲜少。果不滋长果多朽坏。果不贞实多无雨泽。诸果干枯或全无果。如是一切名不与取增上果。若器世间多诸便秽泥粪不净。臭处迫迮多生不净臭恶之物。凡诸所有皆不可乐。如是一切名欲邪行增上果。若器世间农作行船。世俗事业不甚滋息。殊少便宜多不谐偶。饶诸怖畏恐惧因缘。如是一切是妄语增上果。若器世间其他处所。丘坑间隔险阻难行。饶诸怖畏恐惧因缘。如是一切是离间语增上果。若器世间其地处所。多诸株杌荆棘毒刺凡石沙砾枯槁。无润无有池沼河泉干竭。土田碱卤丘陵坑险。饶诸怖畏恐惧因缘。如是一切是粗恶语增上果。若器世间所有果树果无的当。非时结实时不结实生而似熟。根不坚牢势不久停。园林池沼多不可乐。饶诸怖畏恐惧因缘。如是一切是绮语增上果。若器世间一切盛事年时日夜月半月等渐渐衰微。所有气味唯减不增。如是一切是贪欲增上果。若器世间多诸疫疠灾横扰恼怨敌。惊怖师子虎狼。杂恶禽兽。蟒蛇蝮蝎蚰蜑。百足魍魉药叉诸恶贼等。如是一切是嗔恚增上果。若器世间所有第一胜妙华果悉皆隐没。诸不净物乍似清净。诸苦恼物乍似安乐。非安居所非救护所非归依所。如是一切是邪见增上果

复次如世尊言。杀有三种。谓贪嗔痴之所生起。乃至邪见亦复如是。此差别义云何应知。若为血肉等杀害众生。或作是心。杀害彼已当夺财物。或受他雇或为报恩。或友所摄或希为友。或为衣食奉主教命而行杀害。或有谓彼能为衰损。或有谓彼能障财利而行杀害。如利衰毁誉称讥苦乐随其所应。当知亦尔。如是一切名贪所生杀生业道

复次若谓彼于己乐为无义而行杀害。或念彼于己曾为无义。或恐彼于己当为无义。或见彼于己正为无义而行杀害。广说乃至于九恼事皆如是知。如是一切名嗔所生杀生业道。复次若计为法而行杀害。谓己是余众生善友。彼因我杀身坏命终当生天上。如是杀害从痴所生。或作是心。为尊长故法应杀害。或作是心。诸有诽毁天梵世主。骂婆罗门。法应杀害。如是心杀从痴所生。或计杀生作及增长无异熟果。为他开演劝行杀业。彼由劝故遂行杀事时。彼劝者所得杀罪从痴所生。此后所说从痴所生杀业。道理。诸余业道乃至邪见当知亦尔。或有妄计以其父母亲爱眷属掷置火中。断食投岩弃于旷野。是真正法。如是一切名痴所生杀生业道。复次若于他财食饕餮而取。是不与取贪欲所生。或受他雇而行劫盗。或恩所摄或祈后恩。或为衣食奉主教命。或为称誉或为安乐而行劫盗。如是一切不与取业皆贪所生

复次若作是思。彼于我所乐行无义。广说乃至九恼害事增上力故而行劫盗不必贪着彼所有财。不必希求诸余财物。是不与取嗔恚所生。或憎他故焚烧聚落舍宅财物珍玩资具。当知彼触嗔恚所生。盗相似罪。或更增强或憎彼故。令他劫夺破散彼财。他受教命依行事时。彼能教者不与取罪从嗔恚生

复次若作是心。为尊长故而行劫盗是为正法。名痴所生不与取罪。或作是心。若有诽毁天梵世主骂婆罗门。法应夺彼所有财物。此不与取亦从痴生。或作是心。若为祠祀为祠祀支为祠祀具。法应劫盗。是不与取亦从痴生

复次若有见闻不应行事。便不如理分别取相。遂贪欲缠之所缠缚而行非法。名贪所生欲邪行罪。或受他雇窃行媒嫁。由此方便行所不行。彼便获得贪欲所生欲邪行罪。或欲摄受朋友知识。或为衣食承主教命。或为存活希求财谷金银珍宝而行邪行。如是一切名贪所生欲邪行罪

复次若作是思。彼于我所乐行无义。广说乃至九恼害事以为依止而行邪行。非彼先有欲缠所缠。然于相违非所行事。为报怨故勉励而行。名嗔所生欲邪行罪。或憎彼故以彼妻妾令他毁辱。彼若受教行欲邪行。便触嗔恚所生相似欲邪行罪。或更尤重。如是一切欲邪行罪。名嗔所生

复次若作是心。母及父亲或他妇女命为邪事。若不行者便获大罪。若行此者便获大福。非法谓法而行邪行。名痴所生欲邪行罪

复次若为利养而说妄语。或怖畏他损己财物。或为称誉或为安乐而说妄语。如是一切名贪所生妄语业道。若有依止九恼害事而说妄语。名嗔所生妄语业道若作是心。为诸尊长或复为牛或为祠具。法应妄语。如是妄语从痴所生。若作是心。诸有沙门若婆罗门。违背诸天违梵世主违婆罗门。于彼妄语称顺正法。如是妄语名痴所生妄语业道。若作是计。于法法想。于毗奈耶毗奈耶想。以覆藏想妄语破僧无有非法。如是妄语亦从痴生

如妄语业道。离间粗恶二语业道。随其所应当知亦尔

复次若为戏乐而行绮语。或为显己是聪睿者而行绮语。或为财利称誉安乐而行绮语。名贪所生绮语业道。若有依止九恼害事而说绮语。名嗔所生绮语业道若有于中为求真实为求坚固。为求出离为求于法。而行绮语。名痴所生绮语业道

复次若有于他非怨有情财物资具。先取其相希望追求增上力故起如是心。凡彼所有愿当属我。又从贪爱而生贪爱。名贪所生贪欲业道

若于他财不计为好。但九恼事增上力故起如是心。凡彼所有皆当属我。又从嗔恚而生贪爱。名嗔所生贪欲业道

若作是计。诸有欲求鲁达罗天。毗瑟笯天。释梵世主。众妙世界。注心多住获大福祐。作如是意注心多住。名痴所生贪欲业道若为财利称誉安乐。于他有情起损害心。非于彼所生怨憎想。谓彼长夜是我等怨。又从贪爱而生嗔恚。名贪所生嗔恚业道

复次若九恼事增上力故。从怨对想起损害心。名嗔所生嗔恚业道若住此法及外道法。所有沙门若婆罗门。憎恶他见。于他见所及怀彼见沙门婆罗门所。起损害心。名痴所生嗔恚业道

复次若作是心。诸有此见拨无施与。乃至广说。彼于王等获大供养及衣服等。即以此义增上力故起如是见。名贪所生邪见业道

若作是心。有施有爱乃至广说。如是见者。违害于我。我今不应与怨同见。彼由憎恚起如是见。无施无爱乃至广说。名嗔所生邪见业道

若不如理于法思惟筹量观察。由此方便所引寻伺发起邪见。名痴所生邪见业道

复次杀生业道。三为方便由嗔究竟。如杀业道。粗语嗔恚业道亦尔。不与取业道。三为方便由贪究竟。如不与取。邪行贪欲业道亦尔。除其邪见所余业道。三为方便由三究竟。邪见业道三为方便由痴究竟

复次杀生邪行。妄语离间。粗语嗔恚。此六业道有情处起。不与而取贪欲业道资财处起。绮语业道名身处起。邪见业道诸行处起。复次由三因缘。不善业道成极圆满恶不善性。何等为三。一自性过故。二因缘过故。三涂染过故。此中杀生所引思。乃至邪见所引彼相应思。如是一切染污性故不善性故。由自性过说名为恶。若以猛利贪欲嗔恚愚痴缠所发起。即此亦名由因缘过。成重恶性成上不善。能引增上不可爱果。若到究竟即此亦名由涂染过。成极重恶成上不善。能引增上不可爱果。何以故。若有用染污心。能引发他不可爱乐欣悦之苦。彼随苦心威势力故。能引发苦补特伽罗思。便触得广大之罪。是故名为涂染过失。彼虽不发如是相心。诸能引发我之苦者。当触大罪。然彼法尔触于大罪。譬如礠石虽不作意。诸所有铁来附。于我然彼法尔。所有近铁不由功用来附礠石。此中道理当知亦尔。日珠等喻亦如是。知又于思上无别有法。彼威力生来相依附。说名涂染。当知唯是此思转变。由彼威力之所发起。如四大种业威势力所生。种种坚性湿性软性动性。非大种外别有如是种种诸性。然即大种业威势缘如是转变。如业威势缘力转变。神足加行缘力转变当知亦尔。又如魔王惑媚无量娑梨药迦诸婆罗门长者等心令于世尊变异暴恶。非于彼心更增别法。说名惑媚。唯除魔王加行威势生彼诸心令其转变成极暴恶。此中道理当知亦尔

复次如先所说作及增长业。若先所说由五因缘。成极重业。名定受业。与此相违名不定受业。复有四业。一异熟定。二时分定。三二俱定。四二俱不定。诸阿罗汉所有不善。决定受业。或于前生所作。或于此生先异生位所作。由少轻苦之所逼恼。便名果报已熟。若已转依。果报种子皆永断故一切不受。所以者何。由佛世尊依未解脱相续。建立定受业故。问若于一时亦牵亦搦盗取众生即断其命。当言一业为二业耶。答当言二业。以速转故。于此二业由增上慢。谓之为一。若谓我当牵彼。是第一思。即于盗时复谓我当搦杀。是第二思。若时牵彼尔时不搦。若时搦彼尔时不牵。速疾转故生增上慢谓是一时。是故此中当言二业

复次略由三因缘故成现法受业。何等为三。一田广大故。二思广大故。三相续清净故。由五种相田成广大。一从于一切有情。第一利益安乐增上意乐住起。谓慈等至。二从于一切有情第一将护他心住起。谓无诤等持。三从第一寂静涅槃乐相似圣住起谓灭尽等至。四已得一切不善不作律仪。谓预流果。五极清净相续究竟。谓阿罗汉及佛为首大苾刍僧。如是名为田广大性。若于是处以深厚殷重清净信心。舍清净财。是名思广大性。若前生中于他所施衣服等物。由身语意不为障碍。亦不思量与染污心。以无有障障彼相续。当知是名相续清净。若有于此三种因缘一切具足。当知彼业定现法受。亦于生受亦于后受。若有与此相违三种因缘起不善业。当知亦成定现法受。或有所生一刹那业唯现法受。或有所生一刹那业亦现法受亦于生受。或有所生一刹那业三时皆受。譬如一缕其量微小能持一华。一系华已势力便尽不复能系。复有一缕能持二华。再系华已势力便尽。复有一缕能持多华。多系华已其力方尽。又如流水其性微小流经一步势力便尽。有第二水其性稍大流经两步势力方尽。有第三水其性广大流经多步势力乃尽。又如酢滴其性淡薄唯能酢彼一滴之水不能酢多。有第二滴其性稍严酢二滴水。不能酢多。有余酢滴其性更严乃至能酢众多滴水。此中诸业差别道理当知亦尔

复次十种不善业道唯欲界系。亦唯能感欲界异熟。多于恶趣少于善趣。又恶趣业。预流果时皆已断尽。若诸异生世间离欲或复生上。一切皆伏而未永断。若不还果身犹住此或复上生。及阿罗汉。诸不善业皆毕竟断。若已证入清净增上意乐地。菩萨一切不善业皆毕竟断。此但由不忘念力所制持故。非由烦恼得离系故

复次思是业非业道。杀生乃至绮语亦业亦业道。贪恚邪见业道非业。此诸业道余决择文更不复现

后嗢拖南曰

  自性相广略　　方便与轻重
  增减及瑜伽　　引果生决择

如是已说业道决择。生杂染决择我今当说。如先所说生杂染义。当知此生略有十一。一一向乐生。谓一分诸天。二一向苦生。谓诸那落迦。三苦乐杂生。谓一分诸天人鬼傍生。四不苦不乐生。谓一分诸天。五一向不清净生。谓欲界异生。六一向清净生。谓已证得自在菩萨。七清净不清净生。谓色无色界异生。八不清净清净处生。谓在欲界般涅槃法有暇处生。九清净不清净处生。谓生色无色界异生。十不清净不清净处生。谓生欲界异生不般涅槃法。设般涅槃法无暇处生。十一清净清净处生。谓生色无色界非异生诸有学者

复次经言。汝等长夜增羯吒斯恒受血滴。何等名为羯吒斯耶。所谓贪爱。贪爱之言与羯吒斯名差别也。此言显示摄受集谛。恒受血滴。摄受苦谛。

复次婆罗门喻经中。世尊依死杂染说如是言。有五非狂如狂所作。何等为五。一解支节者。谓更有余活命方便。而乐分析所有支节以自活命。是名第一非狂如狂所作。二悭贪者。谓悭贪所蔽。悭贪因缘所获财宝不食不施。唯除命终欻然虚弃大宝库藏。是名第二非狂如狂所作。三乐生天者。谓更有余身语意摄种种妙行生天方便。而乐妄执投火溺水颠坠高崖。自害身命作生天因。是名第三非狂如狂所作。四乐解脱者。谓更有余八支圣道解脱方便。而乐妄执自逼自恼种种苦行作解脱因。是名第四非狂如狂所作。五伤悼死者。谓依伤悼亡者因缘。种种哀叹[犛-牛+万]攫其身。坌灰拔发断食自毁。欲令亡者还复如故。是名第五非狂如狂所作

复说颂曰

  世间无决定　　颠倒谓为我
  父母及妻孥　　兄弟亲友等
  曾母转为妻　　妻复为儿妇
  儿妇转为婢　　或作怨家妻
  曾父转为子　　子复为怨敌
  怨敌复为奴　　或为仆隶等
  曾王转为臣　　臣复为贫匮
  或闾邑下贱　　为世所轻鄙
  曾作婆罗门　　展转为三姓
  或复旃荼罗　　及补羯娑等
  于无量百千　　那庾多往返
  为父复为子　　及怨家等身
  如幻士众中　　示种种形类
  异生处流转　　现多身亦尔
  烦恼业缘因　　令种种诸行
  数数而积集　　如幻化所起
  虽遭是众幻　　然无智所覆
  常于诸行中　　乐着曾无厌
  既自幻惑已　　坌灰泣伤叹
  于不应忧悲　　横生诸悲恼
  离假名亲属　　种种自忧悲
  弃捐正法行　　举手而号泣
  痴憍慢所乱　　数行诸放逸
  如是等种类　　广说遍应知

复次斗诤劫中有四过失。谓寿量衰退。安乐衰退。功德衰退。一切世间盛事衰退

复次斗诤劫中诸有情类。略于八处互不相数。一不数正法。二不数名闻。三不数宗族。四不数可愍。五不数善友。六不数有德。七不数有恩。八不数亲友。

问先说生杂染中。无明缘行乃至生缘老死。此无明等十二支差别义云何应知。答略由五相。一由相故。二由自性故。三由业故。四由法故。五由因果故。问何等为无明相。答贪嗔慢相是无明相。计我我所相。无惭无愧相。多放逸相。性羸钝相。饶睡眠相。心愁戚相。种种恶业现行等相。是无明相。问何等是无明自性。答自性总相如前已说。

自性差别今当显示。谓或有随眠无明。或有觉悟无明。或有烦恼共行无明。或有不共独行无明。或有蔽伏心性无明。或有发业无明。或有不染污无明。或有离羞耻无明。或有坚固无明。谓无般涅槃法者所有无明。问何等为无明业。答于不现见义而生迷惑。是无明业。如是于现见义劣义中义胜义。利益义。不利益义。真义。邪义。因义。果义。而生迷惑。是无明业。又有十种愚痴有情。遍摄愚痴诸有情类。一缺减愚痴。二狂乱愚痴。三散乱愚痴。四自性愚痴。五执着愚痴。六迷乱愚痴。七坚固愚痴。八增上愚痴。九无所了别愚痴。十现见愚痴。缺减愚痴者。谓如有一或缺于眼或缺于耳。于眼所识色。耳所识声。一切境界。皆不领解。是故愚痴。狂乱愚痴者。谓如有一或遭逼迫或遭大苦。或遭重病或痛所切。或复颠痫令心狂乱。由此不了善作恶作。是故愚痴。散乱愚痴者。谓如有一心散异境。不能了余善作恶作。是故愚痴。自性愚痴者。谓如有一于生死中无始以来。自性不了苦集灭道。众生无我。法无我等。是故愚痴。执着愚痴者。谓如有一堕外道中。彼于身见身见为本。诸见趣中不能解了。是故愚痴。迷乱愚痴者。谓如有一或名想乱或形量乱。或色相乱或业用乱。于乱处法不能解了。是故愚痴。坚固愚痴者。谓如有一毕竟无有般涅槃法。所有愚痴自性坚固。乃至诸佛亦不能拔。增上愚痴者。谓如有一常恒无间习诸邪行。又邪行因所生众苦之所逼切。虽知虽见而故奔趣乐着嬉戏。或复贪等行者亦是增上愚痴。无所解了愚痴者。谓如有一不闻不思不修习故。于法于义不能解了。是故愚痴。现见愚痴者。谓如有一现见诸行皆悉无常而起常想。现见皆苦而起乐想。现见不净而起净想。现见无我而起我想。现见病法老法死法起安隐想无逼恼想。又此无明于五处所能为障碍。一能障碍真实智喜。二能障碍烦恼灭得。三能障碍圣道成满。四能障碍往于善趣。五能障碍世间现法诸吉祥事。问何等名无明法。答或有由无明故堕无明趣。说名愚痴非痴所娆不为痴垢非痴所媚。谓住随眠无明。或有所痴为痴所娆不为痴垢非痴所媚谓由缠所摄无明。或有愚痴为痴所娆为痴所垢非痴所媚。谓由发业无明。发恶业已于此恶行而生羞耻。或有愚痴为痴所娆为痴所垢为痴所媚。谓因无明发起种种恶不善业。于此恶行无有羞耻。此中由前三种说名愚痴堕无明趣。不名痴人。由后一种说名痴人。或有闇法无明。谓在欲界。或有昧法无明。谓在色界。或有翳法无明。谓在无色界。问何等名无明因果。答因如本地分已说。果谓一切后有支。又于真如及诸谛义不能解了。或复犹豫。或即于此生邪决定。谓于谛理或增或减颠倒执着无常等故。或由增上慢故。或由自轻蔑故。余有支决择文更不复现

复次如世尊言。眼为因色为缘眼识得生。乃至身为因触为缘身识得生。又说。触为受缘。又说。能生作意为因生所生识。此中非眼等是眼识等生因。亦非触是受生因。非能生作意是所生识生因。由彼诸法各自种子为生因故。何故此中说眼等为眼识等因。当知此依俱有依摄引发因说。非生起因。所以者何。由俱有眼等根为依止故。眼等诸识彼彼境转非无依止。如是由俱有触为依止故。有诸受转。由俱有能生作意为依止故。所生识转非无依止。是故世尊于此诸处。依俱有依所摄引发因说。非生起因。或依助伴因说。何以故。非已灭眼能为已生眼识所依。耳等亦尔。非已灭触能为已生受所依止。亦非已灭能生作意能为已生所生识依

复次缘起次第略有四种。一牵引次第。二生起次第。三受用境界次第。四受用苦次第。无明缘行行缘识。是牵引次第。识缘名色名色缘六处。是生起次第。六处缘触触缘受。是生起已受用境界次第。受缘爱爱缘取取缘有有缘生生缘老死。是受用苦次第。于此处所余决择文更不复现

瑜伽师地论卷第六十瑜伽师地论卷第六十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中有寻有伺等三地之四

复次如佛世尊为出爱王所说经言。彼王一时往诣佛所。顶礼佛足白言世尊。有一沙门若婆罗门。来至我所。以不真实过失。现前呵谏于我。我于尔时其心不生悔恼忧戚。何以故。观此过失。于我自身都不见故。又有沙门若婆罗门。来至我所。以不真实功德。现前赞劝于我。我于尔时心亦不生欢喜踊跃。何以故。观此功德。于我自身都不见故。彼诸沙门及婆罗门既退还已。我便独处空闲静室。生如是心筹量寻伺。我当云何了知诸王真实过失真实功德。若我知者当舍其失当修其德。谁有沙门或婆罗门能了诸王真实过失真实功德。亦能为我广开示者。既寻伺已便作是念。唯我世尊一切知者一切见者。定当了知诸王所有真实过失真实功德。我今当往佛世尊所请问斯义。故我今者来至佛所请决是义。唯愿如来为我开示。世尊云何诸王真实过失。云何诸王真实功德。作是请已。尔时世尊。告出爱王曰。大王大王。今者应当了知王之过失王之功德。王衰损门王方便门。王可爱法及能引发王可爱法

云何名为王之过失。大王当知。王过失者。略有十种。王若成就如是过失。虽有大府库有大辅佐有大军众。然不可归仰。何等为十。一种姓不高。二不得自在。三立性暴恶。四猛利愤发。五恩惠奢薄。六受邪佞言。七所作不思不顺仪则。八不顾善法。九不知差别忘所作恩。十一向纵任专行放逸

云何名王种姓不高。谓有国王随一下类王家而生非宿尊贵。或虽于此王家而生。贱女之子不相似子。或是大臣辅相国师群官等子。如是名王种姓不高。云何名王不得自在。谓有国王为诸大臣辅相国师群官所制。不随所欲作所应作锡赉群臣。于妙五欲亦不如意欢娱游戏。如是名王不得自在

云何名王立性暴恶。谓有国王诸群臣类或余人等。随于一处现行少小不如意事。即便对面摈黜发粗恶言。咆勃忿恚颦蹙而住。时生愤发设不对面。背彼向余而作于前摈辱等事。设不对面亦不背彼向余而作于前黜骂等事。然唯内意愤恚郁怏。怀恼害心怀怨恨心。然不长时持愤恚心相续不舍。复有内意愤恚郁怏。怀恼害心怀怨恨心。亦于长时持愤恚心相续不舍。由如是相对面暴恶。背面暴恶。懊恚暴恶。暂时暴恶。长久暴恶。如是名王立性暴恶。大王当知。长久暴恶名获大罪。非是余者

云何名王猛利愤发。谓有国王。诸群臣等有小愆过有少违越。便削封禄夺去妻妾。或以重罚而刑罚之。如是名王猛利愤发

云何名王恩惠奢薄。谓有国王。诸群臣等供奉侍卫。虽极清净善称其心。而以微劣软言慰喻。颁赐爵禄酬赏勋庸。不能圆满不顺常式。或损耗已或稽留已。或推注已或怨恨已。然后方与。如是名王恩惠奢薄云何名王受邪佞言。若有国王。诸群臣等实非聪睿有聪睿慢。贪浊偏党不闲宪式。情怀谋叛不修善政。听受信用如是辈人所进谏议。由此因缘王务财宝名称善政并皆衰损。如是名王受邪佞言

云何名王所作不思不顺仪则。谓有国王。不能究察不审究察。不能思择不审思择。诸群臣辈于彼彼务机密事中。不堪委任而委任之。堪委任者而不委任。堪驱役者而不驱役。不堪役者乃驱役之。应赏赉者而刑罚之。应刑罚者而赏赉之。又于群臣不善安处先王仪则。由此群臣处大朝会。余论未终发言间绝。不敬不惮而兴谏诤。不如旨教而善奉行。不正安住王之教命。如是名王所作不思不顺仪则

云何名王不顾善法。谓有国王。不信他世亦不晓悟。由于他世不信不悟。便于当来善不善业爱非爱果。不能信解。不信解故无有羞耻。随情造作身语意业三种恶行。不能时时布施修福受斋学戒。如是名王不顾善法。云何名王不知差别忘所作恩。谓有国王。于诸大臣辅相国师及群官等。其心颠倒不善了知忠信伎艺智慧差别。以不知故非忠信所生忠信想。于忠于所非忠信想。无伎艺所生伎艺想。有伎艺所无伎艺想。于恶慧所生善慧想。于善慧所生恶慧想。彼由如是心颠倒故。于非忠信无有伎艺恶慧臣所。敬重爱养。忠信伎艺善慧臣所。反生轻贱。又诸臣等年耆衰迈。曾于长夜供奉侍卫。知其无势无力无勇。遂不敬爱。不赐爵禄不酬其赏。设被陵蔑舍而不问。如是名王不知差别忘所作恩。云何名王一向纵任专行放逸。谓有国王。于妙五欲一向沉没。耽着嬉戏爱乐受行。不能时时勖励方便作所应作劳赉群臣。如是名王一向纵任专行放逸。若有国王。成就如是十种过失。虽有大府库有大辅佐有大军众。而不可归仰。大王当知。此十过失。初一是王种姓过失。余九是王自性过失

云何名为王之功德。大王当知。王功德者。略有十种。王若成就如是功德。虽无大府库无大辅佐无大军众。而可归仰。何等为十。一种姓尊高。二得大自在。三性不暴恶。四愤发轻微。五恩惠猛利。六受正直言。七所作谛思善顺仪则。八顾恋善法。九善知差别知所作恩。十不自纵任不行放逸

云何名王种姓尊高。谓有国王。处在相似王家而生。宿世尊贵。是相似子。如是名王种姓尊高

云何名王得大自在。谓有国王。自随所欲作所应作劳赉群臣。于妙五欲欢娱游戏。于诸大臣辅相国师群官等所。凡出教命宣布无碍。如是名王得大自在。云何名王性不暴恶。谓有国王。诸群臣等随于何处。虽行增上不如意事。性能容忍不现摈黜。不发粗言亦不咆勃。广说乃至不生愤发。亦不背面而作前事。亦不内意秘匿忿缠。亦不长夜蓄怨愤心相续不舍。不现暴恶不背暴恶。不匿暴恶不久暴恶。如是名王性不暴恶

云何名王愤发轻微。谓有国王。诸群臣等虽有大愆有大违越。而不一切削其封禄夺其妻妾。不以重罚而刑罚之。随过轻重而行黜罚。如是名王愤发轻微云何名王恩惠猛利。谓有国王。诸群臣等正直现前供奉侍卫。其心清净其心调顺。于时时中以正圆满软言慰谕。具足颁锡爵禄勋庸。而不令彼损耗稽留劬劳怨恨。易可供奉不难承事。如是名王恩惠猛利

云何名王受正直言。谓有国王。诸群臣等实有聪睿无聪睿慢。无浊无偏善闲宪式。情无违叛乐修善法。听受信用如是辈人所进言议。由此因缘国务财宝名称善法皆悉增盛。如是名王受正直言

云何名王所作谛思善顺仪则。谓有国王。性能究察能审究察。性能思择能审思择。诸群臣等于彼彼务机密事中。不堪委任而不委任。堪委任者而委任之。不堪役者而不驱役。堪驱役者乃驱役之。应赏赉者而正赏赉。应刑罚者而正刑罚。凡有所为审思审择。然后方作而不卒暴。又于群臣能善安处先王仪则。由此群臣虽处宴会。终不发言间绝余论。要待言终恭敬畏惮而兴谏诤。如其旨教而善奉行。能正安住王之教命。如是名王所作谛思善顺仪则

云何名王顾恋善法。谓有国王。信知他世。由信知故便于当来净不净业爱非爱果能善信解。由信解故具足惭耻。而不纵情作身语意三种恶行。时时思择布施修福受斋学戒。如是名王顾恋善法

云何名王善知差别知所作恩。谓有国王。于诸大臣辅相国师及群官等。心无颠倒能善了知忠信伎艺智慧差别。若诸群臣忠信伎艺及与智慧。若有若无并如实知。于其无者轻而远之。于其有者敬而爱之。而正摄受。又诸臣等年耆衰迈。曾于长夜供奉侍卫。虽知无势无力无勇。然念昔恩转怀敬爱而不轻贱。爵禄勋庸分赏无替。如是名王善知差别知所作恩。云何名王不自纵任不行放逸。谓有国王。于妙五欲而不沉没耽着嬉戏爱乐受行。能于时时勖励方便作所应作劳赉群臣。如是名王不自纵任不行放逸。若王成就如是功德。虽无大府库无大辅佐无大军众。而可归仰。大王当知。如是十种王之功德。初一名为种姓功德。余九名为自性功德。云何名为王衰损门。大王当知。王衰损门略有五种。一不善观察而摄群臣。二虽善观察而摄群臣无恩妙行纵有非时。三专行放逸不思机务。四专行放逸不守府库。五专行放逸不修法行。如是五种皆悉名为王衰损门。云何名王不善观察而摄群臣。谓有国王。于群臣等不能究察不审究察。不能思择。不审思择忠信伎艺智慧差别。摄为亲侍加以宠爱。厚赐爵禄重赏勋庸。最机密处而相委任。数以软言现为慰谕。然此群臣所付财宝多有损费。若遇怨敌恶友军阵彼先退败。恐惧破散为他所胜。迟留人后奔北无恋。矫行恶策动[虛*予]王政。如是名王不善观察而摄群臣

云何名王虽善观察而摄群臣无恩妙行纵有非时。谓有国王。虽于群臣性能究察能审究察。性能思择能审思择忠信伎艺智慧差别摄为亲侍。而不宠爱。不如其量具赐爵禄。最机密处亦不委任。不数软言现相慰谕。后于一时王遇怨敌恶友军阵。广说乃至大怖畏事命难现前。尔时于臣方行宠爱。广说乃至数以软言而相慰谕。时群臣等共相谓曰。王于今者危迫因缘。方于我等暂行妙行非长久心。知此事已。虽有忠信伎艺智慧隐而不现。如是名王虽善观察而摄群臣无恩妙行纵有非时

云何名王专行放逸不思机务。谓有国王。于应和好所作所成机务等事。而不时时独处空闲。或与智者共正思惟称量。观察和好方便。如是于应乖绝所作所成机务等事。于应惠施所作所成机务等事。于应军阵所作所成机务等事。于应摄受大力朋党所作所成机务等事。皆不时时独处空闲。或与智者共正思惟称量。观察乖绝方便乃至摄受强党方便。如是名王专行放逸不思机务

云何名王专行放逸不守府库。谓有国王。寡营事业拙营事业。不持事业不观事业。不禁王门不禁宫门不禁府库。或于俳优伎乐笑弄倡逸等所。或复耽乐博弈戏等。非量损费所有财宝。如是名王专行放逸不守府库。云何名王专行放逸不修法行。谓有国王。于世所知柔和淳质。聪慧辩才。得理解脱巧便。无害乐无害法。所有沙门若婆罗门。不能数往礼敬咨询云何为善云何不善。云何有罪云何无罪。作何等业能致吉祥远离诸恶。设得闻已亦不勖励如说修行。不能时时惠施树福受斋学戒。如是名王专行放逸不修法行。若有国王。成就如是五衰损门。当知此王退失现法后法义利。谓前四门退现法利。最后一门退后法利

云何名为王方便门。大王当知。王方便门略有五种。何等为五。一善观察摄受群臣。二能以时行恩妙行。三无放逸专思机务。四无放逸善守府库。五无放逸专修法行

云何名王能善观察摄受群臣。谓有国王。于群臣等性能究察能审究察。性能思择能审思择。忠信伎艺智慧差别。摄为亲侍。如是名王能善观察摄受群臣

云何名王能善以时行恩妙行。谓有国王。于诸群臣善观察已。摄为亲侍。加以宠爱。随其度量厚赐爵禄重赏勋庸。最机密处而相委任。数以软言现相慰谕。彼于一时。王遇怨敌恶友军阵大怖畏事命难现前。即便罄竭显示忠信伎艺智慧。如是名王能善以时行恩妙行

云何名王无有放逸专思机务。谓有国王。于应和好所作所成机务等事。能于时时独处空闲。或与智者共正思惟称量。观察和好方便。如是于应乖绝所作所成机务等事。于应惠施所作所成机务等事。于应军阵所作所成机务等事。于应摄受大力朋党所作所成机务等事。皆能时时独处空闲。或与智者共正思惟称量。观察乖绝方便乃至摄受强党方便。如是名王无有放逸专思机务

云何名王无有放逸善守府库。谓有国王。广营事业巧营事业。善持事业善观事业。善禁王门善禁宫门善禁府库。又于俳优妓乐笑弄倡逸等所。不以非量而费财宝。亦不耽乐博弈戏等。如是名王无有放逸善守府库。云何名王无有放逸专修法行。谓有国王。于世所知柔和淳质。聪慧辩才。得理解脱巧便。无害乐无害法。所有沙门若婆罗门。而能数往礼敬。咨询云何为善云何不善。何等有罪何等无罪。作何等业能致吉祥远离诸恶。既得闻已善能勖励如说修行。亦能时时惠施树福受斋学戒。如是名王无有放逸专修法行。若有国王成就如是五方便门。当知此王不退现法后法义利。谓前四门不退现法所有义利。最后一门不退后法所有义利。云何名为王可爱法。大王当知。略有五种。诸王可爱可乐可欣可意之法。何等为五。一世所敬爱。二自在增上。三能摧怨敌。四善摄养身。五能往善趣。如是五种。是王可爱可乐可欣可意之法

云何能引王可爱法。大王当知。略有五种能引诸王可爱之法。何等为五。一恩养世间。二英勇具足。三善权方便。四正受境界。五勤修法行

云何名王恩养世间。谓有国王。性本知足于财宝门。为性谨慎不邪贪着。如其所应积集财宝不广营求。又有国王。性无贪吝。成就无贪白净之法。以自所有库藏珍财。随力随能给施一切贫穷孤露。又有国王。柔和忍辱多以软言晓谕国界。于时时间随其所应分赏爵禄。终不以彼非所能业恶业重业役任群臣。诸有违犯可矜恕罪。即便矜恕。诸有违犯不可恕罪。以实以时如理治罚。如是名王以正化法恩养世间。由王受行如是恩养世间法故。遂感世间之所敬爱

云何名王英勇具足。谓有国王。计策无惰武略圆满。未降伏者而降伏之。已降伏者而摄护之。广营事业如前乃至不甚耽乐博弈戏等。又善观察应与不应(与勤)于僚庶应刑罚者正刑罚之。应摄养者正摄养之。如是名王英勇具足。由王受行如是英勇具足法故。遂能感得自在增上

云何名王善权方便。谓有国王。于应和好所作所成机务等事。如前乃至于应摄受大力朋党所作所成机务等事。能正了知和好方便乃至摄受强党方便。如是名王善权方便。由王受行如是善权方便法故。遂能摧伏所有怨敌

云何名王正受境界。谓有国王。善能筹量府库增减。不奢不吝平等自处。清正受用众杂受用胜妙受用。随其时候所宜受用。与诸臣佐亲属受用。在于胜处而为受用。奏诸伎乐而为受用。无有愆失而为受用。无愆失者谓疾恼时。应食所宜避所不宜。于康豫时消已方食。若食未消或食而利。皆不应食。应共食者正现在前。不应独食精妙上味。诡摈余人。如是名王正受境界。由王受行如是正受境界法故。遂能善巧摄养自身

云何名王勤修法行。谓有国王。具足净信戒闻舍慧。云何名王具足净信。谓有国王。信解他世。信解当来净不净业及爱非爱果与异熟。如是名王具足净信

云何名王具足净戒。谓有国王。远离杀生及不与取淫欲邪行妄语饮酒诸放逸处。如是名王具足净戒

云何名王具足净闻。谓有国王。于现法义于后法义。及于现法后法等义。众妙法门善听善受习诵通利。专意研究善见善达。如是名王具足净闻

云何名王具足净舍。谓有国王。虽在悭垢所缠众中。心恒清净远离悭垢。而处居家常行弃舍舒手乐施。好兴祠福惠舍圆满。于布施时常乐平等。如是名王具足净舍云何名王具足净慧。谓有国王。如实了知善不善法有罪无罪修与不与胜劣黑白。于广分别诸缘生法亦如实知。纵令失念生恶贪欲嗔恚忿恨。覆恼悭嫉幻诳谄曲。无惭无愧恶欲恶见。而心觉悟并不坚住。如是名王具足净慧。如是名王勤修法行。由王受行此法行故。能往善趣。如是五种能引发王可爱之法。能引诸王现法后法所有利益。谓初四种能引发王现法利益。最后一种能引发王后法利益

复次大王当知。我已略说王之过失。王之功德。王衰损门。王方便门。王可爱法。及能引发王可爱法。是故大王应当修学。王之过失宜当远离。王之功德宜当修习。王衰损门宜当远离。王方便门宜当修学。王可爱法宜当希慕。能引发王可爱之法宜当受行。大王若能如是修学。当获一切利益安乐

复次如说生苦。乃至略说五取蕴苦。云何生苦。当知此苦由五种相。谓众苦所随故。粗重所随故。众苦所依故。烦恼所依故。不随所欲离别法故。云何众苦所随故苦。谓生那落迦及一向苦饿鬼趣中。若于胎生卵生生时。种种忧苦之所随逐故。名众苦所随故苦。云何粗重所随故苦。谓三界诸行为烦恼品粗重所随。性不调柔不自在转。由此随逐三界有情诸行生起。故名粗重所随故苦

云何众苦所依故苦。谓衰老等众苦差别之所依故

云何烦恼所依故苦。谓受生已。于爱境爱于嗔境嗔。于痴境痴。由是因缘住不寂静惛荡身心不安隐苦。故名烦恼所依故苦

云何不随所欲离别法故苦。谓诸有情生者皆死生必殒没。所有寿命死为边际死为终极。如是等事非其所爱。由此因缘唯受众苦。是以不随所欲离别法故说生为苦云何老苦。当知亦由五相。谓于五处衰退故苦。一盛色衰退故。二气力衰退故。三诸根衰退故。四受用境界衰退故。五寿量衰退故云何病苦。当知病苦亦由五相。一身性变坏故。二忧苦增长多住故。三于可意境不喜受用故。四于不可意境非其所欲强受用故。五能令命根速离坏故

云何死苦。当知此苦亦由五相。一离别所爱盛财宝故。二离别所爱盛朋友故。三离别所爱盛眷属故。四离别所爱盛自身故。五于命终时备受种种极重忧苦故

云何怨憎会苦。当知此苦亦由五相。一与彼会生忧苦故。二治罚畏所依止故。三恶名畏所依止故。四苦逼迫命终怖畏所依止故。五越正法恶趣怖畏所依止故云何爱别离苦。当知此苦亦由五相。谓不与彼会生愁恼故。由此因缘生愁叹故。由此因缘身扰恼故。念彼众德思恋因缘意热恼故。应受用等有所阙故。如爱别离苦。求不得苦当知亦尔

云何五取蕴苦。当知此苦亦由五相。谓生苦器故。依生苦器故。苦苦器故。坏苦器故。行苦性故

复次依行差别建立三士。谓下中上。无自利行无利他行。名为下士。有自利行无利他行。有利他行无自利行。名为中士。有自利行有利他行。名为上士。复有四种补特伽罗。或有行恶而非乐恶。或有乐恶而非行恶。或有行恶亦复乐恶。或非行恶亦非乐恶。若信诸恶能感当来非爱果报。由失念故。或放逸故。近恶友故。造作恶行。是名行恶而非乐恶。若先世来串习恶故。喜乐诸恶恶欲所牵。彼由亲近善丈夫故。闻正法故。如理作意为依止故。见诸恶行能感当来非爱果报。自勉自励远离诸恶。是名乐恶而非行恶。若性乐恶而不远离。是名行恶亦复乐恶。若有为性不乐诸恶亦能远离。名非行恶亦非乐恶。此中行恶亦乐恶者。是名下士。若有行恶而非乐恶。或有乐恶而非行恶。是名中士。若非行恶亦非乐恶。是名上士

复有三士。一重受欲。二重事务。三重正法。初名下士。次名中士。后名上士。又有三种补特伽罗。一以非事为自事。二以自事为自事。三以他事为自事。若行恶行以自存活。名以非事为自事。若怖恶行修行善行。名以自事为自事。若诸菩萨名以他事为自事。等。初名下士。次名中士。后名上士。又诸国王有三圆满。谓果报圆满。士用圆满。功德圆满。若诸国王生富贵家。长寿少病有大宗叶。成就俱生聪利之慧。是王名为果报圆满。若诸国王善权方便所摄持故。恒常成就圆满英勇。是王名为士用圆满。若诸国王任持正法名为法王。安住正法名为大王。与内宫王子群臣英杰豪贵国人共修惠施。树福受斋坚持禁戒。是王名为功德圆满。果报圆满者。受用先世净业果报。士用圆满者。受用现法可爱之果。功德圆满者。亦于当来受用圆满净业果报。若有国王。三种圆满皆不具足。名为下士。若有果报圆满或士用圆满。或俱圆满。名为中士。若三圆满无不具足。名为上士

复有三臣。一有忠信无伎能智慧。二有忠信伎能无智慧。三具忠信伎能智慧。初名下士。次名中士。后名上士。若不忠信无有伎能亦无智慧当知此臣下中之下。又有四语。一非爱似爱。二爱似非爱。三非爱似非爱。四爱似爱。诸有语言辞句善顺然非所宜。是名初语。或有语言辞句勃逆然是所宜。是第二语。或有语言辞句勃逆亦非所宜。是第三语。或有语言辞句善顺亦是所宜。是第四语。若有宣说非爱似非爱非爱似爱语者。是下士。若有宣说爱似非爱语者。是中士。若有宣说爱似爱语者。是上士

复有三种受诸欲者。或有受欲非法孟浪积集财宝。不能安乐正养己身及与妻子。广说乃至不于沙门婆罗门所修殖福田。或有受欲法或非法孟浪或非积集财宝。能以安乐正养己身妻子眷属及知友等。不于沙门婆罗门所修殖福田。或有受欲一向以法。及不孟浪积集财宝。能以安乐正养己身。广说乃至能于沙门婆罗门所修殖福田。此三种中初名下士。次名中士。后名上士

复有三人。一者有人贪染而食。爱着饕餐乃至耽湎。不见过患不知出离。二者有人思择而食。不染不着。亦不饕餐吞吸迷闷坚住耽湎。深见过患善知出离。而于此食未断未知。三者有人思择而食。不生贪染。广说乃至深见过患善知出离。又于此食已断已知。初名下士。次名中士。后名上士

复依施物说有三人。一者有人所施之物。但具妙香不具美妙味之与触。二者有人所施之物。具妙香味而无妙触。三者有人所施之物。具足美妙香味与触。初名下士。次名中士。后名上士。又依施田说有三人。一者有人于爱于恩而行惠施。二者有人于贫苦田而行惠施。三者有人于具功德最胜福田而行惠施。初名下士。次名中士。后名上士。复有差别。施于所爱名为下士。施于有恩名为中士。施于贫苦具德胜田名为上士。又依施心说有三人。一者有人将欲惠施先心欢喜。正惠施时心不清净。惠施已后寻复追悔。二者有人先心欢喜。施时心净施已追悔。三者有人先心欢喜。施时心净施已无悔。初名下士。次名中士。后名上士

复于受持戒福业事。建立三人。一者有人但离一分。非一切时常能远离。唯自远离不劝他离亦不赞美。见同法者心不欢喜。是名下士。二者有人离一切分一切时离。唯自远离不劝他人亦不赞美。见同法者心不欢喜。是名中士。三者有人一切俱现。是名上士。又于受持禁戒处所。建立三人。一者有人住恶说法毗奈耶中。受持禁戒。二者有人住善说法毗奈耶中。受持禁戒而有缺漏。三者有人即住于此受持禁戒而不缺漏。初名下士。次名中士。后名上士。又于受持戒心。建立三人。一者有人为活命故受持禁戒。二者有人为生天故受持禁戒。三者有人为涅槃故受持禁戒。初名下士。次名中士。后名上士。又于受持别解脱律仪。说有三人。一者有人唯能受持近住律仪。二者有人亦能受持近事律仪。三者有人亦能受持苾刍律仪。初名下士。次名中士。后名上士。又于受持苾刍律仪。说有三人。一者有人唯能成就受具足支。无受随法诸学处支。亦无随护他人心支。亦无随护如先所受诸学处支。二者有人成前三支。无后一支。三者有人具成四支。初名下士。次名中士。后名上士。又有三人。一者有人唯成别解脱律仪。二者有人成别解脱静虑律仪。三者有人成别解脱静虑无漏三种律仪。初名下士。次名中士。后名上士。又有三人。一者有人唯能成就非律仪非不律仪摄所受戒律仪。二者有人亦能成就声闻等相应所受戒律仪。三者有人亦能成就菩提萨埵所受戒律仪。初名下士。次名中士。后名上士

复依修习思惟方便。建立三人。一者有人唯得励力运转思惟。二者有人有间运转。设得无间要作功用方能运转。三者有人已得成就任运思惟。初名下士。次名中士。后名上士。又依己得修差别故。建立三人。一者有人已得内心奢摩他定。未得增上慧法毗钵舍那。二者有人已得增上慧法毗钵舍那。未得内心奢摩他定。三者有人俱得二种。初名下士。次名中士。后名上士。又有三人。一者有人已得有寻有伺三摩地。二者有人已得无寻唯伺三摩地。三者有人已得无寻无伺三摩地。初名下士。次名中士。后名上士。又依住修差别。建立三人。一者有人住染污静虑。二者有人住世间清净静虑。三者有人住无漏静虑。初名下士。次名中士。后名上士

复次有十种有情众。于十种法爱乐喜悦。何等十法。一寿。二色。三财。四友。五戒。六闻。七梵行。八慧。九法。十生天。何等名为有情十众一傍生。二母邑。三受用欲者。四求所作者。五出家者。六多闻为命者。七入证者。八寻思者。九勤苦者。十弃身者

复次听闻正法者。略有六种烦恼过失。谓憍慢过失。不欲过失。不信过失。身心损恼过失。散乱过失。迷惑过失。由如是等诸过失故。不能恭敬殷重听法。广说如经。散乱烦恼过失复有二种。谓说时散乱。说已散乱。迷惑者。谓颠倒

复次烦恼发业略有三种。一相应发。二亲生发。三增上发。引余烦恼而发起故

复次非所爱法略有六种。一怨敌。二疾病。三不可爱境。四生等诸苦。五苦辛良药。六非串习善。前四应远离。后二应修习复次受用诸欲略有五种。一领纳受用。二摄喜受用。三寻思受用。四贪彼受用。五摄自受用

复次诸欲过失略有八相。一少味多苦多过患相。二他所逼切苦因缘相。三杂染受用胜因缘相。四堕诸恶趣苦因缘相。五寻思扰乱苦因缘相。六受用磨灭胜因缘相。七丧身磨灭胜因缘相。八能障善法胜因缘相

复次诸欲因缘略有六种变坏。一他所逼切变坏。二诸界互违变坏。三所爱有情变坏。四身变坏。五心变坏。六无常变坏。复次当知诸欲由五种相似法故得稠林名。一由众多相似法故。二由杂秽相似法故。三由养育众生相似法故。四由藏窜相似法故。五由险难相似法故。

我已略说有寻有伺等三地决择。其中处处余决择文。更不复现

瑜伽师地论卷第六十一瑜伽师地论卷第六十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中三摩呬多地之一

如是已说有寻有伺等三地决择。三摩呬多地决择我今当说。

谓补特伽罗多随烦恼染污相续。不能正证心一境性。云何名为多随烦恼。谓有诏诳。矫诈。无惭无愧。不信懈怠。忘念不定。恶慧慢缓。猥杂趣向前行。舍远离轭。于所学处不甚恭敬。不顾沙门。唯悕活命。不为涅槃而求出家

云何有谄。谓自有过而不能于大师智者同梵行所如实发露

云何有诳。谓不真实显己功德。彼实无德而欲令他诸有智者同梵行等了知有德云何有矫谓于增上戒毁犯尸罗。或于轨范毁犯轨范。由见闻疑他所举时。遂用余事假托余事。或设外言而相诱引。如经广说。谓由谄诳增上力故。云何有诈。谓怖他故。或复于彼有所悕故。虽有犯重而不发露亦不现行。非实意乐诈于有智同梵行所。现行亲爱恭敬耎善身语二业

云何无惭无愧。谓观于自或复观他无所羞耻。故思毁犯。犯已不能如法出离。好为种种斗调违诤

云何不信。谓于佛法僧心不清净。于苦集灭道生不顺解

云何懈怠。谓执睡眠偃卧为乐。昼夜唐捐舍众善品

云何忘念。谓于久远所作所说。不能随念不令随忆。不守根门不正知住。云何不定。谓于定地下至作意亦不能得

云何恶慧。谓住自见取执不平等难舍言论

云何慢缓。谓不捷利亦不明了。不自起举无所能为。不能以身供侍有智同梵行者

云何猥杂。谓乐与在家及出家众共相杂住。又乐寻思诸恶不善欲寻思等乃至家势。相应寻思多随寻思多随伺察

云何趣向前行。谓受僧祇或复别人诸衣服等所有利养。或请僧祇及与别人。皆名趣向。若诸苾刍于如是事最初前行。故名趣向前行

云何舍远离轭。谓于远离边际卧具远离众恶人所习近似寂静室。远弃舍之不生欲乐

云何于诸学处不甚恭敬。谓遭厄难宁舍学处不弃身命。志求身乐及与寿命。不能随护所有学处

云何不顾沙门谓弃舍学处好为退转。或犯尸罗行诸恶法于内腐烂。广说乃至实非梵行自称梵行。况当悕求沙门果。证八支圣道

云何唯悕活命不为涅槃而求出家。谓或为王之所逼迫而求出家。或为怨贼之所逼迫。或为债主之所逼切。或为恐怖之所逼切。或为财宝常所匮乏恐畏不活而求出家。不为自调自静自般涅槃而求出家

常知此中依同梵行而共止住有所违犯。发起最初四随烦恼。依增上戒有所违犯。当知发起无惭无愧。依增上心及增上慧。当知发起始从不信乃至恶慧诸随烦恼。此中不信及与懈怠依俱违犯。忘念散乱依增上心违犯而起恶慧。依犯增上慧起不信懈怠增上力故。当知发起慢缓猥杂。趣向前行。舍远离轭。忘念乱心及与恶慧增上力故。当知发起于诸学处不甚恭敬不顾沙门。唯悕活命不为涅槃而求出家

复有三种补特伽罗。依三处引诸随烦恼。云何三种补特伽罗。一依正法而出家者。二在居家受用欲者。三正法外而出家者。

云何三处引随烦恼。所谓最初补特伽罗。依放逸处引随烦恼。此复二种。谓或依内妄显己德。为衣服等利养恭敬。自说己得胜过人法。或复依他诸有智者同梵行等。以身语业逼迫加害损恼毁辱。

当知第二补特伽罗。依耽欲处引随烦恼。彼由耽着诸欲因缘受用诸欲。依身语意行三恶行。

当知第三补特伽罗。依邪行处引随烦恼。略有三种。谓随逐远离。随逐愦闹。随逐学处起随烦恼。云何随逐远离起随烦恼。谓诸外道随逐远离所有卧具。而为五盖覆蔽其心。或住于苦领受身心诸苦恼故。或复远离烦恼对治。由离信等五种根故。彼由如是住染污故。住苦恼故。无有对治能除染污苦恼住故。是名随逐远离诸随烦恼。云何随逐愦闹起随烦恼谓各别执异见异欲相违言论。建立自品他品差别。广起忿恨乃至诳谄。是名随逐愦闹诸随烦恼。云何随逐学处起随烦恼。谓观自他现行诸罪。无有羞耻毁戒穿戒。是名随逐增上戒学诸随烦恼。若有依止世间等至。于其下劣计自为胜。或于相似计自为胜。心生高举。是名随逐增上心学诸随烦恼。若少听闻不能观察所有善法。是名随逐增上慧学诸随烦恼。如是一切总略说名非法之行不平等行。由非善义名非法行。非爱果义名不平等行

复次若观行者。修十遍处能为五事。何等为五。谓由修习地遍处等乃至白遍处故。便能引发化事变事诸圣神通。又由修习空无边处一切处故。便能引发往还无碍诸圣神通。又由修习识无边处一切处故。便能引发无诤愿智无碍解等诸胜功德。又即由此识无边处遍处成满。便能成办无所有处解脱。及非想非非想处解脱。又即由此成满因故。便能证入想受灭解脱最胜住所摄。又由识无边处故。无边无量遍满行转。是故此上不立遍处胜处。遍处是诸解脱能清净道。又诸解脱由所知障解脱所显。由此声闻及独觉等。于所知障心得解脱

复次略由三相修等至者。爱味等至。谓或证得等至出已计为清净。可欣可乐可爱可意随念爱味。或未证得或已证得。未来爱味增上力故。追求欣乐而生爱味。或已证得计为清净。可欣可乐乃至广说现行爱味。若从定出可生爱味。若正在定无有爱味。言爱味者。谓于是中遍生贪着

复次下地诸法。若生上地不现在前。上地诸法若生下地。其离欲者或现在前。若生下地于上起爱。未得离欲不定心者。当言此爱是欲界系。当知此爱或是染污或不染污。云何染污。若生是心。我今云何当证如是广大喜乐所随等至。若得证者。我当如是如是爱味。又我云何当得生上常恒不变。当知此爱是染污爱。若有起心专求离欲欣乐证入上地寂静。当知此爱是不染污

复有三种诸法断灭。谓对治断灭。现行断灭。弃舍断灭。诸烦恼事之所显现。是初断灭。诸行生灭之所显现。是第二断灭。若生上地或入无余依涅槃界。下地诸行及一切行弃舍所显。是第三断灭

复有三退。一未得法退。二已得法退。三习行法退

复依世间诸近分定。若方便道。若无间道。若解脱道。或为断灭或为证得而修习者。彼于所缘或观过失或观寂静。观下过失观上寂静。若胜进道。当知彼是遍满所缘或无漏缘

复次诸近分摄六种作意。谓了相等乃至加行究竟作意。此中了相胜解作意。方便道摄。远离加行究竟作意。无间道摄。摄乐作意。四种道摄。观察作意。胜进道摄

问何缘故说修静虑者静虑境界不可思议答修静虑者已善修治磨莹其心。有如是相威德势力。随所欲为皆能成办。非不如意法性故尔。是故说彼由寻思道不可思议

复有二种修静虑者。于一事中俱发变事胜解神通皆得自在。此二神通互相障碍。而此二通无偏大者不相映夺。彼后无间一于此事神通无碍。如其所欲皆能转变。第二神通便被障碍。此中因缘云何应知。由彼二人势力威德皆悉平等俱时发起变现神通。然其所作互不相似。由彼神通所欲为事。不相似故。于此一事二种神通互相障碍尔时有一作是思惟。何因缘故我此神通今有障碍。将无我定有退失耶。此一定者。即于此事起是余心。第二定者。即于此事数数专注心无散乱。所发神通能无障碍。随神通力如意转变。若二神通威德不等。随其胜者所作成办。若二神通威德相似。先作意者成办非余

复有四种修静虑者。一依近分定修静虑者。二依染污定修静虑者。三依世间定修静虑者。四依出世间定修静虑者。于六作意。谓了相等乃至加行究竟作意修定转时。当知是初。爱上静虑广说乃至疑上静虑。当知第二。若住余善世间静虑。当知第三。谓能引发现法乐住无量作意世间功德。又能引发游戏神通若顺决择分所摄受空无愿无相解脱门所显静虑。当知第四

复次无想等至当言唯一有漏。灭尽等至当言无漏。由与烦恼不相应故。非相应故。无所缘故。非诸烦恼之所生故。是出世间一切异生不能行故。唯除已入远地菩萨。菩萨虽能起出世法令现在前。然由方便善巧力故不舍烦恼。又此等至当言非学非无学摄。非所行故似涅槃故

复次当释随身念。经谓。心清净行苾刍有四种随烦恼。一毁犯禁戒。二散乱寻思。三保着内身。四保着外境。毁禁戒者。由忧悔门。于三摩地能为障碍。乱寻思者由三种门。一由于过去境随念散乱门。二由依掉举流散恶见恶闻恶语恶行。唯乐闻思散乱门。三由先串习势力所持散乱门。保着内身者。由于生死无厌患门。保着外境者。于未来境由欣乐门。

当知此中为欲对治初随烦恼故。修一作意。谓正知作意。为欲对治第二随烦恼故。修三作意。谓称顺彼所缘作意。了别彼相能对治彼寻思作意。彼所依心调练作意。为欲对治第三随烦恼故。应修分析积聚作意。为欲对治第四随烦恼故。应当修习不净作意。又初作意修习多修习故。能断忘念。第二作意修习多修习故。能断保着内身外境二种贪欲。第三作意修习多修习故。能断恶见等所有散乱。第四作意修习多修习故。能断先所串习势力任持所有散乱。第五作意修习多修习故。能断于身净有情想。第六作意修习多修习故。能断四贪。所谓色贪触贪形贪及承事贪。如是作意修习为依。断随烦恼心触正定。证得近分根本胜定。又能证得有喜离喜清净安乐。又依如是正定心故。如实了知上地有情无常性。及诸行无常性。云何了知有情无常住。谓得天眼清净过人见诸有情。乃至广说。云何了知诸行无常性。谓能随入未来过去现在作意缘生智故。此随身念依于三处。谓依增上心。增上慧学。修治业地。依增上心学处。依增上慧学处。为欲断除所余诸结。修念住等所有一切菩提分法之所依止。由三因缘不与一切外道沙门婆罗门共。谓于修治业地资粮圆满故。于奢摩他聚无有爱味故。于般涅槃爱乐随逐心。非烦恼火所生处故。又此修念资粮圆满为依止故。四果清净。谓处聚落世法所生烦恼不染。处阿练若空闲所生烦恼不染。处阿练若聚落所生烦恼不染。于二处所不能堪忍淋漏等苦烦恼不染。奢摩他聚无有爱味为依止故五果清净。谓四种清净静虑。及寂静解脱。于般涅槃爱乐随逐心。非烦恼火所生处为依止故。九果清净。谓初三果及六神通。此随身念当知五种清净所摄。谓不定地清净故。定地清净故。摄清净故。不共清净故。不共果清净故。又随逐身转故。彼所摄受故。名随身念

复次当释摩诃俱瑟祉罗经有二解脱。一慧解脱。二心解脱。

此中依慧解脱。谓世间慧之所行者。当知即是建立恶行及与善行并彼因缘。彼体性者。当知即是恶行善行。并彼因缘善不善等体性差别。如实正智。又依心解脱。谓心染净之所依者。当知即是色等境界。能取了别彼世间慧。心解脱果。当知即是于彼相应相杂下类杂染出故。即慧解脱增上力故。出世间慧之所行者。当知即是由世间慧及心解脱增上力故。如实了知一切境界。即出世慧心解脱果。当知即是一切种类杂染出故。此中若世间慧若出世慧。总略为一说名正见。正见因缘。当知即是有佛出世听闻正法无倒思惟。又出世间正见果相。当知即是前后常故无所对故。若法所治若有生已无灭所治。若无灭已有生。彼法名有所对。若法所治。若有若无。若生不生。常时是有。彼法名无所对。又即此果由心解脱增上力故。于自所行及彼所依得清净者。当知即是由清净心增上力故。于诸色根所行境界不生杂染。及令诸根顺清净故。又解脱心住者。当知即是寿之与暖。展转相依相属而住。又此世间及出世间二种解脱果差别者。当知即是于诸受中及因缘中。有痴爱者后有当生。无痴爱者后有不生。又彼相杂而相应故。彼能依止心法清净。当知即是非现在缘之所染污领受彼故。即二解脱住差别者。当知即是六寂静故。由清净识没平等故。非由彼所依平等故。于入定时不由加行入寂静故。于出定时不由加行出寂静故。次第出故。于在定时三行不行得寂静故。于远离出心寂静故。谓于三时。一于阿练若与同梵行共相杂住。二于聚落中与诸在家共相杂住。三于二处行相现行。于亲近出心寂静故。谓于三时。一于有色世间胜定出故。二于无色世间胜定出故。三于出世间有心定出故。又此诸定非唯灭定出已方得。亦先已得今起现前。此中前二由次第定故。展转获得胜定清净。后一不由次第定故。然由通达无相界故。展转获得胜定清净。又有相定由有相作意入住出定。若无相定由无相作意入定住定。由有相作意当知出定

复次当释法因缘经。谓于阿毗达摩阿毗毗奈耶中。善巧苾刍或邬波索迦。欲依解了而请问者。当依八相而兴请问。何等八相。谓解了事。解了所治。解了果。解了自性。解了果差别。解了所依。解了功德。解了证得。

解了事者。谓能解了五取蕴故。解了所治者。谓爱杂染及见杂染。由爱杂染故于后有灭不生欣乐。由见杂染故虽生欣乐而不能证。解了果者。谓此三种杂染永断。解了自性者。谓八圣支道。此复种种差别。宣说对治外道诸邪道故。名八圣支道。对治三种杂染故建立三蕴。谓对治恶行杂染故。对治诸欲杂染故。对治诸见杂染故。是出世间有为所摄。解了果差别者。谓诸断灭。是出世间无为所摄。解了所依者。谓三摩地。此复四种应知。一由种姓故。谓所有定一切皆由静虑种姓。随所宣说诸静虑支皆能解了。二由相故。三由生所缘相故。四由成办因缘相故。解了功德者。谓灭尽定最第一住。说名解了功德。当知此相复有五种。谓灭事故。寂静相似影像故。入定因缘故。出定因缘故。出定功德故。解了证得者。谓于五取蕴以八种相观察诸受。谓观察自性。观察现法转因缘。观察现法转灭因缘。观察当来转因缘。观察彼二转灭因缘。观察转因缘因缘。观察还因缘因缘。及观察还。此中乐俱行对治。谓于最胜根本静虑。苦俱行对治。谓得近分出离欲俱行。不苦不乐俱行对治。谓即于根本静虑。为欲显示转因缘灭故。即依诸受说所有受皆悉是苦。由彼三受约第一义皆是苦故。言相对者。谓有此故施设于彼。是名相对。此中诸受展转相对。由彼一切苦所摄故。又由有此第一义苦。施设无智。由有此故施设治彼出世之慧。由有此故施设彼果寂灭涅槃。是故彼彼诸法。说与彼彼诸法相对

复次当释眠缠。谓勤修习内心寂静奢摩他行诸苾刍等。为欲断除诸随烦恼。应知五种对治之相。谓远离闇相。于能随顺举欢喜法。发生正举加行道理。损害诸见诸见功用诸见所依功用。彼随烦恼既断灭已。复有五种任持定法。何等为五。谓诸远离远离处所。顺定言说。顺无染心资生众具。从有智者同梵行所。获得随顺教授教诫美妙言说。于诸世间等持等至。远离爱味及无漏行如理作意

复次彼勤修习增上心学诸苾刍等。由三因缘当遣现行染污寻思。谓远离所缘故。厌患自性故。远离自性故。由三因缘远离自性。谓有对治力根猛利者。能顿远离。无对治力根处中者如其粗相能渐远离。无对治力根下劣者。于诸寻思因缘财食深见过患

复次诸苾刍有六顺出离界三摩地修习支者。谓诸苾刍于闲静室勤修观行。当知三种补特伽罗有三三摩地。谓勤修习增上心者。于四有情怨行恶行净行恩行有众生缘定。又勤修习趣究竟者。有法缘定。又勤修习谛现观者。有法缘定。

复次由三种大性大三摩地。能令速疾通达真如。既通达已能尽诸漏。谓由所缘大性故。由精勤大性故。由方便所摄作意大性故。又有二远离。能令速疾通达真如。谓于行处远离愦闹。及于住处离恶寻思

瑜伽师地论卷第六十二瑜伽师地论卷第六十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中三摩呬多地之二

复有五种定相违法。一毁犯禁戒。二无无间加行。三无殷重加行。四有沉没。五他所扰恼。

复有三种远离。一住处远离。二见远离。三闻远离

复次心清净行苾刍。略有五种等持相违厚重过失。能为定障。一忿。二慢。三欲贪。四萨迦耶见。五不能堪忍。有五厚重三摩地相。由彼于此障碍而住。是故说名厚重过失。云何五相。一者获得随宜资具便生喜足。二者好乐求诸善法。三于身财无所顾恋。四于生死及与涅槃见太过失最胜功德。五于加行堪忍勤苦。此中忿者。谓怀忿故。若往他家不得利养或得而少。或弊或迟或不恭敬。由此便生颦戚愤憾。从此因缘。发恚寻思及害寻思多随寻伺。彼由此故先所未生胜三摩地不能得生。设彼已生还复退失。所言慢者。谓怀慢故。慢所制伏。为性于法不生恭敬。于诸师范尊重福田。不能时时身心卑屈敬问咨请云何为善云何不善。亦不勤求所有善法。由此不能解了引发三摩地义。从此因缘发起轻慢相应寻思多随寻伺。彼由此故先所未生如前广说。言欲贪者。谓怀贪故。多诸爱染。于身财等深生顾恋。由此于外五妙欲中多生散乱。从此因缘生欲寻思眷属寻思。国土寻思族望家势相应寻思。多随寻伺。彼由此故先所未生如前广说。彼复不净能为对治。应知不净略有三相。谓粪秽相。彼等流相。能依所依差别相。萨迦耶见者。谓由身见制伏因缘会遇世法。便为高欣下戚涂染。设欲弃舍便为身见相违而住。又即于彼世法众相。亲爱恒流之所漂溺。设欲弃舍便为身见相违而住。又即世法众相所生不正寻思之所烧恼。设欲弃舍便为身见相违而住。又即于彼世法众相追求之时。种种扰乱散动所逼。设欲弃舍便为身见相违而住。又即由彼身见因缘。恒常执着世法所依无常诸取。由是因缘为忧悲等之所逼恼。设欲弃舍便为身见相违而住。又复即彼为欲除遣下地垢秽。勤修善时。于彼加行不生喜乐。于此所治设欲弃舍。便为身见相违而住。如为除遣下地垢秽。为遣上地所有垢秽当知亦尔。由此因故虽作是心。我当于彼生死涅槃观大过失观胜功德。便复颠倒。由此因缘先虽获得诸三摩地。然于未生圣谛现观胜三摩地。不能得生。不堪忍者。谓怀不忍故。虽已获得圣谛现观胜三摩地。不能堪忍蚊虻等苦。舍离加行多生懈怠。由此因缘于所未生入根本定不能生起。设复已生还即退失。前三过失能为最初三摩地障。次一过失为谛现观三摩地障。后一过失为入根本三摩地障。

复有差别。谓有八种弃舍近住弟子因缘。于彼杂染之所染污。由染污故彼便弃舍近住弟子。非无烦恼诸阿罗汉常善住念有如斯事。云何为八。谓性于彼近住弟子有憎恶心。唯欲自身受于恭敬。如欲恭敬。欲受利养亦复如是。近住弟子多所毁犯行不正行。又于近住诸弟子众饶益损减。便有所须及与不须。于增上戒教授折伏不能堪忍。于增上心增上慧住教授折伏不能堪忍。于营众务所有扰恼。不能堪忍。

复次嗢拖南曰

  数及所对治　　支分广建立
  远离苦散动　　上支分差别

问如先所说四种静虑。何因缘故唯四静虑不增不减。答由能究竟超苦乐故。所以者何。从初静虑乃至第四。渐超苦乐方究竟故。

云何名初静虑所治。谓有五种。一者欲贪。二欲恚害。三种寻思。三者忧苦。四者犯戒。五者散乱。云何第二静虑所治。亦有五种。一初静虑贪。二寻伺。三苦。四掉。五定下劣性。云何第三静虑所治。谓有四种。一第二静虑贪。二喜。三踊跃。四定下劣性。云何第四静虑所治。谓有五种。一入息出息。二第三静虑贪。三乐。四于乐发悟。五定下劣性

问初静虑有几支。答有五支。何等为五。一寻。二伺。三喜。四乐。五心一境性。问第二静虑有几支。答有四支。何等为四。一内等净。二喜。三乐。四心一境性

问内等净何法为自性。答念正知舍为自性。问第三静虑有几支。答有五支。何等为五。一念。二正知。三舍。四乐。五心一境性。问第四静虑有几支。答有四支。何等为四。一舍清净。二念清净。三不苦不乐。四心一境性。初静虑中念正知舍。由寻伺门之所引发。是故虽有而不宣说。第二静虑由彼自性能有作业。又由踊跃心随烦恼之所缠缚。是故显示内等净名。第三静虑心随烦恼已远离故显彼自相。是故说彼离喜贪故。初静虑中离欲贪故非离喜贪。第二静虑离寻伺贪故非离喜贪。第四静虑即彼显示最极清净。是故当知一切静虑彼皆随转如其所应

问何因缘故于四静虑建立如是五支四支。答住所依故。住饶益故。住自性故。复有差别。谓思惟所缘故。受用所缘故。于缘不散故。复有差别。谓饶益所依故。增上心所依故。增上慧所依故。复有差别。谓为对治三杂染住所对治故。云何名为三杂染住所对治耶。一染污住。二苦恼住。三愚痴住。复有差别。谓受欲者相似法故。诸受欲者略有三种正所作事。能显彼是受用欲者。一正求财宝。二求财宝已能正受用。三于彼自在随意所为。如是修习诸静虑者亦有三种正所作事。当知依彼建立支分如其所应。复有差别。谓为对治自苦恼行。应知建立诸静虑支。如是略有三种对治。一对治缺减对治。二身心逼恼对治。三于外境界其心流散不寂静对治

问何因缘故初静虑中说离欲已。复说远离恶不善法。答为欲显示诸欲自相故。及为显示诸欲过患相故。过患相者。由彼诸欲发起恶行。坠堕极下恶处所故。说名为恶。违善生故复名不善。复有差别。为欲显示烦恼杂染断故。及为显示先所积集业杂染断故。复有差别。为欲显示诸在家者受用事门诸欲断故。及为显示诸出家者由寻思门诸欲断故。复有差别。为欲显示欲寻思断故。及为显示恚害寻思断故。复有差别。为欲显示外道诸仙所得相故。及为显示离彼退已行咒诅故。

问何缘故知初静虑中苦根未断。答彼品粗重未远离故。若于是处苦根已断。便与第二静虑住时应无差别。是故当知是处未断。

问若寻伺等于初静虑等中皆能摄益胜三摩地。又能摄受自地静虑皆令清净。何因缘故世尊于彼显示动名。答此望他地不望自地

问何因缘故从欲界上于初静虑等中。建立后后胜上支分。答当知略有三因缘故。一所治能治故。二证得胜利故。三所证得故。当知如是三种因缘。四静虑中五支所摄随其所应。

问初二静虑有何差别。答第二静虑中三摩地圆满有差别故。问第二第三静虑有何差别。答第三静虑饶益圆满有差别故

问第三第四静虑有何差别。答第四静虑清净圆满有差别故。复有四种修三摩地。一者为得现法乐住故。二者为得胜智见故。三者为得分别慧故。四者为证诸漏永尽故。当知依四补特伽罗建立四种修三摩地。云何四种补特伽罗。谓苦速通已得行迹已见谛者。复有异生未得行迹已得有情所缘无量已离欲者。又乐迟通已得行迹已见谛者。又乐速通已得行迹已见谛者。此中异生已得无量已离欲者。若已证得死生智通。当知是名智见清净。若乐迟通行迹转时虽已见谛。由软根故而名退法。由此因缘复于欲界受想寻思。当住正念当起正知。

复次诸静虑离欲所显。当知离欲略有六种。一自性离欲。二损减离欲。三任持离欲。四升进离欲。五愚痴离欲。六对治离欲。自性离欲者。谓于自性不净非所受用事中诸厌背性。又于苦受诸厌背性。又若已离初静虑染。住于第二静虑等中。于寻伺等诸厌背性。是名自性离欲。损减离欲者。谓两两交会习淫欲法。除热恼已诸厌背性。如是等类所余应知。皆名损减离欲。任持离欲者。谓诸有受用美妙饮食。极饱满已于余饮食诸厌背性。如是等类所余应知。皆名任持离欲。升进离欲者。谓已获得胜上财宝或尊贵位。于余下劣诸厌背性。如是等类所余应知。皆名升进离欲。愚痴离欲者。谓于涅槃甚深功德不能解了。遂于涅槃生厌背性。如是等类所余应知。皆名愚痴离欲。对治离欲者。谓由厌坏对治故。或由断对治故。或由持对治故。或由远分对治故。或由世间出世间道断诸烦恼。如是皆名对治离欲。

问何因缘故说诸静虑名为住耶。答系心于内所缘境界。于外所缘不流散故

问何因缘故说诸静虑名三摩地。答于所知事同分所缘一切影像。平等平等住持心故。问何因缘故说诸静虑名奢摩他。答为欲寂静一切烦恼正安止故

问何因缘故说诸静虑名心一境性。答略有二种所缘境界。一不定地所缘境界。二者定地所缘境界。此中一境。所谓定地所缘境界。非第二境系心于此一所缘境。是故说名心一境性。

复次当知此中从离欲退略有十种。谓或依止不平等故。从离欲退。谓如有一遭极重病。如马胜言。我于此定不能入证。将无我定当退失耶。或复有一性多粗重。于三摩地先不串习。彼由如是多粗重故成其退法。或有所缘境界胜故从离欲退。谓如有一值遇胜妙境界现前。如外道仙乃至获得非想非非想处。遇触少年美妙形色可爱母邑。从离欲退。或有获得敬养故退。谓如有一从他获得利养恭敬即便退堕。如提婆达多。或有遭遇轻毁故退。谓如有一或遭他骂或嗔或责。从离欲退。如外道仙由愤恚故退三摩地现行咒诅。或慢故退。谓如有一恃所得定自举凌他。或有增上慢故退。谓如有一于诸胜定证差别中起增上慢。或有不作意故退。谓如有一于能入定行相作意不复思惟。或有未串习故退。谓如有一安住始业新修善品。或有自地烦恼数起故退。谓如有一爱上静虑乃至疑上静虑。或有寿尽福尽业尽故退。谓如有一从上生处退没下生

复次此中或有补特伽罗下品烦恼下品善法。多念艰辛然后方退。多念艰辛方能入定。或有补特伽罗下品烦恼上品善法。多念艰辛然后方退。经一念顷速能入定。或有补特伽罗上品烦恼下品善法。经一念顷速疾而退。多念艰辛方能入定。或有补特伽罗上品烦恼上品善法。经一刹那速疾而退。一刹那顷速能入定

复有补特伽罗已得离欲从定起已。或于一时彼三摩地相间相杂作意而转。或于一时不相间杂。若遇声缘从定而起。与定相应意识俱转。余耳识生非即彼定相应意识能取此声。若不尔者。于此音声不领受故不应出定。非取声时即便出定领受声已。若有悕望后时方出。

于此地中余决择文。更不复现

    摄决择分中非三摩呬多地

如是已说三摩呬多地决择。非三摩呬多决择我今当说。

或有由自性故名不定地。谓五识身。或有阙轻安故名不定地。谓在欲界诸心心法。或有未发趣故名不定地。谓受欲者。或有散乱故名不定地。谓始业者虽修习定而于五欲其心流散。或有太聚故名不定地。谓始业者于内境界略聚其心便生沉没。或未得故名不定地。谓即散心相应诸法。或未圆满故名不定地。谓未证得加行究竟作意。或杂染故名不定地。谓虽证得加行究竟果作意。而于彼定多生爱味。或不自在故名不定地。谓即由彼染污心故不得自在。或不清净。故名不定地。谓未永害烦恼随眠。或出定故名不定地。谓从已得三摩地起而不退失。或有退故名不定地。谓从所得三摩地退

复次此中依止初不定地。为安住心。应正取相。谓青瘀相。或脓烂相。广说如前。依止第二不定地故为得作意。应勤修习。依止第三不定地故为得根本。应勤修习。依止第四现在前故最初应正安住其念。为无乱故。略摄其心。由正知故速疾摄受。依止第五现在前故应当思惟净妙之相。又应善达沉没之相。依止第六现在前故于师教授能不忘失。应当安住猛利护念如理方便。应当无间殷重修习。依止第七现在前故。应于微劣所得定中不生喜足。依止第八现在前故。于诸杂染应观过失。设生爱味所有杂染。寻即除遣不应恋着。依止第九现在前故。于三摩地应无间修。又应善巧通达其相。依止第十现在前故。应当猛利修谛善巧。依第十一现在前故。为令不退应不放逸。依第十二现在前故。即为彼事应修远离如理作意。应随顺前修习无间殷重方便。

于此地中余决择文更不复现

    摄决择分中有心地

如是已说非三摩呬多地决择。

有心地决择我今当说。当知诸心差别而转略由五相。一由世俗道理建立故。二由胜义道理建立故。三由所依能依建立故。四由俱有建立故。五由染净建立故

云何世俗道理建立。谓依世俗道理建立诸心差别转义。当知如前意地已说

胜义道理建立差别我今当说。云何名为胜义道理建立差别。谓略有二识。一者阿赖耶识。二者转识。阿赖耶识是所依。转识是能依。此复七种。所谓眼识乃至意识。譬如水浪依止暴流。或如影像依止明镜。如是名依胜义道理建立所依能依差别

复次此中诸识皆名心意识。若就最胜。阿赖耶识名心。何以故。由此识能集聚一切法种子故。于一切时缘执受境。缘不可知一类器境。末那名意。于一切时执我我所及我慢等。思量为性。余识名识。谓于境界了别为相。如是三种。有心位中心意意识。于一切时俱有而转。若眼识等转识不起。彼若起时应知彼增俱有而转。如是或时四识俱转。乃至或时八识俱转。又一意识于一时间。分别一境或二或多自境他境。故说意识不可思议。问若彼末那于一切时思量为性相续而转。如世尊说。出世末那云何建立。答名假施设。不必如义。又对治彼远离颠倒正思量故。即此末那任持意识令分别转。是故说为意识所依。又诸转识或于一时一切唯与乐受相应俱有而转。或于一时亦有苦受。或于一时亦有不苦不乐等受相应俱转。阿赖耶识相应受。于一切时唯是不苦不乐。唯是异熟生。此于一切识流转时。或乐俱行或苦俱行。或非苦乐俱行位中恒相续流。乃至命终无有断绝。所余三受当知思惟之所引发。非是俱生。时时作意引发现前。彼俱生受极微细故难可分别。如是等类当知。是名胜义道理建立诸识俱有差别

复次阿赖耶识无有烦恼而共相应。末那恒与四种任运烦恼相应。于一切时俱起不绝。谓我我所行萨迦耶见我慢我爱不共无明。是诸烦恼与善不善无记识俱而不相违。其性唯是隐没无记任运而起。当知诸余分别所起。随众缘力差别而转。又与末那相应俱有遍行任运四种烦恼。世间治道尚不能为损伏对治。何以故。已离欲者犹现行故。随所生处是诸烦恼即此地摄。当知此地已离欲者。此地烦恼现行不绝。何以故。此诸烦恼唯阿赖耶识种子所引。于一切时任运而生。非所对治及能对治境界缘力差别转故。诸离欲者世间治道。若现在前若不现前。此诸烦恼现行不绝。若诸有学已见迹者。出世间道现在前时。此诸烦恼不得现行。从彼出已还复现行。善通达故未永断故。若诸无学。此一切种皆不现行。是诸烦恼当知唯离非想非非想处欲故。一时顿断。非如余惑渐渐而断。如是等类当知。是名建立杂染清净差别。

于此地中余决择文。更不复现

    决择分中无心地

如是已说有心地决择。无心地决择我今当说。

问心不生因凡有几种。由几种因心不得生。答心不生因略有七种。由此因故心不得生。何等为七。谓缘阙故心不得生。如是作意阙故未得故。相违故断故。灭故已生故。心不得生

云何由缘阙故心不得生。谓内眼处坏。若外色处不现在前。广说乃至内意处坏。若外法处不现在前。尔时由彼所生眼识乃至意识终不得生。如是名为由缘阙故心不得生

云何作意阙故心不得生。谓虽有内眼处不坏外色处现前。广说乃至内意处不坏外法处现前。若无能生作意正起。尔时由彼所生眼识乃至意识终不得生。如是名为作意阙故心不得生

云何由未得故心不得生。谓如有一于下欲界思惟粗相。于初静虑思惟静相。为欲证得初静虑故。若于此道不极作意。若修若习若多修习。不善修故于初静虑未能证得。由未得故初静虑俱心不得生。又如有一于初静虑第二第三第四静虑。空无边处。识无边处。无所有处。思惟粗相。于第二静虑乃至非想非非想处。思惟静相。如前广说。又如有一遍于一切萨迦耶中思惟苦相。于萨迦耶灭涅槃界思惟静相。为断一切萨迦耶故。为欲证得涅槃界故。若于此道不极作意若修若习若多修习。不善修故不能尽证一切涅槃。由未证故于诸结缚及与随眠随烦恼缠。永解脱心便不得生。如是名为由未得故心不得生。

云何由相违故心不得生。谓如有一触能随顺乐受诸触。受乐受时乐受相应心现在前。尔时苦受非苦乐受相应之心。以相违故便不得生。如是若触能顺苦受不苦不乐受触。如前广说。尔时乐受非苦乐受乐受苦受相应之心。以相违故便不得生。又如有一贪缠所缠贪缠相应心现在前。尔时嗔缠相应之心。以相违故便不得生。如是若有嗔缠所缠。广说乃至尔时贪缠相应之心。以相违故便不得生。如是名为由相违故心不得生。

云何断故心不得生。谓如有一由善修习八圣支道故。证得无余贪欲嗔恚愚痴永尽。彼于尔时有贪有嗔有痴心等随一心法。诸随烦恼所染污心。彼由已断已遍知故皆不得生。如是名为由永断故心不得生

云何灭故心不得生。谓如有一生无想天入无想定入灭尽定。于其中间经尔所时。由断灭故心不得生。又如有一于无余依涅槃界中已般涅槃。彼于尔时毕竟灭故心不得生。如是名为由灭尽故心不得生

云何由已生故心不得生。所谓一切已生之心于现在生。刹那已后必成灭法。彼现在时由已生故便不可生。彼若灭已亦已生故终不可生。如是名为由已生故心不得生

应知由此七因缘故心不得生。与此相违七因缘故。随其所应诸心得生。谓缘不阙故。作意不阙故。已证得故。不相违故。未断灭故。未灭尽故。未已生故。

于此地中余决择文更不复现

瑜伽师地论卷第六十三瑜伽师地论卷第六十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中闻所成慧地

如是已说无心地决择。闻所成慧地决择我今当说。

谓由五处观察所归乃可归依。一由身业清净故。二由语业清净故。三由意业清净故。四由于诸有情起大悲故。五由成就无上法故。

问归依有几种。何缘但有尔所归依。齐何缘故说能归依。

云何修行归依之行。何等归依所得功德。答归依有三种。谓佛法僧。四缘故有尔所归依。一由如来性极调善故。二于一切种所调能调善方便故。三具大悲故。四以一切财而兴供养未将为喜。要以正行而兴供养乃生欢喜。由如是故彼所立法。彼弟子众皆可归依。齐四缘故说能归依。一知功德故。二知差别故。三自誓愿故。四更不说有余大师故。当知归依有四正行。一亲近善士。二听闻正法。三如理作意。四法随法行。若有成就此四正行乃名归依。当知复有四种正行。一诸根不掉。二受学学处。三悲愍有情。四应时时间于三宝所勤修供养。受归依者获四功德。一获广大福。二获大欢喜。三获三摩地。四获大清净。复获四德。一大护圆满。二于一切种邪信解障。皆得轻微或永灭尽。三得入聪睿正行正至善士众中。所谓大师同梵行者。四为于圣教净信诸天欢喜爱念。谓彼天众心生欢喜唱如是言。我等成就三归依故。从彼处没来生此间。是诸人等今既成就多住归依。亦当来我众同分中

复次由六种相。佛法僧宝差别应知。一由相故。二由业故。三信解故。四修行故。五随念故。六生福故

云何相故三宝差别。谓自然觉悟相。是佛宝。觉悟果相。是法宝。随他所教正修行想是僧宝

云何业故三宝差别。谓转正教业。是佛宝。舍烦恼苦所缘境业。是法宝。勇猛增长业。是僧宝

云何信解故三宝差别。谓于佛宝应树亲近承事信解。于法宝所应树希求证得信解。于僧宝所应树和合同一法性共住信解

云何修行故三宝差别。谓于佛宝应修供养承事正行。于法宝所应修瑜伽方便正行。于僧宝所应修共受财法正行

云何随念故三宝差别。应以余相随念佛宝。应以余相。随念法宝。应以余相随念僧宝。谓是世尊乃至广说

云何生福故三宝差别。谓于佛宝依一有情生最胜福。于法宝所即依此法生最胜福。于僧宝所依多有情生最胜福

复次由五法故沙门婆罗门胜劣差别。何等五法。一者闻法。二者戒法。三摄受法。四受用法。五证得法。

谓婆罗门所有闻法。义虚劣故不示他故文句隐故。是其下劣。沙门闻法与此相违。故是胜妙。又婆罗门所有戒法。随何随分随其差别开许害等。故是下劣。沙门戒法与此相违。故是胜妙。又婆罗门所摄受法。摄受障道田事宅事财货事等。又复摄受妻子奴婢僮仆等类。故是下劣。沙门所有摄受之法。除离苦法更无所有。故是胜妙。又婆罗门所受用法。受用障道涂饰香鬘庄严具等。又现受用歌舞作倡戏笑等事。又现受用淫欲等法。故是下劣。沙门所有受用之法。受用无罪正闻思修所成智慧。故是胜妙。又婆罗门所有证法。但以梵世为究竟故。复退还故杂染污故有苦恼故。是其下劣。沙门证法以般涅槃为究竟故。无退转故一向离垢故一向安乐故。当知胜妙

复次欲求有五。一摄受求。二受用求。三戏乐求。四乏解了求。五名声求。有求亦五。一法尔求。二祈愿求。三愚痴求。四厌患求。五思择求。梵行求亦五。一唯求求。二趣向求。三现得求。四后得求。五思择当得求。复有差别。谓假名求。第一义求。彼观察求。无方便求。有方便求。如本地分中已说。五明处其内明处。

于诸明处诸论诸宗为最为胜。何以故。由四清净清净义故。一摄一切染净义清净故。二即此义非他论所制伏清净故。三即此义易可入清净故。四既得入已正行不坏清净故

复次诸佛圣教若欲略释。由六种理门应随决了。一真义理门。二证得理门。三教导理门。四远离二边理门。五不可思议理门。六意趣理门。此中前三理门。由后三理门应随决了。谓真义理门。由远离二边理门应随决了。证得理门。由不可思议理门应随决了。教导理门。由意趣理门应随决了。此中真义即是理门。是故名为真义理门。乃至意趣即是理门。是故名为意趣理门。理门义者。谓于彼彼无颠倒性。如其实性离颠倒性

复次应知真义略有六种。谓世间所成真实。乃至所知障净智所行真实。安立真实。非安立真实。前四真实。应知如前菩萨地中已广分别。云何安立真实。谓四圣谛。苦由苦故乃至道由道故。所以者何。以略安立三种世俗。一世间世俗。二道理世俗。三证得世俗。世间世俗者。所谓安立宅舍瓶盆军林数等。又复安立我有情等。道理世俗者。所谓安立蕴界处等。证得世俗者。所谓安立预流果等彼所依处。又复安立略有四种。谓如前说。三种世俗。及与安立胜义世俗。即胜义谛。由此谛义不可安立。内所证故。但为随顺发生此智是故假立。云何非安立真实。谓诸法真如

云何证得。谓若略说有四证得。一诸有情业果证得。二声闻乘证得。三独觉乘证得。四大乘证得

有情业果证得者。谓由所作净不净业。自所作业为依因故。诸有情类于五趣等生死海中。感异熟果受异熟果。声闻乘证得者。谓先受归依。乃至沙门庄严为依因故。有五种证得。一地证得。二智证得。三净证得。四果证得。五功德证得。地证得者。谓有三地。一见地。二修地。三究竟地。智证得者。谓九智。一法智。二种类智。三苦智。四集智。五灭智。六道智。七此后所得世俗智。八尽智。九无生智。净证得者。谓四证净。果证得者。谓四沙门果。功德证得者。谓无量解脱。胜处遍处。无诤愿智。无碍解神通等。如是一切。应知如前已广分别。又声闻乘证得因者。谓得世间离欲之道。顺解脱分。顺决择分所有善根。独觉乘证得者。谓略有三种。一先已得顺决择分善根证得。二先已得证得证得。三先未得证得证得。前二证得名为独胜。最后证得名麟角喻

大乘证得者。谓发心证得。大悲证得。波罗蜜多证得。摄事证得。地证得。于五无量随至真如证得。不可思议威德信解证得。不共佛法证得等。如是一切。应知如前菩萨地中已广分别。云何教导。谓由三处所摄教导。一由藏所摄。二由摩呾理迦所摄。三由二所摄。藏所摄者。谓声闻藏及大乘藏。摩呾理迦所摄者。谓十七地及四种摄。二所摄者。略有十种。谓谛相教。遍知教。永断教。证得教。修习教。即彼品类差别教。即彼所摄所依能依相属教。遍知等障法教。遍知等顺法教。不遍知等遍知等过失功德教。如是能摄一切藏摄及本母摄。是名总略摩呾理迦复次教导略有十二。所谓事教。想差别教。观自宗教。观他宗教。不了义教。了义教。世俗谛教。胜义谛教。隐密教。显了教。可记事教。不可记事教

事教者。谓各别说色等眼等诸法体教。想差别教者。谓广宣说诸蕴界处缘起处非处根谛等。名想差别。又复广说诸念住等。名想差别。又复广说有色无色。有见无见。有对无对等。名想差别。如是无量诸佛世尊广说诸法。想差别教

观自宗教者。谓契经应诵记别等依止摄释宣说开示

观他宗教者。谓七种相。依止因明摧伏他论建立己论。七种相者。谓因明中论体论处所论据论庄严等。如前广说

不了义教者。谓契经应诵记别等世尊略说。其义未了应当更释

了义教者。与此相违应知其相

世俗谛教者。谓诸所有言道可宣一切皆是世俗谛摄。又诸所有名想言说增上所现谓相名分别。如是皆名世俗谛摄

胜义谛教者。谓四圣谛教。及真如实际法界等教

隐密教者。谓从多分声闻藏教

显了教者。谓从多分大乘藏教

可记事教者。谓四种法嗢拖南教。即一切行无常。乃至涅槃寂静。如是等类所有言教

不可记事教者。谓有问言世间常耶。此不应记。但言我说此不可记。乃至问言。如来死后有耶无耶。此不应记。但言我说此不可记。此中应知四因缘故宣说如是不可记事。或有无故不可记别。谓有问言。我于诸蕴为异不异常无常等。或有能引无义利故不可记别。如升摄波叶喻经中如来自言。我所证法乃有尔所而不宣说。何以故。彼法不能引义利故。或有甚深故不可记别。谓有问言。我是有耶。此不应记。勿彼即于诸蕴执我或离诸蕴而执有我。又有问言。我是无耶。此不应记。勿于世俗言说士夫起损减执如是如来死后有无乃至非有非无等。皆甚深故不可记别。或有其相法尔建立故不可记。谓有问言。诸法真如于彼诸法异不异耶。此不可记。何以故。彼相法尔不可建立异不异故。应知复有四种因缘。如来宣说不可记事。谓诸外道妄宣说故。不如理故。引无义故。唯是诤论所依处故。有二因缘能引无义。一者远离思因果故。二者远离思染净故

云何远离二边。当知略有六种。谓远离增益非实有边。远离损减真实有边。远离妄执常边。远离妄执断边。远离受用欲乐边。远离受用自苦边。如是应知如前处处已广分别

云何不可思议。当知略有六种不可思议。谓我思议。有情思议。世间思议。有情业果思议。诸修静虑静虑境界。诸佛世尊诸佛境界。此中我思议有情思议世间思议。或依见思议。或不依见思议。我思议者。谓如有一依止身见如是思议。我于过去为曾有耶为复无耶。于三世中乃至广说。又复思议。我是有色后当有想后当无想。后当非有想非无想。如我有色。我无色亦尔。若广宣说如梵网经。如常见论者如是。断见论者现法涅槃见论者当知亦尔。计前际边计后际边。如其所应皆当了知。又复思议。命即是身。命异身异。又此我我遍一切处。无二无别无有缺减。有情思议者。谓如有一即依身见如是思议。今此有情从何而生。是诸有情谁之所作。乃至有情当何所往。是诸有情何处灭尽。世间思议者。谓如有一即依身见如是思议。世间是常乃至广说。或依法性如是思议。此我法性有情法性世间法性。从何而生。不能唯依法尔道理。是故说此名为思议不思议处。有情业果思议者。由四种相不可思议。谓处所差别故。事差别故。因差别故。异熟果差别故。诸修静虑静虑境界由三种相不可思议。谓真如甚深义故。自在转故。无漏界证得故。诸佛世尊诸佛境界。由五种相不可思议。即由如先所说三相。复由二相。谓无障故。成立有情所作事故

复次当知意趣略有十六。谓示现意趣乖离意趣。劝导意趣。赞励意趣。庆喜意趣。令入意趣。断疑意趣。成熟意趣。等持意趣。解脱意趣。别义相应意趣。诸能证者发生无罪欢喜意趣。诸能听者于说者所发生尊重意趣。法眼恒转意趣。多修诸善意趣。摧伏诸相意趣。

云何真义理门由远离二边理门应随决了。谓于安立所有苦谛乃至道谛。略有四种妄增益边。一我增益边。二常增益边。三净增益边。四乐增益边。如此即是四种颠倒。为对治彼说四念住及四定智。由此因缘所有我见皆是妄执我增益边。广说应知如前有寻有伺地。由彼广辩执有我者不应理故。又若略说。离彼诸蕴生故相故及业用故。别有我性不可得故。又异彼相安住诸行所有我性。当知毕竟定无所有。又彼常性不应道理。当知如前已广分别。又有六种不净性。如声闻地已广显示。又有三种苦性。如有寻有伺地已广显示。损减边者。谓即于彼诸圣谛中。随所安立诸谛相状。执为无性。显为无性。何以故。若于诸谛起损减执。彼于三量亦住诽谤。谓现量比量。及圣教量。亦谤染净。是故说此名损减边。若不堕在如是二边。彼于诸谛能生信解。决定通达。渐次能证究竟清净

云何苦谛。谓生苦等。广说如前。若略说者。如说一切生杂染事。皆名苦谛。云何集谛。谓说一切烦恼杂染及业杂染。皆名集谛。世尊就胜唯显贪爱。其胜因缘如前应知。云何灭谛。所谓一切烦恼永断。又此永断由八种相。如前应知。此中爱尽离欲者。此显有余依涅槃界。永灭涅槃者。此显无余依涅槃界。云何道谛。谓资粮道若方便道若清净道。如是一切总略为一说名道谛。世尊就胜依能摄受沙门果证。但略显示八圣支道名为道谛。资粮道者。有十三种。如声闻地已说应知。方便道者。若就最胜谓于暖顶忍世第一法位中。所有一切诸念住等菩提分法。清净道者。谓于见道修道究竟道中。即彼所摄所有一切菩提分法。究竟道中所有能引诸功德道。彼亦皆入道谛数中。又诸菩萨方便道者。谓六波罗蜜多所摄。清净道者。谓般若波罗蜜多所摄。此约最胜说。非不一切菩提分法皆遍修习。如世尊言。略五取蕴皆名苦者。此五取蕴若广分别。如前意地决择蕴善巧中。应知其相。又苦集谛略有三种。谓欲色无色系差别故。又于十方无边世界有差别故其量无边。对治此故应知灭谛道谛差别。又此诸谛建立次第。广分别义如前应知

复次即此诸谛为据为依为建立处。立十三种补特伽罗。云何十三种补特伽罗。谓欲界异生。色界异生。无色界异生。欲界有学。色界有学。无色界有学。欲界无学。色界无学。无色界无学。欲界独觉。欲界菩萨。色界菩萨。不可思议如来。又即如是补特伽罗。若造作若障。若心若烦恼。若业若根。若界若信解。若意乐若随眠。若生若习气。若聚皆应了知

复次造作者。有十二种。谓善造作。不善造作。无记造作。出家造作。彼胜流造作。彼防护造作。生造作。离欲造作。解脱造作。练根造作。引发神通造作。发起他义造作

复次障者。有十二种。一业障。谓作五无间业故。二习气障。谓先数习诸恶业故。三放逸障。谓大兴盛现在前时受用诸欲。四盖障。谓五种盖随一现前覆蔽其心。五懈怠障。谓由懈怠少分烦恼缠扰其心。六障碍障。谓十一种障碍随一现前。七生障。谓生无暇处。八不生障。谓佛世尊不现于世。九信解障。谓佛世尊虽现世间而生邪见。十烦恼障。谓由彼故说慧解脱心得解脱。十一定障。谓由彼故说俱分解脱心得解脱。十二所知障。谓由彼故说诸如来心得解脱

复次心者。略有二种。一有障心。二无障心。烦恼者。亦略有二种。谓缠及随眠。业者。亦略有二种。谓思及思已。根者。亦略有二种。谓顺净分及顺不净分。如根如是。界信解意乐当知亦尔。此中差别者。根是果性。界是因性。信解是因性。意乐是果性。随眠者。亦略有二种。谓可害及非可害。生者。亦略有二种。谓无暇生及有暇生。习气者。亦有二种。谓无间生习气及前生习气。聚者。有三种。一邪性定聚。二正性定聚。三不定聚。邪性定聚。复有二种。一本性邪性定。二方便邪性定。正性定亦有二种。一本性正性定。二方便正性定。不定亦有二种。一本性不定。二方便不定

复次由造作等十三种法。应知广说十三种补特伽罗。如其所应。问若有善造作彼一切不善造作不相应耶。设不善造作不相应彼一切有善造作耶。答应作四句。或有善造作非不善造作不相应。谓诸能造黑白黑白异熟业者所有善造作。或有不善造作不相应非善造作。谓无记造作。或有善造作亦不善造作不相应。谓能造作白白异熟业。及不黑不白异熟业。能尽诸业者所有造作。或有非善造作亦非不善造作不相应。谓能造作黑黑异熟业者所有造作。如是不善造作无记造作。如其所应尽当知。问若成就业障亦成就习气障耶。设成就习气障。亦成就业障耶。答应作四句。或有成就业障非习气障。谓如有一于现法中。于五无间业亦作亦增长。于前生中于此种类恶不善业不作不增长。彼现法中能障圣道。或有成就习气障非业障。谓与此相违。或有俱成就。谓于现法中于五无间业亦作亦增长。于前生中于此种类恶不善业亦作亦增长。彼现法中能障圣道。或有俱不成就。谓与此相违。云何非安立真实。谓诸法真如圆成实自性。圣智所行圣智境界圣智所缘。云何增益边。谓诸法自性略有三种。一遍计所执自性。二依他起自性。三圆成实自性。遍计所执自性者。谓诸所有名言安立诸法自性。依假名言数数周遍。计度诸法而建立故。依他起自性者。谓众缘生他力所起诸法自性。非自然有故说无性。圆成实自性者。谓如前说。若于依他起自性或圆成实自性中。所有遍计所执自性妄执。当知名增益边。所以者何。此自性中彼自性有不应理故。此不应理如菩萨地已略显示。彼决择中当广分别。又若略说由三因缘不应道理。谓种种非一。品类名言所安立故。若离名言彼觉不生故。又彼名言依义转故。损减边者。谓于依他起自性。及圆成实自性诸有法中。谤其自相言无所有。如是真义理门。由远离二边理门。应随决了。

如其所应证得教导二种理门。由后二种不可思议意趣理门。应随决了。

问如前说别义相应意趣者此有何义。答非如言音名身句身文身义相应意趣。但是除遣如言音等。其余胜义是名别义相应意趣

复次此中于真义理门。由远离二边理门随决了已。便能证得所应得义。由能证得所得义故。所余证得理门。由不可思议理门亦随决了。又复一切诸佛世尊教导理门。由意趣理门亦随决了。如是一切随其所应。又若于彼真义理门随决了者。当知能入五种离生。一能入未离欲离生。二能入倍离欲离生。三能入已离欲离生。四能入独觉离生。五能入菩萨离生。

问若安立谛建立为谛。何因缘故更复显示非安立谛。答若离非安立谛。二种解脱不应道理。谓于相缚及粗重缚。所以者何。若有行于诸安立谛。彼一切行皆行有相。行有相故于诸相缚不得解脱。于诸相缚不解脱故。于粗重缚亦不解脱。若有行于非安立谛不行于相。不行相故于诸相缚便得解脱。于诸相缚得解脱故于粗重缚亦得解脱。问若唯由彼非安立谛。于一切缚解脱清净。何缘显示安立谛耶。答为令资粮及方便道得清净故。问若即由彼行有相心于二种缚解脱清净有何过失。答若有极善定心。依第四静虑顺决择分善法中转缘诸谛境。彼诸行者于二种缚应得解脱究竟清净。然不清净故不应理。又世间道出世间道二种差别应不可立。然彼二道。有相无相有差别故不应道理

云何粗重相。谓若略说无所堪能不调柔相。是粗重相。此无堪能不调柔相。复有五相。一现重相。二刚强相。三障碍相。四怯劣相。五不自在转无堪能相。由有此相顺杂染品。违清净品相续而住。是故说为无所堪能不调柔相

复次有五诸根大种长养。谓食长养。梦长养。避不平等长养。梵行长养。等至长养。即此长养略有二种。一任持长养。二不损害长养。此中最初是任持长养。后四是不损害长养。任持长养略有四种。一变坏任持。二喜悦任持。三希望任持。四摄受执取任持

复次有五种行。一身行。二语行。三意行。四业行。五寿行

复次有五种不放逸。一依在家品不放逸。二依出家品不放逸。三能远离不善不放逸。四能摄受诸善不放逸。五修习相续不放逸。依在家品不放逸者。复有五种如前已说。依出家品不放逸者。复有十种。如声闻地决择毗奈耶相应中我当广说。能远离不善不放逸者。当知即是前二正断。能摄受诸善不放逸者。当知即是后二正断。修习相续不放逸者。谓于善法无间殷重精勤修习

复次名有五种。一心。二心所有法。三善。四不善。五无记。色有五种。一诸大种。二大种所造。三有见有对。四无见有对。五无见无对

复次有五无明。一义愚。二见愚。三放逸愚。四真实义愚。五增上慢愚

复次有五种有爱。一法性爱。二誓愿爱。三愚痴爱。四厌离爱。五思择爱

复次由五种相。当知建立无惭无愧。一于染污现行无有羞耻。二于善不现行无有羞耻。三于舍法受无有羞耻。四亲近恶友无有羞耻。五于所作不能成办无有羞耻。当知与此五相相违五种妙相建立惭愧

复次由五种相当知建立恶说者性。一无行故。二邪行故。三不忍故。四无羞耻故。五不律仪故。由五种相建立恶友。一无羞耻。二有邪见。三有懈怠。四有邪行。五性怯劣。当知与此五相相违五种妙相立善说者及与善友。

复次由五种相立奢摩他。一近分定所摄世间奢摩他。二根本色定所摄世间奢摩他。三根本无色定所摄世间奢摩他。四声开独觉作意所摄出世奢摩他。五菩萨作意所摄出世奢摩他

复次由五种相当知建立毗钵舍那。一尽所有性毗钵舍那。二如所有性毗钵舍那。三有相毗钵舍那。四思求毗钵舍那。五观察毗钵舍那

复次略由五相建立欲漏。一不定地事生随眠故。二随顺恶行故。三善相违故。四耽着诸欲故。五能生坏苦苦苦果故。彼诸烦恼说名欲漏。

略由五相建立有漏。一能生劣界诸烦恼。二能生中界诸烦恼。三能生妙界诸烦恼。四能生无欲乐有诸烦恼。五能生有欲乐有诸烦恼。

略由五相立邪解脱欲无明漏。一有想论者。由有想论门生起无明。二无想论者。由无想论门生起无明。三非有想非无想论者。由非有想非无想论门生起无明。四断见论者。由断见论门生起无明。五现法涅槃论者。由现法涅槃论门生起无明

复次略由五相应知诸法差别道理。一由相故。二由体故。三由业故。四由法故。五由因果故。相者。谓由所依故及行住故。体者。谓由自体相故及差别相故。业者。谓由自作用故及邪正行故。法者。谓由染净故及世俗胜义谛故。因果者。谓由近远故及爱非爱故

复次有三种论。一听闻究竟论。二诤讼究竟论。三正行究竟论。听闻究竟论者。谓婆罗门诸恶咒术。诤讼究竟论者。谓诸外道因明论。正行究竟论者。谓佛圣教。复有三论。一无义论。二邪义论。三第一义论。此三如前随其所应。复有三论。一矫诈论。二虚伪论。三出离苦果论。如是三论应知如前随其所应

复次若欲造论。当先归礼二所敬师方可造论。恭敬法故。先应归礼论本大师。恭敬义故。复应归礼开阐义师。

欲造论者。要具六因乃应造论。一欲令法义当广流布。二欲令种种信解有情。由此因缘随一当能入正法故。三为令失没种种义门重开显故。四为欲略摄广散义故。五为欲显发甚深义故。六欲以种种美妙言辞庄严法义生净信故。

将造论时。要以四德先自安处乃可造论。一于昔诸师应离憍慢。二于有情类当起大悲。三于同法者深生敬爱。四不欲彰己有胜技能。云何于昔诸师应离憍慢。谓造论时无如是心。古昔诸师尚能造论。况我今者当不造耶。要离如是憍慢染心乃应造论。云何于有情类当起大悲。谓造论时作如是观。若不造论。无量有情于诸善法定当退失。又余情类堕生老病。乃至广说。是诸有情因我造论。若能解了乃至一句善说妙义。如是如是当奉行者。彼于长夜必获大义利益安乐。要发如是增上心已乃应造论。云何于同法者深生敬爱。谓造论时作如是观。若不造论为欲利他诸同法者于利他事定当退失。云何不欲彰己有胜技能。谓造论时无如是心。当令世间咸谓于我聪睿明哲能造论者开阐义者深生净信因此多获利养恭敬。但为自他善根增长。以无染心乃可造论

复次此中如实开示如来所说经义。名庄严经。譬如红莲其花未开虽生欢喜不如敷荣。又如真金未为严具虽生欢喜不如成功。又如美膳未及得食虽生欢喜不如已食。又如庆书未暇开览。虽生欢喜不如披阅。又如珍宝未得现前虽生欢喜不如已得现前受用。如是如来所说经义。若未显发虽生欢喜不如开示。故说造论名庄严经

复次略有七种通达。一字通达。二字义通达。三能取通达。四能取义通达。五系缚通达。六解脱通达。七法性通达。字通达者。通达为常。字义通达者。达为无常。能取通达者。谓根识等达安立谛或非安立。如能取通达。能取义通达当知亦尔。系缚通达者。通达相缚或粗重缚。与此相违当知说名解脱通达。法性通达者。谓能通达法性安住法界安住。非从自在自性士夫中间等有

复次由十相故具足多闻。谓善说者说故。显了文句说故。尽其所有如其所有义说故。安乐方便加行说故。离众苦说故。如是五种复有五种。谓不求过失而听法故。但求涅槃而听法故。善听法故。谛听法故。于依名句文身义审谛观察而听法故。

于此地中余决择文。更不复现

瑜伽师地论卷第六十四瑜伽师地论卷第六十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中思所成慧地之一

如是已说闻所成慧地决择。思所成慧地决择我今当说。

谓若略说有四种思议。一事思议。二有非有思议。三因果思议。四乘思议。事思议者。略依六事。所谓蕴事乃至根事。有非有思议者。如本地分已说。因果思议者。如有寻有伺地已说。乘思议者。如声闻独觉菩萨地已说

复次略有二种思议。谓恶思思议及善思思议。恶思思议者。如本地分已说。若依黑品。谓如有一不避无明不应思等而起思议。善思思议者。与此相违应知其相。如恶思善思如是。非法所引法所引。非毗奈耶所引毗奈耶所引。非圣圣。不善善。不应修应修。不好好。黑白。引无义引有义。下劣微妙。有罪无罪。应远离不应远离等。当知亦尔

复次如世尊言。诸圣弟子有知为有。非有知为非有。此中云何为有。云何非有。略由二相应知是有。何等为二。一若生已生现在故。应知是有。二若实物故事故义故圆成实故。应知是有。云何应知。略说实有及假有相。谓若诸法。不待所余不依所余施设自相。应知略说是实有相。若有诸法。待于所余依于所余施设自相。应知略说是假有相。非实物有。谓以色等诸蕴想事为待为依。施设有我及有情等。乃至广说。此中色等诸蕴想事是实物有。我及有情命者生者数取趣等非实物有。唯是假有。如于色等诸蕴想事。假立我等如是。即于色等想事。假立色等。又于色香味触想事。假立饮食车乘瓶衣诸庄严具舍军林等。又于有为诸法想事。假立生老住无常种子。有表无表得命根众同分。名身句身文身异生性。和合不和合流转定异相应势速次第时方及数。又复唯以诸色不转为待为依。假立虚空虚空无为。又唯以名中间不转为待为依。假施设有无想等至灭尽等至等。

问于因成道理中。依何道理能决定知我非实有。答不可得故不可见故。云何不可得。谓若内若外若二中间。若离诸蕴。都不可得。云何不可见。谓如眼等实有诸处。各各别有业用可见。如是所计我别业用都不可见。如是自相不可得故。又别业用不可见故。应知所计我非实有。问若如是我于内外等都不可得亦不可见。何故出家诸外道等亦得亦见。由此因缘爱乐显示建立实有。答不得不见。但由身见及与我慢为依止故。起邪分别起邪计度不如正理。爱乐显示建立为有。云何知我非实有故非现有故。而不可得亦不可见。谓诸计我为实有者远极彼岸不过四种。一者计我即是诸蕴。二者计我异于诸蕴住诸蕴中。三者计我非即诸蕴而异诸蕴。非住蕴中而住异蕴离蕴法中。四者计我非即诸蕴而异诸蕴。非住蕴中亦不住于异于诸蕴离蕴法中。而无有蕴。一初蕴法都不相应。依我分别计为有者。皆摄在此四种计中。除此更无若过若增。如是一切我实有性皆不应理。何以故。若计有我即是诸蕴非异蕴者。是则此我但于诸蕴而假建立。斯过自至。所以者何。诸蕴无常。各与自相而共相应。我即彼故非常非一非实有性。是故此计不应道理。若计有我异诸蕴者。此所计我。为是无常为是常耶。若无常者。则所计我刹那刹那异起异灭。此处异死余处异生。异作异受。斯过自至。又异诸蕴别有一我。若内若外若二中间。有生有灭都不可得。是故此计不应道理。若我常者。无有变异是其常相。此所计我若无变异。二因缘变皆不应理。非于当来亦非现法。若于当来我无变者。便应无生无老无病无死无损。亦复不应一时为天一时为人。或为傍生或为鬼趣。或时为彼那落迦等。于现法中我若不变。便应于彼爱非爱等种种境界。无乐无苦无爱无恚亦无有痴。略说不应由苦乐等之所变异。不应随一贪等烦恼及随烦恼之所变异。如是我于当来现法无变异故。不应为乐之所饶益。亦不应为属彼烦恼之所染污。不应因此行法非法。不应为苦之所损害。亦不应为属彼烦恼之所染污。不应因此行法非法。此我如是。于现法中与法非法不相应故。于当来世爱非爱身无因缘故。应不得生。由此道理汝应不计此常住我。由别内身变异所作。于当来世生老死等种种变异。如是此我便无各别。内身生老病死等时乐时苦时及染污时。则应毕竟解脱清净。是故此计不应道理

复次若计有我异于诸蕴住异诸蕴离蕴法中者。彼所计法远离诸蕴。有之自相尚不可得。何况为我之所安住。譬如有言我审了知石女儿顶系空华鬘。应知此计亦复如是。是故此计不应道理

复次若计有我一切蕴法不相应故无有蕴者。此所计我若无有蕴便无有色。非身相应。亦非苦乐等受相应。亦非众多种种差别诸想相应。亦非善不善无记思等相应。亦非受用色等境界分别意相应。如是此我应无所依无受无想无思虑等亦无分别。是则此我不由功用。究竟解脱无有染污。是故此计不应道理

复次由彼一切依我分别。妄所计我不成就故。当知我等于诸蕴中但假建立。非实有物。由我非有唯有蕴故。一切杂染清净道理皆得成就。谓有内外诸处生故。于现法中起无明触。由此于身便有饶益损减受生。由此为缘发起和合乖离等爱及有。依此一切烦恼随烦恼转。为此义故净不净业生起可得。如是烦恼业生起故。当来后有生老死等一切苦法皆悉得生。如是且于无常蕴中无实我故。杂染道理皆得成就。又由他音内正作意为因缘故。远离无明发起于明。由无痴故了达诸受皆悉是苦。由此能断于诸受中所有贪爱。及断依此一切烦恼若随烦恼。由此因缘能感后有净不净业不复生起。如是由业烦恼断故。一切后有及生等苦永更不生。如是无我唯有蕴故。一切杂染清净道理皆得成就

复次此中假立一切有情。所谓无足二足四足多足。有色无色有想无想非想非非想处有情。当知如是九种有情。略由三种因缘建立。总摄一切有情之类。谓依往来身动差别。建立无足乃至多足有情。依身差别。建立有色无色有情。依心差别。建立有想无想非想非非想处有情

复有离系出家外道。作如是说。一切树等皆悉有命。见彼与内有命数法。同增长故。应告彼言。汝何所欲。树等增长为命为因。为更有余增长因耶。若彼唯用命为因者。彼未舍命。而于一时无有增长不应道理。若更有余增长因者。彼虽无命。由自因缘亦得增长故不应理。又应告彼。汝何所欲。诸无命物无有增长。为有说因为无说因。若有说因。此说因缘不可得故。不应道理。若无说因。无因而说而必尔者。不应道理。又应告彼。汝何所欲。诸树等物与有命物。为一向相似。为不一向相似。若言一向相似者。诸树等物根下入地上分增长。不能自然摇动其身。虽与语言而不报答。曾不见有善恶业转。断枝条已余处更生。不应道理。若言不一向相似者。是则由相似故可有寿命。不相似故应无寿命。不应道理。如是增长余因有无。有故无寿命物不增长。说因有无。有故相似一向不一向故。此所计度不应道理

问何缘故知色香味触如是如是别安立中。饮食车乘瓶盆衣服庄严具等诸想事物皆是假有。答由彼想物。或于是处色等想物聚中而转。或于是处色等想物聚中不转。若于是处色等想聚有食想转。非于是处饮等想转。若于是处车乘想转。非于是处衣等想转。如是所余乃至广说。诸假有想若转不转。当知亦尔。一切色香味触想事。遍于一切饮食车乘瓶盆衣服庄严具等诸想事中。无差别转。是故当知。饮食车乘瓶盆衣服庄严具等。皆是假有。色香味触是实物有。复次依诸有法立假想物。非一众多种种品类。当知略说总有二种。一依止一聚。二依止非一聚。各别饮食车乘衣服庄严具等。名依止一聚。诸彩画业雕素等业宅舍宫殿军林等物。名依止非一聚

复次云何有色诸法。谓若略说有十色。处及法处所摄色。由彼诸色具色自相。即以此事还说此事。是故说名有色诸法。此有色法由五种相差别建立。何等为五。一事故。二自相故。三共相故。四界故。五业故。此中诸所有色。彼一切若四大种。若四大种所造。应知是名略摄色事。除此更无若过若增。诸色自相复有三种。一清净色。二清净所取色。三意所取色。谓四大种所造五识所依五清净色眼等处摄。名清净色。色等五境同分清净色之境界。名清净所取色。若与识俱诸清净色与识同境。故名同分。若离于识诸清净色前后自类相续而转。名彼同分色。三摩地所行影像等色。名意所取色。诸色共相亦有三种。谓一切色若据方处各别安立。若可宣说方处差别。名初共相。又一切色若清净。若清净所取增减相。当知是名第二共相。又即此一切色若触所触即便变坏。或以手足块刀杖等。或由寒热饥渴蚊虻风日蛇蝎诸触所触即便变坏。当知是名第三共相。若由定地色爱诸业之所生起。名色行色。若不定地色爱诸业之所生起。名欲行色。如是诸色由界差别略有二种。无色界中无如是色。又前所说诸色共相。谓触所触即便变坏。如是共相非一切遍。除欲界天遍余一切。欲界天中所有诸色。但有手足块刀杖等所触变坏。无有寒热饥渴等触之所变坏。由彼天中诸饮食等众资生具随欲所生则便成办。是故于彼虽有饥渴不为损害。色界诸色无有手足块刀杖等所触损坏。亦无余触之所损坏。若善不善无记身业语业。是名业色。当知是名色业差别。无色诸法亦由五相差别建立。与此相违应知其相。复次略由二种色聚建立诸聚。一不共大种聚。二非不共大种聚。不共大种聚者。谓于此中唯有一类大种可得。非不共大种聚者。谓于此中有二大种或多大种种类可得。又于不共大种聚中。极微已上诸大种合。当知方有相杂不相离。诸大种色无有一处不相离诸大种色。于非不共大种聚中大种极微。如所造色与余大种。当知亦有同一处所不相离者。然彼大种非所造色。互不相依而得转故。各有功能据别处故。又一处不相离者。谓诸大种及所造色同住一处。如置一箧青黄赤白有光明珠种种光明互不相离。相杂不相离者。所有譬喻如前应知。又若有聚或麻豆等或细沙等。为诸胶蜜及沙糖等之所摄持。当知此非一处不相离。亦非相杂不相离。但是和合不相离。多聚聚集非一聚相。当知所余是一聚相。又相杂不相离。当知依止一处不相离。此若不尔不应道理

复次由五种相建立有见诸法差别。何等为五。谓显色故。形色故。表色故。眼境界故。眼识所缘故。亦由五相建立无见诸法差别。与上相违应知其相。复次由五种相建立有对诸法差别。何等为五。一各据别处而安住故。二于余色聚容受往来等业为障碍故。三为手足块刀杖等所触便变坏故。四一切皆为诸清净色之所取故。五一切皆为依清净色识所缘故。亦由五相建立无对诸法差别。与上相违应知其相

复次即由五相应知建立无见无对诸法差别。何等为五。一因缘故。二据处所故。三显现故。四无变异故。五所缘故。谓具威德三摩地俱诸色胜解。当知是名无见无对色生因缘。彼既生已处所可得。是故名色。虽不与彼十有色处自相相应。然得似彼自性显现。于余色聚容受往来等业非障碍住。又非一切清净之色及依彼识。所取境界。亦非所缘。是故说名无见无对。手足等触不能损坏。是故说名无有变异。又根本定名具威德三摩地。此色是彼所缘非余。譬如非一切心皆能变化。若所有心具大威德方能成办。非所余心此亦如是。要具威德极静定心。方能为缘生此无见无对诸色。此如化色亦非不具大威德心及不定心所缘境界。但是彼心所缘境界。是名与上五相相违当知建立无见无对诸法差别

复次由五相故建立有漏诸法差别。何等为五。谓由事故。随眠故。相应故。所缘故。生起故。云何有漏法事。谓清净内色。及彼相依不相依外色。若诸染污心心所。若善无记心心所等。此有漏事。随其所应由余四相说名有漏。谓随眠故。相应故。所缘故。生起故。若于清净诸色。及于如前所说一切心心所中。烦恼种子未害未断。说名随眠亦名粗重。若彼乃至未无余断。当知一切由随眠故说名有漏。若诸染污心心所。由相应故说名有漏。若诸有事。若现量所行。若有漏所生增上所起。如是一切漏所缘故名为有漏。此中现在名为有事。过去未来名非有事。若依清净色识所行名现量所行。若余所行当知名非现量所行。若内诸处增上生起一切外处。名有漏所生增上所起。唯彼所缘当知有漏。所以者何。若缘去来起诸烦恼。过去未来非有事故。不由所缘说名有漏。若现在事非现量所行。如清净色及一切染污善无记心心所。彼亦非烦恼所缘故。说名有漏。但由自分别所起相起诸烦恼。非彼诸法。为此分明所行境故。由生起故成有漏者。谓诸随眠未永断故。顺烦恼境现在前故。于彼现起不如理作意故。由此因缘诸所有法正生已生或复当生。如是一切由生起故说名有漏。又从一切不善烦恼诸异熟果及异熟果增上所引外事生起。如是一切亦生起故说名有漏。又由无记色无色系一切烦恼于彼续生。彼所续生亦生起故说名有漏。如是名为由五相故建立有漏诸法差别。谓由事故。随眠故。相应故。所缘故。生起故

复次由五相故建立无漏诸法差别。何等为五。一有诸法离诸缠故说名无漏。谓一切善无记心心所所依所缘诸色。及善无记诸心心所。二有诸法随眠断故说名无漏。谓已永断见修所断一切烦恼所有诸善。及一分无记造色若诸无记若世间善诸心心所。三有诸法由断灭故说名无漏。谓一切染污心心所彼不转故说名无漏。由彼不转显了涅槃。即此涅槃说名无漏。四有诸法是见所断断对治故。自性解脱故。说名无漏。谓一切见道。五有诸法是修所断断对治故。自性相续解脱故。谓出世间一切修道及无学道。当知是名由五相故建立无漏诸法差别

复次由五相故建立有诤诸法差别。何等为五。谓由事故。因缘故。自性故。助伴故。等起故。此中五取蕴名有诤法事。若爱味染着爱味耽嗜。名诤因缘。若无常性苦性变坏法性。名有诤自性。即于此诤无智愚痴。名诤助伴。由此因缘五黑品转。名为等起谓斗讼违诤。耽着诸欲诸见所生。或余种类。是初黑品。若随所有诸烦恼缠无有羞耻。多安住性。是第二黑品。若有沙门或婆罗门。违逆正道。所欲苦行及余信解。自饿投火坠高岩等。是第三黑品。若有现行身语及意一切恶行。是第四黑品。欣乐后有。是第五黑品。此中最初由生怨恨发愤心故。不安隐住。第二由诸烦恼内烧然故。不安隐住。第三由自誓愿虚受劬劳无义苦故。不安隐住。第四生恶趣故。不安隐住。第五生老死等众苦合故。不安隐住。此中五取蕴有诤事与诤自性及彼因缘助伴等起。共相依故名有诤法。又由五相建立无诤诸法差别。与上相违应知其相。此中五无取蕴无诤事。由诤自性及彼因缘助伴等起于彼法中不可得故。名无诤法。

复次由五相故建立有染诸法差别。何等为五。谓事故因缘故等。如前广说五相差别。此中事者。谓即五有取蕴。因缘者。谓即此中喜乐爱味诸因缘法。自性者。谓此为缘生起喜乐爱味所摄。助伴者。谓于爱味所有贪着。等起者。谓五黑品。如前应知。五取蕴事。由与有染及彼因缘乃至等起共相依故。说名有染。又由五相建立无染诸法差别。与上相违应知其相。如前无诤随应当说

复次由五相故应知建立依止耽嗜诸法差别。何等为五。谓事故因缘故等。如前广说。此中事者。谓欲界系诸五取蕴。因缘者。谓顺欲贪五种妙欲。自性者。谓贪嗜者由彼为缘由彼为境所有欲贪。助伴者。谓不如理作意相应邪愿诸欲分别。由与此俱名分别贪。等起者。谓五种黑品如前广说。彼欲界系五取蕴事。由彼贪嗜因缘助伴及与等起所摄受故。说名依止耽嗜诸法。又由五相当知建立依止出离诸法差别。与上相违应知其相。

复次由五相故建立世间诸法差别。何等为五。一一切清净色及清净所取色世间。二一切染污心心所世间。三一切无记心心所世间。四一切善心心所若当断若已断世间。五一切世间三摩地所行无见无对色世间。又由五相建立出世诸法差别。何等为五。一见道所断对治。二修道所断对治。三由想解脱之所解脱。谓诸声闻独觉菩萨已入无戏论理慧。及彼相应诸心心所。四彼所缘无见无对色。五一分所治解脱之所解脱。谓诸有学。若一切所治解脱之所解脱。谓诸无学

复次依五种世间。即彼世间名堕诸法。谓有情世间。器世间。欲世间。色世间。无色世间。当知是名五种世间。又出世法不堕如是五种世间。是故说名不堕诸法

复次由五相故建立有为诸法差别。何等为五。一后际未生故。二前际已灭故。三中际目相安住故。四因缘相续故。五果相续故。又由五相建立无为诸法差别。何等为五。谓与上相违应知。即是此中五相。灭有为法证得涅槃。若谓涅槃为有异者。当知此为不如理问不如理答不如理思。如是若谓为无异者。有无异者。非有非无异者。当知皆是不如理问不如理答不如理思。何以故。由彼涅槃唯有为灭之所显故。与有为法其相异故。唯有为灭之所显故。谓有异者。若问若答若思便为戏论非所戏论。与有为法其相异故。谓无异者。如前广说。便为戏论非所戏论。总如前说。二种因故。亦异不异不应道理。由有为灭证涅槃故。若谓一切皆无所有故说非有非无异者。不应道理。涅槃义者。谓一切白法所显发故。涅槃相者。谓寂灭相无戏论相。当知唯是内所证相。

复次由五相故建立所缘诸法差别。何等为五。一有善作意所缘法。二有不善作意所缘法。三有无记作意所缘法。四有堕界作意所缘法。五有系属瑜伽作意所缘法。此中若善作意。缘善不善无记诸法。如善作意。如是不善无记作意当知亦尔。欲界系善染污无记作意。缘一切三界诸法。色界系善作意。亦缘一切三界诸法。无色界中若定若生外道异生无色界系善作意。唯缘自地一切法。非下地。若毗钵舍那行菩萨未得自在。及有广慧声闻乘等。若诸有学若阿罗汉。彼无色界系善作意。亦缘下地一切法。若诸菩萨已得自在。决定不于无色界生。由观于彼不能现起利众生事因此成熟广大佛法。及能成熟利益有情行故。当知是名堕界作意所缘诸法。复次因思所缘如说

  名映于一切　　无有过名者
  由此名一法　　皆随自在行

此言有何义谓若略说。观察清净因故。观察自相故。观察杂染因故。又为显示补特伽罗无我及法无我故。此中显示补特伽罗无我者。谓善了知四无色蕴。能断一切自境界相。是故说名能映一切。显示法无我者。谓善了知遍计所执自性。善了知世俗言名。能除一切彼所依相。是故说名能映一切。若过如是四无色蕴诸我相事。定不可得。若过世俗言名遍计所执自性相事。亦不可得。若于此二不善了知。则便一切自境界相。及诸杂染生起随转一切境相。及诸杂染皆彼增上力所生故。又佛世尊依此密意说如是言

  执法自性故　　执我性而转
  觉此故觉彼　　由觉故还灭

系属瑜伽作意略有四种所缘。一遍满所缘。二净行所缘。三善巧所缘。四净烦恼今缘。是诸所缘如声闻地广辩应知。此中净烦恼所缘者。谓世尊说四圣谛及真如

瑜伽师地论卷第六十五瑜伽师地论卷第六十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中思所成慧地之二

复次如佛世尊说三苦性。此中云何为行苦性。谓后有业烦恼所生诸行于彼彼自体中。能随顺生一切烦恼及与众苦所有安立。一切遍行粗重所摄。亦名粗重。是行苦性。依此行苦。佛世尊说略五取蕴皆名为苦。又此行苦遍行一切若乐受中若苦受中若不苦不乐受中。然于不苦不乐受中。此粗重性分明显现。是故但说不苦不乐受由行苦故苦。于乐受苦受中。爱恚二法扰乱心故。此粗重苦非易可了。譬如热痈。若以冷触封之即生乐想。热灰堕上便生苦想。若二俱离。于此热痈尔时唯有痈自性苦分明显现。如是于业烦恼所生诸行。所有安立粗重所摄。犹如热痈。行苦性中所有乐受如冷触封。所有苦受如热灰堕。所有不苦不乐受如离二触痈自性苦。又乐受中多生染着。是故说彼贪所随增。于苦受中多生憎恚。是故说彼嗔所随增。于非苦乐之所显现粗重所摄所有安立行自体中。于无常性计常颠倒。于众苦性计乐颠倒。于不净性计净颠倒。于无我性计我颠倒。是故说彼不苦不乐受无明所随增。又诸愚夫于乐受中多生染着。由是因缘于现法中。行身恶行行语恶行行意恶行。身坏命终广说乃至生那落迦。又由后有爱故能感当来生等众苦。如是乐受贪所依故能生当来五趣等苦。又于苦受多起嗔心。不随所欲触众苦事。便生种种愁恼怨叹乃至迷乱。由此因缘行三恶行堕诸恶趣。如是苦受嗔所依故。能感现法后法众苦。又于不苦不乐受中多生如上颠倒之心。于二种苦。谓依乐受贪所生苦。及依苦受嗔所生苦。生不舍思起不舍行。是故虽有众多烦恼及随烦恼。然佛世尊但立三种根本烦恼。谓贪嗔痴。依此密意佛世尊说。应观乐受是众苦法。应观苦受犹如毒箭。应观不苦不乐受性是无常有坏灭法。若能如实观无常性。渐次能断一切颠倒。如是诸行是第一义苦圣谛事。一切圣贤圣智观已。于第一有最极寂静诸取蕴中。尚不愿乐。何况弊下那落迦中

复次即此能生后有诸行业及烦恼。由相道理是集圣谛。世尊经中据胜道理唯显示爱

复次此烦恼品粗重永灭。是有余依涅槃增上所立灭谛。又因永断未来不生。及先世因受用尽已。现在诸行任运谢灭。是无余依涅槃增上所立灭谛。复次若能证解第一义谛所有正见。及正见为先一切圣道。是名道谛

复次欲令于苦遍知于集永断。于灭作证于道修习。故略建立诸圣谛相。若广建立当知其相无量无边。又令了知苦谛粗相以为依止。渐能趣入谛微细相。故先施设生等众苦。后方显示五取蕴苦

复次由五相故建立任持诸法差别。何等为五。一段食。二触食。三意思食。四识食。五命根若粗段食。于欲界五趣中皆现可得。此于一分各别那落迦。非大那落迦。余食及命。遍三界中皆现可得。由于诸行假立有情。是故世尊说此诸法任持有情令住不坏。问有七因缘任持诸行令住不坏。何故世尊但说有情由食而住。何等为七。一生是诸行住因。由诸行生方得有住。无有无生而有住者。二命根。三食。四心自在通。由彼势力增诸寿行。或住一劫或住劫余。五因缘和合。是诸行住因。谓善不善无记诸法。乃至因缘犹未散坏。于尔所时相续而住无有断绝。六由善不善无记作意引发先业。能牵诸行念住不绝。所谓外分共不共业之所生起。七无诸障碍。是诸行住因。由此能令诸行生时无障因缘。诸行生已相似相续而住。远离相违败坏因缘。若不尔者便应灭坏。答虽由如是七种因缘诸行得住。然此四食是诸行住多分因缘。由种种门能令诸行相续而住。又此诸食能令有情相续而住。易取易入。乃至愚夫婴儿等类亦能随觉。非所余法。又此诸食能令羸损诸根大种皆得增益。又令疾病亦得除愈。非所余法。又有长寿诸有情类。若不得食非时中夭。又此诸食令易入道。能修身等四种念住。谓一切有情食所住故。是故由此五种因缘。世尊但说一切有情由食而住。何缘复说依止命根诸行得住。谓有是处曾无饮食有所阙乏。非求饮食有所艰难。于彼处所唯由命根势力而住。如其所感寿量而住。是故世尊依彼处所说诸有情由命根故诸行得住

复次此中段食当言香味触处所摄。何以故。由香味触若正消变便能长养。不正消变乃为损减。色等余法无有长养损减消变。是故说彼非段食性。若诸段物于吞咽时。令心欢喜诸根悦豫。当于尔时不名段食。但名触食。若受用已安隐消变。增长喜乐。于消变时乃名段食。若有熟变不能长养诸根安乐。彼虽熟变不名段食。若诸段物于吞咽时。不生欢喜亦不能令诸根悦豫。当于尔时都不名食。即彼后时安隐熟变增长安乐。彼于尔时乃名段食。若有熟变不长安乐。彼虽熟变亦不名食

问若有段物亦是食耶。设是食者亦段物耶。答如其所应当作四句。或有段物而非是食。谓诸段物不能长养诸根大种。或有是食而非段物。谓若有触意思及识。能令诸根大种长养。或有是食亦是段物。谓诸段物能令诸根大种长养。或非段物亦非是食。谓若有触意思及识。不能长养诸根大种。如是所余触乃至识。随其所应皆作四句

复次若有异熟法。若异熟法。若异熟生法。皆应了知。略说有异熟法。谓漏及有漏。彼要有力不被损害受用未尽。当知是名有异熟法。于诸漏中若不善者说名有力。有覆无记说名无力。于有漏中若善不善说名有力。余名无力。若漏有漏为世出世二离欲道之所断者。名被损害。与此相违名不损害。若过去世其异熟果已成熟者。名受用已尽。彼异熟果已过去故更无所有。若未来世当与异熟果者。若现在世其异熟果正现前者。名受用未尽。由此差别漏及有漏如其所应。若善不善未被治断。其异熟果非先已熟。如是乃名有异熟法。若诸无漏无记有漏。若善不善有漏已断。若异熟果先已成熟。如是皆名无异熟法。又临终时最后念心是异熟法。若结生相续无间之心亦是异熟。从此已后所有一切自性住心皆是异熟。除善染污。及除加行无记之心。所余皆名自性住心。若心离欲犹故随转。除下地善及与加行无记之心。当知此心亦是异熟。又此异熟于一切处。当言唯是无覆无记。若从一切种子异熟。除其已断未得之法。余自种子为因所生。若善不善或复无记。如是一切当知皆名异熟生法

复次一切处最后没心。及随初第二相续心。于三界中当知唯有非苦乐受。除初相续心。应知此受于一切处异熟所摄。余苦乐受应知皆是异熟所生。如其种子异熟所摄。即随此因此缘为因缘故。从异熟生生那落迦诸有情类。异熟无间有异熟生。苦忧相续如生那落迦如是。若生一分饿鬼及傍生中。当知亦尔。若生人中及欲界天诸有情类。无有决定异熟。无间或时苦忧。或时乐喜。或时唯有不苦不乐受眼续生。若生初二静虑异熟。无间唯异熟生喜受相续。若生第三静虑。唯异熟生乐受相续。若生第四静虑已上。唯有异熟不苦不乐受。是故当知即此受于彼名异熟生广大喜乐所摄受故。彼诸善业不苦不乐正现前时。亦名可爱异熟。与此相违当知名不可爱异熟

复次白白异熟业所得无覆无记异熟果。一向可爱受。种子所摄受故。当知一向可爱一向可意。黑黑异熟业当知与此相违。黑白俱异熟业。二种种子所随逐故。所得异熟果当知亦有二种异熟生受。又黑白业由生类差别建立。谓于是处黑白俱有。即此处业总立黑白。又由事差别建立。谓如有一随于一事于一时间起利益心而现在前。即于此事复于一时不利益心而现在前。或夺他物而行惠施。如是当知由事差别之所建立。又由自性建立如是黑白俱业。谓如有一随于一所许作利益。即由余事复于其所作不利益。譬如有一于极暴虐作恶人所。发生嗔恚俱行之思。不喜彼恶。当知此思嗔俱行故。堕黑分中。不喜乐彼恶俱行故。堕白分中。是故此业说名黑白。如是所余种类亦尔。

复次若善不善无记诸法所有种子未被损害。彼一切法皆由能生生起因故。名有因法。又先所作诸业烦恼。于三界中异熟果熟。此异熟果由业烦恼引发因故。名有因法。又由三处正现在前引发因故。生胎生中。当知此亦名有因法。湿和合故生湿生中。卵[穀-禾+卵]藏故生卵[穀-禾+卵]中。当知亦尔。又六识身以从眼色乃至意法。为增上缘同事因故。名有因法。又有俱生诸心心所。互为展转同事因故。名有因法。又不善法由近恶友闻非正法不正思惟。引发因故。名有因法。当知与此相违三种引发因故。一切善法名有因法。又染污住生邪精进。无果劬劳生忧苦住。彼由引发因故名有因法。又不染污住生正精进。有果劬劳生喜乐住。彼由引发因故名有因法。又世间道趣于离欲。及能引发静虑无色。彼由引发因故名有因法。又现法中静虑无色等至为依。如其所应往生上地。彼由引发因故名有因法。又世间法引出世法。彼由引发因故名有因法。又出世法圣道所摄能证涅槃。彼证涅槃由引发因故。名有因法。由如是等所说诸相。当知建立有因诸法

复次此中能生生起因法。彼由各别等流果故。名有果法。若诸后有业及烦恼。彼由各别异熟果故。名有果法。若有三处正现在前。若湿和合正现在前。若卵[穀-禾+卵]藏。若眼色等。若彼俱生诸心心所。若近恶友等。若近善友等。二种三法如是一切。皆由各别增上果故。名有果法。若现法中由染污住生邪精进。无果劬劳生忧苦住。若现法中不染污住生正精进。有果劬劳生喜乐住。如是一切皆由各别士用果故。名有果法。若趣世间离欲生道。彼由离系增上果故。名有果法。又能引出世间之道。及能证涅槃出世圣道。彼由离系增上果故。名有果法。谓由究竟离系果故。名有果法。若世间道非由究竟离系果故。名有果法。当知是名二道差别。由如是等所说相故。当知建立有果诸法差别之相。谓随所应。立等流果。若异熟果。若增上果。若士用果。若离系果。与此相违应知建立非有因法非有果法

复次缘生法者。谓无主宰无作者法。如前意地决择缘起善巧中已广分别

复次略由五因当知建立内法差别。由此因故说名为内。何等为五。谓假名故。妄执故。增上故。摄受种子故。事故。若于是处假想建立如是种类。谓立为我或立有情。彼如是名如是生类。广说乃至如是寿量。如是名为由假名故说名内法。若于是处妄起如是种类执着。谓计为我或起我慢。如是名为由妄执故说名内法。若由此法增上力故。外色声等处差别生为所受用。如是名为由增上故说名内法。若能摄受善不善无记诸法种子。如是名为摄受种子故说名内法。若五种清净色若心意识。如是名为由事故说名内法。又有假名建立余法为内可得。何以故。于内可得外处所摄亦名内故

复次应知五蕴名色所摄。所以者何。由彼彼处增长可得。手块等触即便变坏。是故色蕴说名为色。其余四蕴由种种名施设势力。由种种名施设为依。多分于其彼彼所缘流转趣向。是故如是四无色蕴说之为名

复次略由五相建立执受诸法差别。何等为五。谓初唯色说名执受。当知此言遮心心所等。彼非执受故。又于色中所有内根。根所依属说名执受。当知此言遮外不属根色。彼非执受故。又心心所任持不舍说名执受。当知此言遮依属根发毛爪等。及遮死后所有内身。彼非执受故。又执受色由四因缘之所变异故。名执受。何等为四。一由外色所逼触故。二由内界相违平等所引发故。三由贪嗔等诸烦恼缠多现行故。四由审虑所缘境故。谓由外色能损恼者。现前逼恼有执受色。即便生苦生悲生恼。若有外色能饶益者。现前触对有执受色。即便生乐安隐饶益。若有内界更互相违。便生苦恼。彼若平等安乐摄受。又若贪等烦恼所恼。即便生苦愤发炽然。又邪审虑所缘境故。或正审虑所缘境故。便起轻安喜乐摄受。又为损害或为饶益。故名变异。如是若色若内若心心所任持不舍。若如是缘令成变异。是名执受诸法差别。与此相违当知是名非执受法

复次若四大种及彼所造。当知唯此名有色法。问如四大种由自种子方得生起。造色亦尔。何故说言诸所造色大种所造。答若诸色根及心中有诸大种种子随逐。即有造色种子随逐。若诸大种所有种子能生果时。尔时必定能随逐彼造色种子亦生自果。故说造色大种所造。随逐色根大种种子名有方所。随无色根大种种子名无方所。又诸大种略有二种。一唯界所摄。二能作自业。唯界所摄者。谓诸大种所有种子。能作自业者。谓从自种子所生大种。又诸大种与所造色。俱时而有互不相离。由彼种类因所成故。如一味团更相涉入遍一切处。非如糗稻末尼等聚。又于一向坚色聚中。唯有地界能作业用。若于欲界亦有色香味界作业。于色界中但有色界能作业用。余水火风及与声界。唯有种子之所随逐。更待异缘方能作业。如是于水火风名想聚中。如其所应次第亦尔。内色聚中一切地等诸界作业皆具可得。谓发毛等种种差别。广说如经。当知于外得有各别地等诸聚。彼若值遇如是如是众缘差别。即便能作如是如是果法生因。譬如善巧钻彼干木即便生火。又如白镴铅锡金银等物融消即流。复次如五识身相应地说触处所摄涩滑等性。当知皆是大种差别。随诸大种如是品类分位差别。如其所应于四大种。假名施设涩滑等性。是故当知皆是假有。问如世尊言触谓外处若四大种若四大种所造有色无见有对。何密意耶。答此诸大种当知能生二种造色。一自类差别。二异类差别。自类差别造色者。谓诸大种造涩滑等。由如是因如是缘故。此诸大种各各差别变异而生。于彼假说涩滑性等种种差别。异类差别造色者。谓眼耳等五内色处四。外色处法处一分。唯除触处。世尊依彼自类差别所造色故。说如是言。若四大种所造。问世尊说有无见无对色。当言何等大种所造。答若彼定心思惟欲界有色诸法。影像生起。当言欲界大种所造。若彼定心思惟色界有色诸法。影像生起。当言色界大种所造。于此大种所造色法。余决择文更不复现

复次云何有法。谓一切世间法说名有法。问阿罗汉等世间善法。是世间故则有所摄。以何因缘说名无漏。答堕三有故名有所摄。诸漏随眠永解脱故说名无漏。问如世尊言云何有漏法。谓意世间法世间意识世间。此何密意。答世尊依彼不断应断世间意法及与意识。说如是言。此中世尊说多种有。谓欲有色有无色有。彼广建立如闻所成慧地佛教所应知处。

复次云何有上法。谓除涅槃余一切法。由五因缘当知涅槃是无上法。何等为五。一集谛寂灭故。二苦谛寂灭故。三离怖畏灾横疾疫大安隐故。四无上现法乐住所缘故。谓无相住故。五常住究竟安义乐义不虚诳故。如是五因非于余处总集可得。唯于涅槃一切可得。是故涅槃名无上法

复次云何应修法。谓一切善有为法。此中应知略有四修。一得修。二习修。三除去修。四对治修。此中未生善法为欲生故作意修习。是名得修。已生善法令住不忘乃至广说。是名习修。已生不善法为欲断故作意修习。名除去修。未生不善法为不生故。于厌患等诸对治门作意修习。名对治修。当知此中从了相作意乃至胜解作意。名厌患对治修。从远离作意乃至方便究竟作意。名断对治修。方便究竟果作意。名持对治修。从此已上即此一切七种作意。堕于胜地上地所摄。当知一切名远分对治修。此四种修一切总说为二种修。谓防护受持修。及作意思惟修。此中修身名防护修。修戒名受持修。若静虑地作意修。若谛智地作意修。总名作意思惟修。此中初作意修名为修心。第二作意修名为修慧

复次云何过去法。谓因已受尽。自性已灭。无间为缘为生余法。除阿罗汉最后心心所熏习相续。虽复已灭经百千劫。犹能令彼爱非爱果异熟当熟。如所领受诸过去事。或一唯能生起忆念。或复有一不生忆念。唯灭所显无诸作用。是名过去诸法差别。此过去法略由五相当知建立其事差别。何等为五。谓或有法刹那过去。谓于刹那一切行中。刹那已后所有诸行。又或有法死没过去。谓彼彼有情从彼彼有情众同分没。广说乃至死及作时。又或有法坏劫过去。谓器世间所摄。由火等灾之所败坏。又或有法退失过去。谓如有一于先所得诸善功德安乐住中。随类退失。又或有法尽灭过去。谓有余依及无余依涅槃界中所有尽灭。复次云何未来法。谓因未受自性未受。待缘当生将起现前。或近当生或远当生。亦由五相建立差别。谓刹那未来。一生未来。成劫未来。现行未来。应得未来

复次云何现在法。谓因已受用自性受用未尽。刹那已后决定坏灭一切杂染所显。一分清净所显。亦由五相建立差别。谓刹那现在。一生现在。成劫现在。现行现在。最后现在。谓阿罗汉最后心心所等

复次云何欲界系法。谓于欲界若生。若长未离欲界欲。心不在定。于此位中所有诸法。或生得故或作意故。已行正行当行。是名欲界系法。复次云何色界系法。谓生欲界能现证入。随一静虑已离欲界欲。未离色界欲。未发上加行。或从彼定起。所有世间意地诸法。由作意故已行正行当行。是名色界系法。或生色界未离彼欲。未发上加行。或生得故或作意故。诸世间法已行正行当行。如是亦名色界系法。如色界系法如是。无色界系法随其所应当知亦尔

复次云何善法。谓若略说。二因缘故一切善法说名为善。谓自性无倒。亦能对治颠倒法故。及安隐故。所以者何。一切善法自性无倒于所缘转。又能对治于所缘转颠倒染法。能往善趣证涅槃。故名为安隐。与此相违二因缘故当知不善。谓自性颠倒故及不安隐。无记诸法性非颠倒。亦不能治颠倒诸法。性非安隐非不安隐。又由五相当知建立善法差别。一感当来可爱果故。二对治杂染故。谓不净等能治贪等。乃至八圣支道对治一切杂染诸法。三杂染寂灭所显故。所谓涅槃。四清净住所显故。谓已离欲者住圣等善现法乐住。五饶益有情所显故。谓已离欲。为哀愍他声闻菩萨及与如来所有种种利他善行。又由五相建立不善诸法差别。与上相违应知其相。谓感当来非爱果故。杂染对治之所治故。染不寂灭之所显故。诸染恼住之所显故。能损害他之所显故。由五因缘善法强盛。何等为五。一加行故。二宿习故。三摄受胜功德故。四田事处故。五自性故。谓诸善法无间加行殷重加行之所造作。若无量品差别所作。谓或自作。或于是处劝他令作。以无量门庆慰赞美。见同法者深心欢喜。当知是名由加行故善法强盛。又诸善法曾余生中若修若习若多修习。由是因缘彼今生中。性于善法心能趣入。于诸不善违背而住。当如是名由宿习故善法强盛。又诸善法下地所摄。由世间离欲者及见圣迹者。若于解脱或于无上正等菩提。深心回向离诸见趣。当知是名摄受胜功德故善法强盛。又诸善法于大福田。以胜妙事施尊重处之所生起。当知是名田事处故善法强盛。又诸善法若施所成。于戒于修自性是劣。若戒所成。于施所成自性是胜。于修所成自性是劣。若修所成所有善法。于施于戒自性皆胜。当知是名由自性故善法强盛。与此相违五因缘故。当知是名不善强盛。又由五相建立无记诸法差别。何等为五。一异熟生无记。二威仪路无记。三工巧处无记。四变化无记。五自性无记。此中自性无记谓诸色根。是长养者及外诸有色处等非异熟等所摄者。除善染污色处声处

复次云何学法。谓或预流或一来或不还有学补特伽罗。若出世有为法。若世间善法。是名学法。何以故。依止此法于时时中。精进修学增上戒学增上心学增上慧学故。云何无学法。谓阿罗汉诸漏已尽。若出世有为法。若世间善法。是名无学法。云何非学非无学法谓除先所说学无学法。所余预流乃至阿罗汉法。若堕一切异生相续。若彼增上所有诸法。当知是名非学非无学法

复次云何见道所断法。谓萨迦耶等五见。及依诸见起贪嗔慢。若相应无明。若于诸谛不共无明。于谛疑等。及往一切恶趣业等。是名见道所断法。云何修道所断法。谓一切善有漏法。一切无覆无记法。除先所说诸染污法。余染污法。是名修道所断法。云何非所断法。谓一切有学出世间法。一切无学相续中所有诸法。此中若出世法于一切时自性净故名非所断。余世间法由已断故名非所断

复次云何甚深难见法。谓一切法。当知皆是甚深难见。何以故。第一甚深难见法者。所谓自性绝诸戏论过语言道。诸法自性皆绝戏论过语言道。然由言说为依止故。方乃可取可观可觉。是故当知一切诸法甚深难见。

如是所说差别建立有色无色法。有见无见法。有对无对法。有漏无漏法。有诤无诤法。有染无染法。依耽嗜依出离法。世间出世间法堕非堕法。有为无为法。所知所识所缘法。住持法。有异熟无异熟法。有因无因法。有果无果法。缘生法内法。名色所摄法。执受非执受法。大种所造非大种所造法。有非有法。应修法。有上无上法。去来今法。欲界系色界系无色界系法。善不善无记法。学无学非学非无学法。见道所断修道所断非所断法。甚深难见法。若有善思所应思者。应当如理精勤方便思惟简择如是诸法。

于此地中余决择文。更不复现

瑜伽师地论卷第六十六瑜伽师地论卷第六十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中修所成慧地

如是已说思所成慧地决择。修所成慧地决择我今当说。当知略有十六种修。

谓声闻乘相应作意修。大乘相应作意修。影像修。事边际修。所作成办修。得修。习修。除去修。对治修。少分修。遍行修。动转修。有加行修。已成办修。非修所成法修。修所成法修

云何声闻乘相应作意修。谓如有一是声闻住声闻法性。或未证入正性离生。或已证入正性离生。不观他利益事。唯观自利益事。由安立谛作意门。内观真如。缘有量有分别法为境。为尽贪爱。由厌离欲解脱行相修习作意。是名声闻乘相应作意修

云何大乘相应作意修。谓如有一是菩萨住菩萨法性。或未证入正性离生。或已证入正性离生。观自观他诸利益事。由安立非安立谛作意门。内观真如。缘无量无分别法为境。大悲增上力故。为尽自他所有贪爱。由摄受有情诸利益事方便行相。及由趣向无上足迹因缘。行相修习作意。是名大乘相应作意修

云何影像修。谓或于有分别毗钵舍那品三摩地所行影像。所知事同分作意思惟故。或于无分别奢摩他品三摩地所行影像。所知事同分作意思惟故。诸所有修名影像修

云何事边际修。谓于过去未来现在内外粗细下劣胜妙近远等法作意思惟。或于真如作意思惟。如是或尽所有性故。或如所有性故。诸所有修名事边际修

云何所作成办修。谓已证入根本静虑或诸等至。或世间定或出世定。诸所有修名所作成办修

云何得修。谓如有一依初静虑。或修无常想。乃至或修死想。彼所有余不现前想。或自地摄。或下地摄。及彼所引诸余功德。或是世间或出世间。皆能修彼令其增盛清净当生于彼获得自在成就。是名得修

云何习修。谓如有一即于彼彼无常等诸善想作意思惟。或于善法由习修故皆现修习。是名修习

云何除去修。谓如有一由三摩地所行影像诸相作意故。如楔出楔方便除遣。弃于自性诸相。又如有一用彼细楔遣于粗楔。如是行者。以轻安身除粗重身。余如前说。是名除去修。

云何对治修。谓于厌患对治。或断对治或持对治。或远分对治。作意思惟诸所有修。名对治修。此中厌患对治者。谓一切世间善道。除诸无量及余行者游戏神通所引作意。断对治者。谓缘真如为境作意。持对治者。谓此后得世出世道若解脱道。远分对治者。谓烦恼断已于对治道更多修习。或多修习上地之道。复有差别。谓闻思修道名厌患对治。出世间道名断对治。此果转依名持对治。世间修道名远分对治

云何少分修。谓于无常想等。随一善法。作意思惟诸所有修。名少分修

云何遍行修。谓于诸法一味真如。作意思惟诸所有修。名遍行修

云何动转修。谓于无相修方便修时。时时有相间隔而修。名动转修

云何有伽行修。谓即于彼方便修时。由有加行相间隔而修。名有加行修。

云何成办修。谓或声闻乘。或独觉乘。或复大乘。已得一切所有转依。及得一切诸法自在。此所有修名成办修。

云何非修所成法修。谓不定地诸施戒等所有善法修。名非修所成法修。

云何修所成法修。谓定地诸善法修。名修所成法修。

于此地中余决择文更不复现

    摄决择分中声闻地之一

如是已说修所成慧地决择。声闻地决择我今当说。

如本地分说。住无种性补特伽罗。是名毕竟无般涅槃法。此中或有心生疑惑

云何而有毕竟无般涅槃法耶。应诲彼言。汝何所欲。诸有情类种种界性。无量界性。下劣界性。胜妙界性。为有耶为无耶。若言有者。无有毕竟无般涅槃法补特伽罗。不应道理。若言无者。经言诸有情类有种种界性乃至胜妙界性。不应道理。如是诲已。

复有难言如有情类虽有种种界性乃至胜妙界性。而无有无根有情。如是无般涅槃法何故不尔。或应许有无根有情。应诘彼言。汝何所欲。诸无根者为是有情为非有情。若是有情。外无根物应是有情。然不应道理。若非有情。而言何不许有无根有情者。不应道理。如是诘已。

复有难言如作刹帝利已或时复作婆罗门。吠舍。戍陀罗。如是乃至作戍陀罗已或时乃至作刹帝利。又作那落迦已或时乃至作天。乃至作天已或时乃至复作那落迦。如是何故不作无般涅槃法已或时复作有般涅槃法耶。应诘彼言。汝何所欲。诸刹帝利乃至戍陀罗。及那落迦乃至诸天。为有一切界耶。为独有一界耶。若有一切界者。喻不相似不应道理。若独有一界者。先是刹帝利。或于一时乃至作戍陀罗。先是那落迦。或于一时乃至为天。不应道理。如是诘已。

复有难言如刹帝利等具一切界。如是无般涅槃法何故不有般涅槃法界耶。应诘彼言。汝何所欲。诸无般涅槃法界。诸有般涅槃法界。此二界为互相违耶。为不相违耶。若互相违而言无般涅槃法何故不有般涅槃法界者。不应道理。若不相违即此补特伽罗是无般涅槃法亦是有般涅槃法者。不应道理。如是诘已。

复有难言如现见有一地方所于一时间无金种性。或于一时有金种性。于一时间无有末尼真珠琉璃等种性。或于一时有彼种性。于一时间无盐种性。或于一时有彼种性。于一时间无种种相界种性。或于一时有彼种性。如是先是无般涅槃法种性。何故不于一时成有般涅槃法种性耶。应诘彼言。汝何所欲。如彼地方所先无此种性。后有此种性。或先有此种性。后无此种性。如是先有声闻定种性。后无是种性。乃至先有大乘定种性。后无是种性。或先无定种性。后有定种性耶。若言尔者。顺解脱分善根应空无果。又若尔者。立定种性不应道理。若不尔者。汝言无般涅槃法者。先住无种性已后住有种性。如有地方所。有般涅槃法者。先住有种性已后住无种性。如地方所者。不应道理。又应责彼。汝何所欲。无般涅槃法下劣界者。安住如是下劣界中。为即于此生转成般涅槃法。为于后生耶。若言即于此生者。汝意云何。彼遇佛法僧已。于现法中为能起顺解脱分善根耶。为不能耶。若言能者。彼遇佛法僧已。于现法中能起顺解脱分善根。而言无般涅槃法者。不应道理。若言不能者。彼遇佛法僧已。于现法中不能起顺解脱分善根。而言转成般涅槃法者。不应道理。若言后生方成般涅槃法者。汝意云何。彼为先积集善根故于后生中遇佛法僧。能起顺解脱分善根耶。为先不积集善根耶。若言先积集善根者。彼即于此生中遇佛法僧。能起善根。而言于后生中方成般涅槃法者。不应道理。又如彼因应空无果。若言先不积集善根者。是则前后相似。俱未积集善根。而言于后生中方成般涅槃法非即此生中者。不应道理

复次略有十种声闻。何等为十。谓清净界声闻。已遇缘声闻。杂染界生声闻。清净界生声闻。未法时生声闻。贤善时生声闻。未得眼声闻。已得眼声闻。清净眼声闻。极清净眼声闻。若有安住声闻种性。是初声闻。已入法者。是名第二。若有声闻所生世界。其中多有众苦可得。容有五浊。所谓寿浊乃至有情浊。是名杂染界生声闻。与此相违当知即是清净界生声闻。末法时生诸声闻相云何可知。谓诸声闻于当来世法末时生。多分爱重利养恭敬。违背妙法。诸贪恚痴及不正法并皆增盛。为悭嫉等诸随烦恼缠扰其心。处悭。家悭。利悭。恭悭。誉悭。法悭。无不具足。谄诳矫诈恒现在前。广说乃至为活命故而求出家非为涅槃。多诸掉动。高举轻躁。强口傲诞懈怠失念。心不静定多诸迷乱。根性闇劣多诸烦恼。烦恼现行无有间断。忧苦虽多不生厌患。乐多众会。弃阿练若边际卧具。来入众中习近村侧。所有卧具便生喜乐。如是乃至喜乐谈谑。喜乐諠众。喜乐猥杂。自举纵逸。不能善修身戒心慧。于佛世尊所说甚深与空相应随顺缘性缘起缘生所有经典。并皆弃舍。于世聪慧所造讽诵。绮饰言辞绚藻文章。随顺世典恭敬受持深生欢喜。于似正法非正法中妄生法想。于正法中起非法想。又即于彼爱乐显现宣说开示。诽谤正法及毗奈耶。于说正法及毗奈耶补特伽罗生怨家想。多犯尸罗习诸恶法。内实腐败外现贤善。广说乃至实非梵行自称梵行。无余有余二篇重罪尚起故思现行毁犯。何况中轻。既毁犯已多不如法发露对治。或为他知而行发露。非实意乐。故欲结好诸亲友家及施食家。于诸在家所为所作能引无义多事业中。好善营造。于诸在家白衣者所。多起亲爱尊重恭敬愍念之心。非于同法修梵行所多喜安住诈现相等起邪命法。展转互起谋略之心。好为种种斗讼违诤。多乐蓄积家产资具。假存法式以之为胜。凡所度人出家受戒。一切皆以有染污心为充供事。然作是言。我今但为怜愍因缘。度其出家受具足戒。所畜共住近住弟子。恒常供侍随心转者。彼虽慢缓而深爱念悦意摄受。余不尔者。虽不慢缓。亦不爱念悦意摄受。若见苾刍多诸亲属广招利养衣服等物。则便尊重恭敬供养。若见苾刍阙乏亲属。虽少欲等功德具足。仍生轻蔑而不采录。食用僧祇及别人物。都无悔愧。好摄犯戒。乐结朋党。悔情微劣或复太过。凡所听受皆为声誉赞诵因缘。或复多为利养恭敬。都不自为调伏身心。如是等类诸杂染法皆悉成就。法末时者。所谓大师般涅槃后圣教没时。尔时如是声闻弟子。身坏命终多堕恶趣生那落迦。若有成就与此相违不染污法。当知是名贤善时生声闻。彼于如来初出世时瘜肉未生时大师现前时。或有一类般涅槃后。如是多分身坏命终还得善趣。往生天上乐世界中。若诸异生声闻名未得眼。预流一来及不还等名已得眼。慧解脱阿罗汉名清净眼。若具三明俱分解脱名极清净眼

复次或有声闻。虽如所应勇猛精进。于现法中而不能证胜过人法。或有声闻。于现法中有力能得胜过人法。沙门果证由放逸故而不能证

复次当释月喻经中具戒具德柔和善法诸句差别。谓声闻中略有四种净妙之法。令诸有情若得见者由身语意生无量福。何等为四。谓住具足尸罗。守别解脱律仪。广说如经。是名初法。复为少欲喜足广说乃至诸漏永尽作证赞美。是第二法。复有柔和易可共住。不恼有智同梵行者。令诸苾刍喜乐同处。又具成就四种证净。是第三法。又有不耽利益。不着恭敬。怜愍于他。覆藏己善。发露己恶。虽复实有种种功德而不欲求令他知有。谓欲令他知我成就如是功德。是第四法

复次若有声闻欲往他家。应先断除三随烦恼然后当往。何等为三。一结亲友家随烦恼。二家悭随烦恼。三以有染心而行法施随烦恼。此中声闻由六种相。应断结亲友家随烦恼已乃往他家。谓时时往不应数往。于可爱事若不如理。执取其相暂生贪爱即便羞耻。不以凶暴强口傲诞邪行追求衣服等物。善自守护善覆其身。不以身触所不应触。亦不坐于所不应坐。终不食于所不应食。亦终不饮所不应饮。又不应受所不应受。又以随顺远离心。趣向远离心邻亚远离心。寻思诸善犹如山岳难往趣处。非净信家能令净信。如旧所履清净泉池。诸净信家倍令增长。

又由六相应断家悭随烦恼已乃往他家。谓往他家于有情事不染不着。如有情事。于利养事。于恭敬事。当知亦尔。又于无利不生忧苦。如于无利。于不恭敬当知亦尔。又于自他诸利养中其心平等。于己所得利养恭敬不自赞美。于他所得利养恭敬终不毁呰。

又由六相应断有染心而行法施随烦恼已乃往他家。谓不悕望他于己净信。又于出离法如实了知。又于他所应起三种纯善意乐。何等为三。谓引发乐故除遣苦故。恭敬听受法随法行得胜利故。为生等苦所苦恼者令脱苦故。若已解脱者。即于诸法妙善法性为缘素呾缆毗奈耶摩呾理迦所摄俗正法中。为令受持读诵正法久住。是故宣说。当知初随烦恼断故。无猥杂住以为究竟。第二随烦恼断故。正受用财以为究竟。第三随烦恼断故。正受用法以为究竟

复次当释伐他迦经。若有声闻欲于染净方便善巧。略于三处应遍了知。谓于杂染清净所依中由杂染清净所依故。于杂染中由杂染故。于清净中由清净故。云何杂染清净所依。谓即此身有色粗重。广说如经。此是愚夫无有智慧趣无明者杂染所依。亦是聪明有大智慧趣于明者清净所依。云何杂染。谓诸愚夫为欲造作净不净业。先寻思已后以身语造作所有净不净业。由此因缘于五趣生死中。感爱非爱有恼无恼自体令生。云何清净。谓二种学清净品中最为殊胜第一学者。谓真如智以为依止能有所作。第二学者。谓为烦恼皆得离系。复次即此清净略由五因之所显示。

何等为五。一正说者。二正行者。三正行。四增上心学所治随烦恼断。五增上慧学所治随烦恼断。此中如来是正说者。根熟声闻是正行者。亦名聪慧者。谛智所摄名为正行。据能断烦恼义。是无上对治故。略有五法名增上心学所治随烦恼。一居远离者所有诸盖。二于教授教诫不堪忍者所有忿恼。三于利养恭敬深贪著者所有悭嫉。四于先所用所受境界发起邪念。五顺舍所学分别贪爱。略有三法名增上慧所治随烦恼。初于世俗理门不了法义者所有无明。次已了法义诸异生者于诸谛中所有犹豫疑惑未断。后已见谛迹诸有学者修道所摄慧所对治所有我慢。由于如是诸随烦恼永断灭故。当知证得最善清净增上心学增上慧学阿罗汉果。此阿罗汉当知是名最极清净。

复次于此杂染清净所依诸声闻众。略由三相应遍了知。一由自性故。二由因缘故。三由过患故。由自性者。谓此人身所有自性由三种相之所显示。由有色故显余一切身之共相。由粗重故显其各别身之自相。由不清净故显与天身不同分相。

由因缘者略有三种。谓一切身共相因缘即四大种。各别自相人身。因缘复有二种。一者未生令生因缘。所谓父母不净和合。二者已生令住因缘。谓糜饭等之所长养。

由过患者复有二种。谓无常性及与苦性。若于寒时为治寒苦。追求覆障以为对治。若于热时为治热苦。追求沐浴以为对治。涉路作业有劬劳者。为治劳苦求按摩等以为对治。当知此类名为苦性。手块杖等之所触对破坏法故。刀所触对断坏法故。若终没已埋于地故。或火烧故。或为种种傍生诸虫所食啖故。或即于彼为诸风日所暴燥故。皆是散坏磨灭法性。当知此类是无常性。昔会今乖名为离散。散已变坏最后都尽名为磨灭

复次因思所缘。如说名映于一切无有过名者由此名一法皆随自在行。此言有何义。谓若略说。观清净因故。观自相故。观杂染因故。及为显示补特伽罗无我及法无我故。若遍了知补特伽罗无我四无色蕴。能断一切自境界相。名映一切。若遍了知法无我遍计所执自性世俗言名。能除一切彼所依相。名映一切。若过四无色蕴诸我相事定不可得。若过世俗言名遍计所执自性相事亦不可得。若于二种俱不了知。则便发起一切境相杂染随转一切境相所有杂染。无不因此增上力故。依此密意薄伽梵说

  执法自性故　　执我性而转
  觉此故觉彼　　由觉故还灭

复次有四圣谛。世尊为诸声闻说是净烦恼所缘境界。谓苦谛等。如前已说。问若真实无颠倒相是谛相者。诸外道见诸邪胜解诸邪论等。非真非实并是颠倒。云何谛摄。若不摄者。彼应不感当来后有。应非苦因。答虽非真实亦是颠倒。然说苦集二谛所摄。所以者何。彼虽皆是邪性所摄。然即此邪性相。是真是实皆不颠倒。是苦性故是苦因故

复次由二相故显无常义。一依大乘道理相。二依声闻乘道理相。谓非有义及其相灭坏义。由二种相显示苦义。谓非有执习气粗重义。及三受所随生等八种苦相转义。由二种相显示空义。谓补特伽罗自性远离相义。及诸法自性远离相义。由二种相显无我义。谓大乘道理及声闻乘道理补特伽罗自性无我相义。诸法自性无我相义

复有二教。谓无常教。无始教。又有二种通达。谓有为界通达。无为界通达。复次由五因缘。若无常即苦。一由摄受。谓无常诸行皆为粗重所摄受故。二由法性。谓是生等苦法性故。三由随逐。谓彼三苦常随逐故。四由因。谓是增长行因故。五由执着。谓是颠倒所缘事故

复次由五因缘。若苦即无我。一离苦诸行我不可得故。二彼苦诸行依众缘故。三无作用故。四有刹那生常随转故。五展转相依故。问若苦谛摄。皆不可爱不可乐是苦。是损恼是违害耶。设不可爱不可乐是苦。是损恼是违害皆苦谛摄耶。答若不可爱不可乐是苦。是损恼是违害。当知皆是苦谛所摄。或有是苦谛摄非不可爱。乃至广说。谓除苦苦所摄诸行。所余坏苦。行苦所摄诸行。问如佛世尊以八种相分别苦谛。所谓生苦老苦。广说乃至总略五取蕴苦。此中几相显苦苦性。几相显坏苦性。几相显行苦性。答前五显苦苦性。中二显坏苦性。爱别离苦。已得所爱变坏故。求不得苦。未得所爱变坏故。后一总略五取蕴苦。显行苦性

问若无常是苦耶。设苦是无常耶。答诸苦皆无常。有无常非苦。谓道谛。所以者何。道非苦受等所摄故非苦苦道非变坏何有变时当生坏苦。道能解脱一切杂染品粗重故。能违一切生相续故。是故亦非行苦所摄

问若无常苦皆空无我耶。设空无我皆无常苦耶。答诸无常苦皆空无我。有空无我非无常苦。谓于此中苦集谛具四种。道谛有三。灭谛有二。非无常非苦

问若无常苦者皆无常故是苦耶。答或无常故或自性故。谓所有行坏苦故苦。彼无常故是苦。若苦苦故苦。行苦故苦。彼自性故。是苦损恼性故。苦所揉故

问若是苦谛亦集谛耶。设是集谛亦苦谛耶。答诸是集谛者皆是苦谛。或是苦谛而非集谛。谓一切阿罗汉清净相续中所有若善若无记。一切世间法一切异生身中所有果异熟摄无记诸法。一切现在士用所生若苦若乐。若不苦不乐俱行无记诸行。当知唯是苦谛所摄

问若厌患后有。能背后有。引出世道世间诸法。彼何因缘集谛所摄。答虽彼自性厌背后有。然能随顺后有身语意妙行。是故亦是集谛所摄

问若一切后有业烦恼由相故皆是集谛摄。何缘世尊唯施设爱。答此爱能起取故。能发业故。遍诸事故。此爱生时普能发起十五种无义利故。遍诸事者。谓如此爱名顺后有爱。若喜贪俱行爱若彼彼喜乐爱名遍诸事。当知亦尔。顺后有爱复有二种。一缘后有境。二是后有因。喜贪俱行爱者。谓于已得可意境界。或于正受用中所有不相离久住爱。彼彼喜乐爱者。谓于未得所求境界。或为和合。或为不离。或为增益诸所有爱。问若是爱者。亦是顺后有喜贪俱行彼彼喜乐耶。答应作四句。或有是爱非顺后有非喜贪俱行非彼彼喜乐。谓于上解脱悕求欲证。或有顺后有喜贪俱行彼彼喜乐而非是爱。谓与顺后有喜贪俱行彼彼喜乐爱。及余烦恼相应所有受想思无明等。即此三爱是第三句。除上尔所相是第四句

问若顺后有爱是喜贪俱行爱耶。设喜贪俱行爱亦顺后有爱耶。答诸喜贪俱行爱。亦是顺后有爱。或有顺后有爱非喜贪俱行爱。谓染污忧俱行爱。或别离爱或不和合爱。问若顺后有爱亦是彼彼喜乐爱耶。设彼彼喜乐爱亦顺后有爱耶。答若彼彼喜乐爱亦是顺后有爱。或有顺后有爱非彼彼喜乐爱。谓缘后有境爱。及喜贪俱行爱

问若喜贪俱行爱是彼彼喜乐爱耶。设彼彼喜乐爱亦喜贪俱行爱耶。答应作四句。谓于已得可爱境界或于正受用中所有爱是初句。即于可爱未来当得未决定中所有爱是第二句。即于此当得决定中所有爱是第三句。除上尔所相。是第四句

问若成就欲界系受亦成就色界系受耶。设成就色界系受亦成就欲界系受耶。答应作四句。或成就欲界系非色界系。谓生欲界未得色界彼对治。或成就色界系非欲界系。谓生色界。或成就欲界系亦色界系。谓生欲界已得色界彼对治。或俱不成就。谓生无色界。又生欲界色界无色界中。所作已办。住出世道及灭尽定。如欲界系望色界系作四句。如是欲界系望无色界系。欲界系望不系。色界系望无色界系。色界系望不系。无色界系望不系。如其所应皆作四句

问诸妙欲亦是过患过失相应欲耶。设是过患过失相应欲是妙欲耶。答应作四句。或有妙欲非过患过失相应欲。谓若色声香味触能不染污现行。若于彼不作功力。无罪安乐住。能摄受梵行。或有过患过失相应欲非妙欲。谓若色声香味触一向不可爱不可乐不可欣不能悦意。及烦恼欲。或有妙欲亦是过患过失相应欲。谓若色声香味触不能不染污现行。一向可爱乃至悦意。或有非妙欲亦非过忠过失相应欲。谓一切色无色界系烦恼及事。世尊依此妙欲及过患过失相应欲故。说如是言。妄分别贪是士夫欲

复次此爱略有二种。初是有爱。后是受用爱。此复二种。谓于已得未得所受用处差别故。又即此爱界差别故。复有三种。谓欲爱色爱无色爱。若生欲界悕求欲界后有者。喜于已得所受用事。欣于未得所受用事。诸所有爱是名欲爱。若生欲界。或生色界。已离欲界。欲悕求色界后有者。喜于已得色界等至。欣于未得胜上等至。诸所有爱。是名色爱。如色爱如是。无色爱随其所应当知亦尔。即此后有爱。常见断见为依止故。建立有爱及无有爱。是故此爱名遍诸事

云何此爱生时普能发起十五无义。一令随眠坚固。二由缠故染恼一切心心所法。三令心相续于所缘境颠倒而转。四发起取所摄所余烦恼。五能安立自类相续。六能随顺生起未生恶不善法。七能随顺已生恶不善法令其增广。八能障碍未生善法令不得生。九能障碍已生善法令不得住不忘倍增长益广大。十令行恶行故结集一切诸恶趣苦。十一悕求后有故结集生老病死等苦。十二能令有情怖畏涅槃。十三能令有情爱乐生死邪执所有功德胜利。十四如于生死于境界亦尔。十五能令有情思为自害思为害他。广说如经。乃至受爱所生心诸忧苦

瑜伽师地论卷第六十七瑜伽师地论卷第六十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中声闻地之二

问诸行寂灭是灭谛耶。设是灭谛诸行寂灭耶。答若是灭谛亦诸行寂灭。或诸行寂灭然非灭谛。谓由无常灭故非择灭故。诸行寂灭

问何等法灭故名灭谛耶。答略有二种。一烦恼灭故。二依灭故。烦恼灭故得有余依灭谛。依灭故得无余依灭谛。问若此灭谛先无后有。云何是常。若常时有。何不一切有情于一切时般涅槃耶。答不流转相不现行相。是灭谛相。此谛云何先无后有。又无生相无灭相。是常相。灭谛亦尔。是故名常。若有证得一切粗重永息灭者。彼般涅槃。若未证得者。彼不般涅槃。有灭谛故。诸有情类有证得者。是故涅槃是证所显。非生所显。复次若有远离四种过失说灭谛者。是名正说。何等名为四种过失。一增益过失。二自相邪分别过失。三相杂乱过失。四损减过失。若言诸行尽灭有异者。是增益过失。言无异者是自相邪分别过失。言亦有异亦无异者。是相杂乱过失。言非有异非无异者。是损减过失。问若唯一切出世间五非取蕴皆道谛摄。何因缘故唯说正见为先八圣支道而为道谛。答依三学故作如是说由有学者于时时间依增上戒学而起修学于时时间依增上心学而起修学。于时时间依增上慧学而起修学。又此八圣支道三蕴所摄。是故唯此说名道谛

问何因缘故正语正业正命说为戒蕴。答二因缘故。一依正受用法故。二依正受用财故。谓正语正业戒为根本戒为所依。方能受用一切正法。是故说名依受用法。由正命故不依矫诈等起邪命法求衣服等。此为根本此为依处。正受用财。是故说名依受用财。又于是处世尊说为增上清净意现行性。此中依止贪等起犯戒思。依止矫诈等。起邪追求衣服等思。若离此事应知是名增上清净意现行性。问何因缘故正见正思惟正精进说为慧蕴。答由此慧蕴略有三种作业因此三法方得究竟。谓通达诸法真义。是初业。通达诸法真义已。即于真义为他宣说施设建立分别开示令其易了。是第二业。为断余结法随法行。是第三业。如是三业由正见正思惟正精进故。如其次第而得究竟

问何因缘故正念正定说为定蕴。答二因缘故。一由自性故。二由所依故。由自性者。谓三摩地。由所依者。四因缘故。念于此定能作所依。一系所缘故。谓于四念住系摄其心。二随顺定故。谓由此念。于守护根门正知而住顺欢喜处随念作意中。能随顺定。三能断盖故。谓于各别不净观等诸盖对治作意中。能断诸盖。四极多修习相作意故。谓远离者于止举舍相无间殷重加行中能多修习。是故此念为定所依

复次正见差别略有十一。谓如病见。如痈见。乃至无我见。结见。离系见。能离结见。于四种行如其次第有四种见。谓于诸烦恼缠俱行行中。于烦恼随眠俱行行中。于爱味俱行行中。于过患俱行行中。次第观为如病如痈如箭如障。若于诸行观为生灭。名无常见。观为三苦之所随逐。名为苦见。观彼远离余我我所。名为空见。观彼诸行体性非我及我所相。名无我见。如是八种。是缘苦谛正见。若于集谛观为因集生缘。名为结见。由彼集谛于苦谛中起杂染结故。若于灭谛观灭静妙离。名离系见。由彼灭谛一切烦恼及依离系所显故。若于道谛观道如行出。名能离结见。由彼道谛究竟能离结缚所显故

问若先起无常苦空无我见。后方起如病如痈如箭如障见。何缘此中先说如病等见。答此中依已得道补特伽罗说彼为先。何以故。已得圣道诸有学者。由增上意乐。于诸取蕴。观为如病乃至如障。如是观已为断余结。复起上位清净无常见乃至无我见。当知此中略有二种无常等见。一是如病等见。所依不清净见。以此为先此为引导。为欲获得所未得故。二是如病等见。能依清净见。已得如病等见。复令增长。及为得心善解脱故。如是十一正见中空行无我行见名为空行。余行见名无愿行。一行见名无相行。谓于灭谛离系行见

复次于修道中。一切出世间道缘四谛为境。当知皆能对治三界一切烦恼。何以故。由诸有学已见迹者。先由法智类智于现不现一切行中起现观。已后于修道摄一切行。总为一团一分一聚。以无常等行次第观察。而不分别此是欲行。此是色行。此无色行。此是现见。此非现见。是故当知。于修道中诸出世道所摄圣道。能总对治下地上地一切烦恼

复次彼诸圣者。于修道中由出世道而升进时。多分以无相行数数作意思惟无相。何以故。由此作意。最能引发现法乐住。断烦恼故

复次五神通无诤愿智无碍解等。及诸如来力无畏等所有一切不共佛法。皆是道后所得其性清净道所建立。由此因缘皆道谛摄。问一切四谛皆应遍知。何缘但说苦谛是应遍知。答由于苦谛以二种相应遍知故。所谓自相及与共相。于所余谛但知自相。谓以因等行知集谛自相。以灭等行知灭谛自相。以道等行知道谛自相。是故唯说苦谛是应遍知

问苦谛亦应永断。何缘唯说集谛是应永断。答由集谛永断能显苦谛永断。是故唯说集谛是应永断

复次于诸谛中略有二种现观。一智现观。二断现观。智现观者。谓随次第于诸谛中别相智生。断现观者。谓随次第无倒智生为依止故。证得所有烦恼断灭

复次略有五种发起正精进因缘。一宣说正法。二修行共住。三察懈怠过失见精进功德。四由思择力相续成熟。五知所证得前后差别

复次略有二种于断作证。一于种子伏断作证。二于种子永断作证。当知离系亦有二种。一于诸烦恼品别离系。二于烦恼事相属离系

问如世尊言。汝等苾刍勿行谄诳。此中如来观见谄曲几种过患。诫诸苾刍不令行谄。答观谄曲者有十二过患故。一谄曲因缘不能证得真实智慧。二退失名誉。三退失他信。四退失功德增长。五退失于智者边听闻正法教诫教授。六诸恶增长。七令心相续远离诸善。八由谄不平损害其心常怀苦恼不安隐住。九虑后苦法。十非圣法器。十一临终追悔。十二身坏已后堕诸恶趣生那落迦

复次欲界中谄有八种行及七种事。云何八行。一迷惑谄行。二覆藏谄行。三显示谄行。四结构谄行。五恭顺谄行。六谋计谄行。七推注谄行。八现悲谄行。云何七事。一言说事。二诘问事。三违诤事。四现亲友事。五现委信事。六所作假托事。七艰辛事。由初事故其谄曲者。与诸世间随起言说。于非义中示现为义。以相迷惑。或于义中示现非义。如于义非义。于有非有当知亦尔。又于现行谄曲所起诸恶行中。若他诘问谄者。则便覆藏实罪显不实德。又诤论者将欲推其功德过失。尔时谄者则便结构诸恶朋党。又谄曲者见诤论人有力暴恶。心生怖惧。即以卑下身语二业。随顺恭敬现亲友相。又谄曲者若见[一/(哭-、)]直可规其利。内与不可委信者等。而外现已极可委信谓行住中虚诈积集清善之相。又谄曲者于诸亲善得意友朋未来广大所作事中。先诈为伴。后所作事现在前时。矫现种种方便推注。谓为遮防自劬劳故。又谄曲者随遭一种苦恼事已。于彼怨对所遭苦事。实无如是重忧重苦。然自显示有重忧苦。谓深叹恨愁忧苦恼乃至闷绝

复次粗语声闻。尚不应得于诸谛中教诫教授。况当能得真谛现观或复清净。又有九种粗语声闻粗语之相。若有成就如是相者。当知此名不可与语粗语声闻。何等为九。谓能举罪补特伽罗正诘问时。以不美言假合而答。或不相应或不圆满。或托余事方便而答。是名初相。又以谬言假设余论。方便推遣所诘问事。是第二相。又嗔恚缠扰乱。懵愦浑浊自心。是第三相。又嗔恚缠发起愤怨詈言鄙语。是第四相。又起高心。彼既说我。我当何故而不说彼。是第五相。又坚覆藏自所作罪。是第六相。又结怨心相续不舍。是第七相。又多发起报怨之心。是第八相。又他显说能举罪者若实不实诸功德时。不生信解非拨毁骂。是第九相。此中略有二种举罪补特伽罗。一共所尊重。二非共尊重。当知此中初二种相。依初能举补特伽罗。余七种相。依第二能举补特伽罗

复次本地分中依戒律仪诸毗奈耶相应之相。今当决择。嗢拖南曰

  摄制立尸罗　　无逸障学观
  依摄受受用　　甚深说喻事

略有七处。摄毗奈耶及别解脱。何等为七。一教敕。二开听。三制止。四犯处。五有犯。六无犯。七出罪

云何教敕。谓佛世尊毗奈耶中敕诸苾刍。舍不善法增长善法。当知是名略说一切教敕之相。若广分别无量无边

云何开听。谓佛世尊毗奈耶中开许一切能无染污现所受用资生因缘。云何制止。谓佛世尊毗奈耶中制止一切自性罪法违无罪法

云何犯处。略有十八。一不善。二违善。三身业。四语业。五意业。六戒坏。七见坏。八轨则坏。九正命坏。十随护他心。十一护他损恼。十二护非处疑虑。十三淫。十四钵。十五衣。十六食。十七卧具。十八病缘医药及余资具。不善者。谓所有性罪。违善者。谓所有遮罪。身语意业处。随其所应于一切五犯聚中当知其相。如是所余犯处。亦于五犯聚中如其所应当知其相。云何有犯。谓若略说有五犯聚。何故于此五犯聚中起诸违犯。谓五因故。一因缘故。二发起故。三事故。四方便故。五究竟故。此分别义。于摄事分毗奈耶摩呾理迦中我当广说

复有九种犯。一近事男犯。二近事女犯。三勤策男犯。四勤策女犯。五正学犯。六苾刍尼犯。七苾刍犯。八异生犯。九有学犯无有无学犯。何以故。由彼更无所应作故。法尔获得小及随小一切学处悉皆止息。又定不能犯染污罪。云何无犯。略有四种。一初业。二颠狂。三心乱。四苦受所逼

云何出罪。略由五相。一由自故。二由他故。三由自他故。四依转故。五依舍故。由自故者。谓应自静息故。由他故者。谓见谛者有所违犯不染污罪。由自他者。谓诸异生染不染罪。依转故者。谓转舍苾刍依转得苾刍尼依。或转舍苾刍尼依转得苾刍依。尔时苾刍苾刍尼各所犯罪。或转余形或转无形。依舍故者。谓命终已。

复次略有十种制立学处清净。一道理清净。二果清净。三摄受清净。四外清净。五内清净。六具分清净。七爱敬清净。八伏对治修清净。九随眠断对治修清净。十相续不断清净。复有差别。谓有因缘制立学处清净。远离受用欲乐边清净。远离受用自苦边清净。胜行清净。胜命清净。同法共住清净。无违诤清净。制伏烦恼清净。烦恼离系清净。任持正法清净

复次略有十种尸罗过失。一毁坏所学过失。二不喜乐过失。三伴相违过失。四期愿过失。五放逸过失。六增上慢过失。七随眠不清净过失。八意乐不清净过失。九不出离过失。十邪禁过失

复有十种尸罗功德。一和合尸罗。二无间尸罗。三无怨对尸罗。四无损害尸罗。五坚固尸罗。六出离尸罗。七胜所治尸罗。八不退转尸罗。九不共尸罗。十无上尸罗

复次于毗奈耶勤学苾刍。依于十时应不放逸。何等为十。一依犯时。二依定时。三依生时。四依乞食时。五依所作时。六依受用利养恭敬时。七依求多闻时。八依思正法时。九依远离时。十依通达究竟时

云何于毗奈耶勤学苾刍依犯初时应不放逸。谓有苾刍成就五支所摄不放逸即前际俱行等。如前广说。如是名为于毗奈耶勤学苾刍于初时中修不放逸

云何于毗奈耶勤学苾刍依定第二时应不放逸。谓有苾刍。或住空闲或居树下。生贪欲盖乃至疑盖。终不安忍。则便弃舍除遣变吐彼。由五盖能染污心乃至能令不得涅槃。为欲断故于时时间应修止相。于时时间应修举相。于时时间应修舍相。彼于如是止举舍相得善巧已。由下劣心虑恐下劣便正修举。由掉举心虑恐掉举便修内止。心得平等便修上舍。又于已得三摩地中。不生爱味不起顾恋。无有贪染无著而住。如是名为于毗奈耶勤学苾刍第二时中修不放逸。云何于毗奈耶勤学苾刍依生第三时中应不放逸。谓有苾刍。临命终时其心猛利。发起如是正加行心。谓我今者应以缘佛缘法缘僧正命而死。应以缘善善心而死。彼遂发起如是如是善守护心。正念现前。以缘于佛法僧正念及缘诸善善心而死。彼由缘佛缘法缘僧所有正念。及由缘善所有善心而命终故。名贤善死贤善夭没。亦名贤善趣。于后世。如是名为于毗奈耶勤学苾刍第三时中修不放逸

云何于毗奈耶勤学苾刍依于乞食第四时中应不放逸。谓有苾刍依于村邑聚落而住。彼即于此村邑聚落。广说如乞食清净经。如是名为于毗奈耶勤学苾刍第四时中修不放逸。云何于毗奈耶勤学苾刍依于所作第五时中应不放逸。谓有苾刍于钵作业。于衣作业。于诸智者同梵行所看侍作业。或复于余所有作业皆无纵逸。无纵逸故不燋不烂。不失不坏。亦不零落不过。所作不鄙所作不恶。所作不急所作不缓。所作不掉所作不染。所作随顺世间。顺毗奈耶所有轨则。如是名为于毗奈耶勤学苾刍第五时中修不放逸

云何于毗奈耶勤学苾刍依受用利养恭敬第六时中应不放逸。谓有苾刍。随所获得利养恭敬。于所获得不染不着。不耽不湎。不闷不执。亦不保玩而受用之。深见过患。善知出离而受用之。随其所得利养恭敬能自制伏。不因所得利养恭敬心住憍傲。如是名为于毗奈耶勤学苾刍第六时中修不放逸

云何于毗奈耶勤学苾刍依求多闻第七时中应不放逸。谓有苾刍。弃舍世间所有讽诵绮饰词论。绚藻文章。随顺世间相应多闻。于佛所说所有甚深。相似甚深空性相应缘性缘起。若顺若逆一切经典。恭敬受持。令得究竟。非观诸法存有所得所获胜利。名得究竟。非观诸法免脱论难所获胜利。名得究竟。非为利养非为恭敬。乃至但为自得调伏。自得寂静。自得涅槃。自得沙门若婆罗门最上义利故。于此法善听善受读诵通利纯熟究竟。如是名为于毗奈耶勤学苾刍第七时中修不放逸

云何于毗奈耶勤学苾刍依思正法第八时中应不放逸。谓有苾刍。独处空闲。如其所闻如其所受如其所得。所有诸法思惟其义称量观察。思所应思离不应思。于其少分但生信解。于其少分以慧观察。凡所思惟但依于义不依于文。如实了知黑说大说。坚固思惟审谛思惟。相续思惟。随所思惟要当究竟。于其中间终无退屈。如是名为于毗奈耶勤学苾刍第八时中修不放逸

云何于毗奈耶勤学苾刍依于远离第九时中应不放逸。谓有苾刍。不与在家及出家众共相杂住。不同其喜不同其忧。广说乃至于所生起世事业中。终不许其究竟随转。处空闲林边际卧具。远离一切有情方邑散乱懈怠及障止观诸随烦恼。如是名为于毗奈耶勤学苾刍第九时中修不放逸

云何于毗奈耶勤学苾刍依通达究竟第十时中应不放逸。谓有苾刍。于有如实知有。于非有。如实知非有。于有上如实知有上。于无上如实知无上。由彼于有非有有上无上如实知故。于所未得不生得想。于所未证不生证想。离增上慢。非增上慢。所摄持故自记所解。如是名为于毗奈耶勤学苾刍第十时中修不放逸

复次有四种障能障出家。谓意乐障。所依障。业障。不自在障。意乐障者。谓或为王威所逼迫而求出家。如是等。所依障者。谓或盲聋或扇择迦或半择迦。或为疥癞秃挛躄等种种恶疾逼切其身。如是等。业障者。谓害母等诸重恶业。不自在障者。谓父母等所不听许。若诸僮仆若王大臣他所劫掠。若兰所得。若有辩答。如是等。

复次略有五处。诸出家者于毗奈耶决定应学。何等为五。谓应学知有犯无犯若重若轻及略所说别解脱经。有犯无犯如前已说。由六种差别所犯成重。一制立差别。谓于学处而制立故。二事差别。谓虽同是波逸底迦。然杀生等所有性罪于余遮罪有差别故。三穿穴差别。谓如有一数数犯故。四烦恼差别。谓如有一用其猛利贪嗔痴缠而毁犯故。五智差别。谓如有一善品微少智慧狭劣。虽等建立等事等穿等烦恼起。然其所犯成极重障。非此相违有所犯者。如小水流少草能偃。于彼细草不能漂没。如大水流聚积草木亦不能偃。此中道理当知亦尔。六时差别。谓如有一于其所犯不能速疾如法悔除。长时习已然后对治。与此相违应知所犯名为轻罪。

复次诸持律者。应以五相观察所犯然后断罪。何等为五。谓一向杂染故。一向不行故。制立依处故。现彼过失生不生故。非一向现行故。此中一向杂染所犯。谓诸性罪应当一向教令不犯。若毁犯者如其所应当为显示令速悔除。又佛世尊依此补特伽罗此方此时。制立如是遮罪学处。若有所余补特伽罗。余方余时犯此过失。由观此失而制立故。如其所犯应为显示对治之法。若有不犯如是过失。不应于此断其有犯。亦不应显对治之法。如是名为总略宣说观察所犯。

复次于毗奈耶勤学苾刍。依止七处于六处中应修加行。云何依止七处于六处中应修加行。谓依止大师。依止亲教。依止轨范。依止衣服。依止乞食。依止卧具。依止病缘医药什物。于法于学教授教诫等持供养不放逸中。应修加行。此中法者。谓别解脱经及广分别。学者。谓增上戒学增上心学增上慧学。教授教诫者。谓依增上戒学教授教诫。依增上心学教授教诫。依增上慧学教授教诫。等持者。谓九次第定。供养者。谓财供养及法供养。财供养者。谓由一种可爱乐法。法供养者。谓由所余。不放逸者。谓于五种善巧相续无间勤修加行。谓蕴善巧乃至处非处善巧

复次毗奈耶中有五种摄受。一属己受。二承受受。三委寄受。四舍施受。五为他受。由二因缘令属己受不得清净。一生染着故。二拟蓄积故。与此相违乃得清净。由二因缘令承受受不得清净。一非处受故。二非量非法受故。与此相违乃得清净。由二因缘令委寄受不得清净。一不观察人而委寄故。二于不净物心系着故。与此相违乃得清净。由二因缘令舍施受不得清净。一于鄙恶田而舍施故。二非无悕望而舍施故。除三种田当知所余名鄙恶田。谓功德田。悲田。恩田。与此相违乃得清净。由二因缘令为他受不得清净。一非宿交。又不告白。及性不识故。二有染心故。与此相违乃得清净

复次毗奈耶中由五因缘所受用事不得清净。一性有罪故。二不端严故。三不任用故。四非摄属故。五不作净故。性有罪者。谓依伪斗伪秤伪函系缚挝打若斫若杀及摣撮等所获财物而受用之。名不清净。不端严者。谓受田宅及诸贿货象马牛羊鸡猪狗犬大男大女小男小女奴婢作使金银珍宝及生谷等。而受用之。名不清净。不任用者。谓大小便利洟唾所污脓血肪膏。此等涂染。复有所余如是等类。若受用者名不清净。如世尊言。便利等器皆不清净。不应受用。非摄属者。谓或僧祇物。若不被差。不堕钵中。亦不属钵。或别人物不与不舍亦不捐弃非处委信。亦复非量而受用之。名不清净。不作净者。谓五种净。何等为五。一受得净。二损坏净。三委寄净。四时法净。五舍分别净。与此相违所有受用名为清净

瑜伽师地论卷第六十八瑜伽师地论卷第六十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中声闻地之三

复次应知毗奈耶由五种制立为最甚深。云何名为五种制立。一学制立。二犯制立。三出离制立。四止息制立。五羯磨制立

复次略由五处应知学制立为最甚深。一自在故。二不自在故。三显现尸罗坏过失故。四显现喜乐鄙业过失故。五彼二过失行不行故。言自在者。若时所化不随烦恼势力而行。非诸烦恼令不自在。尔时即依如是所化自在学行。随意自在。不自在者。若时所化随诸烦恼自在而行。由诸烦恼令不自在。尔时即依如是所化不自在学行。制立不自在学处。显现尸罗坏过失者。观诸性罪定不应行。制立随护尸罗学处。显现喜乐鄙业过失者。谓观能障勤修善品。是故制立遮罪学处。彼二过失行不行者。谓佛观彼自在所化过失不行故无制立。观不自在过失现行制立学处

复次略由五处应知犯制立为最甚深。云何为犯。谓能障碍所有善法令不得生当知此障略有五种。一慢缓障。二有罪障。三轻慢障。四恶作障。五所知障。慢缓障者。谓懈怠故于诸善法不勤方便。有罪障者。谓如有一或由贪缠或由嗔缠。或由痴缠。或由所余随一心法诸随烦恼之所染污。彼既生起如是烦恼随烦恼缠。坚着不舍。轻慢障者。谓如有一不尊所学。于诸学中不甚恭敬。于其所犯不见怖畏而有所犯。犯已不能速疾发露。于大师所及诸学中性不尊敬。恶作障者。谓如有一相续染污恶作所触。于此恶作不能善巧究竟除遣。有怅有快有诸恶作。所知障者。谓如有一心怀变悔。依因净戒不生欢喜。不欢喜故不生适悦。如是乃至心不得定心。不定故无如实知。无如实观。由此因缘名所知障。由慢缓障之所触故。于诸烦恼及随烦恼。为性执着。性执着故复为有罪障之所触。为有罪障之所触故。于诸学中不深恭敬。喜乐所犯。喜乐犯故便为轻慢障之所触。为轻慢障之所触故。生染污悔不能除遣。所生悔故便为恶作障之所触。为恶作障之所触故变悔转增。由此因缘广说乃至心不得定。心不定故便为所知障之所触。如是名为障生次第。与此相违当知即是五种无障。谓无慢缓障。无有罪障。无轻慢障。无恶作障。无所知障

复次意乐毁坏者。于其所犯尚不能出。况能无犯。云何名为意乐毁坏。谓略有五种。一于精进无发起欲。二于烦恼有染着欲。三于所犯有起犯欲。四于恶作无除遣欲。五于等持无引发欲。复次意乐具足者。尚无有犯。况出所犯。云何名为意乐具足。当知此亦略有五种。一于精进有发起欲。二于烦恼无染着欲。三于所犯起无犯欲。四于恶作有除遣欲。五于等持有引发欲。如世尊言。于所犯罪由意乐故我说能出非治罚故

复次应由十处思求所犯。谓由别解脱法故。由广分别毗奈耶故。五犯聚中由犯自相故。由六种差别成重相故。谓制立差别。事差别。烦恼差别。穿穴差别。补特伽罗差别。时差别。由无羞耻者除波罗阇已迦所余有残相故。由初业者非初业者现所行故。由逼恼出离故。由障难出离故。由有犯者时诸苾刍白大师故。由彼白已大师为欲止。当所犯集僧众故。由僧众集已制立所犯故。制立所犯已复于后时随事开听。令得究竟无恼害故

复次略由五处应知出离制立为最甚深。谓无染出离故。逼恼出离故。障难出离故。无计出离故。说悔出离故。无染出难者。谓如有一于小随小所犯法中随有所行。若善法增不善法减。由此因缘便不染污。由此无染即是出离。是故说为无染出离。逼恼出离者。谓若有遭困苦重病之所逼切。除其性罪于余犯法随有所行由此逼恼即是出离。是故说为逼恼出离。障难出离者。谓若见有命难现前或梵行难。于小随小所犯法中随有所行。由此障难即是出离。是故说为障难出离。无计出离者。谓若有一游于异方。经行旷野匮乏之处。随有一种障难之法而现在前。随其所有应受用事求受用法而不能得。遂生敬畏受用此事。于小随小所犯法中随有所犯。由此无计即是出离。是故说为无计出离。说悔出离者。谓如有一于五犯聚有余犯中随有所犯。遂于有智同梵行所。以毗奈耶秘密之法。发露陈说。如法悔除。言小随小所犯法者。谓除性罪

复次略由五处应知止息制立为最甚深。一清净故。二防破坏故。三为引接广大义利补特伽罗令入法故。四为令圣教转增盛故。五为遮防难存活故。清净故者。谓有清净所作已办诸阿罗汉。由彼已得极清净故。僧便于彼小及随小所有学处皆为止息。防破坏故者。谓于僧中一分苾刍。于有犯中生无犯想。于无犯中生有犯想。一分苾刍。于有犯中生有犯想。于无犯中生无犯想。由此因缘发起种种斗讼违诤。由此令僧不得安乐。为欲静息此诤事故。僧众和合白四羯磨。于小随小所有学处皆共止息。为欲引接广大义利补特伽罗令入法者。谓如有一族姓高贵补特伽罗。于圣教中多有所作。僧遇彼人无别方便可令入法。为欲引接令得入故。僧众和合白四羯磨。于小随小所有学处皆为止息。为令圣教转增盛者。谓于末劫诤劫秽劫正现前时。无量有情于小随小众多学处不乐修学。未入法者不欲趣入。已入法者复欲离散。由此圣教渐渐衰退不得增盛。由此因缘僧众和合。为令圣教得增盛故白四羯磨。于小随小所有学处皆悉止息。为欲遮防难存活者。谓于末劫诤劫秽劫现在前时。由小随小诸学处故。令诸苾刍难可存活为欲息此难存活事。僧众和合白四羯磨。止息学处

复次略由五种补特伽罗。于十羯磨应知羯磨制立为最甚深。何等名为十种羯磨。一受具羯磨。二结界羯磨。三长养羯磨。四同意羯磨。五趣向羯磨。六恣举羯磨。七治罚羯磨。八摄受羯磨。九白二羯磨。十白四羯磨。云何五种补特伽罗。一良慧喻补特伽罗。二鹦鹉喻补特伽罗。三炬烛喻补特伽罗。四电光喻补特伽罗。五书画喻补特伽罗。云何良慧喻补特伽罗。谓如有一于上所说十羯磨中。唯依于义不依于文。唯随义转不随音声。虽于此中未作如是羯磨言词。然能依义发起语言行于此义。云何鹦鹉喻补特伽罗。谓如有一唯依于文不依于义。唯随文转不随于义。不能依义发异言词。云何炬烛喻补特伽罗。谓如有一依少羯磨便多增益。现行种种随意言词。譬如炬烛。云何电光喻补特伽罗。谓如有一或一时间于诸羯磨及诸学中现可得见。于一时间都不现见。譬如电光。云何书画喻补特伽罗。谓如有一如其所制羯磨言词。即如是转不增不减。如书昼者

复有五种伪毗奈耶。一伪制立学处。二伪制立所犯。三伪制立出离。四伪制立止息。五伪制立羯磨。云何伪制立学处。谓如有一制立学处。不入契经。不现于律。违背法性。违背法性者。谓能增长诸不善法。及能损减所有善法。云何伪制立所犯。谓如有一于有犯中立为无犯。于无犯中立为有犯。云何伪制立出离。谓如有一于不出离立为出离。于出离中立不出离。云何伪制立止息。谓如有一于不应止息制立止息。应止息中立不止息。云何伪制立羯磨。谓如有一于非法羯磨立法羯磨。法羯磨中立非法羯磨

复次除十种事。若有苾刍。于异人前。宣说显示诸余苾刍坏戒坏见坏诸轨则及坏正命。当知此言非清净说。云何十事。一于佛宝欲为损害或欲劫夺。如于佛宝二于法宝。三于僧宝当知亦尔。四见由彼故坏戒坏见。若坏轨则若坏正命。品类渐渐增长广大。或闻或疑。五见彼显示坏戒坏见坏轨坏命。等不正法或闻或疑。六欲令彼出坏戒坏见坏轨坏命不善法处。及欲安置诸善法处。七为护他心。勿使他人作如是解是诸苾刍皆悉坏戒坏见坏轨坏命。然相覆藏。八或有施主。或邬波索迦。或造寺。主启白僧众作如是言。我不忍许诸有坏戒乃至坏命在此中住。诸苾刍辈。若见坏戒乃至坏命者。当告我知。若诸僧众同闻此言。九若有见他由时因缘内怀嫌恨欲起无义或闻或疑。十僧众于此坏戒坏见坏轨坏命污染他家行恶法者。无有力能治罚驱摈。唯有一因唯有一缘。所谓向他说彼不清净事。若因嫉妒。或因憎恚。或因财利。欲毁欲恼欲令损害。由此缘故向他说者。当知是名不清净说

复次毗奈耶中。略有五种能显法义诸譬喻事。一本生事。二本事事。三影像事。四假合事。五譬喻事。本生事者。谓说前生菩萨行事。本事事者。谓说前世诸相应事。影像事者。谓说乳酪生酥熟酥醍醐等喻。影显最胜补特伽罗。又以世间七种河中补特伽罗喻。影显正法中七种补特伽罗。如是所余影像种类皆应了知。假合事者。谓大王喻或良医喻。如是等类余无量喻。随顺染污及清净品。复有现见世间譬喻。或依杂染品。或依清净品。由彼少分共相应故假合而说。譬喻事者。谓说广长众多譬喻。如长譬喻及余无量如是等类

复次由五种相建立所知诸法差别。何等为五。一由事故。二由品业差别故。三由智依处差别故。四由智差别故。五由摄余智差别故。云何由事故。谓略说一切有为无为名所知事

云何由品业差别故。谓即此事复有五品所知差别及此五品所知作业。何等为五。谓此所知或有假立故名所知。或有胜义故名所知。或有所作究竟故名所知。或有他心净不净行故名所知。或有一切种别故名所知。若世俗智能知假立所知。知假立故如实了知世俗道理善不善法。有罪无罪广说乃至缘生法等一分应远离一分应修习。又能了知世俗言说游行世间。随因随缘而起众行法智类智。苦智集智。灭智道智。能知胜义所知。知胜义故能证见修所断法断尽智无生智。能知所作究竟所知。知所作究竟故。心得决定无有疑惑。于自断中离增上慢。他心智能知他心净不净行所知。由知此故如实知他所有意乐界及随眠。十力智能知一切种别所知。由知此故能正于他起一切种教诫教授。能断一切有情疑惑。能善安置一切有情于善趣果及解脱中。有大势力能作一切有情利益及安乐事。如是名为五品所知及五种业

云何由智依处差别故。谓有二种。一自利行。二利他行。若随顺断世俗智。若正能断胜义智。若于断所作究竟智。如是诸智。应知依自利行依处。若于他意乐界及随眠所有他心智。若于一切种别所知中。所有十力智。如是二智。应知依利他行依处。如是名为智依处差别

云何由智差别故。谓世俗智或善或不善。或无记或有漏或无漏。唯是世间。无漏者。谓于已断一切无学身中可得。此及所余总名俗智。亦唯世间。当知所余法类智等是出世间。亦唯无漏。尽无生智当知唯于漏尽中生。若不分别尽及无生。谓我已得诸漏永尽。我未来苦不复当生者。唯是无漏。唯出世间。若作如是分别者。唯是无漏世出世间世俗智摄。是未曾得是阿罗汉相续中生他心智。唯是世间。若在异生及有学相续中者。是有漏。若无学相续中者。是无漏。问何因缘故清净身中诸世俗智。说名无漏。答由彼身中诸漏随眠已永断故。又此诸智是他心智现所行境。此他心智非染污性。非余染污现所行境。又彼自性不与一切烦恼相应。是故此智由随眠故。由所缘故。由相应故。皆成无漏。十力智在如来相续中。是未曾得唯是无漏。世间智摄。何以故。由此一切种智皆带戏论而现行故

云何由摄余智差别故。谓神通智。解脱门智。无碍解智。无诤智。愿智。力。无畏。念住一切种不共佛法等智。随其所应当知皆为如前所说诸智所摄。谓五神通。皆世俗智摄。若诸异生及诸有学相续中者。皆是有漏。若在无学相续中者。皆是无漏。第六神通。尽及无生二智所摄。尽无生智如前应知。空解脱门智八智所摄。谓法智类智。苦智集智。灭智道智。及出世间尽无生智。无愿解脱门智。六智所摄。谓法智类智。苦智集智。尽智无生智。无相解脱门智。五智所摄。谓法智类智。灭智尽智无生智。无碍解智无诤智愿智十力等一切不共佛法智皆世俗智摄。皆是无漏。在阿罗汉及如来相续中。如其所应尽当知。

诸解脱门建立相。如本地分已说。不共佛法及无碍解等。如菩萨地已说

复次云何神境。云何神境智。云何神境智作证。谓从一种变作多种。如是广说乃至梵世身自在转。是名神境。由神境智于此神境领受示现。是故说此名为神境。若智具大威德。修所成是修果。名神境智。由此智于彼境能领受能示现。是故说此名神境智。即此智种子。由生缘所摄受故。势力增长相续随转。名神境智作证。如是一切总摄为一。名神境智作证

云何天耳。云何天耳智。云何天耳智作证。谓若修果耳所摄清净色。是名天耳。与依耳识相应智。名天耳智。此智作证如前应知。如是一切总摄为一等如前说

复次由此道理余一切通所作问词。如前应知。所有释词随其所应我今当说。谓诸他心由有贪等差别而转。名心差别。若具大威德修所成。是修果缘彼为境智。名心差别智。此智作证如前应知。如是一切总摄为一等如前说。若于过去生自体差别明了记忆。名宿住随念。若智具大威德修所成。是修果依止于念与念相应此方得转。是故说名宿住随念智。余如前说。若诸有情好恶色等种种差别。从彼别别有情众没。于此别别有情众生。说名死生。若修果眼所摄清净色以为依止。缘死生境。识相应智。名死生智。余如前说。若一切结无余永断。名为漏尽。即于此中世间尽智及无生智。名漏尽智。所余一切如前应知

复次诸具神通修观行者。若遇其时便能示现。或复安住或行他利。或于是中能善问记。是故名为具神通者。复次前三通是通非明。后三通亦通亦明。以能对治三世愚故。又初神通能回异类。令他于己发生尊敬。第二神通知他所行染净语业。能善诃责令其欢喜。第三神通善能知他若净不净心行差别。能正教授及与教诫。后三神通能令远离常边断边。能无颠倒离增上慢。依于漏尽宣说中道。即于此中能善教授

复次观察三种义势力故。俱分解脱利根阿罗汉苾刍住无诤定。谓或有一。昔曾于彼无诤等持。闻有无量差别胜利。心生喜乐发起胜愿。由此因缘缘彼为境。猛利意乐。数数熏修。彼既证得阿罗汉已。由彼为因由彼为缘。即于是中心乐趣入。是故今者住无诤定。又复有一。昔异生时。令诸有情起无量诤。于彼发起种种恼害嗔恨等事。今既证得阿罗汉果。于昔所行愚夫之行。生大悔愧。是故今者住无诤定。又复有一。自既证得阿罗汉果。欲令无量众生造作顺现法受可爱果业。又欲令彼于现法中受可爱果。是故方便住无诤定。由此因缘熏修边际第四静虑以为依止。发生无诤想三摩地防护他心。于自所起一切威仪。终不令他起烦恼诤。是故说此名为无诤。如是为欲护他心故。随所依止村邑聚落所住之处。周遍于此村邑聚落诸众生心次第观察。如是遍观一切衢路一切家属一一众生未来世心。如是观已。彼若了知如是村邑如是聚落。如是衢路如是家属。如是众生当于我所暂得见时。必定生起诸烦恼诤。即便隐避令彼众生皆不得见。彼若了知不由见故。由不见故。生烦恼诤。则作方便令彼得见。彼若了知由随顺故令不起诤。即便观察所随顺事为净不净。若清净者即与相见随顺彼事。若不清净或复观彼所随顺事令他相续起烦恼诤。既观察已不与相见。又审观察若因如是语言如是威仪。如是摄受如是受用衣服等物。如是说法如是劝导。令他相续起烦恼诤即便远离。如是语言广说乃至如是劝导。彼由多分住如是住行如是行。是故说名住无诤者

云何愿智。谓俱分解脱利根阿罗汉苾刍熏修边际第四静虑为依止故。若声闻乘随声闻智所行境界。若独觉乘随独觉智所行境界起如是愿。愿我当知如是如是所知境界。从此趣入熟修边际第四静虑。既入定已随先所愿一切了知。若诸如来遍于一切所知境界智无障碍

复次诸佛如来于无诤定而不数入。所以者何。有诸众生胜利益事。由起烦恼俱时成办。如来于此胜利益事不能弃舍复次如熏修边际第四静虑以为依止引发无诤及与愿智。当知如来所有一切不共佛法妙智亦尔。余神通等一切静虑以为依止皆能引发

复次唯依诸静虑及初静虑近分未至定。能入圣谛现观。非无色定。所以者何。无色定中奢摩他道胜。毗钵舍那道劣。非毗钵舍那劣道能入圣谛现观。非生上地或色界或无色界能初入圣谛现观。何以故。彼处难生厌故。若厌少者尚不能入圣谛现观。况于彼处一切厌心少分亦无

复次当说世俗智及出世无漏智初中后际生起差别。谓世俗智初异生位起如先说五染污见及与贪等相应邪智是染污等诸世俗智应断。应知为欲生起彼对治故。复起世间信所摄受无颠倒见。是善有漏世俗智摄。以此正见为依止故。次起闻思所成妙慧。于诸念住勤修观行。亦善有漏世俗智摄。以此为依。次于顺决择分方便道中。由修所成慧于诸念住勤修观行。亦善有漏世俗智摄。以此为依。次起见道方便顺决择分俱行修所成慧。于诸念住勤修观行。亦善有漏世俗智摄。以此为依。次起世第一法见道无间道所摄正见。亦善有漏世俗智摄。如是名为初异生地诸世俗智生起次第。又即以彼世第一法所摄俗智为依止故能入见道。升见道时即先所修善世俗智所有种子。由彼熏修皆得清净亦名为修。此则名为谛现观边诸世俗智。出见道已生起此智。证见所断诸法解脱。昔来于彼曾未解脱。由此生故是诸圣者于见所断烦恼断中能正分别。谓那落迦我已永尽。乃至不复堕诸恶趣。又能了知我今已证得预流果。又能了知我今已断如是如是所有烦恼。又随所欲应可为他所记别者当为建立。又审观察而记别之。又能于诸圣谛现观。以无倒慧而正建立。复于此上随其所应未离欲处。以世间道渐次修习能离彼欲。乃至能于无所有处离欲作证。此诸圣者以出世间智后所得诸世俗智离诸欲时。当知同彼非圣道者所作离欲。但能损伏烦恼种子。非谓永断。此世俗智是出世间智后所得。应言此智亦是世间亦出世间。不应一向名为世间。又修此智略有四道。一方便道。二无间道。三解脱道。四胜进道。于一切地修道所断耎中上等九品烦恼。随其品数各各差别能随顺断。是名初道。能无间断。是第二道。无间断已。是第三道。次后于断。是第四道。此胜进道复有二种。或有无间为断余品修方便道。此于前品名胜进道。于后所断名方便道。或有无间不修方便。但于前品生如足想。不求胜进或住放逸。或于已断以观察智而更观察。或有但以伺察作意而伺察之。当知此道唯名胜进。除未至定所余一切近分地中唯有俗智无出世智。何以故。由未至地是初定心初静虑上所有定心皆先有定故。圣弟子从此以上。但依根本修出世智不依近分。第一有中所有诸智。皆俗智摄。何以故。彼处作意与出世间圣智作意不同分故。但作非想非非想行。出世作意。有想诸定所摄受故。始从学地乃至于此诸世俗智。当知皆名中际俗智。于阿罗汉身中所有一切清净无漏解脱。一切结缚烦恼尽智。无生智及余一切神通等功德所摄诸世俗智。皆是后际世俗智摄

复次诸菩萨初中后际世俗智者。谓从胜解行地乃至到究竟地所有一切世俗智。初际者。谓胜解行地。中际者。谓从增上意乐清净地乃至决定行地。后际者。谓到究竟地。又诸菩萨于诸地中起二种行。谓有戏论想差别行。及离戏论想现行行。似出世间。善修此故得后所得世俗智摄无障碍智。又诸菩萨有与如来愿智相似诸世俗智。胜诸声闻独觉所得一切愿智诸神通等及空智等。应知亦尔。由诸菩萨所有功德皆依十力种性而转。声闻独觉则不如是

复次如是已说初中后际诸世俗智。初中后际诸出世智。次我当说。谓见道修道无学道。若法智品见道。对治欲界见所断惑。若类智品见道。对治色无色界见所断惑。问一切类智现在前时皆能了别色界无色界耶。答若有曾于色无色界所有诸法善闻善思善取相者。即能了别。若不尔者不能了别。所余诸智或在毗钵舍那品。或在奢摩他品。法智类智二品所摄。又于见道初智生时。诸余智因由能生缘所摄受故。皆得增长一切见道。即此刹那皆名为得。于此得已后时渐渐次第现前。当知见道是胜进道。于修道中若有修习出世间道而离欲者。应知如前方便道等。皆是出世。若于苦等诸圣谛中。有戏论想而现行者。是世俗智。离戏论想而现行者。是出世智。为于诸谛以有相想善取相故。为如先时所见所知修习种种微妙智故。为以世间诸善厌行令心厌故。为受种种妙法乐故。是诸圣者亦修世间离欲之道而离诸欲。无学地中即如所说出世间智。解脱修道所断惑故极善清净。又出世智。能为一切世间功德所依持处。能令一切上地下地所有功德皆自在转。如是名为初中后际出世间智次第生起

复次诸神境智或加行得或生得。加行得者。如生此间异生有学及与无学诸菩萨等所有修果。生得者。谓生色界由先修习为因缘故。后于此中生便即得。又有欲界诸天及人一分福果所致。如曼驮多王等。又傍生趣如飞禽等。摄受如是众同分故如得神通。鬼趣一分亦复如是。又有咒术药草威德亦如神通。如作幻惑厌祷起尸半起尸等。即由如是差别道理。余四神通所有差别。随其所应当知亦尔

复次云何所识法。谓一切法皆是所识。诸识能识。由五种相诸识差别。如其所应建立所识。何等为五。一依缘差别故。二欣戚差别故。三胜劣差别故。四心所差别故。五障治生差别故。云何依缘差别。谓由所依所缘差别。建立眼等六识差别。眼识了别诸色境界。余识各各了自境界。意识了别一切眼色乃至意法以为境界

云何欣戚差别。谓苦受相应识名戚。此能了别随顺忧苦不可意法。乐受相应识名欣。此能了别随顺喜乐可意诸法。不苦不乐受相应识名非欣非戚。此能了别随顺舍受非二诸法。

云何胜劣差别。谓不善法及有覆无记法相应识名劣。此能了别诸染污识所行诸法。善法相应识名胜。此能了别一切善识所行诸法。无记法相应识名非胜非劣。此能了别自所行法

云何心法差别。谓有心法遍诸心起。复有心法遍善心起。所余心法应知如前有漏法中已说其相。遍诸心起复有五种。谓作意触受想思。如前意地已说其相。遍善心起复有十种。谓惭愧无贪。无嗔无痴。信精进。不放逸不害舍。如是十法若定地若不定地善心皆有。定地心中更增轻安不放逸等。唯是假法。此相应识皆能了知一切境法。

云何障治生差别。谓所治障有十五心。何等十五。谓欲界系总有五心。见苦见集见灭见道及修所断。如欲界系总有五心。色无色界当知亦尔。能对治心是第十六。谓诸无漏学无学心。如是所治及能治识。随其所应各能了别自所行法

复次生差别者。略有五种。一欲界生行。二色界生行。三无色界生行。四往上地生。五还下地生。欲界生行者。从欲界系若善若染污。若无覆无记心无间。遍欲界系一切心生。是名欲界识生差别。如欲界系如是。色无色界系自地三心无间。皆生自地三心。若先未起静虑无色。初欲生时要从欲界善心无间。初静虑地善心得生。初静虑地善心无间。第二静虑善心得生。如是乃至。无所有处善心无间。第一有地善心得生。必从色界善心无间。初学心生。学心无间。无学心生。若先已起静虑无色。即于彼地不退失者。彼从欲界善心无间。随其所乐上地诸心。及学无学心欲起现前。先已善取彼行相故。于彼诸心如意能起。如是所余上地诸心无间所起。如其所应当知亦尔。又从欲界无记心无间色界善心生。如色界果。欲界变化心即从色界善心无间此欲界无记心生。又说此心为欲界者。当知是彼影像类故。非自性故。又欲界没生上地时。欲界善心无记心无间上地染污心生。谓生初静虑乃至有顶。以一切处结生相续皆染污心方得或故。如是应知往上地生诸识决定于自所行生起差别。又诸异生退先所得世间静虑无色定时。由染污心现前故退。此下地染污心从上地善心染污心无间生。又从上地没生下地时。从一切上地善心染污心无记心无间唯有下地染污心生。如是应知。还下地生诸识。决定于自所行生起差别。如是障治生差别故。诸识决定于自所行了别所识诸法差别

瑜伽师地论卷第六十九瑜伽师地论卷第七十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中声闻地之四

复次诸智光明有五胜利。一能于所知灭一切闇。二能以世间出世间功德适悦摄受所依止身。三能正观见所未见义。四能于现法与第一乐。五能身坏后与第一趣。复次由十五种德差别故。诸智光明胜外光明。何等十五。谓外光明以色为性。诸智光明以慧为性又外光明能害外翳。诸智光明能害内翳。如是非常所爱常所爱。不可分布与诸有情。可分布与诸有情。出已还没出已不没。有色无色粗细。有闇相违无闇相违动不动。不能作一切有情义利。能作一切有情义利。引诸众生趣曾所趣。引诸众生趣未曾趣。不能开发一切所覆。能开发一切所覆。不能隐覆已所开显。能隐覆已所开显。不能发起无量照明。能发起无量照明。违害于见不违害见。当知亦尔

复次有三种调善。一除遣故。二制伏故。三害随眠故。复有三种寂静。一诸恶寻思不能扰故。二不为诸相所动乱故。三任运于内常喜乐故。复有三种寂止。一身寂止。二语寂止。三意寂止。复有三种梵志。一趣向梵志。二住果梵志。三到究竟梵志。如是沙门亦有三种。复有三种婆罗门。一假名婆罗门。二种姓婆罗门。三正行婆罗门。

复次由四因缘令尸罗坏。尸罗坏故依止尸罗所应生善皆不得生。谓于无余罪起毁犯故。于有余罪不悔除故。于诸所犯不忆念故。于无犯中执有犯故。于有犯中执无犯故。由四因缘名戒具足。与上相违应知其相

复次由二因缘令所受戒清净具足。一助伴清净故。二自性清净故。云何名为助伴清净。谓见清净轨清净命清净。云何自性清净。谓恭敬随学具分。随学复有差别。谓三因缘令所受戒清净具足。一意乐清净故。二命清净故。三行清净故。云何意乐清净。谓为解脱修行梵行不为生天。云何命清净。谓如法乞求以自活命。云何名为如法乞求。谓如所应求如所从求而乞求故。云何名为如所应求。谓不矫诈而有所求。亦不绮说而有所求。亦不现相而有所求。亦不抑逼而有所求。亦不以利而悕于利。云何名为如所从求。谓除五种不应行处而有所求。云何行清净。谓深信所犯有不爱果。若行若住系念思惟终不故犯。设有所犯即便从他如法悔除。誓于当来坚牢防护

复次若有苾刍欲勤加行密护根门。应以四相了知妄念过失。及以四相了知不如理作意。云何四相了知妄念过失。一阙念。二劣念。三失念。四乱念。阙念者。谓于密护诸根门法。不听不受不善了知。劣念者。谓于彼法虽听虽受虽善了知。而不常作非委悉作若修若习若多修习。失念者。谓虽修习亦多修习。然或有时不正了知而有所行。乱念者。谓即于彼非杂染中生杂染想。杂染中生非杂染想

云何以四相了知不如理作意。一是烦恼生因。二与杂染生相应。三毁坏羞耻。四起错乱犯。烦恼生因者。谓如有一执取于相执取随好。由此因缘于是处所。恶不善法随心流逸。与杂染生相应者。谓即与彼恶不善法俱现前行。毁坏羞耻者。谓如有一于应羞耻而不羞耻。又即于彼恶不善法现在前时而无羞耻。起错乱犯者。谓即因彼无羞耻故。或犯所犯罪或思舍所学

复次于食知量勤修行者。断除八处乃名具足于食知量。何等为八。一耽着饮食。二耽着自身。三命根坏灭。四饥劣。五身重。六非无病。七命不清净。八多营事业

复次常勤修习觉悟瑜伽者。断除八处乃得名为常勤修习觉悟瑜伽正行具足。何等为八。一由威仪其身疲弊。二爱味偃卧睡眠为乐。三随杂染相。四不勤修习杂染对治。五非时而觉。六虚弃而觉。七非时而眠。八虚弃而眠。

复次依六出离应知建立诸出离地。何等为六。一不随顺出离。二阙出离。三家出离。四不圆满出离。五下地出离。六萨迦耶出离。不随顺者。谓五种依止。一趣不随顺。二生不随顺。三精进不随顺。四障不随顺。五爱乐不随顺。阙者。谓阙四种缘。一亲友阙。二听闻阙。三隐没阙。若教若证皆隐没故。四施主卧具阙

复次由四种力生善法欲。一由缘力。二由因力。三由智力。四由行力

复次由四圆满故于善说法毗奈耶中出家圆满。一形相圆满。谓能随顺无所杂染不染污故。二业圆满。谓如佛说法善随顺故。三意乐圆满。四住处圆满

复次由五因缘应知尸罗律仪圆满。一不坠堕故。二能出离故。三不可诃故。四无穿缺故。五不知足故

复次依二种对治应知四种根律仪。二种对治者。一思择力。二修习力。四种根律仪者。一境界护。二烦恼护。三缠护。四随眠护。境界护者。谓住寂静勤修行时。以念自守于诸境界心不流散故。烦恼护者。谓等位行而游行时。于诸境界远离贪忧故。即分别此不取其相。乃至心不流逸者。若于尔时执取彼相复起随觉。执取随好则便于彼修防护行。以修习力守护眼根。是名缠护。证眼根护。是随眠护

复次由五因缘当知于食知量圆满。一依止对治故。二远离所治故。三作自作业故。四依处故。五分别故。此中旧受者饥所起。苦受者食所起。抚育者增梵行故。力者能害所治故。乐者现法乐住故。无罪者净福田故。安隐住者烦恼苦断能作证故。减省睡眠。无间殷重二加行故精进圆满。殷重加行者。谓行坐时而成办故。于第一第二第四盖中宜坐时。第三盖中宜行时。第五盖中宜俱时。无间加行者。谓于昼日夜初后分应常觉悟。于夜中分正习睡眠。为离师子相似长时极重失念无间睡故。重累其足乃至思惟起想正习睡眠

复次应于五处知量正知而住。一于行处。二于观处。三于摄受利养恭敬处。四于受用资具处。五于善品加行处。由初处故终不游行非所行处。亦不曛暮而出游行。由第二故先不作意而观视者速摄其根。若先作意而观视者善住其念。由第三故若有所受及他礼时。手不拳缩足不躁动。由第四故受用衣钵及与饮食皆知其量。由第五故若居寂静。于昼日分经行宴坐。若行若住若坐若觉善知其量。于其夜分所习睡眠亦善知量。若有修习论义决择。若语若默亦善知量。为令二种所依调适除遣睡眠及诸劳倦亦善知量

复次若有苾刍勤修神足。略由四支摄诸断行。一修习支。二证胜进支。三护随烦恼通达支。四引发能净随烦恼支。修习支者。谓欲精进。何以故。依欲精进修神足故。证胜进支者。谓信轻安。何以故。由证胜进故以净信心信上解脱。以其轻安止息所有身心粗重。护随烦恼通达支者。谓念正知。何以故。由正念故防护未生止观随惑。由正知故通达已生止观随惑。引发能净随烦恼支者。谓思及舍。何以故。由思故策沉下心。由舍故若心掉举摄持于内

复次有四种法。于所得定为增上缘。一审谛听闻。二得正教授。三宿世串习。四具足多闻。审谛听闻者。谓发起乐欲生净信心听闻正法。由此因此缘得心一境性。得正教授者。谓因次第教授无倒教授故。发起勇猛精进而住无间。常委于菩提分精勤方便修习而住。由此因此缘得心一境性。宿世串习者。谓于宿世邻近生中。于诸静虑及诸等至数已证入。由此因此缘得心一境性。具足多闻者。谓多闻闻持其闻积集。即于彼法独处空闲思惟筹量审谛观察。由此因此缘得心一境性

复次有七种法。为欲证得三摩地者应正了知。一内定退因。二外定退因。三内定退。四外定退。五内定退及因对治。六外定退及因对治。七彼二对治依持。内定退因者。谓懈怠。外定退因者。谓掉举。内定退者。谓惛沉睡眠。外定退者。谓于五妙欲散乱。内定退及因对治者。谓善取相而正观察。外定退及因对治者。谓即于身观察不净。彼二对治依持者。谓光明想

云何于身观集法住。谓观此身从过去世及诸饮食现在而生。云何于身观灭法住谓观此身于当来世是死灭法。云何于身观集灭法住。谓观此身于现在世由饮食缘增长久住必当破坏。于有身者。谓于此身善住其念于真如身。或唯出世间智者。谓由于内奢摩他道。或唯出世间见者。谓由毗钵舍那道。或唯忆念者。谓由此后所得出世间道

云何于身无所依住。谓依诸定修习念住。即于彼定无有爱味。乃至无有住着。云何于世间无所取执。谓于四颠倒已永断灭。永断灭故于彼身等终不执取净乐我常

复次依上施设建立五种补特伽罗。云何为五。一欣乐喜乐诸异生者。二欣乐障断见迹行者。三欣乐解脱见趣行者。四到究竟见趣行者。五到究竟见迹行者。云何欣乐喜乐异生补特伽罗。应知此有三种。谓欣乐欲生喜乐。欣乐有寻有伺定生喜乐。欣乐无寻有伺定生喜乐。欣乐无寻无伺定生喜乐差别故。云何欣乐障断见迹行补特伽罗。应知此有二种。谓欣乐烦恼障断。欣乐定障断。差别故。欣乐烦恼障断补特伽罗。于现法乐住未得已得。于一切种有想等至未得已得。谓于依止及于观察。所知有差别故。欣乐定障断补特伽罗。于一切胜处未胜已得。及于一切遍处未得已得。云何欣乐解脱见趣行补特伽罗。谓诸外道起如是见。我为非有。我所为非有。我当无有。我所当无有。彼于此见未得已得

云何到究竟见趣行补特伽罗。谓于非想非非想处未得已得。云何到究竟见迹行补特伽罗。谓于六触处无余永断究竟证受。如是名为依止施设建立五种补特伽罗复次邬波索迦有三种德。一清净。二能造作。

三能引发。清净者。谓意乐清净戒。行清净。证清净。意乐清净者。谓于佛宝等远离疑惑。不悕世事谓作吉祥。戒行清净者。谓能圆满所有学处。证清净者。谓能证得世出世清净故。能作三宝所作事故。名能造作。能引发同法不同法者智故。名能引发。

复次有三种法。一闻法。二行法。三究竟证法。又外道法是颠倒说。所有禁戒非可现见。依止邪愿修梵行故。所有等至有热恼非究竟。不能趣究竟不能出离故。共诸外道故。共诸异生故。诸佛正法与彼相违。是真善说是可现见。乃至智者自内所证

复次诸欲得舍次第谓当宣说。先所应作由此故得。谓由布施持戒。于此可得谓在天上。由此受用谓由爱味。由此故舍谓由过患。如此差别舍于事欲及烦恼欲。谓由出离远离功德。又若显示清净品法。谓应称赞四沙门果。从彼决定无退堕故。或出世间故

复次由三因缘同梵行者。应当和合驱摈犯戒。一为护他故。二彼不堪为上法器故。三彼能令僧无威德故

复次由四因缘令于尸罗深生爱乐。一由师教远离二边制立所学故。二由自内非极猛利贪等类故。三由助伴彼极柔和易共住故。四由加行不住懈怠故

复次有四种观察尸罗。一由共住信知是有。二于厄难信知坚牢。三由世务信知无缺。四由言论决择信知无恋见不坏故

云何心趣远离。谓于住时处愦闹者。云何心趣出离。谓于聚落而游行者。云何心趣涅槃。谓居寂静处奢摩他等相者。复有差别。谓依远烦恼说趣远离。依出生死说趣出离。依入涅槃宫说趣涅槃。一切受并相续灭。故名为无影。名为寂灭。三苦永离故名为寂静。烦恼炽然热恼永息故名为清凉。得无上迹故名为真梵

复次由三过故不能无倒听闻正法。一散乱故。二愚痴故。三不恭敬故。

复次有五种相为闻修器。一谦下心。二奉行心。三摄受义心。四善摄受义心。五恭敬心

复次于善说法毗奈耶中。略有五种大师功德。若有大师具成就者。便能映蔽外道沙门婆罗门师。何等为五。一于诸戒行终无误失。二善建立法。三善制立所学。四于善建立法善制立所学中。随所疑惑皆能善断。五教授出离

复次由三因缘唯有此道能得出离。谓无我见。一未曾得故。二现能对治诸烦恼故。三现于解脱无怖畏故

复次有四种欢喜。一俭素欢喜。二积习梵行欢喜。三无悔欢喜。四乐断乐修欢喜。第一欢喜能引少欲乐。第二欢喜能引远离乐。第三欢喜能引三摩地乐。第四欢喜能引三菩提乐

复次由二因缘佛世尊法名为善说。一言词文句皆清美故。二易可通达故。由二因缘易可通达。一若文若义易觉了故。二出离等觉故。由二因缘名为出离。一往善趣出离故。二趣三菩提出离故。由二因缘趣三菩提。一无疑惑故。二不可坏故。由二因缘不可破坏。一见不可坏故。二有窣堵波故。由二因缘有窣堵波。一证坚住故。二有可依故。由二因缘名有可依。一依智不依识故。二大师是如来应正等觉故。由二因缘大师是如来应正等觉。一断一切疑故。二邪行不可得故。

复次有四种能障断法。一无厌离。二智未熟。三散乱。四沉下。应知慧眼于作恶者说名为盲。于作福者说名有垢。于诸外道说名有翳

复次修法念住者。应正了知十一种杂染法。一贪。二嗔。三痴。四聚。五散。六沈。七掉。八随烦恼相。九不乐远离。十爱味。十一增上慢

复次由四因缘出世间道用世间道以为助伴。一隐障诸盖故。二远分制伏故。三厌患朽坏故。四法力滋润故。

复次由四种相当知如来所得天眼遍行一切有情义境。一现见住造能感一切趣业有情故。二现见住种种无量生处有情故。三现见有中有死生有情故。四现见无中有死生有情故。

复次为证诸法为达诸法勤修行者。有七渐次能证诸法能达诸法。谓于说法者恭敬承事。既承事已审谛听法。审闻法已法随法行。法随法行故为住其心摄正方便摄正方便故发勤精进。发勤精进故远离内外不平等心起处方便。法财二种障得清净。障清净故于三摩地不生爱味离增上慢

复次为对治九种所治故。应修四种念住。一不厌离。二不作意。三止观随烦恼。四沉下。五不堪击难。六于劣喜足。七忘失教授。八毁犯禁戒。九弃舍善轭

复次诸出家者有五过失。一不喜乐过失。二贪着利养恭敬过失。三追求亲属过失。四轻蔑过失。五增上慢过失。诸在家者当知亦有五种过失。一贪着过失。二习近能障诸欲过失。三摄受过失。四造作恶行过失。五不作善行过失

复次愚夫有四种相。一不作善作。二作于恶作。三二种杂作。四虽复一向作于善作而于善作不如实知。又有四种愚夫之相。一不决定慧。二邪决定慧。三不起加行。四所作奸诈。又有四种愚夫之相。一非处欢喜。二非处愁忧。三决定艰辛。四先不观察。又有四种愚夫之相。一邪思构。二邪发起。三设施功劳多分无果。四由此因缘多生愁叹。又诸愚夫多分少福运业薄劣

复次五法相似。生死大海得大海名。一处所无边相似故。二甚深相似故。三难渡相似故。四不可饮相似故。五大宝所依相似故

复次由五因缘于诸财施法施为胜。一者财施于他身中发起恶行。法施决定起诸善行。二者财施于他身中发起烦恼。法施能令对治烦恼。三者财施于他身中无间引发有罪安乐。法施能令无间引发无罪安乐。四者财施若佛现世若不现世易可获得。法施若无诸佛现世难可获得。五者财施施而有尽。法施施而无尽

复次应令五心随己自在而转。不应令己随彼诸心自在而转。何等为五。一恶行方便心于恶行中猛利趣入。二善行方便心于善行中不猛趣入。三追求诸欲方便心于非法凶暴追求欲中猛利趣入。四受用诸欲方便心深生贪染。乃至不见过患不知出离趣入受用。五出离远离方便心于出离远离中速疾退转。于诸欲中或于静虑诸爱味中速疾趣入

复次由五种相诸烦恼魅。甚于鬼魅。一者若为一鬼所魅。唯即为此一鬼所魅。若为一烦恼所魅。必为无量烦恼所魅二者若为鬼魅所魅。或以咒术或以缚害或以资具或以众药易可治疗。若为烦恼魅之所魅不可治疗。三者若为鬼魅所魅。当于魅时易可识别。下至婴儿亦能觉了。若为烦恼魅之所魅。当于魅时难可识别。世聪慧者尚不能了。四者若为鬼魅所魅。此魅是客易可摧伏。非是俱生。不即由彼成其自性。若为烦恼魅之所魅。此魅非客难可摧伏。而是俱生。即由彼故成其自性。五者若为鬼魅所魅。不与一切余有情共。若为烦恼魅之所魅。必与一切余有情共

复次或有苾刍不如理思虚妄计度。谛故实故建立有我。当知此计略有五种虚诳过失。一者随顺外道教转。二者摄受外道妄见。三者设不顺彼而转。然与外道共为同法。四者若随外道教转。便为修行不出离道。五者虽不随顺彼转。然与同法翻成畏法。又二因缘故。一于谛现观因缘起邪行故。二于谛现观起邪行故

复次依止欲行福行展转同居行。有六种爱恚杂染四种依处五种对治。云何六种爱恚杂染。一境界贪。由此习近能障诸欲。二怨憎嗔。由此于怨诸有情所发起憎恚。三顺教贪。由此于他承受其教不得自在苦有情所广行种种恼害逼迫。四增上嗔。由此于彼增上安乐增上欢喜诸有情所。不欲令其得此兴盛。唯欲自得杂起种种嫉妒不忍变异不乐。第五第六有功德贪有过失嗔。由此因缘心不平等。于僧众中虽行惠施修诸福业。而常伺求种种差别。若作不作若恶所作。内怀忧苦不安隐住。云何四种依处。谓初境界为依处。余有情为依处。又初二依处各起一分杂染。所余依处各起俱分杂染。云何五种对治。一不净。二慈。三悲。四喜。五舍。复有异门六种爱恚杂染五种对治。何等为六。一事贪。二事嗔。三贪嗔痴杂染贪。四不贪不嗔不痴不杂染嗔。五不贪不嗔不痴不杂染贪。六贪嗔痴杂染嗔。云何五种对治。谓不净与慈及三种作意。一杂染无颠倒作意。二不杂染无颠倒作意。三杂染不杂染无颠倒心弃舍贪嗔作意

复次有四种特补伽罗。应知出家得五种功德。云何四种补特伽罗。一自依者。二依他者。三已熟者。四未熟者。云何应知出家得五种功德。谓自依补特伽罗由出家故。弃舍王等所共财宝。依止不共清净尸罗。是名获得最初功德。依他补特伽罗由出家故。弃舍属他随他而转不自在事。获得自依不随于他自在转事。是名获得第二功德。已熟补特伽罗由出家故。若无余结即便获得一切苦边。是名获得第三功德。若有余结即便获得恶趣苦边。是名获得第四功德。未熟补特伽罗由出家故。于现法中解脱无量居家迫迮所有忧苦。积集无量顺解脱分广大善根。能令当来相续成熟。是名获得第五功德

复次有三种苦及九种相。应知随逐诸有漏行。云何三种苦。谓苦苦乃至坏苦。云何九种相。谓一一苦各有三相。随逐一切有漏行法故有九相。一死所随缚故。二起恶趣因所随缚故。三诸恶趣生所随缚故。四无常法故。五于无常中苦法故。六于苦中无我法故。七顺爱味行生住乐故。八变坏苦故。九即由如是变坏苦性。诸有智者取为非出离法故

复次若有苾刍成就四支为众主者。乃能无倒教诫摄御所有徒众。修行自利利他正行。云何四支。一解脱随烦恼。二不离正智。三为令一切已生善法坚住不忘修习圆满倍增广故摄受任持。四为令一切未生善法得生起故摄受任持

云何苾刍解脱随烦恼。谓解脱五种随烦恼故。何等为五。一思慕居家。二毁犯禁戒。三忆先所受分别俱行不正作意。四耽着未来所有境界发起贪忧。五于法悭吝。若诸愚夫于四大种造色自相不如实知。谓之为己父母妻子乃至朋友。宰官亲属及兄弟等。于唯形色谓戏笑等。于唯身语所有动作起有情想俱行作意。由此因缘起邪分别妄计。为我父母妻子乃至朋友。宰官亲属及兄弟等。由此分别妄计因缘。发生种种居家思慕。诸有智者了知唯有诸色自相无有情想故。能解脱初随烦恼。所以者何。从久远来由见种种各别色形建立安布。或时与他而共集会。如是见已便谓为我父母妻子广说。乃至是我朋友宰官亲属。或谓为他。非生无色诸有情类有如是事。又诸愚夫不如实知愚夫之相及智者相。由不如实知故。恶思所思恶说所说恶作所作。凡所现行身语意业皆不清净。亦无清净尸罗正命。诸有智者如实知故。当知一切与彼相违。故能解脱第二随烦恼。又诸愚夫于非如理不能如实知非如理。于其如理不能如实知是如理。于先所受随顺欲贪可意诸法。不正作意起欲寻思。坚着不舍不弃不吐。于随顺恚不可意法起恚寻思。于随顺害不可意法起害寻思。余如前说。诸有智者于其如理能如实知此是如理。于非如理能如实知此非如理。于先所受如前所说差别诸法。或不追忆或正思惟或不失念。于彼所缘不起欲寻乃至害寻。设复生起而不坚着。广说如前。故能解脱第三随烦恼。又诸愚夫于根护功德不如实知。不护过患不如实知。于现在世现前别境发生爱恚杂染。其心于诸可意色等境界悕慕欲见。于不可爱色等境界心生厌逆。于可意境心生悕慕。是名为贪。怀此贪者若彼境界变坏之时心便下戚。是名为忧。诸有智者一切道理当知皆悉与此相违。故能解脱第四随烦恼。又诸愚夫于诸贪欲不正法中。不能如实知其过患。常为余四悭所漂溺复起法悭。诸有智者于彼过患能如实知。于余四悭尚不生起。设起寻舍终不坚着。况起法悭。彼既如是远离法悭。若遇乐法补特伽罗。即为宣说大师所说素呾缆。毗奈耶。摩呾理迦相应圣教。令其受持。广为无间分别开示终不隐秘。故能解脱第五随烦恼。是名苾刍成就第一解脱随烦恼支。云何苾刍不离正智。谓有四智。何等为四。谓依最初离染相续通达八圣支道立第一智。依证成办八圣支道立余三智。谓有苾刍住异生位作是思惟。唯于诸佛世尊圣法毗奈耶中有八圣支道。非诸外道异论法中有如是道。若于是处有八圣支道。即于是处有沙门果。有诸沙门及沙门义所谓涅槃。我今为证沙门果沙门沙门义故。应当发起八圣支道修令清净。由如是行于八圣支道中所有智。是名依通达八圣支道立第一智。即以此智为依止为建立。为欲证得成办如所通达八圣支道故。勇猛精进修余三智。谓闻所成智。思所成智。修所成智。彼为勤修闻所成智。亦令此智得清净故求闻正法。若有宣说如来所证法毗奈耶。即便往诣恭敬听受证得欢喜。广大妙善出离所摄。自相高胜故名广大。自性无罪故名妙善。涅槃相应故名出离所摄。又为勤修思所成智亦令此智得清净故。若知是处有诸苾刍持经律论。而共集会铨量决择经律论中深隐要义。则便往趣请问诸谛。彼则为其建立诸谛所有自相证得方便。先未觉悟令其觉悟。若已觉悟开晓令知。即于一义文字差别。方便劝导令不忘失。又于无我相应诸谛证得所依甚深义句。以慧通达。广为开示空性相应如来所说微妙法句。由此因缘彼既证得闻思所成智清净故。复更勤修修所成智。亦令此智得清净故。便于内身住循身观。乃至广说修四念住皆应了知。如是名为依证成办八圣支道建立三智。是名苾刍成就第二不离正智支

云何苾刍为令已生所有善法坚住不忘。广说乃至摄受任持。谓诸苾刍依财食事。从清净信诸施主边。如量受取衣服等物名曰任持。何以故。以诸苾刍由此因缘身不羸顿。心有堪能心无染恼。已生善法不退增长

云何苾刍为令未生一切善法得生起故摄受任持。谓诸苾刍年齿耆宿戒行清高。了知涅槃所有喜乐。于诸喜乐为最第一。善修圣道离增上慢。若有苾刍能于彼所礼敬承事善言随喜。离诸谄曲无求过心。此能生彼名曰任持。何以故。彼由如是正随转时于时时间。从彼获得能发胜喜教诫教授。能令未生一切妙善菩提分法速得生起。如是四支别分十一。十一与四平等平等

瑜伽师地论卷第七十瑜伽师地论卷第七十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中声闻地之五

复次有七种义。一应推义。二应摄义。三应避义。四应引义。五应遮义。六应持义。七应发义。复次有七种喜。一闻所引喜。二思所引喜。三修所引喜。四离盖所引喜。五议论所引喜。六念自功德所引喜。七于诸下劣不生知足所引喜。

复次有五种法。一教法。二行法。三摄受法。四受用法。五证法

复次具三种德方能善射。一由弓德。二由箭德。三由中的德。弓有二德。一其性坚牢。二善作究竟。箭有一德。善作究竟。中的有三德。一究竟工巧。二串习工巧。三师学工巧

复次如来教有三种。一长时教。二无间教。三不重说教

复次如来无量法教。皆由三种理趣。一由义差别理趣。二由文差别理趣。三由难释差别理趣

复次夫涉道者须五对治。一焰光对治。二艰险对治。三江河对治。四枯竭对治。五身劳对治

复次尸罗有二种相。能往善趣。一摄受尸罗。二不缺尸罗

复次诸受欲者于现法中有三种义。一追寻财宝。二守护财宝。三耽着受用。复次寿命变坏有二种。一粗变坏。二细变坏。变坏分位亦有二种。一粗。二细。

复次智有二德。一正行义德。二自性德。正行义德者。谓速疾正行。决定正行。微细正行。自性德者。谓是定地不可退转。是出世间已善修习。于自所行无有挂碍。胜余一切自类善根。胜于一切他类善根

复次有三顾恋。修四念住能为对治。一顾恋助伴。二顾恋利养。三顾恋后有。

复次加行故。现观故。相续故。欲贪无明对治是加行。现见安立非安立谛是现观。已离欲未离欲是相续。又依故地故品故。未修定故。已修未得得故。所依清净障故。作意清净障故。彼障对治故

复次如说六种现观。谓思现观乃至究竟现观。问思现观有何相。答若有成就思现观者。能决定了诸行无常一切行苦。诸法无我涅槃寂静。住异生位。已能证得如是决定。非诸沙门若婆罗门。若天魔梵及余所能如法引夺。问信现观有何相。答若有成就信现观者。或是异生或非异生。或于现法或于现法及后法中。终不妄称余是大师。余法善说余僧正行。问戒现观有何相。答若有成就戒现观者。终不复能乃至故心断傍生命。不与而取。习欲邪行。知而妄语。饮米等酒。诸放逸处。问现观智谛现观有何相。答若有成就现观智谛现观者。终不复能依诸妄见而有所作。于自所证而有疑惑。于诸生处而有贪染。现行世相计为清净。诽谤声闻独觉大乘作恶趣业。何况能造害父母等诸无间业。乃至不能生第八有。问现观边智谛现观有何相。答若有成就现观边智谛现观者。终不于彼他所诘问而生怖畏。问究竟现观有何相。答若有成就究竟现观者。终不复能犯于五处。亦不复能乃至故断诸傍生命。不与而取。行非梵行习淫欲法知而妄语。蓄积财宝诸妙欲具。而受用之。亦不怖畏不可记事亦不妄计。所有苦乐自作他作。自他俱作。非自非他为因而生。如是等类当知是名诸现观相。

问思现观何自性。答上品思所成慧为自性。或此俱行菩提分法为自性。问信现观何自性。答缘三宝境上品世间出世间清净信为自性。或此俱行菩提分法为自性。问戒现观何自性。答圣所爱身语业为自性。或此俱行菩提分法为自性。问现观智谛现观何自性。答缘非安立谛境慧为自性。或此俱行菩提分法为自性。问现观边智谛现观何自性。答缘安立谛境慧为自性。或此俱行菩提分法为自性。问究竟现观何自性。答尽无生智等为自性。或此俱行菩提分法为自性

问此六现观几欲界系乃至几不系。答一唯欲界系。一种一分或欲界系或色界系。或无色界系。即此一分及余三此四是不系。一通系及不系

问此六现观几依未至依可得。几乃至依无所有处依可得。答一依非依可得。余依一切依可得。又三依五依生一种一分亦尔。问若现观智谛现观离众相故名无分别。云何依有寻有伺依可得。答由彼思惟寻伺等全分静虑真如而入于定。是故虽依有寻有伺静虑可得。然是离相无有分别。

问此诸现观。几缘世俗谛。几缘胜义谛。答一缘世俗谛及一种一分。一无所缘。二缘安立胜义谛及一种一分。一缘非安立胜义谛及一种一分

问此诸现观。几有相几无相。答四有相。一无相。一亦有相亦无相

问此诸现观。几有分别几无分别。答如有相无相。当知有分别无分别亦尔。

问此诸现观。几喜俱行几乐俱行几舍俱行。答初唯喜俱行。余通喜乐舍俱行

问此诸现观。几是坏对治。几是断对治。几是持对治。几是远分对治。答二唯坏对治。一通断持远分对治。一通持远分对治。二非对治

问此诸现观。几是诸缠制伏对治。几是随眠永害对治。答三是诸缠制伏对治。一俱对治。二俱非对治

问此诸现观。几是地地软中上品烦恼断对治。答一。余随顺此为此助伴。非断对治

问六现观得九遍知。谓欲系见苦集所断烦恼断故立初遍知。色无色系见苦集所断烦恼断故立第二遍知。欲系见灭所断烦恼断故立第三遍知。色无色系见灭所断烦恼断故立第四遍知。欲系见道所断烦恼断故立第五遍知色无色系见道所断烦恼断故立第六遍知。下分结断故立第七遍知。色贪断故立第八遍知。无色贪断故立第九遍知。此六现观谁得几遍知果。答一得九遍知果。余不得彼果。

问此诸现观能为烦恼断对治者。为生已作断对治耶。为未生耶。答此非未生。虽言生已而非后时。当知烦恼断时对治生时平等平等。即于尔时假施设说对治生已诸烦恼断。

问此诸现观谁得几果。答一得一切四果。一得圆满沙门果。时余是得一助伴是得前行。

问是诸现观。几能转根。答除一余一切

问是诸现观。几能引发诸神通等殊胜功德。答除一余一切

问思现观当言作何业。乃至究竟现观当言作何业。答思现观当言能生正行所摄清净品善法为业。能生无罪欢喜为业。能转一切所疑为业。能趣入修功德为业。能引所余现观为业。能往一切善趣为业。信现观由意乐故。于三宝中能生不动胜解为业。正行清净为业。一分能往善趣为业。戒现观解脱恶趣众苦为业。现观智谛现观。能得一切沙门果为业。能引发一切功德清净为业。能引所余现观为业。能于善趣助感光净果及异熟为业。现观边智谛现观。能于一切安立谛中。问答善巧为业。速疾通慧为业。能引此后现观为业。究竟现观。能引第一现法乐住为业。解脱一切生死大苦为业。住持最后身为业。

问思现观有几种。乃至究竟现观有几种。答思现观当知有无量种。谓契经思。应诵思。记别思。乃至方广未曾有法论议思。苦思。集灭道思。真如实际法界思。蕴界处等思。声闻乘等思。大乘思。如是等类当知差别有无量思。信现观亦无量种。谓正忆念过去无量三藐三佛陀及彼法彼僧。如于过去未来现在亦尔。又正忆念此世界中及余十方无量世界所有如来及彼法彼僧随正忆念有尔所量。亦有尔所信现观体品数差别。戒现观亦无量种。谓随远离十种不善性罪业道差别多种。又随相续亦有多种。谓预流身乃至阿罗汉身。独觉菩萨如来身等无量差别。现观智谛现观亦无量种。谓念住正断神足根力觉支道支等菩提分法无量差别。如现观智谛现观。当知现观边智谛现观究竟现观亦尔。

问此诸现观。由如是名由如是言所安立故。当言是彼自性。当言非彼自性耶。答世俗说故当言是彼自性。第一义故当言非彼自性。何以故。一切法义法尔不可说故

问思现观何因何果如是。乃至究竟现观何因何果。答思现观以佛出世亲近善士。听闻正法。相续成熟。如理作意为因。以所作业为果。如思现观。一切现观当知亦尔。此中差别者。信现观亦以余现观为因。戒现观亦尔。现观智谛现观亦以思现观为因。亦以顺决择分善根为因。亦以自种姓为因。现观边智谛现观亦以现观智谛现观为因。究竟现观亦尔

问六现观七作意。谓了相等。为六现观摄七作意。为七作意摄六现观耶。答二现观非作意摄。一现观摄乐作意摄。一现观摄乐作意观察作意摄。一现观远离作意摄。乐作意加行究竟作意摄。一现观加行究竟果作意摄。余作意当知是现观等流摄。非现观摄。谓了相作意胜解作意

问无边际智及顺决择分善根何现观摄。答非诸现观摄。当知是现观等流。

问诸思现观亦信现观耶。设信现观亦思现观耶。答应作四句。或有思现观非信现观。谓除缘宝决定思。诸余缘决定思。或有信现观非思现观。谓缘宝闻修所成信。或有思现观亦信现观。谓缘宝决定思。除上尔所相。是第四句。由此道理应知所余亦应作四句。复有无量一行顺前句顺后句四句等道理。依声闻地决择道理皆当了知

复次悭之与垢合名悭垢。由八种垢污心相续。能与其悭作安足处。是故说彼名为悭垢。云何为八。一于惠施先不串习。于现法中爱重财食。二于身命极重顾恋不顾后世。三与悭者恒共止住又随顺彼。四见所施田无胜功德及简择福田。五于慈悲先不串习。及于彼处不见胜德。六以诸财宝难可积集。数习彼想故生懒惰及与懈怠。七执取于见及谓惠舍有彼杂染。八希求财宝而行惠施及回向于彼

复次有五种行名为调善。一感财富行。二感善趣行。三感无苦行。四感自义行。五感他义行。感财富行者。谓施性福业事。感善趣行者。谓戒性福业事。感无苦行者。谓修性福业事。感自义行者。谓声闻独觉道。感他义行者。谓菩萨道。为得彼故应修五想。一于诸欲中修不净想。二于自身命修速灭想。三于欲界中修有怖想。四于诸行中修无常想。五于诸众生修哀愍想。

复次当释醍醐喻经。云何了知契经乃至论义。谓略由五相。一了知假名故。二了知摄受故。三了知次第故。四了知圣教故。五了知依处故。云何了知假名。谓能了知差别法门名想施设。云何了知摄受。谓能了知名身句身文身。由此宣说差别法门。云何了知次第。谓能了知从此法门至彼法门。从此句至彼句所有次第。云何了知圣教。谓能了知如是法门如来所说或弟子说。或在家说或出家说。云何了知依处。谓能了知如是法门依自利说。如是法门依利他说。如是法门乃至为令天人利益安乐故说。如是名为略由五相了知契经乃至论义。

云何了知彼彼语义。亦由五相。一了知缘起故。二了知句差别故。三了知次第故。四了知道理故。五了知略义故。云何了知缘起。谓能了知一分所化应示现义。乃至一分所化应庆喜义。云何了知句差别。谓能了知异门异相训释言词品类差别。云何了知次第。谓能了知解释次第成立次第圆满次第。云何了知道理。谓能了知四种道理。一观待道理。二证成道理。三作用道理。四法尔道理。云何了知略义。谓能了知此是蕴相应语。此是界处缘起处非处谛相应语。此是念住等相应语乃至此是八圣支道相应语。此是业相应语。此是烦恼相应语。此是增上戒等学相应语。

复次云何知时。谓由五相故。一通达正现在前杂染故。二通达将现在前杂染故。三通达不染污位故。四等起对治作意故。五对治作意故

复次云何知量。谓于所食所饮所啖乃至广说。当知此中略说二种断随顺性。一任持随顺性。二精进随顺性。任持随顺性者。谓于所食所饮所啖所尝善知其量。精进随顺性者。谓于若行若住乃至广说。善知其量。此中云何于所食等善知其量。谓于受取及受用中皆善知量。于受取中善知量者。谓于此时应受。从此应受。此所应受。齐此应受。何时应受。谓日初分即于此时为受用故。从何应受。谓除五种非所行处。何所应受。谓清净物如来所许。除酒肉等所不应饮不应食物。齐何应受。谓知量而受。勿令自损或损于他。于受用中善知量者。谓如所受于此时中应可受用。于何时中应可受用。谓如前说日之初分是受用时。于何处所应可受用。谓于好处或居道场或在聚落。何所应受用。谓如前说清净物等。齐何应受用。谓善知量应可受用。勿令饥恼勿不顺断。勿令诸界起不平等。云何于勤精进善知其量。谓于此时此处此事齐此。应勤精进。于何等时应勤精进。谓于应行时而行。乃至于应解睡眠时而解睡眠。于何处所应勤精进。谓于闲林或在道场。或居内院或经行处应修精进。于何等事应修精进。谓应勤行勤住乃至勤解睡眠劳惓齐何应修所有精进。谓善知量而修精进。勿因此故太沉太举

复次云何善知刹帝利众。谓善了知刹帝利众如是名如是种。如是姓如是食。乃至如是寿量边际。如是乃至善知长者居士等众。云何善知诸沙门众。谓能善知彼如是名。此是少年此是长年此是耆年。此持经者乃至此是能持论者。善知此是瑜伽师等。

复次云何善知我于是中应当往诣乃至应默。谓若略说为此应往乃至应默。及如此应往乃至应默。何所为故诣在家众乃至应默。谓为乞求资生众具。或复为令未信者信信者增长。或为慰问遭重疾病受众苦者。或为开解诸愁忧者。或为和好展转怨对互相违者。或为随顺他所作事。或复为他之所劝请。或为随从轨范亲教同梵行者。或为经营僧所作事。是故应往乃至应默。云何了知应如是往。谓如声闻地已说其相。云何了知应如是住。谓往诣已不应即入。至内门侧伏慢而住。或无疑虑徐入其家。至相见处从容而住。先言慰问含笑开颜。远离嚬蹙方申爱语。云何了知应如是坐。谓佛开许随其所有如法之座以正威仪端严而坐。云何了知应如是语。谓善了知如时如理如量寂静质直而语。时有三种。一者乐闻非不乐闻。不乐闻者。谓如有一或饥或渴或身疲倦。或风热等之所逼恼。是名初时。二者安住如法威仪非非威仪。或复有一虽乐欲闻非威仪。住非威仪者。谓不应立为坐者说。除彼重病。如别解脱经广说其相。是第二时。三者其心无有染恼非染恼心。染恼心者。谓如有一其心匆遽于彼彼事增上勤劬。或荒或乱或复浑浊。或他仆使或作业者。或复杀者敌者怨者。是第三时。理有三种。谓有求请。如法求请。如量求请。方为宣说如法。为说有义利说。由三种相当知如量。一不乱不杂而有所说。二圆满文句宣说诸法。三凡所宣说言词不重谓不重说。所有言词若诸语言无用非义尚不少说。何况多说。当知寂静亦有三种。一威仪寂静。二言音寂静。三其心寂静。威仪寂静者。谓诸根寂静无有躁扰亦不高举。支节不动而有所说。言音寂静者。谓有所说声不太高。亦不太急。心寂静者。谓虽触恼亦不生愤而有所说。况不触恼。又无染心而有所说。又质直语亦有三种。谓如时语时乃至寂静语时。或由宿习方便任性而语。或由现法串习加行作意而语。或由爱乐学处以思择力。而自制伏方有所说。于一切时无有虚诳。若隐若显所言无二。云何了知应默。谓善了知于五时中应当默然。一者说者正说语时。若彼听者故作异言现相諠乱。尔时说者宜当默然。二者说者正说语时。若彼听者拨言且止吾不欲闻。尔时说者宜当默然。三者说者正说语时。若彼听者于说者所起求过心。发违诤言现相乖背。尔时说者宜当默然。四者施主以衣食等来相屈请。尔时受者宜当默然而许可之。五者若有敌论者来现相较论。尔时论者宜当默然听其言说

复次且由三相应自了知己所有信乃至是善男子。一由依处故。二由自性故。三由时分故。云何由依处故了知己信。谓如实知若事是信之所依处。信缘彼生当知彼事决定是我信所依处。云何由自性故了知己信。谓如实知软中上品己所有信。云何由时分故了知己信。谓如实知我于某时已得是信。如了知信如是。戒等辩等为后皆当了知。此中信是趣入支。戒是入已奢摩他支。闻是毗钵舍那支。舍是奢摩他毗钵舍那资粮支。内思所成慧及他随顺教授教诫。是能摄受奢摩他毗钵舍那支。依止此故证奢摩他毗钵舍那。及能证得诸沙门果。于自所证诸深细义。若有欲加而生疑惑。为断疑故如自所证为彼宣说。又为降伏诸敌论者故须有辩。于他身语邪行起时。须有忍辱柔和所摄善男子性。复次由三因缘发生不信。一由不正知三宝功德故。二行外道见故。三未遇诸佛及圣弟子三种神变。随其一种所调伏故

复次由三因缘不能数往寂静园林。一放逸懈怠所拘执故。二多事业故。三信顺人故

复次由三因缘为性不好造诣于他。一性无畏故。二性高慢故。三依文字故。由三因缘为性不好亲近于他。一性不黠利故。二性非福田故。三无极欲乐故。由三因缘为性不好请问于他。一于法不善故。二于义不善故。三于二俱不善故。由三因缘不能审听。一多寻伺故。二多物务故。三多诸盖缠杂染心故。由三因缘为性不能决定任持。一不听闻故。二恶听闻故。三覆慧胜慧故。由三因缘为性不能观察诸法。一乐着戏论故。二爱居愦闹故。三不成就审察慧故。由三因缘为性不能法随法行。一由顾惜身命。二由即彼增上力故乐着利养。三由乐着恭敬。由三因缘不乐修行利他之行。一性是下劣种姓故。二悲微薄故。三无势力故。如是白品与上相违应知其相

复次诸圣弟子非一众多种种游观其事可得。所谓河滨游观。山谷游观。鬼趣游观。如是等类种种游观其事可得。问何因缘故诸大声闻已得神通。乃往鬼趣诘问诸鬼自先业报。为为除自疑故。为为饶益众生故。若为除自疑者。已得神通不应道理。若为饶益众生者。当说云何饶益众生。答为饶益众生故。谓欲饶益此诸饿鬼及余众生。何以故。由神通力令诸饿鬼忆念宿世。自说先身所作恶业深生厌悔。因为说法便能领悟。由此因缘速离鬼趣。如是说名饶益诸鬼。已得神通诸大声闻。闻彼所说种种所受不可爱果先世恶业。乃还人间展转宣告。他既闻已心生厌患断恶修善。如是说名利余众生

复次由六种相当知欲行诸色名粗。云何六相说彼名粗。一众多故粗。二沉重故粗。三不净故粗。四坚强故粗。五变坏故粗。六不随心转故粗。

于此地中余决择文更不复现。又独觉地诸决择文亦不复现

瑜伽师地论卷第七十一瑜伽师地论卷第七十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之一

如是已说声闻地等决择。菩萨地决择。我今当说

谓如成立声闻种性。当知成立菩萨种性亦复如是

复次有十发心。谓世俗受发心。得法性发心。不决定发心。决定发心。不清净发心。清净发心。羸劣发心。强盛发心。未成果发心。已成果发心。世俗受发心者。谓诸菩萨未入菩萨正性离生所有发心。得法性发心者。谓诸菩萨已入菩萨正性离生。及回向菩提诸声闻等所有发心。不决定发心者。谓非彼种性。设彼种性复退还法所有发心。与此相违当知名为决定发心。不清净发心者。谓如有一或随他转。或被陵逼不揆不量。或怖王难或怖贼难。或怖鬼难或怖退转。或为活命或为利养恭敬因缘或复矫诳。如是等类而发心者。当知皆名不清净发心。与此相违而发心者。名清净发心。羸劣发心者。谓如有一已发心菩萨。贪嗔痴缠所蔽伏故。舍于正行处于邪行。与此相违名强盛发心。未成果发心者。谓从胜解行地乃至第十地所有发心。已成果发心者。谓如来地所有发心。如世尊言。我已解脱难行之行。我于一切难行之行极善解脱。自正愿满亦令于他趣证菩提。此十发心。几染污几不染污等广决择文更不复现。复次有四种心。菩萨应当恒常随护。一闻思所成心。二悲心。三资粮心。四修所成心

复次菩萨有九正行。依于自义及与他义。一于生死正行。二于有情正行。三于自己正行。四于诸欲正行。五于身语意业正行。六于不应损恼有情正行。七于无间修善法正行。八于内心奢摩他正行。九于增上慧法毗钵舍那正行。云何菩萨于生死中行于正行。谓如病者于所有病于辛苦乐。云何菩萨于诸有情行于正行。谓如良医于有病者。云何菩萨于自体上行于正行。谓如善巧家长于未成就幼童。云何菩萨于诸欲中行于正行。谓如商主行于商路于诸财货。云何菩萨于身语意业行于正行。谓如浣染衣者于诸衣服。云何菩萨于不应损恼有情行于正行。谓如慈父于己膝上放失便利婴孩小儿。云何菩萨于无间修诸善法中行于正行。谓如求火者施功于燧。云何菩萨于内心奢摩他中行于正行。谓如其主于能致财可委付者。云何菩萨于增上慧法毗钵舍那中行于正行。谓如善幻者于诸幻事。余决择文更不复现。复次若于五种有情众中。起邪行时。说名无哀无愍无有伤叹。一于乞求者。二于危厄者。三于有恩者。四于乐乐者。五于乐法者。言乞求者。略有五种。一求饮食。二求衣服。三求房舍。四求病缘医药资具。五求救护。其危厄者。亦有五种。一住艰乏者。二住迷乱者。三来归依者。四相投委者。五来拜觐者。其有恩者亦有五种。一母。二父。三妻子。四奴婢仆使。五朋友兄弟亲属宰官。其乐乐者亦有五种。一爱乐事业兴盛乐。二爱乐事业兴盛不乖离乐。三爱乐时节变异苦远离乐。四爱乐解疲倦乐。五爱乐求升进乐。其乐法者亦有五种。一乐说正法。二乐受持读诵。三乐论议决择。四乐教授教诫。五乐法随法行。此中邪行者。谓于是中或作加行故。或不作加行故。或不饶益加行故。或中庸加行故。应知其相。复次于有情中有五种不堪任性。若诸有情成就此者。诸佛如来尚难化度。况诸菩萨。或复余者。诸佛如来虽欲于彼作义利乐。然彼不能领受所作义利乐事。又于所作能为障碍。况诸菩萨。或复余者。何等为五。一于清净无堪任性。二于加行无堪任性。三于彼果成办无堪任性。四于加行及彼果成办无堪任性。五于摄受饶益无堪任性。于清净无堪任性者。谓如有一本性无有般涅槃法。于加行无堪任性者。谓如有一同般涅槃法相续已熟。于此无间造作积集。能障正加行业。由此因缘于现法中无有堪能修正方便。于彼果成办无堪任性者。谓如有一同般涅槃法相续未熟。不作不集能障正加行业由此因缘无有功能成办彼果。于加行及彼果成办无堪任性者。谓如有一同般涅槃法相续未熟。于此无间造作积集。能障正加行业。由此因缘俱无堪能。于摄受饶益无堪任性者。谓如有一于此无间造作积集。能感定受贫穷匮乏苦恼之业。由此因缘于现法中无有堪能令彼巨富无匮安乐。与此相违当知五种有堪任性

复次若欲了知真实义者。当先了知略有五事嗢拖南曰

  总举别分别　　有实世俗事
  若生若异等　　相行等色等

云何五事。一相。二名。三分别。四真如。五正智。何等为相。谓若略说所有言谈安足处事。何等为名。谓即于相所有增语。何等为分别。谓三界行中所有心心所。何等为真如。谓法无我所显圣智所行非一切言谈安足处事。何等为正智。谓略有二种。一唯出世间正智。二世间出世间正智。何等名为唯出世间正智。谓由此故声闻独觉诸菩萨等通达真如。又由此故彼诸菩萨于五明处善修方便。多住如是一切遍行真如智故。速证圆满所知障净。何等名为世间出世间正智。谓声闻独觉以初正智通达真如已。由此后所得世间出世间正智。于诸安立谛中。令心厌怖三界过患爱味三界寂静。又由多分安住此故。速证圆满烦恼障净。又即此智未曾得义名出世间。缘言说相为境界义亦名世间。是故说为世间出世间。世尊依此密意说如是言。我说有世间智。有出世间智。有世间出世间智。若分别所摄智。唯名为世间。初正智所摄智。唯名出世间。第二正智所摄智。通名世间出世间

问相当言有耶。当言无耶。答当言是有。问为如自性差别假立故立如是当言有耶。答如是当言无。问为如分别所行境如是当言有耶。答如是当言有。如是菩萨于相有性得善巧故。于诸相中善记为有善记为无。善记为亦有亦无。善记为非有非无。彼由如是善记别故。远离增益损减二边。行于中道善说法界。问此相为以言说义当言是有。为以离言说义当言是有。答俱由二义当言是有。何以故。若如语言安立足处。如是以言说义当言是有。若如自性差别假立不成就义。如是以离言说义当言是有。如相名分别亦尔。问真如正智当言有耶。当言无耶。答当言是有。问相当言实有。当言假有。答实有行中当言实有。假有行中当言假有。有相诸行亦有二种。问名当言实有。当言假有。答当言假有。唯于相中假施设故。问分别当言实有。当言假有。答二种俱有。问真如当言实有。当言假有。答当言实有。胜义摄故。问正智当言实有。当言假有。答当言俱有。此中智是实有。若智眷属诸心心所亦名为智。说之为假。故有二种。问相当言世俗有。当言胜义有。答当言世俗有。由二因缘故。一杂染起故。二施设器故。问名当言世俗有。当言胜义有。答当言世俗有。由三因缘故。一杂染起故。二施设器故。三言说所依故。问分别当言世俗有。当言胜义有。答当言世俗有。由四因缘故。一杂染起故。二施设器故。三言说随眠故。四言说随觉故。问真如当言世俗有。当言胜义有。答当言胜义有。是清净所缘境性故。问正智当言世俗有。当言胜义有。答初正智当言胜义有。第二正智当言俱有

问相当言谁所生。答当言相所生及先分别所生。问名当言谁所生。答当言补特伽罗欲所生。问分别当言谁所生。答当言分别所生及相所生。问真如当言谁所生。答当言无生。问正智当言谁所生。答当言由听闻正法如理作意正智得生

问相与名当言异。当言不异。答俱不可说。何以故。俱有过故。异有何过。名应实有。不异有何过。若取相时应亦取名。问相与分别当言异。当言不异。答俱不可说。何以故。俱有过故。异有何过。分别应非相为性。不异有何过。离分别外所有诸相应以分别为性。问相与真如。当言异当言不异。答俱不可说。何以故。俱有过故。异有何过。诸相之胜义应非即真如。又修观者应舍诸相别求真如。又于真如得正觉时。不应于相亦得正觉。不异有何过。如真如无差别。一切相亦应无差别。又得相时应得真如。又得真如时亦如得相应不清净。如诸行上有无常苦无我共相。虽复是有而不可说与彼诸行若异不异。又如身心粗重轻安。虽复是有而不可说与彼身心若异不异。又如善恶无记法中种子。虽有而不可说与彼诸法若异不异。何以故。俱有过故。又如虚空遍一切故于诸色处虽有虚空而不可说与彼诸色若异不异。何以故。俱有过故。异有何过。不遍一切故。虚空应无常。不异有何过。离色虚空应无所有。此中道理如其所应当知亦尔。声闻乘中有处世尊依于诸行显示不异亦非不异记别道理。如说苾刍取非即蕴亦不离蕴。此中欲贪说名为取。不异有何过。诽谤蕴中善无记法不清净过。异有何过。于诸取中增益常性不清净过。如相与真如不异非不异道理。名分别正智与真如当知亦尔。问相与正智。当言异当言不异。答如与分别俱不可说。问名与分别。当言异当言不异。答当言异。问名与正智。当言异当言不异。答当言异。问分别与正智。当言异当言不异。答当言异。问相有何相。答分别所行相。问名有何相。答言说所依相。问分别有何相。答相为所行相。问真如有何相。答正智所行相。问正智有何相。答真如为所行相

问相有何行相。答应知此相有种种行相无量行相。由分别行相种种无量故。谓色相心相。心所有相。心不相应行相。无为相。蕴相界相处相。缘起相处非处相。根相谛相。念住相正断相神足相。根相力相。觉支相道支相。行迹相法迹相。奢摩他相毗钵舍那相。举相舍相缘相依相。地相水相火相风相空相识相。此世界相彼世界相。日相月相。那落迦相。傍生相饿鬼相。人相四大王众天相。三十三天相。夜摩天相。睹史多天相。乐化天相。他化自在天相。初静虑相。第二静虑相。第三静虑相。第四静虑相。空无边处相。识无边处相。无所有处相。非想非非想处相。起相尽相。有相非有相。杂染相清净相。见闻觉知相。已得寻求相。心随寻伺相。如是等类余无量相。复有六相。一有相相。二无相相。三狭小相。四广大相。五无量相。六无所有相。云何有相相。谓解了事名分别所有相。云何无相相。谓不解了事名分别所有相。云何狭小相。谓欲界事分别所有相。云何广大相。谓色界事分别所有相。云何无量相。谓空识无边处无色界事分别所有相。云何无所有相。谓无所有处无色界事分别所有相。复有余五相。一相相。二名相。三分别相。四真如相。五正智相。复有余二相。一本性相。二影像相。云何本性相。谓先分别所生。及相所生。共所成相。云何影像相。谓遍计所起。胜解所现。非住本性相。问名有何行相。答由相势力亦有种种无量行相。又若略说有十二种。一假说名。二实事名。三种类相应名。四各别相应名。五随德名。六假立名。七共所知名。八非共所知名。九显了名。十不显了名。十一总名。十二别名。问分别有何行相。答由相名势力故亦有种种无量行相。若略说者当知有七种。一有相分别。二无相分别。三于境界任运分别。四寻求分别。互伺察分别。六染污分别。六无染污分别。问真如有何行相。答其相不可说行相。问正智有何行相。答若出世间正智亦有其相。不可说行相。若世间出世间正智。有取安立谛行相

复次若相若影像。若显现若有。若戏论若萨迦耶。若有为若思所造。若缘生如是等是相差别。若名若想。若施设若假言说。若世俗若假立。若言论如是等是名差别。若分别若思惟。若遍计若邪道。若邪行若越流。若不正取如是等是分别差别。若真如若实性。若谛性若无颠倒性。若不颠倒性若无戏论界。若无相界若法界。若实际如是等是真如差别。若正智若正慧。若正觉若正道。若正行若正流。若正取如是等是正智差别

问如是五事。几色几心。几心所有。几心不相应行。几无为。答相通五种。名唯心。不相应行分别正智。通心及心所有。真如唯无为

问如是五事。几蕴所摄。几非蕴所摄。答三蕴所摄。相摄不摄。真如不摄

问如是五事。几界处所摄。几非界处所摄。答一切皆是界处所摄

问如是五事。几缘起所摄。几非缘起所摄。答三缘起摄。相摄不摄。真如不摄。如缘起摄。处非处摄及与根摄当知亦尔

问如是五事。几谛所摄。几非谛所摄。答谛有二种。一安立谛。二非安立谛。安立谛者。谓四圣谛。非安立谛者。谓真如。此中三是安立谛所摄。相亦摄亦不摄。真如唯非安立谛所摄。问如是五事。几因缘所摄。几等无间缘。几所缘缘。几增上缘所摄。答相一切缘所摄。名等无间缘所不摄。分别正智四缘所摄。真如唯所缘缘摄

问如是五事。几法依所摄。几义依。几了义经依。几智依所摄。答相三依所摄。名唯法依所摄。如相分别亦尔。真如智所行故义依所摄。正智唯智依所摄

问如是五事。几有色几无色。答相通二种。分别正智唯无色。名与真如俱非二种。是假有故不可说故。如有色无色。有见无见有对无对亦尔

问如是五事。几有漏几无漏。答相通二种。二唯有漏。二唯无漏。真如漏尽所缘义故名无漏。非漏尽相义故。正智漏尽对治义故名无漏

问如是五事。几有为几无为。答相通二种。三唯有为。真如唯无为。诸行寂静所缘义故。非诸行寂静相义故

问如是五事。几有诤几无诤。答相通二种。二唯有诤。二唯无诤。如有漏无漏此中道理当知亦尔。如有诤无诤如是。有爱味无爱味依耽嗜依出离当知亦尔

问如是五事。几世间几出世间。答三是世间。真如是出世间。正智一分唯出世间。一分通世间出世间。真如一切言说戏论寂静所缘义名出世间。非超过言说戏论相义故。如世间出世间。堕摄非堕摄当知亦尔

问如是五事。几内几外。答相通二种。名唯是外。分别生所摄故通二种。真如非二种。如分别。正智亦尔

问如是五事。几粗几细。答三通二种。真如唯细。难识义故。非相渐减极略义故。正智唯细。行细义故

问如是五事。几劣几胜。答三通二种。真如唯胜。清净所缘义故。非从下劣胜进相义故。正智唯胜。真如为所行义故

问如是五事。几远几近。答一由处远时远故俱通二种。名分别正智由时远故皆通二种。真如由二故俱非二种。以无为故

问如是五事。几有执受几无执受。答相通二种。名分别正智无执受。真如俱非二种问如是五事。几同分几彼同分。答相通二种。余非二种。唯依有色诸根建立同分彼同分故

问如是五事。几因几非因。答四是因。真如非因。如因非因。果非果有因非有因。有果非有果当知亦尔

问如是五事。几是异熟几非异熟。答相通二种。名非异熟。分别通二种。真如俱非二种。正智非异熟

问如是五事。几有异熟几非有异熟。答相通二种。名非有异熟。分别通二种。真如俱非二种。正智定非有异熟。问如是五事。几有所缘几无所缘。答相通二种。名无所缘。分别正智俱有所缘。真如俱非二种。如有所缘无所缘。相应不相应。有行无行。有依无依当知亦尔

问如是五事。几有上几无上。答四有上。真如无上。无为清净所缘义故

问如是五事。几去来今几非去来今。答四通三种。真如非三种

问如是五事。几欲界系几色界系。几无色界系几不系。答欲色界系三无色界系亦尔。正智一种若唯出世间是不系。若世间出世间通系不系。真如俱非二种

问如是五事。几善几不善几无记。答相及分别通三种。名唯无记。真如唯善。清净善巧所缘义故。非能摄生可爱果相义故。正智唯善。问如是五事。几闻所成闻所成境。几思所成思所成境。几修所成修所成境。答相及分别是三种是三种境。名是闻思所成是三种境。真如唯是修所成境。正智是修所成是三种境

问如是五事。几是空是空境。几是无愿是无愿境。几是无相是无相境。答相通三种。亦三种境。名非三种是二种境。分别通三种是二种境。真如非三种是空无相境。正智通三种是空所行境。若无差别。总说为空无愿无相。当知此中通闻思修所成为性。若唯以三摩地名而宣说者。当知此中唯修所成为性。通世出世。若唯以解脱门名而宣说者。当知此中唯出世间修所成为性

问如是五事。几是增上戒增上戒眷属。几是增上心增上心所行。几是增上慧增上慧所行。答相是增上戒增上戒眷属。是增上心慧亦心慧所行。名是戒眷属。亦是增上心慧所行。分别是增上心慧亦心慧所行。是增上戒眷属。真如是增上心慧所行。非三种。正智是增上心慧亦心慧所行。是增上戒眷属

问如是五事。几学几无学几非学非无学。答相及分别通三种。名唯非学非无学。真如亦唯非学非无学。是无为故。正智通学及无学。问如是五事。几见所断几修所断几不断。答相通一切。名唯修所断。分别通见修所断。真如是不断。正智亦唯是不断

问缘相为境修几念住。答四。问缘名为境修几念住。答一法念住。问缘分别为境修几念住。答三。谓受心法念住。问缘真如为境修几念住。答一法念住。又思惟身相真如。亦修坏缘法念住受心法相。当知亦尔。问缘正智为境修几念住。答三。如分别说

问缘相为境。当言能舍已生未生恶不善法。当言不能舍耶。答当言伏断故舍。非永害随眠故舍。如相名分别亦尔。缘真如及正智为境。当言亦由永害随眠故舍

问是五事中。思惟几事能入世间初静虑定。答思惟欲界所系及初静虑所系相名分别。如是思惟下地所系及第二静虑地所系相名分别。能入世间第二静虑。如是所余静虑无色如其所应当知亦尔

问是五事中。思惟几事能入出世初静虑定。答即思惟欲界所系及初静虑地所系相名分别真如。如是乃至无所有处如其所应当知亦尔。非想非非想处。本性法尔唯是世间。问非想非非想处所系相。当言是相耶。答当言无想相。亦名微细相

问是五事中。信等诸法用何为自性。以何为所缘。于何为增上得根名耶。答分别为自性。名相为所缘。于真如正智为增上故而得根名。如根名。力名亦尔。问于何位中得力名耶。答即信等根非不信等之所陵杂。若成不杂法时转名为力。如根及力如是。若得菩提支名为觉支。此是世间觉支。以分别为自性。若依菩提支名为觉支。此是出世间觉支。以正智为自性。真如为所缘。于觉悟安立谛为增上。又正见等诸道支若是世间。如前应知。若出世间。以正智为自性。除诸戒支。安立非安立真如为所缘。于所证得一切漏尽。现法乐住为增上。如诸道支。行迹法迹。奢摩他毗钵舍那等当知亦尔。此中行迹依钝根利根现法乐住已得未得差别建立。若诸法迹依能任持世俗胜义正法差别建立。谓由任持增上戒世俗正法故建立初二。由任持所余增上心增上慧胜义正法故建立后二。又由于所缘境不散乱义故。及观察彼义故。建立奢摩他毗钵舍那

问依能解脱相及粗重二种缚故立八解脱于五事中。用谁为自性。以谁为所缘。于谁为增上。答用世间出世间正智为自性。初及第二于诸色中以显色相及真如相为所缘。第三即诸色中以摄受相及彼真如相为所缘。次四种各以自相为所缘。及彼真如为所缘。最后无所缘。于能引发一切圣神通功德为增上。又修观者于诸色相及无色相。为自在障之所障故。为断彼障起此观行。诸胜处中。前四如初二解脱。后四如第三解脱。由诸色相难可胜故。于此事中能胜伏时。于无色相亦得胜自在。又此中言胜知胜见。谓诸圣者由正作意思惟诸色真如相故得胜知见。若诸异生即不如是。问若尔异生云何名胜。答由三种想故。谓于净不净色由展转相待想展转相待故。于净不净色由展转相随想展转相随故。于净不净色由清净一味想。此最后胜。异生圣者二所共得。又十遍处由胜处所缘力应知其相。此中差别者。亦以大种相为所缘。及彼真如相为所缘。又空识无边处相为所缘。及彼真如相为所缘。若不尔者。由所依止不遍满故。能依不应得成遍满。由彼所缘真如之相所缘境界极遍满故得名遍满。由胜遍满二种势力。令诸解脱亦得清净。又能引发一切众圣神通功德

瑜伽师地论卷第七十二瑜伽师地论卷第七十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之二

复次嗢拖南曰

  思择自性取　　萨迦有世间
  真寻思实智　　密意与次第

问如是五事几谛所摄。答相四安立谛摄。名一苦谛摄。分别三谛摄。除灭谛。真如四非安立谛摄。正智缘安立非安立谛境道谛摄。问诸相是名耶。设名是相耶。答诸名皆是相。有相而非名。谓除名相余四相。余随所应当知亦尔。问诸相皆相相耶。设相相皆相耶。答诸相相皆是相。有相非相相。谓名等四相。问若分别相相一切名相相合相依而分别耶。设分别名相。一切相相相合相依而分别耶。答应作四句。有分别相相非名相相合相依而起分别。谓分别不了其名所有相相。又于诸相已拔名随眠。有分别名相非相相相合相依而起分别。谓分别不了其事所有名相。与上相违是俱句。除上尔所相。是俱非句。问若思惟真如即观真如耶。设观真如即思惟真如耶。答应作四句。有思惟真如非观真如。谓以分别所摄如理作意思惟真如。但见真如相不见实真如。乃至未至正通达位。及通达后作意思惟安立真如。有观真如非思惟真如。谓通达真如时。由胜义故非思惟其相。有思惟真如亦观真如。谓通达后相续思惟非安立真如。有不思惟真如亦非观真如。谓离如理所引作意思惟诸相

问若思惟相即观其相耶。设观其相即思惟相耶。答应作四句。有思惟相不观其相。谓前第二句。有观其相不思惟相。谓前初句。有思惟相亦观其相。谓前第四句。有非思惟相亦非观其相。谓前第三句

问如是五事为摄一切法。为不如是耶。答如是。问彼一切法当言以何而为自性。答诸法自性不可言说。问云何应观彼诸法相。答如幻事相。非全无有。譬如幻事有幻事性无象马车步末尼真珠金银等性。如是诸法体性唯有名相可得。无有自性差别施设显现可得相。由相名相之自性实不可得。如相如是名名自性。分别分别自性。真如真如自性当知亦尔。正智由正智名。正智自性实不可得。何以故。于一切种随言自性不成就故。若谓诸相自性安立即称其量假立名言。此假名言依相而立。是则于相假立名。前应有彼觉。如已立名。又于一相所立名言有众多故。有差别故应有众多差别体性。是故名言依相而立不应道理。若谓诸相如名安立。由名势力相自性起。是则彼相假立名前应无自性。彼既无有。假立名言亦应无有。是故二种俱成无过。又假名言有众多故。有差别故应有众多差别体性。又依他过。由彼诸相但依于他假建立故。是故一切假立名言如其自性。不应道理。犹如所起种种幻类。譬如幻者造作种种幻士夫类。谓男女象马熊罴等类。非彼诸类如其相貌实有体性。如是诸相非称名言有实体性当知亦尔。若谓离彼相及名言二种和合有自性生。彼于诸相或于名言或二中间。应现可得。然不可得。是故此计不应道理。由此因缘随言自性于一切种皆无所有。若谓名言能显自性。亦不应理。若取不取假立名言俱有过故。若取相已假立名言便不成显。若不取相假立名言。无事名言不应道理。又如前说所立名言有众多故。有差别故。则有众多差别体性成大过失又照了喻不相似故不应道理。不相似者照了因缘于一切事无有差别。种种亦尔。能取因缘名言不尔

问不可言中不可言言既现可得。是故法性不可言说。不应道理。又造幻者所造种种幻化形类。虽彼形类非如其性。然有种种能造幻事如其自性。是故譬喻亦不相似。答正立宗时不可言言亦已遮遣。为令觉知如是义故。方便施设譬喻等故。非不相似。虽假名言非如彼性。不可言义非不是有。问若诸相事假立名言则便得有。若不假立则不得有。若如是者喻可相似。不可言计亦应道理。若不尔者。不可言计则为唐捐。答如是由先所起八分别故。于现在世三种事生。如本地分已说其相。即此所生三种事故。复起分别。由此道理诸杂染法展转相续无有断绝。由此因缘其喻相似。分别假立若断灭时。诸杂染法皆可随灭证得圣智。此是量故。不可言计亦不唐捐

问若于尔时分别假立皆悉断灭。即于尔时相事随遣。若尔随一获得圣智。一切相。名。分别。所摄情无情数。内外事物皆应永灭。譬如幻者所作幻事。答相等诸物或由不共分别为因。或复由共分别为因。若由不共分别所起无分别者。彼亦随灭。若共分别之所起者。分别虽无由他分别所任持故。而不永灭。若不尔者。他之分别应无其果。彼虽不灭得清净者。于彼事中正见清净。譬如众多修观行者。于一事中由定心智种种胜解异见可得。彼亦如是

问如是五事。几是所取。几是能取。答三是所取。分别正智亦是能取。亦是所取

问如是五事。当知几种取所行义。答略有三种。一有言有相取所行义。二无言有相取所行义。三无言无相取所行义。此中最初是言说随觉者取所行境。第二是言说随眠者取所行境。第三是于言说离随眠者取所行境。又初二是世俗谛取。最后是胜义谛取。复有远离言说随眠后所得取。通取一切二谛所摄取所行境。谓世出世智以安立谛为所行故。建立彼智通用二谛为所行境。此二种取由二因缘应知。得成世出世性。谓曾得未曾得故。依言说不依言说故问有相之取世间共成。无相之取非所共成。何因何缘名无相取。无因无缘不应道理。答世俗名言熏习取果。是有相取。世所共成能令杂染。胜义智见熏习取果是无相取。非所共成能令清净。是故此二有因有缘。如眼若有翳等过患。便有发毛轮等翳相现前可得。若无彼患便不可得。但有自性无颠倒取。问于无相界若取其相非无相取。若无所取亦不得成无相之取。若尔云何名无相取。答言说随眠已远离故。此取虽复取无相界。不取相故。成无相取。问若无构获云何成取。答虽不构获诸相差别。有所增益然取无相故。得成取。问若无构获无所增益。此取相状云何可知。答取胜义故。取无相故。五种事相皆不显现以为其相。问若不分明可立为取。何故不许诸取灭无。答灭无无有修作义故。非修观者依于灭无有所修作。问若尔云何证知其相。答自内证智之所证知。问若尔何不如其所证如是记别。答此内所证非诸名言安足处故

问若先无有知无相智。由无有故。亦无数习无相智义。无数习故知无相智既无其因。应不得生。答有相亦得为无相因。随顺彼故。如世间智为缘生出世智。有漏智为缘生无漏智。有心定为缘生无心定。此亦如是

问苦等诸智世尊说为得清净因。若苦等智。于苦等谛分别苦等。应成有相。若不分别苦等诸智。便非是有。彼无有故。云何能得毕竟清净。答由无相智增上力故。于诸谛中极善清净通世出世分别智生。即名已断所断烦恼。其无相智是苦等智因正能断灭所断烦恼。于此因中假立果名。即假说此为苦等智。是故无过

问先说所取是能取果。即此能取当言何果。答此二展转更互为果

问若所知境无常。积集相续无量多不现见。云何修观行者缘彼为境。及令转灭。答于彼闻思增上力故得三摩地。由彼因缘。令三摩地五种境界影像现前。即缘此事以为境界。除遣此故彼得转灭

问除遣五种所知境界。当言何相。答无上转依无为涅槃以为其相。云何为涅槃。谓法界清净烦恼众苦永寂静义。非灭无义。问若唯烦恼众苦永寂名为涅槃。何因缘故非灭无义。答如外水界唯离浑浊得澄清性。非离浊时无澄清性。又如真金唯离刚强得调柔性。非离彼时无调柔性。又如虚空唯云雾等翳障寂静得清净性。非彼无时其清净性亦无所有。此中道理当知亦尔

云何名为法界清净。谓修正智故永除诸相证得真如。譬如有人于眠梦中自见其身为大暴流之所漂溺。为欲越渡如是暴流发大精进。即由发起大精进故。欻然便觉。既得觉已于彼暴流都无所见。除相道理当知亦尔。问为即于此言说随眠正断灭时。诸相除遣。为断灭已后方除遣。答断时。遣时。平等平等如秤两头低昂道理。又如画像彩色坏时形相随灭。亦如医等过患愈时发毛轮等相亦随遣。愈时遣时平等平等。此中道理当知亦尔

问修观行者云何除遣所缘境相。答由正定心于诸所知境界影像。先审观察。后由胜义作意力故转舍有相转得无相。此无相转复有五位。一少分位。二遍满位。三有动位。四有加行位。五成满位。问如是成满其相云何。答不为一切烦恼一切灾横所陵杂故。究竟无恼清净所依说名成满。即此又是善清净真实义所行。一切现量所行。一切自在所行

问于此成满建立几乘。齐何时证。答随三种根差别证故建立三乘。然彼二乘用阿耨多罗三藐三菩提乘。以为根本。又彼二乘随缘差别。随所成熟无决定故。证得时量亦不决定。其最后乘要经三种无数大劫。方可证得。依断三种粗重别故。何等名为三种粗重。一恶趣不乐品。在皮粗重。由断彼故不往恶趣。修加行时不为不乐之所间杂。二烦恼障品。在肉粗重。由断彼故一切种极微细烦恼亦不现行。然未永害一切随眠。三所知障品。在心粗重。由断彼故永害一切所有随眠。遍于一切所知境界。无障碍。智自在而转

复次云何立声闻乘。谓三因缘故。一变化故。二誓愿故。三法性故。变化故者。谓随彼彼所化势力。如来化作变化声闻。誓愿故者。谓有补特伽罗。于声闻乘已发誓愿。即建立彼以为声闻。法性故者。谓有补特伽罗。本性已来慈悲薄弱于诸苦事深生怖畏。由此二因于利他事不深爱乐。非为是事乐处生死。彼由安住此法性故。立为声闻。又觉法性故。谓于一切安立谛中。多分修习怖畏行转。由此因缘证得圆满。如声闻乘独觉亦尔。出无佛世而证正觉。与此差别。即上相违三因缘故。应知菩萨

复次云何声闻失坏正法及毗奈耶。谓有声闻。计唯无有烦恼烧然名为寂灭。生大怖畏。谓我当断。我当永坏。我当无有。譬如有人身婴热病于无病中都无识别。谓病愈时举体随灭。便生怖畏。我宁不脱如是热病。是名失坏。由此譬喻失坏声闻当知亦尔。复次云何菩萨失坏大乘。谓有菩萨。闻一切法甚深无性。即执一切烦恼烧然自性本无。谓已无有生死重病。譬如有人于己身中所生热病。谓为无病。于此热病不能解脱。名为失坏。由此譬喻失坏菩萨当知亦尔

问如是五事。几是萨迦耶。几非萨迦耶。答相通二种。二是萨迦耶。一非萨迦耶。真如俱不可说。如萨迦耶。有及世间当知亦尔

问如是五事四种真实。此中何事摄几真实。答世间所成真实。道理所成真实。三事所摄。烦恼障净智所行真实。所知障净智所行真实。二事所摄。问如是五事四种寻思。此中何事摄几寻思。答如理作意相应分别总摄四种

问如是五事四种如实遍智。此中何事摄几如实遍智。答一切皆是正智所摄。问世尊依何密意。说一切法皆无有二。答即依如是所说五事。由俗自性说无自性。由别别相说有自性

问世尊依何密意。说一切法皆无自性。答由依彼彼所化势力故。说三种无自性性。一相无自性性。二生无自性性。三胜义无自性性。云何相无自性性。谓一切法世俗言说自性。云何生无自性性。谓一切行众缘所生缘力故有。非自然有。是故说名生无自性性。云何胜义无自性性。谓真实义相所远离法。此由胜义说无自性性。如观行苾刍于大骨聚生假胜解。不能除遣。于此骨聚胜义无自性相恒无间转。如是应知胜义无自性性。此中五事非由相无自性性故。说无自性。然由生无自性性故。胜义无自性性故。随其所应说无自性。谓相名分别正智。皆由二种无自性性。真如不由无自性性说无自性。是故世尊依此密意。于伽他中说如是言。我说一谛更无第二

问世尊依何密意。说一切法无生无灭本来寂静自性涅槃。答依相无自性性说如是言

问世尊依何密意。说一切法等于虚空。答亦依相无自性性说如是言问世尊依何密意。说一切法皆如幻等。答依生无自性性。胜义无自性性说如是言问世尊依何密意。说等随观色乃至识有无常耶。答依相无自性性说如是言。何以故。欲说等随观常无有故。说等随观有无常。问世尊依何密意。说等随观色乃至识皆有苦耶。答依生无自性性。及胜义无自性性。说如是言

问世尊依何密意。说等随观即彼皆空。答即依生无自性性。胜义无自性性。诸法由远离相无自性性。说如是言。如依远离性说彼为空。依异相性说为无我。当知亦尔

问世尊依何密意。说色乃至识如理观故。审思虑故。乃至观彼非有显现。答依相无自性性说如是言

问世尊依何密意。说彼虚伪不实显现。答依生无自性性及胜义无自性性。说如是言

问世尊依何密意。说如是言。是故今者应知是处。谓于是中眼永寂灭远离色想。乃至意永寂灭远离法想。答都不依于无自性性。说如是言

问世尊依何密意。说由彼故于一切处遣一切想。帝释天等亦不能知。彼依何处而起静虑。答都不依于无自性性说如是言

问世尊依何密意。说能随顺喜忧舍处眼所识色。乃至意所识法中无谛无实无无颠倒无不颠倒。复说有圣出世间谛。答依于一切无自性性。或不依于无自性性说如是言

问世尊依何密意。说静虑者静虑境界。诸佛诸佛境界皆不可思议。答依于一切无自性性。或不依于无自性性。说如是言问如是五事。何缘最初建立其相。乃至最后建立正智。答若无其事施设于名。不应道理。故此次第施设于名。由此名故施设自性。施设差别。故此次第施设分别。由分别故。或分别相。或分别名。或俱分别。由此三法显杂染品。次第圆满。从此乃容修清净品。谓即观彼所有杂染诸法真如。由正智故能正观察。能得清净。由此二种显清净品次第圆满。是故显示如是次第

如是于真实义分中。已说事决择。若欲了知真实义者。于三自性复应修观。嗢拖南曰

  总举别分别　　缘差别依止
  亦微细执着　　如名等执性

云何名为三种自性。一遍计所执自性。二依他起自性。三圆成实自性。云何遍计所执自性。谓随言说依假名言建立自性。云何依他起自性。谓从众缘所生自性。云何圆成实自性。谓诸法真如。圣智所行。圣智境界。圣智所缘。乃至能令证得清净。能令解脱一切相缚及粗重缚。亦令引发一切功德。问遍计所执自性缘何应知。答缘于相名相属应知。问依他起自性缘何应知。答缘遍计所执自性执应知。问圆成实自性缘何应知。答缘遍计所执自性于依他起自性中毕竟不实应知。世尊于余经中说缘不执着遍计所执自性应知此性者。依得清净说。不依相说。今此义中当知依相说。问遍计所执自性有几种。答略有五种。一遍计义自性。二遍计名自性。三遍计杂染自性。四遍计清净自性。五遍计非杂染清净自性。云何遍计义自性。谓有四种。一遍计自相。二遍计差别相。三遍计所取相。四遍计能取相。遍计自相者。谓遍计此事是色自性。乃至此事是识自性。此事是眼自性。乃至此事是法自性。遍计差别相者。谓遍计此色是可意。此色是不可意。此色是非可意非不可意。此色是有见。此色是无见。此色是有对。此色是无对。此色是有漏。此色是无漏。此色是有为。此色是无为。如是等类差别道理。遍计此色所有差别。如色如是余蕴一切处等当知亦尔。遍计所取相者。谓遍计此色是眼所取。此是耳鼻舌身意所取。又复遍计此受想行识是欲界意所取。此是色界意所取。此是无色界意所取。此是不系意所取。遍计能取相者。谓遍计此色是色能取。此色是声香味触能取。又复遍计此受想行识是色能取。此是声香味触法能取

云何遍计名自性。谓有二种。一无差别。二有差别。无差别者。谓遍计一切一切法所有名。有差别者。谓遍计此名为色。此名为受。此名为想。此名为行。此名为识。如是等类无量无数差别法中各各别名

云何遍计杂染自性。谓遍计此色有贪有嗔有痴。不能远离贪嗔痴系。又与信等一切善法而不相应。又复遍计此受此想此行此识。有贪有嗔有痴。不能远离贪嗔痴系。又与信等一切善法而不相应

云何遍计清净自性。谓与上相违当知其相。云何遍计非杂染清净自性。谓遍计此色是所取。此是能取。此受想行识是所取。此是能取。又于一切无记法中遍计所有无记诸法。复次遍计所执自性当知复有五种。一依名遍计义自性。二依义遍计名自性。三依名遍计名自性。四依义遍计义自性。五依二遍计二自性

云何依名遍计义自性。谓遍计此色事名有色实性。此受想行识事名有受想行识实性。云何依义遍计名自性。谓遍计此事名色或不名色。此事名受想行识。或不名受想行识。云何依名遍计名自性。谓不了色事。分别色名而起遍计。不了受想行识事。分别受想行识名而起遍计

云何依义遍计义自性。谓不了色名。由不了名分别色事而起遍计。不了受想行识名。由不了名分别受想行识事而起遍计

云何依二遍计二自性。谓遍计此事是色自性名之为色。此事是受想行识自性名受想行识

复次遍计所执自性执当知略有二种。一加行执。二名施设执。加行执当知复有五种。一贪爱加行故。二嗔恚加行故。三合会加行故。四别离加行故。五舍随与加行故。名施设执当知复有二种。一非文字所作。二文字所作。非文字所作者。谓执此为何物。云何此物。此物是何。此物云何。文字所作者。谓执此为此物。此物如是或色。乃至或识或有为。或无为。或常或无常。或善或不善。或无记如是等。复次微细执着当知五种。一于无常常执。二于苦乐执。三于不净净执。四于无我我执。五于诸相中遍计所执自性执。复次由五因缘。当知愚夫如名如言于所诠事执有自性。所以者何。谓因问言。此事用何以为自性。答言此事是色自性非是色名。或答言。此事是受想行识自性非受想行识名。复次独处空闲。精勤观察诸法自相共相。寻思此事是色相非色名。或寻思此事是受想行识相非受想行识名。复次于此色事寻求色相。不能得时便生不乐。非求色名不能得时。或于此受想行识事。寻求受想行识相。不能得时便生不乐。非求受想行识名不能得时。复次语于名转。名于义转。此中若名能显自相义。非此能显差别相义。非此能显所取相义。非此能显能取相义。或名乃至能显能取相义。非此能显乃至自相义。若即彼名于自相义转。亦于乃至能取相义转者。此余诸名各别行解随义而转应不可得。此不应理。如是复于各别义转所有名中。若名于自相义转。乃至若名于能取相义转。此名为于有义转耶。为于无义转耶。于有义转且不应理。此不应理。如前观五事中已辩。若于无义转者。是则此名于无相义转。其理便至。若于无相义转此非有义。但能显示自所增益。若取增益即是执着。是故如名如言于所诠事执着自性。道理成就

复次一切愚夫于诸相中名言所缚故。当知如名如言于所诠事妄执自性。问何缘故知于诸相中名言所缚。答由理教故。云何由理。谓若离名言于诸事中喜乐不可得故。若名言俱于诸事中喜乐可得故。是一道理。又复展转相依而生。何以故。事为依止名言得生。名言为依事可得生故。谓诸世间要依有事方得生起名言分别。非于无事起此分别。如是当知事为依止名言得生。如静虑者内静虑时。如如意名言作意思惟。如是如是有所知事。同分影像生起方便运转现在前故。如是当知名言为依事可得生。又于名言修对治时。若安置心于无相界。一切诸相皆不现前。若不安心于无相界。不随所欲。便为诸相漂转其心。由此道理当知于相名言是缚。云何由教。如世尊说

  愚昧思凡夫　　于相为言缚
  牟尼脱言缚　　于相得自在
  清净见行者　　安住于真智
  于自性无得　　不见彼所依
  由真智清净　　说彼为真明
  二执不相应　　故号为无二

又如异生于诸蕴中善知无我。虽观蕴中所建立我但是假有。非不于彼我执随转。由彼随眠未永断故。此中道理当知亦尔

瑜伽师地论卷第七十三瑜伽师地论卷第七十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之三

复次嗢拖南曰

  摄无性知等　　密意等所行
  通达与随入　　差别依为后

问三种自性相等五法。初自性。五法中几所摄。答都非所摄。问第二自性几所摄。答四所摄。问第三自性几所摄。答一所摄。问若依他起自性亦正智所摄。何故前说依他起自性缘遍计所执自性执应可了知。答彼意唯说依他起自性杂染分非清净分。若清净分当知缘彼无执应可了知

复次三种自性三种无自性性。谓相无自性性。生无自性性。胜义无自性性。由相无自性性故。遍计所执自性说无自性。由生无自性性故。及胜义无自性性故。依他起自性说无自性。非自然有性故。非清净所缘性故。唯由胜义无自性性故。圆成实自性说无自性。何以故。由此自性亦是胜义。亦一切法无自性性之所显故

问三种自性几应遍知。答一切。问几应永断。答一。问几应证得。答一

复次由此三种自性。一切不了义经诸隐密义皆应决了。谓诸如来秘密语言。及诸菩萨随无量教秘密语言所有要义。皆由如是三种自性。应随决了。问如经中说无生法忍。云何建立。答由三自性而得建立。谓由遍计所执自性故。立本性无生忍。由依他起自性故。立自然无生忍。由圆成实自性故。立烦恼苦垢无生忍。当知此忍无有退转

复次三种解脱门亦由三自性而得建立。谓由遍计所执自性故。立空解脱门。由依他起自性故。立无愿解脱门。由圆成实自性故。立无相解脱门。问遍计所执自性何等智所行。为凡智耶。为圣智耶。答都非智所行。以无相故。问依他起自性何等智所行。答是二智所行。然非出世圣智所行。问圆成实自性何等智所行。答唯圣智所行

问诸观行者通达遍计所执自性时。当言行于相耶。当言行于无相耶。答若以世间智而通达时。当言行于相。若以出世智而通达时。当言行于无相。如遍计所执自性。依他起自性圆成实自性当知亦尔

问若观行者如实悟入遍计所执自性时。当言随入何等自性。答圆成实自性。问若观行者随入圆成实自性时。当言除遣何等自性。答依他起自性。问遍计所执自性有几种。答随于依他起自性中施设建立自性差别所有分量。即如其量遍计所执自性亦尔。是故当知遍计所执自性无量差别。又于依他起自性中。当知有二种遍计所执自性执。一者随觉。二者串习习气随眠。问依他起自性有几种。答当知如相品类差别。复有二种依他起自性。一遍计所执自性执所起。二即彼无执所起。问圆成实自性有几种。答于一切处皆一味故。圆成实自性无有安立品数差别

问遍计所执自性当言何所依止。答当言依止三事。谓相名分别。问依他起自性当言何所依止。答当言即依遍计所执自性执。及自等流。问圆成实自性当言何所依止。答当言无所安住无所依止

复次嗢拖南曰

  若无有作业　　微细等无体
  生执等了知　　染苦喻分别

问若无遍计所执自性当有何过。答于依他起自性中。应无名言无名言执。此若无者。应不可知杂染清净。问若无依他起自性。当有何过。答不由功用。一切杂染皆应非有。此若无者。应无清净而可了知。问若无圆成实自性。当有何过。答一切清净品皆应不可知

问遍计所执自性能为几业。答五。一能生依他起自性。二即于彼性能起言说。三能生补特伽罗执。四能生法执。五能摄受彼二种执习气粗重。问依他起自性能为几业。答亦五。一能生所有杂染法性。二能为遍计所执自性及圆成实自性所依。三能为补特伽罗执所依。四能为法执所依。五能为二执习气粗重所依。问圆成实自性能为几业。答亦五。由是二种五业。对治生起所缘境界性故

问遍计所执自性当言微细。当言粗耶。答当言微细。如微细难见难了当知亦尔。问依他起自性当言微细。当言粗耶。答当言是粗然难见难了。问圆成实自性当言微细。当言粗耶。答当言极微细。如极微细。极难见极难了当知亦尔

问此三自性几是无体能转有体。答一。问几是有体能转有体无体。答一。问几是有体而非能转。答一

问此三自性几是不生能生于生。答一。问几是生能生生不生。答一。问几是非生不能生生及不生。答一

问遍计所执自性执无执相云何应知。答此有二种。一彼觉悟执或无执。二彼随眠执或无执。若由言说假立名字遍计诸法决定自性。当知是名彼觉悟执。若善了知唯有名者。知唯名故。非彼诸法有决定性。当知是名于彼无执。若未拔彼习气随眠。当知于彼有随眠执。乃至未舍习气粗重。若永断已当知无执。问依他起自性执无执相云何应知。答若由遍计所执自性觉悟执故。复遍计彼所成自性。是名初执。若善了知唯有众相。不遍计彼所成自性。是名无执。若于相缚未永拔者。于诸相中有所得时。名第二执。若于相缚已永拔者。于无相界正了知故。于相无得。或于后时如其所有。而有所得当知无执。问圆成实自性执无执相云何应知。答此无有执。此界非执安足处故。若于此界未得未触未作证中。起得触证增上慢者。当知即是遍计所执。及依他起自性上执

问遍计所执自性当云何知。答当正了知唯有其名。唯遍计执无相无性。无生无灭。无染无净。本来寂静自性涅槃。非过去。非未来。非现在。非系非离系。非缚非解脱。非苦非乐。非不苦不乐。唯是一味遍一切处。皆如虚空。以如是等无量行相。应正了知遍计所执自性。问依他起自性当云何知。答当正了知一切所诠有为事摄。云何一切所诠事耶。所谓蕴事。界事。处事。缘起事。处非处事。根事。业事。烦恼事。随烦恼事。生事。恶趣事。善趣事。产生事。色类事。四大王众天事。乃至他化自在天事。梵众天事。乃至色究竟天事。空无边处事。乃至非想非非想处事。随信行事随法行事。顺决择分善根事。见道事。修道事。预流果事。乃至阿罗汉果事。独觉事。等正觉事。灭想受事。到彼岸事。念住事。乃至道支事。静虑无量无色定事。修想事。修随念事。解脱胜处遍处事。力无所畏愿智不护念住大悲永害习气。诸相随好。一切种妙智。一切不共佛法事。又当了知。同于幻梦光影。谷响水月。影像及变化等。犹如聚沫犹如水泡。犹如阳焰犹如芭蕉。如狂如醉。如害如怨。如饮尿友喻。如假子喻毒蛇箧。是空无愿远离无取虚伪不坚。如是等类差别无量。问圆成实自性当云何知。答当正了知。如先所说差别之相。所谓真如实际法界。如是等类无量差别。复当了知所余差别。谓无形色不可睹见。无所依住无所攀缘。不可显现不可了别。不可施为不可宣说。离诸戏论无取无舍。如是等类差别无量。问此三自性几自非染能令他染。答一。问几唯自染。答一。问几自清净令他清净。答一。如染当知苦亦尔。问遍计所执自性以何为喻。答譬如虚空。问依他起自性以何为喻。答如害如怨。问圆成实自性以何为喻。答譬如无尽大宝伏藏。

问遍计所执自性由何故遍计。答由依他起自性故。问依他起自性由何故依他。答由因缘故。问圆成实自性由何故圆成实。答由一切烦恼众苦所不杂染故。又由常故

问如说能取真实义慧是无分别。云何应知无分别相。为由不作意故。为由超过彼故。为由无所有故。为由是彼性故。为由于所缘境作加行故。若由无作意故者。彼与如理作意相应不应道理。熟眠狂醉应成此过。若由超过彼故者。云何不与圣教相违。如说三界所有诸心心所皆是分别。若由无所有故者。云何此慧非成非心所。若由是彼性故者。云何此慧非成色自性。及非贯达相。若由于所缘境作加行故者。云何不谤无分别慧离加行性。若如是等皆不应理。云何当知无分别慧。答于所缘境离加行故。此所缘境离有无相诸法真如。即此亦是离诸分别。由先势力所引发故。虽离加行。若于真如等持相应妙慧生时。于所缘相能现照取。是故此慧名无分别。

如是已说真实义分决择。由五因缘当知菩萨所有威德不可思议。何等为五。一者菩萨所有威德超过一切寻思境故。二者菩萨所有威德世间譬喻不可得故。三者菩萨所有威德唯系属善磨莹心故。四者菩萨所有威德与不定地心一向不同分故。五者菩萨所有威德一向系属定地心故

复次于大乘中有十法行。能令菩萨成熟有情。何等为十。谓于大乘相应菩萨藏摄契经等法。书持供养惠施于他。若他正说恭敬听闻。或自玩读或复领受。受已广音而为讽诵。或复为他广说开示。独处空闲思量观察随入修相。问如是十种法行。几是能生广大福德道。答一切。问几是加行道。答一。谓第九。问几净障道。答一。谓第十。如是种类余决择文更不复现。

复次如闻所成地摄大乘中说。大菩提由五种相应。当了知。谓自性故。功能故。方便故。转故。还故。而未分别。今当解释

云何大菩提自性。谓胜声闻独觉转依。当知此转依复有四种相。一生转所依相。二不生转所依相。三善观察所知果相。四法界清净相。生转所依相者。谓佛相续出世间道生转所依。若不尔不得此转依。此道应当不生不转。若远离彼而有此事。未转依时先应有此。不生转所依相者。谓一切烦恼及诸习气不生转所依。若不尔不得此转依。一切烦恼及诸习气便有众缘和合不生不转应不可得。善观察所知果相者。谓此转依是善通达所知真实。所知真如果。若不尔诸佛自性应更观察。更有所断。更有所灭。法界清净相者。谓此转依已能除遣一切相故。是善清净法界所显。若不尔此应无常。应可思议。然此转依是常住相不可思议。复次此不可思议说名无二。由五种相应当了知。一由自性故。二由处故。三由住故。四由一性异性故。五由成所作故

云何由自性故。不可思议。谓或即色或离色。如是不可思议。或即受想行识。或离受想行识。如是不可思议。或即地界或离地界。如是不可思议。或即水界火界风界或离水界火界风界。如是不可思议。或即眼处或离眼处。如是不可思议。或即耳鼻舌身意处。或离耳鼻舌身意处。如是不可思议。或有或非有。如是不可思议云何由处故不可思议。谓或在欲界或离欲界。如是不可思议。或在色界无色界。或离色界无色界。如是不可思议。或在人中或离人中。或在天上或离天上。如是不可思议。或在东方或离东方。或在南西北方上下方维。或离南西北方上下方维。如是不可思议

云何由住故不可思议。谓安住如是如是色类乐住。如是不可思议。安住如是如是色类奢摩他住。如是不可思议。安住有心住。如是不可思议。安住无心住。如是不可思议。安住如是色类圣住。如是不可思议。安住如是色类天住梵住。如是不可思议

云何一性异性不可思议。谓一切佛同安住一无漏界中。为是一性。为是异性。如是不可思议

云何成所作故不可思议。谓如是如是如来同界同智势力勇猛住无漏界。依此转依能作一切有情义利。如是不可思议。此复二因缘故当知不可思议。谓离言说义故。及过语言道故不可思议。又出世间故。无有世间能为譬喻。是故不可思议

云何功能。谓若略说有十自在。说名功能。谓寿自在等如本地分已说

云何加行。谓若略说有四种化说名加行。一未成熟有情令成熟故。作菩萨行化。二已成熟有情令解脱故。于三千大千世界百拘胝赡部洲中。同于一时方便摄受如来之化。三即为彼所化有情作声闻化。四即为彼所化有情作独觉化。当知一切诸佛世尊于此四种变化十事中。遍方界功能无碍

云何为转。当知此转略有二种。一权时转。二毕竟转。权时转者。谓诸有情乃至未成熟。未解脱来诸佛世尊有变化转。毕竟转者。谓如无尽不可思议诸佛自性大光明转。如是能作一切有情所作事转

云何为还。当知此还亦有二种。一权时还。二毕竟还。权时还者。谓所化有情已成熟已解脱故。从此无间诸佛世尊现般涅槃。非毕竟灭。毕竟还者。当知烦恼及诸习气毕竟尽故。彼所依处众苦亦尽

云何能赞叹者于如来所能作饶益。谓随所赞叹但行自利。非由赞叹于如来所有异所作犹如造瓶。何以故。如来隐善极少欲故。复有二种于如来所称扬赞叹甚希奇法。一令赞叹者纯行自利生无量福。二于远离一切所求诸如来所而作饶益。谓于如来所如如赞叹。如是如是摄受自利。如如摄受自利。如是如是名以供养摄受如来。由此因缘生极广大无尽福聚。又诸如来有二种事。一不可意事。二可意事

复次由六种相当知略摄如来功德。一圆满。二无垢。三不动。四无等。五能作有情利益事业。六功能

云何圆满。谓诸如来成就三界及出世间一切功德。彼出世间所有功德超过一切语言行路。是故如来一切歌咏所不能及。由此因缘弥应赞叹。云何无垢。谓诸功德有七种垢。一欲。二见。三疑。四慢。五憍。六随眠。七悭。彼于如来一切永无。何以故。由诸如来所有功德不求他知。谓欲令他知我成就如是功德。又于此德无执着见。又于此德无有疑惑为功德耶为过失耶。又不以己所有功德与他挍量。又不观己所有功德憍醉掉举生欣生喜。非彼功德为诸烦恼之所随眠。永害烦恼并习气故。又于功德无悭吝心。谓勿令他同所证得

云何不动。谓诸外道不能动故。一切魔军不能动故。一切盗贼不能夺故。一切亲属不能坏故。一切国王不能坏故。火水风大不能变故。寿命虽尽亦无退故。由诸如来功德无尽。是故不动

云何无等。谓诸如来所有功德极广大故。极尊胜故。极众多故。大威力故。若净不净一切有情无与等者。是故无等

云何能作有情利益事业。谓舍所得广大无罪所有安乐。方便示现利他加行。是故能作利益他事

云何功能。谓于所作利有情事。不待作愿而圆证故。彼加行智为亲属故。于彼恒时而专志故

复次由五因缘。当知诸天非所归依。何等为五。一由形相故。二由自性故。三由作业故。四由法尔故。五由因果故

云何诸天由形相故。非所归依。谓由不现见无交议故。由形暴恶有怖畏故。由习放逸有贪爱故。由舍利他无悲愍故。由不了知作与不作。于真实义不通达故

云何如来由形相故是真归依。谓由现见有交议故。由形憺怕无怖异故。由无纵逸离贪爱故。由常不舍利有情事有悲愍故。由善了知作与不作。于真实义善通达故

复由五相唯有如来是真归依。何等为五。一为利益一切有情取菩提故。二能善转正法眼故。三于恩怨诸有情所等心利故。四舍一切家宅亲属摄受贪爱根寂静故。五能善解一切疑故

云何诸天由自性故。非所归依。谓彼诸天漏所随故。性非调善能调御他不应道理。如来永离一切漏故。其性调善故。能调御一切有情

云何诸天由作业故。非所归依。谓彼诸天受用诸欲安住为业。损害有情恶业可得。如来广大无垢静虑安住为业。能作有情利益为业

云何诸天由法尔故。非所归依。谓诸世间及出世间吉祥盛事一切皆依自功力故。若离功力。虽于诸天极申敬事。亦不能得。虽不敬事。但作功力必能得故

云何诸天由因果故。非所归依。谓诸天身为由能感天业所得。为由供养诸天故得。为无因得。若由能感天业得者。但应归依自所作业。非彼诸天。若无因得。应归无因。不应归天。若由供养诸天故。得此诸天身。为当但用供养为因。为天为俱。若唯供养天应唐捐随所供养应感天身。若但由天供养徒设。虽不供养天应令彼获得天身。若言俱由。谓以供养摄降诸天随所思愿皆令果遂。若尔七种所思果遂不决定故。不应道理。谓供养缘于所摄受。诸信解者于信解缘。于信解事。于能往趣最胜天身。于能果遂最胜富乐。于能灭坏阿素洛等所有怨敌。及于徙没

复次有四清净。一名清净。二语清净。三自性清净。四形相清净。又此形相有大威德。断诸疑网。能善记别。难化能化。天人所归善能诲导。证出离性制诸外道

复次云何当知色等想事。色等施设是假名有非实物有。谓诸名言熏习之想所建立识。缘色等想事计为色等性。此性非实物有。非胜义有。是故如此色等想法非真实有。唯是遍计所执自性。当知假有。若遣名言熏习之想所建立识。如其色等想事缘。离言说性。当知此性是实物有。是胜义有。此中道理言论成立。如菩萨地应知。若诸名言熏习之想所建立识。缘遍计所执自性为境。即说此性非内非外。非二中间少有可得。非已生。非当生。非正生。非已灭。非当灭。非正灭。本来寂静自性涅槃。何以故。此唯假有非胜义有故。若离名言诸法自性。当知此性凡夫所生邪执为缘。已生当生正生已灭当灭正灭。若未永断未遍知便成杂染。若已永断已遍知。乃成清净。复有四法能令菩萨摄正多闻。谓多闻持。多闻证。多闻果。多闻净。如其次第菩提愿。事善友。思择力。住空闲。应知其相

问诸菩萨意乐界云何。答于诸佛法信解有性所显故。问诸菩萨增上意乐界云何。答于诸佛法信解有德所显故。问诸菩萨胜解界云何。答于诸佛法信解可得所显故。问诸菩萨愍云何。答于苦现前诸有情所随生愍伤故。问诸菩萨悲云何。答于苦因现前诸有情所随生悲哀故。问诸菩萨慧云何。答于所知境通达如所有性故。问诸菩萨智云何。答于所知境通达尽所有性故

复有三种思惟过患。谓不究竟思惟。非处思惟。颠倒思惟

复次如诸菩萨所行惠施当知。此施由七种相乃得清净。谓施物清净。戒清净。见清净。心清净。语清净。智清净。垢清净。如是清净当知一切皆有十相。云何施物清净十相。一广大施。谓众多差别故。二平等施。谓无增无减故。三应时施。谓当彼所乐故。四上妙施。谓色等具足故。五清净施。谓非不净物所杂秽故。六如法施。谓无罪相应故。七随乐施。谓随求者所爱乐故。八利益施。谓随彼所宜故。九或顿或渐施。谓观彼求者故。十无间施。谓无断绝故

云何戒清净十相。一发勤精进所获财物而用惠施。二自手臂力所致财物而用惠施。三离垢污物而用惠施。四如法而施。五如法所得而用惠施。六息除诸恶而行惠施。七调伏诸根而行惠施。八殷重恭敬而行惠施。九自手而施。十于己仆从先行恩养。然后惠施他来求者

云何见清净十相。一不计度我能行施施为我所而行惠施。二不将己挍量于他。谓我是胜是等是劣而行惠施。三不观他当有反报而行惠施。四不观察当来有胜殊妙富乐而行惠施。五不观施全无有果而行惠施。六不观施不相似果而行惠施。七不观施有颠倒果而行惠施。八不观杀害为伴侣善而行惠施。九不观奇变吉祥之相而行惠施。十不为世间声誉称赞而行惠施

云何心清净十相。一怜爱心而行惠施。谓任自性于诸有情。二珍宝心而行惠施。谓于施所。三平等心而行惠施。谓于怨亲及中庸所。四调伏垢心而行惠施。谓于悭垢及蓄积垢。当知不施于他名为悭垢。自不受用名蓄积垢。五欣乐心而行惠施。谓由七相。一于未来求者发喜乐心故。二于已来求者初见便生净信心故。三于正施时生悦豫心故。四生静定心故。五生无足心故。六生不恼害意趣心故。七施已无追悔心故。六忍辱心而行惠施。谓于求者强遮障中能堪忍故。及无厌倦故。七以慈心而行惠施。谓于恼害者。八以悲心而行惠施。谓于有苦者。九以喜心而行惠施。谓于有功德者。十以舍心而行惠施。谓于亲友所

云何语清净十相。一先于施物恣彼乞者。二彼若至时称善来进。三远离嚬蹙平面而视。舒颜含笑先言问讯。四以柔软言共申谈论安慰乞者。五从此无间言当施汝可爱财物欣庆斯施。六正发施言。吾今惠汝。七彼若遮障从容分布不出粗言。八于乞求者若对若背不毁不呰亦无论说。九若无施物正言词谢许得随与。十于乞求者。终不对面呵责驱逐轻笑戏弄。亦不令其改容怀愧

云何智清净十相。一由惠施智清净。二由求者智清净。三由施物智清净。四由施加行智清净。五由以施成熟有情智清净。六由方便善巧智清净。七由诸欲过患智清净。八由除垢智清净。九由于友远离摄受智清净。十由隐覆六方智清净

一由惠施智清净者。谓于施异名。于施体相。于施训辞。于施差别。皆如实知而行惠施。二由求者智清净者。谓于一切有情皆住福田觉而行惠施。于诸胜劣有得有失怨恩等所。能善了知随来求者所乐差别而行施故。又先以诸所施财物。遍于一切有情之类意乐而舍。若诸求者自然取时皆生随喜。三由施物智清净者。谓于一切工巧业处智善巧故。速疾能集所有财物而用惠施。或由善根之所摄受。谓于前生或现法受所感财物而用惠施。或发神通或由法受所致财物而用惠施。或他积集所有财物而用惠施。如劝导他或任彼务

四由施加行智清净者。谓于施加行能善了知。不令求者身心劳倦。自心无染而行惠施。善能分布施来求者。施贫匮者。施无依者。施恶行者。施妙行者。施自仆从。谓若贫乏中财大财随其所应如轨行施。非不如轨

五由施成熟有情智清净者。谓善了知施。能成熟诸有情已而行惠施。以所施物与诸大众普共行施。亦令大众生无量福。又于贫穷乐行施者。以己财物分布与之令其行施。或有不贫内怀悭吝虽欲惠施。而不能用自财布施。即以财物与之令施。或于佛法及僧田中欲有所作。便以财物弃舍与之令彼造作。由此因缘于二门中生无量福

六由方便善巧智清净者。谓或由教导令行惠施。或强力逼令行惠施。或领彼恩令行惠施。或由生故令行惠施。或由神力而行惠施。七由诸欲过患智清净者。谓于诸欲所有过患。如实知已而行惠施。谓于苦蕴中或时了知二种过患。一者现法。二者后法。或时了知五种过患。谓如五种过患经说。或时了知六种过患。谓此诸欲是怖增语如是等类。广说如经。或时了知七种过患。谓知诸欲无常虚伪诳妄失法譬如幻事惑乱愚夫。或时了知八种过患。谓知诸欲如朽骸骨。如经广说。乃至犹如树端熟果

八由除垢智清净者。谓于除遣十四垢业。如实知已而行惠施。此如尸佉落迦经说九由于友远离摄受智清净者。谓能善知远离四种恶友摄受四种善友而行惠施。此亦如尸佉落迦经说

十由隐覆六方智清净者。谓隐覆六方而行惠施。此亦如尸佉落迦经说。云何垢清净十相。一远离懈怠垢而行惠施。谓或内或外。或近或远。或身疲倦或不疲倦。或身羸劣或不羸劣。而常惠施。二远离贪垢而行惠施。谓于财物。三远离嗔垢而行惠施。谓于求者。四远离痴垢而行惠施。谓于因果。五远离障垢而行惠施。言障垢者。谓四种障。一不串习。二匮乏。三耽湎。四观果。六善分布而行惠施。此即远离非道理垢。谓贫乏者于自仆从。若中财者即于彼所及贫苦所。若大财者即于彼所。亦于其余来求者所。七由圆满而行惠施。此即远离诸减少垢。谓事圆满。意乐圆满。事圆满者。复有七相。一施资产事。二施国土事。三施有情事。四施庄严事。五施舍宅事。六施居处事。七施内身事。意乐圆满者。谓于内身及外财宝。获得自性无著意乐。八由清净而行惠施。此即远离不清净垢。谓由十种清净。即无著无取等如本地分广说。九善观察而行惠施。此即远离恶慧垢。谓观察施物。观察意乐。观察其田。观察施物者。谓观察受用胜于积聚。观察惠施胜于受用。何以故。若唯积聚不能自益。不能益他。非现法利非后法利。若诸菩萨唯自受用名自饶益。非饶益他。名现法利。非后法利。若诸菩萨能行惠施。便自发生广大欢喜。名自饶益名饶益他。名现法利名后法利。观察意乐者。当知意乐略有四种。一于因中无倒意乐。二于果中无著意乐。三于有情悲愍意乐。四于一切智智圆满意乐。由如是等诸意乐故。而行惠施。观察田者。当知略由五相。一于是处乞求可得。二于是处已有乞求复加贫匮。三于是处已有贫匮复无依怙。四于是处有无依怙复行恶行。是名为田。五于是处虽无此等。而有修行善行可得。由七种相当知非田。一乞求者极大暴恶曾为怨害。归依怨害而有所求。二劝为善事终不能得。三心怀染污为染污事而有乞求。四为损恼而有乞求。五乞求者或自是魔或魔所魅非处乞求。六乞求父母。或复随一非所施物。七能为无义。由此等相当知是名观察非田。十具方便德而行惠施。此即远离无方便过失垢。此中方便者。谓串习施。不顾身命。悲愍有情。真实义智无上菩提胜解教导。强力逼迫。处任恩报。生及神力

瑜伽师地论卷第七十四瑜伽师地论卷第七十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之四

复次当知菩萨毗奈耶略有三聚。初律仪戒毗奈耶聚。如薄伽梵为诸声闻所化有情略说毗奈耶相。当知即此毗奈耶聚。云何摄善法戒毗奈耶聚。谓诸菩萨于摄善法戒勤修习时。略于六心应善观察。何等为六。一轻蔑心。二懈怠俱行心。三有覆蔽心。四勤劳倦心。五病随行心。六障随行心。若诸菩萨于善法中。所有轻心无胜解心及陵蔑心名轻蔑心。若有懒堕憍醉放逸所缠绕心。名懈怠俱行心。若贪欲等随有一盖。或诸烦恼及随烦恼所缠绕心。名有覆蔽心。若住勇猛增上精进。身疲心倦映蔽其心。名勤劳倦心。若有诸病损恼其心。无有力能不堪修行。名病随行心。若有喜乐谈论等障。随逐其心。名障随行心。菩萨于此六种心中。应正观察。我于如是六种心中。为有随一现前行耶。为无有耶。于前三心。菩萨一向不应生起。设已生起不应忍受。若有忍受而不弃舍。遍于一切。皆名有罪。勤劳倦心现在前时。由此心故舍善方便。若为暂息身心疲恼。当于善法多修习者。当知无罪。若于一切毕竟舍离。谓我何用精勤修习如是善法。令我现在安住此苦。若如是者当知有罪。病随行心现在前时。菩萨于此无有自在。不随所欲修善加行。离复忍受而无有罪。障随行心现在前时。若不随欲堕在其中。或观此中有大义利。虽复忍受而无有罪。若随所欲故入其中。或观是中无有义利。或少义利而故忍受。当知有罪。如是六心前三生已而忍受者。一向有罪。病随行心。虽复忍受。一向无罪。余之二心若生起已而忍受者。或是有罪或是无罪。若诸菩萨于作有情利益戒中勤修习时。当正观察六处摄行。所谓自他。财衰。财盛。法衰。法盛。是名六处。言财衰者。谓衣食等未得不得得已断坏。与此相违当知财盛。言法衰者。谓越所学。于先未闻胜义所摄如来所说微妙法句。不得听闻。如不听闻先所未闻。如是于先所未思惟不得思惟。有听闻障有思惟障。设得闻思寻复忘失。于所未证修所成善。而未能证。设证还退。与此相违当知法盛。此中菩萨作自法衰。令他财盛。此不应为。如令财盛。法盛亦尔。此中义者越学所摄。及能随顺越学所摄。或于证法退失所摄。当知法衰。又诸菩萨作自财衰令他财盛。若此财盛不引法衰。此则应为。若引法衰。此不应为。如令财盛法盛亦尔。又诸菩萨作自财盛。令他财盛。此则应为。如令财盛。法盛亦尔。又诸菩萨作自法盛。令他财盛。此则应为。如令财盛。法盛亦尔。于如是事若不修行名为有罪。若正修行是名无罪

如是且说菩萨所受三种律仪略毗奈耶。菩萨于中常应作意思惟修学。若有于此三种所受菩萨戒中。随有所阙当知非护。当言不护菩萨律仪。不当言护此三种戒。由律仪戒之所摄持令其和合。若能于此精勤守护。亦能精勤守护余二。若有于此不能守护。亦于余二不能守护。是故若有毁律仪戒。名毁一切菩萨律仪。若有为令他了知故。随顺他故由他劝导受菩萨戒。非自所起增上意乐。随观随察。自生净信。于诸有情住怜愍心。爱乐善法受菩萨戒。当言。此非真实防护。亦非圆满修习善法。亦不能得彼果胜利。与此相违当知乃名真实防护亦能获得彼果胜利

复次若有不舍如是律仪。当知余生亦得随转非彼舍者。又舍因缘略有四种。一者决定发起受心不同分心。二者若于有所识别大丈夫前故意发起弃舍语言。三者总别毁犯四种他所胜法。四者若以增上品缠总别毁犯随顺四种他所胜法。由此因缘当知弃舍菩萨律仪。若有还得清净受心。复应还受。复次若有出家菩萨。除三衣外所有长物。佛所听畜身所受用顺安乐住。若故思择施来求者。当知无罪。若顾善品非悭贪障而不施者。亦无有罪。诸有叶纸已书正法。有婴儿慧众生来乞。若施与之当知有罪。若劝他施亦名有罪。除作是心。我今惠彼欲试其人于甚深法堪受持不。能信解不。如是无罪。若以叶纸书似正法及外道论。或先已书授彼信解众生手中。或劝他与当知有罪。菩萨唯应劝彼弃舍手中异论。或令书写诸佛圣教。或自欲知彼不坚实不应开示。或有叶纸犹未书写。有来求乞尔时菩萨应问彼言。汝今何用如是物。为彼若答言我欲转卖以充食用。若此叶纸为书正法则不应与。有财物者应施价直。若无价直二俱不与。亦无有罪。彼若答言我求此物为书正法。即以叶纸应施与之。仍告彼言随意受用。彼若欲书下劣典籍。不与无罪。如书下劣书等亦尔。若欲书写最胜经典。不施与者当知有罪。若诸菩萨于己有恩诸有情所。随顺恩想相续发起亲友意乐。以有染心方便摄受。欲为朋党。当知有罪。或于有怨诸有情所。随顺怨想相续。发起怨仇意乐。有秽浊心当知有罪。或于无恩无怨诸有情所相续。发起中庸。意乐放舍意乐。当知有罪。若有现前求欲出家。随顺观察时。有过患却有过患不度出家当知无罪。若有安住怜愍彼心。虽度出家亦无有罪。如说出家受具足戒。与作依止。摄为徒众当知亦尔。由如是等所有行相。当知菩萨三种戒蕴皆得圆满

复次先已广说施等。今当略说。谓诸菩萨所有布施。略与五种功德相应得入布施到彼岸数。何等为五。一者无著。二者无恋。三者无罪。四无分别。五者回向。如施戒等当知亦尔。无著者。谓于一切种施等障法中。无有挂碍。无恋者。谓于有染及彼果中。心无系着。无罪者。谓远离一切种施等随烦恼。无分别者。谓于施等不观遍计所执自性。回向者。谓以一切施等诸行。愿得阿耨多罗三藐三菩提果。如是菩萨由此五德。摄受一切波罗蜜多名菩萨施。乃至名菩萨慧。名一切施。乃至名一切慧。名艰难施。乃至名艰难慧。广说一切嗢拖南颂。皆随决了一切。皆如本地分说

复次于施波罗蜜多。由内及外有十随烦恼。对治彼故得施波罗蜜多十种清净。如菩萨地已说。由增一次第。依于外门有五随烦恼。一遍染恼性。二弃舍性。三不持可乐性。四意望不圆满性。五不成熟性。依于内门有五随烦恼。一不出离性。二杂染恼性。三不劣薄性。四现前堕性。五尽灭法性。复次前戒品中已说十种尸罗清净。当知初一是意乐清净。余九是加行清净。于加行中复有五种。一无间缺加行。二遍修治加行。三回向加行。四助伴加行。五守护加行。第二第三为初加行。第四为第二加行。第五为第三加行。第六第七第八第九为第四加行。第十为第五加行

复次忍波罗蜜多十清净中。当知略有二种清净。谓前九种名思择力清净。其第十种名修习力清净。思择力清净复有四种。一远离罪生清净。二彼不现行清净。三无罪生清净。四远离彼因缘清净。一种二种三种三种如其次第。不忍因缘复有三种。一无惭。二无愧。三无哀愍性

复次精进波罗蜜多有十清净。一安处清净。二纯熟清净。三策发清净。四方便清净。五不虚时住清净。六不艰辛住清净。七出离清净。八摄受助伴清净。九速疾神通清净。十无尽性清净。复次静虑波罗蜜多有十清净。一清净清净。二无漏清净。三根本方便清净。四证得根本清净。五自在方便清净。六住自在清净。七引发神通自在清净。八成熟有情自在清净。九降伏外道自在清净。十无上离系清净。复次慧波罗蜜多有五清净。一通达诸相清净。二通达缘起清净。三通达教导清净。四通达士用清净。五通达证得清净

复次云何菩萨于身住循身观。谓于相身循环观真如身。如于身。于受心法随其所应当知亦尔。云何菩萨为令未生恶不善法得不生故生欲。乃至广说。谓于真如境系心令住。为令一切相及粗重未得现前。内未生者得不生故生欲。乃至广说。如令未生得不生故。如是。已生已得现前于内生者为令断故。于能对治所有善法。未生令生。已生令住。乃至广说。当知此中于念住位最初系心置所缘境。次于所缘令心安住。勤修正断。次得定已复令此定善圆满故。于神足中勤修加行。定圆满已为令一切相及粗重得离系故。依信等根修加行道。加行道中根是下品。力是上品。如是正修加行道已。次得觉支通达实际。达实际已次修道支。渐渐乃至证得阿耨多罗三藐三菩提。于一切障皆得解脱

复次相粗重缚当知差别有十四种。一根缚。二境缚。三有情展转更相爱缚。四建立缚。谓器世间诸所有根依之而转故名建立。五于所知境无智缚。六于能知智无智缚。七后有爱缚。八无有爱缚。九执着不平等因及无因缚。十证得增上慢缚。十一执着遍计所执自性缚。十二执着补特伽罗自性缚。十三补特伽罗遍知增上慢缚。十四法遍知增上慢缚。复次依空勤修念住菩萨。略于六种妄想缚中。当令其心速得解脱。云何名为六种想缚。所谓于身乃至于法发起内想。是初想缚。即于是中发起外想。是第二想缚。即于是中起内外想。是第三想缚。若于十方无数无量诸有情界愿令解脱修习念住。此中诸想是第四想缚。若由此故于身等境循观而住。此中诸想是第五想缚。即于身等循观住者。此中诸想是第六想缚。即于此中循环观故。复有十一后后想缚。云何十一后后想缚。谓于身等住循身等观者。于诸杂染清净谛中所起第一义想。是名初缚。即于杂染第一义中所起造作想。是第二缚。即于清净第一义中所起无造作想。是第三缚。即于无造作第一义中所起常想。是第四缚。即于造作杂染中所起流转想。是第五缚。即于常中所起无变异想。是第六缚。即于流转中由有苦有变异故所起苦性想。是第七缚。即于此中由生灭住异自相故。自相有变异故所起彼自相想。是第八缚。即于无变异及有变异第一义中所起。能摄染污清净一切法想。是第九缚。即于杂染清净一切法中。所有我无染净想。是第十缚。即于杂染清净诸法。所起无自性相想。是第十一缚。由诸菩萨于此后后诸行想缚所知境界正观察故。能依于空善修念住。令心解脱。于此想缚得解脱故。一切想缚皆得解脱

复次于大乘中或有一类恶取空故。作如是言。由世俗故一切皆有。由胜义故一切皆无。应告彼言。长老何者世俗。何者胜义。如是问已彼若答言若一切法皆无自性是名胜义。若于诸法无自性中自性可得。是名世俗。何以故。无所有中建立世俗假设名言而起说故。应告彼曰。汝何所欲名言世俗为从因有自性可得。为唯名言世俗说有。若名言世俗从因有者。名言世俗从因而生而非是有。不应道理。若唯名言世俗说有。名言世俗无事而有。不应道理。又应告言。长老何缘诸可得者此无自性如是。问已彼若答言颠倒事故。复应告言。汝何所欲此颠倒事为有为无。若言有者。说一切法由胜义故皆无自性。不应道理。若言无者。颠倒事故。诸可得者此无自性。不应道理

复次当知由五相故思择大乘经起因缘说。谓为于说者生恭敬故起第一说。为摄众故起第二说。为于正法生尊重故起第三说。为叙事故起第四说。为欲宣说真实义故。及多所作故起第五说

复次依十二处自相共相观故。有十种无颠倒道。能证所有不共佛法。当知此中六种观自相。四种观共相。谓于十二处眼等名言假立相中。能遍了知唯名言相。是名第一无颠倒道能证所有不共佛法。复次于十二处能遍了知摄受虚妄分别种种生相。是名第二无颠倒道能证所有不共佛法。复次于十二处能遍了知依因转相。是名第三无颠倒道能证所有不共佛法。复次于十二处能遍了知相坏转相。是名第四无颠倒道能证所有不共佛法。复次于十二处能遍了知清净转相。是名第五无颠倒道能证所有不共佛法。当知此中依二种业有二清净。一生起清净。二寂灭清净。复次于十二处能遍了知所有名言安足处相。是名第六无颠倒道能证所有不共佛法。如是六种观察自相。复次即于如是十二处中。能遍了知共相自性。是名第七无颠倒道能证所有不共佛法。复次即于如是十二处中能遍了知共相无分别所行相。是名第八无颠倒道能证所有不共佛法。复次即于如是十二处中能遍了知共相出世法所行相。是名第九无颠倒道能证所有不共佛法。复次即于如是十二处中。能遍了知共相清净因相。是名第十无颠倒道能证所有不共佛法。如是四种观察共相

复次当知由八殊胜于诸住地后后转胜。一意乐殊胜。二心清净殊胜。三悲殊胜。四波罗蜜多殊胜。五成熟有情殊胜。六见诸佛往趣承事供养殊胜。七生殊胜。八神力殊胜。复次胜义谛有五种相。一离名言相。二无二相。三超过寻思所行相。四超过诸法一异性相。五遍一切一味相

此胜义谛离名言相。及无二相。当知如解深密经中。如理请问菩萨问解甚深义密意菩萨言。最胜子。言一切法无二一切法无二者。何等一切法。云何为无二。解甚深义密意菩萨。告如理请问菩萨曰。善男子。一切法者略有二种。一者有为。二者无为。是中有为非有为非无为。无为亦非无为非有为。最胜子。如何有为非有为非无为。无为亦非无为非有为。善男子。言有为者。乃是本师假施设句。若是本师假施设句。即是遍计所集言辞所说。若是遍计所集言辞所说。即是究竟种种遍计言辞所说。不成实故。非是有为。善男子。言无为者。亦堕言辞。设离有为无为。少有所说其相亦尔。然非无事而有所说。何等为事。谓诸圣者以圣智圣见离名言故。现等正觉。即于如是离言法性。为欲令他现等觉故。假立名想。谓之有为。善男子。言无为者。亦是本师假施设句。若是本师假施设句。即是遍计所集言辞所说。若是遍计所集言辞所说。即是究竟种种遍计言辞所说。不成实故非是无为。善男子。言有为者。亦堕言辞。设离无为有为。少有所说其相亦尔。然非无事而有所说。何等为事。谓诸圣者以圣智圣见离名言故。现等正觉。即于如是离言法性。为欲令他现等觉故。假立名想。谓之无为。最胜子。如何此事彼诸圣者。以圣智圣见离名言故。现等正觉。即于如是离言法性。为欲令他现等觉故。假立名想。或谓有为或谓无为。善男子。如善幻师或彼弟子。住四衢道积集瓦砾草叶木等。现作种种幻化事业。所谓象身马身。车身步身。末尼真珠。琉璃螺贝。璧玉珊瑚。种种财谷库藏等身。若诸众生愚痴顽钝恶慧种类无所晓知。于瓦砾草叶木等上诸幻化事。见已闻已作如是念。此所见者实有象身。实有马身车身步身。末尼真珠。琉璃螺贝。璧玉珊瑚。种种财谷库藏等身。如其所见。如其所闻。坚固执着随起言说。唯此谛实余皆愚妄。彼于后时应更观察。若有众生非愚非钝。善慧种类有所晓知。于瓦砾草叶木等上诸幻化事。见已闻已作如是念。此所见者无实象身。无实马身车身步身。末尼真珠。琉璃螺贝。璧玉珊瑚。种种财谷库藏等身。然有幻状迷惑眼事。于中发起大象身想。或大象身差别之想。乃至发起种种财谷库藏等想。或彼种类差别之想。不如所见。不如所闻。坚固执着随起言说。唯此谛实余皆愚妄。为欲表知如是义故。亦于此中随起言说。彼于后时不须观察。如是若有众生是愚夫类。是异生类。未得诸圣出世间慧。于一切法离言法性。不能了知。彼于一切有为无为。见已闻已作如是念。此所得者决定实有有为无为。如其所见。如其所闻。坚固执着随起言说。唯此谛实余皆痴妄。彼于后时应更观察。若有众生非愚夫类。已见圣谛。已得诸圣出世间慧。于一切法离言法性。如实了知。彼于一切有为无为。见已闻已作如是念。此所得者决定无实有为无为。然有分别所起行相。犹如幻事迷惑觉慧。于中发起为无为想。或为无为差别之想。不如所见。不如所闻。坚固执着随起言说。唯此谛实余皆痴妄。为欲表知如是义故。亦于此中随起言说。彼于后时不须观察。如是善男子。彼诸圣者于此事中。以圣智圣见。离名言故。现等正觉。即于如是离言法性。为欲令他现等觉故。假立名想。谓之有为。谓之无为。尔时解甚深义密意菩萨欲重宣此义而说颂曰

  佛说离言无二义　　甚深非愚之所行
  愚夫于此痴所惑　　乐着二依言戏论
  彼或不定或邪定　　流转极长生死苦
  复违如是正智论　　当生牛羊等类中

复次胜义谛超过寻思所行相。当知如解深密经中。法涌菩萨白佛言。世尊。从此东方过七十二殑伽河沙等世界。有世界。名具大名称。是中如来号广大名称。我于先曰从彼佛土发来至此。我于彼佛土曾见。一处有七万七千外道并其师首。同一会坐为思诸法胜义谛相。彼共思议称量观察。遍推求时于一切法胜义谛相。竟不能得。唯除种种意解。别异意解。变异意解。互相违背共兴诤论。口出矛[矛*(替-曰+貝)]。更相[矛*(替-曰+貝)]已刺已。恼已坏已。各各离散。世尊。我于尔时窃作是念。如来出世甚奇希有。由出世故。乃于如是超过一切寻思所行胜义谛相。亦有通达作证可得。说是语已。尔时世尊告法涌菩萨曰。善男子。如是如是如汝所说。我于超过一切寻思胜义谛相。现等正觉。现等觉已为他宣说。显现开解施设照了。何以故。我说胜义。是诸圣者内自所证寻思所行。是诸异生展转所证。是故法涌。由此道理当知。胜义超过一切寻思境相。复次法涌。我说胜义无相所行。寻思但行有相境界。是故法涌。由此道理。当知胜义超过一切寻思境相。复次法涌。我说胜义不可言说。寻思但行言说境界。是故法涌。由此道理当知。胜义超过一切寻思境相。复次法涌。我说胜义绝诸表示。寻思但行表示境界。是故法涌。由此道理当知。胜义超过一切寻思境相。复次法涌。我说胜义绝诸诤论。寻思但行诤论境界。是故法涌。由此道理当知。胜义超过一切寻思境相。法涌。当知譬如有人尽其寿量习辛苦味。于蜜石蜜上妙美味不能寻思。不能比度。不能信解。或于长夜由欲贪胜解诸欲炽火所烧然故。于内除灭一切色声香味触相妙远离乐不能寻思。不能比度。不能信解。或于长夜由言说胜解。乐着世间绮言说故。于内寂静圣默然乐。不能寻思。不能比度。不能信解。或于长夜由见闻觉知表示胜解。乐着世间诸表示故。于永除断一切表示萨迦耶灭究竟涅槃。不能寻思。不能比度。不能信解。法涌。当知譬如有人于其长夜由有种种我所摄受诤论胜解。乐着世间诸诤论故。于北拘卢洲无我所。无摄受。离诤论。不能寻思。不能比度。不能信解。如是法涌。诸寻思者于超一切寻思所行胜义谛相。不能寻思。不能比度。不能信解。尔时世尊欲重宣此义而说颂曰

  内证无相之所行　　不可言说绝表示
  息诸诤论胜义谛　　超过一切寻思相

复次胜义谛超过诸法一异性相。当知如解深密经中。善清净慧菩萨白佛言。世尊甚奇。乃至。世尊善说。如世尊言胜义谛相。微细甚深超过诸法一异性相。难可通达。世尊。我即于此曾见一处有众菩萨等。正修行胜解行地。同一会坐皆共思议胜义谛相。与诸行相。一异性相。于此会中一类菩萨作如是言。胜义谛相与诸行相都无有异。一类菩萨复作是言。非胜义谛相与诸行相都无有异。然胜义谛相异诸行相。有余菩萨疑惑犹豫复作是言。是诸菩萨谁言谛实。谁言虚妄。谁如理行。谁不如理。或唱是言。胜义谛相与诸行相都无有异。或唱是言。胜义谛相异诸行相。世尊我见彼已窃作是念。彼诸善男子愚痴顽钝。不明不善不如理行。于胜义谛微细甚深超过诸行一异性相。不能解了。说是语已。尔时世尊告善清净慧菩萨曰。善男子。如是如是如汝所说。彼诸善男子愚痴顽钝。不明不善不如理行。于胜义谛微细甚深超过诸行一异性相。不能解了。何以故。善清净慧。非于诸行如是行时。名能通达胜义谛相。或于胜义而得作证。何以故。善清净慧。若胜义谛相与诸行相都无异者。应于今时一切异生皆已见谛。又诸异生皆应已得无上方便安隐涅槃。或应已证阿耨多罗三藐三菩提。若胜义谛相与诸行相一向异者。已见谛者于诸行相应不除遣。若不除遣诸行相者。应于相缚不得解脱。此见谛者于诸相缚。不解脱故。于粗重缚亦应不脱。由于二缚不解脱故。已见谛者应不能得无上方便安隐涅槃。或不应证阿耨多罗三藐三菩提。善清净慧。由于今时非诸异生皆已见谛非诸异生已能获得无上方便安隐涅槃。亦非已证阿耨多罗三藐三菩提。是故胜义谛相与诸行相都无异相。不应道理。若于此中作如是言。胜义谛相与诸行相都无异者。由此道理当知。一切非如理行。不如正理。善清净慧。由于今时非见谛者于诸行相。不能除遣。然能除遣。非见谛者于诸相缚不能解脱然能解脱。非见谛者于粗重缚不能解脱。然能解脱。以于二障能解脱故。亦能获得无上方便安隐涅槃。或有能证阿耨多罗三藐三菩提。是故胜义谛相与诸行相一向异相。不应道理。若于此中作如是言。胜义谛相与诸行相一向异者。由此道理当知。一切非如理行。不如正理。复次善清净慧。若胜义谛相与诸行相都无异者。如诸行相堕杂染相。此胜义谛相亦应如是堕杂染相。善清净慧。若胜义谛相与诸行相一向异者。应非一切行相共相名胜义谛相。善清净慧。由于今时胜义谛相。非堕杂染相。诸行共相名胜义谛相。是故胜义谛相与诸行相都无异相。不应道理。又胜义相与诸行相一向异相。不应道理。若于此中作如是言。胜义谛相与诸行相。都无有异。或胜义谛相与诸行相。一向异者。由此道理当知。一切非如理行。不如正理。复次善清净慧。若胜义谛相与诸行相都无异者。如胜义谛相于诸行相无有差别。一切行相亦应如是无有差别。修观行者。于诸行中如其所见如其所闻。如其所觉如其所知。不应后时更求胜义。若胜义谛相与诸行相一向异者。应非诸行唯无我性唯无自性之所显现是胜义相。又应俱时别相成立。谓杂染相及清净相。善清净慧。由于今时一切行相皆有差别。非无差别。修观行者。于诸行中如其所见如其所闻。如其所觉如其所知。复于后时更求胜义。又即诸行唯无我性唯无自性之所显现名胜义相。又非俱时染净二相别相成立。是故胜义谛相与诸行相都无有异。或一向异。不应道理。若于此中作如是言。胜义谛相与诸行相都无有异。或一向异者。由此道理当知。一切非如理行。不如正理。善清净慧。如螺贝上鲜白色性不易施设与彼螺贝一相异相。如螺贝上鲜白色性。金上黄色亦复如是。如箜篌声上美妙曲性不易施设与箜篌声一相异相。如黑沈上有妙香性。不易设施与彼黑沈一相异相。如胡椒上辛猛利性不易设施与彼胡椒一相异相。如胡椒上辛猛利性。诃梨淡性亦复如是。如蠹罗绵上有柔软性。不易施设与蠹罗绵一相异相。如熟酥上所有醍醐不易施设与彼熟苏一相异相。又如一切行上无常性。一切有漏法上苦性。一切法上补特伽罗无我性。不易施设与彼行等一相异相。又如贪上不寂静相。及杂染相不易施设此与彼贪一相异相。如于贪上于嗔痴上当知亦尔。如是善清净慧。胜义谛相不可施设与诸行相一相异相。善清净慧。我于如是微细。极微细甚深。极甚深难通达。极难通达。超过诸法一异性相胜义谛相。现正等觉现等觉已。为他宣说。显示开解。施设照了。尔时世尊欲重宣此义。而说颂曰

  行界胜义相　　离一异性相
  若分别一异　　彼非如理行
  众生为相缚　　及为粗重缚
  要勤修止观　　尔乃得解脱

复次胜义谛遍一切一味相。当知如解深密经中。世尊告长老善现曰。善现。汝于有情界中知几有情怀增上慢。为增上慢所执持故。记别所解。汝于有情界中。知几有情离增上慢。记别所解。长老善现白佛言。世尊。我知有情界中少分有情离增上慢。记别所解。世尊。我知有情界中有无量无数不可说有情怀增上慢为增上慢所执持故。记别所解。世尊。我于一时住阿练若大树林中。时有众多苾刍。亦于此林依近我住。我见彼诸苾刍。于日后分展转聚集。依有所得现观。各说种种相法。记别所解。于中一类由得蕴故。得蕴相故。得蕴起故。得蕴尽故。得蕴灭故。得蕴灭作证故。记别所解。如此一类由得蕴故。复有一类。由得处故。复有一类。得缘起故当知亦尔。复有一类。由得食故。得食相故。得食起故。得食尽故。得食灭故。得食灭作证故。记别所解。复有一类。由得谛故。得谛相故。得谛遍知故。得谛永断故。得谛作证故。得谛修习故。记别所解。复有一类。由得界故。得界相故。得界种种性故。得界非一性故。得界灭故。得界灭作证故记别所解。复有一类。由得念住故。得念住相故。得念住能治所治故。得念住修故。得念住未生令生故。得念住生已坚住不忘倍修增广故。记别所解。如有一类。得念住故。复有一类。得正断故。得神足故。得诸根故。得诸力故。得觉支故当知亦尔。复有一类。得八支圣道故。得八支圣道相故。得八支圣道能治所治故。得八支圣道修故。得八支圣道未生令生故。得八支圣道生已坚住不忘倍修增广故。记别所解。世尊。我见彼已窃作是念。此诸长老依有所得现观。各说种种想法。记别所解。当知彼诸长老一切皆怀增上慢。为增上慢所执持故。于胜义谛遍一切一味相。不能解了。是故世尊。甚奇。乃至世尊。善说。如世尊言胜义谛相微细最微细。甚深最甚深。难通达极难通达。遍一切一味相。世尊。此圣教中修行苾刍。于胜义谛遍一切一味相。尚难通达。况诸外道。尔时世尊告长老善现曰。如是如是善现。我于微细最微细。甚深最甚深。难通达最难通达。遍一切一味相胜义谛。现正等觉。现等觉已。为他宣说显示开解。施设照了。何以故。善现。我已显示于一切蕴中。清净所缘是胜义谛。我已显示于一切处缘起食谛界念住正断神足根力觉支道支中。清净所缘是胜义谛。此清净所缘于一切蕴中。是一味相无别异相。如于蕴中。如是于一切处中乃至一切道支中。是一味相无别异相。是故善现。由此道理当知胜义谛是遍一切一味相。复次善现。修观行苾刍。通达一蕴真如胜义法无我性已。更不寻求各别余蕴诸处缘起食谛界念住正断神足根力觉支道支真如胜义法无我性。唯即随此真如胜义。无二智为依止故。于遍一切一味相胜义谛。审察趣证。是故善现。由此道理。当知胜义谛是遍一切一味相。复次善现。如彼诸蕴展转异相。如彼诸处缘起食谛界念住正断神足根力觉支道支展转异相。若一切法真如胜义法无我性亦异相者。是则真如胜义法无我性。亦应有因。从因所生。若从因生。应是有为。若是有为。应非胜义。若非胜义。应更寻求余胜义谛。善现。由此真如胜义法无我性。不名有因。非因所生。亦非有为。是胜义谛得此胜义更不寻求余胜义谛。唯有常常时。恒恒时。如来出世。若不出世。诸法法性安立。法界安住。是故善现。由此道理。当知胜义谛是遍一切一味相善现。譬如种种非一品类异相色中。虚空无相。无分别。无变异。遍一切一味相。如是异性异相一切法中胜义谛。遍一切一味相。当知亦然。尔时世尊欲重宣此义。而说颂曰

  此遍一切一味相　　胜义诸佛说无异
  若有于中异分别　　彼定愚痴依上慢

瑜伽师地论卷第七十五瑜伽师地论卷第七十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之五

复次心意识相。当知如解深密经中。广慧菩萨请问佛言。如世尊说于心意识秘密善巧菩萨。于心意识秘密善巧菩萨者。齐何名为于心意识秘密善巧菩萨。如来齐何施设彼为于心意识秘密善巧菩萨。说是语已。尔时世尊告广慧菩萨曰。善哉。善哉。广慧。汝今乃能请问如来如是深义。汝今为欲利益安乐无量众生。哀愍世间及诸天人阿素洛等。为令获得义利安乐故。发斯问。汝应谛听。吾当为汝说心意识秘密义。广慧当知于六趣生死。彼彼有情。堕彼彼有情众中。或在卵生。或在胎生。或在湿生。或在化生。身分生起。于中最初一切种子心识成熟。展转和合。增长广大。依二执受。一者有色诸根及所依执受。二者相名分别言说戏论习气执受。有色界中具二执受。无色界中不具二种。复次广慧。此识亦名阿陀那识。何以故。由此识于身随逐执持故。亦名阿赖耶识。何以故。由此识于身摄受藏隐同安危义故。亦名为心。何以故。由此识色声香味触等积集滋长故。复次广慧。阿陀那识为依止。为建立故。六识身转。谓眼识耳鼻舌身意识。此中有识。眼及色为缘生眼识。与眼识俱随行同时同境有分别意识转。有识。耳鼻舌身及声香味触为缘生耳鼻舌身识。与耳鼻舌身识俱随行同时同境有分别意识转。广慧。若于尔时一眼识转。即于此时唯有一分别意识与眼识同所行转。若于尔时二三四五诸识身转。即于此时唯有一分别意识。与五识身同所行转。广慧。譬如大暴水流。若有一浪生缘现前。唯一浪转。若二若多浪生缘现前。有多浪转然此暴水自类恒流无断无尽。又如善净镜面。若有一影生缘现前。唯一影起。若二若多影生缘现前。有多影起。非此镜面转变为影。亦无受用灭尽可得。如是广慧。由似暴流阿陀那识为依止。为建立故。若于尔时有一眼识生缘现前。即于此时一眼识转。若于尔时乃至有五识身生缘现前。即于此时五识身转。广慧。如是菩萨虽由法住智为依止。为建立故。于心意识秘密善幻。然诸如来不齐于此施设。彼为于心意识一切秘密善巧菩萨。广慧。若诸菩萨于内各别如实不见阿陀那。不见阿陀那识。不见阿赖耶。不见阿赖耶识。不见积集。不见心。不见眼色及眼识。不见耳声及耳识。不见鼻香及鼻识。不见舌味及舌识。不见身触及身识。不见意法及意识。是名胜义善巧菩萨。如来施设彼为胜义善巧菩萨。广慧。齐此名为于心意识一切秘密善巧菩萨。如来齐此施设于心意识一切秘密善巧菩萨。尔时世尊欲重宣此义而说颂曰

  阿陀那识甚深细　　一切种子如暴流
  我于凡愚不开演　　恐彼分别执为我

复次一切法相。当知如解深密经中。德本菩萨请问佛言。世尊。如世尊说于诸法相善巧菩萨。于诸法相善巧菩萨者。齐何名为于诸法相善巧菩萨。如来齐何施设彼为于诸法相善巧菩萨。说是语已。尔时世尊告德本菩萨曰。善哉。善哉。德本。汝今乃能请问如来如是深义。汝今为欲利益安乐无量众生。哀愍世间及诸天人阿素洛等。为令获得义利安乐故。发斯问。汝应谛听。吾当为汝说诸法相。谓诸法相略有三种。何等为三。一者遍计所执相。二者依他起相。三者圆成实相。云何诸法遍计所执相。谓一切法名假安立自性差别。乃至为令随起言说。云何诸法依他起相。谓一切法缘生自性。则此有故彼有。此生故彼生。谓无明缘行。乃至招集纯大苦蕴。云何诸法圆成实相。谓一切法平等真如。于此真如诸菩萨众勇猛精进。为因缘故。如理作意。无倒思惟。为因缘故。乃能通达。于此通达渐渐修集。乃至无上正等菩提方证圆满。复次德本。如眩翳人眼中所有眩翳过患。遍计所执相当知亦尔。如眩翳人眩翳众相。或发毛轮蜂蝇苣蕂。或复青黄赤白等相差别现前。依他起相当知亦尔。如净眼人远离眼中眩翳过患。即此净眼本性所行无乱境界。圆成实相当知亦尔。复次德本。譬如清净颇胝迦宝。若与青染色合。则似帝青大青末尼宝像。由邪执取帝青大青末尼宝故。惑乱有情。若与赤染色合。则似虎珀末尼宝像。由邪执取虎珀末尼宝故。惑乱有情。若与绿染色合。则似末罗羯多末尼宝像。由邪执取末罗羯多末尼宝故。惑乱有情。若与黄染色合。则似金像。由邪执取真金像故。惑乱有情。如是德本。如彼清净颇胝迦上所有染色相应。依他起相上遍计所执相言说习气。当知亦尔。如彼清净颇胝迦上所有帝青大青。虎珀末罗羯多金等邪执。依他起相上遍计所执相执。当知亦尔。如彼清净颇胝迦宝。依他起相。当知亦尔。如彼清净颇胝迦上所有帝青大青。虎珀末罗羯多真金等相。于常常时。于恒恒时。无有真实。无自性性。即依他起相上由遍计所执相。于常常时。于恒恒时。无有真实。无自性性。圆成实相当知亦尔。复次德本。相名相应以为缘故。遍计所执相而可了知。依他起相上遍计所执相执以为缘故。依他起相而可了知。依他起相上遍计所执相无执以为缘故。圆成实相而可了知。复次德本。若诸菩萨能于诸法依他起相上。如实了知遍计所执相。即能如实了知一切无相之法。若诸菩萨如实了知依他起相。即能如实了知一切杂染相法。若诸菩萨如实了知圆成实相。即能如实了知一切清净相法。复次德本。若诸菩萨能于依他起相上。如实了知无相之法。即能断灭杂染相法。若能断灭杂染相法。即能证得清净相法。如是德本。由诸菩萨如实了知遍计所执相。依他起相。圆成实相故。如实了知诸无相法。杂染相法。清净相法。如实了知无相法故。断灭一切杂染相法。断灭一切杂染相法故。证得一切清净相法。齐此名为于诸法相善巧菩萨。如来齐此施设彼为于诸法相善巧菩萨。尔时世尊欲重宣此义。而说颂曰

  若不了知无相法　　杂染相法不能断
  不断杂染相法故　　坏证微妙净相法
  不观诸行众过失　　放逸过失害众生
  懈怠住法动法中　　无有失坏可怀愍

复次诸法无自性相。当知如解深密经中。胜义生菩萨。白佛言。世尊。我曾独在静处。心生如是寻思。世尊以无量门曾说诸蕴所有自相。生相。灭相。永断。遍知。如说诸蕴。诸处缘起诸食亦尔。以无量门曾说诸谛所有自相。遍知。永断。作证。修习。以无量门曾说诸界所有自相。种种界性。非一界性永断遍知。以无量门曾说念住所有自相。能治所治。及以修习未生令生。生已坚住不忘倍修增长广大。如说念住。正断神足。根力觉支。亦复如是。以无量门曾说八支圣道所有自相。能治所治。及以修习未生令生。生已坚住不忘倍修增长广大。世尊复说一切诸法皆无自性。无生无灭。本来寂静。自性涅槃。未审。世尊依何密意作如是说。一切诸法皆无自性。无生无灭。本来寂静。自性涅槃。我今请问如来斯义。唯愿如来哀愍。解释说一切法皆无自性。无生无灭。本来寂静。自性涅槃所有密意。说是语已

尔时世尊告胜义生菩萨曰。善哉善哉。胜义生。汝所寻思甚为如理。善哉善哉。善男子。汝今乃能请问如来如是深义。汝今为欲利益安乐无量众生。哀愍世间及诸天人阿素洛等。为令获得义利安乐故。发斯问。汝应谛听。吾当为汝解释所说一切诸法皆无自性无生无灭。本来寂静。自性涅槃所有密意

胜义生。当知我依三种无自性性。密意。说言一切诸法皆无自性。谓相无自性性。生无自性性。胜义无自性性。善男子。云何诸法相无自性性。所谓诸法遍计所执相。何以故。此由假名安立为相。非由自相安立为相。是故说名相无自性性。云何诸法生无自性性。所谓诸法依他起相。何以故。此由依他缘力故有。非自然有。是故说名生无自性性。云何诸法胜义无自性性所谓诸法由生无自性性故。说名无自性性。即缘生法亦名胜义无自性性。何以故。于诸法中若是清净所缘境界。我显示彼以为胜义无自性性。依他起相非是清净所缘境界。是故亦说名为胜义无自性性。复有诸法圆成实相。亦名胜义无自性性。何以故。一切诸法法无我性名为胜义。亦得名为无自性性。以是诸法胜义谛故。无自性性之所显故。由此因缘名为胜义无自性性。善男子。譬如空华。相无自性性当知亦尔。譬如幻像。生无自性性当知亦尔。一分胜义无自性性。当知亦尔。譬如虚空唯是众色无性所显遍一切处。一分胜义无自性性。当知亦尔。法无我性之所显故。遍一切故。善男子。我依如是三种无自性性。蜜意说言一切诸法皆无自性

胜义生。当知我依相无自性性。蜜意说言一切诸法无生无灭。本来寂静。自性涅槃。何以故。若法自相都无所有则无有生。若无有生则无有灭。若无生无灭则本来寂静。若本来寂静则自性涅槃。于中都无少分所有更可令其般涅槃故。是故我依相无自性性。密意说言一切诸法无生无灭。本来寂静。自性涅槃善男子。我亦依法无我性所显。胜义无自性性密意说言一切诸法无生无灭。本来寂静。自性涅槃。何以故。法无我性所显。胜义无自性性。于常常时。于恒恒时。诸法法性。安住无为。一切杂染不相应故。于常常时。于恒恒时。诸法法性安住故无为。由无为故。无生无灭。一切杂染不相应故。本来寂静。自性涅槃是故我依法无我性所显。胜义无自性性密意说言一切诸法无生无灭。本来寂静。自性涅槃

复次胜义生。非由有情界中诸有情类。别观遍计所执自性。为自性故。亦非由彼别观依他起自性。及圆成实自性为自性故。我立三种无自性性。然由有情于依他起自性。及圆成实自性上。增益遍计所执自性故。我立三种无自性性。由遍计所执自性相故。彼诸有情于依他起自性。及圆成实自性中。随起言说。如如随起言说。如是如是由言说熏习心故。或由言说随觉故。或由言说随眠故。于依他起自性。及圆成实自性中。执着遍计所执自性相。如如执着。如是如是于依他起自性。及圆成实自性上。执着遍计所执自性。由是因缘。生当来世依他起自性。由此因缘。或为烦恼杂染所染。或为业杂染所染。或为生杂染所染。于生死中长时驰骋。长时流转。无有休息。或在那落迦。或在傍生。或在饿鬼。或在天上。或在阿素洛。或在人中。受诸苦恼

复次胜义生。若诸有情从本已来。未种善根未清净障。未成熟相续。未多修胜解。未能积集福德智慧二种资粮。我为彼故。依生无自性性宣说诸法。彼闻是已。能于一切缘生行中。随分解了无常无恒。是不安隐变坏法已。于一切行心生怖畏。深起厌患。心生怖畏。深厌患已遮止诸恶。于诸恶法能不造作。于诸善法能勤修习。习善因故。未种善根能种善根。未清净障能令清净。未熟相续能令成熟。由此因缘。多修胜解。亦多积集福德智慧二种资粮。彼虽如是种诸善根。乃至积集福德智慧二种资粮。然于生无自性性中。未能如实了知相无自性性。及二种胜义无自性性。于一切行未能正厌。未正离欲。未正解脱。未遍解脱烦恼杂染。未遍解脱诸业杂染。未遍解脱诸生杂染。如来为彼更说法要。谓相无自性性。及胜义无自性性。为欲令其于一切行能正厌故。正离欲故。正解脱故。超过一切烦恼杂染故。超过一切业杂染故。超过一切生杂染故。彼闻如是所说法已。于生无自性性中。能正信解相无自性性。及胜义无自性性。简择思惟。如实通达。于依他起自性中。能不执着遍计所执自性相。由言说不熏习智故。由言说不随觉智故。由言说离随眠智故。能灭依他起相。于现法中智力所持。能永断灭当来世因。由此因缘。于一切行。能正厌患。能正离欲。能正解脱。能遍解脱烦恼业生三种杂染。复次胜义生。诸声闻乘种性有情。亦由此道此行迹故。证得无上安隐涅槃。诸独觉乘种性有情。诸如来乘种性有情。亦由此道此行迹故。证得无上安隐涅槃。一切声闻独觉菩萨。皆共此一妙清净道。皆同此一究竟清净。更无第二。我依此故。密意说言唯有一乘。非于一切有情界中。无有种种有情种性。或钝根性。或中根性。或利根性有情差别。善男子。若一向趣寂声闻种性补特伽罗。虽蒙诸佛施设种种勇猛加行方便化导。终不能令当坐道场证得无上正等菩提。何以故。由彼本来唯有下劣种性故。一向慈悲薄弱故。一向怖畏众苦故。由彼一向慈悲薄弱。是故一向弃背利益诸众生事。由彼一向怖畏众苦。是故一向弃背发起诸行所作。我终不说一向弃背利益众生事者。一向弃背发起诸行所作者。当坐道场能得无上正等菩提。是故说彼名为一向趣寂声闻。若回向菩提声闻种性补特伽罗。我亦异门说为菩萨。何以故。彼既解脱烦恼障已。若蒙诸佛等觉悟时。于所知障。其心亦可当得解脱。由彼最初为自利益。修行加行。脱烦恼障。是故如来施设彼为声闻种性。复次胜义生。如是于我善说。善制法。毗奈耶。最极清净意乐所说善教法中。诸有情类意解种种差别可得。善男子。如来但依如是三种自性性。由深密意。于所宣说不了义经。以隐密相。说诸法要。谓一切法皆无自性。无生无灭。本来寂静。自性涅槃。于是经中。若诸有情已种上品善根。已清净诸障。已成熟相续。已多修胜解。已能积集上品福德智慧资粮。彼若听闻如是法已。于我甚深密意言说。如实解了。于如是法。深生信解。于如是义。以无倒慧。如实通达。依此通达。善修习故。速疾能证最极究竟。亦于我所深生净信。知是如来应正等觉。于一切法现正等觉。若诸有情已种上品善根。已清净诸障。已成熟相续。已多修胜解未能积集上品福德智慧资粮。其性质直。是质直类。虽无力能思择废立。而不安住自见取中。彼若听闻如是法已。于我甚深秘密言说。虽无力能如实解了。然于此法能生胜解。发清净信。信此经典。是如来说。是其甚深。显现甚深。空性相应。难见难悟。不可寻思。非诸寻思所行境界。微细详审聪明智者之所解了。于此经典所说义中。自轻而住。作如是言。诸佛菩提为最甚深。诸法法性亦最甚深。唯佛如来能善了达。非是我等所能解了。诸佛如来。为彼种种胜解有情。转正法教。诸佛如来无边智见。我等智见犹如牛迹。于此经典。虽能恭敬。为他宣说。书写护持。披阅流布。殷重供养。受诵温习。然犹未能以其修相发起加行。是故于我甚深密意所说言词。不能通达。由此因缘。彼诸有情。亦能增长福德智慧二种资粮。于后相续未成熟者。亦能成熟。若诸有情广说乃至未能积集上品福德智慧资粮。性非质直。非质直类。虽有力能思择废立。而复安住自见取中。彼若听闻如是法已。于我甚深密意言说。无有力能如实解了。于如是法。虽生信解。然于其义随言执着。谓一切法决定皆无自性。决定不生不灭。决定本来寂静。决定自性涅槃。由此因缘。于一切法。获得无见及无相见由得无见无相见故。拨一切相皆是无相。诽拨诸法遍计所执相。依他起相。圆成实相。何以故。由有依他起相。及圆成实相故。遍计所执相。方可施设。若于依他起相。及圆成实相。见为无相。彼亦诽拨遍计所执相。是故说彼诽拨三相。虽于我法起于法想。而非义中起于义想。由于我法起法想故。及非义中起义想故。于是法中持为是法。于非义中。持为是义。彼虽于法起信解故。福德增长。然于非义起执着故。退失智慧。智慧退故。退失广大无量善法。复有有情。从彼听闻。谓法为法。非义为义。若随其见。彼即于法起于法想。于非义中起于义想。执法为法非义为义。由此因缘。当知同彼退失善法。若有有情。不随其见。从彼欻闻一切诸法皆无自性。无生无灭。本来寂静。自性涅槃。便生恐怖生恐怖已。作如是言。此非佛语。是魔所说。作此解已。于是经典。诽谤毁骂。由此因缘。获大衰损。触大业障。由是因缘。我说若有于一切相。起无相见。于非义中。宣说为义。是起广大业障方便。由彼陷坠无量众生。令其获得大业障故。善男子。若诸有情未种善根。未清净障。未熟相续。无多胜解。未集福德智慧资粮。性非质直。非质直类。虽有力能思择废立。而常安住自见取中。彼若听闻如是法已。不能如实解我甚深密意言说。故于此法不生信解。于是法中起非法想。于是义中起非义想。于是法中执为非法。于是义中执为非义。唱如是言。此非佛语。是魔所说。作此解已。于是经典。诽谤毁讟。拨为虚伪。以无量门。毁灭摧伏如是经典。于诸信解此经典者。起怨家想。彼先为诸业障所障。由此因缘。复为如是业障所障。如是业障初易施设。乃至齐于百千俱胝那庾多劫。无有出期。善男子。如是于我善说。善制法。毗奈耶。最极清净意乐所说善教法中。有如是等诸有情类意解种种差别可得。尔时世尊欲重宣此义而说颂曰

  一切诸法皆无性　　无生无灭本来寂
  诸法自性恒涅槃　　谁有智言无密意
  相生胜义无自性　　如是我皆已显示
  若不知佛此密意　　失坏正道不能往
  依诸净道清净者　　唯依此一无第二
  故于其中立一乘　　非有情性无差别
  众生界中无量生　　唯度一身趣寂灭
  大悲勇猛证涅槃　　不舍众生甚难得
  微妙难思无漏界　　于中解脱等无差
  一切义成离惑苦　　二种异说谓常乐

尔时胜义生菩萨。复白佛言。世尊。诸佛如来密意语言。甚奇希有。乃至微妙最微妙。甚深最甚深。难通达最难通达。如是我今领解世尊所说义者。若于分别所行遍计所执相。所依行相中。假名安立以为色蕴或自性相或差别相。假名安立为色蕴生。为色蕴灭。及为色蕴永断遍知。或自性相或差别相。是名遍计所执相。世尊依此施设诸法相无自性性。若即分别所行遍计所执相。所依行相。是名依他起相。世尊依此施设诸法生无自性性。及一分胜义无自性性。如是我今领解世尊所说义者。若即于此分别所行遍计所执相。所依行相中。由遍计所执相不成实故。即此自性无自性性。法无我真如清净所缘。是名圆成实相。世尊依此施设一分胜义无自性性。如于色蕴如是。于余蕴皆应广说。如于诸蕴如是。于十二处一一处中皆应广说。于十二有支一一支中皆应广说。于四种食一一食中皆应广说。于六界十八界一一界中皆应广说。如是我今领解世尊所说义者。若于分别所行遍计所执相。所依行相中。假名安立以为苦谛苦谛遍知。或自性相或差别相。是名遍计所执相。世尊依此施设诸法相无自性性。若即分别所行遍计所执相。所依行相。是名依他起相。世尊。依此施设诸法生无自性性。及一分胜义无自性性。如是我今领解世尊所说义者。若即于此分别所行遍计所执相所依行相中。由遍计所执相不成实故。即此自性无自性性。法无我真如清净所缘。是名圆成实相。世尊。依此施设一分胜义无自性性。如于苦谛如是。于余谛皆应广说。如于圣谛如是。于诸念住正断神足根力觉支道支中一一皆应广说。如是我今领解世尊所说义者。若于分别所行遍计所执相所依行相中。假名安立以为正定。及为正定能治所治。若正定修未生令生。生已坚住不忘。倍修增长广大。或自性相。或差别相。是名遍计所执相。世尊依此施设诸法相无自性性。若即分别所行遍计所执相所依行相。是名依他起相。世尊依此施设诸法生无自性性。及一分胜义无自性性。如是我今领解世尊所说义者。若即于此分别所行遍计所执相所依行相中。由遍计所执相不成实故。即此自性无自性性。法无我真如清净所缘。是名圆成实相。世尊依此施设诸法一分胜义无自性性

世尊。譬如毗湿缚药。一切散药仙药方中皆应安处。如是世尊。依此诸法皆无自性。无生无灭。本来寂静。自性涅槃。无自性性了义言教。遍于一切不了义经皆应安处。世尊。如彩画地遍于一切彩画事业皆同一味。或青或黄或赤或白。复能显发彩画事业。如是世尊。依此诸法皆无自性广说乃至自性涅槃。无自性性了义言教。遍于一切不了义经。皆同一味。复能显发彼诸经中所不了义世尊。譬如一切成熟珍羞诸饼果内投之熟酥更生胜味。如是世尊。依此诸法皆无自性广说乃至自性涅槃。无自性性了义言教。置于一切不了义经。生胜欢喜。世尊。譬如虚空遍一切处皆同一味不障一切所作事业。如是世尊。依此诸法皆无自性广说乃至自性涅槃。无自性性了义言教。遍于一切不了义经。皆同一味不障一切声闻独觉及诸大乘所修事业。说是语已。尔时世尊。叹胜义生菩萨曰。善哉善哉。善男子。汝今乃能善解如来所说甚深密意言义。复于此义善作譬喻。所谓世间毗湿缚药杂彩画地熟酥虚空。胜义生。如是如是更无有异。如是如是汝应受持。胜义生菩萨。复白佛言。世尊初于一时。在婆罗痆斯仙人堕处施鹿林中。唯为发趣声闻乘者。以四谛相转正法轮。虽是甚奇甚为希有一切世间诸天人等先无有能如法转者。而于彼时所转法轮有上有容是未了义。是诸诤论安足处所。世尊在昔第二时中。唯为发趣修大乘者。依一切法皆无自性。无生无灭。本来寂静。自性涅槃。以隐密相。转正法轮。虽更甚奇甚为希有。而于彼时所转法轮。亦是有上有所容受。犹未了义。是诸诤论安足处所。世尊于今第三时中。普为发趣一切乘者。依一切法皆无自性。无生无灭。本来寂静。自性涅槃无自性性。以显了相转正法轮。第一甚奇最为希有。于今世尊所转法轮。无上无容是真了义。非诸诤论安足处所。世尊若善男子或善女人。于此如来依一切法皆无自性。无生无灭。本来寂静。自性涅槃。所说甚深了义言教。闻已信解书写护持供养流布。受诵温习如理思惟。以其修相发起加行生几所福。说是语已。尔时世尊告胜义生菩萨曰。胜义生是善男子或善女人。其所生福无量无数难可喻知。吾今为汝略说少分。如爪上土比大地土。百分不及一。千分不及一。百千分不及一。数算计喻邬波尼杀昙分亦不及一。或如牛迹中水比四大海水。百分不及一。广说乃至邬波尼杀昙分亦不及一。如是于诸不了义经。闻已信解。广说乃至以其修相发起加行所获功德。比此所说了义经教闻已信解所集功德。广说乃至以其修相发起加行所集功德。百分不及一。广说乃至邬波尼杀昙分亦不及一。说是语已

胜义生菩萨复白佛言。世尊。于是解深密法门中。当何名此教。我当云何奉持。佛告胜义生菩萨曰。善男子。此名胜义了义之教。于此胜义了义之教。汝当奉持。说此胜义了义教时。于大会中有六百千众生。发阿耨多罗三藐三菩提心。三百千声闻远尘离垢。于诸法中得法眼净。一百五十千声闻永尽诸漏心得解脱。七十五千菩萨得无生法忍

瑜伽师地论卷第七十六瑜伽师地论卷第七十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之六

复次依法假安立。分别解说瑜伽所摄奢摩他毗钵舍那道。当知如解深密经中。慈氏菩萨白佛言。世尊。菩萨何依何住。于大乘中修奢摩他毗钵舍那。佛告慈氏菩萨曰。善男子。当知菩萨法假安立。及不舍无上正等觉愿为依为住。于大乘中修奢摩他毗钵舍那。世尊如说四种所缘境事。一有分别影像所缘境事。二无分别影像所缘境事。三事边际所缘境事。四所作成办所缘境事。于此四中几是奢摩他所缘境事。几是毗钵舍那所缘境事。几是俱所缘境事。善男子。一是奢摩他所缘境事。谓无分别影像。一是毗钵舍那所缘境事。谓有分别影像。二是俱所缘境事。谓事边际。所作成办

世尊。云何菩萨依此四种奢摩他毗钵舍那所缘境事。能求奢摩他。能善毗钵舍那。善男子。如我为诸菩萨所说法假安立。所谓契经应诵。记别讽诵。自说因缘。譬喻本事。本生方广。希法论议。菩萨于此善听善受。言善通利意善寻思见善通达。即于如所善思惟法。独处空闲。作意思惟。复即于此能思惟心。内心相续作意思惟。如是正行多安住故。起身轻安及心轻安。是名奢摩他。如是菩萨能求奢摩他。彼由获得身心轻安为所依故。即于如所善思惟法内三摩地所行影像。观察胜解舍离心相。即于如是三摩地影像所知义中。能正思择最极思择。周遍寻思周遍伺察。若忍若乐若慧若见若观。是名毗钵舍那。如是菩萨能善毗钵舍那

世尊。若诸菩萨缘心为境内思惟心。乃至未得身心轻安所有作意。当名何等。善男子。非奢摩他作意。是随顺奢摩他胜解相应作意。世尊若诸菩萨乃至未得身心轻安。于如所思所有诸法内三摩地所缘影像。作意思惟。如是作意当名何等。善男子。非毗钵舍那作意。是随顺毗钵舍那胜解相应作意

世尊。奢摩他道与毗钵舍那道。当言有异。当言无异。善男子。当言非有异非无异。何故非有异。以毗钵舍那所缘境心为所缘故。何故非无异。有分别影像非所缘故

世尊。诸毗钵舍那三摩地所行影像。彼与此心当言有异。当言无异。善男子当言无异。何以故。由彼影像唯是识故。善男子。我说识所缘唯识所现故。世尊。若彼所行影像。即与此心无有异者。云何此心还见此心。善男子。此中无有少法能见少法。然即此心如是生时。即有如是影像显现。善男子。如依善莹清净镜面以质为缘还见本质。而谓我今见于影像。及谓离质别有所行影像显现。如是此心生时。相似有异。三摩地所行影像显现。世尊。若诸有情自性而住缘色等心所行影像。彼与此心亦无异耶。善男子。亦无有异。而诸愚夫由颠倒觉于诸影像不能如实知唯是识。作颠倒解。世尊。齐何当言菩萨一向修毗钵舍那。善男子。若相续作意唯思惟心相。世尊。齐何当言菩萨一向修奢摩他。善男子。若相续作意。唯思惟无间心。世尊。齐何当言菩萨奢摩他毗钵舍那和合俱转。善男子。若正思惟心一境性。世尊。云何心相。善男子。谓三摩地所行有分别影像。毗钵舍那所缘。世尊。云何无间心。善男子。谓缘彼影像心。奢摩他所缘。世尊。云何心一境性。善男子。谓通达三摩地所行影像唯是其识。或通达此已。复思惟如性。世尊。毗钵舍那凡有几种。善男子。略有三种。一者有相毗钵舍那。二者寻求毗钵舍那。三者伺察毗钵舍那。云何有相毗钵舍那。谓纯思惟三摩地所行有分别影像毗钵舍那。云何寻求毗钵舍那。谓由慧故。遍于彼彼未善解了一切法中。为善了故作意思惟毗钵舍那。云何伺察毗钵舍那。谓由慧故。遍于彼彼已善解了一切法中。为善证得极解脱故作意思惟毗钵舍那

世尊。是奢摩他凡有几种。善男子。即由随彼。无间心故。当知此中亦有三种。复有八种。谓初静虑乃至非想非非想处。各有一种奢摩他故。复有四种。谓慈悲喜舍四无量中。各有一种奢摩他故

世尊。如说依法奢摩他毗钵舍那。复说不依法奢摩他毗钵舍那。云何名依法。云何复名不依法。善男子。若随所受所思法相。而于其义得奢摩他毗钵舍那。名依法。若不待于所受所思所有法相。但依止他教诫教授。而于其义得奢摩他毗钵舍那。谓观青瘀及脓烂等。或一切行皆是无常。或诸行苦。或一切法皆无有我。或复涅槃毕竟寂静。如是等类奢摩他毗钵舍那名不依法。由依止法得奢摩他毗钵舍那故。我施设随法行菩萨是利根性。由不依法得奢摩他毗钵舍那故。我施设随信行菩萨。是钝根性。世尊。如说缘别法奢摩他毗钵舍那。复说缘总法奢摩他毗钵舍那。云何名缘别法奢摩他毗钵舍那。云何复名缘总法奢摩他毗钵舍那。善男子。若诸菩萨缘于各别契经等法。于如所受所思惟法。修奢摩他毗钵舍那。是名缘别法奢摩他毗钵舍那。若诸菩萨即缘一切契经等法。集为一团一积一分一聚。作意思惟。此一切法随顺真如。趣向真如。临入真如。随顺菩提。随顺涅槃。随顺转依。及趣向彼。若临入彼。此一切法宣说无量无数善法。如是思惟修奢摩他毗钵舍那。是名缘总法奢摩他毗钵舍那

世尊。如说缘小总法奢摩他毗钵舍那。复说缘大总法奢摩他毗钵舍那。又说缘无量总法奢摩他毗钵舍那。云何名缘小总法奢摩他毗钵舍那。云何名缘大总法奢摩他毗钵舍那。云何复名缘无量总法奢摩他毗钵舍那。善男子。若缘各别契经乃至各别论义。为一团等。作意思惟。当知是名缘小总法奢摩他毗钵舍那。若缘乃至所受所思契经等法。为一团等。作意思惟。非缘各别。当知是名缘大总法奢摩他毗钵舍那。若缘无量如来法教。无量法句文字。无量后后慧所照了。为一团等。作意思惟。非缘乃至所受所思。当知是名缘无量总法奢摩他毗钵舍那

世尊。菩萨齐何名得缘总法奢摩他毗钵舍那。善男子。由五缘故。当知名得。一者于思惟时刹那刹那融消一切粗重所依。二者离种种想得乐法乐。三者解了十方无差别相无量法光。四者所作成满。相应净分。无分别相恒现在前。五者为令法身得成满故。摄受后后转胜妙因

世尊。此缘总法奢摩他毗钵舍那。当知从何名为通达。从何名得。善男子。从初极喜地名为通达。从第三发光地乃名为得。善男子。初业菩萨亦于是中随学作意。虽未可叹。不应懈废。世尊。是奢摩他毗钵舍那云何名有寻有伺三摩地。云何名无寻唯伺三摩地。云何名无寻无伺三摩地。善男子。于如所取寻伺法相。若有粗显领受观察诸奢摩他毗钵舍那。是名有寻有伺三摩地。若于彼相虽无鹿显领受观察。而有微细彼光明念领受观察诸奢摩他毗钵舍那。是名无寻唯伺三摩地。若即于彼一切法相。都无作意领受观察诸奢摩他毗钵舍那。是名无寻无伺三摩地。复次善男子。若有寻求奢摩他毗钵舍那。是名有寻有伺三摩地。若有伺察奢摩他毗钵舍那。是名无寻唯伺三摩地。若缘总法奢摩他毗钵舍那。是名无寻无伺三摩地

世尊。云何止相。云何举相。云何舍相。善男子。若心掉举或恐掉举时。诸可厌法作意。及彼无间心作意。是名止相。若心沉没或恐沉没时。诸可欣法作意。及彼心相作意。是名举相。若于一向止道。或于一向观道。或于双运转道。二随烦恼所染污时。诸无功用作意。及心任运转中所有作意。是名舍相

世尊。修奢摩他毗钵舍那诸菩萨众知法知义。云何知法。云何知义。善男子。彼诸菩萨由五种相了知于法。一者知名。二者知句。三者知文。四者知别。五者知总。云何为名。谓于一切染净法中。所立自性想假施设。云何为句。谓即于彼名聚集中。能随宣说诸染净义。依持建立。云何为文。谓即彼二所依止字。云何于彼各别了知。谓由各别所缘作意。云何于彼总合了知。谓由总合所缘作意。如是一切总略为一。名为知法。如是名为菩萨知法。善男子。彼诸菩萨由十种相。了知于义。一者知尽所有性。二者知如所有性。三者知能取义。四者知所取义。五者知建立义。六者知受用义。七者知颠倒义。八者知无倒义。九者知杂染义。十者知清净义。善男子。尽所有性者。谓诸杂染清净法中所有一切品别边际。是名此中尽所有性。如五数蕴。六数内处。六数外处。如是一切。如所有性者。谓即一切染净法中所有真如。是名此中如所有性。此复七种。一者流转真如。谓一切行无先后性。二者相真如。谓一切法补特伽罗无我性。及法无我性。三者了别真如。谓一切行唯是识性。四者安立真如。谓我所说诸苦圣谛。五者邪行真如。谓我所说诸集圣谛。六者清净真如。谓我所说诸灭圣谛。七者正行真如。谓我所说诸道圣谛。当知此中由流转真如。安立真如。邪行真如故。一切有情平等平等。由相真如了别真如故。一切诸法平等平等。由清净真如故。一切声闻菩提。独觉菩提。阿耨多罗三藐三菩提。平等平等。由正行真如故。听闻正法缘总境界胜奢摩他毗钵舍那所摄受慧平等平等。能取义者。谓内五色处。若心意识及诸心法。所取义者。谓外六处。又能取义亦所取义。建立义者。谓器世界。于中可得建立一切诸有情界。谓一村田。若百村田。若千村田。若百千村田。或一大地至海边际。此百此千。若此百千。或一赡部洲。此百此千。若此百千。或一四大洲。此百此千。若此百千。或一小千世界。此百此千。若此百千。或一中千世界。此百此千。若此百千。或一三千大千世界。此百此千。若此百千。或此拘胝。此百拘胝。此千拘胝。此百千拘胝。或此无数。此百无数。此千无数。此百千无数。或三千大千世界无数。百千微尘量等。于十方面无量无数诸器世界。受用义者。谓我所说诸有情类。为受用故。摄受资具颠倒义者。谓即于彼能取等义。无常计常想倒心倒见倒。苦计为乐。不净计净。无我计我想倒心倒见倒。无倒义者。与上相违能对治彼应知其相。杂染义者。谓三界中三种杂染。一者烦恼杂染。二者业杂染。三者生杂染。清净义者。谓即如是三种杂染所有离系菩提分法。善男子。如是十种当知。普摄一切诸义。复次善男子。彼诸菩萨。由能了知五种义故。名为知义。何等五义。一者遍知事。二者遍知义。三者遍知。四者得遍知果。五者于此觉了。善男子。遍知事者。当知即是一切所知。谓或诸蕴。或诸内处。或诸外处。如是一切。遍知义者。乃至所有品类差别所应知境。或世俗故。或胜义故。或功德故。或过失故。缘故。世故。或生或住或坏相故。或如病等故。或苦集等故。或真如实际法界等故。或广略故。或一向记故。或分别记故。或反问记故。或置记故。或隐密故。或显了故。如是等类。当知一切名遍知义。言遍知者。当知即是能取前二菩提分法。谓诸念住或正断等。得遍知果者。谓贪恚痴断毗柰耶。及贪恚痴一切永断诸沙门果。及我所说声闻如来。若共不共。世出世间所有功德。于彼作证。于此觉了者。谓即于此作证法中。诸解脱智广为他说宣扬开示。善男子。如是五义当知普摄一切诸义

复次善男子。彼诸菩萨由能了知四种义故。名为知义。何等四义。一者心执受义。二者领纳义。三者了别义。四者杂染清净义。善男子。如是四义当知普摄一切诸义复次善男子。彼诸菩萨由能了知三种义故。名为知义。何等三义。一者文义。二者义义。三者界义。善男子言文义者。谓名身等义义者。当知复有十种。一者真实相。二者遍知相。三者永断相。四者作证相。五者修习相。六者即彼真实相等品差别相。七者所依能依相属相。八者即遍知等障碍法相。九者即彼随顺法相。十者不遍知等及遍知等过患功德相。言界义者。谓五种界。一者器世界。二者有情界。三者法界。四者所调伏界。五者调伏加行界。善男子。如是五义当知普摄一切诸义

世尊。若闻所成慧。了知其义。若思所成慧了知其义。若奢摩他毗钵舍那修所成慧了知其义。此何差别。善男子。闻所成慧依止于文。但如其说未善意趣。未现在前随顺解脱。未能领受成解脱义。思所成慧亦依于文。不唯如说亦善意趣。未现在前。转顺解脱。未能领受成解脱义。若诸菩萨修所成慧。亦依于文亦不依文。亦如其说亦不如说。能善意趣。所知事同分三摩地所行影像现前。极顺解脱已。能领受成解脱义。善男子。是名三种知义差别

世尊。修奢摩他毗钵舍那诸菩萨众知法知义。云何为智。云何为见。善男子。我无量门宣说智见二种差别。今当为汝略说其相。若缘总法修奢摩他毗钵舍那所有妙慧。是名为智。若缘别法修奢摩他毗钵舍那所有妙慧。是名为见

世尊。修奢摩他毗钵舍那诸菩萨众。由何作意何等。云何除遣诸相。善男子。由真如作意。除遣法相及与义相。若于其名及名自性。无所得时。亦不观彼所依之相。如是除遣。如于其名。于句于文于一切义。当知亦尔。乃至于界及界自性。无所得时。亦不观彼所依之相。如是除遣

世尊。诸所了知真如义相。此真如相亦可遣不。善男子。于所了知真如义中。都无有相。亦无所得。当何所遣。善男子。我说了知真如义时。能伏一切法义之相。非此了达余所能伏。世尊。如世尊说浊水器喻。不净镜喻。挠泉池喻。不任观察自面影相。若堪任者。与上相违。如是若有不善修心。则不堪任如实观察所有真如。若善修心堪任观察。此说何等能观察心。依何真如而作是说。善男子。此说三种能观察心。谓闻所成能观察心。若思所成能观察心。若修所成能观察心。依了别真如作如是说

世尊。如是了知法义菩萨。为遣诸相。勤修加行。有几种相难可除遣。谁能除遣。善男子。有十种相。空能除遣。何等为十。一者了知法义故。有种种文字相。此由一切法空能正除遣。二者了知安立真如义故。有生灭住异性相续随转相。此由相空及无先后空。能正除遣。三者了知能取义故。有顾恋身相及我慢相。此由内空及无所得空。能正除遣。四者了知所取义故。有顾恋财相。此由外空能正除遣。五者了知受用义。男女承事资具相应故。有内安乐相外净妙相。此由内外空及本性空能正除遣。六者了知建立义故。有无量相。此由大空能正除遣。七者了知无色故。有内寂静解脱相。此由有为空能正除遣。八者了知相真如义故。有补特伽罗无我相。法无我相。若唯识相及胜义相。此由毕竟空。无性空。无性自性空。及胜义空。能正除遣。九者了知清净真如义故。有无为相无变异相。此由无为空无变异空。能正除遣。十者即于彼相对治空性作意思惟故。有空性相。此由空空能正除遣。世尊。除遣如是十种相时。除遣何等。从何等相而得解脱。善男子。除遣三摩地所行影像相。从杂染缚相而得解脱。彼亦除遣。善男子。当知就胜说如是空治如是相。非不一一治一切相。譬如无明非不能生乃至老死诸杂染法。就胜但说能生于行。由是诸行亲近缘故。此中道理。当知亦尔

世尊。此中何等空。是总空性相。若诸菩萨了知是已。无有失坏。于空性相离增上慢。尔时世尊叹慈氏菩萨曰。善哉善哉。善男子。汝今乃能请问如来如是深义。令诸菩萨于空性相无有夫坏。何以故。善男子。若诸菩萨于空性相有失坏者。便为失坏一切大乘。是故汝应谛听谛听。当为汝说总空性相。善男子。若于依他起相及圆成实相中一切品类杂染清净遍计所执相毕竟远离性。及于此中都无所得。如是名为于大乘中总空性相。世尊。此奢摩他毗钵舍那。能摄几种胜三摩地。善男子。如我所说。无量声闻菩萨如来有无量种胜三摩地。当知一切皆此所摄。世尊。此奢摩他毗钵舍那。以何为因。善男子。清净尸罗清净闻思所成正见以为其因。世尊。此奢摩他毗钵舍那以何为果。善男子。善清净心善清净慧以为其果。复次善男子。一切声闻及如来等所有世间及出世间一切善法。当知皆是此奢摩他毗钵舍那所得之果。世尊。此奢摩他毗钵舍那能作何业。善男子。此能解脱二缚为业。所谓相缚及粗重缚。世尊。如佛所说五种系中。几是奢摩他障。几是毗钵舍那障。几是俱障。善男子。顾恋身财是奢摩他障。于诸圣教不得随欲是毗钵舍那障。乐相杂住于少喜足当知俱障。由第一故不能造修。由第二故所修加行不到究竟。世尊。于五盖中几是奢摩他障。几是毗钵舍那障。几是俱障。善男子。掉举恶作是奢摩他障。惛沉睡眠疑是毗钵舍那障。贪欲嗔恚当知俱障。世尊。齐何名得奢摩他道圆满清净。善男子。乃至所有惛沉睡眠正善除遣。齐是名得奢摩他道圆满清净。世尊。齐何名得毗钵舍那道圆满清净。善男子。乃至所有掉举恶作正善除遣。齐是名得毗钵舍那道圆满清净。世尊。若诸菩萨于奢摩他毗钵舍那现在前时。应知几种心散动法。善男子。应知五种。一者作意散动。二者外心散动。三者内心散动。四者相散动。五者粗重散动。善男子。若诸菩萨舍于大乘相应作意。堕在声闻独觉相应诸作意中。当知是名作意散动。若于其外五种妙欲诸杂乱相所有寻思随烦恼中。及于其外所缘境中。纵心流散。当知是名外心散动。若由惛沈及以睡眠。或由沉没。或由爱味三摩钵底。或由随一三摩钵底诸随烦恼之所染污。当知是名内心散动。若依外相。于内等持所行诸相作意思惟。名相散动。若内作意为缘生起所有诸受。由粗重身计我起慢。当知是名粗重散动。世尊。此奢摩他毗钵舍那。从初菩萨地乃至如来地。能对治何障。善男子。此奢摩他毗钵舍那。于初地中。对治恶趣烦恼业生杂染障。第二地中。对治微细误犯现行障。第三地中。对治欲贪障。第四地中。对治定爱及法爱障。第五地中。对治生死涅槃一向背趣障。第六地中对治相多现行障。第七地中。对治细相现行障。第八地中。对治于无相作功用。及于有相不得自在障。第九地中。对治于一切种善巧言词不得自在障。第十地中。对治不得圆满法身证得障。善男子。此奢摩他毗钵舍那。于如来地。对治极微细最极微细烦恼障及所知障。由能永害如是障故。究竟证得无著无碍一切智见。依于所作成满所缘。建立最极清净法身

世尊。云何菩萨依奢摩他毗钵舍那勤修行故。证得阿耨多罗三藐三菩提。善男子。若诸菩萨已得奢摩他毗钵舍那。依七真如。于如所闻所思法中。由胜定心。于善审定。于善思量。于善安立。真如性中内正思惟彼于真如正思惟故。心于一切细相现行。尚能弃舍。何况粗相。善男子。言细相者。谓心所执受相。或领纳相。或了别相。或杂染清净相。或内相。或外相。或内外相。或谓我当修行一切利有情相。或正智相。或真如相。或苦集灭道相。或有为相。或无为相。或有常相。或无常相。或苦有变异性相。或苦无变异性相。或有为异相相。或有为同相相。或知一切是一切已有一切相。或补特伽罗无我相。或法无我相。于彼现行心能弃舍。彼既多住如是行故。于时时间从其一切系盖散动善修治心。从是已后于七真如。有七各别自内所证通达智生。名为见道。由得此故。名入菩萨正性离生生如来家。证得初地又能受用此地胜德。彼于先时由得奢摩他毗钵舍那故。已得二种所缘。谓有分别影像所缘。及无分别影像所缘。彼于今时得见道故。更证得事边际所缘。复于后后一切地中。进修修道。即于如是三种所缘。作意思惟。譬如有人以其细楔出于粗楔。如是菩萨依此以楔出楔加行遣内相故。一切随顺杂染分相。皆悉除遣。相除遣故。粗重亦遣。永害一切相粗重故。渐次于彼后后地中。如炼金法。陶炼其心。乃至证得阿耨多罗三藐三菩提。又得所作成满所缘。善男子。如是菩萨于内止观。正修行故。证得阿耨多罗三藐三菩提

世尊。云何修行引发菩萨广大威德。善男子。若诸菩萨善知六处。便能引发菩萨所有广大威德。一者善知心生。二者善知心住。三者善知心出。四者善知心增。五者善知心减。六者善知方便。云何善知心生。谓如实知十六行心生起差别。是名善知心生。十六行心生起差别者。一者不可觉知坚住器识生。谓阿陀那识。二者种种行相所缘识生。谓顿取一切色等境界分别意识。及顿取内外境界觉受。或顿于一念瞬息须臾。现入多定。见多佛土。见多如来分别意识。三者小相所缘识生。谓欲界系识。四者大相所缘识生。谓色界系识。五者无量相所缘识生。谓空识无边处系识。六者微细相所缘识生。谓无所有处系识。七者边际相所缘识生。谓非想非非想处系识。八者无相识生。谓出世识及缘灭识。九者苦俱行识生。谓那落迦识。十者杂受俱行识生。谓欲行识。十一喜俱行识生。谓初二静虑识。十二乐俱行识生。谓第三静虑识。十三不苦不乐俱行识生。谓从第四静虑乃至非想非非想处识。十四染污俱行识生。谓诸烦恼及随烦恼相应识。十五善俱行识生。谓信等相应识。十六无记俱行识生。谓彼俱不相应识。云何善知心住。谓如实知了别真如。云何善知心出。谓如实知出二种缚。所谓相缚及粗重缚。此能善知应令其心从如是出。云何善知心增。谓如实知能治相缚粗重缚心。彼增长时彼积集时。亦得增长亦得积集。名善知增。云何善知心减。谓如实知彼所对治相及粗重所杂染心。彼衰退时彼损减时。此亦衰退此亦损减。名善知减。云何善知加行。谓如实知解脱胜处及与遍处或修或遣。善男子。如是菩萨于诸菩萨广大威德。或已引发。或当引发。或现引发

世尊。如世尊说。于无余依涅槃界中。一切诸受无余永灭。何等诸受于此永灭。善男子。以要言之。有二种受。无余永灭。何等为二。一者所依粗重受。二者彼果境界受。所依粗重受当知有四种。一者有色所依受。二者无色所依受。三者果已成满粗重受。四者果未成满粗重受。果已成满受者。谓现在受。果未成满受者。谓未来因受。彼果境界受。亦有四种。一者依持受。二者资具受。三者受用受。四者顾恋受。于有余依涅槃界中。果未成满受一切已灭。领彼对治明触生受领受共有。或复彼果已成满受。又二种受。一切已灭唯现领受明触生受。于无余依涅槃界中。般涅槃时。此亦永灭。是故说言于无余依涅槃界中。一切诸受无余永灭

尔时世尊说是语已。告慈氏菩萨曰。善哉善哉。善男子。汝今善能依止圆满最极清净妙瑜伽道。请问如来。汝于瑜伽已得决定最极善巧。吾已为汝宣说圆满最极清净妙瑜伽道。所有一切过去未来正等觉者已说当说皆亦如是。诸善男子若善女人皆应依此勇猛精进当正修学。尔时世尊欲重宣此义。而说颂曰

  于法假立瑜伽中　　若行放逸失大义
  依止此法及瑜伽　　若正修行得大觉
  见有所得求免难　　若谓此见为得法
  慈氏彼去瑜伽远　　譬如大地与虚空
  利生坚固而不作　　悟已勤修利有情
  智者作此穷劫量　　便得最上离染喜
  若人为欲而说法　　彼名舍欲还取欲
  愚痴得法无价宝　　反更游行而乞丐
  于诤諠杂戏论著　　应舍发起上精进
  为度诸天及世间　　于此瑜伽汝当学

尔时慈氏菩萨复白佛言。世尊。于是解深密法门中。当何名此教。我当云何奉持。佛告慈氏。此名瑜伽了义之教。于此瑜伽了义之教。汝当奉持。说此瑜伽了义教时。于大会中有六百千众生。发阿耨多罗三藐三菩提心。三百千声闻远尘离垢。于诸法中得法眼净。一百五十千声闻诸漏永尽心得解脱。七十五千菩萨。获得广大瑜伽作意

瑜伽师地论卷第七十七瑜伽师地论卷第七十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之七

复次依乘假立。分别解说如实大乘。当知如解深密经中。观自在菩萨白佛言。世尊。如佛所说菩萨十地。所谓极喜地。离垢地。发光地。焰慧地。极难胜地。现前地。远行地。不动地。善慧地。法云地。复说佛地为第十一。如是诸地几种清净。几分所摄。佛告观自在菩萨曰。善男子。当知诸地四种清净十一分摄。云何四种清净能摄诸地。谓增上意乐清净摄于初地。增上戒清净摄第二地。增上心清净摄第三地。增上慧清净于后后地转胜妙故。当知能摄从第四地乃至佛地。善男子。当知如是四种清净普摄诸地。云何十一种分能摄诸地。谓诸菩萨先于胜解行地。依十法行极善修习胜解忍故。超过彼地证入菩萨正性离生。彼诸菩萨由是因缘此分圆满。而未能于微细毁犯误现行中正知而住。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能得世间圆满等持等至及圆满闻持陀罗尼。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能令随所获得菩提分法多修习住心。未能舍诸等至爱及与法爱。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能于诸谛道理如实观察。又未能于生死涅槃弃舍一向背趣作意。又未能修方便所摄菩提分法。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能于生死流转如实观察。又由于彼多生厌故。未能多住无相作意。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能令无相作意无缺无间多修习住。由是因缘。于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能于无相住中舍离功用。又未能得于相自在。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能于异名众相训词差别一切品类宣说法中得大自在。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能得圆满法身现前证受。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。彼诸菩萨由是因缘此分圆满。而未能得遍于一切所知境界无著无碍妙智妙见。由是因缘于此分中犹未圆满。为令此分得圆满故。精勤修习便能证得。由是因缘此分圆满此分满故。于一切分皆得圆满。善男子。当知如是十一种分普摄诸地

世尊。何缘最初名极喜地。乃至何缘说名佛地。善男子。成就大义得未曾得出世间心生大欢喜。是故最初名极喜地。远离一切微细犯戒。是故第二名离垢地。由彼所得三摩地及闻持陀罗尼能为无量智光依止。是故第三名发光地。由彼所得菩提分法。烧诸烦恼智如火焰。是故第四名焰慧地。由即于彼菩提分法方便修习最极艰难方得自在。是故第五名极难胜地。现前观察诸行流转。又于无相多修作意方现在前。是故第六名现前地。能远证入无缺无间无相作意。与清净地共相邻接。是故第七名远行地。由于无相得无功用。于诸相中不为现行烦恼所动。是故第八名不动地。于一切种说法自在。获得无量广大智慧。是故第九名善慧地。粗重之身广如虚空法身圆满。譬如大云皆能遍覆。是故第十名法云地。永断最极微细烦恼及所知障无著无碍。于一切种所知境界现正等觉故。第十一说名佛地

世尊。于此诸地有几愚痴。有几粗重。为所对治。善男子。此诸地中有二十二种愚痴。十一种粗重。为所对治。谓于初地有二愚痴。一者执着补特伽罗及法愚痴。二者恶趣杂染愚痴。及彼粗重为所对治。于第二地有二愚痴。一者微细误犯愚痴。二者种种业趣愚痴。及彼粗重为所对治。于第三地有二愚痴。一者欲贪愚痴。二者圆满闻持陀罗尼愚痴。及彼粗重为所对治。于第四地有二愚痴。一者等至爱愚痴。二者法爱愚痴。及彼粗重为所对治。于第五地有二愚痴。一者一向作意弃背生死愚痴。二者一向作意趣向涅槃愚痴。及彼粗重为所对治。于第六地有二愚痴。一者现前观察诸行流转愚痴。二者相多现行愚痴。及彼粗重为所对治。于第七地有二愚痴。一者微细相现行愚痴。二者一向无相作意方便愚痴。及彼粗重为所对治。于第八地有二愚痴。一者于无相作功用愚痴。二者于相自在愚痴。及彼粗重为所对治。于第九地有二愚痴。一者于无量说法。无量法句文字。后后慧辩陀罗尼自在愚痴。二者辩才自在愚痴。及彼粗重为所对治。于第十地有二愚痴。一者大神通愚痴。二者悟入微细秘密愚痴。及彼粗重为所对治。于如来地有二愚痴。一者于一切所知境界极微细着愚痴。二者极微细碍愚痴。及彼粗重为所对治。善男子。由此二十二种愚痴。及十一种粗重故。安立诸地。而得阿耨多罗三藐三菩提。离彼系缚

世尊。阿耨多罗三藐三菩提甚奇希有。乃至成就大利大果。令诸菩萨能破如是大愚痴罗网。能越如是大粗重稠林。现前证得阿耨多罗三藐三菩提

世尊。如是诸地几种殊胜之所安立。善男子。略有八种。一者增上意乐清净。二者心清净。三者悲清净。四者到彼岸清净。五者见佛供养承事清净。六者成熟有情清净。七者生清净。八者威德清净。善男子。于初地中所有增上意乐清净乃至威德清净。后后诸地乃至佛地所有增上意乐清净乃至威德清净。当知彼诸清净展转增胜。唯于佛地除生清净。又初地中所有功德。于上诸地平等皆有。当知自地功德殊胜。一切菩萨十地功德皆是有上。佛地功德当知无上

世尊。何因缘故说菩萨生于诸有生最为殊胜。善男子。四因缘故。一者极净善根所集起故。二者故意思择力所取故。三者悲愍济度诸众生故。四者自能无染除他染故

世尊。何因缘故说诸菩萨行广大愿妙愿胜愿。善男子。四因缘故。谓诸菩萨能善了知涅槃乐住。堪能速证。而复弃舍速证乐住。无缘无待发大愿心。为欲利益诸有情故。处多种种长时大苦。是故我说彼诸菩萨行广大愿妙愿胜愿

世尊。是诸菩萨凡有几种所应学事。善男子。菩萨学事略有六种。所谓布施持戒。忍辱精进。静虑慧到彼岸

世尊。如是六种所应学事。几是增上戒学所摄。几是增上心学所摄。几是增上慧学所摄。善男子。当知初三但是增上戒学所摄。静虑一种但是增上心学所摄。慧是增上慧学所摄。我说精进遍于一切

世尊。如是六种所应学事。几是福德资粮所摄。几是智慧资粮所摄。善男子。若增上戒学所摄者。是名福德资粮所摄。若增上慧学所摄者。是名智慧资粮所摄。我说精进静虑二种遍于一切

世尊。于此六种所学事中。菩萨云何应当修学。善男子。由五种相应当修学。一者最初于菩萨藏波罗蜜多相应微妙正法教中。猛利信解。二者次于十种法行以闻思修所成妙智。精进修行。三者随护菩提之心。四者亲近真善知识。五者无间勤修善品

世尊。何因缘故施设如是所应学事。但有六数。善男子。二因缘故。一者饶益诸有情故。二者对治诸烦恼故。当知前三饶益有情。后三对治一切烦恼。前三饶益诸有情者。谓诸菩萨由布施故。摄受资具饶益有情。由持戒故。不行损害逼迫恼乱饶益有情。由忍辱故。于彼损害逼迫恼乱。堪能忍受饶益有情。后三对治诸烦恼者。谓诸菩萨由精进故。虽未永伏一切烦恼亦未永害一切随眠。而能勇猛修诸善品。彼诸烦恼不能倾动善品加行。由静虑故。永伏烦恼。由般若故。永害随眠

世尊。何因缘故施设所余波罗蜜多但有四数。善男子。与前六种波罗蜜多为助伴故。谓诸菩萨于前三种波罗蜜多所摄有情。以诸摄事方便善巧。而摄受之安置善品。是故我说方便善巧波罗蜜多与前三种而为助伴。若诸菩萨于现法中烦恼多故。于修无间无有堪能。羸劣意乐故下界胜解故。于内心住。无有堪能。于菩萨藏不能闻缘善修习故。所有静虑不能引发出世间慧。彼便摄受少分狭劣福德资粮。为未来世烦恼轻微。心生正愿。如是名愿波罗蜜多。由此愿故。烦恼微薄能修精进。是故我说愿波罗蜜多与精进波罗蜜多而为助伴。若诸菩萨亲近善士。听闻正法。如理作意。为因缘故。转劣意乐成胜意乐。亦能获得上界胜解。如是名力波罗蜜多。由此力故于内心住有所堪能。是故我说力波罗蜜多与静虑波罗蜜多而为助伴。若诸菩萨于菩萨藏。已能闻缘善修习故能发静虑。如是名智波罗蜜多。由此智故。堪能引发出世间慧。是故我说智波罗蜜多与慧波罗蜜多而为助伴

世尊。何因缘故宣说六种波罗蜜多如是次第。善男子。能为后后引发依故。谓诸菩萨若于身财无所顾吝。便能受持清净禁戒。为护禁戒便修忍辱。修忍辱已能发精进。发精进已能办静虑。具静虑已便能获得出世间慧。是故我说波罗蜜多如是次第

世尊。如是六种波罗蜜多各有几种品类差别。善男子。各有三种。施三种者。一者法施。二者财施。三者无畏施。戒三种者。一者转舍不善戒。二者转生善戒。三者转生饶益有情戒。忍三种者。一者耐怨害忍。二者安受苦忍。三者谛察法忍。精进三种者。一者被甲精进。二者转生善法加行精进。三者饶益有情加行精进。静虑三者。一者无分别寂静极寂静无罪故对治烦恼众苦乐住静虑。二者引发功德静虑。三者引发饶益有情静虑。慧三种者。一者缘世俗谛慧。二者缘胜义谛慧。三者缘饶益有情慧

世尊。何因缘故。波罗蜜多说名波罗蜜多。善男子。五因缘故。一者无染着故。二者无顾恋故。三者无罪过故。四者无分别故。五者正回向故。无染著者。谓不染着波罗蜜多诸相违事。无顾恋者。谓于一切波罗蜜多诸果异熟及报恩中心无系缚。无罪过者。谓于如是波罗蜜多。无间杂染法。离非方便行。无分别者。谓于如是波罗蜜多。不如言词执着自相。正回向者。谓以如是所作所集波罗蜜多。回求无上大菩提果

世尊。何等名为波罗蜜多诸相违事。善男子。当知此事略有六种。一者于喜乐欲财富自在诸欲乐中。深见功德及与胜利。二者于随所乐纵身语意而现行中。深见功德及与胜利。三者于他轻蔑不堪忍中。深见功德及与胜利。四者于不勤修着欲乐中。深见功德及与胜利。五者于处愦闹世杂乱行。深见功德及与胜利。六者于见闻觉知言说戏论。深见功德及与胜利

世尊。如是一切波罗蜜多何果异熟善男子。当知此亦略有六种。一者得大财富。二者往生善趣。三者无怨无坏多诸喜乐。四者为众生主。五者身无恼害。六者有大宗叶

世尊。何等名为波罗蜜多间杂染法。善男子。当知略由四种加行。一者无悲加行故。二者不如理加行故。三者不常加行故。四者不殷重加行故。不如理加行者。谓修行余波罗蜜多时。于余波罗蜜多。远离失坏

世尊。何等名为非方便行。善男子。若诸菩萨以波罗蜜多饶益众生时。但摄财物饶益众生。便为喜足而不令其出不善处安置善处。如是名为非方便行。何以故。善男子。非于众生唯作此事名实饶益。譬如粪秽若多若少终无有能令成香洁。如是众生由行苦故。其性是苦。无有方便但以财物暂相饶益可令成乐。唯有安处妙善法中。方可得名第一饶益

世尊。如是一切波罗蜜多。有几清净。善男子。我终不说波罗蜜多除上五相有余清净。然我即依如是诸事。总别当说波罗蜜多清净之相。总说一切波罗蜜多清净相者。当知七种。何等为七。一者菩萨于此诸法不求他知。二者于此诸法见已不生执着。三者即于如是诸法不生疑惑。谓为能得大菩提不。四者终不自赞毁他有所轻蔑。五者终不憍傲放逸。六者终不少有所得便生喜足。七者终不由此诸法于他发起嫉妒悭吝。别说一切波罗蜜多清净相者。亦有七种。何等为七。谓诸菩萨如我所说七种布施清净之相。随顺修行。一者由施物清净。行清净施。二者由戒清净。行清净施。三者由见清净。行清净施。四者由心清净。行清净施。五者由语清净。行清净施。六者由智清净。行清净施。七者由垢清净。行清净施。是名七种施清净相。又诸菩萨能善了知制立律仪一切学处。能善了知出离所犯具常尸罗坚固尸罗常作尸罗常转尸罗。受学一切所有学处。是名七种戒清净相。若诸菩萨于自所有业果异熟。深生依信。一切所有不饶益事现在前时。不生愤发。亦不反骂。不嗔不打。不恐不弄。不以种种不饶益事反相加害。不怀怨结。若谏诲时不令恚恼。亦复不待他来谏诲。不由恐怖有染爱。心而行忍辱。不以作恩而便放舍。是名七种忍清净相。若诸菩萨通达精进平等之性。不由勇猛勤精进故。自举陵他。具大势力具大精进。有所堪能。坚固勇猛。于诸善法终不舍轭。如是名为七种精进清净之相。若诸菩萨有善通达相三摩地静虑。有圆满三摩地静虑。有俱分三摩地静虑。有运转三摩地静虑。有无所依三摩地静虑。有善修治三摩地静虑。有于菩萨藏闻缘修习无量三摩地静虑。如是名为七种静虑清净之相。若诸菩萨远离增益损减二边。行于中道。是名为慧。由此慧故。如实了知解脱门义。谓空无愿无相三解脱门。如实了知有自性义。谓遍计所执。若依他起。若圆成实三种自性。如实了知无自性义。谓相生胜义三种无自性性。如实了知世俗谛义。谓于五明处。如实了知胜义谛义。谓于七真如。又无分别离诸戏论。纯一理趣多所住故。无量总法为所缘故。及毗钵舍那故。能善成办法随法行。是名七种慧清净相

世尊。如是五相各有何业。善男子。当知彼相有五种业。谓诸菩萨无染着故。于现法中于所修习波罗蜜多。恒常殷重勤修加行。无有放逸。无顾恋故。摄受当来不放逸因。无罪过故能正修习极善圆满。极善清净。极善鲜白波罗蜜多。无分别故。方便善巧波罗蜜多速得圆满。正回向故。一切生处波罗蜜多及彼可爱诸果异熟。皆得无尽乃至无上正等菩提。世尊。如是所说波罗蜜多。何者最广大。何者无染污。何者最明盛。何者不可动。何者最清净。善男子。无染着性。无顾恋性。正回向性。最为广大。无罪过性。无分别性。无有染污思择所作。最为明盛。已入无退转法地者。名不可动。若十地摄佛地摄者。名最清净

世尊。何因缘故。菩萨所得波罗蜜多诸可爱果。及诸异熟。常无有尽。波罗蜜多亦无有尽。善男子。展转相依生起修习无间断故。世尊。何因缘故。是诸菩萨深信爱乐波罗蜜多。非于如是波罗蜜多所得可爱诸果异熟。善男子。五因缘故。一者波罗蜜多是最增上喜乐因故。二者波罗蜜多是其究竟饶益一切自他因故。三者波罗蜜多是当来世彼可爱果异熟因故。四者波罗蜜多非诸杂染所依事故。五者波罗蜜多非是毕竟变坏法故。世尊。如是一切波罗蜜多。各有几种最胜威德。善男子。当知一切波罗蜜多。各有四种最胜威德。一者于此波罗蜜多正修行时。能舍悭吝犯戒心愤懈怠散乱见趣所治。二者于此正修行时。能为无上正等菩提真实资粮。三者于此正修行时。于现法中能自摄受饶益有情。四者于此正修行时。于未来世能得广大无尽可爱诸果异熟

世尊。如是一切波罗蜜多。何因何果有何义利。善男子。当知一切波罗蜜多。大悲为因。微妙可爱诸果异熟饶益一切有情为果。圆满无上广大菩提为大义利

世尊。若诸菩萨具足一切无尽财宝成就大悲。何缘世间现有众生贫穷可得。善男子。是诸众生自业过失。若不尔者菩萨常怀饶益他心。又常具足无尽财宝。若诸众生无自恶业能为障碍。何有世间贫苦可得。譬如饿鬼为大热渴逼迫其身见大海水悉皆涸竭。非大海过。是诸饿鬼自业过耳。如是菩萨所施财宝。犹如大海无有过失。是诸众生自业过耳。犹如饿鬼自恶业力令无有果

世尊。菩萨以何等波罗蜜多取一切法无自性性。善男子以般若波罗蜜多。能取诸法无自性性。世尊。若般若波罗蜜多能取诸法无自性性。何故不取有自性性。善男子。我终不说以无自性性取无自性性。然无自性性离诸文字自内所证。不可舍于言说文字而能宣说。是故我说般若波罗蜜多能取诸法无自性性

世尊。如佛所说波罗蜜多。近波罗蜜多。大波罗蜜多。云何波罗蜜多。云何近波罗蜜多。云何大波罗蜜多。善男子。若诸菩萨经无量时。修行施等。成就善法。而诸烦恼犹故现行。未能制伏。然为彼伏。谓于胜解行地。软中胜解转时。是名波罗蜜多。复于无量时修行施等。渐复增上成就善法。而诸烦恼犹故现行。然能制伏非彼所伏。谓从初地已上是名近波罗蜜多。复于无量时修行施等。转复增上成就善法。一切烦恼皆不现行。谓从八地已上是名大波罗蜜多

世尊。此诸地中烦恼随眠可有几种。善男子。略有三种。一者害伴随眠。谓于前五地。何以故。善男子。诸不俱生现行烦恼。是俱生烦恼现行助伴。彼于尔时永无复有。是故说名害伴随眠。二者羸劣随眠。谓于第六第七地中。微细现行。若修所伏不现行故。三者微细随眠。谓于第八地已上。从此已去一切烦恼不复现行。唯有所知障为依止故

世尊。此诸随眠几种粗重断所显示。善男子。但由二种。谓由在皮粗重断故。显彼初二。复由在肤粗重断故。显彼第三。若在于骨粗重断者。我说永离一切随眠位在佛地

世尊。经几不可数劫。能断如是粗重。善男子。经于三大不可数劫。或无量劫。所谓年月半月。昼夜一时。半时须臾。瞬息刹那量劫不可数故

世尊。是诸菩萨于诸地中所生烦恼。当知何相。何失。何德。善男子。无染污相。何以故。是诸菩萨于初地中。定于一切诸法法界。已善通达。由此因缘。菩萨要知方起烦恼。非为不知。是故说名无染污相。于自身中不能生苦。故无过失。菩萨生起如是烦恼。于有情界能断苦因。是故彼有无量功德。甚奇。世尊。无上菩提乃有如是大功德利。今诸菩萨生起烦恼。尚胜一切有情声闻独觉善根。何况其余无量功德

世尊。如佛所说若声闻乘若复大乘唯是一乘。此何密意。善男子。如我于彼声闻乘中。宣说种种诸法自性。所谓五蕴或内六处或外六处。如是等类于大乘中。即说彼法同一法界同一理趣故。我不说乘差别性。于中或有如言于义妄起分别。一类增益一类损减。又于诸乘差别道理。谓互相违。如是展转递兴诤论。如是名为此中密意。尔时世尊欲重宣此义而说颂曰

  诸地摄想所对治　　殊胜生愿及诸学
  由依佛说是大乘　　于此善修成大觉
  宣说诸法种种性　　复说皆同一理趣
  谓于下乘或上乘　　故我说乘无异性
  如言于义妄分别　　或有增益或损减
  谓此二种互相违　　愚痴意解成乖诤

世尊。于是解深密法门中。此名何教。我当云何奉持。善男子。此名诸地波罗蜜多了义之教。于此诸地波罗蜜多了义之教。汝当奉持。说此诸地波罗蜜多了义教时。于大会中有七十五千菩萨。皆得菩萨大乘光明三摩地。复次即依乘假安立。分别如来成所作事。当知如解深密经中。曼殊室利菩萨摩诃萨请问佛言。世尊。如佛所说如来法身。如来法身有何等相。佛告曼殊室利菩萨曰。善男子。若于诸地波罗蜜多。善修出离。转依成满。是名如来法身之相。当知此相二因缘故不可思议。无戏论故。无所为故。而诸众生计着戏论。有所为故

世尊。声闻独觉所得转依。名法身不。善男子。不名法身。世尊。当名何身。善男子。名解脱身。由解脱身故。说一切声闻独觉与诸如来平等平等。由法身故。说有差别。如来法身有差别故。无量功德最胜差别。算数譬喻所不能及

世尊。我当云何应知如来生起之相。善男子。一切如来化身作业。如世界起一切种类。如来功德众所庄严住持为相。当知化身相有生起。法身之相无有生起

世尊。云何应知示现化身方便善巧。善男子。遍于一切三千大千佛国土中。或众推许增上王家。或众推许大福田家。同时入胎诞生。长大受欲。出家示行苦行。舍苦行已成等正觉。次第示现。是名如来示现化身方便善巧。世尊。凡有几种一切如来身所住持言音差别。由此言音所化有情未成熟者。令其成熟。已成熟者。缘此为境速得解脱。善男子。如来言音略有三种。一者契经。二者调伏。三者本母。世尊。云何契经。云何调伏。云何本母。善男子。若于是处我依摄事显示诸法。是名契经。谓依四事。或依九事。或复依于二十九事。云何四事。一者听闻事。二者归趣事。三者修学事。四者菩提事。云何九事。一者施设有情事。二者彼所受用事。三者彼生起事。四者彼生已住事。五者彼染净事。六者彼差别事。七者能宣说事。八者所宣说事。九者诸众会事。云何名为二十九事。谓依杂染品。有摄诸行事。彼次第随转事。即于是中作补特伽罗想已于当来世流转因事。作法想已于当来世流转因事。依清净品有系念于所缘事。即于是中勤精进事。心安住事。现法乐住事。超一切苦缘方便事。彼遍知事。此复三种。颠倒遍知所依处故。依有情想外有情中邪行遍知所依处故。内离增上慢遍知所依处故。修依处事。作证事。修习事。令彼坚固事。彼行相事。彼所缘事。已断未断观察善巧事。彼散乱事。彼不散乱事。不散乱依处事。不弃修习劬劳加行事。修习胜利事。彼坚牢事。摄圣行事。摄圣品眷属事。通达真实事。证得涅槃事。于善说法毗奈耶中世间正见超升一切外道所得正见顶事。及即于此不修退事。于善说法毗奈耶中。不修习故。说名为退。非见过失故名为退。曼殊室利。若于是处我依声闻及诸菩萨。显示别解脱及别解脱相应之法。是名调伏。世尊。菩萨别解脱几相所摄。善男子。当知七相。一者宣说受轨则事故。二者宣说随顺他胜事故。三者宣说随顺毁犯事故。四者宣说有犯自性故。五者宣说无犯自性故。六者宣说出所犯故。七者宣说舍律仪故

曼殊室利。若于是处我以十一种相。决了分别显示诸法。是名本母。何等名为十一种相。一者世俗相。二者胜义相。三者菩提分法所缘相。四者行相。五者自性相。六者彼果相。七者彼领受开示相。八者彼障碍法相。九者彼随顺法相。十者彼过患相。十一者彼胜利相。世俗相者。当知三种。一者宣说补特伽罗故。二者宣说遍计所执自性故。三者宣说诸法作用事业故。胜义相者。当知宣说七种真如故。菩提分法所缘相者。当知宣说遍一切种所知事故。行相者。当知宣说八行观故。云何名为八行观耶。一者谛实故。二者安住故。三者过失故。四者功德故。五者理趣故。六者流转故。七者道理故。八者总别故。谛实者。谓诸法真如。安住者。谓或安立补特伽罗。或复安立诸法遍计所执自性。或复安立一向分别反问置记。或复安立隐密显了记别差别。过失者。谓我宣说诸杂染法有无量门差别过患。功德者。谓我宣说诸清净法有无量门差别胜利。理趣者。当知六种。一者真义理趣。二者证得理趣。三者教导理趣。四者远离二边理趣。五者不可思议理趣。六者意趣理趣。流转者。所谓三世三有为相及四种缘。道理者。当知四种。一者观待道理。二者作用道理。三者证成道理。四者法尔道理。观待道理者。谓若因若缘能生诸行。及起随说。如是名为观待道理。作用道理者。谓若因若缘能得诸法。或能成办或复生已作诸业用。如是名为作用道理。证成道理者。谓若因若缘能令所立所说所标义得成立。令正觉悟。如是名为证成道理。又此道理略有二种。一者清净。二者不清净。由五种相名为清净。由七种相名不清净

云何由五种相名为清净。一者现见所得相。二者依止现见所得相。三者自类譬喻所引相。四者圆成实相。五者善清净言教相

现见所得相者。谓一切行皆无常性。一切行皆是苦性。一切法皆无我性。此为世间现量所得。如是等类。是名现见所得相。依止现见所得相者。谓一切行皆刹那性。他世有性。净不净业无失坏性。由彼能依粗无常性现可得故。由诸有情种种差别。依种种业现可得故。由诸有情若乐若苦净不净业以为依止现可得故。由此因缘。于不现见可为比度。如是等类。是名依止现见所得相。自类譬喻所引相者。谓于内外诸行聚中。引诸世间共所了知所得生死。以为譬喻。引诸世间共所了知所得生等种种苦相。以为譬喻。引诸世间共所了知所得不自在相以为譬喻。又复于外引诸世间共所了知所得衰盛以为譬喻。如是等类。当知是名自类譬喻所引相。圆成实相者。谓即如是现见所得相。若依止现见所得相。若自类譬喻所得相。于所成立决定能成。当知是名圆成实相。善清净言教相者。谓一切智者之所宣说。如言涅槃究竟寂静。如是等类。当知是名善清净言教相。善男子。是故由此五种相故。名善观察清净道理。由清净故应可修习。世尊。一切智者相当知有几种。善男子。略有五种。一者若有出现世间一切智。声无不普闻。二者成就三十二种大丈夫相。三者具足十力。能断一切众生一切疑惑。四者具足四无所畏。宣说正法不为一切他论所伏。而能摧伏一切邪论。五者于善说法毗奈耶中。八支圣道四沙门等皆现可得。如是生故。相故。断疑网故。非他所伏能伏他故。圣道沙门现可得故。如是五种。当知名为一切智相。善男子。如是证成道理由现量故。由比量故。由圣教量故。由五种相名为清净

云何由七种相名不清净。一者此余同类可得相。二者此余异类可得相。三者一切同类可得相。四者一切异类可得相。五者异类譬喻所引相。六者非圆成实相。七者非善清净言教相。若一切法意识所识性。是名一切同类可得相。若一切法相性业法因果异相。由随如是一一异相。决定展转各各异相。是名一切异类可得相。善男子。若于此余同类可得相及譬喻中。有一切异类相者。由此因缘于所成立非决定故。是名非圆成实相。又于此余异类可得相及譬喻中。有一切同类相者。由此因缘于所成立不决定故。亦名非圆成实相。非圆成实故。非善观察清净道理。不清净故。不应修习。若异类譬喻所引相。若非善清净言教相。当知体性皆不清净。法尔道理者。谓如来出世若不出世。法性安住。法住法界。是名法尔道理。总别者。谓先总说一句法已。后后诸句差别分别究竟显了

自性相者。谓我所说有行有缘所有能取菩提分法。谓念住等。如是名为彼自性相。彼果相者。谓若世间。若出世间诸烦恼断。及所引发世出世间诸果功德。如是名为得彼果相。彼领受开示相者。谓即于彼以解脱智而领受之。及广为他宣说开示。如是名为彼领受开示相。彼障碍法相者。谓即于修菩提分法。能随障碍诸染污法。是名彼障碍法相。彼随顺法相者。谓即于彼多所作法。是名彼随顺法相。彼过患相者。当知即彼诸障碍法所有过失。是名彼过患相。彼胜利相者。当知即彼诸随顺法所有功德。是名彼胜利相

曼殊室利菩萨。复白佛言。唯愿世尊。为诸菩萨略说契经调伏本母不共外道陀罗尼义。由此不共陀罗尼义。令诸菩萨得入如来所说诸法甚深密意。佛告曼殊室利菩萨曰。善男子。汝今谛听。吾当为汝略说不共陀罗尼义。令诸菩萨于我所说密意言词能善悟入。善男子。若杂染法若清净法。我说一切皆无作用。亦都无有补特伽罗。以一切种离所为故。非杂染法先染后净。非清净法后净先染。凡夫异生于粗重身执着诸法补特伽罗自性差别。随眼妄见以为缘故。计我我所。由此妄谓我见我闻。我嗅我尝我触我知。我食我作。我染我净。如是等类邪加行转。若有如实知如是者便能永断粗重之身。获得一切烦恼不住。最极清净离诸戏论。无为依止。无有加行。善男子。当知是名略说不共陀罗尼义。尔时世尊欲重宣此义。而说颂曰

  一切杂染清净法　　皆无作用数取趣
  由我宣说离所为　　染污清净非先后
  于粗重身随眼见　　为缘计我及我所
  由此妄谓我见等　　我食我为我染净
  若如实知如是者　　乃能永断粗重身
  得无染净无戏论　　无为依止无加行

尔时曼殊室利菩萨复白佛言。世尊。云何应知诸如来心生起之相。佛告曼殊室利菩萨曰。善男子。夫如来者。非心意识生起所显。然诸如来有无加行心法生起。当知此事犹如变化。世尊。若诸如来法身。远离一切加行。既无加行。云何而有心法生起。善男子。先所修习方便般若加行力故。有心生起。善男子。譬如正入无心睡眠。非于觉悟而作加行。由先所作加行势力。而复觉悟。又如正在灭尽定中。非于起定而作加行。由先所作加行势力还从定起。如从睡眠及灭尽定心更生起。如是如来由先修习方便般若加行力故。当知复有心法生起。世尊。如来化身当言有心。为无心耶。善男子。非是有心。亦非无心。何以故。无自依心故。有依他心故

世尊。如来所行如来境界此之二种有何差别。善男子。如来所行。谓一切种如来共有不可思议无量功德众所庄严清净佛土。如来境界。谓一切种五界差别。何等为五。一者有情界。二者世界。三者法界。四者调伏界。五者调伏方便界。如是名为二种差别。世尊。如来成等正觉。转正法轮。入大涅槃。如是三种。当知何相。善男子。当知此三皆无二相。谓非成等正觉。非不成等正觉。非转正法轮。非不转正法轮。非入大涅槃。非不入大涅槃。何以故。如来法身究竟净故。如来化身常示现故

世尊。诸有情类但于化身见闻奉事生诸功德。如来于彼有何因缘。善男子。如来是彼增上所缘之因缘故。又彼化身是如来力所住持故

世尊。等无加行何因缘故。如来法身为诸有情放大智光。及出无量化身影像。声闻独觉解脱之身。无如是事。善男子。譬如等无加行从日月轮水火二种颇胝迦宝放大光明。非余水火。颇胝迦宝谓大威德有情所住持故。诸有情业增上力故。又如从彼善工业者之所雕饰末尼宝珠出印文像。不从所余不雕饰者。如是缘于无量法界方便般若。极善修习磨莹集成如来法身。从是能放大智光明。及出种种化身影像。非唯从彼解脱之身有如斯事

世尊。如世尊说如来菩萨威德住持。令诸众生于欲界中生刹帝利婆罗门等大富贵家。人身财宝无不圆满。或欲界天色无色界一切身财圆满可得。世尊。此中有何密意。善男子。如来菩萨威德住持若道若行。于一切处能令众生获得身财皆圆满者。即随所应为彼宣说此道此行。若有能于此道此行正修行者。于一切处所获身财无不圆满。若有众生于此道此行。违背轻毁。又于我所起损恼心及嗔恚心。命终已后。于一切处所得身财无不下劣。善男子。由是因缘当知如来及诸菩萨威德住持。非但能令身财圆满。如来菩萨住持威德。亦令众生身财下劣

世尊。诸秽土中何事易得。何事难得。诸净土中何事易得。何事难得。善男子。诸秽土中八事易得。二事难得。何等名为八事易得。一者外道。二者有苦众生。三者种姓家世兴衰差别。四者行诸恶行。五者毁犯尸罗。六者恶趣。七者下乘。八者下劣意乐加行菩萨。何等名为二事难得。一者增上意乐加行菩萨之所游集。二者如来出现于世。善男子。诸净土中与上相达。当知八事甚为难得二事易得。世尊。于此解深密法门中。此名何教。我当云何奉持。善男子。此名如来成所作事了义之教。于此如来成所作事了义之教。汝当奉持。说是如来成所作事了义教时。于大会中有七十五千菩萨摩诃萨。皆得圆满法身证觉

瑜伽师地论卷第七十八瑜伽师地论卷第七十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之八

如是已说功德品决择。问如说五种无量。谓有情界无量等。彼一切世界当言平等平等。为有差别。答当言有差别。彼复有二种。一者清净。二者不清净。于清净世界中。无那落迦傍生饿鬼可得。亦无欲界色无色界。亦无苦受可得。纯菩萨僧于中止住。是故说名清净世界。已入第三地菩萨。由愿自在力故。于彼受生。无有异生及非异生声闻独觉。若异生菩萨得生于彼。问若无异生菩萨。及非异生声闻独觉得生彼者。何因缘故。菩萨教中作如是说。若菩萨等意愿于彼。如是一切皆当往生。答为化懈怠种类未集善根所化众生故。密意作如是说。所以者何。彼由如是蒙劝励时便舍懈怠。于善法中勤修加行。从此渐渐堪于彼生。当得法性。应知是名此中密意。复次菩萨依四种住能成四事。

云何四住。一者极欢喜住。二者增上戒住。三者增上心住。四者增上慧住。云何极欢喜住。谓诸菩萨随所安住。已入清净增上意乐地故。乃至当坐妙菩提座。于三宝所不藉他缘意乐清净。云何增上戒住。谓诸菩萨即于如是极欢喜住。从此已上随所安住。具性尸罗。远离一切悭吝犯戒。即以如是圆满戒舍。回向无上正等菩提。云何增上心住。谓诸菩萨即依如是增上戒住。从此已上随所安住离欲界贪。获得静虑及诸等至。安住慈悲。于诸众生随能随力如实正行。云何增上慧住。谓诸菩萨即依如是增上心住。从此已上随所安住。渐能获得菩提分法善巧。诸谛善巧。缘起善巧。不共法安立智善巧。出过一切声闻独觉共所证智。而于此中不共法安立智者。谓于菩萨藏中。密意言辞智。非安立谛智。及安立谛智。即于此中共所得智者。谓依缘起所得证智。云何依此四住能成四事。谓诸菩萨依止初住。乃至当坐妙菩提座。终不弃舍大菩提心。依第二住乃至当坐妙菩提座。当来自身财宝善品运运增长。依第三住。为欲利益诸有情故。转诸静虑。以大愿力还生欲界。而不为彼欲缠烦恼之所染污。依第四住。于一切法安立通达而得善巧。为度众生故。发誓愿受于生死。因此誓愿便能积集广大资粮。则由此住清净为因。不待余住。亦不由他教诫教授。速能证得如来妙智

问菩萨当言以何为苦。答众生损恼为苦。问菩萨当言以何为乐。答众生饶益为乐。问菩萨当言以何作意。答悟入所知境界边际。及作一切利众生事以为作意。问菩萨当言以何为住。答以无分别为住

复次菩萨略有四上品障。若不净除。终不堪能入菩萨地及地渐次。何等无四。一者于诸菩萨毗奈耶中起染污犯。二者毁谤大乘相应妙法。三者未积集善根。四者有染爱心。为欲对治如是四障。复有四种净除障法。何等为四。一者遍于十方诸如来所。深心恳责发露悔过。二者遍为利益一切十方诸有情类。劝请一切如来说法。三者遍于十方一切有情所作功德。皆生随喜。四者凡所生起一切善根皆悉回向阿耨多罗三藐三菩提。

复次已入大地菩萨有四微细难可遍知难可除断诸随烦恼。彼诸菩萨应遍了知当正除断。何等为四。一者法爱。二者声闻独觉相应作意。三者味着等至。四者众魔事业。于诸相中所有一切心。动流散。当知皆是众魔事业

问已入初地菩萨当言何相。答当言超过诸异生地。已入菩萨正性离生。由已入故。不名异生超过一切所有怖畏。得未曾得无上法故。常能安住极欢喜住

问已入第二地菩萨当言何相。答当言于毗奈耶中法尔获得止息一切声闻所学自性。能于身语意业清净现行故。能远离诸犯戒垢

问已入第三地菩萨。常言何相。答当言于内获得强盛奢摩他道。由此证得尔焰光明。问已入第四地菩萨当言何相。答当言于内获得强盛毗钵舍那道故。建立能烧烦恼智焰。由此能于如其所证一切所有菩提分法安立善巧

问已入第五地菩萨。当言何相。答当言超过一切世间智故。超过一切声闻独觉智故。能升悟入不思议谛极难胜道

问已入第六地菩萨。当言何相。答当言悟入甚深缘起道理故。于一切行住厌背想。于无相界多住趣向作意思惟

问已入第七地菩萨。当言何相。答当言于有加行无间缺。无相界作意能极远入。于加行道已到究竟

问已入第八地菩萨当言何相。答当言于无加行无功用无相界作意。得任运故。无有动摇。于一切相得自在故住清净地。

问已入第九地菩萨当言何相答当言于名身句身文身得自在故。又得无罪无量广大慧故。又得广大无碍解故。能悦一切众生心故。名大法师

问已入第十地菩萨当言何相。答当言已得一切如来同大洒故。已得如云大法身故。已得一切大神通故。亦名如来

问入如来地菩萨当言何相。答当言即此所得法身更善清净极成满故。于一切种烦恼障及所知障。得永远离清净智见

问于此诸地云何造修。答若诸菩萨住胜解行地。依于十地修十法行

问于此诸地云何而得。答若诸菩萨证入菩萨正性离生。又复证得清净意乐。尔时顿得一切诸地

问何等名为诸地等流。答一切地中证得已后所有威德诸加行道

问于此诸地云何成满。答若诸菩萨于彼诸地。一一地中经于无量百千大劫。随所称赞诸地威德。于此威德任运能证

问如说五种入正性离生。此中声闻入正性离生。若诸菩萨入正性离生。等于法界如实通达。此二差别云何应知。答略说法界有二种相。一者差别相。二者自相。差别相者。谓常住相。及寂静相。常住相者。谓本来无生法性。及无尽法性。寂静相者。谓烦恼苦离系法性。言自相者。谓于相名分别真如正智所摄一切法中。由遍计所执自性故。自性不成实法无我性。此中声闻由差别相通达法界。入正性离生。不由自相以通达彼故。由无没想及安隐想。于法界中得寂静想。于一切行一向发起厌背之想。又复不能于彼相等所摄诸法性。不成实法。无我性如实了知。唯即于此法界定中。由缘法界差别作意。无相心转。非由缘彼自相作意。或复因他为其宣说法界自相。闻已一分回向菩提声闻。极大艰辛然后悟入。既得入已精勤修习。一分一向趣寂声闻。极大艰辛少能悟入。而不入已精勤修习。若诸菩萨俱由二相通达法界。入于菩萨正性离生入离生已多分安住缘于法界自相作意。何以故。由于法界缘差别相多作意时速趣涅槃故。多住彼于阿耨多罗三藐三菩提非正方便。当知虽等通达法界。由此因缘而有差别

问如说三世三轮清净。云何三世三轮清净。答由遍计所执自性故。于过去未来现在诸法平等平等。以如实慧正观察时。于过去未来现在法中。无有顾恋希望染着。是名三世三轮清净

问如先所说百四十不共佛法。余经复说十八不共佛法。如是佛法云何安立。几种所摄。答谓阿罗汉苾刍诸漏永尽。方入聚落游行乞食。或于一时与诸恶象恶马恶牛及恶狗等共路而行。或入稠林履践棘围。或齐双足踰越坑堑。或入如是非法舍宅。为诸母邑非理招引。或阿练若弃舍正道行邪恶径。或与盗贼师子猛兽豺狼豹等共路而游。如是等类诸阿罗汉所有误失。如来于此一切永无。又阿罗汉或于一时游阿练若大树林中。迷失道路或入空宅。扬声大叫呼噪远闻。或复因于习气过失。无染污心。骞唇露齿逌尔而笑。如是等类。诸阿罗汉所有暴音。如来于此永无所有。又阿罗汉或于一时由忘念故。于所作事而有丧失。如来于此永无所有。又阿罗汉于有余依生死界中。一向发起厌背之想。于无余依涅槃界中。一向发起寂静之想。如来于彼有依涅槃无差别想。安住第一平等舍故。又阿罗汉若入等至即名为定。若出等至即不名定。如来遍于一切位中无不定心。又阿罗汉不善思择。而便弃舍利众生事。如是等类。如来于此不善思择。而便弃舍永无所有。又阿罗汉依所知障净。由未得退退失于欲精进念定慧及解脱解脱知见。如是七种退失之法。如来永无。又阿罗汉或于一时善身业转。或于一时无记业转。如于身业。语业意业当知亦尔。如来三业智前行故。智随转故。无无记业。智所起故名智前行。智俱行故名智随转。又阿罗汉遍于三世所知事中。不能率尔作意便解。是故智见说名有着。不能一切无余正解。是故智见说名有碍。如来遍于三世境界。率尔作意便能正解一切所知境事差别。是故说此十八种名不共佛法。此中初四是无忘失法。及拔除习气所摄。次一是大悲所摄。所余当知是一切种妙智所摄。又复世尊于余经中所说随好。为令所化生净信故显示。于彼然不立相。安立诸相如建立品已广显示。从此随好当知。分出彼诸随好。

复次菩萨邪行应当了知。菩萨正行应当了知。菩萨正行胜利应当了知。菩萨于正行中安立法行平等行善行法住行相应当了知。菩萨能生净信譬喻应当了知。菩萨于正行中安立所学应当了知。于诸声闻所学菩萨所学。殊胜差别应当了知。于诸菩萨应所学中。善学菩萨所有世间出世间智利益他事。应当了知。即于菩萨所教授中声闻所学。应当了知。非善学沙门。应当了知。善学沙门。应当了知。住世俗律仪者。应当了知。住胜义律仪者。应当了知。于诸如来调伏方便。应当了知。于密意语。应当了知。于菩萨藏所教授中胜解胜利。应当了知。如是略举菩萨藏中所有教授。

云何邪行。当知略说后后引发有八种相。一者能退智资粮邪行。二者退智资粮故能令忘念邪行。三者由忘念故能坏白法邪行。四者白法坏故能令非菩萨仪恶意现行邪行。五者恶意现行故能令难可调伏邪行。六者难调伏故能令行于非道邪行。七者行非道故能令亲近不贤良邪行。八者亲近不贤良故能令菩萨不如其义邪行

复次菩提以慧为体。慧能引发所余一切波罗蜜多。是故于慧起邪行时。当知菩萨于彼菩提及能引发菩提诸法皆起邪行。有四种法能令菩萨智资粮退。何等为四。一者自不听闻。二者不令他闻。三者为听闻障。四者颠倒执着而有听闻。依此能令智资粮退。四种法故。于现法中或于后法。复生四种智相违法。何等为四。一者无所了知。二者众缘阙乏。三者能生感痴非福。四者颠倒自不听闻为依止故。于现法中无所了知。不令他闻为依止故。于后法中众缘阙乏。为听闻障为依止故。能生后法感痴非福。颠倒执着而有听闻为依止故。于后法中更增颠倒。自不听闻者。憎背法故。憎背补特伽罗故。俱增背故不令他闻者。恐他智胜故。有憍骜故。怖他轻毁故。为听闻障者。诽毁于法及补特伽罗故。恶作矫乱相牵引故。不令启请及开许故。方便毁呰能听者故。颠倒执着而听闻者。依自恶通达领解宣说。执着善通达领解宣说故。依他善通达领解宣说。执着恶通达领解宣说故。此中若自不听闻。若不令他闻。若为听闻障。如是三法。多分能令退失闻所成智资粮。颠倒执着而有听闻。多分能令退失思修所成智资粮

复次有四种法。能令菩萨忘失正念。何等为四。谓于四种补特伽罗。四处迷乱。一于举罪补特伽罗。二于教导补特伽罗。三于欲作利益补特伽罗。四于有德补特伽罗。谓于同梵行所迷乱自过。于学现前迷乱学处。于彼大乘欲胜解者。欲正行者。显无差别。标举分别诸过失故。发起迷乱胜解正行。于能说法补特伽罗。迷乱显彼所有密处

复次有四种法。能令菩萨坏鲜白法。谓与他竞增上力故起诸白法非处加行。虽起白法处所加行。然有三种邪行过失。一者染着过失。二者恶见过失。三者受持过失。由二因缘应知染着过失。一者邪受用故。二者多杂处故。由二因缘应知恶见过失。一者诽拨正法补特伽罗故。二者于不正法显示执着为正法故。由二因缘应知受持过失。一者受持狭小唯不了义经故。二者于所未闻未曾领受诸了义经。悬诽拨故

复次菩萨有四种非菩萨仪恶意现行。一者于大师所生不信顺敬学相违。恶意现行。二者于同梵行摄受举罪能教诫者如实发露己过相违恶意现行。三者于大智福诸善法中。精进相违恶意现行。四者于广大甚深胜解中。能令自障清净相违恶意现行。由三种相应知。于大师所生不信顺。谓于有体尊胜得智。由三种相应知不如实发露己过。一者于彼摄受诸有情所。邪妄显示己为尊胜。因此发起憍举心故。二者于能举罪诸有情所。覆所犯故。三者于能教诫诸有情所。因彼驱摈增上力故。发秽浊心作损恼故。由二种相应知退失于诸善法发起精进。谓于大智福诸有情所。爱着利养恭敬故。及欣乐彼故

复次有四种法能令菩萨难可调伏。谓于正修有四种障。一于听闻执为究竟。二于教授左谬领解。三于尸罗不正安住。多诸恶作。四于自见安住见取。谓但听闻心不寂静故。于听闻执为究竟。由于教诫颠倒分别故。于教授左谬领解。由于尸罗多作缺犯而受信施故有恶作。与胜有情共兴诤竞故。于自见多住见取。胜有情者。谓根调伏胜及断灭胜

复次菩萨有四种于诸有情行于非道。一者于未安立净信有情。而不为说。二者于下乘希求大乘诸有情所。不随所宜而有所说。三者于大乘希求下乘诸有情所。不顺其仪而有所说。四者于住禁戒不住禁戒贪爱朋党。不平等说。由三种相当知是名安住禁戒。一者事业无愆故。二者尸罗无缺故。三者恭敬所学故。由二种相当知是名不住禁戒。一者尸罗缺故。二者不恭敬所学故

复次菩萨由亲近不贤良故。退失四事。一者退失于乘。二者退失利益有情。加行。三者退失圣教。四者退失无间修诸善法

复次有四种菩萨不如其义。一者任持正法。二者住阿练若。三者勤修福业。四者管御大众。谓诸菩萨欲令信伏虽住持正法。亦不如义。非如其义。若诸菩萨为求声誉。虽住阿练若。亦不如义。非如其义。若诸菩萨心专系著有染之果。虽勤修福业。亦不如义。非如其义。若诸菩萨心专系着供事名称。虽管御大众亦不如义。非如其义。复次云何正行。谓与上相违离别过失。宣说对治。当知后后之所引发八种行相。是名正行

谓说由自不闻令智退失。此何因缘。由于正法补特伽罗不恭敬所显故。由此毁犯。设不毁犯亦无胜解。是故退失。又说由不令闻令智退失。此何因缘。由欲令他信伏所显故。由此毁犯。设不毁犯回向邪法。是故退失。又说由为闻障令智退失。此何因缘。由不欲不闻不持所显故。由此毁犯。设不毁犯懈怠懒堕。是故退失。又说由邪执着而有听闻令智退失。此何因缘。由于修行不见功德但闻言说为究竟所显故。由此毁犯。设不毁犯智不成实。是故退失

复说由于举罪者所迷乱自过令念忘失。此何因缘。由于重事中怖畏衰损。于轻事中怖畏呵责。而设妄语所显故。由此毁犯。由业障故有所忘失。设不毁犯由犯障故而有忘失。又说由迷乱学处令念忘失。此何因缘。由非自性随转虚妄见曲所显故。由此毁犯。由业障故有所忘失。设不毁犯由犯障故而有忘失。又说由于大乘迷乱胜解正行令念忘失。此何因缘。由于菩萨不生恭敬隐覆实德所显故。由此毁犯。由业障故有所忘失。设不毁犯由犯障故而有忘失。又说由迷乱显隐密处令念忘失。此何因缘。由欲令于大乘不生乐欲所显故。由此毁犯。由业障故而有忘失。设不毁犯由犯障故而有忘失

复说由非处加行坏鲜白法。此何因缘。由乐己利狭小不转。下乘听闻心不谦下所显故。由此毁犯。由不能得所未获得诸鲜白法。于所听受生赊缓故。于己得退。又说由染爱过失坏鲜白法。此何因缘。由于正在家所得利养不生喜足。矫诳等法有希望所显故。由此毁犯。由不听闻所未闻法。多诸事业轻躁散乱。于三摩地不能证得。又说由恶见过失坏鲜白法。此何因缘。由怀恶意。瞻视于他。于诸声闻大乘所学其心颠倒所显故。由此毁犯。由不正行获得衰损。由诳惑他获得衰损。又说由受持过失坏鲜白法。此何因缘。由于如来智意趣中起等觉慢所显故。由此毁犯。由谤正法获得衰损。由于如来智意趣中邪称量故。获得衰损

复说由于所学不甚恭敬故恶意现行。此何因缘。由于所犯不发露不陈悔。不除恶作所显故。由此现行。由于所缘有散乱故行不明了。又说由不如实显己过故恶意现行。此何因缘。由于身财有所顾恋。乐非谛语所显故。由此现行。由于圣教有散乱故。行不明了。又说由于进进懈怠因缘。恶意现行。此何因缘。由无堪忍所显故。由此现行。由于众苦不能堪忍。于诸善法有散乱故。行不明了。又说由障净因缘。恶意现行。此何因缘。由于大乘无增上意乐胜解所显故。由此现行。于广大乘有散乱故。行不明了

复说由唯听闻究竟修障难可调伏。此何因缘。由唯观见免脱难论胜利听闻所显故。由此毁犯。矫诳显示持法善友。又说由于教授左解修障难可调伏。此何因缘。由不堪受教坚持所犯。不敬教授所显故。由此毁犯。矫诳显示住阿练若善友。又说由于尸罗不坚安住恶作修障难可调伏。此何因缘。由于所学不甚恭敬。虚受信施所显故。由此毁犯。矫诳显示勤修福业善友。又说由于自见安住见取修障难可调伏。此何因缘。由于清净波罗蜜多诸菩萨所。不生恭敬不欲瞻仰。不欲亲近。不欲听闻。不随法行所显故。由此毁犯。矫诳显示御众善友。复说由不宣说。不随宣说。不顺义说。不平等说行于非道。此何因缘。由前后宣说厌倦不平等心。于所宣说不知方便。下乘胜解有染爱心。教诫徒众加行所显故。由此毁犯。由善根不圆满故。由不摄受广大善根故。由弃舍广大善根故。生非福故。诳惑所化诸有情类。复说由四种亲近不贤良故退失四事。此何因缘。由悭吝少闻不善入圣教。于佛语言不听闻所显故。由此毁犯。不修善根故。怖畏生死苦故。于利他事不能作故。狭小善根故。于诸法中有疑惑故。而有退失

复说由于四种菩萨欲求信伏。欲求声誉。欲求染果。欲求供养承事名称是诸菩萨不如其义。此何因缘。由与我爱俱于微细罪不见怖畏。与其无我非胜解俱不顾他利。于生死涅槃一向观见过失功德。于现法中乐相杂住。于当来世欣乐富贵摄受财法所显故。由此毁犯。矫现自身能正持法乃至御众

复次云何正行胜利。此亦四种。后后应知。如是正行菩萨。能积集福智资粮故。以此为依障清净故。以此为依于一切门集成白法故。以此为依起一切种利益有情加行故。又能生长无量福故

复有四法能令积集福智资粮。一者依此正行供养承事诸佛如来。二者闻清净。三者思清净。四者修清净

复有四法能令障净。一者于乘自然无动。二者于诸有情远离不行因缘。三者远离邪行因缘。四者远离不圆满正行因缘

复有四法能令一切门集成白法。一者修修所成。二者成熟有情即彼所成。三者堪忍难事即彼所成。四者闻思无厌即彼所成复有四法能令作一切种利有情事。谓于四处济拔有情。一者于疑惑犹豫处。二者于极秽恶趣颠坠处。三者于下乘信解处。四者于憎背圣教嗔恚心处

复次云何菩萨于正行中现在转时。犹得如是功德胜利。谓具法行中平等行。善行。法住行相

云何菩萨具于法行。此何行相。谓诸菩萨凡所修行不越正法。是故名为具足法行。当知此行有五行相。一者于不饶益乐行恶行诸有情所。欲令入善摄受哀愍故。二者于住种性外缘阙乏诸有情所。劝令发起菩提心故。三者于波罗蜜多殊胜中。自了知故。四者于尊重处。发起恭敬礼拜加行故。五者于诸外道怨敌有情。安住圣教无倾动故

云何菩萨具平等行。此何行相。谓诸菩萨遍于一切利众生事。平等修行。是故说名具平等行。当知此行有八行相。一者于诸有情平等亲爱故。二者于诸有情以无染污无差别身。无差别世。无差别求。亲爱之心平等慰喻故。三者舍诸愦闹舒颜和悦。于已受担平等能运故。四者于未受担平等能取故。五者于一切苦平等堪忍故。六者于无量调伏方便平等能求故。七者展转更互平等正语堪忍语故。八者一切善根平等回向大菩提故。云何菩萨具于善行。此何行相。谓诸菩萨于内成熟诸佛法故。于外成熟诸有情故。修行善行。是故说名具于善行。当知此行有七行相。一者无所依止而惠施故。二者无所依止而持戒故。三者由哀愍心而修忍故。四者非于少分修精进故。五者为作利益诸有情处修静虑故。六者见不相应修妙慧故。七者成熟方便善巧故

云何菩萨具于法住。此何行相。谓诸菩萨非但追求以为究竟。非但读诵以为究竟。非但宣说以为究竟。非但寻思以为究竟。而于内心胜奢摩他正修习中。发勤方便。平等修集。是故说名具于法住。当知此住有十二行相。一者于住禁戒不住禁戒能教授中。无分别故。二者以此为依。恭敬领受所教授故。三者以此为依。身远离故。四者以此为依。心远离故。五者以此为依。越声闻乘相应作意大乘相应作意思惟故。六者以此为依。不舍远离轭。与诸有情共止住故。及与所余共止住故。七者以此为依。领受清净世间智大福资粮威德修果故。八者于世间智不知喜足。寻求修治出世智故。又清净智者。断四种过失。管御大众故。一者不能堪忍触恼过失。二者不决定说教授过失。三者不如其言所作过失。四者有染爱心过失。如是四种及前八种合有十二行相

复次云何菩萨能生净信。所有譬喻。谓诸菩萨从初发心。初中后时作诸众生引发善根所依止故。普于一切若怨若恩。心无所著犹如大地。而诸菩萨非如大地中庸而转。众生依之自施功力。方得存活。然诸菩萨生长善根。净信欢喜。能滋润故。犹如大水。而诸菩萨非如大水与诸稼穑成熟相违。然诸菩萨为欲成熟诸善根故。于可厌法深生厌患。能烧炼故。犹如大火。而诸菩萨非如大火与诸佛土集会相违。然诸菩萨能令善根已成熟者。引发聚集解脱触得。由能发起正教授故。譬如大风。而诸菩萨非如大风能引发已终归灭尽。然诸菩萨令自白法转增盛故。犹如朗月。而诸菩萨非如朗月但于白分光明照曜。非于黑分。然诸菩萨其相平等。于黑白分一切法中。智普照故。犹如日轮。而诸菩萨非如日轮怖罗怙捉即便旋转。然诸菩萨一切趣。中终不怖畏烦恼所执而旋转故。譬如师子。而诸菩萨非如师子怯于大担。然诸菩萨能担一切大苦担故。如善调龙。而诸菩萨非如龙象若遭利衰。软非软语。若乐若苦。则为爱恚之所涂染。然诸菩萨于诸世法。不为爱恚所涂染故。如红莲花。而诸菩萨非如红莲断其茎已不复生长。然诸菩萨虽伏烦恼。由善根力之所任持。于生死中复生长故。犹如大树根未损坏。而诸菩萨非如大树其根后时定当损坏。然诸菩萨所有善根回向涅槃大菩提故。譬如众流趣入大海。而诸菩萨非如众流趣入大海即成海性。然诸菩萨依止涅槃及大菩提诸善根力。而游戏故。犹如诸天依苏迷住。而诸菩萨非如诸天住苏迷卢。于自事中。专行放逸。多受快乐。然诸菩萨方便般若所摄持故。成办一切佛所作故。譬如群臣所辅大王。而诸菩萨非如群臣所辅大王。为自利益守护国人。然诸菩萨不顾己利。摄护众生。犹如大云。而诸菩萨非如大云不能毕竟成办稼穑。然诸菩萨毕竟生长菩提分法。如转轮王出现于世。而诸菩萨非如轮王无有第二大丈夫众。然诸菩萨解脱平等。善根所生多同出现。如末尼宝。而诸菩萨非如末尼宝珠与迦理沙般拏极不相似。然诸菩萨入无漏界。所作平等。受乐等故。譬如已入杂林诸天。而诸菩萨非如已入杂林诸天烦恼增长。当来颠坠。然诸菩萨伏诸烦恼无颠坠故。所有烦恼如咒术等所伏诸毒。而诸菩萨所有烦恼。非如咒等所伏诸毒唯不为害。更无余德。然诸菩萨由自烦恼。能作一切众生利益故。此烦恼如大城中诸粪秽聚。如是菩萨所有功德。粗同世间共所知事故。得为喻。而此功德由殊胜故。无有譬喻。是故当知菩萨功德。一切譬喻所不能及

瑜伽师地论卷第七十九瑜伽师地论卷第八十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄决择分中菩萨地之九

复次云何菩萨于正行中安立所学。谓诸菩萨具足法住。于依世俗谛道理所说不了义。非所依声闻乘相应经典。已作依持已作善巧。而复超度于大乘相应甚深空性相应。依世俗胜义谛道理所说了义。可依经典勤修学时。名为如理正勤修学。如是如理勤修学时。名正修行中道胜行。所以者何。由此正法贯穿十三中道行故。一者贯穿补特伽罗空性。二者贯穿补特伽罗无我性。三者贯穿法空性。四者贯穿法无我性。五者贯穿增益边。六者贯穿损减边。七者贯穿法现观。八者贯穿法现观回向大菩提性。九者贯穿如是行者烦恼众苦不缠绕心性。十者贯穿二无我胜解差别。十一者贯穿前无我性是后因性。十二者贯穿到边际空性。十三者贯穿即彼威德

云何贯穿补特伽罗空性。谓由一种相。不可得所显故。此中不可得者。谓于三种事。一者有情事。二者彼差别事。三者彼受用事。若内若外若二中间。愚夫遍计所执实我都不可得

云何贯穿补特伽罗无我性。谓由唯一相。可得所显故。此中可得者。谓即于彼三事愚夫所遍计缘生诸法中常住实性不可得故。愚夫所计我异相性道理可得

云何贯穿法空性。谓唯由一相。不可得所显故。此中不可得者。即于彼事所取无常性。若内若外若二中间。愚夫遍计所执言说自性都不可得

云何贯穿法无我性。谓唯由一相。可得所显故。此中可得者。谓即于彼事道理可得圣智所行。又即于彼自内所证不可以言为他宣说。彼由六相于诸凡愚遍计所执言说自性异相可得。何等六相。一者不可自寻思。二者不可说示他。三者超过色根所行。四者超过一切相。五者超过识所行。六者超过烦恼所行。云何贯穿增益边。谓由二种相。一者差别增益所显故。二者自性增益所显故。何等名为差别增益。谓由后后展转八相。一者即于彼事执常增益。二者执无常增益。三者执常增益为所依止。执我增益。四者执无常增益为所依止。执无我增益。五者执无我增益为所依止。执真实心增益。六者执我增益为所依止。执不真实心增益。此复二种。一者决定。二者寻求。寻求者。谓遍计所依及遍计相应。于所对治杂染法中由五过失。谓颠倒过失。戏论过失。发起恶行过失。粗重过失。无常性过失。及于彼能对治清净法中。七者执真实心增益为所依止。执善等增益。乃至执清净增益。八者执不真实心增益为所依止。执不善等增益。乃至执杂染增益。是名八种差别增益。此中菩萨于彼增益都不执着。不劝他执。亦不赞美。何等名为自性增益。谓差别增益为所依止。由诸愚夫遍计所执所有言说自性增益。即于彼事增益为有

云何贯穿损减。谓由一相。损减实事所显故。此中损减实事者。谓即于彼邪法无我性起于胜解。执着一切种一切法相都无所有

云何贯穿法现观。谓由三种相。一者即于彼事及第四生事所治能治有为无为安立中。自性不可得所显故。二者彼差别不可得所显故。三者即彼串习故。如实通达智所显故。此中自性不可得者。谓诸愚夫遍计所执自性。此中差别不可得者。谓即彼自性灭生集成二分不可得。此中智通达者。谓即彼自性相不作意不思择加行自内所证智通达

云何贯穿法现观。回向大菩提性。谓由一种相。思择所得能治所治不断故。此中能治所治者。谓空是烦恼对治。无愿是有愿对治。无相是诸相对治。如是一切名无造作。此复是后有业对治。亦是生身流转。刹那生流转对治。名灭烦恼行无自性。此复以生死流转为所对治。若诸菩萨由此对治故。起思择不断所治。此由悲愍诸众生故。希求大菩提

云何贯穿如是行者。烦恼众苦不缠绕心。谓由一种相。虽不永断所对治法。而能如实通达故。此中如实通达者。谓即于彼法由法无我加行。观彼自性无染无苦

云何贯穿差别。谓由四种相。一者见差别所显故。二者即此极远损减差别所显故。三者于断迷失差别所显故。四者于心迷失差别所显故。此中见差别者。谓住补特伽罗无我及涅槃。于当来身起断灭增上慢。又于所取观察故。于能取言说自性毕竟远离。空性所摄不观察故。名不善观察所知境界。由执着诸法故求烦恼断。而诸菩萨则不如是。此中极远损减差别者。谓住补特伽罗无我。于我见异生下中更下。由二因缘。谓苦不解脱故。安住苦故。前后二种执着失坏故。而诸菩萨则不如是。此中于断迷失差别者。谓住补特伽罗无我。执法无我无自性故。便生惊怖。谓无言说自性追求断灭。而诸菩萨则不如是。此中于心迷失差别者。谓如是于断迷失住补特伽罗无我。于自遍计所起境界中。为想颠倒等之所颠倒。而诸菩萨则不如是

云何贯穿因性。谓由二种相。一者观察能取所显故。二者彼如实通达所显故。此中观察能取者。谓即观察此无我智。远离言说自性故。远离彼分别故。应舍相故。有刹那故。此中彼如实通达者。谓观察所取能取二种。如理作意思惟为因。各别内证决定智生。云何贯穿到边际空性。谓由一种相。即彼法无我智如实显现故。此中如实显现者。谓显现业烦恼相似相故。不可言说法故。离言说自性故。如是不执着故。有刹那故

云何贯穿即彼空性威德。谓由一种相。业烦恼断对治所显故。此中断者。谓彼刹那光明想生。能断无始时来所集一切诸业烦恼。

复次有几种声闻。声闻所学菩萨所学有何差别。谓有四种声闻。声闻所学菩萨所学当知差别有十三种

云何名为四种声闻。一者变化声闻。二者增上慢声闻。三者回向菩提声闻。四者一向趣寂声闻。变化声闻者。为欲化度。由彼所化诸有情故。或诸菩萨或诸如来化作声闻。增上慢声闻者。谓但由补特伽罗无我智。及执着邪法无我智。计为清净。回向菩提声闻者。谓从本来是极微劣慈悲种姓。由亲近如来住故。于广大佛法中起大功德想。熏修相续。虽到究竟住无漏界。而蒙诸佛觉悟引入方便开导。由此因故便能发趣广大菩提。彼于如是广大菩提。虽能发趣由乐寂故。于此加行极成迟钝。不如初始发心有佛种性者。一向趣寂声闻者。谓从本来是最极微劣慈悲种性故。一向弃背利益众生事故。于生死苦极怖畏故。唯有安住涅槃意乐。毕竟不能趣大菩提

如二王子相似处生。平等平等受王快乐。一于王政诗论工巧处等皆悉善知。第二王子则不如是。彼二但由此分差别。非由受用王之快乐。如是于无漏界中诸菩萨众与一向趣寂声闻。当知差别

应知彼二复有差别。谓意乐故。白法集成故。智集成故。种类故。种性故。持种故。加行故。威德故。正行故。福田故。殊胜差别故。因果故。生依止故

一向趣寂声闻弃背诸行杂染利益有情事故。一向安住寂静意乐。菩萨虽有垢染而与彼相违。又彼声闻唯为自身得增长故。白法狭小。菩萨为欲增长一切有情乐故。白法无量。又彼声闻由无为智。但为除遣自身烦恼。菩萨普为一切十方诸有情类。又彼声闻虽缘最胜解脱法境作意集成。而非佛子。菩萨虽缘下劣诸行有情法境作意集成。而是佛子。又彼声闻虽勤精进于谛善巧心善安定。不成就佛种性相故。诸佛世尊不堪摄受。而诸菩萨与彼相违。又彼声闻到究竟故。根虽成熟于当来世而不能作佛所作事。菩萨初心刹那生已便能造作。又彼声闻虽到究竟。而不为彼诸天人等供养赞叹。如住始业修行菩萨。而诸菩萨虽复未到究竟之位。然其威德及与智慧映蔽一切声闻独觉。又彼声闻疗烦恼病智慧良药虽复成满。而不能治一切众生诸烦恼病。而诸菩萨与彼相违。由能修行利益他事胜义行故。又彼声闻虽到究竟于诸有情智光明照然。非诸天及余世间真实福田。如诸菩萨未尽烦恼。又于声闻一切时中如来最胜。于最胜中诸菩萨众弥复最胜。彼由于此所集成故。又由二缘应知彼胜。彼能成熟诸有情故。亦能成熟诸佛法故。由此因缘感菩提果。随所成熟诸有情类。能令解脱。譬如有人能办能熟。觉慧希奇非彼端然而食用者。此中道理当知亦尔。又彼声闻虽复一向受学修行清净法因。亦为无量善友摄受。而不能引大菩提果。诸菩萨众与彼相违。而能引发。又诸声闻依菩萨生。非诸菩萨依彼声闻

复次云何由世间出世间智。能作利益他事。谓诸菩萨遍于十方。或游历世界。或游历国土。或游历生。或劝请他。为大良医。善能疗治烦恼鬼魅所著有情。为无有上。宣说三学清净之道。云何世间智。谓于粗品所有杂染。能为止息对治。于中品者能为制伏对治。云何名为粗品杂染。谓在家者贪嗔痴行性。诸出家者见依止性。及彼所依不正作意依止性。后有愿依止性。由总别四颠倒故。于非解脱执为解脱依止性

云何中品杂染。谓已止息粗品杂染。别别对治为依止故。于诸境界贪嗔痴缠依止性。于其所缘正系念故。令不定者心得安定。精勤修习菩提分法。方能制伏。不依此修而自恃举故。于所缘系心令住。勇猛精进。从此于住能正摄受。摄受住故。于积聚中。由一合执中烦恼转。便能制伏。从此为断出世间法所对治故。依止对治。即令坚住。从此能伏诸缘起愚。补特伽罗无我性愚。及法无我性愚。从此能于邪道正道皆得决定。由如是相应知粗品中品杂染止息制伏能对治智。是名世间智

云何出世间智。谓如是制伏贪嗔痴缠诸杂染已。复能对治微细随眠所有杂染。此真实智名出世智。此复云何。谓即依彼制伏对治三处善巧。谓缘起善巧。补特伽罗无我胜解善巧。法无我胜解善巧。为欲超度无余杂染对治四种无知故。不待他教。于内精勤观察自心。四无知者。一于共相无知。二于自相无知。三于杂染相无知。四于清净相无知。由三种相应知心共相。一于缘生者不现在前无作用故。二于现在者唯一刹那无作用故。三于贪等自缘所生非心作故。由三种相应知心自相。一者如前言说自性不可得故。二者如前由六种相如实可得故。三者一切圣者无差别智之所得故。由三种相应知心杂染相。一者生故。二者转故。三者行故。于诸趣中种种自体生故名杂染生。即于此中生者自然刹那有流转故。一切所缘难伏转故。贪爱势力之所转故。名杂染转。若于彼行若如是行。名杂染行。谓于一时行于善中。或于一时行不善中。或于一时行境界中。或于一时行造业中。或于一时行烦恼中。又于烦恼行贪嗔等。无决定行非。即于此行有贪已复行无贪。行无贪已复行有贪。如是等。又于随顺乐等法中。得为增上现行。又生自苦断坏众乐。不由执着故。但由颠倒故。由此引发自身众苦无有厌足。或于善中而安置时。即便弃舍思求瑕隙。为令不善现前行故。于其瑕隙及衰盛中。为诸爱恚之所损恼。又随放逸势力一切所作诸善根本皆令损坏。又极乐着色等境故。虽于极利益甘露界中数数思择。而难可安立。于此义中。示现假合所设譬喻其事应知。由三种相应知心清净相。一者不得得相故。二者无为相故。三者种性相故。若由别异如理勤修。求心清净不能证得。若由如是如理勤修。便能证得。又不观见言说自性。见真如相。此由九种相当观无为相。一者不行世故。二者非如在灭尽定言说自性不可得故。真如相可得故。是无二相。三者非生身相故。四者超过生身因自性相故。五者超过当来生故。六者超过死没故。七者超过刹那展转不远离故。八者超过趣转易故。九者超过业烦恼行故。此中种性相。当知是无学界相。于现法中超过五事。一者超过所作。二者超过非所作。三者超过所作加行。四者超过所作非加行。五者超过非所作加行。于后法中超过六事。一者超过能发起后有行。二者超过彼行。三者超过彼果生。四者超过依彼衰盛。五者超过于彼所依一切无记动摇中修学期愿受用。六者超过彼所依自体差别。复由四位九相应知种性相。何等四位。一不清净位。二清净位。三通达位。四究竟位。云何九相。谓不清净位。于一切相等随行故。譬如虚空。若清净位平等一味及身心远离。若通达位随顺趣究竟。由一切烦恼自性离系离垢故。超过萨迦耶见。及超过彼为根本诸恶见趣。若究竟位安乐成满。及超过三种变坏。何等名为三种变坏。一者老死等变坏。二者颠倒处变坏。三者清净退失变坏。

复次云何于菩萨教授中声闻所学。谓诸贪忧毗柰耶故。是增上戒学加行。厌患作意故。是增上心学加行。补特伽罗无我性故。或法无我性故。是增上慧学加行。此中贪忧是能发起所有毁犯。又如正不除遣。如已不除遣。如正除遣。如已除遣。由此四相。应知自心不如理作意所起贪欲。萨迦耶见。及与嗔恚。若由境界。或复由他而起妄计。如是名正不除遣。若由境界。或由他不饶益加行之所引夺。如是名已不除遣。由随一不除遣故。当知随一亦不除遣。由随一除遣故。当知随一亦复除遣。又若不除遣虽住律仪。于增上戒尚名毁犯。何况安住不律仪者。又增上心学于所缘境散乱错误。是能障碍依补特伽罗无我修增上慧者。萨迦耶见是能障碍依法无我修增上慧者。自性差别分别计缚是能障碍于此三学。正修遣中有八种违逆学法。有八种随顺学法。何等为八。一者唐捐耽着。二者耽着故缚。三者缚故障碍。四者障碍故垢。五者垢故灾雹。六者雹故疮疱。七者疮疱故热恼。八者热恼故诸烦恼病难可疗治。与此相违当知即是八种随顺学法

复次云何不善学沙门。谓三种。应知一者不顾沙门。二者形相同分。三者轨则正命受用加行戒见意乐皆不同分。若回向资具是增上戒。形相同分是增上心及增上慧。形相同分是彼行意乐不同分。若回向声誉是奢摩他支。同分是毗钵舍那支。同分是俱修支。同分是俱资粮支。同分是意乐不同分

复次云何善学沙门。当知由四种相。一者加行故。二者意乐故。三者通达故。四者趣究竟故。于现法中由厌患加行故。于前生中由相续成熟加行故。当知加行圆满。由法无我胜解意乐故。若所应得。若能应得。于此二言说自性无执着故。于意趣义正寻求故。不但随顺言词故。当知意乐圆满。若于法真如以不缘他智通达自性无杂染故。于世俗宝及世俗生死。涅槃解脱。系缚自性无所得故。当知通达圆满。已善修习一切杂染对治故。又于真如无断坏故。及能胜伏故。当知趣究竟圆满

复次不善学沙门。由三种相当知彼名不如其义。一者意乐衰损加行具足。二者意乐具足加行衰损。三者意乐衰损加行衰损。此中意乐衰损加行具足。复有三种。一者能听唯此喜足。二者能说唯此喜足。三者能证世间三摩地而生爱味唯此喜足。若善学沙门唯由一相当知意乐具足加行具足

复次云何住世俗律仪。当知有四种相。谓虽成就六支尸罗。而为二种损害损害尸罗。谓由萨迦耶见缠故。及于毁犯出离不了知故。虽远离此二种过失。而未得世间清净律仪。不能制伏萨迦耶见。虽已得世间清净律仪。已制伏萨迦耶见。而不损减串习法无我性怖畏。损坏尸罗。虽远离一切所余过失。而为邪法无我胜解。及增上慢。损坏尸罗

复次云何住胜义律仪。谓所成就出世间。一切烦恼不相应。能对治三界尸罗。又于四种住律仪中。诸戏论法现所可得。若能寂静彼相。当知是名无漏尸罗。云何名为诸戏论法。谓于初住律仪中我执可得。若我所执。若作毁犯。若不作彼。若故思所作加行。若非彼加行。若正知而行。若彼不行。若失念而行。若彼不行。于第二住律仪中萨迦耶见品粗重随行。若名可得。若色可得。若当来生相。若今时无相。若缠寂静。若随眠故彼不寂静。若补特伽罗无我执。若补特伽罗执弃舍。若即于彼补特伽罗无我执中所执性。若非所执性。若由此故于色等中有情执。若彼假设赞善执。若能假设心语假设赞善执。于第三住律仪中。若生上故世间。若舍下故非世间。若三摩他依止。若诸欲依止。若恃举自尸罗。若轻蔑他尸罗。于第四住律仪中若计我尸罗清净。若由自性差别分别故分别尸罗。如是等诸戏论法。于无漏戒中皆悉寂静。又即与此义相应。依清净三学应知所说伽他。当知为令福德资粮尘垢微薄。摄受善士。无失坏故。智慧资粮于甚深处起胜解故。由二因缘入如来教。一者由法住智深了别故。二者由真实智善决定故

复次云何如来调伏方便。当知此有二种。谓自体同分故。及胜解同分故。又现同分为令安住受教心故。及依教授而出离故。又正清净加行教导教授当知复有四种。一者于杂染清净惊怖转依教导二者远离杂染因缘教导。三者远离于清净惊怖因缘教导。四者第一现法乐住加行教导。此中杂染因缘有二种。一者由世俗言说自性杂染自性执分别故。二者由彼功德过失差别执分别故。由二种相应知于清净导惊怖因缘。一者由于前后清净导杂染分别故。二者由杂染远离分别故。由二种相应知于涅槃清净惊怖因缘。一者由世俗言说自性执故。二者于涅槃增语想中作心所有想故。又于寂静心所有想。若增语想遍了知故。于彼二因缘俱远离故。当知是第一住加行教导。

复次云何名为密意语言。谓无二相智。是能悟入一切密意语言相。云何无二相谓诸名言安足处事。由彼自性无所有故。非名言熏习想所行自性有故。说为无二。于此无二若起二执。名为杂染。若无二执。名为清净。又非一切名言安足处事。由彼世俗言说熏习想所行自性无所有故。非彼熏习智所行自性有故。说为无二。于此无二若起二执。名为杂染。若无二执。名为清净。由此无二相。应知悟入如来一切密意语言。此中由五种相名论圆满。即于教授中由五种相名果圆满。由五种相名果胜利圆满。当知皆依密意语言。云何由五种相名论圆满。谓若由此相宣说。若是宣说。若所宣说。若如是宣说。若彼宣说。如是圆满。云何由五种相名果圆满。谓无余依涅槃界。若有余依涅槃界。若圣道圆满。若胜内怨。若胜外怨。如是圆满。云何由五种相名果胜利圆满。谓即是供养大师。报信施恩。越生死苦。于福田性无有退转。从法化生名如来子。依止如来

复次云何于菩萨藏教授中胜解胜利。当知由五种相。一者建立因时即能映蔽感大富贵增上因故。二者由转依故。三者即于是处作说器故。四者作说者器故。五者于舍身时得见业清净故。由五种相当知映蔽感大富贵增上之因。所谓此因能引有量无量果故。有尽无尽法故。感非广大广大乐故。是智资粮智自性故。由此能引彼故。又由远离六种过失。应知身行。何等名为六种过失。一者愁忧相过失。二者不了知数习过失。三者由二种相威仪过失。四者由三种相怖畏相过失。五者由二种相遏履瑟吒过失。六者身不调柔过失。又于相庆慰时远离五种过失。应知语行何等名为五种过失。一者怯怖过失。二者粗犷过失。三者弃舍佛语作不相应戏论过失。四者不赞叹如来过失。五者于同法者不施谏诲过失。又于记别所解了时远离五种过失。应知语行。何等名为五种过失。一者于所证得忘念过失。二者前后语言相违过失。三者道理相违过失。四者敬信圣教诸天诃责过失。五者如来诃责过失。又由远离五种过失。应知意行。谓依现法义有前四种。依后法义有第五种。何等名为五种过失。一者不忍过失。不能忍受现在过去不饶益事故。二者覆藏过失。由覆藏故。恶作烧恼故。三者贪染过失。希求诸欲及受用故。希求出离怨故。四者忘念过失。摄受不正见故于断心迷乱故。五者期愿过失。由自轻贱远离广大诸佛菩萨之所加被诸佛国土微妙愿故。由微细意乐引发诸佛法故。于一切法殊胜世间兴盛差别起憍慢故。及愿彼故。于分别菩萨藏教授胜解胜利无量标释中。当知有无量无数胜解胜利。

于此地中余决择文更不复现

    摄决择分中有余依及无余依二地

如是已说菩萨地决择。有余依无余依二地决择。

我今当说嗢拖南曰

  离系与寿行　　转依住差别
  有常乐殊胜　　异性自在等

问于有余依涅槃界中现在转时。一切烦恼当言离系耶。当言不离系耶。答当言离系问于一切苦。当言离系耶。当言不离系耶。答当言亦离系亦不离系。所以者何。若未来生所有众苦当言离系。若现在生心所有苦亦当言离系。若现身中饥苦渴苦界不平苦时节变苦。及余所有逼迫等苦。当言不离系。此由现前行故。非诸烦恼所系缚故

问若一切阿罗汉皆得心自在。何因缘故。不舍寿行入般涅槃。虽苦所逼而久住耶。答功能有差别故。所以者何。有一分阿罗汉能舍寿行。一分不能。有一分阿罗汉能增寿行。一分不能故

问若阿罗汉如先所有六处生起。即如是住相续不灭。无有变异。更有何等异转依性。而非六处相续而转。若更无有异转依者。何因缘故。前后二种依止相似而今后时烦恼不转。圣道转耶。答诸阿罗汉实有转依。而此转依与其六处。异不异性俱不可说。何以故。由此转依真如清净所显。真如种性。真如种子。真如集成。而彼真如与其六处。异不异性俱不可说。不可说义。如前已辩。是故若问所得转依与其六处为异不异。非如理问。若此转依无有体者。应有如前所说过失。谓阿罗汉烦恼应行。道应不行。是故当知有转依性。世尊依此转依体性密意说言

  遍计自性中　　由有执无执
  二种习气故　　成杂染清净
  是即有漏界　　是即无漏界
  是即为转依　　清净无有上

如屠牛师或彼弟子。以利牛刀杀害牛已。于内一切斫刺椎剖骨肉筋脉皆悉断绝。复以其皮张而蔽之。当言此牛与皮非离非合。如是诸阿罗汉既得转依。由慧利刀断截一切结缚随眠随烦恼缠已。当言与六处皮非离非合。又已转依诸观行者。虽取众相。当知与昔所取差别。此所取相犹如真如自内所证。不可以言说示于他我所观相如是如是。

问诸阿罗汉住有余依涅槃界中。住何等心。于无余依般涅槃界。当般涅槃。答于一切相不复思惟。唯正思惟真无相界。渐入灭定灭转识等。次异熟识舍所依止。由异熟识无有取故。诸转识等不复得生。唯余清净无为离垢真法界在。于此界中般涅槃已。不复堕于天龙药叉。若干达缚。若紧奈洛。若阿素洛。若人等数。以要言之。所有有情假想施设。遍于十方一切界。一切趣。一切生。一切生类。一切得身。一切胜生。一切地中。非此更复堕在彼数。何以故。由此真界离诸戏论。唯成办者内自证故

问于有余依涅槃界中。若无余依涅槃界中。已般涅槃诸阿罗汉。有何差别。答住有余依。堕在众数。住无余依。不堕众数。住有余依。犹有众苦。住无余依。永离众苦。住有余依。所得转依犹与六处而共相应。住无余依永不相应

问若无余依涅槃界中。已般涅槃所有转依永与六处不相应者。彼既无有六处所依。云何而住。答非阿罗汉所得转依六处为因。然彼唯用缘真如境修道为因。是故六处若有若无。尚无转依成变异性。何况殒没。又复此界非所遍知。非所应断。故不可灭。

问于无余依涅槃界中。般涅槃已所得转依。当言是有。当言非有。答当言是有。问当言何相。答无戏论相。又善清净法界为相。问何因缘故当言是有。答于有余依及无余依涅槃界中。此转依性皆无动法。无动法故。先有后无不应道理。又此法性非众缘生。无生无灭。然譬如水澄清之性。譬如真金调柔之性。譬如虚空离云雾性。是故转依当言是有

问当言是常。当言无常。答当言是常。问何因缘故当言是常。答清净真如之所显故。非缘生故。无生灭故

问当言是乐。当言非乐。答由胜义乐当言是乐。非由受乐。说名为乐。何以故。一切烦恼及所生苦皆超越故

问于无余依涅槃界中。般涅槃者。为有少分差别意趣殊异不耶。答一切无有。所以者何。非此界中可得安立下中上品。不可施设高下胜劣。此是如来此声闻等。问何因缘故无有差别。所以者何。诸声闻等有余残障。于无余依涅槃界中而般涅槃。佛一切障永无所有。答住有余依涅槃界中。可得安立有障无障。住无余依涅槃界中。毕竟无障可立差别。何以故。于此界中一切众相。及诸粗重皆永息故。皆永灭故。所以者何。诸阿罗汉住有余依涅槃界时。一切众相非悉永灭。异熟粗重亦非永灭。由彼说有烦恼习气。即观待彼相及粗重安立有障。住无余依涅槃界时。彼永无有。是故当知于此界中。无有有障无障差别。问若此界中永无有障。如诸如来离一切障。阿罗汉等亦复如是。何因缘故。阿罗汉等不同如来作诸佛事。答彼阙所修本弘愿故。又彼种类种性尔故。阿罗汉等决定无有还起意乐。而般涅槃。是故不能作诸佛事

问于无余依涅槃界中。般涅槃者所有无漏界。此与诸色。当言有异。当言无异。答当言非异亦非不异。如与诸色。与诸受等。当知亦尔。与一切行。与一切界。与一切趣。亦复如是。

问于无余依涅槃界中。般涅槃者。于色等法当言获得自在。当言不得自在。答当言获得自在。问此所得自在。当言能现在前。当言不能现在前。答一分能现在前。一分不能现在前。谓诸如来于无余依涅槃界中。般涅槃已能现在前。所余不能令现在前。问若此界中离诸戏论。由此因缘不堕众数。云何复能起现在前。答由先发起正弘愿故。又由修习与彼相似道势力故。譬如正入灭尽定者。虽无是念我于灭定当可还出。或出已住。然由先时加行力故。还从定出。依有心行而起游行当知此中道理亦尔

问回向菩提声闻。为住无余依涅槃界中。能发趣阿耨多罗三藐三菩提耶。为住有余依涅槃界耶。答唯住有余依涅槃界中可有此事。所以者何。以无余依涅槃界中。远离一切发起事业。一切功用皆悉止息

问若唯住有余依涅槃界中。能发趣阿耨多罗三藐三菩提者。云何但由一生便能证得阿耨多罗三藐三菩提耶。所以者何。阿罗汉等尚当无有所余一生。何况当有多生相续。答由彼要当增诸寿行。方能成办。世尊多分依此回向菩提声闻。密意说言。物类善男子若有善修四神足已。能住一劫或余一劫余一劫者。此中意说过于一劫。彼虽如是增益寿行。能发趣阿耨多罗三藐三菩提。而所修行极成迟钝。乐涅槃故。不如初心始业菩萨。彼既如是增寿行已。留有根身。别作化身。同法者前方便示现。于无余依般涅槃界。而般涅槃。由此因缘皆作是念。某名尊者于无余依般涅槃界。已般涅槃。彼以所留有根实身。即于此界赡部洲中。随其所乐远离而住。一切诸天尚不能睹。何况其余众生能见。彼于涅槃多乐住故。于遍游行彼彼世界。亲近供养佛菩萨中。及于修习菩提资粮诸圣道中。若放逸时诸佛菩萨数数觉悟。被觉悟已。于所修行能不放逸

问若阿罗汉回向菩提。便能证得阿耨多罗三藐三菩提者。何因缘故。一切阿罗汉不皆回向无上菩提。答由彼种性有差别故。所以者何。诸阿罗汉现见种性有多差别。谓或见有诸阿罗汉俱分解脱。或复见有唯慧解脱于无余依般涅槃界。而般涅槃。是故当知由彼种性有差别故。非一切阿罗汉皆能回向无上菩提

复次回向菩提声闻。或于学位即能弃舍求声闻愿。或无学位方能弃舍。由彼根性有差别故。所待众缘有差别故

如回向菩提声闻由遇缘故。乘无上乘而般涅槃如是。菩萨设为如来及诸菩萨之所弃舍。因弃舍故。若遭尤重求下劣乘般涅槃缘。应乘下乘而般涅槃。然无处。无容诸佛菩萨如是放逸。弃舍于彼。定无是处

复次回向菩提声闻。若随证得阿耨多罗三藐三菩提。尔时即同如来。于无余依般涅槃界。而般涅槃

问回向菩提声闻。从本已来当言声闻种性。当言菩萨种性。答当言不定种性。譬如安立有不定聚诸有情类于般涅槃法性聚中。当知此是不定种性

复次彼即于此住处转时。如无死畏。如是亦无老病等畏。如来亦尔。彼及所余于无余依涅槃界中。般涅槃者。于十方界当知究竟不可思议。数数现作一切有情诸利益事。如首楞伽摩三摩地中说幻师喻。若商主喻。若船师喻。当知此中道理亦尔。是名最极如来秘密。于此及余种种差别如来秘密。胜解行地修行菩萨下忍转时。随其胜解差别而转。从此转胜进入增上意乐净地。如是乃至于九地中。展转增进。胜解清净。第十地中于此胜解最善清净。于彼如来诸秘密中。是诸菩萨应正随转。当知如来如是秘密。不可思议不可度量。超过一切度量境界。问于法决择总义云何答

  由品类差别　　而建立诸法
  即于彼释难　　分别一行等

如是应知此中总义。于此地中余决择文更不复现。当知于彼一一地中。皆有无量决择差别。我今且略开示少分。由此方隅由此所学由此教导。诸有智者余类应思

瑜伽师地论卷第八十瑜伽师地论卷第八十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄释分之上

如是已说摄决择。

云何摄释。总嗢拖南曰

  体释文义法　　起义难次师
  说众听赞佛　　略广学胜利

云何为体。为契经体。略有二种。一文。二义。文是所依。义是能依。如是二种总名一切所知境界

云何为释。谓略有五。一者法。二者等起。三者义。四者释难。五者次第

云何为文。谓有六种。一者名身。二者句身。三者字身。四者语。五者行相。六者机请

名身者。谓共知增语。此复略说有十二种。一者假立名。二者实事名。三者同类相应名。四者异类相应名。五者随德名。六者假说名。七者同所了名。八者非同所了名。九者显名。十者不显名。十一者略名。十二者广名。假立名者。谓于内假立我及有情命者等名。于外假立瓶衣等名。实事名者。谓于眼等色等诸根义中。立眼等名。同类相应名者。谓有情色受大种等名。异类相应名者。谓佛授德友青黄等名。随德名者。谓变碍故名色。领纳故名受。发光故名日。如是等名。假说名者。谓呼贫名富。若余所有不观待义安立其名。同所了名者。谓共所解想。与此相违是非同所了名。显名者。谓其义易了。不显名者。谓其义难了。如达罗弭茶明咒等。略名者。谓一字名。广名者。谓多字名

句身者。谓名字圆满。此复六种。一者不圆满句。二者圆满句。三者所成句。四者能成句。五者摽句。六者释句。不圆满句者。谓文不究竟。义不究竟。当知复由第二句故方得圆满如说

  诸恶者莫作　　诸善者奉行
  善调伏自心　　是诸佛圣教

若唯言诸恶。则文不究竟。若言诸恶者。则义不究竟。更加莫作方得圆满。即圆满句。所成句者。谓前句由后句方得成立。如说

  诸行无常　　有起尽法　　生必灭故
  彼寂为乐

此中为成诸行无常故。次说言有起尽法。前是所成。即所成句。后是能成。即能成句。摽句者。如言善性。释句者。谓正趣善士

字身者。谓若究竟若不究竟名句所依四十九字

此中欲为名首。名为句首。句必有名。名必有字。若唯一字则不成句。又若有字名所不摄。唯字无名。问何因缘故施设名等三种身耶。答为令领受诸增语触所生受故。问名是何义。答能令种种共所了知故。名为名。又能令意作种种相故。名为名。又由语言之所呼召故。名为名。摄受诸名究竟显了不现见义故。名为句。随显名句故。名为文。如世尊说增语增语路。乃至广说此中增语者。谓一切众同类相应名增语。路者谓并众同类欲能起彼故。词者。谓彼相应语。又即此语各别于彼彼处若摽若释。彼所依处。名为彼路。施设者。谓一一分别施设。建立彼所依处。名为彼路。欲即是词。无有别欲。此即增语施设之路。又名身等略有六种依处。一者法。二者义。三者补特伽罗。四者时。五者数。六者处所。彼广分别当知已如闻所成地。语者。当知略具八分。谓先首美妙等由彼语文句等相应。乃至常委分资粮故能说正法。先首语者。趣涅槃宫为先首故。美妙语者。其声清美如羯罗频迦音故。显了语者。谓词句文皆善巧故。易解语者。巧辩说故。乐闻语者。引法义故。无依语者。不依希望他信己故。不违逆语者。知量说故。无边语者。广大善巧故。如是八种语当知略具三德。一者趣向德。谓初一种。二者自体德。谓次二种。三者加行德。谓所余种。相应者。谓名句文身次第善安立故。又依四种道理相应故。助伴者。能成次第故。随顺者。谓解释次第故。清彻者。文句显了故。清净资助者。善入众心故。相称者。如众会故。应供故。称法故。引义故。顺持故。常委分资粮者。审悉所作恒常所作故。名常委。彼分者。谓正见等此是彼资粮故

行相者。谓诸蕴相应。诸界相应。诸处相应。缘起相应。处非处相应。念住相应。如是等相应语言。或声闻说。或如来说。或菩萨说。是名行相。机请者。谓因机请问而起言说。此复根等差别当知有二十七种补特伽罗。此中由根差别故成二种。一者钝根。二者利根。由行差别故。成七种。谓贪等行。如声闻地已说。由众差别故。成二种。一者在家众。二者出家众。由愿差别故。成三种。一者声闻。二者独觉。三者菩萨。由可救不可救差别故。成二种。谓般涅槃法。不般涅槃法。由加行差别故。成九种。一已入正法。二未入正法三有障碍。四无障碍。五已成熟。六未成熟。七具縳。八不具缚。九无缚。由种类差别故。成二种。一者人。二者非人。如是六文总有四相。说名为文。一所说相。谓名身等行相为后。二所为相。谓机请摄二十七种补特伽罗。三能说相。谓语。四说者相。谓声闻菩萨及与如来。如是六种皆显于文。若阙一种。不能显义。由能显义是故名文

云何为义。当知略有十种。一者地义。二者相义。三者作意等义。四者依处义。五者过患义。六者胜利义。七者所治义。八者能治义。九者略义。十者广义。地义者。略有五地。一者资粮地。二者加行地。三者见地。四者修地。五者究竟地。又广分别有十七地。谓五识身地为初。无余依地为后。相义者。当知有五种相。一者自相。二者共相。三者假立相。四者因相。五者果相。如是五相。如思所成地已辩。复有五相。一者异门相。二者瑜伽相。三者转异相。四者杂染相。五者清净相。如是五相。当知如前处处分别。复有五相。一者所诠相。二者能诠相。三者此二相应相。四者执着相。五者不执着相。所诠相者。谓相等五法。如五事中已说。能诠相者。谓即于彼依止名等。为欲随说自性差别所有语言。应知此即是遍计所执自性相。此遍计所执自性。有差别名。所谓亦名遍计所执。亦名和合所成。亦名所增益相。亦名虚妄所执。亦名言说所显。亦名文字加行。亦名唯有音声。亦名无有体相。如是等类差别应知。此二相应相者。谓所诠能诠更互相应。即是遍计所执自性执所依止。执着相者。谓诸愚夫无始时来相续流转遍计所执自性执及彼随眠。不执着相者。谓已见谛者如实了知遍计所执相及彼习气解脱。若正分别如思所成地。应知其相

作意等义者。谓七种作意。即了相等。如前声闻地已说。复有十智。一者苦智。二者集智。三者灭智。四者道智。五者法智。六者种类智。七者他心智。八者世俗智。九者尽智。十者无生智。此亦如前声闻地辩。复有六识身。所谓眼识乃至意识。此亦如前五识身地意地已辩。复有九种遍知。一者欲界系见苦集所断断遍知。二者色无色界系见苦集所断断遍知。三者欲界系见灭所断断遍知。四者色无色界系见灭所断断遍知。五者欲界系见道所断断遍知。六者色无色界系见道所断断遍知。七者顺下分结断遍知。八者色贪尽遍知。九者无色贪尽遍知。如三摩呬多地已辩其相。复有三解脱门。谓空无愿无相。当知亦如三摩呬多地已辩其相。此中应当分别诸法几种作意之所思惟。几智所知。几识所识。几种遍知之所遍知。几解脱门之所解脱。以如是等无量观门。应观诸法

依处义者。略有三种。一者事依处。二者时依处。三者补特伽罗依处

事依处者。复有三种。一者根本事依处。二者得方便事依处。三者悲愍他事依处。根本事依处。复有六种。一者善趣。二者恶趣。三者退堕。四者升进。五者生死。六者涅槃。得方便事依处。复有十二种。谓十二种行。一者欲行。二者离行。三者善行。四者不善行。五者苦行。六者非苦行。七者顺退分行。八者顺进分行。九者杂染行。十者清净行。十一者自义行。十二者他义行。悲愍他事依处。复有五种。一者令离欲。二者示现。三者教导。四者赞励。五者庆喜

此中善趣者。谓人天。恶趣者。谓诸恶趣。退堕者。复有二种。一者不方他。二者方他。初谓自然寿命退减。如寿命退减如是。色力财富。安乐名称。辩才等退减。当知亦尔。方他者。谓族姓退减。自在增上退减。薄小宗叶。言不威肃。智慧弊恶。不能获得广大色声及香味触。于所受用广大事中。心不喜乐。如是等类。名为退堕。与此相违。随其所应。名为升进。生死者。谓即善趣恶趣退堕升进。涅槃者。谓有余依及无余依二涅槃界

欲行者。谓如十种受用欲中说。离行者。谓即于彼所受用事。知无常等已厌而出家。受持禁戒。守根门等。善行者。谓施戒修善有漏行。不善行者。谓三种恶行。苦行者。谓露形无衣如是等类。乃至广说。非苦行者。谓不弃舍如法所得所有安乐。远离二边所谓受用欲乐行边。及与受用自苦行边。依止中道如法追求。及正受用衣服等事。顺退分行者。谓所有行能障寿等诸升进事。与此相违。当知即是顺进分行。如鹦鹉经说。杂染行者。略有三种。一者业杂染。二者烦恼杂染。三者流转杂染。当知此中有九根本句。谓业杂染有三句。一贪欲。二嗔恚。三愚痴。烦恼杂染有四句。即四颠倒。流转杂染有二句。谓无明及有爱。所以者何。由三不善根。生起种种业杂染故。由四颠倒能发种种烦恼杂染故。烦恼生已由无明门。诸出家者。能生种种流转杂染。由有爱门诸在家者。能生种种流转杂染。清净行者。略有三学五地。谓资粮地乃至究竟地。如先已说。当知学等有九根本句。谓增上戒学及增上心学。有无贪无嗔无痴。在资粮地及加行地增上慧学。有四无颠倒。明及解脱。在见地修地及究竟地。自义行者。谓自利行如声闻独觉。彼虽或时起利他行。然本期愿不唯利他。是故所行名自义行。他义行者。谓利他行。如佛菩萨为欲利益无量众生。为欲安乐无量众生。乃至广说

令离欲者。谓诃责六种黑品诸行。示现过患令离爱欲。示现者。谓为令受学白品行故。示现四种真实道理。教导者。谓示现已得信解者。安置学处令正受行。由已于彼得自在故。彼便请言。我于今者当何所作。唯愿教诲。因告之曰。汝等今者于如是如是事。应正作。应随学。赞励者。谓彼有情若于所知所行所得中心生退屈。尔时称赞策励其心。令于彼事堪有势力。庆喜者。谓彼有情于法随法勇猛正行即应如实赞悦令其欢喜

复次令离欲示现者。或有令离欲而不示现。如教导他令其离欲。而谓彼曰。如某所言不应作者。汝今必定不应复作。或怖彼言汝若作者我必当作如是如是。或复求彼汝若是我亲爱善友。必不应作。或有示现不令离欲。如处中者。示现功德及与过失。而未堪遮令离过失。或有令离欲亦示现。如示彼过令其离欲。教导赞励者。谓初未受学令其受学。既受学已未上升进。令其升进。庆喜者。若可庆喜而庆喜时。有五胜利。一者令彼于己所证其心决定。二者令余于彼所证功德生趣证心。三者令诽谤者心得清净。四者令不清净者心处中住。五者令清净者倍复增长。若有补特伽罗庆他善事。当知造作增长。能感悦意天生之业。若命终已。随彼彼生。常闻悦意美妙音声。一切境界无不悦意。复次欲行或有能感善趣。如为欲故造后善业。或有能感恶趣。如以非法摄受诸欲。离行若有毁犯能感恶趣。若能成办能感善趣。及能作涅槃资粮。善行能感善趣。及作涅槃资粮。不善行能感恶趣。苦行能感恶趣。由依邪见自苦身故。非苦行能作涅槃资粮。顺退分行顺进分行。随其所应。退堕升进杂染行。能感生死。清净行能证涅槃。自义行唯令自身往善趣。逮升进证涅槃。他义行俱令自他往善趣。逮升进证涅槃

如是三事中根本事有六种。谓初善趣乃至涅槃为后。得方便事有十二种。谓十二行。悲愍他事有五种。谓由五种悲愍众生。此中由根本事增上力故。依十二行。如其所应令他离欲。乃至庆喜

时依处者。谓略有三种言事。一者过去言事。二者未来言事。三者现在言事。如经广说

补特伽罗依处者。谓软根等二十七种补特伽罗。应知其相

即依如是如上所说。若事若时若补特伽罗故。诸佛世尊流布圣教。是故说彼名为依处。过患义者。以要言之。于应毁厌义而起毁厌。或法或补特伽罗

胜利义者。以要言之。于应称赞义而起称赞。或法或补特伽罗

所治义者。以要言之。一切杂染行能治义者。以要言之。一切清净行。如贪是所治不净为能治。嗔是所治慈为能治。如是等尽当知

略义者。谓宣说诸法同类相应。广义者。谓宣说诸法异类相应。复次说不了义经故。说了义经故。复次有二种略义。一者名略。二者义略。如略义如是广义。亦有二种。一有名广。二者义广。如世尊言舍利子我所说法。或略或广。然悟解者甚难可得。广说如经。当知。此中显示世尊于契经中文广义略。于伽他中义广文略

为摄十义故。说中间。嗢拖南曰

  诸地相作意　　依处德非德
  所对治能治　　广略义应知

复次如是略说佛教体性十种义已。诸说法者应依圣教寻求十种若具不具。既自求已应为他说

如是建立诸经文义体已。诸说法者应以五相随顺解释一切佛经。谓初应略说法要。次应宣说等起。次应宣说其义。次应释难。后应辩次第

法者。略有十二种。谓契经等十二分教。契经者。谓贯穿义长行直说。多分摄受意趣体性

应颂者。谓长行后宣说伽他。又略摽所说不了义经

记别者。谓广分别略所摽义。及记命过弟子生处

讽颂者。谓以句说。或以二句或以三四五六句说

自说者。谓无请而说。为令弟子得胜解故。为令上品所化有情安住胜理。自然而说。如经言世尊今者自然宣说。缘起者。谓有请而说。如经言世尊一时依黑鹿子为诸苾刍宣说法要。又依别解脱因起之道。毗奈耶摄所有言说。又于是处说如是言。世尊依如是如是因缘。依如是如是事。说如是如是语

譬喻者。谓有譬喻经。由譬喻故隐义明了。本事者。谓除本生。宣说前际诸所有事本生者。谓宣说己身于过去世行菩萨行时自本生事

方广者。谓说菩萨道。如说七地四菩萨行。及说诸佛百四十种不共佛法。谓四一切种清净。乃至一切种妙智。如菩萨地已广说。又复此法广故。多故。极高大故。时长远故。谓极勇猛经三大劫阿僧企耶。方得成满故。名方广。未曾有法者。谓诸如来。若诸声闻。若在家者说希奇法。如诸经中因希有事起于言说。论议者。谓诸经典循环研窍摩呾理迦。且如一切了义经皆名摩呾理迦。谓于是处世尊自广分别诸法体相。又于是处诸圣弟子已见谛迹。依自所证无倒分别诸法体相。此亦名为摩呾理迦。即此摩呾理迦亦名阿毗达磨。犹如世间一切书算诗论等皆有摩呾理迦。当知经中循环研窍诸法体相。亦复如是。又如诸字若无摩呾理迦即不明了。如是契经等十二分圣教。若不建立诸法体相。即不明了。若建立已即得明了。又无杂乱宣说法相。是故即此摩呾理迦。亦名阿毗达磨。又即依此摩呾理迦。所余解释诸经义者。亦名论义

等起者。谓由三种若事若时若补特伽罗依处故。随应当说。谓如是补特伽罗。有如是行。为令离欲乃至庆喜。已说等起。次应说义。义者。略有二种。一者总义。二者别义。由四种相当说总义。一者引了义经故。二者分别事究竟故。三者行故。四者果故。行复二种。一者邪行。二者正行。果亦二种。一者正行果。二者邪行果。由四种相当说别义。一者分别差别名。二者分别自体相。三者训释言词。四者义门差别。训释言词。复由五种方便。一由相故。二由自性故。三由业故。四由法故。五由因果故。义门差别。当知复由五相。一者自性差别故。二者界差别故。三者时差别故。四者位差别故。五者补特伽罗差别故。此中自性差别者。谓色自性有十色处差别。受自性有三受差别。想自性有六想差别。行自性有三行差别。识自性有六识差别。如是等类当知诸法自性差别。界差别者。谓欲界差别故。色界差别故。无色界差别故。时差别者。谓过去时差别故。未来时差别故。现在时差别故。位差别者。当知有二十五种分位差别。谓下中上三位差别故。苦乐不苦不乐三位差别故。善不善无记三位差别故。闻思修三位差别故。增上戒增上心增上慧三位差别故。内外二位差别故。所取能取二位差别故。所治能治二位差别故。现前不现前二位差别故。因果二位差别故。补特伽罗差别者。如前所说二十七种补特伽罗。应知差别

释难者。若自设难若他设难皆应解释。当知此难略由五相。一者为未了义得显了故。如言此文有何义耶。二者语相违故。如言何故世尊先所说异。今所说异。三者道理相违故。如有显示与四道理相违之义。四者不决定显示故。如言何故世尊于一种义。于彼彼处种种异门。差别显示。五者究竟非现见故。如言内我有何体性有何色相。而言常恒无有变易如是正住。如是等类难相应知。于此五难随其次第应当解释。谓于不了义难方便显了。于语相违难显示意趣随顺会通。如于语相违难显示意趣随顺会通。如是于不决定显示难。于究竟非现见难。当知亦尔。于道理相违难。或以异教而决判之。或复示现四种道理。或复示现因果相应。所谓此言或为增果。或为增因。又于释难应设四记。一者一向记。谓为如理来请问者。无倒建立诸法性相。二者分别记。谓为如理或不如理来请问者。开示差别诸法性相。三者反问记。谓为令彼戏论问者自叙己过。四者置记。由四因缘默置而记。谓无体性故。甚深等故。此广如前思所成地已说其相。又如有问如来灭后为有无等。此于世俗及胜义谛所有理趣。皆不应记。是故说彼名为置记。此中如来约胜义谛。非有性故不可记别。约世俗谛。所依能依道相违故。彼果永断不成实故。亦不可记如来灭后是有无等

次第者。略有三种。一者圆满次第。二者解释次第。三者能成次第。为欲显示此三次第。略引圣教。如世尊言我昔出家甚为盛美。第一盛美最极盛美。此言显示盛美圆满次第。又复说言。我曾处父净饭王宫。颜容端正。乃至广说。此言显示盛美解释次第。又复说言为何义故盛美出家。由见老病死等法故。此言显示能成次第。又复经中略说诸法。如言三受乐受苦受不苦不乐受。如是等类。但显圆满次第。由所余句圆满此受故。名圆满。如受四谛亦尔。谓先说一句。后后随顺次第宣说。能成次第复有二种。谓或以前句成立后句。或以后句成立前句。解释次第当知亦尔

师者。谓成就十法。名说法师众相圆满。一者善于法义。谓于六种法十种义。善能解了故。二者能广宣说。谓多闻闻持其闻积集故。三者具足无畏。谓于刹帝利等胜大众中。宣说正法无所怯惧故。又因此故声不嘶掉。腋不流汗。念无忘失故。四者言词善巧。谓语工圆满。八支成就。言词具足。处众说法故。语工圆满者。谓文句相应助伴等。乃至广说。八支成就者。谓此语言先首美妙等。乃至广说。五者善方便说。谓二十种善巧方便宣说正法故。如以时殷重等。六者具足成就法随法行。谓不唯听闻以为究竟。如其所说即如是行故。七者威仪具足。谓说法时手足不乱。头不动摇。面无变易。鼻不改异。进止往来威仪庠序故。八者勇猛精进。谓常乐听闻所未闻法。于已闻法转令明净。不舍瑜伽。不舍作意心。不舍离内奢摩他故。九者无有厌倦。谓为四众广宣妙法。身心无倦故。十者具足忍力。谓骂弄诃责终不反报。若被轻蔑不生忿戚。乃至广说

说众者。谓处五众宣八种言。何等为八。一者可喜乐言。二者善开发言。三者善释难言。四者善分析言。五者善顺入言。六者引余证言。七者胜辩才言。八者随宗趣言。五众者。一在家众。二出家众。三净信众。四邪恶众。五处中众

可喜乐言者。当知有五相。一有证因。二有譬喻。三语具圆满。四文句绮靡。五言词显了。善开发言者。开深隐义令粗显故。辩粗显义令深隐故。善释难言者。以要言之。当知离五种难善成就故。善分析言者。于一一法依增一道理。乃至析为十种。或复过此。如依三法说或依四念住。乃至广说。善顺入言者。唯善显现解释契经应颂等法。终不引余外道邪论。引余证言者。谓引余经成立所说。胜辩才言者。随自所忍善分别义。随宗趣言者。依摩呾理迦分别显示。或依其余无倒说者所说言教。如理解释

复次处在家众。应依毁诸恶行赞诸善行。现说正法令其止息及进修故。处出家众。应依增上戒等三学。现说正法令速欣乐故。处净信等众。应依圣教广大威德。现说正法如其次第令倍增长。令处中信。令生净信故

瑜伽师地论卷第八十一瑜伽师地论卷第八十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄释分之下

听者。谓如是说法者说正法时。应安处他令住恭敬无倒听闻。云何安处。谓或由一因或乃至十

一因者。谓恭敬听法。现前能证利益安乐故。此中或有利益非安乐等四句。如菩萨地法受中已说

二因者。谓善建立一切法故。善建立者。离诸过故具大义故。又为说者听者所设劬劳有胜果故。若不尔者。能说能听徒废己业。虚设功劳应无有果

三因者。恭敬听法。能令众生舍恶趣故。得善趣故。速能引摄涅槃因故。如是三事。要由恭敬听闻方得

四因者。一恭敬听法。能善了达契经等法。二如是正法。能令众生舍诸不善摄受诸善。若善听者。则能精勤若舍若受。三由舍受故舍离恶因所招后苦。四由此受舍善恶因故。速证涅槃

五因者。谓佛世尊所说正法。有因缘有出离。有依趣有勇猛有神变。如是诸句。如摄异门分当广分别。复有五因。谓我当闻所未闻。我当闻已研究。我当除断疑网。我当弃背诸见。我当以慧通达一切甚深句义。诸佛世尊说此五种。显闻思修三所成慧清净方便。谓初二种显闻所成慧。次二种显思所成慧。后一种显修所成慧

六因者。一为欲敬报大师恩德。谓佛世尊为我等故。行于无量难行苦行求得此法。云何今者而不听闻。二观自义利。谓佛正法有现义利。三究竟能离一切热恼。四善顺正仪。五易可了见。六诸聪慧者内证所知

七因者。谓我当修集七种正法。我当知法知义。乃欲善知补特伽罗尊卑差别

八因者。一佛法易得。乃至为旃荼罗等而开示故。二易可修学。行住坐卧皆得修故。三引发义利。谓能引发增上生果决定胜果故。四初善故。五中善故。六后善故。七感现乐果故。八引后乐果故

九因者。谓能解脱九种世间逼迫事故。一能出生死大牢狱故。二永断贪等坚牢缚故。三弃舍七财贫。建立七财富故。四超度善行闻正法俭。建立善行闻正法丰故。五灭无明闇起智慧明故。六度四暴流升涅槃岸故。七究竟能疗烦恼病故。八解脱一切贪爱罥故。九能度无始生死旷野稠林行故。诸牢狱中生死牢狱最为第一。是故先说

十因者。一恭敬听法得思择力。由此能受闻法胜利。如法求财不以非法。深见过患而受用之。二善知出离。谓丧失财宝无忧无戚。亦不嗟怨。乃至广说。眷属离坏。若遭病苦不甚悲叹。亦不愁恼。乃至广说。三于诸欲中深见过患。及见出离最胜功德。清净出家舍离上妙卧具贪着。乃至能证诸妙静虑。四恭敬听法速顺证解广大甚深相似甚深诸缘起法。又能引发广大善根出离欢喜。如世尊说。我圣弟子专心属耳听闻正法。能断五法能修七法。速疾圆满。五诸圣弟子恭敬听法。所有集法皆成灭法。六解正法已远尘离垢。于诸法中生正法眼。七能引摄证预流果最胜资粮。乃至证得阿罗汉果。及能引摄阿罗汉果最胜资粮。八能引摄独觉资粮。九能善引摄无上正等菩提资粮。十能引一切世出世间静虑解脱等持等至。

赞佛略广者。谓说法师将欲开阐先当赞佛。赞有二种。一略。二广。略赞佛者。由五种相。应当了知。一者妙色。二者静寂。三者胜智。四者正行。五者威德。妙色者。谓三十二大丈夫相八十随好。静寂者。谓善能密护诸根门等。及能永拔烦恼习气。胜智者。谓于过去未来现在世法及非世法。无碍无著。正行者。谓自他利正行圆满。威德者。谓诸如来神通游戏。复有六种。略赞如来。谓功德圆满故。离垢染故。无浊秽故。无与等故。唯利有情以为业故。于此业用有堪能故。此广分别如摄决择分

广赞佛者。谓佛世尊无边名称德无量故。能施光明发智明故。能除黑闇永灭一切无智闇故。成就明眼具三眼故。见胜义谛了知无等诸圣谛故。成就禁戒戒圆满故。戒耆宿故。如是两足中尊。诸调御中最胜最上。沙门众中最为殊美。是诸世间难得珍宝。如是为哀愍者。为大悲者。乐为义者。求利益者。常悲愍者

如是为眼为智。为义为法。于明了义能善决定。凡有所作皆依于义

如是能证一切所未证义。由先证圣八支道故。自然证。故善能制立所未曾立胜梵行故。是知中道者。是证道者。是示道者。是说道者。是引导者。如是是人中师子。离怖畏故。是人中牛王。御大众故。是人中持御。众上首故。是人中龙王。无误失故。是人中良马。心善调故。是人中最胜。家族姓等映众人故。是人中最上。戒正行智胜威德等映众人故。是人中莲华。世间八法所不染故

如是是无等者。无与等故。无等等者。等去来今无等者故。是最第一。于诸有情为最上故。是大仙王。戒耆宿故。长时积集胜梵行故。证古大仙所证道故。是最胜者。于诸外道烦恼等魔能得胜故。是大牟尼。无有一切掉慢等故。与三寂静具相应故。不可引夺一切生等。及诸异论不引夺故。善沐浴者。永离一切诸恶法故。到彼岸者。超度一切萨迦耶故

如是如来应正等觉乃至广说。是薄伽梵。如是白法圆满。一切智者一切法主。无忘失法。于诸有情坚固最胜。一切苦乐不扰其心。是善调者。密护根门善圆满故。是寂静者。受持尸罗善圆满故。是安隐者。已入决定地故。般涅槃者。已证菩提故。拔毒箭者。拔爱箭故。调未调者。静未静者。已如前说。安慰一切不安隐者。善能安立诸异生等。令证预流一来果故。寂灭一切未寂灭者。善能建立住初二果。令证不还及阿罗汉果故。无杻械者。出火坑者。度深堑者。制诸求者。无倾动者。摧慢幢者。大常住者

如是是阿罗汉。诸漏永尽。如前广说。乃至尽诸有结

如是永断五支。成就六支。广说乃至纯善积集最上丈夫

如是善知法者。乃至善知补特伽罗有尊卑者

如是是大沙门。大婆罗门。离垢无垢良医商主。是胜观者。是世间依。是众生尊。此中离垢者。烦恼障断故。无垢者。所知障断故。又永拔习气故。名无垢。日夜六反观察世间故。名胜观

如是是一切种善清净者。大丈夫相及随形好庄严身者。具足十力为大力者。具四无畏无所畏者。是大悲者。于三念住善住念者。成就三种不护法者。无忘失法。永害一切烦恼习气。具一切种微妙智者。此中大悲者。长时积集故。谓经三大劫阿僧企耶。方乃证得。又复依缘一切有情故。缘一切种苦为境界故。于诸众生一切损恼变异利养。得无转故。于诸有情平等转故

复次此中诸说法师。应于如是安立释经法相。先当寻求若文若义。次复为他转五种释。如先所说。解释道理宣说正法。又应如是安立自身于先所说说法者相。谓善法义等十种圆满。如是自安立已。应起如是品类言说。谓处五大众。以如前所说可喜乐等八种言词。为众说法。又安处他。令住恭敬。无倒听闻。又应先赞大师功德。若有具足如是五分说正法者。当知犹如五分音乐能令自他生大喜乐。又能引发自他利益。若能如是善修学已。当知具足五种胜利。一于佛言义解了不难。二能善圆满说诸法相。三能善起发自他相续广大欢喜。四能引善出离。乃至天上人中称誉遍满。五能生起无量功德

复次如经中说住学胜利。当知此经文义为体

文者谓此经言。汝等苾刍。应当安住修学胜利。此中有十二字四名一句。如是则摄名句字身。此中言说。是学处相则摄行相。如来言说本为苾刍请问则摄机。请如来所说言音。则摄于语。是故此经一句具摄六文。如是慧为上首等诸句中。皆随相应知

义者。谓地义中但说声闻地。或具五地经言学胜利者。是资粮地。慧为上首者。是加行地。解脱坚固念为增上者。是见地。修地。究竟地。是名地义。于相义中学胜利者。是戒自相。慧为上首者。具二种相。谓于慧自相所依助伴等中。唯慧自体是慧自相。慧之所依助伴所缘。名为共相。解脱坚固者。谓永离一切烦恼粗重。是解脱自相。念为增上者。是念自相。是名相义。作意义中学胜利者。非诸作意。唯显作意建立处所。慧为上首者。应知了相胜解作意。解脱坚固者。显示远离。摄乐。方便究竟。方便究竟果作意。念为增上者。当知此显观察作意。是名作意义。由此道理于智等中应随建立。依处义中依于涅槃学处所摄清净行。随其所应起教导等。所谓教导乃至庆喜。当知此中亦通有善等行。随其最胜但说清净行。出家补特伽罗是补特伽罗依处。又依软根等一切补特伽罗。应当庆喜。又于过去现在时。应当庆喜。已证得故。正证得故。于现在时起于示现。于未来时起于教导及赞励。是名依处义。胜利义中。谓修三学速得圆满。是胜利义。过患义中。谓出家者。不应行于异行。不应储余财物。所治义中。谓犯尸罗无智烦恼及忘失念。当知护尸罗等。即是能治义。又一切杂染行。皆是所治。三学等行。皆是能治。于略义中谓住学胜利。乃至念为增上。此略举宗名为略义。当知即分别此名为广义。是名略广义。除此更无若过若增

复次于解释中。法者。谓于十二分教。当知此是契经所摄。又是记别由了义故等起者。谓应当说依止处所。为欲自显遍行智力故。发起此经。又为显示精勤修习清净行者。及为显示重财利者令信解彼所化有情依住学胜利等。精进修习速得圆满三学胜利。又为显示四种苾刍体故。此中经言学胜利者。为令远离种姓。形相苾刍体故。及令远离诈现轨则。密护威仪苾刍体故。慧为上首者。为令远离计着虚妄声誉。称赞苾刍体故。解脱坚固念为增上者。劝令修习真实正行苾刍体故。所以者何。若有爱乐声誉等者。虽自勉励听受正法。慧不增长。若有远离前所说过。便于真实正行摄受正解脱中。堪任劝导。又为于下劣生喜足者。劝令渐渐修学增进。为乐追求随顺世间文章咒术。于戒慢缓者。说学胜利。为守尸罗舍多闻者。说慧为上首。为唯于闻思生喜足者。说解脱坚固。为于戒慧解脱起增上慢者。说念为增上。如是等类皆名等起

义者。谓总义中。当知此经宣说正行及正行果。如是戒等三学。当知是名学之边际。又言。如是住者。此显正方便。四种瑜伽所摄。又言。如是住三学者。此显正行果。此中信欲为先。摄受尸罗。听受精进。慧等方便

于别义中所言学者。是勤精进如圣教行。若习若修名之差别。清净身语正命现行。是学自性。由此正行尸罗忍辱等修显发。故名为学。又为静寂及为清凉。进习除灭。故名为学。如是等类训释名言。又应如前说相故。自性故。业故。法故。及因果故。义门差别中。自性差别者。谓学胜利是所显示七品尸罗。或过。一百五十学处。界差别者。谓欲行中有别解脱律仪。色无色行中有静虑律仪。无漏律仪非界所系。时差别者。谓学胜利过去已学。未来当学。现在正学。此学胜利。当知于去来今平等无异。位差别者。谓已入正法补特伽罗。诸学胜利。未成熟者。是下位。正成熟者。是中位。已成熟者。是上位。若心不喜乐勉励修行诸梵行者。此学胜利是苦位。若心喜乐不自勉励修梵行者。此学胜利是乐位。若于梵行非喜乐非不喜乐者。此学胜利是不苦不乐位。又学胜利皆是善位。非不善位。非无记位。若听受者是名闻位。若思惟者是名思位。若修习者是名修位。若未证得增上心慧。唯是增上戒位。若证得者亦是增上心慧二位。如是等类是位差别。补特伽罗差别者。此中意说出家补特伽罗。或是纯根。或是利根。或贪等行。或等分行。或薄尘行。唯是声闻非诸独觉。非诸菩萨。由彼独觉别觉悟故。菩萨解脱为坚固故。不说共住修学胜利。又复此中唯说般涅槃为法者。已入正法者。无有障碍者。亦具缚者不具缚者非无缚者。唯人非天。如是等类名补特伽罗差别。如于学胜利如是。于慧为上首性。于解脱坚固性。于念为增上性。随其所应当知皆有五种差别

此中胜利者。是功德增进圆满名之差别。如说当观十种胜利是其自性。此法能有饶益。应可称赞。故名胜利。又复此法随生有情定应随逐。故名胜利。又复此法称赞所随故。名胜利。门差别者。当知十种差别。谓能摄受于僧。令僧精恳。乃至广说此中苾刍者。是沙门舍离家法趣非家等名之差别。具足别解脱律仪众同分是其自性。于其形色勤精进故。怖畏恶趣自防守故。摄无损故。名为苾刍。门差别者。谓刹帝利等差别故。上族下族差别故。少中老年差别故。当知是门差别

此中住者。是俯就于时。精勤修习名之差别。此住自性。离所说学无有别法。种种威仪摄受时分故。名为住。此是训词。门差别者。谓威仪差别故。朝中后分差别故。日夜差别故。当知是名住门差别

此中慧者。是智见明现观等名之差别。简择法相心所有法。为其自性。训词者。简择性故。治无智故。名之为慧。又各品别能了知故。名之为慧。又能显了诸聪慧者是聪慧性故。名为慧。门差别者。随其所应如前安立

此中解脱者。是永断离系。清净灭尽。离欲等名之差别。自性者。谓粗重永害。烦恼永断。训词者。谓能脱种种贪等系缚故。名解脱。又复世尊为种种牟尼说。此以为牟尼体性。故名解脱。门差别者。谓待时解脱。不动解脱。见所断解脱。修所断解脱。欲行解脱。色行解脱。无色行解脱。如是等类。义门差别如前应知。此中念者。是不忘失心明记忆名之差别。自性者。是心所有法。训词者。追忆诸法。故名为念。又随所经事。随其作意。由此能令明了记忆。故名为念。门差别者。谓佛随念法随念等。乃至广说六种随念。如是如念住差别。当知广说差别。又复如前随其所应当知差别

复次于释难中。问住学胜利者义何谓耶。答此增语显示于增上戒学见胜功德住。问慧为上首者义何谓耶。答此增语显示于诸根中慧根第一。问解脱坚固者义何谓耶。答此增语显示见修所断烦恼永断。问念为增上者义何谓耶。答此增语显示于少下劣不生喜足

问于余经中三学次第世尊异说。何故此中增上戒后说增上慧非增上心。答此中显示住学胜利。由此言说显闻等所成慧摄受无悔等。由此渐次得三摩地。即是显示增上心学。如世尊说于是五根最能摄受。所摄受者所谓慧根。由诸苾刍成就慧根。乃至能修定根。如是乃至成就定根。当知皆是慧根之力。今此经中世尊显示慧根是三摩地引因。及烦恼断引因。增上心学与增上慧学俱时而说。问余经中说三学修习进趣圆满。何故不说增上心学修习圆满耶。答如前所说。当知此中道理亦尔

问何故此中但说住学胜利。不说住慧胜利。住解脱胜利等。答于下劣中劝取胜利。当知亦令所化有情于胜妙中摄受胜利。又摄受于僧令僧精恳等十种胜利。分明易了易可悟入。是故但说住学胜利。问夫解脱者。于诸法中最为殊胜。何因缘故。但说住慧上首。不说住解脱上首。答于下劣中劝取上首性。当知。亦令所化有情于胜妙中摄受上首性。又于解脱显示不共差别功德故。何等名为不共差别功德。谓于无常无上慧边。解脱常故最为坚固

问何等名为住学胜利。答如所施设诸学处中。观十胜利。常守尸罗坚守尸罗。常作常转。如是名为住学胜利。问摄受于僧等诸句有何义耶。答摄受于僧者。是总句。令僧精恳者。令离受用欲乐边故。令僧安乐者。令离受用自苦边故。未净信者。令净信者。未入正法者。令入正法故。已净信者。令增长者。已入正法者。令成熟故。难调伏者。令调伏者。犯尸罗者。善驱摈故。令惭愧者。安乐住者。净持戒者。令无悔故。防现法漏者。随顺摧伏烦恼缠故。害后法漏者。止息邪愿修梵行故。随顺永断惑随眠故。为令多人梵行久住转得增广。乃至为诸天人正善开示者。为令圣教长时相续无断绝故

如是十种胜利略摄为三。即此三种广开为十。何等为三。一者令僧无染污住。二者令僧得安乐住。三者令佛圣教长时随转。此中由七种随护。显示无染污住及安乐住。七种随护者。一敬养随护。二自苦行随护。三资财乏少随护。四展转相触随护。五心追变随护。六烦恼缠随护。七邪愿随护。最后一句显示圣教长时随转

云何常守尸罗。谓不弃舍学处故。云何坚守尸罗。谓不毁犯学处故。云何常作。谓于学处无穿穴故。云何常转。谓穿穴已复还净故。云何受学学处。谓具随学诸学处故。如是行者常守尸罗。坚守尸罗。闻正法已独居静处。系念思惟筹量观察。为欲趣求增上心慧。依闻思修所生妙慧。能证解脱。此解脱性无退法故。说名坚固。是出世间圣智果故。又此行者由正念力审自观察我尸罗蕴为圆满不。我于诸法为有正慧善通达不。我于解脱为善证不。如是依止正念力持具学胜利。发上首慧证坚解脱。又此正念略有三种。谓或因说法故。或依教授故。或由观察应作不应作故

问世尊说戒有无量种。谓事善戒。苾刍戒。近住戒。静虑戒。等持戒。圣所爱戒。如是等戒今依何说住学胜利。答依苾刍戒。由最胜故。问世尊说慧亦有多种。谓闻所成慧思所成慧修所成慧。依何慧说住慧上首。答具依三慧。问世尊说解脱亦有多种。谓世间解脱。出世间解脱。有学解脱。无学解脱。可动解脱。不可动解脱。如是等类。今依何说住解脱坚固。答依出世间不动解脱。问世尊说念亦无量种。谓于身住念。于受住念。于心住念。于法住念。于久所作所说随念。于所受诵诸法随念。教授随念。应作不应作随念。佛随念等所有诸念。今于此中依何念说念为增上。答就胜为言。依应作不应作观察随念

复次于次第中。先应安住苾刍尸罗。次应听受如来正法。次应如理作意思惟。如是行者由净持戒。无有忧悔。由无悔等。渐次生定。由正方便所摄智慧如理作意正思惟故。增上心学速得成满。如是名为圆满次第。前前后后渐圆满故。能成次第者。谓由住学胜利。能成慧为上首。由慧为上首。能成解脱坚固。云何能得住学胜利。乃至能成解脱坚固。谓由念为增上。如是名为能成次第。又如是住修习三学。速得圆满。此亦名为能成次第。解释次第者。谓能善教诫声闻弟子一切应作不应作事。故名大师。又能化导无量众生令苦寂灭。故名大师。又为摧灭邪秽外道出现世间。故名大师。从他听闻正法音声。又能令他闻正法声。故曰声闻。问何因缘故唯为声闻说住学胜利等。答由声闻众是佛世尊随顺修学真实子故。此中法者。当知宣说名句文身。学处者。谓所宣说五毁犯聚。具怜愍者。谓于长夜诸有情所恒住慈等诸无量故。具大悲者。谓能拔济无量众生多苦法故。乐义利者。能与众生多乐法故。求利益者。能与众生无量品类妙善法故。恒悲愍者。能拔众生无量诸恶不善法故。为令多人梵行久住者。依刹帝利等族姓说。转增广者。即依如是有情种类后后增广说。乃至为诸天人者。谓即依彼有势力说。此中显示世尊大悲普覆一切非唯一分。正善开示者。谓如其所有性故。及尽其所有性故。宣说正法者。谓十二分教。听受研寻。任持读诵。处静思惟。如是正法如是能令汝利益者。依增上戒说。如是能令汝安乐者。谓不依止弊苦艰难不自在行。如是能令汝利益安乐者。谓离欲者增上心行。增上慧行。此行善故。名为利益。能饶益故。名为安乐。复次若于是处世尊赞美杜多功德。是名利益。若于是处世尊听受百味饮食百千衣服。是名安乐。若处世尊制立三学。如是名为利益安乐。又说如来于诸法中以彼彼慧善观察者。若为利益若为安乐。若为利益安乐。依增上戒学增上心学增上慧学说。当知此中有二因缘。名善观察。一者长夜串习遍了知故。二者无倒正觉悟故。于彼彼解脱善证得者。依增上心增上慧说。由二因缘名善证得。一者到究竟故。二者不还法故。无退法故。我尸罗蕴不圆满者。谓或于尸罗修习一分。或不依止。如是尸罗圆满。修习诸定地戒。我于诸法不善观察者。由二种相。如前应知。我于解脱不善证得者。由二种证。如前应知。我所应说如是已说者。谓总结前略所标举及广分别

复次由六种相。应当解释一切契经。一者遍知事故。二者舍离恶行及诸烦恼随烦恼故。三者受学善行故。四者由如病等行智遍知通达故。五者由彼果故。六者由自及他领受彼果故。由此六相。及由如前所建立相。应善解释一切经典。此中事者。谓蕴。界。处。缘起。念住。及正断等。彼果者。谓厌患。离欲。解脱。及遍解脱。自他领受彼果者。谓我生已尽。

如是等类名摄释分

瑜伽师地论卷第八十二瑜伽师地论卷第八十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄异门分之上

如是已说摄释。

云何摄异门。总嗢拖南曰

  白品与黑品　　异门等宣说
  为开悟义觉　　略总颂应知

别嗢拖南曰

  师第一二慧　　四种善说等
  亦有因缘等　　施戒道广说

此中大师所谓如来。绍师即是第一弟子。如彼尊者舍利子等。言袭师者。谓轨范师。若亲教师。若同法者。能开悟者。令忆念者。大师即是立圣教者。绍师即是传圣教者。袭师即是随圣教者。开许制止一切应作不应作故。时时教授教诫转故。当知即是能说传说及随说者。驱摈造作不应作故。名能奖者。庆慰造作应作事故。名胜奖者。于前二事能开示故。名至奖者。随所生起一切疑惑皆能遣故。名能导者。恶作忧悔皆能遣故。名胜导者。一切烦恼及随烦恼皆能遣故。名至导者。于诸疑惑能断除者。谓未显义能显发故。已显发义令明净故。甚深义句以慧通达广开示故。誓许为作轨范。尊重所依止故。名第二伴。随转伴故。名为善友。宿昔同处居家乐故。名为知识。父母宗亲互相系属。名怜愍者。若非眷属而施恩惠。名有恩者。言义利者。名所求事能引义利。乐为此故名乐义利。言利益者。名为善行。乐为此故名乐利益。言安乐者。名安隐住益身心义。乐为此故名乐安乐。依现法乐名乐安隐。依后法乐说名为乐相应安隐。于一切事现正随从。故名信顺。若即于彼补特伽罗处所而起故名为信。开彼功德及与威力殊胜慧已。即于彼法处所而起随顺理门故名净信。即由如是增上力故。身毛为竖悲泣堕泪。如是等事是净信相。闻彼功德威力等已。于行住等诸威仪中。恒常信彼实有功德故名信述。所言欲者。若于是处乐作乐得。言精进者。发起加行其心勇悍。言策励者。既勇悍已于彼加行正勤修习。言刚决者。发精进已终无懈废不坏不退。言超越者。殷重精进。言威势者。谓过夜分或前一更被服铠甲当发精进。言奋发者。如所被服发勤精进。或更升进威猛勇悍。发勤精进深见彼果所有胜利故名勇锐。于勤修时堪能忍受寒等淋沥故名勇悍。由善了知前后差别。于其胜上差别证中深生信顺所有精进。名难制伏。于少下劣差别所证进修善中无怯劣故名无喜足。言励心者。谓于精进所有障处一切烦恼及随烦恼诸魔事中。频频觉察令心静息。言常恒者。谓即于此正加行中能常修作能不舍轭。言正信者。谓于大师说正法时。于此正法既听闻已获得净信。不放逸者。谓得信已于乐出离障碍法中。防护其心恒常发起善法修习。言瑜伽者。受持读诵问论决择正修加行。言思惟者。随所受持究竟法义审谛观察。言忆念者。于所观察一切法义能不忘失。于久所作久所说中能正随念。言寻思者。即依如是无倒法义起出离等所有寻思。所言智者。谓出世间加行妙慧。所言解者。谓出世间正体妙慧。所言慧者。谓已证得出世间慧。后时所得世间妙慧。言观察者。谓由无倒观察作意。审谛观察已断未断有余无余。言梵行者。谓八圣支道及与远离。非正梵行习淫欲法。又言安住余梵行者。谓三十七菩提分法。彼由三处之所摄受。谓由奢摩他故。由毗钵舍那故。由修身念故。如其所应彼自性故。彼品类故。此中信念俱通二品。复次即此大师亦称第一。自义行故。亦称为尊。他义行故。亦称为胜。俱义行故。亦称为上。映蔽一切诸外道故。亦称无上。映蔽一切声闻独觉下中乘故。复有差别。言第一者。共诸世间善圆满故。所言尊者。共诸声闻善圆满故。所言胜者。共诸独觉善圆满故。所言上者。于烦恼障得清净故。言无上者。于所知障得清净故。复有差别。言第一者。于欲行善得圆满故。所言尊者。于色行善得圆满故。所言胜者。无色行善得圆满故。所言上者。超过一切三界世间善圆满故。言无上者。出世间善得圆满故。无足有情者。如蛇等。二足有情者。谓人等。四足有情者。如牛等。多足有情者。如百足等。有色有情者。谓从欲界乃至第四静虑。无色有情者。谓从空无边处乃至非想非非想处。有想有情者。谓从欲界乃至无所有处。除无想天。无想有情者。谓无想天。非有想非无想有情者。谓非想非非想处所有生天。如是略说品类差别。显示如来三种第一。谓由蠢动故。由依止故。由心故

复次能得慧者。谓总摄一切能引义利所有善慧。生长增益广大慧者。谓软中上品增进差别。清净慧者。谓宿世串习经历多时其慧成熟。成办慧者。谓于诸烦恼遍知永断。圆满慧者。谓即此善慧已到究竟。无退慧者。谓即此善慧成无退法。究竟出离。言捷慧者。速疾了知故。言速慧者。慧无滞碍故。言利慧者。尽其所有如其所有皆善了知故。言出慧者。于出离法世间离欲能善了知故。决择慧者。于出世间诸离欲法能了知故。甚深慧者。于甚深空相应缘起随顺诸法能了知故。又于一切甚深义句。皆能如实善通达故。此中如来慧。能制立声闻等慧。于所制立能随觉了。又大慧者。谓即此慧。长时串习故。其广慧者。谓即此慧无量无边所行境故。无等慧者。其余诸慧无与等故。言慧宝者。于诸根中慧最胜故。如末尼珠显发轮王毗琉璃宝令光净故。与彼相应故名慧宝。皆得成就。又慧眼者。谓俱生慧。言慧明者。谓他所引。则他所引善加行慧。言慧光者。谓即加行闻思成慧。言慧曜者。谓即由此修所成慧。言慧灯者。谓于如来所说经典甚深建立等开示故。言慧炬者。谓于法教随量随时能随转故。言慧照者。谓于彼彼所有诸法。以其妙慧能善了知。虽善了知犹随他转而未身证。慧无闇者。谓身作证。其慧根者。谓于他所证能遍了知增上力故诸所有慧。言慧力者。谓于自先后差别所证。能遍了知增上力故。由法道理无退屈慧。言慧财者。谓能招引一切自在最胜富贵。随获自心自在转故。又此慧宝于一切财最为殊胜。能为一切世间珍财根本因故。如说慧剑及慧刀者。谓能永断一切结故。言慧杖者。谓能远防一切烦恼天恶魔故。言慧辔者。纵意根马于善行地而驰骤故。慧无堕者。令诸身分不散坏故。慧垣墙者。遍于一切一门转故。慧阶陛者。加行道故。慧堂殿者。到究竟故。为欲显示垣墙等三复说三种。所谓界智。种种界智。非一界智。又正见者。能善通达真实法故。有学慧者。如理作意。复能引发心善解脱慧善解脱。又于后时诸有学慧。谓预流果及一来果不还果摄。诸无学慧。谓阿罗汉菩提所摄。若诸独觉菩提所摄。若诸如来最胜无上菩提所摄。云何界智。谓能了知种种界故。若能了知十八界者。名非一界智。了知彼界种种品类。名种种界智。通达了知彼界趣地补特伽罗品类差别故。又微细者。能入真实甚深义故。言审悉者。具能证入一切义故。言聪明者。谓与引发慧相应故。言睿哲者。谓与俱生慧相应故。或复翻此眼者。能取现见事故。智者。能取不现事故。明者。悟入尽所有事。觉者。悟入如所有事。言义行者。谓思所成善法摄故。言法行者。谓闻所成善法摄故。言善行者。施戒所成善法摄故。调柔行者。谓修所成善法摄故

复次言善说者。谓诸文句善圆满故。言善觉者。谓能善现等觉义故。言出离者。谓世间道断除众苦得出离故。趣等觉者。谓出世道为超众苦而能真实现等觉故。无差别者。师与弟子所说文义相滋润故不相违故。有窣堵波者。一切外道天魔及余世间不能倾动故。言有依者。具足四依无失坏故。大师如来应正等觉者。谓所说教善清净故。此中诸句略显四种善说法律最极圆满。谓初二句显文义圆满。次二句显果圆满。次三句显行圆满。后一句显师圆满

复次佛世尊法有因缘者。谓有缘起。制立一切所学处故。有出离者。谓有犯已制立如法还出离故。言有依者。谓由四依制立。超越一切恶戒诸毁犯故。有超越者。制立远离受用欲乐自苦行边。随顺士用令成就故。有神变者。谓由三种所现神变。为令获得速疾神通。无间制立正教授故

复次解脱舍者。回向涅槃故。于施果中无系着故。常舒手者。殷重广施故。乐弃舍者。施前正施及与施后意悦清净无追悔故。祠祀施者。一向如法不以凶暴积集财物。时时数数周遍舍施所施物故。舍圆满者。谓于福田而奉献故。于惠施中乐分布者。谓于父母妻子等所时时平等而分布故。如是一切总有六施。一无所依施。二广大施。三欢喜施。四数数施。五田器施。六摄受眷属施。此中依止品类时处布施而说

复次广说戒者。中嗢拖南曰

  尸罗法杀生　　具戒等广说

言尸罗者。谓能寂静。毁犯净戒罪热恼故。又与清凉义相应故。言律仪者。谓是远离自体相故。言具足者。谓正摄受无悔等故。言清净者。摄受现行三摩地故。又言善者。谓能摄受可爱果故。言无罪者。谓能摄受自他利故。言无害者。谓能违拒执持刀杖斗诤等事。言随顺者。随顺证得诸沙门果及余所有胜功德故。言隐覆者。谓常隐覆自善法故。言显发者。谓常发露自恶法故。言端严者。谓具摄受诸少欲等所有沙门庄严具故。言福田者。摄受正见轨范净命圆满德故。言无热者。谓正远离自苦边故。言无恼者。远离受用欲乐边故。言无悔者。谓正远离染污不乐忧戚事故

复次善说法者。道理所摄故任持胜德故。毗奈耶者。随顺一切烦恼灭故。所言圣者。远离一切杂染污法令不生故。又言善者。能与无罪可爱果故。言应习者。应习近故。言善哉者。是诸圣贤称赞事故

复次言杀生者。谓如有一。乃至广说黑品白品。当知广如有寻有伺地中已说

复次言具戒等皆广说者。谓安住具戒。亦能守护别解律仪。乃至广说。密护根门。若守护念若常委念。乃至广说。于食知量。于诸饮食思择而食。不为充悦不为憍逸。乃至广说。进止往来正知而住。乃至广说。如是一切广说应知如声闻地

复次广说道者中嗢拖南曰

  念住正断　　神足根力　　觉支道支
  无量为后

为欲勤修四念住故发起上品猛利。欲者。谓为断除不正作意诸过失故。言精进者。谓为断除缦缓策勤诸过失故。言策勤者。谓为断除惛沉掉举二随烦恼诸过失故。言勇悍者。不自轻蔑故。言勇锐者。能抗外敌故。不可制伏者。于少下劣不生喜足故。言正念者。不忘教授故。言正知者。能不毁犯所毁犯故。不放逸者。不舍善轭故。住热光者。能修懈怠对治法故。言正解者。能修毁犯对治法故。念成办者。能修忘念对治法故。调伏世间者。能修贪忧一切世法正对治故。此中显示勤修念住诸苾刍等应当修习四种对治

复次于诸正断诸神足中所有畏名。广说应知如声闻地

复次于如来所安立正信等。广说应知如摄决择分中。安住有势力有精进有勇悍等。广说应知如菩萨地

复次简择诸法最极简择。周遍寻思周遍观察。广说应知如声闻地。已得无漏真作意故缘圣谛境。一切无漏作意相应。名为择法。言简择者。总取一切苦法种类为苦圣谛故。最极简择者。各别分别取诸苦故。谓生苦老苦等。极简择法者。依此处所简择契经等法故。所以者何。依止此故先修所作。又简择者。谓审定解了。最极简择者。谓审定等解了。极简择法者。谓审定近解了。前是寻求道。今是决定道。复有差别。言解了者。于所知事作意发悟。等解了者。既发悟已方便寻求。近解了者。求已决定

复次黠了者。了知分别体故。通达者。通达所知事故。复有差别。黠了者。了知自相故。通达者。了知共相故。审察者。谓能定取。尽其所有如其所有。先后渐次倍增广故。聪睿者。先后渐次于彼义中无忘失故。觉者。谓堪能简择俱生之慧。明者。谓习所得慧。慧行者。谓能受持读诵问论胜决择等增上了别。即于彼义转增明了勤修习慧。毗钵舍那者。谓即于前所了别义审观察故。涉入者。谓先寻思于所缘境。作意思惟心涉入故。纳受者。谓即于彼能摄受故。推寻者。谓取彼诸相故。极推寻者。谓取彼随好故。复有差别。推寻者。谓寻求心。极推寻者。谓伺察心。最极推寻者。谓于得失推构寻思极挍计故。圣教为依而起寻求说名寻思。现量为依说名思惟。比量为依说名分别。厌离者。增上意乐于远离中起决定故。远离者。谓从他边受远离故。随离者。谓受已后能随守护彼尸罗故。还离者。谓误犯已即能如法而悔除故。从此已后寂止律仪随护尸罗。寂止者。由具忍辱柔和事故。律仪者。由具少欲慈心等故。密护根门者。自然不作故。不作者。由他不作故。不行者。由正了知不现行故。不犯者。不由失念而现行故。桥梁者。由此为依渡恶法故。船筏者。谓依对治誓能运彼痴狂失道。令渡相违障碍法故。不喜乐者。谓于远离增上意乐极满足故。不违越者。谓于一切所学众中无毁犯故。不弃舍故。不异违越者。谓于一分无穿穴故。不弃舍故。所言念者。谓住其心故。言等念者。谓等住其心故。如是广说应随九种心住差别。如声闻地当知其相

复次嗢拖南曰

  智宣说善欲　　炽然独远尘
  如病等解释　　我断尽生等
  并天世众生　　依等我作等

智者。谓闻言说为先慧。见者。谓见言说为先慧。觉者。谓觉言说为先慧。知者。谓知言说为先慧。智者。谓知不现见境。见者。谓见现见现在前境。明者。谓无明相违解。觉者。谓实有义智。觉者。谓不增益非实有智。慧者。谓俱生生得慧。明者。谓由加行习所成慧。现观者。谓于内现观法已。于诸法中非不现见。非缘他智

复次宣说者。谓因他请问而为记别。施设者。谓由语及欲。次第编列名句文身。安立者。谓次第编列已略为他说。分别者。谓略说已分别开示解其义趣。开示者。谓他展转所生疑惑皆能除遣。显发者。谓自通达甚深义句为他显示。教者。谓不因他发起请问。由哀愍故说法开示。遍开示者。谓无间演说不作师拳无所隐覆

复次初善者。谓听闻时生欢喜故。中善者。谓修行时无有艰苦。远离二边依中道行故。后善者。谓极究竟离诸垢故。及一切究竟离欲为后边故。义妙者。谓能引发利益安乐故。文巧者。谓善缉缀名身等故。及语具圆满故。纯一者。谓不与一切外道共故。圆满者。谓无限量故。最尊胜故。清净者。谓自性解脱故。鲜白者。谓相续解脱故。梵行者。谓八圣支道。当知此道由纯一等四种妙相之所显说。谛听者。谓于如是相法劝令审听。应善恳到者。谓劝令无倒无间殷重如理思惟

复次猛利欲者。谓我何当于彼处所。乃至广说。猛利爱者。谓于所修正加行中。猛利乐者。谓于说者及与大师尊重处等。猛利信者。谓于教法教授教诫

复次能炽然者。谓为证得速疾通慧。终不自暇推延后期发勤精进。顺瑜伽者。谓随尊教若等若胜。而修加行终不减劣。能永断者。谓能修习烦恼对治。能闲居者。谓依所有边际卧具。远离而居。修三摩地令现在前。依三摩地修习对治

复次独者。谓处远离边际卧具无有第二而安住故。言远离者。谓诸染污无记作意不现行故。无纵逸者。谓于欲等寻思恶法防护心故。又于善中自安处故。言炽然者。谓如前说。言发遣者。谓除五盖内持心故。又由此故发遣其心令趣无上安隐处故

复次远尘离垢者。尘谓已生未究竟智能障现观。有间无间我慢现转。垢谓彼品及见断品所有粗重。令永无故名远尘离垢。又复尘者。所谓我慢及见所断一切烦恼。垢谓二品所有粗重。于诸法中者。谓于自相共相所住法中。言法眼者。谓如实现证唯有法慧。言见法者。谓于苦等如实见者。言得法者。谓随证得沙门果故。言知法者。谓证得已于其所得。能自了知我是预流。我已证得无退堕法故。至诚法者。谓谛现观增上力故获得证净。于佛法僧及自所得圣所爱戒。以正信行如实至诚故。越渡惑者。谓于自所证。越渡疑者。谓于他所证。非缘于他者。谓于此法内自所证。非但随他听闻等故。非余所引者。谓于大师所有圣教。不为一切外道异论所引夺故。于诸法中得无所畏者。谓于自所证若他诘问无悚惧故。言逆流者。谓已登圣道故。言趣向者。谓记神通究竟往趣无退还故。复有差别。当知建立世俗胜义二种法故

复次如说如病。乃至广说。云何显示彼如病等。非但说彼犹如重病。乃至广说。然修行者先以如实无常等行。于彼事中如实诃毁作是思惟。此如病等甚可厌逆。为欲与彼不和合故。是故次说无常行等。如实显示观察彼果。言无常者。显现生身及与刹那皆展转故。刹那展转者。由彼彼触起尽故。彼彼受起尽此相续见。由非不现见非缘他智故。所言苦者。有二种苦。谓生等诸苦。及诸所有受皆说为苦。此二种苦如其所应由见生身展转有故而得悟入。谓死无间有生身生。生已复有老等诸苦。是故说言无常。故苦由见生身展转有故悟入苦性。云何诸所有受皆说为苦。谓诸乐受变坏故苦。一切苦受生住故苦。非苦乐受。体是无常灭坏法故。说之为苦。此中乐受由无常故必有变坏。一切苦受由无常故。生住相续皆起于苦。非苦乐受已灭坏者由无常故。说之为苦。已生起者灭坏法故。亦说为苦。此灭坏法彼二所随逐故与二相应。故亦名为苦。云何当观乐受为苦。谓由此受贪所随眠。由随眠故取当来苦。于现法中能生坏苦。如是当观乐受为苦。云何当观苦受如箭。谓如毒箭乃至现前常恼坏故。非苦乐受体是无常灭坏法者。谓已灭者即是无常。其未灭者是灭坏法。若无常者从此复生若乐若苦。灭坏法者终不解脱苦乐二种。所言空者。无常无恒无不变易真实法故。言无我者。远离我故。众缘生故。不自在故

复次解释者。谓能显示彼自性故。开示者。谓即显示此应遍知此应永断等差别故。显了者。谓能显示若不永断不遍知等成过患故。了者。谓了相作意。解者。谓胜解作意。知者。谓远离等作意。等解了者。谓了自相故。近解了者。谓了共相故。黠了者。谓了尽其所有故。通达者。谓了如其所有故。触者。谓于八圣支道梵行所摄。作证者。谓于彼果涅槃

复次我者。谓于五取蕴我我所见现前行故。言有情者。谓诸贤圣如实了知唯有此法更无余故。又复于彼有爱着故言意生者。谓此是意种类性故。摩纳缚迦者。谓依止于意或高或下故。言养育者。谓能增长后有业故。能作一切士夫用故。补特伽罗者。谓能数数往取诸趣无厌足故。言命者者。谓寿和合现存活故。言生者者。谓具生等所有法故

复次当断诸爱止息诸结者。谓适于圣谛得现观时。便能永断三结。于一切处后有之爱不复现行。彼于后时数数勋修生灭随观。复能无余永断慢等。是故说言能正修习永断诸慢。真现观故彼爱随眠一切永断。由此因缘当来诸苦诸后有法无复可得。又能究竟作苦边际

复次我生已尽者。谓第八有等。梵行已立者。谓于圣道究竟修故无复退失。所作已办者。谓一切结永无余故。一切道果已证得故。不受后有者。谓于七有亦永尽故。又我生已尽者。有二种生。一生身生。此如前说。二烦恼生。此微薄故亦说为尽。此则记别初之二果。梵行已立者。谓不还果非梵行贪此永断故。所作已办不受后有者。谓阿罗汉。当知此中记别四种解了行相

复次并天世间者。是总句。此有二种。一并魔。二并梵。并沙门婆罗门。众生者。谓诸沙门若婆罗门。生在人中希求魔梵而修行者。并诸天人众生者。谓于天中除魔及梵。于其人中除沙门婆罗门。如是总结解脱三缚出离欲贪。又毗奈耶断超越者。毗奈耶由了相胜解作意。断由远离等作意。超越由方便究竟果作意。言离系者。离九结故。言解脱者。解脱一切生老等故。离颠倒者。由见道故。所言多者。由修道故。由彼修道多修习故。说名为多。言利益者。谓诸善行。言安乐者。无损恼行。言哀愍者。谓如有一由诸善行无损恼行。哀愍于他是所求事故。能引义利故名之为义。可爱乐故。无有罪故。为利益。安乐者。谓于彼起所有善行无损恼行。所言人者。谓刹帝利等。若有因佛出现世间。善说正法。僧善修行。能多利益能多安乐。或但自为利益安乐悲愍世间。或但为他利益安乐。或为二种。是故说言为其义利利益安乐。此中唯说天及人者。彼有势力能了其义。修正行故

复次依者。谓五取蕴及与七种所摄受事。即是父母及妻子等。所言取者。谓诸欲贪亦名为取。由不安立及安立故。说有四取心。依处者。谓四识住。言执著者。谓诸烦恼能趣于依。即名为缠。彼品粗重说名随眠。如是名依。取心依处。执着随眠于此有识身及外一切相中者。谓于我我所我慢执着随眠因缘境界相中

复次我我所行者。谓萨迦耶见。言我慢者。谓即此慢。即彼诸缠名为执着。即彼粗重名为随眠。执着多分是诸外道。随眠通二

复次嗢拖南曰

  如来无常想　　底沙怖无为
  不有不相续　　空无常无余

如来应正等觉等者。如经分别。所言应者。应供养故。明行圆满。所谓三明遮行行行皆悉圆满。又复四种增上心法现法乐住皆悉圆满。前是行行后是住行。此中清净身语意业现行。正命是行圆满。密护根门是遮圆满。由此二种显示如来三种不护无忘失法。由不造过世间静虑遮自苦行。言善逝者。谓于长夜具一切种自利利他二功德故。世间解者。谓于一切种有情世间及器世间皆善通达故。由善悟入有情世间依。前后际宿住死生依。一切时八万四千行差别故。于器世间谓东方等十方世界无边成坏善了知故。又于世间诸法自性因缘爱味过患出离能趣行等皆善知故。无上丈夫调御士者。智无等故。无过上故。于现法中是大丈夫多分调御无量丈夫。最第一故。极尊胜故。天人师者。由彼天人解甚深义。勤修正行有力能故。言佛陀者。谓毕竟断一切烦恼并诸习气。现等正觉阿耨多罗三藐三菩提故。薄伽梵者。坦然安坐妙菩提座。任运摧灭一切魔军大势力故。此中如来是初总序。应正等觉谓永解脱一切烦恼障及所知障故。于其别中略有二种。所谓共德及不共德。于共德中且说解脱诸烦恼障及所知障。自余明行圆满等句是不共德

复次于无常想。素呾缆中修。谓若修若习。乃至广说。修果谓一切欲贪。乃至广说。修差别谓譬喻差别故。修方便谓或住阿练若。乃至广说。此中若修者。谓由了相作意故。若习者。谓由胜解作意故。多修习者。谓由余作意故。又若修者。谓于所知事而发趣故。若习者。谓无间殷重修加行故。多修习者。谓于长时熟修习故。为处者。作所依故。为事者。作所缘故。随顺者。由作意思惟故。串习者。得随所欲无艰难故。善摄受者。听闻正法故。善发起者。于内如理作意思惟故。又善摄受者。殷重作意故。善发起者。无间作意故。又善摄受者。到究竟故。善发起者。正加行故。随顺欲贪故说于掉。随顺色贪故说于慢。顺无色贪故说无明。拔除根本者。害随眠故。摧折枝条者。下地善法由彼断灭不增长故。以无常想所缘显示无常想。自心作意观无常故。台阁者。谓解脱俱行无常想。梁栋者。谓彼依因。象迹者。谓于不净等想为第一故。所缘广大故。流注者。谓解脱因俱行无常想能趣涅槃故。日出者。谓能对治无明闇故。如轮王者。谓无学无常想。如城王者。谓所余想。又或居阿练若。或居树下。或居空室。或居迥露。由取树下覆障等故。即摄一切卧具远离。唯有色无常性者。谓唯有色都无有我。如是正修加行。复次略有四种往趣道障。二种道等。谓由疑故不能发趣。虽复发趣由邪寻思而往余处。由邪分寻思见行故。虽无是事然不堪任教授教诫。所言忿者。谓他谏诤时。言苦恼者。谓出家者不得自在禁约艰难粗弊行等。言不乐者。杂嗔事故。此之二种犹如坑涧。又此二种能障行路。虽无是事而由利养及恭敬故。于入山林能为障碍。言猛利者。处深稠林故。所以者何。虽舍所摄受事。而不能舍此故

复次言有怖者。谓有盗贼及矫诈故。言有畏者。谓涉稠林故。有诸恶兽及与非人诸恐畏故。言有刺者。谓一切处多毒刺故。言失道者。往余处故。言恶道者。不平正故。如是五种显道过失。弊趣恶趣者。显示趣过失。失道恶道而行及亲近不善士者。显示能行补特伽罗所有过失。诸盗贼等名不善士

复次无动者。谓一切相皆远离故。无转者。谓贪爱尽故。于诸境界无转变故。难见者。谓甚深故。甘露者。谓生老病死皆永尽故。安隐者。谓超过一切人与非人灾横怖畏故。清凉者。谓一切苦皆寂灭故。极清凉故。善事者。谓现法乐住所缘境故。趣吉祥者。谓断一切烦恼所缘境故。无愁忧者。谓超过一切爱非爱故。又证得已无失坏故。不死没者。谓常住故不退还故。无炽然者。谓清净故。无热恼者。谓所欲匮乏永止息故。无病者。谓一切病诸痈疮等永寂静故。无动乱者。谓一切动乱皆灭尽故。涅槃者。谓一切依皆寂灭故

复次我何当不有。我所何当不有者。谓约未来世于我我所性所摄。内处外处所摄。自内体性。及摄受事。希求不生故。又复显示希求依止不生故。及希求依彼受不生故。我当不有我所当不有者。谓约现在世说。此观无常灭前观于择灭。又前但有希望故。后于现在因观无常性故

复次不相续者。谓死殁已后余识不生故。言无取者。谓无所住识。无有趣入名色事故。自体永不生故。无生长者。谓无有名色更增广故。言一切行皆寂止者。谓诸五蕴皆止息故

复次所言空者。谓离一切烦恼等故。无所得者。谓离一切所有相故。言爱尽者。谓不希求未来事故。言离欲者。谓无现在受用喜乐故。所言灭者。谓余烦恼断故。言涅槃者。谓无余依故。复次言无常者。谓性破坏朽败法故。言有为者。谓依前际所寻思故。言造作者。谓依后际所希望故。言缘生者。谓依现世众因缘力所生起故。有尽法者。谓一分尽故。有没法者。谓全分灭故。又有尽法者。谓全分灭故。有没法者。谓相续变坏故。有离欲法者。谓过患相应故。有灭法者。谓一切有为法皆有出离故

复次无余断者。谓是总句。永弃舍者。诸缠断故。永变吐者。随眠断故。言永尽者。过去解脱故。永离欲者。现在解脱故。言永灭者。未来解脱故。永寂静者。由见道故。永灭没者。由修道故。当知此中由二种道断烦恼事显无余断

瑜伽师地论卷第八十三瑜伽师地论卷第八十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄异门分之下

复次嗢拖南曰

  欲三种延请　　法僧惠施故
  厌梵志无常　　聚沫等为后

诸欲无常虚伪不实者。谓于诸欲宣说颠倒。以是四种颠倒事故。当知此中虚故无我。伪故不净。不实故苦。由于是处乐非实故。然彼诸欲似常等现。说名妄法。颠倒事故。云何诸欲名为妄法。为显此义说幻事喻。虽非常等然似显现故。同彼法诳惑愚夫者。谓无闻愚夫于彼诸欲不如实知故。于长夜恒被欺诳。深生染着为变坏苦之所逼触。诸聪慧者。则不如是。如实知故。又彼诸欲喻枯骨者。令无饱故。喻段肉者。多所共故。喻草炬者。是非法行恶行因故。喻一分炭者。增长欲爱大热恼故。喻大毒蛇者。为诸圣贤所远离故。喻梦所得者。速散坏故。喻所假借庄严具者。托众缘故。喻诸树端烂熟果者。危亡地故。又不净者。是其总句。言臭秽者。受用饮食变坏成故。屎尿不净变坏所成故。名臭处。诸肉血等变坏所成故。名生臭。可厌逆者。受用淫欲变坏所成可恶逆故。复次应招延者。约舍世财。应奉请者。约尽贪爱。欲求果报。是故招延。欲求解脱。是故奉请。应合掌者。即为二事而延请时。应和敬者。应设礼拜问讯等故。应可与彼戒见同故。无上福田世应奉施者。于彼惠施果无量故

复次善说者。文义巧妙故。现见者。于现法中可证得故。无热者。离烦恼故。无时者。出三世故。难引者。老病死等不能引故。难见者。天等趣中不可见故。内自所证者。唯信他等不能证故。诸有智者者。谓学无学为舍为洲为救为归为趣者。由后后句释前前句显出离义。又能了知四圣谛故。名为正见。言生起者。于一切时容可生故。已生起者。于过去世住无学位。今生起者。于现在世或已证得或修圆满。当生起者。或未证得或勤修习应修应习。应多修习者。随其所应如前当知。应随护者。远离随顺退堕法故。言应触者。由身体故。应作证者。或果或胜智如说我已证道故。应时而说者。若了知彼愿乐欲闻。及堪闻者方可为说。坐卑座等是名为时应。当序说先时所作。若了知彼是增上已。即便殷重随其所能尽己所有而为说法。为欲开示彼彼差别未曾有义。非直华词乐说而已。次第者。开示义故。随密者。设妨难故。随会者。显释彼故。令欢喜者化受教者故。令爱乐者。化处中者故。令喜乐者。化诽谤者故。赞励者。求彼实德。以称顺心发自言音揄扬赞美。诃摈者。观彼实过。以无恚心发自言音开示诃责。道理者。具四道理故。谓观待道理。作用道理。法尔道理。证成道理。有益者。于所为处不弃舍故。无杂者。无杂乱故。有系属故。有法者。能引义故。依于苦等有无量种出离远离所生法故。如众会者。随刹帝利等四种会众所堪能故。以慈心者。为欲令彼得乐义故。利益心者。云何当令若有殷重听闻正法。皆得悟解。获大利益故。哀愍心者。欲令彼修法随法行故。无所依者。不为利养恭敬名称故。谓不依止衣服等事。亦不依止礼敬等事。唯欲令他悟入正法。又不于他有所轻蔑。乃至广说。不自高者。不为利养恭敬事故作如是言。唯我能知如是法律。非汝等辈。乃至广说。赞己功德谈彼过失。于时时间应听法者至如是时应自观察。我今说法多有所作。他说法时应正了知勿我于中当为障碍。即便殷重以谦下心坐于卑座。具足威仪。随其所能听闻正法。起恭敬相。为欲启悟先未解义而兴请问。若不悟解。或复沉疑终不讥诮。于其胜者恭敬随顺。于等于劣恭敬法故亦不轻蔑。于说法师深生尊重。如说法者当获无上大果修利故。不轻法者。不作是言。此非绮饰文字章句。所有文句悉皆粗浅故。不轻法师者。不作是言。彼于我所种姓卑劣等故。不自轻者。不作是言。我于解法无有力能。于其所证无怯劣故。奉教心者。无恼乱心唯欲求解故。心一趣者。为欲领解文句差别故。属耳听者。为欲了知音韵差别故。修治意者。为欲悟入甚深义故。于一切心无不系念者。为欲无间领解音韵文句义故。无不了知。无不通达。而空过者。复次言正行者。谓是总句。应理行者。住果有学。质直行者。住于向道。和敬行者。是其无学由彼唯于大师正法及学处等深恭敬故。随法行者。于因转时法随法行。由闻他音内正如理而思惟故。又应理行者。是其正道及果灭行。质直行者。如其圣教而正修行。无谄无诳如实显现。和敬行者。与六坚法而共相应。随法行者。法随法行诸阿罗汉诸漏永尽。乃至广说。最极究竟。乃至广说。亦名出离超出坑堑越度坑堑。乃至广说。永断五支成就六支。乃至广说。获得预流不颠坠法。决定趣向三菩提果。乃至广说。如是一切于自处所摄事分中。我当广说。又大师子者。是其总句。腹所生者。简去异生卑劣子故。口所生者。从说法音而诞生故。法所生者。如理作意法随法行之所生故。法所化者。从法身路而得成立相似法故。法等分者。受用无漏法之财宝相似法故。如是诸句显示增上生圆满。及父相似法生圆满。谓初句于其增上生圆满中。遮器过失。第二句遮其精血不净所生。第三句遮其欲贪非正法生。如是三句显示增上生圆满。第四句显示自体相似之法。第五句显示受用相似之法。如是二句显示父相似法生圆满。又序者。是缘。集者。是因。缘增上故名彼种类。因增上故名彼所生。虽因所生藉缘势力方得生起。为彼依故。又于此中后句释前。又善见者。是其总句。言善知者。知法义故。善思惟者。如其正理而思惟故。善黠慧者。全分知故。善通达者。如实知故。由后二句显善见性。由前二句显彼加行。又言圣者。是无漏故。及在圣者。相续中故。言出离者。出离三界一切苦故。言决达者。究竟出离无退转故

复次诸法皆以世尊为本者。由佛世尊是其最初现等觉故。世尊为眼者。现等觉已为诸天人等开示故。世尊为依者所说法中随所生起一切疑惑皆能遣故。又佛世尊能为眼者。谓能引发俱生慧故。能为智者。谓能引发加行慧故。能为义者。谓能引发思所成慧故。能为法者。谓能引发闻所成慧故。不显了义能决了者。一切疑惑皆能断故。能为一切义所依者。谓能引发一切世间及出世间兴盛事故。复次厌者。谓于见道。言离欲者。谓于修道离欲究竟。所言灭者。谓于无学一切依灭。前之二种于加行位。修习厌行及离欲行。后之一种在无学位。行于灭行。又言厌者。由见谛故。于一切行皆悉厌逆。言离欲者。由于修道永断贪故。言解脱者。由离贪故。一向安隐于余烦恼心得解脱。遍解脱者。烦恼断故。于生等苦普得解脱

复次是为婆罗门者。究竟到彼岸故。蠲除诸恶故。是为其相。无犹豫等者。于自所证离疑惑故。断诸恶作者。于应作事无不作故。不应作事无有作故。离诸贪爱者。无有利养恭敬爱故。于有非有着无有随眠者。随眠永断故。当知此中若现在世若未来世名之为有。其过去世名为非有。由此诸句无倒观察。婆罗门相由前三句显示多闻及与正知观察其相。或谓不正修习善品故。复显示第四一句观察其相。此中著者。谓八种着。于非有中作愁忧着。于现在世所摄有中。有五种着。一作修治。二作救护。三作我所。四作高胜。五作下劣。于未来世所摄有中。作行作动总于三处。作极厚重作极甘味作愁忧者。所爱变坏故。作修治者。养育摄藏故。作救护者。于逼恼处求作救护故。作我所者。执为我所故。作高胜者。计我为胜而起憍慢故。如世尊言世间众生慢为高幢故。作下劣者。计我为劣而起憍慢故。言作行者。是其希望未来世爱。言作动者。既希望已方便追求。作极厚重者。是所爱乐非可食用。谓金银等应可贸易。作极甘味者。是可食用。复有差别。谓此五句略显得道道果作证。是为婆罗门者。略显得道。无犹豫等断诸恶作离诸贪爱于有非有着无有随眠者。如是诸句略显获得道果作证。于记所解疑惑断故。于所行中一切忘失法行断故。于未来世苦因断故。现在苦因粗重断故。所言有者。谓此义中当知于其三界所摄诸相作意。言非有者。于无相界作意思惟。所言著者。谓此义中是贪嗔痴。如无相定诸有学者。犹有随眠。非阿罗汉得有寻思戏论著想四种杂染。前二是出家品。后二是在家品。由有着随眠故。彼得生起。诸出家者由追忆念曾所更境故。有寻思动乱现行故。有戏论。诸在家者住现前境。有著有想由有染着取诸相故。复有二种杂染因缘。谓不如理作意。及顺彼处法。由此因缘彼得生起。是故说此为彼因缘。复次所有无常皆是苦者。义何谓耶。若有无常众同分者。有生老等众苦生起。若依诸触有诸受者。彼皆变坏。生已寻灭故。说诸受皆悉是苦。若有生等苦法。及有坏等苦法。彼皆无我。自非我故。于是处所。亦无有我。由此摄受空无我行。又解了者。闻所成慧。诸智论者如是说故。等解了者。思所成慧。审解了者。修所成慧。即于如是三慧行中所有诸忍。名为喜乐。若等喜乐。若遍喜乐。又有无常随观断随观离欲随观灭随观者。如声闻地已广分别。又无常力之所损害。乃至广说。当知此中增一略文显无常等差别。障碍差别为后如其所应。为欲获得所未得者。最初得故。或先下劣有所证故。于上差别而作证者。谓于其断而作证故。言观察者。此说于慧。言审虑者。说三摩地。如理观察者。此说二法无颠倒转。虽实无有而显现者。谓于此中实无乐故。虚者。空无我故。伪者。不净故。不坚者。无常故。此则显示无四颠倒

复次色如聚沫者。速增减故。水界生故。思饮食味水所生故。不可揉捼故。非如泥团可令转变造作余物。是故说言不可揉捼。又实非聚似聚显现。能发起一有情解故。受喻浮泡者。三和合生不久坚住相似法故。言如地者。所谓诸根彼生依故。言如云者。谓诸境界。言如雨者。所谓诸识。如雨击者。所谓诸触。如浮泡者。所谓诸受速疾起谢不坚住故。想同阳焰者。颷动性故。无量种相变易生故。令于所缘发颠倒故。令其境界极显了故。由此分别男女等相成差别故。云何行类芭蕉。如明眼人者。谓圣弟子。言利刃者。谓妙慧刀。言入林者。谓于五趣举意攀缘种种自性众苦差别同树法故。为取端直芭蕉柱者。谓为作者受者我见。截其根者。谓断我见。[歹*皮]折叶者。委细简择唯有种种思等诸行差别法故。彼于其中都无所获者。谓彼经时无坚住故。何况坚实者。何况有余常恒实我作者受者而可得见。云何识如幻事。言幻士者。随福非福不动行。识住四衢道者。住四识住。造作四种幻化事者。谓象马等。如象身等虽现可见。而无真实象身等事。如是应知随福非福不动行。识住四识住。虽有作者及受者等我相可见。然无真实我性可得。又识于内隐其实性。外现异相犹如幻像。复次已说白品异门。黑品异门我今当说。嗢拖南曰

  生老死藏等　　可欣等烦恼
  广说贪嗔痴　　少等差别等

所言生者。谓初结生。即名色位等生。则是胎藏圆满。出谓出胎。现谓婴孩乃至少年及中年位。起者。乃至极老年位。又蕴得者。谓名色位界得。即是于此位中彼种子得。言处得者。名色增长六处圆满。诸蕴现者。谓从出胎乃至老位。命根起者。舍故众同分。取新众同分。

复次言蹎蹶者。年衰迈时行步去来多僵仆故。言皓首者。发毛变改白银色故。言襵多者。皮缓皱故。言衰熟者。年衰迈时即彼黄皴无光泽故。言朽坏者。势力勇健皆无有故。脊伛曲者。身形前偻凭杖行故。多诸黑子庄严身者。青黑杂黡遍支体故。言惛耄者。于所作事经行住等无多能故。言羸劣者。诸根于境无多能故。言衰退者。念智慧等无多能故。遍衰退者。即诸根等经彼彼念。瞬息等位渐损减故。诸根熟者。即彼衰废无堪能故。诸行朽者。根所依处时经久故。体腐败者。即彼所说性衰变故

复次殒者。舍身形故。终者。临死时故。丧者。若于是时尸骸犹在。殁者。若于是时尸骸殄灭。又丧者。据色身故。没者。据名身故。寿退暖退者。将欲终时余心处在。命根灭者。一切寿量皆穷尽故。死者。其识弃舍心胸处故。殂落者。从死已后或一七日。或复经于二三七日

复次一切愚夫异生于其六处由执我故名藏。执我所故名护。由萨迦耶以为根本。各异世间见趣差别。我慢增上爱现行故名覆。于顺乐受所有六处。有贪欲故名味。于顺苦受所有六处。有嗔恚故名结。于顺不苦不乐受所有六处。有愚痴故名合。于过去世所有六处。有顾恋故名随眠。于未来世所有六处。有希望故名系属。于现在世所有六处。有耽染故名执着。于自摄受他身六处。执为我所。于劣中胜非自摄受他身六处。依慢种类发起于慢。于不定地欲界所系。发起后后所有希求。于其定地色无色系。如其所应。由广大微妙故。发起厚重。依在家品色声香味触。由爱味眷属所随逐故。发起甘味。依出家品六处。由懈怠放逸烦恼故。遍于一切不能舍离。

复次可欣可乐可爱可意者。当知此四句略显可爱事。此可爱事略有三种。一可希求事。二可寻思事。三可耽着事。未来可爱事可希求故。名为可欣。过去可爱事唯可欲故唯可乐故。名为可乐。现在可爱事略有二种。一境界事。二领受事。若境界事可爱乐故。名为可爱。若领受事可爱乐故。名为可意。如是所说诸可爱事。或过去或未来或现在。或境界或领受。有差别故。或名可希求事。或名可寻思事。或名可耽着事。是故宣说如是一切诸句差别。又可欣者约未来世。可希求故。可乐者。约现在世。现可欲乐无厌足故。可意者。约过去世。随念可意而追忆故。可爱者。约妙色相。贯通三世皆可爱故。又可欲者。悦意记念故。欲所引者。欲界系故。或复随顺二种差别受用欲故。可染著者。贪处所故

复次于五种事能和合故。说名为结。五种事者。一所结事。二能结事。三罪过事。四等流事。五趣向事。诸结所缘名所结事。所以者何。由爱恚等各于所缘随相差别而和合故。即彼诸结展转相引而和合故。名能结事。诸结因缘于现法中能生过罪。乃至领受。从彼所生心法忧苦。由此因缘能和合故。名罪过事。为当来世猛利贪等生成之因而和合故。名等流事。能生五趣于诸趣中能和合故。名趣向事。由此因缘自行恶行。遭他笞罚缚录诃骂驱摈害等种种众苦而生起故。名能自损。若不自遭令他遭故。名能损他。若由彼故自他俱遭。名能俱损。能生现法罪者。谓由彼故遭如所说种种苦事。然不决定往诸恶趣。能生后法罪者。谓由彼故虽于现法他所不知。然能为因往诸恶趣。能生现法后法罪者。谓具二种。于现法中多怀染着。所欲不遂广生种种心法忧苦。复于当来往诸恶趣。结虽无量就胜而言略有九结。又约不随所欲义故。说有三缚。谓贪嗔痴依三受故。由彼因缘虽欲脱彼而不能脱。故名为缚。又烦恼品粗重种子之所随逐。说名随眠。是随缚义是微细义。取其根本但有七种。又从烦恼生故。亲近烦恼故。随恼乱心故。名随烦恼。除七随眠。所余一切染污心法。皆随烦恼。又现起相续无断绝义。说名为缠。缠有八种。谓无惭等。又彼能令转成上品相续起故。能令身心无堪能故。说为株杌。如舄卤田不任耕植。又处所别故。彼所生疑有差别故。说五心株。贪等别故。说有三种。又彼能令不清净故。说名为垢。又于诸处门常流注故。名为儞伽。常能害故。亦名儞伽。又彼能令不寂静故。说名为箭。如被毒箭若未拔时多不寂静。又能障舍故有戏论故。名为所有。又非法行不平等行现在前故。说名恶行。又能等起一切烦恼诸恶行故。说名为根。又能出生当来生故。说名为漏。又既生已由老死等令匮乏故。说名为匮。又非爱合会所爱乖离。贪求利养所烧然故。说名为烧。又能令愁叹忧苦恼故。说名为恼。又能令顺流而漂溺故。说名暴流。又依前际能为现法生死流转胜方便故。说名为轭。又依现在能为未来胜方便故。说名为取。又难解故。说名为系。又于所知事能障智故。说名为盖。又望色无色界。欲界为下分。望其修道。见道为下分。由约此二下分差别。随其所应说名五下分障。亦名五下分结。与此相违当知说有五上分结。又言林者。能生种种苦蕴。体性由亲爱故彼得增长。说名稠林。又能发起诸斗讼等种种忿竞故。名为诤。明所治故。说名为黑。能引苦故。说名无义。无所用故。说名弊。下性染污故。说名有罪。不应习近故。说名应远离。毁犯所受清净戒故。名突尸罗。又恶法者。谓极猛利无惭无愧。不信佛等毁谤贤圣。邪见相应故。或复种种恶法现行故。又有贪欲嗔恚心等。乃至广说。当知此中内朽败者。外持沙门相故。内无沙门法故。犹如大木外皮坚妙内被虫食虚无有实。下产生者。广如下产及非下产法门中说。水生蜗螺者。谓所听受与水相似除渴爱故。若诸苾刍犯禁戒等。如彼蜗螺秽浊净水。是故犹如有蜗螺水不堪饮用。应远离故。螺音狗行者。谓诸苾刍习行恶行。于受利养卧具等时。自称年雨最第一故。实非沙门称沙门者。已失苾刍分称有苾刍分故。实怀恶欲。而自称言我是第一真沙门故。非梵行者。实非远离淫欲秽法。而自称言我远离故。又失苾刍性。而自称有苾刍性。是故说名妄称梵行。实非沙门。而自称言我是第一真实沙门。是故说名妄称沙门。又舍所受故。名突尸罗。先舍恶法复还取故。名为恶法。形相意乐互不相称。由是因缘名内朽败。随其所欲而行住故。名下产生。毁辱所闻故。名水生蜗螺。由邪受用诸信施故。名螺音狗行。邪言说故。名为妄称沙门梵行。又有贪嗔痴忿恨等。乃至广说诸杂碎事。摄事分中我当广说。又有无常苦空无我生法老法乃至烧鸡。随其处所即于彼中我当广说

复次染者。谓乐着受用故。著者。谓即于彼无所顾惜故。饕餮者。谓希望未来所得受用事故。吞吸者。谓彼所余助伴烦恼所吞吸故。迷闷者。次后当说。耽著者。谓坚执已得无所营为故。贪求者。谓追求未得勤加行故。欲者。谓于未得已得希求获得及受用故。贪者。谓于受用喜乐坚着故。亲昵及爱乐。如所亲昵所爱乐中。应知其相。藏者。谓于内所摄自体中爱故。护者。谓于他相续中爱故。执者。谓于我所中爱故。渴者。谓倍增希求故。所染者。谓贪居处故。所憍者。谓七种憍所居处故。所欲者。谓种种品类受用贪欲所居处故。所亲昵者。谓是过去诸顾恋。爱所随处故。所爱乐者。谓是现在诸欣喜爱所随处故。又现法中串所习爱。名为亲昵。宿世串习所发生爱。名为爱乐。所迷闷者。不能于中观察功德及过失故。所贪著者。是耽乐心所居处故。所缚著者。是贪嗔痴所居处故。所希求者。能生爱故。所系缚者。是一切结所居处故。是恶者者。谓能和合不善法故。为令现前而喜乐者。谓希望故。为令现前而言说者。谓以语言而追求故。为令证得而遽务者。谓生贪着身追求故。耽着而住者。谓得已抱持而不舍故。等染者。谓于乐受起贪欲故。等恶者。谓于苦受起嗔恚故。等愚者。谓于三受起愚痴故。顾恋者。谓于过去故。系心者。谓于未来故。劬劳者。谓由彼因缘正起追求故。炽然者。谓所欲果遂起染污心故。烧者。谓所欲衰损起染污心故。恼者。谓所得变坏故。为祈祷者。显示取着吉祥爱故。为触对者。显示取着摩执爱故。为希求者。显示取着与利爱故。为欣悦者。显示取着如意思惟所有爱故。又于诸欲其心趣入清净。乃至广说于五种出离界。应知如前三摩呬多地已说。言憍醉者。谓与三憍共相应故。极憍醉者。谓依上憍遍于诸恶不善法中。能令其心不防护故。趣憍醉者。谓于憍醉所有因缘受学转故。于诸欲中生等憍者。谓不观过受用欲故。平安者。谓乐受自相故。领受者。谓诸受共相故。趣受者。谓余受因相故。又欲贪坚着拘碍饕餮等贪。如闻所成地已说

复次言内垢者。谓于怨意乐坚持不舍故。内忌者。谓于所爱障碍住故。内敌者。谓能引发所不爱故。内怨者。谓能引发所不宜故。又不可喜不可乐不可爱等。翻可喜等如前应知。又言苦者。谓彼自性苦。亦随忆念苦故。损害者。谓现前苦故。违逆者。谓于三世思惟苦故。不顺意者。谓现有苦能损害故。又苦猛利坚鞕辛楚不可意等。如摄事分我当广说。又暴恶者。是其总句。[虫*旦][虫*若]者。粗言猛切故。怨字语者。谓造文字无有依违粗犷言故。怨嫌者。谓毁辱所依故。愤发者。谓出言显发恶意乐故。恚害者。谓以手等而加害故。颦蹙而住者。谓愤害已后颦蹙眉面默然而住故。遍生愤恚者。谓数数追念不饶益相。深怀怨恨恼乱心故。若生烦恼恼乱其心。由此因缘便住于苦。如说苾刍懈怠杂诸恶便住于众苦。有苦者。谓彼摄受未来苦故。有匮者。谓彼远离诸善品故。有灾者。谓彼能为余惑因故。有热者。谓于后时发热恼故。又言苦者。是其总句。有苦者。谓忧苦相应故。有匮者。谓乐受变坏故。有灾者。谓在不苦不乐受中。于二不解脱故。有热者。谓于乐等如其所应有贪嗔痴火故。有于过去有苦。于未来有匮。又害者者。显示摄受上品怨嫌故。敌者。怨者。如前已说。又摧伏者。谓与未生士用生相违故。破坏者。谓与生已士用住相违故。为他所胜者。谓与未生功能生相违故。落在他后者。谓与已生功能住相违故。又不摧伏不破坏非所胜有所胜者。如是诸句由前诸句其义应知

复次在前际无智者。谓于过去诸行无常法性。不了知故。于后际无智者。谓于现在诸行尽灭法性。不了知故。于前后际无智者。谓于未来诸行当生法性及当生已当尽法性。不了知故。彼于如是不了知者。谓依前际等起不如理思惟。我于过去世为曾有耶。乃至广说。我为是谁。谁当是我。今此有情从何而来。于此没已当往何所。如是依前后际不如理作意故。于如是无常法性。愚痴不了。于诸行中我见随逐。于内于外俱于二种。唯有法性不能了知。内谓内处。外谓外迹。内外即是根所住处及以法处。由彼诸法于内可得。又是外处之所摄故。于业无智者。谓于诸业唯有行性不能了知。而妄计度我为作者。于异熟无智者。谓于有情世间及器世间。若余境界业因所起。妄计自在作者生者。于业异熟无智者。谓遍愚一切。获得诽谤业果邪见。此即宣说外道异生于诸法中所有无智。于佛无智者。谓不了知如来法身及诸形相。于法无智者。谓不了知善说等相。于僧无智者。谓不了知善行等相。于苦等无智者。谓如诸经所分别相。及十六行中。不了知故。于因无智者。谓于无明等诸有支中能为行等所有因性。不了知故。于因所生无智者。谓于行等诸有支中从无明等因所生性不了知故。又于杂染清净品法。谓不善善有罪无罪过患功德。相应故随顺黑白。谓无明明分故。黑黑异熟。白白异熟。及有对分。谓即黑白黑白异熟。如是一切皆从因缘之所生故。名为缘生。于彼一切不了知故。名为无智。或于六触处不能如实遍通达者。谓于六处顺乐受等触所生中。彼灭寂静不能如实遍了知故。又此加行不能如实于法通达知见现观者。谓即于彼法不如实知故。于彼于此者。于如所说或所未说。无知者。于不现见。无见者。于现见现前。无现观者。于如实证不由他缘。黑闇者。于其实事不正了知。愚痴者。于不实事妄生增益。无明者。于所知事不能善巧。于彼彼处不正了知。谓于彼彼所说义中。及于名句文身不能解了。昏闇者。成就诽谤一切邪见。又障盖无眼等广说如摄事分。又覆蔽隐没昏昧遍昏昧等。广说如爱契经。不恭敬者。不修恭敬故。不尊重者。不信彼德故。不贵尚者。令彼所欲有匮乏故。不供养者。不施利养故。又不恭敬乃至不供养者。当知展转后句释前。又不恭敬不尊重不信。有而听闻法等。广说如摄决择分。又不承听者。不欲闻故。不审听者。心散乱故。不住奉教心者。不欲修行故。不修正行者。于法随法不如意乐正修行故。又不受学转者。于大师圣教不能证故。又乐睡眠虚度生命者。是其总句。唐捐者。不能修往善趣因故。无果者。不能得彼善趣果故。无义者。不能修得涅槃因故。无利者。不能得彼涅槃果故。又问少病恼不者。界无不平等故。少事业不者。加行事业无不平等故。起居轻利不者。希须饮食既饮食已易消化故。又务力乐及无罪等。如声闻地食知量中已说其相。又不简择不极简择等。广说如声闻地。又不思惟不称量等。广说亦如声闻地

复次少者。高广量不相应故。小者。卑狭量相应故。鲜者。才受世间言说量故

复次或异门者。自相差别故。或意趣者。俗相差别故。或殊异者。因相差别故

如是名为摄异门分。如是异门于诸经中随其粗显言多用者。略已采集示差别义。其余无量诸佛世尊所说异门及义差别。由此方隅由此所学由此言教。应当精勤别别思择异门异义显示安立

瑜伽师地论卷第八十四瑜伽师地论卷第八十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事行择摄第一之一

如是已说摄异门。云何摄事。谓由三处应知摄事。一者素呾缆事。二者毗奈耶事。三者摩呾理迦事

云何素呾缆事。谓由二十四处略摄一切契经。一者别解脱契经。二者事契经。三者声闻相应契经。四者大乘相应契经。五者未显了义令显了契经。六者已显了义更令明净契经。七者先时所作契经。八者称赞契经。九者显示黑品契经。十者显示白品契经。十一者不了义契经。十二者了义契经。十三者义略文句广契经。十四者义广文句略契经。十五者义略文句略契经。十六者义广文句广契经。十七者义深文句浅契经。十八者义浅文句深契经。十九者义深文句深契经。二十者义浅文句浅契经。二十一者远离当来过失契经。二十二者远离现前过失契经。二十三者除遣所生疑惑契经。二十四者为令正法久住契经

别解脱契经者。谓于是中依五犯聚及出五犯聚说过。一百五十学处为令自爱诸善男子精勤修学

事契经者。谓四阿笈摩。一者杂阿笈摩。二者中阿笈摩。三者长阿笈摩。四者增一阿笈摩。杂阿笈摩者。谓于是中世尊观待彼彼所化。宣说如来及诸弟子所说相应。蕴界处相应。缘起食谛相应。念住正断神足根力觉支道支入出息念学证净等相应。又依八众说众相应。后结集者为令圣教久住。结嗢拖南颂。随其所应次第安布。当知如是一切相应略由三相。何等为三。一是能说。二是所说。三是所为说。若如来若如来弟子是能说。如弟子所说佛所说分。若所了知若能了知。是所说。如五取蕴六处因缘相应分。及道品分。若诸苾刍天魔等众。是所为说。如结集品。如是一切粗略标举能说所说及所为说。即彼一切事相应教间厕鸠集。是故说名杂阿笈摩。即彼相应教。复以余相处中而说。是故说名中阿笈摩。即彼相应教。更以余相广长而说。是故说名长阿笈摩。即彼相应教更以一二三等渐增分数道理而说。是故说名增一阿笈摩。如是四种师弟展转传来于今。由此道理是故说名阿笈摩。是名事契经。于十二分教中除方广分。余名声闻相应契经。即方广分名大乘相应契经。此分别义如前应知

如是四种契经。由余未显了义令显了等二十种契经。如其所应当知其相。

从是已后依此所说四种契经。当说契经摩呾理迦。为欲决择如来所说。如来所称所赞所美先圣契经。譬如无本母字义不明了。如是本母所不摄经。其义隐昧义不明了。与此相违义即明了。是故说名摩呾理迦。总嗢拖南曰

  界略教想行　　速通因断支
  二品智事诤　　无厌少欲住

别嗢拖南曰

  界说前行观察果　　愚相无常等定界
  二种渐次应当知　　非断非常及染净

有四种所化有情。先数习邪解脱见所集成界。何等为四。谓于先有先世先身先所得自体中。听闻常见增上不正法。不如理作意增上力故。于今由彼为因由彼为缘。数习邪解脱见所集成界。如说由常见。如是由断见。由现法涅槃见由萨迦耶见。广说亦尔。此中世尊由种种胜解智力种种界智力增上力故。寻求彼先胜解及彼后界。如其所应为调伏彼邪胜解界故。多分为转四种法教。或为余智未成熟者令彼智成熟故。智已成熟者令彼解脱诸烦恼故。为初邪界有情。说因灭故行灭。由行尽门说无常性。为调伏彼邪胜解界故。为随第二邪界有情。说因集故行集。由行起门说无常性。为调伏彼邪胜解界故。为随第三邪界有情。由诸行苦门转正法教。为调伏彼邪胜解界故。为随第四邪界有情。若离诸行起萨迦耶见行者。由诸行空门转正法教。若即诸行起萨迦耶见行者。由无我门转正法教。为调伏彼邪胜解界故

复次善说法律。略由三种不共支故。不共外道。堕善说数。一者宣说真实究竟解脱故。二者宣说即彼方便故。三者宣说即彼自内所证故。云何真实究竟解脱。谓毕竟解脱及一切解脱。即是见道果。及此后所得世出世修道果。此中见道果。由毕竟故得名真实。而非究竟。于一切解脱犹有所应作故。又解脱有三种。一世间解脱。二有学解脱。三无学解脱。世间解脱非是真实。有退转故。有学解脱虽是真实而非究竟。犹有所作故。当知所余具足二种。云何方便。谓于诸行中依如所有性及尽所有性修无常想。依无常修苦想。依苦修空无我想。因此得入谛现观时。由正观察所知境故。获得正见。由此正见为依止故。修道位中遍于诸行住厌逆想。彼于住时虽由彼相应受忆念思惟不现前境明了现前。而不生喜。由不生喜增上力故。彼于行时即于彼受所缘境界不生染着。彼于一切所求境界得处中故。尚不希求何况耽着。彼由如是若住若行于喜贪缠速能灭尽。心清净住。又即于彼如所得道。极多修习为因缘故。永拔彼品粗重随眠。获得真实究竟解脱。当知即是心善解脱。云何自内所证。当知有四种相。若于有学解脱转时。由二种相内慧触证。谓我已尽诸恶趣中所生诸行。又我已尽除其七生二生一生所余后有所生诸行。又我已住能究竟尽无退转道。若于无学解脱转时。即由如是二种相故内慧触证。谓我已作为断其余一切烦恼所应学事。我今尚无余一生在。况二况七。又随所乐亦能为他如实记别。如是名为自内所证

复次即彼解脱有二种前行法。一者见前行法。二者道果前行法。见前行法者谓由解脱及彼方便自内所证增上力故。从他言音起闻思修所成妙善。如理作意。未入正性离生。能入正性离生。得如实见出世正见。道果前行法者。谓得如是正见已。复起所余正思惟等。或同时生或后时生。道前行法。为断所余诸烦恼故

复次为欲证得所未得解脱故。应观察八事。谓于诸行中爱味过患出离观察。及闻思思择力见道修道观察。于诸行中观察爱味时。能善通达诸行爱味所有自相。即于诸行观察过患时。能善了知三受分位过患共相。谓于是中甚少爱味多诸过患。如是了知爱味染着多诸过患共相。应已于所爱味一切行中。随所生起欲贪烦恼。即能除遣制伏断舍。于此欲贪不现行故。说名为断非永离欲故名为断。又于彼事心未解脱。若于随眠究竟超越。乃永离欲心得解脱。是名一门观察差别。又修行者于彼诸行正观察时。先以闻所成慧如阿笈摩。了知诸行体是无常。无常故苦。苦故空及无我。彼随圣教如是胜解如是通达。既通达已复以推度相应思惟所成微细作意。即于彼境如实了知。即由如是通达了知增上力故。于彼相应烦恼现行现法。当来所有过患如实观察。由思择力为依止故。设复生起而不实着。即能舍离。彼由如是通达了知及思择力多修习故。能入正性离生。既入正性离生已。由修道力渐离诸欲。彼由思择见道二种力故。随其所应断诸烦恼。谓不现行断故。及一分断故。由修道力究竟离欲。如是由前二种渐离欲贪。由修道力心得解脱

复次有二种烦恼断果及苦灭果。一者见所断果。由证彼故。能自了知我已永尽捺落迦傍生饿鬼。我今证得预流无退堕法。乃至广说。二者修所断果。由证彼故。能自了知。我最后身暂时支持。第二有等永不复转。复有二种苦灭。一者现在为因未来苦灭。二者过去为因现在苦灭。复有二种苦灭。一者心苦灭。二者身苦灭。复有二种苦灭。一者坏苦苦苦苦灭。二者行苦苦灭。复有二种苦灭。一者非爱业果苦灭。二者可爱业果苦灭。复有少分已见谛迹诸圣弟子。虽已超过诸恶道苦所有怖畏。由未永尽一切结故。其心犹有于当来世共诸异生生老死怖。为断彼故。而能发起猛利乐欲乃至正念及无放逸。勤修观行。

复次有二种愚夫之相。何等为二。一者于所应求不如实知。二者非所应求而反生起。何等名为是所应求。所谓涅槃诸行永灭。而诸愚夫于当来世诸行不生。都无乐欲。于诸行生。唯有欣乐。由是因缘于所应求及诸行生所有众苦。不如实知。何等名为非所应求而反生起。非所求者。谓老病死。非爱合会。所爱别离。所欲匮乏愁叹忧苦。种种热恼。彼于如是诸行生起。反生欣乐。于生为本一切行中。深起乐着。于生为本所有诸业。造作积集。由是因缘于有生苦及生为本老病死等众苦差别。不得解脱。如是名为非所应求而反生起

复次于诸行中有四决定。一无常决定。二苦决定。三空决定。四无我决定。云何诸行无常决定。由三种相当知过去未来诸行尚定无常。何况现在。何等为三。谓先无而有故。先有而无故。起尽相应故。若未来行先所未有定非有者。是即应非先无而有。如是应非无常决定。由彼先时施设非有。非有为先。后时方有。是故未来诸行无常决定。若现在从缘行生已决定有者。是即应非先有而无。未来诸行便应非是无常决定。现在诸行亦应不与起尽相应。由现在行从缘生已非决定有。以有为先施设非有。是故过去诸行无常决定。如是现在诸行。因未来行先无而有。因过去行先有而无。由此施设起尽相应。是故说言当知去来诸行无常性尚决定。何况现在。是名诸行无常决定。云何诸行苦性决定。谓去来诸行尚是生等苦法。何况现在。所以者何。过去诸行是已度苦。未来诸行是未至苦。现在诸行是现前苦。是名诸行苦性决定。云何诸行空性决定。谓去来诸行尚定空性。何况现在。所以者何。未来诸行其性未有。由此故空。过去诸行其性已灭。由此故空。现在诸行虽有未灭谛义胜义性所远离。由此故空。是名诸行空性决定。云何诸行无我决定。谓去来诸行尚定无我。何况现在。所以者何。未来诸行非我之相。未现前故。过去诸行非我之相。已越度故。现在诸行非我之相。正现前故。是名诸行无我决定。又由二相当知诸行决定无常。一由过去世已灭坏故。二由未来现在世是应灭坏法故。又由二相当知诸行决定是苦。一是生等苦法故。二是三苦性故。此诸苦相如前应知。又由二相当知诸行决定是空。一毕竟离性空故。二后方离性空故。毕竟离性空者。谓诸行中我我所性毕竟空故。后方离性空者。谓于已断一切烦恼心解脱中。一切烦恼皆悉空故。又由二相当知诸行决定无我。一诸行种种外性故。二诸行从众缘生不自在故。复由十相当知诸行四相决定。谓由败坏。变易。别离相。应法性相故。非可乐。不安隐相。应远离。异相相故。如是等相。如前声闻地已广分别

复次依出世道作意修中。有五离系品界。一者断界。二者无欲界。三者灭界。四者有余依涅槃界。五者无余依涅槃界。谓见道所断诸行断故。名为断界。修道所断诸行断故。名无欲界。即此唯有余依故。名有余依涅槃界。此依灭故。名为灭界。亦名无余依涅槃界。即此五界由一切行永寂静故。名诸行止。由我我所我慢执着。及与随眠皆远离故。说名为空。由一切相皆远离故。名无所得。于断界中。一切随顺有漏法上所有贪爱皆远离故。名为爱尽。于无欲界所有欲贪。皆远离故。名为无欲。于灭界中及于有余依无余依涅槃界中。如其所应皆永灭故。皆寂静故。随其次第说名为灭。亦名涅槃。又于断界未得为得勤修习故。名于诸行修厌。于无欲界未得为得勤修习故。名于诸行修离欲。于灭界未得为得勤修习故。名于诸行修灭

复次为心解脱勤修习者。有二种渐次。一智渐次。二智果渐次。云何智渐次。谓于诸行中先起无常智。由思择彼生灭道理故。次后于彼生相应行。观为生法老法乃至忧苦热恼等法。由是因缘一切皆苦。此即依先无常智生后苦智。又彼诸行由是生法乃至是热恼法故。即是死生缘起。展转流转。不得自在行相道理故。无有我。此则依先苦智生后无我智。如是观无常故苦。苦故无我。是名智渐次。云何智果渐次。谓厌离欲解脱遍解脱。云何厌。谓有对治现前故。起厌逆想令诸烦恼不复现行。云何离欲。谓由修习厌心故。虽于对治不作意思惟。然于一切染爱事境贪不现行。此由伏断增上力故。云何解脱。谓即于此伏断对治。多修习故。永拔随眠。如是名厌离欲解脱第一差别。复有差别。谓于厌位断界极成满故。名厌。即依止厌除非想非非想处。于余下地得离欲时。施设离欲位。故名离欲。于非想非非想处得离欲时。施设解脱位。故名解脱。是名厌离欲解脱第二差别。云何遍解脱。谓由如是烦恼杂染解脱故。生等诸苦杂染亦普解脱。是名遍解脱。如是由智增上力故。于诸行中起厌。由习厌故。得离欲。由习离欲故。得解脱及遍解脱。如是名为智果渐次。此中复有四种邪执。何等为四。一见邪执。二慢邪执。三自内邪执。四他教邪执。见邪执者。谓于诸行中执我我所。慢邪执者。谓于诸行中起我慢。执前见邪执障谛现观。后我慢邪执障修所断烦恼等断。自内邪执者。谓独处空闲不正分别为依止故。执有实我或见邪执。或慢邪执。他教邪执者。谓由他教起邪执着。谓此是我此是我所我慢行转。又于内起不正分别。执我我所。名内邪执。亦名非他教邪执。如是一切邪执永断。当知是名智果

复次由三种相应知诸行非断非常。何等为三。一以无住行为因故。二生已无住因故。三未来诸行因性灭故。此中诸行因无常故。生已住因不可得故。当知诸行非常。能生未来诸行。现在因性灭故。当知诸行非断。复有四缘。能令诸行展转流转。何等为四。一因缘。二等无间缘。三所缘缘。四增上缘。即此四缘略有二种。一因。二缘。因唯因缘。余三唯缘。又因缘者。谓诸行种子。等无间缘者。谓前六识等及相应法等无间灭。后六识等及相应法等无间生。所缘缘者。谓五识身等以五别境为所缘。第六识身等以一切法为所缘。增上缘者。谓五识等以眼等各别所依为增上缘及以能生作意等为增上缘。意识身等以四大种身及能生作意等为增上缘。又先所造业望所生爱非爱果。当知亦是增上缘。如是资粮望道道望得涅槃。当知亦是增上缘摄

复次由三种事二种相应。当观察杂染清净。云何由三种事观察一切杂染清净。一者于诸行中观察杂染因缘。谓观彼爱味为爱味故。二者于诸行中观察清净因缘。谓观彼过患为过患故。三者于诸行中观察清净。谓观彼出离为出离故。如是一切总略为一。名由三事观察一切杂染清净。云何由二种相观察一切杂染清净。一者由如所有性故。二者由尽所有性故。如所有性者。谓于诸行中若爱味若过患若出离。尽所有性者。谓于诸行中尽所有爱味。尽所有过患。尽所有出离。此中观察诸行为缘生乐生喜。是名于彼爱味。又此爱味极为狭小。如是由二种相。观察如所有性所有爱味。又观察诸行是无常苦变坏之法。是名于彼过患。又此过患极为广大。如是由二种相。观察如所有性所谓过患。又复观察于诸行中欲贪灭。欲贪断。欲贪出。是名于彼出离。又此出离寂静无上毕竟安隐。如是由二种相观察如所有性所谓出离又即此爱味即此过患即此出离。于诸行中若过去若未来若现在。若内若外。若粗若细。若劣若胜。若远若近。审谛观察。当知是名于彼观察如所有性所谓爱味过患出离。又为了知如是三事体性是有。应知三种有情众别。一于诸欲染着众。二于诸欲远离众。三于诸欲离系众。于此三处复有三种世间愚痴。谓若天世间。若沙门婆罗门。若诸天人。如是三种世间。由三因缘应知安立。一由得欲自在及净自在故。谓若魔若梵世间。二由勤修得彼因故。谓若沙门婆罗门。三趣种种业因果故。谓若诸天人。又于此三处随其所应能断作证。有二种道离四倒心。谓已入见地及于上修道多修习住。又此二种道有四种相心解脱果。一贪嗔缚解脱相。二欲贪灭断出离相。三九结离系相。四生等诸苦解脱相。此中前三相。显示因处烦恼解脱。后一相。显示果处诸苦解脱。于此义中譬如有人处在囹圄为种种缚之所系缚。所谓或木或索或铁。又置余人令其防守。或设有彼从幽絷处逃至远所。还执将来。或有尚不令彼转动。况得逃避。或有安置广大微妙种种可爱所系妙欲。在幽絷处令彼自然心生乐着无欲逃避。如是彼人为一切种缚之所缚。为善方便守之所守。为最坚牢系之所系。复为怨家随欲加害。所谓打拍或复解割。或加杖捶或总断命。若有能脱是四缚者。乃得名为从一切缚而得解脱。如是于彼三处世间愚痴有情为种种缚所系缚者。当知即譬贪嗔痴缚。其守禁者。譬不正寻思及未永拔烦恼随眠。不正寻思故尚不令动。况得离欲而远逃避。烦恼随眠未永拔故。虽世间道方便逃避远至有顶。复执将还。可爱妙欲譬之九结。由彼结故令于生死自然乐着。于自系缚不欲解脱。彼既如是为种种缚极所密缚。善方便缚之所密缚。最坚牢缚之所密缚。复四魔怨随其所欲以生等苦而加害之。若能从彼四种系缚善解脱者。乃可名为从一切缚而得解脱。复次嗢拖南曰

  略教教果终堕数　　三遍智断缚解脱
  见慢杂染净说句　　远离四具三圆满

由三因缘。有诸声闻。往大师所。请略教授。何等为三。谓唯多闻为究竟者。于诸余行而厌背者。生如是解。但略闻法足得自义。何藉多闻以为究竟。要修正行为贞实故。又弃舍多闻究竟欲故。又有怖畏于所入门多所作者。为善方便而得入故。或有即彼已于多法善听善思。彼作是念。我于多法已善听思。若我今者尽已听思所得诸法以为依止。于住心境及解脱境欲系心者。将不令我作意散乱。若尔住心尚不能得。何况解脱。又于如是所闻所思一切法中。不得决定。当依何者速证通慧。当依何者速得出离。当缘何境而得住心。当缘何境而得解脱。彼既如是自不决定。若于大师或众所识如来弟子现前。见已便即往诣请略教授

复次当知正教授有四种自义果得。谓为此出家及如此出家。即形相具足。事业具足。意乐具足。处舍取具足。依此故得无上得。现法得。自然得。内证得

复次有六种死。谓过去死。现在死。不调伏死。调伏死。同分死。不同分死。过去死者。谓过去诸行没。乃至命根灭故死。现在死者。谓现在诸行没。乃至命根灭故死。不调伏死者。谓于过去世不调不伏。有随眠行展转随眠。世俗说言士夫随眠。而命终已。于现在世结生相续。有随眠行所摄。自体而得生起。于现在世乃至寿尽亦复如是。不调不伏。广说乃至。而命终已。未来自体复得生起。又能摄取有随眠行。由摄取彼以为因故。便为生等众苦所缚。亦为贪等大缚所缚。调伏死者。谓于现在世已调已伏无有随眠。而命终已。未来自体不复生起。亦不摄取有随眠行。不摄取彼以为因故。解脱生等众苦差别。亦复解脱贪等大缚。同分死者。谓如过去不调不伏曾舍身命。于现在世亦复如是而舍身命。当知如此名同分死。名相似死。名随顺死。若于过去不调不伏舍身命已。于现在世已调已伏而舍身命。当知此名不同分死不相似死不随顺死。若于现在有随眠行展转随眠。而命终时如过去死。名同分死及随顺死。不如过去而命终时。不能摄取当所结生未来相续同分诸行。又此六种死当知有二种相。谓诸行流转过患相。及诸行还灭胜利相。若于过去及于现在。不调不伏同分而死。复于未来取生等苦。及为贪等烦恼缚者。名诸行流转过患相。若于现在已调已伏不同分死。又于未来不取众苦。解脱一切烦恼缚者。名诸行还灭胜利相

复次由八种相。得入于彼诸行生起世俗言说士夫数中。谓如是名。如是种类。如是族姓。如是饮食。如是领受。若苦若乐。如是长寿。如是久住。如是所有寿量边际。如是诸相于菩萨地宿住念中。当知如前已广分别

复次由三种相。于诸行中应知无我遍智及断。何等为三。一于内遍智。二于外遍智。三于内外遍智。断亦如是。随其所应。所谓诸行都无有我。无有我所。亦无有余互相系属。当知如是于内外俱遍智及断。此中由法住智得决定。遍智数习此故。舍彼相应所有随眠得毕竟断。当知此中为于诸行未得遍智者令得遍智故。如来大师说正法要。若于诸行已得遍智而未永断者。为令唯于如先所得遍智。数习得永断故。复加劝导

复次于生死中而流转者。有三种缚。由此缚故心难解脱。当知此唯善说法律能令解脱。非由恶说。何等为三。一者除其爱结余结所系诸有漏事。二者爱结所染诸有漏事。三者能生当来后有诸行。于此三缚由三因缘心难解脱。谓初由种种故。第二由坚牢故。可爱乐。故。第三由微细故。复由五相为后有缚所系缚者。当知有五我慢现行。谓由所依故。所缘故。助伴故。自性故。因果故。当知此中萨迦耶见以为依止。计我未来或当是有或当非有。以有非有为所缘境。此中非有为所缘境唯有一种。有为所缘乃有五种。谓我当有色。我当无色。我当有想。我当无想。我当非有想非无想。如是一切总收为一。合有六种所缘境界。言助伴者。谓动乱心。言自性者。恃举行相为其自相。戏论自性为其共相。一切烦恼戏论性故。因果性者。谓能感生为因性故。造作业行爱随逐故

复次由三种相。当知心善解脱。谓于诸行遍了知故。于彼相应诸烦恼断得作证故。烦恼断已于一切处离爱住故。又于此中由四种行。于诸行中能遍了知如所有性。谓无常等。由十一行。于诸行中能遍了知尽所有性。谓过去未来等。如前广说

复次有二种五种杂染并五种因相。如是二种。诸有学者应知应断。诸无学者已知已断。何等为二。谓见杂染及慢杂染。此二当知五种差别。谓由行故缠故随眠故。何等为五。一者计我。二者计我所。三者我慢。四者执着。五者随眠。当知此中计我我所我慢三种为所依止。于所缘事固执取着唯此谛实余皆愚妄。当知此中由缠道理说名执着。即彼种子随缚相续。说名随眠。又有识身及外事等。当知是彼五种因相。谓计我因相。乃至随眠因相。即此因相复有二种。一者所缘因相。二者因缘因相。计我我慢。以有识身为所缘因相。计我所通以二种为所缘因相。彼执着以闻不正法不如理作意及彼随眠。为因缘因相。彼随眠以不如实了知诸行烦恼诸缠数数串习。为因缘因相

复次有四种有情众。当知于中安立杂染。何等为四。一者外道有情众。二者此法异生有情众。三者有学有情众。四者无学有情众。外道有情众中。具有一切。此法异生有情众中。四种可得。及彼因相并执着因相一分。然执着不可得。有学有情众中。计我我所二种。及我因相执着随眠皆不可得。及我慢执着并彼因相。然有我慢随眠可得。无学有情众中。一切皆不可得。又外道有情众凡所有行。不为断彼。此法异生有情众所修诸行。正为断彼而未能断。未见如实故。有学有情众已断一分。为断余分复修正行。虽见如实而不自称我已能见。犹未获得尽无生智故。无学有情众一切已断。于诸行中而自称言我如实见

复次有八种清净说句。何等为八。谓由超过见慢故。名二种超过意清净说句。由断彼因相故。名除相清净说句。由断彼执着故。名寂静清净说句。由断彼随眠故名善解脱清净说句。复次有学有二清净说句。谓于后有一切行中。由不现行道理。名已割贪爱及转三结。无学有二清净说句。谓止慢现观故。及一切苦本贪爱随眠永拔除故。名已作苦边。如是一切总收为一。合有八种清净说句

复次由四支故具足远离名善具足。何等为四。一者无第二而住。二者处边际卧具。三者其身远离。四者其心远离。谓于居家境界所生诸相寻思贪欲嗔恚悉皆远离。依不放逸防守其心。又由五相发勤精进速证通慧。谓有势力者。由被甲精进故。有精进者。由加行精进故。有勇捍者。由于广大法中无怯劣精进故。有坚猛者。由寒热蚊虻等所不能动精进故。有不舍善轭者。由于下劣无喜足精进故。又为断惛沉睡眠掉举恶作。如其次第奢摩他毗钵舍那品随烦恼故。愿正止观无有失坏

复次于善说法毗奈耶中。有三圆满。何等为三。一行圆满。二果圆满。三师圆满。行圆满者。谓为触证断无欲灭界故。听闻正法。为他演说。自正修行。法随法行。是名行圆满。果圆满者。谓即由此法随行增上力故。心善解脱。又能证得现法涅槃。是名果圆满。师圆满者。谓能引发一切梵行之法。皆用世尊为根本故。皆由世尊转法眼故。皆以世尊为所依故。由如来出世有彼教可知故。说世尊为彼根本。佛出世已观待彼彼所化有情。说正法眼。师及弟子展转传来故。说世尊转正法眼转法眼已。若有于中生诸疑惑。唯依世尊乃能决了故。说世尊为所依止。又说法师略有二种。一者由教。二者由证。斯由从他闻正法已而宣说故。依证学道无学道已而宣说故

瑜伽师地论卷第八十五瑜伽师地论卷第八十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事行择摄第一之二

复次嗢拖南曰

  想行愚相眼胜利　　九智无痴与胜进
  我见差别三相行　　法总等品三后广

于诸行中修无常想行有五种。谓由无常性。无恒性。非久住性。不可保性。变坏法性故。此中刹那刹那坏故。无常。自体系属有限住寿故。无恒。外事劫后决定无住故。非久住。寿量未满容被缘坏非时而死故。不可保。乃至尔所时住。于其中间不定安乐故。变坏法。

复次愚夫略有三种愚夫之相。何等为三。谓诸愚夫于一切行如上所说。五无常性不能思惟。于非真实胜劣性中。分别胜劣称量自他。谓己为胜。是名第一愚夫之相。如谓己胜。谓等谓劣广说亦尔。与此相违当知智者。亦有三种智者之相

复次由二种相当知圣者慧眼清净。谓由远尘及离垢故。由见所断诸烦恼缠得离系故。名为远尘。由彼随眠得离系故。说名离垢。又现观时有粗我慢随入作意间无间转。若遍了知所取能取所缘平等。彼即断灭。彼断灭故。说名远尘。一切见道所断烦恼随眠断故。说名离垢

复次远尘离垢。于诸法中得法眼时。当知即得十种胜利。何等为十。一者于四圣谛已善见故。说名见法。二者随获一种沙门果故。说名得法。三者于已所证能自了知我今已尽所有那落迦傍生饿鬼。我证预流。乃至广说。由如是故。说名知法。四者得四证净。于佛法僧如实知故。名遍坚法。五者于自所证无惑。六者于他所证无疑。七者宣说圣谛相应教时。不藉他缘。八者不观他面不看他口。于此正法毗奈耶中。一切他论所不能转。九者记别一切所证解脱都无所畏。十者由二因缘随入圣教。谓正世俗。及第一义故

复次有九种智。能于诸行遍知超越。谓诸行流转智。诸行还灭智。杂染因缘智。清净因缘智。清净智。及苦智。集智。灭智。道智。此中诸行流转智者。略由三种因缘集故。一切行集所有正智。谓喜集故。触集故。名色集故。随其所应若色集若受等集若识集。即此三种因缘灭故。三种行灭。是名诸行还灭智。杂染因缘智清净因缘智及清净智者。谓于爱味过患出离。如前应知。四圣谛中苦等四智。如前分别圣谛道理。应知其相。于异生位修前五智。圣速证后四圣谛智。由证彼故。能于诸行如实了知。又若于前诸智有阙。必定不能以谛道理遍知诸行。要当证得方能遍知。若于谛理遍知行。智有所阙者。必定不能于上修道以对治力断诸烦恼超一切行。与此相违乃能超越。是故说言有九种智能于诸行遍知超越

复次修观行者由三处故。于诸行中无愚痴住。何等为三。一于过去诸行如实了知是无常性。二于现在诸行如实了知是灭法性。三于未来诸行如实了知生灭法性。彼由如是于三世行无有愚痴。不染污心安乐而住。堕在明数。与此相违当知即是有愚痴住。堕无明数。复有三种烦恼异名。多分说在烦恼品中。一贪异名。二嗔异名。三痴异名。贪异名者。亦名为喜。亦名为贪。亦名为顾。亦名为欣。亦名为欲。亦名为昵。亦名为乐。亦名为藏。亦名为护。亦名为着。亦名为希。亦名为耽。亦名为爱。亦名为染。亦名为渴。嗔异名者。亦名为恚。亦名为憎。亦名为嗔。亦名为忿。亦名为损。亦名不忍。亦名违戾。亦名暴恶。亦名[虫*旦]螫。亦名拒对。亦名惨毒。亦名愤发。亦为怒憾。亦名怀戚住。亦名生欻勃。痴异名者。亦名无智。亦名无见。亦名非现观。亦名惛昧。亦名愚痴。亦名无明。亦名黑闇。如是等名当知如前摄异门分多分已辨。喜贪差别我今当说。缘依止受所生欣乐。说名为喜。缘生受境所起染着。说名为贪。又于将得境生名喜。若于已得境生名贪。又于已得临将受用名喜。即于此事正受用时名贪。又于能得境界方便名喜。即于境界名贪。又于后有名喜。于现境界名贪。又于所爱他有情类荣利名喜。于自所得荣利名贪

复次于诸行中如理修者。有四胜进。谓胜进想略有三种。一未得为得。二未会为会。三未证为证。若为获得现法乐住。名第四胜进。最初能得先所未得预流果故。当知是名未得为得。即此为依复能契会上学果故。当知是名未会为会。即此为依复能证得阿罗汉果。于诸惑断能作证故。当知是名未证为证。若已证得阿罗汉果。更无未得为得乃至未证为证故。正勤修习但为现法乐住。正勤修习又依自义有三胜进想。谓于诸行中厌背想。过患想。实义想。厌背想者。复有四行。谓于诸行思惟如病如痈如箭恼害。如病者。谓如有一因界错乱所生病苦。修厌背想。如痈者。谓如有一因于先业所生痈苦。修厌背想。如箭者。谓如有一因他怨箭所中之苦。修厌背想。恼害者。谓于亲财等匮乏中因自邪计所生诸苦。修厌背想。如是名为修观行者于诸行中修厌背想。过患想者。复有二行。谓于诸行思惟无常。及思惟苦。实义想者。亦有二行。谓于诸行思惟空性及无我性。此中先于过患想及实义想正修习已。然后方能住厌背想。当知此中先说其果。后说其因

复次有四种我见为所依止能生我慢。一有分别我见。谓诸外道所起。二俱生我见。谓下至禽兽等亦能生起。三缘自依止我见。谓于各别内身所起。四缘他依止我见。谓于他身所起。分别我见为所依止生我慢者。谓由此见观自他身计有实我。由此二种我见为依。发生我慢。譬如清净圆镜面上质像为依发生影像。影像为依于自依止发生劣中胜想。如是由邪分别故。缘自依止我见为缘。发生缘他依止我见。如依质像发生影像。又此为缘发生我慢。方他谓己或胜或等或劣。俱生我见为缘生我慢者。当知譬喻与前差别。如明眼人临净水器自观眼耳。所余如前应知其相。此一切种萨迦耶见。唯依善说法毗奈耶方能永断。非余邪教。如是如来及众共知同梵行者。或诸弟子同梵行者有大恩德。唯由如是一因缘故。名于大师或灭度后同梵行者真实报恩。又由第二。谓若有能即依如是差别句义。为利益故勤修正行。如是亦名随分报恩。彼所希望未满足故

复次由三种相诸行灭故。说名无余依涅槃界。一者先所生起诸行灭故。二者自性灭坏诸行灭故。三者一切烦恼永离系故。先所生起诸行灭者。谓于先世能感后有诸业烦恼之所造作。及由先愿之所思求。今所生起诸行永灭。自性灭坏诸行灭者。谓彼生已任性灭坏。非究竟住诸行永灭。一切烦恼永离系者。谓诸烦恼无余断灭。由今灭故后不更生。是故由此三相诸行灭。故说名寂灭。非永无相。其相异故。若永无相。不可施设说名寂灭。

复次由三解脱门增上力故。当知建立四种法嗢拖南。谓空解脱门。无愿解脱门。无相解脱门。一切行无常一切行苦者。依无愿解脱门建立第一第二法嗢拖南。一切法无我者。依空解脱门建立第三法嗢拖南。涅槃寂静者。依无相解脱门建立第四法嗢拖南

复次当知有二种法嗢拖南增上行欲。一者胜解俱行欲。二者意乐俱行欲。胜解俱行欲者。由四种法嗢拖南故。于诸行中而生乐欲。又于诸行寂静生乐欲者。由意乐故独处空闲作意思惟。由四种相于彼寂静其心退还。一者于中由见胜利不趣入故。二者不信彼得不清信故。三者于彼所缘不生喜乐不安住故。四者于彼而起不乐胜解故。与彼相违当知即是意乐俱行欲。又由二缘依止无我胜解之欲。于彼涅槃由惊恐故。其心退还。一由于此欲不善串习未到究竟故。二于作意时由彼因缘念忘失故。又此忍欲未串习故。当尔之时于诸行中了唯行智。其心愚昧数数思惟我我尔时当何所在。寻求我行微细俱行障碍而转。由此缘故。彼作是思我当不有不。作是念唯有诸行。当来不有。彼由如是随逐身见为依止故。发生变异随转之识。由惊恐故。于彼寂灭其心退还

复次为断如是惊恐。有二种法多有所作。一者于诸有智同梵行所如实自显。二者因善法欲发解了心及调柔心。又发如是解了心者。听闻正法由三种相发生欢喜。一者由补特伽罗增上故。二者由法增上故。三者由自增上故。补特伽罗增上者。谓由睹见深可赞仰具大威力端严大师。及所称扬善说法者。法增上者。谓所说法能令出离烦恼业苦。及令信解最上深义。自增上者。谓有力能于所说法能随觉悟。又发如是调柔心者。谓有三见。一者若依彼而转。二者若由彼遍知。三者若应所引发。依彼而转者。谓于诸谛未得现观。为得现观。依彼胜解俱行极善串习正见而转。由彼遍知者。谓依随顺现观正见。于三事我执萨迦耶见。及彼随眠断常两见所依止性。并所得果。能遍了知。言三事者。一若所取。二若能取。三若如是取此。何所取。谓五取蕴。谁能取。谓四取。云何而取。谓四识住。随其次第如前应知。为二取心之所依处。又即于彼所有诸缠非理所引。缘彼境界萨迦耶见生起执着及彼随眠。如前应知。云何应所引发。谓住于彼而能永断萨迦耶见三事执着及彼随眠。于圣谛智不藉他缘。又若依彼应所遍知正见转时。于其三处起我执着及有随眠于诸行中若集若没不善知故。于处中行尚不能入。况得出离。若随顺现观正见住时。于三事中所有我执皆已离系。犹被随眠之所系缚。于诸行中若集若没能善知故。远离二边入处中行。虽未出离堪能出离。若已引发圣谛现观。由正见故于三事中无我执着远离随眠。于处中行先趣入已。后由此故方得出离。当知如是三见转时。有此差别

复次嗢拖南曰

  速通自体智境界　　流转喜足行顺流
  知断相想立违粮　　师所作等品后广

为欲证得未得真实究竟解脱。略有三法。能令获得速疾通慧。一者智力。二者不放逸力。三者数习力。智力者。谓若住彼堪能无间永尽诸漏。当知即是有学智见。不放逸力者。谓已获得如是知见。即依如是所得之道。方便勤修于心防护恶不善法。数习力者。谓即依此方便勤修常作常转。终不谓我为于今日得尽诸漏心解脱耶。为于来日。为于后日。由此邪思令心厌倦。无厌倦已便无怯畏。无怯畏已不舍加行。能尽诸漏。问智见何差别。答若照过去及以未来非现见境此慧名智。照现在境此慧名见。又所取为缘此慧名智。能取为缘此慧名见。又闻思所成此慧名智。修所成者此慧名见。又能断烦恼此慧名见。烦恼断已能证解脱此慧名智。又缘自相境此慧名智。缘共相境此慧名见。又由假施设。遍于彼彼内外行中。或立为我。或立有情天龙药叉健达缚阿素洛揭路茶紧捺洛牟呼洛伽等。或立军林及舍山等。以如是等世俗理行。缘所知境。此慧名智。若能取于自相共相此慧名见。又寻求诸法此慧名智。既寻求已伺察诸法此慧名见。又缘无分别影像为境此慧名智。缘有分别影像为境此慧名见。又有色尔焰影像为缘此慧名见。无色尔焰影像为缘此慧名智。彼由如是若智若见为所依止方便修时。复更勤修四善巧事。一观察事。二舍取事。三出受事。四方便事。观察事者。谓四念住。为欲对治四颠倒故。如实遍知一切境故。舍取事者。谓四正断。为欲断除不善法故。及为修集诸善法故。出受事者。谓四神足。依四静虑次第超出始从忧根乃至乐故。方便事者。谓诸根力觉支道支。当知即是能断见修所断烦恼正方便故。如是勤修善巧事者。当知有四种所依能依义。所依义者。谓观行者正勤修习。能依义者。谓成就学诸无漏法。而未清净。余无明[穀-禾+卵]所缠裹故。又彼诸法由清净道后方清净。此清净道当知复有四种差别。一者习近正法正审静虑。二者亲事善友。三者以尸罗根护少欲等法熏练其心。四者独处空闲。用奢摩他毗钵舍那胜正安乐以为翼从。又清净者。谓即依彼清净行道。多修习故。令有学法破无明[穀-禾+卵]趣无学地。又为得真实究竟解脱。当知略有五种渐次。一者先集资粮以为依止。二者以此为依。修奢摩他毗钵舍那。三者以此为依。具谛现观涅槃胜解。四者以此为依。于劣少证不生喜足亦不安住。于可厌法深生厌患。五者以此为依。证得最后金刚喻定相应学心

复次由五因缘。当知一切自体诸行皆悉无常。谓一切自体寿量有限。假使有人欲自祈验。我今以手执持泥团或牛粪团能经几时。作是愿已随取彼团。是人尔时任情所欲能执不舍。乃至于后欲弃即弃欲持即持。非如所受必死之身至寿尽际尚不能遂己之所欲延一刹那。况乎久住。又一切自体因所生故。彼因作故。是无常故。又有自体广大兴盛终归磨灭而可得故。谓在色界欲界天人大梵帝释转轮王等。又由无倒阿笈摩故。谓佛世尊于诸自体无常法性。现见现证而宣说故。复有三种诸受欲者圆满差别。由是因缘诸受欲者恒常戏论。何等为三。一资产圆满。二自体圆满。三广大殊胜有情供养圆满。当知复有三种因缘。能得如是圆满差别。谓施戒调伏诸根俱行。及欲界慈修所得果。慈为先导慈为因处。于诸有情损害。寂静行相转故。

复次当知于所知事有七种如实通达智行。一已得智。二未得智。三无颠倒智。四是处非有知非有智。五是处所余知不空智。六苦不净智。七速灭坏智。又由十五种相觉了诸行。能速断灭一切行愚。何等十五。谓水界所生故无我。似我而显现故不住。随欲而造作故。觉了诸色犹如聚沫。三和合生相似法故。如云地雨和合方便。觉了诸受喻若浮泡。于所知境能显能烧能使迷乱相似法故。觉了诸想同于阳焰。萨迦耶见根本断故。多品自体因差别故。刹那量后时无暂停相似法故。觉了诸行譬芭蕉柱。有取之识依四识住。发起种种自体。随转相似法故。觉了诸识方于幻事。此广分别如前摄异门分应知

复次有二世间摄一切行。一有情世间。二器世间。有情世间名种类生死。器世间名器生死。种类生死不同其余生死法故。望器生死当知略有五不同分。谓器生死共因所生。种类生死但由不共。是名第一因不同分。又器生死于无始终前后际断。种类生死于无始终相续流转常无断绝。是名第二时不同分。又器生死或火水风之所断坏。种类生死则不如是。是名第三治不同分。又器生死因无永断。种类生死则不如是。是名第四断不同分。又器生死断而复续。种类生死断已无续。是名第五续不同分。又于生死由五种相一切愚夫流转不息。一由爱因故。二由爱果故。三由爱自性故。四由因展转故。五即因展转依止前际无穷尽故。此中无明是名爱因。能往善趣恶趣诸业。是名爱果。由往善趣业故。爱结所系。愚夫自然乐往。由往恶趣业故。爱锁所系。愚夫虽不欲往强逼令去。爱自性者。略有三种。一后有爱。二喜贪俱行爱。三彼彼喜乐爱。如是三爱略摄为二。一者有爱。二者境爱。后有爱者。是名有爱。喜贪俱行爱者。谓于将得现前境界。及于已得未受用境。并于现前正受用境所有贪爱。彼彼喜乐爱者。谓于未来所希求境所有贪爱。当知此中由喜贪俱行爱故。名爱结系。由后有爱及彼彼喜乐爱。故名爱锁系。若于彼事爱结所系。名为驰走。若于彼事爱锁所系名为流转。又于长世因展转来诸行相续。前际难知后无穷尽。由是五相流转愚夫当知复由五相所缚。一于彼处缚。二由彼而缚。三正是能缚。四依彼故缚。五有所领受。于彼处缚者。谓由能往善趣业故。于善趣柱而系缚之。或由能往恶趣业故。于恶趣撅而系缚之。又由喜贪俱行爱故。于自事柱而系缚之。由彼彼喜乐爱及后有爱故。于自事撅而系缚之。由彼而缚者。谓愚夫异生为无明缚。正是能缚者。谓自同类于苦无厌相似法故。依彼故缚者。谓依后蕴而被缚故。有所领受者。谓领受彼生等众苦

复次愚夫异生于有漏事有四喜足。当知多分是诸外道。何等为四。一于人身喜足。二于欲界天身喜足。三于生梵世喜足。四于到边际有顶喜足。愚夫于彼随其次第。若趋若住若坐若卧。复有五种一切愚夫爱所行路。一者后有。二者未来所求境界。三者将得现前境界。四者已得所有境界。五者现前受用境界。当知于彼如其次第趋等差别应知。此中趣有二种。一于后有。二于未来所求境界。复有四种爱所行路。一者意业希求境界。二者身语二业。三者获得。四者于所得中随其所欲若转若习。此是发业爱所行路。若求境界或复诸有。当知于彼四种行路。如其次第趋等差别。如说趋等。于余所说诸有漏事所有喜足爱所行路。喜乐戏论染着耽湎四处差别。如其次第当知亦尔。复有二种游爱行路果相差别。一心差别。二身差别。心差别者。复有二种。一品类差别。二杂染差别。品类差别者。谓由自性故。所依故。所缘故。助伴故。杂染差别者。谓由贪嗔痴等所有烦恼及随烦恼。身差别者。亦有二种。一种种身差别故。二一种身差别故。当知此中心之所有杂染差别。能为二种身差别因。为断彼故诸修行者应以无倒数数作意勤修观行。复由四种因差别故令果差别。谓若于此差别。若由此差别。若即此差别。若如此差别。于此差别者。谓于善趣恶趣所有差别。由此差别者。谓由贪嗔痴所染污心令彼差别。即此差别者。谓五种行所摄受身种种差别。如此差别者。谓于诸行流转杂染清净因缘及清净体。不如实知。生喜乐等及趋走等种种差别

复次不能了达诸行无常。萨迦耶见为所依止顺流而行。诸愚夫类。由五种相当知顺流而被漂溺。谓若于此漂溺。若由此漂溺。若依此漂溺。若如此漂溺。若漂溺时诸所有相。于此漂溺者。谓于善趣恶趣而被漂溺。如从两岸彼此往来俱被漂溺。由此漂溺者。谓由爱河浸淫之性之所漂溺。当知此爱有五种相。一游诸境界趣下分故。二微细随行难觉了故。三于诸境界难回转故。四乃至有顶一切广大种种诸行所随逐故。五不寂静相乱身心故。依此漂溺者。谓依色等五种诸行而被漂溺。即于善趣恶趣两岸。有五种行品类差别。数数攀缘顺流漂溺。如此漂溺者。云何漂溺。谓于诸行如前所说流转等事。随其次第不如实知。或计为我及我所故。于漂溺时所有相者。谓彼如是被漂溺时。虽宝爱身欲使长久。由自性灭不能令住。如为漂溺。与此相违当知即是逆流行者。又聪慧者有十种相。当知具摄诸聪慧相。谓成就俱生慧故。又成就方便闻思修所成慧故。又成就故无动摇故。善思所思善说所说善作所作。又能自依己所有性。未尝为命依附于他。又有所求无不安乐。又有所求能依正行。皆悉以法不以非法。又自所宜资产众具。能正防守不令散失。又观过患而受用之。又于病缘所有医药。观察思择然后服行。又能善避非时死缘。如是十种聪慧者相。当知具摄诸聪慧相

复次于诸行中依无我理知者断者。当知略由三相差别。谓于诸行能遍了知萨迦耶见而未断者。彼于诸行忘念之行。多分现行少不忘念。萨迦耶见已永断者。当知其相与彼相违。是名第一差别之相。又于诸行虽遍了知萨迦耶见。而未断者。于诸广大可爱事中多生喜乐。于诸下劣不可爱境多生忧苦。彼二境界现在前时。无纵逸者尚自不能系守正念。况纵逸者。彼于尔时萨迦耶见缠绕其心。由彼令心不能解了。萨迦耶见已永断者。当知其相与彼相违。是名第二差别之相。又于诸行萨迦耶见未永断者。未能于内一切行中现前安立离有情想如于草木叶等外事。萨迦耶见已永断者。当知其相与彼相违。是名第三差别之相。如是已断萨迦耶见。有此三种差别之相。当知复有三种胜利。一者永断能感后有一切烦恼。二者依彼不久获得速能积集彼对治道。三者既作自义利已。即依彼道方便勤修现法乐住。由此获得极安乐住

复次由四差别当知修习一切种行无常苦想。何等为四。一果差别故。二自性差别故。三品类差别故。四方便差别故。果差别者。谓修此想能遣一切欲贪色贪及无色贪掉慢无明。当知此中显示三种本烦恼断。及显三种随烦恼断。欲贪烦恼掉为助伴。色贪烦恼慢为助伴。无色贪惑无明为伴。复有差别。谓于此中显示下分上分结。尽自性差别者。谓于此中由正修习闻所成慧。说名亲近。由正修习思所成慧能入修故。说名修习。由正修习修所成慧。名多修习。又由修习了相作意故。名亲近。唯除加行究竟作意。由正修习诸余作意故。名修习。修习加行究竟作意。名多修习。是名第二三种差别。又由所依所缘作意。随其次第当知是名为乘为事为随建立。又由长时串修习故。说名纯熟数数无倒修方便故。说名善受及与善发。品类差别者。谓修如是无常想时。速能永拔一切随眠。弃舍下地一切善法。摄受上地一切善法。于余一切不净想等最高广性。能善住持。遍行一切犹如观察所取之事。即如是观能取之事。彼相解脱能得无漏无常之想。若有漏想若无漏想。如是一切皆于涅槃善能随顺趣向临入。皆能对治无明大闇一切永断。永断彼故清净鲜白。诸无学想皆由一切无漏学想增上故得。方便差别者。谓独处空闲以无颠倒数数作意。观察诸行无常之性。由无常想住无我想。于见道中既住无漏无我想已。于上修道由有学想永害我慢。随得涅槃二种皆具

复次为住涅槃仍未积集善资粮者。略有五种违资粮法一者忆念往昔笑戏欢娱承奉等事。因发思慕俱行作意生愁叹等。二者由彼种种为依。于所领受究竟法中。多生忘念令于诸法不能显了。三者所食或过或少。由此令身沉重羸劣。于诸梵行不乐修行。四者喜眠不串习断。便为上品睡眠所缠。五者亲近猥杂而住。远离谛思正法加行。如是五种违资粮法。复有五种随顺彼法。一者于二离欲犹未能离随一种欲。谓于诸缠远分离欲勤修善品。及于随眠永害离欲得正对治。二者不护根门。三者食不知量。四者初夜后夜不能勤修勉励警觉。五者不能观察善法究竟。与上相违。当知是名顺资粮法及能随顺彼随顺法。又诸声闻修行如是顺资粮法及彼因缘。于其中间求涅槃时。大师为彼制立五种正道言教。一者由依观察如所闻法。遍于一切诸行无常。诸法无我。涅槃寂静。且以世间作意而得无惑无疑。二者即于住时不着三事。不正寻思。何等三事。一者资命众具。二者他损害相。三者或他毁骂。或随有一非爱现行。同梵行者不同分法。三者教授为先由依他音如理作意。能生正见能断邪见。当知此三是名住时正道言教。复有二种于彼行时正道言教。谓诸有智同梵行者。为彼宣说处非处时不生忿怒。又由粗弊资命众具若得不得。及由戒等所有灾害心不热恼。是名第一。于得所胜利养恭敬心不悒然。是名第二。彼由如是住时行时能正修行涅槃妙道。由此不久当得涅槃终无毁失

复次大师于诸声闻略有五种师所作事。一者正折伏。二者正摄受。三者正诃责。四者正说杂染。五者正说清净。复次由二因缘于诸诤事违越声闻。覆相记别彼所诤事。一扰乱增广故。二与律相应故

复次由七因缘大师驱摈诸声闻众。一者见一切种皆行邪行故。二者见彼多分故。三者由彼众首上座阿遮利耶邬波拖耶方便故。四者不堪共住故。五者被驱摈故。六者避现前过故。七者令不生起未来过故

复次由十因缘如来入于聚落乞食。一者当显杜多功德故。二者为欲引彼一分令入乞食故。三者为欲以同事行摄彼一分故。四者为与未来众生作大照明故。乃至令彼暂起触证故。五者为欲引彼粗弊胜解诸外道故。六者为彼承声起谤故。现妙色寂静威仪。令其惊叹心生归向故。七者为彼处中众生以其少功而树多福故。八者为令坏信放逸深生耻愧。虽用小功而获大福故。如为放逸者懈怠者亦然。九者为彼盲聋癫狂心乱众生种种灾害皆令静息故。十者为令无量无边广大威德天龙。药叉。健达缚。阿素洛。揭路茶。紧捺洛。牟呼洛伽等。随从如来至所入家。深生羡仰勤加宾卫。不为恼害故

复次由八因缘如来入于寂静天住。一者为引乐杂住者令入远离故。二者为欲以同事行摄远离者故。三者自受现法乐住故。四者为与大族诸天示同集会故。五者为以佛眼观察十方世界。现大神化随其所应作饶益事故。六者为令诸声闻众于见如来深生渴仰故。七者为显诸大声闻于所略说善能悟入故。八者劝舍乐着戏论制作言词故。复次由五种相。大师摄受诸声闻众。一以法故。二以财故。三与依止故。四初摄受故。五摈摄受故

复次由七因缘释梵天等往如来所。一为供养如来故。二为听闻正法故。三为决所生疑故。四为顺他而为翼从故。五为愍他欲为饶益故。六由爱重如来圣教故。七知如来起世俗心欲令赴会故

复次由五种相。当知一切初新者性。一由晚出家故。二由幼出家故。三由少出家故。四由劳策出家故。五由受具出家故

复次由三种相。生起恶作。一违越所学增上故。二誓受法律增上故。三弃舍居家增上故

复次如来将欲为诸声闻宣说正法。现四种相。一者从极下坐安详而起升极高座俨然而坐。二者安住随顺说法威仪。三者发謦欬音示将说法。四者面目顾视如龙象王

复次犯戒声闻当于三处安住。惭羞往大师所。一者深知己犯为增上处。二者师事失仪为增上处。三者由事乖则当以方便调顺威仪往大师所为增上处

复次由三种相。应正呵责犯戒声闻。一曰汝期鄙劣活命。二曰汝意乐不清净。三曰汝以活命意乐行非法行。复次于善说法毗奈耶中。略由六相当知遍摄一切邪行。一者现行过失故。二者意乐过失故。三者加行过失故。四者智慧过失故。五者寻思过失故。六者依止过失故。现行过失者。谓由贪缠故染嗔缠故憎。既怀猛利贪嗔等故遂无羞耻。无羞耻故住恶不舍。意乐过失者。谓于染者边此贪意乐最为下劣。如是于憎者边此嗔意乐最为下劣。加行过失者。谓或有不发精进。或有精进慢缓。智慧过失者。谓或于闻思所成慧中。忘失正念多住愚痴。于修所成心不寂定。寻思过失者。谓于随顺居家所有恶不善觉多分寻思。于正法律其心错乱。依止过失者。谓彼依止于其往昔不修集因。由不修集因故。成就自性微褊小信。成就自性修住小戒。成就自性住守小念。成就自性俱生小慧。复次由四种相。能令彼人虽入圣教而行邪行。一由微劣不净意乐故。二由伺求圣教瑕隙为正法贼故。三由专为饮食衣服活命因缘故。四由怖畏王贼债主所加迫切故。若行如是诸邪行者。便于二事有所稽留。一者失坏在家自义稽留。二者失坏出家自义稽留。复次如是邪行有二因缘。谓于三事不正寻思。及彼前行诸不正想。其三事者如前应知。于彼发起诸不正想随取相好。自斯已后于其随法。多随寻思多随伺察

复次为断如是邪行因缘。当知亦有二种对治。一者为断不正寻思。以无颠倒数数二行。于诸念住善住其心。二者为断诸不正想。修习无相心三摩地。此修对治。要由于彼修对治中猛利乐欲。方得成办。非彼乐欲不猛利者。此猛利欲由二缘生。谓此对治有大果故。不共一切诸外道故。有大果者。谓修习时便能克证无相心定。及住二界妙甘露门。所谓断界及无欲界。若有余依及无余依。安住此者近二涅槃。未于今时一切皆得言不共者。谓无相定唯内法有。诸外道无。何以故。由彼外道若有所得即便增益不如量观。若无所得即妄分别。由我见故。愚于诸行。或唯于身或唯无色。或总于二生我执着。以执我故。谓我当无。便于涅槃心不欣乐。尚未能入。况乎安住。唯增惊怖其心退还。住内法者与彼相违。于般涅槃心无退转。了唯苦灭见唯静德。若诸有学唯祈内灭。非为生道更从他求教授教诫。若诸无学唯欣内灭。终不更求尽诸烦恼。唯有先因所生诸行。任运归灭而般涅槃

瑜伽师地论卷第八十六瑜伽师地论卷第八十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事行择摄第一之三

复次嗢拖南曰

  因胜利二智　　愚夫分位五
  二种见差别　　于斯圣教等

一切行因略有二种。一共。二不共。共因者。谓喜为先因。由此喜故于彼彼生处。障于厌离滋润自体。为欲将生所生之处。虽有一切烦恼为因。而于生处生喜者生。非于彼起厌逆想者。又即此喜唯依色说。宿因生已不待余因究竟转故。不共因者。谓顺苦乐非苦乐触。望于受等所有心法无间灭意及俱生名十种。色等望六种识。由彼虽从先因所生。刹那刹那别待余因方得生起

复次有解脱心有净智见诸阿罗汉。有四胜利。当知不与诸外道共。一于行时恒常住性。二于住时无相住性。三往昔因所生诸行任运归灭。四后有行今因断故当不复生。为证如是四种胜利。有三渐次。谓学智见为依止故。得厌离者于诸行中不生喜乐。乃至不生耽湎而住。厌离为先而得离欲。离欲为先心善解脱。自斯已后即由如是心善解脱。恒常住。故无顺无违。又于行时或于住时。于一切相无复作意。于无相界作意思惟。无相而住。能障于此一切见趣先已永断。况当为碍。彼由是二若行若住乃至寿尽。便以无学内般涅槃而般涅槃。先所生有于今永尽。当来诸行无复更生。又由三分当知建立萨迦耶见以为根本一切见趣。一由前际俱行故。二由后际俱行故。三由前后际俱行故。前际俱行者。谓如有一作是思惟。我于去世为曾有耶。为曾无耶。曾为是谁。云何曾有。后际俱行者。谓如有一作是思惟。我于来世为当有耶。为当无耶。当为是谁。云何当有。前后际俱行者。谓如有一作是思惟。我曾有谁。谁当有我。今此有情来何所从。于此没已去何所至。又诸外道萨迦耶见以为根本。有六十二诸恶见趣。谓四常见论。四一分常见论。二无因论。四有边无边想论。四不死矫乱论。如是十八诸恶见趣。是计前际说我论者。又有十六有见想论。八无想论。八非有想非无想论。七断见论。五现法涅槃论。此四十四诸恶见趣。是计后际说我论者。如是计度后际论者。略摄有五。一有想论。二无想论。三非有想非无想论。四断见论。五现法涅槃论。如是五种复略为三。一常见论。二断见论。三现法涅槃论。又此一切诸恶见趣由六因缘而得建立。一由因缘故。二由依教故。三由依静虑故。四由依世故。五由依诸见故。六由生处故。由因缘者。谓彼一切萨迦耶见以为因缘。由依教者。谓由依彼能显见趣不正法藏。师弟传闻展转相授为方便故。由依静虑者。谓以静虑为依上故。于先所闻先所信解而得决定。又此静虑复有二种。一与宿住随念俱行。二与所得天眼俱行。宿住随念俱行者。谓计前际三常论中。由下中上清净差别。及于四种边无边论。由彼忆念诸器世间成坏两劫出现方便。若时忆念成劫分位。尔时便生三种妄想。若有一向忆念上下。下至无间奈落迦下。上至第四静虑之上。忆念如是分量边际。便于世间住有边想。若有一向傍忆无际。便于世间住无边想。若有忆念二种俱行。便于世间住二俱想。若时忆念坏劫分位。尔时便住非有边想非无边想。诸器世间无所得故。复有依止诸静虑故。当知或说一分常论。或说无因论。或说不死矫乱论。应知此中有二净天。一不善清净。二善清净。若唯能入世俗定者。当知是天不善清净。于诸谛中不了达故。其心未得善解脱故。若能证入内法定者。当知是天名善清净。于诸谛中已了达故。其心已得善解脱故。当知无乱亦有二种。一无相无分别。二有相有分别。此中第一是善清净天。第二是不善清净天。前清净天于自不死无乱而转。是故说名不死无乱。后不清净若有依于不死无乱。有所诘问。便托余事矫乱避之。以于诸谛无相心定不善巧故。先兴心虑作是思惟。我等既称不死无乱。复有所余不死无乱。于诸圣谛无相心定。已得善巧。彼所成德望我为胜。彼若于中诘问于我。我若记别或为异记。或拨实有或许非有。彼于记别见如是等诸过失已作是思惟。我于一切所诘问中皆不应记。又于是中见有余过。谓他由此鉴我无知因。则轻笑不死无乱。有行谄者作是思惟。我于此中应如是记。非我净天一切隐密皆许记别。谓自所证及清净道。如是思已故。设诡言而相矫乱。彼既如是住邪思惟遍布其心。于彼最上清净天所。故称我是不死无乱。由怀恐怖而无记别。勿我劣昧为他所知。由是因缘不能解脱。以此为室而自安处。又有愚戆专修止行。不能以其谄诈方便矫设乱言。但作是思。诸有来问我当反诘。随彼所答我当一切如言无减而印顺之。由是计度有差别故。建立四种。由依世者。谓依过去及现在世起分别故。名计前际。依未来世起分别故。名计后际。由依诸见者。谓依三见如前应知。由依初见于现法中计我有色。后或有色有想。或无有想。或非有想非无想。依第二见于现法中计我无色。于后所计如前应知。依第三见我论有二。一者说我有色无色。二者说我非有色非无色。余如前说。又即计我是有色者。或言狭小或言无量。计我无色当知亦尔。此二我论依第三见立为二论。一者计我狭小。二者计我无量。由是四种我论差别说。我有边说。我无边说。我亦有边亦无边说。我非有边非无边。随其次第如前应知。又即依止如是诸见及依我论。复宣说我清净解脱。于欲静虑皆得自在。随其所欲多住变化。如其所欲安住静虑。以清净见游戏受用方便法乐。如是名为依诸见故。应知安立。由生处者。谓我有一想乃至广说。有一想者。谓在无色空无边处识无边处。有种种想者。谓在下地。即如所说随其次第。应知说我有狭小想。有无量想。一向有乐者。谓在下三静虑。一向有苦者。谓在捺落迦。有乐有苦者。谓在鬼傍生人欲界天。有不苦不乐者。谓在第四静虑已上乃至非想非非想处。又于如是诸外道处。当知总有三种衰损。一者见及欲乐展转相违论衰损。二者依我无智论问记衰损。三者依法随法行证得衰损。此中三种。若计有想若计无想。若计非有想非无想论者。及断见论者。或依责他为胜利论。或依免难为胜利论而起计度。当知是名第一衰损。由彼诸论计度后际。依未来世妄计于我为有无故。依我无智论问记衰损者。谓于若诸杂染若杂染处若能杂染。如是一切世俗胜义二谛道理不如实知。由此无智有所趣向以为先故。得有差别。从此无智何所趣向。谓三四转。一常无常等。二有边无边等。三自作他作等。所以者何。彼由无智要先趣向。如是差别后方问记。又于圣法毗奈耶中。所有智者不可记事。于二道理不容记故。谓世俗胜义二谛道理。此中四种一向常论计前际者。及计前际无因论者二种差别。皆先计我后方缘我一向常等诸论差别。又即四种一分常论计前际者。彼有差别。谓有一分缘常无常论。或有一分缘非常非无常论。边无边等诸转如前边无边等。应知其相。若欲一切皆宿因作。名自作论。若欲一切皆自在等变化因作。名他作论。若欲少分自在天等变化因作一分不尔。名俱作论。若无因作论名俱非作论。当知是名第二依我无智论问记衰损。由彼诸论计度前际依过现世妄分别。故依法随法行证得衰损者。谓有沙门若婆罗门。不观责他为胜利论。不观免难为胜利论。亦不依我无智诸论为求利养恭敬等事乐欲开阐。于恶说法毗奈耶中而求出家。唯除乐求出离解脱。当知彼是薄尘种类。为性愚戆专修止行。彼由为得初静虑定教授教诫能于后际俱行见趣。及于前际俱行见趣。不然许故。而得超过。于现法中又能超过欲界诸结。证远离喜。自斯已上无闻无知。即于此中生涅槃想。如由彼故证远离喜。如是。或有由别因缘证得第二第三静虑无爱味乐。第四静虑无苦乐受。从此已上乃至非想非非想处。当知亦尔。于种种想俱行苦乐受等差别。已超过故。如是彼于趣诸取行不能超越。乐退还法。未般涅槃。起涅槃慢。当知是名第三衰损。此中如来自然证觉寂静妙迹。于如所说一切行相三种衰损。由五种相如实了知。谓若彼自性。若彼诸见。若由无智彼得生起。若所缘转。若彼所缘粗弊过患及上出离。于如是事如实了知。即出离中常自出离

复次有二智。能令见清净。及见善清净。谓法住智及此为先涅槃智。法住智者。谓能了知诸行自相种类差别。及能了知诸行共相过患差别。谓于随顺若苦若乐不苦不乐三位诸行方便。了知三苦等性。涅槃智者。谓于如是一切行中。先起苦想后如是思。即此一切有苦诸行无余永断。广说乃至名为涅槃。如是了知名涅槃智。即此二智令见清净及善清净。要由二门正勤修习方令彼净。一自无力补特伽罗。因他教授能令彼净。二自有力补特伽罗。多闻思求能令彼净。此中第一补特伽罗。不聪利故。信等诸根唯一味故。止观所缘于少分法谛察忍转。与此相违当知第二补特伽罗。复有三种现观边智。修习彼故见得清净。一能顺生无漏智智。二无漏智。三无漏智后相续智。初世间第一法所摄智。第二若住于彼能断见断一切烦恼。第三烦恼断后解脱相续智。若住中智便名已入正性离生。超过异生地。未得预流果。虽未克证第三解脱预流果智。于其中间所住刹那如未克证。终无中夭以时少故。从此无间必证第三。住此位中如实现见所知境故。名见清净。有余惑故非善清净。若于此智更多修习成阿罗汉。一切烦恼皆离系故。名善清净。又无余断三相应智。一由不现行故。二由界故。三由事故。不现行者。谓虽生起而不染着。虽未永断由数修习诸善法故。令成远分诸缠烦恼不复现行。界者三界。如前应知。事谓二事。一烦恼事。二是苦事。又于安乐利益随逐诸离系品五种界中。有寂静微妙胜功德等。乃至涅槃。为其最后。差别应知。又于此中一切依持皆弃舍者。当知割舍父母等事。又于中有生有后有无复更生。如其次第当知说名无有相续无取无生。又于三品由三种门为障碍故。当知建立三结差别。谓未发趣故。虽已发趣邪成立故。于正法中不正行故。即在家品处恶说法毗奈耶中。而出家品处善说法毗奈耶品。又行趣向逆流行者。解脱恶趣。成就二种解脱决定。一者烦恼解脱决定。二者后有解脱决定。由是因缘故名预流。乃至广说。又若证得阿罗汉果先在学地。于诸行中已不执受我及我所。后于诸漏皆得解脱。又与四种义相应故。当知是名阿罗汉相。一者自事已究竟应作他事义故。二者应得自义一切遍满道理义故。三者未来行因已永断灭应证现法乐住义故。四者超有学地入无学地相应义故

复次愚位有五。若于中转堕愚夫数。何等为五。一不获得俱生慧故。二不获得从闻他音缘生慧故。三不获得真圣慧故。四愚痴缠所缠缚故。五彼随眠所随缚故。复有四种妄计我论。一者宣说诸行是我。二者宣说我有诸行。三者宣说诸行属我。四者宣说我在行中。由二因缘妄计我论作诸杂染。一执着故。二随眠故。执着故者。谓诸外道虽求解脱。由彼为障于一切种不能获得。随眠故者。谓诸内法耽着境界。暂时为障而非究竟

复次若有我见若无我见。同缘诸行为境事故。说名同分。而于彼事邪取正取染污清净等义别故。名不同分。又由四相于所缘事。邪僻执着增上力故。能令我见作诸杂染。一因缘故。二自性故。三由果故。四等流故。因缘故者。谓二愚痴。一事愚痴。二见愚痴。事愚痴者。由愚事故。先闻邪法。后起我见。见愚痴者。谓愚见故。于见相应诸无明触。所生起受。妄计为我。由此为缘。恒为我爱之所随逐。复由此故常于我见不能舍离。自性故者。谓二因缘之所摄受。等随观察。于彼随眠。不得远离。由果故者。谓即以彼萨迦耶见为依止故。不能远离我慢随眠。是二随眠增上力故。能引当来诸根令起。由彼领纳苦乐二受因。更发起计我我所。不如正理思惟相应。意言分别谓我我所有其领受。等流故者。谓由先因力所持故。即见种子所随逐意。后有意界。由前因缘所熏修力而得成满。即于如是后有意中。有无明种及无明界。是二种子所随逐意所缘法界。彼由宿世依恶说法及毗奈耶所生分别萨迦耶见以为依止。集成今界。即由此界增上力故。发起俱生萨迦耶见。于善说法毗奈耶中。亦复现行能为障碍。又即此见由二种相六转现行。一由世故。二由慢故。由世故者。谓我于过去为曾有耶。为曾无耶。乃至广说如应当知。由慢故者。谓我为胜。乃至广说。彼于如是一切如实不知不见。由此因缘不如正理起于邪观。又明位有三。谓闻他音如理作意。是初明位。已能证入正性离生。是第二明位。心善解脱阿罗汉果。是第三明位。其无明位复有二种。一先。二后。随眠位是先。诸缠位为后。又约见修所断有异。当知是名第二差别。

复次是处世尊依自圣教。为欲显示善说发起。依他邪教。为欲显示恶说失坠。自有所说。后结集者。于法门中。称为世尊嗢拖南说。由二因缘善说法律名为发起大果大利。恶说法律即为唐捐。一者于善说法毗奈耶中。一切众苦永离可得。谓三种苦性。二者一切诸结永断可得。谓下上分结。于恶说法毗奈耶中。如是二事皆不可得。彼由依止萨迦耶见。于诸行中心厌苦苦。欲乐为依起兹胜解。愿于当来无有苦我。我无有苦。或复已断即彼苦因及彼当果。于未来世由二种相而生胜解。谓苦未来当离于我。及我未来当无有苦。虽由如是四种行相乐断为依。离欲界欲生初静虑。次第乃至于彼非想非非想处若定若生。由是因缘超越苦苦。而未能断下分诸结。未断彼故。当知苦苦未永超越。彼于坏行二苦断中尚不生乐。何况能断。由彼随顺所未断故。当知于顺上分诸结亦未能断。住内法者。初修观时。虽于欲界未得离欲。有情胜故。而于三苦深心厌离。依乐断欲。于诸行中。用无我见以为依止。发其胜解。愿于未来无三苦我我无三苦。彼初修习如是行已。于欲界欲而得远离。永断苦苦。如前复生如是胜解。当无彼我。我当无彼。如是行者于其苦苦究竟解脱。亦永超越顺下分结。即于此道次第进修。乃至能得阿罗汉果。若诸愚夫萨迦耶见以为依止。于永超越坏行二苦。及永断灭随顺上分一切结中。谓我当无于不应怖妄生怖畏。尚不起乐。况当能断。又于是处由二因缘不应生怖。谓唯有心住四识住。有转有染。又唯有心断四识住。无转无染。复有四依。谓色受想行。复有四取。谓于欲见戒禁我语所有欲贪。复有二缘。谓若所缘及若能缘。复有六识。谓眼识等。复有二识住。谓烦恼缠住及彼随眠住。此中诸取增上力故。以不如理分别为先。由我我所邪境界取。由缘自相境界之取。由俱有依。此三因缘令诸识转。及令染污。复由三种。谓于现法趣集谛故。缘未来苦我当如是。如是爱故。于彼先因所生现苦。而安住故。复由三种。谓趣乐位故。缘苦位故。安住不苦不乐位故。复由三种。谓趣来世故。缘去世故。住现世故。复由三种。谓由后有爱。趣后有故。由彼彼喜乐爱。缘未来境界故。由喜贪俱行爱。住现在已得境界故。复由三种。由贪欲身系。趣向随顺贪处事故。由嗔恚身系缘彼事故。由戒禁此实二取身系。住彼事故。中嗢拖南曰

  果因与受　　世爱及系

喜爱滋润如前应知。谓如诸行因中宣说。又即彼识如是转时。于二生处当知结生相续增广。一于有色。二于无色。于有色处依止中有而有去来。于无色处唯有徙生。即于两处乃至寿尽相续而住故。名为住。当知此住欲界人中。有三分位。谓初入胎识所滋润。胎分圆满。自胎而出。当知此三复有差别。欲色无色如其次第。若有弃舍如来所说识流转道。而作是言。我当更作别异施设。当知是人所施设者。其文有异其义无别。但有言事。或余智者于其异文先示道理。后方诘问汝所施设别异者何。彼于尔时茫然不了。或于后时自得达鉴。于前所立如理谛观。反生愚昧。由愚昧故。自觉无知我本受持为恶非善。又十色界名为色界。当知复有六种受界想界行界。又于三位当知诸识解脱烦恼。谓于诸行深见过患。能令诸缠远分离故。于见地中。一切外道诸系随眠永断灭故。依止修道得究竟故。又诸外道于所妄计一切生处。谓大自在。那罗衍拏。及众主等无量品类。乐生彼故。名贪身系。于他诸见异分法中。深憎嫉故。名嗔身系。依于邪愿修梵行故。于同梵行可乐法中。起增背故。由此二缘于憎上戒学能为杂染。当知即彼由戒禁取。于增上心学能为杂染。由此实执取身系故。于增上慧学能为杂染。如是四法能于色身名身趣向所缘安立事中。令心系缚故。名身系。又彼在意地故。意分别故。意相应故。意随眠故。染污意故。名意所成。又彼断者。谓缘彼境诸烦恼断。非彼所缘。即于彼境无倒解故。又由后有诸业烦恼之所摄持。后有种识当知。于此依止建立。彼无有故。当来三种如前所说。差别理趣生长广大。当知一切悉皆尽灭。又即由彼无所住识。因分果分不复生长。诸道所摄而得生长。又彼空解脱门为依止故。名无所为。无愿解脱门为依止故。名为喜足。无相解脱门为依止故。说名为住。于彼爱乐数修习故。得善解脱。一切随眠永灭尽故。心善解脱。从是已后逮得恒住。虽住诸行而无所畏。已得诸蕴任运而灭。余因断故无复更生。彼有漏识由永灭已。遍于十方皆无所趣。唯除如影诸受与彼识蕴识树。当知如灯皆归寂灭。即于有余涅槃界中。依初缠断。说名寂静。依第二断。说名清凉。依第三断。说名宴默。又由三缘识趣识住皆无所有。一由自然非染污故。二由所余不染污故。三由余识助伴无故。

复次嗢拖南曰

  断支实显了　　行缘无等教
  四种有情众　　道四究竟五

诸修断者略由五支摄受。于断能于诸行如实显了。一由身远离故。二由心远离故。三由奢摩他品三摩地故。四由毗钵舍那品三摩地故。五由常委所作故

复次当知有十二种如实显了行相。如摄异门分说。谓听闻各别善取恶取故。正教现量比量境界故。自相共相故。如所有性尽所有性故。入见究竟地故

复次略有四种如实显了行相道理智所缘事。谓住内法异生。于率尔堕境所起受中。不如实知增上力故。能令诸行流转杂染。如实知故能令清净。复有在家异生。于欣后有等所依中。不如实知增上力故。能令诸行流转杂染。与彼相违能令清净。复有诸外道。于所爱乐虚妄分别。定生喜爱。所依行中不如实知增上力故。能令诸行流转杂染。与彼相违能令清净。复有住于内法有学。依诸根境所有妄念。于余残行不如实知增上力故。流转杂染。断余残故便得清净。当知于此一切品中。诸清净品皆住内法。如是名为四所缘事

复次由三因缘。如来所说教无与等。一者宣说不共法故。二者宣说无倒法故。三者宣说自觉法故。此中宣说。若趣萨迦耶集行。即是趣苦集行。若趣萨迦耶灭行。即是趣苦灭行。是名宣说不共法教。若复说言此真实有。是名宣说无倒法教。若复说言我如实知。是名宣说自觉法教。复有三种诸行流转差别。一者萨迦耶是诸有情染着安足处所义故。二者世间是染着处败坏义故。三者有是染著者更生义故

复次彼有情众略有四种。何等为四。一者一向安住可爱业果。即于此果耽着受用。谓生天处专行放逸。二者一向因转。谓希求彼所有沙门若婆罗门。三者乐般涅槃诸有情众。四者诸杂种类。谓住于此或住于果。耽着受用。或乐摄受当来爱果。或时时修涅槃资粮。离诸放逸。于前三种有情众中。随其所应当知世间彼集灭边。及萨迦耶彼集灭边。于后第四有情众中。当知萨迦耶彼集彼灭趣道差别

复次依二种道。当知施设四种行相。云何依二种道。谓依见道及依修道。云何施设四种行相。一应遍知行相。二应永断行相。三应作证行相。四应修习行相。如是四种。三依见道。一依修道。入见道时谛现观俱能遍知。苦断一分集证一分。灭于彼一分能断证者。于修道中为求无余断及证故。如所得道应勤修习。因修如是诸思择道及修道故。永断余集证得余灭。

复次证得如是极究竟者。由五种相。应知究竟。何等为五。谓已证得苦及苦因无余尽故。堪作他义一切自义皆圆满故。证得毕竟断及智故。能入究竟涅槃城故。既得入已于其圣住能安住故。于第一相有割爱等四种差别。如前应知。于第二相有阿罗汉尽诸漏等所有差别。如前应知。于第三相有毕竟究竟一切行事皆悉断故。有毕竟无垢一切烦恼毕竟断故。有毕竟梵行以为后边。谓已获得彼对治故。于第四相譬如世间具五种相名入宫城。随阙一种不名为入。如是要具与彼相似五种相故。当知名入涅槃宫城。何等名具世间五相。一者辟宫城门。二者超踰隍堑而不堕落。三者深起果决而越度之。四者越隍堑已逼临宫阙。五者非自非余之所希望。胜幢既仆徐入中宫。如是入宫无诸挂碍。入涅槃宫亦复如是。先断能顺五下分结。如彼辟门。次于涅槃起深坑想。无明怖畏断无余故。如超隍堑而不堕落。能到萨迦耶彼岸故。能持最后身故。如彼果决而越度之。将入无余依涅槃界如逼宫阙。已断有爱于诸境界无复爱生。遍于一切憍慢不起而入涅槃。如非自他之所希望。胜幢既仆徐入中宫。如前所说五种因缘。入涅槃宫当知亦尔。又既入已由二种相安住圣住。一由行故。二由住故。行由三相应正了知。一不共故。二无染故。三正依止所依止故。永断顺五下分结故。于诸欲中毕竟离欲。即于是处而游行故。说名不共。于六恒住常摄受故。名为无染。于一分法思择远离。谓恶象马等。于一分法思择习近。谓衣服饮食等。是名为正依止所依。如是于行善清净已。复由五相应了知住。谓若由此而住。若此为依。若由此离系。若此为依。若由此相应。当知此中由不动心解脱而住。于一分法思择除遣。谓游行散乱劬劳因缘身心疲怠。于一分法思择忍受。谓寒热等。是名为依。由于三种杂染离系。谓见杂染及爱杂染寻思杂染。由见杂染得离系故。于后有中心无动摇。由爱杂染得离系故。于诸境界不被漂沦。寻思杂染得离系故。寻思唯善无有不善。如是名为由此离系。此依四种静虑无动三摩地。安住第一现法乐住。是名为依。由与无学心善解脱。慧善解脱而共相应。又离爱者。于第二身不复生故。于涅槃舍无退转故。克证无上圆满德故。由此五相应知圆满住第一住

复次嗢拖南曰

  二品总略三有异　　胜解断流转有性
  不善清净善清净　　善说恶说师等别

略由三处总摄一切黑品白品。一由所遍知法故。二由遍知故。三由成遍知故。所遍知法者。谓苦谛集谛。当知总摄一切黑品。遍知者。谓灭谛。当知此摄白品一分。成遍知者。谓补特伽罗及道谛。补特伽罗虽是假有。当知亦是白品所摄。此即如来诸圣弟子。于世俗谛及胜义谛。皆悉善巧。依二道理如实随观。俱不可记。谓如来灭后。若有若无。亦有亦无。非有非无。皆不可取亦不可记。所以者何。且依胜义彼不可得。况其灭后或有或无。若依世俗为于诸行假立如来。为于涅槃若于诸行。如来灭后无有一行流转可得。尔时何处假立如来。既无如来何有无等。若于涅槃。涅槃唯是无行所显。绝诸戏论。自内所证绝戏论故。施设为有不应道理。亦复不应施设非有。勿当损毁施设妙有寂静涅槃。又此涅槃极难知故。最微细故。说名甚深。种种非一。诸行烦恼断所显故。说名广大。现量比量及正教量所不量故。说名无量

复次由三因缘。内荷担苦与外荷担苦有其差别。一所荷担。二能荷担。三荷担时。谓外荷担色一分摄。或秆或薪或余种类是所荷担。愚夫乃以一切诸行为所荷担。又外荷担属在身肩。是能荷担。愚夫乃以一切爱蕴为能荷担。又外荷担唯以现肩荷担所担。愚夫乃以一切爱蕴荷担所担。欲舍所担要并除蕴。无别方便而能弃舍。乃至未能舍所担来恒常荷担大重担故。执持尪劣微弱细软不静肩故。长时无间荷所担故。内有三德领受如是荷担众苦。外则不然。是名二种荷担差别

复次由五种相。愚夫内缚与彼外缚而有差别。谓彼外缚为色一分之所系缚。或木或铁或索所系。愚夫乃为诸行所缚。又彼外缚他缚所缚。愚夫乃为自缚所缚。又彼外缚易可了知缚缚因缘脱脱方便。愚夫内缚一切难知。又彼外缚死后即无。愚夫内缚死后诸行随逐往来循环不舍。又彼外缚所有出家能舍诸欲。便得解脱。一切怨仇不能拘碍。愚夫内缚虽得离欲。乃至有顶尚未能脱。况唯出家。当知此中在离欲位。魔罗于彼不得自在。未离欲位便得自在。其出家位未脱魔手。若在家位随欲所作。未离欲位魔缚所缚。由世间道虽生有顶未脱魔罥

复次略由四相。当知如来与慧解脱阿罗汉等同分异分。由一种相说名同分。谓解脱等故。由三种相说名异分。谓现等觉故。能说法故。行正行故。此中如来无师自然修三十七菩提分法现等正觉。等正觉已遍依胜义。若于现法有能无能。若现见法不现见法。于一切种皆悉了达。是名自然等觉菩提。如是了达胜义法已。于其二障善得解脱。谓并习气诸烦恼障及所知障。与诸天众及余世间。为解脱师独一无二。当知了达如是四相。是名自然等觉菩提。由此不与诸声闻共。又依他义作所作等能说正法。由五种相当知不共。何等为五。一者如来如实了知一切种道为道。一切种非道为非道。二者知已如实宣说是道非道。为令趣道不趣非道。三者若有如所说道乐欲勤行。为令彼行摄受方便如理所引作意正道。以教授门而为宣说。四者彼如圣教行时。若有障碍止观过失皆令除遣。五者若有随顺彼法皆令摄受。是名能说不同分法。此中正行不同分者。谓彼声闻先依如来后行正行。夫如来者无少所依。又彼成就声闻种性行于正行。而佛如来成自种性。又彼声闻或已成熟或当成熟。非最后有菩萨身中二行可得。若未熟者彼随道行能熟当来成熟相续。若已熟者彼于现法成大师。教如此二种如其圣教即如是行。若随道行彼于来世当证涅槃。若于现法成大师。教彼依此身便证圣道道果涅槃。即此圣道及圣道果。无损乐故名如实法。饶益性故又说为善

复次于诸行中略有二种无我胜解。一者闻思增上胜解。二者修证增上胜解。此中闻思增上胜解。能与修证增上胜解作生依止。诸善男子净信出家。虽复在此极善殷到。且于其中不应喜足。要此为依于诸行中。渐次修习无常等想。证得无我增上胜解。为令彼证转增胜故勤修观解

复次由四种相。应知诸行有二种断。何等为四。一诸缠断故。二随眠断故。三后有诸行因性断故。四现在诸行染行断故。如是四种当知总说为二种断。谓烦恼断及以事断。前之二相名烦恼断。后之二相说为事断

复次于欲界中诸行流转初中后位。当知略有三种密苦。一者生时为其胎藏所覆障故。有覆障苦。二者生已处婴稚位多疾病苦。三者衰耄诸根成熟有老死苦。又彼诸行流转生起初中后灭。当知即是三种苦灭

复次有三有性。为断彼故诸圣弟子当勤修学。一依过去为因有性。由是因缘净信舍家趣于非家。深见过患厌弃诸欲。二依未来所生诸行为因有性。三依现在未断意乐杂染有性。为断如是三种有性故。有三断。谓无顾恋故。不欣乐故。断离欲灭界集成故

复次于诸行中略有二种离增上慢观无我见。何等为二。一不善清净。二善清净。云何名为不善清净。谓如有一远离而住。依观诸行无常性忍。由世间智于无我性发生胜解。因此胜解于眼所识色乃至意所识法等随观察。我我所相不现行故。说名为断。又能制伏四外系所摄贪嗔痴三种所有。谓贪欲身系摄贪所有。嗔恚身系摄嗔所有。余二身系摄痴所有。当知此中极鄙秽义是所有义。离增上慢无我智者如理作意。共相应故定地摄故。当知此智由二因缘不善清净。一者即于此时。谓于趣入顺决择分善根位时。有粗我慢随入微细现行作意间无间转。由是因缘作如是念。我今于空能修能证。空是我有。由是空故计我为胜。如空无相及无所有当知亦尔。二者能令彼法现行因缘。谓于诸欲或萨迦耶有染爱识。由于如是有染爱识。不遍了知增上力故。便为诸欲萨迦耶爱之所漂溺。由此意乐于彼涅槃不能趣入。其心退还。如前已说。又由八相能遍了知。遍了知故除诸过患。当知是名极善清净。离增上慢无我真智。又于此中已灭坏故。灭坏法故。说名无常。诸业烦恼所集成故。说名有为。由昔愿力所集成故。名思所造。从自种子现在外缘所集成故。说名缘生。于未来世衰老法故。说名尽法。死殁法故。说名殁法。未老死来为疾病等种种灾横所逼恼故。名破坏法。由依现量能离欲故能断灭故。名于现法得离欲法及以灭法。当知此中除离欲法及以灭法。由所余相略观三世所有过患。由所除相观彼出离。若由如是过患出离遍知。彼识名善遍知一切法中无有我性。名诸法印。即此法印随论道理法王所造。于诸圣身不为恼害。随喜能得一切圣财。由此自然吉安超度生死广大险难长道。是故亦名众圣法印。当知此中由前名通达智。由后名善清净见

复次应知由五种相于内外法师及弟子高下差别。一由住故。二由御众故。三由论决择故。四由建立开显道故。五由行故。谓诸外道师及弟子。恒常住于愦闹之住。内法师弟时时住于极寂静住。是名第一高下差别。又外道师由自有量出家弟子。诸外道僧说名有僧。由自有量在家弟子。诸外道众说名有众。希彼一切共许为师故名众师。愚类众生咸谓有德。是故说名共推善色。当知如来与彼相违。虽为一切天及世间无上大师。于彼同尊而无所冀。又外道师与自弟子共兴议论决择之时。凡有所说展转意解。各各差别不相扶顺。转增愚昧非净其智。当知内法与彼相违。又外道师为诸弟子。依止无因不平等因。施设建立开显其道。听闻如是不正法故。为大罗刹娆乱其心。又由不正寻思相应非理作意其心散动。以于他所怀胜负心咎责于他。若他反诘便兴辛暴。不审思择。轻出言词。自为无因不平等因所覆藏故。名为杂染。由此愚夫于染因缘。若自若他不如实知故。名愚昧。离清净故。名不明了。于清净因不善巧故。说名不善。又乃至于应所说语。如所说语。是处说语。如是一切不如实知。是故说彼为不知量。为不知恩。当知内法与彼相违。又诸外道师及弟子虽无异说。所说无减无颠倒故。虽不流漫所说无增无加益故。虽等所说义相似故。虽是法说文平等故。虽复记别法及随法。然于同法乐为朋党。当知彼于法随法行自义证得不放逸者。尚不能得。况纵逸者。彼由如是不得自义。便为他论制伏。轻毁并彼所受诸恶邪法。当知内法与彼相违。是名五种高下差别

复次由四种相。当知诸行非定苦染。又由四相。非定乐净。如是四相总依三事。何等为三。一依生处故。二依受故。三依世故。此中乐者。谓在第三静虑。乐所随者。谓在人中。容有二种。喜乐遍者。谓在初二静虑。未永离乐者。谓在第四静虑已上。此中苦者。谓在饿鬼及以傍生。苦所随者。谓在人中。忧苦遍者。谓在那落迦。未永离苦者。谓在上天众中。当苦所随故。又言乐者。谓不苦不乐受现在前位。乐所随者。谓苦受现在前位。喜乐遍者。谓乐受现在前位。不永离乐者。谓于一切位乐因所随故。若与此相违当知苦差别。又言乐者。谓顺乐行及乐已灭。乐所随者。谓有乐因于未来世当生起乐。喜乐遍者。谓于现在随顺乐处。未永离乐者。谓余三世。与此相违苦差别四。如应当知

瑜伽师地论卷第八十七瑜伽师地论卷第八十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事行择摄第一之四

复次嗢拖南曰

  二智并其事　　乐等行转变
  请无请说经　　涅槃有二种

智有二种。一者正智。二者邪智。此中正智依有事生。邪智亦尔。虽此二智俱依有事。然正智如实取事。邪智邪分别不如实取事。由有正教如理作意为前行故。于所知境正智得生。由有邪教非理作意为前行故。于所知境邪智得生。非正智生坏所知境。但于此境舍于邪执而起正智。如闇中色。明灯生时不坏此色。但能照了。当知此义亦复如是

复次随顺乐受诸行与无常相共相应故。若至苦位尔时说名损恼迫迮。若至不苦不乐位。尔时方于行苦名苦迫迮。若不至彼位。便应毕竟唯顺乐受勿至余位。又生老等法所随诸行皆悉是苦。彼若至疾病位。说名损恼迫迮。若至生等苦位。名苦迫迮。若不至彼位。于诸行中生等苦因之所随逐。勿至果位。又本性诸行众缘生故。不得自在。亦无宰主。若有宰主。彼一切行虽性无常。应随所乐流转不绝或不令生。广说乃至于死

复次有二种契经。一因请而说。二不因请说。因请说者。谓若有补特伽罗由此诸行相教而调伏者。因彼请故。为转如是诸行相教。不因请说者。谓若于彼多百众中。以无量门作美妙说。或为大师近住弟子阿难陀等。作如是说。为令正法得久住故

复次当知由三分故。摄受圆满涅槃。一由随顺教授故。二由正观察一切行故。三由永断一切烦恼故。随顺教授者。谓记说教诫神变所摄。如来随欲记说彼心。由自定意以三行相遍照他心。若展转久远灭心。若无间灭心。若于现在所缘转心。从定起已随念分别思惟定内所受他心。如其所受即如是记。汝有如是心。谓久远灭者。如是意。谓无间灭者。如是识。谓现在者此据种类不据刹那。即以如是记说神变为依止故。于其三处而为教诫。一于行处现前境界。开许如理作意。遮止不如理作意。二于住处遮止不正寻思。开许正寻思。三于止观勤修行处。开许令断未断诸行。及令烦恼永得离系而证涅槃。如是宣说令从三处诸随烦恼心得清净。谓从行处住处依处。又正观察过去未来现在诸行。名正观察。一切诸行又有三漏。三漏为先而有欲害。欲害为先而有寻思热恼。寻思热恼为先而有追求忧恼。如是一切皆永断。故说名永断一切烦恼。如是定住心善解脱无相乐住。无恐怖时于现法中名入圆满般涅槃数。又依三法依止自义。名住归依。依止他义名住洲渚。何者为三。一依内如理作意为先法随法行。二依佛听闻所说正法。三依亲近正法内善士。不依亲近余正法外一切外道诸不善士。如是三法当知显示人中四种多所作法。谓亲近善士。听闻正法。如理作意。法随法行。复由三缘及五种相当知证得彼分涅槃。何等三缘。一遍知苦故。二深见一切随顺苦行诸过患故。三超过愁等一切苦故。云何五相。一知苦种类相交涉时发生愁等。是名于彼遍知自性。二知有种子彼法得生。是名于彼遍知因性。三知自所行所知境界。是名于彼遍知缘性。四随观执着我所及我皆是能顺众苦诸行。是名于彼遍知行性。五随观三世欲界所系诸行过患。能断一切愁等诸苦。当知由此三缘五相。获得如是彼分涅槃。由可爱事无常转变悲伤心戚故。名为愁。由彼发言咨嗟歔欷故。名为叹。因此拊膺故。名为苦。内怀冤结故。名为忧。因兹迷乱故。名为恼。又以丧失财宝无病亲戚等事随一现前创生忧恼。说名为愁。由依此故次乃发言哀吟悲冤。举身烦热名叹。苦位过此愁叹。身烦热已内烧外静心犹未平。说名忧位。过初日已或二三五十日夜月由彼因缘意尚未宁。说名为恼

复次嗢拖南曰

  诤芽见大染　　一趣学四怖
  善说恶说中　　宿住念差别

由四因缘如来不与世间迷执共为怨诤。然彼世间起邪分别谓为怨诤。何等为四。一者宣说道理义故。二者宣说真实义故。三者宣说利益义故。四者有时随世转故。此中如来依四道理宣说正法如前。所谓观待道理。作用道理。因成道理。法尔道理。由此如来名法语者。如来终不故往他所求兴诤事。所以者何。由诸世间违返他义谓为自义故兴诤论。如来乃以一切他义即为自义故。无所诤。唯除哀愍令其得义故。往他所为说正法。而诸邪执愚痴世间颠倒妄谓自义我义。而有差别故。兴我诤。由此因缘当知如来名道理语者。又复如来名真实语者。谓若世间诸聪敏者共许为有。如来于彼亦说为有。谓一切行皆是无常。若于世间诸聪敏者共许为无。如来于彼亦说为无。谓一切行皆是常住。又复如来名利益语者。谓诸世间有盲冥者。自于世法不能了知。如来于彼自现等觉而为开阐。又复如来或时随顺世间而转。谓阿死罗摩登只等依少事业以自存活。然诸世人为彼假立大富大财大食名想。如彼世人假立名想。如来随彼亦如是说。又如一事于一国土假立名想。于余国土即于此事立余名想。如来随彼亦如是说。若怀怨诤而兴怨诤。则不得名道理语者。真实语者。利益语者。随世转者。由具如是四种因缘。是故当知如来无诤。又佛世尊自然观察所应作义。虽无请问而自宣扬现等觉法。能以称当名句文身。施设建立诸法差别。广说如前摄异门分。如是当知乃至说名平等开示

复次一因二缘令后有芽当得生长。谓五品行中烦恼种子所随逐识。说名为因。与因相似四种识住。说名为缘。又由喜贪滋润其识。令于彼彼当受生处结生相续。感萨迦耶。亦名为缘。此中有一由四识住摄受所依由喜贪故。于现法中新新造集及以增长。彼于后时成阿罗汉。令识种子悉皆腐败。一切有芽永不得生。又复有一具一切缚。勤修正行欣乐涅槃。遍于一切诸受生处。起厌逆想。彼具缚故种子不坏。识住和合。然于诸有起厌逆想故无喜贪。彼由如是修正行故。于现法中堪般涅槃。其后有芽亦不得生。又复有一住于学地得不还果。唯有非想非非想处诸行为余。于有顶定具足安住。彼识种子犹未一切悉皆灭尽。然于识住能遍了知能遍通达。彼由忘念增上力故。上地贪爱犹残少分。是不还者。当来下地一切有芽不复更生。与此相违当知一切诸后有芽皆得生长

复次杂染有二。一见杂染。二余烦恼杂染。见杂染者。谓于诸行计我我所邪执而转萨迦耶见。由此见故或执诸行以为实我。或执诸行为实我所。复有所余。此为根本诸外见趣其余贪等所有烦恼。当知是名第二杂染。又见杂染得解脱时。亦能于余毕竟解脱。非余杂染得解脱时即能解脱诸见杂染。所以者何。由生此者依世间道。乃至能离无所有处所有贪欲。于诸下地其余烦恼心得解脱。而未能脱萨迦耶见。由此见故。于下上地所有诸行和杂自体。不观差别。总计为我。或计我所。由此因缘虽升有顶。而复退还。若于如是一切自体。遍知为苦。由出世道先断一切萨迦耶见。后能永断所余烦恼。由此因缘无复退转。是故当知唯见杂染是大杂染。

复次应知由三种相道名一趣。谓于异生地以五行相。观察诸行五处差别。即此观察于二时中修治令净。谓于行向学地及无学地。云何名为五种行相观察诸行。一者观察诸行自性。二者观察诸行因缘。三者观察杂染因缘。四者观察清净因缘。五者观察清净

复次应知于异生位先于五处得善巧已后。于学位即于如是五种处所。更以五种差别行相审谛观察。能令获得速疾通慧。何等名为五种行相。谓观察诸行。诸行因缘。杂染因缘。清净因缘。灭寂静故。趣向清净道出离故。诸行种种众多性故。各自种子所生起故。各待余缘所生起故

复次应知由四因缘。于二处所发生恐怖能为障碍。何等为四。一者若于此位生起。二者若依此法生起。三者若彼如是生起。四者若彼行相生起。位生起者。谓于非圣位中。生起于诸圣谛。未得善巧。又此非圣于五处所亦未善巧。依生起者。谓于诸行起邪行相。计我我所萨迦耶见为依生起。如是生起者。谓由二种诸行变坏差别生起。一由异缘所变坏故。二由自心起邪分别而变坏故。行相生起者。谓于所爱虑恐未来当变坏故。生恐怖行相。于正变坏生损恼行相。即于所爱已变坏中。欣彼重生起顾恋行相。又于涅槃分别自体永变坏故。起怖畏行相。如是行相差别转时。于爱乐圣教及爱乐涅槃。能为障碍。又由二种门于所缘境自所行处。我我所执差别而转。谓推求故。及领受故。即见及受

复次由三种相。善说法者恶说法者。于等事中宿住随念。当知染净有其差别。何等为三。谓恶说法者宿住随念。于彼诸行自相共相不如实知。便于诸行或全计常。或一分常或计非常。或计无因。善说法者宿住随念。如实知故无邪分别。是名第一二念差别。又恶说法者。随依何定发宿住念。不能如实了知是苦。便生爱味。由爱味故。于过去行深生顾恋。于未来行深生欣乐。于现在行不能修行厌离欲灭。善说法者。当知一切与彼相违。是名第二二念差别。又恶说法者。如是邪行四种杂染所杂染故。能感后有。何等名为四种杂染。一业杂染。二见我慢缠杂染。三爱缠杂染。四彼随眠杂染。若诸新业造作增长。若诸故业数数触已而不变吐。是名业杂染。若于诸行邪分别起萨迦耶见。于他有情以诸沙门婆罗门等与己挍量。谓自为胜或等或劣。是名见我慢缠杂染。于内于外所起贪欲。于爱行中应知其相。是名爱缠杂染。于相续中见我慢爱三品粗重常所随逐。是名彼随眠杂染。如是四种总摄为二。谓业烦恼。烦恼复二。缠及随眠。于诸行中先起邪执后生贪着。由此二种增上力故。虽复有余烦恼杂染。而但取此。尔所烦恼于诸行中不挍量他。自起邪执。说名为见。挍量于他。说名我慢。如是邪执是无明品。由此为先发起贪着。名为爱品。由此二种根本烦恼。于生死中流转不绝。若善说法毗奈耶中正修行者。能断如是四种杂染。于现法中能般涅槃。又由此故能住究竟圆满涅槃。若不尔者尚不能住彼分涅槃。何况究竟。是名第三二念差别。又于此中见及我慢。说名高视。爱说名烟。何以故。于诸行中为见我慢所覆障者。不如实知其性弊劣诸行体相。于人天身及彼众具。谓为高胜。是故彼二说名高视。爱犹如烟令心扰乱不得安隐。是故名烟

复次嗢拖南曰

  无厌患无欲　　无乱问记相
  障希奇无因　　毁纯染俱后

有二信者。而非称当信者所作。何等为二。一在家信者。信有涅槃及一切行是无常性。然于诸行不观过患不厌离住。不知出离而受用之。二舍离家法趣于非家有净信者。彼于涅槃不能安住猛利乐欲。不用此欲为所依止。常勤修习所有善法。于现法中不般涅槃。与此相违应知称当信者所作

复次于内法中略有二种具聪明者。若有净信或诸外道来请问时能无乱记。谓依中道。于诸行中问生灭时。不增有情不减实事。唯于诸行安立生灭不乱而记。若立有情有生有灭。是名一边。谓增益边。若立生灭都无所有。是第二边。谓损减边。唯于诸行安立生灭。是名中道远离二边。是故若能如是记别。为善记别。如来所赞。或复有言。何因缘故乃于沙门乔答摩所修习梵行。若得此问应如前说。远离增益损减二边。依中道记名不乱记。若谓有情修习染净。是名一边。谓增益边。若谓一切都无修习。是第二边。谓损减边。若为诸行厌离欲灭而修习者。是名中道远离二边。是故此记名不乱记。名为善记。当知此记诸佛所赞

复次法有二种。一者有为。二者无为。此中有为是无常性。三有为相施设可得。一生。二灭。三住异性。如是三相依二种行流转安立。一依生身展转流转。二依刹那展转流转。依初流转者。谓于彼彼有情众同分中。初生名生。终没名灭。于二中间婴孩等位立住异性。乃至寿住说名为住。诸位后后转变差别。名住异性。依后流转者。谓彼诸行刹那刹那新新而生。说名为生。生刹那后不住名灭。唯生刹那住故名住。异性有二。一异性异性。二转变异性。异性异性者。谓诸行相似相续而转。转变异性者。谓不相似相续而转。非此异性离住相外别体可得。是故二种总摄为一。施设一相。与此相违应知常住无为三相

复次应知修集涅槃资粮略有三障。一者依广事业财宝具足多行放逸。二者无善知识方便晓喻。三者未闻正法未得正法。忽遇死缘非时夭没。与此相违当知无障。亦有三种。又诸圣者将欲终时。略有二种圣者之相。谓临终时诸根澄净蒙佛所记。由三种相佛为过世一切圣者记别。圣性种性。满故但记物类。我已了知法及随法者。法谓正见前行圣道言。随法者。谓依彼法听闻他音如理作意。又我未曾恼乱正法所依处者。谓为此义如来告命。及为此义有所宣说。乃至为令诸漏永尽。彼由此故已得尽漏。

复次诸佛如来略有二种甚希奇法。谓未信者令信。已信者令增长。速于圣教令得悟入。谓大师相。或法教相。或已证得第一德相。普于十方美妙声称广大赞颂无不遍满。又能除遣说无因论及恶因论。摄受一切说正因论。所以者何。说无因论及恶因论。尚非欲往人天善趣及乐解脱诸聪慧者胜解依处。况是其余。当所趣入说正因论。当知其相与彼相违。大师相者。谓薄伽梵是真如来应正等觉乃至世尊。广释如前摄异门分。法教相者。谓说正法初中后善。乃至广说。当知亦如摄异门分。证得第一德相者。谓于一切此世他世自然通达。现等正觉。乃至广说。此中欲界说名此世。色无色界名为他世。现在过去二世别故。当知是名第二差别。不由师故说名自然。六种通慧现所得故。名为作证。于诸有情最第一故。说名圆满。此第一性自然知故。显示他故说名开示

复次由二种相。无因论者。于诸行中执无因转。谓于诸行生起因缘灭尽因缘。不了知故。由此生故彼诸行生。由此灭故彼诸行灭。于此二事不能证得。又不证得诸行性相。起如是见。立如是论。有者定有。无者定无。无不可生。有不可灭。即此论者于三位中现可证得诸行生灭一切世间共所了达粗浅现量毁谤违逆。何以故。现见彼彼若刹帝利或婆罗门吠舍等家所有男女和合因缘。或过八月或九月已便生男女。如是生已或有一类。当于尔时寿尽中夭。复有一类乃至住寿存活支持。或苦或乐或非苦乐受位差别心诸心法。皆是新新而非古古

复次略有二种自赞毁他。谓唯语言及说法正行。若唯语言而自称赞毁呰他者。彼但由于非善士法缠扰其心。是名自毁。非胜贤善。若由说法行正行者。虽无赞毁而是真实自赞毁他。又诸如来宣说正法。速能坏灭二种无智。谓闻不正法生胜解等。长时积习坚固无智及非久习近生无智。复由俱生不能了知往善趣道。亦不了知能往现法涅槃道故

复次当知十一种相总摄诸行立为行聚。应知聚义是其蕴义。又由一向杂染因缘增上力故。建立取蕴。当知取蕴唯是有漏。又由杂染清净因缘二增上力。建立总蕴。当知此蕴通漏无漏。又由三相于诸行中烦恼生起。谓所依故。所缘故。助伴故

复次嗢拖南曰

  少欲自性等记三　　似正法疑痴处所
  不记变坏大师记　　三见满外愚相等

由三种相如来心入少欲住中。一由尔时化事究竟。为欲安住现法乐住。二由弟子于正行门深可厌薄。三为化导常乐营为多事多业所化有情。又如前说如来入于寂静天住一切因缘。当知此中亦复如是

复次诸所化者略有三种所调伏性。一愚痴放逸性。二极下劣心性。三能修正行性

复次由四种相于四处所。生恭敬住速证无上。一于所应得生猛利乐欲故。二于得方便法随法行生猛利爱乐故。三于大师所生猛利爱敬故。四于所说法生猛利净信故

复次有三种无上。谓妙智无上。正行无上。解脱无上。妙智无上者。谓尽智。无生智。无学正见智。正行无上者。谓乐速通行。解脱无上者。谓不动心解脱。当知此中总说智断现法乐住。有学妙智正行解脱。不名无上。犹有上故。当知一切阿罗汉行。皆得名为乐速通行。一切粗重永灭故。一切所作已办故

复次依菩提分择诸行故。于二时中由四种相。如实遍知萨迦耶见。即于二时无间证得诸漏永尽。云何二时。一在异生地。二在见地。云何由四种相。一由自性故。二由处所故。三由等起故。四由果故。自性故者。谓诸行自性萨迦耶见及五种行。彼计为我或为我所。处所故者。谓所缘境。等起故者。谓见取所摄无明。触生受为缘爱。此复有五缘起次第。谓界种种性为缘。生触种种性。触种种性为缘生受种种性。受种种性为缘。生爱种种性。爱种种性为缘。生取种种性。夫缘生者体必无常。由果故者。谓于三时萨迦耶见能为障碍。一依无我谛察法忍时。二现观时。三得阿罗汉时。此中一时由彼随眠萨迦耶见增上力故。有惑有疑。由多修习谛察法忍为因缘故。虽于疑惑少能除遣。然于修习谛现观时由意乐故恐于涅槃我当无有。由此随眠萨迦耶见增上力故。于诸行中起邪分别。谓我当断当坏当无。便于涅槃发生断见及无有见。由此因缘于般涅槃。其心退还不乐趣入。彼于异时虽从此过净修其心又于圣谛已得现谛。然谓我能证谛现谛。彼于此慢由随眠故。仍未能离。又时时间由忘念故。观我起慢。因此慢缠差别而转。谓我为胜或等或劣。前两位中由随眠力能作障碍。于第三位由习气力能作障碍。又由三缘诸行生长。一由宿世业烦恼力。二由愿力。三由现在众因缘力。于异生地能遍知故。于见地中无间能得见道所断诸漏永尽。于见地中能遍知故。次断余结得阿罗汉。无间证得诸漏永尽

复次由五种相于诸行中如理问记。何等为五。一自性故。二流转还灭根本故。三还灭故。四流转故。五流转还灭方便故。自性故者。当知色等五种自性。流转还灭根本故者。谓欲。由善法欲乃至能得诸漏永尽。是故此欲名还灭根本。若由是欲愿我当得人中下类。乃至当生梵众天等众同分中。由于此心亲近修习多修习故。得生于彼。是故此欲名流转根本。还灭故者。于诸行中唯欲贪取得断灭故。若即诸行是取性者。应不可灭。以阿罗汉犹有诸行现可得故。若异诸行有取性者。应是无为。无为故常亦不可灭。是故取性但是诸行一分所摄。即此一分已得断灭。毕竟不行故。可还灭。流转故者。复有三种。一后有因故。二品类别故。三现在因故。后有因者。谓如有一愿乐当来造作诸业。彼作是念。愿我来世当成此行。由是因缘能引后有诸行生因。不引现在。彼于现在不能引故。施设诸行唯有二种。品类别者。谓十一种诸行品类。如前应知。现在因者。谓所造色因四大种。受等心法以触为缘。所有诸识名色为缘。流转方便者。谓萨迦耶见为所依故。于诸行中发生我慢及诸爱味我我所见。还灭方便者。谓于诸行远离我慢。及见过患并彼出离无我我所。又流转方便者。谓无明爱品。随其所应当知其相。还灭方便者。谓彼对治。又由二缘诸不聪慧声闻弟子。越大师教堕恶见中。或起言说。何等二缘。一愚世俗谛。二愚胜义谛。由此愚故违越一向世俗谛理。及违越一向胜义谛理。于行流转不正思惟

复次于三种处唯诸圣者随其所乐能如实记。非诸异生。除从他闻。谓诸行中我我所见我非如实。若彼为依有我慢转。彼虽已断。而此我慢一切未断。若无起依。我慢不断如故现行。当知此中二种我慢。一于诸行执着现行。二由失念率尔现行。此中执着现行我慢。圣者已断不复现行。第二我慢由随眠故。萨迦耶见虽复永断。以于圣道未善修故。犹起现行。萨迦耶见唯有习气。常所随逐于失念时。能与我慢作所依止。令暂现行。是故此慢亦名未断亦得现行。又诸圣者若于诸行思惟自相。尚令我慢不复现行。况观共相。若于假法作意思惟。住正念者。亦令我慢不得现行。若于假法作意思惟。不住正念尔时我慢暂得现行。若诸异生虽于诸行思惟共相。尚为我慢乱心相续。况住余位。又萨迦耶见圣相续中随眠与缠皆已断尽。于学位中习气随逐未能永断。若诸我慢随眠与缠皆未能断。又计我欲者当知即是我慢缠摄。何以故。由失念故。于欲于定为诸爱味所漂沦者。依此欲门诸我慢缠数数现起。言未断者。由随眠故。未遍知者。由彼缠故。彼于尔时有忘念故。言未灭者。虽于此缠暂得远离。寻复现行。言未吐者。由彼随眠未永拔故

复次同梵行者于余同梵行所略有二种慰问。一问病苦。二问安乐。问病苦者。如问彼言所受疹疾宁可忍不者。谓问气息无拥滞乎。得支持不者。谓问苦受不至增乎。非无间乎。非不爱触之所触乎。非违虑乎。非笮身乎。或被笮者得除释乎。问安乐者。谓如有一随所问言少病不者。此问不为婴疹恼耶。少恼不者。此问不为外诸灾横所侵逼耶。起居轻利不者。此问夜寐得安善耶。所进饮食易消化耶。有欢乐不者。此问得住无罪触耶。如是等类差别言词。如声闻地于所饮食知量中释。当知此问在四位中。一内逼恼分。二外逼恼分。三住于夜分。四住于昼分

复次若有说言诸阿罗汉于现法中。于食物务蕴界处等。若顺不顺不如实知。言阿罗汉不顺。不顺是不如理虚妄分别。非阿罗汉现法不顺。所以者何。彼于食物务蕴界处等。现可见故。由此因缘诸阿罗汉。于其灭后。不顺诸行不了执着。是故世尊言。阿罗汉是不顺者。定是密语。当知此是似正法见。由二种义势力为缘。诸同梵行或大声闻。为欲断灭如是所生似正法见。极作功用。勿令彼人或自陈说或示于他。由是因缘堕极下趣。或由爱敬如来圣教。勿因如是似正法见令佛圣教速疾隐灭。复有二因。能生如是似正法见。一者于内萨迦耶见未能永断。二者依此妄计流转还灭士夫。为断如是二种因故。说二正法以为对治。谓于诸行次第宣说无常无我。于四句中推求流转还灭士夫。都不可得。谓依有为。或依无为。声闻独觉佛世尊我说名如来。当知此我二种假立。有余依中假立有为。无余依中假立无为。若依胜义非有为非无为。亦非无为非有为。由说如是正法教故。于六种相觉悟生时。当知永断似正法见。谓阿罗汉于依所摄灭坏法故。觉悟无常。于现法中为老病等众苦器故。觉悟是苦。于任运灭。断界。离界。及与灭界。觉悟为灭寂静。清凉。及与永没。若具如是正觉悟者。是阿罗汉邪。增上慢俱行妄想尚不得有。况可如是于其灭后若顺不顺戏论执着。当知未断萨迦耶见有二过患。一于能害有苦诸行。执我我所。由此因缘能感流转生死大苦。二于现法能碍无上圣慧命根。譬如有人自知无力能害怨家。恐彼为害。先相亲附以如意事现承奉之时。彼怨家知亲附已便害其命。愚夫异生亦复如是。恐似怨家萨迦耶见当为苦害。便起爱缚以可意行而现承奉。如是愚痴异生之类。于能为害萨迦耶见。唯见功德不见过失。殷到亲附。既亲附已。由未得退。说名损害圣慧命根。

复次诸外道辈于内法律二种处所疑惑愚痴。何等为二。谓佛世尊诽毁有见及无有见。而于弟子终殁之后。记一有生。记一无生。又说胜义常住之我现法当来都不可得。世有三师而现可得。一常论者。二断论者。三者如来。此疑痴者有二种因。当知如前似正法见二种法教。能断此因。亦如前说由二因缘。即此所说无我法性。彼诸外道难入难了。谓此自性难了知故。虽此相貌易可了知。然其相貌不相似故。当知此中无虚诳义自所证义。是不共义故。彼自性难可悟入。即此自性体是甚深似甚深现。是故说名无虚诳义。又此自性于内难见。从他言音亦难觉了。是故说名自所证义。又此自性非寻思者之所寻思。非度量者所行境界。是故说名是不共义。又即此法微妙审谛聪明智者内所证故。说名难了。此等差别当知如前摄异门分。由二种相。一切如来所说义智。皆应了知。何等为二。一者教智。二者证智。教智者。谓诸异生闻思修所成慧。证智者。谓学无学慧及后所得诸世间慧。此中异生非于一切佛所说义皆能了知。亦非于慢觉察是慢。又未能断。若诸有学非于我见一切义中皆不了知。又能于慢觉察是慢。而未能断。若诸无学能作一切。

复次诸佛如来于世俗谛及胜义谛。皆如实知。正观于彼二种道理不应记别。若记别者能引无义故。不记别亦不执着。谓于灭后若有。若无。亦有亦无。非有非无。若于如来如是智见为先不记。谓无知者当知自显妄见俱行无智之性

复次应知略有二种变坏。一者诸行衰老变坏。谓如有一年百二十其形衰迈。由是因缘名身老病。二者心忧变坏。由是因缘名心老病。第一变坏。若愚若智皆于其中不随所欲。第二变坏。智者于中能随所欲。非诸愚者。又诸愚夫若身老病。当知其心定随老病。其有智者。身虽老病而心自在不随老病。是名此中愚智差别

复次善取法者由闻思故。善思惟者由修慧故。善显了者如所有性故。善通达者尽所有性故。由二种相。诸圣弟子能正请问大师善记。谓于诸取断遍知论。何等为二。一者于此诸取断遍知论。二者为此诸取断遍知论。当知此中于一切行断遍知论。所谓如来。又此诸取若未断灭随观。彼有三种过患。若已断灭随观。彼有三种功德。一者于诸行中所生诸取行。若变坏便生愁等。应知是名第一过患。已得诸行变坏所作。二者于诸行中所生诸取。为得未得可意诸行。于追求时。广行非一种种众多差别不善。由此追求行不善故。住四种苦。一将现前邻近所起。二正现前现在所起。三他逼迫增上所起。四自杂染增上所起。应知是名第二过患。三者即由如是恶不善法爱习为因。身坏死后往诸恶趣。应知是名第三过患。与此相违于诸取断随观三种功德胜利。如应当知

复次当知略有三种圣者三见圆满能超三苦。云何名为三种圣者。一正见具足。谓于无倒法无我忍住异生位者。二已见圣谛。已能趣入正性离生。已入现观。已得至果。住有学位者。三已得最后究竟第一阿罗汉果。住无学位者。云何名为三见圆满。一初圣者随顺无漏有漏见圆满。二未善净无漏见圆满。三善清净无漏见圆满。此三圆满依说三种补特伽罗。随其次第如前应知。云何名为超三种苦。谓初见圆满。能超外道我见违诤所生众苦。第二见圆满。能超一切恶趣众苦。第三见圆满。能超一切后有众苦。此中云何名诸外道我见违诤所生众苦。谓此正法毗奈耶外。所有世间种种异道萨迦耶见以为根本所生一切颠倒见趣。如是一切总称我见。谓我论者我论相应一切见趣。或一切常论者。或一分常论者。或无因论者。或边无边论者。或断灭论者。或现法涅槃论者彼论相应一切见趣。或有情论者彼论相应一切见趣。谓诸邪见拨无一切化生有情。诽谤他世。或命论者彼论相应一切见趣。谓命论者计命即身或异身等。或吉祥论者彼论相应一切见趣。谓观参罗历算卜筮种种邪论。妄计诵咒祠祀火等得所爱境能生吉祥能断无义。又计睹相为祥不祥。彼复云何。谓二十句萨迦耶见为所依止。发起妄计前际后际六十二种诸恶见趣。及起总谤一切邪见。云何违诤所生众苦。谓彼展转见欲相违。互兴诤论。发起种种心忧恼苦。深爱藏苦。互胜劣苦。坚执着苦。当知此中若他所胜便生愁恼。是名初苦。若胜于他遂作方便。令自见品转复增盛。令他见品渐更隐昧。唯我见净非余所见。执着邪见深起爱藏。由此因缘发生种种不正寻思。及起种种不寂静意。损害其心。名第二苦。爱藏邪见增上力故。以他量己。谓已为胜或等或劣。因自高举凌蔑于他。是名第三互胜劣苦。彼依此故追求利养。即为追求苦之所触。凡有所作皆为恼乱。诘责他论。及为自论免脱他难。是名第四坚执着苦。如是四种名见违诤所生众苦。内法异生安住上品无我胜解。当知已断如是众苦。所以者何。彼于当来由意乐故。于如是等诸恶见趣堪能除遣。是故若住初见圆满能超初苦又即依此初见圆满。亲近修习极多修习。于内诸行发生法智。于不现见发生类智。总摄为一聚。以不缘他智而入现观。谓以无常行。或随余一行。彼于尔时能随证得第二见圆满。及能超第二苦。彼住此已。如先所得七觉分法。亲近修习极多修习。能断如前所说四种业等杂染。能随证得后见圆满。超后有苦。此中第一补特伽罗。犹残二苦。及残现在所依身苦。第二补特伽罗。唯残一苦及依身苦。第三补特伽罗。一切苦断。但依身苦暂时余在。譬如幻化。又依分别萨迦耶见立二十句。不依俱生。又内法者无如是行。依遍处定。谓地为我。我即是地。乃至广说。一切应知

复次诸外道辈。略有五种愚夫之相。由彼相故堕愚夫数。谓诸外道性聪慧者。犹尚不免怀聪慧慢。况非聪慧。是名第一愚夫之相。又诸外道多为贪求利养恭敬自赞毁他。是名第二愚夫之相。又诸外道若诸圣者为说正法正教正诫。即便违逆呵骂毁呰。是名第三愚夫之相。又诸外道喜自陈说似正法论。或开示他。是名第四愚夫之相。又诸外道虽为如来如来弟子之所降伏。亦知如来所说法律是真善说。知自法律是妄恶说。然由我慢增上力故。都不信受。乃至不集观察因缘。是名第五愚夫之相

复次如来成就六分。得名无间论师子王。何等为六。所谓最初往诣外道敌论者所。乃至恣其问一切义。凡所兴论非为诤论。唯除哀愍诸有情故。其未信者令彼生信。若已信者令倍增长。又兴论时。诸根寂静形色无变。亦无怖畏习气随逐。又终不为诸天世间之所胜伏。一切世间无敌论者。能越一翻唯说一翻。皆能摧伏。又诸世间极聪慧者。极无畏者。若与如来共兴论时。所有辩才皆悉謇讷。增上怖畏逼切身心。一切矫术虚诈言论。皆不能设。又复一切同一会坐处中大众。皆于佛所起胜他心。于彼外道敌论者所起他胜心。又佛世尊言辞威肃。其敌论者所出言词无有威肃。

复次有二种论。何等为二。一有我论。二无我论。无我论有力。有我论无力。有我论者常为无我论者所伏。唯除论者其力羸劣。云何名为有我论者。谓如有一。起如是见。立如是论。于色等行建立为我。谓我有行。行是我所。我在行中不流不散。遍随支节无所不至。是故色等诸行性我。依诸行田生福非福。因兹领受爱不爱果。譬如农夫依止良田营事农业及与种植药草丛林。是名我论。云何名为无我论者。谓有二种。一破我论。二立无我。破我论者。若计实我能有作用于爱非爱诸果业中得自在者。此我恒时欣乐厌苦。是故此我唯应生福不生非福。又我作用常现在前内外诸行。若变异时。不应发生愁忧悲叹。又我是常以觉为先。凡所生起。常应随转无有变易。然不可得。如是名为破有我论立无我者。以一切行从众缘生。若遇福缘福便生起。与此相违生起非福。由此为缘能招一切爱非爱果。依众缘故皆是无常。唯于如是因果所摄诸行流转。假立我等。若依胜义。一切诸法皆无我等。如是名为立无我论

复次由五种相。有学无学二种差别。谓诸无学所成就智说名无上。一切有学所成就智说名有上。如智无上。当知正行及与解脱无上亦尔。又诸无学以善清净诸圣慧眼观佛法身。有学不尔。又诸无学以善圆满无颠倒行奉事如来。有学不尔。是名五相

瑜伽师地论卷第八十八瑜伽师地论卷第八十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事处择摄第二之一

如是已说行择摄。处择摄我今当说。总嗢拖南曰

  初安立等智同等　　最后当知离欲等

别嗢拖南曰

  安立与差别　　愚不愚教授
  解脱烦恼业　　皆广说应知

由五种相。当知安立诸受差别。一自性故。二所依故。三所缘故。四助伴故。五随转故。自性故者。谓有三受。一苦。二乐。三不苦不乐。所依故者。谓有六种。即眼耳鼻舌身与意。所缘故者。谓色等六所缘境界。助伴故者。谓想思或余善不善无记心法。与此相应。随转故者。谓此相应心由依彼故。三受随转。彼为诸受同生同灭所依止处。

复次如是五相安立诸受。当知复有八种差别。一内处差别。二外处差别。三六识身差别。四六触身差别。五六受身差别。六六想身差别。七六思身差别。八六爱身差别。当知此中由三和合义立前三差别。由受因缘义立第四差别。由三和合触果义立第五差别。由分别受随言说义立第六差别。所以者何。受诸受时作如是想。我今领受此苦此乐此非苦乐。亦复为他随起言说。由业烦恼二杂染义。当知建立第七第八两种差别。所以者何。由于彼受若合若离起思造作。如如发起思所造作。如是如是生爱求愿。

复次当知略有二种一切。一少分一切。二一切一切。如说一切皆无常者。当知此依少分一切。唯一切行非无为故。言一切法皆无我者。当知此依一切一切。又由三相应知是愚。一由自性故。二由因缘故。三由果故。愚自性故者。谓由缠故即是忘失。于现在世由随眠故即是当来忘失之法。愚因缘故者。谓于五相受安立中。不能觉了是无常等。及遍自体初中后位所有恼乱皆不了故。当知即是于生老病及死法性不能觉了。初恼乱者。谓由生故。中恼乱者。谓由病故。后恼乱者。谓由老死二种法故。愚果故者。谓愁等苦爱等杂染。

复次由三种相当知不愚。一自性故。二由碍故。三由障故。不愚自性者。谓于五相受安立中。善能觉了自相共相。由此能断一切烦恼。能觉圣谛。能证涅槃。不愚碍者。由四种魔。谓由蕴魔遍一切处随逐义故。由彼天魔于时时间能数任持障碍义故。死烦恼魔能与死生所生众苦作器义故。不愚障者。谓缘不现见境烦恼。及缘非不现见境缠。或彼随眠

复次诸佛世尊佛圣弟子。由三种相能正教授诸弟子众。何等为三。一引导教授。二随其所应于所缘境安处教授。三令所化得自义教授。如是教授如其次第。当知即是三种神变

复次由二种相应求能成就解脱妙慧。一者如理闻思。久远相续慧。能成就有学解脱。二者有学久远相续慧。能成就无学解脱

复次略有二种解脱成就。一者有学。二者无学。有学者。谓金刚喻三摩地俱。无学者。谓彼已上

复次心清净行苾刍有五种法多有所作。何等为五。一正教授。二奢摩他支。三毗钵舍那支。四无间殷重加行。五出世间慧。正教授者。谓有三种正友所显。一者大师。二者轨范尊重。三者同梵行者及住内法在家英睿。如是名为三种正友。诸有智者从彼应求积集善门真正教授。奢摩他支者。谓如有一。具尸罗住。广说应知如声闻地。如是尸罗具足住已。便无有悔。无悔故欢。广说乃至乐故心定。毗钵舍那支者。谓得三种随欲言教。一圣正言教。二厌离言教。三令心离盖趣爱言教。云何圣正言教。谓依众圣五无学蕴所有言教。即是宣说诸圣成就如是戒。如是定。如是慧。如是解脱。如是解脱智见。云何厌离言教。谓依三种令增少欲喜足言教。及依乐断乐修令离愦闹言教。云何令心离盖趣爱言教。当知此教复有三门。一者一切烦恼盖离盖趣爱言教。二者五盖离盖趣爱言教。三者无明盖离盖趣爱言教。当知此中依为证得断离灭界所有言说。是初言教。依即于彼见胜功德。及于所治盖处诸行深见过患所有言说。当知是名第二言教。随顺如是缘性缘起所有言说。当知是名第三言教。如是三种言教。总名毗钵舍那支。又此言教以略言之复有三种。一能生乐欲言教。二能正安处资粮言教。三能正安处作意言教。谓圣正言教名能生乐欲言教。厌离言教名正安处资粮言教。令心离盖趣爱言教名正安处作意言教。依此言教胜奢摩他所摄受慧。名毗钵舍那。是故说此言教。名毗钵舍那支。云何无间殷重加行。谓常所作。委悉所作。勤精进住。当知即依止观加行。又勤精进应知五种。一被甲精进。二加行精进。三不下精进。四无动精进。五无喜足精进。此中最初当知发起猛利乐欲。次随所欲发起坚固勇悍方便。次为证得所受诸法。不自轻蔑亦无怯惧。次能堪忍寒热等苦。后于下劣不生喜足。欣求后后转胜转妙诸功德住。彼由如是勤精进住入谛现观。证得诸圣出世间慧。于修道中依止此慧。若行若住。能正除遣所依身中诸随烦恼。令心清净。谓住聚落或聚落边。若见少壮端严美妙形色母邑。即便作意思惟不净。为欲损害缘彼贪故。若遇他人逼迫恼乱。即便作意思惟慈相。为欲损害缘彼嗔故。如是行时能正除遣诸随烦恼。令心清净。若远离处修习入出二种息念。除遣欲等诸恶寻思。如是住时能正除遣诸随烦恼。令心清净。彼依如是已所证得出世间慧。于一切行修无常想。能正蠲除所余我慢。如是善士为所依止。复得无倒教授前行。由此渐次能证有学圆满解脱。得金刚喻三摩地故。亦证无学圆满解脱。一切烦恼皆离系故

云何解脱。谓起毕竟断对治故。一切烦恼品类粗重永息灭故。证得转依令诸烦恼决定究竟成不生法。是名解脱。若圣弟子无所有处已得离欲。唯余非想非非想处所有诸行。复能安住胜有顶定。尔时无间能随证得诸漏永尽。若所余位虽能渐断彼彼诸漏。然非无间能随证得诸漏永尽。如是乃至无所有处未得离欲

复次诸欲界系一切烦恼。唯除无明说名欲漏。诸色无色二界所系一切烦恼。唯除无明说名有漏。若诸有情。或未离欲。或已离欲。除诸外道所有邪僻分别愚痴所生恶见蔽覆其心。依此恶见于彼诸欲。一分寻求。一分离欲。乃至非想非非想处。于彼三界所有无智。总摄为一。立无明漏

复次有九种事能和合故。当知建立九结差别。云何九事。一依在家品可爱有情非有情数一切境界贪爱缠事。二即依此品可恶有情非有情数一切境界嗔恚缠事。三依有情数憍慢缠事。若四五六依恶说法诸出家品三种邪僻胜解缠事。谓依听闻不正法故。依不如理邪思惟故。依非方便所摄修故。如是差别即为三种。七于善说法律无胜解缠事。八依出家品智贫穷事。九依在家品财贫穷事。由此九事如其所应当知配属爱等九结。此中由嫉变坏心故。于正法内发起法悭。由此当来智慧贫乏。余随所应配属应知

复次由为贪缚所缠缚故。于能随顺乐受境界心不能舍。如是嗔缚所缠缚故。于能随顺苦受境界心不能舍。由愚痴缚所缠缚故。于能随顺非苦乐受中庸境界心不能舍。由此因缘故立三缚

复次烦恼品所有粗重随附依身。说名随眠。能为种子生起一切烦恼缠故。当知此复建立七种。由未离欲品差别故。由已离欲品差别故。由二俱品差别故。由未离欲品差别故。建立欲贪嗔恚随眠。由已离欲品差别故。建立有贪随眠。由二俱品差别故。建立慢无明见疑随眠。如是总摄一切烦恼

复次随烦恼者。谓贪不善根。嗔不善根。痴不善根。若忿若恨。如是广说诸杂秽事。当知此中能起一切不善法贪。名贪不善根。嗔痴亦尔。若嗔恚缠能令面貌惨裂奋发。说名为忿。内怀怨结故名为恨。隐藏众恶故名为覆。染污惊惶故名热恼。心怀染污不喜他荣故名为嫉。于资生具深怀鄙吝。故名为悭。为欺誷彼内怀异谋外现别相故。名为诳心。不正直。不明不显。解行邪曲。故名为谄。于所作罪望己不羞故。名无惭。于所作罪望他不耻故。名无愧。于他下劣谓己为胜。或复于等谓己为等。令心高举故名为慢。于等谓胜于胜谓等。令心高举故名过慢。于胜谓胜令心高举名慢过慢。妄观诸行为我我所。令心高举故名我慢。于其殊胜所证法中未得谓得。令心高举。名增上慢。于多胜中谓己少劣。令心高举。名下劣慢。实无其德谓己有德。令心高举故名邪慢。心怀染污随恃荣誉形相疏诞故。名为憍。于诸善品不乐勤修。于诸恶法心无防护故。名放逸。于诸尊重及以福田心不谦敬。说名为傲。若烦恼缠能令发起。执持刀仗斗讼违诤故名愤。发心怀染污为显己德假现威仪故。名为矫。心怀染污。为显己德。或现亲事。或行软语故。名为诈。心怀染污欲有所求矫示形仪故。名现相。现行遮逼有所乞丐故。名研求。于所得利不生喜足。说获他利更求胜利。是故说名以利求利。自现己德远离谦恭。于可尊重而不尊重故。名不敬。于不顺言性不堪忍故。名恶说。诸有朋畴引导令作非利益事。名为恶友。耽着财利显不实德欲令他知故。名恶欲。于大人所欲求广大利养恭敬故。名大欲。怀染污心显不实德。欲令他知名自希欲。于骂反骂。名为不忍。于嗔反嗔。于打反打。于弄反弄。当知亦尔。于自诸欲深生贪爱。名为耽嗜。于他诸欲深生贪着。名遍耽嗜。于胜于劣随其所应。当知亦尔。于诸境界深起耽着。说名为贪。于诸恶行深生耽着。名非法贪。于自父母等诸财宝不正受用。名为执着。于他委寄所有财物规欲抵拒故。名恶贪。妄观诸行为我我所。或分别起或是俱生。说名为见。萨迦耶见为所依止。于诸行中发起常见。名为有见。发起断见名无有见。当知五盖如前定地已说。其相不如所欲。非时睡缠之所随缚故。名[夢-夕+登]瞢。非处思慕说名不乐。粗重刚强心不调柔。举身舒布故曰频申。于所饮食不善通达。若过若减。是故名为食不知量。于所应作而便不作。非所应作而更反作。如所闻思修习法中。放逸为先不起功用。名不作意。于所缘境深生系缚。犹如美睡隐翳其心。是故说名不应理。转自轻蔑故。名心下劣。为性恼他故。名抵突。性好讥嫌故。名諀訿。欺诳师长尊重福田及同法者。名不纯直。身语二业皆悉高疏其心刚劲又不清洁。名不和软。于诸戒见轨则正命皆不同分。名不随顺。同分而转心怀爱染。攀缘诸欲。起发意言。随顺随转。名欲寻思。心怀憎恶。于他攀缘不饶益相。起发意言。随顺随转。名恚寻思。心怀损恼。于他攀缘恼乱之相。起发意言。余如前说。名害寻思。心怀染污。攀缘亲戚起发意言。余如前说。是故说名亲里寻思。心怀染污。攀缘国土起发意言。余如前说。是故说名国土寻思。心怀染污。攀缘自义推托迁延。后时望得起发意言。余如前说。是故说名不死寻思。心怀染污。攀缘自他若劣若胜起发意言。余如前说。是名轻蔑相应寻思。心怀染污。攀缘施主往还家势。起发意言。随顺随转。是名家势相应寻思。愁叹等事如前应知

复次一切烦恼皆有其缠。由现行者悉名缠故。然有八种诸随烦恼。于四时中数数现行。是故唯立八种为缠。谓于修学增上戒时。无惭无愧数数现行能为障碍。若于修学增上心时。惛沉睡眠数数现行能为障碍。若于修学增上慧时。简择法故掉举恶作数数现行能为障碍。若同法者展转受用财及法时。嫉妒悭吝数数现行能为障碍

复次欲贪嗔等欲界所系烦恼。行者欲界所系上品烦恼未断未知。名欲暴流。有见无明三种暴流。如其所应当知亦尔。谓于欲界未得离欲。除诸外道名欲暴流。已得离欲名有暴流。若诸外道从多论门。当知有余二种暴流。谓诸恶见略摄为一。名见暴流。恶见因缘略摄为一。说名第四无明暴流

复次若诸烦恼等分行者非增非减。即上所说一切烦恼。说名为轭

复次当知依于二品建立四取。一在家品。二外道法中诸出家品。当知此中若所取。若能取。若所为取。如是一切总说为取。问何所取。答欲见戒禁我语是所取。问何能取。答四种欲贪是能取。问何所为取。答为得诸欲及为受用故起初取。由贪利养及以恭敬增上力故。或为诘责他所立论。或为免脱他所征难。起第二取。奢摩他支为所依止。为所建立。为欲往趣世间离欲乃至非想非非想处三摩钵底。起第三取。为欲随说分别所计作业受果所有士夫。及为随说流转还灭士夫之相。起我语取。如是四取依于二品。谓受用欲诸在家品。及恶说法毗奈耶中诸出家品。由佛世尊每自称言我为诸取遍知永断正论大师故。于此法誓修行者。虽带烦恼身坏命终。而不于彼建立诸取。所以者何。彼于诸欲无所顾恋而出家故。于见戒禁及以我语无执受故。恶说法者有二差别。一于见爱展转发起怨诤论者。二能证入世间定者。依于见爱展转发起怨诤论者。建立见取。依能证入世间定者立戒禁取。二品为依执着我语故。依俱品立我语取。此中见者。谓六十二。如前应知。邪分别见之所受持身护语护。说名为戒。随此所受形服饮食威仪行相。说名为禁。谛故住故论说有我。名为我语。执有实物。说名谛故。执可安立。说名住故。又于此中欲爱为缘建立欲取。依止智论利养恭敬等爱为缘建立见取。定爱为缘立戒禁取。有无有爱为缘立我语取

复次当知四系唯依外道差别建立。如前应知。复次违背五处。当知建立五盖差别。一为在家诸欲境界所漂沦故。违背圣教立贪欲盖。二不堪忍诸同法者。呵谏驱摈教诫等故。违背所有可爱乐法立嗔恚盖。三由违背奢摩他故。立惛沉睡眠盖。四由违背毗钵舍那故。立掉举恶作盖。五由违背于法论议无倒决择审察诸法大师圣教涅槃胜解故。建立疑盖

复次若贪嗔痴缠所缠故。或彼随眠所随眠故。心不调柔。心极愚昧于得自义能作衰损故。名株杌

复次于弊下境所起贪欲。名为贪垢。于不应嗔所缘境事所起嗔恚。名为嗔垢。于极显现愚痴众生尚能了事所起愚痴。名为痴垢

复次若贪嗔痴数数现行恒常流溢。烧恼身心极为衰损。说名烧害

复次若贪嗔痴远离惭愧。无惭愧故一向无间。不可制伏定为伤损。说名为箭。复次若贪嗔痴惭愧间杂。由相续故。非刹那故。有可制伏。说名所有。是系所摄。极下秽义

复次一切不善身业。名为恶行。如说身业。语业意业当知亦尔。由此恶业数现行故。于诸恶趣。或已随得。或当随得。或现随得。是故说彼名为恶行。由此示现业杂染义。烦恼杂染前已显了

复次有二安立业杂染论。一者邪论。二者正论。言邪论者。谓如是说。若有故思。凡所造作诸不善业。一切决定当受恶趣。此论便谤修行梵行能证涅槃。何以故。诸有情类不易可得于现法中无有故思造不善业。况在余生。若彼决定感恶趣者。便应无有解脱可得。是故当知。此为邪论。若如是说。诸有故思造不善业。此业亦作亦增长者。定于当来受不可爱恶趣异熟。若有虽作不增长者。彼彼法受为依止故。诸所造作或乐或苦。当于造时于现法中。此业决定或顺乐受或顺苦受。诸有造作如是业已。若无追悔不修对治补特伽罗。彼于此业。若更增长若不增长。此业虽定顺现法受。亦转令成顺恶趣受。于现法中能障解脱。诸有造作如是业已。若生追悔修习对治补特伽罗。彼于此业。若不增长。若更增长。此业虽是顺恶趣受。亦转令成顺现法受。不障解脱。是故此论不名诽谤修习梵行能证涅槃。当知此论是为正论

复次若有阙于十种对治。为业杂染之所染污。若有会遇如是十种。便得清净。一者若由如是对治。虽有作业而无增长。彼望当来成不定受。二者若由如是对治。虽未永断而更不受。三者若由如是对治。永断离系。四者守护诸根门故善修其身。为欲修习增上戒学。五者修习增上戒已。为欲修习增上心学。六者修习增上心已。为欲修习增上慧学。七者修习增上慧已。为断诸漏。八者猛利意乐修习。九者长时修习。十者无量门对治修习。若有不会如是十种业对治者。为业杂染之所染污。与此相违。当知清净

复次于现法中不善防护身语意业而住者。彼先造作恶不善业。亦令增长。于当来世令其杂染。若善防护身语意业而住者。彼不杂染。云何于现法中不善防护身语意业而住。云何善防护身语意业而住。不善防护身语意业而住者。谓如有一。于诸不善身语意业缠所发起。能誓远离。然于能起不正作意。相应无明犹故发起。又于诸善身语意业受学随转。由此因缘。于现法中于诸烦恼邪欲寻求所作众苦。无有差别。彼唯即于此誓受远离。便生喜足。于现法中。不起圣道。不证涅槃。彼虽如是防护而住。于现法中暂时不作恶不善业。然为烦恼随眠缠缚。既终没已后有续生。随所受身。依先业缘广起杂染。若善防护身语意业而住者。有此差别。谓此依彼誓受远离不造新业故。业虽熟暂触异熟寻能变吐。彼唯于此誓受远离不生喜足。于现法中能起圣道。亦能证得彼果涅槃。彼于尔时乃至有识身相续住。恒受先业所感诸受。于现法中彼有识身乃至寿量未灭尽位常相续住。寿量若尽舍有识身。于后命根更不成就。由是因缘。识与一切诸受俱灭后不相续。彼如影受与其识树皆灭尽故。遍于一切不可施设。彼于尔时由二因缘。先所作业于当来世不能为染。一由烦恼为其助伴令杂染者。无余断故。二由依此诸行相续成熟。杂染无余灭故。彼于尔时诸有情所善友意乐相续转故。名无怨心。于彼所缘嗔恚断故。名无恚心。于业异熟深见过患增上缘力誓远离故。名无染心。已具获得能对治彼诸圣道故。名无颠倒善解脱心。彼由如是能具证得六种恒住。若有于彼多所住者。于现法中虽有种种诸恶不善业缘间杂。由此远离一向成善。由是因缘。当知此与先防护住有其差别

复次当知施设领受业异熟论。由五种相成其杂染。由五种相成不杂染。云何名为由五种相成其杂染。谓由施设恶因论故。亦由施设无因论故。及由施设恶因无因有三过故。此中施设恶因论者。谓如有一。起如是见。立如是论。若有士夫补特伽罗。诸所领受一切皆是宿因所作。如是或谓自在变化等因所作。施设无因论者。谓如有一。起如是见。立如是论。若有士夫补特伽罗。诸所领受。当知一切无因无缘。云何施设恶因无因。有三种过。谓现法中不善俱行不善诸受。宿世业为因亦有过失。现法业为因亦有过失。若言此受宿世恶业以为因者。是则有一依于不善诸乐法受。而有其乐不善受生。此用宿世诸不善业以为因生。不应道理。何以故。非彼宿世诸不善业于现法中感乐异熟应正道理。若言此受用现法中恶业为因。是则退失自意所立诸恶因论及无因论。谓诸所受皆宿因作。乃至广说。是名初过。又若说言诸不善法皆用宿世恶业为因。是则决定所有善法亦用宿世善法为因。如是所有不善对治。诸善加行。俱生精进。皆成无用。如是名为第二过失。又若现在无有士用。是则应无依善不善。审正观察是所应作所不应作。又如实智应成无用。谓了知已此我应转。此我应成。彼非有故。此亦非有故。如实智理不成就。智不成故念不安住。念不住故无三摩地。无有定故。不正寻思令心迷乱。心迷乱故。便应欣慕愚夫同意所乐诸根。由彼获得愚夫同意所乐法故。是则退失并沙门法及沙门论。如是名为第三过失。若略说此有三种过。谓现在世诸不善受因不成过。谤精进过。谤正智过。云何施设领受一切业异熟论。由五种相成不杂染。谓若能领受者。若由此领受。若如是领受。若领受时。如是杂染如是清净。当知此中依五取蕴施设假名补特伽罗为领受者。即此假者由六触处故能领受。于母胎中四种差别。谓依精血大种所造诸业烦恼之所摄受。结生相续有取之识及母腹中所有孔穴。由如是故得入母胎。次有名色。次有六处。次触次受。如是次第而有领受。又即此受亦用现在触为其因。亦用宿世业等为因。彼若听闻诸不正法非理作意以为因缘。便触无明。触所生受。受为缘故复生于爱。爱为缘故复生于取。乃至当来生老死等众苦差别。如是领受诸无明触所生受时。便有杂染所摄二谛。与此相违。听闻正法如理作意为因缘故。便能领受明触所生诸受差别。受此受时便有清净所摄二谛

复次当知施设邪业清净及邪行中。有二过患。何等为二。一内证稽留过患。二他所讥毁过患。云何施设邪业清净。谓如有一。实非大师。妄分别己自称大师。宣说如是邪施设论。谓现法中诸所受苦。一切皆是宿因所作。彼见宿世诸不善业。为二种因。谓现法中诸不善业。皆是宿业串习所引。诸所受苦亦是彼业之所造作。由是因缘修自苦行。令故恶业所招苦果皆悉变吐。更不造作当不善业。于现法中又能防护身语意住。后当勤修一向善业。令不善法转成非漏。由此因缘不善业尽。由彼尽故众苦亦尽。证苦边际。云何邪行。谓如有一。不能了知自业杂染。不能了知彼业对治。又于前后所证差别不如实知。彼成如是愚痴法故。于其师所得无根信。于非信处妄生真实圣教胜解。彼由坠堕非实非理邪论。朋党他回动时于可疑处而不生疑。不寻求师躬往请问。为能正记为不能记。为能净疑为不能净。为一切智非一切智。大师去世。于所疑处毕竟随转。何以故。大师住世。能为决了此一切智非一切智。大师灭后。何所请问云何决了。是名邪行。何缘应知如是施设令业清净。不应道理。由二缘故。谓彼苦行宿因所作不应理故。由此能尽宿不善业不应理故。所以者何。软中上品自苦行缘所逼切时。软中上品苦受生。故即此三品逼缘远离。由所逼切三品苦受不得生故。宿因所作不应道理。又此苦行无有功能。令宿所作能感苦受。诸不善业成顺乐受。是故彼起如是定见。由自苦行令宿所作恶业变吐。若有是事。彼宿所作能顺苦受诸不善业。为能感得于现法中自苦逼切苦受果不。若言感得此苦受果。修自苦行即为唐捐。受彼果已自然变吐。若如是者。宿世所作诸不善业。非自苦行所能变吐。又即此业一分可吐。谓现法中受彼果者。若余能顺后所受业。彼于后世当受其果。非自苦行可令其果悉皆变吐。若言现在逼切苦受非宿因作。如是所说诸所领受一切。皆是宿因所作。不应道理。如能随顺苦受恶业。不可令其成顺乐受。如是宿世所作能顺乐受善业。不可令其成顺不苦不乐受业。或彼二种顺现法受。不可令其成顺后受。若顺后受不可令其成无所受。若未成熟不可令熟。若已成熟不可彼彼方便令转。此中所说要略义者。所谓一切善不善业自性决定。时分决定。品类决定。若如是者随业决定。必能摄受如是类果。于中更自受逼切苦。复何所用。又若此受宿业因感。彼自所许令业一分减尽。可得少分胜利。由是因缘如此所计少分胜利亦无所有。如是则为极自稽留业所缚故。终无解脱。由此道理是名于此邪论邪行第一过患。谓于内证自义稽留。云何他所讥毁过患。谓彼依止二种邪论。发起三种自苦恼行。若作是说。所有士夫补特伽罗诸所领受一切。皆是宿因所作。是名第一邪论。谓恶因论。复有说言。如彼最初自在变化。从是已后诸所领受一切皆是宿业所作。是名第二邪论。谓恶因论。三种自苦行者。谓身语意护。身护者。谓不以身与余有情共相杂住。唯往山林阿练若处。独居闲静。都无所见而修苦行。语护者。谓彼受持默无言禁。意护者。谓心忍受自逼切苦。彼起如是欲乐言说为他显示。由此二种所见圆满。及由三种苦行圆满。能越众苦。然其自苦不能越度。是故为他之所讥毁。若诸所受一切皆是宿因所作。亦是自在变化因作。亦是三种苦行能越因之所作。是则三种修苦行。俱所受众苦定是宿世黑业所感。亦是暴恶自在所化。三种苦行皆不能越。是故于今受斯苦受。若彼虽复内证稽留。而有为他所称赞者犹尚不可。况此为他称赞。胜利亦无所有。是故名为第二过患。由此分故唯可讥毁。复次与上相违。当知施设正业染净及正行中。有二胜利。一者内证无滞胜利。二者他所称赞胜利。云何施设业杂染论。谓有二业。一者善业。二不善业。于过去世已曾造作善不善业。今现法中受爱非爱异熟果等。受爱非爱果差别时。更复造作善不善业。由此当来受爱非爱异熟果等。如是名为业杂染论。云何施设业清净论。谓如有一。不造新业故。业触已寻复变吐。由对治力永断无余故。得清净。如是名为令杂染业得清净论。如是施设正业染净。名无上论。云何正行。谓如有一。于正法中成就多闻。于业杂染及以清净。正知杂染清净相已。舍不善业修习善业。彼于闻思如理作意。勤方便已为证修故。住空闲处。净修治心。令离诸盖及众苦法。为欲断除贪欲嗔恚掉举恶作。以九种行安住其心。令心弃舍止所对治。为欲断除惛沉睡眠及以疑盖。分析六事如理作意。修饰其心。令心弃舍观所对治。从彼止观所治出已。能正修学消伏众苦。彼既如是净修其心。令离诸盖众苦法已。复于衣服饮食卧具受用仪则。净修其心。若由习近如是衣服乃至卧具。不善法增。善法退减。即便远离。宁可受用。粗弊衣等惙尔。自存忍受众苦。进修正行。又由二缘受用胜妙衣服等。因能令生长恶不善法。谓诸妄想不正寻思。何等二缘。一于诸善未能长时串修习故。心不调柔。二于衣服饮食等事欲贪坚着。由是因缘修正行者。调柔其心。令堪所作。于衣服等欲贪坚着。及诸无常众缘生法。恒常系念深见过患。尔时虽复受用胜妙衣服等事。而于其中无所杂染。如是行者亦受安乐。亦无有罪。由奢摩他毗钵舍那修习力故。净修其心。离诸盖已。由思择力于衣服等邪受用故。虽于尔时暂少成就心一境性。欲贪随眠仍未断故。于当来世复为杂染。彼以妙慧通达是已。便修加行。为毕竟断。受用如法边际卧具。离诸贪着。先善修治正定资粮。渐次乃至能入清净第四静虑。以此为依。证谛现观。随得漏尽心善解脱。于一切苦得离系故。究竟寂静所摄受故。微妙清净一切身心无间满故。一切烦恼永离系故。普能领纳诸无漏受。是名正行。如是应知。内证无滞。及彼相违五种差别他所称赞。彼于尔时从诸盖缠及一切苦。心善解脱。于现法中彼诸随眠无余永断。前际后际业。及异熟所有杂染皆善解脱。由于现法获得圣道及道果故

复次略有三种补特伽罗。一者未入圣教异生。二者已入圣教有学。三者已入圣教异生。由三种相。应知最初补特伽罗。第二第三当知亦尔。云何三相应知最初补特伽罗。谓初有一补特伽罗。已得成就世间正见。了知有施。乃至广说。彼于异时闻不正法。为因缘故。而便发起非理作意。世间正见临将欲灭。虽未一切悉皆已灭。而堪能灭。又彼所治诽谤邪见临将欲生。虽未已生。而堪能生。彼于中间听闻正法。为因缘故。遂还发生如理作意。彼临欲生诽谤邪见不现行故。说名为断。然其正见先成就故。不名为生。第二有一补特伽罗。不成正见及以邪见。听闻正法如理作意。为因缘故。尔乃发生世间正见。彼于邪见不名为断。先不成故。第三有一补特伽罗。成就邪见听闻正法。如理作意为因缘故。断灭邪见。生起正见。云何三相应知第二补特伽罗。谓于佛等已得证净。彼于佛等先所现起一切无智。当于诸谛得现观时先已断尽。是故于今不名为断。而于佛等证净俱行明现前故。说名为生。即以学道断修所断余品无明。而于其明不名生起。此道与先种类同故。彼无学道将现在前。修断无明皆悉灭尽。又能生起诸无学明。云何三相应知第三补特伽罗。谓闻无我相应正法。初但由闻发生信解。而未悟入。彼于无我生信解故。能断我见。未悟入故。不得名为生无我见。如所闻法。复能如理正思惟时。于无我理能悟入故。乃得名为生无我见。于彼随眠而未能断。从此已后由修道力。证谛现观。方断随眠。发生无漏

瑜伽师地论卷第八十九瑜伽师地论卷第九十

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事处择摄第二之二

复次嗢拖南曰

  五二与十三　　四业为最后

有二种业。一者重业。二者轻业。复有二业。一者增进业。二者不增进业。复有二业。一者故思所造业。二者非故思所造业。复有二业。一者定所受业。二者不定所受业。复有二业。一者异熟已熟业。二者异熟未熟业

有三种业。谓善业。不善业。无记业。复有三业。谓顺乐受业。顺苦受业。顺不苦不乐受业。复有三业。谓顺现法受业。顺生受业。顺后受业。复有三业。谓学业。无学业。非学非无学业。复有三业。谓见所断业。修所断业。无断业。复有三业。谓三曲业。即身曲等。复有三业。谓三秽业。即身秽等。复有三业。谓三浊业。即身浊等。复有三业。谓三净业。即身净等。复有三业。谓三默然业。即身默然等

有四种业。一黑黑异熟业。二白白异熟业。三黑白黑白异熟业。四不黑不白无异熟业。能尽诸业。当知此中由三因缘令业成重。一由意乐故。二由加行故。三由田故。由意乐者。谓由猛利缠等所作。于同法者见已欢喜。于彼随法多随寻思。多随伺察。如是名为由意乐故令业成重。由加行者。谓于彼业无间所作。殷重所作。长时积集。又于其中劝他令作。又即于彼称扬赞叹。如是名为由加行故令业成重。由田故者。谓诸有情于己有恩。若住正行及正行果。于彼发起善作恶作。当知此业说名为重。与彼相违。说名为轻。若业非是明了所作。或梦中作。或由无覆无记所作。或不善作。寻复追悔对治摄受。又于一切清净相续所有诸业。如是皆名不增进业。当知异此名增进业。此中故思所造业者。谓先思量已。随寻思已。随伺察已。而有所作。复或错乱。或不错乱。其错乱者。谓于余处思欲杀害。或欲劫盗。或欲别离。或欲妄语及欺诳等。如是思已。即以此想别处成办。当知此中由意乐故。说名为重。不由事故说名为重。不错乱者。当知其相与此相违。若异此业。是即名为非故思造。定受业者。谓故思所起重业。不定受业者。谓故思所造轻业。异熟已熟业者。谓已与果业异熟。未熟业者。与此相违。若欲证得阿罗汉时。先所造作决定受业。由异熟果现在前故。能为障碍。不由随逐身相续故。所以者何。但由彼业。生不平等所依身故。能为障碍。令不能得阿罗汉果。若无生受而有后受。于所证得阿罗汉果。不能为障。然彼非不是定受业。何以故。由即依彼烦恼助伴及即依彼诸行相续。施设此业为定受故

复次由二因缘。建立善业。一取爱果故。二于所缘境如实遍知。及彼果故。由二因缘。立不善业。一取非爱果故。二于所缘境邪执着故。于善不善二种行相。不可记故。立无记业。顺乐受业者。谓初二三静虑地系。及欲界系所有善业。顺苦受业者。谓能招感恶趣生业。生于饿鬼乃傍生中。先业为因感得乐受。当知此业亦得名为顺乐受业。顺不苦不乐受业者。谓第四静虑。及上地等诸所有业。唯除那落迦于所余处。当知皆得苦乐杂受。即由彼业增上力故。令此依身苦乐杂住。不相妨碍。顺现法受业者。谓由如是相状意乐所作诸业。若由如是相状加行。谓事加行。或身加行。或语加行所作诸业。若由如是相状。良田所作诸业。于现法中异熟成熟。如是名为顺现法受业。若所作业。于现法中异熟未熟。于次生中。当生异熟。如是名为顺生受业。若所作业。现法次生异熟未熟。从此已后异熟方熟。当知是名顺后受业。有学业者。谓圣弟子于时时间依增上戒。依增上心。依增上慧。修学无漏。及此后得善有漏业。名有学业。无学业者。谓于一切阿罗汉等身相续中。随应诸业。此余诸业。是名非学非无学业。若见所断烦恼相应。若此所发思等诸业。一切能往诸恶趣业。此等皆名见所断业。若修所断烦恼相应。及此所发思等诸业。如是皆名修所断业。无断业者。所谓一切有学无学出世间业。当知此中由三种相。故思所造诸不善业。即于现法作增长已。还复除断。何等为三。一现法断故。二生断故。三后断故。现法断者。谓如有一。于现法中故思造业。作增长已。寻复厌离。于其所作受厌离故。此是异生未得离欲。住此命终。而未能令于次生位。不造彼业。不受异熟。亦未能令于其后位。无有是事。于现法中。亦未一向能令不造。生断故者。谓复有一。受厌离已。虽是异生。而于欲界已得离欲。住此命终彼于现法更不造作。尚于次生不受异熟。况复生已当有所作。然未解脱后位作业。及受异熟。后断故者。谓复有一。虽是有学。而于欲界未得离欲。受厌离已。获得最初或复第二沙门果。证彼作是念。凡我所有由多粗重。由多热恼。唯应弃舍可厌贱。身所作恶业。愿于现法一切皆受。或我所有现法受业。若苦若乐。皆愿与彼俱时而受。勿复令我当于生位。或于后位受彼异熟。如是正心发誓愿已。为断彼故。复修无量。以奢摩他品定所摄正起加行。为令能起彼业因缘究竟尽故。及为进趣离欲爱故。当知此中或嗔意乐。或害意乐。或嫉妒性。或可爱事。深生染着。由此为因。于诸有情发起邪行。谓身语意所发恶业。种种恶事。若有为欲对治如是能起四种恶业因缘修四无量胜三摩地。彼乃至于少男少女无处无容。暂更发起作恶业思。是故彼修如是加行。能尽所有恶业因缘。当知如是正修加行。由二因缘。于其所作。及所增长一切恶业。皆能摧伏。谓由修习无量定故。所以者何。所作恶业。但于有量有情境界。欲不饶益意乐所起。所修无量。乃于无量有情境界。欲作饶益意乐所起。又能发起不善业心。下劣界摄。是所对治。所修无量俱行之心。胜妙界摄。是能对治。又心是胜诸所造业。皆属于心故。说世间并是心胤。系属心故。依心转故。如是行者先发正愿为所依止。后善修习无量心定。当于进趣离欲爱时便能获得住不还果。若但于此暂生喜足。于现法中不求上进。彼现法中尚不造业。况于生位或于后位。又定不能当受生位后位异熟。又正法外堕邪见者。行邪道者所有一切善不善业。邪见所起。邪见增上力所生故。皆名曲业。猛利贪嗔所起诸业。皆名秽业。猛利痴者。上品钝根忘失念者。极闇钝者。痴所起业。皆是浊业。一切能往善趣妙行。皆名净业。一切能往涅槃妙行。名默然业。复次能感各别处所那落迦恶业。名黑黑异熟业。能感各别处所天趣善业。名白白异熟业。能感余处所有诸业。名黑白黑白异熟业。于是处所。有二业果现前可得。是故总说以为一业。若出世间诸无漏业。皆名不黑不白无异熟业。能尽诸业。若已尽业。若当尽业。二种总名能尽诸业。令未生者当不生故。令已生者得离系故。由约可爱因果异熟故。说不白。当知各别处所天趣一向白者。谓过他化自在天处。有欲界中魔王所都。众魔宫殿。及上梵世乃至非想非非想处所有善业。总说为一。由彼处所眼所见色。乃至意所知法。一向可爱相续。殊胜增上义故。意门引发意成义故。各别处所那落迦有四。一大那落迦。二别那落迦。三寒那落迦。四边那落迦。于此处所。各别纯受顺乐受业诸果异熟。各别纯受顺苦受业诸果异熟。是故说名各别处所。又于魔宫初二静虑。纯受悦乐。若于第三静虑已上。纯受喜乐。言喜乐者。令心调柔。令心安适。与喜相似。故名为喜。非是喜受与乐相似。说名为乐。非是乐受。六触处门恒所领受者。当知即彼名六触处。及各别处所。因果相属道理义故

复次嗢拖南曰

  无智智与定　　殊胜障学等
  着无我圣道　　二海不同分

若诸邪见。若诸我见。若即无明。依前所说三有情众无智为根故。得生起。若能断此无义根本一切众中能起一切。杂染一法。当知彼能正记所解。此中第一所起杂染。损减实事。第二杂染。增益虚事。第三杂染。于其如实显了方便。能作愚痴。于彼二因有愚痴故。或起增益。或起损减

复次有二种如实智。一者如理作意所发。二者三摩地所发。当知此中由正闻思所成作意。听闻正法增上力故。于五种受分位。转变所起过患。如实了知。又即于此分位。转变如理思惟。名不定地如实正智。此为依止能随入修。云何名为分位转变所起过患。谓苦乐位诸无常性。苦分位中有自性苦性。乐分位中有变坏法性。云何名为分位转变。谓乐分位与苦分位。有别异性。若苦分位与乐分位。有别异性如是。当知一切分位展转别异。于此别异如实观见。于此分位。住无常想。如实观见别异过患。知所有受皆是苦已。住于苦想有如是想。有如是见能证清净。是故亦得名如实智。依定所发如实智者。谓即依彼行相转时。轻安所摄。清净无扰。寂静而转。当知此行与前差别。又无常性是一切行共相。苦性是一切有漏法共相。二如实智为依止故。当知如实能正显了彼法二相。

复次住内法者。未得定心。尚与外道定心差别。由智胜故。何况定心。何以故。彼诸外道。虽得定心乃至极远证得非想非非想定。然犹未能于六触处以其五转。如实了知。心正离欲。证得解脱。是故彼与此正法律。犹如地空相去极远。住内法者。虽未得定。但由信闻无我胜解。便能证得三摩地心。于六触处能断能知。心得离欲。及证解脱。是故当知于正法律。彼有失坏。此无失坏。唯正胜解相续转时。于六境界依止六根。略有五种寂静妙行。谓深于彼见过患故。名为善调。于不应役诸境界中。而不役故。名为善覆。于所应役诸境界中。或于率尔现前境上。善住念故。名为善守。一切烦恼皆能断故。名为善护。已善修习圆满道故。名为善修

复次于二处所。如来证得胜安立智。能正显说超诸苦乐。非不证得胜安立智。于中若有作如是解。此大沙门乔答摩种。无知无解。于诸世间一向安乐。为令弟子谓此安乐间杂众苦。深怖畏故。为超苦乐间杂依附诸世间故。为欲超过诸苦乐故。宣说法要。当知此解是为邪想。是邪分别。是大邪见然其如来善知世间或一向乐。或一向苦。或杂苦乐。然彼一切皆是无常。是故为令诸弟子众超过一切无常世间。超过苦乐。说正法要。由三种相。应正了知诸可意事。谓未来世诸可爱事。名所追求。若过去世诸可爱事。名所寻思。若现在世可爱外境。名所受用。若现在世可爱内受。名所耽着。当知此中堕于三世有四行相。一于未来。一于过去。二于现在。于此行相能随悟入。是悦意相。意所乐相。可爱色相。平安色相。如其所应当知。即是可欣可乐可爱可意四种行相

复次勤修定者。略由二门二时二地所有诸欲。于所引发三种等持。能为障碍。为欲断除如是障碍。正勤修习五种对治。当知此中先所受用过去诸欲。于远离处。由寻思门。令心飘荡。复有现在居家所有利养恭敬俱行诸欲。由寻思门。令心散乱。此中利养恭敬俱行所有诸欲。于其行时令心飘荡。先所受用居家诸欲。于其住时令心散乱。即此诸欲于异生地能为障碍。于有学地亦为障碍。又于异生所修无量俱行等持。能为障碍。亦于有学能善通达一切智事广大等持。能为障碍。亦于无学极善修习究竟等持。能为障碍。当知如是诸所生起一切等持。皆与喜俱。此中第一于诸有情利益安乐意乐门中。与喜俱行。第二领受有学解脱喜故。与喜俱行。第三领受无学解脱喜故。与喜俱行。彼由眼等所识色等所缘别故。复有六种。又此等持具诸相故。名为圆满。又此等持究竟边际。谓能往趣世间离欲。或能往趣出世离欲。过此更无能趣清净等持可得。是故说此无有缺减。若欲速证沙门果者。于身命等无所顾恋。恒常无间殷重加行。炽然精进。于诸欲中了知自相。坚守正念。了知过患。无希望等。正知现前。正念正知为所依故。方便勤修四无放逸。谓于昼分若行若坐。于诸障法净修其心。乃至广说。如是发起勇猛精进。于其所证无所怯劣。由九种相安住其心。一向修习奢摩他定。身得轻安。无爱味等故无染污。不为惛沈及以睡眠二随烦恼之所扰乱。一向念住为所依止。精勤修习毗钵舍那。坚守正念。远离掉举随烦恼故。无有愚痴。已入止观双运转道。其心正定。即此二分一境随行。为断彼障。修习如是五种对治为依止故。能于彼障遍知永断。于三等持。依六境事所有差别。喜俱行定圆满能引。由二因缘。诸佛世尊为诸弟子宣说自己能引导法。一于黑品所有过失。令生解故。二于白品所有功德。令生解故

复次于此正法毗奈耶中。略有二种补特伽罗。一已得意。二未得意。已得意者。复有二种。一已见谛已得有学心解脱意。二阿罗汉已得无学心解脱意。未得意者。谓于三学创修事业有学异生。彼全未得一切二种心解脱意。是故希求异生体后有余依灭。及自体后无余依灭涅槃界时。于三学中多修学住。若诸无学虽已证得心解脱意。而或失念。行纵逸时。便有退失现法乐住。彼虽于此现法乐住。或退不退。然无堪能退失解脱。若有修行不放逸者。一切皆为证得解脱。然已证得解脱无退。修不放逸复何所用。若为证得现法乐住。勤作功用。如造工业。非不放逸。若诸有学先已证得心解脱意。彼亦决定趣三菩提。于所修道。不由他缘。自然能修无放逸行。于现法中。犹未毕竟息放逸故。若有一切未得意者。彼应决定修不放逸。又由三相办所应作。一由诸根所集成故。资粮圆满。二由习近随顺如法诸卧具故。心得安住。三由依止亲近善士。闻他法音如理作意众因缘故。乃至获得二心解脱。又即于此应不放逸所作转时。由二种相。应知于彼六处寂灭。有增上慢。无增上慢。谓于未灭起邪分别。妄执为灭。由所缘故。及于未得起邪分别。妄执为得。彼虽如是起邪分别。谓灭解脱。而未能令身坏已后寿命永尽。六处永灭。亦不能离诸境界想。又彼由于六处寂灭。若缘若证邪领受故。有如是事。此二种相应知说名有增上慢。与此根违。当知说名无增上慢

复次住内法者。于二种着。应当了知二种过患。谓诸异生。于二缘识及能依受。不能了知无我性故。未离欲者。于利养恭敬增上业缘所起诸受。有第一着。已离欲者于离诸欲缘所起诸受。有第二着。此着为因当来生起。说名为生。又诸外道由取着故。生诸系缚。系缚生故。能生一切恶不善法。当知是名第一过患。又由此着增上力故。当于正法毗奈耶没。及当来世生等众苦差别而生。于现法中此增上力为因缘故。不般涅槃。当知是名第二过患。与此相违。应知即是白品差别

复次由四因缘。于法无我能到究竟。谓一切法皆无我者。除识自性。识诸因缘。识诸助伴。其余所有不可得故。又识自性是无常故。又此因缘是无常故。又此助伴是无常故

复次由八圣支道法故。及此果故显发正法及毗奈耶。由五种相。当知八圣支道法最胜无罪。谓于现法烦恼有无。善分别故。名为现见。能令烦恼得离系故。名无炽然。若行若住若坐若卧。一切时中。皆可修习易修习故。名为应时导。涅槃故。名为引导。不共一切诸外道故。名唯。此见远离信他欣乐行相。周遍寻思。随闻所起见。审察忍唯自证。故名内所证。此道果法亦有五相。当知已如摄异门分分别其相

复次海有二种。一者水海。二生死海。由三种相。当知水海与生死海而不同分。何等为三。一者自性不同分故。二者沦没不同分故。三者超渡。不同分故。此中自性不同分者。谓水大海。用色一分为自性故。有边有量。生死大海。用一切行为自性故。无边无量。此中沦没不同分者。谓若所有沦没。若由此沦没。若如是沦没。皆不同分。谓水大海。或傍生趣或有人趣。于中沦没。生死大海。诸天世间亦常沦没。又水大海唯由身故。于中沦没。不由语故。不由意故。不由贪故。不由嗔故。不由痴故。不由生等众苦法故。于中沦没。此中宣说诸业。烦恼。彼果三分。如其次第。应知彼相。生死大海。亦由身故。乃至亦由生等苦故。于中沦没。诸出家者。由妄寻思。由妄观察。由自所起诸邪分别。发起种种不正寻思。令心扰乱。于生死海。恒常沦没。又余外道。诸烦恼系所缠系故。于生死海。恒常沦没。诸在家者。恒常无间众苦逼切。烦恼烧然。而不能厌。故名沦没。其余依止诸业烦恼。于诸生处往还无绝。故名沦没。其水大海唯堕其中。暂时衰损。或傍生趣。由业烦恼一分势力。而生其中。暂时沦没。而非究竟。当知是名没不同分。此中超渡不同分者。谓水大海。未离欲贪诸异生类。尚能越渡。何况其余。生死大海。三分建立。未离欲者。由五可爱境差别故。已离欲者。由意所识可爱诸法境差别故。诸有学者。由内六处有差别故。其未离欲诸异生类。于五可爱境界大海。未能超渡。其已离欲诸异生类。于内各别六处大海。未能超渡。由彼于此未超渡故。于前二种境界大海。亦未超渡。其有学者。普于六处遍知为苦。即于所缘修习正道。彼由安住如是住故。于未离欲已离欲地二种境界所有心意所缘境相。明了现前。又由猛利观察作意。于先所见等随忆念。由此因缘。于彼速疾以慧通达。亦能除遣。又彼于其六处大海。速能超渡。能超渡故。于前二种境界大海。毕竟超渡。及能超渡能发弃舍所学烦恼。能发寻思乱心烦恼。能发耽着世间利养恭敬烦恼。能发一切恶行烦恼

嗢拖南曰

  道师不同分　　王国二世间
  有为遮身行　　坚执三空性

略有二种道不同分。一自性不同分。二行相不同分。若趣苦集行。若趣苦灭行。是名自性不同分。当知初一能趣杂染。第二能趣清净。是名此中不同分义。即此趣灭行。或有有为共相行转。或有有为无为共相行转。是名行相不同分。当知此中若诸有为共相行相。彼望道果名不同分。若有为无为共相行相。彼望道果亦名同分。何以故。道果涅槃。常无我故

复次于正法内。略有五种师假立句。诸外道师所制论中。都不可得。谓趣诸取行。趣诸取尽行。若一切法遍知永断。作苦边际。若于五相受建立处。一一相中。不依四相萨迦耶见。用彼为依。能害四种行相憍慢。若慢为因有三过患。离慢为因。有三胜利。当知此中怀憍慢者。于涅槃界其心退还。由怖畏故。是名第一过患。于诸恶行恒现行中。及于可爱诸杂染事。其心趣入。是名第二过患。于涅槃界深生怖畏增上力故。便能生起当来生等生死重病。如由怖畏增上力故如是。亦由于诸恶行。及于可爱诸杂染事。其心趣入增上力故。堪能生起当来生等生死重病。如生等病。眼等处痈。贪等毒箭。当知亦尔。是名第三过患。与此相违。当知即是离慢为因三种胜利。若随缘起增上力故。于现法中。后有种子或增或减。由此为因。当来后有或生不生。以能摄受种子烦恼。或有集起或灭没故。一切世间及出世间所有法教。如实建立。唯于内法有此大师。为诸弟子正所宣说。师假立句。真实可得。非诸外道

复次于欲界中诸器世间。当知譬如王所王国。有情世间。譬如臣民。彼恶天魔。譬如君主

复次有二世间。一有情世间。二器世间。其器世间。为火灾等之所坏灭。有情世间。刹那刹那各各内身任运坏灭

复次空有二种。一者有为。二者无为。此中有为空。无常恒久久安住不变易法。及我我所。若诸无为唯空。无有我及我所。又此空性离诸因缘。法性所摄。法尔道理为所依趣。此或如是或异或非。遍一切处无不同归法尔道理

复次如来不遮能得一切世间边际。唯遮身行随往能得世间边际。此中当依胜义道理。应知世间。若得世间边际方便。及世边际。谓于方处有世间想。假名施设增上力故。即由世间若智若想增上力故。说有世间。若想若智增上力故。于诸世间广起言说。由或见闻或觉或知增上力故。于六触处。由其五转。起如实智。名得世间边际方便。未来诸行因永尽故。名为能到世间边际。于世因果。如实知故。名世间解。能正任持最后身故。名善运转世间边际。于现法中。一切境界爱永尽故。具恒住故。说名能超世间爱者。由如是等所说行相。当知名得世间边际

复次非善说法毗奈耶中诸出家者。随有一恶不善。寻思未生。生时一向能为梵行障碍。如彼生已坚执不舍。此中不行最为殊胜。设有行者。不应坚执。于相续中。不应为作居住依止。何以故。刹那杂染。不能倾动所修梵行。要当相续能倾动故

复次当知略有二种空住。一者尊胜空住。二者引彼空住。诸阿罗汉观无我住。如是名为尊胜空住。由阿罗汉法尔尊胜。观无我住。于诸住中最为尊胜。如是或尊胜所住。或即住尊胜。由此因缘。是故说名尊胜空住。引彼空住者。谓如有一。若行若住。如实了知烦恼有无。知有烦恼。便修断行。知无烦恼。便生欢喜。生欢喜故。乃至令心证三摩地。由心证得三摩地故。如实观察诸法无我。昼夜随学曾无懈废。如是名为引彼空住。当知此中于内烦恼。如实了知。有知为有。无知为无。是名空性

复次正见圆满。已见谛迹诸圣弟子。皆能如实越彼邪空。亦能如实入正不空。以世间道及出世道。修习空性。其义云何。谓于此处彼非有故。正观为空。若于此处所余有故。如实知有。譬如客舍于一时间无诸人物。说名为空。于一时间有诸人物。说名不空。或即此舍由无一类。说名为空。谓无材木。或无覆苫。或无门户。或无关键。或随一分无所有故。然非此舍即舍体空。如是自体所依止身。亦名受趣。亦名想趣。亦名思趣。然此自体所依止身。于一时间。由无一类或受或想。或复思等一切烦恼随烦恼等。说名为空。于一时间由有一类。说名不空。或即自体所依止身。于一时间。由无一类或眼或耳或鼻或舌或身一分。或意一分。说名为空。然非自体所依止身。即自身体一切皆空。当知此中总略义者。若观诸法所有自性毕竟皆空。是名于空颠倒趣入。亦名违越佛所善说法毗奈耶。若观诸法由自相故。一类是有。一类非有。此有非有毕竟远离。又观有性于一时间。一分远离。于一时间。一分不离。如是名为于彼空性无有颠倒。如实趣入。以世间道修空性者。谓圣弟子住远离处。先于城邑聚落人想。作意思惟。次复思惟阿练若想。彼即观察于自身中此想为空。谓人邑等想。此想不空。谓阿练若想。又余不空。谓阿练若想为缘阿练若想相应诸受思等。或即此想由一类故。观之为空。谓无粗重不寂静住。及炽然等。由一类故。观为不空。谓有微细极寂静住。离炽然等。又即于彼能取山林卉木禽兽等阿练若差别相想。无复思惟。但思惟地无别相想。又即于彼能取险恶高下不平。多诸刺棘瓦砾等地差别相想。无复思惟。但思惟地平坦细滑。犹如掌中无别相想。从此次第除色想等。渐次思惟空处。识处。无所有处差别相想。后于非想非非想处所有相想作意思惟。于一切处如前所说。历观空性。观诸下地有粗想等。观诸上地有静想等。如是名为诸圣弟子。以世间道。修习空性。当知为趣乃至上极无所有处。渐次离欲。自斯已后修圣道行。渐次除去无常行等。能趣非想非非想处。毕竟离欲。彼于尔时自观身中空无诸想。谓一切漏一向寂静。永离炽然。又观身中有法不空。谓此依止为缘。六处展转互相任持。乃至寿住为缘诸清净法。无有坏灭。当知世尊于昔修习菩萨行位。多修空住故。能速证阿耨多罗三藐三菩提。非如思惟无常苦住。是故今者证得上妙菩提住已由昔串习随转力故。多依空住

复次有二种空。一者应所证空。二者应所修空。若诸苾刍乐依杂住。于此二种。不能成办。应所证空不能证故。应所修空不能修故。因于二种不成办故。当知退失四种妙乐。谓于一切摄受恶事遽务众苦。皆悉解脱妙出离乐。解脱贪欲嗔恚等事初静虑中妙远离乐。寻伺止息妙寂静乐。二解脱摄无所造作无恐怖。摄妙等觉乐。二解脱者。一时爱心解脱。二不动心解脱。若阿罗汉根性钝故。于世间定是其退法。未能解脱所有定障故。名时爱心解脱。以退法故。时时退失。时时现前故。说名时。于现法乐喜欲证住故。说名爱。不动心解脱者。谓阿罗汉根性利故。是不退法。一切皆以无漏道力。而得解脱。于一切种都无退失。当知此中决定义。是三昧耶义。余如前说。无所造作无恐怖者。当知无有异类可得。令阿罗汉心。于中染彼变异故。生愁叹等。应所证空。略有二种。一者外空。二者内空。外空者。谓超过一切五种色想。则五妙欲之所引发。于离欲贪正能作证。内空者。谓于内诸行。断增上慢。正能作证。应所修空。亦有二种。一于内外诸境界中。修无我见。二即于彼修无常见。此四种空。当知四行为所依止。外空以内住心增上缘力。离所生乐。滋润其身。为所依止。及我慢遍知内空。以内外空。于内外法。修无我见。为所依止。无我见以即于彼修无常见。为所依止。无常见以闻正法如理作意。为所依止。又于此中。若诸苾刍为离欲贪。精勤修学。观察作意增上力故。于欲界系诸不净相。勉励思惟。彼于外空未作证故。于其正道未善修故。趣染习故。于外空性。心不证入。不爱乐故。便于其中。由我慢门。心不流散。等随观察。以寂静相。思惟内空。彼由我慢未永断故。于其正道。未善修故。亦于此中。心不证入。遂于内外一切行中。修无我见。于无我见。未善修故。亦于其中。心不证入。乃于内外一切行中。修无常见。令心不动。于诸行中。见无常故。一切种动皆无所有故。无常见名不动界。由于是处心无不胜解故。以正慧如实通达。或缘不净。或缘慈悲。或缘息念所有境界。或缘诸行无常境界。于三摩地。极多修习为因缘故。令心调柔。由是渐次于一切处皆能证入。由此因缘于所证空能证圆满。因于所证得圆满故。其心解脱一切能顺下上分结。由此因缘于所修空能修圆满。因于所修得圆满故。成就无学正见等法。若于是时。乃至于空。未能证入。当知此时是异生位。若时证入。是有学位。若时修习已得圆满是无学位。为令此修得圆满故。勤修正行。令心证入。以善寻思而正寻思。则于其中能善知量。离诸杂染而起言说。于经行处能正经行。于所坐处能正安坐。于如是等一切处所。皆善知量。如是行时。清净为先。于其住时。亦得清净。其间能以观察作意。数数观察现行烦恼。净修治心。如是能趣一向成就诸白净法。一切魔怨所不能夺。及彼一切恶不善法四种杂染谓后有因性故。现法身心遍烧恼故。恶趣因性故。生等众苦因性故。言说有二。一者随逐音声胜解言说。二者随逐法随法行言说。第一言说。是于正法受持读诵。请问征核之所发起。第二言说。是于所缘令心安住究竟解脱。施设教授之所发起。若为是义如来出世。诸弟子众随入圣教。应勤修习如是善法。若于彼法毗奈耶中。无一切种所修梵行。当知亦无修梵行者。以于其中无梵行故。称梵行者皆修邪行。师弟展转。互相触恼。各自许有尊卑体式。于正法中。二俱可得。若有弃舍大果大利应所证空。应所修空。为极下劣。有大罪过。利养恭敬爱味所漂。多习邪行。当知彼为大梵行灾之所触恼。彼由如是耽嗜爱着利养恭敬。自逼恼故。于能随顺解脱言教。不欲听闻。虽为宣说。不能属耳。或为贪着利养恭敬增上力故。而强听闻。无心求解。不欲修行不为究竟善自调伏。乃至不为证般涅槃。由如是事。憎恶大师。行不平等。以于广大现前恩德。不能报故。当知此中总略义者。谓善说法毗奈耶中。既出家已。由四因缘。如于自己正所应行。而不能行。如于大师圣教。出家正所应行。亦不能行。谓乐相杂住故。随顺随逐音声。胜解言说故。耽着利养恭敬故。由此耽着增上缘力。听闻正法。不修自利利他行故。又佛世尊不欲自显能善御众。而摄徒众。唯深哀愍诸有情故。由是因缘。于行邪行。弟子众中。能无护惜分明示语。宁使弟子由此分明粗利益语。现舍正法及毗奈耶。当获利益。勿令住此广兴邪行

瑜伽师地论卷第九十瑜伽师地论卷第九十一

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事处择摄第二之三

复次嗢拖南曰

  离欲未离欲　　问因缘染路
  保命着处等　　皆广说应知

若有苾刍。于其欲界或已离欲。或未离欲。于五妙欲意所识法。定地三世。由三种缠及彼根本所有随眠。正杂染时。于现法中。不任趣证究竟涅槃。当知此中由过去世。依彼取识。由未来世。属彼取识。由现在世。着彼取识。由彼根本所有随眠。堕在相续常随逐故。执彼取识。与此相违。无杂染时于现法中。堪能趣证究竟涅槃

复次于圣教中。当知有四如理问者。一有净信。若诸长者。若长者子。二具聪慧多闻苾刍。三是大师亲承侍者。四即大师。有二因缘。佛于弟子知而故问。谓观弟子虽欲请问。而无无畏。或于其义无所了知。为遮现在未来过故。为令正法得久住故

复次由二因缘。说六识身。以内六处为因。以外六处为缘。谓内六处为彼种子所依附故。又内六处相续一类。如先所得毕竟转故。境界不尔。非彼种子所依附故。又非一类相续转故。

复次由二种相。当总了知一切杂染。一者一切杂染自性。二者一切杂染行路。言自性者。所谓欲贪与诸杂染为根本故。言行路者。谓内外处。能取所取有差别故

复次若诸苾刍。于二处所。等随观察。若行若住。如理作意为所依止。于二杂染。应脱其心。云何名为于二处。所谓自保命忽然夭丧。不善心殒往诸恶趣。云何名为如理作意为所依止。复于何等二种杂染。应脱其心。谓我宁遭种种楚挞损害。于己诸处之身。勿复令我不善心殒生诸恶趣。又我应当与喜乐俱如实观察。为欲对治现行不善。恳励修习诸行无常。若经行时。于诸境界执取诸相。执取随好所有杂染。令心解脱。远离住时。于诸不善种种寻思所有杂染。令心解脱。当知此中第一杂染。是相似因。第二杂染是相似果。又二杂染现在转时。生于二处。谓自保命。即于尔时倏归夭丧。不善心殒往诸恶趣。是故于彼二种杂染。一刹那中深见过患。发生惭愧尚为妙善。况能相续

复有众多魔所归向所有杂染着安足处。智者了知应当远避。谓已离欲诸异生类系属定生喜乐诸处所有爱味着安足处。未离欲者于妙五欲受为依故。喜乐诤竞贪爱耽染着安足处。于恩于怨。诸有情所一切爱恚着安足处。广大上品能引境界顺乐顺苦所求所寻所可贪爱所有三世着安足处。当知此中。可欣可乐可爱可意诸句差别。如前已辩。不可欣者。于未来世。不可乐故。不可乐者。于过去世。由随忆念不可乐故。不可爱者。于诸境界。不可乐故。不可意者。由于诸受不可乐故。又言苦者。即于境界不可乐故。言损恼者。即于诸受不可乐故。言违背者。于过去世不可乐故。言逆意者。于未来世。不可乐故

复次有二杂染。一者外境杂染。二者内受杂染。眼等为依。于色等境。起诸贪着。名外境杂染。诸触为依。贪着内受。名内受杂染。此二杂染。于永寂灭般涅槃中。皆不可得。非诸魔怨所能游履

复次由十五相。应当了知一切种类爱见杂染。谓于诸处由诸缠故。名藏。由随眠故。名护。由我见故。名覆。所余差别。广说如前摄异门分。

复次总嗢拖南曰

  因同分等　　唯作缘等　　上品贪等
  后多住等

别嗢拖南曰

  因同分思缚　　解脱相触遍
  胜解护根门　　教爱相为后

诸圣弟子。因同分识。随入无我。由三种相。于诸识中正观而住。云何因同分识。随入无我。谓由现见五有色处。四大种身若增若减。若取若舍。无常性故。于缘彼识随入无常。无常则苦。苦则无我。由是因缘。随入无我。云何随入无我性已。由三种相。于诸识中。正观而住。谓诸邪见。一切皆以我见为根。是故此根必应先断。又以正慧即观彼识。所依所缘差别转故。有无量种。又观此识差别转时。如刹那量安住坚实。尚不可得。何况毕竟

复次于六处灭究竟。寂静无戏论中。由戏论俱四种行相。不应思惟。不应分别。不应诘问。唯应依他增长觉慧。审谛观察真实意趣。云何为四。谓或有无。或异不异。以彼六处有生有灭。展转异相。施设可知。由生灭故。有无可得。有异相故。待他种类异性可得。待自种类前后无别不异可得。六处永灭。常寂静相。是故由彼戏论俱行四种行相。思惟观察不应道理。当知此中能引无义思惟分别所发语言。名为戏论。何以故。于如是事。勤加行时。不能少分增益善法。损不善法。是故说彼名为戏论

复次于内外处。若有欲贪境界现前。或不现前。而其诸根不能弃舍故。名为缚。若无欲贪。设有境界正现在前。诸根于彼尚能弃舍。况不现前。故名解脱

复次善修梵行。于诸蕴处我我所见已永断者。若为损身。乃至夺命苦受所触。终无色变心变可得。如是名粗善守根相。彼由如是善守诸根。四苦解脱增上力故。得四种喜。一由当来外缘生苦得解脱故。二由当来内缘生苦得解脱故。三于现法般涅槃时。由二种依所作众苦得解脱故。四命终已与世所见草木相似一切众苦不相续故。由二种相草木相似。一者六处离有情想。与世所见草木相似。二者六处为所依止贪嗔痴火乃得烧然。与世所见草木相似。善修梵行诸圣弟子。当来后有苦不生故。与诸如来成就明力。少分相似。非现法缘苦不生故。设暂生已速疾断故。然诸如来。二种明力。皆悉成就。是故说名无上明持

复次有一沙门或婆罗门。越胜现量。世间愚夫尚不迷惑。况诸智者。一切愚痴所安足处。虚妄推度以为依止。或依前际。或依现法。坚固执着建立四种苦乐邪论。谓依前际。虚妄计度宿作因故立诸苦乐。一向自作。虚妄计度自在变化以为因故立诸苦乐。一向他作。虚妄计度先自在作。然后宿作因所作故。立诸苦乐。自作他作。虚妄计度无因生故立诸苦乐。非自非他所作因生。或依现法虚妄计度。若随自欲自作功用。所生起者。立为自作。若不随欲。不自觉知。他所引者。立为他作。若随所欲。自所觉知。他所引者。立自他作。若非自他功用为先。所生起者。但由境界现在前故。不能了达微细因触。便起邪执。谓非自他所作因生。立无因生。此中唯有诸根境识和合所生苦乐可得。都无前际。或现法中。若自若他实有可得。唯即于此三事和合。假立自他。是故当知。唯有其触遍行一切为苦乐因。

复次由四种相。正发精进。速令诸漏永尽无余。何等为四。一者发起平等精进。谓不极掉举。发勤精进。令其身心疲倦损恼。亦不极下。发起精进。虚弃身命令无所得。是名初相。又不由此而生憍慢。谓我独能发勤精进。余则不尔。是第二相。又于正发勤精进果世间安触所证差别无有爱味。与此俱行修不放逸。是第三相。又于精进平等之相。能善摄受。令于当来无有退失。是第四相。如是正发勤精进故。永尽诸漏。成阿罗汉。若欲于彼大师有智同梵行所。记别自己所证差别。唯阿罗汉六处胜解能正记别。谓依三学及以五种补特伽罗。云何名为六处胜解。一出离胜解。二无恼胜解。三远离胜解。四爱尽胜解。五取尽胜解。六心无忘失胜解。云何三学。一增上戒学。二增上心学。三增上慧学。云何五种补特伽罗。一者异生处在居家。唯依于信发生欣乐出离胜解。从境界缚心求出离。是名第一补特伽罗。二者异生既出离已。唯依于戒。于诸有情由身语意行无恼行。是名第二补特伽罗。三者异生能断利养及恭敬爱。于现法中离欲界欲。是名第三补特伽罗。四者有学已见谛迹。是名第四补特伽罗。五者无学得阿罗汉。是名第五补特伽罗。当知此中。第一第二处所胜解。初学所依。第三处所所起胜解。与第二学作其所依。后三处所所起胜解与第三学作其所依。若由此智能断烦恼。及烦恼断当知是名心无忘失。又于当来。后有因断。说名爱尽。现法境界诸杂染断。说名取尽。又彼第一补特伽罗。虽有正信出离胜解。而未决定堪于当来令彼一切悉皆弃舍及与变异。第二有其无恼胜解。第三有其远离胜解。当知亦尔。若诸有学六处胜解。虽无堪能当来弃舍及与变异。然似幼童等持念慧。皆悉羸劣。虽生圣处未善修故。于贪嗔痴。不能远离无余永断。由慧劣故。及由贪等未永断故。若遇胜妙境界现前。时时忘念。由此因缘而勤生起。学心解脱及慧解脱。尽诸烦恼。是故有学补特伽罗。仍有所作。由此分故。而名减劣。若阿罗汉六处胜解。尚无堪能当来变异。况有弃舍。善修道故。贪嗔痴等永断无余。爱尽取尽胜解圆满。已得尽智无生智故。六种恒住所摄受故。所有智慧非如有学时时忘念故。阿罗汉六处胜解。由第一义最极圆满。亦名成就最极清净。非余下位补特伽罗由此因缘亦无自高记别所解。于三摩地所行所缘。无散乱故。名内心住。即三摩地善成满故。名不狭小。一切烦恼皆离系故。名善解脱。所有智慧善积集故。说名善修。见灭尽故。无有爱味。其心一向善而无罪

复次略有二种补特伽罗。一者不能密护根门。二者善能密护根门。云何名为不能密护根门补特伽罗。谓如有一。于诸境界不能如理作意思惟。于可爱色为贪欲缠之所缠缚。于不爱色为嗔恚缠之所缠缚。又于彼境不能随念所有过患。设有随念。不善修习。由是因缘。心为时缠之所覆蔽。起诸缠已不能制伏。又是异生未得有学心慧解脱。于上无学心慧解脱。不如实知。由不知故。于诸有学心慧解脱。亦不能满。彼于尔时未以修力为所依止。于烦恼品所有粗重。未能永害。又不依先善思择力。念不成就为因缘故。当知不能密护根门。由此三相补特伽罗。应知不能密护根门。一由缠故。二由思择所摄对治有缺减故。三由修力所摄对治有缺减故。与此相违。当知白品。于诸根门善能密护

复次由二种相诸圣弟子。于其大师所说法教。能正记别能善宣说。谓能辩释真实义故。云何为二。一者由是意趣宣说。善能悟入如是意趣。而正记别二者如来以无量门广宣圣教。为无量品补特伽罗种种辩说。于此法教不违法性。能正记别

复次于佛善说法毗奈耶。深心爱乐新学苾刍。由二种相。应正了知。一由身相无变异故。二由心相无变异故。谓由形色极光净故。面貌熙怡极鲜洁故。肤体充实不羸损故。诸根适悦而寂静故。身无变异随有所得生喜足故。远离贪乐畜积资财而受用故。于其室家无顾恋故。心无变异。复有三种淫贪对治。能令淫贪未生不生。已生寻断。一者思惟不应行想。二者思惟极不净想。三者密护一切根门。此中密护一切根门。略广应知如声闻地。谓能密护诸根门者。不令母邑摩触身故。名善护身。于诸母邑不观不听不忆念故。名善守根。设见设闻设随忆念。即能长时摄受正念。以猛利慧深见过故。名善住念。彼由如是善护其身。善守诸根。善住正念。便能思惟不应行想。由此烦恼不能蔽心令暂欣味。又能思惟极不净想。由此烦恼不能蔽心令速回转。

复次嗢拖南曰

  唯缘寻思愿　　一切种律仪
  入圣教不护　　胜资粮善备
  舍所学着处　　不善义随流
  菩萨胜余乘　　论施设最后

由先所作诸业烦恼及自种子相续所引诸受。生起其六触处。唯为作缘。如心所起功用所引诸取受业。手唯能作助取受缘。当知此中道理亦尔。

复次诸有苾刍受用如法边际卧具。安住空闲。若有能令寻思躁扰。胜妙境相来现于心。当知是魔品类所作。此中苾刍应以九相安住其心。从诸境界相应寻思。摄心令住无客寻思随一更起。若由此依由此境界有所餐味。于此境界。随其所得随其所住。能自远离彼。于尔时于可爱事。终不依止诸欲寻思。而有所作。于恚寻思及害寻思。亦能远离。净修其心。于现法中能得涅槃。得涅槃已。终不共他诤竞而住。谓诸诤竞于佛圣法毗奈耶中。极作衰损。如是愚痴所生寻思。亦不寻思如余外道。

复次若由先世后有苦因。于现法中有六触处果法而转。由六境界所损恼时。若有苾刍。为求后有。自发誓愿。修行梵行。彼于尔时令其第七后有苦因倍更增长。转为损恼。于现法中能障涅槃。由此因缘能得当来有暇。圆满不决定故。此后有愿。当知于彼微细缚中。最极微细。何以故。如彼三十三天宫中有一囹圄。其中禁缚天或非天。然彼法尔暂得解脱。以天妙欲游戏而住。乃至未起逃窜之心。此心若起便失妙欲。还见自身为缚所缚。彼才起心便为微细缚之所缚。以时分故。说名微细。非难识故而说微细。由被缚时。能自解了我今有缚。若诸苾刍心愿后有。此心若起便即被缚。既被缚已不能了知自身有缚是故此缚最极微细。当知时分及以难识俱微细。故名极微细

复次若诸苾刍精勤加行。守护诸根。于其律仪及非律仪。应当了知。于软中上世间有学无学律仪。应当了知。云何律仪。谓如有一。于可爱境诸杂染心。不忍不受不执不取。设令暂起寻还弃舍。是名律仪。云何非律仪。谓一苾刍如营农者。亲近善士听闻正法。如理作意。正修所缘境界良田。令其生起善根苗稼。然其种性猛利多贪。未尝串习贪欲对治猛利惭愧。亦未曾有若遇胜妙境界现前。彼由本性猛利贪故。未曾串习贪对治故。所有惭愧皆羸劣故。便起贪缠。坚执不舍。心于贪缠不能防护。而自放纵非理作意相应心牛入境界田。损坏所有善根苗稼。以是因缘。名非律仪。又如有一。能速作意。于诸境界而自摄敛。然未能观所有过患令不再起。是名为软世间律仪。又如有一。能速作意。于诸境界而自摄敛。亦能观彼所有过患。令不再起。是名为中世间律仪。由此为依。获得四种作意所摄九相心住。当知如前声闻地说。由得此故。名离欲贪诸异生类。彼先修习加行观时如营农者。今得增上犹如大王。于先所得等至所生胜妙诸受。能正了知是大放逸安足处已。便使如臣。听闻正法增上所生胜奢摩他之所摄护毗钵舍那。令其观察彼所生受性是缘生。缘生性故体是无常。彼由此故。便以意地诸过患相俱行作意。而得离欲。既离欲已复观等至所依别故。十种差别。时分别故。多百差别。此中等至所依别故十种别者。谓有寻有伺。无寻唯伺。无寻无伺。若喜俱行。若乐俱行。若舍俱行。退分。住分。若胜进分。顺决择分。时分别故多百差别者。谓即观察如是行相。依生住灭时分所作差别道理。当知复有多百差别。如是了知彼所生受是无常性。流转差别种种性已。略由三相。复审观彼是无常性。谓所依故。现行故。因故。所依故者。谓极乃至第四静虑所有色身。是受所依。现行故者。谓极乃至灭受想定其间想受多分现行。言因故者。谓当来世所有受因。即思求愿。观察如是乃至有顶所有诸法缘生性故皆是无常。如是如理审正观察诸离欲地。是名上品世间律仪。当知此中前二律仪。思择力摄。后一律仪。修习力摄。彼既成就如是胜妙不放逸力。如实通达圣谛理故。便能永断执我我所。以为前行一切见道所断烦恼。又能获得有学律仪。彼即修习有学律仪。复能永断妄执我慢以为前行一切修道所断烦恼。究竟证得无学律仪。此上更无若过若胜所余律仪

复次若诸苾刍。已入圣教不护诸根。彼便一向造作众苦。谓后法苦。或现法苦。当知如是不护根者。如癞病人入芦荻丛。为如其叶可爱境界破裂其身。摄受当来微细俱行后有众苦。而不能觉。如是名为由后法苦。说造众苦。彼又于此起染起着广生毁犯。由是因缘。虽住空寂阿练若处。而受现行追悔所起寻思之苦。如菅茅刺伤害其足。不能无畏往净仙众。设强趣入清净僧中。便为有智同梵行人举其所犯。由彼内怀覆藏意故。心如鸩毒。于能举边发愤掺害。又诸有智同梵行者。知其鄙劣乐舍沙门。即便远避不与同住若诸村邑若阿练若。咸共讥毁言。此长老如是毁犯。如是恶说。如是恶作。如是非法杂染而住。已净信者。令其变退。未净信者。令信不生。是故彼人于现法中。领受如此追悔所作。发愤所作。远避所作。讥毁所作。种种诸苦。此及前说领受后法所作众苦。总略为一。名受众苦。此中云何名非律仪。谓于如是现法后法。具众过患。行处境界。起不如理。妄执诸相随好邪想。邪想为先于其住处发起顺彼相应寻思。由此不能于前所说一切过失如实观见。虽复观见所有过失。未能数数多修习故。于所依中诸烦恼品所有粗重。未能除遣。身未轻安。谓色心身。由此行相缠及随眠犹尚和合。能令违背思择修习二力对治。名非律仪。与此相违。当知即是律仪行相。又此律仪三因缘故。能令修习速得圆满。何等为三。所谓最初于善说法毗奈耶中。净信出家。既出家已。便用神力相应闻慧。摄持虫兽相似六根。既摄持已。复用如理作意思慧。正审观察过患。方便在闻慧上修慧下。故中间系缚。中间系已。为欲试察于彼神力得自在不。乃取净相。于诸境界而放纵之。于彼神力未自在故。各各驰散别别境界。然其不能究竟逃窜。未善观见彼过患故。令彼虫兽未善调伏。又令神力不得自在。了知是已。复多修习如理思慧。令到究竟。超过作意。转更勤修循身正念。于此正念善修习故。彼不复能各各驰散别别境界。当知尔时彼善调伏。神力于彼而得自在

复次有诸苾刍。先已修集妙慧资粮。复得值遇善友。圆满听闻诸行三种过患。谓现法过患。后法过患。现法后法过患。当知此中大种互违为所依止一切疾病。名现法过患。恶趣诸行常恒随逐能作能往。名后法过患。先于现法成就喜贪以为所依。能引现法后法老死。名现法后法过患。如是总略有三种苦。一疾病苦。二恶趣苦。三老死苦。谓依善趣及依恶趣。听闻如是诸过患已。精进修行。法随法行。因斯能入圣谛现观。次由善净无我真智。如入空室。现观内外六处皆空。彼于尔时。以慧通达依诸境界忘念。所生诸烦恼缠能为损害。及有余残烦恼随眠贪爱随眠。又自通达于相续中。有诸烦恼。有诸贪爱。有诸苦恼。有诸损害及过。一切烦恼贪爱。证有余依般涅槃界。一向寂静。次后复证无有余依般涅槃界。彼先修习譬如草木枝条茎叶。正法门慧积集圣道。法随法行为所依筏。于修道中正勤修习。渐次证于心善解脱。住有余依般涅槃界。一切灾恼皆得解脱。既住于此。当知究竟越度众苦。到于彼岸

复次由七因缘。于善说法毗奈耶中。虽出家已。复还退舍正所修学。云何为七。谓诸异生未能超度诸异生地。于五取蕴众苦恼法。不能如实了知五转。或复异生于诸妙欲。不能上品观其过患。又于行时及于住时。恒常纵逸于可爱境。取不如理所有相貌。不系念故。恒常寻思善品恶刺非理寻思。又无无畏。若王若余因事呼逼由怖畏故。则便随从。复有亲爱于诸亲属有所顾恋。彼若招命由亲爱故。则便随从。又于境界或随顺贪。或随顺嗔。或随顺痴。发起猛利诸烦恼缠。又即于彼心相续中。常有随缚。又由成就下劣胜解。无有一切广大胜解。谓于出离远离涅槃。由彼成就劣胜解故。于诸境界其心趣入。由于一切父母等事。不能孑然无顾恋故。于其出离心不趣入。于八圣支无胜解故。于其远离心不趣入。由于彼果烦恼断中无胜解故。于其涅槃心不趣入。略由二处摄一切漏。一见所断。二修所断。当知此中非理作意。及所缘境。名顺漏法。若诸有学于能发起修所断漏非理作意所缘境界。虽未永断。而由妙慧正通达故。说名于此顺漏法中其心寂静。犹有失念增上所生微劣缠故。未名清凉。未名宴默。然其所起一切见道所断诸漏。皆永断故。亦名清凉。以于当来不生法故。亦名宴默。而彼异生成就下劣诸胜解者。遍于一切顺诸漏法。心不寂静不名清凉。不名宴默。当知由是七因缘故。复还退舍正所修学。与此相违所有白品七因缘故。于善说法毗奈耶中。既出家已。终不退舍正所修学

复次若有苾刍。依四着处。当知彼行四种邪行。何等名为四种着处。谓有苾刍。于内外处有贪爱故。能感后有。于现法中不乐涅槃。是初着处。复有苾刍。于先所舍外诸所有父母等事。有所顾恋系缚其心。如是名为第二着处。复如有一。于现法中希求一切利养恭敬。于诸所得利养恭敬。耽着不舍。如是名为第三着处。复如有一。是有学者已见谛迹。有余我慢。少分贪爱之所随逐。于修弃舍纵逸而住。如是名为第四着处。云何名为四种邪行。谓彼最初爱乐后有补特伽罗。于现法中不乐涅槃。若诸有学行于纵逸。由此着处增上力故。乐与在家及出家众共相杂住。如是名为最初邪行。又复即前爱乐后有补特伽罗。爱乐后有增上力故。发起邪愿。行于梵行。如是名为第二邪行。又复于先所舍外事有所顾恋。由彼着处增上力故。能令退舍正所修学。如是名为第三邪行。又于现世希求利养及与恭敬。于诸所得利养恭敬。耽着不舍补特伽罗。由此着处增上力故。毁犯尸罗。广说乃至。螺音狗行。彼由顾恋利养恭敬。不舍所学。不见是罪。公然犯戒。如是名为第四邪行

复次有诸苾刍。于义不善从他所闻种种文字一义言说。便怀犹豫不生欢喜。今于是中何者为实。复有四种能生微妙清净智见无倒观门。何等为四。谓极精勤观察苦者。于生受因如实妙智。又于依持及所依因如实妙智。又于住因如实妙智。又于依缘自性助伴随顺苦乐非苦乐行如实妙智。又二缘故。如来除灭于义不善补特伽罗所有犹豫。一者显示种种文词所表一义。文有差别。义无差别。由是能令断除犹豫。二者开显圣教广义。由此能令于义通达。云何名为圣教广义。谓从资粮地乃至漏尽。皆说名为圣教广义。此中边际根成熟住。如来所化无我相应善受坚固闻思所成正见成就。此为依止。此为建立。独处空闲。缘内外处四种识住。为欲断灭诸有取识。修循身念胜奢摩他毗钵舍那之所摄受。由此亲近修习势力。发生如实缘初识住邻逼现观止观双行。从此无间于圣谛中能入现观。复更修习。如所得道以渐进趣。能得一切诸漏永尽。如能如实缘初识住。乃至如实缘第四识住。当知亦尔

复次如先所说。不护根门补特伽罗。烦恼诸缠现前不舍。世及出世思择修习二力对治有所阙乏。烦恼生已性多坚执。魔既了知性坚执已。便往其所以诸境界而媚惑之。如是彼魔于性执着烦恼诸缠补特伽罗。而得其便。为欲媚惑。于其相续安立所缘。又即如是不护根门。补特伽罗。于般涅槃欲乐劣故。亲爱劣故。譬如干朽苇草舍宅。魔便于彼积集可爱境界炬火而焚燎之。由二因缘。彼为境界常所蔽伏。一未生缠令其生故。二已生缠令相续故。由为境界爱所蔽伏。于广追觅诸境界时。多行种种恶不善行。于行如是邪恶行时。复为种种恶不善法之所蔽伏。如前所说。行邪行已。失路而行。沿流而去。名顺流者。与此相违。所有白品。当知是名非顺流者

复次由八种相。当知总摄后有菩萨诸正行道。及以道果。胜声闻乘为无有上。何等为八。谓哀愍故。内勇悍故。谛察法忍性现前故。能出离故。自内发起观谛行故。广大善修世间正见现在前故。由获无漏菩提分法得清净故。由善清净修觉分。俱进修无上纯净修道。依止六处修习圆满。获得六种最胜无上圆满德故。当知此中于诸有情长时哀愍。熏修其心。住最后有诸大菩萨。见诸愚夫堕贪爱河。顺流漂溺为五相苦之所逼切。既观见已深起大悲。何等为五。一者见彼堕贪爱河。不正寻思。不可爱水常所逼触。二者见彼内外六处三毒火鸡住于两岸。三者见彼在于欲界众多忧苦种种灾横诸恶毒刺遍布其下。四者见彼在于色界世间慧眼有所阙故犹如盲冥处在其中。五者见彼在无色界世间慧眼已圆满故。诸圣慧眼有所阙故。犹如昏闇居在其上。既见如是堕贪爱河诸有情类。遍于一切皆不寂静。若触若岸若下中上苦逼迫已。发起大悲。是名哀愍。又即成就此哀愍者。或生王家或帝师家。虽未出家内兴勇悍。我今定当通达妙迹。归修梵行。终无退转。如是名为内兴勇悍。又彼即于未出家位。居赡部影。独坐思惟。便能证入最初静虑。后于自他老病死法。正审观察。能定忍可。如是名为谛察法忍内自现前。又彼宿世所习善根。一切善行之所觉发。复由勇悍谛察法忍增上力故。便能弃舍广大妙欲。净信出家。虽无施设。正梵行者而能自然受持禁戒。由此禁戒为依止故。渐次能证乃至非想非非想处。如是名为能正出离。又彼为欲弃世间道正求出离。由于先世正等觉。所获得无上究竟出离。正闻胜解。积集熏修。身相续故。于世间道都无信乐。由是因缘往菩提树。即依先时观老病死假想之道。于诸谛相次第观察。作是思惟。是诸世间有情之类。堕在种种艰险众苦。有生有老有病有死。然其不能于老病死究竟出离。如实了知如是次第。观于老死。观老死集。观老死灭。观能趣证老死灭行。如理作意为依止故。久已积集大资粮故。以俱生慧便能觉悟一切法性。安住诸法法住法界。如是名为自内发起观察谛行。又彼复欲求上漏尽。方便发起宿住念智。忆念先世。从诸如来正等觉所。于漏尽道积习闻思。由是发起长时积集。世间正见令现在前。然此正见。如教授者以此为依。能令菩萨安处一坐。乃至证得究竟漏尽。如是名为广大善修正见现前。又即由彼如教授者所有正见渐次胜进。先已远离下地诸欲。乃至上极无所有处。当于圣谛得现观时。便证无漏四念住等。乃至最后八圣支道所有一切菩提分法。举其最后。当知亦摄前位一切。由得彼故。成不还果。以得无漏菩提分法。是故说名获得清凉。彼由如是获得世间究竟安乐。获得出世无漏安乐得清凉故。名离炽然。由世间道。乃至已离无所有处所系烦恼。及已远离见道所断诸烦恼故。名离热恼。为欲无余永断有顶所系烦恼故。复勤修纯无漏道。所谓修习无上觉支。是名进修无上修道。由此修故。无学地中六种修法究竟圆满。一者修圣神通。究竟圆满。二者修净五根。究竟圆满。三者证得烦恼并诸习气无余离系。究竟圆满。四者证得四种现法乐住。究竟圆满。五者证得世间静虑等脱等持等至。究竟圆满。六者证得名身句身文身得随所欲。得无艰难宣说正法。究竟圆满。当知此中修净信根究竟满者。谓于涅槃意乐净故。修精进根究竟满者。谓能勇猛造作一切有情义利。善清净故。修习念根究竟满者。谓三念住无忘失法。善清净故。修习定根究竟满者。谓于圣天及以梵住善清净故。修习慧根究竟满者。谓十智力善清净故。彼由如是能住六处修圆满因。得为大王。所谓法王由是证得六种圆满。谓圣神通增上力故。得大财富自在圆满。诸根清净增上力故。得大舍宅自在圆满。断诸烦恼增上力故。得受安乐诸坐卧具自在圆满。现法乐住增上力故。处其舍宅。坐卧具中。证得第一无诸损恼大安乐住自在圆满。静虑解脱等持等至增上力故。证得能办一切有情正利益事。游戏喜乐自在圆满。于诸名身句身文身。得随所欲。得无艰难宣说正法增上力故。得为法王能于他所获得。平等分布作用自在圆满。如是名为六处修满为依止故。证得六种自在圆满

复次略有四种寻求我论。由此论故。萨迦耶见未永断者。求我寻思数数现行。云何为四。一者寻求我。我用何以为自性。二者寻求我。我为常。为是无常。三者寻求云何我。我是常。无常。四者寻求我。所有我住在何处。当知此中略有四种寻求于我。一者寻求自性。二者寻求其转。三者寻求其因。四者寻求窟宅。此中三种可得施设诸行差别。又此施设可非颠倒。第四一种由一切种。终不可得施设差别。当知施设我自性者。谓即施设十二种处所生六识并受想思。以为其我。过此余我不可得故。又即此我体是无常。由有生故。老故。死故。又此诸行以于诸趣种种自体生起差别。不成实故。说如幻事。想心见倒迷乱性故。说如阳焰。起尽法故。说有增减。刹那性故。名曰暂时。数数坏已速疾有余。频频续故。说为速疾现前相续。来无所从。往无所至。是故说为本无今有有已散灭。由如是相。略说生身展转无常。及有因刹那展转无常。如是三种如理施设我之自性若转若因。施设我之所有窟宅。终不可得。由诸行中离诸行性别有实我。住诸行中不可得故。由是因缘。约世俗谛诸行尚空不可施设。何况胜义。是故一向于空立空。如是由心如理作意。闻解了故。思等了故。修谛了故。如其次第差别说言。应当欢喜。应当等喜。应当遍喜

瑜伽师地论卷第九十一瑜伽师地论卷第九十二

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事处择摄第二之四

复次嗢拖南曰

  上贪教授及苦住　　观察引发不应供
  明解脱修无我论　　定法见苦最为后

三因缘故。补特伽罗于所缘境。上品贪行。何等为三。一者康强非羸劣。二者端俨非丑陋。三者习贪非舍贪。复由三种对治。摄受尚令如是怀上品贪补特伽罗。于善说法毗奈耶中。勤修梵行。调伏其心。令得寂静。何况但怀中软品贪微薄尘者。何等为三。一者密护根门为所依止。远离一切欲乐边故。二者于食知量初夜后夜减省睡眠为所依止。远离一切自苦边故。三者最胜正念正知为所依止。行于中道出离行故。当知此中于四念住善住心者。或于行时境界现前。若不取相及与随好。如实了知受生住灭。若取其相及与随好。如实了知想生住灭。或于住时如实了知彼因寻思生住与灭。由如是相。正念正知。于一切时。于一切种所缘境界。能如正轨守护其心。是名最胜正念正知。复有最胜正念正知。谓已获得灭尽定者。或已获得无想定者。或已获得无寻伺者。当知依止圣住天住。除此最胜正念知住。更无有余能过上者。或从灭定起已而住。或将入定。方便而住。如实了知受生住灭。是名最胜正念正知。如依灭定如实知受。依无想定如实知想。无寻伺定如实了知所有寻伺。当知亦尔。由此最胜正念正知。唯取法故。不于如是受想寻伺。起我我所虚妄分别。若诸愚夫受想寻伺差别生时。于受等法不能发起唯有法想。但作是念。我能领受。乃至广说。由是因缘。彼尚无有正念正知。何况最胜。此中后说正念正知。或不还果或阿罗汉。当知前说正念正知。从得作意无有放逸诸异生位至一来果

复次由二因缘。如来自言。其年衰暮身力疲怠。劝诸声闻请他说法。一者为令恃其少年专行憍傲。住放逸者自怖厌故。二者为令于当来世诸有苾刍。其年衰老无有势力。远离疑悔。劝请少年诸苾刍等。宣说正法。诸有苾刍。其年盛美具足势力。远离疑悔。无所恐惧。为他说法。当知此中略有二种处大集会宣说正法。一者决择说。二者直言说。决择说者。谓兴诘问征核方便。说正道理灭除疑惑。直言说者。谓诸听众默然而住。如说法师宣说正法。又由四相名能随顺教授教诫。一能分析诸处差别。于诸行中得无我智见清净故。二于诸受并所依灭离增上慢最极寂静见清净故。三能超越未来诸苦见清净故。四能超越现在诸苦见清净故。此中分析内外诸处识触受想思爱众别。显示无我。由依缘起方便道理。能引最初正见清净。如明依灯。如影依树。彼非有故此亦非有。显示内外诸处差别为因诸受。由彼诸处无余灭故。此亦随灭。离增上慢。于其涅槃如实了知。最胜寂静。能引第二正见清净。于现法中以智慧刀。能永断灭一切烦恼。显示无余超越当来所有众苦。能引第三正见清净。显示遍于顺苦顺乐顺非苦乐一切法中。不起贪欲。不起嗔恚。不起愚痴。显示见道。于其念住善住其心。显示修道。修诸觉分。谓令诸漏永灭尽故。超越现法杂染苦住。能引第四正见清净

复次有诸苾刍。不守根住。于诸境界心多爱染。心多散乱。由此因缘受二种苦。一者粗重所作苦。二者于诸法中疑惑所作苦。所以者何。由彼方便应勤修身。勤修身已。应勤修戒奢摩他支。以不修身亦不修戒奢摩他支。为因缘故。身不轻安。心不轻安。是故彼受粗重所作苦。轻安阙故。不能触证胜三摩地。由是因缘应如实知不如实知多生疑惑。是故彼受于诸法中疑惑所作苦。由此二种苦恼住故。名不守根增上缘力所得众苦不安隐住。如是名为于现法中不守根者所有过患。与此相违。当知即是守护根者所有功德

复次有诸苾刍。为离欲贪勤修方便。由正修习加行道故。伏诸烦恼。作是思惟。我于诸欲为有欲贪而不觉了。为无有耶。乃以净相作意思惟。于断未断方得决定。观察作意为依止故。寻求贪欲生起处所。如实了知。忆念分别。是诸烦恼胜安足处。由彼烦恼未永断故。若为烦恼漂漾心时。了知能趣下劣分故。便即制伏。若不制伏。于先所得少三摩地。尚还退失。况能进趣胜品功德。由整摄故。能不退失。亦能进趣胜品功德。若不观察复还发起增上慢故。亦有退失。由观察故。能证决定。若心漂漾能正了知还复整摄。是故不退。如修方便为离欲贪于余上位随其所应。当知亦尔。若猛利见审观察时。而不生起。彼便获得决定胜解。我于诸处已能胜伏。谓此所缘应生烦恼。我于是处已胜伏故。令不生起。超过学地。犹如大王能随己心自在而转。降伏一切魔罗聚落。证得究竟尽无生智。梵行圆满。

复次于其六根如前所说。五寂静相不寂静故。当知摄受三种苦果。谓现法中依根增上杂染而住。由诸不善现行为因。或于他所成其退劣。或被讥呵。或被杀害。受如是等现法众苦。又受当来生老病死种种诸苦。又受当来由先数习所引等流。不护诸根诸杂染故。亦名为苦。与此相违。于其六根由有五种寂静相故。当知摄受三苦灭果

复次略有二种世俗梵志。实非福田怀增上慢。自谓福田。自称我是真实福田。当知成就非实福田性及相故。不应供养。一者从他所得利养恭敬现前猛利耽着。诸根饕餮。为性躁扰。诈示现前离欲之行。二者摄受家产。亲属杂居。鄙秽专自修身。凡所行行既非自利。亦非利他。远离尸罗正法正行。远离能住善趣善行。远离能住涅槃妙行。当知彼与一切愚夫异生之类无有差别。住正法者。与此相违。当知是名胜义梵志

复次此正法外有诸沙门婆罗门等。为诸弟子宣说法时。多分为求诘责胜利。及求免脱他难胜利。当知如是宣说法者。就第一义无义无利。非自利益。非利益他。诸佛如来为诸弟子宣说正法。唯为证得明及解脱二果胜利。当知如是说正法者。大果大利自利利他无不圆满。行于三世无忘失。住最胜义故。三种所缘境差别故。说名三明。若心解脱。若慧解脱。皆名解脱。是爱无明根本杂染胜对治故。为得未得明与解脱。当知略有四种修道。谓修根故能正修身。修身所引善行修故。能正修戒。修戒所引念住觉支无倒修故。能修心慧。此中修根复有三种。一世间修。二有学修。三无学修。若思择力为所依上。虽取可爱不可爱境不如理相。而不发起烦恼诸缠。设令暂起寻复除遣。是世间修。若于圣谛已得现观。由失念故或生适意或不适意。或兼二意。而心不为缠缚坚住。速于杂染能得解脱。是有学修。若即此心坚固安住。如前于内无有隘迮。善脱善修。都无一切下至失念。于诸可意不可意等。发心亲近。计彼有德而趣向之。是名无学善净修根。当知修戒修心修慧三种亦尔。此中最初是初修根所引。第二是第二所引。第三是第三所引。修戒修心修慧相望各有三种所引。当知亦尔。此中可意不可意境界差别故。有恩有怨有情差别故。功德过失相应有情差别故。所爱非所爱有情差别故。当知一向适意一向不适意。适意不适意相杂差别。可意不可意境界差别故者。自有境界一向可意。自有境界一向不可意。自有境界其类相杂少分可意少分不可意。如是有情或一向有恩。或一向有怨。或恩怨相杂。或一向有得。或一向有失。或得失俱备。若于有情爱复生爱。当知一向是其所爱。若于有情恚复生恚。当知一向非其所爱。若于有情爱已生恚。或于有情恚已生爱。当知是名所爱非所爱。由如是等差别因缘。适意等三有其差别。又于恶行随观现法所有过患。随观当来所有过患。是故远离修习妙行。若于六处由一切门皆被诽毁。是名现法所有过患。由是因缘。堕于恶趣。是名当来所有过患。此中为他所诽毁者。谓为外道及余世间有聪敏者。闻其鄙恶名称声颂。咸共诽毁。当知其余即如所说。又此中言修念住者。谓念觉分创始发起。在异生地。数修习者。在有学地。修圆满者。在无学地。修习觉分未得断界。于其断界正希求时。名依远离。未得无欲界。于无欲界正希求时。名依离欲。未得灭界于其灭界正希求时。名依于灭。弃舍下劣修觉分故。回向胜妙修觉分故。名弃舍回向。又诸苾刍守护诸根有惭有愧。由是因缘。耻于恶行。修习妙行。修妙行故。无有变悔。无变悔故。发生欢喜。此为先故心得正定。心正定故。能见如实。见如实故。明及解脱皆悉圆满。当知是名修行次第

复次有一沙门若婆罗门。自既不能善修诸根。而不如理为他施设善修根法。见唯弃背所有境界。名护诸根。然其自于诸弟子众深生染着。一分起爱。一分生憎。谓于其教顺逆因缘适不适意常现行故。于此微细自己杂染。不能以慧如实悟入。而谓自能善修诸根起增上慢。诸有随顺如是见者。彼虽令根离诸境界。独处空闲。而缘彼境发起种种寻思杂染。然无智慧而自悟入。是亦不名善修诸根。又亦不为善修根故。勤修正行。但信他言起邪胜解及以邪慢。诸佛如来。为诸弟子如理施设烦恼断故。名善修根。非唯一向背诸境界。又诸如来于其三种不共念住。善住其心故。不染着诸弟子众。于正行众悦意现行。于邪行众行不悦意。由此所生贪欲杂染。嗔恚杂染。都无所有。由是因缘。虽与弟子等烦恼断。而名无上善修诸根。又此修根依五品众有差别故。当知亦有五转差别。谓佛世尊或有弟子一向正行而亦毕竟。或有弟子一向放逸而亦毕竟。或有弟子修行正行而不毕竟。或有弟子行于邪行而不毕竟。或有弟子多种品类一行正行。一行放逸。一行一分或时放逸。或不放逸。如是名为第五品众。此中如来称可意者。谓诸弟子于善说法毗柰耶中。为修诸根得圆满故。修行正行。复有一类不可意者。谓行邪行或不修行。是故如来观第一众生。起悦意。观第二众生。不悦意。观第三众生。起悦意。生不悦意。观第四众生。不悦意。生起悦意。观第五众生。起悦意。生不悦意。亦复生起悦不悦意。如来虽复于此五众发起如是五转差别悦不悦意。然诸如来终不为彼爱恚行相之所染污。由诸烦恼并其习气永离系故。善修根故。是故如来一切烦恼并习永断。为所依止。能善住念。于弟子众无诸杂染。说名五转无上修根。又于如是一切五转。随其所应。当正思惟三种对治。一无常想。二者慈心。三无想定。如是三种。随其所应当知其相。又佛世尊所作已办无学弟子。名已修根。由彼长夜乐涅槃故。虽遇如前诸有情数境相现前。或纯可爱。或纯非爱。或多杂类通爱非爱。由贪嗔痴永远离故。由心解脱及慧解脱增上力故。即由无相令心于彼速疾弃舍。由意乐故。于诸境界起厌逆想。又于涅槃见寂静德。如是速能安住于舍。由此因缘。一刹那顷失念所作杂染污心。亦不得起。当知齐此善修习故。名善修根。若诸有学未能速疾安住于舍。有余烦恼熏彼相续成杂秽故。又于一切三转境中。憎恶所起诸烦恼故。现行烦恼所逼迫时。则能方便住厌逆想及过患想。如是修行能令修根速得圆满。是故说彼名正行者。如是当知于善说法毗柰耶中。大师美妙诸弟子众。得所得义。能修正行

复次无我论师略有三种正所作事。何等为三。谓于苦集谛所摄行自相共相。应正显了安立无我。当知此中显各各别众多性故。显了自相。开示生灭相似性故。显了共相。是名第一正所作事。复于无我唯有因行。如其所有杂染清净如实显了。当知此中于三种受缘。生三种烦恼随眠。未能永断。于其见道我见随眠。未能除遣。于其修道我慢随眠。未能除遣。于见慢品能起无明。亦未永断。未能生起彼对治明。是故不能作苦边际。如是名为显示杂染。与此相违。当知即是显示清净。是名第二正所作事。复于诸行断增益我萨迦耶见。依能取实无我正见。如清净相应。实显了此无我见。在异生位。能正摄受圣谛现观。又能证得诸圣慧眼。在有学位。能得上位尽无生智。在无学位。能令一切学与无学见修所断所有烦恼无余永断。是故当知。此无我见能令清净故。应显了。是名第三正所作事

复次于其成就世间正见多闻。不定住正法者。即成就此世间正见多闻。得定住正法者。当知略有五种殊胜正加行果称赞利益。何等为五。谓彼第一住正法者。先由其心未得定故。奢摩他支戒未清净。亦未鲜白。即此第二住正法者。心得定故。清净鲜白。当知是名第一殊胜正加行果称赞利益。又彼第一心未得定补特伽罗。于一切受。并其所依。并其所缘。并其助伴。并其随转。不如实知。由不知故。便为三种无智为因过患所触。何等为三。一受杂染所作过患。二世杂染所作过患。三现法后法杂染所作过患。当知此中受杂染所作过患者。谓愚痴者于其乐受并彼随转并所随染有贪爱缚。于苦受等。有嗔恚缚。于其不苦不乐受等。有愚爱缚及随眠缚。由有愚痴所随眠故。世杂染所作过患者。谓愚痴者于现在世有贪染缚。于过去世有顾恋缚。于未来世有系心缚。现法后法杂染所作过患者。谓彼如是杂染心者。于世于受有杂染故。便能生长感后有业。由此增益后有诸蕴。令当得生。又能增长所有贪爱。谓后有爱及资财爱。后有爱故。能生当来所有自体。资财爱故。于追求时。极生疲怠。若得境界便生染恼。若不获得所欲不遂。便自烧然。若得已失便为愁恼之所损害。如是名为现法过患。若即由彼作及增长。能感后有。诸业烦恼增上力故。起于当来生老死等众苦差别。如是名为后法过患。第二心定补特伽罗。应知一切与上相违。当知是名第二殊胜。余如前说。又彼第一补特伽罗。心未定故。于其无智所作过患。若自若他不如实知。第二心定补特伽罗。于彼皆能如实了知。当知是名第三殊胜。余如前说。又彼第二心已得定补特伽罗。于诸过患如实了知。已入修地。即前所得无我相应所有正见。由此修故。于二时中。依其断界及无欲界与彼一切菩提分法。皆共圆满。初未得定补特伽罗。心未定故。于彼一切皆未圆满。当知是名第四殊胜。余如前说。又彼第二心已得定补特伽罗。所有多闻毗钵舍那助伴支分。彼能摄受胜三摩地。能净修治毗钵舍那。由是因缘。止观二种平等双转。心未得定补特伽罗。应知多闻与彼俱阙。如是于成世间正见多闻。不定住于正法补特伽罗。即此成就世间正见多闻。得定住于正法补特伽罗。当知有此第五殊胜正加行果称赞利益。如是即彼由已获得胜奢摩他毗钵舍那。依于断界。应遍知者。能正遍知。应永断者。能正永断。应作证者。能正作证。应修习者。能正修习。依无欲界于彼一切已知已断已证已修。于所依色及能依名。正知已知。于所依无明及能依有爱。正断已断。于所依明净智及能依解脱。烦恼断正证已证。于所依奢摩他及能依毗钵舍那。正修已修

复次有二法见。一有为法见。二无为法见。有为法见者。谓如有一。于谛依处及谛自性。皆如实知。云何名为谛所依处。谓名色及人天等有情数物。云何为谛。谓世俗谛及胜义谛。云何世俗谛。谓即于彼谛所依处。假想安立我或有情乃至命者及生者等。又自称言我眼见色乃至我意知法。又起言说。谓如是名乃至如是寿量边际。广说如前。当知此中唯有假想。唯假自称。唯假言说所有性相作用差别。名世俗谛。云何胜义谛。谓即于彼谛所依处。有无常性。广说乃至。有缘生性。如前广说。如无常性有苦性等。当知亦尔。若于如是世俗胜义谛所依处。其世俗谛如实了知是世俗谛。其胜义谛如实了知是胜义谛。如是名为有为法见。若有成就有为法见。苾刍齐此言说满足。云何名为无为法见。谓即于彼谛所依处。已得二种谛善巧者。由此善巧增上力故。于一切依等尽涅槃。深见寂静。其心趣入。如前广说。乃至解脱。如是名为无为法见。若有成就无为法见。苾刍齐此言说满足。又此法见当知三种补特伽罗皆得成就。一者异生法随法行已得定心。博识聪敏能如正理观察诸法。二者有学已见谛迹。三者无学诸漏永尽

复次若有希求人天盛事自发誓愿行梵行者当知彼为称赞人天二种过患。何等为二。一者烦恼所生众苦。二者无常所生众苦。云何烦恼所生众苦。谓于人天住境界爱。依现在世故住境界乐。依过去世故住境界欣。于现在世依过去境生爱乐故住境界喜。于未来世依现在境生爱乐故。若于如是三世境中住染污者。当知彼为称赞所欲有匮乏苦。及生老等所有众苦。是名生起烦恼所作众苦过患。云何无常所作众苦。谓顺乐处有背失故。起变坏苦。随顺苦处现在前故。起厌离苦。一切自体于终没时皆灭坏故。有灭坏苦。当知是名三种无常所作众苦。此中如来超过如是二种过患。住一向乐。即于此乐应如实知由此故乐。复应如实知乐方便。云何为乐。谓一切境相应永尽无上安隐。即有余依般涅槃界。云何方便。谓如前说。于五种受发起五转如实妙智。若诸声闻弃舍大师所证超过人天妙乐。希求下劣人天乐者。当知彼于诸智者所。多受毁辱。亦自欺诳

复次嗢拖南曰

  一住远涅槃　　略说内所证
  辩一切智相　　舍所学业等
  空随行恒住　　师弟二圆满

由二因缘。当知名为有第二住。谓有爱故。为欲生起第二自体。受习其因。此自体灭第二自体次生起故。云何有爱。谓诸可爱所缘境界将得现前。最初生起染污欣悦。名有喜乐。从此已后乃至未得于彼。多住作意思惟。设复已得而未受用。于其中间。即由喜乐增上力故。住染欣悦。名有欢喜。于受用时多生贪爱。名有染着故名有爱。又于未来起希求故。及于已得生领纳故。名有喜乐。于过去世随忆念故。名有欢喜。于已获得正受用时。生贪爱故。名有染着。如是名为第二差别。云何生起第二自体。谓喜乐等为集因故。于当来世生老为根众苦生起。与此相违。当知是名无第二住

复次有二种法。更互相违。一者烦恼。二者涅槃。是故安住杂染法已。即便随顺后有而转。若于后有随顺转时。当知说名去涅槃远。复有六种鄙碎士夫补特伽罗鄙碎行相。一者性多忿恚。二者所作不思。三者乐逼恼他。四者若苦所触便发不实粗恶语言。五者或发真实能引无义粗恶语言。六者因此展转发起无量差别恶言。非但少词而生喜足。由二因缘。诸出家者力励受行。速疾能证沙门义利。诸未信者令生净信。其已信者倍令增长。何等为二。一者忍辱。二者柔和。言忍辱者。谓于他怨终无返报。言柔和者。谓心无愤性不恼他

复次以要言之。如来略依二种处所。说无界教。一者说有余依涅槃界教。二者说无余依涅槃界教。若由如是烦恼断故。名成就断。补特伽罗不成烦恼。即由如是不住彼果后有众苦。当知是名说有余依涅槃界教。若由如是不住烦恼后有苦果。即由如是乃至寿尽既灭没已。一切余依都无所有。不住此身。不住余身。不住中有。证得一切众苦边际。当知是名说无余依涅槃界教。略有三种念力强因。一由其年少壮。二由前生串习。三由现法数习

复次由五种相。当知涅槃是内证法。谓离信故。乃至离见审察忍故。如前应知。谓现法中于内各别内外增上所生杂染。如实了知有及非有

复次由三因缘。显示诸佛无上菩提。一者觉了一切境故。二者觉了有及非有如实事故。三者觉了染净二品一切法故。是故他于如是三处。请问世尊

复次诸有为法俱有转时。令心迷乱。能令于相邪取分别。是故如来。为诸弟子分别开示。令于彼相决定悟入。为欲了知真实相故。又为于自无欺诳故。又为于他坦然无畏正记别故

复次诸出家者。弃舍所学增上力故。当知安立顾恋境界。又出家者。毁犯尸罗增上力故。当知安立未出家者弃背趣入心株覆事。远离惭愧故。一向爱味故。若坚执取所缘境界。当知彼名最极爱味。由是因缘。于修上品诸善业中。为心株杌是不调柔。无堪能义。又即由此增上力故。行诸恶行。内怀隐匿所造众恶故。生其覆。如是一切略摄为一。说名于境最极爱味心株覆事

复次若于诸根无护行者。由乐听闻不正法故。便生无明触所生起染污作意。即此作意增上力故。于当来世诸处生起所有过患。不如实知不如实知彼过患故。便起希求。希求彼故。造作增长彼相应业。造作增长相应业故。于当来世六处生起。如是名为顺次道理。逆次第者。谓彼六处以业为因。业爱为因。爱复用彼无明为因。无明复用不如正理作意为因。不正作意复用无明触为其因。又于此中先所造业。是现法受六处之因。现法造业。是次生受六处之缘。或是后受六处由藉。爱等业等随其所应。当知亦尔

复次由二因缘。后有生起。一后有业。二后有爱。而但说言诸有情类随业而行。不言随爱。何以故。略有三爱。一者欲爱。二者色爱。三无色爱。此中欲爱。是不善者虽有异熟。然若不起恶不善业。终不能与恶趣异熟。若欲界爱。于无明触所生诸受。起希求时。于可爱境发生贪欲。于可憎境发生嗔恚。于可迷境发生愚痴。由此三种增上力故。行不善业。由此业故。生诸恶趣。非但由彼贪嗔痴缠定堕恶趣。然即此爱于所造业异熟生时。能为助伴。又由希求可爱境界增上力故。修行善行身语意业。由此为因。得生善趣。此中可爱诸异熟果。但应用业为引生因。非染性爱。又若此爱色无色系。虽非不善。然是染污。一切皆非有异熟果。又即由此色无色爱。名有爱者。彼由听闻正法因故。于其欲界观粗鄙相证得明触而生世间如理作意相应诸受。调伏欲界贪嗔痴等。造修所成善有漏业。由于此间造彼业故。当得生彼。不由于彼染污性爱。然即此爱于所造业。异熟生时。能为助伴。是故但说诸有情类随业而行。不言随爱

复次于外事中。世间假名增上力故。亦说有果及有受者。彼或时空世现可得。或时不空。如果受者。因与作者。当知亦尔。如是名为世俗谛空。非胜义空。若说恒时一切诸行唯有因果。都无受者及与作者。当知是名胜义谛空。应知此空复有七种。一后际空。二前际空。三中际空。四常空。五我空。六受者空。七作者空。当知此中无有诸行于未来世。实有行聚自性安立诸行生时从彼而来。若有是事彼不应生。于未来世诸行自性已实有故。又不应有无常可得。既有可得。是故当知。诸行生时。无所从来。本无今有。是名后际空。又无诸行于过去世。有实行聚自性。安立。已生已灭。诸行往彼积集而住。若有是事。不应施设诸行有灭。过去行聚自性俨然常安住故。若无有灭。彼无常性应不可知。既有可知。是故诸行于正灭时。都无所往积集而住。有已散灭不待余因。自然灭坏。是名前际空。又于刹那生灭行中。唯有诸行暂时可得。其中都无余行可得。亦无别物。是名中际空。当知亦是常空我空。以无我故。果性诸行空无受者。因性业行空无作者。如是名为受者作者二种皆空。作者受者无所有故。唯有诸行。于前生灭。唯有诸行。于后生生。于中都无舍前生者取后生者。是故说言唯有诸法从众缘生能生诸法。又一切法都无作用。无有少法能生少法。是故说言此有故彼有。此生故彼生。但唯于彼因果法中。依世俗谛假立作用。宣说此法能生彼法

复次由五种相。于能顺喜所缘境界。随顺而行。深心喜乐。不如正理。执取其相。发生贪欲。多起寻思。方便求觅。因此广行福非福行。如能顺喜所缘境界。顺忧顺舍所缘境界。如其所应当知亦尔。其差别者。于能顺忧所缘境界。随顺而行。深心厌恶发生嗔恚。于能顺舍所缘境界。随顺而行。深心愚昧发生愚痴。余如前说

复次有诸苾刍。证阿罗汉诸漏永尽。于一切境随顺而行。恒时不堪。乃至失念生诸烦恼。是故恒住无杂染住。由是因缘。说名恒住。彼随行品若喜若忧。若欣若戚。诸阿罗汉皆无所有。乃至善中亦无是事。又彼恒住极难行故。及无罪故。名为最胜。能成就者极难得故。说名第一真实福田。应当奉请。乃至广说。当知如前摄异门分

复次于善说法毗奈耶中。应知大师及弟子众。各由二相其德圆满。云何二相应知大师其德圆满。谓依利他行。欲令悟入诸所有受皆是苦故。说受所依。说彼因缘。说能杂染所有随行。说所对治及能对治师句安立。说一切种究竟出离是名第一师德圆满。又依自利行。宣说不共三种念住无杂染住。是名第二师德圆满。云何二相应知弟子其德圆满。谓于如来无量法教。能了知已而未得到闻之彼岸。若以得到其彼岸者。要为修行法随法行。证得出离。非为受持了知是已如理修行法随法行。非但随说音声语言以为究竟。是名第一诸弟子众其德圆满。如是修行法随法行。不以下劣而生喜足。要当往趣贤敏丈夫所趣之地。定当获得彼所应得。是名第二诸弟子众其德圆满

复次于善说法毗柰耶中。复由三相。应知大师其德圆满。又由二相。应知弟子其德圆满。云何三相应知大师其德圆满。谓佛世尊。为诸弟子。最初施设远离二边中道正行。是名第一师德圆满。又于圣教未生信者。有毁犯者。以正方便令入圣教离诸毁犯。是名第二师德圆满。又于圣教已得入者。由四法摄正摄受之。是名第三师德圆满。云何名为四种法摄。一于秘密以其如法闲静教授。而教授之不以非法。二于违犯以其如法苦切语言。现前呵摈。非不如法。三于寻思依止耽嗜。教令于内勤修寂静。四令时时听闻正法。常无懈废。又令远离相似正法。及令对治弃舍正行。当知即是于其秘密。能引如法闲静教授。于实毁犯若正了知。要当呵摈。方调伏者。以如法言现前呵摈。心无杂染。于寻思者。方便令其易得决了。于诸流荡五妙欲者。示其过患令生厌离。渐次修学乃至证入第四静虑。所有寻思依止耽嗜方能于内究竟寂静。自令无恼。令他摄取。当知是名于时时间听闻正法常无懈废。云何二相诸弟子众其德圆满。谓诸弟子最初忍受大师所见。谓诸法中空无我见。由是因缘。于诸法中不增益我起邪执着。亦不毁坏世俗道理。胜意乐故无所随从。随言说故亦不远离。是名第一诸弟子众其德圆满。又彼于见既忍受已。能正修行法随法行。由四法摄所摄受时。若彼诸法有苦有害。如实了知能速断灭。若彼诸法无苦无害。如实了知能速作证。是名第二诸弟子众其德圆满。如是大师及弟子众之所摄受诸佛圣教。当知一向无染清净。诸聪慧者之所归趣

瑜伽师地论卷第九十二瑜伽师地论卷第九十三

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事缘起食谛界择摄第三之一

如是已说处择摄。缘起食谛界择摄。我今当说。总嗢拖南曰

  立等二谛等　　以触为缘等
  有灭等食等　　最后如理等

别嗢拖南曰

  立苦聚谛观　　摄圣教微智
  思量际观察　　上慢后甚深

略由三相。应知建立缘起差别。一从前际中际得生。二从中际后际得生。三于中际生已随转及趣清净。此中云何从其前际中际得生。及于中际生已随转。谓如有一。宿非聪慧无明为缘。造作增长罪福不动身语意业。由此为缘。随业行识乃至命终随转不绝。能为后世续生识因。如是展转。有内外爱。识生果时。能为助伴。现前而起。既命终已。由前际因。于现在世。自体得生。生已渐次于母腹中。因识为缘续生果识随转不绝。任持所有羯逻蓝等名色分位。后后残胜。始从胎藏乃至衰老。又即此识当续生时。能感生业与异熟果。异熟生识。复依名色相续而转。谓依眼等六依转故。由是说言名色缘识。俱生五根。说名为色。无间灭等说名为名。随其所应。能与六识作所依止。识依彼故。乃至命终数数随转。又五色根根依大种。根处大种。所生诸色。及诸余名。由彼执持所有根等。堕在相续流转不绝。此二总名随转依止。由是故言识缘名色。名色缘识。于现在世犹如束芦相依而转。乃至寿住如是。名为从其前际。中际缘起。诸行得生。于其中际生已随转。当知此中依胎生者说转次第。卵生湿生除在母腹。有余差别有色有情。在欲色界受化生者。于初生时诸根圆满。与余差别。在无色界。诸有情类识。依于名及色种子。名及色种依识而转。由彼识中有色种故。色虽间断后当更生。如是名为此中差别。由福业故。生于欲界人天两趣。由罪业故。生恶趣中。由不动业。生色无色。云何名为从其中际后际缘起诸行得生。云何不生。由不生故证得清净。谓彼如是于中际。生补特伽罗。领受先业所得二果。一者领受内异熟果。二者领受境界所生受增上果。彼由听闻不正法故。或由先世串习力故。于二种果发起愚痴。彼由于内异熟果中有愚痴故。不能如实了知当来后有生苦。由此前际后际无明增上力故。如前造作增长诸行。由此新业。熏变识故。于现法中随业而行。如是无明以为缘故。诸行得生。行为缘故。令识转变。当知此识于现法中但是因性。摄受当生诸识果故。约就一切相续为名。说六识身。又即此识当来后有名色种子之所随逐。名色种子。复为当来后有六处种子随逐。六处种子。复为当来后有诸触种子随逐。此触种子。复为当来后有诸受种子随逐。当知是名于其中际后有引因。由识为先受为最后。遍能牵引诸自体故。如是由先异熟果愚。引后有已。复由第二境界所生增上果愚。缘境界受发生贪爱。由此爱故。或求诸欲。或求诸有。又取欲取。或取见戒禁我语取。取诸取已。爱取和合润先引因转。名为有。是当生起因所摄故。此有无间既命终已。如其引因所引。诸行识为最初。受为最后。或渐次生。或复顿生。如是应知。于现法中。初用无明触所生受为缘生爱。爱为缘故。次生于取。取为缘故。转成其有。有为缘故。当生得生。生为缘故。老病死等众苦差别次第现前。当知此中或有处所生处现前。或有处所种子随逐。如是中际无明缘行。受缘爱等。能生后际缘起诸行。若现法中从他闻法。或于先世已集资粮。由彼为因。能于二种果性诸行。如理思惟。若于彼因。若于彼灭若趣灭行。如理作意。思惟彼故。发生正见。又于诸谛渐次获得有学无学清净智见。彼由如是智见力故。能无余断无明及爱。由彼断故。即彼所缘不如实知。诸无明触所生诸受。亦复随断。由此断故。于现法中。由离无明证慧解脱。又无明触所生诸受。相应心中所有相应贪爱烦恼。彼于其心亦得离系。由离贪故。证心解脱。又即由彼无明灭故。诸有无明犹未断时。依于后际应生行识乃至诸受皆不得生。成不生法。是故说言。无明灭故。诸行随灭。次第乃至异熟所生诸触灭故。异熟所生诸受随灭。又现法中无明灭故。无明触灭。由无明触永得灭故。从无明触所生受灭。由无明触所生诸受永得灭故。爱亦随灭。由爱灭故。如前说名所有取等乃至损恼以为后边。诸行皆灭成不生法。于现法中如是诸行皆不流转。不流转故。于现法中住有余依般涅槃界。名为证得现法涅槃。彼于尔时识缘名色。名色缘识。有余未灭而得说名清净鲜白。乃至有识身住未灭。彼恒领受离系诸受。无有系缚。彼有识身。乃至先业所引寿量。恒相续住。寿量若尽。能执持识。舍所执身。命根亦舍。从此已后。所有命根无余永灭都无所有。又彼诸识与一切受。于此位中。任运而灭。先因灭故。余更不续。亦无余灭。由此道理。名无余依般涅槃界。究竟寂静常住妙迹。为此义故。常随涅槃。常以涅槃为其究竟。于世尊所熟修梵行。是名广说由三种相建立缘起。谓从前际中际流转。从其中际后际流转。复于中际流转清净。

复次安立九相。后有苦树能生当有。谓有世间非聪慧者。于现法中所造新业如小苦树。若彼世间非聪慧者。于能随顺诸漏处所。依现在世随观爱味。依过去世深生顾恋。依未来世专心系着。如是住已。先所未断一切贪爱。由数习故。转更增长。此非聪慧补特伽罗。欲令如是后有小树复加滋茂以贪爱水而恒溉灌。令如前说能感当来取所得果。渐次圆满。若有多闻诸圣弟子。虽造有漏能感当来诸业小树。然于能顺烦恼诸行。无倒随观生灭法性。于断无欲及以灭界。无倒随观是寂静性。损减彼业不令增长。使其爱水亦皆消散故。聪慧者不欲滋荣后有小树。便断其爱。爱缘取等损坏。如是后有小树尚令一切皆无所有。何况使其后更增长。复更有一补特伽罗。已生自体诸先所有造作增长顺后受业。于现法中为其所系。即彼自体及先所造顺后受业。总摄为一。说名后有如大苦树。若于能顺诸烦恼法。如前乃至专心系着。如是住已。彼先所造顺后受业。如直下根令树郁茂。于现法中彼爱烦恼。如傍注道令树润泽。以此为因。令随惑业行一切种子识。于当来世正续生时。住于名色。如是苦树长时安立。当知如是补特伽罗。欲令苦树展转滋茂。此中白品如前应知

复次世尊在昔为菩萨时。弃前所得诸世俗道及世诸师。处菩提座。为欲悲愍利他有情以为上首。自于诸谛起正观察。尔时为欲历观苦谛。由老死支苦谛所摄故。于缘起逆历观察。当知此中由三种相。于其老死如理观察。一者观察细因缘故。二者观察粗因缘故。三者观察非不定故。感生因缘。亦名为生。即生自体亦名为生。前生是细。后生为粗。此中观前细生有故而有老死。亦观由后粗生缘故得有老死。当来老死细生为因。现法老死粗生为因。云何名为非不决定。谓即除彼生处所摄二种生体。余定无能与老死果。如观老死。生有取爱。各由二种如理观察。当知亦尔。如是名为始从老死次第逆观苦集二谛缘起道理。应知此中顺集谛法。犹如灯炷。即此集谛如膏油等。苦谛类灯。诸非聪慧补特伽罗。譬于灌油并集炷者。如是苦灯烧然长世。当知白品与此相违。谓善方便观灭道谛。复有二种补特伽罗。何等为二。一唯行自非利益行。谓但于己集炷灌油。令一苦灯相续久住。二复有余补特伽罗。兼行自他无量大众。非利益行。为然自他大苦火聚。摄受听闻邪法为先。闻思修慧所引邪行。譬如积集干薪干草及干牛粪。由是因缘。令苦火聚长时炽然。无有断绝

复次世尊在昔为菩萨时。处菩提座。依缘起门逆次而入。先缘后际如理思惟老死苦谛乃至其爱。如是观察后际苦谛及后际苦所有集谛。未为喜足。遂复观察后际集谛因缘所摄现在众苦。谓遍逆观受触六处名色与识。当知此中。观未来苦是当苦谛。观彼集因是当集谛。观未来世苦之集谛由谁而有。知由从先集所生起识为边际。现法苦有。既知从先集所生起。不应复观此云何有。是故世尊昔菩萨时。为观当来所有苦集。观现在苦乃至作意相应心识。而复转还。又为渐次观彼后际集谛依处。后际苦谛所依止处。当知即是后际集谛。故乃至识复还顺上。如是顺逆如理观察缘起苦集。从此无间为观灭谛。始从老死逆次第入。乃至无明。何以故。观察如是。现在苦谛云何一切皆悉尽灭。谓不造作无明为缘新业行故。如是历观三圣谛已。次更寻求此灭圣谛何道何行而能证得。由如前说宿住随念。忆昔为求诸漏永尽世间正见。如教授者令现在前作是思惟。我今证得先旧正道古昔诸仙同所游履。如是但以世间作意。历观四谛。又以正见于诸谛中得入现观。次第方便证觉无上正等菩提。现见方便获得无漏有学无学善净智见。为此义故。于三大劫阿僧企耶。修行一切难行之行。今于此义皆已证得。为利他故。哀愍世间诸人天故。随有堪能入圣法者。开四圣谛令生等觉

复次佛世尊教三处所摄。何等为三。一善建立诸缘生法无作用故。二彼为依利他行故。三彼为依自利行故。此中善建立诸缘生法无作用故者。谓从后际苦逆观现法前际苦集。名色缘识。识缘名色。譬如束芦展转相依而得住立。于其中间诸缘生法。皆非自作。亦非他作。非自他作。非无因生。如是施设。名善建立诸缘生法无作用故。所以者何。无常诸行前际无故。后际无故。中际虽有唯刹那故。作用动转。约第一义都无所有。但依世俗暂假施设。如是施设。如实无倒。是故说此名善建立。即依如是善建立性。依诸缘起为他宣说圣谛法教。名彼为依利他行故。即此为依自能趣入圣谛现观。法随法行又能证得现法涅槃。当知是名用彼为依自利行故。又先积集智慧资粮诸弟子众。成就猛利俱生慧故。名为聪慧。具教智故。名为明了。具证智故。名善调伏。不由他缘自觉法故。名无所畏。缘于涅槃如实觉故。名见甘露。尽无生智为所依止。证有余依涅槃界故。名身证。得妙甘露界。具足安住

复次有诸愚夫外道种类。虽能观见四大种身粗无常性。由观此身虽久住立而有增减。死时生时有舍取故。便于其身能厌能离能起胜解。以世间道离欲界欲。离色界欲极至有顶。然彼于身当知仍名未得解脱。所以者何。由于彼彼所得定中。莹磨其识执取为我。杂染而住。复于后时寿尽业尽。还退生下。以于缘起不善巧故。诸圣弟子。虽于缘起已得善巧。而但随观四大种身细无常性。未即观察识无常性。所以者何。四大种身经久时住常相可得。刹那相似相续随转。其无常性难可得故。识无常相粗显可得。刹那刹那所缘易脱。其相转变无量品类有差别故。虽即此识无常性相。无量品类粗显易得。然复说名最极微细。当知其性难可识故。难可入故。所以者何。唯是慧眼所见境故。四大种身有增有减有舍有取。其无常性尚为非理肉眼境界。况其余眼缘起善巧。诸圣弟子复欲悟入最极微细识无常性。即于缘起如理思惟。由能分别堕自相续触所生起诸受分位差别性故。便能悟入识无常性。彼既成就如是智见。渐次于受所依止身。所因诸触及余一切名所摄行。皆能厌离生于胜解。亦得解脱。得解脱故。安住毕竟若有余依若无余依二涅槃界

复次于缘起法善巧苾刍。由三种相。于其三际。能正思量正能尽苦。云何三相。一苦依处。二苦因缘。三苦因缘依处。是名三相。云何三际。一者中际。二过去际。三未来际。是名三际。当知此中内身苦依。是寒热等及病死等众苦差别现法生起之所依处。何以故。由有此故。于所依身彼得生故。外父母等亲属朋党。摄受苦依。是供侍等执持刀杖以为后边。忧愁叹等众苦差别之所依处。何以故。如前说故。此二种依用摄受爱以为其因。由似集爱此依生起。名苦因缘。又即此爱依止可乐妙色境界以为依处。方乃得生。说彼名苦因缘依处。又诸所有现在境界。贪嗔痴火热恼为因令生燋渴。由是遂饮。譬如杂毒可乐。妙色所缘境界甘美之饮。不能弃舍。转增渴爱。由渴爱故。有当来依。当来依故。便有众苦。如是当知。由第一义。名为趣死。即由如是现在道理。应当了知去来道理。当知是名能正思量中去来际。又即依止四种言说。应知一切所依三量。若见若知二种言说是依现量。若觉言说是依比量。若闻言说依至教量

复次由五种相。正勤方便观察缘起。能尽众苦能作苦边。何等为五。一者观察诸缘生法生起因缘。二者观察彼灭因缘。三者如实了知能趣彼灭正行。四者修行法随法行。五者于证离增上慢。如是名为善起观察及果成满。始从未来依因缘苦。逆次乃至识缘名色。由四种相。观察通达修习正行。谓由二相观察当来。因有故果有。因无故果无。既观察已通达因无。由修正行。既通达已随正修行法随法行。又正观察于现法中。无明为缘福及非福不动新业因法有故。随福非福不动业行果识等有。彼非有故。此亦非有。既观察已。如前通达。及正修行。正修行时。不造无明为缘新业故业。触已速能变吐。于现法中证得如前现见圣道。道果涅槃。彼于尔时譬如陶师。举烦恼火随眠烝热。随有识身熟烝热瓮。置极清凉涅槃岸上。令离一切烦恼烝热。又令如瓦有识身摄依得清凉。应知如前领受所有身边际受。乃至广说。未舍命来常处恒住。终不退失阿罗汉果。亦不能造无明缘行。云何于证离增上慢。谓彼尔时成就能缘缘起妙善清净智见。作是思惟。依胜义谛无流转者。无涅槃者。唯有彼彼法生故。令彼彼法生。彼彼法灭故。令彼彼法灭

复次略有二种增上慢者。一于有学增上慢者。二于无学增上慢者。若于有学增上慢者。彼告他言。我已渡疑永断三结。我于所证有学解脱。已离犹豫。已拔毒箭。已能永断萨迦耶见以为根本一切见趣。若于无学增上慢者。彼告他言。我无有上。所应作事所应决择。我皆已作。如是二种。或依缘起。或依涅槃。又依圣说而起说时。谓说甚深出离世间空性相应缘性缘起顺逆等事。于其所说不能觉了。不随悟入。由此二种因及缘故。于如实觉发起狐疑。于自相续烦恼永断涅槃作证。亦生犹豫。所以者何。由于有学增上慢者。计我我所。常所随逐随入作意。微细我慢。间无间转不能了达。又奢摩他任持相续。防粗烦恼。令不杂乱。由是因缘。彼于未得生已得想。于未防护。生已护想。便告于他。又于无学增上慢者。彼自谓言。我已寂静。我已涅槃。我已离爱我已离取。于此未断微细现行诸增上慢。不能了达。于所未得生已得想。于未防护生已护想。便告于他。又于无学增上慢者。当知决定先于有学起增上慢。无有实义。诸有学者。于上无学起增上慢。所以者何。非彼相续烦恼现行。如是缠心坚牢而住。由此因缘。于所未得生已得想。起增上慢。坚固执着经多时住。或告于他。唯有失念。狭小暂时烦恼现行。寻复通达速能远离。又彼如是或由先时于所未得起得增上慢故。或由今时于其所得生疑惑。犹豫坏其心故。便生忧戚。作是思惟。若我所证无所有者。他之所证亦应无有。如是便生谤圣邪见。受恶趣因。获大衰损。云何如前圣说甚深。谓能开示甚深缘起。究竟涅槃。三相相应有为无为体性差别。有为无常。无为常住。诸行皆苦。涅槃寂静。一切有为总唯是苦。及唯苦因。一切无为总唯众苦。及因永灭。若诸苾刍。于现法中得涅槃者。永断后有众苦因道。令当来世所有苦果究竟不转。入无余依般涅槃时。后苦不续。先因所引现在苦依。任运而灭。至苦边际。此中都无先流转者。亦无于今般涅槃者。若能开示如是义言。当知名为如前所说圣说甚深

复次缘起本性最极甚深而有一。能开示令浅当知此。由二因缘故。一由大师善开示故。二即由此补特伽罗成就微细审悉聪敏博达智故。若说若听。是诸句义应知。如前摄异门分。当知此中诸缘起法。略由四相最极甚深。何等为四。一由微细因果难了知故。二由无我难了知故。三由离系有情而有系缚难了知故。四由有系有情而离系缚难了知故。云何微细因果难可了知。谓依观察圣谛道理。始从老死乃至识缘名色所有有支。有缘体性。云何名为有缘体性。谓于是中有因缘生。未永断故。而有生生。生既生已。唯当希待后时老死。当知此中生之因缘亦名为生。因缘所起亦名为生。有前生故。而有后生。有后生故。而有老死。此中前生是后生因。亦老死缘。后生唯是老死之缘。如是一切聪摄为一。略说名为生缘老死。当知是名初老死支有缘体性。如说生支如是。有支取支安立。当知亦尔。取差别者。谓无差别欲贪名取。取之差别安立有四。如是爱支或求欲门发起诸业。或求有门发起诸业。此二业门所有诸爱。当知归趣爱非爱受。又即此爱由六处门。所起无明触所生受为缘故转。复有余受非此爱缘。谓明触所生。及非明非无明触所生。又即此受当知。一切皆用相似触为其缘。此复云何。谓明无明相应是增语触。与此相违。是有对触。又此明触及无明触所随增语触。如其所应当知。彼用听闻正法或不正法。于所缘境。若正若邪闻思修智相应诸名。以为其缘。非明非无明触所摄有对触。当知彼用若内若外诸色为缘。如是总名名色缘触。又即六处略为二分。谓名及色。与触为缘。当知此中。意处非色与余非色诸法相应如是一分。说名为名。诸余色处总为一分。说名为色。又此名色于现法中由续生识为缘牵引。及能执持令不散坏。又即此识续生已后依名色住。或于同时或无间生。依彼而转故。于现法此亦用彼名色为缘。应知先业所引名色与识展转相依。展转为缘如是。当知识缘名色以为后边。所有有支随老死相。如前所说。随其所应有缘体性。如是名为微细因果难可了知。难了知故。当知缘起名为甚深最极甚深。云何无我难可了知。谓诸因果安立缘起。齐尔所事。遍于一切有情众中。起无差别有情增语。即此增语应知是路。依此处所有言辞转施设各异有情众别。谓鸟鱼蛇蝎人天等类。又立各异名字差别。谓鹦鹉。舍利。孔雀。鸿雁。多闻。持国。增长。丑目。舍利子。极贤善。给孤独。一切义成等名字差别。齐尔所事。于诸世俗言说士夫有言论转。谓诸所有受若明触所生。若无明触所生。若非明非无明触所生。如是一切与名色俱。若诸名色无余永灭。所有诸受无容得生。当知是名无我缘起难可了知。云何离系有情而有系缚难了知性。谓如外道触对无明触所生受。由三门故。于其无我缘生诸行。分别有我起见施设。云何三门。一于欲界未得离欲。于欲界系三种受中。妄计一分为明我所。妄计一分为受者性。分别有我起见施设。二于欲界已得离欲。第三静虑未得离欲。唯于乐受计有所得。即妄计此为明我所。计此受外别有实我。是能受者。起见施设。谓即此我是有受法。即用彼受领纳其受。三于第三静虑已上不苦不乐微细诸受。不能通达分别有我。谓于诸受都非受者。起见施设。如是一切由三种门所起我见。皆不应理。所以者何。以三种受皆无常故。其所计我应亦无常。是故彼见三受为我。不应道理。又于第四静虑已上都无乐受。其中亦无能受乐者。计我于彼由乐受故名有受法。不应道理。又于第四静虑已上无色定等。彼所计我应无觉受。彼由寂静定所生受。发起我慢。谓我寂静。此慢应无。然有此慢。是故此计亦不应理。当知是中若诸缘起非甚深者。彼应无有。如是无智妄计失坏内法。多闻诸圣弟子。触对明触所生受故。了知一切所起我见皆不应理。是故观见诸法无我。彼于世俗及胜义谛。皆得善巧。于如前说如来灭后若有若无乃至非有非无。皆不执着。于如是事。心得解脱。设有来问如是为有。如其所应而不记别。如是为无俱及俱非。皆如所应而不记别。如是彼由妙智为先而不记别。或有谓言是无知者。当知此是极大无智。极大邪见。又彼如是见行外道。于现法中依如前说三种妄见或施设我是其有色。或施设我是其无色。或施设我以为狭小。或施设我以为无量。如现法中妄分别我是真可得起见施设。如是当来分别起见为他施设。当知亦尔。虽有多种妄分别我。然唯一类萨迦耶见随眠所系未断彼故。虽由下劣诸世俗道。渐离系缚。乃至有顶。当知即彼犹名系缚。如是名为以诸缘起善巧妙智能随悟入。离系有情而有系缚难了知性。云何名为有系有情而离系缚难了知性。谓有多闻诸圣弟子。触对明触所生受故。于现法中不得实我。亦不施设。身坏已后亦不于彼七识住中施设一切有情众。已复于其下续生识处。又复于彼生起识处。彼于识住及于二处。以诸缘起圣谛道理。如实观时。成阿罗汉或慧解脱或俱解脱。具八解脱静虑等至。彼于现法虽可现见有生老死。然名从彼而得离系。虽复现见领纳诸受。然名于受而得离系。虽复现见有识名色。然名于彼而得离系。如是名为以诸缘起善巧妙智如实了知。有系有情而离系缚难了知性。由此四相。应知缘起名为甚深最极甚深

复次嗢拖南曰

  异世俗胜义　　法尔此作等
  大空与分别　　自作为其后

于此正法毗奈耶中。虽复愚智俱从前际至于中际。并由二种根本烦恼。集成如是有识之身。此身为缘于外所有情非情数名色所摄所缘境界。领纳三受。然其智者。于彼一切前中后际。与彼愚者大有差别。当知此中。于其中际有差别者。谓由二种根本烦恼。集成如是有识之身。于现法中。此二皆断。断此二故。于当来世。无复有彼识所随身。是即名为后际差别。问何缘智者成智者性。答于现法中所有集谛。及于后际所有苦谛。皆离系故。问何缘愚者成愚者性。答于断彼二。无力能故。曾习圣教。名为智者。先已寻求智资粮。摄诸梵行故。于其圣教曾未修习。名为愚者。彼相违故。当知是名智者愚者前际差别

复次于诸缘起。善巧多闻诸圣弟子。如实了知世俗胜义二谛道理。如实知故。于现法中有识身等所有诸法。了知无我。终不执彼为我我所。由于胜义得善巧故。无是邪执。于堕诸行相续自业所作有情。如实了知无有展转所能作者。亦无不作有吉祥义。了知是已。遂正勤修烦恼离系。由于世俗得善巧故。远离所有增益不实损减实事。彼现法中。于有识身先所造作。思所祈愿。思所建立。由誓愿故。即以闻思所成妙慧。缘起善巧为所依止。用奢摩他毗钵舍那修所成行。能随悟入。又于识触受想思身。历观为苦。又于爱身差别观时。当知即是观察集谛。彼于二谛有生灭智。如实了知。由因集故。如其所集。由因灭故。如其所灭。谓由定地世间作意。修习如是作意因缘。入谛现观。彼于先时。于世间集及世间灭。由闻思慧。说名善见。亦名善知。由修慧故。名善思惟。今于圣谛入现观时。名为善了。亦名善达。由尽所有如所有故。随其次第。彼于尔时。由闻思慧。名趣正法。由修慧故。名近正法。由谛通达。名证正法。又由趣由近正法故。名到源底。由证正法故。名遍到源底。又有学慧。名入世间出没妙慧。此无漏故。圣相续中而可得故。名为圣慧。能尽能出一切烦恼及诸苦故。名出离慧。最极究竟能通达故。名决择慧。彼既成就如是妙慧。复作是思。我当进断后诸所有一切烦恼。即于此事多修习故。于修道中。出余烦恼。尽一切苦。如是显示从初业地乃至获得阿罗汉果所有正道

复次由二因缘。于诸缘起及缘生法。建立二分差别道理。谓如所流转故。及诸所流转故。当知此中有十二支差别流转。彼复如其所应。称理因果次第流转。又此称理因果次第。无始时来展转安立。名为法性。由现在世。名为法住。由过去世。名为法定。由未来世。名法如性。非无因性故。名如性。非不如性如实因性故。名实性。如实果性故。名谛性。所知实性故。名真性。由如实智依处性故。名无倒性。非颠倒性。由彼一切缘起相应文字。建立依处性故。名此缘起顺次第性。又此二种善巧多闻诸圣弟子。于三世中如实了知。远离一切非理作意。于诸圣谛。能入现观。于诸外道诸见趣中。能得离系。如前趣等。广说应知。又彼缘起无始时来因果展转。流转相续。如来于此流转实性。现等觉已。以微妙智。起正言词。方便开示非生非作。当知此中无始时来。因果展转。法住法性。由彼相应名句文身。为令解了随顺建立法住法界种性依处

复次由二因缘。此作。此受。余作。余受。不应记别。云何为二。一者因果相属一故。诸行相续前后异故。二者所余作者受者不可得故。若于此论不受不执。以中道行如唯因果而正记别。亦无过失

复次一切无我无有差别。总名为空。谓补特伽罗无我。及法无我。补特伽罗无我者。谓离一切缘生行。外别有实我不可得故。法无我者。谓即一切缘生诸行性。非实我。是无常故。如是二种。略摄为一。彼处说此名为大空。谓若有离世俗言说妄见为依。起如是见。立如是论。谓有别物异缘生法。或缘生法异彼属彼。此依妄见非住梵行。何以故。由如是见依止初空所治见转。非此见者应解脱故。或复即于名色所摄缘生法中。依如前说三种妄见。起如是见。立如是论。命即是身。乃至广说。如是亦非安住梵行。何以故。由如是见依第二空所治见转非此见者。应解脱故。远离如是二邪见边。唯见因果名中道行。所知真如。名如实性。能知真如。名无倒性。于有诸行。假施设有。谓是诸行。诸行属彼。若依胜义有如是者。彼一切行若灭若断。云何可说此是诸行。或行属彼。由于尔时如是二种不可得故

复次由二因缘。当知施设所有缘起一切种相。谓总标举。或别分别。云何为二。一如所有性故。二尽所有性故。云何如所有性。谓无明等诸缘生法。渐次相称因果体性。及有此因未断故。有彼果未断。此未断因生故。彼未断果生。如是名为如所有性。云何尽所有性。谓无明等诸缘生行一切种相。如彼无明。是前际无智。乃至广说差别体相。广分别名。应知如前摄异门分。建立分别。如前应知。如是名为尽所有性。即依如是如所有性尽所有性。若总标举。若别分别。先总标举。说名为初后。即于此复广开示。说名分别

复次由二因缘。自作苦乐。不可施设。不可记别。如是他作。俱作。俱非所作。无因而生。当知亦尔。云何为二。一者诸行如前所说无作用故。二者有余作者有情不可得故。此中诸行无作用故。此受此领自作苦乐。不应道理。又彼有余作者有情不可得故。余受余领不应道理。受所渴爱摄受他受。亦不应理。有诸缘故。诸受得生故。无因生亦不应理。是故远离前之三种恶因论边。后之一种无因论边。觉了如前中道行教。勤修正行能尽众苦

瑜伽师地论卷第九十三瑜伽师地论卷第九十四

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事缘起食谛界择摄第三之二

复次嗢拖南曰

  触缘见圆满　　实解不爱乐
  法住智精进　　生处等为后

于一切触缘受有中。若诸沙门或婆罗门。

宣说无因恶因论者。如前请问。此作此受。乃至广说。安住正法大师弟子。若胜若劣。略有三种无倒记别。一开自宗记。二伏他宗记。三有执无执杂染清净记。当知此中。于彼所问无差别记。谓诸苦乐皆从缘生。是我宗致。斯则名为开自宗记。若于彼问作如是记。诸计苦乐自作他作俱作俱非无因而生。于一切处由触生受。何用妄计自他作等。若触因受现不可得。更求余因可为巧妙。然触因受。既现可得故。求余因非为巧妙。如是记者。是则名为伏他宗记。所以者何。由二因缘。彼为摧伏。一者除唯根境识合。不能显示余作者故。二者不能诽拨一切世间现量如理所得触因缘故。又彼不能立自宗故。亦复不能破他宗故。名被摧伏。若于彼问作如是记。我亦唯依根境界识。假立自作他作俱作。若苦若乐。而于实我都无所执。汝于此中有邪执着故。不随许。所以者何。若有执着即为杂染。若无执着即为清净。云何名为若有执着。即为杂染。谓彼世间不聪慧者。若于前际有所执着。无明缘行。广说如前。便于中际苦乐杂染。若于中际有所执着。彼亦如前。当于后际苦乐杂染。云何名为若无执着即为清净。谓聪慧者。若于前际或于中际。不于诸行执我我所。彼于前际。诸受因灭已。般涅槃。或于后际。诸受因灭。当般涅槃。是名第三有执无执杂染清净记

复次若有弃舍无因恶因。于因生法五种因中。获得正见。名见圆满。于此正法及毗奈耶。不可转故。亦得名为成正直见。由于涅槃意乐净故。亦名成就于佛证净。于所知境。智清净故。由此三缘。如其次第。名于正法趣向亲近。及与正证。云何名为从因生法五种因耶。一恶趣因。谓诸不善及不善根。二善趣因。谓一切善及诸善根。三于识住令识住因。谓四种食。四现法后法杂染因。谓一切漏。五清净因。谓谛缘起。若有于此诸因自性。如实了知是其自性。于此因缘。如实了知是其因缘。于因缘灭。如实了知真实是灭。于趣灭道。如实了知真实是道。名见圆满。观缘生事乃至无明为边际故。过此更无缘生因。观唯由此。观自义究竟

复次略有三种。于现法中。真实寂灭。乃至寿量未永止息。恒相续转所知境事。于彼有学正修行时。施设学性。于彼无学作是思惟。我一切尽不复当尽。尽无生智所思择故。名思择法。云何为三。一六处。二六处缘触。三触缘受。当知此中。所有多闻诸圣弟子。随所领受。即于彼受如实遍知。又即于彼厌离。欲灭勤修正行。又能如实了知彼受触所引生。触复由彼六处引生。即于彼触引因六处。厌离欲灭勤修正行。又于彼受触及六处。一切实事。略摄为一。了知一切由无常灭名灭法。已于现法中。于此一切三种实事无常灭法。如前修行厌离欲灭。由此正行。名学常委。又由修行此正行故。无所造作。究竟解脱。是故说名择法常委。为欲证得曾所未得。曾所未证。修行无间殷重方便。名学常委。为于所有现法乐住。无有退失。无间所作。殷重所作。由是说名择法常委等。说一切事法增上名句文身。名为法界。诸有获得无碍解故。名句文身随欲自在。是故说名善达法界。由于法界善通达故。即于如是真实想义。更以余名随其所乐。差别宣说。乃至能于七日七夜或过彼量。辞辩无竭。复以如是差别种类。如实宣说。彼是有为思所造作动转。羸顿如病如痈。乃至广说

复次当知。具解诸阿罗汉。略有六种记别所解。一有异门记别。二无异门记别。三智记别。四断记别。五总记别。六别记别。有异门记别者。谓如有一或他请问。或复自然为欲令他于佛圣教多起恭敬故。如是记。我于今者无一疑惑。无异门记别者。谓作是记。我生已尽。乃至广说。智记别者。谓有问言。云何知故。云何见故。彼生已尽便记别言。生缘尽故。彼生已尽。以如是相。记别自己善解脱智所摄尽智。名智记别。又即于此别记别者。谓即记别彼因缘有。又复记别彼生因缘因缘诸取。又复记别此诸取相。如实知故。如实见故。令取无有。总记别者。谓即于此一切所记。了知所有诸受皆苦。既了知已令彼生尽。如是记者。名总记别。断记别者。谓即由彼内解脱故。一切贪爱因缘皆尽。如是记者。名断记别。此断记别。即如前说名别记别。此总记别。当知略由三种行相。谓薄伽梵所说诸结。我皆无有。是名最初断总记别。谓诸有结皆永断故。又我安住如是正念。由我安住此正念故。一切贪忧恶不善法能令毕竟不漏于心。是名第二断总记别。谓恒住故。又于此中自无憍慢。是名第三断总记别。谓无有余增上慢故。如是总说有六记别

复次有三种法。是诸世间所爱所乐。依内而说。一者势力。二者妙色。三者寿命。复有违害如是三法。能引所治不可爱乐三种别法。一者疾病。二者衰老。三者夭没。若于三学起邪行时。便不堪任超越疾病衰老夭没。若于三学起正行时。即能超越如是三事。云何三学。一增上戒学。二增上心学。三增上慧学。云何名为依止所有增上戒学起诸邪行。谓如有一。于初学中有所毁犯。或观于自或观于他无有羞耻。既自安住无羞耻已。便于一切恶不善法。不自防护。既于彼法不自护。已于佛法僧不起恭敬。于诸所学教授教诫。都无敬忌。由是因缘。若于此事他正谏举。便于彼言不能忍受。自亦于彼默不与语。于处非处能正谏举补特伽罗。憎背远避。于行邪行同己法者。亲近交游。好共安止。由与恶友共安止故。于诸贤圣尚生憎背。况当诣彼躬申敬觐。设复往彼为说正法。憎背圣故。而不欲闻。设暂属耳心无敬顺。唯怀违诤不为知解。而有听闻于处非处分别正行诸智论中。不乐安住。彼由内怀违诤心故。虽有听闻。而不信受。亦不依行。又诸贤圣默不与语。作是思惟。如是行者不堪与语教授教诫。彼既自然无法自制。又为贤圣之所弃舍。于其内心恒不寂静。外身语意猥杂而住。勃恶贪婪强口憍傲。于如是事不见过罪。多所毁犯不如法悔。由数习故。渐次毁犯一切尸罗。当知是名依止所有增上戒学起诸邪行。与此相违。当知即是依止所有增上戒学所起正行。云何名为依止所有增上心学起诸邪行。谓于行时不如正理。执取境界诸相随好。由是因缘。发起妄念。即于其中不观过患。烦恼生已坚执不舍。由是因缘。不正知住。或于住时居远离处无有第二。即以忘念不正知住为所依止。心外驰散。如是名为依止所有增上心学起诸邪行。与此相违。当知即是依止所有增上心学所起正行。云何名为依止所有增上慧学起诸邪行。谓如有一。离近贤圣。依近恶友。闻不正法。胜解为因。不如正理思择诸法。于诸恶欲及诸恶见。喜乐受行。或于广大所学所得微妙法中。而自轻蔑。如是名为依止所有增上慧学起诸邪行。与此相违。当知即是依止所有增上慧学所起正行。此中异生补特伽罗。依止如是三种学中所起邪行。无有堪能超异生地。无倒趣入正性离生。永断三结。由不永断三种结故。无有堪能依止修道得阿罗汉。于现法中无余永断贪嗔痴等一切烦恼。超越当来疾病衰老及以夭没。与此相违。当知即是于三学中。如实正行一切白品。广说乃至。超越当来疾病衰老及以夭没

复次若有苾刍。具净尸罗。住别解脱清净律仪。增上心学增上力故。得初静虑近分所摄胜三摩地。以为依止。增上慧学增上力故。得法住智及涅槃智。用此二智以为依止。先由四种圆满。远离受学转时。令心解脱一切烦恼。得阿罗汉。成慧解脱。此中云何名法住智。谓如有一。听闻随顺缘性缘起无倒教已。于缘生行因果分位。住异生地。便能如实以闻思修所成作意。如理思惟。能以妙慧悟入信解苦真是苦。集真是集。灭真是灭。道真是道。诸如是等如其因果安立法中所有妙智。名法住智。又复云何名涅槃智。谓彼法尔。若于苦集灭道。以其妙慧。悟入信解是真苦集灭道谛时。便于苦集住厌逆想。于灭涅槃起寂静想。所谓究竟寂静微妙。弃舍一切生死所依。乃至广说。如是依止彼法住智。及因于苦若苦因缘。住厌逆想。便于涅槃能以妙慧悟入信解。为寂静等。如是妙智。名涅槃智

复次于善说法毗奈耶中。诸聪慧者。正观六种圆备。现前足能发起勤精进住。云何名为六种圆备。一大师圆备。二圣教圆备。三圣教易入圆备。四证得自义无上圆备。五一切如理无间宣说圆备。六有圣言将圆备。云何名为大师圆备。谓诸如来成就十力四无所畏如是等。名大师圆备。云何名为圣教圆备。谓自称言。我今已处大仙尊位。能转梵轮。于大众中正师子吼。开示一切顺逆缘起寂灭涅槃如是等。名圣教圆备。云何名为圣教易入圆备。谓此圣教所有文句。其性明显其义甚深。由此圣教能正开发诸甚深义故。说文句其性明显其义甚深。如是名为圣教易入圆备。云何名为证得自义无上圆备。谓无沙门或婆罗门。于如来所。能正开觉通慧为胜。是故于他证得自义所应得义。所应觉义。唯有如来所说法教。为妙为上。若过于此言辞路绝。如是名为证得自义无上圆备。云何名为一切如理无间宣说圆备。谓诸如来所说法教。普为一切人天开示无倒。开示于一切法。不作师卷。无遗开示。如是名为一切如理无间宣说圆备。云何名为有圣言将圆备。谓有能断一切疑惑。及能生起一切善根。一切善法所依大信。现量可得安足之所大师现前。如是名为有圣言将圆备。诸聪慧者。正观此六圆备。现前足能发起勤精进住。于三学中。依增上戒修习瑜伽。依增上心修不放逸。依增上慧于大师教。修瑜伽行。若有安住懈怠心者。当知希求二种过患。一者希求现法当来能生众苦一切烦恼杂染。忧苦不安隐住。二者希求退失所有未证已证一切善法。退失能引能往善趣涅槃大义。与此相违。勤精进者。当知希求二种胜利。此精进者。于诸善法未证能证无退失时。能办自义他义俱义。云何名为能办自义。谓出家已。由其二相。说名有果。一者证得烦恼离系究竟涅槃。谓离系果。二者能起世间胜乐。谓往善趣乐异熟果。云何名为能办他义。谓广为他宣说法要。令其能往世间善趣。究竟涅槃。云何名为能办俱义。谓自修治净福田。性堪任受用从净信边所得如法衣服等事。由此受用摄养己身。令其能顺一切善品。又能令他于己所作得大果报。谓于当来往善趣故。得大胜利。谓当获得财宝仆从皆圆满故。得大荣盛。谓当获得寿命色力乐辩才等自圆满故。得大修广。谓即于上所得三处。长时随逐无间断故。由四种相。应知世尊所说圣教名善说法。一能趣寂静。能令证得有余依涅槃界故。二能般涅槃能令证得无余依涅槃界故。三能趣菩提能令证得声闻独觉无上正等三菩提故。四善逝分别最极究竟现量所显无上大师所开示故

复次具四圆满能生圣处。若随有一成此圆满。于善说法毗奈耶中。正修行时。名曰善来善出家者。云何名为四种圆满。一增上意乐圆满。二根圆满。三智圆满。四即于圣处有佛出世得值圆满。增上意乐圆满者。谓如有一。于般涅槃。极净修治增上意乐。方乃出家。非为债主及诸怖畏之所逼迫。乃至广说。当知如是而出家者。名善出家。生于圣处。根圆满者。谓如有一。眼耳无阙。非半择迦。不缺支分。由得如是根无缺故。于善说法毗奈耶中。堪任出家说正法。时堪能听受。智圆满者。谓如有一。性不愚戆。无有下品愚痴障故。亦不喑哑。无有中品愚痴障故。非手代言。无有上品愚痴障故。离三种智愚痴障故。有力能解善说恶说所有法义。即于圣处有佛出世得值圆满者。谓如今时有薄伽梵释迦牟尼出现于世。是为如来应正等觉。乃至广说。若广解释。应知如前摄异门分。宣说正法。趣寂静等广说如前。当知此中生圣处故。名为善来。善得出家。根无缺故。不愚戆故。不喑哑故。亦不以手代其言故。名善获得具足人身

复次其于缘生诸行流转修观行者。略有二种作犹豫法。云何为二。一者承习说无因论。二者承习说恶因论。此中承习无因论者。观一切种皆无所因。便生疑惑。云何诸法无因而转。其有承习恶因论者。亦生疑惑。云何由彼不相似因不称理因。有诸法转。若有多闻诸圣弟子。远离二种非真实论。正观流转由是因缘。得善决定。无有疑惑。内证真实。若于是处。说有多闻诸圣弟子。当知此中是诸异生。若于是处。唯说有其诸圣弟子。当知此中说已见谛

复次于正法中。略有三种补特伽罗。犹有苦恼不安隐住。云何为三。谓如有一。于善说法毗奈耶中。为求涅槃。趣向涅槃。弃舍家法。趣于非家。既出家已。唯能受持所有禁戒。便喜足住。不于时时转。进修习增上心学增上慧学。彼舍先时居家所有受用境界。未能随得无上安隐证涅槃道。处在中间。犹有苦恼不安隐住。是名第一补特伽罗。复如有一。虽不唯于所受禁戒喜足安住。然其未能超异生地。由未能超异生地故。于一切法缘藉他故。常视他面。常观他口。何当如实知于所知。见于所见。恒于他所求闻正法教授教诫。然其自心有疑有惑。犹有苦恼不安隐住。是名第二补特伽罗。复如有一。是学见迹。放逸而住。于现法中不堪证得究竟涅槃。有能摄受第二有体生起之因。有第二住。犹有苦恼不安隐住。是名第三补特伽罗。如是三种补特伽罗。复有三异补特伽罗。有诸快乐善安隐住。谓阿罗汉一向乐住

复次嗢拖南曰

  有灭若沙门　　婆罗门受智
  流转与来往　　佛顺逆为后

诸学见迹。虽于有灭寂静涅槃。不随他。信内圣慧眼。自能观见。然犹未能以身触证。譬如有人热渴所逼。驰诣深井。虽以肉眼现见井中离诸尘秽清冷美水。并给水器。而于此水身未触证。如是有学虽圣慧眼现见所求后烦恼断。最极寂静。而于此断身未触证

复次有诸沙门若婆罗门。于贪嗔痴无余断灭。真沙门义婆罗门义。全未证得。而诸世间起沙门想婆罗门想。彼亦自称是真沙门真婆罗门。世间于彼虽起是想。然彼但是世俗沙门。及婆罗门。非第一义。若第一义诸有沙门及婆罗门。皆不忍许彼为沙门及婆罗门。所以者何。由彼不能如实了知诸杂染法。杂染法因。亦不如实了知彼灭趣彼灭行。杂染法者。谓老死支所摄众苦。及以生支。杂染法因。复有二种。一爱所作。二业所作。爱所作者。谓由缘起逆次道理有取爱支。若无明触所生诸受。若无明触及无明界所随六处。业所作者。谓由缘起逆次道理名色识行。及即于彼不如实知。如法住智尚未能了。况当如彼谛现观时能遍了知。或如修道未遍了知。如无学地未能超越

复次略由二种明触生法。于其缘生一切行中。依四谛理。趣入现观。云何为二。一由领纳所缘为性明触生受。二由简择所缘为性明触生慧。当知此中于十一支安立四谛。依此一一支谛。建立四十四事。即依明触所生诸受。宣说如是四十四种受事差别。即依明触所生诸慧。宣说如是四十四种智事差别。此中后际所作老死。唯果非因。于其前际所发无明。唯因非果。其余有支。亦因亦果。三时遍智有差别故。如前所说。决定遍智有差别故。由法住智所摄能取智。无常性有差别故。当知建立七十七种智事差别。如是显示历观诸谛一切行相。从此无间入谛现观。渐次修习。乃至获得阿罗汉果

复次由三种相。于缘生行。应正了知流转渐次。何等为三。一因增益故。二果生起故。三果增集故。如是一切略摄为一。总名诸法。若增。若生。若集。依因果灭。如其所应当知。说名若减。若灭。若没。如是意趣差别道理。不违法性。复有别义。初中后际时差别故。欲色无色界差别故。如其次第。若增。若减。若生。若灭。若集。若没。应正了知

复次当知略有二种杂染。一业爱杂染。二妄见杂染。此二杂染依于二品。一在家品。二出家品。应知此中业爱杂染所造作故。名思所作。妄见杂染邪计起故。名计所执。此中异生若在家品。若出家品。具二杂染。由诸缠故。及随眠故。因彼所缘。于四识住。令心生起诸杂染已。招集后有。循环往来不得解脱。有学见迹妄见杂染已永断故。唯有我慢依处习气。尚有余故。不造新业。不欣后有业爱杂染。无有诸缠能为杂染。唯有随眠依附相续能为杂染。因彼所缘。于诸识住。杂染其心。招集后有。若诸无学。二种杂染缠。及随眠。皆永断故。即现法中。于诸识住。其心杂染。及与当来所招后有。一切皆无

复次过去诸佛为菩萨时。如理思惟缘起法已。证觉无上正等菩提。今薄伽梵亦于缘起正思惟已。证觉无上正等菩提。如过去佛得菩提已。即于缘起作意攀缘顺逆道理。方便随修。现法乐住已。住安乐。今薄伽梵。亦复如是。彼虽无量。如说世间七劫相似故。唯说七。如是无上正等菩提。尚犹如实知缘起故。未证能证。证已获得现法乐住。况余下劣所有菩提。又为如实等觉缘起摄受五支。为断方便。如前应知。又此缘起总略义者。谓依转品有因诸苦。又依还品有因无漏所有诸法。又有因苦因缘诸漏。又彼诸漏所依止性从无明触所生诸受。又有因法住立因缘。则现法中烦恼断者。唯有依缘。又复依于七种清净渐次修集。为得无造究竟涅槃。应知宣说随顺如是缘性缘起甚深言教。云何名为七种清净。一戒清净。二心清净。三见清净。四度疑清净。五道非道智见清净。六行智见清净。七行断智见清净。云何名为如是清净渐次修集。谓有苾刍。安住具足尸罗。守护别解脱律仪。广说应知。如声闻地。彼由如是具尸罗故。便能无悔。广说乃至。心得正定。渐次乃至具足。安住第四静虑。彼既获得如是定心。渐次乃至质直调柔安住不动。于为证得漏尽智通。心定趣向于四圣谛证入现观。断见所断一切烦恼。获得无漏有学正见。得正见故。能于一切苦集灭道。及佛法僧。永断疑惑。由毕竟断。超度犹豫故。名度疑又于正见前行之道。如实了知。是为正道。由此能断见所断后修所断惑。又于邪见前行非道。如实了知。是为邪道。于道非道得善巧已。远离非道游于正道。又于随道四种行迹。如实了知。何等为四。一苦迟通。二苦速通。三乐迟通。四乐速通。如是行迹。广辩应知。如声闻地。于此行迹。如实了知最初行迹一切应断。超越义故。非由烦恼离系义故。如实了知第二第三苦速乐迟二种行迹一分应断。如是如实了知初全及二一分应当断已依乐速通。正勤修集。从此无间永尽诸漏。于现法中获得无造究竟涅槃。身坏已后证无余依般涅槃界。如是七种清净为依。渐次修集。乃至获得诸漏永尽无造涅槃。当知此中由于如是七种清净。一切具足。渐次修集。方乃证得无造涅槃。非随阙一。是故应求如是一切。于世尊所熟修梵行。非求随一。又佛世尊。由此因缘。亦具施设如是一切。为令证得无造涅槃。非随舍一。又于此中依一一说。非唯由此。亦非离此能获无造究竟涅槃。如是应知此中缘性缘起甚深

复次嗢拖南曰

  安立与因缘　　观察于食义
  极多诸过患　　杂染等为后

有四种法。于现法中最能长养诸根大种。云何为四。一者气力。二者喜乐。三者于可爱事专注希望。四者气力。喜乐。专注。希望之所依止诸根大种。并寿并暖安住不坏。如是四法。随其次第当知。别用四法为食。一者段。二者顺乐受触。三者有漏意会思。四者能执诸根大种识。当知此中。段与现法气力为食。由气力故。便能长养诸根大种。能顺乐受诸有漏触。能与喜乐为食。由喜乐故。便能长养诸根大种。若在意地能会境思。名意会思。能与一切于可爱境。专注希望。为食。由专注希望故。便能长养诸根大种。由能执受诸根大种识故。令彼诸根大种。并寿并暖与识不离身为因而住。是故说识。名彼住因。由彼住故。气力。喜乐。专注。希望。依彼而转。如是四食。能令已生有情安住。又由段故。而有气力。有气力故。诸根大种皆得增长。由是因缘。诸有顾恋身命愚夫。为此义故。有所追求。于追求时。造作种种新善恶业。亦令增长。又能增长种种烦恼。如说于段。触意会思。随其所应。当知亦尔。由此三门能集后有业烦恼识。此于现法由业烦恼所随逐故。成其有取。便能摄受当来后有。如是四食令求后有爱乐后有。于其后有。未能断者。能摄后有。遍摄后有。随摄后有。又诸段食在欲界天。名之为细。或处中有母腹卵[穀-禾+卵]。当知亦尔。欲界余位段食。名粗。触意会思。及以识食。在无色界。当知名细。余处名粗。有色为依易分别故。无色为依难分别故。又此诸食当知。有异粗细义门。谓若能使已生有情得安住者。说名为粗。摄益求有诸有情者。当知是细。如是应知安立四食

复次如上所说诸根大种。由集谛摄。先爱而生。为欲令彼得增长故。追求四食。由此道理。已生有情虽由四食而得安住。然本藉爱为缘故有。又有爱故。于现法中依诸食身。由三种门。滋长业惑。能办业惑常所随逐有取之识。于现法中摄受后有。是故一切求有有情。虽由四食之所摄益。然复藉爱为缘故有。又即此爱于现法中。由无明触所生诸爱为缘故起。此无明触所生诸受。由无明触为缘故起。此无明触由先串习诸无明界所随六处为缘故起。此六处后更无余因。于现法中唯此六处展转相依。有色诸根依止于识。识亦依止识所执受有色诸根。由此因缘。六处已后更无所说。或复有时听闻正法为外支力。如理作意。正勤修习。为内支力。由是因缘。正见生起。正见生故。能断无明。能生于明。彼现法中。诸无明界所随六处皆得除灭。明界所随六处得生。名为转依。彼品粗重皆止息故。六处既灭。渐次乃至爱亦随灭。由爱灭故。诸食亦灭。能取后有。诸法灭故。当知后有亦复随灭。是故应知。处于明者。不求后有

复次无有少法生已安住。亦无有我能食所食。由此因缘。彼何名食。然唯约与未生诸法作生缘理。唯法引法说为食义。但由法假于其识上假想施设补特伽罗。望此四食。说为食者。为欲随顺世间言说。约世俗谛说有如是补特伽罗。能食四食。非约胜义。所以者何。若说有识生已安住。体是真实补特伽罗名能食者。不应立识为其食性。未曾见有补特伽罗还自能食补特伽罗。一相续中定无二识同时安住。是故立识体是真实补特伽罗为能食者。不应道理。由有如是不应理故。若作是问。谁食识食。当知此问为非理问。若作是问。谁是能食识食因缘。当知此问为如理问。能令悟入缘起理故。复有二有。一者生有。二者业有。若为当来后有生起。今现法中。诸业烦恼所随逐识为因。能引当来生有。即彼曾有前行业性。说名业有。于现法中有此有故。能令当来生有所摄后有生起。于命终时。前际六处才无常灭。后际六处寻复续生。即此六处识于先时为能引缘。复于今时为结生缘。如是由识入母胎故。得有名色。名色为缘便有六处。由无明界所随六处以为缘故。有相似触。渐次乃至取为缘故。令后际业转成其有。如是诸法先未曾有。一切新从别别缘起。当知此中都无触者乃至有者。能有所触。乃至有有唯有诸法。别名所食。别名能食。是故因果堕在诸行。相续流转无有断绝。由其先际业有。往趣后际生有。复由后际业有。还趣先际生有。如是缘起轮回不绝。从此世间往彼世间。自彼世间还此世间。是故唯法能引法义。当知此中说为食义

复次三食为因能令三种内苦生起。一者界不平等所生病苦。二者欲希求苦。三者求不允苦。初苦段食为因。第二苦触食为因。第三苦意会思食为因。段食因缘生内病苦。是故苾刍。当观段食如子肉想。不应贪着。随顺乐受触食因缘。能生于内欲希求苦。是故苾刍。当观顺彼六种触处如无皮牛。应作是观。若我依于六种触处。发起种种欲希求贪。便为依止诸色而住。依止色故。令我发起种种诸恶不善寻思。如无皮牛触处诸虫之所唼食。多生众苦不安隐住。如是观已。于初触处深见过患。无染而住。如依于色如是。依声香味触法。当知亦尔如于初触处深见过患。无染而住如是。乃至于第六触处。当知亦尔。有漏意会思食因缘。能生于内求不允苦。是故苾刍。当观有漏意会思食如一分火。观察如是所求不允能引身心大热恼故。彼作如是正观察已。终不希望衣食等事往诣他家。是故不为所求不允所生苦触。其心坦然安乐而住。由是因缘。应正观察如是三食。所谓段触意会思食。即由如是三食因缘。生如所说依识内苦。是故苾刍。当观识食如三百鉾之所钻刺。所以者何。段食因缘能令非一种种众多品类病苦依识而起。随顺乐受触食因缘。能令倍增欲希求苦依识而起。有漏意会思食因缘。能令种种求不允苦依识而起。如是行者于识食中。正观诸食以识为依多生过患。由是因缘。不顾身命。如是如理于四种食审正观察。审观为依能于现法永断诸食。食永断故。得至当来后有苦际

复次若不如实观此四食。便为喜贪之所染污。若为是二所染污者。当知希求二种过患。一者当来。二者现法。于四食中。有漏意会思食因缘。专注希望俱行喜染名喜。随顺乐受触食因缘。于能随顺喜乐诸食多生染著名贪。此二烦恼于现法中能染于识。令其安止四种识住。增长当来后有种子。既增长已生起后有生等众苦。当知是名喜贪二种烦恼所作当来过患。彼由如是于四食中安住喜贪二种烦恼。便于现法有诸尘染。由尘染故。食若变坏。于现法中便生悲叹愁忧。萎顿怀戚而住。当知是名喜贪二种烦恼所作现法过患

复次诸有于此四种识中喜贪未断。彼六处摄有识之身。犹如台观六处窗牖。能与缘境烦恼日光。作入依处。是光于此或住上地。或住下地。既得住已。如前所说。于四识住能染于识。生起当来后有众苦。若有能断如是喜贪二种烦恼。与彼相违缘境烦恼尚不得起。况依此入而当得住。又复若有补特伽罗喜贪未断。便为魔罗来诣其所。以其种种犹如彩色可爱境界。彩画如是补特伽罗。令其变生种种烦恼相貌显现。当知如是补特伽罗。喜贪未断。譬如其地能为种种烦恼彩画作所依处。已断喜贪补特伽罗。魔诣其所如前广说。当知如是补特伽罗。喜贪已断。犹若虚空。非为种种烦恼彩画作所依处。当知是名于诸食中喜贪未断。如其次第所有过患。当知是名于诸食中喜贪已断。如其次第所有功德

瑜伽师地论卷第九十四瑜伽师地论卷第九十五

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事缘起食谛界择摄第三之三

复次嗢拖南曰

  如理摄集谛　　得相处业障
  过黑异熟等　　大义后难得

若于谛智增上如理。及不如理。不如实知。不能尽漏。与此相违。如实知故。能尽诸漏。当知此中闻不正法。不为寂静。不为调伏。不为涅槃。所起诸智。名不如理。听闻正法。与上相违。当知如理。又于此中。住恶说法补特伽罗。于此正法佛佛弟子真善丈夫。不乐瞻仰。于别解脱尸罗律仪密护根门正知而住。如是等类贤圣法中。不自调伏。不受学转。于诸圣谛无闻思修照了通达。又即于彼诸恶说法毗柰耶中。闻不正法。起邪胜解。于不如理生起如理颠倒妄想。于不如理不如实知是不如理。又于听闻正法如理。不如实知是其如理。由不知故。于诸所有恶说恶解有缚无脱。不应思惟颠倒法中。不能解了。而故思惟。于诸所有善说善解有脱无缚。应可思惟无颠倒法。所谓契经及应颂等乃至广说。不能解了。而不思惟。如是亦名非理作意。由此作意。不欲寂静。不为调伏。不为涅槃故。名非理。又复听闻不正法故。依三言事增上缘力。显示过去未来现在计我品类。即由如是增上力故。于三世境起不如理作意思惟。谓于过去分别计我或有或无。未来现在当知亦尔。彼既如是不如正理。作意思惟。或缘所取事。或缘能取事。此不如理作意思惟。或即诸行分别有我。或离诸行分别有我。彼于所计得决定时。若缘所取事分别为我。或成常见。由此见故。作是思惟。我有。其我于现法中是实是常。或成断见。由此见故。作是思惟。我无。其我于现法中是实是常。若缘能取事。计有我见分别为我。作是思惟。我今以我观察于我。或谓我我先有今无。作是思惟。我今以我观察无我。或复即缘能取之事。计无我见。于现法中以其无我分别为我。作是思惟。我今以其无我随观昔曾有我。如是且说所取能取差别五相不如正理作意思惟五种见处。谓即三世所有诸行分别有我。又复由于不如正理比度作意。离于诸行分别有我。彼谓如是所计实我或自能作感后有业。名能作者。或他令作。名等作者。或自能起现法士用。名能起者。或他令起。名等起者。或自己作后有业故。或他令作后有业故。感果异熟。名能生者。或自能起现士用故。或他等起现士用故。得士用果。名等生者。或由自见。或由他见。随起言说。如是或由自闻觉知。或由他闻觉知。随起言说。名能说者。或于妻子及奴婢等所有家属。随其所应施设教敕令住其处。如是亦复名能说者。或复当来业果已生。名能受者。或于现法诸士夫果已现等生。名等受者。或于过去彼彼生中。造作种种善不善业。今于现法领受种种彼果异熟。名领受者。或有乃至寿量减尽而便夭丧。能舍此蕴。能续余蕴。若异此者既无有我。云何得成如上所说诸所作事。是名第六不如正理作意思惟所摄见处。如是诸见。且说皆以萨迦耶见。为其自性。能生其余。萨迦耶见以为根本所有见趣故。名见处。由能障碍能取真实微妙慧故。名见稠林。损善法故。名见旷野。劳役他故。名见厌背。欲求有求所行历故。名见行历。诘责他论免脱己论而动摇故。名见动摇。能善结构后有苦故。名为见结。习行如是诸邪行者。于现法中未现前漏令起现前。既现前已。令依下品起其中品。令依中品起其上品。由此为因生起当来老病死等一切苦法。如是当知由于如理及不如理不实知故。造作苦谛集谛杂染。与此相违。听闻正法。起正胜解。于其如理。无不如理颠倒妄想。于其如理。如实了知是其如理。广说乃至。于应思惟。无颠倒法。能正思惟。由此因缘。于三世行并其所取及以能取。如实随观无我我所。当于圣谛入现观时。于见所断所有诸漏。皆得解脱。得此事已。于上修道所断诸漏。为令无余永断灭故。精勤修习四种因缘。何等为四。一善护身故。二善守根故。三善住念故。四如先所得出世间道。以达世间出没妙慧多修习故。善护身者。谓正安住远避恶象。乃至广说。如声闻地。由远避故。于尽诸漏无有障碍。善守根者。谓正安住于诸可爱现前境界非理净相。能正远离如理思惟彼不净相。善住念者。谓住四处。一者安住思择受用衣服等处。二者安住能正除遣处静现行恶寻思处。三者安住能正忍受发勤精进所生疲惓疏恶不正淋漏等苦。他粗恶言所生诸苦。界不平等所生苦处。四者安住于所修道依不放逸无杂住处。由正安住如是四处。名善住念。彼由如是善护身故。善守根故。善住念故。如先所得出世间道善修习故。于修所断所有诸漏。皆能解脱。及随证得最极究竟。

复次若有说言此四圣谛唯是境界。或有其我。或有有情。缘此圣谛修诸善法。应告彼言。勿作是说。所以者何。诸有无量世出世间善法生起。一切皆归四圣谛摄。当知诸法略有二种。一能知智。二所知境。其能知智亦所知境。是故诸智俱行善法。无不摄在四圣谛中。彼复修习循身念故。观品止品所有善法。始修业地。已作办地。总得生起。云何名为修循身念。谓若有住始修业地。如理攀缘若内若外诸大种色。为境正念。或复由他爱与非爱增语有对触现行时。如理攀缘触受想行及与诸识。为境正念。或若有住已作办地。如理攀缘诸所造色。为境正念。或复如理攀缘作意及彼所生受想行识。为境正念。如是一切略摄。名为修循身念。当知此念或缘色身。或缘名身。云何名观。云何生起观品善法。谓于内外诸大种色及所余蕴。正决择慧。说名为观。若有从初无倒修习分析聚想。于外大种由观劫尽。修无常想。于内大种所合成身。由观唯食渐渐不净。修不净想。由观从爱所生长性及于后际。老死法性。修无常想及与苦想。若于此身一切愚夫不能如实了知体是无常苦故。或执为我。或执我所。即于此身具足多闻诸圣弟子。如实知故。无有所执。是即能修苦无我想。此无我想由于其身唯有界想。有此想故。若复由他爱与非爱增语有对诸触现行。言非爱者。即是手足杖块等触。彼则于此及此为缘所有受等无色诸行。正观无常离爱离恚。唯观有界。心缘此身正安住故。如是亦名远离愚痴。如是所有分析聚想。于外大种修无常想。于内大种修不净想。若无常想。无常苦想。苦无我想。于所生起受等诸法。依大种身修无常想。离贪嗔痴。如是观品无量善法。始修业地由正修习循身念故。皆得生起。云何名止。云何生起止品善法。谓由修习循身念故。以观为依如理修止。又言。止者。谓于其内正安住心。止品善法者。谓得如是正思择力攀缘。锯喻沙门教授于怨家所正修忍辱。又即缘彼无倒修慈。既由忍慈所摄受故。戒得清净。观戒净故。作是思惟。我今已于大师圣教。微有所作。由是因缘。无所忧悔。无忧悔故。深生欢喜。广说乃至。得三摩地。彼于尔时由静定心。乃至获得第四静虑。此三摩地行拘执故。未能双运无功用转。未善清净。为欲令其善清净故。修如前说四支所摄不放逸行。发勤精进无有怯弱。乃至广说。彼于后时第四静虑清净鲜白。若复为其静定爱味。漂转其心。不能于定正舍而住。于灭涅槃不观寂静。彼乃依佛或法或僧深生厌耻。作是念言。我依如来大师佛宝。法毗奈耶善说法宝。无倒修习善行僧宝。为无所得。非有所得。是其恶得非为善得。于萨迦耶爱藏而住。于灭涅槃不观寂静。彼由内心善调柔故。才生厌耻。便能安住引沙门义平等妙舍。于灭涅槃能观寂静。生起如是止品善法。所谓忍慈。尸罗清净。无悔。欢喜。广说乃至。得三摩地四支所摄不放逸行。引沙门义平等善舍。观灭涅槃寂静功德。彼于尔时。由二因缘。多有所作。一由其妙慧。于大师教为尽诸漏。能净修治第四静虑故。二于萨迦耶心增上舍故。齐此名为始修业地究竟成满。从是已后于所修习不生喜足。为欲趣入已作办地。修循身念。观造色身如草木泥。及彼所生余非色法。以如实慧通达缘起。能随趣入如实谛。智既得入已。依上修道。于去来今诸根境界。能起厌患。乃至解脱。能如实知我已解脱。如是名为已作办地。修循身念所生善法。谓观色身如草木泥。想如是观察无色诸法。真实妙慧通达缘起。能随趣入四圣谛。智于修道中。能起厌患。离欲。解脱。解脱智见。齐是名为于大师教以其妙慧所应作事皆已作讫。所以者何。一切自义皆已究竟。从此已后更无所作。非于作已复须分别。若有作已余时退失当更有作。此作虽作非毕竟作。如诸异生以世间道而得解脱。此中若先始修业地。有漏善法。若后所有已作办地。无漏善法。如是一切随其所应。当知。皆入四圣谛摄

复次由四因缘。应正了知集谛所摄百八爱行。一由内外差别故。二由所依差别故。三由自性差别故。四由时分差别故。云何名为内外差别。谓由内外六处为依。起诸爱行。云何名为所依差别。谓爱依止五种我慢。何等名为五种我慢。谓于我见未永断故。得有如是我慢现行。于其六处计我起慢。乃至未为衰老所损。诸行相似相续而转。作是思惟。是我如昔。彼若复为衰老所损。或于一时成就好色。或于一时成就恶色。或于一时成就大力安乐辩才。或于一时乃至无辩。彼若成就好色大力安乐辩时。作是思惟。我今美妙。若违于此作是思惟。我非美妙。若为衰老所损败时。作是思惟。我今变异。云何名为自性差别。谓此五种我慢为依。发起有爱及无有爱。又彼有爱软中上品差别而转。于其无有。由审思择方能起爱。非由意乐任运而住。是故于中无有三品差别建立。当知此中软有爱者。谓于当来愿我当有。即于六处愿我当有。即如是类愿我当有。于同类生有希求故。异如是类愿我当有。于异类生有希求故。若先自体是可爱者。愿彼相应故。造善业。作是思惟。愿我当有如是种类如今所有。若先自体不可爱者。愿彼离隔故。造善业。作是思惟。愿我当有如是种类异今所有。中有爱者。谓于无有不生希欲。为治彼故。愿我得有。即于六处愿我得有。如前所说。即如是类愿我得有。异如是类愿我得有。如是一切应知。皆名中品有爱。上有爱者。谓即如是行相差别。作是念言。愿我定有。猛利思求四种相爱。应知说名上品有爱。此五种爱自性差别。由有所依内处别故。说十八种爱行差别。于其外处。当知亦尔。此差别者。谓如于彼内六处中。计我起慢如是。于色计为我所而起于慢。谓于此色我自在转。如是乃至。于诸法中计为我所而起于慢。谓于此法我自在转。余随所应。如前应知。如是十八并前爱行。合说总有三十六种爱行差别。云何名为时分差别。谓即如是三十六行各有过去未来现在三世差别。如是名为由四因缘有差别故。爱行合有一百八种。又于此中无差别相。凡诸所有染污希求。皆名为爱。又即此爱集谛摄故。说名为因。津润性故。顺生死流而漂转故。名为流润。于诸境界执着性故。名为着境。能与生已依五取蕴如痈病等所有众苦为因缘故。说名痈根。难制伏故。说名流溢。微细现行魔所缚故。说名纤缴。上至有顶高标出故。说名条干。令无饱故。说名枯竭。又即如是所说相爱缠众生故。说名为碍。由随眠故。说名为覆。即由如是缠及随眠成上品故。说名上耸。成其中品及软品故。说名发起。若欲界爱于所知境令迷惑故。说为冥闇。若色界爱于所知境令迷惑故。说为昏昧。若无色爱于所知境令迷惑故。说为翳瞙。如有三人。第一盲瞽。第二闭目。第三翳瞙微覆其眼。此中第一全无所见。第二少分似有所见。第三虽见眼不净故。不睹真色。如是三爱随其次第。冥闇。昏昧。及与翳瞙。当知亦尔

复次由五种相。转法轮者当知。名为善转法轮。一者世尊为菩萨时为得所得所缘境界。二者为得所得方便。三者证得自所应得。四者得已树他相续。令于自证深生信解。五者令他于他所证深生信解。当知此中。所缘境者。谓四圣谛。此四圣谛安立体相。如前应知。若略若广如声闻地。得方便者。谓即于此四圣谛中。三周正转十二相智。最初转者。谓昔菩萨入现观时。如实了知是苦圣谛。广说乃至。是道圣谛。于中所有现量圣智。能断见道所断烦恼。尔时说名生圣慧眼。即此由依去来今世有差别故。如其次第。名智明觉。第二转者。谓是有学以其妙慧。如实通达我当于后犹有所作。应当遍知未知苦谛。应当永断未断集谛。应当作证未证灭谛。应当修习未修道谛。如是亦有四种行相。如前应知。第三转者。谓是无学已得尽智无生智故。言所应作我皆已作。如是亦有四种行相。如前应知。此差别者。谓前二转四种行相。是其有学真圣慧眼。最后一转。是其无学真圣慧眼。得所得者。谓得无上正等菩提。树他相续令于自证生信解者。谓如长老阿若憍陈。从世尊所闻正法已。最初悟解四圣谛法。又答问言。我已解法。从此已后如前所说。究竟行相。五皆证得阿罗汉果。生解脱处。最后令他于他所证生信解者。谓如长老阿若憍陈起世间心。我已解法。如来知已起世间心。阿若憍陈已解我法。地神知已举声传告。经于刹那瞚息须臾。其声展转乃至梵世。当知世尊转所解法。置于阿若憍陈身中。此复随转置余身中。彼复随转置余身中。以是展转随转义故。说名为轮。正见等法所成性故。说名法轮。如来应供是梵增语彼所转故。亦名梵轮

复次于四圣谛未入现观能入现观。当知略有四种瑜伽。谓为证得所未得法。净信增上。发生厚欲。厚欲增上。精进炽然。炽然精进有善方便。言净信者。谓正信解。所言欲者。谓欲所得。精进如前略有五种。有势。有勤。有勇。坚猛不舍其轭。善方便者。谓为修习不放逸故。无忘失相。说名为念。于诸放逸所有过患了别智相。说名正知。此二所摄。名不放逸。于诸染法防守心故。常能修习诸善法故

复次苦谛如诸疾病。集谛如起病因。灭谛如病生已而得除愈。道谛如病除已令后不生。诸有病者诣良医所。但应寻求尔所正法。诸有良医亦但应授尔所正法。是故更无第五圣谛。诸佛如来拔大爱箭无上良医。亦但宣说尔所正法

复次背圣谛智不成现观诸有沙门若婆罗门。当知略有十相过患。谓有胜义诸沙门等意。不许彼为沙门等。言亦不数为沙门等。于诸后有生等众苦。皆未解脱。于诸恶趣亦未解脱。堪能弃舍正所学处。不堪能证诸出世间过人胜法。所谓圣道道果涅槃。向善趣故。堪能寻访除学无学余外福田。于超苦苦更不还果。无所堪能。于现法中究竟悟解。解脱一切有余依苦。无所堪能。与此相违。当知即是不背谛智。成就现观。所有沙门若婆罗门十相功德

复次趣向谛智。乐正觉者。应当了知。依四圣谛增上缘力。得所依处。得得方便。应知是处。于善说法毗奈耶中。净信出家名得依处。若四沙门果所摄受声闻菩提。若诸独觉所有菩提。若诸如来无上菩提。如是三种。当知名得如前所说三周正转。随其次第智见现观。名得方便。应知于入谛现观时。如实了知是苦圣谛。乃至广说。是道圣谛说。名智位。从此已后于诸谛中复有所作。应当遍知。广说乃至。应当修习。由此观故。说名见位。于无学地如实解了我已遍知。我已永断。我已作证。我已修习。名现观位。复有差别。谓诸无学尽无生智所摄一切极解脱智。说名智位。即此无学极解脱智所引正见。说名见位。从预流果乃至究竟。当知所有一切学慧。名现观位。

复次应知谛智略有六种作业及相。谓此谛智是能永灭众苦前行。如日将出先现明相。正尽苦者。谓初见谛所断众苦作苦边者。谓阿罗汉所断众苦。又此谛智是能对治大无明闇。如日光明能破世间所有大闇。又如有一。已证谛智永断三结。从此无间由失念故。暂为欲贪嗔恚所染。彼于尔时。依不放逸入初静虑。由触谛智。得不还果。如是渐次虽入非想非非想定。而与外凡有其差别。由已证得不退法故。如是谛智有广大用。有广大果。此中所有过去诸行。说名已生。现在诸行。说名正生。未来诸行。说名当生。如是一切总名集法。即此一切由无常灭。或有已灭。或有向灭。或有当灭。总名灭法。又于谛智已证得者。如大石楼已善雕饰。八方猛风不能倾动。一切异论不能移转。所有悟解不假他缘。不视他面。彼将何说。我当听受。不观他口。适出语已。寻我听闻思惟筹量。审谛观察。诸他沙门婆罗门者。当知即是诸外道辈。又即一切四圣谛智渐次集成。名谛现观。非随阙一。此谛现观犹如肴膳。诸圣弟子无上慧命。皆依此活。如受欲者食用肴膳。苦等谛智阙余三智。如睒弥叶。当知余似娑罗枝叶。四圣谛智渐次集成一切圆满。又诸谛智与喜乐俱觉真义故。能令身心极轻安故。名谛现观。生那落迦中。略有二苦。一烧燃苦。二治罚苦。由阙谛智。获斯二苦。此无量生猛利大苦。向圣谛智。皆能超越。如是谛智。假使因其烧燃治罚猛利大苦。于现法中。一身灭坏而可得者。应生踊跃欢喜忍受。纵毁百身尚应欢喜。况乃唯一

复次若有为修圣谛现观。当知略有四种障碍。何等为四。一者不信。二者上慢。三者待时。四者放逸言。不信者。复有三种。一于谛现观不生信解。二于僧善行不生信解。三于佛菩提不生信解。为欲断除初不信故。世尊自引现量所证圣谛现观。告诸弟子言。我已于四圣谛理。得现观故。证觉无上正等菩提。为欲断除第二不信故。复说言。我昔与汝辈长世久流转。由未正思惟觉悟于真谛。我今与汝等由正见通达。以通达为因。尽生死流转。彼因缘尽故。自今无后有。唯余最后身。任持令不灭。第三不信于佛菩提。如是相转。谓若沙门乔答摩种是一切智。何故有问一类能记。一类不记。为欲断除如是不信。故复说言。我所觉法无量无边。譬如大地诸草木叶。为他说者。少不足言。譬如手中升摄波叶。多分能引无义利故。少分能引有义利故。当知此中。非不知故而不记别。但由能引无义利故。而不记别。言上慢者。谓即于彼谛现观中。起增上慢。为欲断除如是上慢故。复说言。如人在远以箭射箭。筈筈无遗甚为希有。或复一毛析为百分。以毛[矛*(替-曰+貝)]毛端端不落。以极细故。是事复难。通达圣谛转难于彼。所以者何。由即以其能取作意。还即通达能取作意。如是方有能缘所缘平等平等无漏智生。通达谛理。是故此事最细最难。箭射箭筈。毛[矛*(替-曰+貝)]毛端。则不如是。言待时者。谓于所作推待后时。为欲断灭如是待时故。世尊说无坠人身甚为难得。复引盲龟以况其事。云何放逸。谓略而言。若邪思惟。若邪寻思。若邪戏论。是名放逸。当知若于不应思处。而强思惟。名邪思惟。谓或思惟我于过去世为曾有邪。乃至广说。于未来世于内犹豫我为是谁。谁当是我。今此有情从何而来。于是没已当往何所。或思世间。谓世间常。乃至广说。如是或谓世间有边。乃至广说。或思有情。谓命即身。乃至广说。或思有情业果异熟。谓妄思惟此作此受。乃至广说。或复思惟诸静虑者静虑境界。或思诸佛诸佛境界。如来灭后若有若无。乃至广说。彼由世俗胜义善巧。于是一切二因缘故。不应思惟。一非思惟所缘境故。二由其事无所有故。若有思求非思境事。或有思求无所有事。如是一切皆无所得。唯有令心转增迷乱。若于此中。不如正理。强思惟者。虽有一类由宿因力。或起厌离。或起厌离相应作意。缘实境界。于其中间暂尔现行。而复于彼见为过患。生不实想。如是思惟世间等法。能引无义。邪寻思者。当知即是欲等寻思。邪戏论者。复有六种。谓颠倒戏论。唐捐戏论。诤竞戏论。于他分别胜劣戏论。分别工巧养命戏论。耽染世间财食戏论。如是一切总名放逸。为欲断除此放逸故。如来亲自为教诲者。为堪受化补特伽罗闻已。速能断诸放逸。世尊弟子。为断如是圣谛现观四种障碍。由三行相。任持圣谛。何等为三。一由闻慧任持其文。二由思慧任持其义。三由修慧任持其证。此中闻慧如其所闻能正任持是苦圣谛。乃至广说。又由思慧任持其义。谓诸圣者。知其是谛故。名圣谛。当知此中由二缘故。得名为谛。一法性故。由真实义。说名为谛。二胜解故。由即于此真实义中起谛胜解。说名为谛。一切愚夫。但由法性得名为谛。非胜解故。若诸圣者。俱由二种得名为谛故。偏说此名为圣谛。又由修慧于诸谛中获得内证现量谛智。亦得证净。由是因缘。于诸谛实远离疑惑。谛智证净更互相依。若处有一必有第二

复次若有沙门或婆罗门。于圣谛智而未相应。于诸圣谛未成现观。当知略有四种过患。何等为四。谓于能往下分恶趣生本行中。深起爱乐。造作增长彼相应业。由此颠坠生恶趣坑。又于欲缠人天两趣众多烦恼常所烧煮生本行中。深起爱乐。造作增长彼相应业。由此因缘。既生彼已大生热恼。常所烧然。又于此上色无色缠所有相应。如前所说无明昏闇。及诸翳瞙生本行中。广说乃至。堕于生闇。又由退失受用境界涅槃道故。于其中间如生三种世界。中间堕在三种妄见黑闇。一者常见。二者断见。三者现法涅槃见。由是因缘。坠堕三界。生黑闇处。摄受如是自妄见故。邪无明闇所覆障故。不如实观如前五支所摄受断。由是因缘。应知如实显示诸谛。

复次或有一类。于诸圣谛不得善巧。造作增长黑黑异熟业已。能感那落迦傍生鬼趣。由此业故。譬如掷杖根。堕那落迦中。堕傍生趣端。堕饿鬼界。如是一类。造作增长黑白黑白异熟业已。由此杂业。譬如掷杖。或堕恶趣不清净处。或堕善趣少清净处。如是一类。造作增长白白异熟业已。由此业故。生在五趣生死诸业所随逐处。寿尽业尽。即还从彼色无色界没已。退堕五趣生死。如五辐轮旋转不住。若有为他说世间道。乃至虽能上升有顶。当知此说非第一义令上升教。何以故。如是上升非毕竟故。若诸如来所说圣谛相应言教。当知此教是第一义令上升教。何以故。如是上升是毕竟故。又若由得诸世俗智。乃至有顶。名聪慧者。非第一义说名聪慧。如前说故。若由谛智名聪慧者。是第一义名为聪慧。如前说故

复次于其四种圣谛智中。初圣谛智能入圣谛。渐次现观。譬如本足。第二谛智。譬如墙壁。第三谛智。如下层级。第四谛智。如上宝台。又即如是四圣谛智。如四阶蹬。能令上升大智慧殿。又即如是四圣谛智。如四桄梯。能令蹬上解脱寂灭。当知此中有三种爱。譬如三枪。诸恶魔罗执持挠搅生死大海。令彼受生诸有情类随而回转。如是三种魔罗爱枪。不能令彼三种有情随而回转。一者劲锐。即是预流。二者处中。即余有学。三者逆流。道行圆满。随其所欲。皆能造作。已见圣谛补特伽罗。永断所有慢所作苦。慢所成苦。由是因缘。诸苦少在多分已断。谓诸有学及阿罗汉。如慢所作所成众苦如是。诸爱身语意业贪嗔痴等所生众苦。当知一切皆少分在多分已断。譬如砾石及大雪山。如是诸慢所作所成所有众苦。若余若断。当知亦尔。如大池沼其水盈满于中沾引二滴三滴。依大池沼水尚甚多。如是无色爱所生苦若余若断。当知亦尔。如大陂湖。余如前说。如是色界爱所生苦若余若断。当知亦尔。又如大海余如前说。如是欲界爱所生苦若余若断。当知亦尔。又大雪山。若诸金山。若苏迷卢。及大地喻。又有六种砾石之喻。又泥团喻。余如前说。如是身业语业意业贪嗔痴等所生众苦。若余若断。当知亦尔。如是多苦已远离故。少苦在故。当知圣谛如实现观有大义利。谓诸有学最极七生人天苦。在诸恶趣苦。皆已越度。若诸无学唯有现法所依苦在。余一切苦皆已越度。

复次若住是身入谛。现观。当知此身最为难得。又圣明眼见谛。有学转甚难得。又闻思修所成妙慧亦为难得。由此慧故。于善说法毗柰耶中。如其次第。解了胜了。及以决了。于解了时。能审分别。于胜了时。能生胜解。于决了时。于法入证。又谛现观所有资粮善有漏法。亦为难得。谓于父母识恩养等诸善业道有暇圆满。亦为难得。又有世间初正见等。乃至解脱智为后边十种正法。亦为难得。如是诸法。即是有学。即是无学。当知此中。善知恩养所有士夫补特伽罗。如实了知一切父母皆应孝养。如是知已。于其父母勤修孝养。是名善识父母恩养。又乐己利所有士夫补特伽罗。于他有德一切沙门及婆罗门。如实了知是福田已。如其所应。勤修供养。是名善知所有沙门若婆罗门。又无贪堕所有士夫补特伽罗。于诸妻子及奴婢等一切亲属。如实了知彼既以我为室为归。我若有乐彼亦随乐。我若有苦彼亦随苦。如是知已。于时时间。正以饮食衣服给赐。复以病缘医药摄受。于彼义利自然勇励而为施造。非于一切求彼忆念。禀性忠平好等分布。亦不淫佚损费财宝。不于非处生毗柰耶。亦不非处而兴愤发。于诸耆长及尊重处。正善随转。如是名为善御家长善能造作自他义利。诸所施为皆以正法。不以非法。于现法中他作恶行。深见过失。谓或杀或缚。或罚或退。或被讥毁正思择已。终不现行。如是名为于此世罪深见怖畏。又正观见造恶行已。于其后世感恶趣苦。及感所余匮乏等苦。正思择已。终不现行。如是名为于他世罪深见怖畏。又时时间能正受学。施福业事。造作种种差别福行。所谓看病。事佛法僧躬为执当。如是等类名作福行。于一日夜乃至尽寿。所有尸罗能正受学。如是总名惠施作福受斋学戒。十业道者。谓二三等差别。宣说乃至。为令由闻思慧于彼相应所有作意正多修习。又诸有情生恶趣已。难可解脱。生善趣已。速疾乖离。当知是名有暇圆满甚为难得。又见谛故无有差别正见生起。于过去世名已生起。于现在世名今生起。于未来世名当生起。如前所说。若习若修若多修习。其义应知。若世间正见应随防护。若有学正见并其断果应随触证。若无学正见。并自离系果。应随作证。如说正见如是。乃至解脱智。应知亦尔

瑜伽师地论卷第九十五瑜伽师地论卷第九十六

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事缘起食谛界择摄第三之四

复次总嗢拖南曰

  总义等光等　　受等最为后

别嗢拖南曰

  总义自类别　　似转后三求

当知诸界略有二种。一住自性界。二习增长界。住自性界者。谓十八界堕自相续。各各决定差别种子。习增长界者。谓则诸法或是其善或是不善。于余生中先已数习令彼现行故。于今时种子强盛依附相续。由是为因。暂遇小缘。便能现起定不可转

复次以要言之。虽界种类十八可得。然一一界业趣有情种种品类有差别故。当知无量。譬如世间大恶叉聚。于此聚中有多品类。种类一故。虽说为一。而有无量。如是于其一一界中。各有无量品类差别。种类一故。虽各说一。而实无量

复次如是诸界。由胜解力之所集成。先恶胜解集成恶界。先善胜解集成善界。随所集成。还与如是相似有情同法而转。谓相往来。同聚同住。同见同意。胜解相似。由是故言有情诸界共相滋润。相似而转

复次由梵行求增上力故。先说起信。次于尸罗受学而转。次于现行所有过罪。观自观他而生羞耻。次于善法无间修习。发勤精进。于久所作及久所说。能无忘失。是二为依令心得定。由心定故。得如实智。如是且说信增上力。渐次修习三种所学。一增上戒。二增上心。三增上慧。如是三学胜资粮道。谓世正见好行慧舍。易养易满。少欲喜足。及四摄事。其易养等句义差别。如声闻地已说其相。如是当知。名梵行求已得圆满。成就如是梵行求者。还与此界诸有情类共相滋润相似而转。离此界者。还与远离此界有情共相滋润相似而转。当知此中。果依于因。非因依果故。无明界所随六处诸界为缘所依别故。起无明触种种品类。其无明触种种品类以为缘故。起无明触所生诸受种种品类。其无明触所生诸受种种品类以为缘故。起无明触所生诸受为缘贪爱。爱为缘故。而有其取。广说乃至。大苦蕴集。当知是名依有求故建立诸界。又无明界所随六处诸界为缘。起无明触。此无明触以为缘故。于诸境界起不如理执取相好所有诸想。此想为缘于诸境界发起希欲。希欲为缘起彼随法多随寻思。由彼随法多随寻思以为缘故。发起思慕愁忧所作身心热恼。身心热恼以为缘故。于诸境界种种品类思求差别。皆可了知。如是当知。依欲求故。安立诸界

复次嗢拖南曰

  三七界相摄　　见想与希奇
  差别性安立　　寂静愚夫后

界有三种。一者色界。二无色界。三者灭界。复有七界。一光明界。二清净界。三空处界。四识处界。五无所有处界。六非想非非想处界。七灭界。当知此中。由其色界摄光明界及清净界。由无色界摄四无色。由其灭界还摄灭界又诸色贪由见由受所显发故。遍于一切色界地中。安立光明及清净界。又于如是七界遍知。应当了知。于得方便。应当了知。即于其得应当了知。于得所为应当了知。如是诸界所有遍知。由四因缘。应当了知。谓有相违所治能治而相待故。狭小无量而相待故。有及非有而相待故。有上无上而相待故。黑闇为缘施设光明。不净为缘施设清净。色趣为缘施设虚空。如是名为有相违故。待彼所治施设能治。由待彼故。能于此中正觉慧转。由缘有量狭小境识以为缘故。施设识无边处。由少所有以为缘故。施设无所有处。由一切有最胜现前以为缘故。施设非想非非想处。为有无上。由萨迦耶所有相应诸烦恼断以为缘故。施设灭界为灭无上。当知有顶是有无上。灭于诸法皆是无上。又有想定名为有行。于七界中。次第乃至无所有处。一切皆是有想定故。皆由行定随顺获得。谓取明相光明想。俱修三摩地随顺获得光明想定。如是由取清净。虚空。识无边想。无所有想。当知亦尔。非想非非想处。由无相作意方便。趣入想极细故。取为第一。诸有寂静起胜解时。随顺获得第一有定。于一切相不思惟故。于无相界正思惟故。萨迦耶灭由无相故。随顺获得灭定灭界。如是二种。不由行定随顺获得。又由永害色无色界所有贪故。不下屈故。不高举故。解脱住故。住解脱故。如是诸定。得随所欲有力调柔自在而转。如是名为随得诸界。又此诸界能随获得八解脱定。当知初界能随获得第一第二二解脱定。其第二界能随获得第三解脱胜静虑定。其余五界如其次第能随获得五解脱定

复次诸外道辈欲令弟子于三处中得升进故。略说法要。谓有一类。于劣欲界为令获得人中快乐。乃至他化自在天生。宣说能感彼果诸行。复有一类。于中色界为令获得梵世间等众同分生。宣说能感彼果诸行。复有一类。于妙无色。为令获得乃至非想非非想处众同分生。宣说能感彼果诸行。如是彼说劣界为缘。名为劣语。中界为缘。名为中语。妙界为缘。名为妙语。彼诸弟子闻是法已。还起如是差别想解。如是想解。亦名劣想中想妙想。如如其想如是如是。发生忍乐。如是忍乐发生劣见中见妙见。彼由如是诸忍乐见。便于彼彼差别生处。信解忍可。执为最胜。造作增长彼相应业。如是信解。名为劣愿。中愿。妙愿。当知此二说者行者。亦说名为劣中妙品补特伽罗。又彼说者及以行者。亦传为他宣说如是劣中妙法。彼亦获得如是类生。又即此生前后相待有差别故。安立诸界劣中妙别。如是三种。若待涅槃一切皆是劣界所摄。若诸如来。由胜义故。妙界为缘。但说妙语。余法差别如应当知。若诸圣者所有行趣。应知皆为现法涅槃。先有外道。彼命终已来生此间。因增长故。众缘和合。于善说法毗柰耶中。暂得出家。彼由先世外道妄见所迷乱故。集成今时大无明界。由此为因。于其涅槃及大师所。生起疑惑。退失正法及毗柰耶。还归外道诸恶说法。彼由先世数习因力。还复宣说如是劣语。乃至广说。如前所说。一切应知

复次于外道处外道弟子各别见趣广施设中。略有三种由忍见依差别可得。依此正法能令永舍缠及随眠。由缠舍故。彼亦随舍。余亦无执。了知由彼于现法中与他违诤忿竞而住。能引自他一切无义。既知是已。舍彼随眠。由舍此故。所余随眠。及余因此所有诸缠。毕竟无执。于外道处各别见趣广施设者。谓执世间若常无常。广说乃至。如来灭后非有非无于中。一类外道弟子。为性迟钝。如如自师。或他教导。如是如是。不审思量。取执坚着唯此谛实余皆愚妄。彼于一切各别见趣。悉皆忍受。是名第一由忍见依。复有一类外道弟子。性是中根而非迟钝。不能自然于法猛利推寻观察。亦不随言便生信解。而于展转相违见趣。随喜乐一。彼于一类见趣忍受。于余一类而不忍受。是名第二由忍见依。复有一类外道弟子。性是利根。彼能自然于法猛利推寻观察。由诸见趣恶施设故。彼见一切皆不应理。见已一切都不喜乐。由是因缘。于诸见趣皆不忍受。此复有二补特伽罗。一邪见行。性无堪能无求解意。二正见行。性有堪能有求解意。此中第一一切不忍补特伽罗。即由如是非理比量。于善说法毗柰耶中。不审思量。执为非理。诽谤贤圣。起无有见。又于一切各别见趣。皆不忍受。方便令彼无所依仗。亦令灭坏无所宗承。而妄分别计度。显示无所依仗所引见趣。常与一切各别见者。共兴违诤。互相恼害。是名第三由忍见依。此中第二一切不忍补特伽罗。于前一切不忍者。见亦不喜乐。住求解心。往诣他所谓善说法毗柰耶中佛。佛弟子。如实显已言。我一切皆不忍受。佛佛弟子。了知彼人有求解意。觉慧猛利具堪任性。即以其心念彼心已。遂依于前补特伽罗而反诘曰。汝即于此都不忍见亦不忍耶。彼便如实唯然而答。如来遂举此正法中诸弟子众。赞励于彼告言。汝与多人相似。我等一切于诸见趣。并不忍见皆不忍受。汝若尔者如此人。众缠与随眠一切见依。皆永断故。于当来世诸见杂染无所堪能。汝今与彼竟无差别。如是辈流极为鲜少。汝于此少。转更为少。若于一切缠及随眠。都不忍见能永断者。彼于一切毕竟无执。如是如来。如来弟子。方便令彼外道弟子于正智见发生希欲。窃作是念。我竟不知如来弟子能断如是缠及随眠。如来知彼于正智见生希欲已。更复策发彼希欲心。其遂承受。如来为欲令彼依止思择修习二对治力。永断一切缠及随眠。宣说法要。令其获得无倒智见。如余安住此正法者。能舍一切缠及随眠。所谓思择彼诸见依。能令展转互相乖背。由是因缘。违诤恼害。能引自他一切无义。诸圣弟子于彼一切。皆无执取。设有来问。亦不记别。观察如是诸过患已。依思择力舍离诸缠。由此因缘。于彼见依能永捐弃。于余见依由正见故。亦令无有。如是为欲永断诸缠拔随眠故。修循身念。于有色身观无常性。于身染着净修其心。于随自身诸受分位。由无常门观无常性。如实了知诸名色故。便于诸漏心得解脱。观身坏已当来诸受皆悉断灭。又于其身住当坏想。乃至命在常能领受离系诸受。如是名为依修习力舍离随眠。当知此中。贪恚痴等。令当来世生等诸苦和合系缚。亦令现法起业杂染。亦令欣求未来染事。执取过去已所舍事。耽着现在正现前事。意佷名违。言佷名诤。由三损恼。说名为害。观无常等。如声闻地已说其相

复次不净慈悲修所对治欲贪恚害未永断故。诸依止中彼品粗重。犹如种子能生彼故。如其所应说名欲贪及恚害界。由有此故。顺欲恚害境现前时。依不如理作意思惟。于三种境。能取非理相好想生。此想生已由坚执故。当知发起二种过患。一者现法。二者后法。此中云何名为坚执。云何名为现法过患。云何名为后法过患。若由己生想增上力。如前相似欣欲分别。所有热恼寻求生起。由是因缘。名坚执想。又寻求时。于其三处。于诸有情。发起邪行。由此为因。或有堪能。能生现法所有忧苦。由此因缘。说名有苦。或无堪能。然即由彼现在前故。名有匮乏。又此有苦及有匮乏。用二为缘。一者用他手块刀杖及粗言等为增上缘。由是缘故。名有灾害。二者用内杂染而住为增上缘。由是缘故。名有烧恼。如是名为现法过患。即由此因于当来世生诸恶趣。如是名为后法过患。又若于其所受学处。有坚固执当知于彼如干苇舍。所依止中所有能依如虫。善法由邪想火掷置其中。能焚灭故。当知即此补特伽罗所有如虫。一切善法。皆被烧害。与此相违。无坚执故。当知退失功德善法。与此相违。如其所应。当知出离无恚无害想等差别。又于是中闻思修慧。能令黑品无坚固执。能令白品有坚固执。若此三种妙慧有阙。能令黑品有坚固执。能令白品无坚固执

复次如来有二甚希奇法。一者显示一切诸法皆无有我。二者显示一切有情自作他作皆无失坏。此中略有二种有情。一在家品。二出家品。在家有情。为求财宝初兴加行。名发起界。即于此中若未获得由顺精进。障碍因缘诸心勇悍即望于彼。名势力界。若已获得由蚊虻等所有灾害顺精进。障不能令转。名任持界。即此诸界从自方所至余方所。从未摈舍至已摈舍。名出离界。即彼有情为财宝故。俱于二处。由起无间殷重加行无缓加行。名勇猛界。出家有情先乐出家。求出家故。生决定欲。名发起界。依出家品。于所应得广大善法。无有怯劣。名势力界。种种淋漏所生众苦。发勤精进所生众苦。界相违等所生众苦。不能败坏。名任持界。若于下劣不生喜足。名出离界。乃至命在常修无间殷重加行。名勇猛界。如是一切应当了知。谓彼诸界及尽所有诸品类界。

复次于诸界中。略有二种界差别性。云何为二。一者他类差别性。二者自类差别性。他类差别性者。谓眼界异。色界异。眼识界异。如是乃至。意识界异。自类差别性者。谓即彼界或顺苦受。或顺乐受。或顺不苦不乐受。由是为缘。能生三受

复次由四因缘。当知建立三种三界二出离界。云何为四。一者外不出离而出离故。二者内不出离而出离故。三者非毕竟出离而出离故。四者无增上慢故。当知此中。用外五妙欲贪为缘建立欲界。即由此界出离义故。建立色界最初静虑。由寻喜乐出离义故。建立此上三种静虑。由色有对种种性想出离义故。建立空无边处所摄无色界。由空识无所有想出离义故。建立此上所摄无色界。如是外处不出离出离义故。当知建立三界差别。又色界中具足六处。内处圆满。无色界中五有色处皆已超越。唯余意处。于灭界中一切六处皆已超越。如是内处不出离出离义故。当知建立余三种界。又色界中非是毕竟出离。欲界无色界中望于色界。当知亦尔。若诸有为皆悉寂灭。当知是名毕竟出离。如是非毕竟出离出离义故。当知建立三界差别。无增上慢者。谓由遍知当知建立五种六种诸出离界。如三摩呬多地已办其相

复次若诸苾刍。专乐寂静勤修止观。略由五相。当知其心名得解脱。一者奢摩他熏修其心。依毗钵舍那解脱奢摩他品诸随烦恼。二者毗钵舍那熏修其心。依奢摩他解脱毗钵舍那品诸随烦恼。三者二种等运离心随惑。解脱一切见道所断所有诸行。四者即由此故解脱一切修道所断所有诸行。住有余依般涅槃界。五者解脱一切苦依诸行。住无余依般涅槃界。于善说法毗柰耶中。略有二种师及弟子甚希奇法。一平等见随起言说。二最胜见随起言说。如是二种。外道法中都不可得。所作差别故。远离涅槃故

复次世间愚夫略有二种愚夫之相一乐习行能引自他无义利行。二于四处不得善巧。当知能引无义利行有四种相。云何为四。谓能生起四种苦故。一他差别苦。二内差别苦。三时差别苦。四身差别苦。他差别苦者。或有疫厉谓非人作。或有灾害。谓人所作。或有已遭。或恐当遭于所未遭而生怖畏。如是名为由他增上所生众苦。内差别苦者。谓界相违疾病因缘。名为灾患。所爱变坏所欲匮乏生染恼心。名为扰恼。如是名为由内增上所生众苦。此复如前应知。或有已所遭苦。或恐当遭生怖畏苦。时差别苦者。谓即如是诸品类苦过去已有。未来当有。现在今有。如是总名时差别苦。身差别苦者。谓自习行邪行为因。能令己苦。由是因缘。他虽正行亦能令苦。如是名为身差别苦。当知此中前三名。为唯能引自无义利行。从一名为亦能引他无义利行。云何四处不得善巧。谓于诸界诸处缘起处非处中。皆不了达。与上相违。当知即是聪慧二相。又由无色意处所依所缘自类流转差别。当知建立有十八界。由五色处。安立运转驱役所依体性差别。当知建立有余六界。安立所依体性差别。谓地等四。运转所依体性差别。即是空界。驱役所依体性差别。即是识界。由染净品想及寻思所依义故。当知建立有余六界。谓欲恚害并彼对治。贪嗔痴缚所依义故。当知建立有余六界谓苦乐忧喜舍无明。若有非理作意思惟。即便生起邪想寻思。若有如理作意思惟。即便生起正想寻思。又由三界染净二品遍行义故。当知建立有余四界。谓名所摄受等四蕴。又由所染所净清净即此不净。清净增上如前所说。外不出离。出离义故。当知建立有余三界。谓欲界色界无色界。如前所说。内不出离。出离义故。当知建立有余三界。谓色界无色界灭界。又即由此内外二事出离增上。听闻正法或不正法。如理思惟。或不如理思惟。依处三种言事差别义故。当知建立有余三界。谓过去界未来界现在界。又由所知诸苦烦恼多中少义。当知建立有余三界。谓劣界中界妙界。若有上苦及上烦恼。是名劣界。若有中苦及中烦恼。是名中界。若有少苦及少烦恼。是名妙界。如是遍知劣中妙界。又由远离此因缘义。及由修习此对治义。当知建立有余三界。谓善界不善界无记界。又由修善清净差别缺缚义故。无缚义故。具缚义故。当知建立有余三界。谓学界无学界非学非无学界。又即由彼有学无学与诸愚夫。若共不共世出世法成就义故。当知建立有余二界。谓有漏界无漏界。又即由彼世出世间若常无常有上无上差别义故。当知建立有余二界。谓有为界无为界。一切皆为趣向涅槃。悉以涅槃为其后际。熟修梵行。是故过此无复立界。诸处缘起及处非处所有善巧。如声闻地已辨其相。又若略说处及非处善巧相者。谓或依止趣五趣行。或复依止趣涅槃行。此一切行略有三种。谓劣中胜。趣恶趣行说名为劣。趣善趣行说名为中。趣涅槃行说名为胜。所以者何。趣善趣行此最为极。更无余行。唯此能感所有世间最极圆满。谓能感得转轮王身。或帝释身。或魔罗身。或大梵身。彼无第二。更无有余补特伽罗或男或女与其等者。趣涅槃行当知能证一切有情最胜法性。谓声闻菩提。独觉菩提。无上菩提。诸佛如来于彼一切最为殊胜。一切三千大千世界补特伽罗无与等者。又余所有安住菩提劣功德者。于诸世间得增上位尚为殊胜。何况如来。彼复云何。谓于是处正见具足补特伽罗。不能现行。诸异生类堪任现行。当知一切如经广说。

复次嗢拖南曰

  自性与因缘　　见染数取越
  转差别道理　　寂静后观察

诸受自性应当了知。诸受因缘应当了知。于受正见应当了知。于受杂染应当了知。于能受受补特伽罗思择不思择二力差别。应当了知。如是于受解脱。不解脱流转品别。应当了知。诸有所受皆苦道理。应当了知。诸受寂静止息差别。应当了知。于受观察一切受相。应当了知。略说三受。是受自性。

三品类触是受因缘。又诸乐受变坏法故。贪依处故。贪是当来众苦因故。由此应观乐受为苦。若诸苦受现在前时。恼害性故。如中毒箭而未得拔。由此应观苦受如箭。非苦乐受已灭坏者。是无常故。正现前者。是灭法故。于二更续能随顺故。由此应观。非苦乐受性是无常性是灭法。

如是于受所生正见。能随悟入诸有所受皆悉是苦。

于乐受中有贪随眠。于苦受中有嗔随眠。于非苦乐无明随眠。是名于受所起杂染。难于乐等所有诸受现前分位。一切未断烦恼随眠之所随眠。然由缘彼各别所行诸缠。生起此后睡眠烦恼随缚。即名于彼相续随眠。为欲永害诸随眠故。熟修梵行。非唯为遣诸缠因缘。

无思择力补特伽罗。受苦受时心极忧悴。即此苦受若身若心现前领纳。所余乐受非苦乐受。由未断故。而说相应。是故名为现见圆满冥闇受坑难得其底。有思择力补特伽罗。应知一切与上相违。

又于诸受心未解脱补特伽罗。但于苦受圆满领纳。犹如一人中二毒箭。二毒箭者即喻三受。或染心领纳。谓由贪嗔痴。或相应领纳。谓由生等苦。如是彼由现法所有上品苦故。及由现法诸杂染故。亦由后法所有苦故。由是诸处受其染恼。心解脱者。应知一切与上相违。此差别者。具领三受。又若有受于依止中生已破坏消散不住。速归迁谢不经多时。相似相续而流转者。应观此受犹若旋风。若有诸受少时经停相似相续不速变坏而流转者。应观此受如客舍中羁旅色类。又彼诸受自性所依染净品别。当知名受品类差别。有味受者诸世间受。无味受者诸出世受。依耽嗜受者于妙五欲诸染污受。依出离受者。即是一切出离远离所生诸善定不定地俱行诸受。

又诸苦受一切众生现知是苦。不假成立。所余二受。由二因缘。应知是苦。非苦乐受。及能随顺此受诸行。由无常故。应知是苦。所有乐受。及能随顺此受诸行。变坏法故。应知是苦。由此道理。当知诸受皆悉是苦。

又彼诸受应知略有三种寂静。一由依止上定地故。下地诸受皆得寂静。二由暂时不现行故。而得寂静。三由当来究竟不转。而得寂静。当知此中暂时不行。名为寂静。令其究竟成不行法。名为止息。乐言论者。广生言论。染污乐欲展转发起种种论。说名为语言。即此语言若正证入初静虑定。即便寂静。又粗寻伺能发语言。诸未得定。或有已得还从定起能发语言。非正在定。正在定者。虽有微细寻伺随转。而不能发所有语言。是故此位说名一切语言寂静。是名第二义门差别。又瑜伽师。于贪嗔痴深见过患。安住领纳贪嗔痴等离系诸受。数数遍知数数断灭贪嗔痴等故。说其心于贪嗔痴离染解脱。

又由七行。于诸受中观受七相。谓观诸受自性故。现在流转还灭因缘故。当来流转因缘故。当来还灭因缘故。杂染因缘故。清净因缘故。及清净故

复次嗢拖南曰

  受生起劣等　　诸受相差别
  见等为最胜　　知差别问记

一切有情应断诸受。略由三缘而得生起。一者欲缘。谓于未来世。二者寻缘。谓于过去世。三者触缘。谓于现在世现前境界。云何名为一切有情。谓有情众略有八种。一在家众。二出家众。三于诸欲未离贪众。四于诸欲已离贪众。五于初静虑未离贪众。六于初静虑已离贪众。七从此已上乃至非想非非想处未得离贪诸外道众能入世间定。具足于邪见乃至邪解脱智者。八住内法众能入世间定。具足于正见乃至正解脱智者。及住内法众能入出世定者。由此八众依能领纳诸受遍知。应知普摄诸有情众。又在家众或出家众于诸欲中未离贪者。由三因缘。诸染污受而得生起。一由染着力。二由作意力。三由境界力。当知此中诸在家者。追求诸欲。为受用故。发生欲乐。由染着力。即此非理思惟先时曾所领受。由作意力。于现前境现在受用。由境界力。应知如是补特伽罗欲寻触缘。由现行故。皆不寂静。以此为缘发生三受。又由最初染污欲寻触现行故。领纳彼缘所生诸受。若彼生已染着不舍。亦不除遣。如是彼受长时相续随转不绝不得寂静。不寂静缘长时相续领纳诸受。又彼欲等由其最初长时相续恒现行故。彼缘彼品所有烦恼堕在相续未永断故。即说名为不寂静缘。是名第二义门差别。若诸出家未离贪者。由于诸欲能弃舍故。其染着力所摄受欲。虽得寂静。作意境界力所摄受若寻若触而未寂静。由是因缘。彼于独处于寻对治。未善修故。一切离欲皆未作故。于曾受境。非理作意。寻思现行。于诸胜妙现前境界。有触现行。若于寻思深见过失。于彼对治已善修故。一切离欲未尽作故。欲如前说。已得寂静。由是因缘。寻亦寂静。唯触独一未得寂静。若胜妙境现在前时。诸染污触便复生起。若于诸欲已离贪者。当知一切皆得寂静。是名一种义门差别。复有一类。于诸欲中未离贪者。由于诸欲所有贪欲未永断故。诸寻染触未永断故。由是一切皆未寂静。若于诸欲贪欲。已断证初静虑。欲已寂静。寻未寂静。于初静虑已离贪者。乃至非想非非想处未离贪者。二已寂静触未寂静。超过有顶一切寂静。是名第二义门差别。若诸外道能入世间定。具足于邪见乃至邪解脱智者。由彼为缘生起诸受。于彼染着。又由彼品烦恼随缚。即由如是不寂静缘。诸受生起。若住内法能入世间定。具足于正见乃至正解脱智者。由彼为缘。生起诸受。于彼染着。又由彼品烦恼随缚。即由如是不寂静缘。诸受生起。又住内法。能入出世定者。若依向道转。自事未究竟。所有诸欲未得为得。未证为证。未触为触。作是希望。我于是处何时当得。广说如前。彼未寂静。由是为缘。彼于尔时诸受生起。若于自事已得究竟彼欲寂静。由寂静缘。便有第一寂静无上诸受生起。彼于一切所有诸受出离方便。如实了知。是故如前于第一义诸沙门中。许为沙门。诸梵志中许为梵志。若不了知。于彼一切皆不忍许。当知此中一切诸受无有差别。皆触为缘。又即此缘欲。亦为缘寻。亦为缘境界。愚痴所摄无明亦为其缘。如是一切不正思惟。及堕相续彼品烦恼以为其集。由此灭故。彼亦随灭。正见等道当知说名能趣灭行

复次于远离喜身作证住诸圣弟子。能断五法。能修五法。令得圆满。应知如前三摩呬多地广办其相。又喜乐舍劣中胜品。谓在欲界及四静虑。如其所应。当知其相。又在第四静虑地。舍一切过患。皆远离故。名善清净。若此上舍复可立为胜无爱味

复次由十种相。当知诸受所有差别。一胜义差别。二流转所依差别。三自相差别。四尽所有性差别。五自相品类差别。六流转门差别。七杂染门差别。八所治能治差别。九时差别。十刹那展转生起差别。此中或有无开觉者。作如是言。受唯有二。一苦。二乐。虽复说有不苦不乐。然唯苦乐。无性所显。是故世尊。即依如是苦乐寂静。假设为有。世尊为欲开晓彼故。说如是言。乐有二种。所谓欲乐及远离乐。此远离乐复有三种。一者劣乐。二者中乐。三者胜乐。劣乐者。谓无所有处已下。中乐者。谓第一有。胜乐者。谓想受灭。既有是理。乐受亦得说为寂静。谓在初二三静虑中。非苦乐受亦名寂静。谓在第四静虑已上乃至有顶。一切受无亦名寂静。谓在灭定。然佛世尊。约第一义说有三种最寂静乐。谓诸苾刍心于其贪离染解脱。如于其贪于嗔于痴。当知亦尔。如是一切总为三乐。一者应远离乐。二者应修习有上住乐。三者最极究竟解脱无上住乐。应远离乐者。谓诸欲乐。应修习乐者。谓初静虑乃至有顶诸所有乐。有上住乐者。谓灭尽定。此亦名为应修习乐。最极究竟解脱无上住乐者。谓如前说三最胜乐。非据受乐说。灭尽定以为有乐。然断受乐说名为乐。又胜住乐与乐相似。又即依此有乐可得说名为乐。谓如有一。从此定起有所领受。作如是言。我已多住如是如是色类最胜寂静乐住。由依此故。说名有乐

复次若有苾刍。依止如是色类见闻及乐想有。无间随得诸漏永尽。当知此见名最胜见。乃至此有名最胜有。从无我见。不更寻求其余胜见。谓无常见。即此无间随得漏尽。是故此见名最胜见。依止此见。复由四门。方能随得诸漏永尽。一或从他听闻正法。二或依四现法乐住。三或依止三种想定。谓从空无边处乃至无所有处。四或天有或在人有。是故此闻于其余闻。此乐于其余乐。此想于其余想。此有于其余有。说为最胜

复次由遍了知应遍知事。于其苦谛得遍解脱。于其集谛得胜解脱。于其灭谛能正作证。于其道谛能正修习。正于苦边能随得者。谓于苦谛得遍解脱。于诸漏尽能随得者。谓于集谛得胜解脱。应厌应离应解脱者。谓于灭谛能正作证。于无常等随观住者。谓于道谛能正修习。又由十相应当了知境事差别。一者已生诸行系属命根住因差别。二者有色无色诸行展转相依住立流转差别。三者无色诸行无常法性入门差别。四者心诸杂染依处差别。五者一切诸行一切品类总皆是苦差别。六者净不净业果受用门差别。七者有喜乐识所行边际差别。八者爱恚依处差别。九者喜乐执藏有情生处安住边际差别。十者堕往恶趣依处边际差别。又清净品应得应修事增上故。当知有余十种差别。一者善法无间修习增上无逸差别。二者心慧解脱依止差别。三者胜三摩地边际差别。四者于一切境系缚其心边际差别。五者解脱方便差别。六者解脱差别。七者等觉真义差别。八者现等觉后于三学中受学差别。九者正学已学现法乐住差别。十者证圣神通广行差别

复次即依如上所说差别。应生问论。摽举者。谓由未了义理。记别者。谓由已了义理。当知此中由四因缘。能请问者不应与言。由四因缘。能记别者不应与言。前四种者。一于现量。二于应理。三于其因。四于非因。谓等示现时而不领解。比度分别正施设时。而不领解。汝自修行自然当了。而不领解。正智论者。亲自演说由此至教。亦不领解。是故于此能请问者。不应与言。后四种者。谓一切行皆是无常。一切诸法皆无有我。一切生处皆不可乐。净不净业终无失坏。是一向记。故思造业当受于苦。此非一向。获得于舍。于现法中定般涅槃。亦非一向。若有问言造作业已往善趣不。应反诘云汝问何业。若有问言修习道已得涅槃不。应反诘云汝问何道。为是世间。为出世间。置记论者。谓依一切所有见趣。如是四种正答问者。名善能记。应可与言。与此相违。不应与言

复次诸佛如来有二记别。一共外道。二者不共。共外道者。记诸弟子当生处等。言不共者。终不记别。有生者。等有二识火炽然所依。一微细爱。二粗名色。欲色二界爱所生识名色为依。爱若止息乃至寿量其识相续随转而住。若无色界爱所生识。但缘其名而得住立。爱若断灭乃至寿量其识相续随转而住。又于色界此爱为依生中有识。即爱为依令于中有般涅槃者暂尔安住。此爱若断即于尔时其识谢灭。复有二种意所生身。一者色界意所生身。二无色界意所生身。谓由定地意门方便。而能集成。二生身故。又诸如来略有二种善避他论。一者能避定不应记作不定论。二者能避决定应记作不定论。如说喜乐色等义别如是。喜乐取等义别应知亦尔

瑜伽师地论卷第九十六瑜伽师地论卷第九十七

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事菩提分法择摄第四之一

如是已说缘起食谛界择摄。菩提分法择摄。我今当说。总嗢拖南曰

  念住与正断　　神足及根力
  觉道支息念　　学证净为后

别嗢拖南曰

  沙门沙门义　　喜乐一切法
  梵行数取趣　　超二染为后

依四念住修习增上。由四因缘。应知内法有沙门道。及有究竟。外法决定无沙门道。亦无究竟。当知他论诸沙门道及以究竟。一切皆空。云何名为四种因缘。一者依止四处得四证智故。二者解脱四种外随烦恼故。三者内法弟子与外道弟子不同品类故。四者内法大师与外道师不同品类故。云何名为内法沙门。谓诸沙门略有四种。一者胜道沙门。二者论道沙门。三者命道沙门。四者污道沙门。是四沙门若略若广。如声闻地已辩其相。内法道者。云何为道。谓八支圣道。若处施设八支圣道。是处施设污道。为后四种沙门。若有其道自行邪行。非生道器。由是因缘。容有污道。是故外法尚无污道。况得有余。内法究竟者。云何究竟。谓断诸取。诸取断已。当来毕竟无复相续。云何名为依止四处。云何复名得四证智。谓四处者。一三结永断苏息处。二无退堕法势力处。三定趣菩提种类处。四极七反有随行处。依此四处。于佛法僧及于净戒。得证净智。云何名为解脱四种外随烦恼。一者解脱现法外随烦恼。二者解脱后法外随烦恼。三者解脱展转互相违戾所作外随烦恼。四者解脱于诸圣谛不能宣说。不能觉悟。所作外随烦恼。当知此中诸外道类阙念住故。其念忘失不正知住。领纳诸受或乐或苦或非苦乐。于乐起染。于苦起恚。于非苦乐发起愚痴。如是名为第一现法外随烦恼。彼由如是染恚痴故。以受为缘生后有爱。以爱为缘发生诸取。有爱取故以取为缘成办于有。广说乃至。纯大苦聚积集增长。如是名为第二后法外随烦恼。又诸外道萨迦耶见以为根本种种见趣意各别故。彼此展转互相违戾。是名第三外随烦恼。又诸外道遍于一切四圣谛中。尚无有能施设其教。况当觉悟。是故彼于自师宗智虽得增上。而实无知堕无明趣。是名第四外随烦恼。住内法者于是一切皆能解脱。云何内法弟子与外道弟子不同品类。谓外道弟子或堕有见常边。或堕无见断边。长夜积集。深起藏护。由闻亲近。由思染着。由修染着。内法弟子行处中行远离二边。云何内法大师与外道师不同品类。谓外道师于一切取。虽同宣说断遍知论。而于诸取不能施设正断遍知。由彼本契出家舍欲故。于欲取立断遍知。非于自见自戒我语。若有与他诸余沙门婆罗门等。见不同分。戒禁同分。彼于见取亦能随分立断遍知。非于戒禁我语二取。若有戒禁亦不同分。于戒禁取亦能随分立断遍知。其我语取于一切时。一切外道悉皆共有。是故外道于自于他。我语取中。皆不施设断遍知论。又彼虽能分舍诸取。而于当来还复能取。未永断故。如是外道于诸取中未全断故。未永断故。不得究竟。内法大师当知一切与上相违。如是应知内法大师与外道师不同品类。

复次依四念住修习增上。略由三处三地三种补特伽罗。当知普摄诸沙门义。云何三处。一境。二智。三证。云何三地。一正加行摄异生地。二有学地。三无学地。云何三种补特伽罗。一正加行异生补特伽罗。二有学补特伽罗。三无学补特伽罗。云何名境。谓地等六界与六触处为所依体。此六触处与十八意行为所依体。十八意行能杂染心。云何名智。谓心清净增上慧依处。云何名证。谓即慧依处增上。若谛依处。若舍依处。若寂依处。云何慧依处。谓慧为依处于正加行异生地中。正修善法为因缘故。能无放逸入有学地。若慧为依处证阿罗汉。无学地中得尽智故。如实了知我生尽等。若学无学出世智后诸世间慧。云何谛依处。谓已获得八支圣道。断诸烦恼。由此依处当来众苦毕竟不生。由此毕竟无忘失故。名谛依处。云何舍依处。谓断彼事。由此依处。于已断事。无杂染行。现法乐住。云何寂依处。谓为断灭所余结事。方便勤修。如已得道此为依处。于所余结及所余事。能舍无余。如是一切。以要而言。为欲得证故。修其智。既得证已便获圣道及圣道果。果有二种。谓烦恼断及与事断。此中一种证所未证。第二依处舍未来苦。第三依处能随习近现法乐住。第四依处断未圆满能令圆满。齐尔所处。诸瑜伽师。于所应作皆得究竟。谓于未证由初能证。于未来苦第二能舍。于现法乐第三能住。于上断灭所未圆满。第四能满。如是一切由四依处应当了知。此中先所获得圣道名寂静道。为断上位烦恼事故。正修习时。于其事断倍趣增益。于烦恼断防未得退。此中云何由智观察所知境界。证所应证。谓正加行异生地中。正行异生补特伽罗。由内外别观察五界。于所有身住循身观。谓心解脱及慧解脱为增上故。彼起如是如理加行。于诸界中住唯界想观。唯有界都无有我。依思择力。于诸色界已远离贪。而于所缘犹未能断。于未来世不希望故。于现在世不耽着故。名已离贪。未能永害彼随眠故。名于所缘犹未能断。彼于其贪已远离故。由心解脱。为增上力远离贪故。心得清净。而于所缘未能断故。有余上位应更修治。从此已后。于六触处所摄境界。无倒观察。于诸受中住循受观。彼如前说。依思择力。于诸受界。亦远离贪。历观缘生无常性故。即如前说。而于所缘犹未能断。彼于无明已远离故。由慧解脱。为增上力。依诸明触所生如理作意相应所有善受。于一切受所生杂染厌舍而住。由于无明触所生受为缘起贪已远离故。名得清净。而于随眠未永断故。有余上位应更修治。从此已后于十八意行无倒观察。俱于心法同时安住循心法观。彼作是思。此十八意行最第一者。谓诸所有寂静解脱。超过诸色在于无色。于能顺舍起诸意行。复作是思。若我依此胜妙意行。于清净舍若定。若生耽着系忆。因此我心便成杂染。如是知已舍而不忆。是名于心住循心观。复于诸处观无常性。是名于法住循法观。彼于尔时于三想定及以非想非非想处所有诸行余第一有。已离贪故。名于想界及行界贪。亦得远离。余如前说。如是彼于正加行摄异生地中。净修心已为欲证会。学心解脱。复于一切身受心法。观唯有法都无有我。于一切有深心厌舍不起加行。谓我当有。或我当无。如实了知此中无有有者无者。彼由如是如实知故。渐于见修所断三漏心得解脱。得尽智故。观察一切当来诸受不复流转。此不流转由身灭故。彼于尔时。依诸漏尽所获尽智为最第一。有学异生诸慧依处犹有垢故。今此所得定无垢故。又即此慧于诸烦恼断灭谛中。以寂静行攀缘而住。暂时失念亦不能动。如是所有心慧解脱。不为忘念之所陵杂。如前异生及有学位。以彼尚有忘失法故。谛不圆满。在无学位。于一切时如实性故。其谛圆满。故谛依处成就第一。由能弃舍一切依事故。舍依处成就第一。一切道果所集成故。名善修道。非如异生及诸有学故。寂依处成就第一。问何因缘故。唯在无学四种依处说为第一。非在异生及有学位。答在此位中微细淋漏亦不可知。况有中上。在异生地淋漏弥多。有学位中少可知有。此中何等名为淋漏。应知如前诸动举等说名淋漏。于彼一切皆永断故。趣向圆满牟尼性故。说名牟尼最极寂静。又已永害当来因故。于初中后生老死苦。永止息故。现法行时于诸世法四种贪爱永寂静故。四种嗔恚永寂静故。又于住时不悦諠杂永寂止故

复次依修所有菩提分法圆满增上。由七因缘。当知建立七种正法。何等为七。一闻所成作意所缘故。二思所成及修所成作意所缘故。三即此三种作意加行时差别故。四于受用财遍受用财善通达故。五受用财法于时时间从他得故。六于究竟时内离上慢无失坏故。七亦于他所离增上慢无失坏故。此中依诸止举舍相修习知时。如声闻地及三摩呬多地已辩其相。食饮等义如声闻地应知差别。又于此中受用财者。谓于刹帝利婆罗门长者等众。受用法者谓于沙门众。我应如是行者。谓善护于身。善守诸根。善住正念。应如是住者。谓至门首若不听许则不应入。或得入已若不听许不应自专就座而坐。应如是坐者。谓不应宽纵一切身分。乃至广说。应如是语者。谓五种语。一应时语。二应理语。三应量语。四寂静语。五正直语。应如是默者。谓于五时应当宴默。谓或纷扰故。或相诽拨故。或违诤而住故。或延请故。或谈论故。为待言终所以宴默。云何应时语。谓非纷扰。或遽寻思。或不乐闻。或不安住正威仪时。而有所说。又应先序初时所作。然后赞励正起言说。又应待他语论终已方起言说。如是等类一切。当知名应时语。云何应理语。谓依四道理。能引义利称实而语。名应理语。云何应量语。谓文句周圆。齐尔所语决有所须。但说尔所不增不减。非说杂乱无义文辞。如是等类名应量语。云何寂静语。谓言不高疏。亦不喧动。身无奋发。口不咆勃而有所说。名寂静语。云何正直语。谓言无诡诈。不因虚构而有所说。离谄曲故。发言纯质。如是当知名正直语。于己所无信等善法不起上慢。谓为自有。于其狭小亦不增益以为广大。唯于实有乃至所有。如实了知自称言有故。名自知。又信为先受持净戒。持戒为先求多闻法。由此为先舍诸过失。普于一切资财身命。无所顾恋。由此为先心得静定。证如实智。如是五法。由四因缘之所显发。一由他教故。二教增上力自内证故。三俱生寻思胜辩才故。四由先串习获得俱生功德相应。善男子故。略有二种补特伽罗者。双标二种。如是二种者分别二种此二为胜者。当知简择二种差别。修七善法得二胜利。谓现法中得轻安乐。觉境实性。发生胜喜。由是因缘多住喜乐。安住是已能如理思。速疾证得诸漏永尽

复次依修菩提分法增上。于善说法毗柰耶中。略由诸学及诸学果摄一切法。云何诸学。谓三种学。一增上戒。二增上心。三增上慧。云何学果。谓有余依及无余依二涅槃果。当知此中一切法者。谓善法欲清净出家为证涅槃先受持戒。由是渐次乃至获得究竟涅槃。是故宣说一切诸法欲为根本。又依净戒引求正法。摄受多闻。由闻正法增上力故。能速集证增语明触。是故说彼以为触集。又彼皆为流趣明触所生诸受。乃至有余依般涅槃界为其后际。为求安乐而发起故。此乐一向无罪性故。是故说彼学所摄法。为受流趣。又彼为求所有明触及依明触。所生诸受。起闻思修所成作意。是故说彼为作意生。又于尔时。于四念住由观品念。以观为依。与内心止为其增上。是故说彼念为增上。又念增上起奢摩他。与后圣谛现观妙智为上首转。是故说彼定为上首。又于圣谛诸现观中慧为最胜。谓能无余永尽诸漏。是故说彼慧为最胜。又由一切漏永尽故。获得究竟明触生受俱行解脱。即此解脱非由一切学所摄法数数随得。唯由顿得。由此解脱一切乐中为最第一。无罪性故。是故说彼即用解脱以为坚固。又彼如是善解脱心。若诸明触所生受等。若学所摄所有诸法并所依身。于无余依般涅槃界。任运自然究竟寂灭。是故说彼皆以涅槃为其后际。应知此中欲为增上受持净戒。名增上戒学。依止触受增上心慧。任持方便所有作意若念若定并其加行。名增上心学。慧为最胜名增上慧学。如是应知名为三学。及彼依持解脱坚固。是有余依般涅槃界第一学果。涅槃后际是无余依般涅槃界第二学果。如是略说学及学果摄一切法。又此诸学及诸学果能证资粮。当知对治八种过患。修集九想。云何名为八种过患。所谓耽着利养恭敬。爱藏一切后有诸行。懈怠懒堕。萨迦耶见。贪着美味。于诸世间种种妙事欣欲贪爱。依止放逸恶行方便。依止邪愿修习梵行。云何名为修集九想。一者修集出家想。二者修集无常想。三者修集无常苦想。四者修集苦无我想。五者修集厌逆食想。六者修集一切世间不可乐想。七者修集死想。八者修集世间平等不平等想。九者修集有无出没过患出离想。应知此中所有如法平等行。摄能往善趣善身语意业。说名平等。所有非法不平等行。摄能往恶趣不善身语意业。名不平等。又住于此若生若长能生后际所有众苦。说名为有。从其前际于现法中有死灭苦。说名为无。余出没等。应知如前已广分别

复次诸外道辈。闻不正法增上所生不如理想为依止故。发起无明所生诸受。由此为依发生诸漏。而诸外道于是诸漏不如实知。亦于无明触所生受不如实知。亦于听闻诸不正法增上所生所有邪想不如实知。于是三处不实知故。发起欲求发起有求。亦复发起邪梵行求及无有求。彼于诸欲不如实知。于后有业不如实知。于其众苦不如实知。此中前五是集谛处。最后一种是苦谛处。如是外道于此集谛及以苦谛不如实知。又即于此集谛苦谛。略由二相不如实知。一杂染故。二清净故。此中杂染复有四相。一自性故。二因故。三果故。四因果差别故。此中清净复有二种。一集苦灭。二趣灭行。彼于如是四圣谛中。阙乏正智不能修习菩提分法。由是因缘。彼所修行所有梵行。不得名为最极究竟。即由此缘不名究达。不尽漏故。住内法者。与彼相违。所修梵行最极究竟。名为究达。尽诸漏故

复次于其六种补特伽罗。依染净法。如来所有大士根智及当来法生起智转。云何名六补特伽罗谓有一类补特伽罗。先余生中。于佛善说法毗柰耶获得净信。广说乃至。得正直见。彼于今生于恶说法毗柰耶中。近不善士闻不正法。非理作意。于现法中最初生起诸邪见。爱诸业杂染。彼于尔时。成就前生所有善法及现法中诸不善法。复于后时。于善说法毗柰耶中。亲近善士听闻正法。如理作意。即由先因弃舍恶说法毗柰耶。于恶说想诸不善法。不生染着。速能遣灭。此于当来成清净法。是名第一补特伽罗。复有一类补特伽罗。先余生中。俱行二法毗柰耶行。由彼为因。于现法中。成就善法及不善法。彼于今生最初如前于善说法。乃至获得如理作意。于现法中诸不善法。令旧灭没新不复生。诸有善法令旧增长新复更生。诸先所有不善未断。随眠随逐。今于一切皆能断除。无放逸住。此于当来成清净法。复有一类补特伽罗。先余生中唯行外行。彼于今生由是为因。串习出家故。串习邪见故。于善说法毗柰耶中。遇缘和合而得出家。既出家已复生邪见。住自见取造无间业。亦断善根。一向成就诸不善法。恶趣决定。是名第三补特伽罗。如是三种补特伽罗。当知第一先于内法纯习因行。于现法中先行放逸。后不放逸。第二补特伽罗。先于内外俱习因行。于现法中当知一向行不放逸。第三补特伽罗。先于外法纯习因行。于现法中当知一向多行放逸。如是三种补特伽罗。复有余三补特伽罗。与上相违。应知其相。此中第一补特伽罗。先于外法纯习因行。于现法中先不放逸。后行放逸第二补特伽罗。先于内外俱习因行。于现法中专行放逸。第三补特伽罗。先于内法纯习因行。于现法中当知一向修不放逸。又于此中先世所习善不善因。犹如种子。今世善说法毗柰耶。于其先世诸善种子。犹如良田。于彼先世不善种子。犹如瘠田。与是相违。今世恶说法毗柰耶。于其先世不善种子。犹如良田。于彼先世诸善种子。犹如瘠田。又彼先世因增上力。今善法起。犹如光明。与彼一切如无明闇诸不善法为能对治。彼不善法与彼一切犹如光明所有善法为所对治。如是先世诸不善法。如有热炭。由有能烧身心义故。今世恶说法毗柰耶。如干[竺-二+韋]舍。又彼先世所有善法。如有热炭。由有能烧烦恼义故。今世善说法毗柰耶。如干[竺-二+韋]舍。又彼先世所有善法。处今恶说法毗柰耶。田损减故。犹如置在冷地石器如无热炭。又彼先世诸不善法。处今善说法毗柰耶。由断灭故。犹如置在冷地石器如无热炭。此中诸如来。由大士无上根胜劣智力。于其先世善不善因所集成根。随其所应如实了知。又于现法染净门转。生起当来染净诸法。亦随所应如实了知故。言成就甚奇希有

复次往恶趣行。往善趣行超度差别。当知略有五门不同。由此五门。于自超度如实了知。于他超度亦正遍知。所谓诸佛及佛弟子。云何名为往恶趣行。谓诸外道所有一切萨迦耶见以为根本。诸恶见趣并彼所缘并彼所依以为依止。发生种种恶欲。及害。若杀生等所有无量恶不善法。如经广说。乃至所有诸非法行不平等行以为最后。能往险恶处。能往那落迦。能往诸恶趣差别生起。若往于彼名生恶趣。领受彼因所感非爱诸果异熟。如是名为往恶趣行。于此多闻诸圣弟子。若彼所缘生诸见趣。若自所依令起执着。若诸所有能往一切险恶趣等诸恶欲等。广说乃至。诸非法行不平等行以为最后。若住于彼。领受非爱险恶等果。如是一切。如实随观非我我所。谓于是中。决定无我。亦无我所。如是观已。当于圣谛得现观时。彼诸见趣随眠根本皆永拔故。说名为断。其余一切毕竟不续。此圣弟子于彼见趣以为根本所有能往险恶处等。定不能作。定不能往险恶处等。是名第一往恶趣行永损害门。由是因缘。能于自内如实了知离我等圣。所余异生虽复有能以世间道超度能往恶趣不善及恶趣等获得四种现法乐住。或得超过诸色无色寂静解脱。然其不能究竟损害诸恶趣等后可相应。是故彼流虽极能离欲色界爱暂时获得胜上乐住。而复当来更还造作杀生等事。往诸恶趣。我等定当不能造作杀生等事。乃至广说。诸非法行不平等行。我等定当能不造作。是名圣法毗柰耶中永损害门。谓能损害往恶趣行。如是诸佛及佛弟子。能实遍知永损害门所有差别。又即如是诸圣弟子。为欲超度所余未断往善趣行。此圣弟子。于先所作不生喜足。于上漏尽起欣乐欲。发正愿心。于彼所得诸世俗道。审观过患。谓彼不能究竟离苦。是名第一为欲超度往善趣行发心愿门。发心愿已。普于一切善趣后有所生爱味。深观过患如险恶道心生厌离。欣慕寂静现法涅槃。正修方便。由是进趣如先所得趣涅槃行。如是名为能进趣门。彼由修道渐次离欲。乃至能入第一有定。若于上舍多生爱味放逸因缘。于现法中不般涅槃。但名上行不还果者。如是名为后上行门。若复于彼深观过患。于上舍中不生爱味。彼于现法能证涅槃。依有余依般涅槃。说如是名为般涅槃门。由是门故。如实了知自般涅槃超度一切往善趣行。于他超度。亦正遍知。所谓诸佛及佛弟子。此中初一永损害门。当知超度往恶趣行。后发心愿进趣上行涅槃四门。当知超度往善趣行

复次诸圣弟子已见谛迹未离欲者。应知略有二种杂染。谓欲杂染后有杂染。于此二种。诸圣弟子。应勤加行净修其心。诸圣弟子为欲断除欲杂染故。勤方便时渐依三行。谓趣无动行。趣无所有处行。证入无动无所有非想非非想处定。此由断对治故。及远分对治故。超度欲杂染。或为断除后有杂染。勤方便时。已离欲界爱。未离色界爱。谓我所何当不有。我何当不有。我当不有。我所当不有。若今所有。若昔所有。如是一切。我皆弃舍。彼正修习能断后有所有差别对治道已离色界爱。乃至能入非想非非想处定。若现法中。于其上舍多生爱味不般涅槃。彼于现法不全解脱一切所有后有杂染。若于上舍不生爱味。彼现法中能般涅槃。能全解脱所有一切后有杂染。当知此中若为对治欲杂染故。修对治道。渐次乃至能入第一有定。若为对治后有杂染。修对治道。渐次乃至能入第一有定。如是二种名共解脱。由诸圣者非圣异生皆可容有。是故此解脱不名圣解脱。若于一切乃至有顶萨迦耶苦。如实知已超度有顶。于现法中永断一切所有杂染。如是解脱唯诸圣者方能获得。故此解脱名圣解脱。如是一切总有五处。一趣无动行。二趣无所有处行。三趣非想非非想处行。四现法涅槃。五圣解脱。复有三种诸欲过患。一者诸欲能为顺乐受境界所生贪欲因缘。二者诸欲能为顺苦受境界所生嗔恚因缘。三者诸欲能为顺不苦不乐受境界所生无明愤发因缘。又此诸欲当于三处应观过患。一自性故。二所缘故。三助伴故。自性故者。谓虚妄分别所生贪爱。所缘故者。谓若内若外五种色境。助伴故者。谓非理作意相应倒想。又离上欲胜方便心。说名广大。何以故。由彼上地转上转胜故。修彼心说名广大。若能厌离下地世间。当知定以无常等行厌坏制伏。于其上地所应得处。当知亦以暂时方便。起寂静想。住持其心。又我已得于是处所具足安住。生信解者当知彼于加行道中修习净信。于是处所生净信心。由此净信增上力故。修习精进念定慧等。从初静虑渐次乃至识无边处诸无动定。皆能证入。又由其慧起是胜解。谓我已能入如是定。此即能感识无动处所有生果。若现法中不般涅槃。或不进求往于上地。彼于当来决定应往此无动处。又由三缘。于是诸地。当知建立为无动处。谓外欲等散动断故。立初静虑为无动处。寻伺喜乐色界地中诸动断故。立第四静虑为无动处。有色有对种种别异想动断故。立空无边处识无边处。为无动处。第二第三静虑中后后所有诸动断故。当知亦得名无动处。识无边处由空无边处外门缘动得远离故。当知建立为无动处。以要言之。缘所有定无动摇故。皆名无动。此定边际极至识无边处。是故当知。乃至此处建立无动。即此一切缘所有定。皆名有上想定。从此已上缘无所有定。当知名为无上想定。从此。已上复名非想非非想处定。故由三分宣说三行。由三种门。诸圣弟子。厌坏欲等。既厌坏已。渐次能入乃至识无边处定。是故建立能趣三种无动处行。又若色想若无动想。于诸下地。深厌坏已。能入无所有处定。是名第一能趣无所有处行。又即此处是无漏道修习边际。此无漏道复有二种。一者有上。二者无上。如有想定其有上者。无常行俱。其无上者。无我行俱。由有上行。于其下地。深厌坏已。入此处定。由无上行。于下于上。一切法中思惟无我。能入无漏无所有处定。此无上行当知名为第二趣行。此第二趣行。复由二行有差别故。建立二种。云何二行。谓能依所依智差别故。此中能依无我智者。谓诸所有若有情界若我己身。于中都无我所属处。谓地方域。我所属者。谓诸有情。我所属事谓或父或母或伴或主如是等类。如彼于我非所属处。非所属者。非所属事。如是。我亦于彼非所属处。非所属者。非所属事。此中所依无我智者。谓诸世间空无有常及我我所。此中都无常我我所真实可得。唯有诸法。如是世间既悉是空。当复有谁有所属处。有所属者。有所属事。是故当知前无我智是其能依。后无我智是其所依。非想非非想处。无无漏道。唯由厌坏无所有处想故。能入此处定。于中唯有此一趣行。又于此中我所何当不有者。谓由生等苦故。说我有苦。我何当不有者。谓即以生等苦为我。发生如是乐欲心已。正勤加行。正加行已。获得前后所有差别。由是因缘。复得决定。谓我当不有。我所当不有。若今所有者。谓今现法造作增长所有新业。若昔所有者。谓诸故业。彼于此一切所有异熟果皆不愿求。一切弃舍无顾恋故

复次嗢拖南曰

  安立边际纯　　及如理缘起
  修时障自性　　说断起修后

此中安立四念住为初。道支为最后三十七种菩提分法。若略若广。如声闻地应知其相。又由四念住。应知一切所知事边际。由所知事边际故。复应了知智事边际。又四念住由欲精进等。修习加行方得圆满。应知除此四种念住。更无有余不同分道或所缘境。由此道此境。能尽诸漏。获得涅槃。由无第二清净道故。说纯有一能趣正道。又此纯一能趣正道。由二因缘。能令有情究竟清净。一由思择力故。二由修习力故。此中愁者。谓染污忧。所言泆者。谓掉俱行欲界染喜。愁以四种世法为所依处。泆以余四世法为所依处。于四念住勤修加行。依思择力超度愁泆。由依世间修习力故。得离欲爱弃舍忧苦。依出世间修习力故。超度一切萨迦耶苦。亦能证得八支圣道及圣道果真实妙法。一切有情当知皆由思择修习二种力故。得一切种究竟清净。

复次若于身等四种所缘。发起种种非理作意。即便违背四种念住。违背此故。即便违背如理作意。谓圣如理无间能生正见支等所有圣道。违背此故。即便违背一切圣道。违背道故。便为违背道果甘露究竟涅槃。又瑜伽师了知身等因缘生已。复于三世身等诸法。住无常观。由住如是无常观故。于诸后有。终不依止后有爱住。又现法中。于一切行若内若外。都不执取我及于所。又于未来当知安住集法随观。于过去世当知安住灭法随观。于现在世生已无间尽灭法故。当知安住集灭法随观。由彼最初于身等法观缘生性。悟入无常。悟入如是无常性已。于诸爱见杂染等处。多修习住。净治其心。如是作意方得圆满。由此为依。能随获得究竟漏尽。又一切法。以要言之。谓善不善。若杂染品。若清净品。当知此中诸杂染品。皆用非理作意为集。诸清净品。皆用如理作意为集。如是一切。总略说名作意为集

复次修诸念住。若略若广。如声闻地应知其相。又此念住修习道理。非今世尊出现于世。方始宣说今圣弟子适初修习。然于过去无始时来。于诸念住。修习流转。于未来世当知修习亦无穷尽。又是过去未来现在世出世间无量善法生起依处故。说如是四种念住。名为善聚。又能障碍如是善聚故。说五盖名不善聚。又由身等四所知法无边别故。如来智慧于彼无碍。亦无有边。智无边故。如来所说无上法教。亦无有边。如是法教二缘所显。一由文故。二由义故。义差别门无有数量。法教文句开显义门。亦无数量。于此文句不重宣说。无边展转辩才无尽。是故如来成就希奇未曾有法。善能宣说所有法教。于一义中能以无量巧妙文句。方便开示而不重说。又于圣教宗义趣智善成就故。名为有趣。俱生闻思所成妙慧善成就故。名为有意。成就定故。名为有念。通达谛故。名为有慧。当知此中初一总标。后三别释

复次有诸苾刍。于身等法先由闻思如理作意。安住唯有身等法观。知一切法无我性已。不唯于此闻思作意而生喜足。唯上希求定心解脱。为求定故。住远离处。唯缘身等。以九行相。安住其心。令心内寂。由二因缘。起四念住。名善发起。一由如理作意如实智故。二由三摩地如实智故。此慧无间由如实智当得究竟

复次有诸苾刍。于三对治得随所欲。得无艰难。得无阻碍。谓无常想。若仁慈观。若无相定。彼由如是三种对治。随其所应。如前所说。于可意等身等境界。住厌逆想不厌逆想。弃彼二种舍念正知。由此因缘。当知名为善修念住

复次嗢拖南曰

  先诸根爱味　　前后有差别
  取相及诸缠　　大果利为后

有三种根。于诸念住一切善聚为障碍故。当知说名不善法聚。何等为三。一恶行根。能令当来住恶趣苦。二寻思根。能令现法住不安苦。三者根根。与恶行根及寻思根为根本故。说名根根。应知此中。诸贪嗔痴三不善根。能与身等恶行为根。欲等三想。能与欲等寻思为根。欲等三界。当知能与贪等三根及欲想等三根为根

复次有诸苾刍。于四念住勤修加行。以世间道离欲界爱。广说乃至。第一有定具足安住。即于此定多生爱味。即于此定生喜足想。不上勤求得所未得。此于圣法毗柰耶中。不名大士。何以故。其心未得善解脱故。与此相违。得名大士

复次有诸苾刍。于身等境精勤安住循身等观。以九行相安住其心。令心内聚。当知此心于奢摩他所治身心惛沉下劣。不得解脱。不解脱故。依此聚心。生起身中诸惛沈性。生起心中诸下劣性。若于念住善安住心。如实了知此所生起随烦恼已。便从内聚还收其心安置在外净妙境相。谓于佛等功德行缘。持心令住。由缘此故发生欢喜。广说乃至。由妙举门于所缘境令心得定。从奢摩他之所对治诸随烦恼而得解脱。从此已后如实了知。于随烦恼心得解脱。为此义故祈愿。于外得此义已还复如前摄心内聚。而不为其诸随烦恼之所恼乱。心内聚已不由祈愿。自然如实了知。于外心得解脱。彼于外缘行相寻思。有所制伏。有其加行难可运转。皆得自在解脱。弃舍安乐而住。已得成办胜奢摩他。如是彼于四种念住善安住心。能正了知前后差别。又应知此补特伽罗。先已修行毗钵舍那。毗钵舍那以为依止。于奢摩他修瑜伽行

复次有诸苾刍。于诸念住勤修加行。毗钵舍那以为依止。于奢摩他乐修观行。彼即应于内奢摩他所摄自心取如是相。谓我今者何所思惟。云何思惟。令奢摩他所摄受心为奢摩他所治身心惛沉下劣之所恼乱。复我今者何所思惟。云何思惟。令奢摩他所摄受心不为彼法之所恼乱。若彼苾刍不取如是自心相貌。但自了知此随烦恼染污心已。便于外缘取净妙相。由是为因。虽能暂时除遣现在现前随惑。然于后时若复如前摄心内聚。还为如是随惑所恼不得静定。如先不取自心相故。由是因缘。为随烦恼数数扰乱。又不能得所欣求义。复为忧愁之所损恼。又经长时不能获得内心寂止。不能获得依奢摩他毗钵舍那为先。清净增上第一正念正知。由不获得内心寂止故。不能得四增上心现法乐住。由不获得增上第一正念正智故。不能得先所未得无上安隐究竟涅槃。与上相违。应知即是一切白品。乃至获得先所未得无上安隐究竟涅槃。此中典厨譬瑜伽。师主即譬于内奢摩他所摄受心。其肴膳味喻执取相。上妙衣食喻于内心奢摩他等。当知黑品喻诸愚夫所有。白品喻诸智者

复次有诸苾刍。于诸念住正勤修习。而是异生或有胜妙可爱境界正现在前。或复独处得诸相状。由失念故。不如理想以为依止。率尔发起猛利贪缠。彼于此缠深心厌耻。谓如自身堕于厄难极鄙秽处。发起猛利思远离心。由如是行。便于彼缠心得解脱。既解脱已心生欢喜。从此已后起猛利厌。猛利厌后得无常想。如见大犁发诸行块。便于圣谛如实现观。以其依止依附涅槃。又即有学观察作意。于胜妙境思惟净相。由未永断贪随眠故。贪缠率尔生起现前。寻复于彼深见过患。为欲断此缠及随眠入无相定。如是能断余未断法。从定起已如实了知一切已断。领受微妙解脱喜乐。如实观见自己。成就大智力故。名为强盛。诸魔罗品其力羸劣

复次修四念住所引功德。当知能感最胜增上究竟果故。名有大果。当知能感最胜增上乐胜利故。名有大利

瑜伽师地论卷第九十七瑜伽师地论卷第九十八

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中契经事菩提分法择摄第四之二

复次嗢拖南曰

  邪师住雪山　　劝勉系属净
  渐次戒圆满　　穗成就为后

有诸外道。于弟子众自立为师。专求利养。专求恭敬。专求自利。遇缘和合。有族姓子投其出家。因而谓曰。汝之与我先无一切资身众具可共受用。汝应为我往诣他处褒赞我德掩藏我失。我亦为汝行如是事。我等二人迭相依护。当于诸王若与王等。乃至一切大商主边多获利养及以恭敬。若作是言诸外道师。名专自利。然其弟子便发抗言。勿为此见。如是护者未名自护。往恶趣失。若防此失乃名自护。是故汝应如前自护。我亦当自别为余护。我既不能护汝。汝亦不须护我。于此义中。当知弟子是如理语者。是聪慧者。重当来故。应知其师是非理语者。是愚痴者。重现在故。复有杂染触恼于他。由杂染故。不能自护。因此恼他。不名护他。此中如前由亲近等断诸烦恼。名当自护。从此已后由断为因不恼他等。名当护他。应知此中无嗔无害。是无恼义。无缘而起利乐二心。无缘而起慈悲二心。当知如此是哀愍义。由哀愍故。不恼于他。是故当知一切哀愍与彼相违

复次应知雪山喻佛善说法毗柰耶。此中略有三分可得。一无学地。二有学地。三异生地。猿猴喻彼非理作意诸相应心。猎人喻魔。于无学地俱不能行。于有学地乃至不还。唯有非理作意相应猿猴喻心独一能往。非猎人喻魔所能行。于异生地二俱能行。又诸愚夫要观余境。能出余境。追求余境。余境所缚。是故于境不得解脱

复次由于正法听闻受持观察义理。法随法行。如其次第应知劝化安立四义。复有三法。尚能断余一切胜妙淫欲贪缠。况乎鄙劣诸欲贪缠。何等为三。一精进力。二不放逸力。三对治力。由精进力其已生者令不坚住。由余二力。其未生者令不得生。如是行者勤修正行。为欲断除已生恶故。及未生者令不生故

复次于四念住殷重修习。如声闻地应知其相。系属魔者。谓在欲界。此不还果即能超度。系属死者。谓从欲界乃至有顶。此阿罗汉乃能超度。言不清净诸有情者。谓诸异生。言清净者。谓诸有学。言鲜白者。谓诸无学。复有三种证净。未清净者能令清净。已清净者能令鲜白。当知此中。上诸有学说名清净。下诸有学名不清净。彼由修道未清净故。余如前说。

复次修四念住应知略有五种渐次。一信增上力清净出家。二戒律仪。三根律仪。四乐远离。五盖清净。诸在家者虽复数数修诸念住。护得净信。诸盖清净。然阙学处。当知所修不得圆满

复次由三因缘。具戒苾刍当知禁戒净命圆满。云何为三。一所行圆满。二摄取圆满。三受用圆满。所行圆满者。谓从买卖乃至害缚断截挝打揣摩等事。皆悉远离。摄取圆满者。谓于摄取象马等事。乃至摄取生谷等事。皆悉远离。受用圆满者。谓衣仅蔽身食才充腹便生喜足。于余长物非时食等皆悉远离

复次身等四法如四大路。于彼所生非理作意。如邪祈愿稻谷麦穗。于彼所生如理作意。如正祈愿稻谷麦穗。当知欲界是不定地。犹如其皮。色无色界俱是定地。犹如其肉。无明如血。于三界中由三种漏。有淋漏义

复次如先所说所有贪等种种无量恶不善法。由二因缘。若成就者。不能修习四种念住。非是一切泛成就者。云何为二。一有贪等缠现前故。二于此缠不见过故。缠现在前杂染心故。不能修习。虽暂远离性染着故。非无恋故。于能随顺贪等诸法。其心散动。常逐漂沦。种种寻思恒随扰乱。是故不能修习念住。若不尔者诸有其性不深染着。皆应不能修习念住。若如是者无容有能修四念住

复次嗢拖南曰

  勇力修等持　　异门神足后

应知建立四种正断。如声闻地已广分别。此中宣说勇第五句。云何名勇。谓如前说堪能忍受。发勤精进。所生众苦。诸淋漏苦。界不平苦。他粗恶言损恼等事所生众苦。非此因缘退舍修习正断加行故。名为勇

复次应知建立四种神足。如声闻地已广分别。若略说者。由四种力持心令定。是故建立四种神足。云何为四。一净意乐力。二勤务力。三心喜乐力。四正智力。当知此中。由第一力。于三摩地。发生乐欲。为证得故。修习勤务。由第二力。最初住心令其安定。由第三力。已住定心无复散动。不令于外更复飘转。由第四力。观察等持所治烦恼。于断未断如实了知。又于等持入住出相。能善了别。如是复于奢摩他等所有诸相。若奢摩他毗钵舍那诸随烦恼。及随烦恼能对治等。皆如实知。乐等持者。于等持中。但有尔所等持作事。除此更无若过若增

复次由五因缘。当知神足略修习相。一由远离奢摩他品随烦恼故。二由远离毗钵舍那品随烦恼故。三于毗钵舍那品所缘境界系缚心故。四于奢摩他品所缘境界系缚心故。五俱于二品所缘境界系缚心故。应知此中。奢摩他品随烦恼者。谓懈怠俱行欲等。及惛沉睡眠俱行欲等。当知懈怠俱行欲等。是惛沉睡眠俱行欲等所依止性。毗钵舍那品随烦恼者。谓掉举俱行欲等。及妙欲散动俱行欲等。当知掉举俱行欲等。是妙欲散动俱行欲等所依正性。又于此中由懈怠俱行欲等。于奢摩他品。令住杂染。然不能令诸奢摩他皆悉灭没。由惛沉睡眠俱行欲等。于奢摩他品。令住杂染。亦复能令诸奢摩他皆悉灭没。由掉举俱行欲等。于毗钵舍那品。令住杂染。而不能令毗钵舍那一切灭没。妙欲散动俱行欲等。于毗钵舍那品。令住杂染。亦令一切毗钵舍那皆悉灭没。毗钵舍那品所缘境者。谓前后想。此想分别。如声闻地应知其相。奢摩他品所缘境者。谓上下想。此亦如前应知其相。俱品所缘境者。谓光明想。彼于俱品由动摇故。有诸光影俱行心。修又非如欲等与余懈怠相应。说名懈怠俱行。精进亦尔。得有懈怠共相应义。然即精进堕在慢缓。不正发勤精进相续。说名懈怠俱行。又此五相当知总摄一切种修。乐等持者。由此等持速得成满

复次于五解脱处。如其所应当知欲等增上四种三摩地。若有苾刍。依净意乐及猛利欲。为欲证得最胜通慧。从诸如来及佛弟子。殷重恭敬。听闻正法。从闻无间渐次证得胜三摩地。当知是名欲增上三摩地。复有苾刍。如所闻法如所得法。起大功用。发大精进。或正为他宣说开示。或以胜妙音词读诵。从此无间渐次因缘能随获得胜三摩地。当知是名精进增上三摩地。复有苾刍。于诸贤善三摩地相善取。思惟观青瘀等乃至骨锁以为边际。由此所缘。次第生起胜三摩地。当知是名心增上三摩地。复有苾刍。如所闻法如所得法。独处空闲。思惟筹量。审谛观察。由此因缘。渐次生起胜三摩地。当知是名观增上三摩地

复有差别。谓由四门起三摩地。一由如前从他生起猛利乐欲闻正法门。二由从他获得无倒教授教诫。无间殷重发起加行。未入根本胜三摩地。为欲趣入正教授门。三由已入根本胜三摩地。为欲转得所余上位胜三摩地心喜乐门。四由多闻闻持自能于法如理观察平等观门。当知此中。由第一门起欲增上三摩地。由第二门起精进增上三摩地。由第三门起心增上三摩地。由第四门起观增上三摩地。所余分别义。及分别断行。如声闻地应知其相

复次修诸神足以为依止。能正引发诸圣神通。无有外道修诸神足能正引发诸圣神通。又诸圣者引发所有最胜神通。随所愿乐延诸寿行。或住一劫或一劫余。谓过一劫不净种性补特伽罗。名为物类。当知此类唯住内法。又诸圣者变化神通。于其四事不能变化。一者根。二者心。三者心所有法。四者业及业异熟。又诸圣者变性神通。不能转变顺乐受业令自性改成顺苦受。如顺乐受望顺苦受。顺苦受业望顺乐受。应知亦尔。若业能顺非苦乐受。当知毕竟顺非苦乐。又诸圣者住持神通。不能住持顺非苦乐受业令成无受。余亦如是。又诸圣者变时神通。不能转变顺现法受业令成顺后法受业。及顺后法受业令成顺现法受业

复次嗢拖南曰

  安立所行境　　慧根为最胜
  当知后安住　　外异生品等

略由六处增上义故。当知建立二十二根。何等为六。一能取境界增上义故。二继嗣家族增上义故。三活命因缘各别事业加行士用增上义故。四受用先世诸业所作爱不爱果。及造新业增上义故。五趣向世间离欲增上义故。六趣向出世离欲增上义故。当知此中。眼根最初意根为后。如是六根。于取境界有增上义。男女二根于能继嗣家族子孙。有增上义。命根一种于爱命者活命因缘各别事业加行士用。有增上义。乐最为初舍为其后。如是五根。于其受用先业所作爱不爱果及造新业。有增上义。信为最初慧为其后。如是五根。于能趣向世间离欲。有增上义。未知当知已知具知三无漏根。于能趣向出世离欲最极究竟。有增上义。一切世间所现见义。其唯此量。当知是义能究竟者。无出于此二十二根。故一切根二十二摄

复次或有一类。作是思惟。若无内我托六根门行六境界。如是六根各别所行。各别境界。然此六根唯能领受自所行境。谁能领受如是六根所行境性。当知此由不能了达缘起道理故。于诸行起邪分别。缘起理者。谓若有时修瑜伽师。于内六根如理攀缘。精勤加行。修四念住。即于尔时此四念住领受六根所行境性。即此于彼由清净故。名为出离。又即勤修四念住故。初达谛理得七觉支。即于尔时此诸觉支真故实故。领受念住所行境性。又由修习觉支因缘。起于明脱。即于尔时如是明脱。领受觉支已善修习。从此已后不复应修所行境性。如实已断一切烦恼。即于尔时于诸烦恼断灭涅槃。离增上慢。即由远离增上慢故。此现实有究竟明脱。如实领受已得明脱所行境性。由此出离一切所有有为法故。当知明脱亦得出离。于涅槃中。能取所取二种施设皆无所有。一切戏论永灭离故。是故乃至诸有为法可得展转问答施设能取所取言论差别。究竟涅槃无为法中一切问答言论差别。皆不如理。是故当知于无我中。应正显示唯有杂染唯有清净

复次若有黠慧诸根猛利种类士夫补特伽罗。由思择力如理作意。思惟诸法。乃于涅槃得正信解。由此增上发勤精进。此增上故。能于身等所缘境界。安住正念。此增上故。能于所缘令心一趣。此增上故。于一切法如实了知。如实观见。由是因缘。能到究竟。是故此慧若初若后多有所作故。说慧根最为殊胜

复次若依诸佛无上菩提。所得正信乃至正慧。于此世间亦无有者。当知此住外异生品。即于此法唯有世间。无出世者。当知此住内异生品。非外异生。若于此法有出世者。当知一切别住。余品非彼品类

复次嗢拖南曰

  思择觉慧等　　国等及诸王
  阿罗汉有学　　质直最为后

略于一切现法后法诸恶行中。深见过已。能正思择息诸恶行。修诸善行。名思择力。当知此力能成二事。一者能往人天善趣。二者能往现法涅槃。又此能与修习力摄。修诸念住为所依止。由此为依。能正修习四念住等菩提分法。当知此修名修习力。又思择力能与三处羞耻为伴。何等名为三处羞耻。一者他处羞耻。谓作是思。若我作恶。当为世间有他心智诸佛世尊若圣弟子若诸天众信佛教者共所呵毁。是名第一处思择力。二者自处羞耻。谓作是思。若我作恶。定当为己深所呵毁。何有善人为斯恶行。是名第二处增上力。三者法处羞耻。谓作是思。我若作恶。便为障碍。于善说法毗奈耶中所修梵行。此法若有。便坏梵行。是名第三处思择力。如是羞耻。当知三处以为增上。一世增上。二自增上。三法增上

复次由自利行及利他行为增上故。当知建立有四种力。一觉慧力。二精进力。三无罪力。四摄受力。能往现法涅槃。名为自义。能往人天善趣。亦名自义。当知此中。依第一自义。建立觉慧精进二力。由是二力。能有方便发起正勤。依第二自义。立无罪力。由此三力。一切自义皆得究竟。乐利他者他义。有余由此增上立摄受力。当知摄事如菩萨地已辩其相。

复次依国及王。若男若女。若夫若妻。若愚若智。若处居家。若出家众。当知建立有十种力。谓诸国王有自在力。如是等力广说如经

复次诸阿罗汉。成就八力。如实领受。贪嗔痴等永尽无余。不造诸恶。修习诸善。谓心趣向远离出离般涅槃故。厌背后有。厌背因缘不造恶业。又见诸欲犹如一分热炭火故。厌背诸欲厌背因缘不造恶业。由此二力不造诸恶。不造恶故。复由六门修习诸善。谓念住。正断。神足。根力。觉支。道支

复次诸佛如来。依自利行及利他行。为欲显己与诸弟子有差别故。说如是言。诸有学者成就五力。唯有如来成就十力。若有成就有学五力。行自利行诸圣弟子。获得最上阿罗汉果。从此无间一切自义皆得究竟。如来获得阿罗汉已。成就十力。行利他行。即用利他以为自义。设于是时一切所化其事究竟。入无余依般涅槃界。当知尔时于所作事方得圆满。若所修行阿罗汉行。若为利他即自义行。此二因缘于诸弟子皆为殊胜。如来十力如菩萨地已广分别

复次若有自爱无谄无诳。其性质直补特伽罗。为证自义有四种相。若依恶说法毗奈耶。便有稽留。要依善说法毗奈耶。乃无稽留。云何四相。一说正法教。二教授教诫。三如理通达。四得真实证。所闻正法是诸胜解所依止处。由能远离无因恶因。开示称理正因义故。诸有无倒教授教诫善能随顺断加行教文义所摄无颠倒法。能令证得如前胜解所依处法。若有自爱诸善男子。已调相续有所堪能。来入内法毗奈耶中。得正宣说。得正开悟。便能速疾趣向胜进。如理通达所应通达。亦能实证真所应证。谓四念住以为依止。于有为法诸聪慧者共许为有。或许为无。皆正了知。于无为法乃至有顶皆是有上。能正了知是为有上。涅槃无上如实了知是为无上。如是名为如理通达。又四念住以为依止。由静定心。于七觉支正修习已。于明解脱究竟作证。如是名为得真实证。若彼自爱诸善男子。趣入恶说法毗奈耶。于是四处皆不能得故。名稽留

复次嗢拖南曰

  立差别　　食渐次　　安乐住　　修居后

由奢摩他毗钵舍那俱品差别。建立觉支如声闻地应知其相。

复次自性差别故。及所缘因缘相差别故。应知七觉支十四种差别。所缘因缘相广分别义。如三摩呬多地及声闻地应知其相

复次于能随顺觉支法中。略有二种无倒作意。当知总与觉支为食。何等为二。一正作意。二数作意。与此相违当知非食

复次于初中后随阙一支。令如实觉不得圆满。如其色类所依能依流转安立。随其生起渐次而说。当知此中。念为所依。择法能依。余随所应当知亦尔

复次若有苾刍。于诸觉支方便修习。由四因缘。令其不得安隐而住。何等名为四种因缘。一者一切烦恼品类粗重皆未离故。二者奢摩他品诸随烦恼现在前故。三者毗钵舍那品诸随烦恼现在前故。四者道未调善而乘驾故。与此相违四种因缘。令其获得安隐而住。于此二种善巧苾刍。如实了达正知而住。由诸作意有加行故。精进太过。又后由前有增减故。运转不等。由此二缘。当知名为道不调善。与此相违二因缘故。名道调善。如转轮王于四洲渚得大自在所获七宝。如是心王于四圣谛得大自在所获真净七觉支宝。当知亦尔。谓于奢摩他毗钵舍那双品运转。降伏一切烦恼胜怨。由此义故。初念觉支犹如轮宝。所知境相其量无边。能知智体亦随广大。由此义故。择法觉支犹如象宝。依此速能乃至往彼所行所得殊异胜处。由此义故。精进觉支犹如马宝。悦意无罪最为殊胜。由此义故。其喜觉支犹如女宝。身心映彻有所堪能。由此义故。轻安觉支如神珠宝。能办一切所欣求事。由此义故。其定觉支如藏臣宝。能摧一切染污法军。能率一切清净法军。能趣无相安隐住处。由此义故。其舍觉支如军将宝。

复次诸修行者。得七觉支。譬如大王有妙衣箧三时受用三分安住。彼七觉支当知亦尔。言三时者。谓初日分时。中日分时。后日分时。言三分者。谓奢摩他品。毗钵舍那品。及其俱品。于初分中住四觉支。第二分中住四觉支。第三分中具足安住七种觉支。诸修行者。未曾安住唯一觉支又七觉支。于诸外道无怨憎故。无违竞故。恒怀利益意乐转故。一切烦恼皆离系故。说名无怨无敌无害无有灾患。若修行者。于七觉分随时现前。随量现前。说名为住。若时退出。说名为灭。于是一切如实了知。彼由如是正知住故。名无罪住。无有爱味。心离味染

复次二十一种想俱行修诸觉支者。当知略由二因缘故。一据相应俱行义。二据无间俱行义。无常等想俱行修。乃至死想俱行修者。据相应义。不净等想俱行修。乃至观空想俱行修者。据无间义。悲等俱行修。应知亦尔。又于过去未来现在一切行中。诸行爱染若懒堕懈怠若萨迦耶见虽已断灭。习气随缚我慢现行。若贪味爱。若于世间种种妙事欲乐贪爱。若有所余烦恼随眠。若希求利养。若希求活命。若诸欲爱。若诸有爱。若随虚妄分别所起四种欲贪。一美色贪。二形貌贪。三细触贪。四承事贪。如是能令生起所有非理过患。及令其心越路而转。对治彼故。随其所应有二十一想俱行修觉支差别。谓为对治四种障故。修无愿行想从无常想乃至一切世间不可乐想。为欲对治一种障故。修空行想苦无我想。为欲断灭所余烦恼随眠障故。修于三界无相行想。为欲对治希求利养及欲爱故。于诸欲中修过患想。为欲对治希求活命及有爱故。修习死想。为欲对治随逐虚妄分别所起四欲贪故。修不净想为初。乃至观空想为后。又此一切从青瘀想乃至观空想。当知皆是不净想摄。又于此中青瘀想为初。膖胀想为后。对治美色贪。食啖想。分赤想。分散想。对治形貌贪。骸骨想。骨锁想。对治细触贪。观无心识空有尸想。对治承事贪。又于此中修慈。最极至遍净等。如三摩呬多地。应知其相

复次嗢拖南曰

  初内外力　　清净差别　　异门沙门
  后婆罗门

若内若外一切力中。为欲生起八支圣道有二种力。于所余力最为殊胜。云何为二。一者于外力中善知识力最为殊胜。二者于内力中正思惟力最为殊胜。当知此中离诸障碍。先修福业。于衣食等无匮乏等。名余外力。除正思惟相应想外余断支分。名余内力。

外善知识者。谓从彼闻无上正法。由此故名从他闻音。内正思惟者。谓此无间能发正见。为上首道。复次彼正见等若在有学由无漏故。说名清净。若在无学相续净故。说名鲜白。若在世间远离无量随外道见诸恶邪行。是故说名无有尘点。远离尘点所起后有诸业杂染。是故说名离随烦恼。略说一切八圣道支。二处所摄。一者世间。二出世间。其世间者。三漏四取所随缚故。不能尽苦。是善性故。能往善趣。出世间者。与彼相违能尽众苦。又正见等八圣道支。广分别义如声闻地及摄异门分。应知其相。七种定因具如三摩呬多地已说

复次正见为首八圣道支会正理故。说名为法。能灭一切诸烦恼故。名毗奈耶。去诸恶法极悬远故。一切圣贤共祖习故。说名为圣。能随顺往诸善趣故。说名为善趣。涅槃故。说名应修。诸有智者所称赞故。说名善哉。与此相违。应知即是邪见为首八邪道支。所有差别堕在无明黑闇品故。说名为黑。往恶趣故。说名无义。不善性故。说名下劣。生现法中所有怖畏及怨憎故。说名有罪。诸有智者所讥毁故。所远离故。名应远离

复次依第一义所有沙门。安立如是八支圣道。为沙门义。为此义故。于善说法毗奈耶中。假名出家受沙门性。又此毕竟无失坏故。名第一义。其假名者即不如是。诸有成就此第一义沙门性者。当知亦名胜义沙门。又彼追求此沙门果贪嗔痴等毕竟断义。是故说彼名沙门义。此沙门义复有二种。一无差别总相建立。二若有所作。若无所作行向住果差别建立。如是一切总有四种。一沙门性。二是沙门。三沙门义。四沙门果。有婆罗门差别道理。当知亦尔

复次嗢拖南曰

  障随惑寻等　　果欲细身劳
  学住及作意　　智无执为后

入出息念修习差别有十六行。广分别义如声闻地。应知其相。又勤修行诸瑜伽师。修习如是入出息念。尔时应知五障碍法。一者于其外缘其心散乱。二者入出息转有所艰难。三者掉举恶作缠现在前。四者惛沉睡眠缠现在前。五者乐与道俗共相杂住。如者五法于未得定欲求心定。及得定已倍复增长。当知一切能为障碍。奢摩他品诸随烦恼所染污时。发身惛沈。生心下劣。由正修习入出息念。身心轻安能令惛沉下劣俱行身心粗重皆悉远离。毗钵舍那品诸随烦恼所染污时。发生种种寻伺妄想。谓欲寻伺等不正寻伺。及无明分寻伺所起诸欲想等种种妄想。由正修习入出息念令寻伺等悉皆静息。为欲对治彼无明分诸妄想故。纯修明分想令速得圆满

复次正勤修习入出息念诸瑜伽师。于缘过去诸行寻伺能令无间所生等持有间缺者。速得损减。于缘未来诸行寻伺能令无间所生等持有间缺者。速得止息。于缘现在诸行寻伺能令无间所生等持有间缺者。速得寂静。又若略说由能永断六种结故。当知建立二种四种及以七种诸果胜利。如经广说。云何六结。谓顺下分上分二结。见道修道所断二结。若起若生二分位结。如是别别当知总说有六种结。如其次第建立二种四种七种诸果胜利

复次入出息念修习差别略有二种。一者有上。二者无上。其有上者。谓如有一独处空闲。以静定心如理观察。命根系属入息出息。若我于入息后无有出息。或出息后无入息者。如是命根即应断灭。而于无常行中。有希奇事入息灭已。我命根住。乃复得至出息生时。出息灭已。我命根住。乃复得至入息生时。彼由攀缘如是事故。深心厌离于三世境所发爱恚。净修其心。是名有上十六行修。当知无上。

复次如是入息出息念住缘细风色为境界故。名微细住。隔绝一切乱寻伺故。名不流散。发生广大身心所有妙轻安故。名不可伏

复次修习如是入出息念。令身无劳善能除遣奢摩他品随烦恼故。令眼无劳善能除遣毗钵舍那品随烦恼故。由随观察涅槃乐故。名随观乐。由随领受第三静虑地中乐故。名领受乐。无染住故。无恐畏故。名安乐住

复次容有是处。或有一人。作如是念。如来与彼最极下劣得慧解脱阿罗汉果。无有差别。谓依解脱作是思惟。如来解脱与慧解脱阿罗汉果所有解脱。无有差别。颇复有人作如是念。如来所有离诸盖住。居内法中最极下劣若诸有学。若诸异生。由精进力。于其五盖伏断而住。名离盖住。此离盖住彼离盖住。为如解脱无有差别。为有差别。应知如是二离盖住极大差别。谓诸有学虽现行故。离盖住心与如来等。然彼随眠未永断故。诸盖数数间心相续。数数作意励力除遣。如来诸盖毕竟断故。离诸盖住。与彼所有离诸盖住。极大差别。非如解脱无有差别

复次修瑜伽师。入出息念为所依止修四念住。如理作意以为依止。于诸未断内心所有非理作意。如实了知是为非理。于内所有如理作意。如实了知是为如理。既了知已于内所有非理作意。一向远离。于内所有如理作意。一向修习。为欲令彼永断灭故。又于此中身等四法如四大路。非理作意如尘土丘。不坚牢故。不真实故。迷乱心故。如理作意如四方来舆乘车车缘。身等四境界门转能损害彼如尘土丘非理作意。亦令一切相续清净

复次精勤修习诸息念者。由正修习四种念住。无我等故。平等平等。是身种类能取于身如理作意。如身无我作意亦尔。是故说彼为身一分。能修如是身念住者。都不可得。如身念住。广说乃至。修法念住当知亦尔。如是诸佛修念住教。外道法中皆无所有。是故说此修念住教。名非一切外道所执

复次嗢拖南曰

  初尊重尸罗　　清净戒圆满
  现行学胜利　　学差别为后

学有三种。谓增上戒学。增上心学。增上慧学。建立如是三学差别。如声闻地应知其相。又略于此诸所学中。所有邪行。应正了知。所有正行应正了知。言邪行者。谓如有一。不尊重戒。泛尔出家。虽复出家不以净戒为其增上。如于净戒。于定于慧应知亦尔。彼可容有犯无余罪。于彼世尊说。其于诸沙门果证为无能者。是故当知彼于三学一向毁犯。言正行者。有三正行。谓下中上。下正行者。谓如有一。尊重净戒。亦以净戒为其增上。与前相违。于定于慧不生尊重。不为增上。此不容有犯无余罪。而容有犯小随小罪。于此如来不说其于沙门果证为无能者。中正行者。谓于戒定皆悉尊重。亦为增上。如尊重戒毁犯次第此中亦尔。是故当知乃至所有诸异生位。上正行者。谓已见谛于三种学皆悉尊重。此已获得沙门果证。不待思择有能无能。如是二行开为四种。即此四种合为二行。此二与四平等平等。当知此中。若有定学必有戒学。若有慧学。必有定学。有戒学者不必定有定学慧学。若瑜伽师尊重诸学。当知是名所作圆满。其余但名所作一分

复次于性罪处能远离故。当知是名净戒圆满。于能密护诸根门等摄受净戒所有善法。无间受持相续转故。当知是名善法圆满。于遮罪处能远离故。当知是名别解脱圆满。又依圣所爱戒。若依蕴等五种善巧。及依别解脱律仪。受持世俗所有禁戒。随其次第应知净戒圆满等第二门差别。

复次依净尸罗。略有二种所学差别。一者受持非止所摄所受尸罗所有如法身语现行所摄学处。二者受持是止所摄所受尸罗所摄学处。此复二种。谓或有是毗奈耶所说。非别解脱所说。或有是毗奈耶所说。亦是别解脱所说。是故一切总略而言有三学处。一增上现行。二增上毗奈耶。三增上别解脱

复次学胜利住慧为上首。解脱坚固念为增上。修习三学速圆满等。如摄释分广辩应知

复次住具戒等。如声闻地应知已辩。又即净戒对治一切犯戒恶故。密护根门所依处故。说名律仪。初善受故。说名圆满。后善守故。说名清净。感爱果故。说名为善。无染污故。说名无罪。于诸有情能善随顺慈心定故。说名无害。于沙门性善随顺故。说名随顺趣。圣所爱澄清性故。名顺澄清。终不随顺戒禁取故。名不随顺。与同法者为同分故。名同色类。于正修习增上心慧为所依处。随顺转故。名为顺转。不恼于他饶益转故。又正远离自苦行故。名无热恼。于所受持无变悔故。名无烧恼。于诸毁犯不现行故。如法悔除己所犯故。名无悔恼。如是名为增上戒学所有差别。三住为依当知增上心学慧学所有差别。谓由天住梵住差别。应知增上心学差别。由诸所有觉分等法圣住差别。应知增上慧学差别。谓四静虑四无色等。名为天住。四无量定名为梵住。四圣谛智。四种念住。乃至道支四种行迹。胜奢摩他毗钵舍那四法迹等。当知一切皆名圣住。又有四种若行若住无杂染法。令修观者或于境界退出游行。或于所缘安心静定。离诸杂染安隐而住。云何为四。一于随顺喜受境界。诸杂染喜深心弃舍。二于随顺忧受境界。诸染污忧深心弃舍。三于毗钵舍那品诸随烦恼净修其心。四于奢摩他品诸随烦恼净修其心。于是四种若行若住。离诸杂染安隐住法。应知四种安足处所所依法迹。如其所应当知即是无贪无嗔正念正定

复次嗢拖南曰

  证净初安立　　有变异为先
  天路喻明镜　　记别最居后

具足正见如来弟子。略由二法能正摄受澄清性故。应知建立四种证净。谓沙门义所摄信戒。于能说者。于沙门义。于同法者。于能证得沙门助伴。所有净信深固根本。于余生中亦不可引。无虚诳故。名澄清性及净尸罗。于其一切能往恶趣恶不善法。获得毕竟不作律仪。是故亦得名澄清性。应知此中。依止净信于善说法毗奈耶中。深生信解。由此净信澄清性故。设在余生。于佛善说法毗奈耶。毕竟无转。又由怖畏诸恶道苦。受持净戒。对治恶行。由此摄受戒。澄清性设在余生。亦不造恶堕诸恶趣。毕竟无退。乃至涅槃。由于善说法毗柰耶。毕竟无转所依处故。毕竟不往一切恶趣所依处故。其用最胜唯说信戒。为澄清性。非余精进念定等法。非澄清性。又此信戒是其增上戒定慧学所依止处。由说信戒是清净故。义显三学皆得清净。由是因缘。唯说是二以为证净。是名第二义门差别。如是证净善能滋润一切堕界白净法故。名滋润福。能引殊胜诸圣道故。名滋润善。能引所余烦恼断故。名能引乐

复次一向决定能往善趣成就证净诸圣弟子。犹有住于善趣。三种诸大互违变异所起重苦怖畏。然无恶趣所有怖畏。云何三种重苦怖畏。一者病苦。二者老苦。三者断截末摩死苦。是故说言其四大种可令变异。非已成就四种证净诸圣弟子可有变异。

复次若第一义清净诸天。说名最胜无有恼害。由身语意毕竟无有恼害事故。即依如是清净天性。说四证净。名为天路。又四证净为所依止诸圣弟子。依三种门修六随念。一者为断奢摩他品诸随烦恼所起染恼。二者为断毗钵舍那品诸随烦恼所起染恼。三者为断虽无染恼而于未来当可生起二随烦恼。当知此中惛沉睡眠名奢摩他品诸随烦恼。欣乐诸欲俱行掉举贪等过失所生不善欲寻伺等。令心流散诸杂染法。名毗钵舍那品诸随烦恼。又由胜义谛理所得随念。名义威勇。由世俗谛理所得随念。名法威勇

复次譬如有人执持明镜为观自面净不净相。如是如来诸圣弟子。执持微妙证净明镜为如实观自身所有染净诸相

复次若有成就四种证净。唯即依自四种证净为他记别。不依上位。能顺欢喜所修随念。由此因缘。当知记别预流果证。未趣上位所修道故。若于上位能顺欢喜五种随念为他记别。由是因缘。当知记别一来果证。由三摩地未成满故。于离欲道未圆满故。于彼诸天未现见故。为求离欲修习能顺欢喜诸法。由此欢喜为所依故。发生轻安。由轻安故。领受身乐。由受乐故。心得正定。而于静定未得成满。若于上位六种随念为他记别。由是因缘。当知记别不还果证。阿罗汉果唯出世道。乃能趣证所有随念唯是世间。是故不还果证已上。更无如是随念记别。又四证净预流果中。唯说为净。于余学果说圆满净。于最上果说为第一圆满清净。

如是略引随顺此论境智相应诸经宗要摩呾理迦。其余一切随此方隅皆当觉了

瑜伽师地论卷第九十八瑜伽师地论卷第九十九

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中调伏事总择摄第五之一

如是已说素怛缆事摩怛理迦。

云何名为毗柰耶事摩怛理迦。谓即从此四种经外别解脱经所有广说摩怛理迦。展转传来如来所说。如来所显。如来所赞。名毗柰耶摩怛理迦。

此毗柰耶摩怛理迦总相少分我今当说嗢拖南曰

  利聚摄随行　　逆顺能寂静
  遍知信不信　　力等为其后

如来观见十种胜利。于毗柰耶中。为诸弟子制立学处。谓摄受僧伽。令僧精恳。乃至广说。如摄释分应知其相。若能摄受四大姓等正信出家趣非家众。当知说名摄受僧伽。如是出家趣非家已。为其宣说有因缘。有出离。有所依。有勇猛。有神变等甚深法教。当知说名令僧精恳。有因缘等诸句差别。如菩萨地已辩其相。由五种相。应知说名令僧安乐。一者令顺道具无所匮乏。二者令摈异法补特伽罗。三者令善除遣所生恶作。四者令善降伏诸烦恼缠。五者令善永灭随眠烦恼。应知此中。最初安乐增上力故。未净信者。令生净信。已净信者。令其增长。第二安乐增上力故。调摄鄙恶补特伽罗。第三安乐增上力故。令惭愧者得安乐住。第四安乐增上力故。令善防护现法诸漏。第五安乐增上力故。能令永灭当来诸漏。如是获得安乐住已。未得入者。令易入故。欲令多人梵行久住。乃至广说。皆应了知。又此一切以要言之。谓正显示最初摄受。次正摄受既摄受已令安乐住。及显未来未摄受者易入方便。如是名为第二差别

复次应知略有五种罪聚。摄一切罪。何等为五。一者他胜罪聚。二者众余罪聚。三者损坠罪聚。四者别悔罪聚。五者恶作罪聚。集粗不定如其所应。即入如是诸罪聚中。复有四种还净罪聚。何等为四。谓除他胜所余罪聚皆可还净故。有四种还净罪聚。最初罪聚虽可还净。然唯依二补特伽罗。非为一切无有差别皆可还净。是故他胜不立一向还净聚中。又若略说有十五种犯罪过失。遍于一切犯罪聚中。当知建立诸所犯罪。何等十五。一事重过失。二猛利缠过失。三匮乏不喜足过失。四他所讥嫌过失。五无净信者倍令不信。有净信者令其变异过失。六多诸财宝多诸事业过失。七染着过失。八恼他过失。九发起疾病过失。十障往善趣沙门过失。十一于应避护不正避护。不应避护而反避护过失。十二不应为依反与为依。应与为依而不为依过失。十三于应恭敬而不恭敬。不应恭敬而反恭敬过失。十四于应覆藏而不覆藏。不应覆藏而反覆藏过失。十五于应习近而不习近。不应习近而反习近过失。应知此中初修业者。于四他胜。虽有事重过失。而无猛利缠过失。由彼意乐无勃恶故。谓于沙门无所顾恋。若初业者。了知此法能障沙门。为命因缘亦不违犯。意乐力强。不唯依事故。彼无犯。制立所犯。要由意乐增强力故。若虽有犯。而无一念起覆藏心。彼亦可出。于沙门果仍有堪能。其余一切犯他胜者。亦有事重过失。亦有猛利无惭无愧诸烦恼缠过失。当知彼由二皆重故。成不可出法及不般涅槃法。若衣钵等世尊开许应持。作净而受用之。于彼一切悉皆弃舍。或不作净而辄受用。如是等罪。由依匮乏不喜足过。制立所犯。若非亲属苾刍尼所受衣与衣。或共彼等独在一处。或复非时诸苾刍僧不同忍许辄往教授。或除余时与诸母邑共道路行。如是等类。当知是名他所讥嫌过失。若非威仪入聚落等乞食受用。坐不如法澡手涤器。或不因请于其食前辄入他舍。或不观白于其食后游履邑居。如是等类。当知是名无净信者倍令不信。有净信者令其变异过失。若有执受金银等宝。种种品类买卖营为种莳林木。畜憍赊耶妙卧具等。当知是名多诸财宝多诸事业过失。若故泄精。或复执触母邑手等。或行媒娉。因兹趣入变异染心。或为好故往亲属所追求上妙长衣服等。当知是名染着过失。若以无根假异分法毁他苾刍。或作离间人语等事。当知是名恼他过失。若自持羊毛过三踰缮那。或荷重担。或上过人树等。当知是名发起疾病过失。若为破坏和合僧故。勤设勇猛方便事等。当知是名障往善趣过失。若作不与自语等事。当知是名障碍沙门过失。若有弃掷僧祇卧具置迥露处舍而去等。或邪受用等。当知是名于应避护不正避护过失。若与邪见苾刍勤策共居住等。为依止等。当知是名不应为依反与为依过失。若于尊教轻触。怨咎怒睛恶视。不恭敬听受别解脱经等。当知是名于应恭敬而不恭敬过失。若于未受具戒补特伽罗前。宣示实得胜过人法。或复覆藏苾刍所犯粗恶罪等。当知是名于应覆藏而不覆藏。不应覆藏而反覆藏过失。若有受用不净非法衣服等事。当知是名不应习近而反习近过失。如是所说十五过失。当知于彼所犯罪中。或有多种或二或一

复次略有五法摄毗柰耶。何等为五。一者性罪。二者遮罪。三者制。四者开。五者行。云何性罪。谓性是不善能为杂染损恼于他。能为杂染损恼于自。虽不遮制。但有现行便往恶趣。虽不遮制。但有现行能障沙门。云何遮罪。谓佛世尊观彼形相不如法故。或令众生重正法故。或见所作随顺现行性罪法故。或为随顺护他心故。或见障碍善趣寿命沙门性故。而正遮止。若有现行如是等事。说名遮罪。云何名制。谓有所作能往恶趣。或障善趣。或障如法所得利养。或障寿命。或障沙门。如是等类。如来遮制不令现行故。名为制。与此相违。应知名开。云何名行。谓略有三行。一者有犯。二者无犯。三者还净。如是三种略摄为二。一者邪行。二者正行。应知有犯说名邪行。无犯还净说名正行。此中云何犯所犯罪。谓于应作而不作故。及加行故。于不应作而反作故。及加行故。犯所犯罪。又彼略由四因缘故。犯所犯罪。一无知故。二放逸故。三烦恼盛故。四轻慢故。云何名为由无知故犯所犯罪。谓如有一。于所犯罪不审听闻。不善领悟。彼无解了无有觉慧无所知故。于其所犯起无犯想。而犯众罪。如是名为由无知故犯所犯罪。云何名为由放逸故犯所犯罪。谓如有一。于所犯罪虽复解了。有其觉慧亦有所知。而住忘念。住不正知。彼由如是不住念故。如无所知而犯众罪。如是名为由放逸故犯所犯罪。云何名为烦恼盛故犯所犯罪。谓如有一。于其所犯虽复解了。有其觉慧亦有所知。而彼本性贪嗔痴等极为猛利。彼由猛利贪嗔痴故。虽知是事所不应。为烦恼缠逼不自在故。而犯众罪。如是名为烦恼盛故犯所犯罪。云何名为由轻慢故犯所犯罪。谓如有一。于所犯罪虽复解了。有其觉慧亦有所知。而彼信解极为下劣。无有强盛宿善因行。由其信解极下劣故。于沙门性。于般涅槃。无有顾恋。于佛法僧。无敬无惮无有羞耻。不乐所学。由轻慢故。随其所欲广犯众罪。如是名为由轻慢故。犯所犯罪。当知此中。无知放逸所犯众罪。是不染污。由烦恼盛及以轻慢所犯众罪。是其染污。由五因缘。当知所犯成下中上三品差别。何等为五。一由自性故。二由毁犯故。三由意乐故。四由事故。五由积集故。由自性者。谓他胜罪聚是上品罪。众余罪聚是中品罪。所余罪聚是下品罪。复有差别。谓彼胜众余。是重品罪。陨坠别悔是中品罪。恶作罪聚是轻品罪。如是应知由自性故诸所犯罪成下中上三品差别。由毁犯者。谓无知故。及放逸故。所犯众罪是下品罪。烦恼盛故所犯众罪是中品罪。由轻慢故所犯众罪是上品罪。如是应知由毁犯故诸所犯罪成下中上三品差别。由意乐者。谓由下品贪嗔痴缠所犯众罪。是下品罪。若由中品。是中品罪。若由上品。是上品罪。如是应知。由意乐故。诸所犯罪。成下中上三品差别。由事故者。谓虽现行相似意乐。而由其事非一类故。应知所犯成下中上三品差别。如以嗔缠于傍生趣所有众生故思杀害。生陨坠罪。即以如是相似嗔缠。或于其人或人形状非父非母故思杀害。生他胜罪。非无间罪。即以如是相似嗔缠。于人父母故思杀害。生他胜罪及无间罪。如是应知。由事别故。诸所犯罪成下中上三品差别。由积集者。谓如有一。或犯一罪。不能如法速疾悔除。或二或三乃至或五。如是应知。由积集故。成下品罪。从此已后。或犯十罪。或犯二十。或犯三十。乃至或犯可了数罪。不能如法速疾悔除。如是应知。由积集故。成中品罪。若所犯罪其数无量不可了知。我今毁犯如是量罪。如是应知。由积集故。成上品罪。云何应作。谓若于彼由不作故。及加行故。便成毁犯。此所应作。略有五种。一于村邑所应作事。二于道场所应作事。三于善品所应作事。即此善品所应作事。复有二种。一者资粮所应作事。二者清净所应作事。如是资粮所应作事。如声闻地说十三种所有资粮。如是清净所应作事。如声闻地说修作意。又于城邑所应作者。谓或为己衣服等事入于聚落。或复为于佛法僧事同梵行事。或为未信令其生信。其已信者倍令增长。入于聚落。与此相违所有能障五应作事。如其所应当知。五种不应作事。云何无犯。谓五因缘令无所犯。何等为五。谓于根门密护而住。饮食知量。初夜后夜常不睡眠。勤修胜行。正知而住。如是名为第一因缘。又于沙门起其上品精勤顾恋。于其大师诸有智者同梵行所。起其上品爱乐恭敬。于现行罪发起猛利增上惭愧。如是名为第二因缘。又少财物。少事少业。不多匆务。如是名为第三因缘。又住喜足。于犯不犯能善了知不与道俗交游纵荡。专修善品。曾无间隙。如是名为第四因缘。又初修业痴狂心乱痛恼所逼。如是名为第五因缘。当知由此五因缘故。从初不犯。云何还净。谓如有一。随所犯罪即便生起五种恶作。五支所摄不放逸行以为依止。由五种相除彼所生五种恶作。云何生起五种恶作。一者由我毁犯净戒因缘。于后定当深自恳责生起恶作。二者由我毁犯净戒因缘。定当为他诸天呵责生起恶作。三者由我毁犯净戒因缘。定为大师及诸有智同梵行者当共呵责生起恶作。四者由我毁犯净戒因缘。定遍方维恶名恶称恶声恶颂彰显流布生起恶作。五者由我毁犯净戒因缘。身坏已后必定当堕诸恶趣中生起恶作。五支所摄不放逸行。如声闻地应知其相。谓前际俱行。后际俱行。中际俱行。初时所作。及俱随行。云何由五种相除彼所生五种恶作。一者世尊所说正法皆有因缘。亦有出离。是故所犯容可还净。由是除遣所生恶作。二者由彼无知放逸烦恼炽盛及以轻慢。犯所犯罪。即此无知乃至轻慢我已断灭。所有正智乃至尊敬我已生起。由是除遣所生恶作。三者当来无犯意乐我已生起。由是除遣所生恶作。四者我已于诸有智同梵行所发露悔灭。由是除遣所生恶作。五者我于佛善说法毗柰耶中既出家已。虽越学处而能悔灭极为善哉。然薄伽梵以无量门呵毁所起相续恶作。为盖为障。我今于彼多住坚执不能除遣。非极善哉。了知此已。由是除遣所生恶作。如是名为所犯还净

复次应知略有五毗柰耶所随行法。依毗柰耶勤学苾刍随行于彼。云何为五。一者安住。二者居处。三者所依。四者受用。五者羯磨。云何安住。谓依毗柰耶勤学苾刍。应当安住五种想住。何等为五。一者若入聚落应当安住入牢狱想。二者若在道场常当于己住沙门想。应知此中沙门想者。谓我于今色形别异弃舍俗相。我已受持坏色等事广说如经。审谛观察二十二处。三者若饮食时常当安住为疗病想。四者若处远离于眼所识色耳所识声等。应住盲聋喑哑等想。五者若寝息时当起难保旷野林中惊怖鹿想。依毗柰耶勤学苾刍。常当安住是五想住。于此想住既安住已。虽现受用堪为国王所受衣服饮食卧具。而不堕受欲乐行边。云何居处。谓五居处。一苾刍居处。二苾刍尼居处。三外道居处。四杂染居处。五无杂染居处。苾刍居处者。谓于是处有诸苾刍下中上座之所居止。苾刍尼居处者。谓于是处有苾刍尼如前三种之所居止。外道居处者。谓于是处种种外道之所居止。谓离系。净命。波输钵多。如是等类。杂染居处者。谓于是处一切羯磨皆不施设。或但施设一分羯磨。无杂染居处者。谓于是处具足施设一切羯磨。又无杂染苾刍居处。应知众会安立整肃。若有杂染苾刍居处。应知众会安立混杂。诸有爱乐所学苾刍。于有杂染苾刍居处。应故思择。弃舍利养。弃舍恭敬。不应止住。除有危难暂时依附。或行道路暂时止息。或为拔彼诸苾刍众出不善处安置善处。于苾刍尼众所居处。不应止住。除如前说三种因缘。外道居处当知亦尔于无杂染苾刍居处。虽正思择尽寿止住。而应常怀羁旅之想。若有苾刍。虽住如是诸所居处。应怀种种虑恐处想。虽住如是无讥嫌处。而常虑恐为诸有智同梵行者之所讥嫌。云何所依。谓五所依。何等为五。一村田所依。二居处所依。三补特伽罗所依。四诸衣服等资具所依。五威仪所依。若依村城地方分所而得安住。应知是名村田所依。若依园林或诸寺院经行处等而得安住。应知是名居处所依。若依施主。轨范。亲教。谏诲忆念教授教诫说正法者。而得安住。应知是名补特伽罗所依。若依顺道或粗或妙。随所获得衣服饮食病缘医药资身众具而得安住。应知是名诸衣服等资具所依。若依是处于时时间。身四威仪如其所乐得安乐住。应知是名威仪所依。若依如是所依而住。终不为其苦恼非圣无义所引困弊匪宜损害自己。云何受用。谓有五种不净受用。及有五种清净受用。云何五种不净受用。一者受用窣堵波物。非遭重病。设遭重病有余方计。二者受用诸僧祇物。非僧授与非堕钵中。非彼分摄。三者受用他别人物。不从彼得。非彼所许。随意受用。四者受用非委信物。谓非委信补特伽罗一切所有不应受用五者受用诸便秽等所染污物。或由习近减诸善法增不善法。或习近时令诸世间生起讥诃。令诸世间共所厌贱。未生信者令倍不信。已生信者令其变异。是名五种不净受用。于毗柰耶勤学苾刍。应当远离。与此相违。应知五种清净受用。于毗柰耶勤学苾刍。应当受用如是。远离不净受用。于净受用随行苾刍。能善酬报所有信施。云何羯磨。谓一切羯磨略有四种。一者单白羯磨。二者白二羯磨。三者白四羯磨。四者三语羯磨。此四羯磨略有二事为所依处。一有情数事为所依处。二无情数事为所依处。有情数事为所依处者。谓出家羯磨。若受具足羯磨。若补特伽罗同意羯磨。若出罪羯磨。若举羯磨。若摈羯磨。若两安居受七二十四十夜等所有羯磨。如是或为摄受有情。或为折伏有情。施设羯磨。是名有情数事为所依处羯磨。无情数事为所依处者。谓受持依钵羯磨。若持羯絺那衣护衣不舍羯磨。若结界羯磨。若净稻谷同意羯磨。如是等类所有羯磨。当知是名无情数事为所依处羯磨。又此羯磨当知或有二众所作。或有四众所作。或有十众所作。或有二十众所作。或有四十众所作。或有合众所作。二众所作者。谓一苾刍对一苾刍三说别悔羯磨。发露悔除或陨坠罪或恶作罪等。四众所作者。谓如有一。犯粗罪已于四人前发露悔除羯磨。十众所作者。谓受具足羯磨。二十众所作者。谓出苾刍众余罪羯磨。及苾刍尼受具足羯磨。四十众所作者。谓出苾刍尼众余罪羯磨。合众所作者。谓增长羯磨。若恣举羯磨。或余所有种类羯磨。是四羯磨由事差别成无量种。广说应知如毗柰耶摩怛理迦。如是解了所有羯磨。于毗柰耶勤学苾刍。随羯磨行。于所犯罪而得善巧。于罪出离亦得善巧。避护自身令得清净离诸罪过

复次于毗柰耶勤学苾刍。应知有五违逆学法。应当远离。复有五种随顺学法。应当受持。云何为五违逆学法。一者障碍。二者像似正法。三者恶友。四者愚戆烦恼炽盛。五者宿世资粮其力薄弱。云何障碍。谓有五障。一增上戒障。二增上心障。三增上慧障。四往善趣障。五利养寿命所作事障。云何名为增上戒障。谓如有一。或是奴婢。或是获得。或有所言。广说一切障出家法而与相应。如是名为增上戒障。云何名为增上心障。有十一障。当知名为增上心障。谓数与众会为初。处分居处为后。云何名为增上慧障。谓于正法及说法师不起恭敬。陵懱正法及说法师轻贱自己。于法悭吝障他正法。令背正法毁谤正法。如是等类当知皆名增上慧障。云何名为往善趣障。谓如有一。恶欲邪见多诸忿恨。乃至广说。如是色类顺诸恶趣受学转法。当知是名顺恶趣障。利养障者。谓随所行。令未信者更增不信。其已信者能令改变。不乐功德。不时时中精勤修习施福业事。不乐为他引摄所有利益安乐。如是等类。寿命障者。谓不谨慎远避恶象。广说乃至。不善远离有灾有疫诸恶国土。又不远离诸因诸缘未尽寿量能令夭殁。如是等类。所作事障者。谓能障碍营衣钵等所有事业。如是一切总摄为一。应知说名利养寿命所作事障。云何名为像似正法。谓略有二种像似正法。一似教正法。二似行正法。若于非法生是法想。显示非法以为是法。令他于中生正法想。如是法教实故谛故。非是正法。而复像似正法显现。是故名为似教正法。若广为他如是宣说。令他受学亦自修行。妄起法想习诸邪行。而自憍慢称言我能修是正行。应知是名似行正法

为广宣说像似正法。复说中间嗢拖南曰

  初法等五种　　次根等诸见
  非处恶作等　　后暴恶戒等

诸以如来所说法教相似文句。于诸经中安置伪经。于诸律中安置伪律。如是名为像似正法。又由增益或损减见。增益虚事损减实事。由此方便于无常等种种义门。广为他人宣说开示如是如是自他习行。如是亦名像似正法。又于宣说补特伽罗所有经典。邪取分别说有真实补特伽罗。如是亦名像似正法。又于种种假有法中。宣说开示为实有性。如是亦名像似正法。又于远离一切戏论究竟涅槃。分别为有或为非有。说为有性或非有性。如是亦名像似正法。又有一类补特伽罗。作如是说。世尊宣示称扬赞叹密护根门。由是因缘宁不视色。乃至于法不以意思。而不系念观视众色乃至以意思惟诸法。如是亦名像似正法。又闻世尊宣示称叹简静而住。便作是言。宁无咎责不测量他。于应毁者而不呵毁。于应赞者亦不称赞。而不有所呵毁称赞。如是亦名像似正法。又闻世尊宣示称叹和气软语。便作是言。受默然戒都无言说为极善哉。如是亦名像似正法。又闻世尊宣示称叹节量衣食。便作是言。断食而住露体而行最为妙善。如是亦名像似正法。又闻世尊宣示称叹离諠杂住。息诸言说及以事业。便作是言。弃舍卧具。寂静闲居。无所修习为极美妙。如是亦名像似正法。又闻佛说心将导世间。心营造一切。随心所生起皆自在而转。于如是等诸经义趣不如实知。或有一类。由恶取执作如是言。唯有一识驰流生死。无二无别。如是亦名像似正法。又闻佛许持戒士夫补特伽罗受百味食百千衣服。障道妙欲。设此品类正受用时亦不为障。或有一类。由恶取执作如是言。世尊所说障道诸欲。若有习近不足为障。如是亦名像似正法。又闻佛说诸阿罗汉于现法中于食言说蕴界处等不舍不取不如实知。便作是说。如我解佛所说法者。阿罗汉僧于其死后无所觉了。如是亦名像似正法。复有一类。不如实知世俗胜义二谛道理。违二谛理。作如是言。诸蕴无我。云何无我造作诸业令我触证。应知亦名像似正法。复有一类。本性愚痴多行谤毁。彼于九种内正住心不如实知。于谛观行念住观行不如实知。由不知故。为他宣说唯信解作意是奢摩他品。唯信解作意是毗钵舍那品。唯信解作意能得究竟。自亦习行。如是相行当知亦名像似正法。复有一类。非处恶作而不思惟。当知亦名像似正法。复有一类。于其读诵观行作意。皆有堪能而乐僧事。亦于其中见胜功德。为他宣说。当知亦名像似正法。复有一类。于戒于修有所堪能。而于惠施见胜功德。游历诸方。于自禁戒所遮止处多有毁犯。集诸财物奉佛法僧。当知亦名像似正法。复有一类。于善说法毗柰耶中既出家已。展转相引专以听闻为其究竟。当知亦名像似正法。复有一类。见诸苾刍大族大福多获衣等所有利养。舍少欲等而往其所恭敬叙慰现亲诲喻。令新苾刍邪心动作。当知亦名像似正法。复有一类。弃舍如来所说甚深空性相应所有经典。专乐习学随顺世间文章咒术。而不自察怀聪明慢。又欲令他知己聪敏。当知亦名像似正法。复有一类。折伏暴恶及诸犯戒。为欲于彼暴恶犯戒作不饶益发起恶思。当知亦名像似正法。复有一类。构集种种矫诈威仪。当知亦名像似正法。复有一类。以解世间文章咒术。多求多获所有利养。当知亦名像似正法。复有一类。损恼于他以其非法积聚财宝作有罪福。当知亦名像似正法。又即于彼能引无义像似正法。以诸因缘开示建立。当知亦名像似正法。如是一切像似正法。应知皆是违逆学法。恶友性相。广说应知如声闻地及菩萨地。又略说者。若于放逸或于恶行。或于下劣诸善功德。而相劝励。应知是类总名恶友。若诸昧劣愚痴种类。所有猛利长时烦恼。是名愚戆烦恼炽盛。若于宿世信等善法不修习故。于现法中信等微弱。虽极精恳。然无力能即于现法获得涅槃。当知是名宿世资粮有所阙故于现法中其力薄弱。是名五种违逆学法。与此相违。应知五种随顺学法。成就彼故于毗柰耶勤学苾刍。能正修集一切所学。成就如是随顺法者。复有五法能防戒蕴一正出家。二善请问。三审观察。四修对治。五任持信。不厄于债而求出家。如前广说。唯求涅槃爱乐所学而求出家。当知如是名正出家。既出家已于犯无犯及还净中。若有苾刍持经律论。其所未了躬往请决彼便开晓。当知如是名善请问。于自尸罗三时观察。或初日分或中日分或后日分。若见无犯便生欢喜。昼夜精勤随学而住。若见有犯即便速疾如法悔除。当知如是名审观察。于时时间初夜后夜或昼日分。思惟修习所有贪等烦恼对治。非唯听闻尸罗言教便生喜足。当知如是名修对治。深信有犯当不爱果。深信无犯当来爱果。当知如是名任持信。又正出家为所依止作余四事。由正请问终不毁犯。无知故犯。由审观察终不毁犯。放逸故犯。由修对治终不毁犯。烦恼炽盛故有所犯。由任持信终不毁犯。轻慢故犯。依止如是五种法故。能防戒蕴名善防护。

复次于毗柰耶勤学苾刍。由有五种寂静法故。能灭诸恶。云何为五。一者柔和易可共住。二者断。三者断支。四者敬事。五者灭诤。何等柔和易可共住。谓如经说。略有六种可爱乐法。何等为断。谓诸人天所有四轮。何等断支。谓五断支。何等敬事。谓敬事大师。广说乃至。无有放逸。何等灭诤。谓七灭诤法。当知此中由依身等于同梵行现行非爱。又于僧祇共有财物不平受用。又有戒见不同分法。由依此故难可共住。性不柔和。心常展转互相经构。如是名为可爱乐法之所对治。与此相违。由其白品三种因缘。当知即是建立六种可爱乐法。由其第一建立三种。由其第二建立第四。由其第三建立第五及以第六。又于此中所有令他获得可爱利益安乐。正现在前身等诸业。名慈善友。若物可令清净受用。此物名为如法利养。若物不依邪命非法方便获得。此物名为如法所得。若物已置在于钵内。当知此物名堕钵中。若物虽未置于钵中而将欲置。当知此物名钵所摄。若所受食不偏精妙。亦不偏多。共食所食。显露而食不私密食。乃至唯有可充腹食亦共分布终不故思隐障处食。亦不闭门。而有所食恐他饥乏来至希求不得分给。当知是名平等受用。圣所爱戒差别分别。如摄异门应知其相。出世正见差别分别。即摄事分应知其相。又由二相成可乐性。一体彼有德而尊重故。二荷彼有恩而慰意故。又可乐性有二差别。一者未生令其得生。二者生已当倍增广。应知此中尊重增上。谓体彼有德。慰意增上。谓财法二摄。彼二增上谓善和合。和合增上谓心无扰恼。远离贪等所有扰恼。名曰无违。和合方便共为一事。名曰无诤。和同水乳名一趣性。又处所圆满。教导圆满。正行圆满。资粮圆满为所依止。应知建立人天四轮。五种妙好所住方处。名处所圆满。广说应知如声闻地。正士善友。名教导圆满。广说应知如声闻地及菩萨地。由五种相自发正愿。名正行圆满。何等为五。一于正教授能敬顺取。二行无违逆。三如实自显。四其教授师随所获得精粗衣服饮食卧具便生喜足。五无间殷重二种加行乐断乐修。乃至修习四种苾刍爱取对治。又宿所作福补特伽罗宿世善根增上力故。应知有五相果胜利。谓宿所作福增上力故。安住二种可爱果报。一内。二外。内可爱果报者。谓长寿久住妙色端严。无病少恼非仆非女非半择迦。智慧猛利发言威肃具大宗叶。外可爱果报者。谓生富贵家。如经广说。大富大翼有大侍卫。是名第一宿所作福相果胜利。又宿所作福增上力故。得善安住。非诸魍魉药叉非人守宅神等能为障碍。谓于财位不作障碍。或于寿命不作障碍。是名第二宿所作福相果胜利。又宿所作福增上力故。性于善法心能趣入修习无怠。是名第三宿所作福相果胜利。又宿所作福增上力故。性于恶行深自恳愧。虽作恶已时时发起猛利悔心。由此因缘令已作恶现在微劣。于当来恶能永远离。是名第四宿所作福相果胜利。又宿所作福增上力故。一切事业方便加行。意趣伎能展转昌盛。凡所施为无不敬顺。少用功力多有成办。是名第五宿所作福相果胜利。如是四种。天上诸天人中诸人。所有止观胜妙车轮。随有所阙其车不转。又依应所得义深生信解。于师长前如实自显身有勇悍心有勇悍堪能领解善说恶说所有法义。如其次第应知建立五种断支。随阙一支断不成办。又于最初应当勉励敬事大师。谓能宣说增上戒学增上心学增上慧学所有法教。次应敬事其所说法。次修习法随法行时。应当敬事依增上戒与毗柰耶相应学处。次应敬事依增上心及增上慧教诫教授。于时时间修财供养及法供养。应知此中财法供养。谓同居止及同受用。次于静虑修三摩地。从此无间随无爱味通达谛理。永尽诸漏无有放逸。如是七种敬事差别次第应知。又由三相应知敬事。由能体彼功德胜利故起尊重。随所体悉以身语意三种正行而修恭敬。复设种种幢旛盖等而为供养。有诸同梵行者举余同梵行者所犯众罪。即于现前四目相对。而以其实不以非实。乃至广说。彼于未了正解了时便更无犯。更无犯故是诸苾刍。由见闻疑不应重举前所犯事。如是诤事便得除灭。有诸苾刍见余苾刍犯罪时节。别于后时彼犯罪者忘自所犯。其见犯者记彼所犯便举是事。问言。汝忆自所犯不。彼乃答言。我都不忆。彼既不忆不可自悔。妄言我忆。非无悔言能离恶作。既被他举故信顺他。应从众僧求乞忆念毗柰耶想及以清净。尔时众僧信诸苾刍与彼清净。彼犯罪者得离恶作。是诸苾刍不应重举前所犯事。如是诤事便得除灭。复有苾刍由癫狂故现行众多非沙门法不随顺法。彼由此事故不成犯。复有一类无知苾刍。谓彼成犯非处举发。有诸苾刍为防未来教示忆念。令得自心还从众僧求乞不痴毗柰耶想及以清净。彼闻是已即便求乞。尔时众僧应断如是补特伽罗不成于犯。僧和合住唱与清净。无知苾刍既闻是已。不复重举前所犯事。如是诤事便得除灭。复有苾刍于众僧中举苾刍罪。其能举者起有犯想。彼所举者起无犯想。由无犯想便自称言我无所犯。能举者云长老岂不曾作如是如是事耶。彼遂诚言。我不曾作。能举复云。彼先已犯。今得举发犹不了。故仍言不犯。尔时众僧便为寻求事之自性为犯不犯。待得实已当如法断。如是诤事便得除灭。有异住处众多苾刍。于所犯罪互生疑诤。或言有犯或言无犯。或言是重或言是轻。有别住处众数过前。或望彼众此多慧解受持三藏。彼应就此请决所疑令到究竟。如是诤事便得除灭。复有苾刍既犯罪已。自恶作缠之所激发遂成忧悴。虑他举发便如法悔。由此一切诤事除灭。有多苾刍互相举罪。各为憍慢之所执持。不欲展转相对发露。专事离散。二部别居各作是言。彼既不肯来对我众发露悔灭。我等何为辄就彼众发露悔灭。彼此部中各应推一有智众首共禀所言。补特伽罗同往他众。许其发露悔灭所犯。如是诤事便得除灭。如是诤事略有四种。应知除灭亦有四种。云何名为四种诤事。一者他举诤事。二者互疑诤事。三者自举诤事。四者互举诤事。何等复名四种除灭。一者愿出所犯除灭。二者施与清净除灭。三者许求实性除灭。四者各各发露除灭

瑜伽师地论卷第九十九瑜伽师地论卷第一百

        弥勒菩萨说

        三藏法师玄奘奉　诏译

    摄事分中调伏事择摄第五之二

复次依毗柰耶勤学苾刍。于其五处应正遍知。云何为五。一事遍知。二罪遍知。三补特伽罗遍知。四引摄义利遍知。五损恼遍知。云何事遍知。谓蕴等五事如声闻地已说。云何罪遍知。谓依毗柰耶勤学苾刍。由五种相遍知所犯。一者遍知犯罪因缘。二者遍知犯罪等起。三者遍知所犯罪事。四者遍知犯罪加行。五者遍知犯罪究竟。遍知犯罪因缘者。谓或贪因缘。或嗔因缘。或痴因缘。毁犯众罪。遍知犯罪等起者。谓或有罪由身等起非语非心。或复有罪由语等起非身非心。或复有罪由心等起非身非语。或复有罪由身由心等起非语。或复有罪由语由心等起非身。或复有罪由身由语等起非心。或复有罪由身由语由心等起。无独由心所犯众罪。应从他处发露悔除。唯当恳诚深自防护。如有苾刍发起种种欲寻思等不善寻思。遍知所犯罪事者。谓犯罪事略有二种。一者有情数事。二者无情数事。遍知犯罪加行者。谓所犯罪有二加行。一非所应作事业加行。二是所应作事业加行。遍知犯罪究竟者。谓于是处施设方便。即于是处而得究竟。非于中间有其退转。以是缘故所犯圆满。诸集粗罪他胜众余方便中犯陨坠恶作。于彼方便及自聚中而得究竟。于陨坠罪诸方便中。亦犯恶作。四种罪聚名有余罪。他胜罪聚名无余罪。若所犯罪由有智故。名不积集。或复从他而显发故。亦不积集。与此相违。非不积集。若所犯罪已从于他如法发露方便悔除。名已显说。与此相违。名未显说。若所犯罪权持当悔。名有期愿。与此相违。名无期愿。若所犯罪。诸佛世尊于别解脱毗柰耶中。建立为犯。名有制立。与此相违。名无制立。若所犯罪。或约一类补特伽罗。或复约时而不决定。先无差别总相制立。当知此罪名为等运。与此相违。名非等运。云何补特伽罗遍知。谓由五相应知差别。一由行差别故。二由众差别故。三由增减差别故。四由证得差别故。五由观察差别故。由行差别者。谓能遍知由贪等行有差别故。彼有差别。如声闻地应知其相。由众差别者。谓能遍知由苾刍苾刍尼等七众别故彼有差别。由增减差别者。谓如一类补特伽罗。或贵族出家。或富族出家。或颜容端正。其余一类则不如是。复有一类补特伽罗。多闻博识语具圆满大智大福。于净尸罗坚猛防护。少有所犯多生恶作。于犯于出能善了知。其余一类则不如是。若能遍知如是等事。当知说名遍知增减有差别故彼有差别。由证得差别者。谓能遍知从随信行俱分解脱以为后边七种差别。预流果向乃至最后阿罗汉果八种差别。诸如是等补特伽罗差别分别。如声闻地已辩其相。由观察差别者。谓能举罪补特伽罗。应善观察所举罪者。然后应举为作忆念。谓观所举补特伽罗为于我边有爱敬不。广说如经应知其相。其所发举补特伽罗。亦应善察能举罪者。为是愚夫癫狂痴騃非法举罪欲于我所当作损害。广说如经应知其相。为是智者非狂非騃所有白品。广说如经应知其相。又于堪举补特伽罗。应正观察为开举不。如是观察补特伽罗所有差别。应知说名补特伽罗遍知。云何引摄义利遍知。谓能遍知略有三种引摄义利。何等为三。一引摄自身利养义利。二引摄他身出罪义利。三引摄僧伽摈斥犯戒安乐义利。引摄自身利养义利者。谓若诸利养体是清净。是名真实。若诸利养体是清净而堪要用。非无所用徒多贮畜凡百资缘。如是名为能引义利。若诸利养不过于时堪住受用。是名应时。若诸利养其余苾刍亦现引摄。是名有伴。即此有伴非引破僧。名离破僧。若所引摄利养义利。具此五支安住正念。以无染心应当受用。如是引摄利养义利。名为无罪。引摄他身出罪义利者。谓若所犯罪彼实现行。是名真实。若复自知我能令彼出不善处安置善处。如是名为能引义利。若他说法敬事尊长恭承病等正加行时。无容举罪。是名应时。若举彼罪诸余苾刍共为助伴。是名有伴。非此因缘能引破僧。如是名为第五清净。若所引摄出罪义利。具此五支安住正念无染污心。如慈善友以柔软言应引摄他出罪义利。如引摄他出罪义利。引摄僧伽摈斥犯戒安乐义利。当知亦尔。而差别者。若因摈斥其被摈者。不与能摈命为障碍。或不因此坏僧居园。亦不因此损坏制多。及不损余同梵行者。如是名为能引义利。与此相违。应知说名引无义利。云何损恼遍知。谓有五种现法损恼。凡夫所趣。愚痴所趣。智者所离。虽实非狂如狂所作。乃至唯有处诳稽留。都无增长所有义利。云何为五。谓有一类伤悼死亡。以无量门而自煎迫伤沦丧者。是名第一现法损恼。凡夫所趣乃至广说。复有一类幸有所余易活方便。而于衢路大市廛间。分解支节疑命殆尽。邪苦逼己以自存活。是名第二现法损恼。凡夫所趣乃至广说。复有一类为性悭贪悭垢所蔽。幸有种种养命资缘。而大艰幸以自存活。是名第三现法损恼。凡夫所趣乃至广说。云何悭垢。谓八悭垢。一者宿习悭贪不串惠施悭垢。二者现法上品顾恋身命悭垢。三者于同分友共住随转诸有情所不串习悲悲心微劣悭垢。四者见田寡德毁犯正行悭垢。五者于诸财物起难得想悭垢。六者三时忧悔悭垢。七者于诸财宝唯见功德不见过患悭垢。八者邪施回向悭垢。当知是名八种悭垢。复有一类爱乐天趣求欲生天。不如实知生天道路。断食投火坠高岩等自加逼害。是名第四现法损恼。凡夫所趣乃至广说。复有一类爱乐清净。不如实知清净道路。谓加苦法而得清净。以无量门自为逼害。是名第五现法损恼。凡夫所趣乃至广说。如是五种现法逼恼。依毗柰耶勤学苾刍。当正遍知应速远离

复次依毗柰耶勤学苾刍。成就五法。未生信者令其生信。已生信者令倍增长。云何为五。一尸罗圆满。二正见圆满。三轨则圆满。四净命圆满。五远离展转斗诤圆满。尸罗圆满略有十种。如声闻地已辩其相。谓初善受持不太沉聚不太浮散。乃至广说。正见圆满略有五种。一者增益萨迦耶见及边执见已永断故。二者损减拨无邪见已永断故。三者取见谓诸见取及戒禁取已永断故。四者妄计吉祥处见已永断故。五者妄计非有为有有为非有诸颠倒见已永断故。轨则圆满亦有五种。谓或依时务应所作事。或依善品应所作事。或依威仪应所作事。随顺世间及毗柰耶所有轨则。广说应知如声闻地。净命圆满亦有五种。谓能远离矫诈等五起邪命法。如声闻地应知其相。远离展转斗诤圆满略有六种。谓离六种斗诤根故。此中六种斗诤根者。谓忿恨等。广说如经。又依六处应知建立六斗诤根。云何六处。一者不饶益相。二者乐隐己过憍慢执持。三者利养恭敬欲爱现行。四者毁犯增上戒行。五者毁犯增上心行。六者毁犯增上慧行。应知依第一处建立第一斗诤根本。乃至依第六处建立第六斗诤根本。谓有一类补特伽罗众所识知。广从他处多获利养。由是因缘有所毁犯。于所犯罪乐欲隐藏。不欲令他知己所犯。有诸苾刍既了知已。对一对二或对众多举其犯事。彼由此故一向忧戚烧恼身心。又由憍慢所执持故多生热恼。勿彼复对他众人前咎责于我。如是彼人先隐所犯。说名为覆。又复发起憍慢烦恼。此二合名乐隐己过憍慢执持。由是建立斗诤根本。复有苾刍恭敬利养欲爱现行。见有他人多饶财宝众所知识具大福祐。则便亲附殷重承事。非爱非敬亦非乐法。专为利养恭敬因缘。如是思惟摄取。质直忍辱。柔和为依止。师我。于其处随意自在。彼于我所多有施为。而我于彼都无所作。如是思惟摄取。捷慧爱乐修福同梵行者。以为助伴。所有僧事及其余事皆令彼作。我独萧然自得而住。如是或有毁犯禁戒。同梵行者正诘问时。便不分明假托余事而有所说。如是名为行矫伪行诳谄。处所由此因缘起诸斗诤。余随所应当知其相。与是相违。有五种法。令未信者转增不信。令已信者寻还变革

复次依毗柰耶勤学苾刍成就五力。于一切种等意正行所有加行。云何五力。一加行力。二意乐力。三开晓力。四正智力。五质直力。若有乐学一切身分于诸学中正善修学。又于所学最极恭敬为自调伏为般涅槃。如是当知名加行力。若有所犯由意乐故速还出离。如是当知名意乐力。若于学处。时时请问持三藏者。所有自爱诸善男子应所修学亦能开示。如是当知名开晓力。从他闻已若于其中是真是实无倒摄受。若于其中伪毗柰耶像似正法诸恶言说违背法性如实了知。虽不至彼躬申请问所未开晓。而多闻故于佛世尊所不遮止亦不开许。能自思惟于沙门性是能随顺是能违逆。既了知已如其所应能正修行能正远离。如是当知名正智力。若信解力离诸诳谄。无有少分诈妄分别。非于少分所开许中增益多分而起现行。非于多分所开许中损减少分而起现行。其所现行不增不减。如是最初自生欣庆。后令自他安乐而住修行正行。非眩惑他。如是当知名质直力

复次依毗柰耶所学加行。应知有五补特伽罗品类差别。谓有一类补特伽罗。于善说法毗柰耶中。依出家法始将发趣。虽欲发趣仍未出家。便生烦恼邪欲寻求。以是缘故遂不出家。复有一类既出家已。烦恼炽盛故思犯罪。由是因缘多诸忧悔。便生烦恼邪欲寻求。复有一类既出家已。于出家法不生喜乐。于舍所学将欲发趣。及于出家发生忧悔。而作是念。非我好作所谓出家。彼由二缘发生烦恼邪欲寻求。复有一类既出家已。命难因缘不起故思违越所学。乃至尽命爱乐出家勤修梵行。彼非二缘发生烦恼邪欲寻求。如是四种补特伽罗是异生类。复有一类。谓诸有学未得解脱。即此为依。于后第一心慧解脱通达升进。如实了知。是名第五补特伽罗。即此第五望前第四诸异生类。由调善可爱有学解脱。于后解脱通达升进而有差别。即此当知已见谛迹。此中前三补特伽罗。如其所应于发趣所生。忧悔所生。及俱所生所有烦恼邪欲寻求。应正除遣。于上解脱应正了知。第四唯于后上解脱应正了知。若能如是一切当得平等平等。

复次于三学中当知略有三种邪行。谓有一类补特伽罗。先求涅槃而乐出家。出家已后为天妙欲爱味所漂。所受持戒回向善趣。唯护尸罗便生喜足。是名外结补特伽罗于增上戒第一邪行。复有一类补特伽罗。不唯护戒便生喜足。而能趣证上诸世间随一静定。即于此定深生味染。不进上求圣谛现观。是名内结补特伽罗于增上心第二邪行。复有一类补特伽罗。是其有学已见谛迹。由住放逸于现法中不般涅槃。当知是名于增上慧第三邪行。

如是略引随顺此论境智相应调伏宗要摩怛理迦。其余一切随此方隅皆当觉了

    摄事分中本母事序辩摄

如是已说毗奈耶事摩怛理迦。

云何名为摩怛理迦事。谓若素怛缆摩怛理迦。若毗奈耶摩怛理迦。总略名一摩怛理迦。虽更无别摩怛理迦。然为略摄。流转还灭杂染清净杂说法故。我今复说分别法相摩怛理迦。嗢拖南曰

  要由余释余　　非即此释此
  于前略序事　　自后当广辩

若有诸法应为他说。要以余门先总标举。复以余门后别解释。若如是者名顺正理。非即此门先总标举。还以此门后别解释。如先总举云何有为后别释言所谓五蕴。若如是者名顺正理。非先总举云何有为后别释言所谓有为。如是一切应随觉了。

略由二相。应知建立分别法相摩怛理迦。一者先略序事。二者即依如是所略序事后当广辩。

云何名为先略序事。谓略序流转杂染品事及以还灭清净品事。云何流转杂染品事。谓六识身自性所依所缘助伴事。若蕴界处事。若诸缘起处非处事。若三受事。若三世事。若四缘事。若诸业事。若烦恼事。若三界事。谓欲界等。若十有事。谓欲有。色有。无色有。那落迦有。傍生有。鬼有。天有。人有。业有。中有。由别离欲善趣恶趣招引趣向有差别故。若十一识住事。谓四识住与七识住总合说故。若九有情居事。如经广说。若五趣事。若四生事。若四入胎事。若四得自体事。若四食事。若四言说事。若四法受事。若四颠倒事。若苦谛事。若集谛事。如是等类。名为略序流转杂染品事。云何还灭清净品事。谓灭谛事。若道谛事。若三摩地事。若诸智事。若此所引诸功德事。若七正法事。若七正作意观察事。若三十七菩提分法事。若四行迹事。若四法迹事。若奢摩他毗钵舍那事。若四修定事。若三福业事。若三学事。若四沙门果事。若四证净事。若四圣种事。若三乘事。若四门记事。如是等类。名为略序还灭清净品事。如是等事广辩建立。随其所应。如前所说彼彼地中及诸摄分。应知其相。

又一切事以要言之。总有五事。一者心事。二者心所有法事。三者色事。四者心不相应行事。五者无为事。云何即依如是所略序事后当广辩。谓略由四相广辩彼事。何等为四。一异门差别故。二体相差别故。三释词差别故。四品类差别故。异门体相释词差别。如摄释分应知其相。品类差别复有八种。一建立有非有异非异性差别。二建立界地差别。三建立时分差别。四建立方所差别。五建立相续差别。六建立分位差别。七建立品分差别。八建立道理差别。由如是等八种差别。于一切事品类差别。应随觉了。云何建立有非有异非异性差别。谓若略说有三种有。一者实有。二者假有。三者胜义有。云何实有。谓诸诠表法有名可得有事可得。此名于事无碍而转。非或时转或时不转。当知是名略说实有。如于色等诸法聚中。建立墉室军林草木衣食等相。此相唯于此聚随转。于余退还。色等诸相于一切处皆悉随转。是故此相所诠实有。当知余相所诠假有。又此假有略有六种。一聚集假有。二因假有。三果假有。四所行假有。五分位假有。六观待假有。聚集假有者。谓为随顺世间言说易解了故。于五蕴等总相。建立我及有情补特伽罗众生等想。此想唯能显了此聚。是故说名聚集假有。因假有者。谓未来世可生法行由未生故。虽非实有。而有其因当可生故。名因假有。果假有者。所谓择灭是道果故。不可说无。然非实有。唯约已断一切烦恼。于当来世毕竟不生而假立故。所行假有者。谓过去世已灭诸行。唯作现前念所行境。是故说名所行假有。已谢灭故。而非实有。分位假有者。谓生等诸心不相应行。如前意地已标辩释。即于诸行由依前后有及非有。同类异类相续分位假立生等。非此生等离诸行外有真实体而别可得。观待假有者。谓虚空非择灭等。虚空无为待诸色趣而假建立。若于是处色趣非有假说虚空。非离色无所显法。外别有虚空实体可得。非无所显得名实有。观待诸行不俱生起。于未来世不生法中。立非择灭无生所显。假说为有。非无生所显可说为实有。云何胜义有。谓于其中一切名言一切施设皆悉永断。离诸戏论。离诸分别。善权方便说。为法性真如实际空无我等。如菩萨地真实义品第四所知障净智所行真实。应知其相。与上相违。当知非有。又由四种别无别故。应知建立异不异性。一由所因别无别故。二由所依别无别故。三由作用别无别故。四由时分别无别故。若所因等诸法异相差别可得。此异于余。若无异相差别可得。此前及后与现无异。时分别者。谓一切行唯刹那住。即此自体还望自体。说为不异。过刹那后说名为异。由彼为种而此得生。说为所因。若由眼等及大种等为依而转。说名所依。若一切行别别功能。说名作用。如是名为建立第一有非有异非异性品类差别。云何建立界地差别。谓欲色无色三界差别。言欲界者。谓下从无间上超他化至魔罗宫。其中诸行皆因欲界烦恼所生。于其三世与彼烦恼为所依止。彼品粗重之所随缚为彼所系。又欲界中一切烦恼全未离欲。非定地摄。色无色界一切烦恼一分离欲。定地所摄。余烦恼相如前应知。言色界者。谓四静虑并静虑中间有十七地。无色界者。谓空处等四无色地。云何建立时分差别。谓于过去世有无间已灭。有邻近已灭。有久远已灭。于未来世有无间将生。有邻近当生。有久远当生。于现在世有刹那现在。有众同分现在。有相续未灭现在。云何建立方所差别。谓有色诸法据处所故。得有远近方所差别。无色诸法由无色故。无据处所。若依色法而得生起。即于其处说有方所。此由转相故。非据处所故。有色诸法具由二种。云何建立相续差别。当知相续略有四种。自他根境有差别故立四相续。一自身相续。二他身相续。三诸根相续。四境界相续。二是假建立。二是真实义。云何建立分位差别。谓苦分位。乐分位。不苦不乐分位。即是能顺三受诸法。云何建立品分差别。当知建立所治能治二品差别。谓染不染法。下劣胜妙法。粗细法。执受非执受法。有色无色法。有见无见法。有对无对法。有为无为法。有漏无漏法。有诤无诤法。有爱味无爱味法。依耽嗜依出离法。世间出世间法。堕摄非堕摄法。当知此中。由五因缘建立染法。一者于三受中如其所应为杂染故。二者能遍摄受诸烦恼品粗重性故。三者能遍摄受现法当来非爱果故。四者能遍连结生相续故。五者能遍障碍一切善法及于所知障智生故。由是因缘名为染法。与是相违。应当了知不染法相。此不染法略有二种。谓善无记。由臭烂不净及烦恼不净故。名不净。由于此中诸所有受皆悉是苦故。名为苦。由无常性故。名不坚。若由如是胜义道理。性是不净。性是其苦。性是不坚。其性鄙秽名为下劣。超过于此应知胜妙。又相待故下劣胜妙二相差别。谓待色界欲界是劣。待无色界色界是劣。若待涅槃三界皆劣。如是等类应当了知。微着差别故。净秽差别故。势用差别故。应知建立色趣粗细。软等品类有差别故。应知建立无色诸法所有粗细。又有色法无色法由世俗胜义谛理易了难了故。应知粗细二种差别。微谓极微聚。着谓所余聚。净谓中有上地色聚。秽谓余有下地色聚。言势用者。谓若是处有地大等势用增强。虽与余聚其物量等。而能胜余粗显可得。软等品类有差别者。谓乐等诸受信等诸法有软中上品类差别。执受法者。谓诸色法为心心所之所执持。由托彼故心心所转安危事同。同安危者。由心心所任持力故。其色不断不坏不烂。即由如是所执受色。或时衰损或时摄益。其心心所亦随损益。与此相违。名非执受。言有色者。谓能据方所。言无色者。谓不据方所。此约所缘领纳流转施设建立。言有见者。谓若诸色堪为眼识及所依等。示在此彼明了现前。与此相违。名为无见。言有对者。谓若诸色能碍他见碍他往来。与此相违。名为无对。言有为者。谓有生灭系属因缘。与此相违。应知无为。言有漏者。谓若诸法诸漏所生。诸漏粗重之所随缚。诸漏相应。诸漏所缘。能生诸漏。于去来今为漏依止。与此相违。应知无漏。能与当来生等众苦为生因故。于现法中有罪性故。名为有诤。与此相违。名为无诤。内门自体爱染随故。名有爱味。与此相违。名无爱味。外门境界爱着随故。名依耽嗜。与此相违。名依出离。若法有漏有诤有爱味依耽嗜。如是一切名为世间。若能治此依世俗谛所起俗智乃所引法亦名世间。与此相违。名出世间。若诸世间名堕摄法。堕有情器欲色无色世间摄故。若出世间非堕摄法。不堕前说世间摄故。云何建立道理差别。谓四道理。一相待道理。二证成道理。三作用道理。四法尔道理。如是道理差别分别。如声闻地应知其相。如是八种品类差别。及前所说异门体相释词差别。应知如前广略所序一切事中能正广辩。无过此辩

复次嗢拖南曰

  初聚相摄等　　其次成就等
  自性等因等　　后广说地等

有九法聚。摄一切法。何等为九。一善法聚。二不善法聚。三无记法聚。四见所断法聚。五修所断法聚。六无断法聚。七邪性定法聚。八正性定法聚。九不定法聚。善等法聚。广如意地已辩其相。见所断法聚者。谓一切见。若依见等贪嗔痴慢。若恶趣业。若于诸谛犹豫疑等。修所断法聚者。谓余一切所应断法。无断法聚者。谓无漏法。邪性定法聚者。谓无间业及断善根。正性定法聚者。谓学无学所有诸法。不定法聚者。谓余非学非无学法。

应知此中所有诸法自性相摄他性相应。或有一类补特伽罗。

成就善法及无记法。非不善法。谓诸圣者已离欲贪。及此异生除种子法。或有一类补特伽罗。成就不善及无记法。非诸善法。谓断善根补特伽罗除种子法。无有成就善不善法。非无记法。或唯不善或唯无记而可得者。又于此中应知诸法如其所应若得若舍。谓有一类。由受所受故。或舍所受故。或邪推求故。或正推求故。或转形故。或法尔故。或离欲故。或加行故。或退失故。或得果故。或死生故。而有得舍。如别解脱律仪等法。由受彼故得。由舍彼故舍。若诸善法由邪推求故舍。由正推求故得。由转形故。舍苾刍律仪或苾刍尼律仪。随得其一二形生故。一切永舍。由法尔故。世间坏时能入法尔所得静虑。由离欲故。能得上地所有善法。由加行故。能发依彼所引功德。令现在前。由退失故。还得先时诸下劣法。由得果故。舍诸世法。得出世法及后明净世间善法。由死生故若生下时获于生得善及不善无记诸法。若生上时唯得善法及无记法。诸有所舍。如其所应亦随觉了。无有相违。诸心心所而共相应。及与相摄。即此刹那行还与此刹那。又无一切生死诸行可永断法。又无诸行先未曾生欻然令起。又一切行皆刹那生。生刹那后必无停住。诸行一生一住一灭。

又一切法一一自性无有第二自性可得。又定无有同类二法一时相应。即由第二自性无故。又非一法有乖异相二种作用。又一切行依于他转而不自依。又非自性与自性俱。亦不随转。又非即此一刹那心与此刹那心为所缘。

又非即此刹那自性与此刹那自性为因。亦非后生为前生因。亦非同类为异类因。如不善望善善望不善。而作无记异熟果因。

广说地等

嗢拖南曰

  初诸地诸依　　次谛智加行
  三摩地根道　　对治行修习
  有漏无漏法　　诸果诸因缘
  立补特伽罗　　后遍知究竟

有九种地。何等为九。一资粮地。二方便地。三观行地。四见地。五修地。六有学地。七无学地。八圣者地。九异生地。先应积集出世资粮。次为尽漏勤修方便。次修随顺决择分时正观诸谛。次能证入正性离生。次后渐证四沙门果。此中前三是有学地。其第四果是无学地证离生已一切世间渐升进道。名为修地。即总摄见。学无学地名圣者地。此余一切名异生地。谓若未修加行。若已修加行。若已离欲。一切异生复有九依。能尽诸漏。何等为九。谓未至定。若初静虑。静虑中间。余三静虑。及三无色。除第一有。复有四圣谛。能为尽净惑所。复有十智。能觉一切所知境界。谓法智。类智。若世俗智。若他心智。若苦等智。尽无生智。此广分别如声闻地。又瑜伽师有五加行。一为欲证入正性离生。二为得上果。三为进离欲。四为欲转根。五为引功德。复有瑜伽三三摩地。一空三摩地。二无愿三摩地。三无相三摩地。复有三种一切行向住果者根。一未知欲知根。是行预流果向者根。二已知根。是预流果已上乃至行阿罗汉果向者根。三具知根。是住阿罗汉果者根。复有九道。云何为九。一世间道。二出世道。三加行道。四无间道。五解脱道。六胜进道。七下品道。八中品道。九上品道。世间道者。谓由此故能证世间诸烦恼断。或不证断。能往善趣或往恶趣。出世道者。谓由此故能证究竟诸烦恼断。加行道者。谓为断惑勤修加行。无间道者。谓正断惑。解脱道者。谓断无间心得解脱。胜进道者。谓从此后发胜加行。下品道者。谓能对治上品烦恼。中品道者。谓能对治中品烦恼。上品道者。谓能对治下品烦恼。复有四种对治。一厌坏对治。二断灭对治。三任持对治。四远分对治。复有十六行相。谓观诸谛为无常等。如前已辩。复有八种修习如是对治如是行相。如是修习如前定地及声闻地应观其相。复有二品摄一切法。一有漏法。二无漏法。此二法如前应知已辩。复有五果。一异熟果。二等流果。三离系果。四士用果。五增上果。复有十因。一随说因。二观待因。三牵引因。四摄受因。五生起因。六引发因。七定异因。八同事因。九相违因。十不相违因。复有四缘。一因缘。二等无间缘。三所缘缘。四增上缘。如是一切果因及缘。如菩萨地等已辩其相。复有七种补特伽罗。谓随信行等。复有六种阿罗汉。谓退法等。复有八种补特伽罗。谓行四向及住四果建立。应知如声闻地。复有六种遍智。一者不定地有漏谛遍智。二者定地有漏谛遍智。三者无漏无为谛遍智。四者无漏有为谛遍智。五者顺下分结遍智。六者顺上分结遍智。复有二种究竟。一者智究竟。二者断究竟。智究竟者。谓尽无生智。自斯已后为断烦恼无复应知。断究竟者。谓遍究竟诸烦恼断。由彼断故。圆满究竟证心解脱及慧解脱。

如是略引随顺此论境智相应摩怛理迦所有宗要。其余一切随此方隅皆当觉了。遍行一切摩怛理迦。如摄释分应知其相。如来法教数无限量。

何能穷到无边彼岸随此。方隅。随此引发。随此义趣。诸聪慧者。于余一切应正寻思。应正觉了

瑜伽师地论卷第一百

大唐贞观廿二年五月十五日于长安弘福寺翻经院三藏法师玄奘奉　诏译
弘福寺沙门知仁笔受
弘福寺沙门灵隽笔受
大总持寺沙门道观笔受
瑶台寺沙门道卓笔受
清禅寺沙门明觉笔受
大总持寺沙门辨机证文
简州福众寺沙门靖迈证文
蒲州普救寺沙门行友证文
普光寺沙门道智证文
汴洲真谛寺沙门玄忠证文
弘福寺沙门明[泳-永+(虍-七+(一/八/八/目))]正字
大总持寺沙门玄应正字
弘福寺沙门玄谟证梵语
弘福寺沙门文□证义
蒲州栖岩寺沙门神泰证义
廓州法讲寺沙门道深证义
宝昌寺沙门法祥证义
罗汉寺沙门慧贵证义
宝澄寺沙门明琰证义
大总持寺沙门道洪证义
慈恩寺沙门玄奘译
银青光禄大夫行太子左庶子高阳县开国男臣许敬宗监阅

大唐内常侍轻车都尉菩萨戒弟子观自在敬写西域新翻经论。愿毕此余生道心不退。庶以流通未闻之所。窃以佛日西沈正法云谢。慧流东渐象教方传。希世之符奥义宣于具叶。非常之宝至赜登于龙宫。挹其冲源截暴河而遐逝。其玄间出朽宅而长驱。玄奘法师释门之龙象振旦之鹙鹭。逾葱专励学赍梵文而旋止杀青。甫就永事流通土方。生涯多幸预闻正法。植田或爽禀质不全。今罄兹寸禄缮斯奥旨。片言只字贝经心目。亲蒙口决庶无乖殊。以斯福祉奉福太宗文皇帝。即御皇帝王公卿士六姻亲族。凡厥黎庶及跋行啄息平等董修。乘此胜基方升正觉

天长十年(岁次癸丑)七月十八日愿主佛师妙广


瑜伽师地论释

    No. 1580 [cf. No. 1579]

瑜伽师地论释一卷

        最胜子等诸菩萨造

        三藏法师玄奘奉　诏译

本地分中五识相应地之一

  敬礼天人大觉尊　　福德智慧皆圆满
  无上文义真妙法　　正知受学圣贤众
  稽首无胜大慈氏　　普为利乐诸有情
  广采众经真要义　　略说五分瑜伽者
  归命法流妙定力　　发起无著功德名
  能于圣者无胜海　　引出最极法甘露
  餐受美音自满足　　复为饶益诸世间
  等注无穷字花雨　　荣润牟尼如意树
  此论殊胜若莲花　　犹妙宝藏如大海
  具显诸乘广大义　　善释其文无有遗
  于此瑜伽大论中　　我今随力释少分
  为令正法常无尽　　利益安乐诸含识

今说此论。所为云何。谓有二缘故说此论。一为如来无上法教久住世故。二为平等利益安乐诸有情故。复有二缘故说此论。一为如来甘露圣教已隐没者。忆念采集重开显故。未隐没者。问答决择倍兴盛故。二为一切有情界中有种姓者。各依自乘修出世善。得三乘果。出生死故。无种姓者。依人天乘。修世间善。得人天果。脱恶趣故。复有二缘故说此论。一者或有于多说空不了义经。如言计着拨无。一切憎背有教。为令随悟诸法有相。解经密意舍无见故。二者复有于多说有不了义经。如言计着执有。一切厌怖空教。为令随悟诸法无相。解经密意舍有见故。复有二缘故说此论。一为成就菩萨种姓补特伽罗。唯依大教。遍于诸乘文义行果。生巧便智。断一切障。修一切善。证佛菩提。穷未来际。自他利乐无休废故。二为成就二乘种姓。及无种性补特伽罗。亦依大教。各于自乘文义行果。生巧便智。断烦恼障。伏诸盖缠。修自分善。得自乘果。出离三界诸恶趣故。复有二缘故说此论。一者或有宿习。无知犹豫颠倒。执着外道小乘邪教。故于大乘不能信解。为善分别大乘法相。令其信解了达。决定离颠倒故。二者复有闻诸契经种种意趣甚深难解。其心迷乱诽毁不信。为善开示令生信解饶益彼故。复有二缘故说此论。一为摄益乐略言论勤修行者。采集众经广要法义。略分别故。二为摄益乐广言论勤说法者。于一一法。开示无边差别义故。复有二缘故说此论。一为开显诸法实相。问答决择立正论故。二为灭除一切妄执。问答决择破邪论故。复有二缘故说此论。一为显了遍计所执情有理无。依他起性圆成实性理有情无。令舍增益损减执故。二为显了世间道理。证得胜义法门差别。令修二谛无倒解故。复有二缘故说此论。一为开阐随转真实二种理门。令知二藏三藏法教不相违故。二为开阐因缘唯识无相真如四种理门。令修观行有差别故。复有二缘故说此论。一为示现境界差别。令知诸法自性相状位差别故。二为示现修行差别令知三乘方便根本果差别故。如是等类所为诸缘。处处经论种种异说。当知皆是此论所为

今说此论所因云何。谓诸有情无始时来。于一切法处中实相。无知疑惑颠倒僻执。起诸烦恼。发有漏业。轮回五趣。受三大苦。如来出世。随其所宜。方便为说种种妙法处中实相。令诸有情知一切法。如是如是空故非有。如是如是有故非空。了达诸法非空非有。远离疑惑颠倒僻执。随其种姓。起处中行。渐次修满。随其所应。永灭诸障。得三菩提。证寂灭乐。佛涅槃后。魔事纷起。部执竞兴。多著有见。龙猛菩萨证极喜地。采集大乘无相空教。造中论等。究畅真要。除彼有见。圣提婆等诸大论师。造百论等。弘阐大义。由是众生。复着空见。无著菩萨位登初地。证法光定。得大神通。事大慈尊。请说此论。理无不穷。事无不尽。文无不释。义无不诠。疑无不遣。执无不破。行无不修。果无不证。正为菩萨。令于诸乘境行果等。皆得善巧。勤修大行。证大菩提。广为有情。常无倒说。兼为余乘。令依自法。修自分行。得自果证。如是略说此论所因

今说瑜伽师地论者。名义云何。谓一切乘境行果等所有诸法。皆名瑜伽。一切并有方便善巧相应义故。境瑜伽者。谓一切境。无颠倒性。不相违性。能随顺性。趣究竟性。与正理教。行果相应故。名瑜伽。此境瑜伽。虽通一切。然诸经论。就相随机。种种异说。或说诸法四种道理。名为瑜伽。观待作用。法尔证成。总摄一切正道理故。或说二十四不相应行中。一名瑜伽。因果相称无乖违故。此二并如决择分等处处广说。或说杂染清净无性。名为瑜伽。除违契顺最为胜故。如大梵问契经等说。诸瑜伽师。观无少法可令其生及可令灭。亦无少法欲令证得及欲现观。谓于一切杂染无性瑜伽中行。观无少法可令其生及可令灭。及于一切清净无性瑜伽中行。观无少法欲令证得及欲现观。或说究竟清净真如名为瑜伽。理中最极一切功德共相应故。如入楞伽契经中说。若观真义。除去分别。远离瑕秽。无有能取。亦无所取。无解无缚。尔时在定。当见瑜伽不应疑虑大义经中。说从一法增至百法。皆名瑜伽。法门虽别义无违故。广义经中。说蕴界处缘起谛等。皆名瑜伽。摄一切境顺机宜故。于如是等诸经论中。说一切境。皆名瑜伽。总具四性顺四法故。行瑜伽者。谓一切行。更相顺故。称正理故。顺正教故。趣正果故。说名瑜伽。此行瑜伽。虽通诸行。然诸经论。就相随机。种种异说。如辩瑜伽师地经中。正修诸行。说名瑜伽。总摄一切相应行故。月灯经中。修三十七菩提分法。说名瑜伽。此于一切顺果行中。最为胜故。于大分别六处经中。辨奢摩他毗钵舍那平等运道。说名瑜伽。如是止观众行主故。海慧经中修三摩地。说名瑜伽。住心发行此最强故。显扬论等。信欲方便精进四法。说名瑜伽。作意或智说名方便此四通生一切行故。闻所成地。别辨九道。说名瑜伽。会理除惑。位别胜故。谓世出世。加行无间解脱胜进软中上道。修所成地。总辨修习诸对治道。说名瑜伽。为乐略者。总说修故。有处说缘诸地所摄无颠倒智。名为瑜伽。缘诸地法无颠倒智行中胜故。有处复说方便善巧或唯方便。名为瑜伽。作意与智发行胜故。或就最初发悟胜故。功德实性契经中。说诸缘起观。名为瑜伽。缘起观智于出生死最为要故。正行经中。说正见等八支圣道。名为瑜伽。趣涅槃城此为胜故。毗奈耶经。说修戒等。名曰瑜伽。戒定慧学因中胜故。大义经中。说修一切世出世行分位差别。皆名瑜伽。正行阶位相符顺故。如是皆说共声闻行。名为瑜伽。通证三乘行中胜故。慧到彼岸契经中。说观空作意。名为瑜伽发起大行。此最胜故。如彼经言菩萨所有大瑜伽者。谓空作意。菩萨由此空作意故。不堕声闻及独觉地。乃至能净诸佛土等。即彼经中。复说般若波罗蜜多。名胜瑜伽。导大乘行。此殊胜故。如彼经言菩萨所有诸瑜伽中。慧度瑜伽。最上最胜。广说乃至。是无等等。何以故。如是般若波罗蜜多。是为无上。瑜伽法故。余处说此慧度所摄。无分别定。名为瑜伽。能发一切胜功德故。余处复说菩萨所有殊胜慧悲平等双转。名为瑜伽。能证无住大涅槃故。如是等说。诸不共行。名为瑜伽。能证无上佛菩提故。于如是等诸经论中。说一切行。皆名瑜伽。具上所说四种义故。果瑜伽者。谓一切果。更相顺故。合正理故。顺正教故。称正因故。说名瑜伽。此果瑜伽。虽通诸果。然诸经论。就相随机。种种异说。分别义经。说力无畏不共佛法。名曰瑜伽。能伏诸魔。制诸异论。胜余乘故。殊胜经中。说佛所证无住涅槃。名为瑜伽。尽未来际。无所住故。大义经中。说如来地无分别智。及以大悲。名为瑜伽。自利利他。常无尽故。辨说瑜伽师地经中。佛地功德。皆名瑜伽。穷于法界无断尽故。分别三乘功德经中。三乘果德。名为瑜伽。皆与正理等相应故。赞佛论说三身三德皆是瑜伽。一切果德不相离故。集义论说。果位所摄。有为无为诸功德聚。皆是瑜伽。等至究竟和合位故。于如是等诸经论中。一切果德。皆名瑜伽。具上义故。如是圣教。亦名瑜伽。称正理故。顺正行故。引正果故。有义正取三乘观行。说名瑜伽。数数进修。合理顺行。得胜果故。境果圣教。瑜伽境故。瑜伽果故。论瑜伽故。亦名瑜伽。如是此论瑜伽两字尚遍扰动。圣言大海。何况具说。瑜伽师地。恐难受持。故且略说。三乘行者。由闻思等。次第习行如是瑜伽。随分满足。展转调化诸有情故。名瑜伽师。或诸如来。证瑜伽满。随其所应。持此瑜伽。调化一切圣弟子等。令其次第修正行故。名瑜伽师。地谓境界。所依所行。或所摄义。是瑜伽师。所行境界故名为地。如龙马地。唯此中行。不出外故。或瑜伽师。依此处所。增长白法。故名为地。如稼穑地。或瑜伽师地所摄智。依此现行。依此增长。故名为地。如珍宝地。或瑜伽师。行在此中。受用白法。故名为地。如牛王地。或诸如来名瑜伽师。平等智等行在一切无戏论界无住涅槃瑜伽中故。是彼所摄。故名为地。或十七地。摄属一切瑜伽师故。如国王地。是故说名瑜伽师地。问答决择诸法性相。故名为论。欲令证得瑜伽师地。而说此论。故以为名。如对法论。或复此论。无倒辩说瑜伽师地。故以为称。如十地经。或复此论。依止此地。故以为号。如水陆花。由是论名瑜伽师地

今此论体。总有五分。一本地分。略广分别十七地义。二摄决择分。略摄决择十七地中深隐要义。三摄释分。略摄解释诸经仪则。四摄异门分。略摄经中所有诸法名义差别。五摄事分。略摄三藏众要事义。此论既有如是五分。何故但名瑜伽师地。就初立名。故无有失。又一切法。无不皆是瑜伽师地。以瑜伽师用一切法为依缘故。此中存略。且说十七。又十七地。具摄一切文义略尽。后之四分。皆为解释十七地中诸要文义故。亦不离瑜伽师地。由是此论。用十七地。以为宗要。虽复通明诸乘境等。然说论者。问答决择诸法性相。意为菩萨。令于一切皆得善巧。修成佛果。利乐无穷。是故此论。属菩萨藏阿毗达磨。欲令菩萨得胜智故

论曰。云何瑜伽师地。谓十七地。释曰。初问云何。瑜伽师地者。总问此论一部宗要。问者。先闻诸经所说瑜伽师地。其义未了。故为此问。谓辨瑜伽师地。经中数说正修瑜伽师地。月灯经中。亦说修习瑜伽师地。如是非一。如前广说。或作论者。先总受请。论体五分。尽在心中。欲为学徒分别解说。自假兴问。为起说因。故问云何瑜伽师地。若不尔者。先无略说。无容欻问此地云何。又发问者。略有五种。一不解故问。二疑惑故问。三试验故问。四轻触故问。五为欲利乐有情故问。今是第五。专为利乐诸有情类。造斯论。故谓十七地者。总集所说瑜伽师地。略有十七。若广安立。地位无边。一一地中。分位差别。义无边故。如是一转。总问总答

论曰。何等十七。嗢拖南曰

  五识相应意　　有寻伺等三
  三摩地俱非　　有心无心地
  闻思修所立　　如是具三乘
  有依及无依　　是名十七地

释曰。何缘更问何等十七。虽闻总数。未了别名。故复为问。嗢拖南者。先略颂答。略集地名。施诸学者。名嗢拖南。五识相应者。谓五识身相应地。意谓意地。有寻伺等三者。谓有寻有伺等三地。三摩地俱者。谓三摩地。俱名三摩呬多地。非者。谓非三摩地。俱名非三摩呬多地。此就一相。且别地名非尽理说。如是二名。互宽狭故。三摩地名。通定不定。唯在有心。三摩呬多。通有心位。及无心位。唯局在定。如后广说。如是具三乘者。谓由如是闻等地故。或由如是上诸地故。得具三乘。及有余依。无余依地。一一别名。如后广释

论曰。一者五识身相应地。二者意地。三者有寻有伺地。四者无寻唯伺地。五者无寻无伺地。六者三摩呬多地。七者非三摩呬多地。八者有心地。九者无心地。十者闻所成地。十一者思所成地。十二者修所成地。十三者声闻地。十四者独觉地。十五者菩萨地。十六者有余依地。十七者无余依地。如是略说十七。名为瑜伽师地

释曰。次广列名。重答前问。言五识身相应地者。谓眼等根。是眼等识。不共所依。眼等不为余识依故。又是亲依。眼等利钝。识明昧故。又同时依。必俱有故。非如意等。由是五识用眼等根。标别其名。犹如麦芽。如鼓声等。故名五识。由所依根有形碍故。又必不离所依身。故犹如身受。故名为身。又复身者。依义体义如六识身六思身等依五识身。建立此地。故名相应如律中说。王相应论。贼相应论。谓依王贼而兴言论。此亦如是。虽此地中分别多法。五识为主。是故偏说。又五识身相应心品。总名相应。于此地中。虽明多法。以心心所胜故别说。又相应者。是摄属义。谓此地中。说五识身所摄属法。即是自性所依所缘。助伴作业。故名相应。地如前说。自后诸地识身相应。随其所应。亦有通者。略故不说

言意地者。六七八识。同依意根。略去识身相应三语。故但言意。又实义门。虽有八识。然随机门。但有六识。六七八识。同第六摄。就所依名。故但言意。所依非色。或离于身。犹如心受。故不言身。相应准前。故略不说。又六七八。虽皆同有心意识义。心法意处识蕴摄故。然意义等。故但言意。皆是思量意根摄故。第八持种。心义偏强。第六普遍了别境界。识义偏强。是故不说心地识地。身及相应。略故不说。地义如前

何缘五识合立一地。说在最初。余识立一。说在第二。五识同无当说分别所缘等业。所说事少故合立一。说在最初。意地翻此。故别立一。说在第二。又以五识同依色根。同缘色境。故合立一。余依无色所缘不定。故别立一。自性依缘粗细次第。故说先后。又以五识同现量摄。故合立一。说在最初。余识不定。或现或比。或非量摄。故别立一。说在第二。如是二地。自性依缘。助伴作业。合为体故。摄一切法。应知此中。以一切法不离识故。依识起故。识为体故。识最胜故。先依八识。建立二地。如是八识。自性依缘。助伴业等。后当广说

有寻有伺等三地者。寻谓寻求。伺谓伺察。或思或慧。于境推求。粗位名寻。即此二种。于境审察。细位名伺。非一刹那二法相应。一类粗细前后异故。今依此二。建立三地有义。此三就二前后相应建立。谓欲界地。及初静虑。粗心心所。前后相续。可有寻伺共相应故。名有寻有伺地。静虑中间。粗心心所。前后相续。定无有寻。唯可与伺共相应故。名无寻唯伺地。第二静虑。已上诸地。诸心心所。前后相续。决定不与寻伺相应。名无寻无伺地。若欲界地。及初静虑。静虑中间。细心心所。不与寻伺共相应者。及一切色不相应行。诸无为法不与寻伺共相应故。亦皆说名无寻无伺地。故后论言。有寻有伺地。无寻唯伺地。一向是有心地。无心睡眠。无心闷绝。无想定。无想生。灭尽定。及无余依涅槃界。名无心地有义。此三就二离欲分位建立。谓欲界地及初静虑。诸法假者。于寻及伺。并未离欲。名有寻有伺地。静虑中间。诸法假者。寻已离欲。伺未离欲。名无寻唯伺地。第二静虑。已上诸地。诸法假者。于寻及伺。并已离欲。名无寻无伺地。若在下地。并已离欲。亦得说名无寻无伺。故后论言。此中由离寻伺欲故。说名无寻无伺地。不由不现行故。所以者何。未离欲界欲者。由教导作意差别故。于一时间。亦有无寻无伺意现行。已离寻伺欲者。亦有寻伺现行。如出彼定及生彼地。如实义者。此三但就界地建立。谓欲界地及初静虑。有漏无漏诸法。于中寻伺俱可得故。名第一地。静虑中间有漏无漏诸法。于中无寻唯有伺故。名第二地。第二静虑。已上诸地。有漏无漏诸法。于中寻伺俱无有故。名第三地。故后论言。此中欲界及初静虑。若定若生。名有寻有伺地。静虑中间若定若生。名无寻唯伺地。第二静虑已上。色界无色界。全名无寻无伺地。无漏有为初静虑定。亦名有寻有伺地。依寻伺处。法缘真如为境。入此定故。不由分别现行故。余如前说。若就相应。及就离欲。建立三地。摄法不尽。亦大杂乱。虽言有寻有伺等地。唯是有心。此就一门。粗辨地相。于此门中。唯说第二静虑。已上无寻无伺地中。无想定。无想生灭尽定。名无心地。余一切位。名有心地。后有四门。复异建立。如后当说。虽言此中由离寻伺欲故。说名无寻无伺地。然唯说彼第二静虑已上诸地。必定已离寻伺地欲。不言已离寻伺欲者。下地诸法。亦得说名无寻无伺。若如是者。未离下地寻伺欲者。上地诸法。亦应说名有寻伺等。如是建立。成大杂乱。是故此三。唯就界地上下建立

所言三摩呬多地者。谓胜定地。离沉掉等。平等能引。或引平等。或是平等。所引发故。名等引地有义。此名唯摄一切有心诸定。皆能平等引功德故。不通无心。以前颂中言三摩地俱故。三摩地者。是别境中。心数法故。二无心定。不能等引诸功德故。非等引地。若尔何故。等引地说。此等引地。略有四种。谓静虑。解脱。等持。等至。言静虑者。谓四静虑。言解脱者。谓八解脱。言等持者。谓空等持。无愿等持。无相等持。言等至者。谓五现见等至。八胜处等至。十遍处等至。四无色等至。无想等至。灭尽等至。此无有失。二无心定。是等引果。故与其名。实非等引有义。此名通有心位。及无心位。所有定体。若有心定。平等能引诸功德故。亦引平等根大等故。及离沉掉。戒无悔等。平等方便。所引发故。名为等引。若无心定。虽不能引殊胜功德。而引平等根大等故。是平等定所引发故。亦名等引。若尔何故。前颂中言三摩地俱。此无有失。颂中文略且言彼俱。其实等引非俱。亦是后说等引通无心故。如实义者。等引地名有通有局。有心无心。两位俱摄。故名为通。后说无想灭尽定。亦是等引地体故。唯在有漏无漏胜定。非欲界等一切散心。故名为局。以后说言唯静虑等。名等引地。非于欲界。心一境性。由此等引。无悔欢喜安乐所引。欲界不尔。准此上界。若在散心。亦非等引。同欲界故。由此相对。得作四句。或等持俱。非等引地。谓欲界等。散心位中。三摩地俱。心心所等。或等引地。非等持俱。谓定位中。三摩地体。及无想定。灭尽定位。所有诸法。或等持俱。亦等引地。谓诸静虑。及诸无色有心定位。心心所等。除三摩地。或有俱非。谓除上位所有诸法。又三摩地。三摩钵底。三摩呬多。名有宽狭。三摩地名目心数中等持。一法通摄一切。有心位中。心一境性。通定散位。然诸经论。就胜但说空无愿等。名三摩地。三摩钵底。通目一切有心无心。诸定位中。所有定体。诸经论中。就胜唯说五现见等相应诸定。名为等至。等引地名。通目一切有心无心。定位功德。故此地中。通摄一切定位功德。由是总故。偏目地名言非三摩呬哆地者。翻上易了。无烦广释。如是二地。总摄一切定非定位所有诸法

所言有心无心地者。略就五门。建立差别。一就地总说门。谓五识身相应地意地。有寻有伺地。无寻唯伺地。此四一向是有心地。无寻无伺地中除无想定。并无想生。及灭尽定。所余一向是有心地。若无想定。并无想生。及灭尽定。是无心地。于此门中。无心睡眠。无心闷绝。亦名有心。有七八故。唯无想定等。心不相应。行与心相违。名无心地。二心乱不乱门。谓四倒等。所倒乱心。名无心地。失本性故。三心生不生门。谓若缘具。此心得生。名有心地。若缘不具。彼心不生。名无心地。于此门中。随此心生。名有心地。彼心不生。名无心地。四分位建立门。谓除六位。名有心地。若无心睡眠位。无心闷绝位。无想定位。无想生位。灭尽定位。及无余依涅槃界位。名无心地。五就真实义门。谓唯无余依涅槃界中。诸心皆灭。名无心地。余位由无诸转识故。假名无心。由第八识未灭尽故。名有心地。如是二地。诸门差别。进退不定

闻所成地者。谓从闻所生解文义。慧及慧相应。心心所等。思所成地者。谓从思所生解法相。慧及慧相应。心心所等修所成地者。谓从修所生解理事。慧及慧相应。心心所等闻谓听闻。即是耳根发生耳识。闻言教故。思谓思虑。即是思数发生智慧。思择法故。修谓修习。即是胜定。发生智慧。修对治故。从此三种。发生三慧及相应法。等名三地体。三慧广义。如后分别。如是三地。用三慧品。心心所等。及所得果。以为自性。故后论言。修所成地。亦是有余无余依地

声闻地者。谓佛圣教。声为上首。从师友所。闻此教声。展转修证。永出世间。小行小果。故名声闻。如是声闻种性。发心修行得果。一切总说为声闻地

独觉地者。常乐寂静。不欲杂居。修加行满。无师友教。自然独悟。永出世间。中行中果。故名独觉。或观待缘。而悟圣果。亦名缘觉。如是独觉种性。发心修行得果。一切总说为独觉地。菩萨地者。希求大觉。悲愍有情。或求菩提。志愿坚猛。长时修证。永出世间。大行大果。故名菩萨。如是菩萨种性。发心修行得果。一切总说为菩萨地。三乘大义。后当广辨。有余依地者。谓有余依涅槃地也。依者即是有漏所依。略有八种。一施设依。谓五取蕴。由依此故。施设假者。名种性等。二摄受依。谓七摄事。即自父母。妻子。奴婢。作使。僮仆。朋友。眷属。三住持依。谓四种食。四流转依。谓四识住十二缘起五障碍依。谓诸天魔。六苦恼依谓诸欲界。七适悦依。谓诸定乐。八后边依。谓阿罗汉。相续诸蕴。今全取一最后边依。除六摄事。流转。障碍。取余一分。又此地中。有四寂静。一苦寂静。谓当来苦。毕竟不。生二惑寂静。谓诸烦恼。毕竟不生。三业寂静。谓不造恶。修习诸善。四舍寂静。谓六恒住于六根门。不喜不忧。安住上舍。正念正知。阿罗汉等。住无学地。具四寂静。有少余依。是故说名有余依地。此地即是二乘。无学身中。有漏无漏诸法。总为自性如来。虽无真实身心有漏余依。而有变化似有漏依。故就化相。亦得说名有余依地。无余依地者。谓无余依涅槃地也。一切有漏余依皆舍。二乘有为无漏亦舍。如来虽有有为无漏。而无一切有漏余依故。亦说名无余依地。于此地中。唯有清净真如所显甚深功德。离诸分别。绝诸戏论。不可说为蕴界处等。及人天等。若即若离。若有若无。所有名相。皆是假说有义。此地正用究竟择灭真如无为为性。兼以如来有为无漏功德为性。如来功德。甚深离相。不可说故。不言亦摄五识地等。理实亦摄有义。如来有为功德。有余依摄。无为功德。无余依摄。故后论言。无余依地。五地一分。谓无心地。修所成地。声闻。独觉。及菩萨地

瑜伽师地论释一卷


掌中论

    No. 1621

掌中论一卷

        陈那菩萨造

        三藏法师义净奉　制译

论曰。谓于三界但有假名。实无外境。由妄执故。今欲为彼未证真者。决择诸法自性之门。令无倒解故造斯论。颂曰

  于绳作蛇解　　见绳知境无
  若了彼分时　　知如蛇解谬

论曰。如于非远不分明处唯见绳蛇相似之事。未能了彼差别自性。被惑乱故。定执为蛇。后时了彼差别法已。知由妄执诳乱生故。但是错解无有实事。复于绳处支分差别。善观察时。绳之自体。亦不可得。如是知已。所有绳解。犹如蛇觉。唯有妄识。如于绳处有惑乱识。亦于彼分毫厘等处。知相假藉。无实可得。是故缘绳及分等心。所有相状。但唯妄识。颂曰

  诸有假设事　　详观自性时
  从他皆假名　　乃至世俗境

论曰。如于绳等支分之处。别别分析。审观察时。知无实体。唯是妄心。如是应知。一切诸法。但是假名。如瓶衣等物。藉埿缕等成。乃至言说识所行境未至破坏。名为瓶等。言从他者。谓从世俗言说而有。非于胜义。颂曰

  无分非见故　　至极同非有
  但由惑乱心　　智者不应执

论曰。若复执云。诸有假事。至极微位不可分析。复无方分是实有者。此即犹如空花。及兔角等。不可见故。无力能生缘彼识故。所执极微。定非实有。所以须说不可见因。由彼不能安立极微。成实有故。所以者何。由有方分事差别故。犹如现见有瓶衣等物。东西北等。方分别故。斯皆现有。支分可得。若言极微是现有者。必有方分。别异性故。是则应许东西北等。支分别故。此实极微理不成就。亦非一体。多分成故。见事别故。一实极微定不可得。如是应舍极微之论。是故智者了知三界咸是妄情。欲求妙理不应执实。颂曰

  妄有非实故　　与所见不同
  由境相虚妄　　能缘亦非有

论曰。若言我亦于彼瓶衣等事。许彼自性是不可得。皆是妄识之所分别。然而缘彼相状乱识是其实有。观健达婆城。及幻人等。其识是有。设有此识。亦非实故。与所见事不相应故。此惑乱识。于所缘境。作有性解。彼事自性已明非有。境既是无。能缘妄识亦非实有。云何令彼妄识有耶。然于世间不曾见有无能生种子有所生芽等。由斯汝说幻城等喻道理不成。颂曰

  斯皆是假设　　善觉者能知
  智人断烦恼　　易若除蛇怖

论曰。如说三界但有假名。瓶等粗觉既除遣已。知从名言而有其事。善观察者。能了知已。即于绳处蛇怖除遣。复审思惟了彼差别于绳等处妄执亦无。如是观时。一切能生离染之法。易速蠲除烦恼罗网。及诸业果自当断灭。有别颂曰

  智人观俗事　　当随俗所行
  欲求烦恼断　　要明真胜义

犹如世人于诸俗事瓶衣等处。以为实有名瓶衣等。智者亦尔。当顺世间而兴言说。知非实有。若乐观察烦恼过失。求解脱者。宜于如是真胜义中。周遍推寻。如理作意。于诸境处。及能缘妄。识烦恼系缚。不复生长

掌中论一卷


中边分别论

    No. 1599 [No. 1600; cf. No. 1601]

中边分别论卷上

        天亲菩萨造

        陈天竺三藏真谛译

    相品第一

  恭敬善行子　　能造此正论
  为我等宣说　　今当显此义

初立论体

  相障及真实　　研习对治道
  修住而得果　　无上乘唯尔

此七义是论所说。何者为七。一相二障三真实四研习对治五修住六得果七无上乘。今依相说此偈言

  虚妄分别有　　彼处无有二
  彼中唯有空　　于此亦有彼

此中虚妄分别者。谓分别能执所执。有者。但有分别。彼处者。谓虚妄分别。无有二者。谓能执所执此二永无。彼中者。谓分别中。唯有空者。谓但此分别离能执所执故。唯有空于此者。谓能所空中。亦有彼者。谓有虚妄分别。若法是处无。由此法故是处空。其所余者则名为有。若如是知即于空相智无颠倒。次说偈言

  故说一切法　　非空非不空
  有无及有故　　是名中道义

一切法者。谓有为名虚妄分别。无为名空。非空者。谓由空由虚妄分别。非不空者。谓由能执所执故。有者。谓虚妄分别有故。无者。谓能所执无故。及有者。谓于虚妄中有真空故。于真空中亦有虚妄分别故。是名中道义者。谓一切法非一向空。亦非一向不空。如是等文不违般若波罗蜜等。如经说一切法非空非不空。如是已说虚妄分别有相无相竟。今当次说其自体相。故说偈言

  尘根我及识　　本识生似彼
  但识有无彼　　彼无故识无

似尘者。谓本识显现相似色等。似根者。谓识似五根于自他相续中显现。似我者。谓意识与我见无明等相应故。似识者。谓六种识。本识者。谓阿黎耶识。生似彼者。谓似尘等四物。但识有者。谓但有乱识。无彼者。谓无四物。何以故。似尘似根非实形识故。似我似识显现不如境故。彼无故识无者。谓尘既是无识亦是无。是识所取四种境界。谓尘根我及识所摄实无体相。所取既无能取乱识亦复是无。如是说体相已。今当显名义。故说偈言

  乱识虚妄性　　由此义得成
  非实有无故　　灭彼故解脱

乱识虚妄性由此义得成者。谓一切世间但唯乱识。此乱识云何名虚妄。由境不实故。由体散乱故。非实有者。谓显现似四物。四物永无故。非实无故者。谓非一切永无。由乱识生故。云何不许乱识永无。故偈言灭彼故解脱。若执永无系缚解脱皆不成就。则起邪见拨净不净品。如是说虚妄体相已。今当次说虚妄摄相。若言唯是虚妄。云何能摄三性。故说偈言

  分别及依他　　真实唯三性
  由尘与乱识　　及二无故说

分别性者。谓是六尘永不可得。犹如空华依他性者。谓唯乱识有非实故。犹如幻物。真实性者。谓能取所取二无所有。真实有无故。犹如虚空。说虚妄摄相已。今当说入虚妄无所有方便相。故说偈言

  由依唯识故　　境无体义成
  以尘无有体　　本识即不生

一切三界但唯有识。依如此义外尘体相决无所有。此智得成。由所缘境无有体故。能缘唯识亦不得生。以是方便即得入于能取所取无所有相

  是故识成就　　非识为自性

所识诸尘既无有体。是故识性无理得成

  不识及与识(疏本云应知识不识)　　由是义平等

不识者。由自性不成就。是故非识。此法真实无所有性。而能显现似非实尘。故说为识。说入虚妄无所有方便相已。今当显虚妄总相。故说偈言

  虚妄总类者　　三界心心法(不识者疏本无不字)

虚妄者。若约界立。谓欲色无色界。若约生立。谓心及心法是总类相。说总相已。别相今当说

  唯尘智名心　　差别名心法

心者但了别尘通相。若了尘别相说名为心法。谓受想行等。说总别相已。次显生起相

  第一名缘识　　第二是用识
  于尘受分别　　引行谓心法

缘识者。谓阿黎耶识。余识生缘故。用识者。谓因黎耶识于尘中起名为用识。于尘受者。谓领尘苦等说名受阴。分别者谓选择尘差别是名想阴。引行者。能令心舍此取彼。谓欲思惟及作意等名为行阴。如是受等名为心法。说生起相已。当说虚妄染污相。故说偈言

  覆藏及安立　　将导与摄持
  圆满三分成　　领触并牵引
  执着及现前　　苦故恼世间
  三种二种难　　亦七由虚妄

覆藏者。由无明能障如实见故。安立者。由诸行能安立业熏习于本识中故。将导者。由本识及意识能令众生往受生处故。摄持者。谓由色能摄持自体五聚故。圆满者。谓由六入能生长故。三分成者。依根尘识诸触成故。领触者。由乐苦等为损益故。牵引者。由贪爱令业能牵后生故。执著者。由四取能令诸识染着欲等四处随从得生故。现前者。由业有谓已作诸业趣向来生为与果报故。苦者。由生老死故。恼世间者。谓三界由无明乃至老死等所逼恼。恒受苦难故。三种二种难亦七由虚妄者。三种难者。谓烦恼业生等。烦恼难者。谓无明贪爱取。业难者。谓行及有。生难者。谓所余七分。二种难者。所谓因果。因难者。谓烦恼业分。果难者。谓所余分。七难者。谓七种因。一颠倒因。谓无明。二牵引因。谓诸行。三将因。谓本意二识。四摄因。谓名色六入。五受用因。谓触受。六引出因。谓爱取有。七厌怖因。谓生老死。由虚妄者。如是苦难从虚妄生。集虚妄义有九种相。所谓有相无相自相摄相入无相方便相差别相众名相生缘相染相。义现于前

说虚妄已。当说方便为显空义。由此相应故。说偈言

  体相及众名　　其义与分别
  成立理应知　　略解空如是

云何应知空相。偈言

  无二有此无　　是二名空相
  故非有非无　　不异亦不一

无二者。谓无所取能取。有此无者。谓但有所取能取无。是二名空相者。谓无及有无是名空相。此显真空无有二相。是法以二无为性。不可说有不可说无。云何非有。是二无故。云何非无。是二无有故。故偈言非有非无。是名真空相。不异亦不一者。与虚妄分别不异相亦不一相。若异者。谓法性与法异。是义不然。譬如五阴与无常性及苦性。若一者。清净境界智及通相不成就。如是道理显现空与虚妄离一异相。是故说不有非不有非一非异相

云何众名。应知

  如如及实际　　无相与真实
  法界法身等　　略说空众名

云何众名义。应知

  非变异不到　　相灭圣境界
  圣法因及依　　是众名义次

无异为义故。是故名如如。恒如是不舍故。无颠倒为义故。说实际。非颠倒种类及境界故。相灭为义故。说无相。离一切相故。无分别。圣智境界故。第一义智为体故。说真实。圣法因为义故。是故说法界。圣法依此境生。此中因义是界义。摄持法身为义故说法身。如是空众名义已显。云何空分别。应知

  亦染亦清净　　如是空分别

何处位空不净。何处位空净

有垢亦无垢

若在此位中是诸垢法。未得出离与共相应是位处说不净。若在此位出离诸垢。此位处说净。若已与垢相应后时无垢。不离变异法故。云何不无常。为此问故答

  水界金空静　　法界净如是

客尘故离灭故不是自性变异故。复有分别。此空有十六。一内空。二外空。三内外空。四大空。五空空。六第一义空。七有为空。八无为空。九毕竟空。十无前后空。十一不舍空。十二性空。十三相空。十四一切法空。十五非有空。十六非有性空。如是略说空。应知

  食者所食空　　身及依处空
  能见及如理　　所求至得空

此中能食空者。依内根故说。所食空者。依外尘故说。身者是能食。所食者依处。是重空故说内外空。大空者。世器遍满故故说名大。此空说大空。内入身及世器。此法是空。无分别智能见此空。此无分别智空故名空空。如道理依第一义相观此法空。是名第一义空。为得此菩萨修行空。是此法空为何修行。为至得二善。一有为善。二无为善。此空是名有为无为空。为常利益他。为一向恒利益他故。修此空故说毕竟空。为不舍生死。此生死无前后。诸众生不见其空。疲厌故舍离生死。此空是名无前后空。为善无穷尽诸佛入无余涅槃。因此空不舍他利益事。是名不舍空。为清净界性性义者种类义自然得故。故立名性。此空名性空。为得大相好。是大人相及小相。为得此二相修行此空。是名相空。为清净佛法故。菩萨行彼十力四无畏等诸佛不共法。为清净令出菩萨修此空。是名一切法空。如是十四种空已安立。应知分别此相。是十四中何法名空

  人法二皆无　　此中名为空
  彼无非是无　　此中有别空

人法二无有是法名空。是无有法决定有亦空。如上说。能食等十四处。此二法是名空。为显空真实相故。是故最后安立二空。一非有空。二非有性空。立二空何所为。为离人法增益。为离人法空毁谤。如次第如是空分别应知。云何空成立义。应知

  若言不净者　　众生无解脱
  若言无垢者　　功用无所施

若诸法空对治未起时。为客尘不染故自然清净。烦恼障无故。不因功力一切众生应得解脱。若对治已起自性故不净。为得解脱修道功用无果报故。作如是果。故说

  不染非不染　　非净非不净
  心本清净故　　烦恼客尘故

云何不染非不染。心本自性清净故。云何非净非不净。烦恼客尘故。如是空分别略说已。安立空众义者。应知有二种。一为体相。二为安立。何者为体相。为有相故。无有相故。是有相者。离有离无相。离一离异相。安立者。众名等四义。应知分别。中边论相品为解释偈已究竟

    障品第二

  遍及一方重　　平等及取舍
  今说二种障

此中遍障者。烦恼障及一切智障。为菩萨种性诸人二障圆满故。一方障者。烦恼障。为声闻性等诸人。重障者。是前诸人欲等诸行中随一粗烦恼。平等障者。平等诸行中随行中随一生死。取舍障者。菩萨性诸人为障无住处涅槃故。如理相应。二种人障已说。一菩萨性人。二声闻等性人。复有烦恼相九种

  九结名惑障

九种诸惑结此中说烦恼障。此诸烦恼障为障谁

  厌离及除舍　　实见

爱欲结者障厌离心心坚碍障者。障除舍心。因此惑违逆。碍境界中不能生舍除心。诸余结者覆障真实见。云何起障是诸烦恼次第

  及身见
  身见所依法　　灭道三宝障
  利养恭敬等　　轻财知止足

是诸余烦恼是此五处障。我慢障者。欲灭离身见时障对正观智有异品无异品。无异品我慢数行故。此身见不得灭。无明结者。欲远离身见依处时为真实见障。因此不得远离取阴故。见结者。欲通达灭谛时为作障。身见及边见于灭谛生怖畏故。邪见于灭谛起诽谤故。取结者。是通达道谛时为作障。依别道理思择求得清净故。疑结者。欲通达三宝时为作障。不信受三宝功德故。嫉妒结者。欲远离利养恭敬时为作障。不见此过失故。悭吝结者。欲行轻财知足时为作障。令贪着财物等故

善法障复十复有别障十种善法等处应知。何者为十处

  不行非处所　　所行不如理
  不生不思量　　资粮不具足
  性友不相称　　心疲故厌离
  修行不相称　　恶怨人共住
  粗惑三随一　　般若不成就
  自性重烦恼　　懈怠与放逸
  著有及欲尘　　下劣心亦尔
  不信无愿乐　　如言思量义
  不敬法重利　　于众生无悲
  闻灾及少闻　　三昧资粮减

如是诸障何者为善法

  善菩提摄取　　有智无迷障
  回向不怖嫉　　自在善等十

如是善等诸法中。何者被障。何者为障。应知答

  此十各三障　　十事中应知

善法有三障。一者不修行。二非处修行。三修行不如理

菩提有三种障。一者不生善。二不生正思量。三资粮不圆满

摄取菩提者。发菩提心是名摄取菩提。此心有三种。一与性不相应行。二朋友不相应。三心疲极厌离。有智者。是菩萨体性。为知此法有三障。一修行不相称。二恶友人共住。三与恶怨人共住。此中恶人者。愚痴凡人。恶怨人者。碍菩萨功德观菩萨过失。无迷者。心不散乱有三障。一颠倒粗失。二烦恼等。三障中随一有余三令成熟。解脱般若未熟未满。无障者。灭离诸障是名无障。此有三障。一自性粗惑。二懈怠。三放逸。菩提回向有三障。令心回向余处不得一向回向无上菩提。一贪着诸有。二贪著有资粮法。三下劣品心。无怖畏有三障。一于人不生信重心。二于正法中不生愿欲。三如名字言语思量诸义。乐嫉妒者有三障一不尊重正法。二尊重利养恭敬。三于众生中不起大悲心。不自在者有三障。因此三不得自在。一无闻慧无闻者生起业惑正法灾故。二闻慧少弱。三者三昧事不成熟。还复是此障善等诸法中十种随一分作因。依此义故应知障中何者为十因。第一生因。譬如眼入为眼识作生因。二住因。譬如四种食为一切众生。三持因。如所持能摄持。譬器世界为众生生世界。四明了因。如光明为色。五变异因。如火等为成熟等诸事。六相离因。如镰等为刈等。七回转因。如金银师为回转诸金银令成镮钏。八必比因。譬如烟为火等必比知。九令信因。譬如立证因分为所立义。十至得因。如道等为涅槃等诸果作因。如是生障善处应知。此应令生故。住障者。菩提处此不应坏动故。持障者。菩提摄取处。菩提心能持故。明了障者。有智处。此应显了故。变异障者。无迷处。迷转灭故有变异。相离障者。无障处。此障相离为体故。回转障者。回向处。菩提心回向为体相故。必比障者。无怖畏处。为不信故怖畏。令信障者无嫉妒处。于法不嫉妒令人信故。至得障者。自在处。无所系属至得为体相故

  助道十度地　　复有余别障

助道品法处者

  处不明懈怠　　三昧少二种
  不种及羸弱　　诸见粗恶过

念处者依处不明了为障。四正勤处懈怠。四如意足处禅定少。二种为不圆满。欲精进心思量四种。随一不具足。为修习不具足成。资粮八法随一不具故。五根处不下解脱分善法种子故。力处是五根羸弱与非助道相杂起故。觉分处诸见过失见道所显故。道分处粗恶过失。此修道所显现故。波罗蜜障者

  富贵及善道　　不舍众生障
  增减功德失　　令诸众生入
  解脱无尽量　　令善无有间
  所作常决定　　同用令他熟

此十种波罗蜜能生此法。此法是波罗蜜果。为障波罗蜜果故。是故显说障波罗蜜。檀波罗蜜者何法为障。自在增上障。尸罗波罗蜜者。障善道为障。羼提波罗蜜障不舍离众生。毗梨耶波罗蜜障。增益功德损减过失。禅波罗蜜者。障受化众生令入正位(四十心正位)。般若波罗蜜者。障令他解脱沤和拘舍罗波罗蜜障。檀等波罗蜜无尽无减。为回向菩提故。诸波罗蜜无尽无减。波抳陀那波罗蜜者。障一切生处善法中无间生起。依愿力故。能摄持随从善法。生处波罗波罗蜜者障善法决定事。思择修习力弱故。不能折伏非助道故。阇那波罗蜜者障自身及他同用法乐。及成熟两处不如闻言通达义故。于十种地中复有次第障

  遍满最胜义　　胜流第一义
  无所系属义　　身无差别义
  无染清净义　　法门无异义
  不减不增义　　四自在依义
  此法界无明　　此染是十障
  非十地扶助　　诸地是对治

法界中十种义。遍一切处等无染浊无明。此无明十种菩萨地中次第应知。是障非地。助道故。法界中何者为十种义。一者遍满义。依菩萨初地。法界义遍满一切处。菩萨入观得通达。因此通达得见自他平等一分。二者最胜义。依第二地观此法已。作是思惟。若依他共平等出离。一切种治净出离应化勤行。三者胜流义。因三地法界传流知所闻正法。第一为得此法。广量三千大千世界火坑能自掷其中。四无所系属义。因此四地因此观法爱一向不生。五身无差别义因第五地十种心乐清净平等。六无染清净义。因第六地十二生因处。无有一法可染可净。如此通达故。七法门无异义。因第七地无相故。修多罗等法别异相不行不显故。八不减不增义。因八地得满足无生法忍故。若不净净品中不见一法有减有增故

此中复有四种自在。何者为四。一无分别自在。二净土自在。三智自在。四业自在。此中法界是第一第二自在依处。八地中通达智自在依义。因九地得四无碍辩故。业自在依义。因十地如意欲变化。作众生利益事。复有略说

  已说烦恼障　　及一切智障
  是摄一切障　　尽彼得解脱

此二种障灭尽无余故。得出离解脱一切障。障总义者。一大障是遍满故。二小障者一方障故。三修行障者重惑。四至得障平等烦恼。五至得胜负障取舍障。六正行障者是九种烦恼结。七因障善等处由十种因义故。八入真实障者是助道障。九无上善障者十波罗蜜障。十胜负舍离障。十地障摄集障略说有二种。一解脱障。二一切智障。中边分别论障品第二竟

    真实品第三

此品真实应说。何者真实

  根本相真实　　无颠倒真实
  果因俱真实　　细粗等真实
  成就清净境　　摄取分破实
  胜智实十种　　为对治我见

如是十种真实。何者为十。一根本真实。二相真实。三无颠倒真实。四果因真实。五细粗真实。六成就真实。七清净境界真实。八摄取真实。九分破真实十胜智真实。胜智又十种真实。为对治十种我执应知。何者为十。一阴胜智。二界胜智。三入胜智。四生缘胜智。五处非处胜智。六根胜智。七世胜智。八谛胜智。九乘胜智。十有为无为胜智

此中何者根本真实。三种自性。一分别自性。二依他自性。三真实自性。一切余真实此中所立故。三性中何法名真实可信受

  性三一恒无　　二有不真实
  三有无真实　　此三本真实

分别性相者。恒常不有。此相分别性中是真实无颠倒故。依他性相者。有不实。唯有散乱执起故。此相依他性中是真实性。真实性相者有无真实。此相真实性中是真实。何者相真实

  增益损减谤　　于法于人中
  所取及能取　　有无中诸见
  知常见不生　　是真实寂相

人等及法等。有增益谤见。有损减谤见不得起。为知见此法故。此法分别性中是真实相。能执所执增益损减谤见不得起。为知见此法故。此法依他性中是真实相。有中无中增益损减见不得起。为知见此法故。此法真实性中是真实相。如是根本真实相。说名相真实无颠倒真实。无颠倒真实者。为对治常等颠倒故。有四种。一无常二苦三空四无我。此四云何。根本真实所立。此中无常云何。应知

  无常义有三　　无义生灭义
  有垢无垢义　　本实中次第

根本真实中有三种性。此性中次第应知三种无常义。一无有物为义故说无常。二生灭为义。三有垢无垢为义

  苦三一取苦　　二相三相应

根中真实中次第三种苦。一取苦。人法执着所取故。相苦者。三受三苦为相故。相应苦者。与有为相应故。为有为法通相故。此三苦于次第性中应立

  无空不如空　　性空合三种

分别性者。无别道理。令有无有物是其空。依他性相者。无有如所分别。不一向无此法。不如有是空。真实性相者。二空自性。是故说名自性空

  无相及异相　　自相三无我

分别性者相体无有。是故此无相是其无我。依他性者有相不如所分别。不如相者是其无我。真实性者是二无我。是故自体是其无我。如是三种根本真实中。显说

有三种无常。一无物无常。二生灭无常。三有垢无垢无常

三种苦。一取苦。二相苦。三相应苦。三种空。一无有空。二不如空。三自性空。三种无我。一无相无我。二异相无我。三自性无我。果因真实。此根本真实中应立何者果因。苦谛集谛灭谛道谛。云何根本真实得立

苦相等已说。苦谛如前说。无倒真实中如三苦三无常等。因此四无倒应知苦谛。三种集谛应知。何者为三

  集谛复有三　　熏习与发起
  及不相离等

熏习集谛者。执着分别性。熏习发起集谛者。烦恼及业。不相离集谛者。如如与惑障不相离。三种灭义故应知灭谛。何者为三

  体灭二种灭　　垢净前后灭

自性无生能执所执二法不生。垢寂灭二种。一数缘灭二法如如。是三种灭。一无体灭。二二灭。三自性灭。道谛有三。于三根本真实中云何得安立

  观智及除灭　　证至道有三

说道谛如是。一者观察分别性。二为观察除灭依他性。三为观察证至真实性。如是此中为观察为除灭为证至故。安立道谛应知。粗细真实者。俗谛及真谛。此二谛根本真实中云何得立

  粗义有三种　　立名及取行
  显了名俗谛

俗谛有三种。一立名俗谛。二取行俗谛。三显了俗谛。因此三义根本真实中。应安立三种俗谛。次第应知

  真谛三中一

胜境谛者。一真实性中应知此胜境。云何真实

  一义二正修　　三至得真实

义真实者。法如如真实智境界故。至得真实者。涅槃功德究竟故。正行真实者。圣道无胜境故。云何有为无为法。共得真实性所摄。答

  无变异无倒　　成就二真实

无为法者。无变异成就。得入真实性摄一切有为法。道所摄无颠倒成就故。境界品类中无颠倒故。成就真实者。于根本真实中云何

  安立成就者　　一处世俗成

分别性中得立是物处。共立印定数习故。因此所立印定起世智。一切世间人一处同一世智。如此物是地非火。此物是色非声。如是等此俗成就属一性

  离名无体故　　三处道理成

即三性。上品诸人于义于理中聪明。在于觉观地中。依三量四道理中依一道理。若物若事得成就。此二名道理成就。清净境真实有二种。一清净烦恼障智境。二清净智障智境。如是清净智境真实

  清净境二种　　摄在于一处

一处者真实性。云何如此。无别性作清净智境故。三种根本真实性中。五摄真实云何安立

  相及于分别　　名字二性摄

如义相应依。五种摄。品类根本性中云何得立相。及分别依他性中摄。名者分别性中摄

  圣智与如如　　此二一性摄

如如及圣智。依真实性中摄。三种根本性中分破真实云何得立。分破真实有七种。何者为七

  生实二性摄　　处邪行亦尔
  相识及清净　　正行真性摄

一者生起真实。二相真实。三识真实。四依处真实。五邪行真实。六清净真实。七正行真实。此中生起真实者。于根本真实中在二处。应知分别依他性处。如生起真实依处。及邪行真实亦如是。根本性中二性摄。相识清净正行四法一真实性摄。此四种云何一性摄。圣境圣智所显故。胜智真实者。为对治十种我见故说。何者阴等处十种我见

  一因及食者　　作者及自在
  增上义及常　　垢染清净依
  观者及缚解　　此处生我见

如是十种我邪执。于阴等诸法中起。为对治十种邪执故说十种胜智。何者十种我邪执。一者一执。二因执。三者受者执。四作者执。五自在执。六增上执。七常住执。八染者净者执。九观者执。十缚解作者执。云何十种胜智根本真实中得立。三种性中五阴等诸法。如义道理被摄故。云何得在三性中

  分别种类色　　法然色等三

色阴有三种。一分别色。色处分别性。二种类色。色处依他性种类。云何名依他。此立五法中体性不同故。立别种类名色。三法然色。色处真实性色通相故。如色受等诸阴亦如是。及界入诸法如是。三性中应等被摄故。十种胜智真实根本真实中应知如是。已说为对治十种我见五阴等胜智。五阴等义未说。此义今说

  不一及总举　　差别是阴义

立阴义有三。初立义者。是阴名字有三义。一道路义。二烧热义。三重担义。复有聚义是阴义。聚有三义。一者多义。如经中说。若色过去现在未来。若远若近若粗若细等。经中广说。此色多故名聚。如是等色摄在一处。此言显总举色等诸阴。体相种种故。更互无相摄故。说有差别。此三义。一多二总三异。是名聚义。聚即是阴义。因此义相似世间中聚

  能取所取取　　种子是界义

复有别摄名界。界名显何义。显种子义。能取种子者名眼等诸界。所取种子者色等诸界。取种子者识等诸界

  受尘分别用　　入门故名入

复有别法名入。此中三受为受用。三受门故说六内入。分别尘境及受用门故。六种说外入。何者十二因缘义

  因果及作事　　不增损为义

因果及事业。不增益不损减义。是名十二因缘义。增益因者。行等诸分别立不平等因故。损减因者。分别立无因义故。增益果者行等诸分别。有我依无明得生如是分别。损减果者。无行等诸法从无明生。增益事者。无明等诸因生行等诸果。时节分别有作意事。损减事者。分别无功用故。因果事中离此二执。此义无增益无损减。应知十二因缘义

  不欲欲清净　　同生及增上
  至得及起行　　系属他为义

处非处有七种。系属他义故。应知此中。一不欲系属他者。因恶行若不欲决入恶道。二欲系属他者。因善行入善道。若不欲决入善道。三清净系属他者。不离灭五盖。不修七觉分。不得至苦边际。四同生系属他者。两如来无前后两转轮王。一世界中不得共生。五及增上系属他者。女人不得作转轮王。六至得系属他者。女人不得作辟支佛及佛。七起行系属他者。已见四谛人不得造杀等诸行。凡夫能造行故。如多界经中广说。如是随思择。根者二十二种。因六义佛立二十二根。复有六义。何者为六

  取住及相接　　受用二清净

能取为义故。乃至二种清净为义故。此六事中为增上故。说二十二法名根。为能取六尘事增上故。眼等六法说为根为摄相续令住增上乃至生死。说寿命为根。为处世相接续增上说男女二根。受用增上故。五受说为根。意等业被受用故。世间清净增上故。说信等五法为根。为出世清净增上故。说未知欲知等三无漏为根

  果因已受用　　有用及未用

复有别名三世如义相应。果因已用故立过去世。果因未用故立未来世。因已用谢果未谢故立现在世

  受及受资粮　　为生彼行因
  灭彼及对治　　为此不净净

复有别名四谛。何者为四。一者苦谛。何法名苦。受及受资粮。如经中说。一切诸受皆是苦。受资粮受生缘。根尘等诸法应知

为生彼行因

何者集谛。为感诸苦一切邪行

  灭彼及对治　　为此不净净

为此因果二法寂灭故说灭谛。为对治此二名道谛。因此世谛说不净。因此真谛说净

  得失无分别　　智依他出离
  因智自出离

复有别名三乘如义相应。应知涅槃及生死功德过失观智。从他闻依他得。出离因果故立名声闻乘。因此智慧如前说。自不从他不依他行。出离因果名辟支佛乘。依无分别智自出离因果是名大乘。应知

  有言说有因　　有相有为法
  寂静义及境　　后说无为法

有别名有为无为。言说者名句味等。因者种子所摄阿黎耶识。相者世器身及所受用生起识所摄心及取分别。如此等法有言说有因有相有相应法。是名说有为法。此中说心者。是法恒起识相解相。取者五识分别意识。此有三分别故。无为法者。寂静义及寂静境。寂静义者灭谛。寂静境者道谛如如。此中道谛云何得寂静名。此法若缘境界。若显果依寂静。因此义五阴等十处。圣智及圣智方便。说名十种胜智。应知

  此十名真实

合真实义者。若略说真实有二种。一能显真实。譬如镜。二所显真实。譬如影。何者能显真实。三根本真实。所余真实得显现故。所显真实有九种一无增上慢所显真实。二对治颠倒所显真实。三声闻乘出离所显真实。四辟支乘出离所显真实。五大乘出离所显真实。因此粗真实成就众生及法。微细真实者解脱众生及法。六诸说堕负处所显真实者依正譬喻依正道理。能令诸说堕下负处。七显了大乘所显真实。八一切种所知摄一切法所显真实。九显了不如及如所显真实。十我执依处法一切义意入所显真实。中边分别大乘论真实品说竟

中边分别论卷上中边分别论卷下

        天亲菩萨造

        陈天竺三藏真谛译

    对治修住品第四

修习对治者。三十七道品修习今当说。此论中初说(心者我执种类又云根尘识也)

  粗行贪因故　　种故不迷故
  为入四谛故　　修四念处观

由身故粗行得显现。思择粗行故得入苦谛。此身者粗大诸行为相故。粗大者名行苦。因此行苦一切有漏诸法。于中圣人观苦谛。受者贪爱依处。思择诸受故得入集谛。心者我执依处。为思择此心得入灭谛。离我断怖畏故。法者不净净二品。为思择此法离不净净品无明故得入道谛。是故初行为令入四谛中。修习四念处所安立。次修习正勤

  已知非助道　　一切种对治
  为上二种故　　修习四正勤

为修习四念处究竟故。非助道黑法及助道品白法。一切种已明了所见故。为灭离非助道法。为生起助道法。四种正勤得起。第一为灭已生非善恶法。如经中广说(为灭为塞为生为长)

  随事住于彼　　为成就所须
  舍离五失故　　修习八资粮

为离为得黑白二种法。修习正勤已。心者无障有助故。得住此心。住有四能。四能者。一随教得成就。随教得成就者。说名四如意足。一切所求义成就因缘故。此中住者。心住名三摩提应知。是故四正勤后次第说四如意足。随事随教住者。为灭五种过失。为修习八种资粮故应知。何者名失耶

  懈怠忘尊教　　及下劣掉起
  不作意作意　　此五失应知

懈怠者。没懒恶处。忘尊教者。如师所立法名句味等。不忆不持故。下劣掉起者。两障合为一忧喜为体故。沉浮是其事。此位中沈时。不作意是第四过失。若无此二而作意。是第五过失。为灭此五失安立八种禅定资粮。为灭懈怠。何者为四。一欲二正勤三信四猗。复有四法次第应知

  依处及能依　　此因缘及果

欲者正勤依处。能依者正勤。此依处名欲。有何因是名信。若有信即生欲。此能依者名正勤果。此果名猗。若作正勤得所求禅定故。余四种资粮。一念二智三作竟四舍灭。余四种失如次第对治。此念等四法次第应知

  缘境界不迷　　高下能觉知
  灭彼心功用　　寂静时放舍

念者不忘失境界。智者不忘失境界时。觉知沉浮两事。觉知已为灭此作功用意。是名作意。此沉浮二法寂灭已。起放舍心放流相续名舍灭。四如意足后次第说修习五根。此五根云何得立

  已下解脱种　　欲事增上故
  境界不迷没　　不散及思择

此中增上次第五处流为修四勤故。心已随教得住。因此心已下解脱分善根种子。一欲增上故。二勤修增上故。三不忘境界增上故。四不散动增上故。五思择法增上故。如次第信等五根应知

  说力损惑故　　前因后是果

信等五法如前所说。为有胜力故说名力。胜力者何义。能损离非助惑故。若五法非信等诸对治惑不相障故。故说根力有次第。云何信等五法前后次第说。五种法如前后为因果故。云何如此。若人信因信果。为求得此果故决勤行。因此勤行已守境不移。若念止住心得三昧(平等住不高不下一三受故二一境故又有五种住未说)。若心得定观知如实境因此义是故五法立次第。若人已下种解脱分善根已。说五根是其位。若人已下通达分善根者。为在五根位中。为当在方位中

  二二通达分　　五根及五力

暖位及顶位立行五根。忍位及世第一法立行五力。若人下解脱善根种。此二二位决定通达分。若未不如此力次说觉分。此云何安立

  依分自体分　　第三出离分
  第四功德分　　三种灭惑分

见道位中显立觉分。觉者何义。无分别如如智是名觉。分者何义。同事法朋是名分义。此七法中觉依止分者是名念觉。自性分者是名择法觉。出离分者名正勤觉。功德分者名喜觉。无染无障分。三法谓猗定舍。云何说三法为无染障分

  因缘依处故　　自性故言说

无障无染因者。猗惑障。为重行作因故。此猗与粗重因对治故。依止者是禅定。自性者不舍觉分。次说道分。此法云何安立

  分决及令至　　令他信三种
  对治不助法　　说道有八分

修习道位中显立道分。见道分决分是正见。此见世间正见。出世正见后得。因此智自所得道及果决定分别。令他至分者。正思惟及正言。因有发起语言。能令他知及得。令他信分者有三种。正言正业正命。此三法次第

  见戒及知足　　应知令他信

令他信分者。三处依正言说言语。共相难正义共思择义时他得信。是人有智。是故令他信。智依正业他得信。持戒不作不如法事故。依正命者他得信。轻财知足如法如量行。见衣服等四命缘故。是故令他信知足轻财知足。烦恼对治分者三种。正勤正念正定。此三法如次第

  大惑及小惑　　自在障对治

非助道烦恼有三。一修习道所断烦恼。是名大惑。二心沉没掉起烦恼。是名小惑。三自在障者。能障碍显出胜品功德。第一烦恼者正勤是其对治。云何如此。因正勤修道得成故。若道得成思惟烦恼灭。第二烦恼者正念是其对治。寂静相处。若正念正寂静相处。沉没及掉起灭故。第三烦恼者正定是其对治。依止禅定故。能显出六神通功德故。此修习对治。若略说有三种应知

  随不倒有倒　　随颠倒不倒
  无倒无随倒　　修对治三种

修习对治有三。何者三。一者随应无倒法与倒相杂。二者颠倒所随逐无见倒。三者无颠倒无倒法随逐。如次第凡夫位中。有学圣位中。无学圣位中。菩萨修对治者有别异。何者别

  境界及思惟　　至得有差别

声闻及辟支自相续身等念处诸法。是其境界。若菩萨自他相续身等念处诸法。是其境界。声闻及辟支由无常等诸相。思惟身等诸法。若诸菩萨无生得道理故思惟观察。若声闻及缘觉修习四念处等诸法。为灭离身等诸法。若菩萨修习此等法。不为灭离故修习诸法。非不为灭离故修习诸法。但为至得无住处涅槃。修习对治已说。修住者何者

    修住品第五

  修住有四种　　因入行至得
  有作不作意　　有上亦无上
  愿乐位入位　　出位受记位
  说者位灌位　　至位功德位
  作事位已说

修住位有十八。何者十八。一因位修住。若人已住自性中。二入位修住。已发心。三行位修住。从发心后未至果。四果位修住。已得时。五有功用位修住。有学圣人。六无功用位修住。无学圣人。七胜德位修住。求行得六神通人。八有上位修住。过声闻等位未入初地菩萨人。九无上位修住。诸佛如来。此位后无别位故。十愿乐位修住。诸菩萨人。一切愿乐行位中。十一入位修住者。初菩萨地。十二出离位修住。初地后六地。十三受记位修住。第八地。十四能说师位修住。第九地。十五灌顶位修住。第十地。十六至得位修住。诸佛法身。十七功德位修住。诸佛应身。十八作事位修住。诸佛化身。一切诸住无量应知。今但略说

  法界复有三　　不净不净净
  清净如次第

若略说此位有三。一不净位住者。从因位乃至行住。二不净净位住者。有学圣人。三清净位住。无学圣人

  此中安立人　　应知如道理

因此住别异故。如道理应知。诸凡圣别异安立。此人者自性中住。此人已入位。如是等修住已说。何者得果

    得果品第六

  器果及报果　　此是增上果
  爱乐及增长　　清净果次第

器果者。果报与善根相应。报果者。器果增上故。善根最上品。爱乐果者。宿世数习故爱乐善法。增长果者。现世数习功德善根故善根圆满。清净果者。灭离诸障。此位果有五种次第应知。一者报果。二者增上果。三者随流果。四功用果。五相离果

  上上及初果　　数习究竟果
  随顺及对治　　相离及胜位
  有上无上故　　略说果如是

若略说果有十种。一者上上果。从自性发心乃至修行。应知后后次第。二初果者。初得出世诸法。数习果者。从初果后有学位中。究竟果者。无学诸法。随顺果者。为因缘故应知。上上果对治果者。是灭道因此得初果。此中初道名对治果相离果数习果圆满果。为远离惑障故。如次第有学无学诸圣人果。胜位果者。神通等诸功德。有上果者。菩萨地为胜余乘故。无上果者诸如来地。如是四种果为分别圆满果故。为略说如是多。若广说则无量。此中修习对治合集众义觉悟修习。令薄修习。熟治修习。上事修习。密合修习。智到境一家故。上品修。胜品得修初发修。中行修。最后修。有上修无上修者。境界无胜思量无集。至得无胜故修住。合集众义应成修住。住者此人住自性中。作事修住者。从发心乃至修行位。名最净住最净位住有庄严位住。遍满十地故。无上位住果合集众义。一摄持果。二最胜果。三宿习果。四上上引出果。五略果。六广果。此中摄持果者五种果。余果是五种果别异。宿世所集故名果报果。上上引出故。有四种余果。若略说上上果有四种。若广说随顺果有六。是四种果分别广说故。中边分别论中此处有四三品。一对治品。二修住品。三得果品。已广说究竟(一器果二果报果三爱乐果四增长果五清净果摄一切果尽)

    无上乘品第七

无上乘今当说

  无上乘三处　　修行及境界
  亦说聚集起

无上有三种。大乘中因此三义乘成无上。何者三义。一修行无上。二境界无上。三集起得无上。此中何者名修行无上。十波罗蜜修行中应知

  修行复六种

此十波罗蜜中随一有六种。何者六

  无比及思择　　随法与离边
  别及通六修

如是六修。一无比修。二思择修。三随法修。四离边修。五别修。六通修。此中无比十二种。何者为十二

  广大及长时　　增上体无尽
  无间及无难　　自在及摄治
  极作至得流　　究竟无比知
  此处无比义　　知十波罗蜜

如是十二种无比修行。一广大无比。二长时无比。三增上。四无尽。五无间。六无难。七自在。八摄治。九极作。十至得。十一胜流。十二究竟。何者广大无比。不欲乐一切世间及出世富乐故。是故广大无比应知。何者长时无比。一一处三阿僧祇劫修习得成故。何者增上无比。一切众生遍满利益事故。何者无尽无比。由回向无上菩提故。最极无穷无尽故。何者无间修无比。由得自他平等乐修故。因一切众生施等功德能圆满。成就十波罗蜜故。何者无难无比。随喜他所行诸波罗蜜。自波罗蜜得圆满故。何者自在无比。由破虚空等诸禅定力故。施等波罗蜜得满足成就。何者摄治无比。由一切波罗蜜无分别智所摄治护故。何者极作无比。地前方便愿乐行地中。最上法忍及道品随一所成故。何者至得无比。于初地中得未曾见出世法故。何者胜流无比。离初地应知余八种上地中。何者究竟无比。第十地及佛地中应知何以故。菩萨道及佛果圆满故。此处无比义。知十波罗蜜者。如是十二无比义。于十法中皆悉具有。是故十法通得名波罗蜜多。何者名十波罗蜜。为显此十法别名故。说偈言

  施戒忍精进　　定般若方便
  愿力及阇那　　此十无比度

此十波罗蜜别事云何

  财利不损害　　安受增功德
  除恶及令入　　解脱与无尽
  常起及决定　　乐法成熟事

如是十波罗蜜次第事应知。由施故菩萨能利益众生。由持戒故不损害众生寿命财物及眷属等。由忍辱故若他起损恼等事安心忍受。由精进故生长他功德。损减他罪障等。由禅定故因神通等诸功德。令他众生背恶归善得入正位。由般若故显说正教令他解脱。由方便故回向善根趣大菩提。施等功德令流无尽。由愿力故能受住舍随乐生处。于彼生中能事诸佛及闻正法。于施等中恒行不息利益众生。由思择修习力故。伏灭对治。决定能行施等诸度利益众生。由智故灭离如言法无明。施等诸行及施等增上缘法得共受用。此二菩萨能成熟众生。无比修行已说。何者思量修行

  如言说正法　　思量大乘义
  是菩萨常事　　依三种般若

依十种施等波罗蜜。如诸佛所安立所说修多罗等。诸法大乘中如理思惟数数听闻思量修习故。闻思修慧恒思惟行若因三慧修行思惟生何功德

  为长养界入　　为得事究竟

若人因闻慧修行思惟者。一切善根界性得增长。若因思慧修行思惟者。如所闻名句义。此理得入意得生显现故。若因修慧修行思惟者。如所求正事得成就。为入地为治净故。此修行思惟有伴应知

  十种正行法　　共相应应知

此思惟修行者。十种正法行所摄持应知。何者十种法行

  书写供养施　　听读及受持
  广说及读诵　　思惟及修习

大乘法修行有十。一书写。二供养。三施与他四若他读诵一心听闻。五自读。六自如理取名句味及义。七如道理及名句味显说。八正心闻诵。九空处如理思量。十已入意为不退失故修习

  无量功德聚　　是十种正行

此十种正行有三种功德。一无量功德道。二行方便功德道。三清净功德道。云何大乘中佛说最极大果报。声闻乘等法不如是说。云何如此有二种因

  最胜无尽故　　利他不息故

最胜者小乘经。但为自利故。大乘自利利他平等。是故最胜。第一为自利故。第二为利他故。是故有下有上。是故说胜。大菩提者至无余涅槃。他利益事如因地中无息故。故说无尽。无尽故胜小乘。思惟修行已说。何者随法修行

  随法有二种　　不散动颠倒

随法修行者如是二种。一无散动修行。二无颠倒变异修行。此中散动有六种。灭除此六种散动故说无散动。何者六种散动。一自性散动。二外缘散动。三内散动。四相散动。五粗惑散动。六思惟散动。此六散动何者为相。应知故说

  起观行六尘　　贪味下掉起
  无决意于定　　思量处我慢
  下劣心散乱　　智者应当知

如是为相。六种散动菩萨应知应离。何者六相。一从禅定起散动。由五识故。是名性散动。六尘中若心行动是名外散动。是禅定贪味忧悔掉起。是名内散动。下地意未决未息。是名相散动。因此相入定故。有我执思惟定中所起。名粗散动。因此粗思惟生我慢起行故。下劣品思惟。名思惟散动。下乘思惟起行故。前两散动未得令不得。次两已得令退。第五令不得解脱。第六令不得无上菩提应知。此中无倒十种处应知。何者十

  言辞义思惟　　不动二相处
  不净及净客　　无畏及无高

此中何法名无倒。无倒者。如理如量知见。此无倒十种处。一者名句味无倒。如偈说

  聚集数习故　　有义及无义
  是言辞无倒

若名句味若有相应。名言无间不相离说故。此物是其名。数数习故。名句等有义。若翻此三无义。若有如此知见名。名句味无倒。何者义无倒

  显现似二种　　如显不实有
  是名义无倒　　远离有无边

诸义显现有二。一显所执。二显能执。由二相生故。如是无所有。如所显现义中。若生如此知见。是名义无倒。云何如此义者远离有相。能执所执无有故。远离无相似能似所散乱有故。何者思惟无倒

  此言熏言思　　彼依思无倒
  为显二种因

所执能执言。所熏习言语思惟。是能执所执虚妄分别依处。若起如此知见一切处。是名思惟无倒。何者思惟为能执。所执虚妄作显现。因此思惟言语名句味两法所生故。为二法作依处。离此思惟无倒境故。何者不动无倒

  如幻等不有　　亦有义应知
  是不动无倒　　有无不散故

是义亦有亦无。如前已说。此有无譬如幻化。幻化者为象马等实体故。无有非无唯似象等。散乱有故义亦如是不有。如所显现能执所执故非不有。唯相似散乱相有故。等者如野马梦幻水月等譬。如是道理应知。已见幻等譬义故心不僻行。是名不动无倒。因此无倒心。有无执中心不散动故。何者二相无倒

  一切唯有名　　为分别不起
  是别相无倒

一切诸法唯有名言。何者名。一切眼及色乃至心及法。如此知见

一切虚妄分别。为对治故说名别相无倒。何者名别相。为虚妄为真实

此相名真实真实别相中是无倒。云何如此。若为俗谛故。一切诸法不但有名。如是执故。何者通相无倒

  出离于法界　　更无有一法
  故法界通相　　此智是无倒

无有别法离无我真实有体。是故法界一切通相。体平等故。如是知见是名通相无倒。何者净不净无倒

  颠倒邪思惟　　未灭及已灭
  此不净及净　　是彼不颠倒

颠倒不正思惟在及未尽。是名法界不清净。若不在及尽。是名法界清净。若有此知见。是名不净及净无倒。如次第。何者客无倒

  法界性净故　　譬之如虚空
  此二种是客　　是彼不颠倒

复有法界如真虚空自性净故。是二种法非旧法故名客。先不净后及净。若有此知见。是名客相无倒。何者无怖及无高无倒

  染污及清净　　法人二俱无
  无故无怖慢　　是二处无倒

人者无染污无清净法。亦如是。先无染污后无清净。云何如此人及法非实有故。是故二中无有一物。是净品及不净品。不净品时无有一法被损减。清净品时无有一物被增益。为此二法生怖畏生高慢。若有如此知见。是名无怖畏无高慢无倒。如是十种无倒。十种金刚足中。如次第应安立。何者名十种金刚足。一有无无倒。二依处无倒。三幻化譬无倒。四无分别无倒。五自性清净无倒。六不净无倒。七净无倒。八如真空譬无倒。九不减无倒。十不增无倒。已说随法修行。何者远离二边修行。如宝顶经中佛为迦叶等说无相中道。何者二边为远离此故。此中道应知

  别异边一边　　外道及声闻
  增益与损减　　二种人及法
  非助对治边　　断常名有边
  能取及所取　　染净有二三
  分别二种边　　应知有七种
  有无及应止　　能止可畏畏
  能取所取边　　正邪事无事
  不生及俱时　　有无分别边

色等诸阴立我别异。一边立我与色一。一边为离此二边。佛说中道。不见我。不见人不见众生。及不见寿者。云何如此。若人执我见者不离此二边。寿者别异身亦别异。若不取执。异即是寿。名即是身。此二见决定有为。此中道此二执不得起。色等常住是外道边。无常是声闻边。为离此二边故佛说中道。色等诸法不观常及无常故。是名中道。有我者增益边毁谤。无我者损减边毁谤。有假名人故。为离此二边故佛说中道。有我无我二。彼中间非二。所触无分别故。心实有是增益法边。不实有损减法边。为离此二边故佛说中道。此处无意无心无识无作意。一切不善法名不净品名非助道。一切善法等是净品名对治边。为离此二边故佛说中道。佛说此二种边不去不来无譬无言。有者名常边人及法。无者名断边人及法。离此二边故佛说中道。是二种中间名中道如前说。无明者。所取一边能取第二边。如无明明亦如是。一切有为法所取一边能取一边。无为法亦如是。如无明乃至老死所取能取。老死灭所取一边。能取第二边。是灭道者所取能取。如是所取能取二边。由黑分白分别异故。为离此二边故佛说中道。佛说无明及明此二无二无。如经广说。云何如此。无明及明等所取能取体无故。染污有三种。一烦恼。二业。三生染污。烦恼染污复有三。一者诸见。二者欲嗔痴起相。三更有生愿。为对治此三佛说。知空解脱门。知无相解脱门。知无愿解脱门。业染污者。善恶造作。为对治此业佛说。智慧无造作。生染污者。更有中生已生意心及心法念念生有生相续不断。为对治此佛说。智慧无生。智慧无起。智慧无自性。如是三种染污灭除名清净。知空等者。及染污空等。是名境界清净。智及一切对治。名行清净因此行烦恼除不更起。名果清净。此三种清净染污空等。如三种清净所作空等。诸法自性无故。法界自性无别异故复有智慧空等诸法非染污所造及非智所造作。云何如是空等诸法自性有故。法界自性无染污故。若人思惟分别法界有时染污有时清净。是边自性无染污。法自体无染净故。此执成边。为远离此边故。佛说此中道非二空作空。令诸法空诸法自体空。如是等如宝顶经广说。复有七种分别二边。何者七。一有中分别一边。二无中分别一边。有真实人为灭此人。是故立空。有真实无我。为灭此法。是故立不空。因此二分别起有执无执。为离此二边故佛说中道。空者不灭人等。何所为无所为。一切诸法自然性故。如经广说。一切无明等诸惑应止令灭。明等诸法道应生。能令止灭如此分别。应止及能止故。空中生怖畏。为离此二种分别边。佛说空譬。可怖畏分别一边。因此可畏起怖畏。复是一边分别所作色等诸尘。起怖畏及起苦怖畏。为离此二种怖畏分别边。佛说画师譬。前譬者依小乘人说。今譬依菩萨说。所取分别一边。能取分别一边。为离此二边佛说幻师譬。云何如此。唯识智所作无尘智。无尘智者灭除唯识智。尘无体故识亦不生。此中是相似正位分别一边。邪位分别一边。分别真实见为正位分别邪位。为离此二边佛说两木截火譬。譬如两木无火相从此起火。火起成还烧两木。如是不正位相及正位相。真实见正通达为相。圣智根起成已。是真实见相正位。复有了灭此中譬与其相似真实见。邪位相无有邪位相。邪位亦无随顺真实位故。分别有事一边。分别无事一边。有事者。智慧先分别作意。复有分别无功用。为离此二种功德边佛说灯光譬。分别无生一边。分别等时一边。若分别对治道无生。分别烦恼长时。为离此二边佛说第二灯光譬。离十四二边修行已说。云何胜有等修行

  胜有等修行　　应知于十地

何者胜有等修行。十地中随一此中波罗蜜最胜无比。此波罗蜜名胜修行。若一切处同无差别。是名有等修行。修行无上已说。何者境界无上

  安立及性界　　所成能成就
  持决定依止　　通达及广大
  品行及生界　　最胜等应知

如是境界有十二。何者十二。一安立法名境界。二法性境界。三所成就境界。四能成境界。五持境界。六决持境界。七定依止境界。八通达境界。九相续境界。十胜得境界。十一生境界。十二最胜境界。此中第一者。波罗蜜等诸法。如佛所安立。第二法如如。第三第四此二如前次第。通达法界故。得行波罗蜜等诸法故。第五闻慧境界。第六思慧境界。云何名决持。已知此法能持故。第七修慧境界。依内依体得持故。第八初地中见境界。第九修道境界乃至七地中。第十是七种地中世及出世道。如品类诸法得成故。第十一八地中。第十二九地等三处是。第一第二境界如前说。处处位中平等境界。所余境界者。前二所显差别。境界已说何者习起

  具足及不毁　　避离令圆满
  生起及坚固　　随事无住处
  无障及不舍　　十习起应知

如是习起有十种。此中因缘具足名性习起。不毁谤大乘法是名愿乐习起。避下乘法是名发心习起。修行圆满波罗蜜名修行习起。生起圣道名入正位习起。坚固善根长时数习故。名成熟众生习起。心随事得成名净土习起。不住生死涅槃中。得不退位授记。不退堕生死涅槃故。灭尽诸障名佛地习起。不舍此等事名显菩萨习起。如是此论名中边分别了中道故。复有分别中道及二边故。是中两边能现故。离初后此中两处不着。如理分别显现故。故名中边分别论

  此论分别中　　甚深真实义
  大义一切义　　除诸不吉祥

此中边分别论名义如前说。甚深秘密义。非觉观等境界故。真实坚义诸说不可破故。无上菩提果故。大义自他利益事为义故。一切义因此论三乘义得显现故。能除一切不吉祥。不吉祥者。三品烦恼及三品生死。能离灭此生死及烦恼不吉祥故。能灭四德障故。能摄持四德故。故说除不吉祥。无上众义者。略说无上有三种。一正行。二正依持。三正行果。此修行如品类无比。如方便。如佛所立诸法大乘中思惟等。如前说。如道理无散动无倒若修奢摩他无散动。若修毗婆舍那无颠倒变异。如所为为出离随中道故。如处十地中。如胜有等行。无倒众义者。名句无倒故。通达禅定相义无倒故。通达智慧相思惟无倒故。得远离颠倒因缘故。无不散动颠倒故。是中道相分明所得。令成就别相无倒故。依此起对治得生死分别道通相无倒故。得通达净品自性不净及净无倒故。惑障未灭及灭。得智各无倒故。不净及净如实见。无怖畏无高慢无倒故。灭除诸障得出离故

  空涅槃一路　　佛日言光照
  圣众行纯熟　　盲者不能见
  已知佛正教　　寿命在喉边
  诸惑力盛时　　求道莫放逸

此中边分别论。无上乘品究竟。婆薮槃豆释迦道人大乘学所造

  我今造此论　　为世福慧行
  普令一切众　　如愿得菩提

中边分别论卷下


转识论(从无相论出)

    No. 1587 [No. 1586; cf. No. 1585]

转识论(从无相论出)

        陈代真谛译

识转有二种。一转为众生。二转为法。一切所缘不出此二。此二实无。但是识转作二相貌也。次明能缘有三种。一果报识。即是阿梨耶识。二执识。即阿陀那识。三尘识。即是六识。果报识者为烦恼业所引故名果报。亦名本识。一切有为法种子所依止。亦名宅识。一切种子之所栖处。亦名藏识。一切种子隐伏之处。问此识何相何境。答相及境不可分别一体无异。问若尔云何知有。答由事故知有此识此识能生一切烦恼业果报事。譬如无明。当起此无明。相境可分别不若可分别非谓无明。若不可分别则应非有。而是有非无亦由有欲嗔等事知有无明。本识亦尔相境无差别。但由事故知其有也就此识中。具有八种异。谓依止处等。具如九识义品说。又与五种心法相应。一触。二作意。三受。四思惟。五想。以根尘识三事和合生触。心恒动行名为作意。受但是舍受。思惟筹量可行不可行。令心成邪成正。名为思惟。作意如马行。思惟如骑者。马但直行不能避就是非。由骑者故令其离非就是。思惟亦尔。能令作意离漫行也。此识及心法。但是自性无记。念念恒流如水流浪。本识如流五法如浪。乃至得罗汉果。此流浪法亦犹未灭。是名第一识。依缘此识有第二执识。此识以执着为体与四惑相应。一无明。二我见。三我慢。四我爱。此识名有覆无记。亦有五种心法相应名字同前。而前细此粗。此识及相应法。至罗汉位究竟灭尽。及入无心定亦皆灭尽。若见谛害烦恼识及心法。得出世道十六行。究竟灭尽。余残未尽但属思惟。是名第二识。第三尘识者。识转似尘。更成六种识转似尘。已如前说。体通三性。与十种心法相应。及十善恶。并大小惑具三种受。十种心法者。触等五种如前。但此为最粗也。后五者。一欲。二了。三念。四定。五慧。此中言了者。即旧所明解脱数也。十善者。一信。二羞。三惭。四无贪。五无嗔。六精进。七猗。八无放逸。九无逼恼。十舍。此十遍一切三界。心及无流心数名大地。此是自性善翻此十为自性恶。大惑有十种者。一欲。二嗔。三痴。四慢。五五见。十疑。小惑者。有二十四种。一忿恨。二结怨。三覆藏。四不舍恶。五嫉妒。六吝惜。七欺诳。八谄曲。九极醉。十逼恼。十一无羞。十二无惭。十三不猗。十四掉戏。十五不信。十六懈怠。十七放逸。十八忘念。十九散乱。二十不了。二十一忧悔。二十二睡眠。二十三觉。二十四观。此小惑中有二种。一作意遍行。二不遍行。五识于第六意识及本识执识。于此三根中随因缘。或时俱起。或次第起。以作意为因外尘为缘。故识得起。若先作意欲取色声二尘。后则眼耳二识一时俱起。而得二尘。若作意欲至某处看色听声取香。后亦一时三识俱起得三尘。乃至一时具五识俱起亦尔。或前后次第而起唯起一识。但得一尘。皆随因缘。是故不同也。如是七识。于阿梨耶识中尽相应起。如众像影俱现镜中。亦如众浪同集一水。问此意识于何处不起。答离无想定及无想天。熟眠不梦醉闷绝心暂死。离此六处余处恒有。如此识转不离两义。一能分别。二所分别。所分别既无。能分别亦无。无境可取识不得生。以是义故唯识义得成何者立唯识义。意本为遣境遣心。今境界既无唯识又泯。即是说唯识义成也。此即净品烦恼及境界并皆无故。又说唯识义得成者。谓是一切法种子识。如此如此造作回转。或于自于他。互相随逐。起种种分别及所分别。由此义故离识之外诸事不成。此即不净品。但遣前境未无识故

释曰。谓是一切种子识者。是阿梨耶识。为诸法种子及所余七识种子及所余七识种子。并能生自类无量诸法故。通名一切法种子识也。如此如此者。由此等识能回转造作无量识法。或转作根。或转作尘。或转作我。或转作识。如此种种不同唯识所作。云如此造作回转也。或于自于他互相随逐者。于自则转为五阴。或为色阴乃至识阴。于他则转为怨亲中人。种种不同。望自五阴故称为他。如是自他互相转作前后不同。故云互相随逐也。种种所作并皆是识无别境界。起种种分别等者。一一识中皆具能所。能分别即是识。所分别即是境。能即依他性。所即分别性。故云起种种分别及所分别也由如此义。离识之外无别境。但唯有识义成。既未明遣识。惑乱未除。故名不净品也。问遣境在识。乃可称唯识义。既境识俱遣。何识可成答立唯识乃一往遣境。留心卒终为论。遣境为欲空心。是其正意。是故境识俱泯。是其义成。此境识俱泯即是实性。实性即是阿摩罗识。亦可卒终为论是摩罗识也。记曰。由二种宿业熏习及二种习气。能为集谛。成立生死。二种宿业熏习者。即是诸业种子。一宿业熏习。二宿业熏习执。宿业熏习即是所分别。为分别性。宿业熏习执即是能分别。为依他性。所即为境能即为识。此二种业名相似集谛。能得五阴生。二种习气者。即诸烦恼。一相习气。二粗重习气。相即烦恼体。是依他性。能摄前相貌。粗重即烦恼境。是分别性。境界粗显故也。此二烦恼名真谛。能集令未来五阴由此似真两种集谛。若宿业已尽更受别报。能安立生死。释曰。二种宿业熏习者。一一种子备有两义。所分别即是宿业熏习。能分别即是宿业熏习执。所即分别性。能作生起种子法门故。说此法门名为宿业熏习。有名而无体也。能即依他性。正是起业种子。名宿业熏习执。有体而不真实也。二种习气亦尔。一一烦恼皆有两义。所分别即粗重习气作起烦恼法门。有名而无体。能分别正是烦恼体。亦有而不真实。是依他性。然此中所明分别依他。与三无性中名字不同。三无性中说分别名相类。依他性名粗重。以分别性当体有其相类能作烦恼法门。说名烦恼也。依他性正是烦恼体。能得生死报故名粗重。今此中为明分别性相类粗显故名粗重。依他性能执前相类故名为相各自有意。若欲转此中自三无性中名亦好也。记曰。如是如是分别。若分别如是如是类。此类类名分别性。此但唯有名。名所显体实无。此所显体实无。此分别者因他故起。立名依他性。此前后两性未曾相离。即是实实性。若相离者唯识义不成。有境识异故。由不相离故唯识无境界。无境界故识亦成无。由境无识无故立唯识义。是乃成立。是故前性于后性不一不异。若定一异则有过失何耶。分别与依他定一者。分别性决定永无不为五法藏所摄。依他性亦应永无。若尔便无生死解脱善恶律戒法。此为不可。既不如此故。分别性与依他性不得定一。若定异者。则分别性便不能遣依他性。既由观分别性是无所有。方见依他性亦无所有故。不得定异。又若分别性定异依他性者。分别性体应定是有。非谓永无。有可异无。何所论异。是故但说不一不异。不可定说一异也。如无常与有为法。亦不得定说一异。前无后无是无常义。五阴是有为法。若无常与有为法定一者。无常是无。一切诸法并皆是无。既不并无故不得定一。若定异者。观无常时。不应通有为法。以其通故不得定异。此亦是不一不异也。如是一切诸法皆尔。如色等与瓶亦不一不异。若色与瓶定一。香等不成瓶。瓶则真实。若色定异瓶。见色不应通瓶。是故不定一异也。两说亦尔。若不见分别性。则不见依他性。是故不一不异。然一切诸法但有三性。摄法皆尽。如来为众生说诸法无性。亦有三种。三性如前说。前二是俗谛。后一是真谛真俗二谛摄一切法皆尽。三无性者。即不离前三性。分别性名无相性。无体相故。依他性名无生性。体及因果无所有。体似尘相。尘即分别性。分别既无体亦是无也。因亦无者。本由分别性为境。能发生识果。境界既无云何生果。如种子能生芽。种子既无芽从何出。是故无生也。真实性名无性性。无有性无无性。约人法故无有性。约二空故无无性。即是非有性非无性故。重称无性性也。此三无性。是一切法真实。以其离有故名常。欲显此三无性故。明唯识义也。若人修道智慧未住此唯识义者。二执随眠所生众惑不得灭离。根本不灭故。由此义故立一乘皆令学菩萨道。若谓但唯有识现前起此执者。若未离此执。不得入唯识中。若智者不更缘此境二不显现。是时行者名入唯识。何以故。由修观熟乱执尽。是名无所得非心非境。是智名出世无分别智。即是境智无差别。名如如智。亦名转依。舍生死依但依如理故。粗重及执二俱尽故。粗重即分别性。执即依他性。二种俱尽也。是名无流界。是名不可思惟。是名真实善。是名常住果。是名出世乐。是名解脱身。于三身中即法身。释曰。二执随眠所生果。或不得灭离者。即是见思二执随眠烦恼能作种子。生无量上心。或皆以本识为其根本。根本未灭支未尽。如胜鬘经说。无明住地不断不究竟。无边四住地不断不究竟也。若智者不更缘此境二不显现故者。此境即此唯识境。唯识散乱由无境故识无。此识既无。能缘唯识之心亦无。故云二不显现。此二但谈二识所现前境。前境先已无故。是名识转品究竟也

转识论


八大灵塔梵赞(西天戒日王制)

    No. 1684

八大灵塔梵赞(西天戒日王制)

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

惹(引)鼎冒亭钵啰(二合)嚩啰末睹朗(一句)达哩摩(二合)作讫啰(二合)左啰藐(二)戴帝炀(二合)左(引)祢炀(二合)帝哩(二合)部嚩那摩呬当(三)室哩(二合引)摩贺(引)钵啰(一合引)底贺(引)哩炀(二合四)萨他(二合)难际(引)曩呬摩儗哩儞罗炀(五)祢(引)缚祢(引)缚(引)嚩多(引)啰(六)满祢(引)喝钵啰(二合)拏摩多室啰娑(引)儞没哩(二合)多(引)拽怛啰(二合)没驮(引七)吠(引)舍(引)梁(引)达哩摩(二合)作讫丽(二合)室输摩儗哩怛致(引八)毗(引)瑟摩(二合)哥(引)踰(引)迭帝(引)丽(引九)室啰(二合引)嚩萨爹(二合引)冒提暮梨(引)拘尸那誐啰嚩丽(引十)龙弥儞(引)哥(引)必逻(引)契曳(二合引十一)憍睒(引)咩(引)萨兔(二合)罗酤瑟致(二合引)末吐啰嚩啰补丽(引十二)难那吴播(引)写啰(引)瑟致丽(三合引十三)曳(引)左(引)[寧*(尤-尢+曳)](切身下同)舍(引)窣都(二合)戴(引)爹(引)捺舍嚩啰嚩里那(引十四)萨旦(二合引)那莫写(引)弥暮达那(二合引十五)割湿弥(二合引)丽(引)际(引)那祢(引)尸(引十六)朅沙怛吒野牟泥(引)末哩嚩(二合)丽(引)星贺梨(引)嚩(引十七)逻(引)浓捺丽(二合引)辛度褒捺丽(二合引十八)三摩怛吒摩[卄/(阿-可+辛)/女]提(引)末朅梨(引)酤萨梨(引)嚩(引十九)泥(引)播(引)梨(引)哥(引)摩噜闭(引)割罗舍嚩啰补丽(引二十)干(引)唧骚啰(引)瑟吒啰(三合)啰(引)瑟吒丽(三合引二十一)曳(引)左(引)[寧*(尤-尢+曳)](上同)驮(引)睹誐哩婆(二合引)捺舍嚩啰嚩哩那(引二十二)萨旦(二合引)那莫写(引)弥暮达那(二合二十三)该逻(引)细(引)系(引)末酤(引)致呬摩儗哩儞罗曳(引二十四)满捺丽(引)弥(引)噜室凌(二合)诣(引二十五)播(引)怛(引)梨(引)昧惹演帝(引)达那钵底儞罗曳(引二十六)悉驮巘达哩嚩(二合)路计(引二十七)没啰(二合)吽满(二合引)尼(引)尾瑟女(二合)部耄(引)钵输钵帝婆嚩泥(引二十八)赞捺啰(二合)素(引)哩也(引二合)祢路(引)计(引二十九)曳(引)左(引)[寧*(尤-尢+曳)](上同)驮(引)睹誐哩婆(二合引)捺舍嚩罗嚩里那(引三十)萨旦(二合引)那莫写(引)弥暮(引)达那(二合引三十一)曳(引)左(引)瑟诛(吒侯切)驮(引)睹誐哩婆(二合)捺舍嚩罗嚩里那(三十二)功婆僧倪也(二合)室左(二合)载爹(引三十三)盎誐(引)啰契也(二合引)萨怛(二合)他(引)[寧*(尤-尢+曳)](上同)呬摩啰惹多儞婆(引三十四)窣都(二合引)波啰怛那(二合)钵啰(二合)哥(引)舍(引三十五)播(引)多(引)梨(引)曳(引)左部咩(引)儗哩室朅啰誐多(引三十六)萨哩嚩(二合)都(引)驮(引)睹誐哩婆(二合引三十七)没驮(引)喃(引)夜(引)儞泯摩(引)钵啰(二合)底祢那摩设讫哩(二合三十八)多(引)儞暮(引)达那(二合引)那摩(引)弥(三十九)阿瑟吒(二合)摩贺(引)载爹满捺那三摩钵多(一合四十)

八大灵塔梵赞


宝行王正论

    No. 1656

宝行王正论一卷

        陈天竺三藏真谛译

    安乐解脱品第一

  解脱一切障　　圆德所庄严
  礼一切智尊　　众生真善友
  正法决定善　　为爱法大王
  我当说由法　　流注法器人
  先说乐因法　　后辩解脱法
  众生前安乐　　次后得解脱
  善道具名乐　　解脱谓惑尽
  略说此二因　　唯信智二根
  因信能持法　　由智如实了
  二中智最胜　　先藉信发行
  由痴贪嗔怖　　而能不坏法
  当知是有信　　吉祥乐名器
  已能熟简择　　身口意三业
  恒利益自他　　说为有智人
  杀生盗邪淫　　妄言及两舌
  恶骂不应语　　贪嗔与邪见
  此法名十恶　　翻此即十善
  离酒清净命　　无逼恼心施
  供养所应敬　　略说法当尔
  若但行苦行　　决不生善法
  以离智悲故　　若唯有苦行
  不能除损他　　与救济利益
  施戒修所明　　正法大夷路
  若弃行邪道　　自苦受牛罚
  是生死旷泽　　无饮食树阴
  或狼所食啖　　长远于中行
  因杀生短寿　　逼恼招多病
  由盗致乏财　　侵他境多怨
  妄语遭诽谤　　两舌亲爱离
  恶口闻不爱　　绮语他憎嫉
  由贪害所求　　嗔恚受惊怖
  邪见生僻执　　饮酒心讷乱
  不施故贫穷　　邪命逢欺诳
  不恭生卑贱　　嫉妒无威德
  恒恨形色丑　　不问聪故痴
  此报在人道　　先已受恶趣
  杀生等罪法　　如所说果报
  无贪等及业　　说名善习因
  恶修及诸苦　　皆从邪法生
  诸善道安乐　　皆因善法起
  常离一切恶　　恒行一切善
  由身口意业　　应知此二法
  由一法能脱　　地狱等四趣
  第二法能感　　人天王富乐
  由定梵住空　　得受梵等乐
  如是略说名　　乐因及乐果
  复次解脱法　　微细深难见
  无耳心凡夫　　闻则生惊怖
  我无当不生　　现来我所无
  凡人思此畏　　智者怖永尽
  世间我见生　　他事执所系
  佛由至道证　　依悲为他说
  我有及我所　　此二实皆虚
  由见如实理　　二执不更生
  诸阴我执生　　我执由义虚
  若种子不实　　芽等云何真
  若见阴不实　　我见则不生
  由我见灭尽　　诸阴不更起
  如人依净镜　　得见自面影
  此影但可见　　一向不真实
  我见亦如是　　依阴得显现
  如实捡非有　　犹如镜面影
  如人不执镜　　不见自面影
  如此若析阴　　我见即不有
  因闻如是义　　大净命阿难
  即得净法眼　　恒为他说此
  阴执乃至在　　我见亦恒存
  由有我见故　　业及有恒有
  生死轮三节　　无初中后转
  譬如旋火轮　　生起互相由
  从自他及二　　三世不有故
  证此我见灭　　次业报亦然
  如此见因果　　生起及灭尽
  故不执实有　　世间有及无
  愚人闻此法　　能尽一切苦
  由无智生怖　　于无怖畏处
  涅槃处无此　　汝云何生怖
  如所说实空　　云何令汝怖
  解脱无我阴　　汝若受此法
  舍我及诸阴　　汝云何不乐
  无尚非涅槃　　何况当是有
  有无执净尽　　佛说名涅槃
  若略说邪见　　谓拨无因果
  此今非福满　　恶道因最重
  若略说正见　　谓信有因果
  能令福德满　　善道因最上
  由智有无寂　　超度福非福
  故离善恶道　　佛说名解脱
  若见生有因　　智人舍无执
  由见灭共因　　是故舍有执
  先俱生二因　　实义则非因
  假名无依故　　及生非实故
  若此有彼有　　譬如长及短
  由此生彼生　　譬如灯与光
  先长后为短　　不然非性故
  光明不生故　　灯亦非实有
  如此因果生　　若见不执无
  已信世真实　　由乱心所生
  见灭非虚故　　即证得真如
  是故不执有　　不依二解脱
  色是远所见　　若近最分明
  鹿渴若实已　　云何近不见
  若远于实智　　即见世间有
  证实则不见　　无相如鹿渴
  如鹿渴似水　　非水非实物
  如此阴似人　　非人非实法
  计鹿渴为水　　往彼若饮此
  若无执为水　　如此人愚痴
  世间如鹿渴　　若执实有无
  此即是无明　　痴故无解脱
  执无堕恶趣　　执有生善道
  若能知如实　　不二依解脱
  不乐有无执　　由择真实义
  若堕于无执　　何不说堕有
  若言由破有　　义至故堕无
  如此破无故　　云何不堕有
  无言行及心　　由依菩提故
  若说彼堕无　　何因不堕有
  僧佉鞞世师　　尼揵说人阴
  约世汝问彼　　若说过有无
  是不可言法　　以过有无故
  汝应知甚深　　佛正教甘露
  如晓无去来　　亦无一念住
  若体过三世　　何世为实有
  二世无去来　　现在实不住
  世生及住灭　　此言云何实
  若恒有变异　　何法不念灭
  若无念念灭　　云何有变异
  若言念念灭　　分具分灭故
  不等证见故　　此二无道理
  若念灭皆尽　　云何有故物
  若坚无念灭　　故物云何成
  如刹那后际　　前中际亦有
  由刹那三分　　故世念无住
  是一念三际　　应择际如念
  前中后三际　　不由自他成
  非一念分故　　若无分何有
  离一多云何　　离有何法无
  由灭及对治　　若言有成无
  此无及对治　　何法有无故
  是故世涅槃　　由义不成有
  世间有后际　　他问佛默然
  是尊一切智　　故智人识佛
  由此甚深法　　不说非器处
  如此解脱法　　甚深无系摄
  诸佛一切智　　故说无依底
  于无依着法　　过有无二边
  世人受依着　　由痴惊怖失
  彼自失坏他　　怖畏无依处
  王愿汝不动　　莫由彼自坏
  为汝成不坏　　我当说真理
  由依无倒合　　离有无二执
  此过福非福　　甚深义明了
  非身见怖空　　二人境当说
  四大及空识　　一聚俱非人
  若合离非人　　云何执人有
  如六界非人　　聚故虚非实
  一一界同然　　由聚故非实
  阴非我我所　　离阴我不显
  不如薪火杂　　何依阴成我
  地界非三大　　地中亦无三
  三中亦无地　　相离互不成
  地水火风大　　各自性不成
  一离三不成　　三离一亦尔
  一三及三一　　相离若不成
  各各自不成　　彼相离云何
  若各离自成　　离薪何无火
  动碍及相聚　　水风地亦然
  若火不自成　　三云何各立
  三大缘生义　　相违云何成
  若彼各自成　　云何更互有
  若各自不成　　云何互成有
  若言不相离　　诸大各自成
  不杂则不共　　若杂非独成
  诸大非各成　　云何各性相
  各成无偏多　　故相假名说
  色声香味触　　简择义如大
  眼色识无明　　业生择亦尔
  作者业及事　　数合因果世
  短长及名想　　非想择亦然
  地水风火等　　长短及小大
  善恶言识智　　智中灭无余
  如识处无形　　无边遍一切
  此中地等大　　一切皆灭尽
  于此无相智　　短长善恶业
  名色及诸阴　　如此灭无余
  如此等于识　　由无明先有
  于识若起智　　此等后皆尽
  如是等世法　　是然识火薪
  由实量火光　　世识薪烧尽
  由痴别有无　　后简择真如
  寻有既不得　　无云何可得
  由无色所成　　故空但名字
  离大何为色　　故色亦唯名
  受想行及识　　应思如四大
  四大如我虚　　六界非人法

    宝行王正论杂品第二

  如分分拆蕉　　无余尽不有
  约六界拆人　　尽空亦如是
  是故佛正说　　一切法无我
  但六界名法　　决判实无我
  我无我二义　　如实捡不得
  是故如来遮　　我无我二边
  见闻觉知言　　佛说无实虚
  二相待成故　　此二如实无
  如实捡世间　　过实亦过虚
  则世间依实　　故堕于有无
  若法遍不如　　云何佛得说
  有边及无边　　有二与无二
  过去佛无量　　现来过算数
  过数众生边　　三世由佛显
  世间无长因　　此际约世显
  世间过有无　　云何佛记边
  由法如此深　　于凡秘不说
  说世如幻化　　是佛甘露教
  譬如幻化像　　生灭尚可见
  此像及生灭　　实义捡非有
  世间如幻化　　生灭可见尔
  世间及生灭　　约实义皆虚
  幻像无从来　　去亦无有处
  但迷众生心　　由实有不住
  世体过三世　　若尔世何实
  谁言说有无　　有无实无义
  故佛约四句　　不记说世间
  由有无皆虚　　此虚不虚故
  是身不净相　　粗证智境界
  恒数数所见　　尚不入心住
  况正法微细　　甚深无依底
  难证于散心　　云何可易入
  故佛初成道　　舍说欲涅槃
  由见此正法　　甚深故难解
  若法非正了　　即害不聪人
  由不如执此　　堕邪见秽坑
  人识法不明　　由自高轻法
  起谤坏自身　　下首堕地狱
  譬如胜饮食　　偏用遭危害
  若如理量食　　得寿力强乐
  若偏解正法　　遭苦亦如此
  若能如理解　　感乐及菩提
  智人于正法　　舍谤及邪执
  于正智起用　　故成如意事
  由不了此法　　人起长我见
  因此造三业　　次生善恶道
  乃至未证法　　能除灭我见
  恒敬起正勤　　于戒施忍等
  作事法为先　　及法为中后
  谓无虚真理　　现来汝不沈
  因法现好名　　乐临死无怖
  来生受富乐　　故应恒事法
  唯法是正治　　因法天下爱
  若主感民爱　　现来不被诳
  若非法治化　　主遭臣厌恶
  由世间憎恶　　现来不欢喜
  王法欺诳他　　是大难恶道
  恶智邪命论　　云何说为正
  若人专诳他　　云何说正事
  因此于万生　　恒遭他欺诳
  若欲使怨忧　　舍失取其德
  己利由此圆　　即令怨忧恼
  约施及爱语　　利行与同利
  愿汝摄世间　　因此弘正法
  王若一实语　　如生民坚信
  此如尊妄语　　不起他安信
  实意起无违　　流靡能利他
  是说名实语　　翻此为妄言
  一舍财若明　　如能隐王失
  如此主吝贿　　能害王众德
  若王静诸恶　　德深人爱重
  因此教明王　　故应事寂静
  由智王难动　　自了不信他
  永不遭欺诳　　故决应修智
  依谛舍静智　　王则具四善
  如四德正法　　人天所赞叹
  能伏说清净　　由智悲无垢
  恒共智人集　　王法智生长
  善说人难得　　听善言亦难
  第三人最胜　　能疾行善教
  若善非所爱　　已知应疾修
  如药味虽苦　　乐差应强服
  寿无病王位　　恒应思无常
  次生厌怖想　　后专心行法
  见决定应死　　死从恶见苦
  智人为现乐　　故不应作罪
  见一念无怖　　若见后时畏
  若一念心安　　云何后不畏
  由酒遭他轻　　损事减身力
  由痴行非事　　故智人断酒
  围棋等嬉戏　　生贪嗔忧谄
  诳妄恶口因　　故应恒远离
  淫逸过失生　　由想女身净
  寻思女身中　　实无一毫净
  女口涎唾器　　齿舌垢臭秽
  鼻臭由洟流　　目泪种类处
  腹屎尿肠器　　余身骨肉聚
  痴人迷可厌　　故贪着此身
  根门最臭秽　　是厌恶身因
  于中若生爱　　何缘得离欲
  譬如屎尿器　　猪好在中戏
  于身不净门　　多欲戏亦尔
  此门所以生　　为弃身土秽
  痴人邪爱着　　不顾己善利
  汝自见一分　　屎尿等不净
  此聚说名身　　云何汝生爱
  赤白为生种　　厕汁所沷养
  如知身不净　　何意苦生爱
  秽聚可憎恶　　臭湿皮缠裹
  若能处中卧　　则爱着女身
  若可爱可憎　　衰老及童女
  女身皆不净　　汝何处生欲
  设粪聚好色　　软滑相端正
  起爱则不应　　爱女身亦尔
  内臭极不净　　外皮所覆藏
  是死尸种性　　云何见不知
  皮不净如衣　　不可暂解浣
  云何秽聚皮　　可权时汰净
  画瓶满粪秽　　外饰若汝憎
  此身秽种满　　云何汝不厌
  若汝憎不净　　云何不恶身
  香华鬘饮食　　本净而能污
  如汝并憎恶　　于自他粪秽
  云何汝不厌　　自他不净身
  如女身不净　　自身秽亦尔
  是故离欲人　　于内外相称
  九门流不净　　自证自浣濯
  若不知不净　　而造爱欲论
  希有极无知　　无惭及轻他
  于最不净身　　何方利益汝
  多众生因此　　无明覆其心
  为尘欲结怨　　如狗斗争粪
  如搔痒谓乐　　不痒最安乐
  如此有欲乐　　无欲人最乐
  若汝思此义　　离欲不得成
  由思欲轻故　　不遭淫逸过
  从猎感短寿　　怖苦重逼恼
  未来决受此　　故应坚行悲
  何人若他见　　生彼极惊怖
  譬粪秽污身　　流出毒恶蛇
  是人若至彼　　众生得安乐
  譬夏月大云　　田夫见欲雨
  故汝舍恶法　　决心修善行
  为自他俱得　　无上菩提果
  是菩提根本　　心坚如山王
  因十方际悲　　及无二依智
  大王汝谛听　　此因我今说
  感三十二相　　能庄严汝身
  支提圣尊人　　供养恒亲侍
  手足宝相轮　　当成转轮王
  手足滑柔软　　身大七处高
  由施美饮食　　于他等丰足
  身圆满端直　　指足跟圆长
  汝当感长寿　　由悲济死囚
  大王坚持法　　令清净久住
  由此足安平　　当得成菩萨
  行布施爱语　　利行及同利
  由此指网密　　手足八十文
  脚趺高可爱　　旋毛端向上
  由长不弃背　　本所受持法
  由恭敬施受　　明处及工巧
  故得鹿王膞　　及聪明大智
  他求自有物　　我疾能惠施
  由此臂佣大　　得为世化主
  亲爱若别离　　菩萨令和集
  此感阴藏相　　恒服惭羞衣
  常施楼殿具　　细软可爱色
  故感天色身　　润滑光微妙
  由施无上护　　如理顺尊长
  感一孔一毛　　白毫端严面
  常说善爱语　　又能顺正教
  上身如师子　　颈圆喻甘浮
  看病给医药　　或令他养护
  故得腋下满　　千脉别百味
  于自他法事　　常能为端首
  顶骨郁尼沙　　横竖颊匿瞿
  由长时巧说　　实美滑善言
  得八相梵音　　及舌根修广
  已知事实利　　数数为他说
  得好如师子　　面门方可爱
  由尊他不轻　　随顺行正理
  齿白齐必胜　　譬若真珠行
  由数习此言　　谓实不两舌
  故具四十齿　　平滑坚遒净
  由瞻视众生　　滑无贪嗔痴
  眼珠青滑了　　睑睫如牛王
  由如此略说　　大人相及因
  转轮王菩萨　　美饰汝应知
  随相有八十　　从慈悲流生
  大王我不说　　为避多文辞
  虽诸转轮王　　同有此相好
  净明及可爱　　终不逮如来
  从菩萨善心　　一念中一分
  轮王相好因　　尚不能等此
  一人万亿劫　　修善根生长
  于佛一毛相　　此因亦不感
  诸佛与轮王　　相中一分等
  譬如萤与日　　于光微有似

    宝行王正论菩提资粮品第三

  诸佛大相好　　从难思福生
  我今为汝说　　依大乘阿舍
  一切缘觉福　　有学无学福
  及十方世福　　福如世难量
  此福更十倍　　感佛一毛相
  九万九千毛　　一一福皆尔
  如此众多福　　生佛一切毛
  复更百倍增　　方感佛一好
  如是如是多　　一一好得成
  乃至满八十　　随饰一大相
  如是福德聚　　能感八十好
  合更百倍增　　感佛一大相
  如是多福德　　能感三十相
  复更百倍增　　感毫如满月
  能感白毫福　　复更千倍增
  此福感难见　　顶上郁尼沙
  如此无量福　　方便说有量
  于一切十方　　如说十倍世
  诸佛色身因　　尚如世无量
  况佛法身因　　而当有边际
  世间因虽小　　若果大难量
  佛因既无量　　果量云何思
  诸佛有色身　　皆从福行起
  大王佛法身　　由智慧行成
  故佛福慧行　　是菩提正因
  故愿汝恒行　　菩提福慧行
  于成菩提福　　汝莫堕沈忧
  有理及阿舍　　能令心安信
  如十方无边　　空及地水火
  有苦诸众生　　彼无边亦尔
  此无边众生　　菩萨依大悲
  从苦而拔济　　愿彼般涅槃
  从发此坚心　　行住及卧觉
  或时小放逸　　无量福恒流
  福量如众生　　恒流无间隙
  因果既相称　　故菩提不难
  时节及众生　　菩提与福德
  由此四无量　　菩萨坚心行
  菩提虽无量　　因前四无量
  修福慧二行　　云何难可得
  福慧二种行　　如此无边际
  菩萨身心苦　　故疾得消除
  恶道饥渴等　　身苦恶业生
  菩萨永离恶　　行善苦不生
  欲嗔怖畏等　　心苦从痴生
  由依无二智　　菩萨离心苦
  有苦时若促　　难忍何况多
  无苦时长远　　有乐云何难
  身苦永不有　　假说有心苦
  悲世间二苦　　故恒住生死
  故菩提长时　　智人心不沈
  为灭恶生善　　是时无间修
  贪嗔及无明　　愿汝识舍离
  无贪等众善　　知应恭敬修
  由贪生鬼道　　由嗔堕地狱
  由痴入畜生　　翻此感人天
  舍恶及修善　　此法是乐因
  若是解脱法　　由智舍二执
  佛像及支提　　殿堂并寺庙
  最胜多供具　　汝应敬成立
  坐宝莲花上　　好色微妙画
  一切金宝种　　汝应造佛像
  正法及圣众　　以命色事护
  金宝网伞盖　　奉献覆支提
  金银众宝花　　珊瑚琉璃珠
  帝释青大青　　金刚贡支提
  能说正法人　　以四事供养
  六和敬等法　　常应勤修行
  于尊恭敬听　　勤事而侍护
  菩萨必应行　　亡后亦供养
  于天外道众　　不应亲事礼
  因无知邪信　　莫事恶知识
  佛阿含及论　　书写读诵施
  亦惠纸笔墨　　汝应修此福
  于国起学堂　　雇师供学士
  兴建永基业　　汝行为长慧
  解医巧历数　　皆为立田畴
  润老小病苦　　于国有济益
  起诸道伽蓝　　园塘湖亭屋
  于中给生具　　草蓐饮食薪
  于小大国土　　应起寺亭馆
  远路乏水浆　　造井池施饮
  病苦无依贫　　下姓怖畏等
  依慈悲摄受　　勤心安立彼
  随时新饮食　　果菜及新谷
  大众及须者　　未施莫先用
  屣伞瓶钩镊　　针綖及扇等
  荃提寝息具　　应施寺亭馆
  三果及三辛　　蜜糖酥眼药
  恒应安息省　　书咒及药方
  涂首身药油　　澡盘灯糗果
  水器及刀斧　　应给亭馆中
  米谷麻饮食　　糖膏等相应
  恒置阴凉处　　及净水满器
  于蚁鼠穴门　　饮食谷糖等
  愿令可信人　　日日分布散
  如意前后食　　恒施于饿鬼
  狗鼠鸟蚁等　　愿汝恒施食
  灾疫饥饿时　　水旱及贼难
  国败须济度　　愿汝恒拯恤
  田夫绝农业　　愿给粮种具
  随时蠲租税　　轻微受调敛
  施物济贫债　　出息不长轻
  直防许休偃　　以时接宾客
  境内外劫盗　　方便断令息
  随时遗商侣　　平物价钧调
  八座等判事　　自如理观察
  事能利万姓　　恒恭敬修行
  应作何自利　　如汝恒敬思
  利他云何成　　如此汝急思
  地水风火等　　草药及野树
  如此或暂时　　受他无碍策
  七步顷起心　　为舍内外财
  菩萨福德成　　难量如虚空
  童女好色严　　惠施求得者
  故获陀罗尼　　能持一切法
  爱色具庄严　　并一切生具
  施八万童女　　释迦佛昔时
  光明种种色　　衣服庄严具
  花香等应施　　依悲惠求者
  若人离此缘　　于法无安行
  则应施与之　　过此后莫惠
  毒亦许施彼　　若此能利他
  甘露不许施　　若此损害他
  若蛇啮人指　　佛亦听则除
  或佛教利他　　逼恼亦可行
  固谨持正法　　及能说法人
  恭敬听受法　　或以法施他
  莫爱世赞叹　　恒乐出俗法
  如立自体德　　于他亦如此
  于闻莫知足　　及思修实义
  于师报恩施　　应敬行莫吝
  莫读外邪论　　但起诤慢故
  不应赞自德　　怨德亦可赞
  莫显他密事　　及恶心两舌
  自于他有过　　如理观悔露
  若由此过失　　智者诃责他
  自须离此失　　有能拔济他
  他辱己莫嗔　　即观宿恶业
  莫报对他恶　　为后不受苦
  于他应作恩　　莫希彼报答
  唯自应受苦　　共求众受乐
  若得大富贵　　自高不应作
  遭枉如饿鬼　　莫起下悲行
  假设失王位　　或死由实言
  亦恒说此语　　无实利默然
  如言如此行　　愿汝坚行善
  因此好名遍　　自在成胜量
  应作熟简择　　后则依理行
  莫由信他作　　须自了实义
  若依理行善　　好名遍十方
  王侯续不断　　王富乐转大
  死缘百一种　　寿命因不多
  此因或死缘　　故恒应修善
  若人恒行善　　是所得安乐
  于自他若等　　此善乐圆足
  依法为性人　　卧觉常安乐
  梦中见善事　　由内无过恶
  若人养父母　　恭奉自家尊
  恭善人用财　　忍辱有大度
  软语不两舌　　实言同止乐
  此九天帝因　　尽寿应修行
  由昔行九法　　天主感帝位
  时时处法堂　　至今恒说此
  一日三时施　　美食三百器
  福不及刹那　　行慈百分一
  天人等爱护　　日夜受喜乐
  免怨火毒杖　　是行慈现果
  无功用获财　　后生于色界
  得慈十功德　　若人未解脱
  教一切众生　　坚发菩提心
  菩萨德如山　　菩提心牢固
  由信离八难　　因戒生善道
  数修真如空　　得善无放逸
  无谄得念根　　恒思得慧根
  恭敬得义理　　护法感宿命
  布施听闻法　　或不障他闻
  疾得如所爱　　与佛相值遇
  无贪作事成　　不悭财物长
  离慢招上品　　法忍得总持
  由行五实施　　及惠无怖畏
  非诸骂能辱　　故感大胜力
  支提列灯行　　幽闇秉火烛
  布施续明油　　故得净天眼
  供养支提时　　即设鼓声乐
  蠡角等妙音　　故获净天耳
  于他失默然　　不谈人德阙
  随顺护彼意　　故得他心智
  由施徙舟乘　　运致羸乏人
  恭谨瞻尊长　　故获如意通
  令他忆法事　　及正法句义
  或净心施法　　故感宿命智
  由知真实义　　谓诸法无性
  故得第六通　　最胜是流尽
  平等悲相应　　由修如实智
  故自得成佛　　恒解脱众生
  由种种净愿　　故佛土清净
  众宝献支提　　故放无边光
  如此业及果　　已知义相应
  故应修利他　　即菩萨自利

    宝行王正论正教王品第四

  王若行非法　　或作非道理
  事王人亦赞　　故好恶难知
  亦有世间人　　非爱善难教
  何况大国王　　能受善人语
  我今愍念汝　　及悲诸世间
  故我善教汝　　实益若非爱
  真滑有义利　　依时由慈悲
  佛令教弟子　　故我为汝说
  若听闻实语　　应住于无嗔
  可取必须受　　如浴受净水
  我今说善言　　现来有利益
  汝知应受行　　为自及于世
  由昔施贫苦　　故今感富财
  因贪不知恩　　废施无更得
  世间唯路粮　　不雇无人负
  由施供下品　　未来荷百倍
  愿汝发大心　　恒兴建大事
  若行大心事　　是人得大果
  小意陜劣王　　心愿未曾触
  好名吉祥事　　三宝依应作
  望王后等毛　　若事非汝法
  死亦起恶名　　王不作最胜
  广大事能起　　大人希有用
  能障下人愿　　以命成此事
  无自在弃物　　只身入未来
  若于法安财　　前至逆相待
  先帝诸产业　　弃本属新王
  能为前王生　　法乐好名不
  用财受现喜　　若施感来乐
  非此二唐失　　唯生苦无欢
  将终欲行施　　臣碍失自在
  祚绝故舍爱　　随新王乐欲
  若舍一切物　　汝今安弘法
  亦常在死缘　　譬如风中灯
  先诸王所起　　平等功德处
  谓天神庙堂　　愿如本修理
  离杀常行善　　持戒爱容旧
  巧增财无诤　　勤力恒修善
  清净无积聚　　不舍于他事
  安立为导首　　受彼功德藏
  盲病根不具　　可悲丐无依
  于庙不得遮　　平等与彼食
  道德无求人　　或住余王界
  供事亦相似　　应作无此彼
  于一切法事　　应立勤力人
  无贪聪智善　　不侵法畏罪
  了正论行善　　亲爱四观净
  美语不怯弱　　上姓能持戒
  识恩知他苦　　如理巧决断
  八人互相羞　　为国立八座
  柔和有大度　　胆勇甚爱王
  坚实能用财　　无放逸恒善
  熟思所作事　　能别十二轮
  常行四方便　　应立为大臣
  持法戒清净　　了事有干用
  能生长护财　　解义巧书算
  于他心事等　　畏罪亲爱王
  富财多眷属　　宜立为职掌
  月月应问彼　　一切财出入
  问己法事等　　喜心善教诲
  为法处王位　　不求名欲尘
  王位胜有利　　异此则不如
  大王即世间　　多互相食啖
  立法王位义　　汝谛听我说
  长老于王处　　上族解是非
  畏恶多相顺　　愿彼看王事
  罚系鞭杖等　　若彼依理行
  王恒润大悲　　于彼更施恩
  为利一切人　　应恒起慈心
  若彼最重恶　　亦应生大悲
  重恶极害心　　必于彼行悲
  彼即是悲器　　正行人悲境
  贫人若被驻　　五日须放散
  余人亦如理　　随一莫拘留
  若于一人所　　起长系驻心
  随人生不护　　因此恶恒流
  乃至彼未散　　虽系亦安乐
  庄饰浣饮食　　药扇等相应
  王欲他成器　　依悲立善教
  善恶人皆同　　不由嗔及欲
  熟思实知已　　人增起反逆
  不杀不逼彼　　愿王摈他土
  看自家如怨　　由参人净眼
  恒念无放逸　　愿作如法事
  赏重加供养　　有恩人令得
  如思德胜负　　报偿亦如是
  将接为饶花　　赏施为大果
  王树忍辱影　　民鸟遍依事
  王持戒能施　　有威得物心
  譬如沙糖丸　　香剌味相杂
  若王依道理　　愚法则不行
  无难无非法　　恒有法欢乐
  不从昔世引　　不可将入来
  王位从法得　　为位莫坏法
  王位如肆家　　若传如所价
  为不更求得　　此用汝应行
  王位如肆家　　王传如所价
  为欲更求得　　此用应修行
  转轮王得地　　或具四天下
  但身心二乐　　余富贵皆虚
  但对治众苦　　谓身喜乐受
  心乐是想类　　皆分别所作
  对治苦为体　　及分别为类
  世间一切乐　　虚故无真实
  洲处土居止　　坐处及衣等
  饮食卧具乘　　妻象马用一
  若心随一缘　　即由彼生乐
  余境非缘故　　是时虚无用
  五根缘五尘　　若心不分别
  虽复得成尘　　不由此生乐
  此尘根所缘　　余则非能所
  故所余根尘　　真实无有义
  此尘根所缘　　心取过去相
  分别起净想　　于彼生乐受
  一尘心所缘　　心尘不同世
  既离心非尘　　离尘亦非心
  以父母为因　　汝说有子生
  如此缘眼色　　说有识等生
  去来世根尘　　不成由无义
  不出二世故　　现尘根无义
  如眼见火轮　　由根到乱故
  于现在尘中　　根缘尘亦尔
  五根及境界　　是四大尘类
  一一大虚故　　尘根非不有
  若大各离成　　离薪火应然
  若离无别体　　尘亦同此判
  四大二义虚　　故不成和同
  既实无和同　　故色尘不成
  识受想及行　　一一体不成
  不合乘缘生　　非有故无合
  如分别喜乐　　缘苦对治成
  如此所计苦　　因乐坏故成
  于乐和合爱　　缘无相则灭
  于苦远离贪　　由此观不生
  若依世言说　　心为能见者
  不然离所见　　能见不成故
  观行睹世间　　如幻实不有
  无取无分别　　般涅槃如火
  菩萨见如此　　于菩提不退
  由大悲引故　　后相续至佛
  诸菩萨修道　　佛说于大乘
  无智憎嫉人　　自害拨不受
  不识功德失　　于德起失想
  或憎嫉胜利　　故人谤大乘
  若知罪损他　　功德能利益
  故说诽谤人　　不识憎嫉善
  由不观自利　　一味利益他
  大乘众德器　　故谤人灰粉
  信人由僻执　　不信由嫉憎
  信人谤尚烧　　何况嗔妒者
  合毒为治毒　　如医方所说
  苦灭恶亦尔　　此言何相违
  诸法心先行　　以心为上首
  以苦灭他恶　　善心人何过
  苦来若能利　　应取何况乐
  或于自及他　　此是本首法
  由能弃小乐　　后若见大乐
  智人舍小乐　　观于后大乐
  若不忍此言　　医师施苦乐
  犯罪不可恕　　故汝义不然
  或见事不宜　　智者由义行
  或制或开许　　此义处处有
  诸菩萨威仪　　悲为先智成
  大乘说如此　　何因可诽谤
  无知故沉没　　上乘广深义
  故诽谤大乘　　成自他怨家
  施戒忍精进　　定智悲为体
  佛说大乘尔　　有何邪说漏
  由施戒利他　　忍进为自利
  定慧脱自他　　略摄大乘义
  略说佛正教　　谓解脱自他
  此六度为藏　　何人能拨此
  福慧为种类　　佛说菩提道
  立此名大乘　　痴盲不能忍
  如空难思量　　福慧行成故
  诸佛德难思　　于大乘愿忍
  大德舍利弗　　佛戒非其境
  故佛德难思　　云何不可忍
  于大乘无生　　小乘说空灭
  无生灭一体　　自义莫违反
  真空及佛德　　若如法简择
  大小两乘教　　于智人何诤
  佛不了义说　　非下人易解
  一三乘说中　　护自体莫伤
  若舍无非福　　若憎恶无善
  若欲爱自身　　大乘不应谤
  菩萨愿及行　　回向等彼无
  若依小乘修　　云何成菩萨
  菩萨道四依　　于小乘不说
  何法佛所修　　而说能胜彼
  约依谛助道　　佛与彼若同
  修因既不异　　云何果殊越
  菩提行总别　　小乘中不说
  于大乘具辩　　故智应信受
  如毗伽罗论　　先教学字母
  佛立教如此　　约受化根性
  有处或说法　　令彼离众恶
  或为成福德　　或具依前二
  或为遣此二　　甚深怖劣人
  或深悲为上　　为他成菩提
  是故聪明人　　应舍憎大乘
  当起胜信受　　为得无等觉
  由信受大乘　　及行大乘教
  故成无上道　　中间种种乐
  施戒及忍辱　　多为在家说
  此法悲为上　　愿汝修成性
  由世不平等　　王位若乖法
  为好名及法　　事及出家胜

    宝行王正论出家正行品第五

  初学出家人　　敬心修禁戒
  于木叉毗尼　　多学破立义
  次起正勤心　　舍离粗类惑
  数有五十七　　谛听我当说
  怪谓心相违　　恨是结他失
  覆恶罪名秘　　及着恶显善
  张他名欺诳　　谄谓曲心续
  嫉于他德忧　　吝心怖畏舍
  无羞及无惭　　于自他为耻
  不下不敬他　　动乱嗔方便
  醉谓不计他　　放逸不修善
  慢类有七种　　我今当略说
  若人起分别　　从下下等等
  从下及等胜　　说此惑为慢
  下人计自身　　不如于等人
  说此名下慢　　由自下等类
  下人高自身　　与胜人平等
  此惑名高慢　　由自高等胜
  下人计自己　　胜于胜类人
  说此名过慢　　如痈上起泡
  于五种取阴　　自性空无人
  由痴故计我　　说此名我慢
  实未得圣道　　计自身已得
  由修偏道故　　说名增上慢
  若人由作恶　　而计自身胜
  兼复拨他德　　说此名邪慢
  我今无复用　　或能下自体
  此亦名下慢　　但缘自体起
  为求利养赞　　故守摄六根
  能隐贪欲意　　此惑名贡高
  为得利供养　　于他起爱语
  此惑缘世法　　说此名谢言
  为欲得彼物　　若赞美此财
  说名为现相　　能示自心故
  为欲得所求　　现前非拨他
  说名为诃责　　能伏彼令顺
  由施欲求利　　或赞彼先德
  说名利求利　　此五邪命摄
  若人缘他失　　心数种种诵
  说名为愔隘　　此或习恨心
  惊怖不能安　　由无知及病
  于下粗自具　　毁呰及懈着
  欲嗔痴污想　　说名种种相
  不如现观察　　说名非思惟
  于正事懈怠　　说名不恭敬
  于师无尊心　　说名不尊重
  上心欲所起　　于外名坚着
  上心坚欲生　　最重名遍着
  自财生长欲　　无足心名贪
  爱着于他物　　是名不等欲
  于非境女人　　求得非法欲
  自无德显德　　说名为恶欲
  离知足恒求　　说此名大欲
  愿他知我德　　说名为识欲
  不能安苦受　　说名为不忍
  于师尊正事　　邪行名不贵
  如法善言教　　轻慢名难语
  于亲人爱着　　思惟名亲觉
  由欲于方处　　思得名土觉
  不虑死怖畏　　说名不死觉
  由真实功德　　愿他尊重我
  此思缘他识　　说名顺觉觉
  由爱及憎心　　思自益损他
  缘自及余人　　说名害他觉
  忧忆染污心　　无依名不安
  身沈说名极　　迟缓名懈怠
  由随上心惑　　曲发身名频
  身乱不节食　　说名为食醉
  身心极疲羸　　说名为下劣
  贪爱于五尘　　说名为欲欲
  于他损害意　　从九因缘生
  三时疑灾横　　说名为嗔恚
  由身心重故　　事无能名弱
  心晦说名睡　　身心掉名动
  由恶事生悔　　忧后燋然名
  于三宝四谛　　犹豫说名疑
  若出家菩萨　　须离此粗类
  若能免此恶　　对治德易生
  此中诸功德　　菩萨应修治
  谓施戒及忍　　勤定慧悲等
  舍自物名施　　起利他名戒
  解脱嗔名忍　　摄善名精进
  心寂静名定　　通真义名智
  于一切众生　　一味利名悲
  施生富戒乐　　忍爱勤焰炽
  定静智解脱　　悲生一切利
  此七法若成　　俱得至究竟
  难思智境界　　今到世尊位
  如于小乘中　　说诸声闻地
  于大乘亦尔　　说菩萨十地
  初地名欢喜　　于中喜希有
  由三结灭尽　　及生在佛家
  因此地果报　　现前修施度
  于百佛世界　　不动得自在
  于剡浮等洲　　为大转轮王
  于世间恒转　　宝轮及法轮
  第二名无垢　　身口意等业
  十种皆清净　　自性得自在
  因此地果报　　现前修戒度
  于千佛世界　　不动得自在
  仙人天帝释　　能除天爱欲
  天魔及外道　　皆所不能动
  第三名明焰　　寂慧光明生
  由定及神通　　欲嗔惑灭故
  因此地果报　　现前修忍辱
  于万佛世界　　不动得自在
  作夜摩天帝　　灭身见习气
  一切邪师执　　能破能正教
  第四名烧然　　智火光焰生
  因此地果报　　精进度现前
  多修习道品　　为灭惑生道
  兜率陀天主　　除外道见戒
  由得生自在　　于十方佛土
  往还无障碍　　余义如前地
  第五名难胜　　魔二乘不及
  圣谛微细义　　证见所生故
  因此地果报　　定度得现前
  为化乐天主　　回二乘向大
  第六名现前　　正向佛法故
  由数习定慧　　证得灭圆满
  因此地果报　　般若度现前
  他化自在天　　能教真俗谛
  第七名远行　　远行数相续
  于中念念得　　无生及无灭
  因此地果报　　方便智现前
  得为大梵王　　能通第一义
  证方便胜智　　六度生无间
  于三乘世俗　　为最第一师
  童子地不动　　由不出真观
  无分别难思　　非身口意境
  因此地果报　　愿度常现前
  胜遍光梵主　　净土等自在
  二乘等不及　　于真俗一义
  俱修动静故　　行二利无间
  第九名善慧　　法王太子位
  此中智最胜　　由通达四辩
  因此地果报　　力度常现前
  为遍净梵王　　四答难无等
  第十名法云　　能雨正法雨
  佛光水灌身　　受佛灌顶位
  因此地果报　　智度常现前
  为净居梵王　　大自在天王
  智慧境难思　　诸佛秘密藏
  得具足自在　　后生补处位
  如此菩萨地　　十种我已说
  佛地与彼异　　具胜德难量
  此地但略说　　十力等相应
  随此一一力　　难量如虚空
  如此等可言　　诸佛无量德
  如十方虚空　　及地水火风
  诸佛无量德　　于余人难信
  若不见此因　　难量如此果
  为此因及果　　现前佛支提
  日夜各三遍　　愿诵二十偈
  诸佛法及僧　　一切诸菩萨
  我顶礼归依　　余可尊亦敬
  我离一切恶　　摄持一切善
  众生诸善行　　随喜及顺行
  头面礼诸佛　　合掌劝请住
  愿为转法轮　　穷生死后际
  从此行我德　　已作及未作
  因此愿众生　　皆发菩提心
  度一切障难　　圆满无垢根
  具净命相应　　愿彼自在事
  一切具无边　　与宝手相应
  穷后际无尽　　愿众生如此
  愿一切女人　　皆成胜丈夫
  恒于一切时　　明足得圆满
  胜形貌威德　　好色他爱见
  无病力办具　　长寿愿彼然
  解脱诸苦畏　　一向归三宝
  于方便善巧　　佛法为大财
  慈悲喜净舍　　恒居四梵住
  施戒忍精进　　定智所庄严
  圆满福慧行　　相好光明照
  愿彼难思量　　行十地无碍
  与此德相应　　余德所庄严
  解脱一切过　　愿我爱众生
  圆满一切善　　及众生所乐
  能除他众苦　　愿我恒如此
  若他有怖畏　　一切时及处
  由唯忆我名　　得脱一切苦
  敬信我及嗔　　若见及忆持
  乃至闻我名　　愿彼定菩提
  愿我得五通　　恒随一切生
  愿我恒能生　　众生善及乐
  若他欲作恶　　于一切世界
  愿遍断彼恶　　如理令修善
  如地水火风　　野药及林树
  如他欲受用　　愿我自忍受
  愿我他所爱　　如念自寿命
  愿我念众生　　万倍胜自爱
  愿彼所作恶　　于我果报熟
  是我所行善　　于彼果报熟
  一人未解脱　　于有随生道
  愿我为彼住　　不先取菩提
  能如此修行　　福德若有体
  于恒沙世界　　其功不可量
  佛世尊自说　　如此因难量
  众生界无量　　利益愿亦尔
  此法我略说　　能生自他利
  愿汝爱此法　　如爱念自身
  若人爱此法　　是实爱自身
  是所爱应憎　　此憎由法成
  故事法如身　　事行如事法
  如行事慧然　　如慧事智者
  净顺有智慧　　伏他说正理
  由自恶疑他　　此人损自事
  是诸善知识　　汝应知略相
  知足慈悲戒　　智慧能灭恶
  善友应教汝　　汝知敬顺行
  由内外胜德　　汝必至胜处
  实誓说爱言　　乐性不可动
  正事增谄曲　　愿汝自易教
  已舍无有悔　　有焰炽心寂
  无懈缓掉动　　不贡高和同
  愿清凉如月　　有炽盛如日
  甚深如大海　　坚住如山王
  一切果所离　　众德所庄严
  众生所受用　　愿汝一切智
  我不但为王　　说如此善法
  如理为余人　　由欲利一切
  大王此正论　　汝日日谛听
  为令自及他　　得无上菩提
  胜戒敬尊长　　忍辱无嫉妒
  不吝财知足　　救济堕难事
  能行善恶人　　摄持及制伏
  弘护佛正法　　求菩提应行

宝行王正论一卷


辟支佛因缘论

    No. 1650

辟支佛因缘论卷上

        失译人名今附秦录

波罗奈国王悟辟支佛缘

辅相苏摩悟辟支佛缘

月爱大臣悟辟支佛缘

    波罗奈国王悟辟支佛缘

  归命一切智世尊　　了达三世大灯明
  归命无上出要法　　并及应真诸胜僧
  我闻寂静辟支佛　　悟解因缘之所行
  心无瑕秽除烦恼　　善护禁戒常清净
  譬如秋天无云翳　　淡泊自守林薮间
  今我渴仰彼功德　　诚心敬顺生信乐
  虽于彼所欲怀疑　　彼力感我强令信
  孰闻快士清真行　　而不生于敬信心
  我今将说辟支佛　　功德妙行之少分
  昔从先师相传闻　　唯述正言无伪说
  大象行道象子随　　是故我今开显示

问曰。辟支佛以何因缘。默然自守恒入舍心。住于山林幽谷河侧寂静之处。心行寂故。亦无言说。譬如犀角独一之行。何故如是

又问。辟支佛有何功德。答曰。宿旧诸师咸作是说

昔佛于三十三天宫殿说法。将欲来下还阎浮提

尔时帝释敕毗首羯磨。为佛作三道宝阶。还阎浮提。此三道阶下柱僧尸沙国。如来尔时从彼天宫乘阶而下。时释梵天王与其眷属。雨华供养。时莲华比丘尼见佛来下。即便化作转轮圣王威仪形像七宝导从。时众人等睹其如是。咸皆生疑。怪未曾有。各作是言。颇复有能神力超绝踰胜于彼比丘尼不

尔时世尊。见诸时众睹三道阶深生奇特。复见莲华比丘尼作此神变咸生渴仰。为欲增长彼信心故。即告时会。有辟支佛。神力过于彼比丘尼。云何名胜彼快士者。佛未出世则于中出。为诸众生而作利益。示其色相。现有饥渴。受取衣食。为作福田。庄严法行。清净寂灭。调伏离欲。令诸众生得见之者。恶心永息舍离刀仗。犹如犀角独一之行

传从诸师得闻此事。闻何事耶。我昔曾闻。迦叶佛时有人出家。于十千岁修行梵行护持正戒。修行忍辱迳常精勤。以修行故。众多比丘皆来亲近。时诸比丘咸作是言。当教授我。以教习故。是等比丘心皆甘乐。以众闹故不得见谛。临终之时而作是念。我见十力其所说法。微妙深远难可得闻。然我得闻。以放逸故不获道果。我虽清净持戒能行忍辱以教化众人。愦闹之故侵毁定心。如彼霜雹害于善苗。是故令我不获道果。即说偈言

  我今溺三有　　众恶烦恼中
  犹如老瘦象　　没于深淤泥
  如彼辟支佛　　独处于林间
  譬如犀一角　　远离诸徒众
  如避猛炽火　　应当独修行
  远离于愦闹　　愿我常远离
  徒党众愦闹

发是誓愿。命终生天天上受乐。福尽命终生迦尸国。波罗奈城中梵摩达王第一夫人胎中。入胎之时夫人身体。譬如清池有柔软花。尔时夫人觉有娠已。以偈白王

  我觉有娠来　　欢悦生恩惠
  此必是儿志　　宜应赦有罪
  时王闻欢喜　　寻即赦天下
  又复白王言　　复应广布施
  王闻益欢喜　　寻即开库藏
  赈赐贫穷人　　无不充足者

尔时夫人生太子已。端政殊特。如似满月。年始八岁聪明慈仁。其父王崩。国人爱乐如盛满月。时有辅相名曰言说。言说辅相。即立太子以绍王位。虽复年稚本誓愿力。不作众恶体性贤善。于诸众生有深悲愍。虽处王宫志求闲静。虽处华堂犹如冢间。虽处愦闹修行禅思。厌患生死称量其过。以道修心弃舍王务。诸臣谏曰。今日大王。专行道行不理国事。若如是者。众恶必起败王风化。譬如渡海。若无船师必为诸难之所败坏。即说偈言

  王承祖先嗣　　籍地如法得
  唯垂理万民　　愿莫放舍国
  若王正法治　　诸善无过者
  人帝应当知　　护国福最胜

尔时其王闻是语已。叹息思惟。说偈答言

  我若不理国　　吾国必当败
  我力能护国　　边恶不敢侵
  我若治国者　　王务尘我心
  若有犯罪者　　必须加毁害
  当言系闭彼　　当截彼手足
  彼应入死罪　　彼应挑其眼
  如今浊恶世　　必当须刑戮
  若行刑戮者　　即是栴陀罗

时王即告所亲爱臣。汝今且听。吾所食者不过一味。吾所衣者不过一袭。所坐卧处不过容身。自此而观。何用多求而无厌足。王位所以称尊号者。以其教令必行无不承肃。唯有此事取异众庶。又告辅相。王者所重唯此一事。我今付汝。汝今应当畏于后世正法治国。赋敛依旧莫违常限。即说偈言

  我虽生王宫　　承籍祖先后
  而我未习学　　刑戮挝罚事
  我今怖畏故　　不能造此业
  汝今莫效我　　但当育民庶
  世人皆愚痴　　各自作愆过
  于所犯罪中　　复生其恐怖
  汝当以正法　　抚育施无畏
  当依于正法　　化导于民庶

时王说偈已。即便以国付此大臣。而此大臣既得国已。于二年中宽纵无度。不恤万民。恣心极意。作诸非法渐渐经久。荣位深重便生憍逸。行诸非法如河暴涨多所损坏。城中富有一切税夺。时城内人皆谏之曰莫为此事。闻他忠言倍生嗔恚。颦蹙作色而作是言。汝等何敢发如是语。诸人惧畏不敢应王。由是之故。所行无道日日转盛。如火得干薪其炎转炽。淫荒暴乱所为勃逆。王所爱妇亦复妻掠。时王夫人见其如是。懊恼垂泪而往白王。嗔心猛盛唇口[目*需]动。言不解了。犹如婴见。以此情事具向王说。王闻是已即召令来。而语之言。我之妃后汝尚隐忍。能行非法。况复万民。王即教诫。自今已后更莫如是。时彼辅相。见王嫌已并民厌患。即便弃国逃至他土。将彼国王及其军众。还向本国规欲讨伐。时本国中诸旧辅相。将兵逆拒破其军众生擒将还。旧辅相等。复白王言。彼人侵毁于王。即将彼臣诣于王所。时王见其颜色既变有惭惧相。王曰。怪哉生死。即说偈言

  愚痴覆蔽心　　不觉后大苦
  为小乐缘故　　今受此惭耻
  譬如上善食　　色香皆具足
  其中杂毒药　　愚人不观察
  贪味故取食　　食消则成害

王告诸辅相。彼之愆过虽复尤重。然我意者不欲加害。复说偈言

  一切皆爱寿　　宜速赦彼罪
  不见害他命　　而得安乐者
  犯罪深重者　　应向生慈心
  彼自招罪害　　当宜生哀矜
  若害于彼命　　自毁所爱法

诸旧臣等即白王言。我等今者。虽违王敕必当加害。终不纵舍。即于王前拔剑斩之。王见杀已即生厌恶。见前境界。便见过去修忍之心。寻时开解悟辟支佛道。如优钵罗花开敷之时。踊身虚空。一切臣佐合掌仰瞻。辟支佛厌生死者。证道如是。我今所得持戒果报。即说偈言

  我虽服璎珞　　心修净梵行
  检身调伏根　　淡泊常寂灭
  于一切人所　　而舍兵刀杖
  修于独一行　　如犀牛一角

说是偈已须发自落。时净居天即奉袈裟。寻即飞空诣雪山中。时彼山中有辟支佛。而问之言。汝处王位。厌恶何事悟斯道迹。即说上偈而用答之。是故如来为不能修行忍故。故说忍辱因缘。以贪亲近愦闹故。故说不亲近因缘。欲使解辟支佛功德故。故说辟支佛因缘。佛为诸天于善法堂上。说辟支佛因缘。佛于三十三天。使诸天生厌恶故。故说斯事婆四咤辟支佛。于毗舍离。说舍身入涅槃。今现有塔。名优陀耶

    辅相苏摩悟辟支佛缘

  坚持禁戒不毁行　　诸有智者得解脱
  不从他学不恼彼　　独一之行如犀角

曾从诸师闻如是说。迦叶佛时有一比丘。于十千岁修行梵行。坐禅得忍修持禁戒。离于愦闹具头陀行。命终生天。于天宫中受五欲乐。从天寿尽。生婆翅多城辅相夫人提婆胎中。尔时夫人说偈白夫

  我今有娠　　心甚爱乐　　必有福人
  来为我子

由是之故。乃于一切常生悲愍。又我今者。放逸心息。更无欲意。譬如海中摩梨大山能截水波。今我欲息。亦复如是。我今畏于妄语。常思实语。又如功德善人畏于缺失。今我慎惧亦复如是。我今见酒如睹毒药。畏他财物如畏火聚。如是众恶今悉舍离。皆由我胎福德之子。淫欲既除用为快乐。尔时辅相即语妇言。今恣汝意修行五戒。夫人尔时修行众善。满十月已而生其子。字曰苏摩。渐渐长大。一切经论。六十四艺。无不明达。端正殊妙犹如满月。能使父母情愿满足。遂至盛年。辅相请王。我今年老当为后世听我修福。时王答言。我今不能于汝修福而为障碍。汝以汝子苏摩。使代汝处以供给我。任汝修善。辅相欢喜。王以苏摩用为辅相。给赐爵赏倍胜于父。众人爱敬。同于往古牛王大臣。能生一切女人爱敬。时王夫人爱着苏摩。语苏摩言。汝今若能称我愿者。能使举国并及于王尽随从汝。又能使汝不得恶名。其所施教与王无异。尔时苏摩执志坚固。而不怯弱。以偈答言

  请听所说　　莫见嫌责　　我闻此语
  如渗入地　　譬如羸马　　困乏之时
  骑入战阵　　不堪前进　　我见他妇
  情无染着　　心意不开　　如夜藕花
  凡在所敬　　与母无异　　况在夫人
  是我所尊　　我坚持心　　敬事所尊
  我为臣子　　不应为逆　　又我情欲
  发动之时　　见他妇女　　自然休息
  彼瀑水起　　多诸波涌　　我如秋水
  自然洁清　　尔时夫人　　心自念言
  彼若断我　　亲昵意者　　我必于彼
  而生诽谤　　即白王言　　辅相苏摩
  兴意无理　　欲侵辱我

时王意惑疑审尔不尔。时苏摩往至园苑。见两牛耕槅在项上极大疲苦。生厌恶心。时王本惑信夫人谗言。即便遣使往杀苏摩。尔时苏摩如马被射箭彻于骨。即自思惟。人当贵时。所爱之色尽来在前。如杂毒食极为香美食。欲消时身则败坏。如人贪五欲其味甚鲜。譬如金屋为火所烧。人贪其色入中被害。命欲尽时心意扰乱。即自安慰而自念言。我持净戒无有毁缺。我之持戒。知牦牛爱尾。我守禁戒。犹如贫人得地伏藏勤加守护。而说偈言

  粗涩崄恶道　　我已得度之
  我遭厄急事　　护戒而不舍
  犹如大海潮　　不失于期限
  今我守持戒　　其事亦如是

说是偈已。尔时诸天并诸善神。见此辅相誓愿如是。皆生欢喜。时诸恶鬼寻着夫人。夫人狂发。即于王前为鬼所著。而说偈言

  我今自坏破　　我应身受死
  彼是纯善人　　不应加伤害
  我之痴婴愚　　口吹须弥山
  不能令动摇　　彼实无秽行
  我妄生是谤

时彼辅相。于园苑中。思惟厌恶得辟支佛。踊升虚空须发自落。时净居天即奉袈裟。尔时诸人劝请之言。愿莫舍我而上天上。时辟支佛说如上偈。以答诸人。飞至雪山。见诸辟支佛。亦以上事。而具说之

    月爱大臣悟辟支佛缘

  海潮不过限　　牦牛守尾死
  如月性自冷　　不可变令热
  调伏诸根者　　守护戒亦尔
  是名独一行　　如犀角无二
  往昔诸大师　　展转相教授
  我从先胜闻　　今欲显说之

过去世时有辟支佛。名曰月爱。于婆伽婆迦叶佛所。种诸善根善修戒行。恒以智慧观于诸阴皆悉无常。于彼佛所竟不获得沙门道果。于彼命终即生天上。以宿善力受天快乐。天寿尽已下还人间。生瞻婆国中大长者家。初生冲雅。恒依戒禁而自修身。观其善行过于宿老。亦不轻躁。无有嗔嫌。所有资财周给贫乏。随家丰俭与众共分。以戒璎珞而自庄严。其父命终顺法治家。彼城人民见其忠谨。深生敬信同于师长。其年盛壮姿貌端政。诸少妇女。一切见者无不耽爱。诸商估客以其忠实咸来依附。于时北方有诸估客。多乘好马至瞻婆国。时瞻婆国王尽取其马。王心暴虐不依正法。王自思惟。我今多取彼马。云何当得不与价直而得其马。即与佞臣集议此事。佞臣白王言。若酬其价库藏竭尽。王即答言。我于今者若不与直。我之恶名流布天下。一切国民当患于我。复当断绝四方商估。佞臣复言。为王计者。不须钱财而得其马。复能令王恶名不出国民不患。今王国内月爱大臣。为一切人之所体信。彼若来索。王但当言。我遣月爱送金付汝。时彼估客有万匹马。其一一马各直一万金钱。若王但言月爱大臣与其直者。国内人民必生疑惑。或疑于王。或疑月爱。王之恶名不必彰露。亦复不为万民厌患。诸商估人来白王言。归我马价。我欲还家。王即答言。我先不使月爱偿尔价耶。宁可再过与尔直乎。诸估客等即答王言。此月爱者从先已来。实不与我马之价直。而彼忠信宁舍身命。终不妄语言与我价。即说偈言

  假使月雨火　　日雨于冷水
  压沙得膏油　　钻水而得酥
  火中生莲花　　欲令彼月爱
  作粗犷妄语　　终无有是处

诸估客等复白王言。人中之天。设使月爱审如王敕言与我者。我终不恨。时王即召月爱而语之言。汝先不在我前我与汝金偿一估客耶。王即动目现作诡相。汝不从我我定杀汝。时月爱臣私自思惟。我于今日。为从实语。为用王言。复自惟忖。为取法身胜耶。此身胜也。即自决计。我今宁舍此身。终不舍于戒法身。即说偈言

  我今自思惟　　于此二身中
  为当舍何身　　复谛自观察
  宁捐鄙秽形　　终不舍戒律
  若当舍法身　　恶名即流布
  我处众善手　　为彼所携持
  若我为恶者　　我自不甘乐
  心生悔热火　　舍此秽身已
  当趣于地狱　　自毁禁戒行
  终不得安乐　　但为一形乐
  亏损无量身　　若当护戒者
  无量身安乐　　是故我应当
  覆护于法身　　不令有毁坏
  为利正法故　　当断于妄语

月爱大臣即白王言。愿王开恩莫忿于我。我实不忆见王与彼价。时王即大怒扣剑而言。云何不见。月爱大臣自定其意。而作是念

  宁为圣法死　　不为愚痴生
  一切诸有生　　谁有不死者
  我今若受死　　为法故丧身
  决定生天上　　何足生惊畏

即答王言。假使王今切割我身碎如胡麻。所受禁戒终不放舍。今我住于仙圣道中。若以此舌作妄语者。非我所宜

我今若当为王故作妄语。后堕地狱。何所恃怙。王时羞愧。倍增嗔忿怒眼视之。如炽然火。月爱尔时心生欢喜。今正是我生定意时。今正是我秉持法时。更于何处欲求闻法。今日此即为我说法。今我为法乃至舍命。今王于我真大亲友。如是念法即时开悟。得辟支佛。踊身虚空。令破戒者见其如是皆生惭愧。为修善者增长信行。为实语者现实事果。于虚空中须发自落。时净居天奉其法服。飞往香山。与诸辟支佛。共集一处。说偈如上

辟支佛因缘论卷上辟支佛因缘论卷下

        失译人名今附秦录

王舍城大长者悟辟支佛缘

波罗奈国王月出悟辟支佛缘

拘舍弥国王大帝悟辟支佛缘

拘舍弥国王悟辟支佛缘

波罗奈国王亲军悟辟支佛缘

转轮圣王最小子悟辟支佛缘

    王舍城大长者悟辟支佛缘

  譬如稠林中　　欲挽大树出
  枝柯相妨碍　　求出将无由
  在家如稠林　　众务如枝柯
  虽欲求出要　　缚着永无因
  静处于林野　　观境修其心
  解脱众缘务　　离诸所亲爱
  修于独一行　　如犀角无二
  先师相传授　　我得闻斯事

昔有辟支佛。于过去五佛所恒修诸善。为优婆塞乐着家事。虽睹诸佛不求出家。然其专心持在家戒。无有毁犯。善根渐增。于迦叶佛所出家学道。乐修头陀六物具足。厌恶于欲。于彼命终得生天宫。从天寿尽。生王舍城大长者家。此长者家财富无量仓库盈溢。以渐长大遂至盛年。父命终后从意快乐。如毗沙门子那罗究伏罗。在己家中乐诸缘务。生育男女各三十人。库藏仆从其数甚众。男女婚娶其事众多。但营目前忘所修法。为缘务所缚。不舍家业于仆从所闻诸亲戚多有死丧。女某甲舍既遭丧祸又失业。焉广闻如是丧失之声。愁毒懊恼。如似百箭一时入心。亦闻美善可爱之语。家之估客大获珍宝。安隐还归。其子某甲产生男儿。又闻已女生于福子。复生欢喜。闻向衰利。忧喜交集。犹如作伎所旋之轮。与一亲友至园苑中。适行游观到一林间。见有一人斫于大树。枝柯条叶繁美茂盛。使多象挽不能令出。斫一小树无诸枝柯。一人独挽都无滞碍。即挽出林。见斯事已。即自思惟而作是言。我于今者得见因缘。即说偈言

  我见伐大树　　枝叶极繁多
  稠林相钩挂　　无由可得出
  世间亦如是　　男女诸眷属
  爱憎系缚心　　于生死稠林
  不可得解脱　　小树无枝柯
  稠林不能碍　　观彼觉悟我
  断绝于亲爱　　于生死稠林
  自然得解脱

即于彼处得辟支佛道。时彼亲友即语之言。日已向暮可共还家。答亲友言。汝自归家。我向家因今以断竟。亲友问言汝云何断。答言。我昔由爱故着居家。今我已断如此爱业。人所爱着妻子眷属。小子稚孙恩爱憍恣。若见父时。弄声不了。疾走攀缘。恋着此事故生爱着。我于妻子及以眷属。如此之事爱心永息。我本在家营理众务。或出或入。或言与彼。或言取此。或言应作。或言不应作。如此之事我今已断。已舍欲乐。获解脱乐。伐爱树根。闭诸趣门。灭大闇障。我于赤子反似怨家等无有异。今我如是。云何而当复还家耶。时其亲友即还家中语其男女。男女大小闻其不来。悉往就看。眷属既至。但见其父。沙门法服飞升虚空。男女白言。今以何事厌恶眷属。处虚空中。即说上偈。以答男女

既说偈已。即时飞至雪山之中。与诸辟支佛。共集会已。还来到本得道园中。舍身涅槃。时其眷属为造塔庙。时人因名为多子塔。凡诸智人善根成熟。以少因缘便得开悟

    波罗奈国王月出悟辟支佛缘

  妻子亲友财　　生死中过患
  处林寂解脱　　犹如犀一角
  从善逝所闻　　传至于我师
  我复从师闻　　今当演说之

昔有辟支佛。于迦叶佛所。万二千岁修行梵行。恒修忍辱慈悲众生。乃至微戒不曾毁犯。命终生天。彼天命终。下生人间波罗奈国国王之家。月出时生因名月出。以渐长大立为太子。其父王崩绍继王位。以宿善力作正法王治国。遣辅相子典领小国以女妻之。此辅相子勇力绝伦。多有眷属。自恃憍豪越逸过度。时国王子。以辅相子是姊妹夫。极成亲昵。因其私屏闲宴之处。阴遘谗计语王子言。尔之叔父兄弟眷属其数甚多。而世人多用妇语。尔之父王一旦倾覆。尔之诸母或生谗谄。自用其子以此推之汝父王位必不至汝。曼王未觉宜早图之。夫王位者天下之尊。极乐之处与天无异。一切世人无不信伏。若为国主以法治国。命终之后必得生天。譬如美肉众皆嗜之。王位亦尔。无不贪者。即说偈言

  譬如水未至　　宜务造桥梁
  瀑流若卒至　　不得有所为
  王位亦如是　　宜应先图之
  擒获在汝手　　尔乃可自安
  兄弟更相嫉　　后求甚不易
  王子思惟言　　如此亲友者
  将欲陷坠我　　如灰覆炽火
  现在既无乐　　来世获大苦

尔时王子具以上事。往白父王。王闻子语。颦蹙怒眼目如赤铜。王当是时。敕语使言。曼其未泄。急追将来。时王子闻辅相子来。即便出迎。既相见已。寻时遇患。使还白王言。王子病极成痿笃。王闻是事即自出看。既睹其子所患困笃。命在危惙。四大苦痛。见此事已。便自思惟。此王位者。甚为大恶。然彼辅相父子。阴教我子。悖逆天常。欲为不轨。而我王位非彼能得。我子今者。患苦垂命。一切世人皆生贪嫉。以此而言。当知王位恶鄙弊处。何故鄙弊。以王位故舍其善行。为王位故害父及祖。为亲厚者。作大过恶。舍于惭愧能使憍逸。为少乐故不畏后世。即说偈言

  如蛾投炽火　　贪国盲亦尔
  深着于得失　　作以及不作
  没国事淤泥　　不得寂定处
  作是思惟时　　身行极清净
  逮得厌恶心　　即获辟支佛

复有师云。此王见儿患已。即便还宫。有一邻国亲厚之王。为贼所逼。即遣使来求索援助。此王闻已。寻将兵众往救彼王。既到彼国连兵交刃。极相杀害。乃至妇人胎中。小儿剥而杀之。王见斯事。深于王位生于厌恶。即说偈言

  贪国微小乐　　没溺欲泥中
  欲忿既增长　　斗战生是非
  以贪财利故　　互共相杀害
  不求胜解脱　　尽灭于王位
  如大炽火中　　飞蛾投而死
  怪哉生死中　　所作事颠倒
  极作劬劳业　　返获其苦殃
  如彼高山巅　　崖傍有蜜蜂
  愚人贪少味　　不觉堕坠苦
  如是自思惟　　即得辟支佛

即告子言。汝能不用恶人之言。无勃逆意。汝若治国必以正法。我今以国付嘱于汝。吾将欲去。子及辅相一切眷属。闻王此语。悉皆懊恼涕泣流泪。合掌白王。不审大王。欲何处去。尔时父王踊身虚空。在日出山上。说如上偈。着沙门服。作十八种变。国人见者无不欢喜。譬如调马若见鞭影即便调顺。智人亦尔。见他受苦心即调顺

    拘舍弥国王大帝悟辟支佛缘

  父母及妻子　　谷帛财宝等
  智者深观察　　暂过如客舍
  弃舍于爱欲　　独行如犀角
  我昔从诸师　　传授闻此事

昔有曾于迦叶佛所作比丘。智慧聪敏柔和忍辱。于日日中。常观诸法真实体性。所谓观阴苦空无常无我。犹如芭蕉热时之炎。如幻如梦如水泡沫。能善观察自修其心。命终生天。于天寿尽下生拘舍弥城。为国王子。名曰大帝。其父王崩。承嗣先业绍继王位。如劫初诸王。善修戒行正法治国。尔时城中有大长者。财富无量。与大帝王。少为亲旧。极相厚昵。彼大长者身婴重病。王闻其疾躬自往问。见长者病形容萎悴。王心不乐低头愁惨。时彼长者以七宝钵盛满中金。用奉献王。王言长者。汝今疾苦极困笃耶。长者对曰。愿王顾视听我所说

  我家大巨富　　犹如毗沙门
  爱语及财宝　　多集亲友众
  妻子与眷属　　僮仆诸走使
  我皆恣所欲　　待遇极丰厚
  今我死时至　　无一为我伴
  王即慰劳言　　此语极真实
  汝子与诸亲　　财宝众库藏
  及我勇健力　　象马车步兵
  虽有如是等　　无能救拔者
  我等诸亲友　　见汝遇苦患
  但有慰喻言　　忧愁流涕泪
  及汝命将绝　　无能救济者
  唯当自持汝　　由来所作善
  王谛观其病　　心如得禅者
  深悟诸苦患　　众生决定有
  一切有生类　　必为病所趣
  病常恼患人　　无有哀愍心
  一切世间人　　决定入死道
  都不生厌畏　　言此我妻子
  彼是我亲属　　此是我财贿
  彼亲厚于我　　我亲友于彼
  意为痴所病　　横作如是想
  火灾患在前　　愚盲而不睹
  上来诸所亲　　无能拔济者
  于此正思惟　　即获辟支佛

王之所亲内外眷属。见王得道绝弃世事。为爱别离火之所烧燃。生大恼热。时辟支佛身升虚空。作十八种变。说如上偈

复有说云。此王为王子时。入园苑中。见诸盲者更互相捉。闻王子出。谓有饮食。在于道侧。不见道路。堕大深坑。有即死者。有头破者。手脚折者。身体碎坏。尔时王子见是众苦。厌患思惟。而作是言。此觉悟我。如是盲人亦曾富贵。由纵逸故今得是苦。我于今者睹是事已。宜好捡行。不应放逸。即说偈言

  譬火烧金鬘　　而用为首饰
  金鬘虽珍妙　　炽火终成害
  王位亦如是　　当慎莫放逸
  此盲觉悟我　　不宜自宽纵
  因此王位故　　身起大憍慢
  威迫国人民　　皆令生苦恼
  后自受苦时　　苦剧百千倍
  目睹他受苦　　云何能自安
  此即是我师　　示我众苦患
  作此思惟时　　即获辟支佛

尔时王子。大赐盲者钱财珍宝。沙门法服身升虚空。现诸神变。语诸亲言。而我今者。不以嗔恚怖畏忧愁故。不嫌汝等故。我舍亲爱国土人民。都无怨亲钱财宝物。如上说偈

    拘舍弥国王悟辟支佛缘

  戏笑众乐具　　弃舍如涕唾
  忍乐于出离　　断灭于诸苦
  能尽贪爱痴　　其心得解脱
  由得解脱故　　独一如犀角
  曾从先师所　　得闻如是事

昔有辟支佛。于过去佛所修诸善根。于最后身生拘舍弥国。为拘舍弥王。其国土内有大灾变。大旱恶风五星倒错。王召太史占相之徒。说偈问言

  何缘有是灾　　大旱不降雨
  虚空无云翳　　观日无威光
  食肉诸恶鸟　　乌鹫及鸱枭
  迥翔虚空中　　见者生恐怖
  咸言如是灾　　是谁之所作
  能使诸妖异　　怪变乃如是

尔时太史即答王言。随我所知今当为说。如我意者。一切国民必有逼迫苦恼之事。王复问言。当以何方禳此灾患。太史白言。王若欲令国安隐者。当随我语。即说偈言

  王若能退位　　脱服与余人
  具足满六月　　微服而行乞
  灾患自消除　　王当如满月

王随彼语。即舍其位。微服行国。渐渐经历。行到婆翅多城。到彼城已。有异国王兴军来伐。婆翅多王为国乐故。兴兵往拒。两阵交战二王俱死。婆翅多城诸王子等。竞共诤国。复大战斗。毗罗仙王见是事已。唱言怪哉。即说偈言

  王位虽尊豪　　其乐甚轻微
  云何为是故　　具受诸苦毒
  竞心生斗战　　乐着随众恶
  如蝇贪食蜜　　着蜜无不丧
  人亦复如是　　为贪小乐故
  斗战自伤害　　王位可鄙贱
  多集诸苦恼　　患害用至灭
  如饮杂毒浆　　毒消身败丧
  为一己身故　　多有所伤害
  愚贪王者乐　　乐少苦甚多
  我从今永止　　更不求此乐
  而此国事务　　忧怖充其中
  荣乐须臾顷　　忧患苦延长
  譬如妙金屋　　火焚炎炽然
  智者畏烧害　　不应入其中
  作是思惟时　　即悟辟支佛
  以神通力故　　须发自然落
  即作沙门形　　踊身升虚空
  寻于虚空中　　即说如上偈

即飞至雪山中诸辟支佛所。时彼辟支佛问言。以何因缘得悟道果。具说上偈答之

    波罗奈国王亲军悟辟支佛缘

  世间戏笑乐　　及爱我我所
  悉皆放弃舍　　心意得解脱
  诸根悉寂定　　独行如犀角
  我昔从先师　　传闻如此事

过去波罗奈城王名曰亲军。有二夫人。心甚爱悦。乐着欲事。恒为放逸。耽荒如醉。亦如香山逸象。香流出时入摩梨山自纵欲事。时二夫人更相妒嫉。各相伺便。其一夫人便以毒药与其亲信。亲信赍药与彼夫人。夫人得药狂闷而卧。甚大苦毒寻便命终。第二夫人见其命终。诈现懊恼。自顼其发。捶胸而哭。举宫哀戚。王闻其死生大苦恼。夫人左右所有直人。所著璎珞严身之具。悉皆挽绝。以土坌身。忧毒入心。如彼群鹄为鹰所逐。如金翅鸟惊诸龙女。宫中婇女为死所惊。亦复如是。尔时宫中。譬如冢间。又如黑尘掩蔽光明。诸宫人等为忧所弊。亦复如是。王闻宫人如是忧苦。心中惊动。天冠璎珞着身服饰。皆弃于地。入到丧边。见诸婇女。哀苦理极。王见是已生大愁恼。而自思惟。即说偈言

  譬如盛暑日　　能炙好花萎
  死日消人形　　面色变青黑
  唇齿尘垢秽　　眼陷鼻角戾
  歌舞妙容仪　　矗直如木石
  先者能令我　　爱着极乐处
  云何卒今日　　能生我怖畏
  可恶生死患　　不净极臭秽
  如梦虚不实　　亦如芭蕉心
  无有坚实相　　如幻泡焰沫
  暂现如水波　　智者所厌恶
  不知观察者　　横生乐着想
  于此不净中　　横生于身想
  迷闷而守着　　犹如睡眠者

如是思惟未久之间。烧夫人尸丧事已竟。第二夫人为藏已过。食好饮食诈自懊恼。言欲断食。现作哀惨。然恐其过彰露发觉。心中愁结。以愁结故。饮食不消。即成大病。王见病已倍增懊恼。即生厌恶。如此皆是生死过患。即说偈言

  如女能生爱　　生累极众多
  人中无不尔　　因爱生于乐
  还复生大恶　　爱为苦根本
  见爱合会时　　必知是无常
  我所爱乐者　　端政与盛年
  一旦死来集　　以是故当知
  云何有是乐　　谁有智慧人
  恩爱合会时　　而当生喜乐
  畏老病死患　　是故我永离
  作此思惟时　　即得辟支佛

即着王者衣服璎珞。飞升虚空。于虚空中说如上偈。变成沙门。飞到雪山中诸辟支佛所

    转轮圣王最小子悟辟支佛缘

过去无量劫时。有一转轮圣王。千子具足。其最小子见父乘金轮宝七宝具足。四兵翼从鼓盖容饰悉皆具备。其最小子即问母言。我当何时得是盖等种种容饰。母即答言。汝至骨朽亦不得是。儿即问言。何以不得。汝有九百九十九大兄。应得绍位。计其次第。都不至汝。儿即思惟。我既不得如是容饰。生必有死形骨腐败。以是种种思惟生死过患。即时觉悟得辟支佛。身升虚空作十八变。母即复请愿莫远去。园苑中住受我供养。时辟支佛受诸母请。即住后园。日日供养经历多时。时辟支佛厌是有身。即便弃舍而入涅槃。诸母恋念。大积香薪以烧其身。收其舍利盛着宝瓶。即于后园为起大塔。时转轮王游四城还。到后园中见有大塔。怪而问之。时守园者即白王言。是王最小之子。得辟支佛。于此涅槃。诸母于此为其起塔。时转轮王即召其母。而问之言。我子云何死而起此塔。时其母等具以上事而白于王。王责其母。我儿欲得何不语我。今虽涅槃。以王容饰置于塔上。由是因缘。无量劫中。恒为转轮圣王。食自然福至今不尽。若处生死。应二千五百世为转轮圣王。由成佛故。得二千五百宝盖。阿阇世王上佛五百宝盖。毗舍离律车子上佛五百宝盖。海龙王上佛五百宝盖。阿须罗王亦上佛五百宝盖。天帝释亦上佛五百宝盖。尔时世尊唯不受一盖。何以故。为将来弟子若乏衣食供养。以此福力当使人天自然供给。以是因缘当知。贤圣福田深广无量

辟支佛因缘论卷下


宾头卢突罗阇为优陀延王说法经

    No. 1690

宾头卢突罗阇为优陀延王说法经

        宋天竺三藏求那跋陀罗译

欲乐味甚少。忧苦患甚多。是以智者。应修方便。速离众欲。勤行净行。我昔曾闻。千福王子。名优陀延。绍父王位。住拘舍弥城。其城殊妙。宽博严净。晃烂宫观。映饰绮丽。窗牖通疏。交络珠网。楼观千万。庄挍此城。街巷相当。阡陌齐整。市肆充盈。多诸珍宝。其城周匝。有好林苑。树木翠蔚。花果茂盛。泉流清洁。生众莲华。青黄赤白。文色相映。鸿雁鸳鸯。孔雀鹦鹉。迦陵频伽。命命之鸟。其声相和。犹如乐音。壮丽之盛。如奇罗娑山王。崇岩峻岳。而自庄严。又像帝释所居喜见之城。优陀延王。形貌端正。威相具足。聪明黠慧。武勇绝伦。才伎兼备。靡所不知。善能咒象。令诸山象。咸来赴集。又能控御。皆令调顺。又善弹琴。和雅中节。宫商相应。鸟兽率舞。合众香丸。用降怨敌。香气所及。尽来归顺。善能刻画。曲得相貌。其所图像。真形无异。六十二艺。悉皆备具。衣服饮食。不尚丰奢。矜穷敬老。存恤民庶。正法治国。日夕忘倦。礼仪法律。一依古典。如昔哲王。什奢之等。国富民殷。库藏盈溢。福德之人。集生其国。受王风化。咸皆修善。博通经学。明解诸论。世间典籍。无不综练。勇健雄武。如罗摩延阿纯之等。由王先身辟支佛所种诸善根。获报如是。王之威德。邻国畏伏。道化光被。声闻天下。时辅相子。名宾头卢突罗阇。姿容丰美。世所希有。聪明智慧。博闻广识。仁慈泛爱。志存济苦。劝化国民。尽修十善。信乐三宝。出家学道。得具足果。游行教化。还拘舍弥城。欲度亲党。遍行乞食。乞食已讫。于林树下。结跏趺坐。思惟入定。时有一人。识宾头卢。来白王言。昔辅相子。宾头卢者。今近在此林中树下。王闻欢喜。心怀敬仰。便敕严驾。将诸宫人眷属仆从。诣尊者所。问讯既竟。命王就坐。王即思惟。所有疑事。今当问之。而作是言。宾头卢。今我与尔。少小知旧。汝之祖先。世为辅相。聪明智达。常为国师。今既相造欲问疑事。非相恼触。为我说不。尊者答言。恣尔所问。我当为王分别解说。王以偈问曰

  一切世人　　贪着五欲　　纵情放逸
  以自娱乐　　如汝今者　　独处空闲
  舍离恩爱　　有何荣乐

尊者答言。我观因缘。皆悉无常。是故出家。以割情爱。乐于林薮。犹如野鹿。专心勤修。永断烦恼。以智慧斧。破爱树枝。心无恋着。毒果消灭。诸结驶流生死瀑河。我已得渡。更无忧患。譬如飞鸟得免罗网。陵虚远逝。名曰解脱。王闻斯语。语宾头卢。今我势力。能伏诸国。威德晖赫。有如盛日。首戴天冠。璎珞盛服。婇女侍卫。如天帝释。汝今独处。颇羡我不。尊者答言。我无羡心。王复问言。何故于我而不愿羡。尊者答言。我于今日欲泥已干。诸有结缚。今已解脱。乃至帝释诸妙天女。尚不生羡。况汝人间鄙秽者乎。谁有智者得离魔缚。渡生死岸。得净慧眼。坏无明闇。而羡王耶。何有明眼。羡于盲者。何有强健而羡病患。何有无罪而羡狱囚。何有巨富羡于贫穷。何有高贵而羡奴仆。何有智者羡于愚痴。何有勇健羡于儜弱。王闻是已。心怀懊恼。而作是言。汝作方喻。一何苦剧我宁困劣乃如是乎。尊者答言。王无慧眼。烦恼所病。四取驶流之所漂没。失于勇健。不能精勤。如斯婴愚。不识真谛。沉沦苦海。是王之分。于五欲中。生希有想。如此之想。实违净行。王复问言。有何等过。而言违失。尊者答言。此五欲者。众苦之本。害于众生。所有善根。如雹害苗。螫恼众生。甚于毒蛇。亦如炽火。能烧功德亦如野马。诳惑凡夫。亦如幻化。迷乱惑者。欲诈亲善。过于怨家。欲如老牛没溺污泥。欲如大网缠裹三界。欲如剑道难可履践。欲能系闭杀害众生。一切过患。皆从欲起。如往古时。有婆须天。由欲因缘。为婆利阿修罗之所系缚。掷沸汤中。婆勒天坏阿修罗城墎。殄灭其民。恼触苦婆罗王种八纯提王及彼百子。悉皆诛灭。鼻多罗阿修罗。害于千眼罗摩。害十头罗刹。及数千亿罗刹之众。罗漫害因陀罗且翼叉王。摩罗支王。灭多摩罗质种族。迦帝毗王为阎摩尼婆罗门所杀。毗那悉那害提头赖吒眷属班细五子。杀十八亿人。弼匿安毒多罗蹭伽王种。俱罗王种。弥絺罗檀特伽王种。是等人王。皆为欲故。更相残灭。即说偈言

  王位虽尊严　　代谢不暂停
  轻疾如电光　　须臾归磨灭
  王位极富逸　　愚者情爱乐
  衰灭死时至　　苦剧过下贱
  王者居高位　　名闻满四方
  端正甚可爱　　种种自严身
  譬如临死者　　着花鬘璎珞
  余命未几时　　王位亦如是
  王者譬如乌　　常怀诸恐怖
  行住及坐卧　　乃至一切时
  于其亲疏中　　恒有疑惧心
  臣民宫妃后　　象马及珍宝
  国土诸所有　　一切是王物
  诸王舍命时　　皆弃无随者
  人王及天王　　阿修罗王等
  威力逼人民　　斧钺相残害
  不识无常苦　　横增贪嫉恼
  譬如妙华林　　金蛇睡在中
  愚人谓珍宝　　盛里赍归家
  蛇觉纵毒火　　焚烧其屋宅
  王位如华林　　灾患如金蛇
  愚人以为贵　　智者所不乐
  譬如以揣肉　　置四衢道头
  狐狼乌鹫等　　竞来诤食之
  王位亦如是　　众共诤取之
  鸟兽以嘴爪　　抓[國*瓜]共斗诤
  王者以刀矛　　相害诤荣位
  亦如彼鸟兽　　愚痴等无异
  我宁食灰土　　草菜以自存
  此身如痈疮　　会归当溃烂
  云何为此故　　造作众恶业
  如食钦婆果　　香味悉具足
  及其果消时　　身体尽烂坏
  王位如彼果　　失灭生苦恼
  譬如有方土　　灾疫行疾病
  有智诸胜人　　宜应速远离
  若不远离者　　如逆风执炬
  不舍必自烧　　如渴饮碱水
  无有饱足时　　如十头罗刹
  城郭及眷属　　为欲因缘故
  灭坏无有余　　又如寄越王
  兄弟有百人　　为欲因缘故
  亦皆尽败灭　　日种槃赵王
  及提头赖吒　　如是诸王等
  尽为欲所灭

当知国土犹如罗网。亦如罥弶。如深淤泥。亦如洄波。又如海浪。如林被烧。亦如危岸。犹如地狱。何有智者。当乐贪着。如是大苦。何有智者。当生乐想。如是大王。呜呼怪哉。被欺乃尔。被诳乃尔犹如空拳诳于小儿。速疾不停。犹如幻化。五欲欺诳。亦复如是。犹如猿猴在高山顶见云弥布以为坚实。谓为是地便以身投堕百丈岩。丧其身命。一切碎灭。亦如野干见甄叔迦树。其果似肉。见落地时。便往欲食。知其非肉。更复生念。今此非肉。彼树上者。必当是肉。遂便守之。为其所困五欲诳王。亦复如是。亦如商估以伪珠诳人。五欲诳王。亦复如是。又如婴愚嗜味贪欢喜丸。人以泥团。而来诳之。谓为真实。走逐疲苦。乃得泥团。如热时焰诳渴愚夫。犹如众人前竖于幻橛。能使时众见种种事。若拔幻橛。色像即灭。犹如画匠及机关师。如狗吠井自见形影。怒眼竖毛。谓井底影欲共己斗。横生嗔忿。投井而死。大王。宜善观察。何有五欲而得常者何有王位而得久停。尊豪威势。无得住者。何有国界而不迁坏。何有珍宝而不散失。何有欲乐常恒不变。苦之封授必受衰灭。何有合会而不别离。一切五欲。体性实苦。皆从妄想而生于乐。何有诸行不似芭蕉揵闼婆城。大王云何。处生老病死衰祸恐怖逼迫之中。云何能为国土少乐生爱乐想。如林中鹿。四边火起。如鸟在笼。如鱼处网。如龟吞钩。如师子毒箭入心。如龙处咒场。如人在屋中四边火起。如处危朽华堂速疾崩坠。如好华池有水罗刹噏食于人。重说偈言

  生老病死患　　于中未解脱
  无明爱毒箭　　犹未得拔出
  人帝汝云何　　而生乐着想
  如象处林中　　四边大火起
  处此急难处　　云何有欢喜
  大王应当知　　荣位须臾间
  智者深观察　　不应于此事
  而生希有想　　汝何故错解
  实是爱奴仆　　而生高贵想
  舍上妙财宝　　而生大富想
  不善解方便　　横生智慧想
  为众烦恼患　　横生无病想
  未脱生死胎　　横生无畏想
  处十二刺林　　横生无刺想
  欲贼劫诸根　　横生无贼想

大王而此身者必归败坏。尊豪荣贵。必有衰灭。财宝库藏。必有散失。大王。如佛言曰。荣位如梦。恩爱暂有。汝于五欲。生于希有难遭之想。贤德于此。岂得名为能善观察。何以故。荣位恩爱。必有别离。如众飞鸟夜栖一树。晨则四散。又如客舍夕则聚宾。明各异路。亦如乘船。异人同载。既至岸已。各自殊道。亦如驶流漂集众木。须臾之间。随流分散。犹如浮云。须臾散灭。作音乐处。男女聚集作乐已后。各自散去。宫人婇女端正美妙。无常理会。会归舍弃。譬如华树蜂集其上。花凋落尽。诸蜂远离。如花池枯涸牸象不入。如大池水鹄乐游居。及其干竭更不复近。福尽之家。荣利不近。如密云聚集。电光暂现。如风吹云。电光不现。彼不舍汝。汝必舍之。如似夏尽孔雀毛羽悉皆自落。如寒既至鸿鹄远池。如阿输伽树花叶盛时。人所爱乐及其枯悴。无有花叶。人不顾视。犹如花幢。贵者爱敬。华萎缕绝而便弃之。即说偈言

  无常不坚固　　如芭蕉水沫
  亦如浮云散　　天王尊胜位
  危脆亦如是　　人帝应当知
  贪利极速驶　　如水澍深谷
  嗜欲极轻疾　　动转如掉索
  愚痴染为欲　　不觉致堕落

尊者言。大王。我今为王略说譬喻。诸有生死。着味过患。王至心听。昔日有人。行在旷路。逢大恶象。为象所逐。狂惧走突。无所依怙见一丘井。即寻树根。入井中藏。有白黑鼠。牙啮树根。此井四边。有四毒蛇。欲螫其人。而此井下。有大毒龙。傍畏四蛇。下畏毒龙。所攀之树。其根动摇。树上有蜜三渧。堕其口中。于时动树[打-丁+棠]坏蜂窠。众蜂散飞。唼螫其人。有野火起。复来烧树。大王当知。彼人苦恼。不可称计。王愁忧厌恶而言。彼人得味甚少。苦患甚多。其所味者。如牛迹水。其所苦患犹如大海。味如芥子。苦如须弥。味如萤火。苦如日月。如藕根孔比于太虚。亦如蚊子比金翅鸟。其味苦恼多少如是。尊者言。大王。旷野者。喻于生死。彼男子者。喻于凡夫。象喻无常。丘井喻于人身。树根喻人命。白黑鼠者。喻昼夜。啮树根者。喻念念灭。四毒蛇喻四大。蜜者喻五欲。众蜂喻恶觉观。野火烧者喻老。下毒龙者喻死。是故当知。欲味甚少。苦患甚多。生老病死。于一切人。皆得自在。世间之人。身心劳苦。无归依处。众苦所逼。轻疾如电。是可忧愁。不应爱着。大王。今我语王。言虽粗恶。实是利益。王闻是语。衣毛皆竖。悲喜交集。涕泣流泪。即起合掌。五体投地。白尊者言。我之婴愚。无有智慧。我之下贱。作斯狂言。如是狂言。听我忏悔。尊者言。我于今者。以忍出家。无不忍受。我心清净。犹如秋月净无云翳。王今忏悔。愿使大王犹如天帝得见道迹。王大欢喜。与诸眷属。作礼还宫

宾头卢突罗阇为优陀延王说法经


成实论

    No. 1646

成实论卷第一

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    发聚中佛宝论初具足品第一

  前礼所应礼　　自然正智者
  一切智应供　　大师利世间
  亦礼真净法　　及圣弟子众
  今欲解佛语　　饶益于世间
  论应修多罗　　不违实法相
  亦入善寂中　　是名正智论
  譬如天日月　　其性本明净
  烟云尘雾等　　五翳则不见
  邪论覆正经　　其义不明照
  正义不明故　　邪智门则开
  罪负恶名闻　　心悔疲倦等
  此衰恼乱心　　皆由邪智起
  若人欲除此　　罪负等衰恼
  为求正论故　　当近深智者
  亲近深智者　　是正论根本
  因此正论故　　能生福胜等
  虽有利智人　　诵百千邪论
  于众不能得　　辩才名闻利
  知佛法第一　　说亦得乐果
  欲令法久住　　不为名闻故
  广习诸异论　　遍知智者意
  欲造斯实论　　唯一切智知
  诸比丘异论　　种种佛皆听
  故我欲正论　　三藏中实义

于是说论。问曰。我今知汝说成实论。汝先言前礼所应礼。所谓为佛。何故名佛。成何功德故应礼耶。答曰。佛名自然人以一切种智知一切法自相差别。离一切不善集一切善。常求利益一切众生。故名为佛。教化所说是名为法。行此法者名之为僧。如是三宝应礼因缘。我今当说。佛五品具足故。为世间天人所敬。问曰。诸余圣人。亦复有此五品功德。与佛何异。答曰。佛五品法具足清净。所以者何。身等诸业无错谬故。戒品具足。又佛尚不误毁禁戒。况当故犯。又久集慈悲恶心不发。如经中说。佛语阿难。若人从生习慈。能起恶不。不也世尊。佛久集善性。不为自守怖畏名闻而持禁戒。又于无量佛所久修戒行。拔三毒根永无余习。以是等缘戒品具足。定品具足者。佛依此定得一切智。以此故知定品具足。如酥油多灯炷大故光明亦大。又佛定坚固如漆漆木。余人禅定如华上水。不得久住。又佛禅定于无量劫次第渐成。故能具足。又如来定不待众缘。若人若处若说法等。余人不尔。又如来定常深修习。如人自字恒忆不忘。佛入禅定不加心力。又譬如人自于住处乃自语言。安隐无难。佛处定中亦复如是。故言如来常在三昧。又坏禅定大喜等法。佛悉善断。又定果报。得自在神通最胜第一。以如意通于一念顷能过十方无量世界。一切所为随意即办。于诸变化自在无碍。心能普周一切诸法。其余众生莫能及者。又佛成就圣自在法。于可乐中生不乐想。于不乐中能生乐想。于乐不乐能生舍想。问曰。于不乐中可生舍想。云何于中能生乐想。答曰。善修心故。于恶口等不乐法中不以为碍。于余神通天眼天耳知他心智宿命通中。亦无所碍。以定力故神通无碍。于诸禅定通达明了。其余众生不闻其名。唯有如来出入无碍。又佛禅定名之为力。如十力中说。余人无有。是故如来定品具足。慧品具足者。有二种无明。一障禅定。二起烦恼。如来悉断断相违故。慧品具足。又得自然法。不从他闻。巧于言辞。善知义趣。辩才无竭。智慧无尽。又余众生于诸技术不能具足。唯佛尽知无有减少。是故如来慧品具足。又佛所说法。善于义趣。余小智人有所言说。不能无过。唯有如来所言无失。故知如来慧品具足。又无量功德。成此智慧故能具足。又说微妙法。无有错谬。如不净观破淫欲等。又智慧胜故威仪亦胜。以是等缘慧品具足。解脱品具足者。于二无明心俱解脱。无有余习永不退转。如是等名解脱具足。解脱知见具足者。能于一切断结道中。念念悉知。如人伐木。手执斤斧。边有智者。知柯微尽。佛亦如是。于断结智念念所尽悉分别知。又知众生深心所念。如应说法令得解脱。是故能于众生一切解脱道中。知见具足。又佛世尊知时说法。如鈂扶卢梵志等也。又如来善知诸法差别。应为是人说如是法。如佛语阿难。应为车匿说离有无经。是故如来善知解脱。又善方便断众生垢。如为难陀以欲断欲。又先知众生信等根熟。然后说法。如罗睺罗。又有众生为业报障不得解脱。佛能令尽。然后说法。又有众生待时漏尽。如夫妇经说。又有众生待人漏尽。如舍利弗待阿说嗜。又有众生待处漏尽。如弗迦沙王。又有众生待伴漏尽。如放牛难陀待阿由陀村人等。又有众生。待佛真身。又待化身。而得漏尽。佛悉别知而为说法。令得解脱。又佛种种说妙法故。能破一切障。解脱法故。名解脱知见具足。又佛说法。善于义趣。不说非义无果报事。又佛渐次说解脱道。犹如算数。见故易解。又佛知众生宿植善根。次第说法。又佛现得解脱。而为人说不从他闻。又佛法具足多诸技能。如以众药具足疗病。佛法亦尔。以众治门。除一切烦恼。如九想等大小诸结不能反害。故能具足破诸烦恼。又无上方便济度众生。或以软语。或以苦言。或复兼以软言苦言。是为如来解脱知见具足

    十力品第二

复次佛十力成就故智慧具足。以往反因缘故说十力。初处非处力。是因果中决定智也。知从是因生如是果不生是果。如行不善必得苦报。不生乐报。是处名有是事。非处名无是事。是初力者。诸力之本。问曰。世间亦知因果是处非处。如从麦生麦不生稻等。答曰。处非处力。知业等法故。名此力甚深第一。诸天世人所不能及。又了知生法因次第缘增上。是故此力名为微妙。谓知去来现在诸业及诸受法。知处知事。知因知报。是故此智名之为力。以知三世处事因报。故名甚深。所以者何。或谓过去未来无法故。佛于此说言有力。又法在过去未来世中。虽无现相。佛亦现知

复次业有二种。若善不善。或有善业而现受苦。如以持戒而受诸恼。或有罪业今现受乐。如为破戒而得自在。或有生疑谓未来世亦如现在。是故如来次业说受。受法四种。有现苦后乐。现乐后苦。有现乐后乐。现苦后苦。佛悉了知处事因报。处名受者。事名施物。因名施心。如经中说。先心欢喜。施时心净。施已无悔。是业得果。名之为报。唯佛能知是业多少。若定不定。现报生报及后报等。悉知无余。故名为力。佛于诸禅解脱三昧三摩跋提。知垢知住知增知净。于此义中禅名四禅四无色定。即是色界无色界业。解脱者谓八解脱。能尽是业。是禅无色定及八解脱名为三昧。得是三昧用现在前名三摩跋提。三摩跋提分别四种。随垢随住随增随净。知垢者随垢定。知住者随住定。知增者随增定。知净者随达定。随达定者。暖顶忍等四法是。佛于此等悉知无余。故名为力。佛了知众生诸根利钝。信等根胜故名为利。如诸佛等。钝名不及。如蛇奴等。无有中根。以不定故。利根有边如诸佛。钝亦有边如蛇奴。中无边故不说中根

复次有二种道。信行法行。复有二道。难道易道。异此二道故名为中。观人利钝。是故为中。又随所乐故。根有差别。乐信根故名为信。多有智慧人。诸根皆胜。以所乐故。名和伽利。信根为胜。如是诸根悉知无余。故名为力。佛知众生各有所乐。乐名为欲。如人乐酢则欲于酢。佛随所乐。各各别知。谓是众生乐于五欲。或乐修道。如是知已。随宜说法故。能广度一切众生。佛知世间无量种性。众生久习所乐则成其性。如调达等。世世谤佛。恶心转深。便名为性。善性亦然。或有众生。从性起欲。或缘现起。如来善知所乐及性。故名为力。佛知一切所至处道。知行是道生地狱中乃至生天。知行是道得至涅槃。是业皆从根欲性生。有漏业故生五道中。无漏业故得至涅槃。先但说道。今说道果。又先总相说。今分别说。有如是业趣于地狱。有如是业能到涅槃。趣地狱者亦有差别。是业当堕活地狱中。是业当堕黑绳地狱。是故佛于第七力中知细微业。余人若知不能分别。故名为力。佛如是知过去业果。名宿命智力。又佛应知众生先所行道。知已说法故。于宿命说有智力。又佛念过去一切生处。若在色处若无色处。自知己身。亦知众生。故名为力。佛天眼智。见未来世三有相续。知三种业。四种受法。亦为记说。了知无碍。故名为力。以漏尽力知不相续。众生命终。或有相续。或不相续。是力皆为一切众生至处道力。总说涅槃道。今此力中。广分别说佛因垢净故有十力。得九力故。则智成就。得第十力故则断成就。智断具足。故名世尊。天人所敬

    四无畏品第三

又佛成就四无所畏。是故应礼。四无畏者。如来得一切智一切漏尽。能说障道及尽苦道。此四法中。若有人来。如法难问。我无所畏。初无畏者是一切智。亦是九力。第二名断。即第十力。智断具足故。如来自己功德具足。后二无畏。令他具足。佛说障碍是实障法。所谓不善或善有漏。障解脱故名障碍法。为离障碍故说出道。问曰。如汝此中所说诸力即是无畏。今力与无畏有何差别。答曰。智名为力。以此力故有所堪受。是名无畏。有愚痴人无惭愧故多所堪受。如来堪受从智慧生。又以智故不畏他人。故名无畏。所以者何。或虽有智犹怯弱故。又智名为力。能说是智名无所畏。所以者何。有人虽知不善说故。又能胜他人名为无畏。所以者何。有人虽知不胜他故。又智无尽故名为力。辩才无尽故名无畏。复次说有义趣故名为力。所说自在名曰无畏。又因名为力。果名无畏。以从智中生无畏故。又人从生怯弱后得少智。便能无畏。何况世尊。从久远来。其心广大。又得一切智。而当有畏

复次有人。不能胜他故有所畏。无有一人佛不胜者。故无所畏。又有论者。善于言辞。亦善义趣。则无所畏。佛即是也。得一切智故善于义趣。得无碍辩故善言辞。或复有人。于事无力。而生怖畏。如来逮得一切智故。于一切事无不有力。一切经书一切论议。皆悉通达明了问答。故无所畏。复次人有短阙若家若性若色若戒多闻智等。故致讥论。如来于此都无所阙。是故无畏。又如法论者不可破坏。佛即是也。如阿叔罗婆罗门语世尊言。如法论者难胜难坏。顺道论者。思量论者。有因论者。亦复如是。复次若人成就四种论法。亦难胜难坏。一者住于正报。二者受因非因。三者能受譬喻。四者住论法中。佛具此四。诸天世人。无能胜者。故无所畏。复次不咨善师而论议者则易可坏。如来昔曾于锭光等无量佛所修集论法故不可坏。复次佛说二谛。所谓世谛第一义谛。是故智者所不能坏。凡夫无智亦不与诤。又佛不与世间共诤。世间谓有。佛亦说有。世间谓无。佛亦说无。是故无诤。以其无诤故不可坏。复次论有二种。一者真实论。二谄曲论。诸外道等多谄曲论。佛真实论故不可坏。又佛法中正行净故论议亦净。正行清净名尽苦因。诸外道论有相似因无正因故不能得胜。又佛经清净。所说义趣不违实相。不同外道。又佛所说道不但随语。皆心自知。如经中说。佛告比丘。汝等莫但信我语也。当自知见自身证行。又言。汝来诸无谄者。若我晨朝为汝说法令夕得道。夕为说法令晨得道。复次若人于法有所不达便止不言。设有所言亦必可坏。佛无不达故能无畏。又如来得诸无碍智。于一切法无不通达故无所畏。又小智不知大人所知。大能知小。佛于众生最为大故能知小论。故无所畏。又诸外道论因所见起。佛知是见从众缘生。知集知灭知味知过知出。诸外道等不能尽知。故生诤论。佛以一切种智知一切法故。能破坏一切诸论。不为一切诸论所坏。故无所畏。如是等缘名力无畏差别义也。问曰。佛于诸法悉无所畏。何故但说四无畏耶。答曰。说四则为总说一切无畏。所以者何。前二无畏自说智断。后二无畏为他说障道法说尽苦道亦名智断。师及弟子智断具足故。名总说一切无畏。问曰。众生何故疑佛非一切智人。答曰。佛所言说或有似非一切智人。如佛问言汝从何来有如是等。又如经中说有人若至城邑聚落。问其名字。我不说是一切智人。闻斯经者疑佛非是一切智人。又佛所说似有贪着。如经中说。佛言善来比丘汝于此身为得大利。随顺我法我则欢喜。有似嗔语。如语调达。汝为死人是食唾人。又似慢语。自言。我是人中师子。成就十力四无所畏。于大众中能师子吼。又似见语。言善持我法如擎油钵。又语调达。我不以众与舍利弗目揵连等。况当与汝。有小智人闻斯等言。便谓如来诸漏未尽。又佛说诸欲是障道法。有人虽受亦能得道。又比尼中所说遮法。有人毁坏。亦能得道。小智疑佛不知障法。有人修道。亦有结使。小智生疑。谓修圣道。不能尽结。既不尽结。何能离苦。是故如来于此四法说无所畏。问曰。如向所疑当云何断。答曰。佛随俗语。世间亦有知而问者不以为过。佛亦如是。在世间故随俗而问。又世间亦有心无贪着而言似有贪有如是等。佛亦如是。利众生故现有是言。若言欲非障法。如来说欲实是障法。若欲在心则无修道。要先除欲然后得道。若言虽犯遮法犹得道者破实遮法必无得道。若非实罪以重缘故佛还自听。非坏遮法。若言修道亦有结者。圣道能破一切结使。未具足故不能尽破。譬如酥性能破热病。以服少故不能消尽。修道亦尔。是故无咎。如来成就四无所畏。是故应礼

    十号品第四

复次经中说如来等十种功德。谓如来。应供。正遍知。明行足。善逝。世间解。无上。调御。天人师。佛世尊。如来者乘如实道来成正觉故曰如来。有所言说皆实不虚。如佛问阿难。如来所言颇有二不。不也世尊。故名如说。复次如来从得道夜至涅槃夜。于其中间所说皆实不可破坏故名如说。又以一切种智知前后际。然后说故所言皆实。又诸佛世尊忆念坚固无所忘失。有人或以比智而有所说有随经书。或有现在。不能善见而有所说。是人所说若得若失。如经中说。比智者言或得或失。佛于诸法现知已说。是故所言皆不可坏。名实说者。又佛所说皆说实义。不如余人有实不实。故不可坏。又所言应时。如经中说。佛知众生心喜心乐乃说道法。故名如说。又应为说者即为说之。如紧叔伽经中说。又所应说法而为说之。所谓若略若广阴入门等。是故所说无非真实。复次有二种语法。一依世谛。二依第一义谛。如来依此二谛说故所言皆实。又佛不说世谛是第一义谛。不说第一义谛是世谛。是故二言皆不相违。复次如来若遮若开亦不相违。随所为事遮。不即此事开。随所为事开。不即此事遮。是故所言皆不相违。又有三种语法。一从见生。二从慢生。三从假名生。佛无二种语。于第三语清净无染。又有四种语法。见闻觉知法。佛于此四所言清净心无贪着。又有五种语法。过去未来现在无为及不可说。是五种法佛悉通达。明了知已然后乃说。故名如说。能如说故名为如来。以烦恼尽故得此法。贪恚痴等是妄语根本。灭此诸结。是故应供。复次如来说应供法。是灭结法。由正智生。以无常等慧正观法故诸烦恼尽。故因正智生应供法。是正智法从明行生。前际后际及不相续善通达故。得名正智。尽行施等波罗蜜故诸明行足。余人亦于无始生死行施等法。无正行故不名善逝。佛有正道行施等行故名善逝。得此五法。如来自已功德具足。得正智故能知世间一切心念。知所念已而为说法。故名无上。调御所当调者无不调伏。已调伏者永不败坏。所调伏者天人是也。故名天人师。或有生疑。云何以生人而能化天。故言我是天人师也。佛者。若过去未来现在诸法有为无为有尽无尽若粗若细等一切诸法。坐道场时。除无明睡得一切智朗然大悟。故名觉者。如是九种功德具足。于三世十方世界中尊。故名世尊。佛十号具足故。自身具足。他亦具足。自利利人是故应礼

    三不护品第五

佛身口意业不护。所以者何。佛无不净身口意业。欲令他人不见不知。又诸余人。或有无记。似如不净身口意业。智者所呵。佛亦无也。所以者何。如来一切身口意业。皆由智慧正忆念起。若诸妄念少智之人无如是业。又世间人或卒误语。佛无此等。又佛善修身戒心慧。如是等法以善修故。一切不善及似不善业皆悉除灭。复次世尊从久远来修行善法不适今也。是故诸业性净不护。又佛常乐戒行。不以怖畏堕恶道等。又佛一切身口意业。皆为利人故无不善。以无不善故不须护。以净不护业是故应礼。又佛成就三念处故。所以应礼。若说法时。听者一心不以为喜。若不一心不以为忧。常行舍心。所以者何。佛贪恚习无有余故。又知诸法毕竟空故。无忧无喜。又佛善集大悲心故。于善不善心无忧喜。等起大悲。又佛深知众生各各性故。若善心听不以为喜。不善心听不以为忧。以性尔故常行舍心。又佛心坚固犹如大地。去重不高。若置重物亦复不下。余凡夫人其心如称。少增而下。少减而高。又佛世尊名大悲者。是故天人皆应敬礼。又舍深禅定乐为人说法。余人悲心无所成办。世尊大悲能济众生。故名有果。又以大悲成无上道。更无余缘。复次佛无我心。少欲知足最为第一。以大悲故自叹己身。又佛性柔和。以大悲故有苦切言。起大方便受诸勤苦。为度众生。又佛以大悲度众生故住于世间。受五阴身如热铁丸于须臾顷。不可堪忍。又佛世尊善修舍心。舍此舍心常行大悲。故可尊敬。又佛为善人善中之善。所以者何。自得大利亦利他人。自利利人故名善人。又佛为众生真善知识。如经中说我是众生真善知识。是怜愍者。利益者等。又佛世尊。有精进等诸功德聚。如和利以百句赞佛。有此功德。是故应礼。又佛自说功德。知增一阿含如来品中自说我是人中师子。人华人象。于沙门中第一沙门。婆罗门中亦是第一。众圣中王。行无错谬不随苦乐者我身是也。问曰。佛以何故。自赞其身。自赞身者是愚人相。答曰。世尊不求名利。但为他故自叹己身。又佛无我心。为利人故自叹无咎。又以因缘少多自赞。于佛功德不能说尽。是故不堕愚人相中。不自高故。又如清净经中。舍利弗住于佛前赞佛功德。是故应礼。又少欲知足等无量功德皆在佛身。所以者何。佛集一切诸功德故。以是等缘应敬礼佛

    法宝论初三善品第六

问曰。汝言应礼法。以何功德故应礼耶。答曰。佛自赞言。我所说法。初中后善。义善。语善。独法具足。清净调柔。随顺梵行。初中后善者。佛法无时不善。于少壮老三时皆善。入时行时出时亦善。又初止恶中舍福报后一切舍。是名三善。又佛三时常说正法。不杂非法如余外道。又初中后时。常为智者之所爱乐。又于三时一切甚深。不如余经初粗中细后则微末。以是等缘故名三善。义善者。佛法义有深利益。得今世利及后世利出世道利。不如外典愿增天眼。语善者。随方俗语能示正义。故名语善。所以者何。言说之果所谓义也。是故诸所言说能辩义理。是名语善。复次佛法贵如说行。非但言说。是故随方俗语能令得道。名为语善。不如外典但贵语言若失语言若失音声辞主得罪。复次善说真谛故名义善。善说世谛故名语善。独法者。佛但说正法。不为戏论说往古事。亦不杂说法及非法。又独法者。但为无余涅槃故说。又独佛能说故曰独法。问曰。有声闻部经。但声闻说。又有余经诸天神说。汝何故言独佛说耶。答曰。是法根本皆从佛出。是诸声闻及天神等皆传佛语。如比尼中说。佛法名佛所说。弟子所说。变化所说。诸天所说。取要言之。一切世间所有善语。皆是佛说。故名独法。具足者。佛所说法无所减少。如郁陀伽经中说具足相。又佛法者。不待余经而得成也。如和伽罗那经待五种经然后得成。佛法不尔。于一偈中其义具足。如说诸恶莫作诸善奉行自净其意是诸佛教。故名具足。清净调柔者。二种清净故。名清净调柔。语清净故名曰清净。义清净故名曰调柔。又佛听于正义中置随义语。于正语中。置随语义。不如外道随经而取。又佛法中依法不依人。法亦分别。依了义经不依不了义经。是名净法。非但随经。又佛法中。有三法印。一切无我。有为诸法念念无常。寂灭涅槃。是三法印。一切论者。所不能坏以真实故名清净调柔。随梵行者。八直圣道名为梵行。梵名涅槃是道。能到故名梵行。法宝成就如是功德。是故应礼

    众法品第七

复次佛自赞言。我法能灭。能到涅槃。能生正智。能善将导。能灭者。灭贪恚等诸烦恼火。故曰能灭。如习不净观灭淫欲火。如习慈心。灭嗔恚等。不如外道断食等法。故名能灭。能到涅槃者。佛法究竟必至涅槃。不如外道住有分中着禅定等。又佛法中说一切有为皆有过患。无称赞处。不如婆罗门赞梵世等。故名佛法能到涅槃。能生正智者。所有佛法皆为涅槃。是故能生正智。又佛法中有真智果。如从闻慧生思慧从思慧生修慧。故名佛法能生正智。能善将导者。佛法先自善成。后令他人住正法中。故名善导。复次佛法有六。一曰善说。二曰现报。三曰无时。四曰能将。五曰来尝。六曰智者自知。善说者。佛说诸法如法实相。若不善法说不善相。善说善相。故名善说。现报者。佛法能得现世果报。如经中说晨朝受化令夕得道。夕为说法令朝得利。又现报者。如说。现在沙门果经中说。现得恭敬名闻禅定神通等利。复次佛法皆有义理故能致得恭敬现报后报及涅槃报。诸外道法无义理故尚无现报及后世报。何况涅槃。故曰现报。无时者。佛法不待某日月岁星宿吉凶。乃得修道。某日月岁。不得修道。不如婆罗门法。初春婆罗门受火。春末刹利受火等。复有或待日出或日未出而供养火。如见五谷待时而种。或谓佛法亦当如是。故说无时。如经中说。佛法易行。行住坐卧无时不得。能将者。以正行故能将众生至解脱处。故名能将。来尝者。佛法应当自身作证。不但随他。如佛语比丘。汝等莫但信我语也。当自思惟。是法可行。是不可行。不如外道语弟子言舍是问答如人净洗不喜尘土当如聋哑但随我语。故曰来尝。智者自知者。是佛法利。智慧人乃能信解。断食等。粗愚者信乐。智者不受以正智慧能破烦恼。如是等法智者乃解。虽以甘膳充足其身。一心精进贪恚不染。如是等事智者现知。如人病愈自知得离。如水相冷饮者乃知。复次或有过语法。如地坚相。坚何等相。不得语答触乃可知。如生盲人不可语以青黄赤白。若人不得佛法味者。不可语以佛法实义。以寂灭故。复次佛法可自证知。不可以己所证传与他人。如财物等。如婆罗延经中。佛言我不能自断汝疑。能证我法汝疑自断。复次是法到他身时。不可得见如火传等。又凡夫愚人为无明山所障覆故不信是法。如因阿夷罗曰沙弥说大山喻。故言智者自知。复次佛法甚深。开示则浅。断除虚伪。流布天人。甚深者。佛法甚深。以不知因故。世间多见现果。不能知因故说自在天等邪因。十二因缘深故难解。世间智浅。于佛法中不生深想。不能通达众因缘法。乃至小草以众因缘思惟观察。其相转深。如佛所说。众因缘法。是事甚深。爱尽离灭及涅槃处。是亦难见。问曰。若因缘甚深。阿难何故生浅想耶。答曰。有论师言。是语不然。阿难是大弟子通达法相。云何当言因缘法浅。又若以总相观因缘法故生浅想。所以者何。是人不能善分别观烦恼业故。复次若人于本所学事得究竟便生浅想。如得大智还观初章。或复有人智慧未成。于甚深法则生浅想。又佛善说法故。或有众生便生浅想。复次佛法皆空。是空甚深。佛以种种因缘譬喻宣示。义则易解小儿亦知。如须陀耶沙弥等。复次佛法坚固。诸言说中最为真实。不如婆罗陀罗摩延经等。但有语言。无有实义。如卢提梵志言世尊诸比丘等。于利益法真实法中精勤修学所谓漏尽。复次佛法为利益一切世间故说。不如婆罗门言婆罗门法但自得道余人不得。又佛法尊重。诸天王等五欲自恣亦来信受。以是因缘故应礼法

    十二部经品第八

复次佛法分别有十二种。一修多罗。二祇夜。三和伽罗那．四伽陀．五忧陀那．六尼陀那．七阿波陀那．八伊帝曰多伽．九阇陀伽．十鞞佛略．十一阿浮多达磨．十二忧波提舍。修多罗者。直说语言。祇夜者。以偈颂修多罗。或佛自说。或弟子说。问曰。何故以偈颂修多罗。答曰。欲令义理坚固。如以绳贯华次第坚固。又欲严饰言辞令人喜乐。如以散华或持贯华以为庄严。又义入偈中。则要略易解。或有众生乐直言者。有乐偈说。又先直说法后以偈颂。则义明了令信坚固。又义入偈中。则次第相着。易可赞说。是故说偈。或谓佛法不应造偈似如歌咏。此事不然。法应造偈。所以者何。佛自以偈说诸义故。又如经言。一切世间微妙言辞皆出我法。是故偈颂有微妙语。和伽罗那者。诸解义经名和伽罗耶。若有经无答无解如四无碍等经名修多罗。有问答经名和伽罗那。如说四种人有从冥入冥。从冥入明。从明入冥。从明入明。从冥入冥者。如贫贱人造三恶业堕恶道等。如是等经名和伽罗那。问曰。佛何故说无答无解经。答曰。有经义理深重。是经义阿毗昙中当别说。是故不解。或有人言。佛所说经皆有义解。但集法者。撰深义经置阿毗昙中。如因内结外结人终夜解义此义应在结使聚中。伽陀者。第二部说祇夜。祇夜名偈。偈有二种。一名伽陀。二名路伽。路伽有二种。一顺烦恼。二不顺烦恼。不顺烦恼者。祇夜中说。是名伽陀。除二种偈余非偈经名忧陀那。尼陀那者。是经因缘。所以者何。诸佛贤圣所说经法。要有因缘。此诸经缘。或在修多罗中。或在余处。是名尼陀那。阿波陀那者。本末次第说是也。如经中说。智者言说则有次第。有义有解不令散乱。是名阿波陀那。伊帝曰多伽者。是经因缘及经次第。若此二经在过去世名伊帝曰多伽。秦言此事过去如是。阇陀伽者。因现在事说过去事。如来虽说未来世事。是事皆因过去现在故不别说。鞞佛略者。佛广说经名鞞佛略。有人不信。谓诸大圣乐寂灭故不喜愦闹。厌世杂语。拔乐众根故不乐广说。如经中说有得道人。过二月已乃出一言。为断此故说有广经饶益他故。如说如来二种说法。一广二略。广胜略故。阿浮陀达磨者。未曾有经。如说劫尽大变异事诸天身量。大地震动。有人不信如是等事。是故说此未曾有经。现业果报诸法势力不思议故。忧波提舍者。摩诃迦栴延等诸大智人广解佛语。有人不信谓非佛说。佛为是故说有论经。经有论故。义则易解。是十二部经名为佛法。法宝具足如是功德。是故应礼

    僧宝论初清净品第九

问曰。汝先言应礼僧。何故应礼。答曰。佛于处处自赞叹僧。是僧宝戒品清净。定品慧品解脱品解脱知见品清净。应请应礼合掌供养无上福田能益施者。戒品清净者。佛弟子众持戒无瑕。乃至小罪深怀畏惧。又佛弟子不为福报生人天等。亦不怖畏堕地狱等。而勤持戒但乐善法。故名清净。又持净戒不限时节。不如婆罗门六月持戒。长夜受持乃至究竟。故名清净。又持净戒离于二边。离五欲乐。亦离苦身。故名圣所爱戒。是戒名为智者所爱。又心净故戒亦清净。又深心止恶。不但守戒。怖畏后世。故名僧宝戒品清净。定品清净者。若定能生真智。故名清净。慧品清净者。若慧能尽烦恼。故名清净。解脱清净者。若得尽诸烦恼非但能遮。故名解脱清净。解脱知见清净者。于诸烦恼尽中得智。谓我生尽非未尽烦恼中言我生尽。是名解脱知见清净。应请应礼应供养者。以能具足如是功德故。应求请礼敬供养福田者。于中殖福获报无量。乃至涅槃。犹不可尽。能益施者。能令施者功德增益。如八功德田。滋茂五谷不令败坏。僧田亦尔。成就八功德故。能令施种功德增长。是故应礼

    分别贤圣品第十

问曰。以何法故名之为僧。答曰。四行四得戒定慧等功德清净故名为僧。四行者。行须陀洹。行斯陀含。行阿那含。行阿罗汉。四得者。须陀洹。斯陀含。阿那含。阿罗汉。行须陀洹有三种人。一随信行。二随法行。三随无相行。信行者。若人未得空无我智。信佛法故随佛语行。故名信行。如经中说。我于是事以信故行。若得真智则不但随信行。如经中说知不作者不信者等是名上人。是故当知未得真智名随信行。如经中说。若人于法能以少慧观忍乐者是名信行。过凡夫地未得须陀洹果。于其中间不得命终是名信行。是人在闻思慧中正观诸法。心忍欲乐。虽未得空无我智能生世间似忍法心。自此以来名过凡夫地。所以者何。后当广说。若无信等五根。是人则住外凡夫中。是人渐习得暖法等修慧。仍本名故亦名信行。以终不及法行人故。是经应言要必当得须陀洹果。不应言不得命终。所以者何。是信行者以尚远故。如郁伽长者供养众僧。天神示言某是阿罗汉。某是行阿罗汉者。乃至某是须陀洹。某是行须陀洹者。若在十五心中。不可得示。当知行须陀洹者有近有远是名信行。法行者。是人得空无我智。在暖顶忍第一法中。随顺法行。谓空无我等是名法行。是二行人入见谛道见灭谛故名无相行。是三种人。名行须陀洹果者。世俗道中无断结故。不得名为行。三果者。此事后当说。须陀洹者。如佛经说。若人断三结。身见疑戒取名须陀洹。不堕恶道。必得正智极至七有。问曰。若须陀洹。见谛所断烦恼都尽。灭无量苦。如池喻经说。何故但言断三结耶。答曰。此事后当广说。谓身见尽故余等亦尽。不堕恶道者。后业聚中。亦当广说。必至菩提者。是人入法流中必至涅槃。如木在恒河离八因缘。必到大海。极七有者。是人于七世中无漏智熟。如歌罗罗等七日变成。又如服酥等极至七日。坚病则消。又如亲族限至七世。又如七步蛇螫人身时。以四大力故得至七步。以毒力故不得至八。又欺诳法极至七世。又如七日出时则劫烧尽。如是七世集无漏慧烧烦恼尽。又法应七有。有须陀洹今世入涅槃。有第二第三极至第七。是名须陀洹。行斯陀含者。思惟所断结有九品。若断一二至三四五。是名行斯陀含者。有人言。以一无碍道断。是事不然。佛经中说以无量心断。如斧柯喻经中说。又行斯陀含者。亦名家家。是人或二或三往来。或于现身得入涅槃。是名行斯陀含者。斯陀含者。一来此间便入涅槃。是人思惟所断结薄。住是薄中名斯陀含。是斯陀含。或今世入涅槃。行阿那含者。若断第七第八品结。是人皆名行阿那含。断第八品。是名一种。行阿那含者。或有今世即入涅槃。尽离欲界九品结故名阿那含。是阿那含。差别八种。所谓中阴灭者。有生有灭者。有不行灭者。有行灭者。有上行至阿迦尼吒灭者。有至无色处者。有转世者。有现灭者。随上中下根故有差别。中阴灭者亦有三种。上中下根。有阿那含深厌世间。有少障碍。不得现灭。是人则于中阴中灭。生亦三种。谓生灭者。行灭者。不行灭者。生灭者生时深厌离有即入涅槃。是名生灭。以根利故或有生已诸无漏道自然在前不加勤行而入涅槃。是不行灭。以根中故。或有生已深畏受身。勤修行道。乃入涅槃。是名行灭。以根钝故。上行灭者亦有三种。若从一处终。至一处生。便入涅槃。是名利根。二三处生。是名中根。一切处终一切处生。是名钝根。从初禅至广果天是名决定。到广果已若生净居。是人不复到无色处。以乐慧故。若入无色处者。是人终不生净居天。以乐定故。转世者。若先世得须陀洹果．斯陀含果。后转身得阿那含果。是人不入色无色界。现灭者。第一利根。即于现身得入涅槃。复有二人。一名信解脱。二名见得。是二人者根差别故。若钝根学人在思惟道名信解脱。利名见得。若阿那含具八解脱是名身证。是等皆名行阿罗汉者。以断结同故。若尽断灭一切烦恼名阿罗汉。阿罗汉有九种。退相守相。死相．可进相．住相．不坏相．慧解脱相．俱解脱相．不退相。是诸阿罗汉。以得信等根故有差别。最钝根者是名退相退失三昧。退三昧故无漏智慧不能现前。守相者。根小胜故。若护三昧则不退失。不护则退。前退相者虽护亦退。死相者。根又小胜。深厌诸有。是人不能得三昧故。无漏智慧难得现前。设得喜失故求死也。住相者。若得三昧不进不退是名住相。前三种在退分三昧。住相者在住分三昧。可进相者。若得三昧转深增益。是人住在增分三昧。不坏相者。得三昧已种种因缘不能败坏。是人住在达分三昧。慧最利故。善取三昧入住起相。故不可坏。因灭尽定故。有二人不得此定名慧解脱。得此定者名俱解脱。不退相者。所得功德尽无退失。如经中说。佛语比丘。若我弟子以床舆我。我先所得尽无退失。如是九种名无学人。先十八学人及九无学。是二十七人。名为一切世间福田。僧中具足。是故应礼也

    福田品第十一

问曰。以何等故此诸贤圣名为福田。答曰。断贪恚等诸烦恼尽故名福田。如说稊稗不去害善谷苗。是故施无欲人。得报利大。又是人心空故名福田。所以者何。以空相故诸贪恚等烦恼不起。不生恶业。又诸贤圣得不作法故名福田。又是人等所得禅定皆悉清净。永离大小诸烦恼故。又弃舍忧乐。故名福田。又能断除五种心缚心得清净故名福田。又成就八种功德田故。又以七定具善护心故。又能尽灭七种漏故。无诸漏失。又具足戒等七净法故。又能成就少欲知足等八功德故。又能度彼岸及勤求度故名福田。又经中说。但能发心欲行善法尚多利益。况修行耶。是诸贤圣常行善法故名福田。又经中说。谁施主家有持戒比丘。受供养已入无量定。是施主家得无量福。众中有入无量三昧无相三昧无动三昧。能令施主得无量报故名福田。又经中说。三事和合故得大福。一曰有信。二曰施物。三曰福田。于众僧中多功德人。功德人中。信心易生。又施众僧具九因缘故获大果。又施众僧以受者净故施必清净。又施有八种。有清净心少施物亦少施破戒人。有清净心少所施物多施破戒人有清净心少施物亦少施持戒人。有清净心少所施物多施持戒人。有清净心多施四种物亦尔。于僧中施必当成就若二若三。一切善人皆因众僧增益功德。然后随意回向菩提。又所施僧。此物皆当得解脱果。于生死中终不能尽。又所施众僧皆为严心。又若于一人生信净心或时可坏。于众僧中信心清净终不坏败。又于一人生爱敬心。或不能广。于众僧中生信敬心。缘无量故心则广大。又施为一切入僧数人。以心大故果报亦大。以是等缘诸贤圣人名为福田。是故应礼

    吉祥品第十二

以是三宝功德具足故经初说。又此三宝于一切世间第一吉祥。如吉祥偈说。佛法及众僧是名最吉祥。复有诸经以吉祥为初学者增寿万岁。名闻流布。是作经者意也。如阿陀等字贯在经初此非吉相。后当广说。若求第一最吉祥者三宝是也。应当归依。如吉祥偈说

  诸天世人中　　无上尊导师
  佛为大觉者　　是名最吉祥
  若人于佛所　　安信心不动
  奉持清净戒　　是名最吉祥
  远离愚痴人　　亲近有智者
  可敬者则敬　　是为最吉祥

是故应礼三宝。以最吉祥故。我经初说

成实论卷第一成实论卷第二

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    立论品第十三

今欲论佛法饶益于世间。佛以大悲心为广利益一切世间故说是法无所齐限。如或有人但为婆罗门故说解脱经。佛所说经皆为度脱四品众生乃至畜生亦不限碍。问曰。不应造论论佛语也。所以者何。若佛自论可名为论。若佛不论余不能论。所以者何。一切智人意趣难解。不知何所为故而说是事。若不得佛意妄有所说则为自伤。如经中说。二人谤佛。一以不信憎恶故谤。二虽有信于佛所说不能谛受亦名谤佛。设有真智不知佛意。尚不能得论佛所言。况未得者而欲造论论佛意耶。所以者何。如异论经中。佛为触故说如是事。诸比丘等种种异论皆不得佛意。又如长老摩诃迦旃延语诸比丘。如伐大树弃舍根茎但取枝叶。汝等亦尔。舍离如来而问我耶。若摩诃迦旃延于论议中自喻枝叶。何况余人能解佛语。又佛问舍利弗。云何学人云何数法人。三问不答。又佛为一切诸法根本。唯佛能解。余人不能。又阿难白佛。遇善知识于得道中则为半利。亦有道理。所以者何。以二因缘正见得生。一从他闻。二自正念。佛语阿难。但善知识则为具足得道利己。又如佛言。若我为人有所说法。是人不得我意故生诤讼。今诸论师各有所执。或言过去未来有法。或有言无。当知如是诸论师等不解如来随宜所说故生诤讼。又如阿难为三摩提说诸所受皆名为苦。尔时佛语诸比丘言。汝观阿难仿像是义

又诸论者谓。阿罗汉应先受供养。比丘不知。便往问佛。佛言。于我法中前出家者应先受供养。饮食粗事。犹尚不能知。况如来意说微妙法。以此等故不应造论。答曰不然。所以者何。有因缘故能知他意。如偈中说。能知说者意所趣向亦知说者欲说何事。有二种道圣道世间道。后当广说。以此道故知说者意。又异论经中。佛亦尽听。又迦旃延等大论议师。得佛意故佛皆赞善。又优陀夷比丘昙摩尘那比丘尼等造佛法论。佛闻即听。又佛法深妙。解者造论。不解则止。如是其余佛为诸法根本等问。悉以通答。又应造论。所以者何。若经造论。义则易解法则久住。又佛听造论。如经中说。佛语比丘。随所造论应善受持。是故于修多罗中取义立论别为异部。故应造论。又佛为种种可度众生。说世间等诸论议门。如莎提等不能解故其心迷乱。莎提等比丘。说生死往来常是一识。佛如是等种种说法。若无论议云何可解。以是等缘故应造论

    论门品第十四

论有二门。一世界门。二第一义门。以世界门故说有我。如经中说。我常自防获。为善自得善。为恶自得恶。又经中说。心识是常。又言。长夜修心。死得上生。又说。作者起业。作者自受。又说。某众生生某处等。如是皆以世界门说。第一义门者。皆说空无。如经中说。此五阴中无我我所。心如风焰念念生灭。虽有诸业及业果报作者受者皆不可得。如佛以五阴相续因缘说有生死。又有二种论门。一世俗门。二贤圣门。世俗门者。以世俗故说言月尽。月实不尽。如摩伽罗母说儿妇为母其实非母。如经中说舌能知味。以舌识知味。舌不能知。如槊刺人言人得苦。是识知苦非人受苦。如贫贱人字为富贵。佛亦随人名为富贵。又佛呼外道名婆罗门。亦名沙门。又如刹利婆罗门等。佛亦随俗称为尊贵。又如一器随国异名。佛亦随名。又如佛言是吾最后观毗耶离。诸如是等随世语言名世俗门。贤圣门者。如经中说。因缘生识眼等诸根犹如大海。又如经说。但阴界入众缘和合。无有作者。亦无受者。又说一切苦。如经中说世间言乐。圣人说苦。圣人说苦。世间言乐。又诸所说空无相等名贤圣门。又有三时论门。若于此事中说名为色。若色曾有当有今有皆名为色。识亦如是。若识曾知当知今知皆名为识。如此等名三时论门。又有若有论门。苦有触必因六入。非一切六入尽为触因。若有爱必因于受。非一切受尽为爱因。或说具足因。如触因缘受。或说不具足因。如受因缘爱不说无明。或复异说。如经中说心欢喜身得猗。三禅无喜亦有身猗。又说猗者受乐。四禅有猗而无受乐。是名异说。又有通塞二种论门。如经中说若人发足为供养塔中间命终。皆生天上。是名为通。又余经说作逆罪者不得生天。是名为塞。又经中说受诸欲者无恶不造。是名为通。须陀洹人虽受诸欲。亦不能起堕恶道业。是名为塞。又经中说因眼缘色而生眼识。是名为通。若尔。应缘一切色皆生眼识。而不然

又经中说因耳缘声生耳识等不生眼识。是名为塞。又所言通塞皆有道理不坏法相。又有二种论门。一决定。二不决定。决定者。如说佛为一切智人。佛之所说名真妙法。佛弟子众名正行者。又言一切有为皆悉无常苦空无我寂灭涅槃。如是等门是名决定。不决定者。若言死者皆生是则不定。有爱则生。爱尽则灭。又经中说若得心定皆生实智。是亦不定。圣人得定能生实智。外道得定则不能生。又如经说所求皆得。是亦不定。或得或不得。若言六入必能生触。是亦不定。或有能生。或有不生。如是等名不定门。又有为不为论门。如说奇草芳花不逆风熏。又说拘毗罗花能逆风闻。为人花故说不逆风闻。为天花故说逆风熏。又说三受。苦受乐受不苦不乐受。又余经说所有诸受皆名为苦。有三种苦。苦苦．坏苦．行苦。为此故说所有诸受一切皆苦。又说。是苦三种有新故中。新受名乐。久厌则苦。中名为舍。又说。为得道故名为道人。未得道者亦名道人。有如是等相因得名。又有近论门。如佛语比丘汝断戏论则得泥洹。虽未便得但以近故亦名为得。又有同相论门。如说一事余同相事皆名已说。又如佛说心为轻躁。则为已说余心数法。又有从多论门。如佛言。若人不知二见生灭相者皆名有欲。若能知者皆名得离。须陀洹人亦知二见生灭之相而有贪欲。但以知者多是离欲人。又有因中说果论门。如说施食则与五事。命色力乐辩才。而实不与命等五事。但与其因。又如说食钱。钱不可食。因钱得食故名食钱。又如经说女人为垢。实非垢也。是贪着等烦恼垢因故名为垢。又说五尘名欲。实非欲也。能生欲故名之为欲。又乐因缘说名为乐。如说以法集人是人为乐。又苦因缘说名为苦。如说与愚同止是名为苦。如说火苦火乐。又说命因为命。如偈中说。资生之具皆是外命。如夺人物名为夺命。又说漏因为漏。如七漏经说。此中二是实漏。其余五事是漏因缘。又有果中说因。如佛言我应受宿业。谓受业果。如是等众多论门。尽应当知

    赞论品第十五

应习此论。所以者何。学习此论得智人法。如经中说。世有二人。一谓智人。一谓愚人。若不善分别阴界诸入十二因缘因果等法是名愚人。若善分别阴界入等是名智人。今此论中正分别解阴界入等。故因此论得智人法。是以应学。又习此论故不名凡夫。又有二人。一是凡夫。一非凡夫。如说虽剃须发被服法衣受佛威仪。犹远佛法以不成就信等根故。若能成就信等根者虽处居家不名凡夫。如经中说。有四种人。有入僧威仪不入僧数。有在僧数非僧威仪。有入僧威仪亦入僧数。有非僧威仪亦非僧数。初名出家凡夫。次名在家圣人。三名出家圣人。四名在家凡夫。以此故知。离信等根则不入僧数。是故当为信等诸根勤行精进。欲得信等。当于佛法听受诵读如说修行。是故应习此佛法论。又从此论得二种利。自利利他。如经中说。有四种人有能自利不能利他有能利他不能自利。有能俱利。有俱不利。若能自具戒等功德不能令他住戒等中是名自利。如是四种。若人虽能自利令他施等得大果故亦名利他。此中佛意不说此利。若人但能为他说法是名利他。是人虽不自随法行。为他说故自亦得利。如经中说为人说法得五种利。此中佛意亦不说此。此中但说最第一利。谓如说行得尽诸漏。是故说法能利他人。以兼利故名人中最。犹众味中之醍醐也。复次是人今处明中。后亦入明。世间众生。多从冥入冥。从明入冥。若少行佛法。是人亦能从冥入明。从明入明。所以者何。行布施等不能得如听佛法利。若少听佛语能得达慧。破诸衰恼获无量利。如经中说。有四种人。有从冥入冥。从冥入明。从明入明。从明入冥。又四种人。有顺流者。有逆流者。有中住者。有得度者。若人一心听佛法者。是人即能除灭五盖修七觉意。是故此人截生死流名逆流者。亦名为住。亦名得度。复有四种人。有常没者。有暂出还没者。有出观者。有得度者。若不能生随顺泥洹信等功德是名常没。或生世间信等功德不能坚固。还复退失。是名暂出还没。起随顺泥洹信等功德分别善恶。是名出观。具足修习随顺泥洹信等功德是名得度。若人能解佛法正义终不常没。设复暂退亦不永失。又此人名为修功德者。若人不修身戒心慧作少恶业亦堕恶道。若人修集身戒心慧。虽多为恶不堕恶道。修身者。以闻慧修身受心法。以修身故渐次能生戒定慧品能灭诸业。灭诸业故生死亦灭。又经中说有四种人。有结使利而不深。有深而不利。有亦深亦利。有不深不利。初名有增上结。时时而来。次名若软中结常来在心。三名若增上结常来在心。四名若软中结有时而来。若人得闻佛法正论。断二种结深而利者。又解佛法义。既不自恼亦不恼他。外道持戒即自恼身。若堕邪见即恼他人。谓无罪福业果报故。若行布施。亦是自恼亦名恼他。如天祠中多杀牛羊。若解佛法义者但为得利。不自恼身亦不恼他。如得禅定行慈悲者。是故应习此佛法论。又习此论者名可与言。解正义故。如经中说。若论议时。应当分别是可与言。是不可与言。若人不住智者法中处非处中若分别中及道中者。是人皆名不可与言。与此相违名可与言。不住智者法中者。论者以正智慧善解义趣。然后执用。此人不知。是故不执。如尼延子等自言我师是可信人但随其语。不住处非处者。不住用因中。诸外道等于二种因共因异因。若他说共因答以异因。他说异因答以共因。不住如是二种因中。不住分别中者不住譬喻中。不住道中者不住论道中。如说论者莫出恶言勿舍义宗。但说实利方便劝诲令得解悟自心欢喜名圣语法。是中若人正知佛法论者乃可与言。非余人也。又不可与言者。有应定答问以不定答。应分别答问以不分别答。应反质答问以不反质答。有应置答问而不置答。与此相违名可与言。应定答问者唯有一因。如佛世尊。世间无等。如此比也。应分别答问者。更有因缘。如死相续等。应反质答问者。如有人问还问令答。应置答问者。若法无实体但有假名。若问此法为一为异常无常等。是不答义唯解佛法者乃能知耳。是故应习此佛法论。又有三种人。正定．邪定．不定。正定者。必入泥洹。邪定者必不入泥洹。余名不定。若人能解佛法义者必入正定。又有四种人。纯罪多罪少罪无罪。纯罪者若人但有不善无一善法。多罪者多恶少善。少罪者多善少恶。无罪者但有善法无有不善。若人能解佛法正义。必入二种少罪无罪。又若人解佛法义。则受苦有量。以必当得至涅槃故

    四法品第十六

若习此论得上摄法。如经中说。有四摄法布施．爱语．利行．同利。布施者衣食等物。以此财施摄取众生。还可败坏。爱语者随意语言。是亦有咎取彼意故。利行者为他求利。若有因缘助他成事。是亦可坏。同利者如共一船。忧喜是同。是或可坏。若人以法布施爱语利行同利摄取众生。则不可坏。以法摄者谓习此论。又习此论得上依止。如经中说依法不依人。有人虽言我从佛闻。若从多识比丘所闻。若从二三比丘所闻。若众中闻。若从大德长宿边闻。不以信此人故便受其语。是语若入修多罗中不违法相随顺比尼。然后应受。入修多罗者谓入了义修多罗中。了义修多罗者谓是义趣不违法相。法相者随顺比尼。比尼名灭。如观有为法常乐我净则不灭贪等。若观有为法无常苦空无我则灭贪等。知无常等名为法相。是应依法不依于人。若说依法则总一切法。是故次说依了义经不依不了义经。了义经者即第三依。谓依于义不依语也。若此语义入修多罗中不违法相随顺比尼。是则依止。依智不依识者识名识色等法。如经中说。能识故识智名通达实法。如经中说。如实知色受想行识故名为智。如实即空。是故识有所得。不应依也。若依于智即是依空。欲通达此上依止故。当习此论。又经中说天人四轮能增善法。一住善处。二依善人。三自发正愿。四宿殖善根。住善处者谓处中国离于五难。依善人者生值佛世。宿殖善根者不聋哑等。自发正愿者是谓正见。正见必从闻佛法生。是故应习此佛法正论。又诵习此论者于寿命中得大坚利。谓通达谛。如经中说。有四坚法说坚．定坚．见坚．解脱坚。说坚者若说一切有为皆无常苦一切无我寂灭泥洹是名说坚。是闻慧满。因此得定名思慧满。因此定故观有为法无常苦等。能得正见名修慧满。三慧得果名解脱坚。又若闻佛法正论则得大利。如经中说四大利法。亲近善人听闻正法。自正忆念。随顺法行。若近善人则闻正法。以此正法在善人故。闻正法已则生正念。以无常等正观诸法。从是正观能随法行。谓无漏见也。又闻此论则具四德处慧德处．实德处．舍德处．寂灭德处。闻法生慧是慧德处。以是智慧见真谛空名实德处。见真空故得离烦恼名舍德处。烦恼尽故心得寂灭是寂灭德处。又人得闻佛法正论。能种随顺泥洹四种善根。所谓暖法．顶法．忍法．世间第一法。以无常等行观五阴时。生顺泥洹下软善根能令心热。是名暖法。暖法增长成中善根。名为顶法。顶法增长成上善根。名为忍法。忍法增长成上上善根。名世间第一法。又有四种善根。退分．住分．增分．达分。离诸禅定。礼敬诵读是等善根名为退分。得定等善根是名住分。从闻思等生诸善根是名增分。无漏善根是名达分。若闻佛法永离退分得三分善根

    四谛品第十七

若人闻佛法义。则能善知分别四谛苦谛．集谛．灭谛．道谛．苦谛者谓三界也。欲界者从阿鼻地狱至他化自在。色界者从梵世至阿迦尼吒。无色界者四无色也。又有四识处色受想行。外道或谓识依神住。故佛说识依此四处。又有四生。卵生．胎生．湿生．化生。诸天地狱一切化生。饿鬼二种胎生化生。余残四生。又有四食。揣食者若粗若细。饭等名粗。酥油香气及诸饮等是名为细。触食者冷暖风等。意思食者。或有人以思愿活命。识食者中阴地狱无色众生。入灭定者虽无现识识得在故亦名识食。又有六道。上罪地狱。中罪畜生。下罪饿鬼。上善天道。中善人道。下善阿修罗道。又有六种。地水火风空识。四大围空有识在中数名为人。又六触入。眼等六根与识和合名为触入。又七识处。于是处中以颠倒力故识贪乐住。又世八法。利衰称讥毁誉苦乐。人在世间必受此事故名世法。九众生居。众生皆以颠倒力故能处此中。又有诸法五种分别。五阴．十二入．十八界．十二因缘．二十二根。五阴者。眼色为色阴。依此生识能取前色是名识阴。即时心生男女怨亲等想名为想阴。若分别知怨亲中人生三种受是名受阴。是三受中生三种烦恼是名行阴。以此事起受身因缘名五受阴。以四缘识生。所谓因缘．次第缘．缘缘．增上缘。以业为因缘。识为次第缘。以识次第生识故色为缘缘。眼为增上缘。此中识从二因缘生。所谓眼色乃至意法名十二入。是中加识名十八界。谓眼界．色界．眼识界等。是阴等法。云何当生。在十二时中故名十二因缘。是中无明是烦恼。行名为业。因此二事。次第生识名色六入触受。爱取二法是名烦恼。有名为业。未来世中初受身识名之为生。余名老死。是十二因缘示有过去未来现在。但众缘生无有我也。又为生死往来还灭。故说二十二根。一切众生初受身时以识为本。是识六种。从眼等生故说六根。所谓眼根乃至意根。能生六识故名六根。可以分别男女相故名男女根。有人名为身根少分。此六根或名六入。从是六事生六种识故名为寿。所以者何。是六入六识得相续生故名为寿。是相续断故名为死。是故此事名之曰命。是中何等是根。所谓业也。以因业故六入六识得相续生。是命中业名为命根。是业从诸受生。诸受即名乐等五根。从此五根生贪爱等一切烦恼及身口业。此业因缘还受生死。是为垢法。能令生死因缘相续。以何因缘能生净法。必因信等。信等四法因缘成慧。慧有三时。谓未知．欲知．知已。修习所作办时。此根皆是智慧差别。佛以生死往来还灭垢净故说二十二根。如是等法苦谛所摄。能知此者是名善知苦谛。集谛者业及烦恼。业者业品中当说。烦恼者烦恼品中当说。诸业烦恼是后身因缘故名集谛。灭谛者后灭谛聚中当广说。谓假名心法心空心。灭此三心故名灭谛。道谛者谓三十七助菩提法。四念处．四正勤．四如意足．五根．五力．七菩提分．八圣道分。四念处者身受心法。中正安念及从念生慧观身无常等安住缘中名身念处。是念及慧渐次转增能分别受名受念处。又转清净能分别心名心念处。能以正行分别诸法名法念处。四正勤者。若生恶不善法见其过患为断故生欲勤精进。断方便谓知见。缘未生恶不善法为不生故生欲勤精进。不生方便谓知见。缘未生善法为生故生欲勤精进。生方便谓知见缘已生善法为增长故生欲勤精进。以上中下次第方便及不退转故。四如意足者。欲三昧妙行成就。修如意分。因欲生三昧名欲三昧。欲精进信猗忆念安慧思舍等妙法共成名妙行成就。功德增长故名如意足。是欲增长名为精进。是名第二。行者有欲有精进故修习定慧得心三昧。所谓定也。思惟三昧所谓慧也。五根者。闻法生信是名信根。信已为断垢法证净法故勤发精进是名精进根。修四念处是名念根。因念能成三昧。是名定根。因定生慧是名慧根。是五根增长有力故名五力。八圣道分者。从闻生慧能信五阴无常苦等。是名正见。是慧若从思生名正思惟。以正思惟断诸不善修集诸善发行精进。从此渐次出家受戒得三道分正语．正业．正命。从此正戒次成念处及诸禅定。因此念定得如实智。名八道分。如是次第。又八道分中戒应在初。所以者何。戒定慧品义次第故。正念正定是名定品。精进常遍一切处行。慧品近道故在后说。是慧二种若粗若妙。粗者闻慧思慧名正思惟。妙者修慧谓入暖等法中。能破假名及五阴法是名正见。以此正见见五阴灭名初入道。从是次得七菩提分。念菩提分者。学人失念则起烦恼故。系念善处系念先来所得正见是名择法。不舍择法故名精进。行精进时烦恼减少心生欢喜故名为喜。以心喜故则身得猗是名为猗。身猗得乐乐则心定。是定难得名为金刚。得无著果断忧喜等故名为舍。是名上行。又不没不发其心平等故名为舍。菩提名无学智。修此七法能得菩提名菩提分。是三十七品得四沙门果。须陀洹果者谓通达空以此空智能断三结。斯陀含果者即修此道能薄烦恼于欲界中余有二生。阿那含果者能断欲界一切烦恼。阿罗汉者断一切烦恼。若能修习此佛法论。则能通达四谛。得四沙门果。故应修习此正法论

    法聚品第十八

习此论者。则能通达可知等法聚。以通达故。外道邪论不能制伏。亦能速灭烦恼。自能离苦亦能济人。可知等法聚者。谓可知法．可识法。色法．无色法。可见法．不可见法。有对法．无对法。有漏法．无漏法。有为法．无为法。心法．非心法。心数法．非心数法。心相应法．心不相应法。心共有法．心不共有法。随心行法．不随心行法。内法．外法。粗法．细法。上法．下法。近法．远法。受法．非受法。出法．非出法。共凡夫法．不共凡夫法。次第法．非次第法。有次第法．无次第法。如是等二法。又有三法。色法．心法．心不相应法。过去法．未来法．现在法。善法．不善法．无记法。学法．无学法．非学非无学法。见谛断法．思惟断法．无断法。如是等三法。又有四法。欲界系法．色界系法．无色界系法．不系法。又有四道。苦难行道．苦易行道．乐难行道．乐易行道。又有四味。出味．离味．寂灭味．正智味。又有四证法。身证法．念证法．眼证法．慧证法。四受身。四入胎。四缘。四信。四圣种。四恶行。如是等。四法。五阴。六种。六内入。六外入。六生性。六喜行。六忧行。六舍行。六妙行。七净。八福生。九次第灭。十圣处。十二因缘。如是可知等法聚无量无边不可说尽。我今略举其要。可知法者第一义谛也。可识法者谓世谛也。色法者色声香味触也。无色法者心及无作法也。可见法者谓色入也。有对法者色法是也。有漏法者若法能生诸漏。如非阿罗汉假名法中心是也。与上相违名无漏法也。有为法者从众缘生。五阴是也。无为法者五阴尽灭是也。心法者能缘是也。心数法者若识得缘即次第生想等是也。心相应法者谓识得缘次第必生如想等是也。心共有法者谓法心共有如色心不相应行是也。随心行法者若法有心则生无心不生。如身口无作业也。内法者己身内六入也。粗细法者相待有也。如观五欲色定为细。观无色定色定为粗也。上下法者亦如是也。近远法者或异方故远。或不相似故远也。受法者从身生法也。出法者谓善法也。共凡夫法者有漏法也。次第法者从他次第生也。有次第法者能生次第也。色法者色等五法也。心法者如上说也。心不相应行者无作业也。过去法者已灭法也。未来法者当生法也。现在法者生而未灭也。善法者为利益他众生及真实智也。与上相违名不善法也。二俱相违名无记法也。学法者学人无漏心法也。无学法者无学人在第一义心也。余名非学非无学也。见谛断法者谓须陀洹所断示相我慢及从此生法也。思惟断法者。谓须陀洹斯陀含阿那含所断不示相我慢及从此生法也。无断法者谓无漏也。欲界系法者若法报得阿鼻地狱乃至他化自在天也。色界系法者从梵世乃至阿迦尼吒天也。无色界系法者四无色也。不系法者无漏法也。苦难行道者钝根得定行道者是也。苦易行道者利根得定行道者是也。乐难行道者钝根得慧行道者是也。乐易行道者利根得慧行道者是也。出味者出家求道也。离味者身心远离也。寂灭味者得禅定也。正智味者通达四谛也。念证法者四念处也。因是念处能生四禅是名身证。因四禅故能生三明名为眼证。通达四谛名为慧证。四受身。有能自害他不能害。有为他害不能自害。有能自害他亦能害。有不自害不为他害。四入胎者。有不自念入胎亦不自念住胎出胎。有自念入胎而不自念住胎出胎。有自念入胎住胎而不自念出胎。有自念入胎住胎出胎。以颠倒心乱故不自念。心正不乱故能自念。四缘。因缘者。生因．习因．依因。生因者若法生时能与作因。如业为报因。习因者如习贪欲贪欲增长。依因者如心心数法依色香等。是名因缘。次第缘者如以前心法灭故后心得次第生。缘缘者若从缘生法如色能生眼识。增上缘者谓法生时诸余缘也。信佛者谓得真智于佛生清净心决定知佛于众生中尊。信此真智即是信法。得是智者一切众中最为第一。是名信僧。得圣所爱戒。谓以深心不造诸恶。知我因是戒能信三宝。信是戒力故名信戒也。以四圣种故不为衣服爱之所染。不为饮食卧具从身爱之所染。故名四圣种。四恶行以贪故嗔故怖畏故痴故堕恶道中。色阴者色等五法也。受阴者能缘法也。想阴者能分别假名法也。行阴者能生后身法也。识阴者唯能识尘法也。地种者色香味触和合。坚相多者名为地种。湿相多者名为水种。热相多者名为火种。轻相多者名为风种。色相无故说名空种。能缘法故名为识种。眼入者四大和合眼识所依故名眼入。耳鼻舌身入亦如是。意入者谓心也。色入者眼识所缘法也。声香味触法入亦如是。六生性者。谓黑性人能习黑法。亦习白法及黑白法。白性人亦如是也。六喜行者依贪心也。六忧行者依嗔心也。六舍行者依痴心也。六妙行者实智慧也。七净戒净者戒律仪也。心净者得禅定也。见净者断身见也。度疑净者断疑结也。道非道知见净者断戒取也。行知见净者思惟道也。行断知见净者无学道也。八福生者人中富贵乃至梵世也。诸福报乐此中最多故说此八也。九次第灭者入初禅灭语言。二禅灭觉观。三禅灭喜。四禅灭出入息。虚空处灭色相。识处灭无边虚空相。无所有处灭无边识相。非想非非想处灭无所有想入灭尽定灭受及想也。十圣处者圣人断五法成六法。守一法依四法。灭伪谛舍诸求。不浊思惟离诸身行。善得心解脱。善得慧解脱。所作已办。独而无侣。断五法者断五上结得阿罗汉一切结尽。行六妙法。眼等诸情于色等尘不忧不喜亦不痴故。守一法者系念身也。依四法者谓乞食等四依法也。复有人言。依四法者圣人有法远离。有法亲近。有法除灭。有法忍受。净持戒故能达实相名离伪谛。断一切见名得初果。舍诸求者谓欲求．有求．及梵行求。得初果故知有为法皆是虚诳。欲舍三求。得金刚三昧已。舍于学道。尔时能尽名舍诸求。不浊思惟者灭六种觉心得清净。能薄三毒得第二果。灭除贪忧得第三果名不浊思惟。离身行者除欲界结得四禅故名离身行。得尽智故名善得心解脱。得无生智故名善得慧解脱。诸圣人心住此十处故名圣处。佛法所作必应尽苦故曰所作已办。远离凡夫及诸学人故曰无侣。心离诸法住毕竟空故名为独。十二因缘。无明者谓随假名心。因此倒心能集诸业故曰无明缘行。识随业故能受有身。故曰行缘识也。受有身已。名为名色六入触受。此诸分等随时渐增。受诸受时依止假名故能生爱。因爱生余烦恼故名为取。爱取因缘有。是名三分。从是诸业烦恼因缘后世中生。从生因缘有老死等。是中若说无明诸行则明过去世有。令断常见知从无始生死往来从业烦恼因缘受身。若说生死则明未来世有。令断断见。若不得真智则生死无边。但有苦果。若说中间八分。明现在法。但从众缘相续故生无有真实。此中无明诸行是先世因缘。此因缘果谓识名色六入触受。从此五事起爱取有。是未来世因。此因缘果谓生老死。若受诸受时还生爱取。是故此十二分轮转无穷。能得真智则不集诸业。诸业不集则无有生。生名起成。若人习此正论。则知诸法皆自相空不集诸业。诸业不集则无有生。无有生故老死忧悲苦恼都灭。故欲自利兼利众生渐成佛道。炽然自法。灭他法者。当习此论

    十论初有相品第十九

问曰。汝经初言广习诸异论。欲论佛法义。何等是诸异论。答曰。于三藏中多诸异论。但人多喜起诤论者。所谓二世有．二世无。一切有．一切无。中阴有．中阴无。四谛次第得．一时得。有退．无退。使与心相应．心不相应。心性本净．性本不净。已受报业或有或无。佛在僧数不在僧数。有人无人。有人言二世法有或有言无。问曰。何因缘故说有。何因缘故说无。答曰。有者。若有法是中生心。二世法中能生心故。当知是有。问曰。汝当先说有相。答曰。知所行处名曰有相。难曰。知亦行于无所有处。所以者何。如信解观非青见青。又所作幻事亦无而见有。又以知无所有故名入无所有处定。又以指按目则见二月。又经中说。我知内无贪欲。又经中说。知色中贪断。名为色断。又如梦中无而妄见。以是等缘知亦行于无所有处。不可以知所行处故名为有。答曰。无有知行无所有处。所以者何。要以二法因缘故识得生。一依二缘。若当无缘而识生者亦应无依而识得生。然则二法无用。如是亦无解脱。识应常生。是故知识不行于无。又以有所识故名为识。若无所识则亦无识。又说识能识尘。谓眼识识色。乃至意识识法。若言有无缘识。此识何所识耶。又若言有无缘识是则错谬。如有人言我狂心乱世间所无而我皆见。又若知无所有不应生疑。以有所知故得生疑。又经中说。若世间所无我知见者。无有是处。又汝言自相违。若无何所知耶。又经中说。能缘法者是心心数法。亦说一切诸法皆是所缘。此中不说无法为缘。又诸尘是生识因。若无以何为因。又经中说。三事和合故名为触。若法无者何所和合。又无缘之知云何可得。若知则不无。若无则不知。是故无无缘知。又汝言知行无所有处如信解观非青见青者无有是处。所以者何。是非青中实有青性。如经中说。是木中有净性。又取青相心力转广。一切尽青。非无青相。又幻网经说。有幻幻事者无众生中见似众生。故名为幻。又汝言以知无所有故名入。无所有处定者。以三昧力故生此无相。非是无也。如实有色坏为空相。又入是三昧所见法少故名为无。如盐少故名无盐。慧少故名无慧。又如说非有想非无想处。是中虽实有想。亦说非有非无。又汝言以指按目见二月者。见不审故以一为二。若合一眼则不见二。又汝言我知内无欲者。是人见五盖相违七觉法故。便生念言我知无欲。非知无也。又汝言知色中贪断名色断者。见真实慧与妄解相违故名贪断。又汝言梦中无而见者。因先见闻忆念分别及所修习故梦中见。又冷热气盛故随梦见。或以业缘故梦。如菩萨有诸大梦。或天神等来为现梦。是故梦中见有。非知无也。难曰。汝言要以二法因缘识得生者。是事不然。佛破神我故说二法因缘生识。非尽然也。又汝言以有所识故名识者。识法有则知有。无则知无。若此事无。以无此事故名为见空。又三心灭故名为灭谛。若无空心何所灭耶。又汝言眼识识色乃至意识识法者。是识但能识尘不辩有无。又汝言若有无缘识是则错乱者。则有知无之知。如狂病人见所无者。又汝言若知无不应生疑者。若疑为有为无。则有无缘知也。又汝言如经中说若世间所无我若知见无是处者。是经不顺法相。似非佛语。或三昧如是。入此三昧所见尽有。为是三昧故如是说。又汝言汝言自相违者。我言缘无非相违也。又汝言心心数法能缘一切法。是缘者有心心数法。而无所缘。亦心心数法不能实缘。故不名缘。又诸法实相。离诸相故不名为缘。又汝言诸尘是生识因若无以何为因者。即以无为因。又汝言三事和合名为触者。若三事可得则有和合。非一切处尽有三事。又汝言若知不无若无不知者。若有缘知亦同是过。又汝言如木中有净性者。是事不然。有因中有果过故。又汝言取相心转广者。是亦不然。本青相少。而见大地一切皆青则是妄见。如是观少青故。能见阎浮提尽皆是青非妄见耶。又汝言幻网经说有幻幻事者无众生中见似众生为众生事。此事实无而见。则是无缘知也。又汝言以三昧力故生此无相如实有色坏为空者。若色实有而坏为空则是颠倒。又少而言无亦无颠倒。又汝言见不审者。是事不然。如眼气病人见空中有毛其实无也。又汝言见五盖相违七觉法故便生念言我知无者。七觉法异。无贪亦异。云何为一。又汝言见真实慧与妄解相违名贪断者。妄解名虚妄观。是故说知欲断故色断真实慧者。无常观也。又汝言梦中见实者。是事不然。如梦堕舍而实不堕。是故有知无之知。不以知行故名有相

    无相品第二十

问曰。若此非有相。今阴界入所摄法应当是有。答曰。此亦不然。所以者何。是人说凡夫法阴界入摄。是事不顺法相。若然者有说如等诸无为法亦应是有。而此实无。故知阴界入所摄法非是有相。问曰。若人以现知等信有所得。名为有相。答曰。此亦非有相。是可信法。决定分别不可得说。又有经说应依于智不应依识。以性得故。色等诸尘不可得。后当广说。此无相不坏。有所得相云何可立。问曰。有与法合故名为有。答曰。有后当破。又有中无有。云何有与法合故名有耶。以是因缘。有相决定分别不可得说。但以世谛故有。非第一义。问曰。若以世谛有者。今还以世谛故。说过去未来为有为无。答曰。无也。所以者何。若色等诸阴在现在世能有所作。可得见知。如经中说。恼坏是色相。若在现在则可恼坏。非去来也。受等亦然。故知但有现在五阴。二世无也

复次若法无作则无自相。若过去火不能烧者不名为火。识亦如是。若在过去不能识者则不名识。复次若无因而有。是事不然。过去法无因可有。是故不然。复次凡所有法皆众缘生。如有地有种水等因缘则牙等生。有纸笔人功则字得成。二法等合则有识生。未来世中牙字识等因缘未会。云何得有。是故二世不应有也。复次若未来法有。是则为常。以从未来至现在故。如从舍至舍则无无常。是事不可。又经中说。眼生无所从来。灭无所至。是故不应分别去来法也。复次若未来有眼色识者则应有作。过去亦尔。而实不然。是故知无去来法也。又去来色有则应有对有碍。而实不然。是故无也。复次若瓶等物未来有者。则陶师等不应有作。而现有作故。无未来有。又佛说有为法三相可得。生灭住异。生者若法先无今现有作。灭者作已还无。住异者相续故住变故名异。是三有为相皆在现在。非过去未来

    二世有品第二十一

问曰。实有过去未来。所以者何。若法是有。此中生心。如现在法及无为法。又佛说色相。亦说过去及未来色。又说凡所有色。若内若外。若粗若细。若过去未来现在。总名色阴。又说过去未来色尚无常。何况现在。无常是有为相。是故应说有。又现见从智生智。以修习故。如从稻生稻。是故应有过去。若无过去果则无因。又经中说。若过去事实而有益。佛则说之。又说应观过去未来一切无我。又缘未来意识。依过去意。若无过去识何所依。又知过去业有未来果。是名正见。又佛十力知去来诸业。又佛自说。若无过去所作罪业。是人终不堕诸恶道。又学人若在有漏心中。则不应有信等诸无漏根。又诸圣人不应决定记未来事。又若无去来则人不应忆念五尘。所以者何。意识不知现五尘故。又说十八意行皆缘过去。又若无去来则阿罗汉不应自称我得禅定。以在定中无言说故。又四念处中。不应得观内心内受。所以者何。现在不得观过去故。又亦不应修四正勤。所以者何。未来世中无恶法故。余三亦尔。又若无去来。则无有佛。又亦不应有修戒久近。是故不然

    二世无品第二十二

答曰。过去未来无。汝虽说有法中生心。是先已答。无法亦能生心。又汝说色相色数色可相者。是事不然。过去未来不应是色。无恼坏故。亦不可说无常相也。但佛随众生妄想分别故说其名。又汝言智生智者。因与果作因缘已灭。如种与牙作因已灭。佛亦说是事生故是事生。又汝言实而有益佛则说者。佛说是事本现在时。不言犹有。若说过去灭尽则知无有。又汝言观无我者。以众生于去来法计有我故。佛如是说。又汝言是正见者。以此身起业。此业与果作因已灭。复后还自受故说有果。于佛法中若有若无皆方便说。为示罪福业因缘故。非第一义。如以因缘说有众生。去来亦尔。依过去意者。是方便依。不如人依壁等。亦明心生不依于神。因先心故后心得生。业力亦尔。佛知是业虽灭而能与果作因。不言定知如字在纸。罪业亦尔。以此身造业是业虽灭果报不失。又汝言不应有诸无漏根者。若学人得无漏根已得在现在。虽过去灭未来未至。以成就故不得言无。又汝言圣人不应记未来者。圣智力尔。虽未有法而能玄记。如过去法虽已灭尽念力能知。又汝言不应念五尘者。是凡夫人痴故妄念先取定相。后虽灭尽犹生忆念。忆法应尔。非如兔角等。十八意行亦复如是。现在取色。虽灭过去亦随忆念。又汝言不应自称我得禅定者。是定得在现在忆念力故自言我得。又汝言不应得观内心内受者。有二种心。一念念生灭。二次第相续。用现在心观相续心。非今犹在。又汝言不应修习四正勤者。防未来世恶法因缘。亦起未来善法因缘。又汝言则无佛者。佛寂灭相。虽现于世不摄有无。况灭度耶。众生归命。亦如世人祠祀父母。又汝言亦不应有修戒久近者。不以时故。戒有差别。所以者何。时法无实。但以诸法和合生灭故名有时。是故汝所说因是皆不然

    一切有无品第二十三

论者言。有人说一切法有。或说一切法无。问曰。何因缘故说有。何因缘故言无。答曰。有者佛说十二入名为一切。是一切有地等诸陀罗骠。数等诸求那。举下等诸业。总相别相和合等法。及波居帝本性等。及世间事中兔角龟毛蛇足盐香风色等。是名无。又经中佛说。虚空无辙迹。外道无沙门。凡夫乐戏论。如来则无有。又随所受法亦名为有。如陀罗骠等六事是优楼佉有。二十五谛是僧佉有。十六种义是那耶修摩有。又若有道理能成办事亦名为有。如十二入。又佛法中以方便故说一切有一切无。非第一义。所以者何。若决定有即堕常边。若决定无则堕断边。离此二边名圣中道

成实论卷第二成实论卷第三

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    有中阴品第二十四

论者言。有人说有中阴或有说无。问曰。何因缘故说有。何因缘故言无。答曰。有中阴者。佛阿输罗耶那经中说。若父母会时。众住随何处来。依止其中。是故知有中阴。又和蹉经说。若众生舍此阴已。未受心生身。于是中间我说爱为因缘。是名中阴。又七善人中有中有灭者。又经中说。杂起业杂受身杂生世间。当知有中阴。又经中说四有。本有．死有．中有．生有。又说七有。五道有业有中有。又说。阎王呵责中阴罪人令颠倒堕又佛因中阴知众生宿命。谓此众生生此处。彼众生生彼处。又经中说。以天眼见诸众生死时生时。又说。众生为阴所缚故。从此世间至彼世间。又世人亦信有中阴言。若人死时有微四大从此阴去。又若有中阴则有后世。若无中阴者。舍此身已未受后身中间应断。以是故知有中阴

    无中阴品第二十五

有人言无有中阴。汝虽言阿输罗耶那经中说有中阴。是事不然。所以者何。若是圣人不知此为是谁从何处来。则无中阴。若有者何故不知。又汝言和蹉经说。是事不然。所以者何。是经中问异答异。是和蹉梵志所计身异神异故如是答。中阴中有五阴。又汝言有中有灭者。是人于欲色界中间受身。于此中灭故名有中有灭也。所以者何。如经中说若人死何处去何处在何处。是义无异。又汝言杂受身杂生世间者。若言受身言生世间。是义不异。又汝言四有七有者。是经不然。以不顺法相故。又汝言阎王呵责者。此在生有非中有也。又汝言佛因中阴知宿命者。是事不然。圣智力尔。虽不相续亦能念知。又汝言天眼见死时生时者。欲生名生时。将死名死时。非中阴也。又汝言众生为阴所缚从此至彼者。示有后世故如是说。不明有中阴也。又汝言死时有微四大去者。世人所见。不可信也。此非用因。又汝言若无中阴中间应断者。以业力故。此人生此。彼人生彼。如过去未来虽不相续。而能忆念。是故无有中阴。复次宿命智中说知此人此间死彼间生。不说住中阴中。复次佛说三种业。现报．生报。及后报业。不说有中阴报业。复次若中阴有触即名生有。若不能触是则无触。触无故受等亦无。如是何所有耶。又若众生受中阴形。即名受生。如经中说。若人舍此身受余身者。我说名生。若不受身则无中阴。复次若中阴有退。即名为生。所以者何。要先生后退故。若无退是则为常。又以业力故生。何用中阴。又若中阴从业成者。即是生有。如说业因缘生。若不从业成。何由而有。是应速答。答曰。我以生有差别说名中阴。是故无如上过。是人虽中阴生亦与生有异。能令识到迦罗罗中。是名中阴。难曰。以业力能至。何用分别说中阴耶。又心无所至。以业因缘故从此间灭于彼处生。又现见心不相续生。如人刺足头中觉痛。此足中识无有因缘至于头中。以近远众缘和合生心。是故不应分别计有中阴

    次第品第二十六

论者言。有人说四谛次第见。有人说一时见。问曰。何因缘故说次第见。何因缘故言一时见。答曰。次第见者如经中说。若人见世间集即灭无见。见世间灭即灭有见。当知集灭二相各异。又若人能知所有集相皆是灭相。是名离垢得法眼净。又说。利智慧人渐舍诸恶。如练金师能离身垢。又漏尽经说。能知见者则漏得尽。行者不能自知日日所尽常修习故得尽诸漏。复次佛言。于诸谛中能生眼智明慧。欲界苦中二色无色界二。集等亦尔。又经中佛自口说。渐次见谛。如人登梯。次第而上。以是等经故。知四谛非一时得。又诸烦恼于四谛中四种邪行。所谓无苦无集无灭无道。故无漏智亦应次第四种正行。又行者应定心分别是苦是苦因是苦灭是苦灭道。若一心中何得如是决定分别。故知次第非一时也

    一时品第二十七

有人言。四谛一时见非次第。汝说见世间集即灭无见。见世间灭则灭有见者则坏自法。若然者亦不应以十六心十二行得道。又汝言知所有集相皆是灭相得法眼者。若尔便应以二心得道。一者集心。二谓灭心。但不然。又汝言利智渐舍恶者。亦不应但十六心也。又汝言漏尽经说能知色等得漏尽者。如是则应有无量心。非但十六心。又汝言眼智明慧者。佛自言。于四谛中得眼智明慧。不言次第有十六心。又汝言佛自口说渐次见谛如登梯者。我不习此经。设有应弃。以不顺法相故。又汝言四种邪行者。于五阴等亦应邪行。随所邪行皆应生智。如是则不应但以十六心得道。又汝言应定分别者。于色等中亦应分别。是故不但应有十六心也。复次行者不得诸谛唯有一谛。谓见苦灭名初得道。以见法等诸因缘故。行者从暖等法渐次见谛灭谛。最后见灭谛。故名为得道

    退品第二十八

论者言。有人说阿罗汉退。或说不退。问曰。何因缘故说退。何因缘故言不退。答曰。有退者如经中说。时解脱阿罗汉以五因缘故退。乐作务。乐诵读。乐断事。乐远行。长病。又经说二种阿罗汉退相．不退相。又经中说。若某比丘退解脱门。则有是处。又经中说。观身如瓶。防意如城。慧与魔战。守胜无坏。若无退者不应守胜。又二种智。尽智．无生智。若尽智不复生者。何用无生智。又优陀耶难得灭尽定者即是退因。是人虽退亦生色界。以是等缘当知有退

    不退品第二十九

有人言。圣道不退。但退禅定。问曰。若然者无二种阿罗汉。但有退相。以一切阿罗汉于禅定中皆有退故。答曰。退禅定中自在力。非一切阿罗汉皆得自在力。问曰。不然。如劬提比丘。六反退已。便以刀自害。若退禅定者不应自害。以佛法中贵解脱不贵定故。答曰。是人依此禅定当得阿罗汉道。失此定故则失无漏。非无漏有退。所以者何。如偈说。毕故不造新。于诸有中皆得厌离。灭诸结使更无生相。是诸健人犹如灯灭。又说。譬如石山风不能动。健者如是。毁誉不倾。又经中说。爱生爱等。是阿罗汉永拔爱根。何从生结。又说。所谓圣人究竟尽边。所作已办。又说。圣人散灭不集。破裂不识等。又经中说。无明因缘起贪恚痴。是阿罗汉无明永尽。云何生结。又经中说。若诸学人求泥洹道。我说是人应不放逸。若得漏尽不复漏也。是故不退。又说。智者善思惟。善语言善身业。所作无失。又说。比丘乐不放逸见放逸过。是则不退。亲近泥洹。又经中说。麋鹿依野。鸟依虚空。法归分别。真人归灭。又三因缘起诸结使。贪欲不断所欲现前中生邪念。是阿罗汉贪欲已断。虽对所欲不生邪念。故不起结。又说。比丘邪观诸法故起三漏。是阿罗汉无邪观故不起诸漏。又经中说。若以圣慧知已则无有退。如须陀洹果无有退者。又阿罗汉。善知三受生相．灭相．味过出相。故不起结。又说。比丘若戒定慧三事成就则不退转。又阿罗汉断已生结。未生者令不生。又经中说。实行圣人终无有退。阿罗汉已证四谛。诸漏尽故名实行者。又说。七觉名不退法。阿罗汉具足七觉。是故不退。又阿罗汉证不坏解脱。是故不退。又阿罗汉于佛法中得坚固利。所谓不坏解脱。又如人截手。念与不念常名截手。阿罗汉亦尔。断结使已。念与不念常名为断。又经中说。信等根利名阿罗汉。利根者终无有退。又阿罗汉能于无上断爱法中。心善得解脱。毕竟尽灭。又譬如火烧所未烧。烧已不还本处。比丘如是已能成就十一法故终无有退。问曰。有二种阿罗汉。汝所引经说不退者。答曰。此是总相说。诸学人应不放逸。阿罗汉不须非是别相说。不退相者。又佛说偈。胜若还生不名为胜。胜而不生是名真胜。若阿罗汉还生烦恼则不名胜。又阿罗汉生已尽故不复受身。汝经虽说阿罗汉退法应还得。若尔亦可法应不退。若比丘能令诸相不生名阿罗汉。是故无退

    心性品第三十

论者言。有人说心性本净以客尘故不净。又说不然。问曰。何因缘故说本净。何因缘故说不然。答曰。不然者。心非性本净客尘故不净。所以者何。烦恼与心常相应生。非是客相。又三种心。善．不善．无记。善无记心是则非垢。若不善心本自不净。不以客故。复次是心念念生灭不待烦恼。若烦恼共生不名为客。问曰。心名但觉色等。然后取相。从相生诸烦恼。与心作垢。故说本净。答曰。不然。是心心时即灭未有垢相。心时灭已垢何所染。问曰。我不为念念灭心故如是说。以相续心故说垢染。答曰。是相续心世谛故有。非真实义。此不应说。又于世谛是亦多过。心生已灭未生未起云何相续。是故心性非是本净客尘故不净。但佛为众生谓心常在。故说客尘所染则心不净。又佛为懈怠众生若闻心本不净。便谓性不可改。则不发净心。故说本净

    相应不相应品第三十一

论者言。有人说诸使心相应。有说心不相应。问曰。何因缘故说心相应。何因缘故言不相应。答曰。心相应者。后使品中当说。又贪欲等诸烦恼业。是业诸使相应。汝法中虽说心不相应使。与心相应结缠作因。是事不然。所以者何。经中说。从无明邪念邪思惟等起贪等结。无有经说从使生也。汝法中虽说久习结缠则名为使生。是事不然。所以者何。身口业等亦有久习相。是亦应有似使心不相应行。而实无有。若然者。诸法皆从现在因生。无过去因。然则不应从业生报。亦不应从意生意识也。又此诸使念念灭故。复何因生。问曰。共相因生。答曰。是亦不然。因果不得一时合故。此事后灯喻中当说。故不应言诸使非心相应

    过去业品第三十二

论者言。迦叶鞞道人说。未受报业过去世有。余过去无。答曰。此业若失则过去。过去若不失是则为常。失者过去异名。则为失已。复失是业与报作因已灭。报在后生。如经中说以是事故。是事得生。如乳灭时与酪作因。何用分别过去业耶。又若言若然者。余因中有过。云何无因而识得生。如无乳时何得有酪。若无四大。身口等业何依而有。如是等我先说过去有过。彼应答此

    辩三宝品第三十三

论者言。摩醯舍婆道人说。佛在僧数。答曰。若说佛在四众。所谓有众．生众．人众．圣人众。是则非过。若言佛在声闻众中是则有咎。以闻法得悟故曰声闻。佛相异故不在此中。问曰。佛居僧之首。有人施者名为施僧。答曰。此施属何等僧。此经小失。是应当言施属佛僧。问曰。佛语瞿昙弥。以此衣施僧。则为供养我。亦是供养僧。答曰。佛意言以语言为供养我是物供养僧。如经中说若人瞻病即是看我。问曰。诸有成就圣功德人。舍利弗等皆在僧数中。佛亦如是。以同相故。答曰。若以同相者。诸凡夫人及非众生数。亦有应入僧数者。而不然。是故知佛不在僧中。又佛不入僧羯磨中。亦不同诸余僧事。又以三宝差别故。佛不在僧中

    无我品第三十四

论者言。犊子道人说有我。余者说无。问曰。何者为实。答曰。实无我法。所以者何。如经中佛语比丘。但以名字但假施设。但以有用故名为我。以但名字等故知无真实。又经中说。若人不见苦。是人则见我。若如实见苦。则不复见我。若实有我。见苦者亦应见我。又说。圣人但随俗故说言有我。又经中佛说。我即是动处。若实有者不名动处。如眼有故不名动处。又处处经中皆遮计我。如圣比丘尼语魔王言。汝所谓众生是即为邪见。诸有为法聚皆空无众生。又言。诸行和合相续故有。即是幻化诳惑凡夫。皆为怨贼如箭入心。无有坚实。又言。无我无我所无众生无人。但是空。五阴生灭坏败相。有业有果报。作者不可得。众缘和合故有诸法相续。以是等缘故。佛种种经中皆遮计我。是故无我。又经中解识义。何故名识。谓能识色乃至识法。不说识我。是故无我。群那比丘问佛。谁食识食。佛言。我不说有食识食者。若有我应说我食识食。以不说故当知无我。又洴沙王迎佛经中。佛语诸比丘。汝观凡夫随逐假名谓为有我。是五阴中实无我无我所。又说。因五阴故有种种名。谓我众生人天等如是无量名字。皆因五阴有。若有我者应说因我。又长老弗尼迦谓外道言。若人邪见无而谓有。佛断此邪慢不断众生。是故无我。又炎摩伽经中。舍利弗语炎摩伽言。汝见色阴是阿罗汉耶。答言不也。见受想行识是阿罗汉耶。答言不也。见五阴和合是阿罗汉耶。答言不也。见离五阴是阿罗汉耶。答言不也。舍利弗言。若如是推求不可得者。应当言阿罗汉死后无耶。答言。舍利弗。我先有恶邪见。今闻此义。是见即灭。若有我者不名恶耶。又四取中说我语取。若有我者应言我取。如欲取等。不应言我语取。又先尼经说。于三师中若有不得现我后我。我说是师则名为佛。以佛不得故知无我。又无我中我想名为颠倒。若汝意谓我中我想非颠倒者。是事不然。所以者何。佛说众生所有见我皆见五阴。是故无我。又说。众生种种忆念宿命。皆念五阴。若有我者亦应念我。以不念故当知无我。若汝意谓亦有经说忆念众生。如某众生中我名某者。是事不然。此为世谛分别故说实念五阴。非念众生。所以者何。以意识念意识。但缘于法。是故无有念众生念。又若人说决定有我。于六邪见中必堕一见。若汝意谓无我亦是邪见者。此事不然。所以者何。以二谛故。若以世谛说无我。第一义谛说有我。是则有过。我今说第一义故无。世谛故有。是故无咎又佛说拔我见根。如痴王问中佛答痴王。若人以一心观诸世间空。则拔我见根不复见死。王又诸说有我因缘忧喜等事。皆在五阴。又以破诸外道我见因缘。是故无我

    有我无我品第三十五

问曰。汝言无我。是事不然。所以者何。四种答中是第四置答。谓人死后若有若无。亦有亦无。非有非无。若实无我不应有此置答。又若人言无有众生受后身者。即是邪见。又十二部经中有本生经。佛自说言彼时大喜见王我身是也。如是等本生。今五阴非昔五阴。是故有我从本至今。又佛说今喜后喜为善两喜。若但五阴。不应两喜。又经中说心垢故众生垢。心净故众生净。又一人生世间。多人得衰恼。一人生世间。多人得利益。又若修集善不善业皆依众生。不依非众生数。又处处经中佛自说我言有众生能受后身。又能自利不利他等。以是等缘故知有我。汝先虽说但名字等。是事不然。所以者何。佛但以外道离五阴已别计有我常不坏相。断此邪见故言无我。今我等说五阴和合名之为我。是故无咎。又虽言我但名字等应深思惟此言。若众生但名字者。如杀泥牛。不得杀罪。若杀实牛。亦不应有罪。又如小儿以名字物施。皆有果报。大人持施亦应得报。而实不然。又但名字故无而说有者。圣人应有妄语。以实语故名为圣人。故知有我。又若圣人见实无我。而随俗故说有我者则是倒见。以异说故。又若随俗无而说有。则不应复说经中实义十二因缘三解脱门无我法等。若人谓有后世随而言有。若人谓无随人言无。又诸世间万物皆从自在天生。如是种种邪见经书。皆应随说。是事不可。是故汝所引经。皆已总破。故非无我。答曰。汝先言以置答故知有我者。是事不然。所以者何。此不可说法。后灭谛聚中当广分别。故无实我及不可说者。但假名说非实有也。又汝法中我以六识识。如汝经说。因眼所见色故我坏。是则眼识所识。则不应言非色非非色。声等亦尔。复次若我六识所识则与经相违。经中说。五情不能互取五尘所伺异故。若我可六识识则六根互用。又汝所言前后相违。眼识所识则不名为色。又汝言无我是邪见者。经中佛自告诸比丘。虽无有我。因诸行相续故说有生死。我以天眼。见诸众生生时死时。亦不说是我。又汝自法中有过。汝法中言我不生。若不生则无父母。无父母则无逆罪。亦无诸余罪业。是故汝法即是邪见。又汝言有本生者。因五阴故。名喜见王。即彼阴相续故名佛。故说我是彼王。汝法中我是一。故不应差别。又汝言为善两喜者。经中佛自遮是事。言我不说有。舍此五阴。受彼阴者。但以五阴相续不异故言两喜。又汝言心垢故众生垢者。以此故知无有实我。若实有我。应与心异。不应言心垢故众生垢。所以者何。不可彼垢此受故。但以假名因缘有垢故。言假名垢。是故假名为我。非真实也。又汝法中说我非五阴。是则不生不灭。无罪福等。有如是过。我等说五阴和合假名为我。因是我故。有生有灭。及罪福等。非无假名。但非实耳。又汝先言破外道意故佛说无我者。汝自妄想如是分别。佛意不然。又种种说我。皆是过咎。如汝言外道离五阴已别计有我。汝亦如是。所以者何。五阴无常。我不可说若常无常。是即离阴。复次阴有三分。戒定慧品。善不善无记。欲界色界无色界系。如是分别。我不得尔。故异五阴。又我是人。五阴非人。是则为异。又阴是五。我是一。是故我非阴也。若有我者。以此等缘。则异五阴。又世间无有一法不可说一不可说异。是故无有不可说法。问曰。如然可然。不得言一。不得言异。我亦如是。答曰。是亦同疑。何者是然。何者可然。若火种是然。余种是可然。则然异可然。若火种即是可然。云何言不一。若可然即是火种。若离火种。亦俱不然。故名同疑。若然有可然。如我有色。即堕身见。又应多我。如薪火异牛粪火异。我亦如是。人阴我异。天阴我异。是即多我。又如然可然在三世中。我与五阴。亦应如是在三世中。如然可然。是有为故。我与五阴。亦应有为。又汝虽言然与可然不一不异。然眼见异相。我与五阴。亦应有异。又五阴失。而我不失。以此间没。至彼间生。有两喜故。若随五阴有失有生。则同五阴不名两喜。汝以妄想分别是我。得何等利。又诸尘中。无有一尘六识所识。汝所说我。可六识识。则非六尘。又十二入不摄。则非诸入。四谛不摄。则非诸谛。是故若谓有我。即为妄语。又汝法中说。可知法者。谓五法藏。过去未来现在无为。及不可说法。我在第五法中。则异于四法。汝欲令异于四法。而非第五。是则不可。若言有我。则有此等过。何用妄想分别我耶。是故汝先说外道离五阴已。别计有我。我等不尔。是事不然。又汝先言我但假名应深思者。是事不然。所以者何。是佛法中。说世谛事。不应深思。又汝说妄语见倒。亦复如是。又汝言不应说经中实义者。是事应说。令知第一义故。又汝言世间所说尽应随者。若说从自在天生万物等。是不可受。若有利益。不违实义。是则应受。是故无咎。若世谛中。能生功德。能有利益。如是应受。后当广说。又汝言杀泥牛等无杀罪者。今当答此。若于有识诸阴相续行中。有业业报。泥牛等中。无如此事。是故当知。五阴和合假名为我。非实有也

    苦谛聚色论中色相品第三十六

问曰。汝先言当说成实论。今当说何者为实。答曰。实名四谛。谓苦。苦因。苦灭。苦灭道。五受阴是苦。诸业及烦恼是苦因。苦尽是苦灭。八圣道是苦灭道。为成是法故造斯论。佛虽自成此法。为度众生故。处处散说。又佛略说法藏。有八万四千。是中有四依八因是义或舍而不说。或有略说。我今欲次第撰集令义明了故说。问曰。汝言五受阴是苦谛。何谓为五。答曰。色阴识阴想受行阴。色阴者。谓四大及四大所因成法。亦因四大所成法。总名为色。四大者。地水火风。因色香味触故。成四大。因此四大成眼等五根。此等相触故有声。地者。色等集会坚多故名地。如是湿多故名水。热多故名火。轻动多故名风。眼根者。但缘色眼识所依。及同性不依时。皆名眼根。余四根亦如是。色者。但眼识所缘。及同性不缘时。是名为色。香味触亦如是。是等相触故有声

    色名品第三十七

问曰。经中说诸所有色皆是四大及四大所因成。何故言诸所有皆是耶。答曰。言所有皆是。是定说色相更无有余。以外道人说有五大。为舍此故说四大。四大所因成者。四大假名故有。遍到故名大。无色法无形。无形故无方。无方故不名为大。又以粗现故名大。心心数法不现故。不名为大。问曰。何故名地等法为色。不名声等。答曰。有对法名色。声等皆有对故。亦名为色。非如心法等。有形故名色。声等皆有形故。亦名为色。障碍处所故名为形。问曰。色等非尽有形。声等无形。答曰。声等一切。有形以有形。以有对有障碍故。壁障则不闻问曰。若声等有碍。则应不受余物。如壁障故。则无所容。答曰。声微细故。得有所受。如香味等。细故共依一形。不相妨碍。是故声等。有碍有对。故皆名为色。又可恼坏相故名为色。所有割截残害等。皆依于色。为违此故名无色定。又示宿命善恶业故名为色。又示心心数法故名为色。又为称名故名为色

    四大假名品第三十八

问曰。四大是假名。此义未立。有人言四大是实有。答曰。四大假名故有。所以者何。佛为外道故说四大。有诸外道说色等即是大。如僧佉等。或说离色等是大。如卫世师等。故此经定说因色等。故成地等大。故知诸大是假名有。又经说地种坚及依坚。是故非但以坚为地。又世人皆信诸大是假名有。所以者何。世人说见地嗅地触地味地。又经中说如地可见有触。又入地等。一切入中。是人见色不见坚等。又人示地色地香地味地触。实法有中。不可异示。又大名义以遍到故。此相假名中说。不但在坚相中。又说地住水上。是假名地住。非但坚住。又说大地烧尽。都无烟炭。烧假名地。非但烧坚。又以色等故。信有地等。非但坚等。又井喻中说。水亦见亦触。若湿是水。则不得有二。所以者何。佛说五情不能互取尘。故又佛说八功德水。轻冷软美。清净不臭。饮时调适。饮已无患。是中若轻冷软。皆是触入。美是味入。清是色入。不臭是香入。调适无患。是其势力。此八和合。总名为水。故知诸大是假名有。又因所成法。皆是假名。无实有也。如偈中说。轮等和合故名为车。五阴和合故名为人。又阿难言。诸法众缘成。我无决定处。又若人说坚等是大是人则以坚等为色等所依。是则有依有主。非是佛法。故知四大皆是假名。又诸法中。有柔软细滑等。皆触入摄。坚等四法。有何义故。独得为大。又一等四执。皆有过咎。故知四大但是假名。又实法有相。假名有相及假名所能。后当广说。是故四大非实有也

    四大实有品第三十九

问曰。四大是实有。所以者何。阿毗昙中说。坚相是地种。湿相是水种。热相是火种。动相是风种。是故四大是实有。又色等造色。从四大生假名有。则不能生法。又以坚等示四大。所谓坚依坚名地。是故坚等是实大。又经中佛二种说坚依坚湿依湿等。故知坚是实法依坚是假名。余大亦如是。是故坚等是实大。依坚法以随俗故名大。故有二种大。亦实亦假名。又阿毗昙中说。形处是地。坚相是地种。余大亦尔。又经中佛说。眼形中所有坚依坚是地。湿依湿是水。热依热是火。肉形是地。此肉形中。佛说有四大。当知坚等是实大形是假名大。又佛不说风中有依。故知风是实大。又若人说四大是假名。则离大相。若依坚名地种者。水依坚物。水即为地。泥团依湿。泥团即为水。如热病人。举身皆热。身即为火。是事不然。是故不得言依坚是地种。但坚为地种。余大亦尔。又四大共生故不相离。如经中说。诸所有色。皆四大造。若人说四大是实。则不相离。若说假名。则应相离。所以者何。依坚色等众。离依湿等众若尔则眼形中。无有四大。则与经相违。汝欲不违经者。则四大是实。汝先言为外道故说四大者。是事不然。所以者何。诸外道辈说四大与色等。若一若异。我等说触入少分是四大。是故无咎。又我等说现见坚等是四大。不如卫世师人说四大亦有非现见。又汝言坚依坚者。依义二种。如经中说色依色。又说心依大法。此义中。说坚即依坚。更无异法。若尔有何过耶。又汝说世人皆信。乃至八功德水。但随俗言说。非是实大。又汝说因所成法。皆是假名。是事不然。所以者何。经中说。若六触入。若因六触入所成法。又有比丘问佛。何等为眼。佛答。因四大造清净色。是名为眼。如是十入。又汝言有主有依。我等不然。但说法住法中。又汝言坚等有何义故独名大者。坚等有义。所谓坚相能持。水相能润。火相能热。风能成就。是故四大是实

    非彼证品第四十

答曰不然。四大是假名。汝虽言阿毗昙中。说坚相是地种等。是事不然。所以者何。佛自说坚依坚是地非但坚相。是故此非正因。又汝说色等从四大生。是事不然。所以者何。色等从业烦恼饮食淫欲等生。如经中说。眼何所因。因业故生。又说贪乐集故色集。又如阿难教比丘尼言姊是身从饮食生。从爱慢生。从淫欲生。故知色等非但从四大生。问曰。色等虽从业等生。四大亦应为少因。如因业故有谷。此谷亦假种子等生。如是眼等虽从业生。四大亦为少因。答曰。或有物无因缘而生。如劫尽已。劫初大雨。是水从何所生。又诸天所欲。应念即得。如坐禅人。及大功德人。所欲随意。是事有何等缘。非但业耶。又如色相续断已更生。若人生无色界。还生色界。是色以何为本。问曰。何故有物。但从业生。何故有物。待外缘生。答曰。若有众生。业力弱者。则须种子众缘助成。业力强者。不假外缘。又法应尔。或有业。或有法。或有生处。但业力得。不须外缘。又若须因缘。应说种子是牙等因。何故乃说因坚等生。又以何义故。从坚等生色等。不从色等生坚等耶。又坚等色等。共俱生故。云何言因坚等有色等。不因色等有坚等。又一时生法。则无相因。如二角俱生。不得言左右相因。问曰。如灯明虽一时生。亦说明因于灯。非灯因明。是事亦尔。答曰。灯与明不异。灯以二法合成。一色。二触。色即是明故。不得异灯。汝不谛思此喻。问曰。是明从灯去在余处。是故应异。答曰。不在异处。此明色现在灯中。若在异处灭灯亦应见。而实不见。当知是色不异灯也。问曰。更有一时生法亦为因果。如有对中识。以眼色为因缘。非眼色以识为因缘。答曰。不然。眼识以前心为因。眼色为缘。因心先灭。云何俱生。又若法随所因生。即是因成。若心因情尘有。即是因所成法。复次四大即是造色。以因所生故。又现见世间物。从似因生。如从稻生稻。从麦生麦。如是从地生地。不生水等。如是从色生色。如是等。问曰。亦见有物从异因生。如倒种牛毛。则有蒲生。种角苇生。答曰。我不言无从异因生。但说似因中亦生。故言从色等生色等。不但从四大生。是故不得定言色等从四大生。又汝言以坚等示四大。是故坚等是实大者。此事不然。所以者何。以坚等相定。可以分别四众软等不定。或在多坚众中。或在多湿众中。故不可以分别诸众。余亦如是。又于坚等触。分别名为软等。何者若以湿亦以生。性柔软细滑。以坚相多故。坚鞕粗涩。如是等。是故但以坚等。分别四众。又如经中说以依坚故。示四大差别。故知依坚法。名为地种。非但坚相。故说坚相是成地因。又于成地中。坚是胜因。是故别说。余相亦尔。又为作名字。所有坚依坚。皆名地种。或复有人。但说坚相为地种。为破是故。佛说坚依坚为地种。余亦如是。又坚相众中。以坚多故。有二种语。一切众中。皆有坚等诸触。若坚依坚。名为地种。若湿依湿。名为水种。若热依热。名为火种。又坚是成地胜因。故于中名地成。假名因缘中。有假名名字。如说我见人伐林。又汝言有二种语。是事不然。若随说种是实者。则十二入等。不应是实。是故因眼缘色。有眼识生。是则非实。以不说种故。是为邪论。又佛入火种定。从佛身出种种焰色。是中何者为火种。以色等成火。非但热相。又佛说是身名箧。于中但盛发毛爪等。如经中说。是身中有发毛爪等。以是故。发毛爪等是地种。不以有种语故名为实法。又种子经中说。若有地种。无水种者。诸种子不得生长。是中何者是地种。谓假名。田非但坚相。水亦假名。非但湿相。又一法二种。亦实亦假名。是不可得。是故色等是实。又眼等假名故有诸大。亦实亦假名者。则是邪论。又六种经中。佛说发毛爪等名地种。又象步喻经中。亦说发毛爪等为地种。又以何义故。说种是实。不说种是假名。又此义非经所载。又汝言佛说眼形中所有坚依坚是地等者。佛以此言。示五根因四大成。或有人。说从我生根。或谓离大别更有根。有说。诸根种种性生。谓从地大生鼻根等。佛断此故。说眼等根四大合成空无实法。又分别成。假名因缘。假名亦无。又此肉形中。有四分坚依坚等。佛以是语。示诸物中有从四大生者。又汝言佛不说风中有依故名实大者。是事不然。所以者何。风中轻是胜相。非依轻法。地等中依坚法等胜。风则不然。又依轻法。少故不说。又汝言若说四大是假名则离大相者。是事不然。若坚依坚从四大生。名为地种。非谓异物相依。若法相异。则不名依。即是相离。问曰。生则即是不名为依。依名异物来依。答曰。名字为依。非异物相依。以生法差别故。如言虚空遍至。实无所至。又汝言四大共生者。是事不然。如日光中。但有色及热触可得。更无余法。月光中。但有色及冷触可得。亦无余法。是故非一切物中尽有四大。如有物无味如金刚等。有物无香如金银等。有物无色如温室等中热。有物无热如月等。有物无冷如火等。有物相动如风等。有物无动如方石等。如是或有物不坚。或有物不湿。或有物不热。或有物不动。是故四大非不相离。问曰。以外因缘。诸大性发。如金石等中有流相。待火则发。水中有坚相。因冷则发。风中有冷热相。因水火则发。草木中有动相。得风则发。是故先有自性。假缘而发。故知四大不得相离。若本无性。云何可发。答曰。若尔风中或有香。香应在风中。如香熏油。香应在油中。是事不然。又不从诸大生造色。如从湿生湿。如是从色生色。又若不相离。则因中有果。如童女有子。食中有不净等。我等不说因中有果。虽乳中无酪。而酪从乳生。如是何用忆想分别。谓四大共生不相离耶

    明本宗品第四十一

汝先言我等不说四大与色。若一若异是故无咎者。是事不然。所以者何。诸外道欲成我故。以四大一异为喻。故佛于假名中。以四大为喻。故说四大义。若不尔。则不应说。世间皆自然知地等四大。而不了实性。是故为说。不说手等。若以坚等为四大者。何所利益。又汝言依义二种谓诸大是实者。此事未了。当知是依义异。谓假名是。又汝言随俗言说非实大者。是事不然。所以者何。若经书。若世间中。不以无因缘故。于色等中。作四大名字。如世间言我见人。于色等中。说人名。非无因缘。若无因缘强作名者。见马应名为人。而实不然。又以何故。不于声中说名为地。世人常说地声。终不说声是地。若无因缘强作名者。亦可名声为地。而实不然。是故色等四法是地。于地分中。说地名字。如色是成假名因。于中说名人。于树中说名林。于比丘中说名僧。如是于色等法中。说四大名。又汝言若六触入。若因六触入所成。是经不然。如汝法中。造色无所能生。我法亦尔。于假名中。更无所生。是故此经不应有。若有应转此义。又汝言因四大造清净色名为眼者。是事不然。四大和合。假名为眼。佛名四大为色。色清净故名为眼。又汝虽言法住法中无依无主。是即为依主。以住者是依所住法为主。又汝言坚相能持等。是事不然。非但坚相能持。假众因缘。余亦如是。是故四大是假名有

    无坚相品第四十二

问曰。汝说多坚色等成地大。是故地等是假名者。是事不然。所以者何。坚法尚无。况假名地。若泥团是坚。泥团即为软。故知无定坚相。又以少因缘故。生坚心。若微尘疏合。名为软。密合名为坚。是故无定。又一法中。无有二触。令生是心身坚身软。是故无定坚相。又坚软无定。相待故有。如见钦拔罗。以叠为软。见叠故。以钦拔罗为坚。触法不应相待故有。又自睹金石。则知是坚触。非眼可得。是故无坚。以此因缘。软等诸触。亦皆无也

    有坚相品第四十三

答曰。实有坚相。汝虽言泥团是坚。泥团即为软。是事不然。所以者何。我等无有实泥团法。诸法和合。假名泥团。故无此咎。又汝言以少因缘故生坚心。是事不然。我于密合微尘中。得是坚相。故名为坚。于不密中。得此软相。是故无咎。若法可得。即名为有。又汝言一法中无二触者。是事不然。我于一法中。可得多触。亦坚亦软。又汝言坚软相待故无定者。是事不然。如长短等相待亦有。又如尝白石蜜味。以黑石蜜为苦。尝呵梨勒味。以黑石蜜为甘。若以相待故无。则味亦无。问曰。黑石蜜中。有二种味。亦甘亦苦。答曰。叠中亦有二触。亦坚亦软。又汝言见石知坚。是事不然。不可以眼知坚。以先触故比知。如见火知热。热非可见。又人见钦拔罗。生疑为坚为软。是故触非眼可见。是故有坚等诸触。又实有坚等。所以者何。能起分别心故。若无坚者。何所分别。又坚能与心作缘。亦所作业异。谓打掷等。又与软湿。相违。则名为坚。又以能持因缘。故名为坚。又能障碍手等。故名为坚。又我等现知是坚。现知事中不须因缘。又以世间事得名为坚。余亦如是。故知有坚

    四大相品第四十四

问曰。我知有是坚法。而今见金热则流。水寒成冰。此金以坚故属地。流故属水。答曰。各自有相。若法坚依坚是地种。若湿依湿是水种等。问曰。金坚则为消流。水湿则为坚冰。云何诸大不舍自相。如经说四大相或可变。得四信者。不可得异。答曰。我不以坚为流以湿为坚。但坚与流为因。湿与坚为因。是故不舍自相。问曰。阿毗昙中说。湿是水相。或有人说。流是水相。经中说。润是水相。竟以何者为实。答曰。流湿润皆是水之别名。问曰。流是水业。眼所见法。是故流非湿润。答曰。以湿润故流。是故赴下。是故流即是润。亦湿润是水相。流是水业。问曰。风中说轻动相。轻异动异。轻是触入所摄。动是色入所摄。今可以二法为风耶。答曰。轻是风相。动是风业。与业合说。问曰。无有动相。诸法念念灭。故不至余处。以至余处故名曰动。至去动是一义故。答曰。我但以世谛故。说名为业。非第一义。因是轻法。余处法生。得名为业。尔时名去。问曰。轻无定相。所以者何。以相待故有。如十斤物于二十斤为轻。于五斤为重。答曰。重法量法。因心等法。亦相待有。如或有法相待故长。或有法相待故短。总相因心故。即为别相。若轻法以相待故无。是等亦应皆无。而不然。是故相待非是正因。又轻非相待故有。以不可称故有。物不可称。如排囊中风。是故非相待有。但重法相待。无有重物不可称者。问曰。若不可称名为轻者。除重余色等法。不可称故。皆应为轻。而不然。是故汝所说。非是轻相。答曰。我等意离色等。更无异法名为重。色等法。或有生性可称。如坚不坚力无力新故朽不朽消不消粗软等。亦不离色等。而有重相。亦如是。是色等众。若属地水。是则可称。若属风火。则不可称。问曰。若重法不离色等者。轻亦应不离色等而有。答曰。然离色等。无别轻法。但色等众和合为轻。问曰。不然。欲分别轻重。必以身根。是故轻重非是色等众。答曰。如分别坚等。或以眼或以耳等。此坚等物。不离色等。轻重亦如是。虽用身根。是中更无异相。又身根不触。不生身识。是重相。身虽未触。亦能生识。如重物虽以物裹持。亦知其重。问曰。非于尔时知是重相。答曰。如人着衣。虽不相触。亦知有力无力。轻重亦尔。所以者何。从种种触。生种种身识。如或因按掐。生坚软识。或从举动生轻重识。或从把捉生强弱识。或从触对生冷热识。或从摩扪生涩滑识。或从挤搦生强濯识。或从劖刺。或因鞭杖。生异种识。或有触常在身内。非如寒热等从外假来。所谓猗乐。疲极。不疲极。若病若差。身利。身钝。懒重。迷闷。瞪瞢。疼痹。嚬呻。饥渴。饱满。嗜乐。不乐。懵等诸触。各生异识。问曰。若轻重相即色等众者。云何于色等中。以身识缘。答曰。非色等众中用身识缘。但此中触。分以身识缘。如坚不坚等。虽在色等众中。或以眼见得知。又如猗乐等。是色等众。亦以身识分别。是事亦尔。问曰。若轻重但是触有何咎。何用分别色等众为。答曰。如世人说新谷陈谷。是新陈相。应异色等。而实不尔。但色等初生名为新。若此新相。是色等众重相。云何非耶。问曰。若色等众。即是轻重等者。是轻相在火风中。则轻多色等众。应名为风。若然火即为风。答曰。随相多者。即名为大。火中亦有轻热相。以热多故名为火。不以轻多故名火。风中但有轻无热。是故但以轻为名。又我等不但以轻为风。若轻而能为动因。故名为风。如经中说轻动相名风。于是中。轻相是风。动是风业。问曰风能倒山。若是轻物。云何能尔。答曰。风粗而力强。势能如是。如或有风能动小草。或能颓山。当知风业如是。问曰。今地等大。皆是色香味触众。无差别耶。答曰。不定。如名地中有色香味触。或但有色触。如金银等。或水中有色香味触。或有三色味触。或火中有色香味触。或有三色香触。或但色触。风中或有触无香。或有香触。是故不定。问曰。风触云何。答曰。寒热坚软等诸触。若随大相续不离可知。即此大触。问曰。有医言。风色黑。是实云何。答曰。风与黑色为因。如风病人口中有辛苦味。而此医不说风中有味。则风与味为因。问曰。或有人。说风是冷。不说为轻。是实云何。答曰。无有名冷为风。如冰雪有冷不名为风。又风冷名异。所以者何。如热风及不冷不热风。亦名为风。是故应依轻众名为风。又无色触等法生。名为风。非冷为风。问曰。风有色味。有何咎。答曰。风中色味不可得。若言虽有以微细故不可得者。心中亦应忆想分别谓有色味。是事不然。又我等不说因中有果。是故若事果中可得。不必因中先有。是名成四大实

成实论卷第三成实论卷第四

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    根假名品第四十五

问曰。眼等诸根与四大为一为异。答曰。从业因缘。四大成眼等根。是故不异四大。又佛分别眼。作如是言。眼肉形中。所有坚依坚。名为地种。故知诸根。即是四大。所以者何。但分别坚等。更无有眼。佛欲令人知眼空故。作如是说。若不尔。应眼中别有坚等。若坚等中别有眼。虽分别坚等。则无所益。是故诸根。不异四大。又六种经中说。六种是人。若诸根异四大。则眼等不名成人因缘。因色等成四大。声亦是成人因缘。但六种中。假名为人。故知诸根不异四大。又比丘问佛。何等为眼。佛答。因四大成色。不可见有对。是名为眼。故知不异四大。是比丘利根有智。于眼等根深生疑。世间皆知见色是眼。乃至亦知触是身。是比丘。于眼等中。生有无疑。所以者何。或有诸师。说五性为五根。或说一性。是比丘。欲试观佛法故问佛。佛欲示五根皆属四大。答言比丘是眼。因四大所成色。不可见有对。若法有实。则非因成。因假名法。更成假名。如因树成林。问曰。或有人言。色成就名为眼。是实云何。答曰。若成就不成就。四大从业因生。名眼等根。若不尔。是比丘。于眼等根中。疑终不可断。所以者何。佛为说眼等诸根因四大造。是故此比丘。知无实眼法。故知眼等不异四大。又佛处处分别四大。示眼空故。如说以慧不戏论者。谓观此身分别六种。坚依坚名为地等。如是厌离五种。但有一识。亦如屠牛喻。象步喻经中分别四大。更无有眼。若别有眼。应更分别。又和蹉等诸论议师。亦作是说。以无过故。应当信受。问曰。五根与四大异。所以者何。眼等眼等入摄。四大触入所摄。又眼等为内入。四大为外入。眼等为根。四大非根。又眼等是造色成就。四大不尔。故知诸根非是四大。答曰。随因缘故。即事异说。如信等五根。亦名行阴。若四大从业生。眼等所摄。亦名内入。亦名为根。又四大即是成就。如轮等成车。轮即是车。是事亦尔。问曰。不然。如心清净名为信。信异心异。是事亦尔。答曰。不然。如因清水珠水即为清水。清即是水。如是得信珠。则心池净。是心净即是心。又我等于此论中。不说从心有异信。是故此喻非也。又根是假名于成假名因。不得言异。问曰。亦不得言一。答曰。四大成就中。假名为根。亦不但名四大为根。故知诸根不异四大

    分别根品第四十六

问曰。是诸根中。何大偏多。答曰。无有偏多。问曰。若诸大等。何故有能见色。有不能者。答曰。皆从业生。从业生属眼。四大力能见色。余根亦尔。问曰。若从业生。何故不以一根遍知诸尘。答曰。此业五种差别。有业能为见因。如施灯烛得眼根报。声等亦尔。业差别故。根力有异。问曰。若是业力。何假诸根。但应从业力识能取诸尘。答曰。不然。现见无根则识不生。所以者何。如盲者不见。聋者不闻。现见事中。因缘无用。此非难也。又法应尔。若无诸根。则识不生。外四大等。无根而生。法应假此。又以诸根严众生身。故从业生。如以得谷因缘业故谷生。亦假种子牙茎枝叶次第而生。此亦如是。问曰。心何故不尔。如眼识以眼为根。亦因次第灭心。心但以次第灭心为根。更无有如眼等根处应说因缘答曰。定有五尘。定有五识。心不如是。又心法应尔。但以次第灭心为根。更不须余。如过去未来法。虽无而意能缘。心法如是。此事亦然。又是事与汝法同。汝法色等尘中。识待根而生。待次第灭心。意识得生。问曰。若意识更无根者。为依何处。答曰。依四大身。问曰。无色界复何所依。答曰。无色界识无所依。法应如是。无依而住。所以者何。相差别故。意识能知有无。若有色则依。无色亦能住。故无色界。亦无依而住。又众缘合故识生。如经中说因意缘法则意识生。此何所依。非如人依壁等。一切诸法。皆住自性

    根等大品第四十七

问曰。诸外道说。五根从五大生。是实云何。答曰。无也。所以者何。虚空无故。是事已明。是故不从五大生也。问曰。诸外道言。眼中火大多。所以者何。似业因故。因施明得眼。如经中说。施衣得色。施食得力。施乘得乐。施灯得眼。是故眼中火大多。又眼假明能见。离明则不见。故知火大多。又火能远照。眼有光故。能远对色。又言。人死眼还归日。故知日为本性。又眼定能见色。色属火故。还见自性。如是虚空地水风等。随根遍多。人死耳根还归虚空。耳定能闻声。声属虚空。余亦如是。是故根中诸大。应有多少。答曰。汝言似业因者。是事不然。所以者何。或见有果不似业因。如说施食得五事报。又若眼中明多。则应不假外明如灯烛等。又若眼假外明故名火多者。则耳等根中。空等亦应多不假外空等。而实假外。是故非因。又水能益眼。如人洗眼眼即明了。则应水多。又火能坏眼。如日光等。若是自性。不应自坏。故知非火多也。又天眼离明亦能见色。是故眼不属火。又月明中。亦得见色。月非火性。又眼法能尔。或有眼待明能见。有不待明而见。如眼得空等因缘。虽不到色而能远见。眼法如是。不应忆想分别谓火大多。又汝言离明则不见者。若离虚空忆念及色。亦不能见。则虚空等。亦应皆多。又非一切眼皆假外明。如鸱鸺等禽。猫狸等兽。不假外明。亦能得见。故非火多。又火是明照。常有热相。眼不如是。若汝言眼有光明能远对色。是事已破。眼无光故。若言还归于日。眼则是常。又日等非根。眼何故归。又若日死。日根及日。复何所归。是故不然。又上天死时。眼何所归。上无日故。又虚空无作。则无所归。又诸根无去。以有为法念念灭故。汝言眼定能见色。色属火故。还见自性。是事不然。无用因故。声属空等。亦如是。是故汝言于五根中诸大偏多。是事已破。问曰。有论师言。一根一性。地中求那多故。有香能发香知。水火风中。有味色触故。能发味色触知。是实云何。答曰。我先说不定。地中有香。余物亦有。是故非因。又诸大合生。不见有地离水等者。若地有香故。能发香知。亦应发色等知。以地中具四求那故。问曰。香但是地。有鼻属地。故独能知香。答曰。地之求那但是地。有鼻应尽知。又水但有冷触。火但有热触。应以舌眼能知。而实不然。又无陀罗骠故。则无有根。又诸根力用谓与尘合。故知生。和合已破。则无根用。是故无有一性为根

    根无知品第四十八

问曰。诸根为到尘故知。为不到能知。答曰。非根能知。所以者何。若根能知尘。则可一时遍知诸尘。而实不能。是故以识能知。汝心或谓根待识共知。不离识知者。是事不然。无有一法待余法故。能有所作。若眼能知。何须待识。又若根能知应当分别。是为根业。是为识业。问曰。照是根业。知是识业。答曰。此非分别。云何名照。汝法中。耳等诸根。非是火性。不应能照。若诸根于识如灯者。今诸根更应有照者。如灯则照复有照。如是无穷。若更无照者。但根能照。亦应无根。但识能知。是故照非根业。又根非能知。如灯能照而不能知。必能为识作依。是名根业。是故但识能知。非诸根也。若有识则知。无识则不知。如有火则热。无火则无热。当知从火有热。问曰。经中说。以眼见色。不应取相。耳等亦尔。故知眼能取色。又眼等名根。若不能知。何以名根。又经中说。我诸弟子。于微细事。能知如眼所见。若眼不能见。佛诸弟子。则无所见。是事不可。是故诸根定能取尘。又以根取尘。以识分别。是则根识有异。答曰。经中佛自说。眼是门为见色故。是故眼非能见。以眼为门。识于中见。故说眼见。问曰。亦说意是门。为知法故。可以意为门。而非知乎。答曰。意亦以次第灭心为门。是故意不能知。意识能知。又经中佛说。眼欲好色。眼是色法。无分别故。实不欲也。是识欲耳。又佛说眼所识是色。识能识色。眼实不识。又世间人。以世俗故。说眼能见耳能闻。佛亦随说。何者但色可见。余不可见。佛亦说见贪欲等过。又世间言月尽。佛亦随说。如贫贱人字为富贵。佛亦随名。佛意不欲与世间诤。如摩伽罗母等。是故当知。随世语故。佛说眼见。问曰。世间何故作如是语。答曰。随眼识所因。于是因中。说名为见。如说彼人见此人见。如说人作罪福等诸佛天神见。又如说以左眼见右眼见。又说以日明见月明见。或虚空见。或向中见。若门中见。如煮物中。言此人煮彼人煮。或言以草木薪煮。牛粪煮。油煮酥煮。火煮日煮。实是火煮。余假得名。如是但识能见。眼得其名。又是语不尽应言以眼门见色。又眼是人所用具。人是假名作者。应有用具。又因眼识见。名为眼见。如床上人笑名为床笑。又眼系识业故。中说识业。如手足等系在于人。是中人业名为手业。又眼识因眼。因中说果。如言某人烧某聚落。如言食金名食为命。草为牛羊。是皆因中说果。如是从眼生识。能见色故。名为眼见。又识近眼见色。便名眼见。如牧牛近水便言在水。又以眼故。分别眼识。是故眼中置眼识业。如杖婆罗门。又眼能成眼识。是故于中说眼识业。如财物损减。名人损减。财物增长。名人增长。又眼识与眼和合。故能见名为眼见。如木与人合而能打名木人打。如墨染合衣故名墨衣。又诸法互说。如慧业于受等中说。又应言以眼识见色。略中语故。但言眼见。又如药石随一受名。汝言若不能见何以名根。今当答。此眼等五法。胜余色等。故名为根。问曰。眼等五法。与余色等。此十法俱不知尘。如离眼等则识不生。若离色等。识亦不生。以何为胜。答曰。以诸根故。识得差别。名眼识耳识等。如鼓与桴合而有音。以鼓胜故。名曰鼓音。如地与谷等合而生牙。以谷胜故。名为谷牙。诸识亦尔。随所依处。得差别名。不以缘故。若说色识。则容生疑。为是眼识。为是缘色意识。又根中有识。尘中无识。又于眼等中。生我痴心。又识所依处。是根非尘。又在自身数中名根非尘。又是人所用具名根非尘。又根是众生数非尘。又根不通利则识不明。若根清净。则识明了。又以诸根上中下故。识随差别。以此等缘故名为胜。又根是不共。一尘可得多人共有。又根与识。一业果报。尘不如是。又根是因。尘是缘。所以者何。以根异故识有差别。不以尘故。如种是因。地等是缘。随种异故。互有差别。因胜缘故。得名为根。汝言我弟子于微细事。如眼所见。是随俗语。世间人眼中说见。故言如眼所见。如佛说偈。明达近智。如舌知味。舌虽不知。不同瓢杓。意依于舌生舌识故。言舌知味。依眼生识名为眼见。故言佛弟子如眼所见。汝言以根取尘。以识分别是事。已答。根无知故。又汝等不说根思惟知我有差别相。是故诸根不能取尘。又汝等诸知不待根生。所以者何。大及我等。先根而生。又汝大等诸谛。无本性故。则应皆无。汝法本性。变为大等。本性法无。是事已说。是则无根

    根尘合离品第四十九

问曰。汝言识能知非根知。是事已成。今为根尘合故识生。为离故生耶。答曰。眼识不待到故知尘。所以者何。月等远物。亦可得见。月色不应离香而来。又假空与明故得见色。若眼到色。则间无空明。如眼篦触眼则不得见。当知眼识不到而知。耳识二种。或到故知。或不到而知。耳鸣以到故知。雷声则不到而知。余三识皆到根而知。所以者何。现见此三。根与尘和合故可得知。意根无色故。无到不到。问曰。汝言眼色不到而知。是事不然。所以者何。眼中有光。是光能去见色。光是火物。眼从火生。火有光故。又若不到能见。何故不见一切色耶。以眼光去有所障碍。不遍到故。不见一切。又经中说。三事和合故名为触。若不到者。云何和合。又五根皆是有对。以尘中障碍故名有对。鼻香中。舌味中。身触中。眼色中。耳声中。若不到则无障碍。又现在五尘中知生。是故五识到故能知。若不到能知。亦应知过去未来色。而实不知。又众缘合故知生。是故眼光去与尘合。以光到色故名和合。声亦以到耳故闻。所以者何。人在远处小语则不闻。若声如色不到而知。小声亦应可闻。而实不闻。故知以到故闻。又声可远闻。若不到闻。则无远近。又声以壁障。则不可闻。若不到可闻。虽障亦应闻。又声远闻则不了。近闻则了。若不到而闻。则无差别。以到耳故。有是差别。故知音声到故可闻。又声顺风则了。逆风不然。故知到故可闻。又声可尽闻。若不到而闻。不应尽闻。如色不到而见故不尽见。故知声不同色。若不到可闻。则与色同。如色一分见。余亦待明故见。声亦应尔。而实不然。是故不到不闻。汝言耳等根尘不到而知。是事不然。声香味触。应来到根。若令根去。是事不然以耳等根无光明故但一。火大有光。是故不去。又声若厚浊物及水等障。耳亦得闻。若有光根。不能如是。故知耳根无光。又耳于闇中。亦能知尘。若有光根。闇则不知。又有光根。待方能知。能见一方。不能一时遍知诸方。如人东向则见东方色。不见余方。又说意能去。是故到尘能知。如经中说是心独行远逝。寝藏无形。又是心散行。如日光照。又是心常动。如鱼失水。又是心本随意行等。是故六尘皆到故知。答曰。汝言光到。是事不然。所以者何。如人遥见杌树。疑谓是人。若光到者。何故生疑。又太近眼。则不得见。如眼着药篦则不能见。故光虽去。以太近故。亦不应见。又眼离明。则不能见。太近则明坏。又若光到彼。何故见粗不能细辩。又见色中有方差别。谓东西方色。亦有远近差别。若眼到故知。则无差别。所以者何。香味触中。无是差别。是故眼光不到而知。又眼光若先见已。复何用去。若先不见。去何所趣。又近色远色。一时俱见去。法不尔。是故眼光不去。又若眼光去。中道应见诸色。而实不见。故知不去。又光去者。光则离身。不名为根。如指断离身则无身觉。又不见有眼。能舍自依。以无比类。则为非因。又此眼光无能见者。则为是无。问曰。有此眼光。以日光明映故不见。如日光中众星不现。答曰。若尔夜则应见。问曰。色法要假外明。乃可得见。夜无外明。所以不见。答曰。若此光昼夜俱不可得。是则竟无可见。问曰。猫狸鼠等。诸夜行虫。眼光可见。答曰。是可见色住猫等眼中。如萤火虫明色在身。非是光也。又如夜行虫闇中能见。人不能见。然则但彼有光。余物则无。法自应尔。又汝言若不到能见。应见一切色者。若色在知境。是则可见。如经中说若眼不坏。色在知境。如是则见。问曰。云何名在知境。答曰。随色与眼合时。名在知境。问曰。若眼不到。有何合时。答曰。是事亦同如汝眼去到色。或有能见。或不能见。如眼到日能见日轮。而不见日业。我亦如是。眼虽不去。若色在知境。是则能见。若不在知境。则不能见。问曰。眼光远去。以势极故。不见日业。答曰。若以势极故。不见细业者。日轮量粗。何故不见。是事不然。又若光到彼能见者。何故见远日轮。而不见巴连弗等近国邑耶。若汝意谓巴连弗等。不在知境。故不见者。我眼不到。亦以色不在知境。故不能见。问曰。已知诸色在知境故可见。今云何可见。云何不可见。答曰。世障故不见。如过去未来色。映胜故不见。如日光明蔽诸星宿及珠火明等。不显故不见。如夜中火可见。余不可见。地胜故不见。如以初禅眼不见二禅色。闇障故不见。如闇中瓶。神力故不见。如鬼等身。厚浊障故不见。如山外色。远故不见。如余世界。太近故不见。如自眼睫。次未至故不见。如光中尘可见。光外则不见。细故不见。如树杌似人不可分别。多相似故不见。如一粒米投大聚中。又如一乌入乌群中。与上相违。名在知境。问曰。云何名眼坏。答曰。风热冷等。众病所坏。若风坏眼。则见青黑转旋等色。若热坏眼。则见黄赤火焰等色。若冷坏眼。则多见白池水等色。若劳坏眼。则见树木动摇等色。疲倦坏眼。则见色不了。偏按一眼。则见二月。鬼等所著。则见怪异。罪业力故。则见恶色。福业力故。见净妙色。热气坏眼。则见焰等色。又众生得眼不成就故。见不具足。又眼生肤翳。蔽故不见。若眼根坏故不见。是名眼坏。与上相违。名为不坏。耳等诸根。亦应随义分别。问曰。已知五尘在知境故可知。法尘云何名不在知境。答曰。上地故不知。如初禅心不知二禅已上法。根胜故不知。如钝根心不知利根心中法。人胜故不知。如须陀洹不知斯陀含心中法。力差别故不知。如有意识于此法无力。以是意识不知此法。如摄心意识所知法。乱心意识所不能知。如辟支佛意力所知法。声闻意力所不能知。佛意力所知法。声闻辟支佛意力所不能知。如上品法下品意识所不能知。又细微法尘不可得知。如阿毗昙中说。何等心可念。谓了了者。先所经用者可念。非不经用者。如生死人。先所用法能念。未用则不念。圣人若经用。若不经用。圣智力故。皆悉能知。又胜尘故知。如用色界心知欲界法。又倒障故不知。如身见心缘五阴不见无我。无常苦亦如是。又力障故不知。如钝根人利根障故。令心不知。与上相违。名在知境。问曰。云何名意坏。答曰。狂颠鬼着憍逸失心。或酒醉。或药迷闷乱心。或有贪恚等烦恼炽盛。放逸坏心。如述婆伽捕鱼师等。或那若婆病。能破坏心。又老病死。亦能坏心。若心在善法。若不隐没无记法中。是名不坏。如是等因缘故。虽有诸尘。而不能知。是故汝言若不到能见。何故不见一切色者。是事不然。又汝言三事和合故名触者。随根知尘时。则名为触。不必相到。所以者何。意根亦说三事和合。是中不以相到故名为触。又汝言以相到故名有对者。是事不然。以说非对相故。又汝言现在知生者。第六识亦有但知现在。如他心智。又汝言众缘合故知生者。第六意根中已答。谓随所知时。名为和合。又因意缘法。意识生。此言则空。以不到故。又以决定故。名和合。眼识但依眼不依余。亦不无依。但缘色不缘余。亦非无缘。乃至意识亦如是

    闻声品第五十

汝言人在远处小语则不闻。故知声到耳者。是事不然。所以者何。如汝言人在远处语。从声有声。相续转微。更不复生。是故不闻。我亦如是。耳虽不到。声小故不闻。又如汝眼光虽去。但见日轮。不见日业。我亦如是。耳虽不到。声粗故可闻。细则不闻。又汝言眼光虽远去。不能至百千万由旬。虽能彻见水精等障。壁等障则不见。能见日轮。而不见日业。我耳亦如是。声虽不到。粗故能闻。而不能细辩。又汝言顺风则了。是事不然。所以者何。则无有人能逆风闻。如香逆风则不可闻。声亦应尔。逆风不应少闻。而实可闻。是故知声不到而闻。若声可少闻。以风障故。又声不可如香为风所吹。何用分别逆顺风耶。又汝言声可尽闻。故知来到不同色者。是事不然。所以者何。声法应尽闻。色法不尔。万物皆有同相异相。是可知尘故同。知尽不尽故异。不以到不到故异。又铃声于铃中可闻。何以知之。如人欲听铃音。则以耳就铃。又声是求那。是故不去。以诸求那无作业故。问曰。从声相续生声求那。如水中波。名为声去。答曰。是声与波。何以相喻。水相鼓扇。则有波生。今声中更有何声。能生异声。若汝意谓声能生异声者。何故不即于本处生。不余处生。水水相击故有波生。若说言人是声造耳即应是说者。而实不可。是故知声不说而去。又若铃声转相续生。而铃非无声。若声如波相续生者。先水无波。如是从铃有声。铃应无声。而实不然。故知声在铃中。又捉铃则声止故。知声常依铃。若声依铃亦离铃者。捉铃时依铃声应灭。离铃声应在。又现语言中。无有如铃相续生者。又声中有方差别。谓东西方声。亦有近声远声。若声到耳。则无是差别。又若声来者。则天耳无用。所以者何。百千世界声。云何能来。又如射声。能中声处。若声到耳。应自射耳。若不尔者。不名射声。又若远近声。可俱得闻。又声念念灭故不生异声不见念念灭法。能有所生。是故声不生异声。如念念灭业不生异业。声亦如是。念念灭故。不生异声。若声生异声。业亦应生异业。然则业不生业。此言则坏。又汝法中。声与异声相违。名不同处。若声与异声同处。则不各相违。若不同处。则前声灭已。后声自生。是故声不生异声。又声是一法。云何能生异声。不见一物有能生者。问曰。如合是一能生成物。声亦如是。虽是一法。能生异声。答曰。汝见合法是一能有所生。声亦然者色亦为一。应生异色。香味触亦如是。然则陀罗骠或有五性三性二性。又同业故。声与业同相。如说虽声求那灭与业同。如以指弹刀刀动名业。即亦有声动不离刀。声亦如是。以手捉刀。则声动俱止。故知业不生异业。声亦不应更生异声。如汝分别。从初业势。更生后业。如是亦应从初声生势。从势生后诸业。是中无有异。因业能生势。而声不能。又业灭故。不名因陀罗骠。所以者何。先业灭已。后陀罗骠生。声亦如是。先声灭已。后声自生。后声不应有因。若汝犹谓前声生异声者。则声不名念念灭。所以者何。是声生时。是第一念。生异声时。是第二念。异声生已。是第三念。前声灭时。是第四念。故非念念灭也。又声云何与异声相违。为如毒与毒药相违。药与病相违耶。若不尔。则铃不应有二声。若一念中。铃有二声。则千念中。亦应有二声。又如无求那陀罗骠与火合故生求那灭本黑色更生赤色。声亦如是。前声灭已。异声更生。若不尔。应一念中铃有二声。而实无二。是故不然。又若从声生异声者。则不随因。而实从铃生声。则是随因。又此异声。应作铃声。又此异声。终不应断。无断因故。问曰。从是初声。转生微声。是故有断。答曰。何故转生微声。随打势着随着。有初声。第二声分等。亦随着差别故有。以无打因故。着势则折。着势折故。声则转微。又若因声生异声者。亦应因色生水镜中色。如是水月镜像。即名为色。然则卫世师经。一切皆坏。又汝等说从离生声。是事亦无。所以者何。不从手离生声。合故有声。以刀竹等诸分相着。离时相掁。是故有声。又我等不说从合生声。所以者何。指与空合。则不生声。若指不相掁。亦不生声。是故不从合生。但四大若合若离。则有声生。如诸大业常在。诸大不舍而去

    闻香品第五十一

问曰。汝言香至鼻闻。是亦不然。所以者何。如声可远闻。香在远处。亦可得闻。汝意若谓从是香物相续生香因。声相续中。已说其过。答曰。香云何可闻。问曰。微华分去。香亦依去。答曰。不然。若华分去。华分是色。应当可见。而实不见。故知不去。问曰。是华分色微故不见。答曰。香亦细微。不应得闻。问曰。香势大故可闻。如羹中兴渠虽不见色但闻其香。答曰。今现见随华分色。亦闻其香细分中色。何故不见。又若烧华其香更增。色但有灭。故香非华分。又若香是华分。亦应少闻。而实不然。又若华分去。华应损减。而实不减。何以知之。如一斤郁金常有香去而常一斤。问曰。所损微故。不可得知。如水瓶中去一渧水不觉其减。答曰若常损者。华尚应无。况不觉减。又若华常减。则不可见闻。以常减故。念念生灭。念念灭故。应生异陀罗骠。况不更生异求那耶。而实是华可得见闻。故知华分不去。问曰。若但香去。香亦应尽。以常损故。又香无分故。便应都尽。答曰。我等不使华分随风。亦不令风吹华香去。但因华香中。更生异香。因此香风。复生香风。来至鼻闻故无斯咎。何以知之。如闻麻中香非华分香。以华熏故。若是华分。何能熏麻。故知此香不在华分。又此华香。若摩若搦。若着热中。其香则灭。若在麻中。则不可灭。又此华香。但在油中。不在滓中。故非华分。又此香。久在麻中。华中不尔。故非华分。问曰。若非华分。是何物香。答曰。是名麻香。因华而生。不得离麻。如是因华香风。更生异香。是事已明。复次或有热风冷风可觉。是中水火色不可见。当知风中更生异触。非吹水火分去。若风中热触属火。冷触属水。则不冷不热触。应当属地。如水火色。不可得者。地色亦应细故不可得。若尔风则无触。是即为过。他人亦可得说如风与水火合故。有冷热触。如是风与地合故。有不冷不热触。是中无有决定因缘。水分火分。得随风去。而地分不去。如汝经中有触。触身而非地水火。故知风是不可见相。以此言故三触于风或客非客。所以者何。是三种触。若非见相则是风。有汝意若谓见水火中有冷热触故。非是风分。如是见地中有不冷不热触故。亦不应是风分。若先别有风触不与地合。应言是触属风。而初不见。云何当知不冷不热但是风触非地分耶。又我等亦说色香味触但是地物非水等有。汝意若谓见水等中有色等者。与地合故。于水等中。见非水等有。如水中热相。是中无决定因。水与火合故。有热相与地合故。无色等相。初不曾见别有水等不与地合。若曾见者。可言是色属水非是地有。亦应如是分别水等。问曰。何故风中得生异香。而不能生异色味触。答曰。风法应尔。法有种种不可思议。余物得生异色味触。如华熏麻生辛苦味。乳浸阿摩勒。即为甘果。燕支熏摩头楼伽子种生赤叶。青杂雌黄。则成绿色。青赤色合。变为紫色。如是等。于异物中。生异色味。问曰。汝说风中更生异香。是事不然。所以者何。如无风室中得闻远香。又香可逆风闻。如波梨质多天树。故知风中不生异香。但应因香更生异香。答曰。缘有二种香。若风中则更生香风。若无风则因香生香。斯有何咎。汝先言香可远闻故应不到。是事不然。所以者何。不同色故。若不至而闻。则与色同。不到而闻。又远睹香烟。则不得闻。到时乃闻。故知不到不闻。又无天鼻故。故知到闻。若不到而闻。应有天鼻如天眼耳

    觉触品第五十二

问曰。触亦应不到可知。所以者何。日触远住故。答曰。日触云何可知。问曰。火分从日边来到身乃知。答曰。若从日有火分来。日没时火分应在。而实不在。故知不来。问曰。日虽没而热犹在。以触故知。答曰。若尔火则无色。汝经中无无色火。是即为过。问曰。是中有细微色。答曰。火色多而触少。如见灯色。未觉其触。问曰。触定到乃知耶。答曰。定到故知。所以者何。如因香风中有异香生。如是因日更有火生问曰。日没火色何故不见。答曰。或有火但触无色。如日没热。如热病人火依于身。如温室中火灭余热汤中火等。皆有触无色。是故火或有色无色。应当信受

    意品第五十三

汝言意行。是事不然。所以者何。意念念生灭。如风如业。念念灭法。则无去相。又意去者。若知已去。不知已去。二俱不然。若先知已。复何用去。若不知已。去为何所趣。又若心在眼。云何复得到耳。若心生念。我当到耳则为念耳。若欲闻声。即是念声。若心在眼。不得生念。余根亦尔。故意不去。又若人先见城国邑等。今随本念。不知现在。故意不去。又若法去者。应先近后远。而今远近俱念。故知不去。又若法去者。中道应知诸尘。如人行道中知色等物。而意不尔。又如心能知无谓过去未来兔角龟毛蛇足风色赤盐香等。亦知俱不到故。故知不去。又若心到缘。则不应有无知疑知邪知。而实有之。故知不到。又心缘泥洹。若心到者。则以有为。到无为中。是则不然。还出无为。入有为中。是亦不然。又若生心。有后世。心即到后世。此身应死。不得复还。是故不去。又心念未来。即到未来。不可以现在法为未来也。又心念过去。即在过去。不应以去来法为现在也。故知不去。又从欲心面生异色。恚等亦尔。若心到异处。色不应异。故知不去。又心在缘中。名之为受。是受三种。若苦若乐不苦不乐。若心到异处。此则无受。故知不去。又心依于身。如经中说。心依名色。故不离身到余处去。又身合识。故名为身。若心在异处。身则无识。缘与识合。便名有识。是故不去。问曰。梦中心至余方。答曰。不然。如梦中所作失不净等。是皆在身心颠倒故。谓在余方。而实不去。又梦中所为皆是虚妄。如人梦饮竟不除渴。又梦行欲等。不名为堕。故知梦中意亦不去。又心但在曾所见闻觉知法中。不行异法。若去到者。亦应知异法。问曰。神使意去能到余方。答曰。是事后破神品中。当广分别。故意不去

成实论卷第四成实论卷第五

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    根不定品第五十四

问曰。诸根为定。为不定耶。答曰。云何名定。云何名不定。问曰。以眼等根所知及因。是名为定。答曰。若尔根非定也。所以者何。诸根非是眼等所知及因。问曰。眼童子及舌身。可以眼见。耳鼻在内。故不可得见。答曰。死人亦有童子舌身。而实无根。问曰。童子二种。有是根非根。死人根童子灭非根者在。答曰。根童子无能见者。故非眼等所得。经中说。五根是色不可见有对。若是可见。则可分别此童子是根此童子非根。问曰。若经中说因四大成清净色名为五根。何故复说五根是色不可见有对耶。答曰。是故可疑业力不可思议。以业力故。四大变而为根。佛恐弟子谓此五根自从业生。故言是色。又外道说五根从我生。我即非色。又言。五根知大知小。故非决定。是人亦以无色为根。是故佛言诸根是色因色等成。或谓因色等成。应可见故说不可见亦非耳等根之所得。或谓。若尔便应无对。故说有对。对诸尘故。若色有形有对。是名粗色。但眼所见。又外道言。诸数量一异合离好丑作业总相别相及陀罗骠。虽非色法。亦是可见。故佛说言于此等中但色可见。非余法也。碍于手等。故名有对。问曰。若尔皆应受触。答曰。虽俱障碍。非一切处尽生。身识随生识。故分别诸根。复次诸根实非决定。所以者何。法若决定。如手取物。唯取一手。眼能见大小。故非定也。又若定物触则有作。如触火则烧触刀则割。眼远而能见。故非决定。又若法决定。则碍决定法。如手碍手。眼于水精云翳等中。亦不障碍。故非决定。又根若决定。应在身内。在身内故。虽与意合。亦应不见外尘。而实能见。故非决定。又法若决定。则可数名五根。而眼等各二并舌与身。是名为八故非决定。但处有定。根非定也。又左眼见。右眼亦识。不应异见异识。以根无左右根故。非是决定。又根尘合法。不可得故。无决定也。又得决定。色等法则不能觉得根。则觉故非决定。问曰。眼光能见大小亦能远去见色。无有障碍。犹如日光离身能见。是光因二眼定处。合为一光。而能见色。又眼是一。耳鼻在内。不可分别。是故汝说异见异识。此言则坏。又神知非根。根是所用。又汝言合法不可得者。是事已答。谓日光映等。耳等诸根。和合密故。亦不可得。如合木密际不可知。又因神故。觉非是诸根。又根由大成。大无觉故。根亦非觉。又瓶因微尘。如微尘无觉瓶亦无觉。又不知异尘。故知无觉。答曰。汝言光去故根是决定。汝以光为根。光非定故。根亦不定。又此光无先已破故。又汝言一眼。是事不然。一眼见异。二眼见异。若一眼坏。见则不明。是左右眼先已答。问曰。若一眼能生识者。则二眼应是一眼。何用第二眼为。答曰。以鼻隔故。不得为一。设无障隔。亦不为一。如手指等。汝言是神所用。是事先破。神不能用。日光映者。是亦先破。汝言和合密故不见。是亦不然。所以者何。法若决定。则无和合。体相异故。如合木虽密犹见其际。根尘和合不见如是。汝言以神故觉。当说无神。汝言诸大成根。是事不然。业力变大为根。则有差别。问曰。根是决定。所以者何。是四大所成。四大定故。根亦决定。又以眼等根是决定故。大等能为利益。又大变为根。大决定故。所变成法亦应决定。又当根有尘。当尘有根。若不决定。不应相当。应如意法。故知决定。又世间人。于童子等决定法中。说名诸根。又根知五种定法非如意等。故名决定。又根知现在。余皆比知。故名决定。又根知有缘意亦无缘。如知过去等。又根尘和合故。生根知法。应以决定根对决定尘。故知决定。答曰。汝言根由大成名决定者。虽俱由诸大。而有是根非根。如是或有决定。或不决定。汝言利益。利益于知非助根也。又言大变成根。变亦为知。非利益根。又四大清净名根。故非决定。汝言根尘。相当亦是意。定根非知。故其余皆是意力差别。又虽说六识。要以意识决了。如见四谛时现知诸法。正观法性。皆以意识。又如旋火轮及幻化焰乾闼婆城。皆无而妄见。见色亦尔。是故眼等悉为邪缘。汝言根尘合故生知。若到故知。不到而知。皆先已答

    色入相品第五十五

又言。青黄等色名为色入。如经中说。眼入灭色相离。是处应知。问曰。有说。业量亦是色入。所以者何。如经中说黑白长短粗细诸色。答曰。形等是色之差别。何以知之。若离色则不生形量等心。若形等异色。离色亦应生心。而实不生。故知不异。问曰。先生色心。后生形心。所以者何。黑白方圆心不并生。答曰。长短等相。皆缘色故。意识中生。如先见色然后意识生。男女相业。亦以诸有为法念念灭故。无灭法不去。以去故名为业。问曰。去名身业。若无去则无身业。答曰。世俗名字故有身业。非第一义。问曰。若第一义中无身业者。第一义中。亦无罪福。无罪福故。亦无果报。答曰。法于异处起时。若益他恼他。故成罪福。不应难也

    声相品第五十六

问曰。何故不说因声成大。答曰。声离色等。色等不相离。是故不说。又声不如色等常相续故。又亦不与色等俱生。又与色等生异。所以者何。色等相生。渐以根牙。次第而有。声不如是。又声从物得名。如说瓶声。不言瓶中声。又人或言见瓶。或言见瓶色。初不言闻瓶。但言闻瓶声。又众生昔殖静寂业故。若万物皆常有声。则无时暂静。是故声非成诸大因。问曰。物皆有声。何以知之。掁则声发。诸大常相掁。故一切尽应有声。答曰。非万物相掁。皆是声因。所以者何。眼见二指相掁。不能生声。问曰。是中生声。微故不知。答曰不生。乃至微声亦不闻故。若言有声。则无现信。他人亦可言水中有香。细故不闻。火中有味。风中空中。皆有色等。而实无故。非一切相掁尽能生声。问曰。俗中常言声是空之求那。今何以知之。从四大生。答曰。今现见声从四大生。我等信现见故。又言钟声鼓声。故知是钟鼓声。又以四大异故。声有差别。如钟鼓声异。又击铜器。则声动俱有。捉则俱止。当知器动声亦如是。又将欲为声。必备四大质像。故知声从大生。又业因缘故。声有差别。如众生声或粗或妙。不应以业缘故生空求那。是故非也。又因相故。因相者随法以何故有。即名为因。如是因大有声。无则无声。如有火则热。无火无热。当知从火有热。从大生声。亦复如是。如有虚空热。虚空犹在。而热或无。当知。空非热因。声亦如是。如有虚空有声。虚空犹在。而或无声。故知非因。又声是虚空求那。此无可信。现事中初不见声因。于空亦无比知。是中以何为比。又经书中。亦多相违。如是无一可信。故知不然

    香相品第五十七

问曰。多摩罗跋等。众香合故。其香异本。为即此等香更生异香耶。答曰。因香和合。更生异香。如青黄色杂更生绿色。又以种种业因缘故。生种种香。问曰。优楼佉弟子谓香唯是地之求那。此事云何。答曰。无陀罗骠。是事已明。故知不然。又卫世师人谓。白镴铅锡金银铜等。皆是火物。而是中有香。故知非唯地有。问曰。白镴等与地合故有香。答曰。此非客香。所以者何。先余物中。不闻此香。若曾闻者。可言是客。如先闻华中香。后衣中闻可名是客。是白镴等香不如是。是故非因。又是白镴等无无香时。不应言客。又我亦可说水等中无色等。但与地合故。色等可得。若汝言水等中自有色者。我亦说白镴等中自有香。又若物中有不相离法。即此物有。是故香随不相离处。即此物香。又水等中若有香。以微故不知有何咎。如说月中有火。火决定热。又汝说温室中火灭余热中有微色。亦说汤中有微冷相。水香亦尔。是中无决定因。言水中无香。又汝诸陀罗骠。无决定相。所以者何。汝自誓言地中有香。而金刚颇梨等烧变异。故皆是地物。而皆无香。又汝言水相定冷。乳等相亦定冷。而酥等有香故。说名地物。又言。火决定热。以白镴等为火物。而中无定热。又月等实冷。而汝说为火物。以此等故。诸陀罗骠。无决定相。是故香唯地有。此事不然。汝以白镴等为火物。是亦不然。所以者何。无决定热故。优楼佉弟子说火决定热。而白镴等无热。问曰。白镴等物热在果中。不在触中。答曰。酥果冷。故应是水物。而汝以定有香故。名为地物是故说果。不名用因。又诃梨勒。果时定热。应是火物。而实有香。有五味。故不名火物。以说果非因故。白镴等非是火物。又火相轻。白镴等重。火色白。而白镴等色异。又白镴等与火。无有同相。可得知是火物。又白镴等与火相违。所以者何。热则消故。若是火物。得火应增。而实不增。故非火物。汝等不善思。故谓香唯是地物。是香皆在四众中

    味相品第五十八

味名甜酢碱辛苦淡等。此六味皆随物差别。不以四大偏多故有。如说地水多故甜。是事不然。甜味有无量差别。当知物生自有别异。问曰。药师说但有六味。此事云何。答曰。不限于六。所以者何。或二味合。或三或四。如是无量。不以甜酢合故名甜酢味。甜酢和合。更生异味。如是无量。又随世俗故差别诸味。如人以为甘即名为甘。又诸味熟时。各各相因。甘味熟时。或甘或变。余味亦尔。故知诸法有如是力

    触相品第五十九

触名坚软轻重强弱冷热涩滑强濯猗乐疲极不疲极若病若差身利身钝懒重迷闷瞪瞢疼痹嚬呻饥渴饱满嗜乐不嗜乐懵等。问曰。有说。触有三种。冷热不冷不热。是事云何。答曰。于坚等中生知。若离坚等。无冷热知。问曰。优楼佉说。地触是不冷不热。风触亦尔。水触冷。火触热。是事云何。答曰。先已说无有决定。谓酥等定冷。镴等无热。又先说三触。若是风客。则风无别触。故无定相。又汤中冷相不可得。故水非定冷相。问曰。汤中有微冷相。火胜故不知。何以知之。若火势尽还更冷故。答曰。白镴等酥等坚物。与火合故则流。若坚相不失。而有流相。则坚相即为流相。若失坚相而有流相。是则冷触灭已。更生冷触。如地触是不冷不热。与火合时。触若不失则不名熟变。若失此触。更生异触。如是则冷触失已。更生冷触。若尔水诸求那。亦应熟变。汝言反覆有过。又相违法生。故诸相无常。如火合故草等相灭。若谓热触覆冷触者。他人亦可言乳相不灭。但酪相覆。故不可得。若汝谓不见乳还为乳。然则无有熟变。所以者何。无始生死中。何物不为火之所烧。亦见土中有黑泥可得。当知亦从熟变而还。故知熟变非常不还。如是则冷触失。还生冷触。或有与火合。故黑色灭。还生黑色。赤色灭。还生赤色。如是冷触灭已。离火还生。斯有何咎。又卫世师人说。但地有熟变相。水等中无。而药师说。若饮沸汤。则得异果。若汤中色等不失。安有异果。故知水等亦有熟变。如火烧物失本相故。更有异相故。知物有异相。水亦如是。又是诸相相违。故无常。如水能灭火火能消水。火力无物不消。况与水合。而冷触不灭。是故卫世师经说水决定冷。是事不然

    苦谛聚识论中立无数品第六十

心意识体一而异名。若法能缘。是名为心。问曰。若尔则受想行等诸心数法。亦名为心。俱能缘故。答曰。受想行等。皆心差别名。如道品中。一念五名。念处念根念力念觉正念精进等亦如是。又一无漏慧。而有苦习智等种种别名。又一定法。亦名为禅解脱除入。如是心一但随时故。得差别名。故知但是一心。所以者何。如经中说是人欲漏心得解脱。有漏无明漏心得解脱。若别有心数。应说心数得解脱。又经中说。佛若知众生欢喜心柔软心调和心堪任得解脱。然后为说四真谛法。是中不说心数。又经中说。心垢故众生垢。心净故众生净。又说。若比丘入四禅中。得清净不动心。然后如实知苦圣谛集灭道谛。又十二因缘中。说行缘识。又说六种为人。又说轻躁易转无过于心。又经中说使诣城主语其事实。语已还去主名为心。又说内有识身外有名色。是名为二。又但说有识身不说有心数。又说三事合故名触。若有心数。不名为三。而实说三。故知但心无别心数

    立有数品第六十一

问曰。心异心数法异。所以者何。心心数法共相应故。若无心数则无相应。而实有相应。故知有心数法。汝意若谓心与余心相应。是事不然。所以者何。经中说心独行远逝寝藏无形。是中但遮同性。虽与心数共行。犹名为独行。如说比丘独处虽有虫兽。以无类故亦名独处。故知心不与余心相应。而实有相应。故知有数。又心七界一入一阴所摄。心数法一界一入三阴所摄。又心是依处。数法依止。如经中说是心数法皆依心行。又若无心数则无五阴。是则不可。又此二生异。从二生心。从三生数。如经中说。因眼缘色。生眼识。三事和合名触。触因缘生受。又说。名色集故识集。触集故受集。又心数法与所依相应。同共一缘。在一世中。心不如是。以是差别。故知心异心数法异。又四依中说。依智不依识。智若是识。云何言依。故知智非识也。又佛自说心数法名谓从心生。依止心故名为心数。又佛不说此义。唯独有心。而无心数。他人亦可言但有数而无心。汝若以名字破数。我亦以名字破心。又所作异故。诸法相异。如水能浸渍火能焚烧。如是受等所作异故知有异相。又诸经中说。心中生觉故知心数异心。不应心中自生心故。又如说心垢故众生垢。心净故众生净。若但是心。则垢净无因。是人不以无明故垢慧明故净。应自垢自净。此则不可。是故有心数法

    非无数品第六十二

汝虽言能缘法名心。心差别名数。如道品中说。是事不然。所以者何。经中说。心相异。心数相异。能识是识相。觉苦乐是受相。别知是想相。起作是行相。故知心异心数亦异。汝言心得解脱。是亦不然。余经中说。离无明故。慧得解脱。不但说心得解脱。又以心胜故但说心。又世间人皆多识。心数法不尔。故佛偏说。又佛经中有不尽语。此言是也。又如经说。汝等比丘。能断一法。我保汝等得阿那含道。所谓贪欲。而实不偏断。是事亦然。欢喜心等。皆以此答。汝言内外二法。是亦不然。说外有名色。即说心数。以外入摄故名为外。又是中佛说三事。内有识身。即说识与根。外有名色。即是说尘。汝言说有识身。是亦不然。此经中说外一切相即是心数。汝言三事和合名触。是事不然。触与受等心数作因。是故独说

    非有数品第六十三

答曰。汝言以相应故有心数法。是事不然。所以者何。诸法独行。后当广说。故无相应。是心独行。亦以此答。非遮同性。是遮数法。汝言摄异故有心数。是作经者。自立名字。佛经中不说相摄。是故非也。汝言依处者。如汝意识依心。不以依故便名为数。如是心依于心。不得名异。汝言无五阴者。是事不然。我以心差别故。有名为受。有名为想等。汝以心数别为三阴。我亦以心别为三阴。汝言生异。是事不然。若心与数法共生。何故言二生心三生心数。若但说心。则有此理。所以者何。是人先说识时。后说相等。汝言相应缘世故知有异。是先已破。无相应故。汝言依智非依识者。我说心有二种。一名为智。一名为识。故依智心。不依识也。汝言佛说依心生法名心数者。心所生法。名曰心数。心依心生。故名心数。汝言佛亦不说无心数者。我亦不言无心数法。但说心差别故名为心数。又若有道理。不可说名说。如其无道理。虽说非说。是故不可以说为因。又我等当说心心数法名字义。以集起故名心。受等亦能集起后有。相同于心。故名为心。又心与心数。俱从心生。故名为心数。若人但说有心数法。是人应说数法名义。而实不可说。是故非因。汝言作异及心生觉。皆以此答。所以者何。我以心差别故。所作业异亦心中生心。名心生觉。汝言垢净无因。是事不然。虽无数法。而有垢净。又无异相故。无心数法。所以者何。汝以心相应故。名为心数。相应法无。后当广说。故不从心别有数法

    明无数品第六十四

汝言相异故有心数。是事不然。所以者何。若识若觉。是诸相等无有差别。若心识色。即名为觉。亦名想等。如世间言汝识是人即名为知。从受苦乐。亦即是知。当知识即受想。若此等法。有定异相。今应当说。实不可说。故无异相。汝言慧得解脱。是事不然。无因缘故。随心有染亦有无明。是心聚中染及无明。尽与相应。若言无明垢慧染垢心者。则无因缘。如是离无明故。慧得解脱。离染垢故。心得解脱。亦无因缘。又是名不了义经。如经中说离三漏故心得解脱。故知亦从无明心得解脱。若说从染心得解脱。是说遮断。言从无明慧得解脱。是毕竟断。若从染故。心得解脱。从无明故。慧得解脱。若从恚等。得何物解脱。是事应答。当知离心无得解脱。故但有心。汝言以心胜故但说心者。心有何胜义。而慧等法无。汝言人多识心故但说心者。世间人亦多识苦乐。应说受等。汝言有余诸经者。何故不但说心数。而但说心。汝言但断一法。是语有缘。佛随众生烦恼偏多若常覆心者。说是一法断此法故。余亦自断。是故非因。汝言说名相故即说心数。汝自忆想分别。是经不说此义。汝若自生忆想分别。何不言以名相说心缘。可有此理。汝言触与受等心数作因。是言多过。俱相应法。而言触是受等因。非受等是触因。有此等咎。故知但心无别心数

    无相应品第六十五

无相应法。所以者何。无心数法故心与谁相应。又受等诸相不得同时。又因果不俱。识是想等法因。此法不应一时俱有。故无相应。又佛说。甚深因缘法中是事生。故是事得生。又如谷子牙茎枝叶花实等现见因果相次。故有识等。亦应次第而生。若汝意谓如贪等烦恼与色共因应俱生者。是事不然。色无了知。不能缘故。心心数法。有缘有了。是故一时不应俱有。无多了故。又以一身。名一众生。以一了故。若一念中。多心数法。则有多了。有多了故。应是多人。此事不可。故一念中。无受等法。又何故六识不一时生。问曰。诸识皆待次第缘生。故不一时。答曰。以何障故。一次第缘不得次第生六识耶。当知先因后果次第生故。又经中说。眼见色不取相。取相即是想业。若佛听识业而遮想业。当知或有识而无想。若人取相。是见已取。非是见时。故知识等次第而生。又经中说。眼见色已随喜思惟。是中亦先说识业。后说受等。又经中说。见是见等。故知非一切心尽有受等。又以五识相是事可明。所以者何。若人于眼识中。不能取怨亲相及平等相。是则无想。亦无忧喜。无分别故。或有人说。是中亦无贪等烦恼。故知无思能求后有。故名为思。此后当说。故知五识亦无思也。又汝等五识不能分别。此中云何当有觉观。思惟分别。先粗后细故名觉观。又若五识中有觉观者。如说欲我知汝。本皆由思觉生。是则觉时无欲。识时云何有觉。或有人言。五识中有想无觉。是觉因想生。云何想时有觉。是故应受五识无想无觉无观。所以者何。五识中无男女分别。亦无受等分别。是中何所分别。又汝等说五识次第必生意识。以五识无分别故。若五识中有分别者。何用次第生意识耶。又觉观不应一心中生。以粗细相违故。譬如振铃初声为觉余声曰观。彼喻亦然。若五识中。有觉观者。应说其业。实不可说。当知心心数法次第而生。又痴慧相违。不应俱有。云何一念中。亦知亦不知。又一心中不容有疑。所以者何。若杌若人。不得一心中行。以心业无此力故。又人言心数法中忆行过去世缘。现在心云何当有。又若念此人是我知识。曾利益我。念已生喜。是事云何。在一心中。又欲不欲。云何在一心中。如经中说。若诸比丘乐欲我法。法则增长。若不乐欲。法则损减。云何当在一心中。又若一心中有心数法。法则错乱。所以者何。于一心中。有知不知疑不疑信不信精进懈怠。如是等过。又一切心数应尽在一心中。以何障故。苦乐贪恚等。不在一心中。若汝谓苦乐等相违故不在一心中者。知不知等亦相违故。不应在一心中。故无相应。又七菩提分经中。佛次第说诸心数法。若比丘行四念处。尔时修习念菩提分。心在念中。简择诸法。简择诸法故生精进。精进力故能集善法。心生净喜。心生喜故得猗。得猗故心摄。心摄则得定。得定故能舍贪忧。舍贪忧故知心数次第而生。又八道分经中。亦次第说。若得正见。则从正见生正思惟乃至正定。又次第经中。佛语阿难。持戒之人。不应愿欲心无忧悔。持戒人心法无忧悔。无忧悔者。不应愿欲。心得欢悦。心无忧悔。法应欢悦。欢悦则心喜。心喜则得身猗。身猗则受乐。受乐则心摄。心摄则得实智。得实智则厌离。厌离则解脱。故知心法次第而生。又八大人觉中。亦次第说。若比丘行少欲则知足。知足则远离。远离则精进。精进则正忆念。正忆念则心摄。心摄则得慧。得慧则戏论灭。又七净中。亦次第说。戒净为心净。心净为见净。见净为度疑净。度疑净为道非道知见净。道非道知见净为行知见净。行知见净为行断知见净。又因缘经中。亦次第说。因眼缘色。生痴分浊念。是中痴即无明。痴者所求为爱。爱者所作名业。如是等。又大因经中。亦次第说。爱首九法。因爱生求。因求故得。因得故挍计。因挍计故生染。因染故贪着。因贪着故取。因取故生悭心。因悭心故守护。因守护故便有鞭杖诤讼诸苦恼等。又须陀洹法中。亦次第说。若亲近善人。得闻正法。闻正法故能生正念。正念因缘。能修行道。又经中说。因眼缘色眼识生。三事和合故名触。若说心心数法一时生者。则无三事和合。若说一一生则有三事和合。以是等缘故无相应

    有相应品第六十六

问曰。有相应法。所以者何。若人见受是神。识心依之。以相应故。想阴等亦如是。若无相应。何由有此。又人经中说。因眼缘色生眼识。三事和合生触。共生受想行等。于是法中。有种种名。所谓众生天人男女大小。如是等名。皆因诸阴。若说心心数法次第生者。则因二阴。有人不应因五阴。所以者何。不可因去来阴得名为人。汝言现在无五阴者。云何说因五阴名人天等。而此中说因诸阴。非但二也。故因五阴有众生名。又经中说有相应语。谓有根智相应信。又经中说。触即与受想思俱生。又说五枝初禅。亦说受等是识住处。若识无相应。云何识住受等法中。是住名依止住。所以者何。不说识是识住处故。又经中说。是心与法。皆从心生。依止于心。又说众生心长夜为贪恚等之所染污。若无相应。云何能染。又心心数法性羸劣故。相依能缘。喻如束竹相依而立。又经中说。心掉动时。不宜三觉。谓择法精进喜。更增动故。宜三觉。意谓猗定舍。止发动故。若心懈没。则不宜三觉。谓猗定舍增退没。故宜三觉。意择法精进喜。能发起故。念能俱调。又论师言。一时修习助菩提法。不得相离。故知有相应

    非相应品第六十七

汝言见受是神。是事不然。凡夫痴惑。妄生此见。不能分别此是受此识依止。是人若能如是分别。亦能入空。是人见心相续不别。但着语言。故如此说。是痴惑语不可信也。汝言因诸阴故名为人者。是因五阴相续名人。故说诸阴。如世间言乐人苦人不苦不乐人。不可一时有此三受。诸阴亦然。汝言有根智相应信。经中亦说余事相应。如说二比丘于一事中相应。又说怨相应苦爱别离苦。汝法中色无相应。而此以世俗故亦名相应。智信亦尔。信能信无常等。慧随了知。共成一事。故名相应。汝言从触即有受等俱生。是事不然。世间有事虽小相远亦名为俱。如言与弟子俱行。亦如顶生王生心即到天上。是事亦然。凡夫识造缘时。四法必次第生识。次生想。想次生受。受次生思。思及忧喜等。从此生贪恚痴。故说即生。汝言五枝初禅。是禅地中有此五枝。非是一时。如欲界三受。所以者何。以先说法后说地。故又觉观。不得相应。先已答。汝言识处者。此经中说识缘处。不说依处。何以知之。即此经中说识缘色喜润故住。汝虽言若识缘识住。则应有五识处。是事不然。所以者何。是识时少。识识事已心生想等。是中起爱。起爱因缘。说名识处。是故不说识是识处。又七识处中亦说识是识处。又应思此经。勿但随语。如说信能度河。是言不尽。而实以慧得度。是亦应尔。汝言心数依心。是事不然。先心识事后生想等故。又经中说。受等依心。非如彩画依壁。是名心数依心。汝言心数相依如束竹者。与经相违。若俱相应。何故心数依心。而心不依数。若汝谓心先生大故数法依止。则成我义。以心生时无数法故。汝言烦恼染心故知相应。此无道理。若心先净贪等来污。是即净法可污。则害法相。亦如先说心性本净客尘来污。彼应答此。若心本性净。贪等何为。如言心垢故众生垢。心净故众生净。然则众生亦应相应。若众生不可相应。贪等亦不相应。以心相续行中生垢等心污诸相续。故说染心。如说从染心得解脱。是心相续中。若净心生。名得解脱。是事亦然。如云雾等虽不与日月相应亦能为翳。贪等亦然。虽不与心相应。亦能染污。又烟云雾等能蔽日月。故名为翳。贪等亦尔。能障净心。故名为污。问曰。云雾日月。在一时中。烦恼与心不如是。故此喻非也。答曰。障碍同故。是事已成。故无咎也。是烦恼能污心相续。故名为染。汝言数从心生依止心者。是事先答。汝言心心数法性羸劣者。以念念灭故名羸劣。非相助故能行于缘。若相助者应得暂住。而实不见。有相助力。何用相应。汝言觉意相宜。是说随时应修三觉非一念中。如舍利弗言。我于七觉。自在能入。若心掉动。尔时应修猗等三觉。又佛亦说觉法次第。汝言一时修菩提分。是事不然。若一时修三十七品。则应一时并修二信及五念等。若汝意谓随得处修即是离修。又随他所得如二禅等。故名不离。又一时三十七品。则无道理。所以者何。一念不得修多法

    多心品第六十八

问曰。已知无别心数。亦无相应。今此心为一为多。有人谓。心是一。随生故多。答曰。多心。所以者何。识名为心。而色识异。香等识亦异。是故多心。又眼识生异。谓待光明虚空等缘。耳识不尔。三识尘到故生。意识从多缘生。故知不一。又若识知尘常如是相。云何更知异尘。若多心生则能得知。如邪正知异。若定若疑若善不善无记知异。善中亦有禅定解脱及四无量神通等异。不善亦有贪欲嗔恚愚痴等异。无记亦有去来等异。有识能起身业口业。有起威仪。若合若离。因次第缘增上。各差别故。诸心亦异。又净不净等诸受差别故心亦异。又所作差别故心有异。又净不净心性各异。若心性净。则不为垢。如日光本净终不可污。若性不净不可令净。如毳性黑不可令白。而施等中。实有净心。杀等法中实有不净心。故应不一。又随苦乐。等受差别。故心亦不一。如说比丘用识。识何等事。谓识苦乐不苦不乐。又若心是一。一识应能取一切尘。说多心者。随根生识。是故不能取一切尘。若心是一。以何障故。不取一切。故知多心。又可取法异故。能取亦异。如人或自知心。云何自体自知。如眼不自见刀不自割指不自触。故心不一。又猿喻经说。譬如猿猴舍一枝攀一枝。心亦如是。异生异灭。又若心是一。说六识众。此言则坏。又经中说。身或住十载。而心念念生灭。又说当观住心无常。此心相续故住。念念不停。又如一业不可再取。识亦如是。不重在缘。又如草火不移到薪。如是眼识不到耳中。故知多心

    一心品第六十九

问曰。心是一。所以者何。如经中说是心长夜为贪等所污。若心异者。不名常污。又璎珞经说。若心常修信戒施闻慧。死则上生。又禅经中说。得初禅者。心调柔故。能从初禅到第二禅。又心品中说。是心常动。如鱼失水。是故汝等当坏魔军。故知心一。动此到彼。又杂藏中比丘言。五门窟中。猕猴动发。猕猴且住。勿谓如本。故知一心。于五根门身窟中动。今即是本。故言勿谓如本。又言。是心遍行。如日光照。智者能制。如钩制象。故知心一。走诸缘中。又无我故。应心起业。以心是一能起诸业。还自受报。心死心生心缚心解。本所更用。心能忆念。故知心一。又以心是一。故能修集。若念念灭。则无集力。又佛法无我。以心一故名众生相。若心多者非众生相。又左见右识。不应异见异识。故知心一。自见自识

    非多心品第七十

汝虽言色等识异。是事不然。所以者何。若心是一。为种种业。取色声等。如一人在五向室中处处取尘。即是心于眼中住。待明等缘。而能见色。如即此人于余处待伴。即是心所知差别。如即此人先是知者后还无知。如是邪知还为正知。如即此人先是净者后还不净。如是疑知即是定知。如即此人先是疑者还为定者。是不善心即还为善。亦为无记。如即此人或念善或念不善或念无记。即是心能作来去威仪差别。如即此人为去来业等种种威仪。如是净心。即为不净。不净即为净。如即此人先是清净后还不净。即是心与乐相应。后还与苦相应。如即此人本为乐人还为苦人。故说心一用为多业。汝言一识不取六尘故非一心。是事不然。我以根差别故识有差别。若识住眼中。但能取色不取余尘。余亦如是。汝言取可取异。是事不然。心法能知自体。如灯自照亦照余物。如算数人亦能自算亦算他人。如是心一能知自体。亦能知他。汝说猿喻。是事不然。如一猿猴舍一枝复取一枝。心亦如是。舍一缘复取一缘。其余所说。能自起业。自受报中皆已总答。所以者何。若心异者。则应异作异受异死异生。如是等过。故知一心

    非一心品第七十一

答曰。汝言心一贪等长污。是事不然。于相续心中见是一相。如言夕风即是晨风。今河即是本河。朝灯即是昨灯。如齿名再生。而先齿实不再生。以相似者生故名再生。如是心异。以相续故。谓是一心。汝言忆念者。人或自念本心。若本心来今何所念。又云何当以此心即念此心。无有一智能知自体。故非一心。汝言修集。若心常一。何所修益。若有多心。则下中上次第相续生。故有修集。汝言心为一相。若心是一。即为是常。常即真我。所以者何。以今作后作常一不变故名为我。又不能知心差别相故。则以为一。如注水相续。心谓为一。如眼病者见众发为一。若于此事能分别者。则知其异。又深智者能知心异。所以者何。诸梵王等于中迷闷。作如是言。是身无常心识是常。若梵王等犹尚迷惑。岂况余人。而不着常故。应善思众缘生法。常倒则灭。汝言左见右识是智力故。异见异识。如此人作书余人能识。又如余人所为圣人能知。亦未来事未生。未有圣智能知。又过去事无忆念。故知未来未有智力能知。此事后当广说

    明多心品第七十二

汝言心一用为多业。是事不然。所以者何。正以了为心。而色了与声了异。心何得一。又如捉瓶手业不即此业更捉余物。如是随以何心取色不即此心闻声。又此眼识。以眼为依以色为缘。是二无常念念生灭。眼识何得不念念灭。譬如无树影亦随无。如是眼色念念灭故。所依生识亦念念灭。念念灭法无有去力。又先意品中已种种答故意不去。汝虽言识住眼中待明能见。如即是人能见闻等。是事不然。所以者何。今此论中求法实义。人是假名不应为喻。又应求人相。我说诸阴为人。亦说疑识等众。异定识众。不以疑识等众即为定识众如是一切。汝言根差别故识有差别。是事不然。根是生识因缘。若识是一。根何所为。汝以灯算为喻。是喻不然。如为不照然灯而灯体非不照故不自照。以灯破闇。眼识得生。眼识生已亦能见灯及瓶等物。又算数人。能知自色亦知他色。故名相知。汝言业等。业等难中已答。故无斯咎。又若心常一则无业无报。所以者何。正以心及所依为业。若心是一。何有业报。缚解等亦如是。又汝言异作异受。是亦不然。诸阴相续非一非异。堕二边故。又世俗名字说诸业等非真实义故。于阴相续中。说此彼等名字无咎故知多心

    识暂住品第七十三

问曰。已明多心。今诸心为念念灭。为少时住。有人言。心少时住。所以者何。了色等故。若念念灭不应能了。故非不住。又若念念灭。则色等法终不可知。所以者何。如电光暂住尚不可了。况念念灭而能了耶。今实有了。故知诸识非念念灭。又眼识依眼缘色。是二不异。识亦不异。又心能具取青等诸色。故知非念念灭。若汝意谓以相续故能决了者。是亦不然。若一一心不能决了。虽复相续亦不能了。如一盲人不能见色。多亦不能。若汝复谓如一一缕不能制象。多集则能。如是一心不能决了相续则能者。是亦不然。一一缕中各有少力。和合则能。心一念中无少了力。是故相续亦不应能而实有了故。知非念念灭。又若心念念灭者。去来等业皆应无用。以少时住故。能令有用。是故知心非念念灭。虽复无常要有暂住

    识无住品第七十四

答曰。汝言心有了故非念念灭。是事不然。诸相在心力能决了不以住故。若不尔者。于声业中不应决了。所以者何。现见此事念念灭故。而实决了。故知不以住故能了。又以了为心。若了青非即了黄。是故设使暂住了青不能了黄。又了青时异了非青时异。一法不应二时。法与时俱时与法俱。又取有二种。一者决了。二不决了。若识不念念灭。一切所取尽应决了。我以随识多相续生是取则了。若少相续是则不了。又识取尘或迟或疾心则不定。汝言依缘不异是义已成。色念念灭故依缘亦异。汝言能具取者。识能遍取身分故名具取。是故无有一识而能遍取。所以者何。未具足取心已随灭。何得有心能一切取。汝言作业无用。是事不然。如灯虽念念灭亦有照用。诸业与风虽念念灭亦能动物。是识亦然。又如灯等虽念念灭。亦可得取。识亦如是。虽念念灭亦能得取。复次诸心意识皆念念灭。所以者何。青等诸色集在现前。能速生灭。故知不住。又人或生心。自谓一时能取诸缘。故识不住。若识暂住则人不应生此惑心。所以者何。如种根相续有暂住故。人于其中不生惑心。谓牙茎等一时而有。故知识念念灭。又人见瓶即生瓶忆。以次见生忆故念念灭。又若诸识不念念灭则可一智即邪即正如见是人是取即取非人。如是疑取即是定取。是则不可。故知念念灭。又取分别等诸因缘。故知念念灭。又声业相续念念灭相。于中生知。故知心念念灭

    识俱生品第七十五

问曰。已明心念念灭。今诸识为一时生为次第生。有论师言。识一时生。所以者何。有人一时能取诸尘。如人见瓶亦闻乐声。鼻嗅花香口含香味。扇风触身思惟雅音曲。故知一时能取诸尘。又若一识能于身中遍知苦乐。然则以一眼识亦应能取诸树。是事不可。云何一识悉知根茎枝叶花实。故知多识一时俱生遍取诸触。又种种色中一时生知。而青知非即黄知。故知一时俱生多识。又诸身分中能速生知。取一分时即能遍取。又佛法中无有有分。不可一识遍取诸分。故知一时能生多识。遍取诸分

    识不俱生品第七十六

答曰。汝言诸识一时俱生。是事不然。所以者何。识待念生。如经中说。若眼入不坏色入在知境。若无能生识念眼识不生。故知诸识以待念故不一时生又一切生法皆属业因。以心一一生故。地狱等报不一时受若多心俱生便应俱受而实不可。故知诸识不一时生。又识能速取缘如旋火轮。以转疾故不见其际。诸识亦尔。住时促故不可分别。又诸识若一时生。一切生法皆可一念一时俱生。有何障碍。然则一切法生不须为功。不造业功亦应解脱。是事不可。故知诸识不一时生。又身为心使。若诸心俱生身则散坏。以去来等心以一时生故。而身实不坏。故知诸心不一时生。又眼见外物种根牙等。及迦罗罗脔胞等色。少壮老形次第而有。心亦应尔。又经中说。若受乐时二受则灭。所谓苦受不苦不乐受。如是等。若识俱生则应一时俱受三受。而实不然。故知诸识不一时生。又一身中一心生故名为一人。若识俱生则一身多人。而实不然。是故一身识不并生。又若识并生。则应一时知一切法。所以者何。眼中无量百千识生。乃至意中皆亦如是。如是则应知一切法。而实不然。故知诸识不一时生。问曰。诸识何故要次第生。答曰。一次第缘故识一一生。问曰。何故正有一次第缘。答曰。法应如是。如汝一神一意。我亦如是。一意一次第缘。如牙属种应次第生牙不生茎等。如是随法属心。应次心生不生余法。又识相定尔。一一起灭次第相属。如火相热。是故诸识要次第生

成实论卷第五成实论卷第六

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    苦谛聚中想阴品第七十七

问曰。何法为想。答曰。取假法相故名为想。所以者何。如经中说有人少想有人多想。有人无量想无所有想。而实无此多少等诸法。故知想者取假法相。是想多在颠倒中说。如说无常中常想颠倒。苦中乐想颠倒。无我中我想颠倒。不净中净想颠倒。亦于信解观一切入等中说。又以想三种差别取缘。谓怨亲中。人于是缘中次生三受。受生三毒。故想有过。想有过故佛说应断。如说眼见色莫取想。故知取假法相是名为想。问曰。取假法为想。此义不然。所以者何。此想能断烦恼。如经中说。善修无常想故。能断一切欲染色染及无色染。一切戏掉我慢无明。故知非但取假法想。取假法想则不应能断诸烦恼。答曰。此实智慧以想名说。如说受者于一切得解脱。亦说以意断诸烦恼。又如说以不黑不白业能尽诸业。亦说信能渡河一心渡海。精进除苦慧能清净。而实以慧得渡。不以信等。如是智慧以想名说。又经中说。以慧为刀。如说圣弟子以智慧刃断诸烦恼故。知慧能断结非是想也。又三十七圣道品中不说想名。故不断结。又经中说知者见者能得漏尽。非不知见者。又三无漏根中说。未知欲知根知根知已根。皆以知为名。又佛说慧为慧品解脱知见品。又说无禅不智无智不禅。又次第经说。持净戒者则心不悔。乃至摄心得如实知。又法智等皆以慧为名。又三学中慧学最胜。亦说智慧具足解脱知见具足。又七净中说知见净。又佛说正知一切法故。名无上智慧。想无如是说。又理应用慧断诸烦恼。不是想也。所以者何。如大因缘经说若义入修多罗。不违法相随顺比尼。是义应取。又说于正义中置随义语。于正语中置随语义。故经虽说无常想等。能断诸结理应是慧。又说无明是烦恼根。离无明故慧得解脱。故以慧断诸烦恼。问曰。汝言诸想取假法相。以何为相。答曰。有人以假法为相。假法有五。一过去。二未来。三名字。四者相。五者人。是事不然。所以者何。人因五阴成。相无成因故非假名。问曰。今相义云何。答曰。缘即是相。何以知之。如说师子兽王立河此岸取彼岸相截流而渡。若不相当则还此岸至死不舍。是经中以树木等为相。又说比丘示相。是中亦以衣等为相。又说世尊现如是相。又说宰人因王食故取所嗜相。又说明旦是日出相。又说三相。所谓摄相发相舍相。是中即以摄等为相。随念何法心系在缘是名摄相。又诸天退时先五相现。是中即以五法为相。故知不以假法为相。亦非行阴所摄。又舍利弗取富楼那面貌等相。又经中说眼见色不取相。又法印中说。若比丘自见断色声等相。我未说是人得清净知见。以此故知。缘即是相非假法也。问曰。缘非是相。所以者何。无相三昧亦有缘故。又说见色已不取相。若缘是相。云何取色而不取相。答曰。相有二种。有过相无过相。遮过相故说见色不取相。无相者缘亦有过。后灭谛中当广说。谓灭三心故名无相。初入行者非一切相尽是过也。若取摄相发舍相等是则无过。又涅槃名无法故不应为难。如说若取法相不能为污。取假名相则生烦恼。所以者何。取怨亲等差别相故生忧喜等。从此能生贪恚等过。故知取假法相。是名为想也

    苦谛聚受论中受相品第七十八

问曰云何为受。答曰。苦乐不苦不乐。问曰。何谓为苦。何谓为乐。云何名为不苦不乐。答曰。若增益身心是名为乐损减身心是名为苦。与二相违名不苦不乐。问曰。此三受无决定相。所以者何。如即一事。或增身心。或为损减。或俱相违。答曰。是缘不定非受不定。所以者何。如即一火。或时生乐或时生苦。或时能生不苦不乐。从缘生受是则决定。即此一事以随时故。或为乐因或为苦因。或为不苦不乐因。问曰。以何时故此缘能为苦乐等因。答曰。随能遮苦。于是时中则生乐相。如人为寒所恼。尔时热触能生乐相。问曰。是热触过增还能为苦。非复是乐。故知乐受亦无。答曰。世俗名相故有乐受。非真实义。随是人喜热触时亦为增益。又遮先苦。尔时是中则生乐相。若离先苦。是热触则不能为乐。故非实有。问曰。汝言但以名相故有乐者。是事不然。所以者何。经中佛自说三受。若实无乐。云何说三。又说色若定苦众生于中不生贪着。又说何等为色中味。所谓因色能生喜乐。又说乐受生时乐。住时乐。坏时苦。苦受生时苦。住时苦。坏时乐。不苦不乐受不知苦不知乐。又乐受是福报。苦受是罪报。若实无乐受。罪福但有苦果。而实不然。又欲界中亦有乐受。若实无乐受。色无色界不应有受。而实不然。又说乐受中贪使。若无乐受贪何处使。不可说苦受中贪使。故知实有乐受。答曰。若实有乐受应说其相何者为乐。而实不可说。当知但以苦差别中名为乐相。一切世界从大地狱上至有顶。皆是苦相。为多苦所恼。于小苦中生此乐相。如人为热苦所恼。则以冷触为乐。是故诸经。作如是说无所妨也。问曰。亦可说世间一切皆乐。于微乐中而生苦相。若不尔者。亦不得言于微苦中生乐想也。答曰。苦受相粗故不可以微乐为苦。又乐虽微亦非恼相。所以者何。不见有人受微乐故。举手大呼。又受转微故名寂灭相。犹如上地转转寂灭。是故说微乐中生苦相者。但有是语。凡夫愚人于微苦中。妄生乐相。则有道理

    行苦品第七十九

诸受皆苦。所以者何。衣食等物。皆是苦因非乐因也。何以知之。现见衣食过增。则苦亦增。故名苦因。又手痛等苦可以相示。乐相不然。又衣食等物皆为疗病。如人不渴饮不生乐。又人为苦所恼。于异苦中而生乐相。如人畏死以刑罚为乐。又鞭杖刀槊诸苦因缘。皆是决定。乐因不然。又一切所须究竟苦故。当知先有后时乃觉。如屐渐尽。又于女色等中先生乐相。后还憎恶。故知以邪忆想生此乐相。离邪忆想还见其过。又女色等皆是干消病等苦因。故非乐也。又离欲时皆舍此缘。若实是乐何故舍耶。又人随生乐处。后即此事还生苦心。故知非乐。又身为苦田非乐田也。如野田中嘉苗难殖而秽草易生。如是身田众苦易集。而虚乐难生。又人于苦中先起乐倒。后生贪着。乐若少实不名为倒。如常我净少实亦无乐亦如是俱颠倒故。又人于辛苦中而生乐心。如担重易肩故知无乐。又经中佛说当观乐是苦。观苦如箭入心。不苦不乐当观无常念生念灭。若定有乐不应观苦。当知凡夫于苦取乐。是故佛说随凡夫人生乐相处。汝当观苦。又此三受皆苦谛摄。若实是乐。苦谛云何摄。又苦为真实乐相虚妄。何以知之。以观苦心能断诸结。非乐心也。故知皆苦。又一切万物皆是苦因。犹如怨贼。怨贼二种或即能为苦。或初虽软善后则害人。万物亦尔。或初便生善或后反为害。故知皆苦。又众生得欲无厌如饮碱水。不足故苦。又无所求欲乃名为乐。求故名苦。不见世间有无求者。故知无乐。又一切众生身苦心苦常随逐。故知身为苦。又身如狱常有羁锁。何以知之。以灭此身乃名解脱羁锁故苦。又一切物渐渐次第。皆可鄙恶。如地狱等身冬夏等时小儿等根知寒暑等相待后皆憎恶。当知皆苦。又身多怨贼。谓毒蛇箧五拔刀贼。诈亲善贼及空聚落坏聚落贼。大河此岸种种诸苦皆常随逐。故知皆苦。又知众生身诸苦随逐。谓生苦老苦痛苦死苦怨憎会苦爱别离苦违愿等苦。常与相随故。故身为众苦之聚。又以有身故则有我所及贪着等诸衰恼集。故知身为众苦因缘。又亦五道众生行四威仪。皆无有乐。所以者何。如经中说。色是苦受。想行识是苦。若色生时当知即是老病死等诸衰恼生。受想行识亦复如是。又身常匆务。以身口意造作众事。造作众事皆名为苦。又诸贤圣以身尽为悦。若实为乐。云何失乐而生欢悦。故知皆苦也

    坏苦品第八十

问曰。汝虽以多因缘明苦。而人犹贪乐。随得所欲以为乐。答曰。是先已答。凡夫倒故于苦取乐。又痴惑所害云何可信。虽得所欲亦应观苦。所以者何。是皆无常坏时生苦。如经中佛说天人爱色乐色贪色。是色坏时生大忧苦。受想行识亦复如是。以坏败故当知亦苦。又人受虚妄乐便生贪着。以贪着因缘生守护等过。故当观乐甚于苦也。又乐为苦门。以贪乐故从三毒起不善业。堕地狱等受诸苦恼。当知皆以乐为根本。又一切合会皆别离相。离所爱时深受诸苦。不由不爱。故知乐者甚过于苦。又乐具之生。皆为欺诳众生令堕诸苦如食野禽为鱼沈饵。皆以取故。乐物亦然。故应观苦。又于乐受中得少味。故获无量过。犹如鱼兽所味至寡其患甚多。故应观苦。又乐受是烦恼生处。所以者何。以贪身故则欲所须。欲因缘故恚等烦恼次第而生。又乐受是生死根本。所以者何。因乐生爱。如经中说。爱为苦本。又一切众生有所造作无不为乐。故名苦本。又乐受难舍甚于桎梏。又生死中贪乐所缚。所以者何。以贪乐故不脱生死。又此乐受常能生苦。求时欲苦失时忆苦。得时无厌如海吞流。是亦为苦。又乐受是不疲倦因。所以者何。众生求乐因时。虽经崄难以为乐。故心不懈倦。是故智者应当观苦。又乐受名起诸业因。所以者何。以贪乐故能起善业。为现乐故起不善业。亦是一切受身之因。所以者何。取乐生爱。爱故受身。又乐受与涅槃相违。所以者何。众生贪着生死乐。故不乐泥洹。又未离欲者。爱此乐受。爱因生苦。故知乐受是众苦本。又经中说二求难断。一谓得求。二谓命求。求随意诸欲。是名得求。求得寿命受此诸欲。是名命求。此二求皆以乐受为本。是故智者难断应断。谓能如实观乐受相。又乐受味亦能染污。未得离欲。大智人心以难断故甚于苦受。又乐受味是贪等因。若无乐受则无所贪。又乐受味真智能断。所以者何。世间诸智要取上地味。能舍下地。故知乐受甚过于苦。又众生心缚在生处。乃至畜生亦贪惜身。当知皆以乐受味故。是故应观乐受为苦

    辩三受品第八十一

问曰。已知一切皆苦。今以何差别故有三受。答曰。即一苦受。以时差别故有三种。能恼害者则名为苦。既恼害已更求异苦。以遮先苦以愿求。故大苦暂息。尔时名乐。忧喜不了不愿不求。尔时名为不苦不乐。问曰。不苦不乐不名为受。所以者何。苦乐可觉。不苦不乐不可觉故。答曰。是人为三触所触。谓苦触乐触不苦不乐触。以有因故当知有果。如人热极。得冷触觉乐。得热触觉苦。得不冷不热触。觉不苦不乐。故知有此不苦不乐。汝意或谓不苦不乐触中不能生受。是事不然。所以者何。人觉此触不冷不热。觉知所缘即名为受。云何言无又缘有三差别。怨亲中人。于亲生喜。于怨生忧。于中生舍。故知想分别故有此三受。以缘别故。起此三想。又缘有三种。为益为损或俱相违。有乐不乐有俱相违。亦有贪处嗔处痴处。有喜不喜有俱相违。有福果罪果有不动果。是诸缘中随生三受。故知有此不苦不乐受。又可适心处是名乐受。违逆心处是名苦受。不逆不顺名不苦不乐受。又世八法得失毁誉称讥苦乐。凡夫于失等四法违逆其心。于得等四法以为可适。必当应有离欲圣人能俱舍者舍名不苦不乐受。是故非无。问曰。若以触等因缘故有三受者。则一切心行皆名为受。所以者何。所有心行在于身中。皆是苦乐不苦不乐。答曰。如是一切心行皆名为受。所以者何。经中说十八意行。是中但是一意有十八差别。谓六喜行六忧行六舍行。以想分别故。有苦分乐分舍分。故知一切心行无非受也。又经中说诸受皆苦。故知心行在于身中。皆名为苦。又说若色生即是苦生。云何色名为苦。以苦因故。故知缘及诸根但能生苦。是故一切心行皆名为受。以行苦故。一切诸行应观是苦。以坏苦故。应观乐受为苦。苦苦即苦。是三种苦。皆从众缘和合故生。念念灭故圣人观苦。是故一切心行。皆名为受。问曰。无漏诸受亦是苦耶。答曰亦苦。所以者何。无漏诸受圣人亦次第舍。从初禅来乃至证一切灭。是皆有苦。又有漏禅乐无漏禅乐。有何差别。随有漏禅以我因故苦。无漏诸禅亦以此苦。又若圣人住无漏心深厌一切。故无漏心生则深生厌患。如睫入目。凡夫不知。皆以苦为乐。圣人智深妙故厌离有顶。甚于余人厌患欲界故。无漏苦喻于有漏。又诸圣人得无漏心。但向涅槃。所以者何。是人尔时明见一切有为法苦。若无漏受乐则应喜乐。不应复生向泥洹心。问曰。若诸心行皆名受者。云何别有诸心等法。答曰。即是一受缘中行异故有差别。诸心等法亦行缘异。但识缘时是行名心。此等如先说。是一切法在身中时。有利益等诸差别故。故名为受。又多以心能起烦恼。尔时名受。如经中说乐受中贪使。苦受中嗔使不苦不乐受中无明使。是故想分别缘中喜等法名受。所以者何。是时能生诸烦恼故。问曰。若一一受中三烦恼使。何故定说乐受中贪使。答曰苦受中不应贪使。痴一切处使以痴力故。于苦中生乐想。不知见事故得苦生嗔。不苦不乐受细故不觉贪嗔。所以者何。是人于此中不生苦乐想故。不知见事故但生痴使。又于舍缘中若贪嗔不行。凡夫于中谓能胜缘。是故佛言。汝不胜此缘以未觉故贪嗔不行。如经中说。凡夫所有色中生舍皆依止色。若胜此缘于我增益若作损减。还生贪嗔故知未胜缘。又不苦不乐受。其相寂灭如无色定。以寂灭故。烦恼细行。凡夫于中生解脱想。是故佛说此中有无明使。又未觉缘故苦乐不了。若知此缘苦乐则了。尔时则生贪嗔。问曰若觉此缘则生苦乐相。是故但应有苦乐受。答曰。是人有时于此缘中。不生乐心不生苦心。是故不但有苦乐也。如先说皆是苦而有三差。问曰。汝言觉知此缘还生乐想。云何觉知不可以无明觉知。答曰。是人于此缘中先取相。故于此缘中若无明使。若贪嗔使。问曰。但于苦乐中生痴。如经中说。是人于诸受不如实知集灭味过出等。以不知故于不苦不乐中说无明使使。是故但于苦乐中起无明使。非不苦不乐中。答曰。此经自说于诸受不如实知集灭味等故。不苦不乐中无明使使。问曰。虽有是说此义不然。云何于苦乐不知集灭等故。不苦不乐受中无明使使。所以者何。于余事不知余事中使。是故此经应如是说。是人于不苦不乐受中不知集等故。不苦不乐受中无明使使。若不苦不乐受中无明不使。答曰。是人于不苦不乐受中生三种心。寂灭想不苦不乐想故生不苦不乐心。若以邪智取相则生乐心。若取上地乐味则生苦心。是故经中说诸受多语。所以者何。一切诸受皆无明所使。是不苦不乐受随时故。有三种差别。又若未通达苦集等。尔时于苦受中生乐想。亦生不苦不乐想。是故说不知诸受集等故无明使使。但不苦不乐受中多无明使使

    问受品第八十二

问曰。经中说是人受乐受时。如实知我受此乐受。如实知何受耶。过去未来受不可得受现在受不得自知。答曰。此经意说人受。是故无过。又乐等受来在身。以意能缘故亦无咎。又于乐具中说乐等名世间。亦有因中说果故。又是人先受乐受。然后取相故。名受乐受时如实知。问曰。为以受者故名受。可受故名受。若以受者名受则受与乐等异。而经中说乐受苦受不苦不乐受。若以可受名受。谁受之者。以受故名受。答曰。于缘中说乐。如火苦火乐。是故以觉知缘故名为受乐。又众生受此受故名可受为受。问曰。众生不名为受。经中说受为受。答曰。名义如是有相则有作。假名中有相。是苦乐不苦不乐在身则心能觉。故说受为受。问曰。经中说诸受中顺受观行者。尔时云何生苦乐不苦不乐相。是人尔时不皆生苦相耶。答曰。是人未得一切皆苦。但忆念三受。问曰。若用意识修四念处。云何说身乐。答曰。于一切受中应如是系念。是身乐是心乐。又修念处时身中生乐相。系念是中故名身乐。问曰。若一切受皆是心法。何故说身受答曰。为外道故说。外道谓诸受依神故。佛说诸受依止身心。问曰。何者是身受。答曰。因五根所生受。是名身受。因第六根所生受。是名心受。问曰。是受云何名垢。云何名净。答曰。诸烦恼名垢。是烦恼所使受。是名为垢。烦恼所不使受。是名为净。问曰。云何苦受名净。答曰。断烦恼人苦受。是名为净。又与烦恼相违苦受。是名为净。问曰。已说垢净。何故更说依贪依出。贪即烦恼。出即是净。答曰。先总说垢。今更别说贪为垢因。如经中说有垢喜。有净喜。有净中净喜。垢喜者。因五欲生喜。净喜者。谓初禅喜。净中净喜。谓二禅喜。若受但为泥洹。是名依出。是故更说。问曰。五根中何故苦受乐受各分为二。而舍受不耶。答曰。忧喜要以想分别生。苦乐不必由想分别。舍受想分别微。故不为二。问曰。第三禅中意识所受何故名乐。不说喜耶。答曰。是乐深厚遍满身心故名为乐。喜但能遍心不能遍身。故三禅中佛差别喜说身受乐。问曰。是三受中何者能生深厚烦恼。答曰。有论师言乐受能生。所以者何。先已说坏败等因缘受大苦故。又论师言。苦受能生。所以者何。众生为苦所逼。以求乐故深起烦恼。又种种乐少苦能胜。如人具足受五欲时。蚊蚋所侵则生苦觉色等五欲乐不如是。又如存百子乐。不如丧一子苦。又生死中苦受相多。乐受不尔。所以者何。多有众生在三恶趣。生天人少。又不须加功自然得苦。加功求乐有得不得。犹如田中秽草自生。嘉苗不尔。又因苦受起重罪业所以者何。苦受中有嗔使经中说。嗔为重罪。又论师言。不苦不乐能生。所以者何。是中有痴使。痴是一切烦恼根本。又此受细微。是中烦恼难觉知故。又此受是众生本性。苦乐为客。又此受遍在三界。余二不尔。又此受是长寿因。贪此受故寿八万大劫久受苦相诸阴。又此受与泥洹相违。所以者何。是中生寂灭相泥洹相故。不复能得真实泥洹。又此受以圣道能过。如说因离性得解脱。苦受乐受以世间道亦能得过。又此受穷生死边断相续时断。是故能生深厚烦恼

    五受根品第八十三

问曰。乐根为在何处。乃至舍根在何处耶。答曰。苦乐在身。随所得身。乃至四禅。余三在心。随所得心。乃至有顶。问曰。如经中说。忧根初禅中灭。喜根三禅中灭。乐根四禅中灭。舍根灭尽定中灭。是故汝说不然。答曰。若汝信此经者。则苦根应在初禅。而汝法中初禅实无苦根。是故不应信此经也。问曰。色无色界深修善法。应无忧苦。答曰。三界皆苦。上二界中虽无粗苦亦有微苦。何以知之。四禅中说有四威仪。随有威仪皆应有苦。又色界有眼耳身识。此识中所有受名为苦乐。从一威仪求一威仪。故知有苦。又经中问。色有何味。所谓因色生乐生喜。色中有何过。谓所有色无常苦败坏相。色界有色故。有味心有过心。故有苦乐。又行者于诸禅定亦贪亦舍。必以乐受因缘故贪。苦受因缘故舍。故知有苦乐也。又佛说声等是初禅刺。觉观是二禅刺。乃至非想非无想处有想受刺。刺名苦义。故知一切有苦。又一切五阴皆名为苦。正以恼害为苦。如欲界受恼害故苦。上二界受亦有恼害。何故非苦。如欲界说病等八行。色无色界同说八行。何故无苦。又色界说光明优劣。故知色界业亦差别。业差别故必应当有得苦报业。又经说。此中有嫉妒等烦恼。如有梵天语诸梵言。此处是常。汝等勿诣瞿昙沙门。亦有梵天来难问佛。又经中说。入第四禅断不善法。又经中亦说是中有邪见烦恼。是等烦恼即是不善。应得苦报。何故无苦。又论师说。一切烦恼皆是不善。是中云何无苦受耶。又经中说。诸天人爱色乐色贪色着色。是诸天人爱乐贪着色故。是色败坏则生忧苦。乃至识亦如是。故知一切未离欲人。皆有忧喜。又爱缘生喜。离此爱缘必生忧悲。凡夫无智何能有力。得所爱缘而不生喜。失不生忧。如经中说。唯得道者。将命终时无忧喜色。故知一切凡夫忧喜常随。又佛自说。不忧不喜一心行舍。是应罗汉功德。又六舍行唯圣所行。非凡夫也。凡夫或时行舍。皆以未能知见缘故。如经中说凡夫色中所有舍心。皆依止色贪色不离。故知凡夫无舍心也。又经中说乐受中贪使。若彼无乐受贪何处使。汝意或谓。不苦不乐中贪使使。经无说处。又上地中。转寂灭乐大利身心。如说是天一坐千劫。若苦行者。于诸威仪不能久住。如经中说安坐七日受解脱乐。又是中猗乐第一。如经中说猗者受乐。故知一切地中皆有乐也。汝意或谓。猗受乐异。是事不然。所有利益事来在身。则名为乐。是故猗乐不异受乐。问曰若上界定有苦乐忧喜。云何得与禅经相顺。答曰。此经违害法相。若舍何咎。又此中乐行寂灭不善。不能发起粗贪粗恚。是故说名无苦乐。又此中苦乐细微不了。无有刀杖等苦丧亲等忧。是故名无。如说色界无寒无热。是中亦有四大。云何当言无寒无热耶。如说三禅众生一身一想。是中亦有光明差别。如说若行禅者。不能善除睡眠戏调。则光明不净。又少智人名为无智。又如世人以食中少碱名为无碱。如是彼中忧喜不了。故名为无。又汝等说彼中无觉。佛经中说想因缘觉。是中有想云何无觉。故知觉法乃至有顶为粗觉故。说二禅灭。是故上二界中亦有苦乐等。受阴竟

    苦谛聚行阴论中思品第八十四

经中说思是行阴。问曰。何等为思。答曰。愿求为思。如经中说。下思下求下愿。问曰。以何故知求名为思。答曰。经中说作起故名为行。受阴作起是名求。如经说作起皆依于爱。又经中说。如一束麦置四衢道中。六人来打。有第七人复更来打。比丘于汝意云何。是为熟不。熟已世尊。佛言。痴人亦尔。常为六触入之所打。如是打时复思后身。是为至熟。当知求即是思。又说。意思食应观如火聚。火何所喻。是人求后身。后身如火。常生诸苦故。又经中说。我即是动处亦是戏论。作起依爱。随有我处则有动念戏论。作起依爱。若作起法说名依爱。当知求即是思。又说。若小儿从生习慈。能起恶业思恶业不。不也世尊。是义名求欲造恶业。又说业者若思。思已是中思是意业。思已是身口业。思已名为求已。又和利经中说尼延子断冷水受暖水。死时求冷水。竟不得而死。生意着天。是则以思冷故生。故知求即是思。问曰。汝言求是思者。此是爱相非是思也。所以者何。有因有缘经中说。痴人所求即是爱也。又大因经中说。因爱故求等。又经中说。苦者多求。乐者不求。又说。若人欲行五欲。欲即是求。又说爱因缘取。先求后取。求即是爱。是故汝以求为思是事不然。又汝言愿是思者。是亦不然。所以者何。和利经中说不思造业业则不重。不思名不先知。世间亦以知为思。如言云何智者能为是事。谁有思者当作是事。此语义名智者。故知知即是思。答曰。愿名为集。欲分愿名思。如人愿言我未来世得如是身。问曰。若欲分愿是思者。则无无漏思。又思为爱因。如经中说若知见意思食即知见断三爱。故知思是爱因。答曰。汝言无无漏思。我亦不说有无漏思。所以者何。作起行相故名为思。无漏法无起作相。故思是作起非灭法也。又汝言思是爱因。是亦不然。所以者何。思为爱果。亦是爱分非爱因也。以果断故说因断。谓意思食断故三爱断。行等因缘众皆以是答。故知爱分是思。爱有二种。有因。有果。因名爱。果为求。求即是思。问曰。若因时名爱。果时名思。则思非爱分。所以者何。若法在因相异在果相异。故知思非爱分。如有因有缘经中说痴人所求即名为爱。爱者所作即名为业。是故思堕业相。故与爱异。若人贪此事故求是事。是故从贪生求。求即是思。是故贪为思因。答曰。我先说爱分是思爱分即是爱。但爱初起名贪。贪已名求。又汝言愿者。是事不然。所以者何。愿是思分。先愿名业。后业回向。问曰。思与意为一为异。答曰。意即是思。如法句中说恶心所作所说皆受苦果。善心亦尔。故知意即是思。若意非即是思。何者为意业。意业名意行缘中。是故思即是意。虽总相说意行名思。而思多在善不善中说。是思有众多分。若人为他众生求善求恶。尔时名思。若求未得事尔时名求。若求后身尔时名愿。故知一思以种种名说

    触品第八十五

识在缘中是名为触。以三事和合名触。是非触相。所以者何。根不到缘。是故根缘不应和合。以此三事能取缘故名为和合。问曰。别有心数法名触。所以者何。十二因缘中说触因缘受。又说触为受想行等因。若法无者云何为因。故知有此心数法名为触。又六六经中说六触众。又经中说应观无明等触。若说成假法诸因。不应复别说假法。又经中有二种触。一三事和合触。二三事和合故触。故知触有二种。一有自体。二是假名。如日珠牛粪。三事异火。月珠异水。地等异牙。如是触异。眼等有何咎耶。又如诸比丘和合不异比丘。诸阴和合不异诸阴。二木和合不异二木。二手和合不异二手。众病和合不异众病。触亦如是。不异眼等复有何咎。答曰。我先说心能取缘尔时名触。是故心时为因。识生然后受等法生。六六经中亦说。尔时名触。是有道理。又我等不受此二种触。常言三事和合名触。设复有是二种触。经违法相故亦应弃舍。是触引经非因。又若是触异如水火者。作亦应异。而实不见别有异作。故知此触不异三事。又若触是心数则与余心数异。所以者何。触是诸心数缘而触。非触缘以生异。故非心数法。问曰。以触胜故触缘。心数非触缘。触如受缘爱非爱缘受答曰。触有何胜相而余心数无。应说其相。而实不可说。是故非因。受是初时爱是后时。故受缘爱非爱缘受。又若触是别心数法应说其相。而实不可说。当知不异。又佛于异法中亦说触名。如说若有苦恼来触人身。又说受乐触不放逸。受苦触不嗔。此于受中说触名字。又佛语箭毛鬼言。汝触粗涩不可近身。如世间说火触是乐。亦说触为食。亦言手触。此等皆于身识所知事中说触名字。又余处说盲不触色。亦于色等缘中说触名字。是触语不定故。非别有此心数法。若说触是心数则与触相相违。所以者何。佛说三事和合故名触。故知实无别心数法。若法来在身皆名为触。又随能与受等心数作因。尔时与名为触

    念品第八十六

心作发名念。此念是作发相。故念念能更生异心。又说。念相能成办事。如经中说若眼内入不坏色。外入在现前。是中若无能生异心念者。则眼识不生。问曰。诸识知皆以念力生不。答曰不也。所以者何。诸识知生不必定。或以作发力生。如强除欲等。或以根力故生。如明目者能察毫端。或以缘力故生。如远见灯不见其动。或善习故生。如工巧等。或以谛取相故生。如所著色。或法自应生。如劫尽时禅。或以时节故生。如短命众生恶心。或以生处故生。如牛羊等心。或随身力故生。如男女等心。或随年故生。如小儿等心。或以疲倦故生。或以业力故生。如受诸欲。或以定力故生。如系心一处知识增长。或以毕定故生。如次无碍道必生解脱。或以久厌故生。如厌辛苦则思甜味。或随所乐故生。如对色等。或乐观色不喜听声。青等亦尔。或以细软故生。如毛入目则生苦心。余处不然。或以苦灭故生。如除目患则食得味。或以灭障故生。如除欲等则知其过。或渐次故生。如因下生中因中生上。或随所偏故生。问曰。若一切知识皆次第相属。何故说无能生异心念耶。答曰。为外道故。外道等说神意合故知识生。为破此语示诸知识属次第缘。故如是言。若无能生异心念者。知识不生。所以者何。以次第缘故则知识有因。一一而生。又随所偏处一一识生。譬如伐树随倾而倒。又先说诸识不一时生。以是因缘故知诸识一一次第生。又诸识法应次第而生。不待神意和合。如外物根茎枝叶华实次第而生。内法亦如是。一一知识次第而生。是念二种。一正。二邪。正谓顺理。如说正问正难。是名可答有理难问。又问诸法实相无常性等。是名为正。又随所能成故名为正。故知随顺道念真实念等名为正念。又随人时念名为正念。如多欲人不净观为正念。心没时发相为正念。与此相违名为邪念。正念能生一切功德。邪念能起一切烦恼

    欲品第八十七

心有所须是名为欲。所以者何。经言欲欲。以须诸欲故名欲欲。又经中说。欲为法本。以欲求故得一切法。故名法本。又说。若诸比丘深欲我法。法则久住。若一心所须名为深欲。又如意足中言欲三昧精进三昧心三昧思惟三昧。随心所须名欲。是欲法以精进助修集定慧。从此四事所须皆得名如意分。又说。汝欲飞去。有一比丘常好读诵。是人修禅得阿罗汉。不复读诵。有天问言。汝常好诵。今何故不诵。比丘言。我本未离欲故须欲经书。今离三界不复须也。所有经书禅定智慧圣人皆说是可舍法。故知以须为欲因所须故贪于诸欲。是名贪欲

    喜品第八十八

若心好乐是名为喜。如说众生性类相从。喜恶随恶好善从善。是名为喜。问曰。性不名喜。所以者何。佛知众生种种诸性是性智力。知种种喜是欲智力。故知性喜各异。答曰。久修集心则名为性。随性生喜。是故知久集心名性智力。智随性生喜名欲智力。故说众生随性相从长集恶心则好喜恶。久集善心则喜乐善。若寒者喜热。是现在因缘不从性生。是为性喜差别

    信品第八十九

必定是信相。问曰。必定是慧相。必定名断疑。是名慧相。答曰。未自见法。随贤圣语心得清净。是名为信。问曰。若然者。自见法已不应有信。答曰。然阿罗汉名不信者。如法句中说不信者不知恩者。名为上人。又经中说。世尊。我于是事随佛语信若自见法心得清净。是名为信。先闻法后以身证。作如是念。此法真实谛不虚诳。心得清净。是名为信。在四信中。譬如病人先信师语服药差病。然后于师生清净心。是名为信。是信二种。一从痴生。一从智生。从痴生者。不思善恶。于富兰那等恶师所生净心。从智生者。如四信中。于佛等生净心。是信三种。善不善无记。问曰。是不善信即是烦恼。大地中不信法非是信也。答曰。非不信法信是净相。是不善信亦是净相。若不尔则不善受不应名受。而实不然。故有三种差别。若信在根数随顺解脱。在三十七品则定是善

    勤品第九十

心行动发是名为勤。常依余法若忆念若定。于中发动一心常行。是名为勤。勤有三种。善不善无记。若在四正勤中是名为善。余不名善行者。若信不善过患。善法利益。然后生勤为断不善。集善法故。故次信根说精进根。是勤入善法中名曰精进。能为一切利益之本。以此精进助忆等法。能得大果。如火得风多所焚烧

    忆品第九十一

知先所更是名为忆。如经中说久远所更能忆不忘。是名为忆。问曰。此忆在三世中。所以者何。经中说。忆一切皆宜。又此忆在四忆处。是四忆处亦三世缘。何故但说缘过去耶。答曰。此言皆宜。非为三世。若心掉没则忆随二处。是名遍行。汝言四忆处三世缘者。是中慧能现在缘。非是忆也。是故如来先说忆名。解则说慧。问曰。云何异识所更异识能忆。答曰。忆法如是于自相续生灭法中。即生异识还自能缘。又知识法尔。异识所更异识能知。如眼识识色意识能知。又他人所更他人能知。如诸圣人乃至宿命余身所更。忆力故知。问曰。若知先所更名为忆者。今识等法皆应名忆。所以者何。是法亦行先所更故。答曰。识等法亦说是忆。如佛语萨遮尼延子言汝忆本事当答。又说。若忆先戏乐则烦恼发。故识等法忆本事。故亦名为忆。是忆从取相生。随法取相是则忆生。异则不生定慧。定慧品中当说

    觉观品第九十二

若心散行数数起生。是名为觉。又散心中亦有粗细。粗名为觉。以不深摄故名粗心。如经中说。佛言。我行有觉观行。是故初禅未深摄故名有觉观。散心小微则名为观。是二法者遍在三界。以是心之粗细相故。又散乱心名为觉观。以此相故应一切处。又未现知事以比智知。思量应尔不尔。是名为觉。是故思量未现知事故。有正觉邪觉之名。离分别思量则名正见。是三种知邪觉是颠倒思惟。谓无常中常等正觉。是未得真智。以比相知是行者在达分善根中是说名忍。如是等余顺道比知名为正觉。是中若离忆相分别名现在知。于此觉中思惟筹量。以此因缘故如是此因缘故不如是。是名为观。问曰。有说。觉观在一心中。是事云何。答曰。不然。所以者何。汝等自说喻如打铃初声为觉余声为观。又如波喻。粗者为觉微者为观。是时方异故不应一心。又五识无分别故。无有觉观

    余心数品第九十三

若不行善。或邪行善名为放逸。无别一法名为放逸也。尔时心行名为放逸。与此相违名不放逸。若善心行名不放逸。亦无别法。又心随不善名为放逸。随顺善法名不放逸。善根者不贪不恚不痴。以思量为首。能无贪著名为不贪。以慈悲为首。不生忿怒是名不嗔。以正见为首。不谬不错是名不痴。无一别法名为不贪。有人言。无贪名不贪。是事不然。所以者何。无贪名无法。无法云何与法为因。无嗔无痴亦如是。又与三不善根相违故但说三。憍慢等亦应。是不善根。以略故说三不善根。不善品中当说。无记根者。有人说四。谓无记爱见慢无明。有人说三。爱无明慧。是非佛所说。随无记心何因缘生。名此因缘为无记根。又身口业多从无记心起故。无记心名无记根。心行时能令身心安静。除灭粗重尔时名猗。种种心时名舍。若诸受中不了心行名舍。诸禅中离苦乐任放心行名舍。七觉中不没不动平等心行名舍。离忧喜得平等心名舍。四无量中离憎爱心名舍。如是随难种法相违故。则有无量心数差别

成实论卷第六成实论卷第七

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    不相应行品第九十四

心不相应行。谓得不得无想定灭尽定无想处命根生灭住异老死名众句众字众凡夫法等。得者。诸法成就为众生故有得。众生成就现在世五阴名为得。又过去世中善不善业未受果报众生成就是法。如经中说是人成就善法亦成就不善法。问曰。有人言。过去善不善身口业成就。如出家人成就过去戒律仪。是事云何。答曰。是皆成就。所以者何。经中说。若人为罪福。即是已所有二事常追其身。犹影随形。又经中说。殃福不朽谓能得果。若不成就罪福业者。不应得果。则失诸业。问曰。过去律仪不应成就。所以者何。汝言过去法灭未来未有。现在不能常有善心。云何成就戒律仪耶。答曰。是人现在律仪成就非过去也。如以现染故染。如是以现在戒故名为持戒。不以过去。但以先受不舍故名成就过去。问曰。有论师言。众生成就未来世中善不善心。是事云何。答曰。不成就。所以者何。未作业已得故。是故未来不成就。是名为得。无别有心不相应法名为得。与此相违名为不得。亦无别有不得法也。无想定者。无此定法。所以者何。凡夫不能灭心心数法。后当说。是心心数法微细难觉故名无想。无想处亦如是。灭尽定者。心灭无行故名灭尽。无有别法犹如泥洹。命根者。以业因缘故五阴相续名命。是命以业为根故说命根。生者。五阴在现在世名生。舍现在世名灭。相续故住。是住变故名为住异。非别有法名生住灭。又佛法深义。谓众缘和合有诸法生。是故无法能生异法。又说。眼色等是眼识因缘。是中不说有生。是故无生无咎。又说生法等一时生。若法一时生即灭。是中生等何所为耶。应思是事。又十二因缘中。佛自说生义。诸众生处处生受诸阴名为生。是故现在世中初得诸阴名生。亦说。五阴退没名死。亦说。诸阴衰坏名老。无别有老死法。名众者从字生名。如言某人随字成义名句。诸字名字。有人言。名句字众是心不相应行。此事不然。是法名声性法入所摄。问曰。凡夫法是心不相应行。是事云何。答曰。凡夫法不异凡夫。若别有凡夫法。亦应受别有瓶法等。又数量一异合离好丑等法。皆应别有。外瓶书中说瓶异瓶法异。因瓶法知是瓶色异色法异。是事不然。所以者何。法名自体。若汝谓凡夫法异。则色自无体。应待色法故有。是事不然。是故汝不深思故说别有凡夫法。有诸论师习外典故造阿毗昙。说别有凡夫法等。亦有余论师说别有如法性真际因缘等诸无为法故。应深思此理。勿随文字。苦谛聚竟

    集谛聚业论中业相品第九十五

论者言。已说苦谛竟。集谛今当说。集谛者。诸业及烦恼。是业有三种。身业口业意业。身业者。身所作名身业。是业三种夺命等不善。起迎礼拜等善。断草等无记。问曰。若身所作名身业者。瓶等物亦应是身业。身所作故。答曰。瓶等是身业果。非是身业。因果异故。问曰。不应有身业。所以者何。身所动作名为身业。有为法念念灭故不应有动。答曰。是事念念灭品中已答。所谓法于余处生时损益他。是名身业。问曰。若尔者。身即身业以余处生故。非身所作名为身业。答曰。身是作业之具。身于余处生时集罪福名为业。是故身非业也。问曰。集罪福是无作。身作云何。答曰。身余处生时有所造作。名为身作。问曰。是身作或善或不善。而身不然。是故非身所作。答曰。随心力故。身余处生时能集业。是故集名善不善。非直是身。口业亦尔。非直音声语言以心力随音声语言所集善恶是名口业。意业亦如是。若决定心我杀是众生。尔时集罪福亦如是。问曰。如从身口别有业。意与意业为即为异答曰。二种。或意即意业。或从意生业。若决定意杀众生是不善意。亦是意业。是业能集罪胜身口业若未决定心是意则与业异。问曰。已知作相从作生异集业。何者为相。答曰。是即名无作。问曰。但身口有无作。意无无作。答曰。不然。所以者何。是中无有因缘。但身口业有无作。而意无无作。又经中说二种业。若思若思已。思即是意业。思已三种。从思集业及身口业。是意业最重。后当说。从重业所集名无作。常相续生故。知意业亦有无作

    无作品第九十六

问曰。何法名无作。答曰。因心生罪福。睡眠闷等。是时常生。是名无作。如经中说。若种树园林造井桥梁等。是人所为福昼夜常增长。问曰。有人言。作业现可见。若布施礼拜杀害等是应有。无作业不可见故无。应明此义。答曰。若无无作则无离杀等法。问曰。离名不作。不作则无法。如人不语时。无不语法生。如不见色时。亦无不见法。答曰。因离杀等得生天上。若无法云何为因。问曰。不以离故生天。以善心故。答曰。不然。经中说。精进人随寿得福多。故久受天乐。若但善心云何能有多福。是人不能常有善心故。又说。种树等福德昼夜常增长。又说。持戒坚固若无无作。云何当说福常增长及坚持戒。又非作即是杀生。作次第杀生法生。然后得杀罪。如教人杀。随杀时教者得杀罪。故知有无作。又意无戒律仪。所以者何。若人在不善无记心若无心。亦名持戒。故知尔时有无作不善律仪亦如是。问曰。已知有无作法非心。今为是色。为是心不相应行。答曰。是行阴所摄。所以者何。作起相名行。无作是作起相故。色是恼坏相非作起相。问曰。经中说六思众名行阴不说心不相应行。答曰。是事先以明。谓有心不相应罪福。问曰。若无作是色相有何咎。答曰。色声香味触五法非罪福性故。不以色性为无作。又佛说。色是恼坏相。是无作中恼坏相不可得故非色性。问曰。无作是身口业性。身口业即是色。答曰。是无作但名为身口业。实非身口所作。以因身口意业生故。说身口意业性。又或但从意生无作。是无作云何名色性。又无色中亦有无作。无色中云何当有色耶。问曰。何等作能生无作。答曰。从善不善作业。能生无作。非无记以力劣故。问曰。几时从作生无作。答曰。从第二心生。随善恶心强则能久住。若心弱则不久住。如受一日戒则住一日。如受尽形则尽形住

    故不故品第九十七

问曰。经中说故作业不故作业。云何名故不故耶。答曰。先知而作名为故作。与此相违名不故作。问曰。若不故作不名为业。答曰。有是业但心故作业则有报。又决定心作业名故。不决定心作名不故。如卒语名不故。不卒语是名故。如经中说汝有过失我当数。若卒语我则不数。乃至三问。若先无作心而作。如人行时。践蹈杀虫是名不故。是不故业以不集故不能生报。业有四种。有作不集。有集不作。有亦作亦集。有不作不集。作不集者。如作杀等业后则心悔。作施等业后亦心悔。又起作业心不复忆。是名作非集。集不作者。若他作杀等则心生喜。他作施等心亦生喜。亦作亦集者。若作杀等罪施等福亦心生喜。不作不集者。亦不作亦不生喜。于是中。亦作亦集是必受报。如经中说若业亦作亦集。是业必受果报。是故作集业。若现受报。若生受报。若后受报。问曰。若故作集业必受报者。则无解脱。答曰。业虽故作得真智故不复更集。譬如焦种不能复生。问曰。佛盐两经中说。有人造地狱报业。现世轻受。答曰。若重恶业能现轻受。何故不能令都尽耶。若人不能具修真智。则恶业得便。故现在世少受果报。问曰。阿罗汉虽具修真智。亦受恶报。答曰。深修善法则障不善。是故若人于百千世集戒等善业。则不善业不能得起。犹如诸佛一切智人。余人不能如是。故为不善业所得便。故阿罗汉虽具修真智。以宿业故亦受恶报。问曰。经中亦说佛受谤等不善业报。答曰。佛一切智人无恶业报。以断一切不善法根本故。但以无量神通方便现为佛事不可思议。如增一阿含中说有五事不可思议。业有二种。定报不定报。定报业者。若多若少必当受报。不定业者可令都尽。问曰。云何名定报业。何等是不定报业。答曰。经中说五逆罪是定报业。问曰。但五逆罪是定报业。更有余耶。答曰。余业中亦有定报分。但不可得示。或以事重故有定报。如于佛及佛弟子。若供养若轻毁。或以心重故有定报。如人以深厚缠杀害虫蚁。重于杀人。如是等余业亦有定报。问曰。若五逆罪可令薄者。何故不能使都尽耶。答曰。此罪法尔。不可都尽。如须陀洹虽至懈怠不到八生。又五逆罪以坚重故不可都尽。如王法中有重罪者。可得令轻不可全舍

    轻重罪品第九十八

问曰。经中说有轻重罪业。何谓轻重。答曰。若业能得阿鼻地狱报是名重罪。问曰。何等业能得此报。答曰。若业破僧必受此报。所以者何。别离三宝令僧宝离佛宝亦碍法宝。又生上邪见故能起是业。亦深嫉恚佛故起此业。亦久集恶性深贪利养故故起此业。又此人说非法是法时。障多众生行诸善法。故名重罪。问曰。但破僧罪得阿鼻地狱报。更有余耶。答曰。余业亦有。若言无罪无福供养父母及诸善人无有果报。是等邪见亦得此报。又使他人堕此邪见。令多众生造诸恶故。亦受此报。又能作如是邪见经书。如富兰那等诸邪见师害正见故。开多众生为恶因缘。又谤贤圣罪亦得此报。如说八万四千岁一胁受苦。又如法句中说。圣人以法寿。以此法教化。钝根依恶见违逆如是语。如刺竹结实则自害其形。是人堕地狱。首下足在上。以恶心恶口。诽谤贤圣者。是人堕十万尼罗浮地狱。三十六及五阿浮陀地狱。又杀生等若事重心重。是罪亦堕阿鼻地狱。与重相违。是名为轻。于炙大炙等诸浅地狱畜生饿鬼。及人天中受不善报。是名轻罪

    大小利业品第九十九

问曰。经中说有大小利业。何者为大利业。答曰。随以何业能致阿耨多罗三藐三菩提。是名最大利报业。次业能得辟支佛道。次业得声闻道。次业得有顶报寿八万大劫。是生死中最大业报。次业得无所有处寿六万劫。如是次第乃至梵世寿命半劫。次欲界他化自在天受天数万六千岁。乃至四天王受天数五百岁。如是人中四天下各随业受报。如是畜生饿鬼地狱。亦有小利业。问曰。何等业能得阿耨多罗三藐三菩提等。答曰。檀等六波罗蜜具足。能得阿耨多罗三藐三菩提。从此善业次第转薄。得辟支佛菩提。转薄得声闻菩提。若行增上四无量心。得生有顶。行四无量次第转薄次生下地。行四无量心小转薄。及随定戒因缘故生色界。以布施持戒修善因缘故生欲界。是施等业随福田厚薄故有差别。若于诸佛福田中行。是则最胜。次于辟支佛等福田中行。次第转少。问曰。为智福田胜。断福田胜。答曰。若智能达法相。谓必竟空此则为胜。所以者何。如佛以智故于弟子中胜。不以断故。如杂藏中说。若扫僧房地如一阎浮提。不如扫佛塔犹如一掌处。有一切智慧皆为断故。若诸菩萨久处生死。皆为善断。善断者。谓自断结亦断众生。是诸结皆以智渐断。故知智慧福田于断为胜。问曰。若利根须陀洹钝根斯陀含。是二福田何者为胜。答曰。利根者胜。非钝根也。问曰。此语不然。如经中说。供养百须陀洹。不如供养一斯陀含。又说。稊稗害禾贪欲秽心。是故施无欲人应得福多。斯陀含能薄三毒。须陀洹未。何故言胜。答曰。是经名不了义。何以知之。即此经中说。施畜生得百倍利。而实施鵽鸟等所得果报。胜施外道五神通人。是故此经应辩其义。此经从多故说。除利智慧。人须陀洹以智力故。虽受诸欲亦名福田。非断欲凡夫乃至能得有顶定者。有多闻智在达分中尚胜。非有顶定不通达分。又弥勒菩萨虽未得佛。为阿罗汉之所礼敬。又但能空发菩提心者。以为罗汉所敬。如一沙弥担持衣钵逐阿罗汉行。是沙弥发无上心。阿罗汉即取衣钵自担随其后行。如喻中广说。故知智慧福田为胜

    三业品第一百

问曰。经中说三业。善不善无记业。何等是善业。答曰。随以何业能与他好事是业名善。是善业从布施持戒慈等法生。非洗浴等。问曰。何名为好。答曰。令他得乐是名为好。亦名为善。亦名为福。问曰。若令他得乐名为福者。令他得苦应当有罪。如良医针灸令他生苦。是应得罪。答曰。良医针灸为与乐故不得罪也。问曰。若为与乐便得福者。如淫他妻令其生乐。亦应得福。答曰。淫欲名决定不善。若人令他行不善法。是则为苦非为乐也。乐名今乐后乐。非现在少乐。以此因缘后得大苦。问曰。有人饮食因缘生他人乐。或饮食不消令人至死。是施食人应得罪得福。答曰。是人好心施食无恶心。故但得福德不得罪也。问曰。淫他妻者亦复如是。但为乐故亦应得罪得福。答曰。此事先答。谓淫欲是决定不善生大苦故。又布施饮食中有福德分。所以者何。得饮食者。不必尽死。众生皆贪染心故而受淫欲。全非福因。云何得福。问曰。有人以杀生故利益多人。如人破贼则国无患。若杀毒兽则利人民。是等可以杀生而得福乎。或有人。劫盗因缘供养父母。淫欲因缘生好儿息。妄语因缘或与寿命。以恶口等令他得利。是皆十恶所摄。云何以此而得福乎。答曰。是人得福得罪。为利他故得福。以损他故得罪。问曰。是医亦初与他苦。后令得乐。何故不得罪得福而但得福耶。答曰。是医以善心针炙无有恶意。若业为善恶故起则罪福并得。问曰。杀等皆是得福。所以者何。以杀因缘得所欲事。如为王杀贼得富贵。以福因缘得随所欲。云何杀生不名为福。又人能杀则得名闻。名闻是人之所乐。人之所乐是福德果。又以杀故得喜乐。喜乐亦是福德果报。又经书说若逆阵死得生天上。如偈说若人战阵死天女诤为夫。又说虽善富贵人为贼而迳前能杀则无罪。不杀则得罪。又世法经说。有四品人婆罗门刹利毗舍首陀罗。是四品人各自有法。婆罗门有六法。刹利四法。毗舍三法。首陀罗一法。六法者。一自作天祠。二作天祠师。三自读违驮。四亦教他人。五布施。六受施。四法者。一自作天祠不作师。二从他受违驮不教他。三布施不受施。四守护人民。三法者。作天祠不作师。自读违驮不教他。自布施不受施。一法者。谓供给上三品人。若刹利为守护人民故。夺他命有福无罪。又违驮经说。杀生得福。所谓以违驮语咒杀羊。羊死生天。违驮经是世间所信。又说若实应死者杀之则无罪。如五通仙能咒杀人。不可言神仙有罪。罪人云何能成此事。故知杀生得福。又或有心力能夺命得福。施命得罪。若人以善心杀生欲令得乐。云何有罪。如屠儿等畜养牛羊。虽施而罪。如盗等事中亦有福德。答曰。汝言杀生得所欲故名福德者是事不然。所以者何。由福德故得随所欲。是所欲事缘杀生得。所以然者。以先世造不净福故。如经中说劫夺杀害得财用施。令他悲泣及不净施如是等施名曰不净。要由恶缘而得受报。又此人先世有福。亦有杀生业缘。是故今身因杀受报。亦有众生应偿财命。故由杀害得随所欲。又非一切众生皆以杀生而得富贵。如世间言是人薄福多作无获。名闻喜乐亦如是。皆以福德因缘故得名闻身力及乐。但是福不净故由杀而得。问曰。师子虎狼等所得身力皆从罪生。夜叉罗刹等得身力乐亦从罪生。答曰。是事先答。亦由不净福故以罪缘得。汝言经书中说若逆阵死得生天上。是事不然。所以者何。是经以此邪语诱导愚人令其有勇。何以知之。要由福生福由罪生罪。是中都无福因。何由得福。汝言四品众生各自有法。刹利为护人故杀无罪者。此如家法如屠儿等世世家法常应杀生亦不免罪。刹利亦尔。虽是王法亦故得罪。若刹利以王法故杀生无罪。则屠猎等亦应无罪。但刹利以怜愍心为民除患由此得福。若夺他命此则有罪。如人劫夺他财以养父母。是人则罪福并得。问曰。是人劫盗以养父母不应得罪。如世法经说。若乏食七日从首陀罗夺取无罪。若命欲断得从婆罗门取。是人虽以恶业活命不名为破戒人。以急难故。犹如虚空尘垢不污。是人亦尔罪所不染。答曰。即梵志法中说。若劫夺时财主来护。梵志尔时应当筹量。若使财主功德不如则应杀之。所以者何。我是胜人能以种种悔法除灭此罪。若功德与等自杀杀他其罪亦等。以此罪重难除灭故。若财主德胜应自舍身以此中罪不可除故。如是分别劫夺杀中亦应如是。有言以恶业活命。是中有恶业故云何名福。汝言若人迳前杀则无罪不杀得罪。是言已坏。所以者何。若前人德胜自应舍身。若无罪者何故尔耶。汝言违驮经说杀生得福。是语先答。谓杀无福汝言人实应死杀无罪者则杀怨贼亦应无罪。有一切众生皆是罪人。以起作业受阴身故。然则杀生无罪者是事不可。问曰。若众生先世自造杀缘。今杀何故得罪。劫盗等业亦皆如是。答曰。若尔则无罪福。所以者何。是人前世造杀缘故杀之无罪故。离此杀生亦无福德。如是若施他人亦应无福。以受者先世自行施业。今自得报而实不可。无罪福故。当知众生虽自造杀业。杀者亦皆得罪。以起贪恚痴诸烦恼故。此诸烦恼名邪颠倒。邪倒心生尚应得罪。况当故起身口业乎。故令生死无穷。若不尔者。则诸神仙起贪恚等诸烦恼时。不应便失神通。若此非罪复与何法相违。故名福德。当知众生虽复先世自造杀缘。杀者亦应有罪。汝虽言罪人无所能成。是事不然。栴陀罗等亦能以咒术杀人。仙人亦尔。以恶心故。随语能成。又此人福力故能成。以夺命故得罪。汝言或有心力从夺命生福施命得罪。是事不然。所以者何。要由心力及福因缘故。能得福非但由心。若以善心淫于师妻杀婆罗门可得福耶。安息等边地人。以福德心淫母姊等复有福耶。故知从福因缘有福德生非但心也。劫盗等亦如是。故知杀等皆是不善。有此杀等非为利他故名不善。虽于现世少时得乐后受大苦。以损他故名不善相。又现见多有众生行杀等法。亦多在三涂及人道中受诸苦恼。当知苦恼是杀等果。果似因故。又三恶道中罪苦尤剧。故知以杀等因缘生于此中。问曰。天人中亦如是。诸天亦常与阿修罗战共相杀害。人中亦以坑陷纲毒。杀害众生。答曰。人天中有离杀等法。三恶道无。当知此中罪苦尤甚。又人杀等因缘则失寿等利乐。上古时人有无量寿命。光从身出。明如日月飞行自在。地皆自然生随意物自然粳米。皆以杀等罪故失如是事。后转更失至十岁人时。酥油石蜜稻粟麦等一切皆无。故知杀等是不善业。又若离杀等还得利乐。寿命增长如寿年八万诸欲随意。故知杀名不善。又今郁单曰土有自然粳米。衣从树生。皆由离杀等故。取要言之。众生所有一切乐具。皆从离杀等生。故知杀等是不善业也。又杀等法善人所舍。若诸佛菩萨缘觉声闻及余功德人。皆亦舍离故知不善。问曰。是杀生等善人亦听。违驮经中为天祠故听令杀羊。答曰。此非善人。善人者常求利他。修慈悲心怨亲同等。如是人者。岂当听杀生也。是人贪恚浊心故造此经。求生天上。咒他众生以福力故能成是事。又此杀等得解脱者之所不为。故知不善。问曰。得解脱者亦不作余事。谓过中食等是事亦可是不善耶。答曰。是罪因缘故善人亦舍。若法无过不应舍离过中食等能害梵行。是故亦舍。有法以体性不善故舍。如杀盗等。有法为不善因缘故亦舍。如饮酒过中食等故知杀生体性不善。又杀生者多人憎恶如师子虎狼及诸怨贼旃陀罗等。若以此法因缘人所憎恶。岂非不善。又若不杀者为多人所爱。如行慈悲诸贤圣人。故知杀为不善。问曰。有杀生者。以勇健故为人所爱。如人为王杀诸怨贼则为王所爱。答曰。以因缘故非深爱也。如说若人以恶业令主心欢喜。主若生厌心反还疑此人。若以恶事生疑云何名爱。又行不善者。尚不自爱况他人乎。故知杀生是不善法。又杀等法是打害系缚等诸苦恼因。故知不善。问曰。不杀等法亦有苦因。如王敕人令杀怨贼。若不杀者王必害之。答曰。若以不杀便被害者。诸不杀者皆当应死。是人自以违王教故。若知此人深心不杀。则不加害反应供养。故知杀等。是苦因缘。非不杀等。又行杀者死时生悔。故知不善。又行杀等故人所不信。于同类中尚不相信。何况善人。有行杀等者尚为同类所讥。况余人乎。有行杀等者。善人舍远如旃陀罗屠猎师等。有行杀等者不名乐人。如屠猎者终不以此业而得尊贵。又善人为功舍离杀等。若非不善。何故为功勤求舍离。又现见杀等有不爱果。当知来世亦得苦报。又若杀等非不善者。更有何法名不善耶。问曰。若杀等法是不善者。则无好身。所以者何。无有不杀生时。若来若去举足下足时。恒常伤杀细微众生。亦常以我相而取他物。亦随自想而为妄语。是故终无好身。答曰。故作则罪非不故也。如经中说实有众生于中生众生想。有欲杀心杀已得杀罪。盗等亦尔。问曰。如人食毒故与不故俱能杀人。有如蹈火知与不知俱能烧人。刺等亦尔。当知杀生故与不故俱应得罪。答曰。此喻不然毒以害身故死。罪福在心何得为喻。又火刺等若不觉不能生苦。是故此喻不然。若无识则不觉痛。有识则觉。如是若无故心。作业不成。有心则成此喻应尔。有故则有罪不故则无。诸业皆以心差别。故有上有下。若无故心。云何当有上下。如医与非医俱生人苦。以心力故罪福差别。又如儿捉母乳则不得罪。以无染心故。若染心捉则便有罪。当知罪福皆由心生。又若不故心而有罪者。得解脱人亦有不故而恼众生。是应得罪则无有解脱。以诸罪人无解脱故。又若不故而有罪福。则一业便应是善不善。如人为福业时。误杀众生此业则名亦罪亦福。是事不然。当知不故不应有罪有福。又若无心而有业者。云何分别此善此不善此无记耶。皆以心故有是差别。如有三人俱行绕塔。一为念佛功德。二为盗窃。三为清凉。虽身业是同而有善不善无记差别。当知在心。有业定报有不定报。有上中下有现报生报后报等。若不由心而得罪福。云何当有如是差别。又若离心有业则非众生数。亦应有罪福。如风颓山恼害众生风应有罪。若吹香花来堕塔寺便应得福。是则不可。故知离心无罪福也。有外道说。行断食法卧于灰土刺蕀等上。投渊赴火自坠高崖等。以苦因缘而有福德。智者难言。若尔则地狱众生常被烧炙。饿鬼饥渴飞蛾投火。鱼鳌处水。猪羊犬等常卧粪土。是等亦应得福。是人答言。要以故心受此苦恼则有福德。非不故也。地狱等不以福心受烧等苦。若不以故心故无福者。亦以无故心是故无罪。若以不故心而有福者。地狱等中亦应有福。有如是过。又若不故心而有罪福则无善人。所以者何。于四威仪中常杀众生。此事不可。当知不故则无罪福。又无得好生处常为罪故。而实有梵王等诸妙好身。故知不故无罪福业。又汝等法中食不净食则皆有罪。若深思惟一切饮食皆是不净食。不净食皆应得罪。如是触酒等则非婆罗门。若不见闻以净心食便无罪者。当知离心则无罪福。又于天祠中以福心故杀羊。令羊生天。以福心杀故则有福德。若不尔者。一切杀生皆得福得罪。又婆罗门言。或有劫盗无罪。如乏食七日得从首陀罗取。若命欲断得从婆罗门取之。亦为生好儿故淫欲无罪。若不以故心则不应有此等差别。故知若人不故与他人毒何由得罪。若故与他毒毒反消病。则应得福。如施人食是食不消。令人死者是应得罪。若不故而有罪福是法则乱。又世间人一切事中皆信于心。如即一言能生喜怒。椎打等亦如是。故知诸业皆由于心。又意业最胜后品当说。故知诸业在心又若智慧人虽处五欲而不得罪。皆是意力。所以者何。智者见色不起妄想故无著色之过。声等亦尔。若不起妄想而有罪者。一切见闻尽应有罪。然则意业无用。智者以智慧为首。虽受五欲不生贪着。五欲虽在以心厌故而能不染。是非意业力耶。是故无有不故而得罪福。问曰。汝说善不善相。谓损益他。是事不然。所以者何。若人自将养身而行福业。是人自食亦有福德。又塔寺非众生洒扫亦得福。又礼敬等于他无益。但损他功德不应有福。又非但发心故有福德。随以衣食利益他人。尔时得福。如是行慈悲者不应有福。又若塔寺等非众生数。若夺财物若加毁坏不应有罪。又不现前恶口骂他。不应有罪。以不闻故何所损减。又于他人但生恶心不起身口。复何所损。此皆不应得罪。又或自骂或自杀身。或自邪行亦或得罪。是故善不善相非但由损益他。答曰。汝言自将养身有福德者。是事不然。若自供养有福德者。则无有人应供养他而实求福德者。供养他人。又随自为己其福转薄。故知自为不应有福。又汝言自食为行福业。若自养身为饶益他。从是心边能生福德。不由自养而得福也。汝言塔寺非众生洒扫亦得福者。是人念佛功德。于众生中尊。是故洒扫。此事亦由众生故得福耳。问曰。已灭度佛不名众生。又经中说佛非有非无亦非有无亦非非有非非无。云何名众生耶。答曰。若以灭度不名众生。是人念佛未灭度时而为供养者。是故得福。如人祭祠父母念生存时。若不尔者不名供养父母。此事亦尔。汝言礼敬等于他无益。是事不然。所以者何。以礼敬等种种利他。令他尊贵人所恭敬。是名利益。亦令他人随学恭敬亦得福德。又礼敬他时自破憍慢。以破不善分故多所利益。亦以显他功德礼敬等有如是利。又汝言礼敬等损他功德。是事不然。以好心礼敬非如外道为损他故而行礼敬。又如布施若他不消亦损他功德。然则布施亦不应有福故。礼敬等应深思惟有益则行。如经说。有一比丘于浴室中手摩他身。佛语诸比丘。此供养者是阿罗汉。受供养者是破戒人。汝等当学。无以师子供养狐等。汝言不但发心故得福者。心是一切功德之本。若人利他己利今利当利。皆以善心为本。若人损他己损今损当损。皆以不善心为本。又行慈者以慈心果报饶益一切。谓风雨随时。日月星宿不失常度。大海不溢大火不烧大风不坏。此皆慈果报力。如经中说若一切世间皆行慈心。则所欲自然。汝言劫夺塔寺不应罪者。是人以众生心而劫夺之。随是何塔为劫夺此。以是因缘故若能为损。若不能为损。皆为主故得罪。若汝心谓于佛不能生恼故无罪者。以恶口等加阿罗汉。不能生苦亦应无罪。汝言不现前骂应无罪者。是事不然。是人以恶心加彼。以恶心故彼虽不闻。若闻必当生苦。是以得罪。汝言若生恶心不起身口不应有罪者。是亦不然。是浊恶心为恼他故生。若他觉知必生苦恼。如贼来夺人物。虽不觉知亦为恼人故。汝言自杀自骂亦得罪者。是事不然。若自苦身而得罪者。则无有人得生好处。所以者何。人于四威仪中常苦其身。然则一切常应得罪如恼他人。是故无有得生好处。此事不然。当知不从自身有罪福也。为道因缘故。比尼中结此戒。若人恶心自杀以烦恼故得罪。无记业者。若业非善不善。于他众生无益无损。是名无记。问曰。何故名无记。答曰。此是业名字。若业非善非不善者。名曰无记。又善不善业皆能得报。此业不能生报故名无记。所以者何。善不善业坚强。是业力劣弱。譬如败种不能生牙。又报有二种。善得爱报不善得不爱报无记无报。问曰。有此中取非爱非憎。是无记报有何咎。答曰。佛说报有二种。邪身行得不爱报。正身行得爱报不说有中。有福德果报得爱念如意。罪则与此相违。又苦乐是罪福报。不苦不乐亦是善行果报。故知无记无报

    邪行品第一百一

佛说三邪行。身邪行口邪行意邪行。身所造恶名身邪行。是邪行有二种。一十不善道所摄。如杀盗邪淫。二不摄。如鞭杖系缚自淫妻等及不善道前后恶业。问曰。是杀生等三不善业。但是身业性耶。答曰。杀罪名杀不善业。是罪身亦可造。随以自身杀害众生。口亦可造。随教敕人令杀众生。或以咒杀心亦可造。有人发心能令他死。盗淫罪亦如是。但自作得具足罪。又身不善业或以身为相。或口为相。或发心他则知。以此因缘亦得造杀等罪。但以多是身所作故。通名身业。口邪行亦如是。口所造恶业名口邪行。是中亦有二种。若人决定问时现前诳他。是不善道所摄。余名不摄。贪恚邪见等是意邪行。问曰。何故十不善道中说邪见。三不善根中说痴耶。答曰。邪见是痴之异名。是痴增长坚固名为邪见。痴更无别相。但以颠倒贪着故名为痴。问曰。经中说。诸邪行得不爱报。正行得爱报。是爱不爱相不决定。如即一色而有爱不爱。是故应辩其相。答曰。乐是爱相。如经中说福报名乐。苦是不爱相。如经中说汝等于罪应生怖畏以是苦因缘故。问曰。若乐是爱相者。猪犬等以食粪为乐。是福德果耶。答曰。是不净福果。如业经说。若非时施不净施轻心浊心非福田中。如是等施得此果报。问曰。若经中说正行得爱报。何故复说以正行因缘得生天上。答曰。有邪行者亦生天上。或谓生天是邪行报。故经中更说正行因缘生于是中。又邪行正行能得善恶道身。受身已于中受苦乐如邪行因缘恶道中受苦。正行因缘天人中受乐

    正行品第一百二

身所作善名身正行。口意亦尔。离杀生等三不善业名身正行。离口四过名口正行。离意三不善名意正行。是离三种律仪所摄。所谓戒定无漏律仪。又所有礼敬布施等。善身业皆名身正行。所谓实语软语等皆名口正行。不贪等意业皆名意正行。是名三正行。问曰。外道神仙无报得解脱戒。是人能得戒律仪不。答曰。是诸外道从心生律仪戒。或亦口受。又诸余人等亦能得戒律仪所摄正行。如寿十岁人受不杀法故生子寿二十岁。问曰。经中说正行净行寂灭行。有何差别。答曰。又论师言。凡夫善身口意业名为正行。学人已断结故。即此正行名为净行。无学人断结。从无结生语故名寂灭行。又无学人必竟不起不善业。故名寂灭行。如说身寂灭口寂灭意寂灭。有人言。此三种行义一而异名。但美其质直故称正。离诸烦恼故曰净。离诸不善故名寂灭。故虽三名其义不异。问曰。有论师言。但心是寂灭行。非思是义云何。答曰。是三种行皆但是心。所以者何。离心无思无身口业。问曰。经中说。见正行成就人则为见天。若见天数非一切正行者皆生天上。何故如是决定说耶。答曰。言天数故。是事已明。正行者虽不必生天若生尊贵处。则与天相似故言见天数。诸正行者皆应生天。或以余缘所坏是故不生。所谓邪正杂行邪行强故不得生天。如经中佛语阿难。我见有人行三正行而生恶道。是人先世邪行果熟。今虽正行未具足故。又临命终时起邪见心。故堕恶道。邪行生善处亦如是。故凡夫法不可信也。当知随强力业受生差别

    系业品第一百三

问曰。经说有三种业。欲界系业色界系业无色界系业。何者是耶。答曰。若业从地狱至他化自在天。于中受报名欲界系业。从梵世至阿迦尼吒天受报名色界系业。从虚空处至非有想非无想处受报名无色界系业。问曰。无记业及不定报业。不在此三种中耶。答曰。是业及果报皆名欲界系。所以者何。此法是欲界业果报故。问曰。欲界法非一切尽是业报。是故不然。答曰。一切欲界法尽是欲界系业报。问曰。若尔则是外道邪论。谓一切所受苦乐皆是先业因缘。又失业果报。谓善不善业有报非报。又精进之功则无所用。若皆是业报复何劳功耶。及若诸烦恼及业皆是业报。则无得解脱。以业报不可尽故。答曰。汝言是外道邪论。是事不然。外道说苦乐好丑但是先业果报。然则不应复假现在因缘。而实见万物从现在缘生如种子等。故不得言一切皆从先业因缘。又从因从缘万物得生。如以种为因。地水空时等为缘。眼识以业为因眼色等为缘。是故不同外道邪论。汝言先业果报是事不然。现见从果。有异果相续生。如从谷生谷。如是从报生报有何咎耶。又如不能男人及鸟雀鸳鸯等欲毒蛇等嗔。当知皆是先业果报。问曰。若从报生报是则无穷。答曰。我说业报三种。善不善无记。从善不善生报。无记不生故非无穷。如从谷生谷于是中从种子生牙。不从[麥*弋]等生。如是从善不善报有异报生。不从无记报生。汝言不劳功者。虽从业生报要须加功然后得成。如从得谷业有谷生。然要须种等尔乃得成。汝言无得解脱。是事不然。得真智故诸业灭尽犹如种燋不能复生。故无解脱过。又诸所生法皆以业为本。若无业本。云何能生。又万法之生各有定分。如此法必从是人身生。不在余身。若无业本。云何如是决定差别。问曰。若法但从因生。如从豆生豆有何咎耶。答曰。是事亦以业为本。以得豆业因缘故从豆生豆。何以知之。上古时人行善行故粳米自生。故知业为本故从豆生豆。问曰。是众生数物则从先业生。答曰。不然。非众生数物亦以业为本。一切众生有共业报果。谓得住处以业因缘故。有地等以得明业因缘故有日月等。当知物生皆以业为本。问曰。若生法皆以业为本。有为无漏云何答曰。亦以业为本。所以者何。皆是先世有布施持戒等力之所由。是故亦从业等生。问曰。若无漏法亦从业生。是亦名系法。是则不可。以经中说有不系受故。答曰。无漏法以真智为因。以业为缘因力大故名为不系。问曰。何业受欲界报。何业受色界报无色界报。答曰。若在欲色无色界起十不善业。则于欲界受报。问曰。若在色无色界。亦能起不善业耶。答曰。彼中能起不善业。经说彼中有邪见。邪见非不善乎。问曰。彼中邪见是无记非不善也。答曰。非无记。何以知之。佛经中说。邪见是苦恼因。邪见人所起身口意业。有所造作皆为苦报。犹如苦瓠。所有四大尽为苦味。如欲界邪见不善。色界无色界亦以此相故名不善。以相同故。如婆伽梵志语诸梵言。汝等勿诣瞿昙沙门。我于此间能度脱汝。是心口不善在色界起。又余梵天于彼难佛。如是等。又人在色无色界。谓是泥洹。临命尽时见欲色中阴即生邪见。谓无泥洹谤无上法故。云何非不善耶。以此等故当知彼中有不善业。问曰。若于彼中起不善业。是业为何处系。答曰。是不善业受欲界报故。系在欲界。善业有上中下。下者受欲界报中者色界报上者无色界报。又有人言。四禅所摄善业受色界报四无色定所摄受无色界报。余散心起业受欲界报。问曰。云何彼中起善业欲界受果报。答曰。如此间摄心起善业彼间受报。如是彼中散心起善业此间受报。又如色无色界起不善业欲界中受报。彼中善业亦如是。问曰。若在色无色界。不能起欲界系善业。答曰。是中无此因缘。若在欲界能起色无色善业。在色无色界不能起欲界善业耶。又汝等说在色界中能生欲界无记心。若能生无记心何故不能生善心耶。又经中佛语手天子。当念住心受粗相。粗相即是欲界系心。是人随以善心听法礼佛。皆是欲界系心。若不尔者不名粗相。又是中求念财福。如说世尊我于三事无厌足故。此间命终生无热天。谓见佛听法供养僧。求念财福是欲界系心。又此中有念佛等非财福故。当知有欲界系善

成实论卷第七成实论卷第八

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    三报业品第一百四

问曰。经中佛说三种业。现报生报后报业。何者是耶。答曰。若此身造业即此身受。是名现报。此世造业次来世受。是名生报。此世造业过次世受。是名后报。以过次世故名为后。问曰。中阴报业在何处受。答曰。二处受。次第中阴业在生报处受。以生有差别名中阴故余中阴业。在后报处受。问曰。是三种业为报定耶。世定耶。答曰。有人言报定。现报业必现受报。余二亦尔。虽有此言。是义不然。所以者何。若尔者。非但五逆名为定报。而六足阿毗昙说五逆是定报。又盐两经中亦说不定。有业应受地狱果报。是人修身戒心慧故能现受报。是故此三种业应当世定。现报业不必现受。若受则应现受非余处。余二亦如是。问曰。何等业能受现报。答曰。有人言。利疾业受现报。如于佛诸圣人及父母等起善恶业。是则现报。若业不利而重。是则生报。如五逆等亦利亦重则受后报。如转轮王业若菩萨业。又有人言。是三种业随愿得报。若业愿今世受。是即现受。如末利夫人以自食分施佛。愿现世为王夫人。余二业亦如是。又随业熟则先受。问曰。过去业云何名熟。答曰。具足重相是名为熟。问曰。颇有一念起业次念受报耶。答曰无也。渐次当受。如种渐次生牙。业法如是。问曰。若处胎中及睡眠狂乱等人能集业不。答曰。此等有思则能集业。但不具足。问曰。若离此地欲能起此地业不。答曰。有我心人皆集此业。若离我心则不复集。问曰。阿罗汉亦礼敬修福等。此业何故不集耶。答曰。以众生心故诸业则集。阿罗汉无我心故。诸业不集。又阿罗汉心无漏。无漏心者不集诸业。又经中说。断罪福业名阿罗汉。是人不集罪业福业及不动业。故业受毕新业不造。问曰。学人集诸业不。答曰。亦不集也。所以者何。经说。是人散坏诸业不积不集灭不然等。有论师言。是学人有我慢故诸业亦集。但以无我智力不必受报。问曰。是三种业于何界可造。答曰。三界中一切处可造。问曰。不定业有耶无耶。答曰有。若业或现报或生报或后报。是名不定。如是业多。问曰。若知此三种业得何利耶。答曰。若能分别是三种业则生正见。所以者何。现见有恶行者而受富乐善者受苦。于中或生邪见。谓善恶无报。若知此三业差别则得正见。如说偈。行恶见乐为恶未熟。至其恶熟自见受苦。行善见苦为善未熟。至其善熟自见受乐。又分别大业经说。不断杀者得生天上。是人若先世有福若将命终时发强善心。能如是知则生正见。是故应知此三种业相

    三受报业品第一百五

问曰。经中佛说三种业。乐报苦报不苦不乐报业。何者是耶。答曰。善业得乐报。不善业得苦报。不动业得不苦不乐报。此业不必定受。若受则受乐报非苦等。余二亦尔。问曰。是诸业亦得色报。何故但说受耶。答曰。于诸报中受为最胜。受是实报色等为具。又于缘中说受。如说火苦火乐。或有因中说果。如人施食名施五利。亦如言食钱等。问曰。从欲界至三禅中。得受不苦不乐报耶。答曰得受。问曰。是何业报。答曰。是下善业报。上善业则受乐报。问曰。若尔何故第四禅及无色定中说耶。答曰。彼是自地。所以者何。彼中但有是报更无异受。以寂灭故。问曰。有人言。忧非业报。是事云何。答曰。何故无耶。问曰。忧但从想分别生。业报不应是想分别故。又若忧是业报业报则轻。故非报也。又此忧离欲时断。业报不尔。离欲时不断。是故忧非业报。答曰。汝言忧从想分别生故非报者。乐亦是业报是乐二种。一乐二喜。喜亦从想分别生不应名报。汝言业报则轻。是忧重过于苦。所以者何。忧是愚人。所有智者则无。是故难除。亦能深生热恼。又四百观中说。小人身苦君子心忧。又此忧要以智断。身苦乐亦能除。又忧能生三世中恼。所谓我先有苦今苦当苦。又忧是诸烦恼住处。如经中为烦恼处。故说十八意行。以五识中不生烦恼故。又经中说。以忧为二箭。以受苦重故。如人一处重被二箭。则受苦倍增。如是痴人为苦所逼。更增忧患以恼身心。故甚于苦也。又愚者常忧。所以者何。是人恩爱乖离怨憎合会。所求不得等故常忧。恼又此忧从二因生。一从喜生。二从忧生。若失所爱物是从喜生。如经中说。佛问波斯匿王。汝爱迦尸憍萨罗国耶。又说。诸天乐色贪色。是色若坏则生忧恼。是名从喜生。从忧生者从所憎事生。亦从嫉妒等生。未离欲者嫉妒等结常恼其心。如说天人多悭嫉结。又多众生忧恼他人。故得忧恼报。如说随种生果。故知忧是业报。汝言离欲时断故非报者。是事不然。须陀洹未离欲亦断地狱等报。可以地狱等报为非报耶。故不可以离欲时断便名非报。问曰。不苦不乐报业名不动。此业是善应受乐报。何故受不苦不乐报耶。答曰。是受不动故实乐。以寂灭故名不苦不乐。又经中说乐受中贪使。彼中贪于彼受中使故知是乐

    三障品第一百六

问曰。经中说三障。业障烦恼障报障。何者是耶。答曰。若诸业烦恼及报。能障解脱道故名曰障。问曰。何者能障。答曰。施戒修善回向三有。此能障道。又定受报业是亦为障。如经中说。若此人必定集受报业。则不入正位。是名业障。又若人烦恼厚利增上。常在心中。是烦恼障。又若人烦恼不可除遣。如不能男等欲亦名烦恼障。又若地狱等罪恶生处。及随所生处不能修道。皆名报障。问曰。有人不先明悉前人。不知其善则不布施。谓彼人若由我施得造诸恶。我则有分。如梵志等诸出家人。故出家人不应布施。以新业系障解脱故。答曰不然。他作罪福于我无分。所以者何。罪福因缘中有多过咎。何者如众生是杀因缘。若无众生何所杀耶。然则死者应当有罪。又如富者是盗因缘。美色是邪淫因缘。他人是妄语等因缘。伪称等是欺诳因缘。买者亦应有罪。又受者为施者因缘。亦应得福。若人造井池等用者皆应得福。然则不应自为福德。而实不然。是故因缘中不应有罪福。又受者福分应当消尽。则人不应从他受施。所以者何。以福德分贸饮食故。又施者应罪多而福少。所以者何。讵有几所婆罗门能为善者。多以三毒浊心深着五欲不勤修善。是故施者应罪多福少。又梵志等自称善人修行法者。是人不能正观诸法禅定摄心。若离禅定心难调伏。是故施者施未离欲人应得罪多。又人供养父母供给妻子亲属知识皆应得罪。则无有人得福分者。而实不然。是故罪福不在因缘中。又持戒等法亦利益他。是人不杀生故施一切命。则持戒者得大罪分。以不杀故前人得寿。所作众恶尽。应是持戒者分。故求福者便当杀生不应持戒。又人说法令他修福。修福因缘后得富贵。富贵则憍逸。憍逸则造诸恶。此诸恶说法者皆应有分。又施因缘令他人富。以富因缘所作诸罪亦应是施者分。然则梵志不应受施。亦不应与。而今梵志但受不与。故知此为邪道。又如诸王如法治民亦应有罪。又若子为罪而父母有分。则应不生子。又良医疗疾亦应得罪。以其得命为诸罪故。又天降时雨生长五谷。天应得罪。以多济育恶众生故。又施食者亦应得罪。受者或食不消乃令至死。亦未离欲人以着味故施者应罪。然则施者常应令受者自立誓言今食汝食要不为恶然后当与。若不如是则施者两失。问曰。经中亦言。若比丘食檀越食着檀越衣入无量定。以是因缘故此檀越得无量福。若以是因缘而得福者。云何不得罪耶。答曰。若是比丘食檀越食着檀越衣入无量定。檀越施福自得增长不得定福。如田良故所收必多薄则收少。如是福田良故施报则大。薄则福少。不以受者为福为罪而施者得分。是故不以罪福因缘而得罪福。彼虽为因缘而罪福。要由自起三业。问曰。未离欲人心不自在必贪著有。故出家人不应行施。答曰。若尔则出家人持戒等皆有福德。是亦应舍而实不可。是故布施亦不应舍。但勿回向三有当为泥洹。又但应远离烦恼诸不善业。所以者何。是诸业因时可防。果时无可如何。是故诸佛常于因时教化说法。不如阎王于果时方化诃责。问曰。是三业障中何障最重。答曰。有人言。报障最重。以不可化故。有人言。以随人故一切皆重。问曰。何者可转。答曰。皆可令灭。若可转者不名为障也

    四业品第一百七

问曰。经中佛说四种业。黑黑报业白白报业黑白黑白报业不黑不白无报业。为灭尽诸业故。何者是耶。答曰。黑黑报业者。随以何业生苦恼处。如阿鼻地狱及余苦恼无善报处。若畜生饿鬼少分。与此相违名第二业。随以何业生无苦恼处。如色无色界及欲界人天少分黑白杂名第三业。随以何业生苦恼不苦恼处。若地狱畜生饿鬼人天少分。第四业名无漏能尽三业。若业二世所呵今呵后呵。是人为罪堕在黑闇。无有名闻故名为黑。及二世苦毒今苦后苦。故名为黑。问曰。是业何者能生纯苦恼处。答曰。相次为恶心无有悔间无有善能消恶业。是名能生纯苦恼处。又以邪见心而造诸恶。又于重人为恶。所谓父母及余善人。又于众生为恶无所遗惜。如杀众生若尽夺财物。若闭牢狱而复断食。若重考掠令无余乐。如是等业生纯苦处。白白报业者。若人纯集诸善。无有不善。此二业势力最大余无能胜。若受黑业报时不容白报。受白业报时不容黑报。所以者何。一切众生皆集善不善。业力相障故不得并受。如负二人物强者先牵。第三业弱善不善杂故。并受报互相胜故。问曰。有人言。若不善业受恶道报是名初业。色界系善名第二业。欲界系天人中杂受报业。是名第三业。无碍道中十七学思是第四业。此义云何。答曰。佛自说此业等相。谓若人起罪身口意行。受苦恼身生苦恼处。所受诸受皆不随意。故知随令众生生纯苦处。是名初业。色无色。界则纯受乐。欲界天人亦有纯受乐者。如经说有乐人亦有六触入天所觉诸尘无不随意。是第二业。黑白杂行是第三业。一切无漏业皆是尽诸业以相违故。非但十七学思名第四业。问曰。无漏实白。何故名不白耶。答曰。此白相异不同第二业白。是白最胜无相待故。如说转轮圣王成就清净过人天眼。实是人眼胜余人故名曰过人。此业亦尔。胜余白业故说不白。又有人言。应说名非黑白报业。此则无过。又泥洹名非白。是故此业应名非白。又亦应说非黑非白。所以者何。泥洹名无法。此业为泥洹。故名不黑不白。又世间贵重有漏善业故名为白。以第四业能舍此业故名不白。又此业无黑相故亦无白相可得。又报白故业名白。是业无报故不名白

    五逆品第一百八

次身受报故名无间。若现受则轻苦恼报少。以其重故。次第疾堕阿鼻地狱。三逆由福田德重故名为逆。所谓破僧恶心出佛身血杀阿罗汉杀父母。以不识恩养故名为逆。此逆罪但人道中能起非余道中。以人有别知故。问曰。杀余圣人得逆罪不。答曰。杀圣人者多堕地狱。若杀阿罗汉必应当堕。若人打佛而血不出亦得重罪。以欲害世尊故。问曰。若人作一逆罪则堕地狱。若作二三亦于一身尽受报不。答曰。是罪多故又受重苦。于是中死还生是中。问曰。破僧罪中云何为重。答曰。若非法知非法。是法知是法。如是心作则名为重。若非法谓法。法谓非法。是不如先。又若人于佛所破僧自称大师天人中尊是亦为重。问曰。若凡夫可破非是圣人。何名重罪。答曰。障碍正法故名重罪。问曰。破僧法为几时。答曰。法不久住不经一宿。是中梵王等诸天。舍利弗等诸大弟子。即还和合。有人言。是五百比丘先世障他得道善根因缘。今得此报。又凡夫人心轻躁故易可破坏。若但得世间空无我心尚不可坏。况无漏耶。以恶欲在心故造破僧因缘。故求福者应舍恶欲

    五戒品第一百九

佛说优婆塞有五戒。问曰。有人言。具受则得戒律仪。是事云何。答曰。随受多少皆得律仪。但取要有五。问曰。离系缚等何故不名为戒。而但说不杀等耶。答曰。是眷属故。问曰。何故不说断淫。而但说不邪淫耶。答曰。白衣处俗难常离故。又自淫其妻不必堕诸恶趣。如须陀洹等亦行此法。是故不说全断淫欲。问曰。离两舌等何故不名为戒。答曰。是事细微难可守护。又两舌等是妄语分。若说妄语则已总说。问曰。饮酒是实罪耶。答曰非也。所以者何。饮酒不为恼众生故。但是罪因。若人饮酒则开不善门。是故若教人饮酒则得罪分。以能障定等诸善法故。如植众果必为墙障。如是四法是实罪。离为实福为守护故。结此酒戒

    六业品第一百一十

业有六种。地狱报业畜生报业饿鬼报业人报天报不定报业。问曰。何者是耶。答曰。地狱报业。如六足阿毗昙楼炭分中广说。又杀生等罪皆为地狱。如经中说喜杀生者生地狱中。若得为人则受短命。乃至邪见亦如是。问曰。已知十不善道受地狱报。亦生畜生饿鬼及人道中。而汝但说生地狱及人中。今当别说。何业但受地狱报耶。答曰。即此罪业最重者受地狱报。小轻则受畜生等报。又若具足三种邪行。则为地狱。余不具足业。为畜生等。又故作重罪则为地狱。又破戒破见人所造恶业则为地狱。又深心为恶心坏行坏。是人造恶则为地狱。又造不善业以不善助则为地狱。又若于贤圣造不善业则为地狱。又起不善业不善修集。如人起不善业后赞快乐不欲舍离则为地狱。又以憎恚心而造罪业则为地狱。若为财物则受余报。又以邪见心起不善业则为地狱。又破戒者所作罪业则为地狱。又无惭愧者所作罪业则为地狱。又恶性人所作罪业则为地狱。譬如湿地小雨成泥。又常行不善者所作恶业则为地狱。又若无急缘而造恶业则为地狱。又若人不得空无我分。深染着故。所造罪业则为地狱。又若人不修身戒心慧所造恶业则为地狱。又若凡夫人所作罪业则为地狱。所以者何。是人不知阴界诸入十二缘等。以不知故。不应作而作。应作而不作。不应语而语。应语而不语。不应念而念。应念而不念。是人所作罪业虽少亦为地狱。又若不见不善中过。是人则能起重罪业受地狱报。又若人为罪不依于善。则为地狱。如负债人不依恃王债主则得便。又若人善业劣弱所作少罪亦为地狱。如人身中火势微少。得难消食则不能消。又若人但行不善无善业杂则为地狱。如人为贼轻重悉系。又若舍离一切善根。如象战时不护惜手。是人作罪则为地狱。又若行小法受学小师。是人作罪则为地狱。如贫贱负债为富贵所牵。又若人常长不善如负债日息。犹如屠儿猎师等业则为地狱。又若覆藏罪则为地狱。如疮内漏。又若人不善久住心中。不能疾灭则为地狱。如被治毒即能杀人。又若人自作不善亦以教人。开多众生苦恼门故则为地狱。如诸国王及多知识人行恶邪行令多人学。如富兰那等。又若所作业多恼众生。如烧林等。又教他人令堕非法如田猎等。又若人以恶业活命。如贼魁脍屠猎师等。又毕竟破戒人所作罪业则为地狱。至死不舍故名毕竟。如偈说。毕竟破戒人。如藤鬘树枝。是人身造恶。自令怨得愿。又无事而忿。以此忿心而为罪业则为地狱。若有事而忿罪则不尔。又以嗔起业是结重故则为地狱。如经中说。嗔为重罪而易除灭。又若恶心成性则为地狱。若以因缘而起罪业是则轻微。又若纵逸人所造恶业则为地狱。若为知识所护则得生天上。如莎婆魁脍临命终时。舍利弗到其所。是人即以恶眼视舍利弗。不能令异呼小来前。更以气嘘之。见舍利弗光色益荣便生念言。此人胜我不可杀也。即以净心七反上下视舍利弗。以此因缘七生天上七生人中。后得辟支佛道。又如鸯掘魔罗多起罪业。将欲杀母。佛为善知识故即得解脱。又如施越以火坑毒饭欲中害佛。佛为善知识故亦得解脱。如是等人虽有恶业不堕地狱。故说若纵逸人所作恶业则为地狱。又若断善根不可复治。如调达等。犹如病人死相已现。是人作罪则为地狱。又若人不数为善。将命终时善心难生。是人心悔故堕地狱。又若临死时起邪见心。是人以先不善为因邪见为缘故堕地狱。如是多有诸业为地狱报。又论师言。一切不善皆是地狱因缘。是不善之余生畜生等中。如经中说。佛语比丘。汝等所见众生身邪行口邪行意邪行者。当知便为见地狱人。问曰。已知地狱报业畜生报业。何者是耶。答曰。若人杂善起不善业故堕畜生。又结使炽盛故堕畜生。如淫欲盛故生于雀鹆鸳鸯等中。嗔恚盛故生于蚖蛇蝮蝎等中。愚痴炽盛故生猪羊等中。憍逸盛故生于师子虎狼等中。掉戏盛故生猿猴等中。悭嫉盛故生狗等中。如是等余烦恼盛故生种种畜生中。若有少施分者。虽生畜生于中受乐。如金翅鸟龙象马等。又口业报多堕畜生。如人不知不信业果报故起种种口业。如言是人轻躁犹如猿猴。则生猿猴中。若言贪[女*戾]如鸟语如狗吠。騃如猪羊声如驴鸣行如骆驼自高如象。恶如逸牛淫如鸟雀。怯如猫狸谄如野干。便如羖羊多毛如牛。起如是等恶口业故。随业受报。又众生以贪乐故发种种愿。如乐淫欲则生鸟等中。若闻诸龙金翅鸟等有势力故愿生其中。又经中说。若于迮狭处死。愿得宽处则生鸟中。若渴死求水故生水中。饿死贪食故生厕等中。又从愚痴起轻微业。以杂善故生于蚤虱虫蚁等中。又若教他人令堕邪法。则生无智处。盲生盲死作死尸中虫。又行杂业故生畜生中。如经中说。诸畜生随种种心。得种种形。又若起应食草业如人妄语自咒誓言。若食此食令我食草。或言食土。如是等。又若人恶口骂言汝何不食草食土。是人随语受生食草土等。又人行不净施得草等报。又若人抵债不偿。堕牛羊獐鹿驴马等中偿其宿债。如是等业堕畜生中。问曰。已知畜生报业。以何业故堕饿鬼中。答曰。于饮食等生悭贪心。故堕饿鬼。问曰。若人自物不与。何故得罪。答曰。是悭人。若人从乞以贪惜故。则生忿怒。以此罪故生饿鬼中。又此悭人若人从乞有而言无。以妄语故堕饿鬼中。又此人久来修集悭结。见他得利生悭妒心故堕饿鬼。又此悭人见他行施则憎恚施主言。此乞者。以惯得故必当复来从我乞。又从久远来修集悭心。既自不施亦遮他与。又若共有物。如寺中僧物及天祠中诸婆罗门物。有人独惜不欲与人。故堕饿鬼。又若人劫夺坏他饮食故。生无饮食处。又若人无布施福。随所生处报无所得。兼有呵骂乞者业故。于中受苦。又此悭者见人饥渴无怜愍心。故所生处常受饥渴。如以慈悲得生天上。如是以恚恨故生恶道中。又深着亲属爱乐住处。故堕迦陵伽等饿鬼中生。以贪爱是生因缘故。如是等。如业报经中广说。问曰。已知三恶报业。以何业故生人天中。答曰。若布施持戒修善等业。上者生天中下者生人中。有利根者则生人中。以能行人法故名为人。又杂善业故生人中。此业有上中下。一心不一心净不净等。何以知之。以人有种种差品不同故。如经中说。杀生则短命。盗窃则贫穷。邪淫则家不贞良。妄语则常被诽谤。两舌则眷属不和。恶口则常闻恶声。绮语则人不信受。贪嫉则多淫欲。嗔恚则多恶性。邪见则多愚痴。憍慢则生下贱。自高则矬短。嫉妒则无威德。悭则贫寒。嗔则丑陋。恼他则多病。杂心布施则嗜不美味。非时布施则不得随意。疑悔则生边地。行不净施则从苦得报。非道行淫则得不男形。人中有如是等杂不善业。善业亦与此相违。如不杀得长寿等。人道中有如是等种种不同。故知是杂业报。又以愿故得生人中。有人不乐放逸亦不多欲。好乐智慧发人身愿。则生人中。又若人好乐供养父母及诸所尊。亦知供养沙门婆罗门等喜为事业。亦好修福则生人中。于人中若净业因缘生郁单越。又若人憎恶田宅舍庐我所差别。生郁单越。又若人正行白业不恼他。取财而以布施。亦不贪着。自持戒行。又不破戒。前后眷属。则生郁单越。是善小劣生拘耶尼。又小不如生弗于逮。天报业者是施戒善上净故生天。又若人得智慧分折伏诸结故生天上。又亦随杂业故有差别。如人中说。又以愿故若闻天上受乐因缘。所作善业皆愿往生。如八福生处中说。若行慈悲喜舍。则生梵世乃至有顶。是中禅定有差品故报亦差别。若不善断睡眠调戏等。是人身光则浊。若善除灭光则明净。又上善业报则生天。以诸所欲随念即得故。若离色相得无色定。则生无色处。如是等名天报业。不定报业者。下善不善业。是业或地狱饿鬼畜生人天中受。问曰。余四道中可得受善业报。地狱云何。答曰。若小地狱中暂有停息。如从火地狱得脱。遥见树林心喜往趣入此林中。凉风动树刀剑未堕。尔时暂乐。或见碱河谓是清水。驰走往趣亦得暂乐。如是等是地狱中善业报分。是名不定报业

    七不善律仪品第一百一十一

七不善律仪。谓杀盗邪淫两舌恶口妄言绮语。若人于此七事若具足若不具足。皆名不善律仪人。问曰。何者成就不善律仪。答曰。成就杀不善律仪。谓屠杀等。成就盗者谓劫贼等。成就邪淫谓非道行淫及淫女等。成就妄语谓歌舞伎儿等。成就两舌谓喜谗谤及读诵谗书遘合国事等。成就恶口谓狱卒等。亦以恶口自活命等。成就绮语谓合集言辞令人笑等。有人言。诸王宰将治王事者。常成就此不善律仪。是事不然。所以者何。若人作罪相续不息。是名成就不善律仪。王等不尔。问曰。云何得此不善律仪。答曰。随行恶业时得。问曰。为从所杀众生得此律仪。为从一切众生得耶。答曰。从一切众生得。如人持戒于一切众生得善律仪。不善律仪亦如是。若随杀众生得二种无作。一杀罪所摄。二不善律仪所摄。于余众生得不善律仪所摄。问曰。是不善律仪几时成就。答曰。乃至未得舍心则常成就。问曰。若人从下软心得不善律仪。若贪等心得。是人常如是成就为更得耶。答曰。随心随烦恼因缘。更得此不善律仪。念念常得于一切众生得起七种。是七种有上中下故有二十一种。如是念念常于一切众生边得。问曰。是不善律仪云何得舍。答曰。随受善律仪时舍。死时亦舍。又发深心从今日更不复作。尔时亦舍。有论师言。转根时舍。是事不然。所以者何。不能男等亦得成就。比尼中亦说。若比丘转根不失律仪。当知不以转根故舍。问曰。五道中何道众生成就不善律仪。答曰但人成就不在余道。有人言。师子虎狼等常以恶业活命亦应成就

    七善律仪品第一百一十二

七善律仪不杀乃至不绮语。问曰。于非众生数得是善律仪不。答曰得。但要因众生。是善律仪三种。戒律仪禅律仪定律仪。问曰。何故不说无漏律仪答曰。无漏律仪在后二中摄。故不别说。有论师言。更有断律仪。谓离欲界时得善律仪。以断破戒等恶故名曰断。而实一切律仪皆三中摄。问曰。诸外道等得此戒律仪耶。答曰得。此人亦以深心离诸恶故。戒师教言。汝从今日不应起杀等罪。问曰。余道众生得此戒律仪不。答曰。经中说。诸龙等亦能受一日戒。故知应有。问曰。有人言。不能男等无戒律仪。是事云何。答曰。是戒律仪从心边生。不能男等亦有善心。何故不得。问曰。何故不听作比丘耶。答曰。是人结使深厚难得道故。又此人不在比丘中。亦不在比丘尼中。是故不听。又彼中亦遮余人。如睐眼等。是人亦得此善律仪。问曰。比尼中遮逆罪者贼住者污比丘尼等。不听作比丘。是诸人等亦有善律仪耶。答曰。是人若为白衣或得善律仪。如不遮此人修行布施慈等善法。如是若有世间戒律仪者。有何咎耶。但以是人为恶业所污亦障圣道。是故不听出家。问曰。为从可杀等众生得善律仪。为于一切众生得耶。答曰。皆于一切众生边得。若不尔。律仪则有分。有分则不具足。又此律仪则可增减。亦同尼延子法。谓百由旬内不杀生等有此等过。是故律仪无有分别。若有人言。我于此人离杀。此人不离是人不得此戒律仪。有论师言。若分别布施行慈心等。有福德戒亦可尔。如持一戒亦得戒福。如是于一众生亦得律仪。问曰。是戒律仪二种。一尽形。二一日一夜。尽形者。若比丘优婆塞。一日一夜者。如受八戒。一日一夜是事云何。答曰。是事无定。若一日一夜。若但一日或但一夜。若半日或半夜。随能受时得出家。则但应尽形。若言我但一月二月。若但一岁则不名得出家法。五戒亦尔。问曰。若得善律仪还破失律仪不。答曰不失。但以不善法污此律仪。问曰。但于现在众生得戒律仪。为从三世众生得耶。答曰。皆于三世众生所得。如人供养过去所尊亦有福德。律仪亦尔。是故一切诸佛同一戒品。是律仪无量。如于一众生得起七种。从不贪等善根起故。亦从上中下心起故。故有多种。如一人一切众生边亦如是。念念常得故有无量。问曰。戒律仪几时可得。答曰。有人受一日戒是初律仪。即日受优婆塞戒是第二律仪。即日出家作沙弥。是第三律仪。即日受具足戒。是第四律仪。即日得禅定。是第五律仪。即日得无色定。是第六律仪。即日得无漏。是第七律仪。随得道果处更得律仪。而本得不失。但胜者受名。如是则福德益增。以此戒律仪于一切众生念念常得。故说一日戒律仪。四大宝藏不及十六分中之一。禅律仪无漏律仪随心行。戒律仪不随心行。问曰。有人言。入定时有禅律仪。出定则无是事云何。答曰。出入常有。是人得实不作恶法。与破戒相违常不为恶。善心转胜故应常有。问曰。若禅无色中无破戒法。以何相违名善律仪。答曰。法应如是。诸仙圣人皆得善律仪。若以破戒相违故有律仪者。则但应从可恼众生所得善律仪。有如是咎。是故不然

    八戒斋品第一百一十三

八戒斋名优婆娑。优婆娑秦言善宿。是人善心离破戒宿故名善宿。问曰。何故正说离八事耶。答曰。此八是门。由此八法离一切恶。是中四是实恶。饮酒是众恶门。余三是放逸因缘。是人离五种恶是福因缘。离余三种是道因缘。白衣多善法劣弱。但能起道因缘故。以此八法成就五乘。问曰。是八分斋但应具受为得分受。答曰。随力能持。有人言。此法但斋一日一夜。是事不然。随受多少戒。或可半日乃至一月有何咎耶。有人言。要从他受是亦不定。若无人时但心念口言我持八戒。是戒五种清净。一行十善道。二前后诸善。三不为恶心所恼。四以忆念守护。五回向涅槃。能如是斋则四大宝藏不及其一分。天王福报亦所不及帝释说偈。佛诃之。若漏尽人应说此偈。偈言

  六斋神足月　　奉行于八戒
  此人获福德　　则为与我等

受此斋法应泥洹果。故漏尽人应说此偈。受斋法中系缚桎梏。皆应放舍。亦断一切不善因缘。是名清净。问曰。转轮圣王好受斋法。谁教之者。答曰。大德天神曾见佛者。教之令受

    八种语品第一百一十四

八种语。四种不净四种净。四不净者。若人见言不见。不见言见。不见谓见问言不见。见谓不见问则言见。如是事倒心倒。故名不净。四种净者。若见言见。不见言不见。见谓不见问言不见。不见谓见问则言见。事实心实。故名曰净。闻觉知亦如是。问曰。见闻觉知有何差别。答曰。有三种信。见名现在信。闻名信贤圣语。知名比知。觉名分别。三种信慧。此三种慧或皆是实。或皆颠倒。上人不起不净。但起净语。是故下人所用则名不净。上人所用故名为净。有人言。是义中诸正智人皆名为上。不但得道故凡夫人亦有净语

    九业品第一百一十五

九种业。欲界系业三种。作无作非作非无作。色界系业亦如是。无色界二种及无漏业。身口所造业名作。因作所集罪福常随。是心不相应法名为无作。亦有无作。但从心生。非作非无作者即是意。意即是思。思名为业。是故若意求后身。此亦名意业。亦名为思。思念后身故名为业。问曰。若尔则无无漏思。答曰。若以此为思则无无漏也。问曰。是无作虽从身生当有多少差别不。答曰。若一切身分皆起作业。因此则集多无作得大果报。问曰。是无作在何处。答曰。业道体定集无作。或有或无余则待心。若强心则有软心则无。又此无作亦从愿生。若人发愿我要当布施若起塔寺。是人定得无作。问曰。是无作几时得几时失。答曰。随所作事在。若起园林塔寺等施。随施物不坏。尔时常随。又随心不息。如人发心我应常作此事。若会同若衣施。如是等事在心不息。尔时常得。又随命未尽。如人受出家戒尔时常得。问曰。有人言。但欲界中从作生无作。色界中无是事云何。答曰。应在二界。所以者何。色界诸天亦应能说法礼佛及僧。如是人等云何不从作业生无作耶。又有人言。隐没无记无无作。是事不然。隐没无记是重烦恼。是烦恼集则名为使。但不隐没无记无无作。所以者何。是心下软不能起集。如华能熏麻非草木等。有人言。过梵世上无有能起作业心。所以者何。觉观能起口业。彼无觉观但用梵世心能起口业。是事不然。众生随业受身。若上地生不应用梵世中报。故知以自地心能起口业。又汝说彼无觉观。后当说有。问曰。圣人断结未尽。能起作业不。答曰。圣人不能起实罪业。问曰。狗等众生音声是口业不。答曰。虽无言辞差别。从心起故亦名为业。又若现相若号令若箫竹等音皆名口业。是身口业要由意识能起。非余识也。是故人有自见身业自闻口业。以意识所起业相续不断故自见闻

    十不善道品第一百一十六

经中佛说十不善业道。谓杀生等。五阴和合名为众生。断此命故名为杀生。问曰。若此五阴念念常灭。以何为杀。答曰。五阴虽念念灭还相续生。断相续故名为杀生。又是人以有杀心故得杀罪。问曰。为断现在五阴故名杀生耶。答曰。五阴相续中有众生名。坏此相续故名杀生。不以念念灭中有众生名。问曰。有人依官旧法杀害众生。或为强力所逼强杀众生。自谓无罪。是事云何。答曰。亦应得罪。所以者何。是人具足杀罪因缘。以四因缘得杀生罪。一有众生。二知是众生。三有欲杀心。四断其命。是人备此四因。云何无罪。盗名若此物实属此人而劫盗取。是名为盗。是中亦有四种因缘。一是物实属他。二知属他。三有劫盗心。四劫盗取已。问曰。有人言。伏藏属王。若取此物则于王得罪。是事云何。答曰。不论地中物。但地上物应属王。所以者何。给孤独等圣人亦取此物。故知无罪。又若自然得物不名劫盗。问曰。若一切万物皆共业所生。劫盗何故得罪。答曰。虽从共业因生。因有强弱。若人业因力强。又勤加功此物则属。问曰。若人于塔寺众僧所夺取田宅等物。从谁得罪。答曰。虽佛及僧于此物中无我所心。亦从得罪。以是物定属佛僧。于中生恶心若劫若盗。是故得罪。邪淫名若众生非妻与之行淫。是名邪淫。又虽是其妻于非道行淫。亦名邪淫。又一切女人皆有守护。若父母兄弟夫主儿息等。出家女人为王等守护。问曰。淫女非妇与之行淫。云何非邪淫。答曰。少时为妇。如比尼中说是少时妇乃至以一鬘遮故。问曰。若无主女人自来求为妻者。是事云何。答曰。若实无主于众人前如法来者。不名邪淫。问曰。若出家人取妇免邪淫不。答曰不免。所以者何。无此法故。出家法常离淫欲。但罪轻于犯他人妇。妄语者。若身口意诳他众生。令虚妄解。是名妄语。佛为重罪故说众中定问名为妄语。乃至一人问时亦名妄语。岂须众人耶。又随所欲诳人。于此人得罪。若人语他人言我语某甲如是事。事虽不实不名妄语。又妄语随想。若见无见想。问言不见。无妄语罪。如比尼中说。问曰。若人事倒不见言见。云何非妄语耶。答曰一切罪福皆由心生。是人于不见事中而生见想。是故无罪。如于实众生中无众生想。非众生中生众生想。不得杀罪。问曰。如实有众生生众生想。乃得杀罪。如是若见生见想则应无罪。非不见见想而得无罪。答曰。是罪因心因众生生。是故虽有众生无众生想则不得罪。以无心故。若无众生有众生想。以众生无故亦不得罪。若有众生有众生想。因缘具故得杀生罪。若于见事中生不见想。问言不见。是人想不倒故不欺众生。虽为事倒亦名为实。若不见事中而生见想。问言不见。是人想倒欺诳众生。事虽不倒亦名妄语。两舌名若人欲别离他而起口业。是名两舌。若无别离心。他闻自坏则不得罪。若善心教化令离恶人。虽为别离亦不得罪。若不以结使浊心。虽复口言亦不得罪。恶口名若人苦言无所利益但欲恼他。是名恶口。若怜愍心为利益故苦言无罪。如无事加恼是则有罪。依方针灸虽苦非罪。苦言亦尔。诸佛贤圣亦为此事。如言痴人等。又若无结使浊心。虽为苦言不名为罪。如离欲人等。若以善心苦语中起烦恼。即时得罪。绮语名若非实语义不正。故名为绮语。又虽是实语以非时故亦名绮语。又虽实而时。以随顺衰恼无利益故亦名绮语。又虽言实而时亦有利益。以言无本末义理不次亦名绮语。又以痴等烦恼散心故语名为绮语。身意不正亦名绮业。但多以口作亦随俗。故名曰绮语。余三口业皆杂绮语不得相离。若妄语而非苦言。亦不别离。则有二种妄语绮语。若是妄语亦欲别离。而不苦言则有三种妄语两舌绮语。若妄语苦言不欲别离。亦有三种妄语恶口绮语。若妄语苦言亦欲别离则具四种。若无妄语苦言亦不别离。但非时语无益语无义语。则但是绮语。是绮语微细难可舍离。但有诸佛能断其根。是故但有诸佛独称世尊。言则信受。余无及者。问曰。已说七种业道。何用复说三意业耶。答曰。有人言。谓罪福要由身口。非但从心。是故说心亦是业道。是三种意业力故起身口恶业。是三种虽重。以意业微细故在后说。虽一切烦恼能起恶业。此三但为恼众生。故名不善业道。若中下贪不名业道。是贪增上深着他有。方便欲恼能起身口业。故以贪嫉为业道。恚痴亦尔。又若说痴即说一切烦恼。此中但为能起身口侵恼众生故说三种。问曰。何故名痴为邪见耶。答曰。痴有差别。所以者何。非一切痴尽是不善。若痴增上转成邪见。则名不善业道。一切不善皆由此三门。若人为财利故起不善业。如为金钱残杀众生。或以嗔故。如杀怨贼。或有不为财利亦不嗔恚。但以痴力不识好丑故杀众生。问曰。经说恶道因缘有四。随贪随恚随怖随痴行。故堕诸恶道。今此中何故不说随怖起恶业。耶。答曰。怖是痴所摄。若说随怖即是随痴。所以者何。智者乃至失命因缘尚不起恶业。又是事先已答。谓烦恼增长能起身口业。尔时名不善道。是三多起不善故。问曰。何故名为业道。答曰。意即是业。于此中行故名业道。先行后三中后行前七。中三业道非业。七业亦业亦道。问曰。亦有鞭杖及饮酒等诸不善业。何故但说十耶。答曰。此十罪重故说。又鞭杖等皆是眷属先后。饮酒非是实罪。亦不为恼他。设令他恼亦非但酒也。问曰。是不善道为在何处。答曰。悉在五道。但郁单越无邪淫以三事起以贪欲成。余以三事起亦以三事成。问曰。圣人能起不善业不。答曰。亦起意不善业不起身口。又意业中亦但起嗔心不起杀心。问曰。经中说学人亦咒人言灭令汝断种。此事云何。答曰。亦有经说阿罗汉咒。是漏尽人烦恼根断尚不起心。况当咒耶。言学人咒亦应如是。又圣人于不善业得不作律仪。云何当作不善。又此圣人不堕恶道。若能起不善则亦应堕。问曰。若诸圣人今世不造不善业。故不堕恶道。过去世中有不善业。何故不堕。答曰。是圣人心。中实智生时。诸恶道业皆已羸劣。犹如败种不能复生。又三毒二种。一能得恶道。一则不能。入恶道者圣人断尽。以业烦恼故得受身。圣人虽有诸业烦恼不具足。是故不堕。又是人依大势力。所谓三宝能消大恶。如人依王债主不恼。又是人智慧明利能消恶业。如人身中火势盛故难消能消。又此人有多方便。或念诸佛或念慈悲诸善业。故得脱诸恶。如多方诈贼依诸险难则不可得。又此圣人知得解脱道。如牛王行如鸟依空。又长夜修习诸善法故不堕恶道。如经中说。若人常修身戒心慧。有地狱报业能现轻受。又如偈说。行慈悲心无量无碍。诸有重业所不能及。又此圣人心不善业不能坚固。如一渧水堕热铁上。又此圣人善业深远如桓殊罗树根。又此圣人善多恶少。少恶在多善中则无势力。如一两盐投之恒河不能坏味。又此圣人富信等财。如贫穷人为一钱受罪。富贵者虽为百千亦不得罪。又入圣道故得为尊贵。如贵人虽罪不入牢狱。又如虎狼犬羊及尊卑共诤大者得胜。又此圣人心宿圣道。诸恶道罪不能复恼。如王宿空舍余人无能入者。又此圣人行自行处。恶道罪业不能得便。如鹰鵽喻。又圣人系心四念处。故诸恶道业不能得便。如圆瓶入鈙。又具二种结。故堕恶道随业受报。圣人断一种故不堕恶道。又此人常受善业报。故诸恶道业不能得便。又如先六业品中说地狱业相。圣人无因缘故不堕恶道

成实论卷第八成实论卷第九

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    十善道品第一百一十七

十善业道。所谓离杀乃至正见。是十事戒律仪所摄。一时得禅无色律仪所摄。亦一时得离名善业道。即是无作。问曰。余礼敬布施等福是善业道。何故但说离名业道耶。答曰。以离胜故。是十种业于施等为胜。所以者何。以布施等所得福报不及持戒如十岁人。以离杀因缘增益寿命。又十不善业是实罪故离名实福。又后三善业是众善之本。是故施等诸善皆业道所摄。又是业道有离鞭杖等。先后合说故。一切诸善皆在中摄

    过患品第一百一十八

问曰。不善业有何过患。答曰。以不善业故受地狱等苦。如经中说。杀生因缘故堕地狱。若生人中则受短命。如是乃至邪见。又以不善业因缘故久受苦恼。如阿鼻地狱过无量岁寿命不尽。又众生所有一切诸恶败坏衰恼皆由不善。又未曾见不善业有大利益。如屠猎师等终不以此业而得尊贵。汝意或谓。以坏贼因缘而得富贵。是事先三业品中已答。又行不善者。受呵[怡-台+責]等诸苦恼分。又令他人得所恶事名为凶暴。是故应离此不善业。又经中说。杀有五失。人所不信。得恶名闻远善近恶。死时生悔后堕恶道。又杀生因缘乐少苦多。又行不善业染污人心。世世积集久则难治。又行不善者。从冥入冥流转三涂永不得出。又行不善者。空受人身如采药雪山而收毒草。是为极愚。如是以十善道乃得人身。但不行善尚为大失。况起恶业。又行不善者。虽自爱身而实不自爱。虽自护身实非自护。以起自恼业因缘故。又是人遇身犹如怨贼自令苦故。又若行不善则自贼身。况他人耶。又行不善业。今虽不现果报则着。是故虽少亦不可不信。如毒虽少亦能害人。如债虽少渐渐滋息。又为恶于人人常不忘。是故为作虽久远亦不可信。又行不善者。名为失乐。以行不善故失人天乐。不乐乐者愚之甚也。又行不善者苦剧可愍。现受心悔等苦。后则受恶道苦。又不善业果飞虚隐海无得脱处。如金枪追佛。又一切不善皆由痴起。故有智者不应随也。又经中说。放逸如怨能害善法故不应随。又不善业诸佛菩萨应真贤圣五通神仙。及明罪福者无不呵毁。故不应造。又现见恶心炽盛。则情志迷乱恼闷痛苦。面色变异人不喜见。况起身口。以此等缘故知不善有无量患

    三业轻重品第一百一十九

三业中何者为重。身业耶口业耶意业耶。问曰。有人言。身口业重非意业也。所以者何。身口业定实故。如五逆罪皆因身口所造。又身口能成办事。如人发心杀此众生。要以身口能成其事。非但意业得杀生罪。亦非但发心得起塔寺梵福德也。又若无身口但意业者则无果报。如人发心我当布施。而实不与则无施福。又非但随愿事得成办。如人发愿为大施会。而实不与则无会福。若心业大者应得施福。然则业报错乱。又比尼中无意犯罪。若意业大。何故不犯。又若发心便得福者。福则易得。行者何故舍此易业而为施等难行业耶。又若然者。则福无尽。如人但空发心竟无所用何所尽也。以财物有量故福可尽。又不但发心能损益他。如饥渴众生要须饮食。非心业能除。又世间人衰利大甚。以心轻躁难制伏故。无恶不起则己受重衰。若发善心欲造福业则己获大利。是则过甚。又若意业大。发心欲杀生则堕地狱。如是虽久集戒等复何所益。又行持戒等诸善功德无有安隐。所以者何。但一发心便得罪故。又经中说。身口业粗故先断。断粗烦恼故得心定。又发淫心则为淫已便应犯戒。若发心不名淫者。离此淫心更有何法名为淫耶。有所起作业皆由身口。不以意业。如欺他人必由口业得妄语罪。又如先说四种因缘得杀生罪。谓有众生有众生想。有欲杀心。断其命。以四事成罪。当知不以意业为重。又如佛言。若小儿从生习慈能起恶业思恶业耶。故知但身口业恶。非意业也。答曰。汝言身口业重非意业者。是事不然。所以者何。经中佛说。心为法本。心尊心导心念善恶即言即行。故知意业为重。又意差别故身口业有差别。如上中下等。离心无身口业。又经中说。故起作业必应受报。又说七种净福。三种但用意业。此七净福于财福为胜。又慈是意业。经说慈心得大果报。如经说。我昔七岁修集慈故。于七大劫不还此间。故知意业为重。则能遍覆一切世界。又意业为重。如意业报故寿八万大劫。又意业势力胜身口业。如行善者将命终时生邪见心则堕地狱。行不善者死时起正见心则生天上。当知意业为大。又经中说。于诸罪中邪见最重。又说。若人得世间上正见。虽往来生死乃至百千岁终不堕恶道。又意业力胜身口业。如和利经中说。外道神仙起一嗔心。即灭那罗于陀国。如檀特等诸崄难处。皆是仙人嗔心所作。又意业能即得果报。如经中说。若是人今死即入地狱。即生天上。如[矛*(替-曰+貝)]鉾离手。又此意业积集垢法。乃至入阿鼻地狱。积集善法乃至泥洹。又心有报故身口得报。以不故业无果报故。又不离意业有身口业报。若意依身口行善不善。名身口业离身口业意业有报。离意业身口无报。故知意业为重。非身口业。汝虽言身口业定实。如五逆罪皆身口所作故名重者。是事不然。以思重事重故业重。非身口重故重。又以心决定故业则定实。如但以心力入正法位。亦以心力能具逆罪。若无心者。虽杀父母亦无逆罪。故知身口无力。汝言身口能办事者。是亦不然。以事讫名办。若夺他命已得杀生罪。非起身口业时。事讫时要须心力是故非身口也。汝言但空发心无果报者。是事不然。如经中说。发强心故即生天上。即入地狱。云何言意业无果报耶。汝言非但以愿能成事者。是亦不然。又人深发善心胜大会福。汝言意无犯罪。是亦不然。若发恶心即时得罪。如佛说有三种罪。身口意罪。故知但发恶心不得无罪。但不结戒以难持故。粗罪持戒能遮。细罪定等能除。汝言罪福易者。是事不然。人以心力薄故舍易为难。如慈心等其福甚多。非布施也。但以众生智力劣弱不能行慈等意业故。为施等以离华香等诸供养等具。净心难得。故汝言福无尽者。亦以此答。是人若有智力则能得无尽善法。汝言意业无所损益。是事不然。以身口业皆为意业所导故不名胜。以随力所起是则为胜。又诸利益皆由行慈心者。所以者何。以行慈力故。风雨顺时百谷成熟。如劫初时粳米自生。至十岁人时是事皆无。云何言慈心无利益耶。又行慈者。能尽一切不善业根。由不善业有诸衰恼。云何言行慈无大利益。若一切众生行慈心者尽生善处。一切自然不须加功。故知慈福最为深厚。又或时以慈布施利益众生。或但以慈利。又行慈者。众生若触其身若入影中皆得快乐。当知慈福胜于施等。汝言衰利太甚。是先已答。谓以意力损益众生。故知意业为重。汝言久集戒等无所益者。是亦不然。以意净故则持戒净。若意不净戒亦不净。如七种淫经中说。又戒清净得大果报。如经说持戒者所愿随意。谓戒净故。又若净持戒得安隐心非余法也。汝言身口业粗故先断。是事不然。以微细善得大果报。如禅定中思。汝言若发淫心便应犯戒。是事不然。若人意业不净则戒亦不净。又得罪福异结戒法异。汝言所起作业由身口者。皆以总答。谓身口业法异。意业法异。身口业要由作成。如以四因缘成杀生罪。不离心业。又世间众生谓身口业恶。意业不尔。又意业不加于人。亦不可得有。又先说罪福相。以是故但意业重非身口也

    明业因品第一百二十

论者言。已略说诸业。业是受身因缘。身为苦性。故应灭之。欲灭此身当断其业。以因灭故果亦灭。故知因形有影形灭则影灭。是故若欲灭苦当勤精进断此业因。问曰。从业受身是事应明。所以者何。或有人言。身从波罗伽提生。有言从自在天生。或言从大人生。或言从自然生。是故应说因缘。云何知从业生耶。答曰。是事已种种因缘破。当知从业受身。又万物有种种杂类。当知因亦差别。如见粟麦等异知种不同。自在天等无差别故。当知非因业有无量差别故受种种身。又诸善人皆信因业受身。所以者何。是人常行施戒忍等善法。离杀生等诸不善法。故知从业受身。又若因业受身是则可返。得真智故邪智则断。邪智断故贪恚等诸烦恼断。诸烦恼断故能起后身业亦断。是则可返。自在等因中则不可返。以自在等不可断故。故知从业受身。又现见果与因相似。如从麦生麦从稻生稻。如是从不善业得不爱报。从善业得爱报。自在等因中无此相似。是故业为身本非自在等。又今现见万物皆从业生。以恶业故受打捕系闭鞭杖死等诸苦。善业因缘受名闻利养等乐。随意爱语者得随意受报。故知从业受身非自在等。又世间人自知万物从业因生。故起稼穑等业。亦为施戒忍等诸福德业。无有闲坐而从自在望所欲者。故知从业得报。又若人虽说因自在等。而犹依诸业。谓自苦身及受斋等。故知以业为因。又若事不现应随他教。谓圣人所行。一切贤圣皆依戒等善法。知从业因有世间故。若离戒等亦无圣人。无有圣教违背业者。故知从业受身。又行戒等诸善业。故能成神通变化等事。故知以业为因。又地狱等诸恶趣中嗔恼等多。故知由嗔恼等有诸恶道。如树上见果知树是因。故知业为身本。又恶道中痴等力强。当知烦恼是恶道因。一切不善皆由痴故。又生诸恶道多。生善处少。眼见杀等恶行者多。行善者少。故知杀等事是恶道因。又杀等事善人所呵弃而不为。善人必知杀等有恶果。故呵弃不为。若知无恶果何故弃耶。又诸善人心若起恶即勤制止。以惧恶报故。当知杀等必有恶报。若不尔者。应随意所作是最为乐。则杀可食众生夺他财物。淫犯他妻。是亦皆乐。以惧来世苦故远离斯事。故知从业有身。又修习正智尽有漏业。则不受身。故知业是其本。又阿罗汉虽有诸有漏业。修正智故业则不集。故知业为身因。身因灭故身亦灭。又知四谛故依谛烦恼永不复起。以不起故则无有身。智者如是思惟则欲知四谛。故知业为身因。又若因缘不具则不受身。如地干种焦则一切牙不生。如是识处地无爱水润业种。为真智所焦。后身牙则不生。智者知是事故。欲干识处地焦业种子。则勤加精进。故知业是受身因缘。业论竟

    集谛聚中烦恼论初烦恼相品第一百二十一

论者言。已说诸业诸烦恼。今当说垢心行名为烦恼。问曰。何谓为垢。答曰。若心能令生死相续。是名为垢。此垢心差别。为贪恚痴等。是垢名为烦恼。亦名罪法。亦名退法。亦名隐没法。亦名热法。亦名悔法。有如是等名。是垢心修集则名为使。非但垢心生时名使。烦恼名贪恚痴疑憍慢及五见。此十差别有九十八使。贪名喜乐三有。亦喜乐无有是名为贪。如经中说。欲爱有爱无有爱。无有名断灭。众生为苦所逼。欲灭阴身以无为乐。问曰。喜乐是受相非贪相也。如经中说今喜后喜义。言今世受乐后亦受乐。又说今忧后忧义。言今世受苦后亦受苦。又如天问中言有子则喜。佛答有子则忧。如是等答。曰贪为喜分。如经中说。受因缘爱乐受中贪使。揣食中有喜有贪。喜尽故贪尽。当知贪为喜分。是则无咎。何以知之。如经中说。集谛者。谓渴是也。何谓为渴。谓欲得后身是渴。何相。谓依止贪欲得种种。问曰。若说欲得后身是渴相者。何故复说依止于贪欲得种种。答曰。更有渴相。若言欲得种种是总相说。欲得后身是别相说。离欲人亦有欲得种种。谓渴欲得水等是非集谛所摄。若依止贪欲得后身。是渴名集谛所摄。问曰。若渴亦是喜贪亦是喜。何故说依止贪耶。答曰。初生名渴。增长名贪。故言依止。如经中说喜系世间。是故喜即是贪。又经中说。除灭贪忧诸不善法。是中贪即是喜。忧即是嗔。如说嗔为忧则知亦说喜为贪。是故十八意行中。不说烦恼但说诸受。故知喜分是贪。又凡夫离贪不能受乐。离嗔不能受苦。离痴不能受不苦不乐。何以知之。第三受中说。凡夫人于此受中不知集不知灭不知味不知过不知出。故于不苦不乐受中无明使使。是凡夫人常不知此五种法。故常于不苦不乐受中为无明使使。无明使者。即是不知性受行也。如是凡夫苦乐心行亦即是贪恚。又若初来在心名受。增长明了名为烦恼。又下软心名受。即此心增上名曰烦恼

    贪相品第一百二十二

论者言。是贪九结中通三界系名为爱。于七使中分为二种。欲贪有贪。所以者何。有人于上二界生解脱相。是故佛说是处名有。有名为生。若无贪则不生。是故别说有贪非但欲贪。或谓但欲贪是名烦恼。尽欲贪名得解脱。故佛说禅无色中亦有有贪。佛示彼中有微细缚。是故别说是贪。于十不善道及四缚中。名为贪欲。贪欲名欲得他物。于五盖及五下分结中名为欲欲。欲欲名欲。于五欲三不善根中名为贪不善根。贪不善根名能生长诸不善法。是贪若非法名为恶贪。如劫盗他物乃至取塔寺及众僧物。若未死众生欲食其肉。若欲淫母女姊妹师妇出家人及己妻非道。是名恶贪。若己物不欲舍是名为悭。即此贪。若实无功德欲令人谓有。是名恶欲。若实有功德欲令人知是名发欲。若欲得多施多物是名多欲。若得少施少物求好无厌名不知足。若深着种性家属名色财富少壮寿等名为憍逸。若贪四供养名为四爱。又是贪二种。一欲贪。二具贪。又有二种。一我贪。二我所贪。一缘内。二缘外。上二界贪一向缘内。又有五种。一色贪。二形贪。三触贪。四威仪语言贪。五一切贪。又色声香味触贪名五欲贪。又于六触生爱名六尘贪。又于三受中贪。乐受中有欲得贪。有守护贪。苦受中有不欲得贪。有欲失贪。不苦不乐受中有痴贪。又此贪有九分。如大因经中说。因爱求随所欲事。如人为此事所苦则求异事。如说乐者不求苦者多求。是贪增长名求。求时若得名为得。爱因得则筹量是可取是不可取。若心决定是名因筹量故欲爱。因欲爱故贪着。贪著名深爱。贪着因缘取。取名为受。因受生悭。因悭守护。因守护故备受鞭杖力槊等。是名九分。又有九分。是贪随时故。有上中下下下下中下上中下中中中上上下上中上上。又此贪世间分为十种。如见好色初发心言是。次生欲。三发愿。四念。五随学所作。六忘惭愧。七常在目前。八放逸。九狂痴。十闷死。是名贪相

    贪因品第一百二十三

问曰。是贪云何生。答曰。若于女色等缘中生邪忆念。若色若形若触若威仪语言则贪欲生。又若不守护眼耳等门。则贪欲生。又于饮食不知节量则贪欲生。又亲近女色则贪欲生。又受诸乐则贪欲生。又以愚痴故贪欲生。于不净中生净想故。又由恶知识故贪欲生。如净洁衣以里垢污。又与多欲人共事故则贪欲生。又于身等四法生妄忆念。则为贪所牵。如圆瓶无制如华无贯。又若懈怠不勤修善则贪欲得便。又于非行处行则为贪所侵。谓淫女沽酒屠儿舍等。如鹰鵽喻。又观不净等未能坏缘则贪欲得势。又从久远来习贪成使。是则易生。又于女色等缘喜取相取了。取相名手足面目语言戏笑视瞻啼泣等相。取了名分别男子形状差别。如是取已忆念分别则贪欲生。又思量心弱随逐所缘。不能制伏则贪欲生。又若生贪欲忍受不舍。则渐增长从下生中从中生上。又于贪欲中但见利味不知其过。则贪欲生。又以时节故贪欲生。如春时等。又以方处故贪欲生。如有处所。从久远来多习淫欲。又有随身故贪欲生。如年少无病资生具足。又以力能故贪欲生。如服药等。又得净妙随意五欲则贪欲生。谓见好花池园林敷荣清冷流泉鲜云电光香风来扇。若闻众鸟哀声相和及女人柔软庄严音声威仪语言等。又以业因缘故贪欲生。如清净施者。则能好喜净妙五欲。罪人则好不净。又以随类故贪欲生。如人欲人。又深着假名则贪欲生。是人于内生士夫相。外生女相及衣服怨亲等相。又未得空心。内见众生外见色等。则贪欲生。又若贪使未尽爱缘现前。于中生邪忆念。如是等因缘则贪欲生

    贪过品第一百二十四

问曰。贪欲有何过故欲断耶。答曰。贪欲实苦。凡夫颠倒妄生乐想。智者见苦。见苦则断。又受欲无厌。如饮碱水随增其渴。以增渴故何得有乐。又受欲故诸恶并集。以刀杖等皆由贪故。又经说。贪罪轻而难舍于嗔恚。故名为轻罪。其实是重。又贪为后身因缘。如说爱因缘取乃至大苦聚集。又说。苦因为爱。又说。比丘应深思惟。所有诸苦何由而有。当知皆以身为因缘。身因于爱。又说。揣食中有喜有贪。是故识于中生。当知爱为受身因缘。又是贪常于不净中行。如女人等。是女人身心不净。如粪涂毒蛇能螫能污。又此贪欲常痴中行。如经中说。譬如狗咬血涂枯骨唌唾合故想谓为美。贪者亦尔。于无味欲中。邪倒力故谓为受味。又如段肉等七种譬喻。有人或于去来事中而生贪欲。故知常痴中行。又众生以贪欲因缘乐少苦多。所以者何。如富贵处少散坏时多。又爱欲者为乐因故备受诸苦。谓求时苦守护时苦用时亦苦。如稼穑商贾征伐仕进等。是求时苦守时恐怖畏失故苦。现在无厌故苦。又欢爱会少别离苦多。故知欲为多过。又如佛说爱欲有五种患。一味少过多。二诸结炽盛。三至死无厌。四圣所呵弃。五无恶不造。又此贪欲常令众生顺生死流远离泥洹。有如是等无量过患。当知欲为多过。又诸烦恼生皆因于贪。如贪身故起诸烦恼。又爱使不拔则数数受苦。如毒树不伐则常害人。又贪能令众生荷负重担。又经中说。贪爱为系。如黑白牛自不相系。但以绳系。如是眼不系色色不系眼。贪欲于中系。若缘是系则无得解脱。又经中说。众生为无明所盖爱结所系。往来生死无有本际。又经说。贪断故色断乃至识断。此贪以无常等观故断。断此贪欲则心得解脱。色贪断则无色。无色则苦灭。乃至识亦如是。故知贪欲为坚固缚。又贪欲如贼。而众生不见其恶。又贪欲常于软美门中行。故名深恶。又众生心喜起贪欲。乃至蚊蚁皆于饮食淫欲中起。又此贪欲种种因缘能缚人心。谓父母兄弟姊妹妻息及财物等。又众生以饮食淫欲等贪欲覆心则能受生。若贪禅定则生上界。又此贪欲能为和合。一切世间所乐各异。贪欲和合犹如干沙得水相着。又生死中以贪爱为味。如说色中味着。谓因色生若喜若乐。若无贪则不味。不味则能速断生死。又此贪欲与解脱相违。所以者何。众生皆以贪着欲乐禅定乐。故不乐解脱。又随断贪分即变为乐。如说随所离欲转得深乐。又说。若欲得诸乐。当舍一切欲。舍一切欲故得毕竟常乐。若欲得大乐。当舍离少乐。舍离少乐。故能得无量乐。又说。智者更无别利。如离贪爱心。随心离贪爱则灭诸苦恼。又此贪欲违害善法。所以者何。深贪著者则不顾戒及种姓教法威仪名闻。不受教化不见衰患不观罪福。如狂如醉不知好丑。亦如盲人不见福利。如说。贪欲不见利贪欲不识法。犹盲闇无智以不除贪故。又说。贪欲为大海。无边亦无底。波浪旋澓深。恶虫及罗刹。如是诸崄难。无人能度者。但住净戒舡。得正见风力。佛为大舡师。能示诸正道。如所说修行。是者则能度。又诸烦恼中。无有想分别。味如贪欲者。又此贪欲最为难断。如经中说。二愿难断。一得。二寿。问曰。贪欲有如是过。云何当知贪欲者相。答曰。多贪欲者。喜乐女色及花香璎珞伎乐歌舞。到淫女家饮食聚会。喜大众集及诸戏具。喜随爱语心常欢喜。面色和泽先意问讯。含笑语言难忿易悦。多怜愍心身体便疾。性多躁动自深着身。如是等名多贪欲相。是相皆与系性相顺。是故难断。又一切贪欲究竟皆苦。所以者何。所贪爱事必当离散。离散因缘必有忧苦。如说天人皆乐色贪色喜色着色。是色坏时忧悲心悔。受想行识亦如是。又佛于处处经中说种种喻。呵此贪欲。谓能害慧命故说为毒。在心即苦故名为刺。能断善根故名为刀。能烧身心故说为火。能生诸苦故名为怨。从心中生故名内贼。以难拔故名为深根。能污名闻故名淤泥。障善道故名曰妨碍。内疼恼故名箭入心。起诸恶故名不善根。注生死海故名为河。劫盗善财故名为贼。贪欲有如是等无量过患。是故应断

    断贪品第一百二十五

问曰。贪欲有如是过。当云何断。答曰。以不净观等遮。无常观等断。问曰。有人觉无常故更增贪欲。此事云何。答曰。若人能知一切无常。则无贪欲。如经中说。善修无常想故。则能破坏一切欲贪色无色贪一切戏掉憍慢无明。又若人能见世间皆苦苦因缘贪。此贪则断。又若人常念我必应受生老病死。是贪则断。又若得净乐则舍不净乐。如得初禅则舍欲爱。又见贪欲过是则能断。过如先说又多闻等慧增长故。能断贪欲。以智慧性破烦恼故。又善因缘具足则贪欲断。谓净持戒等。十一定具后道谛中当说。又色智等法智等诸方便。佛为大医。诸同学为给使。正法为药。自如说行为将息。则贪欲病断。如有知病人三事具足病则时愈。问曰。如经中说。以不净除贪法。何故说不净等及无常等耶。答曰。一切佛法皆为破诸烦恼。然各有胜力。初以不净遮贪。后以无常智断。又以不净除粗贪欲。是多人所知。贪使细故以无常断。又但一经中作如是说。诸经中亦说余法能断。如是因缘则贪欲断

    嗔恚品第一百二十六

论者言。嗔恚相者。若嗔此人欲令失灭。愿使他人打缚杀害。一向弃舍永不欲见。是嗔名波罗提伽。义言重嗔。有嗔但欲毁骂鞭打他人名违欣婆。义言中嗔。有嗔不欲舍离。或从憎爱妻子中生。名拘卢陀。义言下嗔。有嗔常染污心名为摩叉。义言不报恨。有嗔在心不舍。要欲还报。名忧波耶呵。义言报恨。有嗔急执一事种种教诲终不欲舍。如师子渡河取彼岸相。至死不转名波罗陀含。义言专执。有嗔见他得利心生嫉妒。名为伊沙。有嗔常喜诤讼。心口刚强。名三蓝披。义言忿诤。有嗔若师长教戒而返拒逆。名头和遮。义言佷戾。有嗔若得少许不适意事则心恼乱。名阿羼提。义言不忍。有嗔言不柔软。常喜频蹙不能和颜。先意语言。名阿婆诘略。义言不悦。有嗔于同止中常喜骂詈。名阿搔罗沽。义言不调。有嗔以身口意触恼同学。名为胜耆。义言恼触。有嗔常喜弹呵好呰毁物。名登单那他。义言难可。是嗔二种。或因众生或不因众生。因众生名为重罪。又上中下分别九品。又因九恼分别为九。无事横嗔是为第十。是名嗔相。问曰。嗔云何生。答曰。从不适意苦恼事生。又不能正知苦受性故。则嗔恚生。或从呵骂鞭打等生。或与恶人同事则嗔恚生。如屠猎师等。或智力劣弱故嗔恚生。如树枝条为风所动。或久集嗔使乃至成性。故嗔恚生。或从屠猎毒蛇中来故嗔恚生。或喜念他过故嗔恚生。如九恼中说。或随时节故嗔恚生。如十岁人等。或以种类故嗔恚生。如毒蛇等。或以方处故嗔恚生。如康衢国等。又先说贪生因缘。与此相违则嗔恚生。又计我心憍慢炽盛。及深着物。如是等缘则嗔恚生。问曰。是嗔有何等过。答曰。经中说嗔为重罪于贪欲。故名为易解而实难解。但不如贪久随逐心。又嗔为两恼。我自烧恼而后烧人。又嗔定为地狱。以从嗔起业多堕地狱故。又嗔能坏善福。谓施戒忍是三皆从慈等生。嗔与慈相违故名能坏。又从嗔起业皆受恶名。又从嗔起业。后皆心悔。又嗔恨者无怜愍。故名曰凶暴。众生常苦而复嗔恼。如疮如火。又经中自说嗔过。谓多嗔者形色丑陋。卧觉不安心常怖畏。人所不信等。问曰。多嗔恚者有何等相。答曰心口刚强常不欢悦。频蹙难近面色不和。易忿难解常喜恚根。喜于诤讼。严饰兵器朋党恶友。憎恶善人为人粗犷。不谛思虑少于惭愧。有如是等名嗔恚相。是相皆为憎恶他人是故应断。问曰。当云何断。答曰。常修慈悲喜舍嗔恚则断。又见嗔过患。是则能断。又得真智嗔恚则断。又以忍力故嗔恚则断。问曰。何谓忍力。答曰。若能忍他呵骂等苦。是人得善法福。亦不得从不忍生恶。是忍辱力。又行忍者名为沙门。以忍辱为道初门故。沙门法者。怒不报怒。骂不报骂。打不报打。又若比丘能忍则应出家法。又嗔恚者。非出家人法。出家人法忍辱是也。又若比丘形服异俗。而嗔心同则非所宜。又若行忍者则为已具慈悲功德。又修忍者能成自利。所以者何。为嗔恚者欲恼害人。而返自害。所有身口加恶于人。自所得恶过百千倍。故知嗔为大自损减。是故智者欲令自他得免大苦及大罪者应当行忍。问曰。云何能忍呵骂等苦。答曰。若人善修无常了达诸法念念生灭。骂者受者皆念念灭。是中何处应生嗔也。又善修空心故能忍辱。作如是念。诸法实空谁是骂者谁受骂者。又事若实则应忍受。我实有过。前人实语何故嗔耶。若事不实。彼人自当得妄语报。我何故嗔。又若闻恶骂当作是念。一切世间皆随业受报。我昔必当集此恶业。今应偿之。何故嗔耶。又若闻恶骂当自观其过。由我受身身为苦器。故应受骂。又行忍者作如是念。万物皆从众因缘生。是恶骂苦。从耳识意识音声等生。我于此中自有二分。他人唯有音声。是则我罪分多。何故嗔耶。又我于此声取相分别。故生忧恼即是我咎。又忍辱者不咎他人。所以者何。是嗔等过非众生咎。众生心病发故。不得自在。如治鬼师治鬼著者。但嗔于鬼不嗔病人。又是人勤行精进贪集善法。故不计他语。又念。诸佛及众贤圣尚不免骂。如巧骂婆罗门等种种骂佛。如舍利弗等为婆罗门加诸毁辱。何况我等薄福人耶。又作此念。世间多恶不夺我命。已为大幸。况打骂耶。又作是念。此恶骂等于我无苦。易可忍受。如佛教比丘。若铁锯解身尚应忍受。何况骂耶。又此行者常厌生死。若得毁骂则证验明了。转增厌离舍恶行善。又是人。知不忍辱后受苦报。作如是念。宁受轻骂勿堕地狱。又是人深怀惭愧我为大人世尊弟子。修行道者。云何当起所不应作身口业耶。又闻行忍菩萨及帝释等所得忍力。是故能忍

    无明品第一百二十七

论者言。随逐假名名为无明。如说凡夫随我音声。是中实无我无我所。但诸法和合假名为人。凡夫不能分别故生我心。我心生即是无明。问曰。经中佛说不知过去世等名为无明。何故但说我心是耶。答曰。是过去等中。多人错谬故。说是中不知名为无明。又经中解明名义。谓有所知故名为明。知何等法。谓色阴无常如实知无常。受想行识阴无常。如实知无常。与明相违名为无明。然则不明如实故名无明。问曰。若不明如实名无明者。木石等法应名无明。以不明如实故。答曰。不然。木石无心不能分别过去世等。无明能分别。故不同木石。问曰。无明名无法。如人目不见色。无不见法。是故但明无故名为无明。无别法也。答曰。不然。若无无明于五阴中妄计有人。及瓦石中生金想者。名为何等。故知邪分别性名无明。非明无故名无明也。又从无明因缘。有诸行等相续生。若无法者云何能生。问曰。若非明名无明者。今但除明一切诸法尽是无明。是故不以一法名为无明。答曰。是无明自相中说。不说余法。如言不善即说不善体。不说无记。无明亦尔。又虽禀人形。无人行故说名非人。如是此明虽有分别不能实知。故说无明。木石不尔。问曰。若说无色无对无漏无为。皆是余说。无明何故不如是耶。答曰。或有此理。不善等中则不如是。问曰。有人言。但以明无故名无明。如室无光明则名为闇。答曰。世间有二种语。或明无故说名无明。或邪明故说名无明。明无故说无明者。如世间言盲不见色聋不闻声。邪明故说无明者。如夜见杌树生人想见人生杌树想。又若人不能实知是事。故名不知。又邪心名烦恼。是诸行因缘阿罗汉断故。无有无明因缘诸行。若非明名无明者。今阿罗汉无佛法中明。应名无明。若有无明非阿罗汉。当知别有无明体性。邪心是也。是邪是无明分为一切烦恼。所以者何。一切烦恼皆邪行故。又一切烦恼覆蔽人心。皆为盲冥。如说贪欲不见法贪欲不见福。能受此贪者皆名为盲冥。恚痴亦如是。又从一切烦恼生诸行。而经中说从无明生行。故知一切烦恼皆名无明。又不见空者常有无明。但垢无明是诸行因缘。又邪明故说无明。未见空者常是邪明。故知无明分为一切烦恼。问曰。无明云何生。答曰。若闻思邪因则无明生。如有陀罗骠有有分者有精神。诸法不念念灭无有后身。音声及神是常。草木等有心。欲成如是等邪执则无明生。或从邪因故无明生。谓亲近恶友听闻邪法邪念邪行。是四邪因故无明生。又生余烦恼因缘。皆是生无明因。又从无明因故无明生。如从麦生麦从稻生稻。如是随计众生则无明生。又经中说。从邪念因缘则无明生。邪念即是无明别名。谓见有人先生人念。后明了故名为无明。是二先后相助相生。如从树生果从果生树。问曰。无明有何等过。答曰。一切衰恼皆由无明。所以者何。从无明生贪等烦恼。从烦恼起不善业。从业受身。受身因缘得种种衰恼。如经中说。谓无明所覆爱结所系。受诸有身。又师子吼经中说。诸取皆以无明为本。又偈说。所有诸恶处。若今世后世皆无明为本。故从贪欲起一切烦恼过。皆由无明有。以从无明生一切烦恼故。凡夫以无明故。受五阴不净无常苦空无我。何有智者受此诸苦。又正思惟故。能舍五阴。如经中说。若知我心是邪颠倒则不复生。故知以无明因缘故缚。明因缘故解。又世间众生以无明力故。贪求少味不见多过。如蛾投火如鱼吞钩。众生亦尔。现贪少味不顾多过。又外道经典所生邪见。说无罪福等皆是无明。又诸恶道皆因不善。不善皆是无明。又邪见起业多堕地狱。邪见皆由无明故生。又佛为世尊一切智人三界大师。真净行者及圣弟子等。诸外道辈不能别知。如真宝珠盲者弃之。此皆无明过也。又一切众生所有衰恼败坏等事。皆由无明。一切利益成就增长。皆由于明。若增长无明究竟必堕阿鼻地狱。如劫初人不知味是虚妄。而生贪着故失色力寿命等事。当知皆由无明忘失诸利。又此无明但真智断。贪等不尔。又贪心中无恚。恚心中无贪。无明在一切心中。及不修慧人无明常在心中。又诸烦恼中无明最强。如经中说无明罪重亦难除解。又无明是十二因缘根本。若无无明则诸业不集不成。何以知之。诸阿罗汉无众生相。无无明故诸业不能集成。业不集故识等诸分不能复生。故知无明是诸苦本。又现见贪着此不净身。亦于无常中生常想。犹若空卷以诳小儿。亦如幻师能现前诳人。令见土为金。又俗言。愚人现以罪加而可以言诳。世间亦尔。眼见不净而为其所诳。又诸心法念念尽灭。取相故生。色灭尽已痴故取相。于声等中亦复如是。是故难解。此皆无明之过。问曰。多无明人有何等相。答曰。是人于畏处不畏。喜处不喜。憎恶善人爱乐恶人。倒取人意。常喜反戾坚执邪事。少于惭愧不顾嫌疑。不能悦彼。亦自难悦。不能亲附。亦难亲近。愚騃无识。好弊垢衣。乐处黑闇及不净处。自大自贵喜轻蔑人。不以道理自显功德。过不知过利不识利。不好净洁亦无威仪。拙于语言常喜恚恨。僻取他教而深贪着。学诵难得既得易失。设有所得不能解义。设有所解则复邪僻。如是等相皆由无明。故知无明有无量过。是故应断。问曰。当云何断。答曰。善修真智则无明断。问曰。知阴界等亦名真智。经中何故说无明药者若因缘若因缘观。答曰。诸外道辈多于因物中谬。因中谬故说自在天等为世间。因物中谬故说有陀罗骠有有分等。观因缘法此二则断。问曰。因缘名无明药。何故二种说耶。答曰。欲摄余智故。若观阴界入等亦破无明。但重无明名邪见。邪见以因缘断。故二种说。贪恚亦如是。又世间多于瓶等名字中谬。如闻瓶名则心生疑。为色等是瓶。为离色更有瓶耶。如是为五阴是人。为离五阴更有人耶。若心决定则堕二边。所谓断常。身即是神。异身异神亦如是。若人知瓶从众缘生因色香味触成。如是色等诸阴为人。能如是知则能舍离从名生痴。是名字能覆诸法实义。如天问经说名胜一切法更无能过者。是名字一法诸法皆随。又说。见世间集则灭无见。见世间灭则灭有见。又说。诸行相续故说五阴生死。此皆无明过患。观因缘则灭。又经中说。若人见因缘是人即见法。若见法即见佛。如是若人能断从名生痴。是人则实见佛。不随他教。是故以正智故则无明尽。正知因缘法故能得正智。又略说。八万四千法藏中。所有智慧皆除无明。以无明是一切烦恼根本。亦助一切烦恼故。如是因缘则无明断

成实论卷第九成实论卷第十

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    憍慢品第一百二十八

问曰。已说三烦恼是生死根本。为更有不。答曰。有。名为慢。问曰。云何为慢。答曰。以邪心自高名慢。是慢多种。若于卑自高名慢。于等计等亦名为慢。以此中有取相我心过故。于等自高名为大慢。于胜自高是名慢慢。于五阴中取我相。名为我慢。我慢二种。示相不示相。示相是凡夫我慢。谓见色是我见有色是我。见我中色见色中我。乃至识亦如是。示是二十分故名示相。不示相是学人我慢。如长老差摩伽说。不说色是我。不说受想行识是我。但五阴中有我慢我欲我使。未断未尽是名我慢。若未得须陀洹等诸果功德。自谓为得名增上慢。问曰。若未得何故生得心耶。答曰。于习禅中得少味故。能遮结使不行于心中。故生此慢。又闻思慧力。常近善师乐远离行。少知五阴相。故生须陀洹等果想。名增上慢。问曰。增上慢有何等咎。答曰。后当忧恼。如经中说。若比丘言我断疑得道。即应现前说甚深因缘出世间法。若是比丘实不得道。闻是法时则生悔恼。故应勤断此增上慢。又增上慢人。诸佛世尊有大慈悲。犹尚舍远不为说法。是故应断。又增上慢人住邪法。故无实功德。犹如贾客深入大海而贪伪珠。是人亦尔。入佛法海得少禅悦。谓为真道而生贪着。又增上慢人。后老死时不任受道。故当勤求真实智慧。又增上慢人。自失己利亦增益愚痴。以实未得想谓得故。是故不应自诳其身。当速弃舍。若于大胜人谓少不如。名不如慢。是人自高亦自下身。若人无德自高名为邪慢。又以恶法自高亦名邪慢。若于善人及所尊中。不肯礼敬名为傲慢。如是等名为憍慢相。问曰慢云何生。答曰。不知诸阴实相则憍慢生。如经中说。若人以无常色自念是上是中是下。是人正以不知如实相故。乃至识亦如是。若知阴相则无憍慢。又善修身念则无憍慢。如牛恃角则为暴慢。若去其角则不能也。身为不净九孔流恶。何有智者恃此自高。以如是等念身因缘。则无憍慢。又智者知一切众生若贫若富若贵若贱。皆以骨肉筋脉五脏粪秽合而成身。俱有生老病死忧悲苦恼。亦有贪恚等诸烦恼罪福等诸业。及地狱等诸恶道分。云何当起憍慢。又见内外心从因缘生。知念念灭则无憍慢。又善修空心则无憍慢。所以者何。随逐相故则憍慢生。若无相者何处起慢。又智慧者。若实有戒等功德则不生慢。所以者何。戒等功德皆为尽此诸烦恼故。若无功德。何有智者。于无事中而起憍慢。又观无常等相则灭憍慢。何有智者。以无常苦不净之物而为憍慢。问曰。憍慢有何等过。答曰。从慢有身。从身生一切苦。如经中佛说。若我弟子不能如实知慢相者。我与受记当生某处。以有余慢不断故。又一切烦恼皆随取相。我是相中之大。故知从慢有身。又此憍慢即是痴分。所以者何。以眼见色谓我能见。又此憍慢生不以道理。所以者何。一切世间皆无常苦无我。云何以此而生憍慢。是故于贪恚痴最无道理。又从慢起业亦利亦重。以贪着深故从贪起业。不能如是。又憍慢力故贪等炽盛。即此贪得种姓等慢则增长炽盛。又我慢因缘生卑贱家。亦于师子虎狼中生。从此因缘则堕地狱。憍慢有如是等无量过咎。问曰。云何名多憍慢相。答曰。是人所执坚固难可与语。无恭敬心少于怖畏。喜自在行自大难教。所有薄少自以为多。喜轻蔑人此过难除。故有智者。所不应行此慢。为破一切功德故生

    疑品第一百二十九

论者言。疑名于实法中心不决定。谓有解脱耶。无解脱耶。有善不善耶。无耶。有三宝耶。无耶。是名为疑。问曰。若于树杌生疑。杌耶人耶。于土块生疑。块耶鸽耶。于蜂生疑。蜂耶阎浮果耶。于蛇生疑。蛇耶绳耶。于野马生疑。光耶水耶。如是等疑因眼识生。于声生疑。孔雀声耶为人作耶。于香生疑。忧钵香耶为和香耶。于味生疑。为肉味耶似肉味耶。于触生疑。为生缯耶为熟缯耶。意识则种种生疑。如疑是法有陀罗骠耶但求那耶。有神耶无神耶。如是等是疑不耶。答曰。若杌人等中疑则非烦恼。此不能为后身因缘。以漏尽人亦起此故。问曰。是疑云何生。答曰。若见闻知二种法故疑生。所以者何。先见二种立物。一杌二人。于后遥见与人等物则生疑。杌耶人耶。土等亦尔。二种闻者。若闻说有罪福后世。亦闻说无。是故生疑。二种知者。如天大雨而沟渠漫溢。若堰水时渠亦漫溢。如天欲雨蚁子运卵。若人发掘亦移卵去。如孔雀鸣人亦能作实事可见。如瓶不实事亦可见。如旋火轮实事不可见。如树根地下水非实事亦不可见。如第二头第三手。如是等二种见闻知法故生疑。又不审见故疑生。如远等八因缘。又二信故疑生。如有人言有后世。有人言无。俱信二人。是故疑生。又于此可疑事中乃至不见异相。是故疑生。若见异相此疑则无。问曰。云何名见异相。答曰。见闻知决定故则无有疑。于佛法中随以身证法实相时。毕竟无疑。如菩萨坐道场时说精进。婆罗门得深法现前见知诸缘尽。疑网即断灭。又若得有道理慧。此疑则断。如智者闻行因缘识。即决定知生死无始如是等。问曰。疑有何过。答曰。若多疑者。一切世间出世间事皆不能成。所以者何。疑人不能起发事业。若发则劣故不能成。又经中说。疑是心之栽檗。犹如荒田多栽檗。故异草尚不得生。况稻谷等。心亦如是。为疑根所坏。于邪事中尚不能定。况能正定。又佛说。疑名闇聚。闇聚三种。过去闇聚未来闇聚现在闇聚。此闇聚是诸我见生处。又此人设得定心则是邪定。若离佛法则无能为说正定者。又多众生怀疑至死。如说阿咤伽等五通仙人亦抱疑而死。又此疑者。若为施等福德。或无果报或少得报。所以者何。是诸福业皆从心起。是人心常为疑所浊。故无善福。又经中说。疑心布施于边地受报。所以者何。是多疑者不能一心。随时手与不能种种生恭敬心。故于边地受少果报。如波耶绥等小王。问曰。无此疑也。所以者何。疑名心数法。诸心数法念念生灭。若是非疑若非亦非疑。一心不得有是有非。故知无也。答曰。我不说念念中有疑。不决定心相续名疑。尔时心不决了是杌是人。是相续心以不信故浊。亦以邪见故不信。疑时或有或无。是不信二种。一从疑生。二从邪见生。从疑生则轻。从邪见生则重。信亦二种。一从正见生。二从闻生。从正见生信则坚固。从闻生者不能如是

    身见品第一百三十

五阴中我心名为身见。实无我故说缘五阴。五阴名身。于中生见名为身见。于无我中而取我相。故名为见。问曰。于五阴中作我名字有何咎耶。如瓶等物各自有相。是中无过。我亦如是。又若说离阴有我。是应有咎。答曰。虽不离阴说我。是亦有过。所以者何。诸外道辈说。我是常。以今世起业后受报故。若如是说。五阴应即是常。又说我者以我为一。然则五阴即应是一。是名为过。又我即是过。所以者何。以我心故有我所。有我所故起贪恚等一切烦恼。故知我心是烦恼生处。又此人虽不离阴说我。以取阴相故不行于空。不行于空故生烦恼。从烦恼生业。从业生苦。如是生死相续不断。又是人以计我故。尚不能得粗分别身头目手足。况能分别诸阴。以受我一我常故。若不分别何能入空。又若见我则畏泥洹。以我当无故。如经中说。凡夫闻空无我。生大怖畏。以我当无故都无所得。如是凡夫乃至贪求癞野干身。不用泥洹。若得空智则不复畏也。如忧波斯那经说。清净持戒人善修八圣道。命终时心喜犹如破毒器。又若说有我即堕邪见。若我是常则苦乐不变。若不变则无罪福。若我无常则无后世。自然解脱亦无罪福。故知身见是重罪也。又身见者名为甚痴。一切凡夫皆以身见乱心。深著有故往来生死。若见无我往来则断。问曰。若五阴无我。众生何故于中生我心耶。答曰。若闻人天男女名相。想分别故则生我心。亦以非因似因故生我心。所谓若无我者。谁受苦乐威仪语言。起罪福等受果报耶。又于无始生死久集我相。则成其使如瓶等相。故生我心。又于诸受阴中我心生。非不受中。故谓生我心处。此中有我。所以者何。不一切处生我心故。又以愚痴故生我心。犹如盲人得瓦石等生金玉想。又是人未得分别空智。痴故见我。如于幻梦乾闼婆城火轮等中而生有想。问曰。现见色身发毛爪等诸分各异。云何智者以之为我。答曰。有人见神。如麦如芥子等住于心中。婆罗门神白。刹利神黄。违舍神赤。首陀罗神黑。又韦陀中说。冥初时大丈夫神色如日光。若人知此能度生死。更无余道。小人则小。大人则大。住身窟中。有坐禅人得光明相。见身中神如净珠中缕。如是等人计色为我。粗思惟者说受是我。以木石等中无受故。可知受即是我。中思惟者说想是我。以苦乐虽过犹有想我心故。细思惟者说行为我以瓶等想虽过犹有思我心故。深细思者说识为我。知思亦粗。是思虽过犹故有识我心故。又于五阴中生我心。是人不能分别受等诸阴。于色心中合生我想。如于色等四法总生瓶想。以色等差别有二十分。见色是我。所以者何。色是我了法。受等所依。此诸受等系在于色。故谓色为我。有人见色住受等中。受等是不了法故。色所依止如虚空不了故。地等依止如是。二十分皆由痴生。问曰。眼等中何故不说我分。答曰。亦有。如经中说。若人说眼是我。是则不然。所以者何。眼是生灭。若眼是我我则生灭。又眼等各各相别。若说眼是我耳等非我。是则不然。若耳等复是则一人多我。色等中有差别故。可得说色是我而非受等。问曰。若说无我亦是邪见。此事云何。答曰。有二谛。若说第一义谛。有我是为身见。若说世谛无我是为邪见。若说世谛故有我。第一义谛故无我。是为正见。又第一义谛故说无。世谛故说有。不堕见中。如是有无二言皆通。如虎啖子。若急则伤。若缓则失。如是若定说我则堕身见。定说无我则堕邪见。又过与不及二俱有过。若定说无是则为过。若定说有我是名不及。故经中说。应舍二边。若第一义谛故说无。世谛故说有。名舍二边行于中道。又佛法名不可诤胜。若说第一义谛故无。则智者不胜。若说世谛故有。则凡夫不诤。又佛法名清净中道非常非断。第一义谛无故非常。世谛有故非断。问曰。若法第一义谛故无。便应是无。何为复说世谛故有。答曰。一切世间所有言说。谓业及业报若缚若解等。皆从痴生。所以者何。是五阴空如幻如炎。相续生故。欲度凡夫故随顺说有。若不说者凡夫迷闷。若堕断灭。若不说诸阴则不可化。以罪福等业若缚若解皆不能成。若破此痴语则自能入空。尔时无诸邪见。是故后说第一义谛。如初教观身破男女相。故次以发毛爪等分别身相。但有五阴。后以空相灭五阴相。灭五阴相名第一义谛。又若说世谛故有。则不须复说第一义无。又经中说。若知诸法无自体性。则能入空。故知五阴亦无。又第一义空。经中说。眼等以第一义谛故无。世谛故有。大空经中说。若言是老死。若言是人老死。若外道言身即是神。若言身异神异。是事义一而名异。若言身即是神。身异神异。是非梵行者。若遮是人老死即说无我。若遮是老死。即破老死乃至无明。故知第一义中无老死等。言生缘老死皆以世谛故说。是名中道。又罗陀经中说。佛语罗陀。色散坏破裂令灭不现。乃至识亦如是如石壁等。以不实故可令不现。诸阴不现。亦以第一义无故。随诸阴相在则我心不毕竟断。以因缘不灭故。如树虽剪伐焚烧乃至灰炭。树想犹随。若此灰炭风吹水漂树想乃灭。如是若破裂散坏。灭五阴相。尔时乃名空相具足。又如经说。罗陀汝破裂散坏分析众生。令不现在。是经中说五阴无常众生空。无先经中说。五阴散灭是为法空

    边见品第一百三十一

若说诸法或断或常。是名边见。有论师言。若人说我若断若常。是名边见。非一切法。所以者何。现见外物有断灭故。经中说。有见名常无见名断。又身即是神名为断见。身异神异是名常见。又死后不作名曰断见。死后还作名为常见。死后亦作亦不作。是中所有作者名常。所不作者名断。非作非不作亦如是。问曰。是第四不应名见。答曰。是人于世谛中亦无人法。故名为见。常无常边无边等四句亦如是。又经中说。六触入尽灭。有异余即为常。无异余即名断。又若见我先作后当更作。是名常见。我先不作后不更作。是为断见。又邪见经说。人身七分地水火风苦乐寿命。若其死时。四大归本根归虚空。又说。以刀轮害众生。积为肉聚无杀生罪。是名断见。及梵网经中说断见相。若言有后世作者即是受者。是名常见。问曰。断常见云何生。答曰。随以何因缘说死后还作是因缘。故生常边见。随以何因缘说死后不作是因缘。故生断灭见。问曰。此见云何断。答曰。正修习空则无我见。我见无故则无二边。如炎摩伽经中说。若一一阴非人。和合阴亦非人。离阴亦非人。现在如是不可得。云何当说阿罗汉死后不作。故知人不可得。人不可得故。我见及断常见亦无。又见诸法从众缘生。则无二边。又如说见世间集则灭无见。见世间灭则灭有见。又行中道故则灭二边。所以者何。见诸法相续生则灭断见。见念念灭则灭常见。又说。五阴非即是人。亦不离阴是人。故知非常非断。能得异身故不得为一。俱是众生故不得为异。又五阴相续故有众生生死。是中不得言即。以是相续异故亦不得言异。以相续中可说一故。又从此阴彼阴异故不得言常。从自相续因缘力生。故不得言断

    邪见品第一百三十二

若实有法而生无心。是名邪见。如言无四谛三宝等。经中说。邪见谓无施无祠无烧无善无恶无善恶业报无今世无后世无父母。无众生受生世间。无阿罗汉正行正至。自明了证此世后世。知我生尽梵行已成所作已办。从此身已更无余身者。施名为利他故与。祠名以韦陀语言因天故祠。烧名于天祠中烧苏等物。善名能得爱果三种善业。恶名得不爱果三种恶业。善恶业报名今世善恶名等。及天身等后世报。今世名现在后世名未来。父母名能生。众生受生名从今世至后世。阿罗汉名尽烦恼者。谓无此事故名邪见。又众生垢净有知见无知见。皆无因缘。又无力无勇及此果等。名为邪见。取要言之。所有倒心皆名邪见。如无常常想苦为乐想。不净净想无我我想。非胜胜想胜非胜想。净道非净想。非净道净想。无中有想有中无想。如是等诸颠倒心。谓阿毗昙中五见。梵网经中六十二见。皆名邪见问曰。是邪见云何生。答曰。以痴故生。染着非因以因。故邪见生。又以染着乐因故说无苦。又失空道故说无苦。以无受苦者故。若说世间万物无因无缘。或说因自在等不因于爱。是名无集。随以何因缘说无泥洹。或异说泥洹是名无灭。若无泥洹道何所至耶。或说更有异解脱道。谓断食等。是名无道。无佛者是人言。诸法无量云何一人能尽知耶。或生是念。佛为人中之尊。以无人故。当知无佛无烦恼尽。故名无法。无有正行得此法者。故曰无僧。以布施现果不可得故。谓无布施。又有经书说无布施。比知亦不决定。世间有好布施者而更贫穷。有悭贪者而得富贵。以是等因故说无施。无祠无烧亦如是。若火烧物为灰。是中有何等果。无善恶无善恶业报者言。若神是常则无善恶。若神无常则无后世。无后世故则无善恶。无善恶业报。无今世者分析诸法终归都无。无后世者。随以死后不作因缘故。谓无后世。无父母者。亦以分分析之令尽。又说。如因粪生虫粪非虫父母。又头等身分非即父母身分。又诸法念念灭故。以何为父母耶。无众生受生者。众生法无故今世尚无。况能受身。又思惟言。是众生为是身耶。为非身耶。若是身者。眼见此身。埋则为土烧则成灰。虫食为粪故无受生非身则有二种。若心若离心。若是心者。心法生灭念念不住。况至后身。若离心则不计我。于他心中尚不计我。况无心处。是故无受生者。无阿罗汉者。是人见一切人。饥则求食寒则求温。热则求凉。毁害则嗔。敬养则喜。故无有能尽烦恼者。又经书或说。无阿罗汉。随逐此经故生是见。垢净等无因缘者。是人见此垢法自然而生。又有垢者即体是垢。故说无因。知见无知见亦如是。无力无勇者。见一切众生皆假因缘。或有言。由自在天能有所作。又见众生属业因缘不自在故。说无力无勇及此果。无常常想者。随以何因缘破念念灭。以是因缘故生常见。又说。诸法灭时。还为微尘。或言。还归本性。又诸法虽灭。以忆想故能受苦乐。则生常想。又说神是常音声亦常。以是等缘故生常想。苦谓乐者。随以何因缘说言有乐。如先三受品中说。以是因缘故生乐想。不净净想者。以染着身故。眼见不净而生净想。或作是念。我得人根见此人身不净。更有众生以之为净。如是等缘故生净想。无我我想者。见阴相续生。而取一相。以之为我。又如先生身见因缘。以是因缘故生我想。非胜胜想者。是人于富兰那等外道师中。而生胜想。又梵王自说我是大梵天王造万物者。如是等。有人言。若人具足受五欲乐。是名胜法。又言。若人离欲入初禅乃至四禅。是最胜法。又说。世间现见众生中。婆罗门为尊。非现见众生中天为最尊。是非胜胜想。胜非胜想者。一切众生中佛为最胜。有人于中不生胜想。作如是言。是刹利种。又学道日浅。又谓。佛法言不巧妙。文辞烦重不如韦陀。此不名胜。众僧中有四品人。是故不胜。如是等胜中生非胜想。非净道中净道想者。若人言以灰水等洗令人清净。又说。生死尽讫名清净道。又但贪着持戒梵行供养天等。亦说。由自在天故得清净。或说苦行本业尽故名清净道。又断荤辛及苏酪等。故得清净。又净洗浴以韦陀语咒。然后饮食名清净道。以如是等种种邪道而得解脱。不以八直为清净道。有中生无想者。若法世谛中有亦说为无。无中生有想者。若说有陀罗骠有有分者。亦说有数量等求那。亦说总相别相及集。亦说世性等无物为有。如是等因缘生颠倒心皆名邪见。于此邪见中别四种见。余残重者皆名邪见。问曰。是邪见云何断。答曰。经中佛说。正见能消邪见。问曰。正见云何生。答曰。若见闻比知。正决定故则正见生。又善修正定则正见生。如经说。摄心能如实知非散心也。问曰。是邪见有何等过。答曰。一切过咎及诸衰恼皆由邪见。此人谓无罪福及善恶业报。故现在无诸好事。况未来世。如是破善恶人名断善根。决定当堕阿鼻地狱。如阿毗昙六足中说。杀是人罪轻杀虫蚁。又此邪见人污染世间。为多减损众生故。生如毒树生为恼害故。又此人所起身口意业。皆为恶报。如经中说。邪见人所起身口意业欲嗔思念。皆为恶报。如种苦瓠拘赊毒枝必害蔓陀树种是中。所有地种水火风种皆为苦味。以种苦故。如是邪见人诸余心心数法。以邪见故皆得恶报。是故此人。虽有施等终无好果。以先为邪见心所坏故。是人所作不善皆是增上。以久集恶心故。又以戒法故能制非法。是人无善恶故无所禁忌。深为放逸行不善法。定破惭愧二种白法。与畜生无异。又若人言无善恶。是人心中常怀不善。又是人无有能受善法因缘。所以者何。是人不能亲近善人。不闻善法。恶心易起。善心难生。以易起恶故无善因缘。如是渐积则断善根。又此邪见人名在难处。如地狱众生不任得道。如此人虽生中国具足六根能别好丑。亦不任得道。又此邪见人无恶不造不忌轻重。又少作不善亦堕地狱。以重罪心起是业故。如业品中解地狱业。以是因缘此人所作皆为地狱。又此人不能尽罪恶业。以不善法常在心故。又此人展转地狱难得解脱。所以者何。断善根人若善根未相续间。终不脱地狱。是人邪见在心中故。善根云何得相续耶。又邪见人名不可治。犹如病人死相已现。虽有良医不能复治。是人亦尔。无余善故。乃至诸佛亦不能治。是故必堕阿鼻地狱

    二取品第一百三十三

于非实事中生决定心。但是事实。余皆妄语。是名见取。及先说非胜法中定生胜想。亦名见取。问曰。见取有何过。答曰。是人得少功德自以为足。又是人唐劳其功。所以者何。是人于非善事中生妙善想。勤加精进。以是因缘后则心悔。又是人为智者所笑。以非胜中生胜想故。又若人非胜谓胜是愚痴相。犹如盲人于瓦砾中生金银想。为有目者之所轻笑。见取有如是等过。若人舍智。以洗浴等戒。望得清净名为戒取。问曰。不以戒故得清净耶。答曰。以智慧得清净戒。为智慧根本。问曰。戒取有何过。答曰。所说见取之过。以下事为足等。皆是此过。又戒取因缘唐受诸苦。谓受寒热卧灰土木刺棘等上。投渊赴火自坠高等。后世亦受剧苦果报。如经中说。持牛戒若成则还为牛。若不能成则堕地狱。又此人从冥入冥。以受此法现世得苦后亦苦。故又此人得深重罪。所以者何。以非法为法毁坏真法。亦谤行正法者。令多众生背真净法。堕罪中故。积集大罪。故受阿鼻地狱果报。宁止不行勿行邪道。所以者何。若本不行易令行道。邪行败心故难入道。又虽是怨贼不能令人衰恼如生邪见。所以者何。怨贼不能污人。如随逐邪见。受外道所行种种邪戒裸形无耻。灰土涂身拔发等故。又此邪见人皆失世间一切利乐。现在失五欲乐。后失生善处乐。及泥洹乐。若人求乐得苦。求解得缚。不名狂耶。所以者何。以施一餐因缘可得生天。此人行邪行故。虽施身命无所利益

    随烦恼品第一百三十四

心重欲眠名睡。心摄离觉名眠。心散诸尘名掉。心怀忧结名悔。所谓不应作而作。应作而不作。曲心诈善名谄。谄心事成名诳。自作恶不羞名无惭。众中为恶不羞不戁名无愧。心随不善名放逸。实无功德示相令人谓有名诈。现奇特为利养故。口悦人意名罗波那。欲得他物表欲得相。如言此物好等名为现相。若为呰毁此人故称赞余人。如言汝父精进汝不及也。名为憿切。若以施求施。言是施物从某边得。如是等名以利求利。若人有喜睡病。名单致利。若得好处行道因缘具足。而常愁忧名为不喜。若人频申身不调适。为睡眠因缘名为频申。若人不知调适饮食多少。名初不调。若不堪精进名为退心。若诸尊长有所言说。不敬不畏名不敬肃。喜乐恶人名乐恶友如是等名随烦恼。从烦恼生故

    不善根品第一百三十五

三不善根谓贪恚痴。问曰。憍慢等亦应是不善根。何故但说三耶。答曰。一切烦恼皆是三种烦恼分。慢等是痴分故不别说。又三种烦恼多在众生心中。慢等不尔。又一切未离欲者乃至蚊蚁。是三烦恼皆在心中。憍慢等不如是。又贪是嗔不善根。违失所贪则随生嗔。痴为二本。所以者何。若人无痴则不贪嗔。又经中说。十不善业有三种。从贪嗔痴生。不说从慢等生。又有三种受。更无第四。是三受中三烦恼使。若别有慢等于何受中使。是事实不可说。当知此三是诸烦恼本。问曰。何故乐受中贪使。对曰。现见此中生故。如经中说。人得乐触生喜。若触则不喜。是人于诸受中集灭味过出。不如实知故。不苦不乐受中无明使使。所以者何。是人于无色界系诸阴相续不如实知故。则于是中生寂灭想若解脱想若不苦不乐想若我想。是故说不苦不乐中痴生。问曰。是诸使为法中使。众生中使耶。答曰。因法生众生心。随众生心则受诸受随诸受贪等烦恼使。故知因法生使而使众生。何以知之。若众生未断此使。则此使使。若断则不复使。若法中使。法常有故使应常使。常不应断。又非众生数亦应有使。若然者。若以人使故壁等有使。以人识故壁等亦应有识。是事实无。然则无阿罗汉。余人使故有使。问曰。是使未断则使。断则不使。答曰。二种使使。一缘使。二相应使。是使若断若不断。即是缘及相应。何故说断则不使。若尔更应说第三使相。以不可说故当知无也。又使能缘异地而不使。故知但众生中使。非法中也。问曰。二种使使。一缘使。二相应使。是众生诸使非缘非相应。云何当使。答曰。是事先答。诸使因法生而使众生。如阿毗昙身中说欲界众生几使使等。若不使众生云何有如是问。问曰。若使使众生。经中说乐受中贪使。此则相违。答曰。是不尽语。应言乐受中生贪而使众生。问曰。是贪亦因色等生。此中何故但说因乐受生。答曰。以忆想分别欢喜等故贪生。非但从色等生。问曰。因苦受亦生贪。如说乐者不求苦者多求。何故但说从乐受生。答曰。不以苦受故贪生。是人为苦所恼。故于乐受中生贪。问曰。不苦不乐受中亦贪使使。何故但说乐受中耶。答曰。是人以不苦不乐受为乐故贪生。故说乐受中贪使。以此三受中三烦恼使。故但说三

    杂烦恼品第一百三十六

问曰。经中说三漏。欲漏．有漏．无明漏。何者是。答曰。欲界中除无明。余一切烦恼名为欲漏。色无色界有漏亦如是。三界无明名无明漏。问曰。诸漏云何增长。答曰。以下中上法故。渐次增长。又得色等胜缘故诸漏增长。问曰。是三漏云何说为七漏。答曰。实漏有二种。见谛断是诸漏根本。思惟断是诸漏果。五助漏因缘合说为七。即此烦恼。佛随义故说三漏四流四缚四取四结等。问曰。四流。欲流有流见流无明流。何者是。答曰。除见及无明。余欲界一切烦恼是名欲流。色无色界有流亦如是。诸见名见流。无明名无明流。问曰。流中何故别说见流。漏中不说耶。答曰。外道多为见所漂流。是故流中别说。以能漂没故名为流。能系三有故名为缚。问曰。四取。欲取见取戒取我语取。何者是。答曰。无我故但取是语名我语取。若人有我见即生二边。是我若常若无常。若定言无常则取五欲。以无后世故染着现在乐。若定言常。钝根者则取持戒望后世乐。小利根者作如是念。若神是常则苦乐不变则无罪福。故起邪见。如是但因我语故生四取。问曰。四结。贪嫉身结。嗔恚身结。戒取身结。贪着是实取身结。何者是。答曰。贪嫉他物他人不与则生嗔心。以鞭杖等取。是在家人斗诤根本。亦名随乐边。若人持戒欲以此戒而得清净。即谓是实余妄语。是见则随。是出家人诤讼根本。亦名随苦边。五阴名身。是四结要须身口成。故名为身结。又有人言。是四法能系缚生死。故名为结。问曰。五盖。贪欲嗔恚睡眠掉悔疑。是事云何。答曰。人贪着诸欲故嗔恚随逐。如经中说。从爱生恚及嫉妒等烦恼鞭杖等恶业。皆以贪欲故生。是人身心为贪恚所坏。多事疲劳则欲睡眠。是人睡眠小息。贪恚还来散乱其心。不得禅定心。随外缘故生掉戏。不净业人心常忧悔。以散心悔心故心常生疑。有解脱不如王子语阿夷罗曰沙弥。问曰。何故名盖。答曰。贪欲嗔恚能覆戒品。掉悔能覆定品。睡眠能覆慧品。有人为除此盖故。说是善是不善。是人于中生疑。为有为无。此疑成故能覆三品。是五盖三法力强。故独名为盖。二盖力薄故二法合成。又此二盖生因缘俱。是故合说。睡眠因缘五法。谓单致利不喜频申食不调心退没。掉悔因缘四法。谓亲里觉国土觉不死觉。忆念先所戏乐言笑。是名生因。药亦同故。睡眠以慧为药。掉悔以定为药。覆亦同故。二合为盖。此五法或是盖或非盖。欲界系不善名为盖。余不名盖。五下分结。贪欲嗔恚戒取。以堕下故名为下分。如持牛戒成则为牛。不成则入地狱。碍障离欲身见。是四根本。是名为五。又以贪恚故不出欲界。身见不出我心。戒取不出下法。疑不出凡夫。又贪欲嗔恚故不过欲界。若过还为所牵。余三不过凡夫。故名下分。五上分者。掉戏坏禅定故心不寂灭。是掉戏随取相憍慢故生。是取相心从无明生。故有色染无色染。此五结学人以之为上行。故名上分。是五结于学心中说。不为凡夫。问曰。掉戏何故于色无色界说名为结。欲界中不说耶。答曰。彼中无粗烦恼故掉戏明了。又此掉戏于坏定有力。故说为结。断此上分则得解脱。有人色无色中生解脱想。为遮此故说有上结。五悭者。住处悭家悭施悭称赞悭法悭。住处悭者。独我住此不用余人。家悭者。独我入出此家不用余人。设有余人我于中胜。施悭者。我于此中独得布施。勿与余人。设有余人勿令过我。称赞悭者。独称赞我勿赞余人。设赞余人亦勿令胜我。法悭者。独我知十二部经义。又知深义秘而不说。问曰。是五悭有何等过。答曰。是住处等多人共有。是人既舍自家。于共有中更生悭吝。是弊烦恼。又此人于解脱中终无有分。所以者何。是人于共有法尚不能舍。何况能舍自五阴耶。又此人堕饿鬼等诸恶处生。又此人以利养覆心。则生憍慢轻余善人。故堕地狱。又坏他施故。若得人身则为贫穷。又以悭心断施者功德受者施物。故得重罪。若悭吝法得盲等罪。所谓生盲及多恶中生。不得自在退失圣胎。三世十方诸佛怨贼往来生死。常为愚痴。善人远离。离善人故无恶不起。恶名三种恶。恶大恶恶中恶。恶名杀盗等。大恶名自杀亦教人杀自悭亦教人悭。恶中恶名自吝法亦教人吝法。是人吝法令多人堕恶。亦是灭佛法道。如经中说。住处悭有五过。未来善比丘不欲令来。已来则频蹙不喜。念欲令去藏僧施物。于僧施物生我所心。家悭有五过。以贪着家故则与白衣共同忧喜。断白衣为福受者得施。断此二故即生此家为厕中鬼。施悭有五过。常乏资生破二人利。訾毁善人心常忧恼。称赞悭有五过。闻赞余人心常扰浊。于百千世常无净心。呵毁善人自高己身。卑下他人常被恶名。又一切悭总有斯过。谓积聚多物畏怖大众。多人憎恶心常扰浊。身常孤茕生下贱家。如是无量是五悭过。五心栽。疑佛疑法疑戒疑教化。若有比丘。为佛及诸大人所称赞者。是人则以恶口谗刺。是名为五。疑佛者作如是念。佛为大。富兰那等为大耶。疑法者。佛法为胜。违陀等为胜耶。疑戒者。佛所说戒为胜。鸡狗等戒为胜耶。疑教化者。阿那波那等教法为能至泥洹不。谗刺者。以嗔恚心无畏敬心侵恼善人。是人以此五法败坏其心。不任种诸善根。故名心栽。问曰。是人何故于佛等生疑。答曰。是人不能多闻。是故生疑。若多闻者疑则薄少。此人愚痴无智不知分别佛法异法。是故生疑。又此人于法不能得味。是故生疑。又不闻不读违陀等经。闻人称赞故生贵心。又是人世世邪疑偏多。心常浊故。于佛等疑。如佛侍者苏那刹多罗。又此人与多邪见人共同事业。故令生疑。又此人读诵违伽陀和罗那等邪见经。故坏正智慧。是故生疑。又此人于诸法义喜生邪念。不能得造经者意。是故生疑。又此人始终不能得自利功德。以此缘故于佛等生疑。五心缚。若人不离身欲故贪着。身不离五欲故贪着欲。又与在家出家人和合。于圣语义中心不喜乐。得少利事自以为足。是中四缚因贪欲起。若人不离内身欲故。于外色等欲中生着。是故乐与众闹和合。以乐愦闹故。于圣语义示寂灭法中。心不喜乐。是故于持戒多闻及禅定等少利事中。自以为足。以贪着此少利事故亡失大利。智者不应贪着小事以妨大利。是人若离八难得人身难。故应一心勤加精进。又凡夫法不可信也。若离此具足因缘或有余缘。终不复能得入圣道。又不贪小利则能得出家果报。亦死时不悔。亦能自利利他。又此人于功德中尚不贪着。何况恶法。故名正行。又凡夫过咎所不能染。问曰。何谓凡夫过耶。答曰。经中说。凡夫应二十种自折伏心。应作是念。我但形服异俗空无所得。我当以不善而死。当堕大怖畏海。当之畏处。不知无畏处亦不知道。不得禅定数受身苦。难离八难怨贼常随。诸道皆开未脱恶道。常为无量诸见所缚。于五逆罪未能防制。无始生死未有边际。不作不得罪福。善恶不得相伐。不为善法终无安隐。所作善恶终不亡失。我当以不调至死。是二十法所不能污。又所应作者是人已作。故心不悔。若贪著者。则不能成在家及出家法。是故不应贪着小利。七使。问曰。诸烦恼何故名使。答曰。生死相续中常随众生。故名为使。犹如乳母常随小儿。如疟病未脱。如负债日息。如鼠毒未除。如热铁黑相。如谷子牙。如自要奴券。如断事证人。如智慧渐积。如业常集。如焰常续。如是次第相续增长。故名为使。问曰。是使为心相应。为不相应。答曰。心相应。所以者何。所说贪等使相。是诸使相与喜相应。若喜心不相应。是事不然。是喜若在乐受中名为贪使。又贪名染着。心不相应中无染着义。故知诸使与心相应。问曰。不然。诸使非心相应。所以者何。经中说。小儿淫心尚无。况能淫欲。亦为欲使所使。又说。不思不分别。亦有缘识住故。又经中说。身见断时诸使俱断。又圣道烦恼不得一时。是故圣道生心不相应使断。若不尔者。圣道何所断耶。又若无心不相应使。凡夫学人若在善心无记心时。便应是阿罗汉。又使为缠因。从使生缠。得缠则使炽盛。故知诸使非心相应。又若人在善无记心。亦名有使。若无心不相应使者。何故名有使耶。故知诸使非心相应。答曰。不然。汝言小儿无欲亦有贪使。是事不然。小儿未得除贪药。故贪欲未断故为贪使使。如鬼病人虽不发时。亦名鬼病人。所以者何。以其未得咒术药草断病法故。亦如四日疟病虽二日不发。亦名疟病人。亦如鼠毒未差除。故雷声则发。如是于何心中未得除使药。故名为不断。余问亦以总答。汝言不思不分别亦有缘识住故者。亦以未断使故。汝言身见与使俱断者。汝以缠为心相应未生时亦断。使亦如是。虽圣道时无亦名为断。以得相违法故。汝言道与烦恼不一时者。亦以未断故说言有。汝言凡夫学人。若在善无记心应是阿罗汉者。阿罗汉已断。此人未断故。如人不受断肉法。虽不食肉不名断肉。又有无明邪念邪思惟等故。所未断烦恼则生。阿罗汉无此因故不同余人。又汝言得缠使则炽盛。是事不然。诸烦恼以下中上法故炽盛。非得缠故。汝言人在善无记心名有使者。亦以未断故名有使。以是等缘故知贪等诸使非不相应。八邪道邪见乃至邪定。以不如实知颠倒见故名为邪见乃至邪定。问曰。正命邪命不离身口业。何故别说。答曰。邪命出家人所难断。是故别说。邪命者。以谄诳等五法能得利养。故曰邪命。取要言之。诸出家人所不应作资生之业。谓王使贩卖活病等业。及所不应取众生钱谷等。若取皆名邪命。又比尼所制以此自活皆名邪命。如经中说。优婆塞不应五种贩卖。问曰。何以济命。答曰。如法乞求。以此活命不应邪命。所以者何。以心不净毁坏善法。不任修道故。又行道者应作是念。入佛法中为行道故。不为活命。是故乐善法者应行净命。又比丘应住比丘法中。若行邪命非比丘法

    九结品第一百三十七

爱等九结。问曰。何故于诸见中别说二取。答曰。戒取难免离故。犹如浮木入洄澓中难可得出。是人亦尔。作是念我以是持戒当生天上。为此故受投渊赴火自坠高等种种诸苦。又世间人于戒取中不见其过。故佛说为结。又依此戒取能舍八直圣道。又此非正道非清净道。名随苦边。又戒取是出家人缚。诸欲是在家人缚。又戒取者虽复种种行出家法。空无所得。又戒取者。今不得乐后受大苦。如持牛戒成则为牛败则堕地狱。又因此戒取能谤正道及行正道者。又戒取是诸外道起憍慢处。作如是念。我以是法能胜余人。又以戒取故。九十六种有差别法。又戒取是粗见故多众生行。智慧道微妙难见。世间不知行之得利。又此见能牵人心。故愚痴者多行此法。又此名重恶见。以逆正道行非道故。见取者。所以贪着邪法不能舍离。是见取力。又以见取力故诸结坚固。问曰。帝释问经中。何故但说天人有悭嫉二结。答曰。是二烦恼最是鄙弊。所以者何。见他众生饥渴苦恼。以悭心故不能矜济。见从他得亦生嫉妒心怀恼热。以是因缘堕贫贱丑陋无威德处。又释提桓因。是二结偏多数来恼心。故佛为说。又此二结是重罪因缘。所以者何。因此二结起重恶业故。又三毒中贪恚能起重罪。贪恚盛故起此二结。又此二结能恼男女。又难舍离。所以者何。若深修善心乃能永断嫉妒。深修布施。然后尽断悭心。以不见业报而能舍所重物。是为甚难。如人见子得胜己事心尚难喜。况于怨贼。以此二结依憎爱故深难除断。以此等缘故佛独说

成实论卷第十成实论卷第十一

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    杂问品第一百三十八

论者言一切烦恼多十使所摄。是故当因十使而造论。十使者。贪恚慢无明疑及五见。问曰。十烦恼大地法。所谓不信懈怠忘忆散心无明邪方便邪念邪解戏调放逸。是法常与一切烦恼心俱。此事云何。答曰。先已破。相应但心法一一生。是故不然。又此非道理。何以知之。或有不善心与不善信俱。或有不善心而无信。精进等亦如是。故知非一切烦恼心中有此十法。又汝说睡掉在一切烦恼心中。是亦不然。若心迷没尔时应有睡。不应在调戏心中。有如是等过。问曰。欲界中具十烦恼。色无色界除嗔。余残一切。是事云何。答曰。彼中亦有嫉妒等。何以知之。经中说。有梵王语诸梵言。汝等勿诣瞿昙沙门。汝但住此自得尽老死边。是名嫉妒。有嫉妒故亦应有嗔。又经说。梵王捉一比丘手牵令出众。谓言比丘我亦不知。四大何处无余尽灭。如是以谄曲心诳诸梵众。是名谄曲。若言我是尊贵造万物者。是名憍逸。如是等彼间亦有。有如是等恶烦恼故。当知亦有不善。有论师言。若贪父母及和尚阿阇梨等。是名善贪。贪他物等名不善贪。不为损益他人。名无记贪。嗔不善法及恶知识等。是名善嗔。若嗔善法及嗔众生。名不善嗔。若嗔非众生物名无记嗔。若依慢断慢是名善慢。轻他众生名不善慢。无明等亦如是。又论师言。若善不名烦恼。问曰。欲界身见说名无记所以者何。若身见是不善。一切凡夫皆生我心。不可令尽堕地狱故说无记。是事云何。答曰。身见是一切烦恼根本。云何名无记耶。又此人堕为他人说有神我。尔时云何当名无记。边见亦如是。问曰。若转人邪见令堕疑中。此人是不善耶。答曰。此人非是不善。所以者何。宁堕疑中不入邪定。问曰。有人言。欲界系烦恼一切能使欲有相续。色无色界系亦如是。是事云何。答曰。但爱能令诸有相续。以先喜后生故。又说爱为苦集。亦说爱乐饮食贪欲等故随处受生。邪见等中无如是义。经中虽说慢因缘生。亦先慢后爱故生。嗔亦如是。故知皆以爱故诸有相续。问曰。诸烦恼中几见谛断几思惟断。答曰。贪恚慢无明二种。见谛断思惟断。余六但见谛断。问曰。学人亦有我心。故知不示相身见分学人未断。答曰。是慢非见。见名示相。问曰。有人言。悭嫉悔谄曲等。但思惟断。是事云何。答曰。是皆二种。亦见谛断亦思惟断。何以知之。如尼延子等见佛弟子得供养。故生嫉妒心。是嫉妒见道则灭。故知见谛所断。有人先于佛弟子悭惜不施。得见道故便能施与。是悭则见谛断。如苏那刹多罗等悔亦见谛断。如须陀洹堕地狱等因缘。及第八世受身谄曲等。亦见谛断。问曰。诸烦恼几见苦断。几见集灭道断。几思惟断。答曰。先说见谛所断六使四种。见苦断见集灭道断。余四使五种。问曰。身见边见但见苦断。戒取二种。见苦见道断。是事云何。答曰。诸烦恼实见灭谛时断。是故身见等不应但见苦断。又身见于四谛中谬。五阴无常从因缘生。我非无常不从因生。五阴有灭而我无灭。道与我见相违。是故身见四种所断。边见亦四种断。所以者何。行者见苦从集生则灭断见。见由道得灭则灭常见戒取亦四种。有因有果是故见苦时。知戒是苦不以此得净。是见苦断。知戒是苦因不以此得净。是见集断。以邪见谤泥洹谓以此见得净。是见灭断。以此谤道是见道断如见取依邪见故四种。戒取亦应如是。问曰。若尔者不名九十八使。答曰。诸使随地断。不随界故不限九十八也。问曰。贪慢及除邪见。余四见皆三根相应。除苦根忧根。嗔恚亦三根相应。除乐根喜根。无明五根相应。邪见疑四根相应除苦根。嗔覆罪悭嫉但忧根相应。是事云何。答曰。先已破无相应。故后当说五识中无烦恼故。又汝法中贪喜根相应悭则不尔。是无因缘悭是贪分故。如是憍慢不与忧根相应。亦无因缘。故知汝等所说皆自忆想分别。问曰。有人言见苦所断五见疑及贪恚慢。不相应无明。及集谛所断邪见见取疑及贪恚慢。不相应无明。是名遍使余非遍。此事云何。答曰。一切是遍。所以者何。一切皆共相因相缘故。又于己邪见中生贪。所谓无苦乃至无道。贪着此见而以自高。若闻说苦则生憎恚。又此贪能缘灭谛。嗔亦能憎恚泥洹。亦以泥洹生自高心。道亦如是。当知余使亦有能遍。又欲界系烦恼能缘色界。如以贪喜乐以嗔憎恶。以彼法自高亦以之为胜非欲界也。如欲界烦恼能缘色界色界见等烦恼亦能缘欲界果。无色界亦如是。又此烦恼皆能总相别相。所以者何。贪亦能总相染四天下。又长爪经说。一切忍是贪。一切不忍是嗔。一切不忍是贪。一切忍是嗔。亦以此烦恼自高。是烦恼皆能起身口业。所以者何。经中说。生如是见说如是事。谓有神等。又此一切烦恼皆在第六识中。五识中无。所以者何。想行第六识。故一切烦恼皆从想生。若不尔身见等亦应在五识中。所以者何。以眼见色谓我能见。疑慢等亦如是。问曰。经中说六爱众。云何言五识中无烦恼耶。答曰。如六意行皆在意识中。但以眼等开导。故名六意行。是事亦尔。又意识中所有分别因缘五识中无。故知五识中无烦恼也

    断过品第一百三十九

问曰。有人言。诸烦恼九种。下中上。下下下中下上。中下中中中上。上下上中上上。智亦九种。是烦恼先断上上。后断下下。以下下智断上上烦恼。乃至以上上智断下下烦恼。是事云何。答曰。以无量心断诸烦恼。所以者何。经中佛说。譬如巧匠手执斧柯。眼见指处。虽不能分别日日所尽若干分数。但见尽已乃能知其尽。比丘亦尔。修行道时。虽不分别知今日所尽若干诸漏。昨日所尽若干分数。但尽已乃知漏尽。故知以无量智。尽诸烦恼。非八非九问曰。依止何定断何烦恼。答曰。因七依处能断烦恼。如经中佛说。因初禅漏尽。乃至因无所有处漏尽。又离此七依亦能尽漏。如须尸摩经中说。离七依处亦得漏尽。故知依欲界定亦得尽漏。问曰。见谛所断烦恼。不应依无色定断。以此行者坏色相故。答曰。是事先答。谓无色定能缘于色。问曰。为先从初禅次第离欲至二禅等为一时耶。答曰。应当次第。以离初禅欲生二禅等故。问曰。欲界中亦有次第耶。答曰。诸烦恼念念灭。故亦应次第。又如炎摩天抱则成欲。兜率陀天执手成欲。化乐天以口说成欲。他化自在天相视成欲。当知欲界烦恼亦渐次尽。有人言。以福德因缘于彼中生。不以断烦恼故。以所欲妙故成有差别。又根钝故抱乃成欲。根转利故视则成欲。问曰。有人言。思惟所断烦恼渐次断。先欲界系后色无色界系。见谛所断则一时断。是事云何。答曰。随谛所断而实一切烦恼见灭谛断。是事先说。所谓见谛所断身见等烦恼。皆见灭谛断。从暖法来。以无常等行观五阴相。始断烦恼见灭乃尽。问曰。观欲界系苦能断欲界结。集亦如是。如欲界乃至非想非非想处亦如是。观欲界灭能断三界结。道亦如是。是事云何。答曰。灭智能断烦恼。是故汝说不然。问曰。经中说。观五阴无常等故得须陀洹果。乃至阿罗汉果。汝云何言但观灭谛断烦恼耶。答曰。是观五阴智生灭合观。故能断结使。如经中说比丘观是色是色集是色灭。又当说见法识法则烦恼断。可知见灭谛故诸烦恼尽。又五阴是苦于中生诸烦恼。若见五阴灭以为寂灭安隐。如是则苦想具足。故知见诸阴灭则烦恼尽。如说因诸法无体性依一舍心断。无体性即是灭。若行者见色无体性乃至识无体性。则深得离。又三解脱门皆缘泥洹。以此解脱门能断烦恼。无余方便。故知但无为缘道能断烦恼。是故汝所说断烦恼法。是事不然。论者言。诸烦恼有如是等无量分别门。以求解脱者应当知。所以者何。以知是缚过故得解脱。如人识怨故能远离。如知崄道故能得避。烦恼亦如是。又烦恼缚甚为微细过。于毗摩质多罗阿修罗王缚。乃至有顶众生常为恼缚。是故应知其过。又众生乃至有顶犹还退堕。皆以不能见知烦恼过故。又不断结故生增上慢。自谓已断。后则疑悔。是故应知诸烦恼过。勿为所诳。又若众生舍离净妙泥洹之乐。反贪鄙弊欲乐有乐。皆是诸烦恼过。若断烦恼则得大利。故应知见诸烦恼过有障解脱法所谓烦恼。若不断烦恼终无解脱因缘。所以者何。诸烦恼是身因缘。随烦恼有身随身有苦。是故求离苦者。应勤精进断诸烦恼

    明因品第一百四十

问曰。烦恼为身因缘是事应明。所以者何。有诸外道不信此事。或言是身无因无缘。犹如草木自然而生。或言万物是大自在等诸天所生。或言万物从世性生。或言微尘和合故生。说如是等。是故应明。答曰。从业有身是事先成。是业从烦恼生。故以烦恼为身因缘。问曰。云何知因烦恼有业。答曰。随假名心名为无明。假名心者能集诸业。故知烦恼因缘有业。又阿罗汉诸业不集不成。故知诸业由烦恼成。如经中佛说。若人得明舍离无明。是人能起福业罪业无动业不。不也世尊。又无无漏业。故知但随假名者能起诸业。无漏心不随假名故不起业。又学人无行如经说。学人还而不行。灭而不作。作相是行。行名为业。又无漏心非行相故。无无漏业。是故一切诸受身业。皆因烦恼生。又断烦恼者不复受生。故知有身皆因烦恼。问曰。一切众生皆以无烦恼。生后时乃起。如人生时无齿其后乃生。答曰不然。有烦恼者随所有相。谓啼哭等生时现有。故知皆与烦恼共生。又现见众生多生厕等中。不生槃石等中。当知贪着香味等故。于是中生。故知由烦恼生。问曰。地狱等中不应得生。所以者何。无人贪乐地狱等故。答曰。众生以痴力故于颠倒心生。将命终时遥见地狱。谓是华池以贪着故则于中生。如经中说。若人迮闹中死欲得宽处于鸟中生。若渴死者生为水虫。若冻死者生热地狱中。热渴死者。生寒冰地狱中。若贪着淫欲生鸟雀中。若贪饮食则生为死尸中虫。又因所贪着故造诸恶。诸恶因缘强受果报。又贪着身故诸业能生果报。所以者何。贪着己身愚痴力故。憍慢等诸烦恼生。从此能集成业。以业力故生诸道中。问曰。若以烦恼因缘有身。断烦恼者五阴不应复得相续。答曰。是身本由烦恼故生。烦恼虽尽以势力故身犹不断。如以杖转轮虽暂废杖轮犹不止。问曰。若以先业烦恼势故有身。断烦恼者以先业烦恼势故。亦应受身。答曰。要以取相故识能住。是人先业势尽。今善修无相解脱门。故不受后身。又如热石上诸种不生。如是以智慧火热诸识处。则识种不生。后相续断。又诸行因缘不具足。故不复相续。如经中佛说。识为种子业行为田。贪爱为水无明覆蔽。以此因缘则受后身。阿罗汉是缘不具故无后身。当知烦恼因缘受生。又无烦恼者。有知苦等心。今受生者不见有此等心。故知无烦恼者不能受生。问曰。须陀洹等有苦等心而生时亦不见有。答曰。诸阿罗汉智慧力强。一切烦恼不能胜。故将命终时能障受生。须陀洹等智力不尔。故不应为喻。又汝说如齿后渐渐生。烦恼亦尔。是事不然。所以者何。阿罗汉无漏智慧烧烦恼。故不应复生。如焦种子不能复生。又现见今世从烦恼生身。如从贪欲身色变异。嗔恚亦尔。故知后世五阴亦从烦恼生。问曰。亦见从饮食等因缘有五阴生。而不名饮食为受身因缘。答曰。饮食假心能生色等。烦恼不尔。更无所假而生色等。故知烦恼为身因缘。又现见鸟雀等多欲。毒蛇等多嗔。猪等多痴。当知此诸众生必当修集此淫欲等诸烦恼。故于是中生。问曰。生处法尔。非先修集烦恼因缘。答曰。若尔则淫欲等无因是事不可。当知从先修集因缘故有。又贪恚等烦恼炽盛。则为杀等诸罪。以此罪故现受鞭杖系缚等苦。烦恼若薄则得持戒修善等利。因此戒善现得名闻利养等乐。如现世衰利皆因烦恼。故知来世亦当如是。问曰。若因烦恼有身则断生死往来。所以者何。以烦恼盛故堕恶道中。既受罪身。烦恼更增永无脱因。如是不应得生善处。若受福身。为福转增则亦不应复生恶处。如是则无生死往来。答曰。是人虽堕恶处或得善心。虽生善处或起恶心。是故生死往来不断。又随贪等烦恼减少。随生好处。随贪等多。随生恶处。如猪犬等。随减烦恼生善处者。如以烦恼薄故能行布施。持戒等福生六欲天。断淫欲故得胜禅乐。断色染故得胜定乐。一切结尽则得无比泥洹乐。故知此身因烦恼有。又现见众生乐弊国土及诸恶人弊止住处。皆由贪着。故知生死中众生所住亦由贪着。如蛾贪明色故为灯所焚。是贪着不从智生。所以者何。此蛾不知火是苦触故投其中。如是众生坠后身苦。皆以无明因缘贪爱故生。如鱼吞钩獐鹿逐声。皆以贪着故致死。又如人以贪着故。远到异方而不能返。当知皆以烦恼故生。又如树根不拔其树犹生。如是贪根不拔苦树常在。如佛说。树根不拔虽断犹生。贪使不拔数数受苦。又是身不净无常苦空无我。自非无明何有智者贪受此苦。犹如盲人可以垢衣诳为宝饰。如是为无明所盲。则能受多过患不净五阴。又以我心故受身。虽苦而不能舍。若无我心则能远离。如舍利弗说。清净持戒得道者死时欢喜。犹破毒器。故知烦恼因缘有身。又有以无智故贪着此身。如以画箧盛满不净。随未开时则可爱乐。开则臭秽。又如毒蛇满闇室中。灯未照时即生乐着见则舍离。众生亦尔。堕有无明则乐世间。若生明时心则厌离。如是贪爱为身根本。所以者何。以贪爱故求。求有二种。欲求有求。求现在诸欲是名欲求。更求后身是名有求。故知贪爱是身之本。又若着五阴则生身见。谓言是我名我语取。因此取故生余三取。取因缘有。有因缘生。当知烦恼是身根本。又是身皆苦。于此苦身生乐想倒。以此乐倒则生倒爱。以此倒爱能受后身。故知贪爱因缘有身。又此身以食因缘故住。着揣食故不过欲界。如业品中说。贪香味故厕等中生。以着触故胞胎中生。着温凉触故卵生湿生。俱不过欲界。因三种触生三种受。故说触因缘受。意思食亦如是。发后身愿我当作此。无见知识为贪爱本。能致后身。如是四食皆由贪爱。一切众生皆以食存。故知爱因缘生。又四生卵生胎生湿生化生。以爱淫欲故卵生。胎生贪香味等故受湿生。随其所爱故起殷重业。则受化生。故知四生差别皆由贪爱。又四种受身。有能自杀他不能杀。如是等四皆以贪爱差别故有。故知贪爱因缘有身。又四识处随色识住依色缘色以喜为润。受想行亦如是。而不说识是识处。以识时无烦恼故。故知烦恼因缘有身。又十二因缘皆由无明。所以者何。随假名心名为无明。因此无明起福行罪行及不动行。欲安乐众生是名福行。苦恼众生是名罪行摄心慈悲等名为不动行。随此诸业识住后身。依识生名色六入触受。此四是先世业烦恼果报。复因此爱生爱取有。是业烦恼能生后世生老死等。如是十二有分相续。皆以无明为本。故知烦恼因缘有身。又生死无始。何以知之。经中说。从业因缘有眼等根。因爱有业因无明有爱。无明因邪忆念。邪忆念还因眼缘色从痴故生。故知生死轮转无始。若说因自在天等。则非无始是事不可。故知烦恼因缘有身。又灭尽烦恼则得解脱。又众生身种种杂类。若因自在等则不应杂。以烦恼业有多种故。身亦不一。又二十二根因六根生六识。是中有男女根。是诸法相续不断故名为命。是命以何为根。所谓业也。是业因于烦恼。烦恼依受故以五受为根。如是展转生死相续。依信等根能断相续。如是二十二根往来生死。故知皆以烦恼有身。又求解脱者。生戒定慧解脱解脱知见品。此何所用皆为灭诸烦恼。知者见其利故依此诸品。故知烦恼因缘有身。又诸烦恼次第灭尽。断三结得须陀洹果。贪欲等薄得斯陀含果。欲界结尽得阿那含果。诸禅定中亦如是。次第一切都尽得阿罗汉果。如是随诸烦恼次第灭故身亦渐灭。若因自在天等则不应渐灭。故知烦恼因缘有身。又贪等烦恼诸善人皆求断灭。必当见贪等因缘。今世后世得衰恼事。是故求断。若不尔则不求断。若人说身因自在等。是人亦求断贪欲等。故知贪欲等因缘有身。又智者知以智慧而得解脱。可知以无智故缚。故知烦恼因缘有身。又佛处处经中说。贪喜尽故得正解脱。所以者何。眼色等不名为缚。贪喜为缚。破贪喜故心得正解脱。正解脱心能入泥洹。故知烦恼因缘有身。又以空无相无作而得解脱。故知烦恼因缘有身。所以者何。观诸法空即无相可得。以灭相故不愿后身。是故以空名解脱门。相违则缚。以此等故由烦恼有身。是事已明。集谛聚竟

    灭谛聚初立假名品第一百四十一

论者言。灭三种心名为灭谛。谓假名心法心空心。问曰。云何灭此三心。答曰。假名心或以多闻因缘智灭。或以思惟因缘智灭。法心在暖等法中以空智灭。空心入灭尽定灭。若入无余泥洹断相续时灭。问曰。何谓假名。答曰。因诸阴所有分别。如因五阴说有人。因色香味触说有瓶等。问曰。何故以此为假名耶。答曰。经中佛说。如轮轴和合故名为车。诸阴和合故名为人。又如佛语诸比丘。诸法无常苦空无我。从众缘生无决定性。但有名字但有忆念但有用故。因此五阴生种种名。谓众生人天等。此经中遮实有法。故言但有名。又佛说二谛真谛俗谛。真谛谓色等法及泥洹。俗谛谓但假名无有自体。如色等因缘成瓶。五阴因缘成人。问曰。若第一谛中无此世谛。何用说耶。答曰。世间众生受用世谛。何以知之如说画火人亦信受。诸佛贤圣欲令世间离假名。故以世谛说。如经中佛说。我不与世间诤。世间与我诤。以智者无所诤故。有上古时人欲用物故万物生时为立名字。所谓瓶等若直是法。则不可得用。故说世谛。又若说二谛则佛法清净。以第一义故智者不胜。以世谛故愚者不诤。又若说二谛则不堕断常。不堕邪见及苦边乐边。业果报等是皆可成。又世谛者是诸佛教化根本。谓布施持戒报生善处。若以此法调柔其心。堪受道教。然后为说第一义谛。如是佛法初不顿深。犹如大海渐渐转深故说世谛。又若能成就得道智慧。乃可为说实法。如佛念言。罗睺罗比丘今能成就得道智慧。当为说实法。譬如熟痈坏之则易生则难破。如是以世谛智令心调柔。然后当以第一智坏。又经中说。先知分别诸法。然后当知泥洹。行者先知诸法是假名有是真实有。然后能证灭谛。又诸烦恼先粗后细。次第灭尽。如以发毛等相灭男女等相。以色等相灭发毛相。后以空相灭色等相。如以榍出榍故说世谛。又以世谛故得成中道。所以者何。五阴相续生故不断。念念灭故不常。离此断常名为中道。如经中说。见世间集则灭无见。见世间灭则灭有见。以有世谛则可见集见灭故说世谛。又以世谛故佛法皆实。谓有我无我等门。若世谛故有我无咎。以第一义故说无我亦实。又以世谛故有置答难。若就实法则皆可答。又若见实有众生。是大痴冥。若言实无亦堕痴冥。所以者何。此有无见则为断常。令诸行者得出有边。复堕无边。若无世谛何由得出。又若人未得真空智慧。说无众生。是名邪见。以无众生受生死故故名邪见。若得空智说无众生。是则无咎。如经中说阿罗汉比丘尼语恶魔言。汝以何为众生。但空五阴聚实无众生。又说。是身五阴相续空无所有。如化如幻诳凡夫。目为怨为贼如箭如疮。苦空无我但是生灭坏败之相。问曰。俱是无所有心。何故或名邪见。或名第一义耶。答曰。若人未生真空智慧。有我心故闻说无我即生恐惧。如佛言若凡夫人闻空无我更不复作。则大惊怖。故知未得空智。有我心故怖畏泥洹则为邪见。得真空智知本来无则无所畏。又此人未得真空。见无所有则堕恶见谓断见邪见。若是人先以世谛故知有我。信业果报后观诸法无常生灭相。渐渐证灭无我心。即灭贪心。若闻说无所有则无过咎故说世谛。又有外道谤佛。瞿昙沙门破真实神。是故佛言。我以世谛说有众生。我解正见中。说有众生往来生死。是名正见。但凡夫以邪念故。于实无众生中说言实有。破此邪念不破众生。如瓶等物以假名说。是中非色等是瓶。非离色等别有瓶。如是非色等诸阴是众生。亦不离色等阴别有众生。如因色等过假名。如是以灭相过色等。以譬喻故令义易解。犹如画灯亦名为灯。而实无灯用。如是虽说有瓶。非真实有。虽说五阴非第一义

    假名相品第一百四十二

问曰。云何知瓶等物假名故有非真实耶。答曰。假名中示相。真实中无示相。如言此色是瓶色不得言是色色。亦不得言是受等色。又灯以色具能照触具能烧。实法不见如是。所以者何。识不以异具识。受亦不以异具受。故知有具是假名有。又因异法成名假名有。如因色等成瓶实法不因异成。所以者何。如受不因异法成。又假名多有所能。如灯能照能烧。实法不见如是。所以者何。如受不能亦受亦识。又车名字在轮轴等中。色等名字不在物中。有如是差别。又轮轴等是成车因缘。是中无车名字。然则车因缘中无车法。而因此成车。故知车是假名。又如以色等名得说色等。以瓶等名不得说瓶等。故知瓶等是假名。又有假名中心动不定。如人见马或言见马尾。或言见马身。或言见皮。或言见毛。或言闻筝声。或言闻弦声。或言嗅华。或言嗅华香。或言尝酪。或言尝酪味。或言触人。或言触人身。或言触人臂。或言触人手。或言触人手指。或言触指节。意识于众生等中动。谓身是众生。心是众生。色等是瓶离色有瓶。如是等实法中心定不动。不得言我见色亦见声等。又可知等中不可说亦名为有。是为假名如瓶等故。知瓶等是假名有。所以者何。色等法不名可知等中不可说。又如色等法自相可说。瓶等自相不可说。故知是假名有。或有说假名相。是相在余处不在假名中。如经中说业是智者不智者相。若身口意能起善业是名智者。身口意起不善业名不智者。身业口业依止四大。意业依心。此三事云何名智者不智者相。故知假名无有自相。又假名相虽在余处亦复不一。如说人受苦恼如槊入心恼坏。是色相。又受是受相。亦于人中说。如佛说。智者愚者俱受苦乐。而智者于苦乐中。不生贪恚取多少等。相是想相。亦于人中说。如说我见光明见色作。起是行相。亦于人中说。如说是人起作福行亦起罪行及不动行。识是识相。亦于人中说。如说智者识法如舌尝味。是故若在余处说亦说多相。是假名相。色等相不在余处亦无多相。又若法为一切使使。是假名有。实法不为使使。以诸使使人故。又假名中无知生。先于色等中生知。然后以邪想分别。言我见瓶等。又瓶中知要待色等。所以者何。因色香味触谓言是瓶。实法中知更无所待。又假名中生疑。如杌耶人耶。色等中不生疑为色为声。问曰。色等中亦有疑有色耶无色耶。答曰。不然。若见色终不疑是声。更以余因缘故。疑有色无色。如闻说色空而复见色则生疑。言为有为无。若见灭谛此疑则断。问曰。灭谛中亦有疑。为有灭耶无灭耶。答曰。于所执中生疑。非灭谛中。若闻执有灭亦执无灭。于中生疑为有为无。是人尔时不见灭谛。所以者何。见灭谛者无复有疑。故知生疑处是假名有。又于一物中得生多识。是假名有如瓶等。实法中不尔。所以者何。色中不生耳等诸识。又多入所摄是假名有。如瓶等。是故有人说假名有四入所摄。实法不得多入所摄。又若无自体而能有作。是假名有。如说人作而人体业体实不可得。又所有分别是怨亲等。皆是假名非实法有。所以者何。若直于色等法中。不生怨亲等想。又来去等断坏等烧烂等所有作事。皆是假名非实法有。所以者何。实法不烧不坏故。又罪福等业皆假名有。所以者何。杀生等罪离杀等福。皆非实有又假名有。相待故成。如此彼轻重长短大小。师徒父子及贵贱等。实法无所待成。所以者何。色不待余物更成声等。又不假空破。是假名有。如依树破林依根茎破树。依色等破根茎。若以空破是实法。有如色等要以空破。又随空行处是假名有。随无我行处是实法有。又有四论。一者一。二者异。三者不可说。四者无。是四种论皆有过咎。故知瓶等是假名有。一者色味香触即是瓶。异者离色等别有瓶。不可说者。不可说色等是瓶。离色等有瓶。无者谓无此瓶。是四论皆不然。故知瓶是假名

    破一品第一百四十三

问曰。此一等四论有何过耶。答曰。一论过者。谓色等法相各差别。若为一瓶是则不可。又色等一一不名为地。和合云何有地。所以者何。若一一马不名为牛。云何和合为牛。问曰。如一一麻不能成聚和合能成。如是色等一一不能成地。和合能成。答曰不然。所以者何。麻聚是假名有。一等是实法中论。云何为喻。又色香味触是四法。地是一法。四不应为一。若四为一一亦应为四。是事不可。故知色等不即是地。又世间皆说地色地香地味地触。不见有言是色色。要以异法相示。如某人舍等。问曰。此不以异法相示。即以自法自示。如石人手足。所以者何。离手足更无石人。如是虽不离色等是地。亦以自体自示。有何咎耶。答曰。若说地以色等自示。无有此理。汝虽说石人喻。是喻不然。所以者何。若示石人手时。以余身为石人。又空中亦可有说。如说石人身时。尔时石人更无有余。而亦得说。如佛说是身中有发毛血肉等。离此发等更无有身。是发等所依止处。虽无别依处而亦可说。故知说石人者亦是妄说。汝若以石人成地。亦无地也。汝经中说。有色香味触是地。是地即无如身故。知色香味触。非即是地又诸求那中不得相示不得言色有香。但得言地有色味香触。故知非一。又色等心地心各异。故知色等非地。又色等名异地名亦异。问曰。心异名异皆和合中有异。答曰。若心与名但和合故有。和合但是名字。然则地但有名字。无一论也。又地可以一切根知。何以知之。人作是念。我见地嗅地尝地触地。若色香味触是地。不应但色中生地想谓我见地。香等亦如是。而实但色中生地想。故知非色等是地。假名字因缘。一分中亦可说假名名字。如人伐树亦言伐树。亦言伐林。又诸求那边陀罗骠异是中所有因缘。以是因缘不成一论。又僧佉人说。五求那是地。是亦不然。所以者何。如先说。声离色等念念灭相续更生。非成四大因。故知非一切四大尽有声

    破异品第一百四十四

问曰。异论中有何等过。答曰。离色等法更无地也。何以知之。不离色香味触生地心。但于色等法中生心。所以者何。如色异声等异不待声等而生色心。若离色等别有地者。亦应不待色等生地心。而实非不待。是故无别有地。问曰。非不待余法。要待色相而生色心。答曰。破总相品中当说。离色无别色相。是故不然。又异地等法无根能知。故知无别地等。问曰。地等以二根可取。谓身根眼根何以知之。眼见知是瓶。以身根触亦知是瓶。是故汝言无根取地。是事不然。答曰。若尔是瓶则四根取。亦以鼻根嗅泥。舌根尝泥。问曰。鼻根舌根不能取瓶。所以者何。闇中不能分别。若嗅瓶若嗅盆。若尝瓶若尝盆。答曰。虽不能分别瓶盆。而于泥中生知。谓嗅泥尝泥。又若埋瓶出口。若见若触不能定知是瓶是釜为是破瓦。故知眼根身根亦不应取瓶。又于闇中虽生瓶心。不能分别金瓶银瓶。故知眼根身根亦不能取瓶。又鼻根舌根能取花果乳酪等法。眼根身根则不能取。如虽见华等不能分别香臭美恶及甘酢等。是故若谓眼根身根知陀罗骠。而鼻根舌根不知无有是事。如鼻根舌根不得异陀罗骠。而亦有分别。眼根身根亦如是。虽无异陀罗骠而亦得分别。又五根中无有取假名知。故知假名非眼身鼻舌诸根所得。第六根中有。知能知假名。所以者何。意识能缘一切法故。又眼若能见色见非色者。亦应能见声等。若尔则不复须耳等诸根。是事不可。是故不以眼根身根取陀罗骠。问曰。以色了陀罗骠则眼能见。非一切异色法皆可见。答曰。以色了瓶是事不然。所以者何。谁作瓶色但是和合。是故非色了瓶。又若以可见法了余法。令可见者以瓶等不可见法了色。色亦应是不可见。又瓶应二种。亦可见亦不可见。以为可见不可见法所了故。又若要以色等法了故。眼等根可知者。色相不应是眼根所知。所以者何。汝法因色相故。色可见是色相更无有相。然则色相应不可见。是故不然。又若以色了故可见者。一切诸根尽应知陀罗骠。耳根亦应知虚空。以声了故。又应以身根知风。以触了故。而汝法不然。是故无此了法。问曰。余法不能为了。但色能作了。答曰不然。是中无有因缘但色能为了。而余法不能。如汝说大多陀罗骠。是中色可见。如是则因色故得色。应当以色相了色。然后可得。不但色能为了。若如是说犹不离先过。又异时生色心。异时生瓶心。是故纵色能了。于瓶何益。又如盲人习瓶量故。虽失眼根触亦如瓶。是故非但色能为见因。又盲人身根亦能知风。是故非但色了故能生知。又汝经中亦说。触来触身非地水火。当知不可见相是风。此亦不然。所以者何。盲人知此风时。亦不知此触为可见为非可见。又人眼见数量等法。是中无有色了。有闻香亦得知非香法。尝味亦能知非味法。是故要以色了陀罗骠。然后可知。是事不然。问曰。若色了于见中非因者。若数量等法。在不可见陀罗骠中及风亦应可见。答曰。我法离色更无余法可见。故知随法中有色生。则眼能见。眼见色已即生瓶想。若法中无色生。是中虽有眼不生异瓶想。是故若离色等别有瓶者。无此理也

    破不可说品第一百四十五

问曰。不可说论中有何等过。答曰。实法无有于一异中不可说者。所以者何。无有因缘譬喻以此知不可说。色等法实有故。非不可说也。又诸法各有自相。如恼坏是色相更无异相。云何名不可说。又随识差别故法有差别。如以眼识知色不知声等。是故此中无不可说。又色是色入所摄。非声等摄。若汝欲令有不可说者。色是色是可说。色是非色是不可说。声等亦如是。又诸法有次第数。若不可说则诸法无数。所以者何。第一第二不相异故。故知实无不可说法。但于假名中为一异故说不可说

    破无品第一百四十六

问曰。无论中有何等过。答曰。若无则无罪福等报缚解等一切诸法。又若执无所有是执亦无。以无说者听者故。又有无等论皆以信故说。若信见知若信比知。若随经书若说无所有。则不在此三中。汝意或谓我随经书。是事不然。经书意亦难解。或时说有或时说无。云何取信。若信比知要先现见。然后比知。又瓶等法今现见有。以能生心故。随能生心则有此法故。非无也。又今瓶盆等现有差别。若一切无何有差别。汝意或谓以邪想故有分别者。何故不于空中分别瓶等。又汝若谓以痴故生物心者。若一切无。此痴亦无。何由而起。又汝意谓一切法无。是知何缘得生。诸知不以无缘而生。以知物故名知。是知不应言无。又若都无者。今一切人应随意所为。而诸善人皆乐布施持戒忍等善法。远离不善法。故知非无。又瓶等法今现可知。而汝言现在皆无。以无法故。亦不应信经书。然则何因缘故。说一切无故。一切无是事应明。若不能以因缘明者。他人所执自然应成。他论成故。汝法则坏。若有因缘可成则不名为无

    立无品第一百四十七

说无者言。汝虽以言说破空。然诸法实无。以诸根尘皆不可得故。所以者何。诸法中无有有分可取。是故一切法不可取。不可取故无。汝若谓有分虽不可取诸分可取者。是事不然。诸分中不生心。所以者何。粗瓶等物可取故。又分不作有分。所以者何。因有分故说分。有分无故分亦无。又无陀罗骠求那无分。是故无分。又若见细分则应常生分心不生瓶心。所以者何。若常念分终不应生瓶心。又若先忆分后生瓶心则瓶心应久乃生。而实不久生故不念分。又若见瓶不生分别分心。即生瓶心。又无一切分。所以者何。一切分皆可分析坏裂乃至微尘。以方破尘终归都无。又一切诸法究竟必生空智。是故第一义中诸分皆无。又若说分者。则破二谛。所以者何。若人说无有分但有诸分。则无去来见断等诸业。如是则无世谛。汝以第一义为空。第一义中亦无诸分。故知但说诸分则不入二谛。不入二谛故无。又若法可过即为是无。如因分过有分。亦更因余分过先分。以可过故。无此分论。又色等亦无。所以者何。眼不能见细色。意不能取现在色。是故色不可取。又眼识不能分别是色。意识在过去不在色中。故无有能分别色者。无分别故。色不可取。又初识不能分别色。第二识等亦复如是。故无有能分别色者。问曰。眼识取色已后以意识忆念。是故非无分别。答曰。眼识见色已即灭次生意识。是意识不见色。不见云何能忆。若不见而能忆者。盲人亦应忆色而实不忆。是故意识不能忆也。问曰。从眼识生意识。是故能忆念。答曰不然。所以者何。一切后心皆因眼识生。皆应能忆。又终不应忘。以从彼生故而实不然。故知意识亦不能忆。如忆虚妄。取色瓶等万物。亦皆虚诳。无而妄取。是故无一切物。又若说眼见为到色见。为不到能见。若到则不能见。眼无去相。是事先明。若不到而见。应见一切处色。而实不见。故知非不到能见。问曰。色在知境则眼能见。答曰。何名知境。问曰。随眼能见时名为知境。答曰。若眼不到亦名知境者。一切处色应尽是知境。是故到与不到俱不能见。故知色不可见。又若先有眼色。后眼识生。是眼识则无依无缘。若一时则不名眼色因缘生识。一时无相因故。又眼是四大若眼能见。耳等亦应能见。同四大故。色亦如是。又是眼识应若有处若无处二俱有过。所以者何。若眼识依眼是则有处。若物无处则不得依止。若汝谓识于眼少分处生若遍生若二眼中一时生识则有处。有处则有分。如是则以众识而成一识。有如是过。亦有多识一时生过。又一一识分不能识有分者。应识而实无有有分。有如是过。若无处则不应依眼

    破声品第一百四十八

说无者言。一语尚无。所以者何。心念念灭声亦念念灭。如说富楼沙。是语不可闻。所以者何。随闻富识不闻楼。闻楼识不闻沙。无有一识能取三言。是故无识能取一语。故知声不可闻。又散心闻声。定心则不能闻。定心所知是实。是故声不可闻。又是声若到不到俱不可闻。不可闻故无声。又有人说。耳是虚空性。以其无物故名虚空。是故无耳无耳故无声。又声因缘无。是故无声。声因缘者。谓诸大和合。是和合法不可得。所以者何。若诸法体异则无和合。若无异体云何自合。设在一处亦念念灭。是故不得和合

    破香味触品第一百四十九

香不可取。所以者何。以鼻识不能分别是瞻卜香是诸余香。意识不能闻香。是故意识亦不能分别是瞻卜香。问曰。虽不能分别是瞻卜香。但能取香。答曰。不然。如人不得瞻卜树以愚痴故生瞻卜树心。如是不得香体。以愚痴故而生香心。又如先说。香若到不到而取二俱有过。是故无香味亦如是。触亦无。所以者何。微尘等分中尚不生触知。如先说是故无触

    破意识品第一百五十

意识亦不能取法。所以者何。意识不能取现在色香味触。先已说。过去未来则无。是故意识不取色等。问曰。若意识不知色等法应知自体。答曰。法不自知。所以者何。现在不可自知。如刀不能自割。过去未来无法故。亦无余心。是故意识不能自知。问曰。若人知他心时。则意识能知心法。答曰。如人心不自知。亦作是念言。我有心于他心中亦复如是。又若未来法无亦能生知他心。若如是有何咎。又意能缘法则有多过。如意到缘及意识不到缘。不应忆色等。以此过故意识不知法

    破因果品第一百五十一

说无者言。若有果应因中先有求那而生。先无求那而生。二俱有过。如两手中先无声而能有声。酒因中先无酒亦能生酒。车因中先无车而能成车。故非因中先有求那而生果也。汝若谓因中先无求那而生果者。则如无色风之微尘。应能生色。若尔风则有色。金刚等中亦应有香。又现见。白缕则成白叠。黑缕还成黑叠。若因中先无求那。而生果者。何故白缕但能成白不成黑耶。故非因中先无求那而成果也。理极此二而俱有过。是故无果。又若因中有果则不应更生。有云何生。若无亦不应生。无云何生。问曰。现见作瓶云何无果。答曰。是瓶若先不作。云何可作。以其无故。若先已作云何可作。以其有故。问曰。作时名作。答曰。无有作时。所以者何。所有作分已堕作中。所未作分堕未作中。故无作时。又若瓶有作。应若过去未来现在。过去不作已失灭故。未来不作以未有故。现在不作以是有故。有因作者故有作业成。是中作者实不可得。所以者何。头等身分于作无事故无作者。无作者故作事亦无。又因于果若先若后若一时皆不然。所以者何。若先因后果因已灭尽。以何生果。如无父云何生子。若后因先果。因自未生云何生果。如父未生何能生子。若因果一时则无此理。如二角并出。不得言左右相因。理极此三而皆不然。是故无果。又此因果若一若异二俱有过。所以者何。若异则应离缕有叠。若一则缕叠无差。又世间不见有法因果无别。又若有果应自作他作共作无因作。是皆不然。所以者何。无有法能作自体。若有自体何须自作。若无自体何能自作。又不见有法能作自体。故不自作。他作亦不然。所以者何。眼色于生识无事故。不他作。又无作相。故一切诸法无有作者。如种不作是念我应生牙。眼色亦不作是念。我等应共生识。是故诸法无有作想。共作亦不然。有自他过故。无因作亦不然。若无因亦无果名。若四种皆无。云何有果。若有应说。又此果应若先有心作若先无心作。若先有心作。胎中小儿眼等身分谁有心作。自在天等亦不能作。先已说业亦无心。于作是业。在过去中云何当有心作。是故业亦无心。若先无心作。云何苦他者得苦。乐他者得乐。有现作业中亦以心分别。应如是作。不应如是作。若无心作云何有此差别。是故先有心无心。是皆不然。如是等一切根尘皆不可得。是故无法

    世谛品第一百五十二

答曰。汝虽种种因缘说法皆空。是义不然。所以者何。我先说。若一切无是论亦无。亦不在诸法中。如是等破空汝竟不答。犹故立空是故非无一切诸法。又汝所说无根无缘等。是事非我等所明。所以者何。佛经中自遮此事。谓五事不可思议。世间事．众生事．业因缘事．坐禅人事．诸佛事。是事非一切智人不能思量决断。但诸佛有能分别法智。声闻辟支佛。但有通达泥洹智慧。于分别诸法智中。但得少分。诸佛于一切法一切种本末体性总相别相。皆能通达如人舍宅等物易坏难成。如是空智易得。正分别诸法智慧难生。问曰。如佛坐道场所得诸法相。如佛所说当如是说。答曰。佛虽说一切法。不说一切种。以不为解脱故。如佛说诸法从因缘生。不说一一所从因缘。但说要用能灭苦者。彩画等诸色。伎乐等诸音。诸香味触无量差别不可尽说。若说亦无大利。故佛不说如是等事。不得言无。又如人不知分别彩画等法。便言其无。汝亦如是。所不能成事而便说无是事。于智者则有。不知者为无。如生盲人言无黑白。我不见故不可。以不见故便无。诸色如是。若不能以自缘成。故便言无一切法。又诸佛世尊一切智人我等所信。佛说有五阴。故知色等一切法有。如瓶等以世谛故有

成实论卷第十一成实论卷第十二

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    灭法心品第一百五十三

问曰。汝先言灭三心名灭谛。已知灭假名心因缘。今何谓法心云何当灭。答曰。有实五阴心名为法心。善修空智见五阴空。法心则灭。问曰。行者观五阴空。谓五阴中无常法定法不坏法不变法我我所法。以无此法故言其空。非不见五阴。答曰。行者亦不见五阴。所以者何。行者断有为缘心。得无为缘心。是故行者不见五阴。但见阴灭。又若见五阴则不名为空。以阴不空故。如是空智则不具足。问曰。行者见色以无我故空。如经中说行者见此色空乃至见此识空。当知。非无色等诸阴。答曰。有如是言但非清净。如法印经中说。行者见色等无常败坏虚诳厌离之相。是亦名空。但未是清净。是人于后见五阴灭。是观乃净。故知见诸阴灭。问曰。以有为缘智何故不得清净。答曰。行者或时起五阴相。故假名心还生。是故有为缘心不得清净。若证诸阴灭。则五阴不复现前。成假名因缘灭故。假名想则不随逐。譬如有树。剪伐焚烧灰炭都尽。树想乃灭不复随逐。是事亦尔。又佛语罗陀。汝破裂散坏众生令不现在。又一经说。汝罗陀破裂散坏色乃至识令不现在。故知若坏众生是假名空。若破坏色是名法空。又二种观。空观无我观。空观者不见假名众生。如人见瓶以无水故空。如是见五阴中无人故空。若不见法是名无我。又经中说。得无我智则正解脱。故知色性灭受想行识性灭。是名无我。无我即是无性。问曰。若以无性名无我者。今五阴实无耶。答曰。五阴实无以世谛故有。所以者何。佛说诸行尽皆如幻如化。以世谛故有非实有也。又经中说第一义空。此义以第一义谛故空。非世谛故空。第一义者所谓色空无所有。乃至识空无所有。是故若人观色等法空。是名见第一义空。问曰。若五阴以世谛故有。何故说色等法是真谛耶。答曰。为众生故说。有人于五阴中生真实想。为是故说五阴以第一义故空。问曰。经中不说有业有果报。但作者不可得耶。答曰。此因诸法说作者不可得。是说假名空。如经中说。诸法但假名字。假名字者。所谓无明因缘诸行乃至老死诸苦集灭。以此语故知五阴亦第一义故无。又大空经中说。若人言此老死。某老死若人说身即是神。若说身异神异。此言异而义同。若有此见非我弟子。非梵行者。若遮某老死则破假名。遮此老死则破五阴。又说生缘老死名为中道。当知第一义故说无老死。世谛故说生缘老死。又如过瓶相则第一义故无瓶。如是过色等法。则第一义故无色。又经中说。若法是诳即是虚妄。若法非诳即名为实。诸有为法皆变异。故悉名为诳。诳故虚妄。虚妄故非真实有如偈说

  世间虚妄缚　　状如决定相
  实无见似有　　深观则皆无

当知诸阴亦空。又见灭谛故说名得道。故知灭是第一义有非诸阴也。若诸阴实有。行者亦应见而得道。而实不然。故知五阴非第一义有。又以阴灭为实。故知诸阴非实。不可言诸阴是实。无阴亦实。又所有见法皆以痴故。如人眼不可诳。则不见幻。如是若无愚痴则不见诸阴。是故诸阴非第一义有。又经中说。随有我即是动处。而阴中有我。如阿难说。因法成我。谓因色阴乃至识阴。又如诸上座比丘问差摩伽。汝说何事为我。差摩伽言。我不说色是我。不说离色是我。乃至识亦如是。但于五阴中我慢未断。此经意以学人或时散乱念故。则起我慢。若摄心念五阴灭。我慢即灭。如花非但根茎枝叶为华。亦不离此为华。如是非色等是我。亦不离色等是我。如是灭我因缘。则我慢不起。故知诸阴亦空。又行者应灭一切相证于无相。若实有相何为不念。非如外道离于色时。知实有色但不忆念。行者要见色等诸阴灭尽。见灭尽故名入无相。故知色等非第一义。又随有五阴则有我心。当知无五阴故我心则灭。是故诸阴皆空。又水沫经中佛说。若人见水聚沫谛观察之知非真实。比丘亦尔。若正观色阴。即知虚诳无牢无坚败坏之相。观受如泡。想如野马。行如芭蕉。识如幻。亦复如是。此中五喻皆示空义。所以者何。眼见水沫消时还无。泡等亦尔。故知诸阴非真实有。又若佛弟子深厌生死。皆以见法本来不生无所有故。若见无常则但能生败坏苦相。若见无性无余相故。则能具足行苦。具此三苦名得解脱。当知一切诸法皆空。又空是解脱门。此空非但是众生空。亦有法空。如说眼生时无所从来。灭时无所至处。则知过去未来眼空。现在眼亦以四大分别故空。如佛说眼。肉形中所有坚依坚名为地等。若得此空则说无所有。又说。一切诸行断故名断性。离故名离性。灭故名灭性。故知一切诸行皆灭。若实有诸行则无正断离灭。灭名为无。当知第一义故诸行皆无。但以世谛故有诸行

    灭尽品第一百五十四

若缘泥洹是名空心。问曰。泥洹无法心何所缘。答曰。是心缘无所有。是事先明为知泥洹故。问曰。此空心于何处灭。答曰。二处灭。一入无心定中灭。二入无余泥洹断相续时灭所以者何。因缘灭故此心则灭。无心定中以缘灭故灭。断相续时以业尽故灭。论者言。行者若能灭此三心。则诸业烦恼永不复起。问曰。何故不起。答曰。是人具足无我故业烦恼灭。如灯烟墨。有所依处则住。无依处则不住也。如是若有我心依处业烦恼则集。无则不集。又无漏正见烧尽诸相。令无有余。如劫火烧地等无余。以无相故诸业烦恼则不复集。又有我心者则业烦恼集。阿罗汉通达空智。无我心故则不复集。问曰。是人虽新业不集。以故业故何得不生。答曰。是人以正智慧坏此业。故不能得报。如焦种子不复能生。又若无爱心则诸业不能得报。如地无润则种不生。又此行者于诸识处悉灭诸相。识无所依故无生处。如种无依则不得生。又业烦恼具故能受身。不具则灭。是人无烦恼故因缘不具。虽有诸业不能受生。又众生以烦恼故受诸趣身。以受身故诸业于中能与果报。若无烦恼则不受身。不受身故诸业云何能与果报。如人负债恃势力。则债主不能得便。行者亦尔。若不在生死。虽有诸业不能与报。又如人被缚余人则能随意毁辱。如是众生为烦恼所缚。随业多少皆能与报。得解脱者则不能得便。又自业能与果报。是人行空行故。于诸法中无有自相。是故诸业不能与报。如以儿为奴则无有财分。此亦如是。又烦恼力能转诸业。烦恼势尽则诸业不转。如轮虽在动势尽故则不复转。又烦恼力能变诸业。如母爱子血变为乳。爱心灭故则不复变。如是烦恼力故业能与报。离则不能。又是人以戒定慧等功德修身。势力大故诸业不能得便。是故虽有故业不能与报。如是此人故业现在少偿。新业不造。如火烧薪薪尽则灭。是人亦尔。以不受故灭。灭三心故于一切诸苦永得解脱。是故智者应灭三心

    道谛聚定论中定因品第一百五十五

论者言。今论道谛。道谛者。谓八直圣道。正见乃至正定。是八圣道略说有二。一名三昧及具。二名为智。今当论三昧。问曰。三昧何等相。答曰。心住一处是三昧相。问曰。是心云何得住一处。答曰。随所多习于此处住。若不多习则速舍离。问曰。当云何习。答曰。随所乐习。问曰。云何能乐。答曰。身心粗重名苦。以猗法除身心粗重相则能生乐。问曰。云何生猗。答曰。以欢喜因缘故身心调适。问曰。云何生喜。答曰。从念三宝及闻法等心悦故生。问曰。云何心悦。答曰。从清净持戒心不悔生。问曰。已说三昧因。今三昧复是谁因。答曰。是如实智因。如实智者。谓空智也。如说行者如是摄心清净心除盖心。住心不动心。则能如实知苦圣谛集灭道圣谛。是故欲得如实智者。当勤精进修习三昧。散心者尚不能得世间经书工巧等利。何况能得出世间利。故知一切世间出世间利。皆以定心故得。又一切妙善皆由正智。一切鄙恶皆由邪智。如经中说。无明为首。无惭愧随从起一切恶。以明为首惭愧随从起一切善。而三昧是正智慧因。故知一切妙善皆因三昧。是故当勤精进修习

    定相品第一百五十六

问曰。汝说心住一处是三昧相。三昧与心为一为异。答曰。三昧与心不异。有人说。三昧与心异。心得三昧则住一处。虽有此言是义不然。若心得三昧。能于缘中住者。是三昧亦住缘中。亦应更因余三昧住。如是无穷是事不可。若是三昧自然住者。心亦如是。不应因三昧住。是故若言三昧异心于义无益。又受想等诸心数法。亦于缘中住。此复更因何法故住。是事应说。若受想等各有三昧。即同先过。又经中但说一心是三昧相。不说心得三昧故住。故知不然。又言一心则不明余法。如先说。随心乐处于此缘住。当知心边无别三昧。随心久住名为三昧。问曰。是三昧为有漏。为无漏。答曰。三昧二种。有漏无漏。世间诸禅定是有漏。入法位时诸三昧名无漏。所以者何。是时名为如实知见。尔时二种亦名三昧。亦名为慧。摄心故名三昧。如实知故名慧。摄心有三种。善不善无记。是中以善摄心为三昧。非不善无记。此三昧亦有二种。一是解脱因。一非解脱因。解脱因者名为定根。有论师言。但无漏定名为定根。是语不然。若有漏无漏能为解脱因者。皆名定根。是三昧随住缘故分别三种。小大无量。心少时住。若见小缘是为小。余二亦尔。又随时故有三种相。制相发相舍相。心退没时应用发相。心掉动时应用制相。心调适时应用舍相。如金师治金或炙或渍或时舍置。若常炙则消。常渍则生。若常舍置则不调柔。行者心亦如是。若动不制则常散乱。若没不发则复懈怠。若适不舍则还不适。又如调马。若疾则制。若迟则策。若调则舍。行者调心亦复如是。又此三昧有三种方便。入定方便。住定方便。起定方便。如法入定是入定方便。在定不动是住定方便。如法起定是起定方便。问曰。云何得此三种方便。答曰。行者取自心相。如是制如是发如是舍。则能入定住。出亦尔。问曰。但直取定何用方便。答曰。若不生此三种方便。则有过咎。不得随意。欲入则起。欲起还入。有此等过。又以利为损以损为利。如见少净色及少光明。谓得大利。若念无常苦空等心不得乐。反谓为损。问曰。行者何故或有得定或不得耶。答曰。得定因缘有四。一今世勤习。二前身有缘。三善取定相。四闻随定法。又修定四种。一常勤习而不一心行。二一心行而不常修习。三亦常修习。亦一心行。四不常习不一心行。又有四种。有多善少慧。有少善多慧。有多善多慧。有少善少慧。于此中第三行者必能得定。第四必不能得。第一第二若调等则得

    三三昧品第一百五十七

问曰。经中说三三昧。一分修三昧。共分修三昧。圣正三昧。何者是耶。答曰。一分修者。若修定不修慧。或修慧不修定。共分修者。若修定亦修慧。是世间三昧。在暖等法中。圣正三昧者。若入法位能证灭谛。则名圣正。何以知之。如长老比丘说行者以定修心。因慧能遮烦恼。以慧修心。因定能遮烦恼。以定慧修心因性得解脱性。谓断性离性灭性。又若定慧一时具足。故名圣正。如以定慧得解脱名俱解脱。问曰。有人言。一分修者。若因三昧能见光明。不见诸色。若见诸色不见光明。共分修者。谓能见色亦见光明。圣正者。谓学无学所得三昧。是事云何。答曰。无有经说。唯见光明而不见色。经中但说我本曾见光明亦见诸色。今失光明亦不见色。又汝应说因缘。何故能见光明而不见色。如是等故汝说非也。问曰。又经中说三三昧空无相无愿。是三三昧云何差别。答曰。若行者不见众生。亦不见法。是名为空。如是空中无相可取。此空即是无相。空中无所愿求。是空即名无愿。是故此三一义。问曰。若尔何故说三。答曰。是空之能。谓应修空。修空得利谓不见相不见相故无相。无相故不愿。不愿故不受身。不受身故脱一切苦。如是等利皆以修空故得。是故说三。问曰。有论师言。若三昧以空无我行。是名为空。若行无常苦因集生缘道如行出。是名无愿。若行灭正妙离。是名无相。是事云何。答曰。汝言行无常苦名无愿者。此则不然。所以者何。佛常自说。若无常即是苦。若苦即是无我。知无我则不复愿。故知亦以空故不愿。若说行因集生缘名无愿者。此或可尔。所以者何。经中说。见所有生相皆是灭相。则生厌离。又道中不应有无愿行。所以者何。愿是爱分。如经说上中下愿道中不生贪爱。是故不应有无愿行。又经中说。五阴灭故名灭。当知随无五阴。是名为空。空即是灭。是中无愿以爱身故愿。故知此三一义不应差别。问曰。又经中说三三昧。空空无愿无愿无相无相。何者是耶。答曰。以空见五阴空。更以一空能空此空。是名空空。以无愿厌患五阴。更以无愿厌此无愿。是名无愿无愿。以无相见五阴寂灭。更以无相不取无相。是名无相无相。问曰。有论师言。是三三昧名有漏。是事云何。答曰。此非有漏。所以者何。是时无漏能使故。又此三昧于空等胜。云何当是有漏。问曰。若空等三三昧。实是智慧。何故名三昧耶。答曰。诸三昧差别故。又三昧能生如实知见。故名三昧。果中说因故。问曰。有论师言。是空空等三三昧。但无学人得非余人。是事云何。答曰。学人亦应得。所以者何。行者应证有漏无漏一切法灭。是故学人亦应当证无漏法灭

    四修定品第一百五十八

有修定为现在乐。有修定为知见。有修定为慧分别。有修定为漏尽。若三昧能得现在乐。谓第二禅等。何以知之。佛说第二禅。谓从三昧生喜乐为名。不为余法。如入舍卫城为饭食故。问曰。初禅亦有喜乐。何故不说有现乐耶。答曰。初禅杂诸觉观。能散心故不说现乐。问曰。第二禅亦有喜等能乱心法。何故名乐。答曰。先灭诸觉深摄心。故说喜等为乐。但以行苦故一切名苦。又初禅中苦粗。二禅等中苦细。苦细故得名为乐。问曰。第二禅等亦有后世乐行。何故但说为现在乐。答曰。如为阿阇世王说现在沙门果。又以近故说。又为破五欲乐故说现在乐。若人贪着五欲乐故。不得诸禅。为是故说。汝等若能离五欲乐。当得胜现在乐。又诸佛不赞受后身故不说后乐。又世间人。言在家人乐。非出家人。是故佛说。此是出家人现在乐也。又是四修定皆为现乐。以初受名故独说现乐。问曰。若是四修定能成种种利。何故但说此四利耶。答曰。利有二种。世间利。出世间利。第二修定为世间利。所谓知见。知名八除入十一切入等利。见名五神通等利。所以者何。是利眼见故名为见。是事因取光明故成。故为知见。说光明相二。是出世间利。以慧分别五阴。名慧分别。故经中说。慧分别者。行者若生诸受诸觉诸想。皆能别知。别知受者谓触因缘受。无有受者。别知觉者此计我觉。云何令无。谓分别男女等假名想。破此想故则无诸觉。如经说。诸觉何因。所谓为想。故知但破想故则无诸觉。诸觉无故。诸受亦无。故知破假名故名慧分别。以慧分别故得漏尽。如经中说。行者观五阴生灭相。故能证阴灭。故知一切世间出世间利皆摄在四中。问曰。有论师言。第四禅中能得阿罗汉果无碍道。名为漏尽。是事云何。答曰。是中无有差别因缘。但第四禅中无碍道名为漏尽非余。是故不然。又修定为三种利。一为现乐。二为知见。三为断结。或说为二。如说。为毕竟尽故。善清净故。生死尽故。分利种种性故。是有眼者说道。是中前三说断。后一说知。佛于此中不说现乐

    四无量定品第一百五十九

慈悲喜舍。慈名与嗔相违善心。如善知识为善知识常求利安。行者亦尔。为一切众生常求安乐。是故此人与一切众生为善知识。问曰。何谓善知识相。答曰。常相为求今世后世利益安乐。终不相违求无益事。行者亦尔。但为众生求安乐事。不求非安乐事。悲名与恼相违慈心。所以者何。亦为众生求安乐故。问曰。嗔恼有何差别。答曰。心中生嗔念。欲挝打害此众生。从嗔起身口业。则名为恼。又嗔为恼因。怀嗔心者必能行恼。喜名嫉妒相违慈心。妒名见他好事心不忍则生嫉恚。行者见一切众生得增益事生大欢喜。如自得利。问曰。此三皆是慈耶。答曰。即是慈心差别三种。所以者何。不嗔名慈有人虽能不嗔而见苦众生不能生悲。若能于一切众生中。深行慈心。如人见子遭急苦恼。尔时慈心转名为悲。或有人于他苦中能生悲心。而不能于他增益事中生欢喜心。何以知之。有人见怨贼苦尚或生悲。见子得胜己事而不能喜。行者见一切众生得增益事。生欢喜心。如己无异。是名为喜。故知慈心差别为悲喜。问曰。何所舍故名舍。答曰。随见怨亲则慈心不等。于亲则重于中不如。于怨转薄。悲喜亦尔。是故行者欲令心等。于亲舍亲于怨舍怨。然后于一切众生慈心平等。悲喜亦尔。故经中说。为断憎爱修习舍心。问曰。若尔则无别舍心。但以心平等故名为舍。答曰。我先说慈心差别为悲喜等。又慈心以下中上法故有三种。能令此三平等。故名为舍。如说以上慈心修习二禅。问曰。以何方便得此慈心。答曰。后当说嗔恚过患。知此过患已。常修慈心。又见慈心利益功德。如经中说。行慈心者卧安觉安。不见恶梦。天护人爱不毒不兵。水火不丧。如是一切从嗔生业无如之何。闻此利益故能修习。又行者生念。我起嗔恚自受果报。非余人受故。应不嗔而修慈心。又行者思量。我以少恶加人则自受多恶。百陪不啻。故应离恶。又经中说五种除嗔因缘。常当忆念。又嗔恚非是行者所宜。又当念前人利益善事。除舍恶事则嗔恚息。又当观前人本末因缘。此人先世或为我母。怀妊生育为我勤苦。或为我父兄弟妻子。云何当嗔。又念。来世或当为我父母兄弟。或作罗汉缘觉诸佛。云何可嗔。又见恶人以行恶故两世受苦。是故不嗔。又深观前人体性善恶。若恶人加恶何故生嗔。如火烧人不应嗔也。又见前人为烦恼所逼不得自在。犹如鬼着何为生嗔。又随以何因缘修习忍辱。应念此法则嗔恚息慈心增长。忍功德者。谓行者生念。我若嗔他即为凡鄙。与彼无异。是故应忍。如佛说偈。譬如调象能堪刀箭。我亦如是。能忍诸恶。又偈说恶口骂詈。毁辱嗔恚。小人不堪。如石雨鸟。恶口骂詈。毁辱嗔恚。大人堪受。如花雨象。是故应忍。又以此恶事回为功德。以从诸恶成功德故。又行者知此众生愚痴无识。犹如婴儿不应嗔也。以此方便能修慈心。问曰。云何修悲。答曰。行者见诸众生乐少苦多故生悲心。我当云何于苦众生更加诸苦。又见众生深贪着乐。则生念言。我今云何断他所愿。故生悲心。又见苦众生。以现苦故苦。见乐众生以无常故苦。是故一切众生皆有苦分。或早或晚无得脱者。以是因缘故生悲心。问曰。云何修喜。答曰。行者见嫉他利者是凡鄙相。是故修喜。作如是念。我应与众生乐。他今自得则是助我。故应生喜。又见此嫉妒空无所益。不能损他。但反自害。又如经说嫉妒之过。欲离此过故生欢喜。问曰。云何行舍。答曰。见不等心过欲令心等。是故行舍。又行者见贪恚心过。故修行舍。问曰。是无量心在何地中。答曰。皆在三界。问曰。有论师言。从三禅以上无喜根。是事云何。答曰。我不说喜心是喜根性。但为利他心喜不浊故名为喜。是四无量皆是慧性。问曰。云何于无色界有四无量心。以色相故分别众生。彼中坏裂色相。云何当有。答曰。无色众生亦可分别。如经中说。当作有色及无色等。又经中说。修慈极远得遍净报。修悲极远得空处报。修喜极远得识处报。修舍极远得无所有处报。故知无色中亦有无量。问曰。一一地中有一无量心非想非非想处无耶。答曰。一切处有一切。但修上慈故生遍净处。以诸业生相似果报故。谓求乐众生者还得乐报。悲亦如是。由有身故多集诸苦。虚空中无色。故识处心于缘中深乐住。故舍极无所有处者。行者为想所疲惓故入无所有处。非想非非想处亦无量。但以细微不了故不说。又一切处有一切随多故说。遍净中慈最上故如是等。又诸禅定中四无量心受果报胜。以众生缘故。问曰。有论师言。是四无量但缘欲界众生。是事云何。答曰。何故不缘余众生耶。应说因缘。佛于无量经中说。行者慈心普覆四方上下一切众生。色无色界众生亦有无常败坏堕诸恶趣。何故不缘。问曰。有论师言。但生欲界行者能现入无量。是事云何。答曰。一切处生皆能现入。问曰。若彼中生亦能现入。则福不应尽。常生彼中。答曰。如彼中亦现入禅等。诸余善法而亦有退没。慈等亦尔。问曰。若有此理何不速退。答曰。有如是业。虽有退因缘而不速退。如欲天等。虽有善业亦生恶道。是事亦尔。问曰。行慈三昧者。何故兵刃水火不能害耶。答曰。是善福深厚诸恶不加。亦为诸天所守护故。问曰。经说与慈俱修觉意。有漏无漏云何俱修。答曰。是慈与觉意相顺。如经中说。若人一心听法则能断五盖。修七觉意不可听法。亦修觉意。又经中说。汝等比丘修习慈心。我保汝得阿那含果。慈心虽不断结。先以慈心集诸福德智慧利。故得圣道慧。能断诸结故。说修慈得阿那含。与慈修觉亦复如是。问曰。阿罗汉断众生想。云何行无量心。答曰。阿罗汉虽入慈心。不能集成慈业。以不受生故。问曰。诸佛世尊大悲云何。答曰。诸佛世尊有如是不思议智。虽知诸法毕竟空。而能行大悲深。于凡夫但不得定众生相。问曰。悲与大悲有何差别。答曰。悲名但心怜愍。能成办事故名大悲。所以者何。菩萨见众生苦。为尽此苦勤修精进。又于无量劫修习所成。故名大悲。又以智眼见众生苦。决定发心要当除灭。故名大悲。又多所利益故名大悲。亦无障碍故名大悲。所以者何。悲心或念他恶故生障碍。大悲于种种深恶通达无碍。又悲心或有厚薄不等。一切平等故名大悲。又自舍己利但求利他。故名大悲。悲不如是。是名差别。如是慈等于佛皆名为大。但以悲能救苦。是故独说

    五圣枝三昧品第一百六十

经中说五圣枝三昧。谓喜乐清净心明相观相。喜是初禅二禅喜相同故名为一枝。第三禅以离喜乐别为一枝。第四禅中清净心名第三枝。依此三枝能生明相观相。是明相与观相为因。能坏裂五阴。观五阴空故名观相。能至泥洹故名为圣。问曰。经中说圣五智三昧。何者是耶。答曰。佛自说。行者作是念。我此三昧圣清净。是名初智。此三昧非凡夫所近。是智者所赞是第二智。此三昧寂灭妙离故得。是第三智。此三昧现在乐后得乐报。是第四智。此三昧我一心入一心出。是第五智。佛示定中亦有智慧。非但系心。行者修习定时若生烦恼。于中生智除此烦恼。欲令三昧为圣清净。是名初智。圣清净者。谓非凡夫所近。是智者所赞。非凡夫者。谓诸圣人以得智故不名凡夫。此智能破假名。是第二智。薄诸烦恼贪等烦恼灭。故名寂灭。寂灭故妙。离诸烦恼故得名为离。得此皆是离欲道。是第三智。随证烦恼断。得安隐寂灭。离热乐故名现乐后乐。现乐名离烦恼乐。后乐谓泥洹乐。是第四智。行者常行无相心。故常一心出入。是第五智。是故若未生此第五智者。应生若生即得三昧果

    六三昧品第一百六十一

问曰。经中说六三昧。有一相修为一相。有一相修为种种相。有一相修为一相种种相。种种相修亦如是。何者是耶。答曰。一相者应是禅定。禅定于一缘中一心行。故种种相应是知见。知诸法种种性故。于五阴等诸法中方便故。问曰。云何一相修为一相。答曰。若人因定还能生定者是。一相修为种种相者。若人因定能生知见者是。一相修为一相种种相者。若人因定能生禅定及五阴方便者是。种种相修亦如是。问曰。有论师言。一相修为一相者。若人因第四禅证阿罗汉果是也。一相修为种种相者。若人因第四禅证五神通者是。一相修为一相种种相者。若人因第四禅。证阿罗汉果及五神通者是。种种相修为种种相者。若人因五枝三昧。证阿罗汉果及五神通者是。余二亦尔。是义云何。答曰。应说因缘。何故第四禅及阿罗汉果是一相五枝三昧及五神通名种种相。又五枝不可为依。五枝三昧是四禅明相观相。云何依此得阿罗汉果。所以者何。要依一禅得阿罗汉果。又亦不应依明相得阿罗汉果。是故非也。问曰。有人说。六种入定。顺入逆入逆顺入顺超逆超逆顺超。是事云何。答曰。有论师言。行者欲趣灭尽定。故次第入出诸禅。是故不应若逆若顺若逆顺及超越等。五种入出得何利耶。行者欲至灭尽定。必应次第入。亦应次第起。又若得上地何故更入下地。下地刺棘。如人不复乐小儿戏又如人以巧不复乐拙。是事亦应如是。又若说超越是事不然。经中但说次第入诸禅定。行者若能超至第三。何故不能超至四五。若言力势齐此。如人登梯。可超一桄。不能超二。此喻亦不必定。又大力人能至四桄。亦有能越百步。是故不然。经中虽说佛入泥洹时逆顺超越入诸禅定。此经与正义相违不可信受。虽有此言是义不然。所以者何。若说行者趣灭尽定。但应顺入不须五种。行者若欲直趣灭定。是则不须。若欲自试心于禅定中。能自在不退。故逆顺出入超越。如人乘马。若对敌阵则不须盘。若欲调习于闲时。则可。若言下地刺棘不应入者。不以下地胜后便入。以是行者所行道故。若言如人不乐小儿戏者。或以因缘为小儿戏。如老伎人终日舞戏非情所乐为教习故。如是圣人逆顺出入超越诸禅。欲示天人及诸神仙诸禅定中自在力故。又佛入泥洹时。欲以深妙禅定熏修舍利故。自在入出逆顺超越。又人见佛入无余泥洹。则厌恶一切诸有为法。是故佛现珍爱此法。汝言此经违正义者。是事不然。汝言何故不能超至四者。菩萨藏中说超越相。从初禅起入灭尽定。从灭尽定起乃至入散心中。以心力大故能如是

    七三昧品第一百六十二

论者言。有七依依初禅得漏尽。乃至依无所有处得漏尽。依名因。此七处得圣智慧。如说摄心能生实智。有人但得禅定谓之为足。是故佛言此非足也。应依此定更求胜法。谓尽诸漏故说为依。问曰。云何依此禅定得尽诸漏。答曰。佛说行者随以何相何缘入初禅。是行者不复忆念是相是缘。但观初禅中所有诸色若受想行识。如病如痈如箭。痛恼无常苦空无我。如是观时心生厌离解脱诸漏。乃至无所有处亦如是。但三空处无色可观。行者见欲界愦乱初禅寂灭然后乃得。是故佛言。勿念初禅寂灭乐相。但观初禅五阴八种过患。余依亦尔。问曰。欲界何故不说依耶。答曰。须尸摩经中说。除七依更有得圣道处。故知欲界亦有。问曰。有人言。依初禅边未到地得阿罗汉果。是事云何。答曰。不然。若未到地有衣。是则有过。若能得未到地。何故不入初禅。是故不然。问曰。非想非非想处何故不说依耶。答曰。彼中不了定多慧少。故不说有依。七想定即七依也。问曰。佛何故说七依。名七想定。答曰。外道无真智故但依止想。一切依止皆为想所污不为解脱。故名想定。圣人能破坏想。但依此定直取漏尽。故名为依。如说行者观此诸法如病如痈等。非想非非想处亦以想不了。故不说想定

    八解脱品第一百六十三

论者言。经中说八解脱。初内色想观外色。行者以此解脱破坏诸色。何以知之。第二解脱中。说内无色想观外色。以破内色故言内无色想。故知行者于初解脱中渐坏身色。至第二解脱中。内色已坏但有外色。第三解脱中外色亦坏。故不见内外色。是名色空。如波罗延经中说。坏裂色相断灭诸欲。内外无见。我问是事。四解脱中说心识空。如六种经中说。若比丘于五种中深生厌离。余但有识。当知是中四解脱坏裂诸识。第八解脱一切灭尽。所以者何。若灭色灭心。则有为都灭。是名阿罗汉果。以如是次第乃得灭尽。是名八解脱。有人言。初二解脱是不净。第三解脱名净。此事不然。所以者何。是名解脱。无有以不净观而得解脱。净观亦无解脱。但以空观能得解脱。又外道能得净不净观。而不名得解脱。问曰。外道亦能坏裂色相。此事云何。答曰。外道以信解观破坏色相。非空观也。所以者何。如用信解观。见身已死弃之冢间虫狩食等。问曰。外道离色得无色定。应有无色解脱。答曰。外道虽有无色定。以贪着故不名解脱。圣人因无色定。能观四阴病等八事。故名解脱。问曰。汝说灭定是阿罗汉果。此事不然。所以者何。学人亦名得八解脱。汝说灭定名为漏尽。然则学人应得漏尽。答曰。经中总相说灭。不分别言是心灭是烦恼灭。如经中说。二种灭。一灭。二次第灭。二种泥洹。一现在泥洹。二究竟泥洹。亦说二种安隐。一安隐。二第一安隐。得安隐者亦二种。一得安隐。二得第一安隐。是故学人所得非真实灭。又经中说。若比丘能入灭定。一切事讫。若灭定非罗汉果。则不应说一切事讫。问曰。学人实不得八解脱耶。答曰。经中说学人得九次第定。不说得灭尽。行者若得灭尽。而不能入诸禅定。名慧解脱。若能入诸禅定。而不得灭尽。是名身证。若二俱得名俱解脱。所以者何。诸漏是一分障。禅定法是一分得。解脱二分名俱解脱。问曰。诸次第中灭。诸解脱中灭。有异耶。答曰。名同而义异。次第中灭名心心数灭。解脱中灭名诸烦恼灭。如经中说。诸行次第灭。谓入初禅语言灭。入二禅觉观灭。入三禅喜灭。入四禅乐灭。入空处色相灭。入识处空相灭。入无所有处识相灭。入非想非非想处无所有想灭。入灭尽定诸想受灭。于此诸灭更有胜灭。所谓行者于贪恚痴心。厌得解脱。问曰。云何知次第中心心数灭。解脱中诸烦恼灭。答曰。灭名虽同义应有异。次第中说想受灭。解脱中说无明触受灭。所以者何。从假名生受。破假名则灭。次第中不尔。诸经中如是差别。若直说行者得灭尽则一切事讫。当知为证泥洹时诸烦恼灭。不说心心数灭。问曰。若八解脱是灭烦恼法。则一切阿罗汉悉皆应得。答曰。皆得。但不能入。若得诸禅定则能得入。问曰。行者若无禅定。云何能得身心空。及尽诸烦恼。答曰。是人有定而不能证。更有如电三昧。因是三昧得尽烦恼。如经中说。我见比丘欲取衣时有烦恼。取衣已即无烦恼。如是等所以者何。心如电三昧如金刚。真智能破烦恼。又此义佛第三力中说。所谓诸禅解脱三昧入垢净差别如实知。于中禅名四禅。有人言。四禅四无色定皆名为禅。解脱名八解脱。三昧名一念中如电三昧。入名禅解脱三昧中得自在力。如舍利弗说。我于七觉中能自在出入。故知慧解脱阿罗汉有诸禅定。但不能入。深修习故能自在入。问曰。阿罗汉何故有不深修习诸禅定者。答曰。是人得道所作已办乐行舍心。故不善习。若无舍心则入定无难。如经中说。行者善修四如意足。能吹雪山令为尘末。何况死无明耶。故知八解脱中说漏尽灭。非入定灭。又经中说。有明性有空性。有无边虚空性。有无边识性。有无所有性。有非想非非想性。有灭性因闇故有明性。因不空故有空性。因色故有无边虚空性。因无边虚空性故。有无边识性。因无边识故有无所有性。因无所有故有非想非非想性。因五阴故有灭性。若不能破坏五阴假名相。是名为闇。若能破坏五阴假名。则名明性。如佛教一比丘。汝于空诸行中。当观诸行空自调伏心。如人持灯入空室中所见皆空。行者取色证此色灭。是名空性。外道因无边虚空处得离色。乃至因非想非非想处。离无所有处。因诸阴有灭性者。行者所有思量。所有作起皆灭为妙。是名因诸阴有灭性。问曰。是诸性依何定得。答曰。经中说。明性乃至非想非非想性。皆以自行入定故得。谓行缘有为道故得。所以者何。缘色初智是名明性。第二性亦取色。取已分别令空。如是乃至非想非非想性灭性入灭性一切有为法空故得。是中灭尽诸有为故。故知此中说灭名为漏尽泥洹。问曰。此诸解脱在何地中。答曰。行者欲破坏色。或依欲界系定。或依色界定。能得色空。一切地中能得心空。问曰。此解脱几有漏几无漏。答曰。是空性故一切无漏

    八胜品第一百六十四

初胜处。内色想见外色少若好若丑。于是诸色胜知胜见。故名胜处。第二内色想见外色多。第三内无色想见外色少。第四内无色想见外色多。第五内无色想见外青色青形青光。如忧摩伽花。如真青染波罗奈衣。第六见黄。第七见赤。第八见白。行者见如是等无量诸色。所以者何。非但有此青等四色。以略说故有八胜处。行者若能以空坏裂诸色。尔时名为胜处。问曰。谁能得此。答曰。是佛弟子非余人也。问曰。是八胜处在何地中。答曰。在欲色界。问曰。为有漏为无漏。答曰。先是有漏。以空坏色则名无漏。问曰。何故此法独名胜处。答曰。此是行者所贪着处。是故佛为弟子说名胜处。示胜此缘故

    初禅品第一百六十五

九次第定。四禅四无色定。及灭尽定。初禅者。如经中说。行者离诸欲诸恶不善法有觉有观。离生喜乐入初禅。问曰。应但说初禅相。何故乃说离诸欲耶。答曰。有人谤言。世间无有能离欲者。以世人皆处五欲中故。无人眼不见色。耳不闻声。鼻不嗅香。舌不知味。身不觉触。故说离欲。欲名欲心。非是色等。如说色等诸物不名为欲。何以知之。有精进者色等犹在。而能断欲。又经中说。色等是分不名为欲。是中贪心则名为欲。若生贪心则求诸欲。求欲因缘故。有贪恚鞭杖杀害恶法随逐。如火因经中说。因爱生求等。故知离贪欲故名为离欲。有人言。离色等五欲名为离欲。离恶不善法名离五盖。初禅近散乱心。故名有觉。又此行者定力未成。散乱心发故名有觉。如经中说。我行有觉有观行。当知佛说散心为觉。是觉渐微摄心转深。则名为观。随定成就。心不多散。是时名观。是观随逐行者至禅中间。若离觉观得喜名离生喜。是喜初得能利益身。故名为乐。是离觉观喜住一缘中。是名为禅。是禅为觉观所乱。故得异身果报。以下中上差别故。有梵众天梵辅天大梵天。问曰。若离觉观喜名初禅者。则不复以五枝为初禅。若离觉观与第二禅有何差别。又经中说。初禅有觉有观。猗乐异喜亦异。若喜即是乐。则七觉意中不应。别说猗觉意也。答曰。汝言初禅无五枝。是事不然。不说五枝是初禅性。初禅近地有此觉观。故名为枝。问曰。若近地有法数为枝者。初禅亦近五欲。则应说为枝。答曰。五欲不名为近。此行者心已离故。又初禅次第不起欲心。又五欲不住为初禅枝。枝名为因。因即是分。如圣道分集会具等。觉观亦尔。是初禅因。若行者定心于缘中退。还取定相。摄心于缘忆念本相。是名觉观。故知觉观是初禅因。第二禅中定心已成。是故不以觉观为因。亦二禅次第不生觉观。若汝说初禅与觉观俱。是亦不然。从初禅起次生觉观。以杂觉观故名为俱。如与弟子俱行。虽小相远亦名为俱。又此地中有生因缘。故名有觉观。如鬼病人。虽不发时亦名为病。是人为鬼所污。有缘还发故名为病。又乐受即是喜。但差别说。亦从猗别说为乐。如经中说得身猗则受乐。问曰。若尔初禅何故说五枝耶。答曰。随时说五。如七觉意得时节故名十四觉意。是中说有身猗心猗。而实无身猗。但心乐故身亦受乐。喜亦如是。初来在身名为喜。乐喜初得相故名为乐。后但名喜以时异故。又无别猗法。但喜生时身心无粗重法。柔软调适故名曰猗。如病四大灭。无病四大生。是人名乐。猗亦如是。又于除灭中亦说名猗。如经中说。诸行次第灭。如入初禅语言灭。乃至入灭尽定诸想受灭。是故无别猗法。若说初禅与觉观相应。是亦不然。所以者何。经中说。行者若入初禅则语言灭。觉观是语言因。云何有语言因而语言灭。若谓觉观犹在但语言灭者。若人在欲界心不语言时。亦名为灭。问曰。若初禅中无觉观者。应名为圣默然。而佛但说二禅为圣默然。不说初禅。故知初禅应有觉观。答曰。以近觉观故不说默然。非觉观相应故不说也。又经中说。初禅有音声刺。故不说默然。问曰。初禅何故以音声为刺。答曰。初禅住定心弱如花上水。第二禅等住定心强如漆漆木。又触等亦名为初禅刺。以触能令起初禅故。二禅等不尔。所以者何。以初禅中诸识不灭故。第二禅等五识灭故

成实论卷第十二成实论卷第十三

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    二禅品第一百六十六

灭诸觉观。内净一心无觉无观定生喜乐。入第二禅。问曰。若第二禅说灭觉观。当知初禅必有觉观。如二禅中有喜故。三禅说灭喜。答曰。如初禅中无苦根亦说苦根。第二禅灭此亦如是。问曰。初禅中虽无苦根而有诸识。诸识是苦根所依。故说初禅苦根不灭。答曰。初禅中虽有诸识非苦根所依。问曰。五识性是苦根所依。以性同故说初禅有苦。答曰。若尔忧根从意识性生。故应一切处有。问曰。今何故说二禅中苦根灭。答曰。初禅近不定心。不定心者能生欲界系诸识。于中生苦根。是故不说初禅苦灭。问曰。若尔初禅亦近忧根。是忧根亦应说若第二第三禅灭。答曰。依欲忧根从依欲喜生。得净喜则不净喜灭。是故初禅中无忧根。依不定生苦根。初禅近散心故不名为灭。又如三禅无苦。亦说断苦乐故入第四禅。是事亦尔。又行者于初禅中定未具足。常为觉观所乱。故说二禅灭诸觉观。内净者二禅摄心深。故散乱常不得入内无乱心故名内净。是二禅体一心。无觉无观者。一心名。心行一道亦名为禅。即是内净。得此深定故觉观不生。不如初禅心数在觉观。故说无觉无观。定生喜乐者。初禅以离故得喜。此中定成就故得喜。故曰定生。问曰。初禅中喜二禅中喜有何差别。答曰。初禅以灭忧故喜。二禅灭苦故喜。又初禅中喜违不净喜故得。二禅中喜违净喜故得。虽俱以爱因缘故喜。而初禅喜弱。问曰。如是义为有漏为无漏。答曰。皆是有漏。有我心则有喜。若无漏心则无我。无我故无喜。问曰。无漏无喜是事不然。佛七觉中说喜觉分。觉分但是无漏。故知有无漏喜。又经中说。心喜者得身猗。身猗则受乐。若无无漏喜亦应无无漏猗乐。又佛见众僧深行善法。则生欢喜。故知有无漏喜。答曰。汝以七觉证无漏喜。是事不然。觉分二种。有漏无漏。如经中说。行者听法时能断五盖。修七觉分。又觉名无学智。若为觉行不净等法。皆名觉分。汝说亦不应有无漏猗者。先生喜已后得无漏。谓如实知见。又非一切猗皆因喜生。如三禅已上无喜亦有猗。又我等不说离智别有受法。此无漏智初来在心说名为乐。是故有无漏乐。但不因喜生。又经中说。除身心粗重名猗。得无漏时身心调适。是故有无漏猗。又佛常行舍心。是故言佛有喜。此事应明。又若人无我我所则无喜。若罗汉有喜。亦应有忧。而实无忧故知无喜。问曰。如初二禅有喜无忧。罗汉亦尔。有喜无忧有何咎耶。答曰。诸禅定中有忧如根义中说。忧喜乃至有顶。苦乐随身乃至四禅。又趣三禅中说离喜行舍。故知无无漏喜若有云何言离。又无漏心不应有喜。喜皆依假名想分别。有问曰。若尔则初二禅中无无漏受。经中说。初禅二禅但有喜未有心乐。今喜亦无复何所有。答曰。此喜离喜等不说无漏禅。更有经说无漏禅。所谓行者。何相何缘。入初禅不念是相是缘。但观初禅中所有色受想行识。如病如痈乃至无我。问曰。如病如痈如箭痛恼。此四是世间行非无漏。是故汝以此经为证。不能成无漏也。答曰。此四行皆是苦之异名。故名无漏。问曰。学人亦无无漏喜耶。答曰。若在道心尔时无喜。在俗则有。无学常无。问曰。经中说。以喜乐心能得四谛。云何言无无漏喜。答曰。无我心即名为乐。行者得无我心。破坏颠倒知真实故。心则快乐无别有喜。又此经明不以喜能得实智。故如是说

    三禅品第一百六十七

离喜行舍忆念安慧受身乐。是乐圣人亦说。亦舍忆念行乐入第三禅。问曰。何故离喜。答曰。行者见喜能漂故离。又此喜从想分别生。喜动转相。从初已来苦常随逐。以此故离。又行者得寂灭三禅故舍二禅。又从喜生乐浅。离喜生乐深。如人于妻子等不能常喜。以喜从想分别生故。乐不从想分别生故。能常有。行者亦尔。喜初来则以为乐。后则厌离。问曰。若人为热所恼则以冷为乐。行者为何苦所恼。故以三禅为乐。答曰。二禅中喜是发动相如刺棘。行者为此喜所恼。故于无喜定中而生乐心。问曰。随有热苦则以冷为乐。若得离热冷则非乐。行者若以离喜。何故于三禅中犹生乐心。答曰。生乐二种。或由苦在。如有热苦则以冷为乐。或由离苦如离怨憎。如佛离拘舍弥比丘言我安乐。是事亦尔。得离动相故于二禅生乐。如离五欲故以初禅为乐。行舍者。以离喜故心得寂灭。行者先深着喜心多散乱。今得离故其心寂灭。故说行舍。忆念安慧者。于喜过中此二常备。不令喜来破坏。又忆念者。忆念喜安慧见喜中过。受身乐者。离喜行舍舍即是乐。以无动求故。是乐不从想分别生。故名身受乐。圣人亦说。亦舍者说名随世人。故说名为乐。如说非想非非想处心。不贪着故舍。忆念行乐者。是人知舍。谓见喜过而生厌离。故得妙舍。又忆念亦妙。谓能念喜过。此中亦应说安慧。与念同行故不说。乐者是第一乐。是故圣人亦说亦舍。问曰。三禅中有受乐。何故说舍乐。答曰。我此论中不说离受别有舍乐。受乐即是舍乐。问曰。若尔第四禅中应说受乐。以有舍故。答曰。我说四禅亦有受乐。但为灭第三禅乐故如是说。问曰。若俱是受乐。何故初禅二禅名喜。三禅名乐。答曰。以想分别故名喜。无想分别故名乐行者于第三禅心转摄故。无想分别故名为乐。又得三禅寂灭转深。故名为乐。如说动求心圣人名苦。动名分别言此是乐

    四禅品第一百六十八

除断苦乐先灭忧喜。不苦不乐舍念清净入第四禅。问曰。若先断苦何故于此中说。若必欲说应言先断。如先灭忧喜。答曰。四禅名不动欲成此不动相故。说无四受。所以者何。动名发动。行者为苦乐所侵则心动。心动则生贪恚。故断苦乐。令心不动。问曰。若第四禅受利益最大。何故不名为乐。答曰。是受寂灭故说不苦不乐。随心念知此是乐则名为乐。得第四禅离三禅乐。故不以为乐。舍念清净者。此中舍清净。以无求故。三禅有求谓此是乐。又此禅中念亦清净。所以者何。三禅中以着乐故忆念散乱。至第四禅中贪乐断故。忆念清净。问曰。何故四禅不说安慧答曰。若说忆念清净。当知已说安慧。以此二法不相离故。又此是禅定道非智慧道。安慧是慧故不说。第三禅后分中亦不说安慧。但说行舍忆念乐。不说行舍念慧乐。又此忆念能成禅定。若人定未成时要以取想忆念能成。所以独说。又得上功德舍下功德。不须思惟故不说慧。问曰。不苦不乐受是无明分。四禅中多与慧相违。故不说慧。答曰。若尔不苦不乐受不应为无漏。乐受是贪分故亦无无漏。问曰。三禅中为违自地过故说安慧。为违他地过故说忆念。四禅自地无如是过。故不说安慧。答曰。四禅亦有贪等过故应说安慧。是中贪过细微难觉。故必应当说。余地中亦应说而不说。故知应如我答。问曰。何故四禅出入息灭。答曰。息依身心。何以知之。随心细时喘息亦细。四禅心不动。故出入息灭。又如人疲极。若担重上山则喘息粗。息时则细。四禅亦尔。以无动相心止息。故出入息灭。有人言。行者得四禅四大故。身诸毛孔闭。是故息灭。此事不然。所以者何。饮食汁流充遍身中。若诸毛孔闭则不应行。而实不可。故知四禅心力能令息灭。问曰。四禅中无乐受。是中云何有爱使。经中说乐受中爱使。答曰。是中有细乐受。但断粗乐。故说不苦不乐。如风动灯。若置密室则名不动。是中必有微风。然但无粗风故名不动。四禅亦尔。必有细乐。断粗苦乐故。名不苦不乐

    无边空处品第一百六十九

过一切色相灭有对相。不念一切异相入无边虚空处。色相名色香味触相。行者以何故过。谓此色中有对有碍。及诸异相。谓钟鼓等。此诸相是种种烦恼种种业种种苦因。以此故过。若过一切色相则有对相灭。有对相灭则无异相。是中略故。不说过此故此灭。复有人言。一切色相者。即是眼识所依止相。有对相者。是耳鼻舌身识所依止相。异相者是意识所依止相。此事不然。所以者何。若言灭有对相。则已摄色。何故别说。又离色相对相。无别有意识所依止色。是故不应别说异相。应如先说。入无边虚空处者。行者以色相逼闹疲惓故观无边虚空。内取眼鼻咽喉等虚空相。外取井穴门向树间等虚空相。又观身死弃之冢间。火烧灭尽。若鸟狩食啖虫从中出。故知此身先有虚空。问曰。是虚空定以何为缘。答曰。初缘虚空成已自缘诸阴。亦缘他诸阴。所以者何。以悲为首作如是念。众生可愍为色相所恼。问曰。此定何众生缘。答曰。缘一切众生。问曰。是行者离色相。云何能缘欲色众生。答曰。是行者能缘色。但于色中心不通畅。不乐不着。如经中说。若圣人深见忆念五欲。于中不乐不通不着。畏没退还如烧筋羽。若念泥洹心则通畅。此人如是亦能缘色。但不贪乐。又如行者虽离色相以虚空边能缘四禅。如无色定能缘无漏色。是中无过非烦恼处。故余亦应尔。问曰。虚空是色入性。云何缘此能过色相。答曰。此定缘无为虚空。故能过色。问曰。此定不缘无为虚空。所以者何。此定方便中说缘眼等中空。故知缘有为虚空。又经中不说无为虚空相。但说有为虚空相。所谓无色处名虚空。是故无无为虚空。答曰。色性不名虚空。所以者何。经中说虚空无色不可见不可对。问曰。更有经说。因明知虚空。除色无有余法因明可知。答曰。无色名虚空。诸色以明可知。是故因明则知色无。非有虚空。又于闇中亦知虚空。盲人以手亦知虚空。又以杖亦知此是虚空。故知虚空非是色性。色不以此等因缘可知。又色是有对虚空无对。又以火等能尽灭色。而不能灭虚空。若虚空灭更名为何法。问曰。若有色生则虚空灭。如起墙壁是中则无复有虚空。答曰。此中色生。是色竟无所灭。所以者何。色无名虚空。无法不可更无。是故色不灭空。又汝言虚空是色。此中无有因缘可令是色。问曰。现见门向等中虚空。现见事中不须因缘。答曰。虚空不可现见。先已破故。所谓闇中亦可知等。问曰。若虚空非色为是何法。答曰。虚空名无法。但无色处名为虚空。问曰。经中说。因六种故众生受身。又说。虚空名不可见无色无对。若无法。不得作如是说。无有说兔角。名不可见无色无对。答曰。若实有法皆有所依。如名依色色亦依名。虚空无依故知无法。汝言空种是亦不然。所以者何。色碍于色是色得异色无。故得增长。以此义故。佛说因六种众生受身。汝言虚空无色无形无对。亦以破诸物。故作如是说。不说有虚空相。汝言无有说兔角。为不可见无色无对。是亦不然。所以者何。皆由虚空得有所作去来等事。兔角等中无如是义。问曰。心亦如是。无色无形无对可言无耶。答曰。心有作业谓能取缘。虚空无业。但以无故得有所作。故知无法。是故此定初缘虚空。问曰。此定能缘何地。答曰。缘一切地及缘灭道。问曰。有人言。诸无色定虽能缘灭。但缘比智分灭不缘现智分灭。是事云何。答曰。缘一切灭。以现法智缘现在自地灭。以比智缘余灭。道亦如是。能缘一切法故。问曰。生无色界众生。能起余地心不。答曰。能起余地心及无漏心。问曰。若尔云何不没。答曰。住业果报中。故能不没。如欲色界中神通力故。住异色异心而能不没。彼中亦尔。问曰。无边虚空定与虚空处一切处。有何差别。答曰。欲入虚空定方便道名一切。入定成已名虚空定。是中定因果。是地一切有漏无漏。若定非定若垢若净。皆名无边虚空处

    三无色定品第一百七十

过一切无边虚空处。入无边识处。行者深厌色。故亦舍色治法如人渡河已亦弃船去。如得出贼欲远舍去。行者亦尔。虽因空破色亦欲远去。无边识者。行者以识能缘无边虚空则识无边。是故舍空缘识。又如为色疲倦故缘虚空。如是为虚空疲劳欲止息故。但缘于识。又此人以识能缘空故。谓识为胜。故但缘识。行者以识随缘随时故有无边疲惓。厌离欲还破识。故入无所有处。作如是念。随有识则苦。我若有无边识。必当有无边苦。是故摄缘识心。心微细故谓无所有。复作是念。无所有即是想。想为苦恼如病如痈。若无想复是愚痴。我若见无所有即为是有。故于诸想未得解脱。行者见想为衰患无想为痴。寂灭微妙。所谓非想非非想处。凡夫常怖畏无想以为愚痴。是故终无能灭心者。有人言。无想众生亦能灭心。是事不然。所以者何。若色界中能灭心者。无色界中何故不能。问曰。色界有色故能灭心。无色界中先已灭色。今复灭心。若见色心俱灭则惊怖迷闷。答曰。若在彼中不能灭者。于此间生则应能灭。如灭尽定。问曰。是灭心果无想。是故若灭色心则为永失。答曰。灭尽定亦有有心果。此事亦尔。又若果不断亦名住于果。如在变化色。变化心中还生果。故不名永灭。是故色界中不应说灭心。若说者无色界中亦应当说。又无想定中心不应灭。所以者何。行者要厌离心故能灭心。若厌心者。尚不应生无色界中。况生色界。又凡夫于心深生我想。如经中说。凡夫长夜贪着此心。谓之为我。是故不能无余厌离。又经中说。外道能说断灭三取。而不能说断我语取。是故不能灭心。又若正知因缘法者。能得心空。如猿喻经说。凡夫或能离身。而不能离心。宁观身常勿观心常。所以者何。眼见是身或住十岁乃至百年。所谓若心若意若识。如事念念生灭变异。如猿猴缘树舍一枝攀一枝不住一处。若圣弟子于中正观因缘法故。能知无常。又知因缘法者。以受差别故。能分别识。诸外道辈以无分别因缘智故。不能灭心。又凡夫离色不离心。故不得解脱。若俱能灭心。复以何故不得解脱。又凡夫人怖畏灭故。于泥洹中终不能生安隐寂灭想。如经中说。无我无所有。是凡夫人深怖畏处。又于无想中生愚痴心。若于泥洹不生寂灭安隐想者。云何当能灭心。又凡夫法要因上地能舍下地。是故无能灭心因缘。但以定力细想现前心不觉故。自谓无想。若起粗想即时退堕。如少智人名曰无智。如食少碱名为无碱。如迷闷失念。蛰虫冰鱼。如说非想非非想处。此中亦尔。虽实有想随世俗故说名无想

    灭尽定品第一百七十一

过一切非想非非想处。身证想受灭。问曰。何故诸禅中不说过一切。无色定中不说灭耶。答曰。我说诸禅定中皆有觉观喜乐等法。是故不说过一切也。问曰。无边虚空处有色心。此事已明。故无色中亦不应说过一切。答曰。若入无边虚空定中。得脱色心。而不得脱觉观等法。复有人言。若说过灭没。皆义一而异名。又无色中定心坚固。下地中心为散乱所坏。是故不说过一切。问曰。若俱说有刺棘谓色相等。何故说心坚固耶。答曰。虽俱说刺棘亦名第四禅为无动。如是无色定中定力大故。得名坚固。问曰。学人不应得灭尽定。以未过一切非想非非想处故。答曰。学人能见非想非非想处一切行灭。但未能令其不生。故得说过。问曰。若此中意以泥洹为灭者。汝先言九次第中灭是心心数灭。是则相违。答曰。灭定二种。一者诸烦恼尽。二烦恼未尽。烦恼尽者在解脱中。烦恼未尽者在次第中。一灭烦恼故名灭定。二灭心心数法故名灭定。灭烦恼是第八解脱。亦名阿罗汉果。阿罗汉果名灭一切想令不复生。此中虽灭诸想。有余结故不能令更不生。问曰。若行者以九次第定能灭心者。须陀洹等云何能证心灭法耶。答曰。九次第中灭名为大灭。若人善修诸禅定。道心力强故能得此灭。若无斯力则但有灭。不能如是为大力故。说次第定。余处亦有心灭。如第四禅中能灭心心数法入于无想。初禅等中何故无灭。又余处亦应有灭心义。如经中说。须陀洹等皆能证灭。但心灭名灭。更无余法灭。故知离此九地亦有心灭。问曰。若灭尽定能灭一切心心数法。何故但说想受灭耶。答曰。一切心皆名为受。是受二种。一想受。二慧受。想受名有为缘心。以想行假名法中故。假名二种。一因和合假名。二法假名。是故一切有为缘心皆名为想。慧受名无为缘心。是故若说想受灭者。则为说一切灭。问曰。一切心心数法中受想最胜。是故独说。所以者何。烦恼有二分。一爱分。二见分。受生爱分。想生见分。又欲色界中受胜。无色界中想胜。是故但说二种。又诸识处中但说受想。识处从心起故即名为行。又若说受想灭则说一切心心数灭。以诸心数不相离故。答曰。不然。汝言胜故独说。应当说心。所以者何。处处经中说。心为王。亦是二分烦恼所依。亦以心差别故名为受想。故应说心。又说心则易。是故汝说非也。问曰。此定何故说身证耶。答曰。八解脱皆应说身证。又是灭法非言所了故说身证。如触水者则知冷相。非闻能知。此事亦尔。又此是无心法。故应以身证。问曰。汝说灭定是无心法。此义不然。所以者何。入此定者是众生。世间无有无心众生。是故不然。又经中说。命热识此三法常不相离。故无灭心。又一切众生皆以四食得存。入灭尽定则无诸食。所以者何。是人不食揣食。触等亦灭。故无食也。又心从心生。若此心灭余心不生。无次第缘故。后心云何更生。又心但入无余泥洹。断相续时灭。非余处灭。如经中说。以色过诸欲。以无色过色。以灭过诸作念思惟。心为作念思惟。要以灭能过。得有余泥洹则垢心灭。得无余泥洹则无垢心灭。此是佛法正义。又入灭定者不名为死。心灭名死。若灭心还生。死者亦应更生。然则终无有死。若灭心还生。入泥洹者亦应还生。然则终无解脱。而实不然。故心不灭。答曰。汝言无无心众生。虽同无心而异于死。如经中。问入灭尽定者。与死有何差别。答曰。死者命热识三事都灭。入灭尽定者但心灭而命热不离于身。故知应有无心众生。又是人心得常在。以得力故亦名有心。不同木石。汝言三事不相离者。为欲色界众生故。说无色界中有命有识而无热。又入灭尽定者。有命有热而无识。即此经中亦说识离于身。是故若言三事不相离者。随有处说。汝言无食云何存者。此身已先意思食故住现在。以冷等触故能持身。汝言心因心生心与异心作因。作因已灭。是故能生异心。问曰。云何灭心能生异心。如眼已灭则不能生识。答曰。如已灭业能生果报。是事亦尔。又意与意识二事相碍。眼与眼识不如是。是故非因。汝言断相续时心灭。是事不然。灭有二种。色灭心灭。或色灭非心。如无色中。或心灭非色。如入灭定。或色心俱灭。如断相续时。汝言入灭尽定不名死者。是人命热。不灭死者三事都灭。是则为异。又此人因命热故心能更生。死者不尔。汝言若灭心还生则无解脱。是事不然。所以者何。入泥洹者。先业所受命热识灭不期更生。此人命热不灭。先期心生。如灭尽定品中说。入灭尽定者。因是六入及身命故还能起。是故心能更生。入泥洹者心更不生。故知此定无心。问曰。何故施起此定者能得现报。答曰。从此定起心深寂灭。如经中说。起灭定者心顺泥洹。又是人禅定力强。依此定故智慧亦大。智慧大故能令施者得胜果报。如人供养百千声闻不如一佛。是中皆以智慧为胜。不在断结。是事亦尔。又入此定者。以多善法勋修其心。故生大果。如善治田所收必多。又施能厌世者。则得大报。起灭定者深恶世间。是故供养为胜。又施净心者得大果报。非垢心者。此人不以假名垢心。是故供养得大果报。又是人常在第一义谛。余人住于世谛。又此人常住无诤法中。所以者何。有为缘心则有诤讼。又如经中说。稊稗害禾。贪欲害心。是故施无欲人得大果报。贪欲因缘谓假名相。起此定者缘泥洹故。离假名相。又经中说。若人受檀越供已入无量定。是檀越以此因缘得无量福。起灭定者。缘泥洹心是名无量此灭亦是无量。得无量福。故能得现报。又以八功德严此福田。泥洹缘心是真正见。余分随从。是故能生现报。问曰。有人言。灭尽定是心不相应行。亦名世间法。此事云何。答曰。如上说。起此定者有深寂灭等诸功德。是功德世间所不应有。问曰。灭尽定名为遮法。以此法故令心不生。是故应名心不相应行。如铁得火则无黑相离火还生。此事亦尔。答曰。若尔者泥洹亦应是心不相应行。所以者何。因泥洹故余阴不生。若泥洹非心不相应行者。此定亦不应名不相应行。但诸行者法应如是。入此定中随所愿故心能不生。是故不应说名不相应行。问曰。此定如是次第入者。亦应次第起耶。答曰。亦次第起渐入粗心。问曰。经中说初起灭尽定者。触三种触。所谓无动无相无所有。何故如是。答曰。无为缘心中所有触名无动无相无所有。无动即是空。有为缘心轻故有动。所谓取色受等。空中无相。无相中无贪等所有。此无心者初缘泥洹。后缘有为。故说起时触三种触。问曰。有人言。入灭尽定心是有漏。起定心或有漏或无漏是事云何。答曰。非有漏。行者欲入此定。先来破坏一切有为破已故入。起时泥洹缘心现前。故知俱是无漏问曰。经中说。行者入灭尽定不自念入。起时亦不自念。若尔云何能入。答曰。常修习故定力坚强。虽不自念而能得入。又此行者从断有为尔来入灭。若不制心令缘有为。则不名入。是故经说。入此定者先调习心。故能得入。问曰。若无异空可得修无为缘心更得何利。答曰。久修习故定则坚固知见明了。如有为缘心见念念灭。亦无异念念灭。但久修习则心坚固。此事亦尔

    十一切处品第一百七十二

不坏前缘心力自在名一切处。行者取少相已。以信解力令其增广。所以者何。此摄心力。若入实中。则皆能令空。入信解中皆能令随先所取相。问曰。何者是信解性。答曰。青等诸色无量。略说其本有四。地等四大是。四色本能破此八事。是名虚空。以识能知无边空。故亦名无边。所以者何。非有边法能取无边。是名为十。问曰。地中实有水等。行者云何能观但是地耶。答曰。久习此观常取地相。后但见地不见余物。问曰。行者所见地相实为地不。答曰。以信解力故见为地。非实为地。问曰。若变化力有所变化亦非实耶。答曰。变化以定力成。故所作皆实。所谓光明及水火等。问曰。有论师言。八一切处但在第四禅中。是事云何。答曰。若在欲界及三禅中。有何咎耶。后二一切处各当自地。此十皆是有漏。以不坏缘故。问曰。虚空相非破色耶。答曰。行者亦以信解取眼鼻等空相为空。不能直破实色。是故亦名信解。问曰。经中说。入一切地定者。念地即是我我即是地。何故作如是念。答曰。行者见心遍满故生此念。一切是我。问曰。有人言。此定但缘欲界系地等。是事云何。答曰。若缘一切欲色界系地等有何咎耶。假令此定更缘余法。复有何咎。又此定是信解观虚妄缘无有不虚地等。问曰。佛弟子亦观地等。是事云何。答曰。学人若观皆为破坏。问曰。实非一切皆是地等。云何此定非颠倒耶。答曰。此观中有痴分。以此观中起我见故。不净等观虽非真实而随顺离欲。此观不尔。故有痴分。问曰。何故不观受等无边。但观识耶。答曰。可取是地等。取者是识。是故见识不见受等。又先说受等皆心之差别。又行者不见受等遍满。以不一切处受苦乐故。佛弟子若行此定。为坏缘故。所以者何。此缘是行者所贪着处。若不破坏则同凡夫

    无常想品第一百七十三

无常想苦想无我想食厌想一切世间不可乐想不净想死想断想离想灭想。无常想者。谓无常法中定知无常。问曰。何故一切无常。答曰。是一切法皆从缘生。因缘坏故皆归无常。问曰不然。有法虽从缘生而非无常。如外经说。为三祠者得生常处。又梵世身常。答曰。汝法中亦说。释提桓因。能作百祠亦复退堕。又偈中说。多诸帝释等造过百千祠。皆悉无常尽。百千祠者犹不在。故知三祠非常。又释提桓因及天王等身分亦尽。是故从缘生法无有常者。又汝法中以韦陀为贵。韦陀中说由智慧。故得不死法。如说见日色大人过于世性。先随顺此人意。能得不死道。更无余道。小人神小大人神大。常在身中。若人不知此神相者。虽复读诵韦陀等经无所益也。又梵世身皆是无常。何以知之。汝法中说。梵王亦常祀祠持戒。为诸功德。若知身常何故为福。又闻汝经中说。诸梵王有恶淫欲。若有淫欲必有嗔等一切烦恼。若有烦恼必有罪业。如是罪人云何当能得常解脱。又非一切神仙皆为天祠。亦不一切行梵天道。若此是常则尽应为之。又一切万物皆悉无常。所以者何。若地水火风大劫尽时更无有余。又时转如轮。故知无常。又成就戒定慧等无量功德。诸大圣人定光佛等及辟支佛摩诃三摩等劫初诸王。皆悉无常。当有何物常耶。又佛自说。一切生法皆无常定相。如牛粪经中说。佛以少牛粪示诸比丘。无尔所色常定不变。是经中广说释梵转轮诸王果报亦尽。故知一切无常。又三界一切皆有寿量。阿鼻地狱极寿一劫。僧伽陀地狱寿命半劫。余则或多或少。龙等极多亦寿一劫。饿鬼极多寿七万岁。弗于逮寿二百五十岁。拘耶尼寿五百岁。郁单越定寿千岁。阎浮提寿或无量劫或十岁。四天王天寿五百岁乃至有顶寿八万劫。故知三界一切无常。又以三种信信知无常。现见中无有法常。圣人所说中亦无法常。比知中亦无有常。要先现见后比知故。又若有处常。何有智者灭一切法而求解脱。谁不欲与所爱常共同止受诸乐者。而实智者皆求解脱。故知生法无得常者。又复当说一切生法皆念念灭。尚无暂住况有常耶。问曰。修无常想能办何事。答曰。能破烦恼如经中说。善修无常想。能坏一切欲染色染及无色染掉慢无明。问曰不然。此无常想亦增贪欲。如人觉知盛年不久。则深着淫欲。知华不久鲜则速用为乐。知他妙色非已常有。则驶增淫欲。如是随知无常则生贪着。故无常想不坏贪欲。亦有人知无常故而为杀等。又乃至畜生皆知无常。而亦不能破诸烦恼。是故修无常想无所利益。答曰。以无常故生别离苦。失盛年安乐寿命富贵。智者以此则不生喜心。无喜心故不生贪心。因受故爱受灭则爱灭。故无常想能断贪欲。又若法无常即为无我。行者能观无常无我则不生我心。无我心故无我所心。我我所无故何所贪欲。又能修习无常想者。于自他身见念念死。云何生贪。又行者随所求事皆无常坏败。则为所诳。以虚诳故不生贪着。如小儿尚知空卷诳故不生贪着。又众生不喜不牢固事。如人不喜朽故器物。亦如女人闻某男子命不过七日。虽复盛年端正尊贵势力。谁当喜者。是人正以无常想故不生贪着。又智者常习别离想。故不乐和合。所以者何。智者忆念退堕等苦。乃至天欲尚不生贪。但求解脱。汝言无常增贪欲者。是事不然。若人未断我慢。见外物无常故生忧悲。失所爱惜故生贪求。是凡夫人除舍欲乐。更不知离苦。犹如婴儿为母所打还来趣母。智者知苦因犹在苦不可灭。即舍苦因。所谓五阴。又此行者坏裂内阴得无我心。虽失外物不生忧恼。得无我者。更何所求。无常想者亦无所求。又此无常想若未能生苦无我想。则不名具足能破烦恼。故经中说。应一心正观五阴无常。若不坏内阴见外物无常。以有我心故生忧悲。此则不名正观。又人虽见无常亦不生厌离。如屠猎等。是人虽知无常不名善习。又人虽能正观而不能常勤修习。则贪心间错。故说一心。又人少修无常而多烦恼则不能坏。如药少病多。此事亦尔。故说一心正观无常能破烦恼。又知法无常。是名真智慧。真智慧中无有贪等烦恼。所以者何。以无明因缘故有贪等。当知无常非增贪欲。又无常想能灭一切烦恼。行者若知此物无常。则无有贪。又知此人必自当死何为生嗔。何有智人嗔将死者。又若法无常。云何以此而生高心。又知诸法无常性故。则不生痴。以无痴故亦无疑等。故知无常相违诸烦恼

    苦想品第一百七十四

若法侵恼是名为苦。是苦三种。苦苦坏苦行苦。现在实苦。谓刀杖等。是名苦苦。若爱别离时所有苦生。谓妻子等。是名坏苦。若得空无我心。知有为法皆能侵恼。是名行苦。随此苦心名为苦想。问曰。若修苦想得何等利。答曰。是苦想有厌离果。所以者何。修苦想者无依贪喜。无此喜故则无有爱。又行者若能知法是苦则不受诸行。若法虽无常无我不能生苦。则终不舍。以苦故舍。以舍苦故于苦得脱。又一切众生最所怖畏。所谓是苦。若少壮老年贤愚贵贱知此苦相。皆生厌离。一切行人于泥洹中能生安隐寂灭心者。皆于生死生苦想故。何以知之。若众生为欲界系苦所恼。则于初禅生寂灭想。如是展转乃至有顶苦之所恼。则于泥洹生寂灭想。又生死中所有过咎。谓苦是也。如经中说。色中过者。谓色无常坏败苦相。又以无明故贪着此苦。何以知之。众生于真苦中生乐想故。深生苦想。则得厌离。是故佛言。我为能觉苦者说苦谛。此中佛因世谛示如是义。随一切天人世间生乐想处。我诸弟子于中生苦想。生苦想已则能厌离。又极愚痴处。谓于苦中而生乐想。以此想故。一切众生往来生死。心识恼乱。若得苦想则得解脱。又以四食能致后身。以此苦想能断诸食。如子肉食。如无皮牛食。如火聚食。如百槊刺食。如是说四食中皆是苦义。以此苦想能断诸食。又修苦想者意不乐住四识处中皆见苦故。如痴蛾投火以乐想故。智者知火能烧则能远离。凡夫亦尔。无明痴故投后身火。智者以苦想故能得解脱。又一切三界皆是苦苦因缘。于中苦受是苦能生苦受。是苦因缘。虽不即苦久必能生。是故当观世间一切皆苦。生厌离心。不受诸法。则得解脱

    无我想品第一百七十五

行者见一切法皆破坏相。若着色为我。是色败坏知是败坏相故。则离我心。受等亦尔。如人为山水所漂有所揽捉皆断脱失。行者亦尔。所计为我见此物坏则知无我。是故于无我中修无我想。问曰。修无我想得何等利。答曰。修无我想者能具苦想。凡夫以我想故。于实苦中不能见苦。以无我想故。于少苦中尚觉其恼。又于无我想故能行舍心。所以者何。以我想故畏我永失。若能实知但失于苦。无我可失则能行舍。又以无我想能得常乐。所以者何。一切无常。是中若生我我所心。则谓我当无。我所亦无。则常有苦。若作是念。无我我所。诸法坏时则不生苦。又行者以无我想故心得清净。所以者何。一切烦恼皆从我见生。以此事益我故生贪欲。此事损我故生嗔恚。以此是我即生憍慢。我命终后当作不作即生见疑。如是皆以我故起诸烦恼。以无我想故诸烦恼断。烦恼断故心得清净。心清净故能等金石栴檀刀斧称赞毁骂。心离憎爱安隐寂灭。故知无我想者心得清净。又除无我想更无余道能得解脱。所以者何。说有我者若知无我无我所有。能生如是决定心时。即得解脱。问曰不然。或以无我想更生贪心。如贪女色皆以非我亲故随以非我能集罪福。所以者何。自损益身则无罪福。答曰。有我心者能生贪欲。于自身中生男子相。于他身中生女人相。然后贪着。又贪着之起。皆由假名。彼相即是假名。故非无我而生贪心。又无我心者不集诸业。如阿罗汉断我想故诸业不集。此无我想能断一切烦恼及业。故应修习

成实论卷第十三成实论卷第十四

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    食厌想品第一百七十六

一切苦生皆由贪食。亦以食故助发淫欲。于欲界中所有诸苦皆因饮食淫欲故生。断食贪故应修厌想。又如劫初众生。从天上来化生此间。身有光明飞行自在。始食地味。食之多者即失威光。如是渐渐有老病死。至今百岁多诸苦恼。皆由贪着食故失此等利。是故应正观食。又贪着饮食故生淫欲。从淫欲故生余烦恼。从余烦恼造不善业。从不善业增三恶趣。损天人众。是故一切衰恼皆由贪食。又老病死相皆由饮食。又食是深贪着处。淫欲虽重不能恼人。如为食者。若少壮老年在家出家。无不为食之所恼也。又应食此食而心不着。未离欲者是最为难。如受刀法如服毒药如养毒蛇。是故佛说。当修习心。以此而食不为贪食苦之所恼。有诸外道行断食法。是故佛言。此食不以断故得离。当思而食。若但断食烦恼不尽则唐死无益。是故佛说。于此食中应生厌离想。则无上过。问曰。云何于食应生厌想。答曰。此食体性不净极上味食果皆不净。是故应厌。又如净洁香美饮食不即净时能利益身。以齿咀嚼涎唾浸渍状如呕吐。堕生藏中能利益身。故知不净。又此饮食不知故乐。若人虽得美食还吐出已更不能食。当知以不知力故以之为美。又以饮食因缘受田作役使积聚守护如是等苦。由此因缘起无量罪。又所有不净皆因饮食。若无饮食何由而有皮骨血肉及粪秽等诸不净物。又所有恶道诸厕虫等。皆以贪着香味故生其中。如业品中说。渴死众生生为水虫。愦闹处死则生鸟中。贪淫欲死生胞胎中。如是等。又若离此食得大乐。如生色界及泥洹中。又随以食故有稼穑等苦。如是观食不净苦。故应修厌想

    一切世间不可乐想品第一百七十七

行者见诸世间一切皆苦心无所乐。又此行者修离喜定。如无常想苦想无我想食厌想死想等。则心不乐一切世间。又此人见所爱者则增贪欲。见所恶者则增嗔恚。故俱不乐。又见富贵人有守护等苦。见贫穷人有短乏苦。又见好处者将堕恶处。见恶处者现受诸苦。又现在富贵知必将堕。亦是贪等烦恼住处。现在贫穷知无因缘可以得出。故不贪乐一切世间。又少有众生得生好处。多坠恶道。如经中说。少生好处多生恶处。见此过已但求泥洹。又此人见贪等过。烦恼常随众生如怨伺人得便便杀。此怨贼中云何可乐。又见从烦恼生不善业。常追随逐不善业果终不可脱。如经中说。若汝作恶业。今作已作当作。乃至飞空中。终不能得解脱。是故不乐。又生等八苦尚随福人。况无福者。如是云何当乐世间。又如毒蛇箧五拔刀贼空聚落贼。此岸诸苦常随众生。云何可乐。又如碱辛爱河所漂。五欲毒刺无明黑闇火坑中苦。常随众生。云何当乐。又行者知安隐乐少衰恼苦多。所以者何。见诸世间吉日嘉会华林敷荣果实繁茂国土安乐无得久者。欢乐者少受苦者多。是故不乐一切世间。问曰。修习此想得何等利。答曰。能于世间种种相中。心不贪着。又修此想故速得解脱。于生死中不复久住。又此行者得利智慧。常习一切过患相故。又此人心不生烦恼。若生速灭。如一渧水堕热铁上。行者以不乐世间故能深乐寂灭。若不厌世间。则于寂灭不能深乐。是故应习一切世间不可乐想

    不净想品第一百七十八

问曰。云何修不净想。答曰。行者见身种子不净。谓从父母不净道生赤白和合。又此身为不净所成。谓烂坏饮食汁流润渍。又生处不净。谓母胎中不净充满。又粪秽等诸不净物合而为身。于九孔中常流不净。又身所置处。是处即为不吉不净。又饮食衣服来着人身。皆为不净。为他所恶。又为此身物皆是不净。如澡浴水若澡槃等。又从身所出爪发垢腻及涕唾等。皆是不净。又见死尸以为不净。此身死时更有何异。当知本来常是不净。生时但以我心覆故。谓之为净。又触死人者名为不净。而发爪等常是死物。无量死虫亦常触身。故知此身本来不净。又不净虱及蝇蚋等。诸不净虫常来触身。故知不净。又此身如厕不净常满。因是厕中生千种虫。此身亦尔。又此身如冢。所以者何。以死尸处故名为冢。此身亦多死虫在其中住。又此身能造不净。若净处好华衣服璎珞等由此身故皆为不净。又诸婆罗门于死家产家不从受食。以不净故。而此身中千万种虫常生常死。则无可从受饮食者。故知不净。又世间中狱为不净。此身即是千种虫狱。故名不净。又此身常须澡浴。若是净者何须澡浴耶。又以妙好华香璎珞庄严此身。当知此身体性不净。假外净物以为庄严。又此人身最为不净。以余众生皮毛爪齿筋骨肌肉。或有任用于人身中。无一可取。以最不净故。又如忧钵罗钵头摩诸莲花等从不净中生。故名不净。是身不尔。不以余物故令不净。性是不净。又此身若净。则不应以衣裳覆蔽。如人以衣覆屎尿聚欺诳他人。女人如是以服饰覆身诳惑男子。男子亦尔。当知不净。又周遍此身常出不净。谓九孔不净门。及诸毛孔无一净者。故知不净。问曰。修不净想为得何利。答曰。以取男女净想。故起贪欲。从此贪欲开诸罪门。修不净想则能制伏贪欲。所以者何。此身皆是臭秽不净。但薄皮覆故不可知。似如以衣覆不净聚。好净洁者则应远离。又此行者以青瘀等想坏一切身。以坏身故不生贪欲。又亦现见青瘀等色。问曰。若实未青何故见青。答曰。行者以信解力取此青相。见一切色皆为青瘀。问曰。此观云何非是颠倒。答曰。此身有青瘀分。如经中说。木中有净性。又常修习青瘀相。故能胜余色。如青珠光能映白色。如是久习青瘀等相。则不净具足。不净具足则不起淫欲。不起淫欲则诸罪门闭随顺泥洹。修不净想获如是利

    死想品第一百七十九

行者以死想于寿命中心不决定。故应修习。又此人常深乐善法。除断不善。所以者何。众生多以忘死故起不善业。若忆念死则能除断。又常念死故。于父母兄弟姊妹亲里知识等中贪爱则薄。又修习死想则为自利。谓能一心集诸善法。世间众生多乐他利自舍己利。又此人能速得解脱。所以者何。随往来世间常有此死。是人厌死故求解脱。问曰。应云何修死想。答曰。先总说一切无常。今但观身无常。阴相续断名曰死。想此身无常甚于外物。犹如坏瓶无坚牢相。行者观身又过于此。所以者何。此坏瓶。若加防护或可久住。此身极久不过百岁。以无牢故。当念死想。又此身多违害法。谓刀杖锋刃怨贼坑岸。饮食不消。冷热风病。取要观之。一切众生非众生物。皆是违害身法。是故应修死想。又行者见身。于念念中常是坏相。无一念可保。故修死想。又行者现见少壮老年有病无病。无有能却死者。自念己身亦当如是。故修死想。又行者见有不定报业。非一切业尽受百岁。业不定故死亦不定。故应念死。又无始生死中有无量业有业能妨余业。我亦应有非时死业。云何当信此命耶。又行者见死有大力势不可以软言诱诳财物追逐斗讼得脱。如大石山从四方来无逃避处。问曰。若人能令阎王欢喜则得脱死。答曰。是愚痴语。阎王无自在力能为生杀。但能考检行善恶事。若受报尽反得害身因缘故死。是故行者见身无依无救住死道中。故念死想。又行者常见此身为老病所恼无牢固性。以念念生灭相续识系故修死想。又此行者见死是定命。则不定定胜不定故修死想。问曰。何故不说老病等想。而但说死想。答曰。老病夺人不能令尽。病夺强健老夺少壮。亲里财物余身犹在。死则夺尽。又老病等是死因缘。故不别说。又经中说。死名大黑闇。无有光明无救护者。亦无伴党无所恃怙。是最怖处故应念死。又众生以死因缘怖畏后世。又三界中一切有死。老病不尔。问曰。若不离众生有死相者。众生即是假名。行者何故修习此想。答曰。不坏众生相者。怖畏于死。若修死想则不生怖畏。故应修习。又无常想等名为近道。不净食厌及死想等是名远道。未得道者。以此等想故能制伏心

    后三想品第一百八十

断想者。如四正勤中说。已生恶不善法为断故勤精进。此诸恶不善法。是地狱等苦恼因缘。亦是诸恶名闻及心悔等众苦之本。是故应断。问曰。当云何断。答曰。得不作法尔时则断。又邪忆念是贪欲等诸烦恼因。断此念故是法则断。问曰。修此断想得何等利。答曰。修此想者。常不随恶法为所应作。又此离八难。人身利者。谓断烦恼。又乐断烦恼。是法服毁形。出家人利。若不尔者。唐自辱身。又若行者乐修断相。则为以法供养于佛离欲想灭想者。若欲尽不生是名离欲。念此离欲故名离想。问曰。若说断想即是离想。何故更说。答曰。从断得离。断谓除灭贪欲。如经中说断贪欲故五阴则断。又断想是离欲想。所以者何。若于此法无贪名断此法是故若得离欲则苦恼灭。如经中说离欲者得解脱。得解脱即名为断。若入无余是名为灭。又经中说。有三性断性离欲性灭性。若说断性离欲性即是阿罗汉。断一切烦恼离三界欲。住有余泥洹。若说灭性即是命终舍寿。断阴相续入无余泥洹。又有二种解脱慧解脱心解脱。若说断即是离无明。故慧得解脱。若说离欲即是离爱心得解脱。二解脱果是名为灭。又若说断想即说断无明漏。若说离欲想即说断欲漏有漏。若说灭想是此二果。又如经说断一切诸行故名断。离一切诸行故名离。灭一切诸行故名灭。然则此三义一而名异。若修无常想乃至灭想。则一切事讫。灭诸烦恼断阴结相续入无余泥洹

    定具中初五定具品第一百八十一

问曰。汝先说道谛。所谓定具及定以说定。定具今应当说。所以者何。若有定具则定可成。无则不成。答曰。定具者。谓十一法。一清净持戒。二得善知识。三守护根门。四饮食知量。五初夜后夜损于睡眠。六具足善觉。七具善信解。八具行者分。九具解脱处。十无障碍。十一不着净持戒者。离不善业名为持戒不善业者。所谓杀盗邪淫是身三业。妄语两舌恶口绮语是口四业。远离此罪是名持戒。又礼敬迎送及供养等修行善法。亦名为戒。以戒能为定因。是故受持。所以者何。犹如治金先除粗垢。如是先以持戒除破戒粗过。后以定等除余细过。所以者何。若无持戒则无禅定。以持戒因缘禅定易得。如经中说。戒为道根亦为妙梯。又说戒为初车。若不上初车云何得上第二车等。又说戒为平地。立此平地能观四谛。又说二力。思力修力。思力即是持戒。修力是道。先思惟筹量破戒罪过持戒利益。故能持戒后得道已自然离恶。又说戒为菩提树根。无根则无树故须净戒。又法应尔。若无持戒则无禅定。犹如治病药法。所须如是治烦恼病。若无持戒则法药不具。又说净持戒者则心不悔。乃至离欲心得解脱。是诸功德皆由持戒。故名定具。又有业障烦恼障。是二障果名为报障。若净持戒则无此三障。若心无障则能成定。又净持戒者不败坏故必至泥洹。如恒水中材。又净持戒故能安立。持戒能遮不善身口业。禅定能遮不善意业。如是遮诸烦恼。得真实智则毕竟断。又道品楼观以戒为柱。禅定心城以戒为郭。度生死河以戒为桥梁。入善人众以戒为印。八直圣田戒为疆畔。如田无畔水则不住。如是若无净戒则定水不住。问曰。云何名净持戒。答曰。若行者深心不乐为恶。非畏后世及恶名等。名净持戒。又行者以心净故持戒清净。如七淫欲经中说。身虽不犯心不净故戒亦不净。又破戒因缘是诸烦恼。若能制伏为净持戒。又声闻持戒但为泥洹。求佛道者以大悲心为一切众生不取戒相。能令此戒如菩提性。如是持戒名曰清净。善知识者经中说。以二因缘能生正见。一从他闻法。二自正忆念。所从闻法名善知识。问曰。若尔何故但说善知识耶。答曰。经中说。阿难问佛。我宴坐一处作如是念。遇善知识则为得道半因缘也。佛言莫作是语。善知识者。则为得道具足因缘。所以者何。生老病死众生得我为善知识。则于生老病死皆得解脱。又众生因善知识。则能增长戒等五法。如裟罗树。因雪山故五事增长。又佛尚自乐善知识。如初得道时。作如是念。若人无师则无所怖畏。无恭敬心常为恶法所覆。无安隐行。我当以谁为师依谁而住。作是念已遍观一切无胜己者。即生念言。我所得法因此成佛。当还依此法。梵等诸天亦赞言。尔无胜佛者。一切诸佛皆以法为师。又善知识犹如明灯。有目无灯则不能见。如是行者虽有福德利根因缘。无善知识则无所益。问曰。何者是善知识。答曰。随能令人增长善法名善知识。又一切善人住正法者。皆是天人世间善知识也。守护根门者。谓正忆念。行者不可闭目不视。但应一心正念现前。又名正慧。以此正慧能坏前缘。坏前缘故能不取相。不受相故不随假名。若不守诸根以取相故。诸烦恼生。流于五根即破戒等善法。若能守根门则戒等坚固。饮食知量者。不为色力淫欲贪味故食。为济身故。问曰。行者何故为济身耶。答曰。为修善法故。若离善法则无道。无道则无离苦。若人不为修善故食。则唐养怨贼亦坏施主福。损人供养。如是不应食人之食。问曰。饮食以何为量。答曰。随能济身是名为量。问曰。应食何食。答曰。若食不增冷热等身病贪恚等心病。是则应食。是食亦应随时。若知此食于此时能增冷热贪恚等病。则不应食。问曰。诸外道言。若食净食则能得净福。谓随意所嗜色香味触。水洒咒愿然后乃食。是名为净。此事云何。答曰。饮食无有决定净者。所以者何。若以残食为不净者。一切饮食无非残者。如乳为犊残。蜜为蜂残。水为虫残花为蜂残。果为鸟残如是等。又此身从不净生。体性不净不净充满。饮食先是不净。后入身中无一净者。但以倒惑妄谓为净。问曰。若都无净则与旃陀罗等有何差别。答曰。又以不杀不盗不邪命等。如法得食以观食过。智慧水洒然后乃食。非但水洒便名为净。初夜后夜损睡眠者。行者知事由勤成故不睡眠。又见睡眠空无所得。若汝以睡眠为乐。此乐少弊不足言也。又行者不乐烦恼同处。如人不乐与怨贼住世。岂有人于贼阵中而当睡寐。故不睡眠。问曰。睡眠强来云何除遣。答曰。是人得佛法味。深心欢喜故能除遣。又念生死中老病死过。心则怖畏故不睡眠。又行者见得人身诸根具足得值佛法能别好丑是为甚难。今不求度何时当得解脱。故勤精进以除睡眠

    恶觉品第一百八十二

具足善觉者。若人虽不睡眠而起不善觉。所谓欲觉嗔觉恼觉。若亲里觉国土觉不死觉利他觉轻他觉等。宁当睡眠勿起此等诸不善觉。应当正念出等善觉。所谓出觉不嗔恼觉。八大人觉。欲觉者谓依欲生觉。于五欲中见有利乐。是名欲觉。为衰恼众生是名嗔觉恼觉。行者不应念此三觉。所以者何。念此三觉则得重罪。又先已说贪等过患。以此过患故不应念。问曰。何故不说痴等觉耶。答曰。是三恶觉次第而生。余烦恼不如是。行者或念五欲故生贪觉。不得所贪故生嗔恚。嗔成名恼。是故不说痴等。又痴所成果所谓贪恚。若从贪恚生不善业。此三觉名不善业因。如经中说。如有土封夜则烟出昼则火然。烟则是觉火名为业。亲里觉者。由亲里故起诸忆念。欲令亲里得安隐乐。若念衰恼则生愁忧。若念与亲里种种同事。名亲里觉。行者不应忆念此觉。所以者何。本出家时。已舍亲里。今依此觉则非所宜。又若出家人还念亲里。则唐舍家属空无所成。以爱亲里故生贪着。贪着故守护。守护因缘鞭杖等业次第而起。是故不应生亲里觉。又与亲里和合则不能增长善法。又行者当念一切众生生死流转无非亲里何故偏着。又生死中为亲里故忧悲啼哭泪成大海。今复贪着则苦无穷已。又众生以利益因缘便相亲爱。无有决定。又念亲里者是愚痴相。世间愚人未有自利。而欲利他。若念亲里则少自利。以此等故行者不应起亲里觉。国土觉者。行者生念。某处国土丰乐安隐。当往到彼可得安乐。又心轻躁欲遍游观。行者不应起如是觉。所以者何。一切国土皆有过恶。有国大寒有国大热。有国多险有国多病。有国多盗贼。有如是等种种诸过故不应念。又轻躁者则失禅定。随所乐处能增善法则名为好。何用遍观诸国土耶。一切国土但可远闻。到不必称。以世间人多过言故。有游诸国者受种种苦。又身是苦因。持此苦因随所至处则受诸苦。又受苦乐皆由业因。虽复远去亦无所益。是故不应起国土觉。不死觉者。行者作如是念。我徐当修道。先当读诵修多罗比尼阿毗昙杂藏菩萨藏。广综外典多畜弟子。牵引善人供养四塔。劝化众生令大布施。后当修道名不死觉。行者不应起如是念。所以者何。死时不定不可豫知。若营余事中则命尽不得修道。后将死时心悔忧恼。我唐养此身空无所得。与畜生同死。如经中说。凡夫应二十种自折伏心。谓如是念。我但形服异俗空无所得。乃至当以不调至死。又智者不作所不应作。如法句中说。不应作不作。应作则常作。忆念安慧心诸漏则得尽。又经中说。未得四谛者方便为欲得。当勤加精进甚于救头然。是故不应起不死觉。又不死觉是愚痴气。何有智者知命无常如条上露而能保一念。又经中说。佛问诸比丘。汝等云何修习死想。有答佛言。我不保七岁。或言六岁。如是转减乃至须臾。佛言。汝等皆是放逸修死想也。有一比丘偏袒白佛言。我于出息不保还入。入息不保还出。佛言。善哉善哉。汝真修死想。是故不应起不死觉。利他觉者。于非亲里中欲令得利。若作是念。令某富贵安乐能行布施。某则不及。行者不应起如是觉。所以者何。不以念故便能令他得苦乐也。但自以此坏乱定心。问曰。欲令他利非慈心耶。答曰。行者求道应念第一义。利谓无常等。是中虽少有福。以能妨道利少过多。乱定心故。若以散心念利他人。则不能见贪着过患。故不应念。轻他觉者。行者若念此人种姓形色富贵伎能。及持戒利根禅定智慧等皆不如我。行者不应起如是觉。所以者何。一切万物皆无常故。若上中下有何差别。又此人身发毛爪齿皆名不净。等无有异。又老病死等衰恼亦同。又一切众生内外苦恼皆等无异。又凡夫富贵是罪因缘。又富贵不久还为贫贱。是故不应起轻他觉。又此憍慢是无明分。智者云何当起此觉

    善觉品第一百八十三

出觉者。心乐远离。若离五欲。及色无色界。乐此远离故名出觉。此远离乐。无诸苦故。随贪著有苦。无贪着则乐。于诸觉中二觉名乐。谓无嗔觉。无恼觉。所以者何。此二觉名安隐觉。如如来品中说。如来常有二觉现前。谓安隐觉。及远离觉。安隐觉者。即是不嗔恼觉。远离觉者。即是出觉。又念此三觉则福增长。亦能成心定。又心得清净。又念此三觉能障诸缠。诸缠断故速能证断。又行者以乐远离多集善法。故能速得解脱。八大人觉者。佛法中若少欲者能得利益。非多欲者。知足者远离者精进者正忆者定心者智慧者无戏论者能得利益。非戏论者是名为八。少欲行者为修道故必欲所须。但不多求余无用物。是名少欲。知足者。有人若以因缘若为持戒若令他人心得清净。是故少取而心不以为足。若人少取心以为足。是名知足。有人虽取少物而求好者。是名少欲非知足也。若趣得少物是名知足。问曰。若取所须名少欲者。一切众生皆名少欲。以其各有所须故。答曰。行者以不着心取但为用故。故不多取。不如世人为严饰名闻长取多物。问曰。行者何故少欲知足。答曰。于守护等中见有过患。又畜无用物是愚痴相。又出家人不应积聚与白衣同。以此过故少欲知足。又行者若不少欲知足。则贪心渐增。为财利故求不应求。为贪乐财利终无安隐。以深着故。又是人出家为远离乐。以贪利故忘其所为。又亦不能舍诸烦恼。所以者何。外物尚不能舍。况内法耶。又见利养是衰恼因如雹害禾。是故常习少欲知足。又见施物难偿。如负债不偿。后受苦恼。又见利养是诸佛等善人所弃。如佛说。我不近利养。利养勿近我。又此行者善法充足。故舍利养。如佛说。诸天尚不能得出乐离乐寂灭乐真智乐如我所得。故舍利养。又如舍利弗说。我善修无相。持空三昧观一切外万物。视之如涕唾。又行者不见受欲有厌足者。如饮碱水不能除渴。是故勤求智慧为足。又见多欲者。常发愿求多得少。故常有苦。又见乞求者人所轻贱。不加敬仰如少欲者。又出家多求非其所应。人与不取则是所宜。是故应行少欲知足。远离者。若于在家出家人中行身远离。于诸烦恼行心远离。是名远离。问曰。行者何故远离。答曰。诸出家人。虽未得道以远离为乐。诸白衣等处在女色愦闹之中。终无安乐。又若远离则心易寂灭。如水不扰自然澄清。故行远离。又此远离法为恒沙等诸佛所赞。何以知之。佛见比丘近聚落宴坐。心则不悦。又见比丘空处睡卧佛则心喜。所以者何。近聚宴坐多诸因缘散乱定心。令应得不得应证不证。空处睡卧虽小懈怠。若起求定则散心能摄。摄心能得解脱。又因取相故起贪等烦恼。空处无色等相烦恼易断。如火无薪则自然灭。又经中说。若比丘乐于众住乐杂言说。不离众故尚不能得爱缘解脱。何况能得不坏解脱。远离行者。必能俱证。又如灯离风则能明照。行者如是。远离行故能逮真智。精进者行者若行正勤。断不善法修集善法。是中勤行故名精进。如是则能得佛法利。所以者何。以集善法日日增长。如忧钵罗钵头摩等随水增长。懈怠行者。犹如木杵从初成来日日减尽。又精进者。以得利故心常欢乐。懈怠行者。恶法覆心恒怀苦恼。又精进者。于念念中善法常增长无有减损。又深行精进得最胜处。谓诸佛道。如经中佛语阿难。深修精进能至佛道。又精进者定心易得。又钝根精进尚于生死速得解脱。利根懈怠则不能得。又所有今世后世世间出世间利。皆因精进。一切世间所有衰恼皆因懈怠。如是见懈怠过精进利益。故念精进。正忆者常于身受心法修正安慧。问曰。念此四法得何等利。答曰。恶不善法不来入心。如善守备则恶人不入。又如瓶满更不受水。此人如是善法充满不容诸恶。又若修此正忆。则摄解脱分一切善法。如饮海水则饮众流。以一切水在大海故。又修此正忆名住自在行处。烦恼魔民所不能坏。如鹰鵽喻。又此人心安住难动。如圆瓶入制。又此人不久当得利益。如比丘尼经中说。诸比丘尼问阿难言。大德。我等善修念处觉异于本。阿难言。善此法应尔定心者若习定心得微妙利。如经中说。修定心者能如实知。又以此人身得过人法。谓身出水火飞行自在等。又此人得乐。乃至诸天及梵王等所不能及。又此人名为所应为不应为者则不为也。又善修习定。则善法常增。又修习定者后心不悔。是人名为得出家果。亦名顺佛教者。不如余人空受供养。是人能报施福。余人不能。又此定心法诸佛贤圣皆所亲近。又能堪受一切善法。又若定能成则得圣道。若不能成则生净天。谓色无色界。所以者何。以布施等不能得如是事。谓能究竟不造诸恶。如经中说。若小儿从生习慈能起恶心思恶事不。不也世尊。此皆是定力。又定心名真智慧因。真智慧能尽诸行。诸行尽故诸苦恼灭。又行者于一切世间出世间事。应念即办不劳加功。余人尚不能发心量其所得。故说定心能获利益。智慧者智者心中不生烦恼。若生即灭。如一渧水堕热铁上。又智者心不起诸想。若起即灭。如条上露见日则晞。又若有智眼能观佛法。如有目者日能为用。又智者名得佛法分。如所生子得父财分。又智慧者名曰有命。余则名死。又智慧者名真道人。能知道故。又智者知佛法味。如舌根不坏能别五味。又智慧者。于佛法中心定不动。犹若石山风不能动。又智慧者名信。以得四信不随他故。又得圣慧根名佛弟子。余人名外凡夫。故说智者能得利益。无戏论者。若一异论名为戏论。如阿难问舍利弗。若六触入离欲灭尽更有余耶。舍利弗言。六触入离欲尽灭已若有余是不可论。而汝论耶。若无亦有亦无非有非无。问答亦尔。问曰。是事何故不可论耶。答曰。此问实我法若一若异。是故不答。我无决定。但五阴中假名字说。若以有无等答。即堕断常。若以因缘说我。即非戏论。又若人见众生空法空则无戏论。故说无戏论者得佛法利。是名具足善觉

    后五定具品第一百八十四

具善信解者。行者若能好乐泥洹。憎恶生死名善信解。如是信解速得解脱。又乐泥洹者心无所著。有乐泥洹则无怖畏。所以者何。若凡夫心念泥洹。即生惊怖。我当永失。问曰。何因缘故信解泥洹。答曰。行者见世间无常苦空无我。则于泥洹生寂灭想。又此人本性烦恼轻微。闻说泥洹则心信乐。又若从善师若读经书。闻生死过患。如无始经及五天使等诸经中说。则厌离生死信乐泥洹。具行者分者。如经中说。五行者分。一谓有信。二谓心不谄曲。三谓少病。四曰精进。五名智慧。有信名于三宝四谛心无疑悔。无疑悔故能速成定。又有信者心多喜。故能速成定。又信者心调易摄。故疾得定。问曰。若由定生慧。后能断疑。今云何先定已说无疑。答曰。以多闻故能断所疑。非得定故。又生深信家。与信者同事常修信心。虽未得定而能不疑如是等。不谄曲者。以质直心无所隐藏。是则易度。如人向医具说病状则易救疗。少病者。能初夜后夜精进不息。若多疾病则妨行道。精进者。为求道故常勤精进。如攒燧不息则疾得火。智慧者。以有智故四事得果。所谓圣道。问曰。念处等法亦名行者分。何故但说此五法耶。答曰。虽俱是分此法最胜。是行者所须。是以独说。亦离一切恶集一切善。名行者分。如瞿尼沙经中说。具解脱处者。谓五解脱处。一者若佛及尊胜比丘。为之说法。随其所闻则能通达语言义趣。以通达故心生欢喜。欢喜则身猗。身猗则受乐。受乐则心摄。是初解脱处。行者住此解脱处。故忆念坚强心则摄定。诸漏尽皆灭必得泥洹。二者善讽诵经。三者为他说法。四者独处思量诸法。五者善取定相。谓九相等。皆如上说。问曰。佛及尊胜比丘。何故为此行者说法。答曰。以堪受法能获大利。是故为说。又此比丘因佛出家。诸根纯熟故为说法。尊胜比丘以同所业故为说法。又此行者必须闻法。是故为说。又此人有净戒等功德成熟。犹如完器堪任受盛。故为说法。此名三慧。通达语言是多闻慧。通达义趣是思惟慧。从此二慧能生心喜。乃至摄心生如实智。是名修慧。此三慧有三种果。谓厌离解脱。又闻法读诵为人说法。是多闻慧。思量诸法名思惟慧。善取定相是名修慧。问曰。心解脱漏尽是二有何差别。答曰。以定遮烦恼故说心解脱。永断烦恼故说漏尽。问曰。若持戒等法亦是解脱处。如说持戒则心不悔。心不悔则欢喜等。或因施等亦得解脱。何故但说此五法耶。答曰。以胜故独说。又问。此法有何胜耶。答曰。是解脱近因。戒等以远故不说。又问。云何知是近因。答曰。行者闻法。知阴界入等但众法和合中无我。故则破假名。破假名即是解脱。故名近因。又经中说。多闻功德谓不随他教。心易摄等。亦以此故知是近因。又佛法有大功德。能灭烦恼至泥洹等。于此寂灭法中。若听若诵若自思量则速解脱。故名近因。又施得大富。持戒尊贵多闻得智。以智慧故得尽诸漏。不以富贵故知近因。又舍利弗等称大智者。皆由多闻。问曰。若以多闻心易摄者。阿难何故初中后夜不得解脱。答曰。阿难头未到枕。即得解脱。是故数在希有法中何故不速。又阿难于此夜中精进小过。以疲极故不得解脱。又阿难自誓。我于今夜必得漏尽。亦如菩萨于道场自誓。谁有此力。如阿难者皆是多闻之力。无障碍者。所谓三障。业障报障烦恼障。若人无此三障则不堕难处。若离诸难则堪受道。又此人名具足四轮。谓好国土依止善人自发正愿。先世福德。又能成就四须陀洹分。谓亲近善人喜听正法。自正忆念能随法行。又能弃舍贪等三法。如经中说。不断三法则不能度老病死。不著者不着此岸。不着彼岸不没中流。不出陆地不为人取及非人取。不入洄澓不自腐烂。此岸谓内六入。彼岸谓外六入。中流谓贪喜。陆地谓我慢。人取谓与在家出家和合。非人取谓持戒为生天上。洄澓谓返戒。腐烂谓破重禁。若人于内入计我。即于外入生我所心。从内外入生贪喜。故即于中没。从此则生我慢。所以者何。若人着身受有乐故。人来轻毁则生憍慢。如是以我我所贪喜我慢乱其心。故能成余事。问曰。此喻中以何为水。若以八直圣道为水。则不应以内外六入为岸。贪喜等为中流。亦不应有洄澓腐烂。若以贪爱为水。云何随此得至泥洹。答曰。以八直圣道为水。譬喻不必令尽相似。如此木若离八难必至大海。比丘如是离诸流难则随八圣道水流入泥洹。如言乳如贝。但取其色不取坚软。言面如月但取盛满不取形也。又行者出圣道已着内外入。不如此木即于水中着此彼岸腐烂等也。有论师言。如恒河水必至大海。如是八圣道必至泥洹。故以为喻。如是略说十一定具。若有此法自然得定

    出入息品第一百八十五

阿那波那十六行。谓念出入息若长若短。念息遍身除诸身行。觉喜觉乐觉心行。除心行念出入息。觉心令心喜令心摄。令心解脱。念出入息随无常。观随断离灭观。念出入息若长若短。问曰。云何名息长短。答曰。如人上山。若担重疲乏故息短。行者亦尔。在粗心中尔时则短。粗心者所谓躁疾散乱心也。息长者。行者在细心中则息长。所以者何。随心细故息亦随细。如即此人疲极止故息则随细。尔时则长息。遍身者行者信解身虚。则见一切毛孔风行出入。除身行者。行者得境界力心安隐故。粗息则灭。尔时行者具身忆处。觉喜者是人从此定法心生大喜。本虽有喜不能如是。尔时名为觉喜。觉乐者从喜生乐。所以者何。若心得喜身则调适。身调适则得猗乐。如经中说。心喜故身猗。身猗则受乐。觉心行者。见喜过患以能生贪故。贪是心行从心起故。以受中生贪故。见受是心行。除心行者。行者见从受生贪过。除灭故心则安隐。亦灭除粗受。故说除心行。觉心者行者除受味故。见心寂灭不没不掉。是心或时还没。尔时令喜。若心还掉尔时令摄。若离二法尔时应舍。故说令心解脱。行者如是心寂定故生无常行。以无常行断诸烦恼。是名断行。烦恼断故心则厌离。是名离行。以心离故得一切灭。是名灭行。如是次第得解脱。故名十六行念出入息。问曰。何故念出入息名为圣行天行梵行学行无学行耶。答曰。风行虚中虚相能速开导坏相。坏相即是空。空即是圣行。故名圣行。为生净天故名天行。为到寂灭故名梵行。为得学法故名学行。为无学故名无学行。问曰。若观不净深厌离身。速得解脱。何用修此十六行耶。答曰。不净观未得离欲自恶厌。身心则迷闷。如服药过则还为病。如是不净喜生恶厌。如跋求沫河边诸比丘不净观故深生恶厌。饮毒坠高等种种自杀。此行不尔。能得离欲而不生恶厌。故名为胜。又此行易得。自缘身故不净易失。又此行细微。以能自坏身故。不净行粗坏骨相难。又此行能破一切烦恼。不净但破淫欲。所以者何。一切烦恼皆因觉生。念出入息为断诸觉故。问曰。出入息为属身。为属心耶。答曰。亦属身亦属心。所以者何。处胎中无。故知由身。若第四禅等及无心者。无故知由心。问曰。息不故起不应由心。所以者何。是息不由意起。如心念余事息常出入。如食自消如影自转。非人为也。答曰。息不故起不由忆念。但以众缘和合故起。若有心则有。无心便无。故知由心。有随心差别。粗心则短细心则长。又出入息由地由心。若在出入息地。亦有出入息地心。尔时则有出入息地。所谓欲界及三禅。若在出入息地而无出入息地心。及在无心尔时则无。若在无出入息地。尔时亦无。问曰。息起时先出耶先入耶。答曰。生时先出死时后入。出入第四禅亦如是。问曰。是念出入息云何名具足。答曰。行者若得此十六行。尔时名具足。有论师言。以六因缘故名具足。所谓数随止观转缘清净。数名数出入息从一至十。数有三种。若等若过若减。等谓十数为十。过谓十一数名为十。减名数九为十。随名行者心随息出入。观名行者见息系身如珠中缕。止名令心住出入息。转谓转身缘心令受缘心。现前心法亦尔。清净名行者离一切烦恼诸难心得清净。此不必定。所以者何。是诸行中不必要用数随二法。行者但令心住息中断诸觉。故若能行十六种名为具足。又此具足相不决定。钝根所行。于利根者则非具足。问曰。是出入息经中何故说名为食。答曰。若息出入停等。身得快乐。如得美食。益身调适。故名为食。问曰。此十六行中尽念出入息耶。答曰。是人名坏裂五阴方便。若坏裂五阴除假名已。更复何用念出入息。是名身忆。四种忆身故名身忆。问曰。忆缘过去息是现在。何故名忆。答曰。是破假名智以忆名说。诸心数法更相为名。如十想等。亦忆先后所行故名为忆。问曰。长短等中不说圣行。云何无行名忆处耶。经中说。若行者学出入息。若长若短若遍身。若除身行。尔时名身忆处。答曰。是名初方便道。为心清净故后名断道。又此中有无常等行。但此经不说。余经中说。行者于出入息中观身生相灭相及生灭相。又说观身无常等。但第四中无常等行具足故说

    定难品第一百八十六

是定若离障碍诸难。能成大利。定难者。所谓粗喜。如经中说。我生粗喜心难法。行者不应生此粗喜。以有贪着等过乱定心故。问曰。从法生喜云何能令不生。答曰。行者念空则不生喜。以有众生想故生喜。五阴空无众生。云何当喜。又行者应作是念。以因缘故种种法生。谓光明等。是中何所喜耶。又行者见所喜法寻皆败坏。粗喜则灭。又行者更求大事。不以光明等法。为是故不生喜。又行者见灭相利故。不以光明等相为喜。又此行者修习寂灭欲尽烦恼。故不生喜以此等缘能灭粗喜。又有怖畏定难。行者见可怖缘故生怖畏。世间所有可怖畏处行者悉见。于此事中皆应谛观无常败坏不应随也。所以者何。坐禅法中有此因缘见可畏事。不可以此而生怖畏。是事虚妄皆空。如幻能诳凡人非真实也。如是思惟则离怖畏。又依空法则无怖畏。又作是念。我行力故感此异相不应怖畏。又自念。身有戒闻等功德具足。无可加害因缘故不怖畏。又此行者乐道深故。不惜身命何所怖畏。又此人心常处正念。是故怖畏不能得便。又念勇悍相故不怖畏。怖畏是怯弱相。以如是等灭除怖畏。又有不适定难。谓行者有冷热等病。若疲极失睡。谓因缘故令身不适。有贪忧嫉垢等诸烦恼。令心不适则失禅定。是故行者应自将护身心令其调适。又有异相定难。所谓垢相亦有非垢相能乱禅定。如布施等相。又有不等定难。所谓精进若迟若疾。疾则身心疲极。迟则不取定相。俱退失定。如捉鸟子急则疲极缓则飞去。又如调弦若急若缓俱不成音。又精进若速则难究竟。如佛语阿那律。汝精进过。后当懈怠。所以者何。若精进过则事不成。还堕懈怠。精进若迟事亦不办。是故不等名为定难。又有无念定难。谓不念善法。设念善法则非所受。又不念定相而念外色。是名不念。行者应一心精进念所受法如擎油钵。又有颠倒定难。谓多欲人受行慈心。多嗔恚人修习不净。上二种人观十二因缘。又没心中修止。踔心中行精进。是二心中行舍。是名颠倒。又有多语定难。谓多觉观觉观是语言因故。又心不乐住。强系在缘。又有不取相定难。相有三种。所谓止相进相舍相。又有三相谓入定相住相起相。行者不善分别如是等相。故失禅定。又有慢定难若谓我能入定彼不能入。是名憍慢。若谓彼能而我不能。是不如慢。若未得定自谓为得。是增上慢。于不妙定而生妙想。是名邪慢。又贪等法亦名定难。如经中说。若行者一法成就。则不能观眼无常。所谓贪也。问曰。一切未离欲人皆不能观眼无常耶。答曰。此言少失。应说现在起贪不能观眼无常。有成就中亦有差别。有人贪等厚重常来在心则能障定。若薄而不常。则不能为难。又经中说十三恶法皆名定难。十三白法皆是顺定。所谓佛言若不断三法则不能度老病死。谓贪恚痴。若不断三法则不能断贪恚痴。谓身见戒取疑。次有三法谓邪念邪行没心。次有三法谓妄忆不安慧乱心。次有三法谓调戏不守诸根破戒。次有三法谓不信邪戒懈怠。次有三法。谓不喜善人恶闻正法。喜出他过。次有三法。谓不恭敬难可与语。习恶知识。若不断三法则不能断不恭敬难与语恶知识。谓无惭无愧放逸。若能断无惭无愧放逸。则断不恭敬难与语恶知识。乃至能断身见戒取疑。则能断贪恚痴度老病死。是中度老病死。谓无余涅槃断贪恚痴。谓阿罗汉果。有余涅槃断身见戒取疑。谓三沙门果。断邪念邪行没心。谓在暖等达分善根。断妄忆念不安慧乱心。谓修四忆念处。断调戏不守诸根破戒。谓受出家戒。断不喜善人。恶闻正法喜出他过。不信邪戒懈怠不恭敬难可与语习恶知识无惭无愧放逸。谓在家清净。所以者何。若人独处为恶不羞。是名无惭。此人于后恶心转增。众中为恶亦无所耻。是名无愧。失善法本二白法故。常随恶法是名放逸。以成就此三恶法故。不受所尊师长教悔。名无恭敬。反悷师教名难与语。如是则远离师长亲近恶人名习恶知识。于此中从无惭生无恭敬。从无愧生难与语。从放逸生习恶知识。故为不信。受邪戒法常为懈怠。习近恶人教令不信。言为恶无报。或闻行恶得报。即便受行鸡狗等法。望速毕罪。受行此法不觉有利故生懈怠。以懈怠故不喜善人。谓无真实行正行者。亦恶闻正法。谓行正法皆如邪法无所利益。以心浊故喜出他过。谓他行法皆如自己都无所得。如是不能制烦恼。故心则戏调。以戏调故不摄诸根则能破戒。以破戒故妄生忆念。行不安慧心志散乱便生邪念。生邪念故便行邪道。行邪道时不得利。故心则迷没。心不明故不断三结。不断三结故。不能断贪等烦恼病等诸衰。与此相违名为白法。又有愁忧定难。行者生念。我于尔所年月岁数。不能得定故生愁忧。又贪着喜味亦是定难。又有不乐定难。虽得好处善师等缘心亦不乐。又贪等诸盖皆名定难。取要言之。乃至衣服饮食等法。减损善根增长不善皆名定难。应当觉知勤求舍离

成实论卷第十四成实论卷第十五

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    止观品第一百八十七

问曰。佛处处经中告诸比丘。若在阿练若处。若在树下若在空舍。应念二法。所谓止观。若一切禅定等法皆悉应念。何故但说止观。答曰。止名定观名慧。一切善法从修生者。此二皆摄。及在散心闻思等慧亦此中摄。以此二事能办道法。所以者何。止能遮结。观能断灭。止如捉草观如镰刈。止如扫地观如除粪。止如揩垢观如水洗。止如水浸观如火熟。止如附痈观如刀决。止如起脉观如刺血。止制调心观起没心。止如洒金观如火炙。止如牵绳观如用刬。止如镊镊刺观如剪刀剪发。止如器钾观如兵杖。止如平立观如发箭。止如服腻观如投药。止如调没观如印印。止如调金观如造器。又世间众生皆堕二边。若苦若乐。止能舍乐观能离苦。又七净中戒净心净名止。余五名观。八大人觉中六觉名止。二觉名观。四忆处中三忆处名止第四忆处名观。四如意足名止四正勤名观。五根中四根名止慧根名观。力亦如是。七觉分中三觉分名止。三觉分名观。念则俱随。八道分中三分名戒。二分名止。三分名观。戒亦属止。又止能断贪观除无明。如经中说。修止则修心。修心则贪受断。修观则修慧。修慧则无明断。又离贪故心得解脱。离无明故慧得解脱。得二解脱更无余事故但说二。问曰。若止观能修心修慧。修心慧故能断贪及无明。何故定说止能修心能断贪爱。观能修慧能断无明。答曰。散心者诸心相续行色等中。此相续心。得止则息故说止能修心。从息心生智。故说观能修慧。以生观已后有所修皆名修慧。初慧名观后名为慧。若经中说修止断贪。是说遮断。何以知之。色等外欲中生贪。若得止乐则不复生。如经中说。行者得净喜时舍不净喜。若说无明断是究竟断。何以知之。无明断故贪等烦恼断灭无余。经中亦说离贪故心得解脱是名遮断。离无明故慧得解脱是毕竟断。有二种解脱时解脱不坏解脱。时解脱是遮断。不坏解脱是毕竟断。问曰。时解脱是五种阿罗汉无漏解脱。不坏解脱是不坏法阿罗汉无漏解脱。何故但说遮断耶。答曰。此非无漏解脱。所以者何。时解脱名但以上力少时遮结。而未能永断。后则还发故非无漏。又此解脱名时爱解脱。漏尽阿罗汉无所可爱。问曰。若尔则无圣所爱戒。答曰。以诸学人漏未尽故我心时发。是故于戒生爱。非阿罗汉我心永灭而生爱也。问曰。瞿提阿罗汉于时解脱六返退失。恐第七退故以刀自害。若失有漏不应自害。故知时解脱不名有漏。答曰。此人退失所用断结禅定。于此定中六返退失。第七时还得此定。便欲自杀。尔时寻得阿罗汉道。是故魔王谓。学人死绕尸四边遍求其识来。白佛言。世尊。云何汝弟子未漏尽而死。佛言。此人已拔爱根得入泥洹。问曰。若断贪名遮断者。经中说。从贪心得解脱。从恚痴心得解脱。又说断贪喜故心得好解脱。又说从欲漏心得解脱。如是皆应名遮解脱非实解脱。答曰。是中亦说无明断。故知是毕竟解脱。若说断贪或是遮断或毕竟断。若不生真智则是遮断。随生真智是毕竟断。无有用止能毕竟断贪。若然者。外道亦能毕竟断贪。而实不然。故知但是遮断。问曰。经中说。以止修心依观得解脱。以观修心依止得解脱。是事云何。答曰。行者若因禅定生缘灭智。是名以止修心依观得解脱。若以散心分别阴界入等。因此得缘灭止。是名以观修心依止得解脱。若得念处等达分摄心。则俱修止观。又一切行者。皆依此二法得灭心解脱

    修定品第一百八十八

问曰。汝言应修习定。是定心念念生灭。云何可修。答曰。现见身业虽念念灭。以修习故有异技能。随修习久转转便易。口业亦尔。随所习学转增调利坚固易忆。如读诵等。当知意业虽念念灭亦可修习。如火能变生水能决石风能吹物。如是念念灭法皆有集力。久随习烦恼则随炽盛。如人世世修习淫心则成多欲。恚痴亦尔。如经中说。若人随念何事心则随向。如常随欲觉心则向欲。二觉亦尔。故知此心虽念念灭亦可修习。又修名增长。现见诸法皆有增长。如经中说。行者以邪念故。欲等诸漏未生。则生生者增长。谓从下生中从中生上。如种牙茎节花叶果实。现见皆从因渐次增长。定慧等法亦应如是。又现见勋麻其香转增。是香及麻念念不住而有勋力。故知念念灭法亦可修习。问曰。麻是住法花香来勋。无有住心。以念念灭智而来修习云何为喻。答曰。无有住法一切诸法皆念念灭。此事先成故非难也。又若法不念念灭则无修习。即体常住修何所益。若法念念灭。以下中上法故有修习。问曰。诸花到麻能勋。智不及心故无修习。答曰。先业喻中是事已明。所谓后业不到先业。先语不待后语。而身口业亦有修相。是故汝言不到不修。不名为难。又现见因果虽不同时。亦得从因有果。如是心法虽念念灭亦有修习。又如种得水虽不到牙等。亦能令牙等滋茂。如是智慧修习先心后心增长。问曰。若麻念念灭则异麻生。是麻为勋生。为不勋生。若不勋生终无有勋。若勋生者复何用久勋。答曰。以因勋故。如种得水则牙滋茂。如是因先花合而异麻生。是则勋生。汝言何用久勋。如汝经中说。因火合法微尘黑相灭赤相生。若初火合法灭黑相者。不应更生黑相。若初火合法生赤相者。复何须后火合法。若初火合时黑相生。赤相终不应生。若第二时赤相生。复何须久与火合。若汝意谓赤相渐生。心亦如是。有何咎耶。坏等亦尔。又诸法虽有因缘。亦次第生。如受胎等渐渐成身。如种根等亦渐次生。如是定慧等法虽念念灭。亦以下中上法次第而生。又修法微细异心相续。如羽毛暖微卵则渐变。掌肌软故斧柯微尽。心亦如是。定慧妙故渐次修习。又修习法时到乃知。如偈中说。一分从师受一分因友得。一分自思惟。一分待时熟。若人虽复终日读诵。不能明了。如时熟者如以多华一时勋麻。不如少华渐渐久勋。膏润水浸漯墙壁等皆亦如是。现见种根牙等增长微细尚不能见。日日所长如毫末许。小儿等身酥乳等熟亦复如是。故知修法微妙难觉。问曰。或见有法一时顿集。有人先不见色见即染着。亦有少时多所通达。何故但说渐次修习。答曰。皆是过去曾修习故。知积习以渐此事已明。又非但发心能有所成。如经中说。若于善法不勤修习。而但愿欲不受诸法。于诸漏中心得解脱。是人所念终不从愿。以不能勤修善法故。行者若能勤修善法。虽不发愿亦于诸漏心得解脱。以从因生果不须愿故。犹如鸟雀要须抱卵。不以愿故禽从[穀-禾+卵]出。又不以愿故灯明清净。要须备具清油净炷。无物触动其明乃净。又非但愿故能得嘉谷。必须良田好种时泽调适农功具足乃有所获。又不但愿故身得色力。要服良药肴膳等缘。乃得充满。如是非但愿故能得漏尽。要须真智乃得解脱。何有智者知从因生果。而舍其因从余求果。又修习法现见果报。如经中佛说。且置七日我教弟子。乃至须臾修习善法。于无量岁常得受乐。又诸比丘尼语大德阿难。我等善修念处。觉异于初。又经中佛告诸比丘。若人无谄曲心来至我所。我朝为说法。令夕得利。夕为说法。令晨得利。又若人得阿罗汉道。无他人与亦非非人与。但修正因故获斯利。又无上佛道尚以积习善法故得。况余事也。如经中说。佛语比丘。我依二法得无上道。一者乐善无厌。二者修道不倦。佛于善法终无齐限。又诸菩萨虽不得定亦不懈惓。所以者何。若不为善则无所获。为善亦不相伐。不为善者终无安隐。思量此已则勤精进修习善法。若发精进或得或失。不精进者永无得望。是故应勤修习。勿生懈惓。又智者究竟必应解脱。若离修习更无方便。是故智者当勤修习。勿生厌惓。又行者念。行正行必有果报。虽未便得不以为忧。又行者应念。我已曾得修习果报。以众生昔来皆得一切诸禅定故。我今正修亦必当得。故不厌惓。又正行者佛为作证。我今正行故知必得。又我得道因缘具足。谓得人身诸根完具。明识罪福亦信解脱。遇善知识。具此等缘。云何不得修习果报。又正行精进终不唐弃。故不厌惓。又烦恼断细微难觉。如柯渐尽。我诸烦恼亦当有断。但以细故不能尽觉。故知修善精进为最。又少智尚能断诸烦恼。如少光明亦能除闇。如是但得少智则为事办。故不厌惓。又久而难成。所谓得定。若得定已则余功未几。是故虽不速得。终不厌惓。又行者应念得定甚难。如昔菩萨福慧深厚。精勤六年尔乃逮得。及余比丘得定亦难。况我凡夫薄福钝根而能疾得。如是念已不生疲厌。又诸行人必应为者。所谓修定。更无余业。故得与不得要当修习。又修习者。虽不得定亦名得身远离。身远离已定则易得。又若勤修定则不负佛恩。亦以行远离故得名行者。又修习善久则成善性。乃至转身善常随逐。故能常与善人相遇。是为大利。又常修善者。或于现身而得漏尽。若死时得。若命终已化生善处。于彼间得。如闻法利中说。又行者内心发勇猛相。作如是念。我若不坏烦恼阵者终不空返。又行者依憍慢心生如是念。他人有信等善根故能得定。我今亦有何为不得。如昔菩萨从阿罗逻等仙人闻法。作如是念。是人有信等善根。故能得法。我今亦有何故不得。又行者知烦恼劣弱智慧力强。断之何难。如说比丘成就六法能以口风吹散雪山。况死无明。又行者生念。我于宿世不修定。故今不能得。今若不勤后复不得。故应勤习。又常修定故心得住处。如瓶转不止必得住处。又行者生念。我若常勤精进。若得不得后必不悔。故应一心勤修诸定

    道谛聚智论中智相品第一百八十九

真慧名智。真者谓空无我。是中智慧名为真智。假名中慧名想非智。所以者何。经中说。如刀能割。圣弟子以智慧刀能断结缚使缠一切烦恼。不说余法。不以不实能断烦恼。故知智慧为实。问曰。汝但说慧能断烦恼。是事不然。所以者何。以想亦能断诸烦恼。如经中说。善修无常想。故能破一切欲染色染及无色染一切戏调憍慢无明。答曰不然。慧断烦恼以想名说。佛二种语。一实语。二名字语。如经中说慈断嗔恚。而是慈法实不断结。但智能断如说智刀断诸烦恼。故知慈能断结。是名字语。又慧义经中说。解知故名慧。解知何事。谓色无常如实知无常。受想行识无常如实知无常。是名智慧。又说。圣弟子定摄心者如实知见。是故知第一义缘名为智慧。又智慧喻中说智刀慧箭等。是喻皆示断除烦恼。但真智慧能断烦恼。故知智慧为实。又偈中说。行者见世间一切诸天人退失真智故贪着于名色。世间多见虚妄常乐净等。名失真智。若见真实空无我等名得真智。故知智慧为实。又经中佛说。若人失财名失少利。若失智慧名失大利。又说。于诸利中财是少利。慧为最利。又说。于诸明中日月明小慧明第一。若慧非实。佛以何故作如是说。又经中说。慧根是圣谛摄。又说。苦集智等当知真实。缘第一谛是名智慧。又说。于诸法中智慧为上。又说。无上正遍知亦说慧眼。故知其实。又佛十力皆是智性。故知智慧为实。缘第一义。问曰。若尔则无世间智慧。答曰。实无世间智慧。何以知之。世间心缘假名。出世间心缘空无我。所以者何。世间即是假名。出于假名名出世间。问曰。汝说不然。所以者何。经中说。识何所识。谓识色声香味触法。如是阴界入等皆以识识。今是识皆应名出世间。是故汝言世间心但缘假名不能缘实。是事不然。又意识亦能实缘。以能缘受想行等故。又佛说二种正见。世间出世间。见有福罪等名为世间。若圣弟子缘苦习灭道。无漏念相应慧名出世间。又偈中说。得世上正见。虽往来生死乃至百千世。常不堕恶道。又经中说。邪行者得生善处。是人罪业未成。善缘先熟。或临死时正见相应。善心现前。故生善处。又十善道中亦说正见。汝云何言无世间智。又佛自说有三种慧。闻慧思慧修慧。闻慧思慧皆是世间。修慧二种。又佛生念。罗睺罗比丘未能成就得解脱慧。又说。五法能令未熟解脱心熟。此皆是世间智慧。又经中说。有人能出而不能观。有人能观而不能渡。得世间智故名能出。未见四谛故不能观。若见四谛而未得漏尽。故名不渡。又佛自说。法智比智他心智世智。又说。宿命智生死智皆是有漏。又说。法住智泥洹智。如是等经中说。故当知有有漏智。答曰。若有有漏智慧。今应当说有漏无漏智差别相。问曰。若法堕有是名有漏。异则无漏。答曰。何法名堕有。何法名不堕有。是事应答。若不能答则非有漏无漏相。汝言有世间心缘非假名。谓识诸尘等。是事不然。所以者何。佛说凡夫常随假名是义。以一切凡夫心不破假名。故常随我相终不得离。虽见色亦不离瓶等相。故凡夫心不缘实义。虽缘受想等法。亦见是我我所。故知一切世间心皆缘假名。汝言有诸世间智慧。谓二种正见等。今当答心有二种。痴心智心。缘假名法是名痴心。若但缘法。谓空无我是名智心。如解无明经中说。无明者不知先。不知后。不知先后。不知业。不知报。不知先后业报。如是等处处如实不知不见不解。痴妄黑闇故名为无明。如实不知者。谓不知空无我。是凡夫心常在假名缘假名故名为无明。缘空名智。今若一切世间心皆缘假名。缘假名心名为无明。何得言有世间智慧。问曰。如汝说智慧相。缘假名名无明者。今阿罗汉应有无明。亦有缘瓶等心故。答曰。阿罗汉无缘瓶等心。所以者何。初得道时已坏一切假名相。故但为事用故说瓶等。不着见慢。有三种语。一从见生。二从慢生。三从事用生。凡夫若说瓶若说人。是语皆从见生。学人虽无我见。以失正念故。于五阴中以我慢相说是人是瓶。如差摩伽经中说。事用生者。谓阿罗汉如大迦叶见僧伽梨言。是我物。天神生疑。佛释之言。此人永拔慢根烧尽因缘。云何有慢。但以世间名字故说。故知阿罗汉无瓶等心。问曰。若无世间智慧说二种正见等。经当云何通。答曰。此皆是想以智名说。佛能通达诸法实相。随可度众生立种种名。如智慧以受等名说。所谓受者于诸法得解脱。亦说善修无常等想能破一切烦恼。亦说第四不黑不白业能尽诸业。所谓学思。又说。以意断诸贪着。又说。信能度河一心度海。精进除苦慧能清净。又说。眼欲见色眼实无欲。但心欲见以眼名说。问曰。若世间智实是想者。何故名智。若无因缘说名为智。则一切想皆应名智。亦可说有二种想。一缘世谛。二缘第一义谛。答曰。不然。想有种种差别。有想极痴乃至不识世间善恶。有想次痴能别善恶。有想小痴能缘骨相等。不离假名则不能坏诸阴相。此想能顺坏阴相智。故佛说智。又此想能与实智作因。故名为智。世间有因中说果。如说食金施人五事女为戒垢。好岸渠乐法伏人乐。又七漏经中说。用断等漏因名漏。又说。以食为命。草为牛羊。亦说衣食等物皆是外命。若夺人财即是夺命。此皆说因为果。如是智因说智故无咎也。问曰。诸念处及暖等中。心能缘实法是无漏耶。答曰。无漏心能破假名。是故随心能破假名。从此以来名为无漏。问曰。齐何处心能破假名。答曰。随能具足见五阴生灭相。尔时得无常想。无常想能令行者具无我想。如说圣弟子以无常想修心。则能住无我想。以无我想修心能速得解脱贪恚痴等。所以者何。若无我想修心则能住苦想。以我想故虽苦不觉。是故若法无常无我亦苦。智者则能深生恶厌。故无我想能具苦想。问曰。汝何故坏次第说。经中说。若无常即是苦。苦即是无我。故无常想能具苦想。苦想能具无我想。答曰。经中说。无常想修。圣弟子心能住无我想。故无常想能具足无我想。又如是说亦有道理。所以者何。说我者为成后世故说我是常。是故若见五阴无常。即知无我。如经中说。若人说眼是我则无道理。所以者何。眼有生灭。若眼是我我即生灭有如是过。问曰。此二经当云何通。答曰。苦想二种。一从无常想生名坏苦想。一从无我想生名行苦想。是故二经亦不相违。问曰。若尔者念处暖等法中有无常想。此法皆应是无漏答曰。念处等中若是无漏有何咎耶。问曰。凡夫心不应是无漏。亦凡夫心有妄念等。云何当是无漏。答曰。此人非直是凡夫。是人名行须陀洹果。问曰。行须陀洹果在见谛道中。念处等法不名见谛。答曰。行须陀洹果有近有远。住念处等中名远行者。见谛名近。何以知之。佛于斧柯喻经中说。若知若见故得漏尽。知见何法。谓此色等此色等生。此色等灭。若不修道则不得漏尽。修之则得。如抱卵喻。又行者常修道品烦恼微尘。虽不数觉尽已乃知如斧柯喻。又行者常修三十七品。欲缚结缠易可散坏。如海舡喻。故知从念处来修习道品。皆名初果者。又若一念若十五念中。不得修习。当知此是远行须陀洹者。问曰。初说知此色等此色等生此色等灭。是初果道。后三喻是三果道。是故不名行初果者。答曰。若卵不抱则坏。抱则成就。如是从念处来初发修习。若不能成不名为行。能成则是学人名不烂坏能堪受者。是故若于念处等中烂坏。则名凡夫。若修习成则名行初果者。犹在[穀-禾+卵]中。若得出[穀-禾+卵]名须陀洹。故知在念处等中名远行者。又郁伽长者供养众僧。天神示言。此是阿罗汉。乃至此是行初果者。若在见谛道。云何可示。当知是远行者。又经中佛说。若无信等五根。是人名住外凡夫中。是义说有内外凡夫。若不得达分善根。名外凡夫。得名为内。是内凡夫亦名圣人。亦名凡夫。因外凡夫故名圣人。因见谛道故名凡夫。如阿难语车匿言。凡夫不能念色空无我受想行识空无我。一切诸行无常。一切法无我寂灭泥洹。尔时车匿来入法位。亦说凡夫不能念此。问曰。若近若远俱名行者。有何差别。答曰。若见灭谛名真行者。若在远分善根。见五阴无常苦空无我。而未见灭。是名名字行者。所以者何。如经中说。比丘问佛。何名见法。佛言。因眼缘色生眼识。即共生受想思等。是一切法皆无常败坏不可保信。若法无常即是苦。是苦生亦苦住亦苦数数起相亦苦。乃至意法亦如是。若此苦灭余苦不生。更无相续。行者心念。是处寂灭微妙。谓舍一切虚妄贪爱尽灭。离寂泥洹。若于此法中心入信解。不动不转不忧不怖。从此已来名为见法。故知行者。若以无常等行观见五阴。名远行者。若见灭谛名近行者。如车匿答诸上座。我亦能念色等无常。而于一切行灭爱尽。泥洹心不能入通达信解。若如是知不名见法。又说。行者若于此法以软慧信忍名信行者。过凡夫地入正法位。不得初果终不中夭。若以利慧信忍是名法行。见此法已能断三结。名须陀洹。明了无余名阿罗汉。故知见灭名近行者。问曰。行者何故不尽见灭。答曰。经中说。诸法无性。从众缘生是法甚深。一切爱尽寂灭泥洹。是处难见。佛观十二因缘灭。故成无上道。又法印中说。行者若观五阴无常败坏虚妄不坚固。亦名为空。而名知见未净。此经后说。行者作如是念。我所见所闻所嗅所尝所触所念。以此因缘生识。是识因缘为常无常。即知无常。若从无常因缘生识云何当常。是故见一切五阴无常从众缘生。尽相坏相离相灭相。尔时行者知见清净。以说灭尽名知见净。故知见灭名见圣谛。又先法住智后泥洹智。故见灭谛名得圣道

    见一谛品第一百九十

问曰。汝说但见灭谛名行果者。是事不然。所以者何。经中佛说。我及汝等不能如实见四谛。故久处生死。今见是四谛身因缘断生死根尽。更不受有。当知见四谛故名行果者。非但见灭。又佛说。上法所谓四谛。是故行者应悉知见。又说。若人法服毁形正信出家。皆为见四谛故。若人欲得须陀洹斯陀含阿那含道。皆为见四谛故。若得阿罗汉辟支佛佛道。皆已见四谛故。故知非但见灭谛也。又佛自说。四谛以次第得。又转法轮经中说。我观此苦此苦因此苦灭此苦灭道。于是中生眼智明觉。如是三转皆说四谛。又经中说。鲜净白叠投之池中即时受色。此人如是。即于一坐见四真谛。又说。行者净心正观苦谛乃至道谛。如是见故。从欲漏有漏无明漏中心得解脱。又诸经中说。圣谛处尽皆说四谛。不但说灭。又佛说四智。苦智集智灭智道智皆为四谛故。有行者法应遍见四谛。犹如良医应知病知病因破病破病药。如是行者欲脱诸苦。应知苦苦因苦灭苦灭道。若不知苦何由当知苦因苦灭及苦灭道。故知非但见灭。答曰。诸有说四圣谛利。皆于阴界入等中说。谓知此色等色等生灭。故得漏尽。又佛自说。我于色等阴中。不如实知味过出离。终不自谓得无上道。若如实知则自知得道。又城喻经说。我若未知老死老死生老死灭老死灭道。乃至诸行诸行生诸行灭诸行灭道。不自说我得无上道。若如实知自说得佛。如是等见若是得道见者。则十六心不名得道问曰。我不说此名得道见。是思惟时。答曰。四谛中亦如是说。亦可说是思惟时。若不尔应说因缘。见四谛名得道时。见五阴等为思惟时。问曰。断烦恼智名为得道。思惟五阴等不断烦恼。答曰。我先已说五阴等智亦断烦恼。如说知见色等故得漏尽。又说。见世间集则灭无见。见世间灭则灭有见。又佛自观因缘得道。又甄叔伽经中说种种得道因缘。有人观五阴得道。或观十二入十八界十二因缘等得道。故知非但以四谛得道。若汝意谓虽有是说不以此观能断烦恼。亦可说言虽观四谛不断烦恼。又要当以真谛得道。而解四谛中说。生苦老苦病苦死苦怨憎会苦爱别离苦所求不得苦。取要言之。五阴为苦。又说。苦因所谓贪爱。常随喜乐处处受身。观如是等不应尽漏。此皆世谛。非第一故。问曰。虽观生死等不应尽漏。略说五阴皆苦。是中有智能破烦恼。答曰。余三谛云何。故知汝自忆想分别。又观五阴皆苦。是散乱心不应得道。问曰。若不以四谛得道。当以何法得道。答曰。以一谛得道。所谓为灭。如经中说。妄名虚诳实名不颠倒。一切有为法皆虚诳妄取。故知行者随心在有为法中。皆非真实。如经中说。诸有为法虚诳。如幻如焰如梦如假借等。如法句经中说。虚妄系世间似如有坚实。实无见如有。正观则皆无。如实无男女法。但五阴和合强名男女。凡夫倒惑谓之实有行者观此五阴空无我。故即不复见。如法印经中说。行者观色无常空虚离相。无常者。谓色体性无常。空虚者如瓶中无水名曰空瓶。如是五阴中无神我。故名为空。如是观者者亦名为空。亦名知见未净。以未能见五阴灭故。后乃见灭。所谓行者作如是念。我所见闻等。故知见灭诸烦恼尽。问曰。何故见灭则烦恼尽非余谛耶。答曰。行者尔时苦想决定。若未证灭相。于有为法中苦心未定。如人不得初禅喜乐。于五欲中不生厌想。又如未得无觉观定。于觉观定不以为患。行者亦尔。未证泥洹寂灭相时不得行苦。当知见灭谛故苦想具足。苦想具足故爱等结断。问曰。若见灭谛故苦想具足。应见灭谛后烦恼方断。所以者何。见灭谛已苦想具故。答曰。非后时断。随于灭中得寂灭相。即时苦想具足。后当现前。如经中说。行者于集生相。法知尽灭相。即于法中得法眼净。又人于诸阴中常有我心。虽观诸阴无常苦等。未得永灭。若见灭谛以无相故我心永灭。问曰。若见灭谛则我心尽。何故佛观前人柔软心等为说四谛。不但说灭。答曰。此中有顺道行。何者以无常想无我想具足故。得此苦观以其近道。是故合说。问曰。若得道时断身见者。何故复说戒取疑耶。答曰。行者得道现见诸法皆空无我。即不复疑。不同凡夫闻思等观。若见道谛则知唯此一实更无余道。是故说三。问曰。若得道时见谛所断诸烦恼尽。何故但说三结尽耶。答曰。一切烦恼皆以身见为本。如佛问比丘。人以何事因何事。见何事故生如是见。唯有此身死则断灭。如是等一切见。比丘白佛。佛为法王唯愿解脱。佛言。人以色因色见色是我。故起此见。乃至识亦如是。当知因见我故生诸烦恼。所以者何。若有身见则谓此我若常无常。若定见常则是常见。定见无常则是断见。若我是常则无业无报无苦解脱。我若无常亦无业无报及苦解脱。不以修道而得泥洹。若以此见为胜。即是见取。谓能得度即是戒取。自见中爱他见中恚。以此见自高即是憍慢。皆以不如实知故起此结。即是无明。是故身见断故见谛结断。问曰。若身见断余亦断者。何故别说戒取疑耶。答曰。以其胜故。行者现见法相则无有疑。此疑疑我为有为无。亦疑此道得清净不。令见苦谛则我见断。亦知唯此一道更无有余。是故说断身见名真见苦断戒取故名修行道。于知所知法中无疑。若以正智知所知法。即断集证灭名具四谛。故说此三示无疑相。此疑从我道生。如经中说初得道相。谓见法得法知法达法。度诸疑网不随他教。于佛法中得无畏力安住果中

    一切缘品第一百九十一

问曰。何智能一切缘。答曰。若智行界入等名一切缘。所以者何。若说诸入诸界法。物事有诸缘诸尘可知识等。皆尽诸法若智能缘。名一切缘。问曰。此智不知相应共生等法。答曰。能知若缘入等。是名总相智。总相智故能缘一切。所以者何。若说十二入则更无余法。故知此智亦缘自体。问曰。经中说。二因缘生识。是故不应有自缘智。又诸智无有因缘譬喻能缘自体。如指端不能自触。眼不能自见。答曰。汝说二因缘生识此事不定。亦有无缘生智。非一切皆从二因缘生。又第六识于自阴中都无所缘。无现法故是识不能缘色等法。若能缘者盲人亦应见色。此人尔时心心数法。在去来中。去来无法为何所缘。但遮计神故如是说。若诸识生皆由此二非四因缘。或有识生无二因缘。如经中说。六入因缘触而实无触。以六入为因缘。若生则不出于六入。为遮第七入故。如是遮四因缘。故佛说二。又于过去未来虚空时方等中知生。而此法实无。此即是无缘知。问曰。若然者以此因缘过去未来等法应有。若无云何生知。于兔角龟毛蛇足等中终不生知。答曰。于作中知生。如见人去则忆去时。若闻人语。则忆语时。如是等过去中无作是故不然。问曰。今于过去为何所忆。答曰。忆无所有。汝言何故不忆兔角等。若法生已而灭是则可忆。若本来无何所忆耶。如法先名众生今虽过去亦名众生。如是先于此法生忆。故即此心还忆。非异心也。又是人先取此法相。此法虽灭而能生忆想分别法。若法于此人心生。此法失灭后意识生。能知此事是名相缘识。又是相能与后缘相识作因缘。兔角等识无相为因。是故不生。又亦应有缘兔角等识。若无云何能说。问曰。兔角性非可识。所以者何。终不生长短黑白等念。故过去法亦如是。所以者何。我等不能以过去法令现在前。如圣人知未来事。言此事当尔此事不尔。答曰。圣智力尔。法虽未有而能预知。如圣人能坏石壁入出无碍。此事亦尔。无而能知。又以忆力故。知如眼识不能分别男女。若眼识不能意识亦不应能。而意识实能是事亦尔。又如我等于先所用已灭事中生知。圣人亦尔。于无法中而能生知。又如说提婆达多无有一识能识四字。而亦能识。是事亦尔。又如诸数量别异合离此彼等。是中虽无现法亦能生识。又如人身不可以一念遍知。亦不可以分分识知。虽分分不知一念不知。而亦生人知。是事亦尔。汝言无有因缘譬喻能知自体。此中有说意能自知。言行者随心观而去来无心。故知以现在心缘现在心。若不尔终无有人能识现在心相应法。问曰。经中说。若能以慧观一切法无我。即得厌离苦。是道为清净。此智慧除自体及共生法余一切法缘。答曰。此智但有漏缘非无漏。所以者何。此偈中说即厌离苦。故知但缘苦谛。又为坏我见修无我智。我见五受阴缘。当知无我亦缘受阴。是五受阴无常故无我。如经中说。若无常即是无我。若无我即是苦。又佛语比丘。断非汝所有法。比丘言得已。世尊。佛问。汝云何得。世尊色是非我所。受想行识非我所。佛言。善哉善哉。当知但受阴中生无我心。又经中说。诸所有色若过去未来内外粗细近远大小。皆应知非我非我所。如是实以正慧观。又说。观色无我受想行识无我。观色无常虚妄如幻诳无智眼。为怨为贼无我无我所。又佛说。于此坐中有愚痴人。在无明[穀-禾+卵]无明所盲。舍离佛法生此邪见。若色无我受想行识无我。云何无我起业。而以我受故。知无我但缘受阴。又经中无处说无我智缘一切法。处处皆说五受阴缘。问曰。佛自说一切法无我。故知有为无为此智皆缘。非但缘五受阴。又说十空缘一切法。空即无我。又说诸行无常苦。一切法无我。若无我智但缘苦谛。何故不说诸行无我。以说一切法无我故。当知若说行则说有为。若说法即通一切。又说谁于一相法及别异相法智慧现在前。如明眼见色。唯诸佛世尊正智得解脱。能于一相法及别异相法。智慧现在前如明眼见色。以无我想故。诸法一相。故知无我缘一切法。非但缘苦。答曰。一切二种。一摄一切。二摄一分。摄一切者。如佛说我是一切智人一切名十二入。摄一分者。如说一切然。而无漏无为不可得然。又如来品中。说如来是一切舍者一切胜者。不可舍持戒等法。但为恶法说一切舍。不可胜余诸佛。但为余众生故说一切胜。又说。云何比丘名一切智。谓如实知六触入生灭。是名总相知一切法。非别相智。佛总别悉知名一切智。是比丘总知诸法无常等。故名一切智其名虽同而实有异名摄一分。又佛言。若法入修多罗随顺比尼不违法相。是法应受。又说。若人言此是佛语。是人语正而义非。智者于中应说正义。语此比丘。是语应与何义相称。复有说者义正而语非。是正义中应置正语。如是等经佛悉听之。又有了义不了义经。此是不了义经。何故于一事而说一切名。应知其意。又世间人于一事中亦说一切。如言为一切祠一切与食。亦说此人一切皆食。故知虽说一切无我。当知但为五受阴说。非一切法。汝说十空。此中不得有无为空。所以者何。无人于无为中生我想。故设有余空亦无所害。汝亦以苦智与空相应。是故空非一切法缘。问曰。世间空缘一切法。非无漏空。答曰。无世间空。一切空皆是无漏。又问。法印经中说。空是世间空。答曰。是出世间空。非世间空。又问。是中说知见未净。故知是世间空。答曰。我先说无漏心能破假名。是故从破假名来。名无漏心。后见灭谛离增上慢。名知见净。是故无世间空。汝说如一切行无常一切法无我。如是应有行者具足无我想。时法相具足故于无我说法名字。如见品中说。若人不见苦是即为见我。苦如实见苦。即不复见我。如实者。谓见无我。是故说一切法无我。但缘苦谛说无我行。汝说佛现前见一相异相。此亦应有以界入等为一。故说一相有何咎耶

成实论卷第十五成实论卷第十六

        诃梨跋摩造

        姚秦三藏鸠摩罗什译

    圣行品第一百九十二

有二行。空行无我行。于五阴中不见众生是名空行。见五阴亦无。是无我行。何以知之。经中说。见色无体性。见受想行识无体性。又经中说。因无性得解脱。故知色性非真实有。受想行识性非真实有。又经中说。五阴皆空如幻。不可说幻为真实。幻若真实有不名为幻。亦不可言无。但以无实能为诳惑。又此行者观一切空。故知五阴非真实有。如破一相故不见壁等一法。五阴亦尔。无一实法。问曰。若色等法亦非真实。今应唯一世谛。答曰。灭是第一义谛故有。如经中说。妄谓虚诳谛名如实。灭即是如实决定。故名第一义有。又行者生真实智。一切有为皆悉空无。故知灭是第一义有。问曰。汝说见五阴中无众生。因何五阴说名众生。为有漏为无漏。答曰。亦有漏亦无漏。问曰。经中说。若见众生皆是见五受阴。答曰。无漏法亦在众生数。不在非众生数木石等中。故知亦因无漏诸阴名为众生。又若圣人在无漏心。尔时亦名有心众生。故无漏心亦名众生。一切诸阴皆名受阴。从受生故。问曰。云何知皆从受生。答曰。无漏法皆从布施持戒修定等业心中生。无则不生。如经中说。为无明所覆爱结所系。故愚夫得此身智者亦如是。身即受阴。问曰。若一切阴皆名受阴。漏无漏阴有何差别。答曰。一切诸阴从受生。故皆名受阴。但不受后身故名无漏。是名差别。阴与受阴俱从受生。故曰受阴。是故此经不相违背。是二行皆缘无所有。若色等法空及体性灭。皆是无所有。问曰。此二皆缘五阴。经中说。见色空无我见受想行识空无我。答曰。因诸阴见空无我。所以者何。于众生因缘中见众生空。亦见色等法灭。问曰。是则俱缘。若行者念诸阴及空。即名缘阴及无所有。答曰。行者于众生因缘中不见众生。故即生空心。然后见空。又于五阴灭中。不见色体性受想行识体性。故知此二皆无所有缘

    见智品第一百九十三

问曰。正见正智有何差别。答曰。即是一体无有差别。正见二种。世间出世间。世间者。谓有罪福等。出世间者。谓能通达苦等诸谛。正智亦尔。问曰。汝说见智相不如是。所以者何。诸忍但见非智。尽智无生智及五识相应慧。但智非见。答曰。何故诸忍非智。问曰。以未知欲知故名未知根。若苦法忍是智。苦法忍知已。苦法智应名知根。不名未知根。是故忍非智也。又经中说。若行者于是诸法少能以慧观。忍名未讫竟。讫竟名智。若忍名观未讫。又初无漏慧始见名忍。不应以初见为智。又忍时不了。智时决了。又忍生时疑犹随逐。故忍非智。答曰。忍即是智。所以者何。欲乐忍皆是一义。行者先知苦已。然后忍乐。若先不知何所忍乐。又少语中但说观忍。而不说智。然则应受行果者无智。若汝意谓行者有智而名为忍。今亦应受忍即是智。又经中说。行者知时见时即得漏尽。又说。知见得是一义。又佛说苦智集灭道智。不说有忍。故知智即是忍。又佛解智义中说。如实知故名智。忍亦如实知。故不应有异。若汝以未知根故名为忍者。是事不然。我等不说先忍后智。于一心中即名忍智。是义不成。汝云何以不成相成。汝言忍名未讫。我已先答。谓先知后忍。当知忍即为讫。若不知讫云何能忍。汝言忍时未了。汝法中以忍断结。如其不了何能断结。汝言忍时疑犹随逐。若尔见谛道中皆有疑随。是中智生皆应非智。又无有分别是忍是智。如世间观随顺四谛。亦名为忍亦名为智。无漏忍智亦应如是。问曰。尽智无生智但智非见。答曰。有何因缘。问曰。经中别说正见正智。故智非见。答曰。若尔则正见不名正智。若汝谓正见是正智。正智亦应是正见。又五分法身从慧品中别说解脱知见。应当非慧。然则尽智无生智亦非是慧。今即正见以异相故说名正智。谓尽一切烦恼于阿罗汉心中生。故说名正智。问曰。若正智即是正见。则阿罗汉不名十分成就。答曰。体一而异名。如法智苦智。又说阿罗汉名八功德福田成就。是故正智即是正见。又六和敬中第六和敬说名同见。若如汝说则尽无生智不名和敬。又正观故名正见。尽无生智以正观故亦名正见。问曰。五识相应慧但智非见。答曰。何故非见。问曰。五识皆无分别。以初在缘故见名思惟观察。又五识但缘现在。是故非见。答曰。是中无觉观故不能分别。若言初在缘故非见。是事不然。所以者何。汝法眼识有相续缘。如意识故。不应言初在缘。若尔意识亦不应有见。又汝说缘现在故非见。是亦不然。他心智亦缘现在。是亦应非见。五识中无真实知以无行故亦常随假名。故见智慧等一切皆无。况但无见。问曰。有人言眼根名见。是事云何。答曰。眼根非见。眼识能缘随俗言说。故曰眼见。问曰。有人言有八见。谓五邪见世间正见学见无学见。除此八见余慧不名为见。是事云何。答曰。若见智得解了通证皆是一义。若言此见此非见。皆自忆想分别说。问曰。经中说知者见者则得漏尽有何差别。答曰。若智初破假名名为知。入法位已则名为见。始观名知达了名见。有如是法深浅等别

    三慧品第一百九十四

三慧。闻慧思慧修慧。从修多罗等十二部经中生名为闻慧。以此能生无漏圣慧。故名为慧。如经中说。罗睺罗比丘今能成就得解脱慧。虽闻违陀等世俗经典以不能生无漏慧故不名闻慧。若能思量诸经中义是名思慧。如说行者闻法思惟义趣。又说。行者闻法思惟义已。当随顺行。若能现前知见是名修慧。如说行者于定心中见五阴生灭。如诸经中说汝等比丘修习禅定当得如实现前知见。又七正智经中说。若比丘知法名闻慧。知义名思慧。知时等名修慧。又如罗睺罗读诵五受阴部等名闻慧。独处思义名思慧。后得道时名修慧。又经中说三种器杖。闻杖离杖慧杖。闻杖名闻慧。离杖名思慧。慧杖名修慧。又经中说闻法五利。未闻则闻已闻明了。断疑正见以慧通达甚深义趣。未闻则闻已闻明了是名闻慧。断疑正见是名思慧。以慧通达是名修慧。又闻法利中说。行者以耳听法以口诵习是名闻慧。以意思量是名思慧。以见通达是名修慧。又四须陀洹分中闻正法名闻慧。正忆念名思慧。随法行名修慧。又五解脱门中。从所尊闻法是名闻慧。通达语义是名思慧。生欢喜等名为修慧。又经中言。佛所说法三时善等。善男子若长若幼闻法生念。在家愦闹出家闲静。若不出家则不能净修善法。即舍所有亲属财物。出家持戒守护诸根。威仪详审独处思惟。远离五盖得初禅等乃至漏尽。于此中长幼闻法是名闻慧。念在家愦闹出家闲静是名思慧。远离五盖乃至漏尽是名修慧。又经中说。二因缘故能生正见。从他闻法自正忆念。从他闻法名闻慧。自正忆念名思慧。能生正见名修慧。又偈中说。当习近善人听受正法。乐于独处调伏其心。是中习近善人听受正法是名闻慧。乐于独处是名思慧。调伏其心是名修慧。又佛教诸比丘。汝所说时当说四谛。所思惟时当思四谛。是中若说四谛名闻慧。思惟四谛名思慧。得四谛名修慧。如是等处处经中佛说三慧。问曰。是三慧几欲界几色界几无色界。答曰。欲色界一切。如手居士生无热天彼中说法。若人说法必思其义。故知色界亦有思慧。无色界中唯有修慧。问曰。有人言。欲界无修慧色界无思慧。是事云何。答曰。何因缘故欲界无修慧。问曰。以欲界道不能断诸盖障诸缠令欲界缠不现在前。答曰。佛法中无有此语。以欲界道不能断诸盖障诸缠令欲界缠不现在前。又说以欲界道能破烦恼。何者欲界有不净观等。如经中说善修不净观能破贪欲。慈等亦尔。问曰。是欲界不净观等不能永断烦恼。答曰。色界不净观等。亦不能毕竟断诸烦恼。问曰。以粗重不适等行能断烦恼非不净等。答曰。无有经说粗等能断烦恼不净等不能。经中说。以不净等能断烦恼。又粗等有何势力能断烦恼。而不净等不能。又若欲界有粗等行。应以此行断诸烦恼。若无应说因缘。何故有不净等而无粗等。若有而不断烦恼。色界虽有亦不应能断。是亦应说因缘。何故欲界不能而色界能。问曰。欲界虽有粗等而不能断诸烦恼。以是散乱界故。散乱心者无所能断。如经中说。摄心是道散乱心非道。答曰。应说因缘何故欲界名散乱界耶。是中有不净观等。若是散乱界云何能观骨等异相。又色界摄心有何异相而欲界无。问曰。以色界道能得离欲。于此间死生色界中如榍出榍。答曰。何名离欲。问曰。断烦恼名离欲。以色界道能断烦恼非欲界也。答曰。诸外道断结还起还生欲界。是故凡夫不名断结。若断已更生。则无漏断结亦应更生。是事不可。又经中说。断三结已能断三毒。凡夫不能断三结。故无得离欲。又凡夫常有我等心。故无有能断身见等。若凡夫能离欲者。一切烦恼皆不应有。所以者何。一切烦恼皆众缘成。如经中说。从众缘成我。若此凡夫于欲界五阴不起身见。复未得上界诸阴。然则应无身见有如此过。如是烦恼应当永尽。此凡夫应是罗汉。而实不得烦恼都尽。如经中说。闻大雷音二人不怖。转轮圣王及阿罗汉。今此凡夫亦应不怖。又阿罗汉不欣生恶死。如优波斯那阿罗汉。为毒蛇所螫将命终时。诸根不异颜色不变。是人亦应如是。又阿罗汉世间八法不能覆心。此人亦应如是。以离欲故。而实凡夫虽说离欲皆无此相。故知不断烦恼。问曰。凡夫能断烦恼。此间命终往生色界。若不断结云何生彼。经中亦说。有离欲外道。又说阿罗汉迦罗摩郁头蓝弗舍离欲色生无色中。又说。以色离欲以无色离欲。以灭离起思念。是故汝言凡夫虽断烦恼以还生故不名为断。是事不然。汝亦说凡夫诸有所断实皆是遮。但名为断离其实不断说名为断。实不离欲说名离欲。如偈中说。若念我我所。死来则能断。小儿弄土戏。随爱时则吝护若心厌离时即坏而舍去。此亦名离欲。而外道断与死断异。死断不生色无色界。小儿舍土虽供养之。无大果报。若供养离欲外道得大果报。语言虽同其义则异。故知凡夫实有断离。答曰。遮中有差别。若能深遮烦恼则生色无色界。又若能遮身见先已说过。若不能遮欲界身见。云何能生色无色界。但遮贪恚故生色界。非遮身见等。故知凡夫实不断结。亦有欲界善法。能遮烦恼。故知欲界亦有修慧。又经中说。除七依处亦许得道。故知依欲界定能生真智。问曰。是人依初禅近地得阿罗汉道。非欲界定。答曰。不然。言除七依则除初禅及近地已。又此中无有因缘能依近地非欲界定。若此行者能入近地。何故不能入初禅耶。是事亦无因缘。又须尸摩经中说。先法住智后泥洹智。是义不必先得禅定。而后漏尽。但必以法住智为先。然后漏尽。故知除诸禅定。除禅定故说须尸摩经。若受近地即过同诸禅。又无有经中说近地名。是汝自忆想分别。问曰。我先说榍喻。故知以异地道能断异地结。如以细榍能出粗榍。如是以色界道能断欲界。行者若先断欲及恶不善法。然后能入初禅。故知必有近地以之断欲。又说因色出欲。若无近地云何因色。又经中说。行者若得净喜则能舍不净喜犹如难陀因天女爱能舍本欲。又若不得初禅寂灭味者。不能于五欲中生粗弊心。故知先得初禅近地能舍欲界。答曰。得欲界净善能断不善。如说五出性。若圣弟子或念五欲不生喜乐。心不通畅如烧筋羽。若念出法心则通畅。又说。行者随生不善觉观。则以善觉观灭。是故汝说榍喻亦可欲界。汝言因色离欲是末后事。行者以欲界道断诸烦恼。随次渐断乃至能得色界善法。尔时欲界名毕竟断。得色界法汝名得灭尽定阿罗汉亦得诸定。但说其味。汝言得净妙喜及寂灭味。皆已总答。又若欲界无定。云何能以散心证色界善。问曰。慧解脱阿罗汉无定亦但有慧。答曰。此中但遮禅定。必当应有少时摄心乃至一念。如经中佛说比丘取衣时有三毒着衣已则灭。无有经说散乱心中能生真智。皆说摄心生如实智

    四无碍品第一百九十五

问曰。有近法位世智。何者是耶。答曰。是暖等法中能破假名智。是智以世俗见谛故曰世智。近圣道故名近法位。问曰。见谛道中未来修等智。答曰。无未来修等智后当说。所以者何。破法相中无假名心。是故见谛道中不修世智。问曰。经中说四无碍智。何者是耶。答曰名字中无碍智名法无碍。言音中无碍智名辞无碍。谓殊方异俗言音差别。如经中说。行者不应贪着国土言辞。若言音不便义亦难解。若无名字则义不可明。即此言辞不留不尽名乐说无碍。如经中说。有四种说法。或说有义趣不能无尽。有能无尽而无义趣。有二俱能有二俱不能。此三种智名言辞方便。知名语中义无碍智名义无碍。如说有四种说法。有义方便无语方便。有语方便无义方便。有俱方便有俱无方便。若人能得四无碍智是名具足方便。难詶难近说法中上乐说无尽。亦有义趣智慧无穷言辞无滞。问曰。此无碍智云何当得。答曰。以先世业因缘故得。若能世世善修因缘智慧及阴等方便。以修习力故。今世虽不学习文字读诵经典。亦能得知如天眼通等。问曰。何人能得。答曰。唯圣人得。又人言但阿罗汉得非诸学人。此不必尔。学人亦能得八解脱。何故不能得此智耶。问曰。此四无碍在何界中。答曰。欲色界一切。无色界中唯义无碍。无碍二种。有漏无漏。学人具二种无学唯无漏。若得则一时尽得。女人亦得。如昙摩尘那比丘尼等

    五智品第一百九十六

五智。法住智泥洹智无诤智愿智边际智。知诸法生起名法住智。如生缘老死乃至无明缘行。以有佛无佛此性常住故曰法住智。此法灭名泥洹智。如生灭故老死灭。乃至无明灭故诸行灭。问曰。若尔者泥洹智亦名法住智。所以者何。若有佛无佛是性亦常住故。答曰。诸法尽灭名为泥洹。是尽灭中有何法住。问曰。泥洹非实有耶。答曰。阴灭无余故称泥洹。是中何所有耶。问曰。实有泥洹何以知之。灭谛名泥洹。苦等诸谛实有。故泥洹亦应实有。又泥洹中智名灭智。若无法云何生智。又经中佛为诸比丘说。有生起作有为法。有不生起作无为法。又经中说。唯有二法有为法无为法。有为法有生灭住异。无为法无生灭住异。又经中说。诸所有法若有为若无为灭尽泥洹。唯此为上。又说色是无常灭色故泥洹是常。乃至识亦如是。又经中说。灭应证若无法何所证。又佛于多性经中说。智者如实知有为性及无为性。无为性即是泥洹。以真智知云何言无。又诸经中无有定说泥洹无法。故知汝自忆想分别谓无泥洹。答曰。若离诸阴更有异法名泥洹者。则不应名诸阴尽灭以为泥洹。又若有泥洹。应说其体。何者是耶。又缘泥洹。定名曰无相。若法相犹存者何名无相。如经中说。行者见色相断乃至见法相断。又经中处处说。一切行无常一切法无我寂灭泥洹。是中我名诸法体性。若不见诸法体性名见无我者。若泥洹是法则无体性不可得见。以此法不灭故。如随有瓶时无瓶坏法。若瓶坏时得说瓶坏。断树等亦如是。如是若诸行犹在尔时不名泥洹。诸行灭故有泥洹名。又苦灭不名更有别法。如经中说。诸比丘若此苦灭余苦不生。更无相续。是处第一寂灭安隐。所谓舍离一切身心贪爱永尽离灭。泥洹是中言此苦灭余苦不生。更有何法名泥洹耶。又亦更无别有尽法。但已生爱灭未生不生。尔时名尽。更有何法说名尽耶。实不可说。复次有是法之异名。五阴法无名为泥洹。是中无有而名为有。此则不可。以尽灭故说名泥洹。犹如衣尽更无别法。若不尔者亦应别有衣尽等法。汝言有灭智者亦无所妨。如于断树等中智生亦无别有断法。又由诸行故是中智生。谓随诸行无名为泥洹。如随无此物知此物空。问曰。今无泥洹耶。答曰。非无泥洹。但无实法。若无泥洹则常处生死永无脱期。如有瓶坏树断。但非实有别法。言余谛等皆已通答。所以者何。有苦灭故说有不生不起不作无为法等。悉无所害。无诤智者。随以何智不与他诤此名无诤。有人言慈心是也。以慈心故不恼众生。复有人言。空行是也。以此空行不与物诤。又有人言乐泥洹心是。以乐泥洹故无所诤。有人言。在第四禅此不必尔。是阿罗汉以此智修心皆无所诤。愿智者。于诸法中无障碍智名为愿智。问曰。若尔者唯佛世尊独有此智。答曰。如是。唯佛世尊具足此智。余人随力所及得无障碍。边际智者。随行者得最上智。以一切禅定勋修增长。若于增损寿命等中得自在力。名边际智

    六通智品第一百九十七

有六通智。六通者。身通天眼天耳他心智宿命漏尽。身通名行者身出水火。飞腾隐显摩扪日月。至梵自在及种种变化。如是等业名为身通。问曰。此事云何当成。答曰。行者深修禅定故得。如经中说禅定者力不可思议。有人言。变化心是无记。此事不然。若此行者为利他故种种现变。何故名无记耶。有人言。以欲界心作欲界变化。色界心作色界变化。此亦不然。眼等亦应如是。可以欲界识见欲界色耶。如是等若色界心作欲界变化有何咎。又人言。初禅神通能至梵世。乃至四禅神通能到色究竟是亦不然。随根力所及。若利根者以初禅神通能到四禅。钝根者以二禅神通不能用初禅。如大梵王到禅中间。是中无神通以初禅力能到诸余梵天。即以初禅不能知梵王住处。又佛以宿命忆念无色。如经中说。若色无色中先所生处佛悉知之。是故不定又人言。天眼是慧性。此事不然。天眼由光明成慧不如是。问曰。经中说。修光明相能成知见。知见即是天眼。答曰。不然。亦说天耳不以慧性名之为耳故非慧也。又天眼缘现在色。意识不尔。有解天眼中说知众生业报。眼识无有此力。但意识中知用眼识时生故。知从禅定生色名为天眼。问曰。天眼形处大小。答曰。如童子量。又问。盲人云何。答曰。亦齐眼处。又问。天眼为一为二。答曰。是二。又问。随见所向方耶。答曰。遍见诸方。又问。化人有耶。答曰无。造化者有天耳论亦如是。行者若知他心名他心智。问曰。何故不说知他心数。答曰。以此因缘故无别有心数知他受想等亦名他心智。又人言。此智同性缘。如以有漏。知有漏无漏知无漏。是事不然。此人不说决定因缘。以此因缘知同性缘。有人言。但缘现在此亦不然。或缘未来如人入无觉定。知从此定起。当觉如是如是事。有人言。此智不知见谛道。是事不然。若知何咎耶。有说辟支佛欲知见谛道中第三心。即见第七心。声闻欲知第三心。即见第十六心。此不名知见谛道耶。又人言。此智不知上地上人上根。是亦不定。诸天亦知佛心。如佛一时深摈众僧还念欲取梵王悉知。又于一时心念。为王如法化世。魔王即知而来劝请。又诸天亦知此是罗汉乃至此是行须陀洹。又诸比丘亦知佛心。如佛将泥洹时阿那律次第知佛所入诸禅定。又人言。此智不知无色。是亦不然。佛以宿命能知无色。他心智亦如是。知有何咎耶。问曰。云何知他心。答曰。于缘中知。若心行色名缘色心如是等。问曰。若尔则他心智缘一切法。答曰。如是若不知缘。云何知心。如经中说。我知汝心如是如是即是缘色等知他心。三种。一相知。二报得。三修得。相知者。知以鸯伽咒等故知。报得者。如鬼神等。修得者。谓禅定力得他心智。此六通中说。修得者若忆过去世中诸阴名宿命智。问曰。为忆何阴。答曰。忆自阴他阴及非众生阴。唯不能忆胜者诸阴。能忆胜者戒等诸法。何以知之。如舍利弗答世尊言。我虽不知去来佛心能知其法。又净居天知佛心故来白佛言。如是世尊过去诸佛威仪亦尔。问曰。解宿命中何故说共相共性。答曰。忆念明了故如是说相名字。如某人等。又以识事故名为相性名种族。如言此是汝家此是汝性。相性合说。故知见明了。问曰。何故为明了忆。答曰。过去法尽灭无相而能得知。此为奇特。有人以思量相知。不能明了。谓佛弟子亦复如是。是故性相合说。有人用宿命智。或以有道思慧知过去世。如行缘识。此二种中思慧为胜。所以者何。是人虽知八万大劫。无此思慧故生邪见。谓从此来名为生死。过此更无有道思慧。终无此心。有人言。此智次第忆念过去是事不然。若念念次第忆。一劫中事尚难知尽。况无量劫。问曰。经中何故说。我于九十一劫已来。未见布施损而无报。答曰。佛于此中以七佛为证。亦有长寿净居与佛同见。又佛得真智故功德清净。若人供养得二世福。故齐此说。有人言此智不知上地。是事不然。上身通等中已答。问曰。若是忆性何故名智。答曰。忆随相生。过去无相而能忆念。当知胜慧名之为忆。忆宿命有三种。一用宿命智。二报得。三生便自忆宿命智。名修得报得者如鬼神等。生便自忆谓人道中。问曰。以何业故生便自忆。答曰。以不恼众生此业能得。所以者何。死时生时苦切逼故忘失忆念。此中难得不失故须善业。又人言。此忆过去极至七世。是事不定。有人世世深修不恼法。故能忆念久远。证漏尽智通者金刚三昧是也。金刚三昧是漏尽。无碍道漏尽智名无学智。以金刚三昧灭尽诸漏。名证漏尽智通。问曰。余神通亦应说以何法证。答曰。先已说深修禅定证神足通。又随所用证及所证事皆名神通。有人言。一切圣道皆是漏尽方便。如经中说。若佛出世若人闻法出家。奉戒除舍五盖修定见谛。此等皆名漏尽方便。又人言。施等善法亦名漏尽因缘。如经中说。行者布施助成漏尽空无我智。是名真证漏尽智通。此法别名金刚三昧。能破诸相故曰金刚。诸外道人但名五通。皆以不得此真智故。问曰。以无我智应破我见。云何以此断贪恚等。答曰。无我智能灭诸相。以无相故诸烦恼灭。问曰。以初无我智能坏诸相。第二智等更何所用。答曰。诸相虽灭还生。是故须第二等。问曰。若灭已还生相则无边。然则无阿罗汉道。答曰。有边如今现见乳灭还生。有时乳灭。酪生是则为边相亦如是又如烧铁黑相灭还更生至赤相生。尔时名边。迦罗逻等诸喻亦如是。随于何时诸相灭尽更无相生。尔时名得阿罗汉道。问曰。阿罗汉都无诸相耶。答曰。若在不定心中尔时亦有色等诸相。但不生过。若人眼见色以邪心邪分别。尔时相能生过。问曰。何者是。空无我智。答曰。若行者于五阴中不见假名众生。以法空故见色体灭乃至识灭。是名空无我智。问曰。假令诸法常在。爱等烦恼亦可除尽。如说万物常在而精进者能除贪爱。何须灭相。答曰。经中说。所有生相皆知灭相。于诸法中得法眼净。若以灭断名毕竟断。有行者离诸色欲遮灭贪恚。佛为此故说如是偈。又说诸行性空如幻。凡夫无智谓之实有。学人了知虚诳如幻。阿罗汉亦不见幻。故知随以何慧证诸法灭。是名证漏尽智通

    忍智品第一百九十八

问曰。经中说。若行者有七方便三种观义。于此法中速得漏尽。是何智耶。答曰。七方便名闻慧思慧。所以者何。心未定者作如是观。谓此是色色集色灭。及色灭道色味过出。问曰。若是闻思慧者。何故言速得漏尽。答曰虽是闻慧思慧。如是分别五阴。能破我心。故说速得漏尽。三种观智。谓观有为法无常苦无我。若以阴界入门观有为法则无义利。问曰。若尔者前过中已说无常苦。出中已说无我。何故复说此三种观耶。答曰。习学三种。先闻思慧然后修慧。先于闻思慧中说七种。后修慧中说三种。所以者何。若无常苦坏相名坏无常。非行无常。虽说除欲染不说云何除。后乃说三种观义。问曰。何谓八忍。答曰。若智能破假名是名为忍。是忍在暖顶忍世间第一法中。问曰。行者亦于佛法僧及戒等中忍。何故但说八耶。答曰。以胜故说。胜名近道。此慧为智。故名为忍。如为苦法智名苦法忍。如是等。所以者何。先用顺道思慧。后得现智。如牧象人先观象迹。以比智知在此中。后则现见。行者亦尔。先以忍比知思量泥洹。然后以智现见。故经中说。知者见者能得漏尽

    九智品第一百九十九

问曰。有论师言。阿罗汉证尽智时得世俗九智。谓欲界系善无记。乃至非想非非想处善无记。是事云何。答曰。非一切阿罗汉尽得诸禅定。云何当得九智。问曰。一切阿罗汉皆得禅定。但非一切皆能现入。答曰。若不能现入。云何名得。如人言知书而不识一字。是事亦尔。问曰。若人离欲而未能现入初禅。是人命终不生彼耶。答曰。经中说先此间入后当生彼。今云何此间不入而能生彼。问曰。若离欲时过去未来诸禅皆本得。得以此报生。答曰。未来业无作无起不应得报。过去诸禅曾于心生。若与果报则无所害。又不应得未来诸业。若可得者。一切未来皆应可得。以何障故有得不得。问曰。若未来法不可得者。学人不应八分成就。无学不应十分成就。所以者何。若依第二禅等入正法位。是人未来得正思惟。又若行者尽智现前。尔时未来得世正见。又人依无色定得罗汉果。是人未来得正思惟正语正业正命。又若人依第三禅等得圣道得未来喜。如是等法则应皆无故。知有未来法。又若无未来修者。云何当得诸果诸禅定等。行者若在道比智中。悉得初果所摄诸智诸定。若不尔果等应数数得。所以者何。诸果皆应现前时得。是事不可。故知应有未来中修。答曰。汝说无诸分者。此无所妨。所以者何。我说戒等诸分以次第得非一时得。故非难也。汝言诸得得其种类。行者得苦智时余苦智种皆名为得。如得人种故名得人相。亦不名于念念中渐得人相。是事亦尔。问曰。行者所有苦等诸智次第得者。皆已舍离。更一时得须陀洹果所摄诸智。答曰。无漏诸智。得则不失。问曰。若先得不失。则得行无别。所以者何。得果者即是行者。有此等过。答曰。若无差别有何咎耶。如成就果者亦名行者。此亦如是。又是人更得胜法故有差别。是故无过。如受五戒者更得出家律仪亦不失本戒。又得果者。不以见道故有差别。如人虽知初事更以胜事故有差别。此事亦尔。故知无未来得。又行者住空无我智。尔时云何得世间法。故知得尽智时不得世智。问曰此诸世智共尽智。得与阿罗汉作入出定心。答曰。阿罗汉心相续生。念念皆净。若更得九智眼等皆应更得。若不尔不应但得九智。又说。未来修者。皆无因缘。所以者何。此等说见谛道中。但修相似智。思惟道中亦修相似及不相似。见谛道中不修上地。思惟道中修。道比智中不修世俗善。余智中修。无碍道中不修他心智。信解脱转为见到时。一切无碍解脱道中不修世俗道。时解脱转为不坏解脱时。九无碍八解脱道中不修世俗道。第九解脱道中修。微细心中不修一切无漏。如是等皆无因缘。是故汝今若说正因。若应信受。若以学习为修。在暖等中时。上诸善根一切皆修。以悉增益故。如诵习经书则皆明利。是故在暖等法时乃至尽智一切皆修。若不尔当说正因

    十智品第二百

十智。法智比智他心智名字智四谛智尽智无生智。知现在法是名法智。如经中说。佛告阿难。汝于此法如是见知如是通达。过去未来亦如是知。应言现法智。今不说现故但说法智。如经中说。愚者贵现在法智者贵未来。又说。现在诸欲未来诸欲。皆是魔网魔系魔缚。如是等中皆说现语。略现语故但说法智。知余残法名曰比智。余谓过去未来诸法。次现法后知故名比智。所以者何。先现知已然后比知。法智名现智。随此法智思量比知名为比智。问曰。此智是无漏智。无漏智云何名比智。答曰。世间亦有比智。所以者何。法智比智他心智苦智集智灭智道智皆有有漏无漏。是诸智在暖等法中是有漏。入法位中所得名无漏问曰。有人言。知欲界诸行诸行集诸行灭诸行灭道名为法智。知色无色界诸行四种名为比智。是事云何。答曰。经中说。佛告阿难。过去未来世中亦如是知。无有经说色无色界诸行中知名为比智。又经中说。行者应念。我今为现色之所侵食。过去亦曾为色之所侵食。未来中色亦当侵食。又经中说。生缘老死去来世中亦复如是。如马鸣菩萨说偈。如现在火热去来火亦热。现在五阴苦去来阴亦苦。如是等苦。诸大论师亦如是说。又知过去未来世法名为比智。亦有道理。所以者何。行者于去来现在苦中厌离。厌离名于此法中生真智慧。如现在行苦。去来诸行亦如是苦。今以何智知去来法。若是法智色无色界诸行亦有去来。于彼中知亦应名法智。然则唯是法智无比智也。若色无色界去来行中别有智者。欲界去来行中亦应别更有智。以此义故诸论师言。有得未得故次第见谛。欲界苦名得。色无色界苦名未得。是故不可一时并知。若未得苦以比智知。今欲界中所未得苦。亦应以比智知。问曰。以何智为断结道。答曰。但用法智比智在方便道中。问曰。用何法智。答曰。用苦法智灭法智。所以者何行者观无常苦时见空无我。尔时证诸行灭。余智皆是方便。问曰。观何苦灭。答曰。观诸受苦。此中能生我心。亦于此中见灭。如说。内解脱故诸爱尽灭自说得阿罗汉。问曰。经中不说一切行断名断性耶。答曰。此行者证内灭故一切厌离。又行者必当应证内灭余不必定。问曰。于诸谛中。云何生智。答曰。知生苦等。问曰。此非定心何能生智。答曰。有如是观亦有见阴无常等过生苦无我想。如经中说。若法无常即是无我。所以者何。眼等诸根有生有灭。若是我者我即生灭。故知非我。是眼等生时无所从来。以有所作故名为我。而经中说无有作者。故知若法无常即是无我。如是行者善修无常及无我。故身心寂灭所有行生。皆觉其恼则生苦想。如无皮牛小触觉痛。行者如是。以无我想故。成上苦想。愚者以我想故。虽有大苦不觉其恼。是名苦智。见诸行生是名集智。见诸行灭是名灭智。念道始终是名道智。问曰。何谓尽智。答曰。尽一切相故名尽智。所以者何。学人相断还生。此毕竟断故名尽智。如经中说。若知妄想唯是妄想诸苦则尽学人智但妄想是我。此心永断名为尽智。如经中说。阿罗汉于佛前自记世尊所说诸结我无此也。我于是结不复生疑。我常一心摄念正行。贪等不善不漏于心。是中取相故生诸结。诸相断故诸结则灭。学人行于相无相。故我心时发。如见杌树疑谓是人。故阿罗汉独得无疑。以心常行无相中故先以生空。于五阴中不见神我。后以法空不见色性乃至识性。故知一切相尽名为尽智。知诸相不生名无生智。学人断相尽已更生。无学相尽更不复生。若能令诸相尽灭更不复生。尔时名无生智。问曰。学人亦知有尽智无生智。如念我三结尽更不复生。何故不说十分成就。答曰。学人不能断一切相。故不说有尽智无生智。如人处处系缚虽一处解不名得脱。亦有此义。舍利弗说给孤独氏十分成就。又阿罗汉得自在力故。自知结尽更不复生。学人不尔。又阿罗汉得无学道时。自知一切生尽名为尽智。梵行成者。谓舍诸学行。所作办者。谓诸所应作皆已作讫。知从此身更无相续。故知但阿罗汉于一切所作。应得自在成就尽智及无生智。非诸学人。如人疟病虽不发时亦不名为差。如经中说。离一切处喜灭一切处忧。证一切法灭常行无漏心。他心智如六通中说。五阴和合假名众生。此等中智名名字智。无漏智名真实智。此似无漏得名为智。故曰名字智。问曰。又人言。一切众生成就等智。是事云何。答曰。若佛弟子能知诸法从众缘生。是人能得非余众生。以得智名故。一切众生但用想识。若得此智名内凡夫

    四十四智品第二百一

问曰。经中说四十四智。谓老死智老死集智老死灭智老死灭道智。生有取爱受触六入名色识行亦如是。何故说此。答曰。泥洹是真法宝。以种种门入。有以五阴门入。或观界入因缘诸谛如是等门。皆至泥洹。何以知之。如经中说。王处城中有双使来。从一门入到已向王说其事实。语已还去。诸门亦尔。此中王喻行者。诸门谓观阴界入等。双使如止观。说其事实谓通达空。是诸使虽从诸门。入皆到一处。如是虽观阴界入等诸门方便。皆入泥洹。如罗睺罗说。于独屏处思惟法时。知如是法皆随顺趣向称赞泥洹。又佛于赞法中说。是法能灭诸烦恼火故名为灭。能令行者心得安隐故名安隐。能令行者到正遍知故名为至。如是等义皆赞泥洹。又梵行名八圣道。八圣道中正智为上。是正智果所谓泥洹。又佛所说教皆为泥洹。故知五阴等门皆至泥洹。问曰。有论师言。老死智名苦智。是事云何。答曰。非也。所以者何。是中不说苦行故非苦智。问曰。为是何智。答曰。此名老死性智。问曰。亦说知老死集老死灭老死灭道。故知应是苦智。答曰。此是因缘门非真谛门。是故此中不应说苦行。应说集等以相顺故。问曰。此中何故不说味过出等诸智耶。答曰。此义皆摄。但集经者略而不说

    七十七智品第二百二

问曰。经中说七十七智。谓生缘老死不离生有老死。过去未来世中亦如是。是法住智观无常有为作起从众缘生。尽相坏相离相灭相亦如是观。乃至无明缘行亦如是。是中何故不说老死性及灭道等耶。答曰。为利智者故如是说。但开其门可知。余亦如是。又外道多于因缘中谬说世间万物因世性等。故佛于此但说因缘。问曰。已说生缘老死。何故更说不离。答曰。为必定故诸法中有不定因。如施为福因亦以持戒得福。如说持戒得生天上。或有生念老死因生或不因生故须定说。问曰。何故去来世中复须定说。答曰。现在与过去世或有异相。谓过去众生寿命无量势同诸天。如是等。恐人谓寿命等异老死因缘亦当有异。故须定说。未来亦尔。此六种名法住智。余名泥洹智。能令老死相续。故说无常有为作起从众缘生。尽相坏相即是无常行。离相即是苦行。灭相即是空无我行。所以者何。此中色性灭受想行识性灭。是名三种观义。如经中说比丘有七处方便三种观义速得漏尽皆是为泥洹智。如是等因缘智有百千无量。谓眼智等如经中说。眼缘业业缘爱。爱缘无明无明缘邪念。邪念缘眼色诸漏缘邪念。诸食缘爱五欲缘揣食等。地狱短命缘杀生等。若今苦先苦皆缘妄想。妄想缘身心憎爱。憎爱缘贪欲。贪欲缘邪思惟。如是等诸因缘智无量无边。自应当知

成实论卷第十六


大乘宝要义论卷

    No. 1635

大乘宝要义论卷第一

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

  归命十方无边际　　所住一切世界中
  过未现在诸如来　　菩萨声闻缘觉等

智者当知。人身难得。于刹那间。成诸胜行亦复为难。若于此中不起思惟作利益事。此生虚来。云何能于如来清净言教。发勤勇心领纳听受。此有二事。谓人身难得。正法难闻。值佛出世复甚为难

问此中以何而为印证值佛甚难。答无数经中皆作是说。斯为定量。且依妙法莲华经云。佛言。诸苾刍。如来应供正等正觉。经于百千俱胝那庾多劫。如是等旷远世时。或有或无。如来出世斯为甚难。如优昙华时一现尔。决定王经云。佛言。阿难。诸佛出世。彼优昙华。俱时而现。其华如金有净妙光。开敷异香遍由旬内。是华光明能破冥暗。能令念者即得清净。能息病苦。能作明照。能去恶香。能施妙香。彼香能息四界增损。其华亦非随转轮王遍处皆出。唯金轮王乃可应现。况复破戒诸有情类。唯佛出世是华俱出。此中云何能知彼优昙华于旷远时或有或无。如有缘起中说。无热恼大池北面有山名五峰。而彼山上有优昙华林。若佛世尊从兜率天宫没降生人间入母胎时。彼优昙华而方含蕊。若佛世尊出母胎时。是华增长有开敷相。若佛世尊成阿耨多罗三藐三菩提果时。彼优昙华开敷茂盛。若佛世尊弃舍寿命及缘行时。是华萎瘁。若佛世尊入涅槃时。是华枝叶及以华果。皆悉凋落。其华分量大若车轮。觉智方广经云。大名称仙王谓诸仙众言。诸仁者。若菩萨暂时得值如来出世说法化利。是即相应。华严经云。于俱胝劫中值佛出世。听受正法尊重信奉。此真实见甚为难得。贤劫经云。此贤劫后六十五劫无佛出世。其后有劫号大名称。彼一劫中有十千佛出现于世。大名称劫后八十千劫无佛出世。其后有劫号曰星喻。彼一劫中有八十千佛出现于世。星喻劫后经三百劫无佛出世。其后有劫名功德庄严。彼一劫中有八万四千佛出现于世

此中问言。云何能知人身难得。答诸契经中皆作是说。如杂阿含经云。佛言。诸苾刍。譬如大地流水充满有人取木开一孔穴置于水中。是木轻浮随风飘流。东风西向西风东向。南北所吹亦复如是。有一眼龟居其水内寿命无数百岁。凡经百岁自水一浮投木孔中。诸苾刍。于汝意云何。彼一眼龟如是寿极长远。百岁一浮可能得值浮木孔邪。诸苾刍言。不也世尊。佛言。诸苾刍。值佛出世说法化度觉了正道得至涅槃亦复如是。斯极为难。或得人身时分具足又复为难

此中问言。云何能知时分具足而难得邪。答诸契经中作如是说。如增一阿含经云。佛言。诸苾刍。有八种难。不知时人不应修梵行。何等为八。若佛出世时宣说法要。化度有情使至涅槃。而一类有情在地狱中。此为第一修梵行者时分之难。若佛出世时宣说法要。化度有情使至涅槃。而一类有情在畜生中。此为第二修梵行者时分之难。若佛出世时宣说法要。化度有情使至涅槃。而一类有情在饿鬼中。此为第三修梵行者时分之难。若佛出世时宣说法要。化度有情使至涅槃。而一类有情在长寿天。此为第四修梵行者时分之难。若佛出世时宣说法要。化度有情使至涅槃。而一类有情在于边恶恚害之处。此为第五修梵行者时分之难。若佛出世时宣说法要。化度有情使至涅槃。而一类有情虽生中国。或聋或哑根不完具。善说恶说不知其义。此为第六修梵行者时分之难。若佛出世时宣说法要。化度有情使至涅槃。而一类有情生于中国。不聋不哑六根完具。善说恶说而悉能知。然起邪见颠倒计执。谓无施无利亦无事火。无善作恶作诸业果报。无此世无他世。无父无母。无世间沙门婆罗门。无正趣正道。无阿罗汉智解于此世他世以自通力而证圣果。此为第七修梵行者时分之难。或复一类有情生于中国。不聋不哑六根完具。善说恶说而悉能知。又复正见无颠倒计执。谓有施有利乃至有阿罗汉取证圣果。然佛不出世不说法要。此为第八修梵行者时分之难。诸苾刍。当知有一种时分和合应修梵行。谓佛出世宣说法要。初善中善后善。文义深远纯一无杂。具足清白梵行之相。而一类有情生于中国。不聋不哑六根完具。善说恶说而悉能知。正见具足不起颠倒计执。谓有施有利亦有事火。有善作恶作诸业果报。有此世有他世。有父有母。有世间沙门婆罗门。有正趣正道。有阿罗汉智解于此世他世以自通力而证圣果。是为一种时分和合。大集经月藏品云。诸仁者。时分和合如应时香树。极为难得

此中应问。彼作是说。得人身者云何能得清净平等清净所说。答有十种功德。若能圆满。彼得人身清净平等。何等为十。如超越下族经云。一者若善男子善女人内发菩提心已即生净信。二者广多清净欲见圣贤。三者乐闻正法。四者不生悭嫉普行大施。五者端身系念乐涅槃道。六者以无碍心善心广施。七者信有诸业及诸业报。八者不起分别。九者无求无疑亦无染慧。十者不坏善恶业果。如是十种若了知已。于此命缘诸恶莫作。此中应问。何名为信。答信者谓顺向圣贤诸恶莫作。如破染慧经云。诸善法中信为先导。是中信者何义。谓信顺义。此能具足如来无障碍智。而能宣说难见难知甚深正法。永断爱缠。谓无眼无眼灭。无耳鼻舌身意无耳鼻舌身意灭。无住非无住。无意乐非无意乐。具六十种音声文句。次第语业清净洁白。其身极净。其心现种种色相。而佛如来无所不知无所不见。无不成证无不觉了。如来以清净眼及如来普眼。永断过失远离贪爱。破诸痴瞑过于肉眼。而能观照甚深顶相。宣说无上第一义谛。一切佛法虽复分别。如是佛法而不谤缘起。此名为信。信力入印法门经云。佛言。妙吉祥。何名信力。谓于一切佛法现前印顺。信解无疑亦无异求。决定实信业及业报。信心无杂。于空无相无愿所作诸行及一切法皆生净信。谓布施有布施果。持戒持戒果。忍辱忍辱果。精进精进果。禅定禅定果。智慧智慧果。彼如是说是清净相。于大乘胜解中能生净信。此说名为信力。若复觉了诸着。是名信根。若根若力。总说名信。又复此中何名信力。信谓印顺。能信他声。云何修菩萨者信他声邪。所谓闻他教示发菩提心修菩萨行。菩萨依止波罗蜜多。善巧方便及四摄法。一切佛法菩萨法等声。从他闻已极生净信。此说名为信力。菩萨藏经云。佛言。舍利子。此修菩萨行者。内发菩提心已即生净信。广多清净欲见圣贤乐闻正法。决定信有诸业及业果报。断十不善业修十善业。信有沙门婆罗门及正趣正道而复多闻。所闻相应心意和合。超越疑惑不受后有。于诸佛菩萨及声闻等真善知识。常所亲近起爱重心。信彼善知识所说诸业及业果报。知其器已如应为说甚深言论。谓空无相无愿无行无生无起之论。无我无人无有情无寿者之论。及缘生论。是诸言论闻已无疑。亦复无执。随入一切法蕴处界等。悉应无著。信一切法自性皆空。以佛智推求纯一不放逸。何名不放逸。谓若诸根起散乱时。应自心调伏他心随护。月光菩萨经云。若诸有情于三宝中起净信心。而实难得。譬彼如意珠宝求得亦难。入如来功德智不思议境界经云。圣除盖障菩萨白妙吉祥菩萨言。有五种法。诸菩萨摩诃萨当生胜解。若此若彼阿僧祇最胜功德而悉获得。何等为五。一者一切法空。二者一切法无对治。三者一切法无生。四者一切法无灭。五者一切法不可记说。如是五种当生胜解。如阎浮提地过微尘等数诸威仪道及作用处。如来悉无发悟亦无分别。然随众生心意。若时非时一切常转。诸菩萨摩诃萨于此当生胜解。星贺骚那儞缘起经云。世尊释迦牟尼如来。为化度有情作利益故。于殑伽沙数劫中历修诸行现成正觉。诸菩萨摩诃萨于此应生信解。又世尊释迦牟尼如来。于燃灯佛所得授记别。于其中间历修胜行。遍入诸佛境界。经无边际劫。乃至于今现成正觉。于此应生信解。又世尊释迦牟尼如来。见杀释种因缘为化度有情作利益故。经无边际劫历修胜行现成正觉。于此应生信解。是故当知。一切有情若发菩提心。此为难得

问发菩提心实为难得。此复云何得发起邪。答多有经说。且依华严经云。世间有情若发阿耨多罗三藐三菩提心。实为难得。当知菩提心如世间种子。以世间一切善法悉种植故。如一切佛法境界。一切恶作能尽烧故。犹如劫火。一切不善法能销坏故。犹如大地。一切义能成就故。如摩尼宝王。一切意乐悉圆满故。犹如贤瓶。拔出生死流故。如胜钩饵。一切世间天人阿修罗乃至一切佛法一切佛功德。皆悉称赞彼菩提心功德故。如佛塔庙。何以故。此中具有诸菩萨行胜境界故。又复此菩提心出生过去未来现在一切诸佛。善男子。譬如有药名铁金光。是药一两能化铁千两悉使成金。非彼千两铁而能坏此一两圣药。发菩提心者亦复如是。若能一发。一切智心微妙圣药善根回向智所摄受。能令一切业烦恼障悉成一切法一切智金。非彼一切业烦恼障而能染污一切智心。善男子。又如秉一灯炬入于暗室。随入室中彼百千年积集暗瞑。皆悉破灭洞然明照。发菩提心亦复如是。秉一切智心大光明炬。入于有情心意暗室。随入其中彼不可说百千劫已来积集一切业烦恼障。无明黑暗皆悉销除。以大智光出生明照。善男子。又如大龙王顶大如意妙宝王冠。不为他怨敢来侵怖。诸菩萨摩诃萨亦复如是。顶菩提心及大悲心妙宝王冠。不为一切恶趣诸恶敢来侵怖。又如日月净圆光中极所照曜。是中应现所有一切金银珍宝华鬘衣服胜妙乐具。总集彼等一切所有。皆不能与如意宝王等其价直。发菩提心亦复如是。极尽三世一切智智法界道场随所照曜。是中应现一切有情一切天人及彼一切声闻缘觉。若有漏若无漏。一切善根。皆不能与发菩提心自在宝王等其价直。又如牛羊之乳满大海中。若师子乳足迹之滴堕海中时。牛羊诸乳不能凝结亦不和合。菩提心亦复如是。不可说百千劫积集诸业烦恼。其犹大海。如来大丈夫师子发一切智心一滴之乳堕海中时。诸业烦恼永尽无余。所有一切声闻缘觉解脱亦不和合。又如亲近勇猛之人一切怨恶不能侵害。发菩提心者亦复如是。若亲近勇猛菩萨一切恶作之怨不能侵害。又如残缺金刚之宝。虽有所损于众宝中亦复最胜。而能出过诸庄严具。彼金刚宝名亦不殒灭。普能拯济诸有贫乏。少分菩提心亦复如是。其犹残缺金刚之宝。虽未圆具。而亦出过一切声闻缘觉功德庄严。彼菩萨名亦不殒灭。能济贫乏无圣财者。胜军王问经云。佛言。大王。善哉善哉。汝能于佛法中爱乐希求。如汝大王。现今治化憍萨罗国。利益安乐一切人民。救拔济度安慰接引使归正道。而汝若能广利一切有情。令发一切智心圆满一切佛法趣证阿耨多罗三藐三菩提道。斯复大利。又复大王。彼只陀林常有无数百千圣贤。隐居其中生尊重想。大王。彼诸圣贤于正等觉有所乐欲有信有求有愿有称赞生随喜心。是诸圣贤若身语意极生信重。何以故。大王。而彼地方有无数百佛出现。无数百转法轮。无数百圣众相续得度。如是乃至无数百千俱胝那庾多殑伽沙数诸佛出现。转正法轮化度圣众。如是彼诸圣贤。皆悉发生菩提乐欲信求愿等

大乘宝要义论卷第一大乘宝要义论卷第二

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

阿阇世王经云。尊者大迦叶白妙吉祥菩萨言譬如初生师子随生即有力势。凡所向诣或有群鹿。才闻师子之香。皆悉奔窜。设使大力龙象若闻师子香时。逼恼惊怖。掣拽锁缚。锁缚断已奔驰四向。山岩地穴遍求隐匿。水族飞禽闻师子香亦悉惊怖。妙吉祥。若诸菩萨具慧力者亦复如是。彼初发心菩萨才发大菩提心。即能胜过一切声闻缘觉。魔宫震动。一切天魔咸生恐栗。以恐栗故而悉不能安止其宫。宝积经云。佛言。阿难。于汝意云何。譬若有人双断手足。能活命不。阿难答言。手足虽断其命尚活。佛言。阿难。若或有人剖裂其心。是人能活命不。阿难答言。不也世尊。佛言。阿难汝应当知。我之弟子大目干连及舍利子犹如手足。而诸菩萨其犹我心。阿难。若有菩萨。御大宝车。以五欲功德作神通游戏。而无有人为其驾御。如来尔时为彼菩萨。力御其车以进前道。若舍利子及目干连修三解脱门。若经一劫若过一劫。如来不复与其勤力而为策进。父子合集经云。诸苾刍。所有殑伽沙数等诸如来。于殑伽沙数等劫中。称赞彼发一切智相应心者诸功德藏。说不能尽。何以故。如来往昔修菩萨行。曾无暂时不发是心。一切有情悉皆摄受。随摄受已于诸有情亦复不起所化度想。所有无量诸有情界。如来遍是有情界中。历修菩萨广大胜行。一一发心集诸福蕴。所以者何。诸苾刍。有情界无尽。以有情界无尽故。如来广修菩萨胜行。一一发心集诸福蕴亦复无尽。如来秘密经云。若诸菩萨发菩提心修胜行者。令三宝种不断不绝。又云。菩萨菩提心所生福蕴。悉用回向一切有情。如是回向功德满虚空界。而复过上。彼一切有情福蕴所摄。悉由菩萨菩提心转。法集经云。菩萨发菩提心觉悟一切法。知一切法与法界等。而一切法无所从来。及无所止。亦不可知。然以如量智知法性空。令一切有情亦如是觉了。菩萨若如是发心。此说是为菩萨。菩提心。利乐一切有情心。无上心。大慈柔软心。大悲无倦心。大喜不退心。大舍无垢心。空无异作心。无相寂静心。无愿无住心

此中应问。云何以少善根回向一切智。乃至坐菩提场。于其中间而不尽邪。答如无尽意经云。佛告尊者舍利子言。譬如一滴水入大海中乃至穷劫。于其中间而不能尽。菩萨以少善根回向一切智亦复如是。乃至坐菩提场。于其中间亦不能尽。善巧方便经云。或有菩萨见贫穷者。起悲愍心施以少饭。如佛所说。此心广大名最上施。何况诸所施法。其施虽少而。一切智心功德无量。贤劫经云。星王如来于声授如来所。初发菩提心。彼星王如来昔为牧牛人。以末俱罗华供施因缘从是发心。名称如来于电光如来所。初发菩提心。彼名称如来昔为织师。以妙[疊*毛]边缕供施因缘从是发心。明焰如来于无边光如来所。初发菩提心。彼明焰如来昔为守城人。以一草灯供施因缘从是发心。难胜如来于坚固步如来所。初发菩提心。彼难胜如来昔为樵人。以齿木供施因缘从是发心。功德幢如来于妙称如来所。初发菩提心。彼功德幢如来昔为汲水人。以盛水器供施因缘从是发心。力军如来于大臂如来所。初发菩提心。彼力军如来昔为医王。以一庵摩勒果供施因缘从是发心。宝积经云。若或有人为求阿罗汉果故。以摩尼宝充满无边世界而行布施。有菩萨乘人见已发一切智相应随喜心。而此相应随喜所有福蕴。比前布施福蕴。百分不及一。乃至乌波尼杀昙分亦不及一

问云何菩萨而能胜出彼前布施。答以回向一切智故。如般若波罗蜜多经云。佛言。舍利子。菩萨摩诃萨若欲胜出一切声闻缘觉所修布施持戒忍辱精进禅定智慧者。应当一发一切智相应随喜心。修学般若波罗蜜多。以大悲心而为先导。而诸菩萨然后发菩提心。是故当知。大菩提心者大悲为先导。此何能知邪。如菩萨藏经云。若诸菩萨欲求菩提应以大悲而为先导。譬如士夫所有命根以出入息而为先导。诸菩萨摩诃萨亦复如是。于所集大乘法中以大悲心而为先导。又如转轮圣王于诸宝中以其轮宝而为先导。菩萨摩诃萨亦复如是。于一切佛法中以大悲心而为先导。又云。诸菩萨于己过失常行伺察。于他过失悲心护念。无畏授所问大乘经云。佛言。长者。若诸菩萨为欲成就大菩提者。当于一切有情起大悲心。于自身命不生爱着。乃至一切财谷舍宅妻子饮食衣服乘舆床座香华涂香等一切乐具。悉不应着。何以故。长者。多诸有情于身命等皆生爱着。以爱着故广造罪业堕恶趣中。若复有情起大悲已。于身命等不生爱着。以不着故生于善趣。复能于彼一切有情。运心广行布施等行。一切善法相应而作。修菩萨者以大悲心而成其身。此云何知。如宝云经云。佛言。善男子。若诸菩萨具十法者。是为大悲所成其身。何等为十。一者见一切有情为苦逼迫无救无依无归趣者。见已应发大菩提心为作依怙。二者发菩提心已令彼有情得法成就。三者随所得法为诸有情作大利益。四者悭吝有情令住布施。五者若毁禁戒令修净戒。六者若多忿恚令住忍辱。七者若多懈怠令发精进。八者若多散乱令修静虑。九者诸无智慧令得胜慧。十者一切有情极苦所逼。菩萨普为息除令于菩提不为障难。如是名为十法。总持自在王问经云。菩萨或见一类有情贪爱所缠。于自妻子眷属而生耽染。以爱缠故不得自在。菩萨如应为说法要。令解爱缠使得自在。菩萨为诸有情起大悲心故。或见一类有情起忿恚心互相违损生多过失。菩萨如应为说法要。使令断除忿恚过失。菩萨为诸有情起大悲心故。或见一类有情为恶友摄故远离善友常造罪业。菩萨如应为说法要。使令常得亲近善友远离恶友。菩萨为诸有情起大悲心故。或见一类有情最极贪爱不知厌足远离胜慧。菩萨如应为说法要。令断贪爱发生胜慧。菩萨为诸有情起大悲心故。或见一类有情谓无业报执断执常。菩萨如应为说法要。令入甚深缘起知诸业行。菩萨为诸有情起大悲心故。或见一类有情以其无明痴暗所覆取着我人有情寿者。菩萨如应为说法要。使令慧眼清净断诸见执。菩萨为诸有情起大悲心故。或见一类有情耽味生死执着五蕴如杀害者。菩萨如应为说法要。使令出离一切三界。菩萨为诸有情起大悲心故。或见一类有情为彼魔索之所缠缚若爱若恶皆生住着。菩萨如应为说法要。使令解脱魔索缠缚断除爱恶所住着心。菩萨为诸有情起大悲心故。或见一类有情扃涅槃门辟恶趣户。菩萨如应为说法要。使令彼等辟涅槃门扃恶趣户。菩萨为诸有情起大悲心故发菩提心。若于菩萨忍法有毁谤者。彼生欺慢心于法障难。欲令菩萨远离忍法。菩萨当知是魔事起。信力入印法门经云。佛言。妙吉祥。假使有人于一切世界极微尘等一切有情所有善根悉为障难。若复于一优婆塞无异师尊具修十善业者彼少善根。而为障难。如是之罪倍胜于前阿僧祇数。假使有人于极微尘等一切世界诸优婆塞所有善根。悉为障难。若复有人于一苾刍所彼少善根。而为障难。如是之罪倍胜于前阿僧祇数。如是次第。若于随信行人随法行人。须陀洹斯陀含。阿那含阿罗汉。八人地及缘觉人。羊车行菩萨人。象车行菩萨人。日月神通行菩萨人。声闻神通行菩萨人等。若或有人于是极微尘等一切世界诸声闻神通行菩萨人所诸有善根悉为障难。若复有人于一如来神通行菩萨所。彼一善根而为障难。起欺慢心生忿恚者。如是之罪倍胜于前阿僧祇数。假使有人于十方一切世界极微尘等一切有情挑取其眼。而复劫夺一切所有资生财物。若复有人于一菩萨所。起欺慢心而生忿恚。骂辱毁呰加复触娆。如是之罪倍胜于前阿僧祇数。若或有人于菩萨所。随以何缘起欺慢心生忿恚者。由是罪业堕大号叫地狱。身量五百由旬有五百头。其一一头有五百舌。而一一舌有五百犁以耕其舌。有大炽焰。假使有人于三千大千世界一切有情所。皆以刀杖而打斫之。加复侵夺所有一切资生财物。若复有人于菩萨所起欺慢心。而生忿恚及怀损恼。如是之罪倍胜于前阿僧祇数。假使有人发极恶心。一切有情不利益心。于殑伽沙数等世界。一一世界中有殑伽沙数诸阿罗汉而悉杀害。复以殑伽沙数等诸佛塔庙诸宝所成及宝栏楯竖立幢幡殊妙严饰皆悉破坏。若复有人于信解大乘菩萨所同植大乘种已。随以何缘起欺慢心而生忿恚。骂辱毁呰加复触娆。如是之罪倍胜于前阿僧祇数。何以故。以菩萨能生诸如来故。使令佛种不断绝故。若有毁谤菩萨者。是即毁谤正法。若毁谤菩萨者。彼无别法可摄受故。唯菩萨法而能摄受。假使有人于十方一切世界诸有情所悉生忿恚。若复有人于菩萨所生忿恚已。舍而背之不乐瞻视。如是之罪倍胜于前阿僧祇数。假使有人于阎浮提一切有情而悉杀害。加复侵夺一切所有。若复有人随于一菩萨所而生毁谤。如是之罪倍胜于前阿僧祇数。慈氏师子吼经云。若菩萨于满三千大千世界一切有情所。悉生忿恚骂辱捶打。而彼菩萨亦复不为坏失损恼。若此菩萨或于一菩萨所一起忿恚心虽极少分。而此菩萨是为陷失损恼。何以故。彼一菩萨经尔所劫被忍辱铠。常不舍离一切智心。是故此菩萨不应于彼暂生忿恚。妙吉祥神通游戏经云。佛言。妙吉祥。汝今当知。诸言损害者。谓百劫中积修善根别别坏失。此名损害。修菩萨行者应如是知。若于佛世尊所作不饶益得大罪报。作诸饶益者获大福蕴

大乘宝要义论卷第二大乘宝要义论卷第三

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

入定不定印经云。佛言。妙吉祥。假使有人于十方一切世界一切有情悉挑其目至满一劫。若有善男子善女人。于彼如上诸有情所起慈愍心。悉使其目平复如故。至满一劫。妙吉祥。若复有人。于信解大乘菩萨所发清净心。暂一观视者。如是福蕴倍胜于前阿僧祇数。假使有人遍往十方一切有情诸牢狱中。悉为解除牢狱系缚。而复令得转轮圣王或帝释天主上妙快乐。妙吉祥。若复有人。于信解大乘菩萨所发清净心瞻仰赞叹。如是福蕴倍胜于前阿僧祇数。信力入印法门经云。佛言。妙吉祥。若有善男子善女人。于一切世界极微尘等诸有情所。日日常以天百味饮食及天妙衣。于殑伽沙数等劫中普行布施。若复有人。于一优婆塞无异师尊具修十善业者。当起是念。此是学佛戒行人。于一日中以一食施。如是福蕴倍胜于前阿僧祇数。如是次第。若一苾刍。若随信行人。若随法行人。乃至若缘觉。倍倍供施。若复有人但见一画佛形像或经夹中画如来像者。如是福蕴倍胜于前阿僧祇数。何况合掌尊重。或以华香涂香灯明净心供养。如是福蕴倍胜于前阿僧祇数。复次若有于殑伽沙数等诸佛世尊及声闻众。日日常以天百味饮食及天妙衣。于殑伽沙数等劫中布施供养。若复有人。于一羊车行菩萨人所。随于何佛种植善根。净心具足者摄取是人。于一日中以一食施。如是福蕴倍胜于前阿僧祇数。若有人于一切世界极微尘等诸羊车行菩萨人所。日日常以天百味饮食及天妙衣。于殑伽沙数等劫中布施供养。若复有人。于一象车行菩萨人所。一日之中以一食施。如是福蕴倍胜于前阿僧祇数。若有人于一切世界极微尘等诸象车行菩萨人所。日日常以天百味饮食及天妙衣。于殑伽沙数等劫中布施供养。若复有人。于一日月神通行菩萨人所。一日之中以一食施。如是福蕴倍胜于前阿僧祇数。若有人于一切世界极微尘等诸日月神通行菩萨人所。日日常以天百味饮食及天妙衣。于殑伽沙数等劫中布施供养。若复有人。于一声闻神通行菩萨人所。一日之中以一食施。如是福蕴倍胜于前阿僧祇数。若有人于一切世界极微尘等诸声闻神通行菩萨人所。日日常以天百味饮食及天妙衣。于殑伽沙数等劫中布施供养。若复有人。于一如来神通行菩萨人所。一日之中以一食施。如是福蕴倍胜于前阿僧祇数

此中应问。何名羊车行菩萨人乃至如来神通行菩萨人邪。答如入定不定印经云。佛言。妙吉祥。菩萨有五种行。所谓羊车行。象车行。日月神通行。声闻神通行。如来神通行。此中羊车行象车行二菩萨人。于阿耨多罗三藐三菩提有所退转。其日月神通行声闻神通行如来神通行三菩萨人。于阿耨多罗三藐三菩提不复退转。彼羊车行菩萨人。其复云何。譬如有人欲过五佛刹微尘数世界。乃自思念我当乘其羊车。念已即乘随路而去。时极长久历受勤苦行百由旬。忽为大风所吹退八十由旬。妙吉祥。于汝意云何。是人乘彼羊车。若经一劫。乃至不可说不可说劫。能过尔所世界或一世界不。妙吉祥言。不也世尊。若能过者无有是处。佛言。妙吉祥。如是如是。或有菩萨先发大菩提心已。后于大乘法中不持不诵。返于声闻法中爱乐修习同其称赞。受持读诵解释其义。复令他人持习解了。由是缘故智慧钝劣。于无上智道有所退转。是菩萨虽先修习大菩提心慧根慧眼。以其智慧成钝劣故有所坏失。此名羊车行菩萨人

何名象车行菩萨人。譬如有人欲过如前佛刹微尘数世界。乃自思念。我当乘其八支具足妙好象车。念已即乘随路而去。经于百年行二千由旬。忽为大风所吹退千由旬。妙吉祥。于汝意云何。乃至是人能过一世界不。妙吉祥言。不也世尊。若能过者无有是处。佛言。妙吉祥。如是如是。或有菩萨先发大菩提心已。后于大乘法中不持不诵。返于声闻法中爱乐修习乃至持读解了。此名象车行菩萨人。何名日月神通行菩萨人。譬如有人欲过如前佛刹微尘数世界。乃至其人作日月神通行随路而去。妙吉祥。于汝意云何。是人能过尔所世界不。妙吉祥白佛言。世尊。是人能过。时极长久历受勤苦。佛言。妙吉祥。如是如是。或有菩萨先发大菩提心已。不于声闻法中爱乐修习。乃至一四句偈亦不持读。唯于大乘法中爱乐读诵解释解了。此名日月神通行菩萨人。何名声闻神通行菩萨人。譬如有人欲过如前佛刹微尘数世界。乃至其人作声闻神通行随路而去。妙吉祥。于汝意云何。是人能过尔所世界不。妙吉祥白佛言。世尊。是人能过。佛言。妙吉祥。如是如是。或有菩萨发大菩提心已。于大乘法中爱乐修习。而复于他修大乘者信解大乘者持诵大乘者摄受大乘者诸菩萨所。信奉归向亲近于彼。希求大乘受持读诵。乃至值遇失命因缘。亦不暂时舍离大乘。而复于他修大乘者。以香华等尊重供养。于未学菩萨亦不起慢心。此名声闻神通行菩萨人

何名如来神通行菩萨人。譬如有人欲过如前佛刹微尘数世界。乃至其人求佛神通行随路而去。妙吉祥。于汝意云何。是人速能过尔所世界不。妙吉祥白佛言。世尊是人一刹那间发是心时。即能速过尔所世界。佛言。妙吉祥。如是如是。或有菩萨发大菩提心已。乃至善解大乘最上甚深广大义理。常为救度一切有情。发大菩提心慈悲摄受。于六波罗蜜多四摄法等发勤勇心已。复令他人亦如是安住。此名如来神通行菩萨人

此中应言。若有毁谤正法者。是即于法作其障难。斯极大罪。如般若波罗蜜多经云。或有修菩萨乘者。虽曾得见百千俱胝那庾多诸佛如来。于诸佛所广行布施。乃至修习智慧。而起有所得心。虽往诸佛会中听受宣说般。若波罗蜜多不生尊重。若身若心悉不清净起染污慧成大罪业。即于甚深般若波罗蜜多而生毁谤。由谤此甚深般若波罗蜜多故。是即毁谤过去未来现在诸佛世尊及佛一切智。以是缘故是谓于法作大障难。此业相续堕大地狱。经俱胝那庾多百千岁。从一地狱出复入一地狱。如是展转数数成坏。地狱出已复堕饿鬼及畜生趣。舍利子白佛言。世尊。此障正法罪业相续当堕五无间地狱。今可说是校量罪业为不可说邪。佛言。止舍利子。汝不应说

复次诸修菩萨行者有多种魔事。如般若波罗蜜多经云。复次须菩提。若有建立诸名字者。菩萨当知。是为魔事。若有魔来诣菩萨所作如是说。汝此菩萨现成正觉建立是名。菩萨尔时随起伺察。若住不退转相。即彼魔异不得其便。若起解心谓我得记。即生慢意。于余菩萨所乃起欺慢。此是恶魔巧以方便欲令菩萨远离般若。善友不摄恶友随逐。或堕声闻地。或堕缘觉地。起欺慢相应心者。获罪甚重过四根本。菩萨当知。此为魔事。妙吉祥神通游戏经云。妙吉祥言。天子。随有事业成此。皆是魔事。若其所求若有所取若有所舍。皆是魔事。若有所欲若有想像若有领纳若有计度。皆是魔事。又复天子。若于菩提心有所取着。皆是魔事。于布施持戒忍辱精进禅定智慧诸心有所取着。皆是魔事。又施起慢心戒住分别忍生忿恚精进戏论禅定取相智慧作意。此等皆是魔事。若起厌舍心乐居寂静。此是魔事。若于少欲知足头陀功德起领解意。此是魔事。若行于空若行无相若行无愿若行无戏论若行远离。于如来言教所行起我慢意有所分别。皆是魔事。天子。乃至若有分别若无分别见闻觉知想念生时。皆是魔事。天子问言。妙吉祥。是诸魔事何因所起。妙吉祥言。天子。诸魔事者。皆从增上相应所起。何以故。而诸魔事于增上相应法中伺求其便。若非相应胜法魔何所作。天子言。妙吉祥。何等是菩萨增上相应。何等是不相应。妙吉祥言。天子。若二法相应是即增上相应。何以故。以二法相应是为世间和合依止。此增上相应即是正相应增语。此正相应即是不相应增语。此不相应即是无戏论增语。此无戏论即是正相应增语。若相应若不相应。是中建立。是故天子。无眼相应无色相应。乃至无意相应无法相应。此说名为菩萨正相应

复次天子。当知诸菩萨有二十种法随起魔事令魔勇悍。何等二十。一者于修解脱事业者。于怖畏生死者。于修相应胜行者。方便亲近承事供养。此等皆是菩萨魔事。二者若但观空弃舍有情。是菩萨魔事。三者但观无为于有为善根而生懈倦。是菩萨魔事。四者虽起定意而不修定行。是菩萨魔事。五者说法者乐说听者不起大悲。是菩萨魔事。六者于有戒有德人所求行布施。于破戒人所而生毁谤。是菩萨魔事。七者乐说声闻缘觉言论隐覆大乘言论。是菩萨魔事。八者隐覆甚深言论乐说种类言论。是菩萨魔事。九者虽知菩萨道。而不求修波罗蜜多道。是菩萨魔事。十者以称赞增上相应语言。与不相应诸有情类而为教示。是菩萨魔事。十一者虽种植善根而背菩提心。是菩萨魔事。十二者虽于相应观行相续所行。而不为诸有情如应教示。是菩萨魔事。十三者虽求尽彼无余烦恼。于生死相续烦恼厌弃。是菩萨魔事。十四者虽复伺察胜慧。而不取大悲所缘之境。是菩萨魔事。十五者于一切善行若不具方便。是菩萨魔事。十六者虽复希求菩萨藏法。而乐受持路伽邪陀外道典籍。是菩萨魔事。十七者虽复多闻于所闻法。而常秘惜不令他知。是菩萨魔事。十八者虽复多闻以世间缘为他说授。贸取其财为无义利。是菩萨魔事。十九者于住大乘诸法师所而不亲近尊重承事。返于住彼声闻缘觉乘人非同分者同其称赞。是菩萨魔事。二十者若时菩萨恃有财宝威德富盛。若天帝释。若梵王。若护世。若王及长者。皆不亲近尊重承事。以威德富盛故。是菩萨魔事。此等是为菩萨二十种法随起魔事令魔勇悍。海意经云。若有菩萨具大名称。富盛自在种族高胜。眷属广多具有福行。由如是故而生懈怠。不以智求相应胜行。骄倨放逸。或见菩萨出家圆满常以智行求相应法。悍劳忍苦大风大热。悉能甘受。血肉销瘦容貌丑恶。而前菩萨如是见彼胜功能已生欺慢意。彼有善说而不听受。而复增起骄倨痴慢。此为菩萨魔力钩制

又云。有四种法能于大乘而为障难。一者显露己德。二者隐覆他德。三者我慢炽盛。四者忿恚坚固。又诸菩萨勿应以发菩提心便为喜足。然当广修相应胜行

此中应问。在家菩萨云何所行。答如勇授长者问经云。佛言。长者。在家菩萨虽处其家。常修正士所行诸业。非正士所行而实不作。依法受用不以非法。艰苦希求正命自资。不以邪命而活。不恼他人。自所得利虽常受用起无常观。广以实法而行布施大舍无吝。尊事父母。于妻子奴婢及作事人乃至朋友知识。常以正法而相教示。又复何等是在家菩萨不正所行。如出家障难经云。佛告尊者大名言。汝今当知。诸生盲者。聋者哑者。及旋陀罗不知乐者。多毁谤者。谄曲者。不男者。常为仆使者。转女人身者。驼驴猪狗乃至毒蛇。如是等类。世世生生于佛教中不生爱乐。又复大名。在家菩萨若有四种法者。是为难事。一者于先佛所曾种善根诸有情类。及求出离心者。乐圣道心者。于彼若作障难。此为在家菩萨第一难事。二者贪着财宝子息眷属不信业报。若男若女若妻子等诸亲眷属。于富贵中舍欲出家者。若于彼等作障难者。此为在家菩萨第二难事。三者在家菩萨毁谤正法。未闻之法虽复听受。闻已不信返生毁谤。此为在家菩萨第三难事。四者于具戒德沙门婆罗门所起损害心。及多种过失心。此为在家菩萨第四难事。如是四种及别别起诸障难法。皆是在家菩萨乃至世世所生而为难事。如有一人堕秽污井。乃谓余人言。快哉此井。有清洁水。余人闻已于秽水中起清水想。不以秽污为不清净。诸染欲有情亦复如是。自染欲泥。而复教令他人亦染。自嗅恶香教他亦然。自堕贪嗔痴等诸险难处。而复教令他人亦堕。又如有人获其怨对弃掷火坑。是火猛焰高七人量无薪无烟。诸染欲者亦复如是。亲近女人赞说欲事堕欲火坑。而复教令他人亦堕。使彼堕已病苦忧恼常所侵逼。又如一人教令余人登刀锋山受其快乐。而复谓言。是山平坦无复巇险。可登其山受于快乐。世间父母爱恋子息亦复如是。以爱子故于欲染事随生取着。而欲染法其实大恶。犹如毒蛇。是人染心。于彼妻前。返以美言赞说欲事。彼三恶趣极大险怖。亦以美言返为善说。作是说者。当堕地狱饿鬼畜生道中

大乘宝要义论卷第三大乘宝要义论卷第四

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

如日子王所问经云。佛言。大王。彼染欲人爱着欲事。乐见女人行染欲法。不乐亲近具戒沙门及婆罗门。为彼有戒德者而共嫌厌。减失所有信戒闻舍慧等法。彼秽恶门恶气充盈不净流溢。故起耽染。不生厌弃处其秽恶。与蛆虫等非所依着。远离惭愧。天人法灭。残毁身命。智者呵厌。为彼女人之所降伏。与彼女人而为仆使。涎液涕流诸不净物。取以为味。于不净境中与彼牛羊鸡猪狐及驴等。同其所行。于父母沙门婆罗门所远离孝爱。于佛法僧减劣净信。当堕地狱饿鬼畜生趣中。于其险恶怖畏岸侧登铁叉树。堕在等活黑绳众合号叫大号叫炎热极炎热阿鼻大地狱中。皆由与彼女人。俦侣亲狎。爱恋喜笑。嬉戏娱乐。歌舞唱妓。如是等事常思念故。于出离事不起思念。又复不念父母生育极甚为难。十月怀担不净流溢。于诸艰苦而悉甘忍。及其生已转复增长诸苦恼事。养育存惜乳哺爱怜。洎至长立。教彼阎浮提中种种事业。欲令子得安隐利乐。时彼父母为欲令子得安乐故。选择上族与娶其妻。妻至家已子生爱着。迷醉耽湎缠缚闷乱。以彼爱着其妻室故。不念尊重孝养父母。返于父母轻慢弃背。其后父母年迈衰朽。诸根劣弱多所阙乏。子设方计遣其父母令出自舍。佛言。大王。汝观彼人。无悲愍心生舍离心起损害心。不念父母生育极难。而彼父母常与其子作安乐事。方便存惜令得安隐。彼子背恩遣其父母出自舍已。乃与妻子常所欢聚。饮食衣服随意受用。由是因缘弃舍善趣。行斯非法。决定当堕诸恶趣中

复次宣说一切有情共行邪行。唯诸菩萨而乃不行。所谓杀生偷盗欲邪行等。如是作已决定当获不可爱果。如月灯三昧经偈云

  愚者耽着诸欲事　　亲近女人染秽身
  还当向彼染秽中　　随业堕在诸恶趣
  佛不赞说染欲事　　亦不听近于女人
  大怖畏绳所萦缠　　欲女之绳极坚恶
  欲火猛炽当远离　　如恶蛇毒智应知
  女人无信不可凭　　智于此道应觉了
  当观菩提最胜道　　是即先佛所亲近
  观已菩提圣道圆　　获得诸佛无上智

如正法念处经云。诸地狱中所有罪人。时彼狱卒于日日中数教示云。汝等罪人自造恶业。决定无失随其所造。彼无数种不善业行亦然。今受无数种苦。因相等故取果无异。种子等故受果亦然。由如是故汝诸罪人于今堕在炎热大地狱中。由自所作不善业因昔充满故。而今所受不善业果亦悉充满。如是经于百千岁中所作罪业。在不死地无利乐欲。时彼罪人受罪乃至地狱果满。或暂放释即求救护。罪人遥见如大黑云冥然无际极大勇悍。复大力势如金刚嘴大恶狗众。大恶吼声而来围绕。罪人见已四向奔驰。即时诸狗前来。搏噬罪人恣意食啖。皮肉丝裂筋脉断坏。支体骨节各各分离。乃至一切身分皆悉食啖。无复遗余如芥子许。如是食已业力所持而复还生。展转长时。又复食啖。凡如是等业果报者。谓由杀生取其肉食。害有情故果报如是

复次偷盗业果报者。如彼罪人虽见作业果报真实而为恶业。幻惑所迷随逐不了。侵取他财。摄为己有。由斯罪故而彼狱卒执取罪人。执已即持利刀割截支节断坏。断已还合。见余罪人亦悉奔走。为彼狱卒各执取已。或持利剑。或烁吉帝。或都摩啰。或复捣杵。皆有炽焰。斩斫打击种种治罚。此等皆是行偷盗法不善业果。经于无数百千岁中在是地狱。乃至偷盗业果坏散。极尽边际然后放释

复次宣说欲邪行果。谓染欲者见彼女人在灰河地狱或浮或沈叫呼怖畏。而彼地狱炽焰猛恶。其状如流。时彼女人悲涕号哭呼其人言。我自作业今堕于此灰河地狱极险恶处无救无依。愿为救护。时染欲人闻其女人号哭声已业幻痴迷。即时奔驰入彼河中。是人入已流焰触身遍体融溃。无复遗余如芥子许。业力所持即复还活。又复如前见彼女人在灰河中叫呼求救。是人见已亦复奔前持捉女人。时彼女人返捉前人。即以炽焰铁所成棒而为打击。是人为捧所击流血遍满全身碎坏。无复遗余如芥子许。其染欲人业力所持即时还活。染因重故又复奔前持捉女人。同在灰河。大地狱中。经于无数。百千之岁。乃至染欲。业果坏散。极尽边际然后放释。又复还生如经广说

此中当知。财富寿命勿生取着。生取著者是为邪行

如胜军王所问经云。佛言。大王。譬如世间若男若女梦中或见可爱园林或可爱山。或见可爱人众阛阓。及睡觉已都无所有。大王。又如众果树林茎干枝叶。最初青润渐变赤色。次第含蕊后乃开华。华开不久即时结果。果落衰残后见凋谢。如前华果都无所有。今汝大王亦复如是。世间王者所有快乐。王富盛乐。王五欲乐。广有象马车步仓库财谷宫阙园苑金银珍宝臣佐宰官后妃宫属童男童女。乃至一切王族亲枝。凡如是等皆当弃舍应求出离。此等一切悉是无常。是不坚牢。是不究竟。是变易法。是不真实。是不久住。是动是摇。刹那坏散。毕竟是罪。是尽是灭。极其边际为减失法。为怖为恼。多起忧苦。是损是堕。是断是破。是离散法。大王。如是应知。又如有四大山从四方来。其山坚实不破不缺。妙峰圆满从虚空中一时堕地。尔时大地诸有情类。乃至一切树林草木。而悉摧毁。是诸有情及草木等皆不能避。设有力势不能奔走。复无方术及诸作用而为制止。大王四种大怖彼彼若来亦复如是。一切有情皆不能避。设有力势不能奔走。复无方术及诸作用而为制止。何等为四。大王。老怖若来坏少年相。病怖若来坏安乐法。死怖若来坏灭寿命。邪行若生坏失正行。大王。又如师子为兽中王。若入兽群取一兽食。随其所欲不以为难。然彼师子虽有大力。若入咩拏大恶飞鸟口中极不自在。尽食无余。大王。死箭射人亦复如是。中是箭者极甚迷乱无救无归。支节将断血肉干枯。渴恼所逼面相恐畏。手足战掉无力无能。涎液涕流大小便利秽污染身。眼耳鼻舌身意诸识不行。喉颈阗咽欲语不能。医师弃舍无以为疗。众味饮食其何能进。是人尔时随自业力欲奔他趣。无始时来生老病死。轮回流转循环不止。此识若舍他识还依。此命余业复取有身。阎魔狱卒甚可怖畏。黑暗长夜常履其中。将舍识时。彼出入息渐渐微细。单己无侣无所堪任。此界既谢他界即行。长广路中孤然游履。大恐怖处而生极怖。深隐道途隐覆而行。入大黑暗处大艰险。没溺生死长流大海。业风所吹飘扬无定。不辩方隅莫知所诣。尔时无救亦无归趣。佛言。大王。唯除善法当于尔时是所依归是为救护。大王。世间富乐等法都无所得勿生耽着。诸有所作皆为邪行。是故大王。应修正行

所言正行者。如真实品云。王者若行八种想行。是为护世相应正法。何等为八。一者世间无子孤露之人与为子想。二者将护恶友如病人想。三者见有诸苦起救拔想。四者见有诸乐起欢喜想。五者于诸冤对随观彼缘离过失想。六者于诸善友起随护想。七者见诸富乐犹如药想。八者于身作无常想

又如破恶慧经云。王者若能具足四种法者。应受王之灌顶即成不退堕法。速得如来应供正等正觉爱念。获受广大富乐具足。何等为四。一者护持如来教法令得久住。二者弃舍罪不善法。三者摄取空无相无愿法门。四者发起阿耨多罗三藐三菩提心。此中云何是为弃舍罪不善法。如日藏品云。佛言。大王。未来世中诸刹帝利婆罗门吠舍首陀。于彼一类修行正法之者。以其所有舍宅田土园苑奴婢坐卧之具病缘医药乃至四足等。如是一切而悉侵夺。或自受用或与他受用。此等刹帝利婆罗门吠舍首陀。即于现生获二十种不可爱法。何等二十。一者贤圣舍离。二者所向方隅讥谤流布。三者友爱远离。四者多生冤对。五者财物资具而悉破坏。六者多生散乱。七者身分残缺。八者不得睡眠。九者渴恼常逼。十者饮中有毒。十一者朋友轻侮。十二者常与他诤。十三者父母妻子奴婢眷属教令不行。十四者自隐密法及隐密财为他显示。十五者自隐密人及隐密事悉为他说。十六者财物销荡散归五分。十七者轻重病恼而来侵逼。十八者奉医药人而悉舍离。十九者血肉干枯受诸苦恼。二十者其身流注。大小便利染污而终。大王。如是二十种不可爱法。彼等现生决定速获皆由于彼修行正法人所侵夺彼有受用资具或自受用或与他人。由是因缘彼命终已当堕阿鼻大地狱中。尽其一劫渴饮铜汁饥吞铁丸身被火衣。如是种种受大恶苦。尽彼劫寿从地狱出。还复生于饿鬼趣中。处大旷野极恶险难枯涸之地。四方炽盛炎风所吹。其地坚利状若刀锋。经于无数百千岁中受彼趣苦。其后暂时或彼灭已。于大海中为一肉团。量百由旬以其宿业因故。令彼海中周百由旬悉成炎热铜汁。如是经于多百千岁。于大海中受地狱苦。从彼灭已还来于此极恶险难大旷野中。化成肉团与山相等。周匝四方炎风所吹。其四方面飞禽走兽皆来食啖。过长时已或暂彼灭。还复生于大地狱中。地狱灭已数数受是大恶苦果。其后成满一劫乃得人身。虽生佛国土中。然五浊具足空无智慧。眼目角睐又复聋哑。大王。凡如是等皆由于彼修行。正法人所侵夺彼有受用资具等。如月藏品云。诸仁者。于我法中出家人所起大罪者。所谓杀生偷盗欲邪行妄语等极不善业。谓彼刹帝利啰惹乃至州城聚落官属。于出家人所若国土州城住处寺舍。多行制止不令居处。或语调伏。谓恶言呵毁。或身调伏。谓加诸杖责。彼一切处如是循环皆不解脱。于天人趣有所减失。当堕阿鼻大地狱中

尔时诸天乃至羯吒布单那等。随其所来一切大众。咸于三宝发生最上清净之心。以种种相极生尊重。俱发是言。我等从今已往誓于一切世尊教中而作卫护。所有苾刍苾刍尼优婆塞优婆夷。下至破佛戒者。下至于佛法中不持戒行。但剃除须发被服袈裟无所摄受者。我等于彼起大师想。皆为作护。一切资具长养摄持。若复随诸方处或有官属。于彼剃除须发被袈裟者。以多种缘加诸杖责。我等于彼不为作护。弃舍一切彼境界事。随其国中若起种种谄诳不实斗诤杀害疾疫饥馑他兵侵扰非时风雨或旱或涝种子散坏。有如是等诸娆恼事。我不为彼作其止息。我等当往别国土中有佛弟子之所当为作护我乃空其境界舍离而去

如地藏经云。佛言。地藏。过去有国名半左罗。王名最胜军。是时彼有法。应刑戮之人。以护命故潜剃须发。以袈裟衣片缠于颈上。时宰杀者执其罪人系缚五处。驱逐往诣尾体朅蓝嚩迦大丘旷林中弃置而还。即于是夜彼丘旷林中有罗刹女名曰恶眼。与五千眷属来入是林。忽见其人五处系缚剃除须发被袈裟片。见已即时右绕顶礼出林而去。次有罗刹女名佉祢啰奈帝。与千眷属。次有罗刹女名狰狞发。次有罗刹女名曰剑口。次第而来入于林中。各见其人剃除须发被袈裟片。见已虽复彼彼饥急不敢侵食顶礼而去

又复过去有王名最胜福。彼有智臣。以其法应刑戮之人付于醉象。是人以赤袈裟片潜被其身时彼醉象举鼻。卷取罪人双腨。尽其力势欲掷于地。时象乃见罪人身被赤袈裟片。见已即时生清净心。乃以罪人徐置其地。跪伏于前涕泣悔谢。复以其鼻摩洗双足。佛言。地藏。且观彼象虽受无暇傍生趣身。彼时见被袈裟片者。尚能舍离而去不造罪业。况复未来世中有旃陀罗啰惹及其官属沙门婆罗门长者等中旃陀罗人。本实愚痴起聪明慢。以谄曲言诳惑世间。谓言我是求无上大乘之者。彼等愚痴旃陀罗人。不怖不观后世果报。于我法中出家人所。若是法器若非法器以种种缘伺求过失。谓以恶言克责楚挞其身。制止资身所有受用。复于种种俗事业中而生条制。或窥其迟缓。或觇其承事。求过失已而为条制。如是乃至欲害其命。彼诸人等于三世一切佛世尊所生极过失。当堕阿鼻大地狱中。断灭善根焚烧相续。一切智者常所远离

大乘宝要义论卷第四大乘宝要义论卷第五

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

如地藏经云。复次有刹帝利旃陀罗乃至长者旃陀罗人。于其所为四方僧众造立寺舍园林台观。资畜田土给侍人等。饮食衣服卧具医药。或华果树或染色树香树荫树。乃至种种受用之具。若自侵夺。若教他侵夺。若自受用。若令他受用。于我法中出家人所。或生嗔恚或复呵骂制止轻侮。于正法中作其障难。于说法师而兴娆乱。此等皆于三世一切佛世尊所生极过失。乃至一切智者之所远离。复次彼中世尊作如是言。诸得忍菩萨摩诃萨应受刹帝利王灌顶及富乐受用。我即许可。金刚藏菩萨白佛言。世尊。刹帝利王所受灌顶。若非得忍菩萨。彼当堕于何等恶趣。佛言。金刚藏。若非得忍菩萨但能修集十善业道。受刹帝利王灌顶及富乐受用。我亦许可。金刚藏菩萨白佛言。世尊。若非得忍菩萨。又不具修十善业道。彼旃陀罗刹帝利啰惹。于此世尊甚深教中而令减失。当堕阿鼻大地狱中。斯等云何而得解脱。佛言。善男子受刹帝利王灌顶者。若被信力坚固铠甲。于三宝中广生净信。又不于我三乘出离法中而生毁谤。下至一四句偈亦不轻毁。于持戒破戒人中悉不娆乱。下至不受净戒但剃除须发被袈裟者诸苾刍众而不娆乱。若众僧所属。若单己所属。一切受用等物悉不侵夺制止。常所听受三乘出离正法。如其所闻随力修行。于彼修行三乘诸苾刍所而常亲近。愿力坚固不起违背之心。教授有情大乘之法。使令趣入复令安住。若有能具如是相者刹帝利王。应受广大富乐受用。而不退堕。先佛如来皆悉许可。我今亦然许可是事。复次彼中作如是言。若有真善刹帝利王乃至真善长者。若今现在或未来世。乃至后五百岁法欲灭时。若自若他皆作卫护。于佛清净教中坚固守护。又于安住声闻乘者。缘觉乘者。及大乘者。诸补持伽罗具修净戒德广大者。若是法器若非法器。乃至但剃除须发被袈裟者。悉为守护。复为护持塔寺所属之物。悉不侵夺或自受用或与他受用。他所侵者即为制止。如是福蕴无量无数不可限极。尔时会中一切天主乃至毕舍左主咸作是言。世尊。若真善刹帝利王乃至真善长者。具足如是功德者。我等皆为作护。令具十种增长之事何等为十。一者增长寿命。二者增长无难。三者增长无病。四者增长眷属。五者增长财物。六者增长资具。七者增长自在。八者增长名称。九者增长善友。十者增长智慧。我等与自眷属。常当护彼真善刹帝利王。尽其国境。有十种法使令远离。而为守护。何等为十。一者他国兵敌。二者自国兵敌。三者罪业之人。四者杀害之人。五者非时雨。六者恶风暴热。七者极恶宿曜。八者饥馑。九者横病夭死。十者邪见。月灯三昧经云。佛言。若诸天龙夜叉等于我教中作护持者。彼等是大施主。令我法眼而得久住。使三宝种不断不绝。从我口生之子。从法化生诸苾刍苾刍尼优婆塞优婆夷。及余净信善男子善女人。为胜义谛法。乃至为求阿耨多罗三藐三菩提者。悉为护持。我今亲自付嘱于汝天龙夜叉等诸大施主。及慈氏等贤劫之中诸菩萨摩诃萨。如我教敕当为作护。若欲安住修行正法者。即得心善。云何得心善。如宝云经云。菩萨得心善。是中云何名为心善。谓彼若能于身心离即得心善。应生如是心审谛观察。当以何法是我心之所行。又复以何说名为善。若行于善即喜心清净。由心喜故是即行善。能生多种厌离。能起多种伺察。诸不善法而悉断灭。阿阇世王经云。诸菩萨不应如是生心。若心有所生即诸恶魔伺得其便。诸佛如来亦不爱乐。贤圣不生喜心。自善根分而亦减失。若复生心而无所生。即诸恶魔伺不得便。诸佛如来亦悉爱乐。贤圣心喜自善根分亦不减失。彼若如是修行。即于一切处生心。生心转法轮。所说之法而无杂乱。如开发内心经云。佛言。慈氏。若诸苾刍所说杂乱。虽复多闻返生骄倨迷醉忘失。内心散乱而不专注。彼谄曲心相续而生。远离奢摩他毗钵舍那。不为他人之所尊重。天龙夜叉亦不随顺。所修正行而不成就。若于所行悉无所得。是为正行。若欲了知其正行者。谓即勤行修习多闻宴坐。复次彼中作如是说。若有菩萨。勤修胜行而为总领。造七宝妙塔遍满三千大千世界。我亦于彼而不许可若复有人。听受正法一四句偈。与般若波罗蜜多相应者。我即于彼尊重称赞。何以故。多闻能生诸佛菩提。复从世间无取着生。若有菩萨勤修胜行为总领者。应当为他说法讲授。菩萨与其教导。令于系着法中不生系着。所获福蕴广大无量业障销散。慈氏。假使满阎浮提勤修胜行总领菩萨。彼等若能于一勤行说法讲授菩萨之所承事供养。又若满阎浮提勤修说法讲授菩萨。而悉于一勤行宴坐菩萨之所承事供养。此如是等佛悉许可。而亦随喜何以故。智慧事业于难行事业中而为最上。一切三界高显最胜。复次宣说正法行者。如宝积经云。佛言。迦叶。譬如商主欲入大海求无价宝先善观察坚固船筏。乃至到宝所已还复自舍。迦叶。菩萨摩诃萨亦复如是。欲入一切智海。先当观察勤行六波罗蜜多。乃至超过一切愚夫异生声闻缘觉之地。然后住佛果位。阿阇世王经云。佛言。大王。一切智心根本不断。如是根本当起精进策勤教示。布施无厌足。以彼回向一切智智故。持戒无厌足。回向一切有情故。忍辱无厌足。求佛色相故。精进无厌足。于诸善根勤修集故。禅定无厌足。所缘相应故。智慧无厌足。于一切处善思择故为法利故。富乐寿命于一切处皆无过失。及复修正行者。当为一切有情起平等心。如月灯三昧经云。佛言。童子。菩萨摩诃萨当具足一法。若成是功德者。即得速证阿耨多罗三藐三菩提。何等一法。童子。所谓菩萨摩诃萨于一切有情起平等心利益心无障碍心无毒心。是为一法。若欲修正法行者。应当弃舍利养等事。如开发内心经云。应当伺察诸利养事。以其所著失正念故。痴若起时。自利成办故。谄若起时。不能随顺诸佛教敕故。骄倨我慢起时。一向但为险恶根本故。此等坏失诸善根故。智者应当伺察利养。虽于现受而有所得。然其后世果利都无。无量禅定皆悉远离。当堕地狱饿鬼畜生趣中。智者又应伺察利养。犹如水行流注不断。既伺察已如是生心少欲知足。如杂阿含经云。譬如一类哑羊之群于彼尼拘律陀树周匝而行。是中有一哑羊。独诣群鹿岩中守鹿人所。乃至于彼群鹿之前。摇动其头跪伏而坐。求彼所食及求作护。如是还已余哑羊众悉生轻慢。此有一类称赞利养我慢苾刍亦复如是。起无厌心离于众中。为所食故独入城邑。巡行乞食复求邀命。得彼最上清净饮食。自分食已以所求食持还园中苾刍众所。谓苾刍言。诸尊者。我于今日白衣舍中受其邀命。得彼最上清净食已。今我有其所乞之食。是长食法是已舍法。汝诸尊者。若欲食者应当随意。如是言已中有少年苾刍皆生轻慢。智者当知。若发如是粗恶言者。皆为利养等事。如经广说。此中云何远离谄诳二法。如无热恼经云。有二种法。于一切智心而为障碍。所谓一诳二谄。有其二法是无障碍。一正直二无谄。若欲成办诸正行者。常当亲近诸善知识。因善知识故成诸正行。何等经中而作此说。如胜生胜鬘解脱经云。诸菩萨摩诃萨因善知识故。流出一切菩萨行法。善知识者。有大威力。而能圆成诸菩萨故。善知识者。而能出生一切菩萨诸善根故。善知识者。普能结集一切菩萨修学所行。善知识者而为根本。能令一切菩萨深心清净故。善知识者能为守护。增长一切福蕴故。善知识者是所爱乐。获得一切佛菩提故。善知识者而能摄持。令诸菩萨不堕恶趣。使令不退转于大乘不越菩萨学处。出过愚夫异生之地。亦不弃舍声闻缘觉之法。复为作护。善知识者。能令一切失道之者还归正道。闻正法者引令解入一切佛法。善知识如母。能令一切悉生佛家。善知识如父。广为有情资育利益故。善知识如乳母。善护一切令离罪业故。善知识如仆使捍劳。能入生死大烦恼海为拔济故。善知识如举棹人。运载有情至一切智智大宝洲故。诸修正行者。若欲往诣善知识所。应如是作意。使其身心清净勤勇。其心如地。悉能荷担诸重担故。心如仆使。随所欲教令悉为作故。其心如犬。常所警吠为守御故。当观自身如病人想。善知识如医师想。所教示法犹如药想。依教所行如病除想。凡如是等因善知识故得深心清净。已随诸善知识所教令法而善修行。即能增长一切善根。如雪山王一切药草树林皆悉依止。依止善知识亦复如是。能成一切佛法大器。又如大海众流所归。菩萨因善知识从彼出生故。即得圆成一切菩萨行法及一切佛法。如宝积经云。佛言。迦叶。如人乘船入其大海。而于中流船忽破坏。是中或有依一版木或余椽木。随得所依安隐到岸。迦叶。菩萨乘于一切智心之船亦复如是。忽于中流坏失菩萨乘法。若遇善知识而为依止。彼即还得一切智心。乘诸波罗蜜多法运载而行到法界洲。迦叶。所有阿耨多罗三藐三菩提法。而悉依止善知识故。是故于诸善知识所供养承事而为最上。若佛在世。若涅槃后。应当勤行。斯得无量福行圆满。毕竟果报而悉成办。如华积经云。若见师子游戏如来。见已发清净心。而为供养。又若彼佛入涅槃后。取其舍利如芥子许。而为供养。如是所获果报皆悉齐等。是中亦无种种差别。如大悲经云。佛言。阿难。若人于我现前供养。且置是事。又若有人于我涅槃后。收取舍利如芥子许。作诸供养。亦置是事。又若有人。于我法中造立宝塔。复置是事。若或有人。但以一华散掷空中。观想诸佛而为供养。我说是人以此善根。毕竟趣证大涅槃果。阿难。以要言之。下至傍生趣中诸有情类。若能想念诸佛。我说彼等以是善根。毕竟亦成大涅槃果。阿难。汝观于佛世尊所何等行施而为最大。何等发心是大威力。阿难。若有人但能一称那谟佛陀邪。此为胜义。何以故。谓佛世尊具大不空名称故。此不空义者。所谓即是那谟佛陀邪。以于诸如来所随有何等极少善根而不坏失。下至一发净心。此等一切乃至毕竟趣证涅槃。阿难。譬如渔师于大池中欲取其鱼。即以钩饵置于水中。鱼即竞来游泳而食。是时渔师知鱼所在。重复牢固钩竿轮线徐缓深钩。既得鱼已置于陆地。随其所欲取以用之。世间一类有情亦复如是。先于佛世尊所发清净心种植善根。下至一发净信已。而彼有情后复恶作。业障所覆生于难处。其后还得值佛世尊。以菩提智及四摄钩线。拔彼有情出生死流置涅槃岸。海龙王问经云。佛言。龙主。诸菩萨摩诃萨。若能具足八法。即得常不离诸佛。何等为八。一者教示观佛影像。二者承事。如来。三者常赞如来。四者造佛形像。五者教示观佛色相。六者随何佛刹闻佛名称。即于彼佛刹中发生胜愿。七者不生下劣之心。八者起广大心求佛之智。如菩萨藏经云。若能严净如来塔庙者。当得四种清净最上誓愿。何等为四。一者获得最上色相清净誓愿。二者最上诸相具足清净誓愿。三者最上坚固修集清净誓愿。四者最上观见如来清净誓愿。彼经复言。若人于如来塔庙散华涂香作供养者。是人获得八种不坏之法。何等为八。一者不坏色相。二者不坏富乐。三者不坏眷属。四者不坏净戒。五者不坏多闻。六者不坏寂定。七者不坏智慧。八者不坏誓愿。若人欲造如来形像者。应随意作。或以土木铁石。或复象牙。或金银琉璃水精赤珠珊瑚码瑙及诸珂贝众妙香等。或造图[巾*((宋-木)/登)]。或于版木墙壁。作诸画像。或以纸素及诸缯帛錽剪而成。或自新而作。或增修故坏如来形像。如是作已当来。不于下族中生。不于恶业族中生。不于邪见族中生。所感身支当无残缺。设有具造五无间罪者。于如来所能发净信造立如来形像。是人所有当来地狱业报转重令轻。于三乘法或余乘中而得出离。如人不净秽污其身。而能洁净沐浴妙香涂饰。而彼秽恶之香飘散无余。造五无间罪业者亦复如是。造佛像故彼等罪业销灭无余。又复具行十不善业者。若于如来所发净信心。彼之罪业亦悉销灭。如酥投火中而悉成焰。业散无余其义如是。何况具足最胜菩提心者。及彼出家具净戒者

大乘宝要义论卷第五大乘宝要义论卷第六

        西天译经三藏朝散大夫试鸿胪少卿传梵大师赐紫沙门臣法护等奉　诏译

如宝积经云。假使满三界中一切有情。是诸有情各各造立如来塔庙。如是色相一一高显。犹如须弥山王。而诸有情经于殑伽沙数劫中。各各尊重供养是塔。若有不离一切智心菩萨。但置一华而为供养。此获福蕴胜前福蕴。其数倍多。彼经又云。假使三千大千世界。一切有情悉住大乘。而复皆成转轮圣王。设以香油如大海水。积燃灯草等须弥量。各各燃是广大灯明。供养如来所有塔庙。若有出家菩萨取燃灯草投少分油。于佛塔前燃灯供养。此获福蕴倍胜于前灯明布施。百分不及一。乃至乌波尼杀昙分亦不及一。又若彼诸转轮圣王。各于佛及苾刍众所。普施一切受用乐具。若有出家菩萨。以自持钵所乞之食。先减施人然后自食。此获福蕴胜前福蕴最上广大。又若彼诸转轮圣王。积以妙衣如须弥量。普施佛及诸苾刍众。若有出家菩萨。但以三衣。或施十信心菩萨。或施佛及诸苾刍众。或施如来塔庙之中。此获福蕴比前所施。极为殊胜。又若彼诸转轮圣王。一一皆以满阎浮提布设妙华。广为供养如来塔庙。若有出家菩萨。下至但取一华供养如来塔庙者。此获福蕴比前所施。百分不及一。乃至乌波尼杀昙分亦不及一。次第出生经云。当观菩萨有其四种贤善称赞。应于如来策勤供养。何等为四。一者自作最上布施供养。令他有情亦如是作供养胜行。二者勤诚供养诸如来已。转复坚固大菩提心。三者现前瞻睹三十二种大丈夫相。四者种植善根而得增胜。此等四法。是为最上承事供养诸佛如来。海慧问经云。佛言。海慧。有三种最上承事供养如来之法。何等为三。一者发生大菩提心。二者摄受如来正法。三者广为有情起大悲心。此等是为胜义供养之行。慈氏师子吼经云。无佛可想。无佛可观。何况有佛可供养邪。有所得者无有是处。此中何等是供养佛。所谓真供养者。应起无想无相之心。若无心心所作意。无佛想无法想无众想。无补特伽罗想。无自他想。如是供养者。是真供养诸佛如来。般若波罗蜜多经云。佛言。天主。假使殑伽沙数世界之中积满如来舍利置于刹幢之上。若有人书写般若波罗蜜多经。俱为献施。汝于二分之中当取何分。帝释白佛言。世尊。我于此二分中。当取般若波罗蜜多分。何以故。般若能生如来舍利故。若有供养修习般若波罗蜜多者。是即供养如来舍利。佛言。帝释。若诸有情信解如来如实涅盘者。极为难得。此中何等是诸如来如实涅槃。无数经中作如是说。如来兴显经云。佛言。佛子。若诸菩萨乐欲了知诸佛如来大涅槃者。以慧观察。先当了知法自性性。法自性者。谓即真如实际。法界虚空界。自性清净际。无相际我自性际。一切法自性如如涅槃。应如是了知如来如实涅槃。何以故。佛子。诸法本来如是无生无所生。若法本来如是无生无所生。是故无有少法可得。然佛如来有所生者。但为有情喜乐相续乃有生故。如来入涅槃者。亦为有情厌倦生故。而实如来本无所生亦无涅槃。是诸如来常住法界。佛子。譬如日轮光明出现。普遍照耀一切世界。各于清净水器之中见日光影。亦非日轮遍一切处。随入器中乃有所现。若复彼彼清净水器。或破坏时。或浑浊时。或减少时。彼日光明而悉不见。然日光影虽于器中而不显现非日之咎。以彼净器自破坏故。佛子。如来亦复如是。法界日轮广大光明。从法界中常所出现。普遍照耀随顺一切世间。若诸有情清净心相续。如来即为出现影像。一切有情虽常睹见如来日轮影像。亦非如来遍一切处随为出现。若复有情如彼坏器。不清净心相续业烦恼覆故。不见如来日光影像。彼诸有情即起如来入涅槃想。然以如来入涅槃者。非如来咎。但为有情相续善根有破坏故。又复应以大涅槃法所可化度诸有情故。是故如来现入涅槃。而实如来无来无去亦无所住。佛子。譬如一切世间悉作火事。或复后时别异聚落国土城邑火事息灭。且非普尽一切世间火事皆息。佛子。如来亦复如是。普尽一切世界。随顺施作一切佛事。若余佛刹中作佛事已现入涅槃。亦非一切世界诸佛悉入涅槃。如巧幻师善学幻法。诸明咒力而悉洞晓。于一切三千大千世界中。普现其身作诸幻事。一切聚落国土城邑。悉遍显示。随其幻力。若住一劫若过一劫。若余聚落或城邑中。作幻事已隐自身相。亦非一切世间幻事皆隐。佛子。如来亦复如是。以无量如幻之智。善学方便胜慧智明。示现一切法界幻事。如来随现。然如来身毕竟安住。法界及虚空界一切有情。平等事业。别别刹土随顺作已示现涅槃。亦非一佛刹中入涅槃故。一切法界如来悉入涅槃。佛子。诸有菩萨应如是知。诸佛如来大涅槃故。所知无量毕竟无著。法界无边亦复无中。如虚空界自性广大。真如无生而亦无灭安住实际。然以方便随时示现。是故当知。一切世间勿生疲厌。随先行愿而自安住。一切世间一切刹土。成办所有诸胜法行。般若波罗蜜多经云。大涅槃者。所谓自性空。妙法莲华经云。佛言。迦叶。若能觉了彼一切法平等之性。是大涅槃。彼经又云。佛言。善男子。如来诸所作事而皆作已。成佛已来极甚久远寿命无量。如来常住不入涅槃。为度有情故示现涅槃。何以故。应以如是缘成熟有情故。大悲经云。佛言。大梵。如是此世业尽烦恼尽苦尽。苦缘息灭寂然出离。此说是为涅槃。大梵。此中无复有人了是涅槃。谓业烦恼尽自性清净。出世品云。诸佛方便开示无边涅槃之法。梵王问经云。梵王白佛言。世尊。诸出家者。于随所乐一切相中若能止息。此说是为涅槃。佛言。大梵。此互为缘所成立故。觉智方广经云。佛言。大目干连。过去有佛号名称高显。彼佛刹中唯声闻众。是时有一苾刍名等。观诸所缘住大乘行。是人曾于无量俱胝那庾多佛所种植善根。于阿耨多罗三藐三菩提心曾无退转。安住无上大乘法中。欲令严净不可说不可说佛刹。其佛刹中无别有情发菩提心。是时彼苾刍虽广植善根。然于甚深法中生轻慢心。以是缘故当生长寿天。时名称高显如来如其所应作佛事已。即时普观一切佛刹。何等刹中有情不作佛事。还自观见我刹土中。有一苾刍住大乘行。是菩提器。然彼苾刍有障难事。以生长寿天故。彼之身器不能堪任令其种植菩提善根。是人命终之后。当堕阿鼻大地狱中。亦复不能堪任种植菩提善根。地狱出已生于人中而复聋哑。诸有所作举手示物。或假他缘方晓其事。是时名称高显如来为欲化度彼苾刍故。以善方便。于六十俱胝那庾多生中。捍劳忍苦作诸化事。使令成熟。佛言。大目干连。汝且观彼如来大悲心故。为一有情经如是时受其劳苦。乃至彼苾刍机缘成熟安住不退转地。大目干连。于汝意云何。彼时名称高显如来者。岂异人乎。即现一切义如来是。彼等观诸所缘苾刍者。即无量光如来是。父子合集经先行品云。佛言。妙吉祥。彼过去世轮回之中。无量阿僧祇不思议无等比无初际。时有如来名曰帝幢。经于殑伽沙数等世界佛刹。是诸佛刹中诸有情类。皆悉得其五种乐事。或有有情得其欲乐。或得出离乐。或得禅定乐。或得三摩地乐。或得阿耨多罗三藐三菩提乐。而彼有情虽受诸乐然无系着。譬如飞鸟腾翔空中而得自在。彼诸有情受乐亦然。悉无所著。妙吉祥白佛言。世尊。彼时帝幢如来者。即我世尊释迦牟尼佛是。入楞伽经颂云

  我不观寂静　　亦不起行相
  复无分别心　　故我证涅槃

此中当知。于一乘信解极为难得。此一乘者。而诸经中皆作是说。妙法莲华经云。我发起一乘为有情说法。所谓佛乘无二无三。十方一切世界法尔如是。何以故。若过去世十方一切世界诸佛如来。皆发起一乘为有情说法。若未来世十方一切世界诸佛如来。亦发起一乘为有情说法。若今现在十方一切世界诸佛如来。复发起一乘为有情说法。所谓佛乘。以是缘故十方世界尚无二乘而可建立。何况有三。真实品云。佛言。妙吉祥。由昔因中一乘境界能具足故。今佛刹中唯一乘法而为出离。而无声闻缘觉二乘建立。何以故。如来已离种种想故。若有人言。如来或说大乘之法。或说缘觉乘。或说声闻乘者。是人于如来所起不清净心不平等心取着之心。大悲经云。佛言。我若说有种种想者。即于法中自生谄曲。然我为诸有情所说诸法。皆悉令于菩提乐欲得大乘法一切智摄。使诸有情同到一切智智之地。是故无彼诸乘分位而可建立。亦无诸地我所建立。亦不建立补特伽罗事。亦无少行及无量行之所建立。复无三乘而可分别。彼无分别性入法界门。但为世俗谛故开示引导方便宣说。胜义谛中唯一乘法。而无有二。般若波罗蜜多经云。佛言。天主。若诸天子未发阿耨多罗三藐三菩提心者。我当令发阿耨多罗三藐三菩提心。若复不能决定发菩提心者。我亦当令随喜发于阿耨多罗三藐三菩提心。何以故。彼于生死流中相续不断故。我意不欲令彼诸善根分有所隐没。当令于彼最胜法中而有所得。大集会品云。一乘普摄彼一切乘。以其一乘摄诸乘故。同归一理。普入法界无分别性。总持自在王问经云。佛不说有种种之想。然佛出世。诸所作事悉同一味。法界而无障碍。容受一切有情。自成正觉已。复令诸有情而亦觉了。然后转妙法轮。所谓不退转轮。譬如治宝之师。于其宝所但取假色琉璃。先以灰水磨淬令洁。次用黑腻之发而复治之。然其宝师会无疲倦。后以肉汁及以缯帛。重复磨治。又用大药汁及细妙衣。次第精治。然后莹洁去其假色同真琉璃。如来亦复如是。知有情界本不清净。乃为宣说无常苦无我不净之法。令于轮回起厌离想。后以圣法调伏方便开导。如来亦不暂生疲倦。后为宣说空无相无愿之法。令其开觉如来之眼。如来亦不暂生疲倦。后为宣说不退转轮。及说三轮清净。引导有情令入如来境界之中。平等超越种种因性。咸证如来清净法性。此说是为世间究竟得无上果。阿惟越致经云。不退转轮平等故。诸佛说法亦平等。是故如来为下劣信解诸有情类不能解了一乘法故。乃出娑婆世界五浊时中。以善方便为彼有情。建立佛事使成佛果。胜鬘师子吼经云。诸佛如来方便宣说此涅槃法。从三乘中出生诸乘。然由一乘之法取证阿耨多罗三藐三菩提。入楞伽经云。诸烦恼种子入三摩地三摩钵底。如实觉了住无漏界。复入声闻缘觉无漏界中。出世胜行圆满成办。得不思议法身自在如来。为所化有情成诸善行故。以善方便说种种乘。是故诸如来于种种界中非但说三乘。亦说余乘法

大乘宝要义论卷第六大乘宝要义论卷第七

        译经三藏朝散大夫试鸿胪少卿光梵大师赐紫沙门臣惟净等奉　诏译

如华严经云。大毗卢遮那解脱吉祥世界中。普遍智焰功德幢王如来。建立无量有情住声闻地。无量有情成熟缘觉菩提。无量有情成熟迅疾辩才出生菩提。无量有情成熟无垢精进幢出生菩提。无量有情成熟法辩才出生菩提。无量有情成熟根清净辩才出生菩提。无量有情成熟十力诸行圆满出生菩提。无量有情安住法城现前境界一乘出生菩提。无量有情于一切处随现种种神通一乘理法出生菩提。无量有情建立诸行普摄无量方便出生菩提。无量有情安住三摩地分位理法出生菩提。无量有情安住一切所缘境界清净道场理法出生菩提。无量有情发菩萨菩提心。无量有情住菩萨道。无量有情安住清净波罗蜜多道。无量有情住菩萨初地乃至住于菩萨十地

此中应知。菩萨常以正法摄受一切。何等是正法摄受。如信力入印法门经云。佛言。妙吉祥。正法摄受故即菩萨摄受。菩萨摄受故即正法摄受。正法摄受故一切有情摄受。一切有情摄受故即佛种不断所作成就。又若欲令佛种不断。欲破一切有情诸业烦恼。欲闭一切恶趣之门。欲受无量无数转轮圣王上妙快乐。及梵王帝释护世等乐。欲断一切恶魔罥索。乃至欲成阿耨多罗三藐三菩提果者。悉当以其正法摄受。此中应问。初发心菩萨以少善根。彼当云何摄受正法。如菩萨藏经云。菩萨若具四种法者。彼即不减菩提。转生当作转轮圣王。如其愿力即得一切善根。随转得如大力坚固那罗延身。彼得转轮圣王已修四梵行。生于梵世为梵天主。何等为四。一者菩萨若见如来塔庙故坏。发勤勇心而为治饰。乃至以一泥团作其供献。二者于四衢道或阛阓之所建立如来高显妙塔。或冢庙像。或随立幢相。或但竖刹竿。或安如来形像。或别别安布如来诸相。所谓转法轮相。或复踰城出家之相。或菩提树下成正觉相。或现大神通降魔车相。或示现入大涅槃相。或忉利天下降之相。三者若见声闻弟子众中有离间者为作和合。四者于如来教中。若见正法欲减灭时。乃至一四句偈勇力护持。使彼流通令不忘失。又于正法或说法师皆为摄受。乃至损弃身命终不舍法。宝云经云。佛言。善男子。菩萨若具十种法者。即能摄受正法。何等为十。一者于后末世后五百岁正法减时。如来教中起杂乱事。而诸有情多住邪道。息灭智灯无正师授。尔时应以广大经典。具大威力摄广大义。如一切法母者尊重供养。受持读诵宣说解释。二者以甚深经为他演说。解释开示使其解了。三者于修正道人所发生欢喜清净之心。四者得欢喜已为彼摄受。五者以无著心为他说法使其听受。六者于说法人所起师尊想。七者于其正法起甘露想。八者又于正法如良药想。九者不惜身命希求正法。十者以所得法如说修行。是为十法。寂静决定神变经云。佛言。贤护。菩萨若具四种法者。即能摄受正法。何等为四。一者于自快乐而不爱着。二者施于他人上妙快乐。三者具大悲心。四者求法无厌。彼经又云。过去世时无垢威光王。于大高如来所。千岁之中种诸善根。以一切乐具供养彼佛。及以四事给施八万四千诸苾刍众。如是过千岁已。彼大高如来告无垢威光王言。大王。如是满足千岁于如来所行诸施法。若比勤行求法菩萨一出入息中所有善根。百分不及一。乃至乌波尼杀昙分亦不及一。何况于正法中乃至一四句偈勤行宣说解释其义。彼福边际我不能说。大王。且置是事。正使如是满足千岁。尽诸所有布施供养。总以为聚施一游方苾刍。如是或施诸苾刍众。若于勤行宣说讲授菩萨所。以乐法故于彼尊重。起于净信持以饮食。生如是心。我为求正。法故以此饮食而为献施。以前布施之法比此善根。百分不及一。乃至乌波尼杀昙分亦不及一。如来秘密经云。所有菩萨福蕴。若比摄受正法福蕴。此复倍多。正使一切诸佛勤劬宣说经俱胝劫。尚不能得受持正法福蕴边际。何等正法。如胜鬘师子吼经云。此正法者即是大乘增语。何以故。大乘出生声闻缘觉之乘及世出世间一切。善法故。法集经云。彼正法摄受者。所谓于一切如来诸说甚深甚深经典。宣说讲授专注思惟。是为正法摄受。当知诸菩萨。若依著有所得行。虽经无量时供养诸如来。于彼彼佛所然不得授记。况复成菩提。如梵王问经云。佛言。大梵。我于一劫若过一劫。宣说彼彼如来名字。若我供养是诸如来。或复于彼我修梵行及修六波罗蜜多。我于彼彼佛所未得授记。何以故。我于有所得行而依着故。若我尔时于然灯如来所。才见彼佛即得无生法忍。彼佛世尊与我授起。我于尔时超过一切有所得行。而复圆满六波罗蜜多。于甚深法中能生信解。所有诸菩萨自利利他最胜诸行。悉得周毕。大集经月藏品云。佛言。月藏。彼胜义谛即能成就阿耨多罗三藐三菩提。不共一切声闻缘觉所有。是故世俗谛不能成就阿耨多罗三藐三菩提最上善根及办诸胜行。月藏如人持以爝火不能枯涸甚深大海。彼世俗谛亦复如是。尚不能涸自烦恼海。况复为他诸有情类。此中何能信解甚深之法。如菩萨藏经云。菩萨有二种慧。一者从他声闻。二者自心深固作意。此中何等是从他声闻。若有菩萨虽复乐修诸相应行。然于菩萨藏正法不乐听受。又不乐闻诸圣法律。于定中少味而为喜足。慢心炽盛故堕增上慢。而彼菩萨不能解脱生老病死忧悲苦恼。亦不解脱六趣轮回。又复不能解脱苦蕴。以彼缘故如来说言从他声闻。而此所闻不能解脱老死等法。何等是为深固作意。所谓菩萨自作是学。无所有法而可和合非不和合。是深固行。此深固行即是非行增语。彼如是声。若前际若后际。如实伺察。从何所生复从何灭。又若言说若义理。若断若证。若已说若当说。彼等一切如实伺察。无过去相无未来相无现在相可得。即一切法自性寂灭。自性寂静自性圆满。毕究无生无起无实。应观诸法毕竟涅槃。若如是观即无所观亦非无观。此名正观。况复一切法如实可观邪。是即无所观。此无所观亦即无生增语。若一切法无生即不越正理。若一切法平等即佛法平等。如是所说。是为不越。正理。此说名为深固作意。如是乃能解入最上甚深正法。父子合集经云。佛告净饭王言。大王。若或空劫时中。或有梵天楼阁出现于前。七宝所成彼坚实性。若生起时从何所来。如是欲界他化自在天。化乐天。兜率天。夜摩天。忉利天。四大王天。是等诸天楼阁悉现七宝所成。又铁围山大铁围山。坚实一聚金刚所成。是等诸山彼坚实性从何所来。又须弥山。儞民达啰山。持双山。持轴山。持金刚山。朅那里酟山。尾那怛酤山。马耳山。善见山。大善见山。乌咎誐卢山。香醉山雪山。及余黑山。悉现于前。乃至一切三千大千世界。而悉出现。且彼须弥山王去地八万由旬。其坚实性悉集现前从何所来。大王。若此世界成后。大地火然。大水漂流。大风鼓击。其火亘空所有烟烬悉无所现。如酥或油投火中烧亦无烟烬。其水漂时无余可得。如盐投水而悉混融亦无有余。其风鼓击无少物可现。如毗岚风当吹鼓时。何有飞鸟而可得现。此三千大千世界亦复如是。火然水漂风鼓之时。无余可见。彼坚实性如是坏灭。从何所去。此说外地界内地界亦然。及余诸界若内若外亦复如是。是故一切法生时无所从来。灭时亦无所去。彼等有生决定皆空。生已亦复自性皆空。阿阇世王经云。尔时阿阇世王。于其宫中饭佛世尊及诸菩萨声闻大众。盥手涤器已。于妙吉祥菩萨之前。肃恭而坐听受正法。王言。菩萨愿今为我解除恶作。妙吉祥言。大王。假使殑伽沙数等诸佛世尊亦复不能为汝解除恶作。阿阇世王闻是语已惊怖无救烟绝躄地。是时尊者大迦叶即告王言。止止大王。勿生惊怖。此妙吉祥菩萨善能为汝说自因缘。应作是问。以何缘故菩萨作如是说。时阿阇世王从地徐起。白妙吉祥菩萨言。以何缘故菩萨作如是说。妙吉祥言。大王。于汝意云何。汝心有所缘观佛世尊邪。王言。不也。妙吉祥言。汝今云何观心生邪。王言。不也。妙吉祥言。观心灭邪。王言。不也。妙吉祥言。观有为法邪。王言。不也。妙吉祥言。观佛世尊于有为法有表示邪。王言。不也。妙吉祥言。大王。于汝意云何。若诸法中无法可观者。而容有法可解除邪。王言。不也。妙吉祥言。大王。以此缘故我作是说。假使殑伽沙数等诸佛世尊亦不能为汝解除恶作。复次大王。若此空中或烟或尘欲染虚空。于汝意云何是彼烟尘能染空不。王言。不也。妙吉祥言。大王。又或有人作如是言。我欲清净虚空。而彼虚空其能净不。王言。不也。妙吉祥言。大王。如来亦复如是与虚空等。说一切法本来相续自性无染。彼无有法若染若净而实可观。是中复何有所解除。大王。我于是义如实正观故作是说。假使殑伽沙数等诸佛世尊亦不能为汝解除恶作。复次大王。诸佛世尊内心非有所得非有所起。外亦非所得非所起。何以故。一切法自性无所起。若法自性无所起故。即无处容受有所起性。何以故。一切法自性无所起故即无所成。一切法无所成故即无所集。一切法无集故即无出生。一切法无出生故即法离性。一切法离性故即无能作行。一切法无能作行故即无有生。一切法无有生故即无异熟法。一切法无异熟故即无起作。一切法无起作故即无所染。一切法无染故即自性明亮。一切法自性明亮故即法清净。一切法清净故即虚空等。一切法虚空等故即无对治。一切法无对治故即离于二。一切法离二故即离二边。一切法离二边故即法无边。一切法无边故即无涯际。一切法无涯际故即无究竟。一切法无究竟故即无所缘。一切法无所缘故即于一切处无颠倒住。一切法于一切处无颠倒住故即常乐我净悉不可得。一切法常故即无动转相应。一切法净故即自性明亮所成一切法乐故即无分别相应。一切法我自性故即无我表示相应。一切法无恶作故即内心寂止。一切法无实故即胜义谛无所安立。一切法寂静故即遍寂相。一切法无我故即我我所相离。一切法无味故即解脱相。一切法离名故即名差别不可得。一切法无分别故即种种性离。一切法一味故即解脱普摄。一切法离相故即无相际。一切法无相故即无解了所缘清净。一切法空故即一切见作皆离。一切法无愿故即超越三世。一切法三世断故即过去未来现在皆不可得。一切法涅槃普摄故即毕竟无生。大王。于汝意云何。若法无生复无积集。是中还能有所染不。王言。不也。妙吉祥言。又复有法可解除邪。王言。不也。妙吉祥言。大王。由如是故如来知一切法与涅槃等。乃于是中无有恶作而能解除。是故大王。彼深固相应。当如是行。以无颠倒心应当如实作其伺察。如伺察已随伺察时。无有少法可取可舍亦无有法而可共住。若一切法不共住故。此说是为轻安。若法轻安即法寂静。若法寂静是即法自性。若法自性即无自性。一切法无自性故即无主宰。大王。于中应作忍法。即此亦复无法可作。何以故。大王。所作寂静故。如是了者当证涅槃。此中亦复无法可作。亦非无作。若作若非作。此说皆归涅槃寂静

大乘宝要义论卷第七大乘宝要义论卷第八

        译经三藏朝散大夫试鸿胪少卿光梵大师赐紫沙门臣惟净等奉　诏译

尔时阿阇世王。持以价直百千上妙[疊*毛]衣献施妙吉祥菩萨。而菩萨不肯受之。其王即以此妙[疊*毛]衣被妙吉祥菩萨之身。衣未着身。菩萨即时隐而不现。王既不见菩萨之身。但闻空中声曰。大王。汝若能见妙吉祥菩萨身相。即能见汝所有恶作。若见恶作。如是即见彼一切法。如见一切法亦然可见所施[疊*毛]衣。若汝不能见亦然如是见。大王。汝若能见。有身相者。如是乃以[疊*毛]衣奉施。其王即时复以[疊*毛]衣。各各遍施一切菩萨声闻大众。及其宫人婇女眷属。而悉不见彼彼身相。其王即时入定观察。都无少色为眼所见。无境相可现。是中唯存自身想转。又闻如是空中声曰。汝若能见自身相者。如是乃以[疊*毛]衣奉施。王即自观亦不见有自身之相。尔时乃离一切色想。又闻空中声曰。大王。汝若如是无少色相若粗若细而可见者。亦然如是应见恶作。亦然如是见一切法。若汝不见彼即离见。彼离见中若汝可见此即非见。大王。若非见若非不见。此为正见。若如是见一切法者亦即非见。大王。此非见者。是为正见。尔时阿阇世王于一切法所对疑惑悉得远离。从定起已重复观彼一切大众亦悉不见。幻士仁贤经云。菩萨有四种法思惟经义。何等为四。一者缘法生起非无作因。二者无法可生亦无补特伽罗性。三者若法缘生彼生无性。四者于甚深法中无差别门。亦不坏菩提。菩萨十住经云。佛言。妙吉祥。诸菩萨有五法令得安隐能清净初地。何等为五。一者若于无所缘解脱智中自安住已。复令他人亦悉安住无所缘解脱智中。是为菩萨得安隐法。二者此无所缘解脱智即无二无二清净缘法无生。此解脱中自安住已。复令他人亦悉安住缘法无生解脱法中。是为菩萨得安隐法。三者彼缘法无生即诸缘自性无生一切法无所有处。此解脱中自安住已。复令他人亦悉安住一切法无所有处解脱法中。是为菩萨得安隐法。四者彼一切法无所有处即诸分位分别悉无自性智观如虚空。此解脱中自安住已。复令他人亦悉安住如虚空智解脱法中。是为菩萨得安隐法。五者此如虚空智即无杂乱无依止离心意识之智。此解脱中自安住已。复令他人亦悉安住离心意识之智解脱法中。是为菩萨得安隐法。当知彼中离心意识之智。即是无发悟。有所得智是为五法。胜思惟梵天所问经云。梵天问光网菩萨言。一切法深固邪。一切法非深固邪。菩萨言。如汝梵天。复云何说。一切法是深固非深固邪。梵天言。若非思惟即一切法深固。若心与思惟有所和合即非深固。又一切法离相此即深固。若复离中有所和合此即是为差别所行。若差别中有所行者。即诸所作皆非深固。菩萨言。若尔者云何诸法而可生乎。梵天言。善男子。若自境界离清净实际中诸法乃生。七百颂般若波罗蜜多经云。佛言。妙吉祥。汝修般若波罗蜜多时。当何所住而修般若波罗蜜多。妙吉祥白佛言。世尊。我修般若波罗蜜多时。都无所住而修般若波罗蜜多。佛言。妙吉祥。无住云何修般若波罗蜜多邪。妙吉祥言。世尊。我修般若波罗蜜多时。实无法可住。佛言。妙吉祥。汝修般若波罗蜜多时。有何等善根若增若减。妙吉祥言。世尊。我于彼时无少善根若增若减。世尊。诸修般若波罗蜜多者。悉无有法若增若减。妙吉祥菩萨神变品云。有天子白妙吉祥菩萨言。如汝所说。少能有人解了其义。妙吉祥言。天子。以我所说佛智甚深。若少若多不能解了。何以故。佛智无著。无分别。不可记。不可说。非作用。非语言道。离心意识。若少知若遍知。非易解了。天子言。若佛智不能知者。而诸声闻何能解了。菩萨云何住不退转。妙吉祥言。天子。如来以善方便假文字智随为开觉。是智无文字。譬如火中求火其何所得。天子。如来亦复如是。若最初便说广大佛智。即无有情能知佛智。是故如是宣说种类之语开示彼智。是智无文字。天子言。妙吉祥。何等是为种类之语。妙吉祥言。天子。若说持戒及制止法。或说般若波罗蜜多相应之法。或说入解菩提分法。此等所说。是为种类之语。天子。若说离生离灭之法。离杂非杂之语。离染离净之语。不厌离生死之语。不忻乐涅槃之语。无知无断无修无证无得。亦无现前三昧可转。此等所说。是为清净真实之语不思议音声。一切法决定无所得经云。佛问妙吉祥言。诸如来所说不思议不思议界。当云何是。妙吉祥言。此不思议不思议界者。是诸如来说。世尊。界离思惟非心所行。非心所量非心法拣择。世尊。此心如是是即不思议界。何以故。无心可思惟。此心离思惟故。即心自性亦无所有。而此无思惟心。是心如实。世尊。此乃是为不思议界。此经又云。佛言。妙吉祥。汝勿应便被此铠化度有情。妙吉祥言。世尊。若知有情界不增不减。是中何有有情而可化度令入涅槃。世尊。若彼虚空有人能度者。彼有情界亦可化度。又欲以菩提心有所化度者。而彼有情亦可发起为作化度。世尊。一切法是菩提。亦非菩提染净可得。是故世尊作如是说。汝勿被此铠化度有情。世尊。有情非染。我亦不住度有情心。何以故。世尊若有有情即有染净而为表示。既无有情岂有染净可表示邪。世尊。若法有者从缘而生即不相违。世尊。缘生法中而实无染无净可得。以一切法自性无实缘生性故。若于缘中亦无缘义染净可得。世尊。此无所有义缘生之义。智者了知。又复如是缘生之义。智者于中悉无分别。若于无分别义中即无染无净。譬如幻师或幻师弟子幻出楼阁或复舍宅。具有光焰广大炽盛。或有人言。我能勇力于彼楼阁光焰聚中而为止息。是人乃至损坏其身。徒生疲极终不能成。佛言。妙吉祥。如是如是。妙吉祥言。世尊。若被精进铠化度有情亦复如是。徒自疲极终无所得。此经又云。佛言。妙吉祥。汝当如实伺察为是何法增语。妙吉祥言。此谓如实伺察者。然如实伺察中彼无一性。无种种性而可造作。世尊。若无种类无分别中作如实伺察。即非如实伺察。世尊。即此非如实伺察。是为增语。是故若如实伺察成已。是中不起我是凡夫我是圣人之见。何以故。诸法无所观。若法不立凡夫圣人之见。即得如实伺察成就。世尊。若善男子善女人。能如是住者。即得法界相应。是中无有少法若平等若差别可得。若谓凡夫法差别亦无分别生。若谓圣人法平等亦无分别生。何以故。所缘不可得故。若于所缘中或平等差别有所取者。此即分别。是分别性都无所有。若彼彼所缘中有平等差别而可取者。即我法彼法乃有差别。凡如是等应知决定无法可取。维摩诘经云。何为病本。谓有攀缘即为病本。若有攀缘即有其病。何所攀缘谓之三界。若无攀缘彼何所表。若攀缘不可得即无所得。云何无所得。谓二见无所得。何谓二见。谓内见外见。彼无所得。此经又云。爱见菩萨言。色空为二。色即是空。非色灭空。色性自空。如是乃至识即是空。非识灭空。识性自空。此等五蕴若解了者。是为入不二法门。般若波罗蜜多经云。舍利子问尊者须菩提言。若菩萨摩诃萨修行般若波罗蜜多时。云何能知善巧方便。须菩提言。尊者舍利子。若菩萨摩诃萨修行般若波罗蜜多时。不行色不行受想行识。不行色有相。乃至不行受想行识有相。不行色非常非无常。非苦非乐。非我非无我。非寂非动。非空非不空。非相非无相。非愿非无愿。非离非不离。如是乃至不行识非常非无常。乃至非离非不离。五蕴如是所有界处缘生菩提分法。神通波罗蜜多。力无畏无碍解不共佛法等。乃至非离非不离。而悉不行。何以故。尊者舍利子。色不异空空不异色。色即是空空即是色。乃至识不异空空不异识。识即是空空即是识。如是界处缘生。乃至不共佛法不异空。空不异不共佛法。不共佛法即是空。空即是不共佛法。菩萨摩诃萨若如是修行般若波罗蜜多。是即能知善巧方便。而彼菩萨于般若波罗蜜多亦不念我行不念我不行。不念我亦行亦不行。不念我非行非不行。何以故。无性自性即是般若波罗蜜多故。此经又云。佛言。憍尸迦。善男子善女人。宣说般若波罗蜜多时。或有诽谤般若波罗蜜多者。何等是为诽谤般若波罗蜜多邪。所谓若说色是无常是苦无我不净。如是受想行识及界处禅定无量无色定。念处正勤神足根力觉道圣谛。无所畏无碍解不共佛法。乃至一切相智。是无常是苦无我不净。若如是行。是行般若波罗蜜多。作此说者。是为诽谤般若波罗蜜多。何等是不谤般若波罗蜜多。谓若说言。善男子。汝修般若波罗蜜多时。勿观色无常。勿观色苦无我不净。乃至一切相智亦复如是。何以故。色自性空故。若色自性空。是即般若波罗蜜多。若般若波罗蜜多中无色为常可得。彼色如是无所有故。况复若常若无常而可得邪。受想行识乃至一切相智亦复如是。作此说者是即不谤般若波罗蜜多。又若说言。善男子。汝修般若波罗蜜多时。勿谓有法而可过越。勿谓有法而可安住。何以故。般若波罗蜜多于一切法中无所有故。若法不过越无所住。即一切法自性皆空。若法自性空即法无性。若法无性是即般若波罗蜜多。此般若波罗蜜多中。即无有法若出若入若生若灭。如是说者。是即不谤般若波罗蜜多。又须菩提白佛言。世尊。般若波罗蜜多。云何有所得。云何无所得。佛言。须菩提。若法有二即有所得。若法无二即无所得。须菩提言。世尊。云何为二。佛言。须菩提。眼色为二。意法为二。乃至菩提法佛法为二。须菩提言。世尊。有所得是无所得邪。无所得是无所得邪。佛言。须菩提。非彼有所得是无所得。亦非无所得是无所得须菩提。若有所得若无所得而悉平等。此即是为无所得。复次须菩提言。世尊。岂不住胜义谛中证阿耨多罗三藐三菩提果邪。佛言。不也。须菩提言。住颠倒法中邪。佛言。不也。须菩提言。若不住胜义谛中。又不住颠倒法中。成正觉者岂非如来不证菩提果邪。佛言。须菩提。我证菩提果。然于有为界中无为界中悉无所住。又复佛言。须菩提我不能以无性中无性而成正觉。须菩提言。世尊。岂不以有性中无性能成正觉不。佛言。不也。须菩提言。若以无性中无性能成正觉不。佛言。不也。又须菩提。我于金刚般若波罗蜜多经中。曾谓汝言。须菩提。于汝意云何。如来得阿耨多罗三藐三菩提邪。如来有所说法邪。须菩提言。如我解佛所说义。无有法如来得阿耨多罗三藐三菩提。亦无有法如来可说。何以故。若有法如来所说者。彼不可取不可说。非法非非法。所以者何。一切贤圣皆以无为法而有差别。如来但为化度有情故。以善方便开种种门。宣说如是甚深正法

大乘宝要义论卷第八大乘宝要义论卷第九

        译经三藏朝散大夫试鸿胪少卿光梵大师赐紫沙门臣惟净等奉　诏译

如入楞伽经中。大慧菩萨问如来藏。佛言。大慧。何故汝今问于如来自性明亮清净本来清净如是之说。如来具三十二相。在一切有情身中。如无价宝为弊垢衣之所缠覆。蕴处界衣缠覆亦然。彼贪嗔痴不实计执。此之垢染是无常法。是不坚牢。是不究竟。大慧白佛言。世尊。外道所说神我之语。何故不能等比如来藏语。以外道说神我是常。我能造作。离系自在而永不灭。彼说如是神我之语。佛言。大慧外道我语不可等比如来藏语。大慧。然我所说实际涅槃无生空无相无愿等诸句义。如来应供正等正觉。为诸愚者令离无我惊怖之法。故以方便说无分别无所对碍如来藏门。此中亦非未来现在。诸菩萨摩诃萨着我所作。大慧。譬如窑师取土成泥用水及绳并其工具勤力所作成种种器。如来亦复如是。住法无我离分别相。故以种种胜慧方便善巧相应。或说如来藏。或说无我法。以多妙巧文句言词譬喻而说。以是缘故外道我语不可等比如来藏语。大慧。又我所说如来藏语。但为降伏诸外道辈执我语者。故以方便说如来藏。如是等辈何故意乐堕在无实主宰计执见中。若于三解脱门意乐具足。即能速证阿耨多罗三藐三菩提果。以是义故如来应供正等正觉所说如来藏法与外道我语不可等比。是故大慧。为令外道离诸见执。使其当得随顺如来无我藏法。此所宣说。是谓无上成就究竟之法。是谓诸菩萨空无生无二无自性法。是谓甚深之法。若有宣说及受持者。即能普摄一切大乘经中甚深之义。何以故。此甚深法于一切法一切经中摄故。此经又云。大慧。此空无生无二无自性相。普摄一切诸佛及一切经典故。月灯三昧经中。如来说偈云

  三千大千世界中　　我所宣说诸经典
  种种文句皆一义　　故复不能周遍说
  乃至一切诸如来　　及广宣说多种法
  于一句中修学已　　一切修习得成就
  一切诸法皆空性　　若人于义明解了
  此句义中学所成　　而诸佛法不难得
  于甚深法能信解　　获得一切胜福生
  诸有世间出世间　　办所作事至成佛

宝授经云。复次妙吉祥。若菩萨经百千劫善修六波罗蜜多具善巧方便。若有人于此正法勤求听受者。比前福蕴此复倍多。何况以无所求心听受书写为他广说。金刚般若波罗蜜多经云。佛言。须菩提。于汝意云何。殑伽河中所有沙数。彼一一沙为殑伽河。是诸河中所有沙数宁为多不。须菩提。言诸殑伽河尚多无数。何况其沙。佛言。须菩提。我今实言告汝。若善男子善女人。于诸殑伽河中所有沙数如是沙等世界。以七宝满尔所世界。持用布施诸佛如来。是善男子善女人。以是缘故得福多不。须菩提言。甚多世尊。甚多善逝。佛言。须菩提。若有人于此正法乃至受持一四句偈为他说者。其福胜彼。梵王问经云。仁者。若善男子善女人。于如来所乐修福事者。应当于此正法听闻信解及受持等即能获得色相富盛广多眷属于法自在。人天之中受诸快乐。舍利子说般若波罗蜜多经云。舍利子白佛言。世尊。若复有人得闻说此般若波罗蜜多。闻已信解者。是人即于菩提得不退菩。慈转氏萨言。世尊。若有闻说此般若波罗蜜多闻已信解者。是菩萨即得近佛果位。妙吉祥菩萨言。世尊若有闻说此般若波罗蜜多。闻已信解者。见是菩萨当如佛想一切罪染恶作而悉解除。一切业障皆得清净。于甚深法能生胜解。如来藏经云。佛言。迦叶。最极十不善业者。所谓一者假使有人缘觉为父而兴杀害。是为最极杀生之罪。二者侵夺三宝财物。是为最极不与取罪。三者假使有人阿罗汉为母而生染着。是为最极邪染之罪。四者或有说言我是如来等。是为最极妄语之罪。五者于圣众所而作离间。是为最极两舌之罪。六者毁呰圣众。是为最极恶口之罪。七者于正法欲杂饰为障。是为最极绮语之罪。八者于其正趣正道所有利养起侵夺心。是为最极贪欲之罪。九者称赞五无间业。是为最极嗔恚之罪。十者起僻恶见。是为最极邪见之罪。迦叶。此等是为十不善业。皆极大罪。迦叶若一有情有如是罪具行十不善业者。如来即为宣说因缘和合之法使令解入。尔时亦无我人有情寿者之想。若能解了此法无作无为如幻之法。离染清净自性明亮。解一切法本来清净。于一切法净信胜解者。我不说彼有情堕于恶趣。何以故。无诸烦恼聚性可得。生已即时一切破散。故知诸烦恼一聚因缘和合所生。生已即灭。若起心遣除。而诸烦恼随即有生。若如是信解者。彼复何有罪之分位。无处容受故若言有诸罪障而可住者。无有是处。持律优波离尊者问降魔品云。汝诸恶魔云何是苾刍真持律行。魔言。尊者。若苾刍了知一切法毕竟调伏。诸罪本来无前后际。离边际故。若犯堕罪及余恶作。而悉解除勿生坚着。以如是法为他开示。彼之所有五无间罪。尚悉蠲除。况复少略破戒垢染。解是法律者。不为客尘烦恼所染。生出离想。知诸烦恼非内非外亦非中间。非离染智能除烦恼。离染之性亦不可遣。智者如实观诸烦恼。犹如浮云风飘流散。随所向方何适何住又诸烦恼如水中月。遍计影像对现其前。又诸烦恼是黑暗境界慧灯光明而能照破。又烦恼贼窃害色相如夜叉罗刹。若深固作意如实观察。即无所住。又诸烦恼常伺其便。若不深固作意。即烦恼增长于空无相无愿智慧法中即不违害。又于如是诸烦恼中。智者以智于彼染着烦恼诸有情所对住其前起悲愍心为说无我无有情法。令其离染。此即是为真实持律。阿阇世王经云。佛言。阿难。我今实言告汝。若有造五无间罪者。得闻如是正法已能生胜解。我不说彼人有业及业障。阿难。以要言之。此所宣说甚深正法。应生胜解广大称赞。数于彼彼经中专勤听受不离善巧方便菩萨应当如是勤行说甚深法。是故慧及方便二法不离。是为菩萨相应正法。维摩诘经云。无方便慧缚。有方便慧解。何谓无方便慧缚。若菩萨于空无相无愿法中调伏其心。不以相好庄严佛土成熟有情。此即是为无方便慧缚。何谓有方便慧解。若菩萨能以相好庄严佛土成熟有情。于空无相无愿法中调伏其心。习力勤行而不疲懈。此即是为有方便慧解。何谓无慧方便缚。若菩萨于诸见烦恼生起随逐有所住着。然复发起一切善根回向无上菩提。此即是为无慧方便缚。何谓有慧方便解。若菩萨于诸见烦恼生起随逐断诸有着。而发起一切善根回向无上菩提悉无所取。此即是为有慧方便解。此等慧及方便二法和合。当知皆是菩萨之行。云何是菩萨行。所谓非凡夫行。非贤圣行。是菩萨行。在于生死不为染污。在于涅槃不永寂灭。是菩萨行。虽求四谛智亦不非时取证涅槃。是菩萨行。虽观内空而常思念于三有中示现受生。是菩萨行。虽观无生而不入正位。是菩萨行。虽摄一切有情而不染着。是菩萨行。虽行于空而常勤求诸相功德。是菩萨行。虽行无作而勤修一切善行获得轻安。是菩萨行虽修止观之行而不毕竟堕于寂灭。是菩萨行。虽转法轮示现大般涅槃而不舍菩萨所行之行。是菩萨行。凡如是等皆是菩萨所行之行。降魔经云。复次所有诸菩萨摩诃萨最上正行。谓即胜慧智增上相应。若方便智即普摄一切善法之行。胜慧智者即无我无人无有情无寿者无儒童等。方便智者即成熟一切有情之行。胜慧智者即遍摄诸法之行。方便智者即正法摄受之行。胜慧智者即一切佛法界无分别行。方便智者即一切佛法尊重供养承事之行。胜慧智者即一切佛刹如虚空行。方便智者即一切佛刹功德庄严之具作清净庄严之行。胜慧智者即一切贤圣修无为行。方便智者即于一切师尊所起尊重心。施作种种作用之行。胜慧智者即观察佛身无漏之行。方便智者即修佛相好之行。胜慧智者即观察一切行无生无起之行。方便智者即常思惟于三有中示现受生之行。无尽意经云。何等是为菩萨方便。复何等是菩萨胜慧。所谓若入定时起大悲所缘深固之心观察有情。此即方便若于定中住寂遍寂。此即胜慧。若入定时起大悲心随顺佛道。此即方便。若无所有依止观察。此即胜慧。若入定时观察普摄彼一切法。此即方便。若观法界无所分别。此即胜慧。若入定时佛身庄严所作现前。此即方便。若观察法身分位。此即胜慧。维摩诘经云。佛言。慈氏。菩萨有二相。一者信乐杂句文饰。二者不畏甚深之法。如实解入是为二相。若菩萨信乐尊重杂句文饰者。当知是为初学菩萨。若复于此清净甚深经典。普摄种种文义差别之门。听受宣说生胜解者。当知是菩萨久修梵行。复有二法。是即初学菩萨为自毁伤。不于甚深法中调伏其心。一者于昔未闻甚深经典。闻已惊怖生疑亦不随顺。返生轻谤作如是言。我昔未闻此法从何所来。二者于大法器宣说甚深法者。善男子所不乐亲近亦不尊重。或时于中密说其过。是为二法。复有二法。菩萨虽信解甚深之法亦自毁伤。不能速证无生法忍。一者轻毁初学菩萨不为摄受。不为决择复不教诲。二者虽信解甚深之法。而不习学亦不尊重。不行财施法施摄受有情。是为二法。此中应知。若诸有情解入诸佛菩萨大威德力。斯极难得。何等是为菩萨大威德力。维摩诘经云。维摩诘言。大迦叶。所有十方世界现作魔王者。皆是住不可思议解脱菩萨。以善方便成熟有情故现魔相。又十方世界或有菩萨从其求乞手足耳鼻血肉筋骨头目身分妻子奴婢人民国邑象马车乘。凡如是等或来求者。皆悉给施。菩萨以如是相故行逼迫。此等皆是住不可思议解脱菩萨。迦叶。譬如龙象蹴踏非驴所堪。凡夫亦复如是不能如是逼迫菩萨。而菩萨者乃能如是逼迫菩萨

大乘宝要义论卷第九大乘宝要义论卷第十

        译经三藏朝散大夫试鸿胪少卿光梵大师赐紫沙门臣惟净等奉　诏译

如华严经云。法界行愿分位宣说菩萨无尽佛种世界世尊普遍智境界音声如来。从彼刹中来至世尊释迦牟尼如来之前。出现菩萨威德身相。所谓一切身分。一切相好。一切毛孔。一切庄严。一切衣服及缘具等。一切菩萨眷属具足所有世尊大毗卢遮那如来。前际中住过去一切如来。后际中住若已受记及未受记未来一切如来。现在十方一切佛刹普遍安住一切菩萨。昔所修习布施波罗蜜多相应先行海。一切受者及所施物皆悉影现。一切身相一切毛孔诸相好等。亦悉对现而为表示。又复身诸分位及语言道。一切衣饰众缘具等。而亦对现一一表示。又昔修习持戒波罗蜜多相应先行海。又诸忍辱波罗蜜多示现割截身诸分位相应先行海。又诸菩萨加行精进相应先行海。又诸如来广大静虑办事相应先行海。又诸如来转大法轮法事成办舍诸所有自在身相诸门影现一一表示相应先行海。又诸如来喜见诸菩萨道一切世间最上爱乐相应先行海。又诸菩萨诸胜愿海增上法门广大庄严相应先行海。又诸菩萨力波罗蜜多诸行成办清净相应先行海。又诸菩萨广大法界一切神变云广大所作诸菩萨智境界相应先行海乘。如是等十波罗蜜多影现表示。广大法界一切广大诸神变云来诣佛所。于是菩萨并其眷属顶礼佛已。住于上方。化现一切金刚帝宝心庄严藏大楼阁中金刚帝青莲华师子座上加趺而坐。现诸宝焰摩尼王网弥覆其上。复以三世一切如来音声宝王缨珞垂挂庄严。顶戴摩尼宝冠。现菩萨身加持而住。而此菩萨并其眷属。皆从普贤菩萨行愿出生。于一切如来足根门中表现清净。智眼所观闻一切如来法轮经中理法音声胜海。普摄一切菩萨得诸自在。及得最上波罗蜜多。一切如来皆悉云集。于刹那刹那中广现神变。出现诸有情身广大境界。一切如来众会道场身中光明显照一切世界。于一世界中普摄影现。诸境界相如微尘聚。所有一切有情善根成熟。应化度者而悉应时能来应现。一切如来转法轮云。一切毛孔吼音境界。一切世界普遍。一切善根出生。生已即时诸有情身皆悉平等。一切方分云海一心刹那广现神变。此经又云。菩萨大威德力者。尔时善财童子谛观普贤菩萨身相。乃见菩萨一一身诸分位一一身诸分位分明。一一界体一一界体细分分明。一一身分各别分位。一一身分各别分位分明。一一依聚。一一依聚分明。一一毛孔。一一毛孔分明。现此三千大千世界所有风火地界。并大海洲渚江河宝山。及须弥山铁围山等国土城邑聚落方处树林舍宅。并诸人民地狱饿鬼畜生之趣。阿修罗界龙界迦楼罗界。人界天界及其梵界。欲界色界无色界。是诸境界。悉以神力加持而住。乃至形色显色云电星宿。昼夜圆半月时年分。住劫坏劫。现如是等此世界相已。所有东方一切世界亦如是观。南西北方四维上下一切世界。如应对现所观亦然。又诸佛降生众会道场。及有情等所有此娑婆世界。前际中住过去。一切世界一切互相。皆见普贤菩萨一一身中大人之相。并诸佛降生一切菩萨众会道场。及有情舍宅昼夜劫数等。如是后际中住未来一切世界佛刹等普遍一切亦然。皆见如此娑婆世界前际后际中住一切世界一切互相见诸影相。如是十方前际后际中住一切世界。一切皆见普贤菩萨一一身中大人之相一一毛孔中一一分明互相无杂。皆见普贤菩萨在世尊大毗卢遮那如来之前坐于大宝莲华藏师子座上现游戏神通。时此东方莲华吉祥世界贤吉祥如来。见此所现游戏神通。东方如是普遍十方一切世界亦然。皆见一切如来足根门中各有普贤菩萨坐于大宝莲华藏师子座上现是游戏神通。如其十方一切世界悉见一切如来足根门中有普贤菩萨坐于大宝莲华藏师子座上现是游戏神通。时如是普遍十方一切佛刹如微尘数。一一微尘数皆是广大法界佛会道场。悉见一切如来足根门中有普贤菩萨坐于大宝莲华藏师子座上现是游戏神通。时一一身相悉得三世一切所缘影相表示。所有一切刹土一切有情诸佛降生诸菩萨众会道场影现表示。时普闻一切有情语言。一切佛音声一切如来转大法轮一切宣说教授神通变化一切菩萨集会诸佛游戏境相音声此等总略如其所说。当知皆是菩萨摩诃萨大威德力。此中应问。何等是如来大威德力。如菩萨十地经云。解脱月菩萨问金刚藏菩萨言。佛子。诸菩萨行境界如是。加持神力尚复无量。云何能入如来行境界邪。金刚藏菩萨言。佛子。譬如有人于四大洲世界之中取小石块。若二若三如豆之量。作如是言。大地世界颇有过于此邪。或无量邪。说是语者。如汝今时以诸如来应供正等正觉无量智法与菩萨法而相等比。佛子。四大洲世界如所取者豆量石块。而极少分。余无有量。如来境界亦复如是。且法云地菩萨所有功德。经无量劫犹尚不能说一少分。何况如来无量智境。佛子。我今实言告汝。于如来前为我作证。假使十方无边世界如微尘等一切佛刹证菩萨地者。其数充满。如稻麻竹[竺-二+韋]甘蔗丛林。彼等菩萨经无边劫。宣说开示如来所有一智境界。百分不及一。乃至俱胝那由他百千及譬喻分亦不及一。入如来功德智不思议境界经云。佛言。妙吉祥。今此会中或有有情。谓佛如来初始出家。或谓久已出家。或谓修诸苦行。或坐菩提场成等正觉。或破诸魔军。或梵王帝释护世劝请转大法轮。或闻宣说声闻乘法。或说缘觉乘法。或说大乘之法。或睹佛身高一寻量。或见佛身高一俱卢舍。或见佛身高显过诸由旬百千数量。或见佛身如真金色。乃至或见如摩尼宝色。或见如来寂静身相。或见如来入涅槃相。或见如来一聚身相。或见分布如来舍利。或谓十年成等正觉。或谓十年入大涅槃。或谓有于世尊释迦牟尼如来教中得圆满者。或隐没者。或谓若十二十三十四十。乃至百千俱胝那由他劫入大涅槃。或谓世尊释迦牟尼如来。于不可说不可说劫成等正觉。妙吉祥。于如是等差别之相。如来悉非分别非离分别。而佛如来以无发悟无分别法。常随有情心作诸行相。菩萨十住经云。佛言。妙吉祥。有多种说者。如有大池纵广正等五十万由旬。池岸平坦池水清甘。复有莲华遍覆池内。若或有人。以铁所成千辐轮车而以骏马。胜迦楼罗迅疾势者而驾驭之。其车行得不着池水。马迹亦复不践莲华。妙吉祥。如来亦复如是。乘于大车游彼大池中。有毒蛇鼓水腾踊。若刹那间。而彼毒蛇随车后转。其车即时七返右旋。若复毒蛇随彼大车一返右旋。其车即时右旋无数。如阿难等诸大苾刍说法亦然。有时阿难说十种法表示其义。若复阿难说一种法即时舍利子。说千种法。表示其义。若复舍利子说一种法。即时大目干连过八万世界。若复大目干连过一世界。即时如来于十方法界。最上自在越虚空际。普遍一切世界海。一一世界。一一洲渚。一一凡夫道中。示现从兜率天宫没下降人间入胎住胎出胎。梵王帝释承接沐浴庄严。周行七步观察十方作师子吼。习学一切工巧伎艺明论事业现处太子之位。于王宫中嬉戏娱乐游赏园林。出家苦行。食乳糜粥已。诣菩提场坐成正觉。摧伏魔军观树经行。大梵天王请转法轮。入忉利天宫等。国土分量劫名次第。威德身相寿量多少。众会庄严佛刹清净。教法庄严发菩提心。修诸行愿成波罗蜜多。圆满诸地神通智忍。具总持三摩地诸解脱门。如来无量。诸供养事无量。如来及菩萨法境界无量。法云广大所行分量。成熟有情方便分位差别之量。起大游戏神通变化。示现一乘大般涅槃。分布舍利分别教法。住时久近及法灭时。皆从如是大法池中之所出现。又复于诸外道所修行处。及一切有情所应作事。如来以无发悟无分别心。同时悉现于后边际究竟分位。勤勇示现。凡如是等刹那俱时十方一切一一自身毛孔之中。所有遍诸方分三世一切如来及诸菩萨众会之海。广大一切佛刹功德庄严。诸有情聚舍宅宫室广大庄严。诸有情聚眼耳鼻舌身意处广大施设。诸菩萨行皆悉积集广大庄严。一切如来境界广大庄严。如是等相如来俱时以无发悟无分别心普遍示现。于后边际究竟勤勇刹那俱时。普摄一切十方世界。乃至凡夫道中有尽无尽无复遗余。诸有情界一切有情一一有情各各身相形色显色音声语言譬喻说法。凡如是等分量差别。如来俱时以无发悟无分别心普遍示现。随诸有情别别心意。于后边际究竟勤勇。随应表示随所施作。妙吉祥。譬如白月十五中夜之时。遍阎浮提一切男子女人童男童女。各各现前观月轮相。而彼月轮悉无分别。如来亦复如是。以无发悟无分别心作诸行相。由成就不共佛法故。随有情心意随应化度。一切有情各各现前普观如来。而如来心亦无分别。是故当知。若有分别若无分别。诸佛如来悉无发悟。而成就不共佛法故。随应施作一切行相。此中应知。诸广大甚。深经。中而独显。说诸佛菩萨大威德力。若有人。能深生信解书写读诵。尊重供养者。是人获福广大无量。此经又云。佛言。妙吉祥。譬如须弥山王胜出众山。显照殊妙。亦高亦广而复最大。妙吉祥。若菩萨信解此正法者亦复如是。胜出一切菩萨摩诃萨。以十方一切世界。如微尘等诸菩萨众。若于此正法生信解者。所有五波罗蜜多出生善根。于阿僧祇劫中而能积集。显照殊妙亦高亦广而复最大。妙吉祥。若善男子善女人。所有十方一切世界一切有情。而悉劝令发菩提心。复有善男子善女人。信乐无余依涅槃者。此所获福。比倍于前不可数量。妙吉祥。正使善男子善女人普令一切有情信乐无余依涅槃。若复善男子善女人。于此正法能生信乐。若自书写若令他书写。若自读诵若令他读诵。乃至但能信乐受持。以香华灯涂等诸供具而供养之。此所获福。比倍于前不可称数

大乘宝要义论卷第十


大乘集菩萨学论

    No. 1636

大乘集菩萨学论卷第一

        法称菩萨造

        西天译经三藏银青光禄大夫试光禄卿普明慈觉传梵大师赐紫沙门臣法护等奉　诏译

    集布施学品第一之一

  我闻地狱大险怖　　无穷猛苦镇烧然
  谓昔曾无寂静心　　故乐多闻亲大法
  闻已远离诸罪恶　　悔先所造尽无余
  我于善利未尝获　　斯少分中几减失
  菩萨妙乐胜无尽　　唯佛具证平等理
  希有难思法宝中　　愿乐刹那听我说
  三有所来成就主　　龙天八部诸眷属
  咸生渴仰起慈心　　欢喜谛受安隐语
  如来正法及佛子　　善入佛戒所生身
  我今集解大仙言　　遍乐投诚恭敬礼
  我于往昔无少解　　无教无言非善巧
  亦无利乐及含生　　唯自一心为法友
  然我意乐清净法　　为令长养诸善根
  如我等比睹斯文　　于义未习应为说

论曰。谓欲成就士夫义者。于刹那顷具足难得。若不思惟是安隐处。此正等行当云何有。如华严经云。善财于胜热婆罗门。而作是念。得人身难。脱诸难难。得无难难。刹那具足清净难。值佛出世难。诸根具足难。听闻佛法难。得遇善人难。逢真实善知识难。受如理正教难。得正命难

论曰。此若干种正行知已。若有大士如是观察。我意于他脱诸苦怖。不乐己身斯何殊妙。唯护尸罗尽有情界拔诸苦本。希妙乐行竖菩提因。发坚固意不坏信根。如宝光明陀罗尼所说偈云。信顺诸佛及佛法。亦信佛子所行道。信于无上大菩提。菩萨以斯初发心信为先导功德母。长养一切胜善法。断除疑网竭爱流。信能显示安忍行。信无浊染令心净。弃除我慢恭敬本。信如净手摄持因。七圣法财无上行。信能一切欢喜舍。由信喜故入佛法。是信出生智功德随佛所说皆通达。信根光净极锋锐如实永断烦恼本。信力坚固无能坏。唯一谛信佛功德。信于相应非相应刹那远离诸染着。信能超出诸魔境显示最上解脱道。信为不坏功德种。谓能增长菩提苗。信为出生胜智门。应现十方诸觉者。若常信重于佛宝。非戒非学皆远离。若能远离非戒学。是人深赞佛功德。若常信重于法宝。则闻佛法无厌足。若闻佛法无厌足。于法信解不思议。若常信重于僧宝。则于净众无懈退若于净众无懈退。则于信力无能动。若于信力无能动。则得诸根净明利。若得诸根净明利。彼人远离诸恶友。若人远离诸恶友。为善法友之摄受。若善法友摄受已。则常修习广大善。若常修习广大善。则得成办大因力。若得成办大因力。彼人信解最殊胜。若得信解最殊胜。即为诸佛常护念。若为诸佛常护念。则能发起菩提心。若能发起菩提心。于佛功德勤修习。若佛功德勤修习。则得生在如来家。若得生在如来家。于着无著俱解脱。于着无著解脱已。则得深心信清净。若得深心信清净。则得最上最殊胜。若得最上殊胜已。常行深妙波罗蜜。若行深妙波罗蜜。则能悟入摩诃衍。若能悟入摩诃衍。则知如法供养佛。若知如法供养佛。则得念佛心无动。若得念佛心无动。则常观佛不思议。若常观佛不思议。于佛无生无所住。若佛无生无所住。则知是法永不灭

论曰。是中初发信根功德广大无量。于总聚中少略而说。又诸有情异生生身等。于如是法难生信解。若深心清净植福资粮。是信因力得住十佛刹微尘数众生劫。受诸妙乐胜善福报。于如是法当生信解。如十法经所说偈云。信为最胜乘。运载成正觉。是故信等事。智者应亲近。若人无信根。不生诸白法。譬如焦谷种。亦不生芽茎。又大善诱经云。尔时如来敕阿难言。于信法中如其了知。应当奉行

论曰。行是信者于刹那顷得信根坚固。即菩提心坚固而能摄受一切福报。如师子王所问经云。尔时星贺那太子白佛言。世尊。云何令诸众生在所生处常得爱乐摄受诸法。佛言。欲解脱诸众生者。常生谦敬发菩提心。是则名为常得爱乐摄受诸法。又如华严经云。善男子。菩提心者犹如种子。能生一切诸佛法故。菩提心者犹如良田。能长众生白净法故。犹如大地。一切世间所依持故。乃至菩提心者犹如慈父。训导守护诸菩萨故如毗沙门。能断一切贫穷苦故。如摩尼珠。成就一切诸义利故。菩提心者犹如贤瓶。圆满一切善希求故。如独钴杵。毕竟能摧烦恼冤故。犹如正法。能断深心诸作意故。犹如利剑。能断一切烦恼首故。菩提心者犹如利斧。能伐一切诸苦树故。犹如兵仗。防御一切极苦难故。犹如钩竿。于轮回海拔众生故。如大风轮。能疾飘偃一切障碍云雾草故。菩提心者犹如丛林。积集菩萨诸行愿故。如佛塔庙一切世间天人阿修罗等所尊重故。善男子。菩提心者成就如是无量殊胜功德

论曰。云何复知诸异生等发菩提心。是中引圣言量非一经所明。如维摩诘所说经云。虽起身见如须弥山。犹能发起大菩提心生佛法矣。又宝箧经说此异生菩萨义云。佛告文殊师利。譬如迦陵频伽鸟鶵未出卵时。已能作于美妙音声文殊师利。是菩萨亦复如是。虽未断我见不出三界处无明[穀-禾+卵]。已能作于诸佛妙音。所谓空无相无愿解脱等音。又随说诸法经云。尔时胜慧菩萨于地龛中入涅盘时。于大城邑而获受生。彼于空性信解作对治故。又入定不定印经云。佛告文殊师利。云何名羊车行菩萨。譬如有人欲过五佛刹微尘数世界。是人乘彼羊车随路而去。过久远世行百踰缮那遇大风轮。以是缘故却退八万踰缮那。后是人于彼世界乘是羊车。乃至不可说不可说劫能越一世界不。文殊师利言。不也世尊。佛言。若大乘者发菩提心已。不应受持读诵声闻乘教。或与诸声闻共住修习于声闻乘。或自深心为他所教于如是乘。乃至悟解得彼智慧以是缘故于无上道即便退失。是菩萨于菩提心所得慧根慧眼彼悉破坏。文殊师利。我说是名羊车行菩萨

论曰。若菩萨爱乐大乘信解空性。于信解行而获圆满。此圣言量唯信解行菩萨见如是事。如宝云经说。以无数总持三摩地门神通游戏解脱智明无边法聚。平等超越一切愚夫行报。乃至后际不为利养。于俱胝劫世间所得受用资具。心无贪着亦不分别。如莲华敷具足庄严。又于无量百千俱胝那庾多劫安住大乘照了胜义。福智资粮希无减失。于其出离先所修习百千相应行门皆悉具足

论曰。云何了义。谓初发菩提心者说住此地。不了义者少分标相得无疑惑。此圣言量信解行法所生言义。如中广略了信解行。复次如来秘密经云。尔时阿阇世王白佛言。世尊。彼菩提心当云何发。佛言。大王。谓深心不退。王言。世尊。云何深心不退。佛言。大王。谓能发起大悲。王言。世尊。云何能发大钴。佛言。大王。谓于诸众生不起厌舍之心。王言。世尊。云何于诸众生得无厌舍。佛言。大王。谓若不着己乐得无厌舍

论曰。是中菩提心者。谓劝发大悲。欢喜敬爱义故。若不依如来教中相应。是人无有出离。此菩提心见可呵厌。如是不名发菩提心者。如十法经云。善男子。若诸菩萨体性发菩提心时。得值如来及声闻众教化劝发阿耨多罗三藐三菩提心。是名最初喜乐发菩提心相。若闻说菩提及菩提心已。即发阿耨多罗三藐三菩提心者。是名第二喜乐发菩提心相。若彼众生无归无救见是二种住大悲心。乃至发阿耨多罗三藐三菩提心者。是名第三喜乐发菩提心相。若见如来众相圆满即生敬爱。乃至是名第四发菩提心相

论曰。菩提心者。此有二种。一者愿菩提心。二者住菩提心。如华严经云。善男子。复有众生于众生界愿证难得阿耨多罗三藐三菩提心。复有众生住是难得阿耨多罗三藐三菩提心

论曰。一者愿证作佛。一者愿住受生。又首楞严经说。因于某甲佛所发菩提心。云何复作少善根耶。如贤劫经云。昔星宿王如来于施音如来所初发菩提心时。为牧牛人以耽步罗叶施彼佛故。无量名称如来于电光如来所初发菩提心时。为织[疊*毛]师以上妙衣施彼佛故。焰光如来于无量光如来所初发菩提心时。住城邑中以草灯炬施彼佛故。难胜如来于坚固步如来所初发菩提心时。为采樵者以少齿木施彼佛故。功德幢如来于妙吉祥称如来所初发菩提心时。为攻医师以一庵摩罗果施彼佛故

论曰。此初发菩提心非满足行。此阿厌事犹能解脱轮转得无量乐如慈氏解脱经云。善男子。譬如有宝名曰金刚。能断一切贫穷苦故。善男子。此一切智心亦复如是。能断一切轮回苦故

论曰。唯此发菩提心者得近彼果。应如是知。又善谏经云。佛言。大王。汝若谓多种作中能多种作者未。若我一切行中行一切行。一切处中利一切处。谓学布施波罗蜜多。如是乃至学般若波罗蜜多。大王。是故汝于三藐三菩提亦复如是。乐欲发生净信意愿利他。行住坐卧。若梦觉时。若饮食时。而常具足随念作意。观察诸佛菩萨声闻缘觉诸异生身等积集过去未来现在一切善根。称量已和合已。应随喜者而自现前随喜。乃至遍虚空界遍涅槃界亦自随喜。又复随喜一切诸佛菩萨缘觉及声闻众供养事业。平等回向一切众生。乃至令诸众生得一切智智。普皆圆满诸佛善法。日日三时回向阿耨多罗三藐三菩提。大王。汝以如是正行得名王者。不捐宝位求菩提行亦获圆满。说是报者。大王。汝于彼时由发菩提心故。善根业报经无量数常生天上。于诸天中作天帝释。或生人间为人中王。大王。唯一发菩提心善根力故。余无别业。应知圆满或未圆满。以要言之。佛言。大王。唯一发菩提心者救度一切众生故。解脱一切众生故。安隐一切众生故。究竟令诸众生至涅槃故。得生无量无数诸善根故。大王。复何说是多种作中能多种作耶

论曰。此菩提心行相者。经说。过现缘起。如是愿菩提心说入何地菩萨得戒。有云。九地。虚空藏经云。名闻利养是诸罪本。十地经云。说初地中于彼利养无有少分亲近希求若诸众生来至我所。一切所须倍多给与

论曰。如其所言则极喜地菩萨得善住不动相应。复说生如来家。决定趣向成等正觉。又虚空藏经说。声闻乘而不能得如是。唯除乐大乘者。如最上授所问经云。是悭嫉法正说名缚。具表此学说极喜地。远离我想我执不起。云何复执一切所须。如说施头目等

论曰。如是等经。入地已去正表此学。若遍论菩萨彼相应修习中。或复遮止不应顿作。菩萨未能学故。应知此二种遍诸学处。又一种学于成就作用不能学故。虽不修习亦无过失。无尽意经云。行广大布施时。舍净尸罗不为懈怠。以先未说亦不集行。如力亲近故。又十地经说。设犯欲邪行戒惑染轻微。由乐菩提心故。舍利子。说菩萨别解脱戒成就四法。谓是菩萨于修习中得真实语。舍利子。若善男子善女人发阿耨多罗三藐三菩提心已。志乐精进勤求善法。习诸议论坚持禁戒。于菩萨学具足修习。由亲近于他如是戒学。或时违越轻毁师尊。极惭愧故起大怖惧。彼复受用尊重爱乐。圆成如是平等戒法。是菩萨于诸佛如来现前戒学发生乐欲正行应别授学。彼或无有善知识者。向十方现在佛菩萨前。专念作观随力称量。已坚持是戒。勿复欺诳十方一切佛菩萨众及彼世间诸天人等。正法念处经说。先少思惟已后竞不施堕饿鬼趣。语已不施堕地狱趣。况复无上菩提具足许施。无余世间诸众生故。如法集经云。善男子。菩萨应当尊重实谛。何以故。善男子。以集实谛名为法集。善男子。云何名实谛。若菩萨发阿耨多罗三藐三菩提心。乃至弃舍身命不舍是心。不舍诸众生故。是名菩萨实谛。若菩萨发阿耨多罗三藐三菩提心已。复于后时弃舍是心。及舍诸众生者。是菩萨为大妄语。实可呵厌。又海意菩萨所问净印法门经云。佛言。海意。譬如世间若王王臣欲饷一切城邑人民。集已弃舍。若饮若食不为办设。于诸人民则为虚诳。而于饮食少不可得。高声呵责忿恚而出。佛言。海意。是菩萨亦复如是。于诸众生未度者令度。不应但修捷语利辩。乃至而不勤修多闻积集诸善菩提分法。彼菩萨者则为虚诳诸天世人。如先佛说。是圣所呵厌。于智大智无上胜智俱极难得。是故当知。菩萨不应但以语言虚诳一切天人世间。复次海意。或有人来劝请说法施作义利时。彼菩萨随言为说。乃至弃舍己身修菩萨行不复虚诳一切众生。当如是知

大乘集菩萨学论卷第一大乘集菩萨学论卷第二

        法称菩萨造

        西天译经三藏银青光禄大夫试光禄卿普明慈觉传梵大师赐紫沙门臣法护等奉　诏译

    集布施学品第一之二

论曰。故知自力所集。随其行相于一善道亦应守护。如地藏十论经云。如是十善业道佛所证果。若不真实守护一善业道。乃至临命终时。而自称言。我是真实行大乘者。我求阿耨多罗三藐三菩提者。当知是人是极虚诈。是大妄语。对十方界佛世尊前诳惑世间。说空断见诱诳愚痴。身坏命终堕诸恶趣

论曰。乃至临命终时。能须臾说集诸善品。亦应修作。如药师琉璃光经说。若见大心众生如闻菩萨难行苦行及妙胜智。乃至入解发大勇猛。荷负重担捄护众生。尽诸苦本礼拜供养。说罪及随喜福。劝请诸佛住世说法。乃至回向菩提。为善知识劝请说法。或乐自说。当知是名为示道者。如文殊师利庄严佛刹功德经云。世尊。是妙吉祥往昔生时。本行因缘发菩提心。亦如是发如彼所说。乃至最初远离轮回边际。利益众生行如是行。我于尊所发菩提心。现前劝请令诸世间脱贫穷报忿心恨心悭贪嫉妒。我得菩提时。悉不现起。乃至常修梵行脱诸罪欲。于佛随学清净尸罗。爱乐尊重于大菩提。不疾取证我处后际。于诸众生一相无异。时十方界未闻我名无量不思议刹土悉皆严净。由身语意业清净故。于诸所作悉亦清净。又一切时坚持净戒。尽生死际无诸过恶。又阿閦如来本愿授决经云。彼阿閦如来往昔为菩萨时。作如是说。若我生生世世不出家者。是则虚诳一切诸佛如来。舍利子。如是菩萨于阿閦如来亦应随学。又舍利子。诸菩萨摩诃萨生生出家。或诸如来出世。或不出世。毕竟舍家出家亦如是学。所以者何。舍利子。若谓菩萨舍家出家是为最上。乃至男女眷属不生爱着。如我生时无诸过失

论曰。如上所说且止斯事。若说施戒罪相同等。及于罪相相应等事。应自弃舍若别别行相亦非无罪。于别行相然不摄故。而菩萨于诸众生所有未来一切苦恼令得解脱。一切妙乐令其增长。若身语意不勤精进方便纯熟。于缘合集不乐劝化。或散灭处亦不寻求。多分烦恼少分烦恼不起对治。于大义利及少义利或非义利不生损益。刹那俱舍。此说是罪。略说无罪谓自力能于境界事都无果报。或执如是于学表相体性是罪。若自力能境界相应罪处无有。同说罪等于相解脱。是菩萨学于平等身广太无量劫后际说。复次略说菩萨此二种罪。如其成办相应非相应可作不可作都无拣择舍故是罪。谓言毕竟超出寻伺。如旃陀罗奴等谬解义故是罪。彼复云何深心教诫经说。如慈氏因中四种辩才即诸佛语。何等为四。一者择有义利拣非义利。二者择此正法拣彼非法。三者破遣烦恼非增长烦恼。四者乐见涅盘功德不乐见轮回功德。是名四种。以要言之。若尔云何慈氏因中说是四种辩才。谓信善男子善女人生诸佛想。作议论想。闻善法故。所以者何。谓若慈氏有诸善说即诸佛语故。若于此慈氏辩才而生诽谤。非诸佛语起不尊重。是恶人辈即是诽谤诸佛所说辩才由。毁减善法招罪业报堕诸恶趣

论曰。复次修习善巧发起爱乐。此行门中集学最胜作用。应当修学。希大果故如寂静决定神变经云。复次文殊师利。若菩萨于殑伽沙数等诸佛。是诸佛所有殑伽沙数佛刹。复于如是殑伽沙数劫。以自在王摩尼宝满中持用布施。若诸菩萨于如是法相闻已。一心思惟。我当修学。文殊师利。比前无学所有福报未若施此乐欲学地菩萨其福甚多

论曰。是菩萨虽见此功德。未言如其修习等复如彼说。文殊师利。假使教化三千大千世界微尘等众生。一一众生得阎浮王。若以诸音声赞叹受持读诵如说修行大乘经者。于一日夜断割身肉指爪乃至命终。一心奉行。文殊师利。缘是菩萨布施心无怯弱。不惊不怖不畏。毕竟一心发亲近想。无悔无疑亦无分别。于此最上正法摄受相应。意乐读诵如说修行。文殊师利。是菩萨心勇猛故。则布施勇猛。持戒勇猛。精进勇猛。禅定勇猛。智慧勇猛。一切三摩地勇猛。文殊师利。是菩萨设使于恶人辈。亦复不生嗔心厌心及余过失。文殊师利。是菩萨如释梵王等无所动

论曰。今正是时。当一心学希大果报。月灯三昧经所说偈云。若于河沙多亿劫供养百亿那由佛。清净信心施肴膳亦施灯鬘及幡盖。若于正法衰末世如是佛法欲灭时。于一日夜学是行。比前福报胜于彼

论曰。是故一心勤修如佛经中所说菩萨学义。如宝云经说善男子。菩萨于菩萨学坚持净戒如是寻伺。若不于菩萨别解脱戒中。我云何能得成证阿耨多罗三藐三菩提耶。又何不于如来大乘诸经法中所诠菩萨行所集菩萨学。我当如是广大修习

论曰。我等无知。于此广说菩萨制止容起恶觉。何非此理。于修习处了无过失。云何修习处谓若于身所有三世受用。行清净舍护诸众生令净增长。受是菩萨戒已。若此菩萨住修习处说是罪相。如菩萨别解脱经云。于菩萨道摄受一切众生令尽苦趣。彼菩萨道摄受安住过俱胝劫。唯一发起安隐之心及亲近心。菩萨发是心者。应知于诸众生一向摄受多种住处。如文殊清净律云。时文殊师利语寂音天子言。菩萨具足此五无间。速得阿耨多罗三藐三菩提果。何等为五。菩萨深固作意求无上道。发心不堕声闻缘觉之地。是初无间发心。自舍一切所有。于悭吝心而不共住。是二无间。我应救度一切众生。于中不起懈退之心。是三无间。了一切法非空非有无生无灭。于中不堕诸见。是四无间。于诸法智和合一相。如是发心中无所住。由无所住于一切智悉无所得。是五无间

论曰。谓身所受用福报不断者。于舍护事令净增长。如瑜伽观想中说。彼所舍义摄受过失。观想门中起离贪想。观舍功德故。如月灯三昧经所说偈云。如是不坚身。愚者心所乐。何常寿命中。刹那如幻梦。造诸恶业故。罪报常随逐。由是无明因。死多堕恶道。又如无量门陀罗尼经说。云何众生得斗诤因。谓计执财利而为根本。应当弃舍。若离贪爱即得是陀罗尼。又菩萨别解脱经云。复次舍利子。菩萨于一切法极微细分不生他想。所以者何。怖取着故。最上授所问经云。谓若布施者无诸悭吝。执著者而常守护。又布施者为尽贪爱执著者增长贪爱。布施者无诸遍计。执著者有诸遍计。布施者无有恐怖。执著者彼多恐怖布施者住菩提道。执著者住魔境界。布施者作无尽想。执著者作有尽想。又布施者得诸妙乐。执著者而常逼迫。布施者舍离烦恼。执著者增长烦恼。又布施者得大富饶。执著者得大贫乏。布施者善人事业。执著者恶人情计。布施者诸佛称赞。执著者愚夫称赞。乃至布施者自所生子不起乐着。非如于余众生起怜愍故。应知自心说有三种。何等为三。一者菩萨于菩提道正等相应。非邪谬相应。二者菩萨于菩提道起平等心。非高下心。三者菩萨于菩提道无种种行。非有种种行。是名三种自心所说

论曰。谓于自所生子起非善友想。既非善友故非我友。若为利益随佛教敕学负重担故。于自所生子不生乐着。非如于余众生起怜愍故。应知发是心已。如于我子发生慈爱。则我于一切众生亦复随顺发生慈爱。如是深心观察悟解。我子既无异于一切众生。则一切众生皆是我子。所有众生若自若他乃至居士。在家菩萨于其财利或非摄受众生勿应耽着。非出离法又复不应爱乐随顺染欲。复次在家菩萨或有行来乞丐。随何所须发勇悍心而为给与。又作是念。我此财利若舍不舍毕竟散灭。云何于舍受时而得无欲。谓我我所得毕竟忍。于所舍物离胎藏苦。心住正念欢喜爱乐不生随转。复次如是能舍谓于所舍物及乞丐者。应知有四种想。何等为四。谓怯弱故不能纯熟善根先所造业。于大乘中心不自在。见取舍故。又若我及我所住安忍力。自与善人不起悔恼。如是修作。如是踊跃。如是精进。圆满一切众生所希求故。如是在家菩萨于彼乞丐者应作是想。或乞丐者返增过失。是菩萨应当善言慰谕。又乞丐者而不知恩。是菩萨亦复不起悭嫉。是为无罪。此世尊为下种诸菩萨。如菩萨别解脱中说。舍利子。菩萨无有四法。何等为四。一者菩萨无不信心。二者菩萨无有悭贪。三者菩萨无有两舌嫉妒。四者菩萨无懈怠心。谓言我不能成证阿耨多罗三藐三菩提果。舍利子。若我有是四法。彼有智者于此了知。便谓邪命谄求非法染法重世财利。是为第一偷食信施。复次舍利子。菩萨如是心勇猛故。乃至头目手足身体支分男女眷属心所爱乐极妙乐事。舍宅国邑一切所有。悉能弃舍。又如那罗延所问经云。若于财宝发是舍心。应知财利不生取着。然舍未起智故。若于摄受不起舍心。则于非摄受亦常执着。若随乞丐者意于摄受发生智故。则于眷属亦无取着。最上崇贵亦无取着。受用珍宝亦无取着。而菩萨若于财利不起舍心乃至极微细分。应知取着。复次善男子。而菩萨摩诃萨应当发如是心。谓我此身分于诸众生尚能弃舍。何况所有外财资具。又若于众生所如其所须悉能施与。谓有来乞丐须手以手须足以足须眼以眼。乃至脂髓血肉及余身分。随各施与。云何复名外财资具。谓若库藏孳生之物。金银珍宝胜妙庄严。象马车乘国土宫殿。城邑聚落吏民僮仆。作业士夫男女眷属。若诸众生于所有事。彼彼众生如其所有。我当给与不生悔恼亦无退屈。不希果报及余谄诈。复次我此施者随顺一切众生故。悲愍一切众生故。饶益一切众生故。摄受一切众生故。如我摄受众生知如是法得菩提故。以要言之。善男子。譬如药树根茎枝叶花果皮核。若全若分。随其取者不生分别。又复脱诸众生病苦难时。亦不分别上中下性。善男子。是菩萨摩诃萨亦复如是。应知于四大种身生药树想。于彼众生可作饶益。须手以手须足以足。随其取者如前药树不生分别

大乘集菩萨学论卷第二大乘集菩萨学论卷第三

        西天译经三藏银青光禄大夫试光禄卿普明慈觉传梵大师赐紫沙门臣法护等奉　诏译

    集布施学品第一之三

如圣所说无尽意经云。菩萨当观自身于诸众生应何所作。谓四大种地水火风有种种门种种所作种种系属种种器具种种受用。随众生行或全或分。然我此身四大所集亦复如是。有种种门种种所作种种系属种种器具种种受用。于诸众生作大依住如其观察为利众生。设身有苦不生疲厌

论曰。舍受用福。如金刚幢经云。菩萨以种种布施十方无量贫穷困苦。受施之者。信菩萨行闻菩萨声缘菩萨语。悉以来集。然菩萨布施先发誓愿。由闻菩萨心所愿言。一切舍施意喜无厌。令乞丐者遂心满足。随其来者发心忏谢。如彼偈云。我应诣彼施。汝知不可得。诸从远方来。得无疲劳耶。如是于乞丐者头顶礼敬忏谢慰喻。澡浴身秽为设敷具。如其所须一切给与。所谓或末尼车。阎浮提中柔善女宝众具圆满。或施金车侍卫仆从清净女宝众具圆满。吠琉璃车。最上可爱歌咏音乐如前圆满。玻胝迦车。于四方面现四宝女。执妙庄严色相无比。亦复圆满。如前所说。末尼车者。垂诸宝网弥覆其上。驾以白象及御象者无量严饰。其宝轮相与车相称。又于其上置诸妙宝师子之座乃至设众宝盖遍覆其上。庄严宝帐周匝围绕。于四方面植妙幢幡烧种种香。诸妙坚香以为涂拭。散诸妙花遍覆庄严。又于其上百千妓女宝绳交络。彼善御者正等和合。行无错乱。乃至以诸粖香变异和合。虽闻此香意乐第一。令彼男女性行调适。复如彼说。为诸众生当舍己身。承事诸佛之所摄受。或舍转轮王位国城宫殿一切胜庄严具。如其乞者舍诸眷属男女妻妾舍宅人民乃至或全或分一切舍施。如是饮食滋味。而菩萨具舍种种净妙饮膳苦辣咸淡种种上味。遍滋大种柔滑光泽。调适身心安住色力。乃至诸所至处愈诸疾病。悉令安乐。如是灯明粖香涂香华鬘衣服床敷几案房舍卧具病缘医药。而菩萨随其给与。乃至种种广大器具。谓无量无数金银铜钵满中珍宝。供佛世尊起不思议尊重信解等心。或施菩萨善知识等发希有心。或施住佛教者一切圣众声闻缘觉补特伽罗发清净心。或施父母诸阿阇梨及余师尊。发起尊重亲近承事求学等心。或施歉乏困苦之者。于诸众生作无碍眼发慈愍心。以要言之。若菩萨乐施象乘。七支安住高六十尺。六牙具足面目清净如莲华色。金绳交络庄严身相。种种杂宝巧妙间饰。其鼻举掷金色殊妙。行千踰缮那观者无厌。若施马乘。随行四方其步平正。身得安隐控御仆从饮食具足如天庄严。施百千等。或施尊重诸善知识父母师长乃至歉乏困苦一切世间可受施者。心无吝惜亦无执着。大悲大舍是菩萨深心清净。发生如是无量功德。乃至菩萨或施床座。谓贤王座及吠琉璃承足宝几安师子床。金绳宝网处处垂下。柔软茵褥无量严饰。熏诸妙香。大摩尼宝建妙高幢。无量百千俱胝。那踰多宝而用庄严。垂诸宝网。一一网孔悬众宝铃。香风摇击。出和悦声。或施大座仰目高视。无数行列盖诸大地。一切国王大自在主。坐已灌顶。及于是座得无碍轮。教令诸小王等随教奉行。如是乃至菩萨施大宝盖。亦以大宝而庄校之。宝茎宝铃宝绳宝网垂过耳颈。又于周遍吠琉璃宝末尼珠等结妙璎珞。又诸网中如难祢天出妙音响。清净和雅庄严宝炬。其数百千如集宝藏。又于周遍烧无价香。旃檀沉水百千俱胝那由他坚妙诸香。复有清净宝盖。如阎浮檀金光聚。亦以无量百千俱胝那庾多庄校严饰。以如是无数百千俱胝那庾多盖。以心布施诸来乞者。住于人前随其给与。或施真实。诸佛灭后庄严塔庙。或施求法菩萨诸善知识及现生菩萨法师。若父母僧宝奉诸佛教乃至一切可受施者。皆以如是善根回向。如其最初诸有善时皆当亲近。发如是愿说此善根。于诸世间得常依住。于清净法得正自在。若诸众生以此善根。地狱罪报皆得除灭。畜生琰摩罗界息诸苦聚。彼以如是善根回向。我于善根亦复如是。居房舍时。愿诸众生灭诸苦聚。遇拯救时。愿诸众生脱诸烦恼。遇依怙时。愿诸众生离诸怖畏。若行去时。愿诸众生至一切地。若对向时。愿诸众生得毕竟忍。见光明时。愿诸众生得无暗慧。睹电光时。愿诸众生破无明暗。得灯炬时。愿诸众生毕竟净住。遇勇健时。愿诸众生于不思议法深入正理。遇勇将时。愿诸众生而得无碍智蕴。乃至言无虚饰。深固意回向一境心回向。欢喜心回向。极喜心回向。柔软心回向。大慈心回向。爱乐心回向。摄受心回向。守护心回向。安隐心回向。以如是回向。又我此善根。愿诸众生得净所趣成就。得净所生成就。得净福相严身成就。得无损坏成就。得广大施成就。得久远心成就。得无失念成就。得通达惠解成就。得无量觉悟成就。得身业意业一切功德庄严圆满成就。又以无量善根与诸众生供养诸佛。由供养已得无损减。于佛世尊忏诸罪恶。亲近如来应供正等正觉。闻所说法闻已离诸疑惑。如闻受持而得相续具足正行。由供养如来故得成事业。心勤修习无诸罪恶。又我植此善本毕竟离诸贫穷于七圣财而得圆满。随诸佛学得胜善根普能成就广大信解入一切智智。于诸世间作无碍眼。具相严身清净摄受一切功德。庄严语故成就诸根。十力系心分别之所积集。于游止行无不圆满。又诸如来成妙乐处。愿诸众生亦复皆得。如六十回向仪轨中说。愿诸众生获得智食。不应食者心遍了知。决定不拣择食乐不肉食。乃至不生爱欲。愿诸众生如云降雨得法一味。愿诸众生得诸上味。于最上法乐止息充满。一切佛法极善思惟。不生执相。谓不坏乘。最上乘。最胜乘。速疾乘。大力乘等。愿诸众生乐睹诸佛得无厌足。愿诸众生见善知识得无间断。愿诸众生见无毒药。愿诸众生息除烦恼。愿诸众生睹净日轮愿诸众生。破黑暗已随乐为说。如是身相照了自性愿诸众生。睹胜光明不见恼害唯见适悦。贤善爱乐希望极喜诣诸佛所。愿诸众生具足戒香。于菩萨波罗蜜多戒而不毁禁。愿诸众生熏修布施。遍舍一切。愿诸众生熏修忍辱。得心不动。愿诸众生。熏修精进被大精进铠。愿诸众生熏修静虑。依现在佛前得三摩地。愿诸众生熏修菩萨回向。愿诸众生熏修一切白法。解脱诸不善法。愿诸众生获天资具。愿诸众生起大智行获圣资具。愿诸众生以菩提心熏诸异生得妙乐具。愿诸众生离诸轮回行苦获安隐资具。愿诸众生得住净佛国土证诸法触。谓功德住。相应住。广大不动最上诸佛住。愿诸众生得近佛游止愿诸众生得无量光照诸佛法。愿诸众生得无碍光能以一光照诸法界。愿诸众生得安乐身获如来身。愿诸众生犹如药王毕竟能别方论。愿诸众生犹如药树得无损害。愿诸众生如世良医灭除疾病。得一切智至安乐处。愿诸众生为世良药。如其深心捣筛和合。愿诸众生除诸病恼。愿诸众生得大势力身。愿诸众生得碎诸轮围山力。愿诸众生得无限量器尽虚空界广大念根。世出世间一切所说普摄。印持得无忘念。愿诸众生得善净器。了悟三世诸佛分别清净无坚执着。愿诸众生所欲至向得一切处行佛地上。愿诸众生于余一切众生得心无损害。愿诸众生一刹那心缘诸法界。及诣一切世界无疲无倦。由无厌倦得身通轮。愿诸众生得妙乐行。同诸菩萨行诣道场。愿诸众生于善知识及无量善根得心无舍离。知恩报恩随所守护。愿诸众生与善知识同一利乐。愿诸众生深心欢喜惟善摄受。与善知识安乐共住随修福行。愿诸众生于善知识所有善根清净业报。同一大愿。愿诸众生住大乘行永离忧暗。于一切智得无穷尽。愿诸众生深覆善根。为诸如来之所守护。愿诸众生覆护智德。解脱世间一切惑染。愿诸众生具足白法不起散乱。于佛法中得不坏行。愿诸众生张十力盖覆荫一切。愿诸众生得大深心毕竟觉了。愿诸众生踞师子座得佛神通。于诸世间如是观察。又虚空藏经云。我所积集善根法智善巧。无不与诸众生而为依住

论曰。舍过未受用。如无尽意经云。若善心心所法念念回向菩提。是为善巧。若未来善根决定菩提。现前于诸事业所起善心。皆用回向阿耨多罗三藐三菩提

论曰。如是心心所法修习。信解圆满一切舍施。又心所行及身方便舍诸摄受。此言摄受者。即是解脱三有苦本。是中于无量阿僧祇劫种种所造。应招世出世间无量富乐。于身自然如意受用。我应以财利钩拔诸众生置彼岸处。菩萨于菩提道布施。余如宝云经说

    护持正法戒品第二之一

论曰。是人于身虽舍。复何名护。谓若以自受用施诸众生。云何受用。何等名施。若无受用亦无守护。是故护自身者。应以受用利益众生。菩萨别解脱经云。舍利子。应知护他者即是护身。舍利子。如是行相。若菩萨成就护他。设遇丧命因缘。我于是业悉不应作。又无畏授所问经云。复如大车负极重等。唯诸智者于法觉了。无尽意经亦作是说。为护诸众生者。设身有苦不生疲厌。况舍善知识耶。故华严经云。善男子。菩萨由善知识任持不堕恶趣。由善知识具足超越菩萨学处。由善知识教导而得出离世间。由善知识而得亲近菩萨无忘失行。由善知识而得摄受菩萨一切希有行故。由善知识依正觉道除业惑障出生死城至清净处。善男子。是故亲近承事善知识者。应如是作意。谓心如地荷负一切。无疲倦故。心如金刚。志愿不可坏故。心如轮围山。设遇诸苦无倾动故。心如仆使。随诸作务不厌贱故。心如佣人。洗涤尘秽离憍慢故。心如大车。运重致远不倾坏故。心如良马。不暴恶故。心如舡筏。往来不倦故。心如孝子。于诸亲友承顺颜色故。又善男子。应于自身起病苦想。于善知识起医王想。随所教令作良药想。所修正行作除病想。又善男子。应于自身作怖畏想。于善知识作勇健想。随所教令作器仗想。所修正行作破怨想。复次解脱观优婆夷言。善男子。菩萨于善知识随所教令应思供养诸佛世尊。菩萨于善知识言无违逆。得近一切智故于善知识言无疑惑。得近诸善知识不离作意。得诸现在利益。又如善财诣坚固幢比丘所。头面礼足右绕百千匝却住一面。时坚固幢比丘观察礼敬。更复谛观亦复礼敬。如是思惟遍观察已。谓言从何所来作是相者。于现前功德利益求念坚固无量行愿。不舍是意希望见相及音声取。乃至作礼而去。如其诣善知识见一切智涕泪悲泣。至海云比丘所作礼而去。又菩萨别解脱经云。舍利子。菩萨乐善法欲世间珍宝无不弃舍。以身承事无不恭敬。供给走使及余语业无不勇捍。于和尚阿阇梨极生尊重。乃至所以者何。为断系缚求如是法。为断生老病死忧悲苦恼求如是法。发心如宝。除诸众生贫穷困苦。求如是法。发心如药。安乐一切众生。求如是法。最上授所问经云。复次长者。或于菩萨所闻一四句偈。受持读诵为他人说。及积集菩萨布施持戒忍辱精进禅定智惠相应之行。彼于阿阇梨法应生尊重。乃至以名句文说偈赞叹。若一劫中于阿阇梨亲近承事。常行正直。一切财利受用供养长者。于阿阇梨尊重尚未圆满

论曰。云何于法尊重。八千颂般若波罗蜜多经云。善男子。汝于善知识应起尊重爱乐。尔时常惨菩萨摩诃萨如是行相尊重作意。次诣一城。入是中已。我为供养法上菩萨摩诃萨故。当自卖身随取其直。然我于长夜中为欲因缘受生死身。流转诸趣无量无边。未尝为法及利众生。时常惨菩萨高声唱言。从其听闻。谁买此人谁买此人。以要言之。时魔波旬即从座起。令诸婆罗门长者等不闻其声。欲自卖身了不可得。彼一诣已皆无闻者。即自悲泣。唱言。怪哉。于其财利斯何难得如是。我自卖身尚不可得。时有天主。名烁迦罗。作梵志身。乃至白常惨菩萨言。善男子。汝何住此悲泣忧恼。常惨菩萨白言。梵志。我今乐善法欲为供养法。当自卖身竟无买者。尔时梵志语常惨菩萨言。我不须人无所施作。要当人身心血骨髓。乃至于此卖否。时常惨菩萨自念。获大善利我今圆满。定知般若波罗蜜多方便善巧。我身尚卖何得吝惜心血骨髓。发踊跃心。善分别心。极欢喜心。白梵志言。是身随意。乃至常惨菩萨右执利刃。刺臂出血去臂肉已破骨而往。是时有长者女。处高楼阁遥见是事。乃至诣彼谓常惨菩萨言。汝何如是于身苦楚。乃至童女闻供养已复语。善男子。彼有何等功德善利。白言。童女。彼菩男者为我善说般若波罗蜜多方便善巧得如是学。如是学者为诸众生作所归趣。以要言之。复次童女语常惨菩萨言。善男子。于阿阇梨为求如是广大法者。如是于二法义。于殑伽沙数劫当舍是身。为求如是广大法故。善男子。我今具有金银末尼珠宝吠琉璃等。乃至汝于法上菩萨广作善利。时童女与五百眷属俱诣法上菩萨所。尔时法上菩萨摩诃萨。即从坐起诣已住舍。于七岁中如是入妙三摩地。常惨菩萨亦七岁中不起欲寻。不起谤寻。不起害寻。不着滋味。但念法上菩萨当于何时出三摩地。如是诣法座前。于此说法尽地方所。散种种花诸妙珍宝。时长者女与现前五百眷属。于常惨菩萨威仪进止亦如是学。时虚空天响报常惨菩萨言。是法上菩萨后当七日出三摩地诣彼城中随宜说法。尔时常惨菩萨闻是声已。生极喜乐及适悦意。扫地严净。时长者女与五百眷属。于法座前以智善巧七宝间饰。复次常惨菩萨于地方所严持扫洒。周遍求水了不可得。而于是处有魔波旬。名曰饮浆。隐蔽诸水为令菩萨心生苦恼退失道意增不善本。时常惨菩萨知魔蔽已。我应刺身出血洒地。所以者何。是地方所多尘土界。于法上菩萨身或坌污我今为法设破己身斯何吝惜。又我往昔为欲因缘。往复无际轮回生死。不曾为法舍自身命。作是念已。即执利刀刺身出血遍洒其地。诸女眷属亦如是学。时魔波旬皆不得便。故大乘四法经云。佛告诸比丘。菩萨尽其形寿乃至或遇丧命因缘。毕竟不得舍善知识

大乘集菩萨学论卷第三大乘集菩萨学论卷第四

        西天译经三藏银青光禄大夫试光禄卿普明慈觉传梵大师赐紫沙门臣法护等奉　诏译

    护持正法戒品第二之二

论曰。于是经典不舍诸善知识如护己身。于是经典一刹那顷乐菩萨学。于是经典集菩萨行。于菩萨学应择彼言。是故伺察不堕是罪。于无智处亦不爱乐。见是经典常乐尊重。见是经者不舍诸善知识。为说护持一切正法。如海意经云。然善男子不可说者。谓以文字语言于无生法中而不可说。若以文字语言诠总持门。乃有其说。此即名为护持正法。又善男子。有说法师于如是等甚深经海如说修行者。若人于此法师亲近恭敬尊重承事。密为护持。饮食衣服坐卧之具病缘医药种种供施。护诸善品及护语言。设有诽谤亦为覆藏。此即名为护持正法。乃至善男子。于他无诤可胜无法可说。是人与法俱无有执。此即名为护持正法。又善男子。于诸众生解脱慧中不生损减。不以财利之心为他法施。此即名为护持正法。又善男子。或因听法或因说法。乃至行于一步一出入息间而专住者。此即名为护持正法。以要言之。又善男子。若于色心境界之中无诸攀缘。唯一境性调伏止息。此即名为护持正法。又乃至善男子。若谓是法于法可转。是法无所取着。此即名为护持正法

论曰。彼说法师虽说亲近善知识。及不舍善知识相。若不护持正法。是不守护。是不清净。是不增长。即非菩萨决定于如是事护持正法师子吼胜鬘经云。佛言。菩萨所有殑伽沙数无量行愿。皆应涉入一大愿中。所谓护持正法。护持正法者是大境界。彼经复说。譬如有大力士少触身分为彼损害。佛言。胜鬘。少护正法亦复如是。令魔波旬得大忧恼。我不见余一善法能令恶魔生此忧恼。如是唯少护持正法之者。又云。譬如须弥山王端正殊特。于诸黑山最为高大。佛告胜鬘。如是大乘舍身命财以摄取心护持正法。胜余住大乘者不舍身命财所护一切善法故。如海意经偈云。护持如来正法者。即为胜尊所摄受。诸天龙王紧那罗福德智惠皆能摄。乃至护持如来正法者。所生刹土不空过一切生中见胜尊。见已即得心清净。护持如来正法者。而得宿命大我法出家善利数。能成所修真实清净行。又云。护持如来正法者。得大总持及善利。正使百劫非听闻。由具辩才悉无碍。护持如来正法者。乃至释梵护世等人中复得转轮王。悉悟菩提安隐乐。护持如来正法者。具三十二殊妙相大智庄严喜乐身。随所见者无厌足。护持如来正法者。而不舍离菩提心。波罗蜜行不弃捐。普能摄受多种善

    护法师品第三

论曰。守护方便说有三种。谓护身语得离诸难。护持正法行者思惟守护。不令他人之所损害。离此难事。如虚空藏经护持正法诸菩萨等同说偈言。最上两足尊。于此灭度后。咸生勇猛心。不自惜身命。护持佛正法。弃舍于利养。及离诸眷属。为证佛智故。不舍是正法。若毁恨骂辱。乃至加恶言。护持正法故。我等皆当忍。或戏调轻蔑。诽谤不称赞。护持正法故。一切皆当忍。又总略云。为末法众生。我当持正法。如世恶比丘。有大增上力。于诸妙经典。不听亦不读。唯自师己见。执异互相非。又于甚深教。皆顺解脱果。如是正法中。心不乐分别。乃至以慈念众生。或不住是法。为起悲愍心。得持是经故。若见毁戒人。贪着于利养。我当怜愍心。方便令弃舍。若见恶心者。毁谤于正法。我以慈忍心。正见令欢喜。如力护彼人。善成于语业。或复不与言。彼当自安住。后以四摄事。成熟如是人。于罪恶行中。教导令开悟。或能舍愦闹。寂住善境界。如自在鹿王。少欲及知足。乃至偈云。若入于聚落。调柔心正直。诸有求法者。为说深妙法。令远住空闲。乐寂静法欲。由斯善利中。而常获法乐若诸迷谬者。数数现其前安住法乐中。应当自观察。我为导世师。不染世间法。而于毁赞中。若须弥不动。破戒诸比丘。设来增毁谤应自忍是事。慎勿加于彼。又此诸法中。我说。无所有。于斯正法行。不生冤报想。假我沙门相。实无沙门德。闻此嗢陀南。于经亦毁谤。或截于耳鼻。及不喜乐见。闻此嗢陀南。正法悉诽谤。未来诸比丘。护持正法者。为其作留难。不令闻是法。或为王所执。谪罚于大众。我愿承佛威。普皆闻是法。当来恶世时。宁丧于身命。护持正法故。作众生利益妙法莲华经亦作是说。应入行处。及亲近处。常离国王。及国王子。大臣官长。凶险戏者。及旃陀罗。外道梵志。亦不亲近。增上慢人。贪着小乘。三藏学者。破戒比丘。名字罗汉。及比丘尼。好戏笑者。诸优婆夷。皆勿亲近。若是人等。以好心来。到菩萨所。为闻佛道。菩萨则以无所畏心。不怀希望而为说法。寡女处女。及诸不男。皆勿亲近。以为亲厚。及至贩肉自活炫卖女色。如是之人皆勿亲近。凶险相扑。种种嬉戏诸淫女等。尽勿亲近。莫独屏处。为女说法。若说法时。无得戏笑

论曰。复说是难。所谓魔事般若经云。谓魔波旬于未久住菩萨乘者修习此般若波罗蜜多时。起大势力。又云。复次阿难陀。若菩萨摩诃萨修习此般若波罗蜜多时。有恶魔来于菩萨所。生娆乱意现怖畏事。化雷电火烧十方界。欲令菩萨惊怯毛竖。于一念中退失阿耨多罗三藐三菩提心。复次教人书写乃至读诵。是人不乐弃舍利养。从座而去。如是狂乱作大戏笑。复次书写乃至读诵起诸魔事。谓寻求城邑聚落和尚阿阇梨父母知识营从亲党如是作意。又复思念贼难衣服财物。复次有说法师乐欲如是甚深般若波罗蜜多。书写乃至读诵。彼闻法者或生厌怠。于法师所如是颠倒。乐往他处听余经法。又说法师乐欲大器。彼闻法者希望少分。或说法师唯乐略说。彼闻法者更希荷负。如是一切说为魔事。又虚空藏经云。乃至乐行十不善业舍于善法。如是一切悉为魔事。海意经云。世尊。复次菩萨住阿兰若乐处闲寂以为止足。虽离俗出家少欲知足。然妙乐行不求多闻。亦不化度众生。于讲法处不乐听闻。是中随宜所说诸决定义。应当亲近不生咨问。于少善行亦不希求。然住空闲多乐愦闹集烦恼行如弹指顷。即从座起不自知觉不修违害坏道观门。不行自利利他。世尊。是名菩萨住阿兰若第七魔事。以要言之。世尊复次菩萨有恶知识亲近承事。与善知识体相无异乃至断四摄事断修福业断护持正法。唯修狭惠少欲知足。教招为说声闻缘觉。若时菩萨离大乘行于此菩萨营务定可作者。故乐称量。唯修狭惠。如有处说。菩萨于菩提道勇猛精进暂无懈息。或八九劫当得阿耨多罗三藐三菩提然不能得是菩提果。世尊。是菩萨勇猛精进。于此住着决定无有。唯处闲静得此果故。世尊。是名菩萨于善知识体相第十魔事。若人于此菩萨乘为魔钩所制。缘他法行共乐修习。如其随转亲近下劣之所修作趣下劣行。所谓惛迷。所向无知犹如哑羊。乃至是名第十一魔事

论曰。不学如是勇猛精进菩萨。于一切时处修习如不习等。彼宝云经说。谓诸菩萨于诸威仪进止发精进行。若身若心尝无懈倦。是名菩萨毕竟精进。云何于此精进得生懈倦。或非时分修极重事。遽生怯弱尚未成熟信解难行苦行。便谓施自身肉何得非时持此受用施诸众生。由是菩萨于诸众生而生懈倦。即时损弃积集大果菩提心种子。又虚空藏经云。非时固求是为魔事。谓非时于身忽起如是舍心。如先不修习亦勿少施。住是念者以痴自害。违纯熟菩提心等。是故舍自身肉等事。应善守护如善现药树受用根种于非时施。应善守护此正觉药树亦复如是

论曰。于魔事平等是难。如宝云经说。佛告善男子。云何离诸魔事得不坏善。谓此菩萨一切时处。应先远离诸恶知识亦不对类。诣彼方所论世俗语亲近利养供养恭敬。如是多种一切时处悉皆远离。又若微细烦恼能障菩提道者。一切时处亦皆远离。善知如是所对治故。彼经复说恶知识相。谓毁正戒者。此恶知识。应当远离。如是毁正见正行正命之者。悉皆远离。乐愦闹者。多懈怠者。着生死者。背菩提门者。乐居家眷属者。应当远离如是诸恶知识。善男子。虽乐远离此恶知识。然不于彼发起恶心及损害意。应如是住心。又世尊言。处众生界破遣合集。是故我应远离此故

论曰。失菩提心是难。故宝积经云。复次迦叶。菩萨成就四法失菩提心。何等为四。一者谓于阿阇梨及余师长。而不尊重返生欺诳。二者无疑悔处令他疑悔。三者住大乘者而不称赞段生骂辱。四者与人从事心行谄诈而无正直。复次迦叶。菩萨成就四法诸所生处得不舍离菩提之心。乃至坐菩提场相续现前。何等为四。一者设遇丧命因缘。不以忘语亲近戏笑。二者与人从事心行正直离诸谄诈。三者于诸菩萨起议论想。随所四方称赞其名。四者化度众生志不求余。一切具足令住阿耨多罗三藐三菩提。佛言。迦叶。是名四种。师子王所问经偈云。若人行法施。亦不为凌灭。是入速疾得。诸佛集会中。如星贺太子。生生念法施。又生生世世。乃至梦寐中。不舍菩提心。况复今觉时。彼经又云。若于是行处。或聚落城邑亦不舍是心。教化令他悟。文殊庄严佛刹功德经云。菩萨成就四法不失本愿。乃至得离憍慢悭贪嫉妒。或见他人安隐富乐代之悦豫

论曰。如是于菩提心开发无妄失故。如宝积经说。一切威仪进止。皆菩提心事业。是心由过去菩提心故。又月灯三昧经偈云。若人多疑惑。应受我教敕。由得此深心彼疑当出离

论曰。不澄厚是难。远离此者。见宝云经说。菩萨发如是心。以我精进怯弱下劣及懈怠故。修习菩提自谓难得。如是于无量多百千劫之所积集。如救头然方证菩提。我今弃舍如是重担。云何菩萨发如是谓言。所有三世如来正等正觉。精进修行方现等觉。乃至如是非不长时现成正觉。我今亦应于多劫中护持攀缘。为诸众生积集精进。当得阿耨多罗三藐三菩提

论曰。复说是难。宝积经云。于未成熟众生而同善巧。是菩萨错谬。于非法器众生示以诸佛深广妙法。是菩萨错谬。于广大信解众生示下劣乘。是菩萨错谬

论曰。不信解是难。如护国经云。谓于佛法僧宝不生信解。亦不信解学杜多行。亦不信解罪福等事。住是过失门者。由此死已设生人中受痴冥报。后受地狱饿鬼畜生之苦

论曰。为离此者。见宝积经说。若人于甚深法无所入解。不生诽谤如来如是证知。又云。然我不能知解。但于无量诸佛菩提。种种信解故。如来为此众生说正法行

论曰。应知舍善营事行是难。故菩萨别解脱经云。于行法比丘所为供养佛。听闻妙法亲近营事

论曰。彼营事行。如宝积经说。佛言营事比丘于诸比丘众应护持是心。若阿兰若比丘乐空寂处坐。彼营事比丘于一切时处不应役使。时阿兰若比丘设入众学处而得役使。是营事比丘应代彼作。或别请比丘代彼阿兰若比丘作故。若有行乞食比丘。彼营事比丘应与美膳而供给之。复次迦叶。若有比丘得离扼者。彼营事比丘随其所须一切给与。所谓饮食衣服卧具医药。若离扼比丘所住之处。不应高声。彼营事比丘于离扼比丘所。近住坐卧为作防护。随其所乐上妙饮膳而供给之。又云。若有多闻比丘。应当勇悍乃至守护。若有说法比丘。应当为法乃至就座听法。住法会处或论议场清净之处。乃至应当三唱善哉。以要言之。不应于所有物起自在想。设少有办事众许方作。勿自许用。乃至现前僧物。四方僧物。不相掍聚。及佛塔物更互积聚。应善遮防如是颠倒。若四方僧物与现前僧物互有疑滥。彼营事比丘应白众言。此现前僧及四方僧利养事。应同意施作如是佛塔朽坏。应求施者而为兴作。是佛教敕。复次迦叶。若佛塔物多。彼营事比丘不应分与现前僧及四方僧。所以者何。以佛塔物下至十分之一。皆是净信。何得多取。诸天世人生佛塔想。况复珠宝皆即宝故。若取佛塔衣于如来制底。宁使风雨曝烂散灭。不应以宝贸易此衣。如来塔衣无有人能善作价者。又佛无所须故。佛言。迦叶。若营事比丘以恶心故。于持戒者为手供给自在役使。以不善业堕大地狱。设得为人作世奴仆希求财利。为他役使毁骂打扑。以要言之。或于比丘更作新制。恐畏谪罚非时役使。是营事比丘以不善根堕大地狱。名曰多钉乃至千钉钉身。炽然猛焰成大火聚。又总略云。其舌广长百由旬量于舌根上每百千钉炽然猛火。难堪难忍。佛言。迦叶。又营事比丘若来若去。得僧利养悭惜拘藏。或应时不时与或困苦与。乃至不与。是营事比丘以不善根故。死堕饿鬼。名食粪丸。有大力鬼持以示之。初不得近。然于粪丸仰目谛视。受饥渴苦经百千岁。于其饮食了不可得。设有少得。由险恶行悉成粪秽。又僧护缘起亦说是难。佛告僧护比丘言。如汝所见。实非是壁。是地狱人。迦叶佛时。是出家人以非理洟唾污僧坊壁。由斯业报受肉壁苦。猛火烧然至今不息。又汝所见。实非是柱。是地狱人。如前非理以洟唾污僧坊柱。受肉柱苦至今不息。又汝所见。实非树叶华果。是地狱人。如前非理于僧坊树叶华果。独先受用或与白衣。受肉树等苦至今不息。又汝所见。实非紧索。是地狱人。如前非理于僧坊索。独先受用或与白衣。受肉索苦至今不息。又汝所见。实非是杓。是地狱人。迦叶佛时。而为沙弥。以悭诳心执杓摩拭。客比丘来时。彼沙弥见已背立。客比丘言。此众有浆饮否。彼悭吝心答如是言。汝何不见执杓摩拭。求欲饮水尚未可得。时客比丘到已默然。空无所得惭赧而去。由斯业报受肉杓苦。如前不息。又汝所见。实非杵臼。是地狱人。迦叶佛时。比丘聚物主事缘处。有一沙弥持印记者。即阿罗汉。有比丘来语沙弥言。当须杵臼。彼言。尚座且住须臾。我有少务。后当与捣。彼发愤恚语沙弥言。我若得是杵臼。掷汝臼中如是舂捣。何况杵臼。是时沙弥知彼碜毒恶言骂辱。我若报言转增愤恚。默然而住。乃于后时嗔骂少息。诣彼说悔。大德上座如是烦恼。彼言。汝知此迦叶佛法律中出家沙弥我为上座。比丘沙弥说言。若如是者。我等出家。云何断除一切烦恼。解脱一切结使。出是恶言。应善对说悔罪之法。是名随所至向使业消薄。时上座比丘不为对说。嗔犹不悔。以斯业报作肉杵臼。受苦不息。又汝所见。实非是铛。有比丘来铛不用否。沙弥答言。且坐须臾承事病比丘故。为彼煎药。是比丘不乐此说。以恶心故。坏铛而去。受肉铛苦。至今不息。又汝所见。中间若断唯少连持者。是地狱人。由昔主持比丘利养以悭惜故。回换众物。冬时雨时交互而与。由斯业报受苦不息

    空品第四

论曰。复次经说大义。如虚空藏经云。佛告弥勒菩萨言。灌顶刹帝利王。有五根本罪。若犯此者。焚灭一切宿种善根。趣向恶道堕他胜处。远离一切天人等乐。何等为五。善男子。谓灌顶刹帝利王。故取佛塔物四方僧物。自作教他。是名第一根本罪。若谤声闻乘法缘觉乘法谤大乘法隐蔽留难。是名第二根本罪。若依我法而出家者。剃除须发被袈裟服。于学无学持戒毁戒。脱其袈裟逼令还俗。或加捶打狱囚系闭。或断命根。是名第三根本罪。杀害父母。杀阿罗汉。破和合僧。以恶心故出佛身血。随作一事是五无间业。是名第四根本罪。若谤无因果不畏他世。自行十不善业道。或转教多人。身自坚住。教他坚住十不善业道。是名第五根本罪。乃至总略。若乐破坏国邑聚落舍宅人民。是名根本等罪。以要言之。复次善男子善女人初行住大乘者。有八根本罪。此初行住大乘者。于根本罪而有错谬。焚灭一切宿种善根。趣向恶道堕他胜处。远离天人大乘等乐。久处轮回离善知识。何等为八。此诸众生因昔恶行。而生险难五浊恶世。以少善根近善知识。得闻甚深大乘经典。其人浅智即发阿耨多罗三藐三菩提心。而初行菩萨闻说甚深法空经典。如其所闻受持读诵。为前浅智如实开示巧妙文义广大境界。彼愚夫异生闻如是说。心生怖畏。心怖畏故。即便退失阿耨多罗三藐三菩提心。发声闻乘心。是名初行菩萨第一根本罪。善男子。以犯罪故。焚灭一切宿种善根。趣向恶道堕他胜处。远离天人大乘等乐。毁菩提心。是故菩萨于他有情补特伽罗深心志愿。应先知已如心所行。随其渐次而为说法。譬如渐入大海。以要言之。复次初行菩萨。发如是言。汝不能修习六波罗蜜行。亦复不能得阿耨多罗三藐三菩提。汝应速发声闻辟支佛心。汝可速得出离生死。乃至如前所说。是名初行菩萨第二根本罪

大乘集菩萨学论卷第四大乘集菩萨学论卷第五

        西天译经三藏银青光禄大夫试光禄卿普明慈觉传梵大师赐紫沙门臣法护等奉　诏译

    空品第四之二

复次初行菩萨。作如是言。汝何坚持守护波罗提木叉及律仪戒。应速发阿耨多罗三藐三菩提心。读诵大乘经典。若身语意所集烦恼。不善业报悉得清净。乃至如前所说。是名初行菩萨第三根本罪。复次初行菩萨。作如是言。善男子。如能远离听受读诵声闻乘法。亦不为他人说此声闻乘法。不能得大果报。不能永断烦恼。应信大乘经典。听受读诵为他人说此大乘经法。能令忏除一切恶道罪报。速得阿耨多罗三藐三菩提故。如彼所言。取是见者二俱得罪。是名初行菩萨第四根本罪。复次初行菩萨。作二种语。如其所见大乘经典。为利养故广大称赞受持读诵。听其义理为他人说。便作是言。我是修大乘者。见他得利而怀嫉妒。又陀所得或全或分。便生讥谤轻毁淩蔑。以嫉妒故。自高其身。便谓我得过人之法。于大乘中有斯妙乐。是人由财利故。得大重罪。趣向恶道堕陀胜处。譬若有人欲入大海修治船舫。将至宝渚自坏其船丧失身命。此初行菩萨摩诃萨亦复如是。欲入大乘海中。以嫉妒故而作妄语因缘。毁坏信船断智慧命。此初行愚童诸小菩萨。以嫉妒故得大重罪。是名第五根本罪。复次善男子。未来世中当有在家出家初行菩萨。于甚深空义所属经典三昧总持诸忍诸地大庄严事。善人沙门及菩萨行于此大乘经典。受持读诵广为人说。然于是法我自所证。由悲愍故我为汝说。应当修习。汝亦得证是甚深法如我知见。彼不实言但能读诵此甚深法及为他说。于此深法而实未证。求利养故。妄说我得三世诸佛所证之法。菩萨圣人无有过上。得大重罪。即是欺诳诸天世人。于声闻乘尚未能得。何况入解大乘胜行及阿耨多罗三藐三菩提耶。譬若有人居大旷野。大果树下饥渴所逼求索饮食。此大果实色香美味皆悉具足。弃已自趣毒药树下。食毒药果即时命终。我说此人亦复如是。于难得中得获人身。依善知识遇大乘法。贪利养故。虚炫己德卑贱他人。如是行相得大重罪。由重罪故。决趣恶道。是人一切刹帝利婆罗门吠舍首陀及诸智者之所摈弃。皆勿亲近。善男子。是名菩萨第六根本罪。复次善男子。未来世中刹帝利王有旃陀罗国师等。而实愚懵。自谓明智起诸憍慢。具大财宝及大受用。种种布施营修福业。恃布施故增益我慢。向刹利王分别沙门无量过失。依王势力非理治罚责其课调。时诸比丘为彼所逼。或取佛塔物四方僧物现前僧物。而转与之。诸旃陀罗持以上王。如是二种俱获重罪。善男子。是名初行菩萨第七根本罪。复次有刹帝利王与旃陀罗沙门共立制限。非法谓法法说非法。舍诸契经毗奈耶学。不依时说及广大说。舍大悲眼般若波罗蜜多学处方便善巧学处及余契经所说学处。舍如是行相。彼行法比丘先所修习极生娆乱。以娆乱故损智惠命。即便弃舍奢摩他毗钵舍那。劝行他事多有所得。时彼比丘无以制伏诸结烦恼。又诸比丘或于彼时毁弃深心。戒见行等多起过失。实非沙门自谓沙门。实非梵行自谓梵行。说法问难如螺贝音。令王大臣恭敬供养。向白衣舍说是行法比丘无量过失。令王大臣为立制限。取彼行法比丘所乐受用资生之具。如是二种俱获重罪。所以者何。禅定比丘是良福田。营福业者之所依止。是求三昧总持诸忍诸地之器。执持应器作世光明。开示正道于业烦恼地。令诸众生住涅盘道。善男子。是名初行菩萨第八根本罪

论曰。如彼复引余契经云。若诸菩萨闻虚空藏菩萨名已。无有疑惑。欲睹见者。畏堕恶道忏彼重罪。于虚空藏菩萨。称念其名恭敬礼拜。善男子。如其福力住其人前。或见本身或现梵王身。乃至或现童男童女等身。令初行菩萨如从座起于所犯罪悉皆忏悔。及为演说甚深方便善巧大乘之行。乃至住不退地。又总略云。设不现前彼初行菩萨面。于东方阿噜拏天子住立其前。烧香劝请作如是言。汝阿噜拏天。有大慈悲具大威德。照阎浮提悲愍覆护。速自劝请虚空藏菩萨起大悲愍言觉悟我。而于梦中方便显示所犯罪报。授我忏悔得圣大乘智惠方便。彼阿噜拏天出现阎浮提时。与虚空藏菩萨俱来。以本色相即于梦中住其人前。忏彼重罪于如是相谓大智方便。知见方便。善巧智方便。彼初行菩萨获三摩地。名不失菩提心。依此大乘得坚固住

论曰。或有是经先说。真言劝请仪轨等事。作如是说空寂深林辽夐之。处烧沉水香多伽罗香坚黑诸香。遍十方界五轮礼敬。合掌诵此真言曰

怛[寧*也](切身)他(引)苏没哩(二合)舍苏没哩(二合)舍歌(引)噜尼葛左啰左啰尾左啰散左啰歌(引)噜尼葛牟噜噜牟啰尾誐[馬*犬](引)哩摩(引)左弭勃噜(二合)惹摩多歌(引)噜尼葛进多(引)摩尼布(引)啰葛歌(引)噜尼葛萨哩嚩(二合引)娑(引)弥萨他(二合引)波野阿(引)倪也(切身引)[馬*犬](引)哩(引)萨普(二合)颙(五工切)萨普(二合)颙(上同)噜底尾微葛颙(上同)涅哩(二合)瑟致(二合)尾微葛颙(上同)布(引)啰野歌(引)噜尼葛布(引)啰啰演睹摩摩(引)舍(引)萨哩嚩(二合)钵探左阿输(引)葛誐底萨嚩(二合引)贺(引)

说前仪轨。一切病苦。一切怖畏。一切恼害。悉皆殄灭。诸希求事亦悉成就

论曰。若刹帝利若菩萨等。云何罪咎及胜方便。或持戒者。云何说罪。云何过失。谓于持戒者无过失者。多起打扑名执自见。由是展转生怖灭诸罪咎。若于此大性罪拔去苦本毕竟不造。于菩提心戒是所堪任。如实观察相续思惟。故方便善巧经说是根本罪云。善男子。菩萨于别解脱戒学式叉摩那百千劫中唯食根果。解脱一切众生忍受恶言。若于声闻辟支佛行相应作意。是名菩萨根本重罪。善男子。得是根本罪者。譬如声闻于有余依涅盘而不堪任。善男子。此所说罪于声闻缘觉作意无有出离亦复如是。于佛地涅盘而不堪任

论曰。此诸重罪由执我故。持为妙乐是义云何。摄论释云。破坏三宝物。或如芥子量。谤正法二罪。是牟尼所说。设破戒比丘。由被袈裟服。或不听出家。捶考系牢狱。造作五无间。又或执邪见。及破坏聚落。此名根本罪。是胜尊所说。但乐谈空性。实自无知觉。设住佛智中。不修正觉道。舍斯别解脱。希入大乘果。又令诸学人。不断于贪执乐向他人前称扬自己德。由光于他人。广获其利养。或复邪妄说。我得甚深忍。或责罚沙门。故取三宝物。由如是取已。复舍奢摩他。或行法比丘。与所爱受用。是名根本罪。因堕大地狱。又虚空藏菩萨住立佛前宣悔梦中舍菩提心偈云。有诸来乞者。悭贪而不施。碜然生忿怒。打扑诸众生。清净一心者。亦不为恭敬。随他染欲心。诽谤于正法。地藏经云。佛告大梵。若依我教而出家者。犯戒恶行内坏腐败如秽蜗螺。实非沙门自谓沙门。实非梵行自称梵行。常为种种烦恼所胜败坏倾覆。如是比丘虽破禁戒行诸恶行。尚为一切天龙人等开示福德行。故此善知识然非法器而。剃除须发被袈裟衣于无量众生种种善根为开导。因近生善趣显示正道。是故若依我教而出家者。持戒毁戒。我尚不听转轮圣王依俗正法鞭挞其身牢狱系闭节节支解断其命根。况余非法。如是比丘。然依我法毗奈耶中。说名死尸。复说彼人如牛有黄。如麝有香。又云。若依我教而出家者。是器非器不应恼害。即是毁犯三世诸佛。得大过咎焚灭善根堕无间狱。彼经又云。被袈裟衣解脱幢相。是诸如来之所建立。尔时复有无量百千声闻及菩萨众。闻佛所说。皆忏往昔造业障罪。或言。世尊。我于往昔如来圣言量中。及佛弟子是器非器。多行忿恨呵骂毁辱种种诽谤。造业障罪堕三恶道。受种种苦难堪难忍。以要言之。世尊。我于如是业障今悉忏悔。或言。世尊。我念往昔于声闻教及佛弟子是器非器。恐畏恶骂加诸杖捶。复有说言。于佛弟子侵夺衣钵断其受用。复有说言。于出家者逼令还俗非理役使。复有说言。于佛弟子是器非器。有罪无罪。枷锁牢狱。是业障罪于多劫中堕诸恶趣。受种种苦难堪难忍。乃至白言。世尊。是业障罪今悉忏悔。更不敢造。唯愿世尊。摄受怜愍。济拔我等广大罪报。障碍出家经亦作是说。若人成就四大舍法。在所生处获如是难。谓生盲愚哑。或旃陀罗乐多毁谤无诸妙乐。常为奴仆。或作女人扇茶半择迦等。驼驴猪狗及毒蛇报。何等为四。此大舍者。为过去诸佛作增上力。令诸众生发出离心。出家心。圣道心。为作障碍。是名第一。复次乐贪财贿及贪子息。不信业报。谓言于众富乐自在。男女妻妾有出家者。为作留难。是名第二。余二种者诽谤正法。及害沙门婆罗门等

论曰。十不善业道是难。有极苦报。见正法念处经说。彼中杀生罪报。今当略说云。地狱中。复次有鸟。名火顶行。火中不烧。见地狱人极生欢喜。先破其头。次饮其血。复次有鸟名髑髅行。嘴火焰然食脑脂髓。复次有鸟。名曰食舌。食罪人舌食已复生。过前柔软如莲华叶。如是义者随想所生。复有诸鸟。或名拔齿。名执咽喉。名曰食毛。名曰食肺。名食生藏。名食背骨。名食隐密。诸骨节间破已饮髓。次复有鸟。名曰针孔。嘴利如针。唯饮其血。复有诸鸟。名骨中住。名曰拔爪。名食筋脉。名曰拔发。唯食发根。如是阿鼻大地狱中三千由旬名恶夜叉飞鸟住处。于百千岁食已复生。受大苦恼。彼经复说。一切苦网周遍围绕。复有地狱。名堕险岸。疾趣彼处希望归救周匝行时。十一火聚独无伴侣。唯有冤报业绳所缚遍常随逐。谓令趣入诸大地狱。复次趣入堕险岸处。彼下足时炽然销烂。举足复生。过前柔软以柔软故受极痛苦。如是惶怖。头目手足一切肢分。悉皆销烂。而说是处世所希有。名堕险岸。复说堕处。业风所飘高三千踰缮那量。后堕地已。雕鹫鸱枭竞分食之乃至业风举已还堕。经百千岁受如是苦。彼经复说。次有堕处。名曰旋轮。有千辐轮世所希有。炽然猛利。正使金刚不能沮坏。是轮于身速疾旋转。乃至缘诸身分悉皆烧然。举足行处为钉所刺。如是趣入蠰酤吒山。有蠰酤吒虫食彼罪人。食已复生过前柔软。以柔软故受极痛苦。生已复食。食已复生。于是身肉过前希有。由彼快意。造杀生者得如是果

论曰。不与取报。我今当说如是恶作业行。于地狱中有大资具。如旋火轮。乾闼婆城鹿爱相似。由痴恶业。见有珠宝衣服财物种类若干。以痴业故。于炽焰中奔捉彼物。自业所造琰魔罗卒。执利刀釰诣铁网中劈割烧然一切肢分。唯有骨在。由无始来不舍财利。受斯苦报

论曰。造欲邪行。我今当说。造斯罪者。于前苦处暂得脱已。恶业旋增过大火聚。复堕他处。名恶邪见。由业所造见有女人。如先所睹。彼既见已。无始时来贪火发生。即便奔趣彼女人者。自业所造皆铁所成。为彼执已啮其唇吻食其身分。乃至无有如芥子许。食已复生。生已复食。彼人如是贪火所烧。受极痛苦难堪难忍。如是欲火所烧。于彼女人不念苦恼。彼女人者皆铁所成。坚若金刚。身火洞然。执彼罪人如摧沙茧。一切身分炽然散灭。散已复生过于前说。略彼偈云。女为罪根本。能坏诸财利。若人乐女色。云何获妙乐。乃至。此世及他世。女失第一失。远离女色者。身获安隐乐

论曰。妄语业今当说。有大力琰魔罗卒。执彼罪人以刀劈口钤出其舌。此妄语报。恶业力故。舌广五百踰缮那量。舌相出时。琰魔罗卒即共敷置热铁地上。自业所造百千铁犁。犁头焰然世所希有。极大力牛周遍往来。而耕其舌涎血流溢。耕已复入。以要言之。复出其舌。过前柔软。如天舌相。吐声号哭。受大苦恼。经无量百千岁难堪难忍。彼地狱人。舌暂入口极生惶怖。是恶相状处处驰走。堕猛火聚而或焦烂。于是苦恼希望归救。复有琰魔罗卒。手执刀棒世所希有。麾斫罪人。从头至足如微尘许

论曰。两舌报如妄语说。舌出三百踰缮那彼琰魔罗卒。持炽焰刀断取其舌。狐狼野干随处食之。受极痛苦吐声号哭。断已复生过于前说

论曰。恶口报今当说。琰魔罗卒执彼罪人。以刀劈口断取其舌。由彼饥渴求索饮食。令自食舌及饮自血。恶业力故。断已复生。踠转于地吐声号哭。目精旋动受极痛苦。琰魔罗卒诃责教诫。由自所作谁复代汝。说伽他曰。舌放类坚弓。利言毒火箭。若人恶口说。来斯见大报

论曰。绮语报今当说。琰魔罗卒以刀劈口。灌赤洋铜涌沸炽然。先烧其舌。次烧咽喉。次烧其心。次烧其肠。次烧熟藏。烧熟藏已。从下而出。琰魔罗卒说伽陀曰。前后非联属。无义不相应。汝非联属说。彼果来此受。常不诵佛经。不乐真实语。彼既非是舌。何异于肉脔

论曰。悭贪报今当说。彼地狱人自业所造。望见地邑满中珍宝他人守护。彼地狱人由无始来痴恶业故。谓言已有贪不善业乐行多作。于地狱果起颠倒见。如是见已。为多贪取。手执利刀世所希有。疾趣彼物。余地狱人亦执利刀迭相战掠。乃至食啖。身肉俱尽无有如芥子许唯有骨在吐声号哭。略彼偈云。见他人富足。思惟悕我得。是贪生毒果。而今来此处

论曰。嗔恚果今当说以嗔业故。师子蛇虎住其人前。生大怖畏处处驰走。不善业故何能得脱。为彼执已先食其头。乃至两腋。蛇吐牙毒竞螫啖之。虎食其背火烧两足琰魔罗卒远刺射之。如是广大

论曰。邪见有无量果。少略而说。谓地狱中雨锋利剑。及金刚雹雨诸石等。斩截破坏。复有十一火聚。谓饥渴火从口中出。周匝焚烧

论曰。此诸欲本是难。应如是悔。又如经说。有大地狱。名曰大瓮。何业众生堕于彼处。谓若实非沙门自称沙门。或闻女人歌舞庄严具声。深心作意略无省解。由闻歌舞戏笑故。漏失不净。以要言之。堕彼地狱雨热铁丸。一切肢分碎为微尘。复雨火汤如是烧煮。复次忆念往昔欲邪行者。说有地狱。名钵讷摩。谓由忆念梦中欲事。堕是地狱火镬煎煮。琰魔罗卒持大铁叉而撞刺之。如彼广说。复次然修梵行回向愿生天女众中。说堕地狱。名大钵讷摩。是处有岸。名曰碱河。泛涌烧然。如镕金汁。令身销烂。发毛如草。肉滓为泥。聚骨如石。肠为鱼等。于此地狱经无量时。复次邪欲。谓二男子毁坏正行有无量相。如彼经说。如是毁正行者。于彼碱河见妙童稚出没其中。由昔恶业生极爱乐。入彼河已。即为忧苦之所缠逼。复次邪欲说极恶报。谓于傍生起大性罪。彼地狱中有牛鹿等。热铁所成极不善相。于畜生道欲心附近。满腹炽焰为彼烧煮。经百千岁。乃至广说。复次邪欲。强逼净戒比丘尼等。毁坏正行堕大地狱。广如彼说。复次邪行非道行欲。自欲炽盛侵暴他属。或由近住。或称师教。毁坏正行堕大地狱。无量极苦过于前说。七种合集经说。如是婆罗门于一类同梵行者云。我知彼与是里舍二根和合。或彼里舍观瞩境界。去来住立而起爱着。此说婆罗门梵行合集非离和合法。然修梵行而不清净。如是里舍。或共戏笑。若意乐着。说此梵行而不清净。如是里舍。爱乐承事。有庄严具歌舞等声。来两壁间而起乐着。是名和合。如是五欲乐中于他观察而生爱着。回向梵行愿生天处。是名合集非离和合法

论曰。若思念如是趣欲境界是难。诃欲经云。佛言。比丘。应怖此道断彼欲心。起极怖惧如彼榛棘。此二种道是极险恶。彼不善人之所亲近于如是道。为诸正士之所远离。汝勿如是思惟少分着欲。世尊说此多苦多难及多罪垢。讥毁凌蔑。佛言。比丘。又此欲者如病痈疽中含毒秽。如财利钩。为诸罪本。欲如梦寐。是虚妄法。是死。是空。是无常。是过失。云何愚夫于此乐着。乃至如鹿缚围。如鱼缚网。如蛾缚焰。如猴缚粪。如婆罗门缚诸戒线。其欲如是。又总略云。寻求欲者。譬若群兽行长夜中赴师子口。不知限量。牛死虎口不知限量。乃至虾蟆赴百蛇口。不知限量。又长夜中窥近欲事如行贼道执缚断首。不知限量。强侵他属攻伐聚落杀害人民。乃至笼系执缚断首。不知限量。受极艰苦涌血漫流。如四大海其水尚少。以要言之。况此身者而多讥毁。筋骨缠聚皮肉裹络。毛孔诸虫众多咂食。如大痈疽秽恶充满。又此身者种种病恼。谓眼病耳病乃至痔漏疮癣。彼经复说。又此身者是苦是恼。为老所逼癵躄背伛。无强无力发白面皱。诸根过熟行苦倾败。如是衰旧速朽之法。乃至于如是身臭恶毁厌。不可亲附。以要言之。佛言。比丘。云何于欲有是贪爱。缠绵闷绝耽着追求。若我灭后正法欲没。汝等于欲慎勿亲近。当堕彼趣何待老死授我教诲佛言。止止。比丘。当断欲心。谓若非时求欲。未若依时求法。又最上授所问经云。应知远离彼欲邪行。于自妻属而生喜足。于他眷爱不乐观视。止息是意唯一苦恼。忍伏此欲相应作意。若起欲寻随观不净。亲近欲者应知于染意中得自在故。常离系缚。勿起贪着。于无常身作不净想。如是念住如我所作。起正分别勿嗜于欲。何况恶露不堪表示。彼经复说。菩萨于已眷属当起三想。何等为三。谓暂同戏乐不共他世。唯同饮食然于业报不共领纳。唯同快乐不共苦恼。乃至此复三种。谓破戒想。破定想。破慧想。复有三种。谓贼想。冤想。地狱卒想

大乘集菩萨学论卷第五大乘集菩萨学论卷第六

        西天译经三藏银青光禄大夫试光禄卿普明慈觉传梵大师赐紫沙门臣法护等奉　诏译

    空品第四之三

亦如月上童女所问经云。尔时月上童女见诸人等欲来亲近。即时住虚空中高一多罗树。为诸人等说伽陀曰。汝当观我身。晃耀真金色。非因染欲心。感斯清净质。欲生于境界。如火坑焰然。忍欲调六根。净修诸梵行。设见他妇女。皆生母妹想。后获端正身。他人常喜见。我诸毛孔中。妙香遍城郭。不从贪染心。薰修斯善果。贪心本不生。无欲何生欲。牟尼现证明。如实不虚诳。汝昔或我父。我或为汝母。迭为父母身。情何生染欲。我或尝害汝。他复害我来。怨朋互杀仇。情何生染欲。端正非贪得。贪非生善趣。贪非出离因。是故皆弃舍。又此贪欲因。速堕三恶道。夜叉毗舍阇。及阿修罗众。鸠盘茶鬼等。皆由贪欲故。或聋盲喑哑。跰挛丑陋身。世间诸过患。皆由贪欲行。或得转轮王。及帝释天主。梵王大自在。广因修梵行。若象马牛虎。驼驴猪狗等。性本瞢亲疏。而常希染欲。刹利及王臣。或信士长者。丰饶富乐门。广因修梵行。若枷锁系闭。水火诸苦难。或挑目截耳。及断于手足。乃至为奴仆。此由贪欲故。又曰子王所问经诃欲义偈云。说是着欲者。如蝇见疮血。亦如猪犬等。奔臭肉不净。无知乐女人。奔驰亦如是。愚童不明了。舌舐于秽恶。如痴乐女人。具足诸黑闇。现住魔境界。死当堕恶道。又若厕中虫。着味生乐想。犹如画屎瓶庄严观外相。亦如风槖中。满盛诸秽恶。谓眵洟涎唾。及便利不净。身如臭漏囊。愚夫谓为美。举身唯有骨。皮肉之所覆。唯生一面门。譬若大痈疽。亦如疮孔中。种种诸虫满。及余不净器。此身相亦尔。腹如犬疱等。内生藏熟藏。及头骨肋脉。涂污诸血髓。有八万种虫。潜处于身内。堕痴网笼中。故愚夫不见。又于九窍中。流臭恶不净。或若见若言。愚夫生取相。一切秽恶处。由乐不觉知。涎涕以为食。斯愚夫境界。或两腋汗流。秽恶实可厌。乐斯诃厌事。如蝇见疮等。于下劣法中。嗜欲斯最下。造斯恶业者。死当堕恶道。堕无间狱已。受诸大苦报。佛说诸女人。臭中极臭恶。是故于合集。破斯下劣想。又若起执着。唯愚者奔竞。造斯恶业故。当获如是果。彼经又云。如是行相苦求所须。以自活命封着不舍。乃至衣弊贫穷乞丐饮食。为诸女人之所降伏所持所魅。譬若僮仆自在役使。由于女人贪乐养育。必不能修布施持戒及余善品。又复为诸女人恶骂要勒系缚。由心取着悉能忍伏。或诣女人里舍。起贪很[仁-二+戾]审观姿貌。由欲因缘自在而转。佛言。大王。嗜欲爱者是不清净。是极臭恶于。世间行尚为过失。乃至偈云。于女人合集。见作共随喜。闻已意乐观。彼人无出离。亲近诸苦欲。说此实厌贱。由闻是法故。善说及痴说。是心奔女人。无异鼠逐猫。或闻佛所说。暂时得省解。后复于是贪。如喝罗罗毒。又如猪见粪。发生于爱乐。暂得须臾间。转复生厌怖。着乐诸愚夫。远离于佛教。亲近下劣欲。死当堕恶道。乐耽湎醉欲。毁戒破净命。造作诸罪业。死当堕恶道。若于是正法。了知诸欲境。不生放逸心。常生净天趣。于无上菩提。此不为难得。若闻是法已。刹那获正慧。悟出家法门。远离诸欲事

论曰。复说是难。寂静决定神变经云。佛告文殊师利。设若有人于阎浮提一切有情。劫诸财宝悉坏命根。文殊师利。若善男子善女人于菩萨所断一善心即近堕傍生趣。于所取时如同彼堕。断善根故是罪过前阿僧祇数。所以者何。断善根者。即是断灭佛出世故。佛告文殊师利。又他种类于菩萨所起悭嫉时。以是因缘应知即是求三种怖。何等为三。谓堕地狱怖。及生盲怖。边地难怖。彼经又云。若得为人语不诚实而乐诽谤。恶口愤恚娆恼于人。后复于此身坏命终堕大地狱。生无足身受诸苦恼。宛转五百踰缮那量。为诸小虫咂食其肉。是蛇可畏具五千头。由诽谤故。彼一一头有五百舌。彼一一舌口出五百炽焰铁犁。是语业罪。为猛火聚炽然烧煮。又若起不调柔逼恼菩萨者。是人于畜生道尚为难得。堕大地狱经百千俱胝那庾多劫。于彼死已为大毒蛇惨恶可畏。饥渴所逼造众恶业。设得饮食而无饱足。于此死已。设生人中亦复生盲。无有智慧恶心不息。恶言诃毁不敬圣贤。人中死已复堕恶道。经千俱胝劫生不见佛。彼经又云。文殊师利菩萨于菩萨所乃至发明净心时。而心或轻易。乃至多劫住大地狱如被铠甲。文殊师利。是菩萨业必不能堕。唯除诽谤。是菩萨者。文殊师利。譬若金刚摩尼宝。无有木石能破坏者。文殊师利。是菩萨业亦复如是。必不能堕。唯除诽谤是菩萨者信力财入印经中亦作是说。佛告文殊师利。若复有人于十方一切世界诸众生等起嗔恚缚。堕黑暗处。文殊师利。若于菩萨所远住其前。屈伸臂顷起嗔恚心。是罪过前阿僧祇数。文殊师利。又若有人于诸阎浮提一切财物剽掠皆尽。若于菩萨所辄生骂辱。是罪过前阿僧祇数。彼经又云。佛告文殊师利。设若有人以殑伽沙等诸佛塔庙。悉皆焚毁。若于信解大乘菩萨摩诃萨起嗔恚心。加诸骂辱或增诽谤。是罪过前阿僧祇数。所以者何。从诸菩萨。出生诸佛世尊故。从彼诸佛有塔庙故。生诸利乐及诸天等。若轻毁诸菩萨者。即是轻毁诸如来故。若有恭敬诸菩萨者。即是恭敬诸如来故。欲求最上供养者。应当供养诸菩萨等。即是供养诸如来等

论曰。此供养福报。如寂静决定神变经云。若人护法及说法者。即是远离一切恶道。获天帝释及梵世主夜摩兜率自在天等。后生人中为转轮圣王长者居士。具大财宝念慧相应。安隐无畏

论曰。何等菩萨于菩萨所于善作中起恶心故。谓异生等。又如信力财入印经云。文殊师利。设若有人于一切世界微尘数众生。日日以天百味饮食及天衣服。于殑伽沙劫海如是布施。若有善男子善女人。于成就十善供养如是。说声闻者。说辟支佛者。说大乘者。住大乘人戒德相应乐说辩才与彼无智戏论之者。而为咨禀听受皆应供养。乃至得几罪灭。佛言。善男子。譬如有人以初日分满阎浮提诸大珍宝施佛弟子。以中日分及后日分亦复如是。满百千岁如是布施。是人彼所得福宁为多不。白言。甚多世尊。是人福聚无量无数。于是福聚无有能称量者。唯除如来乃能知之。佛言。善男子。若有真善刹帝利王。乃至如前所说。彼所得福宁为多不。如是广略过前福报无量阿僧祇数。佛言。于后五百岁护正法眼。善护自他及护他世。于我教中作弟子者。是器非器剃除须发被袈裟衣皆应善护勿生恼害。乃至自他国土皆得丰乐灭除罪垢。诸天诸仙增益守护寿命长远。自他烦恼亦皆殄灭。住正觉道六波罗蜜离诸罪恶。于轮回海不久沉溺。常离恶友近善知识。共事诸佛大菩萨众。乐诸佛刹。非久如得阿耨多罗三藐三菩提果。尔时众中一切业道一优婆塞。于一日中能施饮食。于佛弟子如是布施。过前福报阿僧祇数。文殊师利又若于一切世界微尘数成就十善业道诸优婆塞。日日以天百味饮食及天衣服。于殑伽沙劫海如是布施。若复有人于一比丘。若一日中能施饮食。过前福报阿僧祇数。入定不定印经云。佛告文殊师利。假使十方一切世界诸有情类。皆被挑目至满一劫。复有善男子善女人于诸有情起慈愍心。令眼平复还满一劫。文殊师利。若复有人于信解大乘菩萨所。以清净心而往瞻觐。过前福报无量阿僧祇数。文殊师利。假使有人能令十方一切牢狱系闭众生皆得脱已。复受转轮圣王妙乐或梵天乐。若复有人于信解大乘菩萨所。以清净心瞻觐赞叹。过前福报无量阿僧祇数。又地藏经云。世尊。若真善刹帝利王。真善居士。真善宰官。真善沙门。真善婆罗门等。自护护他及护他世。于佛弟子是器非器乃至剃除须发被少分袈裟衣者。皆应守护天主及天眷属乃至毕舍遮主。与其眷属皆从座起。合掌恭敬而白佛言。世尊。若未来世乃至后五百岁真善刹帝利王。真善居士。真善宰官。真善沙门。真善婆罗门等。如是守护正法绍三宝种皆令炽盛。以要言之。所有我诸眷属。真善刹帝利王。真善居士宰官等。于十种事守护增长。何等为十。一者增益寿命。二者广持正法。三者常无病恼。四者眷属广多。五者仓库盈溢。六者寿命无乏。七者富贵自在。八者名称普闻。九者得为善友。十者智慧具足。是名十种广如彼说

论曰。应知此广大报如是入圣地者。故观音经云。发正觉心者善利一切众生故。若唯右绕佛塔。我犹说此功德广大。汝诸佛子。若人不爱诸天远离善人。是地狱境界。广如前说

论曰。未能于余开示。且止此分别。净诸业障经云。凡说障碍皆名为难。佛告文殊师利言。云何说名障碍。谓贪为障嗔为障痴为障。布施为障持戒忍辱精进禅定智慧皆为障碍。所以者何。愚夫异生于布施时为悭惜者不起净信。由不净信发损害心。由损害故生悔恼罪堕大地狱。彼护戒者。为破戒人加诸诽谤不为称赞。令诸人等闻过失已。不生净信。由不信故即堕恶道。彼修忍者由忍倨傲。是忍惛醉浑浊于心。由忍惛醉为放逸本即堕苦处。发精进者便起我慢。云余比丘修行懈怠。不共信施之食及饮水具。由发精进起我慢故。轻贱于他如彼愚夫。安禅定者。由于净虑三摩钵底发生爱乐。彼便如是我得三摩地行。余诸比丘心行散乱。由何得佛。广如彼说又随转诸法经云。教招菩萨除业障罪。远得菩提。教招威仪。远得菩提。教招威仪道行。远得菩提。然彼菩萨于菩萨所生下劣想。己身发高大想。谓我少除业障故。此菩萨于彼菩萨或说教令应住佛想。菩萨于菩萨所勿起毁訾之心。彼不舍菩提故。佛言。天子。菩萨如是不断少分善根。如菩萨不二行中。设不发菩提心者。下至聪利菩萨。尚不起於陵蔑。何况发菩提心者。如首楞严三昧经云。佛语坚意菩萨言。云何未发菩提心者而与授记。若人得生五趣轮回或天人傍生地狱琰魔罗界。是人诸根猛利广大信解。如来于彼了知是人乃至若干百千俱胝那庾多劫当发阿耨多罗三藐三菩提心。乃至如是百千阿僧祇劫得菩提果。以要言之。佛言。坚意。说此菩萨名未发菩提心者而与授记。尔时尊者大迦叶波前白佛言。世尊。从是已后当于一切众生起世尊想。所以者何。我等无有如是智慧。何等众生此有成熟菩提根者。何等是无。世尊。我等不知如是行相。若于众生起下劣想则为自伤。佛言。善哉大迦叶波。快说此语。以是义故。自在正观。我于所说如是法中。不妄称量出家在家男子女人。若妄称量则自伤也。唯有如来应量众生等者。大迦叶波若诸声闻及菩萨。说当于一切众生起世尊想

论曰。菩萨于诸补特伽罗。何有少分不作化度不护身者。见有如是。幖相决定得菩提故。于彼佛子不应陵蔑。应当守护。如妙法莲华经云。或有起石庙。旃檀及沉水。木櫁并余材。塼瓦泥土等。若于旷野中。积土成佛庙。乃至童子戏。聚沙为佛塔。如是诸人等。皆已成佛道。乃至彩画作佛像。百福庄严相。自作若使人。皆已成。佛道乃至童子戏。若草木及笔。或以指。爪甲。而画作佛像。如是诸人等。皆已成佛道。若人于塔庙。宝像及画像。以华香幡盖。敬心而供养。若使人作乐。击鼓吹角贝。箫笛琴箜篌。琵琶铙铜钹。如是众妙音。尽持以供养。或以欢喜心。歌呗颂佛德。乃至一小音。皆已成佛道。若人散乱心。乃至以一华。供养于画像。渐见无数佛。或有人礼拜。或复但合掌。乃至举一手。或复小低头。以此供养像。渐见无量佛。又云。若人散乱心。入于塔庙中。一称南无佛。皆已成佛道。于诸过去佛。在世或灭后。若有闻是法。皆已成佛道。又大悲经云。佛告阿难。譬如渔师为得鱼故。于大水池中安置钩饵。令鱼吞食。鱼吞食已。所以者何。然知此鱼尚在池中不久当出。复如是知为彼坚钩竿绳所中系岸树上。时捕鱼师既到其所。即验竿绳知得鱼已。便拽钩绳敷置岸上。如其所欲而受用之。佛告阿难。我今亦复如是。令诸众生于佛世尊心生净信植诸善本。乃至以一信心。彼诸众生虽余恶业之所覆障。刹那堕落。若佛世尊于彼众生。以菩提智执摄事绳。于轮回海拔诸众生置涅盘岸

论曰。是故皆作佛想礼敬。应知此尚意中作礼。若初发菩提心者以身礼敬。如善财童子于宝云大菩萨所初发道意以身敬礼。一切斯为了义。如深心教诫经云。为诸菩萨于所度生恭敬作礼。而或所说何一处所礼不礼故而无相违。于是礼敬展转系属。不如是礼者而无福报。由何一礼得睹诸佛。无有是处

论曰。谓此是菩萨学处此非菩萨学处。俱谤正法说为是难。故集诸法方广经中说言。佛告文殊师利。云何于如来所说少分法中。或起净想及不净想。俱谤正法。谤正法者。即是毁谤轻慢诸佛法僧。又说此是解脱。此非解脱。俱谤正法。我非别说有法属声闻乘属缘觉乘属于大乘。彼愚痴者于我此法中种种施作说言此是声闻。此是缘觉。此是菩萨。由起种种想故便谤正法。云此是菩萨学处。此非菩萨学处。谤正法者。云此说法师有是辩才。无是辩才。亦名谤法。又说此是法说。此非法。俱名谤法。云过去佛出世无有总持可得。亦名谤法。于说法师亦无总持。悉名谤法。于说法师是过失行。亦名谤法。谓说法师无此具足辩才。是名谤法。教示放逸。是名谤法。教示威仪道行。亦名谤法。教不正戒。是名谤法。缺减辩才。是名谤法。于光明法而不了知。亦名谤法。于持明召请不悟所说。是名谤法。于如来教唯文字想而无入解。皆名谤法

大乘集菩萨学论卷第六大乘集菩萨学论卷第七

        西天译经三藏银青光禄大夫试光禄卿普明慈觉传梵大师赐紫沙门臣法护等奉　诏译

    空品第四之余

谓此契经违余契经。俱名谤法。谓此伽陀违余伽陀。亦名谤法。何者是起信解。何者不起。皆名谤法。于说法师所说意解别异而转。是名谤法。作此事业离眼所观说戏笑语。是名谤法。此是有行此是无行。俱名谤法。说此佛言三昧有是解脱说。彼佛言三昧有是解脱。亦名谤法。佛告文殊师利。乃至所有一切展转。皆名谤法。若比丘比丘尼优婆塞优婆夷等。于说法师如是行相如是思惟。一切皆是毁谤正法。彼经又云。佛言。善男子。若如来灭后于我已说法中。随所爱乐如其信解为众生说。于彼会中若一众生身毛喜竖。或堕泪悲泣。当知是为诸佛印可。彼愚痴人谓言。此是菩萨。此非菩萨。当知是菩萨咎。由如是妄说三乘法故。于我所说法中何由悟解。乃至若于菩萨起陵蔑者。我说是人住于地狱。不知限量。所以者何。若菩萨于说法师起诽谤者。即是远离诸佛毁谤正法及比丘僧。又若轻贱诸说法师不起尊重者。即是于佛如来不生尊重。于说法师不欲见者。即是于佛如来不生乐见。于说法师不称赞者。即是于佛如来不起称赞。是则远离佛故。若于初发心菩萨起恼害意。乃至。佛言。慈氏。若于我六波罗蜜诸菩萨正觉行中。彼愚痴人妄作是说。唯般若波罗蜜多应知是菩萨学处。云何学余波罗蜜多。余波罗蜜者。彼为过失佛言。慈氏。于汝意云何。我为烁迦尸王脱虎子命施自身肉为无智不。慈氏白言。不也世尊。佛言。慈氏。若修菩提行。六波罗蜜行之所相应。发善心者。颇不成熟善根不。慈氏白言。不也世尊。佛言。阿逸多。汝亦于六十劫。集行布施持戒忍辱精进禅定般若波罗蜜多。皆共集行。又愚痴者作如是说。唯一正理是菩提道所为空性行。是正理者得本然清净等

    集离难戒学品第五

论曰。略说是难。应当远离。如深心教诫经云。如是种难。闻已怖畏。是初行菩萨如其受持。说利益事白言。世尊。我今最初于如来前如是受持。世尊。我若从今于彼菩萨及所化人说彼过罪。若实不实。是则欺诳如来正遍知者。世尊。又我从今于彼菩萨及所化人讥毁陵蔑。或在家者或出家者。受五欲乐纵逸自在。见已于彼不生净信及惭赧心。起不尊重不生佛想逼恼身心。化知识家受下种施。见已。若不唯一喜美言说。昼夜不以三时归向。是则欺诳如来正遍知者。世尊。我若从今受持禁戒。或作诸王。于身命财而不舍施。陵蔑声闻缘觉及所化人。谓我最胜。或如旃陀罗心行。自高其身卑下他人。或遇斗诤而不怖走。过一由旬或百由旬。是则欺诳如来正遍知者。世尊。若我从今身持具戒或不以多闻别知头陀功德及余出生功德之身乐行。覆藏他善显他过恶。是则欺诳如来正遍知者。乃至。尔时世尊语弥勒菩萨摩诃萨言。若有善男子善女人欲净诸业障者。应如此初行菩萨如是受持。又随转诸法经云。谓若于菩萨昼夜三时头顶礼敬。是人于所行行。亦勿少分窥求错谬。设若常见着五欲乐。亦勿少分窥求过失。菩提行者修无量功德殊胜利益时乃取证由是渐次修道渐次成佛。正使修行一嚩啰分。于无量百千俱胝那庾多劫住大地狱如被铠甲。彼经又云。善男子。如是行相远离罪业。彼菩萨一切行中皆不二行。应当信解一切修作发如是心。然我于他心了知不难。化诸众生行如是行。复次善男子。自在遍观如来如是说法。应无有人称量此者。若人解我所说则为见我。善男子。欲护身者于此行中略无疑惑。如其所作不坏他善。求佛法者当知于昼夜中以法思解。如地藏经云。尔时复有无量百千黠惠众生。从座而起合掌恭敬。而白佛言。大德世尊。我今现前发如是愿。乃至久远流转生死。未得忍间常愿不处诸王宰官城邑聚落辅相将帅等位。乃至不处商主师长居士主沙门断事者一切亲属富贵尊重等位。乃至未得忍间。我等若处如是行相。是愚恶惠。则于佛世尊教无能修习

论曰。广说离如是难。如月灯三昧经偈云。愚童不恭敬。应知无有罪。其母尚教言。汝当后时作。欲少分所须。于我起尊重。若因无上道。懈倦于化度。问讯于耆年。及大德尊者。头面接足礼。为此作尊重。勿视彼错谬。唯观菩提场。常乐起慈心。亦勿生损害。又设见错谬。慎说彼过失。若乐斯善业。亦获于道果。卑幼尊宿前。如面清凉月。常爱乐此言。猛除伏我慢。若饮食衣服。为此作怜愍。施汝如是心。一切得调伏。若发菩提心。或不生信重。彼应自防护。怖堕于恶道。见不见喜纳。自净浊乱心。心惟分别性。堪任获事业。又如华严经云。时慈氏菩萨观善财童子发菩提心功德。以偈赞曰。若见诸众生。老病诸苦逼。及忧生死怖。发大悲利行。由见世苦逼。五趣常流转。为求坚利智。破诸趣苦轮。若见贪乐者。过患多榛棘。为作坚固犁。净治众生地。痴坏世间明。及正道惠眼。为群盲导师。示其安隐处。智剑伏冤贼。解脱三法忍。为世间导师。令得离忧怖。或如法舡主。令涉智海道。为三有导师。达胜忍宝所。智光大愿轮。如佛日出现。光含法界空。普照群生暗。白法圆满轮。如佛月出现。慈定清凉光。平等照诸有。又若胜智海。出生诸法宝。菩提行渐高。住深心坚固。发心若龙主。升法界虚空。雨甘露法云。增诸白果苗。又若然法灯。正念坚固器。慈爱无垢光。净除三毒暗。又此菩提心。譬如羯逻罗。悲疱慈闭尸。钵罗健南位。菩提分渐生。令佛藏增长。福德藏亦然。得智藏清净。又开发惠藏。如愿藏出生。此慈悲法性。解脱众生故。世间天人中。净意难可得。希有智果树。植妙深固本。众行渐增荣。普覆于三有。欲长诸功德。请问一切法。断除一切疑。求诸善知识。欲坏烦恼魔。净除尘染见。解脱诸众生。求斯大智者。欲净除恶趣。显示人天路。开解脱智门安住功德道。欲脱诸趣苦。当断诸有索。施诸趣安隐。近此真佛子

论曰。以意观察远离如是难者。不以为难。如深心教诫经说离此难云。佛言。慈氏。于彼菩萨及所化人。当成就四法。后五百岁正法灭时。不为损坏及彼陵蔑。自然解脱。何等为四。一者观察已非。二者于彼菩萨及所化人不谈他短。三者不化知识家往非亲里。四者不出恶言。是名四种。如前所说。复有四种。何等为四。一者远离寡闻众生。二者眷属而不取着。三者常乐坐卧林野。四者自习奢摩他行。是所相应。是名四种。彼经又云。佛言。慈氏。此初行菩萨获惠力财。远离非分名闻利养。彼名利者。是为过失。见无益语。见世俗语。世俗睡眠。世俗事业。世俗戏论。应当远离。是为过失。以要言之。佛言。慈氏。若菩萨摩诃萨应当观察名闻利养发生贪染破坏正念。于得不得勿作高下。又应观察名闻利养。起愚痴暗作悭种类。发生谄诳资益己身。无惭无愧离四圣种。如诸佛说。名闻利养应善观察。起诸骄慢轻慢师尊。是魔罗分。一向放逸破坏善根。如金刚雹及霹雳火。又名利者。化知识家多种爱乐诣非亲里。而复起恼迷覆知觉。向所爱事倍生忧戚。又名利者。失四念处减劣白法坏四正断。由前后利养破坏神通。远离善人近恶知识。于他眷属常爱合集。又复远离无量禅定。堕大地狱琰魔罗界畜生胎藏。应观察名闻利养如天授水。佛言。慈氏。彼名闻利养有如是等行相。菩萨应当如实观察。以观察故。无有厌怖亦无悔恼。所以者何。于是行相无厌怖者。得无过失。唯乐佛法得无间断。在家出家随所守护。若天若人。住清净心得无惊怖。设堕一切恶道不为逼恼。远离咒诅解脱魔境得无倾动。诸耽湎者之所敬仰。住定学者之所乐见。断除谄诳而获正直。是五欲乐是为过失。安住圣种如说修行。诸梵行者之所喜见。慈氏。如是行相功德。智者了知。菩萨深心住于少欲。乐少欲者。即断一切名闻利养

论曰。无益语今当说。远离贪毒愚痴过失。不住无益语者。一心得决定解如寻戏调。诸无益语爱乐修作。是为过失。不修威仪及微细行。若无益语言爱乐不坚牢世。是说随顺愚夫。若闻比丘不如理言。生爱乐已而常寻求。即便增长如是过失。是故弃舍不如理言。常知法乐。临命终时自舍千身求菩提道。闻法无厌。设若疲极。由闻法故。一切时处悉皆远离不如理言不爱乐言。于最上法乐生难得想。经无量劫住山林中。应知于他功德利益勿求其短。若谓我为最上殊胜。勿取是心。是慢为诸放逸之本。此下劣比丘亦勿陵蔑。渐如是教非止一生得证菩提故

论曰。世俗语。我今当说。彼闻惛醉乐起斗诤获不尊重。由所说言失念及不正知。是为过失。由所说言多竞高名极远内思。若身若心不得轻安。是为过失。由所说言愚夫自心生涩粗矿思入正法。远离毗钵舍那及奢摩他。是为过失。由所说言于功德财常起爱乐。获不尊重住不坚牢。狭劣智惠。是为过失。由所说言减失所知诸天不敬不生爱乐。是为过失。由所说言于彼智者及眷属等所余身命现无义利。是为过失。由所说言彼诸愚夫忧命终时。我何所作得如是苦。减失所知不得悟解。是为过失。由所说言如草动植疑无楷决不生实智。是为过失。由所说言如伎艺者住戏场中别说功勤自以为得。减失所知。是为过失。由所说言远七圣财互生谄诳轻失彼得。是为过失。由彼说言覃思研几喜务怯弱而不自知动本无体。是为过失。乃至不如实说我乐最上。此一句义于久远时思惟。尚未了知。云我乐得无量句义。譬如甘蔗坚硬皮中少有其味。人食皮已无复能得甘蔗甜味。是故广说者如甘蔗皮。唯乐神变思择义理者。如甘蔗味常无惛醉

论曰。言耽着睡眠者。如彼偈云。谓若乐惛睡。造此多种见。彼得见得疑。增长大痴网。若乐惛睡者。智惠皆怯弱。而于悟解中。常时俱减失。若乐惛睡者。怠堕无智惠。设住深林中。非人得其便。若乐惛睡者。即乐非法欲。善心常不增。何由获法乐。若乐惛睡者。愚蔽善法欲。坏白法功德。遍入诸黑暗。若乐惛睡者。封着无辩才。常生放逸心。缠绵身懈倦。若乐惛睡者。我知懈怠故。嫉彼勤力人。毁具足精进。乃至若除诸苦暗。即离于罪本。常亲近胜勤。诸佛之所叹

论曰。世俗事业今当说。如彼偈云。师诲谓恶言。执为非教诫。速毁犯尸罗。乐斯过失事。每思俗事业。常时务匆遽。不修诸禅定。乐斯过失事。由贪生广大。萦缠味中味。下劣非止足。乐斯过失事。处众大喜悦。谓除诸苦恼。如驴行隘道。乐斯过失事。乃至。是心昼夜中。不乐诸功德。唯衣食猛利。乐斯过失事。不乐相应语。唯顺不相应。问世俗所作。乐斯过失事。以要言之。尔时慈氏菩萨摩诃萨白佛言。世尊。菩萨少惠者。由舍最上法已。减失胜惠作下劣事。佛言。慈氏。如是如是。如汝所说。菩萨得少惠者。由舍最上法已。作下劣事。佛言。慈氏。又彼菩萨于如来教既出家已。无有禅定正断正勤。无有多闻不怀希望。佛言。慈氏。此复观察禅定正断知如来教知有为相三摩呬多是所相应。勿白衣事业营务。观察是事不应道理。应知彼菩萨发起爱乐轮回生死者。所谓营务世俗造作远离法财。佛言。慈氏彼营事菩萨假使修七宝塔满三千大千世界。我亦于彼不生恭敬尊重赞叹。乃至满阎浮提一切皆是营事菩萨。不如于一读诵如说修行菩萨起承事行。又若一阎浮提量读诵如说修行菩萨。不如于一各居所安行菩萨作承事行。所以者何。此为难事。所谓惠业。于诸三世为胜为上。最极高胜无有过者。佛言。慈氏。是故菩萨欲勤精进相应义者。当修胜惠

论曰。世俗戏论。我今当说。此戏论行。常为过失。获如是难。谓不得远离彼八种难。亦复不得刹那具足殊胜乃至智者正解离诸戏论。此戏论行速获是难。是故皆不共住。宁使畜受妻孥罪恶过百由旬。于他戏论或须臾顷不应亲近。亦不共住于出家功德之利欲。求财贿者。是则恶心起诸斗诤。勿有田作勿营商贾。若求财利是则戏论。勿有男女妻妾朋属。仆从富饶起诸斗诤。既出家已授袈裟衣。信顺寂静至极寂静。复观是寂胜寂近寂。离戏论故起如是忍。不得远离戏论行者。譬若毒蛇覆藏恶心。后堕地狱畜生焰摩罗界。是故精进起如是忍。乃至得是乘者。于诸业障净尽无余破冤魔力。诸有智者起如是忍

论曰。略说离如是难。佛言。慈氏。是故此菩萨乘。若善男子善女人。后五百岁正法灭时。使无留难而获吉祥。脱诸业障尽除罪欲。当知勿乐合集住阿兰若。旷野林中而修行之。于余众生而或远离。但省己非无求他咎。默然信乐般若波罗蜜多行。故又宝云经亦作是说。行乞食时乃至获得是事除余恶处。谓恶狗家新乳犊家体性犯戒。于彼畜生尚离损害。何况男子女人童男童女起厌贱处。彼一切时处皆应远离

论曰。若见如是种诸恶作者。慎勿往观。得离彼罪。复次说离如是等难。云何得果。离无果利成利他义。应知远离无果利故。如月灯经说。身戒义云。谓密护手足使无虚动。又十法经云。手足动乱往来跳踯。此说身业粗重

论曰。如菩萨为利于他。如其照了而不分别余业故。法集经云。世尊。诸菩萨等所有身口意业。皆为利诸众生起大悲增上安慰众生。令诸众生身意快然。如是深心如是思惟。随修何行而行平等。令诸众生得安隐乐。以要言之。谓菩萨了知观十二处如空聚落。于是等处无不乐舍

大乘集菩萨学论卷第七大乘集菩萨学论卷第八

        西天译经三藏银青光禄大夫试光禄卿普明慈觉传梵大师赐紫沙门臣法护等奉　诏译

    集离难戒学品第五之余

又虚空藏经云譬如孔隙声入其中。菩萨亦尔。若心有间隙则魔得其便。是故菩萨令心常无间隙。若心无间隙。则诸相圆满。及空性圆满。

论曰。况复诸相圆满者。即菩提行。亦不舍修习观诸空性。广如宝髻经说。又如无尽意经云。谓欲发起断除恶不善法者。说彼复有余散乱心。三摩地蕴是对治行。说此是名三摩地分。乃至是名恶不善法

    护身品第六

论曰。此言远离虚无果利者。说何所成就耶。此常成就正念。则得远离虚无果利。所谓不违如来教敕。守护果报尊重正念。于一切身不动自性。安住正念利益众生。随应所行坚固正念。见诸智者乐他所作。不动正念不怖时分。亲属礼制于身解脱正念。于四威仪道分检察正念。于威仪道安庠平正。守护不乱具力正念。发语笑时慎护高举。手足容貌其量端雅。敦肃正念。若应闻说者乃至知彼声品。无高无下一语正念。学者共行勿于余处。令他惊怖而生过失。自心悚敬令他净信。守护正念心如醉象。以奢摩他常縻制之。是为正念。住于观察当照其心。是为正念。于众富饶舍离余事。如所说念一心守护。是为正念。成就如是念者。说为远离虚无果利。又于此念得极尊重。彼尊重事一切观察现前轻毁是所对治如是尊崇。知已则于此广大平等。何名平等。故无尽意经说。奢摩他者。云何奢摩他无尽。若心不乱谓寂近寂密。护诸根性不高举。不动不摇深善谨密。无生无作唯一境性。独处闲静舍离愦闹。身远乐事心无动乱。意乐空寂亦无恶求。乃至护威仪道。知时知量及知止足。易养易满等

论曰。云何于尊重平等而不能生如实智邪。谓过去牟尼所说。若于三摩呬多。则如实知。如法集经云。于等引心得如实见。如实见者。菩萨于诸众生大悲心转。我得如是三摩地门。于一切法皆如实见。当为成办一切众生。以大悲熏修增上戒定慧学圆满。成证阿耨多罗三藐三菩提。是故我于净戒善住不动。得无懈倦

论曰。此奢摩他于自他尊贵平等。超越无量罪苦。得彼世出世间无量富乐。我当趣求发勤修习。诣火宅中希求清冷之水。得极尊重。诸学弟子。当住如是正念行相。近正念者。则得远离无果利事。若远离无果利者。则彼难不生。是故欲护身者。当推求念本常。近正念故。最上授所问经说。在家菩萨云彼于米果甘蔗等酒及放逸处不乐著者。则无惛醉亦无沉湎。不嚣不动亦无忘失。狂乱高举及恶骂等。由近住正念正知故。彼经复说。出家菩萨正念正知而不散乱。又宝髻经云。若正念者一切烦恼而不发生。若正念者一切魔事皆不得便。若正念者邪道恶道皆不能堕。若正念者如守御关钥。一切不善心心所法悉不能入。此说是为正念正知者。般若波罗蜜多经说。行则知行。住则知住。座则知座卧则知卧。如其身处。是名正知。乃至得不违越彼正知行。谓可观不可观。着衣持钵。若饮若食若眠若觉。及与懈倦取舍屈伸。去来坐立。或语默等。各居所安修正知行

论曰。戒定相成。如月灯三昧经云。谓此戒功能清净无垢。速得等持。由定趣入则相应戒亦复趣入。是故由戒正念正知。得三摩地。由三摩地一心故。得净尸罗。彼经说言。禅定功能中得住无行。亦非无行。行相应故。远离境界。无境界故。不起染习。如是成办密护根门

论曰。此由心所成办修习。戒定二种绮互增长。此说菩萨学者利诸众生。谓心成办而为根本。故宝云经说。知一切法皆依于心。心为先导故遍缘诸法。又世间诸决定心。以心所缘而不见。彼则使业清净。若清净已。则心无流转。心无流转即心如烧焰。或如湍流。如是心相遍能观察。得住正念。心不遍缘则心得自在。心自在故。于一切法而得自在。又法集经云。谓若有法。法无处所。亦无方分。即已自心。是所尊法。说名为法。是故我于自心谦敬。建立极妙殊胜。当知发起此善摄受。所以者何。谓若于心有是功德过咎。无是功德过咎。彼菩萨者此二种心。唯求成办功德而不造过咎说如是心是所尊法。所尊法者即菩提故。世尊。我于是法开演成就如是安隐正觉。又华严经云。谓于自心建立一切菩萨行故。自心建立度脱一切众生故。乃至。善男子。我于自心当如是住。应知自心具足一切善根故。应于自心净治法云地故。应于自心坚固无障碍法故。又如善财勤修精进欲见摩耶夫人睹主城神。名曰宝眼。饶益教诫。作如是言。善男子。应守护心城。谓乐排遣一切生死轮回境界。应庄严心城。谓专趣求如来十力。应净治心城。谓毕竟断除悭嫉谄诳。应增长心城。谓增长大精进行求一切智。应防护心城。谓摧碎魔轮御捍一切烦恼魔众及恶知识。应广大心城。谓以大慈普及一切世间。应覆荫心城。谓以广大法盖对治诸不善法。应密护心城。谓遮诸世间内外所有无令侵入。应严肃心城。谓欲排遣诸不善法。乃至。善男子。以菩萨得如是净修心城。则能积集一切善根。所以者何。由菩萨净修心城故。则无诸障碍。谓现前不住。或见佛缘听法缘等

论曰。是故住此菩萨学者。于心所行得不动思等心。不动外境不起妄念不正知者。谓于三摩呬多其心动乱。或于他境而有攀缘。若得正念正知则外境不转。彼自在故。无一攀缘。乃至求彼安住如先所说。功用广大。令利益解脱众生故。得修如是净信。云何得一切处。希望润泽不遽不缓。教斯福行不舍众生。所谓不舍众生者。是菩萨修作。如法集经云。喜见菩萨白佛言。世尊。菩萨以如是行。众生见者俱生喜乐。何以故。世尊。菩萨余无所作。唯一化度众生。世尊。是名菩萨法集

论曰。如是复造何过失耶。谓轻毁诸佛及轻世间。堕地狱中如煻煨覆苗。炽然烧煮慎勿轻毁。如前数说。造此报者。如宝云经说。轻毁禁戒不生净信。一心舍离诸众生等。又如彼言。云何是菩萨学处。乃至为诸菩萨不行非处。无非时语知时知方。若不如是即令诸众生不起净信。何况护诸众生及为己身威仪道行求菩提利益具足圆满喜乐调柔于此现前合集无多执着。又法集经云。若护禁戒则护诸众生应怖彼方。谓于女人里舍勿共住屏处。护世间者勿容故作。又若受用水陆地等大小便利洟唾不净屏处密弃诸利益心。护天人者勿容故作。且正法念处经云。菩萨尚不以残食施人。若故作弃残行者。堕饿鬼趣。又菩萨别解脱经说。所向清净不应现前掷小齿木。亦勿现前遗彼洟唾。如是于尊重者惭耻仪式。一切处见皆非梵行。毕竟经说。修梵行者。见是义已怖彼重罪。又如彼说不应高语。亦非仪轨。如梵天所问经云。应知菩萨者譬若新妇。又菩萨别解脱经云。远离世间人不喜作。谓乃至不满口食啖嚼有声。不伸脚坐不露肘臂

论曰。如是自当远离。人见闻已不喜守护。又如是弃舍不喜作语。亦不为难。念随所解于义可见。故海意经云。无衰弱语。无粗犷语。无炽然语。无不实语。无贪顺卑下语。无下劣语。无覆藏语。无嗔害语。无动乱语。无戏[口*劇]语。无对面斗诤语。又如来秘密经云。复次善男子。菩萨无爱着语。猛恶语。痴乱语。染污语。缺漏记别语。自分高强语。他分离散语。自赞功能语。破他功能语。不救拔语。增上慢记别语。十地经亦作是说。谓若发言。喜自眷属破他眷属。断如是语。谓应发言润泽柔软意喜适悦。美妙可爱悦耳快然。心行乐欲分明不谬。所闻通达无不依止。多人爱乐多人欢喜。平等称赞利益安乐一切众生。自他眷属意喜踊跃。灭贪嗔痴一切烦恼。如是行相若发语言。乃至对向。先发喜笑。除损害故。又虚空藏经云。为尊长言。极研虑故。为他人言。离覆藏故。当乐摄受如是等语。法集经云。佛告虚空藏菩萨言。菩萨不作此语令他起嗔。不作此语令他起恼。不作此语令他无智。不作此语令他无益。不作此语令发无明。不作此语令他众生心不欢喜悦耳快然。菩萨不作如是等语。又海意经云。略说于他不生喜护云。复有一法摄受大乘。谓自错谬而常观察。于诸众生随所守护

论曰。此护身者不恼于他。如是他人亦无恼害我。于此论广大积习菩萨利益。应知常持是意。谓安静不动尊重爱乐。惭耻怖惧于他寂静。一心亲近及于众生而常自在。净信等事。若变若化持如是意。彼护身者云何无有汤药衣服药共二种。谓常受用药及病缘药。常受用药者。如宝云经说。是故行乞食者。应作四分。一者分与同梵行人。二者施诸贫苦。三者饿鬼畜生。四者自食。然于饮食勿起耽嗜。亦不多求。乃至资养于身安住色力。如其饮食得无懈倦。不令身重。所以者何。彼懈倦者。于此善分乐后时得。或令身重而多睡眠。应知此等行乞食者。现前获得如是善分故。宝积经云。若比丘入于城邑聚落乞食。应以法庄严而行乞食。所以者何。谓若见可爱不可爱色。见已不应起违顺意。如是可爱不可爱声香味触法。见已皆勿起违顺意。摄护诸根使无散乱。谛视一寻先所思法不舍作意。不以食覆于心而行乞食。若得食处不生乐着。若不得处不起嗔害。若至十家。若过十家。不得食者。勿生忧恼。当发是心。此诸长者及婆罗门。多作事缘不施我食。乃至未曾摄受于彼。况施我食。如是行乞食者不生忧恼。又乞食时。见诸众生若男若女童男童女乃至畜生起慈悲心。若诸众生见我所作。及施我食皆生天趣。如其所得精粗饮食。受是食已遍观四方。此城邑聚落贫穷之者。我以此食而分施之。若见贫者。于所乞食而为分与。若不见有是贫穷者。亦发是心。以我真实彻眼境际所观众生。我所乞食于中上味愿当施与。持此食已诣阿兰若处。行杜多者净洗手足。于沙门行具诸仪式。威力加持结跏趺座。而饮食之。乃至欲食如是作意。此身中虫有八万户。共得此食皆得安隐。我今以食摄受诸虫。我得菩提复以法化。若复不足发如是心。若食少者。令我身轻。息除便利。断诸过恶身心轻安。又少惛睡。乃至于所乞食。若复多者。于食分量应行舍法。于所乞食发如是心。飞鸟鹿属希求饮食。我当施彼。又乞食比丘于诸味中不应生好味想。乃至如旃陀罗童子。应净身心不应净食。何以故。食美食已。一切皆为臭恶不净。是故我今不应求美食也。乃至不起是心。谓此男子施食。非女人施。此女人施食。非男子施。童男童女亦复如是。又云。此是美食非粗粝食。若入聚落应得恭敬。非不恭敬应得富家。若男若女童男童女种种美味非贫贱家所得饮食。如是勿起一切不善作意。乃至若有众生着食味者。造恶业已堕于地狱。复次有知足者不着美味。舍细受粗舌根喜足。若节约食者彼命终时。得生天上人间或余善道。若天若人食天美食。迦叶波。如是行乞食比丘。离于味爱调伏其心。设唯啖熟豆亦不忧恼。何以故。为求圣道趣活身命。是以故食。以要言之。佛言。迦叶波。若行乞食比丘。值天大雨云雾等时不能乞食。乃至思法庄严以慈为食。住是作意若二夜三夜欲断食者。应作是想。彼琰摩罗界堕饿鬼中。以恶作故于百岁中欲食。少唾尚不可得。我今安住甚深法中不应发起身心羸劣。况复勤修圣道。我今堪忍如是饥渴。又总略云。令在家人为作净食。敷座而座为说法要。乃至彼作净食。受此食已。从座而去。迦叶波。行乞食比丘不应自炫谄谀。云何谄谀。若为他说此粗恶食而复不足。乃至持此多众共食。若食少者令彼饥渴。若有如是行相。是名谄谀。诸行乞食比丘。应当弃舍。云何真实。谓食堕钵中。若粗若细及净不净。皆悉应食。不生忧恼。唯净内心以法调伏。住圣道故得活身命。乃行乞食。如最上授所问经云。若人亲近饭乞食者。能于自他利益圆满随所了知。彼乞食菩萨言。如是乃至不为护身当如服药。入楞伽经说断食鱼肉义云。如说菩萨修大慈故。一切肉皆不得食。乃至略彼偈云。观肉所从来。脓血诸不净。修行净行者。当远离食肉。一切肉及葱。亦不饮诸酒。韭蒜等亦然。修行常远离。于床吉祥卧。及离覆油等。孔隙诸众生。于中大惊怖。乃至为利杀众生。或营财贩肉。是二种罪业。死堕大号叫。又总略云。臭恶实可厌。常生倒悬中。及生旃陀罗。或猎师屠脍。生罗刹女中。食肉诸种类。猫狸夜叉等。是人生于彼

论曰。若具知如断肉品说。成彼广大利益故。说无过失。若比丘于阎浮提临欲灭时。作此三摩地语。常令众生断除于彼。亦得是三摩地。修大慈悲者。无有过失故。宝云经说。应知不肉食住冢圹间发生如是利益众生。若见余毗奈耶中所说。食三种净肉。毕竟皆断一心舍离。得净诸见断除我慢。乐修福者渐令教入远离食肉。又如入楞伽经云。为彼学者读诵解说。渐次系属依止巧妙章句。彼修行者系属三种。我为彼说令作断除。即是断彼性近杀故。说名常受用药病缘药者。如声闻毗奈耶说。乃至我为利益梵行。货鬻衣钵治疗于身。况复普救一切众生。由是菩萨见难得身。于刹那顷获此胜福。世尊。见此利益以自医药。于修行者是为胜见故。宝云经说。若得断三种食。彼时真实或不真实。如是行相为住身命。勿取勿食。所谓酥油根茎果汁。设见起对治心而不可食。若复菩萨得重病时。然后可食。如其疾病命根欲尽。勿恶作故断彼善分。无起疑惑断除是心。当如服药最上授所问经说。着受用衣。云沙门者。惭愧义故。以衣覆身勿现肢体。世间天人阿修罗等。作佛塔想。应知如持佛塔。若不对治修离贪染使余清净。则增长烦恼。坏袈裟衣得此过咎。为不随乐修行庄严法服。于善作中而返恶作。此袈裟衣。为求圣道知对治故。如一刹那顷。亦复于身受持。如宝积经说。此因者。佛言。迦叶波。若复严饰于身而不密护。坏沙门功德。法者是袈裟衣。虽持于身而心不生尊重。复次迦叶波。如是色相。名相似沙门。以是缘故。当堕地狱。迦叶波。以沙门色相相似故。于地狱中衣热铁衣。以覆头上应器敷具热铁所成。所有一切受用资具。悉皆猛焰炽然燋烂。彼说色相相似沙门得受是苦。又宝云经说。若菩萨以身有疾。肌体怯弱不处僧坊。当显露处发如是心。谓佛如来杜多功德。以拣择故对治烦恼。我亦修作。如处僧坊断诸烦恼。然于僧坊不起乐着。亦不请求。设得如是施者。随所摄受。应知亦勿为我满足。彼经又云。彼卧具仪式应叠双足右胁而卧。法服覆身正念正知。起光明想。不着睡眠为乐。亦复不着彼胁此胁及余肢分为乐。乃至于四大种安住调息。彼地方所一切受用。皆为利益众生之所建立。若我爱乐受用。则生疲厌过咎。如月灯三昧经云。得彼细妙滋味饮食。是食非解脱相应。谓得彼食是则系缚。如象子卧非杜多行。又宝积经云。复次世尊。说是受用信施。尔时众中离扼比丘。于此法律闻已悲泣。作如是言。世尊。我今宁取命终。不复得果。亦不受用一信施食。佛言。善哉善哉。善男子。斯言清净如是行相。耻具恶作怖他世罪。佛言。迦叶波。我知信施此有二种说名解脱。何等为二。若离扼比丘及余比丘。学我所行见诸行无常。领纳诸受是苦。信解诸法无我求涅盘寂静者。设食信施量等须弥。及余所施。毕竟清净。若受施主物及信施食。具大光明得大福报。所以者何。以诸增上悭贪令作福事。是为慈心三摩钵底。复次迦叶波。若比丘受施主所施衣服饮食已。思入无量三摩地者。令彼施主于作福事所求果报。亦复无量。迦叶波。假使三千大千世界大海水竭。是所修福亦无有尽

大乘集菩萨学论卷第八大乘集菩萨学论卷第九

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    护身品第六之二

如是行乞食者。于所施食起三种念住。谓愍身中所集诸虫。成就利益一切众生。摄受正法。又如来教敕诸所作事悉具正念。最初以真言声为作守护。应先于此底哩三昧耶王所说明咒曼拏罗利益。今当说

那谟萨哩嚩(二合)没驮冒(引)提萨埵(引)喃(引)盎(引)尾啰惹尾啰惹摩诃(引)嚩[口*爾]哩(二合)萨多娑(引)啰底娑(引)罗底怛啰(二合)以怛啰(二合)以尾驮末底三畔(蒲合切)惹儞多啰末底悉驮(引)屹哩(二合)怛囕(二合)萨嚩(二合引)贺

诵此得入一切曼拏罗。或此如来心念八千遍。云何一切。谓世出世间最上曼拏罗。悉能得入。又真言曰

那莫悉底哩(三合)野提尾(二合)歌(引)喃(引)怛佗(引)誐多(引)喃(引)萨哩嚩(二合)怛啰(二合引)钵啰(二合)底喝多(引)嚩(引)钵底(二合)达哩摩(二合)多(引)末陵那(引)阿三摩三摩三满多都(引)难(上)怛多(引)嚩(引)钵底(二合)舍(引)萨儞喝啰喝啰三摩(二合)啰三摩(二合)啰拏尾枿多啰(引)誐没驮达哩摩(二合)底萨啰萨啰萨摩末罗(引)喝娑喝娑怛啰(二合)野怛啰(二合)野誐誐那摩贺(引)嚩啰洛叉抳入嚩(切身)罗入嚩(切身)罗那娑(引)枿哩萨嚩(二合引)贺(引)

应知此一切如来身最为尊重。无有过上此初行之者。于佛众生无量修作时。诸魔等起诸弊恶。应以如是最上守护。谓或以击掌若灰若白芥子若净水等。随意见已而作结界。又若诸疾病者。真言加持药水令服。或林野中。以酤苏摩华于佛塔庙形像正法经典供养安布。观缘佛菩萨等。心乐利益一切众生。是大疾病必为药叉等所持。说为解脱。又应先念修普贤行法式次第。于此仪轨乃见边极。谓此底哩三昧耶者。设不澡沐盥漱及不清净。或食鱼肉皆无过失。然作是印契者。皆不得食。不违本愿故。亦不于他同床敷具。亦不跳踯。于此信解行学无所倾动。亦勿疑惑。若先破戒此亦成就。有智无智决定皆成。复如彼说。若菩提心坚固得专注意。应离此疑惑毕竟成就

论曰。菩提心坚固者。定说利益诸异生等。令心无退随未入地者。作如是说。欲得持初日光入大暗处。为作照明。若复希求成就。如何名鲜福者。乐此成就。遣除怠堕心故。然入圣地积集无量福聚。超诸恶道不为广大沉溺。先说得是过失者。或无真言而念诵。不知增减文字。此无过咎。设若增减。差忘次第。皆无有失。何况信菩提心弃舍自利。所作筹量伺察而转。决定得睹诸佛及菩萨等。获斯成就。或以此执金刚真言。作守护者。真言曰

那莫悉底哩(三合)野体尾(二合)歌(引)喃(引)怛陀(引)誐多(引)喃(引)萨哩嚩(二合)嚩惹啰(二合)达啰(引)赧(引)赞拏赞拏末罗末罗嚩捺啰(二合)嚩捺啰(二合)扇(引)多那扇(引)多那颇罗颇罗嚩啰嚩啰摩(引)啰拏摩(引)啰拏嚩惹啰(二合)捺罗写萨普(二合引)吒(半音)罗隶多尸珂啰三满多嚩惹哩(二合)抳入嚩(切身)罗入嚩(切身)罗那谟窣堵(二合)阿兀噜(二合引)誐啰(二合)舍(引)萨那(引)喃(引)啰拏啰拏虎罗虎罗颇罗萨癹(二合引)吒(半音)嚩祖噜(二合引)睹弥萨嚩(二合引)诃(引)

诵此于刹那顷诸作障者。频那夜迦悉皆驰散。诸天龙等皆以饮食衣服卧具承事供养。乃至加持净水。或随意所见而作守护。又一切所作诵此不动尊明王心真言曰

那莫三满多(引)嚩惹啰(二合引)赧(引)怛啰(二合引)吒阿谟(引)佉赞拏摩诃(引)噜瑟(引)拏萨普(二合引)吒(引)野吽(引)怛啰(二合)吒(半音)贺(引)[牟*含](切身引)唵(引)末朗捺祢谛儒(二祖切引)摩(引)隶儞萨嚩(二合引)贺

若初食时。诵此真言至一七遍。次当饮食。彼诸药王佛菩萨众。随所念中消诸毒类。真言曰

怛[寧*也](切身)佗(引)伊隶蜜谛底隶蜜谛伊隶底隶蜜谛努弭努嚩(引)梨(引)曳怛哩计(二合)怛哩葛(二合)啰抳摩摩哩弭(二合)摩哩摩(二合)啰抳葛悉弥(二合引)哩葛悉弥(二合引)啰目讫底(二合)阿佉儞阿佉那佉儞伊隶伊梨曳阿珂(引)以(引)曳阿播(引)伊曳尾底悉尾(二合)多敦抳阿那(引)努啰叱萨嚩(二合)贺

复次若闻此明者。于七年中不为蛇螫毒不着身。设为所螫蛇。则头破七分如兰香梢。若持此明者。乃至尽其形寿。不为蛇螫毒不着身。此真言句蛇前勿念。所以者何。蛇趣命终故。真言曰

怛[寧*也](切身)佗(引)伊罗(引)唧罗(引)佐酤(引)嚩酤(引)酤(引)痆(引)酤(引)妮底儞酤噜拏(引)儞酤噜妮底布(引)拏(引)布(引)妮底补噜拏(引)补噜妮底普吒啰呬普吒绽(陟涧切)拏啰呬那(引)枿啰呬那(引)枿吒绽拏辣呬萨哩波(二合)辣呬萨哩波(二合)吒绽拏辣呬遏砌攃隶尾始试(引)底试(引)多嚩多隶喝罗哩喝罗哩亶妮亶妮怛痆(尼辖切)怛痆多(引)抳多(引)抳末罗末罗萨普(二合)吒(半音)萨普(二合)吒(半音)癹吒(半音)癹吒(半音)萨嚩(二合引)诃(引)伊底呬幂叉芜昝(仁奘切引)吾廉(引)尾[寧*也](切身引)焰罗毕多(引)乌捺(引)喝哩(二合)多(引)焰(引)萨哩嚩(二合)普多三摩(引)枿弭萨哩鑁(二合)怛佗(引)阿那担佗(引)普耽萨爹阿尾钵梨(引)耽阿尾钵哩也(二合)萨耽(二合)伊捺尾沙摩尾钐婆嚩睹捺多(引)囕枿璨睹能瑟吒啰(三合引)囕枿粲睹阿仡儞(二合)枿粲睹惹蓝枿粲睹萨耽(二合)蓬枿粲睹酤吒也(二合)枿粲睹普铭枿粲睹扇(引)鼎枿粲睹萨嚩(二合引)诃(引)

复次。若为贼侵害。当诵摩利支。真言曰

怛[寧*也](切身)佗(引)阿哩歌(二合)摩枲摩哩歌(二合)摩枲嚩那摩枲頞多哩驮(二合引)那摩枲钵体弭罗叉乌怛波(二合)体弭啰叉惹那都(引)弭啰叉啰(引)惹都(引)弭荦又租(引)啰都(引)弭荦叉星贺都(引)弭荦叉咩(引)渴啰(二合)都(引)弭荦叉那(引)枿都(引)弭荦叉萨哩波(二合)都(引)弭荦叉萨哩嚩(二合)都(引)弭荦叉荦叉[牟*含](切身引)萨哩嚩(二合)婆曳毗药(切身)萨哩舞(二合引)波捺啰(二合)侮(引)波萨哩吾(二合)播(引)野(引)细毗药(切身)萨嚩(二合引)诃(引)唵(引)嚩底隶嚩底隶萨哩嚩(二合)讷瑟吒(二合引)喃(引)屹囕(二合)汀满驮(引)弭萨嚩(二合引)诃(引)那谟(引)啰怛那(二合)夜(引)野那谟(引)摩(引)哩(引)载祢嚩多(引)潩摩(引)哩(引)嗟(引)祢嚩多(引)野(引)纥哩(二合)捺琰摩(引)嚩哩多(二合)曳奢(引)弭怛[寧*也](切身)佗(引)嚩多隶嚩捺(引)隶嚩啰(引)隶嚩啰(引)诃目契萨哩嚩(二合)讷瑟吒(二合引)喃(引)满驮目龛萨嚩(二合引)诃(引)

由念此明出生无量大德威光。复次五十七字属持明藏。于诸怖畏守护饶益。真言曰

怛[寧*也](切身)佗(引)遏胝末胝那胝酤那胝吒枳姹啰枳姹啰枳乌噜末底噜噜末底睹噜呬隶弭隶萨哩嚩(二合)倪也(切身)努波捺誐那谟(引)萨哩嚩(二合)三摩三没驮(引)赧悉殿都弥满怛啰(二合)钵捺(引)萨嚩(二合引)诃(引)

论曰。此护身者。以汤药衣服等为众生利益。先如是作。谓已所乐着受用之具。起染污罪。由是菩萨于诸众生一切当舍。又若不希他物。已所资具时不乐着则唯饮食起染污罪。虽不念饮食。于众生事。或不爱乐。谓于饮食作他物想。无染污罪。然唯自利是罪满足。于别解脱得波罗夷罪。又说此所受用彼一众生为主。此一众生为主。如是护身皆为过失。非如奴仆常于一主营务役使。自所有物即彼所有。然法集经云。菩萨譬若僮仆应代。一切众生随何所作

论曰。非说于一主者。彼为利他。设若僮仆为病恼等。主乃未言而或先饭。得无咎耶。菩萨如是修作所有亲近不知是事。若心能了知此清净理行广大舍。然于是理勿应疑惑一切当舍故。如前佛说唯备喉急。此护身者。为利众生。当如是说觉了斯义。如理开示使无忘失

    护受用福品第七

论曰。如是护身应知已释。护受用者次当今说。复次起善修作。是中以智观察。此诸学处护受用事。斯不为难。最上授所问经说。此学处者。于平等见善所修作。善修作者。极远谛观弃诸受用

论曰。此奢摩他容于后时。然于是理了如所说得此成就。所谓节去受用。而于是事真实成就。自然于余广多受用。损而能舍余无他事。又如最上授所问经云。妻子奴仆作业使人。是正所受用。若自若他。闻菩提分断斯所作。能舍不舍余无他事。于利益众生极能称量。及菩萨所极善称量。断斯所作。能舍不舍余无他事。此获成就。于此疑者。菩萨别解脱。亦作是说

复次舍利子。若出家菩萨求菩提分。应知说施。云何名施。谓若色施乃至法施。为法施者。舍利子。若在家菩萨以殑伽沙数佛刹七宝满中持用布施如来应供正等正觉。舍利子。若出家菩萨以一四句偈。如说修行乃至为他人说。其福胜彼。又舍利子。岂诸如来于出家者。说无财施。以要言之。舍利子。若有所得堕满钵中及所余物。应分彼食与同梵行。彼复来求若衣若钵。如佛所说有长三衣。随所应舍。又若阙少是三衣者及为依止住净梵行。此不应舍。所以者何。毕竟如来不说施此三衣故。舍利子。菩萨以彼三衣施乞者时。然于师尊无阙亲近。又舍利子。出家菩萨唯应为法而亲近故。彼所求者。当知摄受。唯一众生未及利益多众生聚。是故菩萨于众生所深心修作。若减失大利断灭善事。如是说为刹那远离广大善分。如是乃至弃舍或不弃舍。又如海意经云。大乘者断多财利乃至我决定说。菩萨如是成办。由何趣入。广如最上授所问经说

论曰。若说为他修作当舍己事。如维摩诘所说经云。问曰。维摩诘生死有畏当何所依。答曰。文殊师利。菩萨生死畏中当依如来功德之力。问曰。欲依如来功德之力者当依何住。答曰。欲依如来功德之力者当依一切众生而住。又问曰。欲依一切众生住者复何所住。答曰。应住解脱一切众生故。又如法集经云。商主菩萨白言。世尊。若菩萨乐欲菩提。最先一切众生。不为己事乃至世尊。是名法集

论曰。舍此即成自利。问何故减失利益众生。谓怀怖惧不为众生自任重负。由减失故不观利他。唯于世间修自利行。复何差别。谓若菩萨不弃己德而成他善。或怖恶道自受苦恼。此为二种。谓若是苦。我或当受。故不应舍。如经所说。获大罪报。如宝积经云。佛言。迦叶波。有四种法。说名相似菩萨。谓自利求安而不济度苦恼众生等。又最上授所问经彼说次第。若云先无我执。则是菩萨学处。亦如法集经云。具寿须菩提语无所发菩萨言。善男子。菩萨当云何住。答曰。若为众生不舍正行。问曰。云何为诸众生不离正行。答曰。谓不舍大慈大悲。须菩提言。云何菩萨大慈。答曰。若以身命及诸善本。当施一切众生而不求报。又问。云何菩萨大悲。答曰。若菩萨乐欲菩提。最先一切众生而不自取证。彼经复说。此一切菩萨学处。以大悲为本。世尊毕竟令彼不断利他。是菩萨义。故定非究竟。是中我当观大福海施大义利。匪定一向违害生灭。又决定寂静神变经说。彼昔有王。见一比丘于千岁中入灭尽定。以是缘故。有诸比丘读诵经典求菩萨行。尊重法欲受信施食。发如是心。我为求法以此善根为法舍施。百钱迦罗努贝底执着妙乐等事。如前次第。说无过失。或俱说为护受用福

论曰。复次广乐自利果报守护清净。如那罗延所问经云。守护戒者。非国王因。非天趣因。非烁迦罗因。非受用因。非富乐因。非形色因。非显色因。非美誉因。乃至守护戒者。无地狱恐怖。如是无畜生琰魔罗界恐怖。以要言之。守护戒者。唯除住佛眼者。乃至守护戒者。利乐一切众生。相应义故。彼戒蕴菩萨如是行相。得具足十种无减失法。何等为十。所谓得转轮圣王而无减失。求佛菩提亦无杂乱。得烁迦罗亦无减失。愿睹诸佛得无障难。如是为梵天王亦无减失。听闻妙法得无退堕。乃至如其所闻读诵经法。具菩萨行皆无减失。于诸善法不断辩才。求深禅定亦无减失。乃至如是住戒蕴菩萨摩诃萨。常为一切之所礼敬。谓天龙夜叉乾闼婆等供养恭敬歌咏赞叹。亦为诸龙王阿修罗王等而常尊重。刹利婆罗门长者居士等之所亲近。及诸智者而常赞仰。为佛嗟咨。若天若人。一切众生之所怜愍。乃至不行四种之行。唯除化度众生。何等为四。所谓不行无相之行。亦复不行空诸佛刹。又亦不行生邪见家及堕诸恶趣

论曰。如前所舍彼烦恼力及憍慢等。守护福报。亦复布施。然于是福自不希报。此欲守护唯为利他。后不生悔。如最上授所问经云。若布施已。是心设不生悔而逐彼后者。忧不忧等皆名追悔。减灭福报令罪增长。若不发露于佛覆藏。而翻彼善说为罪性。复次于彼罪恼行忏除者。由此无罪而获福喜

论曰。利益众生者。不以财利之心而为发露。如宝云经说。譬如药王而自赞己德。不为过失。复说欲守护福者。于名闻利养菩萨常当远离高举。以清净法舍愚痴暗

大乘集菩萨学论卷第九大乘集菩萨学论卷第十

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    护受用福品第七之二

宝积经云。佛言。迦叶波。若菩萨具此四法。则未生善法令灭。已生善法亦不增长。何等为四。谓于世间深着过慢。巧构言辞耽着利养。乐观种姓嫌赞菩萨。于未说未闻契经而辄生诽谤。又说一切有部云。如是发毛爪塔及诸身分。见已净信发恭敬心。是大德比丘比丘尼等。从此地面下过八万四千踰缮那至金轮际。是比丘所有若干沙数千倍转轮圣王受用福报。乃至具寿优波离向如来前合掌恭敬。而白佛言。世尊。若佛所说是比丘善根。如是广大。世尊。云何有是善根。言汝于此尚能散灭。佛言。优波离。谓忍此动乱而随彼见。如彼梵行而亲梵行。优波离。由斯善根亦复广大。然汝于此尚能散灭。优波离。是故当如是学。又若积薪所焚。心可无坏。况彼识身等。文殊神变经云。所对害者。谓百劫中积修其善。有所减失说为对害。华严经说。普捄众生妙德夜神因缘。如前已说

论曰。当于是时互相诽谤。增不善本减失寿量。色力安隐悉皆减少。无有少分示饶益者。唯说追求名闻利养作高举事。如宝云经说。佛言。善男子。菩萨得珍宝聚量若须弥。而取彼施。或得弊陋之物。亦取彼施。所以者何。彼如是思惟。由此众生悭贪嫉妒惜自他物而常斗诤。以是因缘处生死海之所沉溺。我欲于彼令长夜中利益安乐。故受彼施。然竟不作己有。亦复不起贪着之心。唯为供养诸佛法僧。亦复转施一切众生。如贫苦者得活身命。亦令施者极生欢喜。具如彼说。得施无憍慢。彼复又云。设有人来以施因缘歌颂称赞。是人不生高举。逮无憍慢。又若于我歌颂称赞。谓起即灭非久如间。设使再三于诸时处歌颂称赞。当生何智。谓诸法无常无住无强无力。令心卑下勿生高举。逮无憍慢。如是菩萨于名闻利养歌颂称赞等事。悉住正念。彼复又云。譬若旃陀罗子游行世间。卑下其意得离憍慢。随所住已生乞食想。复如彼说。善男子。一者菩萨若舍家出家。为诸亲眷朋属之所弃舍。犹若死尸。以是因缘摧伏我慢。二者已毁形好被坏色衣身貌异俗。以是因缘摧伏我慢。三者剃除须发手持应器。于亲非亲游行乞食。以是因缘摧伏我慢。四者如旃陀罗子卑下其心游行乞食。以是因缘摧伏我慢。五者由乞食故得遂生成为他系属。以是因缘摧伏我慢。六者虽为他毁。为乞食故亦受彼施。以是因缘摧伏我慢。七者尊重供献阿阇梨等。以是因缘摧伏我慢。八者行住威仪安详平正。令梵行者见已欢喜。以是因缘。摧伏我慢。九者于诸佛法所未得者愿此当得。以是因缘摧伏我慢。十者于嗔忿心有情之中多行忍辱。以是因缘摧伏我慢。又海意经云。若菩萨得身清净。具相庄严手足柔软。殊妙可爱成福生身。诸根不减身分圆满。然于形好亦无醉傲。不以严身而求触乐。若诸众生种种色相。菩萨尔时为求法故谦下恭敬。彼经又云。譬如大海处地卑下。所有一切江河及诸细流速疾趣入。世尊。菩萨敬重师尊心不高举亦复如是。一切甚深法门及微细善。于其耳根速疾趣入。世尊。是故菩萨安住正念。若高举我慢不重师尊。亦不恭敬礼拜。当知菩萨是为魔钩所制。又如出世间品云。佛言。佛子。菩萨有十种魔事。何等为十。一者于和尚阿阇梨父母沙门婆罗门住于正行向正道者不起尊重。是为魔事。二者谓诸法师说殊胜法说广大法。于大乘中知涅槃道。及余契经得总持王无有休息。然于法师不起尊重。及于所闻不作善巧。是为魔事。三者然于会中闻说大法。于法师所不乐赞美。况起净信。是为魔事。四者好起过慢自执己见陵蔑他人。罔知己短心无拣择。是为魔事。五者好起过慢自无知觉。于阿罗汉补特伽罗。隐蔽覆藏他实有德谓不如己。应赞不赞。是为魔事。六者了知是法是律真为佛语。为嫌其人颇嫌其法。谤正法已于别受持。是为魔事。七者自求高座。谓言我行道法不应亲近执事。于他久修梵行大德耆旧不起承迎。是为魔事。八者貌不温恭复多颦蹙。言极粗犷心伺过恶。是为魔事。九者由增上慢喜调戏故。不亲有德不生恭敬。亦不咨问何者是善何者不善。何者应作何者不作。又何所作于长夜中而得安乐利益。又何所作于长夜中而不能得安乐利益。痴冥顽很为慢所持不明出要。是为魔事。十者由慢所覆。设过佛出亦复远离。坏夙善根竟无新起。说不应说多起斗诤。谓此法行返为是处堕大邪恶。于菩提心根力圣财斯不可得。百千劫中常不值佛。况复闻法。是为十种魔事。佛言。佛子。菩萨舍此十种魔事得十种智业

论曰。此中智业者。说善住化度一切众生等。护国经云。彼人堕蔑戾车罪恶边地贫贱中生。聋盲闇钝而无威德。亲近愚蒙执着我慢。又如法集经说。谓诸菩萨欲取佛土者。即众生土是为佛土。由是得诸佛法。不坏正行。谓诸善行恶行无不依止众生而转。故恶行者依罪恶起。彼善行者依人天等。宝光明陀罗尼经云。佛言。佛子。此初发心菩萨先于一切众生发十种心。何等为十。所谓利益心。安乐心。怜愍心。润泽心。爱乐心。摄取心。守护心。平等心。教授心。称赞心。是十种发心为若此入解信力。财印经云。我已得住一切众生作弟子者。亦令他住一切众生作弟子故。俱获安隐。以要言之。我已先住恭敬礼拜。亦化一切众生当住恭敬礼拜。又如维摩诘所说经云。若乐说世间清净无难故。则随所化调伏一切有情。来生净佛国土

论曰。若踞座洗足思惟。应何所作爱乐尊重等事。故华严经云。尔时有王名法音盖。于大众中处师子座。有诸人众一时合掌住立其前。如是恭敬为王作礼。乃至尔时法音盖王见诸乞者。生大欢喜具大悲愍。假使三千界内俱为转轮圣王经无数劫。所得妙乐过于前说。乃至净居天王于无际劫行寂静解脱门。亦过前说。善男子。譬若有人唯行爱育父母兄弟姊妹朋属男女妻妾时久乖离。后于旷野欻然值遇。更相慰问。极生爱重瞻视无厌。善男子。此法音盖王亦复如是。见来乞者具大爱乐。心生喜乐发起最上大希有心。乃至于诸乞者生一子想。生父母想。生福田想。善知识想。坚固力想。极难得想。难行能行想。多作想。最上成办想。近住菩提道想。阿阇梨教诫想。如其来者知众生性之所承事。平等无碍一切舍。施设弃己身如其所欲。复次选地清净涂拭庄严。舍自利乐等

论曰。若乃主者净信。则侍从等亦当净信。教令具足饶益。应如是作意。向来比丘身有疾病。昔佛世尊尚为承事。如比丘杂诵律云。佛言。佛子。汝勿嫌弃是病比丘。我于比丘中尊尚为承事。持此病比丘衣。乃至洗盥。如是言已。时具寿阿难陀白佛言。世尊。如来勿应洗此病比丘衣覆不净故。我当为洗。佛告阿难。汝应洗此病比丘衣。如来当以亲手盥水。尔时具寿阿难陀于病者比丘为浣彼衣。如来尚以亲手盥水。乃至总略。时具寿阿难陀如彼病比丘所唱言。善哉汝当为起。我今侍汝于外出。外住已。如来亦复亲手盥水。语阿难言

  汝广大承事　　济度生欢喜
  为忧苦损恼　　舍离于众生
  若人此净信　　成就良福田
  所有世间中　　非余众生类
  譬如意贤瓶　　欲悕醇乳汁
  尊重彼天言　　是故生恭敬
  亦如新妇法　　承事无暂舍
  救无量众生　　后当获出离
  又若现前尊　　任持于顶上
  置众生髻中　　一心故无动
  设堕阿鼻狱　　若今造当造
  诸广大度门　　修行如是善
  自我为主宰　　我义不可得
  于彼彼造作　　不为慢所使
  喜乐净诸根　　苦故入烦恼
  由喜默诸根　　为作斯化度
  众生若在苦　　举身如焰然
  于诸欲悦意　　有方便怜愍
  愍诸造苦者　　故我求是苦
  若倦于忍默　　如罪当忏悔
  设于世尊所　　顶足俱散坏
  我舍诸世间　　承事如来故
  我造诸众生　　怜愍无疑惑
  见如是等人　　由何不尊敬
  我亲事如来　　正成于自利
  为除世间苦　　故我持净戒
  假若一强人　　摧坏于大众
  愿长睹众生　　使无能作者
  又若众强人　　一一如王力
  况无如是威　　何容行酷罚
  设逢暴主时　　治官狱卒等
  力行悲愍心　　拯济于群有
  极怒何所为　　宁同地狱苦
  若恼逼众生　　造此亦当受
  大喜何所施　　岂容获正觉
  若悦豫众生　　造此亦当受
  汝后当作佛　　出济诸众生
  云何不暂观　　现住称赞者
  巍昂清净身　　及寿量长远
  逮得生死忍　　转轮王妙乐
  若慈心供养　　名大身众生
  以佛净福报　　为佛大身者

论曰。修慈心观。如月灯经云。乃至供养无量无数百千万亿不可称量歌罗频婆罗等诸佛刹土。如是供养已。不如以一慈心。如是次第供养恭敬。常得远离高举不如理作意

论曰。一心人解是事。如宝云经说。善男子。云何菩萨不如理作意。为是菩萨独处闲静住无杂乱。发如是心。我由独处闲静住无杂乱故。唯我能顺如来法律。汝诸沙门婆罗门等皆住杂乱。于轮回行多所耽着。不能随顺如来法律。是为菩萨得不如理作意。彼经复说。菩萨起精进时。于此精进不拒教诲。谓不自矜己德。亦不陵蔑他人。如是名为善惠发生。然于自所修习。亦求他诲。如是菩萨得谦下精进

论曰。已略说此护受用福。若回向菩提。如无尽意经云。佛言。舍利子。若人以少善根回向菩提。乃至坐菩提场终无散灭。譬如一渧之水堕大海中乃至住劫边际终无散灭

    清净品第八

论曰。护身等说。有三种清净。今当说是义。云何谓己身受用清净俱获安隐。若人于身示现净饮食。成熟正等菩提。如秘密大乘经云。复次菩萨于大城邑大冢圹间。以无数百千众生充满其中。而菩萨摩诃萨示死灭相现旁生趣大身众生。乃至令食身肉。于命终时得生天界及余。善趣。以是因缘。乃至最后入于涅盘。所谓菩萨宿愿清净。于此长夜酬其宿愿作利益事。临命终时。令食身肉。以是因缘得生天界。乃至最后入于涅盘。谓若成就持戒。成就思惟。成就希求。宿愿如是。彼经复说。现法身光为诸众生作利益事。寂惠当知。譬如活命医王集诸妙药捣筛和合成女人相。姝妙端正人所乐见。而善安立施作等事。行住坐卧如其分别。诸有国王王子大臣官长长者居士。而或来诣活命医王。时彼妙药所成女人相与给侍。由给侍故。一切轻安得无病恼。佛言寂惠。汝且观是活命医王。深植妙乐除世间病。然余医师无有是智。寂惠。现法身光菩萨亦复如是。乃至男子女人童男童女及余众生。为贪嗔痴遍触其身炽然烧煮。若弹指顷一切烦恼远离烧煮。身获轻安。所谓菩萨宿愿极清净故

论曰。此身清净义者。譬如苗稼为草所覆而不滋茂。是菩提芽为烦恼覆亦不增胜若不行对治思惟悕求。何容解脱令彼增长。汝诸世间一心伺察。罪业清净则身器清净。说为正觉。复次罪清净者。四法经云。佛言。慈氏。若菩萨摩诃萨成就四法。灭先所造久积过罪。何等为四。所谓悔过行。对治行。制止力。依止力复次悔过行者。于不善业行多所改悔。二对治行者。谓造不善业已极为善业。及余利益之所对待。三制止力者。由读诵禁戒得无毁犯。四依止力者。谓归依佛法僧宝。亦不弃舍菩提之心。由能依止是力。决定灭彼罪等。佛言。慈氏。是为菩萨摩诃萨成就四法灭先所造久积过罪

大乘集菩萨学论卷第十大乘集菩萨学论卷第十一

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    清净品第八之二

论曰。复次应知说悔过行。如金光明经偈云

  十方住世　　两足之尊　　以悲愍心
  当证知我　　若我先造　　广大罪业
  住十力前　　皆悉忏悔　　未识佛时
  未识父母　　未识善恶　　我造此罪
  自恃种族　　及恃财宝　　盛年傲逸
  我造此罪　　心念口言　　造众恶业
  谓不可见　　我造此罪　　愚夫恶行
  烦恼覆心　　由无智暗　　近恶知识
  游戏乐着　　或住忧恚　　财无厌足
  我造此罪　　贫穷谄诈　　由生悭嫉
  不亲圣人　　我造此罪　　因欲生怖
  于去住时　　不得自在　　我造此罪
  因欲恚怒　　动扰其心　　饥渴所逼
  我造此罪　　饮食衣服　　由斯三种
  诸结热恼　　我造此罪　　身语意业
  三种恶行　　具如是相　　我悉忏悔
  若于佛法　　及声闻众　　不起尊重
  我悉忏悔　　又若缘觉　　及菩萨众
  不生恭敬　　我悉忏悔　　或于有德
  诸说法师　　不起承迎　　我悉忏悔
  由谤正法　　而常无智　　不敬父母
  我悉忏悔
  十方三世佛　　观察护念我
  心运无缘悲　　哀受我忏悔
  我于百劫中　　先若造诸罪
  常怀忧怖心　　哀愍愿消除
  又心常怯弱　　怖此诸过咎
  于四威仪中　　曾无欢乐想
  诸佛具大悲　　除诸世间怖
  今当愿摄受　　解脱诸怖畏
  我先造诸罪　　对如来发露
  以佛大悲水　　洗涤烦恼垢
  又若此罪恶　　一切皆忏悔
  若已作之罪　　皆不敢覆藏
  若未作之业　　一切不复造
  谓身业三种　　及语四过愆
  与意业三毒　　一切皆忏悔

论曰。菩萨所得罪犯。约胜说有轻重。故优波离所问经云。于根本罪等比而说。何者复重。佛言。优波离。住大乘菩萨。如犯殑伽沙数贪罪与一嗔罪。于菩萨乘为作校量。此二罪中。嗔唯属重。所以者何。优波离。起嗔者舍离众生。然起贪者爱护众生。优波离。若爱护众生则不为烦恼。于菩萨所无有灾横等怖。乃至是故优波离。若有犯贪罪者。皆名无罪。是义云何。爱护众生者如前增胜。故我说深心有是悲愍。佛言。优波离。菩萨若无方便善巧。则畏犯贪罪。若菩萨有是方便善巧者。则怖犯嗔罪。而不怖犯彼贪爱。何以故。方便善巧者具悲智二种。而不舍离众生。若舍众生者。唯一智惠悟解苦空。或唯悲愍。非久如间为烦恼力之所减灭。如方便善巧经云。善男子。譬若取明之人为彼罥索五处系缚。以真言王于所求法即能超越。由一真言明力。悉能断除一切缚法。善男子。是菩萨方便善巧受五欲乐亦复如是。然于所作不乱正行。谓若以一智力遍一切智心。净诸欲乐当生梵世

论曰。嗔义云何。谓本性为大罪故。由广分别不生方便悲愍。行恚怒者然非利益。何名过失。以容受彼则长养烦恼减失悲愍。斯为过失。断此根者后当可见。若菩萨如于众生失悲愍心。则于众生广大利益相续减失。故圣谛品云。应知如父见子起悲愍心。谓若弃除世间利乐悲愍。则亦当远诸有智。又若菩萨劝行于欲减失利益。是故说贪过咎得二种难。彼着欲者。譬无目人违害父母。于下劣欲而生苦恼损减天趣。又着欲者。毁犯禁戒远离人境。是故希求已乐厌舍他苦。非真实见。应以他苦恼如己苦恼。然不自修习。起二种失。如月灯经说。佛告阿难。假使有人从足至顶。洞然炽焰成一火聚。复有人来语如是言。我劝汝身共受五欲歌舞嬉戏。佛告阿难。于意云何。是人劝就此身可共五欲歌舞嬉戏不。阿难白言。不也世尊。佛告阿难。是人于歌舞嬉戏。由分别横起。劝就此身共受五欲歌舞嬉戏。如来不尔。往昔修菩提行时。见诸众生三恶道苦及贫穷者。心无悦乐

论曰。世间有子不见父母。怀檐痛苦有此大恩。唯见己乐或亲非亲愍惜覆藏。守护善法幢者勿行邪欲此于众生或为利益或复损害。谓若萦缠嗜彼欲者。斯为过咎。具正梵行作利益故。若比丘入是行处。应如母妹而供侍之。不应于他如梵行类。成就众生固当远离。如无尽意经云。于时非时复舍其所作。或见众生增上利益。亦住是学处。又方便善巧经云。昔光明梵志于四万二千岁中严持梵行。住七步已发生悲愍。设犯禁戒受地狱苦。不应弃彼令趣命终。善男子。是光明梵志即时执彼右手。作如是言。姊起如其所欲。以要言之。善男子。如是深妙欲中起大悲心于十千劫受轮回苦。后复还修梵行。善男子。以菩萨方便善巧得生梵世彼经又说。若有菩萨为一众生发善根者。于其色相如罪所堕。百千劫中受地狱苦之所烧煮。世尊。彼菩萨然起是罪无地狱苦。谓由于一众生亦不舍离此善根故。彼经又云。善男子。此方便善巧菩萨有极重罪。谓或时遇恶知识劝就此蕴取证涅盘。然于后际不复堪任被斯铠甲。何容化度一切众生。故我不起是心。如彼轮转化度众生。又若设有是罪。如其法行使无过咎。善男子。若出家菩萨一切分别所造过四重罪。是菩萨具方便善巧者。随起即悔。说为无罪。如宝云经所明。造极无间者。谓令人死。声闻律中名根本罪处。又若[利-禾+(黎-(暴-(日/共))+小)]剥鹿属如起悲愍。说为无罪。此贪得者。若菩萨起贪犹生善趣则不应嗔怒。如说方便善巧菩萨乐作贪暗。于妙女色极乐修作。数数愿求生女人中。厌彼贪心。舍女身已。得丈夫相成大身者。佛告阿难。汝见如是功德不。自余众生虽行如是起猛利贪。然犹出离苦器生人天趣。乃至药王大士。云何菩萨起嗔。谓若发生烦恼。何容施诸妙乐等

论曰。若为此名闻如是。于余众生利益方便设起贪者。说为无罪。此方便善巧菩萨所造利益。而不弃舍众生。广如彼说。然非得地六度妙行。于此伺察极善相应。是故不容嗔等。又优婆离所问经云。佛言。舍利子。菩萨有二大罪。何等为二。谓心与嗔俱及与痴俱。乃至舍利子。应先志诚忏十恶罪及五种[億-音+(夫*夫)]。亦当忏悔。谓手执眼观心难制止。或于一众生兼余二种。舍利子。复说有重五无间罪。谓具作此菩萨。或时于他妇女染行非法手断命根。盗佛塔物四方僧物。菩萨尔时如犯彼罪。应向三十五如来前于昼夜中一忏悔云。我某甲归依佛归依法归依僧

那谟释迦牟尼佛　那谟金刚消伏坏散佛　那谟宝焰佛　那谟龙自在王佛　那谟勇猛军佛　那谟勤勇喜佛　那谟宝火佛　那谟宝月光佛　那谟不空见佛　那谟宝月佛　那谟离垢佛　那谟勇施佛　那谟梵德佛　那谟梵施佛　那谟水王佛　那谟水天佛　那谟贤吉祥佛　那谟栴檀吉祥佛　那谟无边威德佛　那谟光吉祥佛　那谟无忧吉祥佛　那谟那罗延佛　那谟华吉祥佛　那谟净照明游戏神通佛　那谟莲华光游戏神通佛　那谟财吉祥佛　那谟念吉祥佛　那谟善名称吉祥佛　那谟因陀罗网幢王佛　那谟善游步吉祥佛　那谟安祥行佛　那谟胜游步佛　那谟普遍光严吉祥佛　那谟宝莲华胜游步佛　那谟宝莲华善住娑罗树王佛

如是现前乃至一切世界如来应供正等正觉。惟佛世尊观察护念。我于今生或至余生。及无始来生死轮转造业障罪。自作教他见作随喜。或盗窣堵波物四方僧物。五无间业十不善业道。自作教他见作随喜。由斯业障毁除禁戒。应堕地狱。或旁生趣焰魔境界。若生边地及蔑戾车生长寿天。设得为人诸根不具。深着邪见离佛出世。此诸业障佛以真实惠。真实眼。真实证明。真实称量。悉知悉见。今悉忏悔不敢覆藏。若我毁犯禁戒等罪。愿佛世尊观察哀愍。若我今生或至余生。及无始来生死轮转。乃至于旁生趣。或尝施一抟食护一净戒。若修梵行所有善根。化度众生发菩提心。及无上智一切善根。如称量已无不回向最上最胜阿耨多罗三藐三菩提果。我今亦如过去未来现在诸佛之所回向。乃至偈云

  忏除一切罪　　诸福皆随喜
  及劝请诸佛　　演说无上道
  过去及未来　　现住人中尊
  无边功德海　　一切归命礼

舍利子。是菩萨于三十五如来前。如是作已。是诸如来随知作意。得罪清净。由罪清净故。此诸佛世尊当现其前。如是解脱利益众生现诸相好。由是愚夫异生于此化度辄生疑惑。乃至一切声闻及缘觉众。而不能使彼恶作罪处清净地。若有菩萨于此诸佛如来名号。而常持念。昼夜三时转正法行。出离彼罪得三摩地。说此是名悔过及对治行

论曰。读诵甚深经典得彼罪灭。如能断金刚般若波罗蜜多经云。复次须菩提。若善男子善女人受持读诵此经。若为人轻贱。所以者何。是人先世所造罪业。应堕恶道。由见是法。以今世人轻贱故。先世罪业则为消灭得佛菩提等

论曰。信解空性得罪恶清净故。如来藏经云。佛言。迦叶波。有十不善业道。是为大罪。此最极杀生者。谓若杀父断缘觉命。最极不与取者。谓若欺夺三宝财物。最极欲邪行者。谓起污母及无学尼。最极妄语者。谓言我是如来。最极两舌者。谓于圣众作离间语。最极恶口者。谓呵毁圣贤。最极绮语者。谓巧构浮饰乱诸法欲。最极贪者。于正道财利起侵夺心。最极嗔者。于五无间无悲愍心。最极邪见者。谓横起僻执深险恶见。迦叶波。若一众生具足如是十不善业道大罪者。如来以是因缘宣说法要。为令悟入无我无人无众生无命者无作无受。是行是造作是幻化。然诸法性即烦恼性。入解诸法自体明亮。信解诸法种种清净。我不说有众生堕恶趣者。又净诸业障经云。复次文殊师利若菩萨观非律是律则见罪非罪。观轮回界即涅槃界则见诸烦恼是为缘生。当知是人得业障清净。又底哩三昧耶王经说对治行云。若闭目观缘诸佛菩萨。诵百字明八千遍已。开眼备睹佛菩萨等。得离彼罪。或右绕佛塔。诵八千遍塔像经典。随一现前。如仪广说。又尊那陀罗尼经云。若念诵已。乃至梦见是相。得灭彼罪。若梦天女授乳酪饭。得离彼罪。或见日月升虚空中猛火水牛及黑丈夫怖走而去。又若梦见比丘比丘尼众或乳木树白象。白牛山峰舡舫处大殿堂及师子座听闻妙法。应知悉是罪灭之相。又如来形像品说对治行云。譬若有人不净涂身臭恶可厌。以水洗灌施妙涂香。而彼臭恶即时远离。如是造作五无间罪。具足遍行十不善业道。若得信解如来造佛形像。得离彼罪。由无罪故。智惠殊胜具菩提心。由殊胜故。而或出家坚持净戒。花积陀罗尼经云。尔时师子游戏如来当住于世。经百千岁施诸妙乐。时彼如来般涅盘后起舍利塔。若人以菩提心持彼一花供养如来。合掌称名或洒水为净。及一花鬘涂香花灯乃至身行一步超诸言说。称南无佛。于彼师子游戏如来勿应疑惑。若于一劫百劫千劫。返堕恶道者。则无有是处。又药师琉璃光王经云。若持五戒十戒菩萨四重戒。出家比丘二百五十戒。比丘尼五百戒。如于所受或有毁犯怖堕恶道。若人专念药师琉璃光王如来名号。如其供养。是人决定不堕恶趣。尔时世尊告阿难言。若我称赞彼佛世尊药师琉璃光王如来所有功德。是为诸佛甚深境界。汝无疑惑生实信不。尔时具寿阿难陀白佛言。世尊。我于如来所说经中不生疑惑。所以者何。一切如来身语意中所集善行无不清净。世尊。此日月轮最为高远。具大威光可使坠地。妙高山王亦可倾动。是诸佛言终无异也。世尊。然有众生信根不具。闻说诸佛甚深境界。便发是言。由何唯念一如来名。便获尔所功德胜利。由斯不信便生诽谤。于长夜中退失利乐。佛告阿难。若闻彼佛名堕恶趣者。无有是处。阿难。此是诸佛甚深境界。难可信解。阿难。汝信解者。应知皆是如来威神之所建立。非诸声闻缘觉未登地者。唯除一生所系菩萨摩诃萨。故彼经又云。若余净信善男子善女人邬波索迦邬波斯迦。具足八分斋戒。一年三年受是学处。以此善根愿生西方极乐世界无量寿如来前者。若得闻是药师琉璃光王如来名号。是人临命终时。八大菩萨皆以神通来示正道。复有种种间色。世所希有。众宝莲华自然化生。或复生于天上。如是生处而宿植善根。彼无穷尽。亦复无有堕恶道怖。彼天殁已复生人世。为转轮王统四大洲

大乘集菩萨学论卷第十一大乘集菩萨学论卷第十二

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    清净品第八之三

与无量百千万俱胝众住十善业道。后复生彼刹帝利婆罗门长者大种族中。财物丰饶库藏盈溢。色相眷属皆悉具足。彼经又云。若有女人得闻是药师琉璃光王如来名号受持者。后转女身。又文殊庄严佛刹功德经云。妙吉祥言。我亦恭敬是惠上菩萨。光幢菩萨。如意愿菩萨。寂根菩萨。若有女人持是四菩萨名号者。得转女身后不复受

论曰。对治行略如前说。制止力今当说。如地藏经云。若菩萨摩诃萨离杀生者。即是施与一切众生无忧无怖及无悲恼惊慑毛竖。以斯善根果报。所有前际乘五趣轮溺生死海。因是杀生。造身语意一切业障。自作教他及随喜作。由此远离杀生轮故。一切摧灭乃至不受其报。于现身中得寿命长远。诸天及人之所爱乐。复次善男子。若菩萨摩诃萨乃至尽形寿离不与取。即是施与一切众生无忧无怖及无热恼。不生动乱。于自财利而行喜足。终不希取非法之利。以斯善根乃至因是远离不与取故。一切业障摧灭无余不受其报。以要言之。如是十不善业道。亦能对坏自所修善。如月灯经云。闻嗔灭罪者。如说凡愚不实嗔骂诽谤者。安住忍伏尽诸往昔所造罪业。及于菩萨所起嗔等

论曰。制止力已如前说。依止力今当说。故诸缘起中释云。若能归依佛者不堕恶道。舍此人身得生天趣。若法若僧亦同上说。又慈氏解脱经说。菩萨净诸罪业者。诸不善法遍若大地。而劫火起时一切所有无不烧者。乃至譬若有人以喝吒迦汁一两点。千两铁而作黄金。非彼多铁能令少汁而返成铁。此发一切智心亦复如是。以一善根回向智。能摄受一切业烦恼障成一切法智。非诸业烦恼障能令一切智心而为烦恼。善男子。又若有人持以一灯入照暗室。即时能破千年夐古之暗。此发一切智心亦复如是。如入一众生心无明暗室。俱能破坏百千不可说劫夐古业烦恼障发智光明。善男子。如大龙王首戴如意摩尼宝王冠。无他冤敌等怖。此菩提心亦复如是。若菩萨具大悲心。无有恶道冤敌等怖。优波离所问经云。此住大乘菩萨摩诃萨。于初日分时有毁犯罪。当中日分时不舍行一切智心。如是菩萨得戒蕴具足。若中日分时有毁犯罪。当后日分时不舍行一切智心。则菩萨戒蕴亦复具足。我应复说如是次第。佛言。优波离。此住大乘菩萨或时舍戒学处。然于彼菩萨勿起恶作。亦勿随转。若复于彼声闻乘者展转说。为有毁犯罪。然声闻人谓失戒蕴。应如是知乃至广说

    忍辱品第九

论曰。此不远离有多门转。而善守护令戒长养。如是离业障缚破烦恼结。乃至闻忍不忍减失精进怠堕俱故。或复不闻不知等持方便。由无方便净诸烦恼。是故懈退唯闻修习了杂乱行。谓诵习勤苦依止山林。彼修行者。暂息杂乱而心无等持。然此止息亦等持摄。尚无少果。况余净诸烦恼设修此观亦亡少善。乃至说净诸烦恼。法集经云。此说忍有三种。谓安住苦忍。谛察法忍。耐冤害忍。安住苦忍者。得究竟行对治苦怖及得除遣着乐之爱。余二种恼。彼云何说。谓嗔恚懈怠等。月灯经云。着乐之者亦不舍苦。又宝云经说。若内怀忧悲苦恼者。住方便调伏忍。最上授所问经云。复次长者。在家菩萨应当远离不如理损害。勿着世间八法所得妻孥及诸受用财谷丰饶。不以高举逸豫。设诸衰弊亦不低下愁恼。应如是观察诸有为相幻化所造。起高举处息灭罪报。谓此父母妻子奴婢仆从亲眷朋属等。彼既非我。我亦非彼。如有偈云。若有所干集。由何起愁恼。或无所干集。亦何起愁恼。为所干集者。以痴恚恼闷绝疲懈故。或执着勇悍起大过咎。痴迷追悔须臾夭寿。应远离此无益。是难

论曰。云何舍是愁恼。谓发轻软心者。如最上问经云。于此远离则令心柔软如睹罗绵。又华严经云。应如胜财王童女发如是心灭诸烦恼。以无能胜心破诸嗔忿。以不动心于众生海而不退堕深心境界

论曰。修习此者。不以为难。如其所有愚者尚尔。至若担夫耕农畋猎克苦修习。荷负鄙事悕微细果。尘秽不净心无悔恼。况复此等诸妙乐行。诸菩萨乐为最胜事趣无上果。又如诸鄙贱者少不饶益。于身难作尚无废坏。但自系念刚强领纳。如决胜负。况复此等长时无益受诸苦恼。由何于善法财少不悕取。地狱治罚世间贼害。狱卒守护按治无遗。随处遇会极为痛恼使勿为冤。于久远时无诸系缚。捍劳忍苦破烦恼贼净尽无余。于三有中被胜甲胄。执持器仗败诸魔冤解众生缚。由先修习以少克苦而得成就。于诸众生修苦乐想。谓诸苦生时。如其处所修习乐想。住乐想者。即能成办此果得三摩地。名超诸法乐。如父子集会经云。佛言。有三摩地。名超诸法乐。若菩萨得是三摩地者。于诸事缘受如是乐受不苦不乐。非一因缘如其处所而得乐想。譬若有人以因缘故。断截手足及耳鼻等。耳鼻断已。如其处所而得乐想。及以鞭杖之所打扑。翻如乐想。或为牢狱系闭捶挞。谓作衣者。然酥灯者。然油灯者。碾蔗浆等者。如其处所而住乐想。作鸺鹠面者。作师子面者。捻曝晒者。乃至造金钱者。造饮食者。供象酒等者。翻如乐想。或为挑目破坏命根。诸有损害及堕首等。翻如乐想。无苦乐想。所以者何。此菩萨摩诃萨如是愿力长夜修作。若我为诸走使得近妙乐。若我为罪犯者。亦以承事尊重恭敬供养。一切时处得近妙乐。若遇恶言讥刺打扑刀仗割截乃至诸坏命根。一切所有得菩提乐。成证阿耨多罗三藐三菩提果。具足如是作意如是事业如是愿力。亦复具足一切众生随知乐想亲近修习于彼业报多所修作。而得超诸法乐三摩地。若时菩萨得至一切法乐三摩地者。是故得大不动坏诸魔事。由是方便圆满一切舍施。成就一切难行苦行。坚牢一切忍辱。策励一切精进。助修一切禅定智惠。是故常喜。如月灯经说。常喜尊重常住正见。又无尽意经云。何等为喜。谓喜念法清净信乐。发踊跃心不生懈怠。无诸热恼不求五欲之乐。不离一切法乐。由心建立身喜觉喜起适悦意乐。如来身庄严相好希求善巧听法无厌依实法行。由法生喜爱乐净信。然于众生觉了无碍。以最胜欲勤求佛法不舍法欲。广大信解诸佛妙法示解脱乘。发最上心除悭吝心。若初发心施当施施已三轮清净。欢喜布施。于妙尸罗亦常清净。由持净戒摄诸毁禁。而常超越诸恶道怖向佛禁戒坚固无毁。正使他人恶来骂辱。于语言道心不加报乐然故忍变以尊重逮无憍慢。貌常温恭远离颦蹙。先以爱语无谄无佞。净意不邪心不粗涩。见诸胜己亦无曲抑。不觇乖谬不扬他失。修和敬法。于菩萨众敬如佛。使敬诸佛法惜过身命。于诸师长如己父母。护诸众生犹如一子。于和尚阿阇梨敬如佛想。于诸正行皆如上首。诸波罗蜜如爱手足。于说法师如诸妙宝。诸教令中如亲五欲。于喜足行如无病恼。求胜妙法如希妙药。于发露者如遇良医。如是调御诸根使无懈怠。说此是名为喜

论曰。此言学菩萨庄严者。如大云经说。若乐地狱旁生者。于地狱趣心常戒定。虽处狱城而得如旅泊。又乐地狱者。于地狱趣心生爱着及与悭嫉。令地狱火转复炽盛

论曰。说安住苦忍者。故海意经云。有三种忍。佛言。海意。此菩萨摩诃萨如其所发一切智心宝中。或为非人毁犯净戒。谓若诸魔魔民及天魔后魔。力所持。令魔使者固来侵害。震击动摇期克打掷。当于是时此大菩提发深固心令无所坏。亦复不坏。大悲精进解脱一切众生。亦复不坏。令三宝种绍隆不断。亦复不坏。诸佛法中于此相应积集善本。亦复不坏。成办相好修习福行。亦复不坏。勇力精进严净佛土。亦复不坏。求一切法不惜身命。亦复不坏。度诸众生不着己乐。是中深心具如是意。若为一切众生之所恶贱。或遇嗔恚讥毁骂辱及诸打掷。悉能忍受。至若一切众生以恶心来逼恼摧压。亦悉堪任不疲不懈不退不没。勇猛精进势力发现。捍劳忍苦起摄受心。又若有人以恶心来。若嗔若骂。妒害逼恼忿恚打掷。于如是心悉不加报。乃至设复有人于十方界执诸器仗逼逐其后。彼地方所若行若住若坐若卧。是中若遇一人发菩提心修布施心乃至修智惠心者。闻彼发起一善根心。我当即至彼地方所。正使断割其身节节支解如枣叶量。于是等事我悉堪忍。又若世间一切众生皆起嗔恚巧出恶言骂辱讥毁。加以断割其身节节支解如枣叶量。我当是时。于此众生终不为起少分动扰之心。所以者何。然我此身于过去际无量无数生死轮转。靡所不造。或处地狱畜生琰魔罗界。乃至今在人趣耽味饮食。诸欲受用听受非法。艰苦追求邪命资养。多种逼迫。然于身命曾无果利。虽复种种多所营作。缘此不能自利利他。设复生死最后边际。使诸众生于我身分断割支解。宁受众苦我终不舍一切智心。亦复不舍一切众生及善法欲。所以者何。然我此身多种逼恼苦切残毁。比地狱苦百分千分乃至优波尼刹昙分不及其一。又复于佛法中不舍大悲所缘一切众生。以要言之。若有因缘起嗔恚者。我当以法断除。云何为法。所谓爱乐于身。系属于身。取着于身。舍是身者即舍嗔恚。佛言。海意。于如是法聚而趣入者即能堪任一切众生之所逼恼。乃至不惜其身而能弃舍。亦不爱乐者。此即能修布施波罗蜜多。复次若遇身欲坏时。大慈不舍一切众生。此即能修持戒波罗蜜多。若遇身欲坏时。如义解脱堪任忍受。忍力发现亦不动扰其心。此即能修忍辱波罗蜜多。以勤勇力不舍摄受一切智心。于生死中发诸善行。此即能修精进波罗蜜多。复次若身坏时。于心发现一切智宝不舍菩提。如实观察胜寂寂静。此即能修静虑波罗蜜多。若遇身欲坏时。观身幻法犹如草木墙壁瓦砾。入解于身是无常是苦是无我是寂灭。如是谛察其身。此即能修胜惠波罗蜜多。乃至设复有人以恶心来嗔恚骂辱。即作是念。是人懈怠远离白法。我今发起精进勤求修习。植诸善本勿生厌足。乃愿是人先坐道场。我当最后取成正觉。以要言之。是等众生名未调伏者。未寂静者。未密护者。未近寂者。为作义利庄严铠甲。乃至我依此法。云何是嗔云何非嗔。二中伺察俱不可得。又若是嗔非嗔若自若他。嗔与嗔者皆不可得。斯不可得尚离此见。是即名忍。又般若云。若诸众生有所诤竞。应发是心。我当劝勉。我今于此诤竞得无难遇。若诤竞者及所诤事。然我于诸众生为作桥梁。我若为他恶骂毁呰。汝何此语不应加报。但类痴人。及若哑羊不起斗诤。他或恶来丑言骂辱于语言道心无损害。亲近于他我应善语。不似于彼起斯过咎。乃至若我闻他过失亦不似彼。所以者何。我意无怒故。又若一切众生所须妙乐者。我当与彼众生妙乐乃至涅盘。成证阿耨多罗三藐三菩提。然我于他终不起嗔。及与自他起愚痴行。唯修坚固精进。以精进故。设坏身命而无恚恼不生颦蹙。又菩萨别解脱经云。若于恚怒众生。如是安慰极善安慰。住此忍者得随顺法喜

大乘集菩萨学论卷第十二大乘集菩萨学论卷第十三

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    精进波罗蜜多品第十

论曰。虽闻住如是忍发生精进。然于此未闻尚起毁犯。如月灯经偈云

  傲法不护戒　　为得几多福
  破戒纵多闻　　无能免恶道

论曰。由闻具胜能者。那罗延所问经云。善男子。如所闻解得胜惠性。若闻息除烦恼。令烦恼魔皆不得便。是中广如最上大仙本起经云。菩萨摩诃萨具足深心尊重法欲。住余世界现诸佛前随所闻法。若菩萨摩诃萨精进法欲。于山林中贮法伏藏。得无量经典法门如置掌中。又诸菩萨精进法欲而得佛现前。及诸天等与佛辩才。乃至命欲将尽。为佛世尊及诸天等增益寿命及与色力。住命千岁非本所求。为佛诸天共加持故。乃至求住一劫。又诸菩萨生法尊重。为佛世尊除老病苦。得授正念及通达辩才。乃至得授正见随见能说。又若菩萨摩诃萨精进法欲无他一切冤敌等怖。是故精进多闻资粮善巧菩萨修习得如是等

论曰。菩萨闻几种行入解毗奈耶。如无尽意经云。由闻八十种行而能入解。所谓欲行。深心行。深固心行。极相应行。无倨傲行。不放逸行。恭敬行。极尊重行。离名相行。善言行。承事行。闻利益行。作意行。不散乱行。无住行。宝想行。药想行。消除一切疾病行。念器行。达解行。意喜行。悟入行。听闻佛法无厌行。广舍行了知调伏行。亲近多闻行。喜乐容受所作行。身踊跃行。心悦乐行。闻不懈退行。闻义行。闻法行。闻威仪行。闻他说行。闻所未闻妙法行。闻神通行。不乐余乘行。闻诸波罗蜜多行。闻菩萨藏行。闻摄事行。闻方便善巧行。闻梵行行。闻正念正知行。闻已生善巧行。闻未生善巧行。观不净行。观慈行。观缘生行。观无常行。观苦行。观无我行。观寂灭行。观空无相无愿行。无作行。善作行。建立真实行。无减失行。单己行。守护自心行。精进不懈行。谛察诸法行。对治烦恼行。希求自分善法行。降伏他分烦恼行。依止七财行。断诸贫穷行。赞诸有智行。欣乐智者行。众圣平等行。非圣净信行。见谛行。远离诸蕴过失行。称量有为过失行。依义行。依法行。一切恶作行。利益自他行。于善修作不发余业行。趣向殊胜行。所得一切佛法行。彼经又云。若于助法相应则得如是智业。云何助法相应。谓若少务少求。慎语慎行。初夜后夜闻诸世间顺理相应者。称量利他数数推求。心无浊染除诸盖障。于余罪犯以智出离不起恶作。发起趣向。坚固正行。乐法敬法为法奥府。具足精进如救头然。希求智惠为游止处。不堕禁戒不舍重负。趣发殊胜舍无益众。乐单己行于阿兰若现前作意及圣种子杜多功德。喜足不乱欣乐法乐。不念世间语言。求出世法要。及无妄念通达义利。随顺真道。知持戒缘惭愧庄严。以坚实智破坏无智。以胜惠眼极妙清净。觉了无明痴暗系缚。谓广大觉了。无邪曲觉了。分别觉了。现证觉了。不从他得。持自功德赞他功德。善所修作不堕业报。是为智业清净。又般若中说。应何所闻于方广经论。当如是学。非义利者亦应远离。所谓世间处论。鞭扑论。蛊毒论。默置论。童子戏剧论。乃至所有别部解脱等论。成就痴冥。善住一切菩萨乘者。悉应远离。又如无尽意经云。有四种施。于说法师为智资粮而得成就。何等为四。一者谓纸笔墨经。二者严饰法座。三者具诸名闻利养。四者为摄受法不以谄诈称赞。复有四护。何等为四。一者谓护己身。二者护善。三者护诸世间。四者护利益事。乃至复有四住。为智资粮而得成就。何等为四。一者住说法师。二者住法。三者住利养。四者住觉悟。是名四种。又华楼阁经云。若人以须弥量七宝聚。布施在家菩萨者。不如能以千钱奉施出家菩萨。或以信解出家功德。施一指节修难行施。若诸所有。唯除出家得是大果。如来最上最圣非在家者有如是理。况复在家无智心不具足。如最上问经云。谓若一心于他眷属等罪而能远离。说为无罪。彼若不能远离性难调故。于在家者建立是罪

    说阿兰若品第十一

如最上授所问经说。依止住阿兰若。次第居家者。性过失故。又如月灯经偈云

  不起着欲　　远离眷属　　弃舍在家
  得无上道　　若离于欲　　如避火坑
  怖畏在家　　远离眷属　　无上菩提
  斯不难得　　未有三世　　诸佛如来
  由常在家　　住于欲地　　而能获得
  胜妙菩提　　捐舍王位　　如弃欬涶
  安住空闲　　远离诸欲　　断除烦恼
  降伏魔冤　　离垢无为　　悟菩提道
  饮食衣服　　妙花涂香　　而得承事
  人中圣尊　　如出家已　　奉行正法
  若有如是　　求菩提者　　善利众生
  厌有为事　　趣向空闲　　至行七步
  所获福报　　最胜无比　　若复值遇
  非众同分　　乐处众会　　悕财利者
  众生随行　　离彼方所　　是愚闇难

彼经又云

  智不为愚诤　　猛利应当舍
  离此极恶心　　勿竞愚者法
  智不近于愚　　了知愚本性
  能使久相亲　　后当成怨嫉
  智不保于愚　　了知愚本性
  谓体性痴冥　　自当求破坏
  由是诸异生　　何有善知识
  若法共言说　　不顺嗔过咎
  斯愚法碜毒　　故智者不保
  愚与愚者合　　如粪投不净
  智复与智俱　　如酥置酥内

彼经又云

  常于世间　　最极乐处　　无有少分
  若乐不乐　　唯乐林泉　　随得受用
  沙门胜乐　　若于所有　　一切都无
  无有纤毫　　所系属者　　如风转空
  如独觉行　　乃至世间　　诸最乐事
  心常如风　　无所系着　　若乐不乐
  不有合集　　谓此苦恼　　不乐安住
  谓若乐彼　　无苦无违　　离二边故
  唯此法乐　　非人中乐

彼经又云

  彼得常时　　微作相应　　离别众失
  不诤少分　　彼相应理　　住阿兰若
  获是功德　　而常获得　　不悕有为
  不乐世间　　不增有漏　　住山林者
  获是胜能　　不起过分　　常乐近寂
  身语意密　　及远离行　　住空闲者
  获多功德　　得彼厌离　　速悟解脱
  寂静解脱　　住山林者　　即住解脱
  诸阿兰若　　获是功德　　栖止林泉
  而常远离　　城邑聚落　　乐远离已
  常如独觉　　无有伴侣　　非久如间
  得斯胜定

又护国经所说偈云

  弃舍在家　　无量过咎　　亦常不爱
  深险思虑　　得乐山林　　诸根妙乐
  寂静功德　　无有男女　　戏笑言论
  设有人来　　如独觉行　　心净无垢
  不喜财利　　意不耽着　　处处少欲
  当远离此　　谄求恭敬

最上问经云。我应不作众生合集。非为于一众生而起善根。或先所闻具刹那顷。系着财利心不净者。若天若人咸悉舍去。设一天人亦复舍去。又如宝楼阁经云。佛言。迦叶波。譬若有人泛大水中为渴而死。迦叶波。此沙门婆罗门亦复如是。然于多法受持读诵。而不能断贪嗔痴渴。游大法海为诸烦恼渴爱而死。后堕恶道

论曰。是故决定依阿兰若及相似处。又宝云经说。若住所依之处。得行乞食。不近不远。流泉浴池清净无垢少怖畏处。树叶花果皆悉具足。远离险恶多诸龛窟寂静第一。菩萨如是当依此处。应先昼夜六时自诵经典声不高下。善闭诸根心不外驰。于此净命系念所受。善取其相不着睡眠。若王王臣刹利婆罗门及余官属。或亲来诣阿兰若处。彼比丘应作是言。善来大王。如所施设可就此座。王若坐时。比丘亦坐。王若不坐。比丘亦立。王若诸根动乱。应当赞言。大王。得大善利。王之境土有诸具戒具德多闻沙门婆罗门。安住其中。不为恶人冤贼恼害。王若诸根善净堪为说法。即当为说善巧之法。审若不乐善巧则当为说厌离之法。审若不乐厌离则当令知如来有大慈悲具大威德。为诸来者刹利婆罗门及余官属。随其所宜为作化度。彼若多闻堪任法器者。使闻妙法降伏其心。彼等众生信乐是法得大欢喜。最上授所问经云。复次长者。出家菩萨住阿兰若。应如是观察是义。云何我住阿兰若中。非独沙门相者而多猛恶[怡-台+龍]悷。非密非静非律仪非相应非愿求之所共住。所谓非人诸恶鸟兽盗贼旃陀罗等之所共住。彼不具足沙门功德。尔时我住阿兰若处。我应圆满是沙门义。乃至复次长者。出家菩萨阿兰若行。应如是观察。我以何义至阿兰若。我当为此怖畏。云何怖畏。谓处众愦闹怖。合集怖。贪嗔痴怖。憍慢覆很怖。悭嫉财利怖。色香味触怖。蕴魔怖。烦恼魔怖。死魔怖。天魔怖。无常计常颠倒怖。无我为我颠倒怖。不净为净颠倒怖。执苦为乐颠倒怖。心意识怖。离障起障怖。身见怖。我我所怖。疑三世怖。恶友怖。恶属怖。名闻利养怖。不见言见怖。不闻言闻怖。不觉言觉怖。不知言知怖。沙门垢秽怖。互相嗔忿怖。三界怖。诸有趣生怖。三恶道怖。总略一切不善作意怖。我为如是此恶怖畏行相诣阿兰若住。乃至复次长者。出家菩萨住阿兰若。当如是学。若怖生时。一切皆由我执所起。以要言之。复次住阿兰若远离我执则无我无我所无我相无我爱无我想无我见。不为我所持。不为我所计。舍离于我不为守护。住阿兰若此非利益。复次长者。住空闲者。无己想无他想。若于诸法无说则于诸法无杂。以要言之。长者。譬如阿兰若处药草树林不惊不怖不畏。亦无惊慑毛竖。此出家菩萨住阿兰若行亦复如是。于身发起药草树林墙壁瓦砾之想。心如幻化。所生何有。分别及有怖畏惊慑毛竖。如是深心于身观察。是身无有我人众生寿者养者意生儒童虚妄遍计。此怖畏者但有假名。虚妄遍计不应分别。如彼阿兰若处药草树林无有主宰亦无摄属。此阿兰若无有摄属亦复如是。于一切法如是知已。应起是行。所以者何。住空闲者。犹若强尸无有主宰亦无摄属。乃至复次长者。出家菩萨如住空闲。于此知已依佛所说住阿兰若。即得圆满白法深植善根。然后出诣聚落国邑。入于王宫而为说法。复次长者。出家菩萨读诵演说解其义趣。入彼众中而得恭敬。亲近和尚阿阇梨及耆旧中。而新学比丘亦应尊敬亦无懈怠。悉自营办无令他恼。亦应勿使尊重承事。当如是观察。又如来应等正觉为诸天人魔梵沙门婆罗门及诸众生尊重供养。乃至诸有所作悉自营办不怖承事。况复我今欲求无学。如是承事一切众生。若我承事于他一切供给。则我诸有所作悉自成办。不复悕求承事供给。所以者何。长者。此尊重承事者。于比丘功德法中摄取毁犯。造此摄取者。因得承事故。我勿由是法造此摄取。彼经又说。复次长者。彼阿兰若菩萨法。若见若闻和尚阿阇梨疾病者。虽处迥野应往问讯。谓若旦时诣彼。应发是心。设复为他所请读诵解说令住僧坊者。如阿兰若。心勿受着。如是住阿兰若。求法无厌。于一切事皆空闲想

大乘集菩萨学论卷第十三大乘集菩萨学论卷第十四

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    说阿兰若品第十一之余

宝积经云。复次阿兰若行若诸异生未得果者。见虎狼至勿生惊怖。当发是心。我本诣此阿兰若处。已舍身命不应惊畏。为起慈心远离过失使无怖惧。又若虎狼断我命根啖我身肉应起是心。我得善利以不坚身而当获坚固。若复不能令啖我肉。岂彼虎狼得乐触耶。以要言之。复次阿兰若行。有非人来。若美若丑。不应爱乐。亦勿损害。若有往昔见佛诸天来此阿兰若比丘所起诸问难时。彼比丘如力所能。随所学法为诸天说。又若有深问难时。阿兰若比丘。或未能答而不生恭敬者。应语彼言。我今未得无学。若我当勤佛教。时闻法已尽能通解答一切问。我今唯能得闻是法。乃至总略。若住阿兰若处药草树林。尚不取着。云何为生何等为灭。如是观察。是身无我无主宰无作者无受者。谁生谁灭。毕竟无有生灭之者。是身亦复如是。譬若草木墙壁瓦砾无我无主宰无作者无受者因缘和合故即生。因缘离散故即灭。复次于胜义中无有一法是生是灭彼经又说。复次阿兰若行。应发是心。然我至此阿兰若处独无伴侣。若我所起善作恶作。尔时此有天龙药叉佛世尊等。知我深心俱为我证。又若住此阿兰若中以心不善自在游逸。又若至此极远之处。独无伴侣无亲近者。无我无取。应如实觉。欲寻恚寻害寻及余不善法寻。悉如实觉。若我于此不异其众乐处有情愦闹中者即为欺诳天龙药叉诸佛世尊。若如所作天龙药叉不为呵厌。诸佛世尊悉皆欢喜

    治心品第十二(禅定波罗蜜多附)

论曰。于此阿兰若修是禅定。如般若经云修此禅定波罗蜜多者。得心不散乱利诸众生。所以者何。起世间定彼尚亦然。乃至心散乱者皆不可得。况复阿耨多罗三藐三菩提。是故得心不散乱。乃至成证阿耨多罗三藐三菩提果。彼经又说。复次须菩提。初发心菩萨摩诃萨修禅定波罗蜜多行时。于一切相智相应作意则善入禅定。若眼见色不取其相。亦不执取随形妙好。若于眼根不修制止。则依邪妄损恼于余恶不善心随其流转。护眼根者。制此令尽。如是耳所闻声鼻所嗅香舌所了味身所著触意所知法。皆不取相亦不执取随形妙好。若于意根不修制止。则于余恶不善非法之心随其流转。护意根者。制此令尽则行住坐卧语默时处。悉不舍离三摩呬多。得彼手足不生动摇口无杂言亦无戏笑诸根不乱。若身若心俱无妄失三业寂静。于显密中如律仪道。乃至喜足易养易满。善入行处远离愦闹。于得不得无有高下等无差别。如是苦乐毁誉若赞不赞若夭若寿亦无高下等无差别。若冤若亲心常湛然。是圣非圣其声无杂。于乐不乐犹如一相无高无下。等无差别超诸违顺。所以者何。于自相空如不真实。则见诸法无生无灭。乃至广说

论曰。喜乐修习者远诸懈退。而常作意者息除高举。于此二种是所对治。护国经偈云

  无量俱胝劫　　所有佛出世
  由是大仙尊　　刹那获胜益
  远离于放逸　　解脱诸染欲
  此有为虚妄　　如幻梦所见
  乖离非久住　　诸爱亦不常
  如奋力营求　　诸波罗蜜地
  乃至悟菩提　　精进无疑惑

大戏乐经广说偈云

  老病死苦　　如火焰然　　三有炽盛
  无适无莫　　未离轮转　　常处愚瞑
  譬若狂蜂　　处罃器内　　三界无常
  如戏剧者　　及秋空云　　旋生旋灭
  人命迁坏　　过于山水　　轻捷迅速
  如电飞空　　虚天界城　　遍三恶道
  无明横起　　爱有所生　　被转五趣
  如陶家轮　　常乐美色　　及妙音响
  清净香味　　细滑触乐　　贪着此者
  如被囚絷　　如鹿寄网　　如猴被缚
  常怀怖惧　　作冤家想　　此欲乐者
  极多忧恼　　如锋锐刀　　亦如毒药
  智者远离　　如弃粪瓶　　愚懵念着
  为怖畏因　　及为苦本　　爱有所缠
  疾趣衰老　　常乐欲者　　怖无归捄
  昔有圣人　　了知此欲　　怖如猛火
  如大淤泥　　如持蜜刀　　如避空剑
  又诸智者　　了知此欲　　如粪秽瓶
  如毒蛇首　　如木耦驴　　如涂人血
  如死狗头　　如恶冤家　　又诸圣智
  了知此欲　　譬水中月　　如山谷响
  如镜中像　　如戏剧人　　如梦所见
  又此欲乐　　智者了悟　　如幻如焰
  如水泡沫　　刹那而住　　遍计所起
  虚妄不实　　但谓盛年　　任持色相
  意乐此者　　实愚夫行　　及老病至
  坏苦所吞　　退失光泽　　如竭河流
  财力丰饶　　库藏盈积　　爱乐此者
  实愚夫行　　或至匮财　　后疾耗灭
  远离于人　　如空园林
  譬如花果树　　爱乐人悕取
  贫窭衰老时　　厌弃如鸲鵅
  丰财壮色者　　乐生和悦意
  贫窭衰老时　　厌弃如死尸
  又此衰老相　　年迈极过朽
  譬如雷电火　　焚余枯槁树
  此衰老可畏　　亦犹朽故宅
  是故牟尼尊　　说速求出离
  又若娑罗林　　为藤蔓所缚
  如男女眷属　　枯干速衰朽
  又若溺泥夫　　顿乏于勇健
  此老相亦然　　趋捷无快利
  老变形容丑　　威雄势力衰
  长别妙乐寻　　趣死无光泽
  此百种病恼　　固非安隐乐
  是相于世间　　炽然如猛兽
  观若老苦病　　是世间苦恼
  俱舍妙乐寻　　说速求出要
  又如霜与雪　　夺草木滋茂
  病苦于世间　　坏命根色力
  仓库多崇积　　追求极边际
  常如疾病人　　好起嗔恚事
  及冤害仇对　　炎热如空日
  及至死灭时　　财命俱散坏
  譬川流不返　　如果叶堕树
  亦如河中梗　　漂沈不自在
  随业果难停　　独去无伴侣
  此死灭之法　　又若磨竭鱼
  吞啖无量众　　如金翅食龙
  及兽王搏象　　若猛火焰然
  焚烧诸草木

又教示胜军大王经说。佛言。大王。譬若四方有四山来。坚固精实周普连匝。状一合成无有缺漏。亦无间隙。是中空界地际一切动植悉归磨灭。谁有踊踯而可逃避。及以势力咒禁药术财物等事而令退转。佛言。大王。世有四种大怖畏事亦复如是。谁有踊踯而可逃避。及以势力咒禁药术财物等事而能退转。何等为四。谓衰老病死。佛言。大王。一者衰势来时摧逼兴盛。二者老相现时摧逼少壮。三者病苦集时摧逼调适。四者死灭侵时摧逼寿命。此复云何。佛言。大王。亦如师子为众兽王。色相勇健皆悉具足。爪牙刚利入鹿群中。搏取其鹿随应所欲。然鹿踊踯入猛兽口无能为也。佛言。大王。死箭射人亦复如是。纵使刚强无能逃越。无归无救亦无投寄。节节支解血肉枯竭。饥渴热恼。张口大息手足纷乱。于追求事悉无堪能。涎涕流溢便利不净。涂污支体余命渐灭。中有现前随业缘起。焰魔使者甚可怖畏。趣黑夜分于出入息最后而尽。唯己独行更无伴侣。奄背此生倏往佗世。奔大险道入大黑暗。涉大旷野趣大稠林。泛大溟海业风飘堕。所向冥寞曾无标记。余无归捄余无投寄。佛言。大王。唯法与法是归是捄。是所投寄。佛言。大王。此善法者。如寒者得火。如热者遇凉。渴者饮清冷水。饥者食珍美馔。疾病者遇良医药。怖畏者得强力伴。是为归捄。佛言。大王。此诸善法。有大势力亦复如是。无归捄者为作归捄。无投窜者为作投窜。大王。是故应知。有现无常者现灭尽者。法尔如是。唯死怖畏。佛言。大王。王恃所为悉非善法。所以者何。大王。然此身者从昔已来纵加守护及加莹饰上妙饮膳恣情饱满。及命终时未免饥渴逼恼而死。如是身者虽以种种可爱奇文侈服上妙细[疊*毛]。行住坐卧随意严饰。及命终时秽恶不净要当流出。大王。又此身者虽以澡沐涂香粖香熏香妙花无量严饰。及命终时不久臭秽。又此身者后妃婇女眷属围绕。种种妓乐歌舞嬉戏。及诸僮仆悦意快然。及命终时未免怖畏及诸苦恼。佛言。大王。至若此身虽处宫殿台榭楼阁户牖轩槛。彩绘严饰。种种花香及与灯明。屏幛帏幔床座茵褥。烧众名香散诸妙花。宝瓶香炉处处行列。及妙珠宝锦绮杂饰玩好之具。及命终时至冢墓间。骨肉毛发脓血臭秽。尸卧地上都不觉知。佛言。大王。又此身者而常乘御象马车乘。击鼓吹贝作大音乐。张妙幰盖执持扇拂。无量勇健象兵马兵车兵步兵导从前后。百千官属城邑人民叉手恭敬。不久要当尸卧车上。众人荷挽出大城门。父母妻妾兄弟姊妹奴婢仆从作业使人心缠忧恼。头发被乱举手拍头悲咽哀恸咸叹苦哉。于我无捄无亲无主。城邑人民衔悲瞻恋。至冢圹间。或复为诸乌鸢雕鹫狐狼野干之所食啖。乃至余骨积薪所焚。或[瘞-(人*人)+(乂*乂)]于地。风雨曝露末为微尘散掷余方。佛言。大王。此身幻化终归坏灭。一切诸行悉是无常。乃至广说

论曰。此贪嗔痴等一聚烦恼。至若对治修习。因是远离。故宝云经说。对治贪者。于起贪缘悉能远离。云何名对治贪及起贪缘对治。贪者若善了知。于起贪缘修不净观。云何名不净观。谓若于身发毛爪齿皮肤血肉筋脉骨髓肪膏脑膜汗泪涕唾咽喉心肺肝胆脾肾生脏熟脏屎尿浓汁。菩萨于如是物而起观察。则愚痴小儿颠狂不善。知是物已犹尚不起贪爱之心。况诸智者。是为菩萨修不净观。又如般若经云。复次善现。菩萨摩诃萨修般若波罗蜜多行时。然于此身如实了知。善现。譬若解牛之师及师弟子断牛命已复用利刀析为四分。若坐若立如实观察。善现。菩萨摩诃萨修般若波罗蜜多行时。亦复如是。然于此身地界水界火界风界如实观察。乃至善现。又若耕夫或诸长者。满治场中有种种谷。所谓菽麦稻梁脂麻芥子等。有明目人分别视之。如实了知彼种种谷。此是菽麦。此是稻梁。此是脂麻芥子等。善现。菩萨摩诃萨修般若波罗蜜多行时。亦复如是。然于此身从顶至足发毛爪齿种种不净之所充满。而菩萨如实观察是身。唯有发毛爪齿头目脂髓肝胆脾肾生脏熟脏眵矃不净等。乃至若诣冢间观种种相。谓所弃尸于冢圹间或经一日二日乃至五日。身体膖胀青瘀臭恶皮穿肉溃脓血交流。见是事已。我与此身亦复如是。然此身者法尔如是。本性如是。如是法性曾未解脱。复次善现。菩萨摩诃萨修般若波罗蜜多行时。而于外身修随所观。乃至观所弃尸。于冢圹间或经一日二日乃至七日。为诸鸟兽乌鸢雕鹫狐狼野干之所食啖。及余种种蝼蚁咂食。见是事已。我与此身亦复如是。然此身者法尔如是。本性如是。如是法性曾未解脱。以要言之。又若观所弃尸。于冢圹间蛆虫咂食。不净臭秽。我与此身亦复如是。余如上说。乃至复次向凄惨道。观所弃尸。肉销骨现筋缠血污。我与此身亦复如是。余如上说。复次向凄惨道。观所弃尸。血肉都尽身骨相现。余筋尚缠。我与此身亦复如是。余如前说。复次向凄惨道。观所弃尸。唯有众骨散掷异方。所谓头骨足骨腰骨背骨颈骨臂骨等。我与此身亦复如是。余如前说。乃至复次善现。菩萨摩诃萨修般若波罗蜜多行时。向凄惨道观所弃尸。唯有骨在风飘雨渍白若珂贝。我与此身亦复如是。余如上说。复次善现。菩萨摩诃萨修般若波罗蜜多行时。向凄惨道。观所弃尸。唯有骨在。经[應-倠+秝]多年变异青色。如泥处地碎末为尘。我与此身亦复如是。然此身者法尔如是。本性如是。如是法性曾无解脱

论曰。以不净观对治贪者。则修慈观对治嗔恚。此乃平等。若不乐观众生者。此或于一饮食发生爱乐则于他妙乐悕求称赞。无不爱乐。慈者度贪欲因缘不着染爱。是义有三种。无尽意经云。谓初发心菩萨修众生缘慈。已习行菩萨修法缘慈。得无生法忍菩萨修无缘慈

大乘集菩萨学论卷第十四大乘集菩萨学论卷第十五

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    治心品第十二之二(亦名禅定波罗蜜多品)

复有佛缘菩萨缘声闻独觉缘众生缘等。彼众生缘者。谓先乐与利益安乐。以禅定意与彼慈故。或有知识客寄近住。以己聚落如他聚落。乃至于此一方解脱。如是汝缘十方佛等亦无厌怠。如金刚幢回向中说。具足修习菩萨行者。若所见色对治于爱。如是乃至声香味触法对治于爱。则无罪犯。是净是善。最上光洁超诸妙乐。生适悦意起净信乐。发生踊跃安住极喜。于分别心不生退恼。心意调柔诸根猛利常受妙乐。如是回向一切诸佛。转复回向诸佛般若。而得具足不可思议佛妙乐行。然未同佛得善摄受三摩地乐。由是力能展转得佛无量妙乐。具足无量佛解脱乐。摄受无量佛神通乐。得善摄受无数诸佛无著行乐。得佛自在如彼牛王所至远近速疾妙乐。毕竟获得无量佛力了知一切寂静无生无灭等乐。于无著行而常等引得诸如来不二集行无嗔妙乐。是为菩萨常以如是善根回向如来。回向菩萨者。谓于意乐未圆满者。回向圆满于一切智。未清净者。深心清净一切波罗蜜多。未成办者。为令成办发菩提心。犹若金刚令一切智铠无有退屈。若令一切智铠无退屈者。则于菩提妙乐随所轻安。于诸善道无所退向。平等安住一切世间。圆满大愿修习一切菩萨之行。了知菩萨利根神通。由斯善根证一切智。以如是善根义故。回向菩萨。又若学佛教者。一切声闻辟支佛等。亦以善根如是回向。若有众生一弹指顷闻佛法声。及贤圣众为作尊重。以此善根回向阿耨多罗三藐三菩提。所谓念佛圆满回向。念法方便回向。尊重圣众回向。不离见佛回向。清净心回向。通达佛法回向。所修无量功德回向。清净一切神通善根回向。断诸法疑回向。是为于声闻辟支佛等学佛教者之所回向。又彼菩萨亦以善根回向一切众生。所谓远离地狱道回向。断除畜生道回向。与琰摩罗界妙乐回向。断除堕诸恶趣回向。令彼众生乐欲增长无上菩提回向。为令深心得一切智心回向。不谤一切佛法回向。毕竟成就一切智地回向。毕竟清净一切众生回向。以无量智回向一切众生。乃至所有饮食衣服卧具病缘医药。于身承事去来坐立。种种作业住律仪道。于律仪道不生嗔恚。身语意业如善修作。密致诸根而或自身消息。按摩等事。众味饮食。若开若合。若观不观。若卧若觉。而复自身诣彼承事。菩萨于一切智缘平等相应者无不回向。彼一切智心乐利乐一切众生。乃至意常救护一切世间。发起善根远离憍逸。以要言之。令诸烦恼不复现前。为诸菩萨之所守护。决定勤求一切智道。爱乐亲近诸有智者。乃至而能修习一切善根。速得圆满相续诸行。以要言之。彼畜生趣者。或以少饭而能施与。令彼一切得生善趣。如是利益解脱回向。彼畜生者。是为苦海。是苦所取。是为苦蕴。是名苦受。是为苦聚。是苦迁流。是苦边际。是苦根本。是苦依处。于彼众生不退回向。又彼一切众生缘者。谓于众生现前作意。由先所作善根发菩提心回向一切智故。不堕轮回离诸险难得佛妙乐现前无碍超轮回海永断相续照明佛法起大慈故。如最胜金光明经慈悲藏伽陀云

  是金光明　　最胜金鼓　　所出妙声
  遍三千界　　能息地狱　　及焰摩罗
  乃至人中　　贫穷苦等　　又此金鼓
  灭除世间　　一切障恼　　亦愿众生
  得除恐怖　　如牟尼尊　　寂静无畏
  如诸圣人　　处生死海　　修一切智
  如彼所得　　胜慧等持　　及菩提分
  功德大海　　又此鼓音　　愿诸众生
  获斯梵响　　如佛证已　　胜妙菩提
  转净法轮　　住无数劫　　说法利生
  灭贪嗔痴　　烦恼众苦　　若有众生
  住于恶道　　为火所烧　　身常洞然
  闻斯鼓音　　如教诲言　　令归佛宝
  又令众生　　得宿住念　　于百千亿
  俱胝生中　　念牢尼尊　　闻甚深教
  又此鼓音　　常得近佛　　净修善行
  远离罪恶　　乃至偈云　　又诸刹土
  一切众生　　息除世间　　所有诸苦
  又若众生　　身分下劣　　根缺减者
  普得诸根　　悉皆圆满　　若疾病者
  身形怯弱　　随其方处　　无所依怙
  解脱众病　　得获轻安　　根力充实
  又若众生　　王法所加　　生种种怖
  及多忧恼　　彼诸众生　　苦难若至
  最极恶事　　百种怖畏　　悉令解脱
  或复捶打　　枷锁系缚　　种种苦具
  逼切其身　　又复无量　　百千种类
  忧畏愁叹　　间扰其心　　牢狱系闭
  打挞楚毒　　一切解脱　　被临刑者
  遽活躯命　　众苦虽至　　得无怖惧
  又若众生　　饥渴逼恼　　令得上味
  美膳饮食　　盲者备睹　　众妙色相
  聋者得闻　　适意音响　　彼裸形者
  得细软衣　　贫窭众生　　得众伏藏
  仓库丰饶　　众宝严饰　　一切众生
  获斯妙乐　　无一众生　　受诸苦报
  诸相端严　　人所乐见　　饮膳丰饶
  福德具足　　常得受用　　无量妙乐
  箜篌箫笛　　众妙音声　　随彼心念
  应时现前　　念水即现　　清净池沼
  金色莲华　　及优钵罗　　遍覆其上
  随彼心念　　应时现前　　乃至偈云
  涂香花鬘　　和合末香　　每日三时
  从树而雨　　众生取已　　咸生喜悦
  供养十方　　不可思议　　一切如来
  菩提妙法　　诸大菩萨　　远尘离垢
  诸声闻众　　得离一切　　卑下种族
  及八难处　　常值无难　　最胜中王
  常得亲近　　诸佛如来　　乃至偈云
  愿诸女人　　得为男子　　刚健勇猛
  智慧聪利　　而常修行　　诸菩提道
  六波罗蜜　　见十方佛　　在宝树下
  处琉璃座　　安隐快乐　　围绕恭敬
  闻说妙法

论曰。此略明慈行对治于嗔。以缘生观对治于痴。今当说是中缘生义。有稻秆经说。云何内缘生法系属于因。谓无明缘行乃至生缘老死若无无明则知无有行。乃至若无有生则知无有老死。又若实无明灭则行灭。如是乃至生灭则老死灭。又彼无明不念我从行起。行亦不念我从无明得起。如是乃至生亦不念我从老死得起。老死亦不念我从生得起若实无明起者。则行起不可得。如是乃至生起则老死起亦不可得。应知是为内缘生法系属于因。复何内缘生法系属于缘。谓地水火风空识等界。和合于内系属于缘。云何地界。谓令此身聚集而转。坚硬为性。说为地界。又若令身摄持造作。说为水界。又若令身暖性现前饮食成熟。说为火界。又若于身造出入息。说为风界。又若于身中有窍隙。说为空界。谓此名色犹如交芦。令五识身相应系属。有漏意识。说为识界。若非此缘者。则身不转。若内不阙地界。如是水火风空识界亦无阙减。彼彼和合则身定转故。然此地界不念我能令身坚聚。水界不念我能令身摄持造作。火界不念我能令身温暖饮食成熟。风界不念我能于身作出入息。空界不念我能于身中成窍隙。识界不念我为缘生由是缘故身定得转。又此地界无我无人无众生无寿者无意生无儒童非男非女亦非非男亦非非女无自在无主宰无此无彼及无所有。如是水火风空识界亦复无我无人无众生无寿者无意生无儒童非男非女亦非非男亦非非女无自在无主宰无此无彼及无所有。复次无明者。是义云何。谓于此六界之中。起一想合想坚固想常乐我净想众生寿者意生儒童想自在主宰等想。如是种种无智。说为无明。由此无明谓实有境起贪嗔痴。即彼贪嗔痴境。此说为行。于事表了。此说为识。识俱生时彼四取蕴。说为名色。又此名色所依诸根。说为六处。三法和合。此说为触。由触领纳。此说为受。受耽着故。此说名爱。爱深广故。说名为取。取能生有。有复生因。由是蕴起名生。蕴熟为老。蕴灭名死。痴嗔染着畏死名忧。追感伤叹名悲。五识相应不常领纳名苦。作意和合极苦名恼。如是引生随烦恼等。乃至总略

大乘集菩萨学论卷第十五大乘集菩萨学论卷第十六

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    治心品第十二之余

复次所说真实行及邪妄行。谓无智无明。由是无明起三种行。谓福非福不动行等。此说是为无明缘行。又此福行非福行不动行等随所得识之所招集此说是为行缘识(今详此处合有识缘名色一段经文梵本元阙)。如是名色及名色增长于六处门造作所起。此说是为名色缘六处。又此六处六触身转。此说是为六处缘触若触。生时令受所起。此说是为触缘受。若受美味深喜乐着。此说是为受缘爱。喜耽味故若处乐色。色离散时数数追求而不弃舍。此说是为爱缘取。如是追求令后有起身语意业。此说是为取缘有。若业迁谢令蕴生起。此说是为有缘生。又若生已变异令熟及坏灭时。此说是为生缘老死。乃至是中由识等自体为种子。业自体为良田。无明爱等自体为烦恼。以业烦恼等令识种生者。谓此业为识种田事。爱为识种沃润。无明为识种开发。然业不念我为识种田事。爱亦不念我为识种沃润。无明不念我为识种开发。是识种子亦复不念我为众缘所生。然识种子住于业地。以爱沃润无明滋长生名色芽。此名色芽非自作非他作非二俱作。非自在天所化。不由时变。非一因生非无因生。无不系于父母因缘和合耽染相续。是识种子于母腹中生名色芽。然此法尔无有主宰。无我无取等如虚空。体相幻化因缘不阙。由五种缘发生眼识。何等为五。谓眼识生时。藉眼及色空缘明缘作意缘等。是中眼识眼为所依色为所缘。明为照瞩。空作无碍。同时作意为彼警发阙是缘者眼识不生。谓若不阙内眼根处。如是不阙色及空明作意缘等故。彼一切和合则能生眼识。而眼不念我与眼色为作所依。色亦不念我与眼识为作所缘。空亦不念我与眼识为作无碍。明亦不念我与眼识为作照瞩。作意不念我与眼识而为警发。如是眼识不念我从缘生。然眼识生时。实藉众缘和合而生。如其次第诸根生识随应为说。然无有法从于此世得至他世。但由业果因缘不阙之所建立。譬如无薪火则不生。是业烦恼所生识种亦复如是。彼彼生处相续和合生名色芽。如是法尔无有主宰。无我无取如虚空等。体相幻化因缘不阙。应知内缘生法有其五种。何等为五。所谓不常不断无所至向因少果多相似相续。云何不常。谓若此边蕴死彼边蕴生。非即死边蕴是彼生边蕴。是曰不常。又不灭于死边蕴而起于生边蕴。亦非不灭于死边蕴然起于生边蕴。譬若权衡低昂时等。是曰不断。又于异类众生身处非众同分生边蕴起。是曰无所至向。又今少作善恶业因。于未来世多获果报。是曰因少果多。又若此生作业则未来受报。是曰相似相续。佛言。舍利子。此缘生者以如实正惠。常修无我无人众生寿者。如不颠倒则不生不灭。无作无为无对无碍无怖无夺无勤无懈。观彼自性无有坚实。如病如痈如痛如害。是苦空无常无我等性。彼复随观前际不流转者。谓我于过去世曾有耶。谁谓我于过去世曾有耶。我于过去世为无耶。谁谓我于过去世为无耶。复于后际不流转者。我当未来世为有耶。谁谓我当未来世为有耶。我当未来世为无耶。谁谓我当未来世为无耶。复于现在世不流转者。我于今有耶。谁谓我今有耶。云何为我今有耶。又十地经说。是中无明爱取。是为烦恼。流转不断行有。是为业。流转不断烦恼余支。是为苦流转不断。复说无明缘行。是曰前际观待。识及受等。是曰现在观待。爱及有等。是曰后际观待。此上所说皆名流转。乃至如是。由系属故则为流转。若离系属则无流转。由和合故则为流转。若离和合则无流转。由是了知诸有为中多种过失。是故我今当断系属及彼和合。然为化度一切众生。毕竟不断诸有为行

    念处品第十三

论曰。彼治心业略明缘生对治于痴。次当入解不净身念处今当说。如法集经云。复次善男子。菩萨如是住身念处者。谓我此身从足足指跟踝腨胫膝髀臗骨腰脊腹肋胸胁手指肘腕肩臂颈项头颊髑髅等状。众分积聚是即业有。由斯造作种种烦恼及随烦恼。百千种类邪正分别。是身唯有发毛爪齿血肉皮骨肝胆脾肾心肺肠胃生藏熟藏肪膏脑膜眵泪涎涕便利不净多物积聚。以何为身。由是观察身如虚空。则见一切诸法皆空。为空念处。了知是身由二种念。所谓流散及不流散。是身来者。不从前际。去者不至后际。亦不住二际中间。唯从颠倒和合造作。由斯领受。是中居处而为根本。然实无有主宰。亦无摄属。但从客尘先所作事。身体形貌受用依止为所恃处。然此身者。唯有父母赤白和合不净臭秽揽为自体。三毒忧恼常为贼害。是散坏法。种种百千病恼窟宅。如宝髻经说。是身无常而不久住死为后际。了知此已不应于身而生邪命。应当以身修三种净施。何等为三谓身净施。寿命净施。受用净施。是身无常。应当往诣一切众生所亲近承事。欲何所作。或如仆使或如弟子。离诸谄诳身过失等。是身无常。唯出入息为寿命因。宁造罪恶。是身无常。应于爱乐受用不生耽着。一切当舍。复次善男子。菩萨以身观身念处。应观自身及一切众生身等同佛身。威神加持得离缠缚。然观自身及一切众生身与如来身无漏法性彼相无异故。应如是知。又无畏授所问经说。谓我此身非先所集。渐次散坏。譬若微尘。九窍流溢如疮疱门。又诸毛孔有嚩罗弭迦。犹如毒蛇依止而住。身如聚沫体性怯弱。如水上泡暂生即灭。亦如阳焰本无有体。身如芭蕉中无有实。身如幻事为他教敕。身如恶友多诸诤讼。是身如猴性唯轻躁。是身如仇常伺其短。是身如贼机巧贪取。是身如囚常被缚戮。是身如冤不可爱乐。亦如魁脍能断其命。又复此身如空聚落中无有我。如陶家轮无暂停止。如滓秽瓶不净充满。身如痈疽挃唯痛楚。身如朽宅不久迁坏。身如漏舡无堪济渡。身如坏器渐当沮坏。又复此身如河岸树必为駃流之所漂动。身如旅泊多诸艰苦。身如邸舍妄执主宰。如伺盗者常生暴恶。乃至是身如痴小儿要当守护。彼经复说。如是种种不净之身。由我慢愚痴妄为光洁。智者所观犹如秽瓶。眼鼻口等眵涕流出。云何于此多生贪慢。又彼偈云

  如愚痴童子　　洗炭欲令白
  设尽此生中　　求白不可得
  亦如无智人　　洗身欲令洁
  屡加于澡沐　　至死不能净
  菩萨观于身　　九窍疮疱门
  八十千户虫　　依身而所住
  菩萨观于身　　如刻木众像
  筋骨假连持　　应知无主宰
  菩萨观于身　　或受他饮食
  应知同狐狼　　来食自身肉

论曰。由饮食资助成广大行。如是处处应当了知。受念处者。如宝髻经说。善男子。菩萨以受观受念处了知众生。依止大悲得如是乐。若一切众生无有解脱。应当修习以受观受念处。我当被大悲甲摄受调伏一切众生。悉以彼乐灭除众苦。我以大悲令贪行众生了知乐受离于贪染。我以大悲令嗔行众生了知苦受离诸过失。我以大悲令痴行众生了知不苦不乐受舍俱生痴。又彼乐受不坏苦受不减不苦不乐受离于对治则无无明。若无无明彼何名受。云何了知一切无常及无我等。然此乐受即无常性。苦受即逼迫性。不苦不乐受即寂静性。由此了知若乐若苦无常无我等。又无尽意经云。若受苦时当念一切恶道众生起大悲心。摄除于嗔离于颠倒分别受等。又法集经偈云

  说受为领纳　　领纳复为谁
  受者离于受　　差别不可得
  智者观于受　　住如是念处
  彼相如菩提　　光明遍寂静

大乘集菩萨学论卷第十六大乘集菩萨学论卷第十七

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    念处品第十三之余

论曰。此略说受念处。次明心念处者。如宝积经说。佛言。迦叶波。谓于此心或生爱乐或起厌患或多封着。于彼三际云何伺察。若过去则已灭。现在不住。未来未至。非内非外亦非中间。皆不可得。又此心者不可色见。非所诠表亦非对治。非观非照无住无著。然此心者一切如来尚无所见。余何能观。无别境界唯法想转。迦叶波。是心如幻遍计不实。由所取故种种得生。心如虚空为诸烦恼及随烦恼客尘所覆。心如河流生灭不住。心如灯光因缘所起。心如击电刹那不住。心如恶友能生诸苦。心如渔师苦为乐想。心如鬼魅作诸娆恼。心如药叉伺啖精气。心如狂贼坏诸善根。心如灯蛾常眄其色。心如鼙鼓唯警斗战。心如婢仆贪嗜残味。是心如蝇触膻腻器。是心如猪于不净中谓为香洁。佛言。迦叶波。求是心者了不可得。由不可得故无所得。于过现未来皆不可得。则能超越三世有非有等。又宝髻经云。然此心者非外所有。故不可见。于蕴处界亦不可见。如是寻求不可见者。由何所缘数数得起。谓彼彼心缘如是事。云何说为心不可见。应知是心如利剑刃何能自断。又复此心亦如指端指岂能说。心不可见亦复如是。乃至如人远行其身轻转迅疾如风。所至境界无能障碍。善男子。若人于此六处境界自他系属。心无爱着身不散乱。则于奢摩他心一境性得无障碍。是为心念处。又无尽意经说。以相应行修习庄严。于法性心而不减失。云何庄严彼法性心同于幻化。谓若自舍一切所有。而能回向彼法性心。是为严净诸佛刹土。法念处者。亦如彼说。菩萨于法不观法行法无可观故。若非佛法非菩提道。则一切法皆非出离。了知此已得大悲三摩地。于一切法非有烦恼非无烦恼。得三轮无想。所以者何。了诸法性无有二相。是诸烦恼无积聚性。无贪性无嗔性无痴性。若能如是悟菩提者。了烦恼性即菩提性。是为法念处。又宝髻经云。善男子。菩萨以法观法念处。若法起即生。法谢即灭。谓于法尔我人众生寿者养者士夫补特伽罗意生儒童生老死等。若集即集行。若不集即不集行。若善不善及不动行。未有少法无其因缘而得生起。乃至于是法处深所伺察。不舍一切智菩提心故。如大戏乐经云。此有为行唯心造作。犹若坯瓶无常散坏。行如空城为雨沮坏。泥涂不坚渐当磨灭。亦如河岸积沙所成自性怯弱为水流荡。行如风灯生灭不住。行如聚沫不可撮持。行如芭蕉中无有实。复如空拳诳示愚騃。乃至或草葛等搓捻为绳。依瓶辘轳而能汲引。未尝独一有彼作用。一切有支互相依止聚集而转。是前后际亦不可得。如人钻火二手与木勤劬不息火乃得生。众缘若离火势随灭。于如是行印所印已。若自若他即能超越断常等行。如智商人于诸险道。所至方隅而得通达

论曰。由无明爱等烦恼业缘之所招集成蕴处界。于胜义中皆不可得

    自性清净品第十四

论曰。说念处已。次复入解补特伽罗。决定成就相应空性断根本已。余烦恼等不复集行。又如来秘密经云。佛言。寂慧。譬如有树名钵罗奢。若断其根即一切枝叶悉皆枯瘁。寂慧。此亦如是。若断身见即能除灭一切烦恼

论曰。分别空性有无量行相。如月灯经偈云

  若人信解如来教　　于佛戒学无毁犯
  悉能远离诸女人　　知法自性常空寂
  拔除一切忧苦箭　　或施医药令安稳
  速得成斯二足尊　　知法自性常空寂
  若于身命断支节　　杖木捶打无恚恼
  忍力最上人中月　　知法自性常空寂
  设百生中堕恶道　　常得任持妙色相
  亦复获是五神通　　而常安住诸佛所

又般若经云。复次舍利子。菩萨摩诃萨欲成就佛身三十二大人相及八十种好者。于一切生中当念菩提心无令损坏。于菩萨行得无忘失。离恶知识及诸过咎。亲近一切佛菩萨众善知识等。为欲降伏诸天魔众。净诸业障。于一切法得无障碍。当学般若波罗蜜多。复次舍利子。菩萨摩诃萨如是发一念心。悉能超越东方殑伽沙等世界一切方所当学般若波罗蜜多。复次舍利子。菩萨摩诃萨设住十方佛刹当学般若波罗蜜多亦如是说。乃至广如诸法无我。灭业障缚则见诸法自性无灭。如父子合集经云。佛言。大王。如是六界及六触处十八意所伺察。是补噜沙为缘得生。云何六界。所谓地界水界火界风界空界识界。云何六触处。谓眼触处而见于色。若耳触处得闻其声。若鼻触处能嗅于香。若舌触处悉尝于味。若身触处亲觉其触。若意触处则知于法。云何十八意所伺察。谓眼见色已。若生适悦若生忧恼若住于舍。如是六根各各缘彼适悦等三。是名十八意所伺察。大王。云何为内地界。谓于内身所生硬涩发毛爪齿等若内地界不生亦无有灭则无集行。大王。若时女人而于内身如所思惟彼补噜沙。彼补噜沙亦生爱乐。由二和合羯逻蓝生。又复如所思惟相似和合而得生者。无有是处。若二女人无有是处。二补噜沙亦无是处。若彼彼思惟而得生者。亦无是处。自体无实非相应故。云何说此为坚硬性。大王。此坚硬性相似而立。毕竟此身溃烂散灭。唯冢圹间是所归趣。彼坚硬性从何所来。亦非四方上下而去。大王。此内地界应如是知

大乘集菩萨学论卷第十七大乘集菩萨学论卷第十八

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    自性清净品第十四之二

大王。是外地界坚硬性者。尔时世间初建梵天所居宫殿。大宝所成。复生他化自在诸天所居宫殿。皆七宝成。大王。若无地界坚硬性生。彼何所来。复成大地厚八万四千踰缮那。纵广六万踰缮那。复生轮围大轮围山。坚固安住同一金刚。复生苏弥卢山庾健陀山[寧*頁]泯陀山伊舍陀山乃至黑山。如是三千大千世界次第成已。坚固安住。若无地界坚硬性生。彼何所来。大王。又此世界欲坏灭时。或为火焚成为水漂或为风吹。而此大地为火烧时。譬然酥油其焰弥炽。乃至煤烬不复可见。若为水漂如投盐水中。寻即消坏。若为毗岚风所吹时。彼三千大千世界悉皆散坏。净尽无余。大王。此外地界生时本空。灭时亦空。自性空故。无有男相亦无女相。但唯言说之所显示。如是地界与地界性。皆不可得。如实正慧而能了知。云何内水界。若此身内所有执受湿润等性。彼复云何。所谓涎汗涕唾脂髓脓血溲便等物。为内水界。大王。若时忽见亲爱人等眼中流泪。或为苦恼所逼流泪。或闻深法信重流泪。或为寒风所吹流泪。如是水界从何所来。水相干时复何所去。乃至此界坏时遍兴黑云。三十二重弥覆三千大千世界。于虚空中降澍洪雨。点大如象。昼夜倾注相续不绝。如是时分经五中劫。其水积满上至梵世。大王。此大水界从何所来。又此世界将欲坏时。有二日出。二日出已。小河泉源悉皆干竭。三日出时。无热恼池流出四河亦皆枯涸。四日出时。大海水减一踰缮那。或二或三渐次减少至十踰缮那或二十踰缮那。次第枯竭至八十踰缮那。有余水在。或深一多罗树。或深至胸臆。或深如牛迹。乃至少水深一指面。当尔之时。大海中水悉皆干竭。净尽无余。大王。此水界相。生无所来灭无所去。生时本空。灭时亦空。自性空故。无有男相亦无女相。但唯言说之所显示。如是水界与水界性。皆不可得。云何身内火界。若此身中所有执受温热等性。彼复云何。所谓温暖蒸热。咀嚼饮食成熟变坏。使令安乐入热数者。名内火界。云何外火界谓不执受温热相生。若复有人于旷野中寻求火缘。或以蒿艾。或牛粪屑。或兜罗绵。引火生已。或烧草木山林聚落。及余方处皆为所烧。大王。如是火界。生无所来灭无所去。从本已来自性离故。云何身内风界。轻动等性。彼复云何。谓此内风。或时上行。或时下行。或住腹间。或胁或背。或发隐疹。或聚成块。或如刀裂。或如针刺。出入息等遍满身肢。外风界者。谓若此风从四方来。或紧如箭。或利如刃。若狂暴起。摧折林木堕裂山峰。若微细起飘举身衣动多罗树。名外风界。余如前说。云何内空界。若此身内皮肉血等显现增长离质碍性。彼复云何。谓若眼窍耳穴面门咽喉。咽啖饮食所引滋味。于肠胃间通彻而出。若时业缘引生六处。诸处生已围绕空界。此说名入内空界数。然彼空界从何所来。若复外所显现离质碍性。名外空界。大王。若色变坏一切皆空。所以者何。是虚空界本无尽故。安住不动犹如涅盘。遍一切处无有障碍。大王。譬如有人于彼高原穿凿池井。于意云何。是池井中所有空相。从何所来。王言。无所从来。佛言。大王。设使彼人复填以土。于意云何。空何所去。王言。空无所去。所以者何。是虚空界无去来故。不住男相不住女相。大王。外虚空界本来无动。所以者何。自性离故。如实正慧而能了知

复次大王。云何识界。谓若眼根为主各别所缘显色形色及以表色。名眼识界。若六根为主缘于六境各别建立。名六识界。又此识界不着于根不住境界。非内非外及二中间。然此识界各各了别彼彼事已。即便灭谢。生无所来灭无所去。大王。识生时空灭时亦空。自性空故。不住男相亦非女相。但唯言说之所显示。如是识界与识界性皆不可得。如实正慧而能了知。大王。云何眼处。谓四大种地界水界火界风界所造净色。若地界清净则眼处清净。若水火风界清净则眼处清净。何以故。由地界清净眼处得生。是中无有少法可得。如是乃至由风界清净眼处得生。是中无有少法可得。何以故。无主宰故。无造作故。犹如涅盘自性净故。大王。如是眼处各各寻求。皆不可得。所以者何。由地界空故则地界清净。乃至风界空故则风界清净。若诸法自性本空则彼界何有清净。亦无忿诤。若净若诤皆不可得。复有何色而可见耶。当知眼处毕竟空故自性亦空。前际后际皆不可得。未来所造亦不可得。何以故。自性离故。若自性无有则无男相亦无女相。何有爱乐若生爱乐是魔境界。若无爱乐是佛境界。何以故。若无爱乐则能远离一切诸法

大王。云何耳处。谓四大种所造净色。乃至大王。诸法解脱决定现前如法界空。不可施设不可显示。不可记别无所希望。大王。诸根各各乐着境界。眼缘色时而生乐着。是故说色为眼境界。又此眼根缘于色境有三种相瞩。可爱色起于贪想。不可爱色起于嗔想。非爱非恶而起舍想。如是乃至意着法处为意境界。若彼意处缘可爱色极生乐着。为彼所牵引生贪行。不可爱色生于嗔行。于爱非爱起于痴行。如是声等三种攀缘领纳等相。准前应说。大王。当知诸根如幻境界如梦。譬如有人于睡梦中与诸婇女共相娱乐。大王。于意云何。彼梦觉已。忆念梦中婇女娱乐为实有不。王言。不也世尊。大王。于意云何。是人所梦执谓为实为智者不。不也世尊。何以故。梦中所见。众人婇女毕竟无有。何况与之共相娱乐。当知是人徒自疲劳。念梦中境不复可得。佛言。大王。如是如是。愚痴异生眼见色已。心生爱乐复起执着。为彼所牵造贪业行。身业三种语业四种意业三种。最初造作刹那灭谢。不依东方南西北方四维上下中间而住。于死边际命根灭时。自分业报皆悉现前。犹如梦觉念梦中事。大王识为其主。业为攀缘。二种相因初识生起。或趣地狱。或堕傍生琰摩罗界及阿苏啰若人若天。初识生名。各受其报。同分心品相续随转。最后识灭名为死蕴。最初识起名为生蕴。大王当知。无有少法从于此世得至他世。所以者何。性生灭故。大王。身识生时。无所从来灭无所去。彼业生时。无所从来灭无所去。初识生时。无所从来灭无所去。何以故。自性离故。如是了知身识身识空。自业自业空。初识初识空。若灭灭空。若生生空。了知业缚无有作者亦无受者但名想耳。复次大王。譬若有人于睡梦中与诸冤对共相斗战。于意云何。是人觉已。忆念梦中斗战等事。为实有不。王言。不也世尊。佛言。大王。于意云何。是人所梦执谓为实。为智者不。不也世尊。何以故。梦中毕竟无有冤对。何况与之共相斗战。是人徒自忧恼都无有实。佛言。大王。如是如是。愚痴异生眼见恶色即生于恼。厌离破坏毁呰过失造嗔业行。余同前说。复次大王。譬若有人于睡梦中为毗舍遮之所娆害。心生怖畏痴迷闷绝。大王。于意云何。是人觉已。忆念梦中为鬼所娆。为实尔不。不也世尊。梦中毕竟无鬼所恼。况痴迷耶。佛言。大王。如是如是。愚痴异生眼见是色。痴迷不了造痴业行。余如前说。复次大王。譬如梦中得闻众人美妙歌声箜篌弦管诸音乐等。大王。于意云何。是人觉已。忆念梦中所有歌乐。为实尔不。王曰。不也世尊。佛言。大王。于意云何。是人所梦执谓为实。是为智不。不也世尊。何以故。梦中众人尚不可得。何况美妙诸乐音声。是人徒自疲劳毕竟无有。佛言。大王。如是如是。愚痴异生闻可意声。闻已适悦复生乐着造贪业行。如是香等各各三种。准前应知。乃至大王。于此法中善自安意应作是念。我当云何于人天中为作眼目为大灯炬而作照明。为作船师令渡彼岸。为大商主引至宝处。未解脱者令得解脱。未安隐者令其安隐。未涅盘者令证涅盘。大王当知。诸根如幻境界如梦。凡夫缚着无有厌足。乃往过去无量世时。有转轮王名无量称。威德名闻富贵自在。统四大洲独为尊胜。随所意乐而得受用。一切林树常有花果。时世人民安隐无恼。复能降雨众妙香水。金银珍宝种种资具。诸有所须普皆充足。忽于一时升忉利天。帝释天主分座令坐。贪欲无厌欲侵其位。作是念已即便退没。群臣围绕咸共见之。譬如生酥置热沙中不得久住。将趣命终。尔时有王名曰作爱。见是事已而作是言。我当云何于诸世间善说斯事。时无量称语作爱言。汝于未来当如是说。彼无量称贪无厌故自取命终。乃至是故大王。诸根如幻境界如梦。当自安意勿生信顺。身如阳焰自性无有。色受想行自性不实亦复如是

大乘集菩萨学论卷第十八大乘集菩萨学论卷第十九

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    自性清净品第十四之余

论曰。此说依世俗胜义建立诸法。当如是知。若时世尊以一切智观察世间。现证了知依世俗说则有六趣。若天若人及阿苏啰地狱饿鬼傍生。上下种族受报贫富。衰盛苦乐及以毁誉。色无色等种种相生。若时如来出现世间。诸众生等于善逝所。发生净信乐胜义说。是时如来为利众生如证而说。诸法之实无有造作。无有分别。无有知觉。无有显示。亦无言说。如是诸法一切皆空。若如是者。云何世尊复说受记无上正等菩提。于此法中以何为色。复何名为受想行识。而能记别无上正等菩提。由是了知色本无故。则菩提无生。乃至识本无故亦同是说。于诸法中。皆无所得。何名为佛。何名菩提。何名菩萨。何名受记。若色色空。乃至若识识空。但依世俗刹那建立。如是言说但名想耳。智者于此勿生嗔恼。如世尊说。诸法实际毕竟无尽。彼乐变化天不解深义。执我为有亦无障碍。世尊复说。诸法菩提自性离故。若能觉了即是亲近无量菩提。所以者何。若离菩提则无涅盘。若无涅盘乐欲则无轮回可怖。世尊。如乐变化天所执有。我不可得故。况复实际而可得耶。时娑婆界主闻佛说已即生领解。说伽陀曰

  如人梦中饥所逼　　纵食百味饱何有
  了斯梦相本来空　　诸法自性亦如是
  如人善说诸言论　　闻已咸生于爱乐
  若言若爱二皆无　　是中不得生疑惑
  譬如琴瑟发妙音　　彼声自性无所有
  了知蕴爱亦同然　　妙慧推之不可得
  譬如商珂大音响　　闻已寻求何所生
  彼声自性本来空　　则了大仙一切法
  譬如上味诸肴膳　　食已资身使充实
  如是身味本来无　　则了大仙一切法
  譬如天帝现宝幢　　诸天咸睹生爱乐
  了知是相本来空　　则了大仙一切法
  譬如有人分地界　　强名城邑本来无
  亦若身城自性空　　则了大仙一切法
  譬如集会人击鼓　　众共闻已生忻悦
  彼声自性本来空　　则了大仙一切法
  又如击鼓藉缘生　　若无湿润声弥震
  寻求是相何所来　　则了大仙一切法
  复如击鼓出洪音　　彼无思虑及呼召
  如是分别本来无　　则了大仙一切法

论曰。此复明前义。谓眼等诸法自性无有。若诸法无有则无成办。若无成办则无生灭。乃至眼根所缘三相爱非爱等皆不可得。无有言说亦无表示。譬如空拳举示小儿。但诳于彼都无有实。至于名量亦不可得。此胜义空决定无有。如人梦中为彼大仙现威猛相而断其首。智者觉已。了知一切皆自识现。由是解脱。如大树紧那罗王问世尊言。若所说法悉皆是空。云何世尊与我受记。我亦不知。自住楼阁不增不灭。亦不散坏受用无尽。是相云何。佛言。汝当了知彼一切法自性清净法界本空。犹如镜中现其影像。如造车轮聚集而显。我说作业自性亦尔。又如林树由风所吹两相摩击而发于火。如是思惟。火何所得。我说作业亦复如是。如说有人寿满百岁。应知无有积聚年岁而可见也。又如法集经说。眼之与色本无有诤。如是耳声乃至意法亦无有诤。云何眼色无有所诤。以二和合不相违故。乃至意法二相和合亦复如是。若不和合则有所诤。世尊。法无有二。是故不诤。诸法无二各不相知。由不相知则无分别。若离分别则无生灭。无有增减。不生爱乐亦无厌患。不住轮回不着涅盘。世尊。若于诸法不乐不厌。应知则无染净等相。世尊。若言如是我知如是我觉。皆是虚妄之所分别。世尊。若复于此眼等诸法。善了知已。不作是念。我能分别。当知是人不与物诤则能随顺沙门道行。为见法者。为见佛者。为见众生者。为见空性者。世尊。见无所见。是名诸法无见。彼经又云。无所发菩萨问曰。如如空者。于法何说。佛言。彼如如空不生不灭。若如是者。诸法皆空。时无所发菩萨言。如是如是。是故世尊说一切法皆无生灭。世尊。何故复说有为诸法悉皆生灭。若如是者。则佛之塔庙决定生灭。善男子。如来大悲为除世间众生惊怖。随顺宣说生灭之法。是中无有少法可得。况生灭耶。如般若经云。具寿须菩提。无生法者。何名无生。须菩提言。舍利子。生无所生是无生法

论曰。此名积集清净福行而成菩提。以清净慈缘于有情。善观察已无众生相。若复供养十方善逝。彼二足尊已离垢染亦不可见。应当供养苦恼众生。是调御师之所教敕。人中上供而以施之。以大悲心拔除众苦。获安隐乐发生净慧断除烦恼。于此正理善了知已当离疑惑。如是供养果不难得。了佛正教如教观身念八圣道断诸痴染。当舍己身承事诸佛。不希世间诸天妙乐。修奢摩他毗钵舍那若寂遍寂。为出苦道

云何建立世俗诸法。谓于虚妄处和合相应凡夫迷倒。谓为子想依止成就。说胜义空处则无是相。以一切法本无生故。如无垢称经说。文殊师利问维摩诘曰。虚妄分别以何为本。曰颠倒想为本。又曰。颠倒想孰为本。曰无住为本。又问。无住孰为本。曰无住则无本。文殊师利从无住本则能建立一切诸法。又般若经云。应当舍家安住勇猛断除烦恼。心净平等修习般若波罗蜜多。又法集经云。善解空者。心不依止世间所有利衰称讥忻戚毁誉。于诸苦恼不生厌患。于诸快乐不生爱着。不为世法之所破坏。善解空者。则了空性无有少法而生取舍。若无取舍则无贪厌。此则名为善见空者善知空者。于一切法无有执着。若无执着。则于诸法无有所诤

论曰。此明刹那心得清净。谓由我慢轻舍众生。了知我见本来无有。彼若一心专注能断。是人速疾心得清净。如是观察于一切处诸众生所。常乐尊重离于攀缘及所分别自他平等何有相违。如是行学斯不为难。譬若如意摩尼宝珠人所爱乐非能自贵。是故于他当生尊重。谓由颠倒分别执着。于有情边。而生悭吝或生毁訾。皆由我慢之所缠缚。以是缘故。多生赞毁增长热恼如何鼻燃。是声无心于赞。何有此妄慧起彼适悦生。何于他言而生于爱。他喜若生非我有故。常乐平等自取安静。解分别缚离赞毁相。如是了知都无果利。又于财利多生喜恼。惯习悭嫉机巧希求。顺违二种俱获重罪。随顺正理当起对治。摧我慢峰心速清净。离语言过专乐寂默。唯除教诲相续显示。了诸妄法无有坚实。生苦之本不得久住

    正命受用品第十五

复次长者。若在家菩萨当乐正命平等受用。远离非法邪活命等。如宝云经说。云何菩萨于施者所不以身业假现威仪。若举足时不诈徐步。若下足时不作瞻视。现思惟相。云何菩萨语不矫诈不为利养。而现细语柔软语爱语随顺语。云何菩萨心不谄曲不为利养。语现少欲心广贪求内怀热恼。云何菩萨善能舍离。为利养故而现异相。若见施者终不自言我乏衣服卧具饮食病缘医药愿垂惠施。云何菩萨善能舍离。为利养故虚言鼓动。若见施者不作诈言。某甲施主持如是物而施于我。我以某物而报彼恩。又言。以我少欲持戒多闻故施。我起悲心而摄受之。乃至身行恶者。为利养故奔走往来而破禁戒。若见余人同梵行者所得利养。兴心损坏。是名菩萨离于险恶而求利养。云何舍离非法利养。谓此菩萨不以斗秤而行欺诳。他所委信不生侵损。云何舍离不净利养。谓此菩萨于窣堵波若法若僧所有之物不作互用。若有所得亦不肯受。云何舍离耽着利养。谓此菩萨所得之物。不摄于己不自炫富亦不积聚。随时而施沙门梵志婆罗门等。或施父母亲眷朋属。或自受用。若受用时不生染着。若时菩萨不获利养。心不生苦亦无热恼。或复施者无有所施。菩萨于彼不生嗔心。又无尽意经说。无有众生不堪受施如其所许持用施之。有来乞者。不起恼施。不为他人逼迫而施。无劳倦施。无异相施。无轻易施。无背面施。无弃掷施。无不敬施。无分别施。无不自手施。无不依时施。无不平等施。无恼众生施。又如最上授所问经云。菩萨行布施波罗蜜多时。若有人求乞所须物。当依我作而给与之。若乐酒者使生正念。即与其饮后复令断。如是菩萨清净方便摄受众生。若其内心爱乐不舍。菩萨即为种种诃毁。酒之过失如利刀剑。决定远离不令相续。如是施者则无过咎

论曰。此说施行清净渐令趣入。如余经中广明制断。如虚空藏经云。所谓我清净施。我所清净施。因清净施。见清净施。相清净施。种种性清净施。刹那果报清净施。心等如空清净施。乃至譬如虚空无有边际。菩萨行施亦复如是。譬如虚空宽广无碍。菩萨行施广大回向亦复如是。譬如虚空无有色相。菩萨如是离色行施亦复如是。譬如虚空无想无作无表无相。菩萨行施亦复如是。譬如虚空遍诸佛刹。菩萨大慈缘诸有情广大行施亦复如是。譬如虚空含容一切。菩萨行施摄诸有情亦复如是。乃至如变化人施变化者。无有受用亦无分别。意达诸法无所希求。离我我所自性清净。以胜智慧断诸烦恼。以方便智不舍有情。是为菩萨修行布施波罗蜜多犹若虚空

大乘集菩萨学论卷第十九大乘集菩萨学论卷第二十

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    正命受用品第十五之余

论曰。此复明尸罗清净。如虚空藏经云。远离声闻辟支佛心。于菩提心不生退转。则于尸罗而得清净。善男子。譬如虚空体性清净。菩萨持戒清净亦尔。虚空无垢。菩萨持戒无垢亦尔。虚空寂静菩萨持戒寂静亦尔。虚空无坏。菩萨持戒无坏亦尔。又如虚空无能过胜。菩萨持戒于有情中无有胜者。又如虚空清净平等。菩萨行忍于诸有情平等和合清净亦尔。譬如有人手持利斧入娑罗林断其枝叶。当知彼树无有嗔恚。不生分别谁能断者。亦不分别谁所断者。菩萨行忍亦复如是。是为菩萨最上忍辱犹如虚空。又宝髻经说。身精进清净。谓若此身犹如影响。所有言说自性无记。了知是心毕竟空寂。当以大悲被慈甲胄。具足诸行深修禅定。于功德法无令缺减。以菩提心观诸众生无有缺减。乐行布施乃至方便无有缺减。于慈悲喜舍深心相应无有缺减。于布施爱语利行同事无有缺减。于正念正知无有缺减。于念处正勤神足根力觉支圣道无有缺减。乃至于奢摩他毗钵舍那无有缺减。舍业烦恼自性无知。修检其身无令纵逸。常勤佛事成熟有情。咸得清凉安住寂静。善男子。是名菩萨修禅波罗蜜多行清净。如是乃至智慧波罗蜜多当如是知

    增长胜力品第十六

论曰。此明三种增长胜力。谓于所行行常无厌足。所度众生不生懈退。求佛妙智坚固勇猛。是三种力非诸声闻所能行故。如宝云经说。以诸众生自性怯弱。唯除菩萨显现增长。又如来秘密经说。时阿阇世王复白佛言。世尊。菩萨具修几法即能获得如是胜力。佛言。大王菩萨若修十法获斯胜利。何等为十。一者菩萨宁舍身命终不弃舍无上正法。二者于一切众生作谦下想不增慢心。三者于彼劣弱众生起愍念心不生损害。四者见饥渴众生施妙饮食。五者见怖畏众生施其无畏。六者见疾病众生施药救疗。七者见贫乏众生惠令满足。八者见佛塔庙形像图拭圆净。九者出欢喜言安慰众生。十者见彼负重疲困苦恼众生为除重担。菩萨若具如是十法。即能获得如是最胜之力。又海意经说。菩萨若能发起精进。常所坚固勤行乐欲。所起精进无有休息。而诸菩萨即于阿耨多罗三藐三菩提不为难得。何以故。海意。由精进故乃得菩提。若懈怠者于佛菩提远中复远。无懈怠者能行布施。乃至无懈怠者能集智慧。如月灯经云。犹如水中生优钵罗花。应知次第而得增长。当渐修学布施等行。如能断金刚经云。若菩萨善住布施。所获福聚不可称量。又如大般若说。复次舍利子。若菩萨摩诃萨乐欲修习般若波罗蜜多。非少布施而得圆满。应当施与一切众生金银珍宝园林舍宅种种所须随其意乐。以一切相智方便善巧。而能回向无量阿僧祇一切众生。当学般若波罗蜜多

论曰。此明大悲空藏自性清净受用福聚速疾增长。若无大悲非菩萨行。建立诸善此为根本。如是深心坚固大悲现前。勇猛修作诸相应行。则能获得尸罗清净。故有颂云

  如人善斗战　　利器心坚勇
  若小有懈退　　则为彼所执

又如善财往诣圣慈善知识所。即自念言。而我此身于过去世。无勇猛心。无坚固意。无清净因。受诸轮转。心乐流荡颠倒分别。自邪思惟乐习欲行。取着世间无利事业。或于自身所获义利。起不平等悉皆弃舍。于现在世起大勇悍。拣择分别真实思惟。于诸菩萨所行正行当勤修作。于诸众生起增上心多所饶益。于诸佛所发大精进作大善利。庄严诸根增长愿力。读诵经典心净信解。摄持身心不生高举。常乐出离生老病死忧恼苦海。而于后际乐行菩萨所行之行。应当往诣一切佛刹。敬受如来之所教诲。亲近供养善说法师。乐求相应诸佛正法。承事供给诸善知识。开示演说一切佛法。菩萨若能如是思惟观察。则能增长愿力智身。度脱众生植众德本。如无尽意经说。菩萨独一无侣勇猛坚固毕竟摄取阿耨多罗三藐三菩提。深心自修不假他作。以精进铠而自庄严。如诸众生所作善业。我亦如是悉当作之。及诸菩萨从初发心所修诸行。我亦当行。施非我伴我是施伴。戒忍精进禅定智慧。非是我伴。我是彼伴。诸波罗蜜不能使我。而我能使诸波罗蜜。一切善根皆亦如是。乃至于金刚坐道场坏诸魔众。一刹那顷以平等相应慧得成阿耨多罗三藐三菩提如金刚幢经说。如日天子出现世间独一无侣。所历境界而无退转。于生盲者不生厌患。于罗睺阿修罗王不生厌患。于乾闼婆城不生厌患。于阎浮提方处秽恶不生厌患。于四天下地界微尘不生厌患。于诸高山烟云等障皆无厌患。菩萨摩诃萨出现世间亦复如是。以无分别智正念了知。若为众生之所损害。不生厌患心无退转。若于菩萨广大善根而生嫉妒。菩萨于彼不生厌患心无退转。若复众生为邪见垢之所染污。菩萨于彼不生厌患心无退转。若见众生常为嗔恚之所缠缚。菩萨于彼亦不远离。若见众生愚痴覆障烦恼垢重。而复破坏菩提种子。一切世间无能救护。菩萨于彼不生轻慢。何以故。菩萨大悲不见众生有过失故。犹如日轮出现世间。皆令明显无有曀障。若复众生愚痴所覆。不信诸佛不闻正法不识僧田。自所造作种种苦因。或堕地狱傍生鬼界。是时菩萨见彼众生造是业已。心不动乱亦不拣择无有惊畏。发坚勇心不生退转。决定代彼受诸苦恼。所以者何。我当荷负彼诸众生。乃至世间生老病死苦恼之难。八无暇难。诸轮回难。诸恶见难。坏善法难。生无智难。我当毕竟令脱是难。是诸众生无明所蔽。爱网所著。有结所缚。诸苦笼絷不生觉了无求出离。常怀疑惑与愿相违。于轮回海一向漂没。我当安住一切智王。令诸众生成就义利皆得解脱。唯我一人能为救护。假使一切世界悉为恶趣。受苦众生充满其中。以我所集一切善根。平等回向无不与者。乃至最后边际所经时分。一一恶趣消灭无余。一一众生皆得解脱。若使一人未离苦者。我当以身质而出之。愿诸众生因我身故得尽苦际获安隐乐。各各乐出真实语言。勿相欺诳不生损害。我当令发一切智心离五欲境行菩萨行。毕竟安住无上正等菩提。所以者何。是诸众生由着欲故摄属魔境。诸佛世尊之所诃毁。当知贪欲众苦之本。以是缘故。或作诤讼。或相斗战。起诸烦恼。后堕地狱饿鬼畜生。乃至断生天业远离诸佛。何由能发无上智王。是诸众生为欲所没。炽然烧煮无量过患。我以善根平等回向。令诸众生皆悉舍离。乐求佛智得涅盘乐。我当为彼作大导师。以方便智令达彼岸。又如日出照四大洲。于诸境界咸令显现。若王宫殿聚落城邑人民往来所作事业。成熟苗稼滋荣草木。是日天子光明威德。独出世间决定无二。如是菩萨从初发心。见诸众生不种善根。即作是念。我当救护一切众生。我当解脱一切众生。我当照明一切众生。我当教诲一切众生。我当入解一切众生。我当摄受一切众生。我当成熟一切众生皆令安隐断诸疑惑。又如日轮出现世间。光明普照不假他求。菩萨摩诃萨亦复如是。出现世间见苦众生。不待他请而方救护。无少善根而不回向。以诸众生而为庄严。又无尽意经云。菩萨不计劫数而求菩提。从生死本至于今日。所经时分不可称量。于若干劫而作庄严。乃至一睹诸佛一发道心。所经诸佛如殑伽沙。承事供养无有懈倦。方能解了一切众生心之所行。是名菩萨无尽庄严。如是修习檀波罗蜜菩提分法。而能具足相好庄严。又宝云经云。菩萨见诸众生盲无慧眼。[怡-台+龍]悷难调破戒懒堕众恶悉具。是时菩萨深起厌离求生净土。愿我不闻诸恶之名。作是念已。复更思惟。是诸众生愚痴喑哑无涅盘分。不生信心远离诸佛。我当调伏而救拔之。发是心时。一切魔宫悉皆震动。十方诸佛同声赞叹。是人不久坐于道场得阿耨多罗三藐三菩提

论曰。如是渐次思惟观察。则能增长无量福聚。应当质直深心坚固修作。如法集经说。于佛法中质直为本。若诸菩萨无质直心。则是远离一切佛法。若是具足深心坚固。于未曾闻深妙之法而生渴仰。或于空中山林树间。自然出于深妙法音而得解了。是故菩萨当如是行。如人有足则能游行。菩萨若具质直深心。而能修行一切佛法。如人有身则有寿命。菩萨若具质直深心。则能获得诸佛菩提。如人有命则有财利。菩萨若具质直深心。而能获得诸佛圣财。譬如大炬其焰炽然。菩萨若具质直深心。于诸佛法则能明了。譬如有云则能降雨。菩萨若具质直深心。则能宣布诸佛法雨。是故菩萨应当了知质直深心善自守护。譬如树根腐败则不能生枝叶花果。菩萨若无质直深心。于诸善法不复生长。亦不能取诸佛菩提

大乘集菩萨学论卷第二十大乘集菩萨学论卷第二十一

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    增长胜力品第十六之余

论曰。云何名为深心觉了。无尽意经云。复次是心于诸所作离欺诈故。离欺诈者。不起谄故。不起谄者。能决定故。能决定者。除诳幻故。除诳幻者。住清净故。住清净者。常正直故。常正直者。无邪曲故。无邪曲者。性明了故。性明了者。善悟解故。善悟解者。得真实故。得真实者。不可坏故。不可坏者。获坚牢故。获坚牢者。得不动故。得不动者。不舍众生。故此说是为深心觉了。是经复说。最上殊胜深心修习。安住寂静慈覆众生。于贤善者恭敬尊重。非贤善者悲心济拔。无捄护者为作捄护。无依归者为作依归。于漂泊者为作洲渚。无主宰者为作主宰。无伴侣者为作伴侣。于邪曲者使令正直。于暴恶者使令柔顺。于谄谀者使令中正。于虚诳者使令诚谛。于奸宄者使令淳质。不知恩者使令知恩。于苦恼者令得安隐。不饶益者为作饶益。于我慢者使令谦下。于毁訾者使令赞美。于错谬者为作教诏。无守护者为作守护。于相违者不见过咎。于诸师尊起清净行。方便善巧等心恭敬。于所教诲忆持不忘

论曰。如是渐次深心修作。则能增长胜力大悲现前。如法集经云。尔时观世音菩萨白佛言。世尊。菩萨修学不须多法。若持一法则能善知一切佛法。是一法者。所谓大悲。若诸菩萨能行大悲。则能摄取一切佛法如在掌中。世尊。如转轮王所有轮宝随其所至皆悉随从。菩萨若起大悲则于诸佛法自然获得亦复如是。世尊。譬如日出光照世间诸有情类所作事业皆得成办。菩萨若以大悲照于一切菩提分法则易修作亦复如是。世尊。譬如诸根以意为本。悉能取于自分境界。菩萨住于大悲则于一切菩提分法各各修作如理而行。世尊。譬如依彼命根有余诸根。菩萨若有大悲则能修诸菩提分法。又无尽意经云。譬如人之命根以出入息而为其本。如是菩萨修学大乘即以大悲而为其本。又如长者唯有一子爱念情重未曾暂舍。菩萨获得大悲于诸众生爱之若子亦复如是

论曰。此云何观。谓以慈修心。于诸众生爱犹己子。过去世时无量苦恼。现生之中病苦大海。未来长时轮回险难。如十地经说。无智愚痴异生之类。有无数身已灭现灭当灭。如是灭已。不能于身而生厌患。转更增长众苦机关。随生死流不能出离。不能弃舍。诸蕴执藏。不能远离大种毒蛇。不能观察六处空聚。不能断除我及我所。不能拔出见慢毒箭。不能息灭贪恚痴火。不能破坏无明黑暗。不能枯涸渴爱巨浪。不求十力大圣导师。入邪稠林随逐魔党。于轮回海一向漂没。无明卵谷厚膜缠裹。老病死苦常所逼切。我今为愍诸有情等而作救护。积集无量福智资粮。以是善根。皆悉令得究竟清净。彼经复说。是诸有情驰骋生死险难恶道地狱傍生琰魔罗界。愚痴暗蔽阙大导师。乃至没于爱河洄澓流转。不暇省灭欲恚害寻。无由弃舍贪欲习气。身见罗刹之所执持。我慢洲渚无所依怙。不能超越六处聚落。无少善根而能济渡。是故我今以大悲力拔彼众生。令脱苦难离垢寂静。当令安住一切智智大宝洲故。是诸有情忧悲苦恼随转连缚。贪爱桎梏之所检系。无明谄诳长时覆翳。于三界狱不求出离。我皆令脱种种怖畏现前苦恼。使无障碍得安隐乐

论曰。如是于他坚固深心。则能增长大悲福行。又最上问经云。昼夜六时着新净衣。礼敬诸佛常生尊重。次第修作成普贤行。又三聚经说。头面接足礼敬诸佛。则能忏除一切罪垢。三聚者。谓忏悔劝请随喜福等。又优波离所问经中但明劝请一种义利。解诸魔网。悟无常故。又等行礼敬一切诸佛。如无尽意经说。自他忏悔所获福行。如普贤行四伽陀中说。随喜福行。如月灯经随喜品说。自余经中具明三种。次明广大供养回向行相。如宝云经云。若诸菩萨以所生花及诸焚香。栴檀香树劫树宝树。乃至无主宰者无执持者昼夜六时运心供养佛菩萨等。又三三昧耶经云。十方世界国土所有地生宝山水生宝山一切妙药诸清净水上妙饮食及诸金宝乃至北俱卢洲林藤地味自然香稻最上爱乐所受用者。长时运心如前供养

论曰。如上所明广大亲近承事供养佛菩萨等。如是闻已。毕竟一心依教而行发愿回向。如普贤行经见金刚幢经或十地经中说。复次菩萨摩诃萨住极喜地。引发十种广大誓愿。所谓承事供养一切如来。而能成就清净胜解。如是行相尽虚空界同等法性。穷未来际一切劫数。所有诸佛出兴于世。作大供养无有休息。是为发起第一大愿

为欲受持一切如来所说法眼善能守护诸佛正教。尽虚空界同等法性。穷未来际一切劫数。摄受正法无有休息。是为发起第二大愿

为于诸佛出现于世。最初安住兜率天宫降神托阴住胎诞生长年出家修行苦行坐菩提场降伏诸魔转正法轮示涅盘相。最先加行往诣供养。于一切处同时而转最上法轮。尽虚空界同等法性。穷未来际一切劫数。所有诸佛出现世间。请转法轮无有休息。是为发起第三大愿

为欲引发广大无量诸菩萨行。及无分别诸波罗蜜圆满清净。所摄诸地总相别相。同相异相。成相坏相。如实无倒。显示教诫诸菩萨行。使令发心。尽虚空界同等法性。穷未来际一切劫数。所行正行无有休息。是为发起第四大愿

为欲成熟诸有情界。有色无色。有想无想。非有想非无想。卵生胎生湿生化生。三界六趣之所系属。名色所摄使令永断。一切趣数皆悉入于诸佛法中。毕竟安住一切智智使无遗余尽虚空界同等法性。穷未来际一切劫数。成熟有情无有休息。是为发起第五大愿

为欲入解十方世界。若广若狭若粗若细。或覆或仰杂乱而住。犹如帝网分位各异。以相应智现前了知。尽虚空界同等法性。穷未来际一切劫数。悉能入解如是世界无有休息。是为发起第六大愿

为欲严净诸佛国土。从一佛刹至一佛刹。皆以光明周遍莹饰。离诸烦恼成清净土。大智有情充满其中。普入诸佛广大境界。随诸有情意乐归向。平等显示皆令欢喜。尽虚空界同等法性。穷未来际一切劫数。及佛刹数普令严净无有休息。是为发起第七大愿

为欲与诸大菩萨众同一意乐积集善根。同一所缘住平等性。常得值遇诸佛菩萨。随其所欲不相舍离。示佛威力等同发心。而复获得不退神通。即能往诣一切世界。于大众中现同类身。乐修菩萨所行正行。悟不思议大乘妙法。尽虚空界同等法性。穷未来际一切劫数。等诸菩萨悟入大乘无有休息。是为发起第八大愿

为欲乘御不退转轮诸菩萨行。身语意业皆不唐捐。若暂见所作于佛法中便得决定。暂闻言音即生净信。能起正智永断烦恼。愿令是身如大药树救诸疾苦。如如意宝济诸贫乏。广利众生修菩萨行。尽虚空界同等法性。穷未来际一切劫数。不虚所行无有休息。是为发起第九大愿

为于十方一切世界当证无上正等菩提。于其所化毛道众生或一或多。皆能显示降生出家成等正觉转大法轮入般涅盘。示佛境界智惠威力。随诸有情之所意乐。于刹那顷普令觉悟。尽众生界真实回向。唯一菩提广大涅盘。咸以一音宣说法要。令诸有情心皆悦豫。以神通力悉能充满一切世界。示大智力则能建立一切诸法。示大涅盘而不泯绝一切诸行。尽虚空界同等法性。穷未来际一切劫数。成三菩提无有休息。是为菩萨引发十种广大誓愿

论曰。如是观想深心精进。于一切处作是回向。如观音解脱经云。以我所作一切善根平等回向。令诸众生离堕落怖。令诸众生脱诸眷属恩爱怖。令诸众生灭愚痴怖。令诸众生断系缚怖。令诸众生离断命怖。令诸众生离贫穷怖。令诸众生离夭寿怖。令诸众生离毁谤怖。令诸众生离轮回怖。令诸众生离大众威德怖。令诸众生离诸死怖。令诸众生离恶趣怖。令诸众生离黑闇怖。令诸众生离冤憎会怖。令诸众生离爱别离怖。令诸众生离憎嫉怖。令诸众生离身心逼恼怖。令诸众生断除忧悲苦恼怖。又此略明回向。如普贤行经中偈云

  清净勇猛文殊尊　　普贤胜得亦如是
  彼二大士说回向　　我当随顺而修学
  十方三世诸如来　　所说回向清净教
  我今积集诸善根　　悉同最上普贤行

    恭敬作礼品第十七

论曰。此明次第礼敬诸佛增长福行。当云何知。如观察世间经偈云

  若一刹那顷　　承事于诸佛
  我说所得报　　永离八无暇
  形色极殊好　　成就相庄严
  安住佛法中　　无复诸懈怠
  是人于现在　　受用皆充足
  常为众所尊　　无病身光洁
  后生长者家　　尊崇无与等
  广兴于惠施　　珍宝无悭吝
  复作转轮王　　统御四天下
  人民咸善顺　　国土皆丰乐
  威德力具足　　七宝皆殊绝
  于一切时中　　而勤修供养
  得生忉利宫　　自在弥卢顶
  为帝释天主　　奉持清净教
  若人于佛塔　　合掌而右旋
  于俱胝劫中　　受福无穷尽
  又复于佛塔　　发心而致礼
  于无量劫中　　离生盲跛躄
  坚固诸善根　　具勇猛精进
  速得成菩提　　斯由礼佛塔
  若于恶世中　　向佛暂归命
  则为已亲近　　百千俱胝佛
  是人于世间　　最胜无过上
  自在人中仙　　端正无伦匹
  若人以花鬘　　奉施于佛塔
  从此人中没　　生三十三天
  乘上妙辇舆　　珍宝而严饰
  宫殿楼阁中　　天女常围绕
  有清净池沼　　八德水盈溢
  底布以金砂　　琉璃玻璃岸
  受上妙快乐　　惠命皆长久
  从此天中没　　得生豪贵家
  于百千亿劫　　受胜福无极
  常以妙花鬘　　处处而供养
  为转轮圣王　　及帝释天主
  大自在天子　　世主大梵王
  由作是施故　　获如上功德
  以上妙细[疊*毛]　　施佛大导师
  是人于世间　　义利皆成就
  又复以衣鬘　　持以施佛塔
  远离下种族　　永不生于彼
  眷属常围绕　　无别离苦恼
  常得大国王　　供养而称赞
  或生天龙中　　及世间智者
  具勇猛威神　　福报无与等
  若国城种族　　于世尊塔庙
  是人以少香　　其微如芥子
  以决定信心　　而兴于供养
  所获之功德　　今当听我说
  永离诸垢秽　　坚固清净心
  除病恼忧悲　　容仪极高爽
  得作转轮王　　具大智威德
  随其所至处　　福力皆成就
  若王若人民　　咸乐常尊奉
  以上妙衣服　　奉施于佛塔
  是人于当生　　身肢极光洁
  哥尸迦天衣　　俱时而显现
  常出适意香　　闻者生欢悦
  又复以金缕　　织成殊胜衣
  巧妙善安布　　师子众形相
  后生于天中　　所愿无不果
  珍宝众缨络　　随念于掌生
  若人以妙幡　　悬施于佛塔
  随彼所意乐　　往生诸佛国
  当获金色身　　众相悉具足
  上馔众甘味　　咸乐持奉献
  又复以缯[疊*毛]　　茸毳诸珍服
  兜罗哥尸迦　　作幢而施佛
  是人于当生　　库藏皆充溢
  离眷属恼害　　坚固无量智
  上下悉端严　　众乐常瞻奉
  不为火所烧　　及刀杖加害
  若持一灯明　　供养于佛塔
  由作是施故　　获寿命长久
  清净心明了　　形色皆圆满
  是人于后身　　生金河净刹
  妙臂出光明　　有大坚固力
  游行于世间　　而无诸恐怖
  假使那由他　　若干诸佛刹
  芥子满其中　　称量可知数
  我说是福报　　穷劫不能尽
  以广大缯盖　　持以施佛塔
  是人不久得　　具三十二相
  常出妙光明　　无比难思议
  其光常晃耀　　莹彻若金河
  犹俱苏摩花　　开敷相间饰
  名称普周遍　　具殊特神通
  受用无有边　　得最上安隐
  常得诸天人　　亲近而承事
  少欲具威仪　　坚持于净戒
  住寂静林中　　乐修诸禅定
  智惠无所减　　不舍菩提心
  知足无希求　　等行于慈行
  若人作音乐　　供养人中尊
  离烦恼忧戚　　获声相圆满
  眼目极明显　　谛视无杂乱
  耳常闻妙声　　清净心如悦
  鼻高修且直　　严相皆具足
  其舌常嫩滑　　红润若珊瑚
  音响如天人　　闻一俱胝量
  离无舌丑报　　永不生蛇中
  最上殊胜身　　端直无跛曲
  常生善净意　　暂无少间断
  诸天人龙神　　摩睺罗迦等
  随所行世间　　安慰而守护
  由作是施故　　获如上福报

大乘集菩萨学论卷第二十一大乘集菩萨学论卷第二十二

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    恭敬作礼品第十七之余

  若人于我灭度后　　而能修治佛塔庙
  百千那由他劫中　　巍巍身相皆严好
  最上适意旃檀香　　合成宫殿及辇舆
  虽获胜报无所著　　斯由修治于佛塔
  于佛正教欲灭时　　不生阎浮诸国上
  随其意乐住天宫　　斯由修治于佛塔
  厌患五欲诸垢染　　安住清凉净戒蕴
  广修梵行靡不周　　斯由涂香于佛塔
  从是灭已生天上　　快乐丰饶不可量
  复能教化诸天人　　斯由涂香于佛塔
  面貌圆满常熙怡　　所发言音生众善
  见者咸兴爱敬心　　斯由涂香于佛塔
  远离无边恶道苦　　常得亲近诸如来
  广修净业利群生　　斯由涂香于佛塔
  若人暂于刹那顷　　能于佛塔拂尘网
  是人之报难可量　　永离八难生无难
  勇猛聪惠悉明了　　于五欲境无追来
  常能出离诸轮回　　斯由净心扫佛塔
  具足禁戒无缺犯　　闻深妙法生忻仰
  永不退转菩提心　　斯由净心扫佛塔
  是人能于恶世中　　常离毁訾诸过失
  积集广大胜福惠　　斯由净心扫佛塔
  获得上味诸珍馔　　殊净衣服所庄严
  常觉妙触适诸根　　斯由净心扫佛塔
  若于佛塔生欢喜　　而能除去诸萎华
  由依十力大导师　　得离五欲深怨害
  形仪挺特世希有　　众所乐观无厌舍
  王者常生爱敬心　　由去萎花于佛塔
  具足菩萨诸戒品　　灭除一切险恶道
  意常明了远痴迷　　由去萎花于佛塔
  弃背烦恼诸障染　　永无病苦相缠缚
  于一切处获轻安　　由去萎花于佛塔
  得受人中第一施　　复以最上诸供养
  清净福惠庄严身　　由去萎花于佛塔
  又复持以新妙花　　或曼陀罗钵吒罗
  而于佛塔换萎者　　斯人当获殊胜报
  若人能于诸佛塔　　精勤合掌伸礼敬
  彼于佛德善称扬　　令其见者皆稽首
  诸天龙神摩睺罗　　王及臣民生信重
  譬如妙花开世间　　而能善说诸法要
  由彼善说正法故　　安住佛智无缺减
  令众生离恶趣中　　增长人天胜义利
  福力念惠皆具足　　眷属广多常善顺
  我说是人于世间　　随其意乐心安隐
  常发柔和寂静音　　教谕群生使出离
  于其富乐不生贪　　斯由合掌礼佛塔
  能行布施及爱语　　利行平等亦复然
  为他毁訾不生嗔　　斯由合掌礼佛塔
  或往天中为帝释　　或在世间作人王
  所至自在悉随心　　斯由合掌礼佛塔
  于诸欲境无耽染　　处世豪贵常止足
  永不堕于恶趣中　　斯由合掌礼佛塔
  所发言辞丰义味　　悉与经典善相应
  常生人世上族中　　斯由合掌礼佛塔
  若以最上清净心　　盈掬持花散佛上
  所获之报得为王　　安住如前兴善利
  彼于五欲能觉了　　则无忧恼所逼迫
  身相端严众乐观　　自性寂静亡诸怖

又如大悲经云。阿难。若有众生能于现在供养我者。若我灭后供养舍利芥子许者。复能为我造立形像及塔庙者。阿难。且置是事。设使有人暂能发起一净信心缘念诸佛。持以一华散于空中而用供养。是人当得转轮圣王帝释天主大梵天王。即能超越前际无知。及未来劫生死流转。阿难。复置是事。假使有人而于梦中能以一花散空供养。我说是人以此善根所得福报不知其边。又娑伽罗龙王所问经云。若菩萨亲近诸佛。则能获得八种增上之法。何等为八。一者教化众生睹佛妙相。二者于如来所承事供养。三者于众会中赞佛胜德。四者想念如来造立形像。五者劝化众生常不离佛。六者随所至处常闻佛名。七者常愿往生诸佛国土。八者志不怯弱乐求佛智。是为八种增上之法

论曰。复何增长殊胜义利。谓于佛所起承事故。当得菩提。如华严经偈云

  无量亿千劫　　佛名难可闻
  况复得亲近　　永断诸疑惑
  如来世间明　　通达一切法
  普生三世福　　令众悉清净
  如来出世间　　为世大福田
  普导诸含识　　令其集福行
  若有供养佛　　永除恶道畏
  消灭一切苦　　成就智惠身
  若见两足尊　　能发广大心
  是人常值佛　　增长智惠力

是经复说

  如来大慈悲　　出现于世间
  普为诸群生　　转无上法轮
  如来无数劫　　勤苦为众生
  云何诸世间　　能报大师恩
  宁于无量劫　　受诸恶道苦
  终不舍如来　　而求于出离
  宁在诸恶趣　　常得闻佛名
  不愿生善道　　暂时不闻佛
  何故愿久住　　一切恶道中
  以得见如来　　增长智惠力
  若得见于佛　　减除一切苦
  能入诸如来　　大智之境界
  若得见于佛　　舍离一切障
  长养无尽福　　成就菩提道

论曰。暂见形像尚获斯报。况复亲睹如来色相信受教诲。得福甚多。如信力入印经云。文殊师利。若有善男子善女人能于一切世界微尘数辟支佛所。日日持以百味饮食上妙衣服。于河沙劫而用供养。文殊师利。若复有人暂能瞻奉一画佛像及诸经典。此福胜前无量阿僧祇。何况合掌。持以一花。或以一香。及以涂香。或燃一灯。而以供养。此福胜前无量阿僧祇

论曰。此明方便增长功德。如菩萨藏经云。若能修治故旧佛塔。当获四种清净大愿。一者最上色相无有与等。二者受持经典精进无懈。三者所生之处得见如来。四者于当生身具足诸相。是经复说。若人能于如来塔。所以众名花及诸涂香恭敬供养。而复获得八种无减。一者色相无减。二者受用无减。三者眷属无减。四者戒品无减。五者定力无减。六者多闻无减。七者智惠无减。八者胜愿无减。又如宝积经云。假使众生充满三有。各各造作如来塔庙。其量高广如须弥卢山。于殑伽沙劫。各以种种上妙供养。若菩萨以不舍一切智心。持以一花奉施彼塔。所获福蕴复过于彼。是经复说。假使三千大千世界所有众生。一一皆得转轮圣王安住大乘。一一轮王以大海量而为灯器。等弥卢山而为灯炷。各以如是供养佛塔。若出家菩萨能以少油涂捻为烛。持用供养如来塔庙。所得功德胜前灯施。百分歌罗分乃至乌波尼刹昙分不及其一。又彼转轮圣王能于现前佛比丘众。以诸乐具而用布施。若出家菩萨常行乞食。或有所得随彼见者分以食之。所获功德胜前无比。又彼转轮圣王以袈裟服积如须弥。能于现前佛比丘众。持用布施。若出家菩萨于三衣外所有长物。随应奉施现前诸佛安住大乘诸比丘僧及如来塔。其所得福倍前所施。又彼转轮圣王一一各以满阎浮提诸上妙花供养佛塔。若出家菩萨能以一花施如来塔。胜前供养。百分歌罗分乃至乌波尼刹昙分不及其一

论曰。若广明行相。如次第超越品说。彼出家菩萨如是知已。若能现前供养如来。即获四种贤善功德。一者常得最上恭敬供养。二者彼所见已随顺依学。三者而能坚固大菩提心。四者增长善根现前得见三十二种大丈夫相。又海意菩萨所问经云。复次海意。有三种法。名为供养承事如来。何等为三。一者发菩提心无有退转。二者于诸正法而能摄持。三者于众生所发起大悲。又宝云经说。善男子。菩萨成就十法。处于胎藏垢秽不染。何等为十。一者以净信心造如来像。二者修治诸佛故旧塔庙。三者以众妙香而用涂饰。四者持诸香水灌沐如来。五者于佛塔中扫洒涂地。六者亲能承事所生父母。七者亲能供养和尚阇梨。八者常能供给同梵行者。九者所行惠施不希其报。十者以此善根令诸有情不染胎藏垢秽而生。善男子。若能具足如是十法。则能发起深心随喜。如般若经云。若菩萨摩诃萨安住大乘。应当最初发心随喜。是诸菩萨能行是行。则于大乘得不退转。佛言。憍尸迦。假使有人而能称量三千大千世界。可知其数。此诸菩萨发心随喜所得功德。不可校计。时帝释天主白佛言。世尊。若诸菩萨从初发心乃至得成正等正觉。而于其中所作无量随喜善根。若诸菩萨不闻不知亦不摄取。当知是人为魔所持。佛言。憍尸迦。若善男子善女人欲速证得如来应供正等正觉。应于大乘发心随喜。然于声闻辟支佛乘。亦非爱乐亦非舍离。而能共彼兴随喜心。当知是人在所生处。常值十善则能获得供养恭敬尊重赞叹。于所见色声香味触无不可意。永离恶趣得生天上所以者何。是人所作如其利益。使诸众生皆得快乐。以是善根。能令无量阿僧祇人。发随喜心。当得阿耨多罗三藐三菩提。是经复说。须菩提。假使殑伽沙数三千大千世界一切众生皆发阿耨多罗三藐三菩提心。一一各于殑伽沙劫修四禅定。安住寂静离动乱想。若菩萨摩诃萨修习般若波罗蜜多。能以方便善巧。摄取过去未来现在诸佛所修定惠解脱解脱知见。于缘觉乘及声闻乘所有戒定惠解脱解脱知见。如是等种种善根合集称量。以最上最极最胜最妙广大无量无等等心皆悉随喜。复以如是随喜善根。回向阿耨多罗三藐三菩提须菩提。其所得福胜前菩萨修定功德。不可为比。百分歌罗分乃至乌波尼刹昙分不及其一

论曰。此说回向行竟劝请功德。如最上问经云。若能摄受正法。则为已于无量无数诸佛刹土护佛寿命

    念三宝品第十八

论曰。明贤善行次第增福。此非别因而能获得。谓于信等常当修习。如秘密大乘经云。佛言。大王。汝今当知有四种法。若能于此如理行者。则为安住大乘趣向胜道所有善法而无坏失。何等为四。大王。一者谓信能向胜道复何名信。以有信故。而能随顺诸圣种类。所不应作而悉不作。二者尊重能向胜道。以尊重故。于诸圣者所说妙法审谛听受。三者无慢能向胜道。以无慢故。则能于彼一切圣众恭信顶礼。四者精进能向胜道。以精进故。若身若心悉得轻安。所作善法皆得成办

论曰。此说于信常所修习如是。别明信等五根。如无尽意经说。云何五根。所谓信根进根念根定根惠根。云何信根。谓于四法深忍乐欲。一者于生死中。行世正行信于业报。由造业故彼报定有。乃至失命终不作罪。二者信乐菩萨所行正行。不求余乘不随诸见。三者于胜义中。了知无我众生寿者补特伽罗。于空无相无愿诸法深能信解。四者于佛功德力无畏等。生决定信断除疑网。是名信根。云何进根。若法信根所摄是法。勤勇无间。是名进根。云何念根。若法进根所修是法。终不忘失。是名念根。云何定根。若法念根所摄是法。一心不乱。是名定根。云何惠根。若法定根所摄是法。自所观照不从他解。是名惠根。是五根者相续而起。则能圆满一切佛法

论曰。复于信力等法。常当修习。如宝髻经云。善男子。云何菩萨力行清净。谓于诸根无有怯弱。一切恶魔不能动乱。声闻缘觉不能退转。一切烦恼不能破坏。而能坚固安住大乘。夙愿满足心净勇猛。密护身根得胜清净

论曰。如是信等根力常能修习。所修慈行增长功德。如月灯经偈云

  那由他亿佛刹中　　所有种种供佛具
  悉以供养诸如来　　不及慈心一少分

大乘集菩萨学论卷第二十二大乘集菩萨学论卷第二十三

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    念三宝品第十八之二

论曰。由信等故。则能缘念诸佛功德。如护国尊者所问经偈云

  稽首调御真金色　　面如满月净无垢
  功德圣智实难思　　于三有中无与等
  牟尼螺髻绀青色　　高显清净如须弥
  眉间毫相普照明　　乌瑟柅沙无见者
  如来目净若青莲　　譬军那花及珂月
  怜悯观视诸有情　　是故我今稽首礼
  如来舌相类铜色　　修广而能覆面轮
  演甘露法润群生　　是故我今稽首礼
  如来四十齿齐密　　洁白坚利若金刚
  出真实语发光辉　　是故我今稽首礼
  如来色相最殊特　　威光照耀百千刹
  释梵护世及诸天　　所有光明无复睹
  如来双腨逾鹿王　　胸臆广袤如师子
  俯视安行侔象王　　大地山川俱震动
  如来身相极端严　　灿若金光而润泽
  于诸世间无比伦　　众生见者不厌舍
  如来往昔百千劫　　于所爱乐皆能施
  慈悲哀念诸有情　　是故我今稽首礼
  如来志乐修诸度　　戒檀忍进善坚固
  禅定胜惠悉圆明　　是故我今稽首礼
  如来众中师子吼　　勇猛能摧诸异论
  三毒垢秽尽无余　　是故我今稽首礼
  牟尼三业超三有　　譬若芙蕖不着水
  迦陵频伽净妙声　　是故我今稽具礼
  了知世间皆幻化　　如俳优者易形色
  亦如阳焰及梦中　　无我无人无寿者
  法本空寂无有生　　不能悟解随流转
  大慈普导诸群迷　　方便随机宣正法
  观察世间诸苦恼　　贪等众病镇相萦
  如来无上大医王　　各各对治令解脱
  示生老死忧悲苦　　爱别离等诸过患
  牟尼救护于世间　　咸令厌离皆除断
  地狱鬼畜险恶趣　　诸有情辈随轮转
  悯彼无亲无道师　　指示愚迷登正路
  过去诸佛出世间　　自在咸宣深法义
  如是世尊同彼说　　悉使众生证圣道
  佛声深远过梵天　　响润清彻生众善
  乾闼婆与紧那罗　　所出乐声皆不现
  积集清净诸功德　　演说无边真实语
  百千那由他众生　　闻已各发三乘意
  若能供养于如来　　当获胜妙诸快乐
  富贵自在众所钦　　后于世间为帝王
  或作轮王御四洲　　具足七宝皆殊异
  常以十善利众生　　由于如来兴净业
  或为忉利诸天主　　或夜摩王睹史陀
  乃至他化大梵天　　皆因供养如来故
  如是见佛供养已　　及所闻法生信敬
  皆能永断诸苦因　　得证寂静离尘垢
  世尊了知道非道　　而能止恶咸归善
  令诸众生获吉祥　　咸皆安住于圣道
  若人求福供养佛　　常获无尽胜福藏
  于俱胝劫不可量　　乃至当证菩提果
  微妙刹土胜庄严　　如他化天极可爱
  随其愿力住其中　　身口意业常清净
  如是种种妙福报　　皆由供养于如来
  是人虽处于世间　　如受龙宫天上乐
  如来具广大名称　　一切刹土悉闻知
  常于无边大众中　　十方诸佛皆称赞
  永离世间诸热恼　　显示大悲无与等
  最上寂静人中尊　　是故我今稽首礼
  我今获得五神通　　住立虚空伸赞叹
  稽首勇猛大导师　　分别诸法净无垢
  今于天人大集会　　称扬善逝诸功德
  所有广大胜福田　　同与众生成正觉

又如法集经说。复次善男子。诸佛世尊具大福智而为庄严。以大慈悲为所行境。于诸世间为救护者。作大医王善拔毒箭。常住寂静妙三摩地。不着生死及与涅槃。乃至于诸有情犹如父母。以大慈心平等怜愍一切世间无有过者。以相应智为世照明。大智有情之所围绕。一切人民常乐承事。远离自乐息除他苦。住持正法。以法为主。得法自在。以法为食。以法为药。以法为施。一切皆舍。以智拣择常不放逸。于险难处为作桥梁。如王者道平坦无障。乃至清净色身见者无厌。诸佛世尊有如是等无量功德。我当成就彼诸义利。此说名为菩萨念佛。云何念法。菩萨了知诸佛世尊无边功德。皆从法生。从法所化。从法所得。从法增上。从法而有。从法境界。从法依止。从法成就。乃至所有世出世间诸快乐事。亦从法生。从法成就。是故我求诸佛菩提。应尊重法。依法境界。依法所归。依法决定。依法坚固。依法修行。此说是名菩萨念法。复次菩萨于诸众生应当平等而为说法。以法无高下故。我同彼法其心平等。法无面从而为宣说。以法无相党故。我同彼法其心平等。法无时节而为宣说。以法内心领受故。我同彼法其心平等。法非于胜而为宣说。于其劣者不为宣说。以法各能入解故。我同彼法其心平等。法非于净而为宣说。于不净者不为宣说。以法离染污故。我同彼法其心平等。又法非于圣人而为宣说。于凡夫者不为宣说。以法离诸见故。我同彼法其心平等。法非尽说而夜不说。亦非夜说而昼不说。以法常所加持故。我同彼法其心平等。法非调伏亦无违越。以法无所取着故。我同彼法其心平等。法非减失亦非增长。以法如虚空故。我同彼法其心平等。法不厌众生众生能护法。我同彼法其心平等。法非求所归与世作归依。我同彼法其心平等。法无损恼。以法离所害相故。我同彼法其心平等。法无怨嫉。以法离诸结使故。我同彼法其心平等。法非怖轮回。亦不乐涅槃。以法无分别故。我同彼法其心平等。菩萨如是积集正念。是为念法。云何念僧。此中复说。是说法者。是行法者。是思惟法者。是法福田者。是任持法者。是依止法者。是供养法者。是如法所作者。是法境界者。是法行处者。是成就法者。是自性质直者。是自性清净者。是随顺教诲者。是发起大悲者。是能拣择智境界者。是常修习白净法者

论曰。菩萨如是念僧。则能成办一切众生真实功德。如无垢称经偈云

  或示老病死　　成就诸群生
  了知如幻化　　通达无有碍
  或现劫烧尽　　天地皆洞然
  众人有常想　　照令知无常
  无数亿众生　　俱来请菩萨
  一时到其舍　　化令向佛道
  经书禁咒术　　工巧诸伎艺
  尽现行此事　　饶益诸群生
  世间众道法　　悉于中出家
  因以解人惑　　而不堕邪见
  或作日月天　　梵王世界主
  或时作地水　　或复作风火
  劫中有疾疫　　现作诸药草
  若有服之者　　除病消众毒
  劫中有饥馑　　现身作饮食
  先救彼饥渴　　却以法语人
  劫中有刀兵　　为之起慈悲
  化彼诸众生　　令住无诤地
  若有大战阵　　立之以等力
  菩萨现威势　　降伏使和安
  一切国土中　　诸有地狱处
  辄往到于彼　　免济其苦恼
  一切国土中　　畜生相食啖
  皆现生于彼　　为之作利益
  示受于五欲　　亦复现行禅
  令魔心愦乱　　不能得其便
  火中生莲花　　是可谓希有
  在欲而行禅　　希有亦如是
  或现作淫女　　引诸好色者
  先以欲钩牵　　后令入佛智
  或为邑中主　　或作商人导
  国师及大臣　　以祐利众生
  诸有贫穷者　　现作无尽藏
  因以劝导之　　令发菩提心
  我心憍慢者　　为现大力士
  消伏诸贡高　　令住无上道
  其有恐惧众　　居前而安慰
  先以施无畏　　后令发道心
  或现离淫欲　　为五通仙人
  开导诸群生　　令住戒忍慈
  见须供事者　　现为作僮仆
  既悦可其意　　乃发以道心
  随彼之所须　　得入于佛道
  以善方便力　　皆能给足之
  如是道无量　　所行无有涯
  智惠无边际　　度脱无数众
  假令一切佛　　于无数亿劫
  赞叹其功德　　犹尚不能尽

菩萨修习供养功德。如宝光明陀罗尼经偈云

  放大光明鬘庄严　　种种微妙鬘云海
  如是妙鬘普周遍　　广大供养作佛事
  放大光明香庄严　　种种微妙香云海
  如是妙香普周遍　　广大供养作佛事
  放大光明花庄严　　种种微妙花云海
  如是妙花普周遍　　广大供养作佛事
  放大光明璎珞严　　种种璎珞妙云海
  如是璎珞普周遍　　广大供养行佛事
  放大光明现宝幢　　青黄赤白相间饰
  种种珍宝共合成　　而用庄严于佛刹
  摩尼宝网色交映　　悬众缯幡以为盖
  垂珠璎珞演佛音　　庄严而覆如来上
  于一如来伸供养　　掌中涌施诸严具
  无量诸佛亦同然　　自在变现三摩地
  神通智力妙难思　　广能化利诸含识
  最上神变三摩地　　而现百千方便门
  于诸如来供养门　　一切能舍布施门
  杜多功德持戒门　　无尽不动忍辱门
  勤行勇猛精进门　　安住寂静禅定门
  达诸义趣胜惠门　　净修梵行神通门
  行四摄事欢喜门　　积集福智利他门
  四谛缘生解脱门　　修习根力胜道门
  悟声闻乘解脱门　　观缘觉乘清净门
  修最上乘神变门　　或现无常苦恼门
  了知无我寿者门　　作不净观离贪门
  证真常乐三昧门　　如是种种方便门
  平等普共诸众生　　皆能证彼解脱门
  现诸形类应群机　　神通说法难思议
  随顺成熟诸有情　　各生爱敬咸安乐
  常思出离世间因　　求证清净三摩地
  若逢饥馑众难时　　随其所欲而周给
  广能怜愍诸有情　　离诸忧怖常安隐
  及以上妙诸饮食　　种种衣服诸库藏
  国城所爱悉能捐　　于彼世间兴大施
  或现身相极殊特　　种种庄严具威势
  涂香巧妙众花鬘　　巍巍色相无与等
  如是形色及威仪　　各各见已乐瞻奉
  为其方便演法音　　普使群生发道意
  或现迦陵频伽声　　俱计罗及俱拏声
  紧那罗众妙鼓声　　皆演如来解脱义
  佛出世间所宣说　　八万四千真法藏
  如是分别诸法门　　悉与众生作饶益
  或现苦恼或快乐　　及作义利非义利
  随宜引导令发心　　皆能与彼同修作
  或见障难诸危厄　　种种逼迫难堪忍
  当以勇悍大悲心　　代彼众生而受苦
  若处无有解脱法　　亦无阿兰若出离
  以王福力其兴崇　　令彼皆生于净信
  若离在家贪爱缚　　则为超越世间因
  于诸欲境尽蠲除　　是为世间照明者
  若能具足诸功德　　是名行法大丈夫
  牟尼妙行悉能修　　是人得生极乐土
  寿命长远不可涯　　受胜妙乐消诸惑
  生老病苦不能侵　　于无常中得自在
  显示贪嗔诸过失　　炽然烧煮无暂停
  如是四相亦复然　　普使群迷令觉悟
  如来十力四无畏　　十八不共诸功德
  我今称赞誓归依　　常于世间作义利
  譬如种种诸幻士　　而能变现众形相
  如来出现于世间　　神通示化亦如是
  能以权巧善方便　　广行饶益诸有情
  清净意乐叵思议　　譬若莲花超浊水
  或现戏论诸言词　　璎珞庄严舞旋转
  种种伎艺众所观　　显诸色相皆如幻
  或为村营聚落主　　或为长者或商贾
  或为辅相及宰臣　　辩论无伦大智者
  或于旷野作大树　　或为无尽珍宝藏
  如意摩尼随所须　　于迷方所为引导
  或现所作诸事业　　种种彩绘及工巧
  经营播植竞希求　　令悟世间非久住
  或现冤亲无憎爱　　咸令安隐获吉祥
  洞明方药济群生　　方便教示牟尼道
  或演最上牟尼法　　普使人天离痴惑
  令诸异道出家人　　发心归向一切智
  如是苦行诸外道　　常持不语乔答摩
  裸形离系号沙门　　各能依奉师尊教
  或有常持舍身行　　执为最胜无过上
  辫发长髻童子戒　　各能依奉师尊教
  或有五热而炙身　　或受狗牛等禁戒
  或有常被鹿皮衣　　各能依奉师尊教
  或有常乐天中智　　无善无恶及无因
  唯餐根果及清泉　　各能依奉师尊教
  或有蹲坐或翘足　　或卧荆棘或涂灰
  执杖令心不异缘　　各能依奉师尊教
  乃至一一诸外道　　彼能猛利修苦行
  化令永断诸苦因　　悉使深心求解脱
  如是世间诸异见　　皆由依止于师尊
  我今为接彼邪徒　　开示如来真实义
  或演大乘微妙句　　或宣秘密真言句
  或现直说显了句　　或乐天中言说句
  或以文字分别句　　决定妙义金刚句
  以智摧诸异论句　　弃背非法言论句
  或示人中明咒句　　或现诸天胜妙句
  诸龙夜叉乾闼婆　　阿苏啰及步多句
  紧那罗与誐噜拏　　摩睺罗等所说句
  各能入解彼言词　　宣畅如来解脱法
  谓由得悟真实义　　于佛法中心决定
  语言智境妙难思　　此为最上三摩地
  谓由获彼三摩地　　而能普放净光明
  其光摄化诸机宜　　令获轻安常寂静
  或放光明名善见　　众生蒙光而起信
  悉能观察众善因　　具足不空无上智
  由是光明普照已　　获睹无边佛法僧
  如来塔庙众灵踪　　一一称扬伸供养
  又放光明名胜灯　　其光晃耀无能比
  为欲严净于世间　　能破微尘诸黑暗
  彼光照瞩众生已　　各各持灯而奉献
  如来供养不思议　　复以众灯而用施
  或以酥灯及油灯　　或以松脂及竹苇
  乃至众香妙宝灯　　施已愿授然灯记
  又放光明名钩召　　悉能警集诸有情
  由斯教诲彼群迷　　解脱轮回爱有海
  如是慈光普照已　　各使众生得开悟
  当令永离四瀑流　　现除忧恼常安乐

大乘集菩萨学论卷第二十三大乘集菩萨学论卷第二十四

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

    念三宝品第十八之三

  诸有道路河流处　　能建桥梁及舡筏
  普为利乐诸众生　　称赞寂静令忻悟
  放大光名除渴爱　　此光能觉诸含识
  令其舍离于五欲　　专求解脱深妙法
  若能舍离于五欲　　专求解脱深妙法
  则能以佛甘露雨　　普灭世间诸渴爱
  惠施池井及泉流　　勤求无上菩提道
  毁呰五欲赞禅定　　是故光名除渴爱
  放大光明名作变　　此光能觉诸众生
  见者令慕佛菩提　　发心愿证无师智
  造立如来大悲像　　众相庄严处莲座
  常叹最胜佛功德　　是故此光名作爱
  放大光明名忻乐　　此光能觉诸众生
  令其心乐于诸佛　　及以乐法乐众僧
  若常心乐于诸佛　　及以乐法乐众僧
  则在如来圣会中　　逮成无生深法忍
  开悟众生无有量　　普使念佛法僧宝
  及示发心功德行　　是故此光名忻乐
  放大光明名福聚　　此光能觉诸众生
  令其修习种种施　　以此愿求无上道
  设大施会无遮限　　诸来乞者皆满足
  不令其心有所乏　　是故此光名福聚
  放大光明名具智　　此光能觉诸众生
  于一法门了多法　　于多法门刹那解
  为诸众生分别说　　决定了知真实义
  善能广说无损减　　是故此光名具智
  放大光明名惠灯　　此光能觉诸众生
  令知众生性空寂　　一切诸法无所有
  法无主宰本来空　　如幻阳焰水中月
  亦如梦境及影像　　是故此光名惠灯
  放大光名法自在　　此光能觉诸众生
  令得无尽陀罗尼　　悉持一切如来藏
  恭敬供养持法者　　给侍守护如诸仙
  以种种法施众生　　是故光名法自在
  放大光明名具舍　　此光觉悟悭众生
  令知财富悉无常　　乐行惠施而无吝
  善能调伏彼悭者　　了财如梦如浮云
  增长惠施清净心　　是故此光名具舍
  放大光明名除热　　此光能觉毁禁者
  普令安住清净戒　　发心愿证无师智
  劝励众生咸奉持　　十善业道常清净
  复令发趣菩提心　　是故此光名除热
  放大光明名忍严　　此光觉语多嗔者
  令除忿恚及我慢　　乐修忍辱常柔和
  众生暴恶难行忍　　为菩提故心不动
  称扬最上忍功德　　是故此光名忍严
  放大光明名勤勇　　此光觉悟懒惰者
  令彼常于三宝中　　恭敬供养无疲厌
  若彼常于三宝中　　恭敬供养无疲厌
  则能超出四魔境　　速成无上佛菩提
  劝诸众生发精进　　常于三宝伸供养
  法欲灭时专护持　　是故此光名勤勇
  放大光明名寂静　　此光能觉乱意者
  令其远离贪恚痴　　心不动摇栖正定
  舍离一切恶知识　　无义谈说杂染行
  赞叹禅定阿兰若　　是故此光名寂静
  放大光明名惠严　　此光觉悟愚迷者
  令其证谛解缘起　　诸根智惠悉通达
  若能证谛解缘起　　诸根智惠悉通达
  则得日灯三摩地　　智惠光明成佛果
  国财及已皆能舍　　为菩提故求正法
  闻已为众广开演　　是故此光名惠严
  放大光明名佛惠　　此光觉悟诸含识
  令见无量百千佛　　各各坐宝莲花上
  赞佛威德及解脱　　说佛自在诸神通
  显示佛力妙难思　　是故此光名佛惠
  放大光明名无畏　　此光照触除诸怖
  非人捶打所执缚　　一切灾难皆令灭
  于诸众生施无畏　　遇有恼害皆能止
  拯济厄难孤穷者　　是故此光名无畏
  放大光明名安隐　　此光能照疾病者
  令除一切诸苦痛　　悉得胜定三昧乐
  施以良药救众患　　妙宝延命香涂体
  掌中涌现诸饮食　　是故此光名安隐
  放大光明名见佛　　此光觉悟将殁者
  随其忆念见如来　　命终得生其净国
  见有临终劝念佛　　又示尊像令瞻敬
  俾于佛所深归仰　　是故此光名见佛
  放大光明名乐法　　此光能觉诸群生
  令于正法常欣乐　　听闻读诵及书写
  法欲尽时能演说　　令求法者意充满
  于法爱乐勤修习　　是故此光名乐法
  放大光明名妙音　　此光开悟诸菩萨
  能令三界所有声　　闻者皆是如来音
  以大音声称赞佛　　及施铃铎诸音乐
  普使世间闻佛音　　是故此光名妙音
  放大光明名甘露　　此光开悟诸众生
  令舍一切放逸行　　具足修习诸功德
  谓有为法非安隐　　无量苦恼悉充遍
  常乐称扬寂灭乐　　是故此光名甘露
  放大光明名最胜　　此光开悟诸众生
  令于佛所普听闻　　戒定智惠增上法
  常乐称赞大牟尼　　胜戒胜定及胜惠
  如是为求无上道　　是故此光名最胜
  放大光明名宝严　　此光能觉诸群生
  令得宝藏无穷尽　　以此供养诸如来
  以诸种种上妙宝　　奉施于佛及佛塔
  亦以惠施诸贫乏　　是故得成此光明
  放大光明名香严　　此光能觉诸众生
  令其闻者悦可意　　决定当成佛功德
  人天妙香以涂饰　　供养一切最胜主
  亦以造塔及佛像　　是故得成此光明
  放大光名妙庄严　　宝幢幡盖无央数
  焚香散华奏众乐　　城邑内外皆充满
  由以微妙伎乐音　　众香妙华幢盖等
  种种庄严供养佛　　是故得成此光明
  放大光明名严净　　令地平坦犹如掌
  庄严佛塔及其处　　是故得成此光明
  放大光明名大云　　而能密布雨香水
  由以香水洒佛塔　　是故得成此光明
  放大光明名严具　　令裸形者得上服
  严身妙物而为施　　是故得成此光明
  放大光明名上味　　能令饥者获美食
  以众珍馔而为施　　是故得成此光明
  放大光明名胜财　　令贫乏者获宝藏
  以无尽物施三宝　　是故得成此光明
  放大光明名净眼　　能令盲者见众色
  以灯施佛及佛塔　　是故得成此光明
  放大光明名净耳　　能令聋者悉善听
  作乐施佛及佛塔　　是故得成此光明
  放大光明名净鼻　　昔未闻香皆得闻
  以香施佛及佛塔　　是故得成此光明
  放大光明名净舌　　能除粗恶不善语
  由以美音称赞佛　　是故得成此光明
  放大光明名净身　　令根缺者皆具足
  以身礼佛及佛塔　　是故得成此光明
  放大光明名净意　　令失心者得正念
  由修三昧自在力　　是故得成此光明
  放大光明名净色　　难思妙相咸令睹
  妙华供佛及佛塔　　是故得成此光明
  放大光明名净声　　观声缘起如谷响
  了知声性本来空　　是故得成此光明
  放大光明名净香　　令诸臭秽悉香洁
  香水浴佛及佛塔　　是故得成此光明
  放大光明名净味　　能除一切味中毒
  常供佛僧及父母　　是故得成此光明
  放大光明名净触　　能令硬触皆柔软
  戈鋋剑戟从空雨　　皆令变作妙花鬘
  以昔曾于道路中　　涂香散花布衣服
  迎奉如来蹈其上　　是故得成此光明
  放大光明名净法　　能令身诸毛孔中
  悉演难思妙法门　　听者咸欣蒙解脱
  自性无生从缘起　　法性常住等虚空
  了知佛身即法身　　是故得成此光明
  如是等比光明门　　如微尘数无有量
  悉从大仙毛孔出　　所作事业各差别
  如一毛孔所放光　　由若虚空微尘数
  一切毛孔悉亦然　　此是大仙三昧力
  如彼所修诸功德　　随其宿缘同梵行
  今放光明故如是　　此是大仙智自在
  往昔同修胜福业　　能生爱乐皆随喜
  于今所作亦复然　　是故得成此光明
  若有自修众福业　　数数供养于诸佛
  复于佛德常勤求　　由此光明所开觉
  譬如生盲不见日　　非谓无日出世间
  诸有目者悉了知　　各随所务而修作
  大士光明亦如是　　有智惠者皆悉见
  凡夫邪信劣解人　　于此光明莫能睹
  摩尼宫殿及辇舆　　妙宝灵香以涂莹
  具有胜福咸自然　　非无德者能安处
  大士光明亦如是　　有深智者咸蒙照
  邪信劣解凡愚入　　无有能得斯光瞩
  若有闻此光差别　　能生清净深信解
  永断一切诸疑网　　速成无上功德幢
  复现最上三摩地　　眷属庄严皆自在
  十方一切国土中　　佛子众会皆围绕
  有妙莲华光庄严　　量等三千大千界
  其身端坐悉充满　　现此三昧神通力
  复有十刹微尘数　　妙宝莲华所严饰
  诸佛子等住其中　　是此三昧威神力
  宿世成就善因缘　　具足修行佛功德
  如是众会所围绕　　悉共合掌观无厌
  童子身中入三昧　　于盛年身从定起
  盛年身中入三昧　　于老年身从定起
  老年身中入三昧　　近事女身从定起
  近事女身入三昧　　近事男身从定起
  近事男身入三昧　　比丘尼身从定起
  比丘尼身入三昧　　于比丘身从定起
  比丘身中入三昧　　学无学身从定起
  学无学身入三昧　　于缘觉身从定起
  缘觉身中入三昧　　现如来身从定起
  如来身中入三昧　　于诸天身从定起
  诸天身中入三昧　　于大龙身从定起
  大龙身中入三昧　　于夜叉身从定起
  夜叉身中入三昧　　于部多身从定起
  部多身中入三昧　　一毛孔中从定起
  一毛孔中入三昧　　一切毛孔从定起
  一切毛孔入三昧　　一毛端头从定起
  一毛端头入三昧　　一切发端从定起
  一切发端入三昧　　一微尘中从定起
  一微尘中入三昧　　于一切尘从定起
  一切尘中入三昧　　于金刚际从定起
  金刚际中入三昧　　于摩尼宝从定起
  若摩尼宝入三昧　　佛光明中从定起
  若佛光中入三昧　　于水大中从定起
  若水大中入三昧　　于火大中从定起
  若火大中入三昧　　于风大中从定起
  若风大中入三昧　　于地大中从定起
  若地大中入三昧　　于天宫殿从定起
  若天宫殿入三昧　　于空起定心不乱
  是名不思议解脱　　自在功德三摩地
  十方所有诸如来　　于无量劫说不尽
  一切如来共宣说　　众生业报龙变化
  诸佛自在大神通　　及入定力不思议
  声闻心住八解脱　　能以一身现多身
  复以多身为一身　　于虚空中入火定
  彼不具足大慈悲　　不为众生求佛道
  尚能现此难思议　　何况广大饶益者
  譬如日月游虚空　　其光普遍十方处
  泉池陂泽器中水　　众宝河海靡不现
  菩萨色像亦复然　　十方普现不思议
  此皆三昧自在力　　唯有如来能现证
  海中有神名善音　　其音普顺海众生
  所有语言皆辩了　　令彼一切悉欢悦
  彼神具有贪恚痴　　犹能善解诸言说
  况复总持自在力　　而不能令众欢喜
  譬如幻师善幻法　　能现无边巧事业
  须臾示作日月岁　　城邑丰饶大安乐
  幻师具有贪恚痴　　犹能幻力悦世间
  况复解脱诸禅定　　而不能令众欢喜
  罗睺阿修罗变现　　蹈金刚际海中立
  海水虽深没半身　　首与须弥正齐等
  彼有贪欲嗔恚痴　　尚能现此大神变
  况复降魔照世灯　　而无自在威神力
  天与修罗斗战时　　帝释神力得自在
  随其军众之数量　　现身与等彼无敌
  诸阿修罗作是念　　释提桓因来向我
  必取我身五种缚　　由是彼众悉忧怖
  帝释现身有千眼　　手执金刚出火焰
  被甲持杖具威严　　修罗遥见咸退伏
  彼由微小福力故　　犹能摧破大怨敌
  何况救度一切者　　岂于功德不自在
  如风兴云降大雨　　亦能息灭诸云气
  亦能成熟诸苗稼　　亦能安乐诸群生
  彼不能学波罗蜜　　亦不学佛诸功德
  犹成不可思议事　　何况具足诸愿者

论曰。菩萨诸有所作。皆为利乐诸众生故。自余别明增长福因。如宝云经偈云

  若诸菩萨　　严持香花　　奉献如来
  及佛塔庙　　以此回向　　愿诸众生
  离破戒垢　　得佛戒香　　若诸菩萨
  以净香水　　扫洒涂地　　以此回向
  愿诸众生　　离恶威仪　　修善法式
  整肃圆满　　若诸菩萨　　严持花盖
  而以奉献　　以此回向　　愿诸众生
  离烦恼热　　若入伽蓝　　发如是心
  令诸众生　　入涅盘城　　出伽蓝时
  发如是心　　愿令众生　　越生死狱
  若开户牖　　发如是心　　愿令众生
  开圣智门　　若闭户牖　　发如是心
  愿令众生　　闭恶趣门　　若安坐时
  发如是心　　愿令众生　　坐菩提场
  右胁卧时　　发如是心　　愿令众生
  安住涅盘　　从卧起时　　发如是心
  愿令众生　　离缠盖障　　若往便利
  发如是心　　愿令众生　　趣大觉路
  正便利时　　发如是心　　愿令众生
  拔三毒箭　　若洗净时　　发如是心
  愿令众生　　洗烦恼垢　　若洗手时
  发如是心　　愿令众生　　离秽浊业
  若洗足时　　发如是心　　愿令众生
  离障尘坌　　嚼齿木时　　发如是心
  愿令众生　　舍诸垢染　　又彼菩萨
  若身所作　　一切善业　　持以回向
  利益安乐　　一切众生　　若礼如来
  及佛塔庙　　发如是心　　愿令众生
  常得人天　　之所礼敬

大乘集菩萨学论卷第二十四大乘集菩萨学论卷第二十五

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

    念三宝品第十八之四

论曰。谓诸菩萨或以因缘遇诸难事。正念对治不生惊怖。如般若经说。复次舍利子。若菩萨摩诃萨设于恶兽难中。不生惊恼亦无怖畏。何以故是菩萨即作是念。我当利益诸众生故一切皆舍。若诸恶兽欲啖我者。我当施与速得圆满施波罗蜜。愿我当成阿耨多罗三藐三菩提时。国土清净不闻诸恶虫兽之名。复次舍利子。若菩萨摩诃萨于怨贼难中不生惊恼亦无怖畏。何以故。是菩萨若己所有皆悉能捐。即作是念。若诸怨贼来欲所须。我当与之。乃至劫取断我命根。身语意业亦无嗔恨。速得圆满戒波罗蜜。及得具足忍波罗蜜。愿我当成阿耨多罗三藐三菩提时。国土清净不闻如是怨贼之名。复次舍利子。若菩萨摩诃萨于渴乏难中。亦无怖畏。何以故。是菩萨得法利益而无忧恼。即作是念。我今当为一切众生宣说法要断除渴爱。设我此身为渴所逼趣命终者。复于后世起大悲心。嗟此众生薄福德故。还复生此无水难中。令修正行具足胜惠。而能圆满精进波罗蜜多。愿我当得阿耨多罗三藐三菩提时。国土清净不闻如是渴乏之名。其中众生具足福德。自然而有八功德水。复次舍利子。若菩萨摩诃萨于饥馑难中。不生惊怖。何以故。是菩萨被精进铠坚固无懈。作如是念。今此众生受饥馑苦深可怜愍。愿我当成阿耨多罗三藐三菩提。国土无有饥馑之名。所化众生适悦安隐。如忉利天自然快乐。一切所欲随心即现。寿命坚固安住寂静

论曰。如是所作。则能增长广大福因最上境界。亦同清净经中所说。若以法施不生希望所获胜报。见深心教戒经。若人不希名闻财利。能以法施获二十种慈心功德。一者安住正念。二者能生觉悟三者发趣胜道。四者任持诸善。五者增长惠命。六者达出世智。七者除贪过失。八者除嗔过失。九者除痴过失。十者魔不得便。十一者诸佛加持。十二者诸天守护容色光泽。十三者非人恶友不得其便。十四者善友知识常所爱敬。十五者所言真实。十六者得无所畏。十七者意常悦豫。十八者善名流布。十九者明记无忘。二十者常乐法施此说是名慈心功德。又般若经云。复次阿难。若声闻人。以声闻法普为三千大千世界一切众生如其所证而为演说。悉令获得阿罗汉果。阿难。若菩萨摩诃萨。能以般若波罗蜜多相应句义。为一众生开示演说过前三千大千世界一切众生证阿罗汉所得功德。又复于彼诸阿罗汉积集布施持戒功德。于意云何。是为多不阿难白言。甚多世尊。甚多善逝。佛言。阿难。彼福虽多不如菩萨以此般若波罗蜜多相应法门为他演说其福胜彼。又菩萨摩诃萨于此般若波罗蜜多甚深法门。能一日中为人分别。如是乃至一时一刻一须臾顷善宣说者。阿难。彼菩萨如是法施。不可以声闻缘觉所有善根而相比喻。何以故。是菩萨摩诃萨于阿耨多罗三藐三菩提得不退转故。又以法施。如妙法莲华经偈云

  菩萨有时　　入于静室　　以正忆念
  随义观法　　菩萨常乐　　安隐说法
  于清净地　　而施床座　　以油涂身
  澡浴尘秽　　着新净衣　　内外俱净
  安处法座　　随问为说　　若有比丘
  及比丘尼　　除懒堕意　　及懈怠想
  离诸忧恼　　慈心说法　　昼夜常说
  无上道教　　以诸因缘　　无量譬喻
  开示众生　　咸令欢喜　　衣服卧具
  饮食医药　　而于其中　　无所希望
  但一心念　　说法因缘　　愿成佛道
  令众亦尔　　是则大利　　安乐供养

是经复说。以顺法故不多不少。乃至深爱法者亦不为多说。又月灯经偈云

  若耆宿请问　　欲求于法施
  应先谓彼言　　我学习不广
  又复作是说　　尊者甚聪惠
  岂于大德前　　而能辄宣说
  说时勿仓卒　　当择器非器
  既审其机已　　不请亦为说
  若于大众中　　见诸毁禁者
  勿复叹持戒　　当叹施等行
  若见少欲者　　与持戒相应
  起于大悲心　　赞少欲持戒
  得彼胜俦侣　　便可赞持戒

论曰。如是法师。应当澡浴着新净衣。以慈修身为众演说。一切魔罗不得其便。见海意经陀罗尼

怛[寧*也](切身)他(引一)设弥(引二)设摩嚩底(三)设弥多设咄噜(二合四)盎酤哩(引五)摩(引)啰[口*爾]底(六)葛啰(引)腻(引七)枳(引)踰哩(引八)乌朅嚩底(九)乌呼(引)葛野底(十)尾输(引)驮儞(十一)儞哩摩(二合)梨(引十二)摩罗(引)钵那曳(引十三)乌渴哩(引十四)渴噜(引)誐啰(二合)细(引十五)钵啰(二合)萨儞(引十六)系(引)目契(引十七)阿(引)目契(引十八)设曳多(引)儞萨哩嚩(二合)怛啰(二合)誐啰(二合)贺满驮那(引)儞(十九)屹哩(二合)系(引)多萨哩嚩(二合)波啰钵啰(二合)嚩(引)祢那(二十)尾目讫多(二合引)摩(引)啰播(引)舍(二十一)塞他(二合引)必多(引)没驮母捺啰(二合引二十二)三母捺伽(二合引)底多萨哩嚩(二合)摩啰(二十三)阿都[黍-禾+利]多钵捺钵哩戍[亭*夜](切身引二十四)尾誐蹉底萨哩嚩(二合)摩(引)啰葛哩摩(二合引)尼(二十五)

彼说法师。以此真言作持诵已。处于法座。普观众会广运慈心。当于己身起医王想如法药想。于听法者起病人想。于诸如来起正士想。于正法眼起久住想。由此真言现前施作于正理法如应为说。是时周匝百由旬内。诸魔天众悉不能来作诸魔事。设诸魔王至法会所。亦复不能作诸障难

论曰。如是平等法施。则能增长大菩提心。如宝箧经云。文殊师利。譬如林木枝叶繁茂。皆因四大而得生长。文殊师利。如是菩萨以种种门集诸善根。一切皆摄在菩提心。于一切智回向菩提以为增长

论曰。若诸菩萨为欲广大显示修学佛之境界。最初安住正念正知。如是则能成就正断及不放逸谓由发起精进乐欲。而于未生恶不善法防护不起。于其已生恶不善法。则能永断使令清净。未生善法令其发起。已生善法更复增长。于不放逸而常安住。诸善法中此为根本。如月灯经偈云

  如我所说诸善法　　谓戒闻舍及忍辱
  以不放逸为根本　　是名善逝最胜财

云何名放逸。谓于邪教及恶朋友。虚妄推求而得生起。如人执持王所饮药。盛满器中行险滑路。当知是人恐怖忧恼。何有放逸。又如来秘密经说。云何不放逸谓能最初调摄诸根。眼见色等不取于相不着于好。如是乃至意法亦然。了知是已皆不取着不生染爱常求出离。又于自心善调伏已。亦能随应摄护他心。善能息彼烦恼染爱。此名不放逸。若人信解不放逸法。则能随顺诸精进事。亦复积集净信功德。由修净信及不放逸精进法故。则能修作正念正知。以正念正知故。则于一切菩提分法而不坏失。若具净信不放逸精进正念正知者。则能勤修深固之法。菩萨若于深固法中善了知者。则能于有于无如实觉了。乃至于世俗谛中说眼等为有。彼经偈云

  常不放逸甘露法　　利众生发菩提心
  深固寂静心亦然　　诸乐根本无所取

论曰。若能积集诸相应行。则于自他增长胜福。而说颂曰

  学自他平等　　坚固菩提心
  对自成于他　　展转无有实
  亦犹立彼岸　　由此而对待
  彼既本来无　　我性何所有
  若苦不防护　　则为苦所著
  如是行法者　　云何而不护
  起邪妄分别　　执我以为常
  若我本如然　　何现有生灭
  彼若别有生　　为谁修福业
  营求于财利　　及受诸快乐
  现见身衰老　　不久而殒灭
  复生为婴儿　　童子及年少
  于刹那时分　　速朽而变坏
  何处名为身　　爪发皆离散
  初识托母胎　　生已为孩孺
  盛年衰老相　　最后为灰烬
  此明身自性　　分位假安布
  毕竟无一尘　　形相那久住
  又复此身者　　不说当自知
  为异相所迁　　思惟我何有
  由分位和合　　世俗而显现
  于佛正理中　　随相应所断
  彼若无有识　　则不能建立
  亦无贪恚痴　　云何有功德
  余九种世间　　各各有三种
  无识与衣等　　何能生彼乐
  衣不能生乐　　当知从因生
  若乐生于衣　　彼相何曾有
  是故正教理　　说诸行无常
  现证及思惟　　由因缘和合
  见自己眷属　　云何说有常
  于方所推求　　无一微尘许
  如燃灯油尽　　彼油知何往
  如是观察已　　刹那不可住
  聚集诸眷属　　严饰而行列
  妄计为我有　　于乐他可知
  了知彼众生　　无一可积集
  自他既有殊　　于苦亦无得
  如是不相应　　彼我何处有
  或如自力能　　数数而开示
  世间诸众生　　多苦常逼切
  当起大悲心　　为怜愍于彼
  善作是观察　　平等而救度
  假使入阿鼻　　如鹅泛莲沼
  为令诸有情　　常处欢喜海
  自不乐解脱　　救彼常无厌
  作是利益已　　而不生恃赖
  亦无有疲劳　　不希于果报
  若十方福聚　　彼我定获得
  不生嫉妒心　　他乐同己想
  又复若自他　　同修于忏悔
  劝请佛世尊　　及随喜福业
  作如是回向　　平等无差别
  随其福所施　　无尽众生界
  菩萨行是行　　则多所饶益
  增长大悲心　　获最上安隐
  得彼金刚手　　及诸佛世尊
  常作于护持　　群魔咸惊悸
  是法王之子　　诸天咸赞扬
  住菩提心车　　善游履胜道
  众生善修习　　息除自他苦
  故我无所著　　一切皆当舍
  若人为爱缚　　则苦无穷极
  烦恼由之生　　损坏徒后悔
  若火烧众生　　炽然皆普遍
  下至爪分量　　于己亦无乐
  谓一切我爱　　第一之苦本
  烧然使无余　　为利诸含识
  乐妻子眷属　　毕竟皆弃捐
  思惟因缘生　　于身亦无爱
  诸有具智人　　于彼二皆舍
  了知身与心　　刹那差别起
  谓常无有常　　离垢本无垢
  自得于菩提　　彼亦成正觉
  不思以世法　　而利于众生
  法药及佛像　　如是我当施
  以惠自拣择　　所作事相应
  摄护于己财　　积已而能散
  或自身他身　　若少苦多苦
  如是皆令得　　诸上妙快乐
  众生于欲境　　防护生障恼
  如蛇处窟穴　　毕竟令清净
  犹如净良田　　成熟诸稼穑
  能除饥热恼　　满足其福报
  若人不远离　　名利及五欲
  所说亦无诚　　于彼不须怒
  彼既失自利　　怒之忍何有
  于是不生嗔　　利他而不断
  善行真实忍　　如观麝有香
  己物为他侵　　返遭猎者损
  以方便思惟　　无主宰快乐
  自既非受用　　彼何无教诲
  如是彼佛子　　念念除烦恼
  了诸根境界　　譬若大疮疱
  念彼忿恚者　　饶益而开诱
  自性离调柔　　处苦乐何得
  又彼五大种　　示之以强名
  乃至住有情　　皆成于义利
  若利生无懈　　则不造诸恶
  故我勤修习　　六界无衰恼
  至虚空究竟　　及世间边际
  我住利众生　　令智心成熟
  身为阿阇梨　　善学离诸苦
  不问自力能　　何所非防护
  若自作苦恼　　何因生恐怖
  随自师了知　　我慢诸过失
  住大悲境界　　不贪于果报
  常近事修学　　平等何有我
  见痴狂盲者　　行步多错误
  或堕险道中　　自他常忧恼
  为寻求彼故　　同难而救护
  如是行相应　　则见大功德
  我过失非一　　其深如巨海
  若自他复造　　何由得解脱
  若彼善教诫　　羞耻诸过咎
  常顶受他言　　一切皆当学
  闻彼冤生怖　　慎勿于余说
  彼我心命同　　若喜则无耻
  诸烦恼冤敌　　我独能斗战
  若此于心中　　损坏无安隐
  归命观自在　　大悲无与等
  绀发簇旋螺　　复如鬘垂下
  于十方刹土　　指端流乳海
  救地狱鬼趣　　轮回诸极苦
  复于善众生　　亦寻声救护
  婆雉阿修罗　　得脱彼冤害
  极最胜庄严　　世所未曾睹
  愚智诸有情　　瞻奉咸忻庆
  又复虔信礼　　妙吉祥大士
  所集正法藏　　能利乐世间
  无比大医王　　善消诸毒难
  施乐及寿命　　故我今稽首
  无边苦热恼　　现广大清泉
  令众悦其心　　当除诸渴爱
  十方诸世界　　各现劫罗波
  众生满所求　　普现青莲目
  无量诸菩萨　　称赞身毛耸
  归命文殊尊　　最胜无过上
  一切希有菩萨行　　结集所有诸功德
  自他当获福无穷　　皆作文殊真佛子
  书写此正法　　我所有微善
  为愍有情故　　令增长胜惠
  诸法从缘生　　缘谢法即灭
  我师大沙门　　常作如是说

大乘集菩萨学论卷第二十五


大乘起信论

    No. 1666 [No. 1667]

    大乘起信论序

        扬州僧智恺作

夫起信论者。乃是至极大乘。甚深秘典。开示如理缘起之义。其旨渊弘。寂而无相。其用广大宽廓无边。与凡圣为依。众法之本。以其文深旨远。信者至微。故于如来灭后六百余年。诸道乱兴。魔邪竞扇。于佛正法毁谤不停。时有一高德沙门。名曰马鸣。深契大乘穷尽法性。大悲内融随机应现。愍物长迷故作斯论。盛隆三宝重兴佛日。起信未久回邪入正。使大乘正典复显于时。缘起深理更彰于后代。迷群异见者。舍执而归依。闇类偏情之党。弃着而臻凑。自昔已来。久蕴西域。无传东夏者。良以宣译有时。故前梁武皇帝。遣聘中天竺摩伽陀国取经。并诸法师。遇值三藏拘兰难陀。译名真谛。其人少小博采。备览诸经。然于大乘偏洞深远。时彼国王应即移遣。法师苦辞不免。便就泛舟。与瞿昙及多侍从。并送苏合佛像来朝。而至未旬便值侯景侵扰。法师秀采拥流。含珠未吐。慧日暂停。而欲还反。遂嘱值京邑英贤慧显智韶智恺昙振慧旻。与假黄钺大将军太保萧公勃。以大梁承圣三年。岁次癸酉九月十日。于衡州始兴郡建兴寺。敬请法师敷演大乘。阐扬秘典。示导迷徒。遂翻译斯论一卷。以明论旨。玄文二十卷。大品玄文四卷。十二因缘经两卷。九识义章两卷。传语人天竺国月支首那等。执笔人智恺等。首尾二年方讫。马鸣冲旨。更曜于时。邪见之流伏从正化。余虽慨不见圣。庆遇玄旨。美其幽宗。恋爱无已。不揆无闻。聊由题记。傥遇智者。赐垂改作

大乘起信论一卷

        马鸣菩萨造

        梁西印度三藏法师真谛译

  归命尽十方　　最胜业遍知
  色无碍自在　　救世大悲者
  及彼身体相　　法性真如海
  无量功德藏　　如实修行等
  为欲令众生　　除疑舍耶执
  起大乘正信　　佛种不断故

论曰。有法能起摩诃衍信根。是故应说。说有五分。云何为五。一者因缘分。二者立义分。三者解释分。四者修行信心分。五者劝修利益分

初说因缘分

问曰。有何因缘而造此论

答曰。是因缘有八种。云何为八。一者因缘总相。所谓为令众生离一切苦得究竟乐。非求世间名利恭敬故。二者为欲解释如来根本之义。令诸众生正解不谬故。三者为令善根成熟众生于摩诃衍法堪任不退信故。四者为令善根微少众生。修习信心故。五者为示方便消恶业障善护其心。远离痴慢出邪网故。六者为示修习止观。对治凡夫二乘心过故。七者为示专念方便。生于佛前必定不退信心故。八者为示利益劝修行故。有如是等因缘。所以造论

问曰。修多罗中具有此法何须重说

答曰。修多罗中虽有此法。以众生根行不等受解缘别。所谓如来在世众生利根。能说之人色心业胜。圆音一演异类等解。则不须论。若如来灭后。或有众生能以自力广闻而取解者。或有众生亦以自力少闻而多解者。或有众生无自心力因于广论而得解者。自有众生复以广论文多为烦。心乐总持少文而摄多义能取解者。如是此论。为欲总摄如来广大深法无边义故。应说此论

已说因缘分

次说立义分

摩诃衍者。总说有二种。云何为二。一者法。二者义。所言法者。谓众生心。是心则摄一切世间法出世间法。依于此心显示摩诃衍义。何以故。是心真如相。即示摩诃衍体故。是心生灭因缘相。能示摩诃衍自体相用故。所言义者。则有三种。云何为三。一者体大。谓一切法真如平等不增减故。二者相大。谓如来藏具足无量性功德故。三者用大。能生一切世间出世间善因果故。一切诸佛本所乘故。一切菩萨皆乘此法到如来地故。已说立义分

次说解释分

解释分有三种。云何为三。一者显示正义。二者对治邪执。三者分别发趣道相。显示正义者。依一心法。有二种门。云何为二。一者心真如门。二者心生灭门。是二种门皆各总摄一切法。此义云何。以是二门不相离故。心真如者。即是一法界大总相法门体。所谓心性不生不灭。一切诸法唯依妄念而有差别。若离妄念则无一切境界之相。是故一切法从本已来。离言说相离名字相离心缘相。毕竟平等无有变异不可破坏。唯是一心故名真如。以一切言说假名无实。但随妄念不可得故。言真如者。亦无有相。谓言说之极因言遣言。此真如体无有可遣。以一切法悉皆真故。亦无可立。以一切法皆同如故。当知一切法不可说不可念故。名为真如

问曰。若如是义者。诸众生等云何随顺而能得入

答曰。若知一切法虽说无有能说可说。虽念亦无能念可念。是名随顺。若离于念名为得入

复次真如者。依言说分别有二种义。云何为二。一者如实空。以能究竟显实故。二者如实不空。以有自体具足无漏性功德故。所言空者。从本已来一切染法不相应故。谓离一切法差别之相。以无虚妄心念故。当知真如自性。非有相非无相。非非有相非非无相。非有无俱相。非一相非异相。非非一相非非异相。非一异俱相。乃至总说。依一切众生以有妄心念念分别。皆不相应故。说为空。若离妄心实无可空故。所言不空者。已显法体空无妄故。即是真心常恒不变净法满足。故名不空。亦无有相可取。以离念境界唯证相应故。心生灭者。依如来藏故有生灭心。所谓不生不灭与生灭和合非一非异。名为阿梨耶识。此识有二种义。能摄一切法生一切法。云何为二。一者觉义。二者不觉义。所言觉义者。谓心体离念。离念相者等虚空界无所不遍。法界一相即是如来平等法身。依此法身说名本觉。何以故。本觉义者。对始觉义说。以始觉者即同本觉。始觉义者。依本觉故而有不觉。依不觉故说有始觉。又以觉心源故名究竟觉。不觉心源故非究竟觉。此义云何。如凡夫人觉知前念起恶故。能止后念令其不起。虽复名觉即是不觉故。如二乘观智初发意菩萨等。觉于念异念无异相。以舍粗分别执着相故。名相似觉。如法身菩萨等。觉于念住念无住相。以离分别粗念相故。名随分觉。如菩萨地尽。满足方便一念相应。觉心初起心无初相。以远离微细念故。得见心性。心即常住名究竟觉。是故修多罗说。若有众生能观无念者。则为向佛智故。又心起者。无有初相可知。而言知初相者。即谓无念。是故一切众生不名为觉。以从本来念念相续未曾离念故。说无始无明。若得无念者。则知心相生住异灭。以无念等故。而实无有始觉之异。以四相俱时而有皆无自立。本来平等同一觉故

复次本觉随染。分别生二种相。与彼本觉不相舍离。云何为二。一者智净相。二者不思议业相。智净相者。谓依法力熏习。如实修行。满足方便故。破和合识相。灭相续心相。显现法身。智淳净故。此义云何。以一切心识之相皆是无明。无明之相不离觉性。非可坏非不可坏。如大海水因风波动。水相风相不相舍离。而水非动性。若风止灭动相则灭。湿性不坏故。如是众生自性清净心。因无明风动。心与无明俱无形相不相舍离。而心非动性。若无明灭相续则灭。智性不坏故。不思议业相者。以依智净。能作一切胜妙境界。所谓无量功德之相常无断绝。随众生根自然相应。种种而见得利益故

复次觉体相者。有四种大义。与虚空等犹如净镜。云何为四。一者如实空镜。远离一切心境界相。无法可现非觉照义故。二者因熏习镜。谓如实不空。一切世间境界悉于中现。不出不入不失不坏常住一心。以一切法即真实性故。又一切染法所不能染。智体不动。具足无漏熏众生故。三者法出离镜。谓不空法。出烦恼碍智碍。离和合相淳净明故。四者缘熏习镜。谓依法出离故。遍照众生之心。令修善根。随念示现故。所言不觉义者。谓不如实知真如法一故。不觉心起而有其念。念无自相不离本觉。犹如迷人依方故迷。若离于方则无有迷。众生亦尔。依觉故迷。若离觉性则无不觉。以有不觉妄想心故。能知名义为说真觉。若离不觉之心。则无真觉自相可说

复次依不觉故生三种相。与彼不觉相应不离。云何为三。一者无明业相。以依不觉故心动说名为业。觉则不动。动则有苦。果不离因故。二者能见相。以依动故能见。不动则无见。三者境界相。以依能见故境界妄现。离见则无境界。以有境界缘故复生六种相。云何为六。一者智相。依于境界心起分别爱与不爱故。二者相续相。依于智故生其苦乐觉。心起念相应不断故。三者执取相。依于相续缘念境界。住持苦乐心起着故。四者计名字相。依于妄执分别假名言相故。五者起业相。依于名字寻名。取着造种种业故。六者业系苦相。以依业受果不自在故。当知无明能生一切染法。以一切染法皆是不觉相故

复次觉与不觉有二种相。云何为二。一者同相。二者异相。同相者。譬如种种瓦器皆同微尘性相。如是无漏无明种种业幻。皆同真如性相。是故修多罗中依于此真如义故说一切众生本来常住入于涅槃。菩提之法非可修相非可作相。毕竟无得。亦无色相可见。而有见色相者。唯是随染业幻所作。非是智色不空之性。以智相无可见故异相者。如种种瓦器各各不同。如是无漏无明。随染幻差别。性染幻差别故

复次生灭因缘者。所谓众生依心意意识转故。此义云何。以依阿梨耶识说有无明。不觉而起。能见能现。能取境界。起念相续。故说为意。此意复有五种名。云何为五。一者名为业识谓无明力不觉心动故。二者名为转识。依于动心能见相故。三者名为现识。所谓能现一切境界。犹如明镜现于色像。现识亦尔。随其五尘对至即现无有前后。以一切时任运而起常在前故。四者名为智识谓分别染净法故。五者名为相续识。以念相应不断故。住持过去无量世等善恶之业令不失故。复能成熟现在未来苦乐等报。无差违故。能令现在已经之事忽然而念。未来之事不觉妄虑。是故三界虚伪唯心所作。离心则无六尘境界。此义云何。以一切法皆从心起妄念而生。一切分别即分别自心。心不见心无相可得。当知世间一切境界。皆依众生无明妄心而得住持。是故一切法。如镜中像无体可得。唯心虚妄。以心生则种种法生。心灭则种种法灭故

复次言意识者。即此相续识。依诸凡夫取着转深计我我所。种种妄执随事攀缘。分别六尘名为意识。亦名分离识。又复说名分别事识。此识依见爱烦恼增长义故。依无明熏习所起识者。非凡夫能知。亦非二乘智慧所觉。谓依菩萨。从初正信发心观察。若证法身得少分知。乃至菩萨究竟地不能知尽。唯佛穷了。何以故。是心从本已来自性清净。而有无明。为无明所染。有其染心。虽有染心而常恒不变。是故此义唯佛能知。所谓心性常无念。故名为不变。以不达一法界故心不相应忽然念起名为无明。染心者有六种。云何为六。一者执相应染。依二乘解脱及信相应地远离故。二者不断相应染。依信相应地修学方便渐渐能舍。得净心地究竟离故。三者分别智相应染。依具戒地渐离。乃至无相方便地究竟离故。四者现色不相应染依色自在地能离故。五者能见心不相应染。依心自在地能离故。六者根本业不相应染。依菩萨尽地得入如来地能离故。不了一法界义者。从信相应地观察学断。入净心地随分得离。乃至如来地能究竟离故。言相应义者。谓心念法异。依染净差别。而知相缘相同故。不相应义者。谓即心不觉常无别异。不同知相缘相故。又染心义者。名为烦恼碍。能障真如根本智故。无明义者。名为智碍。能障世间自然业智故。此义云何。以依染心能见能现。妄取境界违平等性故。以一切法常静无有起相。无明不觉妄与法违故。不能得随顺世间一切境界种种智故

复次分别生灭相者有二种。云何为二。一者粗。与心相应故。二者细。与心不相应故。又粗中之粗凡夫境界。粗中之细及细中之粗菩萨境界。细中之细是佛境界。此二种生灭。依于无明熏习而有。所谓依因依缘。依因者。不觉义故。依缘者。妄作境界义故。若因灭则缘灭。因灭故不相应心灭。缘灭故相应心灭

问曰。若心灭者云何相续。若相续者云何说究竟灭

答曰。所言灭者。唯心相灭非心体灭。如风依水而有动相。若水灭者。则风相断绝无所依止。以水不灭风相相续。唯风灭故动相随灭非是水灭。无明亦尔。依心体而动。若心体灭。则众生断绝无所依止。以体不灭心得相续。唯痴灭故心相随灭非心智灭

复次有四种法熏习义故。染法净法起不断绝。云何为四。一者净法。名为真如。二者一切染因。名为无明。三者妄心。名为业识。四者妄境界。所谓六尘。熏习义者。如世间衣服实无于香。若人以香而熏习故则有香气。此亦如是。真如净法实无于染。但以无明而熏习故则有染相。无明染法实无净业。但以真如而熏习故则有净用。云何熏习起染法不断。所谓以依真如法故有于无明。以有无明染法因故即熏习真如。以熏习故则有妄心。以有妄心即熏习无明。不了真如法故不觉念起现妄境界。以有妄境界染法缘故即熏习妄心。令其念着造种种业。受于一切身心等苦。此妄境界熏习义则有二种。云何为二。一者增长念熏习。二者增长取熏习。妄心熏习义则有二种。云何为二。一者业识根本熏习。能受阿罗汉辟支佛一切菩萨生灭苦故。二者增长分别事识熏习。能受凡夫业系苦故。无明熏习义有二种。云何为二。一者根本熏习。以能成就业识义故。二者所起见爱熏习。以能成就分别事识义故。云何熏习起净法不断。所谓以有真如法故能熏习无明。以熏习因缘力故。则令妄心厌生死苦乐求涅槃。以此妄心有厌求因缘故即熏习真如。自信己性。知心妄动无前境界。修远离法。以如实知无前境界故。种种方便起随顺行不取不念。乃至久远熏习力故无明则灭。以无明灭故心无有起。以无起故境界随灭。以因缘俱灭故心相皆尽。名得涅槃成自然业。妄心熏习义有二种。云何为二。一者分别事识熏习。依诸凡夫二乘人等。厌生死苦随力所能。以渐趣向无上道故。二者意熏习。谓诸菩萨发心勇猛速趣涅槃故。真如熏习义有二种。云何为二。一者自体相熏习。二者用熏习。自体相熏习者。从无始世来具无漏法。备有不思议业。作境界之性。依此二义恒常熏习。以有力故能令众生厌生死苦乐求涅槃。自信己身有真如法发心修行

问曰。若如是义者。一切众生悉有真如等皆熏习。云何有信无信。无量前后差别。皆应一时自知有真如法。勤修方便等入涅槃

答曰。真如本一。而有无量无边无明。从本已来自性差别厚薄不同故。过恒沙等上烦恼依无明起差别。我见爱染烦恼依无明起差别。如是一切烦恼。依于无明所起。前后无量差别。唯如来能知故。又诸佛法有因有缘。因缘具足乃得成办。如木中火性是火正因。若无人知不假方便能自烧木。无有是处。众生亦尔。虽有正因熏习之力。若不值遇诸佛菩萨善知识等以之为缘。能自断烦恼入涅槃者。则无是处。若虽有外缘之力。而内净法未有熏习力者。亦不能究竟厌生死苦乐求涅槃。若因缘具足者。所谓自有熏习之力。又为诸佛菩萨等慈悲愿护故。能起厌苦之心。信有涅槃修习善根。以修善根成熟故。则值诸佛菩萨示教利喜。乃能进趣。向涅槃道

用熏习者。即是众生外缘之力。如是外缘有无量义。略说二种。云何为二。一者差别缘。二者平等缘。差别缘者。此人依于诸佛菩萨等。从初发意始求道时乃至得佛。于中若见若念。或为眷属父母诸亲。或为给使。或为知友。或为怨家。或起四摄乃至一切所作无量行缘。以起大悲熏习之力。能令众生增长善根。若见若闻得利益故。此缘有二种。云何为二。一者近缘。速得度故。二者远缘。久远得度故。是近远二缘。分别复有二种。云何为二。一者增长行缘。二者受道缘。平等缘者。一切诸佛菩萨。皆愿度脱一切众生。自然熏习恒常不舍。以同体智力故。随应见闻而现作业。所谓众生依于三昧。乃得平等见诸佛故。此体用熏习。分别复有二种。云何为二。一者未相应。谓凡夫二乘初发意菩萨等。以意意识熏习。依信力故而能修行。未得无分别心与体相应故。未得自在业修行与用相应故。二者已相应。谓法身菩萨得无分别心。与诸佛智用相应。唯依法力自然修行。熏习真如灭无明故

复次染法从无始已来熏习不断。乃至得佛后则有断。净法熏习则无有断尽于未来。此义云何。以真如法常熏习故。妄心则灭法身显现。起用熏习故无有断

复次真如自体相者。一切凡夫声闻缘觉菩萨诸佛无有增减。非前际生非后际灭。毕竟常恒。从本已来性自满足一切功德。所谓自体有大智慧光明义故。遍照法界义故。真实识知义故。自性清净心义故。常乐我净义故。清凉不变自在义故。具足如是过于恒沙不离不断不异不思议佛法。乃至满足无有所少义故。名为如来藏。亦名如来法身

问曰。上说真如其体平等离一切相。云何复说体有如是种种功德

答曰。虽实有此诸功德义。而无差别之相。等同一味唯一真如。此义云何。以无分别离分别相。是故无二。复以何义得说差别。以依业识生灭相示。此云何示。以一切法本来唯心实无于念。而有妄心不觉起念见诸境界故说无明。心性不起即是大智慧光明义故。若心起见则有不见之相。心性离见即是遍照法界义故。若心有动非真识知无有自性。非常非乐非我非净。热恼衰变则不自在。乃至具有过恒沙等妄染之义。对此义故。心性无动则有过恒沙等诸净功德相义示现。若心有起。更见前法可念者则有所少。如是净法无量功德。即是一心更无所念。是故满足名为法身如来之藏

复次真如用者。所谓诸佛如来。本在因地发大慈悲。修诸波罗蜜摄化众生。立大誓愿尽欲度脱等众生界。亦不限劫数尽于未来。以取一切众生如己身故。而亦不取众生相。此以何义。谓如实知一切众生及与己身真如平等无别异故。以有如是大方便智。除灭无明见本法身。自然而有不思议业种种之用。即与真如等遍一切处。又亦无有用相可得。何以故。谓诸佛如来唯是法身智相之身。第一义谛无有世谛境界。离于施作。但随众生见闻得益故说为用。此用有二种。云何为二。一者依分别事识。凡夫二乘心所见者。名为应身。以不知转识现故见从外来。取色分齐不能尽知故。二者依于业识。谓诸菩萨从初发意。乃至菩萨究竟地心所见者。名为报身。身有无量色。色有无量相。相有无量好。所住依果亦有无量种种庄严随所示现即无有边不可穷尽离分齐相。随其所应常能住持不毁不失。如是功德皆因诸波罗蜜等无漏行熏。及不思议熏之所成就。具足无量乐相故。说为报身。又为凡夫所见者是其粗色。随于六道各见不同。种种异类非受乐相故。说为应身

复次初发意菩萨等所见者。以深信真如法故少分而见。知彼色相庄严等事。无来无去离于分齐。唯依心现不离真如。然此菩萨犹自分别。以未入法身位故。若得净心所见微妙其用转胜。乃至菩萨地尽见之究竟。若离业识则无见相。以诸佛法身无有彼此色相迭相见故

问曰。若诸佛法身离于色相者。云何能现色相

答曰。即此法身是色体故能现于色。所谓从本已来色心不二。以色性即智故色体无形。说名智身。以智性即色故。说名法身遍一切处。所现之色无有分齐。随心能示十方世界。无量菩萨无量报身。无量庄严各各差别。皆无分齐而不相妨。此非心识分别能知。以真如自在用义故

复次显示从生灭门即入真如门。所谓推求五阴色之与心。六尘境界毕竟无念。以心无形相十方求之终不可得。如人迷故谓东为西方实不转。众生亦尔。无明迷故谓心为念心实不动。若能观察知心无念。即得随顺入真如门故

对治邪执者。一切邪执皆依我见。若离于我则无邪执。是我见有二种。云何为二。一者人我见。二者法我见。人我见者。依诸凡夫说有五种。云何为五。一者闻修多罗说如来法身毕竟寂寞犹如虚空。以不知为破着故。即谓虚空是如来性。云何对治。明虚空相是其妄法体无不实。以对色故有。是可见相令心生灭。以一切色法本来是心实无外色。若无色者则无虚空之相。所谓一初境界唯心妄起故有。若心离于妄动。则一切境界灭。唯一真心无所不遍。此谓如来广大性智究竟之义。非如虚空相故。二者闻修多罗说世间诸法毕竟体空。乃至涅槃真如之法亦毕竟空。从本已来自空离一切相。以不知为破着故。即谓真如涅槃之性唯是其空。云何对治。明真如法身自体不空。具足无量性功德故。三者闻修多罗说如来之藏无有增减。体备一切功德之法。以不解故即谓如来之藏有色心法自相差别云何对治。以唯依真如义说故。因生灭染义示现说差别故。四者闻修多罗说一切世间生死染法皆依如来藏而有。一切诸法不离真如。以不解故谓如来藏自体具有一切世间生死等法。云何对治。以如来藏从本已来唯有过恒沙等诸净功德。不离不断不异真如义故。以过恒沙等烦恼染法。唯是妄有性自本无。从无始世来未曾与如来藏相应故。若如来藏体有妄法。而使证会永息妄者。则无是处故。五者闻修多罗说依如来藏故有生死。依如来藏故得涅槃。以不解故谓众生有始。以见始故复谓如来所得涅槃。有其终尽还作众生。云何对治。以如来藏无前际故。无明之相亦无有始。若说三界外更有众生始起者。即是外道经说。又如来藏无有后际。诸佛所得涅槃与之相应则无后际故。法我见者。依二乘钝根故。如来但为说人无我。以说不究竟。见有五阴生灭之法。怖畏生死妄取涅槃。云何对治。以五阴法自性不生则无有灭。本来涅槃故

复次究竟离妄执者。当知染法净法皆悉相待。无有自相可说。是故一切法从本已来。非色非心。非智非识。非有非无。毕竟不可说相。而有言说者。当知如来善巧方便。假以言说引导众生。其旨趣者皆为离念归于真如。以念一切法令心生灭不入实智故

分别发趣道相者。谓一切诸佛所证之道。一切菩萨发心修行趣向义故。略说发心有三种。云何为三。一者信成就发心。二者解行发心。三者证发心。信成就发心者。依何等人修何等行。得信成就堪能发心。所谓依不定聚众生。有熏习善根力故。信业果报能起十善。厌生死苦欲求无上菩提。得值诸佛亲承供养修行信心。经一万劫信心成就故。诸佛菩萨教令发心。或以大悲故能自发心。或因正法欲灭。以护法因缘能自发心。如是信心成就得发心者。入正定聚毕竟不退。名住如来种中正因相应。若有众生善根微少。久远已来烦恼深厚。虽值于佛亦得供养。然起人天种子。或起二乘种子。设有求大乘者。根则不定若进若退或有供养诸佛。未经一万劫。于中遇缘亦有发心。所谓见佛色相而发其心。或因供养众僧而发其心。或因二乘之人教令发心。或学他发心。如是等发心悉皆不定。遇恶因缘或便退失堕二乘地

复次信成就发心者。发何等心。略说有三种。云何为三。一者直心。正念真如法故。二者深心。乐集一切诸善行故。三者大悲心。欲拔一切众生苦故

问曰。上说法界一相佛体无二。何故不唯念真如。复假求学诸善之行

答曰。譬如大摩尼宝体性明净。而有矿秽之垢。若人虽念宝性。不以方便种种磨治终无得净。如是众生真如之法体性空净。而有无量烦恼染垢。若人虽念真如。不以方便种种熏修亦无得净。以垢无量遍一切法故。修一切善行以为对治。若人修行一切善法。自然归顺真如法故。略说方便有四种。云何为四。一者行根本方便。谓观一切法自性无生。离于妄见不住生死。观一切法因缘和合业果不失。起于大悲修诸福德。摄化众生不住涅槃。以随顺法性无住故。二者能止方便。谓惭愧悔过。能止一切恶法不令增长。以随顺法性离诸过故。三者发起善根增长方便谓勤供养礼拜三宝。赞叹随喜劝请诸佛。以爱敬三宝淳厚心故。信得增长。乃能志求无上之道。又因佛法僧力所护故。能消业障善根不退。以随顺法性离痴障故。四者大愿平等方便。所谓发愿尽于未来。化度一切众生使无有余。皆令究竟无余涅槃。以随顺法性无断绝故。法性广大遍一切众生平等无二。不念彼此究竟寂灭故。菩萨发是心故。则得少分见于法身。以见法身故随其愿力。能现八种利益众生。所谓从兜率天退入胎。住胎出胎。出家成道。转法轮入于涅槃。然是菩萨未名法身。以其过去无量世来有漏之业未能决断。随其所生与微苦相应。亦非业系。以有大愿自在力故。如修多罗中或说有退堕恶趣者。非其实退。但为初学菩萨未入正位而懈怠者恐怖令使勇猛故。又是菩萨一发心后。远离怯弱。毕竟不畏堕二乘地。若闻无量无边阿僧祇劫勤苦难行乃得涅槃。亦不怯弱。以信知一切法从本已来自涅槃故。解行发心者当知转胜。以是菩萨从初正信已来。于第一阿僧祇劫将欲满故。于真如法中深解现前所修离相。以知法性体无悭贪故。随顺修行檀波罗蜜。以知法性无染离五欲过故。随顺修行尸波罗蜜。以知法性无苦离嗔恼故。随顺修行羼提波罗蜜。以知法性无身心相离懈怠故。随顺修行毗梨耶波罗蜜。以知法性常定体无乱故。随顺修行禅波罗蜜。以知法性体明离无明故。随顺修行般若波罗蜜。证发心者。从净心地乃至菩萨究竟地证何境界。所谓真如。以依转识说为境界。而此证者无有境界。唯真如智名为法身。是菩萨于一念顷能至十方无余世界。供养诸佛请转法轮。唯为开导利益众生。不依文字。或示超地速成正觉。以为怯弱众生故。或说我于无量阿僧祇劫当成佛道。以为懈慢众生故。能示如是无数方便不可思议。而实菩萨种性根等。发心则等。所证亦等。无有超过之法。以一切菩萨皆经三阿僧祇劫故。但随众生世界不同。所见所闻根欲性异。故示所行亦有差别。又是菩萨发心相者。有三种心微细之相。云何为三。一者真心。无分别故。二者方便心。自然遍行利益众生故。三者业识心。微细起灭故。又是菩萨功德成满。于色究竟处。示一切世间最高大身。谓以一念相应慧。无明顿尽。名一切种智。自然而有不思议业。能现十方利益众生

问曰。虚空无边故世界无边。世界无边故众生无边。众生无边故心行差别亦复无边。如是境界不可分齐难知难解。若无明断无有心想。云何能了名一切种智

答曰。一切境界本来一心离于想念。以众生妄见境界故心有分齐。以妄起想念不称法性故不能决了。诸佛如来离于见想无所不遍。心真实故。即是诸法之性。自体显照一切妄法。有大智用无量方便。随诸众生所应得解。皆能开示种种法义。是故得名一切种智。又问曰。若诸佛有自然业。能现一切处利益众生者。一切众生。若见其身若睹神变。若闻其说无不得利。云何世间多不能见

答曰。诸佛如来法身平等遍一切处。无有作意故。而说自然。但依众生心。现众生心者犹如于镜。镜若有垢色像不现。如是众生心若有垢。法身不现故已说解释分

次说修行信心分

是中依未入正定。众生故。说修行信心。何等信心云何修行。略说信心有四种。云何为四。一者信根本。所谓乐念真如法故。二者信佛有无量功德。常念亲近供养恭敬。发起善根。愿求一切智故。三者信法有大利益常念修行诸波罗蜜故。四者信僧能正修行自利利他。常乐亲近诸菩萨众。求学如实行故。修行有五门。能成此信。云何为五。一者施门。二者戒门。三者忍门。四者进门。五者止观门

云何修行施门。若见一切来求索者。所有财物随力施与。以自舍悭贪令彼欢喜。若见厄难恐怖危逼。随己堪任施与无畏。若有众生来求法者。随己能解方便为说。不应贪求名利恭敬。唯念自利利他回向菩提故。云何修行戒门。所谓不杀不盗不淫不两舌不恶口不妄言不绮语。远离贪嫉欺诈谄曲嗔恚邪见。若出家者为折伏烦恼故。亦应远离愦闹常处寂静修习少欲知足头陀等行。乃至小罪心生怖畏。惭愧改悔不得轻于如来所制禁戒。当护讥嫌不令众生妄起过罪故。云何修行忍门。所谓应忍他人之恼心不怀报。亦当忍于利衰毁誉称讥苦乐等法故。云何修行进门。所谓于诸善事心不懈退。立志坚强远离怯弱。当念过去久远已来。虚受一切身心大苦无有利益。是故应勤修诸功德。自利利他速离众苦

复次若人虽修行信心。以从先世来多有重罪恶业障故。为魔邪诸鬼之所恼乱。或为世间事务种种牵缠。或为病苦所恼。有如是等众多障碍。是故应当勇猛精勤。昼夜六时礼拜诸佛。诚心忏悔劝请随喜回向菩提。常不休废。得免诸障善根增长故。云何修行止观门。所言止者。谓止一切境界相。随顺奢摩他观义故。所言观者。谓分别因缘生灭相。随顺毗钵舍那观义故。云何随顺。以此二义渐渐修习不相舍离双现前故。若修止者。住于静处端坐正意。不依气息不依形色。不依于空不依地水火风。乃至不依见闻觉知。一切诸想随念皆除。亦遣除想。以一切法本来无相。念念不生念念不灭。亦不得随心外念境界后以心除心。心若驰散。即当摄来住于正念。是正念者。当知唯心无外境界。既复此心亦无自相。念念不可得。若从坐起去来进止有所施作。于一切时常念方便随顺观察。久习淳熟其心得住。以心住故渐渐猛利。随顺得入真如三昧。深伏烦恼信心增长速成不退。唯除疑惑不信诽谤重罪业障我慢懈怠。如是等人所不能入

复次依如是三昧故。则知法界一相。谓一切诸佛法身与众生身平等无二。即名一行三昧。当知真如是三昧根本。若人修行。渐渐能生无量三昧。或有众生无善根力。则为诸魔外道鬼神之所惑乱。若于坐中现形恐怖。或现端正男女等相。当念唯心境界则灭终不为恼。或现天像菩萨像。亦作如来像相好具足。若说陀罗尼。若说布施持戒忍辱精进禅定智慧。或说平等空无相无愿无怨无亲无因无果毕竟空寂是真涅槃。或令人知宿命过去之事。亦知未来之事。得他心智辩才无碍。能令众生贪着世间名利之事。又令使人数嗔数喜性无常准。或多慈爱多睡多病其心懈怠。或卒起精进后便休废。生于不信多疑多虑。或舍本胜行更修杂业。若着世事种种牵缠。亦能使人得诸三昧少分相似。皆是外道所得。非真三昧。或复令人若一日若二日若三日乃至七日住于定中。得自然香美饮食。身心适悦不饥不渴。使人爱着。或亦令人食无分齐乍多乍少颜色变异。以是义故。行者常应智慧观察。勿令此心堕于邪网。当勤正念不取不着。则能远离是诸业障。应知外道所有三昧。皆不离见爱我慢之心。贪着世间名利恭敬故。真如三昧者。不住见相不住得相。乃至出定亦无懈慢。所有烦恼渐渐微薄。若诸凡夫不习此三昧法。得入如来种性。无有是处。以修世间诸禅三昧多起味着。依于我见系属三界。与外道共。若离善知识所护。则起外道见故

复次精勤专心修学此三昧者。现世当得十种利益。云何为十。一者常为十方诸佛菩萨之所护念。二者不为诸魔恶鬼所能恐怖。三者不为九十五种外道鬼神之所惑乱。四者远离诽谤甚深之法重罪业障渐渐微薄。五者灭一切疑诸恶觉观。六者于如来境界信得增长。七者远离忧悔于生死中勇猛不怯。八者其心柔和舍于憍慢不为他人所恼。九者虽未得定于一切时一切境界处则能减损烦恼不乐世间。十者若得三昧不为外缘一切音声之所惊动

复次若人唯修于止。则心沉没或起懈怠。不乐众善远离大悲。是故修观。修习观者。当观一切世间有为之法。无得久停须臾变坏一切心行念念生灭。以是故苦。应观过去所念诸法恍惚如梦。应观现在所念诸法犹如电光。应观未来所念诸法犹如于云忽尔而起。应观世间一切有身悉皆不净。种种秽污无一可乐。如是当念。一切众生从无始世来。皆因无明所熏习故令心生灭。已受一切身心大苦。现在即有无量逼迫。未来所苦亦无分齐。难舍难离而不觉知。众生如是甚为可愍。作此思惟。即应勇猛立大誓愿。愿令我心离分别故。遍于十方修行一切诸善功德尽其未来。以无量方便救拔一切苦恼众生。令得涅槃第一义乐。以起如是愿故。于一切时一切处。所有众善随已堪能。不舍修学心无懈怠。唯除坐时专念于止。若余一切悉当观察应作不应作。若行若住若卧若起。皆应止观俱行。所谓虽念诸法自性不生。而复即念因缘和合善恶之业苦乐等报不失不坏。虽念因缘善恶业报。而亦即念性不可得。若修止者。对治凡夫住着世间。能舍二乘怯弱之见。若修观者。对治二乘不起大悲狭劣心过远离凡夫不修善根。以此义故。是止观二门。共相助成不相舍离。若止观不具。则无能入菩提之道

复次众生初学是法。欲求正信其心怯弱。以住于此娑婆世界。自畏不能常值诸佛亲承供养。惧谓信心难可成就意欲退者。当知如来有胜方便摄护信心。谓以专意念佛因缘。随愿得生他方佛土。常见于佛永离恶道。如修多罗说。若人专念西方极乐世界阿弥陀佛。所修善根回向愿求生彼世界。即得往生。常见佛故终无有退。若观彼佛真如法身。常勤修习毕竟得生住正定故已说修行信心分

次说劝修利益分

如是摩诃衍诸佛秘藏我已总说。若有众生。欲于如来甚深境界得生正信远离诽谤入大乘道。当持此论思量修习究竟能至无上之道。若人闻是法已不生怯弱。当知此人定绍佛种。必为诸佛之所授记。假使有人能化三千大千世界满中众生令行十善。不如有人于一食顷正思此法。过前功德不可为喻。复次若人受持此论观察修行。若一日一夜所有功德无量无边不可得说。假令十方一切诸佛。各于无量无边阿僧祇劫。叹其功德亦不能尽。何以故。谓法性功德无有尽故。此人功德亦复如是无有边际。其有众生于此论中毁谤不信。所获罪报经无量劫受大苦恼。是故众生但应仰信不应诽谤。以深自害亦害他人。断绝一切三宝之种。以一切如来皆依此法得涅槃故。一切菩萨因之修行入佛智故。当知过去菩萨已依此法得成净信。现在菩萨今依此法得成净信。未来菩萨当依此法得成净信。是故众生应勤修学

  诸佛甚深广大义　　我今随分总持说
  回此功德如法性　　普利一切众生界

大乘起信论一卷


大乘缘生论(圣者郁楞迦造)

    No. 1653 [No. 1652]

大乘缘生论一卷(圣者郁楞迦造)

        开府仪同三司特进试鸿胪卿肃国公食邑三千户赐紫赠司空谥大鉴正号大广智大兴善寺三藏沙门不空奉　诏译

  从一生于三　　从三转生六
  六二二更六　　从六亦生六
  从六有于三　　此三复有三
  三复生于四　　四复生于三
  从三生于一　　彼一复生七
  于中所有苦　　牟尼说皆摄
  十二种差别　　智士说为空
  缘生支力故　　应知十二法
  无知与业识　　名色根三和
  领渴及以取　　集生熟次终
  初八九烦恼　　第二第十业
  余七皆是苦　　三摄十二法
  初二是过去　　后二未来时
  余八是现在　　此谓三时法
  烦恼业感报　　报还生烦恼
  烦恼复生业　　亦由业有报
  离恼何有业　　离业何有报
  无报则离恼　　此三各寂灭
  五支因生果　　名为烦恼业
  七支以为果　　七种苦应知
  因中空无果　　果中亦无因
  因中亦无因　　果中亦无果
  智者空相应　　世中四种支
  因果合故有　　烦恼业果合
  应许为六分　　有节所摄故
  二节及三略　　因果杂为节
  三四节总略　　二三二三二
  苦位有五法　　作者及藏界
  境转生流行　　迷惑发起果
  等流果为二　　相应根分中
  一一三二分　　热恼缺短果
  转出等流果　　相应余分中
  二一一一法　　此有十二种
  和合故缘生　　无众生无命
  空无慧以知　　无我无我所
  无我无我中　　四种无知空
  余支亦如是　　断常二边离
  此即是中道　　若觉已成就
  觉体是诸佛　　觉已于众中
  圣仙说无我　　曾于城喻经
  导师说此义　　迦栴延经说
  正见及空见　　破逻遇拏经(张宿名也)
  亦说殊胜空　　缘生若正知
  彼知空相应　　缘生若不知
  亦不知彼空　　于空若起慢
  于蕴不生厌　　彼名恶趣空
  则迷缘生义　　缘生不迷故
  离慢彼知空　　及厌于蕴故
  不迷于业果　　业作缘续生
  亦非不缘此　　空缘当有此
  业报受用具　　十二支差别
  先已说缘生　　彼烦恼业苦
  三中如法摄　　从三生于二
  从二生于七　　从七复生三
  有轮如是转　　一切皆因果
  从空生于空　　从法生于法
  藉缘生烦恼　　藉缘亦生业
  藉缘亦生报　　无一不有缘
  诵灯印镜音　　日光种子醋
  蕴续不移时　　智慧观彼二

缘生三十论本竟

缘生三十论我当随顺次第解释

  从一生于三　　从三转生六
  六二二更六　　从六亦生六

从一生于三者谓无知。此无知者说名无明。于苦集灭道中不觉知故。名为无知。由故则有福非福。不动说名三行。及身行口行心行等。从其转生。从三转生六者从三行生六识身。所谓眼识耳识鼻识舌识身识意识。六二者彼六识身转生二种。所谓名色。二更六者。名色二种转生六处。所谓眼处耳处鼻处舌处身处意处。从六亦生六者。从彼六处转生六触。所谓眼触耳触鼻触舌触身触意触

  从六有于三　　此三复有三
  三复生于四　　四复生于三

从六有于三者。从彼六触转生三受。所谓乐受苦受不苦不乐受。此三复有三者。还从彼等三受。转生三种爱。所谓欲爱有爱无有爱。从三复生于四者。从彼三种爱转生四取。所谓欲取见取戒禁取我语取。从四复生于三者。从彼四取转生三有。所谓欲有色有无色有

  从三生于一　　彼一复生七
  于中所有苦　　牟尼说皆摄

从三生于一者。还以彼等三有作缘生。当来一种生。彼一复生七者。还从一当有老死愁叹苦忧恼等七种。于中所有苦牟尼说皆摄者。于中无明为始苦为终。无量种苦。世尊略说皆此所摄

  十二种差别　　智士说为空
  缘生支力故　　应知十二法

十二种差别智士说为空者。此无知等差别有十二支。彼一切皆自性空。应当知如此所说唯是空。法从空生空从法生。法由缘生支法故。应当知十二法者。若以次第生支力故。彼十二法如是应知。彼中迷惑相者是无明。彼行句处积集当有相者是行。彼识句处次受生支转出相者是识彼名色句处名身色身和合相者是名色。彼六处句安置根相者是六处。彼触句处眼色识共聚相者是触。彼受句处爱非爱颠倒受用相者是受。彼爱句处无厌足相者是爱。彼取句处执持摄取相者是取。彼有句处名身色身相者是有。彼生句处蕴生起相者是生。彼老句处成熟相者是老。彼死句处命根断者是死。彼愁句处匆遽相者是愁。彼叹句处哭声者是叹。彼苦句处身逼恼相者是苦。彼忧句处心逼恼相者是忧。彼诸热恼句处损害相者是恼

  无知与业识　　名色根三和
  领渴及以取　　集出熟后边

于中无知者是无明。业者行。识者是了别。名色五蕴聚。根者是处。三和者是触。领纳者是受。渴者是爱。取者是执持。受用者是有。起者是生。熟者是老。后边者是死

又此等差别相摄。我当次第说之。于中烦恼业差别

  初八九烦恼　　第二第十业
  余七皆是苦　　三摄十二法

三烦恼者无明爱取。二业者行有。七报者识名色六处触受生老死等。此十二法三种所摄。又时差别

  初二是过去　　后二未来时
  余八是现在　　此谓三时法

无明行初二种过去时。生老死后二种未来。识名色六处触受爱取有八种现在时

又此等各各次第相生

  烦恼业感报　　报还生烦恼
  烦恼复生业　　亦由业有报

烦恼业报三种如前所说。由彼烦恼故有业。由业故有报。还由报故有烦恼。由烦恼故有业。由业故有报

问曰由烦恼尽各各寂灭。其义云何答言

  离恼何有业　　离业何有报
  无报则离恼　　此三各寂灭

若其此心无烦恼染。则不集业。若不作业。则不受报。若灭报者亦不生烦恼。如是此三各各寂灭

又此等有因果分

  五支因生果　　名为烦恼业
  七分以为果　　七种苦应知

五种因名为烦恼业者。如前所说。无明行爱取有是也。七种果转生者。亦如前所说。七种苦所谓识名色六处触受生老死是也

又此因果二种空

  因中空无果　　果中亦无因
  因中亦无因　　果中亦无果
  智者空相应(梵本一偈今为一句矣)

若此所说因果二种。于中若因空果亦空。果空因亦空。因空因亦空。果空果亦空。于此四句际当与相应

又此更有分别

  世中四种支　　因果合故有
  烦恼业果合　　应许为六支

世中四种支因果合故有者。所说三世五种因。共七种果。总略为四种。次第有四种分。于中无明行过去时二法为初分。识名色六处触受现在时为第二分。爱取有亦是现在时为第三分。生老死未来时二法为第四分。此谓四种分也。烦恼业果结许为六分者。烦恼业报三种结为二根。则为六分。于中无明乃至受以无明为根。爱乃至老死为爱根。无明根中无明是烦恼分。行是业分。识名色六处触受是报分。爱根中爱取是烦恼分。有是业分。生老死是报分

又节分总略

  有节所摄故　　二节及三略
  因果杂为节　　三四节总略

有节为本。发起二节。所谓有生两间是第一节。行识两间是第二节。此二节并为业果节。受爱中因果共杂是第三节。此之三节复为四种总略。无明行二种是第一总略。识名色六处触受五种是第二总略。爱取有三种是第三总略。生老死二种是第四总略。此谓三节及四总略

又此等法中位时差别

  二三二三二　　苦位有五法
  作者及藏界　　境转生流行

法者无明。行说为二种。识名色六处说为三种。触受说为二种。爱取有说为三种。又二者生老死说为二种。此等五法是苦位中作者。胎藏境界发转出生。于中流行如数当知。于中无明行二种说为苦位中作者。识名色六处三种说为苦位中胎藏。触受二种说为苦位中境界。爱取有三种说为苦位中发转。生老死二种说为苦位中流行

又果差别

  迷惑发起果　　报流果为二
  相应根分中　　一一三二分

如前所说。此无明根及爱根。于无明根初分中。迷惑发起报等流名四种果。一一三二数分之道。随其次第当与相应。于中无明是迷惑果。行是发起果。识名色六处是报果。触受是等流果

复有余残果

  热恼缺短果　　转出等流果
  相应余分中　　二一一一法

如前所说。第二爱根分中。热恼缺短转生等流果等。随其数分二一一一。于此法中当与相应。于中爱取是热恼果。有是缺短果。生是转出果。老死是等流果。如是此等则有八果

  此有十二种　　和合故缘生
  无众生无命　　空无以慧知

如是无明(古译无明今无知乃正也)为初。老死为后。有十二支和合胜故各各缘生。而无众生无寿命空无以慧应知。于中无众生者。以不牢固故。无寿命者以无我故。空者无作者。以无作者故

  无我无我所　　无我无我中
  四种无知空　　余支亦如是

无知是无我。此中无知是无我所。以无我故无我中无无知。四种无知无我所中。亦无无知空。如四种次第无知空如是行等余支。亦皆是空应当知之

  断常二边离　　此即是中道
  若觉已成就　　觉体是诸佛

有是常执。无是断执。此二边由此生缘故生彼。彼诸有中。若离二边即契中道。若不知此是义则诸外道堕于二边。若觉悟已是则一切诸佛。如佛于世间能成就非余

  觉已于众中　　圣仙说无我
  曾于城喻经　　导师说此义

彼亦是此中道。觉已于诸众中。佛说无我无我所。汝等比丘当知。谓着我我所愚童凡夫寡闻之类。随假施设中。复我及我所。比丘生时但苦生。灭时但苦灭如城喻经中导师已说义又

  迦旃延经说　　正见及空见
  破逻具拏经　　亦说殊胜空

此等三经及以余处。如是之相世尊已广说

  缘生若正知　　彼知空相应
  缘生若不知　　亦不知彼空

于前所说缘生若有正知。彼知无异。彼复何知。谓知于空。缘生若不知亦不知空者。于此缘生若其不知。亦于彼空不能解入应知之

  于空若起慢　　则不厌于蕴
  若有彼无见　　则迷缘生义

于空若起慢则不厌。若起空慢则于五蕴中不生厌离。若有彼无见则迷缘生义者。若复由于无见迷此缘生义故。则于四种见中随取何见。一者断见。二者常见。三者自在化语。四者一切宿业作

  缘生不迷故　　离慢彼知空
  及厌于蕴故　　不迷于业果

缘生不迷故离慢彼知空者。于前所说各各缘生中。若无迷心。及于执取我我所中。若得离慢彼则如法能入于空。及厌于蕴故不迷于业果者。五蕴中执取我我所故。则遍世间轮转不息。于彼蕴中厌离故。于业果相续。则无颠倒亦不迷惑

又此义云何

  业作缘续生　　亦非不缘此
  空缘当有此　　业报受用具

业作缘续生亦非不缘此者。烦恼业报如前所说。彼以如是善不善业。推遣众生傍及上下相续而生。若非此业则不作缘。若不然者则不作业受报已作业而失。空缘当有此业报受用具者。若由此等善不善业有报受用。自性是空本无有我。作缘发生彼性空亦应当知彼义今更略说

  十二支差别　　前已说缘生
  彼烦恼业苦　　三中如法摄

无明为初。老死为后。是十二支缘生差别如前所说。彼中三是烦恼。二是业。七是苦。皆已摄入

  从三生于二　　从二生于七
  从七复生三　　有轮如是转

无明爱取三种所生行有二种。彼二所生识名色六处触受生老死七支。彼七支中如前所说还生三种。彼三复其二更七。是故二种次第不断。此之有轮如是转

  因果生诸世　　无别有众生
  唯是于空法　　还自生空法

因果生诸世无别有众生者。无明行爱取有五种名因。识名色六处触受生老死七种名果。此等所有普遍世间。若我若众生若寿若生者若丈夫若人若作者。是等分别唯虚诳。应当知之彼云何生。唯是于空法还自生空法谓自性空中假名烦恼业果。唯有空假名烦恼业果法生。此是其义

  藉缘生烦恼　　藉缘亦生业
  藉缘亦生报　　无一不有缘

若有烦恼则有种种无量业。及种种业所生果报彼皆因共缘。应当知之无有一法无因缘者。又为明彼义今更说譬喻

  诵灯印镜音　　日光种子醋
  众续不移转　　智应观彼二

如诵有教诵者受诵者。所有教诵不移转受诵。何故教诵者仍安。安故其教诵者亦不相续。何以故自不自故。如灯次第生非是初灯。移转亦非第二。无因而生。如是印与像二种。面与镜二种。音与响二种。日与火二种。种子与芽二种。醋与舌唌二种。二种此等所有皆不移转。亦非不生。亦非无因而生。彼二种五蕴。相续次第转。非初蕴而移转。而第二蕴亦非不生。亦非无因而生。智者于此蕴相续次第不移转。应当正观。又内外相应有十种。皆当知。于中外十种者。一者非常故二者非断故。三者不移转故四者因果相系无中间故。五者非彼体故六者非别异故。七者无作者故八者非无因故。九者刹那灭故十者同类果相系故。彼外所有种子灭无余故。非常牙出生故。非断种子灭无余已。其牙本无今有生故。不移转彼所相续无有断绝因果相继故。无中间种子牙差别故。非彼体从出生故。非别异因缘和合故。无作者种子为因故。非无因种子牙茎枝叶花果等展转相生故。刹那灭甜醋碱苦辛涩随因差别果转出故。同类果相繁。于中内十种者。一者死边蕴灭无余故非常。二者得次生支蕴故非断。三者死边蕴灭无余已次生支蕴本无今有生故不移转。四者蕴相续无有断绝因果相继故无中间。五者死边次生支蕴差别故非彼体。六者从彼出生故非别异。七者因缘和合故无作者。八者烦恼业为因故非无因。九者迦逻罗頞浮陀箄尸伽那奄佉。出胎婴孩童子少年长宿等。展转相生故刹那灭。十者善不善薰。随因差别果转出故。同类果相系

又有三偈

  如灯焰转生　　识身亦如是
  前际与后际　　亦无有积集
  不生亦有生　　破坏不和合
  所生亦无住　　而此作业转
  若于彼缘生　　而能观知空
  若知彼施设　　则契于中道

于中无明行爱取有是为集谛。识名色六处触受生老死是为苦谛。彼十二支。道谛者令彼灭证方便。所谓念处正勤如意足根力觉支八圣道名为道谛

大乘缘生论一卷


大宗地玄文本论

    No. 1669

大宗地玄文本论卷第一

        马鸣菩萨造

        真谛三藏译

    归依德处无边大决择分第一

  顶礼一切无余明　　非一非一诸则地
  不数不思无量一　　并诸种种趣生类
  本无量数断命品　　与等尘尘无有法
  兼不可说无所有　　通俱非是等诸法

论曰。就此二行偈中。则有八门。云何为八。一者显示中中主者门。二者显示道路轨则门。三者显示离杂合一门。四者显示无边毛生门。五者显示种种离识门。六者显示假有无实门。七者显示无所有事门。八者显示具足无碍门。是名为八。就显示中中主者门中。则有五种。云何为五。一者随顺随转应身主者。二者有无无碍变身主者。三者本体本性法身主者。四者本末俱绝满道主者。五者随应无碍自然主者。是名为五。修集行因大陀罗尼修多罗中。作如是说。尔时花轮宝光明天子则白佛言。世尊。第一导师有几数量可思议不可思议。唯愿世尊。为我等众开示显说。我等大众闻其名字常诵常念。出无明藏到涅槃城。于是世尊告天子言。我若以神通力。无量无边阿僧祇劫中。说其名字终不能尽。今当略言。为汝等众宣说其要。善男子。其觉者数广大圆满过于恒沙。略说五种。云何为五。一者随体佛。二者变体佛。三者法体佛。四者莫测佛。五者应转佛。乃至广说故。如偈顶礼一切无余明故。以何义故。一切导师皆名主者。以三义故。云何为三。一者自在义。诸法王故。二者顶上义。三界一故。三者周遍义。无所不至故。是名为三。如是已说显示中中主者门。次当说显示道路轨则门。就此门中则有六种。云何为六。一者音脐言导无碍自在轨则。二者所依本地平等一种离诸虚妄轨则。三者生长庄严一一有力轨则。四者究竟圆满无余尽摄轨则。五者非名非相非体非用无造无作轨则。六者自然现前常住不变无所诠了究竟净满轨则。是名为六。金刚三昧无碍解脱本智实性修多罗中。作如是说。复次文殊师利。若我广说。总有十亿七万三千五十法门行者履游道路则则。若我略说。总有六种行者履游则则。如是六则通摄一切无量无边轨则藏海。云何为六。一者说则。二者等则。三者种则。四者上则。五者非则。六者常则。乃至广说故。如偈非一非一诸则地故。以何义故。一切法藏皆名轨则。以三义故。云何为三。一者金区义。时人易转法门之印常恒不变。如彼区故。二者引导义。摄将行者令趣治路。如彼导故。三者能持义。善持自相而不坏失。如彼持故。是名为三。如是已说显示道路轨则门。次当说显示离杂合一门。就此门中则有三种。云何为三。一者结缚合一。一切无量无边无明烦恼之众类再生。虽无内合一。而有外合一。以数量等成立契一义故。二者解脱合一。一切无量无边三乘诸圣人等。内有道理之合一义。外有同尘之合一义故。三者具足俱非合一。一切无量无边金刚中间大圣众等。具足能契所契之二义故。是名为三。文殊师利。论义第一无极无尽修多罗中。作如是说。僧众之海虽无有量。而其本体但有三种。云何为三。一者无根无诤地。二者俱根无诤地。三者有根无诤地。乃至广说故。如偈不数不思无量一故。以何义故。一切诸僧皆名合一。有二义故。云何为二。一者积集义。集会无量无边一切散乱尘故。二者一种义。安止无量无边一切波浪识故。是名为二。如是已说显示离杂合一门。次当说显示无边毛生门。就此门中则有三门。云何为三。一者有类毛生无边门。二者空类毛生无边门。三者似类毛生无边门。是名为三。就初门中则有四种。云何为四。一者卵生。二者胎生。三者湿生。四者化生。是名为四。如是四生。能摄一切无量有类根本名数。就中门中则有三种。云何为三。一者光明中藏空类。二者闇色中藏空类。三者风云中藏空类。是名为三。如是三类。空故非空以隐故空。应审观察空类眷属。其数众多不出此量。就后门中亦有三种。云何为三。一者幻化咒术相相无理似类。二者变药方禁相相无理似类。三者随本现前影像似类。是名为三。如是三类。能摄一切无量无边种种似类根本名数。集类法门修多罗中。作如是说。有识种类广说有十。略说有三。云何为三。一者心识亲近在有众生。二者处所隐藏不见众生。三者识远似有动转众生。是名为三。乃至广说故。如偈并诸种种趣生类故。以何义故。一切众生皆名毛生。有二义故。云何为二。一者动转不定义。随趣受生无有定法故。二者众多无数义。方角无有数量故。是名为二。今此门中。为欲现示圣如角鲜凡如毛多故。如是已说显示无边毛生门。次当说现示种种离识门。就此门中则有二种。云何为二。一者共业建立断命品。二者别业建立断命品。是名为二。就第一门中则有四种。云何为四。一者风轮大地断命品。二者水轮大地断命品。三者金轮大地断命品。四者火轮大地断命品。是名为四。如是四轮。能摄一切无量无边共业建立断命品类根本名数言别业建立断名品者。谓众生身。非执受摄发毛等类业行本因修多罗中。作如是说。复次文殊师利。言众生居住世间者。则有二种。云何为二。一者总轮世间。二者别持世间。是名为二。此二世间。善能摄持无量无边一切居住依止世间。乃至广说故。如偈及无量数断命品故。以何义故。一切离识皆名断命。所谓无有了别智品故。如是已说现示种种离识门。次当说现示假有无实门。就此门中则有五种。云何为五。一者如水中月假有。二者如闼婆城假有。三者如阳炎水假有。四者如幻化作假有。五者如谷响音假有。是名为五。大宝无尽莲花地地修多罗中。作如是说。如水中月等五种虚说譬喻。总摄五万五千五百五十诠虚说譬喻根本名字。乃至广说故。如偈与等尘尘无有法故。以何义故。一切无量虚说譬喻。皆名无有。所谓无有实自性故名曰为无。无有其实非都无故。名曰为有。如是已说现示假有无实门。次当说现示无所有事门。就此门中则有四种。云何为四。一者如石女儿无所有事。二者如兔马角无所有事。三者如龟蹙毛无所有事。四者如罗汉染无所有事。是名为四。本地修多罗中。作如是说。复次佛子。汝前所问。何等法名为无所有品者。石女儿等四种本说。我若广说其数无量。乃至广说故。如偈兼不可说无所有故。以何义故一切空法皆悉名为无所有事。有二种故。云何为二。一者彼空法体性空空如此四本说故。二者此空若不诠彼则是空故。是名为二。如是已说现示无所有事门。次当说现示具足无碍门。就此门中则有十种。云何为十。一者心主法。二者心念法。三者色主法。四者色子法。五者非契应法。六者无为法。七者非有为非无为法。八者亦有为亦无为法。九者俱俱法。十者俱非法。是名为十。言心主法者。可一八识等诸心识本法故。言心念法者。与此相应一切数法。言色主法者。可一能造大种法等。言色子法者。可一所造种种色法。言非契应法者。可一非色非心种种诸法。言无为法者。虚空等四种无为法。言非有为非无为法者。一心等诸本性法。言亦有为亦无为法者。一心等诸本性之法作业用相。言俱俱法者。大本之法其第一分。言俱非法者。大本之法其最后分。如是十法。今此门中。一有一无。一生一灭。一逆一顺。一品一类。不相舍离。是故说言现示具足无碍门焉。最胜德王广大虚空修多罗中。作如是说。不可说不可说不可说十方世界微尘之数。无量无边法门大海。一居一起一住一止。终不分剖亦不舍离。以此义故。建立称曰广大圆满虚空地地无尽无极法界大海门。乃至广说故。如偈通俱非是等诸法故

    归依德处因缘大决择分第二

如是已说归依德处无边大决择分。次当说归依德处因缘大决择分。其相云何。偈曰

  以有十种大因缘　　造作归依德处海
  所谓礼恩及加力　　广大殊胜与无我
  决定大海并赞化　　兼通现示自本身
  如是十种大因缘　　圆满大士乃能具
  凡非境圣亦非量　　随分菩萨亦不能

论曰。何因缘故归依德处。以有十种大因缘故。而作归依。如偈以有十种大因缘造作归依德处海故。云何名为十种因缘。一者礼敬尊重甚深因缘。能作礼敬归依德处。摧伏憍慢增长善根故如偈礼故。二者忆念恩泽报推因缘。而能造作胜妙论教。开晓一切狂乱众生。一切德处皆悉欢喜故。如偈恩故。三者仰请加力成为因缘。若为造作大论法门。彼诸德处不其加力。不能分别法门海故。如偈及加力故。四者开布广散令了因缘。以妙言辞示聪明诠。现了彼诸修多罗中秘密微妙深远文义大海。为令广大故。如偈广大故五者劝物令生殊胜因缘。造作论教开示文义。若不归依彼诸众生。不能究竟信受奉行故。如偈殊胜故。六者修习忍辱无我因缘。发起欢喜尊重归向。广大心故。如偈与无我故。七者出生功德决定因缘。归依德处造作论教。若见若闻。若见见者若闻闻者。若同国住。一切皆悉随时不移。出生增长无量无边一切功德善根之品。决定决定不谬违故。如偈决定故。八者大海无尽宝藏因缘。积集无量无边一切诸种种力。造作殊胜圆满大海。如意宝轮金刚德藏。为欲救度无量无边贫穷苦恼众生类故。如偈大海故。九者方便善巧教化因缘。具足者中虽无别归。而赞教化为利生故。如偈并赞化故。十者现示过去本身因缘。所归德处一切皆悉无非自身之摄持故。如偈兼通现示自本身故。是名十种大因缘相。如是广大殊胜因缘。何人所作佛菩萨作。菩萨菩萨当不能作。况凡二乘。如偈如是十种大因缘圆满大士乃能具凡非境圣亦非量随分菩萨亦不能故

大宗地玄文本论卷第一大宗地玄文本论卷第二

        马鸣菩萨造

        真谛三藏译

    一种金刚道路大决择分第三

如是已说归依德处因缘大决择分。次当说一种金刚道路大决择分。其相云何。偈曰

  一种金刚地　　总有五种位
  谓渐次究竟　　及圆满等非
  并及等是位　　如是五种位
  诸修多罗中　　具足无余说

论曰。一种金刚道路无碍本地地中。总有几位。广说虽无量。略说有五种。如是五位。一切总则。一切根本。一切中藏。一切出生。如偈一种金刚地总有五种位故。云何名为五种本位。一者无超次第渐转位。二者无余究竟总持位。三者周遍圆满广大位。四者一切诸法俱非位。五者一切诸法俱是位。是名为五种根本位。如偈谓渐次究竟及圆满等非并及等是位故。如是五位自家宣说龟则方说。如是五位直是方说非宣说量。如偈如是五种位诸修多罗中具足无余说故。位所依止本数名字。其相云何。偈曰

  所依止本数　　总有五十一
  谓虚假光明　　四十种名字
  不动真金刚　　十种本名字
  及大极地故　　是名所依数

论曰。五种本位所依止之名字差别。其数几有。广说虽无量。略说有五十一种名字。如是五十一种根本名字。一切天地一切父母。一切体性一切所依。如偈所依止本数总有五十一故。云何名为五十一数。所谓虚假光明分中有四十种。真金刚中有十种数。此五十中。加大极自然陀罗尼地故。是故成立五十一数。名字分中四十种数当何等相。所谓十种爱乐心。十种识知心。十种修道心。十种不退心。各差别故。云何名为十爱乐心。一者必叉多。二者阿摩呵尸。三者谛度毗梨耶。四者和罗只度。五者奢摩陀提尸。六者摩诃阿毗跋致多。七者阿罗婆诃尼。八者婆[口*彌]多阿梨罗诃谛。九者尸罗俱尸阿尸罗。十者摩诃毗呵阿僧那。是名为十。云何名为十识知心。一者留伽度。二者留谛迦度。三者留罗伽。四者留摩诃。五者安婆娑。六者毗跋致。七者阿毗跋致。八者必叉伽。九者必阿罗。十者留山迦。是名为十。云何名为十修道心。一者度伽呵。二者度安尔。三者度只罗。四者度和差。五者度利他。六者度生婆谛。七者度沙必。八者度阿诃。九者度佛阿。十者度叉一婆。是名为十。云何名为十不退心。一者罗谛流沙。二者罗昙沙。三者必自伽。四者法必他。五者佛度陀。六者罗叉必七者师罗文伽。八者婆诃谛。九者婆罗提弗陀。十者达摩边伽。是名为十。如偈谓虚假光明四十种名字故。云何为十真金刚心。一者鸠摩罗伽。二者须何伽一婆。三者须那迦。四者须陀洹。五者斯陀含。六者阿那含。七者阿罗汉。八者阿尼罗汉。九者阿那诃诃。十者阿诃罗弗。是名为十。如偈不动真金刚十种本名字故。此五十中。更复加婆伽婆佛陀应审观察。是名五十一种名字。如偈及大极地故是名所依数故。如是五十一种心中。彼无超次第渐转位。安立属当其相云何。偈曰

  五十一位中　　如次无超转
  一中具一切　　名为渐转位

论曰。唯一行者。五十一种别相位中回向趣入。如其次第无超过法。所以者何。此门位量法如是故。如偈五十一位中如次无超转故。如是行者。以何行相而渐渐转。谓具具转故。云何名为具具转相。谓一信心位中具余五十心而转。乃至一大极地位中具余五十心而转故。若尔一物耶异物耶。实是异物而一物故。所以者何。一信心中具一切位。非余位故。而一信中具一切位。同余余位中具一切位故。以何义故。一信心中具诸余位。更须渐转。具一中具而不能具多中具故。是故须转。今此门中五十一中。一切具具皆悉具足。方名渐转位故。如偈一中具一切名为渐转位故。摩诃衍金刚种子修多罗中。作如是说。金刚道路足行行者。以二大事而决定转。云何名为二决定转。一者遍度通达转。二者具具增长转。是名为二。言遍度通达转者。通遍经过五十一种大道路故。言具具增长转者。一一位中摄诸位故。乃至广说故。如是已说无超次第渐转门。次当说无余究竟总持门。其相云何。偈曰

  五十一位中　　随其先得入
  摄一切一切　　名无余究竟

论曰。有五十一别相位中。或有行者以信趣入。或有行者以真金地而趣入。或有行者以大极地而趣入。如是等诸行者。随其先得入位之量。尽摄一切一切位地。究竟无余。亦无移转亦无出入。一一白白。是故说言总持门位。如偈五十一位中随其先得入摄一切一切名无余究竟故。难入未曾有会修多罗中。作如是说

  回向则信心　　信心则佛地
  佛地则十地　　究竟有何次

乃至广说故。如是已说无余究竟总持门。次当说周遍圆满广大门。其相云何。偈曰

  五十一种位　　无前后一时
  俱转俱行故　　名周遍圆满

论曰。五十一位无有前后一时俱。转一时俱行无有所余。亦五十一别相位中。所有无量无边诸位。无有前后一时俱转。一时俱行无有所余。是故说言圆满位焉。如偈五十一种位无前后一时俱转俱行故名周遍圆满故。法界法轮无尽中藏修多罗中。作如是说。尔时文殊师利闻世尊所说即从坐起。合掌顶礼前白佛言。世尊。云何名为横转无向修道人者。如宜世尊为诸大众。宣说开示如是大事。于是世尊即告文殊师利言。一种无二一道一区。大地行者一切行道。无前无后一时发起。一时同转一时住持。一时证入。一时安立。是名横转无向道人。乃至广说故。如是已说周遍圆满广大门。次当说一切诸法俱非门。其相云何。偈曰

  诸无量无边　　一切种种位
  皆悉非建立　　名俱非位地

论曰。今此偈中为明何义。为欲现示此俱非门非因非果非位非地非有非无非名非义非事非理非坏非常非生非灭一切一切皆悉非故。如偈诸无量无边一切种种位皆悉非建立名俱非位地故。若尔以何义故建立位名。以其非义立为位故。大明修多罗中。作如是说。无位位第一位。乃至广说故。如是已说一切诸法俱非门。次当说一切诸法俱是门。其相云何。偈曰

  一切种种法　　无非金刚身
  以一身义故　　名为俱是门

论曰。无量无边一切位法。一切皆悉是金刚身。等无差别唯依一身。是故说言俱是门焉。所以者何。今此门中。无一一法而非金刚真实身故。如偈一切种种法无非金刚身以一身义故名为俱是门故。种金大地修多罗中。作如是说。无病道人唯见积影。不见散身故

    金刚实轮山王大决择分第四

如是已说一种金刚道路大决择分。次当说金刚宝轮山王大决择分。其相云何。偈曰

  渐是尽满非　　一时及前后
  与俱并俱非　　一异时处转

论曰。今此偈中为明何义。为欲现示一身。金刚大力宝轮山王体中次第渐转诸法等是无余究竟周遍圆满俱非绝离。此五种位。一时转前后转。俱有转俱非转。亦一时转亦异时转。亦一处转亦异处转。具足具足自在自在无所障碍故。大严尽地虚空法界修多罗中。作如是说。复次龙明。汝前所问。云何名为金刚本身广大地地无障无碍恒沙功德品者。殊胜极妙不可思议不可思议。五种金刚道路足行地地。无尽中藏之根本自性。出生增长所依止藏。乃至广说故

大宗地玄文本论卷第二大宗地玄文本论卷第三

        马鸣菩萨造

        真谛三藏译

    金轮山王道路大决择分第五

如是已说金刚宝轮山王大决择分。次当说金轮山王道路大决择分。其相云何。偈曰

  山王道路中　　总有十五位
  体五种位中　　各有三用故

论曰。此金轮山王道路中。建立几位为道路量。广说虽无量。略说有十五种位。以如是位为道路分。如偈山王道路中总有十五位故。以何因缘。分明了知此道路中有十五种根本之位。谓彼金刚大力宝轮山王体五种位中。皆悉各各有三种自在作用故。以此义故。成立十五差别名数。如偈体五种位中各有三用故。故方修多罗中。作如是说。一区王民行地地中。唯有十五种体分业数位无所余位。乃至广说故。然明神妙理修多罗中。作如是说。有二十五种差别位者。取王家转非取作转故。造作转摄十五种位。名字形相当如何耶。偈曰

  明了及远数　　相续并三合
  遍动遍不动　　字等兼广大
  遍到不遍到　　融立与俱离
  是名十五名　　如次应观察

论曰。就次第渐转体中。则有三种用。云何为三。一者分明了达审地作用。不乱次第建立位地。行道分明名义俱了故。如偈明了故。二者远行远修无数作用。经无量劫过此诸位。修集功德无穷尽故。如偈及远数故。三者无断无绝恒转作用。刹那刹那中间中间。常恒不息自然转故。如偈相续故。是名为三。就诸法等是体中。亦有三种用。云何为三。一者能诠能了一合作用。善巧言说无碍觉慧。其数无量一金刚故。二者所诠所证一合作用。甚深极义胜妙玄理。唯是一区唯是一身。无二岐故。三者随应有名一合作用。随其所应一切有名一切皆悉一金身故是名为三。如偈并三合故。就无余究竟体中。亦有三种用。云何为三。一者周遍圆满动转作用。第一时中依一位中。通摄一切而究竟转故。如偈遍动故。二者周遍圆满不动作用。如是转者所余一切无量位中。不移不转常决定故。如偈遍不动故。三者名句文字无别作用。随其先唱与余一故。如偈字等故。是名为三。就周遍圆满体中。亦有三种用。云何为三。一者无量无边广大作用。其法自体出现业相。尽极广大无分界故。如偈广大故。二者无碍通达遍到作用。一时建立一切位故。如偈遍到故。三者极极无数不遍作用。遍通经过而唯有一边故。如偈不遍到故。是名为三。就俱非绝离体中。亦有三种用。云何为三。一者消融无所建立作用。一切诸法皆悉遣除无所许故。如偈融故。二者建立诸法悉持作用。一切诸法以俱非义是理成故。如偈立故。三者消融建立俱绝作用。究竟绝道广建立故。如偈与俱离故。是名为三。是为十五种位名字焉。此道路位。大利根者乃能通达。钝根众生决定难了。如偈是名十五名。如次应观察故。如是诸位。亦一时出兴亦异时出兴。亦俱时出兴。亦一处转。亦异处转。亦俱处转。亦不出兴亦不移转。亦唯一种亦是多种。于彼本法有作功用有作方便。自然自在建立造作。应审观察

    独一山王摩诃山王大决择分第六

如是已说金轮山王道路大决择分。次当说独一山王摩诃山王大决择分。其相云何。偈曰

  摩诃山王中　　总有千二百
  七十五种位　　谓五十一种
  大根本位中　　皆一一各各
  渐转等五位　　具足安立故

论曰。此独一山王摩诃山王体中。建立几位以为体分。广说虽无量。略说其要。唯有一千二百七十五种决定位故。如偈摩诃山王中总有千二百七十五种位故。以何因缘。山王体中有千二百七十五位分明现知。所谓常恒五十一种根本位中。一一各各次第渐转诸法等。是无余究竟周遍圆满俱非绝离五种位具足转故。亦渐转等五种位中。各各开示渐转等五种别位故。是故成立一千二百七十五位。如偈谓五十一种大根本位中。皆一一各各渐转等五位具足安立故。故此独一山王摩诃山王体中。如是千二百七十五种位亦一一时转。亦异一时转。亦俱一时转。亦皆非转。亦一时一处转。亦一时异处转。亦异时异处转。亦皆非转。自在自然无障无碍。是故说言无尽虚空大陀陀筏罗法界本藏地地出生无穷无极广德大海法门藏焉。大智庄严法界性身甚深修多罗中。作如是说。非比非喻难得惟说。大海中藏大海一体。本地地中三品德类。具足圆满无所阙失。云何为三。一者上品德类。其位名字众多无数。与十方世界微尘之数其量等故。二者中品德类其位名字。与百百百亿三千大千世界微尘之数其量等故。三者下品德类。其位名字。有一千二百七十五位故。是名为三。如是诸位一一一一一一。乃至无量无量无量无量无量无量。乃至广说故

大宗地玄文本论卷第三大宗地玄文本论卷第四

        马鸣菩萨造

        真谛三藏译

    大海部藏道路大决择分第七

如是已说独一山王摩诃山王大决择分。次当说大海部藏道路大决择分。其相云何。偈曰

  大海部藏中　　总有十种法
  谓五种非空　　及五种无常

论曰。此大海部藏道路分中。建立几法为部藏量。所谓建立十种法体。以为大海部藏分故。摩诃衍地修多罗中。作如是说。俱俱海藏履道分中。唯有十法无有余法。乃至广说故。如偈大海部藏中总有十种法故。以何义故有十应知。五种非空五种无常。各差别故。如偈谓五种非空及五种无常故。彼十种法。其名字相当如何耶。偈曰

  离碍及有实　　性火并今光
  兼深里出兴　　地藏大龙王
  如是五种名　　非空不共称
  起持变坏品　　与大力无明
  如是五种名　　无常不共称
  各有第一一　　以请气力故
  立门实本摄　　如法应观察

论曰。云何名为五种非空决定住法。一者离碍非空决定住法。二者有实非空决定住法。三者性火非空决定住法。四者今光非空决定住法。五者深里出兴决定住法。是名为五。如偈离碍及有实性火并今光兼深里出兴地藏大龙王故。如是五名。五种非空决定住法。不共异转差别名字。如偈如是五种名非空不共称故云何名为五种无常虚假转法。一者动起无常虚假转法。二者止持无常虚假转法。三者易变无常虚假转法。四者散坏无常虚假转法。五者大力无常虚假转法。是名为五。如偈起持变坏品与大力无明故。如是五名。五种无常虚假转法。不共异转差别名字。如偈如是五种名无常不共称故。深里大力如是二法。气力立门非取实体。应审观察。如偈各有第一一以请气力故立门实本摄如法应观察故。如是已说建立名字不同门。次当说所诠义理差别门。如是五种非空决定住法。各有几数。所谓各各有二种故。云何名为二种离碍。一者守身离碍。二者变转离碍。言守身离碍者。无障碍身常恒决定不失坏故。言变转离碍者。建立万有令自在故。是名为二。云何名为二种有实。一者守身有实。二者变转有实。言守身有实者。常平等身常恒决定不失坏故。言变转有实者。建立差别令安住故。是名为二。云何名为二种性火。一者守身性火。二者变转性火。言守身性火者。明德藏身常恒决定不失坏故。言变转性火者。尘累俱转随顺成故。是名为二。云何名为二种今光一者守身今光。二者变转今光言守身今光者。始炎炎身决定常恒不失坏故。言变转今光者。随顺流转无所碍故。是名为二。云何名为二种深里。一者守身深里。二者变转深里。言守身深里者。离绝中身常恒决定不失坏故。言变转深里者。诸无为中得自在故。是名为二。如前所说。五种无常业用差别。各各如何。所谓如次出生一切无量无边大过患海。皆无余故。住持一切无量无边大过患海。皆无余故。变易一切无量无边大功德海。皆无余故。坏灭一切无量无边大功德海。皆无余故。覆障非德非患中身自在。皆无余故。如是五法。自体及品各各差别。应审观察如是已说所诠义理差别门。次当说依位决定安立门。如前所说。五十一种真金刚位。遍几处耶。偈曰

  如是五十一　　遍于五种处
  大聪明行者　　能善决择知

论曰。如前所说。五十一位。遍离碍等五种处中。无所不至无所不通。以此义故。大金刚位有五应知。如偈如是五十一遍于五种处故。如是位地利根能知。非钝者境所以者何。极甚深故。极利了故。极秘密故。如偈大聪明行者能善决择知故。亦复处二故位亦二应知。是故具集有十而已。然今所说是变非身。别建立位总几数有。字身差别其相云何。偈曰

  别建立位数　　总有十种焉
  渐次及尽余　　不动与俱灭
  一空一有位　　智智断智地
  相值兼拨立　　边边转一会
  具足此十位　　门界量圆满

论曰。别建立位总有十种。云何为十。一者一向无超渐次位。二者遍究竟尽不尽位。三者一切中际不动位。四者双立诸法俱灭位。五者若一空当一有位。六者能断所断悉智位。七者熏力相对相值位。八者随除障处立位位。九者真妄得边有无位。十者诸法一种一会位。是名为十。如偈别建立位数总有十种焉。渐次及尽余不动与俱灭。一空一有位智智断智地。相值兼拨立边边转一会故。随有一别建立彼总。必当具足一切别位。方得建立大总位耶。必当具别总得成故。如偈具足此十位门界量圆满故。如是十种别相之位。遍于几处。遍五处故。所谓转摄五种处中。各具五十一金刚位。经过诸位亦有十种别相位故。大总相位总有几数。遍几处耶偈曰

  总位有三种　　谓上中下故
  唯遍五种处　　非余位应知

论曰。大性总地根本体位。总有三种。云何为三。一者趣高上上转去位。二者自然安住中中位。三者向焉下下转去位。是名为三。如偈总位有三种。谓上中下故故如是三总随别有有。唯遍转五非所余位。应审观察。如偈唯遍五种处非余位应知故。如是已说依位决定安立门。次当说依位法数具阙门。如前所说。十种本法守转二种。金刚位中为尽不尽。谓若守位中。唯具德五无所余五。若转位中。十法具足无所阙失。以此义故。总别二门有无亦了。如是已说依位法数具阙门。次当说德患对量现宗门。其相云何。偈曰

  起性止及今　　变空坏并实
  力龙如次对　　有似而取多

论曰。治障照覆对量形相。如其次第动起无常。性火住法止持无常。今光住法易变无常。离碍住法散坏无常。有实住法大力无常。出兴龙王以之为量。如偈起性止及今变空坏并实力龙如次对故。如是对量。一向转耶。俱量转耶。俱量应知。如偈有似而取多故。如是已说德患对量现宗门。次当说随次别释广说门。且离碍门安布形相现示云何。主伴治障当如何耶。偈曰

  离碍身体中　　有五十一位
  五十一位中　　有三种总相
  三种总相中　　有十种别相
  初五十一中　　一一皆各各
  具足十本数　　最初主后伴
  次初主后伴　　如次应观察

论曰。就离碍中。有五十一种金刚位。就此位中。有三种根本总相位。就此总中。有十种分离别相位。如偈离碍身体中有五十一位。五十一位中有三种总相。三种总相中有十种别相故。金刚诸位一一位中皆具本数。如偈初五十一中一一皆各各具足十本数故。主伴各二。云何二主。一者主主。二者伴主。云何二伴。一者伴伴。二者主伴。言主主者。是离碍故。言伴主者。第二转故。言伴伴者。除五本法余眷属故。言主伴者。除其离碍余四法故。如偈最初主后伴次初主后伴如次应观察故。三种总相金刚位中。云何安立。谓初信心以为其始。后[襌-(田/十)+(王*寸)]陀地以为其终。次第渐转。是故建立趣高上上转去位。后[襌-(田/十)+(王*寸)]陀地以为其始。第一信心以为其终。次第渐转。是故建立向焉下下转去位。上下二门位位各各离边中道决定安立。是故建立自然安住中中位。以此义故十种别相唯有上下不有中焉。且依上门建立十位。形相云何。偈曰

  信五事已经　　至后后位故
  一事究竟故　　一味中转故
  治障一灭故　　治障不俱故
  以智断智故　　上下相照故
  本无今有故　　治障自辨故
  无别一转故　　如次应观察

论曰。依趣高上上转去门见十别位形相如何。谓以五种非空住法。对治五种虚假转法。如其次第无有超过。渐渐转故。建立一向无超渐次位。如偈信五事已经至后后位故。故以五事治五事随其所应一究竟故建立遍究竟尽不尽位。如偈一事究竟故。故以五事治五事。不增不减不大不小一味平等中道实相故。建立一切中际不动位。如偈一味中转故。故以五事治五事。随障灭时其智慧体则便灭故。建立双立诸法俱灭位。如偈治障一灭故。故以五事治五事。治起无障障起无治。不能亲近不能俱行不能及达故。建立若一空当一有位。如偈治障不俱故。故以五事治五事。治胜气力变一切障为治眷属。亦以胜力断眷属故。建立能断所断悉智位。如偈以智断智故。故以五事治五事。随其所应上位下位互相照达。随其所应断除障故。建立熏力相对相值位。如偈上下相照故。故以五事治五。事随所断障虚妄无本。安立位地亦无本故。建立随除障处立位位。如偈本无今有故。故以五事治五事。治皆明净障皆闇冥。彼治断事悉已成辨。此障覆用悉已具足故。建立真妄得边有无位。如偈治障自辨故。故以五事治五事。治障二法无二无别一味平等一体一性一业一用故。建立诸法一种一会位。如偈无别一转故。故如是诸位如偈释说。专心观察其理分明本趣具现。如偈如次应观察故。是名为依离碍门安立诸位总别现示上上差别。次依下门建立十门。形相云何。偈曰

  如前说十义　　随应当如如
  坏得体归空　　渐次第转故

论曰。依向焉下下转去门。见十别位。形相如何。谓如前所说十种义中。随其所应顺顺如如。坏其得体归空本存故。如偈如前说十义随应当如如坏得体归空故。如是诸位为一时转。前后转耶。以前后转非一时故。如偈渐次第转故。故于余诸法如是如是。随随如如说示造作。应审观察其别转相。是本存故是本主故。皆悉各各如是二转。一时前后有二义故。云何为二。一者建立转。前后定故。二者本性转。无前后故。是名为二。如前所说种种诸门。同名异物。住思应观

    深里出兴地藏大龙王大决择分第八

如是已说大海部藏道路大决择分。次当说深里出兴地藏大龙王大决择分。其相云何。偈曰

  地藏龙王中　　总有二种义
  所谓德藏义　　并及患藏义

论曰。就深里出兴地藏大龙王体中。则有二义。云何为二。一者功德本藏义。二者过患本藏义。言功德本藏义者。此大龙王为四非空根本藏故。言过患本藏义者。此大龙王为四无常根本藏故。如偈地藏龙王中总有二种义。所谓德藏义并及患藏义故。具二藏义。地藏龙王居住何处。其里几量长短大小等诸形相。当如何耶。偈曰

  处唵婆尸尼　　里五十一量
  长一千由旬　　头有婆多提
  则出四种水　　尾有舍伽必
  则出四种风　　色如玻璃珠

论曰。今此偈中为明何义。为欲现示举事现理开演本法大海故。此大龙王居于何处。谓居唵婆尸尼中故。如偈处唵婆尸尼故。出水入地去隔几量。谓从水底向地下入。五十一由旬之量故。如偈里五十一量故。彼大龙王身长几量。一千由旬无增减故。如偈长一千由旬故。彼大龙王于其头上。有清白毫名曰婆多提。从此毫端出四种水。云何为四。一者中空水。其出水尘。空以为内有以为外。而出生故。二者方等水。其出水尘四角量等无差违故。三者常熟水。其出水尘。于一切处于一切时。常恒暖故。四者耀明水。其出水尘。光明清白常恒今故。是名为四。如偈头有婆多提则出四种水故。亦彼龙王于其尾末。有一毛[葉-世+玨]名曰舍伽。必从此毛末。出四种风。云何为四。一者发尘风。此风起时经多中间。发起无量无边尘故。二者持尘风。此风出时。止住诸尘令安住故。三者变珍风。此风出时经多中间。变诸金玉作砂石故。四者坏珍风。此风出时经多中间。坏灭金玉作无有故。是名为四。如偈尾有舍伽必则出四种风故。彼龙身色譬如玻璃无有定色。如偈色如玻璃珠故。处唵婆尸尼者。喻本性王无住本处。里五十一量者。喻真金位定数量品。长一千由旬者。喻本性王具千种德。头有婆多提者。喻本性王于诸净品有作方便。则出四种水者。喻四非空。尾有舍伽必者。喻本性王于诸染品有作业用。则出四种风者。喻四无常色。如玻璃珠者。喻本性王染净不摄。如其次第应审思择。复次住处大海水底相去中间。喻五十一种金刚位已具。出现至大海时。喻杂类趣。息海浪时喻起善心时。常起浪时喻恶心兴时。亦复住心应审观察。本行上地一味平等妙法无边业用具足大海宝轮妙严王子修多罗中。作如是说。生四道法不四道摄离绝中心。生四轮法不四轮摄离绝中心。而立名字。说大力无明者。随所生法建立名故。乃至广说故

大宗地玄文本论卷第四大宗地玄文本论卷第五

        马鸣菩萨造

        真谛三藏译

    深里出兴地藏大龙王道路大决择分第九

如是已说深里出兴地藏大龙王大决择分。次当说深里出兴地藏大龙王道路大决择分。其相云何。偈曰

  龙王道路中　　总有二十法
  谓二本藏中　　各有十法故

论曰。就深里出兴地藏大龙王道路中。总有二十中自在法。所以者何。功德过患二种藏中各有十故。如偈龙王道路中总有二十法。谓二本藏中各有十法故。故彼二十法。名字形相当如何耶。偈曰

  功德本藏十　　常坏俱及非
  自他俱并非　　无碍兼一全
  过患本藏十　　如一违无有
  对利融上下　　如次应观察
  如是二十法　　一一皆各各
  圆满广大故　　与本存等量

论曰。就功德本藏之体中。则有十法。能摄一切无量功德。云何为十。一者本体自性决定常住不生不灭远离流转功德品。二者本体自性常恒移转是生是灭流转俱行功德品。三者决定常住常恒无常一时俱转无前后违功德品。四者出常无常二事不摄自体本性离脱亡行功德品。五者十种自自摄一切法无有所余独一无二一种一行功德品。六者无体无性从因缘起亦有亦无随应变转功德品。七者无余究竟俱转俱行不相舍离功德品。八者非自非他绝离有名住于非非自性决定功德品。九者于一切法随应无碍自体自性法尔道理性造如是功德品。十者五根一一根五尘一一尘一切诸法亦复如是功德品。是名为十。如偈功德本藏十常坏俱及非自他俱并非无碍兼一全故。就过患本藏之体中。亦有十法。能摄一切无量过患。云何为十。一者于一切法随顺如如如作逆事过患品。二者造作诸法同一业用一作逆事过患品。三者治道起时无有定体违作逆事过患品。四者染净诸法皆无所有无作逆事过患品。五者一切诸法皆总有有有作逆事过患品。六者随治同量如如现前对作逆事过患品。七者由治道力自类增益利作逆事过患品。八者由治道息发起自用融作逆事过患品。九者待上转者方得起用上作逆事过患品。十者以隐藏时方得起用下作逆事过患品。是名为十。如其次第住思止心。专心观察其理故明。如偈过患本藏十如一违无有对利融上下如次应观察故。如是二十法。与彼本方等无差别。是故有二十种本藏。无相违过。所以者何。其本藏中如是道理自然常有。不从本藏长建立故。何故处处皆存品字。如前所说二十种法。各各有百眷属类故。是故言品。例前应了。如偈如是二十法一一皆各各圆满广大故与本存等量故。如是已说建立名字门。次当说所诠义理门。且治及障对量差别。当如何耶。偈曰

  如是二十法　　一一皆各各
  一德治诸过　　诸过障一德
  无有定次第　　而数品类等
  无失对量过　　如理应观察
  如说本存法　　说品类亦尔

论曰。如前所说二十种法。一一各各一德治一切障。一切障障一德。无别对量。如偈如是二十法一一皆各各一德治诸过。诸过障一德无有定次第故。若如是说。今此门中对量轨则混成杂乱。虽无别对量而有总对量。是故无失。如偈而数品类等无失对量过如理应观察故。如本品尔例前应了。如偈如说本存法说品类亦尔故。如是已说治障对量差别门。次当说安立金刚位地门。其相云何。偈曰

  此本法门中　　亦有金刚位
  依位有三门　　谓上中下门

论曰。就此本法门中。亦有五十一金刚位。如上所说二十种法。依位安立。云何安立。谓诸位中皆具二十。无有前后一时转故。然则此中有三种门。云何为三。一者一向上转门。二者一向下转门。三者一向中转门。是名为三。如是三门各各一一位中具足俱转。不待初后际故。如说本法品类亦尔。以此小门广大回持。应广通达。如偈此本法门中亦有金刚位依位有三门谓上中下门故

    大龙王重重广海无尽大藏大决择分第十

如是已说深里出兴地藏大龙王道路大决择分。次当说大龙王重重广海无尽大藏大决择分。其相云何。偈曰

  广海大藏中　　总有三种重
  谓初中后重　　初重有二十
  二亿十方界　　量法门大海
  二十种本藏　　各生一万量
  各别百眷属　　各生一千故
  是故数圆满　　住心应观察
  中后重倍此　　应广通达故

论曰。就大龙王重重广海无尽大藏之自家中。总有三重。能摄诸位。云何为三。一者初第一有重。二者中安住居重。三者后建立转重。是名为三。就第一重中。则有二十二亿十方世界之量种种胜妙法门大海。此义云何。谓二十种本藏法中。一一各各出生一万法门大海。各各别别百眷属中。一一各各出生一千法门海故。以此义故名字圆满义理具足。如其次第安住其心定止其思。聪明观察其数量理及所诠意现了分明。如偈广海大藏中总有三种重。谓初中后重。初重有二十二亿十方界量法门大海二十种本藏。各生一万量。各别百眷属各生一千故。是故数圆满。住心应观察故。次二种重。如其次第倍前普布应广通达。如偈中后重倍此应广通达故。故大摩尼宝藏陀罗尼修集修多罗中作如是说。龙龙地地大无尽海藏中。有多十方之量法门轨则品类。最初名为转大法论具足一海无极无尽引导光明现照地地本业本用出生增长轨则大海法门。最后名为有性无性无我空理大利益广光明亦离脱亦合转具足具足无边摩诃行种地本藏法雨腾门出兴上味品类法门。唯取一界以为譬喻非取尘等。乃至广说故

大宗地玄文本论卷第五大宗地玄文本论卷第六

        马鸣菩萨造

        真谛三藏译

    无尽无穷尘尘数量道路大决择分第十一

如是已说大龙王重重广海无尽大藏大决择分。次当说无尽无穷尘尘数量道路大决择分。其相云何。偈曰

  尘尘道路中　　如前所说量
  亦有五十一　　决定金刚位
  依此位立相　　则有十种重
  以为道路量　　二因一果等

论曰。就此门中有几数位。五十一种真金刚位。具足圆满无阙失故。如偈尘尘道路中如前所说量亦有五十一决定金刚位故。就此位中。则有十种变对法门。能摄门量。云何为十。一者二因一果门。二者一因一果门。三者少因多果门。四者因果一味门。五者无因无果门。六者自然安住门。七者因果门。八者果因门。九者言说门。十者言人门。是名为十。如是十门以为门量。如偈依此位立相则有十种重以为道路量二因一果等故。彼第一门形相如何。偈曰

  以信心为初　　如次率自类
  取所余位初　　至于定心位
  则取如来地　　亦如其次第
  不退心为初　　率同品自类
  取余位第二　　至于愿心位
  亦取如来地　　修行位为初
  如次率自类　　取余位第三
  至于正心位　　亦取如来地
  不退位为初　　如次率自类
  取余位第四　　至灌顶住位
  亦取如来地　　离痴行为初
  如次率自类　　取余位第五
  至于无著行　　亦取如来地
  尊重行为初　　如次率自类
  取余位第六　　至于真实行
  亦取如来地　　随顺观众生
  回向以为初　　如次率自类
  取所余四位　　各数量契当
  余有如来地　　以同地为伴
  庄严一觉海　　各因及果称
  配释广观察　　其理当分明

论曰。今此门中为明何义。为欲现示五十一位皆为同量。以二种因感得一果。广三宝海无穷尽故。此义云何。所谓信心及发心地之二种因。同一行相不相舍离。俱行合转住一所作。起无量具生无边德。具足庄严一大觉海。能生长因。名为最上第一出生增长决定真实本藏原母远离系缚庄严无胜地种子海会所庄严。果名为具足真金刚。圆满大慈悲法身虚空等无差别最初地地无上极海一尽大觉无二山王。次念心地欢喜行地之二种法。能长养因。具足庄严一大觉海。因名为安乐常明决定增长无苦无妄自然照达一切法性无所障碍种子海会。果名为常乐总明大虚空界甚深恒了无二山王。次精进心地救护一切众生回向地之二种法。能长养因。具足庄严一大觉海。因名为发起殊胜大悲光水远离懈怠常度常行本地自性具足通达种子海会。果名为慈悲光明常恒达慧无二山王。次慧心地逆流欢喜地之二种法。能长养因。具足庄严一大觉海。因名为大真金刚日月光明自性离苦除断闇品种子海会。果名为极极重地无上一体自然穷了无二山王。次定心地大极地地之二种法。能长养因。具足庄严一大觉海。因名为决定安寂远离散乱照曜无穷水水火火种子海会。果名为寂圆满地明圆满地具足德藏无二山王。如是诸佛皆悉各各作三大事。云何为三。一者兴化。二者说法。三者胜进。言兴化者。出兴一十方世界之尘量变化身故。言说法者。宣说一十方世界之尘量发心信地法门海故。言胜进者。向上上位如次入故。是名为三。就变化中亦皆各各有此三事。应广通达。如是如是随随如如。后后诸位例前应知。如偈以信心为初如次率自类取所余位初至于定心位则取如来地故。如是已说二因一果门。次当说一因一果门。其相云何。偈曰

  五十一种位　　各不待他力
  独住自家中　　感得一果故
  因及果名字　　如其次第加
  种子大觉故　　配释应了知
  次第同前说　　增减不同耳

论曰。今此偈中为明何义。为欲现示因果二法数量契当庄严觉道。三宝之海转广大故。如偈五十一种位各不待他力独住自家中感得一果故。故因及果称于本名字。加种子大觉之称故。如偈因及果名字如其次第加种子大觉故配释应了知故。次第转相与前所说等无差别。唯增数量减数量别各不同耳。如偈次第同前说增减不同耳。故如是诸佛皆悉各各作三大事。名同前说义有不同。言兴化者。出兴十十方世界之尘量变化身故。言说法者。宣说十十方世界之尘量各各因位法门海故。言胜进者。向上上位如次入故。就变化身中。亦有此三事。应广通达。如是已说一因一果门。次当说少因多果门。其相云何。偈曰

  五十一位中　　一一皆各各
  感五十果位　　名少因多果

论曰。今此门中为明何义。为欲现示唯一种因感五十果。无碍自在无所阙失。三宝之海转广大故。如偈五十一位中一一皆各各感五十果位名少因多果故。如是诸佛皆悉各各作三大事。名如前说义有不同。言兴化者。出兴百十方世界之尘量变化身故。言说法者。宣说百十方世界之尘量各各因位法门海故。言胜进者。向上上位如次入故。就变化中有此三事。应广通达。如是已说少因多果门。次当说因果一味门。其相云何。偈曰

  五十一位中　　一一皆各各
  有五百果海　　五百果海中
  一一皆各各　　有五百因海
  如是平等故　　名因果一味

论曰。今此门中为明何义。为欲现示因果二法数量契当无有增减。三宝之海转广大故。如偈五十一位中一一皆各各有五百果海。五百果海中一一皆各各有五百因海。如是平等故名因果一味故。如是诸佛所作三事。亦复同前唯义异耳。所谓千故。变化身相亦复如是。如是已说因果一味门。次当说无因无果门。其相云何。偈曰

  五十一位法　　非因亦非果
  生千因果法　　名无因无果

论曰。今此门中为明何义。为欲现示五十一位因而不有果。因出生千因之大海果而不有因。果出生千。果之大海。三宝之海转广大故。如偈五十一位法非因亦非果生千因果法名无因无果故。如是诸佛所作三事。亦复同前唯义异耳。所谓万故。如是已说无因无果门。次当说自然安住门。其相云何。偈曰

  五十一位中　　一一皆各各
  经无量劫转　　不出自家故

论曰。今此门中为明何义。为欲现示位位皆各经无量劫以修行成道等事转无其分际。三宝之海转广大故如偈五十一位中一一皆各各经无量劫转不出自家故。故如是诸佛所作三事。亦复同前唯义异耳。所谓亿故。如是已说自然安住门。次当说因果门。其相云何。偈曰

  生五十一位　　生五十一位
  所生无尽故　　名为因果门

论曰。今此门中为明何义。为欲现示能生能生无有穷尽。所生所生无有穷尽。三宝之海转广大故。如偈生五十一位生五十一位所生无尽故名为因果门故。如是诸佛所作三事。亦复同前唯义异耳。谓十亿故。如是已说因果门。次当说果因门。其相云何。偈曰

  此义例前了　　无别意趣耳
  唯有数量增　　住心应观察

论曰。今此门中为明何义。为欲现示五十一位亦因亦果各生无尽无尽因果大海法门。三宝之海转广大故。如偈唯有数量增故。如是诸佛所作三事。亦复同前唯义异耳。谓百亿故。如是已说果因门。次当说言说门。其相云何。偈曰

  一切三宝海　　皆悉起言说
  无有穷尽故　　名为言说门

论曰。今此门中为明何义。为欲现示一切三宝皆悉各各宣说无尽僧海无尽法海无尽觉海。三宝之海转广大故。如偈一切三宝海皆悉起言说无有穷尽故名为言说门故。如是诸三宝所作三事。亦复同前唯义异耳。谓千亿故。如是已说言说门。次当说言人门。其相云何。偈曰

  一切三宝说　　如说量作人
  无有穷尽故　　名为言人门

论曰。今此偈中为明何义。为欲现示如前所说诸三宝说如所说量。造作行者无有穷尽。三宝之海转广大故。如偈一切三宝说如说量作人无有穷尽故名为言人门故。如是诸人。成道已讫所作三事。亦复同前唯义异耳。谓万亿故。大明总持具足心地修多罗中。作如是说。譬喻十方无际无本无始无终道行足履地地法藏中。有十种殊胜转转增长倍倍具足圆满广大法门海会。乃至广说故

    不可思议不可称量俱俱微尘本大山王大决择分第十二

如是已说无尽无穷尘尘数量道路大决择分。次当说不可思议不可称量俱俱微尘本大山王大决择分。其相云何。偈曰

  不思议海中　　则有三种法
  谓三重倍故　　配释应了知

论曰。就不可思议本大山王体性中。则有三种。云何为三。一者法宝数量倍。二者僧宝数量倍。三者佛宝数量倍。是名为三。增几数量作倍义耶。谓增益亿亿十方世界之微尘数量三宝海故。如其次第。依道路十增一种倍。应审观察。如偈不思议海中则有三种法。谓三重倍故配释应了知故。末末三倍依本家说。应广通达。心地修多罗中。作如是说。俱尘无上不可思议根本性海分中。具足圆满亿亿大方三德大海。以大方分建立大方。乃至广说故

大宗地玄文本论卷第六大宗地玄文本论卷第七

        马鸣菩萨造

        真谛三藏译

    不可思议俱俱微尘一切山王道路大决择分第十三

如是已说不可思议不可称量俱俱微尘本大山王大决择分。次当说不可思议俱俱微尘一切山王道路大决择分。其相云何。偈曰

  微尘道路中　　有十方界量
  五十一本位　　名与前说等
  一五十一中　　一一皆各各
  有十方界量　　障治三宝海
  如一余亦尔　　配此应了知

论曰。就俱俱微尘道路中。则有一十方世界之数量五十一根本位。其名字量与前说等无有差别。如偈微尘道路中有十方界量五十一本位名与前说等故。就一五十一种位中。一一各各有十方世界之数量。烦恼大海对治大海僧宝大海法宝大海佛宝大海。具足转故。如偈一五十一中一一皆各各有十方界量障治三宝海故。如说一五十一种位。余一切位亦复如是。如偈如一余亦尔配此应了知故。如是已说现示本体安立门。次当说现示上末转相门。其相云何。偈曰

  今此道路佛　　出兴小无量
  法及化大海　　第二转觉者
  出兴中无量　　法及化大海
  第三转觉者　　出兴大无量
  法及化大海　　后后诸转中
  如次第无超　　渐渐增数量

论曰。依一本信出兴觉者。总有一十方世界之数量。其中一佛成道已讫。则便出兴小无量十方世界之微尘数量。无碍自在化身大海。如是数量信心大海。如偈今此道路佛出兴小无量法及化大海故。依此佛身出兴化身。总有小无量十方世界之微尘数量。其中一佛出兴已讫。则便出兴中无量十方世界之微尘数量。无碍自在化身大海。如是数量信地大海。如偈第二转觉者出兴中无量法及化大海故。依此化身出兴化身。总有中无量十方世界之微尘数量其中一佛出兴已讫。则便出兴大无量十方世界之微尘数量。无碍自在化身大海。如是数量信地大海。如偈第三转觉者出兴。大无量法及化大海故。如是如是随随如如。后诸转中如次无超渐渐增数。如偈后后诸转中如次第无超渐渐增数量故。举此一隅应广通达。本品足地智修多罗中。作如是说。大地微尘譬喻大海履行无住法门。第一转中小无量大方微尘之数品第二转中中无量品。第三转中大无量品。第四转中无边无量品。第五转中无数无量品。第六转中无量无量品。第七转中不可计量无量品。第八转中具足无量品。第九转中不可说无量品。第十转中不可思议无量品。乃至广说故

    一切虚空一切微尘数量高王大决择分第十四

如是已说不可思议俱俱微尘一切山王道路大决择分。次当说一切虚空一切微尘数量高王大决择分。其相云何。偈曰

  虚空微尘中　　则有十方量
  十方尘空量　　五十一本位
  一五十一中　　一一皆各各
  有如前说量　　障治三宝海

论曰。就一切虚空一切微尘数量高王分中。则有十方世界之尘量十方世界之尘量五十一种根本位。十方世界之尘量十方虚空之尘量五十一种根本位。如偈虚空微尘中则有十方量十方尘空量五十一本位故。就一五十一种根本位中。一一各各有十方世界之尘量十方世界之尘量。十方世界之尘量十方虚空之尘量。烦恼大海对治大海僧宝大海法宝大海佛宝大海。具足转故。如偈一五十一中一一皆各各有如前说量障治三宝海故。如是已说现示本体安立门。次当说现示上末转相门。其相云何。偈曰

  此本王觉者　　前数倍十重
  兴化宣说法　　大聪明能了
  后后诸转中　　如次第无超
  渐渐增数量　　转胜广大转

论曰。今此门中为明何义。为欲现示依一本信出兴觉者。其中一佛譬喻。譬喻之数量增益十重。出兴变化宣说信地。后后转中渐渐增数。百千万亿乃至无量无穷尽故。如偈此本王觉者前数倍十重兴化宣说法大聪明能了后后诸转中如次第无超渐渐增数量转胜广大转故。地智修多罗中。作如是说。可一总持大周遍王之自体。转相无量无边。譬喻量说转化时中。渐增数量满玄数量。乃至广说故

大宗地玄文本论卷第七大宗地玄文本论卷第八

        马鸣菩萨造

        真谛三藏译

    独地非乱一定一定道路大决择分第十五

如是已说一切虚空一切微尘数量高王大决择分。次当说独地非乱一定一定。道路大决择分。其相云何。偈曰

  非乱道路中　　亦有金刚位
  一一位各各　　有本存一故
  一百二数成　　依位立转相
  则有五种重　　谓上一本一
  俱转及不杂　　圆满具足位

论曰。就独地非乱一定一定道路分中。亦有五十一种真金刚位。一一位位皆悉各各有本存一。以此义故。一百二数成立而已。如偈非乱道路中亦有金刚位一一位各各有本存一故一百二数成故。依如是位。建立转相则有五种。云何为五。一者上上一一转相门。二者本本一一转相门。三者俱行不离转相门。四者区区不杂转相门。五者圆满具足转相门。是名为五。如偈依位立转相则有五种。重谓上一本一俱转及不杂圆满具足位故。第一转相形相如何。偈曰

  五十一种位　　一各摄五十
  一时一处转　　然不可合一

论曰。云何名为上一一门。所谓五十一种位。一一位位各摄五十一时处转。若尔合集应作一体。各别一转不可合一。如偈五十一种位一各摄五十一时一处转然不可合一故。如是已说上上一一转相门。次当说本本一一转相门。其相云何。偈曰

  五十一本一　　一各摄五十
  一时一处转　　然不可合一

论曰。云何名为本一一门。所谓五十一种本。一一种本一各摄五十一时处转。若尔合集应作一体。各别一转不可合一。如偈五十一本一一各摄五十一时一处转然不可合一故。如是已说本本一一转相门。次当说俱行不离转相门。其相云何。偈曰

  本一及上一　　互各摄诸位
  俱转不舍离　　然不可合一

论曰。云何名为俱行转门。所谓本一五十一法。一一各各摄上一五十一法。上一五十一法。亦能摄彼本。俱行俱转不相离故。然各别别一时处转不可合一。如偈本一及上一互各摄诸位俱转不舍离然不可合一故。如是已说俱行不离转相门。次当说区区不杂转相门。其相云何。偈曰

  本上一切位　　一一皆各各
  安住自家中　　不摄他法故

论曰。云何名为区不杂门。所谓所有一切种种本上诸位。一一各各唯安住自家中。亦不移转亦不出入。亦不摄他亦不定常。常恒具足遍广大故。如偈本上一切位一一皆各各安住自家中不摄他法故。故如是已说区区不杂转相门。次当说具足圆满转相门。其相云何。偈曰

  前所说四门　　一切时处等
  无碍自在转　　名具足圆满

论曰。云何名为具足转门。所谓如前所说四门。一时转一处转。异时转异处转。一转离转总转别转。无碍自在故。如偈前所说四门。一切时处等无碍自在转名具足圆满故。摩诃衍大陀罗尼金刚神咒修多罗中。作如是说。一一一切一切离杂有无一称一量法藏门海中。总有二法。云何为二。一者是总二者是别。言别者。四种俱轮地故。言总者。四种俱轮自在转故。乃至广说故

    独地独天一种广大无二山王大决择分第十六

如是已说独地非乱一定一定道路大决择分。次当说独地独天一种广大无二山王大决择分。其相云何。偈曰

  此山王体中　　则有二种门
  谓自性本本　　如次应观察

论曰。就此独地独天一种广大无二山王体中。则有二门。云何为二。一者本一自性。位地门。二者本一之本位地门。是名为二。如其次第应审观察。如偈此山王体中则有二种门。谓自性本本如次应观察故。自性位地形相如何。偈曰

  彼本一法中　　不待他自然
  有五十一位　　是名自性位
  如是五十一　　一一皆各各
  有五百法门　　周遍广大转

论曰。云何名为自性位地。所谓如前所说五十一种本一法中。一一各各不待他力。自然自性有五十一真金刚位。是故说言自性位地。如偈彼本一法中不待他自然有五十一位是名自性位故。如是各各五十一位。一一各各有五百法门之大海。亦周遍转亦广大转。如偈如是五十一一一皆各各有五百法门周遍广大转故。于此位中亦如前说五种大门。具足具足圆满圆满应审思择。如是已说本一自性位地门。次当说本一之本位地门。其相云何。偈曰

  五十一本法　　亦各有本法
  名空空空一　　此中亦有位

论曰。本一所依空空空一中。亦有诸位。一一位位皆悉各各十万法门。具足圆满无阙失转。于此位中亦有前说五种大门。具足具足圆满圆满。应审思择。品论修多罗中。作如是说禅定摩诃衍体中。则有三大门。云何为三。一者上地安立广大海会门。二者宗本有有有一门。三者根本空空空一门。如是三门皆有诸位。具足圆满同转异转等。乃至广说故

大宗地玄文本论卷第八大宗地玄文本论卷第九

        马鸣菩萨造

        真谛三藏译

    独一无二山王自在道路大决择分第十七

如是已说独地独天一种广大无二山王大决择分。次当说独一无二山王自在道路大决择分。其相云何。偈曰

  自在道路中　　总有千重转
  谓本上一中　　各各五百故

论曰。就此无二山王自在道路分中。总有千重差别转相。所谓本上中各各五百故。如偈自在道路中总有千重转。谓本上一中各各五百故。故本转形相当如何耶。偈曰

  向本一下转　　一空一有转
  乃至第五百　　余位亦如是

论曰。今此偈中为明何义。为欲现示依本一门向下下转。有一金刚空一金刚。如其次第一一现前。渐渐转入乃至第五百。如是亦复余诸位中。渐渐转入乃至第五百。无有穷尽无有边际无有始终。具足具足圆满广大常恒转故。如偈向本一下转一空一有转乃至第五百余位亦如是故。上转形相例此应知。因明性德修多罗中。作如是说。无二一天父子法藏上上转去。有其始终无有穷尽。下下转入。有其始终无有穷尽。有始终者。从信等位起至五百量故。无穷尽者。法藏之海极广大故。乃至广说故

    摩诃无二山王最胜高顶一地大决择分第十八

如是已说独一无二山王自在道路大决择分。次当说摩诃无二山王最胜高顶一地大决择分。其相云何。偈曰

  本上无穷尽　　建立如是名
  所余一切位　　亦如是应知

论曰。今此偈中为明何义。为欲现示本本无穷上上无穷。本上无穷上本无穷。一一无穷多多无穷。同同无穷异异无穷。等等无穷别别无穷。有穷无穷无穷。无穷周遍广大具足圆满故。如偈本上无穷尽建立如是名所余一切位亦如是应知故。摩诃衍海修多罗中。作如是说。禅定摩诃衍海中。一千二百无穷尽品。具足俱转。乃至广说故

大宗地玄文本论卷第九大宗地玄文本论卷第十

        马鸣菩萨造

        真谛三藏译

    [(王*昍)/(王*屾)][囗@日]陀尸梵迦诺道路大决择分第十九

如是已说摩诃无二山王最胜高顶一地大决择分。次当说[(王*昍)/(王*屾)][囗@日]陀尸梵迦诺道路大决择分。其相云何。偈曰

  [(王*昍)/(王*屾)][囗@日]道路中　　七变对修行
  以为道路量　　无有余行相

论曰。今此偈中为明何义。为欲现示[(王*昍)/(王*屾)][囗@日]道路中。唯以七变对为其界量。无余相故。如偈[(王*昍)/(王*屾)][囗@日]道路中七变对修行以为道路量无有余行相故。云何名为七变修行。形相如何。偈曰

  七变有三种　　功德过患等
  五十一位中　　上下七变转
  增长功德品　　及诸烦恼海

论曰。七变修行总有几数。有三种故。云何为三。一者功德七变。二者过患七变。三者等量七变。是名为三。如偈七变有三种功德过患等故。言变相者。五十一种金刚位中。向上上转向下下转具足七变。增长功德增长过患广大转故。如偈五十一位中上下七变转增长功德品及诸烦恼海故。且过患七变形相如何耶。偈曰

  最第一变中　　上各增百数
  下各增千数　　各障一二德
  后六变如次　　增倍倍数转

论曰。第一变中增几数转。障几净法。谓上转时中。一一位位各增百数烦恼品类。障一净法。若下转时中。一一位位各增千数烦恼品类。障二净法。如偈最第一变中上各增百数下各增千数各障一二德故。后六变中功德过患。如其次第增倍数故。如偈后六变如次增倍倍数转故。如是已说现示过患七变门。次当说现示功德七变门。其相云何。偈曰

  最第一变中　　上各增一亿
  下各增二亿　　渐渐次第转
  后六变如次　　增倍倍数转
  不坏患数量　　为功德变作

论曰。第一变中增几数转。谓上转时中。一一位位各增一亿数功德品类。渐渐而转。若下转时中。一一位位各增二亿数功德品类渐渐转故。如偈最第一变中上各增一亿下各增二亿渐渐次第转故。后六变中。如其次第增倍数故。如偈后六变如次增倍倍数转故。如是功德烦恼品类。为断不断。唯变作转。不动坏故。如偈不坏患数量为功德变作故如是已说现示功德七变门。次当说现示等量七变门。其相云何。偈曰

  最第一变中　　各上增一千
  各下增二万　　等数量渐转
  后六变如次　　增倍倍数转
  无断障差别　　唯对量建立

论曰。第一变中增几数转。谓上转时中。一一位位各增一千。如次第转。若下转时中。一一位位各增二万。如次第转。如偈最第一变中各上增一千各下增二万故。其数量品有增减不。唯平等量非差别量。如偈等数量渐转故。后六变中。如其次第增倍数转。谓一倍故。如偈后六变如次增倍倍数转故。如是七变。亦无照相亦无覆相。唯平等量分分建立。如偈无断障差别唯对量建立故。此中次第功德七变以为其终。应审观察。甚深种子修多罗中。作如是说。明达里藏中唯有三变。以七为量不增不减。譬如七步蛇七叶树法尔道理。初唯染品中染净俱。后唯净品。乃至广说故

    [(王*昍)/(王*屾)][囗@日]陀尸梵迦诺本王本地大决择分第二十

如是已说[(王*昍)/(王*屾)][囗@日]陀尸梵迦诺道路大决择分。次当说[(王*昍)/(王*屾)][囗@日]陀尸梵迦诺本王本地大决择分。其相云何。偈曰

  此本王体中　　有三种百变
  名次第如前　　等无有差别

论曰。就此本王体中。则有三种百变修行。名及次第如前所说。如偈此本王体中有三种百变名次第如前等无有差别故。如是三变形相如何。偈曰

  如是三变中　　初各如次第
  十千百亿数　　后九十九变
  如次增倍数　　渐渐次第转

论曰。就过患百变门中。上及并下。第一变中增十亿数次第渐转。就功德百变门中。上及并下。第一变中增千亿数次第渐转。就等量百变门中。上并及下。第一变中增百亿数次第渐转。如偈如是三变中初各如次第十千百亿数故。后九十九变中。皆悉各各如其次第增倍数转。如偈后九十九变如次增倍数渐渐次第转故。大海山王地地品类修多罗中。作如是说。如来藏体中有三流转品。以百数为量。无超次第渐渐转去。如是三中。初功德少其过患多中数量等。后唯功德。乃至广说故

大宗地玄文本论卷第十大宗地玄文本论卷第十一

        马鸣菩萨造

        真谛三藏译

    [玨/覞]尸梵诺本王道路大决择分第二十一

如是已说[(王*昍)/(王*屾)][囗@日]陀尸梵迦诺本王本地大决择分。次当说[玨/覞]尸梵诺本王道路大决择分。其相云何。偈曰

  本王道路中　　有三种千变
  名如前说量　　各初变如次
  增百千万亿　　各后一切变
  如次倍数转　　住心应观察

论曰。就[玨/覞]尸梵诺本王道路分中。则有三种千变修行。其名次第同前所说。如偈本王道路中有三种千变名如前说量故。如是三种。第一变中如其次第。增百亿千亿万亿数。上下一量渐渐转故。如偈各初变如次增百千万亿故。各后诸变如其次第增倍数转。应审思择。如偈各后一切变如次倍数转住心应观察故。则修多罗中。作如是说。如来藏佛上下门中。有三种修行。数以千为量。如是三品。以多亿转出生增长广大周遍法门海藏。乃至广说故

    摩诃[玨/覞]尸梵诺母原主天王大决择分第二十二

如是已说[玨/覞]尸梵诺本王道路大决择分。次当说摩诃[玨/覞]尸梵诺母原主天王大决择分。其相云何。偈曰

  摩诃天王中　　有三种亿变
  名次第如前　　各初变如次
  一二三十方　　世界数量转
  所余一切变　　如次倍数转

论曰。就摩诃主天王体中。则有三种亿变修行。名字次第同前所说。如偈摩诃天王中有三种亿变名次第如前故。如是三种。第一变中如其次第。增一十方二十方三十方数转。如偈各初变如次一二三十方世界数量转故。余一切变如其次第倍数转故如偈所余一切变如次倍数转故。总字法转大轮修多罗中。作如是说。佛陀摩诃本藏王地地中。则有三行。云何为三。一者下亿转行。二者中亿转行。三者上亿转行。初行出生一大方界量下眷属海。中行出生二大方界量等俱转海。后行出生三大方界量上眷属海。乃至广说故

大宗地玄文本论卷第十一大宗地玄文本论卷第十二

        马鸣菩萨造

        真谛三藏译

    一种功德纯纯无杂大圆满地道路大决择分第二十三

如是已说摩诃[玨/覞]尸梵诺母原主天王大决择分。次当说一种功德纯纯无杂大圆满地道路大决择分。其相云何。偈曰

  功德道路中　　有二千五百
  五十法门海　　五十一位中
  一一皆各各　　具五十位故
  亦一一位中　　有性相本末
  一万二百数　　修多罗中说
  总一万二千　　七百五十数
  取彼总本数　　如法应观察
  以如是数量　　为道路分界

论曰。就一种功德纯纯无杂大圆满地道路分中。总有二千五百五十法门大海。甚深甚深广大广大。如偈功德道路中有二千五百五十法门海故。以何义故数如是。成应可了。知所谓五十一种位中。一一各各具五十故。此义云何。所谓五十信心五十念心。乃至五十如来地各差别故。如偈五十一位中一一皆各各具五十位故。故亦一一位位各各具足性相本末之四法故。一万二百数成立而已。如是四事云何差别。谓如其次第不可思议说故。明了现觉说故。能生长因说故。所生长果说故。如偈亦一一位中有性相本末一万二百数故。若尔此方说文云何通耶。谓金刚等地一行三昧修多罗中。作如是说。无杂无乱一一同同非恶非患吉祥地地轨则门中。总有一万二千七百五十法门。彼修多罗中如是说者。总别总故。如偈修多罗中说总一万二千七百五十数取彼总本数如法应观察故。今此道路以之为量有别法门。唯以此数为其极量无别法门。如偈以如是数量为道路分界故

    一种功德摩诃本地明白离恶品藏大决择分第二十四

如是已说一种功德纯纯无杂大圆满地道路大决择分。次当说一种功德摩诃本地明白离恶品藏大决择分。其相云何。偈曰

  本地品藏中　　有一亿三万
  七千五百数　　广大法门海
  前说诸位中　　一一皆各各
  摄别五十位　　法门如是广
  性相本末四　　例此广通达

论曰。就一种功德摩诃本地明白离恶品藏中。总有一亿三万七千五百数广大法门海。甚深甚深周遍周遍。如偈本地品藏中有一亿三万七千五百数广大法门海故。以何义故数如是成。如前所说一切位中。一一各各摄差别转五十位故。法门之海如是广大。如偈前说诸位中一一皆各各摄别五十位法门如是广故。性相本末四种事中。以例配当。更复增数转胜广大。应审思择如偈性相本末四例此广通达故

大宗地玄文本论卷第十二大宗地玄文本论卷第十三

        马鸣菩萨造

        真谛三藏译

    摩诃本地具足品藏非患道路大决择分第二十五

如是已说一种功德摩诃本地明白离恶品藏大决择分。次当说摩诃本地具足品藏非患道路大决择分。其相云何。偈曰

  本地道路中　　则有二种门
  谓横转竖转　　以之为门量

论曰。就摩诃本地具足品藏非患道路分中。则有二门。云何为二。一者横转遍到俱行门。二者竖转无杂一路门。是名为二。如是二门以为门量。如偈本地道路中则有二种门。谓横转竖转以之为门量故。且横转门形相如何。偈曰

  四种事位中　　有总及别中
  各增十重转　　无前后一时
  其法门数量　　例前应了知

论曰。今此偈中为明何义。为欲现示性相本末四种事中。各各有总别之位中。一一位位皆悉各各增十重数。无前无后一时俱转。则是横转遍到俱行门形相故。如偈四种事位中有总及别中各增十重转无前后一时故。此中数量亦复转胜超过前量。配例应了。如偈其法门数量例前应了知故。如是已说横转遍到俱行门。次当说竖转无杂一路门。其相云何。偈曰

  前说诸位中　　如次不超过
  各增十重转　　一明究竟故

论曰。今此偈中为明何义。为欲现示如前所说总别位中。如其次第无有超过。一一各各增十重转。一事明了一事究竟。亦无杂乱亦无合集。一向明转竖转无杂一路门形相故。如偈前说诸位中如次不超过各增十重转一明究竟故。故大金刚宝王法界印藏修多罗中。作如是说。复次文殊师利。宝王道品者。以二事转。云何为二。一者一区转。二者具面转。言一区者。道虽广多先一道量。永究竟故。言具面者。所有诸道一时行故。乃至广说故

    摩诃宝轮王广大圆满无上地地大决择分第二十六

如是已说摩诃本地具足品藏非患道路大决择分。次当说摩诃宝轮王广大圆满无上地地大决择分。其相云何。偈曰

  总别无尽故　　建立本法体

论曰。今此偈中为明何义。为欲现示本法体中以总摄别以别摄总。以总摄总以别摄别。能摄所摄无有穷尽。法门大海甚深广大。义理诠趣周遍圆满。究竟自在故。如偈总别无尽故建立本法体故。摩诃衍地藏无上极说不可思议心地品论修多罗中。作如是说。宝山海中同类无尽别类无尽具足圆满。无有穷尽无有始终。无有边际无有分界。亦广大相亦小狭相。乃至广说故

大宗地玄文本论卷第十三大宗地玄文本论卷第十四

        马鸣菩萨造

        真谛三藏译

    系缚地地品类不吉祥道路大决择分第二十七

如是已说摩诃宝轮王广大圆满无上地地大决择分。次当说系缚地地品类不吉祥道路大决择分。其相云何。偈曰

  系缚道路中　　亦有金刚位
  依位立转相　　则有四种法
  谓能所障果　　如是四种法
  皆悉有为量　　如法应观察

论曰。就系缚地地品类不吉祥道路分中。亦有五十一金刚位。依此诸位建立转相。有四种法。云何为四。一者能证智法。二者所证理法。三者障碍事法。四者证得果法。是名为四。如是四法皆有为量。应审思择。如偈系缚道路中亦有金刚位依位立转相则有四种法。谓能所障果如是四种法皆悉有为量如法应观察故。如是四法各有几数。其转形相当如何耶。偈曰

  各有二种法　　谓本始体相
  生灭及增减　　转相唯上上

论曰。四种法中各有二种。云何二智。一者本古性德智。二者始今起德智。是名为二。云何二理。一者体有实理。二者相有实理。是名为二。云何二障。一者本生本生障。二者本灭本灭障。是名为二。云何二果。一者增长功德果。二者损减过患果。是名为二。如偈各有二种法。谓本始体相生灭及增减故修行转相唯上上故。如偈转相唯上上故。障治证果对量差别。形相如何。偈曰

  本生体增对　　始灭相减对
  从多亦通了　　如法应观察

论曰。本古性德智。断除本生本生障。证得体有实理。成就增长功德果。如偈本生体增对故。始今起德智。断除本灭本灭障。证得相有实理。成就损减过患果。如偈治灭相减对故。如是四法。五十一种真金位中皆悉具足。应审思择。唯一向转俱种转耶。俱种转故。如偈从多亦通了如法应观察故。生灭二障业用差别。形相如何。偈曰

  本主生灭时　　胜生胜灭故

论曰。功德善根出兴。对治转胜出兴。转胜对灭作逆事故。如偈本主生灭时胜生胜灭故。故大金刚山宝海会众修多罗中。作如是说。复次文殊师利。汝前所问。云何名为诸法无常一道一种。第一转门者。以四无常故。我作如是唱。云何为四。一者智无常。二者理无常。三者无常无常。四者上果无常。是名为四。文殊师利。言智无常者。断烦恼故。言理无常者。智所证故言无常。无常者。被断除故。言果无常者。待因力故。乃至广说故

    系缚地地自然本王摩诃[糸*為]品大决择分第二十八

如是已说系缚地地品类不吉祥道路大决择分。次当说系缚地地自然本王摩诃[糸*為]品大决择分。其相云何。偈曰

  自然本王中　　有为无为法
  具足圆满转　　此中具上下

论曰。就自然本王摩诃[糸*為]品分中。则有二转。云何为二。一者有为转。二者无为转。是名为二。如偈自然本王中有为无为法具足圆满转故。亦有二转。云何为二。一者上转。二者下转。是名为二。如偈此中具上下故。有为无为各有几数。上下转相当如何耶。偈曰

  无为唯有一　　有为有二种
  如次实本始　　上下无为主
  出生二有为　　转胜广大转

论曰。无为有一。有为有二。一谓有实故。二谓本始故。如偈无为唯有一。有为有二种。如次实本始故。如是三法五十一种金刚位中亦上亦下增长功德转相。云何谓上时中。一一位位无为法主。皆悉各各出生增长一万本始清妙觉慧其下时中。一一位位皆悉各各二亿本始清妙觉慧具足圆满出生增长。如是如是如如上下至小无量。如说本存眷属亦尔。如偈上下无为主出生二有为转胜广大转故。如其次第。增数应知。品地经论修多罗中。作如是说。世间藏地本王海中。无常功德众多无数。常住功德其数微少。是故说言世间藏地乃至广说故

大宗地玄文本论卷第十四大宗地玄文本论卷第十五

        马鸣菩萨造

        真谛三藏译

    自然本王广大转地无障无碍俱行道路大决择分第二十九

如是已说系缚地地自然本王摩诃[糸*為]品大决择分。次当说自然本王广大转地无障无碍俱行道路大决择分。其相云何。偈曰

  本王道路中　　依位渐渐转
  一主生二伴　　至中无量故
  数变皆悉通　　如法应观察

论曰。就自然本王广大转地无障无碍俱行道路分中。依五十一位。如其次第亦上亦下渐渐转行。无为法主生二有为。若上若下增中无量数。至中无量变故。如偈本王道路中依位渐渐转一主生二伴至中无量故数变皆悉通如法应观察故。部宗花品修多罗中。作如是说。行藏海中有一常德其数无量。行藏海中有二无常功德品类其数无量。亦升亦抃其数无量。乃至广说故

    最极广大俱行山王无尽海海大决择分第三十

如是已说自然本王广大转地无障无碍俱行道路决大择分。次当说最极广大俱行山王无尽海海大决择分。其相云何。偈曰

  无尽海海中　　依位渐渐转
  一主生二伴　　至大无量故
  数及变例前　　应广通达焉

论曰。就无尽海海藏中。依五十一位。如其次第亦上亦下无为法主出生增长二有为法。增大无量数。至大无量变故。如偈无尽海海中依位渐渐转一主生二伴至大无量故数及变例前应广通达焉故。彼修多罗中。作如是说。行常山王海中。有三种大无量。云何为三。一者常大无量。二者无常大无量。三者转变大无量。乃至广说故

大宗地玄文本论卷第十五大宗地玄文本论卷第十六

        马鸣菩萨造

        真谛三藏译

    出离系缚地清白解脱道路大决择分第三十一

如是。已说最极广大俱行山王无尽海海。大决择分。次当说出离系缚地清白解脱道路大决择分。其相云何。偈曰

  解脱道路中　　有二十无为
  谓十空十有　　如是诸无为
  五十一位中　　皆悉具足有
  依法位立转　　有二重重超

论曰。就出离系缚地清白解脱道路分中。则有二十无为常法。所谓十空十有无为各差别故。云何名为十空无为一者广大虚空自然常住离造作空无为。二者大虚空影空无为。三者虚空影影空无为。四者破影无所有空无为。五者空空俱非空无为。六者离言绝说空无为。七者绝离未毕空无为。八者绝离心解空无为。九者绝离穷穷空无为。十者无障无碍大空大空空无为。是名为十。云何名为十有无为。一者一切言说决定常住无破非空无为。二者一切心识决定常住无破非空无为。三者一切大种决定常住无破非空无为。四者一切俱非决定常住无破非空无为。五者一切有实决定常住无破非空无为。六者一切性大决定常住无破非空无为。七者一切今光决定常住无破非空无为。八者一切有名决定常住无破非空无为。九者一切无名决定常住无破非空无为。十者广大圆满自性本有一切种有决定常住无破非空无为。是名为十。如偈解脱道路中有二十无为。谓十空十有故。如是二十种无为法。五十一种金刚位中。具足圆满无阙失转。如偈如是诸无为五十一位中皆悉具足有故。依如是等二十无为。五十一位建立转相。则有二种。云何为二。一者重重该摄无障碍门。二者次第乱转超过门。是名为二。如偈依法位立转有二重重超故。且重重该摄无障碍门形相如何。偈曰

  二十法一一　　各摄后二十
  五十一种位　　一一皆各各
  摄五十一位　　亦此相违摄
  以此因缘故　　建立重重名

论曰。云何名为重重门相。谓该摄故。云何该摄。谓二十种无为常法信心具足。一一各各摄后诸位各二十种无为法故。如说信心余位亦尔。如偈二十法一一各摄后二十故。五十一种位。各摄五十一。亦无障碍。如偈五十一种位一一皆各各摄五十一位故。亦一一法摄一切位。一一位位摄一切法。亦无障碍。如偈亦此相违摄故。以如是二种该摄门故。立重重名。如偈以此因缘故建立重重名故。如是已说重重该摄无障碍门。次当说次第乱转超过门。其相云何。偈曰

  五十一位中　　随一经五十
  渐渐增法数　　周遍广大转

论曰。今此偈中为明何义。为欲现示五十一种金刚位中。以信为初经五十位。以发心住而为其初经五十位。乃至以最极地而为其初经五十位。若第一转。增四十一百数法位转。若第二转。增八十二百数法位转。乃至最后地故。如偈五十一位中随一经五十渐渐增法数周遍广大转故。蕴高山王品类修多罗中。作如是说。无破地地门中。有寂静宝其数众多。空寂静宝其数众多。若有行者入此门中。通达诸法无为大道。无所障碍无所疑畏。其心自在决定常住大安乐。渐渐增长常功德海。乃至广说故

    解脱山王根本地地无碍自在大决择分第三十二

如是已说出离系缚地清白解脱道路大决择分。次当说解脱山王根本地地无碍自在大决择分。其相云何。偈曰

  根本山王中　　空有互相生
  诸位相生故　　转胜广大转

论曰。今此偈中为明何义。为欲现示十空无为。一一各各出生十有无为常法。十有无为。一一各各出生十空无为常法。五十一位。一一各各出生五十依重重等门。圆满广大转故。如偈根本山王中空有互相生诸位相生故转胜广大转故。摩诃衍海修多罗中。作如是说。解脱海中。亦有空有亦有有空其数众多。如是空有。唯是常灭非无常量。唯是功德非过患品。是故说言解脱藏海。乃至广说故

大宗地玄文本论卷第十六大宗地玄文本论卷第十七

        马鸣菩萨造

        真谛三藏译

    解脱山王大道路大决择分第三十三

如是已说解脱山王根本地地无碍自在大决择分。次当说解脱山王大道路大决择分。其相云何。偈曰

  山王道路中　　前所说量中
  增空空有有　　位位转胜生

论曰。就解脱山王大道路分中则有三转。云何为三。一者空空转。十空无为一一各各生十空故。二者有有转。十有无为一一各各生十有故。三者位位转。五十一位一一各各生五十故。是名为三。取自相生非他相故。如偈山王道路中前所说量中增空空有有位位转胜生故。余种种门转转增数。应广通达

    广大无尽解脱海海摩诃山王大决择分第三十四

如是已说解脱山王大道路大决择分。次当说广大无尽解脱海海摩诃山王大决择分。其相云何。偈曰

  前所说诸转　　无有穷尽故

论曰。今此偈中为明何义。为欲现示空生自空无有穷尽。空生异空无有穷尽。空生诸有无有穷尽。有亦如是无有穷尽。位亦如是无有穷尽。重重无穷乱转无穷。无其边际无其始终。甚深甚深周遍周遍广大转行。则是解脱海海山王无碍自在体相用故。如偈前所说诸转无有穷尽故故

大宗地玄文本论卷第十七大宗地玄文本论卷第十八

        马鸣菩萨造

        真谛三藏译

    摩诃空尘海藏王道路大决择分第三十五

如是已说广大无尽解脱海海摩诃山王大决择分。次当说摩诃空尘海藏王道路大决择分。其相云何。偈曰

  海王道路中　　具足百自在
  以此因缘故　　建立海王名

论曰。今此偈中为明何义。为欲现示海王藏中无有别法。唯有自在故。有几自在。谓百种故。云何为百。一者时自在。三十二法。亦一时转亦异时转。亦转时中不转。亦不转时中转。亦远时转亦近时转。乃至无量故。二者处自在。一异等处转。乃至无量故。三者物自在。为同异等用。乃至无量故。四者周遍自在。无所不通等。乃至无量故。五者大小自在。极重极微等。乃至无量故。六者有无自在。亦现亦隐等。乃至无量故。七者寂动自在。亦定亦散等。乃至无量故。八者甚深自在。不可思议等事。乃至无量故。九者不自在自在。以逆等事。乃至无量故。十者无碍自在。以逆顺事等。乃至无量故。乃至第百自在自在。无尽自在等皆悉自在。乃至无量故。如前所说三十二法。如是自在具足圆满无阙失转。以此义故立海王名。应审思择。如偈海王道路中具足百自在。以此因缘故建立海王名故。觉花修多罗中。作如是说。第一广分大海门中。若广说有一十方世界之尘量自在。若略说有一百自在。乃至广说故

    大不可思议重重不可称量阿说本王大决择分第三十六

如是已说摩诃空尘海藏王道路大决择分。次当说大不可思议重重不可称量阿说本王大决择分。其相云何。偈曰

  阿说本王中　　有十方尘量
  十方空尘量　　三十三法海

论曰。今此偈中为明何义。为欲现示阿说海中具足圆满十方世界之尘数。十方世界之尘数。三十三法海。十方世界之尘数。十方虚空之尘数三十三法海故如偈阿说本王中有十方尘量十方空尘量三十三法海故。本王修多罗中。作如是说

尔时世尊告大众言。我以三达智。通达一切法。无所障碍无所阙失。而有一海不可思议。不可思议不能穷了。谓空尘本王性德圆满自在自在无尽藏海。乃至广说故

大宗地玄文本论卷第十八大宗地玄文本论卷第十九

        马鸣菩萨造

        真谛三藏译

    校量功德赞叹信行现示利益大决择分第三十七

如是已说大不可思议重重不可称量阿说本王大决择分。次当说校量功德赞叹信行现示利益大决择分。其相云何。偈曰

  譬如盛火聚　　虽有极远处
  以光明势力　　能破远方闇
  此玄文本论　　亦复如如是
  若有众生类　　同世界共住
  虽未得见学　　此论火光明
  能破远众生　　心相不觉闇
  令得觉知明　　随分伏其染
  譬如盛火聚　　转胜近其处
  光明渐渐了　　能破闇更增
  此玄文本论　　亦复如如是
  若有众生类　　同一国共住
  虽未得见学　　此论火光明
  除众生无知　　转转令分明
  譬如盛火聚　　转转近其处
  光明耀更增　　此玄文本论
  亦复如如是　　若有众生类
  同一城共住　　虽未得见学
  此论火光明　　除众生无知
  转转更分明　　譬如盛火聚
  更转近其处　　光明重重增
  暖气温其身　　此玄文本论
  亦复如如是　　若有众生类
  同一家共住　　虽未得见学
  此论火光明　　除心惑护身
  转转增长故　　譬如有一人
  得彼大火聚　　此人则便得
  六种大利益　　谓能塞寒气
  能成熟资具　　不入毒虫等
  破闇常明了　　随请人普施
  焚烧秽粪等　　此玄文本论
  亦复如如是　　若有众生类
  得此玄文论　　此人即便得
  六种大利益　　谓禁烦恼军
  成就功德品　　不入邪魔众
  破无明品类　　般若慧现前
  贫穷佛法财　　来乞求众生
  随顺普施与　　烧灭烦恼粪
  比如有妙华　　[(糸*昌)/立]水深池中
  名曰青莲华　　有人刹那中
  见此莲华相　　一百七日中
  其眼根清白　　终日无晦浊
  此玄文本论　　亦复如如是
  若有众生类　　虽不知此论
  文义之大海　　而目见此论
  其眼根清净　　见三世诸佛
  有作方便目　　比如有天鼓
  悬圆生树顶　　名曰妙声觉
  无量天女子　　闻此鼓音已
  二千七日中　　其耳根清速
  无塞隔之事　　此玄文本论
  亦复如如是　　若有众生类
  虽不知文义　　而耳闻此论
  其耳根清净　　闻诸佛梵响
  有作方便耳　　比如有妙药
  生雪山之顶　　名曰上味常
  有人取此药　　着其舌之原
  身香极芬芬　　不承用饮食
  其命极长远　　亦飞腾虚空
  此玄文本论　　亦复如如是
  若有众生类　　此论中一字
  一句若一行　　若一决择分
  若一卷之量　　以舌经读诵
  虽不知义理　　而获得一切
  诸修多罗海　　经读诵功德
  比如有菩萨　　名曰不思议
  大力解脱者　　此菩萨大士
  神通自在故　　于一切所作
  皆无所障碍　　随应悉现前
  此玄文本论　　亦复如如是
  若有诸众生　　观达其义理
  觉悟文下诠　　通达一切法
  皆无所障碍　　一一觉分明
  比如有神王　　名曰大安乐
  有人须小具　　祀祠此神王
  出兴七宝藏　　令得大安乐
  此玄文本论　　亦复如如是
  若有一男女　　此玄文本论
  勤受取读诵　　有人须小具
  专心供此人　　即得无穷尽
  福德智慧宝　　无所疑畏心
  比如有妙香　　名曰芬满布
  有人持此香　　游行于远方
  其经过处处　　七七日中间
  有香气不尽　　此玄文本论
  亦复如如是　　若有一男女
  荷担此论部　　游行于远方
  若度大海水　　所有诸众生
  皆得大利益　　若度山野等
  所有诸众生　　亦得大利益
  譬如有妙珠　　名曰如意宝
  随此珠住处　　无量眷属玉
  遍周匝围绕　　此玄文本论
  亦复如如是　　随其住止处
  有十方世界　　尘量大神王
  一一大神王　　各率十方界
  尘数眷属神　　守护此论珠
  若灭正法时　　作微尘散坏
  所有诸神王　　发大声哭涕
  随尘所住处　　往诣常守护
  受持此论者　　如是数量神
  若生若死后　　常不离守护
  功德虽无量　　而略说如是

    校量过患呵责诽谤现示罪业大决择分第三十八

如是已说校量功德赞叹信行现示利益大决择分。次当说校量过患呵责诽谤现示罪业大决择分。其相云何。偈曰

  譬如有一山　　名曰宝轮上
  此山具七宝　　更无有穷尽
  贫穷求宝类　　无量无边数
  有珠能禁宝　　名曰顶玻璃
  若人有此珠　　则能取七宝
  远离贫穷苦　　获得大安乐
  若人无此珠　　不能宝禁故
  终日不能得　　问所以者何
  若无珠人诣　　唯见虎狼熊
  及赤蛇青蛇　　种种杂毒虫
  终不见珍宝　　以见毒类故
  其心极疑怖　　狂乱而驰走
  乃至于死灭　　珍宝自然有
  而彼求珍人　　福薄罪重故
  终不能见得　　众生亦如是
  善根甚深人　　捧坚固信珠
  入大乘深海　　取功德之宝
  出生死苦轮　　善根微薄人
  得见甚深论　　无实信心故
  依正作邪解　　受苦轮无期
  譬如生盲人　　得妙庄严具
  无有欢乐事　　痴人亦如是
  虽得甚深论　　其愚痴极故
  不觉出世宝　　无有学习心
  譬如居井龙　　从流水至海
  大迷大乱故　　谤海而命终
  痴人亦如是　　自所习坚执
  定一不移转　　闻未曾有法
  大迷大乱故　　诽谤其广大
  堕落恶道中　　无有出离期
  若有众生类　　见闻斯论教
  不信心诽谤　　此人则诽谤
  三世一切佛　　三世诸法藏
  三世诸僧海　　此人所得罪
  无量无量数　　不能知边际
  十方界尘量　　诸佛大菩萨
  一时悉出现　　宣说如是量
  法门之大海　　专教化此人
  经过无量劫　　终不能教化
  问所以者何　　唯宣说此法
  无余别道故　　如是众生类
  十方界尘量　　诸佛大菩萨
  以大神通力　　向未来远劫
  观察其限界　　无觉道之期
  问所以者何　　不学三十四
  大金刚轨则　　到大涅槃岸
  无有是处故　　是故诸行者
  以勤修方便　　应观其法海
  不能达其原　　妄生诽谤心
  堕落恶道中　　无有出离期
  决定不应作　　决定不应作
  罪业虽无量　　而略说如是

大宗地玄文本论卷第十九大宗地玄文本论卷第二十

        马鸣菩萨造

        真谛三藏译

    现示本因决定证成除疑生信大决择分第三十九

如是已说校量过患呵责诽谤现示罪业大决择分。次当说现示本因决定证成除疑生信大决择分。其相云何。偈曰

  我于往昔无量劫　　随世尊修菩萨行
  一时世尊王家奴　　国名金水其王名
  宝金轮藏此大王　　有三十亿奴婢类
  有六十亿大白马　　金银等宝亦无尽
  有最下奴名常信　　于中大王告常信
  汝受此六十亿马　　不离守护令无伤
  尔时彼奴受诸马　　常恒不离无伤护
  如是六十亿白马　　经一日食百两金
  时常信作如是念　　我身唯一马众多
  难哉难哉无伤畜　　此诸马恶驰难禁
  今何方便能护持　　常信作是念已讫
  则便依师学术方　　术力变作万白马
  六十亿白马中中　　[(〦/日)/(山/大)][(〦/日)/(山/大)][打-丁+咒][打-丁+咒]立化马
  发大声作如是唱　　马马皆悉作礼拜
  尔时有中中化马　　皆悉先前作礼拜
  余诸马皆随礼拜　　作如是事已讫后
  化马责小咎皆杀　　诸马更皆伏从化
  常信所愿悉成就　　都无所忧怪之心
  常信更复作是念　　此诸马皆从我化
  除其为资具黄金　　造作善业易秽报
  告诸马作如是唱　　谛听谛听诸畜生
  我身并及汝等身　　于过去世心负悔
  具作一切恶业障　　亦奴亦马生此处
  恒一切时不自在　　病苦所逼饥寒乱
  一时不得其安乐　　若此生中不作善
  后世亦受如是报　　去去无有出离期
  如宜汝等诸畜生　　除自资具供德处
  须臾饥渴感长乐　　我人有思心欲修
  无其闲闲空过时　　况汝等畜生之身
  形秽心浊修何时　　如宜从我化无逆
  其国中有殊胜鸟　　名曰雅音声觉悟
  此鸟声不可思议　　人闻其音大悲慨
  尔时彼六十亿马　　闻常信所语已讫
  一时发大声悲哭　　至十日量无休息
  如是诸马其声响　　与雅音声觉悟鸟
  平等平等无差别　　尔时常信马皆喜
  百两金分为二分　　一分以为生长具
  一分以为福田分　　福田分五十两金
  造作一金刚佛像　　总有六十亿佛像
  最上第一大白马　　名曰长严杂色见
  常信及诸马皆死　　第二生中皆悉人
  同一眷属不相离　　出家学道勤修行
  彼六十亿出家人　　皆名马鸣无别名
  从过去立名字故　　过去常信今释迦
  彼时六十亿白马　　今时六十亿马鸣
  最第一马杂色见　　今时中我身而已
  第三生中亦人身　　随世尊行菩萨行
  第四生中亦得人　　随世尊习忍辱行
  转转经过五百生　　次生中嗔因缘故
  得重蛇身受大苦　　次生中受大鱼身
  次生中亦得蛇身　　以蛇身诣世尊所
  投体忏悔发惭愧　　以偈表意发大心
  次生中得人同分　　随世尊发愿系属
  则世尊作如是愿　　我若成觉道圆满
  宣说百亿修多罗　　普利益广略众生
  我则作如是誓愿　　造作一百释明论
  分利益广略众生　　如次后后经多生
  世尊满足行因海　　安住法界山王位
  我亦渐渐修因行　　证入第八不动地
  我则往诣世尊所　　稽首顶礼立一面
  尔时世尊告我言　　我念往昔无量劫
  汝我同住一处中　　发愿作系属因缘
  如宜汝造作论教　　我灭度后兴正法
  我则更顶礼和南　　向世尊作如是白
  我今不知作论法　　雅闇都无所觉达
  唯愿世尊为迷子　　开晓造作论教法
  尔时世尊告我言　　善哉善哉善男子
  谛听谛听善思念　　我当为汝分别说
  善男子诸佛法藏　　无量无边不说劫
  无穷尽亦无分界　　如是无量法藏海
  若广说论若略说　　皆通该摄无余持
  是名造作论教法　　我亦重疑更作请
  法门海无量无边　　我今未满福智海
  居学位中未究竟　　皆摄无余持何得
  尔时世尊告我言　　法门大海虽无量
  有摄无量宗本法　　若具摄此宗本法
  是名说摄诸法藏　　我亦更作如是白
  云何名为宗本法　　其数几有可知不
  尔时世尊告我言　　所言宗本法体者
  谓三十四法大海　　若有论者具此法
  名言圆满大海论　　若有论者不具者
  名言一分小智论　　以如是大要因缘
  我今依三十四法　　该摄安立无余说
  因缘品类虽无量　　而总言略说如是

    劝持流通发大愿海大决择分第四十

如是已说现示本因决定证成除疑生信大决择分。次当说劝持流通发大愿海大决择分。其相云何。偈曰

  愿此圆满大海论　　遍不思议尘刹中
  出生无量般若日　　消除无边无明闇
  转作三宝之大海　　无非法而功德藏
  非请感周遍相应　　非劝策自然成就

大宗地玄文本论卷第二十


发菩提心经论

    No. 1659

发菩提心经论卷上

        天亲菩萨造

        后秦龟兹国三藏鸠摩罗什译

    劝发品第一

  敬礼无边际　　去来现在佛
  等空不动智　　救世大悲尊

有大方等最上妙法。摩得勒伽藏菩萨摩诃萨之所修行。所谓劝乐修集无上菩提。能令众生发深广心。建立誓愿毕定庄严。舍身命财摄伏贪吝。修五聚戒化导犯禁。行毕竟忍调伏嗔碍发勇精进安止众生。集诸禅定为知众心。修行智慧灭除无明。入如实门离诸执着。宣示甚深空无相行。称赞功德使佛种不断。有如是等无量方便助菩提法清净之门。当为一切上上善欲分别显示。悉令究竟阿耨多罗三藐三菩提。诸佛子。若佛子受持佛语。能为众生演说法者。应先称扬佛之功德。众生闻已乃能发心求佛智慧。以发心故佛种不断。若比丘比丘尼优婆塞优婆夷。念佛念法又念如来。行菩萨道时为求法故。阿僧祇劫受诸勤苦。以如是念。为菩萨说法乃至一偈。菩萨得闻是法示教利喜。当种善根修习佛法。得阿耨多罗三藐三菩提。为断无量众生无始生死诸苦恼故。菩萨摩诃萨欲成无量身心。勤修精进深发大愿。行大方便起大慈悲。求大智慧无见顶相。求如是等诸佛大法。当知是法无量无边。法无量故福德果报亦复无量。如来说言如诸菩萨最初发心下劣一念福德果报。百千万劫说不能尽。况复一日一月一岁乃至百岁。所习诸心福德果报岂可说尽。何以故。菩萨所行无尽。欲令一切众生皆住无生法忍。得阿耨多罗三藐三菩提故。诸佛子。菩萨初始发菩提心。譬如大海初渐起时。当知皆为下中上价乃至无价如意宝珠作所住处。此宝皆从大海生故。菩萨发心亦复如是。初渐起时。当知便为人天声闻缘觉诸佛菩萨一切善法禅定智慧之所生处。复次又如三千大千世界初渐起时。当知便为二十五有。其中所有一切众生。悉皆荷负作依止处。菩萨发菩提心亦复如是。初渐起时。普为一切无量众生。所谓六趣四生。正见邪见修善习恶。护持净戒犯四重禁。尊奉三宝谤毁正法。诸魔外道沙门梵志。刹利婆罗门毗舍首陀。一切荷负作依止处。复次菩萨发心。慈悲为首。菩萨之慈无边无量。是故发心无有齐限等众生界。譬如虚空无不普覆。菩萨发心亦复如是。一切众生无不覆者。如众生界无量无边不可穷尽。菩萨发心亦复如是。无量无边无有穷尽。虚空无尽故众生无尽。众生无尽故菩萨发心等众生界。众生界者无有齐限。我今当承圣旨说其少分。东方尽千亿恒河沙阿僧祇诸佛世界。南西北方四维上下各千亿恒河沙阿僧祇诸佛世界。尽末为尘。此诸微尘皆不与肉眼作对。百万亿恒河沙阿僧祇三千大千世界所有众生。悉共聚集共取一尘。二百万亿恒河沙阿僧祇三千大千世界所有众生。共取二尘。如是展转取十方各千亿恒河沙阿僧祇诸佛世界所有地种。微尘都尽。是众生界犹不可尽。譬如有人析破一毛以为百分。以一分毛渧大海水。我今所说众生少分亦复如是。其不说者如大海水。假使诸佛于无量无边阿僧祇劫。广演譬喻说亦不尽。菩萨发心悉能遍覆如是众生。云何诸佛子。是菩提心岂可尽也。若有菩萨闻如是说。不惊不怖不退不没。当知是人决定能发菩提之心。假令无量一切诸佛于无量阿僧祇劫。赞其功德亦不可尽。何以故。是菩提心无有齐限不可尽故。有如是等无量利益。是故宣说为令众生普得受行。发菩提心

    发菩提心经论发心品第二

菩萨云何发菩提心。以何因缘修集菩提。若菩萨亲近善知识供养诸佛。修集善根志求胜法。心常柔和遭苦能忍。慈悲淳厚深心平等。信乐大乘求佛智慧。若人能具如是十法。乃能发阿耨多罗三藐三菩提心。复有四缘。发心修集无上菩提。何谓为四。一者思惟诸佛发菩提心。二者观身过患发菩提心。三者慈愍众生发菩提心。四者求最胜果发菩提心。思惟诸佛复有五事。一者思惟十方过去未来现在诸佛初始发心具烦恼性亦如我今。终成正觉为无上尊。以此缘故发菩提心。二者思惟一切三世诸佛发大勇猛。各各能得无上菩提。若此菩提是可得法我亦应得。缘此事故发菩提心。三者思惟一切三世诸佛发大明慧。于无明[穀-禾+卵]中建立胜心积集苦行。皆能自拔超出三界。我亦如是当自拔济。缘此事故发菩提心。四者思惟一切三世诸佛为人中雄。皆度生死烦恼大海。我亦丈夫亦当能度。缘此事故发菩提心。五者思惟一切三世诸佛发大精进。舍身命财求一切智。我今亦当随学诸佛。缘此事故发菩提心。观身过患发菩提心。复有五事。一者自观我身。五阴四大俱能兴造无量恶业。欲舍离故。二者自观我身。九孔常流臭秽不净。生厌离故。三者自观我身。有贪嗔痴无量烦恼烧然善心。欲除灭故。四者自观我身。如泡如沫念念生灭。是可舍法欲弃捐故。五者自观我身。无明所覆常造恶业。轮回六趣无利益故。求最胜果发菩提心。复有五事。一者见诸如来。相好庄严光明清彻遇者除恼。为修集故。二者见诸如来。法身常住清净无染。为修集故。三者见诸如来。有戒定慧解脱解脱知见清净法聚。为修集故。四者见诸如来。有十力四无所畏大悲三念处。为修集故。五者见诸如来。有一切智。怜愍众生慈悲普覆。能为一切愚迷正道。为修集故慈愍众生发菩提心。复有五事。一者见诸众生为无明所缚。二者见诸众生为众苦所缠。三者见诸众生集不善业。四者见诸众生造极重恶。五者见诸众生不修正法。无明所缚复有四事。一者见诸众生为痴爱所惑受大剧苦。二者见诸众生不信因果造作恶业。三者见诸众生舍离正法信受邪道。四者见诸众生。没烦恼河四流所漂。众苦所缠复有四事。一者见诸众生。畏生老病死不求解脱而复造业。二者见诸众生忧悲恼苦而常造作无有休息。三者见诸众生爱别离苦而不觉悟方便染着。四者见诸众生怨憎会苦常起嫌嫉更复造怨。集不善业复有四事。一者见诸众生为爱欲故造作诸恶。二者见诸众生知欲生苦而不舍欲。三者见诸众生虽欲求乐不具戒足。四者见诸众生虽不乐苦造苦不息。造极重恶复有四事。一者见诸众生毁犯重戒虽复忧惧而犹放逸。二者见诸众生兴造极恶五无间业。凶顽自蔽不生惭愧。三者见诸众生谤毁大乘方等正法。专愚自执方起憍慢。四者见诸众生虽怀聪哲而具断善根。反自贡高永无改悔。不修正法复有四事。一者见诸众生生于八难不闻正法不知修善。二者见诸众生值佛出世闻说正法不能受持。三者见诸众生染习外道苦身修业永离出要。四者见诸众生修得非想非非想定谓是涅槃。善报既尽还堕三涂。菩萨见诸众生无明造业长夜受苦。舍离正法迷于出路。为是等故发大慈悲。志求阿耨多罗三藐三菩提。如救头燃。一切众生有苦恼者。我当拔济令无有余。诸佛子。我今略说初行菩萨缘事发心。若广说者无量无边

    发菩提心经论愿誓品第三

菩萨云何发趣菩提。以何业行成就菩提。发心菩萨住干慧地。先当坚固发于正愿。摄受一切无量众生。我求无上菩提。救护度脱令无有余。皆令究竟无余涅槃。是故初始发心大悲为首。以悲心故能发转胜十大正愿。何谓为十。愿我先世及以今身所种善根。以此善根施与一切无边众生。悉共回向无上菩提。令我此愿念念增长。世世所生常系在心终不忘失。为陀罗尼之所守护。愿我回向大菩提已。以此善根。于一切生处常得供养一切诸佛。永必不生无佛国土。愿我得生诸佛国已。常得亲近随侍左右如影随形。无刹那顷远离诸佛。愿我得亲近佛已。随我所应为我说法。即得成就菩萨五通。愿我成就菩萨五通已。即能通达世谛假名流布。解了第一义谛如真实性。得正法智。愿我得正法智已。以无厌心为众生说。示教利喜皆令开解。愿我能开解诸众生已。以佛神力遍至十方无余世界。供养诸佛听受正法广摄众生。愿我于诸佛所受正法已。即能随转清净法轮。十方世界一切众生听我法者闻我名者。即得舍离一切烦恼发菩提心。愿我能令一切众生发菩提心已。常随将护除无利益与无量乐。舍身命财摄受众生荷负正法。愿我能负荷正法已。虽行正法心无所行。如诸菩萨行于正法。而无所行亦无不行。为化众生不舍正愿。是名发心菩萨十大正愿。此十大愿遍众生界。摄受一切恒沙诸愿。若众生尽我愿乃尽。而众生实不可尽。我此大愿亦无有尽。复次布施是菩提因。摄取一切诸众生故。持戒是菩提因。具足众善满本愿故。忍辱是菩提因。成就三十二相八十随形好故。精进是菩提因。增长善行于诸众生勤教化故。禅定是菩提因。菩萨善自调伏能知众生诸心行故。智慧是菩提因。具足能知诸法性相故。取要言之。六波罗蜜是菩提正因。四无量心三十七品诸万善行共相助成。若菩萨修集六波罗蜜。随其所行。渐渐得近阿耨多罗三藐三菩提。诸佛子。求菩提者应不放逸。放逸之行能坏善根。若菩萨制伏六根不放逸者。是人能修六波罗蜜。菩萨发心先建至诚立决定誓。立誓之人终不放逸懈怠慢缓。何以故。立决定誓。有五事持故。一者能坚固其心。二者能制伏烦恼。三者能遮放逸。四者能破五盖。五者能勤修行六波罗蜜。如佛所赞

  如来大智尊　　显说功德证
  忍慧福业力　　誓愿力最胜

云何立誓。若有人来种种求索。我于尔时随有施与。乃至不生一念悭吝之心。若生恶心如弹指顷。以施因缘求净报者。我即欺十方世界无量无边阿僧祇现在诸佛。于未来世亦当必定不成阿耨多罗三藐三菩提。若我持戒。乃至失命。建立净心誓无改悔。若我修忍。为他侵害乃至割截。常生慈爱誓无恚碍。若我修精进。遭逢寒暑王贼水火师子虎狼无水谷处。要必坚强其心誓不退没。若我修禅。为外事所娆不得摄心。要系念在境。誓不暂起非法乱想。若我修集智慧。观一切法如实性。随顺受持。于善不善有为无为生死涅槃。不起二见。若我心悔恚碍退没乱想。起于二见如弹指顷而。以戒忍精进禅智求净报者。我即欺十方世界无量无边阿僧祇现在诸佛。于未来世。亦当必定不成阿耨多罗三藐三菩提。菩萨以十大愿持正法行。以六大誓制放逸心。必能精勤修集六波罗蜜。成阿耨多罗三藐三菩提

    发菩提心经论檀波罗蜜品第四

云何菩萨修行布施布施若为自利他利及二俱利。如是布施。则能庄严菩提之道。菩萨为欲调伏众生令离苦恼。是故行施。修行施者于己财物常生舍心于来求者。起尊重心如。父母师长善知识想。于贫穷下贱起怜愍心如一子想。随所须与心喜恭敬。是名菩萨初修施心。修布施故善名流布。随所生处财宝丰盈。是名自利。能令众生心得满足。教化调伏使无悭吝。是名利他。以已所修无相大施。化诸众生令同己利。是名俱利。因修布施获得转轮王位。摄受一切无量众生。乃至得佛无尽法藏。是名庄严菩提之道。施有三种。一以法施。二无畏施。三财物施。以法施者。劝人受戒修出家心。为坏邪见说断常四倒众恶过患。分别开示真谛之义。赞精进功德。说放逸过恶。是名法施。若有众生怖畏王者师子虎狼水火盗贼。菩萨见已能为救护。名无畏施。自于财物施而不吝。上至珍宝象马车乘缯帛谷麦衣服饮食。下至糗搏一缕之綖若多若少称求者意随所须与。是名财施。财施复有五种。一者至心施。二者信心施。三者随时施。四者自手施。五者如法施。所不应施复有五事。非理求财不以施人。物不净故酒及毒药不以施人。乱众生故。罝罗机网不以施人。恼众生故。刀杖弓箭不以施人。害众生故。音乐女色不以施人。坏净心故。取要言之。不如法物恼乱众生。不以施人。自余一切能令众生得安乐者。名如法施。乐施之人。复获五种名闻善利。一者常得亲近一切贤圣。二者一切众生之所乐见。三者入大众时人所宗敬。四者好名善誉流闻十方。五者能为菩提作上妙因。菩萨之人名一切施。一切施者非谓多财。谓施心也。如法求财持以布施。名一切施。以清净心无谄曲施。名一切施。见贫穷者怜愍心施。名一切施。见厄苦者慈悲心施。名一切施。居贫少财而能用施。名一切施。爱重宝物开意能施。名一切施。不观持戒毁戒田非田施。名一切施。不求人天妙善乐施。名一切施。志求无上大菩提施。名一切施。欲施施时施已不悔。名一切施。若以华施。具陀罗尼七觉华故。若以香施。具戒定慧熏涂身故若以果施。具足成就无漏果故。若以食施。具足命辩色力乐故。以衣服施。具清净色除无惭愧故。以灯明施。具足佛眼照了一切诸法性故以象马车乘施。得无上乘具足神通故以缨络施。具足八十随形好故。以珍宝施。具足大人三十二相故。以筋力仆使施。具佛十力四无畏故。取要言之。乃至国城妻子头目手足。举身施与心无吝惜。为得无上菩提度众生故。菩萨摩诃萨修行布施。不见财物施者受者。以无相故。是则具足檀波罗蜜

    发菩提心经论尸罗波罗蜜品第五

云何菩萨修行持戒。持戒若为自利他利及二俱利。如是持戒。则能庄严菩提之道。菩萨为欲调伏众生令离苦恼。是故持戒。修持戒者。悉净一切身口意业。于不善行心能舍远。善能呵啧恶行毁禁。于小罪中心常恐怖。是名菩萨初持戒心。修持戒故。远离一切诸恶过患。常生善处。是名自利。教化众生令不犯恶。是名利他。以己所修向菩提戒。化诸众生令同己利。是名俱利。因修持戒。获得离欲乃至漏尽成最正觉。是名庄严菩提之道。戒有三种。一者身。二者口。三者心。持身戒者。永离一切杀盗淫行。不夺物命不侵他财不犯外色。又亦不为杀等因缘及其方便。不以杖木瓦石伤害众生。若物属他他所受用。一草一叶不与不取。又亦未尝眄睐细色。于四威仪恭谨详审。是名身戒。持口戒者。断除一切妄语两舌恶口绮语。常不欺诳离间和合。诽谤毁呰文饰言辞。及造方便恼触于人。言则至诚柔软忠信。言常饶益劝化修善。是名口戒。持心戒者。除灭贪欲嗔恚邪见。常修软心不作过罪。信是罪业得恶果报。思惟力故不造诸恶。于轻罪中生极重想。设误作者恐怖忧悔。于众生所不起嗔恼。见众生已生爱念心。知恩报恩心无悭吝。乐作福德常以化人。常修慈心怜愍一切。是名心戒。是十善业戒。有五事利益。一者能制恶行。二者能作善心。三者能遮烦恼。四者成就净心。五者能增长戒。若人善修不放逸行。具足正念分别善恶。当知是人决定能修十善业戒。八万四千无量戒品。悉皆摄在十善戒中。是十善戒能为一切善戒根本。断身口意恶。能制一切不善之法。故名为戒。戒有五种。一者波罗提木叉戒。二者定共戒。三者无漏戒。四者摄根戒。五者无作戒。白四羯磨从师而受。名波罗提木叉戒。根本四禅四未到禅。是名定共戒。根本四禅初禅未到。名无漏戒收摄诸根修正念心。见闻觉知色声香味触不生放逸。名摄根戒。舍身后世更不作恶。名无作戒。菩萨修戒不与声闻辟支佛共。以不共故名善持戒。善持戒故则能利益一切众生。持慈心戒。救护众生令安乐故。持悲心戒。忍受诸苦拔危难故。持喜心戒。欢乐修善不懈怠故。持舍心戒。怨亲平等离爱恚故。持惠施戒。教化调伏诸众生故持忍辱戒。心常柔软无恚碍故。持精进戒。善业日增不退还故。持禅定戒。离欲不善长禅支故。持智慧戒。多闻善根无厌足故。持亲近善知识戒。助成菩提无上道故。持远离恶知识戒。舍离三恶八难处故。菩萨之人持净戒者。不依欲界不近色界不住无色界是清净戒。舍离欲尘除嗔恚碍灭无明障是清净戒。离断常二边不逆因缘是清净戒。不着色受想行识假名之相是清净戒。不系于因不起诸见不住疑悔是清净戒。不住贪嗔痴三不善根是清净戒。不住我慢憍慢增上慢慢慢大慢。柔和善顺是清净戒。利衰毁誉称讥苦乐不以倾动是清净戒。不染世谛虚妄假名。顺于真谛是清净戒。不恼不热寂灭。离相是清净戒。取要言之。乃至不惜身命观无常想生于厌离。勤行善根勇猛精进是清净戒。菩萨摩诃萨修行持戒不见净心。以离想故。是则具足尸罗波罗蜜

    发菩提心经论羼提波罗蜜品第六

云何菩萨修行忍辱。忍辱若为自利他利及二俱利。如是忍辱。则能庄严菩提之道。菩萨为欲调伏众生令离苦恼故修忍辱。修忍辱者。心常谦下一切众生。刚强憍慢舍而不行。见粗恶者起怜愍心。言常柔濡劝化修善。能分别说嗔恚和忍果报差别。是名菩萨初忍辱心。修忍辱故。远离众恶身心安乐。是名自利。化导众生皆令和顺。是名利他。以己所修无上大忍化诸众生令同己利。是名俱利。因修忍辱获得端政。人所宗敬。乃至得佛上妙相好。是名庄严菩提之道。忍辱有三。谓身口意。云何身忍。若他加恶侵毁挝打。乃至伤害悉能忍受。见诸众生危逼恐惧。以身代之而无疲怠。是名身忍。云何口忍。若见骂者默受不报。若见非理来呵啧者。当濡语附顺。若有加诬横生诽谤皆当忍受。是名口忍。云何意忍。见有嗔者心不怀恨。若有触恼其心不乱。若有讥毁心亦无怨。是名意忍。世间打者有二种。一者实。二者横。若有罪过若人慊疑为彼所打。自应忍受如服甘露。于彼人所应生恭敬。所以者何。善能教诫调伏于我。令我得离诸过罪故。若横加恶伤害于我。当自思惟我今无罪。当是过去宿业所招。是亦应忍。复应思念。四大假合五众缘会谁受打者。又观前人如痴如狂。我当愍之。云何不忍。又骂者亦有二种。一实二虚。若说实者我应生惭。若说虚者无豫我事。犹如响声亦如风过无损于我。是故应忍。又嗔者亦尔。他来嗔我我当忍受。若嗔彼者。于未来世当堕恶道受大苦恼。以是因缘。我身若被斫截分离。不应生嗔。应当深观往业因缘。当修慈悲怜愍一切。如是小苦不能忍者。我即不能自调伏心。云何当能调伏众生。令得解脱一切恶法成无上果。若有智人乐修忍辱。是人常得颜貌端正多饶财宝。人见欢喜敬仰伏从。复当观察。若人形残颜色丑恶。诸根不具乏于财物。当知皆是嗔因缘得。以是因缘。智者应当深修忍辱。生忍因缘有十事。一者不观于我及我所相。二者不念种姓。三者破除憍慢。四者恶来不报。五者观无常想。六者修于慈悲。七者心不放逸。八者舍于饥渴苦乐等事。九者断除嗔恚。十者修习智慧。若人能成如是十事。当知是人能修于忍。菩萨摩诃萨修于清净毕竟忍时。若入空无相无愿无作。不与见觉愿作和合。不猗着空无相无愿无作。是诸见觉愿作皆空。如是忍者是无二相。是名清净毕竟忍也。若入尽结若入寂灭。不与结生死合。不猗尽结寂灭诸结生死皆空。如是忍者是无二相。是名清净毕竟忍也。若性不自生。不从他生。不和合生。亦无有出不可破坏。不可坏者是不可尽。如是忍者是无二相。是名清净毕竟忍也。无作非作无所猗着。无分别无庄严。无修治无发进。终不造生。如是忍者是无生忍。如是菩萨修行是忍。得受记忍。菩萨摩诃萨修行忍辱性相尽空。无众生故。是则具足羼提波罗蜜

发菩提心经论卷上发菩提心经论卷下

        天亲菩萨造

        后秦龟兹国三藏鸠摩罗什译

    毗梨耶波罗蜜品第七

云何菩萨修行精进。精进若为自利他利及二俱利。如是精进。则能庄严菩提之道。菩萨为欲调伏众生令离苦恼故修精进。修精进者于一切时常勤修集清净梵行。舍离怠慢心不放逸。于诸艰难不饶益事。心常精勤终不退没。是名菩萨初精进心。修精进故。能得世间出世间上妙善法。是名自利。教化众生令勤修善。是名利他。以己所修菩提正因。化诸众生令同己利。是名俱利。因修精进。获得转胜清净妙果。超越诸地乃至速成正觉。是名庄严菩提之道。精进有二种。一者为求无上道故。二者广欲拔济众苦而起精进。菩萨成就十念。乃能发心勤行精进。云何十念。一者念佛无量功德。二者念法不思议解脱。三者念僧清净无染。四者念行大慈安立众生。五者念行大悲拔济众苦。六者念正定聚劝乐修善。七者念邪定聚拔令反本。八者念诸饿鬼饥渴热恼。九者念诸畜生长受众苦。十者念诸地狱备受烧煮。菩萨如是思惟十念。三宝功德我当修集。慈悲正定我当劝励。邪定众生三恶道苦我当拔济。如是思惟专念不乱。日夜勤修无有休废。是名能起正念精进。菩萨精进复有四事。所谓修行四正勤道。未生恶法遮令不起。已生恶法速令除断。未生善法方便令生。已生善法修满增广。菩萨如是修四正勤道而无休息。是名精进。是勤精进能坏一切诸烦恼界。增长无上菩提正因。菩萨若能受于一切身心大苦。为欲安立诸众生故而不疲惓。是名精进。菩萨远离恶时谄曲邪精进已修正精进。所谓修信施戒忍定慧慈悲喜舍。欲作已作当作。至心常行精进无悔。于诸善法及拔济众苦。如救头然心不退没。是名精进。菩萨虽复不惜身命。然为拔济众苦救护正法。当应爱惜。不舍威仪常修善法。修善法时心无懈怠。失身命时不舍如法。是名菩萨修菩提道勤行精进。懈怠之人不能一时一切布施。不能持戒忍于众苦勤行精进摄心念定分别善恶。是故说言六波罗蜜。因于精进而得增长。若菩萨摩诃萨精进增上。则能疾得阿耨多罗三藐三菩提。菩萨发大庄严而起精进。复有四事。一者发大庄严。二者积集勇健。三者修诸善根。四者教化众生。云何菩萨发大庄严。于诸生死心能堪忍不计劫数。于无量无边百千万亿那由他恒河沙阿僧祇劫。当成佛道心不疲倦。是名不懈庄严精进。菩萨积集勇健而起精进。若三千大千世界满中盛火。为见佛故为闻法故。为安止众生于善法故。要当从是火中而过。为调伏众生。心善安止于大悲中。是名勇健精进。菩萨修习善根而起精进。如所发起一切善根。悉以回向阿耨多罗三藐三菩提。为欲成就一切智故。是名修习善根精进。菩萨教化众生而起精进。众生之性不可称计。无量无边同虚空界。菩萨立誓我当度之无有遗余。为欲化度勤行精进。是名教化精进。取要言之。菩萨修助道功德助无上智慧。修集佛法而起精进。诸佛功德无量无边。菩萨摩诃萨发大庄严所行精进亦复如是无量无边。菩萨摩诃萨修行精进无离欲心。拔众苦故。是则具足毗梨耶波罗蜜

    发菩提心经论禅那波罗蜜品第八

云何菩萨修习禅定。禅定若为自利他利及二俱利。如是禅定。则能庄严菩提之道。菩萨为欲调伏众生令离苦恼故修禅定。修禅定者。善摄其心。一切乱想不令妄干。行住坐卧系念在前。逆顺观察髑髅顶脊臂肘胸胁髋髀。胫踝安般数息。是名菩萨初修定心。修禅定故。不受众恶心常悦乐。是名自利。教化众生令修正念。是名利他。以己所修清净三昧离恶觉观。化诸众生令同己利。是名俱利。因修禅定。获得八解乃至首楞严金刚三昧。是名庄严菩提之道。禅定由三法生。云何为三。一从闻慧。二从思慧。三从修慧。从是三法渐渐而生一切三昧。云何闻慧。如所闻法心常爱乐。复作是念。无碍解脱等诸佛法。要因多闻而得成就。作是念已。于一切求法时转加精勤。日夜常乐听法无有厌足。是名闻慧。云何思慧。思念观察一切有为法如实相。所谓无常苦空无我不净。念念生灭不久败坏。而诸众生忧悲苦恼憎爱所系。但为贪恚痴火所然。增长后世苦恼大聚。无有实性犹如幻化。见如是已。于一切有为法即生厌离。转加精勤趣佛智慧。思惟如来智慧不可思议不可称量。有大势力无能胜者。能至无畏安隐大城不复转还。能救无量苦恼众生。如是知见佛无量智。见有为法无量苦恼。志愿进求无上大乘。是名思慧。云何修慧。从初骨观乃至阿耨多罗三藐三菩提。皆名修慧。离欲不善法。有觉有观离生喜乐入初禅。灭觉观内清净心一处。无觉无观定生喜乐入二禅。离喜故行舍。心念安慧身受乐。诸贤圣能说能舍。常念受乐入三禅。断苦断乐故。先灭忧喜故。不苦不乐行舍念净入四禅。过一切色相。灭一切有对相。不念一切别异相故。知无边虚空。即入虚空无色定处。过一切虚空相。知无边识。即入无色识定处。过一切识相。知无所有。即入无所有无色定处。过一切无所有处。知非有想非无想。安隐即入无色非有想非无想处。但随顺诸法行故而不乐着。求无上乘成最正觉是名修慧。菩萨从是闻思修慧。精勤摄心。则能成就通明三昧禅那波罗蜜

复次。菩萨修定。复有十法行。不与声闻辟支佛共。何等十。一者修定无有吾我。具足如来诸禅定故。二者修定不味不着。舍离染心不求己乐故。三者修定具诸通业。为知众生诸心行故。四者修定为知众心。度脱一切诸众生故。五者修定行于大悲。断诸众生烦恼结故。六者修定诸禅三昧。善知入出过于三界故。七者修定常得自在。具足一切诸善法故。八者修定其心寂灭。胜于二乘诸禅三昧故。九者修定常入智慧过诸世间到彼岸故。十者修定能兴正法。绍隆三宝使不断绝故。如是定者。不与声闻辟支佛共。复次。为知一切众生烦恼心故。是故修集诸禅定法助成住心。令此禅定住平等心。是名为定。如是等定。则等于空无相无愿无作。空无相无愿无作等者则众生等。众生等者则诸法等。入如是等是名为定。复次。菩萨虽随世行不杂于世。舍世八法灭一切结。远离愦闹乐于独处。菩萨如是修行禅定。心安止住离世所作。复次。菩萨修定。具诸通智方便慧故。云何为通。云何为智。若见色相若闻音声。若知他心若念过去。若能遍至诸佛世界。是名为通。若知色即法性。解了音声心行。性相寂灭三世平等。知诸佛界同虚空相而不证灭尽。是名为智。云何方便。云何为慧。入禅定时生大慈悲不舍誓愿。心如金刚。观诸佛世界。庄严菩提道场。是名方便。其心永寂无我无众生。思惟诸法本性不乱。见诸佛界同于虚空。观所庄严同于寂灭。是名为慧。是名菩萨修行禅定通智方便慧故差别。四事俱行。得近阿耨多罗三藐三菩提。菩萨摩诃萨修行禅定。无余恶心。以不动法故。是则具足禅那波罗蜜

    发菩提心经论般若波罗蜜品第九

云何菩萨修习智慧。智慧若为自利他利及二俱利。如是智慧。则能庄严菩提之道。菩萨为欲调伏众生令离苦恼故修智慧。修智慧者。悉学一切世间之事。舍贪嗔痴建立慈心。怜愍饶益一切众生。常念拔济为作将导。能分别说正道邪道及善恶报。是名菩萨初智慧心。修智慧故远离无明。除烦恼障及智慧障。是名自利。教化众生令得调伏。是名利他。以己所修无上菩提。化诸众生令同己利。是名俱利。因修智慧获得初地乃至萨婆若智。是名庄严菩提之道。菩萨修行智慧。有二十心能渐建立。何谓二十。当发善欲亲近善友心。舍离憍慢不放逸心。随顺教诲乐听法心。闻法无厌善思惟心。行四梵行修正智心。观不净行生厌离心。观四真谛十六圣心。观十二因缘修明慧心。闻诸波罗蜜念欲修集心。观无常苦无我寂灭心。观空无相无愿无作心。观阴界入多过患心。降伏烦恼非伴侣心。护诸善法自伴侣心。抑制恶法令除断心。修习正法令增广心。虽修二乘常舍离心。闻菩萨藏乐奉行心。自利利他随顺增进诸善业心。持真实行求一切佛法心。复次。菩萨修行智慧。复有十法善思惟心。不与声闻辟支佛共。何谓为十。思惟分别定慧根本。思惟不舍断常二边。思惟因缘生起诸法。思惟无众生我人寿命。思惟无三世去来住法。思惟无发行而不断因果。思惟法空而殖善不懈。思惟无相而度众生不废。思惟无愿而求菩提不离。思惟无作而现受身不舍。复次。菩萨复有十二善入法门。何谓十二。善入空等三昧而不取证。善入诸禅三昧而不随禅生。善入诸通智而不证无漏法。善入内观法而不证决定。善入观一切众生空寂而不舍大慈。善入观一切众生无我而不舍大悲。善入生诸恶趣而非业故生。善入离欲而不证离欲法。善入舍所欲乐而不舍法乐。善入舍一切戏论诸觉而不舍方便诸观。善入思量有为法多过患而不舍有为。善入无为法清净远离而不住无为。菩萨能修一切善入法门。即能善解三世空无所有。若作是观。观三世空智慧力故。若于三世诸佛所种无量功德。悉以回向无上菩提。是名菩萨善观三世方便。复次。虽见过去尽法不至未来。而常修善精进不懈。观未来法虽无生出。不舍精进愿向菩提。观现在法虽念念灭。其心不忘发趣菩提。是名菩萨观三世方便。过去已灭未来未至现在不住。虽如是观心心数法生灭散坏。而常不舍聚集善根助菩提法。是名菩萨观三世方便。复次。菩萨观一切善不善我无。我实不实空不空。世谛真谛正定邪定。有为无为有漏无漏。黑法白法生死涅槃。如法界性一相无相此中无法可名无相。亦无有法以为无相。是则名为一切法印不可坏印。于是印中亦无印相。是名真实智慧方便般若波罗蜜。发菩提心菩萨摩诃萨。应如是学。应如是行。如是行者即近阿耨多罗三藐三菩提。菩萨摩诃萨修行智慧心无所行。法性净故。是则具足般若波罗蜜

    发菩提心经论如实法门品第十

若善男子善女人。修习六波罗蜜。求阿耨多罗三藐三菩提者。应离七法。何等为七。一者离恶知识。恶知识者。所谓教人舍离上信上欲上精进集众杂行。二者离于女色。贪着嗜欲。狎习世人而与执事。三者离于恶觉。自观形容贪惜爱重。染着守护谓可久保。四者离于嗔恚暴慢嫉忌。兴起诤讼坏乱善心。五者离于放逸憍慢懈怠。自恃小善轻蔑于人。六者离于外道书论及世俗文颂绮饰言辞。非佛所说不应赞诵。七者不应亲近邪见恶见。如是七法所应远离。如来说言。不见更有余法深障佛道。如此七法是故菩萨应当远离。若欲疾得无上菩提。当修七法。何谓为七。一者菩萨当亲近善知识。善知识者。所谓诸佛及诸菩萨若声闻人。能令菩萨住深法藏诸波罗蜜。亦是菩萨善知识也。二者菩萨应当亲近出家。亦当亲近阿兰若法。离于女色及诸嗜欲。不与世人而共从事。三者菩萨应当自观。形如粪土但盛臭秽。风寒热血无可贪着。日当就死宜思厌离精勤修道。四者菩萨应当常行和忍恭敬柔顺。亦劝化他人令住忍中。五者菩萨应当修集精进常生惭愧。敬奉师长怜愍穷下。见厄苦者以身代之。六者菩萨应当修习方等大乘诸菩萨藏。佛所赞法受持读诵。七者菩萨应当亲近修习第一义谛。所谓实相一相无相。若诸菩萨欲疾逮得无上菩提。应当亲近如是七法。复次。若人发菩提心。以有所得故于无量阿僧祇劫。修集慈悲喜舍布施持戒忍辱精进禅定智慧。当知是人不离生死不向菩提。何以故。有所得心及诸得见。阴界入见我见人见众生见寿命见。慈悲喜舍施戒忍进定智等见。取要言之。佛法僧见及涅槃见。如是有所得见即是执着心。执著者。是名邪见。所以者何。邪见之人轮转三界永离出要。是执著者亦复如是。永离出要。终不能得阿耨多罗三藐三菩提。若人发菩提心。应当观察是心空相。何等是心。云何空相。心名意识。即是识阴意入意界。心空相者。心无心相亦无作者。何以故。是心相空无有作者。无使作者。若无作者则无作相。若菩萨解了如是法者。于一切法即无执着。无执着故于诸善恶解无果报。于所习慈了无有我。于所习悲了无众生。于所习喜了无有命。于所习舍了无有人。虽行布施不见施物。虽行持戒不见净心。虽行忍辱不见众生。虽行精进无离欲心。虽行禅学无除恶心。虽行智慧心无所行。于一切缘皆是智慧。而不着智慧。不得智慧。不见智慧。行者如是修行智慧。而无所修亦无不修。为化众生现行六度而内清净。行者如是善修其心。于一念顷所种善根。福德果报无量无边。百千万亿阿僧祇劫不可穷尽。自然得近阿耨多罗三藐三菩提

    发菩提心经论空无相品第十一

往昔一时佛在迦兰陀竹林。与诸大众无量集会。尔时世尊斑宣正法。告诸大众。如来所说诸法无性空无所有。一切世间所难信解。何以故。色无缚无解。受想行识无缚无解。色无相离诸相。受想行识无相离诸相。色无念离诸念。受想行识无念离诸念。眼色耳声鼻香舌味身触意法亦复如是。无取无舍无垢无净。无去无来无向无背。无闇无明无痴无慧。非此岸非彼岸非中流。是名无缚。无缚故空。空名无相。无相亦空。是名为空。空名无念。无念亦空。是名为空。空念亦空。是名为空。空中无善无恶。乃至亦无空相。是故名空。菩萨若如是知阴界入性。即不取着。是名法忍。菩萨如是忍故。得授记忍。诸佛子。譬如菩萨仰书虚空。悉写如来十二部经。经无量劫佛法已灭。求法之人无所见闻。众生颠倒造恶无边复有他方净智慧人。怜愍众生广求佛法。行到于此见空中字。文画分明即便识之。读诵受持如所说行。广演分别利益众生。此书空者识空字人可思议不。而得宣传修习受持。引导众生令离系缚。诸佛子。如来说言。过去世时求菩提道。得值三十三亿九万八千诸佛。尔时皆为转轮圣王。以一切乐具。供养诸佛及弟子众。以有所得故不得授记。于后复值八万四千亿九万辟支佛。亦以四事尽形供养。过是以后。复值六百二十万一千二百六十一佛。尔时皆为转轮圣王。以一切乐具尽形供养。诸佛灭后起七宝塔供养舍利。后佛出世奉迎劝请转正法轮。供养如是百千万亿诸佛。是诸如来皆于空法中说诸法相。以有所得故亦不得授记。如是展转乃至得值然灯佛兴。见佛闻法即得一切无生法忍。得是忍已乃得授记。然灯如来于空法中说诸法相。度脱无量百千众生。而无所说亦无所度。牟尼世尊兴出于世。于空法中说有文字。示教利喜普得受行。而无所示亦无受行。当如是法性相尽空。书者亦空识者亦空。说者亦空解者亦空。从本来空未来亦空现在亦空。而诸菩萨积集万善方便力故。精勤不懈功德成满。得阿耨多罗三藐三菩提。此实甚难不可思议。于无法中说诸法相。于无得中说有得法。如此之事诸佛境界。以无量智乃可得解。非是思量所能得知。新发意菩萨诚心敬仰爱乐菩提。信佛语故渐能得入。云何为信。信观四谛。除诸烦恼妄见结缚得阿罗汉。信观十二因缘。灭除无明生起诸行得辟支佛。信修四无量心六波罗蜜得阿耨多罗三藐三菩提。是名信忍。众生于无始生死取相执着不见法性。当先观察自身五阴假名众生。是中无我无有众生。何以故。若有我者我应自在。而诸众生常为生老病死之所侵害不得自在。当知无我。无我即无作者。无作者亦无受者。法性清净如实常住。如是观察未能究竟。是名顺忍。菩萨修信顺忍已。不久当成最上法忍

    发菩提心经论功德持品第十二

菩萨具足修无相心。而心未曾住于作业。是菩萨于诸业相知而故作。为修善根求菩提故不舍有为。为诸众生修大悲故不住无为。为一切佛真妙智故不舍生死。为度无边众生令无余故不住涅槃。是名菩萨摩诃萨深心求阿耨多罗三藐三菩提。诸佛子。菩萨成就十法。终不退失无上菩提。何谓为十。一者菩萨深发无上菩提之心。教化众生亦令发心。二者常乐见佛以己所珍奉施供养深种善根。三者为求法故以尊敬心供养法师听法无厌。四者若见比丘僧坏为二部。互起诤讼共相过恶。勤求方便令其和合。五者若见国土邪恶增上佛法欲坏。能读诵说乃至一偈令法不绝。专心护法不惜身命。六者见诸众生恐畏苦恼。为作救护施以无畏。七者发勤修行求如是等方等大乘甚深经法诸菩萨藏。八者得是法已受持读诵。如所说行如所说住。九者自住于法。亦能劝导令多众生入是法中。十者入法中已能为解说。示教利喜开悟众生。菩萨成就如是十法。于无上菩提终不退失。菩萨应当如是修行此经。如是经典不可思议。所谓能生一切大慈悲种。是经能开悟引导具缚众生令其发心。是经能为向菩提者而作生因。是经能成一切菩萨无动之行。是经能为过去未来现在诸佛之所护念。若有善男子善女人。欲勤修集无上菩提。当广宣流布如是经典。于阎浮提使不断绝。令无量无边众生得闻是经。若有善男子善女人闻是经者。是诸人等悉得猛利不可思议大智慧聚。不可称量福德果报。所以者何。是经能开无量清净慧眼。能令佛种相续不断。能救无量苦恼众生。能照一切无明痴闇。能破四魔及诸魔业。能坏一切外道邪见。能灭一切烦恼大火。能消因缘生起诸行。能断悭贪破戒嗔恚懈怠乱意愚痴六极重病能除业障报障法障烦恼障诸见障无明障智障习障。取要言之。此经能令一切恶法消灭无余。能令一切善法炽然增长。若有善男子善女人。闻是经已。欢喜爱乐生希有心。当知是人已曾供养无量诸佛深种善根。所以者何。此经是三世诸佛之所履行。是故行者得闻是经。当自庆幸获大善利。若有书写读诵此经。当知此人所获福报无量无边。所以者何。此经所缘无边故。兴发无量大誓愿故。摄受一切诸众生故。庄严无上大菩提故。所获福报亦复如是无有限量。若能解其义趣如说修行。一切诸佛于阿僧祇劫。以无尽智说其福报。亦不能尽。若有法师说是经处。当知是中便应起塔。何以故。是真实正法所出生处故。是经随在国土城邑聚落寺庙精舍。当知是中即有法身。若人供养香花伎乐悬缯幡盖歌呗赞叹合掌恭敬。当知是人已绍佛种。况复具足受持经者。是诸人等成就功德智慧庄严。于未来世当得授记。决定当成阿耨多罗三藐三菩提

发菩提心经论卷下


方便心论

    No. 1632

方便心论一卷

        后魏西域三藏吉迦夜译

    明造论品第一

  若能解此论　　则达诸论法
  如是深远义　　今当广宣说

问曰。不应造论。所以者何。凡造论者。多起恚恨憍逸贡高。自扰乱心少柔和意。显现他恶自叹己善。如斯众过智者所呵。是故一切诸贤圣人。无量方便断诤论者。常乐远离如舍毒器。又造论者。内实调柔外观多过。是以若欲自利利人。应当舍此诤论之法。答曰不然。今造此论不为胜负利养名闻。但欲显示善恶诸相故造此论。世若无论迷惑者众。则为世间邪智巧辩。所共诳惑起不善业。轮回恶趣失真实利。若达论者则自分别善恶空相。众魔外道邪见之人。无能恼坏作障碍也。故我为欲利益众生。造此正论。又欲令正法流布于世。如为修治庵婆罗果。而外广植荆棘之林。为防果故。今我造论亦复如是。欲护正法不求名闻故。汝前说长诤论者。是事不然。为护法故故应造论。问曰。汝先言解此论者。达诸论法当说其相。答曰。此论分别有八种义。若有能通达解其义趣。则能广为其余诸论。如种稻麦以水溉灌则嘉苗滋茂。不去稊稗善谷不生。若人虽闻此八不解其义。则于诸论皆生疑惑。设有明解斯八义者。决定能达一切论法。问曰。汝言解此论者决了论法。今诸外道有论法不耶。答曰有。如卫世师有六谛。所谓陀罗骠求那总谛别谛作谛不作谛。如斯等比皆名论法。虽善通达犹不了别诸余经论。如此八种深妙论法我当略说。为开诸论门。为断戏论故。一曰譬喻。二随所执。三曰语善。四曰言失。五曰知因。六应时语。七似因非因。八随语难。喻有二种。一具足喻。二少分喻。随所执者名究竟义。语善者谓语顺于义。言失者谓言乖于理。知因者能知二因。一生因。二了因。语应时者若先说界入后说五阴。名不应时。若善通达言语次第。是则名曰应时语也。似因者如焰似水而实非水。若有论者严饰言辞以为水者是名似因。随言难者如言新衣。即便难曰。衣非是时云何名新。如是等名随言难也。我已略说此八种义。今当次第广明其相。问曰。汝前言喻今立喻者作何方便。答曰。若说喻者。凡圣同解然后可说。如言是心动发犹如迅风。一切凡夫知风动故。便得决了心为轻躁。若不知者不得为喻。问曰。何故不但说正义而说喻耶。答曰。凡说喻者为明正义。问曰。汝先言凡圣同解方得为喻。何者名同云何为异。答曰。如前风喻名之为同。圣得涅槃而凡不得。是名为异。问曰。已说喻相。执相云何。答曰。随其所执广引因缘立义坚固。名为执相。问曰。执法有几。答曰有四。一一切同。二一切异。三初同后异。四初异后同。问曰。汝今应当说此四相。答曰。凡欲立义。当依四种知见。何等为四。一者现见。二者比知。三以喻知。四随经书。一切同者。如说者言无我我所。问者亦说无我我所。名一切同。一切异者。说者言异问则说一。是名俱异。初同后异者。如说者曰现法皆有。神非现见亦复是有。问者或言现见之法可名为有。神若非现何得有耶。若言比知而有神者。要先现见后乃可比。神非现法云何得比。若复以喻明神有者。有相似法然后得喻。神类何等而为喻乎。若随经书证有神者。是事不可。经书意亦难解。或时言有或时言无。云何取信。是名初同后异。初异后同者。如说者言无我无所。而问者曰有我有人。此二论者俱信涅槃。是名初异后同。复次执法随义有无量相。如十二因缘苦习灭道三十七品四沙门果。如是等法名佛正义。如说晨朝礼敬杀生祭祠。然众香木献诸油灯。如是四种名事火外道。六十三字四句之义。是音声外道。明药有六。一药名。二药德。三药味。四药势力。五和合。六成熟。是名医法。如六谛等卫世师有。冥初一义多我异解。是僧伽有八微。所谓四大空意明无明八自在。一能小。二为大。三轻举。四远到。五随所欲。六分身。七尊胜。八隐没。是名踰伽外道。有命无命罪福漏无漏差戒具足缚解。五智闻智思智自觉智慧智义智。六障不见障苦受障愚痴障命尽障性障名障。四浊嗔慢贪谄。是皆名为尼乾陀法。又有说言。一切诸法尽是有故当知是一。又一切法尽有求那亦名为一。又一切法从冥初生。根本一故当知是一。又头足等成身与身为一。又依者是空当知是一。如是等名计一外道。又言一切法异。所以者何。如头足等与身为异。又众相差别如牛非马等故知法异。如是等名计异外道。若言一切法有故一者。有法二种。一有觉二无觉。云何为一。因不同故。如是等法皆已总破。论者言。若有人说苦习灭道十二因缘有无等法。为一异者。皆非正因。所以者何。若言一者则堕苦边。若言异者则堕乐边。是故有说。若一若异必堕二边。非佛法义。复次如有说言。涅槃之性无苦无乐。何以知之。凡一切法以有觉故故有苦乐。涅槃无觉云何言乐。复有说者而言有乐。所以者何。乐有三种。一乐受乐。二无恼害。三无希求。涅槃之中无所求故。是故得名涅槃为乐。又有问言。我先已知涅槃是常。今与诸行为异不耶。答曰。汝若先知涅槃常者。云何谓为同诸行耶。诸行之性流转败坏。涅槃之体是常是乐。谁有智者言同于行。复有问言。神我之性虽有形色。而未分别常与无常。答曰若一切法有对碍者皆悉无常。如瓶有碍则可破坏。我若如是必亦无常。然我有形非经所载无有道理。如取沙砾名为珍宝。汝亦如是言多虚妄。问曰。汝何故言我无形耶。答曰。我先已说瓶有形碍故可毁坏。我若如是亦应磨灭。云何复问何故而说我无形耶。复次复有不定执相。如或问言。以物为声常无常乎。答曰。为分成者皆悉无常。声亦分成岂独常也。问曰。何名声物。答曰。若未分别云何为问。问曰。我身与命。于未来世独受苦乐。共身受耶。答曰。此身灭已我余身受。问曰。何者是我。于未来世受苦乐乎。答曰。汝前言我。云何复问有我不耶。此非道理。问曰。已说执义。云何名为语善相耶。答曰。不违于理不增不减。善解章句应相说法。所演譬喻而无违背。无能轻诃。以是因缘名为语善。问曰。不违于理。其事云何。答曰。有人计识是我。以诸行空无我故。非一切行皆是于识此非道理。行是识因。因无我故识云何我。问曰。一切诸法皆悉无常。声非一切是故为常。答曰。汝言一切声有何义非一切耶此说非因。又一切法有造作者。皆悉无常。如火传等声亦如是。是故无常。是则名为不相违相

问曰。云何名为言不增减。答曰。我当先说增减之相。减有三种。一因减。二言减。三喻减。若言六识无常犹如瓶等。不说因缘。是名因减。若言是身无我众缘成故。声亦无我从缘而有。是名喻减。若言四大无常如瓶造作。是名言减。与上相违。名为具足。又具足者。若人言我。应当问言。汝所说我为常无常。若无常者则同诸行便是断灭。若令常者即是涅槃更何须求。是则名为具足之相。问曰。何名言增。答曰。增亦三种。一因增。二喻增。三言增。若言声法无常和合成故。如瓶造作则为无常。又言声是空之求那。空非对碍声是色法。云何相依。是名因增。若言五根无常如呼声响造作法故声亦如是。何以知之。为唇口等之所出故。是名喻增。如言微尘细小虚空遍大。如此二法则名为常。声不如是故曰无常。是名喻增。又说声是无常众缘成故。若言常者是事不然。所以者何。有二种因。一从形出。二为根了。云何言常。又同异法皆无常故。是名言增。问曰。何语能令世人信受。答曰。若为愚者分别深义。所谓诸法皆悉空寂。无我无人如幻如化无有真实。如斯深义智者乃解。凡夫若闻迷没堕落。是则不名应时语也。若言诸法有业有报。及缚解等作者受者。浅智若闻即便信受。如钻燧和合则火得生。若所演说应前众生则皆信乐。如是名为随时而语。问曰。何名言证。答曰。虽多所说善能忆念。若宣诸义深得其相。所立坚固令人爱乐。如言诸法皆空无主。现见万物众缘成故。是名言证。问曰。何名言失。答曰。与上相违名为言失。又二种语亦名为失。何等为二。一义无异而重分别。二辞无异而重分别。云何一义而重分别。如言憍尸迦。亦言天帝释。亦言富兰陀那。是名义一名异而重分别。名义同者如言因陀罗。又言因陀罗。是名义无异而重分别。复次凡所言说。但饰文辞无有义趣。皆名为失。又虽有义理而无次第。亦名言失。如偈说

  如人赞叹　　天帝释女　　名曰金色
  足手殊胜　　而便说于　　释提桓因
  坏阿修罗　　三种之城　　如是名为
  无次第语

问曰。何名知因。答曰。知因有四。一现见。二比知。三喻知。四随经书。此四知中现见为上。问曰。何因缘故现见上耶。答曰。后三种知由现见故。名之为上。如见火有烟。后时见烟便知有火。是故现见为胜。又如见焰便得喻水。故知先现见故然后得喻。后现见时始知真实。问曰。已知三事由现故知。今此现见何者最实。答曰。五根所知有时虚伪。唯有智慧正观诸法。名为最上。又如见热时焰旋火轮乾闼婆城。此虽名现而非真实。又相不明了故见错谬如夜见杌疑谓是人。以指按目则睹二月。若得空智名为实见。问曰。已知现相。比相云何

答曰。前已分别今当更说。比知有三。一曰前比。二曰后比。三曰同比。前比者。如见小儿有六指头上有疮。后见长大闻提婆达。即便忆念本六指者。是今所见。是名前比。后比者。如饮海水得其碱味。知后水者皆悉同碱。是名后比。同比者。如即此人行至于彼。天上日月东出西没。虽不见其动。而知必行。是名同比

问曰。闻见云何。答曰。若见真实耆旧长宿诸佛菩萨。从诸贤圣听受经法。能生知见。是名闻见。譬如良医善知方药慈心教授是名善闻。又诸贤圣证一切法有大智慧。从其闻者是名善闻。问曰。喻相云何

答曰。若一切法皆空寂灭如幻如化。想如野马。行如芭蕉。贪欲之相如疮如毒。是名为喻。如是四事名之为因。能通达者名为知因。问曰。何名似因。答曰。凡似因者。是论法中之大过也。应当觉知而速舍离。如此似因我当宣说。似因随相有无量义。略则唯八。一随其言横为生过。二就同异而为生过。三疑似因。四过时语。五曰类同。六曰说同。七名言异。八曰相违

问曰。如此八法当广分别

答曰。言那婆者凡有四名。一名新。二名九。三名非汝所有。四名不着。如有人言。我所服者是那婆衣。难曰。今汝所著唯是一衣。云何言九

答曰。我言那婆乃新衣耳。非谓九也。难曰。何名为新

答曰。以那婆毛作故名新

问曰。实无量毛。云何而言那婆毛耶

答曰。我先已说新名。那婆非是数也。难曰。今知此衣是汝所有。云何乃言非我衣乎

答曰。我言新衣。不言此物非汝所有。难曰。今现见汝身着此衣。云何而言不着衣耶

答曰。我言新衣不言不着。是名似因。亦名随言而为生过。又复随言而生过者。如说烧山。难曰。实焚草木。云何烧山。是名随言生过。乃至诸法皆亦如是。复次随言生过。凡有二种。一如前说。二于同异而为生过。如言有为诸法皆空寂灭犹如虚空。难曰。若尔二者皆是空无。无性之法便同虚空。如是名为同异生过

问曰。何故名生

答曰。有故名生。如泥有瓶性故得生瓶。难曰。若泥有瓶性。泥即是瓶。不应假于陶师轮绳和合而有。若泥是有故生瓶者。水亦是有应当生瓶。若水是有不生瓶者。泥云何得独生瓶耶。是名同异寻言生过

问曰。生疑似因其相云何

答曰。如有树杌似于人故。若夜见之便作是念。杌耶人耶。是则名为生疑似因。问曰。云何名为过时似因

答曰。如言声常。韦陀经典从声出故。亦名为常。难曰。汝今未立声常因缘。云何便言韦陀常乎

答曰。如虚空无形色故常。声亦无形是故为常。言虽后说义亦成就

难曰。此语过时。如舍烧已尽方以水救。汝亦如是。是名过时。问曰。类同云何。答曰。我与身异故我是常。如瓶异虚空故瓶无常。是名类同

难曰。若我异身而名常者。瓶亦异身。瓶应名为常。若瓶异身犹无常者。我虽异身云何常乎。是名同类

问曰说同云何

答曰。如言虚空是常无有触故。意识亦尔。是名说同。问曰。何名言异。答曰。如言五尘无常为根觉故。四大亦尔。是故无常。难曰。龟毛盐香是无所有。而为意识所得岂无常耶。是名言异。问曰。相违云何

答曰。相违二种。一喻相违。二理相违。如言我常无形碍故如牛。是名喻违。理违者。如婆罗门统理王业作屠猎等教。刹利种坐禅念定。是名理违。如此二法。愚者不解谓为真实。是名相违。问曰。何者名为不相违耶

答曰。异上二法名不相违。是名似因

    明负处品第二

论者言。已说如上八种论法。复有众多负法。今当宣说。问曰。何名语法

答曰。如言四大是假名。所以者何。为色等法之所成故。复有人言四大实有。何以知之。坚是地性。乃至动是风性故知为实。更相违返便生诤讼。如有言地是成身因缘。余大亦尔

难曰。地等亦能成一切物。云何而言唯成身乎。是名非语。若不如是是名是语。问曰。何为名负

答曰。如言声常无形色故如空

难曰。声虽无形而为根觉。有对有碍如瓶造作。而虚空性非是作法。何得为喻。此名负义立曰。瓶是有形可为无常。声无形法何得为喻

难曰。声虽异瓶而为根觉为耳所闻。是故无常。问曰。何等之义不堕负处

答曰。诸行与识作故无常。涅槃非作故常。如此之言句味真正。名非负处。问曰。何者之言而可难耶

答曰。若语颠倒立因不正引喻不同。此则可难。如言想能断结。问者曰。云何以想便断结耶。以不先言智从想发直言想故。此语颠倒则为可难

问曰。何因缘故重说此语

答曰。欲令人知立无执义必堕负处故说。复次应问不问。应答不答。三说法要不令他解。自三说法而不别知。皆名负处。又共他论彼义短阙而不觉知。余人语曰。此义错谬汝不知乎。即堕负处。又他正义而为生过。亦堕负处。又有说者。众人悉解而独不悟。亦堕负处。问亦如是。如此负处。是议论之大棘刺为深过患。应当觉知速宜远离

问曰。问有几种

答曰。有三种。一说同。二义同。三因同。若诸论者。不以此三为问答者。名为违错。此三答中若少其一则不具足。若言我不广通如此三问。随我所解便当相问。是亦无过。说同者。如言无我。还依此语后方为问。是名语同。义同者。但取其意是名义同。因同者。知他意趣之所因起。是名因同。若能如是名非负处。若言轻疾听者不悟亦堕负处。问曰唯有此等更有余耶。答曰有。所谓语少语多。无义语非时语。义重舍本宗等。悉名负处。若以此等为前人说。亦堕负处

问曰。云何名为违本宗耶

答曰。如言识是常法。所以者何。识体二种。一识体生。二识体用。瓶亦二种。一瓶体生。二瓶体用。然识生时即有用故。故名为常。瓶体生已后方有用。故是无常

难曰。若以生便有用名为常者。灯生时即用应当是常

答曰。灯为眼见声为耳闻。云何为喻。是舍本宗名堕负处。复次有说神常。何以知之。非根觉故如虚空。不为根觉故常

难曰。微尘不为根得而是无常

答曰。神非作故常。微尘造作故无常。难曰。汝前言非觉今言不作。是违本宗。答曰。汝言我违。汝乖我言岂不违乎。难曰如此之相可有斯理。我言违者。汝之所说自乖前义故言违耳。又汝前言。不大分别故我生疑。非我违汝。如是以疑为违。亦堕负处

    辩正论品第三

论者言。若人说有众生乃至亦有寿者命者。何以知之。为根觉故。如无余涅槃不为根觉故无。众生不尔故知是有。神是常法。何以故。如阿罗汉果。唯当时有而前后无故知为无。如第二头第三手等。本无今有故知前无。有已还灭故知后无。神不如是。是以为常

难曰。如树根地下水。不见言无。阿罗汉者亦复如是。非是无法。汝自不证。立曰不然。水以地障是故不见。今阿罗汉有何障碍而不见乎。是以知无。难曰。汝以第二头第三手不可见故。明无罗汉。是事不然。虽无二头非无第一。言无罗汉乃是悉无。何得为喻。又汝言以无觉知无涅槃者。是亦不然。如大海水不知几渧。可言无耶。若不知渧数而犹有海。涅槃亦然。虽不可觉实自有之。而言无者应说因缘。若不能说。汝义自坏。是则名为如法论也

复次若以无觉明无涅槃。他则生疑。如夜见树心便生疑。杌耶人耶。当知此树非定人因非定杌因。若令无觉定与涅槃为无因者。不应生疑。又诸业报不可毁灭故有涅槃。所以者何。譬如大火焚烧山林故火是灭因。今此业报是何灭因而得灭耶。若得涅槃则便散坏。立曰。实有灭因。障故不见。难曰。亦有涅槃。但以痴障故不见耳。复次汝今若不分别诸业有灭因者。汝义自坏。若灭因无故而不说者亦无障碍。何须说耶。以是等缘知业不灭。是则名为如法论也。立者曰。汝若以海水有故成有涅槃。岂复能令二头有耶。若设二头不可为有。涅槃云何独得有耶。汝海水喻尚不能立。涅槃为有。何能成于二头有乎。难曰。汝意若谓涅槃无者。为有是无。为当无无。若无无者。云何觉知无涅槃耶。若有此无。云何而言都无所有。若言虽有是无涅槃之法。犹自无者尚有是无。何故不得有涅槃耶。当说因缘。若不能说。当知涅槃决定实有。是亦名为如法论也

问曰。神为是常为无常乎。立曰。神非造作故常。瓶等作法故是无常。难曰。若以无作明神常者。是事不然。何以知之。生人疑故。若非造作神即常者。不应生疑为常无常。以生疑故当知有过。立曰。此过非但唯独我有。一切论者皆有斯过。如言声常无形色故。有过去身以宿命智知故。如是立义如前生疑。故一切处皆有是过。难曰。喻者决疑。汝所引喻令我生疑。是不成喻。喻不成者义则自坏。即堕负处。而汝乃言一切有过非独我有。斯则自咎非余过也。所以者何。如人被诬而不自明。而言一切皆悉是盗。当知此人即自为盗。汝亦如是故堕负处。今汝若欲自宣明者。理极于先。必欲复说则堕多过。汝第一立第二已破。第三之义我又为难。欲以第五而止过者。不出于初及汝后义。是则为重。若有重过即堕负处

问曰。设第六人更可问乎

答曰。第五之人已成于过。何有第六得为问耶。若必说之则同前过。问既有过。答应默然。复次第六人过。而第五者不得诘之。所以者何。由第五故是第六人便得为问。既自有过何由过彼。如是等名正法论也

    相应品第四

问曰。汝已分别如法正论。云何名为相应义耶

答曰。问答相应有二十种。若人能以此二十义助发正理。是人则名解真实论。若不如是。不名通达议论之法。此二十种。要则有二。一异二同。以同显义名同。以异显义名异。凡为义者必依此二故。此二者通二十法。云何名同。如言烦恼尽处是无所有。虚空之性亦无所有。是名为同。云何名异。如说涅槃非作故常。则知诸行作故无常。是名为异

问曰。此同异义云何为难

答曰。欲难同者。作如是言。色以眼见声为耳闻。云何言同。若色异声色自无常声应是常。若难异者。以色根觉故无常。我非根觉故常。瓶我俱有有。若同者。瓶既无常。我亦应尔。若说瓶有异我有者。可言我常而瓶无常。常有既同我应无常。如斯难者。有二十种。一曰增多。二曰损减。三说同异。四问多答少。五答多问少。六曰因同。七曰果同。八曰遍同。九不遍同。十曰时同。十一不到。十二名到。十三相违。十四不违。十五疑。十六不疑。十七喻破。十八闻同。十九闻异。二十不生。是名二十问答之法

问曰。此二十法应分别说

答曰。增多者。如言我常非根觉故。虚空非觉是故为常。一切不为根所觉者尽皆是常。而我非觉得非常乎。难曰。虚空无知故常。我有知故云何言常。若空有知则非道理。若我无知可同于虚空。如其知者必为无常。是名增多。损减者。若空无知而我有知。云何以空喻于我乎。是名损减。同异者。如立我常引空为喻。空我一者一法何得以空喻我。若其异者不得相喻。是名同异。复次汝立我常言非根觉。如虚空非根觉故常。然非根觉不必尽常。何得为证。是名问多答少。复次汝立我常言非根觉。非根觉法凡有二种。微尘非觉而是无常。虚空非觉而是常法。汝何得言非觉故常。是名第五问少答多。复次汝以非觉为因故知我常者。空与我异。云何俱以非觉为因。是名因同。复次五大成者皆悉无常。虚空与我亦五大成。云何言常。是名果同。复次汝以虚空非觉故常。然虚空者遍一切处。一切处物岂非觉也。是名遍同。复次微尘非遍。而非根觉是无常法。我非根觉云何为常。是不遍同。复次汝立我常言非根觉。为是现在过去未来。若言过去过去已灭。若言未来未来未有。若言现在则不为因。如二角并生。则不得相因。是名时因。复次汝立我常以非根觉。到故为因。为不到乎。若不到则不成因。如火不到则不能烧。如刀不到则不能割。不到于我。云何为因。是名不到。复次若到因者。到便即是无有因义。是名为到。复次汝以一切无常。我非一切故常者。我即是有故应无常。如[疊*毛]少烧。以多不烧应名不烧。是名相违。复次汝以我非根觉同于虚空。虚空不觉我亦应尔。若我觉者虚空亦应觉于苦乐。虚空与我无有异故。是不相违。复次我同有故不定为常。容可生疑。为常无常。是名为疑。复次汝言有我非根所觉。则可生疑。有何障故非根觉耶。当说因缘。若无因缘。我义自坏。是名不疑。复次汝以我非根觉故为常者。树根地下水亦非根觉而是无常。我云何常。是名喻破。复次汝以经说。我非觉故知是常者。经中亦说无我我所。尼干法中明我非常。我定常者。诸经不应有异有同。是名闻同。复次若汝信一经。以我为常。亦应信余经我为无常。若二信者。一我便应亦常无常。是名闻异。复次汝以有因知有我者。娑罗树子既是有故应生多罗。若以无故而知无者。多罗子中无树形相。不应得生。若有亦不生。无亦不生。我亦如是。若定有者。不须以根不觉为因。我若定无。以根不觉不可令有。是名不生。若复有人立声是常。亦以如上二十种法同异破之

问曰。此二十种。更有因缘自解说耶。答曰自有。应当问言。由有我故汝破于我。若无我者汝何所破。以有能破故有所破

难曰。理实无我。汝横计为有故我难汝。汝言以有所破故有我者。以有能破故知无我。若言汝执我义以明无我。是事不然。非用汝义。今汝自用我所执耳。立曰。汝云何知我执汝义。应说因缘。难曰。我前已言。非执汝义汝执他立。何故复问。云何知我执汝义耶。汝言自违即堕负处。又汝初以根不觉故知实有我。后以众法而为证明。立因不定违失义宗。亦堕负处。汝义已坏。我若更说不出于初。受言多过。凡问答者。答极至于五。过此更言皆名为过。若有智慧思惟深理。广说譬喻能解于义。然其所论不出此法。论者言。已说如上诸说法要。此论要者。诸论之本。由此论故广生问答增长智慧。譬如种子若遇良地根茎滋茂。若种恶田无有果实。此法亦尔。若有智慧能善思量。则广生诸论。若愚痴人少于智慧。虽习此论不能通达。是则不名真善知见。是故诸有欲生实智分别善恶。当勤修习此正法论

方便心论一卷


佛吉祥德赞

    No. 1681

佛吉祥德赞卷上

        尊者寂友造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

  我今归命佛世尊　　称赞最上诸功德
  时语如语不诳语　　实语法语如义语
  正语寂语无我语　　显示第一义谛门
  出现诸身普遍眼　　善施光明常观照
  开诸有情智慧目　　破彼所有痴暗冥
  十力真实而出生　　已到最上清凉地
  四无所畏等具足　　作大光明持灯炬
  开发明焰布光照　　施彼炽盛大明聚
  发起坚固精进行　　不减一切胜功德
  释迦师子大吼音　　能说无缚正法者
  世间八法不能染　　最上清净大悲者
  梵王帝释毗沙门　　及余天等咸恭敬
  我佛常出妙巧语　　甘美甚深复广大
  正真如理解脱音　　复能了知一切语
  广大清净如虚空　　最上族氏王宫生
  佛光明如日月光　　天人阿修罗供养
  己得七觉支妙宝　　建立最上法宝幢
  愚痴暗翳悉开明　　黄金光聚身照耀
  人中最上人中尊　　已断贪恚痴等染
  人中奔拏利迦华　　人中诸妙莲华等
  清净生死忧悲恼　　无明憍慢悉已除
  永塞斗战诤讼门　　永断相续诸染种
  付授诸法不秘惜　　摧我慢幢竖法幢
  转正法轮利众生　　坏生死轮息诸苦
  奢摩他水湛然净　　如海流注深无底
  已能枯竭爱源流　　是故充满功德水
  见者咸生忻悦心　　于一切处无所著
  能舍己身为众生　　冤亲二处悉平等
  色如真金初出焰　　舌比莲华广清净
  身光照耀净复明　　炽盛如金亦如电
  精进勤策以为腰　　安住三摩地为颈
  智慧通达为顶门　　次第而表庄严相
  如来勇猛无畏尊　　一切广远悉通达
  能摧魔力大象龙　　善说最上诸法语
  安住胜妙忍辱乐　　已断一切爱缠缚
  正智安立智坚牢　　智慧深广无破智
  最上难得优昙华　　具百千种胜功德
  如来圣尊值复难　　具足无边功德法
  如地能持诸种子　　安定寂静复广大
  如来智慧亦复然　　具足无边功德法
  无垢无染本清净　　沐浴身心调伏尊
  引导众生彼岸行　　宣说正法救世者
  三十二相悉具足　　八十种好复庄严
  百福俱圆胜妙身　　广大最上无等比
  已于诸法得自在　　显示清净胜义门
  智能遍诸境界中　　智金刚破诸烦恼
  已能调伏世间境　　发悟希望性已除
  对治烦恼尽无余　　广大辩才无障碍
  布施持戒及忍辱　　精进禅定并智慧
  诸波罗蜜悉已圆　　阿私陀仙常供养
  佛是高胜功德山　　功德藏并功德海
  自觉觉他觉行圆　　声闻十方而普震
  无边言说无边德　　辩才无尽亦无边
  佛一切智无上尊　　归命佛为大恩者
  归命善作世间护　　随应诸法悉已闻
  自智通达诸法门　　稽首最胜知法者
  先以自智见诸法　　证得无上大菩提
  后觉众生利亦然　　稽首自他真觉者
  真实了知诸梵行　　无破无断色力坚
  具足清白复周圆　　稽首净修梵行者
  无忘失法已安住　　勇猛坚固最胜尊
  佛心广大量无边　　悉能照达苦乐性
  佛为最胜善调御　　复称无上二足尊
  诸沙门中大沙门　　稽首沙门无过者
  佛已具修诸净行　　能作世间大医王
  复为胜观解脱尊　　稽首导师大智慧
  调伏寂静近寂静　　安住最上调伏心
  得入第一义谛门　　稽首已到清凉地
  一切合掌作恭敬　　应受人天最初供
  堪为人天施福田　　归命福生无上士
  知法知义知时量　　如实知自亦知他
  自他根性悉了知　　了知此彼数取趣
  三摩呬多诸根寂　　诸行所作悉周圆
  戒禁具足妙无瑕　　稽首大力三摩地
  安住无灭三摩地　　无患无动离诸危
  已无高下取舍心　　结生相续悉永离
  如妙高山心安固　　不退转智悉能成
  遍一切处智常随　　稽首无胜无灭智
  了知诸法无能胜　　佛是爱见善见尊
  智爱善爱德无边　　稽首爱憎平等者
  最上威仪众喜爱　　具足美妙诸辩才
  辩才随意破愚痴　　稽首宣畅正语者
  名称广大复希有　　遍三界中而普闻
  世间智者随问言　　佛皆善答无隐覆
  佛威仪相胜无比　　见者咸生适悦心
  普令世间喜爱生　　稽首善施欢喜者
  迅疾言说无重复　　平等无等无差别
  美味具足妙言音　　稽首语言无等等
  佛是人中大智者　　复为最上人中仙
  世间异见悉不生　　稽首远离邪思觉
  已息忧悲诸苦恼　　蠲除染法尽无余
  轻浮动乱过不生　　稽首永离诸过者
  毁呰如来心不下　　赞誉如来心不高
  称讥平等智安然　　稽首不着于谤赞
  平坦高下及染净　　苦法乐法与爱憎
  佛智无著亦无差　　稽首如来善语者
  众生恶语无义利　　如来善覆无显彰
  行诸施法摄世间　　稽首正真能语者
  恶人恶语固触娆　　佛心无动而安然
  善言恶语等无差　　稽首爱恚平等者
  黄金琉璃真珠宝　　斯为世间最上珍
  如来已离贪爱心　　观同草木土石等
  如来已离三种慢　　其心安定而寂然
  床敷卧具及诸珍　　见来求者皆给施
  于利非利无喜恚　　轻慢亦生喜舍心
  无忧无恼过不生　　稽首智破邪法者
  已能远离诸娆恼　　常说亲近诸善人
  不说世间利养言　　亦无虚妄等言说
  言说随意复自在　　言说调寂离喜乐
  言说纯一净无瑕　　稽首言说寂静者
  言说甘美而无著　　言说能伏一切魔
  言说决定离世间　　稽首已离诸无智
  已能远离颠倒见　　已离轻浮动乱缘
  已离一切非语言　　稽首善言摄化者
  常行无谄无诳行　　顺行清净真实心
  广行爱敬实无虚　　稽首已度生死难
  一切所作善成就　　是为正法出生门
  见者欢喜世间尊　　稽首归命清净士
  归命亲说诸法教　　随宜无转烦恼除
  正善了知出离门　　趣证菩提真实法
  无破高胜归向法　　善启世间寂净门
  乃至正妙广宣扬　　天人世间利乐法
  如来所说诸法语　　离诸爱欲染着声
  不调伏声悉已除　　稽首善说法教者
  如来久修诸净命　　心无动乱本安然
  三处平等念住心　　稽首能仁三不护
  佛已断除疑惑语　　平等分位常所行
  涅槃无异胜爱门　　稽首广大证入者
  佛为最上胜道者　　具足众德天人尊
  神通方便悉圆成　　稽首已得诸自在
  稽首归依众德圆　　十号满足无比等
  如来应供正等觉　　明行具足善逝尊
  世间解了无上士　　调语丈夫天人师
  佛世尊号普称扬　　是故我今伸赞礼
  如来无染无发悟　　离胎藏生殊胜生
  能满众生诸愿求　　稽首善摄一切法
  示生清净圣王种　　广大富贵复尊高
  悉能弃舍而出家　　稽首下心离高举
  具足最上诸色力　　端严相好见者忻
  世诸妙境悉弃捐　　稽首清净解脱者
  戒律清净具无缺　　如应能说即能行
  大智大慧大圣尊　　稽首同事摄益者
  佛语正白复妙善　　断除贪欲过不生
  一切染法悉蠲除　　宣说正因正业语
  说诸行语离缠缚　　常以柔软爱言宣
  沙门婆罗门众中　　如来语言常先胜
  面相圆正离颦蹙　　正顺先导而安然
  善来爱语摄众生　　稽首正说摄诸过
  所出语言皆具足　　无畏语业善称扬
  深语正语智语言　　稽首如来息恶语
  佛语无著无依止　　亦无违背诸语言
  所有言说悉无边　　稽首能敷了义语
  巧美语言善辩才　　利乐悲愍诸众生
  广启众生调伏门　　稽首圣法性调伏
  佛是正法调伏士　　离尘诸法调伏尊
  无等法门调伏师　　以无量法调伏者
  如来戒具足同等　　定慧具足亦无差
  解脱具足本同源　　解脱知见具无异
  圣正吉祥大觉者　　最上调伏同一门
  常于林野息众缘　　随意坐卧而安止
  以不害相而说法　　无绮语相而说法
  无动转相而说法　　示出离相而说法
  已断轮回相说法　　可爱涅槃相说法
  无他苦相而说法　　善自性相而说法
  世间利益相说法　　离邪见相而说法
  同异生相而说法　　不转相续相说法
  稽首无住相说法　　照明真实义真实
  若法若智实亦然　　说明了义破疑惑
  说法正白善分别　　平等高下普言宣
  正道邪道悉显彰　　利非利事皆善了
  若善不善悉分别　　通达正教邪教门
  功德已圆过已除　　稽首自他能度者
  能以善法破恶趣　　乐中非乐方便说
  世间生灭真实知　　善说最胜诸法宝
  如来真实最上教　　三界所作能成就
  善趣恶趣悉了知　　善恶事中智无倒
  了知缚脱本来性　　而能善说缚脱门
  邪正染净悉能知　　善不善义皆明了
  已能具足最上善　　具善行者普称扬
  救拔一切恶趣中　　如来悲为一味药
  稽首天仙最上士　　不着甚深禅定乐
  不生适悦喜爱心　　誓度愚迷贪欲海
  自身广大诸色相　　毕竟圆满可称扬
  三界最胜应供尊　　我今归命不可议

佛吉祥德赞卷上佛吉祥德赞卷中

        尊者寂友造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

  归命如来胜妙相　　足下平满善安住
  千辐轮文现足心　　辋毂众相皆圆满
  如兜罗绵手足软　　鞔网光现手足间
  手足诸指妙纤长　　足跟圆满趺相称
  足趺修高复充满　　腨如伊泥邪鹿王
  双臂修圆摩膝轮　　阴相藏密犹龙马
  发毛端润皆上靡　　一一身毛悉右旋
  身皮细滑垢不侵　　身真金色光晃耀
  手足颈肩七处满　　项及膊腋悉充圆
  容仪敦肃妙端严　　身相修广复佣直
  如诺瞿陀身圆满　　上半身如师子王
  常光面向各一寻　　四十齿平不疏缺
  四牙鲜白妙锋利　　常得味中最上味
  舌相薄净广复长　　梵音深妙犹天鼓
  音声闻者皆悦意　　复如迦陵频伽声
  眼睫齐整状牛王　　眼睛皎洁绀青色
  眉间柔软妙毫相　　右旋清净如螺白
  鸟瑟腻沙顶庄严　　稽首大丈夫相具
  归命如来随形好　　指爪狭长如赤铜
  手足指圆悉纤长　　手足诸指皆次第
  筋脉盘结复深隐　　两踝俱隐而不粗
  充满柔软足安平　　回顾右旋鹿王等
  行步直进如象王　　明显端严无障碍
  自在次序状鹅王　　举身随转步安审
  身分次第而高显　　平等随转身不曲
  善相属着坚固身　　身净光明离翳暗
  身支安定不掉动　　端直身相善圆满
  妙童子相清净身　　柔软妙好悉无比
  腹形方正无欠缺　　不[穴/爪]不凸广复圆
  右旋深厚妙脐轮　　净无点窍无减下
  身支近触离诸过　　悉无靥点疣赘等
  譬如莲华垢不侵　　亦复离诸不寂静
  面轮圆满皎清净　　身相具足而无减
  舌相广长如赤铜　　柔软复如莲华叶
  唇色光润而可爱　　如频婆果及赤铜
  水云击响等音声　　复如象王大震吼
  音声深远复美妙　　一切闻者咸悦意
  手软犹如兜罗绵　　手文深明而不断
  四牙锋利妙坚固　　最上清净复齐平
  诸齿方整鲜白齐　　眼相修广如莲叶
  眼睫稠密而不白　　眉润不白复修长
  耳轮长广厚复圆　　身毛一一皆润泽
  额广平正相殊妙　　上半身分悉充圆
  首发稠密整复长　　绀青旋转而光润
  乃至广及佛胸臆　　俱有喜旋德相文
  螺髻绀青妙庄严　　稽首不可见顶相
  归命处非处智力　　过现未来业皆知
  禅定解脱等持门　　了别自他诸根性
  种种信解悉通达　　种种界趣亦悉知
  他心种类了无差　　宿住随念智具足
  照明一切生灭法　　诸漏已尽漏无余
  如是十力智周圆　　稽首如来大精进
  如来漏尽无余染　　觉了诸法亦无余
  故称正等正觉尊　　我今稽首伸敬礼
  一切染法平等说　　诸出离道亦善宣
  一切觉了尽无余　　稽首能仁初觉者
  佛具不坏正智慧　　普尽无余现觉尊
  正智破诸邪智心　　佛真觉已无余觉
  自境界及他境界　　一切境界所作成
  于彼一切根义中　　佛是无能胜根者
  相中无余相所缘　　非色种现皆悉断
  无生重檐久已除　　已彻缘生河流底
  二种无智痴暗离　　发生二种智光明
  复离二种疑求心　　建立二种决定智
  已得尽智世间句　　智障已离法圆明
  具足胜依寂止门　　具足胜处善安住
  具足一切所应行　　明行具足色相圆
  具足种姓及语言　　获神通果善救度
  身语意业悉不护　　无著无尽智凝然
  决定不退转智门　　智说不坏因时相
  种种因门皆觉了　　种种果门亦悉知
  种种烦恼及对治　　稽首如来善觉者
  无二言说无尽辩　　善说不退转法者
  世间八法不染心　　稽首善达功德岸
  佛三阿僧祇劫中　　积集难行一切行
  运大悲心而普覆　　自他能渡烦恼流
  了知三苦极微细　　由愍苦故起大悲
  三界所缘诸性中　　大悲普及一切处
  如来智性中平等　　若冤若亲而等观
  悲心广大不可量　　普摄一切众生类
  佛为众生说一药　　身病心病普令安
  毕竟极苦亦蠲除　　稽首善说妙药者
  纯一真实决定行　　决定纯善无染尊
  决定不复染法生　　一向为他善长养
  不以己利求于他　　自所得乐悉弃舍
  随宜方便悲愍心　　决定调伏众生病
  众生所应调伏时　　如来善知而无失
  为众生作不请友　　普令得度起悲心
  能仁善说妙法药　　治彼生法苦根源
  照明众生过现身　　了知烦恼无边性
  断除众生烦恼病　　佛知时量悉无差
  随其何病药堪除　　世尊如应为说药
  如来所行一切行　　修习如理悉周圆
  若一若多出现门　　和合了知皆无碍
  如来功满已能到　　一切智智清凉地
  知道识道说道尊　　胜道众道归向者
  拯拔一切轮回苦　　令诸众生离缠缚
  普令得渡烦恼流　　坚固惭愧具足者
  能善建立圣法幢　　表示诸行无常法
  开示尽灭离贪门　　显示寂灭出离道
  能善表示诸法者　　能以诸法教授尊
  能作利益大导师　　稽首善施欢喜者
  常说示教利喜语　　具大威德大神通
  最上清净大梵尊　　稽首自在复炽盛
  已息种姓诸言论　　复断族氏诸语言
  世间人事语亦亡　　稽首常说正法语
  如来行步常寂静　　无阔无狭平正行
  顺善而行见者忻　　表示如来善行相
  如来不坏正知见　　具足如先所作性
  成诸福事断疑根　　离分卫心入聚落
  出必显明众所睹　　无依无转最上尊
  胜妙殊特众吉祥　　纯一具足梵行者
  能善了知五蕴法　　复能具足七法行
  已能摧灭我慢心　　稽首能破愚痴网
  如来已得无动法　　复能具足深广心
  善能成就七圣财　　稽首善学三学者
  佛大丈夫所应赞　　邪异诸境不能怖
  远离一切不吉祥　　稽首已到调伏地
  梵行真实善安立　　上下纵广悉归依
  常以无畏施众生　　稽首于法离取着
  归命佛大阿罗汉　　一切漏尽无染尊
  所作已办德圆明　　稽首已除诸重担
  逮得己所作义利　　尽诸有结障蠲除
  安住正智解脱心　　稽首出离解脱者
  已证无言解脱理　　爱尽取尽而解脱
  心无忘失解脱圆　　稽首无颠倒心者
  佛心无量复广大　　无别异法善修心
  心得离系烦恼除　　稽首已破诸异类
  尽诸染业得清净　　已证无余依涅槃
  人中最胜解脱尊　　战死魔军而得胜
  于诸善法不放逸　　善住正念正智慧
  善开寂眼视众生　　稽首善救生死苦
  善觉众生无明睡　　善破众生诸愚痴
  佛勤勇起精进心　　策发一切懈怠者
  诸不善中施善法　　诸堕学中开学门
  诸怖畏中施无畏　　不安隐者令安隐
  诸暗冥中作明照　　诸不善中令修善
  诸过失中功德生　　诸罪业中除罪业
  令违逆者知恩德　　能满众生意所求
  咒明成就真实修　　稽首能破烦恼者
  佛已远离诸诳妄　　心无躁动不高举
  尊胜显示吉祥门　　稽首佛为福生处
  一刹中生一切行　　不共一切神通种
  毕竟成就最上门　　一切处离非句义
  一切疑惑及杂说　　决定正语悉能破
  诸吉祥行平等修　　善知一切众生意
  已能摄伏诸他语　　犹如猛火焚干薪
  烧诸烦恼义亦然　　稽首安住正士法
  具诸吉祥具惭愧　　世间主宰胜寂默
  释迦牟尼大导师　　盎儗啰娑瞿昙族
  离诸烦恼痴黑暗　　悲愍普摄诸众生
  常于利他摄益中　　具足广多诸胜行
  佛于一切众生类　　一切增上所行中
  佛以大智常观察　　普集世间利益事
  具足六通调伏智　　德智说智及时智
  一切对治胜神通　　界趣胜解业障智
  说法最胜神通具　　三调伏时善开化
  一切文义善解圆　　稽首辩才无尽智
  佛已具足如说辩　　善满诸行到彼岸
  一切功德解脱周　　显示胜身心清净
  闻佛音者心欢喜　　佛自所行悉周圆
  不堕一切言说中　　不取自分功德相
  平等先证最初道　　次集大行不遗余
  众生大担负堪任　　于诸相中得寂静
  已圆大慈等功德　　未尝远离于舍行
  以正智慧摄众生　　于长夜中遍观察
  如来常发大勇悍　　以诸善行教众生
  复于一切众生中　　已得悲心善平等
  佛是悲愍世间者　　第一义谛善解了
  如来三眼已圆明　　三种称赞善具足
  如来已具三不护　　显示三界无垢尊
  四念处行广通达　　名句文身自在者
  巧妙无尽随意辩　　一切说示智悉通
  种类语言善解知　　随处辩才悉无碍
  诸违背中作顺向　　诸恚怒中作清净
  于诸慢中发敬心　　弃舍一切利养事
  所行正真复最上　　以自力能现证尊
  清净一切言说门　　稽首语言无执着
  出善来语如义语　　具足一切正所行
  如来一切功德圆　　稽首无忘失法者
  最上摄益胜调御　　欢喜悲愍诸众生
  悲心坚固欲利他　　稽首常欲利乐者
  佛与众生有恩德　　常为善友及知识
  如父如母能出生　　欲令众生得善乐
  佛为众生亲教师　　善说胜义诸法教
  最上句义如理宣　　使令了知一切性
  如来常以无著说　　无增无减善称扬
  大悲不断相续生　　稽首善见处非处

佛吉祥德赞卷中佛吉祥德赞卷下

        尊者寂友造

  归命作大师子吼　　出生一切善行门
  于一切性如实知　　无胜知见遍一切
  善化众生时无间　　宣说无边诸法门
  最先破彼无明卵　　随觉一切诸法者
  觉了众生大正士　　觉悟微妙诸法尊
  于无我理已觉明　　善觉诸业自性者
  觉了一切界分量　　了知生灭本来性
  于诸苦法如实知　　善悟真实自性者
  善能觉悟无娆恼　　世间自性悉觉知
  破诸恶见智开明　　觉了一切因果者
  觉了三界出离相　　故复修诸极难行
  身无疲倦执相工　　然于小法不厌离
  毕竟方便善摄益　　宣说中道诸法门
  善哉释迦牟尼尊　　顶礼归命应供者
  最上说者寂默者　　最上最胜我大师
  善摄众生诸意乐　　于诸事相悉不取
  具足一种称赞者　　善能成就四摄法
  六和敬法善宣扬　　六常行行已圆满
  安立甚深正知见　　得诸等持寂静善
  善法中无放逸心　　已证先佛所成道
  觉了甚深正道者　　开发甚深智光明
  于彼无寻无伺道　　稽首如来证悟者
  总聚智者所知境　　微细甚深悉觉知
  显示二种涅槃界　　尽证一切涅槃道
  众生长夜起虚妄　　佛方便说无妄法
  众生没在生死泥　　佛为垂手善接度
  众生堕在恶趣者　　佛方便力为拯拔
  诸众生起生等怖　　佛为引示无畏处
  自具广大威神力　　身现一切色相宝
  内藏心宝妙圆明　　宣说无比正法宝
  佛不为他所摄伏　　一切无能违佛者
  安住一切欢喜门　　佛一切相皆圆满
  无上沙门正真行　　如莲华开智清净
  普集梵行尽无余　　稽首梵行已立者
  虽明世间围陀典　　不坏一切圣法教
  洗涤一切诸罪垢　　获得第一增上法
  善能成就持明法　　能善引示寂静处
  导师开示善乐门　　轮回旷野为善导
  常离一切诸暗冥　　开熙怡眼常观视
  毕竟无染清净尊　　罪福无动行解脱
  能于自身观空性　　爱见已尽善无染
  于诸欲境离想心　　离染烦恼及分别
  心住寂静诸事业　　默然法中得解脱
  最上寂静大牟尼　　一切清净无染者
  出世功德已广大　　善布世间大明照
  世间妄境悉能观　　圆满真实诸法想
  爱绳已断神通具　　善发智慧大光明
  破彼一切依着心　　于诸意乐皆寂静
  如来已离诸过失　　所应敬礼及供养
  一切无利恶法除　　一切利益相应者
  佛与众生为善友　　无足二足第一者
  安住念慧诸性中　　善具无忘失法者
  佛于义无义自性　　和合依止而不着
  生死此岸怖已除　　能证涅槃彼岸乐
  佛善依止正道行　　听闻无谬心无减
  诸清净中佛最尊　　广大色相慧光照
  世间所有耽欲味　　佛智久已善出离
  智慧称赞涅槃门　　稽首如来决定说
  无染见及无染思　　无染语并无染业
  无染命与无染勤　　无染念兼无染定
  解脱无染智无染　　于戒定慧善安住
  一切结缚悉断除　　破诸烦恼颠倒处
  如来梵行所出生　　已住最上清凉地
  一切所作寂静尊　　不着世间敬爱事
  已能断除五分结　　复能具足六分法
  起一平等护念心　　四依成就而无缺
  纯一真实无别异　　平等弃舍世所爱
  无倒思惟真正心　　已得一切轻安者
  心善解脱慧解脱　　纯一梵行善安立
  如来最上胜丈夫　　是故归命广称赞
  稽首胜大阿罗汉　　离名离相离分位
  出过名相分位门　　名相分位皆寂静
  善见心能息欲焰　　欲境贪爱染皆除
  于诸欲染离含藏　　及离一切欲过失
  善修七种观想法　　善说菩提分法门
  一切已能胜伏他　　佛是勇猛无畏者
  离痴断染胜中胜　　戒力增上无罪者
  具善智慧微妙心　　内摄种种功德行
  无疑离染常喜足　　已息世间诸妄源
  大沙门事作已成　　稽首真实欢喜者
  佛为摩耨惹中胜　　已于其身善观察
  应得已得诸说门　　稽首如来无比喻
  正念胜观一切觉　　不为他伏能伏他
  已得寂静无所为　　稽首牛王胜上者
  无量甚深住寂默　　正智常行安乐行
  如其法律妙威仪　　稽首身严心寂静
  诸行妙圆语善说　　身现头陀难行相
  言无戏论住正真　　稽首离贪正命士
  如来尊胜复自在　　犹如帝释天中胜
  所向正顺复善观　　语言谦下而和美
  一切清净清净者　　善爱无著广清净
  成熟功德香充满　　稽首已到最上处
  佛是最上大仙王　　广积功德满无减
  净行已圆谄已除　　稽首正智光明聚
  身心清净复轻安　　已息一切诸冤对
  寂慧广慧大慧尊　　塞忿恚源常欢喜
  补特伽罗中无胜　　不可称量离诸着
  句身通达已无疑　　稽首能仁善解者
  教化调伏中最上　　无上可爱作光明
  无求无慢无爱着　　稽首无诳清净者
  已离暗翳无所染　　补特伽罗中最上
  已得善寂大名称　　稽首无著无缠缚
  迷惑耽着久已离　　无我取相我见除
  初中后善法宣扬　　善文善义皆圆满
  众生处苦无疲懈　　佛方便故令休息
  众生不趣出离门　　佛方便故令出离
  如来不住于灭法　　常行救度摄世间
  复于广大正法门　　稽首大智悉包摄
  已息邪妄诸分别　　善离一切寻求道
  催诸恶法号胜人　　离七种染圆梵行
  如空欲泥不能染　　清净常依止梵行
  虽除染法了性空　　出过语言心无著
  佛常安住身念性　　佛心已过于二边
  正智深密勇力尊　　吉祥门中善身者
  稽首大悲不思议　　一切所作自通力
  他劣弱者助营修　　他善美者必随顺
  佛是金刚坚固身　　从真实处所出生
  安住一切相应门　　得大涅槃最上乐
  如来已得最上利　　弃舍自乐而不着
  引示世间安隐处　　广为众生说正道
  归命大觉尊　　现证正觉道
  不修梵行者　　佛善为建立
  佛是知道者　　识道说道者
  佛为正道尊　　诸道所归向
  佛从照明生　　复是智生者
  义生及法生　　善说明了义
  诸义出离者　　人中大师子
  人中大象龙　　人中大仙王
  人中正知者　　人中智勇尊
  人中胜无比　　人中极最上
  人中殊妙士　　人中白莲华
  无怖及无惊　　无怯亦无惧
  佛是离怖者　　无畏无奔竞
  怖畏险难除　　断灭诸怖难
  自出过怖境　　复令他亦出
  自断灭怖难　　复令他亦断
  自渡怖难海　　复令他亦渡
  离身毛喜竖　　离身毛悚立
  佛胜无比等　　亦复无等等
  功德不可称　　已过于称量
  复不可取像　　亦无各别分
  胜补特伽罗　　唯一而无二
  佛是自然智　　而无同等者
  广利诸众生　　稽首一切智
  诸天人世间　　梵魔沙门中
  佛是最上尊　　复为无胜者
  佛宝甚希有　　而亦复难得
  遇佛宝出生　　实希有难得
  佛是广大眼　　复为大光明
  大曜大明照　　大灯大光炬
  无暗大炽明　　已得最上法
  根力觉道圆　　不与声闻共
  若无利益事　　如来即不生
  无利不现化　　无利亦不隐
  佛为诸群品　　利益故出生
  悲愍诸世间　　作诸利乐事
  于诸天人中　　佛是正见者
  以正道法律　　普教示一切
  复一切众中　　佛为所爱尊
  咸起敬爱心　　作尊重观想
  佛是所亲近　　及随从恭敬
  顶礼见真如　　吉祥最上宝
  佛慧眼光明　　复从慧眼生
  开发慧焰明　　持广大慧炬
  燃慧灯普耀　　大慧破诸暗
  一切性自性　　如来悉照了
  如来胜慧根　　微妙复最上
  如来大慧力　　而不可屈伏
  积无尽慧财　　具无价慧宝
  持快利慧刀　　执胜慧器仗
  秉锋利慧剑　　慧无堕无减
  佛善开正慧　　觉了一切法
  广慧为宫殿　　正智者安处
  坚固慧为墙　　周匝而密护
  不思议正慧　　为阶梯进趣
  无屈伏胜尊　　无异心安住
  不为他所伏　　亦伏无所取
  而于三界中　　所应供养者
  一切现观察　　一切无所著
  所应知已知　　所应离已离
  所应得已得　　胜所作已作
  己事悉周圆　　为世间教授
  佛是大圣者　　精进未曾有
  已安立清净　　希有广大行
  现证最上道　　希有难思法
  获得取上句　　饮涅槃甘露
  拔除爱网根　　绝诸过失本
  善行无别异　　无染法能着
  善生及善体　　胜善而出家
  善本所从来　　稽首善来者
  无动不思议　　智者智中尊
  谄曲过染除　　已渡烦恼海
  相应行解脱　　解脱诸缠缚
  已得无取心　　已尽一切漏
  已尽过失边　　已破一切毒
  已断一切障　　尽烧诸见网
  所有邪妄言　　及邪妄见闻
  邪念邪作事　　佛一切已离
  蕴处界诸法　　随广略善说
  依止净无缚　　诸依止中胜
  无救者为救　　无归者作归
  诸无趣向者　　佛为作趣向
  已渡生死海　　遍入诸境界
  所应现化处　　一切皆能到
  诸堕恶趣者　　佛常知常思
  即以善方便　　而普为救度
  无贪及无嗔　　无痴善根具
  大身常住身　　悲愍利益者
  身被释种服　　广作吉祥事
  希有精进力　　大智正识者
  戒忍法真实　　内心常精进
  广大复甚深　　具足诸功德
  光明大照耀　　调伏心洁白
  犹湛水澄清　　善种现圆满
  世间清净眼　　青优钵罗华
  广大而殊妙　　周遍十方界
  寂止性润泽　　一切智妙月
  佛德广无边　　是故我称赞

佛吉祥德赞卷下


佛三身赞(西土贤圣撰)

    No. 1678

佛三身赞(西土贤圣撰)

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

法身

  我今稽首法身佛　　无喻难思普遍智
  充满法界无挂碍　　湛然寂静无等等
  非有非无性真实　　亦非多少离数量
  平等无相若虚空　　福利自他亦如是

报身

  我今稽首报身佛　　湛然安住大牟尼
  哀愍化度菩萨众　　处会如日而普照
  三祇积集诸功德　　始能圆满寂静道
  以大音声谈妙法　　普令获得平等果

化身

  我今稽首化身佛　　菩提树下成正觉
  或起变现或寂静　　或复往化于十方
  或转法轮于鹿苑　　或现大光如火聚
  三涂苦报悉能除　　三界无比大牟尼

回向

  如是佛身无漏智　　我常信解净三业
  以无量慧大福行　　一心垂愍诸群生
  以今颂赞三身佛　　所获无漏功德种
  愿我速证佛菩提　　尽引众生归正道

佛三身赞


佛说八大灵塔名号经

    No. 1685

佛说八大灵塔名号经

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

尔时世尊告诸苾刍。我今称扬八大灵塔名号。汝等谛听。当为汝说。何等为八。所谓第一迦毗罗城龙弥儞园是佛生处。第二摩伽陀国泥连河边菩提树下佛证道果处。第三迦尸国波罗柰城转大法轮处。第四舍卫国只陀园现大神通处。第五曲女城从忉利天下降处。第六王舍城声闻分别佛为化度处。第七广严城灵塔思念寿量处。第八拘尸那城娑罗林内大双树间入涅槃处。如是八大灵塔。重说颂曰

  净饭王都迦毗城　　龙弥儞园佛生处
  摩伽陀泥连河侧　　菩提树下成正觉
  迦尸国波罗柰城　　转大法轮十二行
  舍卫大城祇园内　　遍满三界现神通
  桑迦尸国曲女城　　忉利天宫而降下
  王舍大城僧分别　　如来善化行慈悲
  广严大城灵塔中　　如来思念寿量处
  拘尸那城大力地　　娑罗双树入涅槃

如是八大灵塔。若有婆罗门及善男子善女人等。发大信心修建塔庙承事供养。是人得大利益。获大果报。具大称赞。名闻普遍甚深广大。乃至诸苾刍亦应当学

复次诸苾刍。若有净信善男子善女人。能于此八大灵塔。向此生中至诚供养。是人命终速生天界

尔时世尊复告诸苾刍。汝等谛听我今当说。游止国城及于住世。而说颂曰

  二十九载处王宫　　六年雪山修苦行
  五岁王舍城化度　　四年在于毗沙林
  二年惹里岩安居　　二十三载止舍卫
  广严城及鹿野苑　　摩拘梨与忉利天
  尸输那及憍睒弥　　宝塔山顶并大野
  尾努聚落吠兰帝　　净饭王都迦毗城
  此等圣境各一年　　释迦如来而行住
  如是八十年住也　　然后牟尼入涅槃

佛说八大灵塔名号经


佛说立世阿毗昙论

    No. 1644

佛说立世阿毗昙论卷第一

        陈西印度三藏真谛译

    地动品第一

如佛婆伽婆。及阿罗汉说。如是我闻。一时佛世尊住舍卫大城。毗舍佉优婆夷鹿子母精舍。莲花重阁。与大比丘众。一切阿罗汉。诸漏已尽。逮得己利。尽诸有结。心得自在。所作已办。已舍重担。正智解脱。唯除阿难。是时。大地震动。时富娄那弥多罗尼子。在大众中。即从坐起。偏袒右肩。右膝着地。合掌恭敬。顶礼佛足。而白佛言。世尊。何因何缘。大地震动。佛告富娄那比丘。汝今一心谛听。善思念之。我当为汝分别解脱。有二因缘。令大地动。何者为二。比丘。是地界住水界上。是水界住风界上。是风界住于空中。比丘有时大风吹动水界。水界动时。即动地界。是一因缘。故大地动。比丘。复有大神通威德诸天。若欲震动大地。即能令动。若诸比丘有大神通。及大威德。观地相令小。水相令大。欲令地动。亦能震动。是名第二因缘。故令地动。尔时世尊欲重宣此义。而说偈言

  水界为风动　　地动由水动
  是一因缘动　　是实名所说
  诸天及比丘　　大威神能动
  是二因缘动　　调伏恶人说

尔时世尊复告富楼那弥多罗尼子。有风名鞞岚婆。比风常吹。俱动不息。风力上升。有风下吹。有风傍动。是风平等圆转相持。厚九亿六万由旬。广十二亿三千四百五十由旬。周回三十六亿一万三百五十由旬。此风上际。即是水界。此水上下。悉皆平等停止安住。无有散溢。厚四亿八万由旬。广十二亿三千四百五十由旬。周回三十六亿一万三百五十由旬。此水上际。即是地界。上下边际。悉皆平等安住不动。厚二亿四万由旬。广十二亿三千四百五十由旬。周回三十六亿一万三百五十由旬。如是佛世尊说。比丘。有大地狱。名曰黑闇。各各世界外边悉有皆无覆盖。此中众生自举其手。眼不能见。虽复日月具大威神。所有光明。不照彼色。佛说。如是黑闇地狱。住在何处。两两世界铁轮外边。名曰界外。是寒地狱。一名頞浮陀。二名涅浮陀。三名阿波波。四名阿吒吒。五名嚘吼吼。六名郁波缕。七名拘物头。八名苏健陀固。九名分陀利固。十名波头摩。佛告富娄那等比丘。如摩伽陀国量十婆诃摩一婆诃二十佉利。如是量麻。聚在一处。设有一人。满一百年。来除一麻。比丘。如是麻聚。犹尚易尽。而我未说頞浮陀地狱寿命穷尽。比丘。十倍頞浮陀地狱。是涅浮陀寿量。十倍涅浮陀地狱。是阿波波寿量。乃至波头摩地狱。亦复如是。比丘。是瞿伽离比丘。于舍利弗目揵连所生。不信恶心。由是心故。堕波头摩地狱。尔时世尊。而说偈言

  夫人处世间　　斧在口中生
  斯由作恶言　　以是自斩身
  应呵而赞叹　　应赞而呵骂
  口过故得衰　　衰故不受乐
  若己舍失财　　尽物及自身
  其人罪尚轻　　若于修伽陀
  生恶不信心　　是罪重于彼
  百千涅浮陀　　頞浮陀三亿
  六万及五千　　若诽谤圣人
  作恶语恶心　　如量堕地狱
  瞿伽离比丘　　堕波头摩狱
  诽谤大声闻　　舍利及目连

彼中众生傍行作向上想。犹如守宫。铁轮外边。恒作傍行。是其身量如頞多大。因冷风触。其身圻破。譬如熟瓜。如竹[竺-二+韋]林被大火烧。爆声吒吒。如是众生被寒风触。骨破。爆声吒吒远彻。因是声故。互得相知。有诸众生。此中受生。或时去来更相逢触。因此触故。互得相知。有诸众生。此中受生。是时诸佛世尊出现于世。是时大光过于诸天大威神力。遍照彼中。因此光明。互得相见。作是思惟。有诸众生。此中受生。若有众生。于此间死。多往生此。寒冰地狱。在铁轮外。若余世界。有众生死。往生寒冰地狱。多彼世界铁轮外生。两界中间。其最狭处。八万由旬。在下无底。向上无覆。其最广处。十六万由旬

尔时净命阿难在大众中。即从座起。偏袒右肩。右膝着地。合掌恭敬。顶礼佛足。而白佛言。世尊。我从世尊。闻是法句。我从世尊口。受持此正义。过去有佛。名曰尸弃。时有弟子。大神通第一。名曰阿毗吼。是比丘坐在第四禅梵处。以一指光。照一千世界。一音说法。一千世界。俱解正义。世尊。诸佛弟子。威神尚尔。诸佛如来。其量云何。阿难问已。时佛答言。阿难。此阿毗吼比丘。是弟子位。诸佛世尊如此之处。不可思量

第二。净命阿难复白佛言。世尊。我从佛口。闻是法句。我从世尊。受持如是正义。过去有佛。名曰尸弃。时有弟子。神通第一。名曰阿毗吼。是比丘坐在四禅梵处。以一指光。照一千世界。一音说法。一千世界。俱解正义。世尊。诸佛弟子。威神尚尔。诸佛如来。其量云何。阿难问已。时佛答言。阿难。此阿毗吼比丘。是弟子位。诸佛世尊。如此之处。不可思量。乃至第三。亦如是答。第四问已。佛告阿难。若一日月所围绕处。名一世界。从一至千。此中有千日月。千须弥山王。千四大天王。千忉利天。千夜摩天。千兜率陀天。千化乐天。千他化自在天。千梵辅天。千梵众天。此处大梵王。为一千世界主。王领自在。不系属他。知成他事。初禅上上品。故得自在。大梵天王。住于是处。得称第一。阿难。是梵领处。有四千大洲。四千大树。四千大龙宫。四千金翅鸟王住处。七千大河。九千大山。八千大林。八千大地狱。一千阎罗王地狱。二千大海。十六千地狱园。是名小千世界。又更千倍。是名中千世界。又更千倍。是名大千世界。阿难。若如来作意欲照欲说。是大千世界。光照遍满。所说法句。一切俱解。若复欲过大千世界。随如来意。是中众生。莫不见闻放光说法。阿难。若如来欲放光说法。坐阿迦尼吒天梵处。若大千。若过大千。光照遍满。以八分梵声。说法句义。遍得领解。阿难。是如来光明。及说法音声。无有众生不见不闻。是时无有众生不具根者。阿难。如来在阿迦尼吒天上。说此音声。宣此名句

  汝等受佛教　　起恭敬正勤
  观修于中住　　出离三有难
  除灭死王军　　如象破苇舍
  若佛法律中　　住于不放逸
  是人舍生死　　乃至尽苦际

尔时阿难即从座起。偏袒右肩。右膝着地。合掌恭敬。顶礼佛足。而白佛言。世尊。我今希有利养。我今善得希有之利。我得大师具足神通广大威德。是时净命名曰优陀夷。在大众中。去佛不远。时优陀夷比丘语阿难言。若汝大师具诸威德大神通。汝何所得。是时世尊告优陀夷比丘。汝莫作意违阿难心。若我前不记阿难。今生得阿罗汉果。因此信心。所生业报。当三十六过。作他化自在天王。乃至三十六过。作忉利天主。何况转轮圣王。刹利王种。受灌顶职。乃至四天下王。优陀夷。阿难比丘。吾于往昔。已为授记。我说欲界之中。众生最多。依水生多。于地生少。其地生者。畜生道多。人道复少。人道之中。破戒者多。持戒者少。持戒之中。凡夫者多。圣弟子少。圣弟子中。有学者多。无学者少。无学之中。时解脱多。非时解脱少。如是非时解脱阿罗汉。世间难得。我记阿难应得是处。有诸外道。作如是说。是大地界。恒去不息。是言应答。此事不然。若实尔者。如人掷前。物应落后。又诸外道作如是说。是大地界。恒坠向下。是言应答。此事不然。若实尔者。如向上掷。应不至地。又诸外道作如是说。日月星辰。恒住不移。大地自转。疑是天回。是言应答。此事不然。若如是者。射不至堋。又诸外道作如是说。大地恒浮。随风来去。应如是答。此事不然。若实尔者。地恒并动。若不尔者。地作何相。地住不动。如是义者。诸佛世尊已说。如是我闻

    南剡浮提品第二

佛说比丘。有树。名曰剡浮。因树立名。名是洲地。曰剡浮提。此树生剡浮提地北边。在泥民陀罗河南岸。是树株本。正洲中央。从树株中央。取东西角。并一千由旬。是树生长。具足形容可爱。枝叶相覆。密厚多叶。久住不凋。一切风雨不能侵入。比丘。譬如装花鬘师。装饰花鬘及耳上庄严。其树形相可爱如是。上如华盖。次第相覆。高百由旬下本洪直。都无瘤节。五十由旬方有枝条。树身径刺。广五由旬。围十五由旬。其一一枝。横出五十由旬。间中亘度一百由旬。周回三百由旬。其果熟时。甘美无比。如细蜂蜜。味甜难厌。果味如是。果大如盆。其核大小。犹如世间剡浮子核。其上有鸟形。如大殿猕猴之形。知六十岁大象。是两鸟兽恒食其实。东枝有子。多落剡浮提地。少落水者。西枝果子。多落剡浮提地。少落水者。南枝果子。并落剡浮提地。北枝果子。悉落河中。为鱼所食。树根悉是金砂所覆。当春雨时。下不漏湿。夏则不热。冬无风寒。有乾闼婆。及药叉神。依树下住。如是之事。云何知耶。昔王舍城有两比丘。具神通力。共为朋友。从佛口。闻剡浮树相如此。是二比丘互相谓言。我等当往看彼剡浮。各云我去。遂至树所。见树果熟。堕地自破。其一比丘从其蔕孔。授手至臂。其最长指。犹不至核。牵手而出。为果所染。手臂皆赤。犹如世间贵赤栴檀汁所染污。其果香气能染人心。是时比丘鼻嗅果香。第二比丘问言。汝欲食不。长老。我不乐食。是事希有。不可思议。是离欲结。最为广大。何以故。若人未离欲嗅如是香。即生心气。乃发颠狂。有诸离欲外人。若嗅此香。退失离欲之地。是二比丘。还王舍城。说如上事。时有一人。名曰长胫。本是王种。姓拘利氏。宿业果报所得神通。是人有此威神相貌。若行水中。前脚未没。后脚已移。若行草上。草虽未靡。便得移步。若行树叶。树叶未低。后足已度。鞋履践处。并不为难。是长胫人从佛所闻。是剡浮树。如此如此。即白佛言。世尊。我今若行至剡浮树不。答云得至。是人顶礼佛足。右绕三匝。面正向北。发此而去。行度诸山。一名小黑山。二名大黑山。三名多[犛-未+牙]牛山。四名日光山。五名银山。六名香水山。七名金边山。是人登金边山顶。转面向北。耸身远望。唯见黑暗怖畏而反。佛问汝至剡浮树不。答言不至。佛问汝何所见。是人答曰。唯睹黑暗。佛言。此黑暗色。即剡浮树。是人重礼佛足。右绕三匝。更向北行。重度七山。一名周罗迦啰第二摩呵迦罗第三瞿汉山第四首罗山。第五稽罗山。第六乾陀山。第七修跋姖山。又渡六大国土。一名鸠留国。二名高腊鞞。三名毗提诃。四名摩诃毗提诃。五名郁多罗曼陀。六名沙熙摩罗野。是名六大国土。又度七大树林。林间有河。度是七河。又度阿摩罗林。及诃梨勒林。乃至剡浮提树南枝。从南枝上。行至树北枝。是人俯窥见下水相。与常水异。最澄最清。向底洞澈。都无障翳。是人观已。作是思惟。我之神通。今于此处。得成就不。因脚履水。手攀树枝。是脚至水。如石即没。于此神通。不得成就。云何如此是水。最轻最细。若以彼水。投此涧水。如苏如油。浮在水上。若以此水。投于彼水。即沈如石。是人从剡浮树。取一果子。还王舍城。奉上世尊。佛受此果。破为多片。施诸大众。果汁染于佛手。尔时佛以此手击于山石。至今赤色如昔不异。湿亦不燥。掌迹分明。因昔分果为片片故。因名此石。为片片岩。是时佛化优娄频螺迦叶。取此剡浮提树子。送与迦叶。迦叶。汝食是果。迦叶问佛。大瞿昙沙门。那得是果。佛语迦叶。是树名曰剡浮。此果从彼树得。迦叶曰。我不能食是果子。沙门但取自食。时诸天神又送剡浮树子。供养于佛。或在舍卫若王舍城迦毗罗卫国等。佛得受已。分施大众。复余比丘住剡浮所。还此土说。目连比丘亦曾住彼还此。次第为比丘说。以是因缘。此事可知

    六大国品第三

是剡浮树外有二林。形如半月。围绕此树。其内有林。名呵梨勒。外名阿摩勒。阿摩勒果。是子熟时。其味最美。不辛不苦如细蜂蜜。果形大小。如二斛器。其核如自性阿摩勒核。呵梨勒果。是子熟时。其味最美。不辛不苦。如细蜂蜜。果形大小。两倍于前。核亦如是。阿摩勒林南。复有七林。七河相间。其最北林。名曰庵罗。次名剡浮。三名娑罗。四名多罗。五名人林。六名石榴林。七名劫毕他林。如是诸果。其子熟时。不辛不苦。甜如蜂蜜。是人林中果形似人。如剡浮提胜人王种。其姓拘梨。若男十六岁。女十五岁。庄严具足。状如行嫁。是人林果可爱如是。其子蔕形。如人头髻。未离欲者。见此果子。便生爱心。诸外道等有离欲人。若见此果。退失禅定。欲心还生。其子熟时。唯鸟竞食。鸟食之余。残落在地。如尸陀林。甚可厌恶。诸退定者。见是相已。深生厌离。还得本定。是二林广五十由旬。东西达海。其一一河。广五十由旬。东西达海。林河相次。互相间错剡浮提地。林河所覆。七百由旬。其劫毕他林南有六大国。其最南国名曰高流。次名俱腊婆。三名毗提诃。四名摩诃毗提诃。五名郁多罗曼陀。极北名舍喜摩罗耶。是六国内。人皆贞善。持十善法。自不杀生。不教他杀。其兽将死。自至人所。既自死已。乃啖其肉。是处[犛-未+牙]牛。其数最多。以其髦尾用覆屋舍。其地生麦。不须耕垦。是麦成粒。无有糠糩。是其国人磨蒸为饭。而是麦饭气味甘美。如细蜂蜜。云何知耶。过去久远有王出家。其王夫人亦得出家。国师婆罗门亦随出家。既出家已。各相舍离。入山学道。是王夫人有时月水。月水净时。往至王所。与王相见。即白王言。大王我今有月水。古昔之人尊重儿息。王欲弃舍不从妃意。思惟事重。复恐不可。遂共和合。乃有大福德子。男女二人俱时托胎。舍王而去。既经时节。其后腹大。从诸村落。次到郡县。乃至诸州。人人诃骂云。此女人都无道心。出家破戒。妃闻是语。深生愧悔。是时国师大婆罗门已成仙人。得五神通。随一山林。依止而住。尔时王妃闻婆罗门在彼山住。仍往寻觅。既见师已。乃问妃言。是娠谁作。妃即答言。是王所为。尔时仙人忆王昔恩。仍于别处。为起叶屋。即语王妃。汝止是中。我今当采树根果子以相供赡。太妃依语。仍住其中。于是仙人。如法采拾树根果子。供给是妃。妃怀孕月满。遂产二子。一男一女至断乳已。驱斥是妃。汝今远去。我当随得根果养饴二儿。妃弃二子。依语而去。仙人随得根果。养育此儿。两儿稍大。已至识地。是时仙人以生熟杂果。试与二儿。于是二儿自能分别。熟者即啖。生者便弃。仙人作是思惟。是儿身已长大。心至识地。能分别果生熟差别。我令当住何处国土。丰乐安隐以置立之。以五通故。见是麦地。即以神力携二小儿。飞空而往。安置是地。教是儿言。此草名麦。尔时仙人即自刈取。磨以为食。种种教示。汝等从今当依此法以为资粮。汝住此中。莫生愁恼。我当数数来看视汝。是两小儿乃住其中。仙人后时数往瞻视。是二小儿随年月长。男女二根各皆成就。遂为夫妻。子孙生长。分成六国。尔时大王既学道已。舍于人身。往生天上。舍上天身。还受人身。受人身已。依佛所说无上正法。出家学道。至得无碍六种神通。以六通故。观自宿命。见六大国。作是思惟。是六大国皆我子孙。为怜愍是六国人故。往彼乞食。得麦饭还。不问诸比丘前食。而独自食时。诸比丘称此比丘名。而大骂辱。汝长老。大悭嫉妒。咄汝恶人得是麦饭。不问诸比丘。而独自食。比丘答言。我今不为嫉妒。而不布施汝等。何以故。如是饮食。未离欲人则不得食。时是比丘三过洗钵。再过弃之。以最后汁。取其少分。施诸比丘。是剡浮提无有一味等此味者。于是比丘为诸比丘说此食味次第因缘。彼六大国本我子孙。是故利益彼国人故。往彼乞食。有余比丘往彼乞食。大目揵连亦往乞食。佛世尊为诸比丘说是六国次第因缘。是故得知六大国事。六大国品究竟

    夜叉神品第四

时剡浮提中有两众山。恒河之南名娑多耆利山。恒河之北名醯摩跋多山。娑多耆利山中是山最大。一名萨阇。二名频诃。三名末车。四名遏车婆。五名间诃耆利。六名波梨耶多罗。醯摩跋多山中是山最大。一名周罗迦罗。二名摩诃迦三名瞿诃那。四名修罗婆计。五名鸡罗。六名干驮摩驮。七名修槃那般沙。若一切神住河南山者。皆名婆多耆利神。若在河北山者。皆名醯摩跋多神。是婆多耆利神。领河南一切诸神。故名为王。是醯摩跋多神。领河北一切诸神。故名为王。云何知耶。有一神王。名醯摩槃。住醯摩跋多山。是神王最长老大年至极位。重疾困苦。是神临死。其有太子。名醯摩跋多。呼来教示。即语子言。阿父。我已得闻。从昔夜叉神最为长老。见过去佛。曾值迦叶佛。闻说释迦牟尼佛将应出世。如我见相及我所见因缘。是释迦佛不久应下。阿父。若我中间舍命不及佛者。汝决应往令得见佛。若汝见佛决大利益。太子问曰。云何令我知佛出世。父答子言。汝屋舍中未曾有宝而出现者。当知是时如来出世。复有神王。名娑多耆利。住摩伽陀国界中。汝当与彼共作朋友。同立誓愿。我之与汝所住之处。若见希有奇宝现者。莫不相报。是时父王教其子已。即便舍命。是时太子供养父尸。忆持尊重父之遗嘱因是度河往觅娑多耆利神王。至神所已。对面语言。共相和敬。同坐一处。醯摩跋多神语娑多耆利王言。府君。我父临死说如上言。因即过世。是故我今语汝是事。若屋室中非常宝现。决须相报。娑多耆利答如是如是。于是二人既立誓已。各还所住。后时醯摩跋多王宅有奇宝现。莲花千叶。大如车轮。黄金为叶。众宝为茎。时有一神。见是莲花。驰往白王。王今知不。是宝瑰异。世未曾有。今已出现。千叶莲花。大如车轮。黄金为叶。众宝为茎。此是天物。愿王往观。是时神王闻是言已。即往池所。见是莲花。具足千叶。大如车轮。众宝所成。庄严奇特。见是事已。心生惊怪。身毛皆竖。自下池中。恭敬合掌。顶礼三过。旋绕三匝。作是思惟。我于昔时。曾值善友。而教我言。汝所住处。若有奇宝。当遣报我。因遣使者。往报娑多耆利神王曰。府君。我今住处。希有之宝。今已出现。具说宝相。汝今当来共我观视。是时世尊已出于世。正法已说。一向寂静。今至涅槃。往向菩提。修伽陀所教。是时娑多耆利王觉忆此事。作是思惟。我昔曾有善友来报我言。汝所住处。诸佛世尊于中得道。若佛已出。汝应报我。是其所欲。故我应报。娑多耆利王即遣使往。谓是王言。府君。若一莲花。作何利益。若百若千。亦何利益。我国土中未曾有宝。今已出现何者名宝。谓多陀阿伽度阿罗诃三藐三佛陀今已出世。汝今应来共事此宝。醯摩跋多九月十五。是布萨时。有五百神。共相围绕。取诸莲花。面向南行。履空而去。往娑多耆利王所。彼王又将五百神众。共相围绕。来迎是王于恒河南边。共相聚集。既相见已。醯摩跋多王说偈。问彼神曰

  今十五净日　　四王来集时
  我等事何师　　汝信阿罗诃

尔时娑多耆利王。说偈答曰

  是时佛世尊　　住摩伽陀城
  为灭一切苦　　说法一切智
  诸苦及苦集　　苦灭不更生
  八分苦灭道　　无恼向涅槃
  是故汝及我　　当往事是人
  一切无能比　　是我信罗诃

尔时醯摩跋多。闻是偈已。心大惊怖。身毛皆竖。怀疑未信。三过辩定。府君。汝今说世尊出世。答曰。府君。我说佛宝出世。第二第三。问答亦尔。是时北山神王。即时如力思度诸佛行住威仪境界四法。问南山神王。说偈问曰

  佛心于众生　　善得安立不
  憎爱二思惟　　已得灭尽不

尔时南山神王。以偈答曰

  佛心于众生　　真实得安立
  憎爱两思惟　　灭尽永无余

北山神王。重偈问曰

  佛有妄语不　　无恼他言不
  无离间语不　　有无义语不

南山神王。以偈答曰

  佛不说妄语　　亦无苦涩语
  不说离间语　　说如量义语

北山神王重说偈问曰

  佛无盗他不　　不损他命不
  远离放逸不　　不损禅定不

南山神王。说偈答曰

  佛不盗他财　　是故护他命
  远离诸放逸　　不损深禅定

北山神王。又偈问曰

  佛无著爱欲　　心净无浊不
  已过无明流　　得净法眼不

南山神王。答曰

  不着于欲尘　　心地最清净
  已过于无明　　于法得净眼

北山神王。又问曰

  佛明具足不　　法足清净不
  四流已绝不　　后生已尽不

南山神王。又答曰

  佛明已具足　　法足久清净
  四流已断灭　　是故无后生

尔时北山神王闻已。心生欢喜。说偈赞叹

  智者意成就　　一切事已办
  及身口清净　　赞叹具明足

南山神王。心口欢喜。说偈赞曰

  佛心寂清净　　身口能利他
  十力无与等　　今随喜汝赞
  智者心成就　　及与身口业
  具足明法足　　即共汝往观
  今十五布萨　　四王游巡时
  心解脱无著　　我共汝礼拜

尔时世尊。住王舍城。匿瞿提树下。是二神王千神围绕。往诣佛所。至佛所已。偏袒右肩。右膝着地。合掌恭敬。顶礼佛足。却坐一面。时北山王。以偈问曰

  能说亦能行　　度流永无漏
  独步如师子　　佛不染世法
  度一切法岸　　殷勤故来问
  众生生何处　　数数习有处
  执持是何物　　何处而受苦

尔时世尊。以偈答醯摩跋多神王曰

  众生生六处　　数数习六处
  执持六种法　　六处受苦恼

北山神王。重偈问佛

  是取名何取　　而令众生苦
  愿答出离问　　云何解脱苦

尔时世尊。以偈答醯摩跋多神王曰

  世间有五尘　　我说心第六
  于中离欲着　　解脱如是苦
  众生得出离　　已说如理量
  汝今既有问　　是故答出离

北山神王。重偈问佛

  谁能度驶流　　日夜无疲极
  无底亦无攀　　深处谁不沈

尔时世尊。以偈答醯摩跋多神王曰

  常持清净戒　　精进不散心
  思择内正念　　由智度难度
  欲想无有欲　　伏灭色系缚
  永灭有喜爱　　是人终不沈

尔时南北二山王。同时说偈。以赞佛曰

  我等今善见　　善来今善明
  我等见正觉　　演说甘露道
  名无灭失见实义　　常乐问难无所著
  穷智慧际悉解脱　　行于圣路大仙人
  千余夜叉众　　名闻有威神
  一切归依佛　　是我无上师

是三夜叉三角而坐。是故至今路名菱角。是时世尊住于树下。是故此树名瞿匿昙瞿提。因此二夜叉事。故知南北二山。夜叉神品究竟

立世阿毗昙论卷第一佛说立世阿毗昙论卷第二

        陈西印度三藏真谛译

    漏阇耆利象王品第五

周罗迦罗山。高一伽浮多半。其广亦尔。中间亦如是。摩诃迦罗山。高三伽浮多。广亦如是。中间亦尔。瞿诃那山。高一由旬半。广及中间。亦复如是。修罗婆诃山。高三由旬。广及中间。亦复如是。鸡罗婆山。高六由旬。广及中间。亦复如是。干驮摩驮山。高十二由旬。广及中间。亦复如是。修槃那般娑山。高二十四由旬。广及中间。亦复如是。修槃那般娑山。于秋月时。天晴不雨。最放光明。复有诸人近雪山住。四月高平地会。互相招呼。往观天上。至摩诃迦罗山顶。仰观北面。遥见彼山。光明照曜。因相谓曰。是须弥山。我今已见天上。是修槃那般娑山北边。有最胜处。复有大池。名曼陀基尼。长五十由旬。广十由旬。其水清洁冷甜轻软。其中莲藕根茎具足。其池底岸。皆以白银黄金水精琉璃四宝为塼。构垒为池。银最居外。次第围绕。水所渍处。与宝同色。其池四边有四阶道。通至水底。并四宝成。池东南角。直往至山。其山有岩。名曰难陀。长五十由旬。广十由旬。其岩悉是琉璃。平滑可爱。有似宫室。宝色不同。种种相貌。自然雕画。如北[毯-炎+瞿]毹。人兽草木。莫不毕备。是岩彩色。亦复如是。如人耳珰七宝庄严。是地色相。亦复如是。一切琉璃。平滑可爱。种种宝色。若脚所践。即便陷没。脚若起时。还复如本。如细绵聚。及兜罗绵。其地柔软。亦复如是。是难陀岩。蹈时没足。举足便起。是中殿堂。其数不一。或有金堂。或有银堂。颇梨琉璃。亦复如是。或四宝合成。是诸殿堂。皆象王等之所住处。岩池中间有最胜处。有树匿瞿提王。名曰善立。根茎枝干。并皆具足。形相可爱。其叶繁密。久住不凋。风雨不侵。如世精巧装饰花鬘。及众宝耳珰。亦如伞盖高下相覆。其树形相。亦复如是高一由旬。垂枝如柱。数满八千。下皆入地。故名善立。池西南角外有最胜处。有娑罗王树。名曰善见。根茎枝干。并皆具足。形相可爱。其叶繁密。久住不凋。风雨不侵。如世精巧装饰花鬘。及众宝耳珰。亦如伞盖高下相覆。其树形相。亦复如是。高一由旬。下身洪直。一半由旬。方有枝叶。此树身量。刺径五寻。围十五寻横枝四出。各半由旬。又其树外有娑罗树林。高下相次。七重围绕。枝叶相覆。外望如一。其裹重树围十三寻。如是次第各减一寻。其最外重树围七寻。内重最高。次外渐下。其树形相。根茎枝干。并皆具足。其状可爱。其叶繁密。久住不凋。风雨不侵。如世精巧装饰花鬘。及众宝耳珰。亦如伞盖高下相覆。其树形相。亦复如是。萎叶枯枝。若堕落时。树既繁密。溜堕林外。其林外边。四面突出。状似门屋。其树下之地。金沙所覆。香水散洒。烧众名香。散诸杂花。悬众宝衣。于其树下。是娑罗花。与诸杂花。弥覆其地。甚可爱乐。是娄阇耆利象王恒居其所。其身洁白。七支拄地。六牙具足。随意变化。有大神通有大威德。其一一重。有八千象。一重白特象。次重白牸象。第三黄特象。第四黄牸象。第五赤特象。第六赤牸象。第七青特象。第八青牸象。其外黑特牸象不在围数。如是象王。欲到曼陀基尼池。自洗浴时。外诸黑象即率相往。防持路渚。既防护已。是时象王众象围绕。往到池所。其白牸象围绕象王。入池洗浴。取此池水。摩洗王身。或来洗面。或来洗耳。遍诸身分。悉皆如是。当王浴时。是诸象等采众杂花。以为花鬘。奉献于王。或为耳珰。或为璎珞。种种异饰。庄严王身。既洗浴已。从池登岸。往匿瞿提树下。晒身令燥。过去是处有一猎师。射杀象王。因于是中广说菩萨昔本生经。尔时诸象随色次第并入池浴。既浴竟已。往到树下。围绕象王。其黑象者。最后入浴。拔取藕根。刮洗令净。还至树下。其黑特象送与黑牸象。其黑牸象送与青特象。青特象送与青牸象。青牸象送与赤特象。赤特象送与赤牸象。赤牸象送与黄特象。黄特象送与黄牸象。黄牸象送与白特象。白特象送与白牸象。白牸象送与大象王。令象王食。象王食已。以其残藕。还依次第。分与众象。唯余黑象若食不足。更使黑象往池采之。令得充足。是黑象者。唯在池食。是诸象等食此藕已。成身七分。若食草木诸树叶者。则成屎尿。是诸象等若出屎尿。悉与黑象。为其拼除。送食亦尔。是白象王。于其四月。住难陀岩。春冬八月住娑罗王善见树下。次后象王亦恒在此难陀岩住。昼则移住娑罗王善见树下。浴已食时。皆在匿瞿提树下。云何知耶。昔时净命大智舍利弗。身带风病。医师说言。大德此疾藕能治之。时有净命神通目连。于往昔时。已见此藕。即此大德说如是言。我往取此藕将来于是。目连即以神通往金边山作是思惟。此象王者。有大神通。有大威德。有憍慢心。是故决令象王惊怖。即如象身高耸长大。目连化身为一大象。两倍于彼。又复化为众象眷属。身形头数。亦复两倍。具足围绕当象王前。飞空而下。时白象王见是事已。心怀惊怖。身毛皆竖。作是思惟。有别象王。从别处来。神通威德身形头数。悉皆胜我。今当摈我夺此住处。是时净命大目犍连知其惊怖。见其相异。即舍神通所现化事。仍于别处。跏趺而坐。是白象王见斯事已。作是思惟。非别象王。是大比丘。尔时象王自化其身。为天童子。以天金宝。庄严臂手。天冠耳珰众宝璎珞庄严其身。时目犍连端坐念时。天童子默念合掌。五体投地。敬礼大德。是时目连语象王言。长老象王。汝大神通威德难及。象王答言。大德。我是畜生。有何神力。至无威德。圣师来此。欲何所为。目连答言。我欲得藕。是时象王即敕黑象。汝去取藕。如大德意。是时黑象即入池中。取藕洒束。恣一象担载象背上。随大目连飞空而去。目连至已。时诸比丘即受此藕。从昔至今。故谓此处。名象下支提。又复名曰送藕支提。亦复名为受藕支提。大德舍利弗食此藕已。病即消除。时舍利弗过是病已。至般涅槃。身无病恼。其诸比丘并食此藕。如是藕者。其形可爱。味汁浓多。甜无辛苦。如细蜂蜜。方圆长短纵广一尺。节节如是。其一节汁。满下品钵。有余比丘。神通往彼金边山侧。见如是事。还此间说。时佛世尊为诸比丘。说此因缘。是故得知如是等事

    四天下品第六

尔时佛说。天下有四。一剡浮提。二者西瞿耶尼。三东弗于逮。四北郁单越。尔时比丘白佛言。世尊。此剡浮提其地若大。佛告比丘。剡浮提大。东边地际。二千由旬。西北二边。亦各二千由旬。南边地际。但三由旬。周回六千三由旬。其面如车一切众生生此地上。面似地形。是剡浮提具有江山。江山中间。诸国间厕。尔时比丘白佛言。世尊。西瞿耶尼。其形若大。佛告比丘。西瞿耶尼大。广二千三百三十三由旬。又一由旬三分之一。周回七千由旬。地形团圆无山有江。其江中间。立诸国土。人民富乐。无有贼盗。悉多贤善。填满其中。是时比丘复白佛言。世尊。东弗毗提。地形若大。佛告比丘。东弗毗提大。广二千三百三十三由旬。又一由旬三分之一。周回七千由旬。地形团圆。犹如满月。多有诸山。唯有一江。是山中间。安置诸国。人民富乐。无有贼盗。悉多贤善。充满其国。一切诸山。并是金宝。耕梨鋘斧及诸器物。并是真金。其一江者。名曰萨阇。其江浦岸。并皆可爱。净命宾头卢于彼岸侧。起僧伽蓝。云何得知如是等事。昔时波罗奈国。有一比丘。及一沙弥。皆具神通。从波罗奈。往东毗提下。时此沙弥取一石子。欲以磨针。即持此石。还波罗奈。安置寺中。即于是夜。大放光明。是时比丘问沙弥言。汝取彼物将还此不。大德。我将彼石子。还来此中。欲以磨砺剃刀针等。比丘即便语沙弥言。汝取此石送还彼国。是时沙弥从比丘言。即提此石。投波罗奈深江水中。是时此江大放光明。一切龟鱼诸水类等。并皆显现。其国人民争往观看。衢巷填满。无复门户。皆谓是龙现大神力。是时比丘与此沙弥。于晨朝时入城乞食。见是人众无量无数聚集河边。城门阨塞。还往难通。问沙弥言。汝前此石掷置何处。沙弥答言。大德。我以此石。掷河深处。比丘复语沙弥。汝取此石。还送本处。是时沙弥即从其语。于看众前。入河深水。而取此石。身衣不湿。踊出空中。飞腾而去。送还本处时。诸比丘往还彼国。其数无量。并说如是。时佛世尊为诸比丘。说此因缘。是故得知。尔时比丘。白佛言。世尊。北郁单越国土若大。佛告比丘。北郁单越大。东际长二千由旬。西际二千由旬。南北亦尔。四周八千由旬。以金山城之所围绕。黄金为地。昼夜常明。是郁单越地有四种德。一者平等。二者寂静。三者净洁。四者无刺。谓平等者。彼国土中。无有[山*亢]阱。亦无穴居。又不敧仄。无有高下。亦不泥滑。故名平等。其寂静者。彼国土中。无有师子虎豹熊罴毒蛇蜂虿能害人者。故名寂静。其净洁者。于彼国中。无有死尸死蛇死狗诸不净物。若彼民人。大小便利。地坼受之。受已还合。故名净洁。其无刺者。彼国土中。无利刺树。无臭气树。故名无刺。彼中有草。名曰车毗。其色绀青。形甚可爱。如孔雀项。触时柔软。如迦真邻衣。迦真邻衣者。不可染污。夏冷冬温。又如阿时那衣。烧之不然。草触柔软。亦复如是。是车毗草遍覆其地。四时不凋长唯四寸。其国诸江。八功德水。岸渚及底。并布金沙。其水恒流。无有增减。金堤坚固。永无崩落。佛说如是。尔时佛告比丘。伽娄罗鸟所住四洲。其东弗毗提南剡浮提二洲中间。有伽娄罗洲。南剡浮提西瞿耶尼二洲中间。有伽娄罗洲。西瞿耶尼北郁单越二洲中间。有伽娄罗洲。北郁单越东弗毗提二洲中间。有伽娄罗洲是鸟洲者。围一千由旬。洲形团圆。一切皆是深浮留林。伽娄罗鸟。住在林中。洲外水下。并龙住处。龙居此地。犹如彼鸟。聚蓄饮食。饥则便取。迦娄罗鸟。凡有四种。一者化生。二者湿生。三者卵生。四者胎生。一切诸龙皆亦四生。化生迦娄罗。能食四种龙。湿生迦娄罗。除化生龙。能食三种。卵生迦娄罗。食后二种。胎生迦娄罗。食后一种。其鸟食时。两翅扇水。水开五十由旬。因捉取龙还上树食。鸟所食残。犹如象骨。在地狼藉。是故四洲恒有臭气。东弗毗提南剡浮提两洲中间。迦娄罗鸟所住之洲。有树名曲深浮留。根茎枝干。并皆具足。形相可爱。其叶繁密。久住不凋。风雨不入。如世精巧装饰花鬘。及众宝耳珰。亦如伞盖高下相覆。其树形相。亦复如是。高百由旬。下本洪直。五十由旬。方有枝叶。枝叶四布迳百由旬其树下本。径五由旬。周围十五由旬。迦娄罗王名鞞那低耶。居是树上。其大龙王名摩那斯。欲共鸟王戏时。出浮显现。是时鸟王捉取此龙。安树枝上。而是龙王自性本大。更复变化。能令身长。如是鸟王捉龙还树。龙身随长。遍满树上。如是次第龙身满树。是龙重故。树为摧曲。是时鸟王觉是事已。仍放此龙。作是思惟。是摩那斯龙。坏我住处。时鞞那低耶鸟王起悔恨心。退一处住。默念忧恼。是摩那斯龙遂能张我。尔时龙王又变作天童子。以天金宝。庄严臂手。天冠耳珰众宝璎珞。以饰其身。住鸟王所。而作是言。善友。汝有何事。忧恼困苦。默然独住。起不安心。鸟王答曰。我今被张。为摩那斯龙。坏我住处。童子答言。善友。汝更取龙作饮食不。损汝住处。尚复忧恼龙失眷属。其苦云何。汝若更复取龙。住处决当不立。于是龙鸟二王。共立誓愿。不相损害。永为朋友。为是因缘故。名此树为曲深浮留。是四天下。及四鸟洲。其地最大。是故今说其一一洲。八洲围绕。牛洲。羊洲。[卄/耶]子洲。宝洲。神洲。猴洲。象洲。女洲。其余七洲。亦复如是。此义佛世尊说。如是我闻

    数量品第七

尔时佛告富娄那比丘。是世界地。形相团圆。如铜烛盘。如陶家轮。是世界地。亦复如是。犹如烛盘边缘隆起。其铁围山。亦复如是。譬如烛盘中央耸起。其世界中有须弥山王。亦复如是。此须弥山。七宝所成。色形可爱。四角端直。譬如工匠善用绳墨斫成板柱。其形方正。是须弥山。亦复如是。半形入水。八万由旬。半形出水。八万由旬。其山四边。各八万由旬。周回三十二万由旬。最里大海。名须弥海。深八万由旬。广四万由旬。一边长十六万由旬。周回六十四万由旬。海外有山。名由乾陀。此山入水。四万由旬。出水亦尔。广亦如是。四万由旬。是山一边。长二十四万由旬。周回九十六万由旬。此出外海。亦名由乾陀。深四万由旬。广亦如是。一边长三十二万由旬。周回百二十八万由旬。海外有山。名伊沙陀。入水二万由旬。出水亦然。广亦如是。一边长三十六万由旬。周回一百四十四万由旬。山外有海。亦名伊沙陀。深二万由旬。广亦如是。一边长四十万由旬。周回一百六十万由旬。海外有山。名诃罗置。入水一万由旬。出水亦尔。其广亦然。一边四十四万由旬。周回一百七十六万由旬。山外有海。亦名诃罗置。深一万由旬。广亦如是。一边长三十六万由旬。周回一百八十四万由旬。海外有山。名修腾娑。入水五千由旬。出上亦尔。其广亦然。一边长四十七万由旬。周回一百八十八万由旬。山外有海。亦名修腾娑。深五千由旬。广亦如是。一边长四十八万由旬。周回一百九十二万由旬。海外有山名阿沙千那。入水二千五百由旬。出水亦然。广亦如是。一边长四十八万五千由旬。周回一百九十四万由旬。山外有海。亦名阿沙千那。深二千五百由旬。广亦如是。一边长四十九万由旬。周回一百九十六万由旬。海外有山。名毗那多。入水一千二百五十由旬。出水亦然。广亦如是。一边长四十九万二千五百由旬。周回一百九十七万由旬。山外有海。亦名毗那多。深一千二百五十由旬。广亦如是。一边长四十九万五千由旬。周回一百九十八万由旬。海外有山。名尼民陀。入水六百二十五由旬。出水亦然。广亦如是。一边长四十九万六千二百五十由旬。周回一百九十八万五千由旬。山外有海。亦名尼民陀。深六百二十五由旬。广亦复然。一边长四十九万七千五百由旬。周回一百九十九万由旬碱海外有山。名曰铁围。入水三百十二由旬半。出水亦然。广亦如是。周回三十六亿一万三百五十由旬。从尼民陀山际。取铁围山际。三亿六万三千二百八十八由旬。从尼民陀海际。取铁围山际。三亿六万二千六百六十三由旬。从剡浮提南际。取铁围山。三亿六万六百六十三由旬。从剡浮提中央。取西瞿耶尼中央。三亿六万六千由旬。从南剡浮提北际。取北郁单越北际。四亿七万七千五百由旬。从铁围山水际极西。铁围山水际。迳度十二亿二千八百二十五由旬。铁围山水际。周回四十六亿八千四百七十五由旬。从此须弥山顶边。至彼须弥山顶边。十二亿三千四百五十由旬。从此须弥山中央。至彼须弥山中央。十二亿八万三千四百五十由旬。从此须弥山根。至彼须弥山根。十二亿三千十五由旬。如是义者。佛世尊说。如是我闻

    天住处品第八

佛告比丘。是须弥山王。东西南北。凡有四边。其东边真金所成。西边白银所成。北边琉璃。南边颇梨。其一切边众宝所成。是须弥山。七性最饶。山之极顶。中央平正。最胜处所。是忉利天善见大城。周围四方。十千由旬。纯金为城之所围绕高一由旬。城上埤堄。高半由旬。门高二由旬。其外重门。高一由旬半。十十由旬。有一一门。城之四面。为千门楼。是诸城门。众宝所成。种种摩尼之所严饰。譬如北地妙好氍毹。人非人等。龙兽草木。及诸杂花莫不必备。亦如耳珰众宝庄严填满具足。是诸城门。亦复如是。或有一切诸众生相。种种树木及杂花相庄严其外。是城门边。庄严象军。庄严马军。庄严车军。住是城门。是诸天子庄严铠仗。聚集其中。护国土故。欲游观故。为庄严故。城外四边。七重宝栅。周匝围绕。其最里者。真金所成。次用白银。第三琉璃。四颇梨柯。其外三重。杂宝所成。七重之外诸多罗树。七重围绕。其最里树。真金为本。次是白银。第三琉璃。四颇梨柯。其外三重。众宝为本。金多罗者。白银琉璃颇梨众宝为其花叶。子亦如是。银多罗者。黄金琉璃颇梨柯宝为其花叶。子亦如是。琉璃多罗。金银颇梨为花子叶。颇梨多罗。金银琉璃为花子叶。其外三重花叶果子。并众宝成。是多罗树。微风吹动。出妙音声。能令众生起五系缚。一者生爱。二者起缚。三起迷乱。四生执着。五不厌离。譬如五分音乐。如精妙乐师五音繁奏。能起众生五种欲心。是树音声。亦复如是。其七重树间。处处皆有众宝花池。纵广一百天弓。天水盈满。四宝为塼。构垒底岸。金银琉璃及颇梨柯之所成就。其池四边。亦四宝甎以为阶道。一一池中。有无量花。五宝所成。谓金银琉璃颇梨柯呵梨多。是诸池内。有四宝船。泛漾其中。谓金银琉璃颇梨。复有八种水戏之具。一者。跳入水楼。二者。以七宝涵。注水灌身。三者。击水之具。以为音乐。四者。水溅以为嬉戏。五水轮车。六者。浮屋。七者。宝轮鷿鶙。八者。绳楼自缒。旋回击荡。其中男女诸天乘船游戏。是时宝船随心迟速。男女诸天若作是意。愿欲向彼。船即到彼。是诸天等若作是意。愿取彼花。来至我所。花便自至。其中果报自然风起。吹众名花。遍散诸天。复有别风吹诸花鬘。庄严身首。或为宝冠。或为璎珞。或为臂印。乃至腰绳。或为足钳。池岸四边。有五种宝树。一金。二银。三琉璃。四颇梨柯。五呵梨多。其树行间。有众宝堂殿。五宝所成。诸男女天。于其中住。是其城外多有诸天。遍满国土。多罗树外宝堑三重。其一一堑。广二由旬深一由旬半。下广于上。有如壶口。于其堑中。天水盈满。亦四宝塼之所构成。金银琉璃及颇梨柯。其堑四边。亦四宝塼以为阶道。一一堑中。又有无量四宝诸花。有四宝船。泛漾其中。金银琉璃颇梨等宝之所成就。复有八种水戏之具。一者。跳入水楼。二者。以七宝涵。注水灌身。三者。击水之具。以为音乐。四者。水溅以为嬉戏。五水轮车。六者。浮屋。七者。宝轮鷿鶙。八者。绳楼自缒。旋回击荡。其中男女诸天乘船游戏。是诸宝船随心迟速。男女诸天若作是意。愿欲往彼。船即到彼。是诸天等若作是意。愿取彼花。来至我所。花便自至。其中果报自然起风。吹众名花。遍散诸天。复有别风。吹诸花鬘。庄严身首。或为宝冠。或为璎珞。或为臂印腰绳足钳。亦复如是。堑之中间。众宝堂殿。天诸婇女之所住处。于其堂间。布置宝镬。一一镬中。植诸花草。五色异相。各为行列。其三重堑外有七宝树之所围绕。谓金银琉璃颇梨柯莲花色宝螺石呵梨多等。是树林中。处处皆有七宝花池。天水盈满。乃至宝船游戏。及诸殿堂。男女天众之所居止。多有诸天。遍满国土。亦如上说。是时堑外诸七宝树。开七宝花。谓金银琉璃颇梨。乃至呵梨多等。是其林中诸女天等讴歌作乐。无量天子从大城出。入林观听。是其城中诸天子等讴歌作乐。外诸女天入城观听。因是方便往来戏乐。分于大城四分之一。中央金城。帝释住处。十二由旬。有一一门。四面四百九十九门。复有一小门。凡五百门是城形相。亦卫四兵。栅堑树池杂林宫殿。作倡伎乐及诸外戏。种种庄严。皆如前说。是城中央。释提桓因所住之处。宝楼重阁。名皮禅延多。长五百由旬。广二百五十由旬。周回一千五百由旬。柱高九由旬。四宝所成。一金。二银。三琉璃。四颇梨柯。四种宝塼以为柱础。其楼四方有四阶道。一切诸壁。并四宝成。三层皮持之所围绕。第一层。真金所成。二白银。三琉璃。其一一层。三重宝铃。微风吹动。出妙音声。譬如五分音乐。如前所说。多罗树声能令众生起五欲缚。其阁四边却敌宝楼。东边二十六。三面各二十五。凡一百一所。一一却敌。方二由旬。周回八由旬其却敌上。复有宝楼。高半由旬以为观望。一一却敌有七女天。一一女天有七婇女。楼阁之内有七万七百房室。一一房内。有七天女。一一天女。婇女亦七。其天女者。并帝释正妃。其外却敌及内诸房。凡四亿九万四千九百。正妃三十四亿六万四千三百。婇女妃及婇女。合有三十九亿五万九千二百。皮禅延多重阁最上当中央圆室。广三十由旬。周回九十由旬。高四十五由旬。释提桓因所住之处。并是琉璃所成。地皆柔滑。众宝填厕。譬如北地妙好氍毹。人非人等。龙兽草木。及诸杂花。莫不必备。亦如耳珰众宝庄严。填满具足。帝释住处。亦复如是。皆以琉璃所成。众宝庄严。其地柔软脚所履践。即便陷没。脚若起时。还复如本。如细绵聚。及兜罗绵。帝释住处。亦复如是。脚践则没。举足便起。洒散杂花烧香芬馥。悬诸天衣及宝花鬘。如是处者。释提桓因与阿修罗女舍脂共住。帝释化身与诸妃共住。一切诸妃作是思惟。帝释与我共住。帝释真身与舍脂共住。是其城内四边住处。衢巷市廛。并皆调直。是诸天城。或有住处。四相应舍。或有住处。重层尖屋。或有住处。多层高楼。或有住处。台馆云耸。或有住处。四周却敌。随其福德。众宝所成。平正端直。是天城路。数有五百。四陌相通。行列分明。皆如基道。四门通达。东西相见。巷巷市廛。宝货盈满。第一谷米市。二衣服市。三众香市。四饮食市。五花鬘市。六工巧市。七淫女市。处处并有市官。是诸市中。天子天女往来贸易。商量贵贱。求索增减。称量料数。具市廛法。虽作是事。以为戏乐。无取无与。无我所心。脱欲所须。便可提去。若业相应。随意而取。业不相应。便作是言。此物奇贵。非我所须。当四衢道。象马车兵之所庄严。及诸天子止住其中。或为守护。或为戏乐。或为庄严。市中间路。一切琉璃。软滑可爱。众宝庄严。譬如北地妙好氍毹。龙兽花草。皆如前说。乃至烧香散花。悬诸天衣。亦复如是。复于处处。竖立幡幢。天大城内。如是等声。恒无断绝。所谓象声。马声。车声。螺声。波那婆声。鼓声。牟澄伽声。笳声。音乐声。又有声言。善来善来。愿食愿饮。我今供养。是善见大城。帝释住处。复有天州天郡天县天村。周匝遍布须弥山上。善见大城。其西北角。从门阃外。二十由旬。忉利诸天有善法堂。迳三十由旬。周回九十由旬。高四十五由旬。并琉璃所成。地皆柔滑。众宝填厕。譬如北地妙好氍毹。人非人等。龙兽草木。及诸杂花。莫不必备。亦如耳珰众宝庄严填满具足。善法妙堂。亦复如是。柔滑可爱。脚践便没。移足还起。种种庄严。具如前说。有三皮持之所围绕。一真金所成。二白银。三琉璃。其一一层。三重宝铃。微风吹动。出妙音声。譬如五分音乐。如前所说。多罗树声。能令众生起五欲缚。是堂中央众宝大柱。耸出堂上。其柱最顶。覆金露盘。种种庄严。并皆具足。是中央大柱。围一由旬。径三分之一。其一椽桷有十六柱。其一一柱。复十六柱之所围绕。一一椽桷。为二百七十二柱之所支持。其诸椽桷分为三分。一分有四千五十二周回。三分一万二千一百五十六椽桷。都有三十二亿六千四百三十二柱。是柱下至地。上不至桷。如一发许。或有一柱。上至于桷。下不至地。如一发许。以是义故。是善法堂。住在空中。不可了觉。四方门屋。一者。正东。二者。正西。三者。正南。四者。正北。是善法堂外。处处有大宝池。天水盈满四宝为塼。构垒底岸。金银琉璃。及颇梨柯之所成就。其池四边。亦以宝塼为其阶道。一一池中。有无量花。五宝所成。谓金银琉璃颇梨柯呵梨多。是诸池内。有四宝船。泛漾其中。复有八种水戏之具。一者。跳入水楼。二者。以七宝涵。注水灌身。三者。击水之具。以为音乐。四者。水溅以为嬉戏五水轮车。六者。浮屋。七者。宝轮鷿鶙。八者。绳楼自缒。旋回击荡。其中男女诸天乘船游戏。随心迟速。空中诸花自然来集。庄严天身。乃至多有诸天殿堂。皆悉遍满。亦复如是。是法堂外有大园林。金城围绕。周回一千由旬。城高一由旬。埤堄半由旬。其门高二由旬。十十由旬。有一一门。九十九门有一小门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如北地妙好氍毹。种种雕饰。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。亦如上说。及四宝船。亦如上说。池岸五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。是城外边三重宝堑。余如上说。一一堑者。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸淫女。堂殿罗列。三重堑外。七宝树林之所围绕。亦如上说。是时外林中。一切诸花。开敷鲜荣。诸女天等音乐讴歌。时诸天子从法堂城出。入是园中。相与观听。是中天子亦奏音乐时。诸女天从善法堂。出园观看。因如是事。男女诸天恒受戏乐。从其大城西北角门。取善法堂门。二十由旬。广十由旬。其地平滑。琉璃所成。可爱柔软众宝庄严。譬如北地妙好氍毹。人非人等。象马花树。种种具足。又如耳珰众宝合成。其路亦尔。脚履即没。举足便起。如兜罗绵及以木绵。其路柔软。亦复如是。三种皮持之所庄严。一一皮持。四宝所成。一一皮持。三层宝铃之所围绕。一一宝铃。四宝所成。微风吹动。出妙音声。能令诸天起五欲缚。是路两边夹二江水。名曰长形。亦长二十由旬。广十由旬。八功德水自然盈满。其江两边并四宝塼之所构治。余如前说。其江四边四宝阶道。亦如前说。是江水中有五宝花。亦如前说。四宝船。泛漾其内。八水戏具。乘船游戏。迟速任心。并如前说。是中诸天须彼花来。随念即至。善果报故。雨众宝花。洒散诸天。复有别风吹诸花鬘。随其身分。所须庄严。身臂首足。自然随着。二江外岸。五种宝树。罗列遍满。亦如前说。其树中间有诸宝池。及宝殿堂。诸男女天并于中住。无量无数。充满其中。是时忉利诸天欲入此园。其善法堂有风名曰合聚。聚集故花。吹令出外。其地净洁。无复萎花。复有别风。名曰剃刀。吹外园林及以池沼取诸新花。青黄赤白杂色之花。既取花已。时合聚风聚集此花。入法堂内。遍布其地。作诸形像。或现金银杖形。或现莲花形。或氍毹形。或羺羊形。或师子戏像。或现象马车步兵等像。或现獐鹿兽像。或现迦楼龙马之像。因此次第。周匝遍满善法堂地。花厚至膝。庄严具足。是时诸天围绕帝释。恭敬为尊。入此园裹。善法堂内最中柱边。有师子座。释提桓因升座而坐。左右二边。各十六天王行列而坐。其余诸天随其高下。依次而坐。时天帝释有二太子。一名栴檀。二名修毗罗。是忉利天二大将军。在三十二天。左右而坐。时题头赖吒天王依东门坐。共诸大臣及与军众。恭敬诸天。得入中坐。时毗留勒叉天王依南门坐。共诸大臣。及与军众。恭敬诸天。得入中坐。时毗留博叉天王依西门坐。共诸大臣。及与军众。恭敬诸天。得入中坐。时毗沙门天王依北门住。共诸大臣。及与军众。恭敬诸天。得入中坐。是四天王。于善法堂。世间善恶。奏闻帝释及忉利天。时佛世尊说如是事。比丘是月八日。是四天王大臣遍行世间。次第观察。当于今日。若多若少。一切诸人受持八戒。若多若少。皆行布施。若多若少。修福德行。若多若少。恭敬父母。及沙门婆罗门。家内尊长。比丘。月十四日。是四天王太子遍行世间。次第观察。当于今日。若多若少。一切诸人受持八戒。若多若少。皆行布施。若多若少。修行福德。若多若少。恭敬父母及沙门婆罗门家内尊长。比丘。月十五日。时四天王自行世间。次第观察。当于今日。若多若少。一切诸人受持八戒。若多若少。皆行布施。若多若少。修行福德。若多若少。恭敬父母及沙门婆罗门家内尊长。黑半亦如是。比丘。是时若无多人受持八戒。若无多人修行布施。若无多人修福德行。若无多人恭敬父母沙门婆罗门及家中尊长。比丘。时忉利天善法堂内政坐集时。尔时四王往法堂所。咨闻帝释。说世间事。白言。善尊。无多诸人受持八戒。无多诸人修行布施。无多诸人恭敬父母沙门婆罗门及家中尊长。是时忉利诸天及释提桓因闻此事已。生忧恼心。说如是言。是事非善。是事非如法。若诸人等无多受八戒。无多行布施无多修行福行。无多诸人恭敬父母沙门婆罗门及家中尊长。诸天眷属方应减少。修罗伴侣日向增多。比丘。若人多受持八戒。多修行布施。多修福行。多恭敬父母沙门婆罗门及家中尊长。尔时四王往法堂所。咨闻帝释。说世间事。白言。善尊。多有诸人受持八戒。多人修行布施。多人修行福行。多人恭敬父母沙门婆罗门及家中尊长。尔时忉利天闻四王言。心生欢喜。说如是言。是事甚善。是事如法。若诸人等多受持八戒。多修行布施。多行福行。多恭敬父母沙门婆罗门及家中尊长。诸天眷属日向滋多。修罗伴侣稍就减少。比丘。尔时释提桓因自坐之处。是天坐处。于中正坐。随从天心。令其欢喜。而说偈言

  是月初八日　　十四及十五
  并月二十三　　下九及三十
  三时十五斋　　受持八分戒
  静心所摄治　　若受持布萨
  是人修七法　　当来如我今

比丘。是释提桓因偈。是为邪歌。非是善歌。是为邪言。非是善言。云何如此。比丘。是释提桓因。未解脱生。未解脱老。未解脱死。未解脱忧。未解脱悲。未解脱苦。未解脱恼。未解脱五阴。比丘。若有比丘。成阿罗呵。灭尽诸漏。修道究竟。正智解脱。尽诸有结。如是比丘。若说此偈。是说善言

  是月初八日　　十四及十五
  并月二十三　　下九及三十
  三时十五斋　　受持八分戒
  静心所摄治　　若受持布萨
  是人修七法　　当来如我今

比丘。是比丘偈。乃是善歌。非是邪歌。乃是善言。非是邪言。云何如此。是比丘已解脱生。已解脱老。已解脱死。已解脱忧。已解脱悲。已解脱苦。已解脱恼。已解脱五阴。即说祇夜言

  是四王大臣　　八日巡天下
  四天王太子　　十四观世间
  十五时最胜　　四王好名闻
  故自行世间　　观察诸善恶
  是时四天王　　上善法堂所
  诸天大集会　　奏闻诸善恶
  是世间人意　　与道法相应
  善尊有多人　　行施受布萨
  伏真能修道　　男女福增益
  是时忉利天　　得信甚欢喜
  数数生随喜　　四大王善说
  诸天乐眷属　　转转得增多
  愿修罗伴侣　　日日就损减
  随忆念正觉　　法正说圣众
  诸天安乐住　　心常生欢喜
  世果出世果　　人道所能得
  若依佛法僧　　住于三宝境
  我今为汝等　　说三贤善道
  若人求真实　　舍恶修行善
  无有如是货　　由少能获多
  如诸忉利天　　行小善生天
  帝释等诸天　　大福德名闻
  聚集善法堂　　及诸余住处
  男女善行香　　四王所奏闻
  清净天所爱　　薰习遍诸天

是诸天子形色不同。衣服亦异。众宝庄严。种种差别。善法堂内。四色宝华。人华晃曜。互相映发。譬如宝舍满中众宝。其善法堂可爱如是。云何此堂说为善法。是诸天等聚集其中。多赞叹佛。多赞叹法。多赞叹僧。分别世间邪正之事。宣说种种出世之道。园等诸处。无如是事。故名其地。为善法堂。是事佛世尊说。如是我闻

立世阿毗昙论卷第二佛说立世阿毗昙论卷第三

        陈西印度三藏真谛译

    欢喜园品第九

善见大城北门之外。二十由旬。诸忉利天。有大园林。名曰欢喜。此中有池。亦名欢喜。方百由旬。深亦如是。天水盈满。四宝为塼垒其底岸。余如前说。四边宝阶。亦如前说。五种宝花。亦如前说。四种宝船。及八种戏。随心迟速。是中诸天须彼花时。应念来至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘。随其身分。所须庄严。身臂首足。自然随着。是其池岸。五种宝树。罗列遍满。余如前说。其树中间。及众宝堂殿。诸男女天。居止遍满。具如上说。园中有树。名曰欢喜。树所生花。名曼陀罗。其形大小。如天车轮。其色相貌。如火光焰。其花轻重。如人中花。欢喜树者。此园中有。余处皆无。此园周回一千由旬。迳三百三十三由旬。三分之一。金城之所围绕。是城高一由旬。埤堄一半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门足一百门。是诸门者。众宝所成摩尼妙宝之所庄严。譬如北地妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间。有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。亦如上说。及四宝船。亦如上说。池岸五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。是城外边。三重宝堑。余如上说。其一一堑。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女宫殿罗列。三重堑外。七宝树林之所围绕。亦如上说。是时外林中。一切诸花。开敷鲜荣。诸女天等音乐讴歌。时诸天子从欢喜园。出林观听。诸天子等于外林中。音乐讴歌。园内女天亦出观听。园内女天又奏音乐。外诸天子入园观听。园内天子亦奏音乐。园外女天亦入园听。以此因缘。受诸戏乐。从善见大城北门。至欢喜园南门。其中间路。二十由旬。广十由旬。并琉璃为地。平滑柔软众宝庄严。譬如北地妙好[毯-炎+瞿]毹。人非人像。鸟兽花草。种种具足。亦如耳珰众宝合成。其路形相。亦复如是。脚履即没。举足便起。如兜罗绵及以木绵。其路柔软。亦复如是。三种皮持之所严饰。一一皮持。四宝所成。一一皮持。三层宝铃之所围绕。一一宝铃。四宝所成。微风吹勤。出妙音声。能令诸天起五欲缚。是路两边。夹二江水。名曰长形。亦长二十由旬。广十由旬。八功德水自然盈满。其江两边。并四宝塼之所构成。余如前说。其江四边。四宝阶道。亦如前说。是江水中。有五种宝花。亦如前说。四种宝船。泛漾其内。八种水戏之具。乘船游观。迟速任心。并如前说。是中诸天须彼花来。随念即至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘随其身分。所须庄严。身臂首足。自然随着二江外岸。五种宝树。罗列遍满。余如前说。其树中间。有诸宝池。及宝殿堂。诸男女天并于中住。无量天众充满国土。云何此园名为欢喜。此园大池。名曰欢喜。其园有树。亦名欢喜。其花名曼陀罗。是三物者。唯此园有。余园则无。复何因缘名曰欢喜。尔时忉利诸天欲入此园。生大欢喜。最受戏乐。极相嬉乐。故曰欢喜。是义佛世尊说。如是我闻

    众车园品第十

善见大城东门阃外。去二十由旬。诸忉利天。有园名曰众车。园中大池。名质多罗。方百由旬。深亦如是。天水盈满。四宝为塼。垒其底岸。余如上说。四宝阶道。五种宝花。亦如上说。四种宝船。及八水戏。是中诸天须彼花时。应念来至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘。随其身分。所须庄严。身臂首足。自然随着。是其池岸。五种宝树。罗列遍满。余如前说。其树中间。及众宝堂殿。诸男女天。居止遍满。具如上说。是园周回。一千由旬。迳三分之一。金城之所围绕。是城高一由旬。埤堄一半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门。足一百门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如北地妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间。有诸宝池。相去百弓。种种庄严。亦如上说。五种宝华。亦如上说。及四宝船。亦如上说。池岸五种宝树。亦如上说。及四宝堂殿。诸男女天之所住处。是城外边。三重宝堑。余如上说。其一一堑。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女宫殿罗列。三重堑外。七宝树林之所围绕。亦如上说。是外林中。一切诸花。开敷鲜荣。诸女天等音乐讴歌。时诸天子从众车园。出林观听。诸天子等。于外林中。音乐讴歌。园内女天亦出观听。园内女天又奏音乐。外诸天子入园观听。园内天子亦奏音乐。园外女天亦入园听。以此因缘。受诸戏乐。从善见大城东门。至众车园西门。其中间路。二十由旬。广十由旬。并琉璃为地。平滑柔软。众宝庄严。譬如北地妙好毹毹。人非人像。鸟兽花草。种种具足。亦如耳珰众宝合成。其路形相。亦复如是。脚履即没。举足便起。如兜罗绵。及以木绵。其路柔软。亦复如是。三种皮持之所严饰。一一皮持。四宝所成。一一皮持。三层宝铃之所围绕。一一宝铃。四宝所成。微风吹动。出妙音声。能令诸天起五欲缚。是路两边。夹二江水。名曰长形。亦长二十由旬。广十由旬。八功德水自然盈满。其江两边。并四宝塼之所构成。余如前说。其江四边。四宝阶道。亦如前说。是江水中。有五种宝花。亦如前说。四种宝船。泛漾其内。八种水戏之具。乘船游观。迟速任心。并如前说。是中诸天须彼花来。随念即至。善果报故。雨众宝华。洒散诸天。复有别风。吹诸华鬘。随其身分。所须庄严。身臂手足。自然随着。二江外岸。五种宝树。罗列遍满。余如前说。其树中间。有诸宝池。及宝殿堂。诸男女天并于中住。无量天众充满国土。云何此园名曰众车。此中有大池。名质多罗。其中有树。亦名质多罗。此树生种种花。唯此园有。余园则无。复有因缘。名质多罗。是时忉利诸天欲入此园中。着种种宝物。庄严其身。微妙最极。着种种仗器。如临战时。乘种种乘。入此园林。在其园内。及欲出时。取质多罗树种种妙花。庄严车乘。辕枙毂辋。具足严饰。一切诸乘。并皆如是。此质多罗树花。及天身璎珞。诸宝车乘。所出光明。互相映发。以是因缘。此妙园中。种种光明。聚集其内。由此义故。名众车园。复有自然名众车园。是义佛世尊说。如是我闻

    恶口园品第十一

善见大城南门阃外。二十由旬。诸忉利天。有园名曰恶口。园中大池。名曰恶口。方百由旬。深亦如是。天水盈满。四宝为塼垒其底岸。余如上说。四宝阶道。五种宝花。亦如上说。四种宝船。及八水戏。是中诸天须彼花时。应念来至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘。随其身分。所须庄严。身臂手足。自然随着。是其池岸。五种宝树。罗列遍满。余如上说。其树中间。及众宝堂殿。诸男女天居止遍满。具如上说。是园周回。一千由旬。迳三分之一。金城之所围绕。是城高一由旬。埤堄一半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门。足一百门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如北地妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间。有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。亦如上说。及四宝船。亦如上说。池岸五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。是城外边。三重宝堑。余如上说。其一一堑者。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女宫殿罗列。三重堑外。七宝树林之所围绕。亦如上说。时外林中。一切诸花。开敷鲜荣。诸女天等音乐讴歌。时诸天子从恶口园。出林观听。诸天子等于外林中。音乐讴歌。园内女天亦出观听。园内女天又奏音乐。外诸天子入园观听。园内天子亦奏音乐。园外女天亦入园听。以此因缘。受诸戏乐。从善见大城南门。至恶口园北门。其中间路。二十由旬。广十由旬。并琉璃为地。平滑柔软。众宝庄严。譬如北地妙好[毯-炎+瞿]毹。人非人像。鸟兽花草。种种具足。亦如耳珰众宝合成。其路形相。亦复如是。脚履即没。举足便起。如兜罗绵。及以木绵。其路柔软。亦复如是。三种皮持之所严饰。一一皮持。四宝所成。一一皮持。三层宝铃之所围绕。一一宝铃。四宝所成。微风吹动。出妙音声。能令诸天起五欲缚。是路两边。夹二江水。名曰长形。亦长二十由旬。广十由旬。八功德水。自然盈满。其江两边。并四宝塼之所构治。余如前说。其江四边。四宝阶道。亦如前说。是江水中。有五种宝花。亦如前说。四种宝船。泛漾其内。八种水戏之具。乘船游观。迟速任心。并如前说。是中诸天须彼花来。随念即至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘。随其身分。所须庄严。身臂手足自然随着。二江外岸。五种宝树。罗列遍满。余如前说。其树中间。有诸宝池。及宝殿堂。诸男女天并于中住。无量大众充满国土。云何此园名为恶口。园有大池。名曰恶口。其中有树。亦名恶口。其树有花。亦名恶口。唯此园有。余处则无。复有因缘。名为恶口。是时忉利诸天欲入此园。作是斗诤。觉观思惟。我等今者往彼攻击。斗战修罗。复有彼此互相嫉妒。贪着五欲。诤其前后。因是事故。说诸恶言。是故此地名恶口园。复有自然名为恶口。是义佛世尊说。如是我闻

    杂园品第十二

善见大城西门阃外。至杂园东门。其中间路。长二十由旬。是诸忉利天园中有方池。名曰杂池。面百由旬。深亦如是。天水盈满。四宝为塼。垒其底岸。余如上说。四宝阶道。五种宝花。亦如上说。四种宝船。及八水戏。是中诸天须彼花时。应念来至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘。随其身分。所须庄严。身臂手足。自然随着。是其池岸。五种宝树。罗列遍满。余如前说。其树中间。及众宝堂殿。诸男女天居止遍满。具如上说。是园周回。一千由旬。径三分之一。金城之所围绕。是城高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门。足一百门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如北地妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外十重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间。有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。及四宝船。八水戏等。池岸五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。是城外边三重宝堑。余如上说。其一一堑。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如前说。是堑间地。有诸婇女宫殿罗列。三重堑外。七宝树林之所围绕。亦如上说。是时外林。一切诸花。开敷鲜荣。诸女天等音乐讴歌。时诸天子从杂园中。出林观听。诸天子等于外林中。音乐讴歌。园内女天亦出观听。园内女天又奏音乐。外诸天子入园观听。园内天子亦奏音乐。园外女天亦入园听。以此因缘。受诸戏乐。从善见大城西门。至杂园东门。其路二十由旬。广十由旬。并琉璃为地。平滑柔软。众宝庄严。譬如北地妙好[毯-炎+瞿]毹。人非人像。鸟兽花草。种种具足。亦如耳珰众宝合成。其路形相。亦复如是。脚履即没。举足便起。如兜罗绵。及以木绵。其路柔软。亦复如是。三种皮持之所严饰。一一皮持。四宝所成。一一皮持。三层宝铃之所围绕。一一宝铃。四宝所成。微风吹动。出妙音声。能令诸天起五欲缚。是路两边。夹二江水。名曰长形。亦长二十由旬。广十由旬。八功德水自然盈满。其江两边。并四宝塼之所构治。余如前说。其江四边。四宝阶道。亦如前说。是江水中。有五种宝花。亦如前说。四种宝船。泛漾其内。八种水戏之具。乘船游观。迟速任心。并如上说。是中诸天须彼花来。随念即至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘。随其身分。所须庄严。身臂首足。自然随着。二江外岸。五种宝树。罗列遍满。余如上说。其树中间。有诸宝池。及众宝殿堂。诸男女天并于中住。无量天众充满国土。云何此园名为杂园。因是园中有一大池。名曰杂池。亦有杂树。及诸杂花。唯此园有。余处则无。复有因缘。名为杂园。是时忉利诸男女天来入此园。最为杂聚。歌舞音乐。及众游戏。并相糅杂。余园集时。一切外边诸天并不得入。悉被禁断。此园集时。无有隔碍。大城诸天及诸外天入园游戏。相杂受乐。是故名曰杂园。复有自然名为杂园。是义佛世尊说。如是我闻

    波利夜多园品第十三

善见大城东北角门之外。二十由旬。诸忉利天。有大园林。名波利夜多。此园有方池。亦名波利夜多。面百由旬。深亦如是。天水盈满。四宝为塼。垒其底岸。余如前说。四边宝阶。亦如前说。五种宝花。亦如前说。四种宝船。及八种戏。随心迟速。是中诸天须彼花时。应念来至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘。随其身分。所须庄严。身臂手足。自然随着。其地岸上。五种宝树。罗列遍满。余如前说。其树中间。及众宝堂殿。诸男女天居止遍满。具如上说。园中有树。名波利夜多。亦名拘毗陀罗。是树生长具足。形容可爱。枝叶相覆。密厚多叶。久住不凋。一切风雨不能侵入。譬如装花鬘师。装饰花鬘。及以耳珰。其树形相。可爱如是。上如伞盖。次第相覆。高百由旬。下本洪直。都无瘤节。五十由旬。方有枝条。树身径刺。广五由旬。围十五由旬。其一一枝。横出五十由旬。间中亘度一百由旬。周回三百由旬。下有宝石。名曰班纣剑婆罗。长五十由旬。广十由旬。皆琉璃所成。软滑可爱。众宝庄严。譬如北地妙好[毯-炎+瞿]毹。种种雕镂。人非人像。鸟兽花草。种种具足。亦如耳珰众宝合成。是班纣剑婆罗。亦复如是。脚履即没。举足便起。如兜罗绵。及以木绵。是班纣剑婆罗。其体柔软。亦复如是。三种皮持之所严饰。一一皮持。四宝所成。一一皮持。三层宝铃之所围绕。一一宝铃。四宝所成。微风吹动。出妙音声。能令诸天起五欲缚。余如上说。四边阶道。金银琉璃颇梨所成。园中处处有池。亦如上说。乃至四宝堂殿。诸男女天之所住处。亦如上说。是园周回一千由旬。迳度三分之一。金城所绕。是城高一由旬。埤堄一半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门。足一百门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如北地妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间。有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。亦如上说。有四宝船。亦如上说。其池岸上。五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。是城外边。三重宝堑。余如上说。一一堑者。广二由旬。深一由旬半。形如壶口。下广上狭天水盈满。并如上说。是堑间地。有诸婇女宫殿罗列。三重堑外。七宝树林之所围绕。亦如上说。时外林中。一切诸花。开敷鲜荣。诸女天等音乐讴歌。时诸天子从波利夜多园。出林观听。诸天子等于外林中。音乐讴歌园内女天亦出观听园内女天又奏音乐。外诸天子入园观听。园内天子亦奏音乐。园外女天亦入园听。以此因缘。受诸戏乐。从善见大城东北角门。至园西南角门。其中间路。二十由旬。广十由旬。并琉璃为地。平滑柔软。众宝庄严。譬如北地妙好[毯-炎+瞿]毹。人非人像。鸟兽花草。种种具足。亦如耳珰众宝合成。其路形相。亦复如是。脚履即没。举足便起。如兜罗绵。及以木绵。其路柔软。亦复如是。三种皮持之所严饰。一一皮持。四宝所成。一一皮持。三层宝铃之所围绕。一一宝铃四宝所成。微风吹动。出妙音声。能令诸天起五欲缚。是路两边。夹二江水。名曰长形。亦长二十由旬。广十由旬。八功德水自然盈满。其江两边。并四宝塼之所构治。余如前说。其江四边。四宝阶道。亦如前说。是江水中。有五种宝花。亦如前说。四种宝船泛漾其内。八种水戏之具。乘船游观。迟速任心。并如前说。是中诸天须彼花来。随念即至。善果报故。雨众宝花。洒散诸天。复有别风。吹诸花鬘。随其身分。所须庄严。身臂手足。自然随着。二江外岸。五种宝树。罗列遍满。余如前说。其树中间。有诸宝池。及宝殿堂。诸男女天并于中住。无量天众充满国土。如是佛世尊说。比丘。尔时忉利天波利夜多拘毗陀罗树。叶黄欲落。是时诸天踊跃欢喜。作如是言。今时忉利波利夜多树。其叶转黄。不久凋落。比丘。是时忉利天波利夜多树。其叶落已。是时诸天踊跃欢喜。作如是言。诸天波利夜多树叶已落。不久生萌。比丘。是时忉利天波利夜多树。既生萌已。一切诸天踊跃欢喜。作如是言。今时波利夜多树。既生萌已。不久微现缥色。比丘。是时波利夜多树。现缥色已。诸天尔时欢喜踊跃。作如是言。波利夜多树。现缥色已。不久当出花莟。比丘。是时波利夜多树。出花莟已。诸天尔时欢喜踊跃。作如是言。波利夜多树。既出莟已。不久其花稍开。既稍开已。诸天尔时欢喜踊跃。作如是言。波利夜多树。既稍开已。不久当成一切开敷。比丘。是时波利夜多树。既开敷已。花色遍照五十由旬。其花妙香。亦薰五十由旬。若东风雨时。吹此树花。香薰西方。一百由旬。若西风雨时。吹此花香。薰于东方。一百由旬。若南风雨时。吹此花香。薰于北方。一百由旬。若北风雨时。吹此花香。薰于南方。一百由旬。比丘。如是忉利天波利夜多树。神力威德。比丘。若佛弟子。依如来所说正法律者。由信根故。离自居家。修无家道。为是事故起决定心。比丘。如是人者。譬如波利夜多树。其叶黄时比丘。是时佛弟子。剃除须发。被服法衣。离自居家。修无家道。比丘。如是人者。譬如波利夜多树。叶已落时。比丘。若佛弟子。离诸欲尘。离诸恶法。有觉有观。有喜有乐。从离生起。修习初禅。入此中住。比丘。如是人者。譬如波利夜多树。初生萌时。比丘。是时觉观已寂灭故。依内澄清心行一方便故。无觉无观。从定生起。有喜有乐。修习二禅。入此中住。比丘。如是人者。譬如波利夜多树。现缥色时。比丘。时佛弟子。离欲喜故。住于舍心。正念正智。其身受乐。是故圣师说如是教。若住于乐。有舍有念。修习三禅。入于中住。比丘。如是人者。譬如波利夜多树。生花莟时。比丘。若佛弟子。苦灭尽故。乐已过故。昔时忧喜已灭尽故。无苦无乐。舍念清净。修习四禅。入于中住。如是人者。譬如波利夜多树。花稍开时。比丘。若佛弟子。诸漏尽故。无漏心解脱。及般若解脱。现世已证。入此中住。其生已尽。修道究竟。众事已办。无复有生。故得此智。比丘。如是人者。譬如波利夜多树。一切开时。比丘。是诸比丘诸漏已尽。修道究竟。正慧解脱。有结已尽。忉利等天说赞叹言善友。彼处是人。ㄙ姓ㄙ名及ㄙ郡县一切国土。离自居家。修无家道。ㄙ名比丘。是出家弟子依止弟子诸漏尽故。无漏心解脱。及波若解脱。现世已证。入此中住。其生已尽。修道究竟。众事已办。无复有生。故得此智。是诸比丘。诸漏已尽。正智解脱。有法已尽如是神力。及是威德。譬如波利夜多树。是时忉利波利夜多树。一切开敷。复有诸天守护园者。往帝释所。白帝释言。天主。波利夜多树。悉开敷已。是故天尊应知时节。诸天复有象王。名伊罗槃。行园所乘。其身长九由旬。高三由旬。其形相称。尔时释提桓因。遣使报象言。善友。波利夜多树。一切开已。诸天当往到彼。入园游观。是故汝今当自装饰。象闻使言。踊跃欢喜。譬如诸人初求婚时。及迎妇时。一切吉祥希有之事。象王欢喜。亦复如是。尔时象王即化其头。为三十三。其一一头。各有六牙。其一一牙。有七宝池。其一一池。各生七莲。其一一莲。各生七花。其一一花。各生七叶。其一一叶。各七天女。如是妓女天。有七七重数。围绕莲子。显现可爱。以是因缘。众花庄严。皆悉具足。诸忉利天恭敬帝释。以为众首。前升象上。依中头坐。左右两边。各十六天。一切诸天各自思惟。我中头坐。若真实者。唯天帝释。独居中坐。三十三天。先登象已。其余天众次第并登。是天帝释有二太子。一名旃檀。二名修毗。为忉利天最大将军。亦升象上。诸妙女天。有最胜者。一名阿岚浮娑。二名蜜奢计尸。三名分陀利柯。四名尼罗。五名阿楼那。六名翳尼钵婆。七名修钵婆。八名钵陀罗。九名须跛陀罗。十名摩头柯婆致。如是女等亦升象上。复有男妙天。一名阿岚浮。二名达头楼眉。三名锐浮楼。四名尸弃。如是天等亦升象上。并在象上。歌奏音乐。一切诸天并升象已。是时象王踊跃欢喜。譬如诸王受灌顶职。亦如少壮临婚礼时。行正法竟。以诸妙花。庄严身首。象王欢喜。亦复如是。尔时象王作大雷声。降霔甘雨。并散电光。象王化作花上妓女。歌舞作乐。种种姿态。诸天妓女。及以伎男。歌舞作乐。是时象王作大雷声。驰游徐步。如结花鬘。如是三转。至波利夜多园。时忉利天从上俱下。上班纣剑摩罗宝石。若不周坐。石便更长。诸天福故。是阿夷罗婆那象王。更变化身。作天童子。着宝臂印。及宝耳珰。种种严具。受五欲尘。相应戏乐。有余天子别乘象马车舆楼阁。又有诸天乘众宝船。从长形江。随心速疾。入此园中。于其园内。歌人别处。舞人别处。弦管别处。大集别处。此中诸天用天四月。受五尘欲。具足相应游戏快乐。若准人中日月。一万二千年。天寿十年三分之一。园中用尽。忉利诸园此六最大。又有大小诸园。布满天上。此义佛世尊说。如是我闻

立世阿毗昙论卷第三佛说立世阿毗昙论卷第四

        陈西印度三藏真谛译

    提头赖吒城品第十四

须弥山王。凡有四顶。东西南北。其东顶者。真金所成。其西顶者。白银所成。其北顶者。琉璃所成。其南顶者。颇梨所成。复有一切众宝所成。复多七性。是四顶者。上广下狭。譬如莲芙。其最狭处。周围一千五百由旬。其最大处。迳七百由旬。周围二千一百由旬。是四顶处。多有诸兽。复有众鸟。师子虎豹。并悉化生。一切皆食天须陀味。不相残害。有金刚手。一切诸天依此中住。有四由乾陀山。一东二西三北四南。东由乾陀山。山有两顶。西北南。亦复如是。东二顶者。真金所成。西二顶者。白银所成。北二顶者。琉璃所成。南二顶者。颇梨所成。复有一切众宝所成。复有七性。上广下狭。状如莲芙。其最狭处。迳三百五十由旬。周围一千五十由旬。其最大处。迳五百由旬。周围一千五百由旬。是八顶处。多有诸兽。复有众鸟。师子虎豹。并悉化生。皆食天须陀味。不相残害。有金刚手。诸天依此中住。如是山山其顶两倍。乃至第七尼民陀山。则有五百一十二顶。是七山顶。高广向外。次第半减。东由乾陀山二顶中间。有一国土。名提头赖吒。周围一千由旬。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门。足一百门。是诸门者众宝所成。摩尼妙宝之所庄严。譬如妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间。有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。亦如上说。及四宝船。亦如上说。池岸五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。其城外边。三重宝堑。余如上说。一一堑者。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女宫殿罗列。三重堑外。七宝树林之所围绕。亦如上说。时外林中一切诸花开敷鲜荣。诸女天等奏诸音乐。时诸天子从大城出。观听音乐。诸女天等从大城出。观听音乐。以是因缘。受诸戏乐。提头赖吒城西南角。是提头赖吒天王之所住处。周围二百五十由旬。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。二十四大门。复一小门。足二十五门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如妙好[毯-炎+瞿]毹种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间。有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。亦如上说。及四宝船。亦如上说。池岸五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。其城外边。三重宝堑。余如上说。一一堑者。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女宫殿罗列。三重堑外。七宝树林之所围绕。亦如上说。时外林中一切诸花。开敷鲜荣。诸女天等奏诸音乐。时诸天子从城中出。观听音乐。诸女天等从城中出。观听音乐。以是因缘。受诸戏乐。是大城内四边住处。衢巷市廛。并皆调直。是诸天城。或有住处。四相应舍。或有住处。重层尖屋。或有住处。多层高楼。或有住处。台观云耸。或有住处。四周却敌。随其福德。众宝所成。平正端直。是天城路。其数五十。四陌相通。行列分明。皆如基道。四门通达。东西相见。巷巷市廛。宝货盈满。一谷米市。二衣服市。三众香市。四饮食市。五花鬘市。六工巧市。七淫女市。处处并有市官。是诸市中。天子天女。往来贸易。商量贵贱。求索增减。称量料数。具市廛法。虽作是事。以为戏乐。无取无与。无我所心。脱欲所须。便可提去。若业相应。随意而取。业不相应。便作是言。此物奇贵。非我所须。当四衢道。象马车兵之所庄严。及诸天子止住其中。或为守护。或为戏乐。或为庄严。市中间路。一切琉璃。软滑可爱。众宝庄严。亦如北地妙好[毯-炎+瞿]毹。龙兽花草。皆如前说。乃至烧香散花。悬诸天衣。亦复如是。复于处处。竖立幡幢。天大城内。如是等声。恒无断绝。所谓象声。马声。车声。螺声。波那婆声。鼓声。牟澄伽声。笳声。音乐声。又有声言。善来善来。愿食愿饮。我今供养。是提头赖吒大城。是天子住处。复有天州天郡天县天村。周匝遍布此大城中。提头赖吒天王。依此中住。王领所极。从由乾陀山东。至铁围山乾闼婆天。是王所领。如是义者。是佛所说。如是我闻

    毗留勒叉城品第十五

南由乾陀山二顶中间。有一国土。名毗留勒叉。周围一千由旬。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门。足一百门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。亦如上说。及四宝船。亦如上说。池岸五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。其城外边。三重宝堑。余如上说。一一堑者。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女宫殿罗列。三重堑外。七宝树林之所围绕。亦如上说时外林中。一切诸花。开敷鲜荣。诸女天等奏诸音乐。时诸天子从大城出。观听音乐。诸女天等从大城出。观听音乐。以是因缘。受诸戏乐。毗留勒叉城西南角。是毗留勒叉天王之所住处。周围二百五十由旬。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。二十四大门复一小门。足二十五门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。亦如上说。七重多罗树林之所围绕。亦如上说。其树中间。有诸宝池。相去百弓。种种庄严。亦如上说。五种宝花。亦如上说。及四宝船。亦如上说。池岸五种宝树。亦如上说。乃至四宝堂殿。诸男女天之所住处。其城外边三重宝堑。余如上说。一一宝堑。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女。宫殿罗列三重堑外。七宝树林之所围绕。亦如上说。时外林中。一切诸花。开敷鲜荣。诸女天等奏诸音乐。时诸天子从城中出。观听音乐。诸女天等从城中出。观听音乐。以是因缘。受诸戏乐。是大城内四边住处。衢巷市廛。并皆调直。是诸天城。或有住处。四相应舍。或有住处。重层尖屋。或有住处。多层高楼。或有住处。台观云耸。或有住处。四周却敌。随其福德。众宝所成。平正端直。是天城路。其数五十。四陌相通。行列分明。皆如基道。四门通达。东西相见。巷巷市廛。宝货盈满。一谷米市。二衣服市。三众香市。四饮食市。五花鬘市。六工巧市。七淫女市。处处并有市官。是诸市中。天子天女。往来贸易。商量贵贱。求索增减。称量料数。具市廛法。虽作是事。以为戏乐。无取无与。无我所心。脱欲所须。便可提去。若业相应。随意而取。业不相应。便作是言。此物奇贵。非我所须。当四衢道。象马车兵之所庄严。及诸天子止住其中。或为守护。或为戏乐。或为庄严。市中间路。一切琉璃。软滑可爱。众宝庄严。亦如北地妙好[毯-炎+瞿]毹。龙兽花草。皆如前说。乃至烧香散花。悬诸天衣。亦复如是。复于处处。竖立幡幢。天大城内。如是等声。恒无断绝。所谓象声。马声。车声。螺声。波那婆声。鼓声。牟澄伽声。笳声。音乐声。又有声言。善来善来。愿食愿饮。我今供养。是毗留勒叉大城。是天子住处。复有天州天郡天县天村。周匝遍布此大城中。毗楼勒叉天王。依此中住。王领所极。从由乾陀山南。至铁围山拘槃荼神。是王所领。如是义者。佛世尊说。如是我闻

    毗留博叉城品第十六

西由乾陀山有二顶。中间有国。名毗留博叉。周围一千由旬。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门。足一百门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。并如上说。外七重宝栅。七重多罗树之所围绕。其林中间。有诸宝池。相去百弓。种种庄严。五种宝花。及四宝船。池岸五种宝树。乃至四宝堂殿。诸男女天之所住处。皆如上说。其城外边。有三重宝堑。其一一堑。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女堂殿罗列。三重堑外。七宝树林之所围绕。亦如上说。时外林中。一切诸花。开敷鲜荣。诸女天等奏诸音乐。时诸天子从大城出观听音乐。诸女天等从大城出。观听音乐。以是因缘。受诸戏乐。城西南角。是毗留博叉天王之所住处。周围二百五十由旬。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。二十四大门。复一小门。足二十五门。如是诸门。皆众宝所成。摩尼妙宝之所庄严。譬如妙好[毯-炎+瞿]毹。种种雕镂。是门又有四军防卫。外有七重宝栅。七重宝多罗林之所围绕。其树中间。有诸宝池。相去百弓。种种庄严。五种宝花。及四宝船。池岸五种宝树。乃至四宝堂殿。诸男女天之所住处。皆如上说。其城外有三重宝堑。其一一堑。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女堂殿罗列。三重堑外。七宝树林之所围绕。皆如上说。是外林中。一切诸花。开敷鲜荣。诸女天等奏诸音乐。时诸天子从城中出。并诸女天并共观听。以是因缘。受诸戏乐。是大城内。四边住处。衢巷市廛。并皆调直。是诸天城。或有住处。四相应舍。或有住处。重层尖屋。或有住处。多层高楼。或有住处。台观云耸。或有住处。四周却敌。随其福德。众宝所成。平正端直。是天城路。其数五十。四陌相通。行列分明。皆如基道。四门通达。东西相见。巷巷市廛。宝货盈满。一谷米市。二衣服市。三众香市。四饮食市。五花鬘市。六工巧市。七淫女市。处处并有市官。是诸市中。天子天女。往来贸易。商量贵贱。求索增减。称量料数。具市廛法。虽作此事。以为戏乐。无取无与。无我所心。脱欲所须。便可提去。若业相应。随意而取。业不相应。便作是言。此物奇贵。非我所须。当四衢道。象马车兵之所庄严。及诸天子止住其中。或为守护。或为戏乐。或为庄严。市中间路。一切琉璃。软滑可爱。众宝庄严。亦如北地妙好[毯-炎+瞿]毹。龙兽花草。皆如前说。乃至烧香散花。悬诸天衣。亦复如是。复于处处。竖立幡幢。天大城内。如是等声。恒无断绝。所谓象声。马声。车声。螺声。波那婆声。鼓声。牟澄伽声。笳声。音乐声。又有声言。善来善来。愿食愿饮。我今供养。是毗留博叉大城。是天子住处。复有天州天郡天县天村。周匝遍布此大城中。毗留博叉天王依此中住王领所极。从由乾陀山西。至铁围边一切诸龙伽楼罗鸟。是王所领。如是义者。佛世尊说。如是我闻

    毗沙门城品第十七

北由乾陀山有二顶。中间有国。名毗沙门。周围一千由旬。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。九十九门。复一小门。足一百门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如妙好[毯-炎+瞿]毹种种雕镂。是门又有四军防卫。外有七重宝栅。七重多罗树之所围绕。其林中间。有诸宝池。相去百弓。种种庄严。五种宝花。及四宝船。池岸五种宝树。乃至四宝堂殿。诸男女天之所住处。并如上说。其城外边。有三重宝堑。其一一堑。广二由旬。深一由旬半。形如壶口。下广上狭。天水盈满。并如上说。是堑间地。有诸婇女堂殿罗列。三重堑外。七宝树林之所围绕。皆如上说。是时外林。一切诸花。开敷鲜荣。诸女天等奏诸音乐。时诸天子从大城出。观听音乐。诸女天等从大城出。亦听音乐。以是因缘。受诸戏乐。城西南角。是毗沙门天王之所住处。周围二百五十由旬。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。二十四大门。复一小门。足二十五门。是诸门者。众宝所成。摩尼妙宝之所庄严。譬如妙好[毯-炎+瞿]毹种种雕镂。是门又有四军防卫。外有七重宝栅。七重宝多罗树林之所围绕。其林中间。有诸宝池。相去百弓。种种庄严。五种宝花。及四宝船。池岸五种宝树。四宝堂殿。诸男女天之所住处。皆如上说。其城外有三重宝堑。其一一堑。广二由旬。深一由旬半。天水盈满。并如上说。是堑间地。有诸婇女堂殿罗列。三重堑外。七宝树林之所围绕。皆如上说。时外林中一切诸花。开敷鲜荣。诸女天等奏诸音乐。时诸天子从城中出。并诸女天并共观听。以是因缘。受诸戏乐。是大城内四边住处。衢巷市廛。并皆调直。是诸天城。或有住处。四相应舍。或有重层尖屋。或有多层高楼。或有台观云耸。或有四周却敌。随其福德业。众宝所成。平正端直。是天城路。其数五十。四陌相通。行列分明。皆如基道。四门通达。东西相见。巷巷市廛。宝货盈满。一谷米市。二衣服市。三众香市。四饮食市。五花鬘市。六工巧市。七淫女市。处处并有市官。是诸市中。天子天女。往来贸易。商量贵贱。求索增减。称量料数。具市廛法。虽作此事。以为戏乐。无取无与。无我所心。脱欲所须。便可提去。若业相应。随意而取。业不相应。便作是言。此物奇贵。非我所须。当四衢道。象马车兵之所庄严。及诸天子止住此处。或为守护戏乐庄严。市中间路。一切琉璃。软滑可爱。众宝庄严。亦如北地妙好[毯-炎+瞿]毹。龙兽花草。皆如上说。烧香散华。悬诸天衣。亦复如是。复于处处。竖立幡幢。天大城内。如是等声。恒无断绝。所谓象马车螺等声。波那婆声。鼓声。牟澄伽声。笳声。音乐声。又有声言。善来善来。愿饮愿食。我今供养。是毗沙门大城。是天子住处。复有天洲天郡天县天村。周匝遍布此大城中。毗沙门天王之所住处。王领所极。从由乾陀北。至铁围边一切夜叉神。是王所领。是毗沙门城最饶多佉陀尼蒲阇尼饮食。是故亦名阿罗珂漫陀。如是义者。佛世尊说。如是我闻

立世阿毗昙论卷第四佛说立世阿毗昙论卷第五

        陈西印度三藏真谛译

    天非天斗战品第十八

须弥山王上顶平地。琉璃所成。软滑可爱。众宝庄严。譬如北地妙好[毯-炎+瞿]毹。种种雕镂。亦如耳珰众宝庄饰。脚践便没。举足即起。如兜罗绵。其地柔软。亦复如是。金城围绕。高一由旬。埤堄高半由旬。城门高二由旬。门楼一由旬半。十十由旬。有一一门。三万二千门。是诸城门。众宝所成。种种摩尼之所严饰。譬如北地妙好[毯-炎+瞿]毹。人非人等。龙兽草木。及诸杂花莫不必备。亦如耳珰众宝庄严。填满具足。是诸城门。亦复如是。诸门边。象马车军之所庄严。是诸天子庄严铠仗。聚集其中。为护国土游戏庄严。处处宝池。天水盈满。四宝为塼。垒其底岸。余如上说。乃至诸天男女遍满其中。亦复如是。须弥山王。从其上顶。向下二万由旬。是第一层。是层四出。并五十由旬。周回增本四百由旬。金城围绕。高一由旬。埤堄一由旬半。城门高二由旬。门楼一由旬半。十十由旬。有一一门。无数千门。众宝所成。种种摩尼之所严饰。譬如北地妙好[毯-炎+瞿]毹。人非人等。龙兽草木。及诸杂花。莫不必备。亦如耳珰众宝具足。是诸城门。亦复如是。诸城门边。象马四军之所防卫。为护国土游戏庄严。其城外边。有诸宝池。四宝为塼。垒其底岸。乃至天子天女遍满国土。亦复如是。有诸天子。名曰持鬘。于此中住。是须弥山本周围数。更增四百由旬。合本八百由旬。从顶向下。四万由旬。是第二层。四出并广上层。五十由旬。金城围绕。高一由旬。埤堄一由旬半。城门高二由旬。门楼一由旬半。十十由旬。有一一门。无数千门。众宝所成。种种摩尼之所严饰。譬如北地妙好[毯-炎+瞿]毹。人非人等。龙兽草木。及诸杂花。莫不必备。亦如耳珰众宝具足。是诸城门。亦复如是。诸城门边。象马四军之所防卫。为护国土游戏庄严。有诸宝池。四宝为塼。垒其底岸。乃至诸天子等遍满国土。亦复如是。有诸天子。名曰常胜。于此中住。须弥山王本周围数。更增八百由旬。合本一千二百由旬。从顶向下。六万由旬。是第三层。四出并广二层。五十由旬。金城围绕。高一由旬。埤堄一由旬半。城门高二由旬。门楼一由旬半。十十由旬。有一一门。无数千门。众宝所成。种种摩尼之所严饰。譬如北地妙好[毯-炎+瞿]毹。人非人等。龙兽草木。及诸杂花。莫不必备。亦如耳珰众宝具足。是诸城门。亦复如是。诸城门边。象马四军之所防卫。亦护国土游戏庄严。有诸宝池。四宝为塼。垒其底岸。乃至诸天子等遍满国土。亦复如是。有诸天子。名手持宝器。于此中住。金城围绕。种种庄严。亦如上说。乃至诸天子等遍满国土。亦复如是。须弥山王本周围数。更增四百由旬。合本一千六百由旬。是第四层。广上三层。四出并五十由旬。从海水际。向上五十由旬。是须弥山王第四层。广第三层。五十由旬。厚亦如此。金城围绕。高一由旬。埤堄一由旬半。城门高二由旬。门楼一由旬半。十十由旬。有一一门。无数千门。众宝所成。种种摩尼之所严饰。譬如北地妙好[毯-炎+瞿]毹。人非人等。龙兽草木。及诸杂华。莫不必备。亦如耳珰众宝具足。是诸城门。亦复如是。诸城门边。象马四军之所防卫。为护国土游戏庄严。有诸宝池。四宝为塼。垒其底岸。乃至诸天子等遍满国土。亦复如是。此第四层。四天王军之所住处。是层之外。又出四百五十由旬。周回一千八百由旬。有诸龙及金翅鸟之所住处。须弥山王上下诸层。并厚五十由旬。其海中诸层。悉是修罗住处。此阿修罗为得诸天五事因缘。故往攻伐。何者为五。一天须陀味。二诸天平地。三天诸园林。四诸天国邑。五诸天童女。为是五事。往击诸天。诸天亦欲得彼五事。往击修罗。何者为五。一阿修罗须陀味。二修罗平地。三修罗园林。四修罗国邑。五修罗童女。为是五事。往击修罗。是时修罗来击诸天。先于水际。与龙鸟斗。若不如时便退还本。若战胜时。登最下层。共四王军。及诸龙鸟。亦登此层。一时共斗。修罗不如。更退还本。若战胜时。登下二层。与四王军。及持宝器天。诸龙鸟等。一时共斗。若不如时。便退还本。若战胜者。登下三层。与常胜天。及持宝器。并四王军诸龙鸟等。一时共斗。若不如时。便退还本。若战胜时。登下四层。与持鬘天。及下诸天。若四王军。诸龙鸟等。一时共斗。若不如者。从此还本。若战胜时。登须弥上顶。是持鬘诸天往帝释所。报如是事。善尊。阿修罗已来。是时帝释以一千马。驾其一车。以阿罗汉衣。为其幡帜。象马四兵不相参杂。众军围绕。出往战所。时三十二天王。亦各皆有四部军众之所围绕。亦到战所。王二太子栴檀须毗。亦有四军之所围绕。同往战所。时四天王。亦有四军之所围绕。同往战所。日月天子。亦有四军之所围绕。同往战所。如是诸天并前车将军。于是处所。与修罗起大斗战。其象军者。与象军斗。车马步军。例皆如是。若斗战时。其先来者。必自前退。是事法然。如是事者。佛世尊说。比丘。往昔诸天共攻修罗。正斗战时。两军交刃。诸天军胜。修罗退散。比丘。修罗退时。面向南走。还其本住。诸天逐退。比丘。尔时修罗作是思惟。诸天大胜。我等退散。诸天逐退必急。我军尚可须更决战。第二战时。诸天大胜。修罗又退。是时修罗面向南走。还其本住。诸天逐退。比丘是时。修罗更复思惟。诸天大胜。我等退散。诸天逐退必急。我今军众未尽。必须更决。比丘。第三战时。诸天又胜。修罗退散。还至本城。闭门而住。比丘。是时修罗更复思惟。我已入城。诸天虽来。不能攻我。比丘。诸天亦作是念。诸阿修罗既入其城。不可复攻。是时诸天周匝围绕。令其境界止在城内。诸天遂得食修罗须陀之味。据其平地。及诸园林。并其国邑诸童女等。悉皆系录。取其财宝。男女户口。收缚无遗。若诸天作意。欲入彼城。我与修罗。同共饮食。既为亲戚。应往讯觐随意往返。饮食言谈。既入城已。若作不相应心。以是心故。自然还出。云何如是。此城是阿修罗无畏处故。诸天如意。住此国土。修罗童女既被缚录。若欲去时。将还天上。时诸修罗裹须陀味。往赎家口。入诸天城。处处访问。若见眷属。与诸天等。论价贵贱。若赎得相随还本。若诸天退败。被执缚时。亦复如是。忉利天上善见大城。释提桓因之所住处。阿修罗城。是阿修罗王之所住处。如忉利天伊罗槃行园象王。如是阿修罗亦有象王。名跋陀婆呵乘行园林。如忉利天善柱象王斗战所乘。如是阿修罗鸦罗婆象王斗战所乘。如忉利天州郡县等。修罗境界。亦复如是。如忉利天衣服饮食。种种庄严。修罗亦尔。除善法堂。及皮禅延多重阁。如是义者。佛世尊说。如是我闻

    日月行品第十九

从剡浮提地。高四万由旬。是处日月行半须弥山等游乾陀山。是日月宫殿。团圆如鼓。是月宫者。厚五十由旬。广五十由旬。周回一百五十由旬。是月宫殿。琉璃所成。白银所覆。水大分多。下际水分。复为最多。其下际光。亦为最胜。是其上际。金城围绕。城高一由旬。埤堄高半由旬。城门二由旬。门楼一由旬半。十十由旬。有一一门。凡十四门。并一小门。是诸城门。众宝所成种种摩尼之所严饰。譬如北地妙好[毯-炎+瞿]毹。人非人等。龙兽草木。及诸杂花。莫不必备。亦如耳珰众宝庄严。填满具足。是诸城门。亦复如是。是城门边。象车四军之所庄严。是诸天子庄严铠仗。聚集其中。为护国土。及游戏庄严。处处宝池。天水盈满。四宝为塼。垒其底岸。余如上说。乃至诸天男女遍满其中。亦复如是。是宫殿者。说名栴檀。是月天子。于其中住。亦名栴檀。宫殿天子。悉名栴檀。如是宫殿。住四十余劫。已众生业增上缘故。恒行光照。天子在时。宫殿恒行。天若不在。宫殿亦行。天子还时。随宫所在。即下其中。是日宫者。厚五十一由旬。广五十一由旬。周回一百五十三由旬。是日宫殿。颇梨所成。赤金所覆。火大分多。下际火分。复为最多。其下际光。亦为最胜。是其上际。金城围绕。城高一由旬。埤堄高半由旬。城门二由旬。门楼一由旬半。十十由旬。有一一门。有十四门。并一小门。是诸城门。众宝所成。种种摩尼之所严饰。譬如北地妙好[毯-炎+瞿]毹。人非人等。龙兽草木。及诸杂花。莫不必备。亦如耳珰众宝庄严。填满具足。是诸城门。亦复如是。是城门边。象车四军之所防卫。为护国土。及庄严游戏。处处宝池。天水盈满。四宝为塼。垒其底岸。余如上说。乃至诸天男女遍满其中。亦复如是。是宫殿说名修野。是日天子于其中住。亦名修野。宫殿天子。悉名修野。是宫殿住四十余劫。以众生业增上缘故。恒行光照。天子在时。宫殿恒行。天若不在。宫殿亦行。天子还时。随宫所在。即下其中。其星宫殿。极最小者。迳半俱卢舍。周回广一俱卢舍半。其星大者。迳十六由旬。周回四十八由旬。日月之前。有行乐天子。是天子者。若游行时。则受戏乐。以众生业增上缘故。故有风轮恒吹回转。以风吹故。日月等宫。回转不息。日宫殿者。行一百八十路。月宫殿者。行十五路。日十二路。是月一路。若日出入时。十二日所行路。月出入时。一日行之得度。从极南路。至极北路。二百九十由旬。日月于是中行。无有减长。日复有两路。一者外路。二者内路。内路者。从剡浮路内。至北郁单越内路。相去四亿八万八百由旬。周回十四亿四万二千四百由旬。其外路者。相去四亿八万一千三百八十由旬。周回十四亿四万四千一百四十由旬。其月行者。傍行则疾。周行则迟。其日行者。周行则疾。傍行则迟。日行与月。或合或离。一一日中。日行四万八千八十由旬。合离皆尔。若稍合时。日日覆月三由旬。又一由旬三分之一。以是方便故。十五日一切被覆。月光不现。若稍离时。日日日行。四万八千八十由旬。是日离月三由旬。又一由旬三分之一。以是方便故。十五日月大圆明。如是数量。日行周围。疾速于月。四万八千八十由旬。尔时世尊重宣此义。而说偈言

  四万有八千　　八十诸由旬
  日逐月行尔　　离月量亦然

日恒行一由旬半。又一由旬九分之一。其一一日出时如是。入亦如是。六月日中从内路出。至于外路。六月日从外路入至内路。月恒行十九由旬。又一由旬三分之一。其一一日出亦如是。入亦如是。十五日从内路至外路。十五日从外路至内路。日若行东弗婆提内路。取东弗婆提地南际。相去六百八十三由旬。又一由旬三分之一。是中日行内路。日若行剡浮提内路。取剡浮提地南际。相去三百五十由旬。是中日行内路。日若行西瞿耶尼内路。取西瞿耶尼地南际。相去六百八十三由旬。又一由旬三分之一。是中日行内路。日若行北郁单越内路。取北郁单越地南际。相去三百五十由旬。是中日行内路。日若行东弗婆提外路。从地南际。取日外路。三百九十三由旬。又一由旬三分之一。日于中行。若日行剡浮提外路。从地南际。至日外路。六十由旬。是中日行外路。若日行西瞿耶尼外路。取地南际。至日外路。三百九十三由旬。又一由旬三分之一。是中日行。若日行北郁单越外路。取地南际。六十由旬。是中日行。若日行东弗婆提内路。则行西瞿耶尼外路。则行南剡浮提北郁单越中路。是时东弗婆提日最长。十八牟休多。是时夜最短。十二牟休多。西瞿耶尼夜最长。十八牟休多。日最短十二牟休多。剡浮提北郁单越。日夜等分。并十五牟休多。其六牟休多恒动。二十四牟休多不动。若日行东弗婆提外路。则行西瞿耶尼内路。则行南剡浮提北郁单越中路。是时东弗婆提夜最长十八牟休多。日最短十二牟休多。西瞿耶尼日最长十八牟休多。夜最短十二牟休多。南剡浮提北郁单越等分。日夜并十五牟休多。若日行剡浮提内路。则行北郁单越外路。则行东弗婆提西瞿耶尼中路。是剡浮提日最长十八牟休多。夜最短十二牟休多。北郁单越夜最长十八牟休多。日最短十二牟休多。东弗婆提西瞿耶尼日夜等分。并十五牟休多。日若行南剡浮提外路。则行北郁单越内路。则行东弗婆提西瞿耶尼中路。是时剡浮提夜最长十八牟休多。日最短十二牟休多。北郁单越日最长十八牟休多。夜最短十二牟休多。东弗婆提西瞿耶尼日夜等分。并十五牟休多。西瞿耶尼北郁单越并如是说。若世间中三十牟休多。决定恒为一日夜。其一牟休多。有三十分。是一一分。名曰罗婆。日若增时。日一罗婆。日若减。亦一罗婆。夜亦如是。若日减时。夜增一罗婆。若夜减时。日增一罗婆。若日最长。十八牟休多。是时夜则最短。十二牟休多。若夜最长。十八牟休多。是时日则最短。十二牟休多。若日夜等时。日十五牟休多。夜十五牟休多。若五月十五日正圆满。西国始结夏时。汉地安居。已满一月。是时日则最长。十八牟休多。夜则最短。十二牟休多。从十六日。减一罗婆。月减一牟休多。第二月又减一牟休多。第三月又减一牟休多。至八月十五日西国自恣时。汉地受迦絺那衣时。日夜平等。各十五牟休多。又从十六日。乃至一月。复减一牟休多。第二月减一牟休多。第三月又减一牟休多。至十一月十五日。其夜最长。十八牟休多。其日最短。十二牟休多。是夜从此时。日减一罗婆。一月日则夜减一牟休多。第二月。又减一牟休多。第三月又减一牟休多。至二月十五。日夜平等。各十五牟休多。又从十六日。乃至一月。复减一牟休多。第二月复减一牟休多。第三月复减一牟林多。至五月十五日。其日最长。十八牟休多。其夜最短。十二牟休多。复有别时。若西国夏分。第一月月中第二半第九日。是为六月九日。是时日最长。十八牟休多。夜最短十二牟休多。至九月九日。日夜平等各十五牟休多。十一月九日。是夜最长。十八牟休多。日最短。十二牟休多。三月九日。日夜平等。各十五牟休多。如此回转。具足五年。有一游伽。即两闰月。其一从月。其二从日。五年中间。十二日。又九日。又六日。又三日。又十五日。此中日夜。是其长短。月者分别三用。一者分别月。二分别十五日。三分别圆满。日者分别夜日。分别夏冬秋节。分别年。是三用从日得成。闰月有两者。一从月。二从日。是闰月者。从月所作。四月日应作两小月。一小月者。是第三半中。第二小月。是第七半中。一年之中。应六小月。五年足少三十日。此三十日。应补五年中。若不作小月。则月圆不当时。是小月者。从日所作。依世间说。以三十牟休多。决定是一日夜。分三十牟休多。为六十分。日行疾故。五十九分便周。长余一分。因是事故。二月则长一日。又二月复长一日。乃至一年。足长六日。如是五年。则长一月。用是一月。补五年中。是为日家闰月。若不作闰者。时节及年。差坏不当。复次五年应两闰月。第一者。在第三年。第二者。在第五年。若月在剡浮提中。更三月。日至瞿耶尼。若北郁单越。则六月日。东弗婆提。则九月日。若周一年。还至剡浮提。一天下中。恒有夏冬春三时。夏者为春所随。冬者为夏所随。春者为冬所随。东弗婆提八月十五日自恣时。剡浮提是五月十五结夏时。西瞿耶尼二月十五。北郁单越十一月十五日。东弗婆提夏分三月已出。在东弗婆提南剡浮提二洲中间。西瞿耶尼春分三月未出。在剡浮提瞿耶尼二洲中间。瞿耶尼春一月已出。郁单越冬分二月未出。是为三月在瞿耶尼郁单越二洲中间。郁单越冬分二月已出。弗婆提夏分一月未入。是为三月在郁单越弗婆提二洲中间。须弥山王。在四天下之中央。云何须弥山在四天下北边。所谓随日行分判。东弗婆提东方。是剡浮提北方。东弗婆提西方。是南剡浮提南方。东弗婆提北方。是剡浮提西方。东弗婆提南方。是剡浮提东方。北郁单越。西瞿耶尼。亦复如是。南剡浮提。北郁单越正对。东弗婆提西瞿耶尼正对。是时最初日月下生世间。相去甚远。日下东弗婆提中央。月下西瞿耶尼中央。尔时光明遍照。满四天下。日照一半。月照一半。若日已过东弗婆提中央。北郁单越日已没。南剡浮提日已出。若月已过西瞿耶尼中央。剡浮提已没。郁单越已出。若满月夜已至。郁单越月正中时。南剡浮提日则正中。日过剡浮提中。东弗婆提已没。西瞿耶尼已出。若月过北郁单越中央。东弗婆提已出。西瞿耶尼已没。东弗婆提若满月夜。月正中时。西瞿耶尼日则正中。日过西瞿耶尼中央。剡浮提已没。郁单越已出。若月过东弗婆提中央。郁单越已没。剡浮提已出。剡浮提满月夜。月正中时。北郁单越。日则正中。云何日月合在一处。谓日恒逐月行。一一日相近。四万八千八十由旬。日日相离。亦复如是。若相近时。日日月圆被覆三由旬。又一由旬三分之一。以是事故。十五日月被覆则尽。是名黑半满。日日离月。亦四万八千八十由旬。月日日开覆三由旬。又一由旬三分之一。以是事故。十五日月则开净圆满。世间则名白半满。日月若最相离行。是时月圆。世间则说白半圆满。日月若共一处是合行。世间则曰黑半圆满。日光经度。七亿二万一千二百由旬。周回二十一亿六万三千六百由旬。剡浮提日出时。郁单越日没时。东弗婆提正中。西瞿耶尼正夜。是一天下四时。由日得成。如是义者。佛世尊说。如是我闻

立世阿毗昙论卷第五佛说立世阿毗昙论卷第六

        陈西印度三藏真谛译

    云何品第二十

云何为夜。云何为昼。因日故夜。因日故昼。欲界者自性黑暗。日光隐故是则为夜。日光显故是则为昼。云何黑半。云何白半。由日黑半。由日白半。日恒逐月行一一日相近。四万八千八十由旬。日日相离亦复如是。若相近时日日月圆被覆三由旬。又一由旬三分之一。以是事故十五日月被覆则昼是日黑半满。日日离月亦四万八千八十由旬月日日开三由旬。又一由旬三分之一。以是事故十五日月则开净圆满。世间则名白半圆满日月。若最相离行是时月圆。世间则说白半圆满日月。若共一处是名合行。世间则日黑半圆满。若日随月后行日光照月光。月光粗故被照生影。此月影还自翳月。是故见月后分不圆。以是事故渐渐掩覆。至十五日覆月都尽。随后行时是名黑半。若日在月前行。日日开净。亦复如是。至十五日具足圆满。在前行时是名白半。云何冬时说醯曼多。此时雪应落寒已至故。是故冬时说名醯曼多。世间立此自性名醯曼多。云何春时名曰禽河。日照炙时是正热时正是渴时。故说春时名为禽河。世间立此自性名为禽河。云何夏时名为跋娑。是天雨时是疑雨时是年初时。是故说夏名曰跋娑。世间自性立名跋娑。云何冬寒。云何春热。云何夏时寒热。是冬时水界最长未减尽时。草木由湿未萎干时。地大湿滑火大向下水气上升。所以知然。深水最暖。浅水则寒。寒节已至日行外路照炙不久。阳气在内食消则速。以是事故冬时则寒。云何春热。是禽河时水界长起。已减已尽草木干萎地已燥坼。水气向下火气上升。何以知然。深水则冷。浅水则热。冬时已过日行内路照炙则久。身内火羸故春时热。云何夏时冷热。是大地八月日中恒受照炙。大云降雨之所洒散地气蒸郁。若风吹时蒸气消已是时则寒。风若不起是时即热。是故跋娑有时寒热。云何地狱名泥犁耶。无戏乐故。无喜乐故。无行出故。无福德故。因不除离业故于中生。复说此道于欲界中最为下劣。名曰非道。因是事故。故说地狱名泥犁耶。云何禽兽名底(都履反)栗车。因谄曲业于中受生。复说此道众生多覆身行故说名底栗车。云何鬼道名曰闪多阎摩罗。王名闪多故其生与王同类故名闪多。复说此道与余道往还。善恶相通故名闪多。云何说阿修罗道名阿修罗。不能忍善不能一心。下意谛听善语。种种教化其心不动。以憍慢故非善健儿。又非天故名阿修罗。云何天道说名提婆。言提婆者善行之名。因善行故于此道生。复说提婆名曰光明。恒有光故。又提婆者名曰圣道。又提婆者名曰意乐。又提婆者名曰上道。又提婆者应修应长一切善业。以是义故名曰提婆。云何人道说名摩菟沙。一聪明故。二者胜故。三意微细故。四正觉故。五智慧增上故。六能别虚实故。七圣道正器故。八聪慧业所生故。故说人道为摩菟沙。云何此地名剡浮提。因剡浮树故得是名。云何说名西瞿耶尼。此地在剡浮西故。赀生贸易悉皆用牛。牛名瞿耶尼。故名此土为西瞿耶尼。云何名为东毗提诃。此地在剡浮东故。形相可爱利养胜故。故说东毗提诃。云何名北郁单越。此地在剡浮北故。心直善故复上胜故。一切赀胜他处故。故说名为北郁单越。云何第一天名大王天提头吒等。四大王于中为增上为上首故云何第二天名为忉利。三十三天王于是中为帝主。王位自在故说为忉利天。云何第三天名为夜摩。日夜时节分分度时说如是言。咄哉不可思议欢乐故名夜摩。云何第四天名兜率陀。欢乐饱满于其资具自知满足。于八圣道不生知足。故说名为兜率陀天。云何第五天名为维摩罗昵。是中诸天如意化作。宫殿园林一切乐具。于中受乐故名维摩罗昵。云何第六天名波罗维摩婆奢。他所化作宫殿园林一切乐具。于中作自在计。此是我所于中受乐。故名波罗维摩婆奢。云何第一梵名梵先行。若人从欲界入色界前。至此处故说梵先行。云何第二名梵众。大梵王眷属多故故名梵众。云何第三名大梵。最胜初禅中间所造业所生故。自在不系他故。能观别他事故。为已生应生作主故名大梵。云何第二禅初天名曰少光。说语时口中出光明少故。故名少光。云何第二名无量光。是诸天等若说语时。口中无量光明显照故。名无量光。云何第三梵名遍胜光。是诸天等若说言时。口出光明遍一切处。圆满无余故。名遍胜光。云何第三禅初天名曰少净。是中诸天所受乐少。寂静爱乐与三禅相应。受此少乐故。名少净。云何第二天名无量净。是中诸天乐胜于前寂静爱乐。与三禅相应故。名无量净。云何第三名曰遍净。是中受乐遍满。身心究竟无余。寂静爱乐与三禅相应。诸天受此故。名遍净。云何第四禅初天名曰无云。苦乐前灭故。于先方便忧喜没尽故。此中舍受智念清净故。是中诸天受此舍受故名无云。云何第二天名曰生福。福者智念舍等相应诸禅所生故。生已受用如此三枝故名生福。云何第三名曰广果。广者谓大容果功力及报所生。此二者能摄定慧及离欲依止故。名广果。云何第四名无想天。是中诸天无有想故。何者为想。通别二想。各异生报。此中无故。唯有色阴及不相应行阴故。名无想天。云何那含天。一名善现。昔在因地。可令见实无倒义。可令受可令解故名善现。云何第二名曰善见。昔在因地增寿命具。四支提财及他赀产。并利益事善正守护。于中生正见不除不取。因前善现。及如此因故。名善见。云何第三名不烦。昔在因地。不损恼他。无妨碍意。无相逼意。因前善现。及此业故。是故名不烦。云何第四名曰不烧。是中诸天昔在因地。不烧自身。不困苦身。又不烧他。不困苦他。自他亦乐行速疾通达故。因前善现。及此业故。名无烧。云何第五名阿迦尼吒。迦尼吒者名曰下品。前十七地并已过故。复有从下品天至究竟天于中般涅槃故。复有诸天名阿迦尼吒。至般涅槃故。是故名阿迦尼吒。云何无色界第一天名曰空无边入。空者非所作非有为不可塞碍。过于碍相种种有相。一想心所缘故。无二无别。因于此空业所生故。故说名为空无边入。云何第二名识无边入天。识者第六意识。此识内故细于外空。过于碍相过于外相。一想心所缘故。无二无别。因于此识业所生故。故说名为识无边入。云何第三名无所有入天。无所有者除前二粗相。离此二外无别境界。过内外相。一想心所缘故。无二无别。因于此心业所生故。故说名为无所有入。云何第四名为非想非非想入天。非想者细故。非前七定故说非想。非非想者若无想定及无心定。如此两定名无想定。同无心故。今则有心故名非非想定。因于此定业所生故。故说名为非想非非想入。从剡浮提向下二万由旬。是处无间大地狱。从剡浮提向下一万由旬。是夜摩世间地狱。此二中间有余地狱。从剡浮提向上四万由旬。是四大天王天。从剡浮提向上八万由旬。是三十三天住处。从剡浮提向上十六万由旬。是夜摩天住处。从剡浮提向上三亿二万由旬。是兜率陀天住处。从剡浮提向上六亿四万由旬。是化乐天住处。从剡浮提向上十二亿八万由旬。是他化自在天住处。有比丘问佛世尊。从剡浮提至梵处为若近远。佛言比丘。从剡浮提至梵处。甚远甚高。相异相离。比丘。譬如九月十五日月圆满时。若有一人在彼梵处。放百丈方石坠向下界中间无碍。到后岁九月月圆满时至剡浮提。梵处剡浮提近远如是。从梵处至少光天。复倍于前。从少光天至无量光天。复远一倍。从无量光天至遍胜光天。复远一倍。从遍胜光天至少净天。复远一倍。从少净天至无量净天。复远一倍。从无量净天至遍净天。复远一倍。从遍净天至无云天。复远一倍。从无云天至生福天。复远一倍。从生福天至广果天。复远一倍。从广果天至无想天。复远一倍。从无想天至善现天。又远一倍。从善现天至善见天。复远一倍。从善见天至不烦天。又远一倍。从不烦天至不烧天。又远一倍。从不烧天至阿迦尼吒天。复远一倍

而说偈言

  从阿迦尼吒　　至剡浮提地
  放大密石山　　六万五千年
  五百三十五　　中间若无碍
  方至于剡浮

剡浮提人若离神通及他功力。无能于山壁栅中出入无碍。剡浮提人若游行者。唯能至于大小黑山。若离神通及他功力。不能过此西瞿耶尼。人若离神通及他功力。无有能于山壁栅中出入无碍。若游行者唯能至其地际海边。若离神通及他功力。不能过此东弗婆提。人若离神通及他功力。无有能于山壁栅中出入无碍。若游行者唯能至其地际海边。若离神通及他功力。不能过此北郁单越。人若离神通及他功力。无有能于壁栅山中出入无碍。若游行者唯至其地际山内边。若离神通及他功力。无能过此四天王天自宫殿处。若离神通及他功力。无有能于壁栅山中出入无碍。若游行者唯至铁围山内。若离神通及他功力。不能过此忉利诸天自宫殿处。若离神通及他功力。无有能于壁栅山中出入无碍。若游行者唯至铁围山际。若离神通及他功力。不能过此夜摩兜率陀天化乐他化自在。及梵先行梵众诸天自宫殿处。若离神通及他功力。无有能于壁栅山中出入无碍。若游行者唯在一世界内。若离神通及他功力。不能过此大梵王天自宫殿处。若离神通及他功力。无有能于壁栅山中出入无碍。若游行者唯在千世界内。若离神通及他功力。不能过此从第二禅。乃至阿迦尼吒天自宫殿处。亦如前说。若游行者唯在一千世界内。若离神通及他功力。不能过此大地狱中。以大狱卒作王富自在。阎罗处地狱以阎罗王作王富自在。一切禽兽及水罗刹。以婆娄那王作王富自在。诸蛇龙等以婆修吉龙王作王富自在。诸大龙者以摩那思龙王作王富自在。诸象龙者以娄阇耆利象王作王富自在。诸飞鸟者以迦娄罗王作王富自在。四足步行众生。以师子王作王富自在。一切鬼道以鬼尊王作王富自在。一切修罗道。以四修罗王作王富自在。一罗睺。二波罗陀。三毗摩质多。四婆利毗卢遮。阎浮提中以转轮王作王富自在。一处王作王富自在。国众尊老作王富自在。有时无王如劫初立。西瞿耶尼以转轮王作王富自在。国众尊老作王富自在。有时无王如劫初立。东弗婆提以转轮王作王富自在。国众尊老作王富自在。有时无王如劫初立。北郁单越以转轮王作王富自在。有时无王。四天王处。以四大天王作王富自在。忉利天者。以三十三天作王富自在。夜摩天者。以修夜摩王作王富自在。兜率陀天。以善足意王作王富自在。化乐天者以善化王作王富自在。他化自在天。以令自在王作王富自在。一切欲界中。以有恶魔王作王富自在。一千世界中。以大梵天王作王富自在。世间及诸天魔王所大梵处。沙门婆罗门及人天处。以如来阿罗诃三藐三佛陀法。然作王富自在。若剡浮提婴儿生已满四月日。如西瞿耶尼初生儿大。东弗婆提初生婴儿。如剡浮提五月儿大。若剡浮提婴儿生已满六月日。如北郁单越初生婴儿。如剡浮提儿年六岁。四天王处初生婴儿亦如是。生至七日如父母大。如剡浮提儿生七岁。忉利天处初生婴儿亦如是。生至七日等于成人。如剡浮提儿生八岁。夜摩天处初生亦尔。生至七日等于成人。如剡浮提儿生九岁。兜率陀天初生亦尔。生至七日等于成人。从化乐天乃至阿迦尼吒天。称其形相生便具足。剡浮提一寻半是西瞿耶尼一寻。西瞿耶尼一寻半是东弗婆提一寻。东弗婆提一寻半。是北郁单越一寻。四天王天一伽浮地。是一由旬四分之一。四天王身长二伽浮地。忉利诸天长半由旬。帝释身者长三伽浮地。夜摩诸天长一由旬。兜率陀天长二由旬。化乐诸天长四由旬。他化自在天长八由旬。一切色界至阿迦尼吒。并长十二由旬。从剡浮提至阿迦尼吒天。并长自身四肘。剡浮提众生身色种种不同。有白色者。如夜婆那婆利柯止那等国。有黑色者。如跋婆罗剑蒱阇等国。有青色者。如陀眉罗辛诃罗等国。有赤白色者。如首陀阿。毗罗等国。有黄色者。如基罗多及罽宾等国。东弗婆提西瞿耶尼。唯除黑色。余悉如剡浮。北郁单越一切人民悉皆白净。四天王天有四种色。有绀有赤有黄有白。一切欲界诸天色皆亦如是。云何诸天色有四种。初受生时若见绀华身则绀色。余色亦尔。剡浮提人衣服。有迦波婆刍摩衣。憍奢耶衣。毛衣纻衣麻衣草衣树皮衣兽皮衣板衣[佉*力]波树子衣。西瞿耶尼人衣者。迦波婆衣。刍摩衣。憍奢耶衣。毛衣纻衣麻衣草衣树皮衣兽皮衣板衣[佉*力]波树子衣。东弗婆提人。迦波婆衣。刍摩衣。憍奢耶衣。毛衣纻衣麻衣。郁单越人。[佉*力]波树子衣。长二十肘广十肘。重一波罗(南称一两)。四天王天亦[佉*力]波衣。长四十肘。广二十肘。重半波罗。忉利诸天亦着[佉*力]波衣。长八十肘。广四十肘。重一波罗四分之一。夜摩天着[佉*力]波衣。长百六十肘。广八十肘。重一波罗八分之一。兜率陀天着[佉*力]波衣。长三百二十肘。广百六十肘。重一波罗十六分之一。化乐天乃至他化自在。所著衣服。随心小大。轻重亦尔。剡浮提人衣服。庄饰种种不同。或有长发分为两髻。或有剃落发须。或有顶留一髻余发皆除。名周罗髻。或有拔除发须或有剪发剪须。或有编发。或有被发。或有剪前被后令圆。或有裸形。或着衣服覆上露下。或露上覆下。或上下俱覆。或止障前后。西瞿耶尼人所庄饰。并皆被发上下着衣。如首陀阿毗罗国。东弗婆提人发庄饰剪前被后。上下两衣着下衣上衣绕身而已。如央伽摩伽陀二国庄饰。北郁单越人所庄饰须发翠黑。恒如剃罗。五日头发自然长。横七指无有增减。四天王天庄饰种种不同。或有长发分作两髻。或有剃落发须。或顶留一髻余发皆除。名周罗髻。或拔除须发。或有剪发剪须。或有编发或有被发。或剪前被后令圆。或有裸形。或着衣服。或覆上露下。或覆下露上。或上下俱覆。或止障前后。欲界诸天庄饰亦复如是。色界诸天不着衣服。如着不异。头虽无髻。如似天冠。过男女相。形唯一种。剡浮提人。食粳米饭麦饭糗食鱼食肉。食细佉陀尼根佉陀尼果佉他尼。西瞿耶尼人所食饮。食粳米饭麦饭及糗鱼肉。细佉陀尼根佉陀尼果佉陀尼。乳酪此中最多。东弗婆提人食粳米饭麦饭。及糗鱼肉。细佉陀尼根佉陀尼果佉陀尼。奢利粳米饭最饶。北郁单越人唯食奢利粳米饭。不种自生无秕无碎。亦无有糠自然净米。色香味触并皆妙好。如细蜂蜜其味甘美。其中有树名敦治抧罗。其树生子形如釜鍑。又似[木*(羲-ㄎ+乃)]者若人欲食。取此树子以持盛水。别复有石名曰树提。取此树子以置石上石自生火。是人将取奢利米写置器中。无劳量准即自然称器。饭成熟时石自还冷。仍用前[木*(羲-ㄎ+乃)]次第盛贮。若余人来欲须食者随意取食。不作此意彼人施我是作食人。亦不作意我今施彼。若食竟时掷之而去。所余器物及残食等地裂受之受已还合。四天王天并食须陀味。朝食一撮暮食一撮。食入体已转成身分。是须陀味园林池苑并自然生。是须陀味亦能化作。佉陀尼等八种饮食。一切欲界诸天食亦如是。色界诸天从初禅中。乃至遍净以喜为食。上去诸天以意业为食。剡浮提人所资博易。或生熟金银或米谷等。或诸杂物真珠摩尼种种诸宝。或取众生以为贸易。西瞿耶尼货易交关唯用[牛*秦]牛。东弗婆提货易交关所用米谷。北郁单越无有交关。四天王天所资博易。或生熟金银或米谷等。或诸杂贸易珠摩尼种种诸宝。或取众生以为贸易。一切欲界诸天亦复如是。色界则无同郁单越。剡浮提人或自杀生。或令他杀死则食肉。西瞿耶尼亦复如是。东弗婆提人自不杀生不令他杀。若有自死则食其肉。北郁单越自不杀生。不令他杀死不食肉。四天王天自杀令他杀死不食肉。忉利诸天自杀令他杀死不食其肉。从夜摩天上至阿迦尼吒。不自杀生不令他杀死不食肉。剡浮提人若眷属死。送丧山中烧尸弃去。或置水中。或埋土里。或着空地。西瞿耶尼东弗婆提亦复如是。北郁单越人若眷属死。不送丧不烧不弃。鸟为送尸是鸟啄尸。将至山外而便啖食。四天王天其眷属死。亦不送尸不烧不弃。如光焰没无有尸骸。其上诸天一切如是。剡浮提中有五种树。金树银树玻梨柯树。琉璃树呵利多树。西瞿耶尼东弗婆提树亦如是。北郁单越唯有呵利多树余四则无。四天王天亦有五种宝树并如上说。一切欲界诸天。有五种树亦复如是。色界天中并悉无树。剡浮提中有五种华。金银玻梨柯琉璃呵利多。西瞿耶尼东弗婆提亦复如是。北郁单越有树名散多那。其花悉呵利多宝。四天王天并有五种花。一切欲界亦复如是色界都无。剡浮提中有殿堂。金银琉璃玻梨柯呵利多。有材木殿堂。或有石屋土屋。西瞿耶尼亦如是。东弗婆提殿堂并金无有余屋。北郁单越有树名曼殊沙。如高大殿叶叶相蔽不入风霜。一切诸人以为住屋。四天王天有五种殿堂。金银琉璃玻梨柯呵利多。一切欲界诸天亦复如是。色界诸天有诸殿堂皆白色宝。是中诸天昔在因地。有褊吝心而行布施望得果报。今于果地所得宫殿。光色昏闇不能明净。若是诸天在因地中。无褊吝心而行布施不望来果。我有彼无我主彼不。是正道理是法相应。若能主者施不主者。若行布施心净安隐。为庄严心为治净心。故行布施由此心故。在果地中所得宫殿。微妙光明无有暗浊。剡浮提人若离神通及因他功力。则不能通见山壁栅城障外等色。西瞿耶尼东弗婆提北郁单越。若离他功力则不能通见山壁栅城障外等色。四天王天若离神通及他功力。于自处所不能通见山壁栅城障外等色。若远观时唯见铁围山内之色。若离神通及他功力。不能彻见此山之外。忉利诸天于自宫殿。若离神通及他功力。不能得见山壁栅城障外等色。若远观时唯见铁围山内。若离神通及他功力。不能彻见铁围山外。从夜摩天乃至梵众并皆如是。大梵天王自宫殿处。若离神通及他功力。不能得见山壁栅城障外等色。若远观时唯见一千世界之内。若离神通及他功力。不能彻见。剡浮提人若索他女。女家许已乃得迎接。或有买妾或有货婢。西瞿耶尼东弗婆提亦复如是。北郁单越人不索他女。亦不迎妻不卖不赎。若男子欲娶女时谛瞻彼女。若女子欲羡男时亦须谛视。若女不见男视。余女报言。是人看汝即为夫妻。若男子不见女看。余男报言。是人看汝亦为夫妻。若自相见便即相随共往别处。四天王天若索女天。女家许已乃得迎接。或货或买一切欲界诸天亦复如是。剡浮提中有男女根以相和合。东弗婆提西瞿耶尼北郁单越亦皆如是。四天王天及忉利天。男女和合亦复如是。夜摩诸天以相抱为欲。兜率陀天执手为欲。化乐诸天共笑为欲。他化自在天相视为欲。西瞿耶尼受诸欲乐。两倍胜于剡浮提人。乃至他化自在诸天欲。胜于化乐亦皆两倍。剡浮提女人有恶食者。有胎长者有初产者有饮儿者。西瞿耶尼东弗婆提亦复如是。北郁单越女人有恶食者。有胎长者有生产者唯不饮儿。若生男儿及女儿者放四衢道。母以手指内其口中。若行路人从此过者。亦以手指内儿口中。因此指触身分长大。郁单越人男女别居不相交杂。若男生时七日成人便入男群。若女生时七日成人便入女群。若男女初作欲意相携树下。是曼殊沙树即便覆蔽欲事则成。若不覆蔽便各相离。知是邪淫即不敢犯。四天王处诸女天等。无有恶食无有胎长。亦不生儿亦不饮儿。男女天者或于膝上。或于眠处皆得生儿。若于母膝及母眠处生者。女天作意此是我儿。男天亦言此是我儿。则唯一父一母。若于父膝及父眠处生。唯有一父而诸妻妾皆得为母。剡浮提人一生欲事无数无量。亦有诸人修清净行至死无欲。西瞿耶尼其多欲者。一生之中数至十二。其中欲者数或至十。亦有诸人修清净行至死无欲。东弗婆提其多欲者。一生之中其数至七。其中品者或至五六。亦有诸人修清净行至死无欲。郁单越人其多欲者。一生之中数唯至五。其中品者或至三四。亦有诸人修清净行至死无欲。四天王天一生欲事无量无数亦有诸天修清净行至死无欲。一切欲界诸天亦复如是。凡一切女人以触为乐。一切男子不净出时以此为乐。若一切男子以不净为欲。若诸天欲者以泄气为乐。剡浮提人有三因缘。胜郁单越及忉利天。何者为三。一者勇猛。二者忆持。三者此中有梵行住。郁单越人有三因缘。胜剡浮提及忉利天。一者无我所无藏畜。二者寿量决定一千岁。三者后必上升忉利。诸天有三因缘。胜剡浮提及郁单越。一者寿量长远。二者形相奇特。三者快乐最多。是义佛世尊说。如是我闻

立世阿毗昙论卷第六佛说立世阿毗昙论卷第七

        陈西印度三藏真谛译

    受生品第二十一

造十恶业道最极重者。生大阿毗止地狱。若次造轻恶次生余轻地狱。若复轻者次生阎罗八轻地狱。若复轻者次生禽兽道。若复轻者次生鬼道。若造最轻十善业道。生剡浮提最下品家。或生除粪家或生屠脍家。或生作乐家或生工巧家。或生兵厮家。若造次胜者则生长者家。又次胜者生婆罗门家。复胜此者生刹利家。若复胜者生西瞿耶尼。次复胜者生东弗婆提。次胜者生北郁单越。次胜者生四天王。次胜者生忉利天。次胜者生夜摩天。次胜者生兜驶多天。次胜者生化乐天。若造最胜十善业道。生他化自在天。若凡夫人者。修习四种禅定。各有三品谓下中上。是人因下品初禅相应业生梵先行天。因是业得此天道。得天寿命。得住得天同类。已生于彼受业果报。有二种乐。一无逼乐。二者受乐。是业熟已被用无余。因中品初禅相应业。于梵众天生。因上品业亦生此天。因是业已得天道。得寿命。得住得同类。已生于彼受业果报。有二种乐。一无逼乐。二名受乐。是业熟已被用无余。因二禅下品相应业。因此业故生少光天。因中品二禅相应业。生无量光天。因上品二禅相应业生胜遍光天。因是业得天道。得天寿命。得住得天同类。已生于彼受业果报。有二种乐一无逼乐。二者受乐。是业熟已被用无余。因下品三禅相应业生少净天。因中品三禅相应业。生无量净天。因上品三禅相应业生遍净天。因是业得此天道。得寿命。得住得天同类。已生于彼受业果报。有二种乐。一无逼乐。二者受乐。是业熟已被用无余。因下品四禅相应业。生无云天。因中品四禅相应业生受福天。因上品四禅相应业生广果天。因是业故得此天道。得天寿命。得住得天同类。已生于彼受业果报。有无逼乐。无复受乐。是业熟已被用无余。诸凡夫人随余业故余处受生。若凡夫人修习四无量心。各有三品谓下中上。慈无量者如是修习。如是数行如四种禅定。喜无量者如是修习如是数行。如初禅如二禅。悲无量者如是修习。如是数行如第四禅。舍无量者如是修习如是数行。如第三禅及第四禅。是凡夫人修习不净观。各有三品谓下中上。无憎违行不净观。如是修习如是数行如四种禅定。有憎违行不净观。如是修习如是数行如第四禅。是凡夫人修习阿那波那念。各有三品谓下中上。如是修习如是数行如前三种禅定。凡夫人修习五有想。各有三品谓下中上。何者为五。一不净想。二过失想。三死堕想。四餍食想。五一切世间无安想。无憎违不净想者。如是修习如是数行如四种禅定。有憎违不净想。及后四想如是修习。如是数行如第四禅。是凡夫人修习八种遍入。各有三品谓下中上。何等为八。一内有色想观外色少。是少者或妙或粗。我遍此想得知得见如是有想。二内有色想观外色无量。或妙或粗我遍此想能知能见作如是想。三内无色想观外色少如前。四内无色想观外色无量亦如前。五六七八者。并于内无色想观四色。谓青黄赤白我遍此想。能知能见作如是想。此八想中是第一第二。如是修习如是数行如四禅定。后六想者如是修习。如是数行如第四禅。是凡夫人修习十一切入。各有三品谓下中上。是八一切入如是修习。如是数行如第四禅。后二一切如是修习。如是数行如其自地。空一切入如空无边入。识一切入如识无边入。是凡夫人修习四无色三摩跋提。各有三品谓下中上。是人由下品空处相应业。生空无边入天。由中品空无边入相应业亦生此天。由上品空无边入相。应业亦生此天。因是业故得天道。得天寿命。得天住得天同类。生于彼已受业果报。有无逼乐。无有受乐。是业熟已被用无余。因下品识无边入相应业。生识无边入天。由中品识无边入相应业亦生此天。因上品识无边入相应业亦生此天。因是业故得天道。得天寿命。得天住得天同类。生于彼已受业果报。唯无逼乐无有受乐。是业熟已被用无余。因下品无所有入相应业生无所有入天。因中品无所有入相应业亦生此天。因上品无所有入相应业亦生此天。因是业故得天道。得天寿命。得天住。得天同类。生于彼已受业果报。唯无逼乐无有受乐。是业熟已被用无余。因下品非想非非想入相应业生非想非非想入天。因中品非想非非想入相应业亦生此天。因上品非想非非想入相应业亦生此天。因是业故得天道。得天寿命。得天住。得天同类。生于彼已受业果报。唯无逼乐无有受乐。是业熟已被用无余。是凡夫人随后报业余处受生。是凡夫人修习初禅定已生已得。从此一切更复退失。是人住下品初禅中。是人由下品初禅相应业生梵先行天。生于彼已受下品初禅业报。得无逼乐及与受乐。受中品上品初禅及二禅业果报。于此生中得受无逼乐及以受乐。第三禅及第四禅亦此生中受业果报。但无逼乐无有受乐。是业熟已被用无余。随后报业余处受生。余中品上品初禅亦如是。凡夫人修习四禅已生已得。从此一切更复退失。是人住下品二禅中。是人由下品二禅相应业生少光天。生于彼已受下品二禅业报。得无逼乐及与受乐。受中品上品第二禅及初禅业报。于此生中得无逼乐及与受乐。第三禅及第四禅此生中受果报。但无逼乐无有受乐。是业熟已被用无余。随后报业余处受生。余中品上品二禅亦如是。是凡夫人修习四禅已生已得。从此一切更复退失。是人住下品三禅中。由下品三禅相应业生少净天。生于彼已受下品。三禅业报。得无逼乐及与受乐。受中品上品第三禅业报。于此生中得无逼乐及与受乐。初禅二禅及第四禅业报。受无逼乐无有受乐。是业熟已被用无余。随后报业余处受生。余中品上品三禅亦如是。是凡夫人修习四禅。已生已得从此一切更复退失。是人住下品四禅中。由下品四禅相应业生无云天。生于彼已受下品四禅业报。得无逼乐无有受乐。受中品上品第四禅及余三禅业报。于此生中得无逼乐无有受乐。是业熟已被用无余。凡夫人随后报业余处受生。余四禅中品上品亦如是。是凡夫人修习四禅及四无色定。已生已得从此一切更复退失。是人住下品空无边入。由下品空无边入相应业。生空无边入天。生于彼已受下品空无边入果报。得无逼乐无有受乐。受中品上品空无边入。及上三无色定果报。于此生中得受无逼乐无有受乐。是业熟已被用无余。是凡夫人随后报业余处受生。余中品上品空无边入亦如是。是凡夫人修习四禅及四无色。已生已得从此一切更复退失。是人住下品识无边入。由下品识无边入相应业生识无边入天。生于彼已受下品识无边入业报。得无逼乐无有受乐。受中品上品识无边入。及初后三无色业报。于此生中得无逼乐无有受乐。是业熟已被用无余。是凡夫人随后报业余处受生。余识无边入中品上品亦复如是。是凡夫人修习四禅及四空定。已生已得从此一切更复退失。是人住下品无所有无边入。由下品无所有无边入相应业。生无所有无边入天。生于彼已受下品无所有无边入业报。得无逼乐无有受乐。受中品上品无所有无边入。及前后三无色业报。于此生中得无逼乐无有受乐。是业熟已被用无余。是凡夫人随后报业余处受生。余中品上品亦复如是。是凡夫人修习四禅及四无色定。已生已得从此一切更复退失。是人住下品非想非非想无边入。由下品非想非非想无边入相应业。生非想非非想无边入天。生于彼已受下品非想非非想无边入果业。得无逼乐无有受乐。受中品上品非想非非想无边入。及前三无色业报。于此生中得无逼乐无有受乐。是业熟已被用无余。是凡夫人随后报业余处受生。余中品上品亦复如是

佛世尊圣弟子修习四禅。各有三品谓下中上。是人由下品初禅相应业生梵先行天。因是业得彼天道。得天寿命。得住得天同类。已生于彼受业果报有二种乐。一无逼乐二者受乐。是业熟已被用无余。因中品初禅相应业生梵众天。因上品业亦生此天。因是业得天道。得天寿命。得住得同类。已生于彼受业果报有二种乐。一无逼乐二者受乐。是业熟已被用无余。因二禅下品相应业。因此业故生少光天。因中品二禅相应业生无量光天。因上品二禅相应业生胜遍光天。因是业得天道。得天寿命。得天住。得天同类。已生于彼受业果报有二种乐。一无逼乐二者受乐。是业熟已被用无余。因下品三禅相应业生少净天。因中品三禅相应业生无量净天。因上品三禅相应业生遍净天。因是业得此天道。得天寿命。得住得同类。已生于彼受业果报有二种乐。一无逼乐二者受乐。是业熟已被用无余。因下品四禅相应业生无云天。因中品四禅相应业生受福天。因上品四禅相应业生广果天。因是业故得此天道。得寿命。得住得天同类。已生于彼受业果报。有无逼乐无复受乐。生于彼已由最上品四禅相应业。恭敬勤修无背常修行。杂觉分之所熏修。因此业故生善现天。十倍此业生善见天。次复十倍生不烦天。复十倍生不烧天。次复十倍生阿迦尼吒天。因此业得天道天寿命。得天住。得天同类。生于彼已受业果报。有无逼乐无复受乐。是业熟已被用无余。引上界业于中用尽。即于是中得般涅槃

佛世尊弟子修习四无量定。各有三品谓下中上。慈无量者。如是修习如是数行。如四种禅定。喜无量者。如是修习如是数行。如初禅如二禅。悲无量者。如是修习如是数行如第四禅。舍无量者。如是修习如是数行。如第三禅及第四禅

佛圣弟子修习不净观。各有三品谓下中上。无憎违行不净观。如是修习如是数行如四种禅定。有憎违行不净观。如是修习如是数行如第四禅。佛圣弟子修习阿那波那念。各有三品谓下中上。如是修习如是数行。如前三种禅定

佛圣弟子修习十想。各有三品谓下中上。何者为十。一无常想。二无我想。三灭除想。四离欲想。五寂灭想。六不净想。七过失想。八死堕想。九厌食想。十一切世间无安想。前五种想及无憎违不净想。如是修行如是数习如四种禅定。后四种想及有憎违行不净想。如是修习如是数行如第四禅。佛圣弟子修八遍入。各有三品谓下中上。何等为八。一内有色想观外色少。是少者或妙或粗。我遍此想得知得见如是有想。二内有色想观外色无量。或妙或粗。我遍此想能知能见作如是想。三内无色想观外色少。粗妙如前。四内无色想观外色无量。类亦如前。五六七八者。并于内无色想观外四色。谓青黄赤白我遍此想能知能见作如是想。于此八中第一第二。如是修习如是数行如四种禅定。后六种想如是修习如是数行如第四禅

佛圣弟子修习八解脱。各有三品谓下中上。第一内有色想观外色解脱。第二内无色想观外色解脱。第三净解脱。第四空无边入解脱。第五识无边入解脱。第六无所有无边入解脱。第七非想非非想无边入解脱。第八想受灭解脱。第一解脱如是修习。如是数行如四种禅定。第二解脱如是修习如是数行如第四禅。第三解脱若内有色想观外色。如是修习如是数行如四种禅。若内无色想观外色。如是修习如是数行如第四禅。后四无色解脱各如自地。第八灭受想解脱。但由住故过非想非非想。不由离欲故过是故其地等非非想

佛圣弟子修习十一切入。各有三品谓下中上。前八一切入如是修习如是数行如第四禅。后二一切入各如自地。佛圣弟子修习四无色三摩跋提。各有三品谓下中上。是人由下品空无边入相应业。生空无边入天。由中品空无边入相应业亦生此天。由上品空无边入亦生此天。因是业故得天道得天寿命。得天住。得天同类。生于彼已受业果报。唯无逼乐无有受乐。是业熟已被用无余。由下品识无边入相应业生识无边入天。由中品识无边入相应业亦生此天。由上品识无边入相应业亦生此天。由是业得天道。得寿命。得住。得天同类。生于彼已受业果报。唯无逼乐无有受乐。是业熟已被用无余。因下品无所有入相应业生无所有入天。因中品无所有入相应业亦生此天。因上品无所有入相应业亦生此天。因是业得天道。得寿命。得住。得同类。生于彼已受业果报。唯无逼乐无有受乐。是业熟已被用无余。因下品非想非非想入相应业生非想非非想入天。因中品非想非非想入相应业亦生此天。因上品非想非非想相应业亦生此天。因是业得天道。得寿命。得住。得同类。生于彼已受业果报。唯无逼乐无有受乐。是业熟已被用无余。是中般涅槃。佛圣弟子修习四禅定。已生已得从此一切更复退失。是人住下品初禅中。是人由下品初禅相应业生梵先行天。生于彼已受下品初禅果报。得无逼乐及与受乐。受中品上品初禅及二禅业果报。于此生中得受无逼乐及与受乐。其第三禅及第四禅。亦此生中得受果报。受无逼乐无有受乐。是业熟已被用无余

佛圣弟子是中般涅槃。余中品上品初禅亦如是

佛圣弟子修习四禅。已生已得从此一切更复退失。是人住下品二禅中。是人由下品二禅相应业。生少光天。生于彼已受下品二禅果报。得无逼乐及与受乐。受中品上品第二禅。及初禅业报。于此生中得受无逼乐及与受乐。第三禅及第四禅亦此生中受果报。受无逼乐无有受乐。是业熟已被用无余

佛圣弟子于中般涅槃。余中品上品二禅亦如是

佛圣弟子修习四禅。已生已得从此一切更复退失。是人住下品三禅中。由下品三禅相应业生少净天。生于彼已受下品三禅果报。受无逼乐及与受乐。受中品上品第三禅业报。此生中得受无逼乐及与受乐。受初禅二禅及第四禅业报。受无逼乐无有受乐。是业熟已被用无余

佛圣弟子于中般涅槃。余中品上品三禅亦如是

佛圣弟子修习四禅。已生已得从此一切更复退失。是人住下品四禅中。由下品四禅相应业生无云天。生于彼已受下品四禅业报。得无逼乐无有受乐。受中品上品第四禅及余三禅业报。于此生中得受无逼乐无有受乐。是业熟已被用无余

佛圣弟子是中般涅槃。余四禅中品上品亦如是

佛圣弟子修习四禅及四无色定。已生已得从此一切更复退失。是人住下品空无边入。由下品空无边入相应业生空无边入天。生于彼已受下品空无边入果报。得无逼乐无有受乐。受中品上品空无边入。及上三无色定果报。于此生中受无逼乐无有受乐。是业熟已被用无余

佛圣弟子于中般涅槃。余中品上品空无边入亦如是

佛圣弟子修习四禅及四无色。已生已得从此一切更复退失。是人住下品识无边入。由下品识无边入相应业生识无边入天。生于彼已受下品识无边业报。得无逼乐无有受乐。受中品上品识无边入。及初后三无色业报。此生中得受无逼乐无有受乐。佛圣弟子于中般涅槃。余识无边入中品上品亦如是

佛圣弟子修习四禅及四无色。已生已得从此一切更复退失。是人住下品无所有无边入。由下品无所有无边入相应业生无所有无边入天。生于彼已受下品无所有无边入果报。得无逼乐无有受乐。受中品上品无所有无边入。及前后三无色业报。此生中得受无逼乐无有受乐。是业熟已被用无余

佛圣弟子于中般涅槃。余中品上品无所有无边入亦复如是

佛圣弟子修习四禅及四无色。已生已得从此一切更复退失。是人住下品非想非非想无边入。由下品非想非非想无边入相应业生非想非非想无边入天。生于彼已受下品非想非非想无边业报。得无逼乐无有受乐受中品上品非想非非想无边入。及前三无色业。于此生中得无逼乐无有受乐。是业熟已被用无余

佛圣弟子于中般涅槃。余中品上品非想非非想无边入亦复如是

上流生阿那含有三种。一者初生梵先行天。如是次第往生乃至广果。于中生已得般涅槃。二者初生广果如是次第往生。乃至阿迦尼吒天。生于彼已得般涅槃。三者初生空无边入天。如是次第往生乃至非想非非想天。生是中已得般涅槃

复次上流生阿那含有二种。一者在色界。二者在无色界。若在色界般涅槃者。从梵先行天如是次第生。乃至阿迦尼吒天。生于彼已得般涅槃。在无色界者。初生空无边入天。如是次第往生乃至非想非非想天。生于中已得般涅槃

复次有一种上流生阿那含。从梵先行天生。如是次第往生乃至非想非非想。生于彼已得般涅槃。是义佛世尊说。如是我闻

    寿量品第二十二

佛世尊说人中二万岁。是阿毗止狱一日一夜。由此日夜三十日为一月。十二月为一年。由此年数多年多百年。多千年多百千年。于此狱中受熟业果报。于是中生最极长者一劫寿命。人中六千岁是阎罗狱一日一夜。由此日夜三十日为一月。十二月为一年。由此年数多年多百年。多千年多百千年。于此狱中受熟业报。有畜生道众生。有一日一夜六七过死生。复有诸畜生寿命一劫。人中一月为鬼神道一日一夜。又人中一月日为神鬼中一日一夜。由此日夜三十日为一月。十二月为一年。由此年数五百年是其寿命。是五百岁当人中十五千年。剡浮提人或十岁。或阿僧祇岁。是中间寿命渐长渐短。长极八万岁短极十岁。西瞿耶尼人二百五十年是其寿命。东弗婆提人寿五百岁。北郁单越定寿千年。人中五十岁是四天王一日一夜。由此日夜三十日为一月。十二月为一年。由此年数五百天年是其寿命。当人中岁数九百万岁。人中一百年是忉利天一日一夜。由此日夜三十日为一月十二月为一年。由此年数寿命千年。当人中三千六百万岁。人中二百年是夜摩天一日一夜。由此日夜三十日为一月。十二月为一年。由此年数寿命二千年。当人中十四千万。又四百万年。人中四百岁是兜率陀天一日一夜。由此日夜三十日为一月。十二月为一年。由此年数寿命四千年。当人中五千七百六十亿年。人中八百年是化乐天一日一夜。由此日夜三十日为一月。十二月为一年。由此年数寿命八千年。当人中二万三千四十亿年。人中一千六百年。是他化自在天一日一夜。由是日夜三十日为一月。十二月为一年。由此年数寿命一万六千年。当人中九万二千一百六十亿年。由乾陀山下顶阿修罗寿命如四大天王。须弥山下顶阿修罗寿命如忉利天。一小劫者名为一劫。二十小劫亦名一劫。四十小劫亦名一劫。六十小劫亦名一劫。八十小劫名一大劫。云何一劫名为小劫。是时提婆达多比丘。住地狱中受熟业报。佛世尊说住寿一劫。如是一小劫名劫。云何二十小劫亦名一劫。如梵先行天二十小劫是其寿量。是诸梵天佛说住寿一劫。如是二十劫亦名一劫。云何四十小劫名为一劫。如梵众天寿量四十小劫。佛说住寿一劫。如是四十劫亦名一劫。云何六十小劫名为一劫。如大梵天寿量六十劫。佛说住寿一劫。如是六十小劫亦名一劫。云何八十小劫名一大劫。如少光天寿量一百二十小劫。佛说寿量一大劫半。如是八十小劫名为一大劫。无量光天寿量一百四十小劫。胜遍光天住寿一百六十小劫。是为二大劫。少净天二大劫半是其寿量。无量净天三大劫半是其寿量。遍净天四大劫是其寿量。无云天三百大劫是其寿量。受福天四百大劫是其寿量。广果天五百大劫是其寿量。无想天一千大劫是其寿量。善见天一千五百大劫是其寿量。善现天二千大劫是其寿量。不烦天四千大劫是其寿量。不烧天八千大劫是其寿量。阿迦尼吒天一万六千大劫是其寿量。空无边入天下品一万七千五百大劫是其寿量。空无边入中品一万八千五百大劫是其寿量。空无边入上品二万大劫是其寿量。下品识无边入天三万大劫是其寿量。中品识无边入天。三万五千大劫是其寿量。上品识无边入天。四万大劫是其寿量。下品无所有无边入天。五万大劫是其寿量。中品无所有无边入天。五万五千大劫是其寿量。上品无所有无边入天。六万大劫是其寿量。下品非想天。七万大劫是其寿量。中品非想天。七万五千大劫是其寿量。上品非想天八万大劫是其寿量。是义佛世尊说。如是我闻

立世阿毗昙论卷第七佛说立世阿毗昙论卷第八

        陈西印度三藏真谛译

    地狱品第二十三

    更生一

  过现未来世　　众生还往生
  退起及轮转　　佛世尊证见
  诸业不唐捐　　有果报不失
  随时处成熟　　圣智者自觉
  瞿昙知此说　　八种大地狱
  世尊悉证见　　成一切法眼
  更生及黑绳　　山磕二叫唤
  小大两烧热　　及大阿毗止
  如是八地狱　　佛说难可度
  恶人恒充满　　各各十六隔
  四角及四门　　分分皆正等
  上高百由旬　　四方百由旬
  铁城所围绕　　铁盖覆其上
  下地皆是铁　　炎炽火遍满
  烧恶人可畏　　恒然难可近
  见者必毛竖　　极苦不可看
  我今当为汝　　如法次第说
  恭敬一心听　　如我所说言

有一地狱名曰更生。一切皆铁昼夜烧然恒有光炎。长多由旬广亦如是。是中罪人狱卒捉持脚上头下。依黑绳分斫以鐇斧。时被斫已唯有余骨。筋所接连闷绝暂死。极大重苦狱卒掷去。是时冷风吹之还活。由此风故皮肉复常。是时罪人手爪自生坚利如剑。与其同类互起怨心作是思惟。是人昔时曾经为我作如是恶。是故我先速害彼。彼起害心亦复如是。更互相斫如芟麻丛。是地狱人受如此相害。上上品苦难可堪忍。极坚极强最为痛辣。乃至恶业受用未尽求死不得。以何行业起此果报。令诸众生于彼中生。昔在人中众多女人。共一夫主互相嗔妒。若多男子共诤一女起怨家心。或邪淫他妇或诤田园及车乘等。或二国王诤于邻地。或劫盗他财为财主所治。共结怨家如人交阵。更相残戮。已结怨家未相解谢。怀此命终由此业报彼中受生

复次种种诸恶不善业报故于彼中生。复次有增上业感彼中生。彼中生已受用种种恶业果报。云何业因令诸罪人更相残斫。昔在人中执持鐇斧及刀仗等。斩斫有命众生之类。是故于中受相斫报。复次何业为冷风所吹而复更生。昔在人中畜养饮食。牛鹿猪羊鸡鸭之属得肥长已。为得多肉当复烹杀。由此业报感彼冷风还得暂活。云何业报得生利爪如利剑。昔在人中给人刀仗。作如此教汝等可来。某处州郡及县邑等。往彼行杀或人或畜。由此业报剑爪得生

云何此狱名曰更生。彼中罪人作如此意。我今更生身肉如本故名更生。又复此狱本名更生。尔时世尊欲重明此义。而说偈言

  更生地狱中　　头下脚在上
  执持鐇斧等　　随绳卒所斫
  是时被斫已　　唯余骨聚在
  血肉皮筋等　　还复如本生
  指端利剑爪　　由业自然生
  随昔怨嗔心　　更互相斩斫
  受相斫害已　　冷风还更吹
  生一切身分　　诤风业所感
  如来人天师　　如实见是已
  是故说更生　　造恶人住处

更生地狱品究竟

    第二黑绳地狱

复次地狱名为黑绳一切皆铁。昼夜烧燃火恒光炎。长多由旬广亦如是。是中罪人狱卒捉持扑令卧地。如[狂-王+單]生树随黑绳界斫以鐇斧。或为八角或复六角或复四棱。有诸罪人从其足跟。乃至颈项。斤斧斩斫如蔗节长。复有罪人从项至足。斧斤细断亦如蔗节。是地狱人受此残戮。上上品苦难可堪忍。极坚极强最为痛恼。乃至恶业受用未尽求死不得。是何行业起此果报。令诸众生于彼中生。昔在人中作如此业。随世律制随世量决。自作教他如是重罚。如是多量斩斫其手。如是量者斩斫其脚。劓鼻刵耳亦复如是。如是多量割其背肉。或割二髀或五两或十两。由此业报是诸众生于中受生。复有种种诸恶不善业报于彼中生。复次有增上业感彼中生。彼中生已受用种种恶不善业报。彼中有时狱卒骂詈。怖畏受罪之人恶人起起莫动。时无量罪人心大惊怖。一时竦倚犹如幡林。是时铁衣铁袈裟火恒烧燃出大光炎。无数千万赤铁袈裟及赤铁衣。从空来下时诸罪人作是叫唤。是衣来是衣来。是衣至已随一一人各各缠裹。皮肉筋骨悉皆焦烂。焦烂尽已铁衣自去。是地狱人受此烧炙。上上品苦难可堪忍。极坚极强最为痛辣。乃至恶业受报未尽求死不得。是何行业受此果报。令诸众生于彼中生。昔在人中捉持鞭杖捶挞有命众生。或以皮杖或用萪藤。或复鱼尾鞭枷众生。复有出家破戒受用国土衣服及与腰绳。以此业报于中受生。复次种种诸恶不善果报于彼中生复次有增上业感彼中生。彼中生已受用种种不善业报。有诸罪人狱卒剥皮。从足跟至颈则止不令都离。又狱卒从颈项剥皮。至足跟而止亦不都离。复有罪人从颈剥皮至腰而止。或从腰剥皮至跟而止。令诸罪人身所带皮。垂拖披曳皆至于地。自地践履痛苦难当。譬如世人所著衣服。纵横长短不能整齐。在其身皮亦复如是。此地狱人受自[利-禾+皮]剥。上上品苦难可堪忍。极坚极强最为痛辣。乃至恶业受报未尽求死不得。是何行业受此果报。令诸众生于彼中生。昔在人中作如是业。有命众生生剥其皮。令皮不脱犹着其身似如衣服为戏乐等。复次昔在人中鞭挞众生。或自作为他所教。复次出家破戒。受用国土衣服卧具等。由此业报于彼受生。复有种种诸恶不善业报于彼中生。复次有增上业感彼中生。彼中生已受用种种不善业报。是地狱中极大黑暗。密烟充满烟气燥辣。裂皮破肉彻骨至髓。此烟毒触遍身内外。狱卒驱逼令入烟中然后方置。是诸罪人畏避此烟周章驰走。无数由旬互蹋身皮更相困苦。是地狱人受此烟毒。上上品苦难可堪忍。极坚极强最为痛辣。乃至恶业受报未尽求死不得。是何行业受此果报。令诸众生于彼中生。昔在人中作高密室以烟杀人。或作牢狱人以烟苦。或豪猪或陵鲤或獭或狐或狸或鼠或猾。蜜蜂之属皆在坎中。于其穴中作烟熏取。乃至蚊蚋以烟熏逐。以此业报于中受生。复有种种诸恶不善业报于彼中生。复次以增上业感彼中生。彼中生已受用种种不善业报。云何此狱名为黑绳。是中罪人随黑绳界。斩斫困苦故名黑绳。又复自性本名黑绳。欲重宣此义。而说偈言

  黑绳中狱卒　　[狂-王+單]罪人如树
  随黑绳界道　　执持鐇斧斫
  复次赤铁衣　　昼夜恒烧热
  缠压诸罪人　　血肉流及燥
  剥足皮至颈　　从颈腰亦然
  黑绳中罪人　　多无皮赤肉
  可畏黑暗中　　毒烟悉充满
  狱卒逼驱入　　入已方舍置
  驰走多由旬　　烟暗无所见
  更互履身皮　　自他俱困苦
  此中因及果　　如实佛自知
  如是说黑绳　　恶人所住处

黑绳地狱品究竟

    大巷地狱

在更生黑绳二狱中间。其有地狱名曰大巷如大市巷。是中罪人或时仰眠。或时覆眠或置臼中铁杵舂捣。或有罪人从脚至颈分分斩斫。或有罪人褫皮布地。还割其肉以积皮上。复有罪人下剑手断举剑手生。以是因缘积其手聚犹如山高。脚耳鼻头下剑即断举剑还生。头鼻等聚亦如山高。乃至恶业受报未尽求死不得。是何行业受此果报。令诸众生于彼中生。昔在人中屠脍为业。杀羊猪牛鹿以自活命。或捕鱼鸟或辩决牢狱。或自为劫盗或刑剪罪人。由此业报彼中受生。复有种种诸恶业于彼中生。复次有增上业感彼中生。彼中生已受用种种不善业报。是地狱人头如象头身似人身。复有罪人头如马头身如人身。复有罪人头如牛头身亦似人。如是等类种种不同。是中狱卒取诸罪人驾以铁车。昼夜烧燃恒有光炎。赤铁为枙赤铁为绳。是中路地一切皆铁。长多由旬广亦如是。是中狱卒执赤铁锥驱蹙来去。受如此害。上上品苦难可堪忍。极坚极强最为痛辣。乃至恶业受用未尽求死不得。彼是何业受此果报。令诸众生于此中生。昔在人中。或调象师或调马师。或复调牛诸骑乘师等。由此业报彼中受生。复次种种诸恶业报于彼中生。彼有增上业报感彼中生。彼中生已受用种种不善果报。彼中复有众生头作牛头身是人身。亦有鹿头人身。复有猪头人身。如是等类种种无数。狱卒众多聚集围绕。执持弓刀种种器仗。斫刺罪人受此残害。上上品苦难可堪忍。极坚极强最为痛辣。乃至恶业受用未尽求死不得。是何行业受此果报。令诸众生于彼中生。昔在人中持捉刀杖。田猎网捕有命众生。多人围绕或斫或刺或杀或害。由此等业彼中受生。复次种种诸恶业报于彼中生。复有增上业报感彼中生。彼中生已受用种种不善业报。彼中有树名逆刺睒浮利一切皆铁。昼夜烧燃恒有光炎。树高一由旬刺长十六寸。彼中狱卒捉罪人臂。牵上刺树而复牵下。若牵上时刺低向下。若牵下时刺仰向上。牵上下时腹若着树皮肉即尽。若背着树皮肉亦尽。其腹皮肉还复更生。胁背皮肉尽生亦尔。由此事故随腹胁背牵上牵下。如是罪人受此残害。上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业受用未尽求死不得。昔行何业受此果报。令诸众生于彼中生。昔在人中邪淫他妇。或有妇人欺背夫主。由此等业于彼中生。复次种种诸恶业报于彼中生。复有增上业报于彼中生。彼中生已受用种种不善业报。于彼狱中复有众多赤铁炭山。昼夜烧燃恒有光炎。是中狱卒捉罪人臂牵上牵下。随腹着山皮肉焦尽。若背着山皮肉亦尽。腹还复故背胁皮肉尽生亦尔。由此事故随腹胁背牵上牵下。如是罪人受此残害。上上品苦难可堪忍。极坚极强最为痛辣。乃至恶业受用未尽求死不得。昔行何业受此果报。令诸众生于彼中生。昔在人中取有命众生掷置火中。或热砂中或热灰中。或掷不净秽中。或以牛马驾于车乘热砂中行。由此等业彼中受生。复次种种诸恶业报于彼中生。复有增上业报感彼中生。彼中生已受用种种不善业报

    第三聚磕地狱品

复有地狱名为聚磕。其相犹如二山中间。是中狱卒执持种种器杖恐怖罪人。是时罪人悉皆畏惧。入二山中间无数千人。入山中央已有大火聚塞断前路。是时罪人见是猛火便欲缩退。复见其后有大火聚。周慞宛转二山便合。两山来时一切罪人。发声叫唤作如是言。是山来已是山来已。山遂相合如压麻油。山压罪人亦复如是。既压竟已山开向上。是诸罪人见山耸起。争入其下山即复落重压其身。譬如张压压诸杂狩血流成江。唯筋骨在无复皮肉。受此残害。上上品苦难可堪忍。极坚极强最为痛苦。乃至恶业受用未尽求死不得。昔何行业受此果报。令诸众生于彼中生。昔在人中以竹笪覆人牵象践蹋。或斗战时作诸压车以磕于人。又悬机石缒下杀人。复于崄路作诸机阱陷杀众生。或以爪齿掏啮蚤虱。如是等业受此果报。于中受生。复有种种诸不善业于彼中生。复有增上业感彼中生。彼中生已受用种种不善业报。其中罪人但余筋骨无复血肉。是时狱卒谓其伴言。我今共汝一弹指顷。舂捣罪人即捉诸罪人。内热铁艚中以热铁杵捣碎其身。一弹指顷当人中五百年寿。受此残害上上品苦具如前说。昔行何业感是果报。令诸众生于彼中生。昔在人中或执持矛槊及叉戟等刺害众生。谷米麻麦合虫舂[白*易]。由此等业于中受生。复有种种不善业报于彼中生。复有增上业感彼中生。彼中生已受用种种不善业报。云何此狱名曰聚磕。是中罪人聚集一处。两山聚磕故名聚磕。又复此狱本名聚磕故名聚磕。重说偈言

  聚磕地狱中　　大二山中央
  无数诸罪人　　入中如鹿聚
  由昔业报故　　是两山相合
  磕压多众生　　火聚塞前后
  从罪人身分　　流血成江河
  如是受困苦　　中间不得死
  安置赤铁艚　　执杵所舂捣
  受昔诸业报　　弹指五百年
  如来人天师　　如实见其已
  是故说聚磕　　造恶人住处

聚磕地狱品究竟

    第四地狱名叫唤品

复有地狱名为叫唤。其相犹如狭室无量千数。彼中罪人人各一室身大房小。迫迮困苦绝四威仪受烧炙害。是罪人下其火炽然。火势若猛叫声则烈。火势小羸叫声则下受此烧炙。上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业受用未尽求死不得。昔何业行受此果报。令诸众生于彼中生。昔在人中于无救济于无依止众生。自作教他行大重罚。自作教他焚燎原野。或作密室以火杀之。或作牢狱以火苦人。或豪猪陵鲤獭狐狸。鼠等穴处之类。于其穴口以火烧炙。乃至蚊蚋以火熏逐。以此业报于中受生。复有种种诸恶业报于彼中生。复次以增上业感彼中生。彼中生已受用种种不善业报

    第五地狱名大叫唤品

复有地狱名大叫唤。其相犹如大陷。广长无数由旬。皆是赤铁具如前说。是中狱卒手持铁拍拟怖罪人。罪人见已生大怖畏。或走逃叛或不逃叛。或周章漫走。或面拓壁或复直视。或逢迎赞叹或辞谢乞恩。是时狱卒问逢迎者。汝等云何敢来迎我。即以铁拍打碎其头。如破酪堈头碎脑溅。亦复如尔。语不迎者。汝何敢不来。碎破其头亦复如前。漫走不走拓壁正视。叛不叛者各问打治例皆如是。以此因缘悉皆破头。无得免者受此残碎。上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业受报未尽求死不得。昔何行业受此果报。令诸众生于彼中生。昔在人中凿陷为狱。若犯罪者安置是中。令其不见日月明光。由此业报于彼受生。复有种种诸恶业报。于彼中生。复次诸增上业感彼中生。彼中生已受用种种不善业报。复行何业受碎头报。昔在人中有命众生打破其头。或鱼蛇蜈蚣等种种众生。由是等业受碎头报。此狱烧炙困苦复剧于前。长有碎首等苦。云何此狱名大叫唤。是中罪人由拍由火。大号大叫唯大叫声无所诠辩。乃至不能唤母唤父。是故地狱名大叫唤。又复自性名大叫唤。重说偈言

  叫唤地狱中　　多人被迫迮
  下火若大燃　　叫唤声可畏
  若火势羸弱　　叫声亦随下
  摧折威仪苦　　及以烧炙痛
  第二大叫唤　　深暗令毛竖
  壁立不可登　　广大无数量
  狱卒于彼中　　执持赤铁拍
  碎头如怨家　　无量百千年
  如来人天师　　如实见是已
  故说二叫唤　　造恶人住处

大小叫唤地狱品究竟

    第六地狱名烧炙品

复有地狱名曰烧炙。其相犹如陶窖一切皆铁。昼夜烧然恒发光炎。广长无数由旬。是中罪人无数千万。闭塞烧炙熟已内外焦燥。虚脆易脱譬如肉脯。是时狱门自然开。其门外边有无数狗。或乌或驳身高长大。伺待门开争入狱里。牵出罪人咋[狂-王+單]其身。如倒生树恣意啖食。既被食已皮肉皆尽。唯余骨聚困苦难处当时闷绝。冷风来吹皮肉更复。是时狱卒复驱令入。还受先苦烧炙食啖。上上品苦具如前说。昔何行业受此果报。令诸众生于彼中生。昔在人中造作牢狱无有门户。增土象粪杂以泥壁。及以涂地以盐和瞿昙婆树油。溅罪人身掷置狱中。日光照炙于一夜中臭烂膀胀。或蒸或煮杀害罪人。或复安火燃炙杀人。或煮蚕茧或煎炒有命众生。以此业报于中受生。复有种种诸恶业报。及增上业报感彼中生具如上说。复由何业为狗食啖。昔在人中畜养师子虎豹熊罴豺狗之属。令其咋啮有命众生。以是等业受彼中生余如上说。昔何行业得冷风吹。昔在人中为须多肉养饴众生。以此业故得冷风触。云何此狱名之烧炙。是中罪人身心被炙故名烧炙。又复自性名为烧炙。重说偈言

  烧炙地狱中　　铁舍大炎热
  气热极盛猛　　犹如烧火聚
  是中造罪人　　密塞而受炙
  如昔所行业　　此中受苦报
  是时身已熟　　群狗竞食啖
  皮肉皆消尽　　唯骨是其余
  冷风一来吹　　皮肉还复本
  狱卒更驱入　　还更受前苦
  如来人天师　　如实见是已
  故说是烧炙　　造罪人住处

烧炙地狱品究竟

    第七地狱品名大烧炙

复有地狱名大烧炙。其相如高广山一切皆是赤铁。昼夜烧然恒发光炎。有赤铁利串烧热最剧。恒发光炎周圆上下皆所围绕。或有罪人一串所贯就火山炙。或两三串或十二十。乃至百千纵横穿贯就火山炙。若一边已熟其串自转复炙一边。复有罪人铁串自拔贯未伤处翻转就炙。复有罪人由上上品恶业报故无数诸串并皆自来叉刺其身。是中罪人受此串炙。上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业受报未尽求死不得。昔行何业受此果报。昔在人中串贯火炙。有命众生由此业报于中受生。复有种种诸恶业报于彼中生。复次诸增上业感彼中生。彼中生已受用种种不善业报。云何此狱名大烧炙。彼中罪人为串所刺。以就火山内外烧炙。愁忧苦恼故说大烧炙。又复自性本名烧炙。重说偈言

  大烧炙地狱　　利串皆是铁
  围绕铁火山　　宿世恶业感
  是中行恶人　　无数被穿贯
  如反覆炙鱼　　随业令其尔
  如来人天师　　如实见是已
  故说大烧炙　　造恶人住处

大烧炙品究竟

    第八阿毗止地狱品

复有地狱名阿毗止。其相犹如大城一切皆是赤铁。昼夜烧燃恒发光炎。是狱东壁一切赤铁。昼夜烧燃恒出火炎。西南北壁上下并燃东壁火炎交彻西壁。西壁火炎亦彻东壁。南火彻北北火彻南。上火彻下下火彻上。四方火炎遍满狱中。是中罪人无量千数重沓受烧犹如樵[卄/積]。中有罪人由此恶业上上品故。身体长大虚疏柔软。更相蹙逼身首低垂。不能行走绝四威仪。有诸罪人由此宿业下中品故恒求出离周章漫走。或有时节是大地狱东门自开。是诸罪人咸唱门开竞走求出。未至门边门自还闭。是时西门更复开辟。南门北门亦复自开。是诸罪人唱云门开。疾走向门未至门所门已自闭。是中罪人受此无间地狱大苦。难可堪忍。极坚极强最为痛剧。乃至恶业受报未尽求死不得。昔行何业受此果报。昔在人中或杀母杀父杀阿罗汉。起杀害心出佛身血破和合僧。或复其母已是圣人生于淫逼。杀正定聚人或杀菩萨众生。或破坏如来四种支提。或劫夺聚集因缘四方僧物。或行杀生偷盗邪淫。妄语两舌恶口绮语。贪爱嗔恚邪见等最极上品。随其一二乃至具足。以此恶行于中受生。复有种种诸恶业报于彼中生。复次诸增上业感彼中生。彼中生已受用种种不善业报。云何此狱名阿毗止。彼中罪人恒常受苦无有间息。最上上品余地狱苦则不如此。何以故。余地狱中狱卒或时来或时不来或由冷风大苦暂息。此地狱中则不如是。从始至终受上上品苦难可堪忍。极坚极强最为痛剧。此中罪人寿命一劫。乃至半劫乃至不定。譬如炉冶竟日烧铁星炎沸涌。烧罪人身亦复如是。故说名阿毗止。又复自性亦名阿毗止。重说偈言

  阿毗止地狱　　一向最剧苦
  昼夜火烧燃　　光炎聚遍满
  譬如一日烧　　铁镬出光炎
  如是阿毗止　　一切火光彻
  是中罪人身　　犹如大火聚
  汝等看业力　　由此不灰炭
  或时见门开　　争竞走驰出
  来至门已闭　　宿业未尽故
  如天受乐人　　求生不求死
  此中受苦者　　求死不求生
  如来人天师　　如实见是已
  故说阿毗止　　造恶人住处

阿毗止品究竟

    第九外园隔地狱品

八地狱外四方围绕。各有四重围隔地狱。何等为四。一热灰地狱。二者粪屎地狱。三者剑叶地狱。四烈灰汁地狱。如是四重次第围绕。一一地狱如是应知。若次第说有地狱名热灰。是诸罪人从大地狱出。见外热灰如平坦空地。见此相已起如是心。我今决应往彼。于是罪人往到彼中。脚践热灰皮肉即烂。譬如蜡块投猛火中。随其举脚皮肉还复。或时至膝或时至脐。或时至颈或没不现。此中无数由旬周章漫走。受上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业受报未尽求死不得。昔行何业受此果报。昔在人中取有命众生掷置火中。或热灰中或热砂中。或邪淫他妇过世法则入他境界。或出家破戒行住坐卧僧伽蓝中。或起恶心或蹋践四支堤境界。及履支提影。以此业报于中受生。复有种种诸恶业报于中受生。复次诸增上业感彼中生。彼中生已受用种种不善业报

第二地狱名曰粪屎。是中罪人出热灰狱外。见粪屎如凉花池。见已起如是心。我今决定必应往彼。是时罪人往入彼中。入其中已有无数虫。虫口坚利皆如剑锋。钻破皮肉乃至筋骨啖食其髓。复有诸虫从鼻孔入食其五藏。或从耳入或从眼入或从口入。或从小大道入并唼食五藏。复有大虫含嚼罪人。血肉既尽吐出其骨如弃枣核。具受如是上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业受报未尽求死不得。昔行何业受此果报。昔在人中取有命众生。掷置粪坑或不净处。乃至沟渎以此业报于中受生。复有种种诸恶业报于中受生。复次诸增上业感彼中生。彼中生已受用种种不善业报。昔行何业受虫食啖困苦果报。昔在人中或令蛇狗蜈蚣鼍鳄之属。啮嚼有命众生。或起恶心受用五尘。由此业报于彼中生。受钻破食啖如是等苦。而说偈言

  已渡粪屎狱　　见可爱树林
  具郁茂枝条　　往彼欲求乐

如是林中有老乌白颈鸦鹰鹗鹫鸟等。是地复有豺狗野干虎狼师子等。身皆长大是诸禽兽啮[狂-王+單]罪人。如倒生树食啖其肉皮血肉尽。唯余骨在。时诸罪人受此啄害。上上品苦难可堪忍。极坚极强最为痛剧。当时闷绝冷风复吹皮肉更生。复受啖食乃至受报未尽求死不得。昔行何业受此啖食。昔在人中令虎狼师子啖食有命众生。或放鹰犬猎诸禽兽。由此等业彼中受生受食啖报。有种种诸恶业报于中受生。昔行何业被冷风吹。昔在人中畜养众生。使令肥壮欲得多肉。以是业报得冷风吹

第三地狱名曰剑叶。是诸罪人已度粪屎地狱。见剑叶地狱心起爱着如庵罗林。是剑林路有诸锵刺。匕首剃刀刀剑锋刃遍布其地。时诸罪人行此林路。备受钻刺等苦。得入大林时无数千众生。入此林已恶业因缘。大风卒起雨诸器仗。所谓剑雨箭雨剑雨鐇斧等雨。随所著处身分断绝。头首分离如斫木柄布散狼藉。或雨铁戈从顶贯地。动转不得受此残害。上上品苦极坚极强最为痛剧。乃至恶业受报未尽求死不得。昔行何业受此果报。昔在人中行斗战事。与人刀仗遣令斗战。作如是言。汝等用此器仗取彼国土。长围四合聚集多人肆意杀害。由此业报于彼中生。复有种种业报于中受生。复有增上业报感彼中生。彼中生已受用种种不善业报。剑叶地狱竟

第四地狱名烈灰汁。是诸罪人从剑叶树林出。见烈灰汁言是清冷江水。心起爱着往入江中。是等罪人先在剑林。遍身破裂入此江水。身并烂坏血肉都尽。唯筋骨相连逐水浮漾受此残酷。上上品苦极坚极强最为痛剧。乃至恶业受报未尽求死不得。昔行何业受此果报。昔在人中取有命众生。热油煎灌或糖或蜡。或煮死尸取汁浇灌。或不净秽身入园人所用池井洗濯。以此业报于中受生。复有种种诸恶业报于中受生。复有增上业报感彼中生。彼中生已受用种种不善业报。灰河两岸有诸狱卒无量千数。身并长大执叉戟等守视罪人。有时罪人语狱卒言官我今大饥。狱卒即以叉取掷置岸上。或用钳钩擘开其口。烧热铁丸恒有光炎。捉内口中唇口焦燃。咽胸心腹五藏肠胃。并皆溃烂丸从下出。是诸罪人受此酷害。上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业受报未尽求死不得。昔行何业受此果报。昔在人中以毒食饴他或鸩杀人。或出家破戒食国土供养。或妄语恶口如是等业。受此果报彼中受生。复有种种诸恶业报于中受生。复次诸增上业感彼中生。彼中生已受用种种不善业报。有时罪人语狱卒言。官我今大渴。狱卒即以叉取罪人掷置岸上。或用钳钩擘开其口。烊热铁汁恒有光炎。灌其口中唇口焦燃。咽胸心腹五藏肠胃。并皆烂溃铁汁下出。是时罪人受此酷害。上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业果报未尽求死不得。昔行何业受此罪苦。昔在人中取象马等尿灌他口鼻。或以五辛辣汁浇他鼻口。或置毒饮中逼令他服。或劝他饮种种诸酒。或为利酤酒或自饮酒。或出家破戒受用国土供养。苏油糖蜜等饮。或复饮他非所堪饮。以此业报于中受生。复有种种诸恶业报于中受生。复有增上业报感彼中生。彼中生已。受用种种余不善业报。重说偈言

  罪人出大狱　　见此热灰中
  犹如平广地　　起爱即往彼
  至已漫驰走　　无数诸由旬
  举下脚生烂　　备受上品苦
  既出热灰狱　　便见粪屎坑
  广长深百丈　　爱往谓花池
  是中无数虫　　口坚利如锋
  穿皮啖血肉　　破筋骨食髓
  复出粪坑已　　见剑林起爱
  谓枝条嫩茂　　往彼欲求乐
  林中种种鸟　　口啄利如铁
  [狂-王+單]人如生树　　食啖其血肉
  是时既食已　　唯余筋骨在
  冷风一来吹　　皮肉更还复
  怖畏起跳踊　　苦处作安想
  路中受残害　　入可畏剑林
  是时身破裂　　极痛血洪流
  出离此林已　　便复入灰河
  如煮豆涌沸　　或沈或浮转
  沸烈灰中汁　　罪人亦如是
  两岸诸狱卒　　执叉刺其体
  将出置地上　　逼使吞铁丸
  或复烊铁汁　　求饮灌口中
  焦烂遍身里　　然后从下出
  如是行恶人　　受此地狱苦
  昔不修善业　　修行邪曲路
  由起正思惟　　能离诸恶业
  一向行善行　　是人度恶道
  知善恶二业　　果报差别异
  智人应离恶　　当种诸善根
  复有别修行　　八直圣道分
  为灭一切苦　　观无余四法
  如来人天师　　如实见是已
  故说园隔狱　　造恶人住处

园隔地狱品究竟

    第十阎罗地狱品

如佛婆伽婆及阿罗汉说。如是我闻。一时佛世尊说。比丘我以天眼清净过于肉眼。见诸众生退没生起。善色恶色若妙若粗。或住善道或住恶道。随业受生如实我知。而说偈言

  起造邪恶心　　及说邪曲语
  或作邪身业　　由昔放逸故
  少闻无福德　　促命中为恶
  是人舍身命　　即堕阎罗狱

佛告比丘。若人宿世不恭敬父母。及沙门婆罗门。不恭敬亲友尊长。不修正善及福德行。于现在恶及未来罪不生怖畏。不行布施不修福德。不受八斋不持五戒。舍寿命已生地狱中。狱卒收录送与阎罗白言。此人往昔不恭敬父母。及沙门婆罗门。不恭敬亲友尊长。不修正善及福德行。于现在世恶及未来罪不生怖畏。不行布施不修福德。不受八斋不持五戒。愿王教诫是人令识善恶因果。时阎罗王依五天使正善教戒。谓众生曰。汝先不见第一天使往彼人中。大王我先不见。王曰。昔汝在人中不见年少童子婴孩。初生仰眠不能避湿就燥时耶。众生言。法王我昔已见。王言。汝见识解何不思计。我今应生未度生法。我应随能依身口意修行善法。为长时中得于正道利益欢乐。众生言。大王我昔放逸不能行善。王言。汝邪恶业自作自长。非父母所作。非国王所作。非天所作。非先亡沙门婆罗门等所作。自作自受。虽不愿求果报决至。时阎罗王因是天使诃责教已。复因第二天使。正善教敕谓众生曰。汝先不见第二天使往彼人中。大王我先不见。王曰。汝昔在人中不见若男若女老长大等。或复背瘘犹如角弓。扶杖前步举身战动。众生言。大王我昔已见。王言。汝既识解何不思计。我今应老未度老法。我应随能依身口意修行善法。为长时中得于正道利益欢乐。众生言。大王我昔放逸不能行善。王言。汝邪恶业自作自长。非父母所作。非国王所作。非天所作。非先亡沙门婆罗门等所作。自作自受。虽不愿求果报决至。时阎罗王因是天使诃责教已。复因第三天使正善教敕。谓众生曰。汝先不见第三天使往彼人中。大王我先不见。王曰。汝昔在人中不见若男若女疾病困苦极难。或滞床席或据筌提或眠地上。是身苦受最坚最强难堪难忍。侵损寿命众苦所逼。大王我昔已见。王言汝已识解何不思计。我今应病未度病法。我应随能依身口意修行善法。为长时中得于正道利益欢乐。众生言。大王我昔放逸不能行善。王言。汝邪恶业自作自受。非父母所作。非国王非天非先亡沙门婆罗门等所作。自作自受。虽不愿求业报决至。时阎罗王因是天使诃责教已。复因第四天使正善教敕。谓众生曰。汝等先不见第四天使往彼人中。大王我先不见。王曰。汝昔在人中不见若男若女或一日死。或二日三日乃至七日。或膖胀或黯黑或臭烂或为禽兽食啖。众生言。大王我昔已见。王言。汝既识解何不思计。我今应死未度死法。我应随能依身口意修行善法。为长时中得于正道利益欢乐。众生言。大王我昔放逸不能行善。王言。汝邪恶业自能自长。非父母所作。非国王非天非先亡沙门婆罗门等所作。自作自受。虽不愿求果报决至。时阎罗王因是天使诃责教已。复因第五天使正善教敕。谓众生曰。汝等先不见第五天使往彼人中。大王我先不见。王曰。汝昔在人中不见世人或杀或盗或复邪淫。乃至妄语恶口等罪。为王人所录。编头面缚打鼓。徇令于四衢道出城南门。至行刑所坐置标下。随罪轻重种种治罚。或杖或鞭或刖手足。或劓耳鼻乃至大辟。众生言。大王我昔已见。王言。汝见识解何不思计。一切恶业现报可见。我今属业随业力行。若善若恶所作诸业。于当来世如因受生。众生言。大王我昔放逸不能行善。王言。汝邪恶业自作自长。非父母非国王非天非先亡沙门婆罗门等所作。自作自受。虽不愿求果报决至。作是言已舍心而住。是时狱卒捉此罪人。倒悬向下入更生地狱。此狱有四角四门铁城围绕上下皆铁。昼夜烧燃恒出光炎。其中罪人随黑绳界。受鐇斧斫血肉俱尽。唯余筋骨困苦难堪闷绝暂死。时冷风吹血肉还复。受此残害上上品苦。乃至恶业受报未尽求死不得。昔行何业受此果报。令诸众生于彼中生。昔在人中陵慢父母。沙门及婆罗门。不恭敬亲友尊长不修正善及福德业。于现在恶及未来罪不生怖畏。不行布施不修福德。不受八斋不持五戒。由此等下品业故于彼中生。受此残害种种困苦。次增重品生第二黑绳狱。次增重品生第三聚磕地狱。次复重品生第四叫唤狱。次复重品生第五大叫唤狱。次重品生第六烧热狱。次复重品生第七大烧热狱。次复增品生第八阿毗止狱。是毗止狱四角四门。铁城围绕上下皆铁。昼夜烧燃遍满火炎。是中罪人无量百千重沓受烧。犹如樵[卄/積]犹如炼铁竟一日夜其身被烧亦复如是。佛言比丘。是毗止地狱。或东门暂开罪人见已向门而走。觅依止处觅救济处求觅出离。未达门所门已还闭。西南北门亦复如是。见是事已。念望断绝。身心苦恼悲号酸痛。无量千岁恒受如是上上品苦。难可堪忍最为痛剧。乃至恶业果报受用未尽求死不得。昔何行业受此果报。昔在人中诽谤调善精进仙人。或孤负恩义或反逆杀害爱念亲友。是大阿毗狱正业家。方便因故于中受生。复有种种诸恶业报于中受生。复次诸增上业感彼中生。彼中生已受用种种不善报。受正报已出大地狱。由残业故入四园隔。先入热灰灰深没膝。下膝焦烂如蜡投火。若举足时皮肉还复是中罪人求觅依止。救济出离周章漫走。无数由旬见粪屎坑。其地皆粪死尸遍满。其中有虫名攘鸠咤。其数无量形似长蛇。身白头黑口如剑锋。举头张口待罪人至。罪人入已是虫穿皮入肉彻骨食髓。受此苦时无数千年恒大叫唤。乃至恶业未尽求死不得。出此狱已见剑叶林。求觅依止救济出离向林疾走。于其路中种种锵刺破裂身脚。次入剑林。时有热风吹动剑树。风触如火举体焦烂。剑林复雨种种器仗斫刺身体。随所著处皮肉无余。受此残害无数千载恒大叫唤。乃至恶业未尽求死不得。复有种种禽兽食啖其身并如前说。出此狱已见热灰汁河溢满沸涌。求觅依止救济出离。驰走入河宛转颠倒犹如煮豆。边有狱卒执持铁网。料出罪人贮赤铁岸。狱卒问言。罪人汝何所须。罪人言。我今饥不可忍是时狱卒即以铁钳。格开其口投热铁丸。随丸所至唇舌心胸肠胃五藏。皆悉焦烂丸直下出。渴饮铁汁亦复如是。无数千年恒大叫唤受此困苦。乃至恶业未尽求死不得。出此狱已见中间巷狱。犹如大市是中树林名睒浮梨。中有狱卒执罪人臂。牵上牵下并如前说。复有铁镬铁汁沸满。狱卒捉人掷置镬中。人中岁数满五百年方得暂出。时裁得唤何不展唤。每复沉没是中。复有罪人或仰或覆。以赤铁钉遍钉其身着热铁地。或牵罪人舌如牛皮大。及身布贮地上以无数赤钉钉之。复有罪人通身被斫如甘蔗节。复有罪人狱卒斩斫。下剑头断举剑头生。由此杀故头聚如山手足亦尔。复有罪人褫皮布地。剑割其肉聚置皮上。复有罪人满铁艚中。狱卒捉杵舂捣令碎。复有罪人狩头人身。或牵车等具如前说。复有无数罪人。为诸狱卒捉仗围绕犹如捕猎。是谓罪人受是残害。上上品苦难可堪忍。极坚极强最为痛剧。乃至恶业未尽求死不得。昔行何业受此罪报。昔在人中造作十恶。以轻品故不感大狱于此中生。或已受大地狱果由残业故于此受生。此中生已具受种种残业果报。尔时佛言比丘。阎罗王恒作是愿。我当何时出离于此得生人道与人同类生富贵家。多诸财宝人身柔软具相安乐。车舆游处足不践地。由年长大六根成熟。已行布施作诸功德。剃除须发被着法衣。由正信智故舍离居家。受无家法既出家已。愿我证得究竟梵行。犹如昔时诸善男子。出家得道梵行究竟。尔时世尊而说偈言

  云何作此业　　现世生忧悔
  未来啼叫唤　　受种种苦果
  恶业未熟时　　痴人谓甜美
  其业既熟已　　方知是苦难
  初造恶业时　　不如火即烧
  如灰覆火上　　随逐烧罪人
  罪人多聪黠　　一切为损害
  渐损自善根　　如芭蕉结实
  恶智行自损　　犹如治怨家
  起造诸恶业　　能感当来苦
  苦行善业好　　现在无悔心
  未来受果报　　欢喜恒安乐
  如来人天师　　如实见是已
  故说阎罗狱　　造恶人住处

地狱品究竟

立世阿毗昙论卷第八佛说立世阿毗昙论卷第九

        陈西印度三藏真谛译

    小三灾疾疫品第二十四

佛世尊说。一小劫者名为一劫。二十小劫亦名一劫。四十小劫亦名一劫。六十小劫亦名一劫。八十小劫名一大劫。云何一小劫名为一劫。是时提婆达多比丘。住地狱中受熟业报。佛世尊说住寿一劫。如是一小劫名一劫。云何二十小劫亦名一劫。如梵先行天二十小劫是其寿量。是诸梵天佛说住寿一劫。如是二十劫亦名一劫。云何四十小劫名为一劫。如梵众天寿量四十小劫。佛说住寿一劫。如是四十劫亦名一劫。云何六十小劫名为一劫。如大梵天寿量六十劫。佛说住寿一劫。如是六十小劫亦名一劫。云何八十小劫名一大劫。佛说劫中世界散坏。劫中世界散坏已住。劫中世界起成。劫中世界起成已住。世界散坏等劫其数云何。佛言。比丘经二十小劫世界散坏。次经二十小劫世界散坏已住。次经二十小劫世界起成。次经二十小劫世界起成已住。是二十小劫世界起成已住者。几多已过几多未过。八小劫已过。十一小劫未来。第九一劫现在未尽。此第九一劫几多已过几多在未来。未来定余六百九十年在(至梁末己卯年翻度此经为断)。是二十小劫中间。有三小灾次第轮转。一者大疾疫灾。二大刀兵灾。三大饥饿灾。今第九劫即第三灾。此劫由饥饿故尽。佛言。比丘是二十小劫。世界起成得住中。第一劫小灾起时。有大疾疫种种病。一切皆起阎浮提中。一切国土所有人民等遭疾疫。一切鬼神起嗔恶心损害世人。是时一切人民。寿命短促唯住十岁。身形矬小或二搩手或三搩手。于其自量则八搩手。所可资食稊稗为上。人发衣服以为第一。唯有刀仗以自庄严。是时诸人不行正法。非法贪着恒所染污。非理贪爱之所逼使。邪法欺张起诸过恶。佷戾难教不能行善。不知作福不救苦难。与邪恶法日夜相应。或身口意起三邪行。不能远离杀生偷盗邪淫。妄语恶口两舌绮语。贪爱嗔恚邪见。不知恭敬父母师僧。沙门婆罗门及亲友尊长。恣心所起种种恶业。此业能感寿命短促。能感多病。能感色形丑陋。能感身无威德。能感卑贱家生。能感贫穷困苦。能感愚痴邪见。如是等业日夜生长。如是人者与种种烦恼恶业相应。由此极重邪行业故。漫风起吹方所时节违失常度。由此漫风不平等吹故。天降雨不周正落。政应雨时四王大臣。忿行恶人不水游戏故不降雨。罗睺阿修罗王。欲苦剡浮提人。或以手指或以背脊。接所降雨以置海中。复有鬼神欲苦剡浮提人。神力起火以承天雨令雨焦竭。或政雨时而起大风吹掷海中。以是因缘故天雨不等。一切种子树藤药草。并皆枯焦不复结实。设复结实减色香味。不得长大无有势力。若人受用无五种业。谓色力安乐寿命聪辩。由其邪恶于自身中。起诸重病或癞或痟或颠或瘘或虫或毒血。或吐血或泄漏。或水肿或嗽逆上气。或风痹偏枯或虚劳下疟。或恶疮瘭疾饮食不销。如此重疾及余轻病是时俱起。是时诸人婴大病苦。又为恶鬼之所恼触。欲求吉祥保护身命。故祠祀天神读诵咒术。或恃邪见所起种种恶行。杀诸众生。妄咒神鬼。求觅无病作如此计。一切利养不及无病。一日一夜无量众生。疾病疫死。末劫众生如是过失自然而生。云何如此。若人行不善法不平等法因是果报。于是时中法行平等善行不可得故。一切众生于此中生劫浊自然而起。是时诸人依止粗见粗业。造作种种诸恶。舍命以后受生恶处。苦道退堕无安乐行。是时众生多趣地狱。畜生饿鬼阿修罗道。是时大国王种悉皆崩亡。所有国土次第空废。唯小郡县是其所余。相去辽远各在一处。尔时诸人不行正法。非法贪着恒所染污。非理贪爱之所逼使。邪法欺张起诸过恶。佷戾难教不能行善。不知作福不救苦难。与邪恶法日夜相应。或身口意起三邪行。不能远离杀生偷盗邪淫妄语恶口两舌绮语贪爱嗔恚邪见。不知恭敬父母师僧沙门婆罗门及亲友尊长。恣心所起种种恶业。此业能感寿命短促。能感多病。能感色形丑陋。能感身无威德。能感卑贱家生。能感贫穷困苦。能感愚痴邪见。如是等业日夜生长。如是人者疾病困苦。无人布施汤药饮食。以是因缘寿未应尽横死无数。一日一夜无量众生疾病疫死。末劫众生如是过失自然而生。云何如此。由行恶法不平等法得是果报。于是时中法行平等行不可得故。一切众生于此中生劫浊自然故起。是时诸人依止粗见粗业。造作种种诸恶。舍命以后受生修罗饿鬼畜生地狱时。小郡县次复荒芜。唯少家在相去转远各在一处。尔时诸人不行正法。所起种种恶业能感寿命短促乃至愚痴邪见。如是等业日夜增长。是时诸人疾疫死者。无人送埋及烧弃掷。是时土地白骨所覆。一日一夜无数众生疾病疫死。乃至居家次第空尽。是时劫末唯七日在。于七日中无量众生遭疫病死尽。设有在者各散别处。时有一人合集剡浮提内男女。唯余一万留为当来人种。于是时中皆行非法。唯此万人能持善行。诸善鬼神欲令人种不断绝故。拥护是人以好滋味令入其毛孔。以业力故于劫中间。留人种子自然不断。过七日后是大疫病一时息灭。一切恶鬼皆悉舍去。随诸众生种种须欲。饮食衣服等应念所须。天即雨下阴阳调和。美味出生身形可爱相好还复。一切善法自然而起。清凉寂靖安乐无病。大悲入心由大悲故。大慈入心由大慈故。无恼害意由无害意。互得相见生喜乐心。生忍受心生无厌心。共相携持不相舍离。譬如相爱亲友久不相见。忽得聚集生喜乐心。生忍受心生无厌心。共相携持不相舍离。时人相见亦复如是。因相爱念男女共居。是前劫人寿命十岁。后劫人民从其而生。寿命最长色形奇特。威德最胜神力自在。资生具足寿命二十千岁。是时众生如此功德自然得成云何如此。法行平等行善行是其果报。是时诸人与种种善法相应。身善行口善行意善行。舍寿命已后生善道及天道。舍寿命已还生人道。生人道已自然贤善。自性清净自性道德。心性和雅戒品具足。常行胜善远离杀生偷盗邪淫妄语两舌恶口绮语。无贪欲心无嗔恚心。舍邪见法修行正见。恭敬父母沙门婆罗门亲友尊长。与种种善法相应。是业能感长寿。能感无病。能感色形端正。能感身有威德。能感富贵家生。能感大智。如是善业日夜生长。是时诸人依福德行生无量功德。舍寿以后更生天道。及以善道善道中住。久久时节如是。初劫中间由大疫病究竟穷尽。次第二劫来续二十千岁。是劫中间第一寿量。是人从前二十千岁人所生。是人寿命最长色形奇特威德最胜。神力自在资生具足。寿命四十千岁。时诸众生如此功德自然得成。云何如此。法行平等行善行是其果报。是时诸人与种种善法相应。身善行口善行意善行。舍寿命已生善道及天道。舍寿命已还生人中。生人中已自然贤善。自性清净自性道德。心性和雅戒品具足常行胜善。远离杀生偷盗邪淫妄语两舌恶口绮语。无贪欲心无嗔恚心。舍邪见法修行正见。恭敬父母沙门及婆罗门亲友尊长。与种种善法相应。是业能感长寿能感无病。能感色形端正。能感身有威德。能感富贵家生能感大智。如是善业日夜生长。是时诸人依福德行生无量功德。舍寿命后更生天道。及以善道善道中住久久时节。如是说名第二劫中间。第二寿量四十千岁。是诸人从四十千岁人所生。是人寿命最长色形奇特威德最胜。神力自在资生具足。寿命六十千岁。是时诸人与种种善法相应。身善行口善行意善行。舍寿命已生善道及天道。舍天寿已还生人中。生人中已自然贤善。自性清净自性道德。心性和雅戒品具足常行胜善。远离杀生偷盗邪淫妄语两舌恶口绮语。无贪欲心无嗔恚心。舍邪见法修行正见。恭敬父母沙门及婆罗门亲友尊长。与种种善法相应。是业能感长寿能感。无病。能感色形端正。能感身有威德。能感富贵家生。能感大智。如是善业日夜生长。是时诸人依福德行生无量功德。舍寿命后更生天道。及以善道善道中住久久时节。如是说名第三劫中间。第三寿量六十千岁。次是诸人从六十千岁人所生。是人寿命最长色形奇特威德最胜。神力自在资生具足。寿命八十千岁。如是剡浮提劫中间所生众生。寿量长远究竟极此八十千年。是时女人年五百岁尔乃行嫁。是时诸人唯有七病。谓大小便利寒热淫欲心饥老。如是时中一切国土富贵丰乐。无有怨贼及以盗窃。州郡县邑人民村落。更相次比鸡鸣相闻。耕种虽少收实巨多。是时诸人受功用业少。用宿世善业果多。舍宅车乘衣服财宝。生生之资称意具足。虽复受用终身不坏。是时诸人安坐受乐无所驰求。寿命八十千岁住阿僧祇年。乃至众生未造十恶。从起十恶业道时节。寿命因此十恶灭度。一百年则减十岁。次复百年复减十岁。次第渐减至余十岁。最后十岁住不复减。长极八万短至十年。若佛不出世次第如此。若佛出世如正法住。众生寿命暂住不减。随正法稍减寿命渐减。佛世尊说如是我闻

    小三灾刀兵品第二

佛世尊说。一小劫者名为一劫余如前说。乃至八十小劫名为大劫。云何八十小劫名一大劫。佛说劫中世界散坏。劫中世界散坏已住。劫中世界起成。劫中世界起成已住。世尊散坏等劫其数云何。佛言比丘经二十小劫世界散坏。次经二十小劫世界散坏已住。次经二十小劫世界起成。次经二十小劫起成已住。是二十小劫世界起成得住中。第二劫小灾起时。由大刀兵是劫究竟。是时阎浮提中一切国土。所有人民遭大刀兵互相憎害。又起疾疫一切鬼神。起嗔恶心损害世人。是时一切人民寿命短促。唯住十岁身形矬小。或二搩手或三搩手。所可资食稊稗为上。人发为衣服以为第一。唯有刀仗以自庄严。是时诸人不行正法非法贪着。恒所染污非理贪爱之所逼使。邪法欺张起诸过恶佷戾相教。不能行善不知作福不救苦难。与邪恶法日夜相应。或身口意起三邪行。不能远离杀生偷盗邪淫妄语两舌恶口绮语贪爱嗔恚邪见。不知恭敬父母师僧沙门婆罗门及亲友尊长。恣心所起种种恶业。此业能感寿命短促。能感疾病。能感色形丑陋。能感身无威德。能感卑贱家生。能感贫穷困苦。能感愚痴邪见。如是等业日夜生长。如是人者与种种烦恼恶业相应。由此极重邪业行故。父母儿子。互相斗诤。兄弟姊妹亲友眷属自相斗诤。何况他人。是时诸人起斗诤已。仍相手舞或以瓦石。或以杖损次乃刀杖。互相怖畏乃至杀害。是时诸人起重嗔恚。行诸杀害以为戏乐。东方国王来伐西国。西方国王往伐东国。南北诸王亦复如是。是诸王以相骂为法。说人罪过以为法式。伺求间隙以为正事。行斗诤已起怨家想。执持刀杖更相诛灭。于一日夜被害死者其数无量。劫末众生如是过失自然而生。云何如此。若人行不善法不平等法得是果报。于是时中法行平等行善行不可得故。一切众生于此中生劫浊自然而起。是时诸人依止粗见粗业。造作种种诸恶。舍命已后受生恶处。苦道退堕无安乐行。是时众生多生地狱畜生饿鬼阿修罗道。是时大国王种悉皆崩亡。所有国土次第空废。唯小郡县是其所余盖不足言。相去辽远各在一处。尔时诸人不行正法非法贪着。恒所染污非理贪爱之所逼使。邪法欺张起诸恶业佷戾难教。不能行善不知作福。不救苦难。与邪恶法日夜相应。或身口意起三邪行。不能离杀生偷盗邪淫妄语恶口两舌绮语贪爱嗔恚邪见。不能恭敬父母师僧沙门婆罗门及亲友尊长。恣心所起种种恶业。此业能感寿命短促。能感多病。能感色形丑陋。能感身无威德。能感卑贱家生。能感贫穷困苦。能感愚痴邪见。如是等业日夜生长。东方国人来伐西人。南北诸人亦复如是。是时诸人以相骂为法。说人罪过以为法式。伺求间隙以为正事。行斗诤已起怨家想。执持刀杖更相诛灭。于一日夜被害死者其数无量。末劫众生如是过失自然而生云何如此。若人不行善行法行平等行得是果报。于是时中法行平等行善行不可得故。一切众生于此中生劫浊自然而起是时诸人依上粗业。造作种种诸恶。舍命以后更生恶处。苦道退堕无安乐行。是时众生多生地狱畜生饿鬼阿修罗道。诸郡县次复空尽。唯少家在相去转远各在一处。是时东家来杀西家。西家复杀东家。南北诸家亦复如是。是时诸人以相骂为法。说人罪过以为法式。伺求间隙以为正事。行斗诤已起怨家想。执持刀杖更相诛灭。于一日夜被害死者其数无量。末劫众生如是过失自然而生。云何如此。若人不行善行不行正法。行平等行得是恶业果。于是时中正法行平等行善行不可得故。一切众生于此中生。劫浊自然而起。是时诸人依止粗见粗业。造作种种诸恶。舍命以后更生恶处。苦道退堕无安乐行。是时众生多生地狱畜生饿鬼阿修罗道。是时人家一时没尽纵余残人各各分散。此散人不行正法起种种恶业。能感寿命短促乃至愚痴邪见。是时劫末余七日在。于七日中手执草木即成刀杖。由此器。仗互相残害怖畏困死。是时诸人怖惧刀杖逃窜林薮。或渡江水隐蔽孤洲。或入坑窟以避灾难。或时相见仍各惊走恐怖失心。或时仆地譬如獐鹿遭逢猎师。是时诸人更递相见怖畏如是。是七日中刀兵横死其数无量。设有在者各散别处。时有一人合集剡浮提男女。唯余一万留为当来人种。于是时中皆行非法。唯此万人能治善行。诸善鬼神欲令人种不断绝故。拥护是人以好滋味令入毛孔。以业力故于劫中间留人种子自然不断。过七日后是大刀兵一时息灭。一切恶鬼皆悉舍去。随诸众生种种须欲。衣服饮食等应念所须。天即雨下阴阳调和。美味出生身形可爱相好还复。一切善法自然而起。清凉寂靖安乐无病大悲入心。由大悲故大慈入心。由大慈故无恼害意。由无害意互得相见。生喜乐心。生忍受心。生无厌心。共相携持不相舍离。譬如相爱亲友久不相见。忽得聚集生喜乐心。生忍受心生无厌心。共相携持不相舍离。时人相见亦复如是。因相爱念男女共居。是前劫人寿命十岁。后劫人民从其而生。寿命最长色形奇特威德最胜神力自在资生具足。寿命二十千岁。是时众生如此功德自然得成。云何如此。法行平等行善行是其果报。是时诸人与种种善法相应。身善行口善行意善行。舍寿命后生善道及天道。舍寿命已还生人道。生人道已自然贤善。自性清净自性道德。心性和雅戒品具足常行胜善。远离杀生偷盗邪淫妄语两舌恶口绮语。无贪欲心无嗔恚心。舍邪见法修行正见。恭敬父母沙门婆罗门亲友尊长。与种种善法相应。是业能感长寿能感无病。能感色形端正。能感身有威德。能感富贵家生。能感大智。如是善业日夜生长。是时诸人依福德行生无量功德。舍寿命后更生天道。及以善道善道中住久久时节。如是初劫中间。由大刀兵究竟穷尽。次第三劫来续二十千岁。是劫中间第一寿量。是人从前二十千岁人所生。是人寿命最长。色形奇特威德最胜神力自在资生具足。寿命四十千岁。时诸众生如此功德自然得成。云何如此。法行平等行善行是其果报。是时诸人与种种善法相应。身善行口善行意善行。舍寿命已生善道及天道。舍天寿命还生人中。生人中已自然贤善。自性清净自性道德。心性和雅戒品具足常行胜善。远离杀生偷盗邪淫妄语两舌恶口绮语。无贪欲心无嗔恚心。舍于邪见修行正见。恭敬父母沙门婆罗门亲友尊长。与种种善法相应。是业能感长寿。能感无病。能感色形端正。能感身有威德。能感富贵家生。能感大智。如是善业日夜生长。是时诸人依福德行增长无量功德。舍寿命后更生天道。及以善道善道中住久久时节。如是说名第三劫中间。第二寿量四十千岁。次复诸人从四十千岁人所生。是人寿命最长。身形奇特威德最胜。神力自在资生具足。寿命六十千岁。是时诸人与种种善法相应。身善行口善行意善行。舍寿命已生善道及天道。舍天道已还生人中。生人中已自然贤善。自性清净自性道德。心性和雅戒品具足常行胜善。远离杀生偷盗邪淫妄语两舌恶口绮语。无贪欲心无嗔恚心。舍邪见法修行正法。恭敬父母沙门婆罗门亲友尊长。与种种善法相应。是业能感长寿。能感无病。能感色形端正。能感身有威德。能感富贵家生能感大智。如是善业日夜生长。是时诸人依福德行生无量功德。舍寿命后更生天道。及以善道善道中住久久时节。如是说名第三劫中间。第二寿量六十千岁。次是诸人从六十千岁人所生。是人寿命最长。色形奇特威德最胜。神力自在资生具足。寿命八十千岁。如是阎浮提劫中间所生。众生寿量长远。究竟极此八十千年。是时女人年五百岁尔乃行嫁。是时诸人唯有七病。谓大小便利寒热欲心饥老。如是时中一切国土富贵丰乐。无有怨贼及以盗窃。州郡县邑民人村落。更相次比鸡鸣相闻。耕种虽少收实巨多。是时诸人受功用果少。用宿世善业果多。舍宅车乘衣服财宝。生生之资称意具足。虽复受用终身不坏。是时诸人安坐受乐无所驰求。寿命八十千岁住阿僧祇年。乃至众生未造十恶。从起十恶业道。时节寿命因此十恶减。度一百年则减十岁。次复百年复减十岁。次第渐减至余十岁。最后十岁住不复减。长极八万短至十年。若佛不出世次第如此。若佛出世如正法住时。众生寿命暂住不减。随正法稍减寿命渐减。佛世尊说如是我闻

    小三灾饥饿灾品第三

佛世尊说。一小劫者名为一劫余如前说。乃至八十小劫名一大劫。云何八十小劫名一大劫。佛说劫中世界散坏。劫中世界散坏已住。劫中世界起成。劫中世界起成已住。世尊散坏等劫其数云何。佛言。比丘经二十小劫世界散坏。次经二十小劫世界散坏已住。次经二十小劫世界起成。次经二十小劫起成已住。是二十小劫世界起得住中。第三劫小灾起时。由大饥饿是劫究竟。于是时中灾初欲起。由饥饿由困苦由天亢旱。是时剡浮提中一切国土。所有民人遭大疾疫。一切鬼神起嗔恶心损害世人。是时一切人民寿命短促唯住十岁身形矬小或二搩手或三搩手。所可资食稊稗为上。人发为衣以为上服。唯有刀杖以自庄严。是时诸人不行正法非法贪着。恒所染污非理贪爱之所逼使。邪法欺张起诸过恶佷戾难教。不能行善不知作福不救苦难。与邪恶法日夜相应。或身口意起三邪行。不能远离杀生偷盗邪淫妄语两舌恶口绮语贪爱嗔恚邪见。不知恭敬父母师僧沙门婆罗门及亲友尊长。恣心所起种种恶业。此业能感寿命短促。能感病疾。能感色形丑陋。能感身无威德。能感卑贱家生。能感贫穷困苦。能感愚痴邪见。如是诸业日夜生长。如是人者与重烦恼恶业相应。由极重邪行故。二三年中天不降雨。由大旱故谷贵饥馑舍罗柯行。是时人民微有势力。见他有少资粮便往夺食。皆由饥所逼故。一切众病饥饿为上。以此因缘于一日夜饥饿死者其数无量。末劫众生如是过失自然而生。云何如尔。若人行不善行非法行不平等行得是果报。于是时中法行平等行善行不可得故。一切众生于此中生。劫浊自然而起。是时诸人依止粗见粗业。造作种种诸恶。舍命以后更生恶处。苦道退堕无安乐行。是时众生多生地狱畜生饿鬼阿修罗道。时大国土次第空荒。唯小郡县是其所余。悉不足言相去辽远各在一处。尔时诸人不行正法。非法贪着恒所染污。非理贪爱之所逼使。邪法欺张起诸过恶佷戾难教。不能行善不知作福不救苦难。与邪恶法日夜相应。或身口意起三邪行。不能远离杀生偷盗邪淫妄语两舌恶口绮语贪爱嗔恚邪见。不能恭敬父母师僧沙门婆罗门及亲友尊长。恣心所起种种恶业。此业能感寿命短促。能感多病。能感色形丑陋。能感身无威德。能感卑贱家生。能感贫穷困苦。能感愚痴邪见。如是等业日夜相应。天不降雨四五年中。由大旱故剡浮提地。觅生草菜尚不可得。何况米谷。继诸众生。从来人所憎恶不堪食者。谓乌鸱雕鹫狗野干。此等禽兽悉取食之由饥逼故。一切众病饥饿为上。以此因缘于一日夜饥饿死者其数无量。时小郡县次复空尽。唯少家在相去转远各在一处。尔时诸人不行正法。非法贪着恒所染污。非理贪爱之所逼使。邪法欺张起诸过恶佷戾难教。不能行善不知作福不救苦难。与邪恶法日夜相应。或身口意起三邪行。不能远离杀生偷盗邪淫两舌恶口绮语妄言贪爱嗔恚邪见。不能恭敬父母师僧沙门婆罗门及亲友尊长。恣心所起种种恶业。此业能感寿命短促。能感多病。能感色形丑陋。能感身无威德。能感卑贱家生。能感贫穷困苦。能感愚痴邪见。如是等业日夜相应。是时六七年间天不降雨。由大旱故剡浮提人。思欲见水尚不可得。何况饮之。唯四大河水犹深浚与海相通。尚须船度但有此水可得受用。离此河外无复余水。纵有残民依此水住。采捕鼋鼍鱼龟等属水性之类。以自资养由饥逼故。一切众病饥饿为上。以此因缘于一日夜饥饿死者不可称量。末劫众生如此过失自然而起。云何如此。若人行不善行非法行不平等行得此果报。于是时中法行平等行善行不可得故。一切众生于此中生。劫浊自然而起。是时诸人依止粗见粗业。造种种诸恶舍命以后更生恶处。苦道退堕无安乐行。是时众生多生地狱畜生饿鬼阿修罗道是所余家次第空尽。纵复余人各自星散。尔时诸人不行正法。非法贪着之所染污。非理贪爱之所逼使。邪法欺张起诸过恶佷戾难教。不能行善不知作福不救苦难。与邪恶法日夜相应。或身口意起三邪行。不能远离杀生偷盗邪淫妄语两舌恶口绮语贪爱嗔恚邪见。不能恭敬父母师僧沙门婆罗门亲友尊长恣心所起种种恶业。此业能感寿命短促。能感多病。能感色形丑陋。能感身无威德。能感卑贱家生。能感贫穷困苦。能感愚痴邪见。如是等业日夜相应。是劫中间唯七日在。是七日中一日一夜。饥饿死者其数无量。纵有在者各散别处。时有一人合数剡浮提内男女共一万人。留为当来人种。于此时中多行非法。唯此万人能行善行。诸善鬼神欲令人种不断绝故。拥护是人以好滋味令入毛孔。以业力故于劫中间。留人种子自然不断。过七日后是大饥饿一时息灭。一切恶鬼皆悉舍去。时诸众生种种须欲。衣服饮食等应念所须。天即雨下阴阳调和。美味生出身形可爱相好还复。一切善法自然而起。清凉寂靖安乐无病大悲入心。由大悲故大慈入心。由大慈故无恼害意。由无害意获得相见生喜乐心。生忍受心生无厌心共相携持不相舍离。譬如相爱亲友久不相见。忽得聚集生喜乐心生忍受心。生无厌心共相携持不相舍离。时人相见亦复如是。因相爱念男女共居。是前劫人寿命十岁。后劫人民从其而生寿命最长形色奇特威德最胜。神力自在资生具足。寿命二十千岁。是时众生如此功德自然得成。云何如此。法行平等行善行是其果报。是时诸人与种种善法相应。身善行口善行意善行。舍寿命后生善道及天道。舍寿命已还生人道。生人道已自然贤善。自性清净自性道德。心性和雅戒品具足常行胜善。远离杀生偷盗邪淫妄语两舌恶口绮言。无贪欲心无嗔恚心。舍邪见法修行正见。恭敬父母沙门婆罗门亲友尊长。与种种善法相应。是业能感长寿。能感无病。能感形色端正。能感身有威德。能感富贵家生。能感大智。如是善业日夜生长。是时诸人依福德行生无量功德。舍寿命后更生天道。及以善道善道中住久久时节。如是劫初中间。由大饥饿究竟穷尽。次余劫来续二十千岁。是劫中间第一寿量。是人从前二十千岁人所生。是人寿命最长形色奇特威德最胜。神力自在资生具足。寿命四十千岁。时诸众生如是功德自然得成。云何如此。法行平等行善行是其果报。是时诸人与种种善法相应。身善行口善行意善行。舍寿命已生善道及天道。舍天寿命还生人中。生人中已自然贤善。自性清净自性道德。心性和雅戒品具足常行胜善。远离杀生偷盗邪淫妄语两舌恶口绮语。无贪欲心无嗔恚心。舍邪见心修行正见。恭敬父母沙门婆罗门亲友尊长。与种种善法相应。是业能感无病。能感色形端正。能感身有威德。能感富贵家生。能感大智。如是善业日夜生长。是时诸人依福德行增长无量功德。舍寿命后更生天道。及以善道善道中住久久时节。如是说名第三劫中间。第二寿命四十千岁。次复诸人从四十千岁所生。是人寿命最长身形奇特威德最胜。神力自在资生具足。寿命六十千岁。是时诸人与种种善法相应。身善行口善行意善行。舍寿命已生善道及天道。舍天道已还生人中。生人中已自然贤善。自性清净自性道德。心性和雅戒品具足常行胜善。远离杀生偷盗邪淫妄语两舌恶口绮语。无贪欲心无嗔恚心。舍邪见法修行正法。恭敬父母沙门婆罗门亲友尊长。与种种善法相应。是业能感长寿。能感无病。能感色形端正。能感身有威德。能感富贵家生。能感大智。如是善业日夜生长。是时诸人依福德行生无量功德。舍寿命后更生天道。及以善道善道中住久久时节。如是说名第三劫中间。第三寿量六十千岁。复次诸人从六十千岁人所生。是人寿命最长色形奇特威德最胜。神力自在资生具足。寿命八十千岁。如是剡浮提劫中间。所生众生寿量长远。究竟极此八十千年。是时女人年五百岁尔乃行嫁。是时诸人唯有七病。谓大小便利寒热欲心饥老。如是时中一切国土富贵丰乐。无有怨贼及以盗窃。州郡县邑人民村落。更相次比鸡鸣相闻。耕种虽少收实巨多。是时诸人受功用果少。用宿世善业果多。舍宅车乘衣服财宝。资生之具称意具足。虽复受用终身不坏。是时诸人安坐受乐无所驰求。寿命八十千岁住阿僧祇年。乃至众生未造十恶。从起十恶业道。时节寿命因此十恶减。度一百年则减十岁。复百年复减十岁。次第渐减至余十岁。最后十岁住不复减。长极八万短至十年。若佛不出世次第如此。若佛出世如正法住时。众生寿命暂住不减。随正法稍减寿命渐减。佛世尊说如是我闻

立世阿毗昙论卷第九佛说立世阿毗昙论卷第十

        陈西印度三藏真谛译

    大三灾火灾品第二十五

佛世尊说。一小劫者名为一劫。二十小劫亦名一劫。四十小劫亦名一劫。六十小劫亦名一劫。八十小劫名一大劫。云何一小劫名为一劫。是时提婆达多比丘。住地狱中受熟果报。佛世尊说住寿一劫。如是一小劫名劫。云何二十小劫亦名一劫。如梵先行天二十小劫是其寿量。是诸梵天佛说住寿一劫。如是二十小劫亦名一劫。云何四十小劫名为一劫。如梵众天寿量四十小劫。佛说住寿一劫。如是四十小劫亦名一劫。云何六十小劫名为一劫。如大梵天寿量六十劫。佛说住寿一劫。如是六十小劫亦名一劫。云何八十小劫名一大劫。佛说劫中世界散坏。劫中世界散坏已住。劫中世界起成。劫中世界起成已住。阿僧祇时名劫。世界散坏阿僧祇时名劫。世界散坏已住阿僧祇时名劫。世界起成阿僧祇时名劫。世界起成已住散坏。有三因。一因火散坏。二因水散坏。三因风散坏。如是佛世尊说。比丘散坏因有三种。一火散坏。二水散坏。三风散坏。比丘散坏顶有三。一胜遍光天。二遍净天。三广果天。复次佛世尊说。比丘散坏顶有三种。一胜遍光天。二遍净天。三广果天。云何胜遍光天乃至遍净及广果天为三散坏顶。比丘火炎散坏时。一切下界众生。修第二禅上生胜遍光天。水灾散坏时一切下地众生。修第三禅上生遍净天。风灾散坏时一切下地众生。修第四禅上生广果天。佛说火灾散坏是由胜遍光天散坏。水灾散坏由遍净天散坏。风灾散坏由广果天散坏。复次比丘散坏有二。一者众生世界散坏。二者器世界散坏。十小劫中众生世界散坏。次十小劫器世界散坏。佛告比丘散坏初起时胜遍光散坏时因第二禅。是时一切剡浮提人。寿命八十千年。是时女人年五百岁尔乃行嫁。是时诸人唯有七病。谓大小便利寒热淫欲心饥老。如是时中一切国土富贵丰乐。无怨贼乃以盗窃。州郡县邑人民村落。更相次比鸡鸣相闻。耕种虽少收实巨多。是时诸人受功用果少。用宿世善业果多。舍宅车乘衣服财宝。生生之资称意具足。是时两界减没。一嗔恚界。二逼恼意界。两界起长。一者无嗔恚界。二无逼恼意界。是时诸人减离十恶。修行十善安坐受乐无所驰求。或聚亭馆或依息舍。或大集处或游树下。说如是传各宣辞辩。昔时诸人生劫浊世。因五欲尘贪欲增上故。或父母儿子互相斗诤。兄弟姊妹亲友眷属自相斗打。何况他人。是时诸人起诤以后仍相手舞。或以瓦石或以杖拍。次及刀杖互相怖畏乃至杀害。因此五尘起种种恶。是故五尘宜应弃舍。如是憎恶诃责欲尘。种种显说五尘过失。是时诸人思惟五尘过患及下界躁扰。观无觉观定微妙功德。修习二禅舍寿命后。上生胜遍光天。是时欲界诸天变身。似犀昼夜各三时行于世界。宣令此言善男子善女人。无觉观定最为妙乐。是故汝等修行于此中住。是时人初夜后夜。闻此言已欢喜踊跃。舍余杂事摄心坐禅。观欲尘过失。观无觉观定有大功德。即得二禅舍寿命后上生胜遍光天。是时有人常悦乐他人以为事业。或歌或舞相[打-丁+費]跳掷。或轮刀舞仗或击鼓吹篪。或唱更赞颂。或严饰他身。如是人等作歌诗传。昔时诸人生劫浊世。因五欲尘贪欲增上故。或父母儿子互相斗诤。兄弟姊妹亲友眷属自相斗打。何况他人。是时诸人起诤已后。仍相手舞或以石瓦。或以杖拍次及刀杖互相怖畏。乃至杀害因此五尘起种种恶。是故五尘宜应弃舍。如是憎恶呵责欲尘。种种显说五尘过失。是时诸人思惟五尘过患及下界躁扰。观无觉观定微妙功德。修习二禅舍寿命后。上生胜遍光天。是时诸天从胜遍光天下。行于世界隐蔽身形。宣令此言善男子善女人。无觉观定妙乐寂静。是故汝等修行于此中住。是时诸人初夜后夜。等闻天声言欢喜诵习起信乐心。一切居家村邑郡州。乃至大国土人。起精进心观下界欲尘过失。观二禅功德修习二禅。舍寿命后上生胜遍光天。是时有出家外道。教化一切居家村邑郡州。乃至大国土人。悉使出家有无数眷属之所围绕。次第游行周遍国土。其所宣说与上相应。昔时诸人生劫浊世。因五欲尘贪欲增上故。或父母儿子互相斗诤。兄弟姊妹亲友眷属自相斗打。何况他人。是时诸人起斗诤后。而相手舞或以石瓦。或以杖拍。次及刀杖互相怖畏。乃至杀害。因此五尘起种种恶。是故五尘宜应弃舍。如是憎恶诃责欲尘。显说五尘过失。是时诸人思惟五尘过患及下界躁扰。观无觉观定微妙功德。修习二禅舍寿命后。上生胜遍光天。时诸众生在地狱中作是思惟。我等昔时作种种不善恶业。是故我今来此受苦。由此意故不于狱卒生嗔怨心。时地狱众生无嗔恚界。无逼恼意界。自然生长增足善心。由于宿世后报善业。舍地狱寿生人道中。既生人已思惟欲尘过患。观二禅功德修习二禅。舍寿命后上生胜遍光天。时有众生堕地狱中。仍为狱卒作是思惟。我等因自恶业来此受生。是诸罪人亦因恶业来此受苦。我今云何于他众生而起残害。即生无嗔恚界无逼恼界。自然生长增足善心。由于宿世后报善业。舍寿命已得生人中。生人中已思惟五尘过患。观二禅功德修习二禅。舍寿命后上生胜遍光天。时有水产众生鼋鼍鱼龟之属。皆生慈心不相吞噬。唯食水苔及以草土。自然死者方取食之。乃可饿死不欲害他自食。无嗔恚界无逼恼意界。是时生长生诸善心生爱念心。由于宿世后报善业。舍寿命后生于人中。生人中已思惟五尘过患及下界躁扰。观无觉观定微妙功德。修习二禅。舍寿命后上生胜遍光天。复有陆行众生。师子虎狼豺豹猫狸之属。并生慈心不相食啖。饥食嫩草。渴饮清泉。有自死者方食其肉。宁可饿死不欲杀他自济。无嗔恚界无逼恼意界。是时生诸善心生爱念心。由于宿世后报善业。舍寿命后生于人中。生人中已思惟五尘过失及下界躁扰。观无觉观定微妙功德。修习二禅。舍寿命后上生胜遍光天。一切饿鬼道更相爱念。悉能生善并如前说。舍寿以后得生人中。生人中已思惟五尘过失。观无觉观定修习二禅。舍寿命后上生胜遍光天。阿修罗道亦复如是。时西瞿耶尼人。有于彼土修习二禅。若在彼得二禅从彼上生胜遍光天。若来剡浮受生得二禅者。亦上生胜遍光天。东毗提诃人。或在彼修习二禅。彼从上生二禅天处。若来剡浮提修习二禅。仍从此上生第二天处。北郁单越人舍寿命后上生六欲天。或在天道修习二禅上生二禅。或从六天生剡浮提。修习二禅亦生胜遍光天。是时四大天王天。三十三天。夜摩天。兜率陀天。化乐天。他化自在天。梵先行天。梵众天。或在此等天中修习二禅。舍寿命已生胜遍光天。或从天道来生剡浮提。修习二禅亦上生胜遍光天。比丘是时一切地狱皆悉空虚。一切畜生道亦皆虚空。一切鬼神道亦复空虚。一切阿修罗道亦复空虚。西瞿耶尼南剡浮提东毗提诃北郁单越并皆空虚。四天王天三十三天夜摩天兜率陀天化乐天他化自在天梵先行天梵众天并皆空虚。是时一千世界中一切众生悉皆空尽。唯大梵王在。如是因缘如是次第一切众生世界皆悉散尽。如是时中十小劫已度。比丘是时第二器世界散坏。来续四大散坏火灾散坏。是时中久久时节。天不降雨一滴不落久不雨。已剡浮提中卉木药草。一切种子一时焦枯。次第烧尽无复更生。比丘一切有为法如是无常。如是不恒非安息处短促变异破坏。非能救济。非实依处。非依荫处。比丘以是义故。有为之法甚可厌患。应当离欲应当弃舍。比丘过久长。时有如此时有第二日出。于世间轮相热明倍于旧日。由此日故剡浮提中。一切池沼及小江湖。并皆涸竭无复更有。比丘一切有为法如是无常。具如前说。乃至应当弃舍。比丘复次过久长时。有如此时有第三日次出。于世轮相热明倍第二日。由此日故剡浮提中。深大江湖并皆涸竭无复更有。比丘一切有为法如是无常。具如上说。乃至应当弃舍。比丘过久长时。次第四日复出。于世轮相热明倍第三日。由此日故剡浮提中。阿那婆达池漫陀耆尼池。七林间河及四大河。如是等处最大最深流波迅疾与海相会。并皆涸竭无复更有。比丘一切有为法如是无常。具如前说。乃至应当弃舍。比丘过久长时次第五日复出。于世轮相热明倍第四日。由此日故内外海水减一百由旬。次减二百三百四百乃至千由旬海水减。耗次减二千三千四千。乃至一万次减二万。乃至六万由旬水界悉减。比丘有如是时所余海水。深七多罗或六多罗。或五或四或三或二或深一多罗。比丘有如此时所余海水。或深七寻如是次减乃至一寻。比丘有如此时所余海水。才至人颈或腋或胸腰脐膝胫踝。比丘有如此时所余海水不没指节。比丘一切有为法如是无常。具如前说。乃至应舍。比丘过久长时次第六日复出。于世轮相热明倍第五日。由此日故世界大地。内外大海及须弥山王。初时出烟烟聚遍覆。譬如陶窖初时出烟。烟聚所覆大地大海及须弥山。由第六日烟聚所覆亦复如是。比丘一切有为法如是无常。具如前说。乃至应当弃舍。比丘过久长时次第七日复出。于世轮相热明倍第六日。由此日故世界大地。内外大海及须弥山王。皆发火焰俱时洞然通成一焰经久长时停住不灭。比丘是须弥山王。大火所烧通成一焰。久长时然其顶方百由旬皆悉崩碎。或二百三百乃至一千由旬。堕落崩烬亦复如是。是时外四大中一切火自然而发。世界天地烧热出焰成一火性。以其热势吸下水轮。譬如铜槃火所烧热。置浅水中吸水都尽。世界大地成一火性。吸下水轮亦复如是。譬如苏油为火所烧。一皆消尽无复灰烬。如是大地内外大海。及须弥山王皆发火焰俱时洞然。通成一焰一切烧尽。无有炭灰亦复如是。尔时地轮并皆没尽。水风二轮亦皆烧灭。其火焰上从水轮起。乃至大梵王处。是时大梵舍其寿命。及以住处上生胜遍光天。是时大梵宫殿地。广大周圆光明可爱观者。无厌其色纯白微细净洁。一时烧尽不复更有。梵王所住地本来法然。所以由火等得灭如是多时。一切外器世界散坏都尽如是多时。经二十小劫已度。复次二十小劫。来续是中一千世界处所。空无所有犹如暗穴。上无覆盖空住二十小劫。佛言。比丘是时世界更欲起成。是世间法然初起世界时。若有众生已生长业。能感大梵果报。舍前报已来入中阴。因色界四大和合。大梵宫殿地自然而起。白净光明隐蔽余处。色相圆满观无厌足。心所爱乐住未有人。是诸众生昔已造业。能感可爱胜妙住处。因昔业故感色界四大。及四大所造色。因昔业及色界四大宫殿。即成色界四大。于此宫殿亦因亦缘。宿世所造业但是增上缘。佛言。比丘如是大梵王处。有因有缘得起得成。本来法然由因缘起。是梵王住处如一四天下大。是时梵王在中阴中。见此处所起欲爱心。我今于此中坐。即起爱时于中受生。于此独住满十小劫。喜乐为食依喜乐住。意生化身自然光明。自在而住过十劫已。此梵王起欲爱心。起不安心作是思惟。愿余众生来共我住。是时梵王作是愿已。二禅众生业尽舍寿。退来受生与梵同类。是诸众生见此大梵。本来独住作如是执。我昔上生已见此人端然独住。今从上下犹见独住与昔无异。复起此执。此人是梵作者生者最为尊。始众生所作由。此人成神力自在。已生当生为第一父。我等今日从其而生。云何如此。我昔至今见其在此独自先生。尔时梵王作是思惟。我是大梵作者生者最为尊。始众生所作由。我得成神力自在。已生当生我是其父。一切世间皆我化生。云何如此。由我昔日起如是心。愿他众生来就我住。应我愿心他即来生。我先在此见其来生。是大梵王于余众生。寿命极长形色最胜。有大名称有大神通及大威德。诸余梵众寿命则短。形色名闻神力威德。并皆不及大梵王所住地一切梵众次第遍满。本性法然世界应起时因色界四大及四大所造色。独住梵天宫殿及地自然现。其色纯白微细净洁。光明可爱看者无厌。住未有人是诸众生。昔已造业能感可爱胜妙住处。因昔业故感色界四大。及四大所造色。因昔业及色界四大宫殿。即成色界四大。于此宫殿亦因亦缘。宿世所造业但是增上缘。佛言。比丘如是独梵宫殿。有因有缘得起得成。本来法然由因缘起。是独梵处因此次第遍满。诸梵本性法然世界应起时。因色界四大及四大所造色。梵先行天宫殿及地自然起。现其色纯白微细净洁光明可爱观者无厌。住未有人是诸众生。昔已造业能感可爱胜妙住处。因昔业故感色界四大及四大所造色。因昔业及色界四大宫殿即成色界四大。于此宫殿亦因亦缘。宿世所造业但是增上缘。佛言。比丘如是梵先行处。有因有缘得起得成。本来法然由因缘起。是梵先行天住处。一切梵先行天次第遍满。本性法然世界应起时。因欲界四大及四大所造色。他化自在天宫殿及处所自然起。现金银琉璃及颇梨柯。四宝所成光明可爱观者无厌。住未有人是诸众生。昔已造业能感可爱胜妙住处。因昔业故能感欲界四大。及四大所造色。又因昔业及欲界四大宫殿。即成欲界四大。于此宫殿亦因亦缘宿世所造业但是增上缘。佛言。比丘如是他化自在天宫殿。及有因有缘得起得成。本来法然由因缘起。是他化自在天处。一切诸天次第遍满。诸天本性法然世界应起时。因欲界四大及四大所造色。化乐天宫殿及地自然起。现金银琉璃及颇梨柯。四宝所成光明可爱观者无厌。住未有人是诸众生。昔已造业能感可爱胜妙住处。因昔业故能感欲界四大及四大所造色。又因昔业及欲界四大宫殿。即成欲界四大。于此宫殿亦因亦缘。宿世所造业但是增上缘。佛言。比丘如是化乐天处。有因有缘得起得成。本来法然由因缘起。是化乐天住处一切诸天次第遍满。本性法然世界应起时。因欲界四大及四大所造色。兜率陀天宫殿及处所自然起。现金银琉璃及颇梨柯。四宝所成光明可爱观者无厌。住未有人是诸众生。昔已造业能感可爱胜妙住处。因昔业故能感欲界四大及四大所造色。又因昔业及欲界四大宫殿。即成欲界四大于此宫殿亦因亦缘。宿世所造业但是增上缘。佛言。比丘如是兜率陀天宫殿。及地有因有缘得起得成。本来法然由因缘起。是兜率陀天住处。一切诸天次第遍满。本性法然世界应起时。因欲界四大及四大所造色。夜摩天宫殿及天处所自然起。现金银琉璃及颇梨柯。四宝所成光明可爱观者无厌。住未有人是诸众生。昔已造业能感可爱胜妙住处。因昔业故能感欲界四大及四大所造色。又因昔业及欲界四大宫殿即成。欲界四大于此宫殿亦因亦缘。宿世所造业但是增上缘。佛言。比丘如是夜摩天处。有因有缘得起得成。本来法然由因缘起。是夜摩住处。一切诸天次第遍满是时夜摩天忆念昔时。世界如人眠觉忆梦中事。如得神通忆宿世事是夜摩天。忆昔世界亦复如是。尔时诸天作是思惟。我今应往案行下界作是念已。互相谓言。我等共去看彼处所余天。答言我今同往。尔时诸天各结群侣。遍满案行咸作是言。昔日此处有须弥山王。是处所中是善见天城。此处是难陀宝池。此处是难陀宝园。此处是质多罗池。及质多罗众车园。此处是恶口池及恶口园。此处是杂花池及杂花园。此处是波利质多罗境水。厚四亿八万由旬。广十二亿三千四百五十由旬。周回三十六亿一万三百五十由旬。极此量住不复更长。此水轮上别有地界名曰大味劫。初感起日夜稍厚转坚。譬如煎乳凝冷之时。厚膏覆上大味地界最初起时亦复如是。是地大界数数起长乃至应至已至应满已满皆悉究竟。厚二亿四万由旬。广十二亿三千四百五十由旬。周回三十六亿一万三百五十由旬。极此量住不复更长。此地下际一亿六万并真金所成。上余八万金银铜铁等七界杂成。是时地界柔软随事。譬如湴泥乳糜生苏及和面等。此地柔软随事亦尔。是地轮中央依众生业增上缘故。四方风吹掘成内海起须弥山。有风运土有风聚成有风方正作须弥形。有风起须弥四顶。开善见城堑起善见城。作难陀池造难陀园。质多罗池质多罗园。众车池园恶口池园。杂华池园波利质多树。及俱毗罗罗园由乾陀海。由乾陀山。伊沙陀海山。佉罗胝海山。善见海山。马耳海山。毗那多海山。尼民陀海山。及四天下中间。洲地掘成州海起铁围山。如是树及拘毗罗罗园。此中昔是般住剑婆罗宝石。此中昔时有善法堂。昔时此中有内大海。此中有游乾陀山及游乾陀海。此中有伊沙陀山及伊沙陀海。此中有佉罗胝山及佉罗胝海。此中有善见山及善见海。有马耳山及马耳海。此中有毗那多山及毗那多海。此中有尼民陀山及尼民陀海。此中有四天下。有中间州地及外大海。此中有灼柯婆罗山。是夜摩天身形最大飞行捷疾。由行疾故击起风轮。由此风轮为那罗延风轮根本。此风数数起长。乃至应至已至。应满已满。皆悉究竟。厚九亿六万由旬。广十二亿三千四百五十由旬。周回三十六亿一万三百五十由旬。极此量住不复更长。此风坚劲物不能侵。若人有那罗延力执金钢仗。拟此风轮仗还自碎风轮无损。次风轮上空中雨水渧如楼大。或如车轴或如车輗。昼夜不息犹如河泻无数千年。是水界聚周围有风名曰摄持。日夜恒起令水不散。如是水界增上未息。此水数数起长。乃至应至已至应满已满皆悉究竟。起成世界宿业所感风力所成。复有余风旋圆而起成。西瞿耶尼及东弗婆提。复有余风四方四角成。北郁单越复有余风如半琵琶成。南剡浮提若风成山。次第正上山则有顶。若风起时或正或傍所成山相。或平或耸。复有风起一边急疾。余边则迟所成。山相一边则凹余边平直。若风起时相击深入还复。更出所成山势有岩有洞。若风相击深入下底不复更出。山里则空由此风故起成诸四天下地。或深或耸有处显现。高八万由旬有处甚深四万由旬。复有别处高四万由旬深二万由旬。复有别处高二万由旬。深一万由旬。复有别处高一万由旬。深五千由旬。或复有处高五千由旬。深二千五百由旬。或复有处高二千五百由旬。深一千二百五十由旬。或复有处高一千二百五十由旬。深六百二十五由旬。或复高六百二十五由旬。深三百十二由旬半。以此因缘一切器世界起作已成。是时二种界起长。谓地火两界风界起。吹火界蒸练地界。风界恒起吹一切物使成坚实。既坚实已一切诸宝种类皆现既显现已天降甘雨渧如楼大。渐细如轮乃至车轴。或如涌泉无数千载。遍满善见城堑那陀池。众车池。恶口池。杂花池。内大海由乾陀海。伊沙陀海。佉罗胝海。善见海。马耳海。毗那多海尼民陀海。四天下中间洲地外大海。以此因缘一切世界水皆遍满。于是忉利天及四天王天。舍上天报于中受生。复有诸天寿终福尽。从上天堕于四天下受人道生。是时诸人喜乐为食依喜乐住。意生化身自然光明。安乐而住飞空中行。是时日月未出于世星宿未有。昼夜不分未辩年岁及四时八节。无男女异。亦无父母兄弟姊妹夫妻儿息。无奴无主。一向受用自在欢乐。未有姓字并号众生。是时水界稍稍就减流向下处。是时大海乍增乍减。开川源路水所减处。有地肥出大甘大味。生长覆地色香触味。可爱具足如细蜂蜜。无苦涩辛地肥大味亦复如是。是时大味馨香充满。时有一人嗅此香味。起欲着心起欲心已。指捻大味嗅而尝之。知其甘美如细蜂蜜搏而食之。余人见其食美无厌相效搏食。是时诸人食地味已。身稍坚重从此以后。不能如前飞行空中。是时身光可爱因此失没。既失光已黑暗还生本来法然。是四天下黑暗覆时。日月二轮乃出。于世日月出已。辰宿次现星宿现已昼夜有分。昼夜分已半月一月是时显现。半月一月既显现已。四时八节及以年岁并皆具足。如是多时世间起成。如是多时六十小劫究竟已度。是时众生食此地味。依地味住久久时节。其中众生食味多者形容丑陋。少威德力少神通力。其中众生食味少者。色形可爱身有威德神力自在。以此因缘一切众生色形优劣。由此优劣生胜负心。由此心故而作是言。我今胜汝汝不及我。是时恶法始行于世。计胜负故地味色香从此而失。是时诸人和合聚集。忧恼困苦发声啼哭。咄哉恶法已出于世。因色形故憍慢毁他。由此恶法失我胜味。不可思议色香触等。是时诸人食余美味作是念言。咄哉似我昔时所食地味。追忆悲恼是语至今皆已忘失。无复有人忆说之者。此味失已复有别味名曰地皮。色香触味悉皆甜美如细蜂蜜。是时诸人皆悉来食。依此饮食长时得住。是中诸人为贪味故。多食地皮形容丑陋。薄威德力少神通。力其中众生食味少者。形色可爱身有威德神力自在。以此因缘一切众生色形优劣。因此优劣生胜负心。由此心故而作是言。我今胜汝汝不及我。由此恶法次行于世计胜负故。地皮色香从此而失

立世阿毗昙论卷第十


佛一百八名赞

    No. 1679

佛一百八名赞

        西天译经三藏朝散大夫试鸿胪卿传教大师臣法天奉　诏译

  归命一切智　　一切世间师
  牟尼大法王　　一百八名号
  无边功德海　　具足众吉祥
  能灭诸有情　　罪业诸烦恼

  我今归命礼　　一切大吉祥
  救度诸群生　　令得大安乐

  我今归命礼　　悲愍二足尊
  圆满于众生　　一切吉祥事
  我今归命礼　　无相无上尊
  成就天中天　　秘密大明义
  如来正等觉　　利乐于世间
  最上百八名　　我今集彼说

南无一切义成就。南无正等觉。南无一切智。南无大释子。南无一切法自在无畏。南无大金仙。南无功德海。南无如来。南无应供。南无善逝。南无世尊。南无一切世间解。南无离一切垢染。南无最上法灯。南无无畏净饭王子。南无甘蔗王种。南无瞿昙。南无日族。南无吉祥大牟尼。南无囕儗啰娑族。南无天人师。南无十力降魔军。南无离过除毒。南无调御丈夫。南无妙解脱。南无除障暗。南无止息降诸根。南无清净戒。南无无垢王。南无灭罪无我相。南无无惊无怖畏。南无第一法圆满。南无无边无可喻。南无大论师。南无希有不思议精进。南无三界亲慈父。南无三明知三世。南无灭三毒。南无具足三变通。南无说三乘菩提。南无无相亦无老。南无无我无二执。南无无怨无戏论。南无无业无怖。南无施愿无畏。南无法师子二足尊。南无调伏除烦恼。南无最上意清净。南无明行足。南无自在变化王。南无调伏心清净。南无离尘无上士。南无止息一切罪。南无得清凉。南无得寂静。南无救度世间师。南无勇猛大清净智。南无圆满吉祥相。南无能除怨。南无沙门月。南无释师子。南无作善清净业。南无六佛法庄严。南无六根清净眼。南无第一六神通。南无六趣海到彼岸。南无无师自然觉。南无善逝德成就。南无一切世间为爱乐。南无无等大智慧。南无恒入三摩地。南无一切有情利益主。南无真实降诸根。南无一切世间尊。南无普遍有情精进者。南无永过轮回苦。南无圆满诸所求。南无降伏得最胜说四谛。南无到彼岸度他大龙王。南无得最上涅槃。南无尊师大梵行。南无第一寂静乐。南无秘密最胜大丈夫。南无调伏声闻者。南无利益诸有情。南无世间供养出世智。南无圣智照世间。南无离世法利养。南无出世为如来。南无大法主。南无大法王。南无调御明。南无救度第一二足尊。南无行忍辱。南无善意端严相。南无善持善戒相。南无金色光善逝。南无善逾爱尊重。南无人师子吉祥云。南无佛陀。南无无畏独除闇。南无无边利世间。南无无等三有师。南无能断诸结缚。南无无我最第一。南无普照一切眼。南无证理净慧眼。南无三慧真实眼。如是一百八名。若复有人。于其辰朝。发志诚心。或读诵。或礼念。或忆持。或听闻。获得最上吉祥福德。所有一切烦恼及诸罪业。速得清净不受轮回。当得解脱乃至成佛

  此大牟尼功德名　　我今读诵及礼念
  普将回施与群生　　同得证成菩提果

佛一百八名赞


福盖正行所集经

    No. 1671

福盖正行所集经卷第一

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

  稽首礼诸佛　　及菩萨圣众
  能以净智眼　　普导于群有
  帝释具千眼　　大自在三目
  及日月光明　　皆不能遍照
  那罗延二目　　变现诸色像
  降伏阿修罗　　恃憍慢嗔恚
  唯佛具智光　　灭恶除积暗
  如以孔雀尾　　拂除诸垢毒
  如来大丈夫　　顶舒白毫相
  七匝右成螺　　润泽极可爱
  日月世灯明　　隐蔽皆不现
  诸天及世人　　咸供养称赞

闻是说已。欲何所作。当于佛言。尊重爱乐。彼智光明。如灯远照。能破愚痴翳障黑暗。是故开示佛之智眼。犹如大云。能注甘雨。如秋满月。能除热恼。毕竟任持诸佛正法。增长一切佛之智慧。决定成就根力觉支。息除业惑二种风浪。不为爱河之所没溺。乘正法船。至于彼岸。于施等行。应善修作。以诸珍宝。持用布施。坏贪过失。增益义利。乐持净戒。读诵经典。如是作已。汝诸比丘。于其福盖。速得圆满

如佛所说。于十善业。何不修作。心为贪使。犹如僮仆。身着快乐。不悟无常。数数追求。无有休息。由愚痴故。而生我慢。于己财宝。悭惜守护。诸来乞者。[卑*頁]面而去。未尝暂于空闲静处。修持净戒。习诸禅定。如佛所说利有情行。汝于是中。无所得也。又此财者。增长憍慢棹举散乱。多起忧恼。生诸怖畏。覆障善道。是散坏法。是堕落法。是无常法。无有主宰。无所归趣。于前后际。俱不可得。现在少乐。刹那不住。犹如梦境。幻化阳焰。乾闼婆城。及旋火轮。如彼芭蕉。中无有实。如水上沫。须臾散坏。愚夫不了。种种希取。以是缘故。多苦少乐。积集一切烦恼根本。是故应当作不坚想。作无常想。如是对治。则不为彼盗贼水火。官吏亲属。之所侵损。亦不为彼琰魔罗王之所吞啖。而于后世。决定成就快乐福报。由以财施。摄诸有情。是人同彼酤牟那花。荣盛开敷。众所乐见。所有积集一切罪障。刹那消灭。犹如炽火。焚其干薪。无有遗余。如于恒河。涤诸垢染。悉得清净。如摩尼宝。随意成就诸来乞者。皆使满足。咸共称赞。是所依止。作胜吉祥。真实功德。美名遐布。离诸过患。寿命长远。广修梵行。则能破坏贪恚痴毒。邪见等咎。乘功德乘。永无堕落。若染污心耽着欲境。造黑业已。如誐摩那娑罗天子速疾迁谢。当知女人。恶露可厌。愚痴有情。争竞贪着。是着欲者。如彼渴人。饮其碱水。心无止足。如断木根。不久枯槁。如山瀑流。不可堤障。如处蛇窟。为彼侵螫。如热铁团。触生苦恼。如食毒果。后必为损。如草泫露。不得久停。如空浮云。倏忽散灭。如沙为城。当亟摧毁。如坏为器。体非坚牢。如帝释弓。不久隐没。如乘破车。动即颠覆。犹如网罗。触则为缚。一切灾难。以为伴侣。是故正士应当舍离

又世尊言。若于五欲。不生贪着。现前获得无量乐报。彼则能截烦恼瀑流。乘正法船。能到彼岸。我于三大阿僧祇劫。积集福行。始能获得丰义味辩。为诸众生。平等开示。汝等当诣空闲静处。于我所说。研究思择。如于乳中。求酥酪醍醐。如是知已。积集法财。及清净物。以用布施。又诸如来。已出三界烦恼淤泥。成就清净无漏胜德。方便开示知足之法。如胜园林。居者清凉。离诸热恼。善修是行。得生梵天。我于是处。一切烦恼。不能动乱。一切怖畏。皆悉断除。以是缘故。破坏轮回。得成正觉

又诸如来。大悲相应。善能降伏一切外道。以清净智。观察拣择。以柔软言。摄受教诲。施以无畏。为说正法。令生信解。破坏魔网。于佛法中。心得安住。是大丈夫。能师子吼。如大龙象。威德特尊。兴大云雷。注甘露雨。无漏戒定。妙香薰修。诸有所作。皆不唐捐。为诸众生。宣说法要。离诸很恼。令众悦豫。如劫波树。敷柔软花。最上法药。蠲除心垢

如世尊说。持净戒者。则有善法。离诸忧怖。得安隐乐。能越苦海。到于彼岸。善破四魔。所语天魔。蕴魔。死魔。及烦恼魔。是人则能吹大法螺。击大法鼓。燃大法炬。心净欢喜。利益一切。教化天人。为作佛事。又诸如来。无量劫中。积功累德。修习智慧。而能成就无碍辩才。四无所畏。十种智力。方便通达菩提分法。能以智箭。破诸魔怨。现证如是诸功德已。于三界中。最为第一。为诸有情。作大慈父

又诸如来。由具十种殊胜智力。化诸外道。而为弟子。于佛智戒。深生乐欲。最初证圣。曰憍陈如。能决愚痴暗钝翳膜。于正法中。最为殊特。曰摩诃迦叶。优楼频螺迦叶。于梵志中。为其上首。服佛法药。愈烦恼病。曰尊者舍利子。能以智钩。制心狂象。有大神力。曰大目干连。具修胜行。蹑正法梯。安处清净解脱楼阁。谓阿[少/兔]楼驮。宾头卢。颇罗堕阇。摩诃俱絺罗。阿难陀等。又能化度频婆娑罗王。于佛法中。深生信解。尊重恭敬。为佛弟子。是诸圣者。皆以智斧。伐缘生树。离诸妄念。希一切智。舍外道见。伏除我慢。悉能成就一切功德

若于四大毒蛇。五蕴空聚。妄为主宰。则无解脱。当以慧剑。而断裂之。又智眼观六处境界。犹如冤贼。十二处等。犹如丛棘。善入解者。不为内外烦恼爁焰之所烧逼。是人则为善持净戒。住忍辱地。得念处分。具智光明。破无明暗。彼则能饮八圣道水。复能开发菩提分花。是能超越三世楼阁。断诸有结。入智慧海。于菩提场。结伽趺坐。善住四禅无漏胜定。受用一切无上法乐

又诸愚夫。坏善法分。乐着世间五欲境界。如风触露。不能长久漂流苦海。不得解脱。见法桥梁。舍而远去

如经中说。昔婆罗门有一长者。欲以利剑。害彼女人。忽睹如来。高声唱言。愿佛救度。即得解脱。又如央崛摩罗。欲害母等。又能降伏长爪梵志。起大我慢。令入佛法。餐正法味。亦令一切愚痴之人。闻是说已。舍除憍慢。亦如恶龙。心怀热恼吐猛毒气。损伤苗稼。又如夜叉以恶眼视百千众生。而为损害。如众商人。没于大海。为底弥鱼。欲即吞啖。如是恐怖。诸恶险难。唯除如来能为救度。又如日月怖阿修罗。帝释天主怖堕恶道。梵王异执。计我为常。诸如是等。不真实见。轮回往来。受诸逼迫。使闻正法。咸得悟解。饮解脱味。破无明[聲-耳+卵]。彼智光明。如月清净。是故当于如来言教。深生尊重。亲近法师。乐闻正法。究真实义。如教奉行。彼外道教。是轮回法。诸有智者。当善思之

又牟尼尊。说甘露法。为智光明。破诸痴暗。如处高峰。俯视群物。积聚非法。如堆粪壤。当以智锸。而屏去之。摧诸魔怨。破诸异论。令入解已。发生智心。皆得遣除身心热恼。一切罪恶。皆得消殄。彼牟尼言。如盖广荫。蔽烦恼日。而获清凉。若能彩画造作佛像。以香花鬘。随分供养。乃为生天之阶渐也。依佛言故。所有业障。刹那清净。禅定解脱。皆得现前。非如外道。一生虚掷。无所修作。起邪妄见。依恒河水。洗求解脱。如是知已。应当勇猛越魔境界。执持慧剑。破烦恼贼。坏生死轮。裂缠盖网。具净智眼。灭诸痴暗。息贪爱心。降嗔毒蛇。断诸邪见。摧我慢山。于佛生处。爱乐尊重。散娑罗花。而为供养。如意所求。皆得成就。离诸毁谤。解脱诸怖。安住诸佛真实正理。离生灭相。得寂静乐。应当一心乐欲闻法

如是我闻。一时佛住舍卫城。祇树给孤独园。是时众会。有二外道。曰迦毗罗大仙。乌嚧迦大仙。舍本邪见。入解佛智。善除痴暗。能越苦海。作是思惟。云何如来成就清净广大福盖功德乃尔。殊妙色相。如镕真金。巍巍挺特。犹若须弥。三十二种大丈夫相。及八十种随形妙好。显现分明。端严无匹。一切尘垢。所不能染。现丈六身。光明晃耀。尽虚空界。若幽若显。无不遍瞩。目如广大青莲花叶。眉间毫相。如秋满月。其面光泽。微妙可爱。发绀青色。如孔雀尾。顶相平满。如天帝盖。清净肉髻。如摩尼宝。举身金光。灿然相照。一切众生之所乐见。譬如群蜂采妙花香。一一相好。观无厌足。如春开发拘苏摩花。是时如来。如彼外道心之所念。以净智眼。观彼无量无边世界一切众生。生大怜愍。而告之曰。汝善男子。我于三大阿僧祇劫。修习无量清净正行。积集广大无边福智。非以少因。而能获得。安住无尽功德宝藏。以大悲心。决定拔济无量百千地狱众生。离冤亲想。咸令息苦

福盖正行所集经卷第一福盖正行所集经卷第二

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

尔时帝释天主。首戴摩尼殊妙宝冠。从忉利天。来诣佛所。见佛身相。众德庄严。心大欢喜。得未曾有。头面敬礼佛世尊足。以大妙音。称扬佛德。若诸众生。睹佛相好。发希有心。供养恭敬。尊重赞叹。则能破坏四种魔业。成就义利。获大吉祥。汝等天人。及诸魔梵。皆当至此。觐无上尊。是时有诸持明大仙。日月天子。及诸宿曜。水天。火天。多闻天。焰摩天。大梵天。力坚天。那罗延天。钵啰[口*女]摩那天等。及诸龙神。夜叉。乾闼婆。阿修罗。迦楼罗。紧那罗。毕[(匕/示)*(入/米)]多。毗舍遮。塞健陀等。如是众类。皆共一心。供养礼拜赞佛功德。是出世间。第一智慧。广大名称。靡不闻知。舍利弗等。诸大声闻。皆不能了彼智境界。自苏弥卢顶。至色究竟天。一切有情。咸共谛观如来。应供。正遍知。明行足。善逝。世间解。无上士。调御丈夫。天人师。佛世尊。其所说法。言无虚妄。初中后善。其言巧妙。其义深广。能破寡闻无智众生愚痴暗钝。令彼闻已。生大觉悟。乐修正行。增益慧命。决定得免恶道怖畏。能辟涅盘广大城门。入不思议解脱境界

此经中说福盖先因。云何了知。闻是说已。广行净施。坚持禁戒。于世欲乐。不生爱乐。诸有善利。咸生信顺。如是修作。速得成就。譬如有人。于夜暗中。持大炬火。入大舍宅。于彼方处。皆得明见。是中所有珍宝库藏。种种什物。若精若粗。各各显现。悉能受用。获安隐乐。若复有人。于此经中。受持读诵。乐闻深义。亲近法师。如理思惟。心生觉悟。当知是人。能于生死长夜之中。秉大智炬。入涅盘城。于甚深法若理若事。悉能了解。咸得通达。离诸疑惑。破诸痴暗。出离轮回。心得解脱。而能受用无尽法乐

如世尊说。有漏世间。不生胜慧。唯正智灯。能破痴暗。是故智者当求出世无漏正法。于佛所说契经论议相应教法。应善观察。如诸有情。造福非福。各受彼报。定无差忒。当知世间。皆因缘生。若无众生。则无烦恼。若无烦恼。则无地狱。是故我今说因缘法。非如外道邪执异见。无因无缘。生一切法。彼计棘刺铦利。何人所削。禽兽羽毛。谁为彩绘。是事显然。何假因业。由此了知。世间所有。出于自然。不须修作。如来知已。起大悲心。怜愍教化。以智光明。灭彼痴暗。渐令悟入一切智智。舍本邪见。于佛法中。心得解脱

此经中说。佛所教诲。说施等法。能出轮回。得诸快乐。现见世间诸有情类。造福非福。受苦乐报。如给孤独长者。发净信心。以三十俱胝金银珍宝。奉施如来。及诸弟子。阿[少/(兔-、)]楼驮大阿罗汉等。造立精舍。兴大供养。现生获得无量福报。具大名称。安隐富饶。种种帑藏。悉皆盈溢。亲属朋友。奴婢仆从。广多炽盛。皆得圆满。受用无尽殊胜快乐。斯由施故。感报如是。又诸如来。大悲怜愍一切众生。如世医王。能以良药。善疗世间风癀痰癊。种种诸疾。使令除愈。如来亦尔。善说法药。能祛众生根随烦恼。令得解脱。然彼有情。无善种子。无有资粮。不发勇猛。不求解脱。三毒痼疾之所缠缚。如是之人。难可化度。是故如来。平等大悲。无冤亲想。授与法药。使之服行。为说布施持戒等行。常当受持甚深经典

又彼人身。极为难得。譬如盲龟。遇浮木孔。勤修十善。求离苦际。纵得人身。不生中国。诸根不具。或于佛法。心不爱乐。或复生彼无佛世界。或由恶业。受喑哑报。口不能宣诸佛正法。于佛功德。不能了知。又诸众生。愚痴所覆。邪见惑心。背善知识。坏正法船。摧法宝山。伐智林木。逃解脱城。辟三恶道。不能入解净心信索。不能建立真实法幢。则为焚烧天中宫殿。积聚世间广大珍财。自恃豪富。起大我慢。无智愚痴。不善观察。不修惠施。亦不受用。为彼悭曜之所执持。不悟此身。老病死苦。常所随逐。造诸恶业。不能发露。彼盛年时。色力充实。身形光泽。濯去诸垢。常生爱乐。及其衰老。身肢颤动。皮肤缓皱。多生黑点。唇口干焦。气息喘迫。发白稀少。牙齿疏落。体生疮癣。肌肉消瘦。诸根暗塞。筋急拘牵。头足相近。行步迟留。一切身分。犹如执缚。意欲所至。须假扶掖。歌舞嬉戏。不复思惟。上妙美味。无复能食。设欲饮啖。喉不能咽。目视文字。不能辩了。意欲所嘱。言不分明。出入息微。气不相续。涎涕流落。便利污身。腹胀绞痛。呻吟远彻。唯有皮骨。偃卧在床。面现丑状。生大恐怖。是时有风。触肢节间。犹如针刺。痛不可忍。一切医师。舍之而去。无量忧恼之所烧煮。一切爱乐悉为他有。一切珍财。咸尽弃舍。如霹雳火。破坏无余。无所觉知。奄然长逝。刹那变异。令人怖惧。父母妻子。内外亲属。悲哽流泪。心腑痛裂。迭相号呼。舍我何去。于彼他世。独一而往。犹如幼商无其侔侣。入大黑暗。趣大险难。堕大深坑。没大苦海。无归无救。无所依止。琰摩使者。黑夜母天。怒目利牙。丑状可畏。愤怒叱责。絷缚而去。其疾如风。至琰摩所。生不崇善。死归苦处。无量锋刃。从空而下。斫刺身分。断坏肢节。剖心割舌。血肉交溃。手足指节。截而弃掷。唯有筋骨。连持不散。受大苦恼。寻即闷绝。业风所吹。倏尔还活。长时受苦。业尽得脱

若诸众生。信顺佛语。乐作福业。利益安乐一切众生。随其所须。而能给与。于寒冻者与其炎燠。于烦热者为作清凉。于渴乏者汲以清泉。于饥餧者施之饮食。溺河流者济之船筏。无居止者给其舍宅。于贫穷者赐之财帛。于诤讼者劝令和顺。于独行者为作侪侣。于病苦者示之良药服令轻安。为蛇螫者真言加持消除其毒。恃我慢者授以智剑令自调伏。各悉令得安隐快乐。若能如是。利乐众生。现在即得如意福报。于他世中。唯此福业。为其伴侣。为归为救。为所依止

若诸众生。惯习悭业。于胜福田。不能惠施。设佛弟子如优波离。来化彼人。心亦不喜。不信施福。能招乐报。集积罪恶。后受轮回。设得为人。生下劣族。或屠杀家。或除粪家。造车。作[疊*毛]。捕鱼。窑师。耕夫。织者。作剃发人。染浣衣人诸不善处。衣食弊乏。为他役使。手足皴裂。多苦多求。日无少暇。复为诸病之所缠缚。疥癞。疮癣。痔瘘。痈疽。嗽疟。泻痢。癫狂。热病。如是等疾。逼恼其身。羸瘦憔悴。手足挛躄。唇口喎斜。头发髼乱。两目流泪。下色求人。着破弊衣。拖挽而进。或复遗弃。亦不觉知。为风所吹。形体裸露。坐卧粪壤。犹为自娱。自拔其发。殊无惭耻。语往来者。顾我何为。或持破器。遍经里巷。得少残食。以自活命。百千蝇虫。竞来丛唼。内外垢秽。众所恶贱。由不善因之所招集。自作恶行。复教他作。是人则为苦恼之藏。是故世尊常以大悲。怜念一切。使令发心。决定悔过。速令解脱诸恶过患

此经中说。唯自修作正行福业。能招人天富乐胜报。是故比丘。受持此经。为人演说。如说修行。则令自他福盖成就

尔时世尊住王舍城。迦兰陀竹园。时提婆达多。极大愚痴。以恶毒心。损害佛法。为作百千障碍留难。不能动乱佛一毛端。即时语彼阿阇世王。当出严敕。宣布城中。不得一人往诣佛所。及以饮食。而为供养。当知瞿昙则无所得。必当舍此。远适他国。王闻是说。信而从之。时彼城中诸优婆塞。知是事已。咸曰。苦哉。今王舍城。无有主宰。如来出世。难得值遇。如优昙钵罗花。云何大王信受邪师。不听我等往诣供养。不许如来摄受我辈。尊者阿难陀。闻是语已。即往白佛。佛语之曰。我豫知已。奚必轸虑。于我法中。未尝有一声闻弟子。有所阙乏。况我身耶。时佛世尊。放大光明。照王舍城。皆令清净。触斯光者。身心泰然。是时帝释睹佛光明。以天眼观。知其所由。发大勇猛。现大威德。为大檀越。兴大供养

福盖正行所集经卷第二福盖正行所集经卷第三

        龙树菩萨集

        西天译经三藏朝散天夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

尔时帝释天主白佛言。世尊。唯愿安住此王舍城。我当供给饮食衣服。卧具医药。令无所乏。佛言。天主。且止斯事。有诸人民。以清净心。咸欲于我兴其福业。是时帝释复白佛言。唯愿于此。五夏安居。受我供养。作是说已。佛复止之。帝释复言我今请佛。五日供养。唯愿大慈受我虔请。尔时世尊。愍恻天主。现福力故。令于未来。善因相续。默然许可。于时帝释知佛受请。心大忻悦。即还天宫。召集工巧敏匠天子。而谓之曰。卿等当知。我今欲于王舍城。迦兰陀竹园。建大精舍。严办四事。供养如来。及诸弟子。汝当持取最上摩尼。金银琉璃。珊瑚玻[王*(黎-(暴-(日/共))+(恭-共))]。帝青宝等。诣彼造作殊胜清净广大宫殿。要如天中。等无有异。是诸天子尽意工巧。造立宫殿。廊庑柱栿。户牖栏槛。悉以众宝。间错庄严。如千日光。更相显照。复以雕饰诸妙珍禽。真珠花鬘。综杂罗列。烧微妙香。散众名华。氤氲普薰。靡不周遍。又复造作重门楼阁。峻峙严丽。亦以百宝。而装校之。诸妙摩尼。以为其户。彼诸宝柱。一一皆用金刚诸珍。而共合成。无数宝鉴。净无瑕垢。悬挂空中。如百千月。复以镕金。作三足床。殊妙天衣。以敷其上。又复刻成众妙天女。容止端雅。如能往来。手持莲花。而以奉献。妙玻[王*(黎-(暴-(日/共))+(恭-共))]宝。以甃其地。有妙池沼。莲华庄严。黄金为叶。绿宝为干。无数天女。住立其中。作众伎乐。而为供养。表刹高显。悬众缯幡。回旋空中。远迩皆睹。有诸力士。守护闬闳。持青宝杖。行列左右。处处皆植曼陀罗华。龙自在华。芬馥开荣。缤纷于地。翠叶交映。时飘香风。有诸天子。形体光洁。颜貌熙怡。游憩其下。又诸天女。姝妙无比。徐步鸣珰。声韵和雅。诸药叉女。嬉游林内。美目四盼。遗花坠香。有诸龙象。徐行林中。举鼻啮枝。宛转为戏。及诸飞禽。其羽五色。鼓翼自若。喙啄花葩。复以金笼。置妙鹦鹉。美音清巧。其舌如簧。复有河源。清泠可爱流泉激响。蛙黾惊避。又有广大清净池沼。七宝杂厕。以为阶岸。其水弥满。澄湛无垢。优钵罗花。酤牟那花。行列开敷。众色相杂。翡翠鸂[(來*力)/鳥]。翔集其中。有诸戏鱼。往来游泳。腾跃翻浪。鸥鹭惊翥。复有水鸟。鹳鹤[梟-木+儿]雁。举声嘹唳。人所乐闻。于池四岸。有劫波木。柔条拂水。生清凉风。丛植诸花。修藤滋布。枝叶繁盛。其香远闻。有诸游蜂。竞采其蕊。发声微响。犹如咏歌。复有金河。周匝围绕。流注园囿。萦纡不绝。时诸人民。迭相呼吁。亲属朋友。咸共往观。有诸仕族。富乐庄严。仆从雍容。执持幰盖。作诸伎乐。具设肴膳。游行周览。心无厌舍。其地柔软。如兜罗绵。徘徊往来。足无疲惰。如是最胜广大园林。清净池沼。唯除天中余无及者

是时工巧诸天子等。所作已办。即诣天宫。前白帝释。闻是说已。心生忻庆。得未曾有。即与无量百千天子。前后围绕。作众伎乐。箫笛箜篌。琴瑟鼓吹。一时具奏。从空而下。时彼天主。身出光明。照诸山川。皆悉盈烂。戴摩尼冠。诸珍严莹。其光晃耀。如日盛明。面貌端严。额广平正。其目绀长。鼻修高直。颐颊鲜白。红润无比。耳带宝珰。颈垂缨珞。指环臂钏。众宝所成。展转舒光。其犹珂月。形仪挺特。常如盛年。修短充实。各得其宜。公酤摩香。及多摩罗跋旃檀香。以涂其身。柔软光泽。手指纤圆。甲如铜叶。发语巧妙。清彻远闻。如迦陵音。听者无厌。复以上妙奇绝细[疊*毛]。研金饰之。以为其服。诸妙珍琦。为其束带。众宝间错。成光明聚。复以天上诸妙花鬘。以严其身。周匝垂委。行步平正。犹如象王。进止优游。不假扶掖。时诸人民。咸获瞻奉。怀嗔恚者。即生欢悦。起怨恶者。即发慈心。愖睡眠者。即得惺寤。是时天主至彼园已。遍观所作。皆悉如意。踊跃无量。乃易旧称迦兰陀。名为欢喜园。即以上妙众色茵褥。遍覆其地。复以金银。真珠摩尼。帝青琉璃。末啰迦宝。为高广座。请佛世尊。安处其上。众宝为几。以承其足。五色缯线。设为众位。命诸比丘。亦各就坐。是时天主合掌恭敬。尊重赞叹。顶礼佛足。具设天中上馔美味。是时如来舒金色臂。如象王鼻。而受其食。食已置钵。盥掌澡漱。安住威仪。寂然清净。时彼天主。与诸眷属。生希有心。乐欲闻法。自处卑座。专注肃然。尔时世尊。以大方便。为说法要。赞施等行。示教利喜。令生信解。如是供养。经于四日。时阿阇世王。闻是事已。即升宫中最上楼阁。俯视谛观。见佛世尊。及诸弟子。在竹林园。寂静安隐。严设供养。作大佛事。是时国王。心生觉悟。悔过自责。我大愚痴。无智错谬。造极重罪。如须弥山。今佛世尊。出现于世。具足广大清净功德。而我不能信受教诲。由此业缘。必堕苦处。彼诸天子。尚舍天中上妙欲乐。来诣佛所。我等云何不兴善利。作是语已。即严宝驾。往诣佛所。头面礼足。心怀忧恼。涕泪悲泣。忏谢先咎。时王舍城清信士女。高声唱言。善哉国王。于佛法中。得大觉悟。我等今者同获善利。是时国王鸣钟宣令。召集一切大臣人民。及诸眷属。而告之曰。我佛出世。难得遭[這-言+((口*口)/?)]。今既获睹。当发净心。供养恭敬。乐闻正法。即以上妙香花灯明。涂香末香。及诸花鬘。珍玩衣服。种种庄严。而为供养。作是事已。心大欢悦。是时如来以梵音声。为彼时会。开示演说苦集灭道四圣谛法。无量人天。闻法解了。得真实见。时佛世尊。问诸比丘。汝等见是诸天人民。今于我前。广大施设供养已不。时诸比丘。合掌顶上。叹未曾有。唯然已见。佛言。于我法中。若人净心。于他福业。生随喜者。当知是人得不坏信。具净智眼

诸比丘。我念往昔无量生中。有佛出世。名曰宝山如来应供正遍知明行足善逝世间解无上士调御丈夫天人师。佛世尊。住世说法。饶益众生。尔时有王。请彼如来。及诸弟子。于王宫中。度夏三月。即以种种饮食衣服。恭敬供养。过是已后彼诸人民。咸诣佛所。请佛五年。设诸供养。一切所须。无不充足。诸比丘。于意云何。往昔国王供彼佛者。则我身是。由曩植因。今方成熟。得诸人天广兴供养。宿因今果。不差毫发。由因感果。果如其因。于此正知。除诸疑网。善恶业报。决定不虚。犹如瀑流。势不可制。彼业力故。各招其报。地界水界。火界风界。及蕴处等。自作福因。则受乐果。于时世尊说伽陀曰

  经于百千劫　　彼业不可坏
  因缘和合时　　果报决定受

诸比丘。是名福盖正行。汝当受持。勤修施戒。及诸禅定。受用福盖。得离热恼

此义略明先佛所说。结集契经。缘起行相。最初经首。标其如是我闻之言。由何所以。称如是耶。如佛所说。无别异故。何义名我。指现在身。顺世俗故。何义为闻。谓耳发识。现前了知若文若义。离于增减颠倒失故。最初结集。谓梵网经。是时众集。大阿罗汉。数有四百九十九人。唯除阿难独居学地。及余一切天龙鬼神。初闻唱言如是我闻。举声悲泣。不能自胜。我等在昔。亲睹世尊具足十力。四无所畏。以梵音声。为众演说。如何今者乃称我闻。将知无常。力不可脱。时彼众会。皆得觉悟。离三毒垢。安住正念。任持不忘。何义称一。乃数之始。谓一圣生。一出离法。一游止处。一净梵行。一解脱音。皆悉同故。何义名时。依世俗立。说经事已。大众喜怿。名为一时。如来说法。如日照世。破三有暗。今出离故。诸魔外道。毁谤正法。今佛显现甚深希有难得之法。令降伏故。何义称薄伽梵。具足殊胜广大名闻。世出世间。无与等者。毕竟超越界趣轮回。应受人天妙供养故。云何舍卫城。丰诸妙物。及文行士。清信士女。豪富长者。受用胜故。何义名住。游化依止。离诸思构。若远若近。随意至故

福盖正行所集经卷第三福盖正行所集经卷第四

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

以何义故。名只陀林(华言战胜林顺古不译也)。昔胜军王。与其邻国。斗战获胜。当于是时。诞生太子。乃以战胜。而立名焉。林属彼故。称只陀林。富贵自在。无量庄严。一切人民。咸悉喜见。于此林中。广以人财。营治守护。为嬉游处其林稠密。枝叶郁茂。清阴弥布。蔽诸炎光。夏多清凉。冬无严风。雨无泥淖。奇蘤芬馥。周遍开敷。樛枝偃亚。其状如盖。多诸警卫。无闻盗寇。其地清胜。侔欢喜园

以何义故。名给孤独。于无亲者。施与饮食。而周给故。如毗奈耶藏中。广明其事。由彼长者宿善根力。欲请世尊。供养恭敬。先与如来。造立精舍。即以百千俱胝黄金。为其价直。于太子所。贸易其地。既遂其志。召集诸方一切奇巧。造作最上宫殿楼阁。门轩户牖。流泉浴池种种庄严。皆悉具备。崇峻垣墙。周匝围绕。于是长者诣王舍城。顶礼佛足。而作是言。我今请佛。诣舍卫城。唯愿如来。大慈允诺。彼有伽蓝。广大清净。及诸弟子。同往安居。是时长者。白已而还。时王舍城。有一长者。其名善寂。白世尊言。不须往彼。我当与佛。造立精舍。佛即止之。时佛至彼舍卫城已。长者乃以所造伽蓝。奉施如来。哀愍彼故。佛即受之。复为称赞彼地方所。最上吉祥。第一安隐。过去诸佛。亦于此地。利益安乐一切众生。汝于先佛。久植德本。由昔愿力。今复如是。时有外道。名摩多唧致那。居止草庵。修习苦行。于诸世间一切众生言论智慧。皆悉通达。谓只陀林。最上殊妙。极诸奢丽。云何世尊。及诸比丘。而得受用。佛知是已。以大方便。怜愍彼类。而语之曰。我诸弟子。得尽苦际。善达出世经律论藏。断烦恼故。于是世尊为彼外道。说伽陀曰

  汝虽如大龙　　尚为贪所染
  于赞毁二种　　则为彼所动
  身若有众疮　　飞蝇则随逐
  循环三有中　　如虫居粪壤

时彼外道闻佛说已。心生悟解。以偈赞佛

  如来出世间　　慧日破诸暗
  况我微劣智　　何由得悟解
  设于多劫中　　复以百千舌
  称赞佛功德　　少分不能尽
  佛为天中仙　　知众生诸行
  于四威仪中　　唯利乐含识

时舍卫城。多诸外道。及婆罗门。聪睿智者。闻佛至此。竞来诘难。如来方便。随宜为说。如师子吼怖诸群兽。悉令了悟。离诸痴暗。时有智者。名罗护罗。闻赞佛德。而说偈言

  大悲无上尊　　专修利他行
  不求世名闻　　及增长财利
  初降生王宫　　于四方瞻视
  现微笑思惟　　皆为度群有

是时复有妙臂童子。亦说伽陀。而赞于佛

  牟尼尊大仙　　善说诸法要
  离过无希望　　闻者皆蒙益
  诸天及世人　　咸供养恭敬
  归命十力尊　　唯愿见摄受

此只陀林。给孤独园。由五种因咸生爱乐。一者广博居城中央。二者比丘乞食不远。三者幽寂离诸喧闹。四者清洁无诸蚊虻。五者善人多游其中。是故世尊。多乐居此。住如实智。离无惭行。一切功德。依止显现。具足十力。福智庄严。为彼世间第一导师。故能成熟众生善根。犹如莲华出于淤泥。自利利他。悉圆满故

时胜军王。并诸人民。及诸外道。婆罗门等。皆悉往诣祇园精舍。合掌志心。顶礼佛足。时佛世尊。怜愍摄受诸有情故。破诸异见。令生信解。由不善因。驰流五趣。当依正法而求出离。为彼宣说六念之法。善男子。于我法中。信受教诲。具诸正见。是名念佛。若乐广大听闻正法。如理思惟。是名念法于诸比丘。常生尊重善知识想。是名念僧。于诸善法。爱乐摄受。具足威仪。是名念戒。常以饮食。施佛及僧。住如是因。是名念施。常乐礼敬诸大菩萨。随顺佛敕。名念贤圣

若诸众生。依佛所说。住正思惟则除疑惑。依止正念。则无散乱。是为六念。生长诸善。以何义故。名为比丘。谓能永断诸烦恼故。所有世间生苦。老苦。病苦。死苦。忧悲苦恼。五取蕴苦。求不得苦。爱别离苦。怨憎会苦。如是诸苦。皆已尽故。此明世间五取蕴苦。作如是说

何义名生。如世尊说。彼彼有情。造种种行。招感命根。蕴处界等。展转相续。五根发生。五根生故。众同分生。由是增长。形色圆满。是名为生

何义名老。如世尊说。行蕴迁坏。诸根衰朽。身形伛曲。肌肉枯槁。皮肤缓皱。多生黡点。举止沉重。行须倚仗。疲乏无堪。假人守护。如是老相。此有二种。一者须人承事。二者无所依怙。是名为老

何义名病。如世尊说。四大增损。界不平等。犹如毒蛇。生诸苦恼。此有二种。一者内所发起。二者外缘损害。复有三种。一者业报所招。二者横难侵损。三者为他咒诅。委细分别。有无数种。谓风癀痰癊。疥癞痈疽。嗽泻热毒。羸瘠疼痛等。是名为病

何义名死。如世尊说。谓彼有情。舍众同分。诸蕴散乱。暖触渐微。命根断灭。此有二类。一者自尽。二者往诣。初复有三。谓命根虽尽。其福未尽。或福虽尽。其命未尽。或命与福。俱时而尽。二者往诣亦有三种。一者自往(捕猛兽等)。二者他诣(被劫掠等)。三者自他相遇(如斗战等)。复有三类。一者放逸。二者毁戒。三者报尽。由放逸故。断其慧命。由毁戒故。破诸威仪。由报尽故。内外眷属。围绕悲恋。不能舍去。是名为死。云何名忧。内心愁戚。如火逼切。亦如炎日。炙水如汤。是名为忧。云何名悲。涕泣流泪。哽咽难言。如其孝子追念慈父。及余亲属。一切皆然。意不寂静。是名为悲。云何为苦。碜辣荼毒。与乐相违。同五识身。相应领纳。是名为苦。云何为恼。譬如枯木。中以火烧。令彼有情。烦惋懆扰。与意识身。相应领纳。是名为恼。云何名为求不得苦。谓于所求诸相应事。未得如意。心生疲极。如陶家轮。此心随转。云何名为爱别离苦。于所乐境。相应眷属。所有色相。刹那变异。云何名为冤憎会苦。谓于一切非相应人。互生嫌恶。而返值遇。此中所说生等次第。展转推求。皆为热恼。如旷野鹿。被火围绕。不能自出。必为所焚。唯除如来初降生时。增长善法。寂静安隐。体性自然。离诸热恼。如契经偈云

  诸佛出世乐　　演说正法乐
  众僧和合乐　　令修诸善行
  若佛不兴世　　三界何有乐
  由佛出现故　　我等获安乐

由诸有情。不善种子。以为其因。而能生长苦树境界。常为三毒苦火所烧。于彼世间富乐等事。但闻他说。何由识知。驰涉旷野。险难恶道。砂砾荆棘。受诸艰辛。以乞自济。无所归趣。如是有情。宿乏善本。沉溺恶道。轮转无穷。如俳优者。易其形色。设得为人。生贫穷家。于母胎中。受种种苦

云何有情处胎藏中。受诸苦恼。如世尊说。初结生时。揽其父母赤白二物不净为缘。渐次增长。成其形质。居生藏下熟藏之上。处其中间。极恶臭秽。母或饱食。或时饥渴。身肢动转。及染欲事。皆受其苦。又将产时。于母胎中。不乐居止。起不净想。回趣生门。二手乍触胎子身分。受大苦楚。极重热恼。彼初生子。由饥渴故。发声啼哭。向母求乳。又其乳者。转血所成。或食不充。受其热恼。渐为婴儿。卧于便利。或时戏剧。坠于沟坑。此名生已所受热恼。余世间人。亦皆如此。又彼有情。年渐长大。色力充满。憍恣放逸。念念追求五欲尘境。由染慧故。耽着不舍自任其情速至于毙

云何衰老所有诸苦。形色羸瘦面颊凹戾牙齿疏缺发毛稀白颈臂胸胁悉皆骨现火力渐微饮食薄少。犹如飞禽。置于笼内。日渐消瘦。唯一毛聚。朝有所作。暮即废忘。初欲施为。后则懈退。言如小儿。无有期度。或时终日。口不欲语。于昼夜中。唯务睡眠。纵眠不寐。喘嗽无时。欲说所苦。言不明了。如远行人。不乐久住。诸有所作。难可如意。小不称心。则生悲恼。亲友慰谕。宜自安怀。目视境界。不能受用。诸快乐事。但耳闻说。意欲游行。足不能动。唯假几杖。以为其伴。为诸女人之所轻笑。因念昔日诸根康愈。受诸欲乐。刹那变坏。深自悔恼。久活何为。是名衰老热恼行相

云何病苦所有热恼。谓诸愚夫盛年壮色。放逸着欲。渐成怯弱。萦缠痼疾。众苦现前。善人睹之。深生怜愍。善言诲诱。使其发露。闻已忧怖。恐堕恶道。形貌端正。病所侵夺。上妙饮食。不能餐啖。虽处豪富。如贫窭者。世有智人。常自省察。当知病苦。不可爱乐。如雹损苗。顿伤荣盛。如陆地龟。常思其水。如白昼月。无彼光辉。如渴乏人。堕其枯井。如油尽灯。不得久住。如腐墙壁。无有坚牢。如痴騃童。人所轻侮。如彼狂象。坏莲花池。是名病苦所有热恼。如何愚夫。数数贪着。减损寿命。焚毁善根。无明所覆。邪命邪求。贪彼世间饮食衣服。身漏心漏。破坏正智。不乐依止寂静山林。受持读诵大乘经典。不能坚固护持净戒。何由能趣菩提彼岸。若心寂静。弃背欲境。或先所作。诸放逸行。皆悉厌患。不复思惟。犹如深冤。心不乐见。如甘蔗滓。不可再味。如焚枯枿。令尽无余。如是觉了。是人不为琰摩罗王之所逼切。又诸女人。多诸贪很。心怀怨嫉。乐为主宰。犹如漏瓶。贮其不净。如牝马藏。深可厌恶。如以毒药。和其美膳。如冤执剑不应俯近。如彼火聚触生热恼。若乐欲境。心则错乱破诸梵行。如无戒者。断其乐因。丧失慧命。死军现前。独一而往。趣彼险难。无能救者。皆由染欲。生诸妄念。无惭无愧。舍知足行。为世间人种种讥谤

云何名死。如有颂云

  慧为最胜眼　　痴为极重暗
  病必由其冤　　死称第一怖
  当意乐正法　　以慧善修作
  是故命终时　　决定离险难

是名为死所有热恼

福盖正行所集经卷第四福盖正行所集经卷第五

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

复以何义。说名为忧。谓诸有情。由贪欲故。没忧怖中。犹如猛兽。被火围绕。如深渊鱼。置之陆地。如入大海。损其船筏。深心愁戚。恐失身命。如以少水。滴热铁团。将入死门。命不久住。譬如釜中煮豆。弥满腾沸。复增干薪。彼世间人。身处于家。为忧逼切。诸根衰悴。心无暂安。如以酥瓶。近于炎火。当知不久。则为消坏

复以何义。说名为悲。谓诸有情。先有珍财。不能任持。身复懒惰。以致贫苦。身形裸露。容色憔悴。咽喉干焦。言意凄切。念昔富饶。不复能得

复以何义。说名为苦。谓诸有情。造非法行。身触宪网。刀杖毒药。或为非人斫刺残害。乃至断命。受诸楚毒

复以何义。说名为恼。谓诸有情。恶言相加。如中毒箭。诸根烦扰。失坏乐想

复何名为求不得苦。或诸有情。乐习正法。不能入解。身心劳苦。或由放逸。多求不遂。发生热恼。无欲无求。心则安隐

复何名为爱别离苦。谓于所乐眷属朋友。和合欢慰。忽尔离散。心怀恋慕。而生热恼

复何名为冤憎会苦。谓彼有情。乐着贪欲。多求财利。互相侵竞。而结深冤。或为妻子恩爱缠缚。犹如桎梏。不得自在。当知女色。使人惑乱。其语柔软。如拘牟那花。愚夫嗜之。销除壮色。不久枯悴。如乔答摩仙。乃至诸天。多着欲乐。如薪近火。必为所焚。是故比丘。常当远离。若近彼欲。得第一苦。一切世间。诸天及人。皆为欲火普遍逼迫。现招众苦。死堕恶趣。为彼十三广大火聚。围绕烧然。佛为世间众生慈父。怜愍彼故。而说此经。所谓地狱。有十三种。一者等活。二者黑绳。三者众合。四者号叫。五者大号叫。六者烧然。七者极烧然。八者无间。九者煻煨。十者尸粪。十一者锋刃。十二者剑林。十三者灰河。如是地狱。诸恶险难。无量苦恼。聚集其中。无数有情。造诸恶业。命终入彼。受多种苦。为诸狱卒。种种治罚。以热铁锤。忿恚而击。形体碎烂。周遍流血。诸骨节间悉皆火然。复捉其足。掷入火坑。举手忙乱。恶声号哭。彼琰摩卒。极恶可惧。诸受罪人。见即惶怖。或复趁入煻煨狱中。皮肉筋骨。下足消溃。由恶业故旋踵还生。复有深广极热尸粪。臭不可闻。有铁觜虫。名酤拏波。往来其中。啮罪人足。彻肉穿骨。取髓而食。复以无数铦利锋刃。次第排列。而为其路。逐彼罪人。以足履践。复为猛风。吹走其上。由避其苦。入剑叶林。无数剑锋。从空而下。斫刺其身。无不断坏。复有大河。灰汁盈满。波浪涌沸。煮彼罪人。于其两岸。有诸狱卒。执三戟叉。往来叉刺。受极重苦。或时闷绝。亦有藏窜。如鱼沉泥。即以铁钩。挽唇而出。以大铁网。摝置热地。大火猛焰。翻覆烧烙。复以铁钳。擘开其口。即以铜汁。逼以灌之。或热铁丸。驱令吞啖。龂齶喉舌。各各焦烂。从咽彻下。悉为所烧。复有两石。以夹其身。自首至足。而锯解之。狱卒暴恶。犹如醉象。怒发冲直。火星四迸。驱彼罪人。卧铁床上。以线抨之。或斸或凿。火焰四起。唯闻号哭。复有山峰。从空而坠。击彼罪人。身肢俱碎。闷绝躄地。良久乃苏。有诸狱卒。其状丑恶。或执利斧。椎棒刀轮。弓箭杵炮。热铁器杖。种种苦具。考掠罪人。复有百千猛焰火刺。从四方来。丛集其身。如燃杌木。悉皆焦烂。复以利刀。而取其舌。或斫或剉。为百千分。乃至所有一切身肢。倏然分散。犹若浮云。复置罪人热铁瓮中。炽火四逼。其汤沸溢。上下漂沈。犹如煮豆。身体胀裂。皮肉消尽。唯余骨锁。捞摝于地。业风所吹。还活如故。如是众苦。甚可怖畏。堕此狱者。无能得免。复有广大寒[冰-水+(洗-冼+水)]地狱。有大雪聚。其高如山。严冷恶风。飘注不绝。有大深渊。结成[冰-水+(洗-冼+水)]臼。其状宛若水精所成。有诸狱卒。逐彼罪人。尽入其中。寒苦逼切。发声悲号。复有二杵。更相上下。而以捣之。其身碎坏。如聚沫团。业风吹活。如前不异。长时受苦。业尽方出。彼诸有情。皆由染慧邪欲因缘。于他身色。愖着不舍贪微少乐。受多苦报。是故世尊深生怜愍。起大悲心。而说此经

诸比丘。世间所有种种苦因。生为根本。若无生缘。轮回自息。何况未来无量生苦。由有生故。则有色蕴。由色蕴故。则有受蕴。由受蕴故。则有想蕴。由想蕴故。则有行蕴。由行蕴故。则有识蕴。如是次第。相续而起。增长苦聚。轮转无穷。譬如群贼。入于城隍。纵燎抄掠。扰恼黎庶。如是五蕴。依彼识城。生诸烦恼。损害诸根

又老病死。于诸世间。乐为损恼。是不可爱。如三种冤。常所随逐。一者常求过隙。二者令堕险难。三者伺断其命。是故比丘。常当修习福盖正行。受持经典。如说修行。设老病死。众冤围绕。不生惶怖。于险恶道。则能超越。是大丈夫。为二世益。如火中莲。甚为希有。则为安住寂静妙乐。诸比丘。彼福体性。正所显示。自因及果。皆可爱乐。乃至发生无漏善法。身语意业。咸得清净。住不退转。得授道记。如秋满月。放盛光明。一切世间。咸蒙利益。乐广大施。无有限碍。诸来乞者。皆给与之。令诸有情。心生悦豫。如战胜将。心进勇锐。如依善王。安隐而住。犹如大海。纳诸川流。如弥卢山。安固不动。一切众生。奉如父母。得诸世间供养恭敬。获得殊胜第一吉祥。亲友朋属之所称赞。一切所愿。皆得成就。毕竟超越轮回苦海。此义所明。福之自性。犹如金器。坚固可爱。为诸众生最胜依止。非福自性。不可爱乐。犹如坯瓶。决定破坏。令诸众生。流转恶道。如世之盖。人所执持。四方攸往。遮诸炎热。工巧所为。不久则坏。如是福盖正行所持。能袪生等所有热恼。及地狱火之所烧煮。众善所成。任持不坏。如舍卫城中。有长者女。与族姓子。共为匹偶。后生一儿。费用无度。日渐衰窘。谓其妻曰。我诣远方。勤力求索。汝当爱念长育其子。久历岁月。夫犹未还。年既长大。渐生放逸。与邻处女。迭生爱乐。彼女即解所带宝鬘。而授与之。母于后时。知其所由。乃以善言。种种教诲。我子不应乐为鄙事。当自慎护。无罹我怀。日加检束。不令游行。夜于寝门。以设其榻。子于一夕。贪欲所娆。暂卧复起。须臾不停。白母开门。欲往便利。母语子言。此有盆具。不须出也。为母严约。转增欲心。遂兴恶意。以害其母。造是罪已。深生惶怖。遂往伽蓝。白言。大德。我欲出家。愿垂摄受。时诸比丘。不能观察。诘其来由。便与剃发。作比丘已。远遁他国。勇猛精进。坚持净戒。修习禅定。乐诵经典。彼有长者。睹其比丘。具如是德。兴心供养。为造伽蓝。命其为主。八方众僧。咸来依附。尔时比丘。为众讲宣大乘经典。复令修习相应禅观。四事供给。无所乏少。时诸大众。勤修匪懈。渐次有证罗汉果者。而此比丘。后萦病苦。虽服妙药。转增尪瘵。召集众僧。巧忏谢曰。谬当主宰。轻慢众德。诸弟子等。恼乱亦然。唯愿众慈。施我欢喜。常者皆尽。高者亦坠。合会有离。生必归灭。说是语已。奄忽命终。时诸大众。及彼弟子。共营善利。以资冥福。乃相议曰。我师趣寂。未知神识当生何所。其弟子中。有证圣者。乃入定观。始于诸天。次及人间。乃至鬼畜。皆悉不见。遂复遍观诸地狱中。乃知其师堕无间狱。弟子见已。生大疑惑。我大和尚。在世之日。坚持净戒。多闻辩才。精进修行。未常暂废。摄受供给八方僧众。以何缘故。受兹剧报。时彼弟子。复入定观。乃见先因。尝害其母。以是报故。堕无间狱。炽然火聚。而烧其身。为彼狱卒。种种诃毁。汝在世时。下劣无智。造此逆罪。今遣谁当。狱卒即以极热铁锤。以碎其首。血流闷绝。苦不可言。是时弟子大阿罗汉。见是事已。运悲愿力。息除苦恼。凭法威德。令知宿命。缘念三宝。续其善根。即时命绝。生夜摩天。法尔新生诸天子等。住彼天已。起三种念。一观前身受生何族。二于何处。身谢命终。三修何福。得生天上。时彼天子作是观已。乃见自身先造逆罪。承佛恩力。得生此天。而作是念。我今一心。无别异想。唯求见佛。亲近供养。以报大恩。由天福力。自然而有众宝璎络。庄严其身。于初夜分。身放光明。照只陀林。皆悉显现。前诣佛所。头面礼足。即以天上众色莲华。曼陀罗华。以散佛上。积过于膝。作供养已。退坐一面

尔时世尊。知彼天子心之所念。即为宣说四谛法轮。三转行相。闻已悟解。即得见谛。不起于座。证预流果。无漏坚固金刚智杵。摧坏身见邪慢诸山。是四谛法。非诸沙门。及婆罗门。父母朋属。而能宣说。唯佛世尊。愍念于我泣血盈海。积骨如山。闭恶趣门。开生天路。救拔地狱。饿鬼畜生。皆令安住人天善果。时彼天子即说偈曰

  我由染欲深过患　　堕于无间地狱中
  蒙佛恩力得生天　　复令证得涅盘道
  我由依止净法眼　　永脱轮回诸恶趣
  及彼未来生死流　　得至寂静菩提岸
  我今得见牟尼主　　百千生中难值遇
  善超生老病苦因　　应受世间广供养
  持宝璎珞以奉献　　合掌右绕心忻庆
  故我顶礼二足尊　　能使人天生觉悟

福盖正行所集经卷第五福盖正行所集经卷第六

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

尔时超越恶趣天子。偈赞佛已。心生喜悦。譬如商主。得大财利。如彼农夫。得成稼穑。亦如勇将。战阵得胜。如久病者。顿获痊愈。是时会中。有阿罗汉。知彼天子始末因缘。由此追念。己之本师。没虽久矣。知在何道。时有檀那。于寺营斋。有一比丘。汲新净水。于其斋次。行施众僧。彼阿罗汉。以白铜钵。受水欲饮。指尖触之。极甚清冷。即自思念。我师在昔尝为寺主。知大众事。吝惜众物。贪着资生。常愿后身。复生于此。有如是罪。若堕洋铜地狱之中。欲斯甘泉。岂可得也。作是念已。遂入定观之。遍地狱中。洎傍生鬼趣。都无所见。复更思惟。岂非曩植善根。今得成熟。托于胜处。即于诸天。次第观察。乃见其师生四王天。是时尊者往诣彼所。安慰问讯。而语之曰。我闻此天。唯修众善。坚持净戒。始乃得生。师积宿愆。何能至此。是时天子。谓尊者曰。我于昔日。经作寺主。愚痴恶行。不曾发露。将命终时。志诚恳恻。唯佛法僧。是我归仗。由是缘念三宝恩力。承此善根。来生此处。时彼尊者。闻是说已。心净踊跃。得未曾有。即于人天。有学无学。大众之中。三称奇哉。具陈上事。佛法僧力。功难思议。能销地狱无量极苦。能长有情无量善根。断除烦恼。裂诸疑网。毕竟能至菩提彼岸。诸有智者。当勤精进。净身语意。修施戒定此则能报佛之大恩。然诸众生。性欲各异。渐令具修此三种行。或乐当饶受用五欲。世尊方便。劝令布施。或乐生天。受胜妙乐。世尊方便。令持净戒。或乐解脱出离苦际。世尊方便。令习禅定。是故世尊说此三行。名为福盖。当具奉行。譬如二鬼竞三种物。谓箧。谓履。谓椎。两相交争。扬声大唤。云某方所。有婆罗门。彼甚正直。可断此事。二鬼[臼/丌]物。即往彼处。合掌白言。大婆罗门。汝当为我。均分此物。婆罗门曰。此微物耳。何须相竞。远来求决。二鬼说言。此非小事。最极难得。汝观此箧。则能变现。随所欲物。皆从中出。此双履者。人或蹑之。则能升天。受诸妙乐。又彼椎者。则能摧伏一切冤敌。皆令退散。时婆罗门。闻是说已。即令二鬼。退立一面。我当为汝。良久思惟。分此三物。各得平等。彼婆罗门。遽着其履。复取椎箧。乘空而去。二鬼见已。悔令知是三物。为他所有。于此喻中。当善分别。布施如箧。得如意故。持戒如履。能生天故。禅定如椎。降众魔故。此名世尊说施戒定。方便摄受福盖正行

此中复明三种恶行。所谓悭吝破戒散乱。生诸过患。则为轮回恶趣之本。能坏施戒禅定功德。是故世尊。种种显示悭吝过失。犹若垢秽。涂污有情。招不如意。如是悭者。虽积珍财。不能惠施。犹如鸱鸢。止莲华丛。于父母所。不能供给。亲属集会。舍避而去。不信善言。不乐经法。恃己财富。不耐他荣。犹如醉象。性难调伏。亦如毒蛇。人不欲视。善人见已。悉皆远之。于胜福业。不乐随喜。见来诱掖。心则生恼。如于枯井。而欲求水。所出言音。人不欲听。随所至处无有与语。在大众中。则如痴者。过四衢道。犹若腐尸。彼愚痴人。虽居世间不能远离种种过恶。不能护持诸善功德。不能滋长诸善种子。如是悭人。作贫穷因。现虽富足。不能受用。下心求者。不能少惠。当知是人。如尸陀林。诸世间人。不乐依止。是悭因缘。如大名长者经说

尔时世尊住舍卫城。祇树给孤独园。时彼城中。有大长者。名曰大名。巨富无子。忽尔命终。时憍萨罗国胜军大王闻是事已。遽至其舍。尘土坌身。到已摄取一切库藏。及诸财物。悉付官吏。事毕旋驾。诣世尊所。头面礼足。退坐一面。佛言。大王。何故匆遽。尘土坌身。而至此耶。王以上事。具白世尊。佛言。大王。彼大长者。财富几何。王曰。其家巨富。多有资财。金银珍宝。仓库诸物。各有无量百千俱胝。如是豪富。无与等者。彼唯受用粗粝饮食。所著之衣。破烂故恶。出乘弊车。聚叶为盖。凡欲食时。先扃其门。日虽餐啜未尝饱满。设有沙门。及婆罗门。诸乞丐者。涉远路者。作伎艺者。如是人等。来求饮食。无有一人。曾得少许。时胜军大王复白佛言。世尊。愿为我说大名长者。悭吝过失所招之报。令彼闻者。咸得开悟。佛言。大王。如是长者。虽为大富。不奉尊亲。不能己用。于胜福田。亦不乐施。朋友眷属。未闻少惠。奴婢仆从。及诸人民。皆悉舍离。当知是人。虽处财富。由彼悭故。不相符顺。如不净中。生其莲华。如妙园林。踞于猛虎。如珍美膳。置之毒物。如摩尼宝。生于峭壁。如甘熟果。植于高崖。如清净地。涂以粪秽。如服毒药。欲延寿命。如淫女家。自称梵行。如多嗔者。欲人爱敬。如谬解者。称善论议。言如騃童。无有定量。非法说法。不善说善。多招世间种种讥谤。此但守财。枉名为富。虽有珍宝。无益于物。终日劳苦。如无财者。众人见已。咸谓不祥。亲友视之。不往问讯。如是悭人。众所嫌恶。如彼群雁。不栖寒林。由彼财故。自作缠缚。不知寿命。如山瀑流。不念无常。大怖将至。一刹那顷。丧失自命。当知财富。亦不久住。犹如象耳。不暂停息。于说法师。不能下问。闻赞施行。心不信乐。见来化导。藏窜远避。设有得见。返遭骂辱。如是愚夫。虽多资财。如人梦中所得不异。乃至悭惜。埋藏地中。纵遇病苦。不求良药。闻召医师。心则生恼。由此沉瘵。而取命终。人闻其亡。无不称快。一切身分。溃坏难近。猛火焚之。臭烟蓬[火*孛]。倏成灰烬。任风吹扬。当知是人。定堕恶道。于地狱中。受种种苦。从地狱出。生饿鬼中。其形长大。裸形黑瘦。常为炽火之所烧然。身肢燋烂。两目如坑。其腹极大。咽喉如针。经历长劫。不得饮食。皮骨连立。不能自持。常啖粪秽。以自活命。涂污唇吻。不生嫌恶。若见涎涶。互相争夺。或得少分。受多惊怖。复生迥绝旷野旱海。于彼不闻水之名字。其身高大。犹若山峰。猛风所吹。动摇发响。复为飞禽往来栖止。或啄或擭。受诸苦恼。从是得脱。生余鬼类。所谓夜叉。罗刹娑。毕舍遮。部多。矩畔拏。布单那。羯吒布单那。塞建那。嗢摩那等。设得为人。其形极丑。身皮黑涩。状若烟熏。诸根闭塞。眼不明了。贫窭饥裸。以乞自济。常持塼石。以击其胸。有得残弃不净饮食。或生蛆虫。便以为足。常为风雨寒热逼切。蚊虻诸虫之所[口*(一/巾)]食。永失快乐名闻吉祥。如是恶报。甚可怖畏。是悭业行。复如尊者所问经说

尔时世尊住王舍城。迦兰陀竹园。时彼城中。有长者子。常诣佛所。乐欲闻法。发净信心。欲求出家。即白母言。愿母听我于佛法中。出家为道。母言。今者唯汝一子。我身没已。当自随意。子如其教。勤力营求。所得财物。悉以奉母。愿母将此。恣其所用。若有余者。修诸福业。母得财已。不肯惠施。广多积聚。埋藏地中。或有沙门。来至乞食举手呵骂。谓言鬼来。子闻不悦。我母何故于少饮食。而不能施。复加劝谕。诈言已与。未久之间。母乃命终。时长者子。作广大施。以荐其母。然后舍家。既入法已。勤加精进。乐闻正法。如理思惟。成就根力。达有为行。悟生灭法。息诸轮回。超越五趣。破无明[穀-禾+卵]。离三界贪。视其金宝。犹如瓦砾。涂割于身。不生爱恚。其心平等。犹若虚空。决定永断一切烦恼。现前证得阿罗汉果。大梵天王。帝释诸天。咸共尊重。供养赞叹。是时尊者。于恒河岸居止草庵。修习禅定。忽有一鬼。住立其前。裸形丑黑。如烧杌木。头发髼乱。大腹小颈。肢节焰然。发声号哭。尊者问曰。汝为是谁。鬼白尊者。我即汝母。命终经今。二十五年。堕饿鬼中。受极饥渴。不闻饮食。及水名字。设见大河。倏然枯涸。遥视果林。到不复有。乃至刹那。无有少乐。唯愿尊者。救拔于我。愿依此住。求少水饮。尊者闻已。悲泣嗟念。生不修福。死堕恶道。当发志诚。悔谢前咎。鬼曰。我为悭垢。覆蔽其心。于诸福田。未曾少施。往昔所有种种财物。尽于本舍。掘地藏之。尊者为我。速取其物。作大施会。饭食沙门。及婆罗门。施贫穷者。供养诸佛。及众贤圣。称我名字。发露忏悔。愿令我身。速脱此苦。尊者语曰。若能如是。克责悔过。罪当消灭。鬼曰。我由前身无惭无愧。招斯裸形。不堪止此。尊者谓曰。若造恶已。心不追悼。彼业决定。若能发露。罪不增长。今既发心。可得住此。是时尊者召彼亲属。还昔舍宅。掘取诸物。如彼所说。为作施会。以妙美馔。供养三宝。及婆罗门。诸乞丐者。皆令满足。时尊者母。住立一面。睹无数人。广大集会。耻己丑状。流泪号哭。唯愿世尊。哀愍救度。时彼尊者。五体投地。高声为母称其名字。愿承此善。早令解脱。尔时世尊。以方便力。威神加持。而为说法。及彼时会。百千众生。闻法解悟。得真实见。鬼得离苦。寻即命终。尊者然后复入定观。见彼还生有财鬼中。即至其所。为说宿因。使令发心。劝行施行。今当修福。早求出要。鬼闻化已。良久思惟。白言。尊者。我不能施。是时尊者。闻已咨嗟。汝极愚痴。悭习犹在。不知黑业。展转围绕。鬼趣极恶。何不厌怖。种种方便。苦切责已。渐次诱化。得二白[疊*毛]。尊者受已。持施众僧。未及货易。令一比丘。专收掌之。鬼尚悭惜。心不能舍。即于是夜。潜取而去。比丘失已。往白尊者。尊者思惟。此非他人。我当往取。既至鬼所。果得其[疊*毛]。如是三窃。取复如初。掌[疊*毛]比丘。心亦生恼。即便分裂。俵散众僧。各各受已。或用补衣。彼鬼复来。窃衣而去

佛言。当知悭心。为大过失。由彼缠缚。永堕恶趣。是故我今方便显示。令诸有情。断除悭垢。乐修广大清净施业。是名摄受布施福盖正行

福盖正行所集经卷第六福盖正行所集经卷第七

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

若有众生。以种种物。于诸有情。而用布施。所谓饮食衣服。卧具医药。乃至一切众妙珍宝。及诸库藏。皆能与之。如是施者。名广大施。或诸众生。心乐行施。未及如上种种诸物。随己所有。而能与之。如是施者。名随分施

佛言。此二种施。谓身语意业。及受想等蕴。与思俱转。同时修作。现前而与。相续爱乐。是名为施。若刹那顷。发起净心。以己所有。而能与者。亦名为施

复明二种。一者不清净。二者清净。善行施者。应当了知。则能建立一切种智

若施者无戒。不顺正理。不具正见。谓施无果。如是施者。则无其报。或受者无戒。不解教法。深着邪见。说施无果。于彼施者。亦无其报。此名不清净

若施者持戒。解法正见。知有施果。如是施者。则有其报。或受者具戒。解法正见。说有施果。于彼施者。则有其报。此名施者受者二皆清净正行圆满

若施者清净。受者不清净。此亦说名成就施报。或施者不清净。谓彼愚夫。固守其财。犹如僮仆。奉事其主。或为徭役。官吏催督。执缚忧恼。然后而与。或为冤贼劫夺损害。受诸惊怖。然后而与。或为熟老病苦缠绵。渐逼死门。然后而与。如是等类。皆不名施。或观歌舞种种伎艺。沽自美誉。然后而与。或见他人。与彼财物。自谓豪富。而倍与之。于他美色。心生爱乐。欲摄从己。倍与其直。如是与者。皆不名施所以者何。彼虽与财。心常热恼。与贪嗔痴疑惑等俱。不顺正理。非善相应。唯趣轮回。作不饶益。何能感彼出世善根。如来相好。手指网絻绮画之相。此说名为施着不清净

复说二种。一者施已不清净。二者施已回向清净。时王舍城。有诸檀越。修福业已。于僧伽蓝众僧园中。作诸伎乐。娱乐游戏。时主园者。来白寺主。耆宿比丘语檀越言。汝等何故至此放逸。暂虽适意。后招苦报。主园比丘白耆宿言。檀越在此。美言令喜。何故责彼。令他生恼。时彼耆宿呵主园者。汝先未学。不知戒律。承奉白衣。苟其财利。汝且观此富乐受用。能令众人。心生狂乱。非理作意。为坏法缘。时彼耆宿即说偈言

  若于众僧园　　嬉戏受欲乐
  彼愚夫盲瞑　　破法堕恶道
  应当于其中　　修布施持戒
  此二为伴侣　　能趣解脱门
  如清净池沼　　中植于芙蕖
  彼花既开敷　　后必结其实

云何说为施已回向清净。由彼施者坚持净戒。体性意乐。本来清净。所有一切金银珍宝。仓库等物。象马车乘。心无吝惜。皆悉能施。知有施报。及彼他世。厌患轮回速疾流转。乐证真常。离诸过失。于彼世间五欲快乐。不生染着。皆能弃舍。于毁于誉。其心不动。见来乞者。软言慰问。面色和悦。离于颦蹙。视如尊亲。心无厌倦。随彼意愿。皆令满足。速疾持与。不生疑悔。离诸谄诳。洗除悭垢。专乐利他。荷负群有。守护威仪。断诸诤讼。或有来乞身体肢分。善修忍辱。不生恚恼。心不散乱。乐最上施。彼善方便。从我求索。我当欢喜。而施与之。令我具足净戒精进。禅定胜慧。诸波罗蜜。速证无为现法乐住。得成无上正等菩提。又诸有情。由彼财富。色力勇健。多着欲乐。彼于世间。不亲善友。不乐佛法。刚强难化。乃至发起多种病苦。风癀痰癊。或三集病。而取命终。又彼世间所有官属农商工巧。一切人民。心常匆遽。无暂容豫。一向追求放逸娱乐。堕于五欲险难深坑。展转轮回。不知出要。以大悲心。开示教诲。于痴瞑者。为发智明。无救护者。拔除苦恼。无归依者。得安隐处。乃至现受地狱等苦。以我所修布施福业。施诸有情。皆令离苦。以我布施所获果报。不求世间五欲快乐。亦不爱乐尊荣豪富。愿超轮回。毕竟解脱。此名施已回向清净

佛言。如是所作清净施已。往昔因缘。我今略说。乃往过去无量世时。国名善声。王曰善胜。富贵自在。多诸眷属。人民充满。安隐丰乐。互相爱敬。无有诤讼。不闻恶言。无诸疾疫。林木郁茂。果蓏甘美。地唯沃壤。不生荆棘。资生之具。皆悉充足。彼至治世。禀性仁贤。等视黎民。犹若一子。爱乐正法。未曾暂舍。决定大悲。怜愍一切。厌离有为。了达无我。是大丈夫。众所称赞。住广大施。心无吝惜。一切所有。彼皆能舍。每至明旦。入施场中。诸来乞者。善言安慰。或须饮食。即与美味。或求衣者。即与妙服。乃至金银琉璃。[王*車]磲玛瑙。真珠摩尼。仓库诸物。随其所欲。皆给与之。如是施已。王入后宫。召诸嫔嫱。童男童女。大臣官长。各各施与。咸令满足。种种所有。尽舍无余。唯有所著严身之服。时善胜王作是思惟。今此城中。一切人民。我已周给。皆得富饶。唯诸细虫。未曾沾惠。思以何物。而能济之。时王即至多蚊虻处。脱所著衣。令彼[口*(一/巾)]食。皆得饱足。心无劳苦。是时帝释。下观人世。见是事已。怪未曾有。彼善胜王。能发如是广大悲心。利益安乐一切有情。我当自往。验其诚实。时彼帝释。化一鹫鸟。羽翮黭黮。爪喙铦利。飞至其前。欲啄二目。王积慈忍。殊无惊慑。返以爱眼。顾其鹫曰。今我身肉。恣汝所啖。禽急俯身。忽然不现。于时帝释。复变其身。作婆罗门。来诣王前。亲近恭敬。唯愿大王。施我二眼。王即语曰。大婆罗门。汝诚要者。当自取之。我于己目。无少吝惜。时彼帝释。知其施行。真实不虚。隐婆罗门。现自色相。心生欢喜。赞言善哉。大王今者大悲坚固。愿力决定。利益有情。心不倾动。在在处处。一切众生。闻王名字。得大吉祥。不久当证最上菩提。如是施者。能施之人。及所施物。或广或少。无不清净。是人当得念处正勤。神足根力。诸功德法。于菩提道。不复退转。则为清净最上福田。能长一切众生善根。是大丈夫。则为父母亲属朋友。作归依处。如好舍宅。能障风雨寒热诸虫。得安隐住。能于无数沙门婆罗门等。大众之中。善宣论议。额貌熙怡。身心勇锐。以决定慧。伏诸异见。譬如雪山大力香象。摧彼怨敌。心无所畏。犹如宗师。教诏徒众。不舍是辈。如母念子。当知是人。如清凉池。能济一切诸渴乏者。如奇妙华。人所爱乐。随开发处。而为庄严。如彼医师。善治众病。随所至方。能施安乐。如持咒者。能除蛇螫。彼则善灭贪恚痴毒。见诸众生。贫无福慧。长劫没溺生死淤泥。令修相应真实善法。渐次引至功德宝山。如旃檀林。香风远飘。随所闻者。无不悦意。是人美名。亦复如此。于一切处。咸得钦奉。如王都城。安隐无畏。一切人民。依附而住。是人行施。众所亲近。如秋满月。光明清净。一切世间。共所瞻仰。乐行施者。亦复如是。如牟尼尊。诸根寂诤。说解脱法。欢喜布施。广大圆满。相续无懈。是名布施正念解脱清净。又彼施者。见有人来。从己求索。当起迎劳。先意问讯。奉众香水。以净其手。然后如法设诸饮食。随彼所求。皆能与之。乃至所有娱乐境界。心无吝惜。欢喜奉之。如是施已。彼能弃背一切障累。复能摄取一切善根。舍是身已。中有明利。决定往生知足天上。第一快乐安隐之处。时彼天宫。有劫波树。翠叶郁茂。放妙光明。宝花开敷。皆悉周遍。复生种种上妙天衣。被诸天人。随意而取。复有广大清净宫殿。众宝所成。黄金间错。无数宝瓶。周匝行列。众妙缯幡。随风宛转。复有无数百千天女。形体姝丽。端正无比。上妙花鬘。交饰其服。众宝束带。以系其身。臂钏耳珰。珂佩璎珞。徐步和鸣。甚可爱乐。如是天女。充满其中。时彼最胜第一天女。知有天子。新生此间。与诸眷属。作众伎乐。诣天城门。躬往迎接。是时众中。新生天子。威德特尊。形色殊异。绀发柔软。右旋润泽。一切尘垢。所不能染。目净修广。如青莲叶。唇色赤好。如频婆果。齿白齐密。犹若珂雪。身出光明。与面相照。修短得中。见者忻乐。时彼最胜第一天女。白天子言。今此天中。殊妙快乐。更无过者。唯愿仁者。与我为夫。久住于此。共相娱弃。即以金瓶。注水盥掌。及天宝冠。种种璎珞。严身之具。而以奉献。复有天女。手执白拂。以为前导。至宝花林。作众歌舞。奏诸音乐。两相瞻视。受妙欲乐。复升天中微妙楼观。游行宴处。随意自在。或于宝池。共为游戏。彼诸天女竞采莲花。各各奉上新生天子。或作散花。以布其地。各生欲想。咸来亲近。复有一天。来相庆慰。汝昔人间。修瑜伽行。破坏贪欲不净因缘。今得生此。受极妙乐。得诸天女恭敬围绕。时彼天人。即礼其足。欢喜称赞。而说偈言

  善哉仁者生此天　　得受最上五欲乐
  如净满月丽长空　　能拆青莲香馥郁
  昔修广大诸善行　　身出微妙净光明
  常以慈眼视有情　　故得天人咸尊重
  复有清净旃檀林　　枝叶扶疏极可爱
  修藤弥布四垂下　　妙花周遍悉敷荣
  有诸天女处其中　　容色洁白甚端雅
  身肢柔软出妙香　　竞为歌舞无疲倦
  我今得奉于仁者　　目明心悦未曾有
  此生意乐不唐捐　　非小因缘之所得
  百千天女常围绕　　由先福行而庄严
  如是施报难思议　　应当永断诸疑惑

时彼新生天子以偈答曰

  若欲增长功德藏　　应修广大清净施
  决定获得上妙乐　　水火非人不能坏
  天中快乐甚希有　　随意受用悉现前
  诸有世间聪利人　　当发净心行施行

诸有情等。当善思惟。如是施已。受天胜报。后生人中。大族姓家。具大名称。有大威德。色相端严。人所乐见。亲属圆满。财富无量。设遇恶缘。不能破坏。如毗舍佉王母因缘经说。时彼王女。与其眷属。出于宫中。诣园游看。玩已憩止。即解所戴上妙珠珍严身之具。收置襆中。以付其婢。复往佛所。乐欲听法。闻已还宫。婢忽忘失所掌之物。女闻不悦。白父王知。母谓王曰。此必定在。设有见者。亦不能取。我于多生。乃至此身。不于他物。少分生贪。若起此念。我则欲取一切众生身分财物。我则不能得见诸佛。令诸有情。得如意果。时彼尊者阿难见是物已。即为收之。明旦诣宫。即纳王所。王曰。彼所遗物。赖尊者见。余人若得。必为隐匿。母谓王曰。子何不信。我以此物。掷四衢道。验其福力。谁能取之。如是弃已。彼往来者。各各见异。或谓不净。或云毒蛇。舍之而去。王尚生疑。伺母熟睡。取其指环。掷置河中。母睡觉言。谁取环去。王曰。福力所护。何敢取者。母言。且止。后必当获。忽于一日。遣使市中。买一鱼归。剖腹得环。众皆惊异。王即赞言。善哉我母。所言决定。如师子吼。后时阿难复诣王所。王倍生信。乃云福力。真实如此。我当毕竟乐修福业

福盖正行所集经卷第七福盖正行所集经卷第八

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

佛言。大王。当知世间一切众生。由净施故。所受福报。冤不能坏。设百千人。亦不能夺。随所至处。福为前导。乃至他世。福亦如是。犹如伴侣。常所随逐。尔时世尊而说偈言

  由先世积集　　广大诸福行
  今得为人王　　具吉祥尊贵
  百千诸营从　　住立于王前
  福力所摄故　　瞻仰咸悚栗
  当知彼福业　　如眼腹手足
  常爱护任持　　令相续不断
  我昔修施行　　一切皆能舍
  唯留于一象　　随意乘所往
  乐依止山林　　修习诸禅定
  时彼诸人民　　皆悉来相从
  或手执白拂　　或持于伞盖
  及以诸茵蓐　　所至敷床座
  彼各白王言　　我等无福慧
  今愿咸亲近　　同修诸善行
  福为最胜财　　常得真实乐
  福为第一亲　　引至安隐处
  福如如意宝　　置于己掌中
  作最上吉祥　　所愿皆成就
  具殊妙色相　　受五欲快乐
  语言人乐闻　　善巧极明了
  寿命得长久　　安隐无忧恼
  一切诸众生　　见之若亲友

若诸有情。于胜福田。顺其正理。专注而施。决定此生现得富饶相应福报。如金鬘夫人。闻佛功德。心生赞仰。以己先有微妙金鬘。奉上如来。又善思王女。以妙饮食。供养尊者须菩提。又修发婆罗门女。自剪首发。以鬻其直。饭彼尊者大迦旃延。发复如故。是三女人。由净施故。现身皆得为国之后。又福严长者。躬往请佛及诸罗汉。就舍营斋。库藏复溢。如牧牛女。持旃檀香。及田舍女。以麦[禾*肙]花。供养佛塔。皆得生天。如是得受现报因缘。如胜军王经所说。佛住舍卫城。时胜军大王末利夫人。始生一女。具十八种极丑之状。年渐长大。当求所适。彼诸贵族。不乐为姻。其下种姓。王意不许。时有外国一长者子。久住此城。费用皆尽。俜伶周行。未有所偶。臣吏白王。即可其请。王乃召对。而谓之曰。我有长女。纳卿为婿。若相从者。永终富贵。设欲还国。亦可偕往。时彼王女。即以上妙珍奇杂宝。严饰其身。而以妻之。及与无数种种财物。时长者子。即娶为妇。未久之间。同归本国。既至家已。彼诸亲族。求见设礼。长者子曰。我妻王女。观何容易。若须见者。必当择日。后诸亲属。复至其家。长者子言。却后七日。出城花园。于彼相见。众复审曰。此言决定。若不往者。我当罚钱五十万数。至七日已。彼长者子。具办种种美妙饮食。先取一分。置其房中。白妇知已。固锁其门。时长者子。赍其所罚。及诸饮食。往彼园中。是时众人在园。遥见彼长者子。乃只独来。咸相谓曰。是人诞妄。不依先议。既至园已。白亲属曰。幸无见怒。愿输所罚。众曰。子妻尊崇。藏于深室日月之光。尚不令见。岂况我曹。何能得睹。时彼王女。即自嗟念。我虽年少。形容极丑。是何恶业。招斯鄙陋。厉声叹曰。苦哉苦哉。使其丈夫。受多惭耻。常作虚言。及遭谴罚。如斯处世。虽活奚为。即以缯带。自经其颈。时守宅神见是事已。谓此王女。我当释之。保全其命。使无中夭。当知世尊无尽大悲。常乐救度彼彼有情。每作是念

我今当于何等众生。为说法要。令生信解

我今当于何等众生。令彼洗除贪欲垢秽

我今当于何等众生。令彼息除嗔恚过患

我今当于何等众生。令彼灭除愚痴暗钝

我今当于何等众生。令彼增长一切善根

我今当于何等众生。令彼出离生死淤泥

我今当于何等众生。令彼超越轮回苦海

我今当于何等众生。令彼解脱烦恼结缚

我今当于何等众生。令彼拔除恶慧毒箭

我今当于何等众生。截四瀑流。令至彼岸

我今当于何等众生。令免三涂种种楚毒

我今当于何等众生。施其法水。令除渴爱

我今当于何等众生。令彼厌患境界痈疽

我今当于何等众生。令破无始无明卵[穀-禾+卵]

我今当于何等众生。令彼摧伏我慢高山

我今当于何等众生。令远诸恶。着惭愧衣

我今当于何等众生。令彼具修戒定慧学

我今当于何等众生。令达诸法。心得自在

我今当于何等众生。令彼获得清净智眼

我今当于何等众生。令彼越入大解脱门

我今当于何等众生。令彼发起大菩提心

我今当于何等众生。以菩提鬘。而系其首

我今当令胜军王女。易丑陋形。得如所愿

是为世尊刹那刹那。念念观察一切众生。或近或远。或多或少。或胜或劣。上中下性。皆能救度。慧眼悉见。无有遗余。如有颂云

  佛不舍众生　　远近皆化度
  如果成熟时　　自然生甘味
  是故牟尼尊　　冤亲唯一想
  利乐诸众生　　亦不希其报

尔时世尊。先为摄化裸形外道尼干子故。现大人相坐宝莲华。身被红衣。如日初出。色相寂静。安住威仪。犹若金山。舒光无极。处于无数人天大会。如众星中。现其满月。亦如天宫宝多罗树。微风徐动。人乐依止。如珊瑚株。宝华庄严。如金盘中。然大灯炬。如白香象。入尼连河。为金莲华。蕊尘所坌。亦如春时羯尼迦树。开发金华。众所爱乐。善能调御一切有情。入诸恶趣。不生疲厌。游化善道。善说诸法。皆使发心。得安隐乐。由诸有情。无始已来。相续造作。贪嗔痴等。种种恶行。若冤若亲。及非冤亲。平等怜愍。犹若一子。皆令出离轮回险难。如日破暗。令尽无余。是时世尊。以一切智声。为彼外道。略说法要。当知世间。动不动法。以智了达。皆悉空寂。由虚妄心。迷真实见。自性涅盘。本来清净。彼闻是说。心得开悟。则能断除坚执我慢。譬如师子发声震吼。自然而能裂其巨石。时彼如来。摧彼异见。论义为胜。现大神通。上升阿迦尼吒天。其中所有一切众生。皆悉称赞佛之功德。一切世间。无能胜者。又复显现最胜离垢无见顶相乌瑟尼沙。右旋绀青。润泽可爱。复放眉间白毫相光。如秋满月。是为如来第一功德。非同梵天小善所感。是佛利他大悲所起。设诸众生。如微尘聚。住正思惟。无能测彼乌瑟尼沙。非刚非柔。非成非坏。非忩非暇。非动非静。非速非缓。非强非弱。非沈非掉。非夷非险。非诤非默。非合非散。非着非离。非勤非懈。非虑非度。非病非恼。一切众生。平等共有。最胜吉祥。第一功德。时彼外道。心净信解。于佛法中。得安隐住。是时王女。处其室中。蒙佛光照。心安泰然。即作是念。今佛在世。利乐众生。有厄难者。皆蒙济度。唯愿世尊。不舍大悲。哀愍覆护。现身我前。作是语已。遥伸礼敬。悲泣泪下。佛知其意。令彼室中。忽然严净。是时如来。从地涌出。身真金色。相好端严。时彼王女。睹佛身相。叹未曾有。以妙花香。虔伸供养。珍宝璎珞。而以奉施。合掌作礼。恭敬亲近。佛影蔽身。顿获端正。心大欢喜。踊跃无量。住立佛前。以偈赞曰

  最胜释师子　　依枳罗岩窟
  具少欲知足　　离世间过失
  智慧为利牙　　惭愧为须鬣
  降伏诸魔怨　　如啮彼麋鹿
  忍为坚甲胄　　慈力以为弓
  善发彼智箭　　永害烦恼贼
  八解脱为池　　正行为堤岸
  无垢精进水　　开觉意莲花
  勇猛离诸过　　拔除三有根
  施平等法药　　愈贪恚痴病
  具炽盛威德　　相好而庄严
  增长功德心　　荷担于群有
  善住于威仪　　诸根无散乱
  如拘嚩罗花　　见者生爱乐
  无怖无垢染　　最胜心寂静
  解脱一切缚　　成就一切智
  牟尼大牛王　　世间无与等
  能救诸众生　　或病或忧恼
  服红僧伽梨　　湛然而不动
  我以诸譬喻　　净心而称赞
  如金多罗树　　耸干修且直
  亦如融金柱　　光明极晃耀
  又如彼金聚　　涂以旃檀泥
  如是佛身相　　比况不能知
  或谓妙金山　　一峰极峻峙
  为猛风所吹　　嶷然住于此
  或谓阿修罗　　与天主交战
  坠彼金辇舆　　忽然现于此
  或谓帝释幢　　浑金所成就
  挺特复焕烂　　忽然现于此
  或谓多闻天　　微妙宝楼阁
  以众宝庄校　　忽然现于此
  或持地佛母　　吐出妙宝藏
  放种种光明　　忽然现于此

佛施化已。倏然隐没。时彼王女。加趺而坐。一心专注。想念佛身。是长者子。先在园中。为诸亲友逼饮而醉。众相议曰。可于彼手。易取门钥。疾往其舍。开门视之。乃见彼妻。状如天女。咸皆愕然。不觉作礼。长者子归。见其端正。妇以上事。白夫令知。今佛世尊。最上福田。我今复往。恭敬供养。作佛事已。乃自誓言。若我此身。所有恶业。招斯丑报。愿不复受。乃至世间一切众生。离丑陋身。皆得端正。即于佛前。重说偈言

  世尊妙色相　　庄严皆具足
  能令诸有情　　见者得如意
  以我今少善　　普及诸有情
  悉除丑陋因　　皆获端严报

佛言。贤女。我不自赞。不作妄语。不求供养。随诸众生所受业报。起大悲心。而为救护。即说偈言

  我为世间调御师　　不求名称及利养
  善能摧彼五欲幢　　咸使众生心寂静
  三明二行悉具足　　当与人天作吉祥
  我已降伏众魔怨　　毕竟无有能胜者
  永离三有诸过患　　不生热恼心解脱
  及彼习气尽无余　　得受世间广供养
  设有众生来加恶　　其心不动如虚空
  誓当荷负彼凡愚　　得证圆明无漏智
  若有比丘四众等　　咸来我所乐闻法
  皆令具足诸律仪　　决定当得为智者
  我是净饭王太子　　乐修苦行栖山谷
  得脱生老病苦源　　由是得成无上道

由彼王女。于佛世尊。净心布施。现身获得端严色相。若人乐求最上快乐。当于佛所清净供养。是名佛说福盖正行。汝等比丘。常乐受持。于施戒定。当勤修学

福盖正行所集经卷第八福盖正行所集经卷第九

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

若于佛等最胜福田。专修施行。定获其报。如是乃至。现见世间。王者之贵。尊崇无比。首戴宝冠。诸珍间错。耳环臂钏。金璧交莹。容仪鲜白。具相端严。珠璎宝鬘。以饰其服。所居宫殿。高广宏丽。重楼户牖。尽诸奇巧。众色缯帛。遍张露幔。瑞兽师子。俱枳罗鸟。置之笼槛。以为玩好。城墉峻峙。力士环卫。象马车乘。往来合沓。所居民庶。安隐丰乐。无有诤讼。剽窃逋窜。种种娆恼。怖畏等事。处处皆有妙娑罗树。多摩罗树。占博迦树。无忧树等。枝叶花果。茂盛可爱。王所欲至。于四衢道。屏去尘秽。瓦砾荆棘。以众香水。泛洒其地。百千伎乐。箫笛箜篌。击鼓吹贝。导从前后。王乘龙象。威德特尊。最上无垢。牛头旃檀。磨以涂体。其香远闻。被服绛绡。如日初出。右手执持殊妙白拂。吠琉璃宝。以为其柄。张妙伞盖。黄金为干。种种宝物。装治华焕。时彼城中。一切人民。欢喜合掌。同音称赞。散众名花。遍布于地。有诸士族。或裁巧思。作为咏歌。纪扬德化。王闻是已。倍增悦豫。如是胜报。由施所得。此说是名于胜福田。专修施行。成就福盖

云何布施。令诸有情。一向获得世间富乐。受用殊妙五欲境界。应当了知。如是施业。不唯招致广大富乐。乃至无上智因。亦能成就。当知此施。为坚固藏。不为水火盗贼所坏。当知此施。是最胜友。此生他世。常为其伴。当知此施。如好种子。于一切时。得如意果。当知此施。如妙阶梯。能升天中。受诸快乐。当知此施。犹如灯明。能破饿鬼。悭吝黑暗。于恶趣中。能为济拔。于险难处。能为救护。越生死海。能到彼岸。若诸众生。如是知已。数数发起清净作意。勤行布施。相续不断。于诸所有。心无吝惜。亦不枉费。深生觉悟。此等皆为不坚之物。毕竟乐修清净施业。由是之故。美名遐布。见者忻慕。常得善人依止共住。处大众中。心无怯弱。善住威仪。赞施功德。能招富足。免离恶道。得生天上。趣解脱城。令他信解。离悭垢秽。当知此人。是大菩萨。是善知识。是大丈夫。能长有情真实善根。一切众生应当往诣。亲近供养。乐闻正法。如理修作。求出离道

如上所说。若于佛等。专修施行。定获其报。设使不遇一佛菩萨。而能任持如是施心。所感之报。如前不异。是故世尊方便显示。令诸众生。次第行学

尔时世尊。游化依止。在王舍城。迦兰陀竹林。时尊者大目干连。作是思惟。今者世尊。与诸声闻。大弟子众。住此林中。当须建立清净僧坊。作是念已。诣帝释所。白言。天主。敢募仁者。于王舍城。迦兰陀竹林。为佛世尊。造立精舍。并诸弟子。大阿罗汉。同此安居。时天帝释。闻是说已。心大欢喜。唯然受教。即以无数金银珍宝。帝青摩尼。吠琉璃等。造作重门。廊庑户牖。宫殿楼阁。珊瑚为柱。种种宝物。而装校之。复以众宝。刻诸珍禽。悬处空中。势如翔举。无数宝镜。周匝垂挂。莹彻无垢。灿若星月。种种天衣。光洁柔软。黄金为架。以敷其上。金刚宝鬘。真珠花鬘。杂厕行列。以为庄严。烧众名香。氛氲散彻。燃种种灯。昼夜明照。如是供养。世所未有。于其园中。处处皆植龙自在花。占博迦花。隅噜摩花。拘吒波花。无忧树花。周遍开敷。甚可爱乐。于花林中。有珊瑚亭。门闼窗槛。剞劂奇巧。皆以众宝。装校严饰。微风吹花。香闻远迩。有诸天女。游止其中。上妙珍琦。以为璎珞。兽衔珠[佩-一]。其鸣珊珊。林中复有诸药叉女。形容端肃。竞共驰观。髻遗宝花。迭相嬉笑。复有广大清净池沼。众宝合成。香水弥满。池中复有大宝莲花。白银为叶。黄金为茎。诸妙天女。住立其中。动容作乐。献妙歌舞。复有无数金色莲花。优钵罗花。拘没那花。迦诃罗花。照耀芬敷。香气薰洽。有诸水鸟。鸂[(來*力)/鳥]凫雁。翔集花坞。整其羽翰。有诸戏鱼。往来游泳。触花翻浪。惊诸鸥鸭。周匝皆以金银玻璃。及诸珍宝。而为阶陛。池岸复有劫波树林。修条拂水。密叶交荫。诸妙花蘤。相间开发。无数百千士族人民。富乐庄严。作众伎乐。往返观赏。无有障碍

时彼天主。为佛世尊。造立精舍。弥月方毕。营办所须。令无阙乏。种种库藏。悉皆充溢。前诣佛所。而作是言。此地吉祥。广博严净。与欢喜园。正等无异。唯愿如来。届此安居。佛愍彼故。即为受之。复以百千最胜龙象。奉施如来。及以百千殊妙天女。持盖执拂。扇摇凉风。以为承事。诸大弟子。复以百千乾闼婆众。奏妙音乐。而为供养

时王舍城。有一长者。其家巨富。财宝无量。比多闻天王。犹以为胜。然彼长者深着邪见。信受外道尼干子法。见是事已。心怀疑惑。是时尊者大目干连。知彼机熟。即往化导。为说法要。赞佛功德。彼闻法已。心生悟解。白尊者言。我今发心。归依如来。欲往亲近。恭敬供养。即与尊者。同诣佛所。头面礼足。住立一面。尊者白佛。此大长者。舍邪归正。始发信心。今欲供养佛及众僧。唯愿大慈。受彼勤请。佛知是已。默然许之。时彼长者。知佛受请。心大欢喜。匍匐而还。即以无数种种珍宝。上妙缯绮。严饰其居。门楼堂阁。皆令新净。造作精妙百品饮食。成办既毕。即遣使者。前白世尊。食时将至。唯冀大慈。受我微供。尔时世尊。从僧坊出。威德自在。相好端严。身放光明。如日赫奕。将诸弟子。大阿罗汉。诸根寂静。心得自在。进止详雅。来诣其舍。复有百千天子天女。身意泰然。离诸散乱。旃檀涂身。恭敬围绕。有诸人民。见是事已。怪未曾有。来白长者。复有百千清信士女。心生欢庆。弹指作礼。各持最上坚黑旃檀。然以供养。所烧之香。过百千斛。复奏无量上妙音乐。清婉嘹喨。声震于地。时彼长者。以诸幡盖。次第安布。遍张露幔。珠璎庄严。烧大宝香。躬往迎奉。长者所有内外亲族。各赍名花。满掬而散。时佛世尊。诣彼宅已。于堂中央。为佛设座。上妙缯纩。重敷柔软。杂彩茵褥。遍布于地。宝幢行列。珠网四垂。悬诸妙幡。众色綷错。百千宝铃。铺缀其上。微风动摇。声韵和雅。真珠花鬘。遍垂宝幔。涂香末香。澡瓶净水。排备毕已。命佛升座。即以新好上妙白[疊*毛]。裁所著衣。跪以奉佛。然后上首大阿罗汉。及彼新学诸比丘等。入其堂中。次第而坐。以诸饮食味中上味。施佛及僧。皆悉充足。食已各各收钵净手。时彼长者。合十指掌。瞻仰尊颜。以偈赞曰

  如来具足殊胜相　　随形妙好遍严身
  首发修致不杂乱　　光泽绀青如蜂王
  如来额广复平正　　亦无缺减极坚固
  眉间白毫常右旋　　如秋满月光照耀
  如来两目极清净　　睫若牛王不瞬动
  修广妙好常照明　　如俱那花可爱乐
  如来具足四十齿　　洁白齐密如珂雪
  广长舌相妙难思　　钵罗奢花红可类
  如来复有鼻功德　　高耸端直窍不现
  唇不褰缩不下垂　　鲜润犹若频婆果
  如是大仙面圆满　　耳轮柔软相称可
  譬如开敷妙莲花　　离诸垢染观无厌
  如来身相如金聚　　坚固充实无与等
  肤色犹若占卜花　　亦不羸瘦现筋脉
  双臂佣圆极润泽　　掌纹显现众形像
  具足轮印毂辐辋　　宝幢宝瓶及鱼等
  胸广犹如师子臆　　喜旋德相画分明
  腹量平满称其身　　脐深右旋中圆净
  双腨犹如仙鹿王　　行无回顾身俱转
  右足先举现印文　　安徐无畏如师子
  如来出现于世间　　如日腾空普明照
  能与众生作吉祥　　天及非天咸信礼

于是长者。偈赞佛已。心大欢喜。信力坚固。于大众中。重说偈言

  牟尼十力尊　　能破诸魔网
  永离烦恼垢　　诸根常寂静
  最上胜族类　　日亲甘蔗种
  勇猛大精进　　觉悟诸过失
  无畏释师子　　具足诸功德
  成就微妙法　　为众生开示
  于三界苦海　　轮回诸险难
  以戒为根本　　毕竟能超越
  由持净戒故　　调伏于自心
  善屈众魔怨　　应受妙供养
  具大智大悲　　不舍本誓愿
  怜愍诸有情　　咸令离忧苦
  最胜调御师　　三界无伦匹
  善拔众毒箭　　断三有缠缚
  显现大神通　　能摧诸异见
  开示八圣道　　令修诸梵行
  是名大商主　　能作大施会
  是名大智者　　为作世间眼
  是名大丈夫　　速能远诸恶
  截生死瀑流　　得至安隐处
  世尊大导师　　乔答摩胜族
  具相身金色　　见者无厌足
  调御诸众生　　入解于正教
  永离诸不善　　清净心无垢
  如云住虚空　　注甘露法味
  令一切有情　　滋善根种子
  如来大圣尊　　及诸比丘众
  住最上安隐　　能到于彼岸

福盖正行所集经卷第九福盖正行所集经卷第十

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

是时长者复以伽陀。称赞佛已。发诚实言。作大誓愿。以我所修善根功德。愿未来世。得成佛道。亦如世尊。具足成就三十二相。八十种好。以无碍智无上法药。能愈众生贪恚痴病。于无亲者。为作主宰。于黑暗者。为作照明。未调伏者。令善调伏。未信解者。令生信解。未安隐者。令得安隐。未涅盘者。令得涅盘。毕竟出离生老病死忧悲苦恼。咸使生天。受妙快乐。复能劝修八圣道行。开示宣畅四圣谛法。令彼闻已。心得悟解。赞佛法僧种种功德。无量智慧。自性清净。广大威神。无能胜者。能拔轮回生死苦恼。方便诱导。入解脱城。渐次令修诸功德法。守护净戒。修奢摩他。毗钵舍那。于四无畏。及四神足。四正勤等。治诸懈怠。于四念处。明记不忘。四无量心。平等修习。依五根力。断五趣障。了五蕴相。自他同等。具足圆成六波罗蜜。以七圣财。普施一切。修净戒足。蹈七觉花。一心安住七方便观。分别演说八圣道支。善能修习九次第定。具足十力。名闻十方。得十自在。乃至成佛

尔时世尊。见彼长者。于大众中。发誓愿已。赞言。善哉。汝今真是人中大龙。人中师子。最上最胜。人中大仙。离诸垢染。如白莲华。堪能运载一切众生。堪能荷担无上菩提。是时世尊。舒金色手。如莲华开。指间网絻。其纹巧妙。如父抚子。按长者顶。以梵音声。如春雷震而作是言。汝于来世。当得作佛。号能满众生志愿如来应供。正遍知。明行足。善逝。世间解。无上士。调御丈夫。天人师。佛世尊。具足十力。破诸魔众。其土清净。广大富乐。时虚空中。有诸天子。雨妙香花。而为供养。普佛世界一切有情。皆发信心。乐修福行。尔时世尊。而说偈言

  汝于未来世　　积集胜功德
  于生死海中　　拯济诸沉溺
  过无数劫已　　当得成佛道
  慧眼净无垢　　现证一切法
  具相放光明　　如世间杲日
  令一切众生　　除三毒黑暗
  天人大众中　　最胜无过上
  善调伏有情　　皆令修梵行
  为第一导师　　具足一切智
  得最上菩提　　如莲华出水

尔时世尊。与彼长者。于大众中。授佛记已。时频婆娑罗王国内人民。咸发信心。叹未曾有。由于佛等。专修施行。于人天中。常为主宰。有大威力。常以大悲。利益安乐一切众生。无上菩提。决定获得。是故佛敕。诸比丘等。于此经典。常当受持。为人宣说

广明施行。恐繁且止。持戒功德。今当显示。云何布施之后。即云持戒。此依诸经。次第如是。又诸众生。放逸着乐。多由内心。自邪思惟。随顺造作。乃至现行。流至身语。破毁禁戒。为令众生发起对治。故布施后。说持戒相。若佛弟子。及诸白衣。于彼禁戒。坚持无犯。此说是名清净持戒。若诸众生。发起邪思。身语意业。造众多罪。杀害众生。断人命根。他所有物。不与而取。愖着染欲。心无暂舍。妄言。绮语。恶口。两舌。起大邪见。拨无因果。杀父。害母。杀阿罗汉。以恶毒心。出佛身血。破和合僧。破塔坏寺。盗众僧物。污净行尼。于诸善人。喜生骂辱。常乐聚集。说无义语。轻法慢教。贪营世务。为邪活命。造诸恶业。魁脍狱卒。屠杀捕鱼。穿窬抄劫。乃至贫人微少财物。亦行剥夺。与他毒药。损害众生。象马牛等。乐为犍犗。破坏聚落。斫伐林木。发言碜毒。讥刺贤善。诈现威仪。其心谄曲。善说不善。与令不与。造众罪已。临命终时。种种苦相。皆悉现前。识既灭谢。恶业随逐。堕地狱中。受极重苦。地狱有四。一曰煻煨。二曰尸粪。三曰剑林。四曰灰河。是四地狱。名为近边。复有八热根本地狱。一名烧然。二极烧然。三名众合。四名号叫。五大号叫。六名炎热。七极炎热。八名无间。时彼狱中。有诸狱卒。厥状丑恶。甚可怖畏。或作牛头。驴象头等。其形长大。肥壮多力。身皮黑涩。发毛黄赤。皱眉怒目。褰鼻亸唇。两臂坚硬。手执铁棒。或持利斧。枪戟锤锯。剑轮罥索。种种苦具。皆出猛焰。是诸狱卒。凶险卒暴。于彼罪人。无少慈心。或烧或煮。或斫或锯。寻即命终。须臾复活。或复驱入煻煨尸粪地狱之中。下足燋烂。举复如故。遥见林木。即往逃避。到已枝叶皆为锋刃。从上而坠。斫截其身。有诸鸷兽虎兕师子。摩竭鱼等。张口吐火。齿牙铦利。咀嚼吞啖。造恶有情。有大铁树。名娑拉末黎。上有百千锋刃铁刺。一一铁刺。长十六指。时彼狱卒。驱逐罪人。随其上下。而逆刺之。诸恶飞禽。竞集其上。利喙坚爪。或鹐或躩。狱卒或以大热铁丸。以钤擘口。逼令吞之。或镕铜汁。灌其口中。从咽彻下。悉皆燋烂。或以铁钉。而钉其舌。复以铁犁。使牛耕之。或投罪人大铁臼中。复以其杵。而捣碎之。或以铁匣。而夹其身。耳鼻口中。悉皆流血。一切身分。破坏无余。有大炭坑。极深炎炽。以彼罪人。掷入其中。倏然之间。变成火聚。时诸狱卒。咸共呵责。汝于昔时。多造诸恶。心无慈行。破犯禁戒。今受其报。自当知之。此中极苦。难堪难忍。长时受罪。业尽方出。是故佛敕。汝等比丘。常于此经。受持读诵。为人演说。令修施戒。得成福盖

佛言彼破戒者。由彼恶慧。内心思构。不起对治。热恼逼迫。造作众罪。犹如干枯树穴之中。置之炎火。必为所烧。如败种子。虽植良田。毕竟不能生长其芽。彼破戒者。于佛法田。不生善芽。亦复如是。又如林木。悉伐其本。茎干枝叶。不复滋茂。破戒之人。断其善根。坏功德法。亦复如是。犹如枯井。诸渴乏者。欲求其水。必不可得。彼破戒者。一切善人。从其求法。亦不复得。如旃茶罗。不堪为王。一切人民。不肯信伏。彼破戒者。不堪说法。一切众生。不能听受。譬如人于腐烂甘蔗。欲求其味。终不可得。若于毁犯。禁戒之人。求其功德。毕竟无有。又诸白衣。见彼沙门。孤单无累。寂静安乐。弃舍其家。乐作沙门。彼无正因。心不决定。愚痴暗钝。作沙门已。复乐经营世俗事业。愖着染欲。破毁禁戒。时彼众中。有诸耆德。呵责于彼。为说偈言

  汝持佛三衣　　乐作非法行
  污辱彼净众　　旃茶罗无异
  内心邪思惟　　五欲诸境界
  犹如彼犊子　　常念于水草
  乐作世俗事　　货易诸珍异
  增减其价直　　言说无诚实
  彼则如漏卮　　其心常不足
  为求少财利　　营构虚诈事
  譬如蜂采花　　当依莲花林
  返入荆棘丛　　枉受诸艰苦
  我佛法大海　　终不容其尸
  彼碱卤田中　　不复生种子
  如癞病萦缠　　无方可疗治
  汝作诸恶业　　何不生惊怖
  亦如漏舡舫　　自他岂能渡

佛言。破戒之人。无所堪任。由多欲故。心则多求。侵犯他色。常怀惊惧。失坏名闻。离善知识。当知此辈。如彼悭者。毕竟无有少施功德。彼破戒人。如贫无手。虽至宝山。而无所得。如不净瓶。满而流溢。如彼陷阱。人见远避。如室中蛇。人常恐惧。如好园林。中蹲猛虎。如险恶道。人不欲往。如彼破车。不能运载。如彼恶人。众皆摈弃。如彼毒蛇。眼不欲视。如尸陀林。人多厌恶。如彼狂象。恶人所制。如窃盗人。富者所忌。犹如彩画占博迦花。彼无戒香。亦复如是。如旃檀林。有[卄/毘]麻树。其臭相杂。速当斫伐。假使口中。有百千舌。不能尽说破戒过失。欲知其数。无有边际。由破戒故。不能增长一切众生平等善法。如契经说。有一士夫。谓其婿曰。汝今驾车。入林伐薪。由伐薪故。乃失其牛。因寻牛故。令人守车。牛尚未获。车复失矣。是人周慞。处处推觅。到一池所。见有飞禽。即取其斧。远而掷之。击禽不中。斧坠池中。脱衣岸上。入池求斧。斧不复得。衣为人偷。裸形归家。时已昏黑。既至门首。潜窥窗下。彼家中人。咸谓贼至。以杖击之。而伤一目。眼中流血。闷绝于地。时有恶虫。从上而坠。闻其血腥。复食一目。向晓丈人自舍而出。知其是婿。怪而诘之。具陈上事。即为其婿。乃说偈曰

  失衣及坏目　　人身何所为
  既不堪承事　　由此而遐弃
  亦如佛弟子　　宁废其多闻
  于戒当护持　　破戒如无目
  是知毁戒者　　假名为沙门
  不应受供养　　失诸善功德

此中复说。譬如长者。而有多子。常加训诲。令无放逸。即以库藏。种种财物。奴婢仆从。悉付与之。如此则能长守快乐。其诸子中。或有奢侈。乐着女色。长者闻已。即集亲属。苦切责之。以少财物。遣出其舍。复诫之曰。慎莫放逸。散坏汝财。后受贫苦。为他所弃。是长者子。不从其教。未久之间。所费都尽。形容憔悴。以乞自活。为彼亲族之所恶贱。时父长者。见已忧恼。心则弃舍。于众人前。高声唱言。此非我子。此非我子。令彼闻已。深怀惭恧。佛言。我亦如是。若诸弟子。破毁禁戒。无惭无愧。即便摈出佛法之中。亦不付与菩提分等。诸功德法。种种圣财。乃于人天。沙门婆罗门等。大众之中。高声唱言。此破戒者。非我弟子。令彼闻已。羞耻过罪

又诸白衣。既出家已。当依沙门。清净而住。着袈裟衣。执持应器。被精进镫。修习多闻。返依世俗。作邪活命。乘御象马。身擐甲胄。持弓负矢。入军阵中。如是等比。于我法中。毁坏律仪。眼不欲视。譬如世间彩画灯炬。设使众多。不能除暗。彼愚痴人。不能发起无漏圣智。为世照明。亦复如是。如俳优者。着妙衣冠。于众人前。自称王者。然彼实无第一娱乐。破戒之人。虽服袈裟。作沙门相。则无清净出世妙乐。又如贫人。诈称豪贵。于大众中。高声自谓我是长者。然彼实无随意自在。彼破戒者。假名沙门。则不能得解脱妙果

福盖正行所集经卷第十福盖正行所集经卷第十一

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

此中复说。破戒之人。于诸如来所有种种功德善法。不能成就。譬如王女出降贫士。至彼家已。谓其夫曰。我是王女。所欲如意。当须上妙烧香花鬘。众宝璎珞。严身之具。库藏诸物。皆悉周备。若如是者。我则住此。贫士答曰。如上诸物。家中所无。王女闻已。乃呵责之。如是贫乏。我当去矣。佛言。彼破戒者。亦复如是。不能成就最上清净解脱之女。亦不能得暖顶忍等所烧之香。亦不能得别解脱戒所成之花。亦不能得禅定解脱所成之鬘。亦不能得菩提分等种种库藏。亦不能得闻思修等所成智王。亦不能得最上最胜正等菩提。亦不能得缘觉声闻为其眷属。是破戒者。由无善业。于现生中。则无福德。一切善人。不乐同住。有所言说。人不信用。于出世间所有如来功德法财。则为永失

是时会中。尊者阿难即从座起。前白佛言。云何世尊。于弟子中毁犯戒者。不为宣说甚深法要。不复摄受。而见摈斥。咸谓如来非大悲者。佛告阿难。我于世间一切众生。平等怜愍。于所说法。心无吝惜。由彼非器。不能堪任。故不为说。非如世间智者说法。于诸众生。有违顺相。若相违者。不为宣说。如拳握物。秘之不与。如有国王。作大施会。召诸沙门。婆罗门等。所须之物。皆给与之。有婆罗门。从余方来。住立王前。多乞诸物。王闻语已。悉不与之。时有近臣。劝王随意施婆罗门。王乃答曰。非有所吝。此人无德。故不与也。佛言。阿难。我亦如是。由彼破戒。非是法器。故不为说。设为彼说。不能领受。如器有窍。不堪贮水。纵使昼夜勤力添汲。寻复漏失。是破戒者。不能容受功德法水。亦复如是。设使少分违犯禁戒。是人亦于菩提分等。种种法宝。不能成办。当知是人。所持净戒。不名圆满。不复增长。如是戒行。不增长故。于解脱法。亦不增长。于解脱法。不增长故。彼所获得。非寂静道。但得名为相似解脱。若于戒法。坚持不犯。是人则于菩提分等。种种法财。各各入解。如理思惟。得安隐住。汝等比丘。于此经典。常乐受持。为人演说施戒功德。得成福盖

若诸比丘。住正思惟。亲近善友。乐闻正法。能除世间忧畏热恼。遮遣恶法。不令生起。如灭炽火。使无遗余。若诸比丘。住邪思惟。引生放逸。令心散乱。则唯摄取五欲因缘。是诸有情生烦恼处。决定失坏诸功德法。如非时雹。伤其苗稼。能招世间种种灾难。常怀谄曲。无有惭耻。为彼白衣。讥毁轻慢。此非法人。志意下劣。于彼沙门清净善果。心不希乐。于诸如来甘露法水。则不能饮。乐作诸恶。求趣险道。摄取地狱。饿鬼傍生。极恶苦处。而为依止。若于佛言。心不信受。虽少犯戒。则受剧报。何况广多造作恶业。所感之果。其苦难量。如伊罗叶龙王因缘经说

如是我闻。一时佛在嚩啰拏城。施鹿林中。仙人堕处。为诸大众。宣说法要。时伊罗叶龙王。知佛世尊在彼说法。发清净心。欲诣佛所。亲近供养。即作是念。我身龙属。多诸冤仇。傥相会遇。必为损害。乃变己身。作转轮王。相貌端严。威德自在。众宝璎珞。庄严其身。持妙伞盖。乘宝辇舆。七宝千子。内外营从。复以九十俱胝军众。前后围绕。复有百千外道梵志。婆罗门等。诸乞丐者。皆悉随从。威神翊卫。如天帝释。即时奔趋如来法会

尔时世尊。有诸四众。天龙药叉乾闼婆等。恭敬围绕。而为说法。时彼众会。见是事已。咸生惊疑。前白世尊。此为何王。威德乃尔。佛语大众。此非人王。且待须臾。自当知之。时彼龙王。到佛所已。头面礼足。退坐一面。佛言。龙王。汝昔愚痴。今受此报。复有何缘。而至于此。宜应速疾起离此处。舍其变现。而作本形。可复来此。显示众会。时彼龙王白言。世尊。我辈龙身。然多冤对。忽此相逢。定兴灾难。由是之故。为变化也。时佛世尊闻是说已。敕金刚手大药叉神。为彼龙王。随逐守护。令至余处。乃复本形。其身长大。粗涩干裂。种种恶相。积集成躯。由先业故。而有七头。一一头上。有伊罗树。由彼树故。动摇苦楚。脓血交流。极甚臭秽。无数蛆虫之所[口*(贊-貝+日)]食。复本形已。还至佛所。彼龙之首。在嚩啰拏城。其尾所至。怚叉尸罗国。时诸大众。久离贪者。睹是恶状。犹生惊怖。咸作是念。此何有情。感报如是。而来此耶。佛语大众。此乃适变作转轮王。来至我所。遣令起去现本相。尔时诸沙门。闻佛说已。咎嗟懊恼。默然而住。时伊罗叶龙王。既作龙身。悲啼白佛。唯愿世尊。大慈怜愍。记我何时。脱此恶趣。佛言。龙王。今为汝说。当生谛信。却后当来。众生寿命八万岁时。有佛出世。名曰慈氏。彼佛记汝所经时分。脱此龙身。是时龙王。闻佛说已。举声号哭。泪若河流。佛以大慈。善言诲喻。汝当自咎。徒增悲苦。今此会中。难可久处。时彼龙王。深自克责。我此恶业。无相似者。愿承佛力。早离此苦。乃作誓曰。从是已后。尽未来世。心不邪思。不生放逸。乃至蝼蚁。不生杀害。作是说已。顶礼佛足。即于会中。忽然不现

时彼阿难即从座起。一心合掌。乃问如来。而此龙王。先作何罪。堕龙趣中。复由何业。而有七头。一一头上。有伊罗树。动摇痛苦。脓血交流。唯愿如来。为我等辈。说其因缘。令知罪犯

尔时世尊谓阿难曰。乃往过去贤劫之中。众生寿命二万岁时。有佛出世。名迦摄波如来。应供。正遍知。明行足。善逝。世间解。无上士。调御丈夫。天人师。佛世尊。时彼龙王。于佛法中。出家修道。作三藏比丘。厌怖烦恼。修远离行。于空闲处。习奢摩他。从定出已。日已过中。入彼聚落。而行乞食。或有所得。或无所得。为人所呵。生诸烦恼。出其聚落。至阿兰若。伊罗树下。往返游行。因以两手。而取其叶。如是数四。摘已复摘。碎以弃之。时佛知已。呵彼比丘。为说戒相。俾令悔谢。彼不信受。而作是言。此无情物。何咎之有。由二因缘。受斯苦报。过时乞食。生于龙中。由不信故。生伊罗树

佛语诸比丘。彼伊罗叶龙王。作少恶因。今受多苦。自作其因。自受其果。非外地界水火风界。而能招集。皆由内心之所造作

若诸有情。毕竟乐作非法黑业。于恶趣中。定受苦报。若诸有情。毕竟乐作清净白业。于人天中。定受乐报。若诸有情。所作之业。善恶相参。杂受其报。是故比丘。于彼黑业。毕竟莫造。于彼白业。决定修作。果报卒至。犹如瀑流。善恶之业。影响无差。如有颂云

  设经无量劫　　彼业不能坏
  果报成熟时　　众生决定受

佛言。汝等比丘。当依佛语。如理思惟。于诸禁戒。不应少犯。是故我今委细分别毁戒过患。为令有情。深生怖畏。永断诸恶。勤行众善。汝等比丘。于此经典。为人演说。成就福盖

是时会中尊者阿难陀白言。世尊。是持戒相。云何了知。佛告阿难。欲入佛法。先持五戒。谓不杀生。离不与取。远欲邪行。断虚妄语。饮酒放逸。如是行相。各各了知。阿难。在在处处。城邑聚落。有诸善人清信士女。依止善法。乐持净戒。发生净心。于此五戒。尽其形寿。而能奉持

如造作福业经说。云何持戒得成福事。若人能于一切有情。不行杀戮。是人得名持不杀戒。杀生者。从初起心。决定当杀何等物命。或令他杀。起加行心。正断彼命。剸割受用。是人名为得杀生罪

若人于他所有财物。离不与取。是人得名持不盗戒。偷盗者。谓于他物。不与而取。或行劫掠。或他遗忘。隐而不与。乃至从初。起加行心。盗其物已。是人名为得偷盗罪

若人能离一切染欲。或于他色。不生侵犯。是人得名持不淫戒。欲邪行者。非亲族家。炫卖里巷。生染欲处。皆不应往。或他亲眷。常所守护。巧设方便。遗其珠璎。或他遭难而生强逼。如是起心。乃至所作。是人名为得邪欲罪。若人能离虚妄所说。发言诚谛。心口不违。是人名持不妄语戒。妄语者。谓见言不见。不实言实。如律中说。如有比丘。自远方来。或有问言。见某人不。彼实见已。答言不见。如是等类。得妄语罪

若人于酒。诫已不饮。或风飘香。亦不欲嗅。是人名持不饮酒戒。酒有三种。一曰苏啰谓以米糪。和合造作。二曰梅哩。唯用根果。或花叶等。取汁而成。此二种酒。具色香味。因风飘香。闻皆欲饮。饮已迷醉。则生放逸。三曰摩[寧*也](切身下同)。此略不说。是三种酒。若乐饮者。是人名为得饮酒罪。又如难祢迦经说。摩[寧*也]酒者。不应造作。比丘饮已。引生放逸。损费财物。受用不充。增益嗔恚。或相驱击。恶言相加。多诸诤讼。已至失衣。裸形无愧。恶名流布。善人远离。废忘诵习大乘经典。减损智慧。增长无明。不敬三宝。父母宗亲。于族姓中。不为崇重。如是破戒。由饮如上三种酒故。生诸过失。是故应知。于杀生等。不复造作。常当远离

福盖正行所集经卷第十一福盖正行所集经卷第十二

        龙树菩萨集

        西天译经三藏朝散大夫试鸿胪卿宣梵大师赐紫沙门臣日称等奉　诏译

今此略明持戒之相。始自诸根。任持密护。饮食知量。减除睡眠。常乐尊重。修诸梵行。闻昔受乐。不喜思念。复能显示沙门功德。出离轮回恶趣过患。近善知识。如理作意。乐闻正法。入解其义。除贪恚痴。断诸烦恼。袪虚妄想。增长明慧。专求解脱。不生疲劳。设有毁犯微细罪垢。悉能发露。而不覆藏。一切财物。心无吝惜。常乐惠施贫苦众生了知五欲多诸过患。于己眷属恩爱缠缚。生远离想。譬之深冤。独处林野。舍诸愦闹。不畜长物。异诸贪夫。有来求法。不生悭嫉。即为宣说。令其信解。能以慧剑。除烦恼贼。得诸善人尊重赞叹。堪受世间上妙衣服。卧具饮食之所供养于诸肉味。弃绝亡想。及世名利。心无希取。于善不善。二种业道。若作若止。决定信解。自入解已。除去我慢。以饶益心。为他演说。化诸外道尼干子等。亦生信解。安住佛法。自三衣外余所有物。以清净心。而施与之。是人则为住圣种族。身心清凉。离诸热恼。了知六处。无有真实。犹如痈疽。为物所覆。常为烦恼蚊虻[口*(一/巾)]食。诸有智者。勤求方便。依正念处。及八圣道。善法香烟。而薰屏之。了知五蕴。犹如芭蕉。若生贪心。作不坚想。由彼贪故。失坏正道。先制诸根。令不散乱。渐令修习住三摩地。了知境界。本性唯苦。犹如棘林。稠密难越。亦如尘垢。坌污有情。以正法水。而浣濯之。如是观察。彼蕴处界。生长诸惑。不可爱乐。此明持戒。而有二种。一者不清净持戒。二者清净持戒。如律中说。有二比丘。精进持戒。各处一方。善名远布。时诸人民。咸仰其德。共诣彼所。亲近供养。是时有王。名迦尼瑟姹。闻二比丘护持净戒。与诸臣从。往至其所。见彼耆年。威仪整肃。修习禅定。乃生敬心。先意问讯。王曰。大德。如此持戒。欲何所求。比丘白言。我意来世愿作国王。王闻语已。不生忻乐。云何持戒。无慧拣择。返趣轮回生死缠缚。汝为诳惑诸天人民。我今于此。不应供养。如是持戒。名不清净。复诣新学比丘之处。王乃问曰。汝今持戒。欲何所愿。比丘白言。承王顾问。我所求者。愿成菩提。利乐群品。王闻是说。心大欢喜。如是持戒。则非错谬。离诸垢染。名为清净。我今应作最上供养。如是沙门。发广大心。帝释诸天。皆应供养。时诸人民。闻王称赞。皆共合掌。礼比丘足。王乃顾彼诸侍臣曰。各持所珍。而以奉施。此则名为清净持戒

如世尊说。有十种缘。名不清净持戒。一者摄取损害。二者深着染欲三者不求出离。四者常生懒堕。五者遍计希求。六者退失正行。七者邪命自活。八者失安隐乐。九者寡闻不学。十者废忘诵习

云何名为摄取损害。谓于国王王子大臣。惧其威势。常当远离乃至种种诸恶律仪。比丘设为渴乏所逼。不应于彼。求水而饮。未断烦恼。未得神足。不能自调。多生惊怖

云何名为深着染欲。于五尘境。邪思相续。自性纵逸。废善修作

云何名为不求出离。舍于胜处。而趣非处。复毁胜处。赞五欲乐

云何名为常生懒堕。数数思念过去所作非义利事。互相执诤。恃己所有资生之具。受用随意。而生憍慢。多于耆年有德之人。不能致敬。托事不起。云何名为遍计希望。谓于知识同梵行者。互相谄赞。苟求利养

云何名为退失正行。乐造诸恶。违越戒法。无善方便。起对治道

云何名为以邪活命。畏己难养。心无止足。如律中说。邪命比丘。作非律仪。矫现异相。于大众中。自矜己德。多言无耻。犹如狂犬。或恃种族。多闻论议。或于非时。为他说法。虽有少德。为贪利故。彼闻法者。多不信受。闻有人言。于某方所。有婆罗门大族长者。施诸衣服种种资具。即至彼所。谓长者言。我为耆德。当以最上奇妙之物。愿先见施。是时长者恐生諠竞。不违其意。而给与之。仆吏见已。咸生轻毁。所施不与。摈遣令去。时彼比丘。心生忧恼。于长者前。而作是言。我先不欲诣劣种姓。求诸所须。今既无得。住亦无愧。彼虽下族。亦能喜舍。如是比丘。巧言诡诈。以多求故。心常热恼

云何名为失安隐乐。彼持戒者。当应安住不苦不乐处中之行。非如外道尼干子等。坐卧棘刺。五热炙身。虚受勤苦。一无果利。若着于乐。亦无所证。但增放逸。后招苦报

云何名为寡闻不学。外虽防恶。内无明慧。一向颛愚。不能咨问

云何名为废忘习诵。但思饱食。不能进修。充饫肠胃。不净流溢。实非沙门。自称梵行。犹如鸣螺。但驰虚声。如是十缘。随具一种。此则名为不清净持戒。诸修行者。应当了知

若人深心决定信解。乃至小罪。生大怖畏。当知是人。善住净戒。如律中说。有一长者。市得一仆。既幼且贫。卖身自济。然彼内心受持佛戒。忽尔长者使令杀生仆即白言。长者正人。云何遣人而为杀业。于善不善。要当分别。为持佛戒。弗敢从命。长者感悟。乃止其杀

复有国王。名计罗迦。常以严刑。而治于世。若彼民庶。有诸过咎。摄属官者。悉当诛戮。时有一人。临当被害。彼旃陀罗稽首王前。我今发心。始受佛戒。于诸罪人。誓不行杀。乃至蝼蚁。亦不损害。王曰汝遵佛戒。违拒国令。既无所用。养汝何益。时旃陀罗复白王言。我今决定。不毁净戒。愿王试观。帝释诸天。尚于佛制。无敢违越。况我辈乎。王曰。实尔。当以严刑。先断汝首。旃陀罗曰。我今此身。摄属于王。然于后世。更有余身。以此持戒善根功德。当得世间上妙快乐。乃至诸天。随意愿往。于未来世。乐求善法。增长信进念定慧力。以功德水。洗涤贪等三毒垢染。净尽无余。决定当得预流等果。乃至如来净妙法身。作是愿已。于大众前。高声唱言。我今此身。从因缘生。于刹那顷。必当就尽。为护佛戒。心无忧怖。王闻是说。益增忿怒。即敕使者。驱旃陀罗。于尸陀林。而断其命。时诸人民。咸生惊叹。乃相谓曰。此大丈夫。甚为希有。为护佛戒。捐其躯命

是故当知。一切众生。匪拘小大种姓高下。但能深心。具诸惭愧。决定信解。而不毁犯。则得名为清净持戒

此中复明不清净持戒。如律中说。有一比丘。修远离行。栖止岩谷。忽于夜中。自取糗食。由匆遽故。而破其器。时众闻已。诃彼比丘。虽处山间。而非时食。此则名为不清净持戒

复有比丘。本婆罗门。后依佛法。出家修道。乐于旷野。单己而居。由惯习故。常于夜分。折去袈裟。蹲踞而坐。有先徒属。忽来省问。乃语彼曰。此若无人。汝可入彼庵罗林中。采果持来。弟子受教。即住彼所。乃为主者之所执缚。此亦说名不清净持戒

复有比丘。住阿兰若。修寂静行。入里乞食。误过淫舍。彼女问曰。持戒比丘。何故来此非解脱处。若乐和合。当入火坑。如是比丘。难居空闲。不善观察。为彼讥诃。此亦说名不清净持戒

有二比丘。住阿兰若。然实无德。自谓有德。随诸商人。入于大海。暴恶黑风。非时而起。波涛汹涌。咸生惊怖。水族诸兽。摩竭鱼等。交横往返。触坏船舫。彼诸人众。纷扰悲号。或得浮济。或为沉溺。时老比丘。坠水中已。顾己衰朽。命不能脱。即解浮囊。与其同伴。彼既得已。多取珍宝摩尼珠等。遂丧其命。此则名为不清净持戒。次复明彼清净持戒。有一比丘。涉于远道。乃为贼辈。悉夺其衣。中有一人。先作沙门。知其护戒。语彼徒曰。以草系缚。舍之而去。比丘专念佛所制戒。一切草叶。不得挽绝。伏于道侧。不敢少动。遇王畋猎。遥见疑是裸形外道。我慢不起。即往诘之。知是比丘。为护净戒。不伤草叶。王叹希有。乃令释之。为设饮食。复施其衣。此则名为清净持戒

有二比丘。自远方来。欲往供养如来舍利。途涉辛勤。欲求水饮。第一比丘。为渴所逼。不暇观视。即饮其水。第二比丘。虽亦渴乏。验水有虫。谓其侣曰。宁自渴绝。无伤他命。不应违犯世尊戒律。端坐林下。忍渴而终。以是缘故。生忉利天。见佛闻法。证预流果。此则名为清净持戒

有优婆塞。久修梵行。忽尔其舍为火所焚诫诸子曰。汝慎勿以有虫之水。而沃其火。所以者何。我护水中微细诸虫。不顾财货。岂为少利。而堕恶道。此则名为清净持戒

是故智者。应当安住清净持戒。毕竟远离不清净持戒。当知如来出现于世。常乐利益一切有情。闭恶趣门。示生天路。烧烦恼薪。拔贪欲本。化诸众生。舍家离缚。皆令获得吉祥安乐。究竟超越生死瀑流。乘智慧舟。到于彼岸。渐次圆证菩提涅盘。建大法幢。摧诸外道。我慢高举。诸不善行。皆使发心。勇猛精进。以正法水。洗其渴乏。彼闻法已。依教修学。积集法财。功德宝藏。安住神通。出离三有。了胜义谛。住解脱处。如是持戒。诸佛所赞。当知是人。为世间眼。能导众生。至安隐处。亦如明灯。能破痴暗。如清净水。能涤罪垢。如妙良药。疗烦恼病。如大医王。善拔欲箭。如世良田。生功德苗。善能教示懈怠众生。令生喜心。乐持净戒

若人乐作不善业道。如冤同居。必遭损害。如依外道婆罗门法。而求出离。返招殃咎。当依往古诸佛教法。袈裟幖相。以求解脱。则能销灭诸不善根。令诸魔军。生大忧怖。以智慧力。断除烦恼。得大名称。离诸衰患。究竟成就妙菩提道。如说马鸣智者坚持净戒。善说法要。现生获得名闻义利。复生天中。受胜福报。增长明慧种种功德。当知善能持净戒者。犹如贫士。获其贤瓶。随所求者。皆得如意。常当精进。恭敬守护。如事师尊。无疲劳想。持净戒者。亦复如是

如世尊说。清净持戒。则能获得十种功能。一者由持戒故。凡所施为。无有错谬。不生烦恼。心常喜悦。由喜悦故。深心乐法。由乐法故。身得轻安。由轻安故。受胜妙乐。由妙乐故。引生禅定。由得定故。了知实际。了实际故。安住菩提。弃背障染。住无我智。则能永断微细烦恼。我生已尽。梵行已立。不受后有。向涅盘界。二者由持戒故。所有三业。不造众罪。远离恶趣。临命终时。心无怖畏。所作福业。众善现前。随意往生。胜处受乐。三者由持戒故。美名流布。闻者称赞。四者由持戒故。睡安觉安。身心无恼。五者由持戒故。常得诸天爱念守护。六者由持戒故。处大众中。心无怯弱。七者由持戒故。不为非人。伺求其短。八者由持戒故。得诸恶人。视如亲族。九者由持戒故。所须无乏。不假希求。常得善人恭敬供养。十者由持戒故。所愿随心。皆得成就。若欲求生最上种姓。大富长者。婆罗门家。或复求生六欲诸天。乃至色界无色界天。或求离欲阿罗汉果。寂静解脱。咸得如意。如是持戒。所获功德。譬如大海。深广无边。若我具足次第宣说。穷未来际。亦不能尽。如向所明。持戒功能。何人曾获如是胜报。如佛大仙。皆悉成就。从初发心。修持净戒。乃至获得三明六通。力无畏等。三十二相。八十种好。美妙分明。圆满无减。绀发右旋。如蜂黑润。项[佩-一]圆光。犹如满月。面貌端严。如莲华敷。形仪挺特。如融金山。双足平正。妙善安住。身肢圆满。如尼俱律陀树。常以爱眼。视诸众生。凡见佛者。皆蒙利益。方便拔济。出离恶道。于诸世间。而无与等。故号如来。应供。正遍知。明行足。善逝。世间解。无上士。调御丈夫。天人师。佛世尊。若诸众生。受持净戒。则能获得如上功德。与诸如来。等无有异。善能利乐一切有情。故布施后。明彼持戒。次第行相。如前已说。汝等比丘。常当一心。乐行施戒。为人显示。则为具足成就福盖

福盖正行所集经卷第十二


广大发愿颂

    No. 1676

广大发愿颂

        龙树菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护等奉　诏译

  所有一切众生类　　过未现在世无尽
  而诸佛刹广无边　　彼无边刹尘充满
  又一一尘为一刹　　广大佛刹如尘等
  一一刹中正觉尊　　如尘无量我普礼
  彼尘倍聚诸佛刹　　刹中佛佛我称赞
  我常供养以一心　　经如尘数广大劫
  顶礼诸佛及法众　　我于三宝常归命
  我悉持以诸妙华　　及众宝聚常普施
  若我已起一切罪　　我今普尽而忏悔
  若我未生一切罪　　我一切时常远离
  所有一切胜福事　　我于一切常随喜
  此福回向于有情　　及佛无上菩提果
  如佛正法中所说　　愿力坚固复真实
  我常供养诸世尊　　愿我最后得成佛
  愿我生生具深智　　常如妙吉祥菩萨
  悲心息苦救世间　　愿如观自在菩萨
  贤善爱眼视众生　　愿与普贤尊无异
  慈意善观诸情品　　愿我常如慈氏尊
  布施愿如虚空库　　持戒愿如神通慧
  忍辱精进二度门　　愿我悉如常精进
  定力能摄诸散乱　　愿我得如金刚手
  善说十地诸法门　　说智愿如金刚藏
  于佛世尊善请问　　愿我得如除盖障
  深心智慧具坚固　　愿我常如坚固慧
  神通无碍善方便　　愿我得如无垢称
  善护众生诸善根　　勤勇愿如常勇猛
  善说波罗蜜等法　　愿我得如无尽意
  具足无量妙音声　　愿与妙音尊无异
  近善知识心无懈　　愿我生生如善财
  虚空无喻法能宣　　愿我得如虚空藏
  地能长养诸世间　　普利愿如地藏尊
  息除贫苦利众生　　愿与宝藏神无异
  语出无尽妙法宝　　愿我得如昙无竭
  智慧坚利复常勤　　愿与常啼尊无异
  此等最上诸佛子　　最胜功德聚无边
  名称广大复无尽　　愿我名称亦如是
  我此赞佛功德聚　　最上胜善极广大
  普愿世间诸有情　　住彼最胜功德聚

广大发愿颂


广释菩提心论

    No. 1664

广释菩提心论卷第一

        莲华戒菩萨造

        西天译经三藏传法大师施护奉　诏译

  归命三世一切佛　　略集大乘诸法行
  建立最初胜事业　　我今广释菩提心

此中云何。若欲速证一切智者。总略标心住于三处。出生悲心。从悲发生大菩提心。所有最胜一切佛法。皆由悲心而为根本。此悲所因为观众生故。如圣法集经云。尔时观自在菩萨摩诃萨。白佛言世尊。诸菩萨不应修学多种法门。但于一法而自勤行。即于一切法如掌中得。何等一法所谓大悲。诸菩萨乘此大悲。即于一切佛法如掌中得。世尊譬如转轮圣王轮宝行处。即得一切力聚。而诸菩萨亦复如是。大悲行处。即能成就一切佛法力聚。世尊又如士夫命根坚固。即能令诸根而得转故。而诸菩萨亦复如是。大悲坚固。乃能令诸菩提行法而得转故

如无尽意经云。复次舍利子。当知诸菩萨大悲无尽。何以故与一切法为先导故。舍利子譬如士夫所有命根与出入息而为先导。大乘法门广大普集亦复如是。菩萨大悲为先导故。如象头经云。尔时有一天子。问妙吉祥菩萨言。当云何能发起一切菩萨胜行。复云何住。妙吉祥言。天子大悲乃能发起一切菩萨胜行。菩萨缘诸众生为境界住。是故菩萨常起爱念一切众生。而于己身无所顾惜。纯一为他长养利益。于长时中难作能作。发生诸行

如信力法门经云。彼诸菩萨悲心坚固。为救度一切众生。时而无少分苦想。若得度已亦无所度之想。不舍一切难行苦行。如是不久诸行圆满。成本所愿证一切智。得一切佛法。如是皆由悲为根本。所有佛世尊现证一切智。大悲普摄。广为世间作最胜利益。安住无住涅槃。如是佛所行。悉以大悲而为其因。诸佛因中设有苦恼。尔时乃缘众生作意。转复多作增长不退。如佛于诸经中说。一切众生于诸趣中有种种苦。如其所应极大苦恼。菩萨常为众生悲愍观察。所谓地狱趣中有种种苦。业火烧然长时无间苦恼无尽。如世盗贼种种治罚。系缚捶打铁叉驱逐。断截身分受诸苦恼。此苦亦然。饿鬼趣中有其种种极饥渴苦。身体干枯。为伺求食故互相残害。虽常伺求纵经百岁。终不能得少分残弃及不净等。又有饿鬼自力劣薄依他胜者。虽复依止而无所得。设有所得。转为强力诸鬼。欺陵逼夺埵打治罚。受如是等无量苦恼。受是苦者。是昔人中富乐自在等类。由起诸恶故堕是趣中。畜生趣中受无数苦。起恚害心互相食啖。或有穿通其鼻或破裂其身。或打缚等极不自在。遍身楚痛。实无少分可爱乐处。如人负重尝无懈倦。虽复长时不念疲乏。又诸畜生于广野中一心肆逸。此彼奔驰曾无暂住。互相残害互起怖畏。于此趣中复有是苦。如是地狱饿鬼畜生诸趣。由起种种烦恼恶业。为其因故。彼彼趣中受诸苦恼。如人堕于崖险之处。苦恼亦然。彼人趣中有种种苦。如余处说。复次欲界诸天。欲火烧然心意散乱。欲令自心于刹那间定聚一处。竟不能得。当知欲乐坏时苦即现前。如贫苦者云何有乐。此欲天中常所堕灭。怖畏忧恼及破坏等亦非其乐。所有色界诸天。谓由诸行常所迁转。彼天报尽。或复堕于地狱等趣。如是等诸趣类中。烦恼业等常所缠缚不得自在。由是生诸苦恼。是故当知苦火炽盛。烧然世间而不休息。菩萨见是苦已即起悲心。普观一切众生。又复菩萨见诸众生受种种苦时。无怨无亲起悲愍心。平等观察而为救度。又一切众生无始已来轮回流转。菩萨未尝于一众生不起亲友之想。起是平等心故。即以是行。于十方一切众生普遍观察。若见一众生有苦恼者。菩萨爱之如子。即当代受不令众生受是苦恼。以是悲心转故。能令一切众生苦恼息灭。乃得成就大悲胜行

如无尽意经云。此悲观行。世尊于阿毗达磨经最初演说。为欲救度一切有情故。起悲愿等力。趣求阿耨多罗三藐三菩提。若不为度众生我即不发是菩提心

如十地经云。一切众生中。诸无救护者无归趣者。无依止者无知见者。菩萨见已即生悲念。乃发阿耨多罗三藐三菩提心。若不为他开导教示。菩萨即不发阿耨多罗三藐三菩提心。是故当知诸菩萨。勇发阿耨多罗三藐三菩提心者。谓即悲心坚固

如如来智印三摩地胜上经云。菩提心所行能坏轮回苦

如弥勒解脱经云。善男子譬如有人不取大金刚宝。别得一切金庄严具。而亦不舍大金刚宝。于贫穷者而能普济。善男子。菩萨亦复如是。不取一切智心大金刚宝。别得一切声闻缘觉功德金庄严具。而亦不舍彼菩萨行。所有一切轮回贫穷者而能普济。菩萨能于一切种一切学。平等而修。是为无量胜行。是故从菩提心出生方便。成就大菩提果

如如来示教胜军王经云。佛言大王。若汝所作多种事业。于一切种一切处。应共布施波罗蜜多乃至般若波罗蜜多相应而学。是故大王汝应如是于正等觉。起欲信求愿趣向等心。若住若行若卧若立。若饮若食若诸所作。决定常时思念作意。观想一切佛菩萨缘觉声闻。诸愚夫异生及己身等。所有过去未来现在。一切善根合集一处。发胜上心自当随喜已。普于一切佛菩萨缘觉声闻众中。供养承事所有功德。与一切众生共之。普愿众生乃至得一切智。一切佛法皆悉圆满若日日三时。回向阿耨多罗三藐三菩提。大王汝所作事皆得清净。菩提行等亦悉成就。复次大王。阿耨多罗三藐三菩提心。所生善根果报无数。若生人中或生天上。于一切处常得最胜。而汝大王亦如是作。斯为广大。又复大王大菩提心最上最胜。若复所行真实。即能成就大菩提果

如无畏抚问经云。发菩提心所生诸福如虚空界。广大胜上无有穷尽。正使有人以殑伽沙数佛刹。满中珍宝供养世尊。若有人能合掌至诚。一发阿耨多罗三藐三菩提心者。而此福德胜前福德不可较计

如华严经云。善男子从菩提心生一切佛法。广大胜上庄严。菩提心有其一种。一者愿心二者分位心。又彼经云。善男子一切众生极难得者。所谓阿耨多罗三藐三菩提。若广起行愿。即得阿耨多罗三藐三菩提现前安住。普尽世间能作利益。善男子我得成佛。谓由发起求菩提心乘本愿心。后以所行诸行。从先所起彼一切行。而悉普摄成分位心。是故行愿等力若悉成立。即得善知识现前摄受。舍去一切不实境相。如妙吉祥菩萨于上衣王所发菩提心。菩萨如是发菩提心已。自行布施等诸波罗蜜多相应胜行。若人自不能调伏。何能调伏他人。是故当知菩萨若不自修诸行。而何能得大菩提果

又如象头经云。诸菩萨所行真实故得菩提。非诸所行不真实故

如三摩地王经云。童子如我所行得真实故。而汝童子应如是学。何以故童子。若所行真实。即不难得阿耨多罗三藐三菩提

如是菩萨诸所行行。若以十波罗蜜多四无量四摄法等。广分别者。如无尽意经宝云等经说。又学有二种。谓世间出世间。云何世间学。谓技能功巧等。云何出世间学。谓禅定等。余复云何。谓利益众生所作一切事业。此中应知诸菩萨所行。要略而言谓慧及方便。而此二法无令减少

如维摩诘经云。菩萨无方便慧缚。有方便慧解。无慧方便缚。有慧方便解。又如象头经云。诸菩萨总略而言有二种道。于是二道若具足者。诸菩萨即能速证阿耨多罗三藐三菩提。何等为二所谓慧及方便。若离般若波罗蜜多行。诸波罗蜜多四摄法等。云何能严净佛土大富自在。成熟有情作诸化事。普摄诸法善巧方便。是故此慧与彼方便。为无颠倒性。有分别因。由此因故起正方便。如所说诸法。起无颠倒思惟分别。而能毕竟利乐自他。能令烦恼不起。犹如诸毒为咒所害。又此经云。智慧摄方便。此是有分别智

又如信力法门经云。云何为善巧方便。谓摄一切法。云何为慧。谓于一切法无破坏善

如是慧及方便二种。遍入诸地一切时常行。不得于中令其减少。所有十地诸菩萨。行十波罗蜜多乃至广行诸行。如十地经广说。所有八地菩萨。从佛威仪起住止息行故。彼经云。复次佛子菩萨摩诃萨。应当依先所起大愿加持善根力住。诸佛世尊亦从是法门。流出大智圆满诸所作。此即是为最上忍门。一切佛法由此而集。又善男子不应如是起止息行。如我所得十力四无所畏十八不共。诸神通等一切佛法。而汝未具当发精进。起诸愿求相应而行。是故汝于如是忍门。不应舍离。善男子汝岂不观察诸愚夫异生等。积集种种烦恼。起种种寻求相续不断。云何欲起止息之行。又善男子。当知诸法法性而自常住。以法性常住故。如来即无生。谓诸声闻缘觉。不了一切法无分别无生故。如来以善方便出现世间。又善男子。汝见我身无量智无量。佛刹无量圆光无量。智现前门无量清净无量如是等诸广大法。是故汝乘本愿行。应常思念利益众生。即得如是不思议智门

如十地经所说行相。与维摩诘经相违故。彼经云妙吉祥若人于如来所说法起轻谤者。是人虽出谤言。如我所说亦得清净。此中理事亦不相违

如象头经云。佛言慈氏诸菩萨为菩提故。积集六波罗蜜多。或有痴人作如是言。般若波罗蜜多是菩萨学。云何复学余波罗蜜多。或有闻已于方便等诸波罗蜜多起舍离意。慈氏于汝意云何。如迦尸王取自身肉而救于鸽。是王岂愚痴耶。慈氏白言不也世尊。佛言慈氏我修菩萨行时。广修六波罗蜜多相应善根。应无利益耶。慈氏白言不也世尊。佛言如是慈氏。如汝于六十劫中积集。布施等诸波罗蜜多。乃至六十劫中积集。般若波罗蜜多亦复如是。彼中广说行。相应知

广释菩提心论卷第一广释菩提心论卷第二

        莲华戒菩萨造

        西天译经三藏传法大师施护奉　诏译

复次此中如毗卢遮那成佛经说。所有一切智智。悲心为根本。从悲发生大菩提心。然后起诸方便。是故诸菩萨于一切时。常行此二种。所有施等方便现身现土。眷属色相广大果报。二种摄故悉得成就。如佛世尊不住涅槃。为令一切起于正慧。普能断除诸颠倒故。又复不住生死。为由生死起颠倒故。是故世尊成就无住涅槃。又复当知慧及方便自相所行。应当远离共相毁谤二边。离二边故中间所行即得无碍。所言共相毁谤边者。谓慧离共相边。方便离毁谤边。此中如是。如圣法集经言。若诸相好色身具足。即能令观者起胜意乐。若于三昧中观法身者。即不能令起胜意乐。复有说言。慧及方便生诸如来。能令他起清净信解。如是应知。又复有言。如世间法应当了知。法尚应舍何况非法。离取相故。彼诸颠倒取着心断。由彼断已此说。是为真胜意乐。不应于彼所作事中。而起决定实依止心。亦如有说。一切法中亦不可取亦不可舍。彼取舍法不可得故

或有说言。施等诸行感生死果。此中云何谓离于慧而行施等。得少分善以为喜足起勇悍心。复作增上胜善根想

如维摩诘经说。所有一切法。应与慧及方便二种俱行。施等诸行若为慧所摄。即得名波罗蜜多。名异此即非施等清净

此中当知。若住三摩地能生起诸慧。加行专注总彼所作。谓由先起闻所成慧。以本宗义而正摄持。然后思所成慧乃得生起。于是思慧中观察如实义。彼所观察决定真实。无别邪妄不实颠倒。如是观故疑惑止息。正智出生如理正修。如佛树诸外道说无我法。是中应当思惟观察。必有正因得涅槃果。异此皆是外道常因分别。非为寂静。是故杂阿含等说。思所成慧中如理伺察已。应观诸物有实自相。而彼自相胜义谛中即无有生。如是阿含中所说决定相应

如圣法集经说。无生真实不实谓别异法。如是等皆随顺胜义谛无生。此说真实。又胜义无生即非无生。彼一切所行皆过去性。此中又言。善男子生灭二法毕竟皆是世间取着。是故佛大悲者。为欲警悟世间舍诸所行。说生灭等毕竟无有少法可生

又圣法集经说。云何生云何灭。答无生名生无灭名灭。此中又言。阿字门谓一切法离生灭。是即一切法无自性门。自性空所成

圣二谛经说。若无生平等。即得一切法平等

般若波罗蜜多经说。须菩提色色自性空。乃至识识自性空。自相空所成。象腋经说。一切性不可得生。于无生性中。愚者执有其生

父子合集经说。彼一切法皆悉平等。三世亦平等。过去一切法自性离。乃至现在一切法亦自性离。如是总说。彼阿含中相应坚固之义应当伺察。异此有因即不能成。此中如理决定伺察已。要略说者。谓诸生性或说有因或说无因。如实当知。非彼有因非彼无因。是义云何。若舍因性。此差别性或有实显示。非彼无因。若法生时乃一切性遍一切处。云何非有。彼无性时或无差别。于生时中亦非有得。非彼有因。如是总说。彼非无因而得和合。亦非有因而得和合。如是所说若计有我即是外道常因起执。彼无性得生。能起诸行而为显示。坏诸因性何能生起诸行。不如理舍故。又非外道所执我等自有力能。于他别法得不舍性。既执常性不能于他作义利事。若无义利背相应法。此中如是当知。所执我等一切力能。毕竟皆空如石女儿。彼无自性于所作事中。不能成就彼等。设有所作无实力能。若非所作又非和合。又如一切事随有作。生已后时决定。若有力能即彼力能。自性随转乃如前说。所起作事而得和合。或不随转亦如前说。彼无自性无常因性定不和合。是故诸无常中无有少法可得

此中意者如世尊言。复次大慧。不实共相者。所谓虚空灭涅槃无作者。无性无取者共相。是故无常等。生此不和合而亦非无常。如过去未来二事性中。亦非有生而得和合。彼无和合因性随转。若同时生有所相应。亦非同时因所作自性事得决定。彼同时观亦无所成性。或异时观亦非异时。若于时中缘中观者。彼亦不生不实。过去若生有所和合。而亦非缘亦非有生。彼一切我而亦无缘。又非一刹那中一切刹那随入。劫与刹那分量而不和合。如诸微尘合集抟聚。是中亦无极微量我而得和合。如是一聚一分中。彼刹那蕴聚性不和合。自不得生亦无因分。若于是中取彼分性。即自我所作相违亦无二种。若有二分性即二种过失随着。如是总说。是故一切世俗所生有所得性。于胜义谛中而实无生。此说不与阿含等相违

如佛所言。诸有生性皆谓世俗。胜义谛中生无自性。无自性中若起疑惑。彼即实起世俗之意。所说如理。是佛世尊真胜意乐。如世稻秆等。自性他性于二种中说无因生。是义当止。此中宜应如理伺察。若色无色彼之二性如瓶器等。彼极微量不坏色性。于前分位而非一性。前分位中若有所坏彼即不成。又非极微聚中有一性多性。彼一多性离云何有自性。若无自性此即胜义。如梦中所得色相色性。其义应知此即佛所说

如楞伽经说。复次大慧。譬一大象破如微尘。于是微尘相中。如理伺察彼之色性实无自性。又如色蕴中青等诸色。彼有对碍而无自性。如是毕竟识外非色。是义应知

如世尊言。外无诸色自心所现。彼外青等种种色相实无对碍。而取舍相亦无对碍。非一性相应。亦非多性相应。一多相违云何非一性。以一聚色性故。非一生非多性者。其义应知。此中伺察诸有色相。自体不实故无对碍。彼识亦不实。何以故识自相离。非说彼色离识而有。又复识之自相种种不实。由如是故说识不实。是故佛说识如幻士。如是总说若一性若多性是性皆空。胜义谛中一切性不实此义决定

又如楞伽经说。譬如镜中所见之像。非一性非异性。如是观时是性非有。何以故一异性离故。一异性不着故。或有说言。智者观自性实不可得。此中不可显说无自性故。如是等诸有所说如理伺察。是为思所成慧决定如实。是义成就由此修所成慧当得生起。若无闻等修慧不成

如宝云经说。诸正行者有智光明。出生中间彼正不坏。由智出生诸所修作出生成就。譬如地中不净遍满。诸有所生云何能生。诸修亦然。明了智果真实性中如理出理

如三摩地王经说。若有人起多种寻求。而所起心有著有依止。是故若欲证彼真实修慧者。应当最初修奢摩他相应胜法。令心安住犹如止水。若心有动非奢摩他。不能摄持而住。如佛所说。住等引心能如实知。若散心位非此相应。是故修奢摩他时。诸所得诸所欲。当住平等舍。体中苦等而悉除遣。安住净戒发起精进速得成就。此中如是

如和合解脱经说。先修施等胜上之行。次复修持净戒。然后住于奢摩他行。若欲住是奢摩他者。随诸分位。于诸佛菩萨等先当归命忏悔随喜。次应起大悲心普尽世间生救度想。于安隐座中加趺而坐。直身端住现前正念。引发三摩地。现前相应。从初专注如应观察。乃至多种所缘等事。普尽收摄系心静住。复次总略。色无色二种中。应当舍离散乱过失。总彼相应所缘起胜作意。乃至蕴处界一切事等。悉不分别即得清净。所有广说诸所缘行相。如和合解脱经第十八相应分

所有世尊摄有情事。色等分别及一切事分别。略中广行相。如阿毗达磨等说

此中意者于彼等事。观已离过而悉收摄。令心相续胜进增修。若或心生贪等。尔时应作不净等观。得止息已。又复过前起胜进心。此不净等观思有行相。恐繁且止。若或彼心不能胜进起胜意乐。亦是散乱过失。尔时应观三摩地所有功德起胜意乐。即能止息非胜意乐。若时昏沉睡眠生起。应观佛等功德胜喜悦事。彼能止息。复次如是于所缘中。如应坚固摄持不散。即得相应。又复若时前心爱乐喜悦。随生后心高举。尔时应作无常等观。如是总说。于所缘中应使心无动作。专注静住离高下法。平等所行心得清净。彼发悟散乱等因而悉弃舍。若有真实发悟所作彼心散乱。于所缘中若无动作。如是乃得所欲所行胜定相应。尔时当知奢摩他成。如是等当知一切奢摩他共相。谓心一境性中自性。彼奢摩他所缘决定如是。此等奢摩他法。佛于般若波罗蜜多等经

复次当知。修奢摩他有九种法。一除。二正除。三分位除。四近除。五调伏。六止。七近止。八一向所作。九知止。此等九种行相云何。谓遍此九法是即名除。于所缘中系心是为遍除。于所缘中相续而转是分位除。散乱现前而悉摧伏是为近除。散乱离已又复胜前。遍除所缘是为调伏。若爱起时伏故名止。若散乱过失现前不起。胜意乐而能止故是为近止。若昏沉睡眠等起时。速当遣离是为一向所作。于所缘中得无动作已。然后专注得相应止。得彼止已心住于舍。是为知止。如是等义。如圣慈氏菩萨所说

又复当知诸修一切三摩地时。有六种过失。一懈怠。二所缘忘失。三沉下。四高举。五无发悟。六发悟。此六过失生时。当起八种断行对治。何等为八。一信。二欲。三勤。四轻安。五念。六正知。七思。八舍。此等对治行相云何。谓信等四法对治懈怠。此中意者。以三摩地功德中。要具增上正信顺相。彼相应者起胜希望。于希望时发精进行。所起精进身心勇悍后得轻安。是故对治。念对治所缘忘失。是义应知。正知对治沉下高举。谓以正知起正观察。能令高下二法止息。是故对治。思对治无发悟。是义应知。舍对治发悟。由前高下得止息已。心住正直即无发悟。是故对治。如是八断行。对治六种过失已。所有最上三摩地事业即得成就神足功德由此而生

如诸经说。若具八断行。即能发起四种神足。所有心一境性。胜上事业得正相应。乃能证入禅定解脱法门。圆满一切最胜功德

广释菩提心论卷第二广释菩提心论卷第三

        莲华戒菩萨造

        西天译经三藏传法大师赐紫沙门臣施护等奉　诏译

复次此中次第应修彼诸禅定。谓若得离欲爱所有喜乐。内心清净住正相应。有寻有伺是初禅定。又复此中无寻唯伺。名中间禅。初禅地爱若得离已。所有喜乐内心清净住正相应。是二禅定。二禅地爱若得离已。乐舍正知住正相应。是三禅定。三禅地爱若得离已。舍念相应。是四禅定。所有无色定等行相应知。是中诸所缘相如应分别。于所缘中令心坚固。如理所作以慧观察。智光明生破无明种。毕竟得断即正相应。异此皆是外道所修。非正三摩地。不能断烦恼

如诸经说。所有正修三摩地时。若我想生。是即还复发起烦恼。尔时住心当如止水。入三摩地相应观行

如楞伽经说。总略而言。正慧观行唯心静住外无分别。若住真如所缘是心应过。心若过已彼无对碍而亦应过。无对碍中若相应住是大乘观。彼无发悟最胜寂静。即胜无我智无对碍观

此中意者。如实观察心外必无色法分别。是即最上相应胜行。若尔识之与色云何有异。或不异者识亦应有对碍义耶不然如梦分位所见不实。是故识外如实伺察。极微量色取不可得。以不可得故如是成唯识。无复一切外义可有。唯心静住外无分别。于伺察中以离色法故有所得相。而为得者毕竟无所得。是故于诸色法应观无色。彼若唯心无实能取亦无所取。是二取性实不可得。离取舍故即心无二。如是伺察亦无二相。于真如所缘中是心亦过。彼所取相亦复过已。二无对碍。于是无二智中住如实义。所言唯心过已二无对碍。是智于中而亦应离。是故自性他性中诸有生性而不可得。如应伺察诸众生性亦不和合。若取若舍二不实性悉应远离。当知一切物性诸有取着。于无二智中皆应舍离。于无对碍无二智中若如是住。即于一切法如实觉了无有自性。彼即能入最上实性。入无分别三摩地门。又若于是无对碍无二智中相应住者。是即最上实性中住。是大乘见。如是亦见最上实性。以见最上实性故。即于一切法慧眼观空。智光明中皆如实见

如诸经说。云何见胜义谛。谓一切法无见。此中如是。所言无见者。是胜意乐真实无见。非如世间诸生盲者及瞑目人。缘阙故或不作意故而皆不见。彼等有性颠倒种子悉不能断。此即不然。又如入无想定。后或出时还复生起有性取着。贪等根本诸烦恼聚而不解脱。所言有性取着贪等根本烦恼行相。如圣二谛等经说。若复有言入无分别总持法门。无分别法中离色等相。以决定慧于无色中。观无所得亦无作意。是胜义乐。非如无想定等。于诸色等取着法中作意而离。是故当知如前所说。诸色等中作意离相。若无正慧即不能断疑惑种子。譬如世间火若存时诸物烧然。云何能离思之一法。若不调止所有邪

由此当知。所有奢摩他诸所缘中。心住坚固如理所作。以慧伺察智光明生。明现暗除智生障灭。如人二目随量无差。于诸分位照明无异。智光明出亦复如是。非光明中有冥暗性。明暗二法互相违故。当知三摩地中离冥暗性亦复如是。若不尔者。云何能住心一境相。是故若于三摩呬多中如实了知。即能一向随顺正慧。此中所说悉不相违

复次三摩呬多中。应以慧观都无色相。于一切法悉无所得。彼诸相应分位相中。无所进趣无所发悟。若自若他悉见无性。有性分别戏论相等一切息灭。如是即于正慧所观无相性中而得相应。有心分别悉不能立。即彼无性亦不可得。若于是中或谓有性而可见者。是见应止。如是止已。若于无性分别转者。此亦不然。设使有性三时相应。以慧眼观无相无得。又何止邪。如实义者。有性无性不应分别。一性异性亦不可分别。是中若离性与无性二分别者。悉能照达诸分别空。即彼能照及所照性亦无所有。如是乃得最上最胜无分别相应。此中若住如是相应。即一切分别悉能断灭。所有烦恼障智障而亦能断。于彼烦恼障不生不灭性中。而性等颠倒根本悉除

如圣二谛等经说。如是相应行中。一切性等分别断已。普尽性等颠倒无明自性烦恼障根本即断。彼根本断已诸烦恼障而悉能断

又如圣二谛经中。问妙吉祥菩萨言。云何能得烦恼调伏。云何而能了知烦恼。妙吉祥言。胜义谛中毕竟不生。彼一切法无生性中。世俗皆是不实颠倒。应当止息一切性等所起颠倒思惟分别。若彼思惟分别不止息者即有我共相。既有我共相即起立诸见。若见起立即烦恼转。天子若能了知胜义谛中一切法毕竟无生。即胜义谛具十种无颠倒。若胜义谛中无颠倒即无分别。若无分别得灭相应。若灭相应彼我共相即不能得。若我共相既不能得。而彼诸见不能起立。乃至胜义谛中涅槃之见亦复不起。由如是故即于无生行中一切烦恼毕竟调伏。天子当知。诸烦恼于胜义谛无碍智中。毕竟空毕竟无相毕竟无性。如是知者是为了知烦恼。天子譬如毒蛇为咒所害。彼烦恼种亦复如是。天子又问云何为烦恼种。妙吉祥言天子彼胜义谛毕竟无生性中若于一切法起分别时。此即是为诸烦恼种。由是起诸性等颠倒。于颠倒中不能照达。是故若于所断法中一切颠倒悉能断者。所有智障能正决定而悉除遣。智障断已无相续性。譬如日光出时离诸云翳。于一切处照明无碍。而彼智光清净照明。若色若心一切自性亦复如是。诸物实性决定常住。于无相续性中。真实了如一切物性如实义者。此中物性。云何能以言词宣说。是故于彼胜义世俗谛中。如如所说如实了知一切色相及诸物性已。即得一切智。如是所说断障等义。是证一切智最上胜道。非彼声闻等道。彼诸颠倒不能尽除。亦复不能正断二障

如楞伽经说。大慧。彼声闻人起别异因有所住着。彼见法已取为涅槃自谓得佛。而不能见法无我理。大慧。此非解脱。如是声闻人自智所证未真出离。谓得出离。异见转故而彼所作非此相应。彼所行道非真解脱。世尊但说一乘之法。不说声闻等道。彼声闻人但于蕴中观察无我。而彼所得谓人无我。此中不然。应观三界一切唯识。若说识外有义得无我者。如是即于无二智无我中。而不得入。以他性得入故。若他性得入者。彼即非入唯识性故

又如此经圣出世品中说。复次佛子当知。三界唯心所现是心。亦无中边可得。若言有边即有所生。若言有中即有所住。一切皆是分别相故。若心无中边。是故能入彼无二智。如是入者是真实入

此中有问。若如是者诸相应分位当云何生。答由彼清净胜愿力故。菩萨发起大悲。普为众生作利益事。从彼愿力。出生胜上诸布施等明白善行。彼即真实清净所生。又复菩萨大悲。若一切众生未能尽入诸法无性清净智中。菩萨乃至随入轮回。亦复不染轮回过失。而岂住于彼无发悟寂静法中。如经颂云

  无对碍中见　　最胜无我智

是故若于无二相中说无二语。是为最胜。即胜义谛中真胜意乐。于无二无对碍智中。毕竟无我无有自性。即得所见相应。彼所有见无别异见。一切无分别及无发悟。一切寂静。又问若尔云何能起诸相应行。答不然若或有见彼实。不能随顺胜义。何以故。是中无有主宰自在相应相故。而何有见。但以世俗法中随顺色等境界相故。若智生起。识亦随顺世间所行。是故应知此彼智者。智中冥会说有所见。且非实有主宰等相。若无二无对碍智生起时如实开晓。乃能于是智中得如实见。非谓一切法于胜义谛中无有自性。而世俗谛决定相应。若异此说。是诸异生狭劣之智

如圣二谛经说。胜义谛中毕竟无性。世俗道中随亦应观。若异此者。彼愚夫异生声闻缘觉菩萨及佛等诸分位。当云何立。谓世俗无因故。世俗无生故。今此不然。世俗道中随应观故。于胜义谛实无所生。胜义谛中若有所得如兔角等。诸世俗法如幻如影及如响等。由如是故。世俗缘生与胜义谛。是中物性非不和合。彼审思察无改转性。此中如是。当知世间一切如幻。诸烦恼业即是幻因。诸众生生即是幻转。所有相应福智诸行亦是幻因。如是相应智即于幻中转

如般若波罗蜜多经说。须菩提所有声闻如化缘觉如化。菩萨如化如来如化。烦恼如化业如化。须菩提以是缘故。一切法如化。此如是等差别诸行及异生等。皆如幻相。于彼幻中如所了知。皆是不实取着。若能如是知。是即相应者。若执实取着即愚夫异生。如是所说实不相违

如圣法集经颂云

  如幻所作事　　从化起解脱
  此如前了知　　非化中有着
  说三有如化　　佛菩萨悉知
  知已被胜铠　　作世间利益

如是等诸所行中。应观实性。如前所说奢摩他中。若沉下高举心等起时。应观一切法皆无自性。尔时应离高下作意智得成就。彼奢摩他毗钵舍那相应行者所行之道。即得具足。乃至能起信解力等。住解行地。观后欲起时还复思惟。胜义谛中无有自性。彼世俗谛亦如是住

如宝云经说。菩萨云何得无我理。善男子。菩萨应以正智观察色受想行识。彼观察时是色生不可得。集不可得。灭不可得。如是受想行识若生若集若灭皆不可得。彼胜义谛中了知无生行已。起慧观察。不复所行而有取着。由是愚无智者。于如是等无自性中。执为有性。颠倒取着。是故生死循环无尽。现受众苦无有休息。菩萨大悲如是常起。无间思念现前为作。悲愍利益发胜愿行。如我所行随得一切智已。于是法性如实觉了。然后于一切佛菩萨等供养称赞。成所作已。从空悲藏。发生一切施等福行

如圣法集经说。若诸菩萨如实显示者。谓于一切众生中以大悲转。我此三摩地乐。一切法中如实显示。一切众生为作所成。由是大悲所开发时。即得增上戒定慧等。诸学圆满。成就阿耨多罗三藐三菩提。此中应知。慧及方便是诸菩萨所行相应胜道。不断世俗谛。显示胜义谛。若不断世俗即能以大悲而为先导。善为众生作利益事。远离颠倒。彼即名为善能建立出世间慧。由此乃为顺行方便。于诸方便所行时中。了如幻相亦不颠倒。以出世智。如如善修最胜方便。能于真实句义之中。发勇悍意出生胜慧。菩萨得是慧方便已。乃住相应所行胜道

如无尽意经说。禅定无尽而能出生慧及方便。其所出生应知即是相应行者。所行胜道

广释菩提心论卷第三

妄分别刺等。何能拔除。复次此中云何能离疑惑种子。谓于相应定中。以慧眼观彼种子空。如先所说。于色等中若以其所得相而为得者。毕竟无得。如人迷绳谓蛇。智了无异。色中离疑其义亦然。以慧眼观诸境不实邪妄计执。如人处于暗室复还掩闭。总一暗冥都无所见。又如瓶等器中盛满诸物。以盖覆故亦无所见。此中意者。是暗室等虽无所见。然色等有性疑惑取着亦不能离。以不离故彼虽无见不断过失。如是等人诸取着心毕竟云何而能除断。是故应以三摩地。手执极微妙快利慧刀。断彼思色等。邪妄分别种子。如是真实断故。譬如拔树连根悉除。地既无根不复生长。邪思种子既得断已。一切过失悉不复生。此中如是。断障等义是奢摩他毗钵舍那相应法门。即修行者所行之道。如世尊言。此相应门是无分别正智因性。故经颂云

  先安住戒次得定　　得彼定已慧当修
  清净圆明智慧成　　智净先由戒具足　广释菩提心论卷第四

        莲华戒菩萨造

        西天译经三藏传法大师赐紫臣施护等奉　诏译

复次此中如宝云经说。菩萨云何得大乘法。谓若菩萨善学一切法。彼虽有学而于学时。及所学法悉不可得。虽于学中决定无所得。亦不于彼因缘法中而起断见

如圣法集经说。云何是诸菩萨所行。谓若菩萨于身语意诸所行中。长时不舍一切众生。内心发起大悲增上。为欲利乐诸众生故。应作是念。若我现行及已行行。悉与一切众生。施作广大利益安乐。菩萨虽观诸蕴如幻。亦不于中而生厌舍。一切所行悉无障碍。处如空聚。亦不于中而生厌舍。一切所行悉无障碍。界如蛇毒。亦不于中而生厌舍。一切所行悉无障碍。又复虽观色如聚沫。亦不舍离如来色身相好。受如浮泡。亦不于诸如来禅定三摩地三摩钵底出生妙乐中不起方便。想如阳焰。亦不于诸如来智中不起胜想。行如芭蕉。亦不于一切佛法行中而无所行。识如幻士。亦不于如来三业智为先导中而无所行。如是一切所行。悉无障碍

复次诸经皆说。应知慧及方便。是诸菩萨正所行行。是故诸菩萨于彼无数一切行中。常所发起慧及方便。观想修作长时无间。如是即得十二分位。是诸地位得安立已。彼彼位中胜上功德皆悉具足。所言十二分位者。谓信解行地乃至佛地。此等地中但除佛地。自余皆是异生及菩萨摄。此中信解行地者。未能证得二无我理。一向发起坚固信解。魔不能动。彼信解力亦未能观唯识实性。但于坚固信解法中。立解行地。又诸地中。随应各具无数三摩地总持解脱神通等诸功德

如宝云经说。安立四种顺决择分。而彼四位。有软中上智光明出。此四皆观诸法无我。是中若有软品智光明生。是为暖位。彼所证定名为明得。若有中品智光明生。是为顶位。彼所证定名为明增。若有最上外无对碍智光明生。于心分位离能取相。是名忍位。彼所证定名一分入。若于能取所取相中悉无所得。以无二智。决定印彼二取相空。是为世第一位。彼所证定名为无间。从此无间入唯识性。此中总略。如是等说。皆是信解行地所摄

复次十地即十分位。彼初地者。从前世第一法无间初心得入见道。既获圣性生大欢喜。是故说此名欢喜地。此能分证二无我理。得法无性真实智生。一切分别戏论悉离。此中能断一百一十二见所断惑。余修所断三界总有一十六惑如应而断。此位菩萨得平等智。自利利他。于施波罗蜜多而得圆满。安住三摩地。乃至未能远离微细毁犯垢染。若能分得进居二地

彼二地者。能离一切犯戒垢染。是故说此名离垢地。此位菩萨能正远离微细犯戒垢染。于戒波罗蜜多而得圆满。乃至未能成就胜三摩地三摩钵底及闻总持。若能分得进居三地。彼三地者。能发无量胜智光明。是故说此名发光地。此位菩萨普尽获得胜三摩地及闻总持。堪忍诸苦。于忍波罗蜜多而得圆满已。于一切三摩钵底爱心中舍。乃至未能广修菩提分法。若能分得进居四地

彼四地者。菩提分法慧焰。能烧诸烦恼薪。是故说此名焰慧地。此位菩萨已离缺减语意分别。善修无缺减菩提分法。于精进波罗蜜多而得圆满。乃至未能作四谛观。若能分得进居五地

彼五地者。于生死涅槃。以善方便观察平等。极难中胜是胜修习。是故说此名难胜地。此位菩萨于四圣谛中。能善观察多所修作。于定波罗蜜多而得圆满。从顺决择分出至此地中。始得无相之行。乃至未能作缘生观。若能分得进居六地

彼六地者胜慧具已。而能随转一切佛法胜现前门。是故说此名现前地。此位菩萨能善观察缘生之法。于慧波罗蜜多而得圆满。获无相行。乃至未能圆满是行。若能分得进居七地。彼七地者。于无功用方便道中。虽未能具。以涉远故。是故说此名远行地。此位菩萨观一切相皆如化事。真实了知相用所行悉无违碍。彼能成就无相之行。于方便波罗蜜多而得圆满。乃至未具无功用行。若能分得进居八地

彼八地者。诸相用等悉不能动。是故说此名不动地。此位菩萨善得无相功用行。于愿波罗蜜多而得圆满。乃至未能分别一切相说法自在。若能分得进居九地

彼九地者。具最胜慧善说诸法。是故说此名善慧地。此位菩萨得彼最胜四无碍解慧力相应。于力波罗蜜多而得圆满。乃至未能于佛刹会中随应化现说法利生自在圆满。若能分得进居十地

彼十地者。能于无边一切世界。布大法云洒甘露雨。是故说此名法云地。此位菩萨胜智相应说法利生。作诸化事悉得自在。乃至未能于一切所知一切相中获无碍智。若能分得进居佛地

如上诸地所有建立行相。如和合解脱经说。又此诸地所有广说。蕴等清净及分位相。余处有文恐繁且止

复次佛地即一分位。此佛地者。一切胜相皆悉具足。一切功德皆悉圆满。已能普尽一切边际。过此无别胜上分位。而佛地中所有功德。正使诸佛以妙言词。而亦不能称扬一分。是故当知。诸佛功德无量无边不可称计。唯佛世尊自然智观自证知故。如华严经中所说功德。亦即一分未能穷尽故。况复我今造此论者。敢以言词具赞说耶。又佛地中所有功德。总摄一切殊胜之义。如楞伽经说

复次颂曰

  应当了知三身者　　普摄诸佛一切身
  最上胜义法所依　　是故开显三身相
  自性身及正报身　　化身等三最胜上
  分别诸佛所有身　　初身与二为依止
  已修难行希有行　　百种炼磨安忍心
  所有一切众善门　　普能积集无遗弃
  无量劫来久修习　　大乘最上妙法门
  一切障碍悉蠲除　　尽灭无余得清净
  因中所有微细障　　果中智力悉拔除
  譬如妙宝始开函　　放净光明照一切
  随顺世间现有生　　历苦勤求菩提果
  说法化利百千门　　遍一切处善施作
  如来高显复不动　　安住世间大圣尊
  如彼须弥众山王　　观仰巍巍最高胜
  大以悲心为根本　　三摩地门善出生
  遍三有中现其身　　一切无不示生处
  如净日轮放一光　　普遍世间悉照耀
  诸佛圣智妙光明　　能知诸法亦如是
  诸声闻人所证果　　出离世间为最胜
  而彼声闻所得中　　又复不如缘觉地
  缘觉若比菩萨地　　于诸分中不及一
  菩萨较计佛如来　　倍多分中不及一
  如来所证菩提果　　无量功德不思议
  如其时处所应行　　随顺方便而善转
  果中所证最胜上　　五根清净妙用成
  十二位中功德门　　彼一切义皆能转
  果中所证最胜上　　一切意道皆清净
  如其所证悉应知　　一切无垢无分别
  果中所证最胜上　　摄诸义利皆清净
  佛刹清净如所应　　一切自在而出现
  果中所证最胜上　　一切分别悉清净
  所作不坏常时中　　善修一切智事业
  果中所证最胜上　　一切清净善安住
  已得无住大涅槃　　圆满诸佛清净句
  果中所证最胜上　　一切染法已清净
  不杂烦恼本无瑕　　常入诸佛妙乐行
  果中所证最胜上　　想如虚空悉清净
  积集广大胜义门　　离诸色相而观察
  如来化相极广大　　此无量行皆清净
  成所作智妙难思　　诸佛无垢胜依止

此中当知。清净法界即一切法真如。为一切法无颠倒自性正因。而能出生诸佛及诸佛智。离诸障染。建立三摩地总持法门。及余无量福智诸行。成就一切众生利乐等事。乃至成熟一切正法闻知种子。如是等相皆得成就。所言诸佛智者。谓即四智。初大圆镜智。是智远离我我所相。及离能取所取分别。不杂一切烦恼垢染。于一切所缘所行所知相中。不忘不愚。智影相生现种依持。彼一切智所依清净。是即真如所缘无分别智。二平等性智。得胜上所缘。是智能观自他平等。已能安处无住涅槃。起大慈悲随往一切现身现上以善方便毕竟相应。三妙观察智。普摄一切三摩地三摩钵底总持法门。于一切所知分位。无碍而转及能发生胜功德宝。方便现身善断众疑。如其所应能善说法。四成所作智。能以种种不思议方便。为他成熟一切所作。如应化度一切众生。如是等相是为四智

复次颂曰

  三身分位二二一　　二法二报一化身
  诸佛清净法界中　　若一若多性不立

此中意者。清净法身犹如虚空而无形相。从是身中流出一切法。此等皆是妙无比喻最胜白法。清净真理大利乐因。出生佛地最上善乐。而能圆满无尽法海。复能具足清净妙慧。即能成就大菩提心。如上所释菩提心义。于诸经中略集要文。唯佛菩萨能尽知见

广释菩提心论卷第四


回诤论

    No. 1631

    序回诤论翻译之记

回诤论者。龙树菩萨之所作也。数舒卢迦三十二字。此论正本凡有六百。大魏都邺兴和三年。岁次大梁。建辰之月。朔次癸酉。辛卯之日。乌苌国人刹利王种。三藏法师毗目智仙。共天竺国婆罗门人瞿昙流支。在邺城内金华寺译。时日所费二十余功。大数凡有一万一千九十八字。对译沙门昙林之笔受。骠骑大将军开府仪同三司御史中尉勃海高仲密启请供养。且记时事。以章以闻。令乐法者。若见若闻。同崇翻译矣

回诤论偈初分第一

        龙树菩萨造

        后魏三藏毗目智仙共瞿昙流支译

问曰偈言

  若一切无体　　言语是一切
  言语自无体　　何能遮彼体
  若语有自体　　前所立宗坏
  如是则有过　　应更说胜因
  汝谓如勿声　　是义则不然
  声有能遮声　　无声何能遮
  汝谓遮所遮　　如是亦不然
  如是汝宗相　　自坏则非我
  若彼现是有　　汝可得有回
  彼现亦是无　　云何得取回
  说现比阿含　　譬喻等四量
  现彼阿含成　　譬喻亦能成
  智人知法说　　善法有自体
  世人知有体　　余法亦如是
  出法出法体　　是圣人所说
  如是不出法　　不出法自体
  诸法若无体　　无体不得名
  有自体有名　　唯名云何名
  若离法有名　　于彼法中无
  说离法有名　　彼人则可难
  法若有自体　　可得遮诸法
  诸法若无体　　竟为何所遮
  如有瓶有埿　　可得遮瓶埿
  见有物则遮　　见无物不遮
  若法无自体　　言语何所遮
  若无法得遮　　无语亦成遮
  如愚痴之人　　妄取炎为水
  若汝遮妄取　　其事亦如是
  取所取能取　　遮所遮能遮
  如是六种义　　皆悉是有法
  若无取所取　　亦无有能取
  则无遮所遮　　亦无有能遮
  若无遮所遮　　亦无有能遮
  则一切法成　　彼自体亦成
  汝因则不成　　无体云何因
  若法无因者　　云何得言成
  汝若无因成　　诸法自体回
  我亦无因成　　诸法有自体
  若有因无体　　是义不相应
  世间无体法　　则不得言有
  前遮后所遮　　如是不相应
  若后遮及并　　如是知有体

    回诤论偈上分第二

  我语言若离　　因缘和合法
  是则空义成　　诸法无自体
  若因缘法空　　我今说此义
  何人有因缘　　彼因缘无体
  化人于化人　　幻人于幻人
  如是遮所遮　　其义亦如是
  言语无自体　　所说亦无体
  我如是无过　　不须说胜因
  汝言勿声者　　此非我譬喻
  我非以此声　　能遮彼声故
  如或有丈夫　　妄取化女身
  而生于欲心　　此义亦如是
  同所成不然　　响中无因故
  我依于世谛　　故作如是说
  若不依世谛　　不得证真谛
  若不证真谛　　不得涅槃证
  若我宗有者　　我则是有过
  我宗无物故　　如是不得过
  若我取转回　　则须用现等
  取转回有过　　不尔云何过
  若量能成法　　彼复有量成
  汝说何处量　　而能成此量
  若量离量成　　汝诤义则失
  如是则有过　　应更说胜因
  犹如火明故　　能自照照他
  彼量亦如是　　自他二俱成
  汝语言有过　　非是火自照
  以彼不相应　　如见闇中瓶
  又若汝说言　　火能自他照
  如火能烧他　　何故不自烧
  又若汝说言　　火能自他照
  闇亦应如是　　自他二俱覆
  于火中无闇　　何处自他住
  彼闇能杀明　　火云何有明
  如是火生时　　即生时能照
  火生即到闇　　义则不相应
  若火不到闇　　而能破闇者
  火在此处住　　应破一切闇
  若量能自成　　不待所量成
  是则量自成　　非待他能成
  若不待所量　　而汝量得成
  如是则无人　　用量量诸法
  若所量之物　　待量而得成
  是则所量成　　待量然后成
  若物无量成　　是则不待量
  汝何用量成　　彼量何所成
  若汝彼量成　　待所量成者
  是则量所量　　如是不相离
  若量成所量　　若所量成量
  汝若如是者　　二种俱不成
  量能成所量　　所量能成量
  若义如是者　　云何能相成
  所量能成量　　量能成所量
  若义如是者　　云何能相成
  为是父生子　　为是子生父
  何者是能生　　何者是所生
  为何者是父　　为何者是子
  汝说此二种　　父子相可疑
  量非自能成　　非是自他成
  非是异量成　　非无因缘成
  若法师所说　　善法有自体
  此善法自体　　法应分分说
  若善法自体　　从于因缘生
  善法是他体　　云何是自体
  若少有善法　　不从因缘生
  善法若如是　　无住梵行处
  非法非非法　　世间法亦无
  有自体则常　　常则无因缘
  善不善无记　　一切有为法
  如汝说则常　　汝有如是过
  若人说有名　　语言有自体
  彼人汝可难　　语名我不实
  若此名无者　　则有亦是无
  若言有言无　　汝宗有二失
  若此名有者　　则无亦是有
  若言无言有　　汝诤有二失
  如是我前说　　一切法皆空
  我义宗如是　　则不得有过
  若别有自体　　不在于法中
  汝虑我故说　　此则不须虑
  若有体得遮　　若空得言成
  若无体无空　　云何得遮成
  汝为何所遮　　汝所遮则空
  法空而有遮　　如是汝诤失
  我无有少物　　是故我不遮
  如是汝无理　　枉横而难我
  汝言语法别　　此义我今说
  无法得说语　　而我则无过
  汝说鹿爱喻　　以明于大义
  汝听我能说　　如譬喻相应
  若彼有自体　　不须因缘生
  若须因缘者　　如是得言空
  若取自体实　　何人能遮回
  余者亦如是　　是故我无过
  此无因说者　　义前已说竟
  三时中说因　　彼平等而说
  若说三时因　　前如是平等
  如是三时因　　与说空相应
  若人信于空　　彼人信一切
  若人不信空　　彼不信一切
  空自体因缘　　三一中道说
  我归命礼彼　　无上大智慧

    回诤论释初分第三

释曰论初偈言

  若一切无体　　言语是一切
  言语自无体　　何能遮彼体

此偈明何义。若一切法皆是因缘。则是因缘因缘和合离诸因缘。是则更无一切自体。如是一切诸法皆空。如芽非是种子中有。非地非水非火非风非虚空等因缘中有。非是一一因缘中有。非诸因缘和合中有。非离因缘因缘和合余处别有。若此等中一切皆无。如是得言芽无自体。若如是无一切自体。彼得言空。若一切法皆悉空者则无言语。若无言语则不能遮一切诸法。若汝意谓言语不空言语所说一切法空。是义不然。何以故。汝言一切诸法皆空则语亦空。何以故。以因中无。四大中无。一一中无。和合中无。因缘和合不和合中一切皆无。如是言语咽喉中无。唇舌齿根龂鼻顶等一一皆无。和合中无。二处俱无。唯有因缘因缘和合。若离如是因缘和合。更无别法。若如是者。一切言语皆无自体。若如是无言语自体。则一切法皆无自体。若此言语无自体者。唯有遮名不能遮法。譬如无火则不能烧。亦如无刀则不能割。又如无水则不能澜。如是无语。云何能遮诸法自体。既不能遮诸法自体。而心忆念遮一切法自体。回者义不相应。又复有义。偈言

  若语有自体　　前所立宗坏
  如是则有过　　应更说胜因

此偈明何义。若此言语有自体者。汝前所立义宗自坏。是则有过。若尔便应更说胜因。若汝意谓语有自体余法空者。如是则违诸法空语。汝宗亦坏。又复有义。言语不离一切法数。若一切法皆悉空者。言语亦空。若言语空则不能遮一切诸法。若如是者。于六种中诤论相应。彼复云何汝不相应。汝说一切诸法皆空。则语亦空。何以故。言语亦是一切法故。言语若空则不能遮。彼若遮言一切法空则不相应。又若相应言语能遮一切法体。一切法空语则不空语。若不空遮一切法则不相应。若诸法空言语不空语何所遮。又若此语入一切中喻不相当。若彼言语是一切者。一切既空言语亦空。若语言空则不能遮。若语言空诸法亦空。以空能遮诸法令空。如是则空亦是因缘。是则不可。又若汝畏喻不相当。一切法空能作因缘。如是空语则不能遮一切自体。又复有义。一边有过。以法有空亦有不空。彼若有过更说胜因。若一边空一边不空。如是若说一切法空无自体者。义不相应。又复有义。偈言

  汝谓如勿声　　是义则不然
  声有能遮声　　无声何能遮

此偈明何义。若汝意谓声能遮声。如有人言汝莫作声。彼自作声而能遮声。如是如是一切法空空语能遮。此我今说此不相应。何以故。以此声有能遮彼声。汝语非有则不能遮诸法自体。汝所立义。语亦是无诸法亦无。如是若谓如勿声者。此则有过。偈言

  汝谓遮所遮　　如是亦不然
  如是汝宗相　　自坏则非我

此偈明何义。若汝意谓。遮与所遮亦如是者。彼不相应。若汝说言。我语能遮一切诸法有自体者。彼不相应。此我今说。是义不然。何以故。知如是宗相汝过非我。汝说一切诸法皆空。如是汝义前宗有过咎不在我。若汝说言。汝遮所遮不相应者。是义不然。又复有义。偈言

  若彼现是有　　汝何得有回
  彼现亦是无　　云何得取回

此偈明何义。若一切法有现可取。汝得回我诸法令空。而实不尔。何以知之。现量入在一切法数则亦是空。若汝分别依现有比。现比皆空。如是无现比。何可得现之与比。是二皆无云何得遮。汝言一切诸法空者。是义不然。若汝复谓。或比或喻。或以阿含得一切法。如是一切诸法自体。我能回者。此义今说。偈言

  说现比阿含　　譬喻等四量
  现比阿含成　　譬喻亦能成

此偈明何义。比喻阿含现等四量。若现能成。比阿含等皆亦能成。如一切法皆悉是空。现量亦空。如是比喻亦空。彼量所成一切诸法皆悉是空。以四种量在一切故。随何等法。若为比成亦譬喻成亦阿含成。彼所成法一切皆空。汝以比喻阿含等三量一切法所量亦空。若如是者法不可得量所量无。是故无遮。如是若说一切法空无自体者。义不相应。又复有义。偈言

  智人知法说　　善法有自体
  世人知有体　　余法亦如是

此偈明何义。法师说善法。善法一百一十有九。谓心一相。一者受。二者想。三者觉。四者触。五者观察。六者欲。七者信解脱。八者精进。九者忆念。十者三摩提。十一者慧。十二者舍。十三者修。十四者合修。十五者习。十六者得。十七者成。十八者辩才。十九者适。二十者勤。二十一者思。二十二者求。二十三者势力。二十四者不嫉。二十五者自在。二十六者善辩才。二十七者不悔。二十八者悔。二十九者少欲。三十者不少欲。三十一者舍。三十二者不思。三十三者不求。三十四者不愿。三十五者乐说。三十六者不着境界。三十七者不行。三十八者生。三十九者住。四十者灭。四十一者集。四十二者老。四十三者热恼。四十四者闷。四十五者疑。四十六者思量。四十七者爱。四十八者信。四十九者乐。五十者不顺。五十一者顺取。五十二者不畏大众。五十三者恭敬。五十四者作胜法。五十五者敬。五十六者不敬。五十七者供给。五十八者不供给。五十九者定顺。六十者宿。六十一者发动。六十二者不乐。六十三者覆。六十四者不定。六十五者愁恼。六十六者求不得。六十七者荒乱。六十八者懈怠。六十九者忧愦。七十者希净。七十一者内信。七十二者畏。七十三者信。七十四者惭。七十五者质直。七十六者不诳。七十七者寂静。七十八者不惊。七十九者不错。八十者柔软。八十一者开解。八十二者嫌。八十三者烧。八十四者惺。八十五者不贪。八十六者不嗔。八十七者不痴。八十八者不一切知。八十九者放舍。九十者不有。九十一者愧。九十二者不自隐恶。九十三者悲。九十四者喜。九十五者舍。九十六者神通。九十七者不执。九十八者不妒。九十九者心净。一百者忍辱。一百一者利益。一百二者能用。一百三者福德。一百四者无想定。一百五者不一切智。一百六者无常三昧(少十三法无处访本)。如是如是。善法一百一十有九。如彼善法善法自体。彼不善法不善法自体。如是无记无记。本性无记本性无记。欲界欲界。色界色界。无色界无色界。无漏无漏。苦集灭道苦集灭道。修定修定。如是如是见有无量种种诸法皆有自体。如是若说一切诸法皆无自体。如是无体得言空者。义不相应。此复有义。偈言

  出法出法体　　是圣人所说
  如是不出法　　不出法自体

此偈明何义。如说出法出法自体。如是不出法不出法自体。觉分觉分自体。菩提分菩提分自体。非菩提分非菩提分自体。如是余法皆亦如是。若如是见彼无量种诸法自体。而如是说一切诸法皆无自体。以无自体名为空者。义不相应。又复有义。偈言

  诸法若无体　　无体不得名
  有自体有名　　唯名云何名

此偈明何义。若一切法皆无自体说无自体。言语亦无。何以故。有物有名。无物无名。以一切法皆有名故。当知诸法皆有自体。法有自体故不得言一切法空。如是若说一切法空无自体者。义不相应。偈言

  若离法有名　　于彼法中无
  说离法有名　　彼人则可难

此偈明何义。若汝意谓。有法有名离法有名。如是一切诸法皆空无自体成。非物无名有物有名。此我今说。若如是者。有何等人。说离法体别有名字。若别有名。别有法者。则不得示彼不可示。如是汝心分别别有诸法别有名者。是义不然。又复有义。偈言

  法若有自体　　可得遮诸法
  诸法若无体　　竟为何所遮
  如有瓶有埿　　可得遮瓶埿
  见有物则遮　　见无物不遮

此偈明何义。有物得遮无物不遮。如无瓶埿则不须遮。有瓶得遮无瓶不遮。如是如是法无自体则不须遮。法有自体可得有遮。无云何遮。若一切法皆无自体而便遮言。一切诸法无自体者。义不相应。汝何所遮。若有遮体。能遮一切诸法自体。偈言

  若法无自体　　言语何所遮
  若无法得遮　　无语亦成遮

此偈明何义。若法无体语亦无体。云何遮言。一切诸法皆无自体。若如是遮。不说言语亦得成遮。若如是者火冷水坚如是等过。又复有义。偈言

  如愚痴之人　　妄取炎为水
  若汝遮妄取　　其事亦如是

此偈明何义。若汝意谓。如愚痴人取炎为水。于无水中虚妄取水。有黠慧人为回彼心而语之言。汝妄取水。如是如是于无自体一切法中取法自体。为彼众生妄心回故。说一切法皆无自体。此我今说。偈言

  取所取能取　　遮所遮能遮
  如是六种义　　皆悉是有法

此偈明何义。若当如是有众生者。有取所取有能取者。得言虚妄遮所遮等。如是六种义成。若六义成而说诸法一切空者。是义不然。偈言

  若无取所取　　亦无有能取
  则无遮所遮　　亦无有能遮

此偈明何义。若汝意谓无如是过。非取所取。非能取者。彼若如是虚妄取遮。一切诸法无自体者。彼遮亦无所遮亦无能遮亦无。偈言

  若无遮所遮　　亦无有能遮
  则一切法成　　彼自体亦成

此偈明何义。若非有遮非有所遮非有能遮。是则不遮一切诸法。则一切法皆有自体。偈言

  汝因则不成　　无体云何因
  若法无因者　　云何得言成

此偈明何义。若一切法空无自体。如是义中说因不成。何以故。一切诸法空无自体。何处有因。若法无因一切法空以何因成。是故汝说一切法空无自体者。是义不然。偈言

  汝若无因成　　诸法自体回
  我亦无因成　　诸法有自体

此偈明何义。若汝意谓。我无因成法无自体。如汝无因自体回成。我自体法亦无因成。偈言

  若有因无体　　是义不相应
  世间无体法　　则不得言有

此偈明何义。若汝意谓。我有因成因无自体。若如是者无自体义则不相应。何以故。一切世间无自体者。不得言有。偈言

  前遮后所遮　　如是不相应
  若后遮及并　　如是知有体

此偈明何义。若遮在前所遮在后。义不相应。未有所遮遮何所遮。若遮在后所遮在前。亦不相应。所遮已成遮何能遮。若遮所遮二法同时不相因缘。遮不因所遮。所遮不因遮。皆有自体故。则不得言遮。如角并生各不相因。左不因右右不因左。如是若说一切诸法无自体者。是义不然。释初分竟

    回诤论释上分第四

释曰。如汝所说我今答汝。汝说偈言

  若一切无体　　言语是一切
  言语自无体　　何能遮彼体

此偈。我今答。偈言

  我语言若离　　因缘和合法
  是则空义成　　诸法无自体

此偈明何义。若彼言语。因中大中和合中无。离散中无。咽喉唇舌齿根龂鼻顶等诸处皆各有力。如是二处和合中无。若离如是因缘和合。更无别法。以如是故无有自体。无自体故我言一切皆无自体。空义则成。如此言语无自体空。诸法如是无自体空。是故汝言。汝语空故不能说空。是义不然。又复有义。偈言

  若因缘法空　　我今说此义
  何人有因缘　　彼因缘无体

此偈明何义。汝不能解一切法空。不知空义何能咎我。如汝所言。汝语言空语无自体。无自体故不能遮法。此法若是因缘生者。生故得言一切法空。得言一切皆无自体。以何义故。知因缘生法无自体。若法一切皆因缘生。则一切法。皆无自体。法无自体则须因缘。若有自体何用因缘。若离因缘则无诸法。若因缘生则无自体。以无自体故得言空。如是我语亦因缘生。若因缘生则无自体。以无自体故得言空。以一切法因缘生者自体皆空。如舆瓶衣蕃等诸物。彼法各各自有因缘。世间薪草土所作器水蜜乳等。将来将去及举掌等。又复寒热风等障中诸受用法。因缘生故皆无自体。如是如是我语因缘和合而生。如是得言无有自体。若无自体如是得言无自体成。如是空语世间受用。是故汝言无自体故汝语亦空。则不能遮诸法自体。是义不然。又复有义。偈言

  化人于化人　　幻人于幻人
  如是遮所遮　　其义亦如是

此偈明何义。如化丈夫于异化人。见有去来种种所作而便遮之。如幻丈夫于异幻人。见有去来种种所作而便遮之。能遮化人彼则是空。若彼能遮化人是空。所遮化人则亦是空。若所遮空遮人亦空。能遮幻人彼则是空。若彼能遮幻人是空。所遮幻人则亦是空。若所遮空遮人亦空。如是如是我语言空。如幻化空。如是空语。能遮一切诸法自体。是故汝言。汝语空故。则不能遮一切诸法有自体者。汝彼语言则不相应。若汝说言彼六种诤彼如是遮。如是我语非一切法。我语亦空诸法亦空。非一切法皆悉不空。又复汝说偈言

  若语有自体　　前所立宗坏
  如是则有过　　应更说胜因

此偈。我今答。偈言

  言语无自体　　所说亦无体
  我如是无过　　不须说胜因

此偈明何义。我此语言。以因缘生非有自体。如前所说。自体不生故得言空。如是得言此语言空余一切法悉皆是空。如是空故我则无过。若我说言此语不空余一切法悉皆空者。我则有过。我不如是是故无过。理实不得语言不空余一切法皆悉是空。我以是故不说胜因。若语不空余一切法皆悉空者。可说胜因。是故汝言。汝诤论坏语则有过。应说胜因。是义不然。又复汝说。偈言

  若谓如勿声　　是义则不然
  声有能遮声　　无声何能遮

此偈。我今答。偈言

  汝言勿声者　　此非我譬喻
  我非以此声　　能遮彼声故

此偈明何义。此非我喻。如何人言莫作声者。彼自作声以声遮声。声非不空我则不尔。语言亦空遮法亦空。何以故。譬如彼声能回此声。我不如是。我如是说。一切诸法皆无自体。以无自体故得言空。何以故。若无体语回无自体。则一切法皆成自体。如言勿声声能遮声。如是如是无自体语遮无体法。若如是遮无自体者。则一切法皆成自体。若有自体则一切法皆悉不空。我说法空不说不空。譬喻如是。偈言

  如或有丈夫　　妄取化女身
  而生于欲心　　此义亦如是

此偈明何义。如化妇女实自体空。如或丈夫于化女身。生实有想起于欲心。彼虚妄取诸法亦尔。彼或如来如来弟子声闻之人。为回彼人虚妄取心。或是如来威神之力。如来弟子声闻威力。化作化人。如是如是语空如化。如化妇女无自体空。法如是空。取法自体能遮令回。如是如是以此空喻能成空义。我则相应非汝相应。偈言

  同所成不然　　响中无因故
  我依于世谛　　故作如是说

此偈明何义。若汝或谓如勿声者因同所成。何以故。以因不离一切诸法无自体故。非彼声响而有自体。以因缘生故无自体。若无自体汝说声有能遮声者。彼义则坏。又我所说不违世谛不舍世谛。依世谛故能说一切诸法体空。若离世谛法不可说。佛说偈言

  若不依世谛　　不得证真谛
  若不证真谛　　不得涅槃证

此偈明何义。如是诸法非是不空。一切诸法皆无自体。此二无异。又复汝说偈言

  汝谓遮所遮　　如是亦不然
  如是汝宗相　　自坏则非我

此偈。我今答。偈言

  若我宗有者　　我则是有过
  我宗无物故　　如是不得过

此偈明何义。若我宗有则有宗相。若我有宗有宗相者。我则得汝向所说过。如是非我有宗。如是诸法实寂静故。本性空故。何处有宗。如是宗相为于何处宗相可得。我无宗相何得咎我。是故汝言。汝有宗相得过咎者。是义不然。又复汝说偈言

  若彼现是有　　汝可得有回
  彼现亦是无　　云何得取回
  说现比阿含　　譬喻等四量
  现比阿含成　　譬喻亦能成

此偈。我今答。偈言

  若我取转回　　则须用现等
  取转回有过　　不尔云何过

此偈明何义。我若如是少有法物。则须现比阿含譬喻如是四量。复有四量。我若如是取转回者。我则有过。我既不取少法转回。若我如是不转不回。汝若如是与我过者。是义不然。若现等量复有量成量则无穷。汝如是义不能咎我。又复有义。偈言

  若量能成法　　彼复有量成
  汝说何处量　　而能成此量

此偈明何义。若汝意谓量能成物。如量所量。现比阿含喻等四量。复以何量成此四量。若此四量更无量成。量自不成。若自不成能成物者。汝宗则坏。若量复有异量成者。量则无穷。若无穷者则非初成非中后成。何以故。若量能成所量物者。彼量复有异量来成彼量。复有异量成故。如是。无初。若无初者如是无中。若无中者何处有后。如是若说彼量复有异量成者。是义不然。偈言

  若量离量成　　汝诤义则失
  如是则有过　　应更说胜因

此偈明何义。若汝意谓。量离量成。所量之物为量成者。若如是诤量成所量。汝则有过。有物量成有不量成。若如是者应说胜因。若说胜因则可得知。何者量成何者不成。汝不能示如是分别。义不相应。此我今说。如有人言。我所说量自他能成。而说偈言

  犹如火明故　　能自照照他
  彼量亦如是　　自他二俱成

此偈明何义。如火自照亦能照他。量亦如是。自成成他。我今答彼偈言

  汝语言有过　　非是火自照
  以彼不相应　　如见闇中瓶

此偈明何义。彼量如火自他能成难不相应。何以故。非火自照。如初未照闇中瓶等不可得见。以火照已然后得见。如是如是。若火自照。初火应闇后时乃明。如是得言火能自照。若初火明则不得言火能自照。如是分别火自他照义不相应。又复有义。偈言

  又若汝说言　　火自他能照
  如火能烧他　　何故不自烧

此偈明何义。若汝说言。如火自照亦能照他。如是如是自照照他。如是如是既能烧他亦应自烧。而实不见有如是事。若说彼火自他能照义不相应。又复有义。偈言

  又若汝说言　　火能自他照
  闇亦应如是　　自他二俱覆

此偈明何义。若汝说言。火自他照能却闇者。闇何以不自他皆覆。而实不见有如是事。若说彼火自他照者义不相应。又复有义。偈言

  于火中无闇　　何处自他住
  彼闇能杀明　　火云何有明

此偈明何义。火中无闇火处无闇。云何名为明能破闇。若彼火中如是无闇。何处有闇火能破闇。若当无闇可破灭者。云何而得自他俱照。此我今说。若如是者非火中闇非火处闇。如是如是火自他照。彼火生时即能破闇。如是火中无闇火处无闇。如是火生能照自他。此我今说。偈言

  如是火生时　　即生时能照
  火生即到闇　　义则不相应

此偈明何义。若火生时能自他照义不相应。何以知之。如是初火不能到闇。何以知之。若未到闇不能破闇。若不破闇不得有明。偈言

  若火不到闇　　而能破闇者
  火在此处住　　应破一切闇

此偈明何义。若汝意谓。火不到闇能破闇者。火此处住则应能破一切世间所有处闇。何以故。俱不到故。而实不见有如是事。若俱不到。云何唯能破此处闇。不破世间一切处闇。若汝意谓。火不到闇而能破闇义不相应。又复有义。偈言

  若量能自成　　不待所量成
  是则量自成　　非待他能成

此偈明何义。若汝意谓。量与所量如火成者。量则自成不待所量。何以故。若自成者则不待他。若待他者非自成故。此我今说。若不相待何不自成。若待于他则非自成。此我今说。若量不待所量之物为有何过。此我今说。偈言

  不待所量物　　若汝量得成
  如是则无人　　用量量诸法

此偈明何义。若汝意谓。不待所量而量得成。则无有人用量量法。有如是过。若何等人须用量者。不待所量而得有量。若不待成彼得何过。则一切法皆不待量。若一切法不待量成。彼得何过。成得言成未成叵成。以无待故。若汝复谓。待所量物量得成者。如是四量皆有待成。何以故。若物未成云何相待。物若已成不须相待。天得未成则不待物。若已成者更不待成。如物已作无作因缘。又复有义。偈言

  若所量之物　　待量而得成
  是则所量成　　待量然后成

此偈明何义。若所量物待量而成。是则以量成彼所量。何以故。所成非成量成所量。又复有义。偈言

  若物无量成　　是则不待量
  汝何用量成　　彼量何所成

此偈明何义。若汝意谓。不待彼量所量成者。汝今何用求量而成。何以故。彼量义者为何所求。彼所量物离量成者。彼量何用。又复有义。偈言

  若汝彼量成　　待所量成者
  是则量所量　　如是不相离

此偈明何义。若汝意谓。待所量物是故有量。畏有前过。汝若如是量所量一不得相离。汝若如是量即所量。何以知之。所量成量所量即量。量成所量量所量一。偈言

  若量成所量　　若所量成量
  汝若如是者　　二种俱不成

此偈明何义。若汝意谓。量成所量见待量故。所量成量见待所量。汝若如是二俱不成。何以故。偈言

  量能成所量　　所量能成量
  若义如是者　　云何能相成

此偈明何义。若量能成所量之物。彼所量物能成量者。量自未成因缘不成。云何能成所量之物。又复有义。偈言

  所量能成量　　量能成所量
  若义如是者　　云何能相成

此偈明何义。若所量物能成彼量。彼量能成所量之物。所量未成因缘不成。云何成量。偈言

  为是父生子　　为是子生父
  何者是能生　　何者是所生

此偈明何义。如有人言父能生子。彼若如是子亦生父。汝今为说。何者能生何者所生。汝如是说。量成所量所量成量。汝今为说。何者能成何者所成。又复有义。偈言

  为何者是父　　为何者是子
  汝说此二种　　父子相可疑

此偈明何义。前说二种所谓父子。何者为父何者为子。父子二相若相待生彼则可疑。何者为父何者为子。如是如是。若汝说此量与所量。彼何者量何者所量。此之二种若能成物可得言量。若物可成得言所量则不疑云何者是量何者所量。如是能成可得言量。如是可成得言所量。此则不疑。何者是量何者所量。偈言

  量非能自成　　非是自他成
  非是异量成　　非无因缘成

此偈明何义。如是量非自成。现非现成。比非比成。喻非喻成。阿含亦尔非阿含成。非是自他迭互相成。现非比喻阿含等成。比非现喻阿含等成。喻非现比阿含等成。阿含非现比喻等成。非异现比譬喻阿含别有现比譬喻阿含异量来成。如量自分和合不成。自他境界和合不成。非无因成非聚集成。此之因缘如先所说。二十三十或四五六。二十三十四十五十或有六十。若汝所说以有量故得言所量。有量所量证一切法皆有自体义不相应。又复汝说偈言

  智人知法说　　善法有自体
  世人知有体　　余法亦如是
  出法出自体　　是圣人所说
  如是不出法　　不出法自体

此偈。我今答。偈言

  若法师所说　　善法有自体
  此善法自体　　法应分分说

此偈明何义。若彼法师。谓彼善法有自体者。应分分说此善自体。此之善法如彼善心。善心自体如是如是。一切诸法不如是见。若如是说亦法自体义不相应。又复有义。偈言

  若善法自体　　从于因缘生
  善法是他体　　云何是自体

此偈明何义。若善法体从于因缘和合而生。彼是他体。善法云何得有自体。如善法体余亦如是。若汝说言如彼善法善法自体。如是不善不善体等义不相应。又复有义。偈言

  若少有善法　　不从因缘生
  善法若如是　　无住梵行处

此偈明何义。若汝意谓。少有善法不因缘生。如是不善不善自体。无记无记自体。若当如是无住梵行。何以故。汝若如是。是则舍离十二因缘。若当舍离十二因缘。是则舍见十二因缘。若如是无十二因缘。则不得见十二因缘。如其不见十二因缘。不得见法。世尊说言。若比丘见十二因缘。彼则见法。若不见法不住梵行。若离如是十二因缘。则离苦集。十二因缘是苦集故。若离苦集是则离苦。若无集者何处有苦。若无苦者云何有灭。若无苦灭当于何处修苦灭道。若如是者无四圣谛。无四圣谛则亦无有声闻道果。见四圣谛如是则证声闻道果。无声闻果无住梵行。又复有义。偈言

  非法非非法　　世间法亦无
  有自体则当　　常则无因缘

此偈明何义。若当如是离于因缘和合生者。汝得多过。以不得法及非法故。一切世间法皆不可得。何以故。因缘和合生一切法。以一切法皆从因缘和合而生。若无因缘和合生者。则一切法皆不可得。又复自体不从因缘和合而生。无因缘有则是常法。何以故。无因缘法则是常故。彼若如是无住梵行。又复汝法自有过失。何以故。世尊所说。一切有为皆悉无常。彼何自体皆悉无常。偈言

  善不善无记　　一切有为法
  如汝说则常　　汝有如是过

此偈明何义。若说善法有法自体。不善无记亦如是说。若如是者。汝说一切有为法常。何以故。法若无因无生住灭。无生住灭非有为法。则一切法皆是无为。若说善等一切诸法皆有自体。则一切法皆悉不空。义不相应。又复汝说偈言

  诸法若无体　　无体不得名
  有自体有名　　唯名云何名

此偈。我今答。偈言

  若人说有名　　语言有自体
  彼人汝可难　　语名我不实

此偈明何义。若何人说名有自体。彼人如是汝则得难。彼人说言。有体有名无体无名。我不如是说有名体。何以知之。一切诸法皆无自体。若无自体彼得言空。彼若空者得言不实。若汝有名有自体者。义不相应。又复有义。偈言

  若此名无者　　则有亦是无
  若言有言无　　汝宗有二失
  若此名有者　　则无亦是有
  若言无言有　　汝诤有二失

此偈明何义。若此名无如是宗失。如其是有如是诤失。我宗不尔。有物有名无物无名。如是诸法有自体者。义不相应。又复有义。偈言

  如是我前说　　一切法皆空
  我义宗如是　　则不得有过

此偈明何义。我前已说。一切法空亦说名空。汝取空名而有所说。若一切法皆无自体名亦无体。我如是说义宗无过。我不说名有自体故。又复汝说偈言

  若离法有名　　不在于法中
  说离法有名　　彼人则可难

此偈。我今答。偈言

  若别有自体　　不在于法中
  汝虑我故说　　此则不须虑

此偈明何义。彼不须虑汝妄难我。我则不遮诸法自体。我不离法别有物取何人取法。彼人须虑我不取法故不遮法云何有过。若我取法有自体者。则可难言汝不相应。我不如是。汝难大赊全不相当。又复汝说偈言

  法若有自体　　可得遮诸法
  诸法无自体　　竟为何所遮
  如有瓶有泥　　可得遮瓶泥
  见有物则遮　　见无物不遮

此偈。我今答。偈言

  若有体得遮　　若空得言成
  若无体无空　　云何得遮成

此偈明何义。法若有者则可得遮法。若无者则不得遮。汝难我言。一切诸法皆无自体。实如汝言一切诸法皆无自体。何以知之。以汝遮法无自体成。若遮诸法无自体成。得言一切诸法皆空。偈言

  汝为何所遮　　汝所遮则空
  法空而有遮　　如是汝诤失

此偈明何义。若一切法遮有自体。若无自体彼得言空彼空亦空。是故汝言有物得遮无物不遮。义不相应。又复有义。偈言

  我无有少物　　是故我不遮
  如是汝无理　　抂横而难成

此偈明何义。若我如是少有物遮汝得难我。我无物遮。如是无物我无所遮。如是无遮一切法空。如是无物遮与所遮。是故汝向如是难言何所遮者。此汝无理抂横难我。又复汝说偈言

  若法无自体　　言语何所遮
  若无法得遮　　无语亦成遮

此偈。我今答。偈言

  汝言语法别　　此义我今说
  无法得说语　　而我则无过

此偈明何义。若汝说言无有言语亦成遮者。随何等法。彼一切法皆无自体。说彼诸法无自体语。非此言语作无自体。此我今答。若说诸法无自体语。此语非作无自体法。又复有义。以无法体知无法体。以有法体知有法体。譬如屋中实无天得。有人问言。有天得不。答者言有。复有言无。答言无者语言。不能于彼屋中作天得。无但知屋中空无天得。如是若说一切诸法无自体者。此语不能作一切法无自体。无但知诸法自体无体。若汝说言。若无物者则不得言法无自体。以无语故。不得成法无自体者。义不相应。又复汝说偈言

  如愚痴之人　　妄取炎为水
  若汝遮妄取　　其事亦如是
  取所取能取　　遮所遮能遮
  如是六种义　　皆悉是有法
  若无取所取　　亦无有能取
  则无遮所遮　　亦无有能遮
  若无遮所遮　　亦无有能遮
  则一切法成　　彼自体亦成

此四行偈。我今答汝偈言

  汝说鹿爱喻　　以明于大义
  汝听我能答　　如譬喻相应

此偈明何义。汝若说此鹿爱譬喻。以明大义。汝听我答。如喻相应。偈言

  若彼有自体　　不须因缘生
  若须因缘者　　如是得言空

此偈明何义。若鹿爱中妄取水体。非因缘生。汝喻相当。鹿爱因缘彼颠倒见。颠倒见者以不观察因缘而生。如是得言因缘而生。若因缘生彼自体空。如是之义如前所说。又复有义。偈言

  若取自体实　　何人能遮回
  余者亦如是　　是故我无过

此偈明何义。若鹿爱中取水体实。何人能回。若有自体则不可回。如火热水湿空无障碍。见此得回。如是取自体空。如是如是。余法中义应如是知。如是等如取无实。余五亦尔。若汝说彼六法是有。如是得言一切诸法皆不空者。义不相应。又复汝说偈言

  汝因则不成　　无体云何因
  若法无因者　　云何得言成
  汝若无因成　　诸法自体回
  我亦无因成　　诸法有自体
  若有因无体　　是义不相应
  世间无体法　　则不得言有

此偈。我今答。偈言

  此无因说者　　义前已说竟
  三时中说因　　彼平等而说

此偈明何义。如是大义于前已说。此则无因应如是知。如是论义前因已说遮六种回。彼前论义今于此说。又复汝说偈言

  前遮后所遮　　如是不相应
  后遮若俱并　　如是知有体

此偈我今答。偈言

  若说三时因　　前如是平等
  如是三时因　　与说空相应

此偈明何义。若遮此因三时言语。此先已答。应如是知。何以故。因平等故。如遮三时彼不相应。彼语亦在遮所遮中。若汝意谓。无遮所遮犹故得遮。我已遮竟。此三时因与说空人言语相应。又复云何。先已说竟。如向偈言

  我无有少物　　是故我不遮
  如是汝无理　　抂横而难我

若汝复谓。三时遮成。见前时因。见后时因。见俱时因。彼前时因如父以子。后时因者如师弟子。俱时因者如灯以明。此我今说。此不如是前说三种。彼三种中一一复有三种过失。此前已说。复次第遮。汝立宗失如是等自体遮成。偈言

  若人信于空　　彼人信一切
  若人不信空　　彼不信一切

此偈明何义。若人信空。彼人则信一切世间出世间法。何以故。若人信空。则信因缘和合而生。若信因缘和合而生。则信四谛。若信四谛。彼人则信。一切胜证。若人能信一切胜证。则信三宝谓佛法僧。若信因缘和合而生。彼人则信法因法果。若人能信法因法果。彼人则信非法因果。若人能信法因法果信非法因信非法果。则信烦恼烦恼和合烦恼法物。彼人如是一切皆信。如是前说彼人则信善行恶行。若人能信善行恶行。彼人则信善恶行法。若人能信善恶行法。则知方便过三恶道。彼人如是能信一切世间诸法。如是无量不可说尽

  空自体因缘　　三一中道说
  我归命礼彼　　无上大智慧

释回诤论偈义已竟

作此论者。阿阇梨龙树菩萨摩诃萨。一切论义皆能解释

回诤论一卷


集大乘相论

    No. 1637

集大乘相论卷上

        觉吉祥智菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

归命妙吉祥菩萨摩诃萨。我今略释诸大乘相。从菩提心出生大悲相应。所谓一切法。即当了知一切法无我。此所知相。是故今说

此中何名一切法。所谓蕴处界缘生波罗蜜多地空菩提分圣谛静虑无量行无色等至解脱三摩钵底先行解脱门神通陀罗尼力无所畏无碍解大慈大悲佛不共法诸声闻果。了知一切相真如实际无相法界等法。是谓一切法

所言蕴者。谓即五蕴。何等为五。色受想行识。此中色者五根五境。根谓眼耳鼻舌身。境谓色声香味触。彼眼识所依。谓清净眼根。耳识所依清净耳根。鼻识所依清净鼻根。舌识所依清净舌根。身识所依清净身根。色有二种。显色形色。显谓青等。形谓长等。声有三种。谓执受大种。不执受大种。俱大种。香有二种。谓好香恶香。味有六种。谓苦醋甘辛咸淡。触有十一种。谓坚强流润温燥轻动重轻滑涩软饥渴等如是诸触总略而说。有其三种。谓可意不可意及二中间。此如是等由眼等所生。若界趣等分别三世。分别有无边分微细差别行相。应知此如是等。略说色蕴。受蕴云何。受有三种。谓苦受乐受非苦乐受。而此三受若依眼等分别者。有其六分。彼如是分别。受有十八。如下界中别明行相。此受蕴者。若界趣等分别有无边分行相。应知此如是等。略说受蕴。想蕴云何。想有六种。此之行相。谓依眼等分别彼所取境相。有其六种。所取相者谓即色等。然所依性即不可分别。若分别若不分别。谓即色受二法。此如是等皆从我蕴自类所起。此想蕴者。若界趣等分别有无边分行相。应知此如是等略说想蕴。行蕴云何谓心所有法信等善分。贪嗔痴等诸烦恼分。如是心所法。心诸分位所有行相依眼等转。此行蕴者。若界趣等分别有无边分行相。应知此如是等略说行蕴。识蕴云何。谓六识身。此识蕴者。若依眼等根色等境分别及彼识相。乃至善不善无记等。分别有无边分行相。应知此如是等略说识蕴。如前总说名为五蕴

所言处者。即十二处谓内六处。眼耳鼻舌身意。外六处。色声香味触法。此中应知。眼等五根色等五境为十色处。彼意处者。谓即诸识所余诸法。是为法处

所言界者。即十八界谓六根界六境界六识界。此中眼等识分别有六。即有六触。谓眼触乃至意触。彼色等识有三种相。谓善不善及彼中间。此之行相。眼等触为三受所生因性。即彼三受。从眼等触所生有六。彼六各各三种分别。谓苦乐非苦乐。如是总说触受。各有十八。如前受蕴所指。行相亦然

复次地水火风空识等相。名为六界。所言缘生者云何行相。即十二缘生。何等十二。所谓无明乃至老死。此中无明者。谓于业果谛宝法中不正行故。由此无明起诸烦恼。是故于无我中计我蕴等。而有所得。无明缘行。行有三种。福行罪行不动行。福行谓十善业道。罪行谓十不善业道。不动行谓无色等至。彼如是行。以其无明为因诸行得生。行缘于识是故眼等诸识爱非爱果种子生长。识缘名色。此名色者谓由识故施设彼名。名有生处。是故受等四蕴为名色。即如应依名而立。名色缘六处。彼六处者。谓由如是名色眼等六处建立六处缘触。触谓眼等色等。如前已说。触缘受。受有三种。亦如前说。此中触受行相应知。受缘爱。爱由无明。爱缘取。取谓色等所取所生乐行。取缘有。有行相者谓即如前所说行识等相。有缘生。谓即名色有所生起。由彼无明故有生法。即此无明自性亦无分位。生缘老死。老谓诸蕴衰变。死谓诸蕴灭坏。生法后边而无其实先所得身而悉舍离。然彼无明于后蕴中还复随转。增长一切烦恼过失。彼等皆由无明自类烦恼业等而为其因。是故烦恼业生。此三不断。以是轮回相续流转。如是知者。当于实法而起对治。了无明等自性无我。如是等略说十二缘生。所言波罗蜜多者云何行相。其数有十。此中施有三种。谓法施无妄施慈施。戒有三种。谓摄律仪戒摄善法戒饶益有情戒。忍辱三种。谓谛察法忍耐怨害忍安受苦忍。精进三种。谓被甲精进加行精进毕竟成就精进。定有三种。谓离过失定引发定办事定。慧有三种。谓闻所成慧思所成慧修所成慧。方便三种。谓离过方便拯济方便速证乐方便。愿有三种。谓自行成就愿解众生缚愿清净佛土愿。力有三种。谓成办事业力灭除烦恼力降伏魔怨力。智有三种。谓无分别智分别平等觉了智灭众生罪智。如是施等诸波罗蜜多。以菩提心为先。于一切众生起慈心观。而此诸波罗蜜多。于诸世间所行无有行相亦无所得。于出世蕴等是即无我解脱相。真实所证如理而观

所言地者。即彼十地。所谓欢喜地修施波罗蜜多。离垢地修戒波罗蜜多发光地修忍辱波罗蜜多。焰慧地修精进波罗蜜多。难胜地修定波罗蜜多。现前地修慧波罗蜜多。远行地修方便波罗蜜多。不动地修愿波罗蜜多。善慧地修力波罗蜜多。法云地修智波罗蜜多。如是诸地所得法无我理。皆慈心所证悉无差别。而彼所修施等诸波罗蜜多。安住清净胜上所得。广大愿力普遍成就。不共一切声闻等故。是诸波罗蜜多。于所缘相而无差别。若人若法离相空故

所言空者。即十八空。谓眼等空是名内空。色等空是名外空。眼等色等智观平等名内外空。方等诸分器世间相。各各观察一一皆空。是名大空。于诸分别离取舍性。说名为空。此空复空。是名空空。于胜义谛观不可得。名胜义空。于施等行诸有为法皆悉平等。名有为空。诸无为法无发悟相。名无为空。于空法中无有少法而实可转。散而无集。是名散空。彼一切法无有边际。名无际空。一切法中毕竟无余一法不空。名毕竟空。蕴等诸法自性如是。无所生起离自取舍相。名自相空彼一切法空无差别。名一切法空。于我蕴中取舍不可得。名不可得空。此不可得。谓色等相不可得故。但有诸业性。是名无相空。若人若法彼自性空。是名自性空。于诸性中离取舍性。名无性空。彼无性者谓离蕴等无别性故。若离蕴等自性起空分别者。是对碍相即名无性自性空。若彼如是分别尽处。即能解脱色等系缚。无复分别有无边分。离蕴等取舍。是即一相。而彼一相性无有二。彼如是故即于波罗蜜多安住一境。自性空理离戏论相。是即无我真实所观

所言菩提分者。即三十七菩提分。谓四念处乃至八正道。四念处者身受心法。此中身念处者观身无有种种积集而无所著。离取舍相等。是名身念处。彼受念处心念处法念处亦如是观。又复即此法念处中。若于内外中间而分别者别有三种。谓精进定正念此。三相应即能观察诸菩萨最胜菩提心及施等善行。于一切法中得无我相应。此念最胜。如是略说名四念处。所余诸法亦如是知

四正断者。谓是所对治非菩提分。即已生令断未生令不生。此名勤断二不善非所对治。是菩提分未生令生已生令增长。此名勤修二善。如是略说名四正断

四神足者。谓欲精进三摩地慧。如是相应行增上所得果。以其所得而观欲等所缘。谓四种三摩地。而彼身心离诸所依住离贪想。依止寂灭无所作行。如是略说名四神足

五根五力者。即了知一切相果。谓信精进念定慧等增上相应根力。如是略说名五根五力

复次此中如是等所修即二觉了分。谓暖顶位。暖位修四念处。顶位修四正断。又复有二胜觉了分谓忍世第一法。忍位修四神足。世第一位修五根五力。彼如是等无所作行。最上真实。信等根力为见道缘行相。应知彼见道所修谓七觉支

七觉支者即念觉支乃至舍觉支。此中念觉支者。谓利众生证菩提愿。现前正念无忘失相。择法觉支者。谓于我法自性决择为相。喜觉支者。谓自所修道得无漏因生喜乐故轻安觉支者。谓如其所证真实法性。非菩提分种子而舍离故。身业心业得轻安故。定觉支者。谓四无量及菩提愿。入真如智纯一境相。精进觉支者。谓虽观寂静胜上功德门而不味着。进修诸行复无懈息。舍觉支者。谓念利众生如应调伏。随其所行。波罗蜜多等诸功德法。平等分别观无来去。住平等故。如是略说名七觉支。即如是等七觉支行名正智分。彼能对治烦恼障及所知障行相。应知修道所修即八正道

八正道者。谓正见乃至正定。此中正见者。谓了一切法无我相。住于平等苦等颠倒。彼之二分是微妙相胜慧所观。正思惟者。谓起思惟不断所作因如愿而证果。正语者。谓诸语言离妄分别如实而说。正业者。谓诸所作而无颠倒。不害众生救拔众生等。离妄而修。正命者。谓于净命离诸邪妄。自行所修自行而证。正勤者。谓虽至最上地而亦增进。身无疲倦心生勇悍。正念者。谓念处等如实而观。慈心庄严自愿方便。于一切法无所忘失。正定者。谓身等业而常依止最胜功德。安住无分别智。即诸静虑相平等相应。如是等略说名三十七菩提分法。随应行相总略摄故

集大乘相论卷上集大乘相论卷下

        觉吉祥智菩萨造

        西天译经三藏传法大师赐紫沙门臣施护奉　诏译

复次所言圣谛者。即四圣谛。谓苦集灭道。此中苦圣谛者。谓蕴等颠倒相背圣法为性。集圣谛者。谓如所说苦。由此无明行等烦恼业集为缘。与生等苦而为因性。灭圣谛者。谓于一切法如实无分别无生相为性。世间痴暗对治灭如所证。道圣谛者。谓趣向菩提慈心等法及法念处。总略摄故此诸圣谛于一切法平等所缘。如是略说名四圣谛

所言静虑者。即四静虑。谓离生喜乐名初静虑。定生喜乐名第二静虑。离喜妙乐名第三静虑。舍念清净名第四静虑。如是等四皆寂止相。欲界等贪心不流动。是名静虑。然诸菩萨亦不味着诸静虑乐。毕竟不舍众生。圆满菩萨道法。成就无量行。如是略说名四静虑

所言无量行者。即四无量行。谓慈悲喜舍。此四皆缘无量众生为境界故。此中慈无量行者。谓与一切众生毕竟利乐。所修诸行而悉离相。远离颠倒顺菩萨道。悲无量行者。谓不令众生而有一苦。此悲谓能对治恼害不起为性。喜无量行者。谓证一切法无我平等。所有施等诸善住菩提心。广为利乐一切众生。方便所行如所生喜为喜受相。舍无量行者。谓于三有分别平等起广大行拯救众生。于自所得三摩地乐而不味着。此能对治放逸过失心住实相。如应调伏世间一切执相等心已能安住静虑。于诸色想对治实法。复于无量法门得法平等。住法无我如理而证。所获一切平等乐法。是名自在最胜所得。如是略说名四无量行

所言无色等至者。此有其四。谓空无边处乃至非想非非想处。此中空无边处等至者。谓离种种色对碍想。观无边空而为相应。舍诸有相心住一境。复次识无边处等至。无所有处等至。非想非非想处等至。此如是等皆寂静行如初相应。观无贪相而为所缘。余复观察无著无碍。如应最上无相出生。如是略说名四无色等至

所言解脱者。即八解脱。谓内有色观外色解脱乃至灭受想解脱。此中初解脱者。谓内有色想离外色贪。是名内有色观外色解脱。复次如其行相内无色想离外色贪。是名内无色观外色解脱。复次于色等清净住无贪行。是名净解脱。复次空无边处解脱。识无边处解脱。无所有处解脱。非想非非想处解脱。如是四无色处解脱。皆如其行相住如实观。复次灭受想解脱行相。应知如是略说名八解脱

所言三摩钵底先行者。谓欲住彼空无边处等诸三摩钵底。先当如应灭诸行相。住法自性平等寂静后当安住诸三摩钵底。此名先行。又复当知。此四无色等至及灭尽等至而诸菩萨于冒哩喏多位入师子游戏三摩地。现前而观。不为非三摩呬多心之所间断。亦复不为初静虑等之所间断。此灭尽等至是无动相。此中诸三摩钵底。何故次第如是。谓成熟众生如应所观次第如是。又复当知。此即最上乐门。获是乐者了我无实。我无实故自心寂静。所应修习诸神通波罗蜜多等。皆胜慧所观如实出生。此即略摄一切法相

所言解脱门者。即三解脱门。谓空无相无愿。此中空解脱门者。谓若人若法诸蕴等事离分别相。而彼蕴等若染若净。于分别相中毕竟无性。于空法中离取舍相。而无染智如实对治。无相解脱门者。谓于蕴等毕竟无相。由无相故取不可得。彼无染智如实对治不着诸相。无愿解脱门者。谓于一切清净解脱门蕴处界等及波罗蜜多圆满胜行最上一切相皆如实知。如实出生现前平等。离诸所取愿乐心故。如是略说名三解脱门

所言神通者。有其六种。谓天眼通乃至漏尽通。此中天眼通者。谓于诸色相正观无碍最胜清净。天耳通者。谓于一切音声能闻清净。他心通者。谓于他心一切行相能如实知。宿住通者。谓自他过去诸差别事悉能记念。神境通者。此复有三。谓隐显自在。随诸世界种种现身。于虚空中往来无碍。随所作转如应现身。如其所应不现身相作神通事。漏尽通者。谓诸无明贪等烦恼。此名为漏。智断无余。名为漏尽。如是等最胜六通。安住菩提心离戏论智。是诸菩萨胜上所修。不共一切声闻道等。圆满无相无发悟性。是诸波罗蜜多平等道行。总摄一切白所修法一切愿力一切相故。勇猛精进而为先导。安住最上清净心一境性。初静虑等。如名如义随应差别。无边行相总略摄故。三摩陀耶所住持故。如是略说名为六通

所言陀罗尼者。谓即彼一切相及一切法。一切法性随应总摄。声名句文为诸义相。所有无量念无边辩才及诸三摩地门。彼无相智悉能证入。对治有相有碍心故。是即无上菩提最胜所得陀罗尼门。而彼一切三摩地陀罗尼等。金刚喻定现前证入。即一切相普遍平等。入无相智真实而证。一切种习皆悉舍离。智观平等大悲相应。坚固所作于诸法性如实解脱。胜报现前平等安住。大圆镜智如实出生。一切愿力皆悉圆满。如是略说名陀罗尼

所言力者。即佛十力。谓处非处智力乃至漏尽智力。此中处非处智力者。谓于一切处因果决定不决定智如实知。若佛若梵王若转轮圣王。彼彼所得胜报决定。名之为处。彼非处者。谓因果不决定行相应知。业报智力者。谓诸众生。作善业恶业。生善趣恶趣。此等业报智如实知种种界智力者。谓诸众生界趣差别智如实知。种种胜解智力者。谓诸声闻等于诸法中起种种胜解。离诸染法趣寂静相。此如是等智如实知。了别诸根智力者。谓诸众生信等诸根种种差别智如实知。种种定智力者。谓初静虑等诸三摩地三摩钵底。如名如义无边行相智如实知。至处道智力者。道有二种。谓非爱乐道。即无明等。可爱乐道。谓寂灭等。而彼灭者谓声闻缘觉及诸菩萨所证差别智如实知。生灭智力者。谓诸众生种种生灭智如实知。宿住随念智力者。谓于过去事如实记念。漏尽智力者。谓佛世尊大圆镜智自性观察。离诸障染分别平等。如是处非处等诸力如来游戏神通所证。此力具足故。即一切法增上所观。如是略说名为十力

所言无畏者。即四所畏。谓一切智无畏。漏尽无畏。说障道无畏。出苦道无畏。此如是等若异若非异。有所言说悉无所得无畏自在。此四皆以平等性智而观。如如意宝随众生意普遍平等。此法亦然。我相清净离诸有着。如是略说四无所畏

所言无碍解者。谓义法乐说辩才等。此中义无碍解者。谓于一切众生无我相。以微妙智平等而观。法无碍解者。谓随诸相了知诸法智观平等。乐说无碍解者。谓随所乐说能说所说不离自性。辩才无碍解者。谓于无边法门随应分别通达无相。此如是等与一切法增上相应。皆为摄彼诸愚痴者令悉调伏安住诸法离相平等故。此四皆以妙观察智而观。如是略说四无碍解

所言大慈大悲者。此中慈谓与众生乐。住寂静心无发悟相。广大最胜离相平等。悲谓拔苦。调伏难调不舍众生离诸有相。此二皆成所作智而观。如是略说大慈大悲

所言佛不共法者。即十八不共法。谓如来身无失乃至现在知见无著无碍。此中初者谓如来身无失。无有疲倦离身诸过。如来语无失者。无非爱语离语诸过。如来意无失者。无有失念离意诸过。如是三业为令愚痴者生净信故。无异想心者。于一切众生住平等心。无不定心者。为令愚痴众生除散乱相。无不知舍心者。谓诸众生事无有不知而舍者。此等六法。是彼增上戒学所出生故。与无住涅槃而为因故。信无减者。谓于无住涅槃中不坏信故。欲无减者。谓于无住涅槃不爱着故。精进无减者。谓于利于命于行悉无住故。慧无减者。谓毕竟于诸世间长养众生无不通达故。解脱无减者。谓不取声闻等涅槃相故。解脱知见无减者。为利众生智破戏论相。令诸众生各各平等证得无上涅槃。此等六法是彼增上定学所出生故。与无住涅槃而为缘故。身业随智慧行者。谓于一切处若动若止经行等相。常与智慧而共相应。是故智慧而为先导。语业随智慧行者。谓一切语言离妄分别。常与智慧而共相应。是故智慧而为先导。意业随智慧行者。谓于众生住平等心。随所利益无有差别。常与智慧而共相应。是故智慧而为先导。过去知见无著无碍者。谓内无有性名为无著。外离诸缚名为无碍。于过去一切法。平等悉知破戏论相。未来知见无著无碍者。谓于未来一切法。平等悉知破戏论相。现在知见无著无碍者。谓于现在一切法。平等悉知破戏论相。此等六法。是彼增上慧学所出生故。此等诸法唯佛如来圆满成就无上胜智。为利众生随众生转。不共一切声闻有故。法界清净智所出生。如是略说名十八不共法

所言声闻果者。即四声闻果。谓须陀洹乃至阿罗汉。此中须陀洹者。厌苦欣乐。随应断除所有烦恼。七返生死见苦等谛。悟人无我趣向涅槃。斯陀含者。厌苦欣乐。随应断除所有烦恼。一来此界见苦等谛。悟人无我趣向涅槃。阿那含者厌苦欣乐。无余欲界烦恼可断。不还欲界于色无色界。随应解脱见苦等谛。悟人无我趣向涅槃。阿罗汉者。悉断三界所有烦恼。尽苦边际悟无我理。随应解脱趣证涅槃。如是略说四声闻果

所言了知一切相者。谓诸佛如来于一切相如实了知现前平等。一切相者。即一切法。诸佛如来为利世间。一切所向随应方便。得无妄失法。住坚固相

此中应知。三身亦名一切相。法身自性无我智相。无差别故。报身最胜相。即一切相智所依性故。化身所作事相。于一切处如应现化而施设故。又复一切相者。虽所了知而无分别。为利众生随应所作。是相寂静无缘自性一切平等。所有蕴等一切相亦复无边。若在三界若出三界。应如实了知诸相不可得。如是名为了知一切相

所言真如者。即一切法自性离取舍。若智若愚若色若心。住平等性离妄无分别。是即名真如

所言实际者。即菩提性一切如量如实离诸分别。此中应知。如佛所说于我蕴等性毕竟无所得。复于他量而不可言说。如是名为实际

所言无相者。即彼真如说名无相。而真如者。但以名字假分别故。于名字中性不可得。当知我等性即诸法自性。是故此中若人若法。悉离诸相而同一相。此一相者。即一切法无对碍相。离诸分别。于第一义自性无动。是名无相

所言法界者。即十力等果法及诸因法。乃至一切法自性所依。是即法界。此法界中远离一切虚妄颠倒分别相等。明慧现前如实照了。是名法界

复次当知。此中真如等大圆镜智等。即一切法无所作门。彼真如无所作门。即诸法自相门

复次当知。此中真如及彼十力。皆以大圆镜智而观。彼实际所证及四无所畏皆以平等性智而观。彼无相微妙清净及四无碍解性。皆以妙观察智而观。彼法界一切法真实所证所依性及大慈大悲。皆以成所作智而观。所有一切处增上所观法。皆悉安住法界清净智

如是等一切法。当知皆悉如量正语与菩提心相应。大慈随顺一切众生。是一切法平等同一所缘。相应无相最上法门。总摄波罗蜜多等一切法故。随其所行如量相应。此相应故。是名一切法无我。智者当知。佛所说法从解脱门如实出生

  诸佛智慧无有上　　所说因性亦无边
  于彼无边如实知　　一切相应而表示
  诸相应门显诸性　　随宜方便而出生
  大慧所作悉圆成　　我为利乐故称说

集大乘相论卷下


集诸法宝最上义论

    No. 1638

集诸法宝最上义论卷上

        善寂菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

归命一切佛。归命诸法藏。顶礼一切智。广大甚深理。我今造论名曰宝上。是诸法中最上真实决定胜义。论曰。若人若天及诸情类。从无始来痴暗为因。有语言道是恶趣根。若有乐入彼一切智清净界者。是故归命佛曰光明。此中云何所谓离我等性及一切因当知一切烦恼业生杂染等法。无初无住而无实体。虽有所生与梦幻等。如梦幻故从分别起。当知诸法皆从缘生。是故诸佛缘生义中。宣说诸法诸物性空空无自性。而亦不应于中作无实想。是故清净阿赖耶识。虽有所受而无所著。此义甚深又复广大。诸经教中皆如是说。诸有乐欲求解脱者。应当如实觉了诸法。当知诸法不离于识。若离识者是性即断。是故法中无实有性。法集经中作如是说

若法是实若法不实。若有自性若无自性。是二不应将幻喻等。诸法非有性而亦非无性。此中所说若实无性。无性名空空即成断。若实有性是性为常。当知言空与非空异。离空非空亦无所得。又如明暗二不相合。离暗离明俱无所得。是故应知。此中所说明不现前暗云何离。智之与愚二不相合。离智离愚亦无所得。非智非愚是二中间我想皆空。彼一切法无内无外亦无中间。无法可取无法可舍。宝积经中作如是说

若说言有此为一边。若说言无是为二边。若一若二若彼中间。皆无有相而不可见。无相见故亦不可说。无形无像不可表示。无种类法无所摄藏。亦非中边有所安立。此中所说是真实说。性与无性本来如是。作此解者真观圣谛能离贪等烦恼过失。设复烦恼有所生起。于圣谛中而无所著。若如是知如是解者。即得如来功德聚身。作师子吼转大法轮。普令一切皆悉见闻。楞伽经中作如是说

我语无相而不可取。转识经中作如是说

离识有法理不相应。授记经中作如是说

当知识心遍一切法。十地经中作如是说

色法无实不可取舍。那耨俱梨经中作如是说

若了诸法性即非智所知。是故此中无实可得。智体无实当知如幻。诸经教中作如是说

诸菩萨者随诸相转。是相无实义无所得。胜义谛中言不可立。宝云经中作如是说

若本是无不可言有。识离分别名不可立。彼胜义谛真理离言。而诸物性实无所得。此如是说是决定语。佛所说意破诸无智。现爱经中作如是说

若言有物是为空者。众生业报应有染净。若有染净即是有作。若有所作即种种相随世间转。有相转故见有所成。若能安住无颠倒想。即知物性无别实体。此如是义者慈氏菩萨问。世尊如实说。我本无边菩提亦无边。菩提无边故无菩提可得。我无边故无求菩提者。亦无少法是智所知。唯诸佛智而能照了。彼真如法即是无性。无性即是如来。如来者即是无生性。飒钵多设多经中作如是说

彼一切法若说言有此为常语。若执为无即成断见。若非有非无又中间不立。宝星经中作如是说

贪等烦恼一切染法。若解脱者是无尽相。若能了知烦恼自性本来清净。胜义谛中脱无所脱。若欲真实观如来者。当观如来解脱所生。不从因生不从缘生。非有相生非分别生。远离一切名言差别。非色相非色。真如乃至非识相非识。真如非晦非明。非即非离。非见非知。离诸识法非所了别。不于一切识法中住。若能如是观如来者。名为正观。若他观者。名为邪观。以邪观故彼不能见如来真实。此中所说如实义者。离有离无。非性非无性。如是名为真见如来。无垢称经中作如是说

华严经中有一天下。问妙吉祥菩萨言。云何实语不实语。一切烦恼云何调伏。妙吉祥答言。如人梦中见彼大蛇。是人虽见非毒所害。烦恼虽生而无实性。是性清净而自调伏。此为实语非不实语

又海慧菩萨问不思议梵天言。法本无证及无所说。云何有佛及诸佛法。不思议梵天答言。若佛如来出兴于世。及彼演说诸佛法分。若有若无本自如是。本来无说亦无所证。无说故无闻。无证故无得。但为众生烦恼业生诸果报性引生诸佛大菩提心。住诸菩萨悲心境界。若诸众生烦恼等性能自调伏。所有诸行而不常行无求无愿。彼烦恼性悉清净者。诸佛亦复无证无说

又善财童子言。当知诸法皆悉如幻。我于幻中而求解脱。如是等义华严经说

当知诸法如幻如梦如阳焰如聚。沫如乾闼婆城。三界一切法从识心所生。心如幻故三界如幻。若有一物有实体者。此说幻喻理不相应。三摩地王经中作如是说。如上诸义诸经中说

复次我今依经略释余义。如妙吉祥菩萨言。菩提者不可以身得。不可以心得。若无心即无身。身心离故无为无作。如幻如化。若如是说为菩提者。诸佛说此是为菩提。能入诸佛平等境界。是故乃可名智庄严。而不庄严彼一切智。一切智性不可得故。菩提无生亦复无灭。不一不异非此非彼。诸佛如来咸作是说

又复譬如世间一切种子而能生。长一切芽茎。若无种子芽茎不生。释迦菩萨坐菩提场成等正觉。其义亦然。但从缘法而生起故。虽有所证而无其实。此即说为游戏神通。是故当知。无有外法。诸佛如来亦无有性。是故离识实无一法。若离识者法不生故。若心能生心即无生。若法所生法亦无生。以是义故。诸佛如来于无生心中说菩提义。佛说识心能生菩提。亦非识心而能生故。何以故。识性空故。妙吉祥所说是最上真实。于自佛境界中如实而说。又复诸法皆从缘生。而彼所生亦无自性。是故诸法皆悉如幻如幻之言。是如实说。慈氏菩萨现住如幻三摩地中。是故世尊于是三摩地中与授其记。为表示故。又复世尊于无数经中宣说诸法从识所现。离生离灭。非有相非摄藏。无起作无止息。不有不无。非常非断。当知智性皆悉如幻。况复诸法有所分别。若有执着断常语者。彼非正行佛不许可。若知诸法非断非常。彼正相应。说名真实。于自分外无法可着。亦无有法是心所对。虽于诸法说种种句。但随诸法为表了故。当知自识而非他识。于其外义而无少法所可乐欲。自识无性他识无性。于自于他亦无异性。彼真实智离有离无。当知我识亦复非有。补特伽罗蕴语所摄。是故应知一切佛一切法皆自分有。若离自分求不可得即此所说离有离无。是甚深义。诸佛皆说此微妙法。远离一切取着分别。离此亦复无别所说。诸迷谬者若着于有即有善恶界趣二种差别。若着于无即无其想刹那生起。是故著有着无俱不相应。诸佛如来悲心方便宣说此义。谓一切法离有离无。如是所说是最上句。是故此说诸法真实。法无著性非诸所观。彼无著性离有离无。若如是知。是大智者。当观虚空无增减无分量无边际。即此虚空出生一切。清净识心亦复如是。此心无心一切出生。又如净摩尼宝。彼无心故映现一切。或有问言。云何分位而无能取。应如是答。谓彼虚空无作边故即无能取。若彼虚空无作边者。量云何得。当知一切众生界如微尘聚。彼一虚空悉能容受。而诸众生等虚空界无所增减。若一切有情。及一切方分。一切种类。一切形相。一一分别。是中实无一性有所生起。以是义故非一性非多性。一多中间而亦无性。若言一性定有所得。即种种性而有差别。有差别性即分别生。是故一性多性是性平等。若于外义无所取着。于智亦复而无所得。若于外义无所取着。于智亦复无所生起。若知识心离诸有相。而彼外法有何分量。若知识心是诸有相。而彼外法亦何分量。是故应知于彼外法实无一性而可生起。如梦等法无实作用。若言诸法是此此无自相。若言诸法是彼彼亦无实若于自心有所了知。即此自心亦复无实。若如实知者名觉了识相。若有一切粗重分别心起。当知皆是烦恼差别所生。若能了烦恼性离分别心。即生死涅盘二俱清净。此清净性即诸法性。是性亦复名为真如。名为实际。亦名为空。是诸性中若染若净。实智所观皆悉平等。或有问言。于一切法中何者是不坏。应如是答。诸法自因不坏。云何不坏。不坏因性故。若法有性。若法无性。不离自性。于二义边何能安立。若诸法因及诸作用有所坏者。于一切处理不相应。诸法实性云何随转。谓彼实性无所住故。诸法无性云何有因。离因亦复无别性故。又诸法实性而无所坏。即坏之名亦复无住。此中亦无差别因性。彼坏灭性无分位故。诸法真实是常住性。彼常住性非无常性。若离实性别义作用理不相应。然诸物性而亦不减。又非无常性是真实性。真实性中而有何义。是所作用无差别性不可分别。彼一切常遍一切处又非无常性是真实性。真实性中相云何得。诸不真实此云何立。诸别异性此云何现。是故非无常性应如是知。又复当知。无常性者于物性中自类而转。聚类所现差别因故。所欲为因而生起故。若或以彼诸无常性。而于此中为决定说。与唯识义理不相应。彼无常性无决定故若法不坏亦非不坏。有法刹那而生起故。若言不坏者。何名无常性。若非不坏者。又何名因性。过去未来法亦如是。皆无物性。定实分别诸法随转。随其分位此复何因。谓无住故。诸有为中现前事灭。即彼后事还复生起。前不可分别引生后分。后不可分别从前分生。若言诸法此有所得。即于此中起分别因。若言诸法彼有所得。即于彼中起分别因。过去未来无住亦然。是中不应有所。分别刹那法中可说有坏不坏义边非刹那法。若于彼因如是了知。前后中际不可分别

集诸法宝最上义论卷上集诸法宝最上义论卷下

        善寂菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

复次今说生住异灭。此之四相刹那刹那有所转故。不相应相而无其实。于不相应无实相中。不可起二分别。不可说一时。不可说异时。一时异时无生起故。又不可说无时。理相违故。若说坏时。坏即不生故。是故当知。生时无住。住时亦复而无所得。彼无住性。云何有灭。彼生与住说名为异。若本无生云何有住。若法无住即云何得。以无生故及无住故。于何义中而说有灭。若法有住于住法中可说异性。法既无住何有异性。无异性中不应分别。当知异性而非住性。实无一性而可分别。是故诸相及分别心。此为二种。若无诸相即无分别。若彼诸相若分别心有分别者。二俱分别。如实义者无相无分别。生住异灭若有性者。于一切时一切处一切法初中后分不可安立。若能如是如理思惟者。佛说是人名为大智。初分中分后分诸性。于三分性中实无一性有所生起。是故诸法非一性非多性。一多中间俱无所得。若一切法离一性离多性。即常与无常无所分别。是故非无常非非无常。不应于中起二分别。当知初分中分后分。不俱时生。不俱时有。如他人性即自所无。若自体性。他云何有此中所说自性尚无。他性何有。是故自亦无性他亦无性。当知一切法所行所作不离因性。若坏不坏非心所思。不可分别。初中后分如实思惟。皆无为相无别异相。不应分别彼彼诸法各各种子彼各各性。一一不离智种子生。刹那刹那时分转易。是故彼彼一切法性。云何心能思惟生起。一切法中差别事相。当知无因亦无差别。诸法本来无所造作。虽作用相续当何有实。是故所知诸法及能知者。是二于刹那中不能和合。彼如是性实无能取。是中无所有亦无所得。当观诸法生已即坏。若法不坏即非生法。以法坏故而无所得。彼不坏者是常住性。即常住性彼亦复离。即离之言是中亦离。若如是知。即了诸法彼差别性。是常住因。无差别性亦复如是。诸有为法即生即灭。故名无住。若有住者应有所得。以无住相无所得故。彼无住法是故相应。一切行中诸差别行。若彼彼性有所得者。于无差别行云何对治。是故差别行中无性可生

复次当知。眼等诸识有现量性。大牟尼师亲所宣说。若离现量性别取量非量者。彼于此中当云何得。世间所有先所作事皆无所依。如诸所作无作用性。若彼如是诸现前事。如其现前亦无所成。是中若有所行及非所行。即诸作用义皆相违。是故一切无实作事皆如虚空。常与无常俱不可执。当知诸法皆从缘生。虽生亦无少法可得。缘如幻故所生如幻。即彼如是出生诸法。以是义故。诸法无性亦非无性。此如是义。正等正觉如实宣说。当知一切法无著无碍。于大乘中此真实说。如是了知。即菩提心本来平等。十方三世一切如来。如实知故出生方便。宣说一切甚深法门。如其所应名言分别。是故各各宣说表示出生诸法。所谓彼彼法是四谛法。彼彼法是唯识法。虽有所说而常真实。彼彼诸法皆悉如幻。由如幻故不可寻不可伺。不可知无表示无摄藏。若离如是等即知法真实。以知真实故而菩提心速得解脱。若菩提心如是解脱即诸佛亦然。众生亦然。生死亦然。涅盘亦然。法界亦然。是故佛与众生二俱平等。生死涅盘亦复平等。若于此中如是如实了知是义。佛说此为诸佛菩提。乃于一切所行所作悉能成办。此所说义是第一义。离此无别有第一义。此第一义摄一切法。是不思议真实语行。离有离无。非智非愚。非少非多。无相无性。无所照达。智不可知。识不可识。不即自性不离自性。无取无舍离取舍相。从如实智之所出生。随所出生。随所言说。无取相无摄藏。非心所思。不可知故。非眼所见。不可见故。何以故。心无自性故。由心无自性即一切法无自无他。以无自他二种差别。即一切法自性相应。无生无灭。无集无散。非智非愚。无有少法。有所表示。有所照达。当知彼彼菩提种子。而彼彼相为表了故。若能于彼彼相观无我者。菩提种子亦无所生。诸菩萨摩诃萨自性真实。以善方便出现世间。起大悲心示有所证。而诸菩萨自性真实无生无灭。当知识法远离疑惑。无有少法而可生起。我我所空。而无有相显了表示。识相光明而无自性。然光明性彼性自常。是故我相性者无有光明。无光明中云何可说有光明相。如诸光明而能破暗。然暗与明不近不合。不近故明何能破。不合故暗何所破。若明暗相远又俱无所得。是故当知。明能破暗不即不离。不可于中定实分别。暗虽有破无能破法。彼能破法无别分量。何以故。破名无住故。由此应知。彼一切法因缘和合而有所生。以缘生故如幻而成。如幻法中彼痴暗等亦非烦恼。但为智障而不了故离识分别。亦非光明有所生起。是二实性俱无分别。此中见边而实无得

复次当知。触作意受想思欲胜解念定慧。如是等心所有法。彼彼皆是菩提之相。而彼一一自性清净。若或有法非菩提相者而于自体理不相应。当如虚空自性清净。而彼智性亦然清净。若知我相实无所有。即彼识心亦复无生。若识无生者彼一切法当云何有。是故应知。诸法皆从真实所生。诸法因缘和合即生。虽生无实而无所有。诸法如幻。识心如幻。缘亦如幻。由如是故识从缘生。当知智性亦复如幻。无所分别无所了知。诸法自相非智所知。但有言说皆不相应。此中若能离诸分别。若生若灭皆悉远离。缘生如幻。所生亦如幻。云何如幻中而实有生。当知识心彼如幻故智亦如幻。智如幻故所知亦如幻。智与所知俱如幻故生法亦然。生法如幻故诸法亦然。如人见彼幻所作象。如其所生即有三事。世间诸行亦复如是。如其所生。亦有三事。若于此心有所见者。即有言说及所作事。若了无心即无所思。无心无思。法云何有。若有我相及有我所可说有见。无我我所当云何见。彼菩提相亦云何证。此无我相如是应知。一切幻法而无所有。如幻所现说名为有。有性无性彼自性性。此性无著一切处现。若法是有即不应无。此有亦复现前无体。若法是无即不应有。此无亦复现前有实。是故无生亦无摄藏。由此应知。若法言有不如是有。若不如是有即应是无。此中言有又不可定记。法界自性应如是说。若诸色法是实有体于第一义然无所有。是故此中诸所作事。皆从幻化分别起故。若法有性若法无性。本自如是。若非有性若非无性亦复如是。有性无性自性相应。性与无性非心分别。若有说言诸法是一一无自性。若有说言诸法是异异无自性。一切法中无自性性说不可得。所有诸佛随三世转。普令世间一切众生尽得解脱。而诸佛界无增长因。彼彼亦复无增长性。真实性中诸佛常有。当知一切法四种分别。所谓若有若无是二非二。世间如幻心亦如幻。云何无说而有所说。一切法空离诸所著。空亦不离彼真如性。是中不应戏论分别。以是义故诸法无性。应如是说。当知诸佛正等正觉。非性非无性。性与无性皆离着故。此即非空亦非不空。空有中间亦无所立。是故一切法无生无性。以无生无性故随诸有相处处表示。然其执相义无所得。无实取性。是即真实。诸法无生亦复无灭。彼一切法皆同一相。此中如是同一相故。即一切法无染无净。若言诸法有生有灭。当知皆从烦恼种子虚妄生起。若说诸法为无生者。彼说名为断见增语。若说诸法为无灭者。彼说名为常见增语。是故应知诸法离言。不可说生不可说灭。一切法中若生若灭。实无少法而有所得。若能离彼二种增语。即一切法非断非常。有性无性性自真实。此中无有少法是所得相。无有一事而实可转。诸法虽生而无所有。是中亦复无实境界。智如虚空离诸有相。智与虚空皆悉平等。当知一切差别分别为烦恼网碍清净性。真如无相离诸所缘。自性清净有大光明。是故当知。诸佛世尊本真如性。是为佛宝。以清净因示清净法。开生正解自性任持。是为法宝。指真实道自体相应。是为僧宝。如是三宝皆无为相。非蕴等法。无所集无所有。无有相无分别。是故诸佛世尊住胜义谛。从如实道如实而来。故名如来。如实了知无我等法。是故现诸色相及功德法。从初发心修诸胜行得不退转。乃至最后一生补处成等正觉。此所因者。从无垢真如现诸佛身。此所现身是方便生。宣说诸法然无说相。何以故。无性无所有故。识心清净。是识即有诸所作事亦如是现。虽现无取而亦无说。以胜义谛不可取不可说故。即此无取及无说。性体自真实亦不可说。以不可说即无分别。无分别性是胜义谛。于胜义谛中随事分别所有所有诸法声。如是如是诸法说彼彼诸法无说相。诸法法性皆平等。诸法无我亦无自性。有性无性彼彼自性离有离无。而不可取亦不可说。此中如是若有若无。语义甚深离相而说。诸法无证相。此名正等觉。诸法离说相。是名真实说。无生亦无灭。诸法甚深义。各各诸境界。无我而无转。外法不可转。外法不可取。施戒等诸法虽说而无相。是故于一切法无所取相。即无所著。此中亦复无别作用。设有所作事亦说名为空。作用空故无实行相。无实行相中法无增无减。若于诸法虚妄分别。当知彼心执相中转。起彼心故。是愚痴者着烦恼性彼非解脱。若不起彼虚妄分别。诸所作事皆悉寂静。彼能如实而得解脱。无分别故心性常寂。是故诸法从缘而生。虽有所生说名为空。当观自法而无有相。正等正觉作如是说。当知诸法无集无散无自无他。无有小法取相可得。如初亦如后初后相应。而彼真如性光明照。若能照达彼真如性。诸法缘生现而无碍。如幻所生亦如是说。此所宣说大乘出生。当知一切法若生若灭。非寻伺道而能知故。何以故。诸语义边无所著故。彼真实性不可知故。是故现前无所取着。智者如实离诸言说。彼分别心说名为网。离分别故即得解脱。彼解脱心如空平等。如是所说是甚深法。若于此中如实信解。是大智者。彼信解心与三界等。是心清净离诸尘垢。复能远离一切染着。即于诸法无取无舍。一切执着愚痴皆悉远离。彼能获得十种自在。彼于自法觉了实性。无自性中亦无所住。于诸法中如实信解。如所信解如实而住。譬如虚空周遍无缺。彼一切法圆满出生亦复如是。是法平等普遍一切。是中无法若来若去。无来去故诸法现前。知是义者通达佛教。一切生法悉无所著。异此亦复无别有法。此是大乘诸法要道。最上甚深如实而转。识心净故一切无著。与一切法理不相违。是故当知。一切执心尽处有法。彼法甚深非智所观。非所了知。有无二处俱不可立。以是义故。诸佛菩提无能证者。无所证处。菩提法中无所安立。若能如实证自佛者。与一切法而自相应。诸法无因亦无所作。诸愚痴者思惟分别。若执无因又复不能集诸福事。起染着心感恶趣报。是故智者。于此甚深微妙法中。如实信解尊重恭敬。即得无量最上福聚。是名真实修大乘者。是故若人觉了此道。是如实道。是无著道。最上最胜。而能发生清净信者。诸佛称赞。有诸无智邪见外道。不能舍彼诸执着心。此甚深法不应为说。若为说者理不相应

  我所称赞最上法　　初中后善理相应
  总摄最上真实句　　甚深微妙不思议
  集诸功德量无边　　普施一切众生界

集诸法宝最上义论卷下


迦叶仙人说医女人经

    No. 1691

迦叶仙人说医女人经

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

尔时喏嚩迦仙人忽作是念。世间众生皆从女人而生其身。而彼女人从初怀孕至满十月。或复延胎至十二月方始产生。或于中间有其病患。于病患时极受苦痛。我今方便请问于师。禀受方药与作救疗。作是念已。即诣于师迦叶仙人。伸师资礼而作问言。大师迦叶是大智者。我今欲有所问愿垂听许。迦叶仙言。恣汝所问。时喏嚩迦仙人白言。女人怀孕期当十月或十二月。日满方生。云何中间有诸病患逐致胎藏转动不安。或有损者苦恼无量。我师大智愿为宣说救疗如是病苦方药。作是问已。听受而住

尔时迦叶仙人。告喏嚩迦仙言。女人怀孕不知保护。遂使胎藏得不安隐。我今为汝略说随月保护之药。怀孕之人。第一月内胎藏不安者当。用栴檀香莲华优钵罗花入水。同研后入乳汁乳糖同煎。温服此药能令初怀孕者。无诸损恼而得安乐

复次告喏嚩迦仙言。女人怀孕于第二月胎藏不安者。当用青色忧钵罗花。俱母那花根。菱角仁羯细噜迦等药。诸药等分。捣筛为粖用乳汁煎候冷。服之此药能令胎藏。不损疼痛止息昼夜安隐

复次女人怀孕至第三月胎藏不安者。当用迦俱[日*(匕/示)*(入/米)]药叱啰迦俱[口*(匕/示)*(入/米)]药及蓖麻根等诸药。等分以水相和研令极细。又入乳汁同煎令熟。后入乳糖及蜜。相和冷服。此药能安。胎藏止息。疼痛若有患者服之安乐

复次女人怀孕至第四月胎藏不安者。当用蒺蔾草根并枝叶等。忧钵罗花并及茎[卄/幹]等分用之。以水相和研令极细。复用乳汁同煎令熟。候冷服之。此药能安胎藏止息疼痛。患者服之而得安乐

复次女人怀孕至第五月胎藏不安者。当用瓠子根及忧钵罗花。各用等分捣筛令细。后入蒲萄汁乳汁乳糖同煎候冷服之。此药能安胎藏止息疼痛。患者服之而得安乐

复次女人怀孕至第六月胎藏不安者。当用闭阿罗药子摩地迦罗惹药萨讫多嚩药各用等分。以水相和研令极细。复入乳汁同煎。后入乳糖及蜜。候冷服之。此药能安胎藏止息疼痛。患者服之而得安乐

复次女人怀孕至第七月胎藏不安者。当用蒺[卄/梨]草枝叶并根。捣筛为粖。用乳糖及蜜为丸。用肉汁服之。复以肉汁飱饭食之。或食菉豆粥饭。此药及饭能安胎藏。患者服食而得安乐

复次女人怀孕至第八月胎藏不安者。当用三[牟*含]誐药莲花青忧钵罗花蒺[卄/梨]草各等分以冷水相和研令极细。后入乳汁及糖蜜等同煎。候冷服之。此药能安胎藏止息疼痛。患者服之而得安乐

复次女人怀孕至第九月胎藏不安者。当用蓖麻根迦俱[口*(匕/示)*(入/米)]药舍罗钵赧尼药没哩贺底药。各等分以冷水相和研令极细。入乳汁同煎。候冷服之。此药能安胎藏止息疼痛。患者服之而得安乐

复次女人怀孕至第十月胎藏不安者。当用菉豆忧钵罗花。等分以水相和研令极细。复入乳糖及蜜并乳汁同煎。候冷服之。此药能安胎藏止息疼痛。患者服之而得安乐

复次女人怀孕延胎十一月胎藏不安者。当用青忧钵罗花娑路刚药莲花并茎。等分以冷水相和研令极细。后入乳汁乳糖同煎。候冷服之。此药能安胎藏止息疼痛。患者服之而得安乐

复次女人怀孕延至第十二月胎藏不安者。当用迦俱[口*(匕/示)*(入/米)]药叱啰迦俱[口*(匕/示)*(入/米)]药甘草忧钵罗花。各等分捣筛令细。以水同研。后入乳汁相和煎熟。候冷服之。此药能安胎藏止息疼痛。患者服之而得安乐

尔时喏嚩迦仙人。闻师说是女人怀孕保养法已。欢喜信受作礼而退

迦叶仙人说医女人经


解脱道论

    No. 1648

解脱道论卷第一

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    因缘品第一

礼世尊应供正遍知

  戒定智慧　　无上解脱　　随觉此法
  有称瞿昙

若人脱众难已得离诸着。成就于胜分心。畏生老死。乐善乐解脱。令到涅槃乐。未到有彼岸亦令得具足。广问修多罗毗昙毗尼事。此解脱道我今当说。谛听。问云何为戒。答戒者威仪义。定者不乱义。慧者知觉义。解脱者离缚义。无上者无漏义。随觉者知得义。此法者四圣法义。瞿昙者姓义。有称者世尊义。以戒定慧解脱殊胜功德。能到最胜名称无量。解脱道者何义。解脱者五解脱。伏解脱彼分解脱断解脱猗解脱离解脱。云何伏解脱。现修行初禅伏诸盖。此谓伏解脱。彼分解脱者。现修达分定诸见解脱。此谓彼分解脱。断解脱者。修出世间道能灭余结。此谓断解脱。猗解脱者。如得果时乐心猗。此谓猗解脱。离解脱者。是无余涅槃。此谓离解脱。此解脱道为得解脱。是具足道以戒定慧谓解脱道。解脱道者我今当说。问何用说解脱道。答有善人乐得解脱。不闻说解脱故。又不伏解脱故。又不正伏解脱故。如盲人无导独游远国。唯婴众苦不得解脱。欲得解脱而无所因。何以故。解脱是因。如佛所说。若有众生尘劳微细。不闻法故终亦退转。又如佛说。诸比丘有二因二缘能生正见。云何为二。一从他闻。二自正念。是故说解脱。不伏解脱者。为生厌离故说解脱。不正伏解脱者。为除不正道。为得禅解脱道故说解脱。如远行人得善示导。是伏解脱道。三阴成满。何等为三。谓戒阴定阴慧阴。云何戒阴。正语正业正命及种类所摄。或戒阴种种戒功德聚。云何定阴。正精进正念正定及种类定阴所摄。或种种定功德聚。云何慧阴。正见正思惟及种类所摄。或种种慧功德聚。此三阴成满。是伏解脱道。当学三学。谓增上戒学。增上心学。增上慧学。有戒有增上戒学。有定有增上心学。有慧有增上慧学。复次有戒戒学。有戒增上戒学。有定心学。有定学增上心学。有慧慧学。有慧增上慧学。问云何戒学。答谓有相戒是名戒学。谓达分戒是增上戒学。复次凡夫戒。是名戒学。圣戒是增上戒学。问云何心学。答所谓欲定。问云何增上心学。答色定及无色定。此谓增上心学。复次有相定心学。达分定及道定。是谓增上心学。云何慧学。谓世间智是名慧学。四谛相似智及道智。是谓增上慧学。如世尊为钝根人说增上戒学。为中根人说增上心学。为利根人说增上慧学。问学者何义。答学可学学增上学学无学名学。如是学此三学。谓伏解脱道。以三种学成就清净。所谓戒清净心清净见清净。于是戒是戒清净。定是心清净。慧是见清净。戒者洗犯戒垢。定洗缠垢。是谓心清净。慧除无知垢。此谓见清净。复次戒除恶业垢。定除缠垢。慧除使垢。如是以三清净是伏解脱道。又以三种善伏道。谓初中后善以戒为初。以定为中。以慧为后。云何戒为初善。有精进人成就不退。以不退故喜。以喜故踊跃。以踊跃故身猗。以身猗故乐。以乐故心定。此谓初善。定为中善者。以定如实知见。此谓中善。慧为后善者。已如实知见厌患。以厌患故离欲。以离欲故解脱。以解脱故成自知。如是成就三善道。已伏解脱道。得三种乐。谓无过乐寂灭乐正觉乐。彼以戒得无过乐。以定得寂灭乐。以慧得正觉乐。如是成就得三种乐。是伏解脱道。远离二边得中道具足。以此戒善除诸欲着。于无过乐情生欣乐。以定除身羸。于寂灭乐而增喜乐。以慧分别四谛中道具足。于正觉乐深怀爱乐。如是远离二边得中道具足。是伏解脱道。以戒除恶趣。以定除欲界。以慧除一切有。于戒多修于定慧少修。成须陀洹斯陀含。于戒定多修于慧少修。成阿那含。修三种满。成阿罗汉无上解脱

    分别戒品第二

问云何戒。何相。何味。何起。何足处。何功德。何戒义戒行。何差别。几戒。何所起。何戒初中后。几法障碍戒道。几戒因。几种戒。云何令戒清净。几因以是戒住。答云何戒者。谓思戒威仪戒不越戒。何者为思戒。我不作恶作者自受。何者威仪戒。离于犯处。云何不越戒。若有戒人身口无过。复次断义威仪。一切善法是戒。如阿毗昙说。以出离法断于欲欲。是戒能离恶。思戒护戒威仪戒。以不嗔恚断灭嗔恚。以光明相断于睡眠。以不散乱断于调戏。以见法起断于疑悔。以智断无明。以喜断无可乐。以初禅断五盖。以二禅断觉观。以三禅断喜。以四禅断乐。以空入定断于色想乃至嗔恚及种种想。以识入定断虚空。以无所有定断识入想。以非想非非想定断无所有。以无常见断于常想。以苦见断乐想。以无我见断我想。以不净见断净想。以过患见断于爱想。以无染见断于欲想。以灭见断集。以消见断厚。以分见断聚。以生灭见断常。以无相见断相。以无作见断作。以空见断入。以增上慧见断执着。以如实知见断无明执。以过患见而断居执。以彼观见断不彼观。以转散见断和合执。以须陀洹道断见一处烦恼。以斯陀含道断粗烦恼。以阿那含道断细烦恼。以阿罗汉道断一切烦恼。此谓不越戒思戒护戒威仪戒。此谓戒。何戒相者。威仪除非威仪。问云何名非威仪。答谓破法。破法有三种。一破波罗提木叉法。二破缘法。三破根法。云何破波罗提木叉法。谓无惭无愧。于如来离信云何破缘法。答命与形饰相应离于知足。云何破根法。不闭六根门离于念慧。以此三覆非威仪。是名戒相。何味者起者足处者。无过乐是味。无忧是起。三善行是足处。复次悦胜为味。不悔为起。覆诸根为足处。何戒功德者。不悔是戒功德。如世尊告阿难。不悔戒善是功德义。复次名戒者是无过乐是众姓上。是财为富贵。是处为佛地。是浴无水。是香普薰。是影随形。是伞覆可覆。是圣种是学无上。是善趣道。若人有戒。为有戒故。成就无畏荣显亲友圣所怜愍。是亲友依。是善庄严。是领诸行。是功德处。是供养处。是可贵同学处。于诸善法不畏不退成一切意愿清净。虽死不忘。成伏解脱乐方便。如是无边戒功德。戒者何义。答冷义。增上义。行义。自性义。苦乐性相应义。复次头义冷义安义。云何头为戒义。答如人无头。一切诸根不复取尘。是时名死。如是比丘以戒为头。若头断已失诸善法。于此佛法谓之为死。是戒为头义。何者冷为戒义。如摩胜冷栴檀。则除身热成就欢喜。如是戒为胜冷栴檀。能灭犯戒恐畏心热。成就欢喜。是冷为戒义。何者安为戒义。答若人有戒。风仪整肃不生恐畏。是安为戒义。行何差别者。修行精进受持头陀。是行非戒戒亦名行。戒名威仪受亦名行。几戒者。谓三种戒。善戒不善戒无记戒。云何善戒。谓善身口业及正命。无过患故果报可爱。云何不善戒。谓恶身口业及邪命。有过患故果报不可爱。云何无记戒。无漏身口业及清净命。无有过患亦无果报。云何起戒者。善心所起善戒。不善心所起不善戒。无记心所起无记戒。何戒初中后者。受戒是初。不越是中。欢喜是后戒。有几法障碍几戒因。答三十四法是障碍道。三十四法是戒因。所谓忿恼覆热悭嫉幻谄恨竞慢增上慢傲慢放逸懒惰贪欲不知足不从智不正念恶口恶友恶智恶见不忍不信无惭无愧营身口味狎俗亲近女人不敬师学不摄诸根于食不节初夜后夜堕不禅诵。此三十四法是障碍道。若二障碍戒不成满。若不成满必还退失。若反是法三十四种。是名戒因。戒有几种者。谓有二种三种四种。云何二种。谓性戒制戒。以身口所行佛断不行。是名性戒。身口可行佛断不行。是名制戒。性戒以信精进能令具足。制戒以信念持能令具足。复次戒有二种。退戒得戒。云何名退。能灭非戒。云何名得。得众善法。除诸非戒如断光影。以断非戒离于恶趣。以得正戒能趣善道。以断非戒成就住分。复次戒有二种。世戒出世戒。云何出世戒。如圣道果之所得戒。是出世戒。所余世戒。以世戒成就故有具足。以出世戒成就故有解脱。复次戒有二种有量无量。不具足戒。是名有量。若具足戒以佛所断。是名无量。复次戒有二种。有边无边。云何有边若人为世利为胜。为亲友为身为命。为越所依而行受戒。彼戒利养为边。称誉为边。身有为边命有为边。云何无边。此比丘为出利为胜为身为命。如法受戒不起犯心。何况故犯。此谓无边戒。复次戒有二种。有依无依。云何有依。有相应戒依爱。戒盗相应戒依见。自誉毁他相应戒依慢。此有依戒。若成就解脱资用。是无依戒。若有依戒非慧人所乐。若无依戒是慧人所乐。复次戒有二种。梵行之初学微细戒。云何梵行之初。正业正语正命所摄戒。此谓梵行之初。有余学戒此谓轻戒。复次戒有二种。有心相应无心相应。云何有心。谓初学梵行。云何无心。谓余轻戒。声闻于梵行之初坚戒上戒。于此轻戒得犯得起。何以故。佛不说此障于解脱。复次有二种戒。谓无犯戒清净戒。云何无犯。谓声闻戒。云何清净戒。佛及缘觉戒。复次戒有二种。谓时分戒及尽形戒。少时暂受不俱形命。谓时分戒。从师始誓乃至舍寿。谓尽形戒。时分戒者。果报有时。尽形戒者。果报无时。何者为三。谓止恶不犯。受不犯。断不犯。云何止恶不犯。虽未受受至。非所行处心不生犯。是谓止恶不犯。云何受不犯。从受受已终不复犯。是谓受不犯。云何断不犯。圣人以圣道断诸恶因。是谓断不犯。复次戒有三种。谓触戒不触戒猗戒。云何为触。有为相初见爱为触。是凡夫善戒。资用入道是谓无触戒。云何猗戒。谓阿罗汉戒。复次有三种。谓依世戒依身戒依法戒。何者依世戒。若人有恐怖。将护世意除诸恶法。是名依世。何者依身戒。若人有恐惧。将护于身命除诸恶法。是名依身。何者依法戒。若人惊畏。将护于正法除诸不善。是名依法。复次戒有三种。谓所愿不等。所愿等。无所愿。云何所愿不等。恼他受戒。此谓所愿不等。云何所愿等。戒受戒为现有乐及未来解脱乐。是谓所愿等。云何无所愿。戒受戒不悔为饶益他。此谓无所愿。复次戒有三种。谓清净戒。不清净戒。有疑戒。云何清净戒。以二因缘戒成清净。一不犯。二犯已能悔。此谓清净戒。以二因缘成不清净。一自故犯。二犯不悔。此谓不清净。云何有疑戒。以三因故成就有疑。一以不分别处。二不分别犯。三不分别不正行。此谓有疑戒。若坐禅人戒不清净。深生惭悔成清净乐。又有疑惑令现知罪得成安乐。复次戒有三种。谓学无学非学非无学。云何为学。七学人戒。云何无学。阿罗汉戒。云何非学非无学。凡夫人戒。复次戒有三种。谓畏戒忧戒痴戒。云何为畏。有人畏罪不敢为恶。斯谓畏戒。云何为忧。若人念离亲友暂生愁苦。以愁苦故不起诸恶。斯谓忧戒。云何痴戒。有人受牛戒狗戒。斯谓痴戒。痴戒若成则为牛狗。若复不成则堕地狱。复次戒有三种。谓下中上。云何为下。谓上烦恼上上烦恼大烦恼所触。不知足所染。此谓下戒。云何为中。细烦恼所触知足所染。此谓中戒。云何为上。无所触知足所染。此谓上戒。下戒成满令人具足。中戒成满令天具足。上戒成满令得解脱。复次戒有四种。谓退分住分胜分达分。云何退分。不除道障碍。离精进人。知而故犯。犯已覆藏。此谓退分。云何住分。于戒成就不起放逸。不生寂见成就住分。于戒定成满不起放逸。不生寂见成就胜分。于戒定成满不起放逸。以生寂见成就达分。复次戒有四种。比丘戒。比丘尼戒。不具足戒。白衣戒。云何比丘戒。波罗提木叉威仪。是比丘戒。比丘尼戒。波罗提木叉威仪。是比丘尼戒。沙弥沙弥尼十戒。式叉摩尼戒。是谓不具足戒。优婆塞优婆姨五戒及八戒。是白衣戒。复次戒有四种。谓性戒行戒法志戒初因戒。云何性戒。郁单越戒。此谓性戒。云何行戒。如姓族国土外道等法。是谓行戒。云何法志戒。菩萨入胎戒。是谓法志戒。云何初因戒。菩萨及摩诃迦叶戒。是谓初因戒

复次戒有四种。戒戒集戒灭戒灭道具足。云何戒。戒者有二种。善戒不善戒。此谓戒。云何戒集。善心集善戒。不善心集不善戒。云何灭戒。得善戒灭不善戒。得阿罗汉灭善戒。云何灭道具足戒。谓四正勤。此谓灭道具足戒。如是分别晓了四法。是谓精进非真持戒。是名正勤。复次戒有四种。波罗提木叉威仪戒。命清净戒。根威仪戒。缘修戒。云何波罗提木叉威仪戒。于此比丘波罗提木叉威仪。所覆住行。行处具足。畏于细罪。正受学可学戒。此者于此师法比丘者。有凡夫善。复次有学无学。不动法波罗提木叉者。是戒是起。是初是行。是护是威仪。是脱是无缚。是诸法面为正受善法。名波罗提木叉义。不越身口业。是威仪所覆者。以此波罗提木叉威仪成就住者。护四威仪。众行具足者。复有行有非行。云何非行。若有比丘。于彼一人。或施杖竹。或施花叶果实。或施杨枝澡浴。或贩弄美恶。或为调戏。或谄谀自进。或恣驱驰远招会宾。如此诸行佛之所制。谓邪命自活此为非行。复次二种非行。身口非行。云何身非行。若有比丘。以陵慢心往至僧中。排触大德叨佷自前。或猗或行先坐上位推大于下。或坐猗排调。或拍肩笑语。上座徒跣。自着革屣。耆德下路。己行高陌。以众异缘故相轻恼。或以胜待少推劣与长。或于浴室烧诸薪木。关闭门户皆无咨问。或诣水边辄自先入。娇身击搏现诸鄙相。若入他舍超越前后。行坐无次。或在屏处戏弄女人及诸僮女。摩触其首。如是等过谓身非行。云何口非行。若有比丘。心无敬畏不咨宿望辄自说法。或说波罗提木叉。或拍肩而语。或入他家顾问女人。何所姓字。有可食物不。有者现我我欲得食。如是等语为口非行。一切犯戒此谓非行。云何为行。反于非行。复次比丘有恭敬惭愧。成就威仪无所乏少。摄护诸根能节饮食。初夜后夜未尝睡眠。成就智慧少欲知足。不狎世务起勇猛心。于同学所深生敬重。此谓为行。行处者。谓有行处。有非行处。云何非行处。若有比丘。入于淫舍寡妇舍处女舍不男舍比丘尼舍及诸酒肆。亲近国王大臣外道沙门非法伴侣。如是等辈无信乐心。常于四众不生饶益。甚可厌患。此谓非行处。如佛所说。比丘行非梵行处。云何行非梵行处。谓贩卖女色行处可知

复次三种行处。依行处。守护行处。系缚行处。云何依行处。谓十处功德成就善友。依此功德未闻得闻。若已闻闻已令其增广。断除疑悔正见清白。能随法学深信勇猛。以戒闻施慧念念增长。此谓依行处。云何守护行处。若有比丘。须入他舍及行村里。看地而前不踰寻仞。威容整肃人所瞻敬。不看象马车乘及男女游会。不看宫第巷陌仰观四望。此谓守护行处。云何系缚行处。如佛所说。若有比丘观其家境界。此谓系缚行处。是名为行。以此行处成就故。曰具足行处。畏于细罪者。我于所学毕故。敢造谓畏细罪。复次有说。若起不善心。是谓微过。于此微过心生避远。见过患畏见出离。此谓于微过见畏。正受学可学者。可学何名。谓七聚威仪正受一切随逐。此谓正受学可学。此谓波罗提木叉威仪戒。问云何名清净戒。答谓不犯邪命。云何邪命。懈怠谄曲示相。以嗔骂示相。以施望施。云何懈怠。懈怠有三处。思计欲得。恶他四事。假肃威仪普自称说。若比丘心怀恶欲贪乐财利。让胜衣食趣求粗弊。如不欲得。有若愍他。如此四事。此谓缘计懈怠。若有比丘。恶欲贪利。诈现威仪我入禅定。要引供施读诵经典。此谓威仪懈怠。若有比丘。贪欲谄诳。向人有言。我得圣法栖止闲寂。有若禅习所说深微。示过人相贪利向己广自宣扬。是谓懈怠。谄曲者。如其心念。虚相推举。善言称赞。贩弄好恶为调要利。排谐相悦引利自向。此谓谄曲。云何示相。依有利者而为说法。要利为己心不能普。此谓示相。嗔骂示相者。或骂他令畏。或空相毁薄。或加打触怖人要利。此谓嗔骂示相。云何以施望施者。好为轻施辄要厚答。此谓以施望施。以是诸恶谓为邪命。复有邪命。或施杖竹。或施花叶果实。或施杨枝澡浴。或占相梦悟。观察星宿。善解禽兽音声等业。推步吉凶。恶言离散。烧花事火。商旅贩卖。将领军众蓄锐兵刃。如是种种此谓邪命。若不犯者名清净戒。问云何守护根威仪戒。答于见闻觉知色声香味触法烦恼相着。及受持不犯。此谓守护根威仪戒。此守护根戒以九行成满。以恶为相断诸根故。彼对治不作意故如救头然终不暂舍故。如见难陀。以威仪故。伏恶心故。于定相心。自在故不。守护根人远离故。于守护根人和合故。问云何修行四事戒。答以此八行已观修行乞食。一者不为凶险行不为自高行。二者不为装束不为庄严。三者为此身住为自调护。四者为除饥渴。五者为摄受梵行。六常自思惟。饮食为除先病不起新疾。七当以少自安。八无过贪住。问云何不凶险行不自高行。答我以贪食勇健。凶险戏暴争竞驰走。是凶险行高慢自举不知厌足。如嗔者打扑。不装束庄严者。为身分充满面貌肥悦。令人爱乐情无厌足。是有欲人为此身住为自调护者。贪身安住如毂须膏。除饥渴者。常资少食。如是修行犹疮涂药。摄受梵行者。依少食力乐得圣道。如是修行犹食子想。为除先病不起新疾者。不少不多。如是修习如服汤药。以少自安者。以少功德自安己身。常应习行如看病人。无过者。以少自安。如是修行不令身无。是智慧所叹。是故无过安住。若食调适未尝懈怠。初中后夜亦不眠睡。成就安隐。如是以此八行。已观修行乞食当如是修。复次此八行略为四观。谓可断观。事观。以少自安观。以少功德观。问云何可断观。答不为凶险行。不为自高。不为先身。不为严首。此谓可断观。为此身住。为正调护。为除饥渴。为摄受梵行。此谓事观。我当除先病不起新疾者。此谓以少自安观。我当以少自安无过成安乐住。此谓少功德观。此四观此四观已略成三。谓断二边得中具足。以断观断欲乐着。谓除饥渴断于本疾不起新疾。又以此观断着身疲。余中具足观应当修行。又观衣服。为除风寒暑蚊虻蚁触。为生惭耻遮覆丑露。于具足观如是修行。又观服药乃至疾病。若如此说当何时观。于乞食服药一餐时观。又于衣服卧具及初得时观。又于日日时时中观我命由他是故当观。如是一切皆成观行。先师所说四种受用。谓盗受用。负债受用。家财受用。主受用。云何盗受用。谓犯戒人受用。云何负债受用。谓无惭无愧邪命人受用。云何家财受用。谓精进人受用。云何为主受用。谓圣人受用。复有二种受用。谓秽污受用。清白受用。云何污秽。有惭愧人而不能观。是名污秽。云何清白。有惭愧人观知自节有厌恶想。此谓清白。以清白故。常当修习四事可知。此谓修行四事戒。于是律仪戒者。以深信应令满。命清净戒者。以深精进应令满。根威仪戒者。以深信应令满。修行四事者。以深慧应令满。于此命清净戒。是随从律仪。何以故。不为寿命。而断诸事安者。所作得身口业威仪。此二种戒是随从根威仪。何以故。谓于善以守护心。善守护身口业。修行四事。是根威仪。何以故。已知集相依处。违厌正念正定如此。世尊所说。若有比丘。能知揣食。及知五欲。具足于此律仪及命清净。是戒阴所摄。根律仪戒。是定阴所摄。修行四事戒。是慧阴所摄。何者令受戒清净。若比丘初受禅法。于七聚中观于自身。若具犯波罗夷。断比丘法住不具足戒。若住具足戒。当得胜法。是先师所说。若见犯僧伽婆尸沙。以众事忏悔。若见犯余罪。于其所犯向一人忏。若见犯邪命。于其所犯作相应忏。如此悔已我不更作。见如是受持犯根威仪。及修行四事。我不更作。若受持者当得未来胜上威仪。彼人如是从清净戒。所有身口业可作现作。当观彼彼作善除恶。当观朝夕住清净戒。若如是者令戒清净。何戒清净相者。成相应及诸烦恼不起退悔。得定成满。谓清净相戒。几行住者。以二戒住。一称量犯戒过患。二称量戒功德。何等称量过患。若人犯戒成非功德。成诸恶处畏于四众。疑难智人有戒弃避。不可教禅。天人鄙秽。众所憎薄。思所犯戒。见人赞叹持戒功德。心悔不信。于四众中每生忿诤。于其亲友多起嫌怨。背有戒人成恶朋党。不复堪得殊胜定法。虽假严饰而故丑陋。犹如屎尿人所憎恶。如模范等鲜有所堪。如瘀泥等于现未来无所饶益。常生忧悴。若已作罪追生惭悔心不安隐。如盗在狱心不乐圣。如旃陀罗无欲王位。其有闻慧乐说功德。人不贵敬。犹如粪火。生不如处死时惛忘。神行恶道。如此等过是可称量。若变此恶成戒功德。亦可称量。如是称量。其犯戒者。心意粗屈。情悉退散。其有戒者。唯深精进。倍生信敬。成精进人。成信敬人。一心护戒如蚁守卵。如牦牛爱尾。如护一子。如护一眼。如巫师护身。如贫人护宝。如海师护舶。此诸护中我所修戒最应敬护。如是受持心被拥卫。安住禅定戒得守护

解脱道论卷第一解脱道论卷第二

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    头陀品第三

问尔时净戒坐禅人。心欲成就胜善功德。又为欲得头陀功德。当如是成就。何故受此头陀功德。答为坐禅人性不一种。为于少欲。为于知足。为于无疑。为于灭爱。为欲增长勇猛精进。为自少营不受外施。为于安住。为断所著守护戒善。是诸定众具。是初圣种。是胜功德观。何者为头陀。有十三法二法衣相应。谓粪扫衣及三衣五法乞食相应。谓乞食次第乞食。一坐食节量食。时后不食。五法坐卧相应。一无事处坐。二树下坐。三露地坐。四冢间坐。五遇得处。坐一勇猛相应有一种。谓常坐不卧。云何粪扫衣。答性能受持是谓为性。余亦如是。云何受粪扫衣。断居士施。云何受三衣。谓断长衣。云何乞食。谓断他请。云何次第乞食。谓断超越乞。云何一坐食。谓不再坐。云何节量食。断于贪恣。云何时后不食。谓断于后望。云何无事处坐。断聚落住。云何树下坐。断屋舍住。云何露地坐。断众覆处。云何冢间坐。断余胜处。云何遇得坐。断贪乐处。云何常坐不卧。谓离寝寐。何故受粪扫衣。见居士衣有求乞等过。复见受持纳衣功德。我见如是断居士施故受纳衣。云何受纳衣功德。以似居士衣受持无阙。得不由他失亦不忧。心无贪染盗贼不取。足用常用少所经营。善人所习是行无疑。胜善相应现法乐住。令人欣慕使得正受。是纳衣功德。佛所称叹。问纳衣有几。何人受持。何因而失。答纳衣有二种。一无主守护。二世人所弃。或于冢间。或于粪扫。或于市肆。或于道路。拾剪浣染掩缉裁缝成就受持。此谓无主。或剪凿之余。牛鼠所啮。或火所烧。或人所掷。施覆尸衣及外道服。此谓世人所弃。云何受粪扫衣。若比丘断居士施。是谓受粪扫衣。云何失。若比丘受居士施。此谓失纳衣。云何受三衣。为有长衣应须净施守护受着。知是等过。见三衣功德。我从今日弃舍长衣故受三衣。云何受三衣功德。善人所行离畜游长。少于营造约身知足。如鸟飞空无所顾恋。善人所习是法无疑。问云何名三衣。云何为受。云何为失。答谓僧伽梨。郁多罗僧。安陀会。此谓三衣。云何受三衣。若比丘不畜盈长。是受三衣。若受四衣。是名为失。云何受乞食。若受他请则妨自业。不为悦人。不与非法比丘接膝共坐。知是过患。复见乞食功德。我从今日断受他请。受乞食法。云何乞食功德。依心所愿进止自由。不希供膳。消除懈怠。断灭憍慢不贪滋味。饶益众生。常于四方心无限碍。善人所行是业无疑。问请有几种。云何为受。云何为失。答请有三种。一似食请。二就请。三过请。除此三种请受乞食。若受三请是失乞食。云何受次第乞食。若于次第处得多美味则不重往。若其重往则受常食。若有疑处亦应远离。知是过患。复见次第功德。我从今日舍非次乞受次第乞。云何次第乞功德。以平等心饶益一切。除憎嫉恶断游狎过。不喜唤召不乐多语。远人宅舍。离于疾行。如月希现人所瞻仰。善人所行是业无疑。问云何名次第乞。云何为受。云何为失。答若比丘始行乞食入于聚落。从最后家以为初次。此谓次第行乞。云何为失。谓超越邻比是名为失。云何受一坐食。谓于二坐处数坐数受食数洗钵。与此相违名一坐食。善人所行是业无疑。知如是过。见一坐食功德。是故应受。我从今日舍二坐食一坐食。云何一坐食功德。不多不少不贪不净施。无诸病恼起居无妨。自事安乐。善人所行是业无疑。问云何受一坐食。云何为边。云何为失。答边有三种。谓坐边水边食边。云何坐边。食已犹坐。受水洗钵不得更食。此谓水边。云何食边。若于揣食生最后想。若吞不更食。此谓食边。若经二坐则失一食。除水药等。诸佛所叹。此谓食边。云何受节量食。若餐饮无度增身睡重。常生贪乐为腹无厌。知是过已。见节量功德。我从今日断不贪恣受节量食。云何节食功德。筹量所食不恣于腹。多食增羸。知而不乐。除贪灭病断诸懈怠。善人所行是业无疑。问云何受节量食。云何为失。答若受饭食应自思惟。所须多少。以为常准。不取长食。善知筹量断无期度。谓节量食。若不如是此则为失。云何受时后不食。断于望想离于长食。知是过患。见时后不食功德。我从今日断于长食。受时后不食。云何时后不食功德。断所贪乐节护其身。离于宿食息所营求。无告于他不随心欲。善人所行是业无疑。问时后几种。云何为受。云何为失。答时后有二种。谓不节边受持边。云何不节边。若受长食得别请罪不当更食。云何受持边。已食二十一揣食。不当更受。时后不食则断于长。若受长食失时后不食。云何受无事处。国中喧杂识触五尘心生染乐。若住闹处去来纷动。知是过患。复见无事处功德。我从今日断国中住受无事处。云何无事处功德。离于国中喧杂识触五尘心生染乐。若住闹处去来纷动。见十种语功德最胜可爱。天人欢喜。不乐狎俗乐得寂。寂乐少声从心禅坐善人所行是业无疑。问云何最后无事处。云何为受。云何为失。答离于国城。栖处郊外。避于边远。取中人四肘五百弓内。是最后无事处。除国中住。此谓无事处。若住国中则失无事处。云何受树下坐。舍于覆处不积畜。修治贪受求索。知是为过。见树下功德。我从今日断于覆处受树下住。云何树下功德。依乐可爱不交世俗乐离作务与天同止。断住处嫉及离爱着。善人所行是业无疑。问何树可住。何树可离。云何而受。云何能失。答于日中时树影至处。及无风时叶所堕处。是所可住。除危朽树空腐树鬼神树。离诸覆处是受树下。若往覆处则失树下。云何受露地住。不乐覆处及在树下藏畜物处。知是过患。见露住功德。我从今日断不乐处受露地住。云何露住功德。莫往不乐处。断懈怠睡眠。犹如野鹿随意而行无所追慕。善人所行是业无疑。云何为受。云何为失。断于覆处及在树下。是受露住。若住覆处及在树下。则失露住。云何受冢间住。若于余处少行放逸。不起畏恶。知是过患。见冢间功德。我从今日断于余处受冢间住。云何受冢间功德。得死时念。得不净相。得非人敬重。不起放逸。伏于欲染。多所厌患。不惧可畏。观身空寂。断计常想。善人所行是业无疑。问云何受冢间功德。于何可住。于何可行。何受何失。答若恒有人常多哭泣。恒有烟火。若初欲住如是冢间。当先观察。有余静处。便可往住。若比丘止于冢间。不当作房及安床座。不从风坐不逆风住。卧时不熟。无食鱼味。不饮乳酪不食麻粹。不触肴肉。不住屋中。不安钵器。若人已去捉持坐具及余衣物。往到冢间。当其住处如掷物远。明相现时摄诸衣具还僧伽蓝。除余处住。是谓冢间。若住余处则名为失。云何受。遇得处住。不乐人所贪。不恼他令避。知是过患。见遇得处功德。我从今日断贪住处受遇得处。云何遇得处功德。觅知足处。贪于寂静。断多爱乐。人所敬重。住于慈悲一向敛摄。善人所行是业无疑。云何为受。云何为失。断贪所止。是谓依遇。若往乐处则名为失。云何受常坐不卧。于所住处睡眠懈怠。知是过患。见常坐功德。我从今日断于惛卧。受常坐不卧。云何常坐功德。断生怠处。除为身嫉离染触乐少于缠睡。常多寂静堪修禅胜。善人所行是业无疑。云何为受。云何为失。谓断睡卧。若寝名失。云何离粪扫衣。于居士施衣刍麻古贝憍奢耶钦婆罗等。以方便受不失纳衣。云何三衣。若畜长衣已过十日。有月望衣。有功德衣。又有长衣。为护卧具敷具覆疮衣手巾雨浴衣不受持不净施。若以方便不失三衣。云何乞食方便。若僧次食及常住食。行筹食十五日食。布萨食众食寺食。以方便受不失乞食。若见此过亦应舍离。云何次第乞食方便。见象马等当门而斗可羞鄙处。诸如是等若见宜避。又见旃陀罗覆钵。学家随和上阇梨客行比丘。诸如是等方便而越。不失次第。云何一坐食方便。若正食时见象马牛蛇雨和上阇梨客比丘来。方便而起。起已更食。不失一坐。若节量食及时后食无方便。云何无事处方便。或为受戒忏罪。问法布萨自恣自病看疾。问经疑处。如是等缘。方便住聚落。不失无事处。云何树下方便。若遇雨时宜入覆处。明相既现还而不失。树下露住冢间。遇得此等方便。亦复如是。余住处可住常坐不卧无方便。复有一说。若灌鼻时得作方便。不失常坐。以此十三头陀。更成八法。如毗昙中说八头陀。是时后不食摄。节量一坐。其所受持成一种类。是无事处摄。树下露坐冢间。何故于无事处。若营造房舍乐为作务。多所聚蓄爱着住处。非心所乐。作如是意。于树下冢间露地净住。是故成八。于八头陀复成三法。一无事处。二粪扫衣。三行乞食。若三清净头陀成满。故佛为难陀说。何时见汝成无事处。受粪扫衣。不时后食。趣养身命。无见所欲。问谁名头陀分。头陀有几种法。云何三行人修头陀行。几头陀有时节。有是头陀说头陀。答有十三头陀。是佛所说。佛所制戒。此谓头陀分。此不应说善不善无记。何以故。不善人与恶欲同故。不除恶欲。共起非法贪乐利养。是故不善头陀。几种法者。谓有二头陀法。不贪不痴。如佛所说。若粪扫衣比丘。依少欲知足乐静无疑。依于解脱。是谓受粪扫衣。诸余头陀。亦复如是。不贪不痴。以此不贪于此十三处能除贪欲。以此不痴于十三处能除无明。复次以此不贪佛之所许。能生厌患。相似无疑除欲染欺诳以此不痴。相似除身羸欺诳。此二头陀法。是不贪不痴。云何三行人修头陀行。谓贪痴行人是修头陀行。嗔恚行人不能修行。何以故。贪痴行人。而能修行头陀。如贪人至爱成不放逸。若不放逸则能伏贪。如痴无疑。依头陀受成不放逸。若不放逸则能伏痴。何故贪痴人修行头陀。嗔人受苦更成其恶。如痰病者。若服热汤转增其疾。是故嗔人不当修行。复说嗔人应住无事处及在树下。何故住无事处。以无世间苦故。几头陀有时节。三头陀八月时。谓树下住露地住冢间住。是安居时。佛听覆处。问云何是头陀说头陀。答亦有头陀说头陀。有头陀不说头陀。有非头陀说有头陀。有非头陀不说头陀。云何有头陀说头陀。谓阿罗汉成就头陀受。云何有头陀不说头陀。谓阿罗汉不成就头陀受。云何有非头陀说头陀。谓学人及凡夫成就头陀受。云何非头陀不说头陀。谓学人凡夫不成就头陀受。问头陀何相何味何起。答少欲为相。知足为味。无疑为起。复次无所著为相。无过为味。不退为起。云何初中后。谓受为初。修行为中。欢喜为后

    分别定品第四

问尔时净戒坐禅人。已行头陀受成就胜善处。当何所作。答令定起。问何定何相何味何起何处。何人受禅解脱定。正受何差别。几定因可见。以此起定。障定有几法。几定功德。定几众具。几种定。云何起定。答定者有清净心。一向精进与寂静功德等。正真住不乱。此谓定。复次烦恼猛风无倾心虑。如殿里灯光焰不动。如阿毗昙说。若心正住无所攀缘。亦不动乱。寂静无著。正定定根定力。此谓为定。云何相何味何起何处。心住是相伏怨是味。寂静是起。于染不着心得解脱。是名为处。何人受定。谓受心数等方便定等。如手执称。令心心数等。如钵中油。念与精进等行为定。犹如四马齐力牵车。思惟等为定。如彼箭师注心调直。以除怨故。如药消毒。如毗昙说。敛摄是定义。从是定义满是定义。禅者四禅。谓初禅等。解脱者。谓八解脱。内有色想外观色等。定者三定。谓有觉有观等。正受者。谓九次第正受。云何为禅。思惟事故。思惟怨故。心喜乐故。离障解脱故。令平等故。方便发定故。得自在故。不以一义住正受故。乐起定故。解脱正受者。几功德令定得。起见四功德令定得起。云何为四。现见法乐乐住。以观乐事。神通现证有具足。何者现见法乐乐住。谓人得定。能生无漏。心起悦味。受出世乐。现见法乐乐住。是故世尊说。彼此身从静生喜。使得清凉。令渐圆满具足成就等。如佛告比丘。我先作尼干。七日七夜身不动摇。口不言说默然端住。一向受乐。是谓于圣法现见法乐乐住。以观乐事者。谓坐禅人得心定事。无有盖缠。调柔堪受持。观见阴入界等。自性安乐。是故世尊教诸比丘。应当修行。如是一切以心依如实知。神通现证者。已得定人依证五通。谓如意天耳他心宿命天眼。是故世尊说。已得心定随宜转变。如是一切令得如意。有具足者。已得定人未到无学。终令不退。由定得报。得色无色有具足。如佛所说。少修初禅得梵天眷属。如是种类一切生彼。如是一切此四功德。能生彼定。一一当起。障定有几者。谓八法。欲欲嗔恚。懈怠睡眠。调戏疑惑。无明无喜乐。一切恶法是障法。几定因者。谓有八法。是因出离不嗔。明相不乱。一切善法令心欢喜。能生法智。是为定因。几定资者。谓有七种戒。众具知足。覆蔽根门。节量饮食。初中后夜而不睡眠。常念智慧。住处静寂。定有几种者。定有二种。一世间定。二出世间定。圣果所得。谓出世定。余名世定。其世间定。是有漏有结有缚。是流是厄是盖是戒盗见盗。是取是烦恼。此谓世间定。与此相违名出世定。复次定有二种。邪定正定。云何邪定。不善一心。是谓邪定。若善一心。是谓正定。邪定当断。正定应修。复次定有二种。外定安定。彼彼定初分此谓外定。性除无间此谓安定。复次定有三种。有觉有观定。无觉少观定。无觉无观定。云何有觉有观。谓初禅有觉有观。二禅无觉少观。余禅无觉无观。复次定有三种。谓共喜生定。共乐生定。共舍生定。初禅二禅谓共喜生。三禅谓共乐生。四禅谓共舍生。复次定有三种。善定报定事定。云何善定。圣道学人及凡夫。修色无色定。是谓善定。圣果学人凡夫生。色无色界。是谓报定。无学人受色无色定。是谓事定。复次定有四种。欲定色定无色定无所受定。谓彼彼行正受行。是谓欲定。四禅是谓色定。四无色定及善业报。此谓无色定。四道果谓无所受定。又定有四种修行。谓苦修行钝智。苦修行利智。乐修行利智。乐修行钝智。此四人一者密烦恼。二者疏烦恼。三者利根。四者钝根。于密烦恼人。钝根苦修行。钝智得定。密烦恼利根苦修行。利智得定。疏烦恼人钝根乐修行。钝智得定。疏烦恼利根乐修行。利智得定。于是密烦恼人。已密烦恼故。苦折伏烦恼。是故苦修行钝根人。以钝根故。久积禅行觉钝智。是故名钝智。以此方便。一切应分别。复次定有四种。谓小定小事。小定无量事。无量定小事。无量定无量事。云何小定小事。定不随心所得。定小精进。此谓小定小事。云何小定无量事。定不随心所得。彼事大精进。此谓小定无量事。云何无量定小事。定随心所得。彼事小精进。此谓无量定小事。云何无量定无量事。定已随心所得。彼事大精进。此谓无量定无量事。复次定有四种。欲定精进定心定慧定。欲定者。依欲修得。谓为欲定。依精进得。谓精进定。依心修得。谓为心定。依慧修得。谓为慧定。复次定有四种。有定是佛所得。非声闻所得。有定声闻所得。非佛所得。有定是佛所得及声闻所得。有定非佛所得非声闻所得。大悲定双变定。是佛所得。非声闻所得。学果定是声闻所得。非佛所得。九次第定无学果定。佛所得及声闻得。无想定非佛所得非声闻得。复次定有四种。有定为起不为灭。有定为灭不为起。有定为起为灭。有定不为起亦不为灭。问云何为起不为灭。答欲界善不善定。此谓为起不为灭。四圣道定。是为灭不为起。学及凡夫色无色善定。为起亦为灭。一切果定及事定。非为起非为灭。复次定有四种。初禅二禅三禅四禅。离于五盖成就觉观。喜乐一心。此谓初禅。离于觉观成就三枝。离喜成就二枝。离乐舍一心成就第四禅。复次定有五种。谓初禅二禅三禅四禅五禅。五禅者为五枝。觉观喜乐一心离五盖成就五枝。是谓初禅。离觉成就四枝。是谓二禅。离喜成就二枝。是谓三禅。离乐成就二分。谓第四禅。所谓舍一心。问何故说四禅及五禅。答由二人报故。第二禅二种。谓无觉无观无觉少观。问是谁坐禅人。令初禅自在起第二禅。答于粗觉观摄念思惟。复知觉过患令起无觉观第二禅。是其修四禅次第。复有一人已令初禅自在现起第二禅。于粗觉摄念思惟。唯知觉过患见无觉少观起第二禅。是其受五禅次第。是故说于五禅。复五种定。谓五分正受。喜满乐满心满光满观想。于是初禅二禅喜满。于是三禅乐满。于他心智是名心满。于天眼通是名光满。从彼彼定起观智是名观想。复次定有五种。谓五智正定。此现在乐亦未来乐报。依身智起此定。是圣所行无烦恼。此定慧人修习此定。寂寂快乐。猗所得成就无二。不伏生死。此定寂寂最乐。猗成一性所得。非伏生死我。此定念入念起依身智起。复次已分别行处已。分别修行事及下中上。以如是定有多种。可知一切诸定皆入四定

    觅善知识品第五

问尔时何以起定。答若初坐禅人欲生禅定。当觅胜善知识。何以故。初坐禅欲生禅定得最胜定。若离善知识。成不住分。如经中说。有云比丘成于退分。如人独游远国。无侣开示随意自行。如象无钩。若坐禅人所修之行。得善知识说法教诫。令其摄受。示除过患使得善法。从教修行精勤苦行得最胜定。如富商主众所敬贵。如亲善人。如亲父母。善知识者。如象所系令不动故。如御车人使随去住故。如人执拖为得善道。如医治病为消苦楚。犹如天雨润益诸种。如母养儿。如父教子。如亲无难。如友饶益。如师教诫。一切善法依是成满。是故世尊教于难陀。一切梵行所谓善知识。是故当觅胜善之人为善朋友。云何是胜善知识。谓有所成就明了修多罗毗昙毗尼。是谓所得成就。明了业种。得善神通。得见四谛。此二种人功德成就。是所当觅。若不得二种功德成就人。以七分成就善知识。是亦当觅。云何七分。可敬爱可重可贵。能说忍辱说深语不安非处。云何可敬爱。依二种行者善说共住乐心解不难。是谓可敬爱。可重者。戒行寂静守念成就。不贪欲多语。是谓可重。可贵者。闻慧功德成就知坐禅可重。是为可贵。能说者。我言可爱可重可贵。有果如是思惟饶益彼故。尊重法故。于非可作制伏摄受终不弃舍。是谓能说。忍辱者。能令无滞绮语总语相。如贤圣故。是谓忍辱。深语者。通达业处。若分别。想念作意安着皆。由执相善说如法。不如法烦恼取相。能令灭尽。是说深语。不安非处者。若于姓族住处业聚诵着非住可避。若于堪事处行令得安隐。是住可住。此谓不安非处。以此七分成就。是善知识可觅。问云何应觅。答若知某甲住处是功德成就可重。若有禅师应当往彼。若自不知余处同学知。应往亲觐。已知时节如法未说其意。恭敬劳问起居。咨访所行。何处国土何处住止。有众安住。有僧静坐。有是禅师。其行若为以何功德一切所贵。应作如是问。同学应答。某国某住某众禅坐某禅师。众所爱重。得闻是已深思随喜。当往彼处亲觐受行。应整衣服到和上所自说意乐。和上听我。我当往彼亲觐禅师。和上应听答善哉。我亦随喜。是善人所作。此谓善人共住善人所行。是随法修行。若见闻者得大利益。何况共住。汝当往彼。汝已往彼慎莫放逸。若是善人可勤修学。若于一时及一切时等。加信

敬诚当善语守护身口晓解修行。当得成就。一切依师莫生轻易。如初嫁小女性事舅姑。应生惭愧听受教诫。若见弟子无衣服汤药。若往彼时如法料理。说法教诫。及至将送行坐教以善法。彼坐禅人齐整衣服。恭敬围绕礼师足下。于行所半路园外诸有水地。往彼一处衣钵革屣澡罐禅具。高置一处不使近水。当浴不声。若浴竟已。齐整衣服。着郁多罗僧。衣钵禅具置右肩上。卷僧伽梨若置肩上。若入寺舍低盖绕塔。若见比丘当往咨问。此处有坐禅人。不有粪扫衣人。不有乞食人。不有律师。不有者于何处住。从何可至。有者当往。若无此人。有律师者。我亦当往。又无律师。谁为上座。我亦当往。若上座大僧为取衣钵勿与。若余小者应与。若无人取下置一处。若见上座应当礼足于一面住。旧住比丘以坐。以水及澡洗处如法供给。延其消息安其衣钵。示其便处。访问僧制。日将入时周行寺内。若见律师共语咨问所疑之罪及不犯罪。若见阿毗昙师为应修慧。当问阴入界业。若见头陀人。为相应慧当问头陀功德。若住于彼日日应往处处咨问。若欲行当屏牒卧具。礼大僧足白云行去。此是比丘为客法用。于彼坐禅人应住亲近。禅师若至虽小亦代取衣钵。禅师之法可行不可行。不应即行令去。是先所作应当修行。若欲教人先取觉。学坐禅人先已行法。看视住处安置衣钵。少时消息知识时节亲觐禅师恭敬礼拜。少时静默当坐。若禅师问所欲。当随说所乐。若不问者则不应说。从此已后杨枝澡洗等。当请依止修所行业。若乞时至。往问阇梨如法当作。食时若至。为阇梨洗足及安坐处授钵。于其自钵食。应问阇梨所取多少。安置自钵减与弟子。如是摄受如是不难。尔时食已。取阇梨钵洗讫。安处知时亲觐恭敬礼拜。少时静默当坐。若阇梨问随说所乐。若不问礼拜阇梨请听。我说本来所欲。若蒙听许。随意问。阇梨若听一切当说。若不问礼阿阇梨。觅时节当说我来因缘。愿阇梨听我所说。若阿阇梨听。一切其所乐当说。阇梨言善哉。如法教诫。应当摄受。是故世尊说偈

  以时而亲近　　令心无憍慢
  梵行能护法　　譬如树无风
  念法而修行　　及法戏自乐
  法住法分别　　当说如实法
  毁法不当行　　绮语忧戏笑
  嗔恚勿懈怠　　忿恨贪慢痴
  爱染佷戾等　　修行悉伏除
  守义不自高　　知善诚实语
  为定实知闻　　若人辄放逸
  闻慧不增长　　若人知正法
  天人所恭敬　　恭敬成信心
  多闻能护法　　令得所乐闻
  如是诸功德　　随法能修行
  能生胜妙解　　成就智慧人
  若有如是师　　当修不放逸

解脱道论卷第二解脱道论卷第三

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    分别行品第六

尔时依止阿阇梨。以数日观其行。其行相应行处应当教。于是行者十四行。欲行嗔恚行痴行信行意行觉行欲嗔恚行欲痴行嗔痴行等分行信意行信觉行意觉行等分行。复次爱见慢等种种行可知。于是贪欲意使行性乐着。无异于是义。由行故成十四人。欲行人嗔行人痴行人信行人意行人觉行人欲嗔行人欲痴行人嗔痴行人等分行人信意行人信觉行人意觉行人等分行人。于是欲欲欲使欲性欲乐。此谓欲行人。其欲常行增上欲。是谓欲行。如是一切当分别。尔时此十四人略成七人。如是欲行人信行人成一。嗔行人意行人成一。痴行人觉行人成一。欲嗔行人信意行人成一。欲痴行人信觉行人成一。嗔痴行人意觉行人成一。二等分行人成一。问何故欲行人信行人成一。答欲行人于善朋增长信行欲。亲觐功德故。复次以三行欲及信。此句成一相。有爱念义。觅功德义。非舍义。于是欲者念欲。信者念善。欲者觅欲功德。信者觅善功德。欲者不舍非可爱为相。信者不舍可爱为相。是故欲行及信行成一相。问何故嗔恚行及意行成一。答嗔行人于善朋增长智行嗔。亲觐功德故。复次以三行嗔恚及智成一相。非爱念故觅嗔故舍故。于是嗔人非安爱念。智者非安行念。嗔恚人觅嗔。智者觅行过患。嗔人安舍。智者安舍行。是故嗔行人及意行成一相。等故。问何故痴行人及觉行人成一。答痴行人为得善。增长觉行痴。亲觐功德故。信慧动离故。复次以二行痴觉成一相。不自定故动故。于是痴安乱故不安。觉种种觉忆故成不安。痴无所趣向成动。觉轻安故成动。是故痴行及觉行成一相。等故。以此方便余行当分别。如是此成七人。于此七人云何速修行。云何迟修行。欲行人速修行。以安可教化。信力故。痴觉薄故。嗔行人速修行。安可教化。有意力故。痴觉薄故。痴行人迟修行。难可教化。有痴觉力故。信意薄故。欲嗔行人速修行。安可教化。有信意力故。痴觉薄故。欲痴行人迟修行。难可教化。不安信故。痴觉力故。嗔痴行人迟修行。难可教化。不安意故。痴觉力故。等分行人迟修行。难可教化。不安住意故。有痴觉力故。尔时此七人。由本烦恼成三。欲行人嗔恚行人痴行人。问此三行何因缘。云何可知此欲行人此嗔行人此痴行人。云何行受衣乞食坐卧行处威仪。答初所造因缘。诸行界为因缘。过患为因缘。云何诸行初所造因缘。于初可爱方便故。多善业成欲行人。复从天堂落生于此。多起杀割桁械怨业。成嗔行人。不爱业所覆。从地狱从龙生堕落生此。初多饮酒离间。成痴行人。从畜生堕落生此。如是行初造因缘。云何界为因缘。二界最近故。成痴行人。所谓地界水界。二界最近故。成嗔行人。所谓火界风界。四界等故。成欲行人。如是诸行界为因缘。云何过患为因缘。最多淡成欲行人。最多瞻成嗔行人。最多风成痴行人。复有说。最多淡成痴行人。最多风成欲行人。如是过患为因缘。云何可知此人欲行此人嗔行此人痴行。答以七行可知。如是以事以烦恼以行以受取以食以业以卧。云何以事可知。欲行人见所有事。未常见而见既见。恒观于真实过患不作意。于小功德成不难。不从此欲解脱。既观不能舍行。知于余事。诸如是行欲行可知嗔行人者。见所有如是事。如倦不能久看。随取过患多毁人。于多功德非不难。从此不舍。唯以过患得已便。知行余事亦如是。行嗔行可知。痴行人见所有如是事。于功德过患成信他。闻他人所薄亦薄。闻他所赞叹亦赞叹。自不知故。以如是行于外事。痴行可知。如是以事。问云何以烦恼可知。答欲行人五烦恼。多行嫉悭幻谄欲。此谓五。嗔恚行人五烦恼。多行忿恨覆悭嗔。此谓五。痴行人五烦恼。多行懒懈怠疑悔无明是五。如是以烦恼可知。问云何以行。答欲行人见行以性。举脚疾行平。举脚平下脚不广。举脚可爱行。如是以行欲行可知。嗔恚行人见行以性。急起脚急下。相触以半脚入地。如是已行嗔恚人可知。痴行人见行以性。起脚摩地亦摩下。以脚触脚行。以如是行痴行人可知。如是以行。问云何以着衣欲行人。答欲行人若捉衣以性。不多见不宽着衣太下。周正圆种种可爱可见。嗔行人着衣以性。大急太上。不周正不圆。不种种可爱。不可观。痴行人若着衣以性。多宽不周正不圆。非种种可爱可观。如是以着衣可知。问云何以食可知。答欲行人乐肥甜。嗔恚行人乐酢。痴行人不定乐。复次欲行人。食时自量相应中适取揣食。亦知气味不速食。若得少味成大欢喜。嗔行人见食。多取揣食满口食。若得少味太嗔恼。痴行人见食。不圆小揣食不中适。少取以食涂染其口。半揣入口。半堕盘器。乱心不思惟食。如是以欲可知。问云何以事知。欲行人扫地。平身捉扫帚不駃。不知土沙。而能清净。嗔行人若扫地。急捉扫帚两边駃除去土沙。急声虽净洁而不平等。愚痴行人若扫地。宽捉扫帚辗转看尽处处不净。亦不平等。如是浣染缝等。一切事平等作不与心。是欲人嗔行人。于一切事不平等作不与心。痴行人乱心多作不成。如是以事可知。问云何以卧坐。欲行人眠不駃。眠先拼挡卧处令周正平等。安隐置身屈臂眠。夜中有唤即起。如有所疑即答。嗔行人若眠駃。随得所安置。身面目频蹙。于夜若有人唤即起嗔答。痴人若眠卧处不周正。放手脚覆身而卧。夜中若有人唤。应声噫噫久时方答。如是以卧可知。问何行何法。用受衣乞食坐卧行处。若欲行人衣粗不下色可憎。是与其衣当着。嗔行人衣精细。衣净洁好色下可爱。是应当着。痴行人衣随所得当着。欲行人乞食粗不净洁。无美气味少乞食。嗔行人乞食肥美净洁。好气味如意所得痴。行人乞食随所得有节。欲行人卧坐于树影水间。于小远村处。复于未成寺。于无卧具处。是其当眠坐。嗔行人坐卧树影水边成就平正。于寺已成卧具。具足成其坐卧处。痴行人依。师亲觐当住。欲行人行处。粗饭饮食处。若入聚落应向日而行。于恶人处。是其当行。嗔恚行人处。于饭水饮食具足。逐日而入多信向人处。是其当入。痴行人随所得处。欲行人威仪多行脚处。嗔行人依坐卧。痴行人依行处。于是散向。欲者依可爱境界为信。嗔恚者不可爱境界为信。痴者不观为因。欲者如奴。嗔恚者如主。痴者如毒。贪者少过患断无染。嗔恚大过患使无染。痴者大过患断无染。欲行人乐色。嗔行人乐诤。痴行人乐懈怠

    分别行处品第七

尔时依止师观其所行。授三十八行。当复教示令二行相应。问云何三十八行处。答谓十一切入地水火风青黄赤白空处识处一切入。又十不净想。膖胀想。青淤想。烂想。弃掷想。鸟兽食啖想。身肉分张想。斩斫离散想。赤血涂染想。虫臭想。骨想。又十念。念佛念法念僧念戒念施念天念死念身念数息念寂寂。又四无量心。慈悲喜舍。观四大食不净想。无所有处非非想处。斯谓三十八行处。此三十八行处。以九行当知最胜。一以禅。二以正越。三以增长。四以缘。五以事。六以胜。七以地。八以取。九以人。问云何为禅。答谓十行处成禅外行。又十一行处成就初禅。又三行处成就三禅。又一行处成就四禅。又九行处成就四禅五禅。又四行处成就无色四禅。问云何十行处成禅外行。答除数息及观身。余八念及观四大食不净想。是谓十外行。问云何十一行处初禅所摄。答十不净想及观身。是谓初禅所摄。问云何三行处。三禅所摄。答谓慈悲喜。问云何一行处四禅所摄

答谓舍。问云何九行处四禅五禅所摄。答除空一切入识一切入。余残八一切入。及数息念。问云何四行处四无色所摄。答虚空一切入。识一切入。无所有处。非非想处。是名四行。如是以禅可知。问云何以正越。答入行处成为越色。除无色一切入。余八一切入。余三十行处。不成为越色。又三行处成为越事。二无色一切入。及无所有处。余三十五行处。不成为越事。又一行处成为越想受。所谓非非想处。余三十七行。不成为越想受。如是以越可知。问云何以增长。答十四行处可令增长。所谓十一切入。及四无量心。余二十四行处。不应令增长。如是以增长可知。问云何为缘。答九行处为神通缘。除无色一切入。八一切入。及分别虚空一切入。余三十行不成神通缘。三十七行处成为毗婆舍那缘。除非非想处。又一行处不成毗婆舍那缘。所谓非非想处。如是以缘可知。问云何为事。答二十一行处是分别事。十二行处是为实事。五行处不应说分别事实事。问云何二十一行处是分别事。答除识一切入。余九一切入十不净想及念数息念身。问云何十二实事。答识一切入非非想处。及十禅外行。问云何五不应说分别事及实事。答谓四无量心。及无所有处。复次二行处。内营事内事。又二行处。内营事外事。又一行处。外营事内事。又二十一行处。外营事外事。又四行处。内营事内事设外事。又四行处。设内营事设外营事外事。又二行处。设内营事设外营事。设内事设外事。又一行处。内外营事内事。又一行处内营事不应说及内事外事。于是二行处内营事内事者。谓识一切入及非非想处。又二行处内营事外事者。所谓念数息念身。又一行处外营事内事者。所谓念死。又二十一行处外营事外事者。谓十不净想。四无量心。四色一切入。虚空一切入。及念佛念僧。又四行处内营事内事设外事者。谓念戒念施观于四大。及不净食想。又四行处设内营事设外营事说外事。谓四色一切入。又二行处设内营事设外营事设内事设外事。谓念法念寂寂。又一行处内外营事内事。谓为念天。又一行处内营事内事外事不应说。谓无所有处。又二行处过去事。谓识一切入。及非非想处。又一行处于未来事。所谓念死。又一行处于现在事。所谓念天。又六行处设过去事。设未来事。设现在事。谓念佛念僧念戒念施。及观四大不净食想。又二行处。设过去事。设现在事。设不应说。过去未来者。所谓念法念寂寂。又二十六行处。不应设三世事。谓九一切入。十不净想。四无量心。及念数息念身。无所有处。又四行处动事。谓火一切入。风一切入。及虫烂想。及念数息。其处则动。其相不动。余三十四不动事。如是以事可知。问云何为胜。答八一切入四无色定。是名胜真实事故。以八一切入是名定胜故。彼第四禅得胜地故。四无色定成胜。十不净想及食不净想。是名想胜。以色以形以空以方。以分别以和合。以执着故。以不净想事故。以十念处。是名胜念。微细故。随念故。四无量心以无过为胜。受饶益故观四大。是名慧胜。以执着空故如是以胜可知。问云何以地。答十二行处。不生于天上。谓十不净及念身食不净想。又十三行处不生于色有。初十二及数息念不生色有。除四无色处。余行处不生于无色有。如是以地可知。问云何以取。答谓十七行处。以见应取相。除风一切入及无色一切入。余七一切入十不净想。又一行处。以触应取相。谓念数息。又一行处。或以见或以触应取。谓风一切入。余十九行处。以闻分别应取。又五行处。初坐禅人不应修行。四无色及舍余二十三。初学禅人应取。如是以取可知。问云何以人。答欲行人四无量不应修行以净相故。何以故。欲行人作意净想非其所行。如痰病人多食肥腴非其所宜。嗔行人十不净想不应修行。嗔恚想故。嗔恚作意非其所行。如瞻病人饮食沸热非其所宜。痴行人未增长智。不应令起修行处。离方便故。若离方便其精进无果。如人骑象无钩。欲行人应修不净想及观身。是其欲对治故。嗔行人应修四无量心。是嗔对治故。或当修色一切入心随逐故。信行人当修六念处。念佛为初信定故。意行人当修观四大。于食不净想。念死念寂寂深处故。复次意行人于一切行处无所妨碍。觉行人当修念数息以断觉故。痴行人以言问法。以时闻法以恭敬法。与师共住令智增长。于三十八行随其所乐。应当修念死。及观四大最胜。复说于分别行处我见彼胜。六人于所分别略而为三。问若然于初有妨。答二欲行人。谓钝根利根。为钝根欲人。修不净观。为其欲对治。是所应教行。修得除欲。利根欲人。初信增长。当修念处。是所应教行。修得除欲。二嗔行人。谓钝根利根。为钝根嗔恚行人。修四无量。是其嗔恚对治。是所应教行。修得除嗔。利根嗔恚行人。以智增长修行胜处。是所教修得除嗔。二痴行人。谓无根钝根。为无根痴行人。不应教修行处。为钝根痴行人。为除觉应教修念数息。如是以略唯成三人。是故无妨。于是法一切入及数息。以空增长。无妨成一切行。若已得胜功德。胜一切行所行之处故成不妨

解脱道论卷第三解脱道论卷第四

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    行门品第八之一

问云何地一切入。何修何相何味何处。何功德。一切入者何义。几种地何地取相。云何作曼陀罗法。何修地法。答是心依地相生。此谓地一切入。心不乱住是名为修。善乐着地想为相。不舍为味。意无异念为处。何功德者。谓有十二功德从地一切入是相易得。于一切时。于一切行。心行无碍。如意神通。履水游空如地。受种种色辩。初念宿命辩。及天耳界辩。随行善趣甘露为边。问一切入何义。答谓周普一切入。如佛说偈言

  若人念佛德　　生喜充遍身
  观地一切入　　周满阎浮提
  此观缘地生　　心喜亦如是

修如是观。见曼陀罗遍一切入。问地几种。何地取相可修。答地有二种。一自相地。二造作地。坚为自相地界。是谓自相地。若手自掘若教人掘。造作所成。是谓作地。成四种色。谓白黑赤及如明色。于是坐禅人。于自相地不应作意。应除白黑赤。何以故。若观自相地。从此不起彼分相。若取白黑赤色。成修色一切入。何以故。观自相地离白黑赤。若作不作当取其相。如明相现当取其相。问云何名不作地。答处处平坦。离于草莽无诸株杌。于其眼境当令起心。是名地想。是谓不作地。若旧坐禅随乐不乐。即见彼分地相。住于不退。新学初禅取作地相作曼陀罗。不观非作地。问云何作曼陀罗。答若坐禅人欲于地作曼陀罗。初从当观寂寂。或于寺舍或在石室。或在树下。不住幽闇无日光处非人行路。于如是处皆远一寻。洒扫清洁当令地燥扫。于处所如明相现时。土色使与地性得相发起。筹量调适威仪恭敬。取于器物以水和土。删去草杌却除粪芥。取其衣帊济漉泥滓。于净洁地障蔽坐处。遮断光明安置禅窟。不近不远以规作圆。圆内平满无有痕迹。然后以泥泥地不杂余色。以别色不杂于地应安。乃至未燥当覆守护。若至燥时以异色界其外。或如米筛大。或如搔牢大。或圆或方或三角四角。应当分别。本师所说。最胜圆作曼陀罗。若于衣若于板若于壁处。皆作曼陀罗。于地最胜。如是先师所说。问云何修地法。答若坐禅人。欲修地一切入。从初当观欲过患。复应观出离功德。问何故应观欲过患。答欲者少气味故多忧苦。于是处多过患。欲者如骨喻少气味。欲者如肉揣喻。以多属故。欲者如逆风把火喻。随烧故。欲者如炎炭喻大小故。欲者如梦喻倏忽无故。欲者如借物喻势不得久故。欲者如树果喻。为人所折故。欲者如刀喻以斩斫故。欲者如槊喻以为槊故。欲者如毒蛇头喻可怖畏故。欲者如风吹绵喻不可守护故。欲者如幻喻惑痴人故。欲者是暗无所见故。欲者是障碍路碍诸善法故。欲者是痴失正念故。欲者如熟以烂故。欲者是械相驻缚故。欲者是盗功德物故。欲者是怨家起斗争故。欲者是苦造诸过患故。如是已观欲过患。应观出离功德。名出离者谓初禅从初出家修诸善。是名出离。问云何出离功德。答无盖心自在住寂寂乐。堪忍苦乐住不忘失。旷济众事得大果地。堪受供养。二处饶益。是大智慧。是一切善处。名超三界。复次名出离者。彼出离淫欲。是寂寂诸盖是乐无垢。是处最胜地。是道为得最胜。是清净心垢。此是功德修行所造。是乐内所修行。欲是粗。出是胜妙。欲者有烦恼。出离者是无烦恼。欲者是下。出离者是上。欲者有嗔恚。出离者无嗔恚。欲者非可爱果。出离者是可爱果。欲者有怖畏。出离者无怖畏。如是已观淫欲过患。及观出离功德。依出离生欲乐。心生信生恭敬。观可作非可作。依节量食安置衣钵。身不懈惓心无怠惰。当小行脚。小行脚已坐洗手足。应念佛菩提念法念僧。修善行念已。当令欢喜。我能如此得具足。若我不得出离。复不久安精进。是故应作勇猛。去曼陀罗不远不近。如轭如寻远。应安坐具对曼陀罗结跏趺坐。令身平正。内心起念闭眼小时。除身心乱。摄一切心成一。心小开眼。仿佛令观曼陀罗。彼坐禅人现观曼陀罗形。以三行取相。以等观以方便以离乱。问云何以等观。答坐禅人现观曼陀罗。非大开眼非大闭眼。如是当观。何以故。若大开眼其眼成惓。曼陀罗自性现见自性。彼分想不起。若最闭眼见曼陀罗成闇。亦不见彼相便生懈怠。是故应离大开眼大闭眼。唯专心住曼陀罗。为心住故当观如人映镜见其面像。依镜见面面从镜生。彼坐禅人观曼陀罗。见其定相依曼陀罗起。是故当观等观取相。为心住故。如是以等观取相。问云何以方便。答谓四作意方便。一谓内隔。二满方。三转。四遍满。是时见相出散无隔。是时当作内隔作意。是时见小相。或见半曼陀罗。是时作令满曼陀罗已。方满令作意。是时心散乱。及心懈懒。是时应当策课如陶家轮。是时若心得住。是时令见曼陀罗。遍满无亏当观舍。如是以方便可知。问云何以离乱。答离乱有四种。一最速作精进。二最迟作精进。三最高。四最下。问云何速作精进。答谓急疾作意不待时节。早坐晚罢乃至身疲。是谓速作。问云何迟作精进。答谓离作意方便。虽见曼陀罗。不恭敬作意。数起数眠。若速作精进。则成身懒心退。心出外缘起诸调戏。若迟作精进。身心成懒懈怠。起诸睡眠。最高者。其心退起诸调乱。于所行处成不乐。若不乐于初戏笑言语。以由欲心成高。复次若得诸相行。由喜乐欲心成高。最下者。退调缘故。于业处成不乐。若不乐于初行处。所作嗔处。由嗔恚心成下。复次久惓觉观。从胜退落其心。由忧受心成下。是坐禅人。若心速作退堕调处。以念根定根摄伏令舍调。若心进作退堕懒处。以念根精进根摄伏令舍懈懒。若高心者退堕欲处。成现知令舍欲。若下心者退堕于嗔恚。成现知令舍嗔恚。于此四处成清净心。成专一心。此明因三行定心成随意得见曼陀罗形。若专一心想成。起名相者有二种。谓取相。彼分相云何。名取相若坐禅人以。不散心现观曼陀罗。从曼陀罗起想。如于虚空所见。或时远或时近。或时左或时右。或时大或时小。或时丑或时好。或时多或时少。不以眼观曼陀罗。以作意方便取相起。是名取相。从彼作多故。彼分相起。名彼分相者。若作意时随心即现。非见曼陀罗后生心念。但作心闭眼如先所观。若远作意亦即远见。若近左右前后。内外上下亦复如是。随心即现。此谓彼分相。相者何义。谓因义相义。如佛教比丘。彼诸恶不善法。有相起是因缘义。复说智义相义。如佛说以作想当舍。是谓智义。复说像义相义。如自见面像想像。彼分无异义。尔时得相。坐禅人于其师所起恭敬心。取于胜相应当守护。若不守护是则当失。问云何应守护。答以三种行应守护相。如是以离恶故。以修行善故。以常作故。云何离不善。乐于作务。乐种种语戏。乐睡眠。乐聚会。乐狎俗。不守护诸根。不节于食。初夜后夜不起禅习。不敬所学。多恶亲友修不行处。应离不好时节食卧坐不。彼对治是善应常作。问云何以常作。答彼坐禅人善取此相。常观其功德。如珍宝想。常欢喜行。常修多修。或昼夜多修行。或倚坐卧心乐攀缘。处处放心。取相已取。取已令起。起已观随。观已修。修有时时观曼陀罗。如是以常作见相。彼如是现守护相。或得自在。若相随心得禅外行。若外行从心者。由是得安。问云何禅外行。答此事从心。作意不乱。以伏诸盖。但未修行觉观喜乐一心及信等五根。虽得定力念念犹起。是禅外行。安者。从此外行是法由心得修行力。是觉信等法于事不动。是名为安。问外行及安。有何差别。答若伏五盖是其外行。以伏此五故成安。以禅外行得胜定。若得胜定是名为安。若于身心未得寂寂。于外定心动如船在浪。若于身心已得寂寂。处安不动如船无风在水。诸根无力故。于所为事外禅行不久住。如小童子。诸根有力故。于事安静久住。如有力人。修不自在。故禅外行成不和合。如人诵经久废则。忘以修自在故成安和合。如人诵经恒习不忘。若不善伏盖。犹如盲人。于禅外行成盲。如是等不清净教。若善伏盖成不盲。于成安定如是等清净教。从相自在所初。乃至性除名为外行。性除无间是名为安。问外行者何义。答禅近故是名外行。如路近村是谓村路。义一名异。安者何义。安为和合义。如到曼陀罗。出离禅安无异义。于是坐禅人住于外行。应令增长一切入。或于安定或于初禅。当令增长。问云何应令增长。答谓从初相如手四指节。当令渐增。如是作意。如是得自在。如是次第如轮如盖。如树影。如福田。如邻如村。如郭如城。如是次第。渐令渐长遍此大地。若江山高下树木棘刺。诸不平正。如是一切不作意。乃至大海作意地想。乃至增长时心所行。成最胜定。若坐禅人得禅外行。不能得安定。此坐禅人。以二行应令起安定方便。一以因缘。二以受持。以十行从因缘起安定方便。一令观处明净。二遍起观诸根。三晓了于相。四制心令调。五折伏懈怠。六心无味着。七心欢喜。八心定成舍。九离不学定人亲近学定人。十乐着安定。问云何作明净处观。答以三种行得作分明处。谓能修调适食乐。修时节乐。修威仪乐。遍起诸根。观者谓信等五根不令消灭。无作懈怠。如快马乘车。晓了于相者。善捉意想不急不宽。如巧师绳墨平等无偏。善解作意急离不离。制心令调者。有二种行。以二种行成心调。一多起精进。二心过度处成心调。或住淫处及种种相处。增长乱意成于心调。于坐禅人若多起精进。过度处成心调。以二行应制伏心。以令精进起。每中调适。若往淫处及种种相。增长调心。以二行折伏。以观觅众苦及恶果报。制伏懈心者。以二行成懈怠心。以不得胜定。令心无味故成懈怠。若多懈怠则欲睡眠。是坐禅人若不得胜定。心无味着故成懈怠。以二行当折伏。谓观功德以起精进。若懈怠睡眠懒心。以四种行能伏。若多食者取懈怠想。转行四威仪。以自作意。于光明相住于露处。令心欢喜无所复着。以三行成无味少方便故。以钝慧故。以不得寂寂乐故。于是坐禅人心若无味。以二种行令得欢喜。一以恐怖。二以欢喜。若观生老死及四恶趣。见诸可畏心生愁恼。若念佛法僧戒施天。见六行功德心生欢喜。心定成舍者。以二行成于禅外地定。以断诸盖心成定。或于所得地以起禅枝。故成心定。是坐禅人心定有二行。当舍非成住故。中方便调适故。离不学定人。或安定。或外行定。或威仪定。彼人无此不修不学。不应供养修。学人者。若有安定。有外行定及威仪定。应从修学。亦应供养。乐着安者。此坐禅人。如彼深源。如彼奔泉。如彼低树。常乐恭敬。多所修行。行此十事因缘生于安定。问云何以受持能生安定方便。答彼坐禅人善解缘起入寂寂处。其所解相。于所修定随心自在。生其欲乐令心得起。从此身意堪任有用令得受持。从生欢喜心得受持。从生适乐身心得受持。从生光明心得受持。从生悲伤心得受持。以是悲伤令心得静。善取静心心得受持。如是善取。令舍心得受持。从无边烦恼。心得解脱成就受持。以解脱故。彼成一法味。以一味心得受持修行。是故从此胜妙心得增长。如是住受持。起安定方便。如是善解缘起。及心受持不久起定。彼坐禅人离欲不善法。有觉有观。于寂静处心所成就。有喜有乐得于初禅。是地一切入功德。于是离欲者。离有三种。谓身离心离烦恼离。问云何身离。答远离诸恼出处山野。云何心离。以清净心到胜善处。云何烦恼离。无结累人无生死行处。复次离有五种。谓伏离彼分离断离猗离出离。云何伏离。谓修初禅伏于五盖。云何彼分离。谓修达分定伏于诸见。云何断离。谓修出世间道断诸烦恼。云何猗离。谓得果时乐。云何出离。谓涅槃也。欲者有二种。一者处欲。二者欲烦恼。天堂及人所爱色香味触。此谓欲处。于此欲处起欲染思惟。是谓欲烦恼。从此欲以心别离以伏别离。是远离是出离。是解脱是不相应。是谓离欲。问云何离不善法。答谓不善根有三种。一贪二嗔三痴。与彼相应受想行识及身口意业。此谓不善法。说不善有三种。一自性。二相应。三生缘性。是三不善根。谓贪嗔痴。是名自性。与彼相应受想行识。是名相应。所起身口意业。此谓缘性。以此三不善法。是为远离。是出是脱是不相应。是谓离不善法。复次离欲者。离贪欲盖。离不善法者。谓离余盖。问以说离不善法。欲是不善已在其中。何故别说离淫欲。答淫欲是出对治。佛所说欲能除烦恼。离欲者。佛说为出。如得初禅。欲想相应作意成起。此退分法。是故以欲和合烦恼。欲若别离一切烦恼皆亦别离。是故别说离欲。复次离欲者。已得出成离欲。离不善法者。若得不嗔成离于嗔。若得明相成离懈怠睡眠。若得不乱成离调戏。若得不悔成离于悔。若得安定成离于疑。若得智慧成离无明。若得正思惟成离邪念。若得欢喜成离不乐。若心得乐成离于苦。若得一切善法则离一切不善。如三藏说。以不贪满故。成就离欲。以不嗔不痴满故。成就离不善法。复次离欲者。是说身离。不善法者。是说心离。复次离欲者。是说断欲觉。离不善法者。是说断嗔恚害觉。复次离欲者。是说避欲乐。离不善法者。是说避着身懈怠。复次离欲者。是说断于六戏笑及欢喜乐。离不善法者。是说断戏觉及忧苦等。亦说断於戏笑及舍。复次离欲者。是现得乐出于欲乐。离不善法者。是现得乐心无过患。复次离欲者。谓超出欲流。离不善法者。所余烦恼应生欲有而生色界。是名超越。有觉观者。云何为觉。谓种种觉思惟安思想。心不觉知入正思惟。此谓为觉。此觉成就故初禅有觉。复次入地一切入。依地相无间成觉思惟。是名为觉。如心诵经。问觉者。何想何味何起何处。答觉者。修猗想为味。下心作念为起。想为行处。云何为观。于修观时随观所择心住随舍。是谓为观。以此相应成初禅有观。复次入地一切入定人。从修地相心之所观。如观诸义为观。问观何相何味何起何处。答观者随择是相。令心猗是味。随见觉是处。问觉观何差别。答犹如打铃。初声为觉后声为观。复次如心所缘。初为觉后为观。复次求禅为觉守护为观。复次忆是觉不舍是观。复次粗心受持为觉。细心受持为观。若处有觉是处有观。若处有观。于处或有觉或无觉。如三藏所说。初安心于事是觉。得觉未定是观。如远见来人。不识男女及识男女。如是色如是形为觉。从此当观有戒无戒富贫贵贱为观。觉者求引将来。观者守持随逐。如鸟陵虚奋翅为觉。游住为观。初教为觉久教为观。以觉守护以观搜择。以觉思惟以观随思惟。觉行不念恶法观行受持于禅。如人有力。默而诵经随念其义是观。如觉所觉觉已能知。观于辞辩及乐说辩是觉。义辩法辩是观。心解于胜是觉心解分别是观。是为觉观差别。寂寂所成。名寂寂者。谓离五盖是名寂寂。复次色界善根。复说初禅外行复说禅心从此心生是谓寂寂所成。如地水生花名地水花。喜乐者。心于是时大欢喜戏笑。心满清凉。此名为喜。问喜何相何味何起何处几种喜。答喜者谓欣悦遍满为相。欢适是味。调伏乱心是起。踊跃是处。几种喜。六种喜。从欲生。从信生。从不悔生。从寂寂生。从定生。及菩提分生喜。云何从欲生。贪欲染着心喜。是名欲生喜。云何从信生。多信人心喜及见陶师等生喜。云何从不悔生喜。清净持戒人多生欢喜。云何从寂寂生。入初禅人喜。云何从定生。入二禅生喜。云何菩提分生喜。于第二禅修出世间道喜。复次说喜五种。谓笑喜念念喜流喜越喜满喜。笑喜者。如细雨沾身令毛皆竖。念念喜者。生灭不住。如夜时雨。流喜者。如油下流久灌其身终不周遍。越喜者。周匝一切心生欢喜。不久便失。如贫人见伏藏。满喜者。身住用满。如雷有雨。于是小喜及念念喜。以信起于外行。流喜者。有力起于外行。越喜者。于曼陀罗正与不正皆起处处方便。满喜者。生于安处。问云何为乐。答是时可受心乐心触所成。此谓为乐。问乐何相何。味何起何处几种乐。喜乐何差别。答味为相。缘爱境是爱味。摄受是起。其猗是处。几种乐者。有五种。谓因乐资具乐寂寂乐无烦恼乐受乐。云何名因乐。如佛所说。戒乐耐老。此谓因乐。是乐功德。资具乐者。如佛所说。佛生世乐。寂寂乐者。谓生定舍及灭禅定。无烦恼乐者。如佛所说。第一涅槃受乐。所谓受乐也。于此论中受乐是可乐。喜乐何差别者。心踊跃是喜。心柔软是乐心猗是乐。心定是喜。粗喜细乐。喜行阴所摄。乐受阴所摄。是处有喜有乐。是处有乐或有喜或无喜。初者形第二为名。外行成就入初禅禅枝。谓觉观喜乐一心也。禅者何义。谓于事平等思惟也。奋迅五盖也。思惟对治也。入初禅得正受者。已得已触已作证住。复次离欲不善法者。从欲界地说初禅为胜相。从有觉观说第二禅为胜相。以寂寂所成有喜有乐。从寂寂所成喜乐说为胜相。复次离欲不善法者。谓能断对治。有觉观者。谓说禅相寂寂所成。喜乐者。谓说相似禅正受。入住者。谓得初禅离于五分。成就五分三善十想。具足二十五功德相应。以此福善上生梵天胜妙居处。离五分者。谓离五盖。云何为五。谓贪欲嗔恚懈怠睡眠调悔疑。贪欲者。谓于五尘心生爱染。嗔恚者。谓行十恼处。懈怠者。谓心懒堕。睡眠者。谓身闷重欲得寤寐。眠有三种。一从食生。二从时节生。三从心生。若从心生以思惟断。若从饮食及时节生。是罗汉眠不从心生无所盖故。若眠从食及时节生者。以精进能断。如阿[少/兔]楼驮所说。我初尽漏得不从心眠。于今五十五岁。于其中间断食时节卧已二十五年。问若眠成色法。何故为心数烦恼。答色者一向成心数恼烦。如我见人饮酒及食。是则可知。问若眠身法。懈怠心数法。何故二法合成一盖。答此二种法。一事一相。所谓疲懈共为一。调者心不寂寂。悔者心恨不定。其相既等故成一盖。疑者心执不一。有四种疑。一者奢摩他难。二者毗婆舍那难。三者二俱难。四者于诸非难。于是具足为得奢摩他。或于此疑。或于身疑。我堪得寂寂。为不得寂寂。若于彼成疑。此谓奢摩他难。或于四圣谛。或于三世疑。此谓毗婆舍那难。或于佛法僧疑。此二俱难。或于国城道路。或于男女名姓。是谓非法难。于此经中疑为寂寂难。是可取。盖者何义。谓障碍乘义覆义烦恼义缚义。此无异义。问有诸细结。谓覆恼等。何故但说五盖耶。答以集执取成五。复次以淫欲执着。能摄一切贪欲。以嗔恚执着。能摄一切不善法。以懈怠睡眠调悔疑执着。能摄一切痴不善法。如是以五盖执着。能摄一切烦恼。以此相故成五盖。五分成就者。谓觉观喜乐一心。问若说初禅成就五枝为禅。不应更复别说其枝为禅。若别说枝。何故初禅说五枝相应。答依禅枝成禅。不离禅枝有禅。无别异禅。如依一一车分说车离分无车。如依军分说军非离军分有军。如是依禅枝名禅。非离枝有禅以一种名禅。以可分名枝。说事名禅。说功德名枝。以说依制名禅。以说依性制名枝。问于有念精进等法。何故但说五枝耶。答以执着成五。问云何为执相。答觉者随于事心而得自安。观者随于持心。觉观不杂起于方便。若方便具足喜乐生。若起方便具足得生。喜心增长乐心成满。以此四功德心成就不乱。若心不乱得定。是名执相。如是执着成五。复次盖对治故成五。初盖对治初禅。乃至五盖对治五禅。觉者初禅为胜枝。以觉除欲。若觉入正定余枝亦起。观者于五枝第二禅是初起。喜者于第三禅是初起。乐者于第四禅是初起。一心者于第五禅是初起。如是以胜枝成五。复次以五盖对治成五。如三藏所说。一心是淫欲对治。欢喜是嗔恚对治觉是懈怠眠对治。乐是调悔对治观是疑对治。以盖从对治是故成五。问此坐禅人作意于一切地相何。故乃起喜乐耶。答地一切入相非起喜乐。因离五盖热随性修故。是以法子应起喜乐。又问。若然法子何故。不于第四禅起喜乐。答非其处故。又得第四禅已断喜乐故。复次初已起喜乐以方便伏断。见有过患已。贪着最寂寂舍乐。是故不起喜乐。三种善者。谓初中后善。以清净修行为初善。以舍增长为中善。以欢喜为后善。云何清净修行。谓诸善资具。云何舍增长。是谓安定。云何为欢喜。是谓为观。如是初禅成三种善。十相具足。以清净修行三相。以舍增长三相。以令欢喜四相。问以清净修行云何三相。答是禅障碍从彼心清净。以清净故心得中奢摩他相。以得故于彼心跳掷。此谓以修清净三相。问云何以舍增长三相。答若心清净成舍。若得寂寂成舍。一向住成舍而舍增长此谓三相。问云何以令欢喜四相。答谓于此十相生法。随逐修行令成欢喜。于此诸根以为一味成令欢喜。随行精进乘成令欢喜。以能修行成令欢喜。此谓四相。如是初禅十相具足。二十五功德相应者。谓初禅觉观喜乐一心具足。信精进念定慧具足。初中后具足。敛摄具足修行具足。寂寂具足。依具足。摄受具足。从具足。观具足。修具足。力具足。解脱具足。清净具足。最胜清净修成住二十五功德相应。是天胜居从寂寂生。谓喜乐住超越人间天居胜处。如佛世尊教诸比丘。如勤浴师浴师弟子。以好铜槃盛豆米屑。以水和搅合而为丸。浸润内外相着不散。如是比丘身心寂寂。能生喜乐灌令遍湿。无所不着。如以寂寂所生喜乐。于其身心无不着处。是勤浴师及浴师弟子。坐禅之人。亦复如是。如是铜槃一切入相如是可知。问一切入何等相耶。答如铜槃浴屑处坚细光焰。善取一切入相。成坚生喜成细清净故光焰。心心数法以成事故。是谓铜槃等一切入相。心心数法如浴屑。如是可知。问云何浴屑等心心数法性。答如粗浴屑。既不和合随风飞散。如是心心数法性。离喜乐成粗。离定不和合。与五盖风共飞。此谓是浴屑等心心数法性。云何水等。谓喜乐定如水。令浴屑湿软为丸。如是喜乐令心心数法湿软为定。如是水等喜乐定。如欲水搅令相着。如是觉观可知。问云何丸等。答谓觉观如欲使。以浴屑置于铜槃中。以水挠搅以手作丸。若作丸已合诸湿屑。共作于丸。不令散失置铜槃中。如是坐禅人心心数法。贮于事中能生寂寂。初禅以喜乐为水。以觉观为手。以搅作丸。能生寂寂。所成心心数法。喜乐相随成一丸。禅心不散乱。置于禅事。如是丸等觉观如浴屑。内外遍湿相着不散。如是坐禅人。初禅于身上下。从头至足。从足至髑髅。皮发内外喜乐遍满。住于不退。如是成住梵天。问名喜乐非色法无有对相。何以遍住于身。答名者依色。色依名色。是故若名已成喜色亦成喜。若名已成乐色亦成乐。复次色从乐生令身起猗。一切身成彼色猗乐。是故无碍令生梵天功德者。初禅成有三种。谓下中上若观胜缘不善除五盖。不至如意自在。是谓下禅。若观胜缘善除五盖。至如意自在。是谓中禅。若观胜缘善除五盖。至如意自在。是谓上禅。于是坐禅人。若修下初禅。命终生于梵天种类。彼寿命一劫三分。若修中初禅。命终生于梵天寿半劫。若修上初禅。命终生大梵天寿。命一劫是生梵天功德成有四种有人成退分。有人成住分有人成。胜分有人成达分是钝根人欲。住放逸作意相随。成起此禅故成退分。复次以三禅行成于退分。最大缠故令不精进。若人从初已起恶觉不能消除。以此大缠故成速退。其于乐禅事业乐话语乐。睡眠不住精进。是故成退。问谁退何以退。答有说。若急疾烦恼成起退失。复说悠悠烦恼故退。复说若失奢摩他成退。复说于有相久不修行。于彼彼处不能令起。以不得定成退分。若钝根人住不放逸。得彼法念成禅住分。利根人住不放逸。随意得第二禅。无觉作意相随。起成彼禅胜分。利根人住不放逸。随意得毗婆舍那。随逐厌患想作意成起。随意无染成禅达分

解脱道论卷第四解脱道论卷第五

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    行门品之二

此明求第二禅。思惟初禅过患二禅功德。尔时坐禅人欲乐起第二禅已。于初禅身得自在。何以故。若于初禅未得自在。虽复思惟欲除觉观。望得二禅还复退失。遂不堪起第二禅定。亦复不能入于初禅。如世尊说。为诸比丘作山犊喻。山犊愚痴不知食处。未解行步。欲诣崄远。便自作念。我今当往未尝至处。啖未尝草。饮未尝水。前足未立复举后脚。蹉摇不安莫能前进。遂不得至未尝至处。亦不得啖未尝食草。及不得饮未尝之水。更复思惟。既不能去。政当资昔饮食如是比丘愚痴未达。不知所行处。不解离欲入于初禅。不修此法不多学习。辄自作念。欲入第二禅离于觉观。不解自安。复更思惟。我不能得入第二禅离于觉观。欲退入初禅离欲。愚痴比丘如彼山犊不解行步。是故应修初禅令心得自在。于未食时及食后时。初夜后夜随心所乐。随欲久近随意无碍。为起入观。若从一时乃至多时。多入多出。若从一时乃至多时。于彼初禅成得自在。得自在乐。起第二禅越于初禅。复更思惟。此初禅粗第二禅细。于初禅见有过患。于第二禅见有功德。问云何初禅过患。答近五盖怨令觉观动。身成懈怠心成散乱。其一切法是为粗定。不任为神通证。既乐初禅不成胜分。是初禅过患。第二禅功德是其对治。已观初禅过患。复见第二禅功德。是一切入相作意修行第二禅事。不作意和合初禅。不作意于觉。不作意于观。以从定生喜乐自在。令心受持。彼坐禅人如是作意。不久觉观成灭。以定所起喜乐自在。令心安住。此明二禅四枝义。彼坐禅人觉观灭故。成其内信。心成一性无觉无观。从定生喜乐入第二禅。是地一切入功德。觉观灭者以善分别。觉观灭亦名断。问云何为觉观灭。答亦是初禅觉观过患。及一切觉观根觉观过患。及觉观根与觉观并除故。成觉观灭。复次以断下粗禅得上胜禅。复令现次第灭。内者现证名内。内有三种。一内内。二内定。三内行处。云何为内内。谓六内入。内定者。于自观身。此谓内定。内行处者。于内自思意不出外摄义是性。是谓内行处。于此经中内内是可乐。信者信正信思惟增长信此谓信。于内定是谓内信。内信者。何相何味何起何处。不乱为内信相。寂寂为味。不浊是起。觉观为处。心成一性者。谓心住正定。此谓心成一性。心成一性者何义。心者是意。一者说于念。名性者如声论说生性。性者说自然义。此第二禅一心能灭觉观。以一性得起。此谓心成一性。心成一性者。何相何味何起何处。专正为相。寂寂为味。无浪为起。觉观灭为处。问信及心成一性。何故非初禅所摄。答初禅以觉观为浪动故。成浊。内信心成一性者成不清净。如水有风浪见于面像不复清净。如是初禅觉观为浪。浪动浊故。内信及心一性成不清净。是故以禅枝非初禅所摄。无觉无观者。谓断觉无觉离观无观。问觉观灭无觉无观。此二种断觉观。何故说二。答觉观灭者为现内信。心一性为因无觉无观。为现寂寂所成喜乐妙相。复次觉观灭者。以此觉观见觉观过患。断彼过患法。无觉无观者。断色界觉观。复次无觉无观者有二种。一不以觉观灭无觉无观。以觉观灭无觉无观。于是五识及第三禅等。不以觉观灭成无觉无观。第二禅以方便寂寂故。以觉观灭成无觉无观。是说二义。从定生者名定。初禅从彼智生。第二禅成从初禅定生。复次定者。于第二禅与一心共生故。定生喜乐。喜乐者初已分别。第二禅者依初得名。此第二禅入正受者。谓入第二禅。禅者内信喜乐一心。是名为禅。入正受住者。成得第二禅离于二枝。成就二枝三种善十相具足。二十三功德相应。是天住是功德。生光耀天。如初广说。天住者。从定生喜乐。越人住故名为天住。是故世尊告比丘言。如池生水非四方来。亦非雨出无有时节。是从泉出清冷浸灌盈溢流远。如是比丘此身从定生喜乐。令得清凉无不润泽。从定生喜周遍身心。犹如泉水。彼坐禅人入第二禅其身可知。如不从四方无流水来无天雨水。如是觉观灭可知。如是从泉出流。令身成满不起波浪。如是从定生喜乐。此名色身令满不起乱心。如以冷水令身清凉遍一切处。如是从定生喜乐。一切名色身成满足修定果报。如是天居生光耀功德。此第二禅有三种。下中上。是坐禅人修下禅。命终生少光天寿命二劫。修中禅生无量光天寿命四劫。修上禅生光耀天寿命八劫

念二禅过患。尔时坐禅人。已修第二禅身得自在。第二禅粗三禅寂寂。知二禅过患。见三禅功德。起第三禅。云何二禅过患。谓近觉观是定之怨。与喜满相应故禅成粗。以喜成满心大踊跃。不能起余禅枝。若着于喜是则为失。若知是失则成不失。若不堪作神通证。若乐二禅不成胜分。是知第二禅过患。见第三禅功德。是其对治。已观二禅过患。复见三禅功德。是依一切入相作意。令喜心灭。以由喜乐受持心。如是作意。不久以无喜乐令心得安解三禅枝。彼坐禅人不染喜故。得舍念智。以身受乐。是圣所说。得舍念智乐住第三禅正受。是地一切入功德不染喜故。喜者先已分别。不染者断喜得舍住。云何为舍。是舍是护。不退不进是心平等。此谓舍。于是舍有八种。谓受舍。精进舍。见舍。菩提觉舍。无量舍。六分舍。禅枝舍清净舍。五根为受舍。有时不作意舍相。为精进舍。苦集我今当断成得舍。为见舍。修菩提觉。是为菩提舍。慈悲喜舍。是为无量舍。以眼见色不苦不喜成舍。是为六分舍。无染故成舍住者。是禅枝舍。舍念清净。是清净舍。于此八舍除受舍。余七舍法。是为平等舍。复次有三种舍。一相应乘。二少经营。三无经营。于一切禅行是禅平等方便。不急疾不迟缓。是名相应乘舍。此下舍近第二禅。能断大踊跃心。若心无经营。是名少经营舍。此舍近第三禅。是其能断一切踊跃心。以不动身心。无经营事心。是名无事舍。此舍近第四禅。舍者何相何味何起何处。平等为相。无所著为味。无经营为起。无染为处。问何故说此舍于此禅。非第二禅及初禅。答是处喜满未灭心着。以缘喜乐是故未灭。以大踊跃充遍身心。是故于二种禅不说舍。以不满故。于此第三禅无喜染故。以灭相着故成起禅枝。以由禅枝自在故。说舍念正智。云何为念。念随念彼念觉忆持不忘。念者念根念力正念此谓念。问念者何相何味何起何处。答随念为相。不忘为味。守护为起。四念为处。云何为智。知解为慧。是正智此谓为智。于是正智有四种。有义智。自相智。不愚痴智。行处智。于是有义智者有四威仪。自相智者。入于空处。不愚痴智者。知于世间八法。行处智者。谓于事处。于此经中行处智是可取。问智者何相何味何起何处。答不愚痴为相。缘着为味。择取诸法为起。正作意为处。问何故此念正智一切处不妙。答若人失念不起正智。不堪起禅外行。问何故说第三禅。不说第二禅及初禅。答于此喜为首。粗禅枝灭故。正定细故。此定入细处。以此正智堪能起第三禅。是故以禅枝自在。复次此禅易起到彼乐处。最气味地亦作愚心。是名著处。是故于此禅。知得自在堪为断喜。又说喜乐者共为亲友。是故此念智分别。无喜有乐于事成住。如彼犊子随逐其母。不捉两耳触突随母。如是无喜有乐。以念智分别乐得住行处。若不缓分别。反入于喜成禅退分。以此禅枝自在故说念智。以此舍念智成就。是故说有舍念智以身受乐。问云何心乐。答心摄受是心乐。从心触生摄受是心乐受。是谓为乐。问云何身。答想阴行阴识阴。此谓为身。此乐以身受谓身受乐。问何故此乐无喜。非以身为受。答于第三禅乐根灭。何故世尊说于第三禅乐根灭是乐圣人所说。圣者佛及弟子。开合制教分别显示。此谓圣所说。问何故圣说于此身非余处。答此第三禅易起到彼乐处。彼无受乐。圣者向于乐住。是圣人成就。是故圣人说此禅胜成舍。有念乐住者舍念乐。此已分别成就。入住第三禅。第三者依第二名为第三。第三禅者是舍念正智乐一心。此谓禅成就。入住者彼已得第二禅。离一分五分。成就三种善。十相具足二十二功德相应。天居生遍净天。如初禅广说。天居者无喜乐住。越人住名天居。是故世尊告诸比丘。如是比丘。于郁波罗池花。分陀利池花。若郁波罗花。波头摩花。分陀利花。水生水增长。从水起住水中。从根至首以令水满其中。如是比丘。此身以无喜乐令满润泽。以无喜之乐遍满身心。于是如郁多罗波头摩分陀利花从水而起。如是入第三禅。其身当知如藕生水。从根至首一切皆满。如是入第三禅。其身以无喜之乐。遍满身心修定果报。如是天居生遍净天功德。此第三禅亦成三种。谓上中下。于是坐禅人修行下禅。命终生少净天。彼寿命十六劫。修行中禅生无量净天。彼天寿命三十二劫。修行上禅生遍净天。寿命六十四劫。念三禅过。尔时坐禅人。如是已作。第三禅身得自在乐。起第四禅越第三禅。第三禅粗第四禅妙。见第三禅过患。复见第四禅功德。云何三禅过患。谓近喜为怨。正定以乐枝粗。不能堪忍为得神通。第三禅不成胜分。如是见第三禅过患。见第四禅功德。是其对治。彼坐禅人。如是已见第三禅过患。见第四禅功德。唯彼作一切入相作意。令现灭乐灭。以由舍心受持如是作意不久。以由舍心得安解四禅枝。彼坐禅人断乐故。先已断苦故。以初喜忧尽故。不苦不乐舍念清净成就住第四禅。是地一切入功德。断乐者名身乐断。断苦者名身苦断。前喜忧灭者。喜名心乐。忧名心苦。皆尽灭也。问乐苦忧已断何处灭。答初禅时灭。于此第四禅。佛说苦灭。问何处苦根起无余时灭。答佛告比丘。初禅成就离欲。是处苦根起无余时灭。问何故于初禅苦根灭。答以喜满故身乐。身乐故苦根灭。以断对治故。是故于初禅苦根灭。于第二禅忧根灭。成断忧根。如佛所说。何处喜根起无余时灭。于此比丘觉观灭故。第三禅正受住。是处忧根起无余时灭。何故第二禅忧根灭。若有觉观久随觉观。成身懈怠成心懒惰。若心懒惰忧根即起。于第二禅觉观灭。说忧根灭。于第三禅是处乐灭。如世尊说。何处乐根起无余时灭。于此比丘厌于喜故。第三禅入正受住。是处乐根已起无余时灭。问何故于第三禅乐根灭。答喜灭故喜为因乐成灭。是故于第三禅乐根灭。问若苦乐忧于三禅处已灭。何故于此四禅说灭。答三禅是四禅道路。于三禅已灭受。是故于第四禅说灭。复次以不苦不乐受。为现对治。是故说苦乐对治不苦不乐受。复次四禅共对治受收合故。复次舍烦恼现无余断。不苦不乐受者。意不摄受心不弃舍。此谓不苦不乐受。不苦不乐受者。何相何味何起何处。中间为相。住中为味。除是起喜灭是处。云何舍念清净者。是谓中性为舍。此谓为舍。念者谓念随念正念。此谓为念。以舍为念成分明清白。此谓舍念清净。问何故此念以舍分明清白。答此舍离一切烦恼故。受相似相应故。成不动无经营。以此无经营与舍相应故。此念至无动成无经营。是故此念已舍成分明清白。四者依彼三禅。此第四成就。入定者此谓四禅舍念一心。此谓禅成就。入住者。成得彼第四禅。离一分三分。成就三种善。十相具足二十二功德相应。报居天上生果实天。功德如初广说。天居者舍乐住出于人住。此谓天居。是故世尊告诸比丘。有人坐以白叠覆身。从头至足。一切身分无处不着。如以白叠无不覆处。如是比丘以清白心。令满一切身分。以清白心无所不着。譬如有人白叠自覆。是坐禅人亦复如是。离一切上烦恼。在第四禅可知。如以白叠覆身。从头至足不寒不热时节调和身心清净。如是入第四禅不苦不乐。是为舍乐。令满于身修定果报。如是天居生果实天功德。修第四禅命终凡夫。生果实天。若心厌患生无想天。寿命五十劫。若沙门或生果实天。或生五净居处。如是果实功德。问何故于三禅处下中上。说果地胜不说第四禅。答依三禅所得有粗有妙。是故以胜枝说果地胜。此第四禅已到妙枝彼岸。从此更无妙枝。是故于此无胜果地念四禅过。尔时坐禅人。于第四禅已得自在乐。游虚空定越于色界。复更思惟。色定粗虚空定细。彼坐禅人见色过患。复见虚空定功德。云何色过患。如取器仗相打斗诤。两舌妄语截手脚等。种种诸事。眼痛疾患寒热饥渴诸苦。是谓色欲过患。云何第四禅过患。此近喜成怨依于色事。是名为粗。于是着乐不成胜分。依虚空寂寂解脱。于此定成粗。于色见第四禅过患。见虚空定功德。是其对治。彼坐禅人如是已见于色。及见第四禅过患。已见虚空定功德。念入第四禅明无边虚空定。从此定起除地一切入相。修虚空定地相成失。于虚空所作事无边作意。若如此现作意不久地相成失。从地相心起成越于虚空。以虚空入相自在心得安。彼坐禅人已起。一切色相有对想灭。于种种想不作意故。正受入住无边空处。一切者。说于无余起。色相者。云何色相。入色界定想智正智。此谓色相。越者。从此起有对想灭者。云何是有对想。色想声想香想味想触想。此谓有对想。灭者。彼种种想尽不作意者。云何种种想。不入定人。或意界和合。或意识界和合想智正智。此谓种种想。此种种想不作意。此谓种种想不作意。问何故止说越想。不说受行识。答若越于想。彼一切皆亦成越。何以故。若不离想心不得越。复次世尊欲说越色事。说越色想。一切定事皆由想故。问若不尔。入色定有对想种种想非为无也。答有人入色界定。有对想有种种想。以断故。问何故于彼不修道。答为厌于色。是故于彼不灭于彼不尽故。入初禅声是其刺如是。佛所说于此为厌色以修行道。是故于此成断。于此断故。无色定不动行想。寂寂解脱想。如迦兰郁头蓝弗入无想定。五百车从前去来不见不闻。是故说于处灭。于是起一切色想。说断色界法有对想。灭种种想。不作意者。说断欲界法。复次越一切色想者。说得无色界。有对想灭者。说断彼定外乱。为显现无动种种想。不作意者说断定内乱。说显现寂寂解脱相。问无边虚空者云何为空。答是空入空界空穴。不为四大所触。此谓为空。于空正安心令满无边。此谓无边。无边空者。是无边空入。入虚空处心心数法。此谓虚空入。虚空入者何义。是虚空无边性。是无边性空处。此说虚空义。如住天处名天处。彼虚空处定。此谓虚空处入。正住者得虚空处定。越色事三分。成就三种善。十相具足二十二功德相应。寂寂居住修定果报。此功德生虚空处。如初广说。功德生虚空者。已修虚空处。命终生虚空天。寿命二千劫

念虚空定过。尔时彼坐禅人。于虚空处已得自在乐。起识一切入定。越虚空一切入。思惟虚空定粗。见识处细。复见虚空过患。复见识处功德。云何虚空过患。此定近色为怨。于虚空定是事成粗。与有对想种种想不相远离。成彼念着不得胜分。如是见虚空过患。是识一切入功德。是其对治。明无边识定治彼坐禅人已见如是虚空过患。已见识处功德。安详念入安祥念起。修虚空识令满作意。令识无边。由识处想心受持。如是现作意。不久从虚空处想。心起越于识处。由识处想而心得安。彼坐禅人起一切虚空故。思惟无边识。成就入正受。于一切识处住。一切者。说于无余。越虚空处者。越虚空处。越者谓正度。是谓越一切虚空处。无边识者。唯彼虚空以识作意令满无边。是谓无边识处。问色非色法。云何执为无边。答唯无色法故成无边。何以故。非色之法无有边际。不可得故。复次虚空无边故说无边。无边者。作无边意故成无边。是故不妨识。入处者是入识处。心心数法。此谓识处。识处者何义。是识无边。此谓识无边。识处者。如天住处名天处。此识已受持定。此谓识处定。入正受处者。得彼于识处定者越虚空事。三分成就。以三种善十相具足。二十二功德相应。住于寂寂修定果报。是功德生识处。如初广说。生识入功德者。修行识处入。命终生识处天。寿命四千劫(识入已竟)

念无边识定过。患尔时坐禅人已得识处。自在欲起无所有处定越于识处。复更思惟。识处定粗。无所有处定细。复见识处过患。复见无所有处定功德。云何识处过患。此定近虚空为怨。识事为粗。以思惟无边想成彼念着。不得胜分。无所有处功德。是其对治。彼坐禅人如是已见识处过患。复见无所有处功德。从识处定安详而起。彼识不复修行。不复分别。成失彼识。已见无所有处相自在。心愿受持如是现作意。不久从识处想起。以由无所有处想。其心得安。彼明无边识定。坐禅人越一切识处。见无所有入正受处住。一切者说于无余。越识处者。成越此识超入正度。此谓越一切识处。无所有者。不复修行。不复分别成失彼识但见无所有。此谓无所有处。入无所有处定。心心数法。此谓无所有处。无所有处者何义。是识无性是无所有。无所有处者。说受持言无所有受持正定。此谓无所有处定。入正受住者。成得无所有定。越识事三分。成就三种善。十相具足。二十二功德相。应住于寂寂修定果报。是功德生无所有处。如初广说。生无所有功德者。修行无所有处定。命终生无所有天。寿命六千劫(无所有定竟)

念无所有处过患。尔时坐禅人。于无所有处已得自在。欲起非想非非想处定越无所有处。复更思惟无所有处粗。见非想非非想处细。复见无所有处过患。复见非想非非想处定功德。云何无所有定过患。此定近识为怨。与分明想共故成粗。成彼念着不得胜上。如是见无所有处过患。复见非想非非想入功德。是其对治。复次见此想是患是痈是刺。无想是政是寂寂是妙。所谓非想非非想。彼坐禅人如是已见。念入无所有处安详而起。彼无所有处寂寂作意修行余定。如是现作意。不久从无所有处想心起。由非非想处想而心得安。彼明非非想定。坐禅人越一切无所有处故。成就入住非非相处。一切者说于无余。越无所有处者。成越无所有处超入正度。此谓越一切无所有处。非非想者。彼无所有处。寂寂作意修行余定。此谓非非想处非非想处者。入非非想处心心数法。是谓非非想处。非非想处者何义。灭分明想故。成于无想细想有余故。成非想非非想是其处。是谓非非想。入正住者。成得非非想处定。越无所有处三分。成就三种善。十想具足。二十二功德相应。住于寂寂明修定果报。以是功德生非非想天。如初广说。是功德生非非想天者。修行非非想处定。命终生非非想天。寿命八万四千劫。问何故说非非想处。何故不说为识处。答离无边执故。起想细故。不成识处。问何故依此定不成漏尽。答离分明想。不堪得见道。复次此定最细微。非非想不能分别。是故不成漏尽处(非非想定已竟)

重明上义。问于是定处云何散句。答所谓灭声。颠倒起越外行觉受疑不应得。灭者入初禅语言断。入第四禅。出入息断。次第灭声者。若人入定。闻有音声不得言说。何以故。是入定人。耳识不和合故。复次入色定人。是声成乱。如世尊所说。入禅人声是其刺。颠倒者。入地一切入。于非地想而作地想。问若然何故不成颠倒。答此四颠倒想不异故。知此地想是其相。是故不成颠倒。起者以五因缘从于定起。以威仪苦以最多境界以障碍起。以方便不平等以随意。若入无色定。以最多境界不得起。住不动故。入灭禅定及入果定。以初作行得起。不以余因。越者。越有二种。分越事越。从色禅越色定。是谓分越。从色禅越无色定。复从无色定越无色定。是谓事越。外行者。一切定外行成就五分。觉者第二禅等性。除无间成无觉观。受者第四禅等性。除无间共舍起。有人乐相似无间。疑者。未断一切贪欲等盖。住非非想处。说于有余。如畏毒蛇上树。有四种人不得起定。必堕恶趣。无因作五逆邪见(散句已竟地一切入已满)

问云何水一切入。何修何相何味何起何功德。云何取其相。答心缘水相。此谓水一切入。心住不乱。此谓修行。于水一切入专意为相。不除水想是味。心不作二意是处。于水一切入不共五功德。于地出没自在。于地出宫殿。令动令降雨。令身能起水。令化江海。于地一切入所说功德。亦共有明修水一切入。处处皆见水。云何取其相者。若取水一切入。于水现取相。若自然水。若自作水。于是旧坐禅人。于非水处取水相。彼人处处见水。若于井于瓶。若于池沼江湖淮海。是其所观随意即见。彼分水相得起。不如新坐禅人。新坐禅人于作处取相。不能于非作处明修水一切入方便。彼坐禅人。从初以观如是寂寂处。若寺舍若石室若树下。是处不闇不日光炙。无尘无风。无蚊蚋等。无诸障碍。于如是处。若钵若盆埋净地中。令与地平。周回一寻。盛以两水。不杂以余色。水令满钵盆。应于此处作意水想。以三行取相。以平等观。以方便。以离乱。余事如地一切入。广说至非非想处(水一切入已竟)

问云何火一切入。何修何相何味何处何功德。云何取相。答心于火相。此谓火一切入。彼时心住不乱。此谓修行。火相巧于放意为相。不除火想为味。作意无双为处。何功德者。不共五功德。于火一切入经营。起烟炎以光明想起。灭余色光随意所烧。以作光明晓了于火界。如地一切入所说功德。因修火一切入。处处皆见火。云何取其相者。若现取火一切入。于火取相。或于自作处。或自然处。于是旧坐禅人取于自然相。彼处处见或草火或薪火或林火或屋火。炽燃焰盛。从此为初。以作于观。或自乐不乐。即见彼分火相得起。不如新坐禅人。新坐禅人唯于作处取相。不能于非作处。彼修火一切入方便。新坐禅人从初经营。断截樵薪。于清净处积聚焚烧。或日出时或日入时。从下焚烧。于草薪皆不作意。于上生烟火皆不作意。于聚焰中现作火想。以三行取相。以平等观。以方便。以离乱。如初广说(火一切入已竟)

问云何风一切入。何修何相何味何处何功德。云何取其相。答心于风相。此谓风一切入。修心住不乱。此谓修风一切入。放意为相。不除风想为味。作意无双为处。何功德者。不同三功德。于风一切入风行自在。能令风起。作意受持令清凉。如地一切入所说功德。修风一切入方便。云何取其相者。新坐禅人现取风一切入。以二行取于风相。或见或触。云何。以见取相彼坐禅。人或甘蔗园。或于竹林或多草处。以风鼓动。彼已见作风想。以三行取相。以平等观。以方便。以离乱。如是已见取相。云何以触取相。新坐禅人如是寂寂。坐处作意想。随风来处。是处穿壁作孔。竹荻为筒安置其内。当筒处坐。使风触其身。作意取风相。如是以触取相。若旧坐禅人于处处分即见风相起。若行住坐卧风触其身。随风所动于初已作观。若自乐不乐。即见彼分风相得起。不如新坐禅人(风一切入已竟)

问云何青一切入。何修何相何味何处何功德。云何取其相。答心于青相。此谓青一切入。修彼心住不乱。此谓修。于青相放意为相。不除青想为味。作意无双为处。何功德者。不同五功德。于青一切入。心缘随逐。得净解脱。得青除入如青花。心受持令化种种青色。修青一切入。处处皆见青。云何取其相者。取青一切入相。若作处若自然处。旧坐禅人取不作处相。彼坐禅人于处处见。或青花或青衣或青色。于其目前常见。随若乐若不乐。即见彼分青相得起。不如新坐禅人。新坐禅人取于作处相。不能取非作处。修青一切入方便。彼坐禅人于衣于板于壁处。以阿多思花色青色。以此色作曼陀罗花。或三角或四角。以异色绕其外。于此作青相。以三行取相。以平等观。以方便。以离乱。余如初广说(青一切入已竟)

问云何黄一切入。何修何相何味何处何功德。云何取相。答心于黄相。此谓黄一切入。修彼心住不乱。此谓修。于黄一切入放意是相。不除黄想为味。作意无双为处。何功德者。不同五功德。于黄一切入。心随逐得净解脱。得黄除入作意。如金花种种黄色。修黄一切入。处处皆见黄。云何取彼相者。现取黄一切入。取于黄相。若自作处。若自然处。于是取非作处相。彼坐禅人于处处见。或黄花或黄衣黄色。从此常见。随乐不乐。即见彼分黄相得起。非如新坐禅人。新坐禅者取于已作处相。不能于非作处。修黄一切入方便。彼坐禅人或衣或板或壁。以迦尼罗花色黄色。作曼陀罗花。或三角或四角。异色绕其外。于彼作黄相。以三行取相。以平等观。以方便。以除乱。余如初广说(黄一切入已竟)

问云何赤一切入。何修何相何味何处何功德。云何取其相。答心于赤相。此谓赤一切入。彼修心住不乱。此谓修。于赤相放意为相。不离赤想为味。作意无二为处。何功德者。不共四功德。于赤一切入随心得净解脱。得赤除入。化种种赤色。不共功德者。如说于地一切入。修赤一切入处处皆见赤。云何取其相者。现取赤一切入。取于赤相。若作处若自然处。旧坐禅人于自然处取相。于处处见相。或赤花或赤衣或赤色。从此为初常见。随乐不乐。即见彼分赤相得起。不如新坐禅人新坐禅人于作处取相。不能于非作处。修赤一切入方便。彼坐禅人或衣处或板或壁处。如槃偷时婆花生赤色。或以朱丹作曼陀罗花。或三角或四角。以异色界其外。于此作赤相。以三行取相。以平等观。以方便。以离乱。如初广说(赤一切入已竟)

问云何白一切入。何修何相何味何处何功德。云何取其相。答心于白相。此谓白一切入。彼修心住不乱。此谓修。于白相放意为相。不离白想为味。作意无二为处。何功德者。不共八功德。于白一切入。随心得净解脱。得白除入。伏懈怠眠。除闇作明。白一切入。得起天眼。余功德如地一切入所说。修白一切入。处处皆见白。云何取其相者。现取白一切入。于白取相。若作处若自然处。旧坐禅人于自然处取相。彼于处处见相。或白花或白衣或白色。或月光或日光或星色或镜圆。从彼为初常见。随乐不乐。即见彼分。白相得起。不如新坐禅人。新坐禅人于作处取相。非不作处取相。修白一切入方便。彼坐禅人。或于衣处或板或壁处。以太白星等色。以此色作曼陀罗花。或三角四角。以异色界其外。于此作白相。以三行取相。以平等观。以方便。以离乱。如初广说(白一切入已竟)

问云何光明一切入。何修何相何味何处何功德。云何取其相。答心作光明相。此谓光明一切入。彼修心住不乱。此谓修。光明放意为相。不离光明想为味。作意无二为处。何功德者。与白功德等。修光明一切入。处处见光明。云何取其相者。现取光明一切入。于光明取相。若作处若自然处。旧坐禅人于自然处取相。彼于处处见相。或月光或日光。或灯光或珠光。从彼初常见。随乐不乐。即见彼分光明即起。不如新坐禅人。新坐禅人于作处取相。不能于非作处。修光明一切入方便。彼坐禅人如是或作东西壁。坐令水满钵。安置日光所至处。从彼水光起曼陀罗。从曼陀罗光起着壁光。于此见光明相。以三行取相。以平等观。以方便。以离乱。如初广说(光明一切入已竟)

解脱道论卷第五解脱道论卷第六

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    行门品之三

问云何虚空一切入。何修何相何味何处何功德。云何取其相。答虚空一切入。有二种。有虚空离色。有虚空不离色。虚空入处相。所谓离色虚空。井穴虚空相。此谓不离色虚空。彼修此想心住不乱。此谓修。于虚空想放意为相。不离虚空想为味。作意无二为处。何功德者。不共二功德。于虚空入障碍处。所不能碍。若墙壁山等。身行无碍自在无畏。云何取其相者。于虚空入取虚空相。若作处若自然处。旧坐禅人于自然处取相。能于处处见。或于孔穴。或棂窗间。或树枝间。从彼常见。随乐不乐。即见彼分虚空相即起。不如新坐禅人。新坐禅人于作处取相。不能于非作处。彼坐禅人。或于屋内。或于屋外不障碍处。作圆孔穴作虚空想。以三行取相。以等观。以方便。以离乱。于虚空一切入。生四禅五禅。余如初广说(虚空一切入已竟)

问云何识一切入。答曰识处定。此谓识一切入。余如初广说(十一切入已竟)

问于是一切入。云何散句。答若一相得自在。一切余相随其作意。若于一处一切入。于初禅得自在。堪任余一切入。能起第二禅。如是第二禅得自在。能起第三禅。第三禅得自在。能起第四禅。问于诸一切入云何最胜。答四色一切入。是为最胜。成解脱故。得除入故。曰一切入胜。作光明故心得自在。于八一切入及于八定。以入十六行安详而起。随所乐处。其所乐定随意无障。次第上次第下。次第上下令一一增长。或俱令增长。或中少或分少。或事少或分事少。或分俱或事俱或分事俱。随其所乐处者。或于村或于阿兰若。是斯所乐处。入于三昧。如所乐者。是其所乐禅。入于禅定。如其所乐。时者随意所乐时。入于三昧。或多时入正受。次第上者。于初禅入定次第乃至非非想处。次第下者。从初入非非想定。次第乃至初禅。次第上下者。越于往还。从初禅入第三禅。从第三禅入第二禅。从第二禅入第四禅。如是乃至入非非想定。令一一增长者。以次第入第四禅。或上或下。俱令增长者。入第四禅。从此虚空入第三禅。如是二种入定。中少者。已入初禅。从此入非非想处。从此入第二禅。从此入无所有处。如是现入正受。能辨虚空处。分少者。一禅于八一切入入定。事少者。于三一切入入于八定分。事少者。所谓二定。及一切入。分俱者。于三一切入入二二禅。事俱者。于二二一切入入二禅。分事俱者。是此二句(散句已竟)

问云何增长相。何修何相何味何处何功德。云何取其相。答增长相者。满一切处。犹如排囊满中臭秽死尸。此谓膖胀。于膖胀相以正智知。此谓膖胀想。彼修此想心住不乱。此谓修。于膖胀想相随观为相。厌膖胀想为味。臭秽不净作意为处。何功德者。膖胀想有九功德。得念内身得无常想。得死相。多厌患伏淫欲。断色憍断无病憍。向善趣向醍醐。云何取其相者。新坐禅人现取膖胀不净想。以无二行。以念不动不愚痴。以诸根内入。以心不出外。以往彼处。是处不净有诸死尸。住于彼处离于逆风。对不净相不远不近。或倚或坐。彼坐禅人。若倚若坐近不净处。若石若土埵。或树或杌或藤。为作相作事思惟。此石不净。此不净相。此石如是土埵等。已为作相已作事。以十行膖胀不净相。从其自性修行当观。以色以男女形。以方以处。以分别以节。以穴以坑。以平地以平等。观于一切处。以色者。若黑以观黑。若不黑不白以观不黑不白。若白以观白。若臭皮观以臭皮。以形者。若女形若男形。随观若少若长若老。随观者。若长以长。若短以短。若肥以肥。若小以小随而观之。以方者。于此方掷头。于此方掷手。于此方以脚。于此方以背。于此方以腹。于此方我所坐。于此方不净相。如是随观以光明处。于此光明处是掷手处。于此光明是掷脚处。于此光明是掷头处。于此光明是我坐处。于此光明是不净相处。以分别观。从头至足。从下至头。发皮为边。是一屎聚。以分别观观以节者。于二手六节。于二脚六节。髋节项节。此谓十四大节。以空穴者。谓口或开或闭。随观眼或开或闭。随观手间脚间孔穴。以坑以平等地者。不净相随其处所。或于空处或于地上。是处随观。复次我在空处不净相地上。或不净相在下。我于地上随观以一切处。从我不取近远。若二寻三寻随观。彼坐禅人如是一切正随观见彼相。善哉善哉。如是受持。以善自安。彼坐禅人已善取相。已善受持。已善自安。一无二行。以念不动。心不愚痴。诸根内入。心不出外。去来道路若行若坐。观彼不净心常受持。无二行者何义。为得身寂寂。令念不动者。以不愚痴。以诸根内入心不出外。去来道路者何义。为得身寂寂。离逆风者何义。为离臭气。坐不取远近者何义。若取远不成除相。若取近不成其厌。不见其性。以不见其性。彼相不起。是故不取远不取近。坐遍观一切相者何义。为不愚痴名不愚痴。若坐禅人入寂寂处。见不净相。如在其前。心起惊怖。是故坐禅人。若死尸起逐不起。心思惟如是已知念正智受持已观相遍。是其遍相如是作意。是名不愚痴。问取十种行相何义。答为于心缚。观去来道路者何义。为起次第法。名次第法者。若坐禅人入寂寂处。有时心乱。以不常观不起不净相。是故坐禅人摄一切心。当观去来道路。当观于坐禅处。当观遍相。当观十种取相。彼坐禅人如是数数现观。复更起相。如以眼见。此谓起次第法。初坐禅人于此死尸成珍宝想。如是欢喜心得受持。心常修行灭于诸盖。禅分成起。彼坐禅人。已离欲已离不善法。有觉有观。寂寂所成。有喜乐入初禅定及膖胀相。问何故以不净行起于初禅。非起余禅。答此行未作观故。此成缚处故。常随觉观。觉观恒现其相得起。非离觉观其心得安。是故初禅起非余禅。复说。此不净相色形等。以不一行思惟。令起于行思惟者。是觉观事。不能堪任离于觉观为思惟行。是故唯初禅起非余禅。复说此不净相不可耐事。于不耐事不能举心。于不净处心由喜乐故。除觉观方便。以觉观方便力。是时修行由如臭屎。是故唯初禅起非余禅。问于不耐事云何起喜乐。答不耐事非因为起喜乐。复次善断盖热故。以修心自在故。起喜乐行。余如初广说(膖胀相已竟)

问云何青淤相。何修何相何味何处何功德。云何取其相。答青淤者。或死一宿。或二三宿。成青淤相。如青所染色随生。此谓青淤相。彼青淤是谓青相。以正智知。此谓青淤相。心住不乱此谓修。受持青相为相。厌为味。作意不耐为处等膖胀相功德。修其相者。如初广说(青淤相已竟)

问云何溃烂相。何修何相何味何处何功德。云何取相。答溃烂者。或死二三宿溃烂脓出。犹如灌酪。身成溃烂。此谓溃烂。于溃烂相以正智知。是谓溃烂相心住不乱此谓修。受持溃烂为相。厌为味。作意不耐为处。等膖胀相功德。取相如初广说(溃烂相可知溃烂相已竟)

问云何斩斫离散相。何修何相何味何处何功德。云何取其相。答斩斫离散者。或以刀剑斩斫身体离散。复说所掷死尸。此谓斩斫离散。于斩斫离散是正智知。此谓斩斫离散想。心住不乱此谓修。斩斫离散想为相。厌为味。作意不净为处。等膖胀相功德。问云何取其相。答于两耳二指作片片想。作斩斫离散想。如是取相。于一二上取其空相。余如初广说(斩斫离散相已竟)

问云何食啖想。何修何相何味何处何功德。云何取其相。答食啖者。或乌鹊鸱枭雕鹫猪狗狐狼虎豹食啖死尸。此谓食啖。于彼食啖。是相以正智知。此谓食啖想。心住不乱此谓修。食啖想为相。厌为味作意不净为处。等膖胀想功德。余如初广说(食啖相已竟)

问云何弃掷想。何修何相何味何处何功德。云何取其相。答弃掷者。于处处方散掷手足。此谓弃掷。于弃掷想是正智知。此谓弃掷想。心住不乱此谓修。受持弃掷想为想。厌为味。作意不净为处。膖胀想等功德。云何取其相者。一切身分聚在一处。安诸分节。相离二寸。安已作弃掷想取相。余如初广说(弃掷想已竟)

问云何杀戮弃掷想。何修何相何味何处何功德。云何取其相。答被杀弃掷者。或以刀杖。或以弓箭。于处处斩斫杀戮死尸。此谓杀戮弃掷。于杀戮弃掷。是想是正智知。此谓杀戮弃掷想。心住不乱此谓修。受持杀戮弃掷想为相。厌为味。作意不净为处。等膖胀功德。云何取其相者。如初广说(杀戮弃掷想已竟)

问云何血涂染想。何修何相何味何处何功德。云何取其相。答血涂染者。或斩截手足形分。出血涂身。此谓血涂染。于血涂染相。是正智知。此谓血涂染想。心住不乱此谓修。受持血涂染想为相。厌为味。作意不净为处。等膖胀想功德。云何取其相者。如初广说(血涂染相已竟)

问云何虫臭想。何修何相何味何处何功德。云何取其相。答虫臭者。诸虫生满其身。犹如白珠纯是虫聚。此谓虫臭。于虫臭想以正智知。此谓虫臭想。心住不乱此谓修。受持虫臭想为相。厌为味。作意不净为处。等膖胀想功德。云何取其相者。如初广说(虫臭想已竟)

问云何骨想。何修何相何味何处何功德。云何取其相。答骨者。谓钩锁相连。或肉血筋脉所缚。或无血肉但有筋缠。或无肉血。此谓骨。于此骨想以正智知。此谓骨想。心住不乱此谓修。受持骨想为相。厌为味。作意不净为处。等膖胀想功德。云何取其相者。如初广说(骨想已竟)

问于不净处云何散句。答初坐禅人有重烦恼。于不种类不应取相。不种类者如男女身。若不净业人不。净相不应作意。何故。常观事故不成厌。于畜生身不起净想。以一骨起起相自在于骨取。亦复如是。若不净相以色起。由一切入当观。若以空起以界。当观者。以不净起以不净当观。问何故十不净不多不少。答身失有十种故。复由十人故成十想。欲人当修膖胀想。色爱欲人当修青淤想。如净欲人当修坏烂想。余亦可知。复次不净相。不可得故。一切不净想欲对治故。若欲行人是其所得。彼当取相。是故说一切不净。为十种不净想。问何故不令增长。答若人乐厌欲。令起自性身想。何故。若有自性身想。于想速得厌。彼分故。已令增长不净想。是其身相得除。已除自身想。不速得厌。是故不应令增长。又说若得无欲。为修大心。成令增长。如阿毗昙说。处离欲等初禅正受住膖胀。及起无量事。如大德摨狗父说偈

  比丘佛家财　　于怖畏林处
  既已修骨想　　普令满此地
  我知彼比丘　　速当断欲染(十不净已竟)

问云何念佛。何修何相何味何处何功德。云何修行。答佛者。世尊自然无师。于未闻法正觉正谛。能知一切得力自在。此谓为佛。念佛世尊正遍知道菩提功德。念随念念持念不忘念根念力正念。此谓念佛。心住不乱此谓修。令起佛功德为相。恭敬为味。增长信为处。若修行念佛。成得十八功德。信增长念增长。慧增长恭敬增长。功德增长。多欢喜堪任苦行。离于怖畏。于受恶法。得生惭愧。常与师共住。心乐佛地行向善趣。最后醍醐。如说修多罗涅底里句。若人欲念佛。其可恭敬如佛像处。云何修行。初坐禅人。往寂寂处摄心不乱。以不乱心。念如来世尊应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。于是彼者到一切功德彼岸。世尊者。得世称誉故名世尊。复得妙法故名世尊。复得供养故名世尊。得福具足故名世尊。道法之主故名世尊。以是因故得名世尊。以彼因故受供养名阿罗汉。杀烦恼怨。名阿罗汉。折生死轮辐。名阿罗汉。正遍知者。以一切行正知一切诸法。名正遍觉。复杀无明名正遍觉。以独觉无上菩提。名正遍觉。明行足者。明者三明。宿命智明。众生生死智明。漏尽智明。世尊以宿命智明。断杀过去无明。以众生生死智明。断杀未来无明。以漏尽智明。断杀现在无明。已断杀过去无明故。以一切行一切过去法。世尊应念即现。已断杀未来无明故。以一切行一切未来法。世尊应念即现。已断杀现在无明故。以一切行一切现在法。世尊应念即现。行者。戒定足具。戒者。谓一切善法处。故言明行。足者。谓一切神通处故。名明行足。具者。谓一切定。于是世尊。以一切智。以三明以行得大慈悲。以作世间饶益。明得自在。以知处故。以起论道无人能胜。灭诸烦恼。以清净正行。以明具足成世间眼。现饶益不饶益故。以行具足成世间依。作救怖畏。以明解脱。于第一义已得通达。以行成济渡。作世间义。于一切事自然无师。所行平等得无上寂寂。以明行足世尊成就。此谓明行具足。善逝者。到善路故。名曰善逝。不复更来到。于醍醐界。无为涅槃。故名善逝。复说法不颠倒。故名善逝。复说法不僻。故名善逝。复说法无过患。故名善逝。复说法不多不少。故名善逝。世间解者。世间有二种。谓众生世间。行世间。世尊以一切行。知众生世间。以知众生种种欲乐。以根差别。以宿命以天眼。以从去来。以和合以成就。以种种可化。以种种堪不堪。以种种生。以种种趣。以种种地以种种业。以种种烦恼。以种种果报。以种种善恶。以种种缚解。以如是等行。世尊悉知众生世间。复说行世间者。世尊亦知以一切业。亦知诸行。以定相以随其自相因缘。善不善无记。以种种阴。以种种界。以种种入。以智明了。以无常苦无我。以生不生。如是等行。世尊悉知世间诸行。此谓世间解。无上者。世无有上。此谓无上。复次无人与等。复次最胜无比。余不能过。故名无上。调御丈夫者。有三种人。或闻法即悟。或说因缘。或说宿命。世尊御八解脱道。调伏众生故。名调御丈夫。天人师者。世尊能度天人。从生老死怖畏园林。故名天人师。复次教诫见思惟道。名天人师。如是以此门以此行。当念如来。复次如本师说。以四种行修念世尊。本昔因缘以起自身。以得胜法。以作世间饶益。从初所愿。乃至最后。生于此中间。久远之时。二十阿僧祇劫。一百千亿。观凡夫根念根所。初慈哀世间。我已得脱。当令彼脱。我已得调。当令彼调。我已得安。当令彼安。我已入涅槃。当令彼得入涅槃。施戒出忍谛受持慈舍精进智慧。皆令满足。为得菩提。世尊为菩萨时。说本生因缘。作兔子身。常行布施。当念可护生戒摩瞿频陀生。当念出离生忍辱生。当念忍普明生。当念实语当念恶蹇生。当念受持当念帝释慈悲。当念毛竖舍。当念商主正真。当念麋生。当念长寿生。逐父语。当念六牙白象恭敬仙人。当念白马生往罗刹国渡诸众生。当念鹿生护彼寿命舍自寿命。当念猴生令得解脱所属大苦。复次当念猴生见人落坑以慈心拔出。设树根果以为供养。彼人乐肉以破我头。以慈悲说法语其善道。如是以众愿门。当念世尊本生功德。云何当念世尊自拔身功德。世尊有如是等本生具足。为年少时断一切居止着。断儿妇父母亲友着。以舍难舍独住空闲无所有处。欲求无为泥洹寂灭于摩伽陀国。渡尼连禅河。坐菩提树。降伏魔王及诸鬼兵。于初夜时自忆宿命。于中夜分修得天眼。于后夜中知苦断集。得证醍醐界。修行八正道。分作证漏尽得菩提觉。从于世间拔出自身。住第一清净漏尽之地。如是以众行门。当念世尊自拔身功德。云何当念世尊得胜法功德。如是世尊有解脱心解脱。以如来十力。以十四佛智慧。以十八佛法。已与不一禅法成就到自在彼岸。当念云何世尊成就十力。如来知是处非处。如实而知。如来知过去未来现在善业因缘。以戒以因。若果报等。如实而知。如来知至一切处。具足如实而知。如来知不以一戒种种戒。世间如实而知。如来知众生种种欲乐。如实而知。如来知众生种种诸根。如实而知。如来知禅解脱定正受有烦恼无烦恼。如实而知。如来知宿命如实而知。如来知众生生死。如实而知。如来知漏尽。如实而知。以此十力世尊成就。云何世尊成就十四佛智慧。谓苦智。集智。灭智。道智。义辩智。法辩智。辞辩智。乐说辩智。诸根智。众生欲乐烦恼使智。双变智。大慈悲定智。一切智。不障碍智。以此十四智。世尊成就。云何世尊成就十八法。于过去佛智不障碍。未来佛智不障碍。现在佛智不障碍。随于佛智遍起身业。随于佛智遍起口业。随于佛智遍起意业。以此六法世尊成就。欲无退。精进无退。念无退。定无退。慧无退。解脱无退。以此十二法。世尊成就。无可疑事。无诬师事。无不分明。无有急事。无隐覆处。无不观舍。无可疑事者。无有威仪为于狡狯。诬师事者。无急速威仪。无不分明者。以知无不触。无急事者。无威仪以急事。无隐覆者。心行无有非不忆智。无不观舍者无有不知舍。以此十八佛法。世尊成就。复次世尊以四无畏。以四念处。以四正勤。以四如意足。以五根以五力。以六神通。以七菩提分。以八圣道分。以八除入。以八解脱。以九次第定。以十圣居止。以十漏尽力。以余不一善法。世尊成就到自在彼岸。如是以此门以此行。当念世尊得胜法功德。云何当念世尊作饶益世间功德。世尊成就一切行。到一切功德彼岸。为慈悲众生所转法轮。世间所不能转。以密护无内外。开醍醐门。已作无量天人。于沙门果无量众生。得功德分。能令功德具足。以三种变。身变说变教变。令世间信。已伏邪见诸相咒师。已覆恶道已开善趣。已往天上得解脱果。已安声闻住声闻法。已制诸戒。已说波罗提木叉。已得胜利养。得佛胜法。已得自在遍满世间。一切众生恭敬尊重。乃至天人皆悉闻知。安住不动。慈悲世间饶益世间所作。世尊已作。以此门此行。当念世尊已作世间饶益功德。彼坐禅人以此门此行。已此功德现念如来。其心成信。以信自在。以念自在心常不乱。若心不乱。灭盖禅分起内行禅成住。问何故念佛起内行非安。答佛功德者。于第一义深智行处。第一义事于深智行处。心不得安。以细微故。复次当念不一功德。若坐禅人忆念不一功德。心种种缘作意共起。心成不安。是相为一切外行行处。问若念不一功德。心既不一。外行禅不当成。若专一心。外行禅成住。答若念如来功德。及念佛成一心。是故无过。复说以念佛四禅亦起(念佛已竟)

问云何念法。何修何相何味何处。云何修行。答法者。谓泥洹及修行至泥洹。云何泥洹。灭一切行。出离一切烦恼。灭爱无染寂灭。此谓泥洹。云何修行至泥洹。谓四念处。四正勤。四如意足。五根五力。七觉分八正道分。此谓修行至泥洹。念法出离功德乘功德。彼念随念正念。此谓念法。彼心住不乱此谓修。起功德法为相。择法为味。解义为处。念佛功德等。云何修者。初坐禅人入寂寂。坐摄一切心。以不乱心念法者。善说世尊法。现证无时节。来见乘无时节。来见乘相应。智慧人现证可知。善说世尊法者。离两边故名为善说。不异故名为善说。不谬故三种善故名善说。满清净故名善说。令现泥洹及修行至泥洹。故名善说。现证者。次第得道果故名现证。作证泥洹及道果故为现证。无时节者。不异时得果故名现证。来见者。汝来我处。见我善法性堪教他。是名来见。乘相应者。若人受降伏。成入醍醐界。名为乘相应。向沙门果名乘相应。智慧人现证可知者。若人受降伏不受他教。起于灭智无生智解脱智。是名智慧现证。以余行当念法者。是眼是智是安乐是醍醐乘门。是出离是方便。是至灭是至醍醐。无有堕落是醍醐。无为寂寂微妙非相师所行。是妙智人所知。济渡彼岸是归依处。彼坐禅人以此门以此行以此功德。现念于法其心成信。由其信念心住不乱。以不乱心灭于诸盖。禅分得起。外行禅成住。余如初广说(念法已竟)

问云何念僧。何相何味何处何功德。云何为修。答僧者圣人和合。此谓为僧。现念僧修行功德。彼念随念正念。此谓念僧。彼念住不乱此谓修。念起僧功德为相。心恭敬为味。欢喜和合功德为处。念佛功德等。云何修者。初坐禅人入寂寂。坐摄一切心。不乱心念想。善能修行。世尊沙门众随从软善。世尊沙门众随从如法。世尊圣众随从和合。世尊圣众。所谓四双八辈。世尊沙门众堪可恭敬供养。堪可合掌。无上世间福田。于是善修行。世尊沙门众者。随从善说法故。名修行随从。为自他饶益故。名修行随从。已至具足故。名修行随从。无怨具足故。名修行随从。离二边中具足故。名修行随从。离幻谄故名软善。离身口邪曲恶故名软善。随从如者。八正圣道。彼随从故。名如随从。复次如者谓泥洹。为随从得泥洹故如修行。世尊所说四圣谛。随从如智故名如修行。随从和合者。随从沙门和合具足故。名随从和合。若如是随从作和合事。成大果大功德如是随从。故名随从和合。四双八辈者。住须陀洹道及住其果故为一双。住斯陀含道及住其果故为一双。住阿那含道及住其果。故为一双。住阿罗汉道及住其果故为一双。此谓四双者。彼住道及道果故名四双。八辈者。四向四果。此谓八辈。沙门者。从闻成就故名沙门。僧者圣和合众。可请可供养可施可恭敬。无上世间福田。可请者。堪受请名为可请。可供养者。于众施成大果堪受供养。可施者。若于众施得大果报。可恭敬者。堪受恭敬事名可恭敬。无上者。最多功德故名无上。世间福田者。是众生功德处故。名世间福田。以余行当念众生。如是胜众真实众是名醍醐。戒具足。定具足。慧具足。解脱具足。解脱知见具足。彼坐禅人以此门以此行。以现念众功德。如是现念众功德其。心成信由。于信念心成不乱以。不乱心能灭诸盖禅。分得起外禅成住。如初广说(念僧已竟)

问云何念戒何修何相何味何处何功德。云何修行。答以功德念清净戒。彼念随念正念。此谓念戒。念戒住不乱。此谓修。令起戒功德为相。见过患怖为味。欢喜无过乐是处。若人修行念戒。成得十二功德。成尊重师重法重僧重戒学重供养重不放逸。于细微过患常见忧怖。护自身亦护他。从此世怖畏解脱。彼世怖畏解脱。多欢喜可爱一切戒功德。是念戒功德。云何修行者。初坐禅人入寂寂。坐摄一切心。不乱心念。自身戒无偏无穿无点无垢无杂。自在智慧所叹。无所触令起定。若无偏是无穿。若无穿是不点。如是一切可知。复次若满清净戒。是善法住处故。名不偏不穿。作姓称誉故。名无点无垢。以断爱故。名为自在。圣所乐故无有过患。智慧所叹离戒盗故。故名无所触。成不退处故令起定。以余行当念戒。名戒者。是乐无过患。是姓可贵。以财物自在。如先所说戒功德。如是广说可知。彼坐禅人以此门以此行以此功德。现念戒由信念心不乱。以不乱心灭于诸盖。禅分成起外行禅成住。余如初广说(念戒已竟)

问云何念施。何修何相何味何处何功德。云何为修。答施者。为利他故。乐饶益他。为他人得舍自财物。此谓施。以念施功德现念舍。彼念随念正念。此谓念施。彼念住不乱此谓修。令起施功德为相。不蓄为味。不悭为处。若人修行念施。成得十功德。如是施随乐无悭无贪意。为多人念善取他意。于众不畏多欢喜慈悲心。向善趣向醍醐。云何修行者。初坐禅人入寂寂。坐摄一切心不乱心自念施。以所舍物我有利我善得利。世人为悭垢所牵。我住无悭垢心。我常施与常乐行施。常供给常分布。彼坐禅人以此门以此行以此功德。现念施彼心成信。由信由念故。心常不乱。以不乱心灭于诸盖。禅分成起。外行禅成住。余如初广说(念施已竟)

问云何念天。何修何相何味何处何功德。云何修行。答依生天功德。念自身功德。彼念随念正念。此谓念天。彼念住不乱此谓修。令起自身功德天功德等为相。于功德爱敬为味。信功德果为处。若人修行念天。成得八功德。如是彼人五法增长。所谓信戒闻施慧。成天人所念爱敬。于说功德果报。大欢喜踊跃自重其身。及天人所贵。念戒念施以入其内。向善趣向醍醐。云何修行者。初坐禅人入寂寂坐。摄一切心。以不乱心。念天有四王天。有三十三天。有焰摩天。有兜率天。有化乐天。有他化自在天。有梵身天。有天常生。以信成就诸天。从此生。彼我复如是有信。如是戒如是闻如是施如是慧。成就彼诸天。从此生彼。我复如是有慧。当念其身。当念诸天。信戒闻施慧。彼坐禅人以此门以此行以功德现念天。彼心成信。以由信由念。心成不乱。以不乱心灭于诸盖。禅分成起外行禅成住。问何故念天功德。不念人功德。答诸天功德最妙。生最妙地成妙处心。于妙处修行成妙。是故念天功德。不念人功德。余如初广说(念天已竟)

解脱道论卷第六解脱道论卷第七

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    行门品之四

问曰。云何念安般。何修何相何味何处何功德。云何修行。答曰。安者入。般者出。于出入相。彼念随念正念。此谓念安般。心住不乱此谓修。令起安般想为相。触思惟为味。断觉为处。何功德者。若人修行念安般。成寂寂成胜妙成庄严。可爱自娱乐。若数数起恶不善法令除灭。身成不懈怠。眼亦不懈怠。身成不动不摇。心成不动不摇。令满四念处。令满七觉意。令满解脱。世尊所叹。圣所住止。梵所住止。如来所住止。云何修者。初坐禅人。若往阿兰若。若往树下。若往寂寂处。结跏趺坐。正身在前。彼坐禅人。念入息念出息。念出息。若长出息。我息长出如是知之。若长息入。我长息入。如是知之。若短息入。我短息入。如是知之。若短息出。我短息出。如是知之。我入息如是觉。我出息如是觉。知喜知乐知心所行。令灭心行。令欢喜心。令教化心。令解脱心。见无常见无欲。见灭见出离如是觉。见出离我出息如是觉。见出离我出入息如是。于是现前令学安者。谓系念住于鼻端。或于口唇。是出入息所缘处。彼坐禅人以安念此处。入息出息于鼻端口唇。以念观触。或现念令息入。现念令息出。现于息入时不作意。于出时亦不作意。是出入息所触。鼻端口唇。以念观知所触。现念令入现念出息。如人触材以缘锯力。亦不作意锯去来想。如是坐禅人。于入出息亦不作意。入出息想。所触鼻端口唇以念观知。现念令入息。现念令出息。若坐禅人于入出息作意。内外其心成乱。若心起乱。其身及心成懈怠动摇。此是过患。若最长息。若最短息。不应作意。若作处最长最短息。其身及心皆成懈怠动摇。此是过患。由出入息种种相故。不应作着。若如是作心余缘成乱。若心乱其身及心。皆成懈怠动摇。如是过患无边。起出入息。以无边懈故应作想如是心不乱。若心迟缓。若心利疾。不当精进。若作迟缓精进。成懈怠睡眠。若作利疾精进。成起调。若坐禅人。若与懈怠睡眠共起。若与调共起。其身及心成懈怠成动摇。此是过患。彼坐禅人以九小烦恼。清净心现念入息。彼相得起。名相者。如抽绵抽古贝触身成乐触。如凉风触身成乐触。如见入出息风触。鼻口唇念作风想。不由形色。此谓相。若坐禅人。以修多修相成增长若鼻端增长。于眉间于额。成多处住。成满头风。从此增长。满身猗乐。此谓具足。复有坐禅人。从初见异相。如烟如雾如尘如碎金。犹如针刺。如蚁所啮。见种种色。若坐禅人心不明了。于彼异相心作异想成颠倒。不成出入息想。若明了坐禅人。不作异意想。念现入息念现出息。离作余想。若如是作意。异相即灭。是坐禅人得微妙相。心不放逸。念现入息念现出息。彼相自在。以相自在欲起修行。由欲自在。念现入息。念现出息。起喜。已喜自在。已欲自在。念现入息。念现出息。起舍。彼已舍自在。已欲自在。已喜自在。念现入息。念现出息。其心不乱。若心不乱诸盖灭禅分起。此坐禅人已得寂灭胜四禅定。如初广说。复次先师说四种修念安般。所谓算随逐安置随观。问曰。云何名算。答曰。初坐禅人。从初出息乃至入息。从一至十。过十不算。复说从一至五。过五不算。不令意误。是时当算乃至离算。从入出息事念住此谓名算。随逐者摄算。以念无间逐出入息。此谓随逐。名安置者。或鼻端或于唇。是入出息所触处。于彼作风相令念住。此谓安置。名随观者。由触自在当随观相。于此所起喜乐等法应当随观。此谓随观。彼算为觉灭令得出离觉。随逐者。为灭粗觉。于出入息作念无间安置。为断于乱作不动想。随观者。为受持想为知胜法。若长入息若短出息。于短入息。如是学之者。方便所作过于其性。此谓长。性者现智智为现不愚痴事。问曰。云何不愚痴事。答曰。初坐禅人得身心倚。以入出息念现作住。其出入息成细。出入息细故。成不可取。时坐禅人若长息随观作长。乃至相起住。若相已起住。以性应作意。此谓不愚痴。复次当为心消息。有时作长有时作短。如是当修。复次坐禅人。以事令分明相起。是事当修。知一切身我入息。如是学者以二种行知一切身。不愚痴故以事故。问曰。云何无愚痴知一切身。答曰。若坐禅人念安般定。身心喜乐触成满。由喜乐触满。一切身成不愚痴。问曰。云何以事知一切身。答曰。出入息者。所谓一处住色身。出入息事心心数法名身。此色身名身。此谓一切身。彼坐禅人。如是以见知一切身。虽有身无众生无命。如是学者。谓三学。一增上戒学。二增上心学。三增上慧学。如实戒此谓增上戒学。如实定此谓增上心学。如实慧此谓增上慧学。彼坐禅人此三学。于彼事以念作意学之。修已多修。此谓学之令灭身行。我入息如是学。云何名身行者。此谓出入息。以如是身行。曲申形随申动踊振摇。如是于身行现令寂灭。复次于粗身行现令寂灭。以细身行修行初禅。从彼以最细修第二禅。从彼最细修行学第三禅。令灭无余修第四禅。问曰。若无余灭出入息。云何修行念安般。答曰。善取初相故。以灭出入息。其相得起成修行相。何以故。诸禅相知喜为事知我入息。如是学者。彼念现入息念现出息。于二禅处起喜。彼喜以二行成知。以不愚痴故。以事故。于是坐禅人入定成知喜。不以愚痴以观故。以对治故。以事故。成知乐我入息。如是学者。彼现念入息现念出息。于三禅处起乐。彼乐以二行成知。以不愚痴故。以事故。如初所说。知心行我息入。如是学者说心行。是谓想受。于四禅处起彼彼心行。以二行成知。以不愚痴故。以事故。以如初说。令寂灭心行我息入。如是学者说心行。是谓想受。于粗心行令寂灭。学之如初所说。知心我入息。如是学者。彼现念入息现念出息。其心入出事以二行成所知。以不愚痴以事故。如初所说。令欢喜心我入息。如是学者说令欢喜说喜。于二禅处。以喜令心踊跃。学之如初所说。令教化心我入息。如是学者彼坐禅人。现念入息现念出息。以念以作意。彼心于事令住令专。一心教化以彼心住。学之令解脱心我入出息。如是学者彼坐禅人。现念入息现念出息。若心迟缓从懈怠令解脱。若心利疾从调令解脱学之。若心高从染令解脱学之。若心下从嗔恚令解脱学之。若心秽污从小烦恼令解脱学之。复次于事若心不着乐。令着学之。常见无常我入息。如是学者。彼现念入息现念出息。其入出息及入出息事。心心数法见其生灭学之。常见无欲我入息。如是学者。现念入息现念出息。彼无常法彼法无欲。是泥洹入息学之。常见灭我入息。如是学者。彼无常法如实见其过患。彼我灭是泥洹。以寂寂见学之。常见出离我入息。如是学者。彼无常法如实见其过患。于彼过患现舍。居止寂灭泥洹。使心安乐学之。如是寂寂如是妙。所谓一切行寂寂。一切烦恼出离。爱灭无欲寂灭泥洹。于此十六处。初十二处成沙摩他毗婆舍那。见初无常。后四处唯成毗婆舍那。如是以沙摩他毗婆舍那可知。复次彼一切四种。一谓如是修令起观具足。有时见现念入息现念出息。此谓修知长短。令灭身行令灭心行。令心欢喜。令教化心。令解脱心。此谓令起知一切身知乐知心所行。知心者此谓观具足。常见无常所初四行。此谓有时见。复次修者。以念安般受持地是修。是安般念受持地。是受持是有觉。彼有觉有观有观地。知喜者是二禅地。知乐者是第三禅地。知心者是第四禅地。复次彼一切成二种。谓修及满。于是修行唯彼名满者。十六行不减。修者如种。功德因故。名满者。犹如花果。从相似出故。若如是修行念安般。成满四念处。修四念处满七菩提分。修七菩提分满明解脱。问曰。云何得如此。答曰。长出入息所初四处。成身念处。知起所初成受念处。知心所初成心念处。见无常所初成法念处。如是修念安般成满四念处。云何以修四念处。成满七菩提分。修念处时于念成住不愚痴。此谓念觉分。彼坐禅人如是念住。知择苦无常行。此谓择法菩提分。如是现择法行精进不迟缓。此谓精进觉分。由行精进起喜无烦恼。此谓喜觉分。由欢喜心其身及心成猗。是谓猗觉分。由身猗有乐其心成定。此谓定觉分。如是定心成舍。此谓舍觉分。以修四念处。成满七菩提觉分。云何以修七菩提觉分成满明解脱。如是多修行七觉分。于刹那道成明满。于刹那果成解脱满。如是修七菩提分。成明解脱满。问曰。一切诸行。由地成有觉无觉。如是念安般。何故唯说念安般。为除觉不说余耶。答曰。不依如此说觉。不住者是禅障碍。是故除觉依此义说。何故于风乐触。由心乐着如觉。乾闼婆闻声随着。是故断觉。复次如行堤塘。以心专念倚不动故。是故说念安般为除觉(念安般已竟)

问曰。云何念死。何修何相何味何处何功德。云何修。答寿命行断。此谓为死。彼念住不乱。此谓为修。自寿命断为相。厌患为味。无难为处。何功德者。若修行念死。于上善法成不放逸。成憎不善法。于诸服饰不多受畜。心不悭吝。见身寿命心不贪著作无常想苦想无我想。皆令成满。成向善趣向于醍醐。临命将终。心不谬误。云何修行。初坐禅人入寂寂。坐摄一切心。以不乱心念众生死。我入死法。向于死趣。不过死法。如涅底履波陀修多罗中说。若人乐观死。当观被杀人见死因缘。于是念死有四种。忧相应。惊相应。中人相应。智相应。如丧爱子心生缘念。此谓忧相应。悲念童子卒暴命终。此谓惊相应念。如阇维人念离生故。此谓中相应念。常观世间心生厌患。此谓智相应念。于是坐禅人。忧相应惊相应中相应不应修行。何以故不能除过患。唯智相应勤修行。能除过患。死者有三种。等死断死念念死。云何名等死。依修众生此谓等死。名断死者。谓阿罗汉烦恼已断。名念念死者。诸行念念灭。复次死有二种。不时节死时节死。或自杀或他杀。或以病。或无因缘中间死。此谓不时节死。或寿命尽乃至老死。此谓时节死。应念此二种死。复次以八行。先师所说修念死。如凶恶人逐。以无因缘。以本取。以身多属。以寿命无力故。以久远分别。以无相故。以刹那故。问曰。云何以凶恶逐修行念死。答曰。如被杀人将往杀处。以凶恶人拔刀随逐。彼见凶恶人拔刀随后。如是思惟。此人杀我。何时我当死。我行一一步于何步当死。我去必死。我住必死。我坐必死。我眠必死。如是坐禅人以凶恶人逐故。当修念死。问曰。云何以无因缘故修念死。答曰。无因缘无方便以生能令不死。如日月出无因缘无方便能令不没。如是无因缘故修念死。问曰。云何以本取故修念死。答曰。彼先多财王大乘王大神力大善见王顶生王等。彼一切王皆入死法。复次昔诸仙人大神通大神力。毗沙蜜多阇摩达梨仙人身出水火。复入死法。复次先声闻。有大智慧有大神通有大神力。舍利弗目犍连等。彼入死法。复次诸缘觉人。自生无师一切功德成就。亦入死法。复次诸如来应供正觉无量无上明行具足。到功德彼岸亦入死法。何况于我少时寿命。不当入死法。如是以先取故修念死。问曰。云何以身多属故修念死。答曰。以风痰和合成于死法。或诸虫种和合。或饮食不调成入死法。或毒蛇蜈蚣射蚰蜒鼠啮成入死法。或师子虎豹龙牛等兑成入死法。或人非人所杀成入死法。此身如是多所属故。修念死法。问曰。云何以寿无力故修念死。答以二行。以寿命无力故修于念死。处无力故。依无力故。成寿命无力。问曰。云何处无力故寿命无力。答曰。此身无自性如水泡喻如芭蕉喻。如水沫喻。无有真实。离真实故。如是处无力故。成寿命无力。问曰。云何依无力故成寿无力。答曰。此名出入息所缚。四大所缚。饮食所缚。四威仪所缚。缓所缚。如是依无力故成寿命无力。如是以此二行。以寿命无力故。修念于死。问曰。云何以远分别修念死。答曰。从于久远一切已生。于现在世不过百年皆入死法。所谓久远分别故修念死。复次当修。我于日夜讵能得活。日夜思惟。世尊诸法我得大恩。如是一日我讵能活。或复半日我讵能活。或复少时我讵能活。或一食时或半食时。我讵能活。或四五揣我讵能活。或入息时我讵能至出息时。或出息时我讵能至入息时。以久远分别故修念死。问曰。云何以无相故修念于死。答曰。以无有相死无有时。以无相故修念于死。问曰。云何以刹那故修念死。答曰。以不数过去未来。但数现在缘众生寿命。于一念时住。从彼无二念住。一切众生于刹那心没。如阿毗昙中说。于过去心。无已生。无当生。无现生。于未来心。无已生。无现生。无当生。于现在心刹那。无已生。无当生。有现生。复如说偈

  寿命及身性　　苦乐及所有
  与一心相应　　刹那速生起
  于未生无生　　于现在有生
  心断故世死　　已说世尽故

如是以刹那故修念死。彼坐禅人以此门以此行。如是现修念死。起其厌患。由厌患自在。以念自在成心不乱。若心不乱诸盖灭。禅分成起外行禅得住。问曰。无常想念死。此二何差别。答曰。阴生灭事名无常想。念诸根坏名为念死。以修无常相无我相为除憍慢。以修念死无常相及苦相成住。以寿断心灭。此谓差别(念死已竟)

问云何念身。何修何相何味何功德。云何修。答修念身性。彼念随念正念。此谓念身。此念住不乱。此谓修。令起身性为相。厌患为味。见无实为起。何功德者。以修念身成堪耐。堪受怖畏。堪任寒热等。无常想无我想。不净想。过患想。彼想成满。成随意得四禅。以分明诸法。修令满足。向于善趣。向于醍醐。云何修者。初坐禅人入寂寂。坐摄一切心。不乱心唯修心性。云何修心性。所谓此身发毛爪齿皮肉筋骨髓脑肝心脾胇胆胃肪膏脑膜大肠小肠屎尿脓血淡污涎泪涕唾不净。初坐禅人。于此三十二行。初次第上以次第下。善哉以口语言应常说常观。善哉以常观口语言。是时以一一四行。唯以心当觉以色以行以形以处以分别所起粗相。或一或二或多善取相应。彼坐禅人如是以三种觉成起。以色以厌以空。若坐禅人以色起相。彼坐禅人由色一切入自在应作意。若坐禅人以厌起相。彼坐禅人以不净应作意。若坐禅人以空起相。彼坐禅人以界应作意。若坐禅人依一切入起于四禅。若坐禅人依不净事起初禅。若坐禅人依界事起外行禅。于是嗔恚行人以色起相。贪欲行人以厌起相。慧行人以界起相。复次嗔恚行人以色当作意。贪欲行人以厌当作意。慧行人以界当作意。复次以十三行当念身性。如是以种以处以缘以流。以次第以形以虫种以安处。以聚以憎以不净以处。以不知恩以有边。问云何以种当念身性。答如毒种所生茱萸拘沙多纪等一切生。如是此身从父母不净生。不净种生此身成不净。如是以种当念心性。问云何以处当念身性。答此身不从郁多罗花生。非拘牟陀分陀利迦花生。于母腹生。不净臭秽迫迮处生。从生熟两藏生。从左右胁胞囊所缠依脊骨住。是处不净身成不净。如是以处当念身性。问云何以缘当念身性。答此不净身若增长住。不以金银珠等能得增长。复不以栴檀多伽罗沉香等缘能得增长。此身从母腹生。母所食啖。涕唾涎泪相杂。母胎所生臭食流液得增长住。从如是出。其所啖食饭乳粄豆。涕唾涎淡共相和杂。此身以臭不净流得增长住。如是以缘当念身自性。问曰。云何以流当念身自性。答如皮囊盛满屎尿。以多穿故不净流出。此身亦然盛满屎尿。如是此身所尝饮食。及杂涕唾屎尿臭秽。种种不净。从九孔流溢。以多穿故。不成满故。如是以流应念身自性。问云何以次第形当念身自性。答此身以初业次第立。初七日成迦罗逻。二七日成阿浮陀。三七日成俾尸。四七日成阿那。五七日成五节。六七日成四节。七七日复生四节。八七日复生二十八节。九七日及十七日复生脊骨。十一七日复生三百骨。十二七日复生八百节。十三七日复生九百筋。十四七日复生百肉丸。十五七日复生血。十六七日生膜。十七七日生皮。十八七日成皮色。十九七日业所生风遍处处。二十七日成九窍。二十五七日生一万七千凑。二十六七日成坚身。二十七七日有力。二十八七日生九万九千毛孔。二十九七日成一切身分具足

复说。七七日有体。依母背下头蹲踞坐。四十二七日以业所生风。转脚向上。头向下向产门。此时生。世说假名人如是。以次第形当念身性。问云何以虫种当念身性。答此身八万户虫之所食啖。依发之虫名发铁。依髑髅虫名耳肿。依脑之虫名颠狂下。颠狂复有四种。一名塸拘霖婆。二名湿婆罗。三名陀罗呵。四名陀阿尸逻。依目之虫名舐眼。依耳之虫名蚔耳。依鼻之虫名蚔鼻。复有三种。一名楼扣母可。二名阿楼扣。三名摩那楼母可。依舌之虫名勿伽。依舌根虫名母但多。依齿之虫名狗婆。依齿根之虫名优婆拘婆。依喉之虫名阿婆离呵。依颈之虫有二种。一名虏呵罗。二毗虏呵罗。依毛之虫名蚔毛。依爪之虫名蚔爪。依皮之虫有二种。一名兜那。二名兜难多。依膜之虫。复有二种。一名鞞蓝婆。二名摩諀蓝婆。依肉之虫复有二种。一名阿罗婆。二名罗婆。依血之虫复有二种。一名婆罗。二名婆多罗。依筋之虫复有四种。一名赖多虏。二名喜多婆。三名婆罗婆多罗。四名罗那婆罗那。依脉之虫名架栗侠那。依脉根之虫复有二种。一名尸婆罗。二名优婆尸尸罗。依骨之虫复有四种。一名遏褫(除里反)毗驮。二名安那毗驮。三名殆(涂履反)履拖毗拖。四名遏褫緪可罗。依髓之虫复有二种。一名弭(亡比反)社。二名弭社尸罗。依脾之虫复有二种。一名尼罗。二名比多。依心之虫复有二种。一名死毗多。二名优钵拖毗多。依心根之虫复有二种。一名满可。二名尸罗。依肪之虫复有二种。一名哿罗。二名哿罗尸罗。依膀胱之虫复有二种。一名弭哿罗。二名摩诃哿罗。依膀胱根复有二种。一名哿罗。二名哿罗尸罗。依胞之虫复有二种。一名娑婆罗。二名摩诃沙婆罗。依胞根之虫复有二种。一名赖多。二名摩诃赖多。依小肠之虫复有二种。一名帚赖多。二名摩诃赖多。依肠根之虫复有二种。一名波。二名摩诃死波。依大肠根虫。复有二种。一名安那婆呵。二名[巾*尃]果婆呵。依胃之虫复有四种。一名优受哿。二名优社婆。三名知社婆。四名先市婆。依熟藏之虫复有四种。一名婆呵那。二名摩诃婆呵那。三名陀那槃四名粉那母可。依胆之虫名必多离诃。依唾之虫名纤呵。依汗之虫名随陀离呵。依脂之虫名弭陀离呵。依强之虫复有二种。一名薮婆呵母。二名社摩契多。依强根虫复有三种。一名处呵母珂。二名陀虏呵母珂。三名娑那母珂。有五种虫。依于身前食于身前。依于身后食于身后。依于身左食于身左。依于身右食于身右。虫名栴陀死罗唇呵死罗不偷罗等。依下二孔有三种虫。一名拘楼拘罗唯喻。二名遮罗喻。三名寒头波拖。如是以虫居止当念身性。云何以安当念身自性。于足骨胫骨安住。胫骨于髀骨安住。髀骨于髂骨安住。髂骨于脊骨安住。脊骨于脾骨安住。脾骨于臂骨安住。臂骨于项骨安住。项骨于头骨安住。头骨于颊骨安住。颊骨于齿骨安住。如是此身骨节缠里以皮覆上成此秽身。从行业生非余能造。如是以安当念身自性。云何以聚当念身自性九头骨。两颊骨。三十二齿骨。七项骨。十四胸骨。二十四胁骨。十八脊骨。两髂骨。六十四手骨。六十四足骨。依肉六十四软骨。此三百骨。八百节。九百筋缠。九百肉丸。一万七千凑。八百万发。九万九千毛。六十间。八万虫种。胆唾脑各一波赖他。梁言重四两。血一阿咃。梁言以三升。如是等不可称计种种形。唯是屎聚屎集名身。如二聚当念身自性。云何以憎当念身自性。彼所重物第一清净。所爱服饰。如是花香涂身。衣服庄严。眠坐隐囊。枕褥[毯-炎+瞿]毹毾[毯-炎+登]床帐卧具等。种种饮食住止供养。心生爱重后成憎恶。如是以憎恶。当念身自性。云何以不清净当念身自性。如是衣物种种服饰。已不净洁。可更浣治还得清净。何故。以性清净故。此身不净不能令净。复次以香涂身。以香水洗浴不能令净。何以故。性不净故。如是以不清净念身自性。云何。以处当念身自性。如花依池生。如果依果处生。如是此身从种种烦恼疾患故生。如是眼痛耳痛鼻痛舌痛身痛头痛口痛齿痛。患嗽急气寒热腹痛。心闷痫狂风病霍乱。癞瘿吐血癣疮疥瘑麻閟寒病等。此身有无边过患。如是以处当念身自性。云何以不知恩当念身自性。其人虽复料理自身以最胜饮食。或洗浴摩香眠坐衣帔以自庄严。此毒树身反不知恩。向老向病向死。如亲友不知恩。如是以不知恩。当念身自性。云何以有边当念身自性。此身或可阇维。或可啖食。或可破坏。或可磨灭。此身有边。如是以有边当念身自性。彼坐禅人以此门以此行以自性。当念此身。以念自在。以慧自在。成不乱心。若不乱心诸盖灭。禅分起。随其所乐成得胜(念身已竟)

问云何念寂寂。何修何相何味何处何功德。云何修。答寂寂者。灭身心动乱。已伏断故。此谓寂寂。现念寂寂彼念随念正念。此谓念寂寂。以念住不乱此谓修。令起不动功德为相。不调为味。妙解脱为处。何功德者。若修行念寂寂。成安眠安觉。成寂寂。诸根寂寂心愿具足。成可爱惭愧具足。常为人所贵重。向善趣向醍醐。云何修彼者。初坐禅人入寂寂坐。摄一切心不起乱心。如彼比丘诸根寂寂。心寂寂乐一处寂寂。以相应住。彼比丘以身口意。若见若闻以寂寂念。以寂寂功德。如世尊所说。彼比丘戒具足定具足慧具足。解脱具足解脱知见具足。若比丘得见彼比丘。我说彼大种大恩。若闻彼比丘。我说大恩。若往彼我说大恩。若视供养。彼若念。彼若随出家。我说彼大得恩。何故如是等。诸比丘闻其说法。得二离愦闹。所谓身离愦闹。心离愦闹。彼比丘入初禅。以寂寂念诸盖灭。若入第二禅念彼觉观灭。若入第三禅念彼喜灭。若入第四禅念彼乐灭。若入虚空定念色想嗔恚想种种想灭。若入识定念彼虚空灭。若入无所有定念彼识入想灭。若入非想非非想定念彼无所有想灭。若入想受灭念彼想受灭。若得须陀洹果念见一处烦恼灭。若得斯陀洹果念粗淫欲嗔恚烦恼灭。若得阿那含念细烦恼淫欲嗔恚灭。若得阿罗汉果念彼一切烦恼灭。若入泥洹以寂寂念一切皆灭。彼坐禅人以此门以此行。如是以功德念寂寂。彼心成信。以信自在。以念自在。心成不乱。若不乱心诸盖灭。禅分起外行。禅成住念。寂寂已竟(十念已竟)

于十念处此散句。若念过去未来佛功德。此谓修念佛。如是念缘觉功德。若念善说一法。是谓修念法。若念一声闻修行功德。此谓修念僧。念彼戒此谓修念戒。念彼施此谓修念施。若欲乐念施施于有功德人。当取受相。若有人受施未施。乃至一抟悉不应食。念天者成就信有五。法当修念天

解脱道论卷第七解脱道论卷第八

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    行门品之五

问云何慈。何修何相何味何起何功德。云何修行。答如父母唯有一子。情所爱念见子起慈。起饶益心。如是于一切众生。慈心饶益心。此谓慈彼修住不乱此谓修。令起饶益为相。爱念为味。无嗔恚为起。若修行慈。成得十一功德。安眠。安觉。不见恶梦。为人所爱念。为非人所爱念。诸天守护。火毒刀杖不加其身。使心得速定。面色悦泽。命终不乱。若未得胜法生梵世。云何修行。初坐禅人。乐修行慈。初观忿恨过患及忍辱功德。心应受持忍辱。云何当观忿恨过患。若人初起忿恨。焚烧慈心。令其心浊。从此增长面目嚬蹙。从此增长口说恶语。从此增长观于四方。从此增长手捉刀杖。从此增长嗔忿吐血。从此增长散掷财物。从此增长打坏诸物。从此增长或杀他或自杀。复次若人恒忿恨。或杀父母。或杀阿罗汉。或破僧。或恶心出佛身血。如是作可畏事。如是当观。复次如是当观。我名声闻。若不断忿恨成可羞惭。我忆锯喻。修多罗中所说。我乐善法。若我今忿恨增长。成可憎恶。如人乐浴还入不净。我自多闻。若未伏忿恨。人所弃薄。犹如医师还自霍乱。我为世所为贵若我不除忿恨。人所弃薄。犹如画瓶内盛不净而不覆蔽。若人有智慧而犹起忿恨。如人故食杂毒。何以故。从此忿恨。最可弃薄。成苦果报。如人为毒蛇所啮。自有毒药而不肯服。彼人可知乐苦不乐乐。如是比丘。若忿恨起不速制伏。彼比丘可知乐苦不乐乐。何故从此忿恨最为可畏。复次当观忿恨。忿恨者为怨家所笑。为亲友惭愧。虽有深德复被轻贱。本所贵重翻成轻易。若已得称誉。咸被讥毁。若求乐成苦。若不动成令动。若有眼成盲。若聪明成无智。如是当观忿恨过患。问云何观忍辱功德。答忍辱是力是铠。能护身能除忿恨。是称誉。智人所叹。是乐令不退。是守护令护一切具足。是晓了令观诸义。是名为起惭愧。复次当观。我已剃头唯应忍辱。是我所受我已受国施。以忍辱心令彼施主有大果报。我持圣形饰。我此忍辱是作圣行。我有嗔恚令无嗔恚。我名声闻。今实名声闻。彼檀越施我杂物。以此忍辱令彼施主得大果报。我有信。此忍辱是我信处。我有智慧。此忍辱是智慧处。我有忿恨毒。此忍辱是我却毒药。如是观忿恨过患及忍辱功德。令心受持。我当向忍辱。人有恶骂我当忍辱。我当软无憍慢。如是坐禅人向忍辱乐。作自饶益。入寂寂处。不乱心。从初其身令满。我复乐乐心不耐苦。云何我无怨家无嗔恚。乐离诸烦闹。成就一切功德。彼坐禅人制伏其心。作软心作堪受持心。若心成软堪受持事。从此应修行慈。于一切众生如其自身若坐禅人修行慈。于一切众生。从初不能修慈。于怨家中人恶人无功德人亡人处起慈。彼坐禅人所贵重人。为起惭愧。不为轻贱。不为所中。为饶益故起慈。于彼不起嫉不嗔恚。是彼人处初当修慈。初当念其饶益功德贵重功德。如是以性成就。以称誉成就。以闻成就以戒成就。以定成就。以慧成就。我所贵重。如是以施以爱语以利益以同事成就。是我饶益。如是善念所重功德及饶益功德。令起重想及亲友想。于彼人处当修行慈。当作饶益心常觉观。愿无怨心。愿无嗔恚。成于安乐。愿离一切闹。愿成就一切功德。愿得善利。愿有称誉。愿有信。愿有乐。愿有戒。愿有闻慧。愿有施。愿有慧。愿得安眠。愿安觉。愿不见恶梦。愿人所爱敬。愿非人所爱敬。愿诸天守护。愿火毒刀杖等不着身。愿速得定心。愿面色和悦。愿生中国。愿值善人。愿自身具足。愿无疾病。愿得长寿。愿恒得安乐。复次如是应思惟。于彼不善法。若未生愿令不生。若已生愿灭断。彼善法未生愿生。若已生愿增长。复次彼不爱念法愿不生。若已生愿灭。彼可爱念法未生。彼由慈心得信。彼坐禅人以信自在取心。以取自在令念住。以念自在以取自在。以信自在成不乱心。彼现知不乱。以此门以此行。于彼人修慈心。修已多修。彼坐禅人现知不乱。以此门以此行。于彼人修已。多修慈心。以软心受持心。次第于爱中人修慈想。于所爱人已修慈想。次第于中人当修慈想。于中人已修慈想。次第于怨家当修慈想。如是于一切众生。犹如自身。令满作分别。若如是修行慈。若中人处彼慈不行。若坐禅人暂不起慈。当作厌患。于我不善不可爱。我乐得善法信心出家。我复说言。依大师故。饶益众生起大慈悲。于一中人不起慈心。何况于怨家。若如是厌患嗔恚不灭。彼坐禅人为修慈。不应精进。以余方便应修行。于彼人为除嗔恚。问云何方便除嗔恚。答与彼应作周旋。应思惟其功德恩。自业所作。负债解脱亲族自身罪过。不应作意。自现苦诸根自性念灭。知念应当观空。应作摄受。彼人虽生嗔恚若有所乞随宜施与。若彼有所施。亦随宜取与。常共善语。彼所作事亦当随从。如是摄受因彼此嗔恚成灭。于功德者。若见其功德。是功德应思惟。不为非功德。如水有草除草取水。若彼无功德应起慈。此人无功德。当向恶趣。恩者应思惟彼恩。若人作不爱敬令起恩。于彼若已作不爱敬。应作功德。复次已令灭不善是善趣。彼怨成作恩可知。自业所作者。是人所作恶法。是人所嗔处。于彼恶业当生观。负债解脱者。若人骂我害我。是初恶业。彼负债解脱。我今作证以观当作欢喜。亲族者。于生死众生相续。是我亲族。已忆应令起亲族想。自身罪过者。其作我相。彼嗔恚从我生。为彼得非功德。我成相令起自罪过相。不应作意者。无嗔恚相。不应作意。如人不乐见色闭眼。苦者为自苦无障碍。应令起相。何故如愚痴人。以慈不正忆自作苦。因得心苦如是观。可知于有怨家处。从彼应离其处。使不见不闻。于处当住诸根。自性者。取可爱非可爱境界。诸根自性于此我嗔恚。因是不正忆。如是当观。念灭者。以彼生苦彼得苦。此一切法于一心刹那得灭。我何故与彼非嗔处。我当作嗔。如是当观。和合者。内外不一分和合故生苦。我于一分处。不堪作嗔恚心。如是当观。空者。是人作苦是人受苦。彼第一义不可得。此身因缘所生。无众生无我界聚草聚等。如是当观。是故世尊说偈

  于村林中住　　诸苦乐所触
  非从自他烧　　依烦恼得触
  若无烦恼心　　谁能触细滑

彼坐禅人如是嗔恚灭。方便明了。于自亲友中人怨家。已作分别。已得自在。心次第起慈想。当修住处。种类比丘从彼当修。住处僧众从彼当修。自住处诸天从彼当修。自住处众生从彼当修。自住处外村。如是从村至村。从国至国。从彼当修一方。彼坐禅人以慈心已令满一方。从彼二方。从彼三方。从彼四方。从彼四维上下。于一切众生放慈悲。一切世间以慈心最大无量。无怨无嗔恚令满。彼坐禅人如是修行慈。以三种令安禅。以总摄众生。以总摄村田。以总摄方。以一众生令安慈禅。如是二三众生。乃至众多。于一村田众生。令安慈禅。乃至多村。于一方作一众生令安慈禅。如是乃至四方。于是若依一众生修行慈。若其众生死其事成失。以失事不堪起慈。是故应广修慈心。乃至广行。是时成妙修行。成大果成大功德。问慈者何根何起何具足何非具足何事。答不贪为根。不嗔恚为根。不痴为根。欲为根。正作意为根。何起者。是根令起。何具足者。若慈成就。杀除嗔恚。除不善爱。令身口意业清净。此谓具足。何非具足者。以二因失慈。以自朋生怨。以不善爱。以对治生怨。以起嗔恚。此谓非具足。何事者。于众生为事。问不然。第一义众生不可得。云何说众生为事。答依诸根种于世假说众生。尔时菩萨摩诃萨修慈流。于一切众生遍满十波罗蜜。问何故然。答菩萨摩诃萨。于一切众生行慈。缘饶益成摄受众生。施于无畏。如是满檀波罗蜜。菩萨摩诃萨。于一切众生。行慈依饶益于一切众生。成无苦不失法用。如父于子。如是满戒波罗蜜。菩萨摩诃萨。于一切众生行慈。依饶益一切众生。成无贪意。出离非饶益。向禅向出家。如是满出波罗蜜。菩萨摩诃萨。于一切众生行慈。依饶益一切众生。成多思惟饶益非饶益。如义说方便明了。为除恶为得善。如是满般若波罗蜜。菩萨摩诃萨于一切众生行慈。依取饶益。不舍精进。一切时坚精进相应。如是满精进波罗蜜。菩萨摩诃萨行慈。于一切众生。依饶益彼众生。恶语骂詈。成忍辱不忿恨。如是满忍辱波罗蜜。菩萨摩诃萨。于一切众生行慈。依饶益于一切众生。说实语于实住受持实。如是满实谛波罗蜜。菩萨摩诃萨。于一切众生行慈。依饶益于一切众生。乃至失命誓不舍。愿成坚受持誓愿。如是满受持波罗蜜。菩萨摩诃萨。于一切众生以自相饶益。满慈波罗蜜。菩萨摩诃萨。于一切众生修慈。于亲友中人怨家。平等心离嗔恚爱。如是满舍波罗蜜。如是菩萨摩诃萨修行慈。成满十波罗蜜。明慈满四受持。尔时菩萨摩诃萨。修慈已满十波罗蜜。成令满四受持。所谓谛受持。施受持。寂寂受持。慧受持。于是谛波罗蜜受持波罗蜜精进波罗蜜。令满谛波罗蜜。施波罗蜜戒波罗蜜出离波罗蜜。令满施受持。忍辱波罗蜜慈波罗蜜舍波罗蜜。令满寂寂受持。慧波罗蜜令满慧受持。如是菩萨摩诃萨。已修慈遍满。满十波罗蜜。令满四受持。令满二法。所谓奢摩他毗婆舍那。于是谛受持施受持寂寂受持。令满奢摩他。慧受持令满毗婆舍那。已满奢摩他。令满一切禅解脱定正受。令起双变定及大悲定。已满毗婆舍那。令满一切神通辩力无畏。已满令起自然智一切智。如是菩萨摩诃萨修行慈。次第令满佛地(慈已竟)

问云何悲。何修何相何味何起何功德。云何为修。答如父母唯有一子心所爱念。见子得苦心起悲恼。苦哉如是。于一切众生起慈怜愍。此谓为悲。悲住不乱此谓修。不现非饶益为相。乐为味。不害为起。与慈等功德。云何修者。初坐禅人入寂寂坐。摄一切心。以不乱心。见彼得病得老得贫。若见若闻如是作意。彼众生得苦。云何方便从苦当得解脱。复次若见其颠倒。为烦恼缠所缚入于无明。或有功德人而不修学。若见若闻如是作意。众生得苦当生恶趣。云何方便从苦得脱。复次若见不善法相应善法不相应。以不可爱法相应可爱法不相应。若见若闻如是作意。彼众生得苦。当生恶趣。云何方便从苦得脱。彼坐禅人以此门以此行。于彼人修行悲。心多修行。彼坐禅人以此门以此行。于彼人已修悲心。已多修悲心。心成和软堪能受持。彼次第修行于中人。从彼修行于怨人。余如初广说。乃至满于四方。问何悲具足。何悲不具足。答若悲成就。除于杀害不起忧恼。除不善爱。以二因缘失悲。以自亲生怨。以忧恼行。以对治生忿。以起恐怖。问苦者不于一切众生有。不一切时有。云何于一切众生修于悲。答众生已得苦。善取相故。已取彼相。成一切处修悲。复次生死之苦。一切众生共有。由彼成一切处修行(悲已竟)

问云何喜。何修何相何味何起何功德。云何为修。答犹如父母唯有一子心所爱念。见子得乐心生欢喜。善哉如是。一切众生心生欢喜。此谓为喜。喜住不乱此谓为修。欣悦为相。无怖为味。除无乐为喜。与慈等功德。云何为修者。初坐禅人入寂寂坐。摄一切心不乱心。其人性所敬重。见得安乐心生欢喜。若见若闻如是作意。善哉善哉。愿彼众生长得欢喜。复次若见与不善法不相应。与善法相应与。不可爱法不相应与可爱相应。若见若闻如是作意。善哉善哉。愿彼众生长得欢喜。彼坐禅人以此门。以此行。于彼人修喜心。以多修行。彼坐禅人。以此门以此行。于彼人已修喜心。已多修行。成和软心堪能受持。从彼次第修行于中人。从彼修行于怨人。余如初广说。乃至喜满四方。喜何具足何不具足。若喜成就除不乐。不起不善爱除绮语。以二因失喜。以自亲生怨。以戏笑起行。以对治生怨。以不乐起。如初广说(喜已竟)

问云何舍。何修何相何味何起何功德。云何为修。答犹如父母于一子。非可念非不可念成舍。于彼成中心如是于一切众生舍护中心。此谓舍。舍住不乱。此谓修。无所著为相。平等为味。伏恚爱为起。与慈等功德。问云何为修。答坐禅人从初与慈俱起。与悲俱起。与喜俱起。已起第三禅。彼坐禅人已得第三禅。自在见慈悲喜过患。爱恚近故。与戏俱起。与踊跃欢喜共起。以过患对治。见舍功德。彼坐禅人。如是已见慈悲喜过患。已见舍功德。从初于非可爱念非不可爱念人。已与舍俱起念。令心满足。舍心增长。已修多修心成和软。堪能受持。彼次第于怨人修行。从彼于亲友人修行。余如初广说可知。乃至满四方。彼坐禅人。如是修行。与舍俱起。第四禅以三种令安。已总摄众生。已总摄村田。已总摄诸方。问若坐禅人现修行舍。于诸众生云何作意。答作意所说。于慈悲喜是当作意。于诸众生除作欢喜。行欢喜作意乐中。如人亲友久远别离。初见荣侍心生喜乐。共住已后其心成中。如是住慈悲喜。久复成舍摄受。如是作意修行于舍。复有人说。众生众生者如是作意。云何舍具足舍不具足。若舍成就杀除嗔爱。不起无明。以二因失舍。以自亲生怨。以起无明。以对治生怨。以嗔爱起(舍已竟)

重明四无量义

云何无量散句。四无量以一众生事起。依余处修行。如母念儿随其时节。如是于畜生。于犯戒人。于具戒人。于厌欲人。于声闻人。于缘觉。于正遍知。归依胜处。成胜无量可知。问于慈悲喜。何故三禅起。非第四禅。答众生忧恼所起。嗔恚害不乐。彼忧恼以对治。与喜俱生心。修行慈悲喜。是故三禅生非第四禅。复次舍地是第四禅。以二舍成就故。所谓受舍法中舍。于舍地住。于众生取饶益成舍。由地故三无量三禅生非第四禅。复说于四无量四禅生。如世尊所说。于四无量。汝比丘当修。此定有觉有观。汝当修有觉无观。汝当修无觉无观。汝当修与喜俱生。汝当修与乐俱生。汝当修与舍俱生。问此四无量何故说四。非三非五。答若然一切所疑。复次为嗔恚害无乐。嗔爱对治故成四无量。复说此四唯慈。由人多起嗔恚害恼。为除故以四门成胜。舍者慈悲喜清净。嗔爱对治故。四无量一性。种种相可知。如是过患对治故。众生事故。饶益意故。成一相。复说。法胜故。取事胜故。取饶益胜故。成种种相。如世尊说。于黄衣修多罗中。于清净处慈为第一。于虚空处悲为第一。于识处喜为第一。于无所有处舍为第一。问云何得知。答由依彼近故。其义可知。问何故。答修慈心。于一切众生。随从其意。以常随从。于青黄一切入。现令作意。以小方便令心得安。是众生种类事。或色界清净。一切入放意。彼坐禅人。是时色界得第四禅。是故说慈于清净第一。彼坐禅人依色界第四禅慈。是时得越彼。问此浅云何。答以修慈故。心知色界过患。何故见众生苦。彼为色因生慈。从此以心知色界过患。于色出离现令作意。于虚空处以小方便。其得心安。以得依故。是故说悲于虚空第一。彼坐禅人。依喜越虚空处。问此义云何。答已修喜故。心无所著。常取无边识事。何故此喜于无所著无边识处安众生事。从此心无所著。常取无边识事。离色着于虚空。无边识现令起作意。以小方便其心得安。种类事故。是故说识处为喜第一。问彼坐禅人。依舍越识处。此义云何。答已修舍故。心成离着。何故不以修舍得着。此众生得乐得苦。或由喜或由乐。从彼以心离着。离无所著无所有处。现令心喜。以小方便其心成安。不着种种事。何故于无所有处。而不得着或识或无边。是故说无所有处舍为第一(散句已竟)

问云何观四大。何修何相何味何起何功德。云何修。答择智自相内四大。此谓观四大。彼心住不乱。此谓修。随观四大为相。通达空为味。除众生想为起。何功德者。成得八功德。若修行观四大。成能堪恐怖乐不乐。于可爱非可爱成平等心。除男女意思。成大智慧。向善趣向醍醐。其所有明分法。彼一切成满修行。云何修彼者。初坐禅人。以二行取诸大。以略以广。问云何以略取诸大。答彼坐禅人入寂寂坐。摄一切心不乱心。此身以四大可称。于此身一切见界。湿性是水界。热性是火界。持性是地界。动性是风界。如是此身唯有界。无众生无命。如是以略取诸界。复有说。彼坐禅人。以略取诸界。以身依膜分别。或以色。或以形。或以处或以分别。彼坐禅人已略取诸界。依膜分别一切身性。或以色。或以形。或以处。或以分别。依肉分别此身。或以色。或以形。或以处。或以分别。彼坐禅人依肉已分别一切身。或以色。或以形。或以处。或以分别。彼坐禅人依脉分别一切身。或以色。或以形。或以处。或以分别。彼坐禅人依脉已分别一切身。或以色。或以形。或以处。或以分别。从此复依骨分别一切身。或以色。或以形。或以处。或以分别。彼坐禅人于此四行。以此四行伏心。令伏作软心。令心受持。彼坐禅人于此四行。以四行伏心。已作软已令受持。于此四行有坚性是地界知之。有湿性是水界知之。有热性是火界知之。有动性是风界知之。彼坐禅人于此四行。唯有界无众生无命。以比余行成住。如是以略取诸界。云何以广取诸界。以二十行广取地界。于此身发毛爪齿皮肉筋脉骨髓肾心肝胇脾胃大肠小肠胞屎脑。以十二行广取水界。此身有于胆唾脓血汗脂泪肪水唾涕涎尿以四行广取火界。以是热以是暖。以是温以是平等消饮食啖尝。此谓火界。以六行广取风界。向上风。向下风。依腹风。依背风。依身分风。出入息风。如是以四十二行见此身。唯有界无众生无命。如是已广取诸界。复次先师说。以十行当观四大。所谓以语言义。以事。以聚。以散。以无所著。以缘。以相。以种类非种类。以一义种种义。以界释第一。以言语义章。问云何以语言分别诸界。答二界语言同。所谓同言胜言。于是四大此同言。地界水界火界风界。此谓胜言。问此四大何义。答大生名大。有大非实义。令现实义。是故名大。大者鬼等形名大。云何大生名大。诸界大生。如世尊所说偈

  略说地相　　有二十万　　四那由他
  水四十万　　八那由他　　风住虚空
  乃九十万　　六那由他　　世界所住
  亦以火成　　世界之中　　有诸光焰
  上至梵世　　乃极七日　　如是大生
  是故名大

问云何大非实义令现实义。答名大界者。非男非女以男女色可见。界者非长非短。以长短色可见。界者非树非山。以树山色可见。如是大非实义令现为实义名大。云何诸鬼等异形。如鬼入人身成其身。以鬼形成起四行。或身强或尿热或轻动。如是于身以火界和合成起四行。以地界和合成坚。以水界和合成流。以火界和合成热。以风界和合成轻动。如是鬼形等名大。大者是语言义问地界水界火界风界者何义。答广大名地义。可饮守护是水义。令光明是火义。去来是风义。界者何义。持自相为义。复次地自性是地界。水自性是水界。火自性是火界。风自性是风界。云何地自性。是坚性强性厚性不动性安性持性。此谓地性。云何水性。湿性泽性流性出性。满性增长性喜性结着性。此谓水性。云何火性。热性暖性蒸性熟性烧性取性。此谓火性。云何风性。持性冷性去来性轻动性低性取性。此谓风性。此界义。如是以语言义应观界。问云何以事观界。答地界持为事。水界结着为事。火界令熟为事。风界遮为事。复次地界立为事。水界下入为事。火界令上为事。风界动转为事。复次二界近故成举初步。复次二界近故成举后步。二界近故成初坐卧。复次二界近故成后行立。二界近故成初懈怠睡眠。二界近故成后精进勇猛。二界近故成初重。二界近故成后轻。如是以事观四大。云何以聚观四大。聚者。地界水界火界风界。依此界成色香味触。此八法或多共生住不相离。此合和名聚。彼复成四种。地聚水聚火聚风聚。于是地聚地界成最多。水界火界风界次第成最少。于水聚水界成最多。地界风界火界成最少。于火聚火界成最多。地界风界水界成最少。于风聚风界成最多。火界水界地界次第成最少。如是以聚观诸界。问云何以散观四大。答观于地界从于最细邻空微尘生。此地为水所和故不散。为火所熟成不臭。为风所持成转。如是观。复先师说。中人身地界碎之为尘。成一斛二升。是时以水和合。成六升五合。以火令熟随风起回转。如是以散观诸界。问云何以不相离观四大。答地界水所摄火所熟风所持。如是三界和合。水界者住于地处。火所熟风所持。如是三界所摄。火界者住于地处。水所摄风所持。如是三界所熟。风界住于地处。水所摄火所熟。如是三界所持。于地住三界。水所摄三界不散。火所熟三界成不臭。风所持三界得转直住不散。如是此四界依展转成住不散。如是以不离观诸界。问云何以缘观诸界。答四因四缘为起诸界。云何四。所谓业心时食。云何业从业所生。四界以二缘成缘。以生缘以业缘。余界以依缘成缘。心者从心所生。四界以六缘成缘。以生缘。以共生缘。以依缘。以食缘。以根缘以有缘成其缘。余界以缘以依缘以有缘。于入胎时心。诸色以七缘成缘。共生缘展转缘依缘食缘根缘报缘有缘。后生心为初生。身以三缘成缘。所谓后生缘依缘有缘。此时为时所成。四大以二缘成缘。生缘有缘。余界以二缘成缘。依缘有缘。此食从为食所成。四大以三缘成缘。生缘食缘有缘。余界以二缘成缘。所谓依缘有缘。于是从业生四界共生界。展转以四缘成缘。所谓共生缘展转缘。依缘有缘。余界以缘成缘。所谓依缘有缘。如是从心生。从时生。从食生可知。地界者为余界住处缘成缘。水界者为余界作结着缘成缘。火界者为余界作熟缘成缘。风界者为余界作持缘成缘。如是以缘观诸界。问云何以相观诸界。答坚相地界。湿相水界。热相火界。冷相风界。如是以相观诸界。问云何以类非类观诸界。答地界水界一种类。以重故。火界风界一种类。以轻故。水界火界非类。水界能灭火界令燥。是故非类。地界风界展转非种类。地界障风界行。风界能灭地界。是故非种类。复次或四界展转种类。以展转缘故。或展转非种类。以自相故。如是以种类非种类观诸界。问云何一性种种性观诸界。答从业生四界。以从业生。所谓一性以相种种性。如是从心生。从时生。从食生。可知四因缘地界。以相一性以因。所谓种种相。如是四因缘风界火界。风界可知。四界以界一性。以大一性。以法一性。以无常一性。以苦一性。以无我一性。以相种种性。以事种种性。以业种种性。以心种种性。成种种性。以时种种性。成种种性。以食种种性。成种种性。以种种性。成种种性。以地种种性。成种种性。以生种种性。成种种性。以趣种种性。成种种性。如是。以一性种种性观诸界。问云何以观界隶。答如巧隶师。以材木作人。一切身分具足。随逐行走。内绳所连。外假泥饰。形色如人。宝衣庄严。或男或女。以人牵绳。或行或舞或倚或坐。如是此界隶名身。以初烦恼为隶。师所作身分具足为筋。绳所连以肉为泥。以皮为色。虚空为孔。宝衣庄严名为男女。以其心事为风界所牵。或行或住或去或来或申或缩或语或说。此界隶人。与识界共生。以忧恼因缘。成忧悲苦恼。或笑或戏或相拍肩等。食者支持界隶。命根者受持界隶。以命终界隶分散。若有业烦恼。复更起新界隶。如是生界隶。其初不可知。其后不可知。如是以界隶观诸界。彼坐禅人。如是以此门以此行。唯观此身以界隶。无众生无寿命。是时观以界事。以生心数法受想行识。彼坐禅人已观名色。从彼观名色。是苦是贪爱是苦集。观贪爱灭是苦灭。观八正道。是苦灭具足。彼坐禅人已广观四谛。是时见苦过患。以无常以苦以无我。常思惟不散。以慧见苦灭功德。以寂寂以妙离。彼坐禅人。如是现见苦过患见灭功德。正安于根力觉分。从行相心起。证醍醐界(观四大已竟)

问云何于食不耐想。何修何相何味何处何起何功德。云何为修。答以所啖尝饮食。彼作意悉不耐彼想。知正知。此谓不耐食想。彼想住不乱。此谓修。于食取过患为相。厌为味。伏气味爱为起。何功德者。成得八功德。若修不耐食想。知揣食想。知五欲具足。知色阴。知不净想。在身念成修满。从气味爱缩离彼心。向善趣向醍醐。云何修彼者。初坐禅人入寂寂坐。摄一切心不乱心。以所啖尝饮食作不耐意。如是种种百味经营。清净人所贵重。色香具足所堪大贵。如此饮食入身。变成不净。成不耐成臭腐。成可憎恶。以五行修行不耐食想。所谓以经营以散用以处以流以聚。问云何以经营修行不耐食想。此坐禅人。见诸众生。为经营饮食困。行种种恶法。或杀害或偷盗。亦见彼众生受种种苦。知彼所杀害所缚。亦见众生造种种恶事。或乞索或欺诳。诈现精进。见食如是令起厌患。以不清净屎尿流溢。饮食为因。彼作恶业如是。复见出家人。住清净山林。种种花香禽兽吟啸善人所造。或于田野庄严具足。树影林水取他人意。平舒净妙无诸高下。人见惊讶无诸喧杂。是出家人修菩提处。等梵天居。如是住处心无贪着。常行禅诵乐修善事。或于寒热风尘泥雨诸山崄处。为经营食因于捉钵入家乞食。彼见如是心起厌患。饮食不净屎尿流出。此经营食。是彼因故。如是当舍求第一乐。复次见出家人修行为乞食。或于马象恶兽中。或狗野猪处。或恶人所。或不净处。践踏泥屎。于他家门。少时默住。以衣护身。为得揣食生疑。或见彼食。犹如狗食。于食起厌。此经营食。最可憎恶。何用经营。但从他乞。如是以经营。修行食不耐想。云何。散用修食不耐想。彼坐禅人。如是所得经营饮食。于彼坐食。以湿鲑相杂和软。以手为簸。以口为臼。以唇收聚。以齿为杵。以舌翻转。以涎唾淡血共相和合。最可厌恶。如狗呕吐不可见故。如是以散用修行不耐食想。问云何以处修行不耐食想。答如是此食所吞入腹。与不净和合住。生熟藏以百虫种之所啖食。以暖所熟成第一厌。如人呕吐置不净器。如是以处修行不耐食想。问云何以流修行不耐食想。答此食暖所熟。与新故不净和合。如酒置破杯器。如是一切身流。随流入于脉腠面目。九孔九万九千毛孔。皆悉流满。此食如是流成五分。一分诸虫所啖。一分火所销。一分支持身。一分成尿。一分成体。如是修行不耐食想。问云何以聚修行不耐食想。答此流食成身发毛爪等。令起百一身分。若不成流。令起百一病恼。如是以聚修行不耐食想。彼坐禅人。以此门以此行。如是修行不耐食想。成住厌食。以厌自在心成不乱若心不乱诸盖灭禅分起。外行禅成住(不耐食想已竟)

无所有处。及非非想处。如初地一切入门所说。于是说偈

  坐禅人行处　　所说唯面形
  如人善示导　　波利弗多国
  略说得知广　　晓了其前后
  恒观如非如　　于此已广说
  如是具足相　　彼一切功德
  如法当分别　　解脱道行处

(三十八行品已竟)

解脱道论卷第八解脱道论卷第九

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    五通品第九

尔时坐禅人。如是已作定自在。住于第四禅。能起五神通。所谓身通天耳通他心智通宿命通天眼通。身通者变义天耳者越人耳义。他心智者了他意义。宿命者忆前生义。天眼通者过人眼见。问几种变阿谁修变。云何应起变。答变有三种。谓受持变。作变。意所作变。云何受持变。彼坐禅人以一成多以多成一。以身增长乃至梵世。此谓受持变。云何作变。彼坐禅人舍自性身现童子形。或现龙形。或现梵王形。如是等此谓作变。云何意所作变。彼坐禅人从此身化作余身。随意所造一切身分诸根具足。此谓意所作变。复次变有七种。所谓智变定变圣变。业果报所生变。功德人变。明术所造变。方便变。问云何智变。答以现无常为断常想。成智辩变。以阿罗汉道断一切烦恼。成智辩。此谓变智辩。如长老薄拘罗。长老僧吉栗者。长老部吼多波罗。此谓变智辩。问云何变定辩。答以初禅断诸盖成变定辩。以非想非非想定断无所有变定辩。长老舍利弗多。长老先时婆。长老昆檀若。郁多罗优婆夷沙摩婆底优婆夷。此谓变定辩。问云何圣辩。答若比丘乐于不耐。当住非不耐想。成住有非不耐想。若比丘乐于非非耐。当住不耐想。成住有不耐想。若比丘乐于非不耐及非非耐想。当住非非耐想。成住有非非耐想。若比丘乐于不耐及非。非耐当住不耐想成住有不耐想若取。问云何于非不耐住不耐想。答于爱念处以不净令满。或以无常取。问云何于不耐及非不耐。住非不耐想。答于不爱念及爱念处。或以慈令满。或以界取。问云何于非不耐及不耐。住不耐想。答于爱念及不爱念处。或以不净令满。或以无常取。问云何于不耐及非不耐。离二句住舍念现知。答此比丘以眼见色。成不欢喜不忧。成舍住念现知。如是于一切门。此谓圣辩。问云何从业报生变。答一切诸天一切诸鸟。有人者有恶趣生者。飞行虚空作变。此谓从业报生变。问云何有功德人变。答转轮王。树提长者。阇提长者。瞿师罗长者。复说有五大功德人变。此谓有功德人变。问云何明术所造变。答持明术人。读诵明术。能飞行虚空。或现作象。或变作马。或变作车。或变作步。现种种军。此谓明术所造变。问云何方便变。答以出离断贪欲。以罗汉道断一切烦恼。如陶师等其业具足。于是正方便生故。一切事变。此谓方便变。问云何谁修变辩。答于虚空为九。或于虚空为五。一切入以作第四禅自在。是其修变辩。复说色界第四禅以作胜故。是其修变辩。复说四禅二自在。是其修变辩。问云何当起变。答此比丘修欲定胜行相应如意足精进定心定慧定。亦如是欲者欲乐作变。定者心不乱。彼坐禅人欲乐变变意修行定。受持四种精进。未生恶不善法为不生。已生恶不善法为断。未生善法为生。已生善法为增长为不忘。为更起为修满。此谓胜行成就者。唯彼三法为满语言。六分成就。如意足者。为得如意作道。唯彼法如意足。复次是欲定胜行成就。此谓如意足。为得如意。以初义修者。修彼法多修。此谓修欲定胜行成就如意足。彼坐禅人。如是现修。是其方便。或退或住。彼以精进令起成精进定胜行。成就如意足。若彼方便迟若退若惊怖。彼心迟作速相。意若心退作定心。若心惊怖作舍相。彼成心定胜行。成就如意足。彼若无有烦恼心。欢喜分别饶益不饶益。修行诸法。是其修时。复此法是不修时。彼成分别定胜行。成就如意足。彼坐禅人修四如意足。以作自在心。其身随心其心成随身。彼坐禅人于时安身。于心安心于身。以由身心变。以由心身变。以由身心受持。以由心身受持。或乐想或轻想着于身。于着成住。彼坐禅人如是现修成最轻。其身成最软最堪受持。如铁丸为火所烧随意作物。如是以修心成身轻。以轻故入第四禅。安详念出能分别虚空。以智受持。如是于虚空此身当起。以智受持。于虚空成起。如风吹绵缕。于是初坐禅人。不当速远行。何故其来作观。当起怖畏。若有怖其禅成退。是故初坐禅人。不当速远行。以次第当行。最初以一尺渐渐上以观。复依彼相作精进一寻。以此方便次第随其所乐当起。问彼坐禅人于虚空或从禅退。彼从虚空转当落地耶。答不然。是从其先坐处起若远行。退者还至先坐处。其见自身如先坐。有神通人。是其止法。彼坐禅人。如是次第作观。至受持自在作。不一种变。以一成多。以多成一。或现彻过壁彻过墙彻过山。身行无碍犹如虚空。于地或没或出犹如在水。于水上行犹如行地。行于虚空犹如飞鸟。手摸日月。如是大神通如是大力身。乃起至于梵世。以一成多者。以一令多。或一百或一千或一万等。以变入第四禅安详出。次第以智受持。我当多成多。如小路阿罗汉。以多成一者。欲转多为一。以智受持。我当转多成一。如长老小路阿罗汉。或现或不现。彻过壁彻过墙彻过山。行不障碍犹如虚空。彼坐禅人。如是以修行虚空一切入。入第四禅安详出。彻过壁彻过墙彻过山。已转成转以智受持。此当成虚空。已成虚空。彼坐禅人于虚空。彻过壁彻过墙彻过山。行不障碍犹如虚空。或现者何义开。或不现者何义。不开。彼坐禅人不开令开。彻过壁彻过墙彻过山。行不障碍。此何义。于地令作出没犹如在水。彼坐禅人。如是以心修行水一切入。入于第四禅。安详出转地作隔。以智受持。此当成水彼坐禅人于地成出没。犹如性水。于水上行。心不障碍。犹如行地。彼坐禅人。如是以心修行地一切入。入第四禅。安详出转水作隔。以智受持。此当成地。已成地彼坐禅人。于水行不障碍。如行性地。行于虚空犹如飞鸟。于是三行步行风行心行。于是坐禅人得地一切入定。于虚空受持道路以步行。若得风一切入定。受持风如绵缕如风行。以心行令满身心。或乐想或轻想。以着身身已轻。以心行行如飞鸟。如是以心行。行已手摸日月。如是神通。如是神力。彼坐禅人有禅人有神通。得心自在。以是修行心入第四禅。安详出手摸日月。以智受持。此当成近手。彼成近手。彼坐禅人或坐或卧。以手摸扪日月。起身乃至梵世。彼坐禅人有神通得心自在。乐行梵世。如是四如意足。以如是修行心。于远受持近。于近受持远。或多受持少。或少受持多。以天眼见梵天色。以天耳闻梵天声。以他心智知梵天心。彼坐禅人三行。以二行行于梵世。是法于一切受持变(受持变已竟)

尔时坐禅人欲起变意。如是修四如意足。以心得自在安身于心。安心于身。以由身安心。以由心安身。以由身受持心。以由心受持身。或乐想或轻想。着于身已着身已着身已着成住。如是坐禅人现修其身。成最软最轻堪受持。如铁丸为火所烧随意作物。如是坐禅人已如是修行。心成软堪受持。令满身心。彼坐禅人若乐除自形色。作童子形。入第四禅安详出。次第转童子形。已转以智受持。我当成童子形。如是作意成童子形。如是龙形。凤凰形。夜叉形。阿修罗形。帝释形梵形。海形山形林形。师子形虎形豹形象马形。步军形。已转以智受持。我当成步行军。如是作意成步行军。问受持变作变何差别。答以受持变不舍形色受持。以作变舍形色。此谓差别(作变已竟)

尔时坐禅人欲起意所造变。如是心得自在。修如意足。入第四禅安详出。于其身内作意。犹如空瓶。彼坐禅人如是作意。于空自身内随其所乐为变化。随其当成转。已转以智受持。随其当成。如是作意。成随相似。以此方便多作变化。作变化已成行。若坐禅人以所化身欲向梵世。于梵世前即化自身如梵形。随意所造。一切身分具足。诸根不少若神通人于此逍遥。彼所化人亦复逍遥。若神通人于此若坐卧。现出烟焰。若问若答。彼所化人亦坐亦卧。亦出烟焰。亦问亦答。是其神通所造变化。彼所化人。亦以随作如是等(意所造变已竟)

云何散句变所造色。于至时分别。是时彼不现。未至时分别于其间乐说。彼受持成不现。若不作分别时。念念不现。于化人无寿命根。所化饮食。事变种智。成九事。小事大事不可说事。过去事未来事现在事。内事外事内外事(散句已竟)

问天耳谁起云何当起。答八一切入。彼二一切入。于第四禅得自在。从自性耳起天耳界。复说云何色界于四禅得自在。是其能起。复说于四禅亦起。问云何当令起。答初坐禅人如是修四如意足以心得自在。入第四禅安详出。次第依自性耳界。若远声作意声相。或近声作意声相。若大声作意大声相。若细声作意细声相。若东方声作意声相。如是于一切方。彼坐禅人如是以修行心清白。以耳界清净。令心行增长。彼坐禅人以天耳界清净过人耳闻两声。所谓天声人声。或远或近。于是先师说。初坐禅人先闻于自身众生声。从此复闻身外众生声。从此复闻依所住处众生声。如是次第作意增长。复说初坐禅人。不能如是先闻自身众生声。何以故。不能闻细声。以自性耳非其境界。初坐禅人远螺鼓等声。彼声依自性耳。以天耳智应作意于声相。令起天耳智。或细声或大声。或远声或近声。唯天耳应取。于是初坐禅人不应作意于最可畏。何以故。于可受声应说欲爱。于可畏声应说惊怖耳畏智。彼成三事。小事现在事外事。若失自性耳。天耳界亦失。于是得声闻自在。闻千世界声。从彼缘觉最多。如来闻无数(天耳已竟)

问他心智谁能起云何应起。答光一切入于第四禅得自在。得天眼起他心智。云何应起者。初坐禅人如是修四如意足。以心得自在。清白不动入光一切入。于第四禅安详出。从初以光令满其身。以天眼见其自心意色。此依色意识起。如是知。以自心变见色变。此色从喜根所起。此色从忧根所起。此色从舍根所起。若与喜根相应心现起。意色如酪酥色。若与忧根相应心现起。成如紫色。若与舍根相应心现起。成如蜜色。若与爱欲相应心现起。成如黄色。若与嗔恚相应心现起。成如黑色。若与无明相应心现起。成如浊色。若与信相应及智相应心现起。成如清色。彼坐禅人如是以自身变。分别色变。尔时以光令满他身。以天眼见他心意色。彼以心变分别色变。以色变分别心变。如是分别起他心智已。起他心智除色变分别。唯取心事。彼坐禅人如是以修行心清白。或有爱心知有爱心或无爱心知无爱心。若有嗔恚心知有嗔恚心。若无嗔恚知无嗔恚心。如是一切可知他心智者。其事八。小事大事道事无量事过去事未来事现在事外事。彼无漏他心非凡夫境界。生无色处众生心。唯佛境界。若声闻得自在。知一千世界心。从此缘觉最多。如来无量(他心智已竟)

问忆宿命智谁能起。几种忆宿命智云何应起。答八一切入二一切入。于第四禅心得自在。是其能起忆宿命智。复说云何色界处。答于第四禅心得自在。是其能起。复说于四禅得起几种忆宿命。答三种忆宿命。一者多持生。二者生所造。三者修行所成。于是多持生者。以四行忆宿命智。善取彼相故。见彼分相故。诸根分明故。摄彼性故。此四行多持生忆宿命。于彼最胜彼忆七宿命。诸天诸龙诸凤凰。以生所成忆宿命。于彼最胜忆十四宿命。修行所成者。修如意足。问云何应起忆宿命。答初坐禅人如是修四如意足。以信得自在。清白至不动。从现坐处。于一日所作事。或以身。或以意。或以口。忆一切事。如是于夜所作。如是一日二日。次第乃至一月忆彼一切事。如是二月所作事。如是次第乃至一年所作事。如是二年三年百年所作事。如是乃至初生所作事。忆彼一切。尔时久远过去心心数法有后生。心心数法现生。依初心心数法得生。以心相续生。现观因缘。忆识流转。两俱不断。于此世生。于彼世生。彼坐禅人如是以心修行清白。忆宿命不一种。如是一生二生三生四生等。如是一切。初坐禅人于此生已忆一切。若坐禅人不能忆彼生。彼不应舍精进。更重令起禅。已起禅善哉令自在。如磨镜法。善哉已得自在。现忆如初。于彼成忆。若自从一生。出彼心成忆。彼最乐已见方便。不可忆畜生生。及无色生及无想生不可想。无想性故。长老输毗多于彼最胜忆宿命智。七种小大不应说过去内外。内外于过去已所得道果。或国或村当忆。彼成过去想。忆宿命智。从智忆阴相续。忆宿命智。从此外道忆四十劫。过彼不能忆。身无力故。圣声闻忆一万劫。从此最大声闻。从彼最大缘觉。从彼如来正遍觉。自他宿命及行及处一切。余唯忆自宿命。少忆他宿命。正遍觉随其所乐忆一切。余次第忆。正遍觉若入三昧。若不入三昧。若不入三昧常忆。余唯入三昧(忆宿命智已竟)

问天眼谁起。几种天眼云何能起天眼。答光明为九。或光明为五。或光明一切入事。于第四禅得自在。有眼性是其所能起。几种天眼者。答二种天眼。业果报所成。修行所成。于是典藏天眼。从果报所成。是以得见宝藏或有珠或无珠。修行所成者。修行四如意足。云何能起天眼者。初坐禅人如是修四如意足。以心得自在。清白至不动。光一切入。入第四禅作意光想。及日想受持。此日如夜。此夜如日。以心无碍无所著。现修行心成有光明。彼坐禅人修行其心。成有光明。无闇障碍。过日光明。彼坐禅人如是心修行。以光明令满于内。作意色形。以智令满光明。彼非天眼。以智见内光明色。此谓天眼。彼坐禅人以天眼清净过人眼。见众生或终或生。或粗或妙。或善色或丑色。生于善趣。生于恶趣。如业所作。如是一切众生。于是若能起天眼。此烦恼彼所应断。所谓疑不正忆。懈怠睡眠。慢邪喜恶口。急疾精进。迟缓精进。多语种种想。最观色。此烦恼以此一一成就若令起天眼。其定成退。若其定退光明亦失。见色亦失。是故彼烦恼善哉应断。若已断此烦恼。若复不得定自在。以不自在天眼成小。彼坐禅人以小天眼知少光明。见色亦小。是故世尊说。是时我小定。是时我小眼。我以小眼知少光明。我见小色。是时我无量三昧。是时我无量天眼。我以此无量天眼。我知无量光明。我见无量色。于是初坐禅人非可爱色。非可畏怖色。如初说过天眼五种事。所谓小事现事内事外事内外事。依天眼生四智。未来分智。自所作业智。如行业智。业果报智。于是以未来分智。于未来色当起知之。以自所作业智。见他人所造业。以此业此人当往彼趣。以如行业智。见人生趣。以此业此人先生此知之。以业果报智。至此时至此趣。至此烦恼。至此方便。此业应熟。此业不应熟。此业应多受。此业应少受知之。于是声闻得自在。见一千世间。从此缘觉见最多。如来见无量(天眼已竟)

于是此散句。以天眼为见色。于一种修行定。唯见色不声闻。若以天耳为闻声。于一种修行定。唯闻声不见色。若为见闻二俱修行定。亦见亦闻。若为见闻知他心。修行于定。亦见闻知他心。若为见一方。修行于定。非见余方。不闻不知他心。若不少修行于定。于一切方。亦见亦闻。亦知他心。五神通。世间神通。有漏色界系凡夫共。若善神通。学人及凡夫共或阿罗汉无记神通。五神通。不于无色界生(解脱道说神通道已竟)

    解脱道论分别慧品第十

问云何慧。何相何味何起何处何功德。慧者何义。几功德为得波若。几种波若。答意事如见。此谓波若。复次作意饶益不饶益。作意庄严。此谓波若。如阿毗昙中说。云何波若。是波若是慧是智。是择法妙相随观。彼观聪明晓了分别。思惟见大易悟牵正智。慧钩慧根慧力慧仗慧殿慧光慧明慧灯慧实。不愚痴择法正见。此谓波若。如达为相。择为味。不愚痴为起。四谛为处。复次了义光明为相。入正法为味。除无明闇为起。四辩为处。何功德者。波若无量功德。当以略闻此偈

  以慧净诸戒　　入禅亦二慧
  以慧修诸道　　以慧见彼果
  波若为胜善　　慧眼最无上
  慧退是秽污　　慧增长无上
  慧破诸外论　　非世至所著
  有慧人最妙　　显说善语言
  此世及彼世　　解脱闻苦乐
  诸义及精进　　勇猛有慧人
  悉见此诸法　　因缘诸语言
  教诫及名色　　彼即四谛语
  是有慧境界　　以慧除众恶
  爱嗔恚无明　　以智除生死
  除余不可除

问慧者何义。答智义。能除为义。几功德为得慧者。十一功德。寻修多罗义。多善事。清净居。止观。四谛。作分明处。心停住常在禅。无盖心。离无智慧人。修行智慧人乐着。几种慧者。答二种三种四种。问云何二种慧。答所谓世慧出世慧。于是圣道果相应慧。是出世慧。余是世慧。世慧者。有漏有结有缚是流是厄是盖是所触是趣是有烦恼。出世慧者。无漏无结无缚无流无厄无盖无所触无趣无烦恼。三种慧者。思慧闻慧修慧。于是不从他闻。若自作业智。若得随谛相应智。于功乃明处。此谓思慧。于此处从他闻得慧。此谓闻慧。若入三昧彼慧悉修。是修慧。复次三种慧。来晓了去晓了方便晓了。于是现作意。此不善法成退。善法成增长。于是慧此谓来晓了。复作意此不善法增长。善法成退。于是慧此谓去晓了。于此一切方便慧。此谓方便晓了。复次三种慧。聚慧不聚慧非聚非非聚慧。三地善慧。此谓聚慧。于四道慧。是谓不聚慧。于四地及果报。于三地事有记慧。此谓非聚非非聚慧。四种慧者。自作业智。随谛相应智。道等分智。果等分智。于是十处正见。是谓自作业智。若见阴或无常或苦或无我。如是相似忍。此谓随谛相似智。于四道慧。此谓道分智。于四果慧。此谓果等分智。复次四种慧欲界慧色界慧无色界慧无系慧。于是欲界善有记慧。此谓欲界慧。色界善有记慧。此谓色界慧。无色界善有记慧。此谓无色界慧。于道果慧。此谓无系慧。复次四种慧。法智比智他心智等智。于四道及于四果慧。此谓法智。彼坐禅人以此法智。成就过去未来现在智。久过去亦智。未来亦智。此谛智此谓比智。知他心此谓他心智。除此三智余慧。此谓等智。复次四种慧。有慧为聚非为非聚。有慧为非聚非为聚。有慧为聚亦为非聚。有慧非为聚非非为聚。于是欲界善慧。是慧为聚非不为聚。于四道慧为非聚不为聚。于色界及无色界善慧。是慧为聚亦为非聚。于四地果报。于三地事有记慧。是慧非为聚。亦非为非聚。复次四种慧。有慧有为厌患非为达。有慧为达非为厌患。有慧为厌患亦为达。有慧不为厌患亦不为达。于是慧为厌欲。不为通达神通。及不通达四谛。此谓慧为厌患不为达。现得厌欲。以慧达神通非达四谛。此谓波若。为达非为厌患。于四道慧为厌患亦为达。余慧非为厌患亦非为达。复次四种慧。义辩法辩辞辩乐说辩。于义智此谓义辩。于法智此谓法辩。于说辞慧此谓辞辩。于智智此谓乐说辩。于因果智义辩。于因智法辩。于法辩乐说辞辩。于智智乐说辩。复次于苦及灭智。此谓义辩。于集及道智。此谓法辩。于说法辞。此谓辞辩。于智智。此谓乐说辩。复次知法者。所谓修多罗祇夜阇柯罗界伽陀优陀那伊底(都地反)

跋多伽阇多伽阿浮多达摩鞞佛略此谓法辩。知彼此义。此所说法是其义。此谓义辩。说法辞智。此谓辞辩。于智智。此谓乐说辩复。次于眼智。此谓法辩。眼智为见。此谓义辩。于说法辞智。此谓辞辩。于智智。此谓乐说辩。复次四种慧。苦智。苦集智。苦灭智。于是道等分智。苦相应智。苦智。苦集相应智。集智。苦灭修行相应智。具足智。道智(解脱道分别慧品已竟)

解脱道论卷第九解脱道论卷第十

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    五方便品第十一之一

于是初坐禅人乐脱老死。乐除生死因。乐除无明闇。乐断爱绳。乐得圣慧。于五处当起方便。所谓阴方便。入方便。界方便。因缘方便。圣谛方便。问云何阴方便。答五阴色阴受阴想阴行阴识阴。问云何色阴。答四大四大所造色。云何四大地界水界火界风界。云何地界。坚性坚相。此谓地界。云何水界。水湿和合色。此谓水界。云何火界。火暖熟色。此谓火界。云何风界。风持色。此谓风界。初坐禅人以二行取诸盖。以略以广如说观四大。如是可知。云何四大所造色。眼入耳入鼻入舌入身入。色入声入香入味入。女根男根命根。身作口作。虚空界色。轻色软色。堪受持色。增长色。相续色。生色老色。无常揣食处色。眠色。云何眼入。以是见色有对。依彼眼识起。此谓眼入。复次依眼睛肉揣白黑眼珠三圆。于肉血风痰唾。五重内住。如半芥子。大如虮子头。初业所成。四大所造火。大最多。此清净色。谓为眼入。如大德舍利弗所说。以眼识清净见诸色。或小或微。如牖柯喻。云何耳入。以是闻声。于是声有对。依耳识起。此谓耳入。复次于二孔赤毛为边。依膜住如青豆茎。初业所造空大最多。四大所造清净色。此谓耳入云何鼻入。以是闻香。于是香有对。依鼻识起。此谓鼻入。复次于鼻孔中三和合依细孔住。如拘毗陀罗形。初业所造。风大最多。四大所造清净色。此谓鼻入。云何舌入。以是知味。于是味有对。依舌识起。此谓舌入。复次于舌肉上。两指大住。如郁波罗花形。初业所造。水大最多。四大所造清净色。此谓舌入。云何身入。以是觉触。于是触有对。依身识起。此谓身入。复次除毛发爪齿。所余不受。于一切受身。初业所造。地大最多。四大所造清净色。此谓身入。是可见色。此谓色入。是有对声。是谓声入。是有对香。此谓香入。是有对味。此谓味入。是女性是女根。是男性是男根。是随守护业所成色。此谓命根。是以身令现诸行名行。此谓身作。是以口令现诸行名行。此谓口作。是色分别此谓虚空界。是色轻性此谓色轻。是色轻性此谓色软。是色堪受持性此谓色堪受持。此三种是身不懈怠性。是诸入聚此谓色聚。是色聚此谓色相续。是色令起此谓色生。是令色熟此谓色老。是色败坏所谓色无常。以气味众生得立。此谓气味揣食。色依界及意识界起。此谓界处色。是诸界懈怠。此谓睡眠色。此二十六所造色。及四大。成三十色。问四大及四大所造色。云何差别。答四大依四大共生。四大所造色依四大生。四大所造色非四大所依。亦非四大所造色所依。如三杖得倚。如是四大可知。如三杖影倚。如是四大所造色可知。此谓差别。于是坐禅人此三十色。以五行可知所胜。如是以令起。以聚以生以种种以一。问云何以令起。答九色业因缘所起。所谓眼入耳入鼻入舌入身入。女根男根命根处色。二色心因缘所起。所谓身作口作。一色时节心所起。所谓声入。四色时心食因缘所起。所谓色轻色软色堪受持眠色。十二色四因缘所起。所谓色入香入味入。虚空界色聚色相续色。色生揣食四界。二色无有所起。所谓色老色无常。复次生缘老老缘无常。如是以令起。所胜可知。问云何以聚。答九聚业所起。九聚心所起。六聚时节所起。三聚食所起。问云何九聚业所起。答所谓眼十耳十鼻十舌十身十女根十男根十处十命根九。问云何名眼十。答眼清净四界是其处。复依四界色香味触命根眼清净。此十法共生不相离此谓聚。是谓眼十。此起是生此熟谓老。此坏是无常。此分别。是虚空界。此四法彼聚共起。此眼依于十老时。生第二眼十。彼二种十聚此谓聚。彼随逐此谓相续。此六法彼共起。彼复第二眼十依于老时。生第三眼十。是第二及第三眼十。此谓聚。唯彼法随逐。此谓相续。初十散坏。第二十老。第三十起。彼成一刹那。如是所起眼十。彼间不可知。刹那轻速故。不现世间知。有彼坐禅人见眼相续。如江流如灯焰相续。此谓眼十。如是耳十鼻十舌十身十女根十男根十命根九。以广可知。问云何九聚心所起。答清净八义。清净身作九。清净口作七。清净轻九。轻身作十轻口作十一。清净眼九。眼身作十。眼口作十一。问云何名清净八心所起。答四界依界。色香味触。此八法共生不相离。彼十是名清净八。彼起是生。彼熟是老。彼坏是无常。彼分别是虚空界。此四法彼随起。彼清净八。于坏时与第二心共起。第二清净八。初清净坏。第二清净起。于一刹那起。此非展转为聚。以与三所起所聚。如是清净轻九。及清净眼九。六作聚非初坏。非第二起。无一刹那。何故不一心二作。令起余如初说。问云何六聚时节所起。答清净八。清净声九。清净轻九。轻声十。清净眼九。眼声十。外聚成二清净。八及声九。问云何三聚食所起。答清净八。清净轻九。清净眼九。时节食所起聚相续业处。相似可知。余如初说。命九天聚。于欲界于业处所成。八聚以寿命活。鼻舌身男女根如。是轻等三及眠。此于色界。无有命九。天聚无想梵天。于其身一切入。以是得活。如是以聚。问云何以生。答如男女入胎。于刹那生三十色起。所谓处十。身十。或女根十。或男根十。不男不女二十色起。所谓处十身十。于欲界化生。满根入男女。于生刹那七十色起。所谓处十。身十。眼十。耳十。鼻十。舌十。或女根十。或男根十。或于恶趣化生生盲。女人男人。于其生刹那六十色起除眼十。如是生聋人六十色起。除耳十。生盲聋人五十色起。除眼十耳十。恶趣化生满根入。或非男或非女。及劫初人。于其生刹那六十色起除男女根。于彼盲及非男非女。五十色起除眼根十。除非男非女根。或聋非男非女。亦五十色起除耳十及非男非女根。或盲聋非男非女四十色起。处十身十鼻十舌十梵。天于其生刹那四十九色起。处十眼十耳十身十命根九。无想天众生于其生刹那九色起。命根九。如是以生可知。问云何以种种。答一切色成二种。所谓大细。于是十二色大内外色入。以有对义。余十八色细。以无对义。复二种色。所谓内外。于是五色成内眼等。五入以有境界义。余二十五外色以无境界义。复有二种色。命根不命根。于是八色名根。五内女根男根命根。以依义。余二十二非命根。以无依义。一切色成三种。所谓受色非受色有坏色。于是九色。有受八根及处色。以业报所成义。九色不受声入。身作口作色。轻色软色堪受持色老色。无常及眠。非业报所成义。余十二色有坏。彼以二种义。复有三种色。所谓可见有对。非可见。有对。不可见无对。于是一色可见有对。所谓色入。以见义以触义。十一色不可见有对。除色入余大色以。不见义以触义十。八色不可见无对。余细色不可见义。不可触义。一切色成四种。所谓自性色形色相色分别色。于是十九自性。色余十二大色。女根男根命根水界揣食处色眠色。以毕竟义。七形色。所谓身作口作色。轻色软色堪受持色受色相续自性色。以变三相色。色生色老色无常。以有为相义。一色分别色。所谓虚空界。以聚分别义。于是自性色。彼成分别。余无分别。如是以种种分别。问云何以一种当分别。答一切色非因非无因。因不相应。有缘有为。世所摄。有漏有缚。有结有流。有厄有盖。所触有趣。有烦恼无记无事。非心数心不相应。小欲界系不定非乘。不与乐共起。不与苦共起。不苦不乐共起。不令聚非不令聚非学非非学。非见所断。非思惟所断。如是以一种所胜可知。此谓色阴

问云何受阴。答以相一受。以彼心受持成一。由处二受。所谓身受意受。由自性三受。乐受苦受不苦不乐受。由法四受。善受不善受报受事受。由根五受。乐根苦根喜根忧根舍根。由黑白六受。有漏乐受。无漏乐受。有漏苦受。无漏苦受。有漏不苦不乐受。无漏不苦不乐受。由门七受从眼触生受。从耳触生受。从鼻触生受。从舌触生受。从身触生受。从意界触生受。从意识界触生受。以广成。一百八受。六依爱起受。六依出离起受。六依爱忧起受。六依出离忧起受。六依爱舍起受。六依出离舍起受。此六六成三十六。于三时三三十六。此谓受阴

问云何想阴。答以想一相以心知事。以黑白二相。谓颠倒想。不颠倒想。以由不善三想。谓欲想嗔恚想害想。以由善三想。谓出离想不嗔恚想不害想。以不知义性处门四想。谓不净净想。于苦乐想。于无常常想。于无我我想。以由知义性处四想。不净想苦想无常想无我想。以由毗尼五想。于不净净想。于不净不净想。于净不净想。于净净想。疑想。以由事六想。色想声想香想味想触想法。想以由门七。想从眼触生。想从耳触生想。从鼻触生想。从舌触生想。从身触生想。从意界触生想。从意识界触生想。如是种种想可知。此谓想阴

问云何行阴。答触思觉观。喜心精进念。定慧命根盖。不贪不嗔惭愧。猗欲解脱舍作意。贪嗔恚无明慢。见调戏疑懈怠无惭无愧。除受想一切心数法行阴。于是触者。是心触事。如日光触壁是其想处。思者是心动如作宅足种法。是其事门足处。觉者是口行如以心诵经。是彼想足处。观者。是心观事如随思义。是其觉足处。喜者是心欢喜如人得物。是其踊跃足处。心者是心清如咒令水清。彼四须陀洹分足处。精进者是心勇猛。如壮牛堪重。彼八事处足处。念者是心守护如持油钵。彼四念处足处。定者是心专一如殿里灯。彼四禅足处。慧者是心见如人有眼。彼四圣谛足处。命根者是无色法是寿命。如郁波罗水。彼名色足处。盖者是心恶止离。如人乐命离毒。彼四禅行足处。不贪者是心舍着。如得脱责。彼离出足处。不嗔者是心不嗔怒如猫皮。彼四无量足处。惭者是心羞耻。于作恶如憎恶屎尿。彼自身依足处。愧者是心畏于作恶。如畏官长。彼世依足处。猗者是心动摇灭。如夏热人冷水洗浴。彼喜足处。欲者乐作善如有信檀越。彼四如意足处。解脱者是心屈曲。如水流深处。彼觉观足处。舍者是心不去来。如人执称。彼精进等足处。作意者是心令起法则。如人执施。彼善不善足处。贪者是心摄受如我鸟。彼可爱可乐色足处。嗔恚者是心踊跃。如嗔毒蛇。彼十嗔恚处足处。无明者是心无所见如盲人。彼四颠倒足处。慢者是心举如共相扑。彼三种足处。见者是心取执。如盲人摸象。彼从他闻声不正忆足处。调者是心不寂寂。犹如沸水。彼速。精进足处。悔者是心退如爱不净。彼以作恶善退足处。疑者是心不一取执。如人行远国或于二道。彼不正作意足处。懈怠者是心懒堕。如蛇藏蛰。彼八懒处足处。无惭者是心于作恶无羞耻。如栴陀罗人。彼不恭敬足处。无愧者是心于作恶无畏。如恶王。彼六不恭敬足处。此谓行阴

问云何识阴。答眼识耳识鼻识舌识身识意界意识界。于是眼识者。依眼缘色生识。是谓眼识。耳识者依耳缘声生识。是谓耳识。鼻识者依鼻缘香生识。是谓鼻识。舌识者依舌缘味生识。是谓舌识身识者依身。缘触生识。是谓身识。意界者依处五事依二事。五识若前后次第生识。此谓意界。意识界者。除此六识。余心。此谓意识界。此七识以三行所胜可知。如是以处事以事以法。问云何以处事。答五识种种处种种事。意界及意识界。一处意界五事意识界。六事五识者。内法内处外事意界。内法外处外事意识界。内法外处。内事亦外事。六识者。初生处。初生事意识界。于入体刹那共生处。初以生处。于无色有无处一切事。如是以处事可知。问云何以事。答五识一一受其境界。非一一次第生。不前不后生不散起。以五识不知所有法。除初起。以意界不知所有法。除意转。以六识。不安威仪。以迅速安之。以六识不受持身业口业。以六识不受善不善法。以迅速受之。以六识不入定不安详起。以迅速入定。以后分安详。以六识不终不生。或以后分。或以彼事终。以果报意识界生。以六识不眠不觉不见梦。以后分眠。以转意觉。以迅速梦见。如是以事可知。问云何以法。答五识有觉有观。意界有觉有观。意识界设有觉有观。设无觉少观。设无觉无观。五识与舍共行。身识设与乐共行。设与苦共行。意识界设与喜共行。设与忧共行。设与舍共行。五识果报意界。设果报设方便。意识界设善设不善。设果报设方便。六识无因无起。世间法有漏有结。有缚有流有厄有盖。所触有取有烦恼。不以见所断。不以思惟所断。非为聚非非为聚。非学非非学。少欲界系。不定非乘。意识界一切坏。如是以法胜可知。此谓识阴。此谓五阴

复次此五阴。以四行所胜可知。如是以句义以相。以分别以摄。问云何以句义。答色者现义。受者可受义。想者知义。行者作义。识者解义。阴者种类集义。如是以句义可知。问云何以想。答色者自色相如见刺。彼四大足处。受者彼受相。如癞恶病。彼触足处。想者持相为相。如作像貌。彼触足处。行者和合为相如转轮。彼触足处。识者谓知相如知味。彼名色足处。如是以相可知。问云何以分别。答三种阴分别。五阴五受阴五法阴。于是五阴者。一切有为法。五受阴者。一切有漏法。五法阴者。戒阴定阴慧阴解脱阴解脱知见阴。于此五受阴是可乐。如是以分别可知。问云何以摄。答三种摄。入摄界摄谛摄。于是色阴十一入所摄。三阴法入所摄。识阴意入所摄。色阴十一界所摄。三阴法界所摄。识阴七界所摄。戒阴定阴慧阴解脱知见阴。法入及法界所摄。解脱阴法入及意入。及法界意识界所摄。五阴或谛所摄。或非谛所摄。五受阴苦谛及习谛所摄。戒阴定阴慧阴道谛所摄。解脱阴非谛所摄。解脱知见阴苦谛所摄。有法是阴所摄。非谛所摄。有法是谛所摄。非阴所摄。有法是阴所摄。亦谛所摄。有法非阴所摄。亦非谛所摄。于是非根所缚色。及与道相应。沙门果是阴所摄。非谛所摄。泥洹是谛所摄。非阴所摄。三谛是阴所摄。亦谛所摄。制者非阴所摄。亦非谛所摄。如是以行。于阴知分别方便。此谓阴方便(阴方便已竟)

问云何入方便。答十二入。眼入色入。耳入声入。鼻入香入。舌入味入。身入触入。意入法入。于是眼入者。是界清净以是见色。色入者。界色形摸是眼境界。耳入者。是界清净以是闻声。声入者。是界鸣耳境界。鼻入者。是界清净以是嗅香。香入者。界香鼻境界。舌入者。是界清净以是知味。味入者。是界气味舌境界。身入者。是界清净以是触细滑。触入者。是地界水界火界风界。坚软冷暖身境界。意入者。是七识界。法入者。是三无色阴及十八细色及泥洹。此谓十二入。复次此十二入。以五行所胜可知。如是以句义。以境界以缘。以彼夹胜心起以摄。问云何以句义。答眼者见义。色者现义。耳者闻义。声者鸣义。鼻者嗅义。香者芳义。舌者尝义。味者气味为义。身者正持义。触者可触义。意者知义。法者无命义。入者无色法门义。处义受持义。如是以句义可知。问云何以境界。答眼耳不至境界。鼻舌身至境界。意俱境界。复有说。耳者至境界。何故唯有近障不闻声。如说咒术。复说眼者于其自境界至境界。何故壁外不见。如是以境界可知。问云何以缘。答缘眼色光。作意生眼识。于是眼者为眼识。以四缘成缘。初生依根有缘色者。以三缘成缘。初生事有缘光者。以三缘成缘。初生依有缘作意者。以二缘成缘。次第非有缘。缘耳声空作。意得生耳识。以此分别当分别。缘鼻香风作意。得生鼻识。缘舌味水作意。得生舌识。缘身触作。意得生身识。缘意法解脱作意。得生意识。于是意者是后分心。法者是法事。此成四种。六内入过去现在未来第一种。五外入过去未来现在离除非入根。是第二种。法入第三种。十一种制名者。所谓众生方时犯罪。头陀一切相。无所有入定事灭禅定。实思惟不实思惟。是第四种。此谓法事。专心者心随如昱。作意者于意门转意。识者速心。于是意者为意识以依缘成缘。法者以事缘成缘。解脱者以依缘成缘。作意者以二缘成缘。次第缘有缘。如是以缘可知。问云何以夹胜心起。于眼门成三种。除夹上中下。于是上事。以夹成七心。无间生阿毗地狱。从有分心。转见心。所受心。分别心。令起心。速心。彼事心。于是有分心者。是于此有根心如牵缕。转心者。于眼门色事夹缘故。以缘展转诸界。依处有分心成起。有分心次第。彼为见色事成转生转心。转心次第依眼应转。现得见生见心。见心次第已见以心。现受生受心。受心次第以受义。现分别生分别心。分别心次第以分别义。现令起生令起心。令起心次第以令起义。由业心速行。速行心次第。以速行义。不以方便生彼事果报心。从彼更度有分心。问何譬喻。答如王殿上闭城门卧。伛女摩王足。夫人坐。大臣及直阁列在王前。聋人守门依城门住。时守园人取庵罗果打门。王闻声觉王。敕偻女。汝当开门。偻女即奉命。以相貌语聋人言。聋人解意。即开城门。见庵罗果。王捉刀。女受果将入现于大臣。大臣授与夫人。夫人洗净。或熟或生。各安一处。然后奉王。王得食之。食已即说彼功德非功德。还复更眠。如是如王卧。如有分心可知。如守园人取庵罗果打门。如是于眼门色事夹可知。如王闻彼声王觉。教伛女开门。如是以缘展转界。依处有分心起可知。如伛女以相貌教聋人开门。如是转心可知。如聋人开门见庵罗果。如是眼识可知。如捉刀女受彼果将现大臣。如是受持心可知。如大臣取果授与夫人。如是分别心可知。如夫人洗净。或熟或生各安一处然后与王。如是令起心可知。如王食彼果。如是速心可知。如王食已说彼功德非功德利。如是彼事果报心可知。如王更眠。如是有分心度可知。于是眼门以中事夹。速心无间度彼有心。以夹下事。令起心无间度有分心。如是余于门可知。于意门无事夹。以作意缘以解脱行。于意门成取事。于是于上事三心生。有分心转心速心。彼事心于中及下事二心生。转心及速心。于是可爱不可爱中事。以种种缘种种受可知。以正作意非正作意。缘种种善不善可知。如是彼夹胜心起可知。问云何以摄。答三种摄。阴摄界摄谛摄。于是十入色阴所摄。意入识阴所摄。法入除泥洹四阴所摄。十一入十一界所摄。意入七界所摄。五内入苦谛所摄。五外入。或苦谛所摄。或非苦谛所摄。意入或苦谛所摄。或非苦谛所摄。法入或四谛所摄。或非苦谛所摄。如是所摄可知。如是以此行。于入智令起方便。此谓入方便(入方便已竟)

问云何界方便。答十八界。眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。于是眼清净眼界。色形色界。眼识眼识界。如是余可知。于五门转事。意界受果报。意界唯法入。除法界六识界。余心意识界。余如入广说。于是十界色阴所摄。法界除泥洹四阴所摄。七界识阴所摄。十一界十一入所摄。七界意入所摄。十一界苦谛所摄。五界或苦谛所摄。或非谛所摄。法界四谛所摄。或非谛所摄。意识界或苦谛所摄。或非谛所摄。问云何说化境界。答唯此法阴入界为境界。诸说法种类和合相为阴说门相为入。说自性相为界。复次世尊为利根人。以阴门说苦谛。为中根人以入门说苦谛。为钝根人以界门说苦谛。复次于名著相人。以略说色。以分别名说阴。为着色相人。以分别色以略说名说入。于名色着相人。以名色分别说界。复次说自性处说阴说处事说入。以处事说心起说界。以如是等行界分别方便。此谓界方便(界方便已竟)

问云何因缘方便。答无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是皆苦阴起。唯以无明灭则行灭。以行灭则识灭。以识灭则名色灭。以名色灭则六入灭。以六入灭则触灭。以触灭则受灭。以受灭则爱灭。以爱灭则取灭。以取灭则有灭。以有灭则生灭。以生灭则老死忧悲苦恼灭。如是苦阴皆成灭。于是无明者。不知四谛。行者身口意业。识者入胎一念心名识。名色者共相续心起心数法。及迦罗逻色。六入者六内入。触者六触身。受者六受身。爱者六爱身。取者四取。有者是业能起欲色无色有。生者于有阴起。老者阴熟。死者阴散坏。问何故无明缘行。何故生缘老死。答于此无间凡夫。于四谛不知故。五受阴长夜乐着我物。成彼所触。此我物此我身如是有乐着乐。和合为有思惟。彼思惟使非智所处。为得有成住于有。如种在耕熟田。无彼识为有灭。此谓无明缘行。彼无明所起行。思入有着于有相事成为聚。于转有起相续。识于有随心非断。是故行缘识。如除日无光明。住地增长。如是除识无名色。于无体住增长。如荻相猗展转相依。是故识缘名色。依处余名共生起。意入增长依名命四大。及食时缘余五入起增长。非余此缘。是故名色缘六入。余根境界识和合起触。是故六入缘触。以触受或苦或乐。或不苦不乐。非所触。是故触缘受。痴凡夫受乐成着。复更觅受苦。彼对治觅乐。若受不苦不乐受舍。是故受缘爱。以渴爱急取爱处。是故爱缘取。彼有取作事为有种。是故取缘有。以如业所胜生于诸趣。是故有生。以生成老死。是故生缘老死。如谷为种缘。如是无明缘行可知。如种为牙缘。如是行缘识可知。如牙为叶缘。如是识缘名色可知。如叶为枝缘。如是名色缘六入可知。如枝为树缘。如是六入缘触可知。如树为花缘。如是触缘受可知。如花为汁缘。如是受缘爱可知。如汁为米缘。如是爱缘取可知。如米为种缘。如是取缘有可知。如种为牙缘。有如是缘生可知。如是起种种相续。如是前际不可知。后际亦不可知。如是生无明为初因缘相续。其前际不可知。后际亦不可知。问无明何缘。答唯无明为无明缘。使为缠缘缠为使缘。初为初后为后。复次一切诸烦恼。成无明缘。如佛所说。从漏集起无明集。复次如一心法。以眼见色。痴人起爱。于此时净乐者心痴。此谓无明。思着是无明缘行。心着此行缘识。知相应心数法。及彼所造色。是识缘名色。从受生喜。缘喜故。喜色缘故。诸根清净。是名色缘六入。无明触是六入缘触。喜触缘受欲。受缘爱以着取净乐。是爱缘取。以着思是取缘有。彼法起是有缘生。住已是老念散坏是死。如是于一刹那。成十二因缘。问彼十二因缘分几名烦恼几名业。几果报几过去几未来几现在。几因缘。几已起。云何因缘。云何因缘法。此二何差别。何因缘染性。答三烦恼。无明爱。取二业。行有。余七果报。于是名烦恼者。成因为有后生。如画师色。其事不自生。如画师色事。烦恼令起。有缘得生。如种种色。二过去无明及行。二未来生老死。余八现在。如是以取三时无始生死相续可知。十二分因缘者不应说。除十二因缘。亦不应说。尔时云何因缘。此十二法如次第展转因故。此谓因缘起。十二因缘分已起法。此二何差别者。因缘者诸行异。非成就不可说。或有为或无为。不应说。以起因缘法行。已成就有为。此二法差别。何因缘染性者。以是行以是相。成无明行。缘彼行彼相彼性。彼圣人不他缘。以慧明通达。如是一切此谓因缘染性。复次此因缘。以七行可知。如是以三节以四略。以二十行。以轮以牵。以分别以相摄。云何以三节。诸行及识。其间第一节。受及爱彼间第二节。有及生。彼间第三节。于过去以业烦恼缘现在果报。是第一节。以现在果报。缘现在烦恼。第二节。以现在烦恼。缘未来果报。第三节。第一及第三因果节及有节。第二节果因节非有节。有节者何义。答终无间未度阴入界。以初业烦恼缘故。于诸趣更有生。此谓有生节。问云何成。答彼入无明爱。相应以造功德。恶业凡夫。彼于此时谓死。以死受苦。卧置死人处。不见此世。不见彼世。失念不得念。是时受生苦。意念智成退。身勇猛成退。诸根渐渐失。从身或上或下。命根失燥失。如多罗叶燥。于此时如眠梦。以叶四法起。业业相趣趣相。云何业。是其所造。或功德或非功德。或重或轻或多或少。如近其初所造。彼业即起。业相者。彼处所依造业。彼处即起。业伴侣业相起。彼于时或如现作业。趣者以功德缘善趣起。以非功德缘恶趣起。名趣相者。入胎时三事和合得生。化生者依处处生。是其所生处起。或宫殿或坐处。或山或树或江。随其趣及共取相起。彼于此时往彼。或倚或坐或卧。见彼或取。彼于此时。初所造业及业相。或趣及趣相。作事以速心现起灭。命终去速心无间。共命根灭成终。终心无间次第。以速心起。唯彼业或彼业相。或趣或取相。作事果报心处度于后有。如灯燃灯。如从火珠出火。彼节心起故如伴侣。于母腹依父母不净。三十色业所成成起。处身有十。彼于老刹那无心过节。四十六色成起。业所造三十食节所成。二色及八无心过节色。于老刹那共第二心。五十四色成起。业所成三十食时所成。三色及八如是起。识缘名色。名色缘识。如是成有节。于是成三节可知。问云何以四略。答无明行于过去业烦恼略。识名色六入触受。于现在果报略。爱取有于现在业烦恼略。生老死于未来果报略。如是以四略可知。问云何以二十行。答以取无明过去爱及取。以烦恼相成所取。以取行过去有以业相成所取。以取识名色六入触受。现在以果报相生及老死成所取。以取爱取现在以烦恼相成所取。以取有现在行以业相成所取。以取生老死未来识名色六入触受成所取。此二十四法。以取其成就成二十。如阿毗昙所说。于初业有痴是无明。聚是行。着是爱。觅是取。思是有。此五法于此生有。初所作业是其缘。不了识入痴是无明。聚是行。着是爱。觅是取。思是有。此五法于此业有。为未来生时缘。未来生时识度。是名色清净。是入所触是触取是受。此二法于未来生有。于此所作业是其缘。如是以二十行可知。云何以轮。无明缘行行缘识。乃至生缘老死。如是皆苦阴起于此皆苦阴无知。此谓无明。无明缘行者。复如是以轮可知。云何以牵。二牵。所谓无明所初。及老死所初。于是。问云何无明所初。答是说次第。云何老死所初。是度次第。复次无明所初。是有边际面未来知道。老死所初者。初边际面过去知道。如是以牵可知。问云何以分别。答二种因缘。世间因缘。及出世因缘。于是无明所初。是世因缘。问云何出世因缘。答苦依苦。信依信。喜依喜。踊跃依踊跃。倚依倚。乐依乐。定依定。如实知见依如实知见。厌患依厌患。无欲依无欲。解脱依解脱灭智。此谓出世因缘。复说四种因缘。业烦恼为因。种为因。有作。共业为因。问云何业烦恼为因答无明所初。云何种为因。如种牙相续。云何有作。如化色。云何共业为因。如地雪山海日月。复有说。非此共业因。是诸色心法。时节为因。无有共业。如世尊说偈

  业不与他共　　是藏他不偷
  人所作功德　　其自得善报

如是分别可知。问云何以相摄。答四种相摄。阴相摄。入相摄。界相摄。谛相摄。于是无明行触爱取有行阴所摄。识识阴所摄。名色四阴所摄。六入二阴所摄。受受阴所摄。生老死色阴所摄。及行阴所摄。无明行触受爱取有生老死法入所摄。识意入所摄。名色五内入所摄。六入六内入所摄。无明行触受爱取有生老死法界所摄。识意识界所摄。名色五界所摄。六入十二谛所摄。无明爱取十谛所摄。余九苦谛所摄。出世因缘道分道谛所摄。因缘灭灭谛所摄。如是以相摄可知。如是以行因缘方便可知。此谓因缘方便(因缘方便已竟)

解脱道论卷第十解脱道论卷第十一

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽婆罗译

    五方便品之二

问云何圣谛方便。答谓四圣谛。苦圣谛。苦集圣谛。苦灭圣谛。苦灭道圣谛。问云何苦圣谛。答生苦老苦死苦。忧苦忧悲苦恼苦。苦苦怨憎会苦爱别离苦求不得苦。以略五受阴苦。生苦者。于众生种类诸阴起。此一切苦集义。老苦者。以生诸界熟。此失力色诸根念慧义。死苦者。寿命灭作畏怖义。忧苦者。至苦处心畏惧。此内烧义。忧悲苦者。苦至语言。此内外烧义。苦苦者。身苦此因苦身义。恼苦者。心苦此因苦心义。怨憎会苦者。与不可爱众生共和合。此作苦义。爱别离苦者。与可爱众生共分散离别。此作忧苦义。求不得苦者。乐得与不可爱别离乐可爱和合。彼不得失乐义。已略说五受阴苦者。不离五受阴苦。是故以略五受阴苦。问云何五受阴。答色受阴痛受阴想受阴行受阴识受阴。如阴方便广说。如是可知。于是二种苦处苦自性苦。于是生苦死苦怨憎会苦爱别离苦求不得苦。以略五受阴苦。此谓处苦。忧苦忧悲苦恼苦。此谓自性苦。三种苦者。苦苦坏苦行苦。于是身苦心苦。是谓苦苦。有漏乐受彼处坏。是谓坏苦。五受阴行苦。此谓苦圣谛。问云何苦集圣谛。答爱令复生。与欲共起。处处起。如是欲爱有爱不有爱。此爱令复生者。有爱多成令有生爱。苦集者。唯爱不共故说苦集。与欲共起者。唯爱令欢喜名起。令染名染。共染起喜。起者是处处令身性起。是处欢喜。是处可爱色。是处欢喜。如是欲爱有爱非有爱。除有爱及不有爱。余爱是欲爱。有爱者与常见共起。非有爱者与断见共起。此谓苦集圣谛。问云何苦灭圣谛。答唯爱灭无余。舍远离解脱无处。此谓苦灭圣谛。问不然此亦集灭。何故世尊说苦因灭。答苦因灭故成不生灭。应作证义。是故集灭。世尊说苦灭。问云何苦灭道圣谛。答此八正分道。如是正见正思惟正语正业正命正精进正念正定。正见者四谛智。正思惟者是三善思惟。正语者离四恶行。正业者是离三恶行。正命者离邪命。正精进者四正勤。正念者四念处。正定者四禅。复次若修行圣道。于泥洹知见。此谓正见。唯于泥洹觉是正思惟。彼断邪语是正语。断邪业是正业。彼断邪命是正命。断邪精进是正精进。于泥洹念是正念。于泥洹专心是正定。于是慧根。慧力慧如意足。择法觉分。成入内正见。精进根。精进力。精进如意足。欲如意足。精进觉分。四正勤。成入内精进。念根念力念觉分四念处。成入内正念。定根定力。心如意足。信根信力。定觉分。喜觉分。猗觉分。舍觉分。成入内正定。如是三十七菩提法。成入八正道内。此谓苦灭道圣谛。此谓四圣谛。问何故说四圣谛不三不五。答一切疑。为世间出世间果因故成四。问云何世谛果苦集世谛因果。灭出世谛果。道出世谛因。是故四不三不五。复次应知应断应证应修。以四句故成四。此四圣谛以十一行可胜可知。如是以句义以相以次第以略以譬喻以分别以数以一以种种以次第广以相摄。问云何以句义。答圣谛者。圣人所说名圣谛。通达彼故成圣谛。谛者如是义。不异义。自相不异义。苦者果义。集者因义。灭者随灭义。道者见第一义。如是以句义可知。问云何以相。答苦者过患相。集者因相。灭者不生相。道者方便相。复次苦者逼恼相忧相有为相有边相。集者聚相因缘相和合相着相。灭者出离相寂寂相无为相醍醐相。道者乘相令到相见相依相。如是异相可知。问云何以次第。答以粗义及证义。初说苦谛。此苦以此生第二集。此集灭是此苦灭。第三灭。此方便为实灭。第四说道。如明了医。初见病源后问病缘。为灭病故如病说药。如是病如苦可知。如是病因缘如集可知。如是病尽如脱灭可知。如是药如道可知。如是以次第可知。问云何以略。答生是苦。令生是集。苦止是灭。令止是道。烦恼处是苦。烦恼是集。断烦恼是灭。断方便是道。苦能起开身见门。集能起开断见门。灭能起开常见门。道能起开邪见门。如是以略可知。问云何以譬喻。答如毒树如是苦可知。如种如是集可知。如是烧种。如是灭可知。如火如是道可知。如此岸有苦有怖畏。如是苦可知。如流如是集可知。如彼岸无苦无怖畏。如是灭可知。如船能渡。如是道可知。如担担如是苦可知。如取担如是集可知。如置担如是灭可知。如置担方便如是道可知。如是以譬喻可知。问云何以分别可知。答四种谛。语谛。各各谛。第一义谛。圣谛。于是说实语非不实。是谓语谛。于各各谛大入诸见。此谓各各谛。彼谛比丘妄语愚痴法。彼不妄语愚痴法。是谛。泥洹者是第一义谛。是圣人所修行。是圣谛于此所乐圣谛。如是以分别可知。问云何以数可知

答除爱于三地善不善无记法是苦谛。爱是集谛。断彼是灭谛。八分道是道谛。复次除爱余烦恼。于第三地善不善无记法是苦谛。爱及余烦恼是集谛。断彼是灭谛。道者是道谛。复次除爱余烦恼一切不善。于三地善有记法是苦谛。爱及与烦恼一切不善是集谛。断彼是灭谛。道是道谛。复次除爱与烦恼及一切不善。于三地不善。于三地无记法是苦谛。爱及余烦恼及一切不善。于三地善此集谛。断彼是灭谛。道是道谛。于是觅有气味义是爱。集有结使义。余烦恼是集。以可断义。以令起有义。一切不善是集。以令有义。于三地善法是集。于是爱及余烦恼是集。一切不善于三地及善。或苦谛或集谛。逼恼忧有为有边相故成苦谛。聚因缘着和合相故成集谛。如是以数可知。问云何以一可知。答此四谛以四行成一。以谛义以如义以法义以空义。如是以一可知。问云何以种种可知。答二谛。世谛出世谛。世谛者有漏有结有缚有流有厄有盖可触。有取有烦恼。所谓苦及集。出世谛者。无漏无结无缚无流无厄无盖不可触无取无烦恼。所谓灭道。三谛有为。灭谛无为。三谛无色。苦谛有色无色。集谛不善。道谛善。灭谛无记。苦谛善不善无记。苦谛可知。集谛可断。灭谛可证。道谛应修。如是以种种可知。问云何以次第广。答以一种。有识身是苦。集我慢。断彼是灭。身念是道。以二种。名色是苦。是无明有爱是集。断彼是灭。奢摩他毗婆舍那是道。以三种成。所谓苦苦是苦谛。三不善根是集。断彼是灭。戒定慧是道。以四种成。四身性处是苦。四颠倒是集。断颠倒是灭。四念处。是道。以五种成。五趣是苦。五盖是集。断盖是灭。五根是道。以六种成。六触入是苦。六爱身是集。断爱身是灭。六出离法是道。以七种成。七识住是苦。七使是集。断七使是灭。七菩提分是道。以八种成。八世间法是苦。八邪边是集。断八邪边是灭。八正分是道。以九种成。九众生居是苦。九爱根法是集。断彼是灭。九正作意根法是道。以十种成。十方行是苦。十结使是集。断结是灭。十想是道。如是以次第广可知。问云何以摄。答三种摄。阴摄入摄界摄。于是苦谛五阴所摄。集谛及道谛行阴所摄。灭谛非阴所摄。苦谛十二入所摄。三谛法入所摄。苦谛十八界所摄。三谛法界所摄。如是以摄可知。以此行于圣谛知令起。此谓圣谛方便(圣谛方便已竟)

    解脱道论分别谛品第十二之一

尔时坐禅人。已明了阴界入因缘谛。已得闻戒头陀禅。以凡夫未解脱怖畏恶趣。已观恶趣怖。已观无始生死怖。已观一刹那不可得。已观三百鉾刺喻。已观烧头爱喻。未分别四圣谛。为分别圣谛。当作方便。当作欲。当作勇猛精进。专心缘念具足应令满。问云何当作。答彼坐禅人初四圣谛当闻。或以略或以广或以略广。以闻以义以诵当受持。是时坐禅人入寂寂。坐不乱心不去来心。四圣谛应令起。初苦谛应令起。或以阴或以入或以界阴法。以自相以阴相应令起。如阴方便广说。如是当知。入者以入相应令起。如入方便广说。如是当知。界者以界相应令起。如界方便广说。如是当知。彼坐禅人。如是已阴入界。唯有阴入界。无众生无命。已令起已得行想。尔时已略作二种令起。所谓名色。于是色阴十。入十界色。四阴意入七界。是名法入法界。或名或色余名余色。余名余色者以色空。色者以名空。名者以色不离。色者以名不离。如鼓声唯依名色生。依色名生。如盲跛远行。问名色者何差别。答名者无身。色者有身。名者有所知。色者无所知。名者轻转。色者迟转。名无聚色有聚。名者觉知思识。色者无此。色者行倚坐卧屈申。名无此。名者知我行我倚我坐我卧我屈我申。色无此。色者饮食啖尝。名无此。名者知我饮我食我啖我尝。色无此。色者拍戏笑啼种种言说。名无此。名者知我拍我笑我戏我啼我种种言说。色无此。谓名色差别。彼坐禅人如是名色。唯以名色无众生无命。已令起。已得行想。尔时一切作略。苦谛者令起如实知见清净。令名色起。此总语苦谛令起可知。彼坐禅人如是已令起苦谛。作众生想。从此苦因缘应观。问此苦何因缘何集。答彼坐禅人如是知。此苦生为因缘。生者有为因缘。有者取为因缘。取者爱为因缘。爱者受为因缘。受者触为因缘。触者六入为因缘。六入者名色为因缘。名色者识为因缘。识者行为因缘。行者无明为因缘。如是无明缘行。行缘识。生缘老死。成忧悲苦恼。如是悉苦阴成起。彼坐禅人如是以因缘所缚以广观。尔时以作略。此受缘爱。彼苦集令起。或法住智。或圣取因缘智。或离疑清净。此众语言。集谛令起智。彼坐禅人以令起苦集。于三昧已度疑。尔时观苦灭。谁灭为苦灭谁。灭为此苦灭。彼坐禅人如是知。从生灭此苦灭。从生灭有灭从有灭取灭。从取灭爱灭。从无明灭行灭。如是从无明灭行灭。从行灭识灭。从生灭老死忧悲苦恼灭。如是此一切苦阴成灭。彼坐禅人如是因缘所缚灭。已广已观。尔时作略。此受缘爱。从彼灭苦灭令起灭谛。彼坐禅人如是已令起灭谛。尔时观苦灭道。何道何具足为爱灭。彼坐禅人如是知于五受阴观过患。此道此具足。为爱灭令起道谛。如谛方便广说。如是可知。彼坐禅人如是以次第已令起四谛。尔时于五受阴。以一百八十法。次第以聚分别观。所有色过去未来现在。或内或外或大或小或粗或妙或远或近。一切色以无常广观。以广观苦。以广观无我。如是所有受。所有想。所有行。所有识。于一一阴十二法门。于五阴五十二成六十。六十无常见。六十苦见。六十无我见。成一百八十。复次一百八十法门。六内入。六外入。六识身。六触身。六受身。六想身。六思身。六爱身。六觉六观。此十六成六十。六十无常见。六十苦见。六十无我见。三六十成一百八十。彼久远年时日月月半日夜时念刹那。以回转法行成新故。如灯焰相续成转。以无常于行分别观。以恶趣受苦。饥渴怖畏。求觅爱别离老病死忧悲苦恼。此行相应相续。以苦于行观分别。从阴入界因缘谛业果报因缘令生所生。无众生不动无事自性行成起。以无我于观分别。于行色无常。以灭义。以苦怖义。无我不实义。以作略广分别。如是受想行识无常灭义。苦者以怖义。无我以不实义。如是作略广分别。于是以无常已分别除常想。以苦分别除乐想。以无我分别除我想。问云何以无常广分别。答如实见一切诸行。无有为边灭为边。于无相或令起心。于无相界为安心。是故以无常广分别。问云何以苦分别。答于一切诸行令心怖畏。从作愿令起心。于无作愿为心安。是故以苦广分别。问云何以无我广分别。答于一切法见。从他从此执令起心。于空界为心安。

是故以无我广分别。如是分别三有五趣七识住九众生居。以灭怖畏。以无实观之(分别智已竟)

彼坐禅人于五受阴。已分别于三相。令乐入欲断诸行。尔时现在内五受阴。取彼相令通达起灭。如是此法以无生现生。以生灭如是通达。于是取相者。取相三种。取烦恼相。取定相。取毗婆舍那相。于是愚痴凡夫。于见闻觉知境界。以成乐常想颠倒所。初心以好取相。于此着烦恼。如蛾投灯。此谓取烦恼相。问云何取定相。答于此坐禅人。乐得定以念正智所。初心三十八行。于一一行取相令系心。为不乱故如系象。此谓取定相。问云何取毗婆奢那相。答常观人以慧所初心色受想行识。各各分别其自相。乐欲舍修彼相。如捉毒蛇。此谓取毗婆奢那相。于此取毗婆奢那相可乐。问云何取受想行识相。答彼色识相。或以地界。或以水界。或以火界。或以风界。或眼入或身入。如是观彼受受相。或为乐或为苦。或为不苦不乐。如是观彼想想相。或为色想或为法想。如是观知行行相。或为触或为思。或为觉或为观。或为作意。如是观彼识识相。或眼识或意识。如是观彼彼坐禅。如是善取彼相。以善令起。令起如是取色受想行识相。复次以二行取心相。以事以作意。问云何以事取心相。答以此事我心起。当观彼以此色受事。以此想事。以此行事。以此识事。我心起。如是当观。彼如是以事取心相。问云何以作意取心相。答如是我作意色此心起。如是当观。如是我作意受想行我心起。如是当观。如是已作意取心相。问云何彼相成善取。答以是行以是相。色受想行识想以成观。若复堪更观彼相。以此行以此相。是谓彼相成善取。通达生灭者。有起有灭。有起灭通达。于是色已生现在。彼生相起变相灭。彼二句以慧眼见。通达起灭。受已生现在受想行识。彼生相起变相灭。彼二句以慧眼见通达起灭。复次以三行通达起相。以三行通达灭相。如是以因以缘。以自味。问云何以因通达起相。答爱无明业是因为阴起。以慧眼见以因通达起相。云何以缘通达起相。食缘为色阴起。触缘为三阴起。名色缘为识阴起。以慧眼见以缘通达起相。问云何以自味通达起相。答如灯焰相续无间。初后新新起行。以相以慧眼见。以自味通达起相。于是以因以起见。以集谛相成见。以令起觉。以缘以自味。以起见苦谛。以相成所见。以刹那不可得觉。如是以三行通达起相。问云何以三行通达灭相。答以因灭以缘灭以自味灭。于是以爱灭以无明。灭以业灭。阴成灭。以慧眼见。以因灭通达灭相。以食灭色阴成灭。以触灭三阴成灭。以名色灭识阴成灭。以慧眼见。以缘灭通达灭相。如灯焰相续无间。初有灭行以慧眼见。以自味通达灭相。于是以因灭见灭谛。以相成所见。以无生相觉以缘灭。以自味以见灭。以苦谛相成初见。以刹那不可得觉。问若以起灭见苦谛。以相得见。何故上智当起。答何用起见灭。以苦谛相得见未见。彼苦成满。乃至诸行过尽。如实已见。从行相已令起心。于非行心成度。如实已见诸行过患。从行相已令起心。于非行成度。是处见苦成满。谓往边故。犹如飞鸟为火所围未免怖畏。若未至虚空。见火围过患。成飞虚空。是时彼见火怖围成满如是。于此可知。于是以因以缘以起见。成通达因缘起相。此有此起。此起故此成起。因灭故及缘灭。故以见灭因缘生相成通达。此无有此不成。此灭故此灭。以自味以起灭。见已起成通达。知因缘法有为法起。彼起得知。彼灭亦知。彼住亦知。如是以起灭见四法成所知。如是一相法种种法无事法正法。于是一相续所著诸行以起。彼见不成。种种执。初后转诸行。以彼灭见不成一执。自性离无动诸行。以初后见不成我执。因缘所转初后诸行。如是以法见不成无事执。无闻凡夫以一不觉常断说。以种种不觉成常说。以无事不觉成我说。如是以法不觉。成无事说。于是以平等语言。以一相胜语言。以种种相摄成一相。以分别义成种种。以烦恼义成一性。以方便义成种种性。以爱果成一性。以业果成种种性。彼坐禅人如是见一性。非于此执种种见。若见种种性。非于此执常见一性。若现见一性。余作余觉除此见。若现见种种性。彼作彼觉除此见。若现见一性除此断见。若现见种种性除此常见。彼坐禅人如是以起灭。见一性种种性。法明何以起。现起诸行见彼无事。何故一切诸行无事不动。无余所起住。住自性因缘和合集为因缘。如是以止法生令生。于是以无命义及不动义。无事法可知。以自性。义及缘义。如是止法可知。令现空无事。令现业所作。如是止法令现无事名法。如是令现止法名行。于是以一性法觉苦相成通达。以种种性觉无常相成通达。以无事法觉。如是以止法觉无我相成通达。问彼坐禅人一切诸行。以无余处观起灭为一处当观耶。答于初诸行处取其相。通达起灭无余处。一切诸行令满。如人于大海一处以舌舐水。即知一切水碱。如是于此可知。以二行诸行令满。以事以不愚痴。于是诸行取其相。通达生灭。彼诸行以其事成满。于是断无智故。余诸行以不愚痴成满。于是起灭智。是诸行分别智。一切诸行以起初边成分别。以灭后边成分别。以起初边成寂寂。以灭有边成寂寂。以起从起无初。以灭从灭无后。是故起灭智。成诸行分别智(起灭智已竟)

彼坐禅人如是正见生灭相。善分别诸行。乐得灭乐定。尔时不作意观生。唯见心灭。以色事以心生灭。依彼事见心灭。如是以受持。以想事以行事。以识事以心生灭。依彼事见心生灭。复次以三行。见灭如是以聚以双以分别。问云何以聚。答于威仪威仪所起心心数法。于其处以聚见彼灭。复次已观色无常受无常想无常行无常识无常。尔时以无常事所起心心数法。以聚见彼灭。如是以苦事无我事。如是以聚当见问云何以双。答此色无常已观无常。随无常起心见心生灭。如是受想行识无常已观。随无常事起心见生灭。如是已苦事已无我事。如是以双当观。问云何以分别。答已观此色无常。随无常事起心见心生灭。如是以分别观见多心灭。如是观受想行识无常。随无常事起心见心生灭。以是见心灭复见灭。如是以分别见多心灭。如是观苦观无我。如是已分别。唯现观彼灭。其彼苦灭事成专。常觅诸行刹那成得利。彼坐禅人以此慧非他缘。见一切世间。以自性如到芥子头。于一心刹那生老死变。尔时坐禅人复如是见。如偈所说

  此双名色性　　展转于一灭
  句灭缘彼灭　　及彼因所生
  阴无常灭法　　苦生法灭法
  如桴打鼓声　　亦不从眼生
  色香等五法　　亦不从色生
  亦不离二句　　依缘生有为
  如桴打鼓声　　亦不从耳生
  色香等五法　　亦不从声生
  亦不离二句　　亦不从鼻生
  色香等五法　　亦不从香生
  亦不离二句　　亦不从舌生
  色香等五法　　亦不从味生
  亦不离二句　　亦不从身生
  色香等五法　　亦不从触生
  亦不离二句　　不从处色生
  不从法入出　　依因缘依生
  如桴打鼓声　　彼根最羸出
  初因亦最羸　　彼因亦最羸
  所起彼亦羸　　共地此最羸
  相应亦最羸　　和合亦最羸
  展转此常羸　　展转法不住
  亦无性展转　　无有能令起
  令起彼亦无　　如乾闼婆城
  是谁初令起　　不以自身生
  不以自力住　　由随他法生
  生诸有漏法
  自体裸劣不自生　　亦不自因不自事
  不有为处不自性　　不自性行相诸有
  为生自身裸无时　　无所从来无所行
  处无所生为他国　　心无我所命身性
  一心苦乐相应速　　刹那山海八万劫
  一住不再无二心　　相应过去及当灭
  现住一切彼诸阴　　此等已去无间失
  未来当失于彼间　　已没无异相不起
  以不生故现在生　　从于心失世间无
  第一义中无去来　　未来无聚唯转生
  住如芥子生诸法　　彼法灭已是其初
  世间以法初不杂　　不见去来不见生
  诸法不生如虚空　　犹如电起须臾灭

彼坐禅人。如是见灭无尽入定。如钻火烟起。菩提品刹那刹那起。光明智起。喜猗乐取解脱念处起。舍出离于是不明了。坐禅人于彼法或起乱。或起增上慢。问云何为除乱。答彼坐禅人于法起喜。彼喜复令更安。如是彼坐复更令安。成其心法调所摄。若法调所摄心。从灭观定其心离常。难常通达。如是离去。问云何起增上慢。答彼坐禅人于法初起光相。得出世间法。于未得成得相。常不更作精进。如是增上慢起。明了坐禅人。知此烦恼是定乱。知世间法行事。如是知出世间法泥洹事。如是知已。如是智除乱。除增上慢。唯见灭是善修行多修(观灭智已竟)

解脱道论卷第十一解脱道论卷第十二

        阿罗汉优波底沙梁言大光造

        梁扶南三藏僧伽波罗译

    分别谛品第十二之二

彼坐禅人如是现观灭。以由观灭成畏。阴因亦畏阴生畏。三有五趣七识住九众生居成畏。彼如恶人捉刀可畏。如毒蛇如火聚。如是以由观灭成畏阴因畏阴生畏。三有五趣七识住九众生居。以无常现作意令畏想。以安隐令起无想。以苦现作意成畏生。以安隐令起无生。以无我现作意。成畏相及生。以安隐令起无相及无生。观过患观厌离软随相似忍。是其总语(令起智怖已竟)

彼坐禅人。以怖现修行令起智。乐解脱智生。彼阴相是怖者。乐解脱智起。阴生为怖者。乐解脱智起。三有五趣七识住九众生居此怖者。乐解脱智起。如火所围鸟从彼乐解脱。如人为贼所围。从彼乐解脱。如是彼坐禅人阴因阴生。三有五趣七识住九众生居。此畏怖者。乐解脱智起。以无常现作意畏因。以苦现作意畏生。以无我现作意畏因及生。乐解脱智起。于是凡夫人及学人。于乐解脱智二种引心。或观欢喜。于是现观。于上成通达现观欢喜。心成忧恼成修行障碍。成通达难见思惟行。舍中随相似忍。此是总语言(乐解脱智已竟)

彼坐禅人如是现修行乐解脱智。从一切诸行。乐解脱泥洹诸行。唯作一相欲令起。解脱门相似智起。以三行得相似智。以三行越正聚。于五阴无常现见得相似智。五阴灭常泥洹。如是现见越正聚。于五阴以苦现见得相似智。五阴灭乐泥洹。现见越正聚。于五阴以无我现见得相似智。五阴灭第一义泥洹。现见越正聚。问云何以智现越正聚。云何以智已越正聚。答以性除智现越正聚。以道智已越正聚。问相似智者何义。答相似者。四念处四正勤四如意足五根五力七觉分八正道分。以彼相似。此谓相似智总语言。无怨见利相似忍。此是相似智总语言(相似智已竟)

相似智无间次第。从一切诸行相起。作泥洹事。生性除智。问云何义名性除。答除凡夫法名性除。非凡夫法所除亦名性除。性者是泥洹。复次种殖泥洹者名性除。如阿毗昙所说。除生名性除。度无生亦名性除。复除生因名性除。度无生无相名性除。于泥洹是初引路。从外起转慧。此性除总语言(性除智已竟)

性智无间次第。现知苦现断集现作证灭现修道。生须陀洹道智。及一切菩提法。彼坐禅人于此时以寂寂。现见有边无为醍醐戒。于一刹那以一智非初非后。分别四谛。以知苦分别。以断集分别。以作灭证分别。以修道分别。成分别。如譬喻偈所说

  如人舍此岸　　以船度彼岸
  于彼度诸物　　乘舡者除漏

如船度水。非初非后。于一刹那作四事。舍此岸除漏到彼岸。度物如舍此岸。如是智分别苦如除漏。如是分别断集如度彼岸。如是作证分别灭如以船度物。如是修道分别。如灯共生。于一刹那不初不后作四事。如小灯炷除闇。令油消令光明起。如日共生非初非后。于一刹那作四事。令现色除闇。令灭寒。令起光明。如令现色。如是智分别苦如除闇。如是分别断集如令灭寒。如是作证分别灭。如令起光明。如是修道分别如日。如是圣智。问如实现见苦知苦断集证灭修道。此相云何。若不见苦四颠倒生。尔时如所说。有边无为醍醐戒。以寂寂现见。以一智非初非后。分别四谛。此义云何。答于生灭智。是时未成见苦。满及至如实见诸行过患。从诸行相令起心。于无行成度。是故如实见诸行过患。从诸行相以令起心。于无行成度。是处见苦漏到最后故。复说若如是以寂寂。以性除智。成分别谛性除智者。从行相起成度无行。若性除智从行相起成度于无行。成度于泥洹。唯着因是其事。以着事得定心。若不得定。不生奢摩他毗婆舍那。亦不得菩提法满。是故以性除智成分别谛。从彼性除智。无间道智成生。于此时得于泥洹定。心得定成起奢摩他毗婆舍那。成满菩提分法。是故唯以道智成分别谛。如人从烧城出脚跨门阃。从城已出一脚。是时未名出。如是性除智。从彼行相起成度无行。是时未名度烦恼。诸法未满故。如人从所烧城两脚已出。是时名出烧城。如是性除智无间。成生道智起。是时名从烦恼城出。诸法满故。是故以性除智成分别谛。分别谛者何义。答四圣谛于一刹那说和合。名分别谛。于此时道智和合依义。诸根成平等不动义。力义。乘义。菩提分因义。道分令住义。念处胜义。正勤便义。如意足实义。谛不乱义。奢摩他随观义。毗婆舍那义。不相离义。双义。覆义。戒清净不乱义。心性净见义。见清净义。脱义。解脱通达义。明舍义。脱断义。灭智根义。欲令起义。作意平等义。触受灭出离义。现前义。定依义。念真实义。慧深胜义。醍醐最后义。泥洹最后平等义。坐禅人如是现智。如是现见断三结。所谓身见疑戒取及彼相应烦恼。问云何身见。答于此无闻凡夫见色为我。我有色色为我所于色我。如是受想行识为我。我有识识为我所于识我。此谓身见。此身已断。彼断故六十二见亦断。为身见所初六十二见。问云何疑。答或于苦。或于集。或于灭。或于道。或于佛法僧。或初边或后边。或初后边疑或。于因缘所起法彼疑惑。此谓疑。彼亦断。问云何戒盗。答戒盗二种。渴爱及痴。我以此戒。以此行。以此苦行。以此梵行。我当上天。我皆当生一一天处。此谓渴爱戒盗。从此外沙门婆罗门。以戒。以清净。以清净戒行。彼如是见。此谓痴戒盗。彼亦断。问云何彼一处住烦恼。答彼令往恶趣。淫欲嗔恚痴。此谓彼一处住。烦恼亦断。于此间为须陀洹果。作证成向。未得须陀洹。住须陀洹向地。或第八地。或见地。或定从两起转慧。此须陀洹道智总语言。须陀洹无间次第。三结断故。作无为事。与道等法无异方便起。须陀洹果智果心。或二或三生无间。彼次第度后分。心从后分起。观道。观果。观泥洹。观已断烦恼。观余烦恼。此谓须陀洹。不退法定向。菩提向。未来果欲分别。是世尊胸生口生法生法所造。得法分不与物分。此谓见具足善。修行通达圣法。至醍醐门住。见具足到此妙法。见此妙法已觉智成就。已觉明成就。入法流圣通达慧。开醍醐门住。是故说此偈

  于地一国王　　于天堂一王
  领一切世间　　须陀洹果胜

彼坐禅人于此地住。于上作精进。为作斯陀含果证。作见生灭所。初现观。如初所说。现修行如已见道。依诸根力菩提觉。如是分别谛。彼如是修行。向灭断粗欲嗔恚及彼一处住烦恼。从彼道无间作证须陀洹果。彼坐禅人于此地住。于上作精进。为作阿那含果。证作见生灭为初。现见如初所说。现修行如见道。依诸根力菩提觉。如是分别谛。彼如是向灭断细欲嗔恚及彼一处住烦恼。从彼彼道无间。作证阿那含果。彼坐禅人于此地住。于上作精进。为作证阿罗汉果。作见生灭为初。现见如初所说。现修行如己见道。依诸根力菩提觉。如是分别谛。彼如是向断色欲无色欲。慢调无明余烦恼无余断。从彼坐禅人作证阿罗汉果。彼观道。观果泥洹。观断烦恼。比丘成阿罗汉。灭漏所作。以立置担。到妙义断有结。正智解脱离五分六分。成就一守护。不为死所系。除余谛等灭。信觅无浊思惟猗身。行善解脱。心善解脱。慧梵行已立。成丈夫最胜丈夫。得第一所得。此谓除嗔恚者。度岸者。离烦恼者。无结碍者。得圣翻者。除担者。不相应者。沙门者。婆罗门者。已浴者。度韦陀者。最上婆罗门者。阿罗汉者。度者。脱者。伏者。寂寂者。令寂者。是阿罗汉总语言。于是若须陀洹从其生于上。不更作精进。以三种得见三种须陀洹。一七生家家须陀洹。一生须陀洹。于是钝根成七生。中根成家家。利根成一生。七生者七时往天堂来。此作苦边家家须陀洹。或二时或三时。往彼家已往作苦边。一生须陀洹已令生人有作苦边。若斯陀含人。从其生于上不作精进。一时来此世作苦边。若阿那含从其生于上。不作精进。从此终生净居。彼由诸根胜。以五种得见。成五阿那含。中间般涅槃。生般涅槃。不行般涅槃。行般涅槃。上流往阿迦尼吒天。于是名中间般涅槃者。未至所著无间中间。依寿命时为除残结使。令起圣道。生般涅槃者。越中寿命。为除残结使。已生令起圣道。不行般涅槃者。无异行。为除残结使。令起圣道。行般涅槃者。无异行。为除残结使。令起圣道。上流阿迦尼吒天。从不烦终往不热。从不热终往善见。从善见终往善现。从善现终生阿迦尼吒天。于阿迦尼吒。为除残结使起圣道。于是不烦天万劫寿命。不热天二万劫寿命。善见天四万劫寿命。善现天八万劫寿命。阿迦尼吒天十六万劫寿命。于四地成五。五人于阿迦尼吒。四人无上流人。如是彼成二十四人。阿罗汉已断一切烦恼无余故。不成后有因因。无故阿罗汉已免寿形命。行灭此苦断。不起余苦。此谓苦边。是故说此偈

  譬如槌打铁　　火星流入水
  次第成寂灭　　彼趣不可知
  如是正解脱　　已度欲缚漏
  至于无动乐　　彼趣不可知

问于此有师说。次第修道次第断烦恼。次第分别谛。答或以十二。或以八或以四。道智作证果。问云何于此见不相应。答若次第修行。次第断烦恼。是故次第作证。以是次第作证果。可乐与道果相应故。若如是可乐。一须陀洹果者成耶。若如是不可乐。次第修道。次第断烦恼者亦然。复次第二过。若以见苦见苦所断烦恼。灭断可乐。是故已见苦见苦所断烦恼已断。作证四分须陀洹果。作证应可乐。方便成就故。若如是可乐作证。四分须陀洹。四分七时生。四分家家生。四分一生。四分住于果。于此不相应。若如是不可乐。以见苦见苦所断烦恼断耶。此不相应。复次第三过。若以见苦。见苦所断烦恼断者所乐。是以现见苦。四分须陀洹道住。四分信行。四分法行。成应可乐。不见余三谛。若此所乐住于四须陀洹道。成四信行。成四法行。于此不相应。若如是不可乐。以见苦见苦所断烦恼断。复次第四过。亦不相应。若现见道成向以见道成住果。此可乐以是现见苦成向。以见故成住果。应可乐。见一种故。若如是可乐向。及住果成多过。于此此不相应。若如是不可乐。现见道成证。以见道成住于果。此亦不相应。复次第五过。若以见道作证果。未见苦集灭。成作证果可乐者。以见苦集苦灭是无义。复次第六过。若以十二。或以八或以四道智。作证须陀洹果可乐者。以是作证。或十二。或八。或四。须陀洹果应成可乐者。成道智无果。若如是可乐地以成过。于此此不相应。若如是可乐。或以十二。或以八。或以四。道智作证须陀洹果者耶。此亦不相应。复次第七过。若或十二。若八。若四道智。令起一须陀洹果者可乐。此亦不相应。多事令起一果。如多庵婆果令生一果。问若以一智一刹那。无前无后。成分别四谛。一智应成四见取事。若以见苦成见四谛。四谛成苦谛。若此二义无此不相应。一刹那以一智。无前无后。成分别四谛。答非一智成四见取事。亦非四谛成苦谛。坐禅人唯从初四谛。种种相一相。以前分别故

尔时以圣行苦谛。如是相以通达。成通达四谛。如其相四谛以如义成一相。如五阴种种相。一相以前分别为色阴。以无常已见五阴无常亦常。见无常非色阴为五阴。如是入界。如是于此可知。于是散法可知。如是观觉喜受地根。解脱烦恼正受二定。于是观者二观。禅观燥观。问云何禅观。已得定以定力伏盖。以名比分别色观见禅分。奢摩他为初。修毗婆舍那。燥观者。以分别力伏盖。以色比分别名见观诸行。毗婆舍那为初。修行奢摩他。觉者燥观。初禅及观者。观道及果成有觉。于三禅毗婆舍那乃至性除成有觉。道及果成无觉。于觉地道成八分道。于无觉地七分除思惟。喜者燥观得苦行。具足毗婆舍那相似智。成无苦起性除道及果共起喜。燥观得乐行具足。于二禅毗婆舍那及道果共起喜。于第三禅。于第四禅。毗婆舍那道及果不共起喜。于喜地道及果七觉分起。于无喜地六菩提觉。除喜菩提觉。受者燥观得苦行。具足毗婆舍那乃至相似智。共舍起性。除道及果共喜起。燥观得乐行具足。于三禅毗婆舍那道果共喜起。于第四禅毗婆舍那道果共舍起。地者二地。见地思惟地。于是须陀洹道见地。余三道四沙门果思惟地。未尝见今见名见地。如是见如是修是思惟地。复次二地学地不学地。于是四道三沙门果学地。阿罗汉果无学地。根者三出世间根。未知我当知根。已知根。知已根。于是须陀洹道智。初未知今知者成未知智。三道智三果智已知法。更知知根阿罗汉果智无余。已知法知者已知根。解脱者三解脱。无相解脱。无作解脱。空解脱。于是道相似智。不作相是无相解脱。不作愿是无作解脱。不作执是空解脱。复次此三解脱。以观见成于种种道。以得成于一道。问云何以观见成于种种道。答已观见无常。成无相解脱。以观见苦。成无作解脱。以观见无我。成空解脱。问云何以观见无常成无相解脱。答以无常现作意。以灭诸行起心。成多解脱。得信根及四根。彼种类如实智相。彼种类一切诸行。成无常起。令起相怖畏。从相行生智。从相心起。于无相心越。以无相解脱身得脱。如是以观无常成无相解脱

问云何以观见苦成无作解脱。答以苦现作意。以怖畏诸行令起心。成心多寂寂。得定根及四根。彼种类如实知生。以彼种类一切诸行成苦所见。以怖畏生。令起生智。从生心起。于无生心越。以无作解脱身得脱。如是以观见苦成无作解脱。问云何以观见无我成空解脱。答以无我现作意。以空令起诸行。心成多厌恶。得慧根及四根。彼种类如实知相及生。以彼种类一切诸法。成无我可见。以怖畏令起相及生。依相及生智唯起。从相及生心成离。于无相无生灭。泥洹心越。以空解脱身得脱。如是以观见无我成空解脱。如是此三解脱。以观成于种种道。问云何以得三解脱成于一道。答已得无相解脱。成得三解脱。何故是人以无相。其心得脱。虽解脱彼已作。以执其已得无作解脱。三解脱成所得。何故以作其心得脱以解脱。彼以相以执得空解脱。三解脱亦得。何故若其以执心得脱。以解脱以相以作。如是已得三解脱成于一道。解脱者。解脱门者何差别。答唯彼道智。从烦恼脱名解脱。以入醍醐门义名解脱门。复次解脱者唯道智。彼事为泥洹。此谓解脱门。烦恼者。一百三十四烦恼。如是三不善根三觅。四漏。四结。四流四厄。四取。四恶趣行。五悭。五盖。六诤根。七使世间。八法。九慢。十烦恼处。十不善业道。十结。十邪边。十二颠倒。十二不善心起。于是三不善根者。贪嗔痴。于此三嗔者。以二道成薄。以阿那含无余灭。贪痴者。以三道成薄。以阿罗汉道无余灭。三觅者。欲觅有觅梵行觅。于此三中梵行觅者。以须陀洹道无余灭。欲觅者。以阿那含道灭。有觅者。以阿罗汉道灭。四漏者。欲漏。有漏。见漏。无明漏。于此见漏者。以须陀洹道灭。欲漏者。以阿那含道灭。有漏无明漏者。以阿罗汉道灭。四结者。贪欲身结。嗔恚身结。戒盗身结。此谛执身结。于此戒盗身结者。此谛执身结。以须陀洹道灭。嗔恚身结以阿那含道灭。贪身结。以阿罗汉道灭。四流者。欲流有流见流无明流。四厄者。欲厄有厄见厄无明厄如初。所说灭。四取者。欲取。见取。戒取。我语取。于此三取以须陀洹道灭。欲取以阿罗汉道灭。四恶趣行。欲恶趣行。嗔恶趣行。怖畏恶趣行。痴恶趣行。此四以须陀洹道灭。四悭者。住处悭。家悭。利养悭。色悭。法悭。此五以阿那含道灭。五盖者。欲欲。嗔恚。懈怠。睡眠。调慢疑。于此疑者。以须陀洹道灭。欲欲嗔恚慢。以阿那含道灭。懈怠调以阿罗汉道灭。睡眠随色。六诤根者。忿覆嫉谄恶乐见触。于此谄恶乐见触。以须陀洹道灭。忿覆嫉以阿那含道灭。七使者。欲染使。嗔恚使。慢使。见使。疑使。有欲使。无明使。于此见使疑使。以须陀洹道灭。欲染使嗔恚使。以阿那含道灭。慢使有使无明使。以阿罗汉道灭。世间八世法者。利衰毁誉称讥苦乐。于此四不爱处嗔恚。以阿那含道灭。于四爱处使。以阿罗汉道灭。九慢者。从彼胜我胜生慢。与胜我等生慢。从胜我下生慢。从等我等生慢。从等我下生慢。从下我胜生慢。从下我等生慢。从下我下生慢。九慢者以阿罗汉道灭。十恼处者。贪嗔痴慢见疑懈怠调无惭无愧。于此见疑以须陀洹道灭。嗔恚以阿那含道灭。余七以阿罗汉道灭。十恼处者。此人于我已作现作当作非义生恼。我所爱念人。彼人已作现作当作。其非义生恼。我所不爱念人。彼人已作现作当作者。于非处生恼。十恼处以阿那含道灭。十不善业道者。杀生。不与取。邪行。妄语。恶口。两舌。绮语。贪嗔邪见。于此杀生不与取邪行妄语邪见。以须陀洹道灭。恶口两舌嗔。以阿那含道灭。绮语贪。以阿罗汉道灭。十使者。欲染使。嗔恚使。慢使。见使。疑使。戒取使。有染使。嫉使。悭使。无明使。于此见疑戒取使。以须陀洹道灭。欲染嗔恚嫉悭使。以阿那含道灭。慢有染无明使。以阿罗汉道灭。十邪边者。邪见。邪思惟。邪语。邪业。邪命。邪精进。邪念。邪定。邪智。邪解脱。于此邪见邪语妄语业邪命邪智邪解脱。以须陀洹道灭。邪思惟邪语恶语两舌。以阿那含道灭。邪语绮语邪精进邪念邪定。以阿罗汉道灭。十二颠倒者。于无常常想颠倒心颠倒见颠倒。如是于苦乐。于不净净。于无我我。于此无常常三颠倒。于无我我者。三颠倒。于不净净者。见颠倒。于苦乐者。见颠倒。以须陀洹道灭。于不净净者。想颠倒心颠倒。以阿那含道灭。于苦乐者。想颠倒心颠倒。以阿罗汉道灭。十二不善心起者。与喜共起见相应。无行心起。有行心起。与喜共起见不相应。无行心起。有行心起。与舍共起见相应。无行心起。有行心起。与舍共起见不相应。无行心起。有行心起。与忧共起嗔恚相应。无行心起。有行心。与调共起心起。与疑共起心起。于此四见相应心起。与疑共起心起。以须陀洹道灭。二共起心起。以二道成薄。以阿那含道无余灭。四见心不相应起。及调共起心起。以三道成薄。以阿罗汉道无余灭。二正受者。二正受不与凡夫共及果成就想受灭。正受问云何果正受。何故名果正受。谁修谁令起。何故修。云何修。云何作意。彼成就几缘。几缘住。几缘为起。此正受世间耶。出世间耶。答云何果正受者。此沙门果。心于泥洹安。此谓果正受。何故果正受者。非善非不善。非事出世道果报所成。是故此果正受。阿罗汉及阿那含。于此定作满。复有说一切圣人得令起。如毗昙所说。为得须陀洹道。除生名性除。如是一切。复说一切圣人成就于此定作满。唯彼令起。如长老那罗陀说。诸比丘如是长老于山林井。于彼无绳取水。尔时人来为日所曝热乏渴爱。彼人见井知有水。彼不以身触住。如是我长老有灭为泥洹。如实正智善见。我非阿罗汉漏尽。何故令起者。答为现见法乐住令起。如世尊教阿难。是时阿难如来不作意。一切诸相唯一受灭。无相心定令起住。是时阿难如来身成安隐。云何以令起者。答彼坐禅人入寂寂。住。或住或卧乐得果正受。作生灭见所。初观诸行。乃至性除智。性除智无间。于泥洹果正受令安。依其禅成修道是。是禅成所作。是名果正受。云何作意者。答无为醍醐界。以寂作意。彼成就几缘。几缘为住。几缘为起。答彼正受二缘。不作意一切诸相。于无相界作意。三缘为住。不作意一切诸相。于无相界作意。及初行二缘为起。作意一切相。及无相界不作意。云何此定世间出世间耶。答此出世正受。非世间正受。问阿那含人。为果定现观。何故性除无隔。阿罗汉道不生。答非乐处故。不生观见。无力故。于是二种胜果可知。成有道及性除果。现作证道无间果现。成无道及性除果。成入果定。成无道及性除果。从灭定起。成无道无性除果(果正受已竟)

问云何想受灭正受。谁令起。几力成就。令起几行所除。令起几初事。何义为起。云何起。云何从彼起。云何心以起。以起心何所著。几触所触。云何初起诸行。死人及入灭想受定。何差别。此定有为无为。答不生心心数法。此谓灭想受定。谁令起定者。答阿罗汉及阿那含。于此定作满。谁不令起者。答凡夫人及须陀洹斯陀含。及生无色界人。于是非其境界故。凡夫不能起烦恼障碍定。未断故。须陀洹斯陀含。不能起为更起。非其处故。入无色界不能起。几力成就令起者。答以二力成就令起。以奢摩他力。以毗婆舍那力。于是以奢摩他力者。由八定得自在。以毗婆舍那力者。由自在随七观。云何七随观。无常观。苦观。无我观。厌患观。无染观。灭观。出离观。奢摩他力为灭禅分。及为不动解脱。毗婆舍那力为见生过患。及为无生解脱。几行所除令起定。答以除三行令起定。口行身行心行。于是入二禅觉观口行成所除。入第四禅出息入息。身行成所除。入灭想受定人。想受心行成所除。初几事者。答初四事。一缚不乱。远分别。观事非事。于是名一缚者。钵袈裟一处[怡-台+(噗-口)]受持。不乱者。以所有方便。此身愿莫生乱受持。远分别者。称其身力。以日作分别受持。于此久远过期当起。观事非事者。未至时分别。或众僧为事和合。以彼声我当起受持于是一缚者。为守护袈裟。不乱者及久远分别。为守护身。观事非事者。为不妨众僧和合。住无所有处。或初作事入初禅。何故令起。答为现法乐住者。是圣人最后无动定。复为起神通入广定。如长老正命罗汉。为守护身。如长老舍利弗如长老白鹭子底沙。云何令起者。彼坐禅人入寂寂住。或坐或卧。乐灭意乐灭入初禅。入已安详出。无间见彼禅无常苦无我。乃至行舍智。如第二禅第三禅第四禅。虚空处识处无所有处。入已安详出。无间见正定无常苦无我。乃至行舍智。尔时无间入非非想处。从彼或二或三。令起非非想心。起已令心灭。心灭已不生不现入。此谓入灭想受定

云何从彼起者。彼非如是作意。我当起已至于初时。所作分别成。云何心以起者。若阿那含人。以阿那含果心起。若阿罗汉人。以阿罗汉心起。起已彼心何所著。答心专缘寂寂。几触所触者。答三触所触。以空触无相触无作触。云何初起诸行。彼从身行。从彼口行。死人及入灭想定人何差别者。死人三行没无现寿命。断暖断诸根断入。受想定人三行断没。寿命不断。暖不断。诸根不异。此彼差别。云何此定有为无为者。答不可说此定有为无为。问何故此定不可说有为无为。答有为法于此定无有。无为法入出不可知。是故不可说此定有为无为(灭禅定已竟)

解脱分别谛十二品已竟

于此品数因缘。戒头陀定求善友。分别行行处行门五神通。分别慧五方便。分别谛。此十二品。是解脱道品次第

  无边无称不可思　　无量善才善语言
  于此法中谁能知　　唯坐禅人能受持
  微妙胜道为善行　　于教不惑离无明

解脱道论卷第十二


金刚针论

    No. 1642

金刚针论

        法称菩萨造

        西天译经三藏朝散大夫试鸿胪少卿传教大师臣法天奉　诏译

如婆罗门言。众典之内。四围陀正。又于此中念为其正。又此念中能所诠正。又于此中能诠为正。唯此最上无法过此。世若无此业云何作。由此能诠。若爱若恚从此而生。如一切姓婆罗门上。今此言诠亦复如是

此理不然。所以者何。彼婆罗门何姓何命。复云何知。行业云何。如何得此婆罗门名。又此围陀。云何称正。帝释元因。云何傍生傍生云何。生于月天。日天元因。复生傍生。风天火天水天元因。展转往来。云何如是

又彼妄执。天中死已复生天中。人中死已复生人中。傍生亦然。四围陀内作此说者。皆非正理。此命是何。何因名命。婆罗门等亦复如是

又汝外道婆罗门言。正典所说。婆啰帝山产七禽兽。那娑啰陀及别鹿迦陵惹哩山。彼山所有鹦鹉鹭[斯/鳥]鹅鹿之类。生在人中俱噜乞晒(二合此云福地)。从彼死已生在婆罗门中。解四围论

此等禽兽鹿鹅鸳鸯。出生人中。彼兽之命。是婆罗门非婆罗门。所以者何。彼命若是而非禽兽。彼命若非彼生婆罗。此言非理

婆罗门执。四围陀论是万法本。亦号真如。非于余姓而许受食

于首陀处数数受利。正违自宗。何名净行。由此亦非真婆罗门

又四围陀婆罗门法。妄执正命及于正法婆罗门种。亦复非理。云何正法。种姓间杂。何名最上。所以者何。非最间杂。其事云何

且如父名那洛乞叉。其子乃名兵誐罗仙。又如父名阿誐悉帝。其子亦名阿誐悉帝(二合)。又如父名布沙野(二合)左。其子乃名娇尸迦。又如其父名俱舍子。其子名为僧萨多(二合)誐。又如父名迦痴那。其子亦名迦痴那。又如父名婆左虞腊么(二合)。其子乃名娇怛么。又如父名迦罗舍(引)。其子乃名讷噜(二合)拏左哩野(二合)。又如父名底逸底哩。其子乃名底帝哩[口*女](尼所引)迦。又如父名捺啰(二合)[牟*含]。子名仙觉。又如母名野鹿采鱼人生。其子乃名嚩野(二合)僧子觉乞晒(二合引)。父首陀姓其子乃名尾湿(二合)弥怛览(二合)。母是毡陀罗。子名嚩瑟姹(二合)。母名乌哩嚩(二合)尸。天所生女非婆罗门。如上所说。何因固执言婆罗门人间最上。又如所执戌噜(二合)底经正亦非理。是故所有婆罗门法。道理亦非

又如所执。婆罗门法。新肉紫矿及盐等物。戌陀应受。汝婆罗门。勿宜受之今何不尔

又如彼计。乳卖婆罗门行虚空堕落非婆罗门。食肉堕空非理亦尔。是故应知。买卖乳肉婆罗门。非戌陀之法。由此当知。一切非食肉乳等人及非买卖。皆总得名婆罗门邪。是故应知。乳肉计卖非婆罗门。妄执非法

又世间姓妄执最上。亦非正法。如刹帝利。毗舍戌达各执最上。应皆总名婆罗门姓

又执苦身名婆罗门。诸有苦身一切总应名婆罗门

又彼妄执杀婆罗门而获罪重。害彼眷属获罪亦尔。复执彼从净天口生。刹帝利姓彼天身上。毗舍首陀身足而生。若杀于彼故获重罪

彼执非理。所以者何。应杀余姓其罪非有。害余眷属非有亦然。由是妄执不契正理

又彼所执。破坏彼行。破坏檀行。及彼受施。若智若身皆获重罪

此不应然。所以者何。身智之中何者得名号婆罗门。应首陀等皆有身智。悉应得名婆罗门邪

又彼妄执。解四围陀及弥[牟*含]婆。并僧佉论尾世史迦。乃至诸论皆悉了达。名婆罗门

此理亦非。如首陀等。亦解彼论晓了彼义。应皆得名婆罗门邪

若修苦行名婆罗门。彼首陀等亦能行之。应亦得名婆罗门邪

解诸术数名婆罗门。彼采鱼人及诸乐人。了解术数种种差别。亦可得名婆罗门邪

是故应知。行非婆罗门。业非婆罗门。檀行受者非婆罗门

彼刹帝利毗舍首陀。亦能行之。应皆得名婆罗门邪。是故应知。非族非业非行非生。乃至于德名婆罗门

彼因何立日如军那花。亦似白月。离一切染善修胜行。威仪无缺戒行具足。善伏诸根除断烦恼。无我无人离诸执着。及贪嗔痴悉皆远离。如是乃名真婆罗门

又离爱染乃至畜生。不生贪着修清净行。名婆罗门

是故得知此速骨噜(二合)大仙所说。此婆罗门非姓非业非德非行。亦非工巧。如旃陀罗。善四围陀工巧艺能德行具足。应可得名婆罗门邪。是故应知。非命非姓非智非身。亦非业行名婆罗门

又如首陀。苦行修学解四围陀。获五通仙。汝婆罗门云何奉事此下种姓。又彼仙道四姓皆得。云何余姓名非最上

又如帝释。往修善业得生彼天。本下种姓。彼经正文作如是说。此婆伽晚及于帝释。彼下种姓。如是征诘。一准于前。又彼所说。大自在天。及于天后口中。生彼帝释诸天及器世间。非从世间生大自在及生天后。本能生末非末生本。是故此言违彼正说。本下种姓。云何妄执从彼而生。故知非理。又如首陀命终生彼大自在天。汝婆罗门。云何奉事彼下种姓

又如汝说。婆罗门法。服气饵药苦行绝食。名婆罗门

彼首陀等亦能行之。此应得名婆罗门邪

又彼所执。于首陀处手中受食经于一月。现身变为首陀之身。后报生中决定作狗

又婆罗门娶首陀女以为其妻。父母家神皆悉远离。死入地狱

此执非理。婆罗门姓与彼首陀有何差别

如迦痴那大仙。从于鹿胎而生。苦行修学乃证仙道。此仙岂可从婆罗门而乃生邪

如嚩野(二合)娑大仙。从采鱼女之所生故。苦行修学而成仙道。此仙岂是婆罗门姓。是故妄执不契正理

又如嚩斯瑟吒(二合)大仙。从于乌哩嚩(二合)尸天女所生。苦行修学乃获仙道。此仙岂是婆罗门生

又如鹿角大仙。生于鹿胎。修习苦行而成仙道。此仙岂是婆罗门邪

又如尾湿嚩(二合)弥怛噜(二合)大仙。从于旃陀罗家女之所生。此仙岂是婆罗门耶。是故应知。调伏诸根不执我人。勤修梵行远离染欲。永息诸惑。由此方名真婆罗门。而非从彼族姓而生。如何妄执。婆罗门姓世间最上。戒行清洁族姓无杂。以此妄执非最为最。是故当知。彼婆罗门。非姓非命非族非行非业非生名婆罗门

又如多人本下种姓。持戒修福而得生天。何因族姓乃生天邪

又如汝宗迦痴曩大仙。尾野(二合)娑大仙。嚩尸瑟吒(二合)大仙。觉善大仙。尾湿嚩(二合)大仙。弥怛啰(二合)大仙。曩啰那大仙。此等大仙皆从下姓种族而生。苦行修因乃获仙道。何故妄执种姓非杂世间最上。是故虚言应非信受

又如彼执。婆罗门姓梵王口生。刹帝利姓梵天臂生。毗舍种姓梵天髀生。从于梵足乃生首陀。是故虚妄多作是执。又执苦行坚守其志名婆罗门。应采鱼人染师皮作及首陀等。坚志苦行。应皆总名婆罗门邪

又执彼形编其髻发。腰带索系手执木杖。衣素俭食名婆罗门。余戌陀等亦能行之。应此总名婆罗门邪。又执四姓皆从梵生。如何父一子姓乃别。应可首陀乃至余族一父所生子姓应殊。此既不尔。彼云何然

又婆罗门从一梵天口中而生。姊妹兄弟自相交契。世所呵厌。汝能行之。云何清净。是故妄执非净称净。如一父母而生四子非可别姓。如何妄执。此婆罗门。此刹帝利。此是毗舍。此是首陀。云何一父子姓各别。是故四姓妄执差别

非如象马牛羊驼鹿师子虎狼形足各异。此是牛迹乃至象迹可分差别。又如一树出生花果。可无有异。非余花卉。生处不同非可令同。汝今四姓道理亦然。若婆罗门若刹帝利乃至首陀。皆从一父之所生故。云何妄执四姓差别

复有天王名喻地瑟致(二合)啰。虔恭合掌来诣仙人吠娑波洒头面礼足而白大仙。云何得名婆罗门德。复云何名婆罗门相。差别之相复有几种愿今演说令我了解

时彼仙人吠娑波洒。乃告王言。忍辱精进静虑般若。此乃名为婆罗门德。远离贪嗔及诸杀害一切有情。是名第一婆罗门相。于他所有一切财物而非贪受。是名第二婆罗门相。远离暴恶性行温和。不封我人。舍离系缚及诸欲染。是名第三婆罗门相。于人天女乃至傍生恒离染着。是名第四婆罗门相。又复成熟一切有情恒起悲愍。调伏诸根清净最胜。是名第五婆罗门相。如是五种悉皆具足。名婆罗门。若封彼我非具五相。皆名首陀。仙人复告喻地瑟耻(二合)啰言。非族非姓及修苦行成婆罗门。彼旃陀等具足五相。亦得名为真婆罗门。由如是理。彼婆罗门亦名首陀。首陀亦名真婆罗门

彼喻地瑟耻(二合)啰白仙人言。彼婆罗门行不杀行获果清净。此乃少分名婆罗门

仙人复告喻地瑟耻(二合)啰言。此四姓别。皆由过去宿业因缘。犹如世间胎生有情。一切皆从秽处根生。有何差别。是故戒行复修德业。名婆罗门。乃至首陀修于德行。成婆罗门

若婆罗门不修德业。此亦得名下劣首陀

又此五根能起恶业。恒应调伏。犹如大海沉溺有情。应求济度令超彼岸。尔时喻地瑟耻(二合)啰王。闻仙所说。了解踊跃。以此所闻回施一切无边有情。悉令晓悟。非为自身及贪己命。我今日夜修习忍辱。远离眷属及于嫉妒。一切欲境更不耽着。趣求解脱恒修净行

仙人复告喻地瑟耻(二合)啰言。不杀有情远离贪嗔清净无比。如是名为婆罗门行。调伏诸根。布施忍辱。真实梵行。悲念愍护一切有情。修习智慧。如是名为婆罗门行。离邪苦行。应有情机所有众苦。如是名为婆罗门行

又婆罗门誐野怛哩(二合)经咒中说。苦行离执调伏诸根。四时行施爱念有情。舍离睡眠。恒修净行经于千劫。方得名为真婆罗门

仙人复告喻地瑟耻(二合)啰言。若人解了四围陀论。名婆罗门。称姓最上。余首陀姓亦能了解。何非最上

譬如四姓同游圣境。所有踪迹。不可分别此人之踪非彼人迹。一姓四姓亦复如是。由假施设本无差别

又如世间牛马等形。相状虽异。男女二根同类不殊。彼婆罗门与刹帝利毗舍首陀。一姓四姓相望亦然

又如一人血肉屎尿手足诸根。与众多人所有血肉同类亦然

又如莲花刹怛哩花月螺光色可分差别。于余四姓色相无异。如何差别。又如牛马乃至象鹿行于染欲。而非交契可分差别。今婆罗门与刹帝利毗舍首陀。互相交契而行染欲。皆同胎生有何差别

又如婆罗门所生之女。对余婆罗门同姓姊妹。云何交契。姊妹兄弟夫妻乃尔。世间首陀非行此法

譬如世间忧昙钵树。花果枝叶虽复众多根身无异。非能分别此彼之花。汝婆罗门亦复如是。非可交会同姓姊妹。世所呵厌非可行之

又如舍离身语不善恒修净业名婆罗门。破毗舍等亦能行之。得彼大仙名嚩私瑟姹(二合)

又如世间之火能烧柴薪而无分别。今婆罗门对余诸姓无异亦然

又如彼宗弥野(二合)娑大仙。本是采鱼父之所生。亦非是彼婆罗门生

又如半拏嚩王。兄弟五人同一母生父乃各别。此由宿业同母别父非由于姓。而妄执别

又如世间盐处于水。形虽可隐盐味非无。宿业随身隐显亦然。如是妄执。诸有智人。应当审悉非可依信

金刚针论


龙树菩萨劝诫王颂

    No. 1674 [Nos. 1672, 1673]

龙树菩萨劝诫王颂

        大唐三藏法师义净译

此颂是龙树菩萨以诗代书。寄与南印度亲友乘土国王一首。此书已先译神州处藏人多不见。遂令妙语不得详知。为此更定本文。冀使流通罔滞。沙门义净创至东印度耽摩立底国译

  有情无知覆心故　　由此兴悲为开解
  大德龙树为国王　　寄书与彼令修学

此一行颂乃是后人所述标书本意也

  具德我演如如教　　为生福爱而兴述
  真善宜应可审听　　此颂名为圣只底
  随何木等雕佛像　　诸有智者咸供养
  纵使我诗非巧妙　　依正法说勿当轻
  王虽先解如如教　　更闻佛语增胜解
  犹如粉壁月光辉　　岂不鲜明益姝妙
  佛法并僧众　　施戒及与天
  一一功德聚　　佛说应常念
  十善诸业道　　身语意常亲
  远离于诸酒　　亦行清净命
  知财体非固　　如法施苾刍
  贫贱及再生　　来世为亲友
  众德依戒住　　如地长一切
  勿冗瘦杂悕　　佛说应常习
  施戒忍勇定　　惠不可称量
  此能到应修　　渡有海成佛
  若孝养父母　　其家有梵王
  现招善名称　　来世生天堂
  杀盗淫妄说　　耽食爱高床
  断诸酒歌舞　　华彩及涂香
  若女男能成　　此八支圣戒
  欲界六天上　　长净善当生
  悭谄诳贪怠　　慢淫嗔氏族
  多闻年少娇　　并视如怨贼
  说无生由勤　　有死因放逸
  勤能长善法　　尔可修谨慎
  先时离放逸　　后若改勤修
  犹如云翳除　　良宵睹明月
  孙陀罗难陀　　央具理摩罗
  达舍绮莫迦　　翻恶皆成善
  勇进无同忍　　勿使忿势行
  终得不还位　　佛证可除嗔
  他人打骂我　　欺陵夺我财
  怀恨招怨诤　　舍恨眠安乐
  如于水土石　　人心尽彼同
  起烦恼前胜　　爱法者如后
  佛说三种语　　人美实虚言
  犹如蜜花粪　　弃后可行前
  今明后亦明　　今闇后还闇
  或今明后闇　　或今闇后明
  如是四种人　　王当依第一
  自有生如熟　　亦有熟如生
  亦有熟如熟　　或复生如生
  庵没罗果中　　有如是差别
  人亦同彼四　　难识王应知
  勿睹他妻室　　设观如母女
  姊妹想随年　　起贪思不净
  如闻子藏命　　防持躁动心
  兽药刀怨火　　无令欲乐侵
  由欲作无利　　譬如兼博果
  佛说彼应除　　生死牢枷锁
  谲诳常摇境　　能降斯六识
  执仗扫众怨　　许初为勇极
  臭气九门众秽室　　行躯难满薄皮缠
  请看少女除庄彩　　折别形骸恶叵言
  癞虫穿已痛　　求安就火边
  止息无由免　　耽欲亦同然
  为知真胜理　　作意观众事
  唯斯德应习　　无余法可亲
  若人具族望　　貌美复多闻
  无智破尸罗　　是人何足责
  若人无族望　　貌丑寡知闻
  有智护尸罗　　人皆应供养
  利无利苦乐　　称无称毁讥
  了俗世八法　　齐心离斯境
  再生天乞士　　父母妻子人
  勿由斯造罪　　狱果他不分
  若行诸罪业　　非如刀斩伤
  待至临终际　　恶业果全彰
  信戒施净闻　　惭愧及正慧
  七财牟尼说　　共有物诚虚
  博弈乐观諠杂境　　懒惰恶友敦亲志
  饮酒非时行六过　　此劫芳名尔应弃
  求财少欲最　　人天师盛陈
  若能修少欲　　虽贫是富人
  若人广求诸事者　　还被尔许苦来加
  智者若不修少欲　　受恼还如众首蛇
  禀性抱怨如杀者　　欺轻夫主如男偶
  纵使片物必行偷　　宜可弃兹三贼妇
  顺若姊妹慈如母　　随从若婢伴犹亲
  如兹四妇宜应供　　应知此室号天人
  受餐如服药　　知量去贪嗔
  不为肥憍傲　　但欲住持身
  勤躯度永日　　于初后夜中
  眠梦犹存念　　勿使命虚终
  慈悲喜正舍　　修习可常研
  上流虽未入　　能生梵世天
  舍杂欲苦寻喜乐　　随业当生四地中
  大梵光音及遍净　　广果天生与彼同
  若恒修对治　　德胜愍众生
  此五行为善　　不行为大恶
  雨盐碱少水　　岂若泻江池
  纵令微罪业　　善大殄应知
  嗔掉举恶作　　惛睡欲贪疑
  如斯五盖贼　　常偷诸善利
  有五最胜法　　信勇念定慧
  于此应勤习　　能招根力顶
  病苦死爱别　　斯皆自业为
  未度可勤修　　对品亡娇恣
  若悕天解脱　　尔当修正见
  设使人行善　　邪见招恶果
  无乐常无我　　不净审知人
  妄念四倒见　　难苦在兹身
  说色不是我　　我非有于色
  色我非更在　　知余四蕴空
  不从时节生　　非自然本性
  非无因自在　　从愚业爱生
  戒禁见身见　　及毗织吉蹉
  应知三种结　　能缚木叉门
  解脱终依己　　不由他伴成
  勤修闻戒定　　四真谛便生
  增上戒心慧　　兹学可常修
  百五十余戒　　咸归此三摄
  于身住身念　　兹路善修常
  如其亏正念　　诸法尽沦亡
  寿命多灾厄　　如风吹水泡
  若得瞬息停　　卧起成希有
  卒归灰燥烂　　粪秽难久持
  观身非实法　　灭坏堕分离
  大地迷卢海　　七日出烧燃
  况此极微躯　　那不成煨烬
  如是无常亦非久　　无归无救无家室
  生死胜人须厌背　　并若芭蕉体无实
  海龟投木孔　　一会甚难遭
  弃畜成人体　　恶行果还招
  金宝盘除粪　　斯为是大痴
  若生人作罪　　全成极憃儿
  生中依善友　　及发于正愿
  先身为福业　　四大轮全获
  佛言近善友　　全梵行是亲
  善士依佛故　　众多证圆寂
  邪见生鬼畜　　泥黎法不闻
  边地蔑戾车　　生便痴哑性
  或生长寿天　　除八无暇过
  闲暇既已得　　尔可务当生
  爱别老病死　　斯等众苦处
  智者应生厌　　说少过应听
  母或改为妇　　父乃转成儿
  怨家翻作友　　迁流无定规
  一一饮母乳　　过于四海水
  转受异生身　　更饮多于彼
  过去一一生身骨　　展转积若妙高山
  地土丸为酸枣核　　数己形躯岂尽边
  梵主世皆供　　业力终沦地
  纵绍转轮王　　回身化奴使
  三十三天中妓女乐　　多时受已堕泥黎
  速疾碜毒经诸苦　　磨身碎体镇号啼
  妙高岑受乐　　地软随其足
  转受煻煨苦　　行经粪屎狱
  欢喜芳园里　　天女随游戏
  堕落剑林中　　截手足耳鼻
  或入曼陀妙池浴　　天女金花艳彩容
  舍身更受泥黎苦　　热焰难当灰涧中
  欲天受法乐　　除贪大梵天
  更堕阿毗止　　薪焰苦恒连
  或生居日月　　身光遍四洲
  一朝归黑闇　　展手见无由
  三种灯明福　　死后可持将
  独入无边闇　　日月不流光
  有命黑绳热　　合叫无间下
  斯等恒缠苦　　烧诸行恶者
  或若麻床[打-丁+此]　　或粉如细末
  如利斧斫木　　犹如锯解割
  猛火恒煎煮　　令饮热铜浆
  驱令上剑刺　　叉身热铁床
  或时高举手　　铁牙猛狗餐
  鹰鸟觜爪利　　任彼啅心肝
  虻蝇及诸虫　　其数过千亿
  利觜唼身躯　　急堕皆餐食
  若人具造众罪业　　闻苦身自不干堕
  如此顽騃金刚性　　气尽泥犁遭猛火
  时观尽变闻应念　　读诵经论常寻鞠
  泥犁听响已惊惶　　如何遣当斯异熟
  于诸乐中谁是最　　爱尽无生乐最精
  于众苦内谁为极　　无间泥犁苦极成
  人间一日中　　屡刺三百槊
  比地狱轻苦　　毫分宁相捅
  此处受极苦　　经百俱胝秋
  如其恶未尽　　命舍定无由
  如是诸恶果　　种由身语心
  尔勤随力护　　轻尘恶勿侵
  或入傍生趣　　杀缚苦恒亲
  远离于寂善　　更互被艰辛
  或被杀缚苦　　求珠尾角皮
  锥鞭钩斲顶　　踏拍任他骑
  受鬼望不遂　　无敌苦常临
  饥渴及冷热　　困怖苦恒侵
  口小如针孔　　腹大等山丘
  饥缠纵己粪　　得少定无由
  形如枯杌树　　皮方作衣服
  炬口夜夜然　　飞蛾堕充食
  血脓诸不净　　福少获无从
  更相口排逼　　还餐瘿熟痈
  月下便招热　　日中身遂寒
  望果唯空树　　瞻江水剩干
  如是受众苦　　经万五千年
  长时击身命　　良由苦器坚
  若生饥鬼中　　遭斯一味苦
  非贤涩者爱　　佛说由悭垢
  生天虽受乐　　福尽苦难思
  终归会坠堕　　勿乐可应知
  厌坐衣沾垢　　身光有变衰
  液下新流汗　　头上故花萎
  如斯五相现　　天众死无疑
  地居人若卒　　闷乱改常仪
  若从天处堕　　众善尽无余
  任落傍生鬼　　泥犁随一居
  阿苏罗本性　　纵令全觉慧
  忿天生苦心　　趣遮于见谛
  如是漂流生死处　　天人畜及阿苏罗
  下贱业生众苦器　　鬼趣兼投捺落迦
  纵使烈火燃头上　　遍身衣服焰皆通
  此苦无暇能除拂　　无生住想涅槃中
  尔求尸罗及定慧　　寂静调柔离垢殃
  涅槃无尽无老死　　四大日月悉皆亡
  念择法勇进　　定慧喜轻安
  此七菩提分　　能招妙涅槃
  无慧定非有　　缺定慧便溺
  若其双运者　　有海如牛迹
  十四不记法　　日亲之所说
  于此勿应思　　不能令觉灭
  从无知起业　　由业复生识
  识缘于名色　　名色生六处
  六处缘于触　　触生缘于受
  受既缘于爱　　由爱招于取
  取复缘于有　　有复缘于生
  生缘于老死　　忧病求不得
  轮回大苦蕴　　斯应速断除
  如其生若灭　　众苦珍无余
  最胜言教藏　　深妙缘起门
  如能正见此　　便观无上尊
  正见命正念　　正定语业思
  此谓八圣道　　为寂可修治
  无由集爱起　　托身众苦生
  除斯证解脱　　八圣道宜行
  即此瑜伽业　　四种圣谛因
  虽居舍严饰　　智遮烦恼津
  不从空处堕　　如谷因地造
  诸先证法人　　皆凡具烦恼
  何假多陈述　　除恼略呈言
  事由情可伏　　圣谈心是源
  如上所陈法　　苾刍难总行
  随能修一事　　勿令虚夭生
  众善皆随喜　　妙行三自修
  回向为成佛　　福聚令恒收
  后生寿无量　　广度于天人
  犹如观自在　　极难等怨亲
  生老病死三毒除　　佛国托生为世父
  寿命时长量叵知　　同彼大觉弥陀主
  开显尸罗及舍惠　　天地虚空名遍彰
  大地居人及天众　　勿使妖妍女爱伤
  烦恼羁缠有情众　　绝流生死登正觉
  超度世间但有名　　由获无生离尘浊

阿离野那伽曷树那菩提萨埵苏颉里蜜离佉。了(阿离野是圣。那伽是龙是象。曷树那义翻为猛。菩提萨埵谓是觉情。苏颉里即是亲密。离佉者书也。先云龙树者讹也)

龙树菩萨劝诫王颂


龙树菩萨为禅陀迦王说法要偈

    No. 1672 [Nos. 1673, 1674]

龙树菩萨为禅陀迦王说法要偈

        宋罽宾三藏求那跋摩译

  禅陀迦王应当知　　生死苦恼多众过
  悉为无明所覆障　　吾欲为彼兴利益
  譬如刻画造佛像　　智者见之宜恭敬
  我依如来说正法　　大王亦应深信受
  汝虽先闻牟尼言　　今若听受转分别
  犹如华池色清净　　月光垂照踰晖显
  佛说六念当修习　　所谓三宝施戒天
  修行十善净三业　　离酒放逸及邪命
  观身命财速危朽　　应施福田济穷乏
  施为坚牢无与等　　最为第一亲近者
  勤修净戒除瑕秽　　亦莫悕求愿诸有
  譬如大地殖众物　　戒亦如是生诸善
  修忍柔和舍嗔恚　　佛说是行最无上
  如是精进及禅智　　具此六行超生死
  若能在家孝父母　　此即名为胜福田
  现世流布大名称　　未来福报转无量
  杀盗淫欺耽荒酒　　雕床高广及香熏
  讴歌倡伎过时食　　如斯众恶宜远离
  若少时间修此戒　　必受天乐升涅槃
  悭嫉贪欲及谄伪　　诳惑颠倒与懈怠
  如此众恶不善法　　大王当观速弃舍
  端正尊豪及五欲　　当知危朽若泡沫
  莫恃若斯不坚法　　憍逸自恣生诸苦
  欲长诸善证甘露　　应当远离如弃毒
  有能精勤舍嗔慢　　譬如除云显秋月
  犹如指鬘与难陀　　亦如差摩贤圣等
  如来说有三种语　　入意真实虚妄言
  入意如花实犹蜜　　虚妄鄙恶若粪秽
  应当修习前二言　　速宜除断虚妄者
  从明入明四种法　　王当分别谛思惟
  二种入明是应修　　若就痴冥当速舍
  庵婆罗果四种变　　人难分别亦如是
  当以智慧深观察　　若实贤善宜亲近
  虽见女人极端严　　当作己母姊女想
  设起贪欲染爱心　　应当正修不净观
  是心躁动宜禁制　　如防身命及珍宝
  欲心若起应惊怖　　犹畏刀剑恶兽等
  欲为无利如怨毒　　如此之言牟尼说
  生死轮回过狱缚　　应当勤修求解脱
  六入躁动驰诸境　　应当摄持莫放逸
  若能如是摄诸根　　胜于勇将摧强敌
  是身不净九孔流　　无有穷已若河海
  薄皮覆蔽似清净　　犹假璎珞自庄严
  诸有智人乃分别　　知其虚诳便弃舍
  譬如疥者近猛焰　　初虽暂悦后增苦
  贪欲之想亦复然　　始虽乐着终多患
  见身实相皆不净　　即是观于空无我
  若能修习斯观者　　于利益中最无上
  虽有色族及多闻　　若无戒智犹禽兽
  虽处丑贱少闻见　　能修戒智名胜士
  利衰八法莫能免　　若有除断真无匹
  诸有沙门婆罗门　　父母妻子及眷属
  莫为彼意受其言　　广造不善非法行
  设为此等起诸过　　未来大苦唯身受
  夫造众恶不即报　　非如刀剑交伤割
  临终罪相始俱现　　后入地狱婴诸苦
  信戒施闻慧惭愧　　如是七法名圣财
  真实无比牟尼说　　超越世间众珍宝
  大王若集此胜财　　不久亦证道场果
  博弈饮酣好琴瑟　　懈怠憍逸及恶友
  非时轻躁多动乱　　如斯七法当远离
  知足第一胜诸财　　如此之言世尊说
  知足虽贫可名富　　有财多欲是名贫
  若丰财业增诸苦　　如龙多首益酸毒
  当观美味如毒药　　以智慧水洒令净
  为存此身虽应食　　勿贪色味长憍慢
  于诸欲染当生厌　　勤求无上涅槃道
  调和此身令安隐　　然后宜应修斋戒
  一夜分别有五时　　于二时中当眠息
  初中后夜观生死　　宜勤求度勿空过
  四无量定当修习　　是名开于梵天道
  若专系念四禅心　　命终必生彼天处
  有为迁动皆无常　　苦空败坏不坚固
  无我无乐不清净　　如是悉名对治法
  若有深观此法门　　未来常处尊豪位
  修行五戒断五邪　　是亦大王所应念
  譬如少盐置恒河　　不能令水有碱味
  微细之恶遇众善　　消灭散坏亦如是
  五邪若增劫功德　　王当除灭令莫长
  信等五根众善源　　是宜修习令增盛
  生等八苦常炽燃　　当持慧水洒令灭
  欲求天乐及涅槃　　应勤修习正知见
  虽有利智入邪道　　微妙功德永无余
  四种颠倒害诸善　　是故当观莫令生
  谓色非我我非色　　我中无色色无我
  于色生此四种心　　自余诸阴皆如是
  是二十心名颠倒　　若能除断为最上
  法不自起冥初生　　非自在作及时有
  皆从无明爱业起　　若无因缘便断坏
  大王既知此等因　　当燃慧灯破痴闇
  身见戒取及疑结　　此三能障无漏道
  王若毁坏令散灭　　圣解脱法当现显
  譬如盲人问水相　　百千万劫莫能了
  欲求涅槃亦如是　　唯自精勤后方证
  欲假眷属及知识　　而得之者甚难有
  是故大王当精进　　然后乃可证寂灭
  施戒多闻及禅定　　因是渐近四真谛
  人主故应修慧明　　行斯三法求解脱
  若能修此最上乘　　则摄诸余一切善
  大王当观身念法　　世尊说为清净道
  若无此念增恶觉　　是故宜应勤修习
  人命短促不久留　　如水上泡起寻灭
  出息入息眠睡间　　念念恒谢常衰灭
  不久便当见磨灭　　皮肉臭烂甚可恶
  青瘀胀坏脓血流　　虫蛆唼食至枯竭
  发毛爪齿各分散　　风吹日曝渐干尽
  当知此身不坚牢　　无量众苦所积聚
  是故贤圣诸智人　　皆观斯过咸弃舍
  须弥巨海及江河　　七日并照皆融竭
  如此坚固尚摧毁　　况复若斯危脆身
  无常既至无救护　　不可恃怙及追求
  是故大王常谛观　　速生厌离求胜法
  人身难得法难闻　　犹如盲龟遇浮孔
  既获若斯希有身　　宜应勤心听正法
  得此妙身造诸恶　　譬如宝器盛众毒
  生处中国遇善友　　专念发心起正愿
  久殖功德具诸根　　王今满足此众善
  若复亲近见知人　　佛说此为净梵行
  是故应当乐随顺　　诸佛由此证涅槃
  既遇微妙清净法　　应当志求离欲道
  生死崄难苦无量　　穷劫宣说莫能尽
  我今为王略分别　　应当谛听善思惟
  三界转变无轮际　　父母妻子更相因
  怨亲憎爱无常处　　如旋火轮岂穷已
  无始生死世界来　　计饮母乳多大海
  若不精勤证空智　　将来复饮无穷限
  周流五道经人天　　若积身骨高须弥
  爱别哀悲计其泪　　亦非江河所能匹
  若计一人父母者　　过于世间草木数
  虽受五欲天上乐　　终还坠没恶趣苦
  诸天寿命极长远　　其间娱乐难宣说
  歌讴倡舞流妙声　　哀音和雅甚清远
  奇姿妙色极端严　　围绕侍卫相娱乐
  百味盛馔皆具足　　随意所玩自然至
  宝池香净水恒满　　周匝罗覆诸妙花
  众鸟异色集其上　　哀声相和出远音
  诸天游戏浴其内　　如是欢娱不可说
  福尽临终五衰现　　尔时生苦踰前乐
  是故虽有天女娱　　智者见之已生厌
  虽居珍宝上楼观　　亦必退堕臭秽处
  虽游天上难陀园　　会亦还入刀剑林
  虽浴诸天曼陀池　　终必坠于灰河狱
  虽复位处转轮帝　　归为僮仆被驱使
  虽受梵天离欲娱　　还坠无间炽然苦
  虽居天宫具光明　　后入地狱黑闇中
  所谓黑绳活地狱　　烧割剥刺及无间
  是八地狱常炽燃　　皆是众生恶业报
  或受大苦如押油　　或碎身体若尘粉
  或解支节今分散　　或复[利-禾+皮]剥及烧煮
  或以沸铜澍其口　　或以铁押裂其形
  铁狗竞来争食啖　　铁鸟复集共龃掣
  众类毒虫并[齒*齊]啮　　或烧铜柱贯其身
  大火猛盛俱洞燃　　罪业缘故无逃避
  镬汤腾沸至高涌　　颠倒罪人投其内
  人命危朽甚迅驶　　譬如诸天喘息顷
  若人于此短命中　　闻上诸苦不惊畏
  当知此心甚坚固　　犹如金刚难摧坏
  若见图画闻他言　　或随经书自忆念
  如是知时已难忍　　况复己身自经历
  无间无救大地狱　　此中诸苦难穷尽
  若复有人一日中　　以三百鉾[打-丁+(爂-火+焱)]其体
  比阿毗狱一念苦　　百千万分不及一
  受此大苦经一劫　　罪业缘尽后方免
  如是苦恼从谁生　　皆由三业不善起
  大王今虽无斯患　　若不修因缘坠落
  于畜生中苦无量　　或有系缚及鞭挞
  无有信戒多闻故　　恒怀恶心相食啖
  或为明珠羽角牙　　骨毛皮肉致残害
  为人乘驾不自在　　恒受瓦石刀杖苦
  饿鬼道中苦亦然　　诸所须欲不随意
  饥渴所逼困寒热　　疲乏等苦甚无量
  腹大若山咽如针　　屎尿脓血不可说
  裸形被发甚丑恶　　如多罗树被烧剪
  其口夜则大火燃　　诸虫争赴共唼食
  屎尿粪秽诸不净　　百千万劫莫能得
  设复推求得少分　　更相劫夺寻散失
  清凉秋月患焰热　　温和春日转寒苦
  若趣园林众果尽　　设至清流变枯竭
  罪业缘故寿长远　　经有一万五千岁
  受众楚毒无空缺　　皆是饿鬼之果报
  正觉说斯苦恼因　　名曰悭贪嫉妒业
  若天福尽有余善　　因此得为人中王
  后设懈怠福都尽　　必坠三恶无有疑
  或生修罗起贡高　　恚嫉贪害增诸恼
  诸天虽有善根行　　以其悭嫉失利乐
  是故当知嫉妒结　　为深恶法宜弃舍
  大王汝今已具知　　生死过患多众苦
  应当勤修出世善　　如渴思饮救头燃
  若加精进断诸有　　于诸善中最无上
  当勤持戒习禅智　　调伏其心求涅槃
  涅槃微妙绝诸相　　无生老死及衰恼
  亦无山河与日月　　是故应当速证知
  若欲证于无师智　　应当专修七觉法
  若有乘斯觉分船　　生死大海易超渡
  佛所不说十四法　　但生信心莫疑惑
  唯当正心勤精进　　决定修习诸善法
  无明缘行识名色　　六入触受爱取有
  有则缘生生缘死　　若尽生死因缘灭
  如是正观十二缘　　是人则见圣师子
  若欲次第见四谛　　当勤修习八正道
  虽居尊荣处五欲　　亦得圣道断诸结
  此果不可求余人　　必自心会乃得证
  我说众苦及涅槃　　欲为润益大王故
  不应生于怖畏心　　但勤诵习行诸善
  心为诸法之根本　　若先调伏事斯办
  我说法要略分别　　王不宜应生足心
  若有大智更敷演　　亦当至心勤听受
  王今名为大法器　　若广闻法必多益
  若见有修三业善　　应深助生随喜心
  自所行善及随喜　　如是功德悉回向
  王当仰学诸贤圣　　如观音等度众生
  未来必当成正觉　　国无生老三毒害
  大王若修上诸善　　则美名称广流布
  然后以此教化人　　普令一切成正觉
  烦恼驶河[漂*寸]众生　　为深怖畏炽然苦
  欲灭如是诸尘劳　　应修真实解脱谛
  离诸世间假名法　　则得清净不动处
  若有妇人怀害心　　如此之妻宜远离
  设有贞和爱敬夫　　谦卑勤业若婢使
  恒为亲友姊母想　　此宜尊敬如宅神
  我所说法正如是　　王当日夜勤修行

龙树菩萨为禅陀迦王说法要偈


密迹力士大权神王经偈颂

    No. 1688

    密迹力士大权神王经偈颂序

        古汴龙华寺住持沙门智昌述

盖闻瞿昙演教。普利含生。历代诸师。三分科经。谓序分正宗分流通分。秽迹金刚说神通大满陀罗尼法术灵要门经者。北天竺国三藏沙门无能胜。与三藏沙门阿质达霰同译二经。同卷阙流通分。已入大藏经伊字函第一卷中。是故如来于涅槃台左胁。化现秽迹明王三头八臂。降伏螺髻梵王。说咒划四大宝印书符。四十二道结。五指印契。普利有情。历代以来。持咒行法者僧俗甚多。未达信受奉行先二师同译。后宋曾稽沙门智彬。将此经重行校勘治定。补阙流通。题曰佛入涅槃现身神王顶光化佛说大方广大圆满大正遍知神通道力陀罗尼经。今此经中说大权神王降伏螺髻梵王。复次住世梵王启请。复化现出三头八臂忿怒相。执持器仗与前无异。本王寂定。次化王画出三头八臂。顶上化佛相仪。划四大宝印书。四十二灵符指结。五印契悉皆付与。螺髻梵王受持奉行。尔时化佛与螺髻梵王摩顶授记。号清净光明如来。已于是化王复隐入本王身中。本王紫金光聚隐入金棺。茶毗之后。各分舍利顶戴奉行。所说咒符印五指印契。已在前伊字函二经内。今此经中更不重述前说。本咒内阙九字咒。句续次添入。今广福大师僧录管主八。归命三宝。独心内典。集成偈颂。补阙流通。亦曰密迹力士大权神王经。广行遍布。后有持咒行法之者。了明前后经旨。详而行持。自利利他。福报无穷。集此功勋。上答

佛恩。祝

圣人寿。愿冀

佛日重辉。法轮常转

密迹力士大权神王经偈颂

        元广福大师僧录管主八撰

  归命最上乘　　依经入流通
  愿共诸众生　　同证光明中
  广福心无虑　　幻身四生出
  小习学经书　　忘却真如理
  留心在教典　　早晚参经旨
  心昏未晓得　　念念资熏修
  无有间断期　　若不访究竟
  光明四大归　　何时再出遇
  今逢大觉尊　　广开方便门
  锓梓施梵书　　遍布不全璧
  未至逡巡间　　遐迩八分足
  皆是正遍祐　　觉皇慈悲力
  虽省真空理　　万行未曾毕
  三世诸佛说　　如来一大事
  皆从众生起　　众生无贪嗔
  诸佛因何说　　权行实化彼
  初生至涅槃　　金棺银椁里
  天人四众啼　　螺髻恶神王
  烹宰立一国　　众生被食啖
  我佛又出世　　青黑八臂王
  手执八物诛　　此魔便归依
  众生免遭迍　　等觉胜慈悲
  授与恶魔记　　臣佐眷属类
  累劫清净陀　　海会得省悟
  权化实忿怒　　遭诛莲藏界
  永无恶念起　　是佛慈悲门
  持念不空矣　　依经达修行
  已见真如际　　但求世间事
  无果不随意　　若不志诚者
  虚劳难得遂　　愚蠢劝高智
  不是诳言语　　若不真语者
  愿入击毬狱　　四十二道秘
  四大宝篆文　　大权金刚意
  六印指爪上　　无得乱曲之
  我今详经意　　末法定在世
  护教护君主　　当来弥勒世
  正像末法时　　随类一体出
  本智化后智　　化佛宣密语
  大权化次王　　次王慈悲书
  愿得经中义　　一切众生悟
  晓暮勤参礼　　念念长不息
  看阅大华严　　无有推其理
  海幢比丘问　　方省能仁意
  佛开最上乘　　诸人尽可入
  印经施诸方　　大觉本无语
  念念资随类　　身语及意业
  无有厌怠时　　拙口钝词舌
  无能敢下笔　　不昧真如理
  末法一万年

三宝印证无增减

八部威严常加护

苗裔甘蔗刹帝清净种。为大因缘末法能传授。跋提河边双树寂灭定。八部懊恼世主号哭倒

诸国帝王同时来佛会。捶胸跌脚哽噎啼哭礼。声动三界日月光明暗。愁云惨雾山崩地裂吼

飞鸟悲鸣草木枯干萎。源泉涸竭海水腾波起。凡有物像无不挂孝衣。罗汉应真不晓真谛理

菩提萨埵达其化理趣。了悟无常安禅如虚空。不生不灭留惑润生里。十二缘生叶落方见迹

蠢动含灵本有成佛性。三界诸天前赴涅槃供。诸大帝王哀恋慕如来。螺髻轻蔑商量差仙取

诸天便差大力咒仙取。各执宝杵收摄魔王去。才嗅秽气锁在禁中围。无法取归诸天前来礼

愿佛慈悲慈悲哀纳受。魔鬼灾害一方食生命。劫夺室女欲乐快活受。积骨如山愿佛化归顺

诸王动哭如来寂灭后。贡高我慢恶鬼不敬信。诸天差仙七日不还归。愁闷滴泪来礼金棺躯

能仁慈父顺人归寂灭。众生造恶感得魔王出。螺髻苦害食啖众生肉。愿佛慈悲去邪众生主

根本智佛常乐寂光已。后智化现三头八臂立。都摄宝印火轮金刚挥。罥索铃音八龙缠身臂(二一右手开山印二手金刚杵三手宝铃四手宝印戟左一手都摄印二手火轮三手罥索四手宝剑)

九目三面利剑宝印戟。青黑蓝淀发赤上竖起。次佛宣咒大现光明辉。无量魔王尽赴恭敬礼

腕惯宝鋜足按阎浮界。右足印空彩裙缭绕起。智火洞然塞满虚空中。读诵受持定到无生位

加持本咒四十三字母。顶光如来亲说伽陀启。法界含识世主及无数。听说梵音圆满陀罗尼(前咒内阙九字咒句续添入)

唵(引)[口*佛]吼啒[口*聿]　摩诃般啰　啒那嘘　吻只吻　醯摩尼　微吉微　摩那栖　唵拶割啰　呜深暮哏[口*聿]　唅唅　吽吽　癹癹萨诃(今添入咒句唵拶割啰醯摩尼吽吽癹)

无念观定归依三宝竟。次发菩提不求人天果。愿诸众生同证无上乘。情器变空自魔遣教净

四无量起心月轮中吽。光升虚空无量诸佛至。镜像影灭本体神王出。发朱尖严化身端严处

三枚九眸手执六件宝。劫火炽然安详忿怒势。吽光再召智佛一念至。灌漱濯足五种香华备

拶吽[口*邦]和智句不二一。青心喉顶十方诸佛赴。甘露灌顶注满光明器。身口意净究竟我佛诵

南无本师释迦牟尼佛。南无化身释迦牟尼佛。南无大权神王佛(各念十声)。念诵秘章心口相应和。十万百万定证涅槃路

左心所化大权神王出。威严显赫非天非人礼。眉放毫光十方世界知。华鬘宝盖诸天奏乐起(住世梵王启请流通)

时有梵王名曰救世主。统领梵众来礼金棺躯。仰告大神不坏金刚体。众生危险如来慈悲出

大神告言救世梵王听。我从金棺示现一七日。天人哀请降伏螺髻鬼。起义不善来犯慈悲主

世尊敕我宣谕四众知。不谓小事怎生出尘世。如来示灭四果诸天疑。嘱累流通经文到处立(化浊世为净土转凡质作佛身)

海会菩萨声闻缘觉侣。八部天龙昼夜常守护。戒定慧修诸事庄严就。菩提先发阿耨多罗证

法身无相生灭如何说。愚痴暗昧邪见忿怒诤。淫欲昏迷火宅疑城起。参透真如那时方到得

顶光化佛宣说神咒起。求于初果直至如来地。五根五力菩提八圣谛。日月四洲岂有昼夜理

慈悲喜舍六度万行起。囕怛清虚顿证佛骨髓。十地三贤成就不离体。众生根渐尽是成佛器

如来智日周遍法界际。光明朗耀众生贪嗔痴。生者见常死者见断绝。无常无断第一真消息

救世梵王领诸梵天众。旋绕金棺礼拜向大神。我自随佛游历十方中。宝杵金刚未有大圣尊

神王宣谕救世梵王听。我从正遍后智化现出。名曰密迹力士大神王。调伏螺髻显示后众生

宝印镇心灵文四十二。扫除妖怪尽归东方世。螺髻贡高道佛入灭去。生灭无相缘毕顺寂定

善逝智力我与难比并。菩萨罗汉神力如爪土。世尊不思却似大地土。魔王私念神通为第一

如来缘毕示现入灭相。魔鬼憍慢不礼敬如来。破其窟宅取彼二部归。令还神观天人休懊

诸天四众心中十分喜。魔王宫殿尽倒及崩摧。魔属凶党战战兢兢倒。或是二仙神通依然起

魔王商议如来再出世。或是二仙坏我境界去。忖已神力不能达得知。两眼泪下早晚祸生矣

顶光化佛口中诵伽陀。光明照耀微尘世界虚。三界魔王宫殿如墨漆。不敢违逆摄取众生去

諕得螺髻八识不在体。大臣徒党地上渐渐起。消灭秽迹魔类尽归依。惟愿慈悲留我残生躯(二部咒仙各还神通力)

闷绝不醒逃生无走路。魂飞胆散开口说不得。二部咒仙各还神通力。瞻仰大神今日得还归

大神咒责咄哉螺髻鬼。甚大愚痴我慢耽乐欲。毒心不改犯着慈悲主。汝应速悔舍邪归正理

汝心不悔早早求忏除。全尔性命瞻礼涅槃去。尔于前世强施慧众生。福尽乐足堕入泥犁去

心业不善造罪如山岳。百千徒党聚集一处居。百千万人每日受灾殃。一人自有八识四蛇随

六情对执举念无悲恶。招诱群生八十八使逼。百恼相牵又添二十恶。十二时中受殃从此起

凶恶徒党天魔为眷属。勾引众生罥入魔党聚。动以万人遭殃受大诛。独存四大五蕴六根主

意识不显五根常宛转。六尘色法七漏八垢动。九结十缠十二被牵缚。二十五有百八烦恼生

八万尘劳回心即时转。八识便转直至解脱道。不动五蕴便证法王身。百惑颠倒顿除百法证

百二十恶转为功德果。八万四千转为光明相。皆汝心造非从外处来。青天无物黑云鼓扇起

忽然云收日月圆明鉴。叆叇阴晦不从外处觅。是汝一心本自圆正迷。悟时当体不损些儿理

回汝恶念便归登正路。宝雨宫殿华鬘等奉献。法界如来菩萨四果僧。天龙世主尽入无为洲

螺髻梵王便向大神礼。两眼泪滴五体投地启。忏悔从前作过不正理。俱发声言南无释迦礼(螺髻王于二仙处求忏悔)

二部咒仙各还神通力。俨然如故卫绕神王立。螺髻帅众发露求忏除。白言圣者愍念休生疑

螺髻启告善来大仙知。我昔习学恶业因缘至。刚强凌物损他众生躯。今逢宣化我今头面礼

魔王宫殿大作佛事起。天地晴霁日月增光辉。飞走忻欢来绕金棺体。双树变白鞠恭接足礼

大权神王领诸魔髻鬼。大臣徒党二仙同瞻礼。佛会四众八部诸天仙。各启恭敬同声说偈礼

种种妄想由彼无明起。造作诸幻魔王为眷属。如来指教不入魔党趣。扶宗立教永远无改意

黄金出矿无明所覆翳。油在面中永远难拔出。矿油分别面白黄金赤。舍邪归正黄白无二种

法界通化三界四生类。唯心一起不在别处觅。初遇明师不入邪曲路。今逢大觉免入轮回狱

黄金打就眼耳鼻舌身。金性无变盆盘钗钏等。万品千差本性甚分明。镕金性定真空自在用

四魔作碍如来慈悲起。麻诃葛刺大权忿怒出。观音大智马项狱帝主。因门不舍来救众生苦

悲心门开救世无为智。慈云普布胎卵湿化覆。茕毒邪见不入菩提路。权贵相登尽归究竟处

神王闻偈八臂摇撼动。九目顾盻按右跷足立。方圆智火紫金棺中出。散坏幻术消灭螺髻鬼

秘章功能普施末法世。十善初入恶口臭秽诵。十方诸佛闻诵神咒音。一记当来直至无说地

文殊普贤观音金刚藏。菩提萨埵舍利空生悟。目连迦叶四果应真侣。赞言善哉香华供养庆

三界诸天忿怒金刚众。闻此咒音屈身侍卫立。凡有所愿无有不果遂。未能达理速获菩提路(诵本咒灵验画符印香木雕杵试验治百病一切等事)

诵我咒王如旱逢甘雨。相击战败再逢大将至。孤露之人路逢父母聚。膏盲老病方逢耆婆医

诵念咒师无得生疑虑。神王钦遵驱使随尔用。天人修罗地狱饿鬼趣。耳闻咒音尽得解脱去

恶心持念尚获殊胜果。精严专注心口相应和。其余功能不如伽陀力。善男信女持念得利益

书此咒即绢纸贝多叶。宝网衣缯华鬘宝箧上。随其所仪诸天龙神护。宝盖覆顶古佛宴然坐

若一微尘堕咒于物上。风吹微尘落在众生身。所得福报如似恒河数。彩画顶像除却阿鼻狱

沈笺檀木工巧跋折罗。宝杵执持杵像曼拏心。香华灯涂果蓏饮食奉。供养释迦忿怒大神尊

香水和泥雕塑慈悲像。百种庄严美器安杵像。虔诚结印不动十万遍。杵摇水涌那时方明证

杵像放光言语及神变。大觉慈尊左心化现出。灵瑞万端心生大欢喜。果乘愿力再诵三十万

神王灵感持诵得法语。设一盆器满盛清净水。诵我秘章昼夜不断声。水涌杵动光明神通证

行住坐卧心口常持诵。果熟三昧通达神交用。所行祠庙神祇皆拱奉。随逐不舍不敢违尊命

四百四病及诸妖精怪。蛊毒阴崇害他众生命。患人宿业多生冤债病。朱书秘咒永远除瘥去

诵念咒师虔诚加持水。朱书方印四十二道秘。翦折叠封护带于身上。捻为丸儿到口除百病

无人书写宝印灵应符。香木雕就蘸砂印于纸。如前翦丸灵验无有二。顶光化佛放大毫光起

首题过去现在及未来。诸佛同音宣说根本咒。成道涅槃无不宣此音。情界四生天龙六部诵

净信男女专心称秘音。欲求佛果世间诸事就。如来萨埵慈悲生大悯。放光动地显大神变用

咒师梦中现其所求事。都摄先结一切咒王祖。古往帝王储君并大臣。身心病疾持念无不应

都摄顿除水涌药光出。服下痊瘥百病难生起。日月薄蚀风雨不依时。五星失度逼迫众生苦

人灾国凶岁俭逆贼起。君臣失措五路都摄录。仰视虚空立期诵咒起。保国安宁永无灾祸起

魏周唐武毁灭佛法僧。不听出家修行明真性。驱逼僧尼还俗差役重。毁灭宗乘定入阿鼻轮

但诵宝玉结前都摄印。苾刍困苦转与恶王所。彼自悔责忏悔心归依。塔庙依然精舍伽蓝起

金银铜铁香篆龙形像。瓮缸水满投像于水际。娑竭罗龙手印都摄录。水涌像动空中鸣雷震

牟尼火化大权神王佛。三种名号及诵佛世尊。大澍甘雨遍洒阎浮地。久雨损物止雷得晴霁

象马驼牛禽兽难调制。时行疾病但饮神咒水。蛇鼠恶虫损他诸般物。水洒屋地自然他无迹

所有禁制一一说不尽。殷勤仔细请看正经去。超凡入圣皆是尔自心。不达真如枉去错用心

夜叉恶鬼山精并地灵。水府岩穴树石一切庙。魍魉邪魔久住人间反。侵犯家国都摄除遣了

金蚕蛇蛊骷髅金银蝎。蜈蚣虾蟆一切蛊神众。饮食中下杀坏良人命。宝印云符佩带无所损

狼心狗[狂-王+幸]人面畜生类。生年日月乳名达得知。朱书彼名脚心踏实地。大手都摄悔责头面礼

心智顽钝无所知分晓。欲求智慧都摄伽陀用。吞服咒印默与大辩才。总持多闻博雅多究竟

贫穷受苦诵念给孤富。长生不死戒定与菩提。惠施众生后世大贵富。学习神丹紫磨黄金胜

分段身形变易常不坏。定入分段神通长自在。似鸟飞空往来无挂碍。顶上出火脚下出水海

变易无碍圣凡难测度。像前禁山诵念如前作。住居乏水穿凿香甜水。众生病证即时消散去

素无子息秘咒都摄录。百病妇女鬼胎延年滞。祖宗见祸男女行孝义。鬼怪山魈咒印即平覆

染劳传尸邪鬼梦交感。鼻口四肢巨富去采宝。若遭官讼囚禁便得免。临敌交锋逆贼自然息

求于佛地无不成就者。佛灭降伏天魔及阐提。一切世事种种无不遂。宝王密语放光如来说

常乐我净系缚心猿意。所愿不果善逝皆虚说。真语实语如来无诳语。阿耨多罗三藐三菩提

伽陀灵验诸佛菩萨说。声闻天仙印符画像设。宿昔大愿禅那精进力。梵志外道聪明如黑漆

宝杵神王如何敢自诜。顶上化佛宣说神咒语。忿怒腾身八臂所执物。普放无量百宝光明出

顶光化佛亦放大人相。合掌当坐口放无量光。互相照映散坏幻术灾。消灭秽迹调伏螺髻鬼

三界诸天四王叨利等。六道修罗住世梵王众。世主恭敬大众跪膝礼。宣说神通圆满密咒音

尔时神王顶光化佛说。大方广大圆满神通力。正遍知觉听法天人众。得净法眼各获三昧证

提携螺髻先遣二部归。前后围绕同到涅槃所。化佛神王遍历十方去。化佛说法利济众生主

大权神王宣谕四众听。适来我佛宣说神咒音。魔宫城堑尽倒不留存。臭气远蒸化成优钵果

根本智佛示现千百亿。常住不灭佛住佛灭去。众生祈祷立大誓愿持。坐处安养幻化法身躯

坚持苾刍坐住多宝塔。精严顿证释迦牟尼尊。誓愿驱使奉承持咒人。获六神通得大解脱门

神王说誓恐人生疑忌。惟愿如来照察真实际。为作证明破诸众生疑。不怀疑怖再阐雷音起

尔时如来虽般涅槃寂。左心示现百宝光明出。十方诸佛放光灌金体。菩萨声闻四众生希奇

螺髻我慢臣左眷属类。同声赞叹心中十分喜。道眼照彻达空真如理。尘沙佛国等觉妙觉地

顶光化佛熙怡微笑起。告示神王大众听宣语。根本智佛释迦牟尼陀。失照降伏作业螺髻鬼

化佛宣说根本智佛灭。螺髻恶逆左心力士出。人天惊疑收摄魔天归。代佛行事真如慈悲出

天魔拱手望着智佛礼。臣属部众缘熟当受记。在会清信各发菩提意。永无退转坚固誓愿持

放光如来舒手摩螺顶。善哉善学舍邪归正路。得蒙授记领悟真如性。改故重新勇猛精进力(螺髻王得蒙授记名曰清净光明佛)

梵王得记同来善知识。六十亿劫修诸菩萨位。广于十方供养恒沙佛。累劫修行证入如来地

螺髻证得清净光明佛。调御丈夫十号皆具足。佛寿二万天人听法音。广宣流布应以杂类身

示现二乘声闻缘觉侣。即现佛身一乘至理趣。胎卵湿化上至菩萨乘。蠢动含灵皆听光明音

证得初果直至辟支位。远行法云十地满心住。成就无上佛果大菩提。正像末法佛寿二万岁

光明如来入灭寂定已。次第授与一尊菩萨继。今日所归大臣眷属类。次第所证光明如来体

其佛国土皆名无垢世。天龙八部四众尽归依。与今所宣清净光明佛。并无差别同住无垢世

无垢世界菩萨二乘人。八部威灵四众听法音。光明如来同今化佛宣。大满神咒四十二道圣

清净如来缘毕涅槃已。三昧智火焚身收舍利。建立宝塔高至梵天所。天人四众供养作福处

尔时螺髻与诸同来类。蒙化如来授与菩提记。欢喜勇锐即获无量乘。一时之间大作佛事起

大权神王谛听化佛说。心中踊跃欢喜赞叹礼。告示清众螺髻诸上人。宿业所感得大善利喜

神王再宣本师释迦佛。示现入灭愍汝末法世。有情包识失了功德利。调伏螺髻有劳如来出

我今所头身相现威仪。根本智佛左心化现出。大满神咒顶光化佛宣。所作功德诵咒法仪式(本体神王结印仪式)

都摄宝印左右无名指。屈向掌中二指相靠[監-皿+豆]。中指左上右下捻同指头。指直[監-皿+豆]大拇中节底

手印加咒世间所有事。恶人邪鬼皆向咒师礼。舍恶逆心尊命听驱使。不敢违逆誓愿坚固力

禁山宝印右手无名曲。四指平直进退各七步。一咒一印左右上下顾。散其咒印自然恶心止

无雷宝印恶风雹雷震。暴雨霖久中指无名小。头指直[監-皿+豆]大拇捻中节。左手印咒云散日光出

顿病宝印右手庄严启。头指中指屈向掌中里。三指并直五劳七伤无。一咒一印一百八遍奇

五路宝印左右无名指。曲向掌中八指皆直立。卒死生人散印于心上。高声诵咒魂魄还壳体

恶入鬼神欲犯持咒主。出入不祥追补逃亡躯。昼夜贼盗牛马猪羊类。飞禽走兽情识不舍去

神王示教众会善知识。五大宝印信受奉行已。四枚正印四十二道秘。传授末法展转流通去

大权别化忿怒次王出。威仪进止与本元无异。本体神王寂然入定住。执物不动从此留像仪(本体神王化现次王忽然于虚空至)

次二神王乘空忽然至。手提贝多白[疊*毛]数丈余。鱼胶矾粉诸般颜色聚。举笔才动像严无二异

次二神王来绕金棺躯。啼哭作礼白言智佛知。螺髻殃害本佛归真际。左心所化本体神王出

本体神王调伏螺髻归。化我分身小王流末世。神通变化惟愿如来知。放光印证表记于凡世

次化神王围绕神王礼。白言圣者大圣化我出。与众施设以假存真实。愿王放光照察真实语

寂定如来毫光棺中出。本体神王百宝光明辉。宝光二道灌在化王顶。诸佛印证流传于凡世(寂定如来放光本体神王放光灌化王顶)

化王即时右手引笔起。圣像端严三头及八臂。九目闪烁执索都圆备。顶光如来合掌端严启(次王昼八臂相仪宝印灵符)

左踏宝石右印跷足立。八龙缠臂一切神变异。本体神王一一都无异。大众瞻仰即时光明出

贝叶所画宿命功德智。智印香木一寸八分刻。篆文深直分明细磨朱。印在素帛永远无灾滞

宿命智印印已吞服竟。即获三昧分段证变易。凡夫幻体难证总持门。垢腻之行顿证净妙心

宿命功能感得现世果。手足心中塔上如意宝。未成最上早获智辩才。心眼灵明诸法自然成

第二隐蔽无见自在印。香木一寸七分刻之用。如是圈篆方法照前同。无为空寂堪拟如来论

三显腾空自在无碍印。香木一寸五分如是空。髻中衣物遍体印咒文。周游尘中方省菩萨行

神气交合自在密咒印。一寸二分深直文篆定。蘸朱印心人非人等敬。不能达空自省难比论

次王所画四大宝印已。堪与众会远画四十二。梵夹灵文贝多叶上成。一一分明不离梵字体

次化神王所画符印讫。大众悲喜次王合掌礼。启白本体化我神王知。并及大众听我说端的

五浊恶世淫欲为根本。生熟二脏腹内作生理。发毛爪齿涕唾及脓血。筋骨髓脑尽是腥膻物

日月风持旋转为昼夜。金木水火土居方隅重。罗睺计都月孛三宿动。四斗分界七星拱北斗

角亢为首二十八员将。盈亏变怪人间主祸福。天罡河魁紫气照人美。一四天下帝释为主宰

根本智佛所化大千界。百亿日月五星列诸宿。主持方隅灾福气候等。众生逆境皆是尔自修

末法善人须从恶党类。促命短寿舍我慈门俗。阐提心发损害苾刍意。咒印紧切依然佛在世

大权忿怒告示化王知。善哉大悲汝能作此事。普满众生均沾大惠恩。大行愿力众生得利益(本体神王赞叹次王)

次二神王所作能事毕。宝印灵符对众亲付嘱。螺髻极授梵夹灵文礼。尔成佛威本支神王力

慈善根力大众贤圣力。诸佛菩萨加被威神力。累劫专心持诵广流布。勿令末法众生遭大苦

次王告示顶光如来说。大满咒王手指结印起。五种宝印列宿四十二。各存神用禁制由汝意

本咒功能说之不可尽。精严加持诏示诸神异。水涌波动宝杵横飞转。像仪光出言语端的奉

梦中禅定亲见释迦尊。法报化身大权神王像。妙音抚须凡有所求祷。神交气合五彩法物隐(次二神王隐)

次二化王放大光明出。本体神王光明从顶起。二王交灌融变化王隐。本体神王八宝依然举

化王既隐力士神王说。适来所化忿怒明王出。画我三头八臂及按石。威仪进止宝印灵符秘(圆明无相)

释迦智佛左心力士起。大权所化次王从空至。虚空法界无量诸如来。皆从毗卢遮那心印出

螺髻鞠恭合掌头面体。多蒙提携摄受归正路。自前恶念今日尽断除。悟自真如与佛同一体

化佛授记螺髻无疑虑。证果成就冷暖自得知。一行部众同受菩提记。我佛慈悲魔属得善利

力士告言螺髻菩萨听。秘章流布直至不退地。听法大众右绕神王立。白言大圣今日方见迹

螺髻白言如来示寂灭。左化神王顶光如来出。我佛说咒力士谈经义。守护流布不敢违佛敕

螺髻发愿如来印证知。末法众生天魔外道欺。分身遍满百亿阎浮提。扫除妖精众生无灾滞

时大神王说是经咒已。八臂器仗顶光如来泯。紫金光聚渐渐近金躯。光明身相尽入如来体

明空寂乐妙有真空虚。迦叶离佛鸡足山中住。观行颠倒徒弟晨朝议。必是如来早晚入灭去(系缚归空寂示现舍利)

付[疊*毛]千疋缠里善逝体。金棺银椁自然空中起。拘尸罗城四门都游履。头陀执薪三昧火自起

八万四千分身真舍利。俵散情界宝塔从此起。天上龙宫先分二停去。弥勒出世迦叶焚身体

信受奉行依经流通颂。诸佛慈愍赦我差错过。誓愿四生同证唯心座。真实无语八识莲宫理

多生障翳方逢良药饵。今生庆幸省得无消息。昧觉群生自省求出离。根本圆明那里常自在

念佛功德利济法界内。情器二处十方无穷类。耳闻佛声顿绝三恶趣。各请承当元来本是尔

密迹力士大权神王经偈颂(终)


那先比丘经

    No. 1670 (A)

那先比丘经卷上

        失译人名附东晋录

佛在舍卫国祇树给孤独园。时诸比丘僧比丘尼优婆塞优婆夷。诸天大臣长者人民。及事九十六种道者。凡万余人。日于佛前听经。佛自念。人众日多身不得安。佛意欲舍人众去至闲避处坐思念道。佛即舍人众去。入山至藂树间。其树大有神。佛坐其下思念道。去树不远有群象五六百头。中有象王贤善知善恶之事。譬如人状。象辈众多周匝象王边。诸小象走居前水中。走戏[打-丁+毛]捞水令浊恶。诸小象复走居前食啖美草。走戏蹈践其上。我众大多患。是诸象及小象子。[打-丁+毛]捞水令浊恶令草不净。而反常饥饮浊恶水。食足践之草。象王自念。我欲弃是诸象去。至一避处快耶。象王即弃诸象而去。转行入山到头罗藂树间。象王见佛坐树下。心大欢喜。即前到佛所。低头屈膝为佛作礼。却在一面住。佛自念。我弃众人来在是树间。象王亦弃众象来到是树间。其义适同。佛为象王说经言。佛于人中最尊。象王于象中最尊。佛言我心与象王心适相中。今我与象王俱乐是树间。象王听经心意即开解知佛意。象王即视佛所仿佯经行处。以鼻取水洒地。以鼻捞草扫地。以足蹈地令平好。象王曰。朝暮承事佛如是。佛久后般泥洹去。象王不知佛所在。为周旋行求索佛不得。便啼垂泪愁忧不乐不能食饮。时国中有佛寺舍。在山上名加罗洹寺。中有五百沙门常止其中。皆已得阿罗汉道。常以月八日十四日十五日二十三日二十九日三十日。常以是日诵经。至明时象王亦在山上止于寺中。象王知有六日诵经。至其日当行入寺中听经。诸沙门知象王意听经。欲诵经时湏象王来。乃诵经。象王听经。至明不睡不卧不动不摇。象王数闻经承事佛故。后象王以寿命尽死。死后便化为人作子生婆罗门家。以后年长大不闻佛经亦不见沙门。便弃家去入深山学异道。在山上止。近比亦有一婆罗门道人俱在山上。相与往来共为知识。其一人自念言。我不能于世间悬忧苦老病。死后当入地狱畜生饿鬼贫穷中。用是故我欲剃头须披袈裟。欲求罗汉泥洹道。其有一人自念言。我愿欲求作国王得自在。令天下人民随我教。今如是。久后二人各命尽。俱生世间作人。其一人前求作国王者。生于海边为国王太子字弥兰。其一人前世欲剃头作沙门求罗汉泥洹者。生于天竺字陀猎与肉袈裟俱生其家。有一大象同日生。天竺名象为那。父母便字为那先。年十五六。那先有舅父字楼汉。学道作沙门大高才世间无比。已得阿罗汉道。能出无间入无孔。自在变化无所不作。天上天下人民及蠕动之类。心所念皆豫知之。生所从来死趣何道。那先至舅父所自说言。我喜佛道欲作沙门为舅父作弟子。宁可持我作沙门。楼汉哀之。即听作沙弥受十戒。日诵经思惟经戒便得四禅。悉知诸经要。时国中有佛寺舍名和战。寺中有五百沙门皆得罗汉道。其中有第一罗汉名頞波曰。能知天上天下去来现在之事。那先年至二十。便受大沙门经戒。便到和战寺中至頞波曰所。时五百罗汉适以十五日说大沙门戒经。在讲堂上坐。大沙门皆入。那先亦在其中。诸沙门悉坐。頞波曰悉视坐中诸沙门心皆是罗汉。独那先未得罗汉。頞波曰言。譬若扬米。米正白中有黑米。即扬为不好。今我坐中皆白清净。独那先黑未得罗汉耳。那先闻頞波曰说如是。大忧愁起为五百沙门作礼出去。自念我不宜在是座中坐。譬若众师子中有狐狗。我从今以后不得道不入中坐。頞波曰知那先意。以手摩那先头言。汝得罗汉道不久莫愁忧。便止留那先。那先复有一师年八九十字加维曰。其中有一优婆塞大贤善。日饭加维。那先且为师持钵行取饭食具。师令那先口含水。行到优婆塞家取饭食具。优婆塞见那先年少端正与人绝异有名字。智慧广远有志能说经道。优婆塞见那先前为作礼叉手言。饭诸沙门日久。未曾为我说经者。今我从那先求哀愿。与我说经解我心意。那先自念。我受师教戒令我口含水不得语。我今吐水者为犯师要。如是当云何。那先知优婆塞亦高才有志。我为其说经想即当得道。那先便吐水却坐为说经言。人当布施作福善奉行佛经戒。死后生世间得富贵。人不犯经戒者。后不复入地狱饿鬼畜生中贫穷中。得生天上。优婆塞闻那先说经心大欢喜。那先知优婆塞心欢喜。便复为说经。世间万物皆当过去无有常。诸所作皆勤苦。万物皆不得自在。泥洹道者不生不老不病不死不愁不恼。诸恶勤苦皆消灭。那先说经竟。优婆塞便得第一须陀洹道。那先亦得须陀洹道。优婆塞大欢喜。便极与那先作美饭具。那先语优婆塞。先取饭具置师钵中。那先饭竟澡漱讫毕。持饭具还与师。师见言。汝今日持好饭具来。以犯众人要。当逐出汝。那先大愁忧不乐。师教言。会比丘僧。悉会皆坐。师言。那先犯我曹众人要来。当逐出无令在众中止頞波曰说经言。譬若人持一箭射中两准。那先自得道。亦复令优婆塞得道。不应逐出。师迦维曰。政使一箭射中百准。会为犯众人。要不得止。余人持戒不能如那先得道。如效那先当用绝后。众坐中皆默然师教即逐出那先。那先便以头面礼师足起。遍为比丘僧作礼讫竟。便出去入深山坐树下。昼夜精进思惟道不懈。自成得罗汉道。能飞行彻视彻听。知他人心所念善恶。自知前世所更从来生。得罗汉道已。便来还入和战寺中。诣诸比丘所。前头面悔过求和解。诸比丘僧即听之。那先作礼讫竟。便出去转行入诸郡县街曲里巷。为人说经戒。教人为善。中有受五戒者。得须陀洹道者。中有得斯陀含道者。中有得阿那含道者。中有作沙门得罗汉道者。第二忉利天帝释。第七天王梵第四天王皆来到那先所作礼。以头面着足却坐。那先便为诸天说经。名字闻四远。那先所行处。诸天人民鬼神龙见那先无不欢喜者。皆得其福。那先便转到天竺舍竭国。止泄坻迦寺中。有前世故知识一人在海边。作国王子名弥兰。弥兰少小好读经学异道。悉知异道经法。异道人无能胜者。弥兰父王寿尽。弥兰立为王。王问左右边臣言。国中道人及人民谁能与我共难经道者。边臣白言。有学佛道者。人呼为沙门。其人智慧妙达。能与王共难经道。北方大臣国名沙竭。古王之宫。其国中外安隐人民皆善。其城四方皆复道行。诸城门皆刻镂。及余小国皆多高明。人民被服五色焜煌。国土高燥珍宝众多。四方贾客卖买皆以金钱。五谷丰贱家有余畜乐不可言。其王弥兰以正法治国。高才有智谋明于官事。战斗之术无不通达。能知九十六种道。所问不穷人适发言。便豫知其所趣。王语傍臣言。是间宁有明经沙门。能与我共难经说道者不。王傍臣名沾弥利望群。白王言。然有沙门字野和罗。明经道能与王难经道。王便敕沾弥利望群。即行往请野和罗言。大王欲见大师。野和罗言。王欲相见者大善。王当自来耳。我不往。沾弥利望群即还白王如是。王即乘车与五百伎共行到寺中。与野和罗相见。前相问讯就坐。五百骑从皆坐。王问野和罗。卿用何等故弃家捐妻子。剃头须披袈裟作沙门。卿所求何等道。野和罗言。我曹学佛道行中正。于今世得其福。于后世亦得其福。用是故我剃头须被袈裟作沙门。王问野和罗。若有白衣居家。有妻子行中正。于今世得其福。于后世亦得其福不。野和罗言。白衣居家有妻子行中正。于今世得其福。于后世亦得其福。王言。卿空弃家捐妻子。剃头须被袈裟作沙门为。野和罗默然无以报王。王傍臣白言。是沙门大明达有智者。迫促不及言耳。王傍臣皆举手言。王得胜。野和罗默然受负。王左右顾视。优婆塞面亦不惭。王自念。是诸优婆塞面不惭者。复有明健沙门能与我共相难者耳。王语傍臣沾弥利。宁复有明智沙门能与我共难经道者无。那先者诸沙门师。知诸经要难。巧说十二品经。种种别异章断句解。知泥洹之道。无有能穷者。无能胜者。智如江海。能伏九十六种道。为佛弟子所敬爱。以经道教授。那先来到舍竭国。其所相随弟子皆复高明。那先如猛师子。沾弥利白王。有沙门字那先。智慧微妙诸经道。要。能解人所疑无所不通。能与王难经说道。王问沾弥利。审能与我共难经道不。沾弥利言。唯然常与第七梵天共难经说道。何况于人王。即敕沾弥利。便行请那先来。沾弥利即到那先所白言。大王欲相见。那先言大善。即与弟子相随行到王所。王虽未尝见。那先在众人中披服行步。与人有绝异。王遥见隐知那先。王自说言。我前后所更见众大多。入大坐中大多。未尝自觉恐怖。如今日见那先。今日那先定胜我。我心惶惶不安。沾弥利居前白王言。那先以发旦到。王即问沾弥利。何所是那先者。沾弥利白。因指示王。王即大欢喜。正我所隐意是。那先即到。王因前相问讯语言。王便大欢喜。因共对坐。那先语王言。佛经说言。人安隐最大利。人知足最为大富。人有所信最为大厚。泥洹道最为大快。王便问那先卿字何等。那先言。父母字我为那先。人呼我为那先。有时父母呼我为首那先。有时父母呼我为维迦先。用是故人皆识知我。世间人皆有是耳。王问那先。谁为那先者。王复问言。头为那先耶。不为那先。王复言。耳鼻口为那先耶。不为那先。王复言。颐项肩臂手足为那先耶。不为那先。王复言。髀脚为那先耶。不为那先。王复言。颜色为那先耶不为那先。王复言。苦乐为那先耶。不为那先。王复言。善恶为那先耶。不为那先。王复言。身为那先耶。不为那先。王复言。肝肺心脾肠胃为那先耶。不为那先。王复言。颜色。为那先耶。不为那先。苦乐善恶身心合。是事宁为那先耶。言不为那先。王复言。无有苦乐无有颜色无有善恶无有身心。无是五事。宁为那先耶。那先言。不为那先。王复言。声响喘息宁为那先耶。言不为那先。何等为那先者。那先问王。何所为车者。轴为车耶。不为车。那先言。毂为车耶。王言毂不为车。那先言。辐为车耶。不为车。那先言。辋为车耶。不为车。那先言。辕为车耶。不为车。轭为车耶。不为车。那先言。舆为车耶。不为车。那先言。盖为车耶。不为车。那先言。合聚是材木着一面。宁为车耶。不为车。那先言。音声为车耶。不为车。那先言。何等为车耶。王默然不语那先言。佛经说。合聚是诸材木。用作车因得车。人亦如是。合聚头面目耳鼻口颈项肩臂骨肉手足肺肝心脾肾肠胃颜色声响喘息苦乐善恶合为一人。王言。善哉善哉

王复问言。那先能与我难经说道不。那先言。如使王作智者问。能相答王。作王者问愚者问。不能相答。王言。智者问王者问愚者问何等类。那先言。智者语对相诘相上语相下语。语有胜负则自知是为智者语。王者语自放恣。敢有违戾不如王言者。王即强诛罚之。是为王者语。愚者语。语长不能自知。语短不能自知。[怡-台+龍]悷自用得胜而已。是为愚者语。王言。愿用智者言。不用王者愚者言。莫持王者意与我语。当如与诸沙门语。当如与诸弟子语。如与优婆塞语。当如与给使者语。当以相开悟。那先言大善。王言。我欲有所问。那先言。王便问。王言。我已问。那先言。我已答。王言。答我何等语。那先言。王问我何等语。王言。我无所问。那先言。我亦无所答。王即知那先大明慧。王言。我甫始当多所问。日反欲冥当云何明日当请。那先于宫中善相难问。沾祢利望群。即白那先言。日暮王当还宫。明日王当请那先。那先言大善。王即为那先作礼骑还归宫。于马上续念那先。至明日沾弥利望群及傍臣白王言。当请那先不。王言当请。沾弥利望群言。请者当使与几沙门俱来。王言自在。那先与几沙门俱来。主藏者名悭。悭白王言。令那先与十沙门共来可。如是至三。王嗔恚言。何故齐令那先与十沙门共来。王言。汝字悭。不妄强惜王物自汝物。当云何汝逆我意。当有诛罚之罪。可言可哀赦汝过。今我作国王不堪饭沙门耶。悭大恐怖不敢复语。沾弥利望群到那先所。为作礼白言大王请。那先言。王当令我与几沙门共行。沾弥利望群言。自在那先与几沙门共行。那先便与野和罗八十沙门共行。沾弥利望群旦欲入城时。于道中并问那先。往曰对王言无有那先。何以那先问沾弥利望群。卿意何所为那先者。沾弥利望群言。我以为喘息出入命气为那先。那先问言。人气一出不复还入。其人宁复生不。沾弥利望群言。气出不复还入者定为死。那先言。如人吹笳气出不复还入。如人持锻金[竺-二+角]吹火气。一出时宁得复还入不。沾弥利望群言。不复还。那先言。同气出不复入。人何故犹不死。沾弥利望群言。喘息之间我不知。愿那先为我曹解之。那先言。喘息之气皆身中事。如人心有所念者舌为之言是为舌事。意有所疑心念之是为心事。各有所主。视之虚空无有那先。沾弥利望群心即开解。便作优婆塞。受五戒。那先便前入宫到王所上殿。王即前为那先作礼而却。那先即坐。八十沙门皆共坐。王手自持美饭食着那先前。饭食已竟澡手水毕讫。王即赐诸沙门人一张叠袈裟革屣各一緉。赐那先野和罗各三领袈裟各一緉革屣。王语那先野和罗言。留十人共止。遣余人皆令去。那先即遣余沙门去。与十人共止留。王敕后宫诸贵人伎女。悉出于殿上。帐中听我与那先共难经道。时贵人伎女悉出于殿上。帐中听那先说经。时王持座坐于那先前。王问那先言。当道说何等。那先言。五欲听要言者当说要言。王言。卿曹道何等最为善者。用何故作沙门。那先言。我曹辈欲弃世间苦恼。不复更后世苦恼故作沙门。王言沙门者悉尔不。那先言不悉用是故作沙门。中有负债作沙门者。中有畏县官作沙门者。中有贫穷作沙门者。那先言。我但说欲脱爱欲苦恼灭今世勤苦。至心未道作沙门者耳。王言。今卿用是故作沙门耶。那先言。少少作沙门有佛经道。是故欲弃今世后世苦恼作沙门。王言。善哉善哉

王问言。宁有人死后复生不。那先言。人有恩爱贪欲者。后世便复生为人。无恩爱贪欲者。后世便不复生。王言。人以一心念正法。后世不复生耶。那先言。人一心念正法。智慧及余善事。后世不复生。王言。人以善心念正法与黠慧者。是二事其义宁同不。那先言。其义各异不同。王言。牛马六畜各自有智谋其心不同。那先言。王曾见获麦者不。左手持麦右手刈之。那先言。黠慧之人断绝爱欲。譬如获麦者。王言。善哉善哉

王复问。那先何等为余善事者。那先言诚信孝顺精进念善一心智慧是为善事。王言。何等为诚信者。那先言。诚信解人疑。信有佛信经法信有比丘僧。信有罗汉道。信有今世信有后世信孝父母。信作善得善。信作恶得恶。信有是以后心便清净去离五恶。何等五。一者淫劮。二者嗔怒。三者嗜卧。四者歌乐。五者疑。人不去是五恶。心意不定。去是五恶。心便清净。那先言。譬如遮迦越王。车马人从厉度。令水浊恶过度以去。王渴欲得水饮。王有清水珠置水中水即为清。王便得清水饮之。那先言。人心有五恶如浊水。佛诸弟子度脱生死之道。人心清净如珠清水。人却诸恶诚信清净如明月珠。王言。善哉善哉

王复问那先。精进诚信者云何。那先言。佛诸弟子自相见辈中说诸清净。中有得须陀洹道者。中有得斯陀含道者。中有得阿那含道者。中有得阿罗汉道者。因欲相效行诚信便得度世道。那先言。譬如山上大雨。其水下流广大。两边人俱不知水浅深。畏不敢前。若有远方人来。视水隐知水广狭深浅。自知力势能入水便得过度去。两边人众便随后度去。佛诸弟子如是。人心清净便为须陀洹道。得斯陀含道。得阿那含道。得阿罗汉道。善心精进得道如是。佛经说言。人有诚信之心可自得度。世人能自制止却五所欲。人自知身苦恼能自度脱。人皆以智慧成其道德。王言。善哉善哉。王复问那先。何等为孝顺者。那先言。诸善者皆为孝顺。那先言。有四善事心意所止。言何等四心意所止者。那先言。一者自观其身中外内。二者知意苦乐。三者知心善恶。四者知正法。是为四。那先言。复有四事。何等四。一者制其意。二者诸有恶事不听入心中。三者心中有恶事即出之索诸善。四者其心中有善制持不放。是为四。那先言。复有四事。自在欲所作。何等为四。一者却欲。二者精进。三者制心。四者思惟。是为四。那先言。复有五效事。何等为五。一者诚信。二者孝顺。三者精进。四者尽心念善。五者智慧。是为五。那先言。复有七事弃除诸恶。名为七善。亦名七觉意。复有八种道行。亦名为阿姤者。是凡三十七品经皆是孝顺为本。那先言。凡人负金致远有所成立。皆由地成。世间五谷树木仰天之中皆由地生。那先言。譬若师匠图作大城。先度量作基址已乃起城。那先言。譬若倡伎欲作。先净扫地乃作。佛弟子求道先行经戒。作善因知勤苦弃诸爱欲。便思念八种道行。王言。善哉善哉

王复问那先。何等为精进者。那先言。助善是为精进。那先言。譬若垣墙。欲倒从傍柱之。舍欲倾坏亦复柱之。那先言。譬若国王遣兵有所攻击。兵少弱欲不如。王复遣兵往助之便得胜。人有诸恶如兵弱。人持善心消恶心。譬如国王增兵得胜。人持五戒譬如战斗得胜。是为精进助善如是。那先说经言。精进所助致人善道。所致善者无有逮斯。王言。善哉善哉

王复问那先。何等为意当念诸善事。那先言。譬若取香华。以缕合连[打-丁+絜]风不能吹散。那先复言。譬王守藏者。知中金银珠玉琉璃珍宝有几所。那先言。道人欲得道时。念三十七品经。佛道意念当如是正。所谓脱人道人有意。因知善恶知当所行。别知白黑思惟。以后便弃恶就善。那先言。譬如王有守门者。知王有所敬者。有所不敬者。知有不利王者。所敬利王者便内之。王所不敬者。不利王者。即不内。人持意若是。诸善者当内之。诸不善者不内。意制人善恶如是。那先说经言。人当自坚守其意。及身六爱欲持意甚坚。自当有度世时。王言。善哉善哉。王复问那先。何等为一其心者。那先言。诸善独有一心最第一。一其心者诸善皆随之。那先言。譬若楼陛当有所倚。诸善道者皆着一心。那先言。譬若王持四种兵行战斗。象兵马兵车兵步兵王行出诸兵。皆随引前后。佛经善事皆随一心如是。那先说经言。诸善一心为主。学道人众多皆当归一心。人身死生过去。如流水前后相从。王言善哉善哉

王复问那先。何等为智。那先言。前已对王说。是人智断诸疑明诸善。那先言。譬如持灯火入冥中室。便亡其冥自明。人智如是。那先言。譬若人持利刀截木。人以智截诸恶如是。那先言。人于世间智最为第一。度脱人生死之道。王言。善哉善哉。前后所说经种种智善也

王复问那先。佛经但为趣欲却诸恶事耶。那先言。然是所说种种诸善者。但欲却一切恶。那先言。譬若王发四种兵象马车步兵行战斗。初发行时意但欲攻敌耳。佛经说种种诸善。如是但欲共攻去诸恶耳。王言。善哉善哉。说经甚快也

王复问那先言。人心趣善恶道。续持身故神行生乎。更贸他神行生耶。那先言。亦非故身神。亦不离故身神。那先问王。王小时哺乳时。身至长大时。续故身非。王言。小时身异。那先言。人在母腹中始为精时。至浊时故精耶异。坚为肌骨时故精耶异。初生时至年数岁时故精耶异。如人学书傍人宁代其工不。王言。不能代其工。那先言。如人法有罪语王。王不能解知。王言。如人问那先解之云何。那先言。我故小时从小儿至大续故身耳。大与小时合为一身。是命所养。那先问王。如人然灯火。至天晓时不。王言。人然灯火油至晓时。那先言。灯中炷一夜时续故炷火光不。至夜半至明时故火光不。王言。非故火光。那先言。然灯火从一夜至半夜。复更然灯火耶。向晨时复更然灯火耶。王言不。中夜更然火续故一炷火至明。那先言。人精神展转相续如是。一者去二者来。从精神至老死。后精神趣所生。展转相续是非故精神。亦不离故精神。人死以后精神乃有所趣向生。那先言。譬如乳湩作酪。取上[月*巳]作醍醐。与酪酥上[月*巳]还复名作乳湩。其人宁可用不。王言。其人语不可用。那先言。人神如乳湩。从乳湩成酪。从酪成[月*巳]。从[月*巳]成醍醐。人如是从精沫至生至中年。从中年至老至死。死后精神更受身生。人身死当复更生受一身。譬若两炷更相然。王言。善哉善哉

王复问那先。人不复生后世。其人宁能自知不。复生不。那先言。然有能自知不复于后世生。王言。何用知之。那先言。其人自知无有恩爱。无有贪欲无有诸恶。用是自知不复生后世。那先问王。譬若田家种谷。大得收敛盛箪簟中。至于后年不复耕种。宁复望得谷不。王言。不复望得谷。那先言。道人亦如是。弃捐苦乐恩爱无所复贪。是故自知后世不复生。王言。善哉善哉

王复问。其人于后世不复生者。于今宁有智异于人不。那先言。然异于人。王言。明与智为同不。那先言。明与智等耳。王言。人有明智宁能悉知众事。作一事成五事耶。那先言。作众事所成非一。譬若一地种谷。当其生时各各自生种类。人身五事皆用众事。各有所成。王言。善哉善哉

王复问那先。世间人头面目身体四支皆完具。何故有长命者有短命者。有多病少病者。有贫者富者。有长者有卑者。有端正者有丑恶者。有为人所信者。为人所疑者。有明者有闇者。何以故不同。那先言。譬若众树木生果。有酢者有苦者。有辛者有甜者。那先问王。此等树木何故不同。王言。不同者本栽各异。那先言。人所作各各异不同。故有长命有短命。有多病有少病有富有贫。有贵有贱。有端正有丑恶。有语用者有语不用者。有明者有闇者。那先言。佛经说。豪贵贫穷好丑。皆自宿命所作善恶自随行得之。王言。善哉善哉

那先比丘经卷上那先比丘经卷下

        失译人名附东晋录

王复问那先言。人欲作善当前作之。须后作之。那先言。当居前作之。在后作者不益人。那先言。王渴时乃掘地作井。能趣渴不。王言。不能趣渴。当居前作井耳。那先言。以是故所作当居前。那先问王。饥时乃使人耕种。须谷熟乃食耶。王言不。当先储偫。那先言。人如是当先作善。有急乃作善者无益于身。那先问王。譬若王有怨。当临时出战斗具。王言不当宿有储偫。那先言。佛说经言。人当先自念作善。于后作善无益。莫弃大道就邪道。勿效愚人弃善作恶。后坐啼哭无益。人弃捐中正就于不正临死时乃悔耳。王言善哉善哉

王复问那先。卿曹诸沙门说言。世间火不如泥犁中火热。复言。持小石着世间火中至暮不消。取大石着泥犁火中即消。是故我不信。复言。人作恶死在泥犁中。数千万岁其人不消死。是故我重不信是语。那先问王。宁闻见水中大蟒蛟龙鱼鳖。以沙石为食不。王言然。实以此为食。那先问王沙石宁消不。王言皆消。那先言。其腹中怀子宁复消不。士言不消。那先问王何故不消。王言。相禄独当然故使不消。那先言。泥犁中人数千万岁不消死者何所作。过恶未尽故不消死。那先问王言。师子虎狼皆肉食啖骨。入腹中时宁消尽不。王言消。那先问王。其腹中怀子宁复消不。王言不消。那先言用何故不消。王言独相禄故不消死。那先问王言。牛马麋鹿皆以刍草为食不。王言然。那先言。其刍草宁于腹中消不。王言皆消。那先言。其腹中怀子宁消不。王言不消。那先言。何以故不消。王言。独以相禄当然故使不消。那先言。泥犁中人亦如是。过恶未尽故不消死。那先问王言。世间女人饮食皆美恣意食食于腹中宁消不。王言皆消。那先言。腹中怀子宁消不。王言子不消。那先言。何以故不消。王言独相禄当然故使不消。那先言。泥犁中人亦如是所以数千万岁不消死者。用先作恶未解故不消死。那先言。人在泥犁中生。在泥犁中长在泥犁中老。过尽乃当死。王言善哉善哉

王复问那先。卿曹诸沙门言。天下地皆在水上水在风上风在空上我不信是。那先前取王书水。适以指撮之问王言。风持水若此。王言善哉。王复问。那先言。泥洹道皆过去无所复有耶。那先言。泥洹道无所复有。那先言。愚痴之人贪身爱惜。坐是故不能得度脱生老病死者。那先言。智者学道内外身不爱惜。便无有恩爱。无有恩爱者无贪欲。无贪欲者无胞胎。无胞胎者不生。不生者不老。不老者不病。不病者不死。不死者不忧。不忧者不哭。不哭者不痛。便得泥洹道。王复问。那先诸学道者。悉能得泥洹道不。那先言。不能悉得泥洹道。正向善道者学知正事。当所奉行者奉行之。不当奉行者弃远之。当所念者念。不当所念弃之。如是能得泥洹道。王复问那先言。其不得泥洹道者。宁知泥洹道为快不。那先言。然虽未得泥洹道。由知泥洹道为快。王言。人未得泥洹道。何以故知快耶。那先问王言。人生未尝截手足。宁知截手足为痛剧不。王言。虽未曾更截手足。犹知为痛。那先言。何用知为痛。王言见其人截手足呻呼。用是故知为痛。那先言。人前有得泥洹道者。转相语泥洹道快。用是故信之。王言善哉善哉

王复问那先宁曾见佛不。那先言。未曾见。王言。那先诸师宁见佛不。那先言。诸师亦未曾见佛。王言。如使那先及诸师不见佛者。定为无有佛。那先言。王宁见五百溪水所合聚处不。王言我不见。王父及太父皆见水不。王言皆不见。那先言。王父及太父皆不见此水。天下定为无此五百溪水所聚处不。王言。虽我不见父及太父皆不见此水者。实有此水。那先言。虽我及诸师不见佛者。其实有佛。王复问言。无有复胜佛者耶。那先言然。无有胜佛者。王复问。何以为无能胜佛者。那先问王言。如人未曾入大海中。宁知海水为大不。有五河。河有五百小河流入大河。河一者名恒。二名信他。三名私他。四名博叉。五名施披夷尔。五河水昼夜流入海。海水亦不增减。那先言。王宁能闻知不。王言实知。那先语。以得道人共道说无有能胜佛者。是故我信之。王言善哉善哉

王复问那先言。当何用知无有胜佛者。那先问王。造书师者为谁。王言造书师者名质。那先言。王宁曾见质不。王言。质已死久远未曾见。那先言。王未见质。何用知质为造书师。王言。持古时书字转相教告。用是故我知名为质。那先言。用是故我曹见佛经戒如见佛无异。佛所说经道甚深快人。知佛经戒以后便相效。用是故我知为有不能胜佛者。王复问。那先自见佛经道可久行之。那先言。佛所施教禁戒经甚快。当奉行之至老。王言善哉善哉王复问那先。人死已后身不随后世生耶。那先言。人死已后更受新身故身不随。那先言。譬若灯中炷更相然。故炷续在新炷更然。人身如是故身不行更受新身。那先问王。王小时从师学书读经不。王言然我续念之。那先问王。王所从师受经书师宁知本经书耶。王悉夺得其本经书。王言不也。师续自知本经书耳。那先言人身若此置故身更受新身。王言善哉善哉

王复问那先。审为有智无。那先言无有智。譬若人盗他人果蓏。盗者宁有过无。王言有过。那先言。初种树栽时上无有果何缘盗者当有过。王言。设不种栽何缘有果。是故盗者无状。那先言人亦如是用今世身作善恶。生于后世更受新身。王言人用是故身行作善恶所在。那先言。人诸所作善恶随人如影随身。人死但亡其身不亡其行。譬如然火夜书火灭其字续在火至复更成之。今世所作行后世成如受之如是。王言善哉善哉。王言。那先宁能分别指示善恶所在不耶。那先言。不可得知善恶所在。那先问王。树木未有果时。王宁能分别指示言某枝间有某果某枝间无有果。宁可豫知之不耶。王言不可知。那先言。人未得道不能豫知善恶所在。王言善哉善哉

王复问。人当于后世生者。宁能自知不。那先言。其当生者自知。王言何用知之。那先言。譬如田家耕种。天雨时节其人宁豫知当得谷不。王言然知。知田当得谷多。那先言。人如是人当于后世生豫自知。王言善哉善哉

王复问那先。审有泥洹无。那先言审有。王言那先宁能指示我佛在某处不。那先言。不能指示佛处。佛已泥曰去不可得指示见处。那先言。譬若人然大火已即灭其火焰。宁可复指示知光所在不。王言不可知处。那先言。佛已泥曰去不可复知处。王言善哉善哉

王又问那先。沙门宁能自受其身不。那先言。沙门不自爱其身。王言如令沙门不自爱其身者。何以故。自消息卧欲得安温濡饮食。欲得美善自护视。何以故那先言。王宁曾入战斗中不。王言然。曾入战斗中。那先言。在战斗中时。曾为刀刃牟箭疮所中不。王言我颇为刀刃所中。那先问王。奈刀刃牟箭疮何。王言我以膏药绵裹耳。那先问王言。为爱疮故。以膏药绵絮裹耶。王言我不爱疮。那先言。殊不爱疮者。何以持膏药绵絮裹而护之。王言。我欲使疮早愈。那先言。沙门亦如是。不爱其身。虽饮食心。不乐用作美不用作好。不用作肌色趣欲支身体。奉行佛经戒耳。佛经说言。人有九孔为九弓疮。诸孔皆臭处不净。王言善哉善哉

王复问那先。佛为有三十二相八十种好身。皆金色有光影耶。那先言。佛审有三十二相八十种好身。皆有金色光影。王言。佛父母宁有三十二相八十种好身。皆有金色有光影耶。那先言。佛父母无是相。王言如是相好是父母无是相。佛亦无是相。王复言。人生子像其种类。父母无是相者佛定无是相。那先言。佛父母虽无是三十二相八十种好身金光色者。佛审有是相。那先言。王曾见莲花不。王言我见之。那先言。此莲花生于地长于泥水。其色甚好宁复类泥水色不。王言。不类地泥水色。那先言。虽佛父母无是相者。佛审有是相。佛生于世间长于世间。而不像世间之事。王言善哉善哉

王复问那先。佛审如第七天王梵所行。不与妇女交会不。那先言然。审离于女人净洁无瑕秽。王言。瑕令佛如第七天王所行者。佛为第七天王梵弟子。那先问王。第七天王者有念无念。王言。第七天王梵有念。那先言。是故第七天王梵及上诸天。皆为佛弟子。那先问王言。象鸣声何等类。王言。象鸣声如雁声。那先言。如是象为是雁弟子。各自异类。佛亦如是非第七天王梵弟子。王言善哉善哉

王复问那先。佛宁悉学知经戒不。那先言。佛悉学知奉行经戒。王言。佛从谁师受经戒那先言佛无师。佛得道时。便悉自知诸经道。佛不如诸弟子学知。佛所教诸弟子皆当奉行至老。王又问那先。人父母死时悲啼哭泪出。人有闻佛经。亦复悲啼泪出俱尔。宁别异不。那先言。人为父母啼泣皆感恩爱。恩念愁忧苦痛。此曹忧者愚痴忧。其有闻佛经道泪出者。皆有慈哀之心。念世间勤苦。是故泪出。其得福甚大。王言善哉。王又问那先。以得度脱者有何等别异。那先言。人未得脱者有贪欲心。人得脱者无有贪欲之心。但欲趣得饭食支命耳。王言。我见世间人皆欲快身欲得美食。无有厌足。那先言。人未得度脱。饮食者用作荣乐好美。得度脱者。虽饮食不以为乐不以为甘。趣欲支命。王言善哉善哉

王复问那先。人家有所作能念久远之事不。那先言。人愁忧时皆念久远之事。王用何等念之。用志念耶用念念耶。那先问王言。宁曾有所学知以后念之不。王言。然我曾有所学知以后忽忘之。那先言。王是时无志耶而忘之乎。王言我时忘念。那先言。可差王为有象。王复问那先。人有作皆念耶。若甫始有所作念见在所作。皆用念知耶。那先言。已去之事皆用念知之。今现在之事。亦用念知之。王言如是人但念去事。不能复念新事。那先言。假令新者有所作。不可念者亦如是。王言人新学书技巧为唐捐那。那先言。人新学书画者。有念故令弟子学者有知。是故有念耳。王言善哉善哉。王复问那先人用几事生念念耶。那先言人凡有十六事生念。一者久远所作生念。二者新有所学生念。三者若有大事生念。四者思善生念五者曾所更苦生念。六者自思惟生念。七者曾杂所作生念。八者教人生念。九者象生念。十者曾有所忘生念。十一者因识生念。十二者教计生念。十三者负债生念。十四者一心生念。十五者读书生念。十六者曾有所寄更见生念。是为十六事生念。王复问。那先何等为念久者。那先言佛弟子阿难女弟子优婆夷鸠仇单罢念千亿世宿命之事及余道人。皆能念去世之事。如阿难女弟子辈甚众多。念此已便生念。王又问。何等新所学生念者。那先言。如人曾学知挍计。后复忘之。见人挍计便更生念。王又问。那先何等为大事生念。那先言。譬若大子立为王。自念为豪贵是大事生念。王复问那先。何等为思善生念者。那先言。譬若人为人所请呼。极善意宾延遇待之。其人自念言。昔日为某所请呼。善意待人是为思善生念。王又问那先。何等为更苦生念者。那先言。譬若人曾为人所挝埵闭系牢狱。是为更苦生念。王复问那先言。何等为自惟生念者。那先言。譬若人曾有所见。家室宗亲及畜生。是为自惟生念。王又问那先言。何等为曾杂所作生念者。那先言。譬若人万物字颜色香臭酢苦。念此诸事是为曾杂生念。王复问那先言。何等为教人生念者。那先言。人自喜忘边人。或有念者或有忘者。是教人生念。王又问那先言。何等为象生念者。那先言。人牛马各自有象类。是为象生念。王又问那先言。何等为曾所忘生念者。那先言。譬若人卒有所忘。数数独念得之。是为曾所忘生念。王复问那先。何等为因识生念者。那先言。学书者能次其字。是为因识生念。王复问那先。何等为挍计生念者。那先言。如人共挍计。成就悉知策术分明。是为挍计生念。王又问那先。何者为负债生念者。那先言。如人所当债所当归。是为负债生念。王又问那先。何等为一心生念者。那先言。沙门一其心。自念所从来生千亿世时事。是我为一其心生念。王又问那先。何等为读书生念者。那先言。帝有久古之书。念言某帝某吏时书也。是为读书生念。何等为曾有所寄更见生念者。那先言。若人有所寄更眼见之便生念。是为所寄生念。王言善哉善哉

王复问那先言。佛宁悉知去事甫始当来事那。那先言。然佛悉知之。王言。假令佛悉知诸事者。何故不一时教弟子。何故稍稍教之。那先问王。国中宁有医师无。王言有医师。那先言。其医师宁能悉知天下诸药不。王言能悉知诸药。那先问王。其药师治人病为一时与药为稍稍与之。王言未病不可豫与药应病乃与药耳。那先言佛虽悉知去来现在之事。亦不可一时教天下人。当稍稍授经戒令奉行之耳。王言善哉善哉

王又问那先。卿曹沙门言。人在世间作恶至百藏。临欲死时念佛。死后者皆生天上。我不信是语。复言杀一生死即入泥犁中。我不信是也。那先问王。如人持小石置水上。石浮耶没耶。王言其石没。那先言。如令持百枚大石置船上。其船宁没不。王言不没。那先言船中百枚大石。因船故不得没。人虽有本恶一时念佛。用是不入泥犁中。便生天上。其小石没者。如人作恶。不知佛经死后便入泥犁。王言善哉善哉

王复问那先。卿曹用何等故。行学道作沙门。那先言。我今以过去苦现在苦当来苦。欲弃是诸苦。不欲复受更。故行学道作沙门。王复问那先。苦乃在后世何为豫学道作沙门。那先问王。王宁有敌国怨家。欲相攻击不。王言然。有敌国怨家常欲相攻击也。那先问王。敌主临来时王乃作斗具备守掘堑耶。当豫作之乎。王言当豫有储偫。那先问王。何等故先作储偫。王言。备敌来无时故。那先问王。敌尚未来何故豫备之。那先又问王。饥乃由种渴乃凿井。何故豫作备度。王言善哉善哉。王又问那先。第七梵天去是几所。那先言甚远。令大如王殿石。从第七梵天上堕之六日乃堕此间地耳。王言。卿曹诸沙门言。得罗汉道如人屈伸臂顷。以飞上第七梵天上。王言我不信。是行数千万亿里。何以疾乃尔。那先问王。王本生何国。王言我本生大秦国。国名阿荔散。那先问王。阿荔散去是间几里。王言。去是二千由旬合八万里。那先问王。曾颇于此遥念本国中事不。王言然恒念本国中事耳。那先言。王试复更念本国中事。曾有所作为者。王言我即念已。那先言。王行八万里反覆何以疾。王言善哉善哉。王复问那先。若有两人于此俱死。一人上生第七梵天。一人生罽宾。罽宾去七百二十里。谁为先到者。那先言。试念阿荔国。王言我已念之。那先复言。王试复念罽宾。王言我已念之。那先问王。念是两国何所疾者。王言俱等耳。那先言。两人俱死一人生第七梵天上。一人生罽宾亦等耳。那先问王。若有一双飞鸟。一于一高树上止。一鸟于卑树上止。两鸟俱飞谁影先在地者。王言其影俱到地耳。耶先言。两人俱死一人生第七天上。一人生罽宾。亦俱时至耳。王言善哉善哉

王复问那先。人用几事学知道。那先言。用七事学知道。何等为七。一者念善恶之事。二者精进。三者乐道。四者伏意为善。五者念道。六者一心。七者适无所憎爱。王又问那先。人用此七事学知道耶。那先言不悉用七事学知道。知者持知善恶。用是一事别知耳。王又问那先。假令用一事知者。何为说七言。那先问王。如人持刀着鞘中倚壁。刀宁能自有所割截不。王言。不能有所割截。那先言。人心虽明会。当得是六事共成智耳。王言善哉善哉

王复问那先。人家作善得福大耶。作恶得殃大耶。那先言。人作善得福大。作恶得殃小。人家作恶日日自悔过。是故其过日小。人家作善日夜自念欢喜。是故得福大。那先言。昔者佛在时。其国中有人掘无手足。而取莲花持上佛。佛即告诸比丘言。此掘足手儿。却后九十一劫不复入泥犁中畜生劈荔道中。得生天上。天上寿终复还作人。是故我知人作小善得福大。作其恶人自悔过日消灭而尽。是故我知人作过其殃小。王言善哉善哉。王复问那先。智者作恶愚人作恶。此两人殃咎谁得多者。那先言。愚人作恶得殃大。智人作恶得殃小。王言不知。那先言。王言我国治法。大臣有过则罪之重。小民有过罪之。是故我知智者作过恶得殃大。愚者作恶得殃小。那先问王。譬如烧铁在地。一人知为烧铁。一人不知。两人俱前取烧铁。谁烂手大者耶。王言。不知者手烂。不制其身口者不能持经戒。如此曹人亦不乐其身。那先言。其学道人者。能制其身能制口能持经戒。能一其心得四禅。便能不复喘息耳。王言善哉善哉

王复问那先。为呼言海。海为是水名为海耶。用他事故言海。那先言。人所以呼为海者。水与盐参各半。是故为海耳。王复问那先。何以故海悉碱如盐味。那先言。所以海水碱者。啖畜以来久远。及鱼鳖虫多共渍水中。是故尔碱耳。王言善哉善哉

王复问那先。人得道已宁能悉思惟深奥众事不。那先言然。人得道已。能悉思惟深奥之事。佛经最深奥知众事。不可称量众事。皆以智评之。王言善哉善哉

王复问那先。人神智自然此三事宁同不各异。那先言。人神者。生觉智者。晓道自然者。虚空无有人也。王又问那先。人言得人何等为得人者。今眼视色耳听声鼻闻香臭口知味身知软粗。志知善恶之事。何所为得人者大。那先言。愚者作恶不能自悔故其殃大。智者作恶知不当所为。日自悔过。故其殃少。王言善哉善哉

王复问那先。人有能持此身。飞行上至第七梵天上。及至郁单曰地。及所欲至处者不耶。那先言能。王言。奈何持此身上第七梵天。及郁单曰地。及所欲至处乎。那先问王。王宁自念。少小时跳戏一丈地不。王言。我年少时意念欲跳。便跳一丈余地。那先言。得道之人意欲跳至第七天上。及至郁单曰地者亦尔。王言善哉善哉

王复问那先。卿曹诸沙门言。有骨长四千里。何等身骨长四千里。那先问。王曾闻大海中有大鱼名质。身长二万八千里者不。王言然有是。我曾闻之。那先言。如是二万八千里鱼。其胁骨长四千里王怪之为。王复问那先。卿曹诸沙门说言。我能断喘息之事。王言奈何可断喘息气耶。那先问王。宁曾闻志不。王言我闻之。那先言。王以为志在人身中耶。王言。我以为志在人身中。那先言。王以为愚人不能。那先问王。如今合解用目视脱瞳子去之视宁广远不。裂大其耳听声宁广远不。决鼻令大其闻香宁多不。吻口令大知味宁多不。剥割肌肤宁令信知粗软不。拔去其意盛念宁多不王言不也。那先言。佛所作甚难佛所知甚妙。王复问那先。所作何等甚难何等甚妙。那先言。佛能知人腹中目所不见事悉能解之。能解目事能解耳事。能解鼻事能解口事。能解身事能解贩事。能解所念事能解神事。那先言。人取海水含之。宁能别知口中水。是某泉水是某流水。是某河水不。王言众水皆合为一难各别知。那先言。佛所作为甚难。皆能别知。今人神不见人身。中有六事不可见。那先言。是故佛解之。从心念至目所见。从心念至耳所听。从心念至鼻所嗅。从心念至口知味。从心念至身知苦乐寒温粗坚。从心念有所向。佛悉知分别解之。王言善哉善哉

那先言。夜已半我欲去。王即敕傍臣。取四端[疊*毛]布揾置油麻中持以为炬。当送那先归。恭事那先如事我身。傍臣皆言受教。王言得师如那先。作弟子如我。可得道疾。王诸所问那先辄事事答之。王大欢喜王即出中藏好衣直十万。以上那先。王语那先。从今以去愿那先日与八百沙门共于宫中饭食。及所欲皆从王取之。那先报王。我为道人略无所欲。王言那先当自护。亦当护我身。那先言。何等当自护护王身。王报言。恐人论议呼王为悭。那先为解诸狐疑。而不能赐与。或恐人言。那先不能解王疑故王不赏赐。王言那先受者令我得其福。那先亦当护其名。王言譬若师子在金槛中。由为拘闭常有欲望去心。今我虽为国宫省中。其意不乐。欲弃国去而行学道。王语竟那先便归佛寺。那先适去王窃自念。我问那先为何等事。那先为我解何等事。王自念。我所问那先莫不解我意者。那先归佛寺亦自念王问我何等事。我亦报王何等事。那先自念王所问者。我亦悉解之。念此事至天明。明日那先被袈裟持钵直入宫上殿坐王前为那先作礼已乃却坐。王白那先。那先适去我自念。问那先何等语。那先报我何等语。我又自念所问那先。那先莫不解我意者。念是语欢喜安卧至明。那先言。我行归舍亦自念。王为问我何等事。我亦为王解何等事。我复自念王所问我辄为解之。用是故欢喜至明。语竟那先欲去。王便起为那先作礼

那先比丘经卷下


那先比丘经b

    No. 1670 (B)

那先比丘经卷上

        失译人名附东晋录

佛在舍卫国祇树给孤独园。时诸比丘僧比丘尼优婆塞优婆夷。诸天王大臣长者人民。及事九十六种道者。凡万余人日于佛前听经。佛自念人众日多身不得安。佛意欲舍人众去到闲屏处坐思惟念道。佛即舍人众去入山至校罗丛树间。其树有神佛坐其下思念清净之道。去丛树不远有群象五百余头。中有象王贤善知善恶之事。譬如人状象辈众多周匝象王边。中有雄雌长齿中齿少齿者。象王渴欲行饮水时诸小象走居前入水饮。饮已于水中走戏挠捞水令浊恶。象王不能得清水饮。象王饥欲行食草诸小象复走居前食啖美草。走戏蹈践其上。象王不能得净草食。象王自念我群众多患。是诸象及小象子挠水令浊令草不净。而返常饮浊水食足践之草。象王自念我欲弃是诸象去至一屏处快耶。象王即弃群而去转行入山到校罗丛树间。象王见佛佛坐树下心大欢喜。则前至佛所低头屈膝为佛作礼却在一面住。佛自念我弃众人来在是间。象王亦复弃众象来到是树间。其义适同。佛为象王说经言。佛于人中最尊。象王于诸象中亦尊。佛言我心与象王心适相中合。我与象王俱乐是树间。象王听经竟心即开解晓知佛意。便视佛所彷徉经行处。以鼻取水洒地以鼻捞草扫地。以足蹈地令平好。象王日朝暮承事。如是久后佛便取无为泥洹道去。象王不知佛处为周旋行求索佛不得。啼泣愁忧不乐不敢食饮。时国中有佛寺。舍在山上名迦罗洹。中有五百沙门共止其中。皆已得阿罗汉道。常以月六斋日诵经至明时。象王亦在山上近于寺边。象王知有六斋日诵经。至其日象王常行入寺听经。诸沙门知象王喜听经。欲诵经时须象王来到乃诵经。象王听经彻明不睡不卧不动不摇。象王数闻经承事佛故。久后象王亦以寿终。死便得为人作子生婆罗门家。不复闻佛经亦不见沙门。便弃家入深山学婆罗门道在山上。止近比亦有一婆罗门道人俱在山上。相与往来共为知识。其一人自念我厌世间县官忧苦老病死后当入地狱饿鬼畜生贫穷中。用是故我除头须。被袈裟作沙门求度世无为道。其一人自念我愿欲求作国王得自在。令天下人民皆共属我随我教令。两人共愿如是。久后二人各复寿终得于世间作人。其一人前世宿命欲求作国王者。生于海边为国王太子。父母便字子为弥兰其一人前世宿命欲求度世无为泥洹道者。生于天竺罽宾县。父母便字为陀猎。生便被袈裟俱生。所以与袈裟俱生者本宿命所愿。其家有一象王亦同日生。天竺名象为那。父母便因象字其子名为那先。那先长大年十五六有舅父字楼汉。楼汉作沙门。有绝妙之才世间无比。眼能彻视耳能彻听自知所从来。生行即能飞出能无间入无孔自在变化无所不作。天上天下人民及蜎飞蠕动之类。心所念楼汉皆预知之。那先便自往到舅父计自说言。我意佛道欲除头须被袈裟作沙门。今我当为舅父作弟子宁可持我作沙门耶。楼汉知那先宿命作善有慧甚重哀之因听令作沙弥。那先始作小沙弥受十戒日。诵经学问思惟经戒即得四禅悉知诸经。独未受大沙门戒。于时国山中有佛寺舍名曰和禅。和禅寺中有五百沙门皆得阿罗汉道。中有第一阿罗汉名頞陂曰。能知天上天下去来见在之事。那先年满二十因作大沙门受大沙门戒。便到和禅寺中至頞陂曰所。时五百阿罗汉。适以十五日说大沙门戒经在讲堂上坐。大沙门皆入那先亦在其中。众沙门悉坐。頞陂曰悉视坐中诸沙门心皆是阿罗汉。独那先未得罗汉道。頞陂曰便说譬喻经言。若入折米米正白中有黑米即剔不好。今我坐中皆清白独那先为黑未得阿罗汉道。那先闻頞陂曰说经如是大愁。便起为五百沙门作礼已即出去。那先自念我不宜在是座中坐。我亦未得度脱其余沙门皆已度脱。譬若众师子中有狐狗今我亦如是。我从今不得道者不复入众中坐也。頞陂曰知那先意便呼那先着前。以手摩那先头。汝今得阿罗汉不久勿愁忧也。頞陂曰便欲坐止那先。那先复有一师年八十余字迦惟曰。其县中有一优婆塞大贤善。常日饭迦惟曰弟子。那先至为师持应器行取饭具。师令那先口含水行到优婆塞家取饭具。优婆塞见那先年少端正行与人绝异。宿知有慧预闻有明志之名能说经道。优婆塞见那先入其舍中。便即起立前为作礼却叉手言。我饭诸沙门日久。来尝有为我说经者。今从我那先求哀愿。为我说经解我愚痴。那先即自念我受师教令我口含水不得语。我今吐水者为犯师戒。如是当云何。那先念优婆塞亦高才有志。我为其说经想即得道。那先便吐水而坐即为说经。人布施作善奉行经戒。今世安隐后世便生天上。下生人中即当明慧富贵。后不复入地狱饿鬼畜生中。人不奉行经戒者于今世苦。后世复堕三恶道中无有出时。优婆塞闻经心即欢喜。那先知优婆塞心欢喜。便复说深经言。世间万物皆当过去无有常在者。万物过去皆苦世间人身亦如是。世间人皆言是我身过我许。是皆不得自在泥洹道者。最乐泥洹者不生不老不病不死不愁不忧。诸恶勤苦皆悉消灭。那先说经已。优婆塞即得第一须陀洹道。那先亦自得须陀洹道。优婆塞大欢喜。便为那先好美饭。那先语优婆塞先取具着师钵中。那先饭竟澡漱讫毕持饭具还与师。师见饭具言若今日持饭具来大好已犯众人约当逐出汝。那先愁不乐。师言会众比丘僧众。比丘僧悉会坐。师言那先犯我曹众人约来。当共逐出不得止众中也。頞陂曰说譬喻言。如人持一箭射两准。如是曹人不应逐出也。那先自说得道亦令优婆塞得道。不应逐出。那先师迦维曰言。正使一箭中百准会为众人约。不得留止。余人悉不能如那先得道当已绝后不逐出那先者。余人复效无以却后众坐中皆默然。随师教即逐出那先。那先便以头面着师足。起遍为众比丘僧作礼。礼竟便去入深山中坐树下。昼夜精进念道不懈。便自成得阿罗汉道。能飞行亦能眼彻视耳彻听。亦能知他人心所念。自知前世所从来生。得阿罗汉已便即来还入和禅寺中。诸众比丘僧中叩头求哀悔过和禅诸比丘僧。诸比丘僧即听之。那先作礼竟便出去。那先转行入诸郡县街曲里巷。为人说经戒教人为善。中有受五戒者。中有得须陀洹道。中有得斯陀含道者。中得阿那含道者。中有作沙门得阿罗汉道者。第一四天王。第二忉利天帝释。第七梵天王皆来到那先前。作礼以头面着足却坐。那先皆为诸人说经。名字彻闻四天。那先所行处。诸天人民鬼神龙。见那先无不欢喜者。皆得其福。那先便转到天竺舍竭国止泄坻迦寺中。有前世故知识一人。在海边作国王太子名弥兰。弥兰少小好喜读经学异道悉知异道。经法难异道人无有能胜者。弥兰父王寿终。弥兰即立为国王。王问左右边臣言。国中道人及人民谁能与我共难经道者。边臣白王言。有有学佛道者。人呼为沙门。其人智慧博达。能与大王共难经道。今在北方大秦国。国名舍竭古王之宫其国中外安隐人民皆善。其城四方皆复道行。诸城门皆雕文刻镂。宫中妇女各有处所。诸街市里罗列成行。官道广大列肆成行。象马车步男女炽盛乘门道人亲戚工师细民。及诸小国皆多高明。人民被服五色焜煌妇女傅白皆着珠环。国土高燥珍宝众多。四方贾客卖买皆以金钱。五谷丰贱家有储畜。市边罗卖诸美羹饭饥即得食。渴饮蒲萄杂酒乐不可言。其国王字弥兰以正法治国。弥兰者高才有智。明世经道能难去来见在之事。明于官事战斗之术。智谋无不通达。时王出城游戏诸兵众屯绕外。其王心自贡高。我为王能答九十六种经道。人所问不穷人心适发便豫知所言。王语诸傍臣曰。尚早入城亦无所作。是间宁有明经道人沙门能与我共难经说道者无。王傍臣名沾弥利望群。沾弥利望群白王言。然有沙门字野和罗大明经道。能与王共难经说道。王便敕沾弥利望群行往请来。沾弥利望群即行请野和罗言大王欲见大师。野和罗言大善王欲相见者当自来耳。我不往也。沾弥利还白王如是。王即乘车与五百骑共往到寺中。王与野和罗相见。前问讯已便就坐。五百骑从悉皆亦坐。王即问野和罗言。卿用何故弃家捐妻子剃头须。被袈裟作沙门乎。卿所求何等道。野和罗报王。我曹学佛道行忠政于今世得其福。后世亦得其福用。是故我除头须被袈裟作沙门。王问野和罗言有人白衣有妻子。于家有妻子行忠政。于今世得其福不后世亦得其福不。野和罗言白衣于家有妻子。有行忠政。于今世得福于后世亦得其福。王言白衣于家有妻子有行忠政。于今世后世同得其福。卿无故而弃妻子除头须被袈裟作沙门为。野和罗便默然无以报王。傍臣白言是沙门大明健有智迫。促未及说耳。王傍臣举手言王得胜王得胜。野和罗便默然受负。王即左右顾视诸优婆塞。诸优婆塞面亦不惭。王念是诸优婆塞面亦难惭者。独复有明经健沙门。能与我相难者耳。王语沾弥利宁复有明慧沙门。能与共难经说道者。无时那先者诸沙门师。常与诸沙门俱出入。诸沙门皆使说经。那先时皆知诸经要难。能说十二部经。说经而种种别异章断句解已。知泥洹之道。无有能穷者无有能得胜者。能解诸疑能明思者。所言智如江海能伏九十六种道。为佛四辈弟子所敬。为诸智者所归仰。常以经道教授人。那先来到舍竭国。其所相随弟子皆复高明。那先如猛师子。沾弥利白王有异沙门。字那先智慧深妙明诸经要。能解诸疑无所不通。能与王共难经道。王问沾弥利审能与我共难经道不。沾弥利应唯然能与王共难经道。尚能与第七梵天共难经道。何况于人王。即敕沾弥利便行请那先来。沾弥利即往到那先所白言。大王欲相见。那先即与诸弟子相随到王所。王虽未尝与那先相见。那先在众人中被服行步。与人绝异。王遥见阴知是那先。王自说言我前后所见人众大多。入大座中大多。未尝自觉恐怖。如今日见那先。那先今日定胜我。我定不如矣。我心惶惶不安也。沾弥利白王言。那先已来在外那先既至。王问沾弥利何所是那先者沾弥利因指示王王即大欢喜正我所隐者竟是那先。王即见那先衣被行步与众人绝异。那先即到前相问讯语言王便大欢喜因共对坐。那先语王言佛经说言人安隐最为大利。人知厌足最为大富。人有所信最为大厚。泥洹道者最为大快。王便问那先。卿字何等那先言父母字我为那先。便呼我为那先。有时父母呼我为维先。有时父母呼我为首罗先。有时父母呼我维迦先。用是故人皆识知我世间人皆有是字耳。王问那先谁为那先者。王复问言头为那先耶。那先言头不为那先也。王复问眼耳鼻口为那先耶。那先言眼耳鼻口不为那先。王复问颈项肩臂足手为那先耶。那先言不为那先。王复问髀脚为那先耶。那先言不为那先。王复问颜色为那先耶。那先言不为那先。王复问苦乐为那先耶。那先言不为那先。王复问善恶为那先耶。那先言不为那先。王复问身为那先耶。那先言不为那先。王复问肝肺心脾脉肠胃为那先耶。那先言不为那先。王复问颜色苦乐善恶身心合是五事宁为那先耶。那先言不为那先。王复问假使无颜色苦乐善恶身心无是五事宁为那先耶。那先言不为那先。王复问声响喘息为那先耶。那先言不为那先。王复问何所为那先者。那先问王言名车何所为车者轴为车耶。王言轴不为车。那先言辋为车耶。王言辋不为车。那先言辐为车耶。王言辐不为车。那先言毂为车耶。王言毂不为车。那先言辕为车耶。王言辕不为车。那先言轭为车耶。王言轭不为车。那先言舆为车耶。王言舆不为车。那先言扛为车耶。王言扛不为车。那先言盖为车耶。王言盖不为车。那先言合聚是诸材木着一面宁为车耶。王言合聚是诸材木着一面不为车也。那先言假令不合聚是诸材木宁为车耶。王言不合聚是诸材木不为车。那先言音声为车耶。王言音声不为车。那先言何所为车者。王便默然不语。那先言佛经说之如合聚。是诸材木用作车因得车。人亦如是。合聚头面耳鼻口颈项肩臂骨肉手足肝肺心脾肾肠胃颜色声响喘息苦乐善恶合聚名为人。王言善哉善哉。王复问那先能与我共难经说道不。那先言如使王持智慧与我相问者能相难王持骄贵者意不能相难。王问那先言智者诸何等类。那先言智者谈极相诘语相解语相上语相下语有胜有负正语不正语自知是非是。为最智智者不用作嗔怒智者如是。王复问那先言王者语何等类。那先言王者语自放恣敢有违戾不如王语者王即强诛罚之王者语如是。王言愿用智者语不用王者语。莫复持对王者意与我语与我语。当如与诸沙门语。当如与诸弟子语。当如与诸优婆塞语。当以与众沙门给使者语。无得怀恐怖极正心。当相开悟。那先言大善。王言我欲有所问。那先言王便问。王言我已问。那先言我已答。王言答我何等语。那先言王亦问我何等语。王言我无所问。那先言无所答。王内自思惟念是沙门大高明慧。我甫始当多有所问。王意自念日欲冥当云何明日。当请那先归于宫中善相难问。王告沾弥利语。那先今日迫冥明日相请归于宫中善相难问。沾弥利望群即白那先言。日欲冥王当还宫明日王欲请那先。那先言大善。王即骑马还宫。于马上王续念那先字意念欲言那先。那先念至明日。明日沾弥利望群及傍臣白言王。审当请那先不王言当请之。沾弥利望群言。请者当使与几沙门俱来。王言在那先欲与几沙门俱来耳。王主藏者名悭。悭白王言令那先与十沙门俱来可(耳王)。复言听那先欲与几沙门俱来耳。悭复白王言令那先与十沙门俱来可。王复言听那先自在欲与几沙门俱来。悭复白王令那先与十沙门俱来可耳。王闻悭语大数王便嗔怒悭所汝真悭无辈。汝字为悭不望汝强惜王物自汝物当云何汝不知逆我意。当有诛罚之罪。王言可去哀赦汝罪今我作王为不能堪饭沙门耶。悭便惭愧不敢复语。沾弥利望群即往到那先所。便前作礼白言大王请那先那先言王当令我与几沙门俱行。沾弥利望群言自在那先欲与几沙门俱行。那先便与野和罗等八十沙门俱行。沾弥利望群悉俱行旦欲入城。沾弥利望群道中并问那先。昨日对王言无有何用为那先。那先问沾弥利望群卿意何所为那先者。沾弥利望群言我以喘息出入命气为那先。那先问沾弥利望群言人气一出不复还入其人宁复生不。沾弥利望群言气出不还定为死也。那先言如人吹笳气一出不复还入。如人持锻金笛吹火气一出时宁得复还入不。沾弥利望群言不复还入。如人以角吹地气一出时宁复还入不。沾弥利望群言不复还入。那先言同气出不复还入人何以故犹不死。沾弥利望群言喘息之间我不能知愿为我曹解说之。那先言喘息之气皆身中事。如人心有所念者舌为之言是为舌事。意有所疑心念之是为心事各有所主。分别视之皆空无有那先也。沾弥利望群心即开解便受五戒为优婆塞。那先便前入宫到王所上殿。王即为那先作礼而却。那先即坐八十沙门皆共坐。王极作美饭食。王手自着那先前饭众沙门饭食已竟。澡手毕讫。王即赐诸沙门人一张亵袈裟革屣各一量。赐那先野和罗各三领袈裟各一量革屣。王语那先野和罗言。留十人共止遣余人。令去那先即遣余沙门。令去留十人共止。王敕后宫诸贵人妓女。悉于殿上帷中听我与那先共难经道。时贵人妓女悉出殿上帷中。听那先说经。时王持座坐于那先前。王言当说何等。那先言王欲听要言者当说要言。王言卿曹道何等最要者用何等故作沙门。那先言我曹欲弃世间勤苦不欲更后世勤苦。用是故我曹作沙门。我曹用是为最要善。王言诸沙门皆不欲更今世后世勤苦故作沙门耶。那先言不悉用是故作沙门。沙门有四辈。王言何等四。那先言中有负债作沙门。中有畏县官作沙门者。中有贫穷作沙门者。中有真欲弃灭今世后世勤苦故作沙门。那先言我本至心求道故作沙门耳。王言今卿用道故作沙门耶。那先言我少小作沙门有佛经道及弟子。诸沙门皆多高明。我从学经戒入我心中。以是故弃今世后世勤苦故作沙门。王言善哉。王问言宁有人死后不复生者不。那先言中有于后世生者。中有不复生者。王言谁于后世生者。谁不复生者。那先言人有恩爱贪欲者后世便复生。人无恩爱贪欲者后世不复生也。王言人以一心念正法善故后世不复生耶。那先言人以一心念正法念善智慧及余善事故后世不复生。王言人以一心念正法善与智慧是二事其义宁同不。那先言其义各异不同。王问那先牛马六畜颇有智无有智。那先言牛马六畜各自有智其心不同。那先言王曾见获麦者不左手持麦右手刈之。那先言智慧之人断绝爱欲。譬如获麦。王言善哉。王复问那先何等为余善事者。那先言诚信孝顺精进念善一心智慧是为善事。王言何等为诚信者。那先言诚信者无所复疑。信有佛有佛经法信有比丘僧。信有阿罗汉信有今世。信有后世。信有孝顺父母。信有作善得善。信有作恶得恶。得信是以后心便清净。即去离五恶。何等五恶。一者贪淫。二者嗔恚。三者睡眠。四者戏乐。五者所疑。人不去是五恶心意不定。去是五恶意便清净。那先言譬如遮迦越王车马人从濿渡水令水浊恶过渡以去王渴欲得水饮。王有清水珠置水中水即为清。王便得清水饮之。那先言人心有恶譬如浊水。佛诸弟子得度死生之道心以清净如珠清水人却诸恶诚信清净。譬如明月珠王言善哉善哉。王问言人精进诚信者云何。那先言佛诸弟子自相见辈中脱诸恶心。中有得须陀洹者。中有得斯陀含者。中有得阿那含者。中有得阿罗汉者。中有因相效奉行诚信者。皆亦得度世道。那先言譬如山上大雨其水下流广大。两边人俱不知水深浅畏不敢渡。如有远方人来视水隐知水广狭深浅。自知力势能入水便得渡过。两边人众便效随后亦得渡。去佛诸弟子亦如是。见前人净心得须陀洹斯陀含阿那含阿罗汉道。皆从善心精进所致也。佛经言人有诚信之心。可自得度世道人能制止却五所欲自知身苦者。乃能得度世人皆从智慧成其道德。王言善哉善哉。王言何等为孝顺者。那先言诸善者皆为孝顺。凡三十七品经皆由于孝顺为本。王言何等为三十七品经。那先言有四意止有四意断有四神足有五根有五力有七觉意有八种道行。王复问那先言何等为四意止者。那先报王言佛说一为身身观止。二为观痛痒痛痒止。三为观意意止。四为观法法止。是为四意止。王复言何等为四意断。那先言佛说已分别止四事不复念是为四意断。以得四意断便自得四神足念。王复问何等为四神足念。那先言一者。眼能彻视。二者耳能彻听。三者能知他人心中所念。四者身能飞行。是为四神足念。王复问何等为五根者。那先言一者眼见好色恶色意不贪着是为根。二者耳闻好声恶骂声意不贪着是为根。三者鼻闻香臭意不贪着是为根。四者口得美味苦辛意不贪着是为根。五者身得细滑意亦不喜身得粗坚意亦不恶是为五根。王复问何等为五力者。那先言一能制眼。二能制耳。三能制鼻。四能制口。五能制身。令意不堕是为五力。王复问何等为七觉意者。那先言一意觉意。二分别觉意。三精进觉意。四可觉意。五猗觉意。六定觉意。七护意。是为七觉意。王复问何等为八种道行。那先言一直见。二直念。三直语。四直治。五直业。六直方便。七直意。八直定。是为八种道行。凡是三十七品经皆由孝顺为本。那先言凡人负重致远有所成立皆由地成。世间五谷树木仰天之草皆由地生。那先言譬如师匠图作大城当先度量作基址已乃可起城。那先言譬如伎人欲作当先净除地平。乃作佛弟子求道。当先行经戒念善因知勤苦便弃诸爱欲便思念八种道行。王言当用何等弃诸爱欲。那先言一心念道爱欲自灭。王言善哉善哉。王复问言何等为精进者。那先言持善助善是为精进。那先言譬如垣墙欲倒从边拄之舍欲倾坏亦复拄之是为精进。那先言譬如国王遣兵有所攻击兵弱欲不如。王复遣兵往助之兵便得胜。人有诸恶如兵少弱时人持善心消灭恶心。譬如王增兵得胜。持五善心消五恶心。譬如战斗得胜。是为精进助善。如是那先言精进所助致。人善道已。得度世道无有还期。王言善哉。王复问何等为意当念诸善事者。那先言譬如人取异种华以缕合连系之风吹不能散。那先复言譬如王守藏者知王帑藏中金银珠玉琉璃珍宝有其多少。道人欲得道时意念三十七品经。譬如是正所谓念度世之道者也。人有道意因知善恶知当可行知当不可行。分别白黑自思惟以后便弃恶就善。那先言譬如王有守门者。知王有所敬者。知王有所不敬者。知有利王者。知有不利王者。守门者知王所敬者。知利王者便内之。知王不敬者知不利王者。守门者即不内。那先言人持意亦如是。诸善者当内之。诸不善者不当内。守意制心譬亦如是。那先说经言人当自坚守护其意及身中六爱欲持意坚守自当有度世。时王言善哉善哉。王问那先言何等为一其心者。那先言诸善中独有一心最第一人能一其心诸善皆随之。那先言譬如楼陛当有所倚诸为善者皆着一心。那先言譬如王将四种兵出行战斗。象兵马兵车兵步兵皆导引王前后。佛诸经戒及余善事皆随一心亦譬如兵。那先说经言诸善中一心为本学道人众多皆当先归一心。人身生死过去如水下流。前后相从无有住时。王言善哉。王复问何等为智慧者。那先言我前说己人有智慧能断诸疑明诸善事是为智慧。那先言譬如持灯火入冥室。火适入室便亡其冥自明。明人有智慧譬如火光。那先言譬如人持利刀截木。人有智慧能截断诸恶譬如利刀。那先言人于世间智慧最为第一。人有智慧能得度脱生死之苦。王言善哉。王言那先前后所说经种种别异。但欲趣却一切恶耶。那先言然佛经所说种种诸善者。但欲却一切恶也。那先言譬如王发四种兵。虽行战斗初发行时意但欲攻敌耳。佛所说经种种诸善。但欲共攻去一切恶耳。王言善哉善哉。那先说经甚快也。王复问那先言。人死所趣善恶之道续持故身神行生耶。更贸他神行生耶。那先言亦非故身神亦不离故身神。那先因问王身小时哺乳时身至长大时续故身非。王言小时身异。那先言人在母腹中始随精时至精浊时故精耶异也。坚为肌骨时故精耶异也。初生时至年数岁时故精耶异也。如人学书时傍人宁能代其工不。王言不能代其工。那先言如人犯法有罪宁可取无罪之人代不。王言不可。那先以精神罪法语王王意不解。王因言如人问那先那先解之云何。那先言我故小时身耳。从小至大续故身尔。大与小时含为一身养是命所养。那先问王言譬如人然灯火宁至天明不。王言然灯油至明。那先言灯中炷火至一夜时续故火光不至夜半时故火光不至明时故火光不。王言非故火光。那先言然灯从一夜至夜半复更然灯火耶向晨时复更然灯耶。王言不中夜起更然火续故一炷火至明耳。那先言人精神展转相续亦譬如是。一者去一者来人从精神生至老死后精神更趣所向生。展转相续是非故精神亦不离故精神。人死以后精神乃有所趣向生。那先言譬如乳湩化作酪。取酪上肥煎成醍醐。宁可取醍醐与酪上肥还复名作乳湩。其人语宁可用不。王言其人语不可用。那先言人神乳湩从乳湩成酪从酪成肥从肥成醍醐。人神亦如是从精神生从生至长从长至老。从老至死死后神更复受生一身死当复更受一身。譬如两主更相然。王言善哉善哉。王复问那先人有不复于后世生者。其人宁能自知不。那先言然有能自知者。王言用何知之。那先言其人自知无恩爱无贪欲无诸恶用。是故自知后世不复生。那先问王譬如田家耕犁种谷多收敛着囤中。至后岁不复耕不复种。但仰囤中谷食。其田家宁复望得新谷不。王言其田无所复望。那先言其田家何用知不复得谷。王言其田家不复耕不复种故无所望。那先言得道亦如是自知已弃捐恩爱苦乐无有贪心。是故自知后世不复生。王复言其人于后世不复生者于今宁有智异于人不。那先言然。有智异于人。王言宁能有明不。那先言然有明。王言智与明有异同乎。那先言智与明等耳。王言有智明者宁悉知万事不宁有所不及知不。那先言人智有所及有所不及。王言何等为智有所及有所不及。那先言人前所不学前所不及知。人前所学前所及知。智者所见人及万物皆当过去归空不得自在。人心所贪乐皆种苦本从是致苦。慧者知非常成败之事。是智为异于人。王问言人有智慧痴愚所在。那先言人有智慧诸愚痴皆自消灭。那先言譬如人持灯火入冥室。室中皆明冥即消灭智如是。人有智慧诸痴愚皆悉消灭。王言人智今为所在。那先言人行智以后智便消灭智所作者故作。那先言譬如人夜于火下书火灭字续在。智者如是有所成已。智便消灭其所作续在。王言智有所成已便自灭是何等语。那先言譬如人备火豫作戒火五瓶水。如有失火者其人持五瓶水水滴灭火。火灭以后其救火人宁复望得完瓶归家用不。王言其人不复望瓶破。火灭岂复望瓶耶。那先言道人持五善心消灭诸恶亦譬如瓶水灭火。王言何等为五善。那先言一者信善有恶。二者不毁经戒。三者精进。四者有慧念善。五者一心念道。为是五善。人能奉行是五善者。便得智慧便知身及万物非常。便知苦不得自在。便知空无所有。那先言譬如医师持五种药诣病者家以药饮病人。病者饮药得愈医宁复望得故药复行治人不。王言不复望得故药。那先言五种药者。如五善智。其医者。如求道人。其病者。如诸恶。愚痴者。如病人。得道度世者。如病得愈人。智所成致人度世道人已得道智亦自灭。那先言譬如健斗人把弓持箭前行向敌以五箭射敌得胜。其人宁复望箭归归不。王言不复望箭。那先言五箭者。人五智也。智人从智得道如健斗得胜敌家。诸恶者。如诸恶道人持五善心灭却诸恶。诸恶皆灭善智即生。人从善智得成度世道者常在不灭。王言善哉。王言如人得道后世不复生者后宁复更苦不。那先言或有更苦者或有不更苦者。王言更苦不更苦云何。那先言身更苦耳心意不更苦。王言身更苦心意不更苦云何。那先言身所以更苦者。其身见在故更苦心意弃捐诸恶无有诸欲。是故不复更苦。王言假令得道人不能得离身苦者是为未得泥洹道耶。王言人得道已无所恩爱身苦意安何用为得道。王言假令人得道已成当复何留。那先言譬如果物未熟不强熟也。已熟亦无所复待。那先言王属所道者舍犁曰所说舍犁曰在时言。我亦不求死我亦不求生我但须时可时至便去。王言善哉善哉

那先比丘经卷上那先比丘经卷中

        失译人名附东晋录

王问人更乐者为善耶不善也。人更苦为善耶为不善也。佛得无不说有乐或有苦。王言如使有为无有苦。那先问王言如人烧铁着手中宁烧人手不。复取冰着手中其冰宁复烧人手不。王言然两手皆威也。那先问王言。如是两手中物皆热耶。王言不两热。那先言两冷耶。王言不两冷也。那先言两手中皆烧。那先言我重问王。王前后两热当言两热。两冷当言两冷。何缘一冷一热能同言烧人手乎。王言智虑甚浅近不能及是难也。愿那先为我解之。那先言佛经说之。凡有六事。令人内喜。有六事令人内愁。复有六事。令人不喜亦不愁。外复有六事。令人愁。王问何等为六事。令人内喜。那先言。一者目有所视复有所望。是故令人内喜。二者耳闻好声复有所望。是故令人内喜。三者鼻闻好香复有所望。是故令人内喜。四者舌得美味复有所望。是故令人内喜。五者身得细滑复有所望。是故令人内喜。六者心得乐受复有所望。是故令人内喜。如是六事令人内喜。王复问何等为外六事。令人喜。那先言一者眼见好色念之不可常得皆当弃捐便自思惟审然无常。是故令人外喜。二者耳闻好声念之不可常得皆当弃捐。是故令人外喜。三者鼻闻好香念之不可常得皆当弃捐。是故令人外喜。四者口得美味念之不可常得皆当弃捐。是故令人外喜。五者身得细滑念之不可常得皆当弃捐。是故令人外喜。六者心念爱欲思惟念之是皆无常皆当弃捐念之是以后更喜。是为六事令人外喜。王复问何等为内六事令人内愁。那先言。一者令人内愁者目所不喜而见之令人内愁。二者耳不欲所闻而闻之令人内愁。三者鼻不欲所臭而嗅之令人内愁。四者口不欲所得而得之令人内愁。五者身不欲所著而着之令人内愁。六者心不可所喜而有之令人内愁。是为六事令人内愁。王复问何等为外六事。令人不喜。那先言。一者目见恶色令人不喜。二者耳闻恶声令人不喜。三者鼻闻臭腥令人不喜。四者舌得苦辛令人不喜。五者身着粗坚令人不喜。六者心有所憎令人不喜。是为外六事令人不喜。王复问何等为六事。令人不愁亦不喜。那先言。一者目有所见亦不喜不愁。二者耳有所闻音亦不喜亦不愁。三者鼻有所嗅亦不喜亦不愁。四者口有所得亦不喜亦不愁。五者身有所触亦不喜亦不愁。六者心有所念亦不喜亦不愁。是为内六事。令人不喜不愁。王复问何等为外六事。令人愁者。那先言。一者目所见死者因自念身及万物无常。其人自念言我有是念何以不得道因外愁。二者耳不乐好音其人自念言。我有是念何以不得道因外愁。三者鼻不喜臭香其人自念言。我有是念何以不得道因外愁。四者口不味苦甜其人自念。我有是念何以不得道因外愁。五者身不好细滑亦不得粗坚其人自念言。我有是念何以不得道因外愁。六者心不喜爱欲其人自念言。我有是念何以不得道因外愁。是为六事令人外愁。王言善哉善哉。王复问那先人以死后谁于后世生者。那先言名与身于后世生。王问那先故人名身行生耶。那先言不也。非故名亦非故身持是名身于今世作善恶乃于后世生耳。王言如使今世用是名身作善恶于后世身不复生者极可作善恶径可得脱不复更诸苦耶。那先言于今世作善后世不复生者便可得脱无耶。人作善恶不止当后生耳是故不得脱。那先言譬如人盗他人果蓏其主得盗果者将至王前白言。是人盗我果其盗者言。我不盗是人果是人所种小栽耳本不种果也。我自取果我何用为盗我不盗是人果我不应有罪过。那先问王言。如是两人共争谁为直者谁不直者。王言种栽家为直本造所种盗者无状应为有罪。那先言盗何用为有罪。王言所以盗者有罪本种栽家所种从栽根生故上有果耳。那先言人生亦譬如是人今世用是名身作善恶乃生于后世今世作善恶者是本也。那先言。譬如人盗他人禾穟其主得盗便牵问之汝盗我禾穟。为盗者言我不盗卿禾穟卿自种禾我自取穟我何用为犯盗。两人相牵至王前白如是谁为直者谁为不直。王言种禾谷为直盗者为不直。那先言何以知盗禾穟者为不直。王言是种禾者为本有不种禾者为无缘何有穟。那先言人生亦譬如是。人今世用是名身作善恶。乃生于后世。今世作善恶者是其本也。那先言。譬如人冬寒于一舍中然火欲自温炙。其人弃火而去。稍稍然及壁土烧屋连及楼舍。舍主因言起火者牵至王前白言。是人起火延及烧我楼舍。然火者言我然小火自温炙耳。我不烧楼舍。那先问王谁为直者。王言本然火者为不直本所生也。那先言人生亦尔。譬如人今世用是名身作善恶。乃生于后世今世作善恶者是本也。那先言譬如人夜然烛火着壁欲用自照饭食。烛稍却及壁上及竹木林材。便烧一舍火大炽延及烧一城中。举城中人民共诟言。汝何为烧一城中乃如是。然火者言我但然小烛火以自照饭食耳。是自大火非我火也。如是便共争讼相牵至王前。那先问王言。如是谁为直者谁为不直者。王言然火者为不直。那先言何以知。王言本是火所生也。汝饭食已不当灭火也而令火烧一城中。那先言。人生亦譬如是人今世用是名身作善恶。乃生于后世今世作善恶者是其本也。人用不知作善恶故不能得度脱。那先言。譬如人以钱娉求人家小女。以后女长大他人复更求娉求女得女以为妇。前所娉家来自说言。汝反取妇为。后家言。汝自小时娉女我自大时娉妇我何用为婴汝妇耶。便相牵诣王前。那先言王如是谁为直者谁为不直者。王言前娉家为直。那先言王何以知。王言是女本小今稍长大是故知为直也。是前娉家妇也。那先言人生亦譬如是人今世用是名身作善恶。乃生于后世今世作善恶者是其本也。那先言譬如人持瓶从牧牛家买乳湩。得湩已复还寄其主言我今还。不久其人须臾来还取瓶湩湩以转作酪。买湩家言。我持湩寄卿今反持酪还我牧牛者。言是汝故乳今自转为酪。两人因共争讼相牵诣王前。那先问王言如是谁为直者。王言牧牛家为直那先言王何以知。王言汝自买湩停置地自转成酪。牧牛家当有何过。那先言人生亦譬如是人今世用是名身作善恶。乃生于后世今世作善恶者是其本也。王复问今那先当复于后世生耶。那先报王言用是为问我前说已如使我有恩爱者后世当复生。如使我无恩爱者不复生。那先言譬如人竭力事王。王当知其善使赐其财物。其人得物极自施用衣被饮食欢乐自乐。其人论议言。我有功于王。王未曾有赏赐我也。那先问王如彼人得赏赐。反言未曾得其人语宁可用不。王言其人语不可用。那先言是故我语王言。如使我有恩爱者当复于后世生。如使我无恩爱者不复于后世生。王言善哉善哉。王问那先言。卿前所说人名与身何等为名何等为身者。那先言今见在为身心所念者为名。王复问人何故有名行于后世生而身不行生。那先言人身以名前后相连。譬如鸡子中汁及与上皮乃成鸡子。人名与身相连如是不分也。王言善哉。王复问那先何等为久者。那先言以过去事为久。当来事亦为久。见在事为无有久。王言善哉。王复问那先言审为有久不。那先言。或有久或无有久。王复言。何等为有久何等为无有久。那先言其得道泥洹者为无久。未得道当复更死生者为有久。人于今世好布施孝于父母于当来世当得其福。王言善哉善哉。王复问那先言诸以过去事当来事今见在事是三事何所为本者。那先言已过去事当来事今见在事愚痴者是其本也。愚痴生即生神神生身身生名名生色色生六知。一为眼知。二为耳知。三为鼻知。四为口知五为身知。六为心知。是为六知。是六事皆外向。何等为外向眼向色耳向声鼻向香口向味身向滑心向贪欲是为六外。向名为沛。沛者合沛者知苦知乐。从苦乐生恩爱。从恩爱生贪欲。从贪欲生有致便生因老。从老因病从病因死从死因哭从哭因忧从忧因内心痛。凡合是诸勤苦合名为人。人以是故生死无有绝时。人故本身不可得也。那先言譬如人种五谷生根从根生茎叶实至后得谷已。后年复种得谷甚多。那先问王如人种谷岁岁种谷宁有绝不生时不。王言岁岁种谷无有绝不生时也。那先言人生亦如是。展转相生无有绝时。那先言譬如鸡生卵卵生鸡从卵生卵从鸡生鸡。人生死亦如是无有绝时。那先便画地作车轮问王言。今是轮宁有角无。王言正圆无有角。那先言佛经说人生死如车轮展转相生无有绝时。那先言人从眼万物色识即觉知是三事合。从合生苦乐从苦乐生恩爱从恩爱生贪欲从贪欲生因有致从有致因生从生因作善恶从善恶便生。耳闻声识即觉知三事合。从合生苦乐从苦乐生恩爱从恩爱生贪欲从贪欲生因有致从有致因生从因生作善恶从善恶便生。鼻闻香识即觉知三事合。从合生苦乐从苦乐生恩爱从恩爱生贪欲从贪欲生因有致从有致因生从生因作善恶从善恶便生。口得味识即觉知三事合。从合生苦乐从苦乐生恩爱从恩爱生贪欲从贪欲生因有致从有致因生从因生作善恶从善恶便生。身得细滑识即觉知三事合。从合生苦乐从苦乐生恩爱从恩爱生贪欲从贪欲生因有致从有致因生从生因作善恶从善恶便生。意有所念识即觉知三事合。从合生苦乐从苦乐生恩爱从恩爱生贪欲从贪欲生因有致从有致因生从因生作善恶从善恶便生。那先言人展转相生无有绝。王言善哉。王复问那先卿言人生死不可得本不可得本意云何。那先言有本者当不复生。有本者当复过去用是为本。王言无本者当不复生。见有本者当过去如是本为未绝耶。那先言然皆当过去。王复问那先人生死宁有从旁增益者不。那先问王言世间人及蚑行蠕动之类宁有从旁增益者不。王言我不问那先世间人及蚑行蠕动之类。我但欲问卿人生死本耳。那先言树木生以栽为本五谷生以谷为本。天下万物皆各以其类本生。人从六情恩爱为本。那先言人有眼有色有识。有耳有声有识。有鼻有香有识。有舌有味有识。有身有细滑有识。有念有法有识。从是生苦乐从苦乐生恩爱从恩爱生贪欲从贪欲生合是诸苦乃成为人耳。眼耳鼻口身神识念使有致并合为沛。从沛生苦乐从苦乐生恩爱从恩爱生贪欲从贪欲因生有致从有致因生从生因老因病从病因死因忧从忧因哭从哭因内心痛人生如是。那先言无眼不见色不觉不知从不觉不知无有合。无有合无有苦乐无有苦乐便不生恩爱。无恩爱不生贪欲无贪欲无有致无有致不生不老。不生不老不病不死不病不死不愁不哭。不愁不哭不内心痛无是诸苦便度脱得泥洹道。无耳无所闻无鼻无所嗅无口无所味无身无细滑无识无所念。无所念无沛无沛无苦乐无苦乐无恩爱无恩爱无贪欲无贪欲无胞胎。无所胞胎无所生不生不老不老不病不病不死不死不愁不愁不哭不哭不内心痛。捐弃诸苦便得泥洹道。王言善哉。王复问那先言世间宁有自然生物无。那先言无有自然生物皆当有所因。那先因问王。今王所坐殿有人功夫作之耶自然生乎。王言人功作之材椽出于树木垣墙泥土出于地。那先言人生亦如是。界如和合乃成为人。是故无自然生物也皆有所因。那先言譬如窑家作器取土水和以为泥烧作杂器物其泥不能自成为器。会当须人工有薪火乃成为器耳。世间无有自然生者也。那先语王言譬如箜篌无弦无柱无人鼓者宁能作声不。王言不能自作声。那先言如使箜篌有弦有柱有人工鼓者其声宁出不。王言有声。那先言如是天下无自然生物皆当有所因。那先问王如钻火燧无两木无人钻者宁能得火不。王言不能得火。那先言设有两木有人钻之宁能生火不。王言然即生火。那先言天下无有自然生物皆当有所因。那先问王言譬如阳燧钩无人持之亦无日无天宁能得火。那先言如阳燧有人持之有天有日宁能得火不。王言得火。那先言天下无有自然生物皆当有因。那先问王言若人无镜无明人欲自照宁能自见其形不。王言不能自见。那先言如有有镜有明有人自照宁能自见形不。王言然即能自见。那先言天下无有自然生物皆有所因。王言善哉。王复问那先世间人宁为有人无。那先言世间不能审有人也适当呼谁为人。王言身中命即为人不。那先问王人身中命能用眼视色。不能用耳听音声。不能用鼻闻香。不能用舌知味。不能用身知细滑。不能用意有所知不。王言能。那先言今我与王其于殿上四面有窗自在欲从何窗者宁能见不。王言得见。那先言设令人命在身中自在欲从何孔视耳能以眼视色。不能用耳视色。不能用鼻视色。不能用口视色。不能用身视色。不能用意视色不。王言不能。那先言设令命在耳能以耳有所闻。不能以耳有所见。不能以耳知香臭。不能以耳知味。不能以耳知细滑。不能以耳有所念不。那先言设令命在鼻能以鼻知香臭。不能以鼻闻音声。不能以鼻知味。不能以鼻知细滑。不能以鼻有所念不。那先言设令命在口能以口知味。不能以口有所见。不能以口听音声。不能以口闻臭香。不能以口知细滑。不能以口有所念不。那先言设令命在身中能以身知细滑。不能以身有所见。不能以身听音声。不能以身知臭香。不能以身知味。不能以身有所念不。那先言设令命在识能以识有所念。不能以识听音声。不能以识知臭香。不能以识知味。不能以识知细滑不。王言不能知也。那先言王所语前后不相副。那先言如我与王共在殿上坐彻坏四窗者视宁广远不。王言然广远。那先言设令命在身中捩眼去之其视宁广远不。决耳令大其听宁能远不。决鼻令大闻香宁能远不。决口令大知味宁能多不。副剥皮肤知细滑宁多不。决判去意其令宁大不。王言不也。那先言王亦语前后不相副。那先问王言王持藏人来入在王前住王宁觉知在前住不。王言知在前。那先言持藏者即入王室宁知入室不。王言知入室也。那先言设令人命在身中人持味着口中能知甜醋酸碱辛苦。王言知之。那先言王所语前后不相副也。那先言如人沽美酒着大器中急塞一人口倒置酒中令尝酒其人宁知酒味不。王言其人不知。那先言何以故不知味。王言未入口到舌上故不知味。那先言王所语前后不相副。王言我愚痴智未及是难愿相解之。那先言人从眼见色神动。神动即生苦乐。意念合耳鼻口身意皆同合为意有所念神动。神动即生苦乐从苦乐生意从生念展转相成适无常主。王言善哉。王复问那先人生眼时眼与神俱生耶。那先言然同时俱生。王复问眼居前生耶。神居前生耶。那先言眼居前生神居后生。王言眼语神言我所行生处。汝当随我后生相语言两耶。神语眼言汝所生处。我当随汝后生两相语不。那先言两不相与语。王言卿不言同时俱生何以故不相语。那先言有四事俱不相语。那先自言何等四。一为下行二为向门三为行辙四者为数。是四事俱不相语。王复问何等为下行者。那先报王言高山上天雨其水随流当如何行。王言下行。那先言后复天雨其水流当复如何行。王言当随前流水处行。那先问王言。前水宁语后水言汝当随我后来。后水宁语前水言我当随汝处流行。前水后水相语言尔不。王言水流各自行。前后不相语也。那先言眼亦如水。眼不语神言汝当随我后生。神亦不语眼言我当随汝后行生也。眼与神俱不相语也。是名为下行。耳目鼻口身意亦尔。王复问何等为向门者。那先言譬如大城都有一门。其中有一人欲出当从何向。王言当从门出耳。那先言后复有一人欲出当复从何向出。王言故当从前一人门出耳。那先言王前出人宁语后人言。汝当随我后出。后人宁语前人言。我当随卿所从门出。两人宁相语言尔不。王言前人后人俱不相语也。那先言眼亦如门。眼不语神言汝当随我后生。神亦不语眼言我今当随汝后生。眼与神俱不相语也。是为向门。耳鼻口身意亦尔。王复问那先言何等为辙行者。那先问王言前车行有辙后车行当从何所行。王言后车当从前车辙中行。那先言前车轮宁语后轮言汝当随我处从后来。后车轮宁语前轮我当随汝处行。宁相语言尔不。王言俱不相语也。那先言人亦如是。眼不语神我所生处汝当随我生。神亦不语眼我当随卿后生。那先言耳鼻口身神俱不相语。王复问那先何等为数。那先言数者校计也书疏学问是为数。耳目鼻口身神稍稍习知共合。是六事乃为有所知。不从一事有所知也。王言善哉。王复问那先言。人目生时与苦乐俱生不。那先言目与苦乐俱生皆根从合生。王复言何等为合者。那先言两相触为合。合者譬如两羊相抵是为合。一羊如目一羊如色。合为名沛。譬如一手为目一手为色两手合为沛。譬如两石一石为目一石为色。两石合为沛。耳目鼻身神皆同合为沛。譬如雨石一石如神一石如志。两石合为沛。神志合如是。是名为沛。王言善哉。王复问那先。乐何等类。那先言自觉知为乐。那先言譬若人事国王。其人贤善。王赐与财物。其人得之。用自快乐。在所欲为。其人自念。我事王得赏赐。今得乐乐如是。那先言譬如人心念善口言善身行善。行善如是死后得生天上。其人于天上极意自娱乐自念言。我在世间时心念善口言善身行善。是故我自致生此间。得乐甚乐。是为觉。王言善哉。王复问那先。何等为觉者。那先言从知为觉。譬如王有持藏者入藏室中自视室中。自知有若干钱金银珠玉缯帛杂香色皆知杂处。是为觉知。王言善哉。王复问那先言。人有所念何等类。那先言人有所念因有所作。譬如人和毒药自饮。亦复行饮人。身自苦亦复苦他人身。那先言譬如人作恶死后当入泥犁中。诸所教者皆入泥犁中。恶人有所念所作言如是。王言善哉。王复问那先言。何等为内动者。那先言志念内便动。王言动行时云何。那先言譬如铜鋗铜釜。有人往烧之。其器有声。举乎有余音。而行人如是志动念因行。那先言烧时为动有余音为行。王言善哉。王复问那先言。能合取分别之不。是为合。是为智。是为念。是为意。是为动。那先言假令以合不可复分别也。那先言王使宰人作美羹。中有水有肉有葱蒜有姜有盐豉有糯。王敕厨下人言。所作美羹如前取羹中水味来。次取葱味来。次取姜味来。次取盐豉味来。次取糯味来。羹以成人宁能一一取羹味与王不。王言羹一合以后不能一一别味也。那先言诸事亦如是。一合不可别也。是为苦乐是为智是为动是为念。王言善哉善哉。王复问那先言。人持目视盐味宁可别知不。那先言王知乃如是耶。能持目视知盐味。王言目不知盐味耶。那先言人持舌能知盐味取。不能以目知盐味也。王复言人用舌知味云。那先言人皆用舌别知味。王言诸盐味皆当用舌别知耶。那先言然。诸盐味皆当用舌别知耳。王复问那先言。车载盐牛轭盐。车牛宁能别知盐味不。那先言车牛不能别知知盐味也。王问那先言。盐味宁可称不。那先言王智乃尔能称盐味。王问那先言。盐味不可称也。其轻重可称耳。王言善哉。王复问那先。凡人身中五知作众事所成耶。作一事成五知耶。那先言作众事所成。非一事所成也。譬如一地五谷当生时各各自生动类人身中五事皆用众事各所生。王言善哉善哉。王复问那先。世间人头须发肤面目耳鼻口身体四支手足皆完具。何故中有寿命长者。中有短命者。有多病者。中有少病者。中有贫者。中有富者。中有贵者。中有贱者。中有大士者。中有小士者。中有端正者。中有丑者。中有为人所信者。中有为人所疑者。中有明孝者。中有愚者。何故不同。那先言譬如诸树木果众中有醋不甜者。中有苦者。中有辛者。中有甜者。中有正醋者。那先问王言。是皆树木何故不同。王言所以不同者。其裁各自异。那先言人亦如是。心所念者各各异。是故令世间人不同耳。中有短命者。中有长命者中有多病者中有少病者中有富者中有贫者中有贵者中有贱者中有大士者中有小士者中有端正者中有丑者中有语用者中有语不用者中有明者中有愚者。那先言是故佛所言随其人作善恶自当得之。中有豪贵者中有贫穷者。皆是前世宿命世作善恶各自随其德得之。王言善哉善哉。王复问那先言。人有欲作善者。当前作之耶。当后作之乎。那先言当居前作之在后作之。不能益人也。居前作者有益于人。那先问王言。王渴欲饮时使人掘地作井。能赴王渴不。王言不赴渴也。当居前作井耳。那先言人亦如是。人所居皆当居前。在后作者无益也。那先问王。王饥时乃使人耕地粪地种谷。饥宁用饭耶。当豫有储。王言不也。当先有储贮。那先言人亦如是。当先作善。有急乃作善者无益身也。那先问王。譬如王有怨。当临时出战斗。王能使人教马教象教人作战斗具乎。王言不也。当宿有储贮。临时便可战斗。临时教马教象教人无益也。那先言佛经说言。人当先自念身作善。在后作善无益也。那先言王莫弃大道就邪道。无效愚人弃善作恶。后坐啼哭无所益也。人家弃捐忠正就于不正。临死时悔在后。王言善哉善哉。王复问那先。卿曹诸沙门言。世间火不如泥犁中火热也。卿曹复言。持小石着世间火中。至暮不消也。卿曹复言。极取大石着泥犁火中即消尽。是故我不信也。卿曹复言。人作恶死在泥犁中。数千万岁其人不消死。是故我重不信是语也。那先问王。王宁闻见水中有雌蟒雌蛟雌鳖雌蟹怀子以沙石为食不。王言然。皆以是为食。那先问王。沙石在腹中宁消不。王言然皆消。那先言其腹中怀子宁复消不。王言不消也。那先言何以故不消。王言相禄独当然故不消。那先言泥犁中人亦如是。数千万岁不消死者。其人所作罪过未尽故不消死。那先问王言。雌师子雌虎雌狗雌猫怀子。皆肉食啖骨入腹中时宁消不。王言皆消尽。那先问王言。其腹怀子宁复消不。王言不消也。那先言用何故不消。王言独用禄相故不消也。那先言泥犁中人亦如是。数千万岁不消死者。泥犁中人所作过恶未解故不消死。那先问王言。雌牛雌马雌驴雌麋雌鹿怀子。皆食草刍为餐不。王言然。皆以是为食。那先言其刍草宁于腹中消尽不。王言皆消尽。那先言其腹中子宁消尽不。王言不消尽也。那先言何故不消尽。王言独以相禄当然故使不消尽。那先言泥犁中人亦如是。是罪过未尽故不消死。那先问王言。夫人及长者富家女。饮食皆美恣意食。食于腹中宁消不。王言皆消。那先问王言。腹中怀子宁消不。王言不消也。那先言何以故不消。王言独相禄故使不消也。那先言泥犁中人亦如是。所以数千岁不消死者。用先世作恶故未解故不消死。那先言人在泥犁中长在泥犁中老过尽乃当死。王言善哉。王复问那先。卿曹诸沙门言。天下地皆在水上。水在风上。风在空上。我不信是也。那先便前取王书水适以三指撮举之问王言。是中水为风所持不。王言然。为风所持。那先言风持水亦如是。王言善哉。王复问那先言。泥洹道皆过去无所复有耶。那先言泥洹道无所复有也。那先言愚痴之人径来索内外身爱。坐是故不能得度脱于老病死。那先言智者学道人内外身不着也。人无有恩爱无有恩爱者无贪欲。无贪欲者无有胞胎。无有胞胎者不生不老。不生不老不病不死。不病不忧不哭。不忧不哭不内心痛。便得泥洹道。王言善哉。王复问那先言。诸学道者悉能得泥洹道不。那先言不能悉得泥洹道也。正向善道者学知正事。当所奉行者奉行之。不当奉行者远弃之当所念者念。不当所念者弃之。人如是者得泥洹道。王言善哉。王复问那先。人不得泥洹道者。宁知泥洹道为快不。那先言然。虽未得泥洹道。由知泥洹道为快也。王言人未得泥洹道者。何以知为快耶。那先问王言。人生未尝截手足为痛处。王言人虽未尝更截手足。由知为痛也。那先言何用知为痛也。王言其人截手足时呻呼用是知为痛。那先言人亦如是。前得泥洹道者转相语泥洹道快。用是故信之。王言善哉。王复问那先。那先宁曾见佛不。那先言未曾见也。王言那先诸师宁曾见佛不。那先言诸师亦不见佛也。如使那先及诸师不见佛者定为无有佛也。那先问王言。王见五百水所合聚处不。王言我不见也。那先言王父及太父皆见是水不。王言皆不见也。那先言王父及太父皆不见此五百水合聚处。天下定为无此五百水所聚处耶。王言虽我父及太父皆不见此水者。实有此水。那先言虽我诸师不见佛者。其实有佛。王言善哉

那先比丘经卷中那先比丘经卷下

        失译人名附东晋录

王复问言。无有复胜佛者耶。那先言然。无有胜佛者。王复问。何以知为无有胜佛者。那先问王言。如人未曾入大海中。宁知海水为大不。有五河河有五百小河流入大河。一者名恒。二者名信他。三者名私他。四者名[言*宰]叉。五者名施披夷。尔五河水昼夜流入海。海水亦不增不减。那先言王宁能闻知不。王言实知。那先言以得道人共道说无有能胜佛者。是故我信之。王言善哉。王复问那先。何用知无有能胜佛者。那先问王。造作书师者为谁。王言造书师者名质。那先言王宁曾见质不。王言质以死久远未曾见。那先言王未曾见质。何用知质为造书师。王言持古时书字转相教告。用是故我知名为质。那先言用是故我曹见佛经戒。如见佛无异。佛所说经道甚深快。人知佛经戒已后便转相教。用是故我知为无有能胜佛者。王复问那先。自见佛经道可久行之。那先言佛所施教禁经戒甚快。当奉行之至老。王言善哉。王复问那先人死已后身不随后世生耶。那先言人死已后更受新身故身不随。那先言譬如灯中炷更相然。故炷续在新炷更然。人身如是。故身不行更受新身。那先问王。王小时从师学书读经不。王言然。我续念之。那先问王。王所从师受经书。师宁复知。本经书耶。悉旧得其本经书。王言不也。师续自知本经书耳。那先言人身如此。置故更受新身。王言善哉。王复问那先。审为有智无。那先言无有智。那先言譬如人盗他人果蓏。盗者宁有过无。王言有过。那先言初种栽时上无果蓏。何缘盗者当有过。王言设不种栽何缘有果。是故盗者无状。那先言人亦如是。用今世作善恶。生于后世更受新身。王言人用是故身行作善恶。更新善恶所在。那先言人诸所作善恶随人。如影随身。人死但亡其身。不亡其行。譬如然火夜书。火灭其字续在。火至复成之。今世所作行后世成。如受之如是。王言善哉。王言那先宁能分别指视善恶所在不耶。那先言不可得知善恶所在。那先问王。树木未有果时言宁能分别指视言其枝间无有果。宁可豫知之不耶。王言不可知。那先言人未得道不能豫知善恶所在。王言善哉。王复问人当于后世生者。宁能自知不。那先言其当生者自知。王言何用知之。那先言譬如田家耕种天雨时节。其人宁豫知当得谷不。王言然。犹知当得谷多。那先言人亦如是。人当于后世生豫自知。王言善哉。王复问那先。审有泥洹无。那先言审有。王言那先宁能指示我佛在某处不。那先言不能指示佛在某处。佛以般泥洹去不可得指示指示见处。那先言譬如人然大火。以即灭其火。火宁可复指示知光所在不。王言不可知处。那先言佛以般泥洹去不可复知处。王言善哉。王复问那先。沙门宁。自爱其身不。那先言沙门不自爱其身。王言如令沙门不自爱其身者。何以故。自消息卧欲得安温软。饮食欲得美善自护视何以故。那先问王言。宁曾入战斗中不。王言然。我曾入战斗中。那先言在战斗中曾为刀刃箭所中不。王言我曾颇为刀刃所中。那先问王。刀刃矛箭疮柰何。王言我以膏药绵絮裹耳。那先问王言。王为爱疮故以膏药绵絮裹耶。王言我不爱疮。那先言殊不爱疮者。何以持膏药绵絮裹以护之。王言我欲使疾愈耳。不爱其疮。那先言沙门亦如是。不爱其身。虽饮食心不乐。不用作美。不用作好。不用作肌色。趣欲支身体奉行佛经戒耳。佛经说言。人有九孔。为九矛疮。诸孔皆臭处不净。王言善哉。王复问那先。佛为审有三十二相八十种好身皆金色有光影耶。那先言佛审有三十二相八十种好皆有金色有光影。王言佛父母宁复有三十二相八十种好身皆金色有光影耶。那先言佛父母无是相。王言如使父母无是相者。佛亦无是相。王复言人生子像其种类。父母无有是相者。佛定无是相。那先言佛父母虽无是三十二相八十种好身金色者。佛审有是相。那先问王。王曾见莲华不。王言我见之。那先言此莲华生于地。长于泥水之中。色甚香好宁复像类泥水色不。王言不像类地泥水色。那先言虽佛父母无是诸相者。佛审有是诸相。佛生于世间长于世间。而不像世间之事。王言善哉。王复问那先。佛审如第七天王梵所行。不与妇女交会不。那先言然。审离于妇女。净洁无瑕秽。王言假令佛如第七天王所行者。佛为第七天王梵弟子。那先问王。第七天王者有念无念。王言第七天王梵有念。那先言是故第七天王梵及上诸天皆为佛弟子。那先问王言。鸟鸣声何等类。王言鸟鸣声如雁声。那先言如是鸟为是雁。弟子各自异类。佛亦如是。非第七天王梵弟子。王言善哉。王复问那先。佛宁悉学知奉行经戒不。那先言佛悉学知奉行经戒。王言佛从谁师受经戒。那先言佛无师。佛得道时便悉自知诸经道。佛不如诸弟子学知佛所教。诸弟子皆当奉行至老。王言善哉。王复问那先。人父母死时悲啼哭泪出。人有闻佛经。亦复悲啼泪出。俱泪出宁有别异不。那先言人有父母啼泣皆感思爱恩念愁忧苦痛。此曹忧者愚痴忧耳。其有闻佛经道泪出者。皆有慈哀之心。念世间勤苦。是故泪出。其得福甚大。王言善哉。王复问那先。以得度脱者。未得度脱者。有何等别异。那先言人未得度脱者。有贪欲之心。人得度脱者。无有贪欲之心。但欲趣得饭食支命耳。王言我见世间人。皆欲快身欲得美食无有厌足。那先言人未得度脱者。饭食用作荣乐好。人得度脱者。虽饭食不以为乐不以为甘。趣欲支命。王言善哉。王复问那先。人家有所作。念久远之事不。那先言人愁忧时。皆念久远之事。王言用何等念之。用志念耶。用念念耶。那先问王言。宁曾有所学知以后念之不。王言然我曾有所学知。以后复忽忘之。那先言王是时无忘耶而忘之乎。王言我时妄念。那先言可差王为有象。王复问那先。人有所作皆念。如甫始有所作。今见在所作皆用念知耶。那先言已去之事皆用念知之。今见在之事亦用念知之。王言如是人但念去事。不能复念新事。那先言假令新者有所作不可念者亦如是。王言人新学书技巧为唐捐耶。那先言人新学书画者有念。故令弟子学者有知。是故有念耳。王言善哉。王复问那先。人用几事生念耶。那先言人凡有十六事生念。一者久远所作生念。二者新有所学生念。三者若有大事生念。四者思善生念。五者曾所更苦生念。六者自思惟生念。七者曾杂所作生念。八者教人生念。九者像生念。十者曾有所忘生念。十一者因识生念。十二者校计生念。十三者负债生念。十四者一心生念。十五者读书生念。十六者曾有所寄更见生念。为十六事生。一王复问那先。何等为念久者。那先言佛弟子阿难女弟子优婆夷鸠仇单罢。念亿世宿念时事。及余道人皆能念去世之事。如阿难女弟辈甚众多。念此以便生念。二王复问。何等为新所学生念者。那先言如人曾学知校计。后复忘之。见人校计便更生念。三王复问那先。何等为大事生念者。那先言譬如太子立为王。自念为王豪贵。是为大事生念。四王复问那先。何等为思善生念者。那先言譬如为人所请呼极善意宾遇待之。其人自念言。昔日为某所请呼善意待人。是为思善生念。五王复问那先。何等为更苦生念。那先言譬如人曾为人所挝捶闭系牢狱。是为更苦生念。六王复问那先言。何等为自思惟生念者。那先言譬如曾有所见。若家室宗亲及畜生。是为自思惟生念。七王复问那先言。何等为曾杂所作生念者。那先言譬如人名万物字类色香臭甜苦。念此语事是为杂生念。八王复问那先言。何等为教人生念者。那先言人自喜忘边人或有者或忘者。忘为教人生念。九王复问那先言。何等为像生念者。那先言人牛马各自有像类。是为像生念。十王复问那先。何等为曾所忘生念者。那先言譬如人卒有所忘。数数独念得之。是为曾所忘生念。十一王复问那先。何等为因识生念者。那先言学书者能求其字。是为因识生念。十二王复问那先。何等为校计生念者。那先言如人共校计成就悉知策术分明。是为校计生念。十三王复问那先。何等为负债生念者。那先言譬如顾鼓所当债归。是为债局生念。十四王复问那先。何等为一心生念者。那先言沙门一其心。自念所从来生千亿世时事。是我为一其心生念。十五王复问那先。何等为读书生念者。那先言帝王有久古之书。念言某帝某年时书也。是为读书生念。十六王复问那先。何等为曾有所寄更见生念者。那先言若人有所寄。更眼见之便生念。是为所寄生念。王言善哉。王复问那先。佛宁悉知去事甫始当来事耶。那先言然。佛悉知之。王言假令佛悉知诸事者。何故不一时教诸弟子。何故稍稍教之。那先问王。国中宁有医师无。王言有医师。宁能悉知天下诸药不。王言能悉识知诸药。那先问王。其医师治病。为一时与药。稍稍与之王言人未病。不可豫与药。应病乃与药耳。那先言佛虽悉知去来见在之事。亦不可一时悉教天下人。当稍稍授经戒令奉行之耳。王言善哉。王复问那先。卿曹沙门言。人在世间作恶。至百岁临欲死时念佛。死后者皆得生天上。我不信是语。复言杀一生死即当入泥犁中。我不信是语。那先问王。如人持小石置水上。石浮耶没耶。王言其石没。那先言如令持百枚大石置船上。其船宁没不。王言不没。那先言船中百枚大石因船故不得没。人虽有本恶。一时念佛。用是故不入泥犁中。便得生天上。其小石没者如人作恶。不知佛经死后便入泥犁中。王言善哉。王复问那先。卿曹用何等故行学道作沙门。那先言我以过去苦现在苦当来苦。欲弃是诸苦。不欲复受更。故行学道作沙门。王复问那先。苦乃在后世。何为豫学道作沙门。那先问王。王宁有敌国怨家欲相攻击不。王言然。有敌国怨家。常欲相攻击也。那先问王。敌主临来时。王乃作斗具备守掘堑耶。当豫作之乎。王言当豫有储待。那先问王。用何等故豫作储待。王言备敌来无时故。那先问王。敌尚未来何故豫备之。那先复问王。饥乃田种渴乃掘井耶。王言皆当豫作之。那先言尚未饥渴。何故豫作调度。王言善哉。王复问那先。第七梵天去是几所。那先言甚远。令石大如王殿。从第七梵天上堕之。六月日乃堕此间地耳。王言卿曹诸沙门言。得罗汉道。如人屈伸臂顷。以飞上第七梵天上。王言我不信是。行数千万亿里。何以疾乃尔耶。那先问王。王本生何国。王言我本生大秦国。国名阿荔散。那先问王。阿荔散去是间几里。王言去二千由旬合八万里。那先问王。颇曾于此遥念本国中事不。王言然。恒念本国中事耳。那先言王试复更念本国中事。曾有所作为者。王言我即念已。那先言王行八万里。反复何以疾。王言善哉。王复问那先若有两人于此俱时死。一人上生第七梵天。一人生罽宾。去是七百二十里。谁为先到者。那先言两人俱时到耳。王言相去远近大多何以俱至。那先问王。试念阿荔国。王言我已念之。那先复言王试复念罽宾。王言我已念之。那先问王念是两国何所疾者。王言俱等耳。那先言两人俱死。一人生第七梵天上。一人生罽宾。亦等耳。那先问王。若有一双飞鸟。一鸟于大树上止。一鸟于小卑树上止。两鸟俱止。谁影先在地者。王言其影俱到地耳。那先言两人俱死。一人生第七梵天上。一人生罽宾。亦俱时至耳。王言善哉。王复问那先。人用几事学知道。那先言用七事学知道。何等为七。一者念善恶之事。二者精进。三者乐道。四者伏意为善。五者念道。六者一心。七者适遇无所憎爱。王复问那先。人用此七事学知道耶。那先言不悉用七事学知道。智者持智别知善恶。用是一事别知耳。王复问那先。假令用一事知者何为说七事。那先问王。如人持刀着鞘中倚壁。刀宁能自有所割截不。王言不能有所割截。那先言人心虽明。会当得是六事共成智耳。王言善哉。王复问那先。人家作善得福大耶。作恶得殃大耶。那先言人作善得福大。作恶得殃小。人家作恶日自悔过。是故其过日小。人家作善日夜自念欢喜。是故得福大。那先言。昔者佛在时其国中有人杌无手足而取莲华持上佛。佛即告诸比丘言。此杌手足儿却后九十一劫不复堕入泥犁中畜生薜荔道中。得生天上。天上寿终复还作人。是故我知人作小善得福大。作恶其人自悔过日消灭而尽。是故我知人作过其殃小。王言善哉。王复问。那先。智者作恶愚人作恶。此两人殃咎谁得多者。那先言。愚人作恶得殃大。智人作恶得殃小。王言不如。那先言。王言我国治法大臣有过则罪之重。愚民有过则罪之轻。是故智者作恶得殃大。愚者作恶得殃小。那先问王。譬如烧铁在地。一人知为烧铁。一人不知。两人俱前取烧铁谁烂手大者耶。王言。不知者烂手大。那先言。愚者作恶不能自悔故其殃大。智者作恶知不当所为。日自悔过故其殃少。王言善哉。王复问。那先。人有能持此身飞行上至第七梵天上及至郁单越地及所欲至处者不。那先言能。王言。奈何持此身上第七梵天及郁单越地及所欲至处乎。那先问王。王宁自念少小时跳戏一丈地不。王言。我年少时意念欲跳便跳一丈余地。那先言得道之人意欲跳至第七梵天上及至郁单越地者亦尔。王言善哉。王复问那先。卿曹诸沙门言。有骨长四千里。何等身骨乃长四千里。那先问王。曾闻大海中有大鱼名质。身长二万八千里者不。王言然有是。我曹闻之。那先言如是二万八千里鱼。其胁骨长四千里。王怪之为。王复问那先。卿曹诸沙门说言。我能断喘息之事。王言奈何断喘息气耶。那先问王。宁曾闻志不。王言我闻之。那先言王以为志在人身中耶。王言我以为志在人身中。那先言王以为愚人不能制其身口者。不能持经戒者。如此曹人亦不乐其身。那先言其学道人。能制身口能持经戒能一其心。得四禅便能不复喘息耳。王言善哉。王问那先。为呼言海海为是水名为海耶。用他事故言海。那先言人所以呼为海者。水与盐参各半。是故为海耳。王复问那先。何以故海悉碱如盐味。那先言所以海水碱者。淡畜以来久远及鱼鳖虫多共清便水中。是故令碱耳。王言善哉。王复问那先。人得道以宁。能悉思惟深奥众事不。那先言然。人得道以能悉思惟深奥之事。那先言佛经最深奥知众事。不可称量众事。皆智平断之。王言善哉。王复问那先。人神智自然。此三事宁同各异。那先言人神者主觉。智者晓道。自然者虚空无有人。王复问那先言。得人何等为得人者。眼视色耳听声鼻闻香口知味身知粗软意知善恶之事。何所为得人者。那先问王。如令人能目自视。脱瞳子去之视宁广远不。裂大其耳听声宁广远不。决鼻令大。其闻香宁多不。开口令大。知味宁多不。剥割肌肤。宁令信知粗软不。拔去其志。盛念宁多不。王言不也。那先言佛在所作甚难。佛所如甚妙。王复问那先。所作何等甚难何等甚妙。那先言佛言能知人腹中。目所见事悉能解之。能解目事能解耳事能解鼻事能解口事能解身事能解败事能解疑事能解所念事能解神事。那先言人取海水含之。宁能别知口中水是泉水是某流水是某河水。王言众水皆合为一。难各别知。那先言佛所作为难皆能别知是诸水味。今海水见目前之事。王尚不能别知今人神不见人身中有六事不可见。那先言是故佛解之从心念至目所见。从心念至耳所听。从心念至鼻所嗅。从心念至口知味。从心念至身知苦乐寒温粗坚。从心念有所向。佛悉知分别解之。王言善哉。那先言夜已半我欲去。王即敕傍臣取四端[疊*毛]布揾。置麻油中持以为炬。当送那先归。恭事那先如事我身。傍臣皆言受教。王言得师如那先作。弟子如我。可得道疾。王诸所问那先辄事事答之。王大欢喜。王即出中藏好衣直十万已上那先。王语那先。从今已去愿那先日与八百沙门。共于宫中饭食及欲所得。皆从王取之。那先报王我为道人略无所欲。王言那先当自护。亦当护我身。那先言何等当自护及护王身。王报言恐人论议呼王为悭。那先为王解诸狐疑。而不能赐与。恐或人言那先不能解王狐疑故王不赏赐。王言那先受者当令我得其福。那先亦当护其名。王言譬如师子在金槛中。犹为拘闭常有欲望去心。今我虽为国王在宫省中其意不乐。欲弃国去而行学道。王语竟。那先便起归佛寺。那先适去王窃自念。我问那先为何等事。那先为解我何等事。王自念。我所问那先莫不解我意者。那先归佛寺亦自念。王问我何等事。我亦报王何等事。那先自念。王所问者我亦悉为解之。念此事至天明。明日那先被袈裟持钵直入宫上殿坐。王前为那先作礼已乃却坐。王白那先。那先适去我自念。问那先何等语。那先报我何等语。我复自念。所问那先。那先莫不解我意者。我念是语。欢喜安卧至明。那先言我行归舍亦自念。王为问我何等事。我亦为王说何等事。我复自念。王所问我辄为解之。用是故欢喜至明。语竟那先欲去。王便起为那先作礼

那先比丘经卷下


尼干子问无我义经

    No. 1643

尼干子问无我义经

        马鸣菩萨集

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

尔时尼干子等。心怀异见发起疑惑。寻求往诣解大乘者所。到已作礼合掌恭敬。问无我义使除暗钝。如佛所说为我开示。若说此身无有我者。彼最上我亦无所有。何故身中现见啼笑嬉戏忿怒我慢嫉妒两舌等事。于有于无不能决了。唯愿仁者为我除断。解大乘者谓尼干子言。汝先所执最上我者。决定虚妄。以何名有以何名无。于此二中都无所得。若以自身发甲皮肉筋骨脂髓肠胃手足一切身肢。为最上我。内外寻求何有可见。时尼干子白智者言。我以肉眼故不能见。余有天眼彼可得见。智者曰。亦非天眼之所能见。彼非显色亦非形色。自性空故。何有可见。尼干子言。彼定无耶。智者曰。若说无者。云何现见。从因缘生啼笑等相。或说为有。或说为无。二皆邪妄。非其正理。尼干子言。若有若无俱不应说。如何此身现有所住。智者曰。无有少分见所住相。尼干子言。若无住着即同虚空。智者曰。如汝所说如虚空故。尼干子言。若尔啼笑等相当云何遣。智者曰。于是义中而有二种。一者世俗。二者胜义。依世俗说。则有自他命者士夫补特伽罗作者受者财宝妻子亲眷朋属。如是差别。依胜义说。则无自他命者乃至朋属等事。亦无少分差别等相。若世俗说。则有生灭善恶果报。若胜义中。则无生灭善恶果报。彼真如法自性清净。无有烦恼无有染污亦无觉了。本来寂静。此说是名真如自性。重明此义以偈颂曰

  世俗胜义谛　　二种今当说
  世俗即世法　　胜义无过上
  有情依世俗　　增长于烦恼
  久处于轮回　　不了胜义法
  由依世俗故　　自他生遍计
  起分别疑惑　　而受诸苦恼
  彼愚痴凡夫　　长时受逼迫
  不修出离因　　何知解脱理
  愚人常依止　　世间生灭法
  驰流五趣中　　相续而不断
  由不达胜义　　则无灭苦要
  展转受轮回　　如蚕自缠缚
  亦如于日月　　旋转无休息
  众生三有中　　来往亦如是
  诸行悉无常　　刹那而迁变
  远离世俗法　　当求胜义谛
  乃至住诸天　　及乾闼婆等
  不免彼无常　　此皆世俗果
  夜叉鬼神等　　得持明成就
  不免堕恶趣　　此皆世俗果
  帝释转轮王　　福报无与等
  不免堕傍生　　此皆世俗果
  人天五欲乐　　决定当弃舍
  于彼菩提心　　以惠常观察
  自性无所著　　一切悉皆空
  超越所戏论　　是菩提心相
  非刚非柔软　　非热亦非冷
  非触非执受　　是菩提心相
  非长及非短　　非圆亦非方
  非微细非粗　　是菩提心相
  非白及非红　　非黑亦非黄
  非形色显色　　是菩提心相
  非色非光明　　非动非缠缚
  非住如虚空　　是菩提心相
  离思惟观察　　非外道境界
  与般若相应　　是菩提心相
  无似无对待　　无等常寂静
  自性本凝然　　是菩提心相
  如聚沫浮泡　　如幻化阳焰
  无我亦无常　　一切非坚固
  是身如坏器　　虚幻而充满
  与三毒相应　　毕竟空无有
  如月处云中　　刹那而不现
  以甚深般若　　达有为如幻
  众生器世间　　一切皆如梦
  由自心分别　　彼心亦如梦
  若人依正理　　以惠而修习
  弃背诸障染　　速得无上道
  此最胜般若　　诸佛所称赞
  智者善筹量　　勤求无上法
  离有为过失　　证真常胜德
  由此解脱故　　一切无染着
  时彼外道众　　闻已生欢喜
  善观察除疑　　得悟大乘智

尼干子问无我义经


菩提心观释

    No. 1663

菩提心观释

        西天译经三藏朝散大夫试鸿胪卿传教大师臣法天奉　诏译

  归命本师　　大觉世尊　　我今略释
  菩提心观

如佛所说。从心生一切法。我今当议彼菩提心。云何性。答离一切性。云何一切性。谓蕴处界等性。彼菩提心离取舍故。则法无我自性平等。本来不生自性空故。所言一切性者。是我等性。谓我人众生寿者补特伽罗摩拏嚩迦等性。而彼等性非菩提心。于意云何。谓彼我等。而于自性离一切相中而生我见。从我见生一切烦恼此不生彼心。或言蕴处界等亦离取舍。谓蕴处界等性真实理不可得故。云何色相等无实。谓色蕴四大合成故。四大者。即地水火风界。复生五色谓色声香味触。彼地大等及五色等。一一各自性不可得。如是诸法皆然。是故知色名虚假。由此知色蕴空。譬如因树有影树灭影亡。色蕴如是。受蕴亦然。云何名受。受有三种。谓苦受乐受非苦乐受。而此三受互相因缘。复有二种。谓身受意受。身色蕴摄。身不可得故。若无身即无受。亦不可言亦不可说非短非长。非色非相。无实无著。不可知故。身受如是。意受亦然。受蕴如是。见受蕴空。想蕴亦虚假不实。缘虑所摄。而彼缘虑不可得故。即非缘虑。非缘虑故见想蕴空想蕴如是。行蕴亦然。心所造作善意记念等行。无所有故。彼心法所生色等蕴一一无所生。是故知行蕴业相不实亦无主宰。即见行蕴空行蕴如是。识蕴亦然。乃至眼耳鼻舌身意。彼眼识等一一自性皆不可得。彼眼缘有色。从缘生识。无缘即不生识。而此眼色及彼色蕴等无分齐。此分别眼色即非眼色。识无所生。眼识如是。耳鼻舌身意亦然。如是知此识依止摩曩识。由依止摩曩识故。即发生过去未来见在法故。云何过去未来见在法。谓过去已灭。未来未生。见在不住。由是知识蕴空。如是一一说蕴处界。各各分别自性皆空。彼非无性即真实句。喻无种子不生芽茎。是故说彼蕴处界等亦离取舍。云何菩提心无取无舍。如佛所说。告秘密主彼菩提心。如来应正等觉了知彼心。非青非黄。非赤非白。非红色非颇胝迦色。非短非长。非圆非方。非明非暗。非女非男。非黄门等。又秘密主。菩提心非欲界性。非色界性。非天性非夜叉。非乾闼婆非阿修罗。非人非非人等性。乃至一切智求亦不可得。如是取心非有。云何言有舍故。又如佛说。告秘密主。菩提心非内非外非中间。不可得故。于意云何。以自性寂静故。又秘密主。彼菩提心一切智求不可得。云何得取舍。如是于法得离取舍。平等无我。如一切法无我亦然。如佛所说。菩提心亦然。一切法空无相无我。诸法寂静无寂静相。心本平等本来不生亦非不生。复云何性。答曰空性。空云何性。谓如虚空故。如佛所说。虚空之性空无喻故。菩提之心亦复如是。菩提之名非性非相。无生无灭。非觉非无觉。若如是了知。是名菩提心。又如佛说。告秘密主。于自本心如实了知。于无有法亦不可得。是故名阿耨多罗三藐三菩提。又告秘密主。当于自心如实观已。然后发起方便观于众生。知诸众生于自觉性不如实知。起于疑妄颠倒执着。受于种种轮回大苦。我由此故起大悲心。令诸众生于自心法如实证觉。是即名为菩提心。是名利益心。安乐心。最上心。法界善觉心。以如是智。摄诸众生故。名菩提心。发此心故。所获福德亦如虚空无有边际。其功德海亦复无量。虽复劫尽功德无尽。如是名为发一切智根本最上菩提心

菩提心观释一卷


菩提心离相论

    No. 1661

菩提心离相论

        龙树菩萨造

        西天译经三藏朝奉大夫试光禄卿传法大师赐紫臣施护奉　诏译

归命一切佛。我今略说菩提心义。至诚顶礼彼菩提心。如勇健军执胜器仗。其义亦然。而彼大菩提心。所有诸佛世尊诸菩萨摩诃萨。皆因发是菩提心故。我发菩提心亦如是。所成乃至坐菩提场成正觉果是心坚固。又此菩提心。是诸菩萨总持行门。如是观想如是发生。我今赞说菩提心者。为令一切众生息轮回苦。未得度者普令得度。未解脱者令得解脱。未安隐者令得安隐。未涅盘者令得涅槃。为欲圆满如是胜愿故。安立自相正体因故。入第一义真实观故。彼菩提心无生自相。是故今说。所言菩提心者。离一切性。问曰。此中云何离一切性。答谓蕴处界离诸取舍法无我平等。自心本来不生。自性空故。此中云何谓我蕴等有所表了。而分别心现前无体。是故若常觉了菩提心者。即能安住诸法空相。又复常所觉了彼菩提心。以悲心观大悲为体。由如是故。于诸蕴中无我相可得。有诸外道。起非相应行。执相分别谓诸蕴有非无常法。而实非彼我相可得。诸法任持真实性中。不可执常亦非无常。于我蕴中名尚无实。况复有作及诸分别。若言有一法乃至有诸法。作此说者。世间心转随世间行。彼非相应为常行相。此义不然。是故当知诸法无性。若内若外不可分别。彼能执心而有何因。谓不能离随世间相。若因若相是二无别。此即非常亦非能执。当知心性不可执常。是故彼性无常是常。若知彼性是无常者。当何所作从何所生取我等相。若离世间即于蕴中无有障碍。若处若界觉了亦然。取舍二法即不可得

此中言蕴者。谓色受想行识。此说为五蕴诸声闻人于是中学复次当知。色如聚沫。受如浮泡。想如阳焰行如芭蕉。识如幻士。此五蕴义。佛二足尊为诸菩萨如应宣说

所言色蕴者。今略示其相。谓四大种及彼所造。说为色蕴彼非色者。谓即所余受想行三。诸教应知识蕴行想如下当说

此中言处者。谓内眼等处。外色等处。此说为十二处

此中言界者。谓眼根等界。眼识等界。色等境界。此说为十八界。如是蕴处界离诸取舍。无方无分不可分别。分别见者是义不然。随起分别即有所著。彼复云何而得相应。若有一相见外义者。当知此为破智所转。意长养色是义云何。应知如是非一非异。有诸外道波哩没啰惹迦等。随诸异见起三分别。是义不然。如人梦中造杀害事。而彼所作无实行相。又如人梦居最上处。而彼亦非殊胜行相。此义云何。谓识光明破取舍相故。识法如是外义何有。是故诸法无有外义。当知一切色相所表。自识光明色相照耀。如人见彼幻化阳焰乾闼婆城取以为实。诸无智人以愚执心。观色等实亦复如是由此我执是心随转。如先所说蕴处界义。应知离彼诸分差别。唯心分位所施设故。而种种相唯心所现。此义成就如成唯识说。此中问言。前说五蕴识云何自相答如说心义识亦如是。如佛世尊常作是说。应知一切唯心所现。此义甚深。诸愚痴者不能了故。不见真实。是故若能空其我相。即于是心不生分别。起分别者谓邪教故。彼所建立是义不成。如实义者见法无我。是大乘中法无我义。自心本来而不生故。随有所生亦复平等。自心增上入真实义。瑜伽行门所出生故。此中应知。彼后所依而无实体。此即名为净心现行。若过去法过去无实。若未来法未来未至。若现在法现在不住。于三世中当云何住。如军林等多法成故。应知识者是无我相。彼识亦非为所依故。若于诸法如是见已。犹如赤云速疾散灭。是故当知。若法有者从思所现。阿赖耶识亦复如是。诸有情类若来若去。法尔如是。譬如大海众流所归。阿赖耶识所依亦然。若有如是观彼识者。即不可有分别心生。若彼各各如实知者。而彼彼名复云何说。若彼各各知诸物性。即彼各各不能称说。作此说者是决定语。是故诸法亦决定生。于一切事随转成就。能知所知是二差别。所知若无能知何立。二俱无实法云何得。是故应知。所言心者而但有名。彼名亦复无别可得。但以表了故。彼名自性亦不可得。以是义故。智者应当观菩提心自性如幻。若内若外及二中间求不可得。无法可取无法可舍。非形色可见非显色可表。非男女相非黄门相。不于一切色相中住。无法可见非眼境界。唯一切佛观察平等。若心自性若无自性。平等法中云何得见。所言性者名分别故。若离分别心性俱空。若有分别可见心者。此中云何说名为空。是故应知。无能觉无所觉。若能如是观菩提心。即见如来。若有能觉及有所觉。而菩提心不可成立。是故无相亦复无生。非语言道而能称赞。又菩提心者犹如虚空。心与虚空俱无二相。此说心空空智平等。佛佛神通佛佛无异。所有诸佛三世事业。一切皆住菩提界中之所摄藏。虽所摄藏彼一切法而常寂静。亦复观察。是无常法犹如幻化。非所摄藏调伏三有。住空法故。一切无生此说为空。一切无我亦说为空。若以无生及彼无我观为空者。是观不成。若染若净二种分别。即成断常二种见相。若言以智观彼空者。是空亦复无别有体是故菩提心离诸所缘住虚空相。若观虚空为所住者。是中即应有空有性。二名差别故知空者。犹如世间师子一吼群兽皆怖。如空一言。众语皆寂。故知处处常寂彼彼皆空。又复识法是无常法从无常生。彼无常性即菩提心。此说空义亦不相违。若无常性即菩提心者。若爱乐菩提是心平等。而亦不说爱乐彼空。取空之心当云何得。当知本来自性真实一切成就菩提心义。又复应知物无自性。无自性性。是此说义。此所说者是心云何。若离我法即心不住。此非一法亦非诸法。各各自性而自性离。如世糖蜜甜为自性。又如火者热为自性。彼诸法空。自性亦然。彼诸法性非常非断非得非离。以是义故。无明为初老死为后。诸缘生法之所成立。犹如梦幻体亦无实。由此说为十二支法。即此亦名十二支轮。循环转彼生死门中。而实无我无别众生。无三业行果报差别。若于是中了缘生法。即能出离诸境界门。彼非行相不坏正因蕴所生故。轮回后边非行相故。一切无持空空生故。法法平等造因受果。是佛所说。所有诸法聚类所生。如击鼓有声。如殖麦生芽。诸法聚类其义亦然。如幻如梦缘生所现。诸法因生而亦无生。因因自空而何所生。是故应知诸法无生。即此无生说名为空。如说五蕴蕴性平等。彼一切法亦如是念。若有说空如真实说。而所说空体亦非断。非断体中实亦不可得。说体为空空亦无体。若了无实作者无常。诸烦恼业积集为体。是业亦复从心所生。心若无住业云何得。如快乐心是寂静性。彼寂静心而不可取。诸有智者能实观察。彼见实故而得解脱。又菩提心者最上真实。此真实义说名为空。亦名真如亦名实际。是即无相第一义谛。若不了知如是空义。当知彼非解脱分者。于轮回中是大愚痴。轮回行人六趣流转。若有智者能如实观彼菩提心与空相应。如是观已乃能成就利他智慧无碍无著。是即知恩报佛恩者。常以悲心普观众生父母眷属有种种相。烦恼猛火常所烧燃。使诸众生轮回生死。如所受苦念当代受。如和合乐念当普施。复观世间爱非爱果。善趣恶趣。饶益不饶益。随众生转。而诸众生本来无得。随智差别起种种相。所有梵王帝释护世天等。若天若人一切不离世间相故。又复观察所有地狱饿鬼畜生。是诸趣中一切众生。无量无数种类色相。不饶益苦常所随转。饥渴所逼。互相杀害互相食啖。因如是故不坏苦果。诸佛菩萨如实能观善趣恶趣一切众生诸业报事自相如是。如所观已起方便心。善护众生令离诸垢。诸菩萨由此以大悲心而为根本。以彼众生为所缘境。是故诸菩萨不着一切禅定乐味。不求自利所得果报。过声闻地不舍众生。修利他行发大菩提心。生大菩提芽求佛菩提果。以大悲心观众生苦。阿鼻地狱广阔无边。随诸业因苦报轮转。此种种罪受种种苦。菩萨悲心念欲代受。此种种苦有种种相。说无有实亦非无实。若了知空即知此法。随诸业果如是顺行。是故诸菩萨为欲救度诸众生故。起勇猛心入生死泥。虽处生死而无染着。犹如莲华清净无染。大悲为体不舍众生。空智所观不离烦恼。是故菩萨以方便力示生王宫。踰城出家苦行修道。坐菩提场成等正觉。现神通力破诸魔军。为度众生转大法轮。现三道宝阶从天下降起诸化相。随顺世间入大涅盘。于其中间现诸色相。或作梵王或为帝释。若天若人随诸相转。如是种种示现诸相。是故得名救世导师。此等皆是诸佛菩萨大悲愿力。调伏世间悉令安住相应胜行。是故于轮回中不生退倦。从一乘中说二乘法。一乘二乘皆真实义。若声闻菩提。若佛菩提。智身一相。三摩地一体。虽有所说是说非说。或有说为种种相者。但为引导诸众生故。若众生得利。而佛菩提福智平等。而实无有二相可住。若有住相即为种子。彼种子相聚类所生。是故增长生死芽茎。如佛世尊常所宣说。破彼世间种种行相。但为众生作诸方便。而实非破。若离分别比义甚深。甚深义中无有二相。虽说有破此亦非破。于空法中无有二相。诸法任持自性真实。智波罗蜜多是即菩提心。菩提心者除一切见。是故当知。诸身语心是无常法。但为众生作利益故。此中言空空而非断。此中说有有亦不常。是故无有生死亦无涅盘。而悉安住无住涅盘。诸佛世尊咸作是说。悲心所生无量福聚。彼即最上真实空理。诸佛威神之所出生。自利利他二行成就。我今顶礼彼一切性。我常尊敬彼菩提心。愿所称赞佛种不断。诸佛世尊常住世间。而菩提心者大乘中最胜。我于此心安住正念。又菩提心者。住等引心从方便生。若了是心生死平等。自利利他二行成就。又菩提心者。离诸见相。无分别智真实而转。诸有智者发菩提心。彼获福聚无量无边。又复若人于一刹那间。观想菩提心。彼获福聚不可称量。以菩提心非称量故。又菩提心宝清净无染。最大最胜最上第一。不能坏非所坏真实坚固。能破烦恼等一切魔。满诸菩萨普贤行愿。又菩提心者。是一切法之所归趣。所说真实离诸戏论。是即清净普贤行门。离一切相。此如是说

  我所称赞菩提心　　如二足尊正所说
  而菩提心最尊胜　　所获福聚亦无量
  我以此福施众生　　普愿速超三有海
  如理如实所称扬　　智者应当如是学

菩提心离相论


菩提行经

    No. 1662

菩提行经卷第一

        圣龙树菩萨集颂

        西天中印度惹烂驮啰国密林寺三藏明教大师赐紫沙门臣天息灾奉　诏译

    赞菩提心品第一

  如佛妙法体无边　　佛子正心归命礼
  佛甘露戒垂覆护　　我今赞说悉依法
  此说无有未曾有　　亦非自我而独专
  我无自他如是时　　乃自思惟观察作
  如是发心观察时　　能令我此善增长
  时见如是娑婆界　　此乃是彼佛世尊
  此界刹那难得生　　得生为人宜自庆
  思惟若离菩提心　　复次此来何以得
  如云覆蔽夜黑暗　　闪电光明刹那现
  佛威德利亦复然　　刹那发意人获福
  是故善少力虽劣　　能破大恶之业力
  如是若发菩提心　　此善勇进能超彼
  思惟无量无边劫　　见佛咸说此真实
  若不快乐得快乐　　增长救度无边众
  为诸有情处众苦　　令离百千诸苦怖
  受多快乐百千种　　为恒不离菩提心
  彼善逝子处缠盖　　行在轮回无所爱
  若刹那说菩提心　　人天欢喜悉归命
  若有受持不净像　　喻佛宝像而无价
  如药变化遍坚牢　　等修持妙菩提心
  菩提心宝验无边　　价直世间无可喻
  调御行人伴侣等　　悉使受持而坚牢
  芭蕉不实而生实　　生实芭蕉而身谢
  菩提心树而清净　　恒生胜果而不尽
  已作暴恶众罪业　　依菩提心刹那脱
  勇猛依托无大怖　　彼痴有情何不依
  譬如劫尽时大火　　刹那焚烧罪业薪
  若赞慈尊无量言　　是曰善哉之智者
  彼种种觉心　　正智而平等
  菩提誓愿心　　而行菩提行
  喻去者欲行　　彼之分别说
  智分别说已　　所行如智用
  菩提之愿心　　大果如轮回
  福故不间断　　亦如彼行意
  若彼等无边　　有情界解脱
  与彼心平等　　菩提愿不退
  彼等好睡眠　　亦复多迷醉
  间断于福流　　喻空无所有
  妙臂而问此　　劣意之有情
  于解脱得生　　为自为如来
  乃思惟疗除　　苦恼之有情
  使苦恼尽已　　获得无边福
  有情无边苦　　云何而疗治
  使一一安乐　　获无边功德
  何以利父母　　如是及眷属
  得天及仙人　　净行婆罗门
  如是彼有情　　乃过去睡梦
  不愿于自利　　唯愿生利他
  有情最胜宝　　希有何得生
  种种意利他　　不独于自利
  欢喜世间种　　精进世间药
  心宝与有福　　而彼云何说
  云何诸有情　　得一切快乐
  为发菩提心　　供养于如来
  迷爱乐快乐　　乃喻于冤嫌
  远离与随行　　悉从于自意
  若彼求快乐　　苦恼种无边
  积诸善快乐　　诸苦恼消除
  破坏迷惑因　　善哉云何得
  亲彼善知识　　彼福如是得
  作利若回向　　彼必返赞叹
  作善不求利　　说彼是菩萨
  若有布施于少食　　修善供养于世间
  所施大小如蚊蚋　　亦获快乐得半日
  云何获得于能仁　　要度无边有情尽
  有情无尽若虚空　　一切智求自圆满
  佛子静念而思惟　　若烦恼生自心作
  数生烦恼复生疑　　佛说此人堕地狱
  佛子若发菩提心　　灭大罪力得胜果
  我今归命摩尼心　　救度有情得快乐

    菩提行经菩提心施供养品第二

  端彼摩尼恭敬心　　用奉供养于如来
  及彼清净妙法宝　　佛功德海量无边
  世间所有诸妙花　　乃至妙果及汤药
  所有珍宝澄清水　　悉皆奉供而适意
  山中之宝及众宝　　适悦树林寂静处
  蔓花庄严树光明　　结果低垂枝[橠-多+可]橠
  人间天上香涂香　　乃至劫树及宝树
  池水清净复庄严　　鹅鸿好声极适意
  谷自然生非所种　　别别庄严而供养
  等虚空界量广大　　此一切有悉受用
  我今所献并子等　　供养最上佛牟尼
  为我不舍于大悲　　受彼最上之供养
  我以无福大贫穷　　更无纤毫别供养
  我今思惟为自他　　愿佛受斯随力施
  我自身施一切佛　　以自身等遍一切
  加被我作上有情　　有情恒常佛教化
  我得如来加被已　　化利有情无怖畏
  过去罪业悉远离　　未来众罪不复作
  宝光明处甚适悦　　天盖庄严奉真如
  水精清净复光明　　种种妙堂香浴作
  大宝瓶满盛香水　　复着适意诸妙花
  洗浴如来无垢身　　我当赞咏献歌乐
  清净香熏上妙衣　　用盖覆彼最上色
  我今献此上衣服　　愿佛慈悲哀纳受
  种种柔软妙天衣　　彼庄严中而最上
  供养如来并普贤　　及彼文殊观自在

    菩提行经护戒品第三

  持戒为护心　　护之使坚牢
  此心不能护　　云何能护戒
  喻醉象不降　　不患于疼痛
  放心如醉象　　当招阿鼻等
  念索常执持　　系缚于心象
  得离放逸怖　　获一切安乐
  若能系一心　　一切皆能系
  若自降一心　　一切自降伏
  师子熊虎狼　　夜叉罗刹等
  一切地狱卒　　皆悉是其冤
  若怖一切冤　　无边苦恼集
  皆因心所得　　佛世尊正说
  地狱众苦器　　及热铁丸等
  谁作复何生　　贪嗔痴所有
  由彼诸罪心　　佛生诸世间
  三界心灭故　　是故无怖畏
  若昔行檀施　　今世而不贫
  今贫勿烦恼　　过去云何悔
  若人心少分　　行檀波罗蜜
  是故说果报　　同一切布施
  若人心持戒　　嫌谁而牵杀
  嗔心之冤家　　杀尽等虚空
  大地量无边　　何皮而能盖
  履用皮少分　　随行处处覆
  外我性亦然　　所有谁能劝
  但劝于自心　　外我而自伏
  身贫而无福　　彼果同所行
  若心施一衣　　感果而增福
  诸行若修持　　心念恒不舍
  一切无利心　　虚假宜远离
  一切心法财　　宜秘密观察
  离苦获安乐　　彼得超世间
  我云何修行　　修行唯护心
  是故我观心　　恒时而作护
  喻猕猴身疮　　一心而将护
  人中恶如是　　恒常而护心
  怖苦恼之疮　　我一心常护
  破坏于众合　　心疮乃无怖
  常作如是行　　不行人中恶
  人中罪不犯　　自然而不怖
  我欲尽身命　　利行而供养
  别别身命尽　　善心而不退
  我欲守护心　　合掌今专作
  心念念之中　　一切方便护
  喻于重病人　　诸事不宁忍
  散乱心亦然　　不堪诸事业
  心散乱不定　　闻思惟观察
  如器之渗漏　　于水不能盛
  由多闻之人　　于信方便等
  过失心不定　　获不寂静罪
  心不决定故　　迷惑贼所得
  所有之福善　　偷堕于恶处
  烦恼众盗贼　　魔着故得便
  由魔罗发起　　破坏善生命
  守彼意根门　　恶不能牵去
  念彼罪苦恼　　次复获安住
  善哉随师教　　获得善念生
  奉于教诲师　　当一心供给
  于诸佛菩萨　　刹那心决定
  当怖畏忆念　　慈哀现面前
  尘心而不定　　去去不复还
  若能守意门　　护之住不散
  我今护此心　　恒常如是住
  喻木之无根　　不生恶枝叶
  眼观于色相　　知虚假不实
  物物恒谛观　　是故而不着
  因见而观察　　观之令不惑
  所来观见已　　安畏以善来
  欲行不知道　　望四方生怖
  决定知方已　　观心行亦然
  智者之所行　　思惟于前后
  是善是恶等　　如是事不失
  不住于此身　　离此复何作
  云何住此身　　当复观中间
  观内心亦然　　而用诸方便
  以法为大柱　　缚之令不脱
  当以如是意　　观我之所在
  诸识皆如是　　摄令刹那住
  若怖因业力　　能趣求快乐
  修彼檀戒度　　乃至大舍等
  若修菩提因　　彼别不思惟
  一向修自心　　当起如是见
  如是修诸善　　不起于怖畏
  而令诸烦恼　　决定不增长
  种种正言说　　见在而甚多
  观览悉决了　　破疑网得果
  如草被割截　　念佛戒能忍
  刹那行此行　　获得殊胜果
  欲于诸正说　　皆悉得通达
  当观照自心　　常修于精进
  喻木之无情　　无言无所作
  见自心亦然　　决定令如是
  心起于轻慢　　如彼迷醉人
  惟求自赞誉　　非彼修行者
  若他人于我　　而生于毁谤
  谓是嗔痴等　　住心恒似木
  如木不分别　　利养尊卑称
  亦不为眷属　　乃至承事等
  利他不自利　　但欲为一切
  是故说我心　　坚住恒如木
  一心住如木　　于尊亲朋友
  乃至于三业　　不生憎爱怖
  观察于烦恼　　如空而不着
  当勇猛坚牢　　受持为恒常
  无善惭可怖　　当一心求他
  清净住三昧　　为他所尊重
  虽居童稚位　　不使他嗔恼
  自亦不嗔他　　慈悲恒若此
  我受持禅那　　使意恒寂静
  为一切有情　　恒居无罪处
  念念须臾间　　多时为最胜
  如是受持心　　不动如须弥
  鹫贪肉不厌　　人贪善亦然
  身心不修行　　云何能出离
  云何护身意　　一切时自勤
  汝等何所行　　各各专一心
  迷愚不自制　　妄贪如木身
  此身不净作　　云何返爱恋
  骨锁肉连持　　外皮而庄饰
  自觉令不贪　　解脱于慧刃
  割截诸身分　　令见中精髓
  审观察思惟　　云何见有人
  一心如是观　　审谛不见人
  云何不净身　　贪爱而守护
  处胎食不净　　出胎饮血乳
  不如是食饮　　云何作此身
  豺鹫等贪食　　不分善与恶
  要同人爱身　　受用成业累
  但如是护身　　至死无慈忍
  与豺鹫无别　　汝何恒此作
  身死识不住　　衣食宁可留
  身谢识必往　　受用云何贪
  是故今作意　　不贪如是事
  如是不远离　　得彼诸不善
  如似人生身　　肢体求成就
  受身智不增　　轮还徒自困
  于世亲非亲　　悦颜先慰喻
  如是常自制　　心念恒不舍
  笑不得高声　　不戏掷坐具
  轻手击他门　　谛信恒自执
  如盗如猫鹭　　求事行无声
  修心亦如此　　当离于粗犷
  他人之所嫌　　无义利不说
  恒得诸弟子　　言上而尊爱
  一切所言说　　闻之使称善
  观彼作福事　　称赞令欢喜
  衷私说彼德　　彼闻心必喜
  欲赞说彼时　　先观彼德行
  修诸欢喜事　　难得彼诚心
  勤修利他德　　当受快乐报
  憎爱苦宜舍　　来生大苦故
  此苦我不住　　来生大快乐
  善言声柔软　　悲根闻生喜
  显彼适意事　　当信真实语
  恒悲念有情　　爱护如爱眼
  为彼住真实　　必当得成佛
  彼真实得成　　各此利朋友
  刹那修功德　　离苦大安乐
  功德殷勤修　　恒作而自得
  不炫不覆藏　　谁云诸事等
  檀波罗蜜等　　殊妙而最上
  别行非最上　　利下无远离
  佛如是利他　　恒常之所切
  如来之教中　　见彼慈悲事
  三界师入灭　　分别出家人
  食有可不可　　不离三衣等
  将求妙法身　　不苦恼众生
  于众生如是　　随意获圆满
  舍非须尽命　　彼舍要平等
  悲心当清净　　果报自圆满
  净心而重法　　不执器杖等
  不持伞盖头　　无诸轻慢事
  为男子女人　　说法深广大
  不分人胜劣　　令彼重平等
  法之不广大　　乃及非法行
  远离不敬礼　　乐说于大乘
  齿木及洟唾　　不弃于净地
  净水及净舍　　勿得弃便痢
  吃食勿满口　　食勿令有声
  食时不语言　　亦勿大开口
  坐不得垂足　　行亦不挑臂
  不与女同乘　　亦不同坐卧
  诸所不律事　　人见心不喜
  一切人既睹　　远离而不敬
  人问于道路　　不得一手指
  双手而指之　　示其道所至
  凡所诸行步　　不弄臂作声
  亦勿妄弹指　　威仪如是守
  师虽已化灭　　四仪应当学
  奉戒行不轻　　决定获圣果
  菩萨行无量　　所说无有边
  当以清净心　　决定而奉行
  于一昼一夜　　分之各三时
  行道普忏悔　　住佛菩提心
  菩提心自住　　亦令他获得
  佛子住学戒　　一心如是持
  佛戒体清净　　不见有纤毫
  恒作如是行　　彼福无有量
  无始为有情　　行行而不别
  如是为有情　　化令一切觉
  当知善知识　　如命不可舍
  菩萨戒最上　　大乘法亦尔
  解脱依师学　　而能生吉祥
  佛佛说智经　　读之见戒法
  若人心护戒　　所行悉已见
  若身若心位　　当微细观察
  口诵身不行　　当得何所喻
  譬如重病人　　空谈于药力
  虚空藏经中　　说谟罗波底
  如见集戒定　　广如经所说
  圣龙树菩萨　　一心之所集
  随所住之处　　劝恒伸供养

菩提行经卷第一菩提行经卷第二

        圣龙树菩萨集颂

        西天中印度惹烂驮啰国密林寺三藏明教大师赐紫沙门臣天息灾奉　诏译

    菩提心忍辱波罗蜜多品第四

  奉行诸善业　　施戒而先导
  供养于如来　　百千劫无尽
  修行于羼提　　嗔罪而不立
  观种种体空　　是故一心忍
  不得贪快乐　　守意令平等
  心有嗔恼病　　无睡恒不足
  彼此有施主　　供给于利养
  随彼爱重心　　无得生嗔恼
  凡诸亲近事　　不起于憎嫌
  于彼无所嗔　　乃得其安乐
  忍如是等事　　若对于冤家
  于嗔若能除　　世世获安乐
  冤若生于心　　于爱亦无喜
  若飱嗔恼食　　无忍善不坏
  彼食我大冤　　于我无善利
  知彼冤不食　　是故忍坚牢
  凡见冤来去　　欢喜而不嗔
  于冤若起嗔　　善利终灭尽
  忍心常若此　　令嗔不得起
  住忍无时节　　嗔冤自不生
  若人自保爱　　不作恶口业
  口业若不离　　后感冤家苦
  畏苦不出离　　不行众苦因
  是故坚忍心　　获得诸快乐
  彼讷陵誐子　　邪见求解脱
  刀割火烧身　　无利由能忍
  愚痴无正见　　虚受大苦恼
  我以菩提心　　云何苦不忍
  蚊蚤壁虱等　　常饥渴苦恼
  大痒烦苦人　　住忍而不见
  寒热并雨风　　病枷锁捶打
  被诸苦恼事　　忍不求快乐
  杀他血流迸　　坚牢心勇猛
  割身自见血　　怕怖而惊倒
  智者心清净　　常惧嗔恼侵
  与烦恼相持　　忍心恒勇猛
  蛇腹行在地　　喻嗔伏于心
  杀之谓无勇　　杀彼得最胜
  如来大悲者　　愍苦说轮回
  使识罪根本　　住忍而不作
  父母何计心　　惧子遭沦溺
  持心离嗔怒　　自远大苦报
  譬如无智人　　令罪而得生
  修行而无智　　嗔生亦复尔
  欲住不思议　　当须持自心
  于此生爱重　　令嗔不生起
  若贪彼尘境　　而生种种罪
  因彼诸业力　　而不得自由
  于境若不贪　　彼集无因立
  和合心无故　　是故无有生
  不贪而不生　　无得而自说
  我得如是故　　是生不思议
  彼无生不生　　是得云何有
  瞻察于彼此　　灭尽得无余
  此心恒清净　　喻随色摩尼
  所变悉从因　　无因相何有
  过去行行时　　彼行何所作
  随彼所行因　　等因而感果
  一切虽由因　　因善恶由心
  说求性寂静　　如是有何过
  若取和合因　　是乐于苦恼
  此心不可住　　智人应自劝
  是故见冤家　　想作善知识
  因行如是行　　当获得快乐
  如是诸有情　　由业不自在
  自在若成就　　谁肯趣于苦
  散乱心缘尘　　心被刺不觉
  食断食增嗔　　于苦而返爱
  自若无福行　　返爱缠缚业
  如飱毒药食　　堕于生死崖
  自住是烦恼　　诚由不自护
  欲解脱他人　　此事何由得
  烦恼迷昏浊　　而致于自杀
  毒盛无有悲　　云何嗔不护
  自性既愚迷　　于他行娆乱
  生彼嗔无疑　　如火而能烧
  有情性愚时　　所行诸过失
  愚迷故若此　　如烟熏虚空
  若人嗔不护　　愚迷无智故
  喻持杖劝人　　而增彼嗔恼
  我于过去生　　苦恼诸有情
  是故于今身　　被苦恼能忍
  我身喻于铁　　受彼烧锤锻
  如彼铁持身　　何得有其苦
  我今看此身　　如无情形像
  虽被诸苦恼　　而嗔无所起
  愚迷起爱业　　不知其苦本
  得苦缘自过　　云何生嗔恼
  喻受地狱苦　　飞禽剑林等
  知自业所生　　何处有嗔恼
  我得如是业　　此过知所起
  设令入地狱　　不由他所作
  欲尽我之业　　无量无有边
  我业既如是　　长时受地狱
  我此过如是　　彼实我冤家
  云何分别知　　愚迷嗔造作
  若人自护持　　对冤忍不恚
  是心功德生　　地狱云何入
  尽我之所行　　得因如彼时
  不忍嗔不护　　破坏于修行
  意无相无形　　散乱即破坏
  由身护持故　　身苦当忍受
  我于口恶业　　众过而不作
  身不被众苦　　云何心有嗔
  我于今生中　　净心行利行
  于利益既无　　何事于食饮
  凡所作为事　　要在于利他
  彼无利非爱　　定获罪无疑
  不如今殒没　　无贪邪寿命
  邪命住虽久　　死当堕苦趣
  譬如在梦中　　百年受快乐
  如真实得乐　　觉已知暂非
  喻彼时无常　　寿命之延促
  觉此二事已　　彼何得快乐
  久处于欢娱　　自谓得多益
  如行人被劫　　裸形复空手
  福利随过减　　罪根还复生
  福尽罪不生　　为获不嗔利
  彼何为活命　　一向作不善
  如是不思惟　　无善不破坏
  无得赞于嗔　　破坏有情故
  如是心利他　　彼嗔无由生
  为彼修心人　　于忍不住故
  见彼烦恼生　　是赞忍功德
  塔像妙法等　　有谤及破坏
  佛等无苦恼　　我于彼不嗔
  于师并眷属　　不作于爱业
  今因过去生　　见之而自勉
  觉心观有情　　恒在众苦恼
  见彼如是已　　于苦恼能忍
  嗔恚与愚痴　　分别过一等
  于此毒过咎　　何得说无过
  云何于过去　　而作害他业
  如是诸业因　　间断此何作
  如佛福亦然　　我今一心作
  与一切有情　　慈心互相睹
  喻火烧其舍　　舍中而火入
  舍中若有草　　彼火自延蔓
  如是还喻心　　和合于嗔火
  烧彼福功德　　刹那无所有
  若人杀在手　　放之善可称
  地狱苦能免　　此善谁不赞
  若人在世间　　少苦不能忍
  地狱苦无量　　嗔因何不断
  我以如是苦　　历百千地狱
  一一为利他　　所作不自为
  我无如是等　　诸大苦恼事
  以离世间故　　为利如是行
  离苦获快乐　　彼皆赞功德
  得彼如是赞　　云何而不喜
  彼既得如此　　无碍之快乐
  利他行最上　　智者何不勉
  如是最上行　　得快乐不修
  此见若不舍　　破坏于正见
  若敬爱于他　　以德而称赞
  他德既称赞　　乃是自敬爱
  当发菩提心　　为一切有情
  令得诸快乐　　云何嗔有情
  佛为三界供　　欲有情成佛
  世利得不实　　彼烦恼何作
  若人之骨肉　　乃及诸眷属
  养育与命等　　不喜嗔何生
  如彼求菩提　　当用菩提心
  而不爱有情　　福自舍何嗔
  若人有所求　　出财大舍施
  所求既不获　　不如财在舍
  清净功德福　　何障而不获
  得已自不受　　如住嗔修行
  作罪与作福　　不同不随喜
  亦复不依作　　当自一无得
  若爱于冤家　　欲求其欢喜
  复求诸赞说　　此事无因得
  虽欲利圆满　　返苦而无乐
  菩提心不忍　　于利不成就
  烦恼之恶钩　　牵人不自在
  由如地狱卒　　掷人入汤火
  我本求利他　　何要虚称赞
  无福无寿命　　无力无安乐
  自利行不圆　　智者应须觉
  后后而自行　　当爱乐圆满
  修行要称赞　　若持刃自杀
  如世不实事　　无益无利乐
  譬如破坏舍　　日照内外见
  亦由称赞非　　须用心明了
  汝思惟于声　　起灭而平等
  心如此利他　　当行如是行
  于他何所受　　而行于利益
  彼既获快乐　　我利益非虚
  彼彼获利乐　　以一切赞我
  云何而于我　　无别威德乐
  彼如是赞我　　以爱彼自得
  彼无缘若此　　如愚如迷者
  此赞我虽获　　速破而勿着
  憎恶正德者　　由此而嗔作
  是赞成障碍　　我令不发起
  护不堕恶趣　　为彼行无我
  若解诸有情　　利养尊卑缚
  令有情解脱　　彼意云何嗔
  若人欲舍苦　　来入解脱门
  此是佛威德　　云何我嗔彼
  此嗔我不作　　于福障碍故
  修行平等忍　　彼无不获得
  自身诸过失　　忍辱故不作
  过失不作故　　彼福而获得
  若人福无有　　安忍而自生
  常令安住忍　　云何说障碍
  世求利益人　　不于施作障
  障碍出家故　　是不得出家
  世间诸难得　　求者而能与
  我唯说善利　　于过无所得
  以彼菩提行　　远离于所冤
  如出舍中藏　　是故云不难
  忏悔于业因　　彼初为先导
  是故于忍果　　如是而得生
  彼无我所心　　此心乃住忍
  成就不思议　　供养于妙法
  此心为利他　　乃至以寿命
  或以冤不供　　云何别说忍
  于彼彼恶心　　各各与忍辱
  于如是得忍　　因供养妙法
  佛土众生土　　大牟尼说此
  于彼奉事多　　能感于富贵
  如来及于法　　与有情平等
  尊重于佛故　　尊有情亦然
  立意乃如是　　于自无所作
  以彼大平等　　平等于有情
  大意于有情　　慈心而供养
  发心如佛福　　如佛福可得
  是故佛法行　　佛有情平等
  佛无所平等　　功德海无边
  佛功德精纯　　无功德能比
  虽三界供养　　见之而不能
  佛法等之师　　是最上有情
  供养诸有情　　当如此作意
  于自之眷属　　不能起利行
  于他之奉事　　不作得何过
  破坏身入无间狱　　若彼作已我复作
  广大心为彼一切　　如是常行于善事
  喻世人为自在主　　由于己事不称情
  云何而为彼作子　　我作非彼奴仆性
  喻佛入苦而无苦　　如得快乐复欢喜
  要欢喜彼一切佛　　佛喜为彼能此作
  如身烦恼而普有　　欲一切乏悉充足
  于有情苦亦复然　　我无方便空悲愍
  是故此苦我远离　　救一切苦兴大悲
  先娆恼于忍辱人　　彼罪我今而忏悔
  我今奉事于如来　　同于世间诸仆从
  众人足蹈我顶上　　受之欢喜而同佛
  世间一切贱能作　　以悲愍故无有碍
  见此一切无比色　　彼如是尊谁不敬
  如是为奉于如来　　如是为自利成就
  如是为除世苦恼　　如是我今乃出家
  譬如一王人　　能调伏大众
  众非一能调　　以长亲王故
  彼一而非独　　盖有王之力
  制断不怯劣　　亦无有过失
  悲愍心住忍　　力若地狱卒
  将护于有情　　如事以恶王
  嗔非王所令　　如彼地狱苦
  烦恼于有情　　彼苦而自受
  喜非王所与　　如得于佛等
  善心于有情　　此心何不受
  将护于有情　　后当得成佛
  见感尊重称　　此善何不见
  无病复端严　　快乐而长命
  富贵作轮王　　斯皆从忍得

    菩提行经菩提心精进波罗蜜多品第五

  智者行忍辱　　菩提住精进
  懈怠远离福　　如离于风行
  精进力何解　　彼要分别说
  懈怠不精进　　如毒宜自观
  贪味于睡眠　　谓快乐无事
  轮回苦可嫌　　而从懈怠生
  烦恼之舍宅　　懈怠力牵入
  已到无常门　　云何今不知
  精进为自他　　此行汝不见
  懈怠复睡眠　　此如屠肆牛
  若此而不见　　一切道皆断
  彼既无所得　　云何乐睡眠
  若得于威仪　　无常而忽至
  施为不可及　　何以住懈怠
  精进而不修　　安然若精进
  忽然趣无常　　思惟而苦苦
  见彼焰魔门　　苦恼复情急
  刹那而泪下　　眷属不能救
  听闻地狱声　　自念业热恼
  身住不净处　　惊怖不能极
  地狱苦极恶　　恶业何复作
  如鱼鼎中活　　彼得如是怖
  地狱业作已　　乃受汤火苦
  身糜烂苦恼　　如何得清净
  魔王多苦人　　捉人送无常
  无常苦可畏　　此见懈怠果
  愚迷着睡眠　　此过而不劣
  入于大苦河　　复不得人身
  除乐最上法　　无边乐种子
  懈怠并戏笑　　苦因汝何乐
  见负嗔力多　　知彼自精进
  自他各所行　　如自他平等
  我何得菩提　　而无分别作
  以如来真实　　实言正解脱
  彼蚊蚋虻蝇　　及虫虾蚬等
  若获精进力　　亦当得菩提
  彼我何生人　　能知利不利
  恒知诸精进　　何不得菩提
  或舍于手足　　于此而生怖
  愚迷违师教　　此利彼不知
  断坏及烧煮　　无边皆拔出
  无数俱胝劫　　而未得菩提
  历此无数苦　　久久证菩提
  喻若毒苦伤　　毒尽苦皆出
  作一切医人　　救疗诸病苦
  是故苦消除　　一切病皆少
  是故说救疗　　甜药不利病
  上医疗大病　　甜药皆不与
  前后皆如是　　智者咸所行
  后后而进修　　身肉而舍用
  智者观身肉　　喻菜而生有
  枯谢弃粪土　　是舍不名难
  若身所作苦　　心谓其虚作
  智者心非恶　　彼无恶业苦
  知法意快乐　　具福身快乐
  无此虚轮回　　得苦云何悲
  求尽过去罪　　深利他福海
  此力菩提心　　二乘等要急
  如是利不乐　　行行何得苦
  菩提心辇舆　　智者乘得乐
  为成就有情　　乐施方便力
  身力苦怖作　　观之唯称赞
  断如是分别　　增长于精进
  我身而能舍　　超过身方便
  我消除自他　　无数之过失
  一一之过失　　若劫尽无余
  彼过一一尽　　我无有纤毫
  无边苦已脱　　我心云何损
  我求多功德　　为利于自他
  学一一功德　　劫尽学无尽
  纤毫之功德　　我生不曾作
  或当得生处　　虚度无所有
  我乐兴大供　　供养佛世尊
  为贫不能作　　而愿不圆满
  不施怖者安　　不修母快乐
  如入母胎藏　　母唯病苦恼
  过去为离法　　我今得果报
  所生既如是　　当行何法行
  一切善心根　　世间之牟尼
  彼根恒不退　　常得好果报
  烦恼苦缠绵　　而得种种怖
  于他爱障难　　生罪而自感
  若人于处处　　能起于善愿
  而感彼彼福　　获得供养果
  若人于处处　　作罪取快乐
  而感彼彼报　　获得苦器侵
  月藏中清凉　　广博妙香洁
  佛音味第一　　非修而不得
  而彼善逝子　　得解善逝法
  如莲出最上　　亦如仁觉月
  焰魔之狱卒　　牵引于罪魂
  火坑及洋铜　　烧煮悉皆入
  焰炽杀器杖　　断肉百千斤
  堕落热铁地　　斯由多不善
  是故心作善　　极微细观察
  依彼金刚幡　　修学而作观
  初学观和合　　不观汝非学
  而无最上名　　汝要回心作
  生中之所作　　增长于罪苦
  上事业不修　　彼下不求胜
  三种事应知　　由业烦恼力
  将来之恶因　　于此云何作
  世间之烦恼　　拘人不自由
  我如人不能　　是故我无作
  下业之所修　　云何令安住
  当观我无我　　而此我所作
  一滴之甘露　　鸟食变金翅
  我意谓微劣　　能脱少苦难
  嗔作无心难　　以不善罪故
  无心见发起　　广大胜难及
  是故清净心　　颂作此文句
  使知彼三界　　我远离戏论
  我得胜一切　　无人能胜我
  我今而自知　　是佛师子子
  有情离我人　　而彼得最上
  不降懈怠冤　　懈怠冤自降
  以恶趣所牵　　身善速破坏
  由仆从愚恶　　寄食而受瘦
  彼受于一切　　修行住我慢
  而此得名声　　下劣云何说
  如是若勇猛　　自胜彼冤家
  勇猛行此修　　慢冤而不胜
  彼慢心若起　　此实我冤家
  胜果虽欲生　　是果悉皆舍
  喻精进师子　　烦恼兽中见
  烦恼兽千万　　虽众不能敌
  世有大苦恼　　人自悉具见
  烦恼不降伏　　乃得如是苦
  我宁使头落　　及刳剔心肠
  烦恼诸冤家　　一切我不降
  因修此精进　　得彼慢业尽
  获得胜果报　　自感嬉戏乐
  为快乐修因　　彼却不获得
  所修不决定　　亦得不殊胜
  轮回欲不足　　喻贪刀刃蜜
  福甘露若贪　　食之后转美
  是故业寂静　　感妙果随行
  如日温月寒　　昼夜而相逐
  精进之有力　　能破于懈怠
  获得远离故　　深心而爱乐
  烦恼棒坚牢　　斗彼念慧剑
  喻棒剑相持　　同彼女人学
  执剑手无力　　失之而怖急
  念剑失亦然　　地狱而在心
  世间知善人　　不肯饮毒血
  心过亦复然　　心过而不作
  出家精进心　　喻执持油钵
  钵坠必当死　　坠之故惊怖
  着睡眠懈怠　　喻毒蛇在怀
  不去当被伤　　去之宜须急
  一一之深过　　要回心思惟
  此过不可守　　云何我复作
  和合之业因　　断以正念剑
  云何名自位　　此念而获得
  正念心不发　　纤毫不能灭
  来业如往行　　一切报皆得
  如彼睹罗绵　　随风而来往
  精进人亦然　　增上如是得

菩提行经卷第二菩提行经卷第三

        圣龙树菩萨集颂

        西天中印度惹烂驮啰国密林寺三藏明教大师赐紫沙门臣天息灾奉　诏译

    菩提心静虑般若波罗蜜多品第六

  佛喜精进增　　安住禅定意
  愍彼散心人　　烦恼芽间住
  我今知身心　　不生于散乱
  是故远世间　　亦远离疑惑
  利益行可爱　　爱不离世间
  智者乃思惟　　是故此皆舍
  依于奢摩他　　尾钵奢曩等
  如是而起行　　破坏于烦恼
  先求奢摩他　　不藉世间行
  无常而恒有　　于爱何得要
  若见于千生　　不复起爱着
  不乐尾钵舍　　亦不住等持
  见已不止足　　是患过去渴
  如实而不见　　安得尽烦恼
  意缘于爱集　　被烦恼烧然
  思惟彼下堕　　短命须臾住
  善友不长久　　坚固法不成
  行与愚迷同　　决定堕恶趣
  何得同愚迷　　以毒分牵故
  而于自眷属　　刹那获怨恨
  凡夫性异生　　喜怒而无定
  多嗔承事难　　远离于善利
  下劣心自赞　　缚着憎爱罪
  彼不舍于嗔　　当堕于恶趣
  迷愚不摄心　　为此无功德
  自赞毁谤他　　轮回乐自得
  愚迷之所持　　住是等不善
  不善不和合　　彼事皆获得
  一身我所乐　　而意无所贪
  远离于愚迷　　当得爱承事
  不为于赞叹　　住于何善事
  略如蜂造蜜　　寂静得成就
  我行一切处　　如未曾有者
  恒得于多人　　赞叹而敬爱
  若迷于处处　　得意乐快乐
  以此于世间　　得生死怖畏
  是故彼智者　　怖畏于生死
  知千种苦恼　　住之决定受
  若于刹那顷　　自修于精进
  获得好名称　　亦复多利养
  以彼同利人　　毁我非功德
  若此加毁谤　　我谓赞欢喜
  虽毁谤不嗔　　称赞亦不喜
  谓佛及有情　　种种皆如是
  称赞得功德　　毁谤招苦报
  世间不思惟　　是谓愚痴故
  自性苦同住　　彼生何所乐
  愚迷非朋友　　此乃如来说
  若在于愚迷　　自利无不爱
  若入利他门　　如是为自爱
  不毁于有情　　不一心承奉
  损于利物行　　如烦恼坏善
  如彼天宫殿　　及于树根舍
  随彼爱乐心　　从意得为上
  自性之广大　　斯为无碍处
  彼所未曾见　　亦不能观察
  富贵喻坯器　　虽成不坚牢
  受用然自由　　苦恼而速至
  如盗他人衣　　分之着身上
  行住不自在　　苦恼当求离
  称量于自身　　彼实苦恼法
  我此如是身　　是身必当坏
  观察于此身　　性与身相离
  性然无所坏　　身当为豺食
  一生定一死　　有情界如是
  彼复见何事　　诸大各分去
  如人远路行　　欲及于住舍
  忧苦彼别无　　唯求无障碍
  喻轮回亦然　　咸受于生住
  直至于四人　　彼方获远离
  如是之一身　　冤家所不赞
  直至如是成　　不厌患世间
  过去世间时　　生死无悔恨
  所行行不近　　能离世间苦
  念佛心口同　　无有人嫌毁
  是故身意调　　寂静无烦扰
  如是我恒行　　灭尽诸烦恼
  解脱于自心　　复解脱一切
  得此心平等　　于今世后世
  断彼苦恼缚　　乃至地狱等
  若有男女等　　合掌多恭敬
  善利非算数　　无罪可称说
  有善用自金　　远离弃掷怖
  此行若能行　　得最上寂静
  彼人有此获　　我自得无异
  明了如是行　　何不趣寂静
  一心住贪爱　　此为下趣牵
  业感焰魔门　　前见见可怖
  彼门是汝冤　　烦恼今不同
  分明住贪爱　　今见何能脱
  过咎自藏护　　一一他眼见
  彼今所食啖　　妒忌何不护
  飞鹫常所贪　　唯爱此肥肉
  复以血庄严　　此食偏所重
  喻见鬼形容　　枯瘦及行动
  相貌既如是　　睹之堪可怖
  口吻及牙涎　　皆从不净生
  不净非所堪　　食饮彼何爱
  睹罗绵藏触　　细滑乐嬉戏
  臭秽岂不漏　　欲者心自迷
  此贪谓若盖　　迷者坚乐着
  无著即无事　　云何而不离
  衰老相随生　　肉泥加饰染
  不识彼空幻　　而复乐歍吻
  如袋不净满　　迷人不思惟
  不净如是多　　彼汝何喜行
  身肉非净成　　愚智而皆见
  自性元无心　　云何妄爱肉
  若彼无爱心　　是得分明见
  若能无彼此　　自不见歍吻
  别有非不净　　而自不希有
  如是不自净　　彼汝非希有
  愚迷不净心　　体喻于莲花
  慧日照开敷　　非净身何爱
  不净今无常　　染爱今不正
  欲出正净身　　云何由染爱
  云何歍吻他　　由贪彼不净
  于彼不净地　　种子生增长
  汝受不净身　　此身唯虫聚
  是身既非净　　非净不可爱
  不净而不一　　而汝自不嫌
  无别不净器　　此器孰多爱
  龙脑香米等　　食饮而适悦
  入口味最上　　是地合清净
  若此甚分明　　彼不净不离
  秽恶弃尸林　　是身同若此
  皮剥肉溃烂　　见之得大怖
  既能知彼已　　复何生爱乐
  白檀香复洁　　身无如是妙
  云何殊胜香　　用心而别爱
  自性臭若贪　　不乐于寂静
  亦于法诸香　　一切皆染污
  若复发甲长　　牙齿兼垢黑
  垢腻之所持　　恶性身裸露
  狂乱自痴迷　　欲用行大地
  复持诸器仗　　一心待自杀
  寒林枯骨形　　见乃发恶声
  聚落枯骨动　　迷人返爱乐
  不净乃如是　　此苦为彼爱
  如彼那落中　　无苦痛不受
  少年贪受乐　　不求胜善力
  少年如不求　　老至欲何作
  如彼日将落　　为作困不就
  复如鹿兽群　　至夜空还去
  锡杖钵随行　　在路而困苦
  如犊随母行　　无所畏亦尔
  若自为欲迷　　自卖为仆从
  彼不得自在　　亦复随业牵
  如女产林野　　如战命难保
  迷者为欲诳　　恃我感奴仆
  断欲者心净　　于苦能审察
  见彼欲火烧　　复若毒枪刺
  迷人求欲境　　喜获妄守护
  无利事无边　　清净皆破坏
  世间虚幻财　　愚人忙忙贪
  轮回往来苦　　解脱于何时
  如是贪欲味　　欲者受不少
  喻牛牵重车　　至彼口无草
  欲味与无草　　见者人难得
  见已破知非　　刹那觉希有
  而身为作此　　一切时疲倦
  胜定业不修　　必当堕地狱
  彼百俱胝劫　　分受困不觉
  彼行大苦苦　　不为求菩提
  无器仗毒火　　无山崖冤等
  离欲者若此　　说离地狱苦
  远离如是欲　　生爱乐分别
  爱乐非空处　　而诤善林地
  善财月光明　　白檀凉香洁
  广宝楼阁间　　行住甚适悦
  善林声不闹　　清净风长扇
  彼处而寂静　　思惟心爽利
  若处何可亲　　空舍岩树下
  舍爱离烦恼　　自在护根识
  是处主宰无　　自在随行住
  欢喜爱快乐　　何推帝释天
  观功德智慧　　如是等诸法
  复正菩提心　　消除于疑惑
  先当如是观　　重自他不二
  我自一切行　　苦乐亦平等
  手作多种事　　守护如一身
  世坏不坏法　　苦乐等亦尔
  如己之别苦　　一一皆消尽
  如是我受持　　为于有情等
  我若爱于他　　令得平等乐
  彼得快乐已　　于自胜何夺
  我若不爱他　　彼得诸苦怖
  彼苦怖不脱　　于自当何胜
  苦害令若得　　而由不爱护
  未来苦害身　　云何而可护
  我若住邪见　　复起于我慢
  如是别得生　　如是别得死
  作罪不作罪　　如彼手与足
  手足苦不同　　云何同说护
  以此知不合　　心住于我慢
  是合当尽断　　彼自宜随力
  种子集次第　　排行若军伍
  若此而无苦　　彼不知何得
  苦本非主宰　　世一切不胜
  若住于尸罗　　是苦不能立
  若住戒清净　　能障一切苦
  一切苦无因　　诸苦而无有
  悲苦云何多　　何力而能生
  思惟于世间　　是故悲苦多
  一苦而非多　　见有情获得
  悲苦如是生　　于自他平等
  自苦不消除　　欲消除他苦
  是故妙人月　　说彼有情句
  善者如是观　　他苦平等护
  设在无间中　　如鹅游莲池
  为解脱有情　　彼若欢喜海
  如是恒不足　　如彼解脱味
  作是利他日　　无我无有疑
  利他无所求　　果报谁云爱
  是故我如此　　无德而自谓
  悲心与护心　　为他如是起
  智者细微知　　输羯罗血等
  智者得了此　　观察物不实
  是身非别作　　何以自不知
  以自知他身　　如是故不难
  自知己有过　　不知他功德
  自性不乐舍　　徒观察他施
  此身之和合　　因缘如拍手
  此是世间缘　　有情何不知
  云何学无生　　如学而自知
  自身而非身　　以自如他身
  如是而利他　　作已不疑虑
  果熟而自受　　当获彼无生
  是故世间学　　悲心与护心
  此爱心自蔽　　深重如烦恼
  知有情怖畏　　为师而示学
  若能如是学　　虽难而不退
  沙门见怖畏　　彼无得护者
  若自及与他　　急速而当救
  嗔如冤怖多　　无爱怖获少
  以最上秘密　　自他转行利
  水陆与飞空　　勿令人住杀
  由若于今时　　救度于饥渴
  若人为财利　　杀父毁三宝
  见世恶庄严　　死得阿鼻财
  何有于智者　　见爱而供养
  见冤不欲睹　　供养云何说
  斯鬼而自利　　舍之而何受
  利他而不生　　云何舍受用
  以自利害他　　地狱而别生
  自害而利他　　诸功德具足
  作意善逝见　　如是行别处
  下劣不自爱　　愚痴投恶趣
  自利知微细　　今当堕奴仆
  利他微细知　　当为自在主
  世有诸苦者　　昔自迷贪爱
  世诸快乐者　　于他昔利乐
  何要多种说　　此中间已见
  愚迷乐自为　　牟尼利他作
  不求佛菩提　　轮回何得乐
  自苦欲与他　　回转无由得
  观察于后世　　善利不成就
  于奴仆起业　　主者而返受
  互相之利乐　　迷者见而离
  而返互相苦　　当受恶苦报
  若得世间灾　　乃至惊怖苦
  彼一切自作　　云何而此作
  不能舍自身　　于苦不能离
  如不离于火　　不能远烧害
  自苦若能除　　能消除他苦
  以彼自他受　　是故而取喻
  汝今无别思　　利益诸有情
  汝决定作意　　因业有分别
  眼以见为能　　所观不为眼
  手以执为用　　所持宁为手
  但为诸有情　　亦不住身见
  离见乃善逝　　常行如是利
  见彼下品人　　而起自他见
  虽观彼憎爱　　我心不疑惑
  作此善无我　　获得无我我
  大毁及赞叹　　无苦亦无乐
  我所作业因　　获彼善安住
  谦下世最上　　无德乃有德
  以彼德不称　　一切德自有
  谦下而若此　　胜我由斯得
  离戒见烦恼　　由得无我力
  如医诸病人　　随药力痊差
  我如是救疗　　自见而云何
  然自有功德　　彼德我无住
  地狱之恶门　　于彼愁不生
  以有功德故　　斯乃为智者
  若自平等观　　利益自增长
  自利分尊卑　　斗诤而成就
  此一切世间　　谁得见功德
  若此功德名　　不闻此人得
  罪盖覆心宝　　是不自供养
  于自利益分　　而总不获得
  有见而暂喜　　久久必不喜
  如是一切人　　哂笑而毁訾
  下劣心我慢　　自胜嫌人同
  夸智慧颜容　　种族财富等
  以此为自德　　常欲闻称赞
  闻赞生胜心　　欢喜而得乐
  以此为得利　　自谓功德力
  宿造纤毫因　　得此不正业
  尽此少报已　　永在于轮回
  如是轮回中　　受彼百千苦
  过于无边劫　　不知其出离
  被苦常大困　　罪心而不觉
  如是不知觉　　久久发善种
  后见如来言　　真实得功德
  汝若见过去　　不受彼恶业
  菩提正快乐　　此乐不得离
  是故而取喻　　彼输揭罗等
  汝云何更作　　我慢及不善
  诸行及己身　　观之而不见
  获得如是离　　利他汝常行
  自乐而苦他　　此行乃下劣
  汝自之一心　　于他作憎爱
  中间忽思惟　　何时何此作
  乃自舍快乐　　他苦亦不行
  宁自落其头　　更不造别过
  乃至于小过　　此大牟尼说
  以别胜善等　　于他暗称赞
  喻仆人事主　　当事于有情
  彼住于过失　　无定无功德
  自如不知人　　作此功德意
  汝若紧迅作　　自为及为他
  彼紧迅若此　　必苦恼自退
  此修乃第一　　而未得其力
  喻新住威仪　　以财而惊怖
  如此受持身　　降心不散乱
  汝当如是住　　汝此何不作
  以是常观察　　妄心令不起
  如此调伏我　　息一切过失
  见我去何处　　无明一切坏
  同彼过去时　　如汝之坏我
  自利我今有　　此远离不远
  如人卖于他　　苦多不自在
  汝有情不与　　虽名不散乱
  是故如以人　　付狱卒不殊
  狱中种种事　　被害亦长久
  此得为自利　　怨念彼不生
  不作于自爱　　而自爱得有
  若见自护持　　护持不实故
  此身乃如如　　而作于守护
  得上品柔软　　到此亦复然
  若此而得到　　如地一切受
  若不能圆满　　何人求用意
  爱心之烦恼　　而不能破得
  如彼久富贵　　不能求一切
  若贪于他物　　不受于贤名
  是故求增胜　　身心不放逸
  彼爱终灭尽　　此动此不觉
  诸恶不净身　　此我云何执
  我此身云何　　虽活而必死
  与土而无异　　我见何不破
  为此不实身　　虚受于苦恼
  何更于无情　　复起于嗔怒
  我今徒育养　　终为豺鹫食
  至此无爱嗔　　彼爱何能立
  若彼住嗔怒　　当欢喜供养
  彼如是不知　　何为作辛苦
  我今爱此身　　乃为我所亲
  一切爱自身　　云何我不爱
  是故我舍身　　为舍于世间
  观此多过咎　　喻如持业器
  彼业世间行　　我去而随身
  静念不散乱　　当断于无明
  是故破烦恼　　我处于禅定
  邪道不牵心　　自名最上住

菩提行经卷第三菩提行经卷第四

        圣龙树菩萨集颂

        西天中印度惹烂驮啰国密林寺三藏明教大师赐紫沙门臣天息灾奉　诏译

    菩提心般若波罗蜜多品第七

  如来智慧仁　　为一切世间
  令求远离苦　　是故智慧生
  真如及世间　　今说此二法
  知佛真如故　　说法而智慧
  彼世间凡夫　　见二种相应
  害及胜害等　　乃世相应事
  彼二事见已　　见之乃为智
  智见世间性　　是喻于真如
  此说无去来　　智者无不见
  色等甚分明　　乃世相应事
  不净而为净　　智者喻有利
  为知世间故　　是说世间性
  为见于真如　　见以刹那住
  世间行相应　　此行无过失
  知女人不净　　异世诸害事
  谓佛福虚幻　　使我云何信
  有情若幻境　　云何复生灭
  彼因集和合　　乃得于幻缘
  有情种子生　　云何有真实
  杀彼虚幻人　　无心性等罪
  平等心虚幻　　罪福得生起
  真言力等持　　幻境心无著
  以彼种种幻　　种种因业生
  何有于一人　　得于一切力
  若住于真如　　或住于净戒
  如是即佛行　　谁云菩提行
  因缘当断尽　　幻化不可得
  因缘若断尽　　无生而自得
  若不住疑妄　　幻境而不立
  幻境若彼无　　一切不可得
  如是即真如　　得现于心体
  心如是若分　　虚幻何由见
  心不自见心　　世尊之所说
  如剑刃虽利　　虽利不自断
  自性由若斯　　复喻如灯光
  破闇然得名　　而不云自照
  又若水精珠　　体本唯清澈
  因青而有青　　影现随众色
  非青而现青　　如心而自作
  又如彼灯光　　智者知此说
  智慧此开通　　知者何所说
  虽开而不开　　如人无所睹
  石女义不生　　与此义不二
  亦同无心识　　缘念无所得
  非念而别生　　虚妄念如毒
  谓若因若果　　为法而自说
  有谈眼药方　　见瓶而无药
  若见闻觉知　　此有而非有
  念断于苦因　　此实念当念
  念念而无别　　此心当平等
  前尘常惑人　　了之无所有
  如幻而不实　　妄心而自见
  住尘处轮回　　喻空无所依
  住尘性亦然　　亦无有所得
  若与不善俱　　不善汝所得
  若心有取舍　　施一切如来
  如是用心意　　而有何功德
  幻境一切知　　烦恼云何断
  于彼幻三毒　　远离而不作
  知于烦恼心　　彼作而未尽
  于彼得见时　　空有意无力
  烦恼性非尽　　与空而相杂
  至彼无所学　　彼后乃得尽
  彼性而无得　　亦复不能见
  彼性若无住　　云何住此身
  若性而无有　　身住于无性
  是性如去来　　随现而无著
  劫树与摩尼　　能如意圆满
  佛变化亦然　　当为斯行愿
  喻法咒林树　　咒成而枯坏
  毒等虽久害　　彼彼皆消除
  菩萨之修行　　所作诸事业
  菩提行最胜　　佛树能成就
  以彼平等行　　而住于寂静
  及作不思议　　供养得何果
  随彼所行因　　而得于彼果
  供养等真实　　得果而称实
  云何得法空　　实得解脱法
  不离牟尼道　　当得于菩提
  汝不求大乘　　何法求圆满
  二乘得成就　　成就非圆满
  若彼所作因　　怖畏于大乘
  别怖怖非实　　此怖实名怖
  此法要当知　　大乘之所论
  离此为他法　　知彼外道论
  法乃僧根本　　僧知法出离
  心若有着处　　涅槃不可得
  解脱心无著　　烦恼得消灭
  烦恼业消除　　斯由解脱力
  爱取不相缘　　以此无执持
  爱业而羸劣　　是无有痴爱
  受爱得相缘　　此受而有得
  安住有着心　　是得名处处
  若心之不空　　复得名为着
  心性若云空　　如识而无得
  如应正等觉　　所说之妙法
  是义乃大乘　　大乘行平等
  说法之一时　　了一切过患
  一味之平等　　诸佛无不说
  迦叶大尊者　　如言之不知
  彼汝云不觉　　不受当何作
  解脱力若怖　　轮回得成就
  迷彼苦空事　　而得于此果
  迷空彼若此　　不得谤于法
  此空审观察　　是故得不疑
  离闇知烦恼　　因法知于空
  欲速一切知　　彼言审观察
  若物生于苦　　是苦怖得生
  彼苦因空作　　彼何得生怖
  若于彼物怖　　斯即名我所
  如是我无所　　苦怖云何得
  牙齿发爪甲　　骨肉并血髓
  鼻洟唾脓涎　　脂肪及肠胃
  便痢汗热风　　九漏并六识
  如是诸法等　　一切皆无我
  说彼智与声　　声恒受一切
  若说声智离　　彼离云何知
  若智之不知　　彼智难知故
  彼智既决定　　乃近于智智
  此智非声受　　彼声何以闻
  彼声近于心　　彼知色如是
  若受于色声　　而色复何受
  如彼一父子　　思惟无真实
  有情尘所翳　　无父亦无子
  知声色如是　　亦无于自性
  彼色如是知　　喻乐暂和合
  彼自性如是　　彼一而言有
  余色咸不实　　此说色下品
  彼一切智心　　烦恼悉清净
  思惟一觉心　　彼等彼若无
  爱若虚不实　　云何住于见
  无我而无心　　此心喻画像
  是心智相应　　清净愚痴破
  如是之自心　　彼作云何作
  彼愚痴无行　　此我而虚作
  有行自出离　　而无恶业果
  破坏业若为　　善果云何得
  此二之行果　　互相破成就
  彼说知不虚　　彼自而无事
  因果定相应　　恶见要不生
  此行而实住　　作受今当说
  过去未来心　　彼我无有生
  此心生我破　　我无复生起
  如芭蕉作柱　　无所能胜任
  我心生亦然　　是得善观察
  有情若不有　　此行云何为
  彼行今若为　　而为有痴事
  有情何实无　　痴喻其爱事
  若灭于苦恼　　当断于痴事
  我慢为苦因　　痴是得增长
  彼事心不回　　观空为最上
  无足无胫膝　　无腰复无腿
  无臂亦无肩　　无脐无胸背
  无肋兼无胁　　无手亦无鼻
  无项复无头　　骨锁等皆尔
  观此一切身　　不行于一处
  彼行于处处　　何处自安住
  以彼身手等　　一切处皆住
  彼一身如是　　乃至于手等
  无内无外身　　何独身手等
  手等无分别　　云何彼复有
  彼既无痴身　　宁云意手等
  住已近殊胜　　观者知人喻
  若彼因和合　　木人此可同
  若了如是相　　彼身同此见
  如是舍足指　　手指亦皆舍
  彼初观节合　　后见节自离
  此身破已竟　　彼住分别见
  分别见此身　　得喻如虚空
  如是之梦色　　智者何所乐
  设施若无身　　何有男女等
  若喜真得苦　　此者何不解
  观察此云何　　爱乐深烦恼
  乐者之不实　　如彼无执受
  汝苦复云何　　如彼自无得
  彼有苦微细　　既微而不说
  以彼微细故　　不说令他喜
  因嗔而苦生　　既生而有灭
  若于定有见　　于生自不受
  如是而既知　　如是观因果
  禅爱或相应　　得生彼疑地
  善根之所利　　皆为于何人
  彼此何和合　　和合而何得
  人喻于虚空　　虽合而无入
  无入而非合　　是无分别行
  不求和合名　　若见而无见
  和合彼不求　　云何名得生
  有物非和合　　如导而先知
  而彼识无相　　不住于和合
  彼触法如是　　何受而得生
  我今何所为　　而得于苦害
  若不得所受　　苦害而不觉
  此位彼得见　　何爱不远离
  今见此梦触　　自心之幻化
  既见彼触性　　彼受汝亦得
  先世与后世　　念念而无受
  若此观自身　　受亦无所得
  所受既不实　　彼即知无有
  若此无自身　　云何如是害
  色性之自住　　无根无中间
  无内无外色　　别处亦不得
  身若无异处　　无合无分别
  有情之自性　　寂静彼无所
  智者若先知　　云何而有着
  智者同智故　　彼生何得着
  是智是后得　　是智云何得
  如是一切法　　虽生而无得
  如是法若无　　是法云何二
  彼余法若是　　有情皆寂静
  彼他心有疑　　于自即无有
  彼定彼后有　　此法无彼此
  思惟于自心　　是二互相住
  如得于正住　　一切智者说
  若有诸智者　　获得于智智
  智者得是智　　彼即是无位
  智者得是智　　有得而无住
  无住即无生　　彼说于涅槃
  若彼之二法　　如是极难住
  若法由于智　　智者何因有
  是智由于知　　知者无所得
  二法互相由　　是有情无性
  无父定无子　　欲子生何得
  有父而有子　　彼二法亦尔
  芽从种子生　　种子得何求
  知从智所生　　彼实何不行
  芽从智种生　　知从智芽有
  若彼知不知　　何得有智智
  一切人因缘　　彼前皆已说
  因果所生起　　等喻如莲花
  因果何由作　　皆从于过去
  此果云何得　　由过去业力
  世间因自在　　自在彼何说
  如是得后有　　彼彼名何杂
  是事唯不定　　非心非贤圣
  过恶无善报　　彼何得自在
  不见如虚空　　不见自过去
  自在不思议　　此理不应说
  彼主何最上　　彼亦自无定
  善恶各自性　　智者知无边
  因业有苦乐　　彼说何等作
  先因若不有　　果报谁云得
  云何不作恒　　彼无于别见
  彼作既无别　　何得见彼彼
  若见和合因　　无复云自在
  此和合无主　　彼法乃无主
  彼爱不自爱　　此爱而无作
  所得而由他　　何云自在作
  彼不作过去　　谓若恒不灭
  爱此最上数　　谓世间恒常
  有情尘闇蔽　　住此恶功德
  谓此说最上　　此说世间恶
  一三之自性　　不合而无有
  是德无所有　　彼各各三种
  功德虽无声　　此声有还远
  如衣等无心　　由此生快乐
  色性之亦然　　观之性无有
  彼等快乐因　　有无若衣等
  此衣等快乐　　此乃性快乐
  彼等之快乐　　不能得久远
  彼得是微细　　云何彼粗细
  快乐如是实　　思惟何不受
  离粗得微细　　微细不久远
  一切物亦然　　久远何不得
  快乐得不粗　　快乐不常定
  彼无有所生　　此说不真实
  彼真实德生　　彼得无欲住
  为食不净食　　而有于因果
  爱无价之衣　　买睹罗种子
  不爱世间痴　　彼住真如智
  彼智世间有　　云何而不见
  同彼世间量　　若此分明见
  世量而非量　　彼无妄言说
  是故观真如　　彼空而不生
  知性之不触　　是性而无执
  彼性实非实　　是故非实性
  是故彼梦觉　　此疑彼无有
  彼性若见有　　乃不实生者
  是故知彼性　　无因即无所
  一切皆无主　　因缘中安住
  由彼无别异　　不住复不去
  于实彼若迷　　返为世间胜
  为从因所生　　为从幻化作
  何来彼何去　　了知而若此
  若此而了知　　乃见彼无性
  云何知假实　　同于影像等
  性若云自有　　是因何所立
  彼若是不有　　彼因故不用
  有无之性相　　因俱胝百千
  彼位云何性　　何得于别性
  彼性无性时　　是性何时得
  无性即无生　　当依彼性行
  性无过去性　　而由性不生
  无有性无性　　喻幻化和合
  一切有无性　　有如是不灭
  此一切世间　　是故不生灭
  知行空不实　　喻梦喻芭蕉
  分别灭不灭　　一切不可得
  性空乃如是　　何得而何受
  不实恒若斯　　彼彼云何得
  何苦何快乐　　何爱何不爱
  彼爱何所爱　　要当知自性
  世间亦可知　　何名为无上
  何人何所亲　　何生而何得
  一切喻虚空　　彼此受皆失
  欢喜嗔相对　　因喜或斗诤
  嗔恼诸邪行　　一切令破坏
  罪恶自爱乐　　是得恶趣名
  死即堕恶趣　　得苦而无悔
  或往来天中　　生生而得乐
  舍于多罪崖　　谓真实如是
  如是真无性　　复互相憎爱
  说彼将来恶　　溺无边苦海
  色力并寿命　　彼得而唯少
  虽获于快乐　　而由饥困者
  眠睡灾昏迷　　如虚幻和合
  当尽彼虚幻　　若此而难得
  彼学何所作　　何行何断除
  彼彼诸魔事　　斯为大罪崖
  于彼多正道　　难胜而不行
  复于刹那中　　难得生觉悟
  过去未来苦　　难竭烦恼海
  而于此苦海　　我恨苦求离
  如是此安住　　若自不乐住
  如须臾须臾　　入火而澡浴
  见如是自利　　而受于此苦
  无老死自在　　彼行因如是
  从彼恶法来　　感恶而前死
  苦火热如是　　我何时得息
  自作于快乐　　福云生缭绕
  以我何见知　　而说知慧空
  稽首具足知　　稽首福德重

    菩提行经菩提心回向品第八

  菩提行若此　　思惟于行福
  菩提行庄严　　一切人皆得
  乃至一切处　　身心苦恼者
  彼得此妙福　　欢喜快乐海
  若有不自在　　而处轮回者
  使得世间乐　　及得菩提乐
  若有世界中　　乃至于地狱
  而令彼等人　　悉受极快乐
  寒苦得温暖　　热苦得清凉
  菩萨大云覆　　复浴法水海
  铁树铁山峰　　剑林光闪烁
  一切成劫树　　罪人喜安乐
  喻迦那摩．迦啰拏　　鸳鸯鹅雁声适悦
  池沼清净无浊秽　　微妙诸香生喜乐
  地狱炉炭聚　　而得摩尼聚
  热地水精严　　复宝山和合
  以如是供养　　善逝宫皆满
  炭火热剑雨　　今后洒花雨
  彼剑互相杀　　今后花互散
  烂捣诸身肉　　喻君那花色
  肉骨与火同　　弃堕奈河水
  以我善力故　　令得天宫殿
  彼光如千日　　彼满那枳儞
  焰魔之狱卒　　见者不惊怖
  乌鹫等飞类　　悉离恶食苦
  爱彼普快乐　　此得何善生
  福喻于虚空　　观此上下等
  如见金刚手　　速灭除灾患
  降彼花香雨　　破灭地狱火
  云何名快乐　　云何名欢喜
  处彼地狱者　　得见观自在
  同一切威德　　俱胝髻童子
  大悲菩提心　　救度于一切
  以彼天供养　　天冠及天花
  乃至悲心花　　适悦宝楼阁
  天女之言说　　百千种歌咏
  赞大圣文殊　　及普贤菩萨
  以此善功德　　同于地狱者
  大圣观自在　　观察地狱苦
  无量苦可怖　　手出甘露乳
  济彼诸饿鬼　　与食与洗浴
  令饱满清凉　　离苦得快乐
  如彼北洲人　　色力并寿命
  聋者得闻声　　盲者得见色
  妊娠及产生　　喻摩耶无苦
  虽衣虽饮食　　庄严而清净
  一切随求意　　得利复得益
  怖者不受怖　　不乐而得乐
  烦恼得无恼　　见者皆欢喜
  病者获安乐　　解脱一切缚
  无力而得力　　爱心互相施
  安乐于十方　　行道一切至
  恶事皆灭尽　　当成就好事
  乘船商贾人　　得满所求意
  安乐到彼岸　　亲等同嬉戏
  饥馑时路行　　得伴无所畏
  不怖贼与虎　　复不怖迷醉
  旷野无病难　　耄幼无主宰
  贤圣悉加护　　诸烦恼解脱
  悲愍信智慧　　具足相修行
  恒得宿命通　　而得无尽藏
  乃至虚空藏　　无缘无方便
  无少才不喜　　有情乏名闻
  当得大名称　　出家若丑陋
  当得具色相　　若彼有三界
  使彼得丈夫　　亦离高下品
  当破我慢意　　今我一切福
  利诸有情等　　常离一切罪
  恒作善利事　　菩提心所行
  菩提行不退　　远离我慢业
  当得佛受记　　一切有情等
  得无量寿命　　寿命得恒长
  破坏无常声　　劫树苑适悦
  一切方皆得　　妙法而适意
  同佛佛圆满　　彼诸高下石
  如掌而平坦　　柔软琉璃色
  一切地皆得　　诸大菩萨众
  普遍诸国土　　以自住光明
  庄严于大地　　诸树及飞禽
  光明于虚空　　说法声不住
  诸有情常闻　　佛及佛子等
  彼彼恒得见　　无边供养云
  供养于世尊　　天雨依时节
  谷麦咸丰实　　世间得具足
  王法得依行　　药力倍增盛
  明力皆成就　　罗刹拏吉儞
  斯等皆悲愍　　无有苦有情
  无罪复无病　　不轻慢下劣
  烦恼无所得　　读诵而自在
  随意而行住　　众集乃恒常
  成就于僧事　　苾刍住净戒
  复得一切解　　观察于心业
  舍离诸烦恼　　苾刍所得利
  当远离斗诤　　诸出家亦然
  不得破禁戒　　得戒而守护
  恒乐尽诸罪　　若彼不破戒
  得益往天趣　　若彼持钵者
  为得于善利　　得清净种子
  名闻满诸方　　永不受罪苦
  恒行无苦处　　无边诸有情
  供养一切佛　　当受一天身
  彼成佛世间　　不思议有情
  乐佛而得乐　　愿为于世间
  菩萨得成就　　彼尊若思惟
  彼有情令得　　辟支佛安乐
  及得声闻乐　　天人阿修罗
  意重而恒护　　若彼宿命通
  出家此恒得　　若彼欢喜地
  文殊师利住　　我若以彼位
  随力而能与　　若知和合住
  得生于一切　　若有欲见者
  及有欲闻者　　如是彼得见
  文殊师利尊　　如日照十方
  为一切有情　　彼文殊修行
  我得如是行　　彼或住虚空
  或住于世间　　今我住亦然
  得坏世间苦　　世间若有苦
  彼一切我得　　世间一切善
  菩萨之乐得　　一药救世间
  一切皆富乐　　一切同利养
  佛教而久住　　以善意清净
  归命于文殊　　我说善知识
  清净此增长

菩提行经卷第四


菩提资粮论

    No. 1660

菩提资粮论卷第一

        圣者龙树本　比丘自在释

        大隋南印度三藏达磨笈多译

  今于诸佛所　　合掌而顶敬
  我当如教说　　佛菩提资粮

佛者。于一切所应知中得觉。此为佛义。如所应知而知故。又于无智睡眠中觉故。觉者。觉寤为义。以离无智睡故。又诸释梵等不觉此觉。唯是名声普遍三界者。所能觉故。一切诸佛乃觉此觉。以一切种遍智唯佛所知。非诸声闻独觉菩萨。以不共法具足故。诸者。无阙故。谓过去未来现在等。顶者上分故。合掌者。摄手故敬者。向礼故。我说者。自分别故。如教者。彼彼经中种种已说。今亦如彼教说故。佛者。离无智故。菩提者。一切智智故。资粮者。能满菩提法故。譬如世间瓶盈釜盈等。盈是满义。如是以满菩提法。为菩提资粮。又以持为义。譬如世间共行日摄于热月摄于冷。摄是持义。如是以持菩提法。为菩提资粮。言资粮者即是持义。又以长养为义。譬如世间有能满千或百或十。或唯自满或难自满。菩提资粮亦复如是。以长养菩提为义。又以因为义。如舍城车等因中说言舍资粮城资粮车资粮。如是于生菩提因缘法中。说名菩提资粮。又以众分具足为义。譬如祭祀分中杓火等具足名为祭祀。非不具足。亦如身分头手足等具足得名为身。非不具足。施分亦如是。施者施物。受者回向。此等具足名施资粮。非不具足。戒等资粮亦如是。是故众分具足义。是资粮义。如是我说菩提资粮。是能满者。持者。长养者。菩提因者。菩提分具足者。皆其义也

  何能说无阙　　菩提诸资粮
  唯独有诸佛　　别得无边觉

何能者。何力也。若声闻若菩萨少分觉知无力能故。若欲说诸菩提资粮无阙无余。唯是诸佛别得无边觉者。言无边觉。谓非少分觉故。以佛世尊于无边应知义中觉知无碍。是故佛名无边觉者。又于欲乐及自疲苦断常有无等边见中。觉而不着。以所觉无边。是故佛名无边觉者。问何故资粮唯佛能说。余人不能答

  佛体无边德　　觉资粮为根
  是故觉资粮　　亦无有边际

佛体者。即佛身也。以彼佛体具足无边功德故。说佛体无边德。功德者。谓可称赞义。若可称赞则名功德。又是数数作义。譬如数数诵习经书。彼则说名作功德者。又是牢固义。譬如作绳。或合二为功。或合三为功。又是增长义。譬如息利。或增二为功。或增三为功。又是依止义。譬如诸物各以依止为功。如是佛体为戒定等无边差别功德依止故。说佛体有无边功德。觉资粮为根者。彼菩提资粮。与佛体无边功德为根本故。根者建立义。菩提者智也。根即资粮。以彼资粮能建立一切智智。是故资粮为佛体根本。良由佛体有无边功德。须以无边功德成彼佛体。是故资粮亦无边际

  当说彼少分　　敬礼佛菩萨
  是诸菩萨等　　次佛应供养

彼诸资粮无边而智有边。是以说彼资粮不能无阙。故言当说彼少分敬礼佛菩萨问应礼佛。以一切众生中最胜故。何义此中亦礼菩萨。答是诸菩萨等次佛应供养故。诸菩萨等从初发心乃至觉场皆应供养。菩萨有七种。一初发心。二正修行。三得无生忍。四灌顶。五一生所系。六最后生。七诣觉场。此等菩萨于诸佛后次应供养。以身口意及外物等而供养之。初发心者未得地。正修行者乃至七地。得无生忍者住第八地。灌顶者住第十地。一生所系者方入兜率陀。最后生者兜率陀处住。诣觉场者欲受用一切智智。于七种菩萨中。初发心菩萨一切众生皆应礼敬。何况余者。何以故。深心宽大故。如来教量故。初发心菩萨发菩提心时。于十方分无减诸佛土无减诸众生无减。以慈遍满发菩提心。若未度众生我当度之。未解脱者我当解脱。未稣息者我当苏息。未寂灭者我当寂灭。应声闻者我当令入声闻乘中。应独觉者我当令入独觉乘中。应大乘者我当令入大乘之中。欲令众生悉得寂灭。非为寂灭少分众生。以是深心宽大故。一切众生皆应礼敬。何者为如来教量。如世尊说迦叶。譬如新月便应作礼。非为满月。如是迦叶。若信我者。应当礼敬诸菩萨等。非为如来。何以故。从于菩萨出如来故。又声闻乘中亦说

  于彼知法者　　若老若年少
  应供养恭敬　　如梵志事火

以是故。诸菩萨等。次于佛后皆应供养。如偈说

  绍持佛种者　　胜余少分行
  是故诸菩萨　　次佛后供养
  慈与虚空等　　普遍诸众生
  是故最胜子　　次佛后供养
  于诸众生类　　大悲犹如子
  是故此佛子　　次佛后供养
  悲心利众生　　无二似虚空
  是故无畏者　　次佛后供养
  一切时如父　　增长诸众生
  是故诸菩萨　　次佛后供养
  犹如地水火　　众生常受用
  是故施乐者　　次佛后供养
  唯为利众生　　舍离自乐因
  是故彼一切　　次佛后供养
  佛及佛之余　　皆从初心出
  是故诸菩萨　　次佛后供养

问尊者已正说资粮教缘起。今应说资粮体。答

  既为菩萨母　　亦为诸佛母
  般若波罗蜜　　是觉初资粮

以般若波罗蜜是诸菩萨母故。为菩提初资粮。何以故。以最胜故。如诸身根中眼根最胜。诸身分中头为最胜。诸波罗蜜中般若波罗蜜最胜亦如是。以般若波罗蜜最胜故。为初资粮。又前行故。如诸法中信为前行。诸波罗蜜中般若波罗蜜前行亦如是。以彼陀那若不回向菩提。则非陀那波罗蜜。如是尸罗等不回向菩提亦非尸罗等波罗蜜。回向菩提即是般若。由般若前行故能回向。以是前行故。诸波罗蜜中般若波罗蜜。为菩提初资粮。又是诸波罗蜜。三轮净因体故。以般若波罗蜜为诸波罗蜜三轮净因体。是故般若波罗蜜。为菩提初资粮。三轮净者。菩萨于般若波罗蜜中行布施时。不念自身。以离取自身故。不念受者差别。以断一切处分别故。不念施果。以诸法不来不出相故。如是菩萨得三轮净施。如净施净戒等亦如是。以此般若波罗蜜是彼诸波罗蜜三轮净因体故。般若波罗蜜为菩提初资粮。又大果故。般若波罗蜜大果胜诸波罗蜜。如经说

  菩提心福德　　及以摄受法
  于空若信解　　价胜十六分

鞞罗摩经中大果因缘。此中应说。以是大果故。般若波罗蜜为菩提初资粮

问何故般若波罗蜜。得为菩萨母

答以能生故。方便所摄般若生诸菩萨。令求无上菩提。不求声闻独觉。以是生佛体因故。般若波罗蜜为菩萨母。又置于五波罗蜜中故。如言冥钵啰腻波低也。冥为性。钵啰腻波低为诵。即此性相是为摩多(摩多翻为母于字声论中摩多字从冥钵啰腻波低语中出冥是摩多体性钵啰腻波低是诵摩多义钵啰腻波低正翻为置故以置为母义)

譬如母生子。时或置床敷。或置地上。般若波罗蜜亦如是。生彼求菩提菩萨时。置于施等五波罗蜜中。以能置求菩提菩萨故。说般若波罗蜜为菩萨母。又以量故。如言茫摩泥也。茫为性摩泥为诵。即此性相是为摩多(于字声论中摩多字又从茫摩泥语中出茫亦是体性摩泥是诵其义摩泥正翻为量故以量为母义)。譬如母生子已随时筹量。如是我子以此食故身增。以此故损减。菩萨亦如是。以般若波罗蜜自量其身。我应如是布施。我应如是持戒等。以是自量因缘故。说般若波罗蜜为菩萨母。又以斟量故。譬如量物有钵逻萨他。有阿宅迦。有突嚧挐。有佉梨底等(如此间合升斗斛之类)斟量诸菩萨亦如是。此初发心。此修行。此得忍等。以斟量因缘故。说般若波罗蜜为菩萨母。又以修多罗中诵故。所谓于诸经中作母名诵。彼等经中有名称遍诸佛国菩萨。名毗摩罗吉利帝。说伽他言(旧云维摩诘者不正)

  般若波罗蜜　　菩萨仁者母
  善方便为父　　慈悲以为女

复有余经。亦如是诵。以修多罗量故说。般若波罗蜜为菩萨母

问何故般若波罗蜜。亦为诸佛母

答以出生及显示无障碍智故。过去未来现在诸佛。由般若波罗蜜阿含故。烦恼已尽当尽今尽以是出生故。般若波罗蜜为诸佛母。显示无障碍智者。以过去未来现在诸佛世尊显示无障碍智皆般若波罗蜜中显。以是显示无障碍智故。诸佛亦以般若波罗蜜为母此中有输卢迦

  由大悲相应　　般若波罗蜜
  于无为险岸　　佛子能超过
  得到无等觉　　利摄诸众生
  智度为母故　　大人能如是
  由得智度故　　乃得成佛体
  故为诸佛母　　胜仙之所说

何故此名般若波罗蜜。以不与声闻独觉共故。名般若波罗蜜。于上更无所应知故。名般若波罗蜜。此智到一切彼岸故。名般若波罗蜜。此般若波罗蜜余无能胜故。名般若波罗蜜。三世平等故。名般若波罗蜜。虚空无边平等故。名般若波罗蜜。如是等胜因缘。如般若波罗蜜经中说。故名般若波罗蜜

问已略说菩提初资粮。第二资粮今应说

  施戒忍进定　　及此五之余
  皆由智度故　　波罗蜜所摄

此中陀那波罗蜜。为第二菩提资粮。以般若前行故。菩萨为菩提而行布施。是故施为第二资粮。于中生他身意乐。因名布施。非为作苦。彼有二种。谓财施法施。财施亦有二种。谓共识不共识。共识亦有二种。谓内及外。若施自身支节。若全身施。是为内施。若施男女妻妾及二足四足等。是为外施。不共识亦有二种。谓可食不可食。此有多种若施身内受用饮食等物。是为可食。若施身外受用香鬘所摄金银珍宝衣服土田财物园池游戏处等。是为不可食。然可受用法施。亦有二种。谓世间出世间。若因法施。于流转中(旧云生死者非正翻名今改为流转也已后诸云流转者皆是此义)出生可爱身根境界。是为世间。若因法施果报。越度流转。是为出世间。彼财施法施各有二种谓有着无著。若为自身。若为资生。若为胜果。悕望相续以财法施。是为有着。若为利益安乐一切众生。若为无障碍智。是为无著。其余更有无畏施等。亦随顺入财施中。彼二种施果及余气(谓津液也)具如大乘经说。此中当略说偈

  饮食及被服　　随须皆布施
  亦施花鬘灯　　末香与音乐
  或施诸美味　　药物及猗枕
  养病之所须　　并医人给侍
  男女与妻妾　　奴婢及仓库
  庄饰诸婇女　　随须皆布施
  所有诸宝物　　种种庄严具
  象马车乘等　　妙物尽施之
  园林修道处　　池井集会堂
  土田并杂物　　客舍等皆施
  若二足四足　　若复一洲渚
  村落与国都　　及王境悉施
  施所玩好物　　利乐悕须者
  为诸众生依　　怖者施无畏
  施其所难舍　　手足眼耳鼻
  亦施心与头　　举身悉能舍
  修行布施时　　常于受者所
  应生福田想　　亦如善眷属
  布施诸果报　　具足善聚集
  回向为自他　　成佛及净土
  菩萨所行施　　正回向佛体
  此菩萨陀那　　得名波罗蜜
  若彼若此岸　　亦无能说者
  施果到于彼　　说为施彼岸

今说施主差别

  不贪于爱果　　悲故三轮净
  正觉说彼施　　是为求菩提
  我已作此事　　正作当亦作
  若作如是舍　　佣赁非布施
  贪增施果故　　随须即能舍
  说为息利人　　智念非施主
  不贪增益果　　唯以悲心施
  此名真施主　　余皆是商贩
  如大云遍雨　　诸处等心施
  此名大施主　　余皆是少分
  施及施果报　　哀愍与须者
  施主于众人　　犹如其父母
  不念所施物　　受者及施者
  而常乐布施　　此名为施主
  若不分别佛　　菩提与菩萨
  而为菩提施　　彼当速成佛

问已解释陀那波罗蜜。今应说尸罗波罗蜜。答波罗蜜义如前解释。尸罗义今当说。以尸罗故说为尸罗。言尸罗者谓习近也。此是体相。又本性义。如世间有乐戒苦戒等。又清凉义。为不悔因离心热忧恼故。又安隐义。能为他世乐因故。又安静义。能建立止观故。又寂灭义。得涅槃乐因故。又端严义。以能庄饰故。又净洁义。能洗恶戒垢故。又头首义。能为入众无怯弱因故。又赞叹义。能生名称故。此戒是身口意善行所转生。于中远离杀生不与取欲邪行等。是三种身戒。远离妄语破坏语粗恶语杂戏语等。是四种口戒。远离贪嗔邪见等。是三种意戒。如是等身口意善行所转生十种戒。与贪嗔痴所生十种恶行为对治。彼十种恶行下中上常习近故。堕于地狱畜生阎摩世等。如前数十种善行戒。若不与觉分相应。下中上常习近故。随福上上差别。当得天人差别。若与觉分相应十种善行。戒上上常习近多作。故当得声闻地及菩萨地中转胜差别。又此菩萨戒聚。有六十五种无尽。如无尽意经中说当知。又略说有二种戒。谓平等种莳戒。不平等种莳戒。平等种莳戒者。以此善身口意积聚故。于生生中种莳。若界若富乐。若声闻独觉。若相报若净土若成熟众生。若正遍觉等。彼皆说名平等种莳戒。与此相违。名不平等种莳戒。复有二种戒谓有作戒无作戒。若于有作中有所作者。名有作戒。与此相违名无作戒。复有九种戒。谓凡夫戒。外道五通戒。人戒。欲界天子戒。色界天子戒无色界天子戒。诸学无学声闻戒。独觉戒。菩萨戒。凡夫戒者。入生处故尽。外道五通戒者。神通退故尽。人戒者。十善业道尽故尽。欲界天子戒者。福尽故尽。色界天子戒者。禅那尽故尽。无色界天子戒者。三摩钵帝尽故尽。诸学无学声闻戒者。究竟涅槃故尽。独觉戒者。阙大悲故尽。菩萨戒者。则无有尽。以此戒能显明诸戒故。种子相续无尽故。菩萨相续无尽故。如来戒无尽故。以此因缘。菩萨戒者说名无尽。诸菩萨戒。回向菩提故。说名戒波罗蜜。此中有输卢迦

  犹如父爱功力子　　亦如自身爱寿命
  出离有爱戒亦尔　　大心健者之所爱
  此戒牟尼习近已　　解脱于欲离有爱
  似乌凡人所弃舍　　智者常当爱此戒
  此戒利益于自他　　令身端严离忧乏
  此世他世胜庄严　　是戒智者当所爱
  此戒不由于他力　　非不可得非乞求
  皆因自力而得之　　是故上人爱此戒
  财物国境并土地　　自身肌肉及以头
  皆能舍之不舍戒　　为欲净彼胜菩提
  假使从天坠于地　　设令自地升于天
  为满离垢无染地　　应当决定不移动
  若已满足戒方便　　此时即得第二地
  既得离垢清净地　　是时成就心所欲
  若复天人修罗世　　及畜生中可化者
  善知教化方便已　　随念往彼利益之
  或以布施摄众生　　或以爱语入其意
  或复与其安隐利　　或与同事助其力
  或在人中为其主　　或居天众而自在
  彼彼方便引导之　　悉当安置于白法
  具足实戒神通故　　便能干竭于大海
  世间尽时火增盛　　于刹那顷悉能灭
  观于世间种种恼　　恼而生病由离亲
  智者有戒通方便　　为世亲依示胜道

问已解释尸罗波罗蜜。今应说羼提波罗蜜。答此中羼提者。若身若心受诸苦乐。其志堪忍不高不下心无染浊。此名略说羼提。若自在说。则施设为三。谓身住持。心住持。法住持。于中身住持忍者。谓身所遭苦。若外有心无心不爱之触。所生身苦堪忍不计。此名身住持忍外所生者。谓以食因缘故起怖嗔痴。及蚊虻蛇虎师子熊等二足四足多足。诸有心物无量因缘逼恼于身。或复来乞手足耳鼻头目支节。而割截之。于此恶事心无闷乱亦无动异。此名身住持忍。又暴风盛日寒热雨雹击触因缘。诸无心物来逼恼时。遍身苦切而能安受。此亦名忍。又内身所起界动因缘故。风黄痰癊及起所生四百四病极为身苦。于逼恼时能忍不计。亦名身住持忍。于中心住持忍者。若有骂詈嗔嫌呵责毁谤挫辱欺诳等不爱语道。来逼恼时。其心不动亦无浊乱。此名心住持忍。又八种世法所触。谓得利失利好名恶名讥誉苦乐中。心无高下不动如山。是名心住持忍。又断顺眠嗔故。无杀害心。无结恨心。无斗诤心。无诉讼心。自护护他。于众生中慈心相应。与悲共行起欢喜意恒作舍心。此等亦名心住持忍。于中法住持忍者。于内于外如实观察故。外者。谓骂詈杀害等。骂詈者。声字和合同时不散。以刹那故。字空故。声如响故。不可说次第相应义。此中无有骂詈。但诸余凡夫虚妄分别而生嗔怒。若字与声自性义中知不可得。心则随顺不相违背。平等忍受。此名法住持忍。又于杀害者所。当作是念。身非害者。身若无心。则如草木壁影等故。心亦非害者。以心非色。无所触碍故。于第一义中无杀害者。作是观时。不见杀害。堪能忍之。此名法住持忍。内者。谓观内法时。作如是念。色如聚沫从缘而起。无动作故。不自生故。空故。离我我所故。受如泡。想如阳焰。行如芭蕉。识如幻。从缘而起。无动作故。不自生故。刹那生灭故。空故。离我我所故。于中色非我。色非我所。如是受想行识。识非我识非我所。此等诸法从缘而生。若从缘生则自性无生。若自性无生则无能害者。如是观时。若内若外诸法自性皆不可得。此名法住持忍。若于身心法中。作自性观时。即是顺无生忍。此名略说羼提波罗蜜。如修多罗中具说。此中有圣者颂

  怨亲及中人　　悲念常平等
  嗔因尚无有　　何得嗔众生
  善修习常慈　　众生同己体
  平等无有二　　云何怒众生
  心常舍离嗔　　多生于爱喜
  健者既无碍　　云何与世违
  于诸众生所　　常求作利祐
  云何无嗔恚　　得加众生恶
  世间八法触　　其心不动摇
  譬如口吹山　　应知彼得忍
  深心离诸垢　　碍事不能污
  如泥泥虚空　　应知彼得忍
  于身无所爱　　于命不亦贪
  诸怨悉不能　　动其相续志
  于非可爱声　　安心犹如响
  诸言亦如化　　忍心便在手
  不于五众中　　取我及命相
  身亦非我所　　应知彼得忍
  若不见于我　　及我所自性
  便得无生忍　　佛子最安隐

菩提资粮论卷第一菩提资粮论卷第二

        圣者龙树本　比丘自在释

        大隋南印度三藏达磨笈多译

问已解释忍波罗蜜。今应说精进波罗蜜。答勇健体相。勇健作业等。是为精进。于中诸菩萨等。从初发心乃至究竟觉场。建立一切菩提分相应身口意善业。此名精进波罗蜜。又复若与诸凡夫及学无学声闻独觉等。不共精进。此名精进波罗蜜。精进有三种。谓身口意。彼身口精进。以心精进而为前行。略说有三种福事。若身与福事相应。是身精进。若口与相应。是口精进。若意与相应。是意精进。又于若自利若利他善中身健行。是身精进。口健行是口精进。意健行是心精进。复有三十二种菩萨精进。谓不断三宝种精进。成熟无量众生精进。摄受无量流转精进无量供养给侍精进。聚集无量善根精进。出生无量精进精进。善说令众生欢喜精进。安隐一切众生精进。随诸众生所作精进。于诸众生中行舍精进。受诸戒学精进忍力调柔精进。出生诸禅那三摩提三摩钵帝精进。满足无著智慧精进。成就四梵行精进。出生五神通精进。以一切佛土功德成已佛土精进。降伏诸魔精进。如法降伏诸外论师精进。满足十力无畏等佛法精进。庄严身口意精进。得度诸有所作精进。害诸烦恼精进。未度者令度。未脱者令脱。未稣息者令稣息。未涅槃者令涅槃精进。聚集百福相资粮精进。摄受一切佛法精进。游无边佛土精进。见无量诸佛精进。此诸精进从大悲出。离身口意故。住不取不舍故。得不举不下故。摄不生不起故。如是等三十二法具足已。精进波罗蜜当得清净满足。此中亦有圣颂

  彼诸施等波罗蜜　　精进之力所成就
  是故精进为根本　　诸菩萨等得佛身
  精进方便求菩提　　我念精进胜方便
  以其舍离精进已　　方便不能作所作
  若唯独有一方便　　则无策勤作事业
  所作皆是精进作　　是故精进胜方便
  心有巧力为方便　　此心从于精进生
  是故诸有所作事　　皆以精进为根本
  诸论及以工巧等　　具精进故到彼岸
  是故于诸所作中　　精进最为成就者
  所有自在及财物　　精进之人则能得
  是故诸有安乐事　　皆以精进为得因
  以有殊胜精进故　　佛于声闻为上首
  是故此之精进力　　最为胜因非余行
  胜上精进勇健者　　于地地中虽同地
  而彼恒得最胜上　　是故常应起精进
  佛在菩提树下时　　以精进故觉菩提
  是故精进为根本　　得佛身因前已说

问已略解释精进波罗蜜。今应说禅那波罗蜜

答禅那者。有四种禅那。谓有觉有观离生喜乐。游于初禅。无觉无观定生喜乐。游第二禅。离喜行舍念慧受乐。游第三禅灭于苦乐舍念清净不苦不乐。游第四禅。于此四种禅那中。离证声闻独觉地。回向佛地已。得名禅那波罗蜜。诸菩萨有十六种禅那波罗蜜。诸声闻独觉之所无有。何者十六种。谓不取实禅。不着味禅。大悲攀缘禅。三摩地回转禅。起作神通禅心堪能禅。诸三摩钵帝禅。寂静复寂静禅。不可动禅。离恶对禅。入智慧禅。随众生心行禅。三宝种不断禅。不退堕禅。一切法自在禅。破散禅。如是等十六种。是为禅那波罗蜜。不取实禅者。为满足如来禅故。不着味禅者。不贪自乐故。大悲攀缘禅者。示现断诸众生烦恼方便故。三摩地回转禅者。攀缘欲界为缘故。起作神通禅者。欲知一切众生心行故。心堪能禅者。成就心自在智故。诸三摩钵帝禅者。胜出诸色无色界故。寂静复寂静禅者。胜出诸声闻独觉三摩钵帝故。不可动禅者。究竟后边故。离恶对禅者。害诸熏习相续故。入智慧禅者。出诸世间故。随众生心行禅者。度诸众生故。三宝种不断禅者。如来禅无尽故。不退堕禅者。常入定故。一切法自在禅者。诸业满足故(第十六破散禅本阙不解)。又念净。慧净。趣净。惭净。持心希望净。回向菩提净。根净。无依净。不取实净。起作神通净。心堪能净。身远离净。内寂静净。外不行净。有所得见净。无众生无命无人净。三界中不住净。觉分门净。离翳光明净。入智慧净。因果不相违净。业思惟忍净。开胞藏相智净。摄方便前巧净。菩提场障碍净。不着声闻独觉净。安住禅那出生光明净。佛三摩地不散乱净。观自心行净。知诸众生各各根如应说法净(本阙二净)。彼十六种禅那波罗蜜由。此三十二净故得清净。得入如来地。此中有输卢迦

  若彼十六种　　及三十二净
  与禅度相应　　是为求菩提
  到禅那彼岸　　善知禅那业
  智者五神通　　出生不退堕
  诸色无有尽　　通达其实性
  亦以胜天眼　　普见诸色相
  虽以净天耳　　远闻诸音声
  智者通达知　　声非可言说
  所有众生心　　观其各各相
  诸心犹如幻　　了知其自性
  众生宿世住　　如实能念知
  诸法无过去　　亦知其自性
  往诣俱知土　　见土具庄严
  土相如虚空　　了知其实性
  众生诸烦恼　　皆以乱心生
  是故胜智者　　旷修诸禅定

问所解释禅那波罗蜜者。略说已竟。今应次第说般若波罗蜜

答般若波罗蜜者。如前解释。为初资粮中说我今更释其相。如先偈说

  施戒忍进定　　此五种之余
  彼诸波罗蜜　　智度之所摄

此余有四波罗蜜谓巧方便波罗蜜。愿波罗蜜。力波罗蜜。智波罗蜜等。此四波罗蜜。皆是般若波罗蜜所摄。般若波罗蜜者。若佛世尊于菩提树下。以一念相应智。觉了诸法。是般若波罗蜜。又是无碍相。以无身故。无边相。等虚空故。无等等相。诸法无所得故。远离相。毕竟空故。不可降伏相。无可得故。无句相。无名身故。无聚合相。离来去故。无因相。离作者故。无生相。生无有故。无去至相。离流转故。无散坏相。离前后际故。无染相。不可取故。无戏论相。离诸戏论故。无动相。法界自体故。无起相。不分别故。无量相。离量故。无依止相。依止无有故。无污相。不出生故。不可测相。无边际故。自然相。知诸法自性故。又般若波罗蜜是闻慧相。及正思入。彼闻慧相。有八十种。谓乐欲等。正思入。有三十二种。谓安住奢摩他等。又般若波罗蜜。不与十六种宿住等无明俱。如是等般若波罗蜜相。随量已说。若具说者乃有无量。此般若波罗蜜所摄方便善巧波罗蜜中。有八种善巧。所谓众善巧。界善巧。入善巧。谛善巧。缘生善巧。三世善巧。诸乘善巧。诸法善巧。此中善巧波罗蜜无有边际。又复随于何等生趣。以何等行相。为菩提故。得自增长善根及调伏众生。于彼彼生趣彼彼行中。此一切处凡所应作种种方便。诸大人等所分别说。我今说彼经中微滴之分。若已作今作微少之善。能令多多能令无量。此为方便。不自为己唯为众生。此为方便。唯以陀那令诸波罗蜜满足。此为方便。如是以尸罗摄诸生处。以羼提。庄严身口心为于菩提。以毗梨耶安住精进。以禅那不退于禅。以般若舍离无为。以慈为作依护。以悲不弃流转。以喜能忍不喜乐事。以舍发起诸善。以天眼摄取佛眼。以天耳满足佛耳。以他心智知各各根。以宿住念知三世无碍。以自在通得如来自在通。以入众生心欲知诸行相。已度还入。无染而染舍担更担。无量示量最胜现劣。以方便故涅槃相应而堕在流转。虽行涅槃。不毕竟寂灭。现行四魔。而超过诸魔。达四谛智及观无生。而不入正位。虽行愦闹。而不行顺眠烦恼。虽行远离。而不依身心尽。虽行三界。而于界中不行世谛。虽行于空。而一切时恒求佛法。虽行无为。而不于无为作证。虽行六通。而不尽漏。虽现声闻独觉威仪。而不舍乐欲佛法。如是等巧方便波罗蜜中。所有教化众生方便。彼等方便是菩萨教化巧方便住处应知。此中有输卢迦

  畜生道中诸苦恼　　地狱饿鬼生亦然
  于流转中相应受　　众生种种诸过恶
  此等苦聚不能障　　于众生处起哀愍
  诸佛便说彼菩萨　　一切世间无碍悲
  论中若有善该综　　众多别人所作业
  工巧等明及余事　　皆以爱语授与之
  戒财闻修寂调等　　以此功德摄化他
  摄已复令常相续　　胜仙说为住善道
  或现女身化男子　　令其调伏而受教
  或现男身化女人　　令其调伏而受教
  若不厌于染境乐　　愍其无道令入道
  随众生门种种化　　极逼恼处亦不舍
  或有信解于无我　　及知诸法离自性
  是人未离世间法　　但作如此观察转
  于业及果生信顺　　而有无边诸苦事
  当于受彼苦果时　　不喜诸苦所逼切
  若于声闻出家者　　便置安隐寂静处
  或复置于缘觉道　　或置十种妙力乘
  令其当得正觉乘　　或得寂静及天趣
  若应观察现见果　　如其所作正安置
  如是从初至究竟　　丈夫难事皆能为
  依彼种种巧方便　　舍离一切爱不爱
  此乘诸佛所赞叹　　百千功德而庄严
  能生世间极净信　　以说胜妙善道故
  于缘觉乘声闻乘　　及以天世诸乘中
  皆以十善而成熟　　亦于人乘成熟人

已解释巧方便波罗蜜。我今当说愿波罗蜜。诸菩萨最初有十大愿。所谓供养给侍诸佛无余。是第一大愿。于彼佛所持大正法。摄受正觉普护正教。是第二大愿。诸世界中诸佛出兴。始从住兜率宫乃至退堕。入胎住胎初生出家。证正觉请转法轮入大涅槃。皆往其所受行供养初不舍离。是第三大愿。诸菩萨行旷大无量。不杂诸波罗蜜所摄善净诸地。出生总分别分同相异相共转不共转等诸菩萨行。如实如地道说。修治波罗蜜教诫教授。授已住持。发起出生如是等心。是第四大愿。无余众生界。有色无色有想无想。卵生胎生湿生化生。三界同入六趣共居。诸生顺去名色所摄。无余众生界皆悉成熟。令入佛法。断除诸趣。安立于一切智智。是第五大愿。无余诸世界旷大无量。若细若粗若横若倒若平住等。同入共居顺去。十方分分犹如帝网。入于分分以智顺行。是第六大愿。一切土即一土。一土即一切土。平等清净无量国土。普皆庄严离诸烦恼。净道具足无量智相。众生充满入佛上妙境界。随众生心示现令其欢喜。是第七大愿。为与诸菩萨同一心故。为不共善根聚集故。为与诸菩萨同一攀缘常不离菩萨平等故。为发起自心入如来威神故。为得不退行神通故。为游行诸世界故。为影到诸大众论故。为自身顺入诸生处故。为具足不思议大乘故。为行菩萨行故。是第八大愿。为升不退转行菩萨行故。为身口意业不空故。即于见时令决定佛法故。为即出一音声时令入智慧故。为即于信时令转烦恼故。为得如大药王身故。为行诸菩萨行故。是第九大愿。为于诸世界中正觉阿耨多罗三藐三菩提故。为于一毛道中及余一切毛道中。皆现出生坐道场转法轮大般涅槃故。为以智慧入佛大境界威神故。为于一切众生界如其深心佛应出时开悟令得寂静而示现故。为正觉一法一切法悉涅槃相故。为出一音声令诸众生心欢喜故。为现大涅槃而不断行力故。为现大智慧地安立诸法故。为以佛境界法智神通普遍诸世界故。是第十大愿。如是等大欲大出生十大愿为首。满此十大愿已。建立菩萨阿僧祇百千余愿。得住菩萨欢喜地。此名愿波罗蜜。已解释愿波罗蜜。我今当说力波罗蜜。此中略说诸菩萨有七种力。谓福报生力。神通力。信力。精进力。念力。三摩提力。般若力

福报生力者。如十小象力当一龙象力。十龙象力当一香象力。十香象力当一大香象力。十大香象力当一大力士力。十大力士力当一半那罗延力。十半那罗延力当一那罗延力。十那罗延力当一大那罗延力。十大那罗延力当一过百劫菩萨力。十过百劫菩萨力当一过百千劫菩萨力。十过百千劫菩萨力当一得忍菩萨力。十得忍菩萨力当一最后生菩萨力。住此力已。菩萨即于生时能行七步。十最后生菩萨生时力。乃当菩萨少年时力。菩萨住此力已。趣菩提场成等正觉。得正觉已。以过百千功德力故。成就如来正遍知一种处非处力。如是等十力成就。此名诸佛菩萨及余少分众生福报生力

神通力者。谓四神足善修多作已。以此希有神通力故。得调伏诸众生等。彼以希有神力。显现若色若力若住持等。若诸众生。应以此色像得调伏者。即以此色像。于彼彼众生所。示现或佛色像或独觉色像或声闻色像。如是或释梵护世转轮王等色像。若复诸余色像。乃至畜生色像。为调伏众生故。示现如是色像。若有多力憍慢嗔怒凶恶自高众生。应以此力得调伏者。即现此力。或大力士力。或四分那罗延力。或半那罗延力。或一那罗延力。以此力故。须弥山王高十六万八千踰阇那。宽八万四千踰阇那。以三指举取。如举庵摩勒果掷置他方世界。而四天王天及三十三天等无所娆恼。于菩萨力亦不减损。又此三千大千世界虽复宽旷。从于水界乃至有顶。置之手掌经劫而住。于诸神通道。具足示现如是等力。若有憍慢增上慢嗔怒凶恶自高众生。说法调伏令离憍慢增上慢嗔怒凶恶等。彼得如是神足住持智已。以此住持智。有所住持。随意皆得若以大海为牛迹。即成牛迹。若以牛迹为大海。即成大海。若以劫烧为水聚者。即成水聚。若以水聚为火聚者。即成火聚。若以火聚为风聚者。即成风聚。若以风聚为火聚者。即成火聚。如是若以此住持。随所住持下中上法。既住持已。无有人能震动隐没。所谓若释若梵若魔及余世间同法者。除佛世尊。于众生类中。无有众生于菩萨所住持法震动隐没。以住持力故。为彼种种胜上喜踊尊敬众生说法。彼神足力高出自在。过魔烦恼入佛境界。觉诸众生。聚集宿世善根资粮。魔及魔身天等不能障碍。此名菩萨神通力

信力者。于佛法僧及菩萨行中。信解一向不可沮坏。若恶魔作佛身来。随于何法欲坏其信。菩萨以信解力故。彼不能动菩萨信力。此名信力

精进力者。菩萨若发起精进。与彼彼善法相应时。于彼彼处得牢固力。随所受行若天若人不能动坏令其中止。此名精进力

念力者。住彼彼法处其心安止。诸余烦恼不能散乱。以念力持故破诸烦恼。彼诸烦恼不能破坏菩萨所念。此名念力

三摩提力者。于愦闹中行远离行。诸有音声及语道所出。不为声刺障碍初禅。行善觉观不碍二禅。生于爱喜不碍三禅。成熟众生摄受诸法未曾舍废不碍四禅。如是游四种禅。诸禅恶对不能破坏。虽游诸禅。而不随禅生。此名菩萨三摩提力

般若力者。谓世出世法中不可坏智。于生生中不由师教。诸所作业工巧明处。乃至世间最胜难作难忍。菩萨皆得现前。若出世法救度于世。菩萨智慧随顺入已。彼天人阿修罗众不能破坏。此名般若力。如是等菩萨七力已略解说。若欲具演无有边际。此名菩萨力波罗蜜。已解释力波罗蜜。我今当说智波罗蜜。此中若世间所行书论印算数等。及界论(谓风黄痰癊等性)方论(谓医方论)治诸干痟颠狂鬼持等病。破诸蛊毒。又作戏笑所摄文章谈谑等。令生欢喜。出生村城园苑陂湖池井华果药物及林丛等。示现金银摩尼琉璃贝(石白如贝)玉珊瑚等宝性。入于日月薄蚀星宿地动梦怪等事。建立相诸身分支节等。知于禁戒行处禅那神通无量无色处。及余正觉相应利乐众生等彼岸。又复知诸世界成坏。随世界成随世界坏皆悉了知。又知业集故世界成。业尽故世界坏。知世界若干时成住。知世界若干时坏住。知诸地界水界风界火界若大若小若无量等差别。知极细微尘。亦知所有微尘聚集微尘分散。知世界中所有地微尘数。如是亦知水火风等微尘数。知所有众生身微尘数国土身微尘数。知诸众生粗身细身差别。乃至亦知微尘合成地狱畜生饿鬼阿修罗天人等身。知欲色无色界成坏。及知彼小大无量等差别。知众生身中业身报身色身。知国土身中小大染净。及撗住倒住平住等方网差别

知业报身中差别名字身。知声闻独觉菩萨身中差别名字身。知如来身中正觉身愿身化身住持身。形色相好庄严身威光身意念身福身法身。知智身中若善分别若如理思惟。若果相应摄若世出世。若安立三乘若共法不共法。若出道非出道若学无学。知法身中平等不动。安立世谛处所名字。安立众生非众生法。安立佛法圣众。知虚空身中无量身入。一切处非身真实无边无色身差别。得出生如是等身智。又得命自在心自在众具自在业自在愿自在信解自在神通自在智自在生自在法自在。得如是等十自在已。为不思议智者无量智者不退智者。如是等智有八万四千行相。是菩萨所知智波罗蜜。如是随分解释智波罗蜜。若欲具演。唯佛世尊。乃能解说

  此六波罗蜜　　总菩提资粮
  犹如虚空中　　尽摄于诸物

如所解释六波罗蜜中。总摄一切菩提资粮。譬如虚空行住诸物。有识无识悉摄在中。如是其余闻资粮等诸资粮摄在六波罗蜜中。同相无异。应知

菩提资粮论卷第二菩提资粮论卷第三

        圣者龙树本　比丘自在释

        大隋南印度三藏达磨笈多译

  复有余师意　　诸觉资粮者
  实舍及寂智　　四处之所摄

又一论师作是念。一切菩提资粮皆实处舍处寂处智处所摄。实者不虚诳相。实即是戒。是故实为尸罗波罗蜜。舍即布施。是故舍处为陀那波罗蜜。寂者即心不浊。若心不浊。爱不爱事所不能动是故寂处为羼提波罗蜜及禅那波罗蜜。智处还为般若波罗蜜毗梨耶波罗蜜。遍入诸处以无精进。则于诸处无所成就。是故毗梨耶波罗蜜成就诸事。是故一切资粮皆入四处。问如经说。以慈资粮得无碍心。以舍资粮得断憎爱。于中慈悲有何差别。答

  大悲彻骨髓　　为诸众生依
  如父于一子　　慈则遍一切

若入生死崄道。堕地狱畜生饿鬼诸趣。在恶邪见网。覆愚痴稠林。行邪径非道。犹如盲闇。非出离中见为出离。为老病死忧悲苦恼诸贼执持。入魔意稠林。去佛意远者。菩萨大悲。穿于自身皮肉及筋。彻至骨髓。为诸众生而作依处。令此众生得度如是生死旷野险难恶路。置于一切智城无畏之宫。譬如长者唯一福子而遭病苦。爱彻皮肉入于骨髓。但念何时得其病愈。悲亦如是。唯于苦众生中起。慈者遍于一切众生中起。又复慈故于诸众生得无碍心。悲故于生死中无有疲厌。又慈于善人中生。悲于不善人中生。又菩萨慈增长故不着己乐。则生大慈。悲增长故舍诸支节及命。则生大悲

  若念佛功德　　及闻佛神变
  爱喜而受净　　此名为大喜

若念佛功德者。于中何者是佛功德。谓诸佛世尊无量百千俱致劫中。聚集善根故。不护身口意业故。五种应知中断疑故。四种答难中无失故。三十七助菩提法教授故。十二分缘生中因缘觉故。教九教故。四种住持具足故。得四无量故。满足六波罗蜜故。说菩萨十地故。出世五众成满故。四无畏十力十八不共佛法具足故。无边境界故。自心自在转故。无厌足法故。得如金刚三摩地故。不虚说法故。无能坏法故。世间导师故。无能见顶故。无与等故。无能胜故。不可思法故。得大慈大悲大喜大舍故。百福相故。无量善根故。无边功德故。无量功德故。无数功德故。不可分别功德故。希有功德故。不共功德故。如是等名。念佛诸功德

化诸众生故。起神通变现。随所应度众生。随众生身。随其形量长短宽狭。随其色类种种差殊。随其音声清净分别。诸佛世尊以种种希有神通。如其所行如其信欲。以彼彼方便差别神变。而教化之。闻此事已爱喜受净。名为大喜。于中心勇名爱。爱心遍身名喜。喜心觉乐名受。于受乐时念正觉者大神通德。其心不浊名净。彼心净时喜意充满名为大喜。彼登少分乘者。虽亦有喜。以不共故得大喜名。问菩萨应舍众生。为不应舍。答

  菩萨于众生　　不应得舍弃
  当随力所堪　　一切时摄受

菩萨摩诃萨常念利乐诸众生等。若为贪嗔痴所恼。登于悭吝破戒恚恨懈怠乱心恶智之道。入于异路。此等众生所不应舍。于一切时说施戒修。随力所能应当摄受。不应舍弃

  菩萨从初时　　应随堪能力
  方便化众生　　令入于大乘

此登大乘菩萨于众生中。随所堪能从初应作。如前方便波罗蜜中所说方便。应当精勤以诸方便教化众生置此大乘。问何故菩萨但以大乘教化众生。不以声闻独觉乘也。答

  化恒沙众生　　令得罗汉果
  化一入大乘　　此福德为上

若教化恒河沙等众生。得阿罗汉果。此大乘福。胜过彼声闻等乘教化福。以种子无尽故。此所有种子。能为余众生等。作菩提心方便。亦以出生声闻独觉故。此福胜彼。此福胜者。大乘于声闻独觉乘为上故。又菩提心。有无量无数福德故。又由大乘。三宝种不断故。是故欲求大福。应以大乘教化众生。不以余乘。问诸摩诃萨岂唯以大乘教化众生。不以声闻独觉乘耶。答

  教以声闻乘　　及独觉乘者
  以彼少力故　　不堪大乘化

若中下意众生。舍利他事阙于大悲。不堪以大乘化者。乃以声闻独觉乘。而化度之。问若有众生。不可以三乘化者。于彼应舍为不舍也。答

  声闻独觉乘　　及以大乘中
  不堪受化者　　应置于福处

若有众生。喜乐生死憎恶解脱。不堪以声闻独觉及大乘化者。应当教化置于梵乘四梵行中。若复不堪梵乘化者。应当教化置于天乘十善业道。及施等福事中。不应舍弃。问若有众生喜乐世乐。于三福事无力能行。于彼人所当何所作。答

  若人不堪受　　天及解脱化
  便以现世利　　如力应当摄

若有众生。专求欲乐不观他世。趣向地狱饿鬼畜生。不可教化令生天解脱者。亦当愍彼智如小儿。如其所应现世摄受。随己力能以施等摄之。愍而不舍。问若菩萨于此似小儿相诸众生所。无有方便可得摄化。当于彼人应何所作。答

  菩萨于众生　　无缘能教化
  当起大慈悲　　不应便弃舍

若菩萨于喜乐罪恶可愍众生中。无有方便能行摄化。菩萨于彼当起子想兴大慈悲。无有道理而得舍弃。问已说于众生中应须摄受。未知摄受方便云何。答

  施摄及说法　　复听闻说法
  亦行利他事　　此为摄方便

诸菩萨为摄受众生故。或以布施为摄方便。或受他所施。或为他说法。或听他说法。或行利他。或以爱语。或以同事。或说诸明处。或教以工巧。或示现作业。或令病者得愈。或救拔险难。如是等名为摄受众生方便。当以此诸方便摄受众生。不应弃舍。问以如是等摄受方便。摄众生已成就何利。答

  所作益众生　　不倦不放逸
  起愿为菩提　　利世即自利

此中菩萨作愿利益世间者。发如是意。凡利世间事我皆应作。立此誓已。于诸众生所作事中。不应疲倦不应放逸。又当作念。若利世间即是自利。是故菩萨于利乐众生因缘。不应弃舍。问已说菩萨常应利乐众生。不应行舍。于诸法中为舍不舍。答

  入甚深法界　　灭离于分别
  悉无有功用　　诸处自然舍

法界者。即是缘生。是故先说。如来若出不出。此法界法性常住。所谓缘生。又如先说。阿难陀。缘生甚深证亦甚深。是故入此甚深法界菩萨。灭一切有无等二边。摄取方便智已。即断诸动念戏论分别。离诸取相。诸心意识行处皆不复行。乃至行佛行菩提行菩萨行涅槃处皆亦不行。则于诸法无复功用。于诸法中。得寂静复寂静心无分别心。是名第一义舍。此即菩萨无分别也。已说出世间舍。我今当说世间舍

  利名赞乐等　　四处皆不着
  反上亦无碍　　此等名为舍

于利养名闻赞叹安乐等中无所系着。与此相反无利无名毁苦等中亦不退碍。舍离爱憎处中而住无复分别。此名第二说世间舍。问若菩萨于诸法中。作第一义舍者。为菩提故如然头衣。如是勤行云何可得。答

  菩萨为菩提　　乃至未不退
  譬如燃头衣　　应作是勤行

虽于诸法应如是舍。而菩萨决定修行如然头衣。乃至未得不退转菩提菩萨。为菩提故应当勤行。于中菩萨有五种不退菩提因缘应知。何者为五。如华聚等经中说。若闻具足大愿诸菩萨及佛世尊名号故。若愿生彼佛世尊国土故。是为二种因缘。受持及说般若波罗蜜等深经故。是为第三因缘。修习现前住等三摩提及随喜得者故。是为第四因缘。此四因缘说未得忍菩萨不退转。若此菩萨住菩萨不动地已得无生忍。说为究竟决定不退转。问若此四种因缘中。随以一因缘。菩萨得不退转者。先说如然头衣应当勤行。彼云何成。答

  然彼诸菩萨　　为求菩提时
  精进不应息　　以荷重担故

虽复四因缘中随一因缘菩萨皆得不退。而精进不应休息。由先作是言。我当令诸众生皆得涅槃。以荷如是重担故。于其中间精进不息。问何故于其中间精进不得休息。答

  未生大悲忍　　虽得不退转
  菩萨犹有死　　以起放逸故

于四因缘中随何因缘。得不退转菩萨。彼未生大悲乃至未得无生忍。中间受业力死生者。由入放逸故。是以菩萨应当勤行如然头衣。为得无生忍故。于其中间精进不息

问菩萨复有何死。答

  声闻独觉地　　若入便为死
  以断于菩萨　　诸所解知根

如前所说四种因缘。随何因缘得不退转。此菩萨未有大悲未得忍。未过声闻独觉地。或以恶友力怖生死苦故。或受生中间故。或劫坏时间嗔嫌菩萨毁谤正法故。失菩提心。起声闻独觉地心已。或于声闻解脱。若独觉解脱作证。彼断菩萨根。所谓大悲。是以诸菩萨及佛世尊。名为说解知死。问此应思量菩萨。为畏住泥犁。为畏堕声闻独觉地。答

  假使堕泥犁　　菩萨不生怖
  声闻独觉地　　便为大恐怖

菩萨设住泥犁。与无数百千苦俱。不比堕声闻独觉地怖畏。问何故如此。答

  非堕泥犁中　　毕竟障菩提
  声闻独觉地　　则为毕竟障

设入泥犁。于正觉道。不能作毕竟障碍。住泥犁时。乃至恶业尽边。于菩提道暂为障碍。菩萨若堕声闻独觉地。则毕竟不生故。声闻独觉地。于正觉道乃为障碍。由是义故。菩萨入于泥犁。不比堕声闻独觉地怖畏。问其怖如何。答

  如说爱寿人　　怖畏于斩首
  声闻独觉地　　应作如是怖

经中佛世尊作如是说。如爱寿人怖畏斩首。菩萨欲求无上菩提。怖畏声闻独觉地。亦应如此。是故菩萨虽入泥犁。不比堕声闻独觉地怖畏。问已说未得无生忍诸菩萨障碍法。此菩萨云何得无生忍。答

  不生亦不灭　　非不生不灭
  非俱不俱说　　空不空亦尔

此中菩萨观缘生时作是念。有缘生法但施设。如无生中有生。是故生者自体不成。自体不成故生则非有。如生自体非有。彼灭为二。二俱无体如生灭。彼不生不灭为二。亦二俱无体。彼生灭二种中。生不生灭不灭亦不有互相违故。空亦如是。如有者无自体故。彼不空及空不空亦尔。问若作是念。以缘生故诸法无自体者。何故复作是念。亦无有缘生法。答

  随何所有法　　于中观不动
  彼是无生忍　　断诸分别故

如是菩萨如实观缘生时。得离诸法自体见。离自体见故。即断取法自体。得断法自体时作是念。非无内外法。而无法自体。虽有缘生法。但如苇束幻梦。若法从缘生。彼自体不生。作是观已。若沙门若波罗门。所不能动而不取证。彼以乐观无生法。断诸分别故。说名无生忍。此菩萨即住菩萨不动地。偈言

  既获此忍已　　即时得授记
  汝必当作佛　　便得不退转

得此无生忍故。即于得时非前非后。诸佛现前授记作佛。汝于来世。于尔所时某世界某劫中。当为某如来应正遍知。此名菩萨不退转。问从住初地乃至七地诸菩萨。皆决定向三菩提。何故不说为不退转。唯说住不动地菩萨。为不退转。答

  已住不动诸菩萨　　得于法尔不退智
  彼智二乘不能转　　是故独得不退名

此谓所有信等出世间善根。诸声闻独觉乃至住第七地菩萨。不能障碍令其退转。故名不退转。非余十种菩萨为三菩提于诸法中不退转也。已说不退转因缘。此中又得殊胜授记。大乘中说四种授记。谓未发菩提心授记共发菩提心授记。隐覆授记。现前授记。是为四种授记。于中未发菩提心授记者。其人利根具增上信。诸佛世尊以无碍佛眼观已。而为授记。共发菩提心授记者。成熟善根种菩提种先已修习。其根猛利得增上行。但欲解脱诸众生故。即发心时入不退转。无堕落法离八不闲(谓八难也)。此人或闻自授记。于六波罗蜜不发精进。如其不闻更发精进为令不闻。欲使他人闻其授记。断疑心故。佛以威神隐覆授记。若菩萨成熟出世五根。得无生忍。住菩萨不动地。彼即现前授记。是为四种授记。彼得无生忍菩萨已决定故。诸佛世尊现前授记。又别有密意授记。以为第五。如法华经说

  我等皆随喜　　大仙密意语
  如授记圣者　　无畏舍利弗
  我等亦当得　　成佛世无上
  复以密意语　　说无上正觉

以何义故。说此别语授记。有论师说。为令未入决定声闻乘者发菩提心故。又已发菩提心初业菩萨等。畏流转苦。欲于声闻涅槃取灭度者。为令牢固菩提心故。又有异佛土菩萨。于此聚集。授记时到。以相似名。为彼授记故。诸师如是分别别语授记。于中实义唯佛世尊。乃能知之

  菩萨乃至得　　诸佛现前住
  牢固三摩提　　不应起放逸

诸佛现前三摩提得已而住者。谓现在诸佛现其前住三摩提也。三摩提者。平等住故。菩萨乃至未得此三摩提。其间不应放逸。以未得三摩提。菩萨犹堕恶趣。未离不闲故。是故为得此三摩提。不应放逸。若得三摩提。彼诸怖畏皆得解脱。此三摩提有三种。谓色攀缘。法攀缘。无攀缘。于中若攀缘如来形色相好庄严身。而念佛者。是色攀缘三摩提。若复攀缘十名号身十力无畏不共佛法等无量色类佛之功德。而念佛者。是法攀缘三摩提。若复不攀缘色。不攀缘法。亦不作意念佛。亦无所得。远离诸相空三摩提。此名无攀缘三摩提。于中初发心菩萨。得色攀缘三摩提。已入行者法攀缘。得无生忍者无攀缘。此等名得决定。自在故

  诸佛现前住　　牢固三摩提
  此为菩萨父　　大悲忍为母

此所说三种现。在佛现前住三摩提。摄诸菩萨功德及诸佛功德故。说名诸菩萨父。大悲者。于生死流转中。不生疲倦故。又于声闻独觉地险岸。护令不堕故。说名为母。忍者。得忍菩萨。于诸流转苦及诸恶众生中。不厌流转。不舍众生及菩提。以不生厌。是故此忍又为诸菩萨母。更有别偈说

  智度以为母　　方便为父者
  以生及持故　　说菩萨父母

以般若波罗蜜生诸菩萨法故。佛说般若波罗蜜为菩萨母。诸菩萨法从般若波罗蜜生已。为巧方便所持。不令趣向声闻独觉地险岸。以是持菩提故。说巧方便为菩萨父。问菩萨以几许福能得菩提。答

  少少积聚福　　不能得菩提
  百须弥量福　　聚胜乃能得

菩提者。谓一切智智。彼智与无应知等。应知与虚空等。虚空无边故应知亦无边。以有边福不能得无边智。是故少少积聚福。不能得菩提。云何得百须弥量福。聚集乃能得

菩提资粮论卷第三菩提资粮论卷第四

        圣者龙树本　比丘自在释

        大隋南印度三藏达磨笈多译

问若如是者。百须弥量福聚无有故。亦无一人能得菩提。答

  虽作小福德　　此亦有方便
  于诸众生所　　应悉起攀缘

若此菩萨虽作小福。以有方便成大福聚。或以饮食舍与众生。或以华香鬘等奉如来像。彼诸福德。于一切世界所摄诸众生所。悉作攀缘。我以此福。令诸众生皆得无上正觉。复以此福。与诸众生共之。如是等福。共诸众生回向菩提。是名菩萨方便。如是回向。其福得成无量无数无边。以是故彼一切智智虽是无边。还以此相无边福故能得

复有别义

  我有诸动作　　常为利众生
  如是等心行　　谁能量其福

菩萨于昼及夜。常起如是心行。若我所有动作善身口意。皆为度诸众生故。脱诸众生故。稣息诸众生故。寂灭诸众生故起。及为令众生满足一切智智。得至一切智智故。彼如是具足大悲。安住善巧方便。所有福聚唯除诸佛。何人能量。是故具此福者能得菩提

问何故此福复是无量。答

  不爱自亲属　　及与身命财
  不贪乐自在　　梵世及余天
  亦不贪涅槃　　为于众生故
  此唯念众生　　其福谁能量

此中菩萨行六度行时。于己男女及与亲属。若金银等财。若自寿命。若支节分。若具足身。若身心乐。若天人自在。若梵身天。若无色天。乃至涅槃。为众生故皆亦不爱。唯于众生愍念不舍。我当何为令此众生小儿凡夫无智翳膜所覆盲者。脱三界狱安置常乐涅槃无畏城中。如是菩萨行利乐事。于诸众生无因而爱。所有福德何人能量又偈言

  无依护世间　　救护其苦恼
  起如是心行　　其福谁能量

此菩萨常以大悲。作如是念。今此世间无救无护。遍行六趣入三苦火。无有归依此彼驰走。身心诸病常有苦恼。无依护者我当与作依处。救其身心所受诸苦。起此心行。所有福德何人能量

  智度习相应　　如构牛乳顷
  一月复多月　　其福谁能量

此般若波罗蜜。能生诸佛菩萨。及成就诸佛菩萨法。菩萨若于构牛乳顷。思惟修习彼之福聚。尚无有量。何况若一日夜二日夜三日夜。乃至七日夜半月一月。若复多月修习相应。所有福聚何人能量

  佛所赞深经　　自诵亦教他
  及为分别说　　是名福德聚

甚深者。谓甚深经。与空相应出于世间。彼是甚深。又复分别缘生故。缘生者即是法。法者即是如来身。彼与如来身相应者。是甚深经。诸佛世尊之所赞叹。若自诵若教他诵。若为他解说无希望心。但欲不隐没如来身故。如来身者即是法身。欲令久住故。彼所有福谁能得量

  令无量众生　　发心为菩提
  福藏更增胜　　当得不动地

此有善巧方便菩萨。先以四摄事摄诸众生。知彼众生受我言已。然后教令发菩提心。如是具足善巧方便菩萨。令诸众生发菩提心。彼所有福无人能量。以无量故。又令诸众生发菩提心故。福藏更为增胜。言福藏者。福无尽故。以能至无尽故不可尽。不动地者。以不可动故名不动地。此中菩萨令他发菩提心故。于生生中。菩提心不动不失。以令他发菩提心故。此心即为不动地因

  随转佛所转　　最胜之法轮
  寂灭诸恶刺　　是菩萨福藏

如佛世尊。于婆啰奈城仙人住处鹿林中。转法轮已。于彼最胜法轮随顺而转。亦为福藏。此随顺转有三种因缘。谓于如来所说深经。与空相应出于世间。若持若说及顺法行法。若于如是等经。持令不失。是为第一随顺转法轮。为有根器众生。分别演说。是为第二随顺转法轮。如彼经中所说。依法修行。是为第三随顺转法轮。寂灭诸恶刺者。佛教恶刺所谓外道邪见。及以恶魔欲界自在。憎恶解脱。若四众中或有异人。非法说法。非律说律。非师教说师教。是为佛教内恶刺。应当如法折伏彼等。摧慢破见令法炽然。此名寂灭诸恶刺。以寂灭恶刺。故名为菩萨福藏

  为利乐众生　　忍地狱大苦
  何况余小苦　　菩提在右手

若菩萨着牢固铠。常为利乐众生。发精勤意。于一众生为令解脱故。虽住阿毗至大地狱中。经劫辛苦堪忍不动。况余小苦。菩萨能忍如是等苦。当知菩提如住右掌

  起作不自为　　唯利乐众生
  皆由大悲故　　菩提在右手

菩萨诸所起作。若布施等。由大悲故。唯为利乐众生。亦为令众生得涅槃故。终不为身微少乐事。彼亦是大悲者。如是大人。当知菩提到其右手

  智慧离戏论　　精进离懈怠
  舍施离悭惜　　菩提在右手

问前已解释陀那等诸波罗蜜。今复解释有何所为

答前多为修行者解释。今为无所得忍智光者解释。以觉知一道相故。彼智远离戏论。以不舍轭故。彼精进远离懈怠。以除贪故。彼施远离悭惜。如是菩萨。当知菩提到其右手

  无依无觉定　　圆满无杂戒
  无所从生忍　　菩提在右手

若菩萨善成就禅那波罗蜜已。此定不依三界。其相寂静无有思觉。又圆满尸罗无杂无浊。回向菩提无有磨灭。又善成就般若波罗蜜已。缘生法中住无生忍。根本胜故无有退转。当知菩提住其右掌

问已说修行及得忍菩萨积聚诸福田。此福聚能得菩提。云何初发心菩萨。积聚诸福田。此福聚能得菩提。答

  现在十方住　　所有诸正觉
  我悉在彼前　　陈说我不善

若有现在诸佛世尊。于十方世间无所障碍。以本愿力为利众生故住。今于彼等实证者前。发露诸罪。若我无始流转已来。于其前世及现在时。或自作恶业。或教他或随喜。以贪嗔痴起身口意。我皆陈说不敢覆藏。悉当永断终不更作

  于彼十方界　　若佛得菩提
  而不演说法　　我请转法轮

若佛世尊满足大愿。于菩提树下。证无上正觉已。少欲静住。不为世间转于法轮。我当劝请彼佛世尊转佛法轮。利益多人安乐多人。怜愍世间为于大众。利乐天人

  现在十方界　　所有诸正觉
  若欲舍命行　　顶礼劝请住

若佛世尊世间无碍。在于十方证菩提转法轮安住正法。所应化度众生化度已讫。欲舍命行。我当顶礼彼佛世尊请住久时。利益多人安乐多人。怜愍世间为于大众。利乐天人

  若诸众生等　　从于身口意
  所生施戒福　　及以思惟修
  圣人及凡夫　　过现未来世
  所有积聚福　　我皆生随喜

若诸众生施戒修等所作福事。从身口意之所出生。已聚现聚及以当聚。声闻独觉诸佛菩萨诸圣人等。及以凡夫所有诸福。我皆随喜。如是随喜。是先首者。胜住者。殊异者。最上者。胜摄者。美妙者。无上者。无等者。无等等者。如是随喜乃名随喜

  若我所有福　　悉以为一抟
  回与诸众生　　为令得正觉

若我无始流转已来。于佛法僧及别人边。所有福聚。乃至施与畜生一抟之食。若归依善根。若悔过善根。若劝请善根。若随喜善根。彼皆称量共为一抟。我为诸众生故。回向菩提皆悉舍与。以此善根。令诸众生证无上正觉。得一切智智

  我如是悔过　　劝请随喜福
  及回向菩提　　当知如诸佛

若我为诸众生回向菩提善根。若悔过善根。若劝转法轮善根。若请长寿善根。若随喜善根。彼皆称量为一抟已。如过去未来现在诸佛世尊为菩萨时。已作回向当作回向。我亦如是以诸善根回向菩提。以此回向善根。令我及诸众生当证无上正觉。我今更略说

  说悔我罪恶　　请佛随喜福
  及回向菩提　　如最胜所说

自有罪恶尽皆说悔。及请佛转法轮。住寿长时随喜诸福。回向福等。如前回向为菩提故。如最胜人所说。如是回向问又彼回向。应云何作。答

  右膝轮着地　　一髆整上衣
  昼夜各三时　　合掌如是作

当自清净着净洁服。澡洗手足裙衣圆整。于一髆上整理上着衣已。用右膝轮安置于地。合掌一心离分别意。若如来塔所若像所。若于虚空攀缘诸佛如在前住。作是意已。如前所说。若昼若夜各三时作

  一时所作福　　若有形色者
  恒沙数大千　　亦不能容受

于彼所说六时回向中。若分别一时所作于中福德。诸佛世尊如实见者所说。彼若有色如谷等聚者。其福积集无有限量。虽如恒伽沙等大三千界尽其边际。亦不能容受。以彼回向福与虚空界等回向故。乃至一时回向。犹有如是福聚。况多回向。虽是初发心菩萨由回向力故亦成大福。还以如是相福聚故。渐次能得菩提

问已说诸菩萨得成大福方便。今欲护福用。何方便。答

  彼初发心已　　于诸小菩萨
  当起尊重爱　　犹如师父母

彼初发心菩萨。若欲护自善根及自身者。于诸初发心菩萨。当起至极尊重爱敬之心。犹如世尊一切智师及自所生父母。如是以初发心菩萨为首。于诸菩萨亦应如是极作爱重。若异于此则自身及善根皆悉灭尽。如世尊经中曾说我不见余一法障碍菩萨及灭尽善根。如于菩萨起嗔心者。若菩萨虽于百劫积集善根。由此嗔菩萨心故。皆悉灭尽。是故于诸菩萨应起尊重。犹如教师

  菩萨虽有过　　犹尚不应说
  何况无实事　　唯应如实赞

若菩萨毁呰行大乘人罪过。令得恶名。所有生生善法皆悉灭尽。不得增长白法。是故诸菩萨等虽有过恶。为护自善根命故。不应显说。何况无实。譬如王罪。如经中说。有菩萨清净活命无可毁呰。而彼达摩比丘妾说其恶故。于七十劫中受泥犁报又于六万生中为贫穷人。常受盲哑癞病恶疮。是故于菩萨所。若有恶若无恶。皆不得说。彼有实德唯应称扬。为自善根增长故。亦为余人生信故

  若人愿作佛　　欲使不退转
  示现及炽盛　　亦令生喜悦

若有众生已发愿求菩提。唯欲令其不退。而有人愚痴嗔恚及贪。自朋党故作如是言。何用长行菩萨难行之行。其涅槃乐平等相似。行声闻行疾得涅槃。此等后当说其果报。若以种种譬喻显佛功德令入其心。是为示现。令其具足精进诸菩萨行。是为炽盛。欲令精进更增疾利。为说正觉功德大神通事。是为喜悦。如是令彼不舍菩提之心

  未解甚深经　　勿言非佛说
  若作如是言　　受最苦恶报

甚深经者。谓佛所说与空无相无愿相应。除无量断常等边见。灭我人众生寿者等自性。显如来大神通希有功德。于此经律若未证知。勿以痴。故言非佛说。何以故佛世尊说。若谤如来所说之经。恶果最苦

  无间等诸罪　　悉以为一抟
  比前二种罪　　分数不能及

世尊于不退轮经中说。五无间业所有诸罪。若断三千大千世界中诸众生命所有罪报。若恒伽河沙等佛世尊灭度已所有支提。或坏或烧若障碍过去未来现在诸佛法眼所有罪报。如是等过皆悉搏聚。若于未解深经而起执着言非佛说。及菩萨发菩提愿已而令退菩提心。此二种罪。彼前五无间等罪聚比之。百分不及千分不及。乃至数分柯罗分算分譬喻分优波尼沙陀分亦不及。以是罪相故。为护自身及自善根。勿作此二种罪

问已说菩萨护自善根。何者是修道胜义。答

  于三解脱门　　应当善修习
  初空次无相　　第三是无愿

于中菩萨行般若波罗蜜时。应修三解脱门。最初应修空解脱门。为破散诸见故。第二无相解脱门。为不取诸分别攀缘意故。第三无愿解脱门。为超过欲界色界无色界故

问何故此等名解脱门。答

  无自性故空　　已空何作相
  诸相既寂灭　　智者何所愿

以缘生故法无自性。此名为空。以其空故心无攀缘。则是无相。离诸相故则无所愿。又若法从缘生。彼自性无生。以自性无生故。彼法是空。若法是空彼中无相。相无有故彼是无相。若无有相彼中心无所依。以无依故于三界中。心无所愿

  于此修念时　　趣近涅槃道
  勿念非佛体　　于彼莫放逸

修此三解脱门时。若非方便所摄。则趣近涅槃。虽应修习。莫堕余菩提处。当求无所得忍。应住善巧方便

  我于涅槃中　　不应即作证
  当发如是心　　应成熟智度

发如是心。我当利益诸众生。度脱诸众生。虽修三解脱门。不应于涅槃作证。然我为学般若波罗蜜故。于三解脱门中。专应成熟。我应修空。不应证空。我应修无相。不应证无相。我应修无愿。不应证无愿

  如射师放箭　　各各转相射
  相持不令堕　　大菩萨亦尔

譬如射师善学射已。放箭空中。续放后箭各各相射。彼箭遂多。空中相持。不令堕地

  解脱门空中　　善放于心箭
  巧便箭续持　　不令堕涅槃

如是此菩萨大射者。以学修空无相无愿弓。于三解脱门空中。放心箭已。又以悲愍众生巧方便箭。展转相续。于三界虚空中。持彼心箭。不令堕涅槃。城

问云何复令彼心不堕涅槃。答

  我不舍众生　　为利众生故
  先起如是意　　次后习相应

若我于三解脱门。善成熟已。欲取涅槃如在手掌。然我以小儿凡夫犹如饮乳。不能自向涅槃城者。未涅槃故。我于涅槃不应独入。我当如是发起精进。随我所作。唯为利益诸众生故。亦为诸众生得涅槃故。先应如是起作。次即心与三解脱门随顺相应。随顺者顺后义也。若不如是。彼之心箭。无巧方便摄故。行三解脱门时。即堕声闻解脱。若独觉解脱中。今更有巧方便

  有着众生等　　久夜及现行
  颠倒与诸相　　皆以痴迷故

小儿凡夫诸众生等。以痴迷故。于无始际流转久夜。着四颠倒。无常谓常苦谓乐。不净谓净无我谓我。及于内外众界入中。计我我所。谓有所得。久夜行已及现在行

  着相颠倒者　　说法为断除
  先发如是心　　次后习相应

如是诸众生等。以痴迷故。起我我所二种计着。又于色等无所有中。妄起分别取相。生四种邪颠倒。我为说法令其断除。先发如是心已。然后于三解脱门中。修习相应。若异此而修三解脱门者。则趣近涅槃道

  菩萨利众生　　而不见众生
  此亦最难事　　希有不可思

菩萨起众生想。此亦最难不可思。未曾有如画虚空。于最胜义中本无众生。此菩萨不知不得。而为利乐众生故。勤行精进。唯除大悲。何处更有如此难事

  虽入正定位　　习应解脱门
  未满本愿故　　不证于涅槃

此应思量。若到正定位菩萨。以三十二法故入正定位。与解脱门相应时。中间未满本愿。为证涅槃为不证。以世尊经中说云。四大可令改异。无有入正定位。菩萨中间未满本愿证于涅槃。是故到正定位菩萨。未满本愿不证涅槃

  若未到定位　　巧便力摄故
  以未满本愿　　亦不证涅槃

若初发心菩萨。未到正定位。彼以巧方便所摄故。修三解脱门时。中间未满本愿。亦不证涅槃

  极厌于流转　　而亦向流转
  信乐于涅槃　　而亦背涅槃

此菩萨于流转中。以三种炽火故。应极厌离。不应起心逃避流转。当于众生为子想故。而向流转。及应信乐涅槃。如覆护舍宅故。然复应背涅槃。为满一切智智故。于流转中若有厌离。则于涅槃亦有信乐。若不向流转不背涅槃未满本愿。修习解脱门时。则于涅槃作证

  应当畏烦恼　　不应尽烦恼
  当为集众善　　以遮遮烦恼

以是流转因故。应畏烦恼。不应毕竟尽于烦恼。若断烦恼。则不得集菩提资粮。是故菩萨以遮制法遮诸烦恼。由遮烦恼令其无力故。得集菩提资粮善根。以集善根故满足本愿。能到菩提

问何故不以断灭故灭诸烦恼。答

  菩萨烦恼性　　不是涅槃性
  非烧诸烦恼　　生菩提种子

如诸声闻圣人等。涅槃为性。以攀缘涅槃。得沙门果故。诸佛不以涅槃为性。诸佛烦恼为性。以菩提心由此生故。声闻独觉烧诸烦恼。不生菩提心种子。以二乘心种子无流故。是故烦恼为如来性。以有烦恼众生发菩提心。出生佛体故不离烦恼

问若烧烦恼。不生菩提心种子者。何故法华经中。与烧烦恼诸声闻等授记。答

  记彼诸众生　　此记有因缘
  唯是佛善巧　　方便到彼岸

不知成就何等众生。彼中因缘唯佛所知。以到调伏彼岸。不共余众生相似故。而彼不生菩提心种子者。以入无为正定位故。如经说

  如空及莲华　　峻崖与深坑
  界不男迦柘　　亦如烧种子

如虚空中不生种子。如是于无为中。不曾生佛法。亦不当生。如高原旷野不生莲华。如是声闻独觉入无为正定位中。不生佛法。峻崖者。于一切智智城道中。有二峻崖。所谓声闻地峻崖。独觉地峻崖。声闻独觉若有一切智者。则非菩萨二峻崖也。深坑者。如丈夫善学跳掷。虽堕深坑安隐而住。若不善学。而堕深坑便死坑内。如是菩萨修习无为善相应故。虽修无为而不堕无为中。声闻等修习无为不善相应。则堕无为中。界者。声闻系在无为界故。不复能于有为中行。是故彼中不生菩提之心。不男者。如根败丈夫于五欲利不复有利。如是声闻具无为法。于诸佛法利亦无有利。迦柘者。如迦柘珠。诸天世间虽善修理彼迦柘珠。终不能为鞞琉璃宝。如是声闻虽复具诸戒学头多功德三摩提等。终不能坐觉场证无上正觉。亦如烧种子者。如被烧种子。虽置地中水浇日暖。终不能生。如是声闻烧烦恼种子已。于三界中亦无生义。以如是等经故。当知声闻得无为法已。不生菩提之心

菩提资粮论卷第四菩提资粮论卷第五

        圣者龙树本　比丘自在释

        大隋南印度三藏达磨笈多译

问得力菩萨于众生中。云何应修行。答

  诸论及工巧　　明术种种业
  利益世间故　　出生建立之

于中书印算数。矿论医论。能灭鬼持被毒论等。出生村城园苑河泉陂池花果药林论等。显示金银真珠鞞琉璃贝石(石白如贝)珊瑚宝性论等。记说日月星曜地动梦相论等。相诸身分支节论等。如是等无量诸论。能与世间为利乐者。劫转坏时悉皆灭没。劫转生时还于人间出生建立。如木铁瓦铜作等。工巧非一。能灭鬼持颠狂被毒。霍乱不消食诸逼恼等。种种明术雕画绣织作等。种种事业。能与世间为利乐者。皆亦出生及令建立

  随可化众生　　界趣及生中
  如念即往彼　　愿力故受生

诸摩诃萨随何世界。若天人等趣。若婆罗门刹帝利鞞舍等生。于彼彼处。若有可化众生。为起无量思念。欲化彼等众生故。随彼色类长短宽狭音声果报。得令众生受化之事。即应作愿。起彼色类长短宽狭音声果报。令彼众生速受化故

  于种种恶事　　及谄幻众生
  应用牢铠钾　　勿厌亦勿惮

若以骂詈恐动嫌恨鞭打系闭诃责如是等恶事加我。及诸众生无量谄幻知不可化。以彼等故不应自缓铠钾。亦勿厌流转。勿惮求菩提。又应发如是心。我不为无谄无幻众生而着铠钾。我正为彼等众生着此铠钾。我当作如是事发起精进。为令彼等众生速得建立无谄无幻故。应当如是自牢铠钾

问已说得力菩萨修行。云何未得力菩萨修行。答

  具足胜净意　　不谄亦不幻
  发露诸罪恶　　覆藏众善事

具足胜净意者。谓增上意。又是善增也。意者心也。即彼心具足。名具足胜净意。不谄亦不幻者。谄谓别心。别心者不质直也。又谄者名为曲心。幻者谓诳也。若心不曲不诳。彼是不谄不幻。发露诸罪恶者。若有罪恶显说发露彼名发露诸罪恶。覆藏众善事者。若有善业竟大覆藏。彼名覆藏众善事。若菩萨欲疾得菩提。应当具足净意不谄不幻发露罪恶覆藏善事。是故世尊说云。谄非菩提。幻非菩提

  清净身口业　　亦清净意业
  修诸戒学句　　勿令有缺减

此诸菩萨欲与修念相应故。先当清净身口意业。于中杀生不与取非净行等三种身恶行。应当清净。与此相违三种身善行。应当受之。妄语破坏语粗恶语杂戏语等四种口恶行。应当清净。与此相违四种口善行。应当受之。贪嗔邪见等三种意恶行。应当清净。与此相违三种意善行。应当受之。诸波罗帝摹叉学句。亦当受而随转。于彼学句。无有知而故破。若缺漏戒者。于修念中。心则不定

  安住于正念　　摄缘独静思
  用念为护己　　心得无障心

如是于戒正清净已。断除五盖。于空闲净洁离众之处。少声少喧少蚊虻蛇虎贼等。不甚寒热不置卧床。若立若经行若结加坐。或于鼻端或于额分。回念安住随于一缘善摄作已。若于境界有躁动心。则用念为守门。如是置守护已。远离障碍贼心。独在一处无散乱意。而修习思惟

  若起分别时　　当觉善不善
  应舍诸不善　　多修诸善分

于思惟时若起分别。即于起时觉此分别。若是不善即应舍离勿令复增。若是善分唯当数数多作。不应散乱。如室中灯不闭风道

  缘境心若散　　应当专念知
  还于彼境中　　随动即令住

于中修定比丘。心思惟时专意莫乱。若心离境即应觉知。乃至不令离境远去。还摄其心安住境中。如绳系猿猴系着于柱。唯得绕柱不能余去。如是应以念绳系心猿猴系着境柱。唯得数数绕于境柱。不能余去

  不应缓恶取　　而修于精进
  以不能持定　　是故应常修

缓者谓离策勤。恶取者谓非善取(谓太急也)。若欲成就三摩提者。不应缓作及恶取精进。以缓作及恶取精进。不能持三摩提。是故修定行者。应常正修

  若登声闻乘　　及以独觉乘
  唯为自利行　　不舍牢精进

若欲登声闻乘及独觉乘。唯为自利故。自涅槃故。尚于昼夜不舍牢固精进。策勤修行

  何况大丈夫　　自度亦度人
  而当不发起　　俱致千倍进

然此菩萨应于流转河中度诸众生。亦应自度。何得不发起过彼声闻独觉乘人。俱致百千倍精进也。如自度流转之河度他亦如是

  半时或别行　　一时行余道
  修定不应尔　　应缘一境界

今此一日不应半时修习别定。余时之中复行异道。唯于一定应善缘境。心随一境。勿向余处

  于身莫有贪　　于命亦勿惜
  纵令护此身　　终是烂坏法

应当生如是心。我此身中。唯有薄皮厚皮肉血筋骨髓等。终归干枯。我此寿命亦当终尽。彼丈夫精进丈夫势力丈夫健行。我亦应得。若其未得。我于精进不应赊缓。虽复百岁护此烂身。必定当是破坏之法

  利养恭敬名　　一向勿贪着
  当如然头衣　　勤行成所愿

今此若在旷野宿住之时。勿贪身命于中游行。若有利养恭敬名闻起时。不应贪着。为自愿成就故。应速勤行。如然头衣

  决即起胜利　　不可待明日
  明日太赊远　　何缘保瞬命

彼于如然头衣勤行之时。明日赊远莫待明日。若于我身有胜利者。决即发起。应当生如是心。何缘能保开眼合眼时命。我今即起胜利。明日太远。莫待明日

  安住于正命　　如食爱子肉
  于所食啖中　　勿爱亦勿嫌

如是定行比丘。若村若僧坊中。随有如法无所讥嫌乞得食已。勿起贪心爱着。亦勿嫌之。应当安住正念。如食所爱子肉。但为身住不坏存于寿命。摄护净行故。犹如昔云夫妻行旷野时。共食子肉

  出家为何义　　我所作竟未
  今思为作不　　如十法经说

应当如是观察。我为何义故而行出家。为畏不活耶。为求沙门耶。若为求沙门者。应作是念。我于沙门之事。为已作为未作为今正作。如其未作及正作者。为成就因缘故。应当精勤。我离家类则名非类。应数思念。我之活命系在于他。我亦应作别异仪式。我自于戒得无嫌不。有智同净行者。于我戒所复无嫌不。我已与诸恩爱其相别异。不与共俱。我属于业。业之所。生受用于业。业是所亲依业而行。我所作业。若善若恶我当自受。我于昼夜云何而过。我喜乐空寂不。我有上人法不。能得圣人胜知见不。若当后时同净行者问我之时说之不惭。应数思念此等十法。所谓定行比丘。应数思念

  观有为无常　　若无我我所
  所有诸魔业　　应觉而舍离

有为谓因缘和合生。以因缘和合生故。彼无我所。以有为故彼是无常。若是无常。彼为他所逼迫故苦。若苦彼不自在转故无我。于有为法应如是观。所有诸魔业应觉而舍离者。或于菩提心六度相应经中作不欲乐因缘散乱因缘赊缓因缘障碍因缘。若从自起若从他起。皆应觉知。于此诸恶魔业。皆觉知已离之。莫令彼自在行

  根力与觉分　　神足正断道
  及以四念处　　为修发精勤

信精进念定慧。是为五根。信精进念定慧。是为五力。念择法精进喜猗定舍。是为七觉分。欲定精进定心定思惟定。是为四神足。未生恶不善法为令不生。已生恶不善法为令其断。未生善法为令其生。已生善法为令其住。生欲发勤摄心起愿。是为四正断。正见正分别。正语正业。正命正发行。正念正定。是为八分圣道。身受心法。是为四念处。此等三十七助菩提法。为修习故。发起精勤

  心与利乐善　　作传传生处
  及诸恶浊根　　彼当善观察

心若调伏守护禁系。则与诸利益安乐善事。作传传生因。若不调伏不守护不修习不禁系。则与诸无利恶浊为根知已。于彼应极观察。生住异相故。内外两间不住故。过去未来现在世不俱故。无处来故。无处去故。刹那罗婆牟呼利多时中不住故。犹如幻故。为修习故。应当观察

  我于善法中　　日日何增长
  复有何损减　　彼应极观察

若佛世尊所说。施等善法能出生菩提者。我于彼诸善法。有何增长有何损减。常应如是专精观察。日日之中。起而复起

  见他得增长　　利养恭敬名
  微小悭嫉心　　皆所不应作

若见余同净行者。或沙门。或婆罗门。增长利养恭敬名闻之时。亦不应生微小悭嫉。复应思量生如是心。我亦喜得众生利养衣服饮食卧床病缘药等众具。我亦喜得在家出家之所恭敬。我亦喜得具足可赞之法

  不羡诸境界　　行痴盲哑聋
  时复师子吼　　怖诸外道鹿

若见他人增长利养恭敬名闻之时。于色等境界中。不应稀羡。于爱不爱色声香味中。虽非痴盲哑聋。而作痴盲哑聋之行。若有力能莫常哑住。应以正法遣惑破系时到。为怖外道鹿故。及住持正教故。复当震师子吼。我已解释修心。今当解释修相。所谓

  奉迎及将送　　应敬所尊重
  于诸法事中　　随顺而佐助

于所尊重奉迎将送。于听法时花鬘供养。修理支提等法事中恭敬作故。当得手足轮相。彼又是大眷属先相

  救脱被杀者　　自然增不减
  善修明巧业　　自学亦教他

有被杀者救令解脱。护命因缘离于杀生。受此等业长夜习近故。当得长指相足跟平正相身直相。彼是长寿先相。自所受善法。受已增长不令损减故。当得足趺高如贝相毛上向相。彼二是法无减先相。善修明论工巧等业。自学及教他故。当得伊尼[跳-兆+尃]相。彼是速摄先相

  于诸胜善法　　牢固而受之
  修行四摄事　　施衣及饮食

于诸最胜善法。牢固受之。习近多作故。当得善安立足相。彼是能作事业先相。修行四摄布施爱语利行同事。常习近故。当得手足网相。彼亦是速摄先相。以妙饮食衣服布施。常习近故。当得柔软手足相七处高相。彼二是得上妙饮食甜味。及衣服等先相

  不违乞求者　　和合诸亲戚
  眷属不乖离　　施宅及财物

随所有物。若来求者。即施不违逆故。当得臂髀佣圆相彼是自在调伏先相。和合亲眷朋友共住。不令各各乖异。若乖异者亦使和合故。当得阴密藏相。彼是多子先相。布施舍宅财物。及施上妙床敷衣服堂殿宫等故。当得金色相细滑薄皮相。彼二是得上妙床敷衣服堂殿宫等先相

  父母及亲友　　随所应安置
  所应安置处　　无上自在主

忧波弟邪夜(隋云近诵旧云和上者略而讹)阿遮利夜(隋云正行旧云阿阇梨者亦讹)父母兄弟等。所尊重者。随所应处安置。为无上自在主故。当得一孔一毛相白毫印面相。彼二是平等先相

  虽复是奴仆　　善说亦受取
  应生最尊重　　施药愈诸病

施药愈诸病者。于病人所。施药给侍将息饮食。以给侍将息。病即能起故。当得髆间平满相味中上味相。彼二是少病先相

  前行善业首　　细滑美妙言
  善为正意语　　前后无不供

前行善业首者。园林会堂义井花池饮食花鬘。于难行处起桥。及造僧坊游处等中。劝励他人自为前导。所施过他故。当得尼瞿嚧陀普圆身相顶髻相。彼二是胜主先相。细滑美妙言者。长夜真实细滑语故。当得广长舌相梵音相。彼二是得五分五分语道具足音先相。五分五分语道具足音者。一者可知。二者易解。三者乐闻。四者不逆。五者深。六者宽远。七者无嫌。八者悦耳。九者辩正。十者不杂(二种五分故有十也)。善为正意语者。长夜实语正意语故。当得师子牙相。彼是爱语先相。前后无不供者。他人虽有前后。然皆供养无不供养。以如法威仪平等威仪故。当得齐平齿相细滑齿相。彼二是善净眷属先相

  不坏他眷属　　慈眼观众生
  亦不以嫌心　　皆如善亲友

于诸众生。作怀抱慰喻摄受之心。以不贪不嗔不痴眼观故。当得青眼相牛王眼睫相。彼二是爱眼观先相

我已解释三十二大丈夫相出生之业。别有种种菩萨之行。今当解释

  应当如所言　　即随如是作
  如言若即作　　他人则生信

应当如言即如是作。若如所言即如是作。他则生信。随有言教。即当信受

  应当拥护法　　觉察放逸者
  及作金宝网　　罗覆于支提

于此法中应自拥护。若有背法放逸众生。于彼亦应方便觉察令其向法。及于如来支提之所。应以种种宝网罗覆。为令相好满足故

  有欲求婇女　　庄严以施之
  亦与说佛德　　及施杂光璎

若有求婇女者。即便庄严婇女。而以布施。此诸婇女普皆端正。以此布施。为令自意所求爱事皆满足故。又以无量异种。说佛功德之法。应在集会之处。高出美妙悦意之声。而为演说。为得诸声分清净故。又以种种光明照曜璎珞之具。悦彼心眼而以布施。为得诸随形好满足故

  造作佛形像　　端坐胜莲花
  及于六法中　　修习同喜乐

以金银真珠贝石等造作佛像。坐胜莲花。为得化生。及为得佛身故。六种同喜法者。于彼同梵行中。慈身业口业意业。不分受用物。戒具足见具足。此等六种同喜法中。应数习近。为得徒众。不被诸外论众所坏故

  可供无不供　　为命亦不谤
  佛之所说法　　及以说法人

可供无不供者。于中应可供养。所谓和上阿阇梨父母兄等。无不供养者。无不敬畏。虽为活命。终不谤法及此说佛法人。亦不应谤。不应轻欺。为护自善助故

  金宝散教师　　及教师支提
  若有忘所诵　　与念令不失

应以金银散于教师。亦应以摩尼金宝散教师宝支提。菩萨有三摩提。名现在佛对面。住此等三摩提。于生生中。现前修习为得闻持故。若有众生忘失所诵引世利乐经书。于彼众生。与作忆念。为不忘失菩提心故。及为得忆念现知故

  未思所作已　　勿躁勿随他
  外道天龙神　　于中皆莫信

所作业行。若身口意。于中诸处。若未思所作已。勿为躁急。亦勿随他。应如是行。若异于此则生热恼亦是悔因。于游行出家尼揵等诸外道及于天龙夜叉揵闼婆等中。皆不应信

  心应如金刚　　堪能通诸法
  心亦应如山　　诸事所不动

安置其心应如金刚。有慧力堪能故。于诸世出世法中。如其自性如实通达。于诸事中安置其心。亦应如山。八种世法。所不能动

  喜乐出世语　　莫乐依世言
  自受诸功德　　亦应令他受

或有言说能出世间。若与佛法僧相应。若与六度相应。若与菩萨地相应。若与声闻独觉地相应。彼中应作喜乐。或有言说依止世间。增长世间。与贪嗔痴相应。彼中不应喜乐。若有诸受戒学头多等殊胜功德善人所赞所受取者。于彼等中皆应受取。亦应令他受此功德

  修五解脱入　　修十不净想
  八大丈夫觉　　亦应分别修

于中解脱入者。一者为他说法。二者自说法。三者自诵法。四者于法随觉随观。五者取随何等三摩提相。此是五解脱入。应当念修。十不净想者。谓膖胀想。青瘀想。脓烂想。溃出想。啖想。断解想。分散想。血涂想。肉落想。骨想。此是十不净想。贪若生时应当念修。本为断除欲贪故。八大丈夫觉亦应分别修者。于中有八大丈夫觉。谓少欲是法多欲非法。是为初觉。知足是法不知足非法。是为第二。远离是法杂闹非法。是为第三。发精进是法懈怠非法。是为第四。安住念是法忘失念非法。是为第五。入定是法不入定非法。是为第六。智慧是法无智慧非法。是为第七。不乐戏论是法乐戏论非法。是为第八。此等八大丈夫觉。应当觉之。多欲等八不善助。应当断除

  天耳与天眼　　神足与他心
  及与宿命住　　应修净五通

于中天眼天耳忆念宿住知他心神足。此等五种智通。应当修习

菩提资粮论卷第五菩提资粮论卷第六

        圣者龙树本　比丘自在释

        大隋南印度三藏达磨笈多译

问云何修习答

  四神足为根　　欲进心思惟
  四无量住持　　谓慈悲喜舍

于此四无量中。习近多作已。得心堪能。得心堪能已。便入初禅那。如是第二。如是第三。如是第四。彼得禅那已得身心轻。彼以身心轻具足故。出生入神通道。出生入神通道具足故。便生神足。谓若欲若精进若心若思惟。于中欲者向法。精进者成就法。心者于法观察。思惟者于法善巧。彼菩萨于神通若信解若作用。其心自在。随欲所行。以善成熟故。自根本住持故。诸处顺行如风遍空。于中菩萨得四无量及四禅那已。若信解若作用。出生天眼。若诸天龙夜叉乾闼婆等。若学人及声闻独觉天眼于中独有增上之力。清净胜过光明胜过。上首胜过殊异胜过。其眼无碍世间色相粗细远近。随其所欲彼皆能见。如是闻天人畜生等声。如是念知前世无边无际。如是知他心与贪欲等俱乃至八万四千差别。如是得无量神足。以得神足故。诸所应调伏众生。悉令调伏

  四界如毒蛇　　六入如空村
  五众如杀者　　应作如是观

长夜以诸乐具受用因缘。虽守护将息长养。此地等四界。而速疾发动。不知恩养。不可依怙。不可委信故。应当观察犹如毒蛇。以无主故。离我我所故。眼等诸入有六贼众。逼恼可畏故。应当观察犹如空村。共和与物破坏打罚不能遮障故。犹如杀者。于五受众。应当日日如是观察

  重法及法师　　亦舍于法悭
  教师勿卷秘　　听者勿散乱

于此有四种法。能生大智。应当受取。于法及法师中应当尊重。亦舍法悭。随所闻法随所习诵。为他演说。若有乐欲法者。教师勿为卷手秘惜。听者勿散乱。谓莫有异欲

  无慢无希望　　唯以悲愍心
  尊重恭敬意　　为众而说法

复有四种法。是大智相。应当受取。所谓远离自高轻他。无憍慢故。弃舍利养恭敬名闻。无希望心故。于无明闇障众生中唯悲愍故。尊重恭敬为其说法。以此四种法故。菩萨大智具足。应当受取

  于闻无厌足　　闻已皆诵持
  不诳尊福田　　亦令师欢喜

多闻无厌。闻已持法。持法已顺法行法。不诳所尊福田。亦令教师欢喜此法。是菩提心不忘失因

  不应观他家　　心怀于敬养
  勿以论难故　　习诵于世典

不应为供养恭敬因缘往观他家。除为安立菩提心因缘。亦不应欲为论难故习诵诸世论等。除为多闻因缘

  勿以嗔恚故　　毁呰诸菩萨
  未受未闻法　　亦勿生诽谤

何以故。为护续生善法因缘

  断除于憍慢　　当住四圣种
  勿嫌于他人　　亦勿自高举

断除憍慢者。于诸众生中。当下心如狗断除我慢。于轻俭衣食卧床药具四圣种中亦应当住。于彼圣种知足故。不应嫌他。亦不应自高举

  若实不实犯　　不得发觉他
  勿求他错失　　自错当觉知

他同梵行者犯罪。若实若不实。皆不应发觉。他有错失不应求觅。唯于自错。即应觉知

  佛及诸佛法　　不应分别疑
  法虽最难信　　于中应信之

于佛不应分别。以世尊具足未曾有法故。亦于佛法不应疑惑。以于诸众生是不共法故。及于最难信佛法中。以深心清净故。应当信之

  虽由实语死　　退失转轮王
  及以诸天王　　唯应作实语

若菩萨由实语故。若夺物若死。虽退失转轮王及诸天王。唯应实语。何况其余而不实语

  打骂恐杀缚　　终不怨责他
  皆是我自罪　　业报故来现

诸有他来打骂恐怖杀缚幽闭。皆是自罪应当有此。终不嗔他。此是我业前世已作。今时还受相似不爱之果。彼诸众生都无有罪。唯是我罪业报来现。应当有此

  应极尊重爱　　供养于父母
  亦给侍和上　　恭敬阿阇梨

于父母所。应当极爱尊重供养。应作天想。随父母意令得悦乐。离谄幻心。又应恭敬给侍和上阿阇梨。随和上阿阇梨所说法中。无有内秘。皆为外化

  为信声闻乘　　及以独觉乘
  说于最深法　　此是菩萨错

此中菩萨。有四种菩萨错失。应当舍离。所谓于声闻独觉乘诸众生中。为说最深之法。是菩萨错

  为信深大乘　　众生而演说
  声闻独觉乘　　此亦是其错

于信深大乘诸众生中。为说声闻独觉乘。是菩萨错

  大人来求法　　慢缓不为说
  而反摄受恶　　委任无信者

若有正住大众生。来有所求时。应即为说善法。而更慢缓破戒恶法。反摄受之。是菩萨错。于大乘中未有信解。未以四摄事成熟者。而信任之。是菩萨错。是为四种

  远舍所说错　　所说头多德
  于彼当念知　　亦皆应习近

此中所说四种错失。应远舍离。以此去菩提远故。若声闻独觉乘中所说。头多等及余功德。但知彼等不与菩提作障碍者。于彼彼中。亦应习近

  等心平等说　　平等善安立
  亦令正相应　　诸众生无别

此四种菩萨道。应当习近。何等为四。所谓诸众生中起平等心。诸众生中平等说法。诸众生中平等善安立。诸众生中令正相应。此等皆无差别。是为四种

  为法不为利　　为德不为名
  欲脱众生苦　　不欲自身乐

此四种真实菩萨。应当觉知。何等为四。所谓但为于法不为财利。但为功德不为名称。但欲脱众生苦。不欲自身安乐

  密意求业果　　所作福事生
  亦为成熟众　　舍离于自事

若于业果密意欲求。作三福事。生此福时。唯为菩提利乐众生。亦唯为菩提成熟于众。为利众故舍离自事。此是四种真实菩萨

  亲近善知识　　所谓法师佛
  劝励出家者　　及以乞求辈

此四种菩萨善知识。应当亲近。何等为四。所谓法师是菩萨善知识。为助持闻慧故。佛世尊是菩萨善知识。为助持诸佛法故。劝出家者是菩萨善知识。为助持诸善根故。乞求者是菩萨善知识。为助持菩提心故。此四种菩萨善知识。应当亲近

  依止世论者　　专求世财者
  信解独觉乘　　及以声闻乘

此四种菩萨恶知识。应当知之。何等为四。所谓世论者。习近种种杂辩才故。摄世财物者。不摄法故。独觉乘者。少义利少作事故。声闻乘者。自利行故

  此四恶知识　　菩萨应当知
  复有应求者　　所谓四大藏

如前所说四种知识。是恶知识知已应离。复有应求得者。所谓四大藏

  佛出闻诸度　　及于法师所
  见之心无碍　　乐住空闲处

此四种菩萨大藏。应当得之。何等为四。所谓奉事出世诸佛听闻六波罗蜜。以无碍心见于法师。以不放逸乐住空闲之处。此是四种菩萨大藏。应当得之

  地水火风空　　悉与其相似
  一切处平等　　利益诸众生

与地水火风虚空等。有二因缘相似菩萨。应当摄受。所谓平等故。利益故。如地等大及虚空五种。于有心无心中一切处平等。无有异相。诸众生等常所资用。而无变异不求报恩。我亦如是。乃至觉场究竟。为诸众生之所资用。而无变异不求报恩

  当善思惟义　　勤生陀罗尼
  勿于听法者　　为作于障碍

义者。佛所说义。于彼当善思惟。若共谈若独住。应如是作。又安住禁戒清净心意。精勤鲜洁当生及闻银主海主等陀罗尼。又于听法者所。勿以微少因缘而作障碍。为离法灾生业故

  恼中能调伏　　小事舍无余
  八种懈怠事　　皆亦应除断

恼中能调伏者。于中有九种恼事。所谓于我作无利益。已作今作当作。是为三种。于我亲爱作无利益。已作今作当作。复为三种。于我憎嫌与作利益。已作今作当作。复为三种。此等皆作恼事。于此九种恼事之中。当自调伏。小事舍无余者。于中有二十种小事。所谓不信(一)无惭(二)谄幻(三)掉(四)乱(五)放逸(六)害(七)无愧(八)懈怠(九)忧(十)昏(十一旧睡)睡(十二旧眠)恨(十三)覆(十四)嫉(十五)悭(十六)高(十七)忿(十八)悔(十九)闷(二十)

此等二十种小事。皆舍无余。八种懈怠事皆亦应除断者。于中有八种懈怠事。所谓我欲作务即便安卧。不发精进(一)。我作务已(二)。我于行路(三)。我行路已(四)。我身疲乏。不能修业(五)。我身沉重。不能修业(六)。我已生病(七)。我病得起不久即便安卧。不发精进(八)。由此等故。应得不得应到不到应证不证。此等八种懈怠事中。为除断故。应发精进

  莫作非分贪　　横贪不称意
  离者皆令合　　无问亲非亲

若见具足利养名闻安乐称誉福德众生。于彼具足福中。莫作非分贪心。以作非分贪心则不称意。是故所不应作。又于各各共诤离坏众生中。无问亲与非亲。皆令和合。同心相爱

  于空而得空　　智者莫依行
  若当得于空　　彼恶过身见

依空拔除大无智聚故。智者莫依得空而行。若依得空而行。则于有身见人。难治过之恶亦过之。以诸见行由空出离。若着空见彼不可治。以更无令出离故

  扫涂与庄严　　及多种鼓乐
  香鬘等供具　　供养于支提

于如来支提及形像所。扫地涂地香鬘烧香末香华盖幢幡等。庄严供养之具。当作供养。为得端正戒香自在故。贝笛箜篌腰鼓大鼓雷鼓拍手等。种种鼓乐供养。为得天耳故

  作种种灯轮　　供养支提舍
  施盖及革屣　　骑乘车舆等

支提舍中。应以种种香油酥灯鬘等善作供养。为得佛眼故。布施伞盖皮鞋象马车舆乘等。为得菩萨无上神通乘不难故

  专应喜乐去　　乐知信佛得
  喜乐给侍僧　　亦乐闻正法

于中菩萨。常应如是喜乐于法。莫喜五欲福乐。当知信佛所得之利。莫唯信乐见于色身。当于僧中以诸乐具常喜给侍。莫唯喜诣问讯而已。常喜闻法无有厌足。莫唯喜乐暂闻其语

  前世中不生　　现在中不住
  后际中不到　　如是观诸法

因缘和合力故。及无所从来故。前世中不生念念破灭故。及不住故。现在中不住灭无余故。及无所至去故。后际中不到。应当如是观察诸法

  好事与众生　　不求彼好报
  当为独忍苦　　不自偏受乐

菩萨于诸众生。当以好事而利乐之。自不希望彼等众生利乐好事。及诸众生有无量苦相。我独为其忍受。我有乐具。与诸众生。受用为乐

  虽足大福报　　心不举不喜
  虽贫如饿鬼　　亦不下不忧

虽住大具足福报天中。其心不作喜之与举。虽为饿鬼贫穷破散逼恼此最难活。不应生下心。亦复不应忧。何况人道贫穷破散

  若有已学者　　应极尊重之
  未学令入学　　不应生轻蔑

若有已学众生。于彼应作至极尊重。若未学者应令彼等入学。亦不应轻蔑之

  戒具者恭敬　　破戒令入戒
  智具者亲近　　愚者令住智

戒具足人应当问讯。合掌向礼等而恭敬之。亦应为彼说持戒福。若破戒者应令入戒。亦应为彼说破戒罪。智具足者。应当亲近。亦应为彼显智慧德。愚者应令住智。亦应为彼演愚痴过

  流转苦多种　　生老死恶趣
  不怖此等畏　　当降魔恶智

菩萨于流转中。流转多种。生老死忧悲苦恼等。地狱畜生饿鬼阿修罗恶趣等。不应怖畏。唯当降伏恶魔恶智

  所有诸佛土　　抟聚诸功德
  为皆得彼故　　发愿及精进

十方无量诸佛国土。若佛土具足。若佛土庄严。若从诸佛菩萨闻。若自见之。彼皆抟聚殊胜功德。皆令彼等入到自佛土中。应当作如是愿。随所愿即随成就。亦应如是精勤修行

  恒于诸法中　　不取而行舍
  此为诸众生　　受担欲荷负

以取故苦不取故乐。作是念已。恒于诸法不取而舍。虽不取而舍。若此先时为趣菩提故。作愿受担众生。未度者我当度。未脱者我当脱。未寂灭者我当寂灭。此应荷负为诸众生故

  正观于诸法　　无我无我所
  亦勿舍大悲　　及以于大慈

说诸法无所有。如梦如幻故。诸法无我。其无我所者观无相故。如是以最胜义法。观此相时。然于众生亦不舍大悲及以大慈。如是应当倍复称量叹言奇哉。彼诸众生痴闇所覆。着我我所。于此最胜义道法中。而不觉知。我当何时。令彼众生于此最胜义道法中而得觉知。是为于众生中不舍大悲及以大慈

  胜过诸供养　　以供佛世尊
  彼作何者是　　所谓法供养

若有以诸供具。供养诸声闻独觉菩萨及佛世尊。所谓或以诸华香鬘末香灯轮供养。或以诸盖幢幡供养。或以诸音乐等供养。或以诸药美饮食等布施供养。若欲胜过彼诸供养以供养佛。复何者是。答言所谓法供养。彼法供养复有何相

  若持菩萨藏　　及得陀罗尼
  入深法源底　　是为法供养

于中若与菩萨藏相应。如来所说经等甚深明相背诸世间难得其底。难见微细无著了义。以总持经王印印之。不退转因从六度生。善摄所摄顺入助菩提法合正觉性。入诸大悲说于大慈。离众魔见善说缘生。入无众生无命无长养无人。与空无相无愿无作相应。坐于觉场转于法轮。为天龙夜叉乾闼婆之所赞叹。度在家泥摄诸圣人。演说诸菩萨行。入法义辞乐说之辩。震于无常苦无我等音声之雷。怖诸外论见得之执。诸佛所叹对治流转示涅槃乐。如是等经若说若持观察摄取。是名法供养。又法供养者。得不退堕顺行总持故。于空无相无愿无作相应深法中。入至其底无动无疑。是名最胜义中法之供养

  应当依于义　　莫唯爱杂味
  于深法道中　　善入莫放逸

又法供养者。若于法中思法行法。随顺缘生离诸边取之见。得无出无生忍入于无我。于因缘中无违无斗无诤离我我所。应当依义。莫爱驰逐杂饰句味。应当依智莫依于识。依了义经莫着不了义世俗言说。应当依法莫取人见。应当随顺如实法行入无住处。善观无名行识明色六入触受爱取有生老死忧悲苦恼困极。皆悉寂灭。如是观缘生已引出无尽。以愍念众生故。不着诸见不作放逸。若常如此。乃名无上法之供养

  如是此资粮　　恒沙等大劫
  出家及在家　　当得满正觉

如前所说资粮于恒伽沙等量大劫中出家众及在家众菩萨乘者。多时满愿得成正觉

  系彼资粮颂　　为菩提思惟
  资粮义无阙　　能如在彼颂
  我今择彼颂　　于义或增减
  善解颂义等　　贤智当忍之
  释彼资粮颂　　我所作福善
  为流转众生　　当得正遍觉

圣者龙树所作菩提资粮论竟。我比丘自在解释竟

菩提资粮论卷第六


七佛赞呗伽他

    No. 1682

七佛赞呗伽他

        西天中印度摩伽陀国那烂陀寺传教大师三藏赐紫沙门臣法天奉　诏译

毗婆尸佛赞　惹(仁拶反)誐捺麌(二合)龙勇(二合反)秫啰曩啰路(引)迦布(引)[口*爾]镫(一句)讫哩(二合)播(引)钵吒用(二合反)跛啰呬怛谟(引)乞叉(二合)祢(泥曳反)舍亘(二句)尾钵始也(二合)能(上)底哩(二合)婆(去)嚩(武钵反)摩护伽播(引)啰[口*儼](三句)曩么(引)弭镫苏(上)誐哆(去)誐底孕(二合反)怛他(去引)誐怛荫(二合反引四句)

式弃佛赞

阿(去)难(上)哆播(引)嚟婆(去)嚩(无可反)娑(去引)誐嚟悉弭(二合二句)[寧*吉](重呼)么惹拽(二合反)么(引)能(去)钵啰(二合)舍铭(引)乞史也(三合)路(引)亘(二合)钵啰(二合)迦(去引)始姤(引)曳曩醯哆(去)野达(转舌呼)谟(去引三句)曩谟(引)窣堵(二合)怛萨昧(二合)式企(引)宁[口*爾]曩(引)野(四句)

毗舍浮佛赞

鑁(无满反)尾湿嚩(二合)部吻(无肯反)没邓(一句)赞捺啰(二合引)迦(去)地揭帝惹(仁左反)僧(去二句)娑(引)誐嚧伽弭嚩(引)誐(引)邓(三句)倪野(二合反)祢(泥曳反)曩尾曩曳曩拶(四句)

俱留孙佛赞

野萨拽(二合反)弩(鼻音重呼)啰始铭(二合短呼)钵啰(二合)底(丁以反)昧哩野(二合)戍(引)鼻(一句)啰[口*楞](去引)讫哩(二合)哆(引)婆(去引)底(丁以反)嚩(武钵反)逊驮哩琰(二句)噢努沬嚩(二合)囕补涩播(二合)弭嚩(引)那部(二合)镫(三句)镫鑁(无满反)祢(泥曳反)讫啰(二合)矩璨捺摩贺(引)母[寧*頁](宁顶反引)捺囕(二合引四句)

迦诺迦牟尼佛赞

尾娑(去)哩拏(引)尾誐怛沫[口*(隸-木+士)]曩唧怛娑(去一句)尾啰(引)[口*儗](霓以反)拏(引)萨怛怛醯哆(去引)弩(鼻音)迦(去引)哩拏(重呼二句)喝怛怛谟(引)尾誐多沬[口*(隸-木+士)]曩曳曩镫(三句)苏(上)啰(引转舌呼)唧镫揭曩揭母[寧*吉]曩么(引)么野(二合引)憾(四句)

迦叶波佛赞

钵啰(二合)怛钵怛(二合)左(引)弭迦啰啰湿铭(二合)偶(引)[口*陵](去一句)娑贺娑啰(二合)素哩野(二合引)地迦(去声呼)祢(泥曳反引)钵哆(二合)帝惹(仁左反)僧(去二句)路句(引)怛懵萨(转舌)嚩(无可反)惹(仁左反)曩(引)鼻吻(无肯反)宁孕(二合反三句)吻那(去引)沬野(二合反)憾迦(引)舍钵曩(引)么地[口*孕](四句)

释迦牟尼佛赞

(此赞一首先已到中夏流行出正密三藏新赞集中收录)

嚩(无个反)抧野(二合反)秫惹[口*(隸-木+士)]钵啰(二合)底(丁以反)冒(重呼)[亭*夜]路(引)亘(一句)素哩琰(二合引)秫惹[口*(隸-木+士)]哩嚩(武钵反)钵那么(二合)讪(去)赧(二合二句)愈[寧*吉]没哩(二合)哆(入)设抧也(二合反)母[寧*吉]钵啰(二合)祢(泥曳反)钵(三句)萨怛(二合)萨昧(二合)曩莫播啰么迦(引)噜抳(尼整反)迦(引)野设(引)悉底哩(三合引四句)

当来化主慈氏菩萨赞

昧怛[口*(隸-木+士)](二合)野曩(引)么(引)睹史哆(引)攞野萨吐(二合一句)野萨曳(二合反)迦(去)惹曩么(二合引)怛哩哆(引)醯冒(重呼)地(二句)噜怛钵(二合)餐(入)帝嗫苏(上)誐哆(入)毕[口*栗](二合)体尾琰(二合反三句)萨(转舌)嚩(无可反引)怛么(二合)曩(引)憾(胡敢反)钵啰(二合)拏妒(引)湿铭(二合)怛萨昧(二合四句)

回向结赞一首

窣堵(二合)怛嚩(二合引)么野(引)飒钵哆(二合)[口*爾]曩(引)曩底(丁利反)哆曩曩(引)檗镫左(引)瑟吒(二合)么冒(重呼)地萨怛鑁(二合)野怛奔(去二合)抳野(二合反)[牟*含](牟敢反)娑(去)儞(泥以反)怛么钵啰(二合)弭琰[寧*吉]啰(引)沫野(引)悉帝(二合)曩婆(去)鑁(无满反)睹萨怛缚(二合引)飒钵哆(二合)[口*爾]曩萨怛(二合)嚩(无博切)三(去)么(引)钵哆(下字入声呼二合)

  过去七佛我赞竟　　未来慈氏次称扬
  我所造福利无边　　愿诸众生皆解脱

七佛梵赞一卷


揵稚梵赞

    No. 1683

揵稚梵赞

        西天译经三藏朝散大夫试鸿胪少卿明教大师臣法贤奉　诏译

夜布里鑁(二合)冒地谟隶(引)啰尾誐摩曩波替(引)摩(引)啰誐(引)誐淩(二合)誐誐(引)誐淩(二合一)誐誐(引)誐凌(二合)誐(引)誐誐(引)誐里(二合)伽曩伽伽曩伽伽里(二合)驮驮散曩驮迦刹(二)夜悉怛里(三合)鼻里祢(二合)尾野(二合)噜辈(引)里努努钵底努努鼻里努(二合)努努鼻里努(二合)努鼻(三)刍畔乃嚩努夜(引)多酥啰曩啰曩弥多钵(引)多嚩设(引)枳野(二合)僧贺(四)

夜建那里波(二合)讷婆(二合)曩(引)喃(引)迦贺迦贺迦迦贺(引)贺(引)呬贺底钵啰(二合)贺(引)赛(一)里野(二合)悉弥(二合)曩(引)拏寅(二合)摩啰赧(引)曩致多多致怛吒(引)怛(引)致致底钵啰(二合)罗(引)辈(二)俱怛俱(二合)度度俱怛俱(二合)唧怛俱(二合)啰唧俱贺啰唧多枳(二合)迦啰(引)赧(引)左嚩(引)讷鼻(三二合)努(引)怛怛啰(三合)酥窣睹(二合)噪(引)摩野(二合)酥噜(二合)多娑迦罗扇(引)多曳(引)冒(引)谟儞寅(二合)捺啰(四二合)部噜(二合)刹(引)播(引)波绀(二合引)誐畔誐娑摩(二合)啰舍啰娑罗娑怛波(二合)刹摩(二合)多(引)啰(引)刹波(引)带(引一)钵闹(二合)嗏(引)喃殑誐曩(引)喃(引)罗隶多部惹罗多(引)罗(引)娑隶罗(引)钵旦誐(二引)娑没里(二合)拏(引)娑悉弥(二合)堵讫帝(二合引)迦罗没里(二合)努末度啰(引)谟(引)那啰昧(引)嚩租(引)鼻(三)部览(二合)旦唧(引)堵(引)曩唧怛赖(二合)娑摩(二合)啰嚩罗惹曳努野写怛娑昧(二合引)曩谟(引)窣睹(四二合)

乌里尾(二合)散左(引)罗演多佉啰尸啰儞迦里界(二合引)娑他(二合引)那演堵(引)怛多(二合)里羼(一)入嚩(二合)罗(引)鼻骨噜(二合)驮嚩呬儞(二合)入嚩(二合)罗多捺舍祢舍刍(引)婆演堵(引)没啰始(二)呬(引)路怛佉(二合引)多(引)悉作羯啰(二合)羯啰(二合)迦左钵跓啰嚩(引)啰(引)尾尼所(二合)摩(引)啰尾啰(三引)昧(引)怛里(二合)设悉怛里(三合引)拏曳(引)曩钵啰(二合)娑婆摩鼻[口*爾]多(引)钵(引)多冒(引)噪(引)谟儞寅(二合)捺啰(二合四)

[口*爾]尾塞普(二合)里惹敢(三合)惹多俱(引)波钵啰(二合)迦致多尾迦吒(引)塞普(二合引)吒儞里瞿(二合引)沙瞿(引)啰(一)誐里惹敢(三合)[口*爾]谟多惹啰钵啰(二合)迦吒誐惹伽竨吒句(二合引)波嚩探(引)驮迦(引)览(二)散那里布(二合引)那(引重)摩嚩呬儞(二合)塞普(二合)啰那悉枳啰尼所(二合)讷婆(二合)悉多(引)世(引)沙尾孕(二合)[牟*含](三)补瑟闭(二合引)数赛(引)尔野(二合)谟载(引)昨贺(二合)致底尾伽致旦曳(引)曩没驮三冒(引)弟野(二合引)多(四)

祢吠啰(引)迦邻拏(二合)布里迦摩罗那罗尔鼻波刹摩(二合)隶罗(引)尾路(引)赖(一引)婆(引)嚩悉尔(二合)誐吠(二合引)里尾(二合)那誐吠(二合引)钵啰(二合)左隶多罗隶带娑悉弥(二合)带(引)里部(二合)尾罗(引)赛(二引)尔(引)怛赖(二合)里摩(二合引)览誐曩(引)喃(引)波里誐多啰婆赛(引)里路(二合引)呬旦(引)带(引)啰扇(引)带(三引)曩(引)讫里(二合)瑟吒(二合)萨里嚩(二合)他(引)野娑多(二合)摩贺没里(二合)史嚩览摩(引)多努钐曩摩(引)弥(四)努(引)讷婆览(三合引)旦野写唧旦塞普(二合)吒尾迦吒娑致界(二合引)僧迦致界(二合引)里路(二合)罗尔贺吠(二合引一)摩里界(二合)输罗(引)誐啰(二合)贺悉带(二合)里誐(二合)惹睹啰誐目契(引)僧贺娑(引)里努(二合)罗嚩讫怛赖(三合引二)钵啰(二合)尔愈(二合)摩多(二合)迦(引)摩祢(引)嚩悉怛里(三合)拏嚩那誐尼堵(引)曳(引)曩僧娑(引)啰鼻噜(三)三没驮播(引)睹愈瑟曼(二合引)尾野(二合)波誐多噜数(引)路(引)迦曩(引)度(引)谟尔寅(二合)捺啰(二合四)

阿刍(引)婆野(二合引)野写没弟里驮啰尼曩誐曩祢娑誐览部(引)驮啰讷鼻(一二合)里誐(二合)里惹(二合)讷鼻(二合)里摩(二合引)啰尾里(引)里尾(二合)里嚩设多目契(引)里瞿(二合)啰噜辈(引)啰喃带(引二)曳(引)曩(引)噪(引)补瑟波(二合)计(引)都悉怛里(三合)拏嚩那誐尼多萨里嚩(二合)尾弟多啰(引)誐(三)娑室里(二合)曼(引)没驮尾啰迦噜沙婆野贺啰钵睹冒尔里尾(二合)迦(引)啰(四)

摩(引)啰(引)尔(引)计(引)里摩(二合)护(引)契(引)啰悉波啰秫驮努设讫帝(二合)输(去)罗(引)誐啰(二合)贺悉帝(二合引一)噜迦(引)波(引)带(引)啰尔(引)计(引)里那(重二合)贺曩波跓啰吠(引)里鼻(二合)瑟尼所(二合)里鼻(二合)摩曩(引)乃(二引)曩刍特鑁(二合)野写唧旦诣里里嚩曩左楞誐(引)嗏波里演(二合)迦嚩淡(三)旦曼祢(引)晚那尔演怛里(二合)婆嚩婆野贺览没驮尾览酥尾览(四)

乌载(引)啰吒吒贺赛(引)钵啰(二合)迦吒波跓怛吒(引)满驮健吒(引)啰赧旦(一)散吒(引)波(引)塞普(二合引)吒吒降(二合)迦塞普(二合)吒惹致罗惹致紧迦啰(引)俱(引)吒罗(引)刹(二引)婆誐喃(二合)迦里睹(二合)曩设讫多(二合引)波跓波吒贺跓娑颇(二合引)罗曩野写冒(引)冒杲(二合三)怛里(二合)钵多(二合引)喃(引)誐里(二)驮啰俱致波跓波吒贺波跓酥娑多(二合)冒(引)没驮里啰(四)

俱(引)建赧啰(引)摩览赧钵啰(二合)底婆野俱贺赧涅里波(二合)拏赧啰拏赧(一引)赧曼泥淫(二合)曼拏泥淫(二合)摩尼所(二合)贺尼所(二合)贺迦尼所(二合)憾悉怛览(三合)誐罗悉怛览(二三合)誐罗娑怛览(三合)昨贺(二合)没览(二合)砌没览(二合)昨贺(二合)砌没览(二合)佉谟佉谟具具曼(引)具具曼(引)共具曼共(三)曀鼻里嚩(二合引)乃(引)里曩(二合)鼻多酥啰啰啰弥多半(引)多嚩设枳野(二合)僧贺(四)

焰摩(引)啰左(引)啰驮(引)啰三摩野娑摩(引)览婆三览婆目讫旦(一二合)曩讫旦(二合)喃(引)殑(引)誐曩(引)喃(引)目佉迦摩罗嚩喃室里(二合)尾波刹迦波叉(二)三摩野三冒(引)地罗刹弥(二合)设始曩弥嚩舍啰怛矫(二合引)谟祢三钵啰(二合)曳(引)祢(三引)怛细(引)焰驮摩努底特嚩(二合)曩底婆誐嚩堵(引)达里摩(二合)啰(引)惹写巘尼(四)

尔伽喃(二合)曩钵啰(二合)钵多(二合)怛里(二合)钵底(二合)叉拏摩闭尾佐啰底演(二合)多俱(引)演那览多(一)旦尔刹钵多(二合引)尔野(二合)唧多(引)俱噜多酥左里帝(引)瑟姹(二合引)那览萨里嚩(二合)迦览(二)伊怛淡(二合)啰怛曩(二合)怛啰(二合)夜(引)诣野(二合)弥嚩嚩贺底谟护钵啰(二合)尼喃(引)野写世(引)沙(三引)曳(引)钐曼那(引)野摩(引)曩(引)钵啰(二合)体多目佉啰祢誐曼(二合)拏罗(引)达里摩(二合)巘尼(四)

曼里多(二合引)拏曼拏罗(引)弥冒(引)努誐赧尾[口*爾]底野(一二合)婆底贺底里体(二合)迦惹喃[口*爾]曩舍娑喃左(二)览啰摩野(二合)帝(引)驮啰尼曼拏罗曼拏曩写(三)巘尼夜摩写惹野泥淫(二合)尼摩嚩怛钵啰(二合)赞拏(四)

夜室左(二合)怛鑁(二合)曩涅里(二合)嗏怛鑁(二合)惹弥惹弥尼所(二合)尼所(二合)曼里寅(二合)惹尼寅(二合)喃(引)尼曩(引)尼(一)赧曼泥淫(二合)曼拏泥淫(二合)曼拏婆拏婆尼所(二合)尼所(二合)畔曩(引)尼婆曩(引)尼畔赧(二)览尼寅(二引)噜泥淫(二合)噜噜泥淫(二合)野啰罗嚩佉佉曼佉佉曼佉佉曼佉(三)夜室左(二合)怛吠(二合引)[口*爾]嚩路(引)计(引)捺舍嚩啰嚩隶诺闭拏野(二合)帝(引)摩(引)啰赛(引)尔野(二合四)

部剑布(引)怛剑(二合)波惹(引)多(引)钵啰(二合)左隶多嚩酥嚩(引)剑波帝(引)弥(引)噜啰(引)惹(一引)乌怛啰(二合)娑多(二合引)祢(引)嚩僧伽(引)誐啰(二合)贺誐拏计啰拏(引)曩(引)誐啰(引)惹(引)三摩娑多(二引二合)酥噜(二合)怛嚩(二合引)巘尼钵啰(二合)赞赧(引)尾尾驮婆野迦里寅(二合)底里体(二合)迦喃(引三)冒驮南(引)扇(引)底呬(引)睹(引)钵啰(二合)底啰拏底摩呬啰(引)嚩演底嚩僧健(四)

曀沙(引)尾贺啰始佉里(引)钵啰(二合)尾噜(引)底巘尼(一)弥(引)伽娑嚩(二合)尔嚩俱噜帝(引)底摩努诣野(二合)瞿(引)沙(二引)摩(引)帝(引)嚩嚩怛娑(二合)罗多夜(引)酥嚩呬里誐(二合)旦(引)室左(三二合)补怛览(二合引)娑摩(引)贺嚩(二合)野底部(引)惹曩迦(引)罗巘尼(四)

僧娑(引)啰作羯啰(二合)波里摩里那(二合)曩多怛波(二合)啰写(一)没驮写萨里嚩(二合)娱拏啰怛曩(二合)尾部史怛写(二)曩(引)难迦噜底酥啰努捺啰(二合)鼻睹罗野(二合)瞿(引)沙(引三)巘尼娑摩娑多(二合)努里多尔尾那(引)啰演底(四)曀沙(引)呬巘尼啰拏帝(引)曩誐赧(一)三冒(引)嚩尔祢(引)嚩曩啰(引)酥啰(引)赧(引二)婆捺啰(二合引)室里(二合)尼所(二合)特鑁(二合)酥誐怛写巘尼(三)摩(引)布里旦(引)鼻刍誐奶(引)娑摩誐里(四引二合)

曩(引)诣(引)三曼里多(二合)迦罗刍鼻多惹罗驮啰(引)迦(引)罗嚩驮喻(二合引)弥尔(二合)枳啰尼(一引二合)迦悉弥(二合)啰特鑁(二合)设商迦(引)婆野左计多惹曩(引)娑多(二合)怛钵啰(三合)底迦(引)啰呬(引)堵(二引)俱里鑁(二合)底野(二合)尔野(二合引)闭野写(引)特嚩(二合)尔谟波舍弥多(引)始(引)沙底里体(二合引)嚩隶焰(三)娑(引)巘尼钵多喻瑟曼(二合引)娑迦啰谟尔嚩里界(二合引)娑他(二合引)闭多(引)达里摩(二合)没里(二合)泰(四引)

曀沙(引)酥啰(引)酥啰摩护(引)啰誐娑怛讫里(三合)怛写(一)扇(引)底波啰(引)谟波誐怛写怛他(引)誐多写(二)巘尼啰拏底野(二合)摩啰嫰努鼻都罗野(二合)瞿沙(引三)讫里(二合)啰尔野(二合)底里他(二合)呬里(二合)那(引)野(引)尔尾那(引)啰演底(四)布罗野(二合)怛波(二合)啰摩(引)曩娑(引)婆嚩多部婆嚩(二合)凌誐(二合引)波嚩里誐(二合)钵啰(二合)尔(一引)波半(引)拏凌誐(二合)底那(引)野剑俱噜多摩(引)路(引)迦室左(二合)楞[口*爾]尾旦(二)伊璨摩地野(二合)尔隶曩部凌(二合)誐尾噜带(引)里惹(二合)罗半(二合)曩夜(引)野唧览(三)摩(引)啰(引)里室左(二合)啰拏(引)惹喻(引)尾尔呬多补瑟半(二合引)惹隶半(引)多嚩(四)

扪左讷鼻(二合)俱娑摩(二合引)尔怛里(二合)里野(二合)啰尼带(引)啰(引)野讷鼻(二合)里祢(二合重)输(一引)祖(引)祖寅(二合引)迦(引)啰布啰娑里界(二合)酥啰誐奶(引)设羯啰(二合)祢鼻娑那里界(二引二合)娑嚩(二合)凌誐(二合引)尔野(二合)写部鑁计罗(引)嚩多啰堵(引)难多(引)努夜(引)怛啰(二合)唧览(三)怛写(引)嚩焰(二合)迦噜拏(引)尔地(引)里婆(二合)誐嚩堵(引)巘尼钵啰(二合)赞拏(引)惹誐多(四)

誐怛嚩(二合引)娑钵多(二合)曀那(引)尔曼(引)多噜那览(引)尔瑟迦啰(三合引)多摩(引)怛啰(二合)娑嚩(二合)演(一)僧娑啰弟啰底孕(二合)迦噜底野(二合)贺(引)弥底布噜(二合引)嚩(引)左喻(引)曩罗波(二合)尾(二)野写(引)曩罗波(二合)婆尾嚩部嚩嚩左喃部啰(二合引)[口*爾]瑟拏(二合)鼻嚩[口*爾]旦(三)部夜(引)驮酥誐怛写怛写惹曳拏巘尼多摩欠尼尔(四)

[口*爾]怛嚩(二合引)摩(引)啰嚩楞摩贺(引)婆野迦览讫里(二合)怛嚩(二合)左努(引)沙叉焰(一)萨里嚩(二合)诣野(二合)波那摩(引)波野(二合)酥噜唧览怛怛赖(二合引)地(引)啰(引)怛啰(二合引)嚩呬(二)怛写始(引)沙娱拏(引)迦啰写酥地喻(引)没驮写秫驮(引)怛摩(二合)努(三)巘尼欠尼多赞拏枳啰尼(二合)沙多夜(引)弟部帝野(二合引)涅里(二合)赧(四引)

没啰(二合)憾摩(二合引)伊嚩(引)婆嚩酥啰娱噜誐里鑁(二合)惹护(引)萨里嚩(二合)他(一引)萨里嚩(二合)佉里嚩(二合)摩底里嚩(二合)部嚩婆誐鑁(引)尾瑟拏室赞(二合)拏瑟尼(二合)誐多(二)伊璨演娱拏枳里多(二合)尔(引)数尾没驮(引)夜(引)旦(引)呬里(二合)夜(引)谟迦旦(三引)巘尼怛写谟尔(引)里惹(二引)喃婆野鼻那波(引)夜(引)那播(引)演(引)惹曩(引)曩(四)

夜写(引)惹敢(二合)摩尔祢曩祢曩摩多野钵啰(二合)布输赞底里体迦(一引)贺里沙(二合)尾始沙嚩弟多尾喻(引)冒杲(二合)驮(引)达里(二合)底孕(二合)礼鼻里(二引)夜(引)摩(引)娑(引)尔野(二合)娱拏(引)钵啰(二合)演(引)底尾多底孕(二合)努(引)沙(引)没啰(二合)惹敢(二合)底叉焰(三)娑巘尼迦[口*(隸-木+士)]迦罗枳隶计(二合)沙贺啰(引)部夜(引)讷婆(二合)嚩部多曳(引四)演(引)曩怛嚩(二合)尾尾驮尾秫弟摩多喻(引)誐璨底孕(二合)旦殑誐底孕(一二合)野娑焰(二合)利钵啰(二合)多览钵啰(二合)演(引)底尾嚩舍(引)萨里味(二合引)尾波叉(引)叉焰(二)特嚩(二合)娑多(二合引)尾野(二合)娑多(二合)娑摩酥谟(引)贺波吒罗(引)娑(引)达里摩(二合)巘尼谟尔(三)三部野(引)讷婆(二合)嚩婆(引)尾三没驮娑底祢愈瑟摩(二合引)迦摩(引)愈瑟摩(二合)旦(四引)

酥噜(二合)怛嚩(二合引)演(引)钵底多(引)摩呬(引)多罗摩楞没啰(二合)撼摩(二合引)那野(引)娑嚩(二合)里部(二合)嚩(一)剑波帝(引)驮啰尼驮啰(引)刹帝啰闭刹钵啰(二合)誐多(引)刹摩(二合引)多楞(二)底里体(二合引)喃(引)婆野迦(引)里尼波啰呬多钵啰(二合引)览婆秫驮(引)怛摩(二合)喃(三引)冒杲(二合)驮(引)曩(引)谟波扇(引)多曳(引)娑波祢舍散多(引)尔野(二合)旦(引)巘尼剑(四)

揵稚梵赞


请宾头卢法

    No. 1689

请宾头卢法

        宋沙门释慧简译

天竺国有优婆塞国王长者。若设一切会。常请宾头卢颇罗堕誓阿罗汉宾头卢者字也。颇罗堕誓者姓也。其人为树提长者现神足故。佛摈之不听涅槃。敕令为末法四部众作福田。请时于静处烧香礼拜。向天竺摩梨山。至心称名言。大德宾头卢颇罗堕誓。受佛教敕。为末法人作福田。愿受我请。于此处食。若新作屋舍。亦应请之言。愿受我请。于此舍床敷止宿。若普请众僧澡浴时。亦应请之言。愿受我请。于此洗浴。及未明前具香汤净水澡豆杨枝。香油调和冷暖。如人浴法。开户请入。然后闭户。如人浴讫顷。众僧乃入。凡会食澡浴。要须一切请僧至心求解脱。不疑不昧。信心清净。然后可屈。近世有一长者闻说宾头卢阿罗汉受佛教敕为末法人作福田。即如法施设大会。至心请宾头卢。氍氀下遍布华。欲以验之。大众食讫。发氍氀华皆萎。懊恼自责。不知过所从来。更复精竭。审问经师。重设大会。如前华亦复皆萎。复更倾竭尽家财产。复作大会。犹亦如前。懊恼自责。更请百余法师。求请所失。忏谢罪过。如向上座一人年老。四布悔其愆咎。上座告之。汝三会请我。我皆受请。汝自使奴门中见遮。以我年老衣服弊坏。谓是被摈。赖提沙门不肯见前。我以汝请欲强入。汝奴以杖打我。头破额右角疮。是第二会亦来。复不见前。我又欲强入。复打我头额中疮。是第三会亦来。如前被打。头额左角疮。是皆汝自为之。何所懊惋。言已不现。长者乃知是宾头卢。自尔以来。诸人设福皆不敢复遮门。若得宾头卢。其坐华即不萎。若新立房舍床榻。欲请宾头卢时。皆当香汤洒地。燃香油灯。新床新褥奋绵敷之。以白练覆绵上。初夜如法请之。还闭房户。慎勿轻慢窥看。皆各至心信其必来。精诚感彻。无不至也。来则耨上现有卧处。浴室亦现用汤水处。受大会请时。或在上坐。或在中坐。或在下坐。现作随处僧形。人求其异终不可得。去后见坐处华不萎乃知之矣

请宾头卢法


劝发诸王要偈

    No. 1673 [Nos. 1672, 1674]

劝发诸王要偈

        龙树菩萨撰

        宋天竺三藏僧伽跋摩译

  明胜功德王　　我无余求想
  诸佛所说法　　庄严要何义
  略撰贤圣颂　　大王所宜闻
  如以众杂木　　造立如来像
  智者恭敬礼　　依佛故尊视
  我今以非辩　　光宣真实藏
  慧者应信乐　　依法听所述
  大王虽数闻　　如来梵音说
  胜悟由多闻　　屡闻则深信
  如日照素质　　岂不增其鲜
  三宝施戒天　　最胜说六念
  随顺诸功德　　如实善观察
  身口意常行　　清净十业道
  远酒不醉乱　　离邪修正命
  知财五家分　　无常不牢固
  惠施诸有德　　贫苦及亲属
  所生常随逐　　布施为最胜
  不断亦不灭　　不离不望果
  如是诸净戒　　宜应善受持
  是则为良田　　生诸功德故
  施戒忍精进　　禅定无量慧
  是诸波罗蜜　　慧者当修习
  能度三有海　　逮得牟尼尊
  若人孝父母　　至心尽供养
  是名礼教门　　清净天胜族
  名闻远流布　　舍身生天上
  离杀盗淫欺　　饮酒及三枝
  成就八分齐　　随顺诸佛学
  舍身生六天　　所欲悉随意
  悭谄幻伪慢　　懈怠贪恚痴
  族姓好容色　　少壮多闻乐
  如是诸迷惑　　当视如怨家
  若修不放逸　　是则不死路
  放逸为死径　　世尊之所说
  为增善法故　　当修不放逸
  若人先为恶　　后能不放逸
  是则照世间　　云除月光显
  忍辱无与等　　不随嗔恚心
  佛说能远离　　是得不还道
  有嗔如画水　　或如画土石
  若说超烦恼　　初人则为胜
  改恶修慈忍　　第三则为上

  最胜说众生　　三种善恶语
  初名引人心　　美言如饴蜜
  次名真实语　　犹如妙华敷
  后名不诚实　　鄙浮如粪秽
  慧者应分别　　舍后修初二
  从明明至终　　从闇闇究竟
  有从闇入明　　或从明入冥
  慧者应谛了　　舍三升初明
  有人生似熟　　或复熟似生
  或二俱生熟　　明者谛分别
  不视他妻色　　视则母女想
  如是犹生惑　　当修不净观
  心意善驰乱　　当勤善守持
  如人护胜闻　　宝藏爱子命
  当观五欲乐　　犹如恶毒蛇
  怨憎及刀火　　方便修厌离
  五欲生非义　　犹如频婆果
  覆相善欺诳　　缚人住生死
  智者当观察　　弃舍勿染污
  诸根常轻躁　　驰散六尘境
  若能善调伏　　是则大勇健
  是身为行厕　　九道常流秽
  穿漏难可满　　薄皮隐不净
  愚者为所欺　　智士当厌离

  如人病疥虫　　向火欲除患
  少乐后苦增　　贪欲亦如是
  能善知欲过　　从是离众苦
  欲见第一义　　佛说观缘起
  应当勤修习　　最胜无过是
  族姓身端严　　多闻自缨络
  若不修戒慧　　此则非殊胜
  能具二功德　　无三犹奇特
  利衰及毁誉　　称讥与苦乐
  八法不倾动　　是则为圣王
  莫为诸天神　　沙门婆罗门
  宗亲及宾客　　害生造恶业
  命终入地狱　　独受彼不代
  若人作恶业　　不即受楚毒
  命终受苦报　　后悔将何及
  信戒施多闻　　智慧有惭愧
  佛说不共财　　余财一切共
  博弈大聚会　　懒惰习恶友
  饮酒纵昏荡　　夜游无羞耻
  此六污名称　　智者应远离

  知足为大财　　世尊所称说
  若能修知足　　虽贫贱大富
  譬如多头龙　　多头则多苦
  自性结恨深　　是名怨家妇
  傲慢不承顺　　名为轻夫妇
  费用夫主财　　是则名贼妇
  慎哉贤丈夫　　宜远此三妇
  随顺为姊妹　　爱乐为善友
  安慰则为母　　随意为婢使
  此四贤良妻　　则是夫眷属
  饮食为汤药　　无贪恚痴服
  唯为止身苦　　勿为肥放逸
  昼则勤修业　　初后夜亦然
  中夜亦正念　　无令空梦过
  慈悲喜舍心　　日夜常修习
  设未出世间　　其福胜梵天
  离欲觉欢喜　　苦乐修四禅
  梵光净果实　　受此诸天乐
  若人少行恶　　广修无量善
  如以一把盐　　投之大恒水
  若人多行恶　　少修净功德
  如以多恶毒　　置之小器食
  五阴闇冥贼　　劫人善珍宝
  信五根力士　　是能善守护
  生老病死苦　　所爱者别离
  沦没不超度　　斯由自业过
  求生天解脱　　当勤修正见
  邪见虽行善　　一切得苦果
  无常苦不净　　应当善观察
  若不正思惟　　四倒盲慧眼
  端正色非我　　我色亦非主
  四阴亦复然　　唯是空苦聚
  非时非无因　　亦非自性有
  非自在天生　　无明爱业起
  身见戒取疑　　是三障解脱
  圣慧开脱门　　自力不由他
  净戒学禅定　　精勤修四禅
  增上戒心慧　　常当勤修学
  诸戒智三昧　　悉入三学中
  身念处大力　　佛说一乘道
  常当系心念　　方便善守护
  若忘是正念　　则失诸善法
  身命极浮脆　　喻风吹水泡
  梦觉难可保　　出息无必旋
  倏忽成微尘　　当知无坚固
  大地须弥海　　七日皆烧然
  廓然无遗烬　　况复危脆身
  无常不可依　　亦非覆护法
  是身不可怙　　如何不生厌
  譬如海盲龟　　值遇浮木孔
  畜生复人身　　难得复过是
  如何人道中　　不修胜果业
  宝器盛粪秽　　是则愚痴人
  已得人身宝　　而用造恶行
  当知此士夫　　极愚复过是
  得生有道国　　遭遇善知识
  正见心成就　　宿命有功德
  四宝轮具足　　能出生死路
  亲近善知识　　具足修梵行
  佛说如是人　　心常得寂灭
  邪见三恶趣　　不闻佛法音
  边地闇冥处　　聋哑长寿天
  王已离八难　　得此无碍身
  宜应修善业　　方便求泥洹
  生死长夜中　　无量种种苦
  展转作六亲　　尊卑无常序
  永劫生死中　　未曾不为子
  计饮慈母乳　　量喻四大海
  凡夫方受生　　所饮复过是
  一人从本来　　积骨高须弥
  所经诸人天　　大地微尘数
  先作转轮王　　后复为仆使
  或上为帝释　　诸天所奉事
  下生粪土中　　往反亦无数
  或时生天上　　婇女极娱乐
  目眩众妙色　　耳闻万种声
  触身皆细软　　快乐难可名
  后堕地狱中　　苦毒靡不经
  若生剑林树　　身首随刃零
  或游须弥顶　　升降随所念
  与众天女俱　　沐浴曼陀池
  宝华列庄严　　清凉极快乐
  复入沸灰河　　烹煮悉糜烂
  六天五欲欢　　梵世离欲乐
  死入无择狱　　备受众苦毒
  或作日月天　　光明照四域
  后生黑闇狱　　不自见其形
  王当然慧灯　　勿复随长冥
  八大地狱中　　烧炙屠裂苦
  备经众楚毒　　无量不可譬
  若人随痴惑　　具造众恶业
  出息未反间　　闻是诸大苦
  其心不惊怖　　是则木石人
  眼见报应像　　复闻智者说
  彼采佛经典　　内心正思惟
  则应大怖畏　　何况身自经
  一切受苦中　　无择最大苦
  一切受乐中　　爱尽第一乐
  日夜各三时　　三百枪贯身
  欲比无择苦　　百千倍非譬
  无量诸楚毒　　求死不可得
  受罪百千岁　　恶业尽乃毕
  不净苦果报　　身口业为种
  不种则不有　　王宜断苦本
  若堕畜生趣　　系缚杀害苦
  贪害狂乱心　　怨结更相食
  或为取珠宝　　毛尾皮肉骨
  由是丧身命　　解剥断截痛
  骏足有大力　　穿颈服乘苦
  狂逸不调驯　　策勒而榜楚
  饿鬼思饮食　　所念未曾有
  饥渴寒热迫　　长夜无休息
  或身如大山　　咽口若针锋
  饥渴内烧燃　　对食食无从
  或见粪脓唾　　群走竞驰趣
  到则自然灭　　望绝增苦恼
  饥渴煎其内　　瘤瘿发痈疽
  更共相撮搏　　龃齰唼脓血
  羸疮皮骨连　　裸形被长发
  身长若枯木　　炽焰从口出
  还自焚其身　　状烧多罗树

  处夏希夜凉　　月光增其热
  在冬思昼温　　日出逾冰结
  向树果即消　　趣河水辄竭
  经万五千岁　　业持命不绝
  久受无量苦　　斯由宿罪缘
  种种诸恼逼　　纯苦初无间
  贪惜极悭着　　佛说饿鬼因
  生天虽快乐　　福尽极大苦
  斯非贤圣果　　慧者所不怙
  身体不光泽　　不乐本所座
  华冠卒萎落　　尘垢忽着身
  腋下流汗汁　　当知死时至
  善趣净业尽　　复堕三恶道
  或生阿修罗　　贪嫉常苦恼
  虽有智聪明　　终不见真谛
  生死六趣中　　轮转常不息
  胜法不受生　　生者众苦器
  假令顶火然　　正意慎勿念
  不受后有业　　专心勤修习
  戒品禅定慧　　寂静调不动
  当求涅槃道　　究竟离生死
  念择及精进　　喜猗三昧舍
  此七菩提分　　清净甘露道
  无智则不禅　　无禅亦不智
  是二俱成就　　能出生死流
  无边大苦海　　视如牛迹水
  十四无记论　　佛说不应思
  是非安隐道　　亦非寂灭处
  无明缘诸行　　即缘彼生识
  名色从识起　　六入因名色
  六入生六触　　从触起诸受
  诸受为爱因　　从爱生四取
  四取生三有　　因有爱后生
  从生致老死　　忧悲诸苦恼
  无量众苦聚　　生尽则都灭
  最胜所显示　　甚深缘起法
  若能正观察　　真实见之上
  如是真实见　　是则为见佛
  正见正思惟　　正语正业命
  正念正方便　　及正三摩提
  八分圣贤道　　寂灭当修习
  生为真谛苦　　恩爱则是集
  苦灭名解脱　　到彼谓八道
  为见彼真谛　　常勤修正智
  虽处五欲乐　　慧者能出离
  能证正法者　　皆从凡夫起
  不从虚空堕　　亦不从地出
  明哲无畏王　　领要不待烦
  宜修正法桥　　越度生死渊
  如上诸深法　　出家犹难精
  况复御世主　　而能具足行
  随时渐修习　　勿令日空过
  一切人修善　　常生随喜心
  自行三种业　　正回向佛道
  当于未来世　　受此无量福
  常生天人中　　得为自在王
  与大菩萨众　　游戏诸神通
  方便化众生　　严净佛国土
  施戒慧为种　　往返人天中
  无垢净名称　　流布十方国
  世间导人主　　上生化天王
  令舍五欲乐　　远离诸放逸
  众生迷正济　　漂浪随四流
  无量生死苦　　度令至彼岸
  缘此成佛道　　究竟大涅槃

劝发诸王要偈


如实论反质难品

    No. 1633

如实论反质难品一卷

        陈天竺三藏真谛译

    反质难品中无道理难品第一

论曰。汝称我言说无道理。若如此者。汝言说亦无道理。若汝言说无道理。我言说则有道理。若汝言说有道理。称我言说无道理者。是义不然。复次无道理者自体中有道理。是故无有无道理。若自体中无道理者。无道理亦应无。是故汝说我无道理。是义不然。又若汝称我言说无道理。自显汝无智。何以故。无道理者则无所有。言说者。与无道理为一为异。若一者言说亦无。汝云何称我言说无道理。若异者言说有道理。汝复何故称我言说无道理耶。复次言说自相破故。汝难言说共我言说。为同时为不同时。同时者。则不能破我言说。譬如牛角马耳同时生故不能相破。若不同者。汝难在前我言在后。我言未出汝何所难。是故不成难。若我言在前汝难在后。我言已成复何所难。若同时者。我言汝难是难是可难不可分别。譬如江水海水同时和合不可分别。又汝难为难自义为不难自义。若难自义。自义自坏我言自成。若不难自义难则不成就。何以故。于自义中不成就难故。若成就者。自义则坏他义则成。复次汝称我言说无道理者。非是言说。若是言说不得无道理。有言说无道理。此二相违。譬如童女有儿。若是童女不得有儿。若有儿则非童女。童女有儿此二相违。是故称有言说无道理。是义不然。复次与证智相违故。汝闻我言说而称无道理者。若汝已闻则为证智所成就。证智力大。汝言则坏。譬如有人说声不为耳识得。耳识既得声为证智所成就。证智力大。此言则坏。复次与比智相违故。若汝称我有言说比智所得则知有道理。若无道理言说亦无。若有言说知有道理。譬如有人说声常住从因生故。一切从因生者则无常住。譬如瓦器从因生故不得常住。声若从因生不得常住。若常住者不得从因生。无常住者比智所成就。比智力大常住则坏。有道理者。若有言说则有道理。有道理者比智所成就。无道理者则坏。复次与世间相违故。汝称我言说无道理。是语与世间相违。何以故。于世间中立四种道理。一因果道理。二相待道理。三成就道理。四如如道理。因果道理者。如种子与芽。相待道理者。如长短父子。成就道理者。如五分言成就义。如如道理者。有三种。一无我如如。二无常如如。三寂静如如。于世间中言说为果道理为因。世间中若见果则知有因。若见言说则知有道理。汝称我言说无道理。是义与世间相违。若有言说无道理者。无有是处。汝称我言说异不相应故。我今共汝辩决是处。若人说异则有过失。汝自立义与我义异。则是自说。则是异说。是故汝得过失。若汝义异我自说则异过失在汝。不关于我。若不异汝则同我则无有异。汝说我异此是邪语。复次异与异无异。是故无异。若异与异异则不是异。譬如人与牛异。人不是牛。若异与异无异则是一。若一则无有异。汝何故说我为异。复次是道理者。我于汝道理中共诤故。我说有异。若汝与我不异者。则不与汝共诤。我说汝义故。若一切所说异者。汝亦有所说。是故汝说异。过失在汝。若汝说不说异者我亦说不说异。汝言我说异是义不然。汝是邪语。余义如前说。汝称我说义不成就。我今共汝辩决是处。若说不成就者。是说不成就说。若所说不成就则不得说。若不得说者。汝云何说。我所说不成就。若得说所说则应成就。汝说不成就。是义不然。若一切所说不成就者。汝说难难我。是难则不成就。若汝说难非不成就者。我说亦如是非不成就。汝说我不成就。是义不然。不成就者于自体中成就。是故无不成就。若不成就于自体中无有成就者。亦应无有不成就者。若有成就则无有不成就。是故汝说我不成就无有是处。若汝说不诵我难则不得我意。若不得我意则不得难我。我今共汝辩决是处。若未诵我难则不得说汝难。汝为诵难能难。为未诵难而难。若汝不诵而得说难者。我亦不诵而得说难。若汝诵难得说难者则恒诵难。何以故。难中复生难。难则无穷。无有不诵难时。无有得说难时。复次从难名更有难名。若诵此难名故得说难名。不诵不得说难名者。但得后诵前难名。次难名未得诵。第三方得诵第二难名。第四方得诵第三难名。如是则恒诵无尽。若汝今不诵而得说难名者。初难名亦应不诵而得说难名。若初难名不诵不得说难名者。第二亦应不诵难名得说难名。第二不诵难名得说难名者。初亦应不诵难名得说难名。而今初难名必须诵方得说难名。第二难名亦应必须诵方得说难名。不应不诵而说。复次若不诵难而说。难则堕负处。汝不诵自难。汝说难亦堕负处。若汝不诵难而说难。说难不堕负处者。我亦不诵难而说难亦不堕负处。复次若汝言说难我。我皆当诵。我难难汝。汝皆当诵。唯得互相领诵则不得别立难。若恒相领诵则失正义。譬如两船相系大水若至相牵去来。复次汝言。皆是音声出口则失灭。云何得诵我语。音声既是失灭之法。不得重还故。不得重诵。若音声在则不能诵。以其常声故。若言失灭则无所诵。以其无故。若音声已失灭。汝令我诵。称是汝言。是邪思惟。汝说我语前破后。我今共汝辩决是处。若我说前破后是道理。何以故。我语前汝语后。若我语破后语。我义则胜。汝语则坏。复次若汝说一切语前破后。汝亦出语前应破后。若汝语前不破后。我出语前亦不破后。复次前破后者于自体无前破后。若于自体有前破后。则前后俱无。是故汝说前破后。是语不然。若于自体无前破后。无有因故。前破后亦是无。汝说我语前破后。是邪思惟。汝说我说别因。我今共汝辩决是处。若人舍前因立别因堕负处者。汝则堕负处

何以故汝亦舍前因立别因故。若汝立别因不堕负处。我亦如是。复次我所说因与汝所说因异。若我说异因则是我道理。若不说异因。我则说汝因。非是对治相违。便同汝说。汝说我说异因是邪思惟。若我同汝立因。汝破我因则破汝自因。复次若一切语是别因。汝亦出语则是别因。是故汝堕负处。若汝出语不堕负处。汝说我立因堕负处。是义不然。若汝说我说别义。今共汝辩决是处。我所立义与汝义异。即是道理。我今与汝对治相违。是故说别义。若汝思惟我义与汝义不异。我义则不与汝义对治相违。若汝破我义则是自破。复次异义于自体中无异义。异义则是无。若异义于自体中有异义。异义亦是无。是故汝称我说异义。是义不然。复次若一切所说是异义。汝有所说亦应是异义。若汝有所说不说是异义。汝说一切所说是异义。是义不然。汝说我今语犹是前语无异语者。我今共汝辩决是处。我立义与汝立义对治相违。若我说自立义对治汝义。是正道理。何以故。我一切处说为破汝义。是故我说无有异。若我应说异义者。汝立义与我义异。若我说异义则说汝义。则不共汝相违。汝难我则是难自义

复次如我前说声无常此语自灭自尽。今更别出语。汝说我说前语。是邪思惟。复次若汝说我所说无异。若我说异则是异。若我说无异则是不异。若我说是不得成是汝说我无异。是义不然。若汝言一切所说我皆不许。我今共汝辩决是处。汝说不许一切。此说为入一切数。为不入一切数。若入一切数汝则自不许汝所说。若自不许者我义则是汝所许。我义自成。汝言便坏。若不入一切数者。则无一切。若无一切汝不许一切。若不许一切。我义便非汝不许。我义亦成。汝言终坏

    反质难品中道理难品第二

论曰。难有三种过失。一颠倒难。二不实义难。三相违难。若难有此三种过失则堕负处。一颠倒难者。立难不与正义相应。是名颠倒难。颠倒难有十种。一同相难。二异相难。三长相难。四无异难。五至不至难。六无因难。七显别因难。八疑难。九未说难。十事异难。一同相难者。对物同相立难。是名同相难。论曰。声无常因功力生。无中间生故。譬如瓦器因功力生。生已破灭。声亦如是故声无常。是义已立。外曰。若声无常与器同相者。声即常住。与空同相故。是故如空声亦常住。同相者同无身故。论曰

复次声无常因功力生。无中间生故。若物常住不因功力生。譬如虚空常住不因功力生。声不如此。是故声无常。此义已立。外曰。若声与常住空不同相故。是故声无常则何所至。若与空同相。声即是常。同相者是无身。是故常。论曰。此两难悉是颠倒不成难。何以故。决定一味法立为因。显一切物因功力生故无常。是显无常因决定一味。是故无常不动。欲显其同类故说瓦器等譬。外依不决定一味立难云。若汝依同相立声无常义。我亦依同相立声常义。若汝义成就我义亦成就。论曰。汝难不如。何以故。汝立因不决定常无常遍显故。我立因三种相是根本法。同类所摄异类相离。是故立因成就不动。汝因不如。是故汝难颠倒。若汝立因同我因者。汝难则成正难。若无常立义难常义。是难成就。何以故。立常因难。立无常因。极不能显无常颠倒过失。常因不决定一味故。无常因决定一味故。二异相难者。对物不同相立难。是名异相难。论曰。声无常。何以故。因缘所生故。若有物依因缘生即是无常。譬如虚空。虚空者常住。不依因缘生。声不如是。是故声无常。外曰。若声与常住空不同相故。无常复何所至。若与瓦器不同相声即常住。不同相者。声无身瓦器有身。是故瓦器无常声则是常

论曰。声无常依因缘生故。譬如瓦器依因缘生故无常。声亦如是。外曰。若汝立声无常与瓦器同相者。复何所至。声即常住与瓦器不同相故。不同相者。声无身瓦器有身故。论曰。此两难悉颠倒。何以故。我立无常因决定一味故。汝立常因不决定一味。常无常遍显故。是故不定因不能难决定因。我立因者。是依因缘生故声无常。是因是根本法。同类所摄异类相离。具足三相故不可动。汝立因者是无身故声常住。是因根本法同类异类所摄。是故不成因。三长相难者。于同相显别相是名长相难。论曰。声无常因功力生故。譬如瓦器。是故声无常。外曰。汝立声与瓦器同相因功力生故。别有所以。一可烧熟不可烧熟。二为眼所见不为眼所见等。如是别声与瓦器各有所以。声因功力生常住。瓦器因功力生无常。是故声常住。论曰。是难颠倒。何以故。我立因与无常不相离与常相离。显此因为无常比智。譬如为火比智显烟。烟者与火不相离。是故我立因成就不可动。汝显别声不可烧熟。是故常者。欲嗔苦乐风等不可烧熟而是无常。是故不可烧熟不可立为常因。不为眼所见者亦不可立为常因。何以故。欲嗔苦乐风等亦不为眼所见而是无常。汝因同类异类所摄。是故不成。若汝因与我因同能难我立义。我立义者依三种相因。是故不同。不同者汝说同。是故汝难颠倒。四无异难者。显一同相故立一切无所以。是名无异难。论曰。声无常依因缘异故声即异。譬如灯若炷大明大炷小明小。是义已立。外曰。若依同相瓦器等无常声亦如是者。则一切物与一切物无异。何以故。一切物与异物有同相故。何者同相。有一可知等。是名同相。若有同相一切物与别物异者。声亦如是。与瓦器等有同相。声是常瓦器等无常。何以故。一切于有等同相中有自性异故。如灯声人马若依同相比知则不成就。论曰。是难颠倒。何以故。于一切物有等同相。我亦不舍。我检有别。同相具足三相者立无常义。说此为无常因不取唯同相。若不如是思择道理则无别有道理。何以故。无有一物与异物不同不别。是故若有同相则同类所摄。一切异类相离。若取此立因。是因成就。唯同相立因则不成就。是故颠倒。复次论曰。声无常依因缘生故。譬如瓦器等。是故声无常。外曰。因与立义二无无异。何以故。依因生是何义。因未和合声未生。未生故无有是其义。声无常是何义。声未生得生。生已即灭。灭故无有。是其义。因与立义同无有故。论曰。是难颠倒。何以故。我立义无有。是坏灭无有。我立因无有。是未生无有。未生无有者。一切世间多信故成就立为无常因。灭坏无有者。僧佉等不信故不成就。为令成就故立为义。若取成就立义。不成就为因。汝难则胜不颠倒。我说一切物前世未有后世见无。是故声前世是无后世亦无。若前世无汝不信者。汝自思惟。若前世有声而无碍者。何故耳不闻耶。是故汝知前世无。犹如蛇足。有人竞胜心不能成就义意。欲成就而无道理。是义应舍。五至不至难者。因为至所立义为不至所立义若因至。所立义则不成因。因若不至所立义亦不成因。是名至不至难。外曰。若因至所立义共。所立义杂则不成立义。譬如江水入海水无复江水因亦如是故不成因。若所立义未成就因不能至。若至所立义已成就用因何为。是故因不成就。若因不至所立义者。则同余物不能成因。是故因不成就。若因不至则无所能。譬如火不至不能烧刀不至不能斫。论曰是难颠倒。因有二种。一生因。二显不相离因。汝难若依生因则成难。若依显因则是颠倒。何以故。我说因不为生。所立义为他得信。能显所立义。不相离故。立义已有。于立义中如义智未起。何以故。愚痴故。是故说能显因。譬如已有色用灯显之不为生之。是故难生因。于显因中是难颠倒。六无因难者。于三世说无因。是名无因难。外曰。因为在所立义前世为在后世为同世耶。若因在前世立义在后世者。立义未有因何所因。若在后世立义在前世者。立义已成就复何用因为。若同世俱生则非是因。譬如牛角种芽等一时而有不得言左右相生。是故是同时则无有因。论曰。是难颠倒。何以故。前世已生依因为生。譬如然灯为显已有物。不为生未有物。汝以生因难我显因。是难颠倒不成就。若汝难言。是因若是显因智慧未有是因。是因是谁因。是故不成显因。若作如此难者。未得因名。乃至事未有。若事成有即得因名。是能显事。是时得因名。是言在前未得因名。在后方得因名。若说因前事后则无过失。有人难言。若如此者事不从因生。此亦不成难。何以故。是前物于后得因名。若物已灭后事生者此难成就。既不如此前有未得名。后有方得名。是故果从因生。七显别因难者。依别因无常法显故此则非因。是名显别因难。外曰。若依功力声无常者。若无功力处即应是常。如电光风等不依功力生亦为无常所摄。是故立无常不须依功力。功力非因故。若是因者离功力。余处应无无常。譬如离火立烟烟是火正因。烟与火不相离故。功力则不如此。是故不成因。复次功力不能立无常义。何以故。不遍故依功力生。若遍者得立无常。若不遍者则不得立无常。譬如有人立义一切树有神识。何以故。树能眠故。譬如尸利沙树。有人难言。树神识不成就。何以故。因不遍故。一尸利沙树眠余树不眠。是眠不遍一切树。是故眠不能立一切树有神识。依功力生亦如是。不遍一切无常故。是故不能立无常

论曰。是难颠倒。我说不如此。不说依功力生是因能显一切无常余因不能。若有别因能显无常。我则欢喜。我事成故。我立因亦能显。余因亦能显。我立义成就。譬如依烟知火。若言见光火亦成就。我义亦如是。依功力生能显无常。若别有因能显无常。无常义亦成就。是故汝难颠倒。不如我意难故。若我说一切无常依功力生者。汝可难言。依功力生是因不遍故不成就。此难则胜。我说声等有依功力生者悉是无常。不说一切无常皆依功力生。是故汝难颠倒。八疑难者。于异类同相而说疑难。论曰。声无常依功力生故。若有物依功力生是物无常。譬如瓦器是义已立。外曰。已生依功力得显。譬如根水等依功力得显。非依功力得生。声亦如是。是故立依功力因不定未生已生中有故。故依此因于声起疑。此声定如何。为如瓦器未生得生。为如根水已有得显故非决定。若依此生因起疑。当知非是立义因。何以故。能生能显故。论曰。是难颠倒。何以故。我不说声依功力得显。我说声依功力得生。是故声无常。汝何所难。若汝言。功力事有二种。一生二显。生者。瓦器等。显者。根水等。声是功力事。是故于中起常无常疑。是义不然。何以故。根水等非是功力事故。若汝言根水显了功力事。是亦不难我义。何以故。显了未生依功力得生。是故功力事一种同是无常故。汝难不然。若汝又显功力事有二种无常。瓦器生是无常。瓦器灭是常。声亦如是。是疑亦不然。何以故。不成就故。若汝瓦器灭。是有于灭中有。有故灭义则无有。若灭中无有。即是灭无有。何以故。无体故。若汝说如闇。闇中无光故有闇。灭亦如是。灭中无有故有灭。是义不然。空华石女儿兔角等中无有。是则应有。若汝不许空华等有。瓦器灭亦如是。不可说有。是故功力事一种同是无常故。汝疑不然。汝不信为。汝得信故我说了因声无常。何以故。前世无障依功力得显生故。是故知声无有。譬如瓦器。汝立依功力所得功力所造二义有异。是义不然。何者为义。一切依功力所得即是无常。何以故。未生得生已生灭故。是故根水等亦如是无常。何用汝立显了为常。九未说难者。未说之前未有无常。是名未说难。论曰。义本如前。外曰。若说依功力言语为因声无常者。则何所至。未说依功力言语。前声是常是义得至。前世声已常。云何今无常。论曰。是难颠倒。何以故。我立因为显义。不为生不为灭。若我立因坏灭。汝难则胜。若汝难我未说前未了声无常。是难相似。若以坏灭因难我是难颠倒。十事异难者。事异故。如瓦器声。不如是。是名事异难。论曰。声无常依因缘生故。譬如瓦器是义已立。外曰。声事异瓦器事异。在事既异。不得同是无常。论曰。是难颠倒。何以故。我不说与器同事故声无常。我说一切物同依因得生故无常。不关同事。譬如瓦器故声无常。烟是异物而能显火。瓦器亦如是。能显声无常。复次他人说事异难有别所以说声常住依空故空是常住。若别有物依空。物即常住。譬如邻虚圆。邻虚常住圆依邻虚圆即常住。声亦如是。依空故常住。复次声常住。何以故。耳所闻故。譬如声同异性耳所执故常住。声亦如是。是故常住。是异立义。鞞世师曰。若常住由因得立。因事故即无常。是故声无常。论曰。是难颠倒。何以故。我不说因生无常。我说因显无常。他人未知为他得知。我立因是了因。非是生因。汝依生因难。是难颠倒。复次论曰。汝所说是立义亦是难于我不许。何以故。我等不信乐常住义。是故我说是义。此十种名同相等颠倒难故。以颠倒立其过失。若有难与此相似。即堕颠倒难中。二不实义难者。妄语故不实。妄语者不如义无有义。是名不实义难。不实义难有三种。一显不许义难。二显义至难。三显对譬义难。一显不许义难者。于证见处更觅因。是名显不许义难。论曰。声无常。何以故。依因缘生故。譬如瓦器。是义已立。外曰。我见瓦器依因缘生。何因令其无常。若无因立瓦器无常者。声亦应不依常因得常。论曰。是难不实。何以故。已了知不须更以因成就。现见瓦器有因非恒。有何须更觅无常因。是故此难不实。二显义至难者。于所对义。此义义至。是名义至难。论曰无我。何以故。不可显故。譬如石女儿。此义已立。外曰。是义义至。若可显定有不可显定无者。可显或有或无。不可显亦应如是。譬如火轮阳焰乾闼婆城。是可显而不能立有。若可显不能定立有。则不可显不能定立无。论曰。是难不实。有何道理是义义至。不可显物。毕竟不有。是义不至。可显物者有二种。有义至有非义至有。义至者。若有雨必有云。若有云则不定或有雨或无雨。由烟知火。于此中不必有义至。若见烟知有火。无烟知无火。是义不至。何以故。于赤铁赤炭见有火无烟。是故显物义至难不实。复次唯有色名火轮名阳焰名乾闼婆城。以根迷心倒故。于现世有后世无。惟色实有。根迷心倒。或时见有。汝说可显物不定有。是难不实。复次我以石女儿为喻定判此义。处不可显毕竟不动。是物决定无有。譬如石女儿处不可显动非是我譬。不可显者于邻虚等处。或显或不显。对汝义至我说义至处可显毕竟不动是物定有。于火轮等异唯轮不定。轮不定者。转时有住时无。是故非是义至。汝取非义至作义至难。是难不实。复次有余人说义至难。若声与瓦器同相故声无常。以义至故。若不同相则应是常。不同者。声耳所执无身。瓦器眼所执有身。既不同相故声是常。论曰。若如此难同相难义至难无别体故我不许。三显对譬义难者。对譬力故成就义。是名对譬义难。外曰。若无常器同相故声无常者。我亦显常住。譬常住空同相故声常住。若常同相不得常者。无常同相。何故无常。论曰。是难不实。何以故。唯无有物名空。若有物常住此譬则成难亦是实。既无有物常住。空无有物不可说常不可说无常。此难不成譬。非譬为譬故。此难不实。若人信有物名空即是常住。是颠倒难非实义难。何以故。无身不定故。空无身常住。心苦乐欲等无身而是无常。声既无身为如空是常为如心等是无常耶。无身不定不得成因故此难颠倒。复次声无常有因故。若物有因即知无常。譬如瓦器等。是义已立。外曰。是义可疑。何以故。器生有因是无常。器灭有因是常。声既有因故于声起疑。为同器生有因无常。为同器灭有因是常。论曰。是难不实。何以故。无有实物而名灭者。皆从杖等打物坏灭故得常名。复次声无常。何以故。根所执故。譬如瓦器。是义已立。外曰。此亦可疑。根所执如同异性则应是常。声根所执如同异性。声应是常。若如同异性非是常者。若如瓦器不应无常。论曰。是难不实。何以故。牛等同异性。若实有离牛等应有别体可执可见。离牛同异性不可执不可见无别体。故知无常。复次无我。何以故。不可显故。譬如蛇耳。是义已立。外曰。海水滴量雪山斤两。是有而不可显。我亦如是。是有而不可显。是故不可显因。不得立无我。论曰。数量与聚无别体。是可数量聚次第而现有若干。若干是数量。为摄持念故作一十百千万等名。水滴量山斤两既无别体故非实有。若有别难与此难同相者。立其过失名不实义难。三相违难者。义不并立。名为相违。譬如明闇坐起等不并立。是名相违难。相违难有三种。一未生难。二常难。三自义相违难。一未生难者。前世未生时不关功力则应是常。是未生难。外曰。若依功力声无常者。未生时未依功力声应是常

论曰。是难相违。何以故。未生时声未有。未有云何常。若有人说。石女男儿黑女儿白。此义亦应成就。若不有不得常。若常不得不有。不有而常。则自相违此难与义至难不实难相似。何以故。非是实难故。依功力声无常。是义已立。是义义至得。若不依功力则应是常。此义不实。何以故。不依功力者有三种常无常不有。常者如虚空。无常者如雷电等。不有者如空华等。此三种悉不依功力。而汝偏用一种为常。是故不实。二常难者。常无常故是声常。是名常难。外曰。于无常处常有无常。一切法不舍性故。无常中有常。依无常故得常

论曰。是义相违。何以故。若已无常云何得常。若有人说闇中有光。此语亦应成就。若不尔汝难则相违不实。何以故。无有别法名无常。于无常处相应。更立为常。无常者无别体。若物未生得生。已生而灭名为无常。若无常不实。依无常立常。常亦不实。三自义相违难者。若难他义而自义坏。是名自义相违难。论曰。声无常依因缘生故。譬如芽等。是义已立。外曰。若因至无常则同无常。若不至无常。不能成就无常。此因则不成因。论曰。汝难若至我立义。与我立义同。则不能破我义。若不至我立义亦不能破我义。汝难则还破汝义。复次外曰。若因在前。立义在后。立义未有。此是何因。若立义在前因在后。立义已成。因何所用。此亦不成因。论曰。若汝难在前我立义在后。我义未有。汝何所难。若我立义在前汝难在后。我义已立。汝难复何用若汝言汝已信我难故取我难更难我。若作此说。是亦不然。何以故。我显汝难还破汝义。不依汝难以立我义。若有别难与此难同相者。立其过失名相违难。论曰。正难有五种。一破所乐义。二显不乐义。三显倒义。四显不同义。五显一切无道理得成就义。外曰。有我。何以故。聚集为他故。譬如卧具等为他聚集。眼等根亦如是为他聚集。他者我故知有我。论曰。无我。何以故。定不可显故。若有物定不可显。是物则无。譬如非自在人第二头。第二头者。于色香等头相貌中不可思惟分别。是故定无。我亦如是。于眼等根中分别不显。是故定无。汝说我有。是义不然。是名破所乐义。复次若汝说我相不可分别而是有者。第二头不可分别亦应是有。若汝不信第二头是有。我亦如是。汝不应信。是名显不乐义。复次若汝意谓二种同不可分别。不依道理说我是有。不说第二头是有者。我亦不依道理。说第二头是有。不说我是有。是义应成。若我义不成。汝义亦不成。是名显倒义。复次若汝言。我与第二头同不可分别而不同。无不同过失堕汝顶上。譬如有人说如是言。石女儿有庄严具。石女儿无庄严具。此语亦应成就。若作此说堕不同过失中。汝亦如是。是名显不同义。复次若汝言。不依道理定有我。不依道理定无第二头。此言得成就者。一切颠狂小儿无道理语亦应成就。譬如虚空可见火冷风可执等。并是颠狂之言不依道理。如汝所立亦得成就。若不成就汝义亦如是。是名显一切无道理得成就义

    反质难品中堕负处品第三

论曰。堕负处有二十二种。一坏自立义。二取异义。三因与立义相违。四舍自立义。五立异因义。六异义。七无义。八有义不可解。九无道理义。十不至时。十一不具足分。十二长分。十三重说。十四不能诵。十五不解义。十六不能难。十七立便避难。十八信许他难。十九于堕负处不显堕负。二十非处说堕负。二十一为悉檀多所违。二十二似因。是名二十二种堕负处。若人堕一一负处则不须复与论义。一坏自立义者。于自立义许对义。是名坏自立义。外曰。声常。何以故。无身故。譬如虚空。是义已立。论曰。若声与空同相故是常者。若不同相则应无常。不同相者。声有因空无因。声根所执空非根所执。是故声无常。外曰。若同相若不同相。我悉不捡。我说常同相。若有常同相则是常。论曰。常同相者。不定无身物。亦有无常。如苦乐心等。是故汝因不成就。不同相者。定显一切无常与常相离。是故能立无常。外曰。我亦信无常有因常无因。是名坏自立义堕负处。二取异自立义者。自义已为他所破。更思惟立异法为义。是名取异自立义。外曰。声常。何以故。无触故。譬如虚空。是义已立。论曰。若汝立声常依无触因。无触因者不定。心欲嗔等并无触而是无常。声亦无触。是故不可定。如虚空等常不如心等无常无触。既不定汝因则不成就。因若不成就立义亦不成就。是义已破。外曰。声及常并非我义。我所立义常与声相摄。声与常相摄。我所说声为除色等。我所说常为除无常等。常不离声离色等。声不离常离耳所执等。不相离名相摄。是我立义。不立声亦不立常。汝难声难常并不难我义。是名取异自立义堕负处。三因与立义相违者。因与立义不得同。是名因与立义相违。外曰。声常住。何以故。一切无常故。譬如虚空。是义已立。论曰。汝说一切无常。是故声常者。声为是一切所摄。为非一切所摄。若是一切所摄。一切无常。声应无常。若非一切所摄。一切则不成就。何以故。不摄声故。若汝说因立义则坏。若说立义因则坏。是故汝义不成就。是名因与立义相违堕负处。四舍自立义者。他已破自所立义。舍而不救。是名舍自立义。外曰。声常住。何以故。根所执故。譬如同异性者根所执故常。声亦根所执是故常住。是义已立。论曰。汝说声根所执故常住。根所执者与无常相摄。譬如瓦器等。瓦器等根所执故无常。声应无常。汝说如同异性常。是义不然。何以故。牛等同异性。为与牛一。为与牛异。若一牛是实。同异性不实。若异离牛同异性自体应可显。离牛既不见同异性。不成常住譬。汝立义不得成就。是义已破。外曰。谁立此义。是名舍自立义堕负处。五立异因义者。已立同相因义。后时说异因。是名立异因义。外曰。声常住。何以故。不两时显故。一切常住。皆一时显。譬如虚空等。声亦如是。是义已立。论曰。汝说声常住不两时显。譬如虚空等。是因不然。何以故。不两时显者不定常住。譬如风与触一时显而风无常。声亦如是。外曰。声与风不同相。风身根所执。声耳根所执。是故声与风不同相。论曰。汝前说不两时显故声常住。汝今说声与风不同相。别根所执故。汝舍前因立异因。是故汝因不得成就。是名立异因义堕负处。六异义者。说证义与立义不相关。是名异义。外曰。声常住。何以故。色等五阴十因缘。是名异义。七无义者。欲论义时诵咒。是名无义。八有义不可解者。若三说听众及对人不解。是名有义不可解。若人说法。听众及对人欲得解。三说而悉不解。譬如有人。说尘无身。生欢喜生忧恼。不至而有损益。舍弥多。不舍则灭。声常住。何以故。无常常故。是名有义不可解堕负处。九无道理义者。有义前后不摄。是名无道理义。譬如有人。说言食十种果三种毡一种饮食。是名无道理。十不至时者。立义已被破后时立因。是名不至时。外曰。声常住。何以故。譬如邻虚圆依常住故圆常住。声亦如是。论曰。汝立常义不说因。立五分言不具足。汝义则不成就。此义已破。外曰。我有因但不说名。何者为因。依常住空故。论曰。譬如屋被烧竟更求水救之。非时立因救义亦如是。是名不至时。十一不具足分者。五分义中一分不具。是名不具足分。五分者。一立义言。二因言。三譬如言。四合譬言。五决定言。譬如有人言声无常。是第一分。何以故。依因生故。是第二分。若有物依因生是物无常。譬如瓦器依因生故无常。是第三分。声亦如是。是第四分。是故声无常。是第五分。是五分若不具一分。是名不具足堕负处。十二长分者。说因多说譬多。是名长分。譬如有人说声无常。何以故。依功力生无中间生故。根所执故。生灭故。作言语故。是名长因。复次声无常依因生故。譬如瓦器。譬如衣服。譬如屋舍。譬如业。是名长譬。论曰。汝说多因多譬。若一因不能证义。何用说一因。若能证义何用说多因。多譬亦如是。多说则无用。是名长分。十三重说者。有三种重说。一重声二重义。三重义至。重声者。如说帝释帝释。重义者。如说眼目。重义至者。如说生死实苦涅槃实乐。初语应说。第二语不须说。何以故。前语已显义故。若前语已显义。后语何所显。若无所显。后语则无用。是名重说。十四不能诵者。若说立义大众已领解。三说有人不能诵持。是名不能诵。十五不解义者。若说立义大众已领解。三说有人不解义。是名不解义。十六不能难者。见他如理立义不能破。是名不能难。论曰。不解义不能难。是二种非堕负处。何以故。若人不解义不能难。不应与其论义。论曰。是二种极恶堕负处。何以故。于余堕负处。若言说有过失。可以别方便救之。此二种非方便能救。是人前时起聪明慢。后时不能显聪明相。是愚夫可耻。是名不能难。十七立方便避难者。知自立义有过失。方便隐避说余事相。或言我自有疾。或言欲看他疾。此时不去事则不办遮他立难。何以故。畏失亲善爱念故。是名立方便避难堕负处。十八信许他难者。于他立难中信许自义过失。是名信许他难。若有人已信许自义过失。信许他难如我过失。汝过失亦如是。是名信许他难。十九于堕负处不显堕负者。若有人已堕负处。而不显其堕负。更立难欲难之。彼义已坏。何用难为。此难不成就。是名于堕负处不显堕负。二十非处说堕负者。他不堕负处说言堕负。是名非处说堕负。复次他堕坏自立义处。若取自立异义显他堕负而非其处。是名非处说堕负处。二十一为悉檀多所违者。先已共摄持四种悉檀多。后不如悉檀多理而说。是名为悉檀多所违。若自摄持明巧书射与生因律沙门悉檀多不如理说。是名为悉檀多所违堕负处。二十二似因者。如前说有三种。一不成就。二不定。三相违。是名似因。一不成就者。譬如有人立马来。何以故。见有角故。马无角。角为因不成就。不能立马来。二不定者。譬如有人立秦牛来。何以故。见有角故。有角不定牛。羊鹿等亦有角。角为因不定。不能立秦牛来。三相违者。譬如有人立昼时是夜。何以故。日新出故。日新出与夜相违。日出为因不能立夜。若人立此三种为因。是名似因堕负处。

如实论反质难品一卷


入大乘论

    No. 1634

入大乘论卷上(本无阙第一品名目)

        坚意菩萨造

        北凉三藏法师道泰等译

今欲解入大乘义。问曰。何故说入大乘义。答曰。我为众生欲遮苦因故。汝今当知。或复有人近恶知识。为恶所误偏执己法。专著邪见。颠倒思惟。不解实义。不顺佛智。诽谤圣说。诽谤圣说者。则坏正法。坏正法者。得大罪报如世尊说。谤法之罪。重于五逆。恶道长远。久受苦报。如偈说曰

  诽谤大乘法　　决定趣恶道
  此人受业报　　实智之所说
  生堕地狱中　　大火炽然身
  焚烧甚苦痛　　业报罪信尔
  炽然大铁犁　　具满五百数
  而耕其舌上　　遍碎身苦恼
  若从地狱出　　复受余恶报
  诸根常缺漏　　永不闻法音
  设使得闻者　　复生于谤法
  以谤法因缘　　还堕于地狱

谤法众生闻如是说。于大乘中。便生疑心。如尊者提婆所说偈

  薄福之人　　不生于疑　　能生疑者
  必破诸有

若有疑者。皆应听法。闻已意解。便得开悟。得开悟已。即生信心。生信心已。便生喜乐。生喜乐已。如是次第。生闻思修。乃至具足得一切种智。因谤大乘。而堕恶道。亦由大乘。起诸善业。如人因地故倒。还依地而起。又因于智。趣菩提道。亦与众生。共和合有。若离众生。则无有得菩提道者。从众生界。出生一切诸佛菩提。如尊者龙树所说偈

  不从虚空有　　亦非地种生
  但从烦恼中　　而证成菩提

问曰。汝说善入摩诃衍论。如是功德云何名为摩诃衍耶。答曰。菩萨藏处名摩诃衍。问曰。佛不说三乘亦摩诃衍乎。答曰。如是。此大乘中。亦说三乘。即名三藏。如菩萨藏经中说。佛告阿阇世王。族姓子。藏有三种。何等为三。谓声闻藏。辟支佛藏。菩萨藏。族姓子。非以声闻乘故名为三藏。亦非以辟支佛乘故名为三藏。唯诸菩萨所学大乘。得名三藏。何以故。夫说法者。具足三乘。乃名三藏。以菩萨说法能具三乘故。是故我说名三藏耶。族姓子。有三种学人。声闻学。辟支佛学。菩萨学。声闻乘者。不学辟支佛乘。何以故。非所解故。辟支佛乘者。不学菩萨乘。何以故。亦非所解故。族姓子。唯诸菩萨虽学声闻辟支佛乘。而不证于声闻辟支佛道。学菩萨乘。深知菩萨所行之法。常乐随顺。以是义故。菩萨乘者名为三藏。非谓声闻辟支佛乘。于余经中。以具分别。是故我今但略说耳。如汝意谓非三藏者。汝今但以增一阿含。中阿含。长阿含。杂阿舍百千等偈。以为一藏。毗尼阿毗昙二百千偈。名为二藏。尽具修习。名为三藏。若如是说。不名三藏。所以者何。诸余经等。则非佛说。有如是过。阿含。毗尼。阿毗昙等。亦是三藏。杂藏。舍头罗经。胎经。谏王本生。辟支佛因缘。如是八万四千法藏。尊者阿难从佛受持者。如是一切皆有非佛语过。若无过者。当知一切尽是佛说。如是所说。若皆是藏。此则便有百千等藏。汝言三藏。是语自坏。复有阿难所不受者。佛成道二十年后。方于僧中自言。我年老大。须供给人。若能为我作给侍者。当自言能。尔时大众和合。即差阿难为佛侍者。阿难便语同梵行人。如来有八万四千法聚。我今悉能受持。唯先二十年中。有二比丘。所受持者。皆悉不了。以是义故。当知阿难所受持者。不名多闻。佛所说法中。阿难实有不任器者。如中阿含说。释提桓因语郁多罗言。尊者。我得他心智。观阎浮提一切众生。无有尽能受持佛法。唯除尊者。余不能了。以是因缘当知阿难非悉能持一切佛法。声闻弟子。及以阿难。不任法器。诸大乘经。已具广说。如首楞严经中。佛为净月藏天子说。阿难所持少不足言。不受持者乃有无量。我所知法。百千亿分。不说其一。阿难于我所说法中。百千亿分。不持其一。善男子。我于一日一夜。十方世界梵释。四天王。天龙。夜叉。乾闼婆。及诸菩萨。一切来集。为说智慧修多罗偈颂章句。众生所行诸波罗蜜。及说声闻辟支佛乘。厌恶生死。赞叹涅槃。满足诸波罗蜜。乃至为诸天子广演说法一日一夜假使满阎浮提如微尘数。多闻智慧皆如阿难。于一日一夜。百千亿分亦不能持具足一分。乃至复满十方微尘世界皆如阿难。不能尽持亦复如是。处处经中亦说。阿难不任法器。以是义故。当知阿难不能尽持一切佛法。问曰。如来世尊不说阿难于多闻中为第一耶。答曰。佛于声闻众中。假说阿难以为第一。非谓菩萨。又复汝等于阿难所持尚不尽闻。况于大乘具足深义。汝意若谓是声闻乘即大乘者。此事不然。何以故。因果异故。若声闻乘因与大乘因。而不异者。果亦应不异。现见果异故。当知因亦异。何以故。声闻学者。但断结障。观无常行。从他闻法。菩萨所断微细诸习。乃至空竟观一切法。不从他闻得自然智。无师智。以是义故。非以声闻乘同大乘也。问曰。佛不说解脱无异也。答曰。声闻解脱时。颇能令使须弥山等。尽向道场。悉皆曲躬。光明遍照十方世界。八十由旬一切魔众。悉来降不。菩萨解脱。如上所说。悉能为之。以是义故。佛于余经。虽说解脱相等无异。大小实殊。犹如虫啮芥子中空。虽有空名。当与十方世界中空得为一不。空虽不异。大小有别。又如荧火欲等日月。亦如蚊子比金翅鸟。如娑留枝比丘。说佛本行偈

  一切诸光明　　灯焰与掣电
  星月照差别　　日光最第一
  飞行诸禽兽　　蚊蚁及与蜂
  众鸟飞各异　　金翅最不同

以是故。虽少相似。大小有殊。当知因既有异。果岂同耶。汝言解脱无异。如是观察。解脱不同。声闻解脱。名爱尽解脱。非一切解脱。但为钝根少智众生。假分别说。大乘解脱。断烦恼习。一切都尽。为利根菩萨。广分别说。如汝今说。声闻解脱。即大乘解脱者。如来则非一切种智。有如是过。如佛小疾。遣目连诣耆鞠所。当须何药。是时耆鞠已亡七日。生忉利天。目连即便诣彼天所。尔时耆鞠将入后园。即便问言。如来有疾。当须何药。答曰。用酥。如来身者。犹如金刚。诸恶已灭。岂有疾乎。而问耆鞠。如婆拘罗比丘。于九十劫前。以一药果。施同梵行者。于九十劫中。身常无病。于最后身。年至八十。初无微病。正以此一诃梨勒果微施因缘。尚得无病。况复如来亿百千万阿僧祇劫。具足檀波罗蜜。备诸功德。乃至截身手足髓脑血肉。而施病者。以是因缘。岂得疾耶。如经所说。则现如来非一切智。如来又时入城乞食。空钵还归。为度于提婆达多令使出家。如枯树经说见大火聚。尔时诸比丘中便有生退心者。为度马师满宿故。数数骂婆罗门夺赖阇。萨遮尼干。孙陀利等。于九十日中受食马麦。目连。舍利弗。入于陶室。乃有如是等事。汝意若谓有余业者。此则不然。何以故。如来已尽一切诸恶。具满一切无量功德。有余恶业。则有大过。汝曾不闻诸经中说如来永断一切烦恼业结习耶。如摩陀遮离所说偈赞

  一切结习尽　　唯有救世者
  一切智所有　　功德悉成满

有三种习。所谓业习。烦恼习。威仪习。此三种习。如来永尽。以是因缘。若有余业。此则大过。汝今若谓是方便者。此亦不然。何以故。汝意先谓。佛身是实。不言方便。及与应化。汝常自言。佛身是一。何得复有方便应化。汝于何经闻说方便。及应化耶汝经中说唯有后边身。不言别有法身。与应化方便身异。而我十住经中所说。别有法身。不与方便应化身同。是故。大乘经中说。佛是一切智。则无有过。汝小乘中说一切智。则有大失。若谓声闻乘。即是大乘。此事不然。大乘者。与声闻乘。则有差别。以广大故。汝意若谓声闻乘中显示大乘。是亦不然。何以故。理相违故。声闻乘者。从他闻法。大仙之乘。绍三宝种。不断绝故。如毗琉璃宝终不出于水精之中。体差别故。是故大乘微妙甚深。其心广大。菩萨摩诃萨次第修学。始从初地。乃至十地。具足一切功德智业。是故佛说名为摩诃衍乘。若声闻乘从摩诃衍出。则有是理是故菩萨修学十地。具满一切诸波罗蜜故。能出生三乘善法。如十地经说。金刚藏菩萨语解脱月菩萨言。佛子。譬如字章字本为初。一切文字皆出字本。如是佛子一切佛法亦复如是。以地为初。亦从于地。而得究竟。成自然智。是故大乘名曰甚深。出生一切声闻功德。非谓小乘能出大也。佛说十地。犹如金聚具足无失。云何不受。如来以慈悲力。为钝根故。说声闻乘。而汝信受。便自偏执。受行小法。不信大乘平等正教。是故当知佛说大乘。名最吉胜。问曰。世尊昔说。于我灭后。当来世中。多有众生。起诸诤论。此是佛说。此非佛说。是故如来以法印印之。若义入修多罗。随顺毗尼。不违法相。是名佛说。答曰。佛亦不言。声闻乘者。非是我说。乃至菩萨大乘亦复如是。佛说不异。等一相故。以法印印。汝言入者。为是义入修多罗。为文字入耶。若以文字入者。无有是处。何以故。十二部经。一切文偈章句各异。是故当知非文字入。若以义入理不相违。义者若顺修多罗义。与法相相应。其义显现。是故名为顺修多罗耶。若显示声闻法。名声闻乘。随顺入修多罗。若显示辟支佛法。名辟支佛乘。随顺入修多罗。若显示菩萨法。名菩萨乘。随顺入修多罗。若我显示十地功德。明菩萨行。是名真说。随顺入于大乘。但汝意偏党独谓入小乘三藏。大乘三藏中。我已说入。是故三藏即是大乘。何以故。十二部中。说毗佛略。即是大乘。如中阿含说。云何名丘丘。所谓知法以能善解十二部经。修多罗乃至忧婆提舍。毗佛略者。是摩诃衍。何以故。毗佛略经。为诸众生说修对治法故。名毗佛略。亦有众多乘故。名毗佛略。亦以多庄严具故。名毗佛略。亦能出生无量大果报故。名毗佛略。非是称量所能知故。名毗佛略。除断一切诸邪见故。名毗佛略。若汝意谓。我声闻法中。广说修多罗偈颂章句。亦名毗佛略者。无有是处。何以故。汝依阿含说为毗佛略。但有言语。若但言语。此非可信。若阿含经中。必有斯义。何处章句。为声闻说。是毗佛略。若无定文。是故当知毗佛略者。显发大乘。非谓声闻小乘说也。汝声闻经一部所说。终无百千偈赞文句。况复当有亿万广说。如来世尊。教诸声闻。唯示无常。令厌生死。使知苦本。速求涅槃。从初如是。乃至奉行句味鲜少。则无甚深广大之义。大乘经说菩萨所为。其事深广。如大喻经。贤劫三昧经。解脱经。华首经。如是等。悉是摩诃衍。皆名毗佛略。如结解脱经中。善财童子。诣善知识海幢比丘所。十二年中。入大海三昧。白海幢言。此三昧中。深广无边。更有法门大此三昧不。说是语已。于大海三昧中。见大莲华。佛从中出。即以右手摩海幢顶。赞言。善哉善哉。善男子。更有普眼法门。汝当受持。海幢即受普眼法门章句。次第为他广说。告善财言。善男子。我于一刹那顷。所可受持普眼法门。用大海水尽以磨墨。积大纸聚犹如须弥山。天下草木持以为笔。三千世界水陆众生。悉为书师。于一刹那顷。所受法门。百千分中。犹不能书尽其一分。况复一日一夜。乃至十二年中。所受甚深无量无边大分要义。善财童子于一善知识所从闻法已能如是无量无边过亿千数。况复咨问微尘世界诸佛等边。及善知识所受教法。以是因缘。具足大乘。名毗佛略。无量无边非声闻耶。此义甚深。是故一切声闻所修行法。悉入摩诃衍道。最为大吉。是名随顺修多罗义。今当复说随顺比尼。三乘圣道皆同断贪欲嗔恚愚痴。名为比尼。修多罗者。分别因果。阿毗昙者。分别法相。亦断烦恼。摩诃衍者。亦说断除贪欲嗔恚愚痴烦恼一切恶法。佛教声闻净己三业名为比尼。为菩萨说净己三业。乃至成佛兼及众生满足一切尸波罗蜜。菩萨所持是自性戒。发菩提心。得真实果。是故当知摩诃衍者。随顺比尼不违法相者。三乘经说不违十二因缘。大乘亦不违十二因缘。善观察者。能知大乘即三法印。若不善观察。则无大乘。亦不具三乘。若诽谤摩诃衍者。是大过罪。汝今若言。此是魔说。佛所不说。然诸经中。实无此语。若但口言为大乘者是魔所说。终不可信。汝意若谓是佛说者。犹如师子身中生虫。则还食师子。三乘皆尔。不独大乘。是故当如摩诃衍者。非魔所及。唯佛能说。问曰。汝非魔说。我是魔乎。答曰。我与汝等俱非魔耶。问曰。若谓我与汝。等俱非魔。说言魔说者。此则应遮。答曰。我大乘法利及与众生顺于法相故多魔事。是故如来于大乘中。说言遮魔。汝小乘法。唯能自度。魔不扰恼。何须遮乎。是以如来昔于法华及般若经中说。于当来世。多有众生。喜起嫉妒故遮诽谤。堕于恶趣汝所诵习。于何部经中。言摩诃衍是魔所说。若汝经中。不言摩诃衍魔所说者。自言魔说。此亦叵信。汝意若谓声闻法中。亦有遮断。但事已久灭。难可证据。此亦不然。何以故。非处所故。若假令遮佛以神力则能守护此法。经劫亦不坠没。是故当知汝言久者。但有言语。假令魔说。能除惑障。不违正法。虽曰魔说。即是正法。与佛语不异。何以故。如佛所说。依法不依于人。是以我今但从正理。不取名字。又我等所求。能灭智障。烦恼障者。即是世尊若实魔者。终不能说菩萨之法。何以故。魔不能知菩萨从禅定生闻思修慧。厌离欲恶不善之法。是大乘义。唯佛能说。从于初地。乃至十地。如是次第。四禅。四无量心。四无色定。灭受想定。菩提心。诸波罗蜜。随宜方便成熟摄众生法。十善道戒闻智慧不放逸。离世八法。八圣道。转法轮。坚持头陀具足功德。苦空无常无我寂灭。十二因缘。出入诸禅。三解脱门。诸陀罗尼。三十七品助道之法。诸神通门。实谛四辩。禅智二轮。以自庄严。皆悉和合。游戏诸法。而于生死涅槃等中。不背生死。亦不向涅槃。心常厌恶。正观诸地。出离诸地。不堕声闻。辟支佛地净佛国土。随顺法忍。无生法忍。不退转地。受正位地。力无畏不共法。相好法身。为众生故住于生死顺转决定转。随顺不转。决定不转。如是等因果次第法。不共法。非觉法。魔不能说。非魔境界故。魔有四种。若言阴魔作是说者。我终不说佛有阴身。又复若言实是魔说。如斯语者。弥勒菩萨亦应遮止。又尊者宾头卢。尊者罗睺罗。如是等十六人诸大声闻。散在诸渚。于余经中亦说有九十九亿大阿罗汉。皆于佛前取筹护法住寿于世界。东方弗婆提渚。麦渚。粟渚。师子渚。阎浮渚。大阎浮渚。跋提梨伽处。罽宾。乃至阿耨大池。诸贤圣等皆住。守护佛法。若言摩诃衍是魔所说者。则为佛法之大患也。诸贤圣等悉应遮断。是故当知言魔说者。皆是妄语。空作斯说。又大菩萨诸贤圣等。皆护大乘。是摩诃衍绍三宝种。不令断绝。问曰。如汝所说。若摩诃衍是三宝种。皆悉拥护菩萨声闻。如今云何于诽谤大乘者。何不遮止。使斯人辈。不堕地狱。不趣恶道。不坏佛法。答曰。业报决定不可除断。业有二种。一者决定增长。二者决定受报。非诸菩萨声闻贤圣所能除灭。造作恶业决定受报。不可救止。如瞿迦离比丘。诽谤摩诃衍经是魔所说。当知是人必堕地狱。无能拔者。问曰。汝言谤摩诃衍。能入恶道。亦是粗语。我未信耶。答曰。汝言佛说摩诃衍是魔语者。即是诽谤三世诸佛。亦是一切众生大怨。所言甚粗犷。当受恶口不善重报。如佛偈说

  人生于世间　　如斧在口中
  自斩害其身　　斯皆由恶业

汝谤摩诃衍。如是粗语。非我所说。我今但欲令汝不起诽谤。为利益故。便作是说。犹如病人食不应食。良医瞻病。禁断不听。为怜愍汝。妄作绮语。言摩诃衍是魔所说。过去诸佛已说摩诃衍。未来诸佛当说摩诃衍。现在诸佛今说摩诃衍。是名遮断诽谤摩诃衍论。菩萨为断诽谤大乘。是故演说初入摩诃衍论品。问曰。汝已遮他不令诽谤。今当云何入摩诃衍行。答曰。菩萨当先具种性。随顺善行。所解广大。内心广大。界分广大。种性广大。性既具足。其心调柔。渐损烦恼。少贪嗔痴。好修诸善。精勤诵习。如是众生。六根广大。能发大愿。欲求佛道。种性相貌。如佛所说。下根下性。下发道意。所愿亦下。中根中性。中发道意。所愿亦中。上根上性。上发道意。所愿亦上。是故诸佛。随其根性。则以慈心。分别教授。问曰。若诸众生。各有根性。云何应为随根说法。答曰。上根众生为说菩萨深妙法藏。以知根性堪菩萨行故。说菩萨藏。问曰。为菩萨藏者。当住何地。答曰。有十种行。到解脱地。能听菩萨藏时。得十种法行。离解脱行。便得入于菩萨之行。何等为十。一者修菩萨解脱行。若多若少。皆悉修习。二者菩萨所有之法。若多若少。皆悉书写。三者菩萨藏法。若多若少。皆悉供养。四者菩萨之法。若多若少。皆悉转读。五者菩萨之法。若多若少。皆悉听受。六者菩萨之法。若多若少。皆悉受持。七者菩萨之法。若多若少。皆悉习诵。渐渐通利。八者菩萨之法。若多若少。皆悉为他分别演说。九者菩萨之法。若多若少。皆悉思惟。善解义趣。十者菩萨之法。若多若少。独处思惟。修集增明。是名菩萨十行。第八者是菩萨闻慧。第九者是菩萨思慧。第十者是菩萨修慧。问曰。菩萨得是闻思修已。当入何行。答曰。为得己地入解脱门。如是次第。闻思修生。为见法界。得于己地修三解脱门。问曰。何等名为三解脱门。答曰。行空无相无愿。问曰。云何为空。答曰。观我人众生。无有自体。性相常寂。问曰。云何解了。答曰。当入十二因缘。问曰。是空解脱异十二因缘法耶。答曰。空与十二因缘。等无异相。空即十二因缘。十二因缘即是空。何以故。因缘假起。无有自体。如尊者龙树所说偈

  十二因缘空　　我今欲解说
  假名因缘法　　此即是中道

一切诸法悉皆空寂。何以故。皆属因缘无自性故。问曰。若一切法因缘生者。何故说言无体性耶。答曰。所言因缘世谛故说。第一义谛则无体性。亦无有生。既无有生。亦无有灭。无生无灭。即真寂灭。真寂灭者。即是一切诸法寂灭。是故我说一切诸法无有体性。如老母经中世尊所说。姊譬如因人因桴因鼓。众缘和合便有声出。如此之声。不在三世。亦非内外及在中间。其性空寂。无生无灭。姊今当知一切诸法体性亦然。老母经中佛自说空。是故菩萨于无量劫。修集福德禅定智慧。悉入三解脱法门。善观生灭皆悉空寂。犹如幻炎。乾闼婆城。皆同梦化。如佛说言

  初觉十二缘　　众生皆悉空
  刹那顷所得　　幻炎乾闼城

如是次第。入空解脱门。其心快乐。逮得义利。问曰。外道各着我见。云何遮断。答曰。如是外道。于内外色。皆生染着。取我我所。顺生死流。彼着我者。我能施与饮食财利。如是种种依止我见。众生等见。彼我我所者。我之造作。是我瓶物。如是等名依止我所。彼所作业。若一若异。若一异。若不一不异。取着偏执。但以言语。诳惑于世。及以己身。以是义故。流转生死。不解因缘诸法性空。问曰。是诸外道。不解因缘。而起四执。何者为过。答曰。僧佉所说。有计一过。作与作者一。相与相者一。分与有分一。如是等皆名为一。优楼佉计异。尼健陀计一异。若提子计非一非异。一切外道。及摩他罗等异计。皆悉不离如是四种。问曰。僧佉人言作与作者一有何过。答曰。语有二故不名为一。作是因作者名果。是事不同。云何说一。若实异言一。此则颠倒。何以故。以作者即是作故。作与作者。前后时异。云何为一。问曰。前后一用。如种生芽。时虽前后。但相似相续。故名为一。答曰。此亦有过。若作在先。作者在后。生未生异。云何为一。譬如有瓶终不得并。如牛角不相因生。作以作者亦复如是。复次所以作与作者不得为一。声别义别。因缘别时别。字别体别。若如是者。则有多过。若但一者。不应二名。声义体相先后异故。不得为一。若作与作者一。如取泥团陶师。轮绳酥酪等物皆悉应得。以不得故。当知非一。如我心不得为一。若是一者。心无常故。我亦应无常。以是故作与作者。相与相者。量与量者。分与分者。悉同是破。有一瓶等亦应破遮。如色与瓶一。及白[疊*毛]青叶。长短方圆。如是等物作悉应遮。问曰。比舍师计异。有何过耶。答曰。若作与作者异亦有大过。问曰。云何为过。唯愿说之。答曰。若瓶与泥异。作瓶时应取缕。作[疊*毛]时应取泥。以作瓶不取缕故。当知不异。复次泥团。因微尘成。瓶因泥团成。若瓶异泥团者。瓶则无体。泥团成瓶故。不得为异。泥团于微尘为作者。于瓶为作。若作与作者异。泥于微尘瓶但名异。不应有二。以是故作与作者。不得为异。因缕成[疊*毛]。因蒲成席。皆亦同是说。复次若有一瓶异则一切法坏。何以故。若有一非瓶。离应有瓶。若有一是瓶。则为多瓶。有一非故。异亦应非。是则无瓶。以是义故。汝计异者。即坏一切法。问曰。如此说者。非坏一切法。何以故。有一依瓶立。是故有一瓶等皆成。答曰。若有一与瓶合。有一应是瓶。若瓶与有一合。瓶亦应名有一。以有一合故。不得为异。复次有一异者。犹如白[疊*毛]。此亦有过。何以故。白则非[疊*毛]。[疊*毛]亦非白。白与[疊*毛]异。余物亦然。如烧[疊*毛]时。白不应烧。若[疊*毛]烧时。白亦烧者不得为异。汝今以言物异相异。此事不然。汝先言。六事各异。此则应遮。问曰。尼健陀先言一异。有何过耶。答曰。汝所谓一异者。或说作以作者一。或说作以作者异。此亦多过。问曰。有何过耶。答曰。若作即是作者。事则不成。若作与作者异。事亦不成。何以故。因果各异。云何为一。以众缘成果故。不得为异。作相作者相。亦皆如是。问曰。如瓶相破。而体不破。以体不破故。亦得为异。以见体在。而相破故。若破瓶时。本成体无。不得为异。答曰。若言一。同僧佉破。若言异。同比舍师破。如叶青[疊*毛]白。亦皆俱破。问曰。若提子计不一不异。有何过耶。答曰。前三计者。各有所执。汝说不一。应当是异。若说不异。即应是一。何所执故。而言不一不异。若无所执。妄有所说。则坏法相。问曰。汝说大乘。亦无所执。汝亦应坏一切法相。答曰。我之所执。世间现见。是因缘法。汝之所说。但是颠倒不顺法相故。问曰。何者是法相。而说我坏法相耶。答曰。无体相者。即是体相。问曰。云何无体相。为体相耶。答曰。空名无体相。问曰。云何名空。以有为空。以无为空耶。答曰。我不以有义故名空。亦不以无义故名空。以离于有无故名为空。如尊者龙树所说偈

  执有名为常　　计无则为断
  若离于有无　　是名真实空

复次如龙树中论中说偈

  执有取体相　　执无著无体
  不存于有无　　是名真实观

以是故。以离有无名空。离断常故。名为中道。若能觉悟如是法相故名为佛。是故十二因缘义。名之为空。问曰。十二因缘以何为证。而知为空。答曰。譬如瓶泥团轮绳。及以陶师。众缘和合。然后成瓶。非即泥团是瓶。亦非离泥团有瓶。但假名说瓶。属众因缘。无有体相。无体相故无生。无生故体相寂灭。因缘所成。是故无体。若诸法定有自体。不假因缘。则无是处。以无自相故无瓶。瓶无故一切法亦无。如尊者提婆所说偈

  一法若有体　　诸法亦复然
  一切法本无　　因缘皆悉空
  真实观一法　　诸法不二相
  谛了是空已　　则见一切空

问曰。因缘生法。即是体相。答曰是事不然。何以故。若有体相。若无体相。非汝所及。如汝所说。以因缘为体相者。因缘从他生故。云何有体。言体相者。自性而起。不属因缘。若属因缘。则无自性。譬如假借非自有也。是故因缘假他而成。无有自体。如尊者龙树所说偈

  因缘所生法　　是即无自性
  若无自性者　　云何有体相

问曰。诸法体相。世间现见。云何无耶。答曰。是事不然。凡愚妄见。此非可信。生灭之法。皆悉是空。生灭流速。无暂停时。相似相续故。妄见为实。犹如灯炎。念念生灭。凡夫愚人。谓为一炎。亦如駃流。影响幻炎。如佛所说。幻及幻者。都无所有。而妄见者。谓之为实。若是实者。饿鬼不应见水为火。沙石脓血。而诸众生。以善恶故。随业所见。若有净心。利根众生。则能见空。夜叉饿鬼。远见其水。近则见火。便生疑惑。若物有实。不应二见。以二见故。则知非实。但妄见故。当知一切诸法皆无体相。以无体相故。都无生灭。问曰。若一切法无生无灭。云何得有来去计断常过。答曰。以见种子故。便计来去。若得法空。则离断常。如因种子有芽茎枝叶花果次第而见芽生故种子灭。是以不断。乃至果生故花灭。亦无常过如尊者提婆所说偈

  诸法相续有　　则非是断灭
  因灭故果生　　不得名为常

以是故。见因缘空。即离断常。问曰。痴因缘行。云何而得离于断常。答曰。因无明故。有善恶行。乃至因生故有老死。凡夫不解因缘相续。妄计为实。无明体空故。行亦体空。乃至生体空故。老死体空。以世间假名有相续故。无断灭过。念念不住。无有常过。以凡夫众生死此生彼。相似相续故。如佛所说。第一义中。无有众生死此生彼。但以世谛假名说故。识为种子。行业为田。以慢土覆。无明为粪。爱水为润。父母精气。众缘和合。生名色芽。是故名色无有自体。犹如床脚。相假而用。初名歌罗罗。二名安浮陀。三名肉段。四名坚实。五名诸炮开张。六名为触。生法次第。相假而有。不名为断。菩萨善解因缘法故。即知其空。以因缘空故。一切法空。解法空故。无断常过如出胎经中佛所说偈

  随假名字　　而得诸法　　名中无法
  是则真实

以是故。非言说故。有法。若随名字。有诸法者。法则多体。犹如空法。无一无多。问曰。若一切法无体。汝言有过现见有故。答曰。若法是有。言无则过。法既非有。云何言过。以是故。诸法如初。后亦复然。若诸法定有体相。后涅槃时。应是断灭。若先非是空。后言空者。则是邪见。坏于正法。亦无解脱。如尊者提婆所说偈

  不空而见空　　我应得涅槃
  邪见非涅槃　　如来之所说

诸法本空故。恒见是空。如过去佛所见空相。今亦复然。是故我说因缘法空。是则无过。如是先立第一义谛。后分别世谛。我及众生。作与作者。乃至一异。则无过失。如尊者龙树所说偈

  不说分别谛　　不得于实谛
  若不得实谛　　则无得涅槃

复次说偈

  诸佛演说法　　常依于二谛
  分别于世谛　　及与第一义
  若不能分别　　真俗二圣谛
  如是则不知　　佛法甚深义

是故因缘法空。名为真如。法性实际。是名修习第一义禅。见因缘空。即是空解脱门。若见空者。则不见诸法相。是名无相解脱门。见无相故。无所愿求。是名无愿解脱门。安住如是三解脱门。识种子于三界内。则更不生名色等芽。识无取着。灭三有苦。三有灭故。得寂灭涅槃。如尊者提婆所说偈

  识是种子义　　游行于六处
  若见诸尘空　　有芽则断灭

问曰。菩萨度空。出于生死。云何能得胜于声闻。答曰。菩萨得世间利。出世间利。度尔炎地故。虽出世间。能住世间。教化众生。声闻不然。怖畏生死。求速灭度。以出世间道。见于法界。见法界已。到涅槃岸。菩萨不尔。何以故。菩萨见众生苦。起大悲心。为欲度彼坚住庄严。于阿僧祇劫。修行出世间道。于一念顷。观一切法界。观法界已。众生缘故。不取果证。乃能度脱。如佛阿耨大池经中说。譬如二人欲堕山顶。一人有力。善巧方便。以巧便故。虽堕还起。得升山顶。一人力少。复无方便。即住退堕。不能复起。菩萨于无为法中。不证不着。如善巧人得升山顶。声闻之人。以证着无为故。如少方便者。堕而不起。譬如长者唯有一子。以饥俭故。远至他国。经数十年。长者后时。住一大城。其家巨富。多积珠珍。渐得佣力故。还来本国。菩萨有无量无边阿僧祇功德到尔炎地。向于涅槃。以愍众生故。还入生死。于阿僧祇劫。久受勤苦。菩萨摩诃萨乘大苦乘。求无上果不可思议。出过一切声闻辟支佛上。具足一切功德智慧。是故超度尔炎之地云何菩萨乘大苦乘。譬如有人乘船入海。遇大恶风涛波如山。有如是等无量众难。诸伴心急。生大恐怖。是时船师巧持帆故。能度众难有福德人。得度难已。获大珍宝。菩萨摩诃萨处生死海。亦复如是。为恶知识不信所难。趣向恶道。第一阿僧祇劫。修治净地行。求净解脱。第二阿僧祇劫。修净禅定行。第三阿僧祇劫。修净智慧行。除尔炎地障。是故菩萨名乘苦乘。满足十地。得无疑无障。一切行具足故。得阿耨多罗三藐三菩提。是故以尔炎智。得成大果

入大乘论卷上入大乘论卷下

        坚意菩萨造

        北凉三藏法师道泰等译

    讥论空品第二

问曰。汝先说调顺乘大苦乘。得妙果报。菩萨所得境界。甚难了知。答曰。菩萨行处。微妙甚难。于三阿僧祇劫。乃可成就。无量百千万亿那由他劫。在凡夫中。无有出世之法。如尊者提婆所说偈

  无量亿劫中　　常在凡夫地
  汝今应当知　　未来亦如是

是故菩萨行处甚大。亦复难得。散乱众生。得闻甚难。能说亦难。况复修行。如尊者提婆所说偈

  生得值法难　　听说亦复难
  生死虽无际　　听法故有边

问曰。尊者先所说十地。愿时为我分别演说。何等为菩萨十地。答曰。初欢喜地。二离垢地。三名明地。四名焰地。五难胜地。六现前地。七深远地。八不动地。九善慧地。十法云地。云何名欢喜地。出过凡夫。得不思议出世间道。心生欢喜故。名欢喜地。云何名为离垢地。离破戒垢故。名为离垢地。云何名明地。依十二门禅。得明智慧故。名为明地。云何名焰地。得增上觉意分别道品。烧烦恼薪。功德炽然。故名焰地。云何名难胜地。修习十智。虽伏烦恼。未能胜故。名为难胜地。云何名现前地。能逆顺观十二因缘。得法现前故。名为现前地。云何名深远地。爱佛功德智慧次第不间余心深入法相故。名深远地。云何名不动地。离色等相坚固难动故。名为不动地。云何名善慧地。入四辩才。解一切音声。随其所问。于一刹那顷。悉皆能答故。名善慧地。云何名法云地。能受一切佛法。犹如大云。能注法雨故。名法云地。是名菩萨具足十地。如是十地。是菩萨安住行处。亦能满足一切智慧。如十地经中之所广说。若能如是知菩萨十地者。是名善知安住行处。亦名善知菩萨广大功德处所。亦能善知如来无量功德广大处所。若不能如是知者。我今立决定誓。当知是人于菩萨法。及如来法。皆悉不了。菩萨摩诃萨。从初发意。乃至十地。常修四行。如宝顶经中说。善知无明行。诸波罗蜜行。分别道品行。成熟众生行。如是四行。总入二轮。所谓福轮。智轮。菩萨诸地。悉具二种智果福果。问曰。云何成就二果。答曰。初地福果。为阎浮提王。第二地福果。为转轮圣王。主四天下。第三地福果。为天帝释。第四地福果。为焰魔天王。第五地福果。为兜率陀天王。第六地福果。为化乐天王。第七地福果。为他化自在天王。第八地福果。为千世界梵。第九地福果。为二千世界梵。第十地福果。为三千大千世界净居天王。如花严经广说。如来出生果报。及摄受世界。是名菩萨福轮。云何名菩萨智轮。初地菩萨。于一刹那顷。得百三昧。见百诸佛神通。能过百佛国土。能动百佛世界。光明遍照百佛世界。能成就百众生。能知过去百劫未来百劫。能入百法门。能现百身。复为一身。以百菩萨。庄严眷属。若以愿力。复过于此。百千万亿。无量无边。亦非算数譬喻所知。若身力。若光明力。若神通力。若眼力。若声力。若行力。若庄严力。若住持力。若解脱力。造众善业。是名初住。菩萨于刹那顷。成就如是无量功德。二住菩萨。得千三昧。如是广说。三住菩萨。得十万三昧。余亦如初住广说。四住菩萨。得亿三昧。余亦如初住广说。五住菩萨。得千亿三昧。余亦如初住广说。六住菩萨。得万亿三昧。余亦如初住广说。七住菩萨。得亿百千那由他三昧。余亦如初住广说。八住菩萨。得十三千大千世界微尘数三昧。余亦如初住广说。九住菩萨。得十佛世界百千阿僧祇微尘数三昧。诸余功德。如初住广说。十住菩萨。得十佛世界不可说不可说亿百千那由他微尘数三昧。诸余功德。如初住广说。于一刹那顷。乃至见十佛世界不可说不可说亿百千那由他微尘数诸佛。如初住菩萨。于一刹那顷。见百佛世界。乃至成就百众生。十住菩萨亦复如是。问曰。如佛所说。一世界中无二佛出。云何菩萨见十佛世界不可说不可说亿百千那由他微尘数诸佛。答曰。诸佛说言一世界中无二佛者。为彼钝根小心众生。不为利根大心者说。如汝经中说。一世界无二转轮圣王。无二佛出。然诸四天下实有众多转轮圣王。诸佛出世亦复如是。问曰。释迦牟尼佛。亦能遍一切佛国。何必余佛。答曰。若如汝言。但一佛能遍满一切世界者。不应有过去大释迦牟尼佛。七佛出世。得成正觉。是以我言多佛无过。假使释迦牟尼佛神力能遍一切世界。今无量诸菩萨等广修万行。功德满足皆当成佛。无有一人独成正觉而障诸菩萨使不成佛。无有是处。如阿含枯树法轮及余诸经。说是经时。有六十比丘。漏尽意解。俱得阿罗汉果。菩萨亦尔。功行齐等。同时成佛。当知十方有无量诸佛。又金沙阿含二部经说。有佛始成。有佛现在。有佛灭度。复次说偈

  过去无量佛　　未来亦复然
  及今成佛者　　皆灭于愁忧
  一切尊重法　　今本皆修行
  未来亦复然　　正觉法如是

昙无鞠多亦说是偈

  顶礼一切佛　　漏尽无有上
  无量诸佛身　　正觉最胜尊
  正觉所生处　　并及得菩提
  能转正法轮　　入无漏涅槃
  若住若经行　　如来之所坐
  卧如师子王　　我今皆悉礼
  上下诸世尊　　方面及四维
  法身与舍利　　敬礼诸佛塔
  东方及北方　　在世两足尊
  厥名曰难胜　　彼佛所说偈
  若以此偈诵　　常赞于世尊
  生死百劫中　　终不堕恶道

如佛为尊者目连说言。非汝退神足。但是舍利弗。以神通力。用其衣带。系难胜坐。如是等佛而汝经中。自作此说。况摩诃衍。辩明诸佛无量无边。等于法界。同虚空界。诸佛世界。悉有诸佛。初地菩萨。身行清净。虽有结使。而不能扰。七住菩萨不名断结。亦不名有结。云何名不有结不断结以不为结使所扰故。名为无结。爱佛功德故。名为有结。第二阿僧祇劫满足得于八地。一切行具足无有所作。一切结使尽故得成菩提。空静住处得灭尽定如阿罗汉。如是得无生法忍。若诸佛不劝请者。即于彼定。入无余涅槃。如经中说。得无生法忍。离烦恼障。如阿罗汉。得寂灭无余。离于生死。得十自在。何等为十。寿命自在。得心自在。众具自在。作业自在。生处自在。解脱自在。神通自在。愿自在。法自在。智自在。得如是自在。善修如意足故。降伏四魔。何等为四阴魔。烦恼魔。死魔。天魔。为众生故皆悉一味得无缘慈。犹如如意药树。随众生所愿。皆使成就。问曰。云何菩萨自身作业能令众生随愿令得。答曰。菩萨以慈心为体。犹如见毒而能杀人众生见菩萨故便得利益。问曰。八住菩萨以尽结使。云何最后身菩萨生罗睺罗。答曰。诚如所言。若最后身菩萨有实欲者。乃至无佛可得。况罗睺罗。问曰。云何无佛。答曰。若毁戒无尸波罗蜜。若无尸波罗蜜。则无诸波罗蜜。如佛所说。若无戒则无施。无施则无忍。无忍则无精进。无精进则无禅定。无禅定则无智慧。无智慧则无一切诸功德。无一切诸功德。则无佛。无佛则无罗睺罗。汝何以疑生罗睺罗有结无结八住菩萨无诸烦恼。如阿罗汉以方便力故。现受五欲。作诸过恶。舍四天下转轮王位。令使众生得厌离心。犹如娑留枝比丘说佛本行偈

  一身为多身　　作已极为胜
  非实亦非虚　　各各令喜悦
  放恣生欲意　　盛壮狂所乱
  现同行于欲　　引令到彼岸
  禅智能烧灭　　欲界诸结使
  欲结甚狂逸　　能示现其心

菩萨观欲知如幻梦。是故以此令转其意。大悲菩萨作诸幻术。而化其心。问曰。云何作此幻术诳惑众生。答曰。菩萨常以四摄法。方便教化一切众生。同事利益。为破结使故。如翅烧菩萨本事因缘。以欲狂心担负死尸走唤歌舞。菩萨方便亦现同彼。为除彼女炽欲忧患故现同事。不名妄语。一切菩萨方便同事。皆非妄语世间幻术。少有利益。菩萨得无量解脱如幻三昧门。诸有所为能大利益成就众生故无有过。问曰。罗睺罗为是应化。为真实耶。答曰。二俱无过。菩萨身者。即是天身。如本起经说。佛告阿难。如来为众生故。出现于世。不以天身转于法轮。何以故。欲令众生不懈怠故。佛以天身得成正觉非我凡夫之所能成。以是故天中天为怜愍众生故。示现世间。有其父母妻子眷属。若是幻化现有罗睺罗此亦无过。若是实人。亦无有过。菩萨方便。得不思议解脱。住于大地。成就众生。互为化生父母兄弟妻子

问曰。罗睺罗是菩萨耶。答曰。不但罗睺罗独是菩萨。住迦毗罗卫城诸释种童子。阿难难陀。提婆达多。阿[少/兔]楼驮等。皆是大力不退转菩萨。如婆罗楼志于本行经中所说偈

  或是大丈夫　　或是佛所化
  提婆达多者　　大仙之同伴
  或复为父子　　常作内眷属
  菩萨有大力　　权变能为此
  共佛及余人　　菩萨诸大仙
  阿难难陀等　　那律释摩南
  跋陀与桎沙　　忧波桎丽等
  作父子眷属　　咸皆共围绕

问曰。提婆达多。于五百身中。常与菩萨。而作大怨。云何复言名菩萨耶。答曰。提婆达多。非佛怨耶。何以故。若提婆达多是佛怨者。菩萨修善。提婆达多恒造诸恶。云何世世得与菩萨共俱相值以是义故。提婆达多非菩萨怨。譬如二人各行。一人趣东。一人向西步步相远。而常违背。云何为伴得相值耶。若提婆达多是菩萨怨者。如来世尊应有大过。问曰。有何过耶。答曰。若尔者佛非一切智。亦无神力。是为愚痴。则不能得拥护众生。非金刚身。如来便应有余业不能断尽。云何知佛非一切智。如来在耆阇崛山。为提婆达多推石所压。而不觉知。是故当知。如来非一切智。云何名为无有神力。提婆达多持杵打害。不能禁制。以是当知。无有神力。云何名为愚痴。现见害至。而不知避。是以当知。为愚痴也。云何名为不能拥护众生。提婆达多作五逆罪。而不救度。以是当知。不能拥护众生。云何名非金刚身。转轮圣王以少福报。而无怨害。何况如来。转法轮王为石所压身血流现。当知如来非金刚身。云何名有余作业不能断尽。为他所打。当知如来余业不尽。若欲令佛无是过者。如来便应悉灭怨敌。但以善巧方便。欲令众生起厌恶心。现作逆害。堕于地狱。欲示业报不可坏故。又复欲为堕地狱者。归依如来请佛救护。又为来世豪贵之人入佛法中。若有恃其势力。复以鞭杖加打于人。令此众生便作是念。如来之身。犹被毁害。况我凡夫薄福德者。汝言逆罪。但是菩萨善权方便。如是逆罪。名虽有五而实有二。破僧害佛。如是等业。世间所无。提婆达多是大宾伽罗菩萨。为遮众生起逆罪故。现作二业。堕于地狱。菩萨摩诃萨。随所应作。以化众生。乃至现同魔业。令魔波旬以三玉女。显现如来无欲之相又雨刀剑。一切鉾槊显现如来无嗔恚相。亦无贪爱及愚痴相。问曰。天魔来意。欲坏如来正觉之心。汝云何言欲显如来无贪嗔耶。答曰。不为遮断。何以故。若如来出过魔界。犹为魔遮者。大梵天王亦出魔界。云何不遮菩提。是道之妙果。无能夺者。亦无与者。故不可坏。言魔扰乱。凡有二义。何等为二。一者实有恶业。为魔所扰。二者为进新学。令心坚固。为魔逼试。实是菩萨。真善知识。现作魔来增益功德。譬如道路。以恐畏故。疾度崄难。犹如好牛。以少鞭杖。则得调利。问曰。天魔亦有是菩萨耶。答曰。非但此世界魔是菩萨。十方世界魔王者。多是菩萨。如维摩诘经中所说。十方世界作魔王者。多是住不可思议解脱菩萨。能乞手足头目髓脑。如是言者。皆是住不可思议解脱菩萨。何以故。若非菩萨者。未堪斯事。譬如香象蹴踏非驴所及。唯诸菩萨乃能行耳。如彼广说。以是义故当知。菩萨善知众生种种所行。为欲显其功德智慧方便力故。或现作杀杀者。作乞乞者。问曰。若罗睺罗实是菩萨者。云何复言声闻阿罗汉耶。答曰。菩萨亦名声闻。亦名阿罗汉。何以故。令一切众生。闻阿耨多罗三藐三菩提故名声闻。于一切天人阿修罗。应受供故。名为应供。菩萨摩诃萨。为化众生故。现作声闻阿罗汉。问曰。诸余声闻。亦是菩萨耶。答曰。诸余声闻。亦有是菩萨者。如法华经中。舍利弗等五百弟子。悉是菩萨。皆当作佛。一切声闻。皆是阿鞞跋致菩萨。如不退转法轮经中广说。以是故当知。菩萨皆现为声闻。问曰。一切声闻。皆成佛不。答曰。声闻成佛。此亦无过。问曰。云何无过。答曰。先断结障。后断智障。净治诸地。向一切智。是以无过。问曰。烧灭结使。如焦谷芽。云何得佛。答曰。若如汝言。断灭结使。不得成佛者。汝及一切众生。皆具诸烦恼。即应是佛。汝意若谓。具烦恼人。非是佛者。离烦恼者。应当得佛。汝言。烧烦恼结。如焦谷芽。而不成佛。亦无是处。我不欲令具烦恼种。生佛法芽。汝痴无智。颠倒解故。谓烦恼为佛法种。阿罗汉初断烦恼。后除智障。修菩提道。得成正觉。阿罗汉中。有少断智障者。有不断者。有得无诤三昧者。有不得无诤三昧者。有得五神通者。有不得五神通者。有得四辩者。有不得四辩者。有得禅出入自在者。有不得禅出入自在者。何以故。不断一切智障故。问曰。云何名为智障。答曰。出世间无明。名为智障。犹如娑罗留枝本行中说偈

  无明有二种　　世间出世间
  世间无明行　　贤圣已远离
  愚痴无妙解　　不能如实知
  依止此心识　　法界诸崄处
  未能及本原　　云何决定出
  法身证涅槃　　唯佛能了知

佛婆伽婆。乃能知其体性智慧。及大悲断结。是名声闻所断智障。声闻有二种。一者勤修禅定。是钝根人。二者回向菩提。能断智障。是利根人。乐行禅者。如宝良经说。犹如水精终不能成摩尼宝珠。声闻修禅。亦复如是。终不能成菩提果也。此是诸佛境界。非我所知。一乘多乘。今但略举其义。以明佛教。不相违背。我未能了。譬如长者远行疲极。现作化城。此经中说。但有一乘。实无有三。佛亦自说。唯有一乘。更无二三。问曰。如来以何行得断结使。而成佛耶。答曰。经中说言。佛告阿难。能修四如意足者。若住一劫。若住多劫。乃尽生死。一切诸经皆同是说。若汝言无烦恼者。我亦如是。若有亲爱信归于我。当为汝说。问曰。云何住寿。答曰。阿罗汉无烦恼。与八住菩萨同。善修如意足故。能随意住世。乃至尽于生死。罗睺罗。宾头卢等。尽住于世。为以此身住世。为更有余身住。若以实身而住世者。则无其义。若变化身住寿多劫。斯有是处。亦如僧祇中说青眼如来等。为化菩萨故。在光音天。与诸声闻众无量百千亿那由他劫住。如彼天中声闻住寿多劫。当知此界亦有声闻。能如是住。声闻无结。能如是住者。当知八地菩萨亦能如是。尽生死住。问曰。佛言。弥勒菩萨一生补处。以是因缘当知菩萨有生耶。云何得名无生乎。答曰。言有生者。是戏论法。菩萨摩诃萨。以方便力。示现受生。非是真实。如维摩诘语弥勒菩萨言无生可得。云何如来授仁者记一生当得阿耨多罗三藐三菩提。为过去生。未来生。现在生。若以过去生。过去生已灭。未来生。未来生未至。现在生。亦无住故。如观过去未来现在生。皆不可得。是故我说八住菩萨。于第二阿僧祇劫尽有作行。住无作行。如阿罗汉断结使。而说偈言

  从初发意来　　方便行诸地
  得到第八地　　自在尽诸结

    顺修诸行品第三

问曰。如向所说。八地菩萨善断烦恼一切结使。云何成佛。得一切智。答曰。菩萨摩诃萨。除身诸恶。寂灭结使。离于生死游戏自在。金刚力士常随护助。获得清净金刚之身。如如来藏经中广说。得四辩智。净治第九地。于二千梵中。得自在力。能善说法。为大法师。能入如来秘密之藏。净治第十地。得无量无边禁咒方术。能令一切自在无碍。作摩醯首罗天子。亦为一切世间依止。问曰。所言摩醯首罗者。为同世间摩醯更有异耶。答曰。是净居自在。非世间自在。汝言摩醯首罗者。名字虽同。而人非一。有净居摩醯首罗。有毗舍阇摩醯首罗。其净居者。如是菩萨邻于佛地犹如罗縠障。于一刹那顷。十方世界微尘数法悉能了知。能以口吹十方世界皆大震动。又以一身遍一切佛国。亦如皇太子初受职时。以己业力故。大宝莲华自然化出。受一切种智位。坐宝莲华王座。有无量菩萨。亦坐莲花上而自围绕。坐宝莲花已。十方世界诸佛放大光明照。此菩萨受灌顶位。如转轮圣王长子受王位时。受灌顶已。即于彼座。断除智境微细之障。得首楞严三昧。毗楞严三昧。法华三昧。得一切实法决定三昧。不可思议解脱三昧。甚深无畏海水三昧。微妙清净离垢三昧。诸法平等无言说三昧。乃至金刚三昧。得如是诸三昧已。悉无障碍。一切行满足。觉一切智境。成阿耨多罗三藐三菩提。成正觉已。得如来十力。得四辩智十八不共法。能遍至一切佛国。得一切诸佛不坏法身。遍满一切法界。一切身口意业相。皆悉除灭。得无为寂灭处。登如来地。有二因缘。一于一切世间显现色身。悉以本愿无作业力。二以众生分别想异。是故能作种种色像。皆悉应之。是名如来无碍法身。问曰。如经中说。从初出家。能住佛法。名为法身。答曰。此事不然。汝若以是名为法身。唯法无佛。则无三归。若欲令具三归依者。始从初地。乃至十地在净居天。成于正觉。自在应化名为法身。具足三宝。问曰。若以如是名法身者。虚诳无实。何以故。如来具足功德舍兜率天。降阎浮提生于王宫。于后边身。得成菩提。云何而言于净居天。得成佛道名为法身耶。答曰。非阎浮提成佛。十地功德非欲界法。况于阎浮提得成正觉。我先不言。八住菩萨。尽一切结漏。能作千世界梵王。九住菩萨。作二千世界梵王。十住菩萨。作三千大千世界梵王。以誓愿力故。生净居天。斯有是处。于阎浮提。实身成佛者。则非其义。以是义故。当知净居天成佛。非阎浮提乎。问曰。假使生于阎浮提。得成佛者。亦能于三千大千世界。而得自在。答曰。此事不然。何以故。福德果报。决定有处。汝不知故。而作是说。若释迦牟尼佛生阎浮提。于三千大千世界。得自在者。于一切十方世界。亦应自在。问曰。纵令十方皆使自在。复有何过。答曰。若尔者但是一佛世界。十方诸佛。则无依果。复次如诸经说。皆谓释迦如来王领三千大千世界。不言乃至十方世界。若如汝语则无因果。如经中说。诸佛出世。国土众生。皆是依报。各有齐限。是故当知。在净居天。成于正觉。领三千大千世界。非阎浮提。问曰。若佛非阎浮提成正觉者。如来四塔。则无利益。答曰我先不已说耶。若以结使因缘受身则无成道无尸波罗蜜。若无尸波罗蜜。则无诸波罗蜜。若无诸波罗蜜。则无佛。若无佛。则无四塔。问曰汝之所说。皆非义理。何以故。一切诸部论师皆说。一切诸佛皆从阎浮提出。而释迦如来生于林弥尼园。在伽耶城。坐于道场。成等正觉。于波罗奈。而转法轮。拘尸那城。入般涅槃。是故汝言非也。答曰。此事不然。何以故。我意不欲令诸如来。于此而出在首陀会天。而成正觉。若首陀会成正觉者。则无王宫生。亦无出家亦无成道。何以故。若尔如来便无亲族。亦无生处。亦无有灭。如法华经。智照经。如来出生经。皆广说。如来不生不灭。迦叶亦自说言。我依一切种智出家。当知此义。即是示现如来不生于金棺内。而出其脚。迦叶致礼。则明如来不灭。是故当知。如来法身不生不灭。问曰。如来都无少生灭耶。答曰。我今依理正说如来实无生灭非为虚妄。如来但以方便示现生灭。皆是不可思议。为化众生故。如佛于修赖经中说。我于娑婆世界。若以实身现者。则无一人而受我化。是故此处最为甚深。亦是秘密。亦名显现皆为下根众生智慧微浅。不能得知甚深之法。是故方便为现斯事。以偈颂曰

  大乘甚深广　　显现易可说
  钝智心狭劣　　闻则怀惊疑
  真是佛子者　　能知其甚深
  今乃真实说　　但为求佛者
  成就于二乘　　人天诸利根
  受福乘此乘　　是名大乘道
  大乘能出生　　声闻缘觉道
  若遮大乘者　　云何得诸果
  犹如诸字本　　离本则无字
  若离摩诃衍　　亦无一切乘
  钝根少智者　　不信于大乘
  以不能信故　　则无一切乘
  自利而兼他　　是名无上乘
  是故当亲近　　乃至成佛道

是义甚深。难可显现不应处处而为人说。问曰。虽不得一切处说。应为能解者说。若发大心增长智慧。应为是人具足分别如前所说。答曰。有四不思议。所谓佛不思议。禅定不思议。龙神不思议。业报不思议。佛不思议应显现法。唯有利根众生。从卢舍那佛以来。所说诸法悉能堪受。问曰。云何得从彼佛以为次第乃至今耶。答曰。如来法身为化众生有四方便。何等为四。一者多檀多罗波罗比地。二者多檀多罗尼比致。三者阿亶多波罗比致。四者阿亶多罗比致(此四深妙秦言无以译之故存梵本耳)。问曰。若如来法身常是寂灭无相无为。云何而得随顺有相。答曰。以本愿力故。如入灭尽定比丘。虽无心相。以先要心。若打揵捶。声发至耳。随其声发。即得出定。菩萨亦复如是。发菩提心。本誓愿力。若使我得寂灭法身尔时心识虽复无相以无作力故。教化众生。是故如来无相法身。便能普应。随顺有相。如三千大千世界百亿兜率天。百亿炎摩天。皆悉俱时示现色身。现色身已。或复舍寿。或现入胎。或现初生。或作释梵四天王等。接事左右。或现行七步或现师子吼。或复自言天上人间最尊最上。最后边身断生老病死或现童子。或现入宫。或现出家。或现苦行。或现坐道场。或现降魔。或现初成佛。或现觉悟众生或现久成佛。或现释梵请转法轮。或现成熟不成熟众生。或现度脱已成熟者。或现当入涅槃。或现已入涅槃。或现阎浮提全身舍利分身舍利。或现兜率下来。乃至现度脱成熟众生。随应所见皆为现形。或复数数示现。或复暂时示现。如是说者。名真实义。终不三阿僧祇劫修行诸波罗蜜而成。四十五十年果便灭尽耶。云何当说。因如须弥只罗山等。果如芥子微尘分许。是故汝说即是颠倒。如我法中。乃可令使因如芥子。果如须弥只罗大山。此合斯义。是故三阿僧祇因。得尽一切生死果报。应化众生法身常存。如法花寿量所明。亦如文殊师利授记品中说也。彼云何名为多但多罗尼比致。如佛所说。我作佛事已竟语诸比丘。我涅槃时到。如是十方诸佛。亦复如是。为化众生故。作如是语。其实不灭。一切佛国。神通变化。皆与虚空法界齐等。是故当知。法身是常。色身应化故无常。若以色身观佛者。不名见如来。如佛说偈

  若以色见佛　　音声求如来
  是人行邪道　　不名为见佛

以是义故。以法身观佛。名真见如来。如莲花比丘尼。见佛色身。便作是念。我最先见佛。佛言。汝不先见我。唯须菩提识于法身。已先见我。是故当知。位阶十住。名见法身。若礼法身。即礼一切色身。如佛于法华经中说。若人称名供养观世音法身者。胜供养六十二亿诸佛色身。何以故。以其位阶十地。得佛法身。亦名菩萨。亦名为佛。以是故知。法身为本。无量色身。皆依法身。而现化出。是故佛便假说六十二亿恒河沙色身。不如供养一法身乎。如佛于宝积经中所说

如是迦叶。如世间人。月初出时。恭敬礼拜。至其盛满。而不恭敬。何以故。从初以至满故。如是迦叶。若善男子。欲恭敬我者。先当敬礼菩萨。何以故。以佛从菩萨地得满足故。乃至经历生死变化色像利益众生。以是义故。彼已得佛果。是佛实说。非虚妄也。问曰。若未入菩萨地者。受具戒比丘得为礼不。答曰。得礼。以初发心菩萨胜于一切声闻辟支佛故。如尊者罗睺所说偈

  若发深心　　必生菩提　　故为一切
  之所恭敬

问曰。云何受具足戒比丘。而礼不具足戒未入正位菩萨耶。答曰。应礼菩萨。何以故。声闻戒要须受得尽寿便舍。菩萨发心成就自性第一义戒。解脱戒。是故声闻虽受具足戒。犹应礼彼未入正位菩萨。以菩萨体性不杀。远离刀杖。乃至虫蚁尽无杀心。而有惭愧。如是广说。体性不盗。乃至体性不邪见。如波罗提木叉戒。命终时舍。罢道时舍。菩萨大士性戒成就。乃至道场。终不中舍。以是义故。虽受具戒。应为作礼。问曰。成就体性戒者。乃可供养。不应礼拜。答曰。不然。以有戒功德故。亦应礼拜。岂但供养。汝言。不受戒菩萨。不应向礼。我今复当为汝广说。不但以白四羯磨故。而受具足戒。如比尼毗婆沙中说有十种受具足戒。菩萨有种种受戒。何等为十。如佛自言善来比丘。自然已得受具足戒。如摩诃迦叶。自誓因缘受具足戒。如憍陈如。见谛故受具足戒。如波阇波提比丘尼。以八法受具足戒。如达摩提那比丘尼。遣使受具足戒。如须陀尼耶沙弥。论义受具足戒。如耶舍比丘等。善来受具足戒。如拔陀罗波楞伽。三归受具足戒。如边地第五律师受具足戒。中国白四羯磨受具足戒。是以菩萨常受具足戒未曾舍离。问曰。若被法服菩萨得礼白衣菩萨不。答曰。菩萨方便具足五通。随顺众生一切形相。而同其服。亦随一切众生。入于诸趣。同其状类。大菩萨等。随众生业报。变化受身如尊者拘摩罗陀所说偈言

  诸趣悉变化　　唯除净居天
  随业种种转　　无处不受生

以是故知。诸菩萨常同利益。随其受生。而化导之。以方便力。但为众生。不随烦恼业报所系。如尊者提婆所说偈

  或现作师长　　或复为弟子
  以种种方便　　为化诸凡愚
  自在于诸趣　　常为众恭敬
  若不恭敬者　　是大憍慢业

是以菩萨虽形服在俗。应得礼敬。犹如如来。为化众生。作若干种形。亦如化弗迦沙王。作老比丘形。作瓦师形。作力士形。作琴瑟伎术师形。亦现种种在家人形。虽为种种无量形状。一切皆应恭敬礼拜。是故虽同俗服。应加礼敬。如佛所说偈

  严饰诸行而寂灭　　调伏决定修梵行
  于诸众生舍刀杖　　是名沙门婆罗门

是以于诸菩萨。不应取其形状相貌。而生分别。菩萨但为三界众生。作大舍宅。或化为佛。或化为天人。乃至化为种种畜生。一切皆应礼彼菩萨功德妙聚。不应作心礼其状貌如彼世人。致礼形像。远敬法身。岂在金石泥团土木而尊事乎。是故菩萨。以诸方便。作内外形。利益众生。礼无咎耶。是以如来非是涅槃。非不涅槃。如罗睺罗所说偈

  生死苦长远　　应当入涅槃
  以大慈悲力　　久住而不舍

是故当知。随生死久远。法身常住。色身应现。犹如灯灭是故菩萨法身。胜于诸佛色身。诸佛色身。于欲界而成正觉。菩萨法身。住于净居。菩萨法身。住于诸佛一切种智。诸佛色身。为化众生。令诸释梵。四天王等。皆悉恭敬。是以佛说。供养六十二亿恒河沙诸佛色身。不如供养菩萨一法身也。如集一切福德三昧经中所说。喜乐正法。终不说佛入于涅槃。如法华经中说偈

  常在灵鹫山　　及余诸住处
  凡愚无智者　　虽在而不见

如入一切世界大庄严三昧经中说。告善男子。汝见如来法身不。白言。世尊。唯然已见。于一毛孔。见亿百那由他诸佛世界。身口业等遍满一切诸佛世界。又如来密藏中说持速疾菩萨。观如来顶上。至无量诸佛世界。犹不能见。如目连寻如来说法音声。乃至野马世界。犹不能尽于佛音声。如首楞严经中所说。如来处于宫中。而现无量世界初生转法轮入涅槃。如密藏经中说。如来法身住于一切众生身中。光影外现。犹如净彩裹摩尼珠。无所障蔽亦复如是。是故当知。如来法身遍在一切诸众生中。如佛所说。乃至枯树焦木亦悉皆入不应生害。况复余类。是故不应称量众生。除诸如来。无能知者。如维摩诘所说。一切佛土。皆悉严净。此娑婆世界亦是。大心众生有如来藏故。释迦如来以善方便。令诸声闻大弟子等。现五浊世。诸外道等。虽计一异如是人等。一切身中。亦有法身。悉从菩萨善方便生。皆为显发摩诃衍道。是故当知。菩萨于三千大千世界。教化众生故。种种不同。若利根众生。为赞大乘。而无讥嫌。令心易解。若钝根众生。入邪见林。着愚痴网。得见诸佛菩萨因缘故。灭诸邪见。乃入大乘。是故摩诃衍。于诸乘中。最为根本。若有众生。受持信解此大乘者。当知是人业报烦恼皆悉消除如世尊为阿阇世王解诸疑悔经中所说光相。勿作是言。何以故。汝于余佛世界。十劫修诸禅定。不如于此娑婆世界。能一食顷修行慈心。何以故。于余世界。断除烦恼。亦复不如于此娑婆世界。一食顷中修习善业。如与文殊师利授记中说。及余诸经。皆具分别。若有众生诽谤正法。如般若经及法花中广说。其谤法过逆罪。若能受持信解大乘。乃至五无间等。皆悉消尽。如佛所说偈

  所作重恶业　　能深自悔责
  敬信大乘法　　拔除诸罪根

佛说如是。真实法相。信心次第相续连注。皆悉空寂。先所造恶。即能消灭。如世尊解除疑悔经中说也。大王观察汝心。以何心杀父。为过去心未来心现在心耶。若过去心。过去心已灭。若心已灭。则无方所。亦无住处。若未来心。未来心未至。若现在心。现在心不住。譬如幻化。非青黄赤白。紫颇梨色。体性纯净。乃至非相非可见。如是广说。即得胜趣。是故当知。摩诃衍者。是根本乘。如弥勒庄严经中说。发菩提心事。解菩提心。住菩提心。得大利益。不堕恶趣。解菩提心。净菩提心。从地至地。渐渐增益。而得法身。能现神通。如卢舍那佛所作变化。而说偈言

  若得无垢身　　色像则无量
  或出于阎浮　　或处于兜率
  从于定光佛　　乃尽生死际
  知时与非时　　当知定光化
  非是形色处　　亦复非无相
  悉由于本行　　亦如水中月
  身口意皆密　　悉是不共法
  一切诸世界　　色身现解脱
  持世诸天人　　欲观见佛顶
  无边不思议　　过于亿世界
  目连诸弟子　　至心求佛声
  亦过百千界　　寻声无边际
  法身功德业　　一切无能知
  不可以形类　　言辞巧宣说
  见闻唯佛力　　非我之境界
  念报佛恩者　　顶戴信奉行
  今我所说法　　回施诸众生
  悉灭烦恼结　　得证无上道

入大乘论卷下


三弥底部

    No. 1649

三弥底部论卷上

        失译人名今附秦录

归命一切智。我从此语。如是是人临欲死时。成无记心。其以何业往生。答曰。有业记心惑业往恶道。无惑记心白业往善道。体性记心以是故随行。以无记心起无记业。为业制故往生如是。是故行无隔。若眠若闷若无心死。行制故往业道。此二段语显相应。第三段语显不失。彼业自作自业

自作者何义。答受义故。自业者何义。答分义。何以故。不往他故。是生何以故。方便故。是行处。何以故。由彼故。是不灭。何以故。受故。此显现故。此世作业不灭故。由报业受生四处。此欲界死。欲界生有处。往中间有处受中间有。如是。若欲界处若色界处。第一处第三处。异生可说。如是从欲界中间有。受欲界中间有。从欲界中间有。受色界中间有。如是此欲界死受生中间有。如是。如是第三处。从色界中。间有受色界中间有如此。我等死受中间有如是。云何世尊声闻。从中间有受中间有。非凡夫。云何尔。须陀洹。从此七生七死受天中间有。住彼作斯陀含果证。是其从天中间有。受人中间有。住此作厌欲界证。是其从人中间有。受色界中间有。是其住彼中间般涅槃地作向一。从彼入别中间有。于此处而般涅槃。如是声闻过四中间有。有诸部说家已斯陀含。斯陀含人中间有处。至一间地处。度人中间有如是如是。从欲天受欲天。如是可知。有人舍五阴生有处。受五阴中间有处。如是一切。我从此语今当说。云何有我我舍。此有受彼有若为。问曰。何所疑。答曰。见先师意互相违故生疑。有诸部说实无我。唯阴处是我。何以故。苦起而已。故世尊语迦栴延。唯苦生生。唯苦灭灭。彼但见苦起而已。故知诸部见无有我。如是

复次何义说言无我。答无说故。世尊又语先尼梵志。如师所见法谛实说无我

世尊言。如是见者是名为师。是名为多他阿伽度阿罗诃三藐三佛陀。是我所说彼诸部。见无说故。是故无我如是

复次何义说无我。答自见其身故。世尊说言。无闻无知凡夫见色是我。我亦是色。色在我中。我在色中。如是四种四阴亦如是。若有我者不应自舍。其身见五阴是其体。譬如有人。自舍其身取提婆达多身见为其身见。其身是提婆达多。其身中有提婆达多。提婆达多中有其身。如舍其眼根。取提婆达多眼见。象牙见为其知见。而非其见。是故无我。如是

复次何义说言无我。答我我所不可得故

世尊告诸比丘。若有我者即有我所。若有我所即有我。我及我所谛实不可得。是故无我。彼诸部见我我所不可得故。是故无我如是

复次何以故说无我。答不实言有故。如富楼那语诸比丘长老。佛所说法甚为难测。于无物中有我

佛自言。我亦有如是长老我。但知此语不测深旨如是。不实言有故。知诸部见不实义故。是故无我。如是

又诸部说。不可言有我。不可言无我。何以故。答我相不可言故。答有我者可说。如行行相可说。如无为无为相可说。如是我我相可说

彼诸部见我相不可说故。是故有我无我不可说。如是

复次何以故有我无我不可说

答直置问记故。何以故。问记有四种。一者一问直记。二者先诘然后记。三者反问而记。四者直置不记。今者问我直置不记。是故不可言有我。不可言无我。如是

复次何以故有我无我不可说。答定异合故。若有我便应可说。为是行为异行。为是无为异无为。此二种说既不定。是故不可言有我。不可言无我。如是

复次何以故有我无我不可说

答常无常合故。若有我可说。为是常为无常。此二种说应必有定而不定。是故不可说言有我。不可说言无我。如是

复次何以故有我无我不可说

答有无中依止故

佛告迦栴延。世间依二种。亦依有亦依无。以是故执有执无。是故有我无我不可说。如是又诸部说实有我何以故。语缚故

佛言。是色痛想行识系缚。从此世渡彼

彼诸部见系说缚故。是故有我。如是

复次何以故有我。答正见故

佛言。有人见化生故。正见

彼诸部见。正见故。是故有我。如是

复次何以故有我。答佛说四念故

佛言。观见身受心法。若无我无可见四法。彼诸部见。佛说四念故。是故有我。如是

复次何以故有我。答佛说声闻故

佛言。有人事火自炙其身。劝人自炙。以是故佛说有人。如是。若无人自无炙。亦无他可炙

彼诸部见。佛说有人。是故见有我。如是

复次诸部何故说有我。答一人出世多人得安乐生故

佛语诸比丘。一切功德人生在世间。多人得安乐故。若无人谁生功德

是诸部见一人生故。是故有我。如是

又诸部说五阴是人是我

问曰。何以故。答说界门故

佛语比丘。六界门六触是人

彼诸部见。佛说六界门六触是人。是故是人。如是

复次何以故是人无异人。答佛说。外国有最上女人修多罗等故

佛言。我所说是最上女人。若白若黑若青若细滑。若方若长若短若细腰若肥。即是人更无异人。如是

又佛语比丘。有人见一比丘可憎。若短若瘘若跃。如是

复次佛说。我天眼见众生可爱可憎等。如是

复次说彼地狱人如烧积薪。烧地狱人亦复如是

前所说最上女人等及见比丘可憎。佛见众生可爱可憎。乃至烧地狱人如烧积薪等。但是五阴是人。更无异人。是诸部见。佛说阴是人。是故是人。如是

又诸部说人异五阴。何以故

答如担重担人故

佛言。重担是五阴。担者是人。如是

以是故人与阴各。是故人与阴异。如是

复次何以故人异阴

佛言人取。爱为。其第二久远轮转是故人与。爱异以是故人。与阴各如是

复次何以故人与阴各。答受业果故。佛说偈言

  生世乐欢喜　　异世乐欣然
  作福二处欢　　自见其业净
  此世业报竟　　来世复应受
  阴坏随业往　　更受异阴身

彼诸部见受业报故。是故人与阴各。如是

复次何以故人与阴各。答是我说故

佛言。我前世时作转轮圣王。名曰善见。亦名大天。以是故今受新阴前我不异。是故人与阴各。如是

复次何以故人与阴各。答无记处说故

佛言。阴无常不说人无常。有时说。阴是无常相。有时说。阴是常相。以是故常相异无常相异。是故人与阴各如是

又诸部说人是常。何以故。答无本故。人不应生死中行

如佛所说。生死无本众生轮转。生死源本不可知。如是。是故人无本

若人无本亦无其末。是故人常如是

复次何以故人常。答忆过去世故

佛言。忆一生乃至忆过去无数劫生。阴坏虽流转生死而人不坏

彼诸部见。忆一生乃至忆过去无数劫生故。是故人常。如是

复次何以故人常。答说处故

佛言。渡彼岸住彼地名婆罗门。如是。佛复言。既已渡彼岸更不复还。如是。佛复说。渡彼岸者住彼处不堕落。既至彼岸无复忧恼。如是

若人见渡彼岸者。住彼处不堕落。无忧恼故。是故人常

彼诸部见。佛说处故。是故人常

复次何以故人常。答至不动乐故

佛说偈言

  如是正解脱　　渡欲淤泥流
  智者莫能测　　得至无动乐

彼诸部见。佛说至无动乐故。是故人常。以是人至不动乐无阴故。是人不可知处。是故人常。如是

又诸部说人无常。问何以故

答有本故

佛语比丘。有一人生为一切人安乐如是

若有生有其本。若有本有其末。是故人无常。如是

复次何以故人无常。答佛说语新故

佛言。新生天好颜色端正威德。新者无常法名新。是故人无常。如是

复次何以故人无常。答倒法故

佛言。波斯匿王虽为人王。异世时倒如是。若有倒法成无常。是故人无常

复次何以故人无常。答落生故

涅槃常不落不生

依佛说言。我见众生落生。以是故依佛说落生。是故人无常

复次何以故人无常。答生老病死法故

佛言。我是无数四部众善知识。以生死故来至我所得脱生死。生老病死是无常法。是故人无常。如是

是故从此修多罗以为本。有说。无实我如是。有言。不可说有我如是

有说。有我如是

是故我等生疑。虽然为当实有我。为假设而已。以是故。有说五阴是我。有说我异五阴。有说常。有说无常。如是。是故我等生疑

问曰。云何人舍此有更受异有

答如修多罗意。教化力可知五盛阴。成人以为实人以五盛阴。成人以为实人故不可言。人常无常。如是

难曰。前章所说无我为首。各有所执。云何解释。令得开解。答如前所说。苦起而已。无我如是。我等今说

苦者苦生灭是苦性

佛欲显示苦性。语迦旃延言。苦生生苦灭灭我相生灭不可言。是故佛说如是

复次如前所说。无说故无我。如是。我等今说。我等相。从信受

如佛为外道说。虽有我是假名我不实说我依有漏阴

佛见去来法说是我非实我

如佛说依行行故受名。是故佛说

说名我如是

复次如前所说。自见其身故无我。如是。我等今说。答曰。无明所覆。五阴无我谓为我

如新生无知小儿。见余母人谓为其母五。阴无我谓为我亦复。如是是佛所说如是

复次如前所说。无我。我我所不可得故。如是。我等今说。答曰。佛说依不自在我我所实性不可得。如是

为他所制者不名自制。若自制者不名他制。是故断自他制不断我。如是

复次如前所说。不实言有故无我。如是

我等今说。答不实有故

不实与无法共合无。而言有此言难信。是故断无言有不断我。如是

如诸部前所说。相不可说故

不可说有我无我。如是。我等今说。曰我常无常相等不可说。有我等可说

如佛说。有人自炙身等一切

复次如佛说。无闻无知凡夫以恶业为相。聪明之人以善业为相。是故诸部语不可依。如是

如诸部前所说。有我无我直置问不记故。如是。我等今说。问不相应故。是故直置。相应故不直置

如佛记。无知凡夫人不善。聪明人善。是故诸部语不可依。如是

如诸部前所说。有我无我不可说定异故。如是。我等今说。若我验者应是行为异行。如是。正说为是行为异行应说。是故应遣诸部语不可依。如是

如诸部前所说。有我无我不可说常无常故。如是。我等今说

若我有无中可说成断见常见

若依此二见佛所不许

若言无人者成过不记之类。此言不可。何以故。若言无人者是名邪见

若言有人者是名正见。是故有人可说

如修多罗中说。若言无人名为邪见。若言有人名为我见。若言有者是其常无常故。若如此者行成常无常故。若同有有者。行无常无为常人不如是。同有不同常无常应可知。如是

如诸部前所说。有我无我不可说。有无中依止故。如是。我等今说

若都无我。佛不应说有依止。是佛说有依止故。是故有我可说。如是

如诸部前所说。有我语缚故。如是

我等今说

无人可缚而有缚。如王狱缚。虽无人而有缚有结。如有绳有结。无绳无结。如是。无我而有语缚。如是。如诸部前所说。有我正见故。如是。我等今说

依有漏阴。佛说有人以人见有人故。名为正见。如是

如诸部前所说。有我。佛说四念故。如是。我等今说

佛语迦旃延。唯心而已。欲显身受心法故。说唯心而已成诸法。更无异。如是

如诸部前所说。有我。佛说声闻故。如是。我等今说

声闻说处。依止法声闻说而已更无异。如诸部前所说。有我。有说故如是。我等今说

佛说有人假名。是故是其朋。无我。若实无我不成杀生杀者。亦无所杀亦无偷盗邪淫妄语饮酒亦如是

如是无我若无我者。五逆亦无纵任。诸根无起善恶者无缚。无解缚者亦无所缚。亦无作者亦无业。亦无报。若业无者果报亦无。业果报无者亦无生死。而众生以业果报轮转生死。若无生死者。生死因亦无。若无因者因灭亦无。若因灭无者趣道亦无。如是四谛亦无。若无四谛。亦无佛说四谛。若无佛者亦无有僧。如是无人者。三宝四谛亦无。如是诸说并所不应。以是故无人者成上诸过。后过亦生。若有人有我者。上所说无过。如佛说修多罗。真应当知。是故实有我。如诸部前所说。五阴是人是我界门故。如是。我等今说

若人命我异。是修多罗不显。有我为阴是我我是阴。若阴是我。阴可说我不可说。若我是阴。我可说阴不可说。亦可两可说非五阴。是我如是

如诸部前所说。人异五阴。如担重担人故。如是。我等今说

依担故说有担。若我异阴。坏时起时我亦起亦灭。如斫身一分。我亦应一分。如是一分成多分。一分多分还成一。随身存时命亦随存。命存时身亦存。是故阴即是我。是语可遣。如是。如诸部前所说。人异阴取爱为其二故。如是。我等今说

若人正见无疑。如人有爱系缚。轮转生死

佛欲显示。佛言人取爱。为其第二。长处生死爱断时。无复轮转。是故我不异阴。如是

如诸部前所说。人与阴各。受业果故。如是。我等今说

依有漏生死。此生来生受其果报。是故人与阴不各

复次如诸部前所说。人与阴各。是我说故。如是。我等今说。依度说

佛言。我过去无数阿僧祇劫时。曾为顶生王。是故人与阴不各。如是

复次如诸部前所说。人与阴各。不记处说故。如是。我等今说

阴我异不异不可说。是故法相以常无常为首不可说。我亦不可说

若我异阴者。佛言。我异身异佛所不记。修多罗所不明。若我异阴者。亦可在阴中。亦可遍一切处。若在阴中。斫身时。破身时。我应可见。如蚊在优昙婆罗果中。破优昙婆罗果时蚊可见。我在阴中亦复如是。若我异身冷热触身。我不应觉知。复次若挑眼时。倍应见物。如是。诸根坏时。声香味触等。亦应觉知。如是

复次若我异身。从此身入彼身还来入身。如人从此屋入彼屋还入此屋。我异者应如是

复次我异阴者。我不应处处受生。若处处受生。应一念遍处受生。是故不应常在身中故。解脱难得。若处处行不应作业。若无业果亦无功业。亦无缚解亦无行禅。便应解脱。如是等不应。是故人异身语可遣。如是

三弥底部论卷上三弥底部论卷中

        失译人名今附秦录

如诸部前所说。人是常。无本故。如是我等今说

若无本成常。生死无本亦应是常。此言不应。人无本不可说。如是

如诸部前所说。人是常。忆过去世故。如是我等今说

若我定异阴者。阴坏时人不灭。应忆过去世时事。只应此人不应有异人。而轮转生死无断绝时。此语不应如是

如诸部前所说。人是常说处故如是。我等今说

断苦流灭故。至有余涅槃故。身犹存住名之度彼岸住。婆罗门至无余涅槃。既至得无余涅槃故。是佛所说。是故不说人常。如是

如诸部前所说。人常到不动乐故。如是我等今说

得无余涅槃时。便至不动乐。若人常者。不生不死如涅槃。不生不死身亦不异。其智慧在所处处亦不异。食不食苦乐无异常故。过去时事不忘。常故无变异。亦无缚无解。是故人常此语应遣。如是

如诸部前所说。人无常。有本故。如是我等今说

有漏起故。是名说人。以是故。不可言阴与人异。是故人起不可说。以是假说即答解前次。佛说新等故

若人无常者。众生轮转所作善恶业坏。不作善恶业自来无先因故。一切众生悉应一种不造业应。解脱者不由业自成。既不由业自成功德。无所为先世时生亦无可忆。是故人无常此语应遣

以是假说即答解前次。倒法故落生故。生老病死法。人无常故。如是

问曰。云何说有人

答曰。佛说有三种人

问曰。云何三种人

答依说人度说人灭说人(说者亦名安亦名制亦名假名)

问曰。云何依说

答如佛所说。语跋婆耶言。是是行所依说。是是其名安

是名依说如火譬。如佛语舍利弗。有人名象白净可爱。四大所成是名我。如是一切亦如乳譬。如是依修多罗等所说。是名依说

如色得色人得色人不可说。异色色不可说。异得色人依色得名依色人。若人说是色是我。是其色成名我见。若人说色是我者以是过五阴人。前所说成是其过。复言。若人说得色人异色者。名异我见。若人说异我以是过人异五阴。成是其过

得色人相从而已。非是真说。若人说色得色人相从而已。成其邪见。若邪见者。言无我。以是过前所说。成是其过。以是故。此是三过

是故实异邪见。不随实异不随邪见。依色得色人可说。以是故。得色人共色实可说。是故是时色起是时得色人亦起是时色灭。是时得色人亦灭。不是不可说。如是五阴十二门。五道阿修罗道中阴为七道人。生有处迦罗罗阿浮陀那肉团支。新生童子年少中年老善恶记心。戒犯戒如是上一切合不合。依上诸法。是名依说人可知

问曰。云何度说人

答曰。以是时度异有是时。佛说度众生。云何度说众生。过去说未来说现在说。云何过去说

如天使修多罗所说上启阎罗。此人先不知父母兄弟等。不知功德。不知善恶等。愿教其。如是

如佛所说。我过去世时。曾作顶生王。是名过去说

云何未来说

如佛所说。转轮圣王在中有时。初入母腹。如入堂殿。如是。如佛语弥勒。阿逸多。汝后成佛时。名曰慈氏。是名未来说。如是

云何现在说

答曰。如佛说安伽人。有耳珰种种宝饰臂手。如是

如佛所说。大富长者多有财宝大如意。如是。是名现在说。佛依三世行制三说。如是应知

以是行度说是名度说

云何灭说。答逐依说人度说人

佛说灭说人。如过去身坏时。是名灭说。如是

如佛所说。漏尽比丘五阴无常灭。是名灭说。如佛说偈言

  智者莫能测　　得至无动乐

是名灭说。如是。见依说

度说。是故说有人。舍五阴生有处受五阴中间有。如是

见灭说。佛说无复有受阴处。如是

问曰。为舍五阴灭尽犹有所余

答曰。何所疑。曰。见先师意互相违故生疑。有诸部见五阴一边。从此有往彼有。如是何以故。识上生故

佛言。是人识戒熏定熏是其识上生胜处。佛复说偈言

  善恶二种业　　是业人世造
  是业是其物　　自捉自随去
  粗阴是恶业　　细阴是善行
  善恶二俱造　　随捉逐业往

是人往生其受根义。是以故。其度。天眼人见其度

如佛语比丘。我见众生落生如是一切是故。诸部见五阴一边。从此有往彼有。如是

又诸部说人。如是。从此有往彼有。非是阴。何以故。佛说偈故

佛说偈言

  生世乐欢喜　　异世乐欣然
  作福二处欢　　自见其净业
  护根往善道　　不护堕恶道

佛复说言。此死落生如是。是故。如诸部见人如是。从此有往彼有非阴。如是

又诸部说无人。从此有度彼有。何以故。如佛言新天人。人见如是

佛复说言。是是行行所依。是是受其名。如火依薪受其名。如是

佛复说一切德人。生世间多人受安乐。如是前世已生不复更生。是故无人。舍此度彼有。是故生疑

曰。前所问为舍五阴灭尽。犹有所余。今若舍五阴。五阴无遗余。从此有度彼有。如佛说偈言

  弃舍此人形　　受天身具足

如佛说人无。财宝一切舍。随所往。如是。如佛说临死时。舍其身独自去。在世之时言。皆是我有。临死之时。一切舍。独自去。戒定熏心藉此善业上生。是故佛说善心而已。上生胜处。是故舍五阴灭尽往彼胜处。依业不灭。佛说偈言

  是业是其物　　自捉自随去

中阴根故。往生彼处。受根义行中阴处天眼见中阴色

如诸部说五阴一边。从此有往彼有。是故舍此语。如是

前所说。如是人从此有往彼有。唯人而已。若尔者。应至道实异无往。若实异若常若不常。成邪见。如前所说实。异常不常。成邪见遮。以是故。人共阴实异不可说。是故是人而已往生处不可说。如是

问曰。云何人身灭时。五中有起

答曰。人欲灭时中有起时。依五中有。是名五中有人可说。逐过去说依度说人可说。以是故不依人。是故不依义。不是人可说。如是见法念灭。念灭不灭行念念是名佛说。应当知。以是故。舍五阴身都尽人从此有度彼有。是故说有人舍五阴生有处。受五阴中间有如是

问曰。为前受五中阴处。后舍人五阴。答曰。不如。若如所问。生成有间。若生成有间者。圣人灭应更受有。不成灭四取。若阴与人别是所不应。如是

问曰。为先舍人五阴。受五中阴身。答曰。不如。若如所问。一人一念中。便应成两种有是所不应。如是

问曰。今者云何舍人身。受五中阴身。为一时而受。为不一时

答曰。是一时。问曰。云何

答曰。人临死时。最后一念心现起时。中阴心未起。最后一念心灭时。中阴心方起。中阴心起时成五中有人。是故说舍人阴受中有。何以故中阴心起时成。从人中落中间有处成时。心住是处时是名落生。是故相应时应当知。有人舍五阴生有处。受五阴中间有。如是一切。曰当说。我今

问曰。阴有源本不。而从阴次第生至今。为有本为无本。如是。曰何所疑

答曰。佛语比丘。生死无本。众生轮转生死源本不可知。如是。为无实故不可知。为有实故不可知。如十二门说。有十三门实无故不可知。为无智不可知。何以故无色界人。余二界人无智故。不知。如世界成不成。直置不可答。有展转源本是初有可说。是故我等生疑

问曰。人前生源本不可知。为实有。为实无。若有知见可说

答曰。实有不可知。何以故。譬如实有物覆故不可知。亦如一毫微尘细故不可知。又如地旷故不可知。亦如眼皮极近眼故不可知。又如海岸极远故不可知。复如眼根弱故不可知。如发毫端。亦如芥子聚。以一芥子投聚中。色相似故不可知。又如恒河流水。以一把盐投河中淡。水力多故盐不可得。亦如宝物在壁内隔障故不可见。亦如鬼神隐形故不可见。如无知人不知命所余故不可知。如宝物在壁障隔等实有不可知。如是人源本实有不可知。如是

难曰。从此源本。若尘及毫端等。实有不可知者。余人见。如天眼见毫端

又如地旷边际。唯天眼者见。复如眼皮自不见近其者见。如海岸不可知渡。到者见。如发毫端明眼者见。以一芥子投芥聚中。明眼者见。恒河水以一把盐投之。唯鱼近其边知。覆障财宝。天眼者见。隐形鬼神。唯同类见。有方术人见余命不可知。他心智人见如是。上所说一切有言不可见不可知。然一切可知可见。源本无人知是故。如覆障宝物等实有。不可知非因。复说实有不可知。何以故。无能测量故。如雪山实有不可称量。何以故。无能测量故

难曰。若为知雪山称量实有不可知。答曰。见雪山石有量数挍略。雪山称量实有可知。是故无能测量不可知。难曰。若挍略可知此非知。但挍略知非称量实知。便成无明

又问曰。不实故。称量不可知

答曰。不实不可知。何以故。如修多罗中所说故。佛言。物不实处无知声

如佛语比丘。如酥油灯灭其灰其墨不可知。如是须弥大海大地劫尽火劫起时。一切烧荡尽其尘。其墨不可知。如是

佛言。源本不可知。亦复如是。如酥油灯灭其墨尘不实有不可知。如是源本不可知。亦复如是

问曰。如实物。有处佛说不可知声

答如律中所说。若人酒着手若器。此人以手捧器奉上比丘。盛食比丘不知得食无罪如是。是故此非因

又说不实不可知。若源本实有者。佛实智应从彼起。不应说言不可知。以佛说不可知故。是源本不实有

答曰。此义处不尔。佛实智不从彼起。如世间问常无常等处。佛不答。是故无因。复说不尔故源本不可知。佛说不可知。若佛直说无源本。成断见。若佛说有源本。复成常见。此二种。语不应。是不应故。佛说不可知。如是

问曰。若生死有本者。成常见。若无本者。成断见。圣人生死本已尽别本更起。应知而不尔。别本更起者。便成断见。生死源本不实有不可知。何以故。生死轮转无穷故。佛语诸比丘。有依爱本不可知。从此起爱谢在过去。从此起爱未来当起。如是一切。以是故。无有爱本。是故生死无实。本不可知

复次生死常起故。若无生死亦无涅槃。如佛语阿难。有漏五阴灭尽时。是名灭。是名涅槃

佛又语阿难。涅槃虽灭尽不无本。以是故生死灭有本。是故生死本不实有本不可知。如是

复次因展转合故。一切人不以我为因本。若以我为因本。生死不尽。是故无本。如是

复次忆知过去无数世界。如佛所说过去时若欲知法识随起知。以是故。识无数故。境界亦无数。应知亦无数。是故生死无本。如是

复次生死无本故。若生死有本者。过去生本亦应有。是故不实有过去。生本不可知。如是

复次有爱展转故。佛说过去生本不可知。若生死本无者亦无其名。若无法不应有名如是

答曰。无法无名。无名名不实。虽无名以无名便是其名。是故有名故是其不实。如所说。过去源本名实故。源本应实。此语不是。曰不尔。如所说。无法有名故。有实者。有法有名。亦应无名不实。何以故。无名故。若尔无法不实。其名亦不实。实有法其名亦实有。是故无法之名亦不实。以是故。源生不实有验矣

难曰。若尔实不实便是不定。不实成实实成不实。是所不应

复次有法遮言。无有法无法始显胜降实不实可见以是处无遮言。有是名实。如打物发此声。此声无本故如是。源生可说如兔角。是故生死是源本。难曰。若生死无本者。亦无其末。如是无本无末与涅槃无异。是所不应。如是。答曰。是实无本。五阴展转相生故

是故无常。因展转果亦展转

问曰。若生死无本者。中末亦无。中末无者生死亦无。如林无本无末。亦无中。便无此林。如是无生死。如是

答曰。不尔。何以故。如团圆物。无本中末不。无圆物生死亦尔

难曰。若团圆物无本中末。而有者无。第二未可坏。生死亦尔

答曰。恐如是生死不灭。如所执本无故。一切法无。此是下执以前生因展转故。是故无本。因坏故生死尽。生死坏因亦尽。如是前忆过去无数世界故。是故佛说无源本。若生死源本。阴展转无本故。成常见。依阴依度佛说有众生。如是

说曰。阴展转无本者。众生展转亦无本。众生不应展转。何以故。佛已说生死无本故

问曰。若生死无本。佛何故说不可知。何不直言无

答曰。若佛直说无者。不应起三种邪见。三种邪见者。第一我前身曾生不。第二我后更生不。第三我今若为生不。应生疑。以是故佛说不可知。是故佛说应当知。如是。佛说法有二种。何者二种。一为法。二为众生

云何为法。如佛所说。源生不可知。有爱本不可知。为法故。说无生死源本可说。云何为众生无明覆众生。轮转生死。为众生故说法。众生轮转生死。是故佛为说。说曰。如是时法至其心依度。是时佛说是众生

问曰。何故佛说有法源生不可知

答曰。佛不应为众生说无源本

难曰。如是时法依度。是时佛说是众生。尔时法无常可说。不应说众生常无常。如是源生可说不可说。可知生死无本验矣

三弥底部论卷中三弥底部论卷下

        失译人名今附秦录

如是所说。有人生阴处。舍五阴受中阴五阴。问曰。云何知有中阴

曰。何所疑。答曰。有诸部说无中阴。何以故。道处不说故

佛语舍利弗。地狱我知人往地狱。我亦知可往地狱道。我亦知乃至众生往到涅槃。我亦知佛不说。我知中间有不说。我知众生往中间有。不说道可往中间有。如是

彼诸部见。佛此修多罗中不说。是故见无中阴

复次生处。佛不记故。生五处佛悉记。如佛记调达应入地狱。记都提婆罗门生畜生处。记姑罗柯生饿鬼处。记给孤独氏生天。记儴佉王生人处。如是等记。不记一人生中间有

彼诸部见。佛不记五生处。是故诸部见无中间有

复次佛说业故。此业应受地狱。此业应受畜生饿鬼人天五道。如是等五道生处。佛说业中间有。佛不说业。是故彼诸部见。无中间有。如是

复次佛说此定。是实有五道故。此是地狱畜生饿鬼人天等。不说此定是中间有。彼诸部见。佛不说定中间有。是故诸部见。无中间有。如是

复次生无间故

佛言。人造五逆罪。身坏直入无间地狱。若有中间有者。佛不应说直入无间地狱

彼诸部见。佛说直入无间地狱故。是故诸部见。无中间有。如是

复次无定故

若死生有处。是其中间名为中间有者。中间有于生有处。其间复应有中间有。是故诸部见无中间有。如是。复次无用故。言有中阴者。此言无用。何以故。中间有处无长短寿。病不病亦无。受苦不受苦业亦无。爱不爱色声香味触亦无。服饰庄严亦无。是故若言有中间有者。此言无用

复次同法生不同法生故。若中间有共生一法者。是其生有。非是中间有。若不同法生成别道名。如八正道。如是同法不同法成过。是故无中间有。如是

复次不说相故。佛说有五道相。中间有相。佛不说

彼诸部见不说相故。是故无中间有。如是

复次自身生故。佛说有众生。从其身落无间。一念中受生

佛说一念受生。不说中间有处可生

彼诸部见。一念从其身落受生。是故无中间有。如是。从因等故

诸部见无中间有如是此说受五阴中间有处。是诸部执灭中间有

问曰。若为遣所执。若为因成有中间有。曰听今所说。如诸部所执灭中间。有欲令是因还有中间有

难曰。如诸部所说。五道处不说故无中间有。答曰。不说五道处乘故。是故佛不说中间有。非是无中间有故。如从此城往彼城。不说乘应至彼处不可。以不说乘。应至彼处言无乘。中间有亦如是

复次如诸部所说。生处。佛不说故。无中间有

不住处故。佛不记中间有。是处众生命根苦乐法非法交关胜处。是佛所记。是故佛不记中间有

复次如诸部所说。佛说业故无中间有。是人积聚造业应受六道生。色界无色界。是其所向道。以此业成中间有。乘至受生。是故佛不说中间有业。佛不说中间有业故。是故无中间有。不应尔

复次如诸部所说。佛说此定是实有五道故。无中间有应说不说故。如佛语叶波国人。应多有所告而我不说。不可以佛不定说故。言无法可说。是故佛不定说中间有故。是故不可说无中间有。可知

复次如诸部所说。生无间故无中间有。断异道故。佛说无间。是故不可说无中间有

复次如诸部所说。无定故无中间有。如佛所说有中间禅非是不定。如第一第二禅是其中处。佛说有中间禅。中间禅中佛不说更有中间禅。如是应知。中间有非不定

复次如诸部所说。无用故无中间有。应到彼故。有用用中间有故往彼受生。是故中间有非无用

复次如诸部所说。同法生不同法生故。无中间有

二处生故生中间有处往受生处此二处同法不同法。云何同法。同界故。云何不同法。乘与生处异故。是故不可言无中间有

复次如诸部所说。不说相故。无中间有。多论处不应说此语。若佛说有中间有生多论处。不应间有中间有无中间有。是故不可说无中间有

复次如诸部所说。自身生故。无中间有。未生彼故。是其身应生彼。而未至生中间有。成生从种类中落受空处中间有。自见其身细微细滑。如在地无异彼。随爱制故。依愿乐其身。是故以此语不断中间有

有中间有。何以故。断间故

如佛语摩楼柯子。是时汝见闻觉知而已。汝尔时不在彼世界不在此世界。不在中间处。是名苦尽。我等见佛遣中间处。是故有中间有

复次有中间有。如佛说跋蹉耶那修多罗。尔时佛语跋蹉耶那。舍此身未生彼处。是时意生身爱取合故。我说名为众生。我等见佛说跋蹉耶那修多罗。是故有中间有

复次有中间有。中间入涅槃故

佛语诸比丘。五种人名龙驹马。何等五种人。中间入涅槃是名第一人。生入涅槃是名第二人。行入涅槃是名第三人。不行入涅槃是名第四人。上行入涅槃是名第五人

我等见佛说中间入涅槃故。是故有中间有

复次身不至故。识无身不至彼

我等见身不至彼。是故有中间有

复次天眼力故。佛言。我天眼见众生落生。如是一切。若无中间有者。佛不说我天眼见众生落生。我等见佛说。天眼见众生落生。是故有中间有

复次如佛说揵闼婆处。故。佛言。三处合时。然后度入胎。何等三处合

父母和合揵闼婆来至前立。三事合时。然后度入胎。是名三处合。若无中间有。佛不说揵闼婆处

我等见佛说揵闼婆处。是故有中间有。复次得相关故。柯罗罗作本。乃至老无中间色得相关。我等见得相关故。应有道度处从死有受中间有。应有相关可成

复次稻苗譬故。从稻生苗从苗生稻。是色定法何等为稻。前生有为稻。何等为苗。中间有为苗

又生有为稻

我等见稻苗譬故。是故有中间有

复次光明世间故。如阿难所说。我闻世尊为菩萨时。从兜率天上。忆念智明下降母胎。是时一切世界光明普照。菩萨是时在中间有处光曜遍照。然后入胎。我等见光明世间故。是故有中间有

复次人欲受生转变故。是人是其可往道近其边。其人欲受生心转变。不转变不受生。如人从般稠摩偷罗国落。还从中生。何以故。不见异生道故。无转变。若无中间有不成转变。不应见其所往道。是其所依处是处见其所往道。如天眼见游空如神通。我等见人欲受生转变故。是故有中间有

说曰。如前所说。断间故有中间有

断三缚故是。是时三处中是处断三缚无此。无此有何义。曰不着内门无彼。无彼有何义。曰不着外门。不着中间。不着中间有何义

曰不着六识。是佛所说不明中间有

复次如前所说。跋蹉耶那修多罗故

说三界故。佛已说三界。舍此身有何义

曰舍欲界。未生彼有何义。曰未生色界。是时有何义。曰生色界。意生身。爱取合有何义。曰着禅味爱相合。是佛所说。不明中间有

复次如前所说。中间入涅槃故

行过去。若说中间入涅槃者。成生中间有。恐如是行入涅槃者。成生共勇猛。是语不应不明中间有

复次如前所说。身不至故。曰影现摸像如人映井面像影现。如死受生处。如是不明中间有

复次如前所说。天眼力故。曰细道故。有道细微余人不能见。天眼力乐见是故说天眼力。不明中间有

复次如前所说。如揵闼婆处故。曰向道故。是人先造善恶道临死时。随善恶业道向其人。曰。是故佛说揵闼婆处。不明中间有

复次如前所说。得相关故。曰何故如汝言。从此死有生中间有。相关如我从死有受生。有相关不明中间有

复次如前所说。稻苗譬故。曰道不胜故。何以故。稻苗为譬。道成不胜。何以故。稻性生苗。既生苗已。复能生稻。从人落起中间有。不能生人而已。是故此譬殊险。不明中间有

复次如前所说。光明世间故。曰间过故。此语阿难已说言。我闻世尊。为菩萨得阿耨多罗三藐三菩提时。光明照曜一切世间。恐如是。如此曜照。在菩萨成佛中间光明。非成佛时。光明此语不应。不明中间有

复次如前所说。人欲受生转变故。曰梦见故。如人梦在般稠摩偷罗国。倚见摩偷罗。北界所领国。如是无中间有

人欲受生转变亦如是。不明中间有

难曰。若无中间有者。佛不应说。告诸比丘。如二屋多有门户。唯一大本门有一人立。守此门见人出入。如是我以天眼见众生落生

若无中间有。与修多罗所说相违。若以天眼见众生往还。应无众生可见

复次若无中间有者。不应从人落生余道。何以故。此生灭时。是其生异处如是

若无中间有。天眼不应知。此人造善恶业生善恶道。不应知。佛前已说。我以天眼见众生落生。如是一切

是。故我见从人落有处可依受生。是故我见定有中间有。中间有既定。我今更有所说

问曰。如上所说有人舍五阴生有处。受五阴中间有处彼人若为

答曰。人初凡夫未厌欲界五阴具足五界受柯罗罗处。彼柯罗罗处无空界。彼处有二门。身门意门。化生处在六界六门。彼化生处不聋不盲如是应可知。有九善根不善根。于三界七见谛烦恼七思惟烦恼。如是十四九十八使烦恼。在三界五种如是。第二凡夫离欲界生无想天。处受二阴五界五门。彼处无合阴。依意界门下彼处有如厌离。欲界应知

第三凡夫。厌离色界。从色界下生欲界

问曰。如从无色界落。昔所造业与禅定合色界处生有想天处。何以故。不如是。前所造业。共无想三摩提合。从无色界落生无想天处。如是

答曰。以是故无处可说从无色界落生无想天处。是故应思惟。在此欲界毁想。生色界无想天。如是别有处毁欲毁觉毁喜毁乐。从无色界落生色界有想天处。如是别有处毁想。从无色界落生色界无想天处

如所说言。余人生胜处可说应当知。如是从无色界落生色界无想天。无处说应可知。难曰。有想三摩提处业相异。无想三摩提处业相异。是故觅说处可知。第四阿罗汉。问曰如是人欲受生转变故。复无道故。无人不受生。何以故。作此说断九十八使。无人受使生处。如是

答曰。三有。生有业有死有是名三有。此中生有所说

第五。二人一人七死七生。须陀洹一人斯陀含

第六一人中间入般涅槃

第七二人一人生已入般涅槃一人行入般涅槃

如是第八不行入般涅槃

无色界。此示面而已。不具足说。如是人处所说。一切凡夫不执

十三种人可作。云何十三人

第一凡夫未厌欲界。第二凡夫厌欲界。第三凡夫厌色界。第四七死七生。第五斯陀含。第六家家斯陀含。第七一间斯陀含。第八厌欲界阿那含上生。第九三人生已入涅槃行入涅槃不行入涅槃。第十中间入涅槃。第十一厌色界上生。第十二生行入涅槃。第十三阿罗汉。如是。彼第一凡夫二种生善处恶处。第二凡夫二种生欲界色界

第三凡夫。三种生欲界色界无色界

世尊声闻未厌欲界有二种。生人天二处。厌欲界有二种。生欲界色界

厌色界三种。生欲界色界无色界。如是阿罗汉三种。生欲界色界无色界。彼凡夫未厌欲界五阴处。一切具有五阴界处八种。曰云何尔。答欲界一切中间有处。五阴六界六门。是故作中有验竟。生有。我等今说。有人舍六界生有处。受六界生有处。复舍六界受六界生有处如是

第二舍五界生有处。六六界生有处如是

第三舍六界生有处受五六界如是

第四舍六受六五如是

第五舍五受五六如是

第六舍五受六五如是

第七舍六受五五如是

第八舍五受五五如是

彼第一云何。从具足根体有落

从化生有度化生有

第二从柯罗罗阿浮陀伽那肉团落。从化生有度化生有

第三从具足根体有落。从柯罗罗等度化生有

第四从具足根体有落。从化生有度柯罗罗。第五从柯罗罗等落。从柯罗罗等度化生有

第六从柯罗罗等落。从化生有度柯罗罗。第七从具足根体有落。从柯罗罗等度柯罗罗

第八从柯罗罗等落。从柯罗罗等柯罗罗。如是门处八种

善根处。第一一切处九

第二无人舍善根生有处。受九九生有处如是。复从地狱从断善根有落。从共善根有落。从共善根有度共善根有

如是应作第五五种。无第七第八

有诸师说。唯断善根人。从地狱复生地狱。是故八种可作如是不善根处。使处一种

厌欲界五阴处。第一一切五

第二舍二阴生有处。受五生有处

如此复有人从无想天。有落从有想天有度有想天。有如是五种应作

有诸师说。如如是逐先所作业。积聚与禅定。合复复无间生。有想天处

如是逐先所作业。积聚无想定。合复复无间生无想天处。是故八种可作如是

如是界门处共二门四种。云何四种。舍六入生有处受。六二如是

第二种舍六受五二

第三舍五受六二。第四舍五受五二。从前说应可知。以是故凡夫胎处不至厌。是故四种可作。如是。共善根共不善根共。使。第五可作五种。无第七第八

厌色界阴处五种。如是。共六界五种云何二种共五若为。答有人舍一界生有处。受一五生有处。舍六受一五如是。共入七种。共二入二种

如是。善根处不善根处。使处十一种。七死七生五阴处。一切五。界处门处。五种善根等处。一种

如是。斯陀含不善根处。一切七

使处。一切十长家家

阴处。一种。界门处。八种。善根等处。如斯陀含。一间。阴处。一种。界门处。四种。善根处。一种。不善根处。使处斯陀含二种。厌欲界阴处。一种。界门处。二种。上生善根等处。一种。行成等二种如是。厌色界

阿罗汉五阴处。二种。界门处。三种善根处。三种。不善根处。使处四种。如是中间有处。应当知

如是。初有处。第二有处。未离欲

第三处。离欲。初有处。离欲

第二第三处。离欲。如是。应当知

如是共十八界。十二门有漏阴如是。应当知如是阴展转共因缘起。是故若欲除阴灭阴。因当勤正精进如法修行

依说论竟

三弥底部论卷下


三身梵赞

    No. 1677

三身梵赞

        西天译经三藏朝散大夫试光禄卿明教大师臣法贤奉　诏译

踰(引)乃酤(引)那(引)鳖泥(引)哥(一句)莎波罗呬多摩贺(引)三钵那(引)陀(引)啰部(引)都(引二)乃嚩(引)婆(引)巫(引)那婆(引)嚩(三)朅弥嚩三摩啰苏(引)讷哩尾(二合)婆(引)嚩莎婆(引)嚩(四)儞哩梨(二合引)邦儞哩尾(二合)哥(引)囕始嚩末三摩三莽(五)咩必曩[寧*吉](切身)钵啰(二合)半左(六)满祢(引)钵啰(二合)爹(引)咄摩(二合)味(引)捺焬(二合)怛摩喝摩耨波莽(七)达哩摩(二合)哥(引)野[口*爾]那(引)喃(引八)路(引)哥(引)帝(引)多(引)末进爹(引九)速讫哩(二合)多三摩发朗摩(引)咄摩(二合)努(引)踰(引)尾部(引)鼎(十)波哩杀(二合)努末(二合)提(引)尾唧怛囕(二合引十一)萨多(二合)钵野底摩贺底提(引)末当(引)必丽(二合引)底系(引)都(引十二)没驮(引)喃(引)萨哩嚩(二合)路(引)哥(十三)钵啰(二合)室哩(二合)多末尾啰都(引)那(引)啰萨达哩摩(二合)具(引)爽(十四)满祢(引)三菩誐哥(引)焬(十五)怛摩喝祢喝摩贺(引)达哩摩(二合)啰(引)[口*爾]焬(二合)钵啰(二合)底瑟吒(二合十六)萨埵(引)喃(引)播(引)哥系(引)都(引)聒唧那曩罗以嚩(引十七)婆(引)底踰(引)祢(引)鳖摩(引)那(十八)三冒桃达哩摩(二合)作讫丽(二合)聒唧捺必左补那(十九)啰捺哩(三合)设帝(引)[扰-尢+曳]钵啰(二合)扇(引)当(二十)乃哥(引)哥(引)啰钵啰(二合)没哩(二合)当帝哩(二合)婆嚩跋野喝囕(二十一)尾说噜闭噜播(引)[扰-尢+曳](引二十二)满祢(引)儞哩嚩(二合引)拏哥(引)野(二十三)捺舍祢誐耨誐当当摩贺(引)哩汤(二合)牟泥(引)那(引二十四)萨埵(引)哩台(二合)哥讫哩(二合)播(引)拏(二十五)末波哩弥多摩贺(引)倪也(二合引)那奔女(引)捺夜(引)曩(引二十六)哥(引)夜(引)曩(引)苏誐多(引)曩(引二十七)钵啰(二合)底尾誐多末努嚩(引)酤钵(二合)他(引)曩(引)怛啰(二合)夜(引)赧(引二十八)讫哩(二合)埵(引)薄讫爹(二合引)钵啰(二合)拏(引)莽(二十九)酤舍罗母波唧当[扰-尢+曳]拏摩夜(引)冒提味(引)惹(三十)帝哩(二合)哥(引)夜(引)悉帝(二合引)那腊没陀(二合引)若誐祢那末企朗(三十一)冒提摩(引)哩诣(二合)[寧*吉]喻惹(三十二)帝哩(二合)哥(引)野萨怛(二合)嚩三摩(引)钵多(二合三十三)

三身梵赞


胜军化世百喻伽他经

    No. 1692

胜军化世百喻伽他经

        西天中印度惹烂驮罗国密林寺三藏明教大师赐紫沙门臣天息灾奉　诏译

  过去仙人[尾*耶](切身)娑等　　典籍章句无不说
  我今自咏悦愚怀　　略诵伽他为百喻
  行恩行义行贤德　　无我无慢无怯弱
  真实慈悲可重师　　堪作上人出离行
  虽然贫下存刚志　　设身富贵亦柔和
  若遇强敌而勇力　　此即名为大人相
  少年行善人希有　　人来求者欢喜与
  若人称赞我羞闻　　彼等之人亦难得
  欲求美称先求法　　法上精心德自生
  一切戒行坚持密　　彼人世间甚希有
  天然性善言亦善　　善人恶人各尽知
  他或有过与藏盖　　此等智人世难得
  火性暖兮本自热　　月性清凉亦复然
  刹帝利族名称上　　彼等下族何得怪
  亲眷难危须救济　　他人有难亦复然
  竭力为人情不二　　此中活命名正命
  布施忍辱及明力　　调伏诸根语言善
  此为圣者真庄严　　金宝庄严如担重
  世间未曾有一物　　不被无常破坏空
  唯有无为寂静德　　经劫凝然得常住
  善哉形色身端正　　而具崇修德行光
  譬如明月在当空　　清净光明照楼阁
  富贵行檀一切人　　识心成就无边法
  勇力救护劣弱者　　善哉此德真良善
  德者重德愍无德　　愚者轻德而舍去
  智如红日放炎光　　愚似星光而掩耀
  贤人能护身诸过　　一向修崇德行高
  少若纵心犯一过　　积修多德亦皆失
  恶人远离于戒德　　常欲亲近不善人
  如舍清凉功德池　　而入稠浊不净水
  涂油身上要除垢　　除垢复须洗去油
  譬如作事要成功　　若得功成舍所作
  恶人恒恶喻黑蛇　　恶人迷逸如醉象
  善人怖畏心伤痛　　恶人颠倒情忻悦
  大火亘天难便灭　　深崖无底莫能知
  审慧善观危恶事　　深行信善无疑谤
  落崖入火大危崄　　或有身存复起行
  若人堕入恶趣中　　恶趣深泉不可出
  大水洪波不可漂　　大火炽焰不可烧
  强恶群贼不可夺　　是彼世间最上财
  下劣之人恃有财　　中品之人无所恃
  中人见财略悦心　　劣人恃财世最上
  一切种族形色德　　同行亲眷与朋友
  一一不知何所来　　唯务贪愚好财利
  富者妄言人为实　　贫人实语却为非
  谄诳顺恃无真行　　贤善之人闻愧耻
  有财豪贵而无德　　喻如有德人称赞
  无财贫下德行全　　愚者无知却谤毁
  勇猛德行有如无　　是彼善人真觉观
  离财安道处清贫　　亲眷轻贫实作妄
  屠儿富贵赞真实　　上人无财为下劣
  亲眷朋友顺世情　　只奉屠酤无善恶
  众知恶趣沉沦崄　　受罪中间苦百般
  乞者往来希济给　　全无辍惠固违情
  乞人不遂逆其情　　忿意含嗔叹所恨
  此人心硬语言悭　　舍利不如而舍命
  此人悭鄙痴迷重　　拯救行檀总不知
  藏贮财帛终散坏　　若行惠施永坚牢
  一人如是护多财　　愚迷转厚无思虑
  受苦宁知虚妄悭　　多人护物苦平等
  不使不用不与人　　殊无知此善好事
  金银积聚满屋中　　坑盛不净有何别
  贫穷行施真檀度　　说彼名为最上人
  富贵微舍少财帛　　如河涓滴谁不解
  若人依法行不乏　　好施如同好女色
  若施余财行间续　　感果亏盈亦如是
  清净心田事法王　　少年戒德喻花香
  慈心柔软如闺女　　适悦庄严大行芳
  礼参圣境行檀施　　精进多闻受苦辛
  轨则若亏无戒行　　前修多善并捐功
  今时名称人知重　　来世生天众所钦
  福寿远延恒快乐　　皆从持戒得成功
  常闻极苦三涂狱　　恒守威仪戒德圆
  寿尽浮生舍命时　　焰魔恶趣我无怖
  城隍聚落与林间　　或有愚迷或智慧
  假使知法不知法　　若求善逝须持戒
  坚持禁戒令清净　　恒须亲近善知识
  如法熏修善业圆　　一切功德皆集聚
  持戒法利获安乐　　若意愚迷有毁伤
  德命刹那即便灭　　智者何缘而饮酒
  彼或饮酒彰愚劣　　究竟为非无善名
  忽然倒地喻无常　　染污盈身成不净
  虽然亲眷同欢饮　　醉了相违便害命
  如是过失刹那间　　说此酒毒胜毒药
  得罪多因淫欲行　　直如舍命尚牵心
  一切欲情无善益　　何用痴迷募女人
  若乐自妻求适悦　　由常贪爱可合宜
  于他妻妾妄追求　　当感孤单心怖畏
  血肉筋髓皮肤盖　　内外都来不净身
  自身妻子犹非分　　他人妇女岂合贪
  若人洁志无淫欲　　知此和合如幻梦
  是故远离于女人　　而得心安离迷妄
  女人实可为适悦　　富贵娇奢亦复然
  亲眷共同生爱恋　　命当不久即无常
  愚人一向增贪爱　　智者思惟总是虚
  如向爱尘而乐住　　何时出离得菩提
  修行勿惮于勤苦　　彼后还招安乐身
  应是善言真利益　　服行可喻妙良药
  一切事行多明了　　过失危亡尽可知
  若是合行彼可行　　善事云何有盖覆
  若人修作前程事　　先除邪乱正思惟
  决定后时无过咎　　自然安隐苦不生
  若修善业令增长　　一心寂静离浮嚣
  如有冤家烦恼病　　自然除舍绝愚痴
  恶口两舌心下劣　　愚人纵意任情行
  岂知孔雀色严德　　可喻狼狗乌鹊噪
  呵责愚痴无正解　　赞扬精进戒施门
  我说有人行此行　　集福安身而最上
  自在法音同歌乐　　无心忻乐更何凭
  汝等有情若弃背　　为是傍生为是人
  为利非利都不悟　　是实无实俱不知
  如是暝然无了别　　虽具人形同畜生
  不分贤善与愚痴　　岂辩野干异师子
  并无胜劣一般看　　智者暂时勿共住
  不言自圣不愚痴　　不作两舌不我慢
  难知理上有所知　　说是婆罗门庄严
  一心细意修真行　　过失恒时不受行
  我慢恶人兴斗诤　　如是色德我非有
  愚痴心内怀颠倒　　慈忍全无凶猛多
  以此豪强诸过失　　执为自德胜他人
  出家胜道无心重　　善友全然不敬亲
  师教未曾申供养　　唯亲斗诤大愚痴
  天边圆月终须缺　　山下花芳不久凋
  人世无常何异此　　须诤人我拟何为
  女人本性终无实　　障碍人修善业因
  阿末罗果有其核　　此是世间三种过
  尊重法师参圣迹　　心行知足怀悲智
  如是五种世间事　　若言难作亦易作
  若人知法恒行善　　复能寻访善朋友
  喻如砂内拣真金　　一切有情皆知重
  愚劣同行不自由　　自然无德无知重
  设复出家必暴恶　　纵然活命无善名
  何以不信于朋友　　何以不知于天人
  何以不行于方便　　何以自作于难学
  悭人何处解布施　　流砂何处而有水
  不净何处有馨香　　恶人何处有恩义
  憎爱之人何有德　　冤家何处有善人
  快乐何人解知足　　寿命何人得久长
  淫女嚣浮无厚信　　痴人愚钝无分别
  富贵暂荣谁得久　　业因决定难破坏
  婆罗门得食欢喜　　孔雀闻雷声欢喜
  善人救护他欢喜　　愚迷破坏时欢喜
  愚迷爱乐行斗诤　　如贫得宝心欢喜
  贤人闻彼善言词　　如蜂闻彼花香气
  有德之人德是亲　　有过之人过是冤
  贱使之人贱是苦　　知足之人足是乐
  何惮巡门持钵化　　岂辞力役在他方
  终不于身着我见　　恒调心行善柔和
  底心无爱无人我　　似鹿无家住野林
  住是富豪及尊贵　　应无少事向他求
  弃舍妄缘诸快乐　　都无系碍自由闲
  活命性同于鹅鸭　　长于清净水中行
  王城聚落人居止　　八德多无一二存
  悲羞清净机嫌耻　　知法无我快乐力
  连山溪涧岩峦窟　　食果皮衣伏五根
  寂静野林堪适悦　　何须聚落要求人
  居山不见他门户　　自在无拘快乐行
  住彼心中所得利　　降伏根识命长生
  我今教化汝等已　　合掌调柔心意听
  一切法藏真安乐　　彼须忻乐一心求
  汝知善报一人身　　若要刹那不可得
  得后愚痴不作福　　依前自赚自沉沦
  水滴地上非久住　　可喻人生命不坚
  三种无碍谁能作　　若是智者方能行
  如是彼若随其力　　作意三种少分知
  喻如野鸽观自身　　孔雀庄严非胜我
  无常生死谁人爱　　智慧何曾观五根
  此身虽住终无久　　说彼虚生在世间
  如是焰魔人尽见　　众生受苦几人逃
  老死无侵安乐处　　云何汝等不能行
  无常情物应皆定　　唯务贪生并不知
  前路无凭光影速　　缘何兀兀不思惟
  父母妻子朋友等　　和合虚幻暂时间
  正法亲眷此堪依　　能去无常生死苦
  多求生得烦恼实　　护身生得怖畏实
  破坏生得忧愁实　　智者若求有何利
  彼若不修真如行　　轮回生死几时休
  智者恒观此世间　　都成幻化愚痴力
  戏言伎唱皆无实　　贪欲追求喻疥疮
  损命不坚如幻梦　　何如佛法用身心
  但是为非所作罪　　并皆平等坏其身
  世间何彼心愚暗　　不解思惟罪恶生
  所怀善恶心中事　　护世天人并总知
  心若不能思惟此　　何时意地消诸罪
  随缘坐住受用具　　稍可身依得暂时
  此假助缘行善利　　其余资具人烦恼
  虽睹庄严宫殿等　　唯便粗恶床卧具
  知足自然心喜乐　　如观丑女胜天女
  须知世上有为财　　水火盗贼俱可夺
  如是欲求他世福　　莫求此等不坚财
  论义工商农种士　　不依法则勿须行
  应知此事合如然　　离福自然不成就
  若能作善作不善　　应知非是别余人
  并是自身业所造　　由是众生一切得
  如是一切所作业　　若能后有不复生
  生老病苦及无常　　续续未委从何来

胜军化世百喻伽他经


十二因缘论

    No. 1651

十二因缘论一卷

        净意菩萨造

        后魏北印度三藏菩提流支译

  归命牟尼尊　　妙法比丘僧
  略作因缘论　　为义显现故
  牟尼所演说　　十二胜上分
  因缘所生法　　彼为三所摄
  烦恼业及苦　　次说应当知
  烦恼初八九　　业二及以十
  余七说为苦　　三摄十二法
  从三故生二　　从二故生七
  从七复生三　　是故如轮转
  一切世间法　　唯因果无人
  但从诸空法　　唯生于空法
  诵灯印镜响　　日珠种子水
  诸阴转不转　　智者善思量

有弟子成就。随所闻法堪能受持。令不忘失于如来法。谓事非事及性相等。如是义中心怀疑惑。为得知故问言。尊者

  牟尼所演说　　十二胜上分
  因缘所生法　　彼为三所摄
  如是等诸事　　今为知请问
  愿为我解释　　除断我疑网
  师见弟子意　　于法生渴仰
  恭敬请示故　　即答言汝听
  十二胜上分　　彼为三所摄
  烦恼业及苦　　次说应当知
  是中十及二　　故曰为十二
  以彼不异分　　故名为胜分
  如车舆分故　　说胜分应知

言牟尼者。名为寂灭。亦名无分别。亦名为定。亦名无言说。彼牟尼所演。宣畅辩说。是名假名。然彼非是大人丈夫。自在定时。性相所生。但唯因缘所生成故。彼十二分。于烦恼业及以苦处。三法迭互共作因缘。如拒瓶案。如是三处所摄应知

问曰。何者为烦恼。何者为业。何者为苦。而得有此诸因缘法胜分摄成。

答曰。于此十二胜上分中。初为无明。第八为爱。第九为取。此三胜分是烦恼所摄。第二为行。第十为有。此二胜分是业所摄。余七胜分是苦所摄。此是烦恼业苦等三。摄十二分应知。言余七者。谓识名色六入触受及生老死。恩爱别离。怨憎合会。所求不得。如是等法生一切苦。如是诸分。于向所说。烦恼业苦。以为根本。应知。摄十二分。唯有三事。更无余法。一切经中但有此分。更无有余

问曰。已知此等诸胜分义。为我解释烦恼业苦在于何处。复云何成一切诸事。答曰。从三生二。三是烦恼。二是业。谓从烦恼而生于业。从二生七。七者是苦。谓从于业而生于苦。从七生三者。谓从于苦而生烦恼。此说烦恼业苦三种迭互相生。是故生有轮转不定。所言有者。所谓欲色无色界等。彼中不住。喻如轮转。以彼有故。一切世间凡夫众生。次第上下犹如轮转。有中不定。以不定故。说有三处

问曰。彼造一切身。自在众生。何者是彼作事云何

答曰。偈言。一切世间法。唯因果无人。除假说故有。此是正思量。彼非说性。是故见作众生不成

问曰。若如是者。云何得从现在世间而取未来世间

答曰。乃至无有一毫等法从现在世间而取未来世间。是故偈言。但从诸空法。唯生于空法。此明自我我所空。谓烦恼业处。此五法行性离无我。应如是取

问曰。若性无我法中。而行性无我者。今说何为证

答曰。偈言。诵灯印镜响。日珠种子水。如是等诸喻。为证可取。信无自体。性假名故。有言。现在世未来世者。如师所诵。实不从师转至弟子。虽不从师转至弟子。岂可不成授弟子义。可言弟子无因而得。遮护妄计无因患故。如是临命终时。心识不至未来世间。防常患故。非未来身从余处来。遮护妄计无因患故。如师诵为因。令弟子得。彼不可说。以为即是亦不可说。为一向异。如是临命终时。心识为因。是故得生后身心识。而彼心识。不可说一不可说异。亦不离彼。亦不即彼。如是从灯生灯。从印生印。从镜生像。从声有响。从日从珠出生于火。从子生芽。如安石榴庵罗果等。口生涎水。如是等法。不名即彼。不名异彼。如是一切诸因缘法。转不转事。诸有智者。善思量应知。是中阴者。所谓说色受想行识。彼托生者。此诸阴灭。因彼灭阴。后相似生。然实无有一毫等法从此至彼。此是世间渐次之义。以是义故。一切世间。无常不净苦无我等。以能观察如是事故。于诸法中不生疑惑。不疑惑故则不生染。不生染故则不生着。不生着故则不虚渴。不虚渴故则不造业。以无业故则不取事。不取事故不造有为行。无有为行。故则不复生。以不生故无有一切身心等苦。如是不造五种因故。则于彼处无七种果。以无果故名为解脱。如是作故。则是释成不生不灭不常不断。有边无边如是等句。于中有偈

  不见无缘生　　决定是正义
  于诸最妙事　　是故不成断
  于中无所减　　亦复无所增
  应见如谛实　　随状及如彼

十二因缘论一卷


事师法五十颂(马鸣菩萨集)

    No. 1687

事师法五十颂(马鸣菩萨集)

        西天译经三藏朝散大夫试鸿胪少卿宣梵大师赐紫沙门臣日称等奉　诏译

  依诸经律秘密教　　略出承事师仪轨
  闻已爱乐发净心　　当获如来金刚智
  若于灌顶师　　三时伸礼奉
  则为已供养　　十方诸如来
  起最上恭敬　　合掌以持花
  散彼曼挐罗　　头面接足礼
  彼师或在家　　及新受具戒
  置经像于前　　则息诸疑谤
  若出家弟子　　常净心承事
  已坐当起迎　　唯除于致礼
  彼师及弟子　　当互审其器
  若不先观察　　同得越法罪
  若忿恚无慈　　贪爱多散乱
  骜易恃种族　　以惠当拣择
  具戒忍悲智　　尊重无谄曲
  了秘密仪范　　博闲诸论议
  善达真言相　　曼挐罗事业
  契证十真如　　诸根悉清净
  若彼求法者　　于师生轻毁
  则谤诸如来　　常得诸苦恼
  由增上愚痴　　而获于现报
  为恶曜执持　　重病相缠缚
  王法所逼切　　及毒蛇伤螫
  冤贼水火难　　非人得其便
  彼频那夜迦　　常作诸障碍
  从此而命终　　即堕于恶趣
  勿令阿阇黎　　少分生烦恼
  无智相违背　　定入阿鼻狱
  受种种极苦　　说之深可怖
  由谤阿阇黎　　于中常止住
  彼阿阇黎者　　弘持正法藏
  是故当一心　　辄莫生轻毁
  常于阿阇黎　　承事而供养
  发生尊重心　　则蠲除障恼
  又复于师所　　乐行于喜舍
  不希于己身　　何况于财物
  于无量亿劫　　勇猛勤修习
  今始证菩提　　斯极为希有
  善护其深誓　　供养诸如来
  恭敬阿阇黎　　等同一切佛
  若于己所有　　最上诸珍玩
  求无尽菩提　　诚心而奉献
  施佛阿阇黎　　念念常增长
  是最胜福田　　速得菩提果
  如是求法者　　具戒忍功德
  不虚诳于师　　当获金刚智
  若足踏师影　　获罪如破塔
  于床坐资具　　骑蓦罪过足
  若师所教诲　　欢喜当听受
  自己或不能　　则善言启白
  由依止师故　　所作皆成就
  现乐及生天　　何敢违其命
  守护师财物　　犹若己身命
  于彼执侍人　　如亲常敬奉
  不应于师前　　覆顶及乘御
  翘足手叉腰　　安然而坐卧
  或事缘令坐　　勿舒于双足
  常具诸威仪　　师起速当起
  若于经行处　　不应随举步
  端谨立于傍　　无弃于涕涶
  亦勿于师前　　私窃而言说
  及邻近语笑　　歌舞作唱等
  或令坐或起　　各安徐礼敬
  若于险路中　　白已作前导
  又不应于前　　身现疲劳相
  屈指节作声　　倚柱及墙壁
  或浣衣濯足　　及澡浴等事
  先白师令知　　所作无令见
  又复于师名　　不应辄称举
  设有固问者　　当示之一字
  师或令干集　　当伺其遣使
  于彼所作事　　忆持常不忘
  或笑嗽伸呿　　则以手遮口
  若有事启闻　　当曲躬软语
  若在家女人　　净心来听法
  合掌具威仪　　专视于师面
  闻已当奉持　　舍离于憍慢
  常如初适嫁　　低颜其惭赧
  于彼严身具　　无复生爱乐
  与善非相应　　皆思惟远离
  常慕于师德　　不应窥小过
  随顺获成就　　求过当自损
  说法度弟子　　曼拏罗护摩
  城邑同师居　　无旨不应作
  或说法所得　　净施诸财物
  悉以奉其师　　随得而可用
  同学及法裔　　不应为弟子
  亦不于师前　　受承事礼敬
  若以物上师　　二手持奉献
  师或有所施　　常恭敬顶受
  自专修正行　　常忆持不忘
  他或非律仪　　爱语相教示
  若师所教敕　　或病缘不作
  当作礼咨陈　　斯则无其咎
  常令师欢喜　　离诸烦恼事
  当勤而行之　　恐繁故不述
  彼金刚如来　　亲如是宣说
  及余教所明　　依师获成就
  若弟子清净　　能归依三宝
  设使命将终　　亦为宣法要
  及授秘密教　　令作正法器
  若现相诵持　　当获根本罪
  若能随顺师行学　　则成一切诸功德
  以我所集斯善因　　愿与众生速成佛

事师法五十颂


释摩诃衍论

    No. 1668

    释摩诃衍论序

        天册凤威姚兴皇帝制

盖闻月镜日珠。居爰山王禅宫。履于双道。游于百国乘于等观。达于恒刹举极喜之珠[玨/(冗-几+(樂-白+〡))]。窥寂灭之灵宫。道闻在昔。而犹弗觉其百恒之区。惘惘想想。方于时始释矣。前闻街巷之称声。伫教化之期。见像迹之虚形。瞻风散之界。后果面摩尼宝藏之区至于东境。当因陀罗网之珠。得于沙界。溢喜于内获之心乎。祇园之莲坐。弃来以企龟镜。盈庆于外瞻之目乎。望舒之涌台。勿返以钦星岸欤。朕方解茂花因于七觉之宝林。植莲种于八德之珠池。却欢往向。即急来后。加以金轮东方自来。应于威门之区。道王之偈先册。珠镜山虚已降。至于沙界之面。摩耶之文曾记。以未来八万而轮之驾东。及过去五百而觉之珠南至矣。其为教也。于观音中乞眼手之暇。而瞩搜过恒之教门。其为义也。于尸迦中借珠网之功。而曜罗尘数之义理。以马鸣圣光明之德。于时具显。龙树大士。妙云之瑞。于方圆启。洋洋肃肃。自非结僧那于山林中。植双因于香池中。谁悬演水之珠盖于弥勒已前。敷服膺之秘轨于释迦已后哉。释摩诃衍论者。斯乃穷性海之源密藏。罄行因之本渊词。以轮星而过乎月珠。君子莫识其旨归。以锦华而达于日域。和畴莫测其涯际。可谓一山界中在两日月。一天下中在两皇帝。朕闻其梵本先在于中天竺。遣[馬*夷]奉迎。近至东界。以弘始三年岁次星纪九月上旬。于大庄严寺。亲受笔削。敬译斯论。直翻译人筏提摩多三藏。传俗语人刘连陀等。执笔之人谢贤金等。首尾二年方缮写毕功。两曜之面圆临。群星之目具舒。江河之水澄净。大海之澜泰然。朕未及详。出金轮于坤之上。入妙高于掌之内。细哉喜门周于法界。大哉静室入于毫端。厥若斯理。绝称欤爰翰牍。离像欤爰彩画。语则净名朕呵。谈则善吉朕吐。然而道言。住绝理于讽诵。止爽词于默然。破其台观莫弘大虚。灭其镜玉勿释像迹。朕将无以于[(迷-(這-言)+└)*下]月文请。于龟免翰借。辄申鄙制。爰题序云

释摩诃衍论卷第一

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

  顶礼圆满觉　　觉所证法藏
  并造论大士　　及诸贤圣众
  欲开隔檀门　　权显往向位
  利益诸众生　　分报师恩故

论曰。今造此论重释摩诃衍。为欲显示自师其体深玄其穷微妙。未得正证未出邪行。漠漠冥冥实绝窥[穴/(烈-歹+(跳-兆))](莫昉反)。域超思惟境故。或为欲令利钝众生开顿入门。显渐进位趣入甚深所诠理故或由师亭毒极深重故。小分为报师大恩故。或秘观察当来众生。起百千诤坏论宗故。或亲听受阿世耶故。有如是等因缘。所以须造论

已说本趣次说论差别。论有几数。几论所摄摩诃衍论何所摄耶。颂曰

  十万九千部　　总十论所摄
  摩诃罗跋提　　邬舍摩阇他
  筏那提舍论　　阿部帝跋摩
  呼呵摩僧那　　键婆摩迦摄

论曰。凡集一代种种诸论。总有十万九千部焉。如是诸论总十所摄。云何为十。一者摩迦罗论。二者跋提论。三者邬舍摩论。四者阇他论。五者筏那提舍论。六者阿部帝论。七者跋摩论。八者呼呵论。九者摩僧那论。十者键婆论。是名为十。摩诃衍论如意论摄。马鸣菩萨所作之论。其数几有几文几义。摩诃衍论何所摄耶。颂曰

  总有一百部　　九十九种文
  十种义所摄　　斯论宝册摄

论曰。马鸣菩萨所作诸论总一百部。于百部中九十九种花文论摄。余十种论摄义论摄。斯论宝册。十种摄义论其名字云何。所其开示同耶异耶。颂曰

  遍满及归真　　中藏与微妙
  合一并三昧　　清净本原论
  玄理起信论　　建立同一相

论曰。云何为十。一者一心遍满论。二者融俗归真论。三者法界中藏论。四者秘密微妙论。五者众命合一论。六者真如三昧论。七者心性清净论。八者不动本原论。九者甚深玄理论。十者大乘起信论。是名为十。如是十论其数虽别。而建立相同一种焉

已说论差别次说藏差别。藏有几数几藏所摄。摩诃衍论何所摄耶。颂曰

  或五十一藏　　或唯十如经
  总三藏所摄　　论或通或别

论曰。五十一者。别因果故。表功德故。引行者故。金刚契经中作如是说。佛告佛子。我当为汝无碍言词。宣说开示五十因藏及一果藏。故或有十藏。云何为十。一者唯立一藏总摄诸法。谓法界法轮藏。圆满契经中作如是说。一切众生所有言音。莫非如来法轮声摄故。二者立二藏总摄诸法。谓声闻藏及菩萨藏。总持契经中作如是说。法门虽无边不出二种藏故。三者立三藏总摄诸法。谓加如来藏。光明契经中作如是说。过于恒沙一切诸佛。唯当宣说声闻法藏菩萨法藏如来法藏。更无余道故。四者立四藏总摄诸法。谓加补特伽罗藏。道品契经中作如是说。佛子谛听为汝解说。仁藏义藏礼藏智藏及与信藏并声闻藏及菩萨藏大觉法藏。所以者何。一切行者渐次转胜次第之法故。五者立五藏总摄诸法。谓加天藏。天子契经中作如是说佛告耶论。不可言说清净报空。我为大众广大宣说净藏人藏并二乘藏一切诸佛大觉法藏故。六者立六藏总摄诸法。谓加奈落迦藏。怖畏契经中作如是说。我不动坐分别宣说八万四千奈落迦藏。如前所说五种藏故。七者立七藏总摄诸法。谓加魔罗鸠多耶藏。班母契经中作如是说。我今实言为班母等一亿七万三千大众。分别宣说五万一千三百二种鬼神道藏。如前所说六种藏故。八者立八藏总摄诸法。谓加键婆陀那跋藏。龙王契经中作如是说。难陀龙王发八千问问于如来。佛开十亿傍生道藏。如前所说七种藏故。九者立九藏总摄诸法。谓加器世界藏。世界契经中作如是说。尔时世尊告树神言。善哉善哉如汝所说。若欲闻者我今为汝分别演说所依止藏。如前所说八种藏故。十者立十藏总摄诸法。谓加杂乱藏。音声契经中作如是说。我今开示八种杂藏。如前所说九种藏故。是名为十。如是诸藏总摄十亿八千法藏。根本三藏或摄十藏。云何为三。一者素呾嚂藏。二者毗捺耶藏。三者阿毗达磨藏。是名为三。摩诃衍论或诸藏摄。或唯阿毗达磨藏摄。是故颂曰或通或别。通谓总通别谓简别。持其行法随应不失。所以立名曰藏焉也

已说藏差别。次说经差别。经有几数几经所摄。今摩诃衍论何等经为依。颂曰

  总百洛叉数　　十二部经摄
  修多罗祇夜　　及毗伽罗那
  伽陀忧陀那　　并与尼陀那
  阿波陀那经　　伊帝目多伽
  阇陀伽佛略　　阿浮陀达摩
  优波提舍经　　依或通或别

论曰。凡集一代种种诸经有一百亿部。如是诸经总十二部摄。云何十二。一者修多罗。二者祇夜。三者毗伽罗那。四者伽陀。五者忧陀那。六者尼陀那。七者阿波陀那。八者伊帝目多伽。九者阇陀伽。十者毗佛略。十一者阿浮陀达摩。十二者优波提舍。是名为十二。摩诃衍论所依本经。或通或别。通谓总通。别谓简别。摩诃衍论文狭句少甚极微少。何故无量无边契经之海通为依耶。如婆萨伊伽诺故。如标多罗呾提故。是故无失。别所依经其数几有。何等名字眷属各几。颂曰

  总一百契经　　光明大觉等
  初五十各百　　后五十各千

论曰。摩诃衍论别所依经。总有一百云何为百。一者光明大觉经。二者甚深顺理经。三者金刚三昧经。四者诸法无行经。五者树林说法经。六者无尽一地经。七者清净如如经。八者自性自体经。九者大乘同性经。十者阿梨耶识经。十一者果圆满经。十二者虚空等经。十三者三三昧经。十四者一心法经。十五者本性智经。十六者真法界经。十七者摄无量经。十八者最上极经。十九者维摩诘经。二十者楞伽王经。二十一者中实经。二十二者无始经。二十三者十因经。二十四者轮转经。二十五者慈云经。二十六者器心经。二十七者无位经。二十八者贤圣经。二十九者隐密经。三十者华严经。三十一者大品经。三十二者寂灭经。三十三者圣轨经。三十四者遍缘经。三十五者熏习经。三十六者佛性经。三十七者玄理经。三十八者楞伽经。三十九者本业经。四十者蕴高山经。四十一者归本经。四十二者真修经。四十三者八德经。四十四者佛慧经。四十五者缘起经。四十六者一体经。四十七者自佛经四十八者大海经。四十九者无相经。五十者遍真如经。五十一者十种如来藏经。五十二者三身本有经。五十三者八识通达缘经。五十四者众生身等法经。五十五者诸佛无尽藏经。五十六者赞叹不善品经。五十七者诸法同一相经。五十八者一体大悲观经。五十九者如如本智慧经。六十者尘尘法界刹土经。六十一者轮转本际经。六十二者法界法轮经。六十三者大智本有经。六十四者平等法界经。六十五者四相常住经。六十六者真如一相经。六十七者流转不动经。六十八者寂静涅槃经。六十九者通达音声经。七十者如来自相经。七十一者夫人经。七十二者法门经。七十三者八喻经。七十四者中在经。七十五者总持经。七十六者不动经。七十七者两智经。七十八者道智经。七十九者本觉经。八十者大无量经。八十一者自然本果经。八十二者甚深法藏经。八十三者一道清净经。八十四者十种妄想经。八十五者法门显了经。八十六者境界圆满经。八十七者光明实智经。八十八者因果同体经。八十九者心神不空经。九十者真智无生行经。九十一者无碍解脱经。九十二者随缘增长经。九十三者法性实际经。九十四者广大虚空经。九十五者本因缘起经。九十六者诸法无为经。九十七者本来清净经。九十八者修行道地经。九十九者不修具德经。百者摩诃萨云若经。是名为百。如是百经眷属。如次初半各百后半各千。举经之目属论之纲。下当随文开示现说

已说经差别。次论当造人。契经异说其数几有。今马鸣师何所摄耶。颂曰

  总有六马鸣　　契经异说故
  然随机应故　　无有相违失

论曰。凡集一代诸契经中种种异文。总有六种。云何为六。一者大乘本法契经中作如是说。无上大觉尊说入涅盘缘。马鸣菩萨即从坐起。顶礼佛足合掌恭敬。向佛世尊而说偈言

  大慈满足无上尊　　无边劫海备万行
  唯慈悲群生类故　　而佛自言入涅盘
  我及一切诸大众　　冥冥而乱失心神
  大慈满足世尊尚　　弃自子等往异界
  况我慈悲未满足　　随佛往异界谁谤

尔时马鸣说此偈已。睹佛眼睛徐自命终。二者变化功德契经中作如是说。尔时世尊告马鸣言。我灭度后三百余岁。汝当承我加力。以种种方便法利益安乐末代众生。若我不加力汝当不能自。三者摩诃摩耶契经中作如是说。如来灭后六百岁已。九十六种诸外道等。邪见竞兴毁灭佛法。有一比丘名曰马鸣。善说法要降伏一切诸外道辈。四者常德三昧契经中作如是说。佛灭度后八百岁中。有一智人名曰马鸣。或外道众或佛家众。破诸外道建立佛法。五者摩尼清净契经中作如是说。佛涅盘后一百余岁。马鸣大士出现于世。守护正法安立佛幢。六者胜顶王契经中作如是说。如来成道第十七日。有一外道名曰迦罗诺鸠尸摩。变化其身作大龙王。出现八万六千头八万六千舌。一时发起八万六千相违难问问于如来。如来则作三重答说通彼切难。于是龙王又作十重问问于如来。如来则作百重答说通彼切难。如是问答已。佛告龙王言。善哉善哉马鸣沙门。为护法城故。以破坏相建立佛法。耐也耐也。常如是修常如是行。勿小游行普遍游行。于是龙王以其本形舍畜生相。无上尊前顶礼和南。欢喜之貌向佛世尊。而说颂言

  善哉善哉言　　经听于我耳
  假耶实耶自　　极疑于我心
  我非畜生身　　我非外道众
  而赞化为生　　变化如是形
  世尊如镜知　　我没于是界
  出于余世界　　如教普游行

尔时马鸣说此偈已。如入禅定入于寂室。是名为六。如是诸经各各别说。随机现应无相违过。马鸣菩萨当何位人。何城诞生何因马鸣。颂曰

  本大光明佛　　因不动位中
  西天竺出现　　从过去立名

论曰。马鸣菩萨若克其本大光明佛。若论其因第八地内住位菩萨。西天竺诞生。卢伽为父瞿那为母。同生利益。过去世中有一大王。名曰轮陀。有千白鸟皆悉好声。若鸟出声大王增德。若不出声大王损德。如是诸鸟若见白马即出其声。若不见时常不出声。尔时大王遍求白马终日不得。作如是言。若外道众此鸟鸣者。都破佛教独尊独信。若佛弟子此鸟鸣者。都破外道教独尊独信。尔时菩萨用神通力。现千白马鸣千白鸟。绍隆正法令不断绝。是故世尊名曰马鸣

已说人别相。次唱本作释

本曰

  归命尽十方　　最胜业遍智
  色无碍自在　　救世大悲者

论曰。此一颂中则有二门。云何为二。一者总摄一切众命门。二者归向圆满大觉门

总摄门者。通摄一切十方界中所有众生众命根故。如本命尽十方故

归向门者。用如是众命归契于满足大慈悲人故。如本归最胜业遍智色无碍自在救世大悲者故。论师举几德赞叹大觉尊。各其相云何。颂曰

  总八万四千　　四十八种德
  最胜等各十　　智无碍各四
  及八万四千　　色相差别故
  功德虽无量　　终不出此数

论曰。马鸣菩萨总举八万四千四十八种功德。奉仰赞叹无上大觉。佛果满位中功德净品。虽有无量无边。而终不出此数量。是故马鸣菩萨总相赞叹。云何为八万四千功德。色相差别故成八万四千。云何为四十。最胜业遍各十种故成四十数。云何为八。智及无碍各有四种故成八种。云何为十最。一者超过最。远离二乘地故。二者出离最。永离三界域故。三者对治最。顿断四住地故。四者厌患最。已过五蕴聚落故。五者离爱最。永别六道岐故。六者威德最。胜退七恶军故。七者兵众最。皆尽八邪林故。八者智慧剑最。决断九结绊故。九者解脱最。断除十缠绳故。十者勇猛最。摧伏九十六种诸外道故。是名为十最。于契经中十种第一。云何为十胜。一者力胜。具足十力故。二者无畏胜。具足四无畏故。三者不共胜。具足十八不共法故。四者道品胜。具足三十七道品故。五者变化胜。具足百千种变化故。六者言音胜。具足八十八梵音故。七者端严胜。具足三十二种丈夫相故。八者吉祥胜。随作境界处出生增长功德善根故。九者难得胜。于三界中独尊一故。十者住处胜。所居宫殿以九万八千微妙圆满而所庄严故。是名为十胜。于契经中十种殊胜。云何为十业。一者自然业。所作自在故。二者平等业。教化利益无差别故。三者相应业。随机出现故。四者具足业。圆满福智二资粮故。五者无尽业。无边际故。六者同生业。随趣受生故。七者无著业。远离尘累如莲华故。八者依止业。作归依处如大地故。九者无厌业。摄生无穷如大海故。十者通达业。无有障碍如虚空故。是名为十业。于契经中十种作用。云何为十遍一者根遍。佛诸色根各各一一根周遍法界故。二者识遍。佛诸心识无所不达故。三者境界遍圆智所缘无分界故。四者寿命遍。不可思议故。五者眷属遍。不可测量故。六者功德遍。一一功德等虚空界故。七者慈悲遍。无简择故。八者言说遍。佛言音声无所不至故。九者证遍。无所不穷故。十者无等遍。无与等故。是名为十遍。于契经中十种周遍。云何为四智。一者光明无尽藏智。能出生十亿一千智慧门故。二者一味一相智。通达恒沙一切诸法无差别故。三者大悲无边智。随起一化遍满一切十方世界故。四者无为寂灭智。远离一切起动作业故。是名为四智。于契经中四种圆满智。云何为四无碍。一者法无碍。了知诸法实相实性故。二者义无碍。了知诸法共差别相及生灭相故。三者辞无碍。不坏假名而说实相故。四者乐说无碍。发无边言说契经海次第不断绝故。是名为四无碍。于契经中四种解脱智。自在之言皆通于上。故不别释。色相名义如大总持中广显说已说觉宝次说法僧

本曰

  及彼身体相　　法性真如海
  无量功德藏　　如实修行等

论曰。此一颂中复有二门。云何为二。一者体摄一切众身门。二者总达法藏僧伽门。体摄门者尽摄一切无量众生生灭流转无常身故。如本彼身体相故。总达门者。以如是众身。总达于诸甚深法藏一切如实修行者故。如本及法性真如海无量功德藏如实修行故。等言总通和南之意。论师依几法僧而和南耶。其相云何。颂曰

  总归于十四　　僧十法四故
  或兼上下故　　有多类僧众

论曰。马鸣菩萨总归依于十四德处。十僧四法各差别故。云何为十僧。十地差别故。云何为四法。教理行果各差别故。法谓教法。所谓随顺机根一切契经之海。性真如谓理法。于一切法体性平等。离虚妄之假绝执着之实故。海谓果法。于妙觉果万德圆满。无有穷尽如大海故。无量功德藏谓行法。六度万行净品眷属。不可思议超过数量故。如谓十种真如。实修行谓十种正智。证真如理于真实智建立僧名。理智和通能所一味平等。平等无诤论故。何故取命标十方耶。为欲显示所摄命根广大圆满无边际故。何故取身标其相耶。为欲显示四相所乱一切众生皆悉摄取。欲令获得金刚常住不动身故。何故八圣唯不归自身命。乃通取一切无量众生所有身命归于三宝。由明了知一切众生平等平等唯一真如无有别异。众生身命及我身命。一味一相不相离故。是故颂言等。等言极甚深。何故摄取一切众生无量身命。归于三宝成和南相。由十方三世一切诸佛皆悉欢喜。十方三世一切诸菩萨皆悉赞叹。十方三世一切诸法藏。常恒流布不断绝故。马鸣菩萨证不动地。下地功德悉已满足。何故下位诸僧皆悉和南。由能归人皆非同于自得位故。若自归依唯应和南不动地满并上二地。若尔何故不取地前。非无归人故不别举。以上兼下影显示故。法云地菩萨能归人时当依何僧。于妙觉地有真实僧故无过失。若尔何故不别举耶。以下兼上影显示故。是故颂曰或兼上下故有多类僧众

已说法僧次说本趣

本曰

  为欲令众生　　除疑舍邪执
  起大乘正信　　佛种不断故

论曰。此一颂中则有二门。云何为二。一者断绝障缚门。二者连续解脱门。断绝门中有四差别。云何为四。一者决定信心门。为令一切无量众生。断除疑惑心发起坚固信。决定于甚深大乘正道故。二者远离舍心门。为令一切无量众生。远离厌舍心增长欲乐意。精进于甚深大乘正道故。三者对治邪论门。为令对治九十六种诸大外道。九万三千眷属外道。四种大魔三万二千眷属魔众断除一亿四万六千种诸世论。趣入于大乘甚深正道故。四者除遣执着门。为令一切无量异生。及诸二乘一切菩萨。断除五种人见证得五种对治。断除二种法执证得二种对治。回向于甚深大乘正道故。如本为欲令众生除疑舍邪执起大乘正信故。连续门中有三差别。云何为三。一者不断大觉门。为令集成万行之因。庄严大觉之果。无上法王不断绝故。二者不断法藏门。为令出现胜妙梵响。宣说一切契经之海。八万四千法藏不断绝故。三者不断僧伽门。为令修地前地上之大道。建立真如法界之宫殿。住正后二僧而不断绝故。如本佛种不断故故。颂众生言分际云何。为欲对治何等断故。建立三宝不断耶。颂曰

  通摄三聚人　　未得圆满故
  对四种断故　　建立三不断

论曰。马鸣菩萨通缘三聚。而为境界。所以者何。由未证得圆满果故。然三聚门有其三种。云何为三。一者十信前名为邪定聚。不能信业果报等故。三贤及十圣名为正定聚。决定安立不退位故。十种信心名为不定聚。或进或退未决定故。二者十信前并十信心名为邪定聚。皆无善根故。无上大觉果名为正定聚。已满足故。三贤及十圣名为不定聚。皆未究竟故。三者十信前名为邪定聚。无乐求心故。十圣名为正定聚。已得真证故。十信三贤名为不定聚未得正证故。是名为三。马鸣菩萨须彼初门。为欲对治四种断故。建立三宝不断之义。云何为四。一者疑惑断。由犹豫心不能决定。断三宝种故。二者厌舍断。由爱有心不能乐法。断三宝种故。三者见邪断。由妄想心不能正见。断三宝种故四者定执断。由实有心不能离着断三宝种故。是名为四断已说本趣。次开总体

本曰。有法能起摩诃衍信根。是故应说

论曰。此文中有二门。云何为二。一者能入门。二者所入门。能入门者。于所诠理善趣入故。所入门者。善为彼法作依止故。有法者。总标十六能入门法。能起信根者。总标门法作业之相。摩诃衍者。总标十六所入法体并及不二摩诃衍体。信决定进心。根生长行法。若为入理无超此二。故曰信根。复次信谓十信。根谓从初发心住乃至法云地。所以者何。初信无根随缘进退。譬如班多伽伊摩华故。后信转胜坚固不动。譬如键鸠阿弥礼树故。信根有几义。各其相云何颂曰

  各有十种义　　澄净下转等

论曰。信有十种义。云何为十。一者澄净义。能令心性清净明白故。二者决定义。能令心性淳至坚固故。三者欢喜义。能令断除诸忧恼故。四者无厌义。能令断除懈怠心故。五者随喜义。于他胜行发起同心故。六者尊重义。于诸有德不轻贱故。七者随顺义。随所见闻不逆违故。八者赞叹义。随彼胜行至心称叹故。九者不坏义。在专一心不妄失故。十者爱乐义。能令成就慈悲心故。是名为十。根有十种义。云何为十。一者下转义。能除憍慢故。二者隐密义。能诠甚深理故。三者出生义。生长种种诸功德故。四者坚固义。皆悉摄持不阙失故。五者相续义。转转增长无断绝故。六者出离义。地地转胜渐渐远离故。七者集成义。修集种种道品法故。八者茂荣义。以诸行德而所庄严甚可爱乐故。九者具足义。等觉位中圆满因行故。十者高胜义。于妙觉果最胜广大无能超过故。是名为十。能入所入种种差别。立义分中自当显说

已说总体。次明建立

本曰。

说有五分。云何为五。一者因缘分。二者立义分。三者解释分。四者修行信心分。五者劝修利益分

论曰。何故次第如是。教法出现法如是故。此义云何。为欲显示上味妙药。当由所对疾障出现。能化教法。定由所治机根发起。疾前无药机先无教故。初立因缘分。为欲显示如意宝珠虽唯是一。而为一切诸宝根本。摩诃衍法虽唯是一。而为恒沙法门体性。重威大龙乃所受用。利根智者乃所领解故。第二立立义分。为欲显示摩尼宝藏虽备无量万宝而开千重门群龙所了知。大乘本法虽圆无边千义而别释散说钝根所分明故。第三立解释分。为欲显示虽眼耳中见闻宝雨之妙术。思心中解知无尽之圆德。而出现舌威不竞入门开通往向不近隔檀。得如意宝藏无由蹬台宫。虽口语中诵持教义之尊辞。思心中观察广略之深理。而勤加行添于胜进。方于金刚。不起坚固信。得法界宝藏而无由契玄理故。第四立修行信心分。虽开广略之法示进入之门。而怯弱众生。闻广说法门不堪进修行钝根众生闻略说法门。不能解故生厌离心。如是等众类。若值劝请缘渐渐进修。备百行因至万德果。若不得值劝策缘弥弥远退。将恒沙烦恼而及于无性。马鸣菩萨见是利故。显示利益劝请修行。是故后立劝修利益分。有何因缘不增不减唯立五分。颂曰

  摄彼大　　总地　　五十法门故
  是故不增减　　唯建立五分

论曰。马鸣菩萨十万嗢拖南大总地论中。总立五十门判释诸教理。今此论中五分法门各摄彼十门。是故不增减唯立五分。所谓彼论建立所化圆满等十门。因缘分所摄。百六十摩诃衍等十门。立义分所摄。安立随顺决择等十门。解释分所摄。修习决定趣入等十门。修行分所摄。劝请呵责引导等十门。劝修分所摄

已说建立门次说唱章判说门

本曰。初说因缘分。问曰。有何因缘而造此论。答曰。是因缘有八种。云何为八。一者因缘总相。所谓为令众生离一切苦得究竟乐。非求世间名利恭敬故。二者为欲解释如来根本之义。令诸众生正解不谬故。三者为令善根成就众生。于摩诃衍法堪任不退信心故。四者为令善根微少众生修习信心故。五者为示方便消恶业障。善护其心远离痴慢出邪网故。六者为示修习止观。对治凡夫二乘心过故。七者为示专念方便生于佛前。必定不退信心故。八者为示利益劝修行故。有如是等因缘。所以造论

论曰。是八因缘中。初一为立义分作正因缘。次二为解释分作正因缘。次四为修行信心分作正因缘。后一为劝修利益分作正因缘。初一因缘中即有四门。后七因缘中各具三门。云何为四。一者能化教法出兴门。二者所化众生分际门。三者出兴作业善巧门。四者除遣诤论诽谤门。云何为三。谓前三门。今当举相随次别释。因缘总相者。总举能化教法出兴门。谓为八种根本总体作正因缘。故言因缘总。为二十四种分离别相作正因缘。故言因缘相。三十二种总别法相。立义分中自当显说。为令众生者。总举所化众生分际门。谓摄邪定聚十亿八万六千种众生。不定聚三十种众生。正定聚一百二十种众生故。离一切苦得究竟乐者。总举出兴作业善巧门。谓缘三聚而为境界。宣说开示妙法要者。欲令一切无量众生。远离生灭无常之苦。获得根本总相之乐故。非求世间名利恭敬故者。总举除遣诤论诽谤门。谓愚众生作如是疑。马鸣菩萨居位不动地未及法云地。而缘上地诸菩萨等。为其所化之境界者。唯显自殊胜。为求名利等。有其虚言无有实义。岂下地菩萨应得教化上地菩萨。是故马鸣为遣如是不信疑故。自通而言。我久远劫成正觉讫。而助教化利益群生。为满本愿故权示蓝修位。非谓欲求名利等故作如是说。已说初因缘。第二因缘言解释如来根本之义者。总举能化教法出兴门。谓是因缘能为显示正义对治邪执。作正因缘故。言如来根本之义。所以者何。十方三世一切如来。无有一佛不为根本一心二门七种对治成正觉故。令诸众生者。总举所化众生分际门。谓摄十亿八万六千种邪定聚众生故。正解不谬故者。总举出兴作业善巧门。谓缘邪定聚狂乱众生而为境界。宣说开演显示正义对治邪执甚深法者。正恒沙之谬邪解。摧尘数之逆乱见。断除其阐提不信障。而为令趣入于十信大道故。已说第二因缘。第三因缘为分别发趣道相作正因缘。是名为能化教法出兴门。谓三种发心。善根成就众生者。总举所化众生分际门。谓摄上品十信三品十解三品十行三品十向三品十地诸众生故。于摩诃衍法堪任不退信心故者。总举出兴作业善巧门。谓缘二聚众生而为境界。宣说开示三发心者。为令超过自分获得胜进故。已说第三因缘。第四因缘为修行信心分四种信心四种修行作正因缘。是名为能化教法出兴门。善根微少众生者。总举所化众生分际门。谓摄得十信位前五心中品众生故。已得前五故。非都无善根名言微少。未得后五故不能具足。不名成就。修习信心故者。总举出兴作业善巧门。谓能为令成就后五信心故。已说第四因缘。第五因缘为修行信心分进门之终。复次若人虽修行信心乃至得免诸障善根增长故作正因缘。是名为能化教法出兴门。此中众生摄得十信位初心下品众生故。是名为所化众生分际门。消恶业障等者。总举出兴作业善巧门。谓示礼拜忏悔等方便。而为消除种种业障海故。已说第五因缘。第六因缘言修习止观者。总举能化教法出兴门。谓为修行信心分修行止观门作正因缘故。凡夫二乘者。总举所化众生分际门。谓摄得十信位二心下品众生。邪定聚摄一切二乘故。对治心过者。总举出兴作业善巧门。谓以两轮通为对治凡夫二乘见执过失故。已说第六因缘。第七因缘为修行信心分之终。复次众生初学是法乃至毕竟得生住正定聚故作正因缘。是名为能化教法出兴门。此中众生摄得十信位前四心。更不能胜进下品众生。谓住是世界信心成就极怖畏故。是名为所化众生分际门。必定不退信心故者。总举出兴作业善巧门。谓以胜缘力而为安立正定聚故。已说第七因缘。第八因缘为劝修利益分作正因缘。是名为能化教法出兴门。此中众生摄十亿八万六千种邪定聚诸众生故。是名为所化众生分际门。为示利益劝修行故者。总举出兴作业善巧门。谓为欲令宣说功德增长欲乐。显示过患觉悟厌离故。已说第八因缘。一切诸教法皆尽于立义分。一切诸所化之机皆尽于初因缘分。何故开三分而别释。立七因缘而散说耶。为欲显示利钝广略总别不同故。何故二乘人重取于四处。为欲显示二乘众生下劣狭少。发菩提心向无上道。甚极切难超过于余类众生故。何故所余邪定众生唯取于三处。为欲显示所余众生形于二乘轻其过失故。何故不定人别取三品耶。为欲显示不定众生微薄暗钝。发决定心向无上道。甚极切难超过于正定众生故。何故正定人不别三品通总摄耶。为欲显示正定众生形于不定轻其过失故。有何因缘不增不减唯立八种。何故次第如是颂曰

  总摄大总地　　八十因缘故
  修行转胜法　　次第如是故

论曰。马鸣菩萨十万嗢陀南大总地论中。总立八十因缘。以为论缘由。今此论中八种因缘。各摄彼论十种因缘。故不增减唯立八种。由是义故言如是等。等字总摄彼八十故。因缘次第行法法尔故。谓除阐提不信障得十信心。除着我障得十住心。除畏苦障得十行心。除舍离障得十向心。断异生性等十种障证欢喜等十种地故

已说八因缘。次说四种根

本曰。问曰。修多罗中具有此法。何须重说。答曰。修多罗中虽有此法。以众生根行不等。受解缘别。所谓如来在世时众生利根。能说之人色心业胜。圆音一演异类等解。则不须论。若如来灭后。或有众生能以自力广闻而取解者。或有众生亦以自力少闻而多解者。或有众生无自心力。因于广论而得解者。自有众生复以广论文多为烦。心乐总持少文而摄多义能取解者。如是此论为欲总摄如来广大深法无边义故。应说此论

论曰。此文中有二门。云何为二。一者所说无异难问门。二者举时分位决疑门。问曰。修多罗中具有此法何须重说者。则是难问门。谓光明大觉等一百契经中。开示一切无量法藏。随机根量摄取利益无所阙失。中士何用烦造此论。重传彼法更无加显力。今造此论重说彼法者。颇不求称赞等事耶。毕竟尊信不尽其理。是名为所说无异难问门。答曰。修多罗中虽有此法以众生根行不等受解缘别者。总举决疑门。所谓马鸣自通而言。三世诸佛一切教理。自然常住一味平等。无有移转无有起灭。是故虽题榜差别翰牍不同。而其教法唯是一味唯是平等。或不分或不别。然而众生根性差别利钝不等。心行差别广略不同。既所化之机异。能化之人不能自同。令受教法名字各别。令解文义因缘各别。谓或有众生依佛伽陀修梨毗罗而得解者。或有众生依菩萨遮陀尸修梨毗罗方得解者。故为是人当须造论。复次如来在世时所化清净。能化圆满八万四千种色四种心遍智十种作业十种殊胜。六十八梵圆八十八妙音。无有前后一时敷演。无量无边种种异类。或有众生见佛妙色而得解者。或有众生思惟佛心品而得解者。或有众生观察如来十业十胜而得解者。或有众生听闻佛梵圆妙音而得解者。如是平等明了通达则不须论。若佛灭后所化杂乱能化少阙。经论机异广略根别。根谓四种根。机谓三乘机。云何为四。一者广自力根。二者略自力根。三者广无力依他根。四者略无力依他根。如是四种根性中。初二是修多罗众。后二是优婆提耶众。何故因缘门中所化圆满。根性门中所化微少。为欲显示清净僧那阿世耶无有边际故。为欲显示受教实行众生之类有其分际故。以何因缘出兴两重广略教法。其相云何。颂曰

  本愿系属故　　出兴此法门
  楞伽王契经　　分明显说故

论曰。系属因缘之力故。出兴两重甚深法门。所以者何。于契经中明显说故。所谓楞伽王契经中作如是说。尔时世尊告文殊师利言。我念过去无量劫海。于五百世忍辱仙人。在山林中专心修行小欲知足四圣众种清净之法。于时有一大蛇从山顶下。来诣我所闻我所诵。则投其体礼拜忏悔。投体已讫以头攒地。区区作文而说偈言

  我过去世　　忍辱仙人　　住于此山
  六时行道　　而一时嗔　　因缘力故
  今得蛇身　　常受大苦　　若命终后
  得人同分　　我当弟子　　随汝修行
  汝所读诵　　常我所诵　　是故我今
  发大惭愧

说是偈已即便命终。后得人身则我弟子。尔时互相发愿系属。谓作如是愿。我若证无上道。宣说九十落叉广说修多罗。利益意乐广大众生。宣说十落叉略说修多罗。利益意乐总持众生。即我弟子作如是愿。我当师灭后造作九十部广说优婆萨提耶。利益意乐广大众生。造作十部略说优婆萨提耶。利益意乐总持众生。以此因缘我今宣说诸契经海。以此因缘故。我灭度后我弟子现造作论教

已说因缘分。次说立义分。立义分中法门名字。其数几有其相云何。颂曰

  有三十三种　　十六所入法
  十六能入门　　及不二别故

论曰。立义分中法门名数。总有三十三种差别。云何为三十三差别。所谓十六所入本法。十六能入门。及不二摩诃衍各差别故。何故摩诃衍成十六种。根本摩诃衍中开八种故。一心法界三大义中各开二种故。何故能入门成十六种。一心法界及三大义各二种故。或各开二种门故。是名为本数

已说法数。次当别释

本曰。摩诃衍者总。说有二种。云何为二。一者法。二者义。所言法者谓众生心。是心则摄一切世间法出世间法。依于此心显示摩诃衍义。何以故。是心真如相。则示摩诃衍体故。是心生灭因缘相。能示摩诃衍自体相用故。所言义者即有三种。云何为三。一者体大。谓一切法真如平等不增不减故。二者相大。谓如来藏具足无量性功德故。三者用大。谓能生一切世间出世间善因果故。一切诸佛本所乘故。一切菩萨皆乘此法到如来地故

论曰。此文中有三门。云何为三。一者所入根本总体门。二者能依趣入别相门。三者通达轨则不动门。初二种门有其两重。住思应观。摩诃衍者总者。即是所入根本总体门。即是根本摩诃衍中有八差别。云何为八。一者一体一心摩诃衍。二者三自一心摩诃衍。三者无量无边诸法差别不增不减体大摩诃衍。四者寂静无杂一味平等不增不减体大摩诃衍。五者如来藏功德相大摩诃衍。六者具足性功德相大摩诃衍。七者能生一切世间因果用大摩诃衍。八者能生一切出世间善因果用大摩诃衍。是名为八。如是八种摩诃衍法。皆从能入建立其名。谓以一体一心。而为其门所趣入故。名为一体一心摩诃衍。乃至以能生一切出世间善因果用大。而为其门所趣入故。名为能生一切出世间善因果用大摩诃衍。譬如转轮圣王。谓如轮王随其轮相建立名字。摩诃衍法亦复如是。随其门相建立名故。大觉契经中作如是说。佛告文殊师利言。谛听谛听善思念之。我当为汝分别开说八种身法。何等为八。一者一体趣入身法。二者三自趣入身法。三者诸法差别不增不减体大趣入身法。四者纯净一相无杂不增不减体大趣入身法。五者如来藏功德显了大趣入身法。六者圆满性功德显了大趣入身法。七者出生世间因果自在无碍大趣入身法。八者出生出世间妙因果自在无碍大趣入身法。是名为八。乃至广说。马鸣菩萨正摄彼文。是故说言摩诃衍者总。此中总言。于两处中是总体故。所谓望上及下临故。大总地论中开八十门。广释根本摩诃衍法。今各摄十成一种故。唯立八法。由何义故有八应知。能入别相有八种故。所入总体有八应知。能入所入八种法相。胜劣广狭其相云何。颂曰

  平等平等一　　皆无有别异
  各摄诸法故　　然终不杂乱

论曰。如是能所十六法相。遍满遍满平等平等。一味一相皆无差别。所以者何。各摄诸法毕竟尽故。若尔本末及与总别。皆悉浑同应杂乱耶。终其本末不相杂乱。其总别门初后不无。然各各别皆悉等量。故曰平等。非谓一法故称平等。已说初重。第二重四种法中各具三门。云何为三。一者本法所依决定门。二者根本摄末分际门。三者建立二种摩诃衍门。所言法者谓众生心者。即是本法所依决定门。今当须嗢拖南颂总持显说。其相云何。颂曰

  众谓四衍众　　生谓四种生
  是一法界藏　　遍于彼八处

论曰。众有四种。云何为四。一者一切如来众。二者一切菩萨众。三者一切声闻众。四者一切缘觉众。是名为四众。生有四种。云何为四。一者卵生。二者胎生。三者湿生。四者化生。是名为四生。过数故众。受生故生。是一法界心。彼八处中周遍圆满。不可分析不可离散。唯是一体唯是一相。以四种众摄诸圣尽。以四种生摄诸凡尽。马鸣论师为显一心广大圆满。名为众生。顺理契经中作如是说。尔时世尊放大光明显神力已。告佛子言。谛听谛听善思念之。我当为汝分别解说一法界藏。善男子。一法界藏者。所谓遍于诸如来众诸菩萨众诸声闻众诸缘觉众及诸异生。无所不通。无所不至无所不当。是故名为一法界藏。今摄此文故名众生。马鸣菩萨六万嗢拖南本藏论中。开十种门别释散说。今略摄故唯言众生。已说本法所依决定门。是心即摄一切世间法出世间法者。即是根本摄末分际门。其相云何。颂曰

  是一法界心　　总摄二种门
  名摄世出世　　作法界名法

论曰。一法界心总摄一切生灭门法。是故名为摄世间法。总摄一切真如门法。是故名摄出世间法。皆作法界故名为法。自体契经中作如是说。广大神王即摄一切种种无明。一切种种染法。一切种种净白品法。又摄一切清净法。一切无碍法。一切解脱法。一切绝离法。一切满足法。一切寂静法。而广大神王非世间法非出世间法。今摄此文故名为摄。马鸣菩萨八万嗢拖南归宗论中。开二十门分明显说。此中略故如是而已。已说根本摄末分际门。依于此心显示摩诃衍义等者。即是建立二种摩诃衍门。其相云何。颂曰

  总标二种门　　言依于此心
  总标二本法　　显示摩诃衍

论曰。总标能入二种门故。言依于此心。总标所入二种法故。言显示摩诃衍义。云何为二门。一者心真如门。二者心生灭门。云何为二本法。一者一体摩诃衍。二者自体自相自用摩诃衍。如是所入二种本法。或从能入建立其名。所谓以真如体。而为其门所趣入故。名言为体。以自相本觉心。而为其门所趣入故。名言为自。由能入门二种别故。所入本法有二应知。何以故者。即请问辞。谓由何义。依于此心句中具二种门。显示摩诃衍义句中具二种本法者焉。答曰。作一法界心真如门。即显示一体摩诃衍法。作一法界心生灭门。能示自体自相自用摩诃衍法。由此义故。当知各具二门二法。大觉契经中作如是说。复次文殊师利。有二种法。甚深微妙不可思议。何等为二。一者体相平等摩诃衍。二者自相自然摩诃衍。若欲证得是二种法。当行二门。何等为二。一者无断无缚门。二者有断有缚门。乃至广说。今摄此文作如是说。大总地中开八种门分明散说。已说建立二种摩诃衍门。三大义中各略初二门立后一门。马鸣菩萨本趣意乐。举后摄初中故如是而已。复次比来次第分明显了故。以上二颂本流应至于此。一者体大者。总标所入二种本法。云何为二。一者无量无边诸法差别不增不减摩诃衍。二者寂静无杂一味平等不增不减摩诃衍。谓一切法真如平等不增不减故者。总标能入二种别门。云何为二。所谓如本法名门亦尔故。二者相大者。总标所入二种本法。云何为二。一者如来藏功德摩诃衍。二者具足性功德摩诃衍。谓如来藏具足无量性功德故者。总标能入二种别门。云何为二。所谓如本法名门亦尔故。三者用大者。总标所入二种本法。云何为二。一者能生一切世间因果摩诃衍。二者能生一切出世间善因果摩诃衍。谓能生一切世间出世间善因果故者。总标能入二种别门。云何为二。所谓如本法名门亦尔故。三种大义别别分释。如总地论本地品中分明显说。何故不二摩诃衍法无因缘耶。是法极妙甚深独尊。离机根故。何故离机根。无机根故。何须建立。非建立故。是摩诃衍法诸佛所得耶。能得于诸佛。诸佛得不故。菩萨二乘一切异生亦复如是。性德圆满海是焉。所以者何。离机根故。离教说故。何故八种本法从因缘起。应于机故。顺于说故。何故应机。有机根故。如是八种本法诸佛所得耶。诸佛所得。于诸佛得不故。菩萨二乘一切异生亦复如是。修行种因海是焉。所以者何。有机根故。有教说故。何故依真如门所趣入之摩诃衍法唯立体名。依生灭门所趣入之摩诃衍法立自名耶。真如门中无他相故。生灭门中有他相故。他谓一切不善品法。自谓一切清净品法。若所对治他无。能对治自无故。唯言体不说自焉。若所对治他有。能对治自有。故名言自不唯体焉。复次为欲显示一法界体平等平等无有其私。无量性德自然本有非得他力故。复次随宜安立。无有定故。何故别说门中。一心别为一三大总为一。而等同各诠二摩诃衍。三大义合。方应得诠二摩诃衍。大义之名通于三种。故总为一义。无别意趣。今所开示十六法门。胜劣广狭其相云何。颂曰

  平等平等一　　皆无有别异
  各摄诸法故　　然终不杂乱

论曰。能入所入十六法门。圆满圆满平等平等。周遍法界无有差别。所以者何。各摄诸法毕竟尽故。然终不杂本末能所。已说总别二门。一切诸佛本所乘故一切菩萨皆乘此法到如来地故者。即是通达轨则不动门。谓微尘数过去诸佛。微尘数现在诸佛。微尘数未来诸佛。皆悉乘此三十二种。甚深安车。达于清净无上地故。十方三世一切菩萨亦复如是。此中菩萨言通取三聚一切众生。所以者何。无有众生而不通达如来地故

释摩诃衍论卷第一释摩诃衍论卷第二

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

已说立义分。次说解释分

解释分中法门名字其数几有。其相云何。颂曰

  唯有四种法　　余二十九门
  略不解释故　　九论已说故

论曰。解释分中唯释四法。所余法门略不别释。云何为四。一者一体摩诃衍。二者三自摩诃衍。三者真如门。四者生灭门。何故余法略不解释。一心遍满等九论中已解释故。所谓一心遍满论中唯释四法。所余法门略不别释。云何为四。一者一体一心摩诃衍。二者三自一心摩诃衍。三者一体一心门。四者三自一心门。融俗归真论中唯释四法。所余法门略不别释。云何为四。一者无量无边诸法差别不增不减体大摩诃衍。二者寂静无杂一味平等不增不减体大摩诃衍。三者诸法差别不增不减体大门。四者一味平等不增不减体大门。法界中藏论中唯释四法。所余法门略不别释。云何为四。一者如来藏功德相大摩诃衍。二者具足性功德相大摩诃衍。三者如来藏功德相大门。四者具足性功德相大门。秘密微妙论中唯释四法。所余法门略不别释。云何为四。一者能生一切世间因果用大摩诃衍。二者能生一切出世间善因果用大摩诃衍。三者世间因果用大门。四者出世间善因果用大门。众命合一论中唯释四法。所余法门略不别释。云何为四。一者无量无边诸法差别不增不减摩诃衍。二者寂静无杂一味平等不增不减摩诃衍。三者诸法差别不增不减门。四者一味平等不增不减门。真如三昧论中唯释四法。所余法门略不别释。云何为四。一者如来藏功德摩诃衍。二者具足性功德摩诃衍。三者如来藏功德门。四者具足性功德门。心性清净论中唯释四法。所余法门略不别释。云何为四。一者能生一切世间因果摩诃衍。二者能生一切出世间善因果摩诃衍。三者世间因果门。四者出世间善因果门。不动本原甚深玄理二种论中唯释一法。所余法门略不别释。云何为一所谓不二摩诃衍法。广说略说各差别故。何故诸论建立门中备标本数。散说门中各阙其数。为欲显示法体不分义门得别故。复次为欲令使学者增长思惟力故。复次为欲令使开示教理甚深极玄。出生尊重赞叹心故。复次为欲显示法门广大如虚空界。义理无穷如澄神海。言说不能具谈。思惟不知其量故

已说本数。次当别释

本曰。解释有三种。云何为三。一者显示正义。二者对治邪执。三者分别发趣道相

论曰。如是三门解释四法大门数量

本曰。显示正义者。依一心法有二种门。云何为二。一者心真如门。二者心生灭门。是二种门皆各总摄一切法。此义云何。以是二门不相离故

论曰。即是略说分。此中有三门。云何为三。一者建立四种法相门。二者法门该摄圆满门。三者发起问答显因门。依一心法有二种门。云何为二。一者心真如门。二者心生灭门者。即是建立四种法相门。二法二门名字差别。其数几有其相云何。颂曰

  各有十种名　　契经异说故
  而无有别体　　随能立名故

论曰。二法二门各有十名。诸契经中别别说故。而其法体无有差别。随彼功能立其名故。二种本法十名云何。颂曰

  毗摩诃健那　　摩诃鸠尸帝
  摩尸陀那罗　　摩迦罗俱舍
  必萨伊尼罗　　婆伽婆俱舍
  必达摩边那　　或名摩诃衍
  婆伽叉一婆　　必阿素摩利
  如是十种名　　通二种本法

论曰。二种本法各有十名。名通义别。云何为十。一者名为广大神王。此中有二。云何为二。一者鸠那耶神王。二者遮毗佉罗神王。第一神王住金刚山。一向出生吉祥神众。第二神王住大海中。遍通出生一切种种吉祥神众过患神众。二种本法广大神王亦复如是。一体本法。一向出生真如净法。三自本法。遍通出生一切种种清白品法染污品法故。自体契经中作如是说。文殊师利前白佛言。世尊甚深极妙二种大乘。不知不觉同异极疑众心。如宜世尊为众更说。佛造作相而告文殊言。善男子如是二法。譬如金刚神王及主海神王其相各差别。谓如金刚神王住金刚山现诸境界。唯现金光不现余光。真如一心金刚神王亦复如是。唯有净法无有余法故。又如金刚神王唯出生清净眷属。尝不出生杂乱眷属。真如一心亦复如是。唯出生无垢清净法故。复次譬如主海神王住大海中。出生种种粗恶眷属种种善妙眷属。生灭一心主海神王亦复如是。出生一切染净法故。二者名为大虚空王。此中有二。云何为二。一者空自在空王。二者色自在空王。第一空王以空容受而为自在。第二空王以色容受而为自在。二种本法亦复如是。一体空王以无住处而为自在。三自空王以有住处而为自在故。金刚三昧契经中作如是说。一心如法理自体空无。如彼空王本无住处。一地契经中作如是说。一心法体于诸障碍。无有障碍令住诸法。譬如空王于一切色。得自在故容受大种故。三者名为出生龙王。此中有二。云何为二。一者出生光明龙王。二者出生风水龙王。第一龙王以净光明而为依止。第二龙王以风水德而为依止。二种本法出生龙王亦复如是。一体本法以纯净法而为其体。三自本法以染净法而为其德故。顺理契经中作如是说。一心本法纯一无杂。譬如光明龙王以净光明而为宫殿。以净光明而为相身。以净光明而为徒众。无始契经中作如是说。譬如大海中有大龙王。名曰出生风水。从其头顶出生澄水。从其尾末出生标岚。由是龙王故大海水。风常恒相续无有断绝。一心龙王亦复如是。能生一切差别平等种种诸法。常恒相续无有断绝故。四者名为如意珠藏。此中有二。云何为二。一者金主如意。二者满主如意。第一如意唯出金刚。第二如意具足出生善不善物。二种本法亦复如是。一体如意唯生净法。三自如意通生染净法故。如如契经中作如是说。佛告金刚藏菩萨言。佛子譬如金翅鸟王命终。然后其心入海为如意珠。能生金沙利益龙王。一心本法亦复如是。能生真理利圆满者。故本性智契经中作如是说。譬如遮多利鬼。为报恩故于一万劫。为如意珠利益海生。一心如意亦复如是。能生长生死及涅盘法故。五者名为方寸。此中有二。云何为二。一者白毫方寸。二者乱色方寸。第一方寸中唯现前天像。第二方寸中通现前五趣。如是二毫众生身分。显了分明譬如明镜。二种本法亦复如是故。摄无量契经中作如是说。清净法界如白必萨伊尼罗。无尽法界如乱必萨伊尼罗故。六者名为如来藏。此中有二。云何为二。一者远转远缚如来藏。二者与行与相如来藏。实际契经中作如是说。佛子如来藏者。唯有觉者唯有如如。离流转因离虑知缚。一一白白。是故名为如来之藏。楞伽契经中作如是说。如来藏者。为善不善因受苦乐。与因俱若生若灭。犹如伎儿故。七者名为一法界。此中有二。云何为二。一者纯白一法界。二者无尽一法界。第一法界如空劫时。第二法界如住劫时。真法界契经中作如是说。空种无碍如空长时。遍种无碍如有长时故。八者名为摩诃衍义如前说。九者名为中实。此中有二。云何为二。一者等住中实。二者别住中实。第一中实如独明珠。第二中实如顺明珠。明中实契经中作如是说。离边真心。若真如依如异同珠。若生灭依如同异珠故。十者名为一心。此中有二。云何为二。一者是一是一一心。二者是一切是一切一心。第一一心随所作立名。第二一心随能作立名。一心法契经中作如是说。尔时舍利弗白佛言。世尊本地修多罗中作如是唱。其心体性非大非小。非法非非法。非同非异非一非一切。何因缘故。今日自言真如一心因一故一。生灭一心因多故一。将非世尊无有前后相违过耶。佛言善男子莫作如是说。所以者何。心法非一。因所作一故假名为一。心法非一切。因所作一切故假名为一切。而言一心不说一切心者。随能作心立其名故。乃至广说。是名为十。如是十名总摄诸佛一切法藏根本名字

已说二法十种别名。次说二门名字差别。真如十名其相云何。颂曰

  婆伽婆俱舍　　健遮阿多那
  必菩提婆梨　　健诃健婆那
  阿陀阿只尼　　阿伽阿始耶
  度罗诺补帝　　漠呼健那地
  摩诃标陀一　　婆阿叉尼罗
  如是十种名　　真如不共称

论曰。心真如门有十种名。云何为十。一者名为如来藏门。无杂乱故。二者名为不二平等门。无差别故。三者名为一道清净门。无异岐故。四者名为不起不动门。离作业故。五者名为无断无缚门。无治障故。六者名为无去无来门。无上下故。七者名为出世间门。无四相故。八者名为寂灭寂静门。无往向故。九者名为大总相门。无别相故。十者名为真如门。无虚伪故。是名为十。如是十名。总摄诸佛一切法藏平等义理法门名字。生灭十名其相云何。颂曰

  阿梨耶键摩　　婆伽婆俱舍
  阿伊婆那罗　　健诃健只尼
  健伽健始耶　　叉叉筏那罗
  罗诺补帝尼　　阇缚多涅盘
  呵只伽那尸　　多跋多健舍
  如是十种名　　生灭不共称

论曰。心生灭门有十种名。云何为十。一者名为藏识门。摄持一切染净法故。二者名为如来藏门。覆藏如来法身体故。三者名为起动门。相续作业故。四者名为有断有缚门。有治障故。五者名为有去有来门。有上下故。六者名为多相分异门。染净之法过恒沙故。七者名为世间门。四相俱转故。八者名为流转还灭门。具足生死及涅盘故。九者名为相待俱成门。无自成法故。十者名为生灭门。表无常相故。是名为十。如是十名。总摄诸佛一切法藏种种差别法门名字

已说二门十种别名。次说同异分相门。二种本法同异差别其相云何。颂曰

  有三异二同　　各依门境别
  各遍名同故　　同名异义故

论曰。二种本法有三异二同。云何为三异。一者依异。各有所依摩诃衍故。二者门异。各具能入门差别故。三者境异。各缘自依为境界故。是名为三异。云何为二同。一者遍同。周遍法界等其量故。二者名同。十种名字通二法故。是名为二同。何故如是。同名异义故。二种法门同异差别其相云何。颂曰

  有七异一同　　人法依行体
  境界位别故　　异名异义故

论曰。是二种门有七异一同。云何为七异。一者人众异。真如门中唯有清净解脱者故。生灭门中备有三聚诸众生故。二者法门异。真如门中唯有一向清白品故。生灭门中备有一切染净法故。三者所依异。各有所依摩诃衍故。四者行法异。真如门中一心一念生缚。不生以为其行故。生灭门中以生灭生以灭灭灭。以为其行故。五者体相异。心真如门与其本等故。心生灭门与其本别故。楞伽契经中作如是说。寂灭者名为一心。一心者名如来藏故。六者境界异。各缘自依为境界故。七者位地异。真如门中相杂住故。生灭门中往向住故。是名为七异。云何为一同。所谓遍同故。何故如是。异名异义故。二门位地何等契经分明显说。各有几位。颂曰

  楞伽等契经　　真如有一种
  生灭门有二　　唯乱上下故

论曰。二门位地楞伽等契经中明了显说谓大本楞伽契经中作如是说

  回向即信心　　信心即佛地
  佛地即十地　　十地即发心

分流楞伽契经中作如是说

  十地为初地　　初地为八地
  九地为七地　　七地为八地
  二地为三地　　四地为五地
  三地为六地　　寂灭有何次

真修契经中作如是说

  一岁母一时　　生五十岁儿
  彼五十岁儿　　怀妊一岁母
  生五十一岁　　大丈夫男子
  或岂如是有　　或岂如是无

如是等诸经依心。真如门建立其位地。于真如门唯有一向杂乱住位无有余位。是故颂曰唯乱。余契经中次第往向种种位地。依生灭门而所安立。应审观察。于生灭门有二种位。云何为二。一者向上门。二者向下门。如是两门生灭决择自当显说。心生灭门正智所证性真如理何门所摄。生灭门所摄。非真如门。分界别故。二门真如复有何别。真如门理理自理故。生灭门理智自理故。二门位地以何义故其理各别。无障有障故。举是一隅随应应观。已说建立四种法相门。是二种门皆各总摄。一切法者。即是法门该摄圆满门。谓以真如门摄一切法。无一一法而非真如。以生灭门摄一切法。无一一法而非生灭故。然真如门。不能摄生灭门一切诸法。又生灭门。不能摄真如门一切诸法。而言总摄一切法者。总摄生灭一切法故。总摄真如一切法故。所以者何。如是二门皆悉平等各各别故。已说法门该摄圆满门。此义云何。以是二门不相离故者。即是发起问答显因门。谓直表问故直说答故

已说略说分。次说广说分

本曰。心真如者。即是一法界大总相法门体。所谓心性不生不灭。一切诸法。唯依妄念而有差别。若离心念则无一切境界之相。是故一切法从本已来。离言说相离名字相。离心缘相毕竟平等。无有变异不可破坏。唯是一心故名真如以一切言说假名无实。但随妄念不可得故。言真如者亦无有相。谓言说之极。因言遣言。此真如体无有可遣。以一切法悉皆真故。亦无可立。以一切法皆同如故。当知一切法。不可说不可念故。名为真如。问曰。若如是义者。诸众生等云何随顺而能得入。答曰若知一切法。虽说无有能说可说。虽念亦无能念可念。是名随顺。若离说念名为得入。复次真如者。依言说分别有二种义。云何为二。一者如实空。以能究竟显实故。二者如实不空。以有自体具足无漏性功德故。所言空者从本已来。一切染法不相应故。谓离一切法差别之相。以无虚妄心念故。当知真如自性。非有相非无相。非非有相非非无相。非有无俱相。非一相非异相。非非一相。非非异相。非一异俱相。乃至总说。依一切众生以有妄心。念念分别皆不相应故说为空。若离妄心实无可空故。所言不空者。已显法体空无妄故。即是真心常恒不变净法满足。则名不空。亦无有相可取。以离念境界唯证相应故

论曰。即是广说分。此中有三门。云何为三。一者根本体性真如门。二者发起问答决疑门。三者假说开相真如门。第一门中即有三门。云何为三。一者建立名字门。二者直诠真体门。三者解释名字门。心真如者即是一法界大总相法门体者。即是建立名字门。谓随功能立其名故。一心真如各有十名。何故除余唯立是名。作业当故。所余众名必非如是故略不立。此义云何。一心作大业。法作总业。界作相业。故法之门。门则是体。是故说言法门体。种种别相率向应审。已说建立名字门。次说直诠真体门。所谓心性不生不灭者。直诠真如门而简生灭门。谓真如法非生非灭无生无灭。非住非异无住无异。非如生灭之法。是生是灭有生有灭。是住是异有住有异故。以相有无为差别故。复次非是言不。非谓是非故言不焉。所以者何。其真如法百非非非。千是非是。非非非是。于非二亦不住故。一切诸法唯依妄念而有差别者。且假彼有显此是无。谓假生灭门之假有。示真如门之实无故。若离心念则无一切境界之相者。若离诸戏论之识。无有一切妄境界故。是故一切法从本已来离言说相离名字相离心缘相者。直显示真如法离绝之相故。言说名字心量各有几数。其相云何。颂曰

  言说有五种　　名字有二种
  心量有十种　　契经异说故

论曰。言说有五。云何为五。一者相言说。二者梦言说。三者妄执言说。四者无始言说。五者如义言说。楞伽契经中作如是说。大慧。相言说者。所谓执着色等诸相而生。大慧。梦言说者。念本受用虚妄境界。依境界梦。觉已知依虚妄境界不实而生。大慧。执着言说者。念本所闻所作业而生。大慧。无始言说者。从无始来执着戏论。烦恼种子熏习而生。金刚三昧契经中作如是说。舍利弗言。一切万法皆悉言文。言文之相即非为义。如实之义不可言说。今者如来云何说法。佛言我说法者。以汝众生在生说故。说不可说。是故说之。我所说者义语非文。众生说者文语非义。非义语者皆悉空无。空无之言无言于义。不言义者皆是妄语。如义语者实空不空。空实不实。离于二相中间不中。不中之法离于三相。不见处所如如如说故。如是五中前四言说。虚妄说故不能谈真。后一言说。如实说故得谈真理。马鸣菩萨据前四故。作如是说。离言说相。名有二种。云何为二。一者字字名。二者字影名。楞伽契经中作如是说。大慧。复次名身者。所谓诸字从名字差别。从阿字乃至呵字名为名身。道品契经中作如是说。镜中共说名为影名故。字有二种。云何为二。一者依声字。二者依空字。楞伽契经中作如是说大慧。复次字身者。谓声长短音韵高下名为字身。大海契经中作如是说。佛告文殊师利言。汝所前问。云何名为虚空轮字者。譬如虚空中飞鸟。踰明耀时出十种和声。虚空轮字应如是观故。如是二中各初一种。不能诠表甚深真理。各后一种得诠真理故。今据前门作如是说。离名字相。心量有十。云何为十。一者眼识心。二者耳识心。三者鼻识心。四者舌识心。五者身识心。六者意识心。七者末那识心。八者阿梨耶识心。九者多一识心。十者一一识心。如是十中。初九种心不缘真理。后一种心得缘真理而为境界。今据前九作如是说。离心缘相。本有契经中作如是说。甚深真理非余境界。唯自所依缘为境界故。毕竟平等无有变异不可破坏者。显示三离之功德故谓一切差别以四种妄言说。而为根本而转。一切外道九种变论十种异执。唯以名字为本而转。一切烦恼破障一切所知坏障。唯以心品为依转故。而真体中离三相故满三德耳。唯是一心故名真如者。总结体真如。以一切言说假名无实但随妄念不可得故者。显示三离之因缘故。谓以一切言说无实。一切假名无实。一切心识但随妄念不可得故。不可言说真实理中。不离三相故。虚假之相。如实之法极相违故。言真如者亦无有相者。第二转言遣执着之过。谓愚众生作如是执。远离三相圆满三德体真如理。虽无假相而有实相。自然常住决定实有。由如是计堕于常边无出离时。是故为遣如是见故。言言真如者亦无有相。谓言说之极因言遣言者。直示真如无相之因缘。谓诸言说极于真如更莫超过。既绝言说。岂得有相无言。故得因言遣言而已。于是能遣如如如说。所遣四种虚妄言说。大本维摩诘契经中作如是说。尔时文殊师利菩萨摩诃萨。语鸠那阿筏陀多言。我等诸大众。皆悉各各随所自乐。宣说八千一种向不二门。如宜维摩诘为我等大众。离言说言说说非不二不二。除遣假说之垢。于是维摩诘默然无所说。尔时文殊赞维摩言。善哉善哉居士。如言说如如耳听如。善哉善哉斯乃真实不二法门。斯乃真实不二法体故。已说直诠真体门。次说解释名字门。此真如体无有可遣以一切法悉皆真故者。约真释名。亦无可立。以一切法皆同如故者。约如释名。此文明何义。所谓显示无有断证智故。此义云何。谓断道起必因治障。不能自起。而真体中。无有染法而可除遣故。无有能治之断道。所以者何。以无有一一法而非真体故。复次若有障智随心高下。应可建立一切位地。而如体中。无有分位而可建立故。无有能立之方便所以者何。以无有一一法而非如体故。当知一切法不可说不可念故名为真如者。总结所上说故

已说根本体性真如门。次说发起问答决疑门

问曰。若如是义者诸众生等云何随顺而能得入者。生疑致问。问者依何等句发何等疑。所谓依不可说不可念句故。发难随顺之疑。依第二转言句故。发难得入之疑。于是随顺之句直疑其因。得入之句直疑其果。所以者何。善巧言说生长闻慧随顺方便。闻所成慧生长思慧随顺方便。思所成慧生长修慧随顺方便。一切善教极于言说。一切三慧尽于念法。若无言说则无三慧。若无三慧则无万行。而真如法不可说故无有言教。不可念故则无三慧。无三慧故无以成就十地万行。诸众生等以何为依渐渐进修。如是疑故。作问而言云何随顺。行因能起果德所起。若无起因则无能入。若无能入不得所入。能入谓金刚心。所入谓金刚地而已。无因以何为门。证入于如来萨婆若海中。如是疑故。作问而言而能得入。如是二问依生灭门疑真如门。谓有众生作如是疑。如生灭门中断一切恶修一切善。备足因行圆满果德。真如门中亦复如是。岂不可说拨加行善。不可念诽五等位。今举此意发如是问。答曰若知一切法虽说无有能说可说虽念亦无能念可念是名随顺若离说念名为得入者。如其次第决彼二疑。所谓随顺自有二种。云何为二。一者生灭随顺。二者真如随顺。生灭随顺中而有其二种。云何为二。一者向上随顺。二者向下随顺。向上随顺者。从信乃至金刚。能为菩提果随顺方便故。向下随顺者。从自性净妙藏乃至第一念信。能为耶耶地随顺方便故。所言向上随顺者。因无常音声言说。生长无常之闻慧。因无常之闻慧。生长无常之思慧。因无常之思慧。生长无常之修慧。因无常之修慧。生长无常之行德。是名向上。所言向下随顺者。因常之行德。生长常之修慧。因常之修慧。生长常之思慧。因常之思慧。生长常之闻慧。因常之闻慧。生长常之言说。是名向下。如是二门同时具足无有前后。障智别相至于文处自当显说。真如门中作如是说。不可说者。以无有常无常之音声言说故。不可念者。以无有常无常之三慧故。非无自门之言说及念。作如是说不可说不可念。以此义故。不可以异门难异门。此有故彼有。彼有故此有。若尔真如门中言说及念何等相耶。谓有言说。非常音声非无常音声。谓无能说可说如如如说。复次有念。非常三慧非无常三慧。谓无能念可念寂灭寂静念。所以者何。真如门中无有往向。杂乱住故。云何名为真如随顺。谓若知一切法虽说。无有常说说无无常说说。无能说说无可说说。是名为随顺于真如音声。若与此相违。是名为颠倒于真如音声。复次若知一切法虽念。无常慧念无无常慧念。无能念念无可念念。是名为随顺于寂灭寂静念。若与此相违。是名为颠倒于寂灭寂静念。已说随顺相。次决得入疑。此中有二。云何为二。一者生灭得入。二者真如得入。生灭得入中而有其二种。云何为二。一者向上得入。二者向下得入。言向上得入者。即金刚地。言向下者。则耶耶地。须随顺句应审观察。真如得入者。则自所依。以何得入。谓是杂位。云何得入。谓离说念。离何等说念耶。谓真如门俱非言说及俱非念。是故说言若离说念名为得入。第一转言得成就故。第二转疑决断理明

已说发起问答决疑门。次说假说开相真如门。此中有二门。云何为二。一者如实空真如门。二者如实不空真如门。如实空者。如如体中。过于恒沙一切染法。皆悉空空无所有故。如实不空者。如如体中。过于恒沙一切净法。皆悉具足无所少故。如是二门随一一具不相舍离。于是应诵玄理颂言。如彼颂言

  远离三假相　　圆满三实德
  以此因缘故　　建立体真如
  远离四句相　　圆满四法德
  以此因缘故　　建立相真如
  一切过患行　　三四相为本
  一切功德品　　三四德为本
  以此因缘故　　不增亦不减
  止于数量品　　作如是安立

今诵此颂本应持真如门。以离念境界唯证相应故者。是乱住证非往向证

已说心真如门。次说心生灭门

本曰。心生灭者。依如来藏故有生灭心。所谓不生不灭与生灭和合。非一非异名为阿梨耶识。此识有二种义。能摄一切法能生一切法。云何为二。一者觉义。二者不觉义

论曰。此中有二门。云何为二。一者所依总相门。二者能依别相门。此中有二重。住思应观察。谓生灭门一心为依。生灭门摄觉义不觉义。梨耶为依故。先说初门。心生灭者者。唱上立故。依如来藏故者。所依一心。彼多一心亦名如来藏故。则是上心字下降建立异名故。有生灭心者。能依法门。谓生灭门故。今当依经如来藏门分明显示。如来之藏其数几有。今如来藏何所摄耶。颂曰

  如来藏有十　　契经异说故
  此中如来藏　　与行与相摄

论曰。如来藏有十种。于契经中别别说故。云何为十。一者大总持如来藏。尽摄一切如来藏故。诸佛无尽藏契经中作如是说。佛告文殊。有如来藏。名曰大宝无尽殊胜圆满陀罗尼。尽摄诸藏无所不通无所不当。圆满圆满平等平等。一切所有诸如来藏。无有以此非为根本。何以故此如来藏。如来藏王如来藏主。如来藏天如来藏地。以此义故。名曰大宝无尽殊胜圆满陀罗尼如来藏故。此经文明何义。所谓显示陀罗尼藏所依总相。余契经中诸如来藏能依别相故。以何义故名如来藏。谓摄持故。二者远转远缚如来藏。一清一满故。实际契经中作如是说。佛子如来藏者。唯有觉者唯有如如。离流转因离虑知缚一一白白。是故名为如来之藏故。此经文明何义。所谓显示真如门一心。无有惑因无有觉因。无有惑果无有觉果。一真一如唯有净妙如来体故。以何义故名如来藏。谓无杂故。三者与行与相如来藏。与流转力法身如来令覆藏故。楞伽契经中作如是说。如来藏者。为善不善因受苦乐。与因俱若生若灭。犹如伎儿故。此经文明何义。所谓显示生灭门一心。于惑与力于觉与力。出现生死涅槃之法。譬如非幻幻人于诸幻事。随其所应与力用故。以何义故名如来藏。谓令覆故。四者真如真如如来藏。唯有如故。真修契经中作如是说。如理如理如来藏。非建立非诽谤。非常非无常。非正体智之所证得。亦非意意识之所缘境界。何以故。唯有理理无彼彼故。此经文明何义。所谓显示真如门中性真如理。唯理自理非智自理故。以何义故名如来藏。谓无他故。五者生灭真如如来藏不生不灭被生灭之染故。楞伽契经中作如是说。大慧。愚痴凡夫不觉不知。执着诸法刹那不住。堕在邪见而作是言。无漏之法亦刹那不住。破彼真如如来藏故。复次大慧。金刚如来藏如来证法。非刹那不住。大慧。如来证法若刹那不住者。一切圣人不成圣人故。此经文明何义。所谓显示生灭门中性真如理。远离无常之相不生不灭之法故。以何义故名如来藏。谓被染故。六者空如来藏。一切诸空覆藏如来故。胜鬘契经中作如是说。世尊空如来藏。若离若脱若异一切烦恼藏故。此经文明何义。所谓显示生灭门中一切染法。隐覆自相本觉无量性功德故。以何义故一切染法总名为空。所谓一切染法幻化差别。体相无实作用非真故名为空。而能隐覆法身如来实德真体。是故名为如来之藏。从能藏染立其名故。七者不空如来藏。一切不空被空染故。胜鬘契经中作如是说。世尊不空如来藏。过恒沙不离不脱不异不思议佛法故。此经文明何义。所谓显示生灭门中自相本觉。备过恒沙一切功德。被过恒沙一切染法之所染故。以何义故一切净法总名不空。所谓一切净法自体中实作用胜妙。远离虚假超越巧伪。故名不空。被染之覆名如来藏。于出现时名为法身。于隐覆时名如来藏故。从所藏净立其名故。八者能摄如来藏。无明藏中自性净心。能摄一切诸功德故。不增不减契经中作如是说。如来藏本际相应体及清净法。此法如实不虚妄不离不脱智不思议法。无始本际来。有此清净相应法体故。此经文明何义。所谓显示一切诸众生自性清净心。从无始已来具足三智圆满四德无所阙失故。以何义故名如来藏。由颠倒心不知不觉故。从能所净立其名故。九者所摄如来藏。一切染法无明地藏。既乃出离圆满觉者为所摄故。不增不减契经中作如是说。如来藏本际不相应体。及烦恼缠不清净法。此本际离脱不相应。烦恼缠不清净法。唯有如来菩提智之所能断故。此经文明何义。所谓显示始觉满佛。断一切障具一切智。智明为外障闇为内。一切染法智所摄持故。以何义故名如来藏。谓摄持故。十者隐覆如来藏。法身如来烦恼所覆隐没藏故。不增不减契经中作如是说。如来藏未来际平等恒及有法。则是一切诸法根本。备一切法具一切法。于世法中不离不脱故。此经文明何义。所谓显示多一心体。等于法界遍于三际。具足圆满染净诸法。无所不通无所不至故。复次显示随缘门中自性净心。于染法中隐藏沉没。法身如来未出现故。是名为十。如是十中今如来藏。与行与相已说如来藏门。次说阿梨耶识门。所谓不生不灭与生灭和合非一非异名阿梨耶识者。略去分名建立满名。虽义具足言未足故。此中所说不生不灭及与生灭。各何等法分际云何。颂曰

  总摄诸无为　　名为不生灭
  总摄诸有为　　故名为生灭

论曰。总摄一切无为法故。是故名为不生不灭。不生不灭诸无为法之总相故。总摄一切有为法故。故名生灭。生灭之言诸有为法之总相故。如是有为无为二法各有几数。何等名字。颂曰

  无为虽无量　　略说有四种
  谓真如本觉　　始觉与虚空
  有为虽无量　　略说有五种
  谓根本无明　　及与四相品

论曰。无为法有四种。云何为四。一者真如无为。二者本觉无为。三者始觉无为。四者虚空无为。是名为四。有为法有五种。云何为五。一者根本无明有为。二者生相有为。三者住相有为。四者异相有为。五者灭相有为。是名为五。且四无为以何为体。有何等用。颂曰

  依各有二种　　所谓通及别
  如体用亦尔　　随释应观察

论曰。真如无为有二所依。云何为二。一者通所依。非有为非无为一心本法以为体故。二者别所依。生灭门内寂静理法以为体故。本觉无为有二所依。云何为二。一者通所依。非有为非无为一心本法以为体故。二者别所依。生灭门内自然本智以为体故。始觉无为有二所依。云何为二。一者通所依。非有为非无为一心本法以为体故。二者别所依。生灭门内随他起智以为体故。虚空无为有二所依。云何为二。一者通所依。非有为非无为一心本法以为体故。二者别所依。生灭门内无所有事以为体故。是名二依。复次真如无为有二种用。云何为二。一者通用。一切诸法令出生故。二者别用。平等之性令不失故。本觉无为有二种用。云何为二。一者通用。不守自性故。二者别用。不转变故。始觉无为有二种用。云何为二。一者通用。随妄转故。二者别用。对治自过故。虚空无为有二种用。云何为二。一者通用。欲有令有故二者别用。空无之性令不失故。是名二用。此中所说通谓他义别谓自义。依此二言应广观察。种种别相至于文处自当显说。五种有为以何为体。有何等用。颂曰

  依各有二种　　所谓通及别
  如体用亦尔　　随释应观察

论曰。根本无明有为有二种依。云何为二。一者通依。非有为非无为一心本法以为体故。二者别依。生灭门内大力住地以为体故。生相有为有二种依。云何为二。一者通依。非有为非无为一心本法以为体故。二者别依。生灭门内细分染法以为体故。住相有为有二种依。云何为二。一者通依非有为非无为一心本法以为体故。二者别依。生灭门内粗分染法以为体故。异相有为有二种依。云何为二。一者通依。非有为非无为一心本法以为体故。二者别依。生灭门内粗分染法以为体故。灭相有为有二种依。云何为二。一者通依。非有为非无为一心本法以为体故。二者别依。生灭门内粗分染法以为体故。是名二依。复次根本无明有二种用。云何为二。一者通用。能生一切诸染法故。二者别用。随所至处作碍事故。生相有为有二种用。云何为二。一者通用。于上下中与其力故。二者别用随所至处作碍事故。如说生相住异亦尔。灭相有为有二种用。云何为二。一者通用。于上及自与其力故。二者别用。能作碍事故。是名二用。种种别相至于文处自当显说。以何义故作如是说。有为无为一切诸法。通以一心而为其体。于契经中如是说故。何等契经。谓道智经。云何说耶。于彼经中作如是说。尔时文殊师利白佛言。世尊阿梨耶识。具一切法备一切法。过于恒沙过于恒沙。如是诸法以谁为本生于何处。佛言如是有为无为一切诸法。生处殊胜不可思议。何以故。于非有为非无为处。是有为法是无为法而能生故。文殊师利又白佛言。世尊云何名为非有为非无为处。佛言非有为非无为处者。所谓即是一心本法。非有为故能作有为。非无为故能作无为。是故我说生处殊胜不可思议。复次善男子。譬如庶子有二所依。一者大王。二者父母。有为无为一切诸法亦复如是。各有二依。谓通达依及支分依。复次善男子。譬如一切草木有二所依。一者大地。二者种子。有为无为。一切诸法亦复如是。各有二依。谓通达依及支分依。乃至广说故。与和合者。即是开示能熏所熏之差别故。云何开示。所谓显示染净诸法。有力无力互有胜劣故。今当作二门分明显说。云何为二。一者下转门。二者上转门。生灭门中不出此二。如是二门云何差别。颂曰

  诸染法有力　　诸净法无力
  背本下下转　　名为下转门
  诸净法有力　　诸染法无力
  向原上上转　　名为上转门

论曰。由染净诸法互有胜劣故。二种转门得成而已。今当先说初下转门根本无明以何等法而为所熏于何时中而作熏事。颂曰

  所熏有五种　　谓一法界心
  及四种无为　　非初非中后
  取初中后故　　如契经明说

论曰。根本无明以五种法而为所熏。谓一法界及四无为。熏一法界其相云何。颂曰

  一种法界心　　有二种自在
  谓有为无为　　是根本无明
  依于初自在　　而能作熏事

论曰。一法界心有二种自在。云何为二。一者有为自在。能为有为法而作依止故。二者无为自在。能为无为法而作依止故。根本无明依初自在能作熏事。非后自在。中实契经中作如是说。根本无明熏自所依分际之量。非他所依故熏真如法其相云何。颂曰

  真如无为法　　有二种作用
  所谓通及别　　如前决择说
  是根本无明　　依于初作用
  而能作熏事　　余无为亦尔

论曰。真如无为有二种用。谓通及别。如前所说。根本无明依初作用能作熏事。非后作用。如说真如余三无为亦复如是。皆依初用非后用故。作熏事时量。非初亦非中后。取初中后故。本智契经中作如是说。大力无明作熏事时。初及中后一时具取。而非别取故。此中所说能熏所熏以何义故名言为熏。谓能引彼法。而合自体不相舍离。俱行俱转故名能熏。又能彼法不作障碍。若随若顺不逆违故。名为所熏。谓五有为法。能熏四种无为法及一法界心。所熏五法随来。而与五能熏共会和合同事俱转。是故说言不生不灭与生灭和合。如大无明一心本法为通依故。依初自在作熏习事。四相有为应如是知。如大无明依四无为通达作用能作熏事。四相有为应如是知。如是等义至自决择其理分明。非一非异者。即是开示有为无为同异差别故。云何开示。所谓显示一法界心无为自在。四种无为别事作用。与一法界心有为自在。四种无为通达作用不同理故。名为非一。为欲显示受能熏染法一法界心有为自在四种无为通达作用。与能作熏事五种有为不异理故。名为非异。复次所熏净法与能熏染法。各差别故名为非一。能熏所熏俱一心作。无有他故名为非异。名为阿梨耶识者。总结圆满字

已说下转门。次说上转门。若欲成立此上转门。更应安置经本之辞。所谓楞伽王契经中作如是说。尔时世尊告大众言。诸佛子我念往昔。于出时中我来依他。于入时中他来依我故。此经文明何义。谓显示二转故。云何显示。谓于出时中我来依他者。即是下转。于入时中他来依我者。即是上转。此义云何。我谓则是真如本觉如来藏佛故。来谓受熏之义故。依他者背自本觉依无明他故。依此经文作解释故。是故说言不生不灭与生灭和合。则是下转门。若欲成立上转门者。可言生灭与不生不灭和合。以此义故玄理论中则存斯词。马鸣菩萨本阿世耶。比来次第分明显了。举一兼一影示而已。是故无有阙失过咎。上转门义于对治分其理自明。已说上转门。次说该摄安立门。诸识差别其数几有。何等契经中各说几种识。颂曰

  牟尼大觉尊　　一代圣说中
  总集有十种　　各异说契经
  谓一种为始　　十种而为终
  归本等契经　　分明显说故

论曰。凡集一代诸圣说中异说契经。总有十种。谓从一种识乃至十种识。云何为十种差别经。一者立一种识总摄诸识。此中有四。云何为四。一者立一切一心识总摄诸识。所谓以一心识遍于二种自在无所不安立故。一心法契经中作如是说。尔时文殊师利承佛威神之力。即白佛言。世尊说几种识。体相如何。当愿为我分别开示。尔时世尊告文殊言。善哉善哉文殊师利。为诸大众当问此事。谛听谛听善思念之。我当为汝分别解说。于是文殊白佛言。善哉世尊愿欲乐闻。佛告文殊言。我唯建立一种识。所余之识非建立焉。所以者何。一种识者多一一识。此识有种种力。能作一切种种名字。而唯一识终无余法。是故我说建立一种识。所余之识非建立焉故。二者立阿梨耶识总摄诸识。所谓以阿梨耶识。具足障碍义无障碍义无所不摄故。阿梨耶识契经中作如是说。尔时观自在菩萨即白佛言。世尊云何名为通达总相识。以何义故名为总相。佛告观自在菩萨言。所言通达总相识者。即是阿梨耶识。此识有碍事及非碍事。具一切法备一切法。譬如大海为水波等作总相名。以此义故名为总相故。三者立末那识总摄诸识。所谓以末那识具足十一种义无所不摄故。显了契经中作如是说。种种心识虽有无量。唯末那转无有余法。所以者何。是末那识具足十一义。无所不作故。四者立一意识总摄诸识。所谓以意识有七种转变自在。随能作其事故。七化契经中作如是说。譬如幻师唯是一人。以幻术力变化七人。愚人见之谓有七人。而智者见唯有一人无余七人。意识幻师亦复如是。唯是一识能作七事。凡夫见之谓有七事。而觉者见唯有意识无余七事故。是名建立同一种识四种契经。二者立二种识总摄诸识。云何为二。一者阿梨耶识。二者意识。阿梨耶识者。总举业转现三识故。意识者。总举七种转识故。楞伽契经中作如是说。大慧广说有八种识。略说有二种。何等为二。一者了别识。二者分别事识。乃至广说故。三者立三种识总摄诸识。云何为三。一者阿梨耶识。二者末那识。三者意识。阿梨耶识者。总举三相识故。末那识者。直意根故。意识者。总举六种转识故。慈云契经中作如是说。复次敬首广说有十种识。总说有三种识。何者为三。一者细相性识。二者根相性识。三者分离相性识。乃至广说故。四者立四种识总摄诸识。云何为四。谓前三中加一心识故。无相契经中作如是说。识法虽无量不出四种识。云何为四。一者所依本一识。二者能依持藏识。三者意持识。四者遍分别识。乃至广说故。五者立五种识总摄诸识。云何为五。谓前四中加随顺遍转识故。大无量契经中作如是说。复次有识。非彼彼识摄。遍于彼彼识。所谓随顺遍转识故。六者立六种识总摄诸识。云何为六。所谓眼等五种别识。及第六意识故。四圣谛契经中作如是说。佛告树王。我为小根诸众生故。以密意趣作如是唱。但有六识无有余识。而实本意。为欲令知六种识中具一切识。于大众中作如是唱故。七者立七种识总摄诸识。云何为七。谓前六中加末那识故。法门契经中作如是说。复次文殊师利识法有七种。云何为七。所谓六识身及末那识。如是七识或一时转或前后转。复次第七识有殊胜力故。或时造作持藏之用。或时造作分别之依故。八者立八种识总摄诸识。云何为八。谓前七中加阿梨耶识故。道智契经中作如是说。心王有八。云何为八。一者眼识心王。乃至八者异熟报识心王。种种识法不出此数故。九者立九种识总摄诸识。云何为九。谓前八中加唵摩罗识故。金刚三昧契经中作如是说。尔时无住菩萨而白佛言。尊者以何利转。而转众生一切情识入唵摩罗。佛言诸佛如来常以一觉。而转诸识入唵摩罗故。十者立十种识总摄诸识。云何为十。谓前九中加一切一心识故。法门契经中作如是说。心量虽无量而不出十识。乃至广说故。是名十种异说契经。如是十种于宝册中云何该摄。云何安立。颂曰

  于本论虽明　　今更作重释
  将契经散文　　属斯论总言

论曰。于本论中。虽分明说。而今为钝更作重释。将契经文属当论言。所谓一心法契经中。总所建立一切一心识。摩诃衍论一法界摄。义如前说。阿梨耶识契经中。总所建立阿梨耶识。摩诃衍论总阿梨耶摄。所以者何。于本论中作如是说。所谓不生不灭与生灭和合。非一非异名为阿梨耶识。此识有二种义。能摄一切法生一切法。云何为二。一者觉义。二者不觉义故。显了契经中。总所建立大末那识。摩诃衍论总末那摄。所以者何。于本论中作如是说。复次生灭因缘者。所谓众生依心意意识转故。此义云何。以依阿梨耶识。说有无明不觉而起。能见能现能取境界。起念相续故说为意。此意复有五种名。云何为五。一者名为业识。谓无明力不觉心动故。二者名为转识。依于动心能见相故。三者名为现识。所谓能现一切境界。犹如明镜现于色像。现识亦尔。随其五尘对至。即现无有前后。以一切时任运而起常在前故。四者名为智识。谓分别染净法故。五者名为相续识。以念相应不断故。乃至广说故。七化契经中总所建立同一意识。摩诃衍论一分意识摄。说相虽阙具密意故。于本论中作如是说。复次言意识者。即此相续识。依诸凡夫取着转深。计我我所种种妄执。随事攀缘分别六尘。名为意识。乃至广说故。如是如是彼彼诸经。随应当处应如如配。已说该摄安立门。次说藏识剖字门。阿梨耶识名字差别其数几有。契经异说其相云何。何等字义属何等处。颂曰

  有十阿梨耶　　契经异说故
  摩诃键怛摽　　键阿尸伽罗
  白白唵摩罗　　黑白唵摩罗
  羯罗罗键摩　　缚多提键摩
  奢呵那键摩　　婆阿叉尼罗
  白白迦萨罗　　黑白迦萨罗
  如是十种识　　摩诃衍论中
  分明显说故　　随应各配属

论曰。阿梨耶识总有十种。所以者何。于契经中别别说故。云何为十。一者名为大摄主阿梨耶识。所谓即是总相大识。义如前说。二者名为根本无明阿梨耶识。所谓根本无明别立。以为阿梨耶故。十种妄想契经中作如是说。刹奢只多提王识。直是妄法。不能了达一法界体。一切染法阿梨耶识以为根本。出生增长无断绝时。若无提王识。黑品眷属永无所依不能生长故。此阿梨耶识当何决择摄。于本论中作如是说。所言不觉义者。谓不如实知真如法一故。不觉心起而有其念。乃至广说故。三者名为清净本觉阿梨耶识。所谓自然本智别立。以为阿梨耶故。本觉契经中作如是说。自体净佛阿梨耶识。具足无漏圆满功德。常恒清净常恒决定。无受熏相无变异相。智体不动具足白品。是故名为独一净识故。此阿梨耶识当何决择摄。于本论中作如是说。复次觉体相者有四种大义。与虚空等犹如净镜。乃至广说故。四者名为染净本觉阿梨耶识。所谓不守自性陀罗尼智。别立以为阿梨耶故。本因缘起契经中作如是说。尔时光严童子即白佛言。尊者以何因缘故。难入未曾有会中作如是说。随他缘起陀罗尼智名。为楞伽王识。云何名为楞伽王。以之为喻示彼缘起陀罗尼智。于是尊者告光严童子言。此楞伽王常在大海摩罗山中。率十万六千鬼神之众以为眷属。如是诸眷属皆乘化宫殿游于诸刹。皆悉承赖彼楞伽王。方得游行。所谓诸鬼神众作如是言。我等神众无有威德无有气力。于诸所作无有其能。如宜大王。我等众中与堪能力。彼楞伽王即随其时与殊胜力。不相舍离而共转故。谓楞伽王虽非分身。而能遍满诸神众中。各各令得全身之量。于一切时于一切处共转不离。不守自性智亦复如是。能受一切无量无边烦恼染法鬼神众熏。不相舍离而俱转故。以此因缘故。我难入会中作如是说。随转觉智名为楞伽王识故。此阿梨耶识当何决择摄。于本论中作如是说。自性清净心。因无明风动。心与无明。俱无形相不相舍离。乃至广说故。五者名为业相业识阿梨耶识。所谓根本业相及与业识。别立以为阿梨耶故。本性智契经中作如是说。阿梨耶识无能了作无所了作。不可分析不可隔别。唯由精动隐流义故。名为键摩故。此阿梨耶识当何决择摄。于本论中作如是说。复次依不觉故生三种相。与彼不觉相应不离。云何为三。一者无明业相。以依不觉故。心动说名为业。觉则不动。动则有苦。果不离因故。六者名为转相转识阿梨耶识。所谓能见境界之相及与转识。别立以为阿梨耶故。大无量契经中作如是说。阿梨耶识有见见转无见见起故。此阿梨耶识当何决择摄。于本论中作如是说。二者能见相。以依动故能见。不动则无见故。七者名为现相现识阿梨耶识。所谓境界之相及与现识。别立以为阿梨耶故。实际契经中作如是说。别异别异现前地转。相异相异具足行转。是故名为阿梨耶识。复次此阿梨耶识。真是异熟无记之法。净白相故或名成就故。此阿梨耶识当何决择摄。于本论中作如是说。三者境界相。以依能见故。境界妄现。离见则无境界故。八者名为性真如理阿梨耶识。所谓正智所证清净真如。别立以为阿梨耶故。诸法同体契经中作如是说。有识是识非识识摄。所谓如如阿梨耶识故。此阿梨耶识当何决择摄。所谓清净般若质境真如摄故。九者名为清净始觉阿梨耶识。所谓本有清白始觉般若。别立以为阿梨耶故。果圆满契经中作如是说。佛告菩提树王言。自然始觉阿梨耶识。当常不离清净本觉。清净本觉当常不离始觉净识。随是彼有。随彼是有。或非同种或非异种故。此阿梨耶识当何决择摄。于本论中作如是说。本觉义者对始觉说。以始觉者即同本觉故。十者名为染净始觉阿梨耶识。所谓随缘始觉般若。别立以为阿梨耶故。果圆满契经中作如是说。复次树王。如始觉净识及白净本觉。说染净始觉阿梨耶识。不守自性缘起本觉。亦复如是故。此阿梨耶识当何决择摄。于本论中作如是说。始觉义者。依本觉故而有不觉。依不觉故说有始觉。又以觉心原故名究竟觉。不觉心原故非究竟觉。乃至广说故。如是等义至自决择自当备演。十种末那六种意识。于后文中随次释故。今略而已。已说藏识剖字门。分相门。次说总识摄生圆满门。此识有二种义。能摄一切法能生一切法。云何为二。一者觉义。二者不觉义者。而总显示本识殊胜圆满相故。此义云何。所谓具足二种圆满故。云何为二。一者功德圆满。二者过患圆满。功德圆满者。觉义字句。能摄一切无量无边过于恒沙不离不断诸功德故。能生一切无量无边过于恒沙不离不断。诸功德故。过患圆满者。不觉义字句。能摄一切无量无边过于恒沙若离若脱诸过患故。能生一切无量无边过于恒沙若离若脱诸过患故。如是种种摄生熏习差别之相。至彼别相决择分中。分明显示

释摩诃衍论卷第二释摩诃衍论卷第三

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

已说总识摄生圆满门。次说总相剖分散说门

本曰。所言觉义者。谓心体离念相。离念相者等虚空界。无所不遍法界一相。即是如来平等法身。依此法身说名本觉。何以故本觉义者对始觉说。以始觉者即同本觉。始觉义者。依本觉故而有不觉。依不觉故说有始觉。又以觉心原故名究竟觉。不觉心原故非究竟觉

论曰。于此文中即有二门。云何为二。一者略说本觉安立门。二者略说始觉安立门。本觉门中即有二门。云何为二。一者清净本觉门。二者染净本觉门。始觉门中又有二门。云何为二。一者清净始觉门。二者染净始觉门。云何名为清净本觉。本有法身从无始来。具足圆满过恒沙德常明净故。云何名为染净本觉。自性净心受无明熏。流转生死无断绝故。云何名为清净始觉。无漏性智出离一切无量无明。不受一切无明熏故。云何名为染净始觉。始觉般若受无明熏不能离故。如是诸觉皆智眷属。当证何理以为体分。谓性真如及虚空理。如是二理各有几种。各有二故。云何名为二种真如。一者清净真如。二者染净真如。虚空之理亦复如是。云何名为清净真如。二种净觉所证真如。离熏习故。云何名为染净真如。二种染净觉所证真如。不离熏故。虚空之理亦复如是。以何义故强名本觉。字事差别其相云何。颂曰

  本觉各有十　　体虽同字事
  各各差别故　　谓根镜等义

论曰。本觉各十。云何十本。一者根字事本。本有法身能善住持一切功德。譬如树根能善住持一切枝叶及花果等不坏失故。二者本字事本。本有法身从无始来。自然性有不始起故。三者远字事本。本有法身其有德时。重重久远无分界故。四者自字事本。本有法身我自成我。非他成我故。五者体字事本。本有法身为诸枝德作依止故。六者性字事本。本有法身不转之义。常建立故。七者住字事本。本有法身住于无住无去来故。八者常字事本。本有法身决定实际无流转故。九者坚字事本。本有法身远离风相。坚固不动若金刚故。十者总字事本。本有法身广大圆满。无所不遍为通体故。是名为十。云何十觉。一者镜字事觉。萨般若慧清净明白无尘累故。二者开字事觉。萨般若慧通达显了无障碍故。三者一字事觉。萨般若慧独尊独一无比量故。四者离字事觉。萨般若慧自性解脱。出离一切种种缚故。五者满字事觉。萨般若慧具足无量种种功德。无所少故。六者照字事觉。萨般若慧放大光明。遍照一切无量境故。七者察字事觉。萨般若慧常恒分明无迷乱故。八者显字事觉。萨般若慧清净体中净品眷属悉现前故。九者知字事觉。萨般若慧于一切法无不穷故。十者觉字事觉。萨般若慧所有功德唯有觉照。无一一法而非觉故。是名为十。如是十种本觉字义。唯依一种大性法身随义异释。据其自体无别而已。此中所说二本觉中当何本觉。谓清净本觉。非染净本觉。染净本觉字义差别其相云何。颂曰

  染净本觉中　　或各有十义
  前说十事中　　各有离性故

论曰。此本觉中或各有十义。所以者何。前十义中各有不守自性义故。字事配属依向应知。如是二觉同耶异耶。非同同故非异异故。以此义故或同或异。或非是同或非是异。是故皆是皆非而已。以何义故强名始觉。字事差别其相云何。颂曰

  从无始已来　　无有惑乱时
  今日始初觉　　故名为始觉

论曰。从无始来始觉般若。无有惑乱时。而无惑时今始初觉。故名始觉。如是始觉前惑后觉即非始觉。而无惑时理常今常初故。名为始觉。如是始觉二始觉中当何觉耶。谓清净始觉非染净始觉。染净始觉字事差别其相云何。颂曰

  清净始觉智　　不守自性故
  而能受染熏　　故名染净觉

论曰。清净始觉虽无惑时。而不守自性故。能受染熏随缘流转。以此义故。是故名为染净始觉。以何义故强名真如。字事差别其相云何。颂曰

  性真如理体　　平等平等一
  无有一多相　　故名为真如

论曰。性真如理平等平等。唯同一相。亦无一相亦无多相。无一相故远离同缘。无多相故远离异缘。以此义故名为真如。如是真如二种净智亲所内证。复次真如各有十义。云何为十真。一者根字事真。乃至第十总字事真。如是十真十种本义。相应俱有不相舍离。是故同名表示而已。云何十如。一者镜字事如。乃至第十觉字事如。如是十如十种觉义。相应俱有不相舍离。是故同名表示而已。所以者何。十种真理。本有法身有德方便。十种如理。萨般若慧有觉方便。以此义故更重言词作如是示。此中所说二真如中当何真如。谓清净真如。非染净真如。染净真如字事差别其相云何。颂曰

  清净真如理　　不守自性故
  而能受染熏　　名染净真如

论曰。清净真如从无始来。平等平等自性清净。不生不灭亦无去来亦无住所。而真如理性不守自性故随缘动转。是故名为染净真如。如是真如二染净智亲所内证。相应俱有不相舍离。如是等义。观前所说比类应知。以何义故强名虚空。字事差别其相云何。颂曰

  虚空有十义　　体虽同义事
  各各差别故　　谓无碍等义

论曰。性虚空理有十种义。云何为十。一者无障碍义。诸色法中无障碍故二者周遍义。无所不至故。三者平等义。无简择故。四者广大义。无分际故。五者无相义。绝色相故。六者清净义。无尘累故。七者不动义。无成坏故。八者有空义。灭有量故。九者空空义。离空着故。十者无得义。不能执故。是名为十。如是十事义用差别。若据其体无别而已。此虚空理二种净智亲所内证。相应俱有不相舍离。二虚空中当何虚空。谓清净虚空非染净虚空。染净虚空字事差别其相云何。颂曰

  清净虚空理　　不守自性故
  而能受染熏　　名染净虚空

论曰。清净虚空具足十德。亦无染相亦无净相。而虚空性不守自性故。能受染熏随缘流转。是故名为染净虚空。能熏所熏建立诽谤等种种门。至广说分其理具显。已说字事门。次说随释门。所言觉义者者。即是总句。从此自下皆是别句。总者通表一切觉故。别者各各差别说故。就别句中先说清净本觉清净始觉。次说染净本觉染净始觉。如其次第说相可见。谓心体离念相者。即是清净本觉。心谓即是自性清净心。体谓即是本有法身体。如是心体即名本觉。离念相者。即是显示清净之义。所谓远离大无明念故言离念。远离四种无常之相故言离相。过于恒沙烦恼眷属。此五有为以为根本。是故举本无。示眷属皆空。离念相者者。即唱清净本觉人辞者即人故。等虚空界无所不遍者。如是觉者善证具足十种德义虚空理故。法界一相者。如是觉者于所证之真如法界。而共和合。一味一相无差别故。即是如来平等法身者。善证二种胜妙之理清净觉者。即是法身如来自性自体故。依此法身说名本觉者。本有法身自性德中。而作归依。建立清净本觉称。故已说清净本觉。次说清净始觉。何以故者。即请问辞。谓欲建立清净始觉作如是请。问相云何。谓有众生作如是难。本有法身从本已来。具足无量性之功德。常恒明净常恒自在。依此义故名本觉者。如是本觉于何时中。何因缘故。具足一切无量功德名本觉耶。若作是说。此本觉者有大智力。能善断除一切过患。具足圆满诸功德者。即此本觉前惑后觉。非本觉明。即此功德断已前隐断已后显。非自性明。岂惑觉隐显。本有之义而得成立。若作是说常断更不断。常具足更不具足。是故应有本断本德者。此义亦不成立。无功德过故。谓一切障。从本断讫更不待断。一切功德。从本具足更不待具足觉者。即是始觉非彼本觉。是故般若波罗蜜中作如是说。若觉者是始觉。若不觉者即是无明。若离此二者即名为本觉。以何义故作如是说。本有法身自性德中。而作归依说名本觉。故言何以故。本觉义者对始觉说者。直决彼疑。谓马鸣师自通而言。清净本觉。从本已来不生不灭。非建立有非诽谤无。或非过患或非功德。言语道绝心行处灭。而有言说。具足圆满过于恒沙无量性德名本觉者。当知从无始来。而有清净始觉。发大智力发大定力。于一切时于一切处。常恒对治过于恒沙无量无边过患之海。具足圆满过于恒沙无量无边功德净品。对此清净始觉者故。立彼清净本觉之称。以始觉者即同本觉者。作其所由。谓以自然始觉与彼本觉同故。得对始觉示本觉故。如是二觉熏习差别其相云何。颂曰

  清净本始觉　　从无始已来
  远离一切染　　湛明若虚空
  是故此门中　　无能熏染法
  无所熏净法　　唯有自家德

论曰。如是二觉无有能熏所熏差别。唯有自家真实功德故。此门中不应建立能熏所熏。若如是者于此门中有何熏义。所谓有熏。染法净法不相待成。所谓即是具足转熏。此熏云何。谓白白故。三身本有契经中作如是说。本有本觉本有始觉。唯有德熏无患德熏。唯有满转无分转事故。已说清净始觉。次说离性二觉。始觉义者依本觉故而有不觉依不觉故说有始觉者。通示二种离性本始。谓依本觉故而有不觉者。即是离性本觉。依不觉故说有始觉者。即是离性始觉。此义云何。本觉般若不守自性故。善受染熏彼诸染法令得住止。即是本觉离性之义。始觉般若不守自性故。依诸染法如今方起被彼染诳。即是始觉离性之义。始觉般若能断诸障证诸功德。何故说言始觉之智被染诳耶。于无过法立诸过患。断除障。故于无德法立诸功德。证得理故。若尔始觉于何时中而得离妄。极解脱道时。方得究竟离。于彼时中到无念故。满分二事下当显示

已说略说两觉安立门。次说广说两觉决择门

本曰。此义云何。如凡夫人。觉知前念起恶。故能止后念令其不起。虽复名觉即是不觉故。如二乘观智初发意菩萨等。觉于念异念无异相。以舍粗分别执着相。故名相似觉。如法身菩萨等。觉于念住念无住相。以离分别粗念相。故名随分觉如菩萨地尽。满足方便一念相应。觉心初起心无初相。以远离微细念故。得见心性心即常住。名究竟觉。是故修多罗说。若有众生能观无念者。即为向佛地故。又心起者。无有初相可知。而言知初相者。即谓无念。是故一切众生不名为觉。以从本来念念相续未曾离念故。说无始无明。若得无念者。则知心相生住异灭。以无念等故。而实无有始觉之异。以四相俱时而有。皆无自立。本来平等同一觉故

论曰。即是广说始觉决择分。此文中有二门。云何为二。一者建立四相门。二者建立随觉门。四相门中即有四种。云何为四。一者粗重过患四相。二者微细过患四相。三者无常功德四相。四者常住功德四相。粗四相者即长时故。细四相者即短时故。无常相者。过患相违始起德故。常住相者。过患相违德常住有故。随觉门中即有二门。云何为二。一者满觉门。二者分觉门。满觉门者。明一觉故。分觉门者。具足显示觉不觉故。云何名为长时四相。从十信位乃至极解脱道时。方究竟离故。云何名为短时四相。因缘有法不过一刹那故。云何名为始起四相。起灭灭灭起异异异。起住德住起生德生。是故说言始起四相。翻过患故名为功德。今始起故名为无常。云何名为常住四相。今始起德本来有故。云何名为一种觉耶。觉与不觉无有二故。云何名为觉不觉。觉或受染熏。或不受故。如其次第说相可观。此中四相有二次第。云何为二。一者前后次第。二者俱有次第。前后者。彼无时中前后差别故。俱有者。彼有时中前后一时故。彼无时者。据断时故。彼有时者。据乱时故。俱有次第其相云何。颂曰

  生住异灭相　　如是四种相
  一时即前后　　非渐次转得
  一时故俱有　　前后故次第
  俱故成一相　　别故成四相

论曰。俱有次第四相者。一者生相。二者住相。三者异相。四者灭相。如是四相或是一时。或是前后。以何义故名为一时。由得同故。以何义故名为前后。粗细别故。非渐次转得者。别为显示一时义故。以何义故名为俱有。由一时故。以何义故名为次第。由前后故。如是四相俱有故一。粗细故四。此中一时当何时耶。根本无明熏真心时。于此时中具起四相。不知不觉一切诸法真实之性周遍。建立过于恒沙无量烦恼。而能隐覆自性净心还原无日。是故名为俱有四相。何故名生乃至名灭。字义差别其相云何。颂曰

  大无明住地　　熏本觉时中
  生三种细相　　故名为生相

论曰。根本无明熏本觉时生三种相。故名生相。云何为三。一者独力业相。二者独力随相。三者俱合动相。独力业相者。非取无明之体。取无明之业故。独力随相者。非取本觉之体。取本觉之用故。俱合动相者。取和合动相故。总举此三故名生相。生相之称立初生故。住相字义其相云何。颂曰

  住相有四种　　转相与现相
  智相及相续　　是名为四种

论曰。住相有四。云何为四。一者转相。二者现相。三者智相。四者相续相。是名为四。如是四相。以何义故说名为住。此中住义随应差别。所谓若据转相说其住相。而能住持心识熏习故名为住相。若据现相说其住相。而能住持色相熏习故名住相。若据智相说其住相。而能住持六种渐次分别智相应染故名为住相。若据相续相说其住相。而能住持分别事识连续染污。故名住相。即是细分非粗分故。异相字义其相云何。颂曰

  异相有二种　　执取计名字
  如是二种相　　直是人执品

论曰。异相有二。云何为二。一者执取相。二者计名字相。如是二相直人执品。如是二相以何义故名为异相。若据执取说其异相。能缘一切无量别相。随其诸相。粗分别识而能执着。异自成异故名异相。若据名字说其异相。随相立名。依其名字而起着。故名为异相。灭相字义其相云何。颂曰

  灭相有二种　　起业及果报
  破坏前异心　　令受苦名灭

论曰。灭相有二。云何为二。一者起业相。二者业系苦相。如是二相坏前异位令受苦轮。故名灭相。复次受苦轮时。能灭一切无量善品。故名灭相。复次发起业时。佛性善根渐渐损灭。故名灭相。已说俱有。次说前后。其相云何。颂曰

  灭异住生相　　如是四种相
  随智力劣胜　　有增减不同

论曰。前后次第者。一者灭相。二者异相。三者住相。四者生相。如是四相随智慧量增减不同。此义云何。以信位人阙一具三。三贤位人阙二具二。于十地中第九地中阙三具一。第十地中阙粗一分具细一分。如来地中四相都无究竟清净。是故说言增减不同

已说建立门。次说随释门。依彼四相明觉差别即有五位。云何为五。一者十信位。二者三贤位。三者九地位。四者因满位。五者果满位。前四位中各有四事。云何为四。一者趣向行者。二者修行因相。三者行因果相。四者熏离俱相。第五位中唯有三事。云何为三。一者能圆满者。二者对治行相。三者满究竟相。如其次第说相应观。第一位言如凡夫人者。即是趣向行者。位在十信。未得不退名为凡夫。已出邪定名为觉者。觉知前念起恶者。即是显示修行因相。谓未得入十信已前。二种灭相是大过患不知不觉。具造种种一切恶业。遍受一切无量苦果。常恒轮回五趣四生无休息时。而今以承知识妙缘圣说净则。而能得入十信位中。觉诸恶业是极过失。知诸苦果是实无乐故。言觉知前念起恶。即是显示觉灭相义。故能止后念令其不起者。即是显示行因果相。谓此位中始起治道。气力极弱故名为故。发心已去发起治道转自在故。复次前不觉知常起恶业。今觉知故有惭愧心不作恶业。灭相之秽止息不起。虽复名觉即是不觉故者。即是显示熏离俱相。所谓觉知灭相之法实是过患。彼灭相品不作灭事。故言熏离。彼灭相品。无始已来体性清净实是功德不知不觉。故言熏俱。此中字句远流应至于第十地。复次显示觉与不觉。互相即通是一味故。第二位言如二乘观智初发意菩萨等者。即是趣向行者。位在三贤。于此位中人空无漏。成就自在无所疑畏。故将二乘同于菩萨总明而已。复次显示一切二乘。皆悉修行菩萨之道。证入自在大觉地之海故。觉于念异者。即是显示修行因相。谓二种异相互相与力。而能执取境界之相。发起爱着寻求名字。分别言相故。是故无厌我我所转盛攀缘思虑更增终日无息。而今发起人空般若。建立方便法空现前。觉知本觉净心为无明眠。梦于异相起一切障。分分渐渐与远离智而共相应。从彼梦念得于觉悟。是故说言觉于念异。念无异相者。即是显示行因果相。谓始觉正念中。二种异相无所有故。以舍粗分别执着相者。即是显示无异相缘。所谓意识有二分别。而能分别一切诸法。云何为二。一者粗分别。二者细分别。粗者起贪嗔等。能善分别违顺境故。细者法执分别。恒流注故。今所远离彼粗分别。非细分别。细分别者极喜离故。故名相似觉者。即是结前。并粗显示熏离俱相。此中相似义即有二种。云何为二。一者异类相似。二者同类相似。异类相似者。二乘相似同类相似者。菩萨相似。二乘人空形三贤空作相似义。三贤菩萨方便法空。形净心地作相似义。是故总言相似觉焉。第三位言如法身菩萨等者。即是趣向行者。位在九地。九地菩萨真如法界以为自身。般若实智以为自心。垢累已出缚障悉断。清净明白无碍自在。是故名为法身菩萨。觉于念住者。即是显示修行因相。谓四种住相于一切时。而能发起法执分别。离性本觉能令睡眠。本觉之心梦于住相。不能觉晓狂乱而住。今发始觉般若之日。照迷乱住相之闇。始觉正智无分别性。迷乱住相有分别性。有无觉乱极相违故。不能俱行。如是道理分明现前。是故说言觉于念住。念无住相者。即是显示行因果相。以离分别粗念相者。即是显示无住相缘。谓四种住相形于彼生相极粗现故。恐生住际互相杂乱。作如是说止思应观。如是四种迷乱住相。如其次第。于极喜地过三有地寂灭净地善慧地中。各离一相。故名随分觉者。即是结前。并粗显示熏离俱相。生相细念未出离故。第四位言如菩萨地尽者。即是趣向行者。此字句中自有二人。云何为二。一者因圆满者。二者果圆满者。因圆满者。学地尽故。果圆满者。无学之果满究竟故初人对治俱合动相。后人对治独力业相及大无明。独力随相非断法故。无对治道。自此已下显示二种圆满者焉。满足方便一念相应者。即是显示因圆满者。谓此位中即有二种金刚喻定。云何为二。一者方便金刚。二者正体金刚无垢行者二种金刚喻三摩提以为自体。是故举道而标彼人。觉心初起心无初相者。即是显示果圆满者。大圆镜智分明现前。无所不通无所不穷。法界一体无有与等。独力业相根本无明不能自有。平等虚空一相无相。无初念故。以远离微细念故得见心性心即常住名究竟觉者。即是显示始觉般若圆满之相。而得到于无生觉故。是故修多罗说若有众生能观无念者即为向佛地故者。即是引经赞自所说。如是经文为证何义。证佛果故。云何证耶。谓佛果中证成远离二种念故。云何为二。一者大无明念。二者细业相念。如是二念极解脱道一时相翻不能俱行。是故说言佛果无念。若无妄念当有何念。谓正念故。云何名正念。十德相应故。云何为十。一者出离功德。远离一切诸难处故。二者同体功德。一切染法归于自故。三者常住功德。远离始有之过失故。四者一味功德。圆满始觉常本觉故。五者俱离功德。远离一切染净法故。六者还转功德。周遍诞生于诸趣故。七者无住功德。于一切处无在处故。八者修行功德。为诸众生修万行故。九者圆满功德。为诸众生成觉道故。十者虚空功德。如前所说种种功德。从本已来自性皆空无所有故。是名为十。如是十德与极解脱初刹那中。俱行俱起无有前后。一时俱转是名正念。所引经文不出此义。应审观察。又心起者无有初相可知而言知初相者即谓无念者。即是除疑令生胜解。谓有众生作如是疑。极解脱道会本觉时微细初生。知得有耶知得无耶。若知有者。极解脱道当非无念。所以者何。知有初念有初念故。若知无者。极解脱道当不能有。所以者何。既无初念。待何念无立解脱道有。如是疑故。今自通言。所知之相从本已来自性空无。能知之智从本已来无有起时。既无所觉之相。亦无能觉之智。岂可得言有细初相智慧可知。而有言说知初相者。即是显示无念道理。所以者何。法性之理。虽无所知之初起相。亦无能知之始觉智。而能通达无所知相无能知智。无所有觉都非空无。是故今且衣此道理。作如是说知初相耳。是故一切众生不名为觉以从本来念念相续未曾离念故说无始无明者。即是成立上无念义。谓金刚已还一切众生。独力业相大无明念未出离故。即是显示一切众生皆是有念名为众生。一切诸佛皆得无念名为佛故。自此已下显示始觉境界周遍圆满。谓大觉者已到彼岸。遍知一切无量众生。一心流转作四相故。如本。若得无念者即知心相生住异灭故。以何义故如是知耶。得自无念时。一切诸众生平等得故。如本以无念等故故。以何义故。唯一行者得无念时。一切众生悉得无念。一一众生皆悉各各有本觉故。此义云何。谓一行者始觉圆满同本觉时。遍同一切无量众生本觉心中。非自本觉。所以者何。自性本觉遍众生界。无所不至故。清净觉者得无念时。一切众生皆得无念者。清净觉者断无明时。一切众生亦可断耶。若尔何过。若始觉者断无明时。一切众生皆得断者。何故上言金刚已还一切众生。独力业相大无明念。未出离故不名为觉。若诸众生无始无明未得出离。而与诸佛同得无念者。无念等义。唯有言说无有实义。岂可得言一切众生皆有本觉亦有始觉。决断此难即有二门。云何为二。一者自宗决断。二者望别决断。自宗决断者。此论正宗。为欲显示一切众生。同一相续无差别故。是故可得一修行者无始无明究竟断时。一切众生亦同断尽。一修行者满始觉时。一切众生亦同得满。是故三身本有契经中作如是说。尔时世尊告文殊师利言。我由二等而成正觉。云何为二。一者断等。二者得等。言断等者。我极解脱道初发起时。一切众生所有无量无始无明。一时究竟顿决断故。言得等者。我初成道满始觉时。一切众生皆满足故。是名二等故。望别决断者。举圆满者望众生界。无一一法而非清净。举诸众生望无上尊。入无明藏无所觉知。皆悉清净无所障碍。无念等义而得成立。入无明藏无所觉知。上所说文无相违过。举此一隅应广观察。自此已下融诸始觉令同本觉谓五十一分满始觉。实无转胜渐次之异。亦无究竟圆满之极。所以者何。一切始觉四相俱时。而得住止皆无自立。从本已来一味平等自性圆满。契同无二一相觉故。如本而实无有始觉之异以四相俱时而有皆无自立本来平等同一觉故故。大总持契经中作如是说。悟灭相品始觉般若。有灭相位中而共俱时有。无灭时中始觉随无。悟异相品始觉般若。有异相位中而共俱时有。无异时中始觉随无。悟住相品始觉般若。有住相位中而共俱时有。无住时中始觉随无。悟生相品始觉般若。有生相位中而共俱时有。无生时中始觉随无。所以者何。一切始觉不能自起。当待染法方得而起。一切染法不能自灭。当待智力方得灭尽。广说乃至从本已来。一切染法自体空无。而始觉者本无处中作有之解。俱时而转不名正故

已说广说始觉决择分。次说广说本觉决择分

本曰。复次本觉随染分别生二种相。与彼本觉不相舍离。云何为二。一者智净相。二者不思议业相。智净相者。谓依法力熏习如实修行满足方便故。破和合识相灭相续心相。显现法身智淳净故。此义云何。以一切心识之相皆是无明。无明之相不离觉性。非可坏非不可坏。如大海水因风波动。水相风相不相舍离。而水非动性。若风止灭动相即灭湿性不坏。如是众生自性清净心。因无明风动。心与无明俱无形相不相舍离。而心非动性。若无明灭相续则灭。智性不坏故。不思议业相者。以依智净。能作一切胜妙境界。所谓无量功德之相常无断绝。随众生根自然相应。种种而现得利益故

论曰。即是广说随染本觉决择分。于此文中即有二门。云何为二。一者本有性智清净门。二者业用自在无碍门。第一门中即有二门。云何为二。一者不守自性随缘门。二者对治一切业障门。第二门中复有二门。云何为二。一者随顺机根契当门。二者不动本性常寂门。如是四门随释应配。本觉随染者即是简句。简异清净本觉智故。此句为欲显示何义。谓为显示受熏义故。直唱本觉受无明熏不守自性。随缘无碍俱时转故。是故名为本觉随染。即此字句从所随染立名而已。自此已下直显能随本觉体相。分别生二种相与彼本觉不相舍离云何为二。一者智净相。二者不思议业相者如是二种殊胜之相。与彼随染本觉性智。俱行俱转不相舍离故。如是本觉智净行相其相云何。颂曰

  破灭一切障　　显现法性身
  实智清净故　　名为智净相

论曰。断一切恶修一切善。具足功德圆满智慧。庄严法身名智净相。断一切障当须何力。须满足力。满足力者其数几有。有二种故。云何为二。一者法力熏习满足方便力。二者如实修行满足方便力。如是二种方便之力。从无始来自然常住不始而起。如是二中。依法力熏习满足方便力故。破根本无明及独力业相。依如实修行满足方便力故。灭俱合业相能见相及与现相分别智相并相续相。破根本无明独力业相故。自性身体分明现前。灭俱合相等相续故。般若实智淳净明白。如本智净相者谓依法力熏习如实修行满足方便故。破和合识相灭相续心相显现法身智淳净故故。何故三贤及十信位略不显示。比来次第分明显故。何故今此门中。最初对治根本无明。乃至最后对治灭相。为欲简异始觉般若悟次第故。何故始觉背凡向圣。上上去去为次第转。随染本觉背圣向凡。下下来来为次第转。以法尔故。如是二转当一时耶当前后耶。决定一时即无前后。如是等义何契经中明了显说。谓证说经。彼契经中如何说耶。谓彼证说契经中作如是说。尔时陀罗尼菩萨发十千问问于如来。于是如来即作十万决疑难答开菩萨问。如其次第答彼问已即告陀罗尼菩萨言。何故仁者。一事不问须问余事。加宜佛子更问开发。为自他利问于如来。尔时陀罗尼菩萨。即承佛威神而白佛言。世尊何因缘故。于大众中唱如是言

  谛听诸佛子　　我从具缚凡
  具经一切地　　圆满行因海
  庄严大觉果　　我从清净地
  具经一切地　　将一切万行
  得第一信位　　入无明藏海
  如是二大事　　一时非前后

我及一切诸大众海。皆悉怀疑无解脱时。如宜世尊为诸佛子。种种方便随宜开示。尔时世尊告总持言。谛听谛听善思念之。我当为汝略说其要。善男子此二大事显示二种般若觉智。云何为二。一者始觉般若。二者本觉般若。善男子始觉般若者。从具缚地渐渐出离。乃至金刚圆满因行发究竟道。顿断根本无明住地。觉日圆照无所不遍。是故名为始觉般若。善男子本觉般若者。从清净性渐渐远离。乃至信初发究竟智。断灭相品入无明海随缘动转。是故名为本觉般若。于是总持及诸大众闻此语已。觉知诸法一相一体。亦无一相亦无一体。亦空无言空无言亦空。而诸法性亦是实相亦是常住。亦是决定亦是实有故。自此已下别释散说显示因缘。此义云何者即是总问。以一切心识之相皆是无明者。即是总答。所谓种种诸戏论识。发起种种诸攀缘量。虑知一切无量境界。或着一切境界之相不舍离者。皆是无明之气分故。即是成立上中所说破灭二义。自此已下显示断非断之差别。此中无明当定可断耶。当不可断耶。此何所疑。若可断者。本觉之心亦当可断。何以故。无明染法本觉性智。俱行俱转不相舍离。譬如眠士夫及与悟士夫。俱行俱转不相离故。亦不可言斩眠士时悟士不伤。相续一故。亦不可说得悟士时眠士空无。相续同故。若言异者。过失太故。若不可断者。自性清净心常为无明覆。轮转五道无出离时。是故若言不可断者。过失亦太。如是无明亦可断除。亦不断除。此义云何。无明本觉有二义故。云何为二。一者同体同相义。二者异体异相义。言同义者。一切诸法皆是理故。言异义者。一切诸法功德过患各差别故。若据初门不可断除。若据后门亦可断除。诸法无行契经中作如是说

  贪欲是涅槃　　恚痴亦如是
  如是三事中　　有无量佛道
  见非见一相　　着不着亦然
  此无佛无法　　知此名世智

本智契经中作如是说

  根本无明闇　　其力最大故
  能障一切智　　令得不自住
  断须般若剑　　饰须功德宝
  无明海渐竭　　法身山徐显

如本。无明之相不离觉性非可坏非不可坏故。自此已下显示喻说。大海者喻阿梨耶识。此识有二种义。广大圆满如大海故。水者喻本觉心。自性清净心显了明白。如净水故。风者喻根本无明。根本不觉能起动转虑知之识。如彼风故。波动者喻诸戏论识。如是诸识迁动流转。往来无常如海波故。水相风相不相舍离者。喻真妄相资俱行合转。谓本觉心不自起故。当资无明之力方得而起。根本无明不自转故。要因真心之力。方得而转如水不自作波浪故。当因风之力方得作波。风不自现动相故。要资彼水方得而现动转相故。而水非动性者。喻本觉心离有为相。谓本觉真心从本已来。远离动念解脱结缚。体性清净相用自在。而不守自性故。随无明之缘作种种相。如水非动性而不守自性故。随风之缘作种种波故。若风止灭动相则灭者。喻根本无明灭戏论诸识皆灭无余。本觉断障先对治根本无明。后对治虑知攀缘之诸识故。湿性不坏者。喻本觉之智离断灭法故。谓无明灭诸识皆尽。本觉真心无有坏灭。如彼风灭诸波皆息而清白水终不坏灭故。自此已下显示合说。如其次第应配属焉。大海风水从谁而生。谓从龙王生故。各从何处而生。所谓若水从其头顶而出。若风从其尾末而出。何故海水为风所动。作种种波不断绝耶。谓由二事故。云何为二。一者有同类大种故。二者由法尔故。此义云何。彼水大中亦有风大。彼风大中亦有水大。互相有故。而共和合作种种波。常恒相续不断绝焉。若水大中无彼风大。风当不能令水动。若风大中无彼水大。水当不能随风转。何以故。以四大种俱生俱转不相离故。而随一大分明现知不了余大者。增相减相而不同故。复次从无始来由法尔故。无明本觉亦复如是。大龙王者。喻一心法。风者喻无明住地。从尾未出者。显示此法下劣形相。水者喻本觉真心。从头顶出者。显示此法胜妙形相。彼水大中亦有风大者。喻自性清净本觉心中有根本无明。彼风大中亦有水大者。喻根本无明藏中有本觉佛性。此论本意异相为初同相为后。随释应观。诸佛无尽藏契经中作如是说。烦恼大海中有圆满如来。宣说实相常住之理。本觉实性中有无明众生。起无量无边烦恼之波。如是大事佛菩萨境界。非凡夫二乘之所能知故。已说本有性智清净门。次说业用自在无碍门。谓此门中。本有性智以为所依。起应化用。为一切修行者。显示种种胜妙色相。为眼根作境界。出现种种胜妙音声。为耳根作境界。发起种种胜妙芬香。为鼻根作境界。出现种种胜妙法味。为舌根作境界。发起种种胜妙三昧触。为身根作境界。出现种种甚深法藏。为意根作境界。如其次第。光明日月宝德如来。音声梵响清净如来。香积芬流圆满如来。一味无杂平等如来。觉触分明显相如来。智慧明达遍满如来。具足成就随时随处随机根量。教化利益无碍自在。不动一念遍三世中。不分一身满十方中而能作佛事故。如本不思议业相者以依智净能作一切胜妙境界所谓无量功德之相常无断绝随众生根自然相应种种而现得利益故故

已说广说随染本觉门。次说广说性净本觉门

本曰。复次觉体相者。有四种大义。与虚空等犹如净镜。云何为四。一者如实空镜。远离一切心境界相无法可现。非觉照义故。二者因熏习镜。谓如实不空。一切世间境界悉于中现。不出不入不失不坏常住一心。以一切法即真实性故。又一切染法所不能染。智体不动具足无漏熏众生故。三者法出离镜。谓不空法出烦恼碍智碍。离和合相淳净明故。四者缘熏习镜。谓依法出离故。遍照众生之心令修善根。随念示现故

论曰。即是广说性净本觉分。此四种大义中各有二义。与彼大义不相舍离。云何为二。一者等空义。二者同镜义。如本复次觉体相者有四种大义与虚空等犹如净镜故。云何名为如实空镜。及有二义其相云何。颂曰

  性净本觉中　　远离虑知如
  远离妄境实　　示远离义空
  镜摩奢趺娑　　举一示一故

论曰。性净本觉之体性中。远离一切攀缘虑知诸戏论识。成就一味平等之义故名为如。远离一切虚妄境界种种相分。成就决定真实之相故名为实。为欲显示远离之义故名为空。镜谓喻名。然此中镜即喻摩奢趺娑珠镜。非余种种油摩等镜以为譬喻。何以故。取此摩奢趺娑珠镜安置一处。珠镜前中或蕴种种石。或蕴种种饮食。或蕴种种庄严具。或蕴同类珠镜。彼珠镜中余像不现。唯同类珠分明显了故。如实空镜亦复如是。于此镜中唯同自类清净功德安立集成。种种异类诸过患法皆远离故。如本云何为四。一者如实空镜。远离一切心境界相无法可现故。何故各有二种义。而唯示同镜义等。空之义不显示耶。以举一义兼示一义故。若如是者。云何名为等空之义耶。谓如虚空清净无染四障所不能覆。广大无边三世所不能摄。如实空镜亦复如是故。非觉照义故者。即是显示远离因缘。谓如彼摩奢趺娑珠镜中。石等诸像不现前者。石等诸法皆鄙秽故。此本觉珠镜中。种种妄法不现前者。一切染法皆悉是无明不觉之相。无照达义故。云何名为因熏习镜。及有二义其相云何。颂曰

  性净本觉智　　三种世间法
  皆悉不舍离　　为一觉熏习
  庄严法身果　　故名因熏习
  镜轮多梨花　　空容受遍一

论曰。性净本觉三世间中皆悉不离。熏习彼三而为一觉。庄严一大法身之果。是故名为因熏习镜。云何名为三种世间。一者众生世间。二者器世间。三者智正觉世间。众生世间者。谓异生性界。器世间者。谓所依止土。智正觉世间者。谓佛菩萨。是名为三。此中镜者。谓轮多梨花镜。如取轮多梨花。安置一处周集诸物。由此花熏一切诸物皆悉明净。又明净物华中现前皆悉无余。一切诸物中彼华现前亦复无余因熏习镜亦复如是。熏一切法为清净觉令平等故。复次虚空义者。即有二种。云何为二。一者容受义。二者遍一义。容受义者。容受诸色无障碍故。遍一义者。种种诸色唯同一种大虚空故。如本二者因熏习镜谓如实不空一切世间境界悉于中现故。如是本觉从无始来远离四种过。自性清净常住一心。云何为四。一者远离不遍之过。三种世间不出本觉清净镜故。如本不出故。二者远离杂乱之过。一切诸法不入本觉清净镜故。如本不入故。三者远离过患之过本觉镜中现前诸法。无不本觉净功德故。如本不失故。四者远离无常之过。本觉镜中现前诸法。无不常住无为智故。如本不坏故。远离边过圆满中实。是故说言常住一心。自此已下显示因缘。何因缘故本觉智中种种诸法。如彼本觉离诸过耶。种种诸法皆悉无不真实体故。如本以一切法即真实性故故。自此已下作缘决疑。谓有众生作如是疑。三世间中众生世间无明染法具足圆满。流转迁动无休息时。如是世间现本觉者。不可得言本觉清净远离诸过。以此义故今通而言。又一切染法所不能染。般若实智其体不动。自性清净具足无漏。常恒熏习众生世间令清净故。如本又一切染法所不能染智体不动具足无漏熏众生故故。云何名为法出离镜。及有二义其相云何。颂曰

  如实不空法　　出离三过失
  圆满三种德　　故名法出离
  镜消练颇梨　　空出离色义

论曰。无漏性德。出离三过圆满三德。名法出离。云何名为三种过失。一者无明染品。名烦恼碍。二者根本无明。名为智碍。三者俱合转相。名戏论识。是名为三。如是三过究竟离故。名为出离。如本三者法出离镜谓不空法出烦恼碍智碍离和合相故。云何名为三种功德。一者淳成就功德。二者净成就功德。三者明成就功德。是名为三。如本淳净明故故。出离何过圆满何德。谓出离烦恼碍圆满净成就功德。出离智碍圆满明成就功德。出离和合转相圆满淳成就功德。何以故相对法尔故。此中镜者谓颇梨珠。譬如颇梨珠沦深泥中。即便涌现出离彼泥。外腾一丈量。若置浊水中驱浑成尘累。唯止清水安住其中。若置福多伽林中。出现香气碍彼秽香。远去而住。法出离镜亦复尔故。此中喻诠者。喻自体净义。住思应观。等空义者。出离色义。谓如虚空远离大种一向清净。法出离镜亦复尔故。云何名为缘熏习镜。及有二义其相云何。颂曰

  于无量无边　　诸众生缘中
  出无量无边　　殊胜应化身
  熏习众生心　　出生诸善根
  增长两轮花　　庄严法身果
  故名缘熏习　　镜碧中颇梨
  空随顺成义　　如法应观察

论曰。譬如取颇梨珠安置一处。周匝积集种种色珠。彼颇梨珠随向珠色现前转变。缘熏习镜亦复尔故。又譬如虚空有自在力故。于一切所作之事中随顺成立。缘熏习镜亦复如是。于一切众生修行之事中。随应建立故。如本四者缘熏习镜谓依法出离故遍照众生之心令修善根随念示现故故。如是四种本觉大义。遍一切众生界一切二乘界。一切菩萨界一切如来界中。无不住处无不照处。无不通处无不至处。具足圆满具足圆满

释摩诃衍论卷第三释摩诃衍论卷第四

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

已说广说性净本觉门。次说根本无明住地门

本曰。所言不觉义者。谓不如实知真如法一故。不觉心起而有其念。念无自相不离本觉。犹如迷人依方故迷。若离于方则无有迷。众生亦尔。依觉故迷。若离觉性则无不觉。以有不觉妄想心故。能知名义为说真觉。若离不觉之心。则无真觉自相可说

论曰。则此文中自有二门。云何为二。一者异说相应契当门。二者随次别释散说门。初门云何。颂曰

  牟尼大觉尊　　一代圣说中
  总有六种说　　谓明闇俱非
  空及与具足　　如是六无明
  随义立异名　　克体无差别

论曰。凡集牟尼尊一代中种种异说。总有六种。云何为六。一者明无明。二者闇无明。三者俱是无明。四者俱非无明。五者空无明。六者具足无明。是名为六。如是六种随义立名。据体无别。明无明者。字义差别其相云何。颂曰

  究竟无余无　　通达显了明
  以此因缘故　　言总意别明

论曰。究竟无余故名为无。通达显了故名为明。所谓圆满船若之日周遍法界。无一一法而非明故。是故当知如是无明言总意别光明实智契经中作如是说。尔时舍利弗则白佛言。世尊何因缘故。于大众中唱如是言。我今所说一切契经中。一一字字一一句句。尽摄一切无量所诠。而为钝根之众生故。以种种言说而谈论耳。若如世尊说。当应有过失。何以故。如无明字唯表黑品。不能表示般若智明。乃至无常字唯表生灭之相。不能诠表无为当住真实理焉。如何世尊作如是说。于是世尊告舍利弗言。我今所说实无过失。何以故。如无明字。不可得言唯表黑品。汝智慧之力狭劣小见小闻故。作如是疑。而此无明字尽摄一切般若智明。具足圆满无所阙失。所谓究竟义故。周遍义故圆满义故。平等义故。无余义故。说言为无。通达义故。显了义故。观照义故。现前义故。无碍义故。说言为明。乃至广说故。闇无明者。字义差别其相云何。颂曰

  一切般若明　　隐覆令不生
  譬如闇中具　　无有殊胜事

论曰。根本无明。能覆一切总持慧明碍令不生。譬如暗中庄严具虽有胜妙相。而为闇障故。彼殊胜事不得出现。是故名为暗之无明。圆满契经中作如是说。一切众生具足三智。由颠倒故不知不觉故。俱是无明者。字义差别其相云何。颂曰

  唯一种无明　　或明或暗俱
  譬如一暗色　　二人各异见

论曰。一种无明或明或闇。譬如一色二人异见。此义云何。谓如迦罗鸠奢那。及人同分极闇夜分中。同在一处见此暗色。若迦罗鸠奢那唯见清净光明之色。若人同分唯见一向黑暗之色。俱是无明亦复如是。唯一无明。或智慧明或黑法暗具二事故。甚深密严契经中作如是说。根本无明于幻人中能作幻质。于德人中能作德质。不可取一非一故。俱非无明者。字义差别其相云何。颂曰

  从无始已来　　无有言说依
  远离了别转　　远离远离故

论曰。言俱非者无言依故。离心转故。是故名为俱非无明。八胜天子契经中作如是说。尔时光明自在华宝妙轮天子。即承佛神力白佛言。世尊无明有耶。答曰非也。问曰无耶。答曰。非也。问曰亦有亦无耶。答曰非也问曰非有非无耶。答曰非也。问曰非是耶。答曰非也。问曰何故如是耶。答曰以无可明之事故。是故说言无始无明故。空无明者。字义差别其相云何。颂曰

  无体用则空　　譬如兔角无
  如是道理了　　是故说言明

论曰。空无明者。体用俱空。故名为无。如是道理明了现前。故名为明。譬如兔角本来无体。一切人众皆悉现知。无始契经中作如是说。根本无明无所有事。遍计所执性故。具足无明者。字义差别其相云何。颂曰

  染净一切法　　通出生增长
  以此因缘故　　建立具足名

论曰。言具足者。根本无明能生一切染净诸法。令增长故立具足名。佛性解脱契经中作如是说。从无明种出觉知树从觉知树出功德智慧华。从两轮华结法身解脱果。乃至广说故。如是六种根本无明。于论文中明了说故。安立配属且略而已。且暗无明名字差别其相云何。契经异说其数几有。颂曰

  总有十种名　　契经异说故
  见一处住地　　或报恩无尽
  或无始有终　　或无等等生
  或生得观满　　智碍及不觉
  觉了与子藏　　如是十种名
  随义用差别　　唯一暗无明

论曰。凡集一代种种契经总有十种。云何为十。一者见一处住地。二者报恩无尽住地。三者无始有终住地。四者无等等生住地。五者生得住地。六者观满住地。七者智碍住地。八者不觉住地。九者觉了住地。十者子藏住地是名为十。如是十名唯是一体。随义用别。应审观察。见一处住地者。字义差别其相云何。颂曰

  圆满般若慧　　现见一法界
  无明体顿断　　故名见一处

论曰。金刚心还智慧未满福德微少。不达一心中实处故。根本无明犹未出离。而率万行到果位时。始觉般若分明显了。本有功德具足圆满。现见一中法界之心安立住处。根本无明顿断无余。是故名为见一处惑。光严童子契经中作如是说。复次有惑。一切声闻辟支佛。及十地菩萨所不能断。谓见一处无明住地。如是住地证一法界。清净觉者乃所能断故。报恩无尽住地者。字义差别其相云何。颂曰

  无量一切佛　　报无明之恩
  尽未来无穷　　故名恩无尽

论曰。十方三世一切诸佛报无明恩。尽未来际无有穷尽。所以者何。一切觉者以无明作无为因。具足庄严法身果故。本来清净契经中作如是说。文殊师利则白佛言。世尊无量劫中不惜身命。断一切恶修一切善。圆满行因庄严性海。喜乐自在德用无碍。何因缘故作如是言。我有多恩尽未来际不能尽报。佛言我由无明。以之为质成正觉道。是故我说有极重恩。于尘劫中报恩不尽。以此义故。无明住地亦名报恩无尽住地故。无始有终住地者。字义差别其相云何。颂曰

  却过去无际　　进未来有尽
  以此因缘故　　名无始有终

论曰。根本无明若却过去无其本际。名为无始。若进未来必有间断。名为有终。般若波罗蜜中作如是说。始觉净智有始无终。无明住地无始有终。故无等等生住地者。字义差别其相云何。颂曰

  过恒上烦恼　　无前后一时
  具足出生故　　名无等等生

论曰。根本无明有胜力故。过于恒沙诸上烦恼。无有前后一时俱生。是故名为无等等生。自体契经中作如是说。譬如天魔波旬于大自在天。色力寿命眷属众具自在殊胜。无等等出生大力住地。亦复如是。粗细前后无有前后。一时生长故。生得住地者。字义差别其相云何。颂曰

  生谓三种生　　得谓立成就
  无明彼成立　　故名为生得

论曰。所言生者。所谓即是三种生相。所言得者。即有二义。云何为二。一者建立义。二者成就义。根本无明能善成立彼三种相。是故名为生得住地。十种妄想契经中作如是说。据子子转生得住地。非据自体名为生得故。观满住地者。字义差别其相云何。颂曰

  根本无明体　　金刚还不尽
  当待果满位　　故名为观满

论曰。根本无明金刚心还犹存不尽。当待满位永断无余。是故名为观满住地。无上菩提契经中作如是说。根本无明待究竟道。名为观满。诸戏论识随位渐除。名为观分故。智碍住地者。字义差别其相云何。颂曰

  碍一切种智　　逆世间通达
  相违过极重　　故名为智碍

论曰。根本无明漠冥极暗。一切种智显了极明。如是明暗相违过失。极重深故。是故名为智碍住地。甚深因缘契经中作如是说。染烦恼碍与正体智。相违过极建立为障。般若慧碍与后得智。相违过重建立为障。乃至广说故。不觉住地者。字义差别其相云何。颂曰

  从无始已来　　备三身菩提
  圆四德涅盘　　不能觉不觉

论曰。一切众生从无始来。具足三身圆满四德。自性清净远离系缚。而由无明不知不觉。是故名为不觉住地。大本楞伽契经中作如是说。般若无知。诸戏论识即是知无。根本无明即是不觉。所以者何不觉觉故。乃至广说故。觉了住地者。字义差别其相云何。颂曰

  十地非境界　　凡小亦非境
  唯大觉者了　　故名为觉了

论曰。根本无明十地菩萨未能尽知。何况凡小能善知之。唯大觉者穷了无余。是故名为觉了住地。宝积契经中作如是说。唯佛境界非余能知。觉了无明故。子藏住地者。字义差别其相云何。颂曰

  无明藏大海　　摄持上烦恼
  譬如种持子　　故名为子藏

论曰。无始无明摄持烦恼令得住止。譬如诸种持隐显子。是故名为子藏住地。本业契经中作如是说。子子种藏譬如天网故。何因缘故皆名住地。字义差别其相云何。颂曰

  无明力大故　　住持诸染法
  如地持四担　　故名为住地

论曰。根本无明其力最大。能善住持一切染法。譬如大地有胜力故持四重担。故名为住地。云何为四。一者大海。二者诸山。三者草木。四者众生。是名为四。胜鬘契经中作如是说。世尊如是无明住地力。于有爱数四住地。无明住地其力最大。乃至广说故

已说异说相应契当门。次说随次别释散说门。所言不觉义者者。总标本末一切不觉。自此已下作释略示。于是初释根本不觉。次释分离眷属不觉。本广末略。应审观察。谓不如实知真如法一故不觉心起者。即是显示根本不觉之起因缘。根本不觉何因缘故得起而有。因不如故得起而有。何等法中而不如耶。谓三法中而不如故。言不如者。当有何义。谓违逆义故。云何三法。一者实知一法。二者真如一法。三者一心一法。是名为三。实知一法者。谓一切觉即能达智。真如一法者。谓平等理即所达境。一心一法者。谓一法界即所依体。于此三法皆违逆故无明得起。是故说言谓不如实知真如法一故不觉心起。彼三种法皆守一中终不舍离。故通名为一。自此已下眷属略示。而有其念者。即是显示分离无明。谓本已立一切眷属皆得有故。自此已下即有二门。云何为二。一者归德成幻力无力门。二者攀妄显真力无力门。归德成幻门者。一切无明。若克其本无自体相。依止本觉而得成立。譬如迷道路人依道路故迷。若离道路无迷乱事故。如本念无自相不离本觉。犹如迷人依方故迷若离于方即无有迷。众生亦尔依觉故迷。若离觉性即无不觉故。攀妄显真门者。法身般若不能自显。当待不觉然后方乃赞扬名义具足现前。譬如勇猛丈夫伏诸军众。然后方乃得高胜位故。如本以有不觉妄想心故。能知名义为说真觉。若离不觉之心则无真觉自相可说故

已说根本无明住地门。次说眷属无明住地门。此决择中自有二重。云何为二。一者显示微细眷属门。二者显示粗重眷属门。初门云何

本曰。复次依不觉故生三种相。与彼不觉相应不离。云何为三。一者无明业相。以依不觉故心动说名为业。觉则不动动则有苦。果不离因故。二者能见相。以依动故能见。不动则无见。三者境界相。以依能见故境界妄现。离见则无境界

论曰。就此文中即有二重。云何为二。一者总标略示门。二者标释俱成门。第一门言依不觉故生三种相与彼不觉相应不离者。即是显示末相承赖本体之气力故而得成立。复彼本体为受末相之枝养故而得止住。譬如父子互相为因得成立故。是故说言相应不离。若如是说。八地已上诸菩萨等。应断无明同妙觉耶。是事不尔。虽断粗相。微细三相犹未断故。自此已下释第二门。此三相中第一业相。能见所见无有差别。心王念法不可分析。唯由精动隐流之义故名为业。如是动流只由不觉。若觉不动动即有苦。所以者何。业相之初果不离无明之初因故。如本一者无明业相以依不觉故心动说名为业觉则不动动则有苦果不离因故故。第二转相。以业相念为所依故。转作能缘流成了相。若无业相动念之分位。当无了别转相之见分。依此动作彼转名为转相。如本二者能见相以依动故能见不动即无见故。第三现相以了别转为所依故。戏论境界具足现前。所缘相分圆满安布。若离了别见识之分位。即无所缘境界之尘相。依此见分现彼相分。譬如依明镜故现诸色像名为现相。如本三者境界相以依能见故境界妄现离见则无境界故。如是三相虽名字别是示本识。前决择中已广说故。此中三相初能及所同体无别。中唯能见则无所见。后能与所具足圆满。根本无明复有何别。此何所疑。无明自体不明了故。所谓若言心体无动。就此时故名无明者。此事即不然。所以者何。三者分言以依不觉故心动说名为业故。若言动是业识分位非无明者。此事亦不尔。所以者何。校量分言以不达一法界故心不相应忽然念起名为无明故。动起二文皆就业识作如是说。非彼无明。所以者何。能动能起根本无明。随动随起即是业识。以此义故无相违过。若尔根本无明自体。如何能动心体能起诸念。此处难了。十地非境三贤不量。唯佛穷了不可妄说。然依经说假言强称但曰不觉。得有因缘次决择中自当显说。业相细念能所未分。相及境界不可分别。何因缘故立动名字释业相耶此事亦复不可妄说。唯依经说作如是言。业相本识。无能了作无所了作。不可分析不可隔别。唯由精动隐流义故。名为键摩而已。若有众生须种种辞绮语此处。咄哉终日不堪了说

已说显示微细眷属门。次说显示粗重眷属门

本曰。以有境界缘故复生六种相。云何为六。一者智相。依于境界心起分别爱与不爱故。二者相续相。依于智故生其苦乐觉。心起念相应不断故。三者执取相。依于相续缘念境界。住持苦乐心起着故。四者计名字相。依于妄执分别假名言相故。五者起业相。依于名字寻名取着造种种业故。六者业系苦相。以依业受果不自在故

论曰。如是六相皆意识地非余识法。所以者何。大本经中如是说故。此决择分当释何经。谓楞伽经。彼契经中当何说耶。谓分流楞伽契经中作如是说

  譬如巨海浪　　斯由猛风起
  洪波鼓溟壑　　无有断绝时
  藏识海常住　　境界风所动
  种种诸识浪　　腾跃而转生
  青赤种种色　　珂乳及石蜜
  淡味众华果　　日月与光明
  非异非不异　　海水起波浪
  七识亦如是　　心俱和合生
  譬如海水变　　种种波浪转
  七识亦如是　　心俱和合生
  谓彼藏识处　　种种诸识转
  谓以彼意识　　思惟诸相义
  不坏相有八　　无相亦无相

依此经文作解释故。起六相文。今此经文为明何义。谓欲显示现识之海性自常住。为彼六尘境界之风所飘动故。七种转识现识之体以为内因。六尘境界以为外缘。兴盛六种粗重相故。如经

  譬如巨海浪　　斯由猛风起
  洪波鼓溟壑　　无有断绝时
  藏识海常住　　境界风所动
  种种诸识浪　　腾跃而转生

云何名为境界之风。其风形状当如何耶。谓青黄等种种显色。能起眼识。宝珂等珠出现种种胜妙音声。能起耳识。檀乳等香熏布种种芬芬香气。能起鼻识。木罗石蜜等诸安触着和合种种诸善美乐具。能起身识。甘淡等味。随其所应出种种味。能起舌识。现在之华未来之果种种法尘。随为彼识所缘境界。能起意识。今此文中举尘取识。应审观察。彼末那识。即是意识微细分位无别体耳。如是六尘能动心体令使散乱。譬如猛风故名为风。如经

  青赤种种色　　珂乳及石蜜
  淡味众华果

如是七识及与藏识。同耶异耶。非同非异。离二边故。譬如日与光明水与波浪非同非异。七识藏识非同非异义亦如是。如经

  日月与光明　　非异非不异
  海水起波浪　　七识亦如是
  心俱和合生

如是七识从何处所来入藏识作七种数。流转起动无断绝时。如是七转识。不从内来不从外来不从中来。唯藏识体变作七识。譬如海水变作波浪。如经

  譬如海水变　　种种波浪转
  七识亦如是　　心俱和合生
  谓彼藏识处　　种种诸识转
  谓以彼意识　　思惟诸相义

如是现识及七转识八种心识。唯有生灭无常相耶。亦有实相常住相耶。如是八识从无始来。三际不动四相不迁。真实常住自性清净不坏之相。具足圆满无所阙失。而如是等一切功德。同法界故无有二相。无二相故唯是一相。唯一相故亦是无相。皆以无相故无相亦无相。如经

不坏相有八无相亦无相

此楞伽经凡明几识。即有二门。云何为二。一者略说门。二者广说门。如是二门中三本各异说。云何异说。谓一本分流楞伽契经中作如是说。大慧略说有三种识。广说有八种相。何等为三。谓真识现识分别事识。又一本分流楞伽契经中作如是说。大慧广说有八种识。略说有二种识。何等为二。一者了别识。二者分别事识。又一本分流楞伽契经中作如是说。大慧略说有四种识。广说有七种识。云何为四。谓业识转识现识分别事识。如是三经直是真说。当应归依。何等楞伽。因缘楞伽沙罗楞伽。盘尸多楞伽等此四种经。即是伪假说故不可归依。今当依彼十万六千嗢拖南颂大本楞伽。三经异相安立会释。如其次第应审观察。初契经中第一真识。直是根本无明所熏本觉真心。第二现识。直是现相阿梨耶识。第三分别事识。直是意识。粗分意识。细分即末那故。何故此经意识细分末那陀识。三细之中业识转识。且略不示。即有二门。云何为二。一者举两显三备数门。二者率上达下备数门。初门云何。谓举粗强显细劣故。此义云何。于三细中粗是现识。于七识中强是意识。举粗现识显细业转。唯言现识。举强意识示劣末那。唯言意识。是故言略而义圆耳。是名举两显三备数门。后门云何。谓浑前后满名字故。此义云何。经上文言诸识有三种相谓转相业相真相。第一转相。即是三细所摄转识。第二业相。即是三细所摄业识。第三真相。即是意识细分所摄之末那识。率此经文及于下文。圆满名字义理具足。是名率上达下备数门。此契经中八种识者。阿梨耶末那意识及五识身。是名为八。何故成八。一意识中分七种故。中契经中第一了别识。直是现相阿梨耶识。第二分别事识。直是意识。义如前说。同说末那。彼初经中名言真相。此中经中智相识者。异名同义。末那位中始有慧数。分别于尘名智相识。如是智识所缘境中。作真实之相解。而转故名真相。此中八识比前可知。后契经中四种识法。文相明故且略不说。言七识者。末那意识总为一故。粗细虽别唯一识故。法界法轮契经中作如是说。第六意识分别六尘境界时中。必依末那为所依根方得生起。是故意识当是能依。彼末那识当是所依。能依所依。不能一种。何故今说一体无别。经意别故无相违过。谓彼经中立别种故。今此经中立同种故。以何文故。分明现知分别事识。不依末那而得生起。楞伽经中明了说故。彼契经中云何说耶。谓分流楞伽中作如是说。大慧了别事识分别事识。彼二种识无有差别迭共为因。又一本分流楞伽中作如是说。大慧现识及分别事识。此二坏不坏相展转为因。由此文故明知意识。唯以现相阿梨耶识为内所依。生起动转不依末那。复次大本楞伽契经中作如是说。尔时妙严菩萨则白佛言。粗相意识细相意识。以何为因以何为缘。相续而转。佛言如是粗细意识。以现镜识而为其因。以六尘境而为其缘。相续而转故。以此义故。第七末那缘六尘境。为所缘转义已成立。何以故。经伽他中作如是说。境界风所动七识波浪转故。复次若有众生。经现识者即是末那。是故意识以之为因。咄哉此言不可指南

已说经本。次释论文。即此文中自有二门。云何为二。一者总标略示门。二者标释俱成门。以有境界缘故复生六种相者。即是初门。此文为明何义。谓为显示彼一意识六种粗相。现镜识中六尘境界以为起缘。现镜识体以为依因。得长相续具足转故。若尔何故。唯言以境界为缘。不说以彼本识为因。义相显故且略而已。其理非无。若尔现识即应末那。为彼意识亲所依故。犹如意根。解释此义即有二意。云何为二。一者遮意。二者许意。遮者遮别种故。许者许阿梨耶末那故。如是疑难至大末那决择分中其理自显。自此已下释第二门。此六相中。第一二相即是法执。第二二相即是人执。第三二相即是业因果报别相。复次初二地上所断。中二三贤所断。后二十信所离。复次初二则是细相。后有四相则是粗相。复次初一则是细相。后有五种即是粗相。复次初五则是细相。后一粗相。复次六相皆是粗相。复次六相皆无细相亦无粗相。如其次第应审思惟

已说显示粗重眷属门。次说显示无明有决疑门

本曰。当知无明能生一切染法。以一切染法皆是不觉相故

论曰。即此文中自有二门。云何为二。一者直示得有门。二者释相决疑门。初门云何。颂曰

  譬如见树木　　当知有种子
  见诸上烦恼　　知无明亦尔

论曰。譬如有人见林树等决定当知有其种子。见诸烦恼知无明有义亦如是。如本当知无明能生一切染法故。后门云何。谓有众生作如是疑。无明唯一染法无量。岂一无明生诸烦恼。起不信心。若决彼疑应作是言。譬如种子唯一出生无量无边华果枝叶等一切类。根本无明亦复如是。唯一无明能生一切无量无边烦恼染法。以何得知一切烦恼皆无明生者。由彼诸染法皆不觉相故。若须是言彼疑便决。如本以一切染法皆是不觉相故。从上已来本上无明略释已焉。自此已下总蕴一切染净诸法。更作同异之二种门。表示造论真实本意。其相云何

本曰。复次觉与不觉有二种相。云何为二。一者同相。二者异相。言同相者。譬如种种瓦器皆同微尘性相。如是无漏无明种种业幻。皆同真如性相。是故修多罗中依于此义说。一切众生本来常住。入于涅盘菩提之法。非可修相。非可作相。毕竟无得。亦无色相可见。而有见色相者。唯是随染业幻所作。非是智色不空之性。以智相无可见故。言异相者。譬如种种瓦器各各不同。如是无漏无明随染幻差别性染幻差别故

论曰。即此文中故有二门。云何为二。一者同相门。二者异相门。为明何义故建立同相门。为欲显示一切诸法。唯一真如无余法故。当真如门。为明何义故。建立异相门。为欲显示唯一真如作一切法。名相各别。义用不同故。当生灭门。如是二门依何契经所建立耶。谓文殊师利答第一经。彼契经中当何说耶。谓彼契经中作如是说。佛问文殊。汝久远来恒无休息。普遍游行十方刹中见何殊事。文殊答曰。我久远来不见余事。唯见微尘。又佛问言。汝百年中居于轮家。不见种种瓦器相耶。文殊对曰。我唯见尘不见瓦器。又佛问言。汝实不见地水火风山川林树等种种相耶。文殊对曰。我实不见如是等相。唯见微尘。如是如是世尊问诘文殊答曰。至一百数佛问文殊见微尘耶。文殊对曰。我久远来不见微尘。尔时世尊告文殊言。善哉善哉汝是大士。能觉一相。能觉一相即无相法。文殊师利。汝一仁者非如是觉。依一相门。一切众生本来常住。入于涅盘菩提之法。乃至以智相无可见故。马鸣菩萨依彼经文立同相门。文相明故不须重释。异相门者。彼契经中作如是说。佛告身子。汝见此土作何心见。身子答曰。我见此土。山川林树沙砾土石日月宫殿舍宅等种种相各各形相名字差别不同。佛言汝智慧力下劣狭少。心有高下见如是异。唯汝一人非如是见。一切众生亦复如是。乃至诸法亦复如是。真妄互熏染净相待。功德过患形相名字各各差别。随凡夫心所立名相。有而不实皆幻化法。乃至广说。依此文故。寻义之述立异相门。文相明故不须重释。此二门中所存初门。应审思惟。从上已来释本分中是心生灭字句已焉。自此已下直释因缘

本曰。复次生灭因缘者。所谓众生依心意意识转故。此义云何。以依阿梨耶识说。有无明不觉而起。能见能现能取境界起念相续。故说为意。此意复有五种名。云何为五。一者名为业识。谓无明力不觉心动故。二者名为转识。谓依于动心能见相故。三者名为现识。所谓能现一切境界。犹如明镜现于色像。现识亦尔。随其五尘对至即现无有前后。以一切时任运而起常在前故。四者名为智识。谓分别染净法故。五者名为相续识。以念相应不断故

论曰。即此文中自有二门。云何为二。一者摄义显宗生解门。二者随文散说决疑门。初门云何。此中因缘有其二重。云何为二。一者不相应生灭因缘。二者相应生灭因缘。初重因缘其相云何。颂曰

  彼根本无明　　是随缘本觉
  各因缘具足　　为三不相应
  正作因缘故　　细生灭因缘
  更作意观察　　应审其义理

论曰。根本无明随缘本觉。各各因缘二义具足。能为三种不相应染。正作因缘。是故说言微细生灭之因缘门。具足形相散说门中其理自明。次重因缘其相云何。颂曰

  现镜识自体　　六尘境界相
  为三种相应　　能作因缘故

论曰。现镜识体六尘境界。如其次第。为彼三种相应染法能作因缘。是故说言粗重生灭之因缘门。现识体中又有缘义。应审思惟。复次更有二重因缘。云何为二。一者本遍因缘。二者末遍因缘。言本遍者。举根本无明及本觉心。望于六粗相。有因缘义故。言末遍者举业转相望于三相应。有因缘义故。复次更有二重因缘。云何为二。一者上下因缘。二者下上因缘。言上下者。无明为始果报为终。下下与力不越其数。作因缘故。言下上者。果报为始无明为终。上上与力不越其数。作因缘故。复次一切有为生灭之法刹那不住。无因无缘故。复次因缘之法空而无主。其实自性不可得故。复次不可得法。不可得亦不可得故。如其次第应审思择

已说摄义显宗生解门。次说随文散说决疑门。此中有二门。云何为二。一者总标门。二者广释门。复次生灭因缘者所谓众生依心意意识转故者。即是初门。此文为明何义。谓欲显示所依能依之差别故。云何所依。谓本觉心。云何能依。谓即众生。言众生者。当何法耶。谓意意识。何故意及意识名为众生。意及意识一切众染合集而生。故名众生。而无别自体。唯依心为体。是故说言依心而转

已说总标门。次说广释门。此中二品。先说末那转。后说意识转。文相可见。此义云何者。总问二转。自此已下作释散说。此意转门依何契经所建立耶。谓显了经。彼契经中当何说耶。谓显了契经中作如是说种种心识虽有无量。唯末那转无有余法。所以者何。是末那识具足十一义无所不作故。彼契经中十一义名略不别说。是故论者。具举十一种之别名分明显示。云何名为十一种名。一者根本无明。二者业相。三者转相。四者现相。五者智相。六者相续相。七者业识。八者转识。九者现识。十者智识。十一者相续识。是名十一。如本以依阿梨耶识说有无明不觉而起能见能现能取境界起念相续故说为意。此意复有五种名广说乃至五者名为相续识以念相应不断故故。本地契经中作如是说大末那识具十二转者。所依本觉以为一故。相识两字何差别故。更加其数别建立耶。甚大别故。云何差别。谓一切诸眷属染法。皆悉各各有二义故。云何为二。一者神解义。二者暗钝义。神解义者。据从本觉流转边故。暗钝义者。据从无明流转边故。依初门故建立识名。依后门故建立相名。二门差别应如是知。何故如是。所言识者。解了义故顺于本觉。所言相者。背本义故顺于无明。是故常住佛性契经中作如是说。以何得知一切众生悉有佛性。答曰一切众生皆有心识故。当知有佛性。何以故。佛名觉者。能善照达一切法故。众生身中有此觉者故。是故一切众生。得有了别识耳故。以何义故名为意耶。谓有二义故。云何为二。一者根义。二者身义。言根义者。能生义故。言身义者。依止义故。以何义故。根本无明随染本觉各具因缘。互相望故。此义云何。谓举本觉及与无明望于三识。本觉为因无明为缘。同举彼二望于三相。无明为因本觉为缘。所以者何。以由亲为因由疏为缘故。何故上言分别智相及相续相意识细分。今此文中末那识摄。为欲成立末那意识。唯是一体无二别故。若尔何故略去粗分不以为意。约实皆意。而理尽故且略而已。是故经言无所不作。然别建立意识转者。为欲建立能依所依之法门故。举此决择三相末那应广通达。复次为欲显示阿梨耶识非定阿梨耶。末那非定末那。意识非定意识。以无定故。藏识末那。末那藏识。意识藏识。藏识意识。亦皆藏识。皆是末那。皆是意识。亦复皆非。如是无定故。皆是无常。无常故非真实。非真实故皆是幻化。以幻化故自性空无。自性空故决定寂灭。寂灭故寂灭亦寂灭故。金刚三昧契经中作如是说。地藏菩萨言。不可思议不思议聚七五不生。八六寂灭。九相空无。有空无有。无空无有。乃至上文言。佛言见则为妄。何以故。一切万有无生无相。本不自名悉皆空寂。一切法相亦复如是。一切众生身亦复如是。身尚不有云何有见故

已说随文散说决疑门。次说相续业用差别门

本曰。住持过去无量世等善恶之业令不失故。复能成就现在未来苦乐等报。无差违故。能令现在已经之事忽然而念未来之事不觉妄虑

论曰。此相续识即有三义。云何为三。一者摄前不失义。二者感果成就义。三者妄虑遍缘义。初义云何。此相续识而能发起润业烦恼。住持过去无明所起。一切种种善不善业。而能令作成果力用故。如本住持过去无量世等善恶之业令不失故。中义云何。此相续识又能发起润生烦恼。而能令使已成辨业。决定果报安立属当故。如本复能成就现在未来苦乐等报无差违故。后义云何。此相续识攀缘转广分别更强。缘已知境发乐不乐之心。对现前境增爱不爱之心。缘未知境不了妄计故。如本能令现在已经之事忽然而念未来之事不觉妄虑故。如是此识连续生死令不断绝。是故名为相续识焉

已说相续业用差别门。次说唯心回转诸法门

本曰。是故三界虚伪唯心所作。离心则无六尘境界。此义云何。以一切法皆从心起妄念而生。一切分别即分别自心。心不见心无相可得。当知世间一切境界。皆依众生无明妄心而得住持。是故一切法。如镜中像无体可得。唯心虚妄。以心生则种种法生。心灭则种种法灭故

论曰。此文为明何义。为欲显示一切诸法唯心回转无余法故。所以者何。随心有无诸差别法有无有故。诸法唯心此心有耶。如是心法亦不可得故。若尔唯是心义。云何成立。此亦心故。以何现知。经文明故。云何说耶。谓分流楞伽契经中作如是说。无心之心量我说为心量故。复次由心不可得之句故。成立大空之义。由无心之心量句故。成立幻差别之义。复次由大空之义故。诸法得成。由幻差别之义故。空理得显。复次由相观故无定二事。无二事故不成一事。无一事故不成亦不成。如其次第应审观察

已说广大末那转相门。次说分别事识转相门

本曰。复次言意识者。即是相续识。依诸凡夫取着转深。计我我所。种种妄执随事攀缘。分别六尘。名为意识。亦名分离识。又复说名分别事识。此识依见爱烦恼增长义故

论曰。即此文中自有四门。云何为四。一者拣择假者同分门。二者生起粗重转相门。三者建立名字差别门。四者显示安立所依门。拣择假者门者。举三种凡夫拣地上圣故。云何三凡。一者无根盲聋凡夫。二者毛头难角凡夫。三者金刚不变凡夫。是名为三。如本依诸凡夫故。生起粗重门者。若据邪定聚诸众生。常兴戏论分别之识。取着一切种种境界。转转深厚无有边际。无有始终。常恒增长无断绝故。如本取着转深故。若据不定聚诸众生。虽觉灭相定是不善起不作意。而人空智未现前故。缘诸境界及身分等。计我我所坚执不舍故。如本计我我所故。若据三贤位诸众生。虽已成就人空般若觉异相梦。而真法空智犹未现前故。起种种着坚执法实。随事思虑不能通达平等正理故。如本种种妄执随事攀缘分别六尘故。建立名字门者。即有三种。云何为三。一者所依微细名字。二者所依粗现名字。三者随顺境界名字。是名为三。初名云何。此识依彼微细末那。以为止根而得安立故名意识。如本名为意识故。中名云何。此识依彼眼等五根。以为止根分别五尘。是故亦名为分离识。如本亦名分离识故。后名云何。此识今缘事之境界。而转分别未以如理为自境界。是故名为分别事识。如本又复说名分别事识故。显示所依门者。见修二惑熏于本识。由此熏力粗分意识建立。增长相续恒转得住持故。如本此识依见爱烦恼增长义故故

从上已来生灭因缘决择已焉。自此已下显示因缘殊胜不可思议之相

本曰。依无明熏习所起识者。非凡夫能知。亦非二乘智慧所觉。谓依菩萨从初正信发心观察若证法身得少分知。乃至菩萨究竟地不能知尽。唯佛穷了。何以故。是心从本已来自性清净。而有无明。为无明所染有其染心。虽有染心而常恒不变。是故此义唯佛能知。所谓心性常无念故。名为不变。以不达一法界故。心不相应。忽然念起名为无明。深心者有六种。云何为六。一者执相应染。依二乘解脱及信相应地远离故。二者不断相应染。依信相应地修学方便。渐渐能舍得净心地。究竟离故。三者分别智相应染。依具戒地渐离。乃至无相方便地究竟离故。四者现色不相应染。依色自在地能离故。五者能见心不相应染。依心自在地能离故。六者根本业不相应染。依菩萨地尽得入如来地能离故。不了一法界义者。从信相应地观察学断。入净心地随分得离。乃至如来地能究竟离故。言相应义者。谓心念法异。依染净差别。而知相缘相同故。不相应义者。谓即心不觉。常无别异。不同知相缘相故。又染心义者。名为烦恼碍。能障真如根本智故。无明义者。名为智碍。能障世间自然业智故。此义云何。以依染心能见能现。妄取境界违平等性故。以一切法常静无有起相。无明不觉妄与法违故。不能得随顺世界一切境界种种知故

论曰。即此文中故有五门。云何为五。一者举人显示殊胜门。二者显示染缘决疑门。三者举障示治配当门。四者显应不应差别门。五者立二碍别障用门。是名为五。第一门中即有三人。云何为三。一者分满俱绝人。邪定凡夫一切二乘。愚痴深故。智慧劣故。如本依无明熏习所起识者非凡夫能知亦非二乘智慧所觉故。二者有分无满人。五十位人始觉般若未圆满故。如本谓依菩萨从初正信发心观察若证法身得少分知乃至菩萨究竟地不能知尽故。三者有满无分人。佛果位中大圆镜智遍现前故。如本唯佛穷了故。是名为三

已说举人显示殊胜门。次说显示染缘决疑门。此中有二意。云何为二。一者常无常门。二者无常常门。言常无常门者。自相本觉之心从无始来。决定常住体性不变。无非无常时。无非变化处故。如本何以故是心从本已来自性清净而有无明为无明所染有其染心故。言无常常门者。此本觉心从无始来。常恒无常常恒变异。无非常住时。无非不变处故。如本虽有染心而常恒不变故。是故此义唯佛能知者。总结殊胜。自此已下更以二句释上二句。文相可见

已说显示染缘决疑门。次说举障示治配当门。即此门中自有二意。云何为二。一者随转对治分位门。二者根本对治分位门。随转对治门者。六种随相如其次第。发心为初妙觉为后。随应离故。如本染心者有六种。云何为六。一者执相应染依二乘解脱及信相应地远离故。广说乃至六者根本业不相应染依菩萨地尽得入如来地能离故故。根本对治门者。大力无明极喜为初妙觉为后。随应离故。如本不了一法界义者从信相应地观察学断入净心地随分得离乃至如来地能究竟离故。极喜地中根本随相对治形相当如何别。谓后得智之所断者名为无明。及正体智之所断者名为随相。应如是知。如说极喜上一切地亦复如是

已说举障示治配当门。次说显应不应差别门。云何名为相应义耶。言相应义者。所谓心品及念法异。云何心品。所谓本觉随染之心。云何念法。所谓直依无明生长妄法。以何义故名为相应。谓相与力故。如是二法何故名异。本各别故。如本言相应义者谓心念法异故。念法之依染。心品之依净。如是二法各各差别。犹如水火而何故言成相应义。知相缘相合契同故。云何名为知相契同。心品念法不相舍离。和会转故。云何名为缘相契同。如是二品所缘同故。如本依染净差别而知相缘相同故故。大本金刚三昧契经中作如是说。三种相同。异故成同。若同不同故。若尔何故部宗契经中作如是说。三种粗染二义故转。云何二转。一者相违转。二者随顺转。乃至广说。逆上顺下作如是说。无别意趣。不相应义相应相违。应审观察

已说显应不应差别门。次说立二碍别障用门。彼烦恼碍多散动性。是真如智直寂静性。如是相违故立为障。如本又染心义者名为烦恼碍能障真如根本智故。彼智慧碍漠溟之性。是作业智聪明之性。如是相违故立为障。如本无明义者名为智碍能障世间自然业智故。此义云何下显示其因缘。应审思择。二障二碍复有何别。立二障门据一向断。立二碍门据断不断。应如是知。应如是观。从上已来因缘殊胜决择分已焉

释摩诃衍论卷第四释摩诃衍论卷第五

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

自此已下显示生灭之相差别

本曰。复次分别生灭相者。有二种。云何为二。一者粗与心相应故。二者细与心不相应故。又粗中之粗凡夫境界。粗中之细及细中之粗菩萨境界。细中之细是佛境界。此二种生灭。依于无明熏习而有。所谓依因依缘。依因者不觉义故。依缘者妄作境界义故。若因灭则缘灭。因灭故不相应心灭。缘灭故相应心灭。问曰若心灭者云何相续。若相续者云何说究竟灭。答曰所言灭者。唯心相灭非心体灭。如风依水而有动相。若波水灭者则风断绝无所依止。以水不灭风相相续。唯风灭故动相随灭。非是水灭无明亦尔。依心体而动。若心体灭则众生断绝无所依止。以体不灭心得相续。唯痴灭故心相随灭。非心智灭

论曰。则此文中自有五门。云何为五。一者标释俱成示相门。二者率相属当假人门。三者显示粗细所依门。四者本觉对治次第门。五者发起问答决疑门。言标释俱成示相门者。粗重生灭与心相应故。微细生灭与心不相应故。云何名为粗重生灭。当与何识而相应耶。谓末末故。与分别事识而共相应故。云何名为微细生灭。当与何识而不相应耶。所谓末故与三位本识而不相应故。马鸣菩萨依何经本作此解释。谓楞伽经。彼契经中如何说耶。谓一本分流楞伽契经中作如是说。尔时大慧菩萨摩诃萨复白佛言。世尊诸识有几种生住灭。佛告大慧。诸识有二种生住灭。非思量所知。诸识有二种生。谓流注生及相生。有二种住。谓流注住及相住。有二种灭。谓流注灭及相灭。又一本分流楞伽契经中作如是说。大慧。诸识有二种灭。何等为二。一者相灭。二者相续灭。有二种生。何等为二。一者相生。二者相续生。有二种住。何等为二。一者相住。二者相续住。又大本楞伽契经中作如是说。尔时文殊师利即白佛言。世尊诸心识法。有几无常之相。佛告文殊。若第一有缚细识。有上品非离生灭。若中转有缚细识。有中品非离生灭。若远转缚细识。有下品非离生灭。若遍分别粗识。有分离面镜非离生灭。如是三本楞伽契经为明何义。为欲显示粗重微细二种生灭差别相故。于契经中唯出名字不示其义。以此义故马鸣菩萨。分契不契显示粗细二种生灭。如本复次分别生灭相者则有二种。云何为二。一者粗与心相应故。二者细与心不相应故故

已说标释俱成示相门。次说率相属当假人门。此中假人即有三种。云何为三。一者不退凡夫。二者分清净者。三者满清净者。是名为三。初人以何相应而为自境界耶。谓执相应染以为自境界故。如本又粗中之粗凡夫境界故。中人以何等染而为自境界耶。谓后二相应初二不相应。及业识之一分以为自境界故。如本粗中之细及细中之粗菩萨境界故。后人以何不相应染为自境界耶。谓俱合动相之一分。及独力业相之全分以为自境界故。如本细中之细是佛境界故

已说率相属当假人门。次说显示粗细所依门。此中所依即有二种。云何为二。一者是通。二者是别。通者二种生灭。皆以无明为所依故。别者二种生灭如其次第。各因及缘为所依故。如本此二种生灭依于无明熏习而有所谓依因依缘。依因者不觉义故。依缘者妄作境界义故故。今此论文依何经起。谓楞伽经。彼契经中如何说耶。谓分流楞伽契经中作如是说。大慧。不思议熏及不思议变。是现识因。取种种尘及无始妄想熏。是分别事识因。又大本楞伽契经中作如是说。复次不离染因者。可思议熏不可思议熏。及可思议变不可思议变。复次分离染因者。种种猛风。妄想现镜识乃至广说。何法名为不思议熏。所谓即是根本无明。以何义故名不思议熏。谓甚深故。云何甚深。谓金刚已还一切众生不了此处。是故名为不思议熏。如熏变亦尔故大本经中作如是说。可思议不可思议者。就金刚还上之人故

已说显示粗细所依门。次说本觉对治次第门。谓本觉智根本无明为始。灭相为终。如其次第渐对治故。然此中断不舍无明以为其断。非以断除而为断故。若尔云何断义成耶。谓断烦恼心。断除不起故。是名本觉治道次第。如本若因灭则缘灭。因灭故不相应心灭。缘灭故相应心灭故

已说本觉对治次第门。次说发起问答决疑门。即此门中自有二意。云何为二。一者两难闭关门。二者开通决疑门。文相可见。本觉明智断根本无明。三种细染永灭不起。已三细无六粗之心亦不能起。三六种心永灭不起。本觉性智不能自有。所以者何。三六种心非但无明。亦本觉俱。真妄和合名三六心故。然若言三六心灭者。本觉同灭无所有也。岂可得言本觉之心而得相续至于邪定。故言问曰若心灭者云何相续。即是初关。若言本觉是功德法非断之法。常恒相续无断绝者。岂可得言三六种心永灭不起。故言若相续者云何说究竟灭。即是第二关。自此已下作释决疑。文相明故不须重释

从上已来。生灭之相决择分已焉。自此已下显示染净相熏相生不断绝义

本曰。复次有四种法熏习义故。染法净法起不断绝。云何为四。一者净法。名为真如。二者一切染因。名为无明。三者妄心。名为业识。四者妄境界。所谓六尘。熏习义者。如世间衣服实无于香。若人以香而熏习故则有香气。此亦如是。真如净法实无于染。但以无明而熏习故则有染相。无明染法实无净业。但以真如而熏习故则有净用。云何熏习起染法不断。所谓以依真如法故有于无明。以有无明染法因故。即熏习真如。以熏习故即有妄心。以有妄心故即熏习无明。不了真如法故。不觉念起现妄境界。以有妄境界染法缘故。即熏习妄心。令其念着造种种业。受于一切身心等苦。此妄境界熏习义即有二种。云何为二。一者增长念熏习。二者增长取熏习。妄心熏习义有二种。云何为二。一者业识根本熏习。能受阿罗汉辟支佛一切菩萨生灭苦故。二者增长分别事识熏习。能受凡夫业系苦故。无明熏习义有二种。云何为二。一者根本熏习。以能成就业识义故。二者所起见爱熏习。以能成就分别事识义故。云何熏习起净法不断。所谓以有真如法故。能熏习无明。以熏习因缘力故。则令妄心厌生死苦乐求涅盘。以此妄心有厌求因缘故。即熏习真如自信己性。知心妄动。无前境界。修远离法。以如实知无前境界故。种种方便起随顺行不取不念。乃至久远熏习力故。无明即灭。以无明灭故心无有起。以心无起故境界随灭。以因缘俱灭故心相皆尽。名得涅盘成自然业。妄心熏习义有二种。云何为二。一者分别事识熏习。依诸凡夫二乘人等。厌生死苦随力所能。以渐趣向无上道故。二者意熏习。谓诸菩萨发心勇猛速趣涅盘故。真如熏习义有二种。云何为二。一者自体相熏习。二者用熏习。自体相熏习者。从无始世来具无漏法。用熏习者。备有不思议业作境界之性。依此二义恒常熏习。以有熏习力故。能令众生厌生死苦乐求涅盘。自信己身有真如法发心修行。问曰若如是义者。一切众生悉有真如等皆熏习。云何有信无信无量前后差别。皆应一时自知有真如法。勤修方便等入涅盘。答曰真如本一而有无量无边无明。从本已来自性差别厚薄不同故。过恒河沙等上烦恼依无明起差别。我见爱染烦恼依无明起差别。如是一切烦恼依于无明所起。前后无量差别。唯如来能知故。又诸佛法有因有缘。因缘具足乃得成办。如木中火性是火正因。若人无知不假方便。能自烧木无有是处。众生亦尔。虽有正因熏习之力。若不遇诸佛菩萨善知识等。以之为缘能自断烦恼。入涅盘者则无是处。若虽有外缘之力。而内净法未有熏习力者。亦不能究竟厌生死苦乐求涅盘。若因缘具足者。所谓自有熏习之力。又为诸佛菩萨等慈悲愿护故。能起厌苦之心。信有涅盘修习善根。以修善根成就故。则值诸佛菩萨示教利喜。乃能进趣向涅盘道。用熏习者即是众生外缘之力。如是外缘有无量义。略说二种。云何为二。一者差别缘。二者平等缘。差别缘者。此人依于诸佛菩萨等。从初发意始求道时乃至得佛。于中若见若念。或为眷属父母诸亲。或为给使。或为知友。或为怨家。或起四摄。乃至一切所作无量行缘。以起大悲熏习之力。能令众生增长善根。若见若闻得利益故。此缘有二种。云何为二。一者近缘。速得度故。二者远缘。久远得度故。是近远二缘分别复有二种。云何为二。一者增长行缘。二者受道缘。平等缘者。一切诸佛菩萨皆愿度脱一切众生。自然熏习恒常不舍。以同体智力故。随应见闻而现作业。所谓众生依于三昧。乃得平等见诸佛故。此体用熏习分别复有二种。云何为二。一者未相应。谓凡夫二乘初发意菩萨等。以意意识熏习。依信力故而修行。未得无分别心与体相应故。未得自在业修行与用相应故。二者已相应。谓法身菩萨得无分别心。与诸佛智用相应。唯依法力自然修行。熏习真如灭无明故。复次染法从无始已来熏习不断。乃至得佛后即有断。净法熏习即无有断尽于未来。此义云何。以真如法常熏习故。妄心即灭法身显现。起用熏习故无有断

论曰。即此文中自有五门。云何为五。一者总标纲要门。二者立名略示门。三者通释熏习门。四者分剖散说门。五者尽不尽别门。第一门中自有六意。云何为六。一者相待相成似有意。谓欲显示染净诸法。皆悉相待而得成立。无有唯自建立法故。二者本无性空非有意。谓欲显示染净诸法种种名字。于本无中权假建立。一切皆悉非自名故。三者相待相成显空意。谓欲显示染净诸法由相观故。从本已来无有自体自性空故。四者自然虚空无碍意。谓欲显示一切诸法。非有非有故自然作空。非碍非碍故常作无障碍义故。五者非作非造自然意。谓欲显示一切诸法。有佛无佛相熏相生无断绝义。法尔道理性如是故。六者不守自性无住意。谓欲显示一切诸法。作缘起陀罗尼义故。总标如是等无量义。故名为总标纲要门。如本复次有四种法熏习义故。染法净法起不断绝故

已说总标纲要门。次说立名略示门。于此门中即有二门。云何为二。一者净真法相门。二者染妄法相门。所言真者。自性清净本觉藏智。所言妄者。离脱体相本上无明。染妄门中即有三种。云何为三。一者无明。二者业识。三者境界。一真三妄如是四法。能作熏事本数名字。今此文中举一。后有并兼中有。应审观察。所以者何。一切染法皆悉有熏习之事故。如本云何为四。一者净法名为真如。二者一切染因名为无明。三者妄心名为业识。四者妄境界所谓六尘故

已说立名略示门。次说通释熏习门。于此门中即有二门。云何为二。一者比量譬喻善巧门。二者法喻合说安立门。比量譬喻善巧门者。譬如衣服从本已来。亦无芬香亦无鄙香一向无气。而士夫众入于班多伽耶娑叉提邬林时。会末耶提以熏习故而有秽香。入于梵檀只多那林时。陀摩键多以熏习故而有香气故。如本如世间衣服实无于香若人以香而熏习故则有香气故。法喻合说安立门者。胜义道理亦复如是。自性清净无漏性德。从无始来一向明白。亦无垢黑亦无染污。而以无明而熏习故则有垢黑。无明藏海从无始来一向闇黑。亦无智明亦无白品。而以本觉而熏习故则有净用。如是染净但是假立。染非实染净非实净。皆是幻化。无实自性。如本此亦如是。真如净法实无于染。但以无明而熏习故。则有染相无明染法实无净业。但以真如而熏习故则有净用故

已说通释熏习门。次说分剖散说门。于此门中即有四门。云何为四。一者黑品相熏有力门。二者白品相熏有力门。三者发起问答决疑门。四者举缘广说开通门。第一门中即有二门。云何为二。一者总问总答显宗门。二者归总作别散说门。第二门中具此二门应审观察。第四门中自有二门。云何为二。一者总标轨则决定门。二者因缘各示生解门。如其次第说相可见。云何熏习起染法不断者。即是总问谓通总问一切黑品相熏相生不断义故。自此已下即总答分。就于即此答说分中。从净妙藏乃至粗重。背本向末渐次转胜说其次第。说相次第应审观察。根本无明不能自有。当依真如方得止住。所以者何。真如之性如虚空界。至部实主于障碍及无障碍中。为作归依无所碍故。如本所谓以依真如法故有于无明故。如是无明得自所已。气力殊胜功能自在。能熏真如令作妄法。增不了相加闇钝用。譬如爱父生诸男女。如本以有无明染法因故即熏习真如以熏习故则有妄心故。如是微细业识妄心。因无明故自体生已。还熏无明能令增长。譬如生子养能生父。如是熏力更增长故。不能通达平等如理圆满一心故。起转识之惑念。生现相之妄境。生死之海更深。涅盘之岸弥高。如本以有妄心即熏习无明不了真如法故不觉念起现妄境界故。如是境界之风。还熏现识之海。起七识之波浪。此识乐着境界之尘。彼境面向识眼之前。遍造诸恶之业。具受一切苦报。三有之轮环循。四毒之贼浪起。如本以有境界染法缘故。即熏习妄心令其念着造种种业。受于一切身心等苦故

已说总问总答显宗门。次说归总作别散说门。就此门中即有三重。云何为三。一者境界。二者妄心。三者无明。是名为三。如是三种各有二故即成六数。如其次第初以为后后以为初渐次显示。初重云何。此妄境界有如实熏习之力故。增法执念。有如有熏习之力故。长人执着。人法二执具足起故。过于恒沙上烦恼类皆悉发起。是故名为境界熏习。如本此妄境界熏习义则有二种。云何为二。一者增长念熏习二者增长取熏习故。中重云何。业识妄心有上熏之力故。已得出离三乘圣人。而能令受变易细苦。有下熏之力故。未得出离一切凡夫而能令受分段粗苦。是故名为妄心熏习。如本妄心熏习义有二种。云何为二。一者业识根本熏习能受阿罗汉辟支佛一切菩萨生灭苦故。二者增长分别事识熏习能受凡夫业系苦故故。后重云何。无明住地自体本故。能熏初末令得成就。通达遍故。能熏事识令得成就。何故唯举初后中间不显。有二意故。云何为二。一者有成就意。二者空成就意。云何名为有成就意。举边得有现中有故。云何名为空成就意。举中空无显边空故。后义云何。于契经中如是说故。当何契经。谓熏习经。彼契经中如何说耶。谓熏习契经中作如是说。转识现识末那三识。非从无明而得成就。所以者何。根本无明唯边成就非中成就。此文后义直释彼经。是故明知此义得成。如本无明熏习义有二种。云何为二。一者根本熏习以能成就业识义故。二者所起见爱熏习以能成就分别事识义故故

已说黑品相熏有力门。次说白品相熏有力门。云何熏习起净法不断者。即是总问。谓通总问一切白品相熏相生不断义故。自此已下即总答分。就于即此答说分中。自有二熏。云何为二。一者无始自然熏。二者始有建立熏。无始熏者。从无始已来有因果之二位故。始有熏者。因修力故。有因果之二位故。本因果者其相云何。谓无始来有三贤十圣之位故。有三身四德之果故。始因果者其相云何。今修行时方乃有无始之十地故。显本有之因果故。本因果者次第云何。从无始来以有十种本觉真智。及十种如实法界故。能熏十种枝末无明。以有一种法界心故。能熏习根本无明故。是名本地。如本所谓以有真如法故能熏习无明故。始因果者次第云何。谓虽未得十信之位。而以本熏习之力故。则自心中厌生死苦求涅盘乐。以此力故。即熏习真如性。自信佛性入十信位。知心虚妄入十解位知境界空入十行位。修出向法入十向位。以如实般若知境界空故。无量方便发起随顺法界性行。不取涅盘不念生死。入极喜地乃至金刚。自久远熏习故。发解脱道无明顿断。根本尽故枝末皆无。本末黑品无所有故。得法身涅盘。成应化业用故。是名始地。如本以熏习因缘力故则令妄心厌生死苦乐求涅盘以此妄心有厌求因缘故即熏习真如自信己性知心妄动无前境界修远离法以如实知无前境界故种种方便起随顺行不取不念乃至久远熏习力故无明则灭以无明灭故心无有起以无起故境界随灭以因缘俱灭故心相皆尽名得涅盘成自然业故

已说总问总答显宗门。次说归总作别散说门。就此门中即有二门。云何为二。一者妄染熏习门。二者净法熏习门。染法门中即有二种。云何为二。一者是粗。二者是细。所言粗者。即是意识。所言细者。十一末那。意识熏者其相云何。四十心凡夫及诸二乘。以意识中本觉智分。熏意识中无明痴分。厌生死苦欣涅盘乐。渐渐转胜向佛道故。如本妄心熏习义有二种。云何为二。一者分别事识熏习依诸凡夫二乘人等厌生死苦随力所能以渐趣向无上道故故。十一末那熏习义者。其相云何。从初圣地乃至金刚。如其次第。以清净分熏染污分。证入无上菩提道故。以菩萨等断无明故。如本二者意熏习谓诸菩萨发心勇猛速趣涅盘故故

已说妄染熏习门。次说净法熏习门。就此门中自有二门。云何为二。一者总标门。二者开释门。总标门者。总标其名。如本真如熏习义有二种。云何为二。一者自体相熏习二者用熏习故。开释门中有二门。云何为二。一者法身自然熏习门。二者应化常恒熏习门。所言法身熏习门者。本觉性智从无始来。圆满功德具足智慧。自自作自无他力故。如本自体相熏习者。从无始世来具无漏法故。所言应化熏习门者。如是本觉发过恒沙无量无边不可思议种种业用。一切众生诸心相中随应教化。断一切恶修一切善。具百行之因。满万德之果故。如本用熏习者。备有不思议业。作境界之性故。如是二门不相舍离。于一切时于一切处。常恒熏习起信生解。建立修行造作不转。到正后二地。达真俗境令无碍故如本依此二义恒常熏习以有熏习力故能令众生厌生死苦乐求涅盘自信己身有真如法发心修行故。由此义故。三身本有理故显了

已说白品相熏有力门。次说发起问答决疑门。此决疑门义理难解文教更闭。作释非散说无定通人不能明了。是故今更作种种释。具足开示晓行者心。如其次第问答之相应审观察。一切众生皆有本觉。有众生数而无本觉。皆有理故。所以者何。大觉尊者如是说故。此义云何。一切众生从无始来具足本觉。从无始来无本觉故。若依初门一切众生悉有本觉。如是本觉唯是一体遍诸众生。一一众生各有别觉。一切众生唯有一觉无别觉故。若尔众生唯应是一。所有本觉一故。本觉应非一。能有众生多故。此事不尔。所以者何。意趣别故。谓本觉心平等性故不能异种。一切众生差别性故不能同种。不能异种故一。不能同种故多。若尔此文云何通耶。谓马鸣尊者大宗地玄文本论中作如是说

  譬如虚空中　　清净满月轮
  独一无二体　　遍现于千器
  本觉亦如是　　独一无二体
  遍于诸众生　　种种心相中
  譬如一段云　　覆彼满月轮
  千器诸月轮　　皆隐没不现
  无明亦如是　　唯一体无二
  遍到诸众生　　能作熏习事

有二义故无相违过。云何为二。一者自宗决定。二者引摄决定。言自宗决定者。显示同一相续义故。言引摄决定者。显示差别相续义故。彼玄文论为显初义。是起信论为显后义。以此义故无相违过。是故马鸣尊者虚空地地论中作如是说

  譬如以莲叶　　覆一器月轮
  而余器月轮　　终不隐现前
  无明亦如是　　覆惑人觉时
  已觉人本觉　　终不能隐覆

此文为明何义。为欲显示差别相续之义故。复次文殊师利论议第一神力殊胜慈悲圆满虚空功德契经中作如是说

  有无量无边　　无明烦恼障
  遍到众生身　　能作障碍事

此文为明何义。谓欲显示精进修行之义故。云何显示。谓有众生作如是念。若无明体唯是一种。遍于一切诸众生者。无明唯一众生众多。易可断除。何须敢劳可修行也。如见世间相。多人作一事。为难之不足不勤修行。为欲对治如是懈怠痴众生故。如来说言有无量无边无明能覆佛性。以此义故一无明义而得成立。若尔一众生烦恼尽时中。余一切众生皆悉亦可尽。所以者何。唯一无明故。若一人断时余人不能断者。不可得言同一无明。复次有众生界断绝过失故。此事不尔。无明虽一相续别故。其相云何。颂曰

  譬如夜闇一　　遍到十室中
  灭一室闇时　　余灭不可言

论曰。夜闇虽一。而能遍到十室之中。闇一室一亦不可言。室十闇十亦不可说。于一室中人以明灯照室之中。闇尽灭无余。明圆显遍照一室中。闇尽灭无余。九室中闇尽灭无余亦不可言。余九室闇具有不灭。灯照一室闇不灭者亦不可说。无明烦恼亦复如是。言夜闇者喻于无明。言十室者喻众生身。言明灯者喻于智慧。是故当知。无明虽一相续别故。断及不断各各不同。若一众生烦恼尽时。余诸众生不能断者。烦恼未尽众生身中本觉佛性。为无明覆。烦恼已尽众生身中本觉佛性。无明所覆已尽出离。离障佛性为障佛性。天殊地别。何故今言同一佛性。不分其体遍诸众生。本觉佛性等虚空界。无所不遍无所不至。无所不通无所不当。平等平等一味一相无有差别。而无明藏中本觉佛性为染覆障。法界之外本觉佛性离染覆者。此俱攀缘虑知之心现量境界。非是自性中实理心。是故当知佛性之理。唯是一种等无差别。是故马鸣尊者大宗地玄文本论中作如是说

  月轮现千器　　若有浊水器
  现而非分明　　若有清水器
  圆现而明了　　晦明虽不同
  唯一满月轮　　本觉亦如是

一切众生从无始来。皆有本觉无舍离时。何故众生先有成佛。后有成佛。今有成佛。亦有勤行。亦有不行。亦有聪明。亦有闇钝。无量差别。同有一觉皆悉一时发心修行到无上道。本觉佛性强劣别故。如是差别。无明烦恼厚薄别故。如是差别。若言如初者。此事则不尔。所以者何。本觉佛性圆过恒沙之诸功德无增减故。若言如后者。此事亦不尔。所以者何。一地断义不成立故。如是种种无量差别。皆依无明而得住持。于至理中无关而已。若如是者一切行者。断一切恶修一切善。超于十地到无上地。圆满三身具足四德。如是行者为明无明。如是行者无明分位非明分位。若尔清净本觉从无始来。不观修行非得他力。性德圆满本智具足。亦出四句亦离五边。自然之言不能自然。清净之心不能清净。绝绝离离。如是本处为明无明。如是本处无明边域非明分位。若尔一法界心。非百非背千是。非中非中背天。非天演水之谈足断而已止。审虑之量手亡而已住。如是一心为明无明。如是一心无明边域非明分位。三自一心。摩诃衍法一不能一假能入一心。不能心假能入心。实非我名而目于我。亦非自唱而契于自。如我立名而非实我。如自得唱而非实自。玄玄又玄。远远又远。如是胜处为明无明。如是胜处无明边域非明分位。不二摩诃衍法。唯是不二摩诃衍法。如是不二摩诃衍法为明无明

已说有觉门。次说无觉门。何故一切众生无有本觉耶。无本觉故。何故无本觉耶。无众生故。何故无众生耶。无所依本觉故。率此二门应广通达。如本问曰若如是义者一切众生悉有真如等皆熏习。云何有信无信。无量前后差别。皆应一时自知有真如法。勤修方便等入涅盘。答曰真如本一而有无量无边无明。从本已来自性差别厚薄不同故。过恒河沙等上烦恼依无明起差别。我见爱染烦恼依无明起差别如是。一切烦恼。依于无明所起前后无量差别。唯如来能知故故

已说发起问答决疑门。次说举缘广说开通门。就此门中即有二门。云何为二。一者总标轨则决定门。二者缘相散示生解门。于第一门即有三种。云何为三。一者法体说。二者譬喻说。三者契合说。又诸佛法有因有缘因缘具足乃得成办者。即是法说。谓诸佛法当待因缘无自立法。所以者何。以法尔故。所言因者。本觉性种所言缘者。权实别用。以此二事故诸法得成立。应审观察。已说法说。次说喻说。如木中火性是火正因。若人无知不假方便能自烧木无有是处者。即是喻说。此中譬喻即有四种。云何为四。一者木喻。二者火喻。三者人喻。四者烧喻。所言木者。喻于染法。所言火者。喻于智慧。所言人者。喻于众生。所言烧者。喻于对治。第一譬喻其意云何。所谓阿梨罗多掩尸。木即具五事。云何为五。一者根源深固无能超过。二者干枝花叶。乃至果实生利铦刺。三者香气极秽。四者毒虫乐着。五者眷属无尽。是名为五。无明染法亦复如是。根本无明甚深广大无能过故。一切种种枝末不觉迷惑过失无有量故。第二譬喻其意云何。所谓伏火即有七事。云何为七。一者干亡义。能令枯木乃至死故。二者生长义。能碍寒气令得生故。三者莫测义。不知所故。四者隐藏义。不能见故。五者出现义。出火炎故。六者随有义。随木有故。七者随无义。随木无故。是名为七。本觉般若亦复如是。熏习染法至尽灭故。受熏流转故。所住之处不思议故。无明藏中密隐没故。具足出现无所余故。随染有无本觉有无故。第三譬喻其意云何。谓假人者有二种故。云何为二。一者婆罗利多提假人。二者那尸阿多罗假人。彼第一人即知五事。云何为五。一者知出火木。二者知钻转木。三者知渐顿时。四者知止住所。五者知成就次。是名为五。若第二人不知此事终不得火。修行诸人亦复如是。亦有方便无方便故。第四譬喻其意云何。谓火烧木即有三事。云何为三。一者舍利作钝事。谓火烧即诸刺木等不能害故。二者舍异作同事。谓作钝即都合灰故。三者背末还本事。谓同相即与地等故。是名为三。治道次第亦复如是。谓断障故。证得理故。归一心故。已说喻说。次说合说。此合说中即有二门。云何为二。一者总说。二者别说。言总说者。总所为故。如本众生亦尔故。言别说者。别所为故。此别说中即有三门。云何为三。一者缘阙单因无力门。二者因阙单缘无力门。三者因缘具足圆成门。缘阙单因无力门者。譬如虽木中火性从本已来有伏藏火。而不假方便无以得火。如是虽无明藏中如来之性。从本已来有自性清净心。而不待修行之功无以得佛故。如本虽有正因熏习之力。若不遇诸佛菩萨善知识等。以之为缘能自断烦恼入涅槃者。则无是处故。因阙单缘无力门者。譬如有人虽具足方便。而彼木中若无火性终不得火。如是一切行者。虽具修行无量方便。而众生心中若无本觉佛性。终不得佛故。如本若虽有外缘之力而内净法。未有熏习力者。亦不能究竟厌生死苦乐求涅盘故。因缘具足圆成门者。譬如木中有火性亦具方便。火炎出现烧木无余。因缘具足者亦复如是。内中有本觉之佛性。外中具修行之功能。圆百行之因。满万德之果。三智俱行四德双开。如本若因缘具足者。所谓自有熏习之力。又为诸佛菩萨等慈悲愿护故。能起厌苦之心。信有涅盘修习善根。以修善根成就则值诸佛菩萨示教利喜。乃能进趣向涅盘道故

已说总标轨则决定门。次说缘相散示生解门。就此门中即有二说。云何为二。一者总说。二者别说。就总说中即有二意。云何为二。一者能缘。二者所缘。言能缘者。即应化身。能为众生造作成本觉之境界故。如本用熏习者故。言所缘者。即众生界。一切诸佛所化徒故。如本即是众生外缘之力故。就别说中即有二门。云何为二。一者有简择缘。二者无简择缘。如本如是外缘有无量义。略说二种。云何为二。一者差别缘。二者平等缘故。所言有简择缘者。即有二意。云何为二。一者能缘之人。二者所缘之境。能缘人者其分齐云何。所谓发心以为其初。如来之地以为其后。能作此缘。所缘境者其分齐云何。所谓通于邪定不定二种众生故。复次通于正定聚故。如本差别缘者此人依于诸佛菩萨等。从初发意始求道时乃至得佛于中。若见若念。或为眷属父母诸亲。或为给使。或为知友。或为怨家。或起四摄。乃至一切所作无量行缘。以起大悲熏习之力。能令众生增长善根。若见若闻得利益故故。自此已下明善根已成熟未成熟之差别。谓有众生善根已熟。应化之身即便应时速令得度。亦有众生善根未熟。应化之身时节久远令使得度。如本此缘有二种。云何为二。一者近缘速得度故。二者远缘久远得度故故。自此已下于近远缘各开二缘。显示因果之差别相。云何为二。一者增因缘。二者增果缘。增因缘者。彼二种缘各各增长十地万行故。增果缘者。彼二种缘各各增长如来之地圆满果故。如本是近远二缘分别。复有二种。云何为二。一者增长行缘二者受道缘故

已说有简择缘。次说无简择缘。就此文中即有二门。云何为二。一者是总。二者是别。总说中言平等缘者。一切诸佛菩萨。皆愿度脱一切众生。自然熏习恒常不舍者。即是慈悲愿力缘焉。所谓一切诸佛菩萨。于一切时于一切处。常恒熏习一切无量诸众生中。而能作境。发起伏藏善根之气常不舍故。以同体智力故。随应见闻而现作业者。即是实行。所谓应化上佛。以随转自在无碍之力故。随时随处随宜随事随乐。顺顺如如显示八种利益之业。教化众生无有余故。所谓众生依于三昧乃得平等见诸佛故者。即是显示观佛正法。谓一切诸佛出现众生界中。譬如角中毛。重重无数不可说劫。如是虽有无量无边。而若不修奢摩他者终不见佛。是故发心已去一切诸菩萨等。以三昧力观见诸佛法性之身。平等平等无有差别。同一真如同一法身。异唯见自。我自无别。是故说言平等见佛

已说总说门。次说别说门。就此门中即有二门。云何为二。一者未入正位。二者已入正位。云何名为未入正位。谓十信凡夫一切二乘三贤菩萨等。未得正体智。未证后得知。未证如理故。如本此体用熏习分别。复有二种。云何为二。一者未相应。谓凡夫二乘初发意菩萨等。以意意识熏习依信力故。而修行未得无分别心与体相应故。未得自在业修行与用相应故。云何名为已入正位。谓十地菩萨内得正智外得后智。一分智用与如来等。唯本熏力自然修行。增长真如能灭无明故。如本二者已相应。谓法身菩萨得无分别心。与诸佛自体相应故。得自在业修行与智用相应。唯依法力自然修行熏习真如灭无明故

已说分剖散说门。次说尽不尽别门。此门为明何义。为欲显示一切妄法非道理故无始有终。一切净法契道理故有始无终故。复次为欲显示真妄二法。极相违故不俱行故。复次为欲显示真妄二法无有胜劣。其体相等无有广狭其作业同故。如本复次染法从无始已来熏习不断。乃至得佛后即有断净法。熏习则无有断。尽于未来。此义云何。以真如法常熏习故。妄心则灭。法身显现起用熏习故无有断故

释摩诃衍论卷第五释摩诃衍论卷第六

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

从上已来。染净诸法相熏相生不断绝义决择分已焉。自此已下分明显示生灭门中三种大义

本曰。复次真如自体相者。一切凡夫声闻缘觉菩萨诸佛无有增减。非前际生。非后际灭。毕竟常恒。从本已来唯性自满足一切功德。所谓自体有大智慧光明义故。遍照法界义故。真实识知义故。自性清净心义故。常乐我净义故。清凉不变自在义故。具足如是过于恒沙不离不断不异不思议佛法。乃至满足无有所少义故。名为如来藏。亦名如来法身。问曰。上说真如。其体平等离一切相。云何复说体有如是种种功德。答曰。虽实有此诸功德义。而无差别之相。等同一味唯一真如。此义云何。以无分别离分别相。是故无二。复以何义得说差别。以依业识生灭相示。此云何示。以一切法本来唯心实无于念。而有妄心不觉起念见诸境界。故说无明。心性不起。即是大智慧光明义故。若心起见即有不见之相。心性离见即是遍照法界义故。若心有动非真识知。无有自性。非常非乐非我非净。热恼衰变则不自在。乃至具有过恒沙等妄染之义。对此义故心性无动。则有过恒沙等诸净功德相义示现。若心有起更见前法可念者。则有所少。如是净法无量功德。即是一心更无所念。是故满足名为法身如来之藏。复次真如用者。所谓诸佛如来本在因地。发大慈悲修诸波罗蜜。摄化众生立大誓愿。尽欲度脱等众生界。亦不限劫数尽于未来。以取一切众生如己身故。而亦不取众生相。此以何义。谓如实知一切众生及与己身真如平等。无别异故以有如是大方便智。除灭无明见本法身。自然而有不思议业种种之用。即与真如等遍一切处。又亦无有用相可得。何以故。谓诸佛如来唯是法身。智相之身。第一义谛。无有世谛境界离于施作。但随众生见闻得益故说为用。此用复有二种。云何为二。一者依分别事识。凡夫二乘心所见者名为应身。以不知转识现故。见从外来。取色分齐不能尽知故。二者依于业识。谓诸菩萨从初发意。乃至菩萨究竟地。心所见者名为报身。身有无量色。色有无量相。相有无量好。所住依果亦有无量种种庄严。随所示现。即无有边不可穷尽。离分齐相随其所应。常能住持不毁不失。如是功德皆因诸波罗蜜等无漏行熏。及不思议熏之所成就。具足无量乐相故说为报。又凡夫所见者是其粗色。随于六道各见不同。种种异类非受乐相故说为应。复次初发意菩萨所见者。以深信真如法故。少分而见。知彼色相庄严等事。无去无来离于分齐。唯依心现不离真如。然此菩萨犹自分别。以未入法身位故。若得净心所见微妙其用转胜。乃至菩萨地尽见之究竟。若离业识则无见相。以诸佛法身无有彼此色相迭相见故。问曰。若诸佛法身离于色相者。云何能现色相。答曰。即此法身是色体故能现于色。所谓从本已来色心不二。以色性即智故。色体无形说名智身。以智性即色故说名法身。遍一切处所现之色无有分齐。随心能示十方世界。无量菩萨无量报身无量庄严各各差别。皆无分齐而不相妨。此非心识分别能知。以真如自在用义故

论曰。即此文中自在三门。云何为三。一者显示自体大义门。二者显示自相大义门。三者显示自用大义门。初大义中即有二门。云何为二。一者五人平等门。二者时不转门。是名为二。中大义中即有三门。云何为三。一者圆满功德门。二者问答决疑门。三者别释广说门。是名为三。后大义中自有六门。云何为六。一者本愿无尽门。二者离相不着门。三者能所平等门。四者无相现应门。五者随见粗细门。六者问答决疑门。是名为六。今当作释如其次第分明散说。大聪明者应审思择。复次真如自体相者者。即是总标体相二义。自此已下别释散说。初说体大。云何名为五人平等门。谓真如自体通于五人。平等平等无差别故。云何名为五种假人。一者凡夫。二者声闻。三者缘觉。四者菩萨。五者如来。是名为五。如是五名。人自是五真自唯一。所以者何。真如自体无有增减。亦无大小亦无有无。亦无中边亦无去来。从本已来一自成一。同自作同。厌异舍别唯一真故。是故诸法真如一相三昧契经中作如是说。譬如金刚作五趣像。五人平等亦复如是。于诸人中无有增减故。如本一切凡夫声闻缘觉菩萨诸佛无有增减故。云何名为时不转门。谓真如自体。自然常住决定不变。三际不动四相不迁。寂灭又寂灭。真实又真实故。如本非前际生非后际灭毕竟常恒故

已说显示自体大义门。次说显示自相大义门。圆满功德门者其相云何。谓真体中圆满一切功德无所少故。何等功德。所谓六种性义功德。云何为六。一者大智慧光明义。本觉般若能除无明之闇夜故。于契经中名广大圆满殊胜般若实智光明性义。二者遍照法界义。本觉般若照达一法界之源故。于契经中名周遍通达一法界藏自然性义。三者真实识知义。本觉般若远离虚假之解量故。于契经中名离妄想解决定了知实际实性性义。四者自性清净心义。本觉般若无量性功德自然本有非得他力。远离尘累契中实故。于契经中名本有明白离边中中性义。五者常乐我净义。本始二觉从无始来远离四障。圆满四种自然德故。于契经中名如来正觉自然性德远离炎幻不修行性义。六者清凉不变自在义。二种本觉譬如明镜之南北相具随违故。于契经中名具足随顺逆违无碍陀罗尼全遍性义。是名为六。如本从本已来唯性自满足一切功德。所谓自体有大智慧光明义故。遍照法界义故。真实识知义故。自性清净心义故。常乐我净义故。清凉不变自在义故。广大圆满自性本德契经中作如是说。自性功德本数之名有十七者。于初二中各开二种。于次二中各开三种。于后二中如其次第开四三故。复次清净心地无垢陀罗尼契经中作如是说。自性功德本数之名有二十五者。最后一中开十一故。如是三数别相云何。马鸣菩萨摩诃衍论本数名字。为欲显示名略义广总持相故。是故摄散总立为六。复次所依别本总持说故。复次名字数多迷真实故。以此义故总立为六。言十七者名字云何。一者大智慧义。二者大光明义。三者遍一法界义。四者照一法界义。五者真实义。六者识义。七者知义。八者自性义。九者清净义。十者心义。十一者常义。十二者乐义。十三者我义。十四者净义。十五者不义。十六者变义。十七者自在义。是名十七。言二十五者名字云何。所谓前数不功德中开八种故。变功德中开二种故。言二变者。一者上流转变。二者下流转变。言八不者。中观论中如分明说

已说有名数量功德分。次说无名过量功德分。本觉体中自性功德无量无边。离于言量过于心行。以何义故。止于数量作如是部。本有功德虽无有量不出三数。故举本耳。如本具足如是过于恒沙故。如是无量无边功德各各别别有体相耶。唯一心量无别法体。唯一心量终不离心。所以者何。心法虽一而有二种陀罗尼自在用故。云何为二。一者自不离彼陀罗尼自在。二者彼不离自陀罗尼自在。是名为二。如本不离故。如是性德从无始来。一向妙有非遣除法。所以者何。自性自性非他俱故。如本不断故。如是一切功德唯一自作一。终异自不能作一。所以者何。一法界故。如本不异故。如是深理一切菩萨一切二乘一切凡夫。心不思惟。言不论量。绝之又绝。远之又远。如本不思议故。三人非境当何人之言思境界。唯大觉者乃自轨则。如本佛法故。如是无量性之功德。从具缚地乃至无上大觉智地。具足圆满无所少阙。所以者何。如是诸德从无始来自然本有。非假缘力而建立故。如本乃至满足无有所少义故。名为如来藏亦名如来法身故

已说圆满功德门。次说问答决疑门。就此门中即有二门。云何为二。一者发起略问难违门。二者发起广答解释门。问者难意其相云何。谓举说文相违前后杂乱审其理故。前后之文云何相违。所谓真如决择分中作如是说。心真如者。即是一法界大总相法门体。所谓心性不生不灭。一切诸法唯依妄念而有差别。若离心念则无一切境界之相。是故一切法从本已来离言说相。离名字相。离心缘相。毕竟平等无有变异不可破坏。唯是一心故名真如。自相大义决择分中作如是说。从本已来性自满足一切功德。所谓自体有大智慧光明义故。遍照法界义故。真实识知义故。自性清净心义故。常乐我净义故。清凉不变自在义故。具足如是过于恒沙不离不断不异不思议佛法。乃至满足无有所少义故。名为如来藏。亦名如来法身。如是相违故以为难。如本问曰上说真如其体平等离一切相云何复说体有如是种种功德故

已说发起略问难违门。次说发起广答解释门。就此门中即有二门。云何为二。一者是总。二者是别。于总门中即有二种。云何为二。一者真如总。二者生灭总。如其次第说相可见。答曰。虽实有此诸功德义而无差别之相等同一味唯一真如者。即是真如总。谓虽自相大义门中作如是说。具种种德过于恒沙。而是生灭门之界量。非真如门。真如门中无差别相。平等平等一相一味。独存真如净法界故。以此义故无相违过。自此已下作其缘由决断疑惑。以无分别离分别相是故无二者。真如门中唯有同同无异异故。自此已下释生灭总。于此文中即有二种。云何为二。一者是问。二者是答。有广略故。二重问答不同应知。初重问答其相云何。复以何义得说差别者。即是开问。谓若诸法从本已来。平等平等一味一相独存真理无二体者。复有何法而非平等。以之为依建立差别。即是举异门以疑异门焉。自此已下发起答说决断此疑。文相可见。以依业识生灭相示者。即是总答。谓真如门中无过恒沙一切染法以为所治。无能治之过于恒沙一切净法以为对量。是故真如门中作如是说。一切诸法平等平等。一味一相无有二体等焉。而此生灭门中所治染法无量无边。能治之净法亦无量无边。是故生灭门中作如是说。本觉体中具种种德。无量无边过恒沙等焉。即是大意。次当作释别别散说。所言依者。即是根本无明住地。一切染法之所依故。所言业者。即是业相。所言识者。转等诸识。生灭相者。门之总称。所言示者。相反显示。此中以字远流应至于三字。如是三法功德之起当缘由故。已说略说分。次说广说分。就此分中即有二种。云何为二。一者是问。二者是答。此中问略答广应知。此云何示者。即是诘问。所谓诘问其所由故。自此已下直答此问。此答释中即有三种。云何为三。一者自宗正理。二者非道邪行。三者具举对量。是名为三。如其次第。说相应观。以一切法本来唯心实无于念者。即是第一自宗正理。所谓法性从无始来唯是一心。无一一法而非心故。而有妄心不觉起念见诸境界故说无明者。即是第二非道邪行。所谓总举本上之诸无明住地故。自此已下直显具举对量差别。如上所说本觉体中六相功德。各各待观何等过患。以之为对建立显示。所谓根本无明熏习一心之海。发起业等种种诸识。隐覆般若实智之明。增长愚痴迷乱之闇。即是不觉无明之界量明以之为对。一心之性寂灭无起。即是本觉惠明之安立德故。建立显示。如本心性无起即是大智慧光明义故故。自此已下显第二德。文相可见。如是妄心起见达境。一向唯转虚妄境中。不能通达真实境界。所以者何。真伪相违不契当故。如本若心起见则有不见之相故。自此已下明遍观义。而真实心离转见故。通达诸法无所不至。无所不当无所不尽。所以者何。真实智见离能见所见之边见故。如本心性离见即是遍照法界义故故。自此已下明第三德。所谓若心有动转相。即是无明熏习气故。虚妄转明以之为对。心性寂静无有喧动。正直无有颠倒之解。即是实智之照。随顺道理无倒建立显示。如本若心有动非真识智故。自此已下显第四德。所谓妄法从无始来。无自体明以之为对。自性清净本有功德建立显示。如本无有自性故。自此已下显第五德。所谓妄法四相之所迁故非常。三种苦俱转故非乐。二种自在无故非我。一道清净无故非净。此四种过以为对量。本觉体中四种功德建立显示。如本非常非乐非我非净故。自此已下显第六德。所谓妄法烧真心故。是故名热。又是恼乱诸众生故。是故名恼。破灭变德令不作故。是故衰变。由此事故一切众生不得自在。是故亦名为不自在。待观此事以为对故。清凉不变自在之德建立显示。如本热恼衰变则不自在故。自此已下显示无边功德相义。所谓若所对治染法无量无数。以能治之净法亦无量无边故。如本乃至具有过恒沙等妄染之义对此义故心性无动则有过恒沙等诸净功德相义示现故。自此已下结圆满德。所谓若一心法有动转相。更前见境有可缘者。能见之心所见之境二差别故。本觉功德则不圆满。而本性德虽过恒沙。唯一心量终无二体。所以者何。如是诸德悉皆各各不分其体。于一法界其量等故。是故圆满自性功德。结缚解脱之二位中。常恒具足名为法身。名如来藏。如本若心有起更见前法可念者则有所少如是净法无量功德即是一心更无所念是故满足名为法身如来之藏故。染净数量平等决择依何契经所解释耶。所谓文殊师利善巧方便相似譬喻大陀罗尼经。彼契经中如何说耶。谓彼经中作如是说。尔时文殊师利承佛神力。即说嗢拖南颂曰

  譬如阿只多　　遮那尸帝树
  其果多无数　　表实有十等
  染净数量等　　亦应如是知
  行者依此喻　　可了真妄理

今此经文为明何义。为欲显示假当待实真定赖妄。无有独孤自立法故。所言表者喻于何法。谓喻妄法。妄假无实如果外故。所言实者喻于何法。谓喻真法。真实无假如果中故。云何名为十种等耶。一者数等表实。契当其数等故。二者尘等表实。细末配其数量等无差别故。三者量等表实。称量终无差别轻重等故。四者色等表实。挍量同白色故。五者香等表实。熏习其香等故。六者味等表实。啖食无差别故。七者触等表实。触身等无差别故。八者本等表实。同依树木出故。九者俱等表实。一时无前后故。十者同等。终一味故。是名十等。举喻合法说相明故不须重释。复次若钝根者不达此事。依功德黑暗之譬喻应知等意

已说显示自相大义门。次说显示自用大义门。此中六门。如其次第应审观察。言本愿无尽门者。清净僧那阿世耶。广大圆满无边际故。谓诸如来无量无边不可思议不可称量微尘数劫中。兴十方世界之微尘数量大慈悲心海。修十方世界之微尘数量大圆满因海。摄十方世界之微尘数量一切众生海。立十方世界之微尘数量广大誓愿海。成十方世界之微尘数量大自在果海故。所以者何。以如实知同一无异相续义故。如本复次真如用者所谓诸佛如来本在因地发大慈悲修诸波罗蜜。摄化众生立大誓愿。尽欲度脱等众生界。亦不限劫数尽于未来。以取一切众生如己身故故

已说本愿无尽门。次说离相不着门。言离相不着门者。于所作中远离所作不生着故。谓诸如来虽发无量无边大悲摄化一切恒沙众生。而诸如来无一一佛而摄生故。所以者何。如实了知一切众生及与自身。唯一真如唯一法身。无有增减无差别故。如本而亦不取众生相。此以何义。谓如实知一切众生及与己身真如平等故

已说离相不着门。次说能所平等门。言能所平等门者。人法体用理智平等无差别故。谓法身应化之三身。及实实假假之二理。平等一体无差别故。自性本身及枝末身。一等一体无差别故。能证正智所证如理。平等一体无差别故。以一体故无有二体。无二体故亦无一体。无二无一亦无无耳。以此义故自然本性。具足功德不假他力。甚深极妙契经中作如是说。尔时文殊师利即白佛言。云何名为异异异相。云何名为同同同相。佛言所言异异异相者。即是无明。所言同同同相者。即是明法。如是二法如牛两角。对治之相非消融体如两空绝。是故此二法名曰为非观伪法。于此文殊师利即承佛神力。即从坐起白佛言。世尊云何名为非观伪法。其相可说耶不可说耶。以何为门应觉知耶。尔时世尊即告文殊师利言。我诸一切契经海中作如是说。异者无明同者明者。为欲度脱愚痴凡夫权作此说。而今日为汝真实言说。文殊师利。所言非观伪法者。同异归同。同同归空。空空归绝。乃至广说故。如本以有如是大方便智除灭无明见本法身自然而有不思议业种种之用即与真如等遍一切处故

已说能所平等门。次说无相现应门。言无相现应门者。自性身体空寂无像。能现诸像。譬如兔角自体空无。善能出生一切角故。谓法身佛唯是一一。唯是寂寂。亦非一一。亦非寂寂心行处灭。言语道断。灭灭断断唯阿作阿故。所以者何。诸佛如来唯自自身无他身故。而诸众生见闻得益。自心量中获得利益。法身体中无有关故。如本又亦无有用相可得。何以故。谓诸佛如来唯是法身智相之身。第一义谛无有世谛境界离于施作。但随众生见闻得益故说为用故

已说无相现应门。次说随见粗细门。就此门中即有二门。云何为二。一者应身用相差别门。二者报身用相差别门。初门云何。所谓一切凡夫二乘。不能了达一切诸法唯一心之量甚深宗故。依遍分别妄想事识。见应化身作外量解。不能通达无有分界。分分转故。如本此用有二种。云何为二。一者依分别事识凡夫二乘心所见者名为应身。以不知转识现故见从外来取色分齐不能尽知故故。次门云何。所谓从初信解乃至金刚一切菩萨。明了通达一切诸法唯一心量甚深宗故。依彼业识见报身佛。作唯识解。通达依正无分齐故。如本二者依于业识。谓诸菩萨从初发意。乃至菩萨究竟地心所见者名为报身。身有无量色。色有无量相。相有无量好。所住依果亦有无量种种庄严。随所示现。即无有边不可穷尽离分齐相。随其所应常能住持不毁不失故。自此已下显示报应之差别相。所言报者。具胜妙因受极乐果。自然自在决定安乐。远离苦相故名为报。如本如是功德。皆因诸波罗蜜等。无漏行熏及不思议熏之所成就。具足无量乐相故说为报故。所言应者。随顺机根而不相违。随时随处随趣出现。非安乐相故名为应。如本又凡夫所见者是其粗色。随于六道。各见不同种种异类非受乐相故说为应故。自此已下更作重释明前所说。所谓位位各各见佛增减别故。此义云何。若三贤位诸菩萨者。信真如故。分见报身。观知色相无分际量。而此菩萨不能离脱分别之心。所以者何。以未得入真如位故。如本复次初发意菩萨所见者。以深乐信真如法故。少分而见知彼色相庄严等事。无来无去。离于分齐唯依心现不离真如。然此菩萨犹自分别以未入法身位故故。若得十地诸菩萨者。如其次第转胜究竟。如本若得净心所见微妙其用转胜乃至菩萨地尽见之究竟故。若佛果中业识本种无所有故。能见所见亦复空无。所以者何。一切诸佛真如真如平等平等。法身法身平等平等。无此无彼无我无他。无大无小无高无下。无无无有戏论都尽虑知亦空。唯一大空真如本智。服遮伽利娑那提衣。于键尸多陀摩宫。自性身坐独存无二故。如本若离业识则无见相以诸佛法身无有彼此色相迭相见故。何故应身章中作如是说。依分别事识而见彼佛。报身章中作如是说。依于业识而见彼佛为欲显示随识粗细所见佛身随粗细故

已说随见粗细门。次说问答决疑门。于此有二。云何为二。一者是问。二者是答。答说分中即有五门。云何为五。一者法身出现色相门。二者显示智身形相门。三者显示法身形相门。四者广大圆满无际门。五者不可思议殊胜门。是名为五。如其次第说相可观。问者意乐其相云何。所谓问者作如是疑。克其法身真实自体。湛湛虑绝寂寂名断。色相作业由谁而有。无相现应决择分中作如是说。法身无相能现色相。若能出现种种色相。不可言说法身空寂离色像域。如是疑故发起此问。如本问曰若诸佛法身离于色相者云何能现色相故。自此已下即决此疑。言法身出现色相门者。自性法身能为色相作所依止。善出色相无障碍故。所以者何。能依色法所依心法。从无始来平等平等无有二体。唯一心量故。如本答曰即此法身是色体故能现于色所谓从本已来色心不二故。言显示智身形相门者。以智摄色。无一一色而非智故。说名智身。如本以色性即智故色体无形说名智身故。言显示法身形相门者。以色摄智。无一一智而非色故说名法身。如本以智性即色故说名法身故。言广大圆满无际门者。如是二身所现色相。等遍一切众生界一切非情界一切虚空界一切涅盘界一切如来界中。无所不通。无所不至。无所不当。无所不会。无所不作。亦无分际。亦无障碍。纯纯一一无相乱故。如本遍一切处所现之色无有分际随心能示十方世界无量菩萨无量报身无量庄严各各差别皆无分际而不相妨故。言不可思议殊胜门者。如是业用甚深极妙独尊殊胜。非凡夫二乘之所能知故。如本此非心识分别能知以真如自在用义故故。如是三种甚深大义。二种门中云何安立。谓真如门中三种大义者。唯各立一。无双立故。若生灭门中三种大义者。三种大义具足双立。无前后故。以之为别。是故大印陀罗网譬喻契经中作如是说。有体大义无相及用。有相大义无体及用。有用大义无体及相。如是三大有第一一无第二一。复次有体大义当有相用有相大义当有体用有用大义当有体相。如是三大随有第一一有第二一。不相舍离故。余种种相结总持决择分中自当理明

已说显示三种大义门。次说门自入门破异门

本曰。复次显示从生灭门即入真如门。所谓推求五阴色之与心六尘境界。毕竟无念。以心无形相。十方求之终不可得。如人迷故谓东为西方实不转。众生亦尔。无明迷故谓心为念心实不动。若能观察知心无起。即得随顺入真如门故

论曰。今此论文为明何义。为欲对治广狭大小诸异执故。云何异执。谓有众生作如是执。一法界心是其本法。亦广亦大。真妄二门是其末法。亦狭亦小。为欲对治此执着故作如是说。门亦所入。与本量等。复次为欲显示真如门中。无有为法差别相故。复次为欲显示空五阴智。如所空阴自体空无。以此能空所空皆空。为入真如平等门故。复次为欲显示生灭门假真如门实故。如本复次显示从生灭门即入真如门所谓推求五阴色之与心六尘境界毕竟无念以心无形相十方求之终不可得故。以何义故。譬喻门中东方喻觉。西方喻念。为欲显示本觉般若。出现清净智慧光明。照耀幽冥生死暗夜。譬如日轮出现已讫。发净光明破世间闇。无明住地出生种种染法眷属。隐覆无量无漏之性清净慧明。譬如日轮隐没已讫。发大暗夜障覆分别了知清净明故。如本如人迷故谓东为西方实不转众生亦尔。无明迷故谓心为念心实不动故。自此已下明得益相。谓有众生了知心法无有能起所起别相即得成就真如随顺。即得成就真如得入。无有随顺无得入故。如本若能观察知心无起即得随顺入真如门故故

已说门自入门破异门。次说对治邪执正解门

本曰。对治邪执者。一切邪执皆依我见。若离于我则无邪执。是我见有二种。云何为二。一者人我见。二者法我见。人我见者。依诸凡夫。说有五种。云何为五。一者闻修多罗说如来法身毕竟寂寞犹如虚空。以其不知为破着故。即谓虚空是如来性。云何对治。明虚空相是其妄法。体无不实。以对色故有是可见相令心生灭。以一切色法本来是心实无外色。若无色者则无虚空之相。所谓一切境界唯心。妄起故有。若心离于妄动。则一切境界灭。唯一真心无所不遍。此谓如来广大性智究竟之义。非如虚空相故。二者闻修多罗说世间诸法毕竟体空。乃至涅盘真如之法亦毕竟空。从本已来自空离一切相。以不知为破着故。即谓真如涅盘之性唯是其空。云何对治。明真如法身自体不空。具足无量性功德故。三者闻修多罗说如来之藏无有增减。体备一切功德之法。以不解故。即谓如来之藏有色心法自相差别。云何对治。以唯依真如义说故因生灭染义示现说差别故。四者闻修多罗说一切世间生死染法。皆依如来藏而有。一切诸法不离真如以不解故。谓如来藏自体。具有一切世间生死等法。云何对治。以如来藏从本已来。唯有过恒沙等诸净功德不离不断不异真如义故。以过恒沙等烦恼染法。唯是妄有性自本无。从无始世来。未曾与如来藏相应故。若如来藏体有妄法。而使证会永息妄者。则无是处故。五者闻修多罗说依如来藏故有生死。依如来藏故得涅盘。以不解故。谓众生有始。以见始故。复谓如来所得涅盘有其终尽还作众生。云何对治。以如来藏无前际故。无明之相亦无有始。若说三界外更有众生始起者。即是外道经说。又如来藏无有后际。诸佛所得涅盘与之相应。则无后际故。法我见者。依二乘钝根故。如来但为说人无我。以说不究竟。见有五阴生灭之法。怖畏生死妄取涅盘。云何对治。以五阴法自性不生。则无有灭本来涅盘故。复次究竟离妄执者。当知染法净法皆悉相待。无有自相可说。是故一切法。从本已来非色非心。非智非识非有非无。毕竟不可说相。而有言说者。当知如来善巧方便。假以言说引导众生。其旨趣者皆为离念归于真如。以念一切法令心生灭不入实智故

论曰。即此文中自有四门。云何为四。一者显示根本总相门。二者显示人见对治门。三者显示法见对治门。四者显示俱非绝离门。是名为四。言显示根本总相门者。无量无边过恒沙数一切邪道。无量无边过恒沙数一切定执。皆以我见为自所依。出生增长更无有余。为此邪执作根本故。是故无明住地无边际契经中作如是说。一切无量种种虚妄邪论之海。以我见岳为依而转。譬如一切无量无边。种种林树种种草木。皆悉以山为依而转故。如本对治邪执者一切邪执皆依我见。若离于我则无邪执。是我见有二种。云何为二。一者人我见。二者法我见故

已说显示根本总相门。次说显示人见对治门。言显示人见对治门者。直为对治邪定聚及不定聚一切凡夫谬执过失生胜妙解故。五种人见治障别相。文相明故不须重释。复次无大要故。如本人我见者。依诸凡夫说有五种乃至广说。又如来藏无有后际。诸佛所得涅盘与之相应则无后际故故

已说显示人见对治门。次说显示法见对治门。言显示法见对治门者。直为对治二乘众生实有过失。令得成就法空大理故。二种法见治障别相。文相明故不须重释。如本法我见者依二乘钝根故。如来但为说人无我。乃至广说则无有灭本来涅盘故故

已说显示法见对治门。次说显示俱非绝离门。言显示俱非绝离门者。若有众生除遣二执证得二空。通达诸法言语道断心行处灭。断断照寂灭灭虑止无所达故。如本复次究竟离妄执者。当知染法净法皆悉相待无有自相可说。是故一切法从本已来。非色非心非智非识非有非无毕竟不可说相。乃至广说令心生灭不入实智故故

释摩诃衍论卷第六释摩诃衍论卷第七

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

已说对治邪执正解门。次说分别发趣道相门

本曰。分别发趣道相者。谓一切诸佛所证之道。一切菩萨发心修行趣向义故。略说发心有三种。云何为三。一者信成就发心。二者解行发心。三者证发心。信成就发心者。依何等人修何等行。得信成就堪能发心。所谓依不定聚众生。有熏习善根力故。信业果报能起十善。厌生死苦欲求无上菩提。得值诸佛亲承供养修行信心。经一万劫信心成就故。诸佛菩萨教令发心。或以大悲故能自发心。或因正法欲灭。以护法因缘故能自发心。如是信心成就得发心者。入正定聚毕竟不退。名住如来种中正因相应。若有众生善根微少。久远已来烦恼深厚。虽值于佛亦得供养。然起人天种子。或起二乘种子。设有求大乘者。根则不定。若进若退。或有供养诸佛。未经一万劫。于中遇缘亦有发心。所谓见佛色相而发其心。或因供养众僧而发其心。或因二乘之人教令发心。或学他发心。如是等发心悉皆不定。遇恶因缘或便退失堕二乘地。复次信成就发心者。发何等心。略说有三种。云何为三。一者直心。正念真如法故。二者深心。乐集一切诸善行故。三者大悲心。欲拔一切众生苦故。问曰。上说法界一相佛体无二。何故不唯念真如。复假求学诸善之行。答曰。譬如大摩尼宝体性明净而有矿秽之垢。若人虽念宝性。不以方便种种磨炼终无得净。如是众生真如之法体性空净。而有无量烦恼垢染。若人虽念真如。不以方便种种修习亦无得净。以垢无量遍一切法。故修一切善行以为对治。若人修行一切善法。自然归顺真如法故。略说方便有四种。云何为四。一者行根本方便。谓观一切法自性无生离于妄见。不住生死。观一切法因缘和合业果不失。起于大悲修诸福德。摄化众生不住涅盘。以随顺法性无住故。二者能止方便。谓惭愧悔过。能止一切恶法不令增长。以随顺法性离诸过故。三者发起善根增长方便。谓勤供养礼拜三宝。赞叹随喜劝请诸佛。以爱敬三宝淳厚心故。信得增长。乃能志求无上之道。又因佛法僧力所护故。能消业障善根不退。以随顺法性离痴障故。四者大愿平等方便。所谓发愿尽于未来。化度一切众生使无有余。皆令究竟无余涅盘。以随顺法性无断绝故。法性广大遍一切众生平等无二。不念彼此究竟寂灭故。菩萨发是心故。则得少分见于法身以见法身故。随其愿力能现八种利益众生。所谓从兜率天退。入胎住胎出胎出家成道。转法轮入于涅槃。然是菩萨未名法身。以其过去无量世来。有漏之业未能决断。随其所生与微苦相应。亦非业系。以有大顺自在力故。如修多罗中或说有退堕恶趣者。非其实退。但为初学菩萨未入正位。而懈怠者恐怖令使勇猛故。又是菩萨一发心后远离怯弱。毕竟不畏堕二乘地。若闻无量无边阿僧祇劫。勤苦难行乃得涅槃。亦不怯弱。以信知一切法从本已来自涅槃故。解行发心者。当知转胜。以是菩萨从初正信已来。于第一阿僧祇劫将欲满故。于真如法中深解现前所修离相。以知法性体无悭贪故。随顺修行檀波罗蜜。以知法性无染离五欲过故。随愿修行尸波罗蜜。以知法性无苦离嗔恼故。随顺修行羼提波罗蜜。以知法性无身心相离慢怠故。随顺修行毗梨耶波罗蜜。以知法性常定体无乱故。随顺修行禅波罗蜜。以知法性体明离无明故。随顺修行般若波罗蜜。证发心者。从净心地乃至菩萨究竟地证何境界。所谓真如。以依转识说为境界。而此证者无有境界。唯真如智名为法身。是菩萨于一念顷。能至十方无余世界。供养诸佛请转法轮。唯为开导利益众生不依文字。或示超地速成正觉。以为怯弱众生故。或说我于无量阿僧祇劫当成佛道。以为懈慢众生故。能示如是无数方便不可思议。而实菩萨种性根等。发心则等所证亦等。无有超过之法。以一切菩萨皆经三阿僧祇劫故。但随众生世界不同。所见所闻。根欲性异。故示所行亦有差别。又是菩萨发心相者。有三种心微细之相。云何为三。一者真心。无分别故。二者方便心。自然遍行利益众生故。三者业识心。微细起灭故。又是菩萨功德成满。于色究竟处。示一切世间最高大身。谓以一念相应慧无明顿尽。名一切种智。自然而有不思议业。能现十方利益众生。问曰。虚空无边故世界无边。世界无边故众生无边。众生无边故心行差别亦复无边。如是境界不可分齐。难知难解。若无明断无有心想。云何能了名一切种智。答曰一切境界本来一心离于想念。以众生妄见境界故。心有分齐。以妄起想念不称法性故。不能了知。诸佛如来离于见想无所不遍。心真实故。即是诸法之性。自体显照一切妄法。有大智用无量方便。随诸众生所应得解。皆能开示种种法义。是故得名一切种智。问曰。若诸佛有自然业。能现一切处利益众生者。一切众生若见其身若睹神变。若闻其说无不得利。云何世间多不能见。答曰诸佛如来法身。平等遍一切处无有作意。故说自然。但依众生心现。众生心者犹如于镜。镜若有垢色像不现。如是众生心若有垢。法身不现故

论曰。即此文中自有二门。云何为二。一者总标总说门。二者别释散说门。是名为二。第二门中自有三门。云何为三。一者三种发心分剖门。二者发起问答决疑门。三者因论生论问答门。是名为三。说相可观。言总标总说门者。为欲显示即此分别发趣道相门中。无量无边三世诸佛。所誓愿海所行因海。所证果海所化徒海。无量无边三世一切诸菩萨众。如是如是如如随践顺行应转。如其次第不超数量不过位地趣入义故。复次为欲显示如一切诸佛无趣向则。一切菩萨于彼无有趣向则中如如行故。如本分别发趣道相者谓一切诸佛所证之道。一切菩萨发心修行趣向义故故。已说总标总说门。次说别释散说门。此中三门。如其次第应审思择。就第一三种发心分剖门中即有三种故。自有三种门。云何为三。一者信成就发心门。二者解行发心门。三者证得发心门。是名为三。如本略说发心有三种。云何为三。一者信成就发心。二者解行发心。三者证发心故。就初门中即有三门。云何为三。一者发起开问总标门。二者显示答释广说门。三者发起问答决疑门。是名为三。第一二门有二种重。应审观察。就第一发起开问总标门中即有四意。云何为四。一者假者意。问能修人故。二者行相意。问所修行故。三者自分意。问得成就故。四者向上意。问胜进相故。是名为四。如本信成就发心者。依何等人。修何等行。得信成就堪能发心故

已说发起开问总标门。次说显示答释广说门。就此门中即有二门。云何为二。一者随问次第答释门。二者举劣显胜生解门。是名为二。就随问次第答释门中即有六门。云何为六。一者显示修行假者门。二者自然本有熏习门。三者显示修行功能门。四者信心成就时量门。五者显示发心因缘门。六者显示得益位胜门。是名为六。言显示修行假者门者。谓虽所化众生无量无边。而今此处中且取不定聚摄十信众生故。所以者何。为欲令使化不定聚三品众生。十种信心具足成就。决定安立十住菩萨初发心住。金刚不变之位中故。如本所谓依不定聚众生故。言自然本有熏习门者。谓如是众生相续中。从无始世来。常有本觉藏佛。众生善根常恒熏习令增长故。如本有熏习善根力故。言显示修行功能门者。谓不定聚种种众生。信因业果报似有不空因缘和合之道理故。知十恶过失。起不应作意。观十善功德。起当应作意。厌系缚地求解脱城。渐渐出离向菩提故。如本信业果报能起十善厌生死苦欲求无上菩提得值诸佛亲承供养修行信心故。言信心成就时量门者。谓显示其信心成就。时节远近差别相故。即此门中十五契经各各异说。云何名为十五异说。一者一切诸法因缘无主契经中作如是说。尔时文殊师利即白佛言。尊者从具缚地入不定聚。一切行者经几时节。十种信心具足成就。渐渐转胜定不退位。于是尊者告文殊师利言。善男子谛听谛听善思念之。我当为汝解说信成就时节分际。善男子一切行者从具缚地入不定聚经一万三千劫已讫。即便成就十种信心。决定菩萨初发心住。二者摄无量大乘契经中作如是说。复次佛子信地假名菩萨。六万四千劫量已满。即便成就十爱乐心定金刚地。三者慧明陀罗尼契经中作。如是说。不定聚众生多经八万一千五十劫已讫。信心成就决定不退。四者法门名字契经中作如是说。复次信乐地位毛头凡夫。经二万六千劫已讫。便信成就无所阙失。五者清净三昧契经中作如是说。若有众生入难角地修行信心。当九万劫满足已讫信品成就。六者金刚陀罗尼契经中作如是说。信成就量四万八千六十劫量。七者大智慧光明契经中作如是说。复次善男子。若有众生为欲成就功德善根父母天地。当经十刹那量已讫。即便信地平坦无草。八者实相本际决定不动契经中作如是说。信位成就。信心发起初刹那中。十种信心具足圆满。九者文殊师利圆满因海大总持契经中作如是说。三阿僧祇大无量劫经过已讫。即便信位具足成立。十者甚深菩提因缘契经中作如是说。建立信地唯三万劫。十一者大方便智善巧契经中作如是说。信行菩萨九千劫量。决定成就清净信心其思极乐。十二者菩萨光明遍照契经中作如是说。尔时金刚慧菩萨摩诃萨即白佛言。世尊无上菩提初种子地。经几时节决定淳熟。菩提之芽出生增长。佛言若为成就初种子地。当经七万五千六十劫。初种子地具足建立。十三者授记平等契经中作如是说。信心成就非远非近非无非有。非高非下非本非末。非去非来非大非小。非三世非非三世非位非地。非善非恶非非非是。言语道断心行处灭。是故名为真实信心。十四者如来藏本识契经中作如是说。尔时地藏菩萨摩诃萨即白佛言。世尊云何名为广大圆满功德父母信地品耶。佛言。十信十信十解十信。十行十信十向十信。十地十信佛地十信。乃至具缚恶种子地。及一切二乘皆悉十信。无量无边一切诸法。无一一法而非十信。以此义故名为广大圆满信地。十五者菩萨缨络大本业契经中作如是说。信想菩萨于十千劫行十善法。决定安立信成就处。是名十五异说契经。如是诸经以何义故如是差别。谓众生心无量无边各差别故。随其心品说信行相如是不同。应审思择。今此文中且依本业解释而已。如本经一万劫信心成就故故。言显示发心因缘门者。谓已信心成就行者。为欲发起第一住心。当待缘力而发起故。于此文中自有三种。云何为三。一者劝请因缘。二者救度因缘。三者护法因缘。是名为三。言劝请因缘者。所谓无量无边一切诸佛及大菩萨众。出现种种胜妙教法契经之海。信位行者劝请教化。超不定地。决定安立不动域故。如本诸佛菩萨教令发心故言救度因缘者。所谓缘无量无边种种众生之一切苦海。以之为因发起金刚不退广大清净大慈悲心故。如本或以大悲故能自发心故。言护法因缘者。所谓诸佛教法欲破灭时。以种种方便随宜随应随当。随时随处不惜身命。救护佛法大因缘之力故。自能发起金刚不退广大清净大久住心故。如本或因正法欲灭以护法因缘故能自发心故。言显示得益位胜门者。所谓信成就得解行者。具足十名无退失故。云何为十。一者名为无忧恼人。远离退还堕于凡夫具缚烦恼地怖畏心故。二者名为大富贵人。蠲除烦恼之荒。收藏涅盘之果故。三者名为种性高胜人。远离凡夫之下劣种。已入如来尊高种性中故。四者名为手足具备人。执般若炬游行法界广大庭故。五者名为作大江水人。无碍直流入萨婆若之大海中故。六者名为宫殿建立人。已超不定地决定安住如来家中故。七者名为真实佛子人。远离凡胎已入圣胎故。八者名为大福田人。出离烦恼独清净故。九者名为徒众无量人。法界众生皆悉以为自眷属故。十者名为无障碍人。随心转故。是名为十。如本如是信心成就得发心者入正定聚毕竟不退名住如来种中正因相应故

已说随问次第答释门。次说举劣显胜生解门。就此门中即有二门。云何为二。一者举劣显劣形相门。二者举胜显胜形相门。是名为二。言举劣显劣形相门者。所谓善根微薄烦恼深厚凡夫众生。虽值摩诃衍之因缘。而起小善根种子故。如本若有众生善根微少久远已来烦恼深厚虽值于佛亦得供养然起人天种子或起二乘种子故。言举胜显胜形相门者。所谓若有众生求摩诃衍之甚深微妙法门。其心即便不能决定。值顺因缘恍惚若进。遇逆因缘自然若退。无定心故。如本设有求大乘者根则不定若进若退故。若不能定。云何名为胜高人耶。虽不能定。而所望法极最高故复次望起天人二乘之种子故。自此已下显示信心成就无定时。解释十四经之大意焉。所谓若有众生供养诸佛。信心成就其时不定。或极极远。或极极近。或中间故。所以者何。随缘有无信熟生故。如本或有供养诸佛未经一万劫于中遇缘亦有发心故。自此已下造作别释。显示发心因缘之相。于此文中即有四种发心因缘。云何为四。一者见佛因缘。因见如来妙色之身。而能发起广大心故。如本所谓见佛色相而发其心故。二者供僧因缘。以种种具供养众僧。因此因缘而能发起广大心故。如本或因供养众僧而发其心故。三者惭愧因缘。见闻二乘之人教法惭愧其劣。因此因缘而能发起广大心故。如本或因二乘之人教令发心故。四者随兼因缘。随他兼心。因此因缘。而能发起广大心故。如本或学他发心故。是名为四。自此已下作其因缘。显示十种信心不定聚形相。及总结前所说之十信决释分焉。以何义故十种信品立不定称。所谓若值顺当因缘随向善趣。若遇逆违因缘应趣恶道。譬如经毛随风所吹东西转故。如本如是等发心悉皆不定遇恶因缘或便退失堕二乘地故

已说第一重二种门。次说第二重二种门。言复次信成就发心者发何等心者。即是发起开问总标门。谓发开问总问所为故。略说有三种者。即是总标总答焉欤。云何为三者。即是总举总问焉欤。自此已下直明显示答释广说门。就此门中即有三种。云何为三。一者正智方便门。二者福德具足门。三者安乐成就门。是名为三。于此三中初通二利。中唯自利。后唯利他。复次初二唯自利分。后一利他。复次三种皆通二故。皆悉各各具足标释。应审思择。言正智方便门者直心。为正体智有作方便故。如本一者直心正念真如法故故。言福德具足门者深心。为一切功德有作方便故。如本二者深心乐集一切诸善行故故。言安乐成就门者悲心。能善救度一切众生无量苦恼。令得安稳广大乐故。如本三者大悲心欲拔一切众生苦故故

已说第二重二种门。次说发起问答决疑门。就此门中即有二门。云何为二。一者前后相违难问门。二者开通会释消难门。是名为二。言前后相违难问门者。谓举上下之二文相违。难其差别相故。云何相违。谓上文中作如是说。所言觉义者谓心体离念相离念相者等虚空界无所不遍法界一相即是如来平等法身依此法身说名本觉。于下文中作如是说。二者深心乐集一切诸善行故。上下二文如是相违。是故发问难其异相。应审思择如本问曰上说法界一相佛体无二何故不唯念真如复假求学诸善行故

已说前后相违难问门。次说开通会释消难门。就此门中即有七门。云何为七。一者正答决断彼难门。二者修善行者得益门。三者修行善巧方便门。四者显示发心功德门。五者拣择上下显异门。六者通契经文决疑门。七者赞叹发心功德门。是名为七。就初门中即有三门。云何为三。一者开示譬喻善巧门。二者合说契当安立门。三者显示法说生解门。是名为三。就譬喻门中即有四种。云何为四。一者宝喻。二者性净喻。三者垢染喻。四者人众喻。是名为四。言宝喻者。谓即大摩尼珠之宝。如是珠宝当有何处。如是珠宝当有黄石。如是珠宝其色如何。谓深黄色。其身形相当如何耶。谓如方座。无长短。故大小之相其量云何。谓一丈故。如是珠宝诸黄石中皆悉具足无有黄石而无摩尼。其止住相次第如何。谓第一珠。第二黄金。第三石体。此摩尼珠一丈量者。彼诸黄石或有极小或有极大。各各差别。岂可得言皆遍一切。此摩尼珠有殊胜力虽一丈量。遍于大中小中无余无所障碍。亦可得说遍一切处。于彼石中有此宝故。其石色黄应审观察。是名宝喻。如本答曰譬如大摩尼宝故。言性净喻者。如是珠宝其体性甚极明白。远离尘累故。是名为性净喻。如本体性明净故。言垢染喻者。如是珠宝能为金石等之所障。不能出现明白相故。是名为垢染喻。如本而有矿秽之垢故。言人众喻者。谓极穷贫极懈怠故。不求宝人。并及精进乐求宝人故。是名为人众喻。如本若人虽念宝性不以方便种种磨炼终无得净故

已说开示譬喻善巧门。次说合说契当安立门。宝喻中言大摩尼珠者。当喻何法。喻本觉佛性故。所以者何。本觉佛性隐藏众生相续身中。似彼珠故。言黄石者当喻何法。喻一切众生相续故。所以者何诸众生身藏裹佛性似彼石故。言色黄者当喻何法。喻彼佛性不变义故。所以者何真如佛性坚固不改似彼金故。言如方座无长短者。当喻何法。喻真如法平等无增减故。所以者何。此真如法一味平等。无有差别似彼座故。言一丈者当喻何法。喻真如法具足圆满无阙失故。所以者何。真如法身具足万德无所阙失。似彼丈故。言如是珠宝得黄石中皆悉具足。无有黄石而无摩尼者当喻何法。喻真如性遍诸众生种种身中。无有众生而无真如本觉性故。所以者何。此真如性离不遍过似彼珠故。言第一珠第二黄金第三石体者。当喻何法。喻俱有次第法渐渐粗现故。所以者何。从本觉智流转。建立四相海时。如其次第渐渐粗现似彼三故。言此摩尼珠有殊胜力虽一丈量。遍于大中小中无余者。当喻何法。喻真如本觉有不思议业。遍蚊龙等小大身中无妨难故。所以者何。此真如法其性平等。遍凡圣中似彼珠故。言于彼石中有此宝故其石色黄者。当喻何法。喻诸众生悉有本觉有心相故。所以者何。一切众生有觉心故有了别识似彼石故

已说宝喻合说契当门。次说净喻合说契当门。言如是珠宝其体性甚极明白远离尘累者。当喻何法。喻性净本觉清净明白离垢故

已说净喻合说契当门。次说染喻合说契当门。言如是珠宝能为金石等之所障不能出现明白相者。当喻何法。喻自性清净心。为无明之沂隐覆。不能出现无漏性德故

已说染喻合说契当门。次说人喻合说契当门。言二种人者当喻何法。喻求佛法宝极精进人极懈怠人故。如本如是众生故

已说合说契当安立门。次说显示法说生解门。于此门中如其次第。法说合喻生行者解应审思释。文相明故不须别释。如本真如之法体性空净而有无量烦恼染垢。若人虽念真如不以方便种种修习亦无得净以垢无量无边遍一切法故修一切善行以为对治故

已说正答决断彼难门。次说修善行者得益门。谓若有众生断一切恶修一切善。自然自在得真如三昧照达无明之闇夜。无所疑畏故。如本若人修行一切善法自然归顺真如法故故

已说修善行者得益门。次说修行善巧方便门。就此门中故有四门。云何为四。一者一切修行根本门。二者制伏恶业不生门。三者出生善根增长门。四者誓愿无边平等门。是名为四。如本略说方便有四种故。就第一门中即有二门。云何为二。一者般若成就无住门。二者大悲成就无住门。是名为二。言般若成就无住门者。所谓观察一切诸法。从本已来不生不灭。毕竟寂灭皆无所有。不住生死故。如本云何为四一者行根本方便谓观一切法自性无生离于妄见不住生死故。言大悲成就无住门者。所谓观察一切诸法因缘和合故。因果不空业报亦有。缘无量无边众生界之海。为究竟取摄不住涅盘故。如本观一切法因缘和合业果不失起于大悲修诸福德摄化众生不住涅盘故以随顺法性无住故者。即是示缘及结两种不住道行。修行法门虽无有量。而不住道其最根本。是故说言行根本方便焉

已说一切修行根本门。次说制伏恶业不生门。此门为明何义。为欲显示行者当发起惭愧等清净心品。防止一切无量恶作。渐渐损灭不令增长故。如本二者能止方便谓惭愧悔过能止一切恶法不令增长故以随顺法性离诸过故者。总结其缘

已说制伏恶业不生门。次说出生善根增长门。此门为明何义。为欲显示行者当一切三宝恭敬供养。礼拜赞叹随喜劝请。增长信心消除业障。志求无上大菩提故。如本三者发起善根增长方便谓勤供养礼拜三宝赞叹随喜劝请诸佛以爱敬三宝淳厚心故信得增长乃能志求无上之道又因佛法僧力所护故能消业障善根不退故。以随顺法性离痴障故者。总结其缘

已说出生善根增长门。次说誓愿无边平等门。此门为明何义。为欲显示行者当发起十方世界之尘数广大誓愿海。修习十方世界之尘数行因海。摄取十方世界之尘数众生海。成就十方世界之尘数果满海。一切皆悉无有余故。如本四者大愿平等方便所谓发愿尽于未来化度一切众生使无有余皆令究竟无余涅盘故。以随顺法性无断绝故者。总结其缘。自此已下显示随顺殊胜之相。以何义故。四门结中皆悉通名随顺法性。为欲显示法性虚空。其体性广大圆满无有边际。其相用无碍自在无有始终。修彼四门一切行者。亦复如是顺顺如如。其阿世耶广大圆满无分际故。如本法性广大遍一切众生平等无二不念彼此究竟寂灭故故

已说修行善巧方便门。次说显示发心功德门。此文为明何义。为欲显示初发心住菩萨。起随顺法界性中广大圆满心故。相似观智见法性身。见法身故愿力自在。由愿力故缘无量无边法界之众生而起大悲心。由大悲心极甚深故。出现八种安乐化相。随时随处随宜随应。顺顺如如利益安乐故。如本菩萨发是心故则得少分见于法身以见法身故随其愿力能现八种利益众生所谓从兜率天退入胎住胎出胎出家成道转法轮入于涅盘故

已说显示发心功德门。次说拣择上下显异门。就此门中即有二门。云何为二。一者拣异地上门。二者拣异具缚门。是名为二。言拣异地上门者。谓发心住菩萨。唯名幻化影相身。不得名真如法身菩萨故。所以者何。此菩萨无始余业犹未出离。随受生处与微细苦相应不离。地上菩萨此相违。故如本然是菩萨未名法身以其过去无量世来有漏之业未能决断随其所生与微苦相应故故。言拣异具缚门者。所谓初发心住菩萨。无系缚俱转业因相。无系缚受生果报故。所以者何。大愿方便具足转故。如本亦非业系以有大愿自在力故故

已说拣择上下显异门。次说通契经文决疑门。就此门中自有五种各说契经。云何为五。一者文殊师利欢喜陀罗尼契经中作如是说。尔时文殊师利即白佛言。世尊常大众中唱如是言。五十子心庄严果海行因之本。一切行者当经此道成等正觉。如是五十子心中。几是退分几是定分。唯愿世尊为我解说。于是世尊即告文殊师利菩萨言。谛听谛听善思念之。我今为汝分别解说。善男子十种真地名为金刚般若住地。前四十心名为颇梨珠随转回向地。汝当应如是知应如是观。今此经文为明何义。为欲显示大士十地。已得真证域名不退分。自此已前四十种心。未得证智名为退分故。二者本觉大悲自然熏习契经中作如是说。复次佛子。汝前所问云何名为节退相者。此事殊胜不思议中不思议故。愚痴凡夫初发意菩萨等之所不能知尔时大明菩萨至心劝请。佛即告大明言。善男子言节退相者。谓信心。发心住。净心地。金刚心之此四处皆名为退分。各彼中间皆名为不退分。是故说言节退相焉。今此经文为明何义。为欲显示佛法大海。广大圆满无边际故。三者大证得陀罗尼契经中作如是说。十种安心决定不退无退失理。今此经文为明何义。为欲显示十住菩萨。发起随顺法界性中广大善根故。决定安住金刚位故。四者五明契经中作如是说。十种定心非退非进。非来非去非出非入。圆满万德无所阙失。是故说言自然住心。今此经文为明何义。为欲显示十住位中果德已满。更无所进复无所退。自然常住无阙事故。五者菩萨缨络大本业契经中作如是说。诸善男子。若一劫二劫乃至十劫。修行十信得入十住。是人尔时从初一住乃至第六住中。若修第六般若波罗蜜。正观现在前。复值诸佛菩萨善知识所护。出到第七住常住不退。自此七住已前名为退分。今此经文为明何义。为欲显示劝策下劣懈怠众生。为令增长勇猛心故。今此论中且据本业而作会通。应审观察。如本如修多罗中或说有退堕恶趣者非其实退。但为初学菩萨未入正位而懈怠者恐怖令使勇猛故故

已说通契经文决疑门。次说赞叹发心功德门。此门为明何义。为欲显示发心菩萨远离二怖畏。其心决定不动故。云何名为二种怖畏。一者下生怖畏。生下劣道极怖畏故。二者上生怖畏。闻殊胜境其心怯弱极怖畏故。离此二怖。是故名为发心功德。如本又是菩萨一发心后远离怯弱。毕竟不畏堕二乘地若闻无量无边阿僧祇劫勤苦难行乃得涅盘亦不怯弱故。以信知一切法从本已来自涅盘故者。即是总结二种功德之因缘焉。从上已来信成就发心决择分已焉。自此已下种种诸门。文相明故不须重释

释摩诃衍论卷第七释摩诃衍论卷第八

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

已说解释分。次说修行信心分

就此分中则有七门。云何为七。一者能治所治契当门。二者信心品类分剖门。三者修行方便善巧门。四者广释魔事对治门。五者赞叹三昧功德门。六者两轮具阙益损门。七者劝劣向胜不退门。是名为七。能治所治契当门者。其相云何

本曰。是中依未入正定聚众生故。说修行信心分

论曰。言是中依未入正定聚众生者。即是所治。所谓所化之境界故。故说修行信心分者。即是能治。所谓能化之教法故。所化境界其量云何。谓摄二聚之众生故。云何为二。一者邪定聚。二者不定聚。是名为一。所以者何。此二众生皆悉未入正定聚故。言契当者其相云何。谓二众生中各契教说故。契相云何。谓欲邪定聚众生故说信心门。欲彼不定聚众生故说修行门。所以者何。进入次第其法尔故。谓未信人先起信故。其已信人直修行故。复次通利益故

已说能治所治契当门。次说信心品类分剖门

本曰。何等信心。云何修行。略说信心有四种。云何为四。一者信根本。所谓乐念真如法故。二者信佛有无量功德。常念亲近供养恭敬发起善根。愿求一切智故。三者信法有大利益。常念修行诸波罗蜜故。四者信僧能正修行自利利他。常乐亲近诸菩萨众。求学如实行故

论曰。就此文中则有三门。云何为三。一者直问信心品类门。二者直问修行品类门。三者略答显示信心门。是名为三。言直问信心品类门者。所谓总问信心量故。如本何等信心故。言直问修行品类门者。所谓总问修行量故。如本云何修行故。就第三门中即有三门。云何为三。一者总答门。二者总问门。三者广答门。言总答门者。所谓总答其所说故。如本略说信心有四种故。言总问门者。所谓总问其所说故。如本云何为四故。就第三门中故有四种门。云何为四。一者信本令心平等门。二者信佛欣有功德门。三者信法精进修行门。四者信僧令心无诤门。是名为四。言信本令心平等门者。所谓乐信为自根本真如理法。由无明力种种差别。一切诸心皆悉会一令平等故。如本一者信根本所谓乐念真如法故故。言信佛欣有功德门者。所谓乐信无上大觉如来世尊。欣求所有无量无边一切功德故。如本二者信佛有无量功德常念亲近供养恭敬发起善根愿求一切智故故。言信法精进修行门者。所谓乐信三世诸佛。为自恩父为自恩母为自恩师。不能改坏不能生灭。虚空金刚不动轨则。有不可思议中不可思议殊胜利益。常恒转转于一切时于一切处。修行一切助道品故。如本三者信法有大利益常念修行诸波罗蜜故故。言信僧令心无诤门者。所谓乐信一切无量菩萨僧众以两胜行为自内德。若远若近随自闻时随自见时。随自思时往诣僧所。至心听受种种深法种种深经。种种深论种种深理。种种妙事不断绝故。如本四者信僧能正修行自利利他常乐亲近诸菩萨众求学如实行故故

已说信心品类分剖门。次说修行方便善巧门

本曰。修行有五门能成此信。云何为五。一者施门。二者戒门。三者忍门。四者进门。五者止观门。云何修行施门。若见一切来求索者。所有财物随力施与。以自舍悭贪令彼欢喜。若见厄难恐怖危逼。随己堪任施与无畏。若有众生来求法者。随己能解方便为说。不应贪求名利恭敬。唯念自利利他回向菩提故。云何修行戒门。所谓不杀不盗不淫。不两舌不恶口不妄言不绮语。远离贪嫉欺诈谄曲嗔恚邪见。若出家者为折伏烦恼故。亦应远离愦闹常处寂静。修习少欲知足头陀等行。乃至小罪心生怖畏惭愧改悔。不得轻于如来所制禁戒。当护讥嫌不令众生妄起过罪故。云何修行忍门。所谓应忍他人之恼心不怀报。亦当忍于利衰毁誉称讥苦乐等法故。云何修行进门。所谓于诸善事心不懈退。立志坚强远离怯弱。当念过去久远已来。虚受一切身心大苦无有利益。是故应勤修诸功德。自利利他速离众苦。复次若人虽修行信心。以从先世来多有重罪恶业障故。为魔邪诸鬼之所恼乱。或为世间事务种种牵缠。或为病苦所恼。有如是等众多障碍。是故应当勇猛精进。昼夜六时礼拜诸佛。诚心忏悔劝请随喜。回向菩提常不休废。得免诸障善根增长故。云何修行止观门。所言止者。谓止一切境界相随顺奢摩他观义故。所言观者。谓分别因缘生灭相随顺毗跋舍那观义故。云何随顺以此二义渐渐修习。不相舍离双现前故。若修止者住于静处端坐正意。不依气息不依形色不依于空不依地水火风。乃至不依见闻觉知。一切诸想随念皆除。亦遣除想以一切法本来无相。念念不生念念不灭。亦不得随心外念境界。后以心除心。心若驰散即当摄来住于正念。是正念者。当知唯心无外境界。即复此心亦无自相。念念不可得。若从坐起去来进止所作。于一切时常念方便随顺观察。久习淳熟其心得住。以心住故渐渐猛利。随顺得入真如三昧。深伏烦恼信心增长速成不退。唯除疑惑不信诽谤。重罪业障我慢懈怠。如是等人所不能入。复次依是三昧故。则知法界一相。谓一切诸佛法身。与众生身平等无二。即名一行三昧。当知真如是三昧根本。若人修行。渐渐能生无量三昧

论曰。就此文中即有五门。云何为五。一者总标答前所问门。二者通达总问所说门。三者略答建立门数门。四者略问广答散说门。五者赞叹三昧殊胜门。是名为五。言总标答前所问门者。所谓总答彼前问故。如本修行有五门能成此信故。言通达总问所说门者。所谓总问其所说故。如本云何为五故。言略答建立门数门者。所谓建立大门数故。如本一者施门二者戒门三者忍门四者进门五者止观门故。何故次第如是。谓修行六度次第法如是故。次就略问广答散说门中。故有五门故。故有五门应审观察。此五种门中各各具二门。云何为二。一者略问门。二者广答门。是名为二。如其次第不乱数量。应审思择。第一修行施门中。言云何修行施门者。即是略问门。所谓开问。故后后诸门应如是知。就广答门中即有三种施。云何为三。一者财物施。二者随应施。三者教法施。言财物施者。所谓若有众生来到我所乞我所有。则便不疑随时随处。皆悉施与无所顾惜故。何等物名为财物耶有几种物。所谓有二种财物故。云何为二。一者内物。二者外物。是名为二。就内物中亦有二种。云何为二。一者无色。二者有色。言无色者。则是心识。言有色者。即是诸根。若有众生来到我所。乞我心识。则便不惜随时施与令彼欢喜若有众生来到我所。随其所用乞我一一有色妙根。则便不惜随时施与令彼欢喜。是名为二种内财物。就外物中亦有二种。云何为二。一者有识。二者无识。言有识者。即是妻子奴婢等类。言无识者。则是宫殿舍宅衣服严具等类。若有众生来到我所乞此等物。即便不惜随时施与令彼欢喜。是名为二种外财物。如本若见一切来求索者所有财物随力施与以自舍悭贪令彼欢喜故。已说财物施。次说随应施。云何名为随应施耶。谓或有众生五根坏失不能具足。或有众生病苦无量不得安隐或有众生其心愚痴不能明了。行者尔时以贤士。则随其所应随其所当。随其所宜随其所用。能善拣择能善分别。除彼苦恼令欢喜故。是故说言随应施焉如本若见厄难恐怖危逼随己堪任施与无畏故。已说随应施。次说教法施。云何名为教法施耶。谓有众生若时不时若亲不亲。若贵不贵若愚不愚。若夫不夫若女不女。若恶不恶若人不人。如是等类来到我所。欲求法时则便不惜。发起无量无边广大圆满大慈悲心。决断彼疑。分除烦恼徐增智慧。摄取彼人不堕恶道。令到无上大菩提故。是故说言教法施焉。如本若有众生来求法者随己能解方便为说不应贪求名利恭敬唯念自利利他回向菩提故故

已说修行施门。次说修行戒门。就此门中则有四门。云何为四。一者建立戒相标宗门。二者成就戒品胜处门。三者具足戒行不轻门。四者守护不令诽谤门。是名为四。言建立戒相标宗门者。所谓建立十种清净防转戒故。如本云何修行戒门所谓不杀不盗不淫不两舌不恶口不妄语不绮语远离贪嫉欺诈谄曲嗔恚邪见故。言成就戒品胜处门者所谓若为具足戒品。常当远离散乱杂处。常当亲近寂静胜处。安住其中不舍离故。如本若出家者为折伏烦恼故亦应远离愦闹常处寂静故。言具足戒行不轻门者。所谓修行种种妙行起深信心。不得轻贱如来所制师母戒故。如本修习少欲知足头陀等行乃至小罪心生怖畏惭愧改悔不得轻于如来所制禁戒故。言守护不令诽谤门者。所谓护持佛眼睛戒。终不破失具足自利。种种放逸讥嫌众生。不令发起妄想过罪。具足利他圆满庄严大觉海故。如本当护讥嫌不令众生妄起过罪故故

已说修行戒门。次说修行忍门。就此门中即有二门。云何为二。一者显示略忍伏我门。二者显示广忍无我门。是名为二。言显示略忍伏我门者。所谓若有众生。造作恶阿世耶之境令恼我心。行者尔时其心能忍不动恼故。如本云何修行忍门所谓应忍他人之恼心不怀报故。言显示广忍无我门者。所谓或有众生。以饮食衣服等种种财物。施与我所利益欢乐。或有众生。以剑杖等种种怖相来到我所。损灭我依正令不得自在。或有众生。以粗恶诽谤等种种秽语。若远若近毁嫌于我。或有众生。以正住等种种之德赞叹我身。于如是等种种事中。其心平等坚固不动。如须弥故。如本亦当忍于利衰毁誉称讥苦乐等法故故

已说修行忍门。次说修行进门。就此门中则有二门。云何为二。一者通示修行精进门。二者别释修行精进门。言通示修行精进门者。所谓于诸种种妙事其心转胜。勤欲精进终不息故。如本云何修行进门所谓于诸善事心不懈退立志坚强远离怯弱故。就别释修行精进门中故有二门。云何为二。一者无障修行精进门。二者有障修行精进门。言无障修行精进门者。所谓行者作如是念。我从无始过去时来。唯受虚妄不实身心。都不能受金刚不坏之身心者无余因缘。唯妙行中不勤行故。我若懈怠如前不行。向未来去。亦复受都无有利益虚妄身心。无出离期。我自身尚不得出离都失自利。何况救济所余种种有苦众生具足利他。作是念已。即便发起大精进心。修行行因之海。庄严满德之果。建立两利无阙偏故。如本当念过去久远已来虚受一切身心大苦无有利益是故应勤修诸功德自利利他速离众苦故。言有障修行精进门者。所谓若有众生。有无始过去之余业障故。为魔外道及恶鬼神之所恼乱不能修行。或有众生。为现在世种种事务之所牵缠不能修行。或有众生。为一切诸种种病苦之所逼恼不能修行。如是等诸众生虽耳听闻轨则尊辞。眼中观见文教说相。而不能勤修行生厌求心。然若其心勇猛精进。发起种种胜妙方便。存堪任心。业障之海渐渐波息。功德之岳弥弥峰高。八风不飘。九结不缚故。如本复次若人虽修行信心以从先世来多有重罪恶业障故为魔邪诸鬼之所恼乱或为世间事务种种牵缠或为病苦所恼有如是等众多障碍。是故应当勇猛精勤昼夜六时礼拜诸佛诚心惭悔劝请随喜回向菩提常不休废得免诸障善根增长故故

已说修行精进门。次说修行止观门。就此门中即有四门。云何为四。一者总标总释止轮门。二者总标总释观轮门。三者略释决择随顺门。四者广释决择止轮门。是名为四。言总标总释止轮门者。谓止虑知之心。碍散乱之思。安住于一中寂静性。不出于一切境界相。随顺定标陀阿罗观义故。如本云何修行止观门所言止者谓止一切境界相随顺奢摩他观义故故。言总标总释观轮门者。谓明拣择因缘之道理。审分别无常之形相。能善通达能善遍知。随顺观标陀阿罗观义故。如本所言观者谓分别因缘生灭相随顺毗跋舍那观义故故。言略释决择随顺门者。谓定随时彼观则顺观随时中彼定即顺。具足具足不离转故。如本云何随顺以此二义。渐渐修习不相舍离双现前故故。就广释决择止轮门中即有四门。云何为四。一者成就止轮因缘门。二者直示修行止轮门。三者修行止轮得益门。四者拣入不入分际门。是名为四。就第一成就止轮因缘门中。即有十五种。云何为十五。一者住处寂静因缘。二者独一不共因缘。三者所居方善因缘。四者衣服具足因缘。五者饮食具足因缘。六者结界护净因缘。七者舍宅造立因缘。八者言语不出因缘。九者坐像造立因缘。十者坐其座中因缘。十一者出入时节因缘。十二者知识善友因缘。十三者印知邪正因缘。十四者植善林树因缘。十五者字轮服膺因缘。是名十五种大因缘言住处寂静因缘者。谓若为修彼止轮门。居山林等空闲处中。远离散乱聚落处故。所以者何。散乱处中彼止轮门难成就故。言独一不共因缘者。谓若为修彼止轮门。一界内中二人共住不得理故。所以者何。互动烦故。言所居方善因缘者。谓若为修彼止轮门。居止东西之两方中。南北方中不得居故。所以者何。有觉轮故。言衣服具足因缘者。谓若为修彼止轮门。必当用三种衣故。云何为三。一者黄色。二者赤色。三者白色。如是三衣一时用故。所以者何。毗叉罗虫不能入故。言饮食具足因缘者。谓若为修彼止轮门。必当用干练伽摩伊陀耶。所余谷等不能用故。所以者何。彼伽摩伊陀耶有仙性故

复次若无用婆尼罗等故。受用时节唯用自中。无有定故。言结界护净因缘者。谓若为修彼止轮门。离自居室一俱卢舍量中。诵一百十遍大神咒。其相云何。谓即诵咒言

[口*怛][口*姪]咃那罗帝　婆叉尼　阿摩[口*耶]迦陀帝婆婆阿阿婆婆[口*彌]陀　阇佉那　邬呵伊陀帝　奄奄奄奄帝　哆跋陀陀[口*耶]　摩那尸只帝　奢陀尼筏　叉罗尼鸠诃阿诃鸠多[口*尸]　奄[咒-几+可]陀陀帝　摩诃伽耶帝　摩诃阿伽耶帝　键多尼　阿罗罗罗罗罗罗罗罗罗罗罗阿帝娑婆呵

若诵此咒已讫。即便结界护净。所以者何。种种毒类不能入故。言舍宅造立因缘者。谓若为造修定舍宅。当具十事。云何为十。一者门户事。唯向东方非余方故。二者高下事。东方渐高西方渐下故。三者方角事。于一方中各一丈故。四者品重事。重十重故。五者作物事。唯用五种非余种故。云何为五。一者金二者银三者铜四者铁五者松木。是名为五。六者户塌事。等其地量无差别故。七者户重事。重十户故。八者户枢事。无音声故。九者壁墙事。其高一丈重十重故。十者出入事。彼诸户中各诵咒故。其相云何。谓若为出。即诵咒言

喃嚤[口*夜]帝　摩诃鸠毗那呵　阿罗婆提　陀陀阿伽度　般枳阿枳尸　遮娑[言*尼]诺帝　婆枳摩毗摩　婆枳摩阿那　阿那尸枳尼尸枳　娑婆呵

若此神咒诵一千遍。即便顺时皆悉开通。若为入时。即诵咒言

南无喃枳那　南无筏尸陀　南无諵阿帝　南无諵阿唎那　南无键陀尼娑婆呵

若此神咒诵一千五百遍已讫。即便顺时皆悉开闭。言言语不出因缘者。谓若为修彼止轮门。于一切时于一切处不出言故。所以者何。随其言说心识出故。言坐像造立因缘者。谓若为造修定坐像。当具五事。云何为五。一者作物事。用松木故。二者高量事。如自身半不增减故。三者方角事。于一方中各四尺故。四者方向事。唯向东方非余方故五者坐上具事。唯用黄陀罗帝及黄坐具故。是名为五。言坐其座中因缘者。谓若为修彼止轮门。当具十事坐其座中。云何为十。一者足等事。两膝末中其两母指。互相契当令无差故。二者膝等事。两膝平摄令无差故。三者腰端事。其腰端直无[田*戈][出*面]故。四者手累事。两手相对右手为下左手为上。左手为下右手为上。经一日已互互易变不忘失故。亦复其手置根上故。五者颈端事。其颈之质端直不动定建立故。六者面端事。其面相貌不仰不俯令平相故。七者口相事。其口之相不癀不狭开中间故。八者鼻相事。出其气息令无差违不出一故。九者眼相事。其眼根量不上不下平等舒故。十者止眼事。置其眼处安置大虚空字轮中。恒不离故。是名为十。言出入时节因缘者。谓若为修彼止轮门。唯用辰及午之二时。此余时中不出入故。言知识善友因缘者。谓若为修彼止轮门。深智慧人以为友故。言印知邪正因缘者。谓若为修彼止轮门。随至像量须金刚印。即便了知邪及正故相。其云何。谓即诵咒言

坦咥咃[口*曼]那邬陀帝　婆罗枳陀尼　遮[口*尸][口*彌]哆耶　掩阿尸帝那娑婆呵

若此神咒诵四千六百五十遍已讫。即彼像中付二字轮。谓若邪人付邪字轮。若正直人付正字轮。以之为别。言植善林树因缘者。谓若为修彼止轮门人。自室前中植二种大吉祥草故。云何为二。一者松木。二者石榴木。是名为二言字轮服膺因缘者。谓若为修彼止轮门人。必当服[囗@(王/(王*王))]字轮而已。服何处耶。谓方寸处故。以何义故必付此轮。谓此字轮三世诸佛无量无边一切菩萨。大恩师长大恩父母大恩天地大恩海故。此因缘故。为修止人当付此轮。如是因缘虽有无量。而今此摩诃衍论中。明第一因缘。不明余者。举初摄后故。如是而已。如本若修止者住于静处故

已说成就止轮因缘门。次说直示修行止轮门。就此门中则有七门。云何为七。一者存心决定门。不生不灭。真空理中其心定故。如本端坐正意故。二者不着身体门。能善通达此身空无。其本自性不可得故。如本不依气息不依形色不依于空不依地水火风故。三者不着心识门。能善通达虑知之心。自性空无无所有故。如本乃至不依见闻觉知一切诸想随念皆除亦遣除想故。自此已下作其身心空无因缘。如本以一切法本来无相念念不生念念不灭亦不得随心外念境界故。四者不着不着门。能遣之心亦遣除故。如本后以心除心故。五者集散会一门。摄散动心置一中故。如本心若驰散即当摄来住于正念故。六者显示正念门。显示诸法唯一心故。如本是正念者当知唯心无外境界即复此心亦无自相念念不可得故。七者不离恒行门。如是定心于一切时于一切处。常恒相续不舍离故。如本若从坐起去来进止所作于一切时常念方便随顺观察故

已说直示修行止轮门。次说修行止轮得益门。谓若有人能修此定。渐渐转转。竭烦恼海崩业障岳。入真如定达一切法到不退故。如本久习淳熟其心得住以心住故渐渐猛利随顺得入真如三昧深伏烦恼信心增长速成不退故

已说修行止轮得益门。次说简入不入分际门。就此门中即有二意。云何为二。一者入趣意。二者不入意。言入趣意者。所谓或有众生趣入深法心无所疑。或有众生闻甚深法。其心决定不生不信。或有众生闻甚深法。即便尊重不生诽谤。或有众生无重业障。或有众生无我慢心。或有众生无懈怠心。如是六人入佛种性决定不疑。是名入趣意焉。言不入意者。所谓若有众生此六相违。永断绝三宝之种子。决定不疑。是名不入意焉。如本唯除疑惑不信诽谤重罪业障我慢懈怠如是等人所不能入故

已说略问广答散说门。次说赞叹三昧殊胜门。就此门中则有二门。云何为二。一者体大无边殊胜门。二者眷属无尽殊胜门。是名为二。言体大无边殊胜门者。修此三昧通达一切无量诸佛法。同体一相无差别故。如本复次依此三昧故则知法界一相谓一切诸佛法身与众生身平等无二即名一行三昧故。言眷属无尽殊胜门者。所谓即是真如三昧。能为一切无量无边金刚三昧作正根本。而能出生增长故。如本当知真如是三昧根本若人修行渐渐能生无量三昧故

释摩诃衍论卷第八释摩诃衍论卷第九

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

已说修行方便善巧门。次说广释魔事对治门

本曰。或有众生无善根力。则为诸魔外道鬼神之所惑乱。若于坐中现形恐怖。或现端正男女等相。当念唯心境界则灭终不为恼。或现天像菩萨像。亦作如来像相好具足。若说陀罗尼。若说布施持戒忍辱精进禅定智慧。或说平等空无相无愿无怨无亲无因无果毕竟空寂是真涅盘。或令人知宿命过去之事。亦知未来之事得他心智。辩才无碍。能令众生贪着世间名利之事。又令使人数嗔数喜性无常准。或多慈爱多睡多病。其心懈怠或卒起精进。后便休废生于不信。多疑多虑。或舍本胜行更修杂业。若着世事种种牵缠。亦能使人得诸三昧。少分相似皆是外道所得非真三昧。或复令人若一日若二日若三日乃至七日。住于定中得自然香美饮食。身心适悦不饥不渴。使人爱着。或亦令人食无分齐乍多乍少颜色变异。以是义故。行者常应智慧观察勿令此心堕于邪网。当勤正念。不取不着则能远离是诸业障。应知外道所有三昧。皆不离见爱我慢之心。贪着世间名利恭敬故。真如三昧者。不住见相不住得相。乃至出定亦无懈慢。所有烦恼渐渐微薄。若诸凡夫不习此三昧法。得入如来种性。无有是处。以修世间诸禅三昧多起味着依于我见。系属三界与外道共。若离善知识所护。则起外道见故

论曰。即此门中自有二门。云何为二。一者略说略示总持门。二者广说广示散剖门。第一门中即有五门。云何为五。一者众生胜劣不同门。二者能作障碍假人门。三者显示所作业用门。四者显示对治行法门。五者显示因治之力得益门。是名为五。言众生胜劣不同门者。二种众生各不同故。云何为二一者因缘具足众生。二者因缘阙失众生。具众生者具五事故。阙众生者。阙四事故。云何五具。一者信具。深爱乐故。二者人具。能守护故。三者法具。能善通达邪正区故。四者时具。随应当故。五者性具有真性故是名为五。若有众生具此五事终无障碍。云何四阙谓与彼前四相违故。若有众生虽有真性。阙此四事终无离障。今此文中取阙应知。如本或有众生无善根力故

已说众生胜劣不同门。次说能作障碍假人门。作障假人虽有无量而不出四。云何为四。一者魔。二者外道。三者鬼。四者神。是名为四。所言魔者。四种大魔三万二千眷属魔众。言外道者。九十六种诸大外道。九万三千眷属外道。所言鬼者。十种大鬼。五万一千三百二种诸眷属鬼。所言神者。十五大神五万一千三百二种诸眷属神。如是诸类一切皆悉碍乱正教令向非道故名邪道。魔及外道名义差别。出现经中分明说故。且略不释。鬼及神事。出现经中无分明故。便造作释纲要略说。言十鬼者名字云何。一者遮毗多提鬼。二者伊伽罗尸鬼。三者伊提伽帝鬼。四者婆那键多鬼。五者。尔罗尔梨提鬼。六者班尼陀鬼。七者阿阿弥鬼。八者阇佉婆尼鬼。九者多阿多伊多鬼。十者堆惕鬼。是名为十。如是十鬼用各云何。若第一鬼或作昼境。或作夜境。或作日月及星宿境。或作节境。随应变转。若第二鬼作种种香味种种衣具种种草木境随应变转。若第三鬼作地水火风之境界随应变转。若第四鬼作飞腾境随应无碍。若第五鬼作诸根识闭开之境随应无碍。若第六鬼作六亲眷属亦有亦无境随应无碍。若第七鬼作老少境随应无碍。若第八鬼作有智无智之境随应无碍。若第九鬼作无有境随应无碍。若第十鬼作蝎蝇蚁龙虎师子种种音声等之境界随应无碍。是名为用。如是诸用各因何力而得成就。各因三事而得成就。云何为三。一者师。二者教。三者习。师谓教人。教谓所学。习谓宿熏。是名为三。如是十鬼恒一切时不相舍离。俱行俱转作障础事。用之名字从增建立。如第一称。十五神者名字云何。一者筏罗罗键多提神。二者阿只陀弥梨尼神。三者补多帝陀诃诃婆神。四者阇毗摩只尼神。五者那多婆奢神。六者多多多多地地神。七者阿里摩罗神。八者尸叉尼帝婆竭那神。九者班弥陀罗邬多提神。十者唵唵吟吟神。十一者阿阿诃帝神。十二者修梨弥尼神。十三者头头牛头神。十四者婆鸠神。十五者精媚神。是名十五。此十五神用各云何。若第一神作聪明境。若第二神作闇钝境。若第三神作乐有光明之境界。若第四神作乐空光明之境界。若第五神作浮散境。若第六神作专注境。若第七神作恶空善有之境界。若第八神作一切觉者之境界。若第九神作我觉他惑之境界。若第十神作俱不修行之境界。第十一神作无无境。第十二神作速进退之境界。第十三神作移转境。第十四神作坚固境。第十五神作应时境。如是十五大神王者。恒一切时不相舍离。俱行俱转而作碍事恼乱行者。魔及外道云何差别。所言魔者令作恶事。言外道者令舍善事。二种差别应如是知。鬼并及神云何差别。障身为鬼。障心为神。二种差别应如是知。如是四障当云何治。此中对治即有四种。云何为四。一者随顺随转对治。二者相逆相违对治。三者俱行对治。四者俱非对治。言随顺随转对治者。即是无碍自在对治。所谓若彼外人作如是事乱行者心。所乱行者即作是念。从无始来此事如是终不破事。所以者何。如是诸见本有本觉自家实德。非过患故。若作是解。诸邪见类伏从如化。所以者何。随见增损。无漏性德亦大小故。是名随顺随转对治。言相逆相违对治者。即是简择别相对治。所谓若彼外人作如是事乱行者心。所乱行者即求方便。逆回违移相反相违令简择故。是名相逆相违对治。言俱行对治者。即是具足俱转对治。所谓一时具足逆顺二治。不离转故。是名为俱行对治相。言俱非对治者。即是无念无依对治。所谓于一切法无有所念。无有所虑。无有所著。无有所求。其心寂静住无住故。是名为俱非对治相。如是治相。于后文中说相明故。此决择中略去而已。如本即为诸魔外道鬼神之所惑乱故

已说能作障碍假人门。次说显示所作业用门。就此门中即有二种。云何为二。一者是总。二者是别。总相门中即有二门。云何为二。一者总相所作业用门。二者通达对治行法门。第一门者其相云何。所谓如上所说一切邪类。现六道像乱行者心故。今当作释分明散说。若鬼及神。多分造作地狱饿鬼畜生阿修罗之四道乱行者心。如本若于坐中现形恐怖故。若魔多分造作天道乱行者心。如本或现端正故。若外道众多分造作人道乱行者心。如本男女故。言等相者。即是同相。所谓造作同品依正乱行者心故

已说总相所作业用门。次说通达对治行法门。谓有众生作如是观。一切诸法唯一心量无心外法。已无外法。岂一心法与一心法作障碍事。亦一心法与一心法作解脱事。无有障碍无有解脱事。一心之法一即是心心即是一。无一别心无心别一。一摄法界心摄法界。无量无边妄想境界。寂静无起中中离相。一切诸法平等。一味一相无相。作一种光明。心地之海风风永止波波尽住。是名通达对治之相。所以者何。一切行者若不归此对治门者。无以摧邪道伏谬执故。如本当念唯心境界即灭终不为恼故

已说通达对治行法门。次说别相所作业用门。就此门中则有八门。云何为八。一者出现人相令信门。二者出现言说乱识门。三者得三世智惑人门。四者不离世间缚缠门。五者心性无常生乱门。六者令得邪定非真门。七者劝请行者离邪门。八者简择真伪令了门。是名为八。如其次第说相应观。就第一门中有三种人。云何为三。一者天人。二者菩萨人。三者如来人。是名为三。若外道人为作三像。各用几门。各六门故。云何为六。一者造像门。二者祷祀门。三者神咒门。四者诵经门。五者阿呼门。六者劝请门。是名为六。言造像门者。随用何人像处。作其人像故。言祷祀门者。以种种饮食种种众生身命而作祀事故。言神咒门者。随应当处诵陀罗尼故。言诵经门者。读诵八陀多等诸经故。言阿呼门者。随所作事不须余语。唯作是言阿呼阿故。言劝请门者。向自世尊劝请神力故。言造像者其相云何。且作天像时中当如何耶。谓头面眼耳鼻舌身手足。此九种处中各各诵一万八千遍陀罗尼咒成立此处。谓若为作眼像时中。则诵咒曰

遮阿那尸帝　筏邬多阿[尼*隹]婆阿[尼*隹]叉婆帝跋逃帝多陀陀那　尸婆尸叉那邬咤邬[口*運]尸　啰啰啰啰啰啰啰啰啰　诺诺诺诺诺诺诺诺诺　跋多跋多帝佉只啰迦结那啰啰佉只那遮尸阿阿帝　加加加加遮跋尸　毗键毗键尸　那叉娑娑娑　键跋帝阿多那尸　阿多那尸　跋多那尸　跋多那尸　诃娑诃伊多利利娑梨帝　遮遮遮遮遮　伊伊伊伊伊　多多多多多　尸尸尸尸　[尼*隹][尼*隹][尼*隹][尼*隹][尼*隹]　岚岚岚岚帝帝帝帝那尸那阿伊阿伊跋陀帝跋多提多多跋多提娑婆阿呵诃

若此神咒诵一万八千遍已讫。即眼之像清净具成精动根转更转明利。若为造作耳像时中。即诵咒言

唵嚤娑只伊那　唵嚤娑只伊多　跋陀陀提邬提邬阿那揭啰　堨那那那啰啰那啰　阿阿阿阿阿阿阿阿阿阿　呵呵呵呵呵呵呵呵呵呵　遮遮遮遮遮遮遮遮遮　陀陀陀陀陀陀陀陀陀　只只只只只只只只　帝帝帝帝帝帝帝　哪哪哪哪哪哪哪　[口*梨][口*梨][口*梨][口*梨][口*梨][口*梨][口*梨]　陀[口*夜]陀咜[口*夜]陀陀[口*夜]　邬哆提邬哆提　跋陀邬多提　毗[口*梨]娑嚤　阿咹陀　婆堨那　那那尸娑婆诃阿呵

若此神咒诵一万八千遍已讫。即耳之像清净具成。开动理转更转明利。若为造作鼻像时中。即诵咒言

婆抧啰啰帝　阿摩[口*彌]陀[尼*隹]岚婆阿尸提抧邬堨哪尸　呼呼呼呼呼呵毗遮键那尸提楼摩　摩尸摩啰邬遮哪　萨婆提梨帝　邬陀尸　堨坦哆陀毗尸那　遮呵[口*彌]帝阿呵阿呼　那啰那啰尸抧阿[口*彌][口*梨]婆　叉叉叉叉叉叉叉叉叉叉　婆叉阿陀哆伊那　嘶嘶嘶嘶嘶嘶嘶嘶嘶嘶嘶嘶　键键键键键键键键键键键键　呵呵婆婆　婆婆阿呵　诃抧[口*夜]　摩抧[口*夜]阿枳[口*夜]阿尸帝　键婆[口*梨]阇阇阇阇　[口*彌][口*彌][口*彌][口*彌]　婆跋尸　吐吐娑婆诃阿呵

若此神咒诵一万八千遍已讫。即鼻之像清净具成。随动导转更转明利。若为造作舌像时中。即诵咒言

阿摩阿伊[口*夜]　佉那尸　帝提跋多提　阿抧婆哆哆摩陀哆　阿啰帝哪邬婆哪邬哪邬尸邬邬　抧跋伊坦提　阿抧阿[損-口]尼毗奢邬抧哪　[口*結][口*結][口*結][口*結]哪舒帝邬舒帝陀哆抧　槃哆抧　尸呵[口*夜]　摩阇阿哆帝堨那呵　婆那呵　邬尸帝　迦毗提那阿抧陀　摩那尸摩那尸　阇抧阇抧　毗阇抧　娑婆诃阿呵

若此神咒诵一万八千遍已讫。即舌之像清净具成。了动业转更转明利。若为造作身像时中。即诵咒言

佉阿伊帝迦伊迦伊　婆婆毗婆婆婆婆婆提舒邬嚤舒邬　跋哆阿跋陀婆堨那　诃伊诃伊诃诃诃诃伊　咇邬帝嚤那尸　剖帝哆　佉枳[口*彌]邬帝　[唸-今+耶][耶/心]婆[唸-今+耶][耶/心]　阿[口*曼]尼　婆婆阿[口*曼]尼　阇诃嚤阇诃婆帝　堨那尸堨那尸　阿[口*彌]帝阿[口*彌]啰娑婆　阿诃阿阿阿阿呵

若此神咒诵一万八千遍已讫。即身之像清净具成。方作面变。若为造作手像时中。即诵咒言

掩嚤邬[口*夜]帝　阿[口*夜]阿曼哆　邬哪婆帝毗哪尸　舒啭婆　迦啰[口*彌]邬　诃陀[(士/絲)*(而/口)]尸　摩[口*彌]尸[口*彌]尸　[口*彌]尸[口*彌]尸　枳咇帝　婆毗嚤　阿毗嚤　诃键跋帝　邬哆那　婆[口*陀]那娑婆阿诃阿呵

若此神咒诵一万八千遍已讫。即手之像清净具成。指圆爪具。若为造作足像时中。即诵咒言

柯伊[口*夜]　嚤伊[口*夜]　堨啰帝　婆啰帝　键那键那鸠嚤鸠帝　鸠嚤跋帝　阿只娑阿只婆　呵那呵那娑婆诃　阿阿诃呵

若此神咒诵一万八千遍已讫。则足之像清净具成。指圆爪具。若为造作头面时中。如其次第。初二神咒初以为后。后以为初。逆次第诵一万八千遍已讫。即头面像清净具成。好妙相好。若种种根造作已讫。即须轮咒令付心识。谓方寸所中付标堨那罗字轮。即诵咒言

[囗@几][囗@几][囗@几][囗@几][囗@几][囗@几][囗@几][囗@几][囗@几]　[囗@几][囗@几][囗@几]　[囗@几][囗@几][囗@几][囗@几][囗@几][囗@几](於呼反)[(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)][(几@水)/(几@山)](那闇反)[?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡][?￡](伊因反)[幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)][幽-(ㄠ*ㄠ)+(║*║)](毗入反)娑婆阿诃阿呵

若此神咒诵一万八千四百五十遍已讫。即心量具无所不了

已说造像门。次说祷祀门。为成天像。以神咒门圆具无阙。有何不足更以祀门。以神咒门虽足其理而时节量不得久住。唯七日量不过此故。若以祀门止住其像。或十七日或百七日乃至千故。以此义故以祷祀门。祷祀门者其相云何。谓造像已。彼像前中以种种供而作祀事。祀事已讫即彼图像喜乐受用。受用已讫即告人言。一日二日三日四日五日六日七日及一百日。乃至千万亿日中。住我身心随汝所乐。随汝所求随顺不逆。今以此事为门之要

已说祷祀门。次说神咒门。以前二门其理圆满无所阙失。以何义故更须神咒。所谓二种事阙失故。云何为二。一者庄严。二者往来。以此义故立神咒门。若为成立天上种种妙庄严具。当须何等之神咒耶。谓若为作天上庄严具。即说咒言

唵嚤[口*提]帝[口*曼]哆　阇毗那　阿呵尸　键邬嚤迦尸帝　[口*彌]佉尸陀叉罗阿嚤伊嚤伊嚤[口*夜]　邬呵那　邬呵诃邬呵诃　邬诃那　[乃*乃][乃*乃][乃*乃][乃*乃][乃*乃][乃*乃][乃*乃][乃*乃][乃*乃][乃*乃][乃*乃](阻立反)跋阿跋阿阿阿阿阿阿　跋摩尸　[器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口][器-犬+口]　[器-犬+口][器-犬+口][器-犬+口][器-犬+口]　[器-犬+口][器-犬+口][器-犬+口][器-犬+口]　[器-犬+口][器-犬+口][器-犬+口][器-犬+口]　[器-犬+口][器-犬+口](语巾反)娑婆诃阿阿诃呵

若此神咒诵二万三千遍已讫。即便从时种种胜妙天庄严具。皆悉出现无余现前。出现已讫。即随当处至身分中周遍庄严。若为往来无有障碍。当须何等之神咒耶。谓若为欲自在往来。即诵咒言

阿婆婆婆梨　那啰阿啰阿啰帝鸠那尸　嚤呵陀　喃阿[口*梨]伊[口*夜]　阿喃阿[口*梨]伊耶　阿阿喃阿喃阿阿阿阿[口*梨]耶　婆婆阿喃阿[口*梨]耶　尸那尸那　嚤尸那嚤尸那哆陀帝　堨啰堨啰婆堨那　陀陀帝　哆哆提　堨堨那　娑婆诃　阿阿诃呵

若此神咒诵二万一千遍已讫。所造之像或往或来或飞或腾。随时随处随求随乐。无所障碍自在往来。今以此事为门之要

已说神咒门。次说诵经门。以何义故建立此门。谓为令增威德力故。此事云何。彼佛弟子。以种种门对治时中。若不须此诵经门者。力难对故。若如是者诵何等经。谓八陀多经魔头陀经婆邬舍经等。诵此等经以为对门。以此义故立诵经门

已说诵经门。次说阿呼门。以何义故建立此门。谓能成事要言说故。此义云何。若为成事须余言语即不成就。若成事时作如是说阿呼阿唱即便成就。所以者何。不共说故。以此义故立阿呼门

已说阿呼门。次说劝请门。以何义故建立此门。为作礼故。此义云何。为有所为仰自上人更劝请故。以此义故立劝请门

已说造作天像差别门。次说造作菩萨形相门。说此门中亦具六门。然通及别差别而已。通谓祷祀门神咒门阿呼门劝请门。别谓造像门诵经门。别相二中初造像门其相云何。谓如前说。九种处中各诵陀罗尼神咒故。各其相云何。若为造作头像时中。即诵咒言

哆哆哆哆呵哆哆哆帝婆婆婆婆伊婆婆婆帝叉婆叉婆[口*彌]啰帝[咒-几+阿][咒-几+阿][咒-几+阿][咒-几+阿][咒-几+阿][咒-几+阿][咒-几+阿][咒-几+阿]嚤呵帝娑婆诃阿阿诃呵

若此神咒诵八千四百五十遍已讫。即头之像具足成立。若为造作面像时中。即诵咒言

[口*尸]哪邬婆帝呵呵呵呵[月*尹][月*尹][月*尹][月*尹]　嚤佉[口*夜]　鸠驮尸陀帝　摩呵阿摩呵咇邬帝　娑婆诃阿阿诃呵

若此神咒诵三千七百遍已讫。即面之像具足成立。若为造作眼像时中。即诵咒言

驮跋尸哪嚤尼佉娑[坦-一+工][口*彌]帝遮阇哆毗坐[口*梨]阿嚤尸陀嚤尸陀尼迦哪迦[口*耶]僧佉[口*耶]诃婆尼娑婆诃阿阿诃呵

若此神咒诵八千四百五十遍已讫。即眼之像具足成立。若为造作耳像时中。即诵咒言

阿嚤嚤伊嚤嚤婆嚤嚤哆嚤嚤键鸠提迦鸠帝　毗那尸迦迦迦迦迦迦娑婆诃阿阿诃呵

若此神咒诵六万一千遍已讫。即耳之像具足成立。若为造作鼻像时中。即诵咒言

婆婆婆婆毗婆婆婆帝键那尸娑婆诃阿阿诃呵

若此神咒诵十万八千遍已讫。即鼻之像具足成立。若为造作舌像时中。即诵咒言

[烈-列+((口/女)*艮)]帝[烈-列+((口/女)*艮)]帝[咒-几+阿]帝[咒-几+阿]帝那陀那陀邬提邬提娑婆诃阿阿诃呵

若此神咒诵五万七千遍已讫。即舌之像具足成立。若为造作身像时中。即诵咒言

[坦-一+工]毗提[坦-一+工]毗提哆哆[坦-一+工]毗提　那啰尸帝　娑婆诃阿阿诃呵

若此神咒诵十万四千遍已讫。即身之像具足成立。若为造作手像时中。即诵咒言

咤提咤提　喃帝喃帝　[口*尸]陀[口*尸]陀那[口*彌]那[口*彌]娑婆诃阿阿诃呵

若此神咒诵八万一千遍已讫。即手之像具足成立。若为造作足像时中。即诵咒言

[哆*多]吱陀　[哆*多]吱陀　佉枳啰嚤呵尼咤喃尸啰啰啰啰啰娑婆诃阿阿诃呵

若此神咒诵三万二千一百遍已讫。即足之像具足成立。造作根已。即须轮咒令付心识。谓方寸所中付标堨那罗字轮。即诵咒言

[○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)][○@(冉-土+└)](隐天反)　[王@?][王@?][王@?][王@?][王@?][王@?][王@?][王@?][王@?][王@?][王@?][王@?][王@?][王@?][王@?](于阿反)　[?/?/山][?/山][?/山][?/山][?/山][?/山][?/山][?/山][?/山][?/山][?/山][?/山][?/山][?/山][?/山](弗入反)[甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?][甲/?](去言反)娑婆诃阿阿诃呵

若此神咒诵二万三千遍已讫。即心识具无所不了

已说造像门。次说诵经门。其相云何。谓诵毗舍阇尼经阿佉多陀经优婆罗一尸经叉提佉罗经等故

已说造作菩萨形相门。次说造作如来形相门。就此门中亦具六门。然通及别不同而已。别谓造像门。通谓所余五门。造像门者其相云何。谓如前说。九处咒中如其次第各加一句。若付心咒各别而已所加句者其相云何。咒言

那那阿那罗婆婆[口*彌]哆帝鸠奢陀尼嚤呵尸咤[這-言+(口*庶)]娑阇尼枳陀帝[口*曼]哆帝咇邬提陀陀帝叉婆尼

付心咒相其相云何。咒言

[凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)][凵@(?/?)](伊入反)[((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?][((彰-章)*?)/?](阿含反)[(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)][(〣*田)/山/((伒*斤)/一)](只因反)[几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)][几@((巢-果+一)/(巢-果+一)/山)](伊允反)

若此神咒诵一万八千遍已讫。即心识具无所不了。已说所治。次说能治。若清妙天子天女像来到行者所时。邪正差别云何知耶。此何所疑。由杂乱故。此义云何。谓无量光明契经中作如是说。若修行者其心清净。无量无边诸天子。无量无边诸天女。雨种种妙花。烧种种所有名香。出现种种微妙妓乐。开布种种胜妙庄严具。甚可爱乐貌来到行者所供养行者。所以者何。重其法故。彼外道人亦作天像。来到行者所。如前无异者。其邪正差别难可了知故。解释此疑即有六门。云何为六。一者咒知根坏不坏门。二者严具圆珠有无门。三者身光眼入不入门。四者头发末结不结门。五者双背无所取着门。六者俱取摄不除遣门。是名为六。言咒知根坏不坏门者。谓诵对治陀罗尼咒。若真实天不坏其根。若虚伪天诸根坏失皆无所有。以之为别。诵咒形相其相云何。谓有二意故。云何为二。一者诵外咒故。二者诵内咒故。诵外咒时若真实天无增减异。若虚伪天其诸根相渐渐增长。诵神咒相如其次第不超数量。如如诵故。以之为别。言内咒者其相云何。谓且咒眼。即诵咒言

[坦-一+工]跮哆嚤呵鸠尸帝迦那毗只帝[口*彌]哆尼　嘶邬婆　咇陀尼　婆[坦-一+工]奢毗　阿那帝阿枳尼阿枳尼　陀陀帝娑婆呵帝　嚤呵娑婆诃帝娑婆呵

若此神咒诵三七遍。眼根坏失皆无所有所余诸处各有神咒。而无要故略去不释

已说咒知根坏不坏门。次说严具圆珠有无门。其相云何。谓若真实天者。其庄严具中有十圆珠。若虚伪天者。其庄严具中无此珠故。以之为别。已说严具圆珠有无门。次说身光眼入不入门。其相云何。谓且彼行者目闭时中。若真实天其身光明入于眼内。若虚伪天不入眼内。以之为别。已说身光眼入不入门。次说头发末结不结门。其相云何。谓见发相。若真实天两末相结。若虚伪天两末互解。以之为别。已说头发末结不结门。次说双背无所取着门。其相云何。谓观若真实天若虚伪天。唯自妄心现量境界无有其实。无所著故。以之为治。已说双背无所取着门。次说俱取摄不除遣门。其相云何。谓观若真实天若虚伪天。皆一真如皆一法身无有别异。不断除故。以之为治。已说对治天像除遣门。次说对治菩萨形像门。就此门中即有二门。云何为二。一者诵咒了知邪正门。二者智慧观察无著门。言诵咒门者其相云何。谓且咒心即诵咒言

[坦-一+工]阿哆舸毗提　嚤鸠帝婆尼婆婆尼　嘶咇帝　阇那那尸邬嚤　阿只陀阿只陀沙婆呵

若此神咒诵八百十遍已讫。即彼菩萨漠漠不动。譬如木石以之为治。一切根及庄严具中。各有神咒等多种门。而无要故略而不说。已说诵咒了知邪正门。次说智慧观察无著门。其相云何。谓以智慧观察诸法空无相理。无执着故。已说对治菩萨形像门。次说对治如来形像门。其相云何。就此门中亦具二门。名如前说。言神咒门者其相云何。谓且咒光明。即诵咒言

哆跮[坦-一+工]唵那罗帝　岑枳罗　[口*尸]驮尸阇键尼婆键尼嚤那耶　邬婆帝　阇嚤罗娑婆呵

若此神咒诵四百遍。若实如来其身光明即不损减。若伪如来其身光明。即便损减作闇之色。以之为别。彼第二门观所前说应审思惟。谓有外道。造作一切种种异类。来到行者所。乱行者心。尔时当各诵何等咒。谓有神咒是通非别。所谓如来总持法藏因缘契经中所说神咒大陀罗尼。彼契经中如何说耶。谓彼经中作如是说。尔时文殊师利即白佛言。世尊。一切种种邪道之类。来到于行者所。乱行者心时。当须何等门而以除遣。于是如来即告文殊师利言。有深法门。能善通治一切邪道。所谓诸佛无尽藏无碍自在印陀罗网随顺随转总持大陀罗尼法门。文殊师利。谛听谛听善思念之。我当为汝分别解说。文殊师利。所言通达无碍自在总持大陀罗尼法门者。十方三世一切诸佛所护念之宝藏。十方三世一切菩萨。常所诵持之大轨则。十方三世一切神王及一切天人。皆悉所礼拜供养之广大福田焉。于是世尊。即诵咒言

怛咥咃　那罗尸　伽诺邬帝[這-言+(口*庶)][口*曼]哆　娑毗提呵呵[口*彌]陀尼　婆伽婆尸　帝驮驮邬嚤[口*梨]阇那筏尼帝　伽怛尼娑[口*耶]哆　鸠[敲-高+咥]那婆提婆呵嚤　伊婆哆尼　毗舒诃　邬佉哆陀尼[((口*口)/田)*比][罩-卓+習]提　叉阿[口*耶]　键那尸娑婆呵

若此神咒诵八千七百五十一遍已讫。随其所应一切邪类皆悉退失。不能恼乱故。如本或现天像菩萨像亦作如来像相好具足故。已说出现人相令信门。次说出现言说乱识门。就此门中即有三门。云何为三。一者说陀罗尼门。二者说修行因门。三者说果满德门。是名为三。如是三说各何人说。所谓若天像多说陀罗尼。若菩萨像多说行因。若如来像多说果德。所以者何。各说自得行者信故。所说陀罗尼当其相云何。所谓而能说光明连续陀罗尼。故若诵此咒当有何利。谓若诵此咒自身光明续他身故。是故天像来到彼修行者所中。说此陀罗尼门已讫。即彼行者古无光明今有光明。极欢喜故作如是念。我今承修行之力故。今有如是殊胜光明。乱自正行入外邪网。以此义故。彼天像说陀罗尼门。即诵咒言

阿[口*歹*王*歹]哆嚤嚤阿婆尸　那佉耶　邬婆娑尼帝佉[口*耶]　[咒-几+阿]呵[口*彌]伽帝[坦-一+工]哆婆尸呵　筏那鸠筏帝迦嚤[口*梨]　[口*彌]叉[口*彌][坦-一+工]尼陀[口*耶]哆陀尼　娑婆呵[口*彌]婆婆婆婆呵[口*彌]阿哆尼婆哆尼娑婆阿呵

若此神咒诵五千三百遍已讫。即便光明相续作一焉。尔时行者。即诵咒言

[坦-一+工]咥哆遮[口*曼]尼　阿婆[口*彌]陀帝　叉跋那尼[口*耶]嚤邬提　婆佉那罗帝毗呵邬帝跋跋那提　多筏陀阿嚤啰娑婆呵

若此神咒诵一百遍。彼身光明断绝不着。终不为恼。如本若说陀罗尼故。已说说陀罗尼门。次说说修行因门。修行因门虽有无量。而不出六种波罗蜜。是故彼像为修行者说六资粮。乱彼行者令入邪网。彼外道人当有何利。作如是说乱行者耶。彼修行者当时意乐。断一切恶修一切善。圆满因行无所阙失。彼外道人示现同心。令舍离正道趣向邪道故。如本若说布施持戒忍辱精进禅定智慧故。已说说修行因门。次说说果满德门。圆满果门虽有无量。而不出寂静涅盘界。是故彼像为修行者说涅盘德。乱彼行者令入邪网。彼外道人当有何利作如是说乱行者耶。彼修行者修因意趣当证果故。是故外道出现行者所欲求之殊胜果德。彼行者心能令爱着趣向邪道。如本或说平等空无相无作无愿无怨无亲无因无果毕竟空寂是真涅盘故。已说出现言说乱识门。次说得三世智惑人门。如是三达智各其相云何。所谓若过未之二达智各达自境。其最远际八万劫量。其最近际能善通达经一生事。如本或令人知宿命过去之事亦知未来之事故。言现达智者。即是他心智。所谓而能达现在人种种心故。如本得他心智故。已说得三世智惑人门。次说不离世间缚缠门。谓外道人令使成就一亿四万六千种诸世论之辩。十万八千种诸戏论之才。缚缠众生止住世间不得出离故。如本辩才无碍能令众生贪着世间名利之事故。已说不离世间缚缠门。次说心性无常生乱门。所谓破坏坚固之信。而能令发无常之心。断修行之足绝趣入之路。引入邪网及无性故。如本又令使人数嗔数喜性无常准或多慈爱多睡多病其心懈怠或卒起精进后便休废生于不信多疑多虑或舍本胜行更修杂业若着世事种种牵缠故。已说心性无常生乱门。次说令得邪定非真门。谓外道人得二十一种邪三昧。乱修行者入邪网故。如本亦能使人得诸三昧少分相似皆是外道所得非真三昧或复令人若一日若二日若三日乃至七日住于定中得自然香美饮食身心适悦不饥不渴使人爱着或亦令人食无分齐乍多乍少颜色变异故。已说令得邪定非真门。次说劝请行者离邪门。言劝请行者离邪门者。劝修智慧。诸善分别除愚痴之病。遣邪论之谬故。如本以是义故行者常应智慧观察勿令此心堕于邪网当勤正念不取不着则能远离是诸业障故。已说劝请行者离邪门。次说简择真伪令了门。所谓随顺于世间中名伪三昧。若随顺于出世间中名真三昧。二种三昧应如是知。如本应知外道所有三昧皆不离见爱我慢之心贪着世间名利恭敬故。真如三昧者不住见相不住得相乃至出定亦无懈慢所有烦恼渐渐微薄若诸凡夫不习此三昧法得入如来种性无有是处以修世间诸禅三昧多起味着依于我见系属三界与外道共若离善知识所护则起外道见故故

已说广释魔事对治门次说赞叹三昧功德门

本曰。复次精勤专心修学此三昧者。现世当得十种利益。云何为十。一者当为十方诸佛菩萨之所护念。二者不为诸魔恶鬼所能恐怖。三者不为九十五种外道鬼神之所惑乱。四者远离诽谤甚深之法重罪业障渐渐微薄。五者灭一切疑诸恶觉观。六者于如来境界信得增长。七者远离忧恼于生死中勇猛不怯。八者其心柔和舍于憍慢。不为他人所恼。九者虽未得定。于一切时一切境界处。即能损减烦恼不乐世间。十者若得三昧。不为外缘一切音声之所惊动

论曰。就此文中即有二门。云何为二。一者是总标门。二者是散说门。言总标门者。总标所说故。如本复次精勤专心修学此三昧者现世当得十种利益故。散说门中自有二门。云何为二。一者是总问门。二者是别说门。言总问门者。总问所说故。如本云何为十故。就别说门中故有十种胜妙功德。由一真定而所成就云何为十。一者守护功德。常为一切无量无边诸佛菩萨所护念故。如本一者常为十方诸佛菩萨之所护念故。二者怖魔功德。能善降伏一切魔故。如本二者不为诸魔恶鬼所能恐怖故。三者出道功德。能善出离一切外道诸邪道故。如本三者不为九十五种外道鬼神之所惑乱故。四者离谤功德。能善远离诽谤大乘等诸罪故。如本四者远离诽谤甚深之法重罪业障渐渐微薄故。五者决疑功德。能善决断诸疑惑故。如本五者灭一切疑诸恶觉观故。六者深信功德。于胜妙境起乐信心更转深故。如本六者于如来境界信得增长故。七者勇猛功德。缘众生界起大悲心。集成万行无懈怠故。如本七者远离忧恼于生死中勇猛不怯故。八者无我功德能善断除一切我慢作意。皆是佛清净意故。如本八者其心柔和舍于憍慢不为他人所恼故。九者厌离功德。于一切时一切处等诸境界中。能善伏除种种烦恼。不乐世间生死之海故。如本九者虽未得定于一切时一切境界处则能损减烦恼不乐世间故。十者寂静功德。于一切诸散动境界。其心安定无有动故。如本十者若得三昧不为外缘一切音声之所惊动故。如其次第不乱数量。止心之波应审思择

释摩诃衍论卷第九释摩诃衍论卷第十

        龙树菩萨造

        姚秦三藏筏提摩多奉　诏译

已说赞叹三昧功德门。次说两轮具阙益损门

本曰。复次若人唯修于止。则心沉没。或起懈怠不乐众善。远离大悲。是故修观。修习观者。当观一切世间有为之法。无得久停须臾变坏一切心行念念生灭以是故苦。应观过去所念诸法恍惚如梦。应观现在所念诸法犹如电光。应观未来所念诸法犹如浮云忽尔而起。应观世间一切有身悉皆不净种种秽污无一可乐。如是当念。一切众生从无始世来。皆因无明所熏习故。令心生灭。已受一切身心大苦。现在即有无量逼迫。未来所苦亦无分齐。难舍难离而不觉知。众生如是甚为可愍。作此思惟。即应勇猛立大誓愿。愿令我心离分别故。遍于十方修行一切诸善功德。尽其未来以无量方便。救拔一切苦恼众生。令得涅盘第一义乐。以起如是愿故。于一切时一切处所有众善随己堪能不舍修学心无懈怠。唯除坐时专念于止。若余一切悉当观察应作不应作。若行若住若卧若起。皆应止观俱行。所谓虽念诸法自性不生。而复即念因缘和合善恶之业苦乐等报不失不坏。虽念因缘善恶业报。而亦即念性不可得。若修止者。对治凡夫住着世间。能舍二乘怯弱之见。若修观者。对治二乘不起大悲狭劣心过。远离凡夫不修善根。以此义故。是止观二门共相助成。不相舍离。若止观不具。则无能入菩提之道

论曰。就此文中即有六门。云何为六。一者示问观止轮失门。二者显示修行观轮门。三者缘众生界立愿门。四者两轮俱转不离门。五者显示两轮所治门。六者总结两轮俱转门。是名为六。就第一门中即有四过失。云何为四。一者沉沦过失。其心昧略不能觉了。如入嚤键诃尸闇室中故。如本复次若人唯修于止则心沉没故。二者不勤过失。其心懈怠不能精进。如阿那毗提人故。如本或起懈怠故。三者背善过失。其心专一不能分别应作不应作。如婆多诃弥尸人故。如本不乐众善故。四者离悲过失。其心安寂不能发起大慈悲心。如坏根人所自欲中更不增故。如本远离大悲故。是故修观者。即是劝俱转

已说示阙观止轮失门。次说显示修行观轮门。就此门中即有三门。云何为三。一者苦相观门。二者无常观门。三者不净观门。是名为三。就初苦相观门中即有二种。云何为二。一者坏苦。二者行苦。言坏苦者。一切有为之清净法。能坏一切不清净法。亦一切诸不清净法。能坏一切清净法故。复次二种世间互相破坏故。云何为二。一者具足一切世间。二者妄想有为世间。如是二种世间之法。相破坏故。是故说言坏苦而已。若修此观当得何利。所谓成就一自作一甚深法故。如本修习观者当观一切世间有为之法无得久停须臾变坏故。言行苦者。一切心行于念念中常恒迁转速生速灭。不能从此处至于彼处故。如本一切心行念念生灭以是故苦故。已说苦相观门。次说无常观门。就此门中则有三种。云何为三。一者已过无常。过去诸法前有后无。譬如彼梦熟眠时有已乃觉悟时无有故。如本应观过去所念诸法恍惚如梦故。二者今有无常。现在诸法古无今有。譬如电光即时便灭不能久停故。如本应观现在所念诸法犹如电光故。三者当有无常。未来诸法无有自性而忽然至。譬如浮云不知有所而忽然起遍十方故。如本应观未来所念诸法犹如浮云忽尔而起故。已说无常观门。次说不净观门。言不净观者。缘种种身作不净解。远离贪故。如本应观世间一切有身。皆悉不净种种秽污。无一可乐故

已说显示修行观轮门。次说缘众生界立愿门。就此门中即有二种。云何为二。一者缘众生界思惟门。二者建立誓愿遍布门。是名为二。言缘众生界思惟门者。所谓缘三界中无量无边一切众生。作如是念。从无始来。根本无明所覆藏故。弃背自本觉清净佛归原无日。出无明藏更复时远。我若不发悲心不摄取者。又之又之唯过劫数。取正觉期实无其齐。发起无边大悲心故。如本如是当念一切众生从无始世来皆因无明所熏习故令心生灭已受一切身心大苦现在即有无量逼迫未来所苦亦无分齐难舍难离而不觉知众生如是甚为可愍故。言建立誓愿遍布门者。所谓作如是思惟已讫。则立大誓愿。起十方世界之微尘数光明般若。达十方世界之微尘数种种心相。对治十方世界之微尘数一切诸烦恼业障海。圆满十方世界之微尘数行因海。证得十方世界之微尘数果德。皆悉令无余故。如本作此思惟即应勇猛立大誓愿愿令我心离分别故。遍于十方修行一切诸善功德尽其未来以无量方便救拔一切苦恼众生令得涅盘第一义乐故。已说缘众生界立愿门。次说两轮俱转不离门。所谓起如是愿已讫。即直修习行因之海故。若起愿海不勤修行。不能庄严圆满果故。若为修行当如何耶。谓具两轮令无偏故。具两轮相何契经中分明显示。谓文殊师利发起十万一千种甚深广大圆满陀罗尼开问问大觉尊益大众海契经。彼契经中如何说耶。所谓彼契经中作如是说。尔时文殊师利即白佛言。世尊云何名为止观俱行不相离门。我及一切无量无边大众之海。皆悉入于不知不觉无明之海。不能通达不能出离。如宜世尊为欲我等诸迷子女分明显示。尔时世尊即告文殊师利言。谛听谛听善思念之。我当为汝分别解说。于是世尊即说伽陀言

  譬如阙翼鸟　　及一轮之车
  一足人同分　　阙眼险之马
  无有高远翔　　随所应运载
  其道路游行　　不堕恶趣坑
  若具足一轮　　阙一轮行者
  亦复如是知　　以其实无有
  法性虚空中　　乘如量智翔
  入于法藏海　　运载义理宝
  真如平道中　　周遍通游行
  一切魔外道　　邪见深坑中
  不倒堕坑故　　是故诸行者
  两轮具足转　　终不可舍离
  若有修行者　　不具此两轮
  终不能通达　　无上大觉地

今此经文为明何义。谓为显示修习三昧达寂静境。修习智慧照散动境。在寂静中常不舍动。在散乱中常不舍寂。而不相舍离俱行俱转故。复次为欲显示修习三昧达空无境。修习智慧照在有境。在空不著有。在有不染无。有无双照无有偏边。而不相舍离俱行俱转故。复次为欲显示修习三昧达平等理。修习智慧照差别事。理事双达无有偏边。而不相舍离俱行俱转故。复次为欲显示止当待观方得建立非自性止。观当待止方得建立非自性观。亦无有止亦无观故。复次为欲显示止则是观观则是止。止观一体无差别。故如其次第应审思择。如本以起如是愿故。于一切时于一切处所有众善随己堪能不舍修学。心无懈怠。唯除坐时专念于止。若余一切悉当观察应作不应作。若行若住若卧若起。皆应止观俱行。所谓虽念诸法自性不生而复即念因缘和合善恶之业。苦乐等报不失不坏。虽念因缘善恶业报而亦即念性不可得故。已说两轮俱转不离门。次说显示两轮所治门。若有行者修习止轮。当为对治何过失耶。谓为对治凡夫众生著有过失。二乘众生乐空过失俱绝离故。如本若修止者对治凡夫住着世间能舍二乘怯弱之见故。若有行者修习观轮。当为对治何过失耶。谓为对治二乘众生远离大悲。不救众苦下劣过失。凡夫众生常恒懈怠。不能精进不修善品。乐恶过失俱出离故。如本若修观者对治二乘不起大悲狭劣心过远离凡夫不修善根故。已说显示两轮所治门。次说总结两轮俱转门。所谓总结如上所说轮阙行者大过失故。如本以此义故是止观门共相助成不相舍离若止观不具则无能入菩提之道故

已说两轮具阙益损门。次说劝劣向胜不退门

本曰。复次众生初学是法。欲求正信其心怯弱。以住于此娑婆世界。自畏不能常值诸佛亲承供养。惧谓信心难可成就。意欲退者。当知如来有胜方便摄护信心。谓以专意念佛因缘。随愿得生他方佛土。常见于佛永离恶道。如修多罗说。若人专念西方极乐世界阿弥陀佛。所修善根回向愿求生彼世界。即得往生常见佛故终无有退。若观彼佛真如法身常勤修习。毕竟得生住正定故

论曰。就此文中即有七门。云何为七。一者显示趣向假人门。二者归依所学教法门。三者厌恶处所退信门。四者如来方便殊胜门。五者承力得胜妙处门。六者得善处定不退门。七者引经证自所说门。是名为七。言显示趣向假人门者。所谓显示得十信位前四种心。更不胜进下品众生故。如本复次众生故。言归依所学教法门者。彼十信位下品众生。归依甚深无极大乘初学习故。所谓一切诸佛所师。三世不动四相不迁。自然常住地前地上大道路故。如本初学是法故。言厌恶处所退信门者。彼十信位下品众生。虽亲听受甚深法门。而其心根极下劣故。怖二大事不能胜进。为欲退故。云何为二。一者国土。二者胜缘。言国土者。即此娑婆世界。处所粗恶众生浊乱。发起净心为勤修行。甚极切难故。所以者何。于彼心中违逆境界。于一切时于一切处常恒现前。进心面中不舍离故。言胜缘者。于此世界依正浊乱。一切诸佛出世极鲜。无量菩萨赴感时节极远。诸佛菩萨出现于世。随顺情心之镜净不净故。以此义故彼修行者不值胜缘。极怖畏故发退意耳。如本欲求正信其心怯弱以住于此娑婆世界自畏不能常值诸佛亲承供养惧谓信心难可成就意欲退者故。言如来方便殊胜门者。谓诸佛如来有不可思议之甚深极妙大方便故。能善摄护彼人信心。转胜进故。云何名为胜妙方便。所谓专念如来方便。云何专念。谓专注意忆念他方净土种种依正。其念相续令不绝故。如本当知如来有胜方便摄护信心谓以专意念佛因缘故。言承力得胜妙处门者。以诸如来不可思议方便力故。随自所愿即得往生妙乐土故。如本随愿得生他方净土故。言得善处定不退门者。生彼土已。眼见如来具相好像。耳闻圣者说深妙音。永离恶名。从定不动心海澄净身体明白。依妙正清故。如本常见于佛永离恶道故。言引经证自所说门者。所谓该摄说相属当经本之辞。赞自所说解释文故。所引经文说相明故。不须重释。如本如修多罗说若人专念西方极乐世界阿弥陀佛所修善根回向愿求生彼世界即得往生常见佛故。终无有退若观彼佛真如法身常勤修习毕竟得生住正定故故

已说修行信心分次说劝修利益分

本曰。如是摩诃衍诸佛秘藏。我已总说。若有众生欲于如来甚深境界得生正信远离诽谤入大乘道。当持此论思量修习。究竟能至无上之道。若人闻是法已不生怯弱。当知是人定绍佛种。必为诸佛之所授记。假使有人能化三千大千世界满中众生令行十善。不如有人于一食顷正思此法。过前功德不可为喻。复次若人受持此论。观察修行若一日一夜。所有功德无量无边不可得说。假令十方一切诸佛。各于无量无边阿僧祇劫。叹其功德亦不能尽何以故。谓法性功德无有尽故。此人功德亦复如是无有边际。其有众生于此论中。毁谤不信所获罪报。经无量劫受大苦恼。是故众生但应仰信不应诽谤。以深自害亦害他人。断绝一切三宝之种。以一切如来皆依此法得涅槃故。一切菩萨因之修行入佛智故。当知过去菩萨已依此法得成净信。现在菩萨今依此法得成净信。未来菩萨当依此法得成净信。是故众生应勤修学

论曰。就此文中即有八门。云何为八。一者举前所说总结门。二者举益劝人令修门。三者显离疑信功德门。四者比类为对示胜门。五者举受持功赞扬门。六者举诽谤过令怖门。七者殊胜广说离谤门。八者总结修行劝人门。是名为八。言举前所说总结门者。谓以一总字总结八种摩诃衍故。何故。余法略不结焉。所谓举本摄其末故。如本如是摩诃衍诸佛秘藏我已总说故。言举益劝人令修门者。所谓集成行因之海。而为庄严法身之果。受持此论思惟义理。常恒相续不断绝故。如本若有众生欲于如来甚深境界得生正信远离诽谤入大乘道当持此论思量修习究竟能至无上之道故。言显离疑信功德门者。谓有众生闻此摩诃衍之甚深极妙广大法门已。即其心中亦不疑畏亦不怯弱。亦不轻贱亦不诽谤。发决定心发坚固心。发尊重心发爱信心。当知是人实真佛子。不断法种不断僧种。不断佛种常恒相续。转转增长尽于未来。亦为诸佛亲所授记。亦为一切无量菩萨之所护念故。如本若人闻是法已不生怯弱。当知是人定绍佛种必为诸佛之所授记故。言比类为对示胜门者。谓若有人能善摄化三千大千世界中遍满众生。皆悉无余令行十善。或有众生于一食顷。于此甚深法观察思量。若挍量此二人功德。彼第一人所得功德甚极微少。譬如芥子碎作百分一分之量。此第二人所得功德甚极广大。譬如碎十方世界微尘数量故。如本假使有人能化三千大千世界满中众生令行十善不如有人于一食顷正思此法过前功德不可为喻故。言举受持功赞扬门者。谓若有人受持此论观察义理。若一日若一夜。中间所得功德无量无边。不可言说不可思量。若假使十方三世一切诸佛。若十方三世一切诸菩萨。以十方世界微尘数舌。各各皆悉于十方世界微尘数之量不可说劫。赞扬其人所有功德亦不能尽。所以者何。法身真如之功德。等虚空界无边际故。何况凡夫二乘之人能称叹之。一日一夜不多中间受持人。尚所得功德不可思议。何况若二日若三日若四日乃至百日中。受持读诵思惟观察。不可思议不可思议。不可说中不可说故。如本复次若人受持此论观察修行若一日若一夜所有功德无量无边不可得说。假令十方一切诸佛各于无量无边阿僧祇劫叹其功德亦不能尽。何以故。谓法性功德无有尽故。此人功德亦复如是无有边际故。言举诽谤过令怖门者。谓有众生于此论教生不信心破谤不行。如是众生所得罪报。于诸不可说不可说劫中。受苦中之重大苦故。如本其有众生于此论中毁谤不信所获罪报经无量劫受大苦恼故。是故众生但应仰信不应诽谤者。即是总结上说决择。劝请行者。自此已下作其因缘示重过失。谓此法中不信诽谤。失自善根损他功德。断绝一切三宝之种无续期故。如本以深自害亦害他人断绝一切三宝之种故。言殊胜广说离谤门者。谓十方三世诸如来。一切皆悉以摩诃衍。为其根本成正觉故。十方三世无量菩萨。一切皆悉以摩诃衍。为其根本具因海故。如是重深摩诃衍法。若有众生生不信心诤论诽谤。如是众生亦名断伐一切诸佛。亦名断伐一切菩萨。亦名断绝自如来藏本觉佛故。如本以一切如来皆依此法得涅盘故。一切菩萨因之修行入佛智故。当知过去菩萨已依此法得成净信现在菩萨今依此法得成净信未来菩萨当依此法得成净信故。是故众生应勤修学者。即是总结修行劝人门。应审思择

已说劝修利益门。次说回向遍布门

本曰

  诸佛甚深广大义　　我今随分总特说
  回此功德如法性　　普利一切众生界

论曰。就此一颂中即有三种门。云何名为三种门耶。一者摄前所说总结门。二者展舒功德令广门。三者施于众生普利门。是名为三。就初门中则有二种。云何为二。一者通总摄前所说门。二者显示能说字相门。如其次第应审观察。诸佛甚深广大义者。即是通总摄前所说门。所谓通摄三十三种本数法故。此义云何。言诸佛者。则是不二摩诃衍法。所以者何。此不二法形于彼佛其德胜故。大本花严契经中作如是说。其圆圆海得诸佛胜。故其一切佛不能成就圆圆海劣故。若尔何故分流花严契经中作如是说。卢舍那佛三种世间为其身心。三种世间摄法无余。彼佛身心亦复无有所不摄焉。卢舍那佛虽摄三世间。而摄不摄故。是故无过。言甚深者。即是两重八种摩诃衍之本法。以何义故名为甚深。如是两重摩诃衍法。能入门望极甚深故。以此义故立甚深称。应审思择。言广大义者。即是两重能入门法。以何义故名广大义。如是两重能入门法。皆悉各各能广自法。能大自法。能为自法。作名义故。以此义故建立广大义名字焉。已说通总摄前所说门。次说显示能说字相门。言我今随分总持说者。即是显示能说字相门。谓以总字通持一切种种说故。立义分中摩诃衍者总。即是此焉欤。何故一字通持诸说。为欲显示摩诃衍论如意论故。已说摄前所说总结门。次说展舒功德令广门。言回此功德如法性者。即是展舒功德令广门。谓自所作之功德回向三处故。云何为三。一者真如。二者一心法。三者本觉佛性。是名为三。以何义故回向三处。谓为欲自所作功德令平等故回向真如。或为欲自所作功德令广大故回向一心。或为欲自所作功德令明了故回向本觉应如是知应如是观。如是回向有何利益。谓众多故。此义云何。譬如用一微尘置大地中。所置微尘与彼大地等无差别。回向法门亦如是故。又譬如用一注水置大海中。所置水注与彼大海等无差别。回向法门亦如是故。又譬如破一小有。即便与大虚空等无差别。回向法门亦如是故。已说展舒功德令广门。次说施于众生普利门。言普利一切众生界者。则是施于众生普利门。谓举广大圆满功德。周遍利益众生界故

  欢喜大士至心劝　　无量佛子众海中
  我已超毛头三角　　过于生死之四根
  第一无数粗满讫　　第二僧祇始入无
  如宜汝等诸佛子　　以于左右之两手
  捧于本释之明镜　　临七识散虑之面
  见六尘境界之垢　　洗法执人我之咎
  汝等佛子若如是　　法身应化之三身
  如舒伊字圆现前　　常乐我净之四德
  如入达池具出生　　我从四王自在处
  下入大海龙宫殿　　随分窥诸契经海
  总有一百洛叉数　　如是诸经真实法
  无量无边差别义　　摩诃衍论立义中
  该摄安立具足说　　有善男子善女人
  若自手捧斯论卷　　名捧百洛叉经者
  若自口经诵本分　　名诵百洛叉经者
  此人所得之功德　　十方世界微尘数
  诸佛及大菩萨众　　各出微尘数舌相
  如是微尘数劫中　　不息称说不能尽
  何况观察其义理　　思惟文下之所诠
  有善男子善女人　　生不信心谤斯论
  此人所得之罪业　　十方世界微尘数
  诸佛及大菩萨众　　各出微尘数舌相
  如是微尘数劫中　　不息说过不能尽
  是人往罪灭无所　　一切诸佛不能救
  是故行者归本原　　当依斯论应修行
  实不可生不信心　　诽谤甚深大乘教
  当愿此劝远流布　　遍于重重不说刹

释摩诃衍论卷第十


手杖论

    No. 1657

手杖论一卷

        尊者释迦称造

        大唐三藏法师义净奉　诏译

世间一类有情为无慧解便生邪执。由彼沉沦生怜愍故。今造斯论。颂曰

  设于平坦道　　有步步颠蹶
  为此等愚蒙　　谈兹手杖论

论曰。一一世尊出现于世。而便寂灭阿僧企耶诸有情类。然诸有情无有终际。犹若虚空。无边性故。此是世亲菩萨之所述理边。谓断割尔许数量。是一义故。为遮此故。故曰无边。所言终者。是尽了义。为此便无所立能立不相离过。宗言无终。因云无边。是宗一分过也。有异论者作如是说。许未曾有新生有情。犹如神村。如彼计云。如林薄等虽有众多斫伐等费见摧残已而更新生。因无穷尽。由斯定许别有未曾新起有情。略诠述故。如略诠中作如是说。因问致答。命药军曰。有旧有情。有新众生。如是广说。是故决定应如是许。若异此者。如油麻等聚无新添数而损减必定见其有终尽故。尔者如若许有未曾有情今始新起。此即便成许其生死有最初也。若许有始彼即便有无因之过。既许无因一切皆应无因而有。此是阿遮利耶之本意也。彼复于此而为答曰。由有于子造相属业。善不善二法等种子。阿陀那识羯刺罗等事。此谓最初。而得生起。既属着已。由近善恶自造诸业而入流转。或出涅槃。斯乃善顺缘生道理。即是僧塞迦罗八底也。毗若南婆薄八底也。社底既有斯义。如何强逼许有新生有情。论者便成生死有最初失。有别论者曰。此非雅答。何为也。若容有新生。彼便有增剩。由增待其减。初者是无因。若云此新有情曾不了知生死意趣。但由他业为缘力故忽尔得生。若如是者。彼诸有情今受流转。一一刹那展转相生。便成增剩。由斯道理彼新生论。便应许有。初一有情。由许增者。待其减故。一切时中许有新生众多有情。是诸情数定有其增。前前刹那待其减故。若如此者能减转少。乃至将终成唯独一。然此最初不待余业。便成最初。是无因有斯固不能辨无因过。若言必定有增剩者。可招此过。有加无费是增剩因。如悭人物。然诸有情有其减理。何者一一佛图嗢波柁。而令无算众多有情入于圆寂。亦不如是。颂曰

  佛出难遭故　　信教亦难逢
  生因既易得　　脱理相不同

论曰。由佛出世实是难逢。如论中说。于初无数劫中已曾承事五个七十千佛。第二六个七十千佛。第三七个七十千佛。成佛资粮极难得故。如有颂云

  无数百苦行　　无数善根生
  进无数长时　　断无数烦障
  得一切种智　　净除诸障恼
  成无上世尊　　如开箧观宝

纵许或时逢如知出世。彼之所演清净法律。敬信之者诚复难得。由彼信心于八暇处方能具足。然彼最是难得性故。然生起因是极易得。谓惑及业。此之因缘随在何时多现前故。此之烦恼有三种缘。一随眠未断。二缠境现前。三于彼起不如理思。此为凡愚多所乐着。然而诸业但由能造属着。因者亦非难得。或可有时而得解脱。欲将少费答彼新增固亦未能免便成过。理不相应。颂曰

  器界无增数　　容成有减时
  生死既无初　　此应成大迮

论曰。若容有新生应流至。此由非器世界。如有情世界而有增理。横竖世界安布定数容有减时。如劫坏时。有界空故。如有说云。犹如天雨注。若伊沙无间无缺从空注堕。如是东方无间无缺。有诸世界或成或坏。如是等然非有情新生新长。有其限齐。然而萨埵增多数无穷极。理不相容。更互逼迫受迮苦耶。今更设问。新生论者。所许未曾有情忽起。藉余业力识乃得生。为是熏耶为不熏耶若言熏者。从其属着新生识熏便成体。是一多过起。凡论熏习须共杂染及清净法同生同灭。依止此已作彼生因。非彼有情先有生因。令彼二法可共生灭。依止此已作彼生因耶。然而能为属著者。识与前二法同生同灭。为彼生因。颇无违失。若尔最初识许熏习。其属著者如前刹那。是此因故。次后刹那亦应如是。若异此者熏习之法理不成故。由斯道理。其父用功而得解脱。或复多闻。子不施劳应同其父。或时如子父亦应然如斯等类过失转多。悉皆招得

若言不由熏多种功能自起。若转救云。为无染净。同生灭故。依彼作因。有如前过。而今但取能属著者。因缘合故。为增上缘。为无根源彼得生起。此义固无不生果失。若尔功能与果灭。犹若业功能。彼诸贪等所有功能。既酬果已并皆息灭。如异熟业自有功能。既生果已随即沦丧。若异此者。便成无尽之愆。此亦如是。纵尔何失以不许投余种解脱不劳勤故。贪等功能既其灭已。离此所有贪等功能。望自自果更不许其投新种子。由种断故。纵不修习圣道便成圆寂。此便符顺。善见天言。苟出私怀赞扬非法。如彼言曰

  我观群众类　　彿心并彿身
  离诸欢乐欲　　别求除苦因
  但须耽妙乐　　何劳作余见
  即将贪染心　　便招涅槃理

转复生过业无用故。如略诠云。有三种福业事。所谓施性戒性修性。于此发起勤劳修习。诚无用耶。何故如是。以和合功能果自起故。若诸福事将欲灭时。于阿赖耶识置异熟熏。后时此熏随其自用得助生因。和合当生未来异熟。尔者所用劬劳营彼福事果不虚也。若也于先不修善业。藉彼属者为其缘故。异熟功能忽然生起。从此能生现法。生后所有异熟苦身勤修同前无用

又二种业思及思作善不善及以无记。如斯等类并成虚设。若言已后熏。及除阿陀那识最初刹那。乃至违缘未生已来。于自相续熏其贪等。如是便无所征诸过。若如是者。先时熏亦尔将其自熏习此并尽成陈。若不尔者如何与彼作生因耶。出世之智虽不曾得。但以堕在自相续中。所有似说二无性智。共许从此熏习之处而作生因。此闻之熏是极清净。法界等流之体性故。法界即是如来法身。我法二无性解。是法界所流果。法谓法身。界即因也。是出世间诸法之界。谓能持彼熏习性故。及断烦恼所知二障所有余习。名极清净。其闻熏习。是似彼果。彼为增上缘而得生起故。同彼体性故。如有说云。诸初发心菩提萨埵所有正闻熏习种子。虽曰世间。应知即是法身所摄。室罗缚迦钵羝迦佛陀应知即是解脱身摄。是故定知。虽是世间而能亲作出世间心之种子也。说法之义似相分识。虽现是无。而从其章依其句义。显彼所有相属道理。示以一篇类诸余颂咸亦同耳。于此断章虽无支分为令解了。若尔何过此并成陈。如于其后先亦同然。但是堕在自相续中。以其贪等而熏着之。若如是者即从先生种子而得生起。彼复从先。彼更由先。斯乃萨婆石揭。尽从陈种而生。所执新生便成无氏。据此便能立有先世

  天授初眼识　　定从余识来
  识性故应知　　犹如于后识
  假令灭定起　　心彼亦摄居
  宗内以理性　　同无不定过
  诸心心起法　　共许四缘生
  尔立最初心　　何谓等无间

心心起法从四缘生。阿毗达磨理成决定。尔者汝之所许最初起心。何者是其同无间缘。亦非在他相续之中。所有心聚与自心聚。为缘应理。少多不同故。更有定理。诸生有染论自地烦恼。今汝所许生有染心。便非自地烦恼。纵于三世境生理不能成。且非过去。不曾经故。亦非未来。由想曾经起愿求故。复非现在。由其意识自在而起。便成无有聋盲等故。复为五根及诸趣命根皆是异熟。汝便非异熟。奇异善谈经。然而说云。内五有熟养。故知眼等五根异熟性成五趣。亦是异熟体性。略诠为量故。有说。具寿诸那洛迦。由其漏恼现前力故。遂便造作生捺洛迦业。令数增长。具寿谓身语意曲秽浊业。命终便于可恶贱处令其异熟色受想行识被极煎煮。异熟生已名那洛迦具寿。此中离彼法外。无别那洛迦而可得也。言彼法者。即是异熟生塞建陀义。此处聚言。非无差别。此义即是遮其实。我能驰诸趣义准应知。意但摄取别异聚也。所云异熟生者。有情名体。虽不差殊为明有异熟者。谓五聚内善恶无记不是趣性。非是熟报。若彼亦是趣体者。即应现造生捺洛迦。诸不善业或数增长。此即应名那洛迦。为此诸识趣之体性。但是无覆无记。名为有情。于对法中亦如是说。又云。命根是毗播迦。思择命根必定但唯是其异熟。然瑜伽论要立诸法皆异熟识。曾无一法越异熟性故。然汝新起有情论者。便成根等不是异熟。彼新有情生受后受所有诸业。先非有故。现法受业。当尔之时弗容有故。由殊胜等因乃无故。亦复便成余所作业令他招报故。奇异善谈经者。将斯戏调意欲道渠。不善经论呈自胸臆。违阿笈摩故

手杖论一卷


四谛论

    No. 1647

四谛论卷第一

        婆薮跋摩造

        陈天竺三藏真谛译

    思择品第一

  般若遍诸法　　大悲摄众生
  无相说正道　　顶礼人天尊
  大圣栴延论　　言略义深广
  大德佛陀蜜　　广说言及义
  有次第庄严　　广略义相称
  名理互相摄　　我见两论已
  今则舍广略　　故造中量论
  利益说受者　　正法得久住
  若人达四谛　　四信处难动
  不更视他面　　永离四恶道
  八等人天识　　后必至苦际
  故造四谛论　　不由求慢等
  缘起义多种　　句味前后次
  他难及救义　　总别相应理
  证义及譬喻　　依此说四谛
  愿众生知此　　得天道涅槃

圣谛有四。此言是经何因何缘。佛世尊说如此经。云何圣谛有四不增不减。云何圣义及与谛义。若以圣故名为谛者。前二不应名谛。若言圣家谛故名为谛义则不定。复有经说。谛唯是一无有第二。云何四义而不破坏。复有经说。一切行法是名为苦。故唯二谛。四谛义不成。复次增一中说。安立诸法从一至二乃至众多。云何谛义独不增一。复次四相既其不同。云何一时而得并观。复次四相婆罗门谛。及与圣谛有何差别。持散偈曰

  云何四圣谛　　非谛不定境
  唯二增并观　　净圣谛何别

云何诸佛于四谛中同有一意。云何唯以四谛为诸佛上品正说。云何同观四谛为境。智慧平等而果有差别。云何阿罗汉于四谛中智圆无余。不同诸佛得一切智。若不同者。于四谛中应有无明。若一切法四谛中。摄胜奢波叶譬经。应须救解。若不救解应有五谛。若无五谛余法非谛。若苦等四名圣谛者。又说。一苦具足圣谛。如是等经则不须说。若四谛智说名为苦。是义不然。若知一谛亦知余谛者。说后三谛则为无用。云何在先说于苦谛。若未说因先说果者。何得不违一二缘生。云何说灭谛后说道谛。持散偈曰

  一意上果异　　一切智叶譬
  四违一无用　　先苦因缘灭

圣谛有四。云何佛世尊说此经。答有诸弟子应得圣道。先在外道禀受邪法。或事常行外道。或不住一处道护命道相违道老声闻道思瞿昙道鸟翅衣道事水道编发道事火道裸形道等。如是诸道各赞己法。唯有我法真实无余谛不相违无死为果。他法不尔。闻此言已无决定智。如是等法何者真实。何者不实。是诸弟子于谛非谛。起无明惑为显实谛。是故大仙说如是经。譬如有人为伪璎珞之所欺张。令其得见真实璎珞。复次有诸别法说如此义。若舍俗饰持沙门相。住阿兰若处行头陀法。值遇白法减舍财物。守护惭羞登上戒车。控制根马。磨练闻仗被服定铠。因此等行。自谓我等是真沙门。是诸人等起沙门增上慢。令其得见真实沙门故。佛世尊说如是经。为显此义。为通达四谛。于圣法中成实沙门。不由余行。如沙门经说。若有如此具如经说。实沙门者。由四谛观故得成立。不由世间修行究竟共得有流而名沙门。如裸形偈说

复次已免九难。前佛已生其厌离因法。以善根香熏习其心。已长圣道资粮意行俱净。应通达圣谛。是勤行心。为令服圣谛智药故。佛世尊而说是经。如可治病医则施药。复次闻恶道苦最极难忍生厌怖心。为如此人显不堕恶道因缘。故说此经。何以故。八地狱中受生众生。六方火焰之所围绕。举体洞然如融金色。其出入息皆是火焰受烧热苦。复有诸人饥食铁丸渴饮铜汁。或剉或斫或破或抽受种种苦。有众色狗及铁嘴鸟等之所啖食。或受饿鬼生。饥渴苦恒随逼身。咽如针孔。恒欲食饮终无饱足。渴行求水宿业所逼。若近河边便见河燥。或见脓血屎尿臭秽遍满。值花果树变成空林。如偈说言

  月炙如夏日　　风触如火焰
  雨渧如洋汤　　履地如热灰

是故饿鬼受苦最剧。或生畜生道。恒被笼系斫破鞭打。互相吞食更相疑畏。心恒不安。受如此苦。或生修罗。怨结悭吝慢触犯受是等苦。佛诸弟子闻诸恶道有如是苦。畏自堕彼。欲显四谛知见不是堕因缘故说此经。如人应堕海底施以船筏令其得济。如经中说。若有众生于如是苦能如实见则得解脱四种恶道及生老病一切诸苦。复次为令众生远离五种邪欺诳语。一能生众恶。二恶人受行。三贤人远离。四能发起烦恼。五欺诳为体。为令他说利益众生五分正语。一自德相应。二善人受行。三生长善根。四令离生死蕀刺稠林。五令至实乐离五邪言行五正语。故说此经。譬如令舍伪宝取真宝。如经中说。莫说实邪恶言。若僧聚集应行两事。一圣默然。二圣正法言。复次有诸凡夫。各自执着诸别异谛。我执是实他执为非。由此执故互相斗诤。如生盲见象。欲显最胜无死斗诤。无更起无颠倒。是圣谛智慧故说此经。为现此意。执着断常说我诸人互相斗诤。见四谛人则不如是了达真空故。如佉多柯经说。复次依正师长住空闲处。受头陀行减损生具。守护六根节量饮食。初后夜觉乐一心听。如理思量正说及诵。端坐寂定数息观门。由此因缘成熟相续。心地静细或聚动弱。为如是人令得通达故说此经。如润滑人施其利药。若真实义唯以智根名为通达。应知此根缘四圣谛。是通达经此中应说。复次为破四惑显两方便故说此经。如偈所说

  生起灭离闇　　种种诸邪执
  六十二种见　　因果中无明
  为破此等惑　　欲显不动理
  及系解脱缘　　故佛说此经

复次梵等诸天仙等诸人。婆利等修罗道龙等。说药叉等神。阎摩等。犹不见四圣谛故。不出三界狱。如蚕处茧。回转六道犹如车轮。漫走闇中堕深坑崄受大烧热。若见四圣谛。则破无明闇得智光明。解脱四恶道。则不仰观诸道。由是四圣谛真实无二无倒无诤。能成如来出世胜用。欲显此义故说此经。论主欲显四谛义无与等者故。说首卢柯

  知外谛不离　　律理行胜负
  不能度生老　　死忧悲大海
  则此圣智人　　贪嗔引斗诤
  智者求解脱　　外谛不应知
  若人见圣谛　　免恶道胜法
  离过无染浊　　常行四等心
  众苦所遍满　　解脱三界狱
  聪慧求涅槃　　应须见圣谛

持散偈曰

  弟子及沙门　　免难畏恶道
  过失与邪执　　师尊破显梵

云何圣谛。唯有四种不减不增。答此问非问。一切处如是无穷故。复次身见断见常见无事见。为对治此四。是故圣谛有四。复次为对治四倒故说四谛。犹如四念处。复次为离四种邪执事故。由一切众生有四种邪执。何者为四。谓果因解脱方便邪执。一果邪执者。我见念爱业所生阴界入等。不净臭秽犹如死狗。三苦火随烧。无常金刚之所破坏。我我所者使作者受者。使受者之所远离。此中净乐常我执。是果邪执。为离此执故说苦圣谛。二因邪执者。谓世主梵王自在人。双时自性定自然非因宿业亡尊曰宿药地水火风邻虚空等。此非因不平等因执为生因。是名因邪执。为离此执故说集谛。三解脱邪执者。归五入毗纽体极入空。至世俗住无苦上独存离我德三定果暂舍永舍。如是等执解脱者。非定非永名解脱执。为破此执故说灭谛。四方便邪执者。谓远离五尘饮食衣服卧具住处。风水花果根芽枝叶米面油滓牛粪。以此等物为饮食故。树皮茅藤板编草青鹿皮。用此等物以为衣服。或复舍此地上。并杵板刺灰聚。卧此等上。或首下脚上。或随向日热炙身。恒着湿衣恒住水中。大行投岩赴火永没水。依时节业尽无因。由此等行谓得涅槃。是名方便邪执。为离此执故说道谛。以事四故。故说四谛。犹如圣道。复次为分别希有法故。圣谛有四。何以故。取阴是众生依着处故。说苦应知不可依着。由贪爱故无有寂静。贪爱灭故则有寂灭。苦灭者我慢寂灭。心苦对治故。由修道故无明寂灭。道能对治无明故。复次一切求解脱人。灭苦得乐。是其胜用。灭苦云何。由集灭故。得乐由修道故。圣谛有故。复次经论师说。若人观见生死过失。观涅槃功德。则入正定聚。生死过失云何。谓受生识起失。此识起因即是贪爱。涅槃功德云何。谓识不起乐此识不起方便。即是圣道故说四谛。复次分别世出世因果故说四谛。复次通达四种故。复次依住四种故说四谛。复次别相四种故说四谛。问圣义及谛义云何。答圣义有八。一自在。若系属他则不自在。名为仆隶。不名为圣。诸佛及弟子。于心及法二处自在。故名为圣。二免贪爱好。如许自在人出家。三圣种生故。名为圣人。如生婆罗门种。四于圣地生。地者谓真实无生。譬如生中国地。五行离生死如婆罗门。六不乘生死车。如舍则无著。七不更生故。犹如陈种。八恭敬应往。以福德故。犹如皇帝。持散偈曰

  自在离贪奴　　圣种圣地生
  行离不乘车　　不生恭敬往

谛义有七。一不倒是谛义。譬如火相。二实有是谛义。如经中说。三无变异是谛义。四无二行是谛义。譬如树提伽蛇耶达多行。五不更起是谛义。从此智不更起。不同火轮智。六不相违是谛义。譬如业及圣戒。七文义相称是谛义。何以故。言苦者必苦为义。由此七义故名为谛

汝问。若以圣故名为谛者。前二不应名谛。又若言圣家谛故名为谛者。义则不定者。答谛是圣因。能生圣故。譬如梵住。故名圣谛。如经中说。四足为圣与义相应。复次圣人所说。故名圣谛。如导师路。如经中说。若诸如来。已正当说皆说四谛。问若以圣说名圣谛者。凡夫亦说应名凡谛。答承佛神力说故。成立佛正教故。非凡谛。如舍利弗行因缘。复次圣人故先所了故。譬如仙药。复次圣人依真实见。故名圣谛。譬如世谛。问凡夫依不实义见。应非圣非谛。答无清净眼则不能见。譬如生盲择真似宝。如翳眼人谬见多月。凡夫醉狂不得见。此譬如草头百象。复次智习论说以体圣故。故说圣谛。譬如乌蛇赤米。复次经中说。无上圣慧所照了故。故说圣谛。汝问。复有经说谛唯是一。无有第二。云何四义而不破坏者。答以无倒义故。一品类异故。四譬如四倒复次由谛义故。一譬如圣道事用异故。四譬如道分。复次法相通故。一譬如色相别故。四譬如四大。复次无我平等故。一无我者一切平等。譬如同异。复次无变异故。依心解脱说。谛唯一更无第二。何以故。苦等圣谛皆有变异。如经中说。一切有为空虚是破坏法。是一真实无坏心解脱。如变异相相应皆实不虚。四义亦尔。是故圣谛有四。汝问。复有经说。一切行法是名为苦故。唯二谛四义不成者。答分别部说意。一切有为法无常故苦。不由第一谛义故苦。为离此故。于世尊所修清净梵行。是名苦谛。后当广说。是故四义不坏。复次三苦种说种经。一切有为分分摄。有为苦者说具足分。如依苦苦说苦种苦根苦界苦受等。依坏行苦说亦如是。依一切受说苦。若无常是苦故。说一切有为。或依行苦说生起。是苦有生是苦色生。即是苦生。或说是苦谛。以种种意说苦。是故皆不相违。复次无变异故。依涅槃说一切有为苦苦田故。苦相相应故。故苦四谛义不失。汝问。复次增一中说。安立诸法从一至二乃至众多。云何谛义独不增一者。答义真实故。无颠倒故。佛说一切皆名为谛。虽一二三名为增一。谛无增一。为分别谛观故说有四。为安立智及相故如四念处。如前因缘成立四谛。是义应知为知圣谛故四。知苦有因即得见法。如经中说。若人见十二缘生名为见法。通达出世十六相。皆由见谛故。系属因缘是无常义。譬如鼓声。以难陀经为证。若无常是苦。若苦是无我。若无我是空。若人知此则得见法。通达十六相。得灭惑离苦。以是义故。圣谛有四。复次最上品故。不共智境界故。故无增一。如问复次四相不同。云何一时而得并观者。答由想故。经中说。修习无常想。拔除一切贪爱。是想境界即是苦谛。一切贪爱即是集谛。拔除即是灭谛。无常想即是道谛。以是义故。虽四不同一时得见。复次由思择故。如经言。因无常等想。思择五阴贪爱。未生不得生。已生则灭。此中五阴即是苦谛。贪爱即集谛。不生及灭即是灭谛。无常等思择即是道谛。以是义故。一时得见四谛。复次由观失故。如经言。观结处过失贪爱即灭。结处即苦谛。贪爱即集谛。灭即灭谛。过失观即是道谛。以是义故一时见谛。复次一时见谛。譬如火。火者是可烧等物。一时烧熟热照。观者亦尔。害生静出各各自相离灭。证修同在一时。复次譬如日。日者是可干等物。谓水种闇花各各异相。干熟破开同在一时。观谛亦尔。复次譬如灯。灯者是可烧等物。谓炷油闇物各各异相。烧干破照皆是一时。观谛亦尔。复次譬如船。船者是可到等不同相物。谓彼此两岸物流到离。载断皆在一时。观谛亦尔。分别部说。若聚苦相观达生灭心。厌有为修无愿解脱门。若观有为唯有生灭。不见余法。修空解脱门。若观寂静不见有为及生灭相。修无相解脱门。此中苦相即是苦谛。相生是烦恼。业即是集谛。相灭即是灭谛。是法能令心离相见无相。即是道谛。若见无为法寂离生灭。四义一时成。异此无为寂静。是名苦谛。由除此故无为法寂静。是名集谛。无为法即是灭谛。能观此寂静。及见无为。即是道谛。以是义故。四相虽别得一时观。后更思量故不广说。持散偈曰

  相思择过失　　火日灯船譬
  苦相脱门故　　一时观四谛

汝问。婆罗门谛及圣谛有何差别者。答世尊真圣真婆罗门。此谛故无差别。譬如释与天帝与。复次婆罗门谛道谛所摄。圣谛者。道果对治道境界所摄。复次一向善是婆罗门谛。善恶无记是圣谛。复次唯道是婆罗门谛。道果是名圣谛。汝问。云何诸佛于圣谛中同有一慧者。答通达无余法。相平等故。譬如净眼观色。复次证见法故。譬如火热明。此事世间一慧所共证故。复次熟磨法镜故。诸佛通达法界。知此一切三世。皆如现在。譬如众多水镜月面影一。持散偈曰

  两人一无异　　道善果故异
  无余证见故　　法镜故同慧

汝问。云何唯以四谛为诸佛上品正说者。答能拔众生度生死海。譬如出世法。复次谛中最胜故。譬如谛胜。复次能摄一切诸法真实故。犹如胜奢波叶譬。复次梵释等诸天不曾见故。乐行健力毗搜纽天等。智足未履故。智勤远行诸外仙人所得故。复次无分别智境界故。若能知此一切功德之所庄严。如舍利弗等及佛世尊。复次义具足故。由不共故。此说功德最胜。是故四谛名上品正说。汝问。云何同观四谛为境故智慧平等而果有差别者。答不由境同故智慧同。譬如定及贪欲等。复次由智慧差别故。故果有差别。譬由业差别故。果有差别。复次修道异故。故得果不同。譬如种子不同果有差别。复次观过失下中上品故。故得果不同。汝问。若阿罗汉于四谛中智圆无余。与一切智则应无异。若不然者。于四谛中应有无明者。答阿罗汉不知四谛外。诸佛境界非是无明。所以者何。但有说故。若阿罗汉不知四谛外言说。非是无明。如胜奢波叶譬经说。复次佛世尊已决判故。于苦等谛不知是名无明。不知四谛外四皮陀皮陀分等。不名无明。复次正对谛智对治烦恼。说名无明。非是不知一切智者。四种别说为无明。何以故。自苦一分识相续各各异。依约无始生死。阿罗汉亦不能见是心。如是已生。由如此增上缘缘等。及思惟等。善恶无记等。如是因所生缘所摄。在如此地迹位时中。次复第二心。次复中后心。如此方法。始自刹那罗婆牟休多。日夜半月一月时节。年数生变及灭自相续中。阿罗汉亦不能见。何况能见一切一切种自苦。若自苦尚其不见。何况能见他苦。是故阿罗汉不能见一切智境界。四谛中总别非是无明。复次离四谛无明对治。智境界外。复有余法在。声闻境界有阿罗汉。亦不能见。如舍利弗言。我不见有人天。能见知我。入初定观及称量我令我退起。唯拣世尊此寂定名。乃至目连亦不能解是舍利弗所入所起。乃至化度陀难蛇耶婆罗门。及其外生优波低舍。如定智慧辩说修习等。他不能及。如舍利弗。迦叶波亦尔。是故离四谛无明等对治。是名非智。非是无明。汝问。若一切法四谛中摄。胜奢波叶譬经。应须救解。若不救解应有五谛。若无五谛余法非谛者。答自然灭等不出谛外识境界故。非所观故。云何非所观。若知此法不得流尽及苦尽故。不离仰视外道面故。非诸见不能动如帝释幢。若通达此。不得称为微细通达。如射破发端不可遍行故。是故不须修学。复次余论师说。一切法由相故皆入谛摄。虽然皮陀及皮陀分宿传世本量判。僧佉愉伽实广论。欲尘论。鞞世师论。医方论。相论。算数论。时智论。兽论鸦域论。明论。歌舞庄严论。人舞论天舞论。天仙王传等论。外道论。常行外道等。乃至九十六种。复有草药藤树等。皮根心花果叶等力。熟德味等。复有世间不可思议希有四大变异业果报等。有论能分别此。佛依此论说胜奢波叶譬。如是等义不为汝说。不生功德故。能起诸惑故。增长有为故。是故不说。譬如毒药相憎药。反质咒幻化皮多罗论等。以损恼他故。佛所不说。非为四谛外故。所以不说。汝问。若苦等四名圣谛者。又说是苦具足圣谛。如是等经则不须说。又若汝言于苦谛是名苦者。是义不然。答是经说智为苦谛。如境无分别故。如说四量。复次由境界安立故。智得成立。譬如六识。复次由功能故。智体唯一。约能为四。如四正勤智亦如是。复次四圣谛智为总故。于四谛观说智为胜。由此义故说智如境。复次欲显决定出离是四谛功德故。随说一苦具足圣谛。与义相应。若了义说者。苦等是了义谛。何以故。佛说苦等有生等相故。安立四种观故。若不如此。唯有一观名为修习。若取此经分别诸谛。唯有一谛。所谓道谛。谓说无为谛故。是经非证此义。依阿毗达磨及藏论故得成立。汝问。若知一谛亦知余谛。说后三谛则为无用者。答我不说见苦谛即见余谛。我说一时见四谛。一时离一时除。一时得一时修故。说余谛非为无用。譬如说苦谛。复有为境界数量故。如说道数量。复次四中随知一已即通余谛。如知一粒则通余粒。是故四谛并皆有用。复次入观门故。观取阴即离舍爱念。如知怨家。取阴者是苦谛。爱念即集谛。离舍即灭谛。知是道谛。依苦观门。其义如此。知贪爱已即舍。由此苦不生贪爱即集谛。所贪爱即苦谛。苦不生即灭谛。知即道谛。依集谛观门如此。知有为寂灭已。若人证此。无明即灭。有为贪渴即寂静。有为寂灭即是灭谛。此所离法即是苦谛。无明贪爱即是集谛。知即道谛。依灭谛观门如此。知助道法即生修习。烦恼障与其相违。即舍。由舍此故有更生。助道者是道谛。有即苦谛。烦恼业即集谛。舍此及有不生是即灭谛。依道谛观门如此。由诸谛观门故。虽复观一说于余谛。非为无用。汝问。云何在先说苦谛者。答为止息苦修四谛观。及出家住于梵行故先说苦。复次生老死等众苦无边念念恒逼。行人观此求觅苦因。譬如师子。复次外缘不能治无始时节是根本病。行人观此求觅病因。譬如医师。复次遍满三界灾横疾恼。行人观此求觅其因。如寻毒树。复次粗故失故。厌恶依止故。惊怖处所故。故先说苦。汝问。若未说因先说果者。何得不违十二缘生者。答生次第故。十二缘生先因后果。思择次第故。于四谛中先果后因。是故二说皆不相违。复次果中有迷缘因计果。如经言。若此有彼亦有。由此生彼亦生。若因中有迷缘果计因。如经言。老死等有何法令有。由此义故。各有所破。皆不相违。逆顺说故。二说不同。逆说缘生。是名四谛。是故不违十二缘生。汝问。云何先说灭谛后说道谛者。答有二种义。一顺二逆。如经中说。戒清净为心清净。心清净者为慧清净。乃至解脱知见及明解脱。是名顺说。逆说者。解脱者以离欲为缘。离欲者厌恶为缘。厌恶者以实见为缘。乃至无忧悔者。以戒清净为缘

四谛论思择品究竟

    四谛论略说品第二

问四谛次第云何。答

  粗横重结所　　依道怖事果
  病火怨依债　　热毒逼害境

欲显粗大境故说苦谛。得苦相已。此法何因生故说集。此法尽何处次说灭。此法因何得故次说道。复次无始横网是名苦。横根名集。永离横根是名为灭。能拔除者说名为道。复次极重名苦。执重名集。舍名灭。能灭执名道。复次结处名苦。是结名集。结尽名灭。观过名道。复次取亦如是。复次依处名苦。世间凡夫虽为取阴所害。犹起依着。如依怨家谬为亲友。依所安爱名集。因此安爱住三有狱不求出离。譬如狂囚。无依爱名灭。无方所依止故。如瞿提经说。能灭依爱名道。观依过故。如观烧屋。复次六道名苦。以无乐故。犹如秽厕。业烦恼名集。为道因故。离道名灭。无假名物故。譬如火灭。如鹿头经说。能引出诸道故名为道。如婆罗呵马王经说。复次怖畏名苦。我爱名集。无畏处名灭。上实乐故运至无畏处名道。复次作事名苦。事因名集。拔除事因名灭。能拔名道。复次似果名苦。似种子名集。似种子坏名灭。似种子坏因名道。复次苦如病。集如病因。灭如无病。道如治病药。复次苦如火。集如薪。灭如火尽。道如火尽因。复次似怨名苦。结恨名集。除结恨名灭。能除因名道。复次似衣名苦。似尘名集。尘净名灭。净因名道。复次苦如债。集如贫。灭如离贫。道如财物。复次苦如烧热。集如烧热因。灭如清凉。道如凉具。复次苦毒发。集谛如毒。灭如离毒。道如阿伽陀。复次苦如逼恼。集如能恼。灭如离恼。道如离恼因。复次苦如杀害。集如能害者。灭如离杀。道如离杀因。复次苦应知。集应除。灭应得。为此三事故修圣道。次第如此。四谛体相云何。偈曰

  似真理足品　　有为相影识
  虚妄一切三　　逼有等十二

有诸法师说真似二谛。生者贪爱果故名为真苦。道者业果名为似苦。生因贪爱名为真集。牵六道业名为似集。生因爱尽名为真灭。六道因尽名为似灭。能灭生因正智名为真道。戒等方便能离道因说名似道。又理足论师说。识为真苦。与此相应色等亦名为苦。自爱名真集。与此相应业等亦名为集。自爱尽为真灭。由此尽故余尽亦名为灭。正见名真道。若此不生余不至灭。由此生故余亦名道。又假名部说。谛有三种。一苦品。二品谛。三圣谛。苦品者。谓五取阴苦。品谛者。逼恼为相苦。圣谛者。是苦一味。集品者谓贪爱集。品谛者能生为相。集圣谛是集一味。灭品者谓沙门果。灭品谛者寂静为相。灭圣谛者一味为相。道品者谓八分圣道。道谛者直离为相。道圣谛者一味为相。又分别部说。一切有为皆苦。由无常故。非初谛故苦。为离此故。于世尊所修净梵行。是苦圣谛。一切因皆名集。以能生故。非第二谛故集。为断此故。于世尊所修净梵行。是集圣谛。一切有为寂离名灭。由寂静故。非第三谛故灭。为证此灭。于世尊所修净梵行。是灭圣谛。一切善法皆是道。能出离故。非第四谛故道。为习此道。于世尊所修净梵行。是名圣谛。又说执相为烦恼。烦恼及烦恼所起业名集。若从此有有名集圣谛。有生名苦圣谛。如此从第二谛生第一谛。若心舍离执相达无相界。由此因故烦恼。烦恼所起业断。由此断故无复因缘。有不更生。此不更生名灭圣谛。此法能令心舍离执相证无相界。是正见等名灭道圣谛。如执相余影似道妄分别等亦如是。又分别论中说。世尊不依一切苦。假说苦谛。若尔何为为显无记果。执取阴性体相故。假说苦谛。假说苦因法。为别离此故。于世尊所修净梵行。是真苦谛。不依一切。因假说集谛。为显能生后有因性体相故。假说集谛。假说集因法。为断此故。于世尊所修净梵行。是真集谛。不依一切灭。假说灭谛。为显轮转道断性体相故。假说灭谛。假说灭因法。为证至故。于世尊所修净梵行。是真灭谛。不依一切道。假说道谛。为显能除惑道性体相故。假说道谛因法。为修此故。于世尊所修净梵行。是真道谛。又藏论说。略明苦有二种。一与憎会。二与爱离。此二二处。一身二心。因爱三种故。则成三苦。集谛有三。爱见及业。爱见二惑名为后集。由此已有业。粗妙集灭谛有三。一见一处惑灭。二欲一处惑灭。三有一处惑灭。道谛有三。一见道。二修道。三成守道。此三即三根。复说。苦者逼相。集者生相。灭者寂静相。道者能出离相。复说。苦者有相。集者能有相。灭者离相。道者能离相

    四谛论分别苦谛品第三之一

何者为苦谛。略说如此已。云何广分别。于苦聚中云何说生为初。云何为生。云何生相。云何生事。云何生缘生。云何苦。若生是苦三种乐生义则不成。生之与起云何为异。阿罗汉五阴未灭。云何说生已尽。云何为老。云何老相。云何老事。云何老缘。云何老苦。齿落相等不皆遍有。苦非不遍。云何说老是苦圣谛。有为不住念念灭故。云何有老。持散偈曰

  分别初四生　　苦三及差别
  尽四老并苦　　齿落等念灭

云何为病。云何病相。云何病事。云何病缘。云何病苦。若由病故身恒苦者。云何不违此偈

  无病第一利　　知足为胜财
  无疑为上亲　　涅槃无比乐

若天道无病。一切众生以病为法。此言应救正道。论说病为业果。是业果苦非苦圣谛。佛说苦名为病。又偈说饥为第一病。如此二说云何为异。云何为死。云何死相。云何死事。云何死缘。云何死苦。放逸死。破戒死。生缘死。此三何异。又有觉无觉死。有悔无悔死。有放逸无放逸死。有着无著死。有调伏不调伏死。少分调伏死。其义云何。五阴念念自灭。他害等死。云何得成。云何为怨憎会。云何怨憎会相。云何怨憎会事。云何怨憎会缘。云何怨憎会苦。若怨憎类有聚会者。永不相离。此义应至。云何为亲爱离。云何亲爱离相。云何。亲爱离事。云何亲爱离缘。云何亲爱离苦。老等聚会即怨憎会。少壮等离即亲爱离。更说怨会爱离。云何非重说耶。云何所求不得。云何求不得相。云何求不得事。云何求不得缘。云何求不得苦。欲尘即苦至得亦苦。求之不得云何为苦。以何因缘求之不得。云何略说五取阴为苦略义。云何诸阴何相。阴有何义。是色识等同有为相。云何说五阴与取阴云何为异。云何说取阴为苦阴。不名苦阴者何义。随正见一苦已即通达苦谛。何用广说诸苦相耶。经中亦说。色乐亦在乐处。若取阴是苦。经则相违。云何此经独说略言。余经说色苦乃至识苦取阴。复何因缘苦。总略义云何

汝问。何者为苦谛。略说如此已。云何广分别者。答有诸弟子乐略正教。如舍利弗等开智受化。是故略说。有诸弟子乐闻广说。如难陀及弗迦婆等。广分别智故为广说。复次有诸弟子。因力最强。如大迦叶。已增长善根故为略说。缘力弱者。如莎提等。未增长善根故为广说。复次利根如鸯崛摩罗等故为略说。钝根受化如蛇奴等故为广说。复次多闻弟子如阿难等。能持闻藏。是故略说。少闻弟子如周罗般陀等。智慧钝弱故。广分别说。复次富圣言胜德如离婆多等。数习内观故为略说。未有圣言及胜德。如阐那等未习内观。为广分别说

汝问。于苦聚中云何说生为初者。答曰。苦始故。老病死等诸苦生为最初。譬如无悔等世出世法以戒为初。如是老病死等。生为足所。故说生为初。不相离故。复次由生能故。若生已有老病死等。能害身根心等。譬如火若火已成则有烧熟照等。非不有火生亦如此。是故先说。复次不相离故。假使众生得离老病。决不离生。以行苦故。是爱果故。道所治故。故先说生。复次平等过失故。一切众生同受生害。譬如无常杀鬼。复次随逐一切有分故。生者遍无明等十二有分。譬如毒乳。复次遍三界故。生者遍三界。如牛同异。故先说生。复次苦根故。生者根苦。老病死等为枝叶苦。如经中说。一切诸苦以生为本。以生为因。如经广辩。故先说生。持散偈曰

  苦始能不离　　等失随有分
  遍三界苦根　　是故先说生

云何为生者。答偈言

  生五经等说　　得阴初续心
  生分与诸伴　　胎位及五种

释曰。如经阿毗达磨藏论。十二缘生等。心思择论中广说生应知。复次业增长品随眠为伴。引接生因缘法。聚集所得种种众生处。得阴入界等。是名为生。复次临续生时初识受生。是名为生。如经说。由识入故。名色和合。若说生次第。识初起名生。复次余论师说。生分初识与伴俱起。是名为生。复次生有多种。谓柯罗等胎位差别。乃至出胎如受生经说。复次生有五种。如偈言

  得圣法名生　　胎位姓家成
  聚同异及有　　唯有名为生

释曰。得圣法名生。如经中说。已免奴位从我口生。复次有已生圣法律中。如鸯崛摩罗经说。复次住胎位名生。谓柯罗啰頞浮陀伽诃那等。譬如种子芽茎枝等。复次姓家成名生。如金宝等刹利等生。复次聚同异类名为生。形相有异。谓人象马等。譬如婆罗多罗等树。复次有名为生。谓阴入界等有。是名为生。如说有花有子等。此论唯说有为生。何以故。本故贪爱果故。故言唯有名为生。云何为生相。云何为生事。云何为生缘者。答有显是生相。种种苦为事业有为生缘。云何苦者。答三苦火所烧故。是受生处非所爱乐。非福行果。聚同异类苦苦所烧。所受生处是所爱乐。是福行果。聚同异类坏苦所烧。所受生处不动行果。聚同异类行苦所烧。譬如野火烧绕大树。故说生苦。复次众苦所依故。若有生者身心众苦之所依集。非不生时。譬如鹿苑众仙所依。复次阴入界等有。显名生处。处生已斫破。刺擘解析分离堕失等苦平等随生。以无常怨不可遮故。如王子境及以坏器。故说生苦。复次生者是诸苦藏。忧悲恼生非苦根本。老死因缘诸病发起。痛入失类。诸恶依止。碍坏所践。疲极城门。怨具库府。烦恼续流。此生是闇非灯可治。深坑难出。无火大烧。是怨难觉。是拄不疑。是痛无药。是缚非绳。蕀林无导无有光火。婴儿赞叹。慧人毁訾。乐有所爱。诸佛菩萨引大悲因。有学所离无学除尽。诸佛自觉。立名为苦。故说生为苦。复次胎位苦故。临受生时赤白和合。有识来托受杂秽苦。次柯罗啰。頞浮陀伽那。卑尸等位。受转熟苦。如痈熟苦。既坚实已身分生时。受迫大苦。如大家苦。在胎卧时两藏重逼。譬如罪人下蒸上压受大困。由母饮食威仪失度。若走若跨若行泅水。伸屈役力被打痛恼。服相违食。由此威仪饮食故。支节如解。受种种苦。如犯王法受诸拷楚。故生为苦。临出胎时。其身柔软如芭蕉心。产门迮逼如压油车。受压迮苦。又初出胎时身如新疮。手水衣触如热灰灌。如刀剑解。受难忍苦。故说生苦。若生是苦。三种乐生义则不成者。答为分别业报异故。为安三界差别故。为显有三受故。由此应知。三安乐生行苦所摄故。是苦谛故。苦所逼故。苦众多故。故生是苦。复次有福行果故。有三乐生。如偈说

  福德果报乐　　随意得成就
  速得最寂静　　如愿般涅槃

无常恶毒所杂故。苦如杂毒食。虽具百味色香触好。若有食者决得死报。一切生死亦如是。杂无常毒故说为苦。复次为生时乐住时乐故说乐生。此安乐生坏时苦故。圣人厌此坏苦。如憎粪秽。故说生苦。生之与起云何为异者。答化生一名起。余三名生。复次入胎名生。出胎名起。复次有分次第生名生。一时具生名起。藏论中说。生者属识。托胎种子故。起者属业。能散置识诸道中故。阿罗汉五阴未灭。云何说生已尽者。答有既灭故说生已尽。复次因缘灭故。此生无后生法故说生尽。譬如由贪爱灭故说苦谛灭。复次为拔除生根本说已尽。譬如有树已断根故。虽富花叶等亦说已灭。生尽亦尔。复次当来应尽故说生尽。譬如山顶弃掷坏器。虽未至地已说其破生尽亦尔。故说罗汉生尽。云何为老者。答少壮灭失。次第度位。四大衰损。诸行变异。身缓节疏。色形粗丑。诸根羸弱。念识智行无所能为。归向死门是名为老。复次微细过根。遍入物中。后时方了减损变异。此法名老。何以故。老若入齿则现落相。若入皮中皮则缓皱百种黎黮。若入毛发则现脱白。若入四大大则疏弱。若入根门则根无力。若入身形形体战动举止不安。若入于心心则掉荡忘失忆智。若入背脊则偻屈。若入支节支节蹉戾。少壮软滑悉皆失故。现故坏相。复次老有二种。一依减失。二能依减失。一依减失者。诸大血肉膏骨髓等稍就减失。由此减失得相似果。谓走跳跨驷申屈去来勤力担负等。并皆损失。二能依减失者。谓眼耳等根见闻等用。皆不分明。由不分明得相似果。念智意灭心地勤力担负等并皆损失。如经及藏论。十二缘生论中广说。是名为老。云何老相云何老事云何老缘者。答减变熟坏故等。名为老相。少壮损失软滑去离憎恶事来。名为老事。阴界入生。是名老缘。此老又为忧悲等之处。云何老苦者。答此老能生众生憎恶相。已夺可爱色勤力忆智引就死王。如犯王法禁伺劓刖付杀者处。老亦如是。故说老苦。复次众生辩言身力根。能取持思量弃掷识及智力无间无眴。老日逼夺。如热时日解脱五翳盛光普照。小坑浅水皆悉干竭。老亦如是。故说老苦。复次老者。令色形丑陋能夺爱德。除灭少壮及无病乐。勤力担负念智忍门。思识悉能损夺。诸根羸弱无复势用。如罗刹女吸人精气趣向死处。故说老苦。复次少身莲华亲心所爱。色形端政悦他心眼。为老霹雳之所变异。卷缩破坏目心不悦他人憎恶。故说老苦。复次能坏身根念智。故说老苦。由身坏故。行住坐卧屈申转侧等皆不自在。由根坏故。见闻嗅尝触等皆不分明。又有说言。我闻不明还似婴儿。由念坏故更事不忆。不了所说曾见不识本。故说为老。犹如行相。又跋私弗部。说有为诸法实有暂住。此住有异。是有为相说名为老。如经中说。此身得住百年。或说有四识住。以是义故说名为老。若有为法实念念灭。少壮不成亦无命根。云何为病者。答曰。身界不平等生长。乖违不平等生长时。说名身病。若平等时说名无病。如佛世尊因耆婆说。如来身界今至平等。复次自性更互相违。不识恩养。身界毒蛇触忤名病。复次病有二种。一身二心。身病复有二种。一因界相违名缘内起。二因他逼触名缘外起。是身病者。由名因处有差别故。品类多种。名差别者。谓漏癞痈疽气嗽肿癖疟风狂等。因差别者。谓痰风胆及等分病。或单或二或三或四。如是痰等有六十二为病家因。处差别者。谓头眼耳喉心腹等。是名身病。若广解者有四百四。心病者因邪妄起。谓忧烦等。此病亦有二种。一缘内境名内门惑。二缘外为境名外门惑。由名因处有差别故。品类多种。名差别者。谓贪嗔慢痴见疑谄曲欺诳等。因差别者。谓净相失相有无等相为心病因。处差别者。谓色等六尘。如经说。色爱乃至法爱。此中所明。但论身病不说心病。云何病相云何病事云何病缘者。答病者逼恼身为相。苦忧为事。本界不平等是缘。云何病苦者。答世间聪明人。随其自能欲有造作。由疾病故并不成就。违愿故苦。是故疾病能为苦因。如火为烧因日为光因。老死等亦尔。为苦因故苦。复次能害本故。故说病苦。譬如蕉竹芦苇。复次生痛受故。能害命际令寿终故。如火毒伏故说病苦。复次苦苦所摄故。生及相续中。众生不能忍受。譬如象子落野火中。是故病苦。复次不得自在故。若人遭病。于四威仪及想皆不自在。其身低垂不能申屈行动等事。譬如木人关戾断绝。复次能舍寿命故。如人遭病不能忍痛。求火毒伏自舍寿命。譬如陀尼柯罗汉。复次一切方便不可疗治。来命必终故。故说病苦。譬如頞底仙人断痢汤药。复次所憎厌故。逼害为性起。长无明故。智慧恐种故。困苦为体故。不安依处故无学情忘。由智坏故。选择取舍之所远离。不识是事非事。犹如愚人。以此义故。故说老苦。如大德佛陀蜜说。诸佛世尊无量数劫。生长善根。具足十力。有十自在。胜破四魔。得四无畏。平等能观一切方便。秋时净空圆月可爱。那罗延坚固身节身力。形皮肤等相为老所损。故说老苦。此义佛在阿罗毗国。优陀夷比丘。依佛说偈

  恶老汝可患　　侵污爱妙色
  是身悦众心　　由汝故变异

四谛论卷第一四谛论卷第二

        婆薮跋摩造

        陈天竺三藏真谛译

    分别苦谛品第三之二

齿落相等不皆遍有。苦非不遍。云何说老是苦圣谛者。答遍满三界诸行变异。说名为老。是苦圣谛。如寿命灭。如经言。一切众生以老为法。复次诸天身形微妙稍损变害。前后异故。非无有老。细故难知。犹如其身。复次住前后异。是有为相遍满诸行说名为老。如牛同异。有为不住念念灭故。云何有老者。答一切有为法。刹那刹那灭实无有住。依相续住。故说老相。如江灯雨。是江水流。念念不住见相续不断。世人说言。此江流急。或言江长。灯雨亦尔。复次生死中间说名为老。何以故。初五阴起是名为生。最后阴坏是名为死。是二中间诸阴变异。病对治故。死生挍具故。说病为苦。若由病故身恒苦者。云何不违此偈无病第一利等。答冷热等病来逼迫故。说身恒病。免癞漏等重疾病故。游戏威仪读诵思修有力有能。故依此身说于无病为第一利。复次行苦火所燃故。说身恒病。暂离苦故。说无病为第一利。复次恒治助故说常病。身界暂调故。说无病为第一利。若天道无病。一切众生以病为法。此言应救。答阴生为苦遍满三界。是天道病。如经中说。色生是苦。生诸病依处故。如色余阴亦尔。又经说。比丘若说病者。是五阴别名。乃至痈刺等。又余师说。天将退时身心粗动。是名天病。正道论说。病为业果。是业果苦非苦圣谛者。答是业果报不离爱果。是故说业果报即说爱果。贪爱不离业故。如灯与光。业爱我见识果苦为性故。苦谛所摄故。不相违佛说苦名为病。又偈说饥为第一病。如此二说云何为异者。答若说病苦。重中轻病皆悉被摄。饥则不尔。故二说有异。复次不可治故。说饥为第一病。何以故。饥苦难治。治不穷故。如间日疟病。若眼病等则不如此。复次无止际故。是饥病者。从生至终永无暂息。余病不尔。复次饥病恒须治故。如朽弊屋相似无病。如怨诈亲。遍一切处故。揣食众生并患饥苦。如地狱品说。是故饥病最为第一。云何为死者。答命根断绝说名为死。遍一切众生故。由有火大能消饮食。身界毒蛇相乖违故。其性尽灭由此灭故。诸根无食随火而灭。心及心法根为上缘。以根灭故心法随灭。暖命及识舍离身根。是时名死如偈说

  暖命及意识　　若舍离于身
  眠尸委在地　　如枯木无知

复次同聚所得。阴界入等相续断绝。是名为死。死有二种。一自性死。二横死。自性死者。复有二种。一由业尽。二由命尽。横死亦有二种。一者自横。二者他横。复次死有三种。一随刹那死。二横死。三因尽死。随刹那死者。从托胎以来。乃至柯罗逻等十一位。无眴无息刹那谢。如偈说

  从初夜众生　　爱托住于胎
  无碍自然去　　一向往不回

又如经说。比丘汝等刹那刹那生老及死。是名随刹那死。横死者。毒火刀杖等自作或他作。因此命根断。是名横死。因尽死者。感长寿业尽灭无余。是死贞实。唯罗汉有。犹如灯尽。是名因尽死。云何死相云何死事云何死缘。答命根断绝。是名死相。舍离本道是名死事。生为死缘。云何死苦者。答怖畏苦故。是人临终为死金刚之所破坏。应往他方。非所究悉。将离亲友。我之爱热所护身屋崩破坏时。永离所作生重怖畏。故说死苦。复次火烧热故。若人曾经作恶不乐行善。将命终时破戒因故。见未来生恶道相现。起大忧悔身心焦恼。如死法经说。故名死苦。复次剧胎苦故。是人在胎中时恒受重苦。或母饮食相违威仪疲极。他所逼苦。虽受大苦而不失命。若死苦来顿夺前苦命根即绝。出胎亦尔。虽受大苦亦不失命。死苦若来夺此生苦命根即灭。复次在少壮位。受用六尘不知厌足。与所爱亲共住未久。由少壮无病性力自在财物胜故。恒起醉慢。是时若死其苦无比。若人过少壮位。财宝巨富谷帛资生。皆悉具足。或被王重罚。或遭困病。作是思惟。我必应死。其心已决。眼满热泪咽喉噤塞。观爱亲属目不暂眴。死王将去何苦剧此。是死至者如大山来。行四方便亦不能制。如大力怨不可摧伏。食啖一切如马口。火烧曝一切如劫末日。一切众生所不能度。如海水动不能过岸。如金刚霹雳碎五阴山。如大猛风拔倒身树。如伽楼罗吞啖阴龙。如饮味鬼伺人过失。如大怨贼恒夺命宝。如重罪人心无安乐。如恶国王重罚难谢。如春等时必定当有。以是义故说死名苦。放逸死破戒死生缘死。此三何异者。答慧命断故。名放逸人死。戒清净命破坏失故。名破戒人死。寿命根断故。名生缘死。复次退惰正法名放逸死。失比丘性名破戒死。退聚同分名生缘死。又有觉无觉死。有悔无悔死。有放逸无放逸死。有着无著死。有调伏不调伏死少分调伏死。其相云何。答行善凡夫圣及菩萨。正起忆念舍寿命根名有觉死。异此名无觉死。破戒人死名有悔死。持戒人死名无悔死。由五醉故。不恭敬行法律学处名放逸死。异此名不放逸死。于父母妻子等起爱着心而舍寿命。名有着死。异此名无著死。阿罗汉等在六恒住调伏六根。舍寿命根名调伏死。行恶凡夫散漫心死名不调伏死。有学圣人舍寿命根名少分调伏死。五阴念念自灭他害等死云何得成。答诸阴实念念灭。相续恒流。依相续故。他害等死得成。如约相续故说灯灭。复次诸根无事能故。譬如破瓶。复次寿命根坏故。有人说言。寿命根非刹那刹那灭。何以故。若念念灭寿命亦无。时死非时死他害死等皆不得成。三种病亦不得成。是故命根非念念灭。云何为怨憎会者。答怨憎亲爱不定故。若尘是所憎怨是其聚会。亦是所憎。如人于猪食。外曰。若尔苦谛不成立。以不定故。答不为怨亲尘不定故。怨憎会所生苦不定。如境界不定。生善则定。恶亦如是。怨憎会苦亦复如是。复次宿世恶业相似果聚集。名怨憎会立名为苦。复次怨憎会苦者。约苦受及资粮说。何以故。一切众生爱乐憎苦故。是受会名怨憎会。复次恶友共聚。多过失故名怨憎会苦。如偈所说

  与恶友共聚　　非聚多过失
  是功德最大　　离则无忧悔
  善友共聚价　　我思难判决
  分离时是苦　　是共聚等价

复次修净戒人。观细失怖畏。犯受恶戒事是其怨憎。生悔热故。恶觉观起。是修行人。憎怨能枯灭善法故。烦恼烧燃是圣人怨。能逆心静故。此中说恶业法烦恼果相应是名怨憎会。云何怨憎会相。云何怨憎会事。云何怨憎会缘者。答非所爱聚为相。心忧为事。业烦恼为缘。云何怨憎会苦者。答逼恼为体故。如恶邻里。为苦因故。如兽见狼。逼身心故。如毒刺在体。嗔恚缘故。如见本怨。无安因故。如无忧王传。复次与种种重苦品类相应。能害自身故。如阿难宿传。非爱相应多生求欲。求欲因缘生种种苦。如偈言。爱苦人求。复次由恶友故生大惊怖。如鹿见猎师。如人坐卧天衣所覆宝床。烧赤铁针以刺其身。身心战动生大困苦。是故名为怨憎会苦。若怨憎类有聚会者。永不相离。此义应至者。答一时境界性用相续。共相连知诸法恒相聚会。怨憎聚会异此义故。难不得成。复次苦受是名怨憎。此受不离于心。如是义者顺难。答如经中说。如摄有多种会义亦然。如持散偈言

  一分具分心　　道用类相应
  类处及自性　　经说名法摄

如摄有多种会亦如是。谓一境不相离。相对相着等。是故此难违顺皆得。云何为亲爱离者。答是亲爱尘或名众生或。非众生。与其别离名亲爱离。复次少壮无病寿命家色形富贵自在亲友相离。亦名爱别离。复次善业果报六入触摄。是退失名爱别离。如退天道。复次乐受破坏名爱别离。何以故。此乐受是爱着处。由此爱着于色等境亦生爱着。是乐受伴。谓想行识等亦所爱着。若论实义唯乐受坏名爱别离。云何亲爱离相。云何亲爱离事。云何亲爱离缘者。答离爱类为相。心忧悲为事。遭败为缘。云何亲爱离苦者。答因爱别离。是诸众生忧悲内然。犹如空树野火烧腹。如经说。若天退堕爱别离苦剧于地狱。如目连宿传。复次若众生疑闻见忆念亲爱别离忧悲苦生。是故名爱别离苦。复次父母妻子所爱眷属别离因故。如并失财懊悔失心。如着鬼狂漫语啼哭闷绝战掉。如临死人。如失王位重苦所逼。如无识无知痴乱默然。如船舶破没忧悲海。故名爱别离苦。老等聚会即怨憎会。少壮等离即亲爱离。更说怨会爱离。云何非重说者。答老等聚会少壮等离。如此二苦罗汉亦有。唯无憎会。如偈

  若一切永无　　怨憎及亲爱
  无忧无染心　　是人得涅槃

以此义故不名重说。复次由老病等无分别苦。与罗汉共。如前偈说。恶老汝可患等。怨憎会苦及爱别离因分别起。皆属心苦。未离欲人则有此苦。复由老病等名依内苦。怨会爱离名依外苦。故非重说。何所求不得者。答远离苦与苦不会。则得欢乐与不相离。求此不得名求不得苦。复次与生中老病死等诸苦。求不相会而不能得。是生定法故。故名求不得苦。复次求与怨憎不会亲爱不离。既不能得故。名求不得苦。外曰。此苦在前。二苦已显现。何用重说。答非所爱共聚名怨憎会。是所爱分离名爱别离。今求怨不会求亲不离。翻前二种立此为苦故非重说。复次已得未舍。与所憎尘共聚。名怨憎会。已得未舍。与所爱尘不得共聚。名爱别离。未得未舍。是所。爱尘求不能得。名求不得苦。由三世安立故非重说。云何求不得相。云何求不得事。云何求不得缘者。答求不得者。违逆意欲为相。以忧渴为事。现无功用宿不作善为缘。云何求不得苦者。犹如如意瓶等破故。失求王位等愿。复次苦因缘故。是所求欲五尘。由不能得欲火所然。如述波伽等烧然成灰。故名求不得苦。复次三时中能生苦故。是所求利我应不得。今不得已不得。由此生忧悲等苦故。名求不得苦。命尘即苦至得亦苦。求之不得云何为苦者。答以不定故。得者未必皆苦。何以故。若得信根不名为苦。复次是厌忧依止故。求不得者。能生求者厌恶忧恼心得五尘利。则不如是是乐想故。复次如少壮身老为后故。说名为苦。如是得五尘利败为后。说名为苦。如取阴为苦依止说名为苦。得五尘利说名为苦。义亦如是。以何因缘求之不得者。答因缘不具故。譬如种子若无有缘芽不得生。由宿世悭吝嫉妒邪见嗔故坏大家因。今求不得。如郁多罗比丘等宿传。因恶法故离苦受乐求不能得。譬如阿鼻地狱众生。求不得者。略说三因。一无宿世善。二自无功用。三他不爱敬。云何略说五阴为苦。答为摄初中后苦故。生为初苦。死为后苦。老等忧悲等名为中苦。复次为摄有间苦故。有间苦者。如老病死等。无间苦者。恒随一切有分。复次为摄各各自相无边众苦故。故说五取阴名通相苦。何以故。诸苦别类无边故。假使如来于无量劫广说苦相亦不能尽。复次生等诸苦如火。五取阴如薪。如烧然经说。复次五取阴为生等诸苦田地。何以故。取阴生苦名生取阴。变异苦名老取阴。逼恼苦名病取阴。破坏苦名死取阴。非爱聚苦名怨憎会取阴。亲离散苦名爱别离取阴。所须不遂名求不得。略义云何。答有三种。一多二异三一处。谓三世分散种类不同。摄在一处。故名为略。复次略有二种。一义略。以一义摄多义。譬如真宝。二名句偈略。能摄略义。如真宝器。如是苦有多义多名。但以一义一名摄之。皆尽说名为略。问诸阴何相。阴义云何。诸阴同一行相。云何不立一阴。阴及取阴二种云何。答如是等问。五阴论思择品中已广分别。问云何说取阴名苦。不直名阴苦。答欲分别谛有四相故。说取阴为苦。若直说阴是苦。则二谛不成。何以故。明阴戒定等五阴皆成苦谛故。问取阴何义。答爱欲是取义此阴能生取。为取所生与取相应。取所随逐能有取故。故名取阴。问随观一苦则通达苦谛。何用广分别诸苦相耶。答行人须广观众苦生厌离心。生厌心已能观通苦得入正观为此用故应须广说。复次为分别生老等苦生思择智。得此智已观苦一义。决无分别智。因此得生此智。以平等为境不劳功用。自然而流无有觉观。名第八智。依法境生。如宝象譬。问如经中说名为乐是乐依止。云何而说取阴为苦。答如偈言

  执对治乐故　　颠倒欲故乐
  经说为苦故　　正见故无乐

此义如五阴论广说。于轻品苦中及苦对治中。起于乐想实唯是苦。问此经中云何说略余经广辩色为苦。答为多闻慧人。是故略说取阴为苦。若无闻慧则为广说色取等为苦。如是为见光未见光人故广略说。问云何说取阴为苦。答苦盛逼故。如人处七宝楼。种种严饰可爱五尘。能悦其心生大欢乐。小针所刺即生苦受。忘失前乐如碱酸味。复次苦最多故。谓老病死爱别离怨憎会求不得。忧悲苦恼觅守失苦逼害苦等。取阴中最多乐少。虚妄如坏井水。问略说八苦其义云何。答众苦依止故生名苦。能令变坏故老名苦。能逼困身故病名苦。能灭诸根故死名苦。非爱共聚故怨憎会名苦。可爱相远故爱别名苦。悕望不遂故求不得名苦。是众苦相故取阴名苦。譬如射堋。复次有者。是真实苦有即是生。生是何法。谓名及色。色为老病死所害。名为别离怨憎会求不得苦所害。取阴为众苦所害。复次老病死名为身苦。以无分别故。爱别离等三名为心苦。由分别起故。生及取阴是身心二苦。复次由生说行苦。由死说坏苦。所余五句说名苦苦。此三苦以取阴为因。复次取阴有起名生。六道出现故。身变熟名老。以萎悴故。身界不平等及增长名病。令相违故。命终阴坏名死。离本道故。非爱受因共聚怨憎会乖意相应故。爱受因相远名爱别离。与爱不共故。所欲不遂名求不得。如愿不成故。为一切苦种本田故。取阴名苦。诸苦自生无功用故。婆薮跋摩法师分别苦谛品究竟

    思量集谛品第四

说苦谛已。云何次第说于集谛。集者何义。云何自问及答。是渴爱何者。渴爱何相。何事何缘。是渴爱是言胜义。云何渴爱即集。此言自足。说渴爱已。何用复说能感后有。能感后有其义云何。能感后有决定喜欲相。随处处爱着。云何作多种说喜欲。何义随义。云何处处爱着重言。云何有诸别惑能作集相。云何但说渴爱为集。何因独说渴爱为集。不说诸业。若贪爱等。亦是业烦恼集。云何说但苦集耶。无明缘观味缘三受缘等爱。其异云何。已说四大触名色各为诸阴因。复说渴爱为因。此二说云何不相违。渴爱无明我慢业食皆为苦因。此等异相云何。喜欲欲欲等其义云何。藤林等是贪别名。其义云何

汝问说苦谛已。云何次第说集者。答已决心信果。未识信因。令识信因故。次说集为显苦谛随属因缘。复次为受化者迷十二缘生故。说苦谛依因缘生。复次苦谛犹如机关。随属因缘故。自性羸弱及无我相。复次世间贪爱坚锁之所系缚。不能出离生死牢狱故。显所缚能缚。复次有诸众生作如是计。此苦谛者。无有始终。难可除灭。由此执故不修正勤。是故佛说。苦虽无始。由因缘生故可除灭。譬如种子。故应修正勤。汝问集何义者。答平等聚生是名为集。离此三义则不成因。复次令起有本泉源能成能现。遮因缘是名集义。汝问。云何自问及答者。有诸弟子不解怯畏定心。护此三事故。佛自答者。为破难邪因显立正因。有诸异执。谓梵王自在及天人。时性四大空邻虚等。以为正因。为破邪执欲显正因故。佛自答。复次于十二缘生等诸经。已说多种集。有诸弟子未知此经定以何法为苦集故。佛自答。为欲令得决定智力。复次为覆智受化不通达略教中义。为令开觉故佛自答。复次为胜智受化觉观多故。不执持令智坚固故佛自答。复次为了智受化令得决定智力故佛自答。复次为分别智弟子令得了别。犹如燃灯。故佛自答。汝问是渴爱何者。渴爱何相何事何缘者。答是诸众生恒观有为法功德。依有用资粮心无厌足。故名渴爱。如饮碱水。如人盛夏昼日光照热渴所逼。周遍觅水来饮碱海。碱海有竭此渴无尽。如是世间凡夫。常为生死资粮爱欲焦然其心。邪妄分别令生热渴。一向专求五欲快乐。眼耳身识及心忆持所受用物。已得未得永无厌足。故说此法名为渴爱。复次不知厌足名为渴爱。如火草薪果苏蜡等。是所烧燃。于取类中无有厌足。世间凡夫贪爱然心。于人天中上妙五尘。念念受用不知厌足。如项生王。复次渴爱类见性别异故。各为二种。类异者。于取阴中起我执我爱。是名缘内类贪。于非取类中起我所执。是资粮爱名缘外类贪。见异者。依因有见愿有胜生。是名有爱依。无有见愿乐我断名无有爱。性异者。贪爱倒起覆藏为事。犹如云网。故名上心。贪爱随眠随逐为事。犹如蹑毒。名离心爱。复次渴爱因依缘业别异故。各为三种。因异者。愿乐未曾得尘。是爱名求觅苦因。于已得尘心生贪着。是爱名守护苦因。于已失尘心生懊恼。此爱名忧悲内热苦因。依异者。谓众生处所受具。众生者。乐得未来阴。求欲生故名依众生。爱处所者。乐三有道常求此处。名依处所爱。乐好声触色味香等尘境界。求欲受用。名依受具爱。缘异者。谓贪爱能作烦恼业苦缘。及缘此三起。业异者。谓平等不平等相续渴爱。平等爱者。依道理求觅受用。名平等爱。翻此名不平等爱。相续爱者。随眠贪爱无始相逐名相续爱。复次渴爱取道对治资粮别异故。各为四种。取异者。于欲界中欲喜迷闷渴爱贪着。名为欲取。于我言见戒等中渴爱着亦尔。道对治异者。谓四圣性所对治故。资粮异者。谓饮食衣服卧具医药。复次渴爱依三受别异故为五种。于乐受中生二种爱。谓聚集爱及不相离爱。于苦受中亦生二种。谓不聚会爱及相离爱。于舍受中起无明爱。复次渴爱以事异故。离为五种。谓未得求得以愿为事。二生愿乐已求觅为事。三求觅得已增长为事。四增长已守护为事。五既守护已后时失坏忧悲为事。复次渴爱依五阴故五。依六根故六。依六根各有三受故成十八。复次依结及离结故三十六。如是等是贪爱树随眠为根。我爱资粮受为身干。三界贪爱为其高大。六爱聚为枝。爱行为茂叶。百八爱为花。生等为恶果。如此渴爱为苦集因。为苦生因。名为渴爱。此中应知。渴爱相者。心喜为相。事者无厌足等十一种为事。缘者观有为功德为缘汝问。是渴爱是言胜义。云何渴爱即集此言自足者。答渴爱多种。若能感后生乃是定集。余则不取。若不尔者。闻正法等亦应为集。复次是渴爱能感未来。若不能感则非所取。复次是渴爱若与喜欲相随。则名为集。若不尔者则非所取。复次为欲简除似集谛法故。言是渴爱。复次是守为显证量。如现世苦因渴爱生证量所得。当知去苦生不离渴爱。如郁伽长者经说。汝问。说渴爱已何用复说能感后有者。答渴爱者。此言未了故。说能感后有显定渴爱。若但说渴爱是集。则阿罗汉渴爱水等亦应是集。若有渴爱能为灭渴爱。依止亦应成集。汝问。能感后有其义云何者。答能令识等阴着后有故。何以故。我及我所是所执处。如是渴爱能令识等执着此处。如尘着湿衣种子着湿田。复次能生未来有故。如母生子。复次能为未来生食。故如识食触。食复次能引能爱。故故说能感后。有又有往昔耆旧诸师释佛说。渴爱有四因缘。能感后有。一能使相缘。如经言。随眠贪爱未被拔除。是苦恒生恒续犹如龙池。二能摄诸道故。如经言。比丘若于色等境界。起贪欲爱着。是识随依色住。受想行亦如是。三能结能续。如经言。能结能缝不舍境故。令未来世三有得生。四能令受生。如经。于此四食处若有爱欲。名色即生。汝问能感后有决定喜欲相。随处处爱着。云何作多种说者。答此三句皆是渴爱别名。譬如人手名为頞悉多。亦名柯罗。亦名波尼。复次果伴境界别异。是故多说能施。未来果故。说能感后有。喜欲为伴故。说喜欲相随。取种种境故。说处处爱着。复次有法但感后有。不与喜欲相随。如随眠贪爱。有法但与喜欲相随。不能生有。如不堕界贪。故应具说多名。汝问。喜欲何义者。答喜者于有资粮中心生安乐。说名为喜乐。此中生欲名为喜欲。譬如色欲。复次喜种类欲名为喜欲。譬如宝瓶。复次是乐有染名喜心著名欲。合此二种故名喜欲。譬如名色。复次喜欲更互相生。故名喜欲。如庵罗子等。汝问。相随义云何者。答共义名随。此随眠与上心为伴。能生后有。复次外爱共行故。说内爱与喜相随。譬如爱取。复次随者。得地为义。复次分别部说。相随有四种。一境界相随。二相应相随。三间杂相随。四缘起相随。境界相。随者如经说。若人起觉观。分别与色相随。相应相随者。如经言。此心与慈相随。间杂相随者。如经言。是人修习信根与慈相随。复次有经说。染着憎恚相随思惟相随。缘起相随者。如经言。修习正见与无放逸相随。此论所明喜欲。即是间杂相随。汝问。处处爱着重言云何者。答于三有中爱着种种诸界。于诸界中爱着种种生处。于诸生处爱着种种众生聚。于众生聚中爱着种种诸根。于诸根中爱着种种诸尘。于诸尘中爱着种种诸业。复次心猴行境不定。恒乐取尘随逐渴爱种种诸有及有资粮。由随摄舍处处爱着。复次观着求处行不定故。如偷稻牛。复次弃取余尘亦不离欲。譬如五囚人母欲说处处爱着。汝问。有诸别惑能作集相云何但说渴爱为集者。答为最胜故。若渴爱王所至之处。一切惑众皆同聚集。复次由渴爱摄故。若渴爱不令余惑啖味。余惑则灭。若诸惑不起。贪爱亦不起。何以故。无分别依故。复次设无余惑。但有贪爱生死亦起。如手抟湿沙。复次难分别故。由此渴爱亦入善法。但观口故如内怨家。复次至门不入故。如阿那舍至涅槃门。由贪爱故不能得入成上流人。问无明亦胜。何故不立。答不然。无明盲人由渴爱故堕阴坑苦。譬如盲象。求欲后生。故受来报不由无明。譬如生盲入诸门。以是义故。故说渴爱为集。汝问何因独说渴爱为集不说诸业者。答烦恼胜故。何以故。贪爱等是实生因。业不如此。云何知耶。业虽具在。为贪爱尽故。诸阿罗汉无复后生。前来已说有真似集。贪爱等能为有因故。是实集谛业为引有因故。说为相似集。复次贪等由道所灭。业则不尔。何以故。诸佛等究竟修道已。犹闻有残业在。复次业不堕界故。不名真集。汝问。若贪爱等亦是业烦恼集。云何说但为苦集者。答有如是义。此中为立四谛故说为苦集。何以故。于圣谛中简择真实因故。说渴爱等为苦谛集。复次有及生阴渴爱为集。是渴爱于现世中与生等诸缘。共作烦恼业集。不如渴爱独为苦集故。但说渴爱为苦谛集。复次定以随眠渴爱为苦谛集。为显此义。佛说偈言

  如树根未拔　　虽断犹更生
  随眠爱未除　　苦体恒相续

约缘内渴爱。说缘爱起取。约缘外渴爱。说缘取起求觅业。汝问。无明缘观味缘三受缘等爱其异云何者。答经说无明为爱。缘此爱为烦恼缘起。经说观味亲境起常邪等见。因此起爱。是爱为业缘起。经说由贪爱故得三种受。是爱为受缘起。复次一切烦恼无明为缘。此贪爱缘无明起故。说缘无明爱。一切诸见为诸业缘。缘此诸见起贪爱。此爱名业缘爱。一切诸苦三受为体。缘此起爱名苦缘爱。复次不信了为因。名缘无明爱。观有为法乐常等味邪智为因。名缘观味爱。余类为因名缘爱爱。此爱为缘起。及界有三。由境界有六。汝问。已说四大触名色名为诸阴因。复说渴爱为因。此二说云何不相违者。答为显有因故说渴爱有已。为显等分因故说四大。为显种种因。故说于触为触不一故受有三。为坚信因故说名色。如大缘生经说。阿难。若识不托母胎。是迦罗啰。得结实不。不得世尊。阿难。若无迦罗啰。是识能托胎不。不能世尊。由此二法更互相持故得坚住。复次无始时因名渴爱。一期因。谓四大刹那因。谓触及名色具二因。谓宿世因及现功用因。复次五阴宿世因。谓渴爱于受生中四大为初因。如迦罗啰为頞浮陀等因。俱起因名触。先时及俱起因名为色。汝问。渴爱无明我慢业食皆为苦因。此等异相云何。答渴爱为无别异因。业为别异因。食为引持苦因。无明及我慢为一切因。复次渴爱能为有因。业为道因。食为平等因。无明及我慢为更互因。复次渴爱为苦真正因。是苦根本故。所余因为资粮。集助贪爱故。汝问。喜欲欲等其义云何。答尘已到故心生欢喜。由喜生爱故名喜欲。求未得尘名欲。因此生爱名为欲欲。汝问。藤林等是贪别名。其义云何。答欲尘为境界。能染于心故。说欲染贪着四定及果是名色欲。贪着三摩跋提及果。是名有欲。能障涅槃行。说名为刺。能烧热心说名欲火。能垢污心说名欲尘。能令心浊说名欲垢。能缠绕心说名欲辫。无思计故说名欲缚。令痴迷故说名欲闷。心沉名欲着。随有行故说名随流。常悕望故说名无厌。得无饱足故说名为贪。障出离故说名为盖。能覆藏故说名烦恼。令不离有故说名为结。不正思惟所触恼故。说名为锥。能萦朿刺故说名为藤。向上转增故说名大。欲周普界道丛根尘胜乐等故说名为遍。着种种尘起种种着。说名爱着。于生死资粮未得及得心生欢喜。说名喜欲无厌。积聚欲尘利养名为渴爱。如是方便轮回送引不离生死。说名欲将。游烦恼水结爱行绳。说名欲网。从上下流入生死海。说名爱河。譬如变异渴病所逼入尘海。由此无有饱足故名渴。如海吞流。如火烧薪等。此惑无满。说名无休。能结死生前后无间。故名为缝。此渴爱在。能令生死相续不断。或由自由他能受六道生死故。于余惑中说名为集。具如大有品中广说。此品解贪爱有十一种应知。一名。二义。三体。四用。五因。六对治。七净。八不净。九生次第。十立难。十一救义。若行人识此起观。自行教他不迷道理。故说此义。思量集谛品究竟

四谛论卷第二四谛论卷第三

        婆薮跋摩造

        陈天竺三藏真谛译

    分别灭谛品第五

经说苦灭。云何此言。何所因起。何法为灭。何相何事何缘灭名。何义无余灭。离灭舍断弃。此七义何异。云何尽无余。名为灭谛。不说念念灭等。若渴爱灭名为灭谛。无余涅槃则非灭谛。渴爱尽者。应名集灭。云何说苦灭。若由渴爱尽故苦灭者。无渴爱人即应无苦。现见有苦。此理云何。十结惑中但说渴爱灭为灭谛。安立四果。云何得成。十二缘生中说灭有十二种。云何但说渴爱尽为灭。持散偈曰

  何节及前义　　七义与念灭
  界他灭罗汉　　十结十二灭

汝问。经说苦灭云何此言何所因起者。答由是法生故是法有。是法灭故是法无。譬如灯。复次已说苦谛渴爱为因。今说由渴爱尽故显苦灭。譬如病缘灭故疾病不起。复次是渴爱流遍满三有。无始时起欲对治有故。故阿罗汉无渴爱灭。为破外道如此邪执故说苦灭。云何汝问。何法为灭。何相何事何缘者。答灭有多种。一中间灭。二念念灭。三相违灭。四无生灭等。中间灭者。如施戒定三摩跋提能灭三有。由此施等随得免离所对治法。谓贪嗔等暂时不起。名中间灭。念念灭者。一切有为随刹那谢。名念念灭。相违灭者。此有为法与相违因其性相乖。相续灭故名相违灭。此三名相似灭。无生灭者。有因灭尽故。五阴应生不复得生。此名真灭。又余师说。因及有因渴爱后有不生名灭。复次与渴共除烦恼爱业苦不生名灭。复次是真实用经无所有离有离无。是般涅槃名为灭谛。如瞿昙传说。复次灭有二种。一非择灭。二择灭。非择灭者。有为诸法自性破坏。名非择灭。如空石堕择灭者。由智火故惑薪烧。是名择灭。如因火薪尽。复次灭有三种。一未有灭。二伏离灭。三永离灭。若惑未生未得缘地。名未有灭。若惑已生已得缘地。由世出世道现时不起。名伏离灭。若惑已伏离灭因灭无余故。未来决不生。是名永离灭。如经言。未生欲欲未来永不复生。亦知此灭。又分别部说。灭有三种。一念念灭。二相违灭。三无余灭。譬如灯灭。又余师说。灭有四种。一自性灭。二无生灭。三中间灭。四永离灭。不由因灭名自性灭。如偈言

  诸行悉无常　　生灭是其法
  若有生还灭　　此寂灭是乐

又经言。若法有生是法必灭。不由功用。如物轻重自然浮沉。名自性灭。由因无故果不得生。名无生灭。如经言。由无明灭故三行不起。如七流中种芽。因坏果则不生。名无生灭。由定力者名中间灭。如经言。伏离上心惑。名有时心解脱。九种次第灭。如难提柯比丘缘事为证。名中间灭。由八圣道灭。名永离灭。如经言。若人修无常想。能灭一切结及随眠惑。以明生故无明永灭。名永离灭。犹如覆器及被燃炬。此论正辩永离灭。何相何事何缘者。无所有为灭相。心不烧热为事。通达实际为缘。大德说寂静为相。心安止为事。极解脱知见为缘。汝问。灭名何义者。答此灭名尼卢陀。尼者训无卢。陀训遮障。渴爱等法能障。此中永无故。名尼卢陀。相违法生起故。渴爱流永不更生。如熟烧坏赤色生故本青色相永不更生。汝问。无余灭离灭舍断弃。此七义何异者。答此皆是涅槃别名。此七名依器故说。如涅槃有六十别名。复次上心及随眠俱尽。如树拔根名无余灭。次第灭尽。如斧柯喻故名为灭。昔缚着处由道力故无有缚着。如富贵人不着贫贱。是名为离。胜异昔退如圣人离。恶尽故名为灭。又如前义名尼卢陀。是名为灭。若法与惑相离。譬如舍物。是名为舍现世。是与未来永不相续。譬如内根。是名为断灭。不更取如覆水器。是名为弃。复次一切渴爱品类净尽。故名无余。渐坏名灭。由观过去不起着心。名为远离行。断结尽缘起亦无。故名为灭。解脱烦恼。是名为舍。缘智初惑永灭。是名为断。先取我执今则置舍。故名为弃。汝问。云何尽无余名为灭谛。不说念念灭等者。答由无余灭故未来苦不更生。不由念念灭等故说。无余名为苦灭。不说念念灭等。若观无余灭寂静等相。能灭诸惑。念念灭等则不如是。复次随属道故。胜余法故。真实善故。不共得故。烦恼不能坏故。不违言故。安心缘故。故说无余名为苦灭。不说念念灭等。汝问。若渴爱灭名为灭谛。无余涅槃则非灭谛者。答余论师说。清净梵行果故。故烦恼灭名为灭谛。一切假名灭名无余涅槃。此论所说无余涅槃界是真灭谛。何以故。为得此灭修净梵行。如富楼那七车譬经中说。诸阿罗汉惑尽无余。而老病死寒热饥渴害缚等苦犹尚未免。是故无余涅槃界是真灭谛。此真灭谛由因尽故得。故说渴爱尽是真灭谛。优波及多道理足论说。能令至无余涅槃界故。故贪爱尽得名灭谛。虽然有余无余二涅槃界。皆名灭谛。何以故。因灭名为有余。果灭名为无余。由因灭故。故有因灭。如灯尽故光尽。是故二灭皆名灭谛。汝问。渴爱尽者应名集灭云何说苦灭者。答苦火以渴爱为薪。若无渴爱苦薪苦火即灭。如薪尽火灭。复次苦谛以爱食得住。由爱食断故苦谛即尽。故说苦灭。复次耆旧师说。不为离过去及现在苦。于世尊所修净梵行。何以故。过去自性已灭。与现在决应相离。未来有苦为令不生。于世尊所修净梵行。是苦不生。由渴爱尽故。约后际苦尽说爱断苦灭。汝问。若由渴爱尽故苦灭者。无渴爱人则应无苦。现见有苦。此理云何者。答忧悔热苦寂静故。如手长者经说。复次永离心病故。如已拔心刺。复次求欲苦断故。如富足六尘。由渴爱灭故。诸阿罗汉永离心苦故不违理。复次非过去未来现在苦名为苦谛。亦非圣道所破。何以故。过去已尽未来未有。与现世决定应相离故。但由通达实际故。渴爱灭尽。由离渴爱故。为后际苦不生修八圣道。以是义故说阿罗汉无苦。如渴病譬。汝问。十结惑中但说渴爱灭为灭谛安立四果。云何得成者。答贪爱有四种。须陀洹果道等所破。由此灭故。余结共起一时俱尽。说名灭谛。是故安立四果于理不失。复次同一相一味故。若说渴爱尽则说一切结尽。如说八圣道即说一切道品。以同相故。共成一事故。复次有诸余惑。亦能立集谛相。而渴爱正能续未来生。能令后有。以是义故。独说渴爱名为集谛。如是一切惑尽皆入灭谛相。但有因灭尽。是渴爱灭名为灭谛。汝问。十二缘生中说灭有十二种。云何但说渴爱尽为灭者。答如前问此难自遣。复次如道断爱尽欲灭涅槃。此五名义。一但更互相显。是故由说渴爱尽故。即说十二道断。复次渴爱尽为通灭。十二道等灭名为别灭。问涅槃别名有六十六句。其义云何。答无为等一切句。相貌赞叹。因立对治违反等。应广解释。何因如此。是涅槃无生无长无灭。非因缘所作。违反有为。故说无为。(其一)高出三界离于偏低。无与等者。故说无下。(其二)永离诸流诸流不生。非流迹处。故说无流。(其三)非虚妄非颠倒非相违。故说真谛。(其四)不疑诸界毒蛇怖畏。穷三有际舍功用处。度生死海。故说彼岸(其五)。极智所了故说听细(其六)。如优昙花世间希遇。故说难见。(其七)不老不破故说无坏。(其八)无动本有故说恒在无争。(其九)对治除法。体不亏故说无失。(其十)过眼境界。无法与等。故说无譬。(其十一)无有贪爱诸见慢执故无戏论。(其十二)惑火灭尽故说寂静。(十三)过死王界故说甘露。(十四)是极美味寂静可爱故说极妙。(十五)寂静无苦故说为止。(十六)真实善法故说为安。(十七)无烧热渴故说爱尽。(十八)生他叹讶故说希有。(十九)于生死中未至此德说未曾得。(二十)老等诸横所不能害。故说无枉。(二十一)内无所少外无恶障。故说无灾。(二十二)无后有生苦究竟安乐。故说涅槃。(二十三)异有无相故说难思。(二十四)与离生过失乐相应。故说不生。(二十五)四魔不至故说无迹。(二十六)不由因成故说非作。(二十七)非悲行处故说无忧。(二十八)一得不退故说名住。(二十九)无法能似故说无等。(三十)永离取欲故说无求。(三十一)无前后际故说无边。(三十二)难可通达故说微细。(三十三)无有可逼故说无损。(三十四)无惑染着故说离欲。(三十五)无诸过失故说名净。(三十六)结缚皆断故说解脱。(三十七)离依止故说非住。(三十八)无有二法故说非对。(三十九)无等等故说为等。(四十)诸入没处故说无害。(四十一)外人不得故说甚深。(四十二)离佛正教不可了知。故说难解。(四十三)观此功德令到彼岸。故说能度。(四十四)上法之定上故说无上。(四十五)攒搜法海所获贞实。上人所得。故说为胜。(四十六)万行所得最上无价。故说圣果。(四十七)离恐怖因故说无畏。(四十八)圣爱坚固故说不舍。(四十九)凡圣等有故说遍满。(五十)功德难称故说无量。(五十一)不属六道故说无数。(五十二)体极贞固故说不破。(五十三)诸法无首故说为尊。(五十四)最净可称故说应赞。(五十五)众圣所栖故说为舍。(五十六)能救众苦故说归依。(五十七)战斗寂静故说无争。(五十八)本有非作故说无假。(五十九)离欲嗔痴故说无垢。(六十)除无明闇故说为灯。(六十一)诸受寂静故说为乐。(六十二)免色等坠故说无堕(六十三)四流不没故说为洲。(六十四)散心不证故说不动。(六十五)遣荡十相说无所有。(六十六)无所依故说名无著。经部问曰。何法名思择灭。答结离名思择灭。问结离何法。答是思择灭。若尔此二互相释。终不能显二法体相。是故应别方便说其体相。圣人无分别证智所知。是其体相。如是可说。为善异于余物。或说名结离。或说思择灭。诸经师说。一切无为非是物有。何以故。不如色受有。于别物何者唯以无触名为虚空。如经言。闇中无碍无覆名为虚空。由般若力与现在随眠惑。体性相违余后不生。名思择灭。离此思择因缘不具余不得生是名非思择灭。譬如一期中间横死残果不续。异部师说。随眠烦恼后不得生。是思择力故名思择灭。由缘不具后苦不生。是中思择无力故说非思择灭。论曰。是义不然。若离思择此灭不成故。知属思择灭。又诸部说。若法已生生后自灭。自性灭故名非思择灭。若如此执非思择灭。应是无常。何以故。法未坏时未有灭故。难曰。若尔思择灭亦应无常。何以故。思择在先后得灭故。答此灭不以思择为先。何以故。未生法不生。在思择后。无此义故。所以者何。未思择时未生不生法本来已有。是法应生。思择正起后不得生。由思择力。此惑昔来未有生障。今断其生思择力。外曰。若定以不生为涅槃者。云何通释国譬经。经云。修数习多行信等五根能灭。过去现在未来苦灭者。名涅槃不生。唯属未来非现在过去。答有如此经义不如文。何以故。能缘三世苦惑灭故说苦灭。如余经说。汝等应舍是色爱欲。由爱欲灭。汝等色阴则灭离。乃至识阴亦尔。以此义故灭三世苦。其义应尔。外曰。若说苦灭。其义可然。又国譬经云。修习五根能灭过去现在未来世惑。云何不违此经。答如前解释。又有别解。过去惑者宿世所摄。现世惑者今生所摄。此二世惑。于相续中已成种子。能生未来惑芽。由此种子灭故。故说三世惑灭。如果报尽说业因尽。是未来苦及惑。由种子无故永不更生。是故经中说。三世惑灭。若不如此过去现在有何所灭。何以故。于已灭法及向灭法功用何施。外曰。上胜经说。一切有为无为法中。是离欲法因是不有。云何不有胜余不有。答我不说无为定是不有。如我前说。如是故有。如世人言。声有先无声有后无。不由此有言使无物成有当知无为其义亦尔。虽同是无而有。无可赞胜于余。无如一切灾横毕竟不生。此无为胜最可赞叹。为受化者起愿求心。故佛赞叹。外曰。若无为唯是无法。是灭则成圣谛。何以故。无所有故。答若尔。谛是何义。外曰。无颠倒是谛义。答是二法圣人观皆无颠倒苦。如相苦相无如无相。以是义故何乖圣谛。外曰。云何无物为第三谛。答立为圣谛。已如前说。依第二后次说故为第三。外曰。若无为唯是无法智缘。虚空及与涅槃则无境界。答我不说一切智以有法为境。若缘有为非去来世。则有物为境。若缘余法则无法为境。外曰。若汝许无为有物何所有。答若我许无为有物何所有。外曰。若汝许者我义被守。答诸天应守。若许可守汝许不实。何以故。是无为法不如色受其性可证。不如眼等其事可见。是物是灭。云何可别是无为与有为事不相关。何以故。互非因果故。但违反渴爱是其道理。如说是惑本无名曰无为。外曰。若立无为是有。由此惑至得断故。可说此灭是此惑灭。若说无为是无法者。此无为何因能决至得。经言。是比丘已至得现法涅槃。若涅槃是无何可至得。答由对治起得相续。与惑后生毕竟相违。故说至得现法涅槃。又诸阿含说。唯以无法是名涅槃。经言。是苦灭无余舍穷尽。及离欲苦不来续不生。是静是妙。何者舍。一切取并渴爱尽及般涅槃。外曰。何故不许于中余物不生。说此不生名为涅槃。答我见此执无有胜能。汝谓于中余物不生者。为是有故余物不生。为由得故余物不生。若是有故余物不生。涅槃恒有三有。应永不生。若由得故余物不生。诸阿罗汉得证此时。阴即应灭。若如汝执有此过失。故知但无所有名为涅槃。如偈说。譬是正道理。偈言。譬如灯光灭。心解脱亦尔。如灯光灭非是有物。佛心解脱。亦复如是

分别灭谛品竟

四谛论卷第三四谛论卷第四

        婆薮跋摩造

        陈天竺三藏真谛译

    分别道谛品第六

经说道谛。云何此言。何所因起。若道能灭渴爱。则不应说行至苦尽。若不尔者。是言相违。若俱灭集苦。云何经中不具足说。若道能尽苦。修道办人应无品苦。若不尔者。则不应言行至苦尽。若有为法于无为中无有行至。云何说言行至苦尽正行义。言正行者八圣道是。决言何用圣名何义。云何但说道名为圣。不说余助道若道异分应说其相。若言道唯是分。则具分与分无有差别。道名何义。云何此经说于具分。余经不具。若道是有为。云何佛说。本昔已有。若是无为。云何说言有为。若道是一。一人修时余人应得。譬如衣等若不尔者。则不应说由此一道。若诸圣人同得一道。云何智慧不同。若智慧不同。云何解脱平等。若道非心。无情等物亦应有道。若心非心。法修则不具。若是心法。诸相违法云何一心并有。若道至除惑。则相违法一心并有。若不至者于他相续云何不除。若分俱起则有多作意。若次第起则但有一分。云何止立八分不增不减。云何不取欲等余法。云何一法作三种说。中道能灭福恶行至尽苦。云何说正见为初。云何说先行正见有何义。见者既无孰为能见正见。与十善正见两异云何。若由正见一时见谛应有多境。若不尔者非念念灭。若正见已了诸谛。余分何用。正觉何义。云何三法成一。若依二定证得流尽。正觉不具道分有阙。此义应救。正言何义。若有语言道修无定。何以故。佛说定以声为刺。若无不成道分。正业何义。一切分皆是正业。云何说一名为正业。若离名正业。离则非作。云何成业。离挝打等。云何不说名为道分。正业正命与十善正业正命两异云何。正命何义。正命若身口业摄。云何别立。何者正精进。何相何用何缘何义。若但灭恶是善则无二精进。若非善者灭谛则非善。若一心修正勤即具足者。则无四正勤。若次第修者。则助道修不具何者正念。何相何用何缘何义。诸有为法刹那不住云何成念。何以故。他见他忆无此义故。若一切诸法皆是念处。念根即是念处则义不相应若念。犹自不能守一法者。云何经说有念一守。云何有时能忆有时不忆。何者三摩提。何相何用何缘何义。正定若是定。须陀洹人应无欲嗔。若不尔者则违道理

汝问。经说道谛。云何此言何所因起者。答此问不为开智人说。何以故。由闻其名已了义故。从大悲所起辩涅槃道显隐覆义。欲广说言灯。为分别智弟子故佛自问。何以故。由先问后解多有利益。广辩缘起已如前说。复次受化弟子问诸外道闻种种道。未能决了是道邪正。为除疑倒无明等心故。佛自问自答。何者为道。是八圣道。如疑路人导之善道。汝问。若道能灭渴爱。则不应说行至苦尽。若不尔者是言相违者。答圣人从初发心是修行用欲除灭苦。为此起道故。说行至苦尽。是苦尽由因灭得成。是故除因。譬如师子。复次诸佛观一切众生堕于苦难。发心修道。为除他苦。是修行用如国譬经说。又余经说。苦尽是出家修梵行用。如七车譬经。又如来出世为三事故。令他苦尽。是最第一故。言行至苦尽。复次一切有为无常故苦。离有为法故说苦尽。如筏喻经说。法尚应舍何况非法。复次由八圣道能除取阴。是故通说二灭言不相违。汝问。若俱灭集苦。云何经中不具足说者。答是渴爱灭由苦尽得显。复次因尽非是正用。以苦尽为正。复次圣道能灭有为及与取阴。故说苦尽通渴爱灭。汝问。若道能尽苦修道办人应无品苦。若不尔者。则不应言行至苦尽者。答依因缘尽故说苦尽。如说火尽名为灰尽。亦如根灭说为树灭。复次圣道能灭邪分别苦。而不除宿业报苦及界地及苦。譬如气嘘旃陀罗及优波斯那等。复次圣道于有余涅槃能灭心苦。于无余涅槃能灭身苦。复次圣道能灭后有阴苦。但宿行所作随逐未灭。如轮及箭。汝问。若有为法于无为中无有行至。云何说言行至苦尽者。答涅槃无行道亦无行。虽俱不由归向涅槃令得涅槃故。说行至苦尽。譬如国路。复次是方便言。如说诸流行没水渧行尽。流及水渧于尽中无行。而世说有行。行至苦尽亦复如是。汝问。正行何义。答由此了知实义故说正行。又以进趣为行。如说行一切处道。又能往安隐处故。说为正行。复次正是不背义。行是归向义。由此不背归向涅槃故名正行。汝问。正行者是八圣道。是决言何用者。答为反余道。为成立一切处行道。为显不往余处。复次能穷一切道苦。能遮一切烦恼业报烧热。能除自他恶骂重罚恶道死等怖畏。能除积骨如毗富罗山。能干乳血泪。以此功用故说决言。汝问。圣名何义者。答由体无流一味解脱众生。依此相续得名圣人。譬如善法。如经中说。是圣正见。复次圣人所行故名为圣。譬如王路。复次圣人所说。故名为圣。譬如师路。复次圣众所事。故名为圣。譬如牛路。复次令至极圣。故名为圣。譬如国路。如经说。圣正解脱。汝问。云何但道名为圣。不说余助道者。答同一相故。皆名为圣。譬如火性。复次同一解脱味故。譬如海水同一碱味。复次八道最为上首。能摄余助道。如象迹譬经说。汝问。若道异分应说其相。若言道唯是分。则具分与分无有差别者。答是具分与分差别之相。亦可见可说。譬如五分三昧。亦如五分比丘住五分处。道亦如是。与分有异。是分平等说名为道。何以故。是八种分若至平等位能除烦恼。若沈若起则不除惑。犹如调弦。复次是分圆满说名为道。能办事故。譬之如车。虽然若真实义分中说具分。譬如五分音乐及五分定。道亦如是。唯分为道今论所说。唯分是道六义证成。一说道。经言五根是道行至涅槃。此五根即是道分。故知唯分为道。二为经言。三身摄道。三身唯分。三由灭。经言。正见行于灭离道无灭。四由除。经言。若修习正见。能除欲等。若离于道则不能除。五由出离。经言。正见等诸分能出离此。若非道不能出离。六由清净道。经言。般若是道。为得清净。般若即正见。故知分是道。汝问。道名何义。答道以求觅为义。何以故。由此能得真实义故。亦以行为义故。亦以行为义者。如世间言。此道行向舍卫国等。道亦如是。归向涅槃。复次真实义门方便行生理。如此等皆是道义。汝问。云何此经说于具分。余经不具者。答法藏论说。假名有二种。一自在假名。二依他假名。说自体诸分名。是自在假名。如正见等道分。依他假者。如念等门及余助道分。何以故。此道品修非是散修。复次为胜逼故。念处等中随一法胜逼故。念处等中随一法胜余同一名。譬如碱酸等味。有诸余味随胜得名。又如诸界随一胜故。余随得名。复次于欲界中说道具分。色无色界或五或四。为灭自体。四对治故。余或增减。随界地故。以此义故有具不具。汝问。若道是有为。云何佛说是古昔道。若是无为。云何复说是有为法者。答由此古言道是有为。何以故。有为之法有新有故。譬如谷等。若是无为不应此言。譬如虚空及以涅槃。如说身是昔业而非无为。如说圣种及法诸师。是故由此古言道非无为。今论所辩道是有为。何以知之。由广分别故。如谛相应经及答达磨尘那。问由有为相故。如经言。依正思惟若道未生得生。已生得增长。有生长故知是有为。由舍除故。又如经言。法尚应舍何况非法。灭是无为则不可舍。缘内起故。如经言。是道依内起此归依难得。若是无为不依内起。由业名故。如经言。是道非黑白业能灭诸业。若是业者非无为法。由有食故。如经言。七菩提分以食为因。若无为者不须食因。以此义故道是有为。汝问。若道是一一人修时余人应得。譬如衣等。若不尔者则不应说由此一道者。答多道非一。何以故。果不同故。由道异故。故果有异。如路异故行异。复次体异故道异。谓见道修道等。亦如四苦乐迟速。复次根异故道异。谓九学九无学辟支佛佛。由根差别。是故有异。依种性故说由一道。如世说一谷。如经言。三世诸佛若观若说是此四谛。而苦等三谛体实不常。由一道言亦复如是。汝问。若诸圣人同得一道。云何智慧不同。若智慧不同。云何解脱平等者。答观一切一切种境界得成正觉。是故佛道不同二乘。如经言。若人当知一切一切种境界。当知是人名为世尊。通达平等道故。唯灭本惑三乘人等。如经言。解脱五阴与解脱无异。如多种火各烧然薪灰尽无异。由火不同热触光明威德有异。如是智慧差别。所灭惑除解脱是同故。佛定智威德及恩。由道差别难可思量。如大轮经说。汝问。若道非心法无情等物亦应有道。若心非心法修则不具。若是心法诸相违法。云何一心并有者。答心是生死分是世间法。道是出世法。两不相应。如法非法故。说道非心法。依境名心。求能名道。两若一体则自性自知。为免此失故。说道非心法。譬如寿命及无想无心等定。虽非心法而壁等中无道。亦如是。道虽有心非心处位。达皆有故无不具修。复次修有三种。谓守习研故无不具然。道亦可说是心法。何以故。与正思惟同生灭故。譬如一心。如经言。以心作增上故得一心。是名心定。即是道分。同一出离。同成一事。故共一心而不相违。汝问。若道至除惑。则相违法一心并有。若不至者于他相续云何不除者。答道不至惑而能除惑。如道不至破戒能除自破戒不除他破戒。除惑亦尔。于自他相续虽俱不至。但除自惑不能除他惑。分别部说。非至非不至此时除惑。以不生为灭故。譬如治病。苦受已至医不能治。何以故。不可转苦为乐故。苦受未至医亦不治。何以故。无所有故。若尔为何所治。但作违缘。令未生苦永不得起。道能除惑亦复如是。汝问。若分俱起则有多作意。若次第起则但有一分者。答由成一事故得俱起。非缘别境故。无多意相杂俱起。由功能故差别可见。譬如欲等。汝问。云何止立八分不增不减者。答此问不穷。是故置答。复次对治八邪分故说八分

复次为摄三身。复次为对治三刺三结三火三毒故说八分。复次藏论中说。能成八功德心故说八分。由得正见故心清净。由得正觉故心鲜洁。由得正言故心平但。由得正业故心无悔。由得正命故心软滑。由得正精进故心随教。由得正念故心安住。由得正定故心不动。汝问。云何不取欲等余法者。答但取胜法。或取强用。或取能任重担。或俱摄尽正言正业正命。是须陀洹分信为三摄故。须陀洹具四智信。欲即是信

复次此信亦正见摄。须陀洹人得智信故。喜猗舍正定所摄。是故八分摄诸分尽。汝问。云何一法作三种说。或说中道能灭福恶行至尽苦者。答由三胜事故。譬如日能破闇名光。能分别昼夜名日。能分别刹那等故名时。本圣道亦尔。能离二边故名中道。能除黑白二业名灭福恶。拔除身心苦故。故说行至苦尽。或除三世道故说行至苦尽。汝问。云何说正见为初者。答为上首故譬于王。如经言。一切有为法中般若最胜

复次能作胜功德故。若智慧胜诸德皆胜。如舍利弗由正见故不观他面。如首罗长者由正见故其心难动。如阿输柯王由此正见他不能引。如质多罗长者能拔除灾横本故。如经言。由明起故无明灭尽。是故正见为初。汝问。云何说先行者。答由得正见余分。得出世得无流得不共。或说由正见力余分得解脱道名。如经言。比丘是正见人。身口意业为得可爱胜美果故。如经广说。故以正见为先行。汝问。正见有何义者。答谓不倒证照为见。自所依止真实种类无倒证照

复次真如名正观名为见。如实观圣谛故名正见

复次正者可赞叹义。见者光明义。可赞光明故名正见。如经言。诸光明中此光最胜所谓正见

复次胜德境智行。是名正见。何以故。是正定位说名正见。如种子譬经说。复次理足论说。由境正故智正。不由智正故境正。有为有流相相应故一切唯苦。决定知此是名正见。如佛为大迦旃延说

又藏论说。对治无智疑智倒智。能度苦等。真实此智名为正见。汝问。见者既无孰为能见者。答众缘聚集共成此见。无别一物为其见者譬如花果。又如偈说

  有见无能见　　何法为见者
  从缘和合生　　见色言是虚
  是法集时见　　合散无能见
  但因缘所作　　如戾人无者

法从缘生。不可说属一。如佛为破求那说。我不说识为能识。何以故。此名具分假名所作故。汝问。正见与十善正见两异云何者。答俗智在十善。真智在八正。能感后生。以苦为果。观业为境。如此正见在十善法。能灭三有。涅槃为果。缘谛为境。如此正见在八圣道。汝问。若由正见一时见谛应有多境。若不尔者非念念灭者。答一时能成四事。故说一时。不为境异故。理足论说。修观行人以圣智慧。通达毛孔能断诸惑

又余经说若通观三受。诸事已办。无更所作。由通相法谛无我相。是故一时通观四谛。如次第观中缘无常苦无我一时通苦谛。汝问。若正见已了诸谛余分何用者。答一切诸分能灭自对治。各各有用如吐下方

复次一切诸分。于自事中各为上首共成一事。譬如车分及车车分。各有自事共成运载。道分及道亦复如是。汝问。正觉何义者。答未曾有计今日如生。是名正觉

复次是平等法由想行缘起故

复次体相境界果共相扶合。故名正觉

复次如见随择不舍名为正觉。如牛齝食。汝问。云何三法成一者。答同一相故如余道分

复次善听计平等故。譬如定分

复次缘涅槃为境。如无相定故三成一。汝问。若依二定证得流尽。正觉不具道分有阙。此义应救者。答若依二定修八正道。但无初定觉观分。非无道分中觉。譬如初定及三摩提无有觉观

复次由事成故说有正觉。不由体在故。如有学五根

复次能拔除对治故说有正觉。譬如正言。汝问。正言何义者。答永受誓不破名为正言。如瞿师罗传

复次是言清净。由除愿取垢灭故

复次法然所得永善行。是名正言。正言戒有二种

一不令知。如经言。是人离妄语等。二令知。如经言。是人时语实语等。汝问。若有语言道修无定。何以故。如佛说定以声为刺。若无不成道分者。答道分故非刺。譬如正觉喜觉分等

复次声刺不定。如见女人。经言。数见女人为修梵行刺。然非阿罗汉刺。已除刺故

又经言。大象说在定行立等亦静。若观行人正思说法。心则有定。不由有言故无定。经部师说。但离四言即是正言。如世间说。已离如正作。如说。此马快行此人善续。汝问。正业何义者。答经说。离身恶业名为正业

又经说。是身业不析不流不颁。自在无取能生寂静。是名正业

复次由观过失远离杀生。不作不行遮止不乐。是名正业。汝问。一切分皆是正业。云何说一名为正业者

答若离此名别名不显。如法界法入等。非眼识等所缘故。不令他知。说名正业。一切诸业所依止故。譬如业基。汝问。若说离作名为正业。离则非作云何成业者。答不作故起恶业作守护善。应知是业。如经言。我说作我说不作

复次能除黑白二业故说不作。能作对治业故说名作

复次正业亦名正业除。由此名故作不作义。此名得成。譬如由眼说见由眼亦说不见。若不作云何知有此业。答有多因缘此业可知。由经言。色有三种。一有见有碍。二无见有碍。三无见无碍。又说有无流色。又说由七福德利故。又说由教他亦有十业道。又说比丘有法非十一入摄。谓无见无碍不说无色

复次若无此业。八分圣道则不具足。何以故。正入观时不行三业故。难曰。是义不然。何以故。在方便中已修三业故。如经言。是人如是见如是知是正见。得修圆满及正觉精进正念正定。先时正言正业正命先已清净。答依世间离欲道戒故说此言

复次波罗提木叉戒亦不应有。何以故。当受时有。后在异心不应说名比丘比丘尼

又经说。此业名为堤塘。能遮破戒故。若无不能止恶。经部师说。此证殊多。甚为希有义不如此。何以故。汝言。由说三色故。知有无作者。是义不然。诸观行师目连阿尼楼驮等说。有定境色由定力得。此色非眼根境界故说无见。不障处所故名无碍。若汝言。若尔云何名色者。此与无作等故。还难汝义。汝言。由说无流色知有无作者。是义不然。此色亦是定力生。由定无流故色亦无流

又诸师解。阿罗汉色亦是无流。非流依止故。难曰。此义不然。如经言。何者有流法。谓一切眼一切色等。此色非流对治故说有流。若尔此色或有流或无流。答若尔何有。难曰。相相杂故。答如有流相无流相。不知有何相杂。复次若色入一向有流。云何经中偏简择说不通途说。经曰。有流色者。谓有取心坚覆藏所依故。名有流色。汝言。由七福德利故知有无作者。此义不然。经部师说。如汝受用施主施物。由受者功德被利益故。施主虽在异心。由前施作意熏修相续次第转胜。由此胜故能生未来随多少报。依此相续说施主功德生长。若汝言。由他相续胜负及随用故。若在异心是相续转胜。云何得成者。是义不然。何以故。与无作等故汝执无作。由他相续胜负。及随用因他相续。云何得成。问不增长福德种类中无教云何恒生。答由数习缘戒定作意故。乃至眼中增长随逐。问若尔郁伽长者经其义云何。经言。若比丘持戒行善。受用施主衣食等。已修无量心定。身证此定入林中住。由此受用施主福德善乐增流无量。应当信知。此中有何作意。故知相续转胜是正道理。汝言。若无作无教如他作业业道。云何得成者。经部师亦作此说。由此教故。他或离或受杀害等苦故。能教者于微细相续善恶增胜。由此转胜能生未来随多少报。若人自作随事成时相续转胜。名为业道。是义应知。果假因名故。是身口事果。假身口名义亦如是。如意身口无教。有大德说。依众生取阴。由三时作意。得杀生罪。谓当为我杀正杀杀已。此解亦不然。虽有三意业道未必得成。何以故。未断母等命根。起三意人无逆罪故。若人自害他命。由此三意得罪可然。难曰。等不可见。何故憎嫉诽谤无教而信受相续转胜。答无此憎嫉。但由心运身业道事成。若谓行者有别法异心。我所不喜。由心加行是事得成。此事成故相续转胜。是义可喜。何以故。由心相续果得成故。汝言。法入佛不说无色知有无教者。此义已答。如定境界色。汝言。若无此业八道不成故知有无教者。此义应辩。朋友汝应为说。入谛观人正言正业正命。云何得有。此人在观为有言说作业。求觅四事故有此三。为当不尔。答不然。何者正在观时。得此三种无教。由此得故。若出观后不在邪言等中。但住正言等。是故因中假得果名。故说无教名正言等。论主答是中何不执如此。若正在观中离于无教。得在如是意。得如是依。由得此故。后出观时不在邪言等中。但住正言等。是故因中假得果名。故说相续转胜名正言等。以此义故。道有八分

又上座部说。但不作恶名为三分。何以故。由圣道力法决定不作。依止无流道故名无流。未必一切处被数法。皆真实有如八世法。谓得不得名无名誉毁乐苦。是中不得更无别法

又余师说。波罗提木叉戒。是三道分。依先方法作信受意。由此作意能防身口遮所作恶。说名波罗提木叉戒。若汝言。人在异心则无守护者。是义不然。由数习故。犯戒缘来作意即至。说此作意名为堤塘。何以故。由忆先誓差不作恶。为有此用故须受戒

复次若如汝立。有别无教能遮破戒者。则不应有失念犯戒。不须广辩。若尔不尔。决定应知。八正道中戒有三分。为道基故。譬之如地。以先行故。譬如王。能度生死蕀刺稠林故譬足。可爱香故如天檀叶。清净传传能到涅槃。如七车譬。又余师说。引经为证。是道果故。恭敬利养因缘故。非守护对治故。翻令知所得故。知有此戒。又余师说。云何无教是色而非身受。答无教属身口业。为色所摄。身受者与心相应。为名所摄

复次无教是身业故属身。受是心法故属心

复次无教亦戒亦色色阴所摄。身受心法受阴所摄。今论所辩此法心业所依故。由身口成就假得其名。此法与受何异。答受阴所摄此法通诸阴摄。何以故。依相续故。汝问。离挝打等云何不说为道分者。答有学圣人未寂静故。譬如制罪。以不遍故如非梵行。以不定故。如布疏陀分。为资粮故譬如施等。今论所辩分明八戒。此中说名三圣道分。汝问。正业正命与十善正业正命有异云何者。答可坏除不可坏除。从出世正见起。无流甘露为果。从世正见起有流取阴为果。能生福德是名业道。能离福德名为道分。汝问。正命何义者。答正命有二种。一白衣离五种贩卖。二出家人出离五种邪命。复次依理求觅受用衣食等四缘。复次知足无失圣种所摄。及守护身口。复次先因智慧远离身心邪具。是名正命。汝问。正命若身口业摄。云何别立者。答通在二摄。由义异故。别立可知。譬如诸阴通是行摄。由义异故别立四阴。复次体有二故。譬如身观。经言。于身观身住。复次正命异前二分。譬如惑数。汝问。何为精进者。答行于处处随地差别。为得种种善法。策起身心不舍荷负。复次为灭恶法证于善法。常行勇猛。是名精进。复次修行是处不倒身心勤力。是名精进。汝问。何相何用何缘何义者。答策起身心为相。不退堕为用。起精进类为缘。藏论中说。精进者勇猛为相。不沈为用。四正勤为缘。胜利行为义。若懈怠人行无胜利行

复次难胜力故。若人有精进。于烦恼战斗有难胜力。若懒惰人则无此事。复次此行能散破除舍。是精进义。汝问。若灭恶是善则无二精进。若非善者灭谛则非善。答灭恶者唯是无物。善则不尔。故精进有二。复次灭恶名真实善。所余即三善。何以故。有四善故。离破戒臭名为灭恶。戒香发起名为生善。譬如热静异于冷生。汝问。若一心修正勤即具足者。则无四正勤。若次第修者则助道修不具。答一心得修四正勤。譬如一心通观四谛。何以故。由此修故。未生诸恶不得生。已生诸恶不得住。善法未生得生。已生得坚住。是故精进由体故一。由用故四。又分别部说。若持戒观行人。为除定对治修四正勤。已生之恶能障定。由精进故灭。未生破戒后不得生。未生定得生。已有净戒得坚固住。以是义故。精进唯一事用有四。复次有说。四正勤次第起。譬如得定。何以故。有正勤但能破上心惑。有余正勤能拔随眠惑。又有正勤。能生未生根。又有正勤。能令已生坚固。故道品修非是散修。有正勤故。汝问。何者正念者。答不忘先所知境。是名正念。犹熟取相。如经言。心悎心系等是名为念。汝问。何相何用何缘何义者。答境界后忆为相。心境不离为用。六念为缘。自忆令忆名为念义。譬如菩提自觉令觉。复次藏论说。心澄净为相不忘失。若失还现。复次能守境界是智依止。故名为念。复次念有四种。一随执名句味。二能随所执义。三能随所思义。四能随通达所思义。今论所辩正明第四。汝问。诸有为法刹那不住念云何成。何以故。他见他忆无此义故者。答若知者异念则不成。如张见王忆。若智相续异念亦不成。如见牛不忆马等。若智一念亦不成。无后智故。及此三义则名为念。又释若不相关则他见他不得忆。如此人见彼人不忆。若因缘相关则他见他得忆。譬如童子少壮老弱智念得随逐生。复次譬如种子。不相关故。麦种不生谷芽。若因果相关而有异者。是谷类等种子芽茎支节叶位得随逐生。若一念亦不成。因果不立故。如种子恒一芽则不生。由相关不异不一故念得成。汝问。若一切诸法皆是念处。念根即是念处则义不相应。答今论所辩。念根即四念处。但不以境界分别根故。譬如智根智量

复次念处有三种。一自性念处。但生忆念譬如王。二杂念处。若法能助于念。亦名为念。如王臣佐亦得王名。三境界念处。由念缘此起。亦得名念。如王住处。是故念根即是念处。义不相违。汝问。若念独自不能守一法者。云何经说。有念一守者。答念是守护中第一增上缘。故说一守。譬如王胜。如经言。一切诸法念为增上缘。为守护故。复次一念能护一切行。故说一守。如经言。是念行一切处。复次一切念能守六根。如当门人。复次是念能录一心。如人手捻阴阳筒口。复次能守一相续故名一守。如护一子。复次六根被系。于一念柱不散住自境。如六众生同系一柱。是故经言。有念一守。汝问。云何有时能忆有时不忆者。答有三因缘故能生念。一数习。由数习身口意如梦中见。二相。由顺逆相忆。似不似境。三澄清。由心澄净念即得起。如净器水得见面像。若反此三则不得忆。又临死及初生重苦所逼。忘失本念故不忆宿命。复次有六因缘能生于念。如偈言

  顺逆及数习　　一处共会聚
  定力及因力　　此六为念因

顺者。如见他似儿便忆自子。逆者。由触热故忆昔时冷。数习者。如所串行事自然忆。一处会聚者。如人见庵罗树忆其酸味。定力者。如得三明人忆宿住事。因力者。犹如圣人及大行善人忆过去生。汝问。何者三摩提。答经说心定住静名三摩提。又阿毗达磨藏说。能摄法不散。名三摩提。复次是心相续。烦恼恶风所不能动。如密室灯。复次三摩提有二种。谓世间出世间。世间者。能生世间果报。与觉分相离。能伏上心惑。出世间者。能令度离世间与觉分相应。能拔随眠惑。今论所辩。是出世定。汝问。何相何用何缘何义者。答心定住为相。伏对治为用。依心学为缘。复次藏论说。一心为相。不散为用。四定为缘。安心令直为义。如箭师调簳。世间说为三摩提箭。此言调直箭。如是调直心相续名三摩提。如偈言

  心跳掷散动　　难守亦难遮
  智人使调直　　如箭师调簳

复次能安心平等。譬如驭车取平坦路避崄曲道。观行人亦如是。能安置心于平等处门境相行。能遮不平等恶故。名三摩提。复次五盖病销。如人不病名三摩提。汝问。正定若是定。须陀洹人应无欲嗔。若不尔则违道理者。答所对治定在。由得果故验其得定。譬如五根。复次专心向定故。譬如蜂虽系秽处心慕莲花。故知恒在花处。圣人亦尔。虽处欲尘心乐寂静。故知恒在定。复次如须陀洹人。无明虽在而明不失。复次如佛婆伽婆。虽有觉观不出散心。恒在定故。须陀洹人定亦尔。故不违理。问圣道八分次第云何。答由能依理观圣谛故。先立正见。于所观法执视不舍。次立正觉。从此次立正言正业正命。于所观法为离为得。次立精进。于所离得永不忘失。次立正念。由念不失。于所见境心不散动。次立正定

复次若八法俱起则无次第。而次第说不无道理。若人欲起涅槃。应先求正见。如人欲行必须有眼。如所见理执视简择。次立正觉。如所择说次立正言。何以故。若有语言。依觉观故。如言而行次立正业。此二清净。次立正命。是人住戒。若起勤策次立精进。有精进故则念不失。次立正念。由有念故心一不散。次立正定

复次阿毗达磨藏说。此行以智慧为根本。何以故。四谛境深非智不了故。先立正见心触此境。次立正觉。由此二分。于四谛中对自令知。次立正言由前二分如言发行。次立正业。由前两分。口说身行受用四谛。次立正命。身心勤策为进谛理。次立精进。由此精进。于四谛境心用澄净。次立正念。由此正念。于四谛境心及诸法永不散动。次立正定。复次由正见故。是观行人不堕增上慢中。能如实分别自所得故。由正觉发起正言。是自所得能传至他。由此正言能立能破能决。令他信有智慧。由有正业宁舍寿命不犯非法。故令他信有圣所爱戒。依法如量求用四缘故。由正命令他信有圣种知足。复次由正见正觉。及因正言能师子吼。由正业正命能显所说义。由正精进未得令得。未灭令灭。由有正念沈起平时不忘三相。故定无障。由有正定灭除定障。能引六通诸德故后俱解脱

复次阿毗达磨藏说。由正见故说信根信力及欲。何以故。由有智慧信欲成故。由精进故。能摄正勤及精进根力觉分。由正定故摄心如意足。及定根定力喜猗舍定觉分等。以是义故。当知三十七品。是八道内摄。复次正见及正念。是毗婆舍那分。由此灭无明故。慧解脱为果。所余道分属奢摩他分。由此离欲故。心解脱为果。是故略说道有二分。一毗婆舍那。二奢摩他。复次藏论说。正言业命三为戒聚。由有此戒拔除嗔恶根本。正觉精进正定三为定聚。由此拔除贪欲恶根。正见正念二为慧聚。由此拔除无明恶根。以此义故。道有三分

复次道有四。一方便道者。由此无碍道生。无碍道前皆名方便。二无碍道者。正能除障碍对治故。惑不碍故。名为无碍。三解脱道者。解脱无碍道所碍之惑。初起名为解脱。四胜道者。从解脱道后所余诸道。皆名胜道。问此四云何名为道。答由此进至涅槃故名为道。若尔解脱及胜云何名道。答道种类故。转胜故。令前至后故。能至无余涅槃故。说名为道。复次道有四种。一苦道迟智。二苦道速智。三乐道迟智。四乐道速智乐道者。谓依止四定具分故。定慧平等故。无功用行故。以是义故。名为乐道。离此皆名苦道。谓依止未来定中间定三空定等。不具分故。定慧不等故。有功用行故。未来定者有慧少定。三空有定少慧。中间定者分不具故。定慧皆少。以是义故名为苦道。此之二道。若信根人得名为迟行。若智根人得名为速行。是八分圣道。约定约根故有四行。复次圣道或说三十七助觉。何法为觉。以尽智无生智名之为觉。由三种人成三品觉。谓声闻菩提。辟支菩提。无上菩提。能灭无明令无余故。是自事已作不复更作。如实觉故。是名为觉。助者。三十七法随从尽智无生智故名为助。由名故说三十七。不由于体。今论所辩体唯有十。谓信精进念定慧喜轻安舍戒觉。阿毗达磨师说。体有十一。即开戒为二。所谓身口。复有阿毗达磨师说。体有十三。谓足欲及心故。经一切所得法。皆是助觉。但此十既胜故偏举之。言三十七者。谓四念处。四正勤。四如意足。五根。五力。八圣道。七觉分。问此七科助觉安立何处。答凡有四位。一初发行位。二通达位。三见位。四修位。问次第云何。答是观行人已住于戒。已能了别生死过失涅槃功德。离四谛观无别方便。能了知此过失功德。为摄多境散心令住一处。为生对治伏四颠倒。令心如理入四谛观。是故在先观四念处。由四念观已别诸法可取可舍。为取善舍恶故。次修行正勤。因四念观正勤得成。由正勤观惑障已净。助法已立心随意住故。次立四如意足。由此定力。于不疑境心有增上。由此信故。于不懈怠心有增上。由此精进所得善心。有助无障。于不忘境心有增上。由此念故摄在一境。于无散中心有增上。由此定故。如实观境心有增上。由当体增上故。于不退位。心有增上。由不退故。于通达分心有增上故。次立五根。是五根增长至最上上品故。下惑不能破故。余世间法不能胜故。无流心次第缘故。不退圣位故。以是义故。次立五力。已见彼此得失。已得真路。已得决心。已得眼。已得足。由五力故得出世行。故次立八圣道。由八圣道破见谛惑已。得近尽智无生智故。转此道名七觉分。是故次第立三十七。四念处观是初发行位。即解脱分。四正勤名忍位。四如意足是名位。五根名相位。五力名第一法位。此四通名决了位。八圣道名见位。七觉分名修位。尽智无生智名究竟位。是果非因故。不立为道。复次此道或说名梵轮。梵轮者。佛世尊及弟子所转故。此圣道有六种义。譬之如轮。一速疾行。谓或一心。或十二心。或十五心。遍行三界四谛故名速疾。二舍此到彼。谓舍世间到出世间等。三上下行故。谓或在法忍。或在类忍等。四从此至彼。谓从师师相续解。至弟子相续解。五毂辐辋相似故。戒有三分为毂。正见正觉正精进正念为辐。正定为辋。六圣王轮。未伏能伏。已伏能守护。由无碍道能伏。解脱道能守。以是义故。名为梵轮。复次此八圣正见有五分。戒有六种。谓三业教无教。精进有九分。正念有八分。正定亦八分。此圣道若广说则有三十七分。若中说则有八分。若略说或三分。或二分。偈言

  若人求涅槃　　灭止及妙离
  应常行精进　　听思修四谛

四谛论卷第四


随相论

    No. 1641

随相论一卷

        德慧法师造

        陈天竺三藏真谛译

论中解十六谛

十六谛总问。为物有十六。为名有十六耶。答毗(防夷反)颇(判何反)沙(翻为广解)师解。为物有十六故。立十六名。实有其体故称物。经优波提舍(翻为离欲修善说)师解。名有十六。物唯有七苦谛有四。谓无常苦空无我。集灭道三谛各一。合为七。佛本说优波提舍经。以解诸义。佛灭后阿难迦旃延等。还诵出先时所闻。以解经中义。如诸弟子造论解经。故名为经优波提舍。毗婆沙复从优波提舍中出。略优波提舍。既是传出故。不言经毗婆沙。今先依前释属缘故。称无常有为法。无力不能自起。藉缘方起。如婴孩小儿不能自起。藉他扶持方复得起。所言缘者。即是贪爱及业。必须具此二法。五阴方得生。业能生果。虽复能生。若无贪爱爱着应生处者。果亦不起。由如地水等能生谷牙。若无人功以谷子安置地中。牙终不得生。未起贪爱及业时。果则是无起。贪爱及业因缘和合。果方得生。生则是有。业力若尽果则谢灭。还复成无。即是先后。先后无系属于缘故。言属缘故名无常。逼恼性故名苦。逼恼有两种。一违逆逼恼。二随顺逼恼。若于佛弟子。是违逆逼恼。佛弟子于生死中恒生怖畏。经中譬云。譬如烧利剑火光耀眼。人执之在侧欲以相害。于念念中恒生大怖畏。佛弟子怖畏生死亦如此。此下是违逆义。而生老病死等。恒相逼恼故苦。若于凡夫是随顺逼恼。凡夫爱着生死。即是随顺义。如兄弟二人。兄甚爱弟弟恒恼兄。兄虽受恼犹自爱之。凡夫爱着生死。虽复受苦犹爱着之。故以逼恼性为苦。对治我所见故名空。凡夫执一切法言是我所。今明一切悉非我所。为对治此见故名为空对治我见故名无。我凡夫。执五阴等以为我。今明一切法悉无有我。为对治此见故说无我(此四是苦谛)。次释集谛四名。种子法道理故名因能生果是种子法。具四义。是其道理。四义者。一种子破则不能生。如取种子磨之令破。虽具诸缘不复能生牙。贪爱等烦恼。亦是生果之种子。若为道所破。虽具余缘不复能生果。二陈宿故。虽具诸缘亦不能生牙。以种子经时节久故。贪爱等生果。亦复如此。声闻六十大劫修行。独觉百大劫修行。佛三阿僧祇劫修行。三乘人在未发心之前。于一阐提位中起贪爱等烦恼。烦恼生业。业所感果。犹未受之。从修行已去多历时节。功德智慧既转深广。映蔽先因力用衰弱。虽具余缘不能生果。大有经说。九十八惑生一烦恼。一烦恼生九十八惑。如因贪具生九十八惑。皆能生贪。三失时故。虽具余缘则不生牙。如春种则生冬则不生。因失时亦不能生果。如鸯掘魔罗。因无明断二千命。死必应入地狱。而现身得成阿罗汉。先所作恶以时差故。虽具余缘不复得生果。四因缘不具。虽不破不陈宿不失时。亦不生牙。如地水人功等因缘不具故不能生牙。因生果亦尔。虽未被破未经久时及失时。而因缘不具则不能生果。若众生作业能牵生果。须具三事。一亲近善知识。二有信向心。三作功力恶业。须三事对此求之。若无三事。因缘不具则不能得果故。丑陋经云。若众生愿生人中而作业。因缘不具故。乃于畜生等中受果。若作恶业应于畜生等中受生。因缘不具。乃于人中受果。如阿罗汉。虽具有诸业。以断烦恼尽业。无烦恼为伴故。则不能牵生。又如中灭阿那含。用业已尽。而贪爱未尽。不得受色界生。生在中阴中。又如得初果。竟起修道所灭烦恼。烦恼生业。虽具业烦恼。由断见道所破烦恼故。不复得用新业受生。世间种子法。必须具四种道理方得生牙。贪爱及业为种子法亦尔。必须具四种道理方能生果。生果故名因。问业及烦恼。何者正为种子。答烦恼为正。烦恼生业。业不能生烦恼。烦恼是本故。又有业无烦恼。必不能牵生。有烦恼无业。由得中阴生

二显现故名集起。显现有两义。一贪爱与业相应。令果得生。未生时果。未现生时则显现。二贪爱能显于境界。境界实是鄙恶。而贪爱转心。谓境界为好。即显现境界令好。如一女人。三识往观之。凡夫见之谓为可爱之境。虎狼观之谓是可食之物。圣人观之谓为骨藏。谓为骨藏。此是称境而知。谓为可爱可食。并由贪爱显现此境故尔。由贪爱显现。应生处境。于中起染着故。业得生果。若无此二显现。果则不得生。明此两种显现。为释集起义。外道谓一切法唯有一因生。言自在天。一因生一切物。今为破此见。明众缘集聚方能生果。虽复众缘集聚。若不能令果起。亦非因义。集聚而令果起方得是因。二种显现亦明集聚义。亦明令果起义。故以显现释集起。如窑师埏埴绳水等。众缘聚集共生一瓶。能拔出果令成就故名缘。因直感果令起。缘则能令果生。使一期报得具足成就。次释灭谛四名。五阴尽不生故名灭。此据果报为语。现在五阴尽。未来五阴不生故名为灭。今取灭名目无为体耳。灭谛自以无为为体。不取五阴灭。不生为体。五阴灭不生有三世。灭谛体是无为。非三世法。五阴灭不生。有三世者。如舍利弗目揵连等五阴。是过去灭不生。凡夫五阴则于未来方灭不生。若现在圣人五阴。则是现在灭不生。无为法中无五阴。五阴不于此中生故。用尽不生义以目无为。又五阴若尽灭不生时。方证得此无为故。以尽不生义。目无为故。名无为为灭。能灭三火故名寂静。三火有两种。一欲嗔痴为三火。此三有三义故名火。一能烧众生一切善根。二此三烦恼能使心热。即有烧心义。三能然三界故名火。此三烦恼遍三界中。从六尘六根六识生。此烦恼根尘识皆是有流。由此三烦恼故。不得安乐。三烦恼如火能然。根尘识如薪是所燃。问上界无嗔。今那得言有嗔耶。答凡夫生上界者。具有见谛烦恼。在上界非无之。但不得起故言无。今言有者就理为语。二以三苦为三火。此三苦能烧众生。令不得安乐。若欲界则具三苦。色界则具坏行二苦。无色界唯有行苦。三苦即是三灾。苦苦是火灾。坏苦是水灾。行苦是风灾。有此二种。三火则喧动。以灭此二种三火故名寂静。无三抂故名妙。三抂者。谓生老死为三苦。此三苦平等遍三界中故。偏说此三苦为三抂。三界皆有生故有生苦。若欲界则有头白面皱之老。六天及色界乃无此老相貌。亦有改异义。如采画始时则分明可爱。久则采色歇薄。上界色身亦有此义。即名此为老。无色界心亦有老。果报将尽之时。心用改异。昔时定心坚固。将终定心劣弱。恒欲退堕。故三界皆有老苦。三界皆有终尽故。皆有死苦。所以名此为抂者。凡夫之性恒求安乐。所以修世俗善望得乐报。而此三横灾。使其受苦故。名三苦为三抂。无为之中无此三抂。故名为妙。问上界生时自不苦。何故名为苦耶。答未必生苦。受故名苦。生是苦本故名为苦。无为不生所以无苦。生死有生所以有苦。故名生为苦。如地狱是处所之名。处实非苦。但处能生苦故。名地狱为苦。问生苦三苦中是何苦。耶答若是苦受生是苦。苦若乐受生是坏苦。舍受生是行苦。欲界生具有三苦。色界生具二苦。谓坏苦行苦。无色界唯是行苦。老苦亦具三苦。若转乐为苦。则是苦苦。若转苦为乐。转乐为乐。则是坏苦。转乐为舍。则是行苦。约三界类。此死苦亦具三苦。类前可解耳。问经中说有几苦耶。答说有无量苦。此间所说八苦。以外分别。复有诸苦。但止说七苦耳。旧八苦中不说病苦。说七苦竟。言等等余诸苦。所以不说病苦者。病苦唯在欲界人中。近不遍欲界天中。故不说之。天中所以无病苦者。病从内外缘生。外谓寒热不平等饮食不调适故。致病苦。内者或行多令四大弱。或坐多令四大弱。四大弱故成病。上界外无寒热不平等饮食不调适之缘。内四大既强。无有行坐过差之缘故。不得有病苦。曲解亦有病义。六天作欲事。或三日不食。乃至七日。不至七日则死。未死之前四大弱。亦得名病苦。问余四苦云何。答五阴若通三界。求不得爱别离怨憎会。此三苦上二界定无。以名自住果报。无有杂住一处故。无此三苦。欲界六天则具有之。下品诸天愿乐上品不得故生苦。即求不得苦。与阿修罗斗战。即怨憎会苦。斗战不如。为阿修罗所缚所破。即爱别离苦。解脱一切失故名永离。一切失者。是因缘果报。因是烦恼缘是业。所受五阴是果报。此三是过失法。究竟解脱此三。非暂时解脱。故名永离。问烦恼何故称因业为缘。答烦恼是种子。正能牵生故名因。若无烦恼虽复有业。则不能牵生。若无业有烦恼。犹得生中阴。若烦恼尽业虽得庄严果。终由烦恼生业故得果。次释道谛四名。于中行故名道。凡有两释。一云尽无生智是能行。戒定慧是所行。从苦法智讫道比智。十二心皆断烦恼。是尽智。第十三心。是无生智。戒有有流本是有流。由两智行之故。成无流定。亦如此智有三种。谓闻思修。修慧亦有有流无流。亦由两智行之。故成无流。尽智行之者。苦流智现前。具八分圣道。戒定本是有流。今为尽智行之。故成无流。尽智有二种。一是正见。二是正思惟。同观无常而有粗细。正见细见思惟粗。而此二互得相生。若以正见为尽智。亦得言使正见成无流。终是比尽智令智慧成无流。如此明义。则一时中为尽智所行故。令戒定慧成无流。以异性故得同时。乃至阿罗汉悉如此。若还以正见望正见。正思惟望正思惟者。则不得同时。必以前正见使后正见成无流。正思惟亦尔。一时中不得并有。一性两法故。若如此明义。则异时明智慧。为尽智所行乃至阿罗汉悉如此。为无生智所行。乃至阿罗汉悉如此。为无生智行故。戒定慧成无流者。见谛有后十心。后十心属果。若须陀洹人。作十二心观者。则是无生智。使同时戒定慧及异时慧成无流。问苦法见即是无生智。何不说之耶。答苦法见若形待苦法智。亦得名其作无生智。若望苦类智者。其复为苦类智。作本断上界烦恼。复属尽智。既不定。是无生智故。悉属尽智。唯第十三心定故。可说为无生智。第二解言。戒定慧为无流心所行成无流故名道。则以无流心为能行。戒定慧为所行。尽无生智是助心法故。前解异后释。言于中者。于戒定慧中与理相应故。名如者。若通论则与四相应理相应故名如。若别论与不断不常中道理相应故名如。如是得理之智。若以邪思惟不如破之。不能使其成不如故名如

正见所作故名正行。若声闻人闻正师说正教。从正声名生正闻。正闻生正修。作如此次第习学。名为所作。若是独觉及佛。则从正思生正修。无有从正声名生正闻义。以此两乘根利。自能思惟得悟。问独觉及佛。根本悉经闻法故。得生思惟修慧。何故无正闻生正思耶。答宿世非不经闻。今论即事。非是忆昔所闻乎。时师作此说。依此说依此而生思慧。直端然思惟自得悟理。声闻则必依师语思惟之。永过度故名出离。有两解。一解言。由邪思惟故生烦恼。烦恼生业业生果报。此等皆是不正思惟故。若生无流智慧。智慧生戒定等。皆悉是正。正与不正相反。正即过度不正。非暂时过度。及是永过度。又一解。烦恼是倒。智慧是不倒。倒与不倒相反。不倒永过度倒。前解则广。后解则略。故有异用。前家又一解十六名言。非永法性故名无常。若无为法本来是有。永无有生永无住灭。有为法暂生暂住暂灭。此法性尔故名无常。从无明生故。苦者不解世间事故。苦近不解世间事。已自是苦。况不解真实甚深理邪。弥是大苦无明根本。是苦由无明故。受生死报故。生死无处不苦。中间人所离故名空。六根是中间。佛自以聚落譬六根。今言中间如聚落之中间。我人不在此中间故。言人所离。以为我人所离故名为空。不自在故名无我者。自在有两义。一不依他故名自在。若不由他生住灭则是自在。二者随意所作故名自在。若欲令火冷火辄冷。欲令水不湿水即不湿者。此则是自在。一切有为法依他故。有生住灭。又不得如意。若有神通能转变者。终须依定等修学方有此用。既不免依故无自在。既无自在故无有我。来道理故名因。今次第举譬释之。以种子为譬。如有种子不藉余缘自有生树之力。树犹未生而种子既有。能生力能令牙等后时来。现在业分为四分。初分者。当作善恶业时。不藉余缘。便自有能感果力。果至命终犹在未来。业既有能感果力。能令果后时来。现在有能令来之道理故。言来道理名因。出道理故。名集起者。种子本能生树。树牙茎枝叶等。本在未来。今以种子内土中。藉地水等外缘方得出牙。牙才起现在种子即灭。业亦如此。本能感果。果在未来。现在报既尽。先受中阴生。中阴生才起业。初分即谢。业有能出中阴之道理。必须因缘聚集。中阴果方生故。言出道理。故名集起。行度故名生处者。牙先出现在。从牙生茎。从茎初讫至未生华。以来名为行度。行者渐渐增长。度牙位茎才生牙。便谢业亦如此。先受中阴牙。舍中阴牙。受正生从柯罗逻初。至第七分之终。名为行度。渐渐增长故名行过。中阴位故名度柯罗逻。才生业第二分便谢。柯罗逻等次第生故名生。此生从业生故名业。为处故。言行度故。名生处业。第三分自用强。若无业用。虽有余缘生果。终不得起

所依道理故名缘。茎先渐长犹未生华。从生华以去至结子。子又生未来树。皆名所依道理。华果等皆依此位种子。而得生华。才生种子。第三分便谢。业亦如此。从柯罗逻初。至第七分。未能作生死因及解脱。至六根具足第二刹那已去。能造生死解脱。因此位是业第四分。此第四分初以去。若苦乐若恶若善。皆依业第四分。业第四分。是依道理故名为缘。业第四分才生。业第三分便谢。业第四分。自用亦强。果既已生。藉余缘义则弱。正由业用故果得具足。若业第二分感中阴生。因缘俱弱。以贪爱为因。业为缘。二事俱弱。不可以种子全为譬。止少分为譬耳。当作业时具能感此四位。果逐时节有异。有此四种。约此位故。分业为四分。问一业那忽俱感此果耶。答就一刹那明一业。亦得义分为三分。前分后分弱。中分明强。弱感中阴。强感生果。若无流业则初强后弱。问业生果与种子若为异耶。答此义不同。若依萨婆多等部。明有为法皆刹那。刹那灭者。一种子。且据十刹那为语。若当分论相生者。第一刹那能生第二刹那。第二刹那能生第三恒邻。次明相生。第一生而即灭。不至第二。岂能生第三耶。若就向分因。约相续为语者。第一刹那同分因。即能生第二刹那。以去乃至华实同分因摄。此业果在未来。第一刹那灭。第二刹那。同分即摄。第三刹那以去果在未来。后去次第类此。若无第一刹那种子为本。则不得有第二第三刹那。次第相续故。初一刹那种子。以得说其能生。后诸果言同分因者。种子四大即四分。同能生一果故有此名。不如业有同随得摄其因果。若正量部。色不念念灭。有暂住义。种子未生牙时。只是一种子耳。若当分论生果。正生牙果。若约相续。亦有生茎叶等义。后去类皆如此。业则不尔。业虽自灭。有无失法在。摄其果令不失。今且据戒善为语。戒有根本。根本有前方便及正方便。前方便有三事。一大众和合许为受戒。二正乞戒。三时节。时节者。要期尽形寿息一切恶。正方便者。师为其说。一白三羯磨。至第三羯磨竟。即得护身口善。此善即是戒。以要期心等缘摄之。以此为根本。尽形寿不灭。从此后相续恒流。若中间作罪。戒则不复流。若忏悔竟则还复流。言流者。从根本流出一刹那戒善。所流出者。亦生即灭。不从此刹那戒生第二刹那戒。还从根本流出第二刹那戒。如此后生者。能从根本流出。若是萨婆多义。有同随得系之戒善。生虽谢同随得系。其住在过去。系果在未来。若正量部戒善。生此善业。与无失法俱生。其不说有业能业。体生即谢灭。无失法不灭摄业果令不失。无失法非念念灭法。是待时灭法。其有暂住义。待果生时其体方谢。若是定戒。皆有随根本相续流义。布施物则随物在善恒流。若无流善不能得果。无有无失法与善俱生。无有出在余心无流善恒流义。问业与无失法俱生。同是有为法。业体何故灭。无失法不灭耶。答善是心相应法。故生而即灭。无失法非心相应法。故不念念灭。萨婆多义同。随得亦念念灭。但非心相应法。种类自相续不断。问布施善恒流定云何。答身口是业体。以相貌为身业。以语言为口业。运手捉物。或取物或擎物与前人。此即是相貌。即以此相貌为身业。发言呼取某物施某人。此语言即是口业。发起身口业缘有三种。一三善根。二从三善根生正思惟。三从正思惟生作意。谓作施意。若总论用。此三缘发身口业。近论正是作意。发身口业。言布施者。以三缘发身口业故名布施善。菩萨默念而雨宝。意业亦是施业。田有三种。一福德田。如佛及菩萨等。二恩养田。如父母等。三贫穷田。即饥寒众生等。若施福德田。则无痴善根多。若施贫穷田则无痴嗔善根多。对贫穷众生。必起慈悲故。无嗔善根多。一时中乃具三善根。随所对田故。不无多少之异。施复有二种。一恭敬施。二利益施。若恭敬当施时善生。施竟则善不复流。所以尔者。如佛已涅槃。为恭敬佛故。以衣食等供养。又如世人。以衣食等供养过去世尊。亦有恭敬故。既无人受用此物故。善不得随事而流。二利益施者。为利益前人四大。以前人受用此物。四大增长故。为利益而施者。善则随三事恒流。三事者。一三善根。二余物。三众生。三事中若一事不具。善则不复流。如余物虽未尽。众生犹受用之。而施主已死。或起邪见断善根。善无复根本则善不复流。若施主生存。善根不断。能受用人未灭。而余物已尽。善亦不复流。若施主不断善根。亦不死。余物又未尽。而能受用人已谢灭。无复人受用之。善亦不复流。余人虽用。非施主本心所期。唐自受用善终不资。若檀越施心通普。此则随用。皆有善资故。为福田者。受他施时。须将其约。若听随意用。则随所回施。传传生福则无穷。若不尔者。辄回与他。乖施主心。回施人非但无福。亦更招罪。乃至后应堕恶道中更相报偿。此不容易故宜慎之。问断善根竟。善既无复根本。云何得更生善耶。答此应更作两。问须陀洹初道无流。无有无流种类为根本。何得以阿罗汉退起修道所破烦恼。烦恼无不善根为本。云何得生耶。答生有两种因。一先生因。二俱生因。先生因即是三善根。未作善时先有此善根。能生所作善。故名先生因。俱生因者。即是作意思择故善生。只思择时是善生时。故名俱生因。若善根未断。作善之时从两因生。若善根已断。作善之时。则唯从俱生因生。若善生时还复接三善根。令与善心得相应。断善根非是善根。体都灭尽。直以邪见隔之。无复有善心。与其相应名之为断。若无流道生者。有流善根体则灭。须陀洹初道无流。尔前未有无流善根。唯从俱生阿罗汉退起烦恼。三不善根已尽。亦但从俱生因生。问小乘佛受施食。食此食时作便利不。答佛无便利。佛颔下两边向颈。各有千筋。受一切食味。食下至此便变为血肉。故无便利。转轮王有两解。一云有便利。一云无有。三乘同凡夫。亦有便利。若六天食名须陀。须翻为善。陀翻为贞实。此食精妙。亦不成便利

无共系义是灭义。共系净尽故名灭。例前止应有后句。而有前句者。天竺云尼卢陀。此一名有十义。覆亦名尼卢陀。兰亦名尼卢陀。灭亦名尼卢陀。今示说灭义不说余义故。以初句分别之。中阿含中有解系缚。经云佛语比丘。贪爱在汝眼中。汝须灭之。若灭贪爱。汝眼亦灭。因眼对色生贪爱。共系缚识。贪爱即烦恼系缚。眼及色境界是系缚。若灭贪爱系缚。眼等系缚亦坏灭。经譬之云。如以锁锁系人置牢狱中。锁是一系缚。狱是一系缚。若打除锁。又烧灭狱。则离二系缚。两缚共系众生故言共系。解脱贪爱故言净。解脱境界故言尽。此即是除无余涅槃。贪爱灭是有余涅槃。境界灭是无余涅槃。眼既如此。耳鼻等悉然。三有为相解脱故名寂静。三有为自有二种。一以三世为三有为相。二以生老灭为三有为相。所以不明有住者有为法。无住住是无为相故不说之。由邪思惟故起烦恼。烦恼生业。业生果报。既有因果相生故有三世。无为法无因果相生。故无三世。有为法本是无故有生。有生故有老灭。无为法本有故无生。无生故无老灭。有为法具有二种。二相喧动故非寂静。无为法解脱此二种。三相既无喧动故名寂静。就一烦恼有一解脱。九十八烦恼。即有九十八解脱诸法本来不生。不生即解脱。众生颠倒故。于色等而起贪着。因贪着生业。业生果报。烦恼贪着色。不能称所对无为之理。所对无为。即是此贪爱若被断。即证得此无为故。九十八惑。有九十八无为业及果报逐。烦恼无别有无为

真实善故名妙。善自有四种。一真实善。二自性善。三相杂善。四发起善。真实善者。即是涅槃。生死是恶法。涅槃无恶不从因缘生。故名真实善。自性善者。即是无贪无嗔无痴三善根。此三善根不藉余缘。性能对治贪嗔痴三恶。涅槃无三恶。其与涅槃相称故名为善。譬如三药非藉余缘。性能治病。油能治风。苏能治热。蜜能治淡。三相杂善者是意业善。由与三善根相应故。生信智等善。信智等生时。心及助心法。与三善根相应。悉皆成善。未杂之时。三善根各能治一恶。心及助心法。不与三善根相杂。则无治恶用。相杂之时。则能备破诸恶。如众药未相和杂之时。各能治病。和杂以后。则无所不治四发起善者。是身口善。身口本无善。由意业善。发起身口故。身口生善。譬如水本非药。以药内水中而煮之。由药发起水使水亦成药。三善根皆由随顺真实善故得成善。恶是粗法。无为无恶是真实善。故名妙好。问心及助心法与三善根相应时。一时中具与三善根相应不。答一时中具与三善根相应。如信智等现前时。此心得理即是无痴。贪嗔不起即是无贪嗔。问心及助心法与三不善根相应时。一时中具与三不善根相应不。答恶心现前时此心乖理。恒与无明相应。苦与贪相应时。不与嗔相应。以恶性相反故。问三善根是心法不。答非心法。故有时不与心相应。如僧祇等部说。众生心性本净。客尘所污。净即是三善根。众生无始生死已来有客尘。即是烦恼。烦恼即是随眠等烦恼。随眠烦恼。即是三不善根。由有三善根故生信智等。信智等生时与三善根相扶。故名相应。由有三不善根故。起贪嗔等不善。不善生时与三不善相扶。故言相应。若起邪见断三善根。三善根暂灭非永灭。后若生善还接之令生。若断三不善根者。断则永不生。最胜息故名永离者。如人处在怨贼之中。则不得安息。若断离怨贼。离之未远。乃有安息义。非最胜安息。若都出其境界者。方是最胜安息。内合亦尔。若在烦恼怨贼中。则都未安息。若虽复稍断。断之未尽乃有安息义。非最胜安息。断之若尽。永出烦恼外。方是最胜安息。阿罗汉烦恼都尽。永不复生。是最胜安息。须陀洹见谛烦恼都尽。永不复生。亦是最胜安息

为对治邪道故名为道。九十六种沙门。皆行邪道。所以称邪道者。行此道者。去无所至。故名邪道。若行戒定慧正直道者。得至涅槃。为对治邪道故。说戒定慧为道。又解言可觅故名道。如人期心欲至一方。先须觅道路。若欲求解脱。须先觅出世道。戒定慧是可觅之处故名道。对治非如故名如。有两解。一明对治非如理。二明对治非如行。四倒与理不相应。即是非如。以常乐我净置生死中。以无常苦无我不净置涅槃中。今观生死是无常苦无我不净。涅槃是常乐我净。与理相应即是如。问小乘涅槃云何。得是我耶。是我则一切法不皆是无我。答小乘明一切法中无我。故名无我耳。涅槃有体。有体即是法我。对治行不如者。外道有常见断见。常见者。计我不灭于未来受报。为未来报故。于现在修苦行。凡有十一事。一永坐。恒坐不起。二大发行。不住不避山谷险难而漫行。三不食。断食自饿。四长倚。恒立一处。五随日仰头视日。朝则东视随日上落视之不懈。六五炙。当昼大热以日炙头。四边然火以炙身。七眠刺。取刺置一处。以眠其上。八投岩。九赴火。十投水。十一供养诸天。自挑出筋。为琵琶弦弹之。而预供养诸天。断见者。谓身灭我亦灭。无有未来现在。恣心所作造种种罪。此行并不与正行相应故。名不如行。今观不常不断。离二边行中道。与涅槃国相称事故名正行所以呼涅槃为国者有二义。一大力人所镇故。大力人即是佛。及独觉阿罗汉。证得涅槃无有过失。故言镇。二怨贼不侵故。涅槃之中永离烦恼。即是不侵。不种事有三义。一不肯去。二僻路。三疑路。若起我见者。以生死为极处。不复进求涅槃。即是不肯去义。虽欲进求而修戒取。即是僻路。于无流八定及有流八定。不知何者是正。即是疑路。若修无流慧。分别是非。即除疑路。既除疑路。亦除僻路。不着生死。即除不肯去。修无流慧。能除我见戒取疑等烦恼。涅槃无烦恼。即是与涅槃相称事。此事不邪故名正行。对治一切怖畏是名出离。一切怖畏者。佛问波斯匿王。有人说。有大山从东方来下。历地上际日轮。如是次第明有人说。余三方有大山来。汝今欲作何计。王答佛言。世尊。此不可以爱语而得却之。不可以布施而得却之。不可作怖畏事而得却之。不可兴兵而得却之。非此四方便所。如我今唯当一心急修八分圣道以求出离耳

佛又问。如有火来烂汝头烧汝衣。汝为当先须灭火。先须修八分圣道耶。王答言。世尊。火烧我头及衣。我若灭火乃是暂时得免苦。非是永免。若修八分圣道则永离苦。我当先修八分圣道不先灭火。四方山即譬老病死爱别离四苦。老苦能坏少壮。病苦能夺强健。死苦能倾寿命。爱别离苦能乖富乐。前来皆是出异义。天亲所执同经优波提舍师义

论主云。如我所信所解。今当说之。有生有灭故名无常。有为法有生灭故。不得是常。生即是有。灭即是无。先有后无故是无常。生何故非常生。灭何故非常灭。而言生灭是无常耶。解言。生坏于灭故灭非常。灭复坏生故生亦无常。相违性故名苦。五阴是苦聚。恒违逆众生心。令其受苦。众生无不爱所受身。以衣服饮食种种将养。而其不知此恩。恒生诸苦违逆众生心。于衣食增减之间。恒生苦恼。欲令得安。所以坐久则生苦。厌坐须行。久行又生苦。如此四威仪中恒相违逆。所以恒违逆众生心者。由所缘境界非真实故。违逆生苦。体所离故名空。一切诸法皆是假名。有名有义而无有体。和合能生是因义。于和合中以立因名。所生是果义。于所生中以立果名。而因果无体。何以故然。根尘和合能生识。离根尘外。岂别有因体耶。和合故说识生。离和合外。岂复别有识体生耶。有因果无能作能用。无有因果。是有因果名义。无能作者。因无体无真实能作。无能用者。果无体无真实。能受用苦乐名义。中无体即是体所离义。故名空。无自人故名无我。佛说有法不出十八界。若言有我。是何界所摄。若十八界不摄。故知无我。此破跋和弗多罗可住子部义。其救义云。我遍十八界中。岂可令别为一界所摄耶。其所执我言。不一不异。是不可说藏。今更破之。如眼根与色尘是所缘。眼识是能缘。缘根尘故生识。今先就所缘中破之。我遍在根尘中。为一为异。若其异者。则应所缘。有根尘我三法。佛何故止说二不说三耶。若言有我异于根尘。而佛不说为所缘者。此我则无用。又若言异根尘者。汝说不异义此则坏。若言我与根尘一。则唯有根尘。何处有我。则汝说不一义又坏。次就能缘破之。我与识为一为异耶。若异则能缘有二种。谓我及识。若有二法。佛何故不说耶。若虽有而佛不说。则我无用。又汝说不异义则坏。若我与识一。识从缘生。既是有为。我亦应是有为。汝立我非有为非无为。此言则坏。又汝言不一。此言又坏。若破外道计我者。外道立我义。以四智证知有我。一证智。二比智。三譬智。四声智。以此四智证知有我。外道有断常二见。若是断见者。谓即此身是我。故身灭我亦灭。既即身是现见有身。即是证智知有我。若见出息入息等五种是我相。既见其相则知有我。此即是比智知有我。若见自身有我。知他身亦有我。即是譬智知有我。闻圣师说有我则知有我。是声智知有我。若常见者。则唯比声二智知有我耳。常见者言。邻虚及我不可见。非证智所知。复有常见者亦言。我是证智所知。其说眼中之白精是月。白之中间赤精是日。赤之中间青精。言是空。青精中人子是我。我则常。此亦可见故。是证智所知。月是母造。日是父造。空是自在天造。我非因造故是常。所以名青精为空者。若覆之则不见知其是空。天亲次第破之。证智所知不过七法。即是六尘及识。六尘及识并非是我。岂得为证智所知耶。比智所知者。如眼色空作意等因缘。生眼识。识即是明用。既见其有用。比智知必有眼。我无别用。以何义比知有我耶。譬智者。如见家牛形容。譬类知野牛形容。状亦应如此。我既非证智所知。亦非譬智所知。声智者其执我。是圣师说言有我。我信圣师声说。故立有我。此亦不然。汝师有断常二说。若如跋婆梨柯。阿赖伽也(扬荷反)。优楼迦(脚何反)等三外道。起常见执言有我说有未来。若是诃梨多闻。陀阿轮罗耶那等三外道。起断见执言无我不说有未来。汝师所说有无自不定。岂可以此为证有我耶。言无自人者。计我者言。我是五阴主。独居五阴中。譬如国王。国是自己所有不与他共。今明五阴无主故言无自人。故名无我。问外道明我有何用耶。若有用则可以比智知。答其说我外相有五内相有九。此是优楼迦等作此执。外相有五者。一出息。二入息。三瞬。四视。五寿命。具此五相故知有我。五相即五用。今破之。若以前四相知有我者。如卵无前四相。岂有我邪。其救义云。虽无前四相。有第五相则知有我。又破之。寿命必与身相接。汝明我得解脱时。我则离身。我离身时则无复寿命。岂得以寿命证知有我邪。内相者其说我是常。心是邻虚。心亦是常。别有法非法。法者是善。非法是恶。法非法能令我心共合。我心共合生九法。从我心生觉。能觉知故。从觉生苦乐。从苦乐生欲憎。于乐生欲。于苦起憎。从欲憎生功力。作功力欲灭苦求乐。从功力生法非法。若常见者。计有未来故。于现在修诸苦行。名之为法。若断见者。计无未来故。于现在恣心造恶。名为非法。从法非法生修习。修习既熟其用速疾。修疾即是因力。修疾故能疾忆念过去事。由别有法非法合之。故九法中生法非法。有时作善。有时作恶。别有法非法。凡有五种事。一能使火上升。二能使风傍行。三能使地水沉下。四能使邻虚和合。五能使我心和合。外道说有二灾。一中间灾。二火灾。中间灾者。凡经三百千拘胝。即是三百千拘胝劫。一百千拘胝火。一百千拘胝水。一百千拘胝风世界。于火灾时。世界一劫减一劫生。水风时亦尔。灭则粗尘灭。本邻虚相离而住。生则是法非法使其共合。法合为善道。非法合为恶道。本尘既合。从此增长。更生诸尘。故成世界。我心亦逐外尘离合。度三百千拘胝。中间灾满。至火灾时。复经三百拘胝。世界一向灭。本尘一向相离而住。我心亦一向相离而住。则我暂时解脱。度三百千拘胝火灾满。法非法复使其共合。问火何故上。风何故傍行。地水何故下。答火能成熟物。若火不上升。众生则无以得成熟饮食等物。又火有光明。主于智慧故。在上自在天。身备有六道。从心向上是人天。从心下向至脐。是阿修罗及鬼。从脐下至足。是畜生及地狱。人天光明有智慧故在上。火有光明主于智慧故在上。风若不傍行。众生则无以得去来。如船在海。风若沉下上升船则不得进。由风傍行故有去来。地水若不在下。则众生无依处。地水闇生惑。惑属地狱畜生。故在下。地狱畜生闇而有惑。故在下地。地水闇生惑故在下。为欲永得解脱故。修戒施苦行定四法。从四法生正法。正法者是其得道。从正法生乐生智。智乐者受天中乐果。智慧若后时断法非法。我与心则永相离。九法永不复得生。则永得解脱。若破我见及邻虚。此执自坏。论云。爱欲有四种。一执我。是不分别爱欲。二执当我。是不分别更有爱欲。三执当我有胜劣是分别更有爱欲。四结有相接爱欲。今且次第释之。第一执我者。于现在执言身中有我。而不分别。执一阴为我余阴非我。亦不分别。五阴都非我。而于我生爱。于我所色香味触等境。生染着心故名欲。我及爱是见道所破。欲是修道所破。第二爱欲者。常见者。谓我不灭得至未来故名当我分别。不异向释未来。言更有我。于更有我生爱。于我所六尘生染着。故名欲。第三执当我。如向释。亦不分别有胜劣。是分别者。分别未来我。或受苦或受乐。或于上地生。或于下地生。此即是胜劣义。更有爱欲不异向解。第四爱欲论文乃不说执我。亦是执我爱欲。执我无分别不异向解。谓我不灭得至未来。于未来生处起染着故。推此身即爱后身结。前后二有命相接不断故言结。有相接爱欲不异向解。论云。经中佛说。五阴者以爱欲为根本。爱欲为集起。爱欲为生处。爱欲为缘。经中复说。爱欲有四种。论更次第列前四名。后乃释之。释因云。第一爱欲。是五阴初根本故名因。如种子与果者。根本是因义故初。引经言以爱欲为根本。即是爱欲为因。今以根本释因义。言初根本者。先于现在执我生爱欲。此爱欲即有感未来果力故名初。如有种子。便有生果之力。故言如种子与果

释集起云。第二爱欲者。是五阴集起。能令当果来故。譬如牙等与果者。第二爱欲。缘未来有我及诸尘生。以爱欲共和合。能令当果来现在故。名爱欲为集起。由如牙乃至华能生实等节等茎叶及华。果即是实。释生处云。第三爱欲者。是五阴生处。能生五阴胜劣。譬如果与田水土等。故有香味力变熟。感德者。第三爱欲。分别未来有胜劣故。受报之时有升有沈。由第三爱欲。使未来胜劣报得生故。名第三爱欲为生处。第二誓以实为果。今言果亦取实为果。果已生田及水土等。为果作缘。增长其香味等。田等有肥瘦等诸力用不同。果于中生香味等。随缘有异亦尔。随爱欲分别故得果。有胜有劣。香依正量部及外道立义。谓有三种。一香二臭三平。平者无香臭。若是余部止有香臭。无别余气。而香臭各有二种。一增。二损。如麝香。人若嗅之则增鼻邻虚尘。虫有闻此香则损鼻邻虚尘。粪等臭。人若嗅人损鼻邻虚尘。猪狗嗅之则增鼻邻虚尘。味有七种。谓甜苦辛酢碱涩灰汁味。涩者如生查等。灰味私谓只应是淡味耳。力者有十种。即轻重冷热涩滑坚软漱(俟苟反)糗(丘酉反)。果子熟如林檎之流。其肉则糗。变熟者有三种。一甜。二酸。三刺。此非三味。以三味为名耳。食果入腹。变熟成淡者名甜。变熟成热者名酸。变熟成风者名刺。淡体甜滑重故名淡为甜。热体使酢咽故热名酸。风体能使身瘦面涩。刺体无肥而涩故名风为刺。人身有三分。从心向上是淡位。从心下至脐是热位。从脐下至足是风位。此三分若相通者。则调适无病。若壅结不通则成病。若以六味约之变熟则不同。甘碱二味变熟成甜。酢味变熟成酸。苦辛涩三味变熟则成刺。威德者。药木等自有威德。或根能出光。或能却鬼。或能除毒。如摩伽药所生之处。一切毒草皆无复毒。力果随缘有此不同。以喻众生感报差别

释缘云。第四爱欲者。是五阴生缘。五阴从其起故。譬如果缘华灭故生者。第四爱欲染着未来生处。结二有使相接。未来五阴缘其得起故。名第四爱欲为缘。如缘华灭故实得生。事断故名灭者。事即十二缘生。此据因为事。以因断不复相续故名灭。即明第一爱欲断。今十六谛有十六物故灭。下四各以一法为体。无苦故名寂静。苦不据苦受为语。从前生者是果。名果为苦。前明因断今明果无。若果更生喧动不已。岂称寂静。并由果无故。所以寂静。此即明无第二爱欲。第二爱欲。从初爱欲生。即是果无上故名美妙者。最胜无过无等故言无上。即明无第三爱欲。第三爱欲分别胜负。今明唯胜无劣。即除胜劣。爱欲不更还故。名永离者。若出而更还。非谓永离。今出而不还。故名永离。即明无第四爱欲。第四爱欲结有令相接。是更还生死。今断此结不得复还。无流心所行故名道者。道即戒定慧为体。从无流心生名之为行。无流心自有三种。一熟。二直。三明。熟故无退。明故不迷。直故是真也。得修慧离散动故熟。熟故不复退失也。若心闇则迷境。由明故不迷也。若有邪僻则不得名直。正趣不邪故名为直。直而无杂故称真。无流心既具此三德。所生之道。亦具三德也。通达真实境故名如。与四谛理真实境界相称故名如也。决定故名正行。如经说。唯此是道更无别道。为清净见故者。无胜之无等之者。故名决定。若更有一法胜此法则成不定。若更有别法等此法者亦非是定。不定则不得称正行也。论引经证定义故。言唯此是道无别法等之胜之。故言更无别道也。见有两种。一是僻见。即五见也。二是正见。即尽智也。尽智即阿罗汉。断烦恼已尽所得智也。能断除僻见。得阿罗汉正见故。言为清净见故也。若曲解见道。第十三心亦得名正见。以能清净见故。名为正行。故唯正行是道。此外岂复有别道耶。毕竟度故名出离者。灭谛是毕竟。以毕竟不生故也。无流智断除烦恼。越诸流证得无为故名为度。无为既是毕竟。证得无为度亦毕竟故。以灭谛。毕竟之名目。度名为毕竟。以毕竟度故称出离也。论云。经中又说。众生有四见。一常见。二乐见。三我所见。四我见。佛为破此四见故。说无常苦空无我。释此语者。起见之时必先起我见。起我见时即具起余三见。起我见者计我为常。即起常见。我既是常。如刀不能斫火不可烧。既不可破坏。此即是乐。即是乐见。既计有我我所在处。即是我所。即是我所见。若破我见余三见俱被破。僧佉鞞世师等作此执也。僧佉鞞世师等。又起常见云。无不有有不无。一切法无则恒无。无不成有。有则恒有。有不成无故。一切法皆是常。现见一切法。有生灭者。此是转异耳。非其体始生。非其体终灭。如金转为环玔。金体不曾生灭也。其说自性生空等五大。五大复生五根。何者自性生空。空与声俱起。空是本声是末。声是空德空最细无物能破之。自性生风。与触俱起。风是本触是末。触即是风德。风粗空细。以空来破风。风杂于空。风则具两德。自德是触。他德是声色。自性生火。火与色俱生。火是本色是末。色即是火德。火粗风细。风来破火。火杂于风。火具三德。自德是色。他德是声。触自性生水。水与味俱生。水是本味是末。味即是水德。水粗火细。火来破水。水杂于火。水具四德。自德是味。他德是声。色触也。自性生地。地与香俱起。地是本香是末。香是地德。地粗而水细。水来破地。地杂于水。地具五德。自德是香。他德是声。色触味也。五大作因生五根。五根是果。空生耳。耳还取空。自德不取他德故。唯闻于声不见色等也。风生皮。皮即皮肉等也。皮还取风。自德唯取触不取余德也。以火生眼。以水生舌。以地生鼻。类前两可解耳。五根既从五大生。五根灭还归五大。耳根灭还归空。乃至鼻根灭还归地。故诸法是常也。破常见者。明未有已有灭即是先无后无故是无常。其言无不有。今明未有有。未有是无。本是无今成有。则无不恒无。其言有不无。今明已有无。先是有今成无。则有不恒有也。问火云何能破水。答色是火德。水中有色即是以火破水也。问何者是自性。而说其能生耶。答有三种法。一名自性。二名人。三名变异。三种中初一但名自性。人但名人。变异亦名自性。亦名变异。所以尔者。初一无知。故不得名人。无转故不得名变异。故但称自性也。人有知不能取。不得名自性。无转故不得名变异。但得名人也。从三德以去悉无知。其能传生后故名性。从他生有转故名变异也。三法悉是常前两是常。而无变异。后一是常而变异。如金性不改而有环玔之异。人即是我也。自性如盲人能行而不见路人。如有目而无足人。能见不能行。自性能作而不能知。人能知而不能作。人与自性共合则生变异自性。自性凡有八种。一根本自性。二三德自性。三大自性。四我执自性。五唯尘自性。六大实自性。七知根自性。八业根自性。三中之第一是根本自性。本来有之。从根本自性。生七种自性。七种自性并是变异自性也。从根本性生三德自性。三德者天竺语。第一名萨埵。无的相翻义翻。应言妙有。其生时精妙而体是有也。二名阿罗社(常荷反)。正翻为尘。动而能染。染故名尘。三名多摩。正翻为闇。其体塞也。若以义立者。第一名轻光。第二名动持。第三名重塞一切法若内若外。不出此三种。先论外论。外法约四大论之者。空大及火大是轻光。风大是动持。而能持物令不堕落也。地水是重塞。其体重而闇塞也。约六趣者。天是轻光。人是动持。四恶趣是重塞也。约内法论之者。舍受是轻光。乐受是动持。心动摇而执捉于境。苦受是重塞。智慧是轻光。贪是动持。嗔痴是重塞也。初生三德时。内妙有始显。外法未显后时方显也。从三德自性。生大自性。大者是觉。觉是诸知之本。有觉察之用也。从大自性生我执自性。执言有我与他异也。若是僧佉义。从我执生唯尘。唯尘生大实。若鞞世师义。从大实生唯尘。今且依前释。言唯尘者。唯有五尘。余法未显也。从五尘生大实。即五大。一切法无出其外者。故名大也。实者一切法。去来皆在此五中。一切法自有变异。其体常在无异。如眼根坏还归空大。眼根自有坏。空大不坏。乃至鼻根归地亦尔。故名实也。从大实生知根。眼等五根能知故也。从知根生业根。业根有五。一口。二手。三脚。四尻。五男女根。口能语为语之根。语即是口业。手为捉根。捉是手业。脚为行根。行是脚业。尻为放根。能放粪秽。放是尻业。男女根能生子。为生子根。生子是男女根业也。此即是二十五句。实谛义。五业根。五知根。五尘。五大。为二十。我执为二十一。大为二十二。三德为二十三。人为二十四。自性为二十五也。问约五大论三德。五大只应属大实。那忽属三德耶。答其体性属三德。五大自属大实。由如一牙分为多牙。或刻为马。或刻为象。象马虽异体性是牙。五大亦尔。五大自属大实。逐其体性相摄。自属三德也。前言自性生空等。即说根本。自性能生也。僧佉义明因中具有果。如钵多树子中具足已有枝叶华果。自性之中已具足有七种变异自性。人与其合时。七种则次第显现。名之为生耳。非先无后有名为生也。问三德有智慧及三烦恼。缘何物为境。答其是妙有法不缘境起。如佛家三善根。三不善根复何所缘起耶。问三德中有智慧。大言是觉。那忽言变异自性悉非知耶。人是知者。人能知耳。七种变异自无知用。如人能斫故名刀。为能斫耳。刀实不能斫也。问唯尘是色等五尘。云何用尘来显大实耶。答五大并是邻虚不可见。色等五尘是五大之末。见末方得显本。色等五尘非邻虚故可见也。问自性是能生。亦是能变。三德望自性是所生所变。望大是能生能变。何故自性能生得受生名。能变不得受变名。而三德具受两名耶。答能变能生并是因名。所变所生并是果名。直呼为变直呼为生者。此是果名。果起方是变是生耳。因未有变及生也。今言自性。能生者即是能变。说能变为能生耳。其非所变故。不得受变名。三德具能所二义。故受两名也。问何以能生为自性耶。答能生是本。本是自性义。故受自性名。问人亦是本。何不受自性名耶。答其无作用。不能变他故。不受自性名也。乐见者。尼捷子等起见。谓言生死真实是乐涅槃真实是苦。其推之云。如人无一手一目。此是苦不。若是苦者。无一手一目以自是苦。都无此身岂非极苦耶。涅槃中既无复五阴。故云涅槃是真实极苦也。无一手一目。傍人为治。更得一手一目时此是乐不。是乐者。得一手一目以自是乐。具足一身。岂非极乐。现在世既具有五根。故知有身真实是极乐也。僧佉鞞世师。又起乐见云。生死真实有乐有苦。人天是真实乐。地狱畜生等真实是苦。其以因推之。因既真实有善有恶。恶能感苦。善能感乐。以因真实故。知果亦真实也。破此两见者。生死互相待故生乐耳。何以知然。以粗为乐。以细为苦。如饿鬼缘地狱为苦。自缘其报为乐。畜生缘饿鬼为苦。自缘其报为乐。阿修罗缘畜生为苦。自缘其报为乐。如此人天色无色界中。互相形待。妄谓为乐。极至非想。若以涅槃望非想。非想为苦。涅槃为乐。既无复有胜涅槃者。故涅槃是真实乐。生死真实是苦。若大乘三乘涅槃复有异。今不论此也。问常言。上罪地狱。中罪畜生。下罪饿鬼。今那得言畜生胜饿鬼耶。答若小乘则如所引大乘理论。畜生胜饿鬼。饿鬼带火而行。受重之苦。颈小腹大。恒患饥渴。设值清流谓为猛火。畜生之中无此等事。故知为胜也。破后见者。生死以有流为因。虽是善因善亦有流。既是有流故非真实。如有好食以毒药内中。则不复成好食。善既非真实。乐岂是真实耶。论言我作器故名我所者。僧佉鞞世师作此执。一是内作器。二是外作器。我是知者作者受者。知是我法。即是九法中之觉法也。心是我内作器。根是我外作器。尘是我资粮。知有五根尘各五。心只是一。心及我皆常。非法令其共合。已前解所以。名作器者。如世间斧锯等。是工巧人之作器。其用之作床机等。心及根亦尔。我用之见色闻声。故名作器。由尘生知故名资粮也。以内作器证有我。以外作器证有内作器。以资粮证有根。我法通证有我及作器资粮也。内作器证有我者。我是作者。若无有我。谁使心在眼。或时在耳鼻舌中耶。故知有我也。外作器证有内作器者。凡证两义。一证心是一。心若是多。何故一时中不并生五知以知五尘耶。故知只是一心。在眼中则能见不能闻。在耳中则能闻不能见色。故五根不并用也。二证心是有。若有心者既恒有。有我恒有五根。何不恒生知知五尘耶。心在根中时。方能知尘。故知必定有心也。资粮证有外作器者。若无外作器。眼根坏时何故不见复见色耶。故知必有外作器也。我法通证四事者。心非是知。根尘亦尔。若无有我。岂得有知。我是知者。故知是我法既有我。法证有我也。若无有心。则一时中并有五知。若知色时不能知声。故知必定有心。在根中故知得生亦得以知证心是一。心若不一。五心并在根中。则一时一时中应有五知也。若无有根。根坏之时。何故不生知耶。若无有五尘。知何所知耶。心与我共合故。名内作器。根不与我合故。名外作器。尘是前境。能资生我法。名我资粮也。其即名我作器。及我资粮为我所也

僧佉立有我。以五义为证。一聚集为他故知有我。如世人为弘通法故聚集经书。非是自为。乃是为他。又如世人聚集床席。亦非自为。乃为拟他。既见聚集为他。则有他人也。众生身亦尔。五尘四大五根五阴等聚集。见其聚集。知非自为必是为他。他即是我故。知有我也。二见自性变异。为三德等七法故知有我。自性非知。其不能变异。为三德等七法。既能变异。为三德等七法。知必有知者来合之方得有变异。知者即是我故。知有我也

三见变异。中有觉故知有我。自性非觉。自性是本变异是末。本既无觉。末中不应有觉。变异中既有觉。故知别有觉体。未合自性故。变异中有觉。觉体即是我。是我故知有我也。此一事即显我被系缚。以从觉生我执故也。四见有可用故知有我。既有可用知必有能用。自性是可用。我是能用。既见有可用故。知必有能用。故知有我也。其譬云。如女人是可用男子是能用。见有女即知有男也。自性是可用。故我与之合。合故变异为三德等七法。七法系缚于我。后闻师教得闻思修慧。知从自性生此系缚住在生死。于自性及系缚生厌恶。既生厌恶。永离系缚故。我得解脱。其譬云。如男子于闇中与病癞女人共为欲事。数数为之了无厌恶。后于光明中见之即生厌离。若是强性女人。犹来就此男子。若是软性者。一被厌恶即不复来。虽当时不来。犹有来义。自性一被厌恶。则永不与我共合。无一软性女人。及此自性软性者也。五独住义真实有故知有我。既知从自性生变异故被缚系。修得智慧。于自性生厌离。自性既与我相离故。我独住。我独住故。我得解脱。若无有我则无独住义。独住义既真实有故。知有我也。后别委悉破我执。不复两烦也

十六谛义出随相论释


提婆菩萨破楞伽经中外道小乘四宗论

    No. 1639

提婆菩萨破楞伽经中外道小乘四宗论

        提波菩萨造

        后魏北印度三藏菩提流支译

问曰。外道所立四宗法非佛法者何者是。答曰。谓一异俱不俱。问曰。云何言一异俱不俱。答曰。有诸外道言。一切法一。有诸外道言。一切法异。有诸外道言。一切法俱。有诸外道言。一切法不俱。是诸外道于虚妄法中各各执着。以为实有物故。问曰。何等外道说一切法一。答曰。言一切法一者。外道僧佉论师说。言一切法异者。外道毗世师论师说。言一切法俱者。外道尼犍子论师说言一切法不俱者。外道若提子论师说。问曰。云何僧佉人说一切法一。答曰。僧佉外道言。我觉二法是一。何以故。二相差别不可得故。问曰。云何二相差别不可得。答曰。如牛马异法。二相差别可见可取。言此是牛此是马。而我离觉我不可得。离我觉不可得。如我经中说。我觉体相如火与热。二法差别不可得。问曰。云何差别不可得。答曰。彼法不可说异故。譬如白叠不可说言此是白此是叠。二法差别如白叠。一切法因果亦如是。问曰。云何毗世师外道说一切法异。答曰。所言异者。我与觉异。何以故。以说异法。问曰。云何名说异法。答曰。如说此是白此是叠。此是天德。此是天德叠。我与觉异亦如是。此是我此是智故。问曰。有何差别彼法不可说一。答曰。譬如白叠此是白此是叠。如是一切因果各异。不可说一故。问曰。云何尼干子说一切法俱。答曰。言一切法俱者。如我与觉不可说一不可说异。复有异义可说一可说异故。问曰。云何不一不异亦一亦异。答曰。如我与命用相有异方便异故言。如贪嗔痴等得言有异。譬如灯明得说言一得说言异。以有此有彼无此无彼。得言一。灯异处明异处。故得言异。如灯明因果白叠一切法亦如是。亦得说一亦得说异。故言俱也。问曰。云何若提子外道说一切法不俱。答曰。不俱者。谓一切法不可说一不可说异。以二边见过故。以说一异俱论师等皆有过失故。智者不立如是三法。问曰。云何过失。答曰。若离白别无叠者。白灭叠亦应灭。若异白更有叠者。应有叠非白有白非叠。是故一异俱等法我俱不立。虽然一异俱等一切法不可得言无。答曰。此诸外道虚妄分别。是邪见相非是智相。皆是不善。此义云何。又一等法虚妄分别。以不得言即彼法。彼法一不得言瓶。瓶一以瓶即是瓶故亦不得异法。异法一以不得言瓶共。叠一以瓶相异叠相异以异法离异法。异法不得一不得异。以异法不成异法。以异法不得言异法。若二法说一说异。彼二法应说一应说异。若不说一不说异者。此是虚妄分别。若彼二法是一者。不得言彼法是异。若无二者云何言一。以彼法相待成故依世谛虚妄分别。第一义谛中无彼外道虚妄分别戏论过故。此是总答四种外道邪见之相

自此已下别答四义。如是一一观察迦毗罗忧楼佉等外道虚妄分别义不成就。此义云何。言一切法一者。此义不然。以灭应灭。不灭不应灭。俱灭俱不灭此义云何。汝向说我与觉相差别不可得如白叠。我破此义。何以故。以此义不与诸经论相应故。汝说诸法差别不可得者。此义不然。如手爪彼法二相差别不可得故。此明何义。如爪指掌名之为手。若异此法手不可得。如是白叠一不可得。何以故。无异法故。我觉一不可得。如是白叠一不可得。如手与指掌。若此灭者彼亦应灭。此义云何。若白灭者叠应灭故。如截手即截指掌。汝意若谓白灭叠不灭者。此义不然。若叠不灭白亦不应灭。如截于手指掌应在如截指掌手亦应在故。汝意若谓青黄赤等唯灭白色不灭叠者。云何言一。若不尔者青黄赤等色不应灭。不尔叠不灭者青黄白等色亦不应灭

问曰。我青黄赤等覆白色而不灭白。此义云何。答曰。叠亦如是覆叠而不灭叠。又此义不然。洗叠已还见白色故。叠亦如是。覆叠不灭叠。是故白即是叠。叠即是白。若叠灭者青黄赤白等色云何见。若汝意谓白灭覆非灭叠应灭覆叠不应灭白。若尔有法灭覆有法不灭不覆。云何言一。是故一义不成。已答外道僧佉论师一切法一竟

问曰。迦那陀外道论师言一切法异者。我与觉异。以说异法故。此是我此是觉。如白叠此是白此是叠故。答曰。此义不然。以无譬喻故。如人说言。此是手此是指掌。彼人虽说此语不能说异法。是故不得言我觉异。如白叠以见世间有二种差别故。一者相二者处。相差别者。色香味触不异相有异相故。处差别者。如谷豆等有白叠不异相有差别。如彼色香味触。若不尔者有四种过。此义云何。白灭叠亦灭。如彼色香味触。譬如火和合烧瓶成赤色已又为青色。香味亦尔。若不尔者色香味触亦不应灭。如彼白叠异不可得。若白灭者叠亦应灭。叠不灭者白亦不应灭

问曰。此义不然。依彼法有此法。譬如画壁依壁有画。壁灭画亦灭。画灭壁不灭。我白灭叠不灭义亦如是。答曰。汝此譬喻事不相似。壁是先有画是后作。而彼白叠起无前后。不可得言此白先有叠是后作。已答外道卫世师论师一切法异义竟

问曰。尼揵子外道论师言一切法俱。迦毗罗等论师皆有过失。以说一异故。是故我说俱而不俱。譬如灯明。有此有彼。有彼有此。无此无彼。无彼无此。如有灯有明有明有灯。无灯无明无明无灯。异者能照所照。以灯异处明异处。是故说异。如我觉白叠等。亦得说一亦得说异。譬如白于叠中别处不可得言此是白此是叠。如世间此是牛此是马等。白叠不尔。是故我不说异亦不说一。若一者白灭叠应灭。又若一者亦不应说赤叠黑叠等。是故我言得说一得说异。此义云何。答曰。此义不然。如向说僧佉毗世师等过失。与此无异。以何等义僧佉一如向说。以何等义毗世师异如向说。云何向说。如向说言。灯明一者灯即是明。明即是灯。此唯有别数而无别义。若尔灯亦应明。明亦应灯。若此二法。一者云何异处。如手与指掌无差别。脚手有差别。手指掌无差别。若一者云何言异。是故不得言一言异。此一异义不成。已答外道尼犍子论师一切法俱竟

问曰。若提子论师言。僧佉等论师说一切法一异俱皆有过失。我若提子不说一切法一异俱。如我论中不许此义。唯许不俱。是故我无僧佉等过失。虽然不得说言无不俱。此义云何。答曰。此义不然。以无譬喻故。以无譬喻者我说。世谛有如是法。第一义谛中无如是相。是故此成我所说义。此明何义。以无彼法即无此法无彼法体亦无此法体。以此法不成彼法。彼法不成此法。以此法毕竟非彼法。彼法亦毕竟非此法。以白非叠以叠非白。以灭不应灭。以一者即白是叠叠即是白。不尔者灭是灭。不灭者不灭。若尔云何虚妄分别。彼法是一异俱不俱。若尔叠亦应非叠非不叠。白亦应非白非不白。以叠即是叠白即是白。是故叠非叠白非白。是故非白不得白。如是一异俱不俱皆是虚妄分别。唯有言说无有实义。如是我觉因果等义亦如是故。已答外道若提子论师一切法不俱竟

提婆菩萨破楞伽经中外道小乘四宗论


提婆菩萨释楞伽经中外道小乘涅槃论

    No. 1640

提婆菩萨释楞伽经中外道小乘涅槃论

        提波菩萨造

        后魏北印度三藏菩提流支译

问曰。何者外道所谓涅槃

答曰。外道所说涅槃有二十种。是诸外道等虚妄分别。如是等因能生六道。如来为遮是等邪见故说涅槃因果正义。何等二十。一者小乘外道论师。二者方论师。三者风论师。四者违陀论师。五者伊赊那论师。六者裸形外道论师。七者毗世师论师。八者苦行论师。九者女人眷属论师。十者行苦行论师。十一者净眼论师。十二者摩陀罗论师。十三者尼犍子论师。十四者僧佉论师。十五者摩醯首罗论师。十六者无因论师。十七者时论师。十八者服水论师。十九者口力论师。二十者本生安荼论师

问曰。何者外道说诸受阴尽如灯火灭种坏风止名涅槃。答曰。第一小乘外道论师说

问曰。何等外道说方名涅槃。答曰。第二外道方论师说。最初生诸方。从诸方生世间人。从人生天地。天地灭没还入彼处名为涅槃。是故方论师说方是常名涅槃因

问曰。何等外道说风为涅槃因。答曰。第三外道风仙论师说。风能生长命物能杀命物。风造万物能坏万物。名风为涅槃。是故风仙论师说风为常是涅槃因

问曰。何等外道说梵天是涅槃因。答曰。第四外道围陀论师说。从那罗延天脐中生大莲华。从莲华生梵天祖公。彼梵天作一切命。无命物从梵天口中生。婆罗门两臂中生。刹利两髀中生。毗舍从两脚跟生。首陀一切大地。是修福德戒场生一切华草。以为供养。化作山野禽兽人中猪羊驴马等。于界场中杀害供养梵天。得生彼处名涅槃。是故违陀论师说梵天名常是涅槃因

问曰。何等外道说不见分别见常无常是涅槃。答曰。第五外道伊赊那论师眷属作如是说。伊赊那论师尊者形相不可见遍一切处。以无形相而能生诸有命无命一切万物。名为涅槃。是故伊赊那论师眷属作如是说。伊赊那是常名涅槃因

问曰。何等外道。分别见种种异相名涅槃。答曰。第六裸形外道论师说

问曰。何等外道说见一切法自相同相名涅槃。答曰。第七外道毗世师论师作如是说。谓地水火风虚空微尘物功德业胜等十种法常故。和合而生一切世间知无知物。从二微尘次第生一切法。无彼者无和合者。无和合者即是离散。散者即是涅槃。是故毗世师论师说。微尘是常能生一切物。是涅槃因

问曰。何等外道说身尽福德尽名为涅槃。答曰。第八苦行论师说

问曰。何等外道说自性人命转变名涅槃

答曰。第九外道女人眷属论师说。摩醯首罗作八女人。一名阿提[仁-二+致]。二名提[仁-二+致]。三名苏罗婆。四名毗那多。五名迦毗罗。六名摩[少/兔]。七名伊罗。八名歌头。阿提[仁-二+致]生诸天。提[仁-二+致]作阿修罗。苏罗婆生诸龙。毗那多生诸鸟。迦毗罗生四足。摩[少/兔]生人。伊罗生一切谷子。歌头生一切蛇蝎蚊虻蝇蚤蚰蜒百足等。如是知者名为涅槃。是故女人眷属论师说。女人是常名涅槃因

问曰。何等外道说罪福尽德亦尽故名涅槃

答曰。第十外道行苦行论师说

问曰。何等外道说烦恼尽故依智名涅槃

答曰。第十一外道净眼论师作如是说

问曰。何等外道说见自在天造作众生名涅槃

答曰。第十二外道摩陀罗论师言。那罗延论师说。我造一切物。我于一切众生中最胜。我生一切世间有命无命物。我是一切山中大须弥山王。我是一切水中大海。我是一切药中谷。我是一切仙人中迦毗罗牟尼。若人至心以水草华果供养我。我不失彼人。彼人不失我。摩陀罗论师说。那罗延论师言。一切物从我作生。还没彼处名为涅槃。是故名常。是涅槃因

问曰。何等外道说众生递共因生名涅槃

答曰。第十三外道尼犍子论师作如是说。初生一男共一女。彼二和合能生一切有命无命等物。后时离散还没彼处名为涅槃。是故尼犍子论师说。男女和合生一切物。名涅槃因

问曰。何等外道说证谛道名涅槃因

答曰。第十四外道僧佉论师说。二十五谛自性因生诸众生是涅槃因。自性是常故从自性生大。从大生意。从意生智。从智生五分。从五分生五知根。从五知根生五业根。从五业根生五大。是故论中说。随何等何等性修行二十五谛。如实知从自性生还入自性能离一切生死得涅槃。如是从自性生一切众生。是故外道僧佉说。自性是常能生诸法。是涅槃因

问曰。何等外道说有作所作而共和合名涅槃

答曰。第十五外道摩醯首罗论师作如是说。果是那罗延所作。梵天是因。摩醯首罗一体三分。所谓梵天那罗延摩醯首罗。地是依处。地主是摩醯首罗天。于三界中所有一切命非命物。皆是摩醯首罗天生。摩醯首罗身者。虚空是头。地是身。水是尿。山是粪。一切众生是腹中虫。风是命。火是暖。罪福是业。是八种是摩醯首罗身。自在天是生灭因。一切从自在天生。从自在天灭。名为涅槃。是故摩醯首罗论师说。自在天常生一切物。是涅槃因

问曰。何等外道说一切物自然而生名涅槃。答曰。第十六外道无因论师作如是说。无因无缘生一切物。无染因无净因。我论中说。如棘刺针无人作。孔雀等种种画色皆无人作。自然而有不从因生名为涅槃。是故无因论师说。自然是常生一切物。是涅槃因

问曰。何等外道说诸物皆是时作名涅槃

答曰。第十七外道时散论师作如是说时熟一切大。时作一切物。时散一切物。是故我论中说。如被百箭射时不到不死。时到则小草触即死。一切物时生。一切物时熟。一切物时灭。时不可过。是故时论师说。时是常生一切物。名涅槃因

问曰。何等外道说见有物名涅槃

答曰。第十八外道服水论师作如是说。水是万物根本。水能生天地。生有命无命一切物。下至阿鼻地狱上至阿迦尼吒天。皆水为主。水能生物。水能坏物。名为涅槃。是故外道服水论师说。水是常名涅槃因

问曰。何等外道说见无物名涅槃因。答曰。第十九外道口力论师说。虚空是万物因。最初生虚空。从虚空生风。从风生火。从火生暖。暖生水。水即冻凌坚作地。从地生种种药草。从种种药草生五谷。从五谷生命。是故我论中说。命者是食后时还没。虚空名涅槃。是故外道口力论师说。虚空是常。名涅槃因

问曰。何等外道说见有无物是涅槃因

答曰。第二十外道本生安荼论师说。本无日月星辰虚空及地。唯有大水。时大安荼生如鸡子周匝金色时熟。破为二段。一段在上作天。一段在下作地。彼二中间生梵天名一切众生祖公。作一切有命无命物。如是有命无命等物散没。彼处名涅槃。是故外道安荼论师说。大安荼出生梵天是常。名涅槃因

提婆菩萨释楞伽经中外道小乘涅槃论


贤圣集伽陀一百颂

    No. 1686

贤圣集伽陀一百颂

        西天译经三藏朝散大夫试鸿胪少卿明教大师臣天息灾奉　诏译

  稽首一切出世间　　三界最尊功德海
  智火能烧烦恼垢　　正觉我今归命礼
  稽首能拔生死崄　　普竭忧恼贪痴海
  破彼尘劳罪业山　　我今归礼妙法宝
  稽首一切佛称赞　　八圣道行作庄严
  无为禅定渐圆明　　我今归礼圣众宝
  内宫宝藏诸楼阁　　金玉摩尼种种光
  真珠璎珞广庄严　　百千天人恒游履
  若得安居天界中　　修严佛寺获斯报
  信心归敬于三宝　　给施财帛精舍中
  受彼人天快乐已　　当得涅盘寂灭果
  精舍年深多摧坏　　重修严饰供佛僧
  常获快乐住人天　　亦得涅槃寂灭果
  若于精舍施园林　　座具衣服汤药等
  复遇恶世饥难时　　施彼众生饮食物
  如是而获无边福　　及得智者七圣财
  消除一切恶道苦　　永受大富无穷尽
  诸佛如来行住处　　若人到已生恭敬
  承事供养兼闻法　　深信修学依戒行
  当获广大无边果　　譬如大海渺渺深
  以器较量算不及　　福德因缘亦如是
  若人修建于佛殿　　寒热风雨不能侵
  最先获证寂灭法　　圆满一切随意愿
  若人塑画于佛像　　忧恼疾病得解脱
  复得生天胜妙身　　大智吉祥及尊贵
  若人重修于佛像　　当得坚牢无病身
  长寿色力诸相圆　　后得涅盘寂静乐
  忧恼诤讼皆灭除　　勇猛辩才人称赞
  调伏诸根而策勤　　一切庄严众所敬
  若人修诸佛像等　　远离过失得生天
  富贵端严众所钦　　一切福德皆具足
  破损塔庙若重修　　彼人无病身圆满
  一切世间可爱果　　种种随心皆具足
  若造佛像及佛塔　　形量至小如麦粒
  不唯天上与人间　　决定为王受快乐
  有色无色生亦尔　　富贵无边不可量
  当离生老病死苦　　究竟菩提佛果圆
  若于塔庙安舍利　　及画佛像而供养
  得彼智光极大地　　善逝净妙佛富贵
  安住无边众生界　　同入平等无相性
  若于寂静山峰上　　安置佛塔及相轮
  形量可如指节许　　当生一切人天中
  端严大富色力安　　后作三十三天子
  若人以手开佛塔　　当获富贵及具足
  身体光洁心柔软　　多知性净无嗔恨
  若有智者行檀度　　施佛涂香及白檀
  恭俱摩等种种香　　当获广大可爱果
  若人信佛生欢喜　　持妙香花及音乐
  种种供养佛如来　　生天而感金宝池
  以彼池莲细香蕊　　遍身沾惹而澡浴
  曼那吉儞水清净　　入者尘垢自然除
  波涛流涌喷香冷　　宝岸红莲周匝开
  天等睹斯恒适意　　给施佛僧得此报
  如是功德不可量　　是故诸经结颂赞
  名衣及上服　　施佛及施僧
  后生天界时　　最上天衣香
  青黄种种色　　百千摩尼宝
  而用作庄严　　富贵而无量
  快乐亦无边　　获斯胜妙果
  若人生世间　　而得作国王
  具足诸色相　　上妙缯彩衣
  种种殊胜香　　随身恒受用
  皆因施佛衣　　成就如斯报
  若有生天界　　种种宝庄严
  身挂珠璎珞　　头戴宝玉冠
  耳镮及腕钏　　如是富快乐
  施佛庄严具　　获天胜妙果

  若作大国王　　身相广严饰
  璎珞摩尼珠　　玎珰声响亮
  亦是三宝田　　布施庄严具
  智者清净心　　施佛花鬘等
  天上及人间　　恒获于快乐
  复生后报中
  成就七觉花　　复生天山地
  而为帝释主　　与彼诸眷属
  游嬉于园林　　种种花供养
  而获如是果　　琉璃真珠宝
  金银青绿等　　庄严于伞盖
  团圆如满月　　若王若大臣
  而用覆头顶　　如佛说此因
  施盖获斯报　　解脱贪忧恼
  无病恒安乐　　复作世间王
  亦是施盖报　　若于佛塔庙
  布施于幢幡　　当作天轮王
  世上无能胜　　远离一切罪
  于诸众生中　　而为于上首
  恒得人供养　　若人于塔庙
  布施铃铎等　　不生罪恶地
  常得梵音声　　若人作伎乐
  琴瑟鼓吹等　　供养佛圣贤
  令闻心适悦　　当获天耳根
  庄严常清净　　复得金刚慧
  摧坏烦恼山　　若发信喜心
  以妙色香味　　种种美饮食
  供养诸佛等　　当生天界中
  眷属同宝座　　以摩尼宝器
  食天上妙馔　　饥馑刀兵劫
  永不生其中　　若人以饮食
  供养圣贤众　　当生人天中
  美食常丰足　　种种而最上
  智者恒敬爱　　若以美妙食
  施彼出家者　　常获富乐身
  辩才而长寿　　色力相具足
  施食报如是　　若以慈愍心
  施彼甘蜜水　　酥乳酪浆等
  令彼渴乏者　　饮之获安乐
  亦得如前报　　若以呵梨勒
  林藤诸药草　　供施于圣贤
  当生人天中　　无病而长寿
  恒获身安乐　　又彼施浆饮
  后得生天宫　　劫树花芳盛
  所求随意得　　宝器酒蜜等
  眷属同所饮　　又复于劫树
  能出庄严具　　妓唱天乐等
  悦乐天众心　　甘露复随身
  施饮获斯报　　若人设斋食
  当得生人天　　远离于贫寒
  长命足财宝　　若以象马等
  车乘及辇舆　　供施佛如来
  当得大神通　　若施鞋袜等
  恒生上族家　　常有象马车
  永离贫辛苦　　师长等有病
  若人勤承事　　当于一切处
  所求皆成就　　若施座具等
  当生于天上　　不受苦辛勤
  常坐上妙座　　敷设卧具施
  生天恒快乐　　身相广端直
  无畏人称赞　　修种杂园林
  严饰诸屋宅　　施人令游止
  身心生适悦　　当招欢喜园
  天人游行处　　与诸天女等
  嬉戏受快乐　　若于炎热时
  而作阴凉施　　当感优昙钵
  尼俱菩提树　　复后得生天
  恒受五欲乐　　井泉及池沼
  修饰令严净　　济彼渴乏人
  普皆令充足　　后报得生天
  或生于梵世　　种种受快乐
  复证寂灭果　　若以钵多罗
  布施于三宝　　当生一切处
  富贵而快乐　　于彼世间中
  尊高德最上　　复感诸众生
  恒时而供养　　智者若施刀
  当得生天上　　智慧极聪利
  永不值刀兵　　若人施其针
  智慧恒猛利　　能断诸烦恼
  证彼寂静道　　佛说若有人
  塑画于佛像　　生于天界中
  身体真金色　　清净光如日
  而诸天人众　　天男及天女
  恒时而归命　　若彼智慧人
  善能说法施　　天上人间生
  智德力具足　　恒受于快乐
  永离忧悲苦　　于其后有身
  得证寂灭道　　若彼诸有情
  书写妙法宝　　当得宿命智
  富贵恒安乐　　而灭一切罪
  经彼俱胝劫　　不堕于地狱
  及与鬼畜生　　若彼有智者
  扫洒结坛场　　旋绕散香花
  恒时而供养　　后生于人间
  及生于天上　　恒受于富贵
  复证寂灭故　　若以长明灯
  供养佛贤圣　　生彼人天中
  三眼常清净　　慧眼与天眼
  及于肉眼故　　又彼施灯者
  常得生天上　　口亦不喑哑
  耳眼无聋眇　　又彼施灯者
  非唯三眼净　　能于正觉法
  一切悉通达　　智者若施财
  供养有德众　　沙门婆罗门
  少施获多报　　广得顺道财
  长时而受用　　又彼行施者
  食施畜生类　　所获于福德
  而成于百倍　　若以财食等
  布施于罪人　　功利渐加殊
  获福成千倍　　若施持戒人
  福获千百倍　　供养无心人
  得益百俱胝　　若人施有学
  及彼无学者　　所获于福德
  比前而最上　　若施佛如来
  当生于天上　　大富永不断
  恒受于快乐　　乃至尽轮回
  而证寂灭法　　我集此一切
  佛说伽陀经　　略明于福报
  普令生信受　　假使千光日
  吉祥照大地　　夜分满月辉
  能开青莲花　　水天毗沙门
  帝释那罗延　　上首诸天等
  俱因行施得　　日行于虚空
  上下普皆照　　能活诸物命
  时至亦无常　　帝释四天王
  并及诸天众　　福寿穷尽时
  而入死冤口　　忧悲苦恼火
  不住被焚烧　　是故劝汝等
  观察无常身　　远离欲渴心
  勿耽人天乐　　须臾不久长
  皆归于散坏　　我发净信心
  舍离虚幻乐　　常诣于佛前
  合掌而亲近　　以自大菩提
  而作解脱主

贤圣集伽陀一百颂


新译大乘起信论

    No. 1667 [No. 1666]

    新译大乘起信论序

夫声同则应道合自邻。是以法雄命宗赖宣扬乎法子。素王垂范假传述乎素臣。盖德必不孤圣无虚应矣。起信论者。大乘之秘典也。佛灭度后五百余年。有马鸣菩萨。出兴于世。时称四日道王五天。转不退轮建无生忍。铭总持之智印。宅毕竟之真空。受波奢付嘱。蒙释尊远记。善说法要大启迷津。欲使群生殖不坏之信根。下难思之佛种。故造斯论。其为论也。示无价宝。诠最上乘。演恒沙之法门。惟在方寸。开诸佛之秘藏。本自一心。遣执而不丧其真。存修而亦忘其相。少文而摄多义。假名而会深旨。落落焉皎智月于净天。滔滔焉注禅河于性海。返迷归极莫不由之。此论东传总经二译。初本即西印度三藏法师波罗末陀此云真谛。以梁武帝承圣三年岁次癸酉九月十日。于衡州始兴郡建兴寺。共扬州沙门智恺所译。此本即于阗国三藏法师实叉难陀。赍梵文至此。又于西京慈恩塔内。获旧梵本。与义学沙门荆州弘景崇福法藏等。以大周圣历三年岁次癸亥十月壬午朔八日已丑。于授记寺。与花严经相次而译。沙门复礼笔受。开为两卷。然与旧翻时有出没。盖译者之意。又梵文非一也。夫理幽则信难道尊则魔盛。况当劫浊尤更倍增。故使偏见之流。执成唯识诽毁此论。真妄互熏。既形于言遂彰时听。方等甘露翻为毒药。故经云。唯佛与佛乃能究尽诸法实相。岂可辄以凡心贬量圣旨。夫真如者。物之性也。备难思之业用。蕴不空之胜德。内熏妄法令起厌求。故胜鬘经云。由有如来藏。令厌生死苦乐求涅槃。又经云。阐提之人。未来以佛性力故。善根还生。如彼净珠能清浊水。是胜义之常善。异太虚之无记。故经云。佛性常故非三世摄。虚空无故非三世摄。岂执事空以齐真理。夫论妄者。依理故迷真性。随流为妄漂动。故经云。随其流处有种种味。又楞伽经云。如来藏为无始虚伪恶习所熏。名为识藏。密严经云。佛说如来藏。以为阿赖耶。恶慧不能知。藏即赖耶识。虽在缠而体净。不变性而成迷。故经云。然药真味停留在山。犹如满月。又云。虽处五道受别异身。而此佛性常恒不变。若言真不熏妄妄不熏真。真妄两殊岂会中道。故梁摄论云。智慧极盲暗。谓真俗别执。今则真为妄体。妄假真成性相俱融一异双遣。故密严经云。如来清净藏。世间阿赖耶。如金与指环。展转无差别。圣教明白。何所致疑。良由滞相而乖真。寻末而弃本。言越规矩动成戏论。自贻圣责深可悲哉。余少小以来。专心斯论。玩味不已。讽诵忘疲。课拙传扬二十余遍。虽未究深旨。而粗识文意。以为大乘明镜莫过于此。幸希宗心之士。时览斯文。庶日进有功。聊为序引云尔

大乘起信论卷上

        马鸣菩萨造

        大周于阗三藏实叉难陀奉　制译

  归命尽十方　　普作大饶益
  智无限自在　　救护世间尊
  及彼体相海　　无我句义法
  无边德藏僧　　勤求正觉者
  为欲令众生　　除疑去邪执
  起信绍佛种　　故我造此论

论曰。为欲发起大乘净信。断诸众生疑暗邪执。令佛种性相续不断故造此论。有法能生大乘信根。是故应说。说有五分一作因。二立义。三解释。四修信。五利益此中作因有八一总相。为令众生离苦得乐。不为贪求利养等故。二为显如来根本实义。令诸众生生正解故。三为令善根成熟众生不退信心。于大乘法有堪任故。四为令善根微少众生。发起信心至不退故。五为令众生消除业障。调伏自心离三毒故。六为令众生修正止观。对治凡小过失心故。七为令众生于大乘法如理思惟。得生佛前究竟不退大乘信故。八为显信乐大乘利益。劝诸含识令归向故。此诸句义大乘经中虽已具有。然由所化根欲不同待悟缘别。是故造论。此复云何。谓如来在世所化利根。佛色心胜。一音开演无边义味故不须论。佛涅槃后。或有能以自力少见于经而解多义。复有能以自力广见诸经乃生正解。或有自无智力因他广论而得解义。亦有自无智力怖于广说乐闻略论摄广大义而正修行。我今为彼最后人故。略摄如来最胜甚深无边之义。而造此论

云何立义分。谓摩诃衍略有二种。有法及法。言有法者。谓一切众生心。是心则摄一切世间出世间法。依此显示摩诃衍义以此心真如相。即示大乘体故。此心生灭因缘相。能显示大乘体相用故。所言法者。略有三种。一体大。谓一切法真如在染在净性恒平等。无增无减无别异故。二者相大。谓如来藏本求具足无量无边性功德故。三者用大。能生一切世出世间善因果故一切诸佛本所乘故。一切菩萨皆乘于此入佛地故

云何解释分。此有三种。所谓显示实义故。对治邪执故。分别修行正道相故。此中显示实义者。依于一心有二种门。所谓心真如门。心生灭门。此二种门各摄一切法。以此展转不相离故。心真如者。即是一法界大总相法门体。以心本性不生不灭相。一切诸法皆由妄念而有差别。若离妄念则无境界差别之相。是故诸法从本已来性离语言。一切文字不能显说。离心攀缘无有诸相。究竟平等永无变异不可破坏。唯是一心说名真如。以真如故从本已来不可言说不可分别。一切言说唯假非实。但随妄念无所有故。言真如者。此亦无相。但是一切言说中极以言遣言。非其体性有少可遣有少可立问曰。若如是者。众生云何随顺悟入。答曰。若知虽说一切法而无能说所说。虽念一切法而无能念所念。尔时随顺妄念都尽名为悟入

复次真如者。依言说建立有二种别。一真实空。究竟远离不实之相显实体故。二真实不空。本性具足无边功德有自体故。复次真实空者。从本已来一切染法不相应故。离一切法差别相故。无有虚妄分别心故。应知真如非有相非无相。非有无相非非有无相非一相非异相。非一异相非非一异相。略说以一切众生妄分别心所不能触故立为空。据实道理。妄念非有。空性亦空。以所遮是无。能遮亦无故。言真实不空者。由妄念空无故。即显真心常恒不变净法圆满故名不空。亦无不空相。以非妄念心所行故。唯离念智之所证故

心生灭门者。谓依如来藏有生灭心转。不生灭与生灭和合非一非异。名阿赖耶识。此识有二种义。谓能摄一切法。能生一切法。复有二种义。一者觉义。二者不觉义。言觉义者。谓心第一义性离一切妄念相。离一切妄念相故。等虚空界无所不遍。法界一相即是一切如来平等法身。依此法身。说一切如来为本觉。以待始觉立为本觉。然始觉时即是本觉。无别觉起立。始觉者。谓依本觉有不觉。依不觉说有始觉。又以觉心源故名究竟觉。不觉心源故非究竟觉。如凡夫人。前念不觉起于烦恼。后念制伏令不更生。此虽名觉即是不觉。如二乘人及初业菩萨。觉有念无念体相别异。以舍粗分别故。名相似觉。如法身菩萨。觉念无念皆无有相。舍中品分别故。名随分觉。若超过菩萨地究竟道满足。一念相应觉心初起。始名为觉。远离觉相微细分别究竟永尽。心根本性常住现前。是为如来。名究竟觉。是故经说。若有众生。能观一切妄念无相。则为证得如来智慧。又言心初起者。但随俗说。求其初相终不可得。心尚无有何况有初。是故一切众生不名为觉。以无始来恒有无明妄念相续未曾离故。若妄念息。即知心相生住异灭皆悉无相。以于一心前后同时皆不相应无自性故。如是知已则知始觉不可得。以不异本觉故

复次本觉随染。分别生二种差别相。一净智相。二不思议用相。净智相者。谓依法熏习。如实修行功行满足。破和合识灭转识相。显现法身清净智故。一切心识相即是无明相。与本觉非一非异。非是可坏非不可坏。如海水与波非一非异。波因风动非水性动。若风止时波动即灭非水性灭。众生亦尔。自性清净心因无明风动起识波浪。如是三事皆无形相非一非异。然性净心是动识本。无明灭时动识随灭。智性不坏。不思议用相者。依于净智。能起一切胜妙境界常无断绝。谓如来身具足无量增上功德。随众生根。示现成就无量利益

复次觉相有四种大义。清净如虚空明镜。一真实空大义如虚空明镜。谓一切心境界相及觉相皆不可得故。二真实不空大义如虚空明镜。谓一切法圆满成就无能坏性。一切世间境界之相皆于中现。不出不入不灭不坏常住一心。一切染法所不能染。智体具足无边无漏功德为因。熏习一切众生心故。三真实不空离障大义如虚空明镜。谓烦恼所知二障永断和合识灭。本性清净常安住故。四真实不空示现大义如虚空明镜。谓依离障法随所应化。现如来等种种色声。令彼修行诸善根故

不觉义者。谓从无始来不如实知真法一故。不觉心起而有妄念。然彼妄念自无实相。不离本觉。犹如迷人依方故迷。迷无自相不离于方。众生亦尔。依于觉故而有不觉妄念迷生。然彼不觉自无实相。不离本觉。复待不觉以说真觉。不觉既无真觉亦遣

复次依于觉故而有不觉生三种相不相舍离。一无明业相。以依不觉心动为业。觉则不动。动则有苦。果不离因故。二能见相。以依心动能见境界。不动则无见。三境界相。以依能见妄境相现。离见则无境。以有虚妄境界缘故。复生六种相。一智相。谓缘境界生爱非爱心。二相续相。谓依于智苦乐觉念相应不断。三执着相。谓依苦乐觉念相续而生执着。四执名等相。谓依执着分别名等诸安立相。五起业相。谓依执名等起于种种诸差别业。六业系苦相。谓依业受苦不得自在。是故当知。一切染法悉无有相。皆因无明而生起故。复次觉与不觉有二种相。一同相二异相。言同相者。如种种瓦器皆同土相。如是无漏无明种种幻用。皆同真相。是故佛说。一切众生无始已来常入涅槃。菩提非可修相。非可生相。毕竟无得。无有色相而可得见。见色相者当知皆是随染幻用。非是智色不空之相。以智相不可得故。广如彼说。言异相者。如种种瓦器各各不同。此亦如是。无漏无明种种幻用相差别故。复次生灭因缘者。谓诸众生依心意识转。此义云何。以依阿赖耶识有无明不觉起。能见能现能取境界分别相续。说名为意。此意复。有五种异名。一名业识。谓无明力不觉心动。二名转识。谓依动心能见境相。三名现识。谓现一切诸境界相。犹如明镜现众色像。现识亦尔。如其五境对至即现。无有前后不由功力。四名智识。谓分别染净诸差别法。五名相续识。谓恒作意相应不断。任持过去善恶等业令无失坏。成熟现未苦乐等报使无违越。已曾经事忽然忆念。未曾经事妄生分别。是故三界一切皆以心为自性。离心则无六尘境界何以故。一切诸法以心为主从妄念起。凡所分别皆分别自心。心不见心无相可得。是故当知。一切世间境界之相。皆依众生无明妄念而得建立。如镜中像无体可得。唯从虚妄分别心转心生则种种法生。心灭则种种法灭故。言意识者。谓一切凡夫依相续识执我我所。种种妄取六种境界。亦名分离识。亦名分别事识。以依见爱等熏而增长故。无始无明熏所起识。非诸凡夫二乘智慧之所能知。解行地菩萨始学观察。法身菩萨能少分知。至究竟地犹未知尽。唯有如来能总明了。此义云何。以其心性本来清净。无明力故染心相现虽有染心而常明洁无有改变。复以本性无分别故。虽复遍生一切境界而无变易。以不觉一法界故不相应。无明分别起生诸染心。如是之义甚深难测。唯佛能知非余所了。此所生染心有六种别。一执相应染。声闻缘觉及信相应地诸菩萨能远离。二不断相应染。信地菩萨勤修力能少分离。至净心地永尽无余。三分别智相应染。从具戒地乃至具慧地能少分离。至无相行地方得永尽。四现色不相应染。此色自在地之所除灭。五见心不相应染。此心自在地之所除灭。六根本业不相应染。此从菩萨究竟地入如来地之所除灭。不觉一法界者。始从信地观察起行。至净心地能少分离。入如来地方得永尽。相应义者。心分别异。染净分别异。知相缘相同。不相应义者即心不觉常无别异。知相缘相不同。染心者。是烦恼障。能障真如根本智故无明者。是所知障。能障世间业自在智故。此义云何。以依染心。执着无量能取所取虚妄境界。违一切法平等之性。一切法性平等寂灭无有生相。无明不觉妄与觉违。是故于一切世间种种境界差别业用。皆悉不能如实而知

复次分别心生灭相者。有二种别。一粗谓相应心。二细谓不相应心。粗中之粗凡夫智境。粗中之细及细中之粗菩萨智境。此二种相。皆由无明熏习力起。然依因依缘。因是不觉缘是妄境。因灭则缘灭。缘灭故相应心灭。因灭故不相应心灭。问若心灭者云何相续。若相续者云何言灭答实然。今言灭者。但心相灭非心体灭。如水因风而有动相。以风灭故动相即灭。非水体灭。若水灭者动相应断。以无所依无能依故。以水体不灭动相相续。众生亦尔。以无明力令其心动。无明灭故动相即灭。非心体灭。若心灭者则众生断。以无所依无能依故。以心体不灭心动相续

复次以四种法熏习义故。染净法起无有断绝。一净法。谓真如二染因。谓无明。三妄心。谓业识。四妄境谓六尘。熏习义者。如世衣服非臭非香。随以物熏则有彼气。真如净法性非是染。无明熏故则有染相。无明染法实无净业。真如熏故说有净用。云何熏习染法不断。所谓依真如故而起无明为诸染因。然此无明即熏真如。既熏习已生妄念心。此妄念心复熏无明。以熏习故不觉真法。以不觉故妄境相现。以妄念心熏习力故。生于种种差别执着。造种种业。受身心等众苦果报。妄境熏义有二种别。一增长分别熏。二增长执取熏。妄心熏义亦二种别。一增长根本业识熏。令阿罗汉辟支佛一切菩萨受生灭苦。二增长分别事识熏。令诸凡夫受业系苦。无明熏义亦二种别。一根本熏。成就业识义。二见爱熏。成就分别事识义。云何熏习净法不断。谓以真如熏于无明。以熏习因缘力故。令妄念心厌生死苦求涅槃乐。以此妄心厌求因缘复熏真如。以熏习故则自信己身有真如法本性清净。知一切境界唯心妄动毕竟无有。以能如是如实知故。修远离法。起于种种诸随顺行。无所分别无所取着。经于无量阿僧祇劫。惯习力故无明则灭。无明灭故心相不起。心不起故境界相灭。如是一切染因染缘及以染果。心相都灭名得涅槃。成就种种自在业用。妄心熏义有二种别。一分别事识熏。令一切凡夫二乘厌生死苦。随已堪能趣无上道。二意熏。令诸菩萨发心勇猛。速疾趣入无住涅槃。真如熏义亦二种别。一体熏。二用熏。体熏者。所谓真如从无始来具足一切无量无漏。亦具难思胜境界用。常无间断熏众生心。以此力故令诸众生厌生死苦求涅槃乐自信己身有真实法发心修行。问若一切众生同有真如等皆熏习。云何而有信不信者。从初发意乃至涅槃。前后不同无量差别。如是一切悉应齐等。答虽一切众生等有真如。然无始来无明厚薄无量差别过恒沙数。我见爱等缠缚烦恼亦复如是。唯如来智之所能知。故令信等前后差别。又诸佛法有因有缘。因缘具足事乃成办。如木中火性。是火正因若无人知或有虽知而不施功。欲令出火焚烧木者无有是处。众生亦尔。虽有真如体熏因力。若不遇佛诸菩萨等善知识缘。或虽不修胜行不生智慧不断烦恼。能得涅槃无有是处。又复虽有善知识缘。傥内无真如熏习因力。必亦不能厌生死苦求涅槃乐。要因缘具足乃能如是。云何具足。谓自相续中有熏习力。诸佛菩萨慈悲摄护。乃能厌生死苦信有涅槃。种诸善根修习成熟。以是复值诸佛菩萨示教利喜。令修胜行乃至成佛入于涅槃。用熏者。即是众生外缘之力有无量义。略说二种。一差别缘。二平等缘。差别缘者。谓诸众生从初发心乃至成佛。蒙佛菩萨等诸善知识。随所应化而为现身。或为父母或为妻子。或为眷属或为仆使。或为知友或作怨家。或复示现天王等形。或以四摄或以六度。乃至一切菩提行缘。以大悲柔软心广大福智藏。熏所应化一切众生。令其见闻及以忆念如来等形增长善根。此缘有二。一近缘。速得菩提故。二远缘。久远方得故。此二差别复各二种。一增行缘。二入道缘

平等缘者。谓一切诸佛及诸菩萨。以平等智慧平等志愿。普欲拔济一切众生。任运相续常无断绝。以此智愿熏众生故。令其忆念诸佛菩萨。或见或闻而作利益。入净三昧随所断障得无碍眼。于念念中一切世界平等现见无量诸佛及诸菩萨。此体用熏复有二别。一未相应。二已相应。未相应者。谓凡夫二乘初行菩萨。以意意识熏。唯依信力修行。未得无分别心修行。未与真如体相应故。未得自在业修行。未与真如用相应故。已相应者。谓法身菩萨得无分别心。与一切如来自体相应故。得自在业与一切如来智用相应故。唯依法力任运修行。熏习真如灭无明故。复次染熏习。从无始来不断成佛乃断。净熏习。尽于未来毕竟无断。以真如法熏习故。妄心则灭法身显现。用熏习起故无有断

复次真如自体相者。一切凡夫声闻缘觉菩萨诸佛无有增减。非前际生非后际灭常恒究竟。从无始来本性具足一切功德。谓大智慧光明义。遍照法界义。如实了知义。本性清净心义。常乐我净义。寂静不变自在义。如是等过恒沙数非同非异不思议佛法无有断绝。依此义故名如来藏。亦名法身

问上说真如离一切相。云何今说具足一切诸功德相

答虽实具有一切功德。然无差别相。彼一切法皆同一味一真。离分别相无二性故。以依业识等生灭相。而立彼一切差别之相。此云何立。以一切法本来唯心实无分别。以不觉故分别心起见有境界。名为无明。心性本净无明不起。即于真如立大智慧光明义。若心性见境则有不见之相。心性无见则无不见。即于真如立遍照法界义。若心有动则非真了知。非本性清净。非常乐我净。非寂静。是变异不自在。由是具起过于恒沙虚妄杂染。以心性无动故即立真实了知义。乃至过于恒沙清净功德相义若心有起见有余境可分别求。则于内法有所不足。以无边功德即一心自性。不见有余法而可更求。是故满足过于恒沙非异非一不可思议诸佛之法无有断绝。故说真如名如来藏。亦复名为如来法身

复次真如用者。谓一切诸佛在因地时发大慈悲。修行诸度四摄等行。观物同已普皆救脱。尽未来际不限劫数。如实了知自他平等。而亦不取众生之相。以如是大方便智。灭无始无明证本法身。任运起于不思议业。种种自在差别作用。周遍法界与真如等。而亦无有用相可得。何以故。一切如来唯是法身。第一义谛无有世谛境界作用。但随众生见闻等故。而有种种作用不同

此用有二。一依分别事识。谓凡夫二乘心所见者是名化身。此人不知转识影现。见从外来取色分限。然佛化身无有限量。二依业识。谓诸菩萨从初发心乃至菩萨究竟地心所见者名受用身。身有无量色。色有无量相。相有无量好。所住依果亦具无量功德庄严。随所应见无量无边无际无断。非于心外如是而见。此诸功德皆因波罗蜜等无漏行熏及不思议熏之所成就。具无边喜乐功德相故亦名报身。又凡夫等所见是其粗用。随六趣异种种差别。无有无边功德乐相名为化身。初行菩萨见中品用。以深信真如故得少分见。知如来身无去无来无有断绝。唯心影现不离真如。然此菩萨犹未能离微细分别。以未入法身位故。净心菩萨见微细用。如是转胜乃至菩萨究竟地中见之方尽。此微细用是受用身。以有业识见受用身。若离业识则无可见。一切如来皆是法身。无有彼此差别色相。互相见故。问若佛法身无有种种差别色相。云何能现种种诸色

答以法身是色实体故。能现种种色。谓从本已来色心无二。以色本性即心自性。说名智身。以心本性即色自性。说名法身。依于法身。一切如来所现色身。遍一切处无有间断。十方菩萨随所堪任随所愿乐。见无量受用身无量庄严土各各差别。不相障碍无有断绝。此所现色身一切众生心意识不能思量。以是真如自在甚深用故

复次为令众生从心生灭门入真如门故。令观色等相皆不成就。云何不成就。谓分析粗色渐至微尘。复以方分析此微尘。是故若粗若细一切诸色。唯是妄心分别影像实无所有。推求余蕴渐至刹那。求此刹那相。别非一无为之法。亦复如是。离于法界终不可得。如是十方一切诸法应知悉然。犹如迷人谓东为西方实不转。众生亦尔。无明迷故谓心为动而实不动。若知动心即不生灭。即得入于真如之门

大乘起信论卷上大乘起信论卷下

        马鸣菩萨造

        大周于阗三藏实叉难陀奉　制译

对治邪执者。一切邪执莫不皆依我见而起。若离我见则无邪执。我见有二种。一人我见。二法我见。人我见者。依诸凡夫说有五种。一者如经中说。如来法身究竟寂灭犹如虚空。凡愚闻之不解其义。则执如来性同于虚空常恒遍有。为除彼执。明虚空相唯是分别实不可得。有见有对待于诸色。以心分别说名虚空。色既唯是妄心分别。当知虚空亦无有体。一切境相唯是妄心之所分别。若离妄心即境界相灭。唯真如心无所不遍。此是如来自性如虚空义。非谓如空是常是有。二者如经中说。一切世法皆毕竟空。乃至涅槃真如法亦毕竟空。本性如是离一切相。凡愚闻之不解其义。即执涅槃真如法唯空无物。为除彼执明真如法身自体不空。具足无量性功德故

三者如经中说。如来藏具足一切诸性功德不增不减。凡愚闻已不解其义。则执如来藏有色心法自相差别。为除此执。明以真如本无染法差别。立有无边功德相。非是染相。四者如经中说。一切世间诸杂染法。皆依如来藏起。一切法不异真如。凡愚闻之不解其义。则谓如来藏具有一切世间染法。为除此执。明如来藏从本具有过恒沙数清净功德不异真如。过恒沙数烦恼染法。唯是妄有本无自性。从无始来未曾暂与如来藏相应。若如来藏染法相应。而令证会息妄染者。无有是处

五者如经中说。依如来藏有生死得涅槃。凡愚闻之不知其义。则谓依如来藏生死有始。以见始故复谓涅槃有其终尽。为除此执。明如来藏无有初际。无明依之生死无始。若言三界外更有众生始起者。是外道经中说。非是佛教。以如来藏无有后际。证此永断生死种子。得于涅槃亦无后际。依人我见四种见生。是故于此安立彼四

法我见者。以二乘钝根。世尊。但为说人无我。彼人便于五蕴生灭毕竟执着。怖畏生死妄取涅槃。为除此执。明五蕴法本性不生。不生故亦无有灭。不灭故本来涅槃。若究竟离分别执着。则知一切染法净法皆相待立。是故当知。一切诸法从本已来。非色非心非智非识非无非有。毕竟皆是不可说相。而有言说示教之者。皆是如来善巧方便。假以言语引导众生。令舍文字入于真实。若随言执义增妄分别。不生实智不得涅槃

分别修行正道相者。谓一切如来得道正因。一切菩萨发心修习。令现前故。略说发心有三种相。一信成就发心。二解行发心。三证发心。信成就发心者。依何位修何行。得信成就堪能发心。当知是人依不定聚。以法熏习善根力故。深信业果行十善道。厌生死苦求无上觉。值遇诸佛及诸菩萨。承事供养修行诸行。经十千劫信乃成就。从是已后。或以诸佛菩萨教力。或以大悲。或因正法将欲坏灭。以护法故而能发心。既发心已入正定聚毕竟不退。住佛种性胜因相应。或有众生。久远已来善根微少。烦恼深厚覆其心故。虽值诸佛及诸菩萨承事供养。唯种人天受生种子。或种二乘菩提种子。或有虽求大菩提道。然根不定或进或退。或有值佛及诸菩萨供养承事修行诸行。未得满足十千大劫。中间遇缘而发于心。遇何等缘。所谓或见佛形相。或供养众僧。或二乘所教。或见他发心。此等发心皆悉未定。若遇恶缘或时退堕二乘地故

复次信成就发心。略说有三。一发正直心。如理正念真如法故。二发深重心。乐集一切诸善行故。三发大悲心。愿拔一切众生苦故。问一切众生一切诸法皆同一法界。无有二相。据理但应正念真如。何假复修一切善行救一切众生

答不然。如摩尼宝本性明洁在矿秽中。假使有人勤加忆念。而不作方便不施功力。欲求清净终不可得。真如之法亦复如是。体虽明洁具足功德。而被无边客尘所染。假使有人勤加忆念。而不作方便不修诸行。欲求清净终无得理。是故要当集一切善行救一切众生。离彼无边客尘垢染显现真法

彼方便行略有四种。一行根本方便。谓观一切法本性无生。离于妄见不住生死。又观一切法因缘和合业果不失。起于大悲修诸善行。摄化众生不住涅槃。以真如离于生死涅槃相故。此行随顺以为根本。是名行根本方便。二能止息方便所谓惭愧及以悔过。此能止息一切恶法令不增长。以真如离一切过失相故。随顺真如止息诸恶。是名能止息方便。三生长善根方便。谓于三宝所起爱敬心。尊重供养顶礼称赞。随喜劝请正信增长。乃至志求无上菩提。为佛法僧威力所护。业障清净善根不退。以真如离一切障具一切功德故。随顺真如修行善业。是名生长善根方便。四大愿平等方便。谓发誓愿尽未来际。平等救拔一切众生。令其安住无余涅槃。以知一切法本性无二故。彼此平等故。究竟寂灭故。随顺真如此三种相发大誓愿。是名大愿平等方便

菩萨如是发心之时。则得少分见佛法身。能随愿力现八种事。谓从兜率天宫来下入胎住胎出。胎出家成佛转法轮般涅槃。然犹未得名为法身。以其过去无量世来有漏之业未除断故。或由恶业受于微苦。愿力所持非久被系。有经中说。信成就发心菩萨。或有退堕恶趣中者。此为初学心多懈怠不入正位。以此语之令增勇猛非如实说

又此菩萨一发心后。自利利他修诸苦行。心无怯弱尚不畏堕二乘之地。况于恶道。若闻无量阿僧祇劫勤修种种难行苦行方始得佛。不惊不怖。何况有起二乘之心及堕恶趣。以决定信一切诸法从本已来性涅槃故。解行发心者当知转胜。初无数劫将欲满故。于真如中得深解故。修一切行皆无著故。此菩萨知法性离悭贪相是清净施度。随顺修行檀那波罗蜜。知法性离五欲境无破戒相是清净戒度。随顺修行尸罗波罗蜜。知法性无有苦恼离嗔害相是清净忍度。随顺修行羼提波罗蜜。知法性离身心相无有懈怠是清净进度。随顺修行毗梨耶波罗蜜。知法性无动无乱是清净禅度。随顺修行禅那波罗蜜。知法性离诸痴闇是清净慧度。随顺修行般若波罗蜜

证发心者。从净心地乃至菩萨究竟地证何境界。所谓真如。以依转识说为境界。而实证中无境界相。此菩萨以无分别智。证离言说真如法身故。能于一念遍往十方一切世界。供养诸佛请转法轮。唯为众生而作利益不求听受美妙音词。或为怯弱众生故示大精进。超无量劫速成正觉。或为懈怠众生故。经于无量阿僧祇劫。久修苦行方始成佛。如是示现无数方便。皆为饶益一切众生。而实菩萨种性诸根发心作证。皆悉同等无超过法。决定皆经三无数劫成正觉故。但随众生世界不同。所见所闻根欲性异。示所修行种种差别。此证发心中有三种心。一真心。无有分别故。二方便心。任运利他故。三业识心。微细起灭故

又此菩萨福德智慧二种庄严悉圆满已。于色究竟得一切世间最尊胜身。以一念相应慧。顿拔无明根。具一切种智。任运而有不思议业。于十方无量世界普化众生

问虚空无边故世界无边。世界无边故众生无边。众生无边故心行差别亦复无边。如是境界无有齐限难知难解。若无明断永无心相。云何能了一切种。成一切种智

答一切妄境从本已来理实唯一心为性。一切众生执着妄境。不能得知一切诸法第一义性。诸佛如来无有执着。则能现见诸法实性。而有大智显照一切染净差别。以无量无边善巧方便。随其所应利乐众生。是故妄念心灭。了一切种成一切种智

问若诸佛有无边方便。能于十方任运利益诸众生者。何故众生不常见佛。或睹神变。或闻说法

答如来实有如是方便。但要待众生其心清净。乃为现身。如镜有垢色像不现。垢除则现。众生亦尔。心未离垢。法身不现。离垢则现。云何修习信分。此依未入正定众生说。何者为信心。云何而修习。信有四种。一信根本。谓乐念真如法故。二信佛具足无边功德。谓常乐顶礼恭敬供养。听闻正法如法修行。回向一切智故。三信法有大利益。谓常乐修行诸波罗蜜故。四信正行僧。谓常供养诸菩萨众正修自利利他行故。修五门行。能成此信。所谓施门。戒门。忍门。精进门。止观门。云何修施门。谓若见众生来从乞求。以己资财随力施与。舍自悭著令其欢喜。若见众生危难逼迫。方便救济令无怖畏。若有众生而来求法。以己所解随宜为说。修行如是三种施时。不为名闻不求利养。亦不贪着世间果报。但念自他利益安乐。回向阿耨多罗三藐三菩提

云何修戒门。所谓在家菩萨当离杀生偷盗邪淫妄言两舌恶口绮语悭贪嗔嫉谄诳邪见。若出家者为欲折伏诸烦恼故。应离愦闹常依寂静。修习止足头陀等行。乃至小罪心生大怖惭愧悔责。护持如来所制禁戒。不令见者有所讥嫌。能使众生舍恶修善云何修忍门。所谓见恶不嫌遭苦不动。常乐观察甚深句义

云何修精进门。所谓修诸善行心不懈退。当念过去无数劫来。为求世间贪欲境界。虚受一切身心大苦。毕竟无有少分滋味。为令未来远离此苦。应勤精进不生懈怠。大悲利益一切众生。其初学菩萨虽修行信心。以先世来多有重罪恶业障故。或为魔邪所恼。或为世务所缠。或为种种病缘之所逼迫。如是等事为难非一。令其行人废修善品。是故宜应勇猛精进。昼夜六时礼拜诸佛。供养赞叹忏悔劝请。随喜回向无上菩提。发大誓愿无有休息。令恶障销灭善根增长。云何修止观门。谓息灭一切戏论境界是止义。明见因果生灭之相是观义。初各别修渐次增长。至于成就任运双行。其修止者。住寂静处结加趺坐端身正意。不依气息。不依形色。不依虚空。不依地水火风。乃至不依见闻觉知。一切分别想念皆除。亦遣除想以一切法不生不灭皆无相故。前心依境次舍于境。后念依心复舍于心。以心驰外境摄住内心。后复起心不取心相。以离真如不可得故。行住坐卧于一切时如是修行恒不断绝。渐次得入真如三昧。究竟折伏一切烦恼。信心增长速成不退。若心怀疑惑诽谤不信。业障所缠我慢懈怠。如是等人所不能入

复次依此三昧证法界相。知一切如来法身与一切众生身平等无二皆是一相。是故说名一相三昧。若修习此三昧。能生无量三昧。以真如是一切三昧根本处故。或有众生善根微少。为诸魔外道鬼神惑乱。或现恶形以怖其心。或示美色以迷其意。或现天形或菩萨形。乃至佛形相好庄严。或说总持或说诸度。或复演说诸解脱门。无怨无亲无因无果。一切诸法毕竟空寂本性涅槃。或复令知过去未来及他心事。辩才演说无滞无断。使其贪著名誉利养。或数嗔数喜。或多悲多爱。或恒乐昏寐。或久不睡眠。或身婴疹疾。或性不勤策。或卒起精进即便休废。或情多疑惑不生信受。或舍本胜行更修杂业。爱着世事溺情从好。或令证得外道诸定。一日二日乃至七日。住于定中得好饮食。身心适悦不饥不渴。或复劝令受女等色。或令其饮食乍少乍多。或使其形容或好或丑。若为诸见烦恼所乱。即便退失往昔善根。是故宜应审谛观察。当作是念。此皆以我善根微薄业障厚重。为魔鬼等之所迷惑。如是知已。念彼一切皆唯是心。如是思惟刹那即灭。远离诸相入真三昧。心相既离真相亦尽。从于定起诸见烦恼皆不现行。以三昧力坏其种故。殊胜善品随顺相续。一切障难悉皆远离。起大精进恒无断绝。若不修行此三昧者。无有得入如来种性。以余三昧皆是有相。与外道共。不得值遇佛菩萨故。是故菩萨于此三昧当勤修习。令成就究竟。修此三昧。现身即得十种利益。一者常为十方诸佛菩萨之所护念。二者不为一切诸魔恶鬼之所恼乱。三者不为一切邪道所惑。四者令诽谤深法重罪业障皆悉微薄。五者灭一切疑诸恶觉观。六者于如来境界信得增长。七者远离忧悔于生死中勇猛不怯。八者远离憍慢柔和忍辱常为一切世间所敬。九者设不住定于一切时一切境中烦恼种薄终不现起。十者若住于定不为一切音声等缘之所动乱

复次若唯修止。心则沉没或生懈怠。不乐众善远离大悲。是故宜应兼修于观。云何修耶。谓当观世间一切诸法生灭不停。以无常故苦。苦故无我。应观过去法如梦。现在法如电。未来法如云。忽尔而起。应观有身悉皆不净。诸虫秽污烦恼和杂。观诸凡愚所见诸法。于无物中妄计为有。观察一切从缘生法。皆如幻等毕竟无实。观第一义谛非心所行。不可譬喻不可言说。观一切众生。从无始来皆因无明熏习力故。受于无量身心大苦。现在未来亦复如是无边无限难出难度。常在其中不能觉察。甚为可愍。如是观已生决定智起广大悲。发大勇猛立大誓愿。愿令我心离诸颠倒断诸分别。亲近一切诸佛菩萨。顶礼供养恭敬赞叹。听闻正法如说修行。尽未来际无有休息。以无量方便拔济一切苦海众生。令住涅槃第一义乐。作是愿已于一切时。随己堪能修行自利利他之行。行住坐卧常勤观察应作不应作。是名修观

复次若唯修观则心不止息。多生疑惑不随顺第一义谛。不出生无分别智。是故止观应并修行。谓虽念一切法皆无自性不生不灭本来寂灭自性涅槃。而亦即见因缘和合善恶业报不失不坏。虽念因缘善恶业报。而亦即见一切诸法无生无性乃至涅槃。然修行止者。对治凡夫乐着生死。亦治二乘执着生死而生怖畏。修行观者。对治凡夫不修善根。亦治二乘不起大悲狭劣心过。是故止观互相助成不相舍离。若止观不具。必不能得无上菩提

复次初学菩萨住此娑婆世界。或值寒热风雨不时饥馑等苦。或见不善可畏众生。三毒所缠邪见颠倒。弃背善道习行恶法。菩萨在中心生怯弱。恐不可值遇诸佛菩萨。恐不能成就清净信心。生疑欲退者应作是念。十方所有诸佛菩萨。皆得大神通无有障碍。能以种种善巧方便。救拔一切险厄众生。作是念已发大誓愿。一心专念佛及菩萨。以生如是决定心故。于此命终必得往生余佛刹中。见佛菩萨信心成就永离恶趣。如经中说。若善男子善女人。专念西方极乐世界阿弥陀佛。以诸善根回向愿生决定得生。常见彼佛信心增长永不退转。于彼闻法观佛法身。渐次修行得入正位

云何利益分。如是大乘秘密句义今已略说。若有众生。欲于如来甚深境界广大法中生净信觉解心。入大乘道无有障碍。于此略论当勤听受思惟修习。当知是人决定速成一切种智。若闻此法不生惊怖。当知此人定绍佛种速得授记。假使有人。化三千大千世界众生。令住十善道。不如于须臾顷正思此法过前功德无量无边。若一日一夜如说修行。所生功德无量无边不可称说。假令十方一切诸佛。各于无量阿僧祇劫。说不能尽。以真如功德无边际故。修行功德亦复无边。若于此法生诽谤者。获无量罪。于阿僧祇劫受大苦恼。是故于此应决定信。勿生诽谤自害害他断三宝种。一切诸佛依此修行成无上智。一切菩萨由此证得如来法身。过去菩萨依此得成大乘净信。现在今成未来当成。是故欲成自利利他殊胜行者。当于此论勤加修学

  我今已解释　　甚深广大义
  功德施群生　　令见真如法

大乘起信论卷下


一百五十赞佛颂

    No. 1680

一百五十赞佛颂

        尊者摩咥里制吒造

        大唐沙门义净于那烂陀寺译

  世尊最殊胜　　善断诸惑种
  无量胜功德　　总集如来身
  唯佛可归依　　可赞可承事
  如理思惟者　　宜应住此教
  诸恶烦恼习　　护世者已除
  福智二俱圆　　唯尊不退没
  纵生恶见者　　于尊起嫌恨
  伺求身语业　　无能得瑕隙
  记我得人身　　闻法生欢喜
  譬如巨海内　　盲龟遇楂穴
  忘念恒随逐　　惑业堕深坑
  故我以言词　　叹佛实功德
  牟尼无量境　　圣德无边际
  为求自利故　　我今赞少分
  敬礼无师智　　希有众事性
  福慧及威光　　谁能知数量
  如来德无限　　无等无能说
  我今求福利　　假赞以名言
  我智力微浅　　佛德无崖际
  唯愿大慈悲　　拯我无归处
  怨亲悉平等　　无缘起大悲
  普于众生界　　恒作真善友
  内财尚能舍　　何况于外财
  尊无吝惜心　　求者满其愿
  以身护彼身　　以命赎他命
  全躯救一鸽　　欢喜无悭吝
  尊不畏恶道　　亦不贪善趣
  但为心澄洁　　尸罗由此成
  常离诸邪曲　　恒亲质直者
  诸业本性空　　唯居第一义
  众苦逼其身　　尊能善安虑
  正智断诸惑　　有过悉兴悲
  殉命济他难　　生无量欢喜
  如死忽重苏　　此喜过于彼
  怨对害其身　　一切时恒恼
  不观其过恶　　常起大悲心
  正遍菩提种　　心恒所珍玩
  大雄难胜智　　无有能及者
  无等菩提果　　苦行是其因
  由此不顾身　　勤修诸胜品
  豪贵与贫贱　　等引以大悲
  于诸差别中　　而无高下想
  胜乐等持果　　心无有贪着
  普济诸群生　　大悲无间断
  尊虽遭极苦　　于乐不悕求
  妙智诸功德　　殊胜无能共
  染净诸杂法　　简伪取其真
  如清净鹅王　　饮乳弃其水
  于无量亿劫　　勇猛趣菩提
  于彼生生中　　丧身求妙法
  三僧祇数量　　精勤无懈惓
  持此为胜伴　　以证妙菩提
  尊无嫉姤心　　于劣除轻想
  平等无乖诤　　胜行悉圆成
  尊唯重因行　　非求果位圆
  遍修诸胜业　　众德自成满
  勤修出离法　　超升众行顶
  坐卧经行处　　无非胜福田
  拔除众过染　　增长清净德
  斯由积行成　　唯尊最无上
  众福皆圆满　　诸过悉蠲除
  如来净法身　　尘习皆已断
  资粮集更集　　功归调御身
  欲求于譬类　　无能与佛等
  遍观诸世间　　灾横多障恼
  纵有少分善　　易得为比对
  远离诸过患　　湛然安不动
  最胜诸善根　　无能为譬喻
  如来智深远　　无底无边际
  世事喻佛身　　牛迹方大海
  深仁荷一切　　世间无有比
  大地持重担　　喻此实为轻
  愚痴闇已除　　牟尼光普照
  世智非能譬　　如萤对日光
  如来三业净　　秋月皎空池
  世洁喻佛身　　俱成尘浊性
  如上诸所引　　世中殊胜事
  佛法迥超过　　俗事可哀愍
  圣法珍宝聚　　佛最居其顶
  无上无比中　　唯佛与佛等
  如来圣智海　　随乐叹少分
  鄙词赞胜德　　对此实多惭
  时俗睹降魔　　一切咸归伏
  观彼同真性　　我谓等轻毛
  假令大战阵　　智勇能摧伏
  圣德超世间　　降彼非为喻
  邻次降魔后　　于夜后分中
  断诸烦恼习　　胜德皆圆满
  圣智除众闇　　超过千日光
  摧伏诸邪宗　　希有无能比
  三善根圆满　　永灭贪恚痴
  种习悉已除　　清净无能喻
  妙法尊恒赞　　不正法恒非
  于斯邪正处　　心无有憎爱
  于圣弟子众　　及外道师徒
  于彼违顺中　　佛心初无二
  于德情无著　　德者亦非贪
  善哉极无垢　　圣智恒圆洁
  诸根常湛寂　　永离迷妄心
  于诸境界中　　现量由亲睹
  念慧穷真际　　非凡愚所测
  善安立语言　　证彼亡言处
  寂静无碍光　　皎洁逾辉映
  妙色世希有　　熟不怀敬心
  若有暂初观　　或复恒瞻睹
  妙相曾无二　　前后悉同欢
  最胜威德身　　观者心无厌
  纵经无量劫　　欣仰似初观
  所依之德体　　能依之德心
  性相二俱融　　能所初无异
  如斯善逝德　　总集如来躬
  离佛相好身　　余非所安处
  我因先世福　　幸遇调御师
  仰赞功德山　　远酬尊所记
  一切有情类　　皆因烦恼持
  唯佛能善除　　由悲久住世
  谁当先敬礼　　唯佛大悲尊
  圣德超世间　　悲愿处生死
  尊居寂静乐　　处浊为群生
  永劫久精勤　　慈心为一切
  从真还利俗　　由悲所引生
  如咒出潜龙　　兴云注甘雨
  恒居胜定位　　等观以怨亲
  凶崄倡聒人　　投身归圣德
  神通师子吼　　宣言三界尊
  久已厌名闻　　由悲自称赞
  常修利他行　　曾无自利心
  慈念遍众生　　于己偏无爱
  悲愿无边际　　逐器化群生
  随处皆饶益　　犹如散祭食
  深心念一切　　恒不舍须臾
  利彼反遭辱　　由咎非佛作
  慈音演妙义　　诚谛非虚说
  广略任机缘　　半满随时转
  若闻尊演说　　孰不叹希奇
  纵令怀恶心　　有智咸归信
  义词恒善巧　　或复出粗言
  利益悉不虚　　故并成真妙
  柔软及粗犷　　随事化众生
  圣智无碍心　　一味皆平等
  胜哉无垢业　　善巧喻良工
  成此微妙身　　演斯珍宝句
  睹者皆欢喜　　闻说并心开
  美颜宣妙词　　如月流甘露
  慈云洒法雨　　能清染欲尘
  如彼金翅王　　吞灭诸龙毒
  能殄无明闇　　喻如千日光
  摧碎我慢山　　譬犹天帝杵
  现证非虚谬　　静虑除乱心
  如实善修行　　三事皆圆满
  创闻佛所说　　心喜已开明
  从此善思惟　　消除诸垢染
  遭苦能安慰　　放逸令生怖
  着乐劝厌心　　随事皆开诱
  上智证法喜　　中根胜解生
  浅劣发信心　　尊言遍饶益
  善拔诸邪见　　引之趣涅槃
  罪垢能洗除　　由尊降法雨
  一切智无碍　　恒住正念中
  如来所记莂　　一向非虚谬
  无非处非时　　亦无非器转
  尊言不虚发　　闻者悉勤修
  一路胜方便　　无杂可修学
  初中后尽善　　余教所皆无
  如斯一向善　　狂愚起谤心
  此教若生嫌　　无怨与斯等
  历劫为群迷　　备经众苦毒
  此教纵非善　　念佛尚应修
  况能大饶益　　复宣深妙义
  纵使头被焚　　先应救此教
  自在菩提乐　　圣德恒淡然
  皆由此教生　　证彼亡言处
  世雄真实教　　邪宗闻悉惊
  魔王怀恼心　　人天生胜喜
  大地无分别　　平等普能持
  圣教利群生　　邪正俱蒙益
  暂闻佛所说　　金刚种已成
  纵未出樊笼　　终超死行处
  闻法方思义　　如实善修行
  次第三慧圆　　余教皆无此
  唯独牛王仙　　妙契真圆理
  斯教不勤修　　宁有怨过此
  暂闻除渴爱　　邪见信心生
  听者发喜心　　依斯具净戒
  诞应时咸喜　　成长世皆欢
  大化利群生　　示灭兴悲感
  赞咏除众毒　　忆念招欣庆
  寻求发慧明　　解悟心圆洁
  遇者令尊贵　　恭侍胜心生
  承事感福因　　亲奉除忧苦
  尸罗具清洁　　静虑心澄寂
  般若圆智融　　恒沙福所集
  尊容及尊教　　及尊所证法
  见闻思觉中　　此宝最殊胜
  漂流作洲渚　　害己恒为护
  怖者作归依　　引之令解脱
  净戒成妙器　　良田生胜果
  善友能饶益　　慧命由此成
  行恩及和忍　　见者咸欣悦
  广集仁慈心　　功德无边际
  身口无过恶　　爱敬由之生
  吉祥众义利　　咸依善逝德
  导师能善诱　　堕慢使翘勤
  等持调曲心　　迷途归正道
  善根成熟者　　驾驭以三乘
  [怡-台+龍]悷不调人　　由悲故暂舍
  于遭厄能设　　安乐劝善修
  悲愍苦众生　　利乐诸群品
  违害兴慈念　　失行者生忧
  暴虐起悲心　　圣德无能赞
  恩深于罔极　　举世所咸知
  于此返生怨　　尊恒起慈愍
  亡身救一切　　自事不生忧
  于诸崩堕人　　亲能为援护
  二世行恩造　　超过诸世间
  于闇常照明　　尊为慧灯炷
  人天所受用　　随类有差殊
  唯尊正法味　　平等无差别
  不观于氏族　　色力及年华
  随有善根人　　求者皆蒙遂
  广现诸希有　　无缘起大慈
  圣众及人天　　合掌咸亲近
  呜呼生死畏　　佛出乃光晖
  饶益诸众生　　皆能满其愿
  恶人与共处　　摧乐取忧危
  谤恼害其身　　犹如受胜德
  为物行勤苦　　曾无染着心
  世尊希有德　　难以名言说
  尊游崄恶道　　马麦及牛锵
  苦行经六年　　安受心无退
  尊居最胜位　　悲愍化群生
  纵遇轻贱人　　身语逾谦敬
  或位尊贵主　　曾无憍慢心
  屈己事众生　　卑恭如仆使
  机情亿万种　　论难百千端
  如来慈善音　　一答疑皆断
  恩深过覆载　　背德起深怨
  尊观怨极境　　犹如极重恩
  怨于尊转害　　尊于怨转亲
  彼恒求佛过　　佛以彼为恩
  邪宗妒心请　　毒饭与火坑
  悲愿化清池　　变毒成甘露
  以忍调恚怒　　真言销谤毁
  慈力伏魔怨　　正智降邪毒
  群迷从旷劫　　习恶以性成
  唯尊妙行圆　　一念翻令善
  温柔降暴虐　　惠施破悭贪
  善语伏粗言　　唯尊胜方便
  难提摧巨慢　　鸯掘起慈心
  难调能善调　　谁不赞希有
  唯尊圣弟子　　法味自怡神
  草座以为安　　金床非所贵
  善知根欲性　　摄化任机缘
  或有待其请　　或无问自说
  初陈施戒等　　渐次净心生
  后谈真实法　　究竟令圆证
  怖畏漂流处　　唯佛可归依
  勇猛大悲尊　　拯济诸群品
  身云遍法界　　法雨洒尘方
  应现各不同　　随机故有异
  善净无违诤　　唯尊可承奉
  广利诸人天　　咸应兴供养
  身口无起作　　善化遍群方
  所说妙相应　　此德唯尊有
  久修三业净　　妙瑞现无边
  普观诸世间　　曾无此胜德
  况于极恶者　　纯行最上悲
  广利诸众生　　勇猛勤精进
  声闻知法者　　于尊恒奉事
  设使证涅槃　　终名为负债
  彼等诸圣众　　为己而修学
  由舍利生心　　不名还债者
  无明睡已觉　　悲观遍群方
  荷负起翘勤　　圣善宜亲近
  魔怨兴恼害　　佛力已能除
  无畏功德中　　斯但显少分
  悲心化一切　　圣意绝希求
  利乐无不施　　能事斯皆毕
  如来胜妙法　　若或可迁移
  调达与善星　　不应投此教
  无始流转中　　互为不饶益
  由斯佛出世　　开示化众生
  鹿苑度俱邻　　坚林化须跋
  此土根缘尽　　更无余债牵
  法轮久已转　　觉悟诸群迷
  恒沙受学人　　皆能利三有
  以胜金刚定　　自碎坚牢身
  不舍于大悲　　自化犹分布
  二利行已满　　色法两身圆
  救摄一阐提　　双林显佛性
  悲心贯三有　　色像应群方
  粟粒以分身　　尔乃居圆寂
  善哉奇特行　　希有功德身
  大觉诸法门　　世所未曾有
  流恩遍含识　　身语恒寂然
  凡愚背圣恩　　于尊兴谤怒
  法聚宝藏真无际　　德源福海实难量
  若有众生曾礼尊　　礼彼亦名为善礼
  圣德神功无有尽　　我今智劣喻微尘
  欲赞如来功德山　　望崖怯退由斯止
  无量无数无边境　　难思难见难证理
  唯佛圣智独了知　　岂是凡愚所能赞
  一毫一相充法界　　一行一德遍心源
  清净广大喻芳池　　能疗众生烦恼渴
  我赞牟尼功德海　　凭斯善业趣菩提
  普愿含生发胜心　　永离凡愚虚妄识

一百五十赞佛颂


因明入正理论

    No. 1630

因明入正理论一卷

        商羯罗主菩萨造

        三藏法师玄奘奉　诏译

  能立与能破　　及似唯悟他
  现量与比量　　及似唯自悟

如是总摄诸论要义。此中宗等多言名为能立。由宗因喻多言。开示诸有问者未了义故。此中宗者。谓极成有法极成能别差别为性。随自乐为所成立性。是名为宗。如有成立声是无常

因有三相。何等为三。谓遍是宗法性。同品定有性。异品遍无性。云何名为同品异品。谓所立法均等义品。说名同品。如立无常瓶等无常。是名同品。异品者。谓于是处无其所立。若有是常见非所作。如虚空等。此中所作性或勤勇无间所发性遍是宗法性。同品定有性。异品遍无性。是无常等因

喻有二种。一者同法。二者异法。同法者若于是处显因同品决定有性。谓若所作见彼无常。譬如瓶等。异法者若于是处说所立无。因遍非有。谓若是常见。非所作如虚空等。此中常言表非无常。非所作言表无所作。如有非有说名非有

已说宗等如是多言。开悟他时。说名能立。如说声无常者是立宗言。所作性故者是宗法言。若是所作见彼无常。如瓶等者是随同品言。若是其常见非所作。如虚空者是远离言。唯此三分说名能立

虽乐成立由与现量等相违故。名似立宗。谓现量相违。比量相违。自教相违。世间相违。自语相违。能别不极成。所别不极成。俱不极成。相符极成。此中现量相违者。如说声非所闻。比量相违者。如说瓶等是常。自教相违者。如胜论师立声为常。世间相违者。如说怀兔非月有故。又如说言人顶骨净。众生分故。犹如螺贝。自语相违者。如言我母是其石女。能别不极成者。如佛弟子对数论师立声灭坏。所别不极成者。如数论师对佛弟子说我是思。俱不极成者。如胜论师对佛弟子立我以为和合因缘。相符极成者。如说声是所闻。如是多言。是遣诸法自相门故。不容成故。立无果故。名似立宗过已说似宗。当说似因。不成不定及与相违。是名似因

不成有四。一两俱不成。二随一不成。三犹豫不成。四所依不成。如成立声为无常等若言是眼所见性故。两俱不成。所作性故对声显论。随一不成。于雾等性起疑惑时。为成大种和合火有而有所说。犹豫不成。虚空实有。德所依故。对无空论所依不成

不定有六。一共。二不共。三同品一分转异品遍转。四异品一分转同品遍转。五俱品一分转。六相违决定。此中共者。如言声常所量性故。常无常品皆共此因。是故不定。为如瓶等所量性故声是无常。为如空等所量性故声是其常。言不共者。如说声常。所闻性故。常无常品皆离此因。常无常外余非有故。是犹豫因。此所闻性其犹何等。同品一分转异品遍转者。如说声非勤勇无间所发无常性故。此中非勤勇无间所发宗。以电空等为其同品。此无常性于电等有。于空等无。非勤勇无间所发宗。以瓶等为异品。于彼遍有。此因以电瓶等为同法故。亦是不定。为如瓶等无常性故。彼是勤勇无间所发。为如电等无常性故。彼非勤勇无间所发。异品一分转同品遍转者。如立宗言声是勤勇无间所发。无常性故。勤勇无间所发宗。以瓶等为同品。其无常性于此遍有。以电空等为异品。于彼一分电等是有。空等是无。是故如前亦为不定。俱品一分转者。如说声常。无质碍故。此中常宗。以虚空极微等为同品。无质碍性于虚空等有。于极微等无。以瓶乐等为异品。于乐等有。于瓶等无。是故此因以乐以空为同法故。亦名不定。相违决定者。如立宗言声是无常。所作性故。譬如瓶等。有立声常。所闻性故。譬如声性。此二皆是犹豫因。故俱名不定

相违有四。谓法自性相违因。法差别相违因。有法自相相违因。有法差别相违因等。此中。法自相相违因者。如说声常。所作性故。或勤勇无间所发性故。此因唯于异品中有。是故相违。法差别相违因者。如说眼等必为他用。积聚性故。如卧具等。此因如能成立眼等必为他用。如是亦能成立所立法差别相违积聚他用。诸卧具等为积聚他所受用故。有法自相相违因者。如说有性非实非德非业。有一实故。有德业故。如同异性。此因如能成遮实等。如是亦能成遮有性。俱决定故。有法差别相违因者。如即此因即于前宗有法差别作有缘性。亦能成立与此相违作非有缘性。如遮实等。俱决定故。已说似因。当说似喻

似同法喻有其五种。一能立法不成。二所立法不成。三俱不成。四无合。五倒合。似异法喻亦有五种。一所立不遣。二能立不遣。三俱不遣。四不离。五倒离。能立法不成者。如说声常。无质碍故。诸无质碍见。彼是常犹如极微。然彼极微所成立法常性是有。能成立法无质碍无。以诸极微质碍性故。所立法不成者。谓说如觉。然一切觉能成立法无质碍有。所成立法常住性无。以一切觉皆无常故。俱不成者。复有二种。有及非有。若言如瓶。有俱不成。若说如空。对无空论。无俱不成。无合者。谓于是处无有配合。但于瓶等。双现能立所立二法。如言于瓶见所作性及无常性。倒合者。谓应说言诸所作者皆是无常。而倒说言诸无常者皆是所作。如是名似同法喻品

似异法中。所立不遣者。且如有言诸无常者见彼质碍。譬如极微。由于极微所成立法常性不遣。彼立极微是常性故。能成立法无质碍无。能立不遣者。谓说如业。但遣所立。不遣能立。彼说诸业无质碍故。俱不遣者。对彼有论。说如虚空。由彼虚空不遣常性无质碍性。以说虚空是常性故。无质碍故。不离者。谓说如瓶见无常性。有质碍性。倒离者。谓如说言诸质碍者皆是无常。如是等似宗因喻言。非正能立

复次为自开悟。当知唯有现比二量。此中。现量谓无分别。若有正智于色等义离名种等所有分别。现现别转。故名现量。言比量者。谓藉众相而观于义。相有三种。如前已说。由彼为因。于所比义有正智生。了知有火或无常等。是名比量。于二量中即智名果。是证相故。如有作用而显现故。亦名为量

有分别智。于义异转。名似现量。谓诸有智了瓶衣等分别而生。由彼于义不以自相为境界故。名似现量。若似因智为先所起诸似义智。名似比量。似因多种。如先已说。用彼为因。于似所比诸有智生。不能正解名似比量

复次若正显示能立过失。说名能破。谓初能立缺减过性。立宗过性。不成立性。不定因性。相违因性及喻过性。显示此言开晓问者。故名能破。若不实显能立过言名似能破。谓于圆满能立显示缺减性言。于无过宗有过宗言。于成就因不成因言。于决定因不定因言。于不相违因相违因言。于无过喻有过喻言。如是言说名似能破。以不能显他宗过失。彼无过故。且止斯事

  已宣少句义　　为始立方隅
  其间理非理　　妙辩于余处

因明入正理论一卷

    因明入正理论后序

因明入正理论者盖乃抗辩标宗摧邪显正之闷阈也因谈照实。明彰显理入言趣本。正以离邪。论之者。较言旨归。审明要会也。昔应符道树兹义备焉。登庸鹿林斯风扇矣。六师稽颡而卷舌。十仙请命以知归。非天灵曜寝光邪津鼓浪。同恶孔炽。寔繁有徒。所以世亲弘盛烈于前。陈那纂遗芳于后。扬真殄谬夷难解纷。至矣。神功备详余论。粤有天主菩萨亚圣挺生。博综研详。聿修前绪。撰略精秘。逗适时机。启以八门通其二益。芟夷五分取定三支。其义简而彰。其文约而显。西方时彦钻仰弥深。自非履此通规。未足预其高论。大唐皇帝乘时启圣。阐金镜而运金轮。纳录嗣明。振玉鼓而调玉烛。洞敷玄化。载缉彝章。爇慧炬而鉴昏城。舣智舟而济苦海。我三藏法师玄奘。神悟爽[打-丁+(改-己)]峻节冠群。行四勤如不及。瞻三宗而好问。汉地先达各擅专门。寓目必察其微。纳心并殚其妙。嗟乎圣迹緜远。像教陵夷。未尝不临讹文以喟然。抚疑义而太息。望葱山而高视。期鹫峰而远游。既而冒险乘危。询师访道。行达北印度迦湿弥罗国。属大论师僧伽耶舍。稽疑八藏考决五乘。论师以大义磐根嘉其素蓄。唯因明妙术诲其未喻。梵音觏止冰释于怀。后于中印度摩竭陀国。遇尸罗跋陀罗菩萨。更广其例。触类而长。优而柔之。于是遍谒遗灵备讯余烈。虽遇鍱腹纵辩无前。风偃邪徒抑兼兹论。旋弘周化景福会昌。粤以贞观二十一年秋八月六日。于弘福寺。承诏译讫。弘福寺沙门明浚笔受证文。弘福寺沙门玄谟证梵语。大总持寺沙门玄应正字。大总持寺沙门道洪。实际寺沙门明琰。罗汉寺沙门慧贵。宝昌寺沙门法祥。弘福寺沙门文备。廓州法讲寺沙门道深。蒲州栖岩寺沙门神泰。详证大义。银青光禄大夫行左庶子高阳县开国男臣许敬宗奉诏监译。三藏法师以虚已应物辟此幽关。义海淼其无源。词峰峻而难仰。异方秀杰同禀亲承笔记玄章并行于世。余以不敏妄忝吹嘘。受旨证文偶兹嘉会。敢录时事贻诸后毗。胜范鸿因无泯来际


因明正理门论

    No. 1628 [No. 1629]

因明正理门论本

        大域龙菩萨造

        大唐三藏法师玄奘奉　诏译

为欲简持能立能破义中真实故造斯论

  宗等多言说能立　　是中唯随自意乐
  为所成立说名宗　　非彼相违义能遣

宗等多言说能立者。由宗因喻多言辩说他未了义故。此多言于论式等说名能立。又以一言说能立者为显总成一能立性。由此应知。随有所阙名能立过。言是中者。起论端义。或简持义。是宗等中故名是中。所言唯者。是简别义。随自意显不顾论宗随自意立。乐为所立。谓不乐为能成立性。若异此者。说所成立。似因似喻应亦名宗。为显离余立宗过失故。言非彼相违义能遣。若非违义言声所遣。如立一切言皆是妄。或先所立宗义相违。如獯狐子立声为常。又若于中由不共故无有比量为极成言相违义遣。如说怀兔非月有故。又于有法即彼所立为此极成现量比量相违义遣。如有成立声非所闻瓶是常等。诸有说言。宗因相违名宗违者。此非宗过。以于此中立声为常。一切皆是无常故者。是喻方便恶立异法。由合喻显非一切故。此因非有。以声摄在一切中故。或是所立一分义故。此义不成名因过失。喻亦有过。由异法喻先显宗无后说因无。应如是言。无常一切。是谓非非一切义故。然此倒说一切无常。是故此中喻亦有过

如是已说宗及似宗。因与似因多是宗法。此差别相今当显示

  宗法于同品　　谓有非有俱
  于异品各三　　有非有及二

岂不总以乐所成立合说为宗。云何此中乃言宗者唯取有法。此无有失。以其总声于别亦转。如言烧衣。或有宗声唯诠于法。此中宗法唯取立论及敌论者决定同许。于同品中有非有等亦复如是。何以故。今此唯依证了因故。但由智力了所说义。非如生因由能起用。若尔既取智为了因。是言便失能成立义。此亦不然。令彼忆念本极成故。是故此中唯取彼此俱定许义。即为善说。由是。若有彼此不同许。定非宗法。如有成立声是无常。眼所见故。又若敌论不同许者。如对显论所作性故。又若犹豫如依烟等起疑惑时。成立大种和合火有。以现烟故。或于是处有法不成。如成立我其体周遍于一切处。生乐等故。如是所说一切品类所有言词皆非能立。于其同品有非有等。亦随所应当如是说。于当所说因与相违及不定中。唯有共许决定言词。说名能立。或名能破。非互不成犹豫言词复待成故。夫立宗法理应更以余法为因成立此法。若即成立有法为有。或立为无。如有成立最胜为有。现见别物有总类故。或立为无。不可得故。其义云何。此中但立别物定有一因为宗。不立最胜故。无此失。若立为无。亦假安立不可得法。是故亦无有有法过。若以有法立余有法。或立其法。如以烟立火。或以火立触。其义云何。今于此中非以成立火触为宗。但为成立此相应物。若不尔者。依烟立火依火立触。应成宗义一分为因。又于此中非欲成立火触有性。共知有故。又于此中观所成故。立法有法。非德有德故。无有过。重说颂言

  有法非成于有法　　及法此非成有法
  但由法故成其法　　如是成立于有法

若有成立声非是常。业等应常故。常应可得故。如是云何名为宗法。此说彼过由宗因门以有所立说应言故。以先立常无形碍故。后但立宗斥彼因过。若如是立声是无常。所作非常故。常非所作故。此复云何。是喻方便同法异法如其次第宣说其因宗定随逐及宗无处定无因故。以于此中由合显示所作性因。如是此声定是所作非非所作。此所作性定是宗法。重说颂言

  说因宗所随　　宗无因不有
  依第五显喻　　由合故知因

由此已释反破方便。以所作性于无常见故。于常不见故。如是成立声非是常。应非作故。是故顺成反破方便非别解因。如破数论我已广辩故。应且止广诤傍论

如是宗法三种差别。谓同品有。非有。及俱。先除及字。此中。若品与所立法邻近均等。说名同品。以一切义皆名品故。若所立无。说名异品。非与同品相违。或异。若相违者。应唯简别。若别异者。应无有因。由此道理。所作性故能成无常及无我等不相违故。若法能成相违所立。是相违过。即名似因。如无违法。相违亦尔。所成法无。定无有故。非如瓶等因成犹豫于彼展转无中有故。以所作性现见离瓶于衣等有。非离无常于无我等此因有故。云何别法于别处转。由彼相似。不说异名。言即是此故。无有失若不说异。云何此因说名宗法。此中但说定是宗法不欲说言唯是宗法。若尔。同品应亦名宗。不然。别处说所成故。因必无异。方成比量故。不相似。又此一一各有三种。谓于一切同品有中。于其异品。或有。非有。及有非有。于其同品非有及俱。各有如是三种差别。若无常宗。全无异品。对不立有虚空等论。云何得说彼处此无。若彼无有。于彼不转。全无有疑故。无此过。如是合成九种宗法。随其次第略辨其相。谓立声常所量性故。或立无常。所作性故。或立勤勇无间所发。无常性故。或立为常。所作性故。或立为常。所闻性故。或立为常。勤勇无间所发性故。或非勤勇无间所发。无常性故。或立无常。勤勇无间所发性故。或立为常。无触对故。如是九种二颂所摄

  常无常勤勇　　恒住坚牢性
  非勤迁不变　　由所量等九
  所量作无常　　作性闻勇发
  无常勇无触　　依常性等九

如是分别。说名为因相违不定。故本颂言

  于同有及二　　在异无是因
  翻此名相违　　所余皆不定

此中。唯有二种名因。谓于同品一切遍有。异品遍无。及于同品通有非有。异品遍无。于初后三各取中一。复唯二种说名相违。能倒立故。谓于异品有及二种。于其同品一切遍无。第二三中取初后二。所余五种因。及相违。皆不决定。是疑因义。又于一切因等相中皆说所说一数同类。勿说二相更互相违共集一处犹为因等。或于一相同作事故。成不遍因。理应四种名不定因。二俱有故。所闻云何。由不共故。以若不共所成立法所有差别遍摄一切皆是疑因。唯彼有性彼所摄故。一向离故。诸有皆共无简别因。此唯于彼俱不相违。是疑因性。若于其中俱分是有亦是定因简别余故。是名差别。若对许有声性是常此应成因。若于尔时无有显示所作性等是无常因。容有此义。然俱可得一义相违。不容有故。是犹豫因。又于此中现教力胜故。应依此思求决定。摄上颂言

  若法是不共　　共决定相违
  遍一切于彼　　皆是疑因性
  邪证法有法　　自性或差别
  此成相违因　　若无所违害
  观宗法审察　　若所乐违害
  成踌躇颠倒　　异此无似因

如是已辨因及似因。喻及似喻今我当说

  说因宗所随　　宗无因不有
  此二名譬喻　　余皆此相似

喻有二种。同法异法。同法者谓立声无常。勤勇无间所发性故。以诸勤勇无间所发皆见无常。犹如瓶等。异法者谓诸有常住见非勤勇无间所发。如虚空等。前是遮诠。后唯止滥。由合及离比度义故。由是虽对不立实有太虚空等而得显示无有宗处无因义成。复以何缘第一说因宗所随逐。第二说宗无因不有。不说因无宗不有耶。由如是说。能显示因同品定有。异品遍无非颠倒说。又说颂言

  应以非作证其常　　或以无常成所作
  若尔应成非所说　　不遍非乐等合离

如是已说二法合离顺反两喻。余此相似。是似喻义。何谓此余。谓于是处所立能立及不同品虽有合离而颠倒说。或于是处不作合离。唯现所立能立俱有。异品俱无。如是二法。或有随一不成不遣。或有二俱不成不遣。如立声常无触对故。同法喻言诸无触对见彼皆常。如业。如极微。如瓶等。异法喻言。谓诸无常见有触对。如极微。如业。如虚空等。由此已说同法喻中有法不成。谓对不许常虚空等为要具二譬喻言词方成能立。为如其因但随说一。若就正理应具说二。由是具足显示所立不离其因。以具显示同品定有异品遍无。能正对治相违不定。若有于此一分已成。随说一分亦成能立。若如其声两义同许。俱不须说。或由义准一能显二

又比量中唯见此理。若所比处此相审定于余同类。念此定有。于彼无处念此遍无。是故由此生决定解。故本颂言

  如自决定已　　悕他决定生
  说宗法相应　　所立余远离

为于所比显宗法性故。说因言。为显于此不相离性故。说喻言。为显所比故。说宗言。于所比中除此更无其余支分。由是遮遣余审察等及与合结。若尔喻言应非异分。显因义故。事虽实尔。然此因言唯为显了是宗法性。非为显了同品异品有性无性故。须别说同异喻言。若唯因言所诠表义。说名为因。斯有何失。复有何德。别说喻分。是名为德。应如世间所说方便与其因义都不相应。若尔何失。此说但应类所立义无有功能非能立义。由彼但说所作性故所类同法。不说能立所成立义。又因喻别此有所立同法异法。终不能显因与所立不相离性。是故但有类所立义。然无功能。何故无能。以同喻中不必宗法。宗义相类。此复余譬所成立故。应成无穷。又不必定有诸品类。非异品中不显无性。有所简别能为譬喻。故说颂言

  若因唯所立　　或差别相类
  譬喻应无穷　　及遮遣异品

世间但显宗因异品同处有性为异法喻。非宗无处因不有性。故定无能。若唯宗法是因性者。其有不定。应亦成因。云何具有所立能立及异品法二种譬喻而有此失。若于尔时所立异品非一种类。便有此失。如初后三各最后喻。故定三相唯为显因。由是道理虽一切分皆能为因显了所立。然唯一分且说为因。如是略说宗等及似。即此多言说名能立及似能立。随其所应为开悟他说此能立及似能立

为自开悟唯有现量及与比量。彼声喻等摄在此中。故唯二量。由此能了自共相故。非离此二别有所量为了知彼更立余量。故本颂言

  现量除分别　　余所说因生

此中现量除分别者。谓若有智于色等境远离一切种类名言。假立无异诸门分别。由不共缘现现别转。故名现量。故说颂言

  有法非一相　　根非一切行
  唯内证离言　　是色根境界

意地亦有离诸分别唯证行转。又于贪等诸自证分。诸修定者离教分别皆是现量。又于此中无别量果。以即此体似义生故。似有用故假说为量。若于贪等诸自证分亦是现量。何故此中除分别智。不遮此中自证。现量无分别故。但于此中了余境分不名现量。由此即说。忆念比度悕求疑智惑乱智等于粗爱等皆非现量。随先所受分别转故。如是一切世俗有中瓶等数等举等有性瓶性等智。皆似现量。于实有中作余行相假合余义分别转故

已说现量当说比量。余所说因生者谓智是前智。余从如所说能立因生是缘彼义。此有二种。谓于所比审观察智。从现量生。或比量生。及忆此因与所立宗不相离念。由是成前举所说力念因同品定有等故。是近及远比度因故。俱名比量。此依作具作者而说。如是应知。悟他比量亦不离此得成能立。故说颂言

  一事有多法　　相非一切行
  唯由简别余　　表定能随逐
  如是能相者　　亦有众多法
  唯不越所相　　能表示非余

何故此中与前现量。别异建立。为现二门。此处亦应于其比果说为比量。彼处亦应于其现因说为现量。俱不遮止。已说能立及似能立。当说能破及似能破。颂曰

  能破阙等言　　似破谓诸类

此中能破阙等言者谓前所说阙等言词。诸分过失。彼一一言皆名能破。由彼一一能显前宗非善说故

所言似破谓诸类者。谓同法等相似过类名似能破。由彼多分于善比量。为迷惑他而施设故。不能显示前宗不善。由彼非理而破斥故。及能破处而施设故。是彼类故。说名过类。若于非理立比量中如是施设。或不了知比量过失。或即为显彼过失门。不名过类

  示现异品故　　由同法异立
  同法相似余　　由异法分别
  差别名分别　　应一成无异
  显所立余因　　名可得相似
  难义别疑因　　故说名犹豫
  说异品义故　　非爱名义准

此中示现异品故。由同法异立。同法相似者颠倒成立故名异立。此依作具作者而说同法。即是相似故名同法相似。一切摄立中相似过类故。言相似者是不男声。能破相应故。或随结颂故。云何同法相似能破。于所作中说能作故。转生起故。作如是说后随所应亦如是说。今于此中由同法喻颠倒成立。是故说名同法相似。如有成立声是无常。勤勇无间所发性故。此以虚空为异法喻。有显虚空为同法喻。无质等故。立声为常。如是即此所说因中瓶应为同法。而异品虚空说为同法。由是说为同法相似

余由异法者谓异法相似。是前同法相似之余示现异品由异法喻颠倒而立二种喻中如前安立。瓶为异法。是故说为异法相似

分别差别名分别者前说示现等故。今说分别差别故。应知。分别同法差别。谓如前说瓶为同法。于彼同法有可烧等差别义故。是则瓶应无常非声。声应是常不可烧等。有差别故。由此分别颠倒所立。是故说名分别相似。所言应一成无异者示现同法前已说故。由此与彼应成一故。彼者是谁。以更不闻异方便故。相邻近故。应知。是宗成无异者成无异过。即由此言义可知。故不说其名。是谁与谁共成无异。不别说。故即此一切与彼一切。如有说言。若见瓶等有同法故。即令余法亦无别异。一切瓶法声应皆有。是则一切更互法同应成一性。此中抑成无别异过。亦为显示瓶声差别。不甚异前分别相似故。应别说。若以勤勇无间所发。成立无常。欲显俱是非毕竟性。则成宗因无别异过。抑此令成无别异性。是故说名无异相似。有说。此因如能成立所成立法亦能成立此相违法。由无别异。是故说名无异相似

显所立余因名可得相似者。谓若显示所立宗法余因可得。是则说名可得相似。谓有说言。如前成立声是无常。此非正因。于电光等由现见等余因可得无常成故。以若离此而得有彼。此非彼因。有余于此别作方便。谓此非彼无常正因由不遍故。如说丛林皆有思虑有睡眠故

难义别疑因故说名犹豫者过类相应故。女声说。此中分别宗义别异因成不定。是故说名犹豫相似。或复分别因义别异故。名犹豫相似过类。谓有说言。如前成立声是无常。勤勇无间所发性故。现见勤勇无间所发或显或生故。成犹豫。今所成立为显为生。是故不应以如是因证无常义

说异品义故。非爱名义准者。谓有说言。若以勤勇无间所发说无常者。义准则应若非勤勇无间所发。诸电光等皆应是常。如是名为义准相似应知。此中略去后句。是故但名犹豫义准。复由何义此同法等相似过类异因明师所说次第。似破同故

  由此同法等　　多疑故似彼

多言为显或有异难。及为显似不成因过。此中前四与我所说譬喻方便都不相应。且随世间譬喻方便。虽不显因是决定性然摄其体故。作是说。由用不定同法等因成立自宗。方便说他亦有此法。由是便成似共不定。或复成似相违决定。若言唯为成立自宗。云何不定得名能破。非即说此以为能破。难不定言说名不定。于能诠中说所诠故。无有此过。余处亦应如是安立。若所立量有不定过。或复决定同法等因有所成立。即名能破。是等难故。若现见力比量不能遮遣其性。如有成立声非所闻。犹如瓶等。以现见声是所闻故。不应以其是所闻性遮遣无常。非唯不见能遮遣故。若不尔者。亦应遣常。第二无异相似是似不成因过。彼以本无而生。增益所立。为作宗因成一过故。此以本无而生极成因法证灭后无。若即立彼可成能破。第三无异相似成立违害所立难故。成似由可烧等不决定故。若是决定可成相违。可得相似所立不定故。成其似。若所立因于常亦有可成能破。第二可得虽是不遍。余类无故。似不成过。若所立无可名能破。非于此中欲立一切皆是无常。犹豫相似。谓以勤勇无间所发得成立灭坏。若以生起增益所立。作不定过。此似不定。若于所立不起分别。但简别因生起为难。此似不成。由于此中不欲唯生成立灭坏。若生若显悉皆灭坏。非不定故。义准相似。谓以颠倒不定为难故。似不定。若非勤勇无间所发立常无常。或唯勤勇无间所发无常非余可成能破

  若因至不至　　三时非爱言
  至非至无因　　是名似因阙

若因至不至三时非爱言至非至无因者。于至不至作非爱言。若能立因至所立宗而成立者。无差别故。应非所立。如池海水相合无异。又若不成应非相至。所立若成此是谁因。若能立因不至所立。不至非因。无差别故。应不成因。是名为至非至相似。又于三时作非爱言。若能立因在所立前。未有所立。此是谁因。若言在后。所立已成。复何须因。若俱时者。因与有因皆不成就。如牛两角。如是名为无因相似。此中如前次第异者由俱说名似因阙故。所以者何。非理诽拨一切因故。此中何理唯不至同故虽因相相应。亦不名因。如是何理唯在所立前不得因名故。即非能立。又于此中有自害过。遮遣同故。如是且于言因及慧所成立中有似因阙。于义因中有似不成。非理诽拨诸法因故。如前二因于义所立俱非所作能作性故。不应正理。若以正理而诽拨时。可名能破

  说前无因故　　应无有所立
  名无说相似　　生无生亦然
  所作异少分　　显所立不成
  名所作相似　　多如似宗说

说前因无故应无有所立名无说相似者。谓有说言。如前所立。若由此因证无常性。此未说前都无所有。因无有故。应非无常。如是名为无说相似

生无生亦然者生前无因故。无所立。亦即说名无生相似。言亦然者类例声。前因无有故。应无所立。今于此中如无所立。应知。亦有所立相违。谓有说言。如前所立。若如是声未生已前无有勤勇无间所发。应非无常。又非勤勇无间所发故。应是常。如是名为无生相似。所作异少分显所立不成名所作相似者。谓所成立所作性故。犹如瓶等。声无常者若瓶有异所作性故。可是无常。何豫声事。如是名为所作相似

多如似宗说者如是无说相似等多分如似所立说。谓如不成因过。多言为显或如似余。今于此中无说相似增益比量。谓于论者所说言词立无常性。难未说前因无有故。此似不成。或似因阙。谓未说前益能立故。若于此中显义无有。又立量时。若无言说可成能破。无生相似声未生前增益所立难因无故。即名似破。若成立时显此是无。可成能破。若未生前以非勤勇无间所发。难令是常。义准分故。亦似不定。所作相似乃有三种。若难瓶等所作性于声上无此似不成。若难声所作性于瓶等无此似相违。若难即此常上亦无是不共故。便似不定。或似喻过。引同法故。何以故。唯取总法建立比量。不取别故。若取别义。决定异故。比量应无

  俱许而求因　　名生过相似
  此于喻设难　　名如似喻说

俱许而求因名生过相似者。谓有难言。如前所立。瓶等无常。复何因证。此于喻设难名如似喻说者谓瓶等无常俱许成就而言不成。似喻难故。如似喻说

  无常性恒随　　名常住相似
  此成常性过　　名如宗过说

谓有难言如前所立。声是无常。此应常与无常性合。诸法自性恒不舍故。亦应是常。此即名为常住相似。是似宗过。增益所立无常性故。以于此中都无有别实无常性依此常转。即此自性本无今有暂有还无故。名无常。即此分位由自性缘。名无常性。如果性等

如是过类足目所说多分说为似能破。性最极成故。余论所说亦应如是分别成立。即此过类但由少分方便异故。建立无边差别过类。是故不说。如即此中诸有所说增益。损减。有显。无显。生理。别喻。品类相似等由此方隅皆应谛察。及应遮遣诸有不善比量方便。作如是说展转流漫。此于余论所说无穷故。不更说。又于负处旧因明师诸有所说。或有堕在能破中摄。或有极粗。或有非理。如诡语类故。此不录。余师宗等所有句义亦应如是分别建立。如是遍计所执分等皆不应理。违所说相。皆名无智。理极远故。又此类过失言词我自朋属论式等中多已制伏。又此方隅我于破古因明论中已具分别。故应且止

  为开智人慧毒药　　启斯妙义正理门
  诸有外量所迷者　　令越邪途契真义

因明正理门论本


因明正理门论b

    No. 1629 [No. 1628]

因明正理门论一卷

        大域龙菩萨造

        大唐三藏法师义净奉　制译

论曰。为欲简持能立能破义中真实故造斯论。颂曰

  宗等多言说能立　　是中唯随自意乐
  为所成立说名宗　　非彼相违义能遣

论曰。能立过义印真实义。此论今作宗等多言说能立。如是等此言为显由绪所诠所为。言由绪者。为由利益诸有情等。为缘绪故。言所诠者。谓所诠义即宗等也。所为事者。为欲印定实义故也。若其为显由绪等果。于此论初置斯言者。由于余处已显此义故。犹如现量。何谓余显解论后时由此于初不应说故。若尔非论分故。犹若余言由于余处已显此义。此因不成。解论后时方晓义者。觉慧先闻于由绪等。若不了知初便不转。由斯解故方契后时非论分故。此亦不成。设如斯意既非经故复非其释必非支分。谁释此经谁经此释。是故当知。如天授语非其支分。诸论由绪亦成分故。此因有故远离非成。余复难言勿造斯论无由绪等故。如狂人言为显此因不成。答曰。所谓能立能过义等。若言如是勿造斯论。述已显义故。如第二理门恶叉波拖已说宗等相。此因彼言显不成故。岂非能立等有印实义。然此论等不印实义故不成过。上来已辩论主标宗。自下本文随次当释。宗等多言说能立者。由宗因喻多言辩说。他未了义为开示故。此之多言于论式等说名能立。又以一言说能立者。为显总成一能立性。由此应知。随有所阙名能立过。言是中者起论端义或简持义。是宗等中故名是中。所言唯者。是简别义。随自意显。不顾论宗随自意立。乐为所立。谓不乐为能成立性。若异此者。说所成立。似因似喻应亦名宗。为显离余立宗过失故。言非彼相违义能遣。若非违义言声所遣。如立一切言皆是妄。或先所立宗义相违。如獯狐子立声为常。又若于中由不共故无有比量为极成言相违义遣。如说怀兔非月有故。又于有法即彼所立为此极成现量比量相违义遣。如有成立声非所闻瓶是常等。诸有说言。宗因相违名宗违者。此非宗过。以于此中立声为常。一切皆是无常故者。是喻方便恶立异法由合喻显非一切故。此因非有。以声摄在一切中故。或是所立一分义故。此义不成。名因过失。喻亦有过。由异法喻先显宗无后说因无。应如是言无常一切。是谓非非一切故义。然此倒说一切无常。是故此中喻亦有过。如是已说宗及似宗因与似因多是宗法。此差别相今当显示。颂曰

  宗法于同品　　谓有非有俱
  于异品各三　　有非有及二

论曰。岂不总以乐所成立合说为宗。云何此中乃言宗者唯取有法。此无有失。以其总声于别亦转。如言烧衣。或有宗声唯诠于法。此中宗法。唯取立论及敌论者决定同许。于同品中有非有等亦复如是。何以故。今此唯依证了因故。但由智力了所说义。非如生因由能起用。若尔既取智为了因。是言便失能成立义。此亦不然。令彼忆念本极成故。是故此中唯取彼此俱定许义。即为善说。由是若有彼此不同许。定非宗法。如有成立声是无常眼所见故。又若敌论不同许者。如对显论所作性故。又若犹豫。如依烟等起疑惑时。成立大种和合火有。以现烟故。或于是处有法不成。如成立我其体周遍于一切处。生乐等故。如是所说。一切品类所有言词皆非能立。于其同品有非有等。亦随所应当如是说。于当所说因与相违及不定中。唯有共许决定言词。说名能立。或名能破。非互不成。犹豫言词复待成故。夫立宗法。理应更以余法为因成立此法。若即成立有法为有。或立为无。如有成立最胜为有。现见别物有总类故。或立为无。不可得故。其义云何。此中但立别物定有。一因为宗不立最胜。故无此失。若立为无。亦假安立不可得法。是故亦无有有法过。若以有法立余有法。或立其法。如以烟立火。或以火立触。其义云何。今于此中非以成立火触为宗。但为成立此相应物。若不尔者。依烟立火依火立触。应成宗义一分为因。又于此中非欲成立。火触有性共知有故。又于此中观所成故。立法有法非德有德故无有过。重说颂言

  有法非成于有法　　及法此非成有法
  但由法故成其法　　如是成立于有法

论曰。若有成立声非是常。业等应常故。常应可得故如是云何名为宗法。此说彼过由因宗门。以有所立说应言故。以先立常无形碍故。后但立宗斥彼因过。若如是立声是无常。所作非常故。常非所作故。此复云何。是喻方便同法异法如其次第宣说其因。宗定随逐及宗无处定无因故。以于此中由合显示所作性因。如是此声定是所作。非非所作。此所作性定是宗法。重说颂言

  说因宗所随　　宗无因不有
  依第五显喻　　由合故知因

论曰。由此已释反破方便以所作性于无常见故。于常不见故。如是成立声非是常。应非作故。是故顺成反破方便非别解因。如破数论我已广辩。故应且止广诤傍论

如是宗法三种差别谓同品。有非有及俱先除及字此中若品与所立法邻近均等说名同品以一切义皆名品故若所立无说立异品。非与同品相违。或异若相违者。应唯简别。若别异者应无有因。由此道理所作性故能成无常及无我等不相违故。若法能成相违所立。是相违过即名似因。如无违法相违亦尔。所成法无定无有故。非如瓶等因成犹豫于彼展转无中有故。以所作性现见离瓶于衣等有非离无常于无我等此因有故。云何别法于别处转。由彼相似不说异名言即是此故无有失。若不说异云何此因说名宗法。此中但说定是宗法。不欲说言唯是宗法。若尔同品应亦名宗。不然别处说所成故因必无异方成比量故不相似。又此一一各有三种。谓于一切同品有中。于其异品或有非有及有非有。于其同品非有及俱。各有如是三种差别。若无常宗全无异品对不立有虚空等论。云何得说彼处此无。若彼无有于彼不转全无有疑故无此过。如是合成九种宗法。随其次第略辩其相。谓立声常所量性故。或立无常所作性故。或立勤勇无间所发无常性故。或立为常所作性故。或立为常所闻性故。或立为常勤勇无间所发性故。或非勤勇无间所发无常性故。或立无常勤勇无间所发性故。或立为常无触对故。如是九种二颂所摄。颂曰

  常无常勤勇　　恒住坚牢性
  非勤迁不变　　由所量等九
  所量作无常　　作性闻勇发
  无常勇无触　　依常性等九

论曰。如是分别。说名为因。相违不定。故本颂言

  于同有及二　　在异无是因
  翻此名相违　　所余皆不定

此中唯有二种名因。谓于同品一切遍有异品遍无。及于同品通有非有。异品遍无。于初后三各取中一。复唯二种说名相违。能倒立故。谓于异品有及二种。于其同品一切遍无。第二三中取初后二。所余五种因及相违皆不决定。是疑因义。又于一切因等相中。皆说所说一数同类勿说二相。更互相违共集一处犹为因等。或于一相同作事故成不遍因。理应四种。名不定因二俱有故。所闻云何由不共故。以若不共所成立法。所有差别遍摄一切。皆是疑因。唯彼有性彼所摄故。一向离故。诸有皆共无简别因。此唯于彼俱不相违是疑因性。若于其中俱分是有亦是定因。简别余故。是名差别。若对许有声性是常此应成因。若于尔时无有显示。所作性等是无常因。容有此义。然俱可得一义相违不容有故是犹豫因。又于此中现教力胜故。应依此思求决定摄上。颂言

  若法是不共　　共决定相违
  遍一切于彼　　皆是疑因性
  邪证法有法　　自性或差别
  此成相违因　　若无所违害
  观宗法审察　　若所乐违害
  成踌躇颠倒　　异此无似因

谕曰。如是已辩因及似因。喻及似喻我今当说。颂曰

  说因宗所随　　宗无因不有
  此二名譬喻　　余皆此相似

论曰。喻有二种。同法异法。同法者。谓立声无常勤勇无间所发性故。以诸勤勇无间所发皆见无常犹如瓶等。异法者。谓诸有常住见。非勤勇无间所发。如虚空等。前是遮诠后唯止滥。由合及离比度义故。由是虽对不立实有。太虚空等而得显示。无有宗处无因义成。复以何缘第一说因宗所随逐。第二说宗无因不有。不说因无宗不有耶。由如是说。能显示因同品定有异品遍无非颠倒说。又说颂言

  应以非作证其常　　或以无常成所作
  若尔应成非所说　　不遍非乐等合离

论曰。如是已说。二法合离顺反两喻。余此相似是似喻义。何谓此余。谓于是处所立能立及不同品虽有合离而颠倒说。或于是处不作合离。唯现所立能立俱有异品俱无。如是二法。或有随一不成不遣。或有二俱不成不遣。如立声常无触对故。同法喻言。诸无触对见彼皆常。如业如极微如瓶等。异法喻言。谓诸无常见有触对。如极微如业如虚空等。由此已说同法喻中有法不成。谓对不许常虚空等为要具二。譬喻言词方成能立。为如其因但随说一。若就正理应具说二。由是具足显示所立不离其因。以具显示同品定有异品遍无。能正对治相违不定。若有于此一分已成。随说一分亦成能立。若如其声两义同许俱不须说。或由义准一能显二。又比量中唯见此理。若所比处此相审定。于余同类念此定有。于彼无处念此遍无。是故由此生决定解。故本颂言

  如自决定已　　悕他决定生
  说宗法相应　　所立余远离

论曰。为于所比显宗法性故说因言。为显于此不相离性故说喻言。为显所比故说宗言。于所比中除此更无其余支分。由是遮遣余审察等及与合结。若尔喻言应非异分。显因义故。事虽实尔。然此因言唯为显了是宗法性。非为显了同品异品有性无性。故须别说同异喻言。若唯因言所诠表义说名为因。斯有何失。复有何得。别说喻分是名为得。应如世间所说方便。与其因义都不相应。若尔何失。此说但应类所立义无有功能非能立义。由彼但说所作性故。所类同法不说能立所成立义。又因喻别此有所立。同法异法终不能显。因与所立不相离性。是故但有类所立义然无功能。何故无能。以同喻中不必宗法宗义相类。此复余譬所成立故。应成无穷。又不必定有诸品类。非异品中不显无性。有所简别能为譬喻。故说颂言

  若因唯所立　　或差别相类
  譬喻应无穷　　及遮遣异品

论曰。世间但显宗因异品。同处有性为异法喻。非宗无处因不有性故定无能。若唯宗法是因性者。其有不定应亦成因。云何具有所立能立及异品法二种譬喻而有此失。若于尔时所立异品非一种类便有此失。如初后三各最后喻故定三相唯为显因。由是道理虽一切分皆能为因显了所立。然唯一分且说为因。如是略说宗等及似。即此多言说名能立及似能立。随其所应为开悟他。说此能立及似能立。为自开悟唯有现量及与比量。彼声喻等摄在此中故唯二量由此能了自共相故。非离此二别有所量为了知彼更立余量。故本颂言

  现量除分别　　余所说因生

论曰。此中现量除分别者。谓若有智于色等境。远离一切种类名言。假立无异诸门分别。由不共缘现现别转故名现量。故说颂言

  有法非一相　　根非一切行
  唯内证离言　　是色根境界

论曰。意地亦有离诸分别唯证行转。又于贪等诸自证分。诸修定者离教分别。皆是现量。又于此中无别量果。以即此体似义生故。似有用故。假说为量。若于贪等诸自证分亦是现量。何故此中除分别智。不遮此中自证现量。无分别故。但于此中了余境分不名现量。由此即说忆念比度悕求疑智惑乱智等。于鹿爱等皆非现量。随先所受分别转故。如是一切世俗有中瓶等数等举等有性瓶性等智。皆似现量。于实有中作余行相。假合余义分别转故

已说现量。当说比量。余所说因生者。谓智是前智。余从如所说能立因生。是缘彼义。此有二种。谓于所比审观察智。从现量生或比量生。及忆此因与所立宗不相离念。由是成前举所说力念因同品定有等故。是近及远比度因故俱名比量。此依作具作者而说。如是应知。悟他比量亦不离此得成能立。故说颂言

  一事有多法　　相非一切行
  唯由简别余　　表定能随逐
  如是能相者　　亦有众多法
  唯不越所相　　能表示非余

论曰。何故此中与前现量。别异建立为现二门。此处亦应于其比果说为比量。彼处亦应于其现因说为现量。俱不遮止。已说能立及似能立。当说能破及似能破。颂曰

  能破阙等言　　似破谓诸类

论曰。此中能破阙等言者。谓前所说阙等言词诸分过失。彼一一言皆名能破。由彼一一能显前宗非善说故。所言似破谓诸类者。诸同法等相似过类名似能破。由彼多分于善比量。为迷惑他而施设故。不能显示前宗不善。由彼非理而破斥故。及能破处而施设故。是彼类故说名过类。若于非理立比量中如是施设。或不了知比量过失。或即为显彼过失门。不名过类。颂曰

  示现异品故　　由同法异立
  同法相似余　　由异法分别
  差别名分别　　应一成无异
  显所立余因　　名可得相似
  难义别疑因　　故说名犹豫
  说异品义故　　非爱名义准

论曰。此中示现异品故由同法异立同法相似者。颠倒成立故名异立。此依作具作者而说。同法即是相似故名同法相似。一切摄立中相似过类故。言相似者是不男声。能破相应故。或随结颂故。云何同法相似。能破于所作中说能作故。传生起故。作如是说。后随所应亦如是说。今于此中由同法喻颠倒成立。是故说名同法相似。如有成立声是无常勤勇无间所发性故。此以虚空为异法喻。有显虚空为同法喻。无质等故立声为常。如是即此所说因中瓶应为同法。而异品虚空说为同法。由是说为同法相似。余由异法者。谓异法相似。是前同法相似之余。示现异品由异法喻颠倒而立。二种喻中如前安立瓶为异法。是故说为异法相似。分别差别名分别者。前说示现等故。今说分别差别故。应知分别同法差别。谓如前说瓶为同法。于彼同法有可烧等差别义故。是则瓶应无常非声。声应是常不可烧等有差别故。由此分别颠倒所立。是故说名分别相似所言应一成无异者。示现同法前已说故。由此与彼应成一故。彼者是谁。以更不闻异方便故。相邻近故。应知是宗成无异者成无异过。即由此言义可知故不说其名。是谁与谁共成无异不别说故。即此一切与彼一切。如有说言。若见瓶等有同法故。即合余法亦无别异。一切瓶法声应皆有。是则一切更互法同应成一性。彼中抑成无别异过。亦为显示瓶声差别。不甚异前分别相似故应别说。若以勤勇无间所发成立无常。欲显俱是非毕竟性。则成宗因无别异过。抑此令成无别异性。是故说名无异。相似有说此因如能成立。所成立法亦能成立。此相违法由无别异。是故说名无异相似。显所立余因名可得相似者。谓若显示所立宗法余因可得。是则说名可得相似。谓有说言。如前成立声是无常。此非正因。于电光等由现见等余因可得无常成故。以若离此而得有彼此非彼因。有余于此别作方便。谓此非彼无常正因由不遍故。如说丛林。皆有思虑有睡眠故。难义别疑因故说名犹豫者。过类相应故女声说。此中分别宗义别异因成不定。是故说名犹豫相似。或复分别因义别异故。名犹豫相似过类。谓有说言。如前成立声是无常。勤勇无间所发性故。现见勤勇无间所发。或显或生故成犹豫。今所成立为显为生。是故不应以如是因证无常义。说异品义故非爱名义准者。谓有说言。若以勤勇无间所发说无常者。义准则应若非勤勇无间所发。诸电光等皆应是常。如是名为义准相似。应知此中略去后句是故但名犹豫义准。复由何义。此同法等相似过类。异因明师所说次第。似破同故。颂曰

  由此同法等　　多疑故似彼

论曰。多言为显或有异难。及为显似不成因过。此中前四与我所说譬喻方便都不相应。且随世间譬喻方便。虽不显因是决定性。然摄其体故作是说。由用不定同法等因。成立自宗方便说他。亦有此法。由是便成似共不定。或复成似相违决定。若言唯为成立自宗。云何不定得名能破。非即说此以为能破。难不定言说名不定。于能诠中说所诠故。无有此过。余处亦应如是安立。若所立量有不定过。或复决定同法等因有所成立。即名能破。是等难故。若现见力比量不能遮遣其性。如有成立声非所闻犹如瓶等。以现见声是所闻故。不应以其是所闻性遮遣无常。非唯不见能遮遣故若不尔者亦应遣常。第二无异相似。是似不成因过。彼以本无而生增益所立。为作宗因成一过故。此以本无而生极成因法证灭后无。若即立彼可成能破。第三无异相似。成立违害所立难故。成似由可烧等不决定故。若是决定可成相违可得相似。所立不定故成其似。若所立因于常亦有可成能破第二可得。虽是不遍余类无故似不成过。若所立无可名能破。非于此中欲立一切皆是无常。犹豫相似。谓以勤勇无间所发。得成立灭坏。若以生起增益所立。作不定过。此似不定。若于所立不起分别。但简别因生起为难。此似不成。由于此中不欲唯生。成立灭坏。若生若显悉皆灭坏。非不定故。义准相似。谓以颠倒不定为难故似不定。若非勤勇无间所发立常无常。或唯勤勇无间所发无常。非余可成能破。颂曰

  若因至不至　　三时非爱言
  至非至无因　　是名似因阙

论曰。若因至不至三时非爱言至非至无因者。于至不至作非爱言。若能立因至所立宗而成立者。无差别故应非所立。如池海水相合无异。又若不成应非相至。所立若成此是谁因。若能立因不至所立不至非因。无差别故应不成因。是名为至非至相似。又于三时作非爱言。若能立因在所立前未有所立。此是谁因。若言在后。所立已成复何须因。若俱时者。因与有因皆不成就。如牛两角。如是名为无因相似。此中如前次第异者。由俱说名似因阙故。所以者何。非理诽拨一切因故。此中何理唯不至同。故虽因相相应亦不名因。如是何理唯在所立前不得因名故即非能立。又于此中有自害过。遮遣同故。如是且于言因及慧所成立中有似因阙。于义因中有似不成。非理诽拨诸法因故。如前二因。于义所立俱非所作。能作性故。不应正理。若以正理而诽拨时。可名能破。颂曰

  说前无因故　　应无有所立
  名无说相似　　生无生亦然
  所作异少分　　显所立不成
  名所作相似　　多如似宗说

论曰。说前因无故应无有所立名无说相似者。谓有说言。如前所立若由此因证无常性此未说前都无所有。因无有故。应非无常。如是名为无说相似。生无生亦然者。生前无因故无所立。亦即说名无生相似。言亦然者。类例声前因无有故应无所立。今于此中如无所立。应知亦有所立相违。谓有说言。如前所立若如是声未生已前。无有勤勇无间所发。应非无常。又非勤勇无间所发故应是常。如是名为无生相似。所作异少分显所立不成名所作相似者。谓所成立所作性故犹如瓶等。声无常者若瓶有异所作性故可是无常何豫声事。如是名为所作相似。多如似宗说者。如是无说相似等多分如似所立说。谓如不成因过多言为显。或如似余。今于此中无说相似增益比量。谓于论者所说言词立无常性。难未说前因无有故。此似不成。或似因阙。谓未说前益能立故。若于此中显义无有。又立量时若无言说可成能破。无生相似。声未生前。增益所立难因无故。即名似破。若成立时显此是无可成能破。若未生前以非勤勇无间所发。难令是常义准分故。亦似不定所作相似乃有三种。若难瓶等所作性于声上无。此似不成。若难声所作性于瓶等无。此似相违。若难即此常上亦无是不共故。便似不定。或似喻过引同法故。何以故。唯取总法建立比量。不取别故。若取别义决定异故。比量应无。颂曰

  俱许而求因　　名生过相似
  此于喻设难　　名如似喻说

论曰。俱许而求因名生过相似者。谓有难言。如前所立瓶等无常。复何因证。此于喻设难名如似喻说者。谓瓶等无常俱许成就。而言不成似喻难故。如似喻说颂曰

  无常性恒随　　名常住相似
  此成常性过　　名如宗过说

论曰。谓有难言。如前所立声是无常。此应常与无常性合。诸法自性恒不舍故。亦应是常。此即名为常住相似。是似宗过。增益所立无常住故。以于此中都无有别。实无常性依此常转。即此自性本无今有暂有还无。故名无常。即此分位由自性缘名无常性。如果性等如是过类足目所说多分说为似能破。性最极成故。余论所说亦应如是分别成立。即此过类但由少分方便异故。建立无边差别过类。是故不说。如即此中诸有所说。增益损减有显无显。生理别喻品类相似等。由此方隅皆应谛察。及应遮遣诸有不善。比量方便作如是说展转流漫。此于余论所说无穷故不更说。又于负处。旧因明师诸有所说。或有堕在能破中摄。或有极粗。或有非理。如诡语类故此不录。余师宗等所有句义。亦应如是分别建立。如是遍计所执分等皆不应理。违所说相皆名无智。理极远故。又复此类过失言词。我自朋属论式等中多已制伏。又此方隅。我于破古因明论中已具分别。故应且止颂曰

  为开智人慧毒药　　启斯妙义正理门
  诸有外量所迷者　　令越邪途契真义

因明正理门论一卷


因缘心论颂

    No. 1654

    因缘心论颂

        龙猛菩萨作

  差别十二支　　能仁说缘生
  于烦恼业苦　　三中俱摄尽
  初八九烦恼　　二及十是业
  余七习是苦　　十二唯三摄
  从三生于二　　从二生于七
  一复生于三　　此有轮数转
  诸趣唯因果　　此中无众生
  唯从于空法　　还生于空法
  诵灯镜及印　　火精种梅声
  诸蕴相续结　　不移智应察
  于甚微细事　　若有见断者
  彼不善因缘　　未见缘生义
  此中无可见　　亦无少安立
  于真以观真　　见真而解脱

    因缘心论释

        龙猛菩萨造

此中有沙门。乐闻能听。善能忆持。能悟。能观。及具简弃。来诣师所。于如来教中。作如是问。薄伽梵。差别十二支。能仁说缘生。彼于何所摄。今欲乐闻。知彼问其真义。师即呼曰汝于烦恼业苦三中都摄尽。作此分别典切之语。此中十及二。故曰为十二支。即差别。故言差别。如车支分。故说为支。能寂身口。故名能仁言。能仁说者。宣畅解释。说之异名。彼非自性。决定士夫。假相自在。时自然随欲。化主。偶遇等所生。此是因缘所生。此差别十二支法。于烦恼业苦。递手相依。犹如束芦。于彼三中。并皆摄尽。言尽者。即是无余义也。问曰。何者烦恼。何者是业。何者是苦。此差别之法。当于何摄。答曰。初八九烦恼。差别十二支法。初是无明。第八是爱。第九是取。此三是烦恼所摄。何者是业。二及十是业。二是行。十是有。此二法是业所摄。余七皆是苦。烦恼业之所摄之余七种是苦。所摄应知。所谓识。名色。六入。触。受。生。老死。言皆者是惣摄之辞。即摄爱别离。怨憎会。求不得苦。是故此十二支法。于业烦恼苦中。并皆摄尽。言唯者。是其遮义。经中所说之法。此中摄尽。更无有余。问曰。此义已知。彼烦恼业苦。云何相生。请为解说。答曰。从三生于二。从三烦恼生于二业。从二生于七。谓上所说苦法。七复生于三。所谓诸烦恼。复从三烦恼。生于二业。此有轮数转。言有者。有其三种。所谓欲。色。无色。于中不息。而作流转。彼诸异生世间。而自流转浪。言此者。显不定义。非如流转。次第生于诸有。此不定也。问曰。何者是身之自在众生耶。彼之作用。其事云何。答曰。诸趣惟因果。惟除假名。此中无众生。此是真实义。非假立有。假立之境。不成实物。问曰。若如是者。谁从此世至于他世。答曰。无有极微等法。从于此世。移至他世。虽然唯从于空法。还生于空法。从无我我所。烦恼业。五种空因。还生空无我我所。七种苦果之法。彼则无我我所。彼此手无我我所。虽然从自性无我之法。还生自性无我之法。应如是知。作如是说。此中问曰。从自性无我之法。还生自性无我之法者。有何譬喻。此中答曰。诵灯镜及印。火精种梅声。已如是等喻。及假喻立成自性无我及成就彼世应知。譬如师所诵者。若转至弟子。师后更无言说。是故不至。彼弟子诵者。亦不从余得。成无因果故。如师所诵临终心识。亦复如是。成常过故。不至他世。彼世亦不从余得。成无因果故。如师所诵。与弟子诵者。即彼异彼。不易施设。如是依彼临终心识。生分心识。得生者。亦复如是。即彼异彼。不易施设。如是从灯生灯依于面像。镜中现其影像。从印成文。从精出火。从种生芽。从梅生涎。从声出向。即彼异彼。不易施设。如是。诸蕴相续结。不移智应察。言蕴者。即色受相行识蕴也。言相续结者。彼已从彼因。所生余者是也。无有极微等法。从于此世。移至他世。是故流转。从于虚妄分别习气而生。后言应者。即是逆观。义当知反。彼应观诸法无常苦空无我者。则不愚诸事。若不遇者。则无有贪。若无有贪嗔则不生。若无有嗔则无有业。若无有业。则无有取。若无有取。则不造后有。若无有者而则不生。若不生者。即于身心而苦不生。如是不集五种因故。即相余处。而果不生。此果解脱。是故断除。断常等诸恶见也。此中有二讼

  于甚微细事　　若有见断者
  彼不善因缘　　未见缘生义
  此中无可见　　亦无少安立
  于真以观真　　见真如解脱

因缘心论释一卷


缘生论

    No. 1652 [No. 1653]

    缘生论序

原是一心。积为三界。痴流漫远。苦树郁高。欲讨其际。难测其本。理极实相之门。筌穷假名之域。五因七果。十有二分缘生之法。总备于此。凡则迷而起妄。圣则悟以通真。下似免浮。上如象度。大哉妙觉。渊乎洞尽。十地与双林俱畅。闻城共稻芋咸敷。至若此经独苞彼例。彼所未说。此乃具演。攀缘为首。对治为末。总则一十一门。别则百二十问。其旨微而密。其词约而隐。经之纲目。摄在兹焉。并有圣者郁楞迦。附此经旨作论。显发其论也。遍取三乘之意。不执一部之筌。先立偈章。后兴论释。偈有三十。故亦名三十论也。大业二年十月。南贤豆国(旧名天竺者讹也)三藏法师达磨笈多。与故翻经法师彦琮。在东都上林园。依林邑所获贤豆梵本。译为隋言。三年九月其功乃竟。经二卷。论一卷。三藏师。究论闲明。义解沉密。琮法师。博通经论。兼善梵文。共对叶本。更相扣击。一言靡遗。三覆逾审。辞颇简质。意存允正。比之昔人。差无尤失。真曰法灯。足称智藏。愿穷后际。常益世间。云尔

缘生论

        圣者郁楞迦造

        大隋南印度三藏达磨笈多译

  从一生于三　　从三转生六
  六二二更六　　从六亦生六
  从六有于三　　此三复有三
  三复生于四　　四复生于三
  从三生于一　　彼一复生七
  于中所有苦　　牟尼说皆摄
  十二种差别　　善净说为空
  缘生分力故　　应知十二法
  无智与业识　　名色根三和
  知渴及以取　　集出熟后边
  初八九烦恼　　第二第十业
  余七皆是苦　　三摄十二法
  初二是过去　　后二未来时
  余八是现在　　此谓三时法
  恼起业感报　　报还生烦恼
  烦恼复生业　　亦由业有报
  离恼何有业　　业坏亦无报
  无报则离恼　　此三各自灭
  五分因生果　　名为烦恼业
  七分以为果　　七种苦应念
  因中空无果　　因中亦无因
  果中空无因　　果中亦无果
  因果二俱空　　智者与相应

(梵本一偈今为一偈半)

  世中四种分　　因果合故有
  烦恼业果合　　念欲为六分
  有节所摄故　　二节及三略
  因果杂为节　　三四节总略
  二二三三二　　苦时有五法
  作者胎境界　　发转生流行
  迷惑发起果　　报流果为二
  相应根分中　　一一三二分
  热恼贫乏果　　转出津流果
  相应他分中　　二一一一法
  此有十二种　　等力缘自生
  无众生无命　　无动以慧知
  无我无我所　　无我无我因
  四种无智空　　余分亦如是
  断常二边离　　此即是中道
  若觉已成就　　觉体是诸佛
  觉已于众中　　仙圣说无我
  曾于城喻经　　导师说此义
  迦栴延经说　　正见及空见
  破逻具腻经(张宿名也)
  亦说殊胜空　　缘生若正知
  彼知空相应　　缘生若不知
  亦不知彼空　　于空若起慢
  则不厌受众　　若有彼无见
  则迷缘生义　　缘生不迷故
  离慢彼知空　　及厌受众故
  不迷业果合　　业作缘续生
  亦非不缘此　　空缘当有此
  业报受用具　　十二分差别
  前已说缘生　　彼烦恼业苦
  三中如法摄　　三中生于二
  二中生于七　　七中复生三
  有轮如是转　　因果诸生世
  无别有众生　　唯是于空法
  还自生空法　　藉缘生烦恼
  藉缘亦生业　　藉缘亦生报
  无一不有缘　　诵灯印镜音
  日光种子酢　　众续不超到
  智应观彼二

缘生三十论本竟缘生三十论我当随顺次第解释

  从一生于三　　从三转生六
  六二二更六　　从六亦生六

从一生于三者。一谓无智。此无智者说名无明。于苦集灭道中。不觉知故。名为无智。由无智故。则有福非福不动。说名三行。及身行口行心行等从其转生。从三转生六者。从彼三行生六识身。所谓眼识耳识鼻识舌识身识意识。六二者。彼六识身转生二种。所谓名色。二更六者。名色二种转生六入。所谓眼入耳入鼻入舌入身入意入。从六亦生六者。从彼六入转生六触。所谓眼触耳触鼻触舌触身触意触

  从六有于三　　此三复有三
  三复生于四　　四复生于三

从六有于三者。从彼六触转生三受。所谓乐受苦受不苦不乐受。此三复有三者。还从彼等三受。转生三种渴爱。所谓欲渴爱有渴爱无有渴爱。三复生于四者。从彼三种渴爱转生四取。所谓欲取见取戒苦行取我语取。四复生于三者。从彼四取转生三有。所谓欲有色有无色有

  从三生于一　　彼一复生七
  于中所有苦　　牟尼说皆摄

从三生于一者。还以彼等三有作缘。生当来一种生。彼一复生七者还从彼一。当有老死忧悲苦恼困等七种。于中所有苦牟尼说皆摄者。于中无明为始困为终。无量种苦。世尊略说。皆此所摄

  十二种差别　　善净说为空
  缘生分力故　　应知十二法

十二种差别善净说为空者。此无智等各别不杂有十二分。又彼皆自性空应当正见。如此所说唯是空法。自生空法。缘生分力故应知十二法者。若以次第生分力故。彼十二法如是应知。彼中迷惑相者是无明。彼行句处。积集当有相者是行。彼识句处。次受生分转出相者是识。彼名色句处。名身色身和合相者是名色。彼六入句处。相安置相者是六入。彼触句处。眼色识。共聚相者是触。彼受句处。爱不爱受用相者是受。彼渴爱句处。无厌足相者是渴爱。彼取句处。执持摄取相者是取。彼有句处。名身色身相者是有。彼生句处。五众出生相者是生。彼老句处。成熟相者是老。彼死句处。命根断者是死。彼忧句处。高举相者是忧。彼悲句处。哭声者是悲。彼苦句处。身烧热相者是苦。彼恼句处。心逼恼相者是恼。彼困句处。极疲乏相者是困

  无智与业识　　名色根三和
  知渴及以取　　集出熟后边

于中无智者是无明。业者是行。识者是解。名色者是五众总聚。根者是入。三和者是触。知者是受。渴者是渴爱。取者是执持。集者是有。出者是生。熟者是老。后边者是死

又此等差别相摄。我当次第说之。于中业烦恼报差别

  初八九烦恼　　第二第十业
  余七皆是苦　　三摄十二法

三烦恼者。无明渴爱取。二业者。行有。七报者。识名色六入触受生老死等。此十二法三种所摄

又时差别

  初二是过去　　后二未来时
  余八是现在　　此谓三时法

无明行初二种过去时中。生老死后二种未来时中。识名色六入触受渴爱取有八种。现在时中

又此等各各次第相生

  恼起业感报　　报还生烦恼
  烦恼复生业　　亦由业有报

烦恼业报三种如前所说。由彼烦恼故有业。由业故有报。还由报故有烦恼。由烦恼故有业。由业故有报

问曰。由烦恼尽各各寂灭。其义云何。答曰

  离恼何有业　　业坏亦无报
  无报则离恼　　此三各自灭

若其此心无烦恼染则不集业。若不作业则不受报。若灭报者亦不生烦恼。如是此三各各自灭

又此等有因果分

  五分因生果　　名为烦恼业
  七分以为果　　七种苦应念

五种因名为烦恼业者。如前所说。无明行渴爱取有是也。七种果转生者。亦如前所说。七种苦所谓识名色六入触受生老死是也。又此因果二种空

  因中空无果　　因中亦无因
  果中空无因　　果中亦无果
  因果二俱空　　智者与相应(梵本本一偈今为一偈半)

若此所说因果二种。于中若因空果果亦空因。如是因亦空因果亦空果。于此四际当与相应

又此更有别分

  世中四种分　　因果合故有
  烦恼业果合　　念欲为六分

世中四种分因果合故有者

道中五种因。及七种果。和合故总略为四种。次第有四种分。于中无明行过去时中。二法为第一分。识名色六入触受现在时中。为第二分。渴爱取有亦是现在时中。为第三分。生老死未来时中。二法为第四分。此谓四种分也。烦恼业果合念欲为六分者。烦恼业报三种和合。以次第故。于二根本有六种分。于中无明所摄。乃至受以无明为根。渴爱所摄。乃至老死以渴爱为根。无明根中无明是烦恼分。行是业分。识名色六入触受是报分。渴爱根中渴爱取是烦恼分。有是业分。生老死是报分

又节分总略

  有节所摄故　　二节及三略
  因果杂为节　　三四节总略

有节为本发起二节。所谓有生两间。为第一节。行识两间。是第二节。此二并为业果节。受渴爱中因果共杂。是第三节。此之三节复为四种总略。无明行二种。是第一总略。识名色六入触受五种。是第二总略。渴爱取有三种。是第三总略。生老死二种。是第四总略。此谓三节及四总略

又此等法中住时差别

  二二三三二　　苦时有五法
  作者胎境界　　发转生流行

二二法者。无明行说为二种。识名色说为二种。三三者。六入触受说为三种。渴爱取有说为三种。又二者。生老死说为二种。此等五法。是苦时中作者胎藏境界发转出生。于中流行。如数当知。于中无明行二种。说为苦时中作者。应如是见。识名色二种。说为苦时中胎藏。应如是见。六入触受三种。说为苦时中境界。渴爱取有三种。说为苦时中发转。生老死二种说。为苦时中出生

又果差别

  迷惑发起果　　报流果为二
  相应根分中　　一一三二分

如前所说。此无明根及渴爱根。于无明根第一分中。迷惑发起报流。名四种果。一一三二数分之中。随其次第当与相应。于中无明是迷惑果。行是发起果。识名色六入是报果。触受是津流果。复有余残果

  热恼贫乏果　　转出津流果
  相应他分中　　二一一一法

如前所说。第二渴爱根分中。热恼贫乏转生津流果等。随其数分二一一一。于此法中当与相应。于中渴爱取是热恼果。有是贫乏果。生是转出果。老死是津流果。如是此等。则有八果

  此有十二种　　等力缘自生
  无众生无命　　无动以慧知

如是无明为初。老死为边。有十二分。平等胜故。各各缘生。而无众生无寿命无动作。以慧应知。于中无众生者。以不牢固故。无寿命者。以无我故。无动作者。以无作者故

  无我无我所　　无我无我因
  四种无智空　　余分亦如是

于无我中无智。无我所中无智。无我中无智。无我因中无智。此中以无我故。四种无智空。如四种次第无智空。如是行等余分。亦皆是空。应当知之

  断常二边离　　此即是中道
  若觉已成就　　觉体是诸佛

有是常摄。无是断摄。如此二边彼作缘彼处。彼处诸有转生。离此二边即是中道。若无智诸外道则堕于边。若已觉悟诸佛世尊。则为觉体。于此世间独能成就。余人悉无此义

  觉已于众中　　仙圣说无我
  曾于城喻经　　导师说此义

彼亦是此中道觉已。于诸众中佛说无我。所谓比丘。有我我所。小儿凡夫无闻之类。顺堕假名。于中无复我及我所。比丘。生时但苦生。灭时但苦灭。如城喻经中。导师已说此义。又

  迦栴延经说　　正见及空见
  破逻具腻经(张宿名也)　　亦说殊胜空

此等三经。及以余处。如是之相。世尊已说。彼亦是此

  缘生若正知　　彼知空相应
  缘生若不知　　亦不知彼空

于前所说缘生。若有正知彼知无异。彼复何知。谓知于空。缘生若不知亦不知彼空者。于此缘生若其不知。亦于彼空不能解入。应当知之

  于空若起慢　　则不厌受众
  若有彼无见　　则迷缘生义

于空若起慢则不厌受众者。若起空慢。则于五受众中。不生厌离。若有彼无见则迷缘生义者。若复由于无见迷此缘生义故。则于四种见中。随取何见。一者断见。二者常见。三者自在化语。四者唯依宿世所作

  缘生不迷故　　离慢彼知空
  及厌受众故　　不迷业果合

缘生不迷故离慢彼知空者。于前所说各各缘生中若无迷心。及于摄取我我所中。若得离慢。彼则如法能入于空。及厌受众故不迷业果合者。五受众中摄取我我所故。则遍世间轮转不息。于彼受众起厌离故。于此业果相续。则无颠倒。亦不迷惑

又问。此义云何

  业作缘续生　　亦非不缘此
  空缘当有此　　业报受用具

业作缘续生亦非不缘此者。烦恼业染如前所说。彼以如是净不净业。推遣众生。傍及上下相续而生。若非此业则不作缘。若不然者。则未作竟而来。及已作竟而失(来谓业未作竟其果即来失谓业已作竟其果便失)。空缘当有此业报受用具者。若由此等净不净业。有报受用。则自性是空。本无有我作缘发生。彼自性空亦应当知。彼义今更略说

  十二分差别　　前已说缘生
  彼烦恼业苦　　三中如法摄

无明为初。老死为边。是十二分缘生差别。如前所说。彼中三是烦恼。二是业。七是苦。皆已摄入

  三中生于二　　二中生于七
  七中复生三　　有轮如是转

无明渴爱取三种所生。行有二种。彼二所生。识名色六入触受生老死七分。彼七分中如前所说。还生三种。彼三复二。其二更七。是故二种次第不断。此之有轮如是普转

  因果诸生世　　无别有众生
  唯是于空法　　还自生空法

因果诸生世无别有众生者。无明行渴爱取有五种名因。识名色六入触受生老死七种名果。此等所有普遍世间。若我若众生若寿若生者。若丈夫若人若作者。是等为首。次第分别其唯虚诳。应当知之。彼云何生。唯是于空法还自生空法。谓自性空中假名烦恼业果。唯有别空假名。烦恼业果法生。此是其义

  藉缘生烦恼　　藉缘亦生业
  藉缘亦生报　　无一不有缘

若有烦恼。则有种种无量种业。及种种业所生果报。彼皆共因共缘。应当知之。无有一处无因缘者

又为明彼义。今更说譬喻

  诵灯印镜音　　日光种子酢
  众续不超到　　智应观彼二

如诵。有教诵者受诵者。所有教诵不到受诵。何以故。教诵者仍安住故。其教诵者亦不相续。何以故。自不生故。如灯次第生非是初灯。超到亦非第二。无因而生。如是印与像二种。面与镜二种。音与响二种。日与火二种。种子与芽二种。酢与舌涎二种。此等所有皆不超到。亦非不生。亦非无因。而生彼二种。五受众相续到时。非是初受众。超到而第二受众。亦非不生。亦非无因。而生智者。于此受众相续不超。而次第到。应当正观

又外内受用。俱有十种。皆应当见。于中外十种者。一者非常故。二者非断故。三者不超到故。四者无中间故。五者非彼体故。六者非别异故。七者无作者故。八者非无因故。九者念念空故。十者同类果相系故。彼外所有种子灭无余故。非常芽出生故。非断种子灭无余已。其芽本无今有生故不超到。彼所相续无有断绝。因果相系故无中间。种子芽差别故非彼体。从彼出生故非别异。因缘和合故无作者。种子为因故非无因。种子芽茎枝叶花果等传传相生故念念空。甜酢碱苦辛涩随因差别果转出故。同类果相系于中。内十种者一者死边受众灭无余故非常。二者得次生分受众故非断。三者死边受众灭无余已。次生分受众。本无今有生故不超到。四者受众相续无有断绝。因果相系故无中间。五者死边次生分受众差别故非彼体。六者从彼出生故非别异。七者因缘和合故无作者。八者烦恼业为因故非无因。九者迦罗逻。頞浮陀箄尸。伽那奢佉。出胎。婴孩。童子。少年。长宿等。传传相生。故念念空。十者善不善熏。随因差别果转出故。同类果相系

又有三偈

  如灯炎转生　　识身亦如是
  先际与后际　　亦无有聚集
  无生亦有生　　破坏无相着
  生已亦无住　　而此作业转
  若于彼缘生　　而能观知空
  为其施设教　　彼亦是中道

于中无明行渴爱取有。是为集谛。识名色六入触受生老死。是为苦谛。彼等十二分灭。是为灭谛。若于缘生如实能知。是为道谛

缘生论


赞法界颂

    No. 1675

赞法界颂

        圣龙树菩萨造

        西天北印度乌填曩国帝释宫寺三藏传法大师赐紫沙门臣施护奉　诏译

  归命十方佛　　法身及报化
  愿共诸众生　　速成法界性
  轮回三恶道　　法界理凝然
  本来常清净　　诸相不能迁
  寂静如虚空　　处处悉周遍
  体皆离彼此　　非深复非浅
  乳未转变时　　酥醍醐不见
  烦恼未伏除　　法界无由显
  如酥处乳中　　酥本妙光莹
  法界烦恼覆　　圆满体清净
  如灯被障碍　　非能照余物
  无明恒覆心　　法界非明了
  如灯离障碍　　处处物能照
  烦恼破坏时　　真如恒显现
  初中及最后　　二障不能扰
  如净琉璃珠　　恒时光照曜
  光明物所障　　被障明非见
  法界烦恼覆　　真如理难显
  圆寂体光洁　　轮回不能染
  勤求趣法界　　轮回非能揜
  如米糠缠裹　　谷体米非无
  烦恼覆真如　　真如烦恼有
  如谷去其糠　　米体自然见
  若离烦恼糠　　法界理方显
  妄执有世间　　芭蕉终无实
  法界非世间　　亦非虚妄见
  如人饮甘露　　热恼悉皆除
  若证法界性　　烦恼热皆弃
  灭除烦恼焰　　法界甘露现
  一切有情中　　高下皆平等
  体实果不生　　执种果非有
  智慧出生时　　有为非法界
  法界本无处　　究竟方可证
  清净恒光洁　　日月皆莹净
  法界无垢染　　如龙夜雨尘
  况似罗睺面　　光明恒灿然
  譬如火浣布　　处火能离染
  垢去布犹存　　光明转莹净
  贪爱令心染　　虚妄有轮回
  亦如火浣布　　真空妄非有
  三毒生死本　　智慧火能烧
  法界体常有　　朗然恒照曜
  烦恼染称垢　　世尊恒所宣
  垢灭真如显　　如汲地中泉
  法界体无垢　　根随能覆藏
  若除烦恼尽　　莹净叵难量
  法界本无我　　二形及女男
  体无虚妄执　　何处更思惟
  法界离憎爱　　根尘境本无
  虚妄执为因　　差别从此生
  真空非苦恼　　贪爱苦恼因
  耽染由妄想　　三界乃轮回
  怀孕在于腹　　婴子未言见
  二障覆真如　　法界不能证
  种种生疑虑　　见慢及恚痴
  妄计有真实　　真实计非有
  兔角体非有　　妄执令真实
  法界离妄执　　妄执真非有
  如色必破坏　　微尘犹可知
  法界非破坏　　三时不能得
  有生还有灭　　荣辱亦皆随
  法界非生灭　　云何言所知
  兔角本非有　　三世犹可思
  真空非兔角　　思虑不能知
  真空称善逝　　色相悉皆亡
  应化随缘有　　修因离执非
  圆通如日月　　水现影皆同
  色声双泯绝　　差别云何有
  三世可寻思　　生缘时决定
  若悟己身法　　己身云何有
  如水居热际　　处热觉悟非
  寒际理亦然　　圆通皆如是
  心恒烦恼覆　　迷惑不能了
  若离烦恼缠　　觉悟而非有
  如眼观诸色　　离障能照曜
  真空理亦然　　照曜离生灭
  耳识闻于声　　离妄及分别
  法界性亦然　　分别妄非有
  鼻能嗅诸香　　妄执性非有
  色相二俱亡　　真空亦如是
  舌根自性空　　味界恒远离
  识空体亦然　　法界理如是
  身根自性净　　冷暖触非有
  法界理亦然　　触处常远离
  意缘法称最　　自性恒远离
  诸法性本空　　圆通理如是
  见闻及觉知　　相应法亦空
  了绝诸妄想　　见闻理亦非
  根尘起妄执　　清净体源无
  迷执有根尘　　根尘理非有
  世间并出世　　空性本无差
  我法由迷起　　遍计自轮回
  法界理清净　　贪嗔痴本无
  迷悟从心起　　三毒法假名
  迷执自缠缚　　了达假名智
  菩提非近远　　三世理非有
  烦恼笼迷执　　世尊经所宣
  智生惑染灭　　妄执勿相缠
  去来执最胜　　体空犹可思
  菩提非妄执　　正证亦知非
  水乳同一处　　鹅饮乳非杂
  生空烦恼离　　二障亦非杂
  妄执我非无　　了达本非有
  涅盘清净理　　二我俱非立
  三檀齐修施　　尸罗离过非
  忍因端正果　　精进勇勤依
  静虑令心止　　般若用无疑
  愿兼方便力　　安住胜菩提
  菩提难妄执　　真空生灭无
  了达空本性　　二相亦非有
  乳糖离甘蔗　　离蔗糖非有
  三乘趣菩提　　离种体非有
  守护稻谷种　　芽茎必得生
  守护菩提种　　菩提从此起
  譬如于黑月　　光明未能见
  有情烦恼缠　　真如未明显
  月初光虽有　　渐渐而增长
  初地证菩提　　菩提未圆满
  十五月圆满　　处处光皎洁
  解脱显法身　　法身理无缺
  染污意相应　　缠缚俱生灭
  解脱一切障　　三世悟非有
  初大僧祇满　　三檀普遍修
  断除分别障　　欢喜智难俦
  三业误兼犯　　防非重及轻
  尸罗圆满戒　　离垢独标名
  二障恒时染　　俱空慧刃除
  发光能照曜　　破灭渐无余
  远离根随染　　渐增焰慧威
  菩提称最胜　　烧照转光辉
  真俗称二智　　相应互起违
  合令无所碍　　难胜事恒时
  十二缘生智　　巡环理趣全
  甚深称最胜　　般若现于前
  世俗二乘行　　久修道已明
  相无功用满　　最后称远行
  智用无分别　　恒时任运成
  众魔降退散　　不动独彰名
  善慧名无碍　　十方演法希
  身云甘露雨　　应物最堪依
  众德犹如水　　虚空喻似身
  重粗皆蔽塞　　大法智称云
  审谛轮回事　　孰能免业牵
  要知无苦恼　　净土勿相缠
  归命佛真子　　位登智慧云
  细微皆断尽　　超苦离诸尘
  灌顶诸光照　　根尘普遍身
  金刚寂大定　　众苦勿相亲
  大宝花王座　　俱胝众妙成
  庄严皆普遍　　功德实难思
  十力兼无畏　　三身四智圆
  六通恒自在　　应物化机缘
  照曜如圆月　　恒时焰炽燃
  十方无不遍　　灿烂转光鲜
  永绝缘生染　　恒时处涅盘
  菩提称最胜　　化益物情欢
  智用深如海　　随机现应身
  水清来月影　　处处度迷津
  况似颇胝宝　　随缘现影同
  物情根有感　　周普事无穷
  饿鬼恒饥渴　　不能见水泉
  众生无少信　　宿业自萦缠
  化现身诸相　　光明皆灿然
  佛虽恒在世　　不睹宿无缘
  晓了尘沙界　　根随染久无
  二空殊胜智　　妙用化童愚
  清净绝诸垢　　自他受用身
  恒居色究竟　　利益五乘人
  救护众生苦　　俱胝寿命长
  二严无有尽　　功德叵难量
  佛演一乘法　　随机悟浅深
  莲花无垢染　　玉本绝瑕侵
  少分而称赞　　广宣理趣玄
  愿将诸功德　　普利施人天

赞法界颂


彰所知论

    No. 1645

    彰所知论序

        元正奉大夫同知行宣政院事廉复撰

夫出三界者惟佛。佛以大事因缘故。出现于世。悯化群生。此亘古不磨之善也。大元帝师。洞彻三乘。性行如春。仁而穆穆不可量。裕皇潜邸。久知师之正传。敬诣请师敷教于躬。师笃施静志。弘扬帝绪。大播宗风。彰其所知。造其所论。究其文理。推其法义。皎如日月。广于天地。盖如来之事。非圣者孰能明之。总统雪岩翁英姿间世。听授过人。久侍师之法席。默译此论。见传于世。公昔与予会闽。交情相照。爱同昆仲。公固肯予为序。予抗尘幻海。绝笔疏砚。岂足发正教之光耶。公笑之曰。汝何谦哉。予不敢辞。遂序焉

彰所知论卷上

        元帝师发合思巴造

        宣授江淮福建等处释教总统法性三藏弘教佛智大师沙罗巴译

    敬礼金刚上师

    敬礼诸佛菩萨

遍知见所知。怜悯示群生。敬礼最上智。当演彰所知。谓器情世界。道法与果法。并诸无为法。略摄列为五

    器世界品第一

谓器世界所成之体。即四大种。种具生故。地坚水湿火暖风动。是等大种。最极微细者曰极微尘。亦名邻虚尘。不能具释。彼七邻虚为一极微。彼七极微为一微尘。彼七微尘为一透金尘。彼七透金尘为一透水尘。彼七透水尘为一兔毛尘。彼七兔毛尘为一羊毛尘。彼七羊毛尘为一牛毛尘。彼七牛毛尘为一游隙尘。彼七游隙尘为一虮量。彼七虮量为一虱量。彼七虱量为一麦量。彼七麦量为一指节。三节为一指。二十四指横布为一肘量四肘为一弓。五百弓量成一俱卢舍。八俱卢舍成一由旬。此是度量世界身相。成世界因。由一切有情共业所感。云何成耶。从空界中十方风起。互相冲击坚密不动。为妙风轮。其色青白极大坚实。深十六洛叉由旬。广量无数。由暖生云名曰金藏。降澍大雨。依风而住。谓之底海。深十一洛叉二万由旬。广十二洛叉三千四百半由旬。其水搏击上结成金。如熟乳停上凝成膜。即金地轮故水轮减唯厚八洛叉。余转成。金厚三洛叉二万由旬。金轮广量与水轮等。周围即成三倍。合三十六洛叉一万三百五十由旬。其前风轮娑婆界底。地水二轮四洲界底。于地轮上复澍大雨。即成大海。被风钻击。精妙品聚成妙高山。中品聚集成七金山。下品聚集成轮围山。杂品聚集成四洲等。其妙高体。东银南琉璃西玻璃珂北金所成。余七唯金。四洲地等杂品所成。彼轮围山唯铁所成。其妙高量入水八万緰缮那。比于余山皆悉高妙。名曰妙高。然后次第七金山者。一踰乾陀罗山。高四万由旬。二伊沙陀罗山。高二万由旬。三佉得罗柯山。高一万由旬。四修腾娑罗山。高五千由旬。五阿输割那山。高二千五百由旬。六毗泥怛迦那山。高千二百五十由旬。七居民陀罗山。高六百二十五由旬(藏论疏云。一持双山。二持轴山。三檐木山。四善见山。五马耳山。六象鼻山。七鱼嘴山)。四大洲外有轮围山。高三百一十二由旬半。彼等广量各各自与出水量同。七金山间诸龙王等游戏之处。名曰戏海。八山间七海近妙高者。一踰乾陀罗海。广八万由旬。二伊沙陀罗海。广四万由旬。三佉得罗柯海。广二万由旬。四修腾娑罗海。广一万由旬。五阿输割那海。广五千由旬。六毗尼怛迦那海。广二千五百由旬。七尼民陀罗海。一千二百五十由旬。盈八功德水。八山七海其相咸方。外海味碱。尼民陀罗至轮围山。二山相去三洛叉二万二千由旬。其外海水虽无有分。由妙高色东海色白。南海色青。西海色红。北海色黄。现是等色。故称四海。是彼周边三十六洛叉。七百五十由旬。外轮围山周围三十六洛叉。二千六百二十五由旬。其外海南赡部洲者。状若车厢狭。向铁围三由旬半。余三边者。各二千由旬。周围六千三由旬半。有二中洲。东遮摩罗(此云猫牛)。西婆罗摩罗(此云胜猫牛)。赡部中央摩竭陀国。三世诸佛所生之处。次此向北度九黑山。有大雪山名具吉祥。其山北边有香醉山。是二山间有大龙王。名曰无热。所居之池曰阿耨达(此云无热)。其状四方面各五十由旬。周围二百由旬。池内遍满八功德水。从此池内出四大河。东[石*克]伽河。从象口中流出银沙共五百河流归东海南。辛渡河从牛口中流出琉璃沙。共五百河流归南海。西缚刍河。从马口中流出玻璃珂沙。共五百河流归西海。北悉怛河。从狮子口流出金沙。共五百河流归北海。是彼四河从无热池。右绕七匝随方而流。是香山北度二十由旬。彼处有岩名难陀岩。面各五十由旬。周围二百由旬。高三由旬半。又有八千小岩。其岩北边度二十由旬。有娑罗树王。名曰善住。其根入地四十弓量。高八十弓量。七重行树罗列围绕。东边度二十由旬。有缓流池。其状圆相广五十由旬。周围一百五十由旬。又有八千小池。盈八功德水。内有莲华。叶若牛皮。其茎如轴。华若车轮。味美如蜜。是处又有帝释临战所乘象王。名曰善住。与八千象。寒四月时住金岩。所热四月时住善住。所雨四月。时住缓流。池无热池侧有赡部。树果实味美其量如瓮。熟时堕水出赡部音。龙化为鱼吞啖是果。残者遇流成赡部金。由此树名故号赡部。此洲向西有乌佃国。大金刚宫持种所居。金刚乘法从彼而传。南海之中山曰持船。观音菩萨居止其顶。圣多罗母居止山下。东有五峰。文殊菩萨居止其上。有十六大国千数小国。又有三百六十种人。有七百二十种异音。其外海东洲曰胜身。状若半月。对妙高边三百五十由旬。余边六十由旬。周围六千三百五十由旬。其洲二边有二中洲。北提诃(此云身)。南毗提诃(此云胜身)。是彼三洲越余洲等七多罗树。或曰洲人相貌端严其身胜故名曰胜身。其外海北洲曰鸠娄。其状四角畟方相似边各二千由旬。周围八千由旬。其洲二边有二中洲。一名鸠娄(此云有胜)。二高罗娑(此云有胜边)。彼洲人等所有受用出如意树。临殁七日其如意树出不美音。报曰当七日死。或曰洲人卑舌即割食肉鬼音。故曰鸠娄是不美音。其外海西州曰牛货。形如满月。径二千五百由旬。周围七千五百由旬。有二中洲。南舍搋(此云具谄)。北嗢怛罗曼怛哩拏(此云仪上)。彼洲人等多宝牛货。故曰牛货洲。海山等向下皆悉八万由旬。近金地故。近赡部洲。星割棘洲金洲月洲等者。系赡部洲。余大洲等小洲亦尔。次上空中四万由旬。纯净无碍。胜坚风轮从右而旋。日月星宿空居天等。依止而住。日轮者。火珠所成。径五十一由旬。周围百五十三由旬。厚六由旬零十八分。上有金缘。其上复有金银琉璃玻璃珂等。秀成四角。日天子等所居宫殿。由风运行一昼一夜绕四大洲。日行向北时日即长。南行时短。行南北间时昼夜停。由游处光即有寒暑。为冬夏际。北行六月南行六月。行至中道曰日月回星轮。历遍谓曰一岁。月轮者。水珠所成。径五十由旬。周围百五十由旬。厚六由旬零十八分。其上复有金银琉璃玻璃珂等。秀成四角。月天子等所居宫殿。是彼日月相去远近。自影增减。由增一分即生上半。十五分毕谓曰圆满。由减一分即生下半。自影覆彼。十五分毕曰不圆满。由增减故名曰宿空。由一昼夜名曰宿地。如是三十名曰一月。诸星宿者。空居天宫诸宝所成。其状皆圆。小一牛吼。中三牛吼。大六牛吼。周围三倍系四王众。其妙高山有四层级。始从水际向上相去十千由旬。即初层级。从妙高山傍出十六千由旬。向上相去一万由旬。即二层级。傍出八千由旬。向上相去一万由旬。即三层级。傍出四千由旬。向上相去一万由旬。即四层级。傍出二千由旬。彼妙高山其顶四角。各秀一峰。高四由旬半。广百二十五由旬。周围五百由旬。有药叉神于中止住。是山顶上三十三天中央城曰善见。纯金所成。高一由旬半。面各二千五百由旬。周万由旬。其城体金。俱用百一杂宝严饰。其地柔软如兜罗绵。是城四面有一万六千宝柱宝桴宝椽宝檐。四面四门。又有千数阙一小门。四大衢道有诸小衢。其四门侧五百天子。皆服坚铠守护是门。城中有帝释殿。曰最胜处。亦曰殊胜殿。其状四方。高四百由旬半。面各二百五十由旬。周千由旬。百一却敌。一一却敌各有七楼。一一宝楼各七小楼。一一小楼各七池沼。一一池沼各七莲华。一一华上各有七数童男童女。奏种种乐歌舞欢娱。善见城东有诸所乘。曰众车苑。高千由旬。南临战处曰粗恶苑。西诸行处曰相杂苑。北游戏处曰欢喜苑。纵广同前。其苑等外度二十由旬。有善地曰众车粗恶相杂欢喜。量同四苑。善见东北有如意树。名波利阇多。亦名圆生树。根深五十由旬。高百由旬。枝条傍布五十由旬。能施欲乐。下有盘石。曰阿[口*栗](二合)摩丽歌。色白如[疊*毛]。面各五十由旬。周二百由旬。善见西南诸天集处。名善法堂。周九百由旬。其状圆相。是堂中央有帝释座。纯金所成。其座周围有三十二辅臣之座。咸皆布列三十三天。向上度八万由旬。于空界中依风而住。诸宝所成。离诤天宫量。若妙高山顶二倍。上度一亿六万由旬。于空界中依风而住。诸宝所成。兜率天宫量如离诤。纵广二倍。上度三洛叉二万由旬。于空界中依风而住。诸宝所成。化乐天宫量如兜率。纵广二倍。上度六洛叉四万由旬。于空界中依风而住。诸宝所成。他化自在天宫量。同化乐。纵广二倍。此即欲界。上有初禅。如是四洲七山妙高轮围。欲界六天并初禅等。谓四洲界。一数至千为小千界。一小铁围山围绕。此小千界一数至千。为中千界一中铁围山围绕。此中千界一数至千。为三千大千世界。一大铁围山围绕。如是有百亿数四洲界等。皆悉行布铁围山等。诸洲山间黑暗之处。无有昼夜举手无见。初禅天量等四洲界。二禅天量等小千界。三禅天量等中千界。四禅天量等三千大千世界。其相去量皆倍倍增。谓曰色界。无色界者。无别处所。若有生者。何处命终即彼生处。住无色定故曰无色

    情世界品第二

谓情世界总有六种。一者地狱。二者饿鬼。三者傍生。四者人。五者非天。六者天。此等六种名义云何。谓斫坏肢体故曰地狱。饥渴所逼故曰饿鬼。傍覆而行故曰傍生。意多分别故名曰人。摩[少/兔]沙义身及受用。虽与天同微分鄙劣。或由无酒故曰非天。阿修罗义。从梵身生。游戏娱乐。或应供养故谓曰天。是提婆义。地狱者。赡部洲下过二万由旬。旷廓四方二万由旬。纯铁所成火焰洞然。有八热狱。一曰更活。二曰黑绳。三曰众合。四曰号叫。五曰大号叫。六曰炎热。七曰大炎热。八曰无间。更活狱者。生彼有情先业所感。执众器仗互起冤憎递相斫害。段段堕落闷绝暂死。空音更活。彼等有情即便更活。复相斫害。彼寿量者。四天王天。一生之期为一昼夜如是算数。寿五百岁受是苦楚。黑绳狱者。其狱卒等于有情身。从顶至足拼界黑绳。以火锯钺解斫肢体。由先业力解下上生。彼寿量者。忉利天一生之期为一昼夜。如是算数寿一千岁。受是苦楚。众合狱者。生彼有情以铁追打。或二铁山犹如羊头。二山相合研磕摧坏。二山开时复自然活。又被摧坏。彼寿量者。离诤天一生之期为一昼夜。如是算数寿二千岁。受是苦楚。号叫狱者。生彼有情怖热铁池。入稠林中。火焰炽盛永岁焚烧。由先业力。其舌纵广千由旬量。有一大牛。铁角铁甲架铁犁铧。火焰炽盛耕犁其舌。彼寿量者。兜率天一生之期为一昼夜。如是算数寿四千岁。受是苦楚。大号叫狱者。亦与前同其苦倍增。彼寿量者。化乐天一生之期为一昼夜。如是算数寿八千岁。受是苦楚。炎热狱者。三重铁城火焰洞彻内受苦楚。彼寿量者。他化自在天一生之期为一昼夜。如是寿数万六千岁。受是苦楚。极炎热狱者。亦同其前其苦倍增。彼寿量者。等半中劫。受是苦楚。无间狱者。于铁室内身一聚焰受极苦楚。彼寿量者等一中劫。十六增狱者。八热狱傍面各四所。一煻煨增。深皆没膝。有情游彼。才下足时。皮肉与血俱燋烂坠。余剩其骨。举足还生平复如本。二尸粪增不净淤泥没有情腰。于中多有攘矩吒虫。嘴利如针。钻皮透骨[口*(一/巾)]食其髓。三峰刃增。复有三种。一刀刃路。谓于此中仰布刀刃以为大道。有情游彼才下足时。皮肉与血俱断碎坠。举足还生平复如本。二剑叶林。谓此林树纯以铦利剑刀为叶。有情游彼风吹叶坠。斩刺肢体骨肉零落。有乌驳狗[齒*(虎-儿+且)]掣食之。三铁刺林名铦摩利。谓此林树。有利铁刺长十六指。有情被逼上下树时。其刺铦利上下镵刺。是等有情血肉皮等。挂染刺上唯剩觔骨。有铁嘴乌。探啄有情眼睛脑髓。争竞而食。刀刃路等三种虽殊。而铁仗同故一增摄。四烈河增。名曰无渡。遍满极热烈灰汁水。有情入中或浮或没。或逆或顺或横或竖。被蒸被煮骨肉糜烂。如大镬中。满成灰汁置稻米等猛火下然。米等于中上下回转举体糜烂。有情亦然。设欲逃避。于两岸上有诸狱卒。手执刀枪御捍令回。无由得出。此河如堑。前三似苑。彼等名曰近边地狱。八寒狱者。一曰水疱。二曰疱裂。三阿吒吒。四阿波波。五呕喉喉。六裂如郁钵罗花(此云青莲华)。七裂如莲花。八裂如大莲花。水疱狱者。生寒水间极甚严寒。随身生疱。曰水疱狱。彼寿量者。摩伽陀国所有大斛八十斛麻百年除一。若芝麻尽。彼寿亦尔。疱裂狱者。由极严寒其疱而裂黄水漏流。彼寿量者倍前二十。阿吒吒狱者。由大严寒咬齿忍耐。彼寿量者倍前二十。阿波波狱者。忍寒音声。彼寿量者倍前二十。呕喉喉狱者。由寒号泣出是苦声。彼寿量者倍前二十。裂如郁钵罗花狱者。严寒身裂如郁钵罗花叶。彼寿量者倍前二十。裂如莲花狱者。严寒身裂如莲花开。彼寿量者倍前二十。裂如大莲花狱者。身裂越前如大莲花开敷多叶。彼寿量者倍前二十。孤独狱者。在赡部提旷野山间。一昼一夜受苦受乐。相杂受故。八热地狱八寒地狱近边孤独。如是名为十八地狱。饿鬼者。王舍城下过五百由旬。有饿鬼城名曰黄白。亦云惨淡彼鬼王曰阎罗法王。共三十六眷属等居。其类有四。一者外障。二者内障。三者饮食障。四者障饮食。一外障者。饮食音声亦不得闻。二内障者。获微饮食。口若针窍不能得入。设能入口。咽如马尾无能得过。设若过咽。腹若山廓不能饱满。虽满腹中。胫如草茎无能举动。受此大苦。三饮食障者。见饮食时。无量狱卒执诸器仗守御无获。四障饮食者。食饮食时由业所感。铁丸铜汁泻置口中。从下流出。如是四种皆是饿鬼。彼寿量者。人间一月为一昼夜。如是算数寿五百岁。即当人间一万五千岁。或居人间寒林等处。食血肉等。皆饿鬼类。三傍生者。多居河海。亦如酒糟混漫而住。以大食小以小食大。互相惊怖。由海波涛住所不定。或处人天。彼寿量者。长如龙王寿半中劫。短如蚋等寿一刹那。身量无定。四人者。住四大洲八中洲等及诸小洲。彼寿量者。如赡部洲人。初成劫时其寿无量。次后渐减今六十岁。次后渐减至十岁间。复次渐增无有定量。北鸠娄人定寿千岁。东胜身人寿五百岁。西牛货人寿二百五十岁。除北鸠娄余有夭横。彼等受用。北鸠娄洲食自然稻。衣服璎珞出如意树。余三洲者食谷肉等。资宝受用。彼等身量。赡部提人肘量八肘。西牛货人身十六肘。北鸠娄人三十二肘。人等面相亦如洲状。其小洲人亦如大洲。身各减半。故如是说。五非天者。妙高水际下过一万一千由旬。山旷廓间光明城内。阿修罗王。曰罗睺罗(此云摄脑)。众眷属居。又过一万一千由旬。星鬘城内阿修罗王。名曰项鬘。众眷属居。又过一万一千由旬。坚牢城内阿修罗王。名曰妙镇。又曰大力。众眷属居。又过一万一千由旬。甚深城内阿修罗王。名曰毗摩质多罗(此云丝种种亦云纹身)。众眷属居。常共帝释比对斗诤。城曰具金。殿名奏乐。如意树王名即怛钵栗。聚集之处名曰贤财。石名善贤苑名普喜妙喜最喜甚喜善。地亦名普喜妙喜最喜甚喜。临战所乘象名无能敌。游戏所乘象名垒雪。马曰峭脖。是等非天。共三十三天。诤须陀味及修罗女。为战诤故。从山廓出。身服金银琉璃玻璃珂等坚固铠甲。手执剑槊标枪弓箭。领四部军。彼阿修罗王。罗睺罗。项鬘。妙镇。毗摩质多罗等。或前三来或四皆来。是时帝释五守护众。一住戏海。愿乐白法龙王等众。与非天军斗战令回。龙若不胜去坚首所。共二守护复与修罗斗战。又若不胜去持鬘所。共三守护复与斗战。又若不胜去恒憍所。共四守护复与斗战。又若不胜去四王所。共五守护复与斗战。四大天王率四军众。服宝坚铠执诸戈仗。斗战多分四天王胜。若不能却。去忉利天前。白帝释曰。我等守护不能回彼阿修罗众。王应却敌。如是白已。天主帝释乘善住象。告三十三天众等曰。汝等应知。今修罗军至妙高顶。当服坚铠取所乘车与修罗战。说是语已。彼诸天子。各服宝铠执持戈仗。去众车苑取所乘车。入粗恶苑转身心恶。出善见城。共彼修罗相敌斗战。若修罗胜侵至城内。若天得胜逐修罗军至第一海。斗战之时。天与非天断其胫腰。彼等即死手足若断。复生如本。若薄伽梵辟支佛。转轮圣王住世间时。诸阿修罗不起诤心。设若相持诸天必胜。世间善增天众亦胜。世不善增阿修罗胜。是故诸天护持善事。天者。欲界六天。色界十七。无色界四。欲界六天者。苏迷卢山第一层级坚首众居。第二层级持鬘众居。第三层级恒憍众居。持双山上北方有城。名阿那迦嚩帝。多闻天王药叉众居。如是东方城名贤上。有大天王名曰持国。乾闼众居。西方有城名曰众色。有大天王名曰广目。龙神众居。南方有城名曰增长。有大天王名曰增长。焰鬘众居。余四层级七金山等。日月星宿铁围轮山。赡部洲山多罗树所。四王部众亦住止住。咸属四王。是谓一部。彼寿量者。人五十岁为一昼夜。如是寿量经五百年。若其身量一俱卢舍四分之一。三十三天妙高顶上。天主帝释住最胜处。共非天女。名曰妙安。同众天女受诸欲乐。无有厌足。复有临战所乘象王。名曰善住。游戏苑中。所乘象王。名曰蔼罗筏拏(此云持地子)。二象周围各七由旬。各以八千小象众居。又有马王名迅疾风。与八千马居。天主辅臣数三十三。是故名曰三十三天。诸天子等耽五欲乐。若放逸时有大天鼓。鼓声出音警诸天曰。诸行无常。有漏皆苦。诸法无我。寂灭为乐。与修罗军斗战之时。出除苦音警曰。天愿得胜。愿修罗败。宫殿城池树集石等。如前所辨。彼天寿量。人间百岁为一昼夜。如是算数寿一千岁。其天身量半踰阇那。焰摩天者。三十三天共非天诤。此离诤故名离诤天。彼天寿量。人二百岁为一昼夜。如是算数寿二千岁。其天身量二踰阇那。兜率陀天者。有慈氏尊。绍世出世法王之位。受大法乐。谓曰兜率。是俱乐义。人间四百年彼天一昼夜。寿四千岁。身量四踰阇那。化乐天者。自化受用谓曰化乐。人间八百年彼天一昼夜。寿八千岁。身量八踰阇那。他化自在天者。受用他化。谓曰他化自在。彼中天王威德自在。即是魔主。人间千六百年。彼天一昼夜。寿量万六千岁。身量十六踰阇那。下从无间至他化自在天。谓之欲界。耽着欲乐所食段食。故如是说。色界一十七天者。四静虑摄。初禅三天者。谓梵众梵辅大梵。彼天寿量。梵众半劫。梵辅一劫。大梵一劫半。彼天身量。次第半由旬。一由旬。一由旬半。二禅三天者。谓少光无量光极光。彼天寿量。少光二劫(以上四天四十中劫为一大劫以下诸天八十中劫为一大劫)。无量光四劫。极光八劫。彼天身量。少光二由旬。无量光四由旬。极光八由旬。三禅三天者。少善无量善广善。彼天寿量。少善一十六劫。无量善三十二劫。广善六十四劫。彼天身量。少善十六由旬。无量善三十二由旬。广善六十四由旬。四禅八天者。无云福生广果。三是凡居。无烦无热善现善见色究竟。五是圣居。名曰五净居。彼天寿量。无云百二十五劫。福生二百五十劫。广果五百劫。无烦一千劫。无热二千劫。善现四千劫。善见八千劫。色究竟一万六千劫。彼天身量。无云一百二十五由旬。福生二百五十由旬。广果五百由旬。无烦一千由旬。无热二千由旬。善现四千由旬善见八千由旬。色究竟一万六千由旬。始从梵众至色究竟。皆名色界。出离欲乐。非离色故。故名色界。无色界四天者。无有身色。亦无处所。从定分四。空无边处。识无边处。无所有处。非想非非想处。彼天寿量。空无边处二万大劫寿量。识无边处四万大劫。无所有处六万大劫。非想非非想处八万大劫。彼等四处。谓无色界。非离定色。出离粗色。故无名色。彼等寿量。谓岁劫时。其量云何。时最少者名为刹那。百二十刹那为一怛刹那。六十怛刹那为一罗婆。三十罗婆为一牟休多(此云须臾)。三十牟休多为一昼夜。三十昼夜即为一月。十二个月即是一年。劫有六种。一中劫(或名别劫)。二成劫。三住劫。四坏劫。五空劫。六大劫。一中劫者。或赡部人从无量岁。渐渐减至八万岁时。即成劫摄。从八万岁。减至十岁谓中劫初。复增八万岁。减至十岁。为一辘轳。如是增减十八数者。为十八中劫。然后十岁至八万岁。中劫后际前后中间。十八辘轳为二十中从。二成劫者。始从风轮至无间狱。生一有情器世界成经一中劫。如前已说。情世界者。此三千界。火坏后成。从极光天天人命终生大梵处。孤生疲倦呜呼。若有同分生此界者。有何不可。发如是心。虽非念力。极光天人有命终者。即生彼处。先生之心而作是念。由我贪生故世咸称人祖大梵。如次梵辅梵众他化自在。乃至四王次第而生。北鸠娄洲。西牛货洲。东胜身洲。南赡部洲。次第而生。时赡部洲人寿无量岁。饮食喜乐有色意成。身带光明腾空自在。如色界天。有如是类。地味渐生其味甘美。色白如蜜其香馥郁。时有一人。禀性耽味。嗅香起爱。取[嚐-旨+甘]便食。亦告余人。随学取食。食段食故身光隐没。由众业感日月便出。照耀四洲。次地味隐复生地饼。其味甘美色红如蜜。竞耽食之。地饼复隐次林藤生。竞耽食故林藤复隐。有非耕种自然稻生。众共取食。此食粗故即余滓秽。根道俱出。尔时诸人。随食早晚。取香稻食。后时有人禀性懒惰。长取香稻。储宿为食。余亦随学。香稻隐没。随共分田。虑防远尽。于己分田生吝护心。于他分田有怀侵夺。故生争竞。是时众人议一有德。封分田主。众所许故。谓曰大三末多王(此云众所许)。王多有子。相续绍王。嫡子号曰光妙。彼子善帝。彼子最善。彼子静斋。是等谓曰成劫五王。静斋王子名曰顶生。彼子妙帝。彼子近妙。彼子具妙。彼子严妙。是等谓曰五转轮王。严妙王子名曰舍帝。彼子舍双。彼子舍固尼。彼子固室。彼子善见。彼子大善见。彼子除碍。彼子金色。彼子具分。彼子离恶。彼子妙高。彼子定行。彼子甚吼音。彼子大甚吼音。彼子能安。彼子方主。彼子贤尘。彼子能广。彼子大天。此王种族五千相承。其最后子七千相承。曰阿思摩迦王。最后子八千相承。曰鸠娄王。其最后子曰具头王。有九千王。其最后子名曰龙音。有一万王。其最后子怛弥留怛一万五千。其最后子名瞿昙氏。此即甘蔗裔。彼子相承。甘蔗王种一千一百数。其最后子甘蔗种王。名曰增长(即懿师摩王)。王有四子。一名面光二名象食。三名调伏象。四名严镯。称释迦氏。严镯有子名曰严镯足。彼子致所。彼子牛居。彼子师子颊王。有四子。一名净饭。二名白饭。三名斛饭。四名甘露饭。净饭王子即婆伽梵。次名难陀。白饭王二子。一名帝沙调达。二名难提迦。斛饭王二子。一名阿尼娄驮。一名跋提梨迦。甘露饭王二子。一名阿难。一名提婆达多。婆伽梵子名罗睺罗。释迦种族至斯终矣。又别种王依法兴教。如来灭度后二百年。中印土国有王。名曰无忧。法王于赡部提。王即多分中结集时。而为施主。兴隆佛教后三百年。赡部西北方有王。名曰割尼尸割。三结集时。而为施主。广兴佛教。梵天竺国。迦湿弥罗国。勒国。龟兹(音丘慈)。捏巴辣国。震旦国。大理国。西夏国等。诸法王众。各于本国兴隆佛法。如来灭度后千余年。西番国中初有王。曰呀乞[口*栗]赞普。二十六代有王。名曰祫陀朵[口*栗]思颜赞。是时佛教始至。后第五代有王。名曰双赞思甘普时班弥达。名阿达陀。译主名曰端美三波罗。翻译教法。修建袷萨等处精舍。流传教法。后第五代有王。名曰乞[口*栗]双提赞。是王召请善海大师。莲华生上师。迦摩罗什。罗班弥达。众成就人等。共毗卢遮那罗佉怛及康龙尊护等七人。翻译教法。余班弥达共诸译主。广翻教法。三种禁戒兴流在国。后第三代有王。名曰乞[口*栗]徕巴赡是王界广。时有积那弥多。并湿连怛罗菩提。班弥达等。共思割干吉祥。积酌罗龙幢等。已翻校勘。未翻而翻。广兴教法。西番王种。至今有在。班弥达等。翻译译主。善知识众广多有故。教法由兴。北蒙古国。先福果熟生王。名曰成吉思(二合)。始成吉思。从比方王多音国。如铁轮王。彼子名曰干果戴时称可罕。绍帝王位。疆界益前。有子名曰古伟。绍帝王位成吉思皇帝。次子名朵罗。朵罗长子。名曰蒙哥。亦绍王位。王弟名曰忽必烈。绍帝王位。降诸国土疆界丰广归佛教法依化民。佛教倍前光明炽盛。帝有三子。长曰真金丰足。如天法宝庄严。二曰厖各刺。三曰纳麻贺。各具本德系嗣亦尔。兹是始从释迦王种。至今王种

彰所知论卷上彰所知论卷下

        元帝师癹合思巴造

        宣授江淮福建等处释教总统法性三藏弘教佛智大师沙罗巴译

始帝王祖三末多王。是时田分互起侵盗。初发偷盗。被王推问言不曾偷。始起妄语。王法诛戮。即有杀害不善法生。尔时众生造不善法。命终之后即生傍生。次生饿鬼。渐生地狱。次无间狱生一有情。时成劫终。如是有情行诸不善。寿量惭减受用乏少。阎浮提人寿八万岁。无间地狱生一有情。是二同时。如是情世界成。十九中劫器世界成。即一中劫。如是成劫二十中劫。阎浮提人八万岁时。始为住劫。住劫亦经二十中劫。至十岁时刀兵灾起。唯七昼夜。疾疫灾起七月。七日饥馑灾起。七年七月七日多分死殁。余者相睹起希见心。互相睦恋远离杀害。渐生善故。寿量受用复增益盛至八万岁。增上之时转轮王出。依法化民。下减之时婆伽梵出。拔济众生。增减时间独觉出世。令诸有情而作福田。住劫亦经二十中劫。始坏劫初情世界坏。无间狱中无有情生。先生业尽即生别趣。若有未尽生上地狱。或别世界地狱中生。无间狱空。如是向上地狱渐空。生饿鬼趣。如是饿鬼傍生趣空。人趣之中除鸠娄人。余共欲天无师法然。获初静虑生初禅天。北鸠娄人生欲界天。获初诤虑生初禅天。无师法然获二静虑。生二禅天。从无间狱至梵世空。如是亦经十九中劫。然后四洲有七日出。初不降雨。药草丛林悉皆枯槁。二日出时沟池干涸。三日出时。殑伽河等悉皆枯竭。四日出时无热池竭。五日出时海水没膝。六日出时大海亦竭。七日出时。彼器世界一聚火耸。从无间狱直至梵世。以火烧坏经一中劫。坏劫总经二十中劫。空劫亦尔。如是成住坏空即八十劫。总此八十名一大劫。为梵众等寿量之数

器世界坏有其三种。火水风。坏者亦如前说。如是七次后世界复成。又被水坏至二禅天。从极光天即生大云。降注大雨。其器世界。如水化盐销镕皆尽。彼水自竭。一水灾次复七火灾。度七火灾还有一水。如是水灾满至七次。复七火灾。后世界成。被风灾坏。至三禅天。其风之力吹散妙高。何况其余。第四禅天虽无外灾。是等有情生与殿生。命尽殿隐。如是器情世界。并成坏等。咸皆说已

复次因果相续缘生法者。因缘相藉而生。故曰缘生。缘生有二。一外缘生二内缘生。外缘生者。成世界法。如种生芽。如前已说。内缘生者。如有无明即有行等。名顺缘生。如无明灭即行等灭。名逆缘生。顺缘生者有七。复次约位。约远续。约连缚。约刹那。约三际。约二重因果。约三惑等。约位者。于宿生中诸烦恼分位中五蕴。即名无明。由无明胜故。如是说。已下皆以从胜为名。行等诸法各具五蕴。行者。宿世所造善不善业位间五蕴。识者。于母胎中正结生时。一刹那位所有五蕴。名色者。结生识后。六处生前其间五蕴。名者。受想行识四蕴名。名色者。处胎分位。羯逻蓝(此云和合亦云凝滑)頞部昙(此云疱结)闭尸(此云肉团)键南(此云坚实)钵罗奢佉(此云肢体筋力等生)等五名色。六处者。处母胎中。从眼等生至三和合。未了别境位间五蕴。触者根境识三和合。未能了别苦乐之因。位间五蕴。受者。已了三受因差别相。婴儿之时至未起淫位间五蕴。爱者。即年盛时能了淫欲。未广追求位间五蕴。取者。为得种种上妙资具。周遍驰求位间五蕴。有者因驰求故积集。能牵。当来果业位间五蕴生者。由是业力从此舍命。正结当有位间五蕴。老死者。从当来生名色至受位间五蕴。一切有部说。约位缘生即是远续。连缚亦尔。经部宗者。无约位说。约远续者。谓无明与明相违。是心所法发行之因。行者。所发起业。福及非福不动等业。识者。由业引令识生。名色者。胎中五蕴。六处者。眼等根生。触者。根境识三和合。了别是心所法。受者。由彼所生苦乐舍等。爱者。贪着乐境。取者。寻求彼境。有者。由彼发起成当生业。生者。由业相续结。生老死者。令生彼生究竟转死。连缚亦尔

约刹那者。谓由一刹那。十二有支缘生具足。由贪行杀痴谓无明。断命即行。于诸境事了别名识。五蕴同俱总称名色。住名色根。说名六处。根境识三和合有触。因触为受。贪即是爱。与此相应诸缠名取。所起身语二业名有。如是诸法集起名生。熟变名老。灭坏名死

约三际者。谓无明与行属过去摄。名曰因支。识等五支属现在摄。名曰果支。爱取有三属现在摄。名曰未来因支。生老死二支属未来摄。名曰果支。过去二支。现在八支。未来二支。故十二支

约两重因果者有二。一前际。二后际。前际者。谓无明是惑。行即是业。彼二因支。由彼所生识等五支。即是果支。一重因果。现在爱取二支是惑。有即是业。三当来因。由彼所生。当生老死。即是果支。一重因果。如是十二有支。两重因果

约三惑者。谓无明爱取三即是惑。行有二即是业。谓之集谛。识等七支即是苦。谓之苦谛。是顺缘生。逆缘生者。无明灭即行灭。无明灭则了无我智。即是道谛。若无明灭生因行灭。引业灭故识等五支灭。由是灭故。起发后业爱取等灭。由是灭故。生老死等皆悉亦灭。即是灭谛。说四谛已。器情缘生及四谛等。皆五法摄。一色法。二心法。三心所法。四不相应法。五无为法。一色法者。即是色蕴。五根五境无表色等十一法。言五根者。谓眼根极微如香荾华。在眼星上傍布而住。耳根极微。如卷桦皮居耳穴内。鼻根极微如双爪甲。居鼻頞内。舌根极微形如半月。布在舌上。身根极微亦如身量。从顶至足遍在身根。根是尘故不能缘境。言五境者。色谓眼缘之境。有其二种。一显色。二形色。显色者。有其四种。青黄赤白。形色者。有十六种。长短方圆高下正不正。光影明暗云烟尘雾等。二十数声。谓耳缘之境。有其二种。一有执因如语等。二无执因如鼓声等。有记无记各二为四。此复可意及不可意。差别成六。香谓鼻缘之境。有其四种。一好香。二恶香。等不等故。差别成四。味谓舌缘之境。有其六种。甘酸苦辛咸淡。触谓身缘之境。因触四大果触。滑涩重轻冷热饥渴等。言无表色者。谓律仪不律仪俱相违色。此是色蕴。二心法者有六。谓眼耳鼻舌身意识。六即是识蕴。三心所有法者。有四十六。一大地法者。有十种。受谓领纳。想谓令心执境。思谓令心运动。作意谓令心缘境。胜解谓令心于境印可即是令心于所缘境无怯弱义。欲谓希求。触谓和合了境。慧谓拣择。念谓令心于境明记不忘。定谓令心专注一境。如是十种遍一切心。名大地法。二大善地法者有十。信谓令心于境澄净。不放逸谓恒习善法守护心性。轻安谓心堪任性。舍谓令心平等。惭谓于诸功德及有德者。恭敬而住。愧谓于罪见怖。无贪谓不著有漏。无嗔谓于诸有情不乐损害。不害谓怜愍有情令无损恼。勤谓于善令心勇悍。如是十种遍诸善心。名大善地法。三大烦恼地法者。有六种。痴谓愚痴即是无明。无智无显。逸谓放逸不修诸善。怠谓懈怠心不勇悍。不信谓心不澄净。惛沈谓身心相续无堪任性。是昧重义。掉举谓心不寂静。如是六种遍烦恼心。名大烦恼地法。四大不善地法者。有二种。一者无惭。谓于诸功德及有德者。令心不敬。二者无愧。谓于诸罪中不见怖畏。如是二种遍不善心。名大不善地法。五小烦恼地法者。有十种。忿谓令心愤发。恨谓于忿所缘事中。数数寻思结怨不舍。谄谓心曲。诳谓惑化。嫉谓不忍他德。恼谓坚执诸罪。由此不受如理谏诲。覆谓隐藏自罪。悭谓于己法财令心吝惜。憍谓染着自身所有色力种族等事。令心傲逸。害谓于他能作逼迫。如是十种唯修所断。遍意识地。名小烦恼地法。六不定法者。有八种。寻谓令心于境粗转为相。伺谓令心于境细转为相。恶作谓恶所作业是追悔义。睡眠谓不能任持身心相续。令心昧略。嗔谓令心于有情等乐为损害。贪谓爱著有漏。慢谓令心恃举。疑谓令心犹豫。如是八种于前诸地无有定故。名曰不定。对法集论并五蕴论。说十一善。内了知四谛名曰无痴。随烦恼中执不净为净。染污作意胜解。名非理作意。邪胜解根本烦恼内。于诸谛理颠倒推度。染污慧分。名不正知。随烦恼内。于诸所缘不能明记染污念分。名曰失念。于诸所缘令心流荡。染污定分名曰散乱。对法藏论无如是说。以上心所。除受想二皆行蕴摄。心所法竟。不相应行者。有十四种。谓有情相续。律仪相应。有别物曰得。与彼律仪不相应。有别物曰不得。诸有情类同作事业。曰众同分。若生无想有情天中。有法能令心心所灭。是实有物名曰无想果。复有别法能令心心所灭。名曰无想定。无想者定名。或定无想名无想定。如下所说。圣者相续想受等灭。是实有物名灭尽定。有情始生住未死间。名曰命根。先无今有曰生。令暂时住曰住。转变曰老。变坏曰无常。即有为四相。能诠自体谓曰名身。诠义究竟谓曰句身。是二所衣谓曰文身等十四法又义摄内破和合众。曰不和合。所造业果于自成熟。犹如负债终不唐捐。物等亦系。不相应行。一切有部。色心所三有别物。经部师说。是彼三法假说分位。除彼受想。四十有六。心所有法。及不相应。名曰行蕴。无为法者至下当知。如是色法即名十界。除无表色。是眼等十。心法七界。谓六识及意根界。若说处时。是彼七法。一意处摄。心所有法不相应法。无为法无表色等。总名法界。亦名法处。如是所说。所知五法五蕴。并十二处。及十八界

    道法品第三

复次道者。谓彼少欲知足。具种性者。身心远离种种群杂。住近事戒等。应当勤闻。若广闻已。思所闻义。思已应修。谓当修止观。多贪修不净观。多嗔修慈悲观。多痴修分别缘生观。多我修分别界观。多散乱修数息观。止观成已。修胜解故。如法了解内外身。名身念住。如法了解苦乐舍等。名受念住。如法了解六识心法。名心念住。如法了解想行无为。名法念住。修此四法。是智资粮。道集资粮已

修加行道。暖位之中。已生恶令断。未生恶令不生。已生善令增长。未生善令生。如是四法名四正勤(文云正断)。顶位之中。欲善法定。勤乐善定作意善心定。拣择善定。如是名四神足。忍位之中行世正见。澄净名信。乐修善法。曰进明记不忘曰念。专注一境曰定。知取舍法曰慧。修此五法能生善法。故曰五根。世第一位中修信进念定慧等五。能破相违故曰五力。此是加行道。见道位中了知四谛。名曰正见。正语发起。名正思惟。如法正说。名曰正语。舍不善业。名曰正业。弃舍邪命。名曰正命。希求善法。名正精进。明记不忘。名曰正念。专注一境。名曰正定。如是八法。名八圣道支。此是见道。见道所断分别烦恼。及得相等。谓欲界苦谛贪嗔慢无明疑。有身见边执见。戒禁取见见取邪见。集灭二谛各除三见。七七十四道谛所断。除上二见。欲界四谛共三十二。色界四谛各各除嗔。共二十八。无色亦然。如是三界。见道所断八十有八

修道位中明记善法名念觉支。拣择取舍名慧觉支。希求精进名勤觉支。证无漏喜名喜觉支。身心任性名轻安觉支不为世法所牵。无著无碍名舍觉支。令心住境名定觉支。修此七支名曰修道。修道所断俱生烦恼。得相无记有漏善等。欲界之中贪嗔痴无明四。各具九品共三十六。色界之中第一静虑除嗔。余三各各九品成二十七。如是二三四静虑亦尔。色界总有一百八数。无色界亦然。如是三界修道所断。总有一百五十二数

次证十无学法者。谓正见。正思惟。正语。正业。正命。正进。正念。正定。正解脱。正解脱知见。是无学道

    果法品第四

复次果者。如上所说三十七品菩提分法。为自解脱轮回发心。利根极速。三生证阿罗汉。一生修顺解脱分善。名资粮道。二生修顺决择分善。名加行道。三生亦如沙门证第四果。钝根懒惰。即不定故。如沙门者。向预流等。四者名果。向预流者。加行道前情器所摄。皆苦自性即是苦谛。复次彼因业及烦恼。是名集谛。令彼解脱。即是灭谛。复次彼因。即是道谛。修习纯熟。由彼次第证见道时。初观苦谛。四法性者。转变名无常。三苦名苦。实有与我非一蕴故名空。实有与我别故名无我。现证四智。次观集谛。四法性者。如种苦理故因。等现苦理故集。相续苦理故生。随顺苦理故缘。现证四智。次观灭谛。四法性者。苦因灭故灭。苦果息故静。超有漏故妙。脱轮回离。现证四智。次观道谛。四法性者。通行义故道。契正理故如。修无念智故行。现证三智。此十五者名初果向。第十六者。以彼道谛永超诸有故出。现证一智。此等十六。是住初果。已证四谛。十六行相修习纯熟。欲界修道所断九品烦恼之中断前五品。即一来向。断第六品即一来果。彼一来者。复来欲界受一生故下三品者。欲界之中一生断故。现证行相修习纯熟。断七八品名不还向。断第九品名不还果。彼不还者。断尽欲界一切烦恼。必不还来欲界生故。现证上界诸地行相。修习纯熟。四静虑四无色。各九烦恼断。初静虑一品为始。至断有顶八品为终。名阿罗汉向。断第九品名阿罗汉果。彼阿罗汉者。三界烦恼断尽无余。名阿罗汉。经云。干慧地等八者。声闻资粮道。即干慧地。欲爱枯干根境不偶。是所修善名干慧地。种性地者。即加行道。必不成佛。定成声闻独觉种性。名种性地。八人地者。是初果向。至阿罗汉果。名八人地。具见地者。是住初果。四谛行相现证见故。名具见地。薄地者。是一来果。欲界烦恼多分断故。名曰薄地离欲地者。是不还果。离欲界中贪欲等故。名离欲地。已办地者即阿罗汉。苦已知。集已断。灭已证。道已修名已办地。声闻地者。即不来不还阿罗汉。三名声闻地。辟支佛地者如上所说三十七品菩提分法。唯自一人欲证菩提。如是发心修百大劫。以最后身生无佛世。不假师教成证独觉。此有二种。一麟角。二部行。麟角喻者。唯一而居具圣德行。部行类者。与众群居

究竟正觉者。如上所说三十七品菩提分法。为诸有情而成佛故。发起大悲胜菩提心。奉侍诸佛悉令欢喜。利益他故行六度行。三无数劫究竟成佛者。释迦如来昔为陶师。名曰大光明。于大释迦如来之处。始初发心。至初无数劫。奉侍七万五千佛。其最后佛名曰宝髻。第二无数劫。奉侍七万六千佛。其最后佛名曰然灯。第三无数劫。奉侍七万七千佛。其最后佛名曰胜观。其六度者。以大悲心于诸有情所有资具悉皆惠施。为普度太子时。施波罗蜜究竟圆满。未离贪欲。被析肢体心无少恚。为忍辱仙时。忍戒二行究竟圆满。为婆罗门子时。视底沙佛住火界定。忘下一足经七昼夜。旋绕赞曰

  天地此界多闻室　　逝宫天处十方无
  丈夫牛王大沙门　　寻地山林遍无等

如是赞已便超九劫。进波罗蜜究竟圆满。处圆满处金刚座。初夜分时降诸群魔。后夜分时金刚喻定。定慧二行究竟圆满。如是处金刚座降魔之前。三无数劫修福智足。奉侍诸佛。六度虽圆即异生身。坐金刚座。证见修道。成等正觉。声闻乘中。因时不说了知诸法无我空悲施行三轮体空十地行相。果时不说报身及四智等

正觉法者。六种所摄。谓身智断。利他大悲德具足等。身者有二。一者色身。二者法身。色身者。具三十二相八十种好。即自性身。度乾闼婆及苾陵伽故。示现乾闼婆王及转轮圣王。即化身。然诸佛等种性身量。寿命国土及根机等。有种种异。二法身者。有十无学法。诸佛等同

智者有二。一者遍智。二者正智。遍智者。谓了蕴界处因果体性。故曰遍智。二正智者。谓知四谛中无常等法。故曰正智

断者有二。一断烦恼障。二断所知障。断烦恼障者。谓对治贪等根本烦恼。及随烦恼令断灭故。二断所知障。谓对治能障境时。自性无知之法。令断灭故

利他者有二。一者于诸有情安置解脱。弃舍相违令住于道。二者于诸有情安置善趣。弃舍于恶令住于善。大悲及德。次下当说

诸圣者等言功德者。有十一种。谓无诤愿智。四无碍解。六通。四静虑。四无色。四无量。八解脱。十遍处。八胜处。三等持等

无诤者。谓依第四静虑心。愿诸有情勿缘己身生诸烦恼。思惟等持。故名无诤

愿智者。谓依第四静虑心。以愿为先。引如智起如愿了知。故名愿智

四无碍解者。一法无碍解。知诸法名故。二义无碍解。正知义故。三词无碍解。正知言辞故。四辩才无碍解。正知正理故。名四无碍解

六通者。一神境通。游行石壁等无碍故。天耳通。若近若远诸异音声。皆了知故。三天眼通。能随所应取被障隔极细远等诸方色故。四他心通。能知他心有无欲故。五宿住通。知自及他宿世事故。六漏尽通。知世出世一切道故。前五有漏依第四静虑。第六无漏依第九故

四静虑者。初静虑具有五支。一寻。二伺。三喜。四乐。五等持。二诤虑中具有四支。一内等净。二喜。三乐。四等持。三静虑中具有五支。一行舍。二正念。三正惠。四受乐。五等持。四静虑中具有四支。一行舍清净。二念清净。三非苦乐受。四等持

四无色者。修加行时。思无边空及无边识无所有故。以正定时除色依余四蕴。第四名者由想昧劣。谓无明胜。得非想名。有昧劣想。名非非想。如是次第空无边处。识无边处。无所有处。非想非非想处。名四无色。若加灭尽定。亦名九次第定

四无量者。谓慈悲喜舍。四中初二无嗔为体。喜即喜受。舍即无贪。所缘境者。欲界有情所有嗔害。及有欣慰欲贪嗔等。如次对治

八解脱者。依初二静虑。一内有色想观诸外色解脱。不净想转作青淤想。以色观色。二内无色想观诸外色解脱。内无色观。三依后静虑净解脱。身所证具足住。观一切色作净光鲜。如是三种。及四无色定为次四解脱。灭受想定为第八解脱。依有顶心。诸圣者等厌粗受想。以寂静定灭心心所名灭尽定

十遍处者。谓周遍观察地水火风青黄赤白。及空与识二无边处。依第四静虑。缘欲可见色。于地等处周遍观察。无有间隙。十中前八无贪为体。后二如次空识无色。为其自性

八胜处者。一内有色想观外色少。二内有色想观外色多。三内无色想观外色少。四内无色想观外色多。内无色想观外色。青黄赤白为四。足前成八八中初二如初解脱。次二如次解脱。后四如第三解脱。若尔八胜处与三解脱何殊。答前修解脱唯能弃背。此修胜处能制所缘。随所乐欲而终不起。修解脱等。一为诸惑。已断更远。二为于定。得胜自在故。能引起无诤等德及胜神通。由此便能转变诸事。起留舍等种种作因故

三三摩地者。谓空无相无愿。空三摩地者。谓空非我二种行相。相应等持。无相三摩地者。谓缘灭谛四种行相。相应等持。涅槃无相离十相故。名曰无相。能缘彼定。得无相名。无愿三摩地者。谓缘余谛十种行相。相应等持。非常苦因可厌患故。道如船筏。必应舍故。能缘彼定得无愿名。皆为超过。现所对故。此等功德。俱解脱。阿罗汉辟支佛如来共故。名共功德。慧解脱者。无三等持及四无量故

如来不共功德者。有十八种。谓十力四无所畏。三念住。及一大悲

十力者。一处非处智力。二诸业异熟智力。三静虑解脱等持等至智力。四根上下智力。五种种胜解智力。六种种界智力。七遍趣行智力。八宿住随念智力。九生死智力。十漏尽智力

四无所畏者。一正等觉无畏。二漏尽无畏。三说障无畏。四说道无畏。由有智力于他不惧。故名无畏

言三念住者谓如来说法。诸弟子等。一向恭敬能正受行。如来缘之不生欢喜。舍而安住正念正知。是谓如来第一念住。诸弟子众惟不恭敬不正受行。如来缘之不生忧戚。舍而安住正念正知。是谓如来第二念住。诸弟子众。一类恭敬能正受行。一类不敬不正受行。如来缘之不生欢戚。舍而安住正念正知。是谓如来第三念住。此三皆用念慧为体。故名念住

大悲者。于诸世间昼夜六时。观察世间孰苦孰乐。孰应调伏。随应利乐。故名大悲。大乘所说。如来十八不共法。三不护等。彼声闻乘未曾闻故

    无为法品第五

复次无为法者。有其三种。一虚空。二择灭。三非择灭。谓虚空无为者。虚空但有无还为性。由无障碍遍一切处。名虚空无为色于中行。其余所有门窗窍隙。所有明暗等空及阿伽色等。皆非无为。二择灭无为者。谓无漏智断诸障染。见修二道所显真理。名择灭无为。三非择灭无为者。谓能永碍未来法生。得灭异前名非择灭得不因择但由阙缘。名非择灭。此三无为。一切有部许有实物。经部师说无有造作。问真如岂非无为耶。答彼即无我。以声闻乘不说法无我故。人无我者。即无常等十六行相。三谛行相。即是有为。灭谛行相惟择灭法。非余法故。如是器精。道果无为。所知五者。总摄一切所知法故。情器之法即是苦谛。成彼之因。即是集谛。道果二法。即是道谛。择灭无为。即是灭谛。虚空非择二种无为。三种非四谛摄。苦集二谛有漏法故。道灭二谛无漏法故。如是所说。世出世间。有为无为。所知法已

  种相富具足　　睿智皇太子
  数数求请故　　慧幢吉祥贤
  念住日藏论　　起世对法等
  依彼造此论　　有情所知论
  机宜有无边　　纂略列为五
  谓器情道果　　并无为法等
  故今明开示　　冏冏晓解者
  惟兹彰所知　　解已复示他
  此论文句等　　乖义懈怠过
  智者并启请　　惟愿垂忍纳
  所生诸善根　　周遍虚空界
  我共诸众生　　愿证无上果

彰所知论者。为菩萨真金皇太子求请故。法王上师萨思迦大班弥达足尘顶授比丘癹思巴慧幢吉祥贤。时壬寅仲秋下旬有三鬼宿直日。于大吉祥萨思迦法席集竟。持经律论妙音并智。师子笔授

彰所知论卷下

大经云。森罗及万像。一法之所印。重重交光。历历齐现。非法界之现量欤。彰所知论者。乃先皇裕宗皇帝。圣明观照。神智睿鉴。愍邪见之炫惑。伤正涂之壅底。劝请帝师法王。利乐有情故。阐扬至觉真理。原始要终。修习次第之大旨也。弘而密。奥而典。古锦钝金。随器受用。义摄为五。至当归一。所言情器世界者。非若夫群盲摸象之异执。或言一气。或曰自然。直指心造。详明劫初。罗笼八极之外。剖析邻虚之内。如像临镜。如指在掌。言道法者。以少欲知足。闻思修慧三十七菩提分为其因。言果法者。以资粮加行见道修习无学为。其果。言无为者。四圣谛中之灭谛理也。由其五法总摄一切所知法故。故曰彰所知论。真智灵知。岂见闻觉知之谓乎。深入缘起。穷法实相。盖依念处日藏起世对法相应之义。而错综其宏纲也。然则他化天王通力。观世界微尘数之雨滴。犹目睹所受用物。声闻起神用。观三千大千世界如掌中庵摩罗果。况正遍知之妙用。其孰能语于此。盛矣优昙瑞世。天开玉历之期。像教中兴。时际金轮之治。钦惟圣制云。皇天之下。一人之上。西天佛子。大元帝师。玺篆赐玉。宠渥弥隆。其尊师重道。为万世帝王之[彞-糸+分]典也。行宣政院同知廉公。正奉夙承授记。深乐佛乘。一日以江浙总统沙罗巴大师所译彰所知论。传之前松江府僧录管主八大师。师续雕大藏圣教。偶其时忻获至宝。锓梓随函。属余序其后。辞不获免。辄述教起之由致。至于发扬圣教之粹美。则备于公之本序云。时大德丙午十月既望。江西前吉州路官讲报恩寺。讲经释克已序

(A) Namastraiyabdhika^na^m! tatha^gata^na^m! savartra^pratihata^va^ptidharmata^balina^m!, om% asama-

    sama samantato 'nantana^va^ptis/a^sani, hara smara smaran!a vigatara^gabuddhadhaumate, sara

    sara samabala^, hasa hasa, traya, traya, gagana maha^calaraks!an!a, jvala jvalana sa^gare sva^ha^.

(B) Namastraiyabhika^na^m! tatha^gata^na^m! sarvavajradhara^n!a^m! can!d!a^la can!d!a^la, cala cala, vajra

    vajra, s/a^ntana s/a^ntana, phalana phalana, cara cara, ma^ran!a ma^ran!a, vajrada^lakat!a, lalitas/i-

    khara samantavajrin!i, jvala jvala, namos/tr te agrogras/a^sa^na^na^m! ran!a ran!a ham! phula

    spha^t!a vajrottame sva^ha^.

(C) Namah! samantavajra^n!am! tra^t!a, amogha can!d!amaha^ros!an!a spha^t!aya hu^m!, bhra^maya bhra^-

    maya hu^m!, tra^t!a hu^m!, mam%, balam! dade tejoma^lini sva^ha^.

(D) Tadyatha^, ilimitte tilimitte, ilitilimitte, dumbe, duh!se, duh!sa^li^ye, dumba^li^ye, takke tark-

    karan!e, marmme, marmaran!e, kas/mi^re, kas/mi^ramukte, aghane, aghanaghane, ilimili^ye, ak-

    ha^pye, apa^pye s/vete, s/vetatun!d!e, ana^nuraks!e sva^ha^.

(E) Tadyatha^, illa^, cilla^, cakko, bakko, kod!a^ kod!oti, nikurud!a^ nikurud!eti, pod!a^ pod!eti, mod!a^,

    mod!eti, purud!a^ purud!eti, phat!arahe phut!at!an!d!a rahe, na^ga rahe, na^gat!at!an!d!a rahe, sarpa

    rahe, sarpat!at!an!d!arahe, chala vis!as/a^te, s/i^tacatta^le, halale, halale, tan!d!i, tad!a tad!a,

    ta^d!i ta^d!i, mala mala, sphut!a sphut!a, phut!u sva^ha^.

    Iti hi bhiks!avo ja^n%gulya^m! vidya^ya^m! uda^hr!ta^ya^m! sarvabhu^tasama^gate sarvam! tatha^vita-

    tha^nanyatha^bhu^tam! satyamavipari^tamaviparyastam!, idam! vis!amavisam! bhavatu, da^ta^ram!

    gacchatu, dam!s!t!ra^ram! gacchatu, agnim! gacchatu jalam! gacchatu, sthalam! gacchatu, stambh-

    am! gacchatu, kud!yam gacchatu, bhu^mim! samkra^matu, s/a^ntim gacchatu sva^ha^.

(F) Tadyatha^, para^kramasi, udayamasi, vairamasi, arkamasi, markamasi, vanamasi, antarddha^-

    namasi, pathe me raks!a, utpathe me raks!a janato me raks!a, cairato me raks!a, ra^jato me

    raks!a, sim!hato me raks!a vya^ghrato me raks!a, na^gato me raks!a, sarpato me raks!a, sarvato

    me raks!a, raks!a raks!a, ma^m! sarvasattva^m!s/ca sarvabhayebhyah! sarvopa^ye sarvopa^ye sopasargebhyah!

    sva^ha^. Um%vad!ili um%vad!ili sarvadus!t!a^na^m! granthim! vanda^mi sva^ha^.

    Namo ratnatraya^ya, namo ma^ri^cyai devata^yai, ma^ri^cya^ devata^ya^ hr!dayama^vartayis!ya^mi.

    Tadyatha^ batta^li, bada^li, bada^li, bara^li, vara^hamukhi, sarvadus!t!a^na^m! niva^raya, bandha

    mukham! sva^ha^.


止观门论颂

    No. 1655

止观门论颂一卷

        世亲菩萨造

        三藏法师义净奉　诏译

  若见女形相　　及以艳娇姿
  愚人不了知　　妄生淫染意
  佛说膖胀等　　蠲除淫欲念
  能随世尊教　　得胜果非余
  戒净有闻思　　策励常修习
  系念观诸境　　斯为解脱因
  若人有嗔染　　及昏沉睡眠
  掉恶作并疑　　此五遮修定
  少闻与众居　　鄙事情欣乐
  爱身并受用　　亦能遮定心
  心乱有五缘　　情随众境散
  味着并沉掉　　我慢重名闻
  苾刍依圣教　　有过应说除
  善取住心缘　　是为最初行
  次依寂静处　　妨难并皆无
  然后息邪思　　是苾刍初业
  应可住尸林　　着粪扫衣服
  常求静息事　　断除淫染心
  乞食见女人　　应观为不净
  摄眼除邪意　　正心当取食
  多言多事务　　此皆须远离
  恼乱缘来逼　　慧力应须忍
  树下草[卄/積]中　　或居崖窟内
  观时应住此　　寂静可修心
  习定缘境时　　不太高太下
  不应极近远　　于境使相应
  善取所缘境　　子细善观察
  闭目住心时　　犹如开眼见
  根门皆摄敛　　住念凝内心
  缘境现前观　　念念令相续
  于前所取相　　形貌用心观
  膖胀女根边　　可畏可嫌贱
  犹如浊池水　　风吹令动摇
  观诸树影时　　不善分明住
  心垢烦恼水　　乱情风所吹
  澄念观察时　　闇昧不能住
  心沈应策举　　可观胜妙事
  如蛭饮血困　　水浇令使苏
  还应速收敛　　于旧境安心
  令意有堪能　　调善皆随念
  若其心掉举　　应思厌恶事
  令心寂静住　　如钩斸象头
  远离于沉掉　　应平等运心
  随情住舍中　　此时无过咎
  从此渐得住　　取相影心安
  明了中道行　　正念灯持照
  此时用寻伺　　次第应观察
  定影即便生　　分明现前住
  不动摇明净　　如大丈夫形
  此影望前观　　是为差别相
  此相既生已　　欲爱等便除
  即是系心人　　初定方便相
  次知嗔恚体　　本由贪染发
  欲爱既已除　　得离于嗔恚
  次以勤策念　　遣除昏睡心
  既观差别相　　疑情即便息
  次当除恶作　　善行安隐路
  寂静无障碍　　能防于掉举
  应知用粗寻　　观其所取相
  即于心影内　　以伺细推求
  见差别心喜　　由此得轻安
  次证于乐定　　定支次如是
  即是根本定　　善安于念心
  犹如欲至村　　及至村中者
  既获根本定　　更复作余修
  得他心宿住　　神通天眼耳
  于此有伺时　　心未能静住
  犹如河有浪　　非上地应知
  既得初定已　　仍于所缘住
  次依二静虑　　寻伺皆止息
  虽得住此位　　尚有喜水漂
  入第三定时　　其心便静住
  由其心有乐　　未能令住念
  既证四静虑　　众过并皆除
  退分胜进分　　住分决择分
  静虑有四种　　修定者初知
  若定顺烦恼　　此名为退分
  后胜为胜分　　自住住应知
  由先善分别　　是决择道因
  此定能招彼　　名为决择分
  于无常等相　　作苦等行解
  若得此定者　　是暖等道分
  于青膖等相　　观事有多途
  如圣教修行　　差别宜应识
  死尸风鼓腹　　穴处有脓流
  连跨并皆粗　　说名为膖胀
  不爱身粗分　　唯贪细滑身
  对此染心人　　令修如是观
  若于死尸分　　少有白脓流
  余肉并多青　　说此为青膖
  睹色而生爱　　斯名爱色人
  对治以青膖　　日亲之所说
  死尸脓遍出　　是谓脓流相
  对彼爱香人　　令观染心息
  死尸腰烂断　　名为断坏相
  对彼爱全身　　大仙尊为说
  尸骸狐貉啖　　鸟啄有残筋
  对治爱肌肤　　为说食残相
  手足诸支骨　　随处皆分散
  对贪支分人　　说骨邪乱相
  即于骨乱相　　刀杖斫分离
  亦为爱全身　　令观打乱相
  尸骸被刀斫　　或由鉾箭伤
  流血遍残躯　　名为血涂相
  净洁香涂体　　新庄着彩衣
  于此起贪人　　用斯为妙药
  于境唯独爱　　不许外人看
  多虫唼死尸　　令观除恶念
  骸肉皆销散　　但唯牙骨存
  于齿生贪者　　令观齿骨相
  若见新死者　　识去有残形
  乐着众生贪　　令除娇态欲
  屎尿及洟唾　　合聚共成身
  三十二种物　　皮囊唤作人
  发毛并爪齿　　肝肚等相因
  内扶三百骨　　横缠九百筋
  九孔流不净　　垢污秽难陈
  审观真可恶　　智者不应亲
  既观他女体　　亦复察己形
  于斯贪染因　　理应常系念
  不出三界狱　　咸由欲染心
  是故明智者　　极善思其事
  经多地狱苦　　幸会得人身
  岂得纵狂心　　不修殊胜行
  淫贪有多种　　随生爱不同
  一观并能除　　谓是白骨观
  色触形娇态　　衣缨生染着
  何药能除此　　无过白骨观
  先于足大指　　定心缘作疮
  破坏既脓流　　肉皆随堕落
  即观指骨形　　由如白鸽色
  其疮既渐大　　肤肉尽皆除
  作如是次第　　身肉皆除尽
  正念胜解成　　但观其骨锁
  若有片肉在　　即名为乱意
  况复纵心猿　　驰求趣诸境
  于多时系想　　自知能善住
  次渐及余人　　总观为骨锁
  渐宽至海际　　满中皆白骨
  此定既成已　　舍广复令狭
  略时从外舍　　乃至唯身骨
  还观足指端　　是定心次第
  或时片片舍　　极至于顶骨
  应知最后心　　眉间摄令住
  若作此修习　　常生胜梵宫
  不落堕三涂　　得生于五净
  人间散心善　　还流生死河
  智人修定心　　如救身衣火
  即可舍诸缘　　宜居静林处
  勿使无常逼　　虚死散心中
  以般若净心　　终获可爱果
  如不愿后有　　于胜道应修
  剃发着袈裟　　宜应修圣道
  自余諠杂事　　咸为生死因

止观行门七十颂


诸教决定名义论

    No. 1658

诸教决定名义论

        圣慈氏菩萨造

        西天译经三藏朝奉大夫试鸿胪卿传法大师臣施护奉　诏译

  归命一切佛世尊　　归命所说三乘法
  归命一切和合众　　归命普贤法界理

今当略说一切教中诸根本字。彼如实义此中云何。所谓

唵字最为上首。我今顶礼此字清净住不二相。若复有人能以此字舌上转者。彼得真实诸慧根本。此字于一切教中甚深秘密

复有三字。所谓金刚吽字而为正因。从是字中宣说一切正法仪轨。彼三界心此法如是。恶字为说相。盎字即空性。即彼恶字复为慧母。若道非道皆从是说。亦即法界文字根本遍入空性。初后相应由此正智而得成就。若法有说皆悉成就。彼无所说亦复如是。是故一切造作皆悉平等。于轮回中随顺而转

所言法界文字此复云何。是故今说。所谓

迦(讫当切)佉(去当切)誐(宜当切)伽(其当切)左(左当切)蹉(凄当切)惹(喏当切)酂(齐当切)吒(知江切)姹(敕江切)拏(尼江切)茶(直江切)多(低刚切)他(梯刚切)那(泥刚切)驮(蹄刚切)波(卑刚切)颇(纰刚切)摩(縻刚切)婆(步刚切)羊啰罗罔桑[元*欠](呼郎切)

如是诸字。即如前说彼盎字摄。此相今说是即空性。出生甚深一切教法。此复名为空空。出现一切说相。所谓迦佉誐伽左蹉惹酂吒姹拏茶多他那驮波颇摩婆耶啰罗嚩萨贺

如是诸字即如前说彼恶字摄。此相今说。谓即一一文字。皆从一切智智所生。初相应行我法二种皆悉平等。金刚加持究竟安住

复次一切事业皆从金刚三昧出生。所谓

迦(引)佉(引)誐(引)伽(引)左(引)蹉(引)惹(引)酂(引)吒(引)姹(引)拏(引)茶(引)多(引)他(引)那(引)驮(引)波(引)颇(引平)摩(引)婆(引)耶(引)啰(引)罗(引)嚩(引)萨(引)贺(引)。如是诸字皆阿(引)字摄。此相今说。谓一切金刚事业。复次今说

乌(乌功切)污(乌贡切)壹(伊灵切)翳(伊证切)哩(黎丁切下同)哩梨(里丁切下同)梨伊(依绫切)爱(依岗切)唵(乌笼切)奥(乌当切)

此中唵字相今如是说。谓即一切文字从彼出生

此中吽字相即如前说。一切事业皆从金刚三昧出生

复次如前所说诸字。谓即三身。若性若相如实安住。所谓

吽字即法身。阿字即报身。唵字即化身。如是三字摄此三身。彼分别说三乘解脱道。是为正说因。所有声闻缘觉及一切智智。由是出现说一切法。即彼三字。亦是金刚三业如实安住。所谓

唵(引)阿(引)吽(引)

此中唵字是名金刚身业。阿(引)字金刚语业。吽字金刚心业

又复阿恶二字安住空性。此中恶字亦为正智。此中阿字是即正觉最上秘密

又复吽字而为心智。觉了一切法。如上所说一切文字。当知皆从盎阿(引)吽三字所生。由是诸法起。种种相今当分别。彼一切法皆与盎阿(引)二字初后相摄。此中吽字出生一切。于三界中出现众色。所有天人龙阿修罗迦楼罗紧那罗乾闼婆。成就持明天吉祥天。辩才天乌摩天。帝释天梵王天。那罗延天大自在天。如是等天及天后。所有一切有情界中男子女人。乃至诸佛菩萨等。皆从此吽字出生变化。彼一一心住此字相

若心想此字时。当住虚空出生无碍。所谓三界心同此一心入。入是心已。此得名为现证菩提。当知此心无等无取无著无住无表无相。是即虚空平等一切智。无所得相应。无自无他相应正行。世间所有旃陀罗等。最下族类彼等诸行。乃至傍生等类。彼所行行种种差别。如是诸行虽复差别。皆亦不离一切智智相应正行

复次一切文字性非有说。然彼一切智智。于诸文字方便宣说

此中文字当云何义。谓虚空义。虚空何义谓空性义空性何义谓戍室啰义。戍室啰何义谓无说义。无说何义谓无相义。无相何义谓一切智义。一切智何义谓如意宝义如意宝何义谓即智义。智复何义所谓心义。心复何义谓彼三界大自在义。三界大自在何义谓遍照义。遍照何义谓梵天义。梵天何义谓大力天义。大力天何义谓自在天义。自在天何义谓即佛义。佛者何义谓金刚萨埵义。金刚萨埵何义谓观自在义。观自在何义谓世间义。世间何义谓轮回义。轮回何义谓涅槃义。涅槃何义谓不可数义。不可数何义谓不可知义。不可知何义谓无生义。无生何义谓无灭义。无灭何义谓无色义。无色何义谓无声义。无声何义谓无根本义。无根本何义谓无长养义。无长养何义谓无住义。无住何义。此无住者即无所有。离诸有智思惟分别。出过诸佛及佛菩提。安住金刚吽字根本。即此吽字复成莲华火曼拏罗。住空空性离尘法性。二种根本最上清净相应胜行

如是了知已。于轮回中勇猛精进。普令获得涅槃大乐。若住此心。是为智者灭苦恼法。二种根本皆悉平等。是为最上精进胜行。成就牟尼大安乐法。安住正念。如日光明普照世间。心智平等相应安住。所有一切甚深秘密如前所说。彼戍室啰及虚空分皆如是说

如是成就最上乐法。即得诸佛自性相应。了知世间所有众生一切生法。喜爱二种和合相应当知无性。彼无常法毕竟空寂

诸教决定名义论


阿弥陀经疏

    No. 1757 [cf. No. 366]

阿弥陀经疏

        京兆慈恩寺基法师撰

窃闻。三宝之宝理超系象之表。三乘之乘事涉名言之迹。原夫真际之理平等性空。赴机启权实之门。接凡施净秽之土。识其路者即语默一途。迷其趣者则理事天隔。故身子以高下之累则镜地而见丘陵。梵王以彼我俱亡则石田而观宝砾。是知净土之净志洁开极乐之门。秽刹之秽心尘起纯苦之域。良以物怀取舍。指悬鼓而可欣。人竞是非斥溷囊而可厌。故使励诚十念则高升日宫笃崇三行则迩登莲座。今言佛说阿弥陀经者。则越危城之要躅载苦海之慈船。语事目前论生界表。华手经曰。佛者名为觉。而诸众生长寝生死不能觉悟。唯佛能觉。既自觉已能复觉他。故名为佛。说者十住论云。开示解释义。阿弥陀者。此经下文自释。问何故名阿弥陀。答为含二义名阿弥陀。一无量光明故名阿弥陀。二无量寿命故名阿弥陀。经者法也常也。法即举直以措诸枉。绳墨以譬之。常即汲引而无竭。涌泉以况之。故言经也。佛地论云。能贯能摄故名为经。以佛圣教贯穿摄持所应说义故言经也。注文之初略申七意

第一叙佛身。第二叙其土。第三叙不退转。第四叙偏赞之心。第五叙体性。第六叙部类宗趣。第七判释文义

第一言叙佛身者。问诸往生者见佛何身。答见二种身。若登地菩萨见佛受用身。若地前菩萨凡夫二乘见变化身。问依何得知。答摄论云。若离应身登地菩萨善根则不得成就。若离化身声闻缘觉及愿乐位中菩萨所有善根亦不成就。故往生者见二种身。问西方有二弥陀耶。答约报即一。若化即百亿弥陀。问彼报化两身为同处现生者皆见。为别处现诸往生者但见一佛耶。答同一三千界内各见不同。若登地菩萨即见他受用身亦见百亿化身。若地前人等但见一身。问若同处不异者。何故入大乘论云。诸佛色身于欲界成道。法性生身者住净居天。其处即异。菩萨生者应生净居。众生生者应生欲界。云何同处。答上下虽殊。同是一报所生之境。但上人生者正见受用土无处非净居。众生生者即见化土在阎浮提。故真谛云。诸菩萨于净土见佛。此约报土一向纯净说。波颇三藏云。应佛净土有凡夫二乘地前菩萨。报佛净土唯大菩萨。如此经说彼佛有无量声闻弟子及大菩萨者。此约化说。问众生生彼亦知是下界否。及知是化身否。答下界知之。佛谓真佛。问彼佛有报化者。何故大乘同性经云如我今释迦牟尼佛及西方阿弥陀佛皆是报身耶。答此约本身说。谓极乐国土是一报佛所王之土。然百亿四天下中者即是化佛。亦释迦莲华藏世界中者即是报身。百亿阎浮中者即是化佛。问弥陀何不但现一实之身令圣凡同见。答由机福力不同故身现有其粗妙。问如彼观经云彼佛身长六十万亿那由他恒河沙由旬。又鼓音经所说是刹利种者。此并是何身耶。答如彼观经者是报身。鼓音经者即是化身。问何以知之。答准净居天身身量皆大。如来报身皆在净居色究竟天实报净土故报身大也。若在阎浮提示有种姓父母生处及有得道菩提树。如无量寿经说。其树高四百万里。鼓音经说。其所住城纵广十千由旬。又观音授记经云。弥陀灭后观音补处。据上因缘此身即小。又去来生灭故知是化。问若是化者。众生生彼即见化佛之身。至得初地之时复见何身。答若登地已上即见报身。问登地见报身者。为灭前化相而见报身。为复不灭而见报身。答即于前所见身相上而见妙身。如人服药惺时即于针上见种种华草。如是地地见佛身相转转胜妙。唯佛与佛见常不异无增减相

第二次问净土有几种。答有四种。一法性土二自受用土三他受用土四变化土。问四土之中西方是何净土。答若法性土者即是无垢真如。自性清净第一义空。本来湛然不假修成。为一切法之所依止。无一佛出世间法不有。名性净土。凡圣同有。凡夫尚隐。诸佛明显。若自受用土从三大阿僧祇所修善根万行所感。其土净与诸佛亦不可见但可得闻。唯佛自受用。佛地论云。此自受用土周遍法界。无处不有。不可说言离三界处。不可得言即三界处。若他受用土者佛地论云。诸佛为令地上菩萨受大法乐进修胜行。于后得智中以大悲故于诸菩萨大圆镜智相应净识之上。依诸菩萨业力如来与作增上缘。随其根宜现其净土。或胜或劣改转不定。地地优劣。如轮王所感。其土与众生同处。所见即异。若化土者佛地论云。随菩萨所宜。或在色界净居天上。或在西方等。处所不定。今取相而言。西方有二土。若登地菩萨各见他受用土。若地前生者便见化土。问云何知见化土。答若报净土诸佛平等无有优劣。若化土者随众生现而有差别故。华严经云。娑婆世界一劫当阿弥陀佛国一日一夜。彼国一劫当袈裟幢世界一日一夜。又首楞严经云。文殊未来于南方成佛名普现色身。其土胜阿弥陀国不可为喻。又观音授记经云。过去金光师子游戏佛土及观世音未来成佛佛土胜今阿弥陀佛土无量。又准大阿弥陀经等。其土既在欲界。上有六天复致优劣。故知是化。问众生生彼为生何土。答生化土。问若是化土。何故二乘女人不得生耶。答论据报土说。平等觉经云。众生生彼始得初果。乃至后得阿罗汉果作大菩萨。或生于彼始发菩提心。既有凡夫及初发心菩萨者即是化土。若言二乘亦不生彼。即谓一向是报净土者。彼观经中三辈九品云何得生。此经下文彼佛有无量无边声闻弟子。何得不生也。又女人亦不得生者。此阿弥陀经等皆云。善女人闻说彼佛名执持不忘。必得往生。此云何通。又若彼土一向无女人故即谓是报土者。鼓音经云。彼佛父名月上。母名殊胜妙颜。此岂无女人也。女人根缺不生者。由彼佛本愿愿生我国者皆作男子六根具足端严胜天故。清净觉经云。女人往生者则皆作男子。故言无女人及以根缺。非是此处女人此间根缺不得生彼。问若是化土。何故摄论云称别时意。答论言别时意者有二意。一以彼土增上乐处非少福能生。二见众生多不修道空唯发愿。有斯二意故道别时。即是弥陀经云不可以少善根得生是也。若六时念佛即三业无非。便是持于十善。或一日乃至七日由念佛故一念即除八十亿劫生死之罪。此即有多行又复愿生行愿相资。问若是化土。何故大论云非三界摄。答彼言非三界摄者。非谓出过三界。但谓异三界故。故大论云。地居故非色界。有形故非无色界。无欲故非欲界。故言非三界摄。又佛地论云。此是佛出三界净识心所现。为化地前诸有情类令其欣乐修行彼因。令声闻等见。若谓非三界者即谓出过三界。与彼平等觉经相违。问若是化土。何故解深密经三地已上乃得生彼。答此约他受用土说。他受用有二。一为登地已上现者。令登地已上人受用。二为地前人现者。令愿乐已前人受用。即化净土。彼经据诸大菩萨生彼者约受用土说。非是西方一向是初地已上净土。由有凡夫二乘亦得生故有化土及受用土。问若是化土。众生生者初见何土后见何土。答初见化土后见受用土。问何处见此二土。答于一界中一相之土初见粗后见细。非灭前土而见后土。亦非异处见其二土。故佛地论云。释迦如来说佛地经时。地前大众见变化身居秽土说法。登地菩萨见受用身居佛净土说法。问若生彼见化佛又居净土。我此释迦亦是化身。其土何以不净。既自不同。明知彼净土是报土。此秽土是化土。答依大论引目连问经。释迦亦示目连己身净土。又佛说言。一切诸佛皆有净秽两土。如释迦牟尼有净秽二土。今十方诸佛阿弥陀佛亦尔。问诸佛既同有净秽二土。何故阿弥陀不见有秽。释迦牟尼佛不见有净。答由此众生有乐见净土者。但说净土之名。又由众生不苦则不求涅槃。所以释迦于众生恶业之上作增上缘示现秽土令众生厌。然非释迦亦处其秽。故涅槃经云。诸佛无有出于不净土者。为化众生示现净秽。故维摩经云。若诸众生应以此缘得入律行者佛即为现。问若彼土是化又居欲界者。亦应有须弥大海。答以佛本愿力故无诸山川江海四王忉利。以福力故依空即住

第三次问彼是不退转地。众生生者皆不退转。云何但以念佛发愿而不断惑即得往生。答彼言不退者。但以彼地胜缘强时长无间遂得不退。非亦生即是不退。言地胜者。众生有宜安乐适悦即能发心。即有比丘愿得七宝房舍卧具者是也。彼土既无三恶道。又无贫穷生老病死。国土清净百宝庄严胜第六天。故是地胜。言缘强者。彼无五退具。如婆沙说。一无长病。二无远行。三无常诵习。四无常营事。五无恒乖诤。此五因缘令心劳倦故多生退心。又无女人无淫欲无迷爱。于六尘境虽见闻触心全不染。又无恶友常与诸菩萨每至平旦历供诸佛。水流风树皆演法音。以是缘强故令不作恶业更退三途。言时长者。娑婆一劫当彼一日一夜。又彼众生寿命无量无边阿僧祇劫。经尔许时修行。何为不至不退转位。言无间者。胜人胜法无间资持受最后身。斯何可退。又不退转者有其三处。一若依璎珞本业经。地前第七住名不退转住。若修行者进退多在第六住末。若至第七住毕竟不退。是人入种性菩萨数。二者依弥勒问论及智度论云。菩萨若未至初地正位。虽无量劫修习善根。而未能得不退转。若至初地。以见道力离身见等诸烦恼。故断发菩提心相违退因故更不退。三者依资粮论云。若菩萨得无生忍时即住不动地。必当作佛更不退转。此即当于八地。以无生忍在七地故得无生忍已至八地中更不退转。今准观经。众生生彼得不退转者。但谓初地得生法二忍更不退转。非取七地。究竟而论亦得成佛。何但七八地也。若言念佛非断惑者。此非解烦恼性故不能断。然能伏惑令其不起。且如人一心念佛。意地当更不起贪嗔嫉妒邪见也。由念佛故转无始恶业生无量功德。遮无量恶业止无量三不善根。又纵不断烦恼。但生到彼地方断烦恼。然后渐渐乃得不退。于理何过

第四叙偏赞之心。次问十方更无净土。何以独赞西方。答非为更无佛土。恐众生境繁心乱。故随愿往生经云。此处众生信向者少习邪者多。心意无定故令众生专心有在。故偏赞也。又若言十方皆有净土。众生之心则便慢缓。若唯一处心即殷重。问弥勒下生此土亦净。复是同界。佛劝生彼何胜此间。答此虽言净由劣四天。当知西方胜过自在。又复此界有三恶道女色淫欲便利之秽。何得同彼。地既非胜终还退转。所以赞彼

第五叙体性。次问净土以何为体。答摄论云。唯识智为体。谓佛及菩萨唯识智为体。即金刚般若论云。智习唯识通。如是取净土。若佛地论。以佛自在无漏心为体。非离佛净心外别有宝等净色也。又释者。是彼佛大慈悲愿力无分别后得智为体

六次问此经部类多少宗趣所明。答穷括部类。有其四本。通明净土即以净土为宗。一观经二无量寿经三小阿弥陀四鼓音经。又如晋时帛延译无量清净平等觉经。又有大阿弥陀经两卷成。即与宋元嘉年中所译无量寿经及前清净觉经而同本异译。准此观经亦宋元嘉年中求那跋摩译与彼全别。今寻捡四经。部部之内虽则俱明净土。然旨趣不同。如此观经教修净土之业。即以定散二善为宗。如无量寿等三经。如来观众生净土机熟宜闻说时至。故释迦颜色胜常。阿难因起发问。世尊颜色欢悦者。应念过去当来现在诸佛胜妙事也。佛赞阿难善哉能问。因为广说西方净土之事。即以净土为宗。如此小阿弥陀经又问何故名极乐。极乐之事未知虚实。如来因为释得极乐之名。及引六方诸佛证成非妄。此经即以断疑证实为宗。如鼓音经人疑彼佛为天为人是何趣类。又彼净土增上报处。众生多有业障。或恶魔留难。云何得生。如来为辩弥陀是刹利之种。又教忏悔诵咒令转业除魔。彼经即以转业护难为宗。上来即辩四经宗趣及部类多少。然四经前后者准其道理。先为说令知。次教修净业。次断疑证实。后护难不生。即无量寿经初。观经第二。小阿弥陀第三。鼓音经第四。然以事推验。即观经为初。无量寿为二。何以知之。准说观经时阇王犹为太子。创夺父位。母时见害因请净土。如来为现西方教修定散二善。若至说无量寿经时。阇王已登位。太子作储君。故大弥陀经等云。如来说西方事时。阿阇世王太子与五百长者持盖献佛。闻说弥陀二十四愿。其太子当发愿愿如彼尊。佛记却后皆得如弥陀佛。以此知居第二也。人云。阿阇世王太子者阇王身是。尔时由未篡位故为太子来至佛所。今释不然。若尔应除王字但言阿阇世太子。既标王及太子。明知即父子名殊。是故无量寿经当第二说。而观经自为夫人侍女。无量寿经自为人天大众说也。问若观经是初为夫人说者。何故下经佛还灵山令阿难重演而众无所请。明知大众已曾闻故。由已闻故更欲令闻修生彼业。所以如来敕令重演定散二善。何得即以观经为初。答如来意令大众知定散二善三世诸佛为净土因故令重说。又冀此经永传末代。后若结集知阿难所传不虚。所以令说。非为已闻后不请而说。即当第二。其余二经如前所释可知

七判释文义。今判此经遵之往古亦为三节。谓序正流通。然依大悲开五分。一信分。即彼经云。在在处处佛所说法。谓如是我闻等。二证分。即彼经云。在在处处大众所集。谓与大比丘也。三缘起分。亦名发起分。即彼经云。随其因缘。随其由序也。此经略无人云。以尔时佛告舍利弗下为发起。彼土何故名为极乐下为正宗分。今恐不然。但如来初略举示。次广分别。此总是正宗非发起分也。四正说分。即彼经云。随其名句味种种广为人说等。即尔时佛告舍利弗下是也。五奉持分。即彼经云。佛说经已大众欢喜顶戴奉持故即佛说是经已是也。然诸经论中初之二分并为证经非谬。开合无在。就初信分文复为五。一信二闻三时四主五处。流支云。此之五句文为证三义故佛教之。一证是佛说令物生信。二表异外道经书阿呕吉义。三为息诤论知非结集者言。又智度论云。说时方人欲令众生闻之生信。是故此五句名为信分因缘。广如彼论说

经曰如是。次释信也。智度论云。佛法大海信为能入。若人有信能入佛法。是故信者闻之即云如是。若不信者言不如是。故知如是者表信也。人疑云。经尚未宣。预信何事即言如是。答如指题目及题后经。是佛所说非我自言。闻者应信。故真谛云。如是之言标所闻法。明一部文理决定可信从故云如是。流支云。如是之言具有四义。一发心义。谓自念言我当如是发心如是修行也。二教他义。谓汝当如是发心修行也。三譬喻义。谓是人威德智慧得如天如日也。或汝今如是富贵如树提伽。四决定义谓我所见闻其实如是。今取此义故云如是。又佛地论云。如是有四义。一譬喻二教诲三问答四许可。如彼论说。即许可义故言如是。谓我当为汝如是说也。真谛云。如是者谓所信法体有二义。一就佛解。谓三世诸佛所说不异故名为如。以同说故即知非妄故称为是。正以诸佛同说其法可信故言如是。二就理解。谓诸法实相古今不异名之为如。如如而说不增不减决定可信故云如是。又有问者。此之五句皆为证是佛所说令人信受。何但如是两字独名为信。答义实如是。但为指名定实可信义彰故言为信

经曰我闻者。次释举能闻人也。佛地论云。如来慈悲本愿增上缘力闻者识上文义相生故曰我闻。又我谓假者。即一身之总称。闻谓于耳。即六根之别名。今废别就总故曰我闻。问谁言我闻者也。答据元意。但结集者教作此言。然大悲经第四云。佛将涅槃执阿难手付属一切佛法。及第五卷教结集法用。又处胎经第五当结集时令阿难升座。迦叶告言。佛所说法一言一字汝勿缺漏。菩萨藏声闻藏律藏等各集一处。时阿难即言如是我闻。即是阿难称我闻也

经曰一时者。次释说经时。谓说此一部经时故佛地论云。说听究竟总名一时。若流支云。佛说此经。我及大众闻无异时故言一时。又如来正演之际。群生即听之辰。说则教尽其宜。听即法充其量。故曰一时

经曰言佛者。次释教主也。所以此中标佛者。为简余人。故智度论云。有五人说法。一佛二佛弟子三诸天四神仙五变化。表非余人说故故言佛。梵魔喻经云。所言佛者。生死根本燋然尽无余。诸疑已尽无所不达。得一切智。尊号为佛。放光般若云。诸佛所行所证之道名觉。诸佛皆共觉故故名为佛。大法炬陀罗尼经云。梵天王问佛。何故名佛。佛言能于生死得觉悟者名之为佛

经曰在舍卫国祇树给孤独园者。次释说经处也。此又有二。一境界住。谓天子所统之方即舍卫国。二依止住。谓如来所居之处即给孤独园也。舍卫者此云闻物。故法镜经云游于闻物。三字生经胜氏树十二游巡经云。其国无物不有。天下闻之故名闻物。善见律云。此名多有。昔道士修行于此。时王出游见此地胜。就乞立都。地从人立名为舍卫。舍卫者即地主之名故言舍卫国。祇树者是彼国太子之号。谓之只陀亦言誓多。此云战胜。施其林树与佛经行故言祇树。即阿含经称林者是也。给孤独园者。别译阿含第九云。长者须达多诣王舍城初见于佛。即自称言。我舍卫国人名须达多。此翻善施。乡人以我好给独老。众人称为给孤独也。后买只陀之园造佛精舍故言给孤独园。良以君上而臣下故先只后给。以别归总故初树次园

经曰与大比丘众。次释别证也。即举同闻此经众。准经首末略标五众。一声闻二菩萨三天四人五修罗。今经初有三。经末有二。经初三者。一声闻二菩萨三诸天。声闻众有五。一标类二唱数三举位四列名五结定。与者。其义兼人及己。大者。名称位高。善见律云。僧中功德极大者名大阿罗汉。又最小者名须陀洹。又多比丘众故言大也。比丘者。智论云此有三义。一者名为能怖。能怖魔王及魔人故名比丘。二名乞士。能离邪命清净行乞以资身命故名乞士。邪命者此有三种。一离口邪命。不以禁咒妄说吉凶得资生具以活命故。二离身邪命。不行合药书符耕田种作及手作器得价资养。三离身口邪命。谓口不诵禁咒。身不然火及杨枝折等。出僧祇律。又智度论有四邪命。一仰口谓仰观星象薄蚀。二下口田种作器。三方口为他驱使四方。四维口合药卜筮兼前三事。若作此四得活身命名四邪命。比丘之法不行此四事。应清净行乞名为乞士。三比名破。丘名烦恼。能破烦恼故名比丘。言众者。比丘非一故称为众。或多僧和合故名为众也

经曰千二百五十人俱者。唱数也。谓常随。旧谓如来所度三迦叶二外道师弟合有千二百五十人。为报佛恩恒随给侍。今按名讳事恐不然。即如罗睺大迦叶等常在其中。岂亦是彼之徒侣也。今据长阿含第一云。佛言劫将欲末诸物减损。如前迦叶佛一会说法弟子常二万人。今我释迦牟尼一会说法弟子有千二百五十人也。言俱者。善见律云共在一处

经曰皆是大阿罗汉众所知识。次释举位也。初举得位即罗汉。次举名闻即众所知识。所言大者。谓腊高德上。即迦叶结集中言。若阿罗汉具三明八解脱大罗汉者住。故言大也。阿罗汉者。善见律云。阿罗之名义舍五种。真谛云。其名有六。一名杀贼。即阿罗名杀贼。汉名为能。谓三界见修烦恼侵善法财喻之如贼。又六尘如贼。是人能以智慧力断之令尽。证六尘空。况之如杀。真谛称杀怨。即涅槃经云。一切烦恼是菩萨怨。佛应害之故言杀贼。三果虽断未能全尽。不与此名。二者阿罗名一切恶业。汉名远住。是人远离一切恶业住无漏善功德中名阿罗汉。真谛称不生。谓是人虽有故业。无烦恼缘润故。彼旧业如六年陈种无力能生。故阿罗汉言我生已尽。故名不生。不生何处。谓不于三界烦恼之中更受生死之报。三者阿之言无。罗汉名覆藏。世人作恶即自覆藏。彼不作恶亦无覆藏。是故罗汉自称梵行已立。四者阿罗谓三界车轮。汉称打破人。能打三界十二因缘轮转车轮故名阿罗汉。即真谛称为破轮。谓破十二因缘轮。即以无明爱取为辋。谓烦恼贯穿三故即以行有为毂。由业能生种种报故。即以现在五果识等未来二果谓生老死总七果为辐。五者名应供。是智断具足胜福田堪消物养能生大利故名应供。若真谛云示不偿。谓不偿生死债故。是人由三学圆满四流永绝一向涅槃不入生死故名不偿。六名应教。谓自觉已满。将己所证堪应教人故名应教。若大品经云。是人断五上分结尽名阿罗汉。五上分者。一色爱二无色爱三禅四慢五无明。此五是上二界结性。谓将至上分故随生上界。生上界缚故说上分结也。此五一向思惟所断。是人由断尽故名阿罗汉。众所知识者。此举名闻。法华论云。诸王王子大臣帝释梵天王等皆知识故。又声闻菩萨佛等是胜智者。皆善知识故。又释一切凡圣识其形容知其种姓故

经曰长老。次释四列名。今列十六人。其中阿难虽非罗汉。以德望隆重亦是众所知识故在此会。善见律云。老者而言大德。少者而称长老。增一阿含云。佛言自今已后诸比丘不得君卿相向。大者称尊。少者称贤。又小比丘向大比丘称长老。大比丘称小比丘字。准此二文尊卑不定。今据长阿含云。老有三。一年耆二知法三善作。又智度论引宝顶经。普化菩萨呼舍利弗为耆年。今称长老者。一是年尊。二者知法。如俗有先生之称长老之名。谓赞美其德不言其讳

经曰舍利弗摩诃目犍连。次释此二人。本为外道情同莫逆俱时悟道。所以合列。增一阿含云。富楼那问舍利弗言。仁者诸人称仁者何等号。答曰我父名优婆提舍。我母名舍利弗。从母称名舍利弗。大论云。其母目如舍利鸟目。佛华严入如来智德不思议经云。舍利此云鸲鹆。弗多罗此云子。故涅槃经云。如舍利弗因母立名名舍利弗。良以女仪端齐贤才冠世清扬之目眸子圆明。母擅令名。子承嘉号。又罗云忍辱经名鹙鹭子。又中本起经云。舍利弗者本名优波替。佛言汝与目连者同时发愿。我成道为佛左右弟子。今既遂心。优波替者高世之号华而不实。复汝本愿还字为舍利弗。拘律陀亦复如是。汝自本目连。婆沙论云。舍利翻为身。弗之言子。名为身子。然优波提舍亦名优婆替舍。大论此翻为彗星。谓身子父名优波。此言彗。提舍此言星。故言彗星。舍利弗若逐父名应名优婆提舍。摩诃言大。文殊问经云。大目犍连此云萝茯根。其父好啖。因物为名。若涅槃经云。目犍连是姓与过去因果经同。此云赞诵。字拘律陀。因接拘律陀树而生。故真谛云应名勿伽罗。此云爱胡豆。爱胡豆即菉豆也。上古有仙人唯食此豆。是彼仙种因姓为名

摩诃迦叶。迦叶者此翻为饮光。真谛云。其人先祖是大仙。身有光明能饮诸光皆令不现。是彼仙种故名饮光。但迦叶之身尚胜金色。饮光之号继祖未详。文殊问经翻为龟。良恐误耳。律毗婆沙云。以迦叶多有胜故以大标之。以五事胜故名大。一富贵长者所生故。二能舍大富贵豪族出家故。三能行头陀少欲知足故。四国王天龙鬼神多知识可供养故。五舍世间大利养行少欲知足行乞食故。又迦叶本起经云。王舍城内有大富梵志名尼拘律。此云无恙。有子名毕拨罗。即大迦叶也。迦叶是姓。毕拨罗是字。佛弟子中头陀第一。佛当见来分座令坐

摩诃迦旃延者。真谛云。此翻思胜。古昔有仙。由闻思胜余人故。是彼仙种故名思胜。旧号肩乘。人云。将应误。应名扇绳。义将稍切。其父早亡唯母孤养恋不再嫁。如扇系绳。以此为号。又释。迦旃延者是姓。扇绳是字

摩诃拘絺罗。此云大膝。骨高大故。是舍利弗舅。甚大聪明初为外道师名长爪梵志

离婆多者。文殊问经翻为常作声。未详其义。相传云。依智度论。此翻为假和合。谓假死人头顶手足而成体故。按彼论第十四卷泛说一人不言名字。未知此是此人不。有人路行夜寄神庙中宿。有一老鬼持一死人来欲吃。即被一少鬼欲夺。各言我许。分竞无定。乃引彼人为证。彼人思惟。我实语亦死妄语亦死。宁实不虚。即云老鬼将来。彼少鬼发怒。便擒彼人挽取臂咬乃至头脚。老鬼惭愧此人为证。便取死人手足及头挟着。天晓而去。口云为是我身为非我身。遂至一伽蓝问僧是我不。因问自说如上之事。僧云汝身本来四大五阴假和合成。何但今日方和合。即出家后得罗汉

周利槃陀伽者。依佛华严入如来智德不思议经云。翻为继道。善见律翻为路边生。有一长者。止有一女与奴私通。遂逃他国久而有孕。垂产思归。行至中路即诞其子。因名路边生。如是二度凡生两子。长名槃陀伽。弟名周利槃陀伽。以兄弟相继于路边生。兄名路边。弟名继道。即周利槃陀伽也。增一阿含云。其人父母并亡。兄厌家入道。其弟寻复出家。性甚愚钝。兄怒之曰。汝不能持诵。又加懒惰幸即归俗。牵出祇洹门外。号泣而立。如来见之知其道根将熟。唤之在侧付扫帚与。汝诵此名。此名亦号除垢。若日诵之得扫。忘帚乃即思惟此名除垢之义。除者应是清净。垢者应是身中结缚。思惟忽然悟解成阿罗汉果。处处经其人过去遍通经论。藏秘不说。临死悔恨曰。我所解不为人说。用解何为。由我秘惜故今则暗钝。以临死悔恨故今经二十四年记五字因之得悟。又五百弟子本起经云。我昔放猪驱令渡水。以绳系口。猪不得喘息中流而死。以是罪因于是后身犹尚曚昧。我讽学一偈三月乃知。增一云。然能化形体作若干变

经难陀者。大威德陀罗尼经云有四。一者但言难陀此云喜。二修难陀此云善喜。三阿难陀此云欢喜。四婆难陀此云贤欢喜。今言难陀者。即佛之亲弟。本姨母所生孙陀罗婿也。所以名喜者。时王白净适有悉达弃家入道。无人嗣位心常致忧。及生难陀。仪貌似兄堪继洪业故心生少喜。别译阿含云。佛言我弟难陀者能摄诸根不着六尘。饮食知节才以止饥故名难陀。又增一云。身形端正与世殊异。诸根寂静心不变易故名难陀。五百弟子本起经云。由过去施僧暖浴室及洗一比丘僧。即得无垢身形端正色妙如华。又曾修饰辟支佛塔。又见迦叶佛塔建立刹柱安承露盘。以是诸因今生释氏得为佛弟。有大人相身长一丈五尺二寸

经曰阿难陀者。智度论云。如来得道夜生。朝有天人空中告白净王曰。悉达太子昨夜明星出时成一切智。王闻欢喜。又王第三弟斛饭王复是其日来启王。昨夜生一男。王曰贵弟生男我心欢喜。今日大吉。尔所生子应字阿难。此云欢喜。又以其人世世修忍辱故生身端正。父母欢喜。因以为字。观佛三昧经云。佛告阿难汝名欢喜。此则依名定实。增一云。阿难有四希有。令人欢喜。一者默然至大众之中见者皆喜。二者正有所说闻者亦喜。三者至四众皆生欢喜兴敬仰心视无厌足。四者正有所说闻者无厌故心生欢喜。大论云。其人昔作长者。因施诵经沙弥食。遂发大愿言。小师成佛愿我为多闻弟子。故今如来所有法藏悉能受持

罗睺罗者。此云覆障亦曰宫生。五百弟子本起经云。我昔为王。有一仙人犯罪。禁安后园忘经六日不与其食。然我无恶心以忘因缘遂堕黑绳地狱经六万岁。最后身受胎六年乃生。故言覆障。谓被胎膜久所覆障也。佛出家六岁罗睺罗乃生。诸释皆疑非是释种。佛成道后还宫说法。其妻耶输陀罗此云名声。欲自雪身知其清白。乃以欢喜丸与罗睺罗令奉汝父。佛知其意乃变弟子皆作佛身。罗睺罗献奉而不错。佛既受已化佛皆灭。诸释方信实是宫生。入大乘论云。罗睺罗久住世者是变化身

憍梵波提者。佛华严入如来智德不思议经云。翻为牛王。大论翻为牛齝。处处经云。昔作比丘摘他一穗谷观其生熟。五百生来与他作牛偿力。如今得道足犹似牛食后即齝。因名牛齝比丘。分别功德论云。恐人毁谤得罪。佛令居忉利天。尸利弗沙树下坐。解律第一。佛涅槃后结集法藏时。大迦叶令使命之。今阎浮提有大法事。问曰佛般涅槃耶。答佛已涅槃。我和上舍利弗在不。答先已涅槃。乃叹曰。我大师已灭度。和上复涅槃。世间眼灭。不能复下。即化火烧身。四道流水注阎浮提结集众中。水说偈云。憍梵钵提头面礼妙众第一大德僧。闻佛灭度我随去。如大象去象子随。于是天上涅槃。大论亦如是说

宾头卢颇罗堕者。大智度论云。宾头卢颇罗堕誓能师子吼第一。按请宾头卢经云。宾头卢是字。未详其义。颇罗堕誓是姓此曰利根。但一切新作屋宅浴室斋会新衣上服先奉请。凡欲请者。当于静处烧香礼拜向天竺国摩利山至心称。南无大德宾头卢颇罗堕誓受佛教敕为末法人作福田者愿受我请。毗奈耶律云。其人本贪木旃檀钵。为树提长者现神足往取之。佛责之不听住此界。即往西衢耶尼教化众生。三摩竭经云。佛欲度彼事裸形外道难化国王故。令诸弟子皆现神变一时至彼受其所请。时宾头卢在于山中。缝衣乃忘去忽忆。以针刺地綖犹着衣。便运神足即往。其山以针綖所牵遂随后去。时彼国有一怀孕妇人。见大山蔽空而至惶怖堕胎。佛遥知之令目连往语。汝后何山。宾头卢回顾见之。把得此山一掷八千里。佛语之曰。我教化众生皆欲涅槃。今汝失期又杀一人。人命既重我所不喜。汝从今已后不得复随我食及预众会。留汝作后世福田。至弥勒佛出乃得灭度。宾头卢闻忧恼自责食讫入山。入大乘论云。阿罗汉无烦恼者与八住菩萨同修如意足能随意住世。即宾头卢是变化身非实身也

迦留陀夷者。正法华云。此名黑曜。毗奈耶律云。名黑光。增一阿含云。迦留陀夷其身极黑夜行乞食。时天大闇而至他家。天有闪电。彼家妇人身正怀孕。于电光中见谓是黑鬼怖而堕胎。乃谓之曰。汝何鬼耶。答曰我瞿昙弟子今来乞食。彼女人即发声恶骂。如来知之即敕比丘。从今日已后不得过中食亦不得预乞食

摩诃劫宾那者。此云房宿。相传云。以其初入道门在僧房宿。佛知道根将熟。即自化为老比丘与之共宿。因为说法而悟圣道。故名房宿。亦名房星。因祷房星而生故以为字

薄拘罗者。此云善容。谓好容仪。过去曾持一不杀戒。今得五不死报。一釜煮不死。二[金*敖]搏不燋。三堕水不溺。四鱼吞不烂。五刀割不伤。五百弟子自说本起经云。我昔曾施病僧药及施沙门一呵梨勒。九十劫以来不堕恶道。今年一百六十未曾有病。又分别功德论云。薄拘罗者昔作长者因醉入寺唱曰。诸比丘有须者当至家。明旦有一比丘来索药言患头痛。长者曰此膈上水仰攻其头头遂痛也。即施一呵梨勒果。比丘服已得差。由是九十一劫未曾有患。至年八十出家学道至今八十余年。合一百六十年。中阿含经云。我持粪扫衣来八十余年。未曾忆受用针线缝衣及针绵囊乃至一缕。未曾从一大家乞食。未曾视女人面及入比丘尼房。亦不共语。未曾忆畜一沙弥。且不曾暂患头痛等。亦不曾服一片药。八十年来常结跏趺坐未曾倚物。杂阿含云。佛灭度之后时阿育王遍礼诸塔广施珍宝。闻薄拘罗少欲第一乃施一金钱。时彼塔神还掷出之。王言善哉真实少欲一钱亦不受也

阿[少/兔]楼驮者。亦云阿泥卢豆亦言阿[少/兔]楼陀。此云如意。正法华名淳[少/兔]。是白净王第四弟甘露饭王之子。其人过去曾以一食施辟支佛。五十劫来天上人间受胜妙乐。末后生此释种之中得阿罗汉。常求如意故以为名

经曰如是等诸大弟子者。次释结也。等者等及余人也　次明菩萨众文有三。初标类次列名后结定

经曰并诸菩萨摩诃萨者。初释标类也。智度论云。按梵本应名菩提萨埵摩诃萨埵。今此释云菩提谓无上智慧。亦名为觉亦名为道。萨埵言众生。或言大心或云勇猛心。摩诃言大。是人为无上智慧道故。发生大勇猛心故。菩下去提萨下去埵故言菩萨摩诃萨。小品经云。是人为觉一切法无障碍义名为菩萨。常为大众作上首故名摩诃萨。道行经云。是人于一切法悉了悉知故名菩萨。天上天下最尊胜法名摩诃萨。十地论云。摩诃萨者有三种大。一愿大。起愿普及法界。不同二乘但求自度故。二行大。菩萨起行无有难行不行难舍不舍难作不作故。三利益大。菩萨愿深行远。凡所施作皆欲利益一切众生故

经曰文殊师利法王子者。次第二列名。按梵本云曼殊室利。此云妙德。新译称赞净土经名妙吉祥。正法华名溥首。有经名濡首。悲华经云。过去有佛名宝藏如来。时转轮王第三子聪明智慧。发深大愿修菩萨行。彼佛语言。我今字汝为文殊师利。今依旧目为名。问彼人为实菩萨为示现人。答依首楞严经云。过去不可思议阿僧祇劫于此南方作佛。世界名平等。佛号龙种上尊王如来。即文殊菩萨是也。央掘魔经云。今北方有刹名常喜。佛号欢喜藏摩尼宝积如来。文殊是也。又菩萨处胎经云。文殊言本为能仁师。今为其弟子。二尊不并化故我为菩萨。璎珞经第四云。过去久远有佛名大身者文殊师利是也。又文殊师利佛土经云。却后于南方作佛名普现。世界名离垢心。胜阿弥陀国。又文殊涅槃经云。佛告言我灭度后四百五十年。文殊从雪山出。趣本生处舍卫国多罗聚落。现其妙身三十二相八十种好放大光明。奄然光灭遂即涅槃。留全身舍利一丈六尺。如净琉璃内外明彻。心中有真金像。结跏趺坐莲华上。长六尺。其文殊全身左臂有十佛印。一一印中有十佛名字。右臂有七佛印。一一印中有七佛名字。若人念文殊者。先当心想琉璃像及心中坐像。又一念其名除十二亿劫生死之罪。若至心者七日必现所愿得从。香山有八鬼神。移置香山顶上供养。法王子者。谓从佛化生从佛口生。佛为法王。人为法子。彼菩萨堪嗣圣种故言法王子。佛地论云。从世尊口正法生故能绍佛种令不断绝名法王子。十住菩萨名法王子住。何以故。次绍佛位故。何况其人过去佛也。但示为菩萨堪继法王故。放钵经云。释迦佛言我今得佛是文殊恩。文殊是我过去本师。过去无数诸佛皆文殊弟子。当来亦尔。文殊者佛道中之父母也

阿逸多菩萨者。依新译称赞净土经翻为无能胜或言弥勒。此云慈氏。由彼多修慈心多入慈定故言慈氏。修慈最胜名无能胜

乾陀诃提菩萨。未详所译。然称赞净土经第三菩萨名不休息。未知为即翻此乾陀诃提为当非也。若是不休息者。即教众生不绝名不休息。正法华名不置远

常精进菩萨者。正法华云常应时菩萨。涅槃云。如是时中任修布施。乃至任修智慧。随时不懈名常精进

经曰与如是等诸大菩萨。次释结也　第三明天众

经曰及释提桓因等无量诸天大众俱。次释天众。智度论云。释迦为能。提婆为天。因陀罗为主。谓能为天主。又云释是字。提桓因是号。或称憍尸迦者。彼于往昔在摩诃陀国作婆罗门名摩伽。姓憍尸迦。此人有大福德。与三十二友发心修迦叶佛破塔基故俱生忉利天上。摩伽为主。称为帝释。佛呼本姓故言憍尸迦。或言千眼。以其过去聪俊故。少时能断千事故称千眼。问是何位人。答有言是须陀洹。有言是大菩萨。有言是凡夫。所言不定。等者。谓兼及下。其数非一故言无量诸天大众俱。谓上来别证分亦言证信序了　自下第二正说分。有人用此以下为发起分。今谓不然。此净土之事如来前已说故。但舍卫国有人未闻者故无问自说。若以此下乃至无有众苦名为极乐是发起分者。如观经指西方日没等观亦应是发起序。故知此下即为正说分。文有六节。一标净土果。二举净土因。三引六方以证诚。四指三生以显实。五他述希有。六自叙甚难。就初文复分二。先略后广。就略中复有七段。一指方处。二述远近。三举国号。四显导师。五明垂化。六征题目。七释得名

经曰尔时佛告舍利弗从是西方。次释指方处也。善见律云。尔时者发起义因义。谓发言之因起。有释。传经者言当尔之时佛告身子故曰尔时。从此西方。即清净觉经及观经当日没处是彼国土。随愿往生经云。普广菩萨白佛言。十方可无净土。今乃偏赞西方。佛言十方净土理实无穷。以此处众生信向者少习邪者多心意无定。欲令众生专心有在故我偏赞。即涅槃经云。一切诸佛无有出于不净土者。为化众生示居秽境。又智度论引目连问经曰。佛言如我释迦牟尼有净土秽土。我今西方阿弥陀佛一切如来亦尔皆有净秽。但以机缘有宜故致差异。即维摩经云。应以此缘得入行者如来为现。今之西方机所宜矣。佛知根性故赞仰之

经曰过十万亿佛土。次释第二定远近也。若观音授记经云过百千佛刹。清净觉经云过千亿万须弥山佛国。无量寿经云去此十万亿刹。语虽似殊土数相似。菩萨处胎经云。去此西方十二万亿那由他有懈慢国快乐安稳。人欲往生阿弥陀佛国者从此国过。人多染着即愿生其中遂不得到阿弥陀国。若见不贪不爱。即得越过到安乐国

经曰有世界名曰极乐。次释第三国号也。此即处圆净。无量寿经名安乐。若清净觉及大阿弥陀经并云国名须摩提。须摩提者应是梵语。安乐极乐应是汉音。若鼓音经世界名安乐。如来所生之国名清泰。圣王所住。其城纵广十千由旬。于中充满刹利之种。国名如后释

经曰其土有佛号阿弥陀。次释第四显导师也。此即主圆净。名如后释

经曰今现在说法。次释第五垂化也。谓以法教众生

经曰舍利弗彼土何故名为极乐。次释第六征问题目也

经曰其国众生无有众苦但受诸乐故名极乐。次释第七得极乐之名。其国者即如来所统之境。众生者是如来所化之机。大法鼓经云。一切法和合施设名为众生。谓四大五阴十二因缘十八界等合成假名为人号曰众生。般若灯论云。谓有情者数数生故名为众生。大品经云。无有法可名众生。但假名故号为众生。是名字本无有法。强为立名名为众生。不增不减经云。此法身本性清净。但为恒沙烦恼所缠。随顺世间往来生死即名众生。无有众苦者。无量寿经云。彼无苦难之名亦无三恶道。但有自然快乐之事。亦无少苦故。央掘魔经云。无有少苦。纯一快乐故名极乐。又无八苦故莲华化生即无生苦。国无老病无有病苦。年寿欲尽愿生十方净土。随意往生离念念灭名无死苦。喜乐相随无怨憎会苦。心皆平等亦无怨憎。虽为去留无爱别离苦。所欲如意无求不得苦及贫穷苦。又身金色端正如天神通自在。香风拂钵天味自盈无五盛阴苦。目观诸佛显赫耳听树网风铃。水流天乐随意闻见。故名极乐　次下第二广明彼土依正两果。初明依报器世间清净依果。后明正报如来功德清净正果。就初文中有八。一宝林曜颖。二德水澄澜。三妙妓鸣天。四檀金饰地。五时华舞回。六羽驾游方。七鸟韵法音。八风生善念。初文且五。一下绕金栏。二上罗珠网。三树同严饰。四国遍周围。五结成极乐

经曰极乐国土七重栏楯。次释第一下绕金栏也。无量寿论云。此即地庄严宝栏周匝围绕。说文云。栏门遮也。楯木栏也。按彼所释。楯即遮遏之体。栏即防护之名。此即形净土也。若第一义土。华严经云。清净心为楯。即意无三恶为楯之体。七业不生即为栏之用

经曰七重罗网。次释第二上罗珠网也。无量寿论云。空庄严也。无量宝绞络罗网遍虚空。若观经云以妙真珠弥覆树上。无量寿经云总覆佛土。何但树上。其网四边皆垂宝铎。网用真珠金百千宝饰

经曰七重行树皆是四宝。次释第三树同严饰。谓皆七宝庄严也。若无量寿经云皆以七宝间错。清净觉经或以四宝百宝一宝庄严。随念即现。若观经云。一一树皆高八千由旬。其叶华果一一皆作异宝色也。若无量寿经说权不言大小。唯佛菩提树高四百万里。其本周围五十由旬。枝叶四布二十万里。一切众宝自然合成。彼土天人闻此树动演出法音。皆得无生深法忍。住不退转。见嗅及触皆得适悦。此且形相净土也。第一义土者。净名经云。无漏法林树敷觉意妙华。解脱智慧果

经曰周匝围绕。次释第四国遍周围也。无量寿经云。七宝诸树周满世界。国之四境及随所在绕池绕舍。皆七重行树及以栏楯

经曰是故名为极乐。次释第五结成　次明第二德水澄澜。无量寿论云水庄严也。文有七。一池莹七珍。二水含八德。三下填宝砾。四上匝玉阶。五珠台际天。六鲜华吐褥。七结成极乐

经曰有七宝池。次释第一池莹七珍也。准观经但有八池。此应据大者胜者说。若清净觉经等处处皆有浴池。或绕佛讲堂。或绕罗汉菩萨讲堂。如来浴池最大纵广四万八千由旬。其诸菩萨声闻及天人等各洗浴已。或于堂中诵经说法坐禅者。或在虚空中讲法诵经入定者。于是未得道者悉皆得道。或得初果四果及不退转。彼无大海江河溪涧。但有诸池及小芙渠。其池四边皆七宝间错。令水亦作诸异宝色

经曰八功德水充满其中。次释第二水含八德也。称赞净土经云。一澄净。二清冷。三甘美。四轻软。五润泽。六安和。七饮时除饥渴等。八饮已长养诸根四大。准此水即具四尘。清净即色入。冷软触入。甘美味入。余三水之用。阙无香尘。成实论云。一轻二冷三软是触也。四美是味。五清净是色。六不臭是香。七饮已调适。八饮已无患。是水之用也。正法念经云。一具六味。谓甘苦辛淡碱酢。二清净。三香洁。四除渴。五凉冷。六饮之无厌。七无尘垢。八饮之无患。清净觉经云。其池中水浅深随念上下逐之。观经云。水随莲华树上下。水流之音或闻三宝声空无我诸波罗蜜声。此则弥陀神力使之然。即是形相净土摄。若第一义土者。净名经云定水湛然满

经曰池底纯以金沙布地。次释第三下填宝砾也。无量寿经即互相厕映。若黄金池者下布白银沙。余亦类之。其池底有紫黑栴檀沉水香泥

经曰四边阶道金银琉璃颇梨合成。次释第四上匝玉阶。问经言众宝所成。何以言玉也。答凡言玉食玉貌。非以玉为之。但贵美之言。彼亦如是

经曰上有楼阁亦以金银琉璃颇梨车渠赤珠玛瑙而严饰之。次释第五珠台际天也。无量寿论云。谓地庄严。即色相圆净。谓七宝台阁光明净也。准观经处处皆有众宝楼阁。何独地上　次第六释鲜华吐褥。即依止圆净。若如来所居处有大宝莲华王座而为依止。自外诸人若或生莲华之中座。即以莲华为依止。此文中为四。一华名。二分量。三光色。四香气

经曰池中莲华。次释华名。谓之莲华

经曰大如车轮。次释第二分量也。此经据小小者说。谓如车轮。观经清净觉经约大者说。或二十里乃至六十万里。然随念大小遂无常准

经曰青色青光黄色黄光赤色赤光白色白光。次释第三光色也。然此经但有四色。准清净觉经观经。一一华叶皆作异宝色。何独青色但有青光也。按诸经据彼华非一一华有种种色。此经但据纯色者说

经曰微妙香洁。次释第四香气也。清净觉经云。其彼华香八方上下最胜无比。闻其香气无不适悦

经曰舍利弗极乐国土成就如是功德庄严。次第七结极乐

经曰又舍利弗彼佛国土常作天乐。次释第三妙妓鸣天也。准观经等。无量乐器常悬在天。不鼓自鸣。又随物有处。或舍或林皆悬乐器。悉自和鸣随众生意。皆奏法音无非法声。人天闻者俱发道意

经曰黄金为地。次释第四檀金饰地也。即形貌圆净。故佛地论云。无量寿佛所游行地处处庄严希有。按诸经多以金为地体。诸宝间错而中表映彻。故观经称琉璃地。又彼经云。地下有八楞金柱。杂宝交饰光明赫奕。其地犹如日宫悬处虚空。其宝地柔软下脚即凹举足便起。又彼国土无须弥山及诸山等。无量寿经云。佛言彼四天王忉利依空而住

经曰昼夜六时雨曼陀罗华。次释第五时华回舞。无量寿论云雨庄严也。依庄严论。雨华意为严饰地。故无量寿经云。其华覆地厚四寸余。随色次第而不杂乱。光泽香软。足蹈上行才下四寸。举足还起。若更雨新华之时。旧华即渐渐地裂受之。故华没尽新华已满。或雨宝衣遍覆其地。人践上行。称赞净土经云。见此华者心虽适悦而不贪着。更增众生殊胜功德曼陀罗者。此云赤圆莲华。亦云如意华。正法华经名适意华大适意华。曼殊沙华名为柔软华。大品经中帝释雨曼陀罗华供养般若波罗蜜。须菩提言此华从心树生。即如心所欲而雨。释之者。华之所生从其心生。然华之色貌终是赤圆　次第六羽驾游方。问若仙人乘鹤等可言羽驾。彼乃运身而往或乘宫殿。何言羽驾。答谓飞若驾羽疾若乘龙故言羽驾。此即乘圆净。谓乘大定大慧之力。文复有三。初捧华历供。次限晨旋路。后结成极乐

经曰其国众生常以清旦各以衣裓盛众妙华供养他方十万亿佛。次释第一捧华历供也。准诸经或乘七宝宫殿百宝莲华。或但尔而去。或乘佛威神。一念之顷游十方界。于诸佛前随心所念种种诸佛称心供养。礼佛听法或蒙授记。衣裓者谓衣衿也

经曰即以食时还到本国饭食经行。次释第二限晨旋路也。谓限晨至斋时即便还归国。即任持圆净也。谓或以大乘法味喜乐持身。故饮食已说法诵经。经行者。谓旋绕思惟。问言食时者为同此处已午之际为别时也。答曰虽短长不等食时亦是同也。问四食之中彼有何食。答彼有段食。然竟不食。见色闻香意以为食。自然饱足无所味着。事讫化去。时至自来。故无量寿经云。彼欲食时。七宝钵器自然在前。百味饮食湛然盈满。若清净觉经欲食时有自然劫贝及[疊*毛]以为座。食者坐之诸菩萨罗汉皆食。食亦不多不少自然平等。亦不以美故喜食。何故此二经不同。答有食不食。食者故不多不少。若不食者见之便足。此即形相土也。若第一义土即净名经云。甘露法为食。解脱味为浆

经曰极乐国土成就如是功德庄严。次释第三结成极乐　第七次明鸟韵法音。即眷属圆净。谓净土中如来化作天龙八部异类眷属。示庄严徒众眷属也。问彼土是三界摄不。虽言无须弥山。而六欲天皆空居者即是欲界摄。何得无实畜生乃是化也。答据无量寿经等。说是欲界。然智度论云。若他方化土杂恶不净者是名欲界摄。若清净者非三界摄。又有形故非无色界。地居故非色界。无欲故非欲界。是故彼土住似欲界而非欲界。故非三界摄。无实畜生。故正法念经云。四天已上即无实畜生。诸天福力为庄严处所亦有禽兽。然非实报。何况净土而得有之。言诸鸟者。或弥陀所化作宝光状似。此文有二。初叙后释去外疑。叙文有五。一总标羽族。二别列禽名。三啭和雅音。四诠论妙法。五闻声动念

经曰复次舍利弗彼国常有种种奇妙杂色之鸟。次第一总标羽族也。色类非一故言种种。容貌绝群故言奇妙

经曰白鹤孔雀鹦鹉舍利迦陵频伽共命之鸟。次第二别列禽名也。佛华严不思议经云。舍利者此云鸲鹆鸟。迦陵频伽智度论云。迦陵频伽者此无正名号好音鸟。此鸟子虽未出[穀-禾+卵]其音已胜众鸟。何况出[穀-禾+卵]。共命之鸟者。相传云一身两头

经曰是诸众鸟昼夜六时出和雅音。次释第三啭和雅音也

经曰其音演畅五根五力七菩提分八圣道分等。次第四诠论妙法也。三十七品亦名三十七助道法。亦名三十七助菩提法。言三十七者是数也。谓三十七心数法也。若言品者。谓三十七法各各别故名品。言助道者。谓能随顺资助尽智无生智。能令圣道势用胜故。故云助道。二智也。若言菩提者。菩提亦名觉。即前二智也。故四谛论云。三十七助道觉法。此法小乘正学。菩萨兼修二智。智度论云。如来何故多说此法不增不减。但说三十七品。答此三十七品譬如众药和合疗众生病正须尔许。是故常说不多不少。又常说者。以是初欲入道次第名字。如人初到师处听法先用心念记持所闻法。故先明念。念已依行故次明正勤。勤断二恶勤修二善。若多精进则心散乱。欲令摄心便住定中。故次明如意足。心定已便生五根。五根渐增能遮烦恼能入深法。故次明五力。五力既增能分别圣道。故次说七觉分。既见谛已须除修惑趣涅槃城。故次明八圣道。若广分别具如别章。问准鸟所诠应当具说。何故经中但说四科。答然彼化生身无脓血不净等。故无倒执净不净心。故不说身念。虽无苦受亦无乐报心倒。不说受念。心知无常励诚修道。不说心念。知法无我而无我倒。不说法念。以是因缘不说四念。又不曾造恶无烦恼不说断。炽然自励修诸圣道不假说修。故鸟不说四正勤也。又定慧兼修非恒散乱。五通报得无劳说四如意足。是故前三众鸟不宣。又复释者是义不然。但经略举非鸟不宣。亦言三十七助道法者。谓四念处四正勤四如意足五根五力七觉支八正道。四念处者谓身受心法。四正勤者谓未生之恶方便令不生。已生之恶方便令断。未生之善方便令生。已生之善方便令增长。四如意足者谓欲定足精进定足念定足慧定足。五根者谓信根精进根念根定根慧根。五力者谓信力精进力念力慧力定力。七觉分者谓择法觉支精进觉支喜觉支猗觉支舍觉支念觉支定觉支。八正道者谓正见正思惟正语正业正命正精进正念正定。体性有十。谓净信．精进．念．智慧．及喜．猗．舍觉品相应舍．思．戒．三摩提。信分有二。谓信根信力。精进分八。谓四正勤为四。精进根精进力精进觉支正精进。念分为四。谓念根念力念觉支正念。智慧分八。谓四念处为四。慧根慧力择法觉支正见。喜为喜觉支。猗为猗觉支。舍为舍觉支。思是觉支数谓正思惟。戒分为三。谓正语正业正命。三摩提定。定分为八。谓四如意足为四。定根定力定觉支正定。问曰何故名助道法。助道是何义。答曰尽智无生智是菩提。谓此诸法随顺彼法令势用胜故名助道法

经曰其土众生闻是音已皆悉念佛念法念僧。次第五闻声动念也。谓闻鸟说法皆生善念念三宝也。问诸经多说六念。此何独念三。答六念者约此处及下界中教其六念。以诸众生诸根不具得恶趣身。欲令持戒故教念戒。以诸众生贫穷困乏。欲舍悭故教念施。以下界人不及天故。意欲令其修天行故。故令念天。彼国众生无恶趣故。自念修善。无犯戒垢故。不念戒。无贫乏者故无念施。然亦持华历散诸佛。是供非施。由彼众生无悭吝垢故不念施。彼人形貌及所依止胜第六天故不念天。以三宝福田最胜无比但念三宝也。大涅槃经云。盲贼念佛还得眼根。释女念佛手足还具。商人念佛即免鱼难。摩诃斯那念佛得除疮痛。又观经云。一念阿弥陀佛除八十亿劫生死之罪。法华经云。一称南无佛皆得成佛道。是为念佛之力。大品经云。念般若波罗蜜除四百四病离灾难消诸恶业。或念诸三昧得胜知见。是念法之力。若人念观音地藏虚空藏菩萨。诸难消除所愿果遂。是为念僧之力。问佛藏经云。诸法毕竟性空。空中无佛无法无僧。若有言说形相是可念者为是颠倒。当云何念。答若彼经据毕竟空理说。今此经据接引说。从浅至深。故十住毗婆沙云。新发意菩萨若念佛者先念色身。应以三十二相八十种好念色身佛。心渐渐得入深法者应念法身佛。次转深入得上势力。应以实相念。莫以色身念。亦莫着法身。善知一切法永寂如虚空。故无所念亦无能念者。是真实念者。今为新发意者旦以事相念。即优婆塞戒经云。佛有七胜事故将以须念。一身胜。具诸相好圆满故。二如法住胜。三业常无失故。三智胜。具一切种智故。四具足胜。一切福德圆满故。五行处胜。常在三昧故。六不思议胜。六通具足故也。七解脱胜。一切烦恼正习俱尽故。又摄大乘论云。佛有三身。诸菩萨念佛者当缘念何身。答缘念法身。法身虽有无量甚深道理。然依法身念佛七种相。此七相是法身正用。亦是法身圆满德。一身平等利益圆德。谓能示现化身成道亦作大利益。若地前菩萨二乘凡夫未下种者令下种。未成熟者令成熟。未解脱者令得解脱。二无失圆德。由一切惑智二障永灭离故。无有烦恼令生过失。三无碍圆德。由智慧故于世八法不以忧喜碍心。四能施大法乐圆德。由有内外财故常受富乐。亦得清净土自受法乐。亦令他方诸菩萨受用法乐。五无功用圆德。谓一切事如来无功用自然成就。由本愿力故所欲作事自然而成。六心圆德。诸佛于六通境得最极自在。虽同类人及下人等不能为碍。在有心无心位中恒不废忘。已久修习成就故故得自在。七常圆德。谓法身常住故及众德亦常。由真如是常住故诸法以此为身故诸佛身常住。故依身所有众德亦常住。故言念佛等。三宝之义广如别章　次下第二释去外疑。其文有五。一遮二征三答四例五释

经曰汝勿谓此鸟实是罪报所生。次释有畜生。由此疑心故佛遮扫。莫谓实是罪报所生

经曰所以者何。次释第二征也。既有鸟演法音。何以非实罪报也

经曰彼佛国土无三恶趣。次释第三答也。彼国实无三恶趣故。所以无者。由阿弥陀佛昔发愿言。设我得佛国有三恶趣者亦不取正觉。乃至国中天人寿终之后复更生三恶道者亦不取正觉。故知无也

经曰彼佛国土尚无三恶道之名何况有实报之鸟也。次释第四例答也。三恶道之名尚无。况有实报之鸟

经曰是诸众鸟皆是阿弥陀佛欲令法音宣流变化所作。次释第五释通也。人疑云。此鸟既非实报。当是何身。答彼佛所化。或宝光明所作。意欲令其助宣正法。故智度论问云。净土中诸佛有无量神力。何不但多化作佛处处说法度众生。乃化作畜生树木等说法也。答若处处皆见佛身说法。众生即不能信受。谓为幻化心不敬重。故于道难入。所以不化作佛。又如本生经说。若菩萨化作畜生身为人说法。以希有故闻者皆信受。又以畜生心直故不诳于人。闻则信受。又恐谓有情众生是欺诳故。亦令无情树木而演诸法。闻即信受　第八风生善念。谓风摇树网出妙音声时。闻者便生善念。无量寿经云。众生闻彼风树网音者。得深法忍住不退转至成佛道。耳根清彻不遭苦患。此文为四。一清风所摇。二歌音所演。三闻生善念。四结成极乐

经曰舍利弗微风吹动诸宝行树及宝罗网。次释第一清风所摇也

经曰出微妙音譬如百千种乐同时俱作。次释第二歌音所演也。谓妙声和雅譬如五音百千乐同时俱奏也

经曰闻是音者皆生念佛念法念僧。次释第三闻生善念

经曰舍利弗成就如是功德庄严。次释结成极乐。次明第二如来功德清净正果。无量寿论曰。又分有二。初明如来功德庄严。次明菩萨功德庄严。就初文中先问次答后释外疑

经曰于意云何彼佛何故名阿弥陀。次释第一问也。彼佛从何义趣名阿弥陀　自下答中为含二义名阿弥陀。一无量光明故名阿弥陀。二寿命无量故名阿弥陀

经曰彼佛光明无量照十方国无所障碍故名阿弥陀。次释光明无量故名阿弥陀。无量寿经云。佛言无量寿佛威神光明最尊第一。诸佛光明所不能及。由光多故名无量光。乃至有十二光名。其有众生遇彼光者罪垢消灭。若在三途受苦见光皆悉休息。寿终之后皆蒙解脱。平等觉经云。彼佛项光常照十方千万佛国。智度论云。阿弥陀国诸菩萨众身之光常照十万由旬。若是佛光遍十方界。问诸佛德行皆同。何故弥陀独胜。答智度论曰。诸佛常光亦无大小远近之异。但由众生根有浅深德有厚薄。诸佛常光所照现不同。然实平等。故十住婆沙云。诸佛常光不可以由旬数量为限。遍满十方莫知边际。又准彼国菩萨声闻身光亦胜。故无量寿经云。彼佛国菩萨光明常照百千由旬。声闻身光一寻。大品经云。欲得寿命无量光明无量。当学般若波罗蜜

经曰其佛寿命及其人民无量无边阿僧祇劫故名阿弥陀。次释第二答寿命无量故名阿弥陀。无量寿经云。彼佛寿命长久不可称计。假使十方世界无量众生皆成阿罗汉共尽思惟百千万劫不知寿限。菩萨天人寿命亦尔。清净觉经云。阿弥陀佛欲令十方一切有情之类皆生其国悉至于泥洹。若诸作菩萨者皆欲令悉作佛。作佛已更转教十方众生之类得作佛。作佛已复教一切众生悉至泥洹。是故菩萨寿命无量。十住婆沙云。寿谓受业报因缘故得命根相续。一期得住故名寿命。大品经云。量不可得名无量。边不可得名无边。大法炬陀罗尼经云。不可算数故名无量。不可穷其际限故名无边。智度论云。阿之言无。僧祇言数。劫言时也。谓无数时。摄论云。不可数有二。一阿僧祇劫。谓年月岁数不可数菩萨修道以此是小劫。二劫阿僧祇。谓菩萨修道以劫为量。此劫又不可数故名劫阿僧祇。此是大劫。今阿弥陀寿劫者是年岁阿僧祇也。其劫义如别章。人闻彼佛寿越僧祇。未知作佛已来于今久近。若久则恐临灭度。虽十念而难逢。近则固未涅槃。终百年而可望。良有斯问故下答云

经曰阿弥陀佛成佛已来于今十劫。次第三释斯疑也。谓成佛已来始经十劫。愿生必见亦何疑也。问是何劫。答是小劫。如梁朝摄论。以行年双等岁为一数。数过六十数为一阿僧祇劫。谓五年两闰为一双。即一双二双乃至十双百双千双万双乃至阿僧祇双名一小劫。所以知是双等劫者。华严经云。娑婆一劫当彼一日一夜。即以彼三十日为一日。乃至十二月为一岁。五年有两闰为一双。乃至僧祇双故　次明第二菩萨功德庄严。文分为五。一常随众。二新贤。三旧圣。四劝往生。五释劝。初文有二。一总标二众。后结成严土

经曰彼有无量无边声闻弟子皆阿罗汉非是算数之所能知诸菩萨众亦复如是。次释第一常随众也。声闻者。成实论曰。闻法得悟故云声闻。故佛地论云。闻佛言音而入圣道故名声闻。即观经称小乘根者生彼得四果也。问彼既是有四果。何故经言皆是阿罗汉。答此举随佛众。即如释迦弟子无量无边经初但标千二百五十人。举常随众也。问无量寿论曰二乘种不生。云何得有声闻众。答彼论据佛受用报土说。以诸佛受用土唯有十地诸大菩萨无二乘凡夫故。今此经中约化土说。有地前菩萨及二乘凡夫同见同受用故。观经言小乘根性亦得往生。诸菩萨者亦举常随菩萨众也。言声闻者。宝积经云有四。一是应化。二增上慢。三定性。四发菩提心。言应化者。实是诸佛及大菩萨。为度众生示作声闻。为引接实声闻故。即富楼那罗睺罗等是。言增上慢者。未得谓得未证谓证名增上慢。言定性者。谓本少慈心一向为己不为众生。怖畏世间唯住涅槃。是名于小乘中决定性也。言发菩提心者。彼从本来慈悲心少。亲近于佛所信心彼。虽住涅槃诸佛劝化方便诱引遂发菩提心。然而迟钝。问彼国声闻弟子皆是罗汉其数甚多。四种之中有何声闻也。答准观经无量寿经等。彼但有三种声闻。无增上慢者。何以知之。准此土有增上慢者。或恶魔作佛示与授记。即自念言。有何所得故谓证涅槃与大阿罗汉同。或有坐得四禅言得四果。即将自身为阿罗汉等想。悉受他供养。准成实论。此人后当忧恼。谓临命终时乃见三恶趣中阴相现即生忧恼。彼国无此故无也。清净觉经云。其国菩萨罗汉自共语言皆说经道不说余语。其声如三百雷声。皆悉相敬爱无相憎嫉。悉存长幼上下。问彼土何众最多。答大论云。菩萨僧多声闻少

经曰极乐国土成就如是功德庄严。结第二也

经曰极乐国土众生生者皆是阿鞞跋致。次释第二新贤众也。故无量寿经云。诸众生明信佛智作诸功德。信心回向愿生我国者。于七宝华中自然化生。须臾之顷身相光明智慧功德如诸菩萨。悉皆三十二相身真金色。若不尔者不取正觉。故清净觉经云。生到彼者悉具诸相。智慧成满神通无碍。或得百法明门入欢喜地。是知生至彼者有到地前三贤位中。故言新贤。阿鞞跋致者。阿之言无。鞞跋致言退转。故大品经云。不退转故名阿鞞跋致。问阿鞞跋致有何胜用。答大品经云。若至阿鞞跋致位。是人不为诸魔所动。更无退转。故大论曰。此入不退转位菩萨名入菩萨位。自知自证不随他语不堕凡夫数名为得道人。一切世事不能动心。闭三恶趣门。若据彼论。与弥勒问论同。故彼论曰。菩萨未证初地正位。虽无量劫修集善根报。而未能得不退转。未得毕竟无怖畏心。此二论即取初地为不退转位。故弥勒问论云。云何不退转。答以诸菩萨得初地毕定因故。以见道力离身见等诸烦恼。如须陀洹人。菩萨初地断菩提心相违退因。离身见等烦恼。方得名为入菩萨位。自知自证二空真如过凡夫地。尔时有九种过。一入位过。谓初入菩萨位初得出世间心故。二家过。谓生在佛家。以依般若慧生故。三种姓过。种姓尊贵无可讥嫌。以大乘行生故。四出过。谓一切世间道所不能摄故。五入过。由入出世间道法故。六身过。以善住菩萨法中以大悲为体故。七处过。以善住菩萨正修行处而不舍世间而不染故。八业过。谓入三世平等真如法中。顺空圣智生命相似法故。九毕竟过。谓入如来种中令佛种不断究竟证涅槃道故。是则不退转位在于初地。若依资粮论。菩萨若得无生忍时即住在不动地。必当作佛更不退转。是则不退转位在于八地。故彼自发问云。何故从初地乃至七地。皆决定向三菩提。而不说为不退转。唯说住不动地者。答不动地菩萨所有信等出世间善根七地菩萨及二乘不能障碍令其退转。是故彼地名不退转。若据众生生彼得至七八地者。其位太高。若至初地者。即与观经相应。故彼经云。众生生彼有经一劫半劫得入欢喜地。若依璎珞本业经十住位中。彼经云。若新发意菩萨若进若退多在第六住欲入第七住中。何以故。若善男子一劫二劫乃至十劫修行六度得入七住。是人尔时从初一住至第六住若修般若波罗蜜。正观现在前复值诸佛及诸菩萨善知识等所护念。故即得出到第七住中即常不退。自七住已前名为退分。若众生生彼得入七住名不退转。此事必然。以彼时长久修缘强故。又有释者。彼无七种退缘故。故令生者皆不退转。一无五退具在。婆沙云。一长病。二远行。三常诵习经业。四常营事务。五恒和诤讼。此五因缘令心劳倦。是名五退具。二寿长于无量劫供佛听法陪随胜人。即长时修道故是名不退。三无女人故无淫欲迷爱。而六尘境界见闻触知令心不染而发菩提心。即无染爱缘故是名不退。四无不善及不称心故不退转。五无恶友常见诸佛及一生补处菩萨故心无慢惰。即恭敬修行故心无退。六由彼佛愿力故不退转。无量寿经云。其有众生一生我国乃至成佛不受恶趣。除示现生。若不尔者不取正觉。又十住婆沙云。若人欲得现身至不退转者。当学般若波罗蜜。当称念西方无量明佛。七为利益众生故不退转。智度论云。阿鞞跋致有二种。一得无生法忍。二未得忍者即是众生生死肉身。结使未断。佛知其人必当断故。为利傍人如来亦记彼菩萨是阿鞞跋致。释迦如来亦知我等众生得生于彼必不退转。故远记亦名不退。故言皆是阿鞞跋致。又纵生彼渐渐得至七地得无生忍。入于八地不动不退者。于理无妨。何以故。上言彼佛欲令十方众生生彼悉得作佛。作佛已更化众生。彼所化众生复亦得佛乃至涅槃。此乃住经六大阿僧祇时。彼众生尔许时修道。亦令生彼即至得佛。非但七八地也

经曰其中多有一生补处非是算数所能知之但可以无量无边阿僧祇劫说。次释第三旧圣众。即助圆净。谓诸菩萨助佛扬化。一生补处者。谓十地菩萨更于兜率天一度受生。从兜率下即补前佛处而成佛故。故资粮论云。一生补处及最后身问为一为异。答不同。谓第十地菩萨更有一生所系者方欲入兜率天也。若正住兜率天中者名最后身。大品经云。是菩萨一生补处。是菩萨最后身。大论问云。兜率天有一生补处菩萨。如何余国亦有。答天上者是三千国土常法。余处者不定。无量寿经云。设我得佛。他方佛土诸菩萨众来生我国。究竟必至一生补处。除其本愿自在所化者。以佛本愿力故生彼国者入补处位也

经曰众生闻者应当发愿愿生彼国。次释第四劝往生也。汝等未来现在众生若闻我上说者。应当发愿愿生彼国

经曰所以者何得与如是诸上善人俱会一处。次释第五劝生意。所以我劝汝愿生彼国者。得与一生补处菩萨共聚会故。上来标净土果竟　次明大段第二举净土因。文分为五。一简少因。二陈多行。三圣众垂接。四众生托灵。五结劝敦励

经曰舍利弗不可以少善根福德因缘得生彼国。次释第一简少因也。良恐众生曾闻佛说临终十念即得往生。我今天命未究且当放逸。为遮此念故言不可以少善根得生彼国。有人释云。此文正与摄论别时意相应。今释不然。论言别时意者。如人诵持多宝佛名决定于无上菩提更不退堕。又唯由发愿于安乐土得往生者。皆是别时意。今念佛者但愿往生。不论菩提退与不退。又专念佛即离十恶。一念便除八十亿劫生死之罪。何况多念。即是有行非唯发愿。十住论云。诸菩萨凡起小行发深大愿。愿大故得大果。我今多念于佛。是即多行。又愿往生。愿行相资扶。何为不得生于净土。众生由闻少善不生即怀疑惑。几许功德方可得生于彼乎。故下经云。如来教令一日念佛。乃至七日也。是知念佛发愿必得往生。非别时意。今经言善根者。未必要是无贪嗔痴三善根也。然亦不离。但今所论一日念佛等所修善根三业无非往生。决定非别时也

经曰善男子善女人闻说阿弥陀佛执持名号若一日乃至七日一心不乱。次明第二陈多行也。优婆塞戒经云。若受三归名近住男女。兼受一戒乃至五戒不作恶业。故名之为善。即修行人。闻说阿弥陀佛者。所修行也。执持名号。诵念无忘也。若一日等者。行所经时也。一心不乱者。专注无散也。故十住毗婆沙云。一心者用意。即是念佛。念佛三昧经云。此是诸佛要法。二乘所无。占察经文殊般若并云。若人欲生他方现在净妙国土。应当随彼国土佛名一心诵念。愿往生者必得往生。观佛三昧经云。此念佛三昧欲成就有五因缘。一持戒不犯。二不起邪见。三不憍慢。四不恚不嫉。五勇健精进。鼓音经云。令念彼佛名十日十夜六时礼拜。贤护经云。能持戒者专念阿弥陀佛七日即得往生。清净平等觉经及大阿弥陀经并说三辈得生。一上品者舍家业弃俗。行作沙门修无为道。奉行菩萨六度修戒忍慈。专念彼愿生。彼佛不舍。其人现身眠梦得见彼佛菩萨声闻。若命终时彼佛菩萨必亲自来迎。于七宝池中莲华台上化生。受身长大即作阿惟越致菩萨。与诸菩萨飞行十方。供佛听法。二中品者是人在家不舍妻子。常持经戒。至诚忠信饮食沙门。作佛造寺起塔。烧香散华然灯悬缯幡盖。行慈断欲。愿生彼国。一日一夜念佛不断。其人现在亦梦见彼佛。若临终时彼佛更化作佛来迎。即得往生宝池华上。若人虽念彼佛及愿往生。然狐疑不信。是人终时亦遣化佛来迎现其人前。彼人见佛心生惭愧悔昔疑惑。亦愿往生。虽至彼国不得到于佛所。彼边界七宝城中欢喜便止。即于彼城宝池华上化生。于五百岁不见佛不闻法不见僧。彼名圣胎生。故成实论云。如经所说轻心布施生于边地受少果报。是知念彼佛者疑心亦然。所生之城纵横二千里。舍宅园林床衣皆众宝所成。百味饮食应念而生。所受快乐如忉利天。然不得出彼城。但时时见佛光明。以不见闻三宝故心生恼恨。经五百岁已乃得出城。至于佛所见佛菩萨。虽得闻法心不开解。亦不得在彼菩萨比丘僧众中听法。以去所居舍宅远故。又不能令舍宅在空随身来去。久久已后亦得如彼上品。其下品者无一切功德。但一心念彼佛愿得往生昼夜不绝经于十日是人亦生。若其狐疑亦如前说。复过五百岁得出城见佛于舍宅去佛亦远。又彼经云。当作十种善业。一不杀。二不盗。三不邪淫。四不调欺。五不饮酒食肉。六不两舌。七不恶口。八不妄语。九不嫉妒。十不贪欲。不悭惜不嗔怒不愚痴。不随心嗜欲不中悔不狐疑。常孝顺忠信。能善奉戒持斋。勿共妇人同床。断爱欲心专念彼佛。经一日一夜乃至十日十夜不绝。必得往生。若观经云。当修三行。一孝养父母奉仕师长。慈心不杀修十善业。二受持三归具足众戒不犯威仪。三发菩提心深信因果。读诵大乘劝进行者。修此三业亦得往生。又九品修行皆得往生。如彼经说。若无量寿论修五念门成就亦得往生。一礼拜门。谓身业礼拜。二赞叹门。谓口业赞叹也。三发愿门。心常愿往生。四观察门。以智慧观察彼国佛及菩萨故。五回向门。不舍一切苦恼众生故。无量寿经云。设我得佛。十方众生至心信乐欲生我国乃至十念。若不生者不取正觉。唯除五逆诽谤正法。又法华经云。若人得闻药王菩萨品愿生西方亦得往生。药师经云。念药师如来亦得生于西方极乐。涅槃经云。旷路造作井。桥梁树荫僧房佛塔。回愿往生悉得生彼

经曰其人临命终时阿弥陀佛与诸圣众现在其前。次释第三圣众垂接也。准观经等。或见彼佛菩萨持紫金台。或金莲华。如梁朝珍禅师。见白银台或见化佛菩萨来迎。但随行浅深迎相优劣也

经曰是人终时心不颠倒即得往生阿弥陀佛国土。次释第四众生托灵也。心不颠倒往生者。谓不改善心夙愿也。准往生者皆生于彼七宝池中。莲华化生身形端正如诸菩萨。人天无别皆黄金色须臾长大

经曰我见是利故说此言若有众生闻是说者应当发愿生彼国土。次释第五结劝敦励也。谓我了了见有如是胜利。故劝汝往生也　次明大门第三引六方以证诚。文分为三。初叙自言。次引他证。后释名目

经曰如我今者赞叹阿弥陀佛不可思议功德。即是叙自言也。如我向来所赞西方之事。非独我说。六方诸佛亦如我所见。知说不虚也

经曰东方亦有阿閦鞞佛须弥相佛大须弥佛须弥光佛妙音佛如是等恒河沙数(至)一切诸佛所护念经。次释第二引他赞叹证也。称赞净土经举十方。此本略举六方。一一方中皆有五句。一证处谓东方等。二证人谓阿閦鞞等。三证多谓如是等恒河沙数等。四证相谓各于其国舒舌相也。五证辞谓说诚实言。所以先引东方者。准西域法。以东方为上。天子正殿及以临朝皆面向东。又东方即阳之初。故日行东路为正之始。故先举东方也。阿閦鞞佛经云。名无嗔恚。在东方阿比罗提国。法华经云在欢喜国。须弥相佛者。谓金容尊大状类须弥也。大须弥佛者。谓仪容甚大如山王也。须弥光佛者。谓光大如山王也。妙音佛者。其声慈润清彻踰于梵响也。恒河沙者。长阿含第十八云。此阎浮提雪山北面顶有香山。四宝所成高二十由旬。顶有龙池名阿耨达。此云无热恼。此池流出四河。东方金象口中流出大河名曰恒河。智度论云。其河既深且广。其沙细而复多。真谛云。此河出池口。方一由旬。满中有沙。其沙皆细与水同流。东天竺地最近此河。世人多见故引之为喻。问如来大人何表信时乃舒舌也。答大论云。佛同人间相法故也。谓舒舌至鼻者必不虚语。况覆三千得无实也。然如来为证小事但舒舌覆面或至发际。若证大事即舒舌覆大千。今微因着果。恐人不信。舍苦轮之要躅。登涅槃之庄迳。其事不轻。其证须大。故覆三千大千世界也。当信是称赞等者。称即述其德。赞即光其美。心虑所不测名曰不可思。言谈所不及名曰不可议。诸行虽积靡方念佛之功。诸德虽多难俦此经之德。故使恒沙诸佛护持而不灭记忆以在心。故言称赞不可思议功德一切诸佛所护念经。南西北方上下同前说也。须弥者此云最高也。其山高十六万八千由旬。半在海中　次释第三释经题目。文有三。先问次释后劝

经曰于汝意云何何故名为一切诸佛所护念经。次释第一问。汝知题此经否。此经所以得一切佛护念名者

经曰若有善男子善女人闻是经受持者及闻诸佛名者是诸善男子善女人皆为一切诸佛共所护念皆得不退转于阿耨多罗三藐三菩提。次释第二释也。若善男女等者。是所护人。闻是阿弥陀及闻上六方恒河沙诸佛者。是能护人也。是诸善男子善女人皆为一切诸佛所护念者。正得护念也。如天亲般若论云。说根熟菩萨为诸佛所护念。即防其外慢缘。即诸外恶不及。内心无苦念。即记其内德。盖智慧以自成加外佛力以利物也。又经为起行之本。修以内资。佛则防行之缘。敬称而为外护。故言由持是经及闻诸佛名故为所护念。由蒙护念令善男女闻是经者皆不退无上道心。十住婆沙云。若人能称阿弥陀佛名一心念者。即亦得不退转。问为但念阿弥陀佛即得不退转。为又有余方便。答非但称念礼敬。又应至心于诸佛前忏悔劝请随喜回向发愿。由忏悔故即能转诸定业。如如意珠随愿易得。若有愿生之处即当忏悔令心不退。问不退及不转何异。答弥勒问经论云。诸菩萨见法时即永离菩提障。谓身见等一切诸烦恼。出过二乘地证得深心故名不退。以证胜法成就施等行故名不退转。即生自在。阿耨多罗此云无上。三藐言正遍。三菩提言知觉。谓无上正遍知觉。又无上者谓法身菩提。正谓如理智。遍谓如量智。又正谓无分别根本智。觉谓无分别后得智。谓由诸佛护念故于求无上果智之心遂得不退转也

经曰是故舍利弗汝等皆当信受我语及诸佛所说。次释第三结劝也。是故者。结上之辞。皆当等者。劝励之语也。汝当信我上来所说及六方诸佛之言　次明大门第四举三生以显实。文有四。一发心。二获益。三遂志。四劝生

经曰若有人已发愿今发愿当发愿欲生阿弥陀佛国。次释第一发心也。已发愿者是过去。今发愿者是现在。当发愿者是未来。欲生等者一心希望也

经曰是诸人等皆得不退转于阿耨多罗三藐三菩提。次释现获益也。由念佛发愿故。一即彼佛冥加。二即此佛潜卫。遂令求道之心不退愿生之志不移。故言不退转。问已发愿今发愿可令得不退转当发愿者既未发愿云何得言得不退转。答若已发愿者已得不退。若今发愿即现得不退。若当发愿亦当得不退

经曰于彼国土若已生若今生若当生。第三释遂志也。谓若已发愿者谓过去。过去发愿者已生也。若今发愿者谓现在。现在发愿者今生也。若当发愿者谓未来。未来发愿者当生也

经曰是故舍利弗诸善男子若有信者应当发愿愿生彼国。次释第四劝生也。汝等若信我语者发愿生彼国也　次下大门第五他述希有。四。一彼赞扬。二讶能堪处。三怪登胜果。四赞授秘方

经曰舍利弗如我今者称赞诸佛不可思议功德彼诸佛等亦称说我不可思议功德。次释第一彼赞扬也。我赞六方诸佛能为众生作真实证。众生因此心得无疑。又弥陀如来大慈悲摄引。我偏赞彼。彼佛复赞此

经曰而作是言释迦牟尼佛能为甚难希有之事能于娑婆国土五浊恶世劫浊见浊烦恼浊众生浊命浊中。次释第二讶能堪处也。自誓三昧经云。释迦者此云能仁。十二因缘经曰。牟尼者名为寂灭亦名无分别。过去因果经云。谓身口意满足。即能证寂灭涅槃。能证无分别智。能令身口意功德满足。故言释迦牟尼。能为甚难希有之事者。讶佛堪忍五浊恶中。娑婆世界者。今翻杂恶。自誓三昧经云名忍世界。真谛云。忍是世界梵王之名。由能忍他胜事不生妒忌故更从主立名为忍界。又悲华经云。此界众生忍受三毒及诸烦恼。是名忍土。五浊恶世者。五者是数。浊者是滓。十地论云。有无明杂智。名之为浊。浊是最下滓秽。譬如酒水苏油等淳清在上滓浊在下。若众生劫初生时。人能长寿衣食精好。烦恼轻微诸见薄劣。身色端正孝顺慈敬。无五滓秽。名之为清。劫将欲末时。恶寿短烦恼厚重。诸见深固反逆不慈。有兹五滓。名之为浊。今此浊义广如别章。此略释名。一劫浊者。劫谓时也。菩萨善戒经云。由众生内有恶故外有三恶时。谓饥馑疾疫刀兵。此三劫起时名之为劫浊。饥经七年。病经七月。刀经七日。时虽长短不等。但众生死者一种。逢一一劫死者过半。若今众生施僧一抟食者不逢饥馑劫。施僧一丸药及与贫病者不逢疾病劫。行不杀戒起慈悲心不逢刀兵劫。而此三劫先饥后刀中间有病。然非相继而有。但次第有。谓一樚栌劫下时有饥馑劫。次樚栌劫下时有疾病。后樚栌劫下时有刀兵也。此三灾劫起时必其人寿十岁之时。故言劫浊。二见浊者。见谓五见。邪智推求邪心作解故名之为见浊。善戒经云。如今众生非法见法。法见非法。非法说法。法说非法。以不正见妄生分别。破坏正法增长邪法。令他修习故名见浊。三烦恼浊者。谓三毒在心能令心生烦恼造诸恶业。即善戒经云。令诸众生因烦恼故造诸恶业及畜恶具。谓刀兵仗等损害众生。俱名烦恼浊。四众生浊者。揽假名色而生。名色非一。即多法假和合成说名众生。而诸众生忘恩背义傲慢欺诳。不修三学及十善业。多造十恶五逆。即善戒经云。令诸众生不能孝养不敬师长不造善业名众生浊。五命浊者。谓报得非色非心一期命根名为命浊。若修善业所得命根长远或八万岁。由诸众生多行杀盗损命缘业不满百年。即文殊问经云。人命渐减短下至十岁即老即无名为命浊。故名五浊。所言中者。谓释迦出五浊之内

经曰得阿耨多罗三藐三菩提。次释第三释怪登胜果也。怪能于此恶时恶处恶众生中能忍诸恶能得菩提

经曰为诸众生说是一切世间难信之法。次第四释赞授秘法也。一切世间难信之法者。谓一日乃至七日念佛即拔尘滓高升净境。微因着果俗情难信。人恐如来引接之语故言难信之法　自下大门第六自叙甚难。文分有四。一显难行之因。二显难得之果。三说难信之法。四结成甚难

经曰舍利弗当知我于五浊恶世行此难事乃至是为甚难。释此自叙甚难中分有四句。一我于五浊等者。叙出秽方。二得阿耨多罗三藐三菩提者。叙证胜果。三为诸众生说等者。叙授秘术。是为甚难者。结上三事难作能作也　自下第三明流通分。即依教奉行分也。文有三。初能说已周。次所闻已备。后欢喜顶受

经曰佛说是经已长老舍利弗及诸比丘一切世间天人阿修多罗等闻佛所说欢喜信受。释曰。佛说经已者。结集者所叙。即能说已周。长老已下即所闻已备。闻佛说经已下即欢喜顶受。言一切世间者。世间物非一故言一切。大集日藏经云。世间有三。一众生世间。谓六趣之类。二器世间。谓三界四十居止处。三五众世间。谓有漏五阴。云何名世间。杂阿含云。危脆败坏故名世间也。涅槃经云。天名灯明亦曰光明。光明能除黑暗而为大明故名为天也。又吉祥故名天。能多恩义故名人。有信能多恩义故名人。大法炬经云。阿修罗名非天。彼非天故名阿修罗。等者。即应等取龙金翅鸟紧那罗乾闼婆等。略而不数也。欢喜者。心欢体悦故言欢喜。即十地论云心欢体悦也。又伽耶山顶经论云。具三清净名为欢喜。一能说者清净。谓佛是一切智人。普为众生尽说顿尽无垢藏之法。二所说清净。谓理教相应随顺无逆句义依之出离。三受者清净。谓彼从受而诚信不生轻谤。具兹三义故言欢喜。又颜舒曰欢。神悦曰喜。闻之不谤称信。领之在心为受。故言欢喜信受。奉行末代奉行

阿弥陀经疏(毕)后批云　福州开元寺常契和上以大中七年九月日舍与珍

    阿弥陀经疏跋

自什公译阿弥陀经以来。历朝诸师制之疏记者亡虑数十家盖亦盛矣。慈恩基师所撰有二。一名通赞疏。一单名疏。二疏互有出没影发经义。犹一室两灯。照物愈明。岂可废其一乎。余尝读长西录。又见记主禅师之所援引。知通赞外更有疏。而切惜其不传于今焉。一日与智积之慧岳麟瑞二公话次。语偶及此。因知犹存于彼藏中。遂嘱二公写得一本。粗加校订。藏之箧中。顷有人[鎨-十+乃]梓。共之同志。藏版于华顶之库中。余因不愧鄙拙。略述得此书之颠末。以跋其后云

  宽政四年壬子二月谷旦

                    江户沙门典寿撰


阿弥陀经通赞疏序

    No. 1758 [cf. No. 366]

    阿弥陀经通赞疏序

        大慈恩寺沙门窥基撰

详夫理绝众诠。岂三乘之可摄。智圆万德。非十地以能观。布慈云而荫四生。洒法雨而湿九有。由是降神兜率诞迹迦维。厌欲乐于王宫获真常于觉树。良以群生业惑魔党增强。腾苦海以辟三途。溺慈舟而吞万善。是以高张教网直指净方。是入圣之玄门乃超凡之妙躅。十重净土约地位以等差。九品莲台契根宜之次第。大哉迥抛空有之门独颖断常之表

佛者觉道已圆。说者悲心演法。阿弥陀者无量寿也。经者常法摄贯也。常则百王不易。法则千代同规。摄则包括众诠。贯则通连妙理。故云佛说阿弥陀经也

经如是我闻等。赞曰。将释此经略以六门料简。第一总叙源由。第二别明宗旨。第三彰经体用。第四翻译时人。第五论于顿渐。第六正释经文

且初第一总叙源由者。佛从因地发弘誓愿愿渡众生。今赴宿因故说诸法。故法华经方便品云。舍利弗当知我本立誓愿。欲令一切众如我等无异。又寿量品云。每自作是念。以何令众生得入无上道速成就佛身。若昔因中若今果位。每皆发愿愿令众生犹如我身得入佛道。故酬本愿而说诸经。又如论说。菩萨初生时放大光明普遍十方。行至七步观视四方作师子吼。而说偈言。我生胎分尽。是最末后身。我已得解脱。当复度众生。为酬此愿故说诸经。问世尊说法处会颇多。何故祇园又谈慈典。答余处说法意趣不同。维摩经即折其偏执。法华经即引入一乘。此经起由为破三轮故。三种轮者。一为破无常轮。有情无情皆是无常。令生觉悟舍无常故。二为破不净轮。有情无情皆是不净故。生归净土莲华化生。舍胎胞血肉之身。破有情不净也。所居净土无诸秽恶。破器世间不净也。为破不净轮故。三为破苦轮。诸众生为苦逼迫故。令归净土除此苦故。为破此等三种轮故。故说此经。又为接引二种众生故。一为接引懈怠众生。怯修大行多诸退屈故说此经。因微果著令身不退故。经云若一日乃至七日便得往生等。二为散乱众生驰流诸境沉沦恶道故说此经。指示西方令心专注故。问处处说法皆破三轮。何故此经独彰慈意。答别经之内虽破三轮。断舍时长。不同此典。故说为破三轮

第二别明宗旨者。此方先德总判经论有其四宗。一立性宗。杂心等是。立五聚法有体性故。二破性宗。成实等是。破法体有性唯有相故。三破相宗。般若等是。破法相状亦成空故。四显实宗。涅槃华严法华等是。显于真实中道义故舍化城而归宝所等故。此经乃是第四宗也。依文判教。教但有三。以类准宗。宗乃有八。教但三者。一多说有宗。说阿含等小乘教是。二多说空宗中百十二门般若等是。三非有宗。华严深密法华及此经等是。有为无为名之为有。我及我所名之为空。此等三教处所广明。宗有八者。一我法空有宗。犊子部等是。二有法无我宗。萨婆多等是。三法无去来宗。大众部等是。四现通假实宗。说假部等是。五俗妄真实宗。说出世部等是。六诸法但名宗。一说部等是。七胜义皆空宗。般若等经龙树等说中百论等是。八应理圆实宗。华严法华等及无著等说中道教是。此经乃是应理圆实宗收。即净土为宗。更有二宗。一不说法宗。二说法宗。且不说法宗。龙军等言。佛唯有三法。谓大定智悲久离戏论曾不说法。由佛慈悲本愿缘力。众生识上文义相生。虽亲依自善根力起。而就强缘名为佛说。故无性云。随堕八时闻者识上真非真说聚集显现以为教体。故经云。始从成道终至涅槃。于其中间不说一字。如母啮指子生唤解。二者亲光等言。佛身具有蕴处界等。由离分别名无戏论。岂不说法。名无戏论。谓宜闻者善根本愿缘力如来识上文义相生。此文义相是佛利他善根所起。名为佛说。闻者识上虽不亲得。然似彼相分明显现。故名我闻等。世亲说言。谓余相续识差别故。令余相续差别识生。彼此互为增上缘故。由此护法等随机就事教说三乘。此经即是大乘所摄。三藏之中菩萨藏收。十二分中无问自说教。问白莲华教待请方宣。净土经文因何自说。答说法华而待请恐生轻慢之情。谈净土以自宣为显慈悲之意。旨者旨趣。令舍秽土趣向净方之旨也

第三彰经体用者。且体即教体以五门分别。一摄相归性。皆以真如为体。二摄境从心。一切唯识。三摄假从实。即不相应摄归色心心所。四体用别论门。即能缘四蕴收本质相分。各别摄自他有差别故。五聚集显现门。如闻诸行无常四字。聚集显现以为教体。唯取佛本质声名句文四法为体。若取影像教体。便成有漏。若唯取有漏影像为体者。即应真实。三宝应唯有漏无记。若不尔者如何影像教体。故知但取无漏声名句文为体。声是实。名句文等是假。更有诸师出教体如别处说。用者彰秽显净为用。又显实证真之用也

第四翻译时人者。此经前后有其四译。一秦弘始四年二月八日罗什译。名小无量寿经。二宋元嘉年中求那跋陀罗译。四纸。三永徽六年大唐三藏于慈恩寺译。名称赞净土佛摄受经。十纸。四后秦又译出阿弥陀经偈颂一纸而失译主。今此所解者即是秦罗什法师所译。问三时之中此经是何时所摄。因此问故略明诸师判教。初明此土判教。二明西天判教。此土判教而有五人。一魏时三藏菩提流支此云觉受。以佛一代时教总判为一时。有二义不同教似有多。一教同根异。如天雨是一所润三草二木不同等。教法是一。众生悟解不同。如声闻缘觉作四谛十二因缘解。菩萨作六度解。约根教似有异。二理同证异。三乘证理不同如三兽之度河浅深别。故判教一时。二宋朝三藏昙无谶判如来一代时教为顿渐二时。顿教者。佛一代时有说二空三性三无性八识二无我等教。皆是顿教。所以华严声闻对目不闻等是。渐教者。佛一代时有说四谛缘生五八戒等总名渐教。三梁朝真谛三藏判如来一代时教为三时。一有教二空教三非空非有教。且有教者。佛初成道七年已后说有教。五年度五俱轮。第六年化舍利弗。第七年度三迦叶。总名有教。二空教。从第八年至三十八年已来总说八部般若等是。三非空非有教。从三十九年至临涅槃时说非空非有教。法华楞伽思益等是。四隋朝崛多笈多二三藏判如来教为四时。一生空教二法空教三法相教四观行教。一生空教即十二年前说阿含经等是。二法空教即三十八年前说八部般若。三法相教者即三十八年后四十九已来说楞伽思益法华经等。广说百法三性三无性八识二无我等是。四观行教者。即说华严法界观等是。五晋朝刘居士山中隐逸自述意怀判教为五时。一人天教二生空教三法空教四俱空教五非空非有教。人天教者。即佛成道后三七日内为提谓长者说三归五戒十善等。是未有出世善根器故。觉受难云。提谓经说。五百贾人将受五戒先忏悔五逆十恶谤法等罪。世尊言四大本净吾我本净。提谓得不起法忍即无生法忍。五百贾人得柔顺忍等皆是证圣。岂是人天教耶。二生空教者。即十二年前说二乘之教是。三法空教。即三十年前说者是。四俱空教者。即三十八年前说八部般若是。五非空非有教者。即四十年已来说法华楞伽等经是。二西天判教者。一胜义俱空宗判教。二应理圆实宗判教。且初那烂陀寺师子觉智光等依文殊为宗主判教为三时。一生空二非空非有三俱空。且生空者即广说二乘等教是。二非空非有教者即法华等是。三俱空即八部般若是。第二应理圆实宗判教者。即那烂陀寺有论师名戒贤。依弥勒菩萨为宗主判教为三时。一有教。一代时教说有处是。二空教。但说空处是。三非空非有教。但说非空非有处是。依圆是有。遍计等无。是真谛。但以将教就时此非也。戒贤论师将时就教为正。难真谛云。佛成道后第二七日说华严经。岂是第一时教。又言四十年后非空非有是第二时教者。即佛临涅槃说遗教经。岂是第三时。戒贤将时就教判为正。此经诠净土。依圆是有。遍计等无。即是非空非有教也

第五论顿渐者。曾得二乘果发心向大者名为渐悟。由生数少或全无故。若从二凡而归大者即顿悟摄。未曾证悟二乘理故生数犹多不名渐悟。涅槃经云。但说初果回心八万劫乃至辟支迦十千劫。既不说资加二位劫数多少。明知五果回心方名渐悟。若七方便回心但是顿悟收。曾发二乘心曾修二乘行求归大者皆名渐悟。具彼性故修彼行故闻思悟解亦名为悟。何必证悟。况复亦有生数少者。谓已定生即此生及一坐顺决择分等。涅槃经且说五果回心而论劫数。亦不遮七方便回心亦名渐悟也。故知资加二位既亦有生数少。明知回心皆是渐悟摄。此之二师。第一师有教有理。第二师无教有理。此经者一心不乱十念专精便往净土顿抛浊世。即顿教所收。故经云若一日乃至七日一心不乱等

阿弥陀经通赞疏卷上

        大慈恩寺沙门窥基撰

经云佛说阿弥陀经

赞曰。下第六正释本文分二。初解题目。二释经文。此初也。佛说者即能化教主。阿弥陀者。唐言无量寿等也。经者摄贯等四义也。以胜显劣。依主释也。或以别简总亦依主释也。依人得名也。正释经文者

经如是我闻

赞曰。此经之中总有三段。初如是我闻下乃至及释提桓因等无量诸天大众俱名为序分。二从尔时佛告长老舍利弗从是西方乃至是为甚难已来为正宗分。三从佛说此经下是流通分。序者。由也始也。陈教起之因由作法兴之渐始故名序分。金仙演法各有所宗。陈净域以境殊劝令生而忻慕故云正宗分也。陈事既终时众获益。欲显教门不坠冀其远代流通故名流通分也。若依古师序分有六。今依佛地论序分有五。一为令生信。总显已闻言如是我闻。二说者听者共相会遇时分无别故名一时。三说必有主。欲显主尊法必殊胜故总称佛。四说必依处。在舍卫国祇树给孤独园。化身所居。非报土也。五所被机舍利弗等。如是我闻即为初也。为令生信总显已闻。故以三门分别。一说之所由。二立之所以。三正释其本文。说之所由者。如大术经等说其本缘。佛临涅槃时佛令有疑当问。时优婆离阿[(而/而)*(少/((色-巴)+兄))]楼驮教阿难问四事。一佛灭度后诸比丘等以谁为师。二依何处而住。三恶性比丘如何治罚。四一切经首当置何言。佛言我灭度后以波罗提木叉为汝大师。依四念处安止其心。恶性比丘梵檀治之。此云默然。故不应打骂但默摈故。四一切经首当置如是我闻等言。后阿难结集还依佛教故也。二立之所以者。为令众生生信顺。故智度论云。如是我闻生信也。信受奉行生智也。信为能入智为能度。信为入法之所基。智为究竟之玄术。信则所言之理顺。顺则师资之道成。由信故所说之法皆可顺从。由顺故说听二徒师资建立。于此信中略为十释。一趣极果之初因。依仁王经等。趣圣位之初因。证谛理之顿渐。故四十心以信为首。最初发起大菩提心。须具十德起三妙观。大菩提心以善根为自体。以善友为良缘。以不退屈而为策发。摄大乘之清净增上力坚固心胜进名菩萨初修无数三大劫。二入谛理之基渐。诸论皆说。将入圣位有信根信力。有信根故万善因此而生。有信力故四魔不能屈伏。由此经初创令生信。三通妙真之证净。能越恶道离贫贱因故。入圣已证四不坏信。信三宝故能越恶道。由信戒故离贫贱因。故论亦说有信现观。四荷至德之嘉。依毗婆沙论。信者食法味之嘉手。学佛法者如大龙象。以信为手。以舍为牙。以念为[至*頁]。以慧为头。于其两肩担集善法。象所饮啖以鼻为手。故学佛法者最初生信。五圣七财之元胎法财初故。学者大卖无规法宝教获圣财。故初生信。显扬论云。七圣财者。谓信戒闻舍慧惭愧。信即一焉。六善八因之俶落。善法本故。瑜伽论云。入诸善法欲为根本。作意所生。触所集起。受所引摄。定为增上。慧为最胜。解脱为坚固。出离为后边。欲为根本者起希望故。作意所生者数警觉故。触所集起者和心心所对胜缘故。受所引摄者领在心故。定为增上者心澄寂故。慧为最胜者择善恶故。解脱为坚固者息缠缚故。出离为后边者觉道满故。信既为欲依。故最初令起。七启机门之胜手。摄教手也。俱舍论云。拔众生出生死泥。陈正宗为佛教手。序令生信为众生手。两手相摄出淤泥故。智度论又云。如人有手至于宝山随意所取。若其无手空无所得。有信心者入佛宝山得诸道果。若无信心虽解文义空无所得。亦此所摄。八湛心水之清珠令心净故。成唯识云。信如水精珠能清浊水。能治不信性浑浊故。九建名道之良资。宣尼云。兵食信三不可弃。自古皆有死。人无信不立。如大车无輗小车无轨。其可以行乎。故先令生信。十款哀诚之佳待。春秋云。苟有明信。涧溪沼沚之毛苹蘩蕴藻之菜可荐鬼神。可羞王公。而况君子结二国之信。此中十义初八依真后二依俗。是故经首置如是我闻。如是经义亲从佛闻。离增减失。为令众生起信乐心顺修学故。正释其文者。佛地论说。如是言依四义转。一依譬喻。如有说言。如是富贵如毗沙门。如是所传所闻之法如佛所说。定无有异。定为利乐方便之因。或当所说如是文句如我昔闻。二依教诲。如有说言。汝当如是读诵经论等。此中如是。远则佛之教诲。近则传法之者教诲。三依问答。谓有问言。汝当所说昔定闻耶。于此答言。如是我闻。四依许可。如有说言。我当为汝如是而思如是而作如是而说。谓结集时诸菩萨咸共请。如汝所闻当如是而说。传法菩萨便许可言。如是当说。如我所闻。或信可言。是事如是。谓如是法我昔所闻。此事如是。则此当说。定无有异。由四义故经所皆置如是我闻。真谛三藏云。微细律明阿难升座集法藏时。身如真佛具诸好。下座之时还复本形。勘集藏传亦作是说。众有三疑。一疑佛大悲从涅槃起更说妙法。二疑更有佛从他方来住此说法。三疑是阿难转身成佛为众说法。今显如是所说之法。我昔侍佛亲所曾闻。非佛更起他方佛至转身成佛。为除此疑。故经初言如是我闻。结集之缘如藏章记。已上数解。言我闻者。传法菩萨自指己身言。如是法亲从佛闻。故名我闻。非谓我者定属一人。我谓诸蕴。世俗假者。然我有三。一妄所执我。谓外道等所横计我。二假施设我。谓大涅槃常乐我净除二乘倒强施设故。三世流布我。谓世共传天授祠授等。今传法者随顺世间自指称我。问诸佛说法本除我执。何故不称无我乃称我闻。答有四义。一者言说易故。若说无我通蕴处界。知此经谁。二者顺世间故。三者除无我怖故。言无我者为谁修学。四者有自他染净因果事业等故。所以称我闻。问若尔何故。不称名字但称我闻。答有三义。一示不乖俗宗。虽显真宗不乖俗理。虽显妙言不乖粗欲。虽显真谛不离俗故。二我者主宰自在之义。集藏传云。有三阿难。一阿难陀云庆喜。持声闻藏。二阿难跋陀云喜贤。持独觉藏。三阿难伽罗云喜海。持菩萨藏。但是一人。随德各别。由此阿难多闻闻持。其闻积集三慧齐备。文义并持。于三藏教总持自在。若称名字。虽顺正理。无于诸法得自在义。由斯称我不道阿难。三我者亲义。世间共言我见闻。此将为亲证。若言阿难闻。或非亲闻。从他传受。今显亲闻世尊所说非是传闻破他疑网。故不称字但言我闻。闻谓耳根发识听受所说。今废耳别就我总称故名我闻。虽依大乘根识心所对境和合方名为闻。然根五义胜于识等故根名闻。若但闻声可唯在耳。既缘名义便在意中。故瑜伽言。闻谓比量。耳名闻者。亲闻于声。与意为门。意方闻故以二为闻。熏习在总。因闻所成总名为闻。废别耳意总名我闻。问庆喜于时亲亦见觉知佛所说。何故但言我闻不言我见乎。答有三义。一欲证深理要先闻法。名等诠义非色等故。二此界以声为佛事。事为所依。名等有故。三希证菩提要闻熏习。由闻熏习成出世故。由斯经首不说见觉知。唯说我闻据实。于时亦见佛说诸余佛土以光明等而为佛事。可言见等

经云一时

赞曰。第二说教时分也。此有二义。一者道理时。说听二徒虽唯现在五蕴诸行刹那生灭。即此现法有酬于前引后之义。即以所酬假名过去。即以所引假名未来。对此二种说为现在。此过未世并于现在法上假立。即说听者五蕴诸法刹那生灭。前后相续事绪究竟假立三世总名一时。那一生灭之一时也。二者唯识时。说听二徒识心之上变作三时相状而起。实是现在。随心分限变作短长事绪终讫总名一时。如梦所见谓有多生觉位唯心都无实境。听者心变三世亦尔。唯意所缘是不相应行蕴法处法界所摄。不别约四时八时。但听者根熟感佛为说。说者慈悲应机为言。说听事讫总名时

经云佛

赞曰。第三说教主也。梵云佛陀此略云佛。有慧之主唐言觉者。觉有三义。一自觉胜凡夫。凡夫不自觉故。二觉他胜二乘。彼不觉他故。三觉行圆满胜诸菩萨。菩萨虽复修于二觉行。未圆满故。佛地论云。具一切智一切种智。能自开觉亦能开觉一切有情。如睡梦觉如莲华开。故名为佛。准诸经梵本皆称本师名薄伽梵。佛教安置以此一言含众德故。翻译之主意存省略。随方生善故称佛名。问此三身中何身所摄。答准处准机。应声闻而为化佛。准文准理。教菩萨而即报身。感者根器不同。应现故通报化。王城鹫岭劫尽火烧。鹙子闻经即化佛也。我土安稳寿量长远。文殊在中即报身。劬师罗长者睹三尺以发心。五百婆罗门见灰身而起信。无边之菩萨穷上界而有余住。小圣之凡夫观丈。六而无无尽。今显主尊教随定胜。初标教主令生喜心

经云在舍卫国祇树给孤独园

赞曰。第四所化处也。梵云室利罗筏悉底。言舍卫者音讹略也。此中印度境憍萨罗国之都城名。为别布憍萨罗故以都城为国之称。金刚般若经云。在舍婆提城兄弟二人。于此习仙而后得果。城遂因此号为舍婆提。今新解云。应云丰德城。一具财物。二好欲境。三饶多闻。四丰解脱。国丰四德故以为名焉。祇树者应云誓多林。言祇树者讹也。誓多云战胜。此即太子之名。太子生时邻国怨至。战而得胜遂以为名。给孤独者是苏达多长者此云善施。善施仁而且[(止/脊)*殳]。积而能散。极济贫乏哀恤孤老。时人美其德号为给孤独。是钵刺犀那恃恃王旧云波斯匿王是也。此名胜军。苏达多是彼王之大臣也。佛在摩竭陀未游舍卫。给孤独长者为儿娶妻遂诣王舍城。时有长者将筵请佛家修供养。善施问其所由。长者具陈请佛。彼闻佛德深心欢喜。佛在灵鹫山相去五十余里。遥施光照善施。善施寻光遥见世尊。悲感喜哽如子见父。寻光诣佛路逢天祠。善施礼拜佛光遂灭。善施惭愧光明还照。寻光至佛请佛。诸佛国普化有缘。何独此土。佛时许可。令舍利子先瞻处所。佛言出家当须寂静。丰德人闹城中小隘。唯城南五六里余有太子誓多之园。地幽境媚林密华繁壁方十里。可置伽蓝。善施请买。太子不许。因戏言曰。侧布金满地高敷五寸。时即卖之。善施许诺太子辞。以戏言固陈不与。善施请为对理。时净居天恐人遮曲。乃化为断事者断与善施。善施得之布金取地。时少五百步未满十里。一库金尽使者来报。善施思惟当取何藏中金。太子疑其情吝悔。地而还金。善施具陈心非悔吝。太子知其情恳自发胜心。人所贵重莫过金宝。而彼尚能倾库买地以造僧园。我何所乏而无修建。请悔先地长者不从。太子云许地取金。未论林树。地随汝主。林属我身。共助成功俱陈供养。外道心嫉奏王闻胜。六种皆亏阖国重其释教。佛后游此告阿难曰。园地善施所买。树林只陀所施。二人同心崇福。自今已往应谓此地为誓多林给孤独园。布金之地自此兴焉

经云与大比丘众千二百五十人俱

赞曰。第五所被机。以四门分别。一显来意。二彰权实。三定多少。四明次第。来意有二。一为证信标听众者助成庆喜。闻法可信。众有三疑。今显同闻。二证经德。如天帝释诸天围绕大梵天王梵众围绕等。今显法王诸圣围绕。二彰权实。如佛地论云。化佛秽土中声闻等实菩萨是权。报佛净土中菩萨是实声闻等为权。既是秽土。即菩萨是权也。三定多少。初有五众。一道行尊高众。二悲心广大众。三乐法诸天众。四欲界人趣众。五非天修罗众。三众此列。二众后陈。问何故余经兼有诸众八部等。此经唯独五众。答劝归净土。境胜地殊。莫非上德上贤。余即不能信受。所以独标五众不列余也。四明次第者。先列声闻菩萨二众。是内护众。次列帝释。是外护众。且内护众先列声闻后明菩萨。佛地论有四解。一形相不同。声闻出家形同诸佛。菩萨不尔。二处有近远。声闻近佛。菩萨远之。三戒德有殊。声闻出家持出家戒。菩萨不尔。随类化生故。四欲令菩萨于声闻所舍憍慢故。且初道行尊高众分三。初标类举数。二叹德。三列名。此即初也。与者。兼并共及之义。龙树释大而有五义。一数大。千二百五十人故。二离大。大障断故。三位大。大阿罗汉故。四名大。名称远闻故。五识大。大人大众所知识故。梵云苾刍。讹云比丘。由具五义所以不翻。一曰怖魔。初出家时魔宫振动故。二云乞士。既出家已乞食自济故。三名净持戒。渐入僧数应持戒故。四云净命。既受得戒所起三业以无贪发。不依于贪邪活命故。五曰破恶。渐依圣道灭烦恼邪故。又依草立名。喻五德草故云比丘。众者僧也。理事二和得众名也。三人已上得僧名故。千二百五十人俱俱至祇园故

经云皆是大阿罗汉众所知识

赞曰。第二叹德也。新翻大般若及旧论中有十六句。皆是阿罗汉。诸漏已尽。无复烦恼。得真自在等。此经之中是初一句。阿罗汉者。唯识论中此翻为应。而具三义。一应永害烦恼贼故。二应受人天广大供养故。三应不受分段生死故。众所知识者。名高德重众所知识故

经云长老舍利弗摩诃目揵连

赞曰。第三列名分二。初列名。二总结。如是等诸大弟子。是总结。且初列名分成八对。第一内智外通对。第二苦行辨才对。第三悟空知幻对。第四舍愚离欲对。第五多闻密行对。第六流泉应供对。第七化贪除慢对。第八施药筵僧对。今且初也。具二义故名为长老。一年高腊长故。二学广解深故。梵云奢利弗呾罗。此云春莺亦云鹙鸟。弗呾罗云子。讹略故云舍利弗。母未怀此子言词謇讷。与兄俱悕罗论义常劣于兄。自怀子后言词辨捷论胜兄。母多辨故故曰春莺。春莺即今百舌鸟也。是彼所生故复称子。亦云鹙子也。尊者大婆罗门种。其父豪才博识深鉴精微。凡是经籍无不究习。其妻感梦具告夫曰。吾昨宵梦感见一异人。身被甲胄手执金刚。摧破诸山追立一山下。夫曰汝梦甚善。汝当生男。慧学贯世摧诸论师破其宗致。唯不知一人为佛弟子。果然有娠。母忽聪明高德。剧谈言语无滞碍。尊者年始八岁振四方。志性淳质其心慈悲。早坏缠结成就智慧。故云内智也。问千余罗汉尽到祇园。总证三明皆登四果。列名之处鹙子何先。答只如鹙子辨过小圣智颖常伦。灵山为发请之先。舍卫作闻经之首。最初标列于理何违。梵云摩诃没特伽罗。言大目揵连者讹也。摩诃没特伽罗此云大采菽氏。上古有仙居山寂处。常采菉豆而食。因以为姓。尊者之母是彼之族也。取母氏姓而与立名。得大神通。拣余卑姓故复云大采菽氏。与鹙子少为亲友。深厌俗尘未有归。二人同事删阇耶外道学法。乃相谓曰。此非究竟之理。各于诸处访求胜法。时遇马胜尊者入城化导。鹙子见其威仪闲雅寻而问曰。尊者师是谁耶。答曰释迦世尊是我师也。鹙子曰所说何法可得闻乎。马胜尊者随宜演说云。诸法从缘生。诸法从缘灭。我佛释迦师长作如是说。鹙子闻已即证初果。乃逢目连转为说法亦得初果。遂与同党二百五十人俱往诣佛所。至已顶礼。愿从佛法。世尊告云。善来苾刍。闻是语已戒品具足。渐渐进修已成罗汉。此尊者神通第一孝养无双。救危苦于冥间。荐慈亲于天界。故云外通也

经云摩诃迦叶摩诃迦旃延

赞曰。第二苦行辨才对。摩诃如前解。迦叶者梵云迦叶波。姓也。此略云迦叶。此婆罗门姓饮光仙人种。昔有婆罗门获证仙果。身体金色饮蔽日月之光。尊者是彼之种。以姓标名。又迦叶身饮蔽日月光故以为号。付法藏传云。往昔过九十一劫毗婆尸佛入涅槃后。四部弟子起七宝塔。时彼塔中有佛形像。佛面金色少处缺坏。有一贫女游行乞丐得一金珠。见像面坏欲薄像面。迦叶尔时作锻金师。女即持往诣令修薄。匠师闻于福事欢喜为令作发愿。女云愿生生世世常为夫妇。身真金色恒受胜乐。常修梵行。从是已来九十一劫身金色生天人中快乐无极。最后詑生第七梵天。时摩竭陀国有婆罗门名尼呴律陀。过去修福聪明多智巨福无量。金银七宝牛羊田宅奴婢车乘比瓶沙王千倍为胜。王有金犁千具。彼婆罗门恐与王齐畏招罪咎。其家但作九百九十九具金犁唯少一具。其家有金[疊*毛]千张。最下之者价直百千两金。有六十圌。金栗每圌有三百四十斛。其家虽富而无子息。于其舍侧有一树神。颇有灵只。夫妇累求子息。数年无应。怒曰今七日尽心奉事。若复无验必相烧煎。树神愁怖告四天王。四天王告帝释。帝释遍观阎浮。无堪与彼而为子者。即诣梵王广宣上事。梵王即以天眼遍观。一梵天临当命终。即往劝之劝其生往。梵天受教即来詑生。满足十月生男儿。颜端正身真金色。光明赫[亦/火]照四十里。相师占云。此儿宿福必定出家。父母闻之皆怀愁恼。本为求子继绍。若也出家必当绝嗣。夫妇议曰。当说何计断绝其意。复自思惟。世所耽着唯有美色。当为嫂取。迦叶至年十五。欲为取妻。语父母言。我意志清净不须婚姻。父母不许。儿知难免便设权计语父母言。能为我得紫金色女端正超世。我当取之。父母即召诸婆罗门遍行求嫂。诸婆罗门铸一金神。端正奇特。捋持舁行聚落。高声唱言。若有在室得见金神礼拜之者。后出嫁时必得好夫。有一女人身真金色端正无比。闻此语已出往礼拜金神。长者见之欢喜。即为取作儿妻。夫妇相见皆无染情。共立要契各住一房。父母闻已毁除一室令共一房。迦叶语妻曰。我若眠息汝当行道。汝若睡息我当行道。妻因睡次申手床前。毒蛇入房欲螫妻手。迦叶见已以衣掌手举于旧床。妻便惊窹而责之曰。本立要誓各修梵行。今何触手。迦叶具陈。妻曰毒蛇螫我手令我半身枯。今君触我手令堕三涂。夫妻节操深厌世间。启辞父母求欲出家。父母见志不移便即听许。夫妇俱共出家来诣佛所。佛即摄受渐得果满。此尊者心坚白玉体莹黄金。杜多之行难齐。少欲知足情莫并。不归寂灭。赖且留身入三昧于鸡足山中。献袈裟于龙华会上。故云苦行也。迦旃延者梵云摩诃迦多衍那。云迦旃延亦讹也。大般若云大迦多衍那。此云大剪剃种男。剪剃种是婆罗门姓。上古有仙。山中静处年岁既久。鬓发稍长无人为剃。婆罗门法斥剃发。一仙有子。兄弟二人俱来觐父。小者乃为诸仙剃发。诸仙愿护。后成仙道。尔来此种皆称剪剃种。尊者身是男子威德特尊。拣余卑姓故云大剪剃种男。又西方亦有取母姓者。今显是父姓故置男名。古云扇绳。母恋此子如绳系扇。又往昔曾为五戒扫地。果招端正无比。游行化导遇钵戍多王。怪其端正因问世尊。世尊具答王。曾助五戒除秽亦得端正。王即欢喜更发胜心辨捷无双。论义第一也。此尊者辩潟波涛。貌扬冰玉。能将慧炬破长夜之昏朦。迫淬词锋挫六师之宗党。故云辨才也

经云摩诃俱絺罗离婆多

赞曰。第三悟空知幻对。摩诃俱瑟耻罗此云大膝。膝盖大故。俱絺罗讹也。此舍利弗舅氏。曾与妹论义数见堕负。发愤远游博学道艺。业就归国。妹已颜衰甥已披剃。辞妹入寺觅佛论谈。顶戴火盆身被铁叶。发毛至地甲长尺余。啸月呼风。来入佛会心怀憍慢。傍若无人。乃见世尊语世尊曰。摄我[外*男]甥何法教导。便索论义。世尊曰。汝以何法为宗。彼答曰。我以不受一切法为宗。世尊曰。不受一切法之言已是受也。虽乃堕负慢心未息。世尊乃现神力。令其铁叶束身火盆烧顶。闷绝乃伏投心忏谢。投佛出家。呼之善来。僧仪闲雅已证罗汉。因悟空理得于道果名曰悟空。此尊者博通道术遍揽经书。辩若倾江词同贯玉。一言悟道五蕴知空。忻净土以受生。诣祇园而听法。故云悟空也。离婆多者梵云颉丽代多。此云室星北方星也。祀之得子因以为名。或云彗星。彗星妖星也。此星出时生故因以为名。离婆多讹也。或云假和合。智度论说。一人值雨止宿神祠。深夜见鬼携尸欲食。须臾大鬼来争尸食。各云我自将来。大鬼力强乃夺尸食小者云梁上之人具见。纵由异常惊怖具实。曰小鬼将来。大鬼闻语发怒。乃擒彼人取一脚食之而去。小鬼感其明证。乃取死尸一足连缀证人俨若旧质。即自思惟此身虚幻。因诣于佛所问世尊曰。生死路别。彼此体殊。假合身躯一何如故。世尊告曰。四大假合五蕴灵华悟何晓矣。彼人因悟投佛出家。渐成圣果。此尊者心无苟絇口不虚词。神祠伤一足之因佛会了百年之幻也。故云知幻也

经云周利盘陀伽难陀

赞曰。第四舍愚离欲对。周利盘陀伽者此云路边生。有长者有女。出适他人怀孕乃归。路边诞子。名路边生也。兄弟二人兄名盘陀伽弟名周利盘陀伽也。增一云。此尊者父母并亡。兄先入道已成圣果。彼弟后亦出家。以愚闇时久都无所解。兄怪曰。徒淹岁久全无知会。违归俗舍不听出家。弟倚寺门嗟叹流泪。世尊见已令付帚扫每日习诵。记一忘一。后乃豁然省悟曰。帚扫者除秽令净为义。应是世尊令我断除身中烦恼垢也。因兹证果。又五百弟子本起经云。此尊者往昔驱豕度河。以绳系口。喘息不通中流而死。因兹暗昧。舍愚得慧故也。此尊者前生恶业现世方除。知帚扫有净室之功。悟身因起断愚之慧。故云舍恶也。梵云孙达罗难陀此云艳喜。孙陀罗讹也。艳是妻号。色美端严无比名艳。喜是自名择牧牛难陀。故言艳喜。艳之喜故。是佛亲弟。身长一丈五尺二寸。佛化难陀令求出离。慕恋妻美。种种方便示之苦乐等。方肯出家已成圣果。此尊者世尊华萼庆喜雁行恋美色于王宫示恶因于地狱。从兹惶怖方肯回心知贪欲是招苦之源。悟好色是受殃之本。舍荣弃俗剃发披缁故云离欲也

经云阿难陀罗睺罗

赞曰。第五多闻密行对。梵云阿难陀此云庆喜。但言阿难翻为欢喜亦讹也。世尊成道内外咸庆。当喜时生故云欢喜。已成圣果。又论云。尊者往昔曾为大富长者。因施诵经沙弥饮。遂发愿言。愿小师成佛。愿我为多闻弟子。所说教法悉能记持。今符往愿博学多闻。此尊者貌莹秋蟾心明皎日。岩间结集诵三藏之教微言。水上分身应四王之请命。故云多闻也。梵云罗怙罗此云执日。罗睺罗不正。执日者障蔽也。往昔曾为国王太子。兄弟二人大者名日小者名月。父王崩后兄绍国位。后厌荣贵付位与弟月太子。乃投佛出家精持禁戒无有少犯。后因夜暗误用他人瓶水。鸣钟作相集僧忏除。众僧知罪轻微不与作法忏谢。忧愁转甚。乃自入宫告月王求忏盗罪。月王不违兄意。寻遣左右收兄拘系一房。贪遂欢娱六日忌治。今招恶报腹内六年。又云昔填鼠穴六日。今招斯报六载腹中。此皆不然。太子逾城之日马鞭指耶输之腹。令有此孕表异凡众特现异灵。六载胎中方诞殊质。国王疑谤母子俱焚。火变莲池都无伤损。群臣国王顿息疑心。知释迦之久离染情。显罗睺之不同余众。又乃将珠奉佛。雪耻耶输。鹙子将归便令度脱。少欲知足大行密修已证四果。此尊者圣凡莫测因果难知。内修菩萨之心外现声闻之相。故云密行也

经云憍梵波提宾头卢波罗堕

赞曰。第六流泉应供对。梵云笈房钵底此云牛相。憍梵波提讹也。过去因摘一茎禾数颗堕地。五百生中作牛偿他。今虽人身尚作牛齝之相。因号为牛相比丘。恐人谤毁反堕众苦。佛敕令往忉利天宫。尸利沙园修习禅定。佛入灭时结集法藏。令人往唤。问曰世尊安乐否。语曰已灭度。又问我师在无。报曰舍利弗不忍见世尊灭度。三界无依先已入灭。尊者闻语嗟叹再三。乃化水流至下界。水中说偈。偈云憍梵波提头面礼。妙众端严第一像。象王既去象子随。大师入灭我亦灭。因兹化火焚身入于寂灭。此尊者辟嫌疑于妙高顶上习禅观。于沙利园中忽闻我佛世尊示归寂灭。又知本师鹙子现迹沈空。水流偈于岩间火焚身于天上。故云流泉也。宾头卢颇罗堕者。案请宾头卢经云。宾头卢者是字。未详其义。颇罗堕者是姓。此云利根。故毗奈耶律云。树提长者以栴檀钵置于刹上告云。若有神通能取之便与。尊者在山纳衣之次天眼遥见。削针山崖骋通便往。线连山埵带入王城。蔽日翳空。城中士庶莫不惊惶。孕妇堕胎乃往白佛。佛呵责已云。汝自今后不得随吾不得入灭。留身久住与人增福受请应供。现在南天竺摩利支山居住受请。垂赴往往现身。请命仪轨具在请宾头卢经内。此不繁叙。此尊者受佛敕命不入涅槃。恒驻锡于摩利支山每应供于阎浮世界。故云应供也

经云迦留陀夷摩诃劫宾那

赞曰。第七化贪除慢对。迦留陀夷正法念经云。翻为黑曜。身有黑光。能照曜故。增一云。迦留陀夷夜行乞食值天阴暗。闪电照见。孕妇惊怖将为神鬼。时乃堕胎遂诣白佛。佛呵责已便立禁戒不得夜行乞食。又化悭女令舍悭贪。具如别处。此尊者惊孕妇伤子。化悭女舍贪。损正教于一时。立规绳于千古。故云化贪也　摩诃劫宾那此云房宿。佛与同房宿。化作老比丘为之说法。因而得道故云房宿。因佛化导慢心乃除。此尊者世尊以韬藏圣相变现僧仪。持金锡以同行。处茅堂而共宿。乃知根熟却复本形。睹相好而发心。听微言而息慢。故云除慢也

经云薄拘罗阿[(而/而)*(少/((色-巴)+兄))]楼驮

赞曰。第八施药莚僧对也。梵云薄矩罗此云善容。言薄拘罗讹也。毗婆尸佛入涅槃后。有一比丘甚患头痛。善容时作贫士持一呵梨勒施病比丘。比丘服已病即除愈。因施药故九十一劫天上人间受福快乐。又因往昔曾作比丘。发愿不视女子面。不受女子所施衣。不受女子手中饭。尊者母苦忆子情切乃入寺看子。善容不乐寻时遣母便出房门。母怀小愤为儿五逆乃发恶愿。愿我来世作伊后母种种陵治。果应前愿五杀不死。投佛出家遂成圣果。少欲知足塔涌一钱。故此尊者心唯少欲身不重衣。施良药之微因获无病之殊报。故云施药也。阿[(而/而)*(少/((色-巴)+兄))]楼驮者梵云阿泥律陀此云无灭。佛之堂弟。云阿[少/兔]驮者讹也。应作[(而/而)*(少/((色-巴)+兄))]字。于过去世曾施缘觉一食。五十劫中福不灭故。又过去世曾作猎人欲盗毫珠。以箭挑灯睹佛相好乃发胜心。舍弃弓矢誓不害命。善因力故今得出家。多诸睡眠障习禅定。佛乃呵责。耻见大众。更不寝息。乃得天眼。此尊者挑灯少善根获天眼之殊功。施食微因缘感福田而无尽。故云筵僧也

经云如是等诸大弟子

赞曰。第二结也。标千余人列名十六。不能具载故云等也。诸大弟子者。学在我后故名为弟。解从我生名为子也。上来道行尊高众讫

经云并诸菩萨摩诃萨

赞曰。第二悲心广大众也。又分为三。初标类。二列名。三结之。此即初也。梵云菩提萨埵摩诃萨埵略云菩萨摩诃萨。菩萨修行略有二门。一自利大智为首。二利他大悲为先。菩提觉义智所求果。萨埵有情义悲所度生。依弘誓语故名菩萨。以二为境名为菩萨。有财释也。又觉是所求果。有情是自身。求三菩提之有情故名菩萨。依主释也。云摩诃萨者。今此等菩萨名振十方位居八地。拣小菩萨表异二乘故云摩诃萨也

经云文殊师利法王子阿逸多菩萨

赞曰。第二列名也。分之为二。一十祥三会对。二愍物策勤对。此即初也。梵云曼殊师利此云妙吉祥。生时有十种吉祥事故。一光明满室。二甘露盈庭。三地涌七珍。四神开伏藏。五鸡生凤子。六猪孩龙肫。七马产骐驎。八牛生白驿。九仓变金粟。十象具六牙。故云妙吉祥也。是北方常喜世界欢喜藏摩尼宝积佛。闻名能灭四重等罪。又云过去为龙种上尊王佛。华严经说。在此清凉五台山。与一万菩萨俱。法王子者。佛地论云。从世尊口正法所生。绍继佛身不断绝故名法王子。问文殊已三祇行满十号身圆。何得息国之化扬于他方而示迹。答此尊者慈悲广大利物弘深。显净名之悟理已言。助释迦而投机演法。或因或果何必生疑。阿逸多此云慈氏。依梵本应云梅呾利曳那。此翻为慈。古云弥帝隶或言弥勒者皆讹。当来下生之时才生。便具三十二相。身紫金色姿容揵特。母性不调。怀子已来悲心济物慈心救厄。相师曰。此师子儿之德也。因为立号称梅呾利曳那。若释此名应云梅呾利曳尼。尼是女声。母姓慈故因名慈氏。因成现在果熟当生。忻慕净方亦来至会

经云乾陀诃提菩萨常精进菩萨

赞曰。第二愍物策勤对也。乾陀诃提菩萨者未详所译。称赞净土经第三菩萨名不休息。即化利有情更无止息也。常精进者。念念胜前进后。更无懈怠故也

经云与如是等诸大菩萨

赞曰。第三结之也。已上菩萨众也。即悲心广大众讫

经云及释提桓因等无量诸天大众俱

赞曰。第三明乐法诸天众。梵云释迦提婆因达罗。释迦姓也。此释翻为能。提婆者天也。因达罗帝也。云释提桓因言天帝释俱讹倒也。此在妙高山顶而住三十三天之帝王。过去字憍尸迦此云茧儿。名阿摩竭陀。此云无毒害。即摩竭陀国过去帝释修因之处。用国为名。修行因缘如宗轮疏。如帝释等等者。余诸天大众俱至祇园也。上来三众不同。总是第五所被机讫五段不同总是序分已竟(已下正宗分也)

佛说阿弥陀经通赞疏卷上阿弥陀经通赞疏卷中

        大慈恩寺沙门窥基撰

经云尔时佛告长老舍利弗从是西方过十万亿佛土有世界名曰极乐

赞曰。第二正宗分也。大文分六。第一标净土之宗果。经尔时佛告长老舍利弗乃至得与如是诸上善人俱会一处。第二明极乐之因殊。经舍利弗不可以少善根乃至若有众生闻是说者应当发愿生彼国土。第三诸佛证明。经舍利弗如我今者赞叹阿弥陀佛乃至舍利弗汝等皆当信受我语及诸佛所说。第四三生发愿。经舍利弗若有人已发愿今发愿当乃至若有信者应当发愿生彼国土。第五彼尊赞叹咸曰希奇。经舍利弗如我今者称赞诸佛乃至一切世间难信之法。第六我佛叙陈独称难事。经舍利弗当知我于乃至经终五行来是。初文分二。初略明净土。二广明净土。初文有七。一指方所。二明数量。三显国名。四明化主。五辨说法。六征国名号。七结成极乐此初三也。佛告告语也。从是西方从是指方所此土远指西方。过十万亿佛明数量也。有世界名曰极乐显国名也。极乐国土正是。经宗告鹙子。以令知诱含生而忻慕不能广叙。聊述七门。第一释名。第二出体。第三辨假实。第四漏无漏料拣。第五五位分别。第六三科收摄。第七释其妨难。且释名者。世者可破坏义。界者境分剂也。即所居土名。曰极乐者。乐即能居者。第六识相应乐受也。世即界。持业释也。极者至极乐受。世界者即是无情。相违释也。出体者。极乐者即至极乐受也。世者即有情无情法上不坚可破坏而立世名。即色心上假立。界者四尘五尘为体。虽圣境无坌恶。义是尘之类故亦呼为尘。细四相迁亦名世界。辨假实者。若是化净土而但是假。是定果色去者。有情未除秽种。未能变得净土。但是变心如三变土田等不乖唯识。漏无漏料拣者。若是佛本质净土唯无漏摄。若往生有情及菩萨所变净土唯是有漏。谓第八识果转非因故。五位分别者。极乐者心所收。世界者即色法摄。三科收摄者。极乐者即行蕴收。世界者即色蕴摄。十二处中极乐法处收。世界即色处摄。十八界中法界及六境中摄。释妨难者。问十方佛国快乐皆同。何故偏指西方劝人生彼。答良为凡夫业重处处生贪。若不偏指一方即不系心专注。所以法华经云。众生处处着。引之令得出。又西方净土主胜愿强。偏劝往生疾成圣果。所以偏指也

经云其土有佛号阿弥陀今现在说法

赞曰。此第四明化主。第五辨说法也。阿弥陀上已解。自下经亦有自说处。现在者拣于过未。说者演说。法者执持名号之法。即是教法也。阿弥陀佛长为众生演说妙法转令精进。故慈悲广大利物弘深。现初地之报身化无边之根器。故云今现在说法。问何故不告菩萨只告声闻。答菩萨已无秽种。居净国而皆同。声闻分别未除秽方之各异。令生忻慕只告声闻。问声闻数广。顿悟者颇多。何故不告余人独告鹙子。答只如任家长子国付贤臣。鹙子智辨不群。偏告一何爽理乎

经云舍利弗彼土何故名为极乐

赞曰。第六征国名号。故者所以义。前标极乐之名未彰极乐之相。不睹胜妙难为发心。将欲显示净方故乃自征国号也

经云其国众生无有众苦但受诸乐故名极乐

赞曰。第七结成极乐之名。其国众生者。众生具十种名。众生即十名中之一名也。莲华化生无其生苦。四序不能迁故无老苦。非分段无病苦。寿命无尽无死苦。无父母亲疏故无怨憎会苦。所欲如意无求不得苦。颜貌端严无诸根缺陋之苦。又四时一等故无寒暑等苦。故云其国众生无有众苦。谓处绝三途人无众苦。只如娑婆世界。有漏形躯四蛇回身三龙害命。乖张病恼报尽死侵。有爱必离无怨不会。竖迷至理横受阴缠。今兹众人永无此也。且积修白业生处红莲。相好常身蠲除四相。已情绝虑谁为爱憎。随念即来无求不得。五香佛体众德严身。故云无有众苦也。但受诸乐者。才归净土圣众随迎。莲华倏开睹金容之相好。征风暂扇听宝树而摇声。加以飘渺仙云近浮神足。轻盈衣裓远供祥华。晨谒慈颜得法印而旋国。暮游金殿听宝偈而经行。然大慈愿广利钝普沾。且旧莲欲发为遣残殃。新学化生行成不退。岂唯近已粗苦抑亦妙果非远者哉。故云但受诸乐。故名极乐。问彼土属三界否。答无欲故非欲界。地居故非色界。有形相故非无色界。内无秽种外感净方。回出四流水超三界。故非界系也

经云又舍利弗极乐国土七重栏楯七重罗网七重行树皆是四宝周匝围绕

赞曰。第二广明净土。文分为二。初明国土庄严。二辨佛身功德。初文分八。第一树饰四珍。第二池严众宝。第三空盈天乐。第四地布黄金。第五华雨长天。第六人游诸国。第七鸟吟妙法。第八风吹乐音。初文分二。初正辨庄严。二结成极乐。此即初也。又者复也重也。谓前来已告舍利弗。彼国无有众苦名曰极乐。此欲广明净土境物殊常。又告鹙子故云又舍利弗。极乐国土七重栏楯者。宝树周围有七重栏楯也。横曰栏。竖曰楯。栏槛也。庄严众宝围绕华丛。何独偏举树严。彼土处处皆有也。七重罗网者。严显国土罗覆树林金缕结成众宝饰。观经云。一一树上有七重网。皆是真珠。一一网间有五百亿妙华宫殿。如梵王宫。诸天童子自然在中。以摩尼宝而为璎珞。其光照曜一百由旬。亦准于前处处皆有。故瑞相经云。无量宝网皆以金缕真珠百千杂宝奇妙珍异庄严狡饰。周匝四面垂以宝铃。光色晃曜尽极严丽。祥风微起吹众网罗。声演法音振闻一[囗@(夕/方)]。耳听心悦更增快乐也。七重行树者。七重宝树行列[囗@(夕/方)]中。长开异华更无凋变。灵禽栖上众圣游从也。故云七重行树。皆是四宝者。皆由咸也。咸是四宝也。四宝者或是金银珊瑚琥珀也。瑞相经云。其国有七宝诸树周满世界。谓有二宝乃至众宝所共合成。如金树则以银为枝叶华果。银树以金为枝叶华果。乃至有紫金为本白银为茎琉璃为枝水精为条珊瑚为叶玛瑙为华车磲为实。白银为本等一一例此。行行相对枝枝相映。叶叶相显荣色光曜。不可胜视。清风时时发出五音声。微妙宫商自然相振。又观经云。一一树高八千由旬。一一树叶纵广二十五由旬而作异色。一一华叶之中皆有七宝光也。四宝皆是者即据此经。栏楯罗网行树此之三种咸是四宝所成也。四宝者金银琉璃颇胝迦也。通贯上文故云皆是四宝也。周匝者。古申多解。一云栏楯围绕宝树故云围绕。二云栏楯罗网行树围绕国土处处庄严故。问栏楯罗网行树何故各有七重更无增减。答表生归彼国得七觉支故。身口七支无诸过故有七圣财

经云是故彼国名曰极乐

赞曰。第二结成极乐

经云又舍利弗极乐国土有七宝池

赞曰。第二池严众宝。文分为七。第一七宝池深。第二八德水满。第三金砂作地。第四玉砌成阶。第五朱阁凌空。第六宝莲覆水。第七结成极乐。此即初也。又者如前解。七宝者一金。金有五种。黄者为上。久埋不失。百炼不轻。从草不违。生于土左右。所以金字象金在土中形。二银易知。三琉璃者。梵云吠琉璃。有五种色。略云琉璃。四者玻璃者。智度论云。出山石窟中过千年冰化为玻璃。净国无其寒暑土地无冰。何物化焉。但是石类非实石也。谓净土故亦云胝迦。五车磲者。梵云牟娑洛揭拉婆。青白间色也。六赤真珠者。珠体赤也。七玛瑙者。梵云遏湿摩揭婆。此云杵藏。下辨七宝亦依此处。池者池沼严宝璎珞砌墁池潭异种光曜自然严显。瑞应经云。其池纵广深浅或十由旬乃至百千由旬。其池岸上有栴檀树。华叶垂布香气馥薰也

经云八功德水充满其中

赞曰。第二八德水满也。八功德水充满于池。净土福胜水异凡间。含八德之殊功益五常之妙体。八德者。一澄净。二清冷。三甘美。四轻软。五润泽。六安和。七饮时除饥渴。八饮已长养诸根。清净觉经云。其池中水浅深随念上下逐心。观经云。水随莲华枝叶上下。水流之音或闻三宝空无我等诸波罗蜜之声也

经曰池底纯以金沙布地

赞曰。第三金砂作地也。绿水金沙重重显映。无量寿经云。更迓相映。金池白银砂等

经曰四边阶道金银琉璃玻璃合成

赞曰。第四玉砌成阶。边者周围四圻边也。阶即砌。道者路也。上阶之道也。金银琉璃玻璃已如上解。合成者四宝共合成故

经云上有楼阁亦以金银琉璃玻璃[王*車]璖赤珠玛瑙而严饰之

赞曰。第五朱阁凌空也。上有楼阁者。七宝池上斗空起楼阁也。亦以者。七宝池上楼阁凌空还用宝成故云亦也。金银琉璃玻璃[王*車]璖赤珠玛瑙七宝如前解也。严饰之者。庄严丽华饰也。无量寿论云为地庄严也。观经云。处处皆有众宝楼阁庄严池上也。时时游赏往往登攀眺望净土适悦情思也

经曰池中莲华大如车轮

赞曰。第六宝莲覆水也。此文分四。一显华名。二辨形量。三释颜色。四明香洁。此初二文也。莲者芙渠之实。华美曰华。大而复圆状若车轮。观经及平等觉经云。大者或二十里乃至六百万里。然今大小亦无定准。此中约小者说也

经云青色青光黄色黄光赤色赤光白色白光微妙香洁

赞曰。此后二文。第三颜色四香洁四色各有异光也。光即光彩各异。微妙者深细殊常。香者香气。洁者体无尘垢。故云微妙香洁。清净经云。一一华叶皆作异宝色。何独青色光等也。经据纯色者说。问何故只有四色。答表四色是实而无假者。表生居净土心无谄曲语不虚词证四涅槃得四智故

经曰舍利弗极乐国土成就如是功德庄严

赞曰。第七结成极乐。可知

经云又舍利弗彼佛国土常作天乐

赞曰。第三空盈天乐。空中奏乐声演法音。彼国人闻咸生善念。观经云。无量乐器悬处虚空。不鼓自鸣。或林或幢皆悬乐器。悉自和鸣。随众生意皆奏法音。人天闻者俱发道意。或歌六度或赞三乘

经云黄金为地

赞曰。第四地布黄金。心无秽种地感黄金。柔软自然高低随步。观经云。其地由如日宫悬处虚空。其地柔软下足即凹。举足便起。又彼国无须弥山及诸山等。瑞相经亦说。其佛国土自然七宝合成其地不可限量。殊特妙好逾诸十方一切世界。此唯金者亦文略也。又众宝妙衣遍有其地。一切人天践之而行。种种庄严以显殊特也

经云昼夜六时而雨曼陀罗华

赞曰。第五华雨长天也。昼夜六时者。昼夜各有六时。共十二时也。问西方净土境胜地殊。人绝无明国无昏晓。何言昼夜。答华开金浦化生为天曙之情。鸟宿琼林菩萨作时昏之相。不同此界昏昧各殊。而者助句也。雨者从空飘落谓之雨也。曼陀罗华者是梵语。此云适意华也。光洁异香闻者。见者身心适悦长道情故。风飘萎者。地裂受之更雨新华庄严金地故。法华经云。香风吹萎华更雨新好者。华有四德。一严净国土。表生彼国善法饰身故。二敷荣见台。表胜二乘真实法故。三先华后果。表生彼国先因后果故。四香气远腾闻者欢悦。表生归彼者德业馨香名振十方故。故雨华也。问净土雨白华者表于何事。答表生净土唯白业故。有云赤圆华者不善其理也。法华经云。唯白莲华放白毫光。白牛驮驾手执白拂等。表白是众色之本一乘是诸法之源。若云赤圆者此为未可

经云其国众生常以清旦各以衣裓盛众妙华供养他方十万亿佛

赞曰。第六人游诸国。文分为三。初将华供佛。二还国经行。三结成极乐。此即初也。经文易见。各以衣裓者衣襟也。盛诸妙华者易见。供养者进财行曰供。有所摄资为养故云供养。他方者即十万亿佛。显所供养佛数也。准诸经等。或乘七宝宫殿白宝莲华承佛威神腾空。往彼十方世界将诸妙华及诸异物随心供养。听闻妙法及受记别等事

经云即以食时还到本国饭食经行

赞曰。第二还国经行也。即以食时还归本国。饭了经行。经行或绕宝殿。或绕琼林。或往或来。如绢经来往。故云经行。足行宝地。口念金经。故云经行也。瑞相经云。诸往生者若欲食时。七宝应器自然在前。如是众钵随意而至。百味饮食自然盈满。虽有是食实无食者。但见色闻香以之为食。自然饱足身心柔软无所味着。事已化去。时至复现。广经云食如何相违。彼约示现食亦有何失。问西方人胜自有身光。既无日月晖。宁辨辰齐之候。答金钟自振玉磬摇声。圣众云来自然赴会也。问所言食者资益为义。净土之中是何食也。答若约实报净土即禅悦为味。若以化净土即假食资身也

经云舍利弗极乐国土成就如是功德庄严

赞曰。第三结成极乐

经云复次舍利弗彼国常有种种奇妙杂色之鸟

赞曰。第七鸟吟妙法。分文为二。一叙灵禽。二去疑执。初文有五。第一总叙灵禽。第二分别名字。三传和雅韵。四诠显法音。第五闻兴善念。此即初也。复次者复重也。次以次反复征问故云复次。彼国者。即西方常有恒有也。种种者。不一故云种种。奇妙者奇异也。妙殊妙希奇也。杂色者毛色异也。问净土殊胜尚无凡夫。何故飞禽亦生彼国。答弥陀变化而有灵禽。赞利法音庄严国界。故下经云。欲令法音宣流变化所作

经云白鹤孔雀鹦鹉舍利迦陵频伽共命之鸟

赞曰。第二别列名字也。白鹤者。丹朱作顶霜雪为毛。鸣之则声振九皋。舞之则雅和八节。迥异诸鸟故云白鹤。孔雀者。天生灵鸟迥异凡禽。顶戴绿冠身严众彩。故云孔雀。鹦鹉者。毛严翡翠觜饰朱红。羽轻俊以能飞。舌纤长而解语。故云鹦鹉。舍利者梵语。此云鹙鹭鸟也。幼而且俊。俊而又灵。斯项而万里飞腾。增妙而千般音韵。迦陵频伽者此云妙音鸟。音声美妙身体殊常。闻之者侧耳倾心。见之者怡神悦思。妙音鸟也。共命者亦云命命。美音演法迅羽轻飞。人面禽形一身两首故云共命也

经云是诸众鸟昼夜六时出和雅音

赞曰。第三传和雅韵也。昼夜六时者。昼夜各有六时。共十二时也。出和雅音者。和即柔和。雅妙音韵西方灵鸟不并凡禽。音韵柔和言词雅妙。故云出和雅音也

经云其音演畅五根五力七菩提八圣道分如是等法

赞曰。第四诠显法音也。演畅者。演者水流不绝之貌。畅者宣畅。五根等者。三十七菩提分法。经中阙四念住四正勤四神足也。下有等言。等此三位。今释此法略为七位。一四念住。谓身受心法。以慧为体。谓由念力慧于境住。二四正断。谓律仪断断断防护断修习断。以精进为体。精进起用能修断故。三四神足。谓欲勤心观。以定为体。为此四种而修定故。四五根。谓信进念定慧。如名以为五体。出生善故。五五力体即五根。难屈伏故离根别立。六七觉支。谓择法觉支精进喜念定舍轻安。三是别境。择法念定。三是善数。勤舍轻安。一是遍行。谓喜。七八圣道分。谓正见正思惟正语正业正定正命正念正精进。其正思惟体以慧为性。能发语言通佛有故。正语正业以无嗔痴所发身语为体。无贪所发名为正命。离五邪命俱以无表色思为体。余如自名。三十七种合体有九。一慧二精进三定四信五念六喜七舍八轻安九无表色。遍行有一。谓喜。别境有三。谓念定慧。善有四。谓信勤舍轻安。色法有一。谓无表色。菩提所修与声闻异。故菩提分名菩萨法。如是等法者。上等根力觉道。下等念断神足。故云如是等法。或可等者谓六度万行等法。不尔。余法何故不演也

经云其土众生闻是音已皆悉念佛念法念僧

赞曰。第五闻兴善念念三宝也。佛义如前。法者梵语达摩。此翻云法。法即执持物解也。谓即四谛十二因缘六度。僧者梵云僧伽。此名为众。和合义也。谓身和共住。语和无诤。意和无违。戒和同修。见和同止。利和同均。具此六和故名僧也。皆可重故名为三宝。鸟传妙法人发胜心。念三宝之芳名消百生之障累。问灵禽演法数目颇多。众念名一何微妙鲜。答禽传广法表词说之无穷。人念三名绾众善而俱尽

经云舍利弗汝勿谓此鸟实是罪报所生

赞曰。第二去疑执。文分为五。一遮非实报。二征问因由。三答无三趣之名。四通无恶道之字。五正辨化现之情。此初也。汝者呼于弟子故云汝。勿由莫也。莫谓此等灵鸟等实是罪报恶业所生。闻说灵禽恐生滞惑。谓净土之恶缘未息。令一会而胜意不生。所以遮云勿谓此鸟实是罪报所生

经云所以者何

赞曰。第二征问因由。所以者何由义。非是实报。因由者何谓也

经云彼佛国土无三恶趣

赞曰。第三答无三恶之名。三恶趣者即地狱饿鬼畜生也。地狱者梵云那落迦。此云苦器。受苦众生所居器物。饿鬼者多诸恐怕久受饥虚故名饥鬼也。畜生者或云刃六反或云希六反。人之畜养故。或云傍生。造业傍故。受报亦傍。因便令辨。六趣广有章门。如别处说。问有何所以恶道俱无。答生居净土善业缘深永除异类之身。尽是同生之众。只如天宫胜境。尚须善业所招。极乐殊方岂有恶因能往也。况彼尊发愿言。设我得佛国中有三恶趣者不取正觉。故知无也

经云舍利弗其佛国土尚无三恶趣之名何况有实

赞曰。第四通无恶道之名字。名字犹无。何况实有禽类之质

经云是诸众鸟皆是阿弥陀佛欲令法音宣流变化所作

赞曰。第五正辨化现之情。当初众会各有疑心。既非实报之身。此等因何而有引。此一段经文答也。问弥陀神力广变佛身。睹相好以发心。听梵音而悟道。何故作诸禽类显发教门。答化身为佛未是希奇。乃现灵禽令生牢遇发难遭之胜想生殊特之信心。化现多途何足为难。况随类化身处处皆说。琼林宝网皆演法音。流水清风尽谈真教。有斯所以乃现灵禽也

经云舍利弗彼佛国微风吹动诸宝行树及宝罗网出微妙音譬如百千种乐同时俱作

赞曰。第八风吹乐音也。文分为四。一风摇宝树。二声似乐音。三闻兴善念。四结成庄严。此初二文也。微风者细风也。非猝暴风也。吹树及网罗即发微妙音韵。譬如者。譬者况也。如由似也。况似于百千种音乐同时俱奏也。细风徐起吹树网罗。音韵而遍满十方。雅妙而便同众乐。故云譬如百千种乐同时俱作也

经云闻是音者皆自然生念佛念法念僧之心

赞曰。第三闻兴善念也。自然者惯习任运名曰自然。非无因缘名自然也。生念佛念法念僧者。三宝之名如前释也。念佛有三。一心念。心中系念。二轻声念。自耳闻故。三高声念。有十种功德。一能排睡眠。二天魔惊怖。三声遍十方。四三涂息苦。五外声不入。六心不散乱。七勇猛精进。八诸佛欢喜。九三昧现前。十往生净土。应作四句分别。一心念口不念。二口念心不念。三心口俱念。四心口俱不念。此四句中第一句第三句是。瑞相经云。清风徐起不寒不暑。吹诸罗网及众宝树。演发无上微妙法音。其有闻者尘垢不起。自然快乐如得三昧

经云舍利弗其佛国土成就如是功德庄严

赞曰。第四结成极乐庄严。易知

经云舍利弗于汝意云何彼佛何故号阿弥陀

赞曰。下第二辨佛身功德也。文分为二。初明化主功德。二辨听众功德。初文分三。初征问佛号。二正辨得名。三明成佛劫数。此初文也。佛自征也

经云舍利弗彼佛光明无量照十方国无所障碍是故号为阿弥陀

赞曰。第二正辨得名。而有二义。一约光明得名。二约慧命得名。此即初。光有二种。一内光即智内照理。二外光即身光外照也。此即身光也。金刚不坏之体无碍解脱之身如净琉璃表裹莹彻。彼方境物悉现光中。羽之只有一寻。展之动论无量也。无量寿佛经云。身多光故乃至无量等光众生遇彼光者三垢消灭。若在三涂见光息苦寿终之后皆得解脱。大论云。阿弥陀国诸菩萨众身之常光照十万由旬。若是佛光遍照十方世界。又观经云。彼佛身如百千万亿夜魔天阎浮檀金色。其身六十万亿那由他恒河沙由旬。眉间白毫右旋宛转。如五须弥山。佛眼如四大海水。清白分明身诸毛孔演出光明。如须弥山。其佛圆光如百亿三千大千世界。于圆光中有五百万亿那由他恒河沙化佛。一一化佛亦有众无数化菩萨而为侍者。彼佛有八万四千相。一一相有八万四千好。一一好有八万四千光明。遍照十方无量世界。有此光明故号阿弥陀也。问光照十方无量世界者。此土人民何以不睹。答道合即千里悬应。世乖则肝胆梵越。如翳者不睹于曦光。岂曦光之有咎。似聋者不闻于雷震。非雷震之有愆。众生业累增强。佛有光而不见

经云又舍利弗彼佛寿命及其人民无量无边阿僧祇劫故名阿弥陀

赞曰。第二答寿命得名。寿命者第八识上连持功德也。即是不相应行中摄也。无量者无其限量。无边者无彼边际。阿僧祇劫者此云无央数劫也。问彼尊彼众身属有为。未逃四相迁移。争免一期磨灭。答舍两重生死获五蕴常身。悲愿无边身命何尽。况又杀业久已寿命延远也。问弥陀已居果位寿命无量可然。人民见处因中。何故亦同彼佛。答业累轻鲜善种增强。既非分段之身。永离去来之质。与佛齐等于理无违。故无量寿经曰。彼佛寿命长远不可称计。假使十方世界无量众生皆成罗汉共尽思惟百千万劫不知寿限。菩萨天人寿命亦尔。又清净觉经云。阿弥陀佛欲令十方一切有情之类生其国悉至泥洹。若菩萨者皆令作物作物已更展转教化十方之类亦复作佛。作佛已更转教化一切众生悉至泥洹。然后涅槃。是知寿命无量也。问彼国人民者为是分段为是变易。答若论报土即便变易之身。若说化净国中分段尚犹未舍。问彼佛寿命长远此经自明未审。成作佛已来至此于今几劫

经曰舍利弗阿弥陀佛成佛已来于今十劫

赞曰。第三明成佛劫数

经曰又舍利弗彼佛有无量无边声闻弟子皆是阿罗汉非是算数之所能知诸菩萨众亦复如是

赞曰。第二辨听众功德。文分为四。初小大两众算数无边。二新旧二徒因行有异。三劝生彼国。四劝生利益。此初分二。初辨众多少。二结成庄严。此初也。声闻弟子者。因声悟道故曰声闻。弟子者。长在我后名弟。解从我生名子。皆阿罗汉者拣前三果故也。非算数之所知者。算数之不及故。菩萨亦如是者。亦同声闻算之不及。问浊世众生业重难化。教说三乘。净土人众信深易劝。何言四果。答有二意。一欲明化泽被浅深故。五逆十念亦生其国。二显庄严眷属故多众围绕。故虽是净土亦有声闻也。故法华经云。彼佛出时虽非恶世。以本愿故亦说三乘。故观经云。小乘根者生到彼土得四果也。问若论真净报土。二乘不令得居。若论化现。净方四果尽皆得往。何故云皆阿罗汉。不说余三果耶。答报净土中声闻权化。约其殊胜。不说化净土中四果。皆有加行位中能伏分别得居净土。无量寿经云。二乘种不生。约报土

经曰舍利弗彼佛国土成就如是功德庄严

赞曰。第二结成庄严也

经曰又舍利弗极乐国土众生生者皆是阿鞞跋致

赞曰。第二新旧二徒因行有异。文分为二。初新生不退众。二补处位高众。此初也。阿鞞跋致或云阿惟越致是梵语。此云不退转。不退有五。一信不退。二位不退。三证不退。四行不退。五烦恼不退。不被烦恼所退转故。问生居净土何故不退。答无五退缘故。一无病苦缠故。二无违行故。三常诵经法。四常营善事。五长和顺无诸违诤事。所以不退。此界人多退反此应知。又有欲境所牵多诸退屈也

经曰其中多有一处补处其数甚多非是算数所能知之但可以无量无边阿僧祇劫说

赞曰。第二补处位高众。一生补处者。补者补阙。处者处所。此等菩萨因圆十地劫满三祇。尽此一生便成正觉。故云一生补处也。余经文易见故。只如弥勒现居天界当来果成。一生补大觉之尊三会度无量之众。即是此类。故无量寿经云。设我得佛。他方国土诸菩萨众来生我国。究竟各到一生补处。以本愿力故生彼即入补处之位

经曰舍利弗众生闻者应当发愿愿生彼国

赞曰。第三劝生彼国。现在未来一切众生闻我向来说者。应当发愿愿生彼国。问慈氏天宫快乐不少。胜侣颇多。何须坚劝往彼西方。答若论兜率即胜人间。乃并西方全成微劣。胜劣既异。彼此各殊。劝生西方舍劣求胜也。胜劣有异者。净土十胜天宫十劣。净土十胜者。一化主所居胜。二所化命长胜。三国非界系胜。四净方无欲胜。五女子不居胜。六修行不退胜。七净方非秽胜。八国土庄严胜。九念佛摄情胜。十十念往生胜。天宫十劣者。一所居国土劣。二所化寿役劣。三界系摄属劣。四彼天有欲劣。五男女杂居劣。六修行有退劣。七秽方非净劣。八国土庄严劣。九善念摄情劣。十修行劳苦劣。有斯十胜十劣所以劝生彼国

经曰所以者何得与如是诸上善人俱会一处

赞曰。第四劝生利益。诸上善人者。善者过现益物谓之善。人即前声闻不退及补处等菩萨也。俱在西方一会处也。同师进业必假良缘。朋家作仇事资恶党。孟母移居于胜处。宣尼不饮于盗泉。盖耻恶而慕善也。慕善则芳兰袭庆。朋恶则鲍肆荤风也。劝生西方亲之胜侣也

经曰舍利弗不可以少善根福德因缘得生彼国

赞曰。自下第二举极乐之因殊。文分五段。一遮少善。二说多因。三圣众来迎。四众生生往。五结劝往生。此即初也。不可以微少善根得往殊常净土。问十念弥陀顿生净土。据斯所说果着因微。何故少善因缘不生彼土。答十念得生净土。接引懈怠众生。却谈多善因缘。乃被精进劝学者或广或略理不相违

佛说阿弥陀经通赞疏卷中阿弥陀经通赞疏卷下

        大慈恩寺沙门窥基撰

经曰舍利弗若有善男子善女人闻说阿弥陀佛执持名号若一日若二日若三日若四日若五日若六日若七日一心不乱

赞曰。第二说多因也。善男子者。梵云乌波索迦。此云近事男。索者男声也。坚持五戒堪可亲近承事比丘僧故。善女人者。乌波斯迦。斯者是女声也。亦持五戒堪可承事比丘尼故。西天分男女二声故。闻说阿弥陀佛者。谓于善友处闻此阿弥陀教中往生之事。或自寻览执持佛名号。一日乃至七日一心者。更无间隔故名曰一心。不乱者。专注无散也。问净土论云。女人及根缺二乘种不生。云何相违。答只如女子念佛。至意专精命尽欲生转成男子便生净土。有何不可。根缺亦尔。文殊般若经云。若人欲生他方现在净妙国土者。应当随彼国土佛名。一心诵念愿往生者。必得往生。观佛三昧经云。此念佛三昧欲使成就有五因缘。一持戒不犯。二不起邪见。三不生谄慢。四不恚不嫉。五勇健精进。鼓音声经云。令念彼佛名号七日七夜六时礼拜。贤愚经云。持戒专念七日亦得往生。平等觉经及大阿弥陀经并说三辈得生。如彼中说

经曰其人临命终时阿弥陀佛与诸圣众现在其前

赞曰。第三圣众来迎也。其人者。既七日念佛行人也。临命终时者。此一报寿命临欲终时。即彼佛与诸圣众即彼国菩萨声闻等现身于念佛修行人前。如梁朝珍禅师见白银台或见化佛来迎也

经云是人终时心不颠倒即得往生阿弥陀佛极乐国土

赞曰。第四众生往生。不颠倒者不移正念也。即得往彼国也。莲华化生颜貌端正如诸菩萨。心无颠倒意想正修。便别秽方顿生净土。故云即得往生。问众生恶业无量。如何念佛灭除业障便得往生净土。答十疑论说有三义故能敌恶业。一者在心。为造罪是虚妄心。念佛是真实心。以实除虚有何不可。如千年之闇不能拒朝日之光。二者在境。谓造罪缘于颠倒境界。念佛缘于胜妙功德。以真遣伪有何不可。三者在净谓造罪是染意。念佛是净心。净胜染劣讵可相比。如童子[木*為]刀能断千丈之索。一星之火能烧万束之薪。又观经云。于念念中灭除八十亿劫生死之罪。罪业既除得生何惑。西域之人临命终时皆以幡像前引。亲友知识助念弥陀令发往生之意。是此教也。又华严云。将欲没者令其忆念想见如来。命终得生净土。见有临命欲终。劝念佛名。又示尊像。令其瞻敬。令生善念即得往生。问临终作善便得往生。何假预前修诸胜业。答人生寿夭难测短长。或即病因昏迷。或即非时奄逝。既阙生前之善。难逃后世之殃。预作善缘恐防斯咎。问往生之人有中有身否。答群疑论中有二师义。一师云极善极恶无中有。二不拣善恶但有舍报受生者皆有中有。为传识故。除现世变身即无中有。净土既是极善中有定有。有者为正

经曰舍利弗我见是利故说此言若有众生闻是说者应当发愿生彼国土

赞曰。第五结劝往生。我见是利者。我者世尊称我也。见是利者见是殊常胜利益。故劝生彼国也

经曰舍利弗如我今者赞叹阿弥陀佛不可思议功德

赞曰。第三诸佛证明。文分为三。初陈自赞言。二引他佛证。三释经名字。此即初也。如我今者自指也。彼佛功德不可以心思言议故也

经曰东方亦有阿閦鞞佛须弥相佛大须弥佛须弥光佛妙音佛

赞曰。第二引他佛证。称赞净土经云十方诸佛。此略举六方便为六段。且举东方。每一方各有五段。一指国土。二举佛名。三辨多少。四明证相。五引证言。今初两段合一唱也。东方者指国土。亦有阿閦下举佛名。先引东方者。西域以东为上。所以先举。阿閦梵语此云无动。不被烦恼四魔违顺等动故。须弥相者。谓金容尊状若须弥。大须弥者。谓诸相甚大如大山王。须弥光者。大如山王身光故。妙音者。其声微妙清彻远闻

经曰如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界

赞曰。第三辨多少。四明证相。如是等恒河沙数诸佛是辨多少。各于其国辨明证相也。如是等佛数比河沙而不具列故言等也。恒河数者梵云殑伽。讹略云恒河。是河神之名。河从彼称。殑音其[(美-(王/大)+弔)*令]反去声也。经中说河沙为喻。无热恼池出四大河。此河即一也。由具五义。一由沙多。二由世人共为福水入洗罪灭投死生天。三虽经劫坏名字常在。四佛多近此宣说妙法。五众人共委。故多为喻仍取。初出池口方四十里河以为喻。明证相。诸佛各于其国出广长舌相者。即各在本国舒舌相也。三千大千世界者。准大论云。千须弥山千日月千四天下及千梵王是谓小千。以小千为一数至千名大千。故名三千。非小中故为大千。俱舍论云。小千至初禅。中千至二禅。大千至三禅。俱同一成坏遍此故云遍。故云遍覆三千大千世界也。表无量劫来口离四过感此舌相也。证小事即覆面门以至发际。今证大事故至三千。今说因微果胜恐众生疑。此乃抛苦恼之要门。证常乐之疾路。事既广大。现瑞非轻。舒舌相而遍覆大千。证西方而真快乐

经曰说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经

赞曰。第五引证词。经文易见。诚者实也。问汝等者。为是六方诸佛告语自国听徒。为当释迦劝试祇园之众。答观此经势而有二意。一他方诸佛告自国听众。二释迦转引彼佛意言证彼西方。令一会众生信敬也。一切诸佛所护念经者。即是此经也。准此具足应名称赞阿弥陀佛不可思议功德。其文略也。一切诸佛所护念经者。诸佛护持明记忆念也。即众行虽广难方念佛之功德。福然多。争并持经之力。故使六方诸佛以神力而护持。沙界圣人乃一念而忆念。故云一切诸佛所护念经。问若释迦谈于净土。可言佛所护念。诸佛不说此经。何说佛所护念。答王言是敕。佛语成经。既称赞于净方。此说便成经也。或可佛所护念者即指释迦所说阿弥陀经也。问灵山开塔要假召集分身。舍卫启筵何故不邀诸佛。答召佛开其宝塔。赴彼佛之愿心。证土启相信诚显此尊之悲意。但各居自国不至此方也

经曰舍利弗南方世界有日月灯佛名闻光佛大焰肩佛须弥灯佛无量精进佛

赞曰。第二南方也。分五如前。此前二段也(一指国土二举佛名)。可知。日月灯佛者。身光智光内外俱照故。名闻光者。有大名闻光照内外。或闻名见光生觉悟故。大焰肩者。身光发焰出于肩故。或肩者齐也。即身光智光皆发焰齐也。须弥灯者。身光如灯焰有破暗故。无量精进者。利乐有情也

经曰如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界

赞曰。第三辨多少。第四明证相。行相如何

经曰说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经

赞曰。第五引证词。亦同前释

经曰舍利弗西方世界有无量寿佛无量相佛无量幢佛大光佛大明佛宝相佛净光佛

赞曰。第三西方。同前五段。此二文也。无量寿者。即西方本尊。依二义得名。如前已解。问儒宗尚无自伐其善。何故弥陀自赞难思。答据其文势即是诸佛称赞。又设若弥陀自赞。于理何违。引转众生令生胜意。无量相者。相好无量故。无量幢者。身量功德高而复峻由如幢也。大光者。身智二光无不照故。大明者。得佛三明无不知故。即正遍知也。宝相者。内外二相皆可宝重故。净光者。净者无漏。光者身智二光。故言净光也

经曰如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界

赞曰。第三第四文也。如上说也

经曰说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经

赞曰。第五文也。引证词可知

经曰舍利弗北方世界有焰肩佛最胜音佛难阻佛日生佛网明佛

赞曰。第四北方证也。文五同前。焰肩佛义同于前。最胜音。音声美妙胜过余故。难阻佛者。诸魔不能阻碍故。日生者。依智慧日流声教故。或依智慧日令众生生诸善法故。网明者。施此教网令众生生于明解故

经曰如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界

赞曰。第三第四文如前可知

经曰说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经

赞曰。第五段文意可知也

经曰舍利弗下方世界有师子佛名闻佛名光佛达磨佛法幢佛持法佛

赞曰。第五下方证也。文五同前。此二文也。师子佛者。如于师子兽中自在。佛于法中自在故得此名。又世师子伏诸猛兽。佛即伏四魔也。名闻者。名振十方故。名光者。闻名见光生觉悟故。达磨者梵语。此云法也。以法为身。即有为无为诸法所依止故。法幢佛者。广开大法高峻如幢故也。持法佛者。持过去佛法付未来故

经曰如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界

赞曰。第三第四文相可知

经曰说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经

赞曰。第五文也。行相同前

经曰舍利弗上方世界有梵音佛宿王佛香上佛香光佛大焰肩佛杂色宝华严身佛娑罗树王佛宝华德佛见一切义佛如须弥山佛

赞曰。第六上方佛。文五同前。此初二文也。梵音者。声相美妙闻者悦心故。宿王佛者。宿者星也。月是星中之王。佛者是十地菩萨二乘凡夫之王也。得自在故。香上佛者。戒德馨香更无过上故。香光佛者馨香自远光彩教门故。大焰肩佛者。身肩发焰故。杂色宝华严身佛者。心华发明自严饰故。或可杂色众宝以严其身饰形可以美价故。娑罗树王佛者。如大树王能覆癊故。佛能覆癊诸众生故。宝华德佛者。身智功德如宝可重故。见一切义佛者。义者境也。佛具五眼见一切境故。如须弥山佛者。福智如山巍巍高峻故

经曰如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界

赞曰。第三第四文可知也

经云说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经

赞曰。第五文也。同前可知

经云舍利弗于汝意云何何故名为一切诸佛所护念经

赞曰。第三释经名字。文分为三。初征问。次通释。后结劝。此初也。世尊云汝舍利弗还知此经如何得名一切诸佛所护念经否

经曰舍利弗若有善男子善女人闻是诸佛所说名及经名者是诸善男子善女人皆为一切诸佛共所护念皆得不退转于阿耨多罗三藐三菩提

赞曰。此是第二通释也。善男子善女人等是所护人也。闻是阿弥陀佛及闻六方恒沙佛名者能护念人也。是诸善男子善女人皆为一切诸佛所护念者。得正护念也。即受持经及佛名男子女儿因闻诸佛及释迦佛说修净土经方始得生净土。即此经是诸佛所匡护明记忆念故。阿耨多罗三藐三菩提者。阿之言无。耨多罗云上。三云正。藐云等。三云正。菩提云觉。即是无上正等正觉。问为但念阿弥陀佛即得不退。为更有余方便。答非但称念礼敬。又应至心于诸佛前忏悔劝请随喜回向发愿。由忏悔故转诸定业。如如意珠随愿即得不退转。为由诸佛护念故于无上正等觉心得不退也

经云是故舍利弗汝等皆当信受我语及诸佛所说

赞曰。此第三结劝也。是故者结上之词。皆当等者劝励之语。汝等信我上来所说及六方诸佛之言

经云舍利弗若有人已发愿今发愿当发愿欲生阿弥陀佛国者

赞曰。自下第四三生发愿。文分为四。第一发心往生。第二彰其胜益。第三位居三世。第四劝生彼国。此即初也。已发愿者过去。今发愿者现在。当发愿者是未来。欲者希望也。生者即五蕴假者也

经云是诸人等皆得不退转于阿耨多罗三藐三菩提

赞曰。第二彰其胜益。念佛发愿故。一即彼佛冥加。二即此佛潜卫。遂令求道之心不退愿生之志不转。故言不退转。若已发愿已得不退。今发愿者即现在今得不退。当发愿者当得不退转也

经曰于彼国土若已生若今生若当生

赞曰。第三位居三世。已发愿者为过去发愿者已生。今发愿者为现在者即生。未来发愿者为未来未来发愿当生

经曰是故舍利弗诸善男子善女人若有信者应当发愿生彼国土

赞曰。第四劝生彼国。若有信心深重烦恼轻微。知大觉以诚言获良愿而当往也

经曰舍利弗如我今者称赞诸佛不可思议功德彼诸佛等亦称说我不可思议功德

赞曰。第五彼尊赞叹咸曰希奇。文有四段。初赞功德难思。二叹化行浊世。三嗟讶成佛。四说法幽玄。此文是初。我赞六方诸佛能为众生作真实语。众生因此心无疑惑。又弥陀如来慈悲接引。我等偏赞彼佛。彼佛复赞于我

经曰而作是言释迦牟尼佛能为甚难希有之事能于娑婆国土五浊恶世劫浊见浊烦恼浊众生浊命浊中

赞曰。第二叹化行浊世。而作是言结集家叙也。释迦梵语。此云能仁。牟尼此云寂默。得姓之缘如别处说。言甚难希有之事者。即是忍苦教化众生之事也。能于娑婆国土者。梵云娑婆此云堪忍。堪可忍受苦恼之事故也。五浊恶世者。略以五门。一释名。二出体。三对治。四废立。五相摄。初释名者。浊是滓秽义。如食滓秽。下恶可污名之为浊。此言意说劫增之时。三灾渐轻烦恼转薄。众生向好恶见渐微。命根转长渐渐向胜。已上好可忻名之为清。众生无苦化佛不出世。诸化佛出世必向劫减。小三灾渐起烦恼转厚。众生向恶染见渐增。命根转短渐渐向劣。下恶可厌故立浊名。五者是数。带数释也。次望别名皆持业释也。或以别拣总。亦依主释。二出体者。地持论云。谓今世人多皆短寿。极长百岁。是名命浊。此以本识名言种子。由业所引功能差别命根为体。善业力弱命根渐短。由杀生业之所感故。若诸众生不识父母不识沙门及宗族尊长。不修义理不怖不畏今世后世恶业果报。不修惠施不作功德。不修齐法不持禁戒。是名有情浊。虽第八识名为有情。今说由近恶外缘故。五蕴假者作恶无善名有情浊。合以第八识及五为性。若此众生增非法贪。或惠刀剑或施器仗。诤讼斗乱谄曲妄语。摄受邪法及余恶不善法。是名烦恼浊。除五见外所余一切烦恼随烦恼皆烦恼浊体。此非法贪惠刀剑等令行杀害。或悭好财但舍刀剑。因非法贪诤等竟起。乃至诸余恶不善法通摄一切烦恼随烦恼尽。由性数习逢恶境牵烦恼尤重。若于今世法坏法没。像法渐起邪法转生。是名见浊。此以五见而为体性。多近外道恶见数生。若饥馑劫起疾病劫起刀兵劫起。是名劫浊。此以色蕴四尘为体。或通五蕴。仍是不相应时为其体。依四五蕴而建立故。烦恼增多恶业尤重。便招恶果三灾遂生。三对治者。智度论中立四悉檀。悉檀宗也。一世界悉檀。二为人悉檀。三对治悉檀。四第一义谛悉檀。劫浊众生浊世界悉檀治之。识器世间众生世间悉皆虚幻。厌怖修道即永离故。命浊以各各为人悉檀治之。识知人由善业所得。修持净戒行不杀等。命自长故。或为三乘之人各说自乘涅槃之果。便除生死所有命浊。烦恼浊见浊对治悉檀治之。修习随应对治之道令不起故。由三悉檀破五浊故。入第一义证会真宗。四废立者。何故唯立五浊不增减耶。答众生有二。一恶行。谓在家白衣。二邪行。谓出家外道。白衣无慧烦恼增时名烦恼浊。外道邪解浪推求时立为见浊。又诸钝惑名烦恼浊。诸余利惑名为见浊。由此二因得当果时离合不同。复分二浊。合二内果名众生浊。恶众生故。合二外果总名劫浊。恶器具故。劫谓时分。时无别时。依法辨故劫浊故以恶器为体。此恶众生及与外果。虽复总陈是二浊果未辨。何者。正恶果体今显根本故立命浊。或内恶果名为命浊。外恶果者名为劫浊。此恶因果由谁而有。谓恶众生故名众生浊。由此五浊据增行相。欲令生厌故偏说五。五相摄者。萨遮尼干子经云立十二浊。一示现劫浊。二示现时浊。三示现众生浊。四示现烦恼浊。五示现命浊。六示现三乘差别浊。七示现不净国土浊。八示现难化众生浊。九示现说种种烦恼浊。十示现外道乱浊。十一示现魔浊。十二示现魔业浊。劫浊及时即劫浊。众生及难化众生即众生浊。烦恼及说种种烦恼即烦恼浊。命即命浊。外道乱即是见浊。此八即五浊。余之四种谓三乘差别不净国土。魔及魔业非五浊摄。五浊据胜唯实杂染。十二浊通能化能障佛示现故。问何故释迦百岁时生。弥勒八万岁出。答各据本愿出时不同故

经曰得阿耨多罗三藐三菩提

赞曰。第三嗟讶成佛。缘此界境唯秽恶人不足是非证菩提。如火内生莲。得解脱似冰中出烛故也

经曰为诸众生说是一切世间难信之法

赞曰。第四说法幽玄。难信之法者。只如此典一朝诵佛十念精进诚超五浊之秽方登初地之净域。岂非难信哉。上来第五彼尊赞叹咸曰希奇讫

经曰舍利弗当知我于五浊恶世行此难事

赞曰。下第六段我佛叙陈独称难事。文分为四。初叙行难修。二叙果难证。三叙法难信。四总结甚难。此即初也。行此难事者。即三僧祇劫万行备修。捐身命以殉菩提。舍国城而为郡众方成正觉。岂非难事也

经曰得阿耨多罗三藐三菩提

赞曰。此第二叙果难证。如上已解。其文可知

经曰为一切世间说此难信之法

赞曰。此第三叙法难信也

经曰是为甚难

赞曰。此第四段总结甚难。结上三事。上来已解正宗分讫

经曰佛说此经已舍利弗及诸比丘一切世间天人阿修罗等闻佛所说欢喜信受作礼而去

赞曰。第三流通分文有四段。初说经事毕。二听法缘终。三闻法欢忻。四退辞佛去。四段合一唱也。佛说此经已者。是第一说经事毕。及诸下文皆结集之语也。舍利弗及诸比丘一切世间天人阿修罗等闻佛所说者。是第二听法缘终。言世间者即有情世间也。可破坏故。天人者。天即欲界六天。天者即光洁自在名天。人即人趣。谓多忍义名人。阿修罗此云非天。如人不仁名曰非人。修罗亦尔。欢喜信受者。是第三闻法欢忻。颜舒曰欢。神悦曰喜。故云欢喜。即意识相应喜受也。此经乃三乘妙旨。众圣要枢。出生死之鸿源。证真常之疾路。得路得闻圆备。岂不乐哉。故云欢喜。问先标听徒之处兼明菩萨声闻。经终作礼欢忻何故不明菩萨。答迓影略说。不必俱陈。作礼而去者。是第四退辞佛去。五轮俱屈。三业归诚。咸别世尊各还本土故云作礼而去

佛说阿弥陀经通赞疏卷下(终)

此慈恩所撰阿弥陀经通赞一卷者。祐世僧统于元丰元祐之间。入于中华求得将到流通之本也。(予)助洪愿。付于广教院。命工重剶。自戊辰十月十九日起首。至十二月十日毕乎矣。所有功德。自利利他。此世来生福慧圆满。普与含识同会乐方。时大安五年已已二月晦日记

海东大慈恩玄化寺住持广祐僧统释韶显题

件书等(予)以嘉保二年孟冬下旬。西府郎会宋人柳裕传语高丽王子义天。誂求极乐要书弥陀行愿相应经典章疏等。其后折裕守约。以永长二年(丁丑)三月二十三日(丁丑)送自义天所传得弥陀极乐书等十三部二十卷。则以同五月二十三日家时兴福寺净名院到来。恳诚相臻。清素自[怡-台+皆]。仍以彼本。已重新写。善种不朽。宿心爰成。欲为自他法界往生极乐之因缘矣

康和四年(壬午)四月二十二日未克药师寺西室大房书写毕

愿以此书写善根。先二亲消灭罪障。次桓贤终往生极乐矣。(生年)三十一。但此书者。桓贤没后门弟之中常住僧房修学为宗之辈可传领也

嘉历元年(丙寅)六月十七日依众议誂有小生分书写所奉奇符春日社西新谈议屋也

                    大法师源觉


阿弥陀经义记

    No. 1755 [cf. No. 366]

阿弥陀经义记

        天台智者大师记

夫至圣垂慈照机应迹。开导六道普济十方。逐境升沉随缘净秽。斯则善权摄诱引趣菩提。是故大觉弥陀昔弘誓力应形极乐现处道场。三辈愿生皆入定聚。色像殊胜寿量难思。宝树天华咸能演法。清风流水俱说妙音。闻唱苦空证无生忍。释迦圣主本愿弘深。不舍慈悲。化兹秽境五痛烧然八苦煎逼。广明诫劝遍洽群品。示其妙术十念往生。四众奉行依教修观。说有广略时处不同。灵鹫宣扬三种净业。舍卫敷演六方护念。阿弥陀天竺梵音。震旦译言为无量寿。化主极号以立嘉名。经者训常。由圣人口此即释尊所说语西方事故言经也。即斯一教在文虽约明义实繁。总语西方安养国界。第一释名。从人。标称。依教修习往生彼国。第二辨体。法性真如谛心观察证常乐果。第三宗致。净土机缘妙乐庄严化像迎摄第四力用。破除爱见五住尘劳正习俱尽。第五教相。带别挟通生熟醍醐总为教相也。分文三段。序正流通。略无别序。通中具六。第一如是者决定之辞。大圣观机。为多嗔者略说深妙。为多贪人广开秘密。为多无明者处中而说。言不虚发应物逗缘。我闻者。如来正法无量无边。我所得闻犹如微渧。所不闻者喻大海水。一时者。有感斯应。机悟之辰。即于会革凡成圣。佛者正标化主。应供遍知四辩六通三明八解一音演说随类闻晓。在舍卫国者名闻物。多有名贤。又饶珍宝觉徒商侣诸国共臻。复名为无物不有。祇树给孤独园者。只陀舍树创起门坊。须达赈贫金布地共立精舍也。与大比丘僧者。大义三种。天王大人所敬故言为大。遍知内外经教是故言多。超九十五上故名为胜。比丘者此言除馑。在因三义。乞士怖魔破恶。果地三德应供杀贼不生。僧者四人已上和合羯磨事理无隔匡维正教。千二百五十人俱者。三迦叶众共有一千。舍利目连二百五十。常随圣尊为证信众。长老舍利弗智慧上首。翻鹙鹭子。大目揵连神力标名。此翻读诵。摩诃迦叶亦言钵罗。此翻龟氏。又曰光波。摩诃迦旃延善能清论。此翻扇绳。摩诃俱絺罗辩才无滞。此翻大膝。离波多翻为室宿。亦曰常作声。周梨槃陀伽此土翻译曰小路边生。难陀尊者此翻欣乐。阿难陀者翻善欣悦。罗睺罗者此言障持。憍梵波提译曰牛迹。宾头卢颇罗堕翻走闭门。迦留陀夷翻大粗黑。劫宾那翻为房宿。薄拘罗者翻曰善容。阿[少/兔]楼驮翻为如意。文殊师利此翻妙德。阿逸多者翻无三毒。乾陀诃提翻为香意。常精进者此土方言。如是等者结菩萨众。释提桓因翻能天主。等诸天众。总结同闻列众序竟

正说为二。初明彼佛依正二果。次劝物往生。初复为二。前标次释。前标国界。后明化主。此经命章对舍利弗。余经皆有诸主。此经无问自说。十二部中亦不具足无两种偈。其余诸部亦不全有。不对菩萨者。适化无方欲令凡夫小乘厌此欣彼也。标依果中前明近远。从是西方过十万亿佛土有国名极乐。望贤首犹是下品。但比娑婆故言极乐。彼有三名。极乐对苦。安养从用。无量寿者逐人名国。次出正果号阿弥陀。其实有量。以余人不能称数。既云观音补处下地。不知说无量耳。彼土何故下解释。前明依果有三。初总次别后结。初总如文。七重行树下别释有四。一明宝树池楼阁奇丽。二明天华天乐映显庄饰。三明为宣道品。四树奏乐音。其树七重皆是四宝金银琉璃玻璃等宝。七重罗网七重行树微风徐动畅发和音。闻此声时即入正位。八功德水充满盈溢。轻清冷软美而不臭。饮时调适饮已无患。底布金沙。四面阶道四宝合成。池中莲华大如车轮。光色炫耀微妙香洁。上有楼阁。亦以四宝而严饰之。二明天乐。不抚而韵弦出无量法化之声。听发慈心。闻便悟道。昼夜六时雨曼陀罗。天华至妙名曼陀罗。色妙无比香气芬馥。常以清旦衣裓盛华。供养他方十万亿佛。即以食时还到本国。衣裓是盛华器。形如函而有一足。手擎供养。三杂色鸟白鹤孔雀鹦鹉鸲鹆。亦如此闻水禽之类。迦陵频伽妙音清高。可譬佛声。共命两头而同一体生死齐等。故曰共命。此等众鸟昼夜六时演畅五根五力七觉八道。妙音和雅。即道品中法门名义。初五根者信进念定慧。次明五力名不异前。根生有力别更号。七菩提分念择进喜舍定等。八正道分正见正思正语正业正命正进正念正定。善修道品即得见谛至于无学。勿谓此鸟罪报所生。皆是彼佛欲令法音宣流变化所作。四明七重行树及宝罗网。妙音譬如百千种乐同时俱作。自然皆生念佛念法念僧之心。悟无生忍。怡然快乐

次辩正果文复有二。前明化主次辨徒众。化主又二。初辨光明无量次述寿命无限。大品云。欲得光明无量寿命无极。当学般若。就此徒众前辨声闻次明菩萨。前问前云有无数声闻。后何得云众生生彼国者皆是阿鞞跋致。解云彼土二乘亦皆不退。二乘不退为凡夫。菩萨不退为小乘也。从众生闻者下第二劝物往生有三。初正劝往生。次引证劝。三结劝又二。初正劝。次示往生方法。就初又二。初正劝次释劝意。舍利弗以少善下次示方法。问前云不可以少善。后那云一日七日心不散乱皆得生。答今不以时日多少。特由用心厚薄耳。若能七日一心不乱。其人命终阿弥陀佛以宿愿力化佛迎接。心不颠倒即得往生。何以故临终一念用心恳切即当得去也。我见是利即是释意。应当发愿一心修行。发愿庄严行愿相扶必当得往生也。如我今者下引证劝。非我独叹彼佛正劝物往生。六方诸佛皆悉劝发称扬赞叹恒河沙数各于其土往生彼国。若男女闻是经名。皆为诸佛共所护念。皆得不退无上菩提心。故汝等当信我语及诸佛说。发愿欲生皆不退转往生彼国。彼诸佛等亦称释迦。能为难事于娑婆杂恶五浊境界。为诸众生说难信之法。当得菩提。秽国障深五浊垢重。贪嗔是烦恼浊。五见为见浊。二为本揽此作因得有连持之命。于五阴假立众生。此四经时名为劫浊。秽国苦多其浊极重。同居净土其浊即轻。因顺余方有其名字。无此迫恼号极乐耳

佛说经已下即流通段。说经既竟。四众天人修罗等类欢喜信受。圣主难遇若优昙华。庆今得见。正法难闻而今闻。昔所未悟而今得悟。具此三喜是故欣悦。得之于怀踊跃无量也

阿弥陀经义记一卷


阿弥陀经义述

    No. 1756 [cf. No. 366]

阿弥陀经义述

        慧净述

阿弥陀经(此云无量寿后秦罗什师元译小无量寿元寿求那跋陀法师重译)

窃以。法身无像像。因有像之机。净土无方。方因有方之感。虽复至理凝寂道绝名言。大悲善巧随□□□□□□□□□□□□□□□□三转醍醐尘沙出俗。契之者必同其本。化之者或异其流。是以弥陀种觉居妙刹以弘道。释迦能仁处娑婆以接物。净土之内。根就易调。秽国之中。刚强难化。开三因以运四生。布九品而摧五痛。六方诸佛。现于三千。证得往生。言无虚妄。缘众生空而不舍大悲。观如来寂而不失敬养。虽知佛□□寂如空而现种种清净佛土。可谓不坏假名而说诸法实相。不动□□而建立诸法者。佛说阿弥陀经者。乃劝生净土不退菩提者也。皎三明以像秋月。振四辨而类春雷。赞净境以示西方。美胜因而指东土。班自我口。畅之彼心。以觉合机。故称佛说。阿弥陀此云无量寿。光明说法徒众皆悉无量。为引物情。偏标寿名故名。无量。经有二义。训经训常。众圣所游。曰经古经今。恒定曰常。故名佛说阿弥陀经

如是(至)给孤独园者

述曰。经开三分。一由序。二正体。三流通。三分例各二。由序二者。一者通序证信。二者别序发起。正体二者。一安乐净土因果。一弥陀法身因果。流通二者。一如来说此经已。二大众欢喜信受。通别二序。例各有六。通序六者。一信成。二闻成。三时成。四主成。五处成。六众成。别序六者。至下文当释。今通序六中五成就也。如是则信成也。如是者信顺之辞。信则所言之理顺。顺则师资之道成。经无丰约。非信不传。故名如是。又如则指法。是则定辞。如佛所说。一切皆是。故名如是。故如是。又信则信此经。下文云。六方诸佛恒沙种觉现相证成念阿弥陀佛定生净土。经初如是示信。经后欢喜示智。信为能入。智为能度。进念定三。网罗始终。五根具足。堪受堪传。故云如是。我闻者闻成也。亲承曰我闻。传授曰所闻。此则亲承音旨。谓阿难亲从佛边。闻说阿弥陀佛极乐国土若有专念定得生。生无传闻之谬。阿难未为侍者前非亲承。而言我闻者。佛临涅槃时。更为略说。故得称我闻也。一时者时成也。佛说此阿弥陀经时。舍利弗阿难等听受时。又法王启运嘉集之时。故曰一时。佛者此云觉。则主成也。说法五人。一佛说。二弟子说。三诸天说。四神仙说。五变化说。今是佛说。故名主成就。佛是大师之名。以觉为义。觉有二。一觉察。二觉悟。悟则智障尽。察则烦恼障除。于二觉而有三异。自觉异凡夫。觉他异二乘。觉满异菩萨。三者备矣。爰佛名焉。在者处成也。在亦云住。住有八。今略有二。一境界住。二依止住。在舍卫国祇树给孤独园者。出二住。境界为化在俗之徒。园是依止之处。为接出家众。只陀太子云战胜。太子载诞之时。王破敌军之贼宫人闻奏因以为名。给孤独本须达。此云善慈。内外慈而富。赈贫而恤寡。乡人美之。因以号焉。人有上下。不可先称独园。园总树别。不可俱言祇树。二人同心共造精舍。含为名。故云祇树给孤独园。法身实无栖詑。示化有方。假住此处。说阿弥陀五门修行定得往生。五门者。故往生论云。一礼拜门。二赞叹门。三作愿门。四观察门。五回向门

与大比丘众(至)诸大弟子

述曰。众成也。众有三。一声闻众。二菩萨众。三诸天众。此声闻众有五。一标类。二唱数。三赞德。四列名。五结定。与大比丘者标类也。与者亦名共。四□□乳身自兼彼。目之为共。智度论云。共一戒一见一处□□□□□□□□□□□□等名共。大者梵云摩诃。此有三义。一大。二多。三断故。人天王等。人所恭敬故。云何多。数至千二百五十人。□□十六外道论议能破故。比丘略有三义。一怖魔。二乞士。三破恶。此三即初中后也。怖魔者。夫创轨玄门。即建降魔之志。故前剃发染衣时。天魔宫动而魔怖也。乞士者。身为道器。身安即道隆故。已沽法服乞食以资身也。破恶者。然圣人道长。凡夫道消。所修已满。破恶以证果也。本觉地三名为至果地。转怖魔为杀贼。改乞士为应供。说破恶为不生。僧者此云众也。多比丘一处和合故。名为众也。千二百五十人俱者唱数也。皆是大阿罗汉者。赞德也。罗汉三义。如上比丘果地三名。应知。众所知识者。人天大众所共知其内德识外形也。长老舍利弗至阿[少/兔]楼驮者。列名也。明列声闻众中十七人。长老慧命净命等并称赞之谓。舍利弗此云身子。钝若有边则段陀利若有边则身子。告往知来。雄才隼夹。神慧□悟。目连此云赞诵。迦叶此云饮光。俱絺罗此云大膝。周利槃陀迦此云蛇奴。难陀此云庆喜。阿难此云欢喜。罗睺此云覆障。憍梵波提此云牛王。宾头卢此云上座。颇罗堕此云利根。迦留陀夷此云黑色。劫宾那此云房宿。薄俱罗此云善容。阿[少/兔]楼驮此云如意。如是等诸大弟子。结定也

并诸菩萨(至)如是等诸大菩萨者

述曰。菩萨众也。有三。初标类。次列名。后结定。菩萨名觉士。觉义有四。一应觉。二正觉。三觉分。四全觉。土有二训。一治。二事。以此觉事。治化众生。故云觉士。摩诃大觉士。真谛云。为约位言之。地前十信十解十行。名菩萨自利□□回向名摩诃萨利他也。登地已上。七地已还。名菩萨。八地已上。名摩诃萨。地论云。大义有三。一愿大。二行大。三利益大。文殊下列名也。文殊师利此云妙德。法王子当继尊位。阿逸多此云无能胜也。乾陀诃提此云赤色。常精进身心修道如救头燃也。与如是等菩萨者。结定也

及释提桓因(至)诸天大众俱者

述曰。下列诸天众。具足应云释提桓因陀罗。因陀罗。此云主提桓此云天。释迦此云能。总名能天主。等者等余。通序下明发起别序有六。一扣机。二指处。三数量。四依报。五正果。六弘化。扣机。即佛告舍利弗。指处。则示在西方。数量。则过十万亿佛土。依报。则极乐世界。正果。即有佛号阿弥陀。弘化。则现在说法

舍利弗彼土何故名极乐者

述云。下明正宗。略二。中五。广十。略二者。一净土因果。二法身因果。中五者。一明极乐弥陀不退之果。二明发愿起行劝修其因。三明六方诸佛现相证成。四明诸佛既证令修奖乐。五明二土世尊现相赞德。广十者。一安乐依报。二者弥陀正果。三发愿往生。四往生之行。五诸佛现相。六释相所由。七三时愿因。八三生行果。九此佛赞彼。十彼佛赞此。今依后判。即为十章。第一明极乐依报有二。一问。二答。此问也

其国众生无有众苦(至)故名极乐者

答也。有二。初标宗略答。后开宗广释。此标宗略答也。彼阿弥陀国。无有众苦。唯有乐事。一生彼土。横截五道。超出三界。至不退转。当初僧祇万劫修行。十住毗婆沙论云。修道有二。一难行。二易行。此土修道名曰难行。西方修道名曰易行。如跛人步行陆路即苦。跛人乘船水路即乐

又舍利弗极乐国土七重栏楯(至)名为极乐者

述曰。下明开宗广释有五。一明宝栏楯林严。二明宝池华光严。三明宝乐神通严。四明宝鸟法音严。五明宝树摇风严。此是第一宝栏楯林严。有六。一宝栏。二宝楯。三宝罗林。六宝树严。栏持内德。楯防外。罗网誓以珠绳无漏法。芝林□西方功德法庄严国界也

又舍利弗极乐国(至)功德庄严者

述曰。第二宝池华光严。有八。一宝池。二宝水。三宝阶。四宝道。五宝楼。六宝阁。七宝华。八宝光严等。池则八解之浴池。水则八德之香水。楼则八定之高楼。阁则三空之重阁。华则七净之觉华。光则智慧之光明。能破疑生之愚闇

又舍利弗常作天乐(至)功德庄严者

述曰。第三宝乐神通严。有三。一明作乐雨华。二明应供诸佛。三明结严成就。天即六时而雨四华。人即十方而供万佛。旭旦则□□彼供养。食时即从彼到此经行

复次舍利弗彼国常有种种之鸟(至)变化所作者

述曰。第四宝众鸟□法音严。有六。一总标瑞鸟。二别指其名。三歌咏法音。四闻念三宝。五破除疑执。六显不思议。种种奇妙杂色鸟者。总标祥瑞异色之鸟也。白鹄孔雀共命之鸟者。别指其名。略叙七鸟之名也。六时演畅根力觉道等法者。歌咏法。佛常六时观六道众生。鸟亦六时歌咏道品也。其土众生闻是音已皆念佛法僧者。明闻者利益也。舍利弗汝勿谓此鸟实是罪报所生至何况有实者。此破遣情疑。初牒疑意。所以下释。彼土尚无三恶之名。况有三恶之义也。是诸至变化所作者。此显不思议。是诸鸟者。乃是弥陀化作令宣法音。庄严国界。利益众生也

舍利弗彼佛国土微风吹动(至)如是庄严者

述曰。第五宝树摇风严。有四。一风摇树响。二如天乐音。三闻念三归。四结严成就。微风吹动诸宝行树者。风摇宝树。即法说妙音也。譬如百千种乐音如天乐音。则譬说妙音也。闻者同时念佛法僧者。明闻念三归。则闻者利益也。成就如是功德者。结严成就也

舍利弗于汝意(至)阿弥陀者

述曰。下明第二弥陀正报□有四。一问。二答。三结。四判位。此问何故名阿弥陀也

舍利弗彼佛光明者

述曰。此答也。答有三。一光明。二寿命。三徒众。此光明无量也

又舍利弗寿命(至)于今十劫者

述云。此明寿命无量。初通。次别。通则其众寿命无量。别则唯论弥陀寿命。寿虽十劫。然世间不可数知。故名无量寿

又舍利弗彼佛有无量无边(至)诸菩萨亦如是者

述云。明徒众。徒众有二。一声闻众。则四向四果。二菩萨众。则五十二贤。俱雨权实之威。齐柄乘之理

舍利弗(至)成就如是功德庄严者

述曰。此略结也。光明寿命菩萨声闻人法虽殊。皆算数所不能及。故名无量。从本为名。故无量寿

又舍利弗极乐国土众生生者(至)阿僧祇劫说者

述云。次明判位。有三意。一彼土即阿鞞跋致。此明因强。二多有补处大士。此明缘胜。三阿僧祇劫说。此明众大

舍利弗众生闻者应当发愿(至)俱会一处者

述云。下明第三发愿往生。初标。次释。情无胜期。半路取证。标心极果。中不牵生

舍利弗不可以少善福德因缘得生彼国者

述云。下明第四往生之行。初标。次释。后结。此标行也。将明久种善根生。故言不少

舍利弗若善男子善女人闻阿弥陀佛名(至)极乐国土生者

述云。释行也。有五。一条机。二名本。三时分。四彼佛此迎。四此生彼。条机。则男子女人。名本。则阿弥陀佛。时分。则七日一心。彼佛此迎。则弥陀圣众垂终迎接。此生生彼。则心不颠倒即得往生也

舍利弗我见此利(至)发不可思议功德者

述云。结也。初结前愿。次结后行。一生彼土。必登不退。横截五道。直超三界。生死之河虽闇不久超度。涅槃之道虽远且亦可登。故云见是利也。舍利弗如我今者赞叹不可思议功德之利者。此结后行。亦是调前起后相证成也

东方亦有阿閦毗佛乃至上方佛所护念经者

述云。第五明六方诸佛现相证诚。六方即四方上下。示证佛处也。诸佛则三世三身恒沙种觉。明证佛人也。现相则舒舌遍满三千。明证相也。证诚则说诚实言者。即证成教也。文有六方则为六重。一一方中。例皆有四。东方四者。一证处则东方。二证人则阿閦毗等恒沙诸佛。三证相舌遍三千。四证教则□当信是经。弟子说经引弟子为证。诸佛说经以□□诸佛为证。故引六方恒沙诸佛舒舌实语。念弥陀一生定得往彼极乐世界至不退转。余五方四门类可知

舍利弗于汝意云何(至)护念经者

述曰。下明第六释相所由。初问。后答。此问也

舍利弗若善男子善女人(至)三菩提者

述云。答也。但闻此经名弥陀及诸佛号。能持不忘者。一切佛护。不退转菩提

是故舍利弗汝等当信受我语及诸佛所说者

述曰。明第七三时愿因。文有二。一敕听信受。二正明三时愿因。此敕听信受也。我语者。释迦劝生净土也。诸佛说者。六方恒沙诸佛劝证往生

舍利弗若有人已发愿(至)三菩提者

述云。正明三时愿也。已发愿者。观音势至龙树之流。今发愿者。现今信受之辈。当发愿者。未来信生之类。欲生阿弥陀佛国者。三时愿所生处也。得不退菩提者。一生彼处。地胜缘强。必阶不退无上菩提也

于彼国土(至)生彼国土者

述云。下明第八三生行果也。已生者。观音势至之流。今生者。现今信受之辈。当生者。未来信受生之类也。既前贤后圣皆愿生彼。见贤思齐。故有信者应当发愿生彼国也。诸佛所以殷勤只劝归西方。定获不退

舍利弗如我今者(至)不思议功德者

述曰。下明第九此佛赞彼。谓释迦如来赞阿弥陀诸佛净土之果

彼诸佛等(至)甚难希有之事

述曰。下次第十明彼佛赞此。释迦秽土道成能为难事。难事即五浊恶世。教化众生。信归净土。定证不退。文有三重。一标。二释。三结。标即甚难希有之事。甚难则三章二释则五浊菩提之事。三结则还结此三义。此则标也。初总。次别。总即明彼佛禅我功德。别则甚难希有之事。甚难则五浊恶世。希有之事则无上菩提之事。即为众说。为众说即秽土修因得净土果。此是难证之法

能于娑婆国土(至)难信之法者

述曰。释三章。五浊者释甚难章门。得菩提者。释希有章门。为众生说者。释之事章门也

舍利弗当知我于(至)是为甚难

述曰。结三章也。五浊得菩提者二门结自利也。为一切世间说者一门结利他也

佛说此经已(至)欢喜信受者

述曰。明流通。两圣对扬。四部蒙益。深心欢喜。信受奉行

阿弥陀经义述(终)


般若波罗蜜多心经略疏

    No. 1712 [cf. No. 251]

般若波罗蜜多心经略疏(并序)

        唐翻经沙门法藏述

夫以。真源素范。冲漠隔于筌罤。妙觉玄猷。奥颐超于言象。虽真俗双泯二谛恒存。空有两亡一味常显。良以。真空未尝不有。即有以辨于空。幻有未始不空。即空以明于有。有空有故不有。空有空故不空。不空之空空而非断。不有之有有而不常。四执既亡百非斯遣。般若玄旨斯之谓欤。若历事备陈。言过二十万颂。若撮其枢要。理尽一十四行。是知诠真之教乍广略而随缘。超言之宗性圆通而俱现。般若心经者。实谓曜昏衢之高炬。济苦海之迅航。拯物导迷莫斯最为。然则般若以神鉴为体。波罗蜜多以到彼岸为功。心显要妙所归。经乃贯穿言教。从法就喻诠旨为目。故言般若波罗蜜多心经

将释此经五门分别。一教兴。二藏摄。三宗趣。四释题。五解文。初教兴者。依大智度论云。如须弥山王。非无因缘非少因缘令得振动。般若教兴亦复如是。具多因缘。一谓欲破外道诸邪见故。二欲回二乘。令入大乘故。三令小菩萨不迷空故。四令悟二谛中道生正见故。五显佛胜德生净信故。六欲令发大菩提心故。七令修菩萨深广行故。八令断一切诸重障故。九令得菩提涅槃果故。十流至后代益众生故。略说此十具收彼意。令此教兴。第二藏摄者。谓三藏之中契经藏摄。二藏之内菩萨藏收。权实教中实教所摄。第三宗趣者。语之所表曰宗。宗之所归曰趣。然先总后别。总以三种般若为宗。一实相。谓所观真性。二观照。谓能观妙慧。三文字。谓诠上之教。不越此三故以为宗。别亦有三。一教义一对。以文字教为宗。余二义为趣。二境智一对。以真空境为宗。观照智为趣。三因果一对。以菩提因行为宗。菩提果德为趣

般若波罗蜜多心经　第四释题者亦有三。初教义分二。谓般若心。是所诠之义。经之一字是能诠之教。即能诠般若之经依义立名。二就所诠义中法喻分二。谓般若等是所诠之法。心之一字是所引之喻。即般若内统要衷之妙义。况人心藏为主为要。统极之本。三就前法中有体用分二。谓般若是体。此云智慧。即神悟玄奥妙证真源也。波罗蜜多是用。此云到彼岸。即由斯妙慧翻生死过尽。至真空之际。即简不到彼岸之慧。故以为名。谓体即用故。法之喻故。义之教故。立斯名耳

观自在菩萨　自下第五解文。此既心经。是以无序及流通也。文中分二。初显了般若。后即说咒曰下。明秘密般若。何以辨此二者。谓显了明说。令生慧解灭烦恼障。以咒秘密言。令诵生福灭罪业障。为灭二障成二严故。说此二分。就前文中亦二。初略标纲要分二。从舍利子色不异空下。明广陈实义分。以义非顿显故先略标。非略能具故次广释。又前是据行略标。后即就解广陈。前中有四。一能观人。二所行行。三观行境。四明能观利益。且初能观人。观自在菩萨者。是能观人也。谓于理事无阂之境。观达自在故立此名。又观机往救自在无阂。故以为名焉。前释就智后释就悲。菩谓菩提。此谓之觉。萨者萨埵。此曰众生。谓此人以智上求菩提。用悲下救众生。从境得名故

行深般若波罗蜜多时　二明所行之行。谓般若妙行有其二种。一浅即人空般若。二深即法空般若。今简浅异深。故云行深般若。言时者。谓此菩萨有时。亦同二乘入人空观。故法华云。应以声闻身得度者。即现声闻身等。今非彼时故云行深时也

照见五蕴皆空　三明观行境。谓达见五蕴自性。皆空即二空理深慧所见也

度一切苦厄　四明利益。谓证见真空苦恼斯尽。当得远离分段变易二种生死。证菩提涅槃究竟乐果。故云度一切苦厄也。上来略标竟

舍利子。色不异空空不异色。色即是空空即是色。受想行识亦复如是　自下第二明广陈实义分。于中有五。一拂外疑。二显法体。三明所离。四辨所得。五结叹胜能。初段文有四释。一正去小乘疑。二兼释菩萨疑。三便显正义。四就观行释。初中言舍利子者。举疑人也。舍利是鸟名。此翻为鹙鹭鸟。以其人母聪悟迅疾如彼鸟眼。因立其名。是彼之子。连母为号故曰鹙子。是则母因鸟名。子连母号。聪慧第一。标为上首。故对之释疑也。彼疑云。我小乘有余位中见蕴无人。亦云法空与此何别。今释云。汝宗蕴中无人名蕴空。非蕴自空。是则蕴异于空。今明诸蕴自性本空。而不同彼。故云色不异空等。又疑云。我小乘中入无余位身智俱尽。亦空无色等与此何别。释云。汝宗即色非空灭色方空。今则不尔。色即是空非色灭空。故不同彼。以二乘疑不出此二。故就释之。二兼释菩萨疑者。依宝性论云。空乱意菩萨有三种疑。一疑空异色。取色外空。今明色不异空。以断彼疑。二疑空灭色。取断灭空。今明色即是空。非色灭空。以断彼疑。三疑空是物。取空为有。今明空即色。不可以空取空。以断彼疑。三疑既尽。真空自显也。三便显正义者。但色空相望有其三义。一相违义。下文云。空中无色等。以空害色故。准此应云色中无空。以色违空故。若以互存必互亡故。二不相阂义。谓以色是幻色必不阂空。以空是真空必不妨幻色若阂于色即是断空。非真空故。若阂于空即是实色。非幻色故。三明相作义。谓若此幻色举体非空。不成幻色。是故由色即空。方得有色故。大品云。若诸法不空。即无道无果等。中论云。以有空义故一切法得成。故真空亦尔。准上应知。是故真空通有四义。一废己成他义。以空即是色故。即色现空隐也。二泯他显己义。以色是空故。即色尽空显也。三自他俱存义。以隐显无二是真空故。谓色不异空为幻色色存也。空不异色名真空空显也。以互不相碍二俱存也。四自他俱泯义。以举体相即全夺两亡绝二边故。色望于空亦有四义。一显他自尽。二自显隐他。三俱存。四俱泯。并准前思之。是则幻色存亡无阂。真空隐显自在。合为一味圆通无寄。是其法也。四就观行释者有三。一观色即空以成止行。观空即色以成观行。空色无二一念顿现。即止观俱行方为究竟。二见色即空。成大智而不住生死。见空即色。成大悲而不住涅槃。以色空境不二悲智念不殊成。无住处行。三智者大师依璎珞经立一心三观义。一从假入空观。谓即是空故。二从空入假观。谓空即是色故。三空假平等观。谓色空无异故

舍利子。是诸法空相　第二显法体。于中有二。先总后别。今初也。言是诸法空相者。谓蕴等非一故云诸法。显此空状故云空相。中边论云。无二有此无是二名空相。言无二者无能取所取。有言。有此无者有能取所取。无是二不二名为空相

不生不灭。不垢不净。不增不减　二别显中有三对六不。然有三释。一就位释。二就法释。三就观行释。初就位释者。一不生不灭。在道前凡位。谓诸凡夫死此生彼。流转长劫。是生灭位。真空离此故云不生不灭也。二不垢不净者。在道中菩萨等位。谓诸菩萨障染未尽净行已修。名垢净位。真空离此故名不垢不净。三不增不减者。在道后佛果位中。生死惑障昔未尽。而今尽是减也。修生万德昔未圜。而今圜是增也。真空离此故云不增不减。又佛性论中。立三种佛性。一道前名自性住佛性。二道中名引出佛性。三道后名至得果佛性。佛性唯一就位分三。今真空无异。亦就位分异。又法界无差别论中。初名染位。次名染净位。后名纯净位。皆同此也。二就法释者。谓此真空虽即色等。然色从缘起。真空不生色。从缘谢。真空不灭。又随流不染。出障非净。又障尽非减。德满不增。此生灭等是有为法相。翻此以显真空之相。故云空相也。三就观行释者。谓于三性立三无性观。一于遍计所执性作无相观。谓彼即空无可生灭。二于依他起性作无生观。谓依他染净从缘无性。三于圜成实性作无性观。谓前二不有而非减。观智照现而不增。又在缠出障性无增减。又妄法无生灭。缘起非染净。真空无增减。以此三无性显彼真空相

是故空中无色无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界乃至无意识界　第三明所离。然真空所离历法多门。统略有四。一法相开合门。二缘起逆顺门。三染净因果门。四境智能所门。初是故空中者。是前不生不灭等。真空中故。无色等者。彼真空中无五蕴等法。此就相违门故云无也。理实皆悉不坏色等。以自性空不待坏故。下并准知。此中五蕴。即合色为一开心为四。二无眼等者。空无十二处。十二处即合心为一半。谓意处全及法处一分。开色为十半。谓五根五境为十处。及法处一分。三无眼界等者。空无十八界。十八界中即色心俱开。准上可知释此三科具如对法等论也

无无明亦无无明尽。乃至无老死。亦无老死尽　二明缘起逆顺门。无无明者。顺观无明流转门。以其性空故云无无明也。亦无无明尽。逆观无明还灭门。以真空故无可尽也。此举初支。中间十支。皆应准此。故云乃至。末后一支。谓老死亦流转还灭皆空也

无苦集灭道　三染净因果门。苦集是世间因果。谓苦是生死报。先举令生厌。集是彼因。谓是烦恼业。厌苦断集先果后因故也。灭道是出世间因果。灭是涅槃果。先举令欣。道是彼因。谓八正道。修之于后。皆空无有也

无智亦无得　四境智能所门。非但空中无前诸法。彼知空智亦不可得。故云无智也。即此所知空理亦不可得。故云无得也。问前云空即是色等。明色等不亡。何以此文一切皆无。岂非此空是灭色耶。答前虽不阂存而未尝不尽。今此都亡未尝不立。故大品云。诸法无所有。如是有此无。此就无所有。前据如是有。又前就相作门。此就相害门。一法二义随说无违

以无所得故　第四明其所得有二。初牒前起后。二正明所得。今初也。言以无所得故者。牒前起后也。以者由也。故者因也。由前无所得为因。令后有所得也。大品云无所得故而得

菩提萨埵依般若波罗蜜多故　二正明所得有二。先明菩萨得涅槃断果。后明诸佛得菩提智果。前中亦二。先举人依法。后断障得果。今初也。言菩提萨埵者举人也。义如前解。依般若波罗蜜多故者。明依此法行也。故者起后也

心无挂阂　二断障得果中有三。初行成。二断障。三得果。今初也。言心无挂阂者行成也。谓惑不阂心故。境不阂智故

无挂阂故无有恐怖。远离颠倒梦想　二断障也。言无挂阂故牒前起后也。无有恐怖者。外无魔冤之怖。即恶缘息也。远离颠倒梦想者。内无惑障之倒。即恶因尽也

究竟涅槃　三得果也。涅槃此云圜寂。谓德无不备称圜。障无不尽称寂。简异小乘化城权立。今则一得永常故云究竟。又释智能究竟尽涅槃之际。故云究竟

三世诸佛依般若波罗蜜多故　第二得菩提智果。于中有二。初举人依法。二明得果。今初也。谓三世诸佛更无异路。唯此一门。故云依般若波罗蜜多故也

得阿耨多罗三藐三菩提　二正明得果也。阿耨多罗此云无上也。三藐者此云正也。次三者此云等也。菩提此云觉也。即无上正等觉也。觉有二义。一正觉。即如理智。正观真谛。二等觉。即如量智。遍观俗谛。皆至极无边。故云无上也。上来所得竟

故知。般若波罗蜜多是大神咒。是大明咒。是无上咒。是无等等咒　第五结叹胜能。于中有二。先别叹。后总结。今初也。言故知者牃前起后也。由佛菩萨依般若。得菩提涅槃果。故知。般若是大神咒等。叹其胜能。略叹四德。然有三释。一就法释。一除障不虚名为神咒。二智鉴无昧名为明咒。三更无加过名无上咒。四独绝无伦名无等等咒。二约功能释。一能破烦恼。二能破无明。三令因行满。四令果德圜。三就位释。一过凡。二越小。三超因。四齐果。谓无等之位互相济等。故云无等等。十地论云无等者。谓佛比余众生彼非等故。重言等者此彼法身等故。何故不但说无等耶。示现等正觉故

能除一切苦真实不虚　二总结胜能。谓三苦八苦一切苦也。又分段变易。亦云一切苦也。除苦决定故云真实不虚也。上来广略不同。总明显了般若竟

故说般若波罗蜜多咒即说咒曰　自下第二段明秘密般若。于中有二。初牒前起后。二正说咒词。今初也。前云是大神咒。未显咒词故今说之

羯谛羯谛波罗羯谛波罗僧羯谛菩提萨婆诃

二正说咒词。此有二义。一不可释。以是诸佛秘语非因位所解。但当诵持除障增福。亦不须强释也。二若欲强释者。羯谛者。此云去也度也。即深慧功能。重言羯谛者。自度度他也。波罗羯谛者。波罗此云彼岸。即度所到处也。波罗僧羯谛者。僧者总也溥也。即谓自他溥度总到彼岸也。言菩提者。至何等彼岸。谓大菩提处也。言萨婆诃者。此云速疾令前所作速疾成就故也

略释绝笔述怀颂曰　般若深邃　累劫难逢　随分赞释　冀会真宗

般若波罗蜜多心经略疏　法藏。长安二年于京清禅寺。翻经之暇。属同礼部兼检校雍州长史荥阳郑公。清简成性忠孝自心。金柯玉叶之芳葩。九刊三王之重寄。羽仪朝序城堑法门。始自青衿迄于白首。持此心经数千万遍。心游妙义口诵灵文。再三殷勤令出略疏。辄以蠡管讵测高深云尔

    般若心经赞序

        张说撰

万法起心。心人之主。三乘归一。一法之宗。知心无所得是真得。见一无不通是玄通。如来说五蕴皆空。人本空也。如来说诸法空相。法亦空也。知法照空见空舍法。二者知见复非空耶。是故定与慧俱空中法。入此门者为明门。行此路者为超路。非夫行深般若者。其孰能证于此乎。秘书少监驸马都尉荥阳郑万钧。深艺之士也。学有传癖书成草圣。乃挥洒手翰镌刻心经。树圣善之宝坊。启未来之华业。佛以无依相而说。法本不义。以无所得而传。今则无灭。道存文字。意齐天壤。国老张说。闻而嘉焉。赞扬佛事。题之乐石

般若心经略疏


般若波罗蜜多心经幽赞

    No. 1710 [cf. No. 251]

般若波罗蜜多心经幽赞卷上

        大乘　基撰

赞曰。今为有情结习所蔽。敬受邪教诽毁大乘。于空有经如言计着随印所解互生厌希。设希出要亲依善友由各迷方邪乱授学。惧广文海初不趣求。虽乐略经而不能了。于真俗谛竞说有无心境法中递生取舍。令正法义真谬具分。信学有情皆获利乐。依先所授略赞中道。如解深密经中佛依遍计所执。说一切法皆无自性无生无灭。本来涅槃相生胜义三无性已。时胜义生菩萨白佛言。世尊佛初唯为趣声闻者转四谛轮。虽甚希奇然未了义。是诸诤论安足处所。次复唯为趣大乘者转隐密轮。说一切法皆无自性无生无灭本来涅槃。虽更希奇犹未了义。亦诸诤论安足处所。今为发趣一切乘者转显了轮。无上无容是胜义中真了义教。非诸诤论安足处所。金光明经说此三法名转照持。轮摧破名。具遮表故。由诸有情迷法实相起造惑业沦生死海。大圣法王证法自性善巧方便。应彼机宜离言法中以言显说。欲令随获中道实相。故有颂言

  诸佛或说我　　或时说无我
  诸法实相中　　无我无非我

余经复说。佛以一音演无边义。众生随类各得解等。既犹天鼓应念发声。亦类末尼如求雨宝。应物虽设种种法门。智见纯和未生乖竞。佛涅槃后因彼大天人法纠纷初封著有。如有颂曰

  应审观佛教　　圣谛说为依
  如采沙中金　　择取其真实

圣龙猛等为除有执采集真教究畅空宗。如别颂曰

  真性有为空　　如幻缘生故
  无为无有实　　不起似空华

彼言。世俗可说法有。依胜义谛一切皆空。虽此真空性非空有。寄诠胜义理皆性空。有情由是次生空见。无著菩萨复请慈尊说中道教。双除二执。而说颂言

  虚妄分别有　　于此二都无
  此中唯有空　　于彼亦有此
  故说一切法　　非空非不空
  有无及有故　　是则契中道

彼言。世俗说我法有依胜义谛唯此二空。虽佛为破执空执有总相宣说诸法有空。或说诸法非空非有。名字性离空有双非。胜义寄诠有空有有。故慈尊说。有为无为名之为有。我及我所称之为无。非说有空法皆空有。观斯圣意空有无乖。法离智诠何空何有。对机遣病假说有空。后诸学徒随文起执。己之所解谓契中宗。他之所知将为谬说。今赞经义申其两端。妙理是非智者当了。般若波罗蜜多者大经之通名。心经者此经之别称。般若之心经也。三磨娑释依士为名。苏漫多声属主为目。虽此心经亦名般若。彼总此别故但名心。般若慧义。古释有三。一实相谓真理。二观照谓真慧。三文字谓真教。今释有五。第四眷属谓万行。第五境界谓诸法。福智俱修有空齐照。寻诠会旨究理解生。慧性慧资皆名般若。能除障习证法真理。众德之首万行之导。虽独名慧摄一切法。波罗者彼岸义。古说有二。谓菩提涅槃。今释有五。一所知。二教。三理。四行。五果。蜜多者离义到义。由行般若离诸障染。境尽有无解穷六藏。义洞真俗业备二因。觉满寂圆斯升彼岸。体用兼举故立此名。然所修行具七最胜。方可得名波罗蜜多。一住菩萨种姓。二依大菩提心。三悲愍有情。四具行事业。五无相智所摄。六回向菩提。七不为二障间杂。若行慧等一切善业。随阙此一非到彼岸。此在初劫名波罗蜜多。在第二劫名近波罗蜜多。在第三劫名大波罗蜜多。佛果位中更无异称。今包因果故举通名。心者坚实妙最之称。大经随机义文俱广。受持传习或生怯退。传法圣者录其坚实妙最之旨别出此经。三分二序故皆遗阙。甄综精微纂提纲迹。事虽万像统即色而为空。道纵千门贯无智而兼得。探广文之秘旨标贞心以为称。经者津妙理之格言。掖迷生之恒范。欲令随证或依或说般若贞实而说此经。故以心目。如瑜伽论水陆华等十地等经

经曰。观自在菩萨

赞曰。胜空者言今此经中略有二分。初观自在等破二执显二空。后菩提萨埵等叹二依得二利。大经云。佛告舍利子。菩萨摩诃萨行般若波罗蜜多时。应如是观。实有菩萨不见有菩萨。不见菩萨名。菩萨自性空菩萨名空。故今标菩萨令彼不见。故破生执而说生空。如应者言。今此经中总有三分。初观自在等标上人修行劝示发心。次舍利子等陈机感者名述理垂喻。后菩提萨埵等彰依学之德叹获胜利。或初令练磨。次断除四处。后离苦圆证。练磨有三。今标菩萨先修行人劝示发心。初练磨也。谓闻菩提广大深远。若生退屈应练磨心。彼观自在昔初发意。具诸烦恼于无明壳建立胜心。舍身命财求佛智慧。兴大勇猛已成等觉。我亦应尔励己增修。不应自轻而生退屈。观者察义。府救慧悲。自在者无滞义。拔济妙用。诸有殷净三业归依。必应所祈六通垂化。无暇危苦飞轮摧伏。作不请友为应病医。摄利难思名观自在。又观者照义。了空有慧。自在者纵任义。所得胜果。昔行六度今得果圆。慧观为先成十自在。一寿自在。能延促命。二心自在。生死无染。三财自在。能随乐现。由施所得。四业自在。唯作善事及劝他为。五生自在。随欲能往。由戒所得。六胜解自在。能随欲变。由忍所得。七愿自在。随观所乐成。由精进所得。八神力自在。起最胜通。由定所得。九智自在随言音慧。十法自在。于契经等。由慧所得。位阶补处道成等觉。无幽不烛名观自在。但言观音词义俱失。菩提萨埵略言菩萨。菩提即般若萨埵谓方便。此二于有情能作一切利益安乐。又菩提者觉义。智所求果。萨埵者有情义。悲所度生。依弘誓语故名菩萨。又萨埵者勇猛义。求大菩提精勤勇猛故名菩萨。又修行者名为萨埵。求三菩提之有情者故名菩萨。有具悲智遍行慈愍。绍隆净刹府救秽方。机感相应故唯标此。或处上位诸具大心妙慧成就皆观自在。或指示此令瞩曰观。非住西方来游此者。彼大经中不别显故

经曰。行深般若波罗蜜多时

赞曰。胜空者言下破法执而说法空。大经次言。不见般若波罗蜜多。不见般若波罗蜜多名。般若自性空。般若名空故。如应者言。显由学慧方照性空。示先所修法。第二练磨心也。谓见菩萨万行难行。若生退屈应练磨心。我无始来为求世乐尚能备受无义众苦。况求菩提。为出生死度有情类生怯劣心。此深般若彼已修学。我亦应尔省己增修不应退屈。彼舍利子先发大心因施眼故退求小果。恐今更退劝示练磨。所言行者。胜空者言。若依世俗。欲证出世无分别智无倒观空。要学能遣一切所缘闻思慧等。学照空者即名为行。若依胜义。由无所得无分别故都无所行是名为行。无垢称说。不行是菩提无忆念故。大经亦言。不见行不见不行无自性故。今言行者。都无所行是名为行。非有行义。或有密取余义释言。若无所行无所不行是则为行。若有所行有所不行非为行也。复有异释。动念攀缘为生死根非为行也。惩心绝虑为出世本是名为行。如应者言。譬如幻士而有所作。虽无实作非无似者。待因缘闻信学证说曾无暂舍。然无分别不见行相是谓行义。非都无行。以病说除非除法故。若本无法可行可除。即愚法者称已成觉。说有迷悟深自毁伤。翳花体空可不资疗。翳既非有如何假除。翳既不除初无真眼。由何胜义照花体空。若无所行无所不行。有情无明无所不明。应从无始一切皆明。其先未明今明谁也。便同异道无所不为。背理乖宗何成觉慧。若绝攀虑即是真行。应无想等皆真圣道。徒设受持厌舍造修。可谛思惟疾除邪谬。今言行者。虽行而不见行。非无行义。由此经说不见行不见不行。假有所行实无行故。不尔唯应说不见行。复言不见不行有何诠理。是故定应如后所说。然佛果德殊胜无边。非广大修无由证得。故依此义而说行者。要具大乘二种种姓。能于五位渐次修行。二种姓者。一本性住种姓。谓住本识能生无漏本性功能。二习所成种姓。谓闻正法等熏习所起。云何应知有本性住种姓依之修习大菩提因。若性乐施好赞劝他。无罪事中应时为说。他债不狂受寄无差。大财宝中心无耽着。若性成就软品恶业不极损他。作恶速悔常行慈爱。知恩报恩。凡所规求不以非法。乐修福业轻罪重怖。见闻受苦过于自身。善事好同恶法乐远。于诸僮仆尝无苦言。于德有德恒生赞仰。若被他害无反报心。他来谏谢速能纳受终不结恨不久怀怨。若性翘勤夙兴晚寐。凡事勇决乐为究竟。大义无畏不自轻蔑。若于法义性审思惟。好乐寂静爱慕出离。所作无忘于怨慈愍。若性总慧凡学易成。离恶事中有力思择。性不能起上烦恼缠造无间业断善根等。设生恶趣便能速出亦不受于猛利大苦。虽受微苦发增上厌于苦有情深生悲愍。若见有此施等粗相缠盖轻微粗重薄[苟*苟]。应知定有菩提本性。然由未遇真实善友为说菩提。虽遇为说颠倒执学方便慢缓善根未熟故处生死。若入五位所修无边胜善法种名习所得。五位者何。一资粮位。从初发起大菩提心。乃至始修四寻思观住四十心皆此位摄。一信等十心。一信二精进．三念．四慧．五定．六施亦名不退．七戒．八护．九愿．十回向。二十住。一发心．二治地．三修行．四生贵．五方便．六正心．七不退．八童真．九法王子．十灌顶。三十行。一欢喜．二饶益．三无恚．四无尽．五离痴．六善现．七无著．八尊重．九善法．十真实。四十回向。一救护众生．二不怀．三等一切佛．四至一切处．五无尽功德藏．六随顺平等善根．七随顺等观一切众生．八如相．九无缚无著．十法界无量。二加行位。从资粮后四种等持。一明得定。二明增定。三印顺定。四无间定。三通达位。从四定后初地初心真相见道。四修习位。从见道后至金刚定十地修道。十地者。一极喜。二离垢。三发光。四焰慧。五极难胜。六现前。七远行。八不动。九善慧。十法云。五究竟位。金刚定后解脱道中三种佛身。四妙圆寂。圆满佛果。虽知五位云何修行。诸修行者欲证菩提作大利乐。要先发起大菩提心方兴正行譬如大海初有一滴能为诸宝作所住处。最初发心亦复如是。五乘善法皆因此生。又如世界初始渐起即为荷负诸众生因。此心亦尔。能为五趣无量种类荷负依止。又如空界无不含容。大菩提心亦复如是。遍空有为皆厌离故。如空菩提皆求证故。尽空众生皆深念故。此初发心虽为下劣一念福聚尚说难尽。况经多劫发心修行利乐功德。因何发心。一者见闻佛等神力。二者闻说菩萨藏教。三者见闻佛法将灭。念言法住能灭大苦。四者末劫多见众生痴无惭愧悭嫉忧苦恶行放逸懈怠不信。念言浊世多起如是恶烦恼时。我当发心令余学我起菩提愿。由此便发大菩提心。将欲发心先具十胜德起三妙观。十胜德者。亲近善友。供养诸佛。修集善根。志求胜法。心常柔和。遭苦能忍。慈悲淳厚。深心平等。信乐大乘。求佛智慧。三妙观者。一厌离有为。谓观生死恶趣无暇等众苦逼迫。自身之中五蕴四大能生恶业。九孔常流臭秽不净。三十六物之所集起。无量烦恼烧煮身心。如沫如泡念念迁流。痴覆造业六趣轮回。谛审思惟深心厌舍。二求菩提。谓观佛果相好庄严。法身本净。具戒等蕴力无畏等无量胜法。成二妙智慈愍众生。开导愚迷令行正路。诸有情类遇皆除恼。见是功德修集希求。三念众生。谓观众生痴爱所惑受大剧苦。不信因果造恶业因。厌舍正法信受邪道。四流所流七漏所漏。虽畏众苦还为恶业。而常自作忧悲苦恼。爱别离苦见已还爱。怨憎会苦觉已弥怨。为欲起业生苦无厌。求乐犯戒。怀忧纵逸作无间业。顽蔽无惭谤毁大乘痴执生慢。虽怀聪敏具断善根。妄自贡高常无改悔。生八无暇匮法无修。虽闻不持翻习邪业。得世妙果谓证涅槃。受彼乐终还生恶趣。见是等辈深心悲愍。次应发心如是发愿。愿我决定当证无上正等菩提。能作有情一切义利。或随意乐诸佛之名如释迦佛初发希愿。如有颂言

  于三无数劫　　逆次逢胜观
  然灯宝髻佛　　初释迦牟尼

无著菩萨由此说言

  清净增上力　　坚固心胜进
  名菩萨初修　　无数三大劫

先起信精进念定慧根除伏障染。次发大愿常逢善友以为胜缘。虽遇恶友方便俎坏终不弃舍大菩提心。所修善法运运增长以不退屈而为策发。齐是名为最初修行。依如上说初发心已即名趣入无上菩提。预在大乘诸菩萨数于生死海作出限量。勇猛定当速登彼岸。次应修行。此有二种。一略。二广。略复有三。一境。二行。三所得果。犹昔不知真妄境界。起烦恼等因受众苦。今正翻彼故亦有三。由此最初应审观境。既知善恶修断行成。因行既圆果德便证。诸佛圣教虽复无边。说修行门不过三种。故修行者应依此学。云何名为所观境界。谓初观察从缘所生一切色心诸心所等似空花相诳惑愚夫名依他起。愚夫不了于斯妄执为我为法喻实空花性相都无名计所执。依他起上我法本空。由观此空所显真理譬若虚空名圆成实。诸所知法不越有无无法体无。但可总说名计所执。横遍计心之所执故。有法体有理应分别。诸有为法名依他起。缘生事故。一切无为名圆成实。法本理故。或有漏法名依他起。性颠倒故。诸无漏法名圆成实。非颠倒故。知境界已应修正行。一因闻所成。二因思所成。三因修所成。此三虽通福慧二种一切功德。然行根本甚深纲要。胜义易入应时无等。离诸过者遍观详审唯识为最。渐悟顿悟小乘大乘无不依说此深理。故华严经说

  心如工画师　　画种种五阴
  一切世间中　　无法而不造
  如心佛亦尔　　如佛众生然
  心佛及众生　　此三无差别
  诸佛悉了知　　一切从心转
  若能如是解　　是人见真佛
  身亦非是心　　心亦非是身
  起一切作用　　自在未曾有
  若人欲求知　　三世一切佛
  应当如是观　　心造诸如来

智度论说。菩萨复作是念。三界所有皆心所作。以随心所念皆悉得见。以心见佛以心作佛。心即是佛心即我身。心不自知亦不自见。若取心相悉皆无智。心亦虚妄。皆从无明出。因是心相即入诸法实相。故唯识观最为第一。识者心也。由心集起彩画为主。独立唯名摄所余法。唯言为遮所执我法离心而有。识言为表因缘法性皆不离心。显法离心决定非有名为唯识。非谓一切唯一识心更无余物。善友恶友诸果诸因理事真俗皆不无故。计所执性唯虚妄识。依他起性唯世俗识。圆成实性唯胜义识。是故诸法皆不离心。如有颂言

  鬼傍生人天　　各随其所应
  等事心异故　　许义非真实
  于过去事等　　梦像二影中
  虽所缘非实　　而境相成就

此等处处说唯有心。恐厌文繁故略应止。今详圣教所说唯识。虽无量种不过五重。一遣虚存实。观遍计所执唯虚妄起都无体用。应正遣除。观依他圆成诸法体实二智境界。应存为有。如有颂言

  名事互为客　　其性应寻思
  于二亦当推　　唯量及唯假
  实智观无义　　唯有分别三
  彼无故此无　　是则入三性

遣者空观对破有执。存者有观对遣空执。今观空有而遣有空。有空若无亦无空有。以彼空有相待观成纯有纯空谁之空有。故欲证入离言法性。皆须依此方便而入。非谓空有皆即决定。证真观位非有非空。法无分别。难思议故。说要观空方证真者。谓即观彼遍计所执我法空故入于真性。真体非空。此唯识言既遮所执。若执实有诸识可唯。既是所执亦应除遣。诸处所言一切唯识．二谛．三性．三无性．三解脱门．三无生忍．四悉檀．四嗢拖南．四寻思．四如实智．五忍观等。皆此观摄。二舍滥留纯。虽观事理皆不离识然。此内识有境有心。心起必托境界生故。但识言唯不言唯境。识唯内有境亦通外。恐滥外故但言唯识。又诸愚夫迷执于境。起烦恼业生死沉沦。不解观心勤求出离。哀愍彼故说唯识言。令自观心解脱生死。非谓内境如外都无。由境有滥舍不称唯。心体既纯留说唯识。故契经说。心意识所缘皆非离自性。故我说一切唯有识无余。余经复说三界唯心。制一处等皆此观摄。三摄末归本。心内所取境界显然。内能取心作用亦尔。此之二法俱依识有。离识体本末法必无。三十颂言

  由假说我法　　有种种相转
  彼依识所变　　此能变唯三

成唯识说变。谓识体转似二分。相见俱依自证起故。解深密说。诸识所缘唯识所现。摄相见末归识本故。所说理事真俗观等多皆此观四隐劣显胜。心及心所俱能变现。但说唯心非唯心所。心王体胜。所劣依王。隐劣不彰唯显胜法。故慈氏说

  许心似二现　　如是似贪等
  或似于信等　　无别染善法

无垢称言随心垢净等。皆此观摄。五遣相证性。识言所表具有理事。事为相用遣而不取。理为性体应求作证。故有颂言

  于绳起蛇觉　　见绳了义无
  证见彼分时　　知如蛇智乱

余经说。心自性清净。诸法贤圣皆即真如。依他相识根本性故。又说。一谛．一乘．一依．佛性．法身．如来藏．空．真如．无相．不生不灭．不二法门．无诸分别．离言观等。皆此观摄。如是所说空有．境心．用体．所王．事理五种从粗至细展转相推唯识妙理。总摄一切。以闻思修所成妙慧而为观体。明了简择。非生得善。若欲界观唯有闻思。色界观中通闻修慧。无色界观但修无余。无漏观修。义通前二。此诸唯识从初发意四十心中。听闻思惟但深信解。随所遇境。依教思量令彼观心渐渐增胜。未能修位观二取空。虽少入修犹非正胜。于加行位四等持中起四寻思。审观所取若名若义自性差别假有实无。起如实智于能取识遍知非有故。圣慈尊教授颂言

  菩萨于定位　　观影唯是心
  义想既灭除　　审观唯自想
  如是住内心　　知所取非有
  次能取亦无　　后触无所得

此位菩萨虽得修观。犹带相故未能证实。通达位中无分别智于所缘境都无所得。理智既冥心境玄会。有空之相时不现前唯识真理方名证得。故本颂言

  若时于所缘　　智都无所得
  尔时住唯识　　离二取相故

证真识已起后得智方证俗识。厚严经言

  非不见真如　　而能了诸行
  皆如幻事等　　虽有而非真

至此位中名达法界。住极喜地生如来家。自知不久成无上觉。于修习位修有差别。初四地中真俗唯识各各别证。于第五地方少合观。然极用功未常任运。至第七地观真俗识虽得长时而有加行。八地已上无勉励修。任运空中起有胜行。至究竟位虽更不修念念具能缘真俗识。所修有二。一现行。二种子。于初二位有漏三慧皆通二修。种修无漏。通达位中无漏修慧。通现种修。有漏唯种。在修习位七地已前有漏无漏皆具三慧。通现种修。八地已上有漏唯种。无漏三慧。通现种修。于究竟位有漏皆舍。虽唯无漏然具现种。所言修者。令观种现展转增胜生长圆满。有自在者下亦修上。未自在者不能上修。此唯识修总摄诸行。诸行皆依唯识修故。此略修行果相云何。有漏修者能感世间一切妙果。无漏修者永灭诸障得大菩提。穷尽未来广生饶益。此说别得。若互相资容得一切。说略修已。云何广修。此亦有三。一所学处。二修学法。三能修学。最初应知所学之处。次应依彼如是而学。然后方成能修学者。故三皆是菩萨行摄。初所学处略有五种。一所化处。谓应了知三乘不定阿颠底迦种姓差别。如应成熟。二利行处。若纯自利如为已乐求财受用。为悭法故追访受持。为生天乐持戒修行。求有染果供养三宝。为贪利誉自说己德令他脱难还自摄受。耽定味等舍利有情。若纯利他如以邪见修行施等。以无因见缺行说法。此等纯利皆应除断。无罪二利应善勤修。三真实义处。谓于如所有性。尽所有性。世间所成。道理所成。二障净智所行真实等。随应修断。四威力处。谓神通威力。六到彼岸能断悭等。乃至与当来果善法威力。为利有情堪忍大苦。四生信委八相现化。逆胎盲等遇皆饶益等俱生威力。法界有情处时法器普能了知。神通化境遍无边界等共不共威力。知此五力应正勤修成自佛法。五菩提处。谓智断等一切功德。应遍了达希当果证。如是五处最先应达所化机宜。方应发起利他胜行。次知实义可断可修。于威力门修成自利。后于果位无上菩提爱乐希求精勤修证。知学处已次应修学。修学法者。初于三宝功德。佛菩萨威力。诸真实义。无倒因果。应得义利。得此方便。善言善说契经等中。净信胜解决定喜乐。次应求法。当于一切佛法内论因论声论医论工论。应正勤求。应云何求。于佛正法应住猛利爱重求闻。设为听闻一句善法。路犹铁地尚欢喜入。何况欲闻多善言义。虽爱自身及诸资什。比爱正法非为譬喻。无足无倦深信柔和。心直见直爱德爱法。往法师所无诘难心。唯作妙宝．慧眼．智明．胜果．无罪．悦意之想。深生敬重无高慢心。不作坏戒．卑族．丑陋．拙文．鄙句．异意之想。唯为求善非显己德。不为名利而求正法。应时殷重恭敬听闻。勿起损害顺求过心。于其自身亦不轻蔑。唯为求解。专精属耳扫涤摄持。何义故求。于内明处为自修习利悟于他。于因明处为伏邪论安立正道。于声明处为令信乐典语众生深生敬等。于医方明处为息众病安乐众生。于工业明处为以少力多集珍财广生饶益。要于此五次第勤求。无障智生资粮速满。次应为他宣说正法。说五明处随应利乐。云何而说。谓应安住如法威仪。不为无病处高坐等而说正法。诸佛菩萨敬重法故。令他于法极珍敬故。应无间说。勿作师拳。随众所欣次第标释无悭吝想名随顺说。于有怨者应住慈心。于行恶者住利益心。于有乐放逸有苦下劣者。应住利益哀愍之心。不起嫉妒自赞毁他。不希名利恭敬赞叹而为说法。次应修行。于佛所制有罪三业善能远离。所闻事业无倒修行。独居闲静思所闻法。无间殷重观察称量。未知求知。已知勿忘。未达推佛不生诽谤。恐无慧目直心强信。善知密意异说无动。于离言境专注系心。离诸戏论无扰乱想。修奢摩他毗钵舍那。次应教授。应观于彼心根意乐。随宜为说处中之行。令其舍弃增上慢等。次应教诫。应遮有罪开许无罪。诸现行事暂行犯者如法谏诲。若有数犯。起无染异亲善意乐呵摈令忆。下犯权时。上犯永摈。勿令犯者多摄非福。能正行者慈爱称叹。谦冲晓喻令喜增修。次安三业。先以财物饶益有情。令听所说奉教行故。于有痴者当行爱语。令其摄受瞻察正理。拔出不善劝安善处。于正事业应共修行。令所化生无他说故。次修波罗蜜多。施即舍位无贪三业。凡行布施。若唯令乐不作善利。或非利乐俱不应与。若唯善利而非安乐。或俱利乐皆应施与。若希财物恣彼所须。规诸断心应随自在。若求刀等为自他害。非己财物。媒媾他人。食等有虫。无义乐具。杀害物法。邪作天祀。水陆众生损杀处所。怨希仇隙。病冀非宜。馋嗜数求。愁忧规损。抑夺卑物。乐恶求位。夺施施他。卒暴损余。自违学处。怨亲等所生分别心。许胜与劣。许多与少。或怀异意。生愤浊心。施已称杨说恩。向彼撩掷所舍。邪厌恶求。妄兴邪施。执为善净。他之所引。怖自贫穷。余残及秽与出家者。曾不告白窃施非法。不合仪物持以惠舍。数求还往亲附摄属。依世名誉。求报恩果。规余敬叹。意劣限量。初少诳与后便倾败。乖离属己。自怠策他。不依来者次第均给。心不悦净。后生悔恼。求真与假。先未运心。不应其时乖仪散乱。蚩笑轻弄令生愧赧见。来嚬默研求不与。外道觅过求佛正法。炫卖秘藏业未成法。此等有过皆不应为。与上相违一切应作。财宝若乏应思来者。一是安乐非贫苦类。二是危苦无依怙等。揆己财足俱应遂愿。少应善遣安乐来求。知有怀悭或先贫乏。寄之树福。方便导利言。无损费仍为饶益。我有珍财随汝取施。慎勿令彼求者空还。我若施时。汝应随喜令怀悦意施种渐生。见来求相知乐应与。若有矫诈欺诳乞求。掩过勿伤称满其愿。令无羞愧欢喜而往。有初欺诳后始觉知。勿举勿诃但生悲愍。彼误于我起此愆违。我怀喜心令彼无罪。若无财宝随己所能。如法经求令施无阙。于佛正法巧妙宣扬。令诸有情随应习施。见常惠舍应教数求策施者心。勿令鲜阙恶供朋党不敬忘念。知余有法应求转施。或书写与。若见余无更写无力。当应思审我非悭所蔽别碍胜须耶。若有悭碍即应施与。由施痴哑尚应无吝。况令阙乏妙智资粮。若无悭碍但为胜须。思施彼时为灭烦恼。为念生类。为满智因。观无烦恼。见若不施增智资粮。当丰巧慧。亦为爱念此及余生。若施彼时便唯念此。如是不施非违净戒。善设轨仪晓喻发遣。若畜财宝。为作净故心应奉施诸佛菩萨。虽畜宝财犹住圣种。恒思此福令常增长。如佛菩萨所寄护持。若观施时不称正理。应言贤首此是他物不许施汝。慰喻发遣。或持余财恭敬倍施。令知施者非悭故然。知此经等或非己物。于有怨苦德恩有情。应行慈悲喜舍而施。若有四障不能惠舍。应起四智而对除之。一有财宝心不乐施。应思由先曾未串习。今不强舍后更增背。故力励修生觉悟智。二财鲜阙心不乐施。思此匮乏障施因缘。应起悲心。自受贫苦。见施利益生忍苦智。三财悦意心不乐施。思此耽着虚妄颠倒。应觉能生当来众苦。故力励舍生知倒智。四虽行施唯欣世果。当疾通达是邪果见。应观诸行皆不坚牢离散速尽。不生欣乐唯求菩提生不坚智。应居闲静起淳厚信。数数缘念多妙财宝。以意解力施诸众生。故少用功生无量福。于所宝爱能自开舍。设艰辛得亦勿悭吝。信心恭敬自手应时不损自他。而行惠舍。此有三种。与净妙物广修财施。拔除恐怖修无畏施。劝修善业而行法施。速疾而与不作稽留。非彼疾望如速舍者。随有即施非积方舍。于彼谦下无竞无慢。戒即受学净戒三业。凡修净戒。正受净意犯已还净敬念无犯。正受有犯。观他起愧。净意有犯自顾生惭。故能护戒。还净敬念。由前二故离诸恶作。初二后一能不毁戒。犯已还净能还速出。即妙无量饶益大果胜利净戒。在家出家俱修三种。一律仪戒。谓即七众所受律仪。住出家者舍轮王位如弃秽草。不希天欲。况余财位。尚厌胜果。况卑贱事。勤更修余。非戒为足。离恶言念。设起速悔。渐为拘捡正理言念。闻难行事心不惊怯恕己勤修。不伺他非常察己过。见诸凶暴悲心摄受。害触无恚勿行呵摈。有过悔除誓更勿犯。少欲喜足堪忍众苦。不掉不躁威仪寂静。离矫诳等诸邪命法。二摄善法戒。谓受戒后为大菩提所集善法。依戒独处起闻思修。尊所敬事病所慈愍。说施善哉。德施赞叹。于善随喜。诸善回向发愿供养。精勤护戒。饮食知量密护根门。初后夜中常生觉寤。亲依善友勿顾身财。于恶法中皆不忍受。善知因果乃至舍障。便能渐次住十度中。三饶益有情戒。于诸有情无倒事业皆为助伴。病者供侍。盲者启导聋者撝义。哑者晓像。迷示遇途。疲施安息。缺支者惠以荷乘。愚骇者诲以胜慧除彼缠等。解他胜蔑劝断悭恶。教获珍财令信圣教尽结离苦。守恩思报见赞善来。欢慰吐诚谈谑设座。随答名利等增非劣。怖者救护。忧者开解。恒备资财随求即与。初为依御后方济给。若自匮乏巡觅与之。有众同用自无隐费。数数应行教授教诫。除无利行余随他转。非诃违犯终不恼他。亦不轻诮令生愧赧。不彰他屈。不自贡高。不极亲近。非不亲近。亦不非时亲近于彼。不毁他爱不赞他憎。非情交者不吐实诚。不屡希求不乖先诺。是名无量大功德藏。若诸菩萨先于菩提发弘愿已欲勤修学。于能开授如法请受。时彼菩萨令求受者生殷重心专念长养。为正开授。若无授者。于佛像前如法自受。此后数思菩萨应作。非所应作听闻解释契经本母。若虽聪慧广说乃至谤菩萨藏不应从受。不信谤毁亦勿开示。如住净戒具大功德。彼诽谤者亦成大罪。言见未舍终不免离。非唯他劝及为胜他。自慧思择起坚固受。有四他胜处法。一为名利恭敬自赞毁他。二从求财法悭吝不与。三害恼归谢不舍怨结。四谤菩萨藏乐宣像法自信随他。犯此不堪增长净意摄大资粮。相似菩萨非真菩萨。略由二缘舍此净戒。一舍无上菩提大愿。二上品缠犯他胜处。下中缠犯不舍净戒。数犯四种都无惭愧。乐犯为德名上缠犯。非一暂行即名为舍。若无二缘。虽转余生净戒不舍。余生忘失虽数更受觉寤戒念。非新受得。住此戒者于佛法僧及安造处。应日日中随应供养。下礼一拜。少赞四句。极生一信随念实德。无令空度恭敬策勤。勿生大欲厌舍名利。敬侍耆德依理酬对。赴如法请。受无染施。舍无染法。于性遮罪应等护持。若为利他随应现起。应住正命。三业寂静。毁厌生死欲欣涅槃。恶声称誉自护清雪。陈谢侵犯不酬嗔弄。无染管御。时量倚眠离爱谈谑。卑下求法断除五盖。不毁二乘。善究菩萨藏方学声闻藏。精闲佛法方习外论。上聪敏者于日日中二分学内一分学外。犹如辛味而习近之。法可信爱方以利乐。闻如理法励意往听。巧依文义敬叹法师。乃至现通能正引摄。如是一切若心狂乱重苦所逼。未受净戒及住十地皆无违犯。与上相违当知有犯。若上缠犯。或三或多解诸乘者如法悔灭。悔已更受。下中缠犯对一发露。现前若无可对灭者。净意自誓更勿重犯。由此于犯还出还净。依此修习得三满业。一行满。由无缺犯三业清净。二意满。为法出家求大菩提。乃至不为当来异熟。三因满。昔行妙业今得胜果复能修善。岂非安乐。与此相违衰损危苦。为持净戒舍大财位。乃至命终无少缺犯。恒不放逸亦不误犯。由此生生常获五利。一为十方诸佛护念。二舍命时住大欢喜。三持戒者常为亲友。四功德藏成就圆满。五生常得戒戒成其性。为住其心成就佛法利有情故专精勿犯。忍即于境所有无嗔精进审慧。此有三种。一耐怨害忍。谓遇他害应作是思。此我先业。今若不忍更作苦因。便非爱己成自缚害。又自他身性皆行苦。彼无知故增害我身。我既有知宁增彼苦。声闻自利尚不苦他。我既利他应忍他害。作此思已应修五想。一念彼于我无始长时或为亲属或为我友。应舍怨害住亲善想。二念托众缘唯行。唯法都无有我。谁为怨害。应舍有情住唯法想。三念彼生长自性无常。我极报怨不过断命。谁有智者于彼身命生死法中而欲更杀。尚不应起染浊之心。况复加害。应舍常坚住无常想。四念衰盛者皆为三苦恒所随逐。我今于彼应设方便令永舍离。何容更苦。应断有乐住有苦想。五念求菩提本为生类。应与义利摄受为亲。何容今者返加怨害。应舍于他住摄受想。自无愤勃不报他怨。亦不随眠流注相续。故于怨害皆能忍受。二安受苦忍。若逄事苦应作是思。我从无始愚痴过失。为求诸欲尚受众苦。况求菩提成大事业。纵经百千俱胝大苦亦应忍受。况小苦哉。若于一切四事什物鲜弊稽侮不生忧恼。世法衰毁乃至病死。住四威仪。为摄受法。正毁形貌。着坏色衣。自兢摄。行乞求。弃非法财。绝淫欲乐。修善。利益。如法。勤劬。皆能忍受。精进匪懈求大菩提离异染心勿生退转。三谛察法忍。于三宝等串习净智善安胜解故。于羸劣卑贱有情。自居尊贵臣隶等所。怨亲中等皆能忍受。众前屏处昼夜往来。乃至疾卧三业修习。于有损恼由忍故离。于有所求由忍故与。恒作饶益先后无异。非一益已舍而不益。怨所速谢。怨谢速受。勿令于己生疲极心。不堪忍所起上惭愧。审观由忍现世安乐。能除不善引安乐因临终不悔。后生善趣无怨无仇。证无上觉。亦见不忍所有苦果。自作教他赞励庆慰。精进即是修善品时勇悍三业。此略有三。一加行精进。谓修善前心生勇悍先擐誓甲。我今为脱一有情苦。以千大劫等一日夜或复过此百千倍数。常处地狱方证菩提。我之勇悍亦无退屈。何况所经时短苦薄。于此能起少分信解尚长无量大菩提因。何况成就。故修善位无少怯劣。二摄善精进。谓此能引能满众行。一切分别烦恼异论苦触不动。殷重乃至离慢而行。世尊恒时称赞精进。故能满善疾证菩提。三饶益有情精进。谓即前说利乐有情种种策励。如是远离身资什想。尽众同分无间无废。平等通达功德相应。不缓不急无倒修习。能令染法不生断灭。亦令白法新生广大。三业净三慧增。无舍无退无下无倒勤勇而行。有势有勤有勇坚猛不舍善轭。猛利乐欲等修无倦。如灭头燃疾断烦恼。法随法行。护己利他静虑即是闻思为先心一境性。此有三种。一现法乐住静虑。谓离分别惛掉爱相。能生轻安寂静等持。二引发神通静虑。谓能引住神通等持。三饶益有情静虑。谓为利乐所有等持。由依静虑能成咒术息灾厄。除众病致甘雨拔怖畏。施财位与饮食。谏诲放逸造应作事。神通记说教诫变现。乃至放光息除众苦。亦能永断一切重障。慧即于境如理简择此有三种。一于所知随觉真慧。谓于无我真胜义中平等明觉。二于五明三聚妙慧。谓摄受此能速圆满智资粮觉。三作有情诸义利慧。谓助伴等俱行妙觉。学内明处净慧为依。示现愚痴教导放逸赞励怯弱庆慰勤修。次修四摄事。一者布施。如上已讫。二者爱语。常说悦意谛实如法引义之语。远离嚬蹙含笑。先言命进问安。随宜慰喻。见有昌盛而不自知觉善法增而申庆悦。说佛法教恒为胜益。于己怨仇起清净意。于极痴者誓除疑惑。于真福田谄诳恶行。都无嫌恨修难行爱语。欲除障盖为说先作。心调善者为说谛法。多放逸者诲令出离。有疑惑者谈说决择。依四净语起八圣语。三者利行。由爱语故先示正理。随所觉处悲无染心劝导调伏安处建立。能令获得现利财位后利出家俱利离欲轻安解脱。习近恶友未植善根。着大财位深极放逸。外道僻执邪见诽谤。常起八缠十恶业者。于此一切皆能开解起大悲心。虽受大苦心无劳倦倍生欢喜。虽处财位最胜第一。而自卑屈如仆如奴如旃荼罗如孝子等。无染无伪真实哀怜。慈愍之心永不退转。四者同事。以此义利若劝他学亦自修学。教他知已所修同事。善根坚固不生退转。令作是念。此所教我定有利乐。彼自行故。不尔便言。汝自不善。何能教我。汝且于他咨受此事。次供养三宝。一于对现前佛设利罗及制多等所亲面供养。二于余三世十方佛制多等作佛等想修不现前供养。三现对前时复作是念。一佛制多等法性即三世十方诸佛制多等法性。故我今者现前供养一佛制多等。即是供养三世十方佛制多等。修现前不现前供养。若佛灭后造一或多佛制多等而为供养。当获无量大福德果。受大梵福无数大劫不堕恶趣。亦满无上菩提资粮。四于如是所唯自供养。五若起悲心以随力物施贫苦等。愿彼安乐令他供养。六或俱供养。七以花香等敬问礼拜。乃至以珍宝等修财敬供养。八即以财敬长时多妙乃至净心回向菩提修广大供养。九不以轻慢矫诈放逸不净物等。修无染供养。自力集财从他求得。发愿想化为百千身恭敬礼拜。一一化身出百千手持散花香。出百千声歌赞实德。复出百千妙庄严具而为供养。于赡部洲乃至十方所有供养普生随喜。虽少用功而兴无边广大供养。应起善心真欢喜心精勤修学。十若有须臾修四无量。乃至少时信忍离言真如法性。起无分别住无相心。即为守护菩萨净戒乃至修行四摄事等。修正行供养应念。此为最上胜妙。过前供养百千万倍不可比喻。修供养时应念。如来是大福田具大恩德。有情中尊极难遇。独出众义依止。于法于僧供养思念随应亦尔。当获大果。说不能尽。次应亲近善友。戒无穿缺．多闻．修证．哀愍．无畏．堪忍．无倦．言词辨了．名善友相。求施利乐．于此正知．有力善权．饶益不舍．大悲无傥．名为善友所作不虚威仪圆满．言行敦肃．无矫．无嫉．俭畜随舍．是名善友可为依信。谏举．令忆．教授．教诫．能为说法．是名善友于所化生为善友事。有病无病爱敬供侍。翘问迎礼修和敬业。四事什物不阙应时诣敬承事问听无动。名为亲近。次修无量。法界有情总为三类。一无苦无乐。二有苦。三有乐。于此三类慈悲喜舍。于其十方初有情类欲求乐者。作有情解无倒与乐。名有情缘慈。作唯法想假说有情。名法缘慈。复于诸法离分别想。名无缘慈。于有苦者欲拔苦故修有情缘悲。于有乐者助彼喜故修有情缘喜。于无苦无乐者起离痴想。于有苦者起离嗔想。于有乐者起离贪想。平等欲令离诸惑故名有情缘舍。余并同前。三无量中。初共外道。次共二乘。后唯菩萨。初三安乐。后一利益。次修惭愧。若有应作而不随之。随不应作。于[雨/復]己恶。己可悔事随逐不舍。应顾内身羞耻非法遵崇贤圣宝重善法修起于惭。外顾世轨羞耻恶名轻侮凶顽拒惮恶法修起于愧。次修坚力。禁制染心勿随惑转。虽遭大苦修行无苦。怖畏无动勇猛思择坚持自性。次观世间命浊有情浊烦恼浊见浊及以劫浊厌离怜愍。见器成坏修无常想。观自内身六界集起假立名性。而不坚执。年德耆尊迎敬问礼。如父母想。二俱相似讯慰谈论。如兄弟想。俱卑劣者慈爱劝修。如男女想。处尊见卑终不戾[怡-台+發]。纵怀资给摄受随顺。若识不识有病无病贵贱贫富。一切等心为友为朋。无怨无隙。设有违犯终不斥讳。勿令须臾住不安乐。离十四垢藏隐六方。远四恶朋摄四善友。分财平等。他物不规。审观财宝称直买卖。彼若不解无枉豪厘。次修四依。唯求于义不依饰文。起敬爱故。唯依于法不依说者。心住理故。唯依了义经不依不了义经。无疑虑故。唯依于智不依于识。证决定故。以要言之。四无碍解乃至四妙总持三十二相业乃至一切种妙智。皆是菩萨正所应学。以身语意普为有情于一切时欢喜无变。不损恼他。唯见功德真实寂静。心善决定不悕异熟等。修一切种皆令现行。不净观等乃至三十七种菩提分法。菩萨虽与二乘别修而不作证。皆如经说。次应修愿。总发一种摄一切愿。谓摄受正法。复有三愿。一于生生得正法智。二无厌心为众生说。三舍身命财护持正法。复有四愿。一未离苦者速离。二未得乐者疾得。三未发心断恶修善者发心断恶修善。四未成佛者早得成佛。复有五愿。一者发心最初愿得无上菩提。二者受生愿。愿生善趣随顺饶益。三者所行愿。愿正思择修诸善业。四者正愿。愿摄一切菩萨功德若总若别所有正愿。五者大愿。此有十种。愿当获得上妙供具供养诸佛。愿护正法传持不断。愿如诸佛八相现化。愿行一切菩萨正行。愿普成熟一切有情。愿诸世界皆能示现。愿能净修一切佛土。愿诸菩萨同趣大乘。愿所修行皆不虚弃。愿当速证无上菩提。欲令所修果广大故修一一行皆发此愿。如上所说一切愿行四十心中通所修法。位别修者。初发心住学十种法。供养佛．赞菩萨．护众生心．亲近贤明．赞不退法．修佛功德．愿生佛前．修习三昧．赞离生死．为苦归依。亦修十力。如是余位各有二十别所修法。广如经说。然此位中多修散行。少亦修定未以制伏。将入加行位。前方便中先修三三摩地。诸法有二。谓有非有。有为无为名之为有。我及我所名为非有。于妄生死依他有为可厌逆故。修无愿三摩地。于真涅槃圆成无为正愿乐故。修无相三摩地。于我我所遍计所执非有事中无愿无无愿故。修空三摩地。此若但言空无愿相。通有无漏三慧定散。言三摩地。通有无漏。唯修非散。言解脱门。唯是无漏。亦修非散。此位所修准义应悉。次修四种法嗢拖南。欲令有情清净故说。一观诸行皆是无常。有生灭故。二观无常皆悉是苦。具逼迫故。三观涅槃性相寂静。离苦缚故。四观诸法皆都无我。无主宰故。修方便已。次于加行暖顶二位修四寻思。忍世第一法修四如实智。即修空相修自利已。通修五无量起利他善巧。为饶益故初观六十四种有情。依处受化次观十方世界差别。有情在彼染净可得次观善等诸法类异。即此有情有堪任势力修解脱苦者次观五十五种所调伏差别。要由善巧令得解脱次观随应调伏方便。于加行位修二利。已于初地中以无漏观证达理事。名真相见。无少散修。如略行中已略解相。从此位后于十地中修十胜行断十重障证十真如。十胜行者。谓前施等六到彼岸。又加方便愿力智度。一切妙行皆此十摄。方便善巧有十二种。悲心顾恋。了知诸行。欣佛妙智。乐处生死。轮回不染。炽然精进。此六为内。令以少善感无量果。令以少力摄大善根。憎圣教者除其恚恼。处中住者令其趣入。已趣入者令其成熟。已成熟者令得解脱。此六为外。如是十二总束为二。一回向。二拔济。愿有五种。此总为二。一求菩提。二行利乐。力有十种。总摄为二。一思择。二修习智。证诸法安立净智。此亦有二。一受用法乐。二成熟有情。于前所说施等诸行。十地所修过前增胜。谓总求身及支节等以无染心而随彼欲。若求为过。宁以百千身命布施终不遂彼。施意若净。现利众生有乞身支。魔等兴恼。痴狂心乱。皆不应与。若愍食吐等活命众生。应数吐食等而行布施。一切有恩未喻亲属。虽已晓喻求者凶残害等。妻孥将为仆隶。皆不应施。与上相违应行惠舍。宁犯性罪自堕地狱。终不令他逆业成就。审起思惟心非不善。深生惭愧怜愍杀之。暴恶宰官方便黜废。劫守盗财夺废随还。无属继心求非梵行。方便随许令种善根。出家菩萨皆不应尔。为拔他难起虚诳语。令离恶朋说离间语。遮越正略出粗恶语。引摄机宜行杂秽语。由此便生无量功德。或现神通示诸恶趣怖之令见永离不善。若无信等问事不答。示相现通令怖信等。行楚利行令得利益。若遭苦迫能无异想证谛察忍。勇悍无倦。能住殊胜甚难思度十力种姓所有等持。命终不舍还生欲界。能起胜义平等遍满将正已觉。由此能知诸法无我。调伏方便。境界无碍。于摄事中或有隐己功德威力是他同事而不显现。或化怖畏生狗等中非他同事而自显现。所作善根犹可摇动为令坚住实现同事。若行放逸二种俱非。于供养中由于佛等得平等故具足珍宝。或以神通化为无量珍宝众具。乃至礼拜持散赞扬十方三宝真行供养。修无量中得有情平等。证俗真故作证修习。即悲无量亦名大悲。缘微细苦。长时修习。猛利发起。极清净故。修此心时即修一切菩萨悲心。悲意乐净。故于诸有情获极亲厚爱念恩德无厌代受有堪能心。声闻已得菩提究竟。深远厌心不如菩萨悲前行心。由此熏修无少内外而不能舍。乃至妙慧无不能入。菩萨菩提由悲建立。故于生死堪忍众苦。又于十地各有别修。谓初布施乃至第十神通作业。此等随应皆十行摄。唯说十度不增减者。颂曰

  障富贵善趣　　不舍诸有情
  于失德减增　　令趣入解脱
  障施等诸善　　无尽亦无间
  所作善决定　　受用法成熟

十种障者。随修十度十地所断俱生无明。又有十障。谓异生性乃至诸法未自在障。十真如者。一遍行。由此能得自他平等。二最胜。由此遍修同出离行。三胜流。由此求法不顾身命。四无摄受。由此乃至法爱亦皆转灭。五类无别。由此得十意乐平等净心。六无染净。由此能知缘起无染无净。七种种无别。由此知法无相不行契经等种种法相中。八相土自在所依。由此圆满证无生法忍不见染净一法增减。九智自在所依。由此圆满证无碍解。十业自在所依。随欲化为利乐事故。一切菩萨应以四相修前诸行。一者善修。皆悉决定委悉恒常无罪修作。二者善巧。令获义利修莹律仪所受当满应机说法。三者饶益。能以利乐别总随与。四者回向。三门积集去来今世所有善根一切摄取以淳一味妙净信心回求菩提不悕余果。应以七相怜愍有情。非怖畏彼．如理劝授．无厌倦心．不待他请．无所悕望．遭害不舍．平等无限．如是一切名所学法。三世菩萨勤修此等。曾当现证无上菩提更无增减。诸出家者离摄亲属。弃世业务。能行梵行。舍证圆满。住净戒中出言减信。诸在家者无是众德。诚大尊高真胜殊胜

般若波罗蜜多心经幽赞卷上般若波罗蜜多心经幽赞卷下

        大乘　基撰

知所学法如是修已。何相名成能修学者。种行具修成十二住。总摄一切菩萨皆尽。此后方得无上菩提第十三住成圆满果。颂曰

  种姓胜解行　　极喜增上戒
  增上心三慧　　无相有功用
  无相无功用　　及以无碍解
  最上菩萨住　　最极如来住

一种姓住。犹未发趣无上菩提。于余住中唯有因转。相如前说。二胜解行住。从初发心乃至初地。由前修相于自住中虽已得净为得净故而修正行。起分别慧励意修作。成苦迟通行勉励说法。随力亦能现正觉等利益安乐。于前诸行或未普学。诸相未成。意乐未净。三极欢喜住。即是初地。如前白品并十大愿皆现圆满。由此转名净胜意乐。超过异生地证正性离生。生如来家成佛真子。绍隆佛种得诸平等。离诸诤害获实证净。知于菩提我已邻近。证二空理成二妙智。生大欢喜行十法净修住。谓信．慈悲．惠舍．无倦．知诸论．解世间．修惭愧．坚力持．供养诸佛。于九住法专精求趣。多为轮王王此洲界。调伏悭垢。乃至愿我恒处最尊为有情依作诸义利。或乐精进净信出家。瞬息须臾证百三摩地。以净天眼于诸佛国见百如来。变化住持皆能解了。神力能动百佛世界。身亦能往放大光明普令他见。化为百类利百有情。若欲留身得百劫住。见前后际各百劫事。证百法门。化为百身。身皆能现百菩萨眷属。四增上戒住。即第二地。由前住中十意乐住净得入此住。性戒具足。少邪业道诸恶犯戒亦不现行。况中上品。能善了知业道因果。自及劝他行诸净业。于有情苦得大哀愍如实观照。广见诸佛善根清净。多为轮王王四天下。止息犯戒。一切威力过前十倍。五增上心住。即第三地。由前作意解了通达。复由十净心得入此住。能通达诸行有情大菩提。亦正推求脱苦方便诸烦恼缠无障碍智。净法界中无分别慧。辨此智见胜三摩地。于菩萨藏精进多闻。不惜身命舍诸所爱。无有师长不誓承事。教誓皆行。身誓受苦。但闻一颂胜得大千充满妙宝。闻佛一句法能引正等觉净菩萨行。胜得释梵护世等果。设有告言。我有一句法能引正等觉净菩萨行。汝若能投大火坑者。当为汝说。菩萨欢喜踊跃言能。正使火坑等三千界。为闻法故我从梵天尚能投入。况小火坑。为求佛法尚应久处大地狱中。况余小苦。闻已便能法随法行。能引住世间静虑等至等。复还弃舍随愿受生。多作释天帝化他令断欲贪。威力过前百千之数。六觉分相应增上慧住。即第四地。由前求多闻成十法明得入此住。得十成熟智。修菩提分法能断萨迦耶见等一切执着。离诃毁业修赞美业。心转调柔功德隆盛。安住寻求修治地业。圆满意乐胜解界性。圣教怨敌不能倾动。多作苏夜摩天王化除萨迦耶见。威力过前俱胝之数。七诸谛相应增上慧住。即第五地。由前十平等清净意乐得入此住。以十方便观察诸谛。正毁诸行悲愍有情。摄受资粮勤修正愿念慧行等。皆得增长离异作意。以诸方便成熟有情。一切工巧皆能引发。多作珊都使多天王化舍一切内外邪法。八缘起相应增上慧住。即第六地。由前十种法平等性得入此住。觉悟缘起生解脱门。一切邪想皆不能动。为益有情摄受生死。智．悲．随逐无所著智．般若波罗蜜多住现前。证得无量胜三摩地。意乐不坏余不能夺。多作妙化天王化除一切增上慢等。威力过前百千俱胝之数。九有功用无相住。即第七地。由前十种妙方便慧所引世间进道胜行得入此住。达佛境界无间缺修。一一刹那证十度等菩提分法。有加行行一切圆满极。净住前导犹名有染工巧智满超二乘三摩地境。念念能入灭尽定能现菩萨甚希奇业。多作他化自在天王能授二乘现观方便。威力过前俱胝百千之数。十无功用无相住。即第八地。由前十种入一切法第一义智得入此住。以前所修四如实智。今得清净成无生忍。断四灾患爱甚深住。蒙诸如来觉悟劝导授与无量引发门智神通事业。悟入无量分身妙智得十自在。随受胜利。多作初静虑天王。创入此住第一刹那。所有福智一切威力。过前诸住所得一倍。第二刹那过前二倍。至十地满运运增长。说不能尽。十一无碍解住。即第九地。由前于甚深住不生喜足。复于智殊胜性爱乐随入。起智加行宣说诸法。说法所作皆如实知。成大法师具无碍解。多作第二静虑天王。十二最上成满菩萨住。即第十地。前无碍解遍清净已堪为法王受法灌顶。得离垢等无量等持作佛所作。得一切佛相称法座身诸眷属。得大光明证利有情佛事妙智逮得无量解脱陀罗尼门神通大念等无数功德。多作过色究竟大自在天王。菩萨道满资粮周备。从佛大云堪领广大微妙法雨。自如大云同现等觉。普雨法雨殄息尘埃。令善稼穑生长成熟。此一一住所断所修所证功德非余住无。依各圆满故别建立。胜解行住趣无相修。所作狭小有缺不定。次后六住获无相修。所作广大无缺决定。后之四住圆证清净领受修果。所作无量。胜解行住信等第六心。信生不退不断善根。十住第七心居位不退不作二乘。至极喜住所证不退永无忘失。至无功用无相住修行不退。任运进修皆求种智广行利乐。故留诸惑助愿受生。由此不说断烦恼相。生有五种。一除灾生。由愿自在为大鱼等济诸饥乏。为大医药救诸疾病。为大善巧善和诤斗。为大国王如法息苦。为大天神断邪见行。为火为水为乘为船为种种物息除灾患。二随类生。愿自在力于傍生等恶类中生彼所行恶而自不行。彼不行善而自行之。如入酒肆能立其志。入诸淫舍示欲之过。为说正法除彼过失。三大势生。禀性生时寿量形色族姓贵富最为殊胜。能除众生轻慢等过。四增上生。受十王果自在化导随所应生。五最后生。此生资粮已极圆满。如慈氏等生婆罗门大国师家。如释迦等生刹帝利大国王家。能现等觉作诸佛事。复以四相摄受有情。一者顿普。初发心位普顿摄受一切有情。皆为眷属随力饶益。二者增上。若为家主。劝识恩惠孝养父母。妻子等所随时愍给。仆隶等所终不逼切而能堪忍。病等瞻疗爱语慰喻犹如自身。不生贱想。若为国王。不行刀杖以法理化财利饶益。依本土田而自食用不行侵掠。视诸众生如父如子。所言诚谛不行欺诈。劝舍诸恶教修诸善。三者摄取。平等无傥不希名利秉事。徒众等无染摄受于自义利。正教修习。非邪加行而陷逗之。四者随时。诸有情类下中上品。长短少时方堪净故随应成熟而行摄受。此十三住七地所摄。一种姓地。二胜解行地。三净胜意乐地。此之三地即初三住。四行正行地。即次六住。五决定地。即第十住。堕在第三决定中故。六决定行地。即第十一住。七倒究竟地。即第十二第十三住。因果二中皆究竟故。此前所说诸菩萨行。虽有无量不过四种。一波罗蜜多行。则六十度。二菩提分行。三十七品四寻思等一切妙行。三神通行。即六神通。四成熟有情行。即所调伏界调伏方便界无量。如上所说若所学处．若所学法．若能修学．皆菩萨行。勇猛炽然依前修学不见行相。是名为行。此所行法云何名深。胜空者言。妙理玄邈不可思议。二乘不能晓。凡夫所不测。故名为深。如应者言。真谛智境超言议道。非喻所喻微妙难知。备三无上具七大性。体业利乐一切殊胜。白法溟海妙宝泉池。非大菩提为法界主无由相称。故所修学皆名为深。应勤趣证。或此一切诸菩萨行真如实相难可圆证。智慧观照难可获得。诠教文字难可悟说。万行眷属难可成就。有空境界难可通达。以慧为首余性或资皆名般若。故并名深。云何名时。胜空者言。若依世俗。信学修证求照达空。若依胜义。悟法体空修行般若。事绪究竟总名为时。如应者言。无上菩提广大深远。非少积因可能证获。于前所说十二住中。若日夜等时分算数。一一住中经多俱胝百千大劫。或过是数方证方满。若以大劫超过一切算数之量。总经于三无数大劫方得证满。经初无数大劫于一行中修一行。故证极喜住。经第二无数大劫于一行中修一切行。证无功用无相住。以意乐净决定勇猛。后经第三无数大劫一切行中修一切行。证如来住。此常精进非不尔者。若上勇猛如翘足等。或有能转众多中劫或多大劫。决定无转无数大劫。故知因位决定经三无数大劫修行圆满方证菩提。五种彼岸皆能到故。此意即说修五般若三劫分位。或随自心变作分限事绪究竟总立时名。若达空时唯正智证。既修学位通摄所余。独觉利根尚经百劫。况求作佛无多劫因

经曰。照见五蕴等皆空

赞曰。此显由行甚深般若得正慧眼。达空名照。谓色受等诸有为法。皆有三世．内外．粗细．劣胜．近远。积聚名蕴。此五。谓色．受．想．行．识。等言等取处等诸法。胜空者言。前破能观执显能观空。今破所观执显所观空。若痴所蔽迷胜义理。于蕴等中妄执为有。如处梦者见境现前。若正了知胜义谛理。不生执着。如梦觉位了境非有。故行般若便照性空。如应者言。虽修一切皆行般若。证真遣妄由慧照空。故此偏说。此中空言即三无性。谓计所执本体非有相无自性。所以称空。诸依他起。色如聚沫。受喻浮泡。想同阳焰。行类芭蕉。识犹幻事。无如所执自然生性。故亦名空。圆成实性因观所执空无方证。或无如彼所执真性。故真胜义亦名为空。据实三性非空非不空。对破有执总密说空。非后二性都无名空。说一切空是佛密意。于有及无总说空故。如世尊说

  相生胜义无自性　　如是我皆已显示
  若不知佛此密意　　失坏正道不能往

又此空者即真如理。性非空有因空所显。遮执为有故假名空。愚夫不知执五蕴等定离真有。起相分别。今推归本体即真如。事离于理无别性故。由此经言。一切有情皆如来藏。一切法等皆即真如。说有相事则无相空。令诸有情断诸相缚。眼类有五。一肉眼。非定所生大造净色。二天眼。因定所起大造净色。三慧眼。照理空智。四法眼。达教有慧。五佛眼。前四觉满总得佛名。今在因位慧眼达空明了瞩观。故名照见。然此空性资粮位中听闻思惟。多唯信解。在加行位方纯修观。虽皆名照犹带相故而未证真。住十地中起无漏观。通达真理方实照空。至如来位照见圆满。知离言境假名为空。虽此空言通空我法。逗舍利子唯说法空。我执久亡不假空故。或复我执依法执生。但观法空我随空故。此所说空虽体无异。而依事显亦有差别。如大经中或说十六。谓内空．外空．内外空．大空．空空．胜义空．有为空．无为空．毕竟空．无际空．无散空．本性空．相空．一切法空．无性空．无性自性空或说十七。加无所得空。或说十八。又加自性空。或说十九。别加所缘增上及互无空。或说二十。于十八中离无散空为散空．无变异空。离相空为自相空．共相空。释初颂曰

  能食及所食　　此依身所住
  能见此如理　　所求二谛空
  为常益有情　　为不舍生死
  为善无穷尽　　故观此为空
  为种姓清净　　为得诸相好
  为净诸佛法　　故菩萨观空
  补特伽罗法　　实性俱非有
  此无性有性　　故别立二空

经曰。度一切苦厄

赞曰。胜空者言。此上略说破二执显二空能度众苦。既照性空离诸分别。如蛾出[雨/虫]永离缠裹。便度苦厄疾证涅槃。虽依胜义无度无得。随世俗中有度有得。如应者言。由照性空能越生死显先修益。第三练磨心也。谓观转依深妙难证。若生退屈应练磨心。世间有情行粗施等。于命终位尚招胜果。况我今修无障妙善。当来不证度苦转依。如彼行慧已度苦厄。舍粗重依得无粗重。我亦应尔。励已增修不应自轻而生退屈。度者越也脱也。苦谓三界有情及处。即业烦恼所生所起。理实有漏无非是苦。此略有三。诸有漏法性堕迁流逼迫不安。皆名行苦。世间诸乐必归坏尽缘合缠忧。俱名坏苦。性已逼迫更增楚切。难忍重生皆名苦苦。此苦即厄灾难义故。苦或八苦。住胎出胎俱受逼迫。众苦根本名生苦。时分朽坏名老苦。大种衰变名病苦。寿命衰没名死苦。不爱现前名怨憎会苦。所爱乖离名爱别离苦。所希不遂名求不得苦。诸有漏行名略摄一切五取蕴苦。厄谓八难及诸危怖小三灾等。由未照空。境相拘缚心起分别。发烦恼业五趣苦生。既见三种无性为空。或照蕴等即真如空。分别不生。恶果随灭。故诸苦厄皆能越度。如有颂言

  相缚缚众生　　亦由粗重缚
  善双修止观　　方乃俱解脱

据实照空亦度惑业。体宽现果唯说度苦。即此空相资粮位中闻思等照。初十心位第六心后信心不退。不断善根便永伏度极重苦厄。故经颂言

  若有成世间　　增上品正见
  虽经历千生　　终不堕恶道

至十住中第四住后粗无明等皆始不行。方能伏度恶趣苦厄。生贵住说除灭烦恼永尽无余。舍离生死能出三界。缘起经说。外道异生诸行。皆以四愚为缘。内法异生若放逸者福不动行。三愚为缘。不放逸者所有诸行。我不说以无明为缘。故知此后伏离恶趣一切苦厄。第七住后更不退位伏离二乘所应苦厄。至通达位初证真空后能永度三恶趣八处无暇贫疾等种一切苦厄。或有亦能永离三界分段苦厄怖烦恼故。有八地后方离此厄。七地已前留烦恼故。第十地终照空圆满。一切有漏种子永除。变易死等苦厄皆尽。至如来位利乐众生。或时示现非实如是。此观自在犹未成佛由照空故当必皆除。劝示发心言度一切

经曰。舍利子

赞曰。胜空者言。生由法立。法即生因。此广生空。法空后显。如应者言。下陈机感者名。述理垂喻。示彼胜行除四处也。义段有三。初舍利子等。总告彰空。次是故等。别结所空。后以无所得故。释成空理。梵云舍利。唐曰春鹙。由母辨才指喻为号。显彼所生故复称子。母因能论子假为名。树正摧邪少闻多解。昔杨知见最初悟入。今演性空呼而垂喻。唯说胜教以统法显是理皆空。独告上人以摄机即时众咸告。彼虽秉告而未悟空。先劝练磨方除四处

经曰。色不异空空不异色色即是空空即是色

赞曰。谓四大种及此所造。即十色处及法处色。性皆变现总立色名。胜空者言。下广法空。大经说言。所以者何。色自性空。不由空故色空非色。色不离空。空不离色。色即是空。空即是色。此破二种执。色不异空空不异色者。破执世俗所取色外别有真空。不悟真空执着诸色妄增惑业轮转生死。今显由翳所见花色目病故然。非异空有故。依胜义色不异空如圣教说。因缘生法我说空故。色即是空空即是色者。破愚夫执要色无位方始有空。于色于空种种分别。今显依胜义色本性空。迷悟位殊义彰空色。如何色灭方乃见空。如翳见花自性非有。岂要花灭彼始成空。故于色空勿生封执。应除倒见究竟涅槃。由此二句经作是言。色自性空非色灭空。如应者言。若依胜义诸法皆空都无有者。初虽可尔理未必然。真俗相形俗无真灭。色空相待色灭空亡。故非本来色体空也。胜空者言。据实此空非空不空。翻迷对色悟说色空。非此空言即定为空。空亦空故。如应者言。若因缘色自本都无。应诸愚夫先来智者。是则凡圣互是圣凡。自处师资实为谁迷。胜空者言。烦恼成觉分。生死即涅槃。尘劳之俦为如来种。诸众生等本来寂灭。岂非愚夫先即智者。如应者言。若许色事有异空理。可舍色迷而求空悟。既空本色。智即为愚。求智舍愚岂非颠倒。且厌生死求趣涅槃。苦乐不殊。求之何用。愚夫生死已得涅槃。圣者更求极成邪妄。胜空者言。俗事迷悟求圣去凡。真理色空何成取舍。如应者言。若许事别亦说即空。俱胜义中自成矛楯。应未悟者知色即空。其已悟者不悟空色。精勤圣者可愍可伤。懈怠愚夫可欣可乐。如世尊言。云何菩萨随顺会通方便善巧波罗蜜多。若诸有情于佛所说空性经典。谓一切法皆无自性皆无有事无生无灭皆如幻梦。于是等法不能解了。菩萨为彼如理会通。应告彼言。此经不说一切诸法都无所有。但说诸法所言自性都无所有。故说诸法皆无自性。虽有一切所言说事依止彼故诸言说转。然彼所说可说自性。据胜义谛非其自性。故说诸法皆无所有。彼一切法所言自性理既从本都无所有。当何所生当何所灭。故说诸法无生无灭。又如幻梦非如显现如实是有。亦非一切幻梦形质都无所有。如是诸法非如愚夫言说串习势力所现如实是有。亦非一切诸法胜义离言自性都无所有。由此悟入一切诸法非有非无。犹如幻梦其性无二。故说诸法皆如幻梦。如是菩萨普于一切诸法法界。不取少分不舍少分。不作损减不作增益。无所失坏。若法实有知为实有。若法实无知为实无。如是开示是名菩萨随顺会通方便善巧。此经意说。一切愚夫如言所执实有可说诸法自性。如实幻梦皆无自性。都无有事无生无灭。非无圣智真俗谛境离言法性。非如幻梦形质亦体都无名无性等。达所执无名悟非有。达圣境有名悟非无。故言菩萨不取少分不舍少分无知为无有知为有。若依胜义法体都空无少有者。作此会通便非善巧。称悟非无不舍少分。亦徒施设乃为损减失坏正理。由此故知。此经意破先执色有故说色空。空者无也。非法性空。愚夫所执当情色相本性非有。若执非空及色灭无方成空体。既成二倒。故应双遣显色事理非如所执。勿起妄情生颠倒见。妄情既断所执色亡。故断依他遣计所执。如翳既灭不见空花。二乘外道执实作用因缘生法性都非有。故圣说言。因缘生法我说皆空。非谓依他如幻之色亦皆空也。故有颂言

  虚妄分别性　　由此义得成
  非实有全无　　许灭解脱故

圣教又说。诸法不自生亦不从他生。亦不从共生非不从二生。虽无所执作用因缘。而有功能缘可得故。此若无者应无俗谛。俗谛无故真谛亦无。依谁由谁而得解脱。或此空者即法性空。若执遍计所执诸色及依他色定异真有。真俗定别极成迷乱。今显二色性即空如无相无为非诠智境。应舍二执求趣真空。故摄归空双除妄见。法性之色体即真相。不异即空。此复何惑。圣说二谛各有浅深。彼互相形皆有真俗。有俗俗俗。有俗俗真。有真真真。有真真俗。即俗真俗。真亦俗真。有俗有真俗无真灭。既非无色而独有空。亦非色空定不异即。故真空与色非异非不异。非即非不即。今遮定异等唯说不异即。此不异即言亦非不异即。辩中边说

  无二有无故　　非有亦非无
  非异亦非一　　是说为空相

今说色空互相显者。令义增明破疑执故。前说观自在教练磨心。今说色空等令除四处。一者二乘作意狭劣欣厌不乐利他。二者于大乘中颠倒推求及起疑惑。三者于闻思等言我能然种种法执。四者现前安立骨琐色等乃至菩提执着分别。今说色等不异即空。令舍二乘劣作意等得无分别出世行成

经曰。受想行识等亦复如是

赞曰。恐彼疑执唯色不异空。唯色体即空余法不尔故。以受等亦例同色。能领纳境起苦乐舍名受。能取于境有相．无相．小．大．无量．无少所有分齐名想。思造善恶无记分位及余心所等迁流名行。心意识三皆能了别并通名识。谓四识住及能住识。如色而领。如领而知。如知而作。如作而了。故色受等如是次第。然由世执我事有五。谓我身具．我受用．我言说．我造作．我自体。今显是蕴唯法功能。无实自性非我我所故。唯说五不减不增。愚夫不知为破我执于非蕴中假说为蕴。遂执为有。故今对破并说为空。二十论云。说无有情我。但有法因故。等者。等取下处界等五种善巧。然大经言。色空乃至菩提亦空。设有一法过涅槃者。我亦说为如幻如化。故此等言通摄一切。胜空如应二皆准释。大经次言。受想行识自性空。不由空故。乃至广说。受想行识即是空。空即是受想行识何以故。此但有名谓为菩提。谓之为空。此但有名谓之为色受想行识

经曰。舍利子是诸法空相不生不灭不垢不净不增不减

赞曰。前告法体空。今告法义空。是诸法者。指前对空色受等法。本无今有名生。暂有还无名灭。障染名垢。翻此名净。相广名增。翻此名减。胜空者言。依世俗谛。许色等有。可有生等。依胜义谛。色等本空。如何空中更有生等。故生灭等空相皆无。如应者言。遍计所执及依他上自然生法本性空无。法性色等体即空理。皆无如彼二乘等执生等位别。故说空相不生灭等。又若有执有为迁流定有生灭。无为在缠出缠位别实有垢净。未证真位及证真已有为无为互有增减。如是定执皆所执故体相都无。宁如彼执有为生灭．无为垢净．通二增减。如见阳焰执为实水。此水本空何有生等。非无阳焰似水生等。又设难言。若摄归性依他色等皆即空如。彼有生灭此亦应尔。今义答言。如太空中色虽生灭而空相无。如是依他虽有生灭真空不尔。复有难言若一切法皆即真空。空相遍在贪等垢染信等净中。如应垢净。今义答言。如太空中有色染净空相不尔。如是诸法虽有垢净而空相无。故有颂言

  非染非不染　　非净非不净
  心性本净故　　由客尘所染

或有难言。若法皆真无别相者。甘露圣教既有增减。真空应尔。今义答言。如太空中色相增减空相不然。如是圣教虽有增减而空性无。皆由事理体相别故。若一切法唯真如空。如何得有生灭等事。以上总说非但色体不异即空。色上生等诸差别义亦不异即空。今遮通别且略举三。而实空相亦不一等。大经次言。如是自性无生无灭无染无净。菩萨如是修行般若波罗蜜多时。不见生灭不见染净。何以故。但假立客名别别于法而起分别。随起言说如如言说如是如是生起执着。菩萨修行般若波罗蜜多时。于如是等一切不见。由不见故不生执着

经曰。是故空中无色无受想行识

赞曰。胜空者言。上以色等体义总对于空明不异即。恐义不明。令观纯熟别结空中所无之法。乘前起结说是故言。此言通下诸所无法。如应者言。三乘通修五种善巧。谓蕴．处．界．缘起及谛。随彼所应为远近观。由二乘等皆随执有。今对说无。所执空中体义俱寂。故所执蕴其性都无。然佛方便于有为中施设为蕴。破五我事渐令入真说为善巧。非谓实有。故经颂言

  如星翳灯幻　　露泡梦电云
  诸和合所为　　应作如是观

有为之法尚非定蕴。所执蕴等何理成真。法性空如故非蕴相。是故空中都无五蕴。大经次言。复次舍利子。诸菩萨修行般若波罗蜜多时。应如是观。菩萨但有名。般若波罗蜜多但有名。色受想行识但有名。乃至广说

经曰。无眼耳鼻舌身意无色声香味触法

赞曰。此说空中无十二处。胜空者言。佛权方便说有处等引令入真。既入真已依真实义故说皆空。如应者言。唯由根境能与六行为生长门。说为处义。然以世间相见．问讯．涂香．受膳．侍给．分别故。佛说处次第如是。因位眼耳不至能取。鼻舌身三至方能取。意即八识。果俱不定。眼耳用胜。天得通名。变化非真。唯欲色界。下地诸识有依上者。业．缘．通．定．法力皆生。诸位随应用有胜劣。如次九八七五缘起。色谓显．形．表。声谓执受．不执受．俱大种所生。香谓俱生．和合．变异。味谓苦．酢．甘．辛．碱．淡。触谓四大及此所造。法谓无对色及余心所．不相应．无为。初五唯二。余通异熟．长养．等流。异熟唯欲色。后二通三界。色．声．有表．意．法通三。十色皆唯无记及善。即离依有假立造名。一切皆通有漏无漏。二十颂曰

  依彼所化生　　世尊密意趣
  说有色等处　　如化生有情

此说佛为妄执有我久沉生死不肯趣求。非处法中说之为处。如遮断见密说化生。引令入真除舍我执。二乘等不了方便言说。执为实有。今显所执性本都无。因缘法中既非实处。法性空理亦无处相故。乘前义而结处无。大经次言。眼处但有名。乃至法处但有名。眼处空乃至法处空

经曰。无眼界乃至无意识界

赞曰。此说空中无十八界。胜空者言。眼界．色界．眼识界．耳界．声界．耳识界．鼻界．香界．鼻识界．舌界．味界．舌识界．身界．触界．身识界．意界．法界．意识界名十八界。今举无初后例中间十六界。世俗故说有。胜义故皆无唯有假名。自性空故。如应者言。由根及境能持六识。彼复自持因果性义名之为界。前处次第识界随生。故十八界次第如是。能取于境是六内界相。眼等所取是六外界相。依根缘境似境了别是六识界相。此中意界即心意识。心谓第八识。持种受熏趣生等体。善无覆性。能变身器为有情依。有三位名。一我爱执藏位名阿赖耶。此翻为藏。能藏所藏执藏义故。二善恶业果位名毗播迦。此云异熟。善不善业所招集故。三相续执持位名阿陀那。此云执持。能执持身不失坏故。意谓第七识。染执我相为有漏依。净常平等。性善有覆。亦三位名。一我执相应位名有覆末那。缘阿赖耶执为我故。二法执相应位名无覆末那。缘毗播迦执为法故。三思量性位但名末那。缘阿陀那等起思量故。能缘所缘短长平等。故七八识各有三名。初二名皆有漏。后一名通无漏。识谓余六。如自名显。皆通三性。至佛位中转异熟识名圆镜智。九喻影像于中现故。随应初地转二末那名平等智。能具十种平等性故。三乘见位转第六识名妙观智。随应具足十胜用故。转前五识名成事智。起十化业满本愿故。因多分别以识为主。果皆决断标智为名。此前八识即七心界。四智唯善。并法界摄。三照有空具真俗智。成事照有俗智非真。圆镜平等恒不动摇。初恒遍观名一切智。妙观成事有时间断。虽此四智皆具众德。而随相增起摄不定。然佛说法有略广门。于蕴义中略说色识。处界随广。蕴广心所。处界皆略。为愚三故。蕴说有为。处说二取。界增取体。机欲待故。破我能持施设为界。二乘等不了便执为实。所执都无。余非实界。故乘前义亦结此无

经曰。无无明亦无无明尽乃至无老死亦无老死尽

赞曰。胜空者言。上无远观。下无近观。此无独觉邻近所观。故契经言。为求独觉者说应十二缘起法。又说。无明乃至老死唯有假名。自性空故今说为无。尽者空也。空亦空。故说无无明尽乃至无老死尽。十二缘起有空俱无。例余皆尔。今影显之。如应者言。慈氏尊说此于染净皆有顺逆。杂染顺观依于生死流转法说。逆依世间加行法说。清净顺观依于根本断障法说。逆依断已重观法说。杂染顺观者。初知体性具十二支。一无明。谓迷内外愚。二行。谓福非福不动。三识。谓异熟识。四名色。谓五蕴。五六处。谓六根六触能对境之胜劣。七受能领境之苦乐。八爱。谓三界贪。九取。谓烦恼。十有。即行至受六支种子由爱取润能有后有。十一生。谓苦果现起。十二老死。谓衰变终没。次观由痴发起邪行。能集当来随业果识。五蕴相起诸根圆满。触受境界种子感果。耽着希求。烦恼滋长。润前业等。五趣苦生老死忧悲之所随逐。故契经言。无明缘行乃至生缘老死。识等五支因无次第。依当起位说为后缘。杂染逆观者。依初习位安立谛说。谓老死苦．老死集．老死灭．老死趣灭行。乃至随应历观诸谛。由老死支苦谛所摄。于缘起中先逆观察。以三种相观老死支。一细因缘。二粗因缘。三非不定。感生因缘名细。谓爱．取．有。生自体名粗。谓生支。由此二生而有老死。当来老死细生为因。现法老死粗生为因。除二生体余定无能与老死果。名非不定。虽观老死苦谛。至爱于后际苦并彼集谛未为喜足。遂复观察后集因缘现在众苦。谓遍逆观受触六处名色与识。观未来苦是当苦谛。观彼集因是当集谛。观未来世苦之集谛由谁而有。知由从先集所生起识为边际现法苦有。既知从先集所生起。不应复观此云何有。由识名色譬如束芦展转相缘无作者等。是故观察齐识退还。如是顺逆观察苦集。唯十支已。次观灭谛。始从老死乃至无明。云何一切皆当灭尽。谓由不造无明为缘新业行故彼苦方灭。次更寻求证此灭道。忆昔师授于缘起法世间正见念智现前。如是数观令见增长。是名杂染顺逆观察。清净顺观者。由先已集正见资粮。能于诸谛渐次获得有学无学清净智见。能无余断无明及爱。诸无明触为缘生受亦复随断。于现法中证慧解脱。受．相应心．贪爱烦恼得离系故证心解脱。无明断故应生诸行识乃至受皆不得生。是故经言。无明灭故行灭。乃至触灭故受灭。彼受不生无由起爱。由斯复说。受灭故爱灭乃至愁叹忧恼皆灭。唯有识等清净鲜白住有余依般涅槃界。名为证得现法涅槃后有漏尽住真常迹。名无余依般涅槃界。清净逆观者。既断灭已还逆观察。由谁无故老死无。由谁灭故老死灭。知由无作缘生种子现行二生无故老死无。无常缘生二生灭故老死灭。如是乃至知由无作缘生发起缠随眠三无明无故行无。无常缘生三无明灭故行灭。是名清净顺逆观察。有依顺染不说生支。机欲待故。说逆唯九。以业为识非集缘故。或观十一。无明无因智种阙故。世尊如是方便施设令独觉等获自菩提。而彼不了妄执有实染净缘起。今说彼无令舍执着。于杂染品唯说无无明乃至无老死。于清净品唯说无无明尽乃至无老死尽。各但无顺而例无逆。举无初后例中亦无。故第六地虽作此观。尚执有实流转还灭。第七地中方除生灭障。生者顺染。即此所无无明乃至老死。灭者顺净。即此所无无明尽乃至老死尽。其所无者。谓无所执作者常住二种缘生。非无功能缘起灭理。以契经言不坏世谛入于胜义。无造受者业不亡故。依他既非定缘起相。真理亦非无明等灭。故并无之。若善恶业一切都无。契经唯应说法非有。何容繁长言亦非无。待因缘故诸法成立。自事既重故应详究

经曰。无苦集灭道

赞曰。胜空者言。前无独觉近观。此无声闻近观。故契经言。为求声闻者说应四谛法。又说。四谛唯有假名。自性空故。然上兼下此亦余境。于缘起中亦修谛观。故缘起后方说谛无。如应者言。胜鬘经说安立四圣谛非安立四圣谛。如是八圣谛非二乘所知。分段生死名苦。烦恼及有漏业名集。择灭名灭。生空智品名道。粗显施设浅智所知名安立谛。变易生死名苦。所知障及无漏有分别业名集。自性清净无住涅槃名灭。法空智品名道。微隐难知非粗浅境名非安立谛。总合说者。有漏逼迫皆苦。招感后有名集。故无记法皆非集谛。此即略说生死果因。四种涅槃名灭。无漏有为为证灭路名道。此即略说出世果因。如疗病者知病．病因．病除．除法。观生死苦．苦因．苦灭．灭法亦然。唯圣知实名为圣谛。或随观察二空真如不作别观名非安立远观四谛各有四行。谓无常．苦．空．无我．因．集．生．缘．灭．静．妙．离．道．如．行．出。由苦谛行能除四倒故有通局。为入真门。近加行观不唯观苦。观非安立方入真故。于非苦等中佛说为苦等。声闻等不了如言起着。今破彼执故说为无。依他定非苦集等相。真理何由有彼差别。由此并无。故第五地虽作此观尚执有实染净粗相。第六地中方除染净障。染者有漏。即此所无苦集二谛。净者无漏。既此所无灭道二谛

经曰。无智亦无得

赞曰。胜空者言。上无声闻近观。此无菩萨近观。能证道名智。所证境名得。有能证智可有所得。证智非有所得亦空。如契经言。为求菩萨者说应六波罗蜜多法。唯言无智得。总合说故。若法非空。初有所行后可有得。法既非有。初无所行后何有得。故大经言。一切智空乃至无上菩提亦空。如应者言。菩萨真观唯非安立。故总说近亦无智得。如有颂言

  依识有所得　　境无所得生
  依境无所得　　识无所得生

无分别智证真如位。心境冥合平等平等。能取所取一切皆无。后得智中离诸相缚无虚妄执。亦离二取。复有颂言

  由识有得性　　亦成无所得
  故知二有得　　无得性平等

余位执种犹未断。故观不分明谓有二取。破实能取故说无智。破实所取复言无得。又于二法俱遮二取。别遮二取说为无得。能所得故。遮有妙用故言无智。照断能故。此释皆除遍计所执。依他幻事非定智得。真如体寂都无二相。故依三性皆说为无。非真智生一切非有。说智及智处俱名般若。真无相取不取相故

经曰。以无所得故

赞曰。胜空者言。前说是故空中无色等者。虽结成上色不异空无生灭等。而未释色等无之所由。今显空中无法所以。若色等中体少是有。应依胜义有少所得。既都无得故本皆空。如大经言。自性空故一切皆空。如应者言。辩中边言。菩萨正修十善巧观。一蕴二处。三界。四缘起。五处非处。六根。七世。八谛。九乘。十有为无为。由舍利子渐悟大乘故。此俱无三乘通．别．近．远．加行．根本六种。二真观位证法事理。所执六相都无所有。依他圆成非定六相。故以无得通释上无。如大经言。色等诸法无所得。故甚深般若亦无所得

经曰。菩提萨埵依般若波罗蜜多故心无挂碍无挂碍故无有恐怖远离一切颠倒梦想究竟涅槃

赞曰。胜空者言。上破二执广显二空。下叹二依彰获二利。此叹因依断障染利。依即前说行之异名。挂者障。碍者拘。恐者畏。怖者惧。未依慧悟。滞色等有拘溺众苦畏惧恒生。有虚妄颠倒及生死梦想。由斯欣乐究竟涅槃。既依般若达色等空。便无拘碍．苦畏．倒．想。以色生死即涅槃故。何假虚求究竟圆寂。故依般若一切远离。如应者言。下彰依学德叹获胜利。离苦圆证也。此叹菩萨因位修益。菩萨常时缘说文字学起观照。寻观实相修持眷属。不妄求知一切境界。名依般若。挂谓烦恼障。不得涅槃故。碍谓所知障。不得菩提故。或挂即碍。俱通二障。恐怖者谓五怖畏。一不活畏。由分别我资生爱起。二恶名畏。行不饶益有悕望起。三死畏。由有我见失怀想起。四恶趣畏。不遇诸佛恶业所起。五怯众畏。见已证劣他胜所起。颠倒者谓七倒。一想。二见。三心。四于无常谓常。五于苦谓乐。六于不净谓净。七于无我谓我。于后四种妄想分别名想倒。忍可．欲乐．建立．执著名见倒。心倒者谓烦恼。此有三。一根本。谓愚痴。二体性。谓边执见一分．戒禁取．见取及贪．萨迦耶见。三等流谓余烦恼。梦想者未真智觉恒处梦中。由斯佛说生死长夜。梦由想起故名梦想。前之七倒由妄想生。处梦而行故名梦想。或前诸倒皆生死因。此梦想者即生死果。如处梦中多瞩身境。故偏于果标梦想名。梵云涅槃。唐言圆寂。即体周遍性湛然义。虽真如性无二无别。依缘尽证说有四种。一自性清净涅槃。谓一切法实相真如。二无住处涅槃。谓大悲慧常所辅翼。出所知障清净真如。三有余依涅槃。谓集谛尽所显真如。四无余依涅槃。谓苦谛尽所显真如。有处依初说。诸凡圣平等共有。一切有情无生灭等。本来涅槃。有依第二说。诸菩萨住无。所住。及声闻等不得涅槃。有依后二说。三乘者同得解脱。此中总说。由诸菩萨依般若故。悟三无性。及因我法二空所显一切空故。其心不为二障所碍五怖所恐七倒所缠梦想所惑。便能究竟契证涅槃。或诸菩萨由依般若。胜解行位资粮道中。渐伏分别二障现行。于加行道。能顿伏尽。亦能渐伏俱生二障。心无挂碍。见道位中。断分别执随愿速满。无有恐怖。于修道位。解行广增断诸颠倒。远离一切生死梦想。当无学道究竟涅槃。四位所彰从增说故。又极喜住。一切恶趣诸烦恼品。及所知障在皮粗重皆悉永断。能令烦恼皆不现行。心无挂碍。最初证得无漏智故。无功用无相住。一切能障无生法忍诸烦恼品。及所知障在肤粗重皆悉永断。一切烦恼皆不现前。无有恐怖。因从果名。果已断故。最上成满菩萨住。一切烦恼习气随眠。及所知障在骨粗重皆悉永断。入如来住。名为远离颠倒梦想。即是二障三住所断。由斯佛位究竟涅槃

经曰。三世诸佛依般若波罗蜜多故得阿耨多罗三藐三菩提

赞曰。胜空者言。上叹因依断障染利。下叹果依得菩提利。三世者去来今。诸佛者非一故。梵言佛陀。此略云佛。有慧之主。唐言觉者。得谓获证。阿云无。耨多罗云上。三云正藐云等。三又云正。菩提云觉。末伽名道。此不名也。无法可过故名无上。理事遍知故名正等。离妄照真复云正觉。即是无上正等正觉。大智度论说。智及智处俱名般若。三世觉者由依此故证智达空名得正觉。或唯空性说名菩提。如来妙体即法身故。如应者言。出生死而慧悟。如从梦觉。契法性而敷阐。喻若花开。成真俗智具自他觉。慧行俱满。标以佛名觉慧圆满虽更不修。然持不舍济有情类。故亦说佛依于般若。或依即修。佛由因位依行般若得正觉故。此彰五法。一净法界。即佛法身真如涅槃。具真性相微妙功德。由观空理所得果故。余之四智谓有为德。即是所证受用佛身。修自利因所得果故。为大菩萨所现净相广大佛身。名他受用。为二乘等现净秽相不定佛身。名为变化。俱利他因所宜现故。自受用身具百四十不共实德。谓诸如来三十二种大丈夫相．八十随好．四一切种清净．十力．四无所畏．三念住．三不护．大悲．无忘失法．永害习气．一切种妙智。及八解脱．八胜处．九次第定．十遍处．四无量．三解脱门．三无生忍．三十七种菩提分法．五眼．六通．四无碍解．无诤愿智．恒住舍性．十八佛不共法．乃至一切智．种智无量功德。说不能尽。他受用身及变化身亦具有此相似功德故。有为功德四智所摄。以智为主名菩提智。法身真如名菩提断。如契经言。菩提智菩提断俱名菩提。由此故知皆称菩提。假者名佛。即总假者证得别法。故说诸佛依得菩提。如是总摄诸功德尽。智断圆满名无上觉。异生邪智。简名正觉。二乘分智。简名等觉。菩萨缺智。简复名正觉。唯佛圆证独得全名。金刚分言。一切诸佛从此经出。一切如来从此经生。是故三佛俱是菩提。理趣分说。信学此经速能满足诸菩萨行。疾证无上正等菩提。故三菩提皆由此得

经曰。故知般若波罗蜜多是大神咒是大明咒是无上咒是无等等咒

赞曰。胜空者言上已别显因果二依断得二利。下文总叹般若胜用。乘前起结名曰故知。妙用无方曰神。无幽不烛曰明。最胜第一名无上。无类可类名无等等。大师秘密妙法纪纲。显正摧邪除恶务善。灵只敬奉贤圣遵持威力莫加。故名为咒。如应者言。梵云陀罗尼。此曰总持。略有四种。一者法。以略教含广。二者义。以略义含广。三者能。得菩萨无生法忍。慈氏尊说

  壹胝蜜胝吉胝毗羼底(丁履反)钵陀腻莎诃

四者咒。大经中说

  纳慕薄伽筏帝(一)钵剌坏波罗弭多曳(二)呾侄他(三)室囇曳(四)室囇曳(五)室囇曳(六)室囇曳细(七)莎诃

此咒神力广说如经。念慧二能具含万德。顺此古说总立咒名。此乘前结法义二持起下咒持。说故知也。由此总持出过异生．声闻．独觉．菩萨四道。或文字妙用．观照圆鉴．眷属胜益．实相无喻。或四皆通。故此般若名神等咒。或此般若是大神者。乃至是无等等者之所说咒。劝诸学者皆于此经修十法行。慈氏颂言

  谓书写供养　　施他听披读
  受持正开演　　讽诵及思修
  行十法行者　　获福聚无量
  胜故无尽故　　由摄他不息

经曰。能除一切苦

赞曰。前明具德。此明破恶。信学证说皆除众苦。故大经言。能于此经行十法行。一切障盖皆不能染。虽造一切极重恶业。而能超越一切恶趣。假杀三界一切众生。终不由斯堕于地狱．傍生．鬼界。设住一切烦恼丛中。而犹莲花终不为染。常与一切胜事和合。于法．有情得无碍智。能善悟入诸平等性。自他忿等皆能调伏。现世怨敌咸起慈心常见诸佛得宿住智。所闻正法总持不忘。诸胜喜乐恒现在前。常勤精进修诸善法。恶魔外道不能稽留。四天王等常随拥卫。终不横死枉遭衰患。诸佛菩萨恒共护持。令一切时善增恶减。于诸佛土随愿往生。乃至菩提不堕恶趣。速能满足诸菩萨行。疾证无上正等菩提。随心所愿无不成办。所以王城四众才诵念而魔伏。天宫千眼始受持而怨溃。况复深衷恳己因植果圆。不拔五趣以为师。跨十方而为主未之有也

经曰。真实不虚

赞曰。除疑劝信重说此言。何有弃大宝轮王之位。处寂林而落饰。称慈父法王之尊。践众道而提誉。对诸龙象导彼天人。诳诱群生诚为未可。所以经言。如来是真语者乃至不异语者。故应信奉勿起惊疑

经曰。故说般若波罗蜜多咒即说咒曰

揭谛揭谛　波罗揭谛　波罗僧揭谛　菩提莎诃

赞曰。前说法义二持虽劝信学。欲令神用速备更说咒持。佛以大劫慧悲难修誓行加略文字。意趣深远教理幽。广不易详赞

般若波罗蜜多心经幽赞卷下

贞应三年(甲申)正月十五日为助先师真归上人余业敬雕摸毕兼以此功令故权大僧都重信荡流转妄执趣菩提正道及自他群类同开真解矣　　　　　　　愿主性如


般若心经略疏连珠记

    No. 1713 [cf. Nos. 251, 1712]

般若心经略疏连珠记上

立斯题者。示无胸臆尔。谓此记文。是皆佛祖之灵蛇夜光赤野丹渊明月亏全者也。第以朱丝金缕贯连成记。有类苍梧之珠丘焉

        宋玉峰沙门师会述

将释此疏。文二。初题目二。初标疏题。然题目有二种。冠之经首则曰经题。标于疏前乃曰疏目。今即疏题。般若等是所解之经略。疏乃能解之疏。取所解之经目。能解之疏分。取他名有财释。若云之疏。即依主释。略者。要略之略。非别有广疏也。并序者。兼有一序也。二显嘉号翻经者。京口仅公所刻。夹科经疏之后刊。祖师自题云。法藏长安二年于京清禅寺翻经之暇。属司礼部兼检校雍州长史荥阳郑公再三殷勤令出略疏。既曰翻经之暇。非曾预译场之谓也。沙门者。此翻勤息。次二字疏主之令名。述者述而不作之谦词也。二本文三。初总标名意。二开章释文。三庆赞回向。初中二。初通叙玄纲彰般若大宗二。初正叙幽深三。初超言以指体二。初体玄。夫以等者。夫乃发语之词。以言由也。真源者。非虚妄念虑曰真。是诸法性体曰源。即实相般若无相真如也。清凉释刹那际三昧云。即穷法真源谓穷彼刹那时相。都寂则刹那无际。由达清净真如本无相故。则以无相真如为真源矣。贞元曰。妄随境变体逐相迁。鼓击真源浩荡无际。彼以衣珠秘藏为物性之真源。草堂曰。般若之心是万法之体。又曰。真空者。即灵妙心源。良由本是真如。一心与生灭合。名黎耶。变起根身器界色等诸法。推之无体归于真心之空。则第一义空为诸法之本源。故曰真源。论曰。以有空义故一切法得成。经云。从无住本立一切法。镇国曰。无住性空真如皆实相之异名。疏主又曰。令机证真源入果海也。则以果海为真源矣。素范者。素表无瑕范持自性。谓其体若冰霜。性犹珠玉。在烦恼泥不改坚白。论云。如如体中过恒染法。皆悉空空无所有故。疏主曰。素范超情空有以兹双泯。冲漠者。冲曰深玄。漠言广远。疏主又曰。廓无涯而超视听。深无极而抗思议。论曰。超思惟之境绝窥竀之域。是岂筌罤所能获哉。筌者。取鱼之器。罤者。网兔之罝。以况谈思与真理隔绝也。妙觉下二用妙即观照般若也。镇国曰。离觉所觉故名妙觉。经云。如来今得妙空明觉。论曰。觉心源故名究竟觉。又论曰。萨般若慧唯有觉照。无一一法而非觉故。疏主即曰。妙证真源之知慧也。玄猷者。猷者道也。因也。言此妙觉入真源之正道克妙果之深因故。下疏云。由斯妙慧翻生死过。尽至真空之际奥。颐者谓般若渊海深而不可极也。大论云。智慧大海唯佛穷底。超于言象者。经云。般若义者无名无说。又曰。真般若者清净如虚空。无知无见无作无缘。古德云。体本绝待名说俱寂故。超言象也。前云筌罤。乃言象之喻而互举者。欲文妙耳。周易略例云。言生于象。故可以寻。言以观象。象生于意。故可以寻。象以观意。意以象尽。象以言着。故得意忘象。得象忘言。犹罤者。所以在兔。得兔而忘罤。筌者。所以在鱼。得鱼而忘筌。存言者非得象。存象者非得意。然彼欲学者舍诠而求旨也。今之疏者。乃谓妙空真觉理圆言偏毕竟不可说相故。疏主曰。渺渺玄猷名言罕寻其际。茫茫素范相见靡究其源。是则即言忘言即相忘相。非谓涤除万物。相塞视听。寂寥虚豁。然后为真者也。问曰。时然后言非其时而言谓之过言。且此教之兴。欲令行者发大心修广行。破外回小断障得果益众生也。疏主何由约彼万法之源妙觉极果而遽叙耶。答曰。欲显修因同果地觉故。文殊创问本起之因。至圣首提究竟之果。若性非金玉虽琢不成宝器。故经云。不能了自心云何知正道。又问。苟叙首楞圆觉顿教深经可如高论。今此经者列属五时渐教明矣。何以直叙真源妙觉。以渐滥顿宁无过乎。答曰。吾祖心游大教妙悟圆宗。行行令了自心。字字朝宗顿旨。圆顿宗主华严祖师。岂与夫三时五时之学士。会权归实之渐人。同日而语哉。又况一经之所宗万行所由生也。虽真下二三谛以彰玄下疏云。令悟二谛中道生正见故空假皆中。色空无寄方为此经所宗。第一义谛之真空。故于中有二。初二谛存泯。文有二句。上句相违义故双泯。下句相作不相碍义故双存。镇国曰。色空相望总有三义。一相违义。二不相碍义。三相作义。结云。此三无碍方曰真空。亦称妙有义。记曰。所以真俗双泯者。真者真空之理为真谛也。俗者色等诸法为俗谛也。又曰。但约缘起万差为俗。无性一味为真。双泯者以二谛不一相违义故。以俗害真。真泯。以真违俗。俗亡。互夺两亡。是曰双泯。又曰。此缘起法由性空故。令彼幻有亦不得有。是故一切唯是真空。经云。诸法毕竟空无有毫末相。又云。一切法空如劫尽烧等。大般若云。色等空故空中无色。依彼幻有非有之门。及依真空非不空门。说彼真空永害幻有。是故遂令俗相永尽而为真谛。又此缘起法由幻有相故。令彼真空亦成不空。唯是缘起幻有差别故。楞伽云。非遮灭复生相续因缘起故。摄论瑜伽等中明依他起法。永不是无。如是并依真空非空门。及依幻有非不有门。说彼缘有永非是空故。方为俗谛。如是二谛极相形夺方成本位。璎珞云。世谛有故不空。真谛空故不有。故双泯也。二谛恒存者。宗致曰。以若不缘生不无性。故谓缘有者。显不自有。不自有者则是无性。又无自性者显非自有。非自有者则是缘有。下经云。色即是空空即是色。论云。智障极盲闇。谓真俗别。执亦不得以性空故。而不许缘生以无缘生空不立故。论云。有为法空以从缘生故。又此是真空非断空故。若待灭缘生方为空者。是则情中恶趣空也。是故以真夺俗俗尽而俗常存也。又亦不得许缘有故。违害真空。以若不空非是缘有。自若有者非缘生故。是故以俗害真真泯而真常存也。又不异有之空方为真空。不异空之有方是幻有。是故此二不二存泯同时也。空有下二。一味圆彰。圭山曰。谓一真心性非空非色。能空能色如镜之明。是于二谛之后。加第一义谛。谓无性故缘生空亡也。缘生故无性有亡也。空有俱亡为一味法故云常显。下疏曰。幻色存亡无碍真空。隐显自在合为一味。圆通无寄是其法也。良以下三中道以显妙。清凉曰。意明此中空有皆是中道。然幻有真空虽通三性。诸祖释义多就依他以叙诸宗立义不同。诸教浅深迥异。而宣政之来奥义湮微。遂令驾说之流多抑深经以为权浅。今当先叙诸家所宗空有。令昼然在前后销疏文。初言幻有者。亦名缘有妙有假有似有。宗致曰。此大乘内于缘生法二宗盛诤。一法相宗说此缘生决定不空。以有因缘之所生故。犹如幻事不可言无。若言空者应非缘生。如兔角等。又云。三论但破小乘外道。遍计实我实法。不破大乘依他起性。以是幻有非过失故。若此亦破则是断灭恶趣空摄。非正法故。既是深过。明知缘生决定不无。摄论瑜伽深密经等决定说有不可违故。此乃始教相宗说。此幻有不许即空也。二空宗说。此缘生法决定是空。以从缘生必无自性。犹如幻事不可言有。若言有者则不从缘。不从缘故则非缘起之法也。又云。设使瑜伽等论所立。依他三论。亦破以诸缘生无不空故。若此不破见不亡故。理非尽故。此是始教空宗说。此幻有不得言有。若言其有则是病眼愚夫所取。法执未尽也。三法性宗说。此幻有从缘无性。如幻化人非无幻化人。幻化人非真故。云幻有。亦名妙有。以非有为有故名妙有。又曰。以即空之色为妙色。由了无色而现色故成妙色。又曰。即空之有方为具德之有。又曰。幻有义者是则非有非不有名为幻有。又云。不堕一边为俗谛中道等。此乃法性宗约空有相。即以显幻有义也。次言真空者。一法相宗约彼遍计所执。密意说言诸法自性皆空。翻彼小乘而空六识依圆。是有不得即空遍计。是空但是空无亦曰真空。二空宗说。心境俱空平等一味。圭峰曰。以诸法无性即名真理。如幻花无体。即是太虚。又引门论云。大分深义所谓空也。假名及中道但就空说。清凉曰。三论宗云。妄说为有真谛故空。依计是俗俗故是有。圆成是真真故是空。从缘生法决无自性。故曰真空。若言有者。即是法执。智光竺汰康朗诸师之所宗也。汰法师本无论曰。非有有即无非无无即无。故曰真空。所以肇公作不真空论演义释。其题曰。此中真空非是对妙有之真空。此真空是所破病。彼谓真谛一向无物为真空故。肇公以不不之云不一向是无物故。曰不真空。又曰。此但得三论一分空义耳。草堂曰。彼且不立真何况于妄。以真谛为真空也。三法性宗所说真空。镇国曰。即色之空方曰真空。亦称妙有。又曰。要皆即有之空。方为具德之空。又曰非空之空为具德耳。此即法性宗所显中道之真空也。次销疏文。文有四节。初对总融空有以显中道。所以前科三谛圆通。空有一味者。良由幻有真空无二为中道故。一疏结成中道云。非空非有是中道义。钞云。然其正意合真空二义。总名非空。合幻有二义总名非有。空有不二故为中道。真空二义即空与非空。幻有二义即有与非有也。言真空者。清凉曰。由无性故空。是空义缘生故空。是空之所以。所以即是因缘。谓何以无性得成空义。释云。由从缘生所以无性。是故缘生无性。是空之所以。既是从缘生法无性故空。故曰真空。而又不待坏彼差别法体然后方空。是故真空未尝不有。又即此有法缘生无性。便名真空。故云。即有以辨于空。言幻有者。清凉曰。缘生故有是有义。无性故有是有之所以。又曰。何以缘生得为有义。释云。特由无定性故方始从缘而成幻有。是故无性是有所以。既是从缘无性之有。则此有常无自性。故云。幻有未始不空。又即此无性举体从缘而成于有。是故即空以明于有。然此疏文直明真空。是即幻有之真空。幻有是即真空之幻有。故云。总融空有以显中道。有空下二别融空有以显中道。即于幻有真空之上。各显一中道义也。初言有者。是指幻法自体即幻有上非不有义也。次言空有者。谓此幻法从缘无性。即空之有。是空家之有。故言空有。故不有者。以其举体全空无所有故。即幻有上非有义也。非有非不有无二为一幻有。宗致曰。一非有义。谓举体全空无所有故。二非不有义。谓不待坏彼差别相故。大品云。诸法无所有如是有。是故非有非不有。名为幻有。次云空者。是指真空上非不空义也。言有空者。谓此真空是缘生无性之空。即有之空。是有家之空。故云有空。故不空者。不待灭缘生方为空。故全有之空故不空也。即真空之上非空义也。非空非不空无二为一真空。宗致曰。二真中亦二义。一非空义谓以空无空相故。二非不空义谓余一切相无不尽故。是故非空非不空名为真空。经云。空不空不可得名曰真空。中论云。无性法亦无一切法空故。宗致合此有五重中道。一谓非有则是非不有。以此无二为幻有。庄严论云。无体非无体非无体即体无体体无二。是故说是幻。此以无体为幻体故说无二。由此无二不堕一边故名中道。此是俗谛中道。二真中非空即是非不空。以此无二为真空双离二边。名为中道。此是真谛中道。三幻中非有则真中非不空义。幻中非不有则真中非空义。以并无二故。由此无二与前无二复无二。是故二谛俱融不堕一边。名为中道。此是二谛中道。四幻中非有与真中非空融无二故。名为中道。此是非有非空之中道。经云。非有非无名为中道。五幻中非不有则是真中非不空。此则非非有非非无之中道。谓绝中之中也。是故二谛镕融妙绝中边。是其意也。此中初二中道是空有别融。后三二谛交络以显中道也。不空下三显正拣非。以明中道言不空等者。即无性故。空缘生故。空为真空也。镇国云。显正也。空而非断者非无见断见之空。镇国云。拣非也。断见之无是定性之无。定无则着断。今缘生故空非是定无。无性故空亦非定无。定无者一向无物。如龟毛兔角。今但从缘无性故非定无。是故空而非断也。不有等者。亦先显正后拣非。不有之有者。即无性故有缘生故有。此二种有并非常见之有。常见之有是定性有。今从缘无性之有。非定性有。显是幻有显正也。既非定性之有。故云有而不常拣非也。则是真空妙有离断常之中道也。四执下四离谤。具德以显中道。镇国曰。中道者非唯非有非无而非断非常等。皆中道也。四执者亦云。四谤。镇国谓。定有者增益谤。定无者损减谤。亦有亦无相违谤。非有非无戏论谤。一异俱不俱常无常等。皆曰四谤。如情所封定执四句。故皆成谤。般若离四句不可以有无取故。今四执既亡即成四德。吾祖又曰。然皆具德不成四谤。谓此四句即是具德以称真故。不同情计。又曰。尽有之空尽空之有。方为具德。又皆即有之空方为具德之空。即空之有方为具德之有。又随一句必具余三。若随阙者则非具德。百非斯遣者。论曰。百非非非千是非是。非百非背千是非非。中中背背天天。演水之谈。足断而止。审虑之量。手亡而住。可谓般若二谛中道之大宗也。古云。境智余科不贯义似未安。故不欲循其辙也。上来正叙幽深竟。般若下二结归玄旨。夫般若虚玄者。盖群诠之宗极真一之无差。一十六会之格言。二十四年之雅诰。性理幽微超情离见独拔于有名之表。颖脱于曳尾之涂。玄虽玄矣。妙复妙焉。不亦罄于兹序哉。故云。斯之谓欤。若历下二别叹真诠显。曲尽妙旨二。初通明广略二。初示文。若历等者。谓历色心等事备陈正理。则有八部二十万颂。颂有四种。一阿耨窣睹婆此云数字颂。不论长行。但数三十二字。则云一颂。二伽陀此云讽颂。亦云直颂。直以偈颂讽美法门故。三祇夜此云应颂。应前长行颂故。四集施颂积集法义令诵持故。今即初也。若撮下即略经也。枢谓门枢。尔雅曰。制扇以柎门傍曰枢。即俗呼门准是也。又言行乃君子之枢机。盖言华屋之要四体之本也。以况八部所诠顿实之旨。斯经尽之。故曰。撮其枢要理尽一十四行。行即十七字之行耳。理趣般若序云。此经并乃核诸会之旨归。绾积篇之宗绪。清凉曰。明是六百卷理趣也。今经亦六百卷之枢要矣。是知下二显意二。初广略由机。疏主曰。机缘感异圣应所以殊分论说。广自力根略自根力。如来则以广说修多罗略说修多罗以应之。故曰。广略随缘。缘者机缘也。超言下二理圆俱现。疏主又曰。圣应虽殊不思议一。经云。譬如痴人畏空而走。经恒沙劫不能得出。在所至处不离虚空。良以真空妙宗性无不在故。能俱现矣般若下二别叙。今经二。初妙赞投机。昏衢苦海以喻有情奔驰生死无智慧明。五苦八苦不得边底也。高炬迅航以况斯经。三无相慧拯接物机导引迷徒。群修多罗莫比斯最。然则下二聊示经目二。初略提纲要。般若等者。肇公曰。然则智有穷幽之鉴而无知焉。神有应会之用而无虑焉。神无虑故能独王于世表。智无知故能玄照于事外。经云。般若无知无所不知。则观照实相也。波罗下功者。功用也。谓漉人天龙渡生死海置涅槃岸。乃斯妙慧之功用也。心显等者。赞能诠经略能摄广之妙胜也。如圆觉题中修多罗了义五字。是故圭山科下六字总属能诠。钞曰。上五字是比对诸经叹此经殊胜。意显圆觉一经是修多罗藏中了义之经。今疏主特彰一十四行。是六百卷中之要妙。意言是般若部中之心。如人心藏是一身之要也。前已广叙所诠甚深故。此特显能诠文字。般若如精耀气丝焉。盖顺译主独就喻彰经。乃等者。线能贯华。经能持纬。圣宣法义。经以贯之也。从法下二以义结成般若法也。心乃喻焉。心经为诠般若为旨。结为题目矣。将释下二开章释文二。初标列章门。五门者。疏从经略门止五焉。前三义门。后二正释。以经题目即本文故。然此五门生起有绪。初教兴者。夫圣人言不虚发。动必有由。非大因缘莫兴斯教。教虽无量不出二藏。三藏权实教门。虽知深旨未悉所崇。宗趣既明。须知题目纲要。已彰在文难晓。五章生起。其略如是。初教下二依门解释五。初教兴二。初生起大意。教兴者。论问曰。佛以何因缘故说般若波罗蜜经。诸佛不以无事及小事因缘而自发言。譬如须弥山王不以无事及小事因缘故动。今以何等大因缘故。说般若波罗蜜经。故疏引此生起教兴大意。一谓下二开章别释二。初正释四。初破邪回小。谓末伽黎等广起有无等见。行于理外。世尊说般若等经破实我法化令入道。二者鹿园之器方等弹呵渐已成熟。般若之经广说诸法自性皆空。翻彼小乘引令入大故。大品云。若人欲得阿罗汉果。当学般若波罗蜜等。疏主曰。九十五种竞扇邪风。一十八部争挥爝火。遂使真空慧日匿辉昏云。般若玄珠惑兹鱼目。三令下二显理成行。前二显理。次三成行。令小等者。即下三乱意人。为说般若令意净入理也。四令悟下正见者。令信解真正了悟。中真不执定实色空。方名正见。二谛中道者。以是此经之所诠故。义记云。二论宗于般若通。以二谛中道而为其宗。彼文具彰真俗空有与夺存坏。以明缘有性空。或相夺全尽。或相与全存。或自坏自存无有障碍。若相与门则不坏有之空。与彼不坏空之有理不杂。故成非一门。若相夺门则此坏有之空。与尽空之有全。夺故非一也。若各自存门则不相。是故非一也。若各自坏门则无一。可一故非一也。以存坏无碍二理不杂。不堕边故不失中道。是谓二谛中道也。非异之义如彼所明。又非一与非异复无有二。以缘起无二故。以坏有之空即是尽空之有。无障碍故。极相违反。还极相顺。是故相夺相与复无有二。镕融无碍也。由非一即非异故。即二谛为中道。由非异即非一故。即中道为二谛。又非一与非异亦非一。是故即非一之非异与即非异之非一。义不杂故。而非一也。谓不异中之二不异二之中。融通不杂故非中非二。具足中二。是谓中边无障无碍之中道。令悟此故斯教兴也。五显等者。此下欲成胜行故演斯经。以净信大心万行之本。又发三心修十信即是行故。佛德者。常等四德及佛地河沙真净功德。义同华严。举果劝乐生信心也。问觉钞说空宗佛德空云诸部般若中百门论首末皆是。又引此经无所得等。皆曰彼义。何由今说常乐等德答彼成智光此顺疏主。下辨所得中。云德无不备故。非佛德空也。大菩提心者。即直等三心深广。行者离相为深。随相为广。般若具明二行故。八令下三断障得果二障二果。并如下说。十流下四传芳万古。此为未来等蒙益也。略说下二结指第二下二明藏摄二。初藏摄三藏者。谓经律论也。通称藏者。以含摄故。谓摄一切所应知义摄。即包含故。契经者。谓契理契机贯穿摄化。即贯穿言教摄持所化也。经非余二故。契经摄二藏者。则约大小以分。今非二乘故。菩萨藏收。权实下二教摄。镇国曰。由前经藏有权实等故有此门。然疏主述作随宜制度事非一准。且华严备张五教起信无差。唯约四宗斯经但明权实。梵网独开化制。盖以欲和阳春之高唱乃追玉舌之旨归。然则门门刃解东流义义冰镕。三藏戒经具说重轻。佥明持犯约化制以释通。岂非得旨。般若竖贯二时横通五教。有带有双谈空谈有彰权实以明之。可称绝唱。且一大藏经虽皆佛说。然有就机方便权宜说。有称性决了真实说。今经决了真实故云实教摄也。但以权实多门理须略辨。约说有三。一就五教。前四皆权后一方实。此如孔目教章等说。二者前二为权后三皆实。如华严圆觉等疏所说。三者净土说为真实娑婆谈是权宜。如修证仪说疏依第二。问般若谈空以空为始。始固属权故。政观以来议斯权实众说不同。或约大小或约通别。或曰。教果是权理行是实。何以记皆不叙。答曰。论云。从得道夜乃至涅槃。常说般若。斯经权实双彰渐顿兼唱诸宗判释不同。故使后贤多误。今将具列以罄源流。一戒贤论师曰。依遍计所执而说诸法自性皆空。依他圆成犹未说有。即判般若等经中百等论。说六识空多谈空理。属第二时法界无差。论疏依此以判般若等经。属第二宗摄。二智光论师曰。第三时中方为上根说无相大乘。谓此缘生即是性空平等一相。依计是有圆成是空。依此以判般若等经。总破大小法相八识俱空多说空理。圆觉疏等叙彼所判。般若等经中百等论属于空宗。始教所摄。三吾祖镇国大和尚曰。若唯说法华为实则抑诸部般若了义大乘之经。般若离四句何曾存空。般若不坏四句岂无妙有。是知实相般若即是正因佛性。观照般若即为了因。大品仁王理趣等经。皆属终教。四者诸祖皆曰。二边既离中道不存心境两亡。亡绝亦绝。般若现前。已当八部无相六乘之极致。镇国曰。即同智照无二亦同顿教。文殊问光赞放光等经。诸祖并曰。顿教。五镇国曰。大品云。一切法趣色即一切皆色。一中具一切。即事事无碍般若义。该五教即具圆矣。而疏主以戒贤智光二宗所判。真谛之空非第一义空。故不摄此义。当后三故言实摄。若约今经显诠分齐者。镇国云。若以三观就心经意。色不异空明俗不异真。空不异色明真不异俗。色空相即明是中道。为空假中之三观。疏中亦以三观释经。当前第三义也。又云。以会色观中明色不异空等。明空即色中明空。不异色等。第三观但合前二。第四拂前四。向相现真空相不生不灭。无智亦无得真空观备矣。贞元判同顿教。即前第四义也。前疏广叙中道。下文备彰相作相成。互存互泯无碍自在。圆中同教。经诠坚实一心即圆觉妙心。含圆别矣。皆前第五义也。疏文经旨明若瞩日。别议权实者。惑亦甚焉。第三下三明宗趣二。初唱章释名。宗者崇也。尚也。今云。语之所表者。即此经表彰表显之崇。崇尚也。趣者趣向也。即宗意所归趣之处也。然先下二总别演义二。先总。总以等者。大论云。说智及智处智智皆般若。晓公曰。此中即显三种般若说。智者文字般若。及智处者。实相般若。智智即观照般若。是三皆此经之宗。一贯等者。古德曰。妙心湛寂无相而相。谓之实相。实相随缘为诸法之真性。肇公云。实相法性性空缘会本无一义耳。二观照等者。即正体智等无相离分别之慧也。三即文字般若。孔目云。熟教有三种智。谓实相般若智等。清凉曰。清凉法界相宗不得名智。法性宗中亦名为智。即此实相也。或说五种般若不离此三。故云不越等。别亦下后别一教义。对深穷教海志在见理成智也。二境智对谛观正理意。其破惑发智矣。三因果对因行。即观照妙慧也。果德为趣非佛德空矣。然别宗如此。其通宗者。般若以无相为宗。清凉曰。无相宗含于三教。谓始教顿教实教。今经正当顿实。若深必该浅。义或可通。第四下四释题三。初唱章。二演义三。初分教义二。初辨诠旨。谓般若心者。标举也。是所之诠义者。判释也。判此题中心及般若等言。皆属所诠之法。即下无挂碍心也。不空译云。菩萨有般若波罗蜜多心。名普遍智藏。乃至色性是空空性是色等。即心是所诠法。明矣。圭山曰。藏和尚般若心经疏作所诠义释心字。意云。般若之心是万法之体故云心也。会同坚实用释圆觉妙心。拣云。不同缘虑集起之义。又曰。肉团粗浅不必拣也。故云。所诠之义经之等者。诠上般若心也。佛地论云。能贯能摄故名为经。又曰。应知此中宣说佛地饶益有情。依所诠义名佛地经。且能所诠释经题者。本出亲光。而四明礼公乃言。大违佛理。智者位居五品。亲光登地菩萨位望相辽。如一轻尘较大地土。而辄是彼非此不知其可也。若心作喻释。即心经二字是能诠教也。二结离合即能等者。依所诠义立能诠名。三摩娑释依主得名。补卢沙声属声受称。二就下二析法喻二。初约所诠以指法。就上所诠义中。复取心字以喻能诠教胜。唯般若等是所诠之法。故不言所喻。复云。所诠是知实相观照非所喻也。独将一十四行文字般若为所喻。故但言所引之喻。不言能喻心之下二叹能诠以引喻。此乃译人之意非疏主正义。故慈恩云。般若波罗蜜多者。大经之通名。心经者。此经之别称。般若之心经也。草堂曰。亦作能诠教释。意云。此半纸之经是六百卷之中也。即纥利陀耶此云肉团心。引而为喻。喻此略经是大部之心藏也。即文字般若是所喻。心之一字是能喻也。即般下法合以彰要。谓六百卷二十万颂之内也。统要等者。幽赞曰。甄综精微纂纲赜事。虽万象统即色而为空。道纵千门贯无智而兼得。采广文之秘旨。标贞心以为称也。况人等者。况譬也。如人百体心为其主。故经云。心如帝。三喻此略。经唯谈妙最余藏六腑喻广说。经兼被二乘亦该权浅。岂似此经中道镕融。唯终唯顿文略义深。括尽玄奥故云。统极之本。然泛论心者。有其四种。一纥利陀耶即肉团心。二缘虑心谓八识。俱能缘虑自分境故。三质多谓集起心。即第八识。集诸种子起现行故。四干栗陀。此云坚实心。若作所诠则当第四坚实。约法以解心也。作能诠释则当第一肉团。约喻以解心也。且圭山出。自大唐。非后人救过而穿凿也。显矣。近代岳公而谓疏主不知约法以解心陋哉。坐井而观天曰天小者也。三就下三明体用二。初翻名以显体。即就前所诠法中。非所喻文字般若中也。体用分二者。然体用多门略明三义。一寂体照用则实相观照为体用也。放光云。般若无所有相无生灭相。此明寂体无相也。道行云。般若无所知无所见。此显照用无知也。二权实二智以分体用。实智照真内鉴而无知体也。权智涉俗外应而无虑用也。三直就大乘以明体用。则以当法包含为体。运载功能为用。疏主曰。体用合说故云大乘。三大二运即其义也。又疏主明乘体中。则以无分别智所依真如互为兼。正摄余胜行为乘体。性明业用中。乃约三佛性中自性为所乘。引出为能乘至得果。为所至处。又约运因成果等义。为乘业用。然今此疏。乃取到岸为用。证真为体。正用第三兼之前二。若以翻尽为用照源作体。则通用二三该之。第一般若等者。译梵成唐。即神等者。灵知不测曰神。颖脱众妄曰悟。超名言之表曰玄。出相见之乡称奥。以无得无智之般若。会契离性离相之真源。本觉自知照体。独立绝知会忘能所。本心挺现不由他悟。故证而称妙也。若以真源为实相。则般若但目观照文字。若约一法多名则理智互出。以无智外之如故。真源即般若。亦无如外之智。故智慧即真源矣。波罗下二会梵以彰用。波罗者译梵成唐。既以到岸为用。正约运因成果也。而义有三。一由斯妙慧者。运行令增也二生死过尽者。运惑令灭也。三真空际者。运理令显也。初一是能后二是所。又即杂集三转依义。一心转真性现故。二道转行渐增故。三断转惑障灭故。又起信云。破和合识是转灭显现法身。是转显智淳净是转增。但小不次不到之慧。拣权小也。谓体下三结释。初一持业。后二依主。立斯名者。据不空译本。即说主立耳。经观下五解文疏三。初唱经标章。然此当通唱一经而判释之。随科释处再唱子科。经文于义即便。今疏从略但存别唱。不然则判释居前。或本作此安布以广陈。中例亦如此。故不敢率易改动。此既下二会义具阙。然此经六译三分有无译人意乐。今此云者。是语略之之意也。慈恩曰。录大经妙。最别出此经。三分二序故。皆遗阙。然余译多具。文中下三开章演释二。初总别开判二。初分总二。初判经。何以下二显意。何以者。假问令说也。谓显等者。灭惑要须开解。开解在于显谈。祝诅志期生福障除。然后福生。经谈二分依修而福慧等严。故云显了等也。夫灌顶大悲涤业之辞甚显。首棱如意雪罪之文颇明。孤山乃谓显秘之与机心好异引。直说为神咒。判情迷作秘宣。遂使教阙浅深人无利钝。且郢书燕说谁曰不空。献替凤毛岂称秘密。况乃全抄本疏杂以浮辞谩夸。十疏通经是亦浪名。江表钞盂兰而服义疏。斯经乃欺心中边皆甜实难其味。就前下二判别二。初判经略标。纲要者。真心之空斯教喉衿。是以经家标为义本。不空译云。菩萨白言。我欲于此会中说诸菩萨普遍智藏般若波罗蜜多心。蒙佛听许入慧光定。照五蕴空度苦厄等。一经宗本故略标之。广陈实义者。色空交彻性相融通。事非权浅故云尔也。以义下二显意。初约广略。三约解行者。略乃定中照见得非自利行乎。广则起定宣扬对机明辨。开彼解为。然今经略分则别译序分之文。译者之妙巧应秦人。而皆别相修多罗摄略为广本。亦本略收前中下。二依门作释

般若心经略疏连珠记上般若心经略疏连珠记下

        宋玉峰沙门师会述

经二。初显了般若二。初略标纲要分疏三。初科分。第四科名诸师注本。但云明利益无能观之言。以愚所见。传写之家误下能字耳。二随释经四。初能观人疏二。初标章指经。初句标章。次句牒经。能观人者指示也。言观自在者。镇国曰。三业归依十通随应。鉴无遗照益无不周。然或云。观世音梵云婆卢枳底。此云观世湿伐罗此云自在。若云摄伐多。此云音。梵本有二故。译有二名。而法华云观其音声皆得解脱。即观世音。然彼经初语业称名灭除七灾。二身业礼拜能满二愿。三意业存念净除三毒。即自在义。今多称观世音者。语业用多感易成。故经取义圆云观自在。慈恩说十自在。恐繁不录。谓于下二依名演义二。初解别名理事等者。良以观不可分之理。圆摄一尘中。本分限之事全遍法界内。理事圆融无所挂碍。广大甚深三昧。自住三摩地时解脱若斯。是以从三昧起。如证而说。故云观达自在等也。又观等者。十四无畏三十二身。皆本妙圆通也。菩谓下二释通名。上求下化翻梵成唐矣。经行下二所行行二。初唱经。二明下二演义二。初就法以拣浅

妙行二者。即二空行也。人我执无处所显真如。名人空。法我执无处所显真如。名法空。如为所显智是能显。二执空无故名二空。太一云。人空通小乘而未清净三乘方清净。法空在三乘而未清净。至一乘究竟清净。言时下二约时。以显深。别译云。欲说菩萨普遍藏心非应二乘时也。然疏主循荣阳之请。协译者知见。以大拣小略显一理。般若时贯五三教。诠权实对浅论深。旨该多义。清凉引理趣般若一段经文。用彰二义深浅悬绝。理趣分当五百七十八。经云。尔时世尊依一切无戏论法。说如来之相。为诸菩萨宣说般若甚深理趣轮字法门。谓一切法空无自性故。一切法无相离众相故。一切法无愿无所愿求故。一切法寂静永寂灭故。一切法。无常无常性故。一切法无乐非可乐故。一切法无我不自在故。一切法无净离净相故。一切法不可得推寻其相不可得故。钞曰。此上显性空理趣。又经云。尔时世尊复依一切住持藏法如来之相。为诸菩萨宣说般若。一切有情住持遍满。甚深理趣胜藏法门。谓一切有情皆如来藏。普贤菩萨自体遍故。一切众生皆金刚藏。以金刚藏所灌洒故。一切众生皆正法藏。一切皆依正语转故。一切众生皆妙业藏。一切事业加行依故。钞曰。前明有法非有。后明无法不无非有非无。是中道理趣。上皆彼文有法非有。是性空理趣义。当始教空宗无法不无中道。理趣义通。后三实教理趣。今经采其秘旨。实教所摄理当后义。故云行深时也。又般若义具五教。今经撮其枢要。相望备论浅深理无不可。恐繁不叙。上皆顺疏以深拣浅。今于疏外率愚以助一解。辄谓慧光三昧。广大甚深穷法源底。当体难思菩萨游此。故云行深。如理而证照理究竟。当斯之时乃曰行深时耳。原夫经意未必须俟拣显。疏主且顺译人。三乘宗旨大以拣小为义。作此释耳。经照下三。观行境。初唱经。三明下演释观行境者。镇国曰。五蕴者。身心之异名。行人若不识身心真妄。何能悬契。不达真妄之本。诸行徒施。是以菩萨欲为大心宣秘要法。先入慧光大定。以离念之明智。彻法之慧目。洞达五蕴自性空。无所起当体即如。然后从三昧起。告鹙子曰。应如是学。故以达五蕴空为观行境。然以深慧观蕴性空对之起观。故名为境。若成般若境即所行。镇国曰。如般若中虽有实相。为成智慧所行境中。若能若所皆是所行。如诸菩萨行深般若。能观所观皆所行行。二空理者。镇国又曰。生死之本莫过人法二执。迷身心总相故。计人我为实有。迷五蕴自相故。计法我为实有。智眼照知。五蕴和念假名为人。一一谛观。但见五蕴。求人我相终不可得。先观色蕴是观身了知。坚则地润则水暖则火动则风。观余四蕴则是观心了知。领纳为受。取相为想。造作为行。了别为识。依此身心谛观分明但见五蕴。求人我相终不可得。名为人空。若观一一蕴。皆从缘生都无自性。求蕴相不可得。则五蕴皆空名为法空。是以照五蕴而二空理现。经度下四明利益。夫一切苦厄二死收尽。今见真空度已尽矣。何者。清凉曰。乘人空观行出分段生死。永处涅槃。乘二空观行双照人法二我。毕竟空无所有。则离诸怖畏度一切苦厄。出变易生死名究竟解脱。苦谓五苦八苦。变易谓因缘等四种生死。如唯识等说。依此观行得究竟乐果。佛德空乎。上来下三通结。经舍下二广陈实义分五。初拂外疑。作此科者。切缘郑公久诵此经。先己熟闻译者之说。是以疏主顺其闻见。有此云耳。故慈恩云。今说色空互相显者。令义增明破疑执故。一者二乘作意狭劣不乐利他二者于大乘中颠倒推求。及起疑惑等。实非疏主及经宗旨。故有便显正义之科。方顺本宗释经通意。于中二。初唱经。清凉曰。色即法相之首。五蕴之初。故诸经论凡说一义。皆先约色故。大般若等从色已上种智已还。八十余科皆将色例。若略收法不出十对。所依体事无不即空。是以诸祖皆云真空之理幻色等事。遂以释或十门无碍也。自下下二作释二。初判。总此科疏文理在唱经之前。疏中从略不存通唱。已如上会。初段下二释别二。初总示释仪。文有四释者。则此唱经文通。作四释。盖文含四义故也。非于所疑法中有。四释也。是则鹙子亦随四说义有不同。若总四释皆属所疑法。则陆沈经宗失于深旨矣。大科从初二义以立其名。初中下二唱章显相四。初正去小乘疑。经二。初举疑人。言舍下牒。经举疑人者。判释也舍利下出得名之缘。亦翻春莺。聪慧下叹德。以释对告之由。异译经说。佛在鹫山与大比丘众满千百人。今特告之。故曰上首。彼疑下二对释疑三。初有余位。初举疑。彼闻大乘说法空理而生此疑。有余者。太一云。有余身智故。见蕴无人者。蕴中无我显人空故。亦云下正疑。与彼大乘法空无别。今释下显异相。蕴中等者。床上无人床固非无。蕴中无人蕴岂空耶。则空与蕴异。今明下以经遣疑。又疑下二无余位。太一曰。无余身智故同数灭无为为体初举疑。此位身智俱尽无色心等蕴故。汝宗等者以小乘析色观色尽方空。大乘体色观色即是空。非灭色明空。如始教说。今则下以经释遣。以二下。三通结示。二兼下二兼释菩萨疑。是亦通释。舍利下一段经文。理当亦有唱经。举疑人之科。疏略不指疑人。即舍利子耳。而谓引论举疑人者。非也。然疏云。菩萨何以鹙子者。疏主曰。此等皆是已在三乘中。则鹙子等位皆三乘。太一曰。舍利弗身在佛法中义当聪明位。又曰。其位在于顿悟熟教义通初教。又回心声闻约本则名声闻。据现学法则名菩萨。疏文有三。一宝性下标举。一疑下二列释。三疑下三结示。然今列三疑以顺经文。故与玄镜不次而圭峰略注。意存的示。观心不欲衍引故。云不必和会。三便下三便显正义。良以色空无碍相即圆通。乃是斯经所诠正理故。云便显正义释疑之义。义门兼有经亦二段。舍利子者。对告人也。所显义中一彰所以。释成空有二。初正显无碍因由二。初标示。便显下牒科名。但色下示义所以。经说色空相即互无异者。良由具此三义故得空。非断空有非定有空而全有即有。以辨于空有而全空。即空而辨于有。真空妙色存亡无碍。隐显圆融一味无寄也。镇国又曰。缘起之事与性空之理。二互相望有乎三义。由此三义成于理事无碍。彰其所以。亦但说此三门四义。疏主仰释斯经。则此段经文义渊奥。具足十门理事无碍。是一经实义之宗本也。下明所离显法体。皆即妙有之真空耳。此下二科疏文。今古同迷乃将斯经抑为权浅。往往不免谤法矣。镇国大和尚循文解释。辞句晓然。今略出之。一相违下二释相。彼文云。言相违者。经云。空中无色以空害色故。亦应云。色中无空以色违空故。若互相存必互相亡故。即五六九十四门后二义全同。此疏但不相碍义。末文云。此即七八事理相即。二门相作义至准上应知。下云。此即三四依理成事。事能显理门也。其初二门即通显体相亦不相碍义。释曰。言初二门者。即相遍二门文句全同。故不备书。具如贞元。第一之下真空亦有者。上以色望于空而成相作。若空望于色作义亦成。是故下二蹑示圆通所以。是故者。蹑上之辞。由上三义无碍故。令真空妙色各具四义。而成空色圆通。镇国曰。又由上三义诸空有法通有四义。当知始教所诠真谛之空。虽云即色之空不具四义三门。良由若言其有即是法执未尽故。当深究此经所诠即色之空即空之色。各具四门三义。双存双泯逆顺隐显。具德自在无滥空宗。妄说为有真谛是空。镇国说性宗。即空之色为妙色。即色之空为真空。是则非有之有非空之空。为具德之空有也。吾祖随句牒释。恐有固执不敢避繁。遂具书之。于中二一真空望妙色。彼文云。一废已成他义以空即色故。即色现而空隐也。即是第三依理成事门。二泯他显己义。以色即空故即色尽空显也。即第八事法即理门。三自他俱存义。以隐显无二是真空故。谓不异空为幻色色存也。不异色名真空。空显也。以互不相异二俱存也。即是第九真理非事门。四自他俱泯义。以举体相即全夺两亡。绝二边故。即第五以理夺事门。上之四义并空望于色。色望下二妙。色望真空。初标示。以色为自以空为他。故异前门一显他自尽义。即是第四事能显理门。二自显隐他义。即是第七真理即事门。三俱存义。即是第十事法非理门。四俱泯义。即是第六事能隐理门并准前思之者。一以色即是空故。即空现而色隐也。良由显空之他尽色之自故。事有显理之能也。余三可知。又有前四门必带后四门。有后四门必带前四门。合则通为四门全有之空全空之有。故通合为四。是则下二会圆通结示经宗。是则者。承前之语也。由色有显他自尽等不思议玄奥之德。故能或存或亡无有障碍。具德之空或隐或显逆顺自在故。即幻有之真空即真空之幻有。圆妙融通无有异相。故云合为一味圆通无寄。是其所诠之法故。经云。色不异空空不异色等也。所以相违无碍及相作者。以缘起法有四义故。一缘生故有。二缘生故空。三无性故有。四无性故空。由初及四二义别故。有相违义。由二及三有相作义。谓缘生故空。则有作于空无性故有。即空作于有。由上四义同一缘起有不相碍义。又由初二义有有望于空而成四义。由后二义有空望于有而成四义。谓由无性故有有广己成他义由无性故空有泯他显己义。由上二义无碍故。有俱存义。由上二义相形故有自他俱泯义。有望于。空四义准之。又以无性缘生故有。则非常见有见之有为幻有。无性缘生故空。则非断见无见之空为真空幻有。即是不有有真空即是不空。空非空非有是中道义。以有与非有无二。方为幻有。空与非空无二为真空。故有非空与有无二为一幻有空与非有无二为一。真空又幻有与真空无二为一味法。上来并是镇国和尚将此一科经旨疏文。释彼理事无碍法界。则此经正义于斯可见。若依此释斯经分齐。正当圆中同教。于中若唯取双存义。当终教。唯取俱泯则当显教。若欲属当经文如前所引玄镜二义。亦当终顿。又以明所离未文问答并法相开。合疏语。则一经始终皆谈色空。交彻理事无碍中道。玄旨精考。疏主深衷未易肯将经文一字抑为权浅。况下更。有明所得一科。显佛德圆常乎。由斯等义。是故疏主判云。实教所摄。乃将今家五教后三合为一实。其理甚明。四就下四就观行释。前约所证所观之境。今就能证能观之智。以释经文。于中亦有对告等。科疏略不出。文三。初止观两轮。一观色等者。经第二句也。宝册云。所言止者。谓止一切境界相。即以觉慧唯识道理破外尘相。尘相既止无所分别故云止。色是外尘观之即空故成止行。论又云。依是三昧则知法界一相。即名一行三昧。当知真如是三昧根本。文殊般若经云。云何名一行三昧。佛言。法界一相系缘法界。是名一行三昧。入一行三昧者。尽知河沙诸佛法界无差别相。乃至广说真如三昧。能生此等无量三昧。文殊般若即此经之广文也。观空等者。论云。所言观者。谓分别因缘生灭相。随顺毗钵舍那观义故。即经第四句瑜伽云。若于诸法胜义理趣及诸无量。安住理趣世俗妙慧。当知名观。观空即色乃安立世俗矣。空色无二即二不异句也。见色非实色举体是真空。见空非断空举体是幻色。廓情尘而空色无碍。泯智解而心境俱冥。可谓止观变行为究竟也。论云。定随时彼观则顺。观随时中彼定即顺。具足具足不离转故。见色下次二不住道见色等者论曰。观一切法自性无生。离于妄见不住生死智也。见空等者。论曰。观一切法因缘和合业果不失。起于大悲修诸福德。摄化众生不住涅槃悲也。色空下二不异句。悲智念不殊者。即悲之智。观彼即生之空。即智之悲。以化即空之生。随顺法性不住二边。故云成无住处行。镇国曰。大智自利异凡大悲利他异小。此二相导成不住道。三智下后一心三观而言。依璎珞。经者。智者云。有次第三观一心中三观。从假入空观亦名二谛观。从空入假观亦名平等观。二空观为方便得入第一义谛观。此名出璎珞经。彼释意云。假是虚妄俗谛。空是审实真谛。今欲去假归真。故言从假入空观。假是入空之诠。先须观假。知假虚妄而得会真。故言二谛观。从空入假观者。若住于空与二乘何异。不成佛法不益众生。是故观空不住于空。而入于假知病识药应病授药。令得服行故。名从空入假观。而言平等者。望前称平等前破假用空。今破空用假。破用既均故言平等观。二空为方便者。初观空生死。次观空涅槃。此之二空为双遮之方便。初观用空。次观用假。此之二用为双照之方便。心心趣归萨婆若海。双照二谛也。是为次第三观。一心三观者。此出释论。论云。三智实在一心中得。只一观而三观。观于一谛而三谛故。名一心三观。乃至此观成时证一心三智。准此即三观之名本出璎珞。论以一心融之。名一心三观。故云。依璎珞经。当知论宗于经人承于论。就本而言依经立耳。文中初观会色归空。次观明空即色。后即空色无碍泯绝无寄。中道第一义谛观也清凉曰。空如不二为真空不坏。假名即为假观。合上空假为中道。故疏云。空假平等非破用均也。又可以次显不次也。谓说之前后观时三一相即。经诠普遍藏心故名。一心三观玄。镜云。色不异空明俗不异真。空不异色明真不异俗。色空相即明是中道。二祖配。经不同。则知经意融通。亦各任放辩才也。经舍下大文第二显法体经。二先总二。初唱经科判。今初下二依义演释二。初释经蕴等者。谓三科七大等法空。状者。即第一义空形相体状也。不同角犎垂壶之相。负近致远之性。内为性外为相也。良以真空随缘而现诸法。要在缘中方显空理。故约诸法而明空相。中边下二引论。初引颂。宗致亦引此颂则云。无二有此无是二名中道。言无下引释文义记。又曰。此有彼无无二为中道。又曰。此中有此无者。只是无彼有也。探玄云。一遣妄。二顺真。又初会性永无二实相不灭。又前了其不有后证其不无。故云无二有。此无是二名空义也。镇国云。无妄法之有有妄法之无。然有无有二。一定性有无。二真空妙有。无妄法之有。则无定性之有。非断无矣。有妄法之无是真空之无。便为妙有。是故若举妄取真则妄有真空。如三论说。若空有对辩。则妄空真有。如涅槃明无能取所取有者。则无妄法之有也。有能取所取无者。则有妄法之无也。又曰。遂令缘起之相相无不尽。无性之理理无不现。经不下后别三。初唱经。经明六不。而中论云。不生亦不灭。不常亦不断。不一亦不异。不来亦不去。此明八不。清凉曰。欲明不生不灭含义无尽。略举八不。又曰。然不生等佛法之体。正教之要。义味无尽。释有多门略伸一两。是以贤首清凉约境行通别以释斯义。破法显理。此为最要。中论曰。不生不灭已总破一切法。又六八十不。若约显仪无尽。则经论异出不必更会。若言展转相因互成。由不来去得非一异。由不生灭得不断常。会亦无违。备如二祖恐繁不录。二别下二释仪。初就下三演释三。一就位释二。初直释。道前者。疏主云。谓见道前也。凡者内外二凡。今就相显遍。从外凡杂染众生位说。论曰。为本际无边烦恼藏所缚。从无始来生死趣中生灭流转。名众生界。故云。谓凡夫等是生灭位。第一义空性非生灭。故经以不不之。是以疏言真空离此等也。道中者。见修二道十地位中也。疏主曰。又以十地说为见修。故云菩萨等位。障染等者。此约能所治障行以分垢净。疏主又云。已断障故名净。断未尽故名垢。又修起净德名净。净德未圆犹带障故名垢。又异前位故名净。异后位故名垢。真空离此故。经不之道后等者。究竟位也。今尽者。疏主曰。习气亦尽也。万德今圆者。疏主曰。福智圆满最极净也。此皆染净相翻缘修。若此性觉真空不容有。是故总不之。首棱云。云何是中更容他物。又佛下二引论二。初引佛性先总标。即彼论第二卷第三显体分三因品。论云。复次佛性体有三种。三性所摄义。应知三种者。所谓三因三种佛性。三因者。一应得因。二加行因。三圆满因。初即二空所显真如。由此应得菩提心。乃至道后法身故。二加行因者。谓菩提心。由此心故得三十七品十度十地乃至道后法身。三圆满因者。即加行因。由此得一切满三种佛性者。应得因中具有三性。一住自性性。二引出性。三至得性。清凉曰。住自性性者。谓道前凡夫位。引出性者。从发心已上穷有学圣位。至得性者。无学圣位。言发心已上者。若约得位已去。则当解行发心。若约见道位说。则证发心也。疏主又曰。自性住佛性者。杂染众生位中有垢真如。引出性菩萨位垢净真如。至得性即无垢真如。真空等者。就前三位故有生等性空觉明无若干也。又法下二引无差论如彼分位门说。二就下二就法释二。初释别。谓此等者。珠现青黄而珠不生青黄。遽亡而珠不灭。又随等者。如华华空空不生华。华去空澄空不加净。障尽等者。垢尽对除即无对垢将谁减乎。德不增者。于此无修亦无成就。其何增耶。此生下二会总诸识熏习故妄心分别故。有色等生。是故皆有为也。真空离此故翻破彼显空相也。三就下三就观行释二。初正释。谓于等者。标指也。具言三无性者。谓相无自性性生无自性性胜义无自性性于中二。初对三无性说。一于遍计作无相观。由无遍计方显无相。故唯识云。依此三性说彼三无性。是知若无。遍计安知无相。谓彼等者遍计之法妄情谓有道理。是无古今观之无可生灭。二于等者。染净之法从因缘生。无有生故。故经云。一切法无来。是故无有生。以生无有故。灭亦不可得。既本无生将何垢净。三圆成中。言前二不有者。谓依计也。此约空性二宗义说。若法相宗但无遍计。又下约本性重释圆成也。又妄下二真就当性说。遍计性者。性本自无何有生灭。缘生即无性无性即空。奚染净之有。觉明空海面为虚空。平等本性孰增减耶。镇国曰。别约三性中。各有三释。一直就当性说。二约当性二义说。三对三无性说。今即初后二义显正作通别释者。未见其理。二会总可知。经是下大文第三明所离二。初正释经义四。初法相开合门二。初唱经。第三下二判释二。初总判。然真等者。真空是能离妄法之真如也。所历乃所离。定实有性蕴等妄染之法也。云空无者。即无此染法非无不空真如理也。统略有四。广说则八十余科法相。开合者。则蕴界处随根开合也。初是下二别释二。初示经意会中道。初是等者。良以第一义空无性故。空蕴等诸法定实有性有无相违。是故此中无彼等法。此就下会中道。即前相违义也。今云无者。以空害色故。中无色也。不坏色者。即不相碍相作义也。空是真空不妨幻色。若碍于色非真空故。自性等者。由从缘故有。有来即无故不待坏。近古不达而谓但显空理。未晓全即妙有也。此中下二就法相显开合。初明五蕴。亦云五阴。阴章曰。问蕴义云何。答诸所有色去未现在内外细粗远近胜劣。彼一切略说色蕴积聚义。故如财货积聚。乃至识蕴。此问显得名也。又苦相广大故。名为蕴。如经纯大众苦蕴集故等。又问。蕴义云何。实有几是实有为何义。故观实有耶。答此余根境是实有义。一切皆实有为舍执着实有故。观察实有。此蕴义声闻即实初教即空。终教即如。顿教不可说。一乘即法界。二无下空十二处也。处章云。十色界即十色处。彼不言半略也。章问曰。处义云何。答识生长门义。是处义。当知是种子义摄。三无眼下三空十八界。界章曰。云何建立界谓色蕴即十界。眼等五根界。色等五境界。及法处一分受想行蕴。即法界一分识蕴。七识界谓眼等六识。及意界故。故云。色心俱开有作三六观者。义亦可见。章问。界义云何。答一切法种子义。谓依阿赖耶识中诸法种子说名界。界是因义故。又能持自相义。是界义。广义。彼说释。此下指广。经无下二缘起逆顺门二。初唱经。此即缘起观也。镇国云。缘起深义佛教所宗。乘智阶差浅深多种。龙树曰。因缘有二。一内。二外。外即水土谷牙。内即十二因缘。今正辨内。然外由内变本末相收总含法界。一大缘起。大经文内略说十重穷究性相。以显无尽一乘之义。广如彼疏。三乘缘起亦具十门。如璎珞经。三乘之智观之。各得自果。广说如余。二明下二作释彼之十门。皆具逆顺。逆则缘灭顺则缘生。此约流转还灭以为逆顺。即逆生死顺生死也。若言无明缘行等。顺生死也。无明灭故行灭等。逆生死也。顺即流转门。逆乃还灭门。若二门各说逆顺。具如探玄第十。以其等者。三道性空故。因缘生法生无有生故。逆观等者。以生无有故灭亦不可得。经云。诸法从本来常自寂灭相。故无可尽。此举下例余支。经无下三染净因果门二初唱经。四圣谛也。圣者正也。无漏正法得在心故。谛有二义。一者谛实。此约境辨如所说相。不舍离故。真实故。决定故。谓世出世二种因缘必无虚妄差失故。二审谛。此就智明圣智观彼审不虚故。凡夫虽有苦集而不审实。不得称谛。无倒圣智审知境故。故名圣谛。瑜伽云由二缘故名谛。一法性故。二胜解故。凡夫有初无后。圣具二故偏称圣谛。法性是谛实胜解即审谛。三染下二作释。言世间因果者。欲显四谛义。通大小事理具足不同。十二因缘但事而无理。名广而事略。事亦不具。但有苦集而无道故。六波罗蜜但显出世间而无世间。今言苦集是世间因果。显四谛包含具足相也。所知所断无改易故。谓苦是下出谛体相也。逼迫名苦。虽释别名亦即辨相。逼迫身心是苦行相故。是生死报者。指体也。体即有漏色心业所招报也。集是彼因者。积集增长名集。亦是出名相也。谓是等者。出体也。厌苦断集能化教法出兴意也。上是染因果灭道等者。净因果也。灭是涅槃者。寂静名灭显名相也。涅槃者。出体也。道等者。即止观八正道等。令欣等者。示教意也。此约相说通大小乘。智论云。小乘三是有相灭是无相。大乘四皆无相。皆空者。即空即如也。然天台有四四谛。一生灭。二无生。三无量。四无作。束之唯性相。相开生灭无量。四无作束之唯性相。相开生灭无量。性开无生无作。若以名必召实。今经具四。若约所诠正当无作。兼摄无生。何者。若但解苦无苦名苦圣谛。解集无和合。解灭无灭。解道无道。达四缘生故空。则当无生。若了阴入皆如无苦可舍。无明尘劳即是菩提。无集可断。生死即涅槃无灭可证。边邪皆中正。无道可修。无苦无集即无世间。无灭无道即无出世间。不取不舍同一中道。又无苦可舍非是空故。无有可舍以体即如。如外无苦何所舍耶。此句言如如尚似空。集中无明尘劳皆即菩提。岂同前空。菩提体外无别可断。不同无生空无可断。前则空中无花。云何可摘。今则色则是空。波即是水不可除波。非同灭色。生死即涅槃。非是体空。无可生灭。边邪皆中正。非离边外别有中道。非离邪外别有正道。亦非无边无邪无可修也。即是今经圆通无碍一味法也。故当无作。经无智下第四境智能所门二。初唱经。四境下二作释。知空等者。经云。若说有觉犹未离幻。是故无智所知等者。经云。本无菩提及与涅槃。又经云。设更有法胜过菩提涅槃。我亦说如梦如幻。文殊般若分云。若知我性即知无法。若知无法即无境界。若无境界即无所依。若无所依即无所住。若无所住即住平等。若住平等则无能所故曰无住。镇国曰。我即法性更不证入。法性无性复何所入。又曰。然有二意。一上二句明一性不分故无能所。犹如一指不能自触。二法性无性复何所入。明性空故无能所入。亦如虚空不住虚空。文殊分又云。佛告文殊。汝于佛法岂不趣求。文殊言。世尊。我今不见有法非佛法者。何所趣求。此即一性意也。佛又问云。汝于佛法。已成就耶。文殊言。我都不见法可名佛。法何所成就。此即性空意也。佛又问。汝岂不得无著性耶。文殊答曰。我即无著性岂无著。性复得无著性。此即我即法性更不证入。唯一如如何有能所得哉。此皆今经之广文也。问前下二问答显宗二。初异乘蹑迹。问此中文虽中道义有二问。一即前后相违。二则疑今灭色。前拂疑中。空即是色色存也。今云。都无故似相违。二乘不达疑今灭色也。答前下二经旨圆通答不碍存者。清凉曰。即空之色为妙色故不碍存也。即色之空为真空。未尝不尽矣。今此都亡即色之空也。未尝不立即空之色也。镇国曰。般若不坏四句岂无妙有不碍存。未尝不立有句也。都亡未尝不尽无句也。合二则两亦形。夺则俱非。有则妙有。岂非正诠一性哉。大品下引证诸法无所有。即无妄法之有。是都亡无句也。如是有此乃则有妄法之无。是未尝不立有句也。此就等者。即所离中无定性实有也。前据如是有者。即空之有不思议之有也。又前下显正义中三义也。一法者。一味无差别法也。二义即空有二门。随说无违者。互融相是不同空宗空。即是真有即为妄。清凉曰。性空通于初顿终教。妙有即是实教。若通于空有二互交彻。具德即是圆教。经以下第四明所得。此经大科有五。初则断疑以生信。次则显理令正解。三则起行而断惑。四明所得以显果。五乃叹法以赞德。是则当机禀教依修克证。一道始终。岂可但将所离一科断除众生情计。经家说示行者。令解理中无。此便谓说空。抑归权始不观此科。二转依果。无得而大得当机获益耶。然此所得若通论般若虽有权实。皆为三人所得。故经云。若有情类于声闻乘性决定者。闻此法已速能证得自无漏地。乃至于无上乘性决定者。闻此法已。速证无上正等菩提等。又疏主曰。般若亦为二乘。良以法华之前未经破会。通说三乘法。具获三乘益。今经虽唯说大兼断彼疑与其进也。于中二。初牒前起后二。初唱经。二判释言以下牒经科释也。前云无智亦无得故。今蹑为因行由是而得果。如是则前明所离。是断惑。今明所得。是证果也。清凉曰。无所得即般若相。由得般若无得智慧故方得也。故引大品无得而得。大品又云。以无所得而为方便。祖曰。若不住事理生死涅槃。则事理无碍之方便也。疏主曰。由观真空方成诸行。是故十度等行皆由空成。菩提等果皆由空立。是故从此真空无住建立诸法。又令诸法得相即相入。无障无碍等。并是此门之大用也。又无得者。要须足迹不存。荡然净扫。方云无得。清凉曰。非但相有性无而已。谓诸宗计多有此说。但空自性不空于法。如法相宗但无遍计非无依他。设学三论。不得意者亦云。法无自性故说为空。则令相不空矣。今无性缘生故有。有体即空缘生无性故空。空而常有要互交彻。方是真空妙有。其言大同而旨有异。政观以来尚不达此。经菩下二正明所得二。先明得断果二。初举人依法二。初唱经。二判释。言断果者。断所显故。明依等者。即依前无得般若智慧法行也。若无般若余度皆不到岸。经心下二断障得果三。初行成二。初唱经。二断下二作释。初科判。次牒释。行成者。总示。谓惑下别显。谓烦恼障障心。心不解脱故造业轮转。所知障障慧。慧不解脱故不了自心。不达诸法性相。纵出三界亦滞下乘不得成佛。今得般若深慧。二障种现俱亡得二解脱故。不碍等也。经无下二断障二。初唱经。二断下二作释。言魔冤之怖者。天魔外道现形以怖行者。广如起信本末论说。颠倒梦想者。生住异灭。疏主例释。以梦皆能眠。众生于我我所中而不觉知故。梦所见境无而谓有故。名颠倒。由本净心为无明所眠。梦于四相起诸烦恼。今得般若智。日破烦恼梦。了诸法空故。云恶因尽也。经究下三得果二。初唱经。三得下二作释。初翻梵成华。德无不备者。无住处大般涅槃。具足常等无尽德也。教兴中云。显佛胜德生净信故。今得菩提涅槃果故。不同无得。乃真佛德空也。祖文引此显佛德。空者。乃顺智光前记。已会障无不尽者。惑障本如无尽可尽。无断可断。简异下释究竟言。但简小乘顺慈恩三藏也。又释等者。非真流之行。无以契真未有适真之行。不从真起。今以即实相之观。照证彼即智之如。如珠发光光还自照。穷理尽性故名究竟。此据自宗释也。经三下二诸佛得智果二。初举人依法二。初唱经。二作释。经云。一门超出妙庄严路。经得下二正明得果二。初唱经。二正下二演释。初翻梵成唐。觉有下释义。如理智观真非行理外故。云正觉。如量智观俗。如彼性相遍观察故。故云等觉至极。无边者。得一切种智。过彼下乘下位故。无有上。上来下结也。经故下大文第五结叹胜能。二先别叹胜德二。初唱经。二演释二。初牒前起后。由佛下显经意。叹其下二略叹四德三。一就法释。二约功能释。行满故无有过上。德圆故与无等齐等也。三就下三就位释。引论中比余下释无等字。重言等下。释后等言也。经能下二总结胜能二。初唱经。二总下二作释变易者。方便生死因缘生死。有有生死无有生死也。上来下二结分齐。经故下二秘密般若二。初牒前起后二。初唱经。自下下二判释。言前云者。牒前未显下起后也。然前科结叹。叹前显了。今云尔者。经意多含贯前通后也。经羯下二正说咒辞。二正下二疏语二。初理不可释。是诸等者。以诸佛心印下位不测故不须释。二若下二应机强释。疏主应郑公之请。而强释也。然虽云秘密不可说。有因缘故亦可无言而言。如文殊五字咒。而般若等经大智度论皆有解释。智论曰。阿字是实相门则显三种般若。不相舍离字即名字般若。入般若波罗蜜门即观照般若。悟不生等即实相般若。大品云。阿字门一切法初不生故。智论释云。若菩萨一切诸法中闻阿字即时随义。所谓一切法从初来不生相。以阿提秦言初故。阿耨波陀秦言不生故。大品云。啰字悟一切法离尘垢故。论云。若闻啰字即随义知一切法离垢相。以啰阇秦言垢故。大品云。波者第一义故。论云。若闻波字即知一切法入第一义。以波罗末陀秦言第一义故。大品云遮字修不可得。论云。若闻遮字即时知。一切法。诸行皆悉非行。以遮利夜秦言行故。大品云。那字门诸法离名性相不得不失故。论云。若闻那字即知一切法不得不失不来不去。以那秦言不故。故知不因缘亦可强释。三庆赞回向般若深邃赞也。累劫难逢庆今逢也。随分赞释谦也。冀会真宗回向实际也。而言真宗者。谓般若真宗亦佛法大宗也

般若心经疏连珠记下(终)

心经疏者。乃唐贤首国师。于译场中应郑公之请。而作也。其文约其旨微。故述钞之家尤为难能。慧因华严法师。独明幽趣颖迈常谭。每苦旧章颇乖疏意。一日俯从众请。爰出新记。名曰连珠。盖取诸祖遗训以为指南。经论格言而作程式。钩索深隐诒厥方来。俾令慧炬相然。则其功岂不懋矣。时皇宋乾道龙集乙酉中秋既望。沙门慧诜题

般若心经略疏连珠记下(终)


本愿药师经古迹

    No. 1770 [cf. No. 450]

本愿药师经古迹上

        青丘沙门太贤撰

药师琉璃光如来本愿功德经　此经略以三门分别。一者题名。二者教摄。三者本文。一题名者经有三名。一说药师琉璃光如来本愿功德经。二说十二神将饶益有情结愿神咒。三说拔除一切业障。此中宋孝武世大明元年译出之本取第三名拔除过罪生死得度。隋大业十一年东都洛水南上林园翻经馆译略取初名药师如来本愿经。今大唐贞观年中玄奘三藏所译之本具取初名题一部也。文义广略后二相似。言药师琉璃光如来所归人也。本愿功德者所感德也。能拔众苦喻名药师。无缘不彻称琉璃光。所修妙行名为本愿。所证胜果名为功德。即以如来因果为宗。劝物归依出苦为趣。是以初名题宗为称。后二之名以趣为号。经谓契经能诠名也。与义相应贯持法器令不散失故言契经。药师如来之本愿功德。本愿功德之契经。故六合释中依主释也。二教摄者。南地师云。佛教有三。一顿二渐三偏方不定教。初二如常。今药师经第三教摄。随缘局说异顿渐故。此不应理。以顿渐外无别悟故。勿离大小有别教故。既对曼殊直说大乘因果德故所说顿教。又说净土无覆相故。第三了义大乘教摄。三本文者经

如是我闻一时薄伽梵游化诸国至广严城住乐音树下与大苾刍众八千人俱菩萨摩诃萨三万六千及国王大臣婆罗门居士天龙夜叉人非人等无量大众恭敬围绕而为说法

述曰。本文有三。一说经因起分。二对问广说分。三闻名喜行分。此初也。如是我闻等如常应知。薄伽梵者含六义名。一自在义。永不系属诸烦恼故。二炽盛义。猛焰智火所烧练故。三端严义。众妙相好所庄严故。四名称义。功德圆满无不知故。五吉祥义。亲近供养必获利故。六尊贵义。具诸功德利乐有情无懈怠故。如佛地论颂曰　自在炽盛与端严　名称吉祥及尊贵　如是六种义差别　应知总名为薄伽　言广严者梵云毗舍离或云毗耶离。表众德满至广严城。示生物乐住乐音树。微风历动宫商雅音从而出故名乐音树。众有三种。一声闻众二菩萨众三世间众。如文可解。就中居士居家士也。夜叉可畏或威势义

尔时曼殊室利法王子承佛威神从座而起偏袒一肩右膝着地向薄伽梵曲躬合掌白言世尊唯愿演说如是相类诸佛名号及本大愿殊胜功德令诸闻者业障消除为欲利乐像法转时诸有情故

述曰。自下对问广说分。此有五义。一菩萨请问成就。二法王赞许成就。三大众乐闻成就。四如来说法成就。五夜叉报恩成就。此初也。于此有三。一请因缘门。如经曼殊室利法王子承佛威神故。曼殊室利唐云妙吉祥。从法化生得佛法分称法王子。二请威仪门。如经从座而起乃至合掌故。从座而起者表从真际起。偏袒一肩者表作利乐事。右膝着地住世间故。向薄伽梵者趣出世故。曲躬者离慢故。合掌者专心故。三正开请门。如经白言世尊乃至诸有情故故。略问三事。一问佛名号。二问因大愿。三问果功德。令诸闻者已下举说之利。言像法转时者。大集经云有六种坚固。一法身得住坚固。二解脱得住坚固。三禅定得住坚固。四多闻得住坚固。五福德得住坚固。六斗诤得住坚固。此中初一佛在世时。后五灭后。如其次第各五百年。总言三时。一者正法。谓彼五中初二坚固。二者像法。即次二坚固。三者末法。即后一坚固。如次具有教行果三。有二无果。有教无二。今为利乐千年之后像法有情发此问也

尔时世尊赞曼殊室利童子言善哉善哉曼殊室利汝以大悲劝请我说诸佛名号本愿功德为拔业障所缠有情利益安乐像法转时诸有情故汝今谛听极善思惟当为汝说曼殊室利言唯然愿说我等乐闻

述曰。此中有二。一法王赞许成就。如经尔时世尊乃至当为汝说故。所闻可记初言善哉。应时宜故重言善哉。欲令审文故言谛听。令解义故言善思惟。二大众乐闻成就。如经曼殊室利言唯然愿说我等乐闻故

佛告曼殊室利东方去此过十殑伽沙等佛土有世界名净琉璃佛号药师琉璃光如来应正等觉明行圆满善逝世间解无上丈夫调御士天人师佛薄伽梵

述曰。第四如来说法成就。此有二门。一正答所请门。二劝物利益门。初亦有三。答三问故。此初也。广释十号如瑜伽等

曼殊室利彼世尊药师琉璃光如来本行菩萨道时发十二大愿令诸有情所求皆得

述曰。答第二问中有三。略标广说总结故。此初也。阿修罗经云。琉璃光菩萨遇智胜佛初发总愿。宝顶佛所始发别愿。十方诸佛现前经云。青龙光佛所发十二誓愿

第一大愿愿我来世得阿耨多罗三藐三菩提时自身光明炽然照曜无量无数无边世界以三十二大丈夫相八十随好庄严其身令一切有情如我无异第二大愿愿我来世得菩提时身如琉璃内外明彻净无瑕秽光明广大功德巍巍身善安住焰网庄严过于日月幽冥众生悉蒙开晓随意所趣作诸事业第三大愿愿我来世得菩提时以无量无边智慧方便令诸有情皆得无尽所受用物莫令众生有所乏少第四大愿愿我来世得菩提时若诸有情行邪道者悉令安住菩提道中若行声闻独觉乘者皆以大乘而安立之第五大愿愿我来世得菩提时若有无量无边有情于我法中修行梵行一切皆令得不缺戒具三聚戒设有毁犯闻我名已还得清净不堕恶趣第六大愿愿我来世得菩提时若诸有情其身下劣诸根不具丑陋顽愚盲聋喑哑踤躄背偻白癞癫狂种种病苦闻我名已一切皆得端政黠慧诸根完具无诸疾苦第七大愿愿我来世得菩提时若诸有情众病逼切无救无归无医无药无亲无家贫穷多苦我之名号一经其耳众病悉除身心安乐家属资具悉皆丰足乃至证得无上菩提。第八大愿愿我来世得菩提时若有女人为女百恶之所逼恼极生厌离愿舍女身闻我名已一切皆得转女成男具丈夫相乃至证得无上菩提第九大愿愿我来世得菩提时令诸有情出魔罗网解脱一切外道缠缚若堕种种恶见稠林皆当引摄置于正见渐令修习诸菩萨行速证无上正等菩提第十大愿愿我来世得菩提时若诸有情王法所绳缚录鞭挞系闭牢狱或当刑戮及余无量灾难陵辱悲愁煎迫身心受苦若闻我名以我福德威神力故皆得解脱一切忧苦第十一大愿愿我来世得菩提时若诸有情饥渴所恼为求食故造诸恶业得闻我名专念受持我当先以上妙饮食饱足其身后以法味毕竟安乐而建立之第十二大愿愿我来世得菩提时若诸有情贫无衣服蚊虻寒热昼夜逼恼若闻我名专念受持如其所好即得种种上妙衣服亦得一切宝庄严具华鬘涂香鼓乐众伎随心所玩皆令满足

述曰。广说门中有六对门。一饶益净秽门。即初二愿。净土一切如我身故。乃至世界中间幽冥众生皆逐意故。二世出世间门。即次二愿。以人天乘无所乏故。乃至行邪道者。随其种姓安住三乘菩提道中。不定二乘皆以大乘而安立故。三存戒存身门。即次二愿。不缺重戒具三聚故。六根之身皆得净故。此中下劣不具标句也。虽具诸根不胜妙故。及有缺故。言丑陋者释身下劣。言顽愚者释意下劣。盲聋等下释眼耳舌身根不具。癫狂释意根不具。种种病苦摄鼻等病。端正等四如次翻上。四除内外苦门。即次二愿。一能除外缘逼切苦。无救者标无医药也。无归者标无亲等也。今得佛医法药圣财故除病等乃至丰足。二能转内缘女身苦。如涅槃经。一切女人皆是众恶之所住处。五内外解缚门。即次二愿。摄置正见解恶见缚。证无上道出魔罥故。以威神力出刑缚故。六志食与衣门。即次二愿。以食法味而建立故。以妙衣等而令满足故

曼殊室利是为彼世尊药师琉璃光如来应正等觉行菩萨道时所发十二微妙上愿

述曰。总结也

复次曼殊室利彼世尊药师琉璃光如来行菩萨道时所发大愿及彼佛土功德庄严我若一劫若一劫余说不能尽然彼佛土一向清净无有女人亦无恶趣及苦音声琉璃为地金绳界道城阙宫阁轩窗罗网皆七宝成亦如西方极乐世界功德庄严等无差别于其国中有二菩萨摩诃萨一名日光遍照二名月光遍照是彼无量无数菩萨众之上首悉能持彼世尊药师琉璃光如来正法宝藏是故曼殊室利诸有信心善男子善女人等应当愿生彼佛世界

述曰。答后问也。于中有二。初本处庄严功德成就。后外方闻名功德成就。此初也。言所发大愿佛土庄严说不能尽者。显如大愿果亦无边。身应准愿。略说其土则有八种功德成就。一无所著秽成就。如经无有女人故。二离所怖恶成就。如经亦无恶趣及苦音声故。三所依清净成就。如经琉璃为地故。四道路成文成就。如经金绳界道故。五宫殿庄严成就。如经亦如西方故。六大圣无绝成就。如经有二菩萨即补处故。七利乐不断成就。如经悉持彼佛正法藏故。八愿生无碍成就。如经应当愿生彼佛世界故

尔时世尊复告曼殊室利童子言曼殊室利有诸众生不识善恶唯怀贪吝不知布施及施果报愚痴无智阙于信根多聚财宝勤加守护见乞者来其心不喜设不获已而行施时如割身肉深生痛惜复有无量悭贪有情积集资财于其自身尚不受用何况能与父母妻子奴婢作使及来乞者彼诸有情从此命终生饿鬼界或傍生趣由昔人间曾得暂闻药师琉璃光如来名故今在恶趣暂得忆念彼如来名即于念时从彼处没还生人中得宿命念畏恶趣苦不乐欲乐好行惠施赞叹施者一切所有悉无贪惜渐次尚能以头目手足血肉身分施来求者况余财物

述曰。此即第二外方闻名功德成就。于中有五。令诸闻者除施戒修十善业道往生乐处五种障故。今此初段显除施性福业障。此有三门。一显障自性门。如经不识善恶乃至来乞者故。不识恶者唯贪吝故。不识善者不知施故。不识善恶也。愚痴无智唯怀贪吝故。阙于信根不知施等故。多聚不舍。二示障过患门。如经彼诸有情生鬼畜故。以悭贪故生饿鬼界。以愚痴故生傍生趣。三闻佛胜利门。如经由昔人间乃至况余财物故

复次曼殊室利若诸有情虽于如来受诸学处而破尸罗有虽不破尸罗而破轨则有于尸罗轨则虽得不坏然毁正见有虽不毁正见而弃多闻于佛所说契经深义不能解了有虽多闻而增上慢由增上慢覆蔽心故自是非他嫌谤正法为魔伴党如是愚人自行邪见复令无量俱胝有情堕大险坑此诸有情应于地狱傍生鬼趣流转无穷若得闻此药师琉璃光如来名号便舍恶行修诸善法不堕恶趣设有不能舍诸恶行修行善法堕恶趣者以彼如来本愿威力令其现前暂闻名号从彼命终还生人趣得正见精进善调意乐便能舍家趣于非家如来法中受持学处无有毁犯正见多闻解甚深义离增上慢不谤正法不为魔伴渐次修行诸菩萨行速得圆满

述曰。此显能除戒性福业障。此亦三门。如前应知。初门有三。一摄律仪戒障。如经破尸罗轨则故。言尸罗者别解脱戒。言轨则者于往来等正知而住。二摄善法戒障。如经毁正见弃多闻增上慢故。三摄有情戒障。如经复令无量俱胝有情堕大险坑故。次示障过患门者。如经于地狱等流转无穷故。后闻佛胜利门者。如经乃至三聚速圆满故

复次曼殊室利若诸有情悭贪嫉妒自赞毁他当堕三恶趣中无量千岁受诸剧苦受剧苦已从彼命终来生人间作牛马驼驴恒被鞭挞饥渴逼恼又常负重随路而行或得为人生居下贱作人奴婢受他驱役恒不自在若昔人中曾闻世尊药师琉璃光如来名号由此善因今复忆念至心归依以佛神力众苦解脱诸根聪利智慧多闻恒求胜法常遇善友永断魔罥破无明谷竭烦恼河解脱一切生老病死忧悲苦恼

述曰。此显能除修性福业障。亦有三门。一显障自性门。如经悭贪嫉妒自赞毁他故。此中悭贪能障修慈。不与乐故。嫉妒障喜。不随喜故。赞毁障悲。能恼害故。三通障舍性。染污故。语便次第故不相违。二示障过患门者。如经堕三恶趣及受苦故。三闻佛胜利门者。如经乃至永破四种魔故。如文可解

复次曼殊室利若诸有情好喜乖离更相斗讼恼乱自他以身语意造作增长种种恶业展转常为不饶益事互相谋害告召山林树冢等神杀诸众生取其血肉祭祀药叉逻刹婆等书怨人名作其形像以恶咒术而咒咀之厌媚蛊道咒起尸鬼令断彼命及坏其身是诸有情若得闻此药师琉璃光如来名号彼诸恶事悉不能害一切展转皆起慈心利益安乐无损恼意及嫌恨心各各欢悦于自所受生于喜足不相侵淩互为饶益

述曰。此显能除十善业道障。亦有三门。初障自性者。如经好喜乖离乃至增长种种恶业故。好喜乖离意三业道悉能令他离所欲故。更相斗讼语四业道理不相应多招诤故。恼乱自他身三业道三业果遂即恼乱他。若不果遂恼乱自故。二障过患者。谓由自恶招他谋害。如经展转常为不饶益事乃至咒起尸鬼断坏身命故。三胜利门者。现尚离害。况于当苦。文显可知

复次曼殊室利若有四众苾刍苾刍尼邬波素迦邬波斯迦及余净信善男子善女人等有能受持八分齐戒经一年或复三月受持学处以此善根愿生西方极乐世界无量寿佛所听闻正法而未定者若闻世尊药师琉璃光如来名号临命终时有八菩萨乘神通来示其道路即于彼界种种杂色众宝华中自然化生或有因此生于天上虽生天中而本善根亦未穷尽不复更生诸余恶趣天上寿尽还生人间或为轮王统摄四洲威德自在安立无量百千有情于十善道或生刹帝利婆罗门居士大家多饶财宝仓库盈溢形相端严眷属具足聪明智慧勇健威猛如大力士若是女人得闻世尊药师如来名号至心受持于后不复更受女身

述曰。此显能除往生乐处障。此复有二。第一显除净处乐生障。如经生极乐世界故。此中受持八分齐戒经年月者。迈师云。经一年者谓一年中月别六日。谓黑白月各八十四十五日故。或三月者不能一年月别六斋。但能一年持三长月。谓即正月五月九月三除之中各初月斋即表一年常修善也。如宋本云常修月六斋年三长斋故。智论十三云。斋日持八戒者。是日恶鬼逐人欲夺人命。劫初圣人教人持斋。然不受八戒直以一日不食为斋。后佛出世制立八戒。问五戒八戒何者为胜。答有因缘故二戒俱等。以时及支互多少故。问十念称名尚得往生。况令一年何故不定。答勇猛容豫有差别故。如智论云。临终心猛胜百年功。自然化生者。如涅槃经。庵罗树女因树华生名为湿生。净土因华何名化生。迈师云。未托生前树有湿气。净土莲华与人化生。第二能除秽土乐生障。如经或有因此生于天上等故。此复有四。生天轮王贵胜男身。如文可解

本愿药师经古迹上(终)本愿药师经古迹下

药师琉璃光如来本愿功德经

尔时曼殊室利童子白佛言世尊我当誓于像法转时以种种方便令诸净信善男子善女人等得闻世尊药师琉璃光如来名号乃至睡中亦以佛名觉悟其耳世尊若于此经受持读诵或复为他演说开示若自书若教人书恭敬尊重以种种华香涂抹香烧香华鬘璎珞幡盖伎乐而为供养以五色彩作囊盛之扫洒净处敷设高座而用安处尔时四大天王与其眷属及余无量百千天众皆诣其所供养守护世尊若此经宝流行之处有能受持以彼世尊药师琉璃光如来本愿功德及闻名号当知是处无复横死亦复不为诸恶鬼神夺其精气设已夺者还得如故身心安乐

述曰。大段第二劝物利益门。此有五门。一誓愿警觉门。如经我当誓于像法转时方便令闻如来名号由于此经受持供养天众守护无灾横故

佛告曼殊室利如是如是如汝所说曼殊室利若有净信善男子善女人等欲供养彼世尊药师琉璃光如来者应先造立彼佛形像敷清净座而安处之散种种华烧种种香以种种幢幡庄严其处七日七夜受八分斋戒食清净食澡浴香洁着新净衣应生无垢浊心无怒害心于一切有情起利益安乐慈悲喜舍平等之心鼓乐歌赞右绕佛像复应念彼如来本愿功德读诵此经思惟其义演说开示随所乐愿一切皆遂求长寿得长寿求富饶得富饶求官位得官位求男女得男女若复有人忽得恶梦见诸恶相或怪鸟来集或于住处百怪出现此人若以众妙资具恭敬供养彼世尊药师琉璃光如来者恶梦恶相诸不吉祥皆悉隐没不能为患或有水火刀毒悬崄恶象师子虎狼熊罴毒蛇恶蝎蜈蚣蚰蜒蚊虻等怖若能至心忆念彼佛恭敬供养一切怖畏皆得解脱若他国侵扰盗贼反乱忆念恭敬彼如来者亦皆解脱复次曼殊室利若有净信善男子善女人等乃至尽形不事余天唯当一心归佛法僧受持禁戒若五戒十戒菩萨四百戒苾刍二百五十戒苾刍尼五百戒于所受中或有毁犯怖堕恶趣若能专念彼佛名号恭敬供养者必定不受三恶趣生或有女人临当产时受于极苦若能至心称名礼赞恭敬供养彼如来者众苦皆除所生之子身分具足形色端正见者欢喜利根聪明安稳少病无有非人夺其精气

述曰。此即第二如来述成门。于中有二。初明供养后说获益。供养有三。一财物供养。如经造立形像乃至庄严其处故。二正行供养。如经七日受戒乃至平等之心故。三三业供养。如经鼓乐歌赞乃至演说开示故。获益有三。一所求称遂门。如经随所乐愿乃至得男女故。二所厌消灭门。如经若复有人乃至亦皆解脱故。三毁戒离苦门。于中有二。一现身毁戒。畏当苦故。如经复次曼殊乃至不受三恶趣生故。此中菩萨四百戒者。良由如来随物宜闻广略说故开合不同。方等经说四重二十八轻。瑜伽论说四重四十五轻。梵网经说十重四十八轻。有不同故。然此一本宋译云二十四戒。隋译云一百四戒。诸梵本者有不同故。二前身毁戒。受女产苦故。如经或有女人乃至夺其精气故

尔时世尊告阿难言如我称扬彼佛世尊药师琉璃光如来所有功德此是诸佛甚深行处难可解了汝为信不阿难白言大德世尊我于如来所说契经不生疑惑所以者何一切如来身语意业无不清净世尊此日月轮可令堕落妙高山王可使倾动诸佛所言无有异也世尊有诸众生信根不具闻说诸佛甚深行处作是思惟云何但念药师琉璃光如来一佛名号便获尔所功德胜利由此不信返生诽谤彼于长夜失大利乐堕诸恶趣流转无穷佛告阿难是诸有情若闻世尊药师琉璃光如来名号至心受持不生疑惑堕恶趣者无有是处阿难此是诸佛甚深所行难可信解汝今能受当知皆是如来威力阿难一切声闻独觉及未登地诸菩萨等皆悉不能如实信解唯除一生所系菩萨阿难人身难得于三宝中信敬尊重亦难可得得闻世尊药师琉璃光如来名号复难于是阿难彼药师琉璃光如来无量菩萨行无量巧方便无量广大愿我若一劫若一劫余而广说者劫可速尽彼佛行愿善巧方便无有尽也

述曰。此第三毁信损益门。此有四门。一佛语决定门。如经如我称扬乃至诸佛所言无有异也故。二毁谤衰损门。如经有诸众生乃至流转无穷故。三敬信获益门。如经佛告阿难乃至堕恶趣者无有是处故。四劝物信受门。如经阿难乃至无有尽也故

尔时众中有一菩萨摩诃萨名曰救脱即从座起偏袒一肩右膝着地曲躬合掌而白佛言大德世尊像法转时有诸众生为种种患之所困厄长病羸瘦不能饮食喉唇干燥见诸方暗死相现前父母亲属朋友知识啼泣围绕然彼自身卧在本处见琰魔使引其神识至于琰魔法王之前然诸有情有俱生神随其所作若罪若福皆具书之尽持授与琰魔法王尔时彼王推问其人算计所作随其罪福而处断之时彼病人亲属知识若能为彼归依世尊药师琉璃光如来请诸众僧转读此经燃七层之灯悬着五色续命神幡或有是处彼识得还如在梦中明了自见或经七日或二十一日或三十五日或四十九日彼识还时如从梦觉皆自忆知善不善业所得果报由自证见业果报故乃至命难亦不造作诸恶之业是故净信善男子善女人等皆应受持药师琉璃光如来名号随力所能恭敬供养

述曰。此是第四开像资助门。此有二门。一资助所为门。二资助胜利门。初所为者。如经像法转时乃至而处断之故。言琰魔者唐云静息。晓悟罪人止众恶故。即由此义虽鬼界摄亦名法王。谓由业力病人意识现四相分。一琰魔使。二已神识。三琰魔王。四俱生神。传说本识与身故名俱生神。能熏习言具书持。表于法王故言授与。由业威力似神相现。如净土三昧经云。同生同名一神俱生。二资助胜利门者。如经时彼病人乃至诸恶之业故。此中资缘有五。归佛请僧转法燃灯及悬幡故。灯者明也。幡者将也。救闇沈故须幡灯也。七层五色者无说所以。若以义推。伏七支罪。调五方故。或有是处彼识得还者。为简定业故言或有。言或经七日乃至四十九日者。拟中有命。七日住故。然其后三隔二七说。为显据实不离身故。传者皆言其实神识未曾离身

尔时阿难问救脱菩萨曰善男子应云何恭敬供养彼世尊药师琉璃光如来续命幡灯复云何造救脱菩萨言大德若有病人欲脱病苦当为其人七日七夜受持八分斋戒应以饮食及余资具随力所辩供养苾刍僧昼夜六时礼拜供养彼世尊药师琉璃光如来读诵此经四十九遍燃四十九灯造彼如来形像七躯一一像前各置七灯一一灯量大如车轮乃至四十九日光明不绝造五色彩幡长四十九搩手应放杂类众生至四十九可得过度危厄之难不为诸横恶鬼所持复次阿难若刹帝利灌顶王等灾难起时所谓人众疾疫难他国侵逼难自界叛逆难星宿变怪难日月薄蚀难非时风雨难过时不雨难彼刹帝利灌顶王等尔时应于一切有情起慈悲心赦诸系闭依前所说供养之法供养彼世尊药师琉璃光如来由此善根及彼如来本愿力故令其国界即得安稳风雨顺时谷稼成熟一切有情无病欢乐于其国中无有暴恶药叉等神恼有情者一切恶相皆即隐没而刹帝利灌顶王等寿命色力无病自在皆得增益阿难若帝后妃主储君王子大臣辅相中宫婇女百官梨庶为病所苦及余厄难亦应造立五色神幡燃灯续明放诸生命散杂色华烧众名香病得除愈众难解脱

述曰。自下第五问答释难门。于中有二。一问答故。二释难故。此初也。答中有二。初约病难答。如经救脱菩萨言乃至广说故。此中所说就其边际设不具足非无胜利。如前经言随力所能而供养故。法社经云。贫者一灯亦得成故。各置七灯者。迈师云。像前一座造七轮灯形如车轮。一一像座前各置一轮灯。一一轮上各安七盏灯。后约国难答。此复有二。国界难故。眷属难故。如经复次阿难乃至众难解脱故。非但病人亦济王难。此中意也。国有七难。如文可解。灌顶王者。最大国主上位之时诸小国王及诸群臣各取四大海水灌其顶故。言国界安稳者。第二三难除故。风雨谷顺者。第六七难除故。无病无神者。初难除故。恶相隐没者。第四五难除故。王眷属难如文可解

尔时阿难问救脱菩萨言善男子云何已尽之命而可增益救脱菩萨言大德汝岂不闻如来说有九横死邪是故劝造续命幡灯修诸福德以修福故尽其寿命不经苦患阿难问言九横云何救脱菩萨言有诸有情得病虽轻然无医药及看病者设复遇医授以非药实不应死而便横死又信世间邪魔外道妖[薛/女]之师妄说祸福便生恐动心不自正卜问觅祸杀种种众生解奏神明呼诸魍魉请乞福祐欲冀延年终不能得愚痴迷惑信邪倒见遂令横死入于地狱无有出期是名初横二者横被王法之所诛戮三者畋猎嬉戏耽淫嗜酒放逸无度横为非人夺其精气四者横为火焚五者横为水溺六者横为种种恶兽所啖七者横堕山崖八者横为毒药厌祷咒咀起尸鬼等之所中害九者饥渴所困不得饮食而便横死是为如来略说横死有此九种其余复有无量诸横难可具说复次阿难彼琰魔王主领世间名藉之记若诸有情不孝五逆破辱三宝坏君臣法毁于信戒琰魔法王随罪轻重考而罚之是故我今劝诸有情燃灯造幡放生修福令度苦厄不遭众难

述曰。此即释难门。于中有五。一难二决三征四解五结。决意者九种横死皆不定业宿业相似等流果故。若有助福得延长故。言终不能得者。夫杀生短命食肉病多。而断他命延已寿乎。得病虽轻损灭寿业横死入狱。此中意也。结意者。若不延命属琰魔故。文相可知

尔时众中有十二药叉大将俱在会坐所谓宫毗罗大将伐折罗大将迷企罗大将安底罗大将頞尔罗大将珊底罗大将因达罗大将波夷罗大将摩虎罗大将真达罗大将招杜罗大将毗羯罗大将此十二药叉大将一一各有七千药叉以为眷属同时举声白佛言世尊我等今者蒙佛威力得闻世尊药师琉璃光如来名号不复更有恶趣之怖我等相率皆同一心乃至尽形归佛法僧誓当荷负一切有情为作义利饶益安乐随于何等村城国邑空闲林中若有流布此经或复受持药师琉璃光如来名号恭敬供养者我等眷属卫护是人皆使解脱一切苦难诸有愿求悉令满足或有疾厄求度脱者亦应读诵此经以五色缕结我名字得如愿已然后解结尔时世尊赞诸药叉大将言善哉善哉大药叉将汝等念报世尊药师琉璃光如来恩德者常应如是利益安乐一切有情

述曰。此下第五药叉大将获益报恩成就。此中有三。初经家列名。次药叉誓愿。后如来赞许。文相可知

尔时阿难白佛言世尊当何名此法门我等云何奉持佛告阿难此法门名说药师琉璃光如来本愿功德亦名说十二神将饶益有情结愿神咒亦名拔除一切业障应如是持时薄伽梵说是语已诸菩萨摩诃萨及大声闻国王大臣婆罗门居士天龙药叉健达缚阿素洛揭路罗紧奈洛莫呼洛伽人非人等一切大众闻佛所说皆大欢喜信受奉行

述曰。此下第三闻名喜行分。言应如是持者答第二问。应如三名所诠之法而受持故

药师琉璃光如来本愿功德经

本愿药师经古迹下(终)


大般涅槃经集解

    No. 1763 [cf. No. 375]

大般涅槃经集解卷第一(序经题)

皇帝为灵味寺释宝亮法师制义疏序　道生法师　僧亮法师　法瑶法师　昙济法师　僧宗法师　宝亮法师　智秀法师　法智法师　法安法师　昙准法师

此十法师经题序。今具载略标。序中要义。八科如左

  释名第一　辨体第二　叙本有第三　谈绝名第四　释大字第五　解经字第六　核教意第七　判科段第八

    大般涅槃经义疏序(明骏案谨写　皇帝为灵味释宝亮法师制)

非言无以寄言。言即无言之累。累言则可以息言。言息则诸见竞起。所以如来乘本愿以托生。现慈力以应化。离文字以设教。忘心相以通道。欲使玟玉异价泾渭分流。制六师而正四倒。反八邪而归一味。析世智之角。杜异人之口。导求珠之心。开观豢之日。救烧灼于火宅。拯沉溺于浪海。故法雨降而燋种受荣。慧日升而长夜蒙晓。发迦叶之悱愤。吐真实之诚言。虽复二施等于前。五大陈于后。卅四问。参差异辨。方便劝引。各随意答。举要论经。不出两途。佛性开其有本之源。涅槃明其归极之宗。非因非果。不起不作。义高万善。事绝百非。空空不能测其真际。玄玄不能穷其妙门。自非德均平等。心合无生。金墙玉室。岂易入哉。有青州沙门释宝亮者。气调爽拔。神用俊举。少负苦节。长安法忍。耆年愈笃。倪齿不衰。流通先觉。孳孳如也。后生晚进。莫不依仰。以天监八年五月八日。敕亮撰大涅槃义疏。以九月廿日讫。光表微言。赞扬正道。连环既解。疑网云除。条流明悉。可得略言。朕纵名暇日。将欲览焉。聊书数行。以为记莂云

案。道生曰。夫真理自然。悟亦冥符。真则无差。悟岂容易。不易之体。为湛然常照。但从迷乖之。事未在我耳。苟能涉求。便反迷归极。归极得本。而似始起。始则必终。常以之昧。若寻其趣。乃是我始会之。非照今有。有不在今。则是莫先为大。既云大矣。所以为常。常必灭累。复曰般泥洹也。般泥洹者。正名云灭。取其义训。自复多方。今此经明常。使伏其迷。其迷永伏。然后得悟。悟则众迷斯灭。以之归名其唯常说乎。又菩萨住斯经者。则已伏灭诸累。虽未造极。便能示般泥洹。众示无妙泥洹。复以无不示为大也。更用兹称经。盖是重美尽善矣

案。僧亮曰。此是如来神道之极号。常乐八味之都名。涅槃是异俗之音。音有楚夏。前后互出。乃有三名。谓泥洹。涅槃。泥曰。言涅槃者。中正天竺之音也。名含众义。此方无一名译之。存其胡本焉。般涅言不。亦名为无。槃者名生。名灭。名因。名相也。生是八苦之本。佛既无之。不生也。寿与太虚等量。不灭也。不从作因得。故无因也。体无十相。无相也。无学地法。皆是其体。略说三相。以标神道。一般若。二法身。三解脱谈般若。则三达之功显。论法身。则应化之理同。言解脱。则众德所以备也。语此三法。足明神道之极矣。大者明其常故。亦以大我大乐大净故。后有释也。如来始自道场。终于双树。凡三说涅槃。二是方便。一真实也。初开三究竟。是一方便。但说解脱。是涅槃。而身智是有为也。二方便中。说法华破三究竟。而身智故。是有为耳。今双树之说。身智即涅槃。谓究竟无余之说也。经者。胡音修多罗。修多罗名含五义也

案。法瑶。夫涅槃者。盖穷原之宗会。数尽之大归。其为体也。妙绝于有无之域。玄越于名数之分。言之不能尽称之不能讫。然非称无以拟极。故寄称以拟之非言无以显实。故因言以显之。其为目也。总莫之大。故称苞众理。名冠众义。故曰一名之中。有无量名也。是则宗音。无以译其称。晋言无以代其号。故欲以此音而当者。失其旨。此名而对者。乖其致。是为有称之极言。犹不能究。况无称之极乎。是以涅槃至号。其义赡博。折而辨之。则弥论无穷。岂唯般若等三。以极其致。但略而举其要者。是以径此三名。入于涅槃。伊字之譬。不亦宜手。然则此三。名殊而实同。非体异者也。如其体别。则涅槃同于因成假名法也。虚而非实。岂得称曰常乐者哉

案。昙济。夫大涅槃者。盖是大圣神道之极号。八味之都名。此是垂终之道教。放言异唱。故制名不同。成天竺之音。义有苞含。此方无一言以当之。故推义不一。亦言无生。复云无灭。亦言无为。亦言无相。所以言无生者。永绝于四生。所以言无灭者。量齐太虚。故称无灭。所以言无为者。不为生灭之所为。故言无为所以言无相者。体绝十相。故言无相也。涅槃者。敢无学地诸功德。尽为涅槃体也。略举三事。以称遂焉。三事者。般若法身解脱。语般若。明智周万境。辨法身。明备应万形。称解脱。明众累不生。智周万境。故三达之功显。备应万形。故能殊方并应。众累不生。明神道苞含。所以成也。所言大者。有大我故。下有文言。譬如有一秘方。摄一切方。此经亦尔。多有苞含。所以尔者。从于鹿野。终于双树。凡三说涅槃。一明初鹿野说。三乘各有别涅槃。二明三乘同一涅槃。三明真教。破二方便。说身智即涅槃。以是故。多有所含。故称为大。经者。胡言修多罗。含有五义。一能生。二微发。三涌泉。四绳墨。五华鬘。或以文为经。或以理为经。或四十卷文字。尽为经体。所以言能生者。此文行者寻求。能生善根也。所以言微发者。善根渐增。如初以三归。次以五戒。如是乃至得道。故有微发之义也。所以言涌泉者。譬文表理。不可穷尽。故如泉也。所以言绳墨者。绳本辨木曲直。明此经辨耶正之理。依文可知。故知绳墨也。所以言结鬘者。华散在地。不为人用。以綖贯穿。以成人首饰。若不以綖贯。不为人用。明若不以文辨理。于人无用。以文辨理。于人有用。故如綖也。虽有此义。今言经。五义之中一也。得结鬘义也

案。僧宗曰。此累尽之都名。万善之极称也。大者一谓教大。二谓理大。何者。始于鹿园。讫至法华。辨因果未满。明境行不周。所以为小。此教圆备。所以称大也。昔三乘涅槃。非实究竟。是道理中小。今明法身般若。在乎众累之外。是道理中大。所以言大也。涅槃者。天竺正音。此言解脱。谓脱于万累者也。累患既息。体备众德。今略举有三。可以贯众。一法身。二般若。三解脱也。妙有清净。体无非法。故言法也。妙体介然。异于太虚。故曰身也。澄神虚照。鉴无不周。故曰般若。道高万惑之表。体无垢累。故称解脱也。此三德者。体一而义异。一体之上。义目有三。而今所以唯录取解脱。以标经者。有三义。一明理在万惑之外。二者斥昔解脱。何者。以昔日小乘。患身智起动。求灭此患。情凭解脱。以身智俱尽。是孤解脱。故知小也。今日所明。体备众德。带法身般若。以常存故。以称大也。经者。谓三世诸佛。从凡至圣。莫不经由于此也

案。宝亮。夫至灵幽寂。体踰有无。凝照虚湛。妙过数表。其旨绝于生死。超有为于言境。故大觉垂悲。以被苦为本。但群品根异。则教成五别。犹物迷障重。未能安深。所以先开方便之说。资今圆常之旨也。众生既蒙昔教以习心。便稍涉虚以入道。体常无常。二轮双彻。鉴生死为不有之有。涅槃为不无之无。既安真而悟理。识苦空而断迷。自非修行入道发理缘之知。则烦惑不遣。生死难除。故今教之兴。开神明之妙体也。辨生死。以二苦为本。明涅槃。以常乐为源。妙质恒而不动。用常改而不毁。无名无相。百非不辨。今涅槃之音。就用而得称。是出世法之总名。贯众德之通号。代生死之要目。美无余之极说。障累既尽。万行归真。无德不满。众用皆足。转因字果。名大涅槃。故下文言。若一德不修。则不得称大涅槃也。然斯之语。乃是方土之音。圣既出于彼国。此亦无名以正翻。但文中训况指义释而已也。然其德渊旷。难可备举。今略陈其枢要。理可有三。故哀叹品明。谓正法宝城。及秘密藏也。二标别德。三寄功用。其义云何。夫涅槃无体。为众德所成。故取况宝城。喻于斯旨。非二乘所守。瓦砾而非宝也。既体备万工。亦何宝不满。但昔教未明。今说始彰。隐实显权。非秘密如何。二举别德者。功德品云。谓大常大我大乐净等。此是成涅槃之胜因。故据别而标美也。体无生灭。故称曰常。八用自在。谓之为我。寂然无苦。目之为乐。尘秽永尽。名之为净。体相无边。便名为大。此乃是赞叹之辞。裒美之称也。三叹其工用者。故师子吼品称谓。归依洲渚也。能使物免苦而永安。离河而登洲。越四流之渊海到无为之彼岸也。若寻其名用理数忘言。故圣化奖被谈德万端。是以就开宗之始。借喻于伊字云。三点不纵不横。异昔有余无德之说。明具法身般若解脱也。然此三乃化道边要。复贯通于诸德。亦表异因中之色心。显佛果之胜用。无感不应。称曰法身。嘱境皆明。谓之般若。即体无累。便名解脱。明一一之德。皆非涅槃。要总为其体。故下名字功德品中。借八味甜苏为叹也。谈真俗。两体本同。用不相乖。而闇去俗尽。伪谢真彰。朗然洞照故称为佛。此经既于出世法之中。开出世之教。引外凡之近资。接下愚之要道。斯理圆而益人。体无为而进德。但文博而旨幽。乃寄述于后释也。经者以经由为义。凡学者若不由此理教。则无容得解。故以经之一字。贯斯一部之文理也

案。智秀曰。斯盖圆极至德之总名也。若备称旧本。应云摩诃般涅槃那。夫道绝百非。而理归一致。归一致故。则有识斯成。绝百非故。则无言可极。然既因迹见名。亦寻名知本。但名迹之兴。乃肇自天竺。在我大梁。亦理应有称。而弘道之近。既发彰西域。未测此方。何以译翻。是以先贤后哲。皆修旧本。述而无作。故题之经首。体德名也。夫名以名体。体故有德。体者圆极妙有之本也。德者波若解脱之流也。谈德乃众。论体唯一。名虽有殊。实则无异。何者。即圆极之体有可轨之义。名为法身。有静照之功号为般若。有无累之德。称之解脱。是则解脱之体能照。亦能照之体解脱。更无别体。而有众德也。故以涅槃。总名冠目。圆体名总。体圆故。备含众义矣。下经文名字功德品。以众义释于名云。八味具足。名大涅槃。八味者。一常。二恒。三安。四清凉。五不老。六不死。七无垢。八快乐也寻此经致教之意。如来化始鹿园。旨穷鹫岳。唯明道极灰尽。善必菩提。未辨含情抱气。悉成无等。但说寿量长远。复倍上数。未明正觉虚凝。湛焉不灭。今此经者。以至极妙有为指南。常住佛性为宗致。明阐提。则正因无改。辨法身。则圆果嶷然。所谓无余之至教。究竟之极说也。经者经由义也。天竺以诠理文。总曰修多罗。修多罗者。备含众义。何者。如出生微发涌泉绳墨之流也。至于经由之义。亦其一耳。但梁之坟籍。皆以经为目。是以通方之士。简繁从略。举要而称焉。进不乖含总之一义。退且循俗而得简也

案。法智曰。夫言象生。自数内形名。起于累中。至人神道。既无象无言。岂复有其形名者哉。圆道不可以遍称。故以该德总名。强谓之涅槃。此天竺之音也。具存胡名。应言般涅槃那。外国此名有多义。兹土无音以反之。故存胡而名焉。既寄名为其名。寄有言乎而以言。言理者。亦是寄言也。若可寄言。请试言之。源涅槃为理。超注数之表。绝冥朕之外。语其幽彻。斯在于本有者也。所言本有。乃是玄指未来隔世为有耳。不言现在同世有也。若以未来为有。则禀识之类。源本未造因时。已自有之。故言本有也。若未造因时。本自有之。则不待业缘为其始。故非始造矣。既非始造。故说此未来。不同三世。要待造业。方得为有也。虽本自有之。然未来未起。已来用故。故须了因。然方应欲显其果体圆满具足。故为之置名。是则万德之义。无非涅槃义也。故始开伊字。便寄三德。以明涅槃。表异昔说也。何者。昔教以身智是有为。未脱果缚。须灭身智。始是无为说此灭法。为无为解脱也。若此灭法。可得说为解脱灭度无为乐净诸义。故对生死即说之。为无余涅槃也。是为昔说涅槃。亦有多义。但不得说身智耳。所以三事俱无也。今既无余极教。有异于昔。必须存三德。即身智而为解脱矣。存三德者。显三德一体。为涅槃法。法皆有德。为涅槃义也。三德体为涅槃法者。经言法名自体故。以体为法也。三德为涅槃义者。以三德在法。则法有三义。故三德义。皆为涅槃义也。言法身为涅槃义者。法以法则为用。身是体之异名。良以。其体可法。故名为法身。今常住涅槃。既有体可法。故以法身义。为涅槃义也。般若义为涅槃义者。般若以鉴解为功。常住涅槃。既言有体。则无知而无不知。即是般若。故以般若义。为涅槃义也。解脱义为涅槃义者。解脱以脱缚为义。常住涅槃。其体虽在。然因缚果缚。二俱解脱。故以解脱义。为涅槃义也。昔说涅槃。既言身智二俱尽灭。所以二俱明之。其余诸义。二教通有。事同解脱。略而不辨也。唯我义功在觉者。涅槃是法宝。人法既殊。无俟有释也。若凡是万德义。皆为涅槃义。则法是圆法。名亦圆名。名法两圆。始尽至人神道之极致。故名涅槃也。复以大大之者。显其名理俱极也。昔二事尽灭。未是所以大。今明涅槃。其体圆满。理既应名。名不失理。名理俱极。始是所以大也。经者。唯金口所吐言理。乃得称经。弟子制作。非佛印可。不得称也。何者。经之字训。略有二义。一训言常。其二言由。常者。夫至人智极而后言。言必称理矣。众圣莫能改言。故言常也。出凡入圣。靡不由之。佛之所说。既穷兹二。故得称为经也。弟子所说。理有所未鉴。言有所未真。既于常由二义。有所未极。故不得称为经。是以维摩胜鬘。虽有所说。要须佛印可。方得称经

案。法安曰。涅槃之为名言乎。至极果也。此极果者。微过形声。妙绝筌寄。有累斯遣。是德必备。故能超踰生灭。凝然常存。何以言之。夫照法未穷。新知移其神。惑累为因。故其起必谢。今此极果。体无尘翳。为明因所生。嶷尔而常。不其宜乎。将以汲物。乃寄言三德。以其唯法为体。号曰法身。惑累斯亡。称为解脱。所照靡遗。谓之般若。法身一名。标其妙体。智断两称。举其胜德。略言此三。则已总摄众美矣。天竺一名。合此三训。此出一称。不穷其致。故仍彼胡音。用标经首也。大者。夫涅槃之名。名总众义。从因地未满。预有斯称。故加一大字。使宗致晓然也

案。昙准曰。盖是吉祥之灵府。生白之虚室也。捡因则行逾十地。核果则妙极抠始。冥造弗能移。玄运莫之动。一寂孔神。此以常为宗也。然群美不可尽言。故偏寄三德。取其洞照虚明。目之般若。应不摇寂。字曰法身。结惑都亡。谓之解脱。三义既彰。涅槃称在。大是梁方之言。涅槃是西域通语。彼训多含。此方无以偏译。故直存胡本。以为题目

标出叙中要义

释名第一　辨体第二　叙本有第三　谈绝名第四　释大字第五　解经字第六　核教意第七　判科段第八

    右八例

    释名第一

案。僧亮叙曰。如来神道之极号。常乐八味之都名。而此异俗之音。有楚夏之别。所谓涅槃泥洹泥曰也。涅槃乃中正天竺音也。名含众义。此方无以为译。法瑶。昙济。宝亮。昙爱。智秀。法智。法安。昙准悉同。而法瑶所叙。如有不同云。故曰一名之中。有无量名也。案寻此而言是。则涅槃之名。非直止含众义。亦含众名也。又宝亮云。虽复同无翻译。不云名含众义。乃云训况指释义也。叙曰。圣既出彼。此方无以正翻。但文中训况指义释而已也。法安亦曰。训出众义也。道生曰。正名云灭。取其义训。自复多方。今此经明常。使伏其迷。其迷永伏。然后得悟。悟则众迷斯灭。以之归名。其唯常说乎。又菩萨住斯经者。则已伏灭诸累。虽未造极。便能示般涅槃。众示无妙涅槃。复以无不示为大也。更用兹称经。盖是重美尽善矣。慧朗述法瑶曰。此言寂灭。谓即心识不可得之名也。又述昙纤曰。此言无累。僧宗曰。此言解脱。寻无累之与解脱。名殊而义一。故是离缚之谓耳。然而解之与脱。俱是德名。无累之称。兼所去也。案僧肇论曰。此言灭度。亦曰无为。盖是灭生死度彼岸。寂怕之谓也。会稽慧基。同彼云此言无为。智藏法云。同彼云此言灭度。明骏案。虽无正翻译。而非众德之都名。乃是无累之总称也。何者。下文曰。般涅言不。亦言无。槃那言生。亦言灭。于是。具列无累之名。以为训释也

    辨体第二

案。道生曰。夫真理自然。悟亦冥符。真则无差。悟岂容易。不易之体。为湛然常照。但从迷乖之。事未在我耳。苟能涉求。便反迷归极。僧亮叙曰。无学地法。皆是其体。佛略说三。以标神道。一曰般若。二曰法身。三曰解脱也。法瑶叙曰。涅槃至号。其义赡博。岂唯般若等三。以极其致。但略举其要。然则此三。名殊而实同。非体异者也。如其体别。则同因成假名之法。虚而不实。岂得称常。僧宗叙曰。累患既息。体备众德。略举其三。可以贯众。然此三德。体一而义异。就一体之上。义目有三也。宝亮叙曰。障累既尽。万行归真。无德不满。众用皆足。转因字果。名大涅槃。然其德渊旷。难可备举。略陈其要。理可有三。一谓正法宝城。二标别德。三寄工用。何者。夫涅槃无体。为众德所成。取况宝城。以喻斯旨也。别德者。谓大常大我等。此是成涅槃之胜因也。工用者。谓归依洲渚。能使物免苦。而获安也。智秀叙曰。体者。圆极妙有之本也。德者。般若法身解脱之流也。谈德虽众。论体唯一。何者。即圆极有可轨之义。曰法身。有静照之功。曰般若。有无累之德。曰解脱。是则即解脱之体可轨。亦可轨之体能照。更无别体。而有德也。案旧所详习。有二种解释。一谓。圆极果体。真实妙有。非如假名。但以有用而无体也。一谓。涅槃无体。假众德以成。岂得不空耶。慧朗述法瑶曰。生死涅槃。义分为二谓十二因缘颠倒故有。即因缘无性。是名涅槃。岂待离烦恼已。有妙有可得而不空乎。故般若经云。设有法。过于涅槃。亦说如幻如梦矣。又述纤爱宗等旧释云。万行得圆极之果。果体是实。而随德立义。非假众义共成一体也。法安曰。涅槃虽假众德为体。而异五阴成人也。何者。人及五阴。假实斯空。今涅槃虽空。而众德是实也

    叙本有第三

案。道生叙曰。归极得本。而似始起。始则必终。常以之昧。若寻其趣。乃是我始会之。非照今有。僧亮叙曰。般涅言不。亦名为无。槃者名生。亦名为因。不从作因所得。故无因也。宝亮叙曰。辨生死。以八苦为本。明涅槃以常乐为源。妙质恒而不动。用常改而不毁。无名无相。百非不辨。今涅槃之旨。就用而得称也。若谈真俗。两体本同。用不相乖。而闇去俗尽。伪谢真彰。朗然为佛也。法智叙曰。幽微难解。在乎本有也。所言本有者。乃是玄指未来隔世为有耳。不言现在世有也。禀识之类。源本未造因时。已自有之。故言本有。是则不待业缘为其始。故非始造矣。故说此未来。不同三世。要待造业。方得为有也。虽然未来未起。未为已用。故须了因。然后方应也。慧朗述法瑶曰。生死不断。由十二因缘。因缘无性。即是涅槃。岂是始有也

    谈绝名第四

案。众议曰。旧所详习。有五种解释。第一妙极法身。寂怕无为。与真如等际。一相无相。岂言德所能及。虽复寄言以往辨。虽辨而绝言。犹因指以得月。月非指也。第二夫言方而理圆。难以辨述。神道冥漠。可会而不可言也。譬轮扁之斲轮。不能传妙于所授。世谛粗浅。尚难可言。况真谛深妙。而可名乎。第三所谓绝言者。法身之地。绝凡累之名耳。体是妙有尊胜。云何以尊胜之名。而不得耶。第四夫名字是相累之法。若召相累之地。则与所召相称。若无相之地。虽因召而得。终绝于召也。第五一切诸法。本绝名字。以此而谈。岂直法身。亦可目生死为涅槃。目涅槃为生死。今名字已定。谓涅槃绝于生死之名。为可贵耳

    释大字第五

案。道生叙曰。有不在今。则是莫先为大。既云大矣。所以为常。常必灭累。僧亮曰。大者。明其常故。亦谓大我大乐。后文自有释也。僧宗曰。谓教大理大也。教大者。此说之前辨因果境行。并未周圆。今日所明究竟了义。故言大也。理大者。昔日三乘涅槃。非实究竟。理中为小。今日身智解脱。在乎累外。理中为大。故言大也。宝亮曰。体相无边。名之为大也。法智曰。理既应名。名不失理。名理俱极。故言大也。法安曰。昔日虽有涅槃。体德未圆。不得称大。今日体圆德备。故称大也

    释经字第六

案。僧亮叙曰。经者。胡音修多罗。名含五义也。僧宗叙曰。从凡至圣。经由此理也。宝亮曰。学者所由得解也。以此一字。贯一部之文理也。智秀曰。天竺以诠理之文。总曰修多罗。备含众义。如出生微发涌泉绳墨华鬘之流也。至于经由之义。盖其一也。法智曰。有二训。一曰常。谓称理之言。众圣莫能改也。二曰由。谓出凡入圣之所由也。法安曰。经者。训释有二种。一曰常。二曰法也。外国修多罗。有众多义。亦曰涌泉。亦曰绳墨。今以常义。代彼涌泉。明流注而不竭也。以法义。化彼绳墨。明规矩暮则轨靶不没也

    核教意第七

案。僧亮叙曰。如来始自道场。终于双树。三说涅槃。而二是方便。一是真实。何者。初开三究竟。谓一方便也。但说解脱。是涅槃身智。是有为也。二方便中。虽说法华破三究竟。而身智故。是有为也。今双树之说。身智即涅槃故。谓究竟无余之说也。宝亮叙曰。群品根异则教成五别。犹物迷障重。未能安深。所以先开方便之说。资今圆常之旨。蒙昔教以习心。稍涉虚以入道。体常无常。二轮双彻。鉴生死为不有之有。涅槃为不无之无。既安真而悟理。识苦空而断迷。自非修行八道发理缘之知。则烦惑不遣。生死难除。故今教之兴。开神明之妙体也。故开宗之始。借喻伊字。不纵不横。异昔有余无余也。僧宗叙曰。今所以唯录取解脱以标经者。有二义。一明理在万惑之外。二者斥昔解脱之执。昔日小乘。患身智起动求灭此患。而凭解脱。是故用今之胜。以代昔也。智秀叙曰。如来化始鹿园。旨穷鹫岳。唯明道极灰尽。善必菩提。未辨含情抱气。悉成无等。但说寿量长远。复倍上数。未明正觉虚凝。湛焉不灭。今此经者。以至极妙有为指南。常住佛性为宗致。明阐提。则正因无改。辨法身。则圆果嶷然。所谓无余之至教。究竟之极说也

    判科段第八

案。僧亮曰。经出未尽。现分可为四别。第一劝问。第二问。第三答问。第四法轮证也。案昙爱曰。大分有十别。第一序说。即序品也。第二正说。从纯陀品。讫金刚身品也。第三流通说。从名字功德品。讫四倒品也。第四佛性说。从如来性品。讫月喻品也。第五叹经功能。从菩萨品。讫现病品也。第六明依经修行。即五行也。第七出行体。有功德之义。以向佛果为行义。由功而德为功德义也。第八料简。上所明佛性。即师子吼品也。第九犹是料简佛性。广辨树王下以来。及今日所明之旨。举彼善星断根之事。即迦叶品也。第十明流通。命憍陈如。度十外道。从憍陈如品讫经也。案昙纤曰。大分此经为两别。前略后广。就略门中。分为五段。第一序品也。第二开宗。明常住因果。从陀品。讫哀叹品。第三问。从长寿品讫问也。第四答。从赞迦叶。入大众问品后也。第五付嘱。从尔时大众白佛讫品也。就广门中。分为五段。第一广果。即现病品也。第二广因。即五行也。第三广流通。即十功德品也。所以流离光远来。正为明弘通故也。第四广佛性即师子吼迦叶两品也。第五广付嘱。从憍陈如品。讫经文也。案昙济曰。大判凡有三段。第一劝分。第二问分。第三答分。从如是我闻。至迦叶发问。劝分也。从答问。讫憍陈如。答分也。案僧宗曰。经之始末。凡有五别。第一由序。即序品也。第二略开常宗。从纯陀品。讫新旧医也。第三广明常住。从长寿品。讫迦叶品也。所明因果境行。粗已周矣。将欲付嘱。第四先破外道。从憍陈如品。至阿难何在也。文旨既毕。应须付嘱。是以。第五顾命受持之人。从阿难比丘今何在。讫经也

案。宝亮曰。此经大致有四别。有一从此讫老少二人譬。劝问也。第二从多罗聚落迦叶。以下。发问也。第三从佛赞迦叶以下。竟迦叶。答问也。第四从憍陈如讫经。付嘱流通也所以第一通为劝问者。此经正以问答为宗。自双树以前所说半字。皆不了义。欲令众生有疑应问也

案。道慧记曰。大判此经有十别。第一序说。即序品也。第二正说。从纯陀。讫金刚身也。第三流通说。从名字功德。讫四倒也。第四佛性说。从如来性。讫月喻也。明所以得常者。以本有佛性故也。第五叹经。即菩萨一品也。第六证成常住。明不食而现食。不病而现病。不灭而现灭。即现病品也。第七明所得。无病者由行故也。即五行十功德也。第八境界明义为成于行。即师子吼迦叶也。第九破外道说。即憍陈如品也。第十嘱累说。从阿难何在。竟经文也

案。道慧又撰曰。此经有十别。第一序品也。第二开宗。即纯陀品也。第三会通。即哀叹品也。第四流通。从长寿品。讫现病品也。第五明因。即五行也。第六明果。即十功德也。第七明佛性。即师子吼品也。第八辨始终。即迦叶品也。第九破外道。即憍陈如品也。第十嘱累。即顾问阿难也。案。法安曰。此经分为二别。初讫大众问品。为前说也。末从现病品讫经。为后说也。就前说中有五段。第一经之由序。从序品。讫卅五问。第二正明经体。从答问始。讫名字功德也第三明流通人法。从四相品。讫四倒品也。第四明佛性。从佛性品。讫月喻品也。第五叹经嘱累。从菩萨品。讫大众问品也。就后说中分为五分。第一由序。即现病品也。第二重明涅槃因果。即五行也。第三明流通功德。即十功德也。第四重明佛性。即师子吼迦叶也。第五重更嘱累。憍陈如品竟经也

案。智秀曰。此经广略有二别。第一略门。从序品。讫大众问品也。第二广门。从现病品。讫憍陈如品。就略门中有三段。第一由序。即序品也。第二正说。从纯陀入大众问品也。第三付嘱。从大众问品中。尔时大众白佛。讫品也。就广门中有两段。第一广前正说。从现病品。讫迦叶品也。第二广前付嘱。从憍陈如品。讫经也

案。法智曰。此经大判有两别。第一经家序说。即序品也。第二正说。从纯陀品。讫经也。所以无付嘱者。传译未尽。就正说中。分为六段。第一纯陀哀叹两品。为开宗。第二从长寿品。讫现病品。可为随问说也。第三说五行。示闻经人修行之法也。第四说十功德。明行人所得之功德也。第五师子吼迦叶。明因果佛性也。第六憍陈如。化外道说也

案。昙准曰。此经不出三别。第一序。即序品也。第二正说。从纯陀品。至阿难何在也。第三流通。从顾命阿难。讫经也。又撰曰。此经有八别。第一序。即序品也。第二开宗。即纯陀哀叹二品也。第三明缘因境及经功德。从长寿品。讫四倒品也。第四明正因佛性。从如来性品。讫现病品也。第五广缘因行。从五行讫十功德也。第六广正因性。从师子吼。讫迦叶品也。第七广明果相。即憍陈如品也。故云因灭无常色。获得常住解脱色也。第八付嘱。从阿难何在。竟经也

明骏案。大分此经。可为三别。第一叙述。即序品也。第二略说。从纯陀。讫大众问品也。第三广说。从现病品。讫经文也。就略说中有三段。第一开宗劝问。从纯陀。讫老少二人譬。第二问答。从多罗聚落迦叶发问。入大众问品也。第三略付嘱。从大众问品中。尔时大众白佛。讫品也。就广说中有三段。第一广前开宗。即现病品也。夫食为生本。病为灭因。前纯陀品。因食以明现生。此品因病以明示灭。第二广前问答之旨。从五行。讫憍陈如品也。此经所明。常住因果。境之与行。今以五行十功德。广行广因也。师子吼迦叶。广境也。憍陈如以广常果。故云因灭无常色。获得解脱常乐之色也。广略所明因果境行。粗已周悉。将欲教洽未来。化传永劫。若不摧彼异学。挫伏迷元。千载之下。终为流通之病。是以第三度诸外道以灭邪群。使弘通大士身心无碍。故曰广前付嘱从尔时诸外道以下。讫经文也

大般涅槃经集解卷第一大般涅槃经集解卷第二(序品第一卷上)

  释如是我闻一时　释拘夷城　释力士生地　释阿利罗跋提河　释娑罗双树　释波罗奢华　释优钵罗华　释拘物头华　释分陀利华　释曼陀罗华　释波利质多树　释憍奢耶衣　释摩词跋多衣　释迦陵伽衣　释八功德水　释默然不受　释五门观

    序品第一

案。旧经云尽命品。僧亮曰。诸经所不论者。其旨有三。何者。一曰常住。二曰一体三宝。三曰众生悉有佛性。然常住是经之正宗。余二为常故说耳。今以寿命表常。略经之大体也。僧宗曰。序者由致也。将说正宗。若不序述由致。无以证信也。有二序。一曰现序。亦曰别序。二曰未来序。亦曰通序。如放光等瑞。为当时由致。名为现序。余经不同。故名别序。如是我闻五证。是阿难所请。名未来序。经皆有此。故名通序也。宝亮曰。此劝问门中有四段。第一当序名。第二纯陀。略开常宗。第三哀叹。举胜修广常。劝问。第四老少二人譬。催问也。智秀曰。有八事。第一称如是。第二称我闻。第三称一时。第四记住处。第五列同闻。第六举时节。第七述集众瑞。第八叙表息化之相也。法安曰。序品有三段。初有六字。明阿难之言不虚也。次举住处。示说法根本。后列时众。明说法缘起也。就缘起中。有三别。第一从尔时世尊与大比丘。讫前后围绕。列常随佛众也。第二二月十五日。讫后诸天众。此列为声光所召者也第三大身菩萨来集。彼佛所遣。非声光所召者也。慧朗曰。此品有两段。前名通序后明别序也。就别序中有六别。第一明六道众生。遇三相故。生忧悲也。从以佛神力。讫当复问谁。第二列出家在家四众。从时有无量。讫三恒沙也。第三列豪姓眷属。从四恒沙。讫七恒沙也。第四乱列天龙鬼神。从八恒沙。讫河神设供也。第五变林显涅槃相。仍明四天乃至梵王眷属也。第六列无边身眷属也。明骏案。此品大开为两分。前通序。后别序。就通序中。自有五事。一如是。二我闻。三一时。四住处。五同闻人也。别序中有五事。一从二月十五日。讫当复问谁。述三种相。总叙见闻之者忧悲之至也。二从时有无量诸大弟子。讫河海诸神设供。别叙四众及诸趣来集。三述二种相。四列诸天及他方菩萨来集。从四天王。讫除一阐提。五述二种相。从尔时三千大千世界。讫品也。前后凡三述异相。合有七种。初则声光动地。中则变林重阁。后则改秽收光也。再叙时众。亦有七科。谓圣人及六道

如是

案。僧宗曰。如者不异之辞。明阿难所传与佛说不异也。是者明即是佛说也。有两物相似。亦曰如。故以是字。简相似也。宝亮曰。如斯文理。并是佛说也。智秀曰。阿难所传。与佛说不异曰如。言当于理曰是也。法智曰。阿难自明之辞也。金口所说。旨深意远。非所仰测。而章句始末。正自如是也。慧朗曰。旧释云直指之辞也。谓如是之经。我从佛闻。非自造也

我闻

案。僧宗曰。夫亲闻则淳。传闻则澹。为成上句。明非谬也。智秀曰。咨承有所。无自信之过也

一时

案。僧宗曰。佛加威神。又得佛觉三昧。能一受领受。无所遗失也。为成我闻句也

佛在拘夷城

案。亦曰拘尸那竭国。亦曰拘尸那城。法瑶曰。仙人名也。将显长仙久寿也。兼遣着常之病。丈六尚然。况凡夫耶。僧宗曰。据方所。以证非谬也

力士生地

案。法瑶曰。将显法身自在。有大我之力也。兼遣封我之患

阿利罗跋提河边

案。僧亮曰。云与熙连河。相去百里也。法瑶曰。出阎浮金之处也。水之净者。莫过此河。将显法身真实净也。兼遣保净之心也。僧宗曰。此言金沙。河流奔浚。以譬生死。金沙不动。以譬佛性。寄显生死之中有佛性也。在边者。寄明涅槃在彼岸也。又释应身无常。喻彼水流。法身常住。若彼金沙也。宝亮曰。亦称金泉河也。众水之最。世人所保。今破所爱。虽曰最净。犹是烦恼所得。当修无漏。以求常净也

娑罗双树间

案。僧亮曰。方有二树。合则八也。高五丈许。上合下离。其花甚白。其实如瓶。香味具足。今以二树鲜荣。二树枯悴。明法不偏也。昔道场偏说。所以一树。今日教圆寄之双也。法瑶曰。谓坚固林也。风霜不能改。四时莫能迁。以况法身金刚之质。老死不能变。念念不能易。常乐之相也。兼遣存常乐之意也。僧宗曰。所以名坚固者。为四天所护也。表佛所说法。四部所护。永不坠丧也。在林之间水之边者。处林则息乱。近水则清净。表明如来寂静。而无累也。宝亮曰。亦破着也。物情以往古诸佛。皆于此处涅槃。四天所守。谓为保固。今破云。此非坚法。若能不为四魔所坏。乃至坚也

尔时世尊与大比丘八十亿百千人俱前后围绕

案。僧宗曰。此列同闻人也。凡四过列。第一与佛具至双林。不待光召。第二蒙三瑞方来。第三虽蒙三瑞。未能自遣。故变林催至。第四不待光召。诸佛知时。遣来同事。此即第一先列在佛边者也。比丘天竺语也。此以三义往释。谓乞士破恶怖魔也。宝亮曰。此列十四日暮从佛来此者也。彼国出家者之名也。此间无此名。但以三义美之。如怖魔等也。前后围绕者。回旋致敬也。智秀曰。此故是声光所召者耳。为欲依准余经序故。略标大数。别称在前也。然同闻有三种。一处同。二时同。三所闻法同。阿难于时。既在娑罗林外。是则时不同也。道慧记曰。大者皆是得道人也

二月十五日临涅槃时

案。僧亮曰。下文有释。彼土唯立三时。谓春夏冬也。二月是春和之中节。异耶。冬夏寒暑。偏也明也。昔说苦空。如彼之偏。今既二理双显。故取表于中和也。僧宗曰。此是荣枯交代之节。将明如来二种法身。舍迹归本者也。智秀曰。临涅槃时者。指说经之时也

以佛神力出大音声

案。僧亮曰。应感之事。本自佛境。不以声告。物莫知也。僧宗曰。菩萨二乘。亦有神力。不得称大。今言大者。佛之神力也。道慧记曰。此中有三瑞。又云。通哀叹以来。凡七瑞也。此声不从口出。故云神力

其声遍满乃至有顶

案。僧宗曰。谓色究竟天也。无色界中。彼无诸根。故不及也。宝亮曰。随有缘悉闻此。盖举其一隅耳。道慧记曰。推此声所极。正应二十恒沙国土也。下实谛中云。今声至二十恒河沙。以此而例。光明动地。亦应然也

随其类音普告众生

案。僧宗曰。六道不同楚夏之别。皆如闻而解也

今日如来应供正遍知(至)大觉世尊将欲涅槃

案。僧亮曰。因伪显真。寄灭表存也。僧宗曰。所以先举三德者。使怀德而慕善也。既内怀悲愍。故外能荫护。以此二心。等行于物。已为匪易。复能极如一子。弥见其难也。归依者。若慈母之赴婴儿也。舍者以遮风霜为用。譬大悲之力。有大方便。能令众生烦恼不起也。大觉世尊者。复举两号。以速其心也。宝亮曰。将欲涅槃者。非经题所称也。言无余涅槃耳。自鹿苑迄此。众生闻一教。增一疑。唯今第五时说疑心顿息。所以略举十号。使知佛恩之重也。道慧记曰怜愍不必[雨/復]护。不必平等。今以归依释怜愍。以为舍释[雨/復]护。以罗睺罗释平等也。慧朗曰。声中有五句。第一总称慈悲。谓怜愍[雨/復]护也。第二称慈用。谓如罗睺罗也。第三称悲用。谓作归依也。第四偏舍化。谓今欲涅槃也。第五催令来问。谓为最后问也

一切众生若有所疑今悉可问为最后问

案。僧亮曰。众生厌苦。苦从惑起。灭苦要先断惑。惑有轻重。重名为见。轻者曰疑。疑尚须断。况复见耶。断疑唯佛可不问乎。僧宗曰。自此之前。唯说无常。今明常理。教与昔反。事则应疑。虽复言不指的。而意在于此也。宝亮曰。此是如来。最后宗极之教。故劝令问

尔时世尊于晨朝时

案。僧亮曰。上记日月。今记时也

从其面门放种种光(至)乃至十方亦复如是。

案。僧亮曰。声至有顶。语其上闻。光遍十方。语其四远。二文互出。事表未殊也。法瑶曰。口出其光。以表最极妙说之相也。僧宗曰。此第二相也。上以音声生解。此从光明得悟也。门以通为义。故以口为面门也。宝亮曰。种种色光者。昔经亦有此瑞。但出经者。表佛威光。故以种种为名也。智秀曰。向虽闻声。未测所之。是以放光示令知也

其中所有六趣众生(至)身体战栗涕泣哽咽

案。僧亮曰。向告令知。今除罪障也。僧宗曰。罪语于果。垢恼语因也。宝亮曰。此言灭者。据伏除也。谓睹光者。心缘胜境。三毒不得并起。但生净心。故云罪灭

尔时大地诸山大海皆悉震动

案。僧亮曰。垢障已除。恋慕情至。哀迷乱心。无由速集。故以神力动地。抑其哀情也。法瑶曰。无情尚动。况有心乎。以感时人。速令云集也。僧宗曰。第三相也。如来至德如地。以安群生。舍化归真。示之令悟也。智秀曰。见地动已。兴三种意。一者相劝且各裁抑。二者今当速往速往。三者设后有疑。无所咨问也。慧朗曰。此下有两阶。此即第一叙地动相也

时诸众生共相谓言(至)若减一劫互相执手

案。僧宗曰。既睹三瑞。宁得不悲。更相晓喻。设敦请之计也。宝亮曰。旧解云。众生若寿命一劫。则请之一劫寿。若半劫。则请半劫也。自意不然。盖随俗也。于时人情。愿佛住世。岂容指愿一切半劫。就少为言。恐多难冀耳。慧朗曰。此下第二阶有两意。第一先相晓劝也

复作是言世间虚空(至)如来不久必入涅槃

案。僧宗曰。如来道被大千。德荫三界。今入涅槃。世间空也。福尽者。福以感圣。圣既不应。所以知尽也。不善增长者。福既尽矣。恶所以增

又作是言世间虚空(至)设有疑惑当复问谁

案。慧朗曰。无救护者。此下举前声告之旨也。救者。举前怜愍大慈句也。护者。举前[雨/復]护大悲句也。贫穷者。举前等视如罗睺罗。大慈之用也。谓罗睺罗已得法财。我今未得。而佛舍我。方是贫穷也。无所宗仰者。举前为作归依也。孤露者。举前为世间舍。大悲之用也。一旦远离者。举前大觉世尊。将欲涅槃也。设有疑惑者。举前今悉可问也。是以宜自抑遣速往速往之也

时有无量诸大弟子(至)生如是等种种苦恼

案。僧亮曰。上三瑞相集众因缘。此下说集时次第。大弟子者。先在佛左右。故不言其来也。道慧记曰。即是前所言八十亿百千者也。既非声光所召。而复列者。欲叙其遇光悲恼也。慧朗曰。此举三业苦恼。谓身战掉。心浊发声也

尔时复有八十百千诸比丘等

案。僧亮曰。此下叙远来者也。来不必前后。文不可累书。分作三次耳。一众多在后。二众多供胜。三但以供胜也。僧宗曰。此经所列时众。与诸经不必同也。以声闻德狭。不能广化。多以侧侍左右。所以先列也。宝亮曰。此列十五日旦承光至者也。比丘者。列其位。罗汉者。叹其德也。道慧记曰。列众凡有五别。第一八十亿百千。谓内眷属也。第二时有无量诸大弟子。谓外眷属也。第三优婆塞以下。随以供胜众多为后也。第四从金翅鸟王讫山王。但以众多为后。第五从阿僧祇海神讫无边身。但以供养为后也。又撰曰。不必皆先后。但义为次第也。然若列先后有。不出四种。一者以位为次。二者以数为次。三者以供为次。四者不以位数供。但以是时来者。即是中列也。智秀曰。此下至其林变白。皆是声光动地所召也。然列条序不同。多则至五。少则唯二。言五者。一列数。二置位。三叹德。四列名。五叙来相也。言二者。一列数二列名而已。又列其秩序。差品有三。第一从此。讫得自在力能化作佛。列出家二众。以道小近佛。故先列也。明骏案。此中列六事。一列数。二称位。三叹权德。四叙忧悲。五叹实德。六叙来事

皆阿罗汉

案。僧亮曰。此言不生。生是苦本。惑是生因。罗汉断三界之惑。苦果不生。故名不生也。僧宗曰。此名含三义。一谓杀贼。盖断烦恼也。二谓不生。盖不受三界生也。三谓应供。以备三德。可为福田也

心得自在

案。僧亮曰。心为苦乐之本。众生厌苦。不离苦因。为烦恼所惑。不得自在。今无苦因。所以自在也

所作已辨

案。僧亮曰。苦因既尽。所期已毕也。僧宗曰。谓得尽智无生智究竟也。此义含智。即释应供也。宝亮曰。此两句。共释不生义也。所以得不生者。由断三界使尽。治道力辨故也

离诸烦恼

案。僧亮曰。释上已辨义也。僧宗曰。释所以不生也。道慧记曰。释心所以得自在。所作所以已辨也

调伏诸根

案。僧亮曰。释心得自在也。僧宗曰。惑在由于诸根。诸根既调。所以惑尽也。宝亮曰。此两句释杀贼也。诸烦恼贼。所以而尽。由摄六情。制三业故也

如大龙王

案。僧宗曰。为三明六通作譬也。龙有二德。一则兴云降雨。二则隐显自在也。宝亮曰。此下讫逮得已利。辨应供也。道慧记曰。龙王即是人中象王。如大品经云。如调象王也。为善调作譬释烦恼。所以而离由乎善调诸根故也

有大威德

案。道慧记曰。此下叹其外德。明在在处处。众所宗伏也

成就空慧

案。僧亮曰。释断烦恼也。若不得空慧。则不断也

逮得已利

案。僧亮曰。结断不起。可保之为利也。道慧记曰。释所以有大威德也。空慧明其智满。已利明其结尽也

如栴檀林栴檀围绕如师子王师子围绕

案。僧亮曰。师子王者。空慧既成。戒定皆是无漏空慧。如王余德如子也。道慧记曰。此不取王为譬。乃总叹诸功德。更相围绕也

成就如是无量功德一切皆是佛之真子

案。僧宗曰。自法华已来。皆得称为菩萨。若未尔之前。不得称也。宝亮曰。真伪之名。就教有三重。第一判圣为真。以凡为伪。第二以二乘为伪义。菩萨为真。第三谓信常者为真。信未立者为伪。今就第三重判也。明此诸人尽双解六行也

各于晨朝日初出时(云)涕泣盈目生大苦恼

案。僧亮曰。波罗奢华。叶青。其华白。而一日三变。日未出时则白。日始出则赤。日晚则黄也。道慧记曰。其华质青而脉赤也

为欲利益安乐众生

案。僧宗曰。下五句别叹。此一句总叹也。宝亮曰。此下皆探取实德。以为叹也。此第一明以利益故来。谓是众人得道之缘。若使千人为缘。少一人则不得也

成就大乘第一空行

案。僧亮曰。诸罗汉知佛是常。今欲请佛发明常教也。此经第一义空者。常乐我净。无二十五有。故名空也。僧宗曰。般若是万行之主。欲令众生得无相之解也

显发如来方便密教

案。僧亮曰。昔说无常。[雨/復]今常旨。谓之密教也。僧宗曰。显三乘为方便。一乘是实行。丈六是有为。法身是无为者也

为不断绝种种说法

案。僧宗曰。从初鹿苑。迄至今日。随能生解。皆为人说

为诸众生调伏因缘故(至)合掌恭敬却坐一面

案。僧宗曰。谓闻无常解无常。闻常住亦即解也。既自通达。复为他说。宝亮曰。谓除众生四倒之缘也。寻此而言。故知法华诸教无得道者

尔时复有拘陀罗女(至)合掌恭敬却坐一面

案。僧宗曰。尼者此言女也。所列科例与上同也。明骏案。此列有九事。一称族。二称位。三列名。四举数。五叹权德。六叙忧悲。七叹实德。八叙来事。九蕳尊胜。故曰位阶十地

比丘尼众中复有诸比丘尼(至)得自在力能化作佛

案。僧宗曰。出家二众。权实难知。今蕳尼众有菩萨者。推比丘众中。亦应尔也。宝亮曰。向所列实解六行。成真子之义。此偏指尼众。亦有本是八住以上菩萨也。慧朗曰。此中叹权德。初云诸漏已量。谓总句也。明骏案。前叹比丘中。结末云。逮得己利。此中叹初有诸漏已尽。两彼互阙。盖出经者差脱耳。旨则存焉

尔时复有一恒河沙(至)菩萨摩诃萨而为上首

案。僧宗曰。上列声闻二众。今列菩萨也。而不言设供者。应是出家人也。宝亮曰。此偏指前比丘众中。有权为声闻者。智秀曰。向声闻二众之中。皆曰真子。已知并是菩萨也。今复别列者。皆就迹为言也。前有声闻之迹。有以亲待之义。故在前列也。菩萨行广。迹有疏义。故次后列也。彭城慧令曰。此是离居家者。非比丘也。明骏案。此中列有七事。一举数。二略叹德位及方便。三列名。四叹三世行。五叙忧悲。六叹实德。七叙来事也。菩萨罗汉。更无别位。不出在家出家四众数也。所以此一恒河。在两楹之间。但称菩萨者。辨异彼此故也。法华之日。已无声闻。况在此席。岂更别有菩萨耶。而尼众简出阶十住者。盖标其胜出者耳。故云人中之龙也

其心皆悉敬重大乘(至)诸未度者当令得度

案。僧亮曰。菩萨以济物为怀。大乘既是良药。故先明也。随一切者。以法济物。要须曲与物同。仁德广被也。随从有四。一形类。二语言。三根性。四事业也。作是誓者。既入五道。同彼苦乐。苦则心退。乐则生着。自非弘誓。无由两舍也。僧宗曰。此叹现在德也。宝亮曰。菩萨此言道心人也。叹德不过自行之与外化。此中据三世为叹。于一世中。皆具二义也

已于过去无数劫中(至)绍三宝种使不断绝

案。僧亮曰。能备上德。非积行不就也。解未解者。向说誓时。今说行时也。僧宗曰。向明现在行。今明过去行

于未来世当转法轮以大庄严而自庄严

案。僧宗曰。次叹未来德也

成就如是无量功德(至)合掌恭敬却坐一面

案。僧宗曰。旨与前同也

尔时复有二恒河沙(至)平等无二如视一子

案。僧宗曰。此在家菩萨也。优婆塞者。此言清信士。论文有释。谓为善宿。皆以义翻彼名耳。此下列众有四阶。第一从此。讫十恒河沙。以众渐多而供稍胜。为次第也。第二从廿恒沙。讫九十恒沙。供不必胜。但以众渐多。为次第也。第三从千恒沙。以多少不定乱来。为次第也。第四变林以下。众不必多。但以供胜。为次第也。明骏案。此中列十五事。一举数。二称位。三以戒为行本。故先叹戒也。四列名。五次叹定。谓深观对治门也。六叹慧。谓亦欲乐闻无上大乘等也。七举四弘。以叹外化。八举庄严净戒结叹也。九叙遇光忧悲。十叙设供。十一叙因辨供时。又发弘誓。十二叙念佛受供已必入涅槃。十三叙来佛所事。十四叙佛默然不受。十五叙不果愿故忧悲也

亦于晨朝日初出时(至)憍奢耶衣刍摩缯彩

案。僧亮曰。天木香者。名时物重物也。出家法施。在家财施。施具九事。财施有三。谓时物。重物。如法物也。心亦有三。谓先心欢喜。施时心净。施已无悔也。地亦有三。谓不动。无相。无量定也。今但说六种佛地。不须说也。以佛力故者。谓以佛力。成其重物。悦施者之心也。乃至盖覆大千。皆类此也。优钵罗华色青。拘物头色赤。波头摩色不正。云似昌蒱花。分陀利色白。生水中也。曼陀罗是天华也。中国亦有。其色不定。如赤而黄。如青而紫。如绿而绛。种种色变。波利质多在天上。则种种色。天竺亦有。而华叶色并青绿。憍奢耶者。云蚕茧所作。东天竺有国名乌陀。粳米欲熟变为虫。虫即食米。人取蒸以成绵也。如此丝绵者。名摩呵跋多。此言大衣。甚贵也。刍摩者布衣也。迦陵伽者国名。亦出细叠也

是诸香木载以宝车(至)哀受我等最后供养

案。僧亮曰。各作是念。若有所乏者。此下说三种心也。道慧记曰。八功德水者。谓轻．冷．软．美．清净．不臭．饮时调适。饮已无患也

世尊知时默然不受(至)却在一面默然而坐

案。僧亮曰。知受持未至也。若受前人者。后人则不得献也。昔默则受。今默则不受者。昔日体康。触味斯可。若言受则近贪。故不言也。今称病力弱。所须自知。是以言之则受。不言则不须也。法瑶曰。初生王宫。唱云应供。是则有施便受。何假发言。今显法身常乐不食。默然无言。理知不受也。宝亮曰。知时有三种一者佛不受二檀越请。二者由昔愿故受。三者知纯陀作施主者。为益处旷也。慧朗曰。知时有三种。一知受时未至。二知时众无宿愿。三知即时若受余施。不能广利也

尔时复有三恒河沙(至)百千众生故现女身

案。法瑶曰。大众闻见涅槃之相。理应一时云集。不容前后。设复先后。亦不必如经所列也。慧朗曰。列数列名。叹德之事。准前可知也

呵责家法

案。僧亮曰。恋着之处名家。即女人之身是

自观己身如四毒蛇(至)是身可恶犹如死狗

案。僧亮曰。此苦观也

是身不净九孔常流

案。僧亮曰。不净观也

是身如城血肉筋骨(至)愚痴罗刹止住其中

案。僧亮曰。空观也。色阴譬城。四阴譬人。诸见无过譬王。烦恼有过譬民也

是身不坚犹如芦苇伊兰水沫芭蕉之树

案。僧亮曰。无我观也

是身无常念念不住(至)谁有智者当乐此身

案。僧亮曰。无常观也

宁以牛迹盛大海水(至)是故当舍如弃涕唾

案。慧朗曰。结上诸观也

以是因缘诸优婆夷(至)心怀惆怅却住一面

大般涅槃经集解卷第二大般涅槃经集解卷第三(序品第一卷之第二)

  出诸离车在虚空坐去地七多罗树　又出诸大长者亦去地七多罗树　出诸鬼神及禽兽异名　叙变林及重阁讲堂事　释魔王说咒事　出无边身来事

    序品之第二

尔时复有四恒河沙(至)及阎浮提诸王眷属

案。慧朗曰。此下第三列诸豪族也

为求法故善修戒行(至)于虚空中默然而住

案。僧亮曰。去地七多罗树者。彼以豪族自憍。不愿杂坐。故置之空也

尔时复有五恒河沙(至)绕佛一匝却住一面

案。僧亮曰。陀那婆王者。阿修罗例也。此言随也

尔时阎浮提中比丘比丘尼(至)其林变白犹如白鹄

案。僧亮曰。贪生爱寿者。以佛灭为苦。今明灭非作法。乃息伪反真也。五色之中。白是真实自然之色。不可染成。借事表理也。僧宗曰。向三种瑞。人中悉集。今现此相。以摧诸天速集也

于虚空中自然而有(至)皆悉悲感愁忧不乐

案。僧亮曰。今说涅槃。无一切有。故名为空。希有常乐万德。如虚空中有堂阁也

尔时四天王释提桓因(至)来至佛所稽首佛足

案。僧宗曰。魔多是圣人。如今是实。佛以大慈能转其恶也

而白佛言我等今者(至)除灭怖畏说如是咒

明骏曰。案维摩经云。十方世界。作魔王者。多是住不思议解脱菩萨。信之于此矣

侘枳咤咤罗侘枳卢呵隶(至)阿罗遮罗多罗莎诃

案。僧宗曰。若能穷达其旨。经之与咒。竟何所在。但物心难以理从。易以威逼。咒方别是止耶之术。魔无法以助化。说咒以弘道也。慧朗曰。此有三阶。前明魔以神力。施地狱之乐。办供而来。此第二说咒。以请印可之

是咒能令诸失心者(至)心怀愁恼却住一面

案。僧宗曰。叹咒功能。复明己自为护。以劝受持也。慧朗曰。此第三请佛受供印咒。佛不受供。而印其咒也

尔时大自在天王与其眷属(至)天人师佛世尊

案。僧亮曰。此菩萨所以现者。美大之辞也。此中明身大。彼土庄严。众生清净。世乐之极。远来献供。更求胜法者。证有为非乐也。慧朗曰。此下有两段。初辨无边。次明佛神力也。辨无边身中。有八章。此即第一略叙彼土佛事也

尔时彼佛即告第一大弟子(至)并可礼敬请决所疑

案。慧朗曰。此第二彼佛命使来

尔时无边身菩萨摩诃萨(至)所有威德悉灭无余

案。慧朗曰。此第三叙时众惊怪也

是时文殊师利法王子(至)如来不久当般涅槃

案。慧朗曰。此第四叙文殊安慰大众也

是时大众一切悉见(至)如是流布大乘经典

案。慧朗曰。此第五叙菩萨神力

尔时无边身菩萨(至)如来不久当般涅槃

案。慧朗曰。此第六明菩萨以神力。令身中众生。得法悟也

尔时无边身菩萨(至)余无能见是菩萨身其量边际

案。慧朗曰。第七明以神力办供

尔时无边身菩萨及其眷属(至)如是三请悉亦不受

案。慧朗曰。第八明以供上佛。佛不受

尔时无边身菩萨及其眷属(至)却住一面皆亦如是

案。慧朗曰。举十方同到者总结

尔时娑罗双树吉祥福地(至)见诸佛土亦复如是

案。慧朗曰。此辨佛神力有两章。此即第一光明变秽为净也

尔时如来面门所出(至)身诸毛孔流血洒地

案。法瑶曰。化缘周毕。表涅槃之相也。有三种。一众生心净。二国土净。三收光入口。收光入口。则止教之相。众生心净。则表化周。国土净者。则明行毕也。慧朗曰。此第二阶。示涅槃之相也

大般涅槃经集解卷第三大般涅槃经集解卷第四(纯陀品第二卷上)

  释福田义　释纯陀名

    纯陀品第二

案。僧宗曰。经之五别。此下两品。是第二开宗。明常住因果也。通分为三段。第一因施以明常。亦曰因请受供以明常也。从品初。讫释梵诸天等。悉来供养我也。第二因请以明常。从一切诸世间悉生大苦恼。讫琉璃珠譬也。第三因会通以明常。即新旧医譬也。昙谶曰。此一品有四段。第一因施以明常。第二因大众喜庆以明常。第三因文殊与纯陀论义以明常。第四因催供以明常也。昙爱曰。此品分为八段。第一纯陀请受供。佛许受也。第二纯陀设五难。佛即答也。第三大众庆纯陀。仍请纯陀。令请佛住也。第五纯陀自庆。申大众意。以请佛也。第六佛印可纯陀所庆。止纯陀所请也。纯陀领佛答旨。重申所以请也。第七文殊与纯陀。广兴讥论。第八放光催供也。道慧记曰。此品四段。第一因受供以明常。第二因请住以明常。第三因二大士共论以明常。第四因止请以明常也。法智曰。此下讫哀叹品。开宗有两别。前略后广也。此品有三段。始因二请。再明常住。是如来开宗说也。第二从诚如圣教。讫论义竟。是纯陀信解说也。前虽因二请。再有所闻。而理未在我。取信为难。故须始信之入。宣明乃解。故文殊云。试汝菩萨事也。第三从放光讫品。是如来结会说也。慧朗述僧宗曰。谓此二品开宗。明常住因果者。凡有四处。何者。第一纯陀之施为因。佛即开宗。明常果也。第二纯陀与文殊抑扬。引千力士王等。显常果。引贫女丈夫二譬。明常因也。第三佛说伊字涅槃为果。说胜三修。讫琉璃珠譬为因也。第四新旧医。会通今昔因果之教。以显常也

尔时会中有优婆塞

案。僧亮曰。纯陀因先愿力。如来受供。而其意有六。此第一表不弃始学。而重旧行也。法瑶曰。应迹斯下影向。大圣扣发至高之理也。僧宗曰。所以受纯陀供者。略有五意。此是第一以纯陀形处贫陋。将明如来不遗贫贱。而接富贵也。二者纯陀奉施之意。普兼一切。三者已有妙解。可与论常。四者于众有缘。五者于迦叶佛时。有愿云。释迦如来涅槃之日。我当最后奉设供养也。从此讫释梵诸天等。悉来供养我。第一因施以明常也。有五章。第一纯陀请佛受供。第二佛受其供。寄报等以显常。即设五难。佛即答也。第三大众欢喜。第四说偈请纯陀。令请佛。第五纯陀自庆也。昙谶曰。此下讫答五难竟。四段中。第一因施以明常。有四章。第一从始讫如罗睺罗。请佛受供也。第二从尔时世尊。讫令汝具足檀波罗蜜。佛受供也。第三纯陀设五难。第四佛答也。昙爱曰。此下讫令汝具足檀波罗蜜八段之中第一也。有两章。第一纯陀请。第二佛受也。慧朗述僧宗曰。此下入纯陀自庆偈中。讫释梵诸天等。皆来供养我。三段之中第一也。有六章。第一请受供。第二佛受供。第三纯陀难不应等。第四佛答。第四大众请纯陀。令请佛。第六纯陀自庆也。法安曰。此下两品开宗。各有两段者。第一从初讫答五难竟。因请受供以开宗。第二从大众欢喜讫品。因请住以开宗也。就前请受供中。有四章。第一纯陀请受供。第二佛受纯陀供。第三纯陀设五难。第四佛答五难也。就后请住中。有三章。第一大众请也。从大众欢喜。讫纯陀受上妙乐。第二纯陀请。从纯陀领旨。讫试汝诸菩萨事也。第三纯陀要大众相与共请。从放光催供。讫品也。明骏案。此品有四别。皆是请门。第一因纯陀请受供以开宗。第二因大众请住以开宗。双辨本迹之异也。第三因纯陀请。仍生傍论。还正常宗。双辨受供之与悦可也。何者。上纯陀请受供。佛即许受。如似实受。此迹宜拂。又上五难往复。圣心悦可。及文殊致论。迹居负地。复宜遣拂也。第四从放光催供讫品。还复双明本迹以广上旨。向虽云普为大会。受汝所供。而开宗之始。唯云当施纯陀常命色力。今此一章。以定斯旨。故云若诸人天。于此最后供养我者。悉皆当得不动果报。我是众生良福田故也

是拘尸城

案。僧亮曰。此第二意。不舍近从远也。慧朗曰。出其乡邦也

工巧之子

案。僧亮曰。此第三意。不遗卑而就胜也慧朗曰。言其事业

名曰纯陀与其同类十五人俱

案。僧亮曰。此第四意。不弃少而从多也。慧朗曰。称其名显其德也

为令世间得善果故

案。僧亮曰。此第五意。显其内有大士之德。出于众也。法瑶曰。叙其人地虽卑。而志德甚大。苟有其道。不在贵贱。使斯下之徒。皆不自轻也。智秀曰。所以不将供来者。为兴催供之旨

舍身威仪从坐而起

案。僧亮曰。此第六意。不薄粗而贪妙也。何者。佛先敕纯陀办供。其以供粗。不敢奉佛。但就坐而已。既见不受余人所供。方起有献也。法瑶曰。舍身威仪者。废工巧之事业。更起崇法之恭貌也。僧宗曰。既有祈请之节。宜舍常缓之威仪

偏袒右臂右膝着地(至)为度无量诸众生故

案。宝亮曰。此言有迹有实也。迹者。若佛受我所供。余人亦当蒙受也。实者。若所供得设。便成檀度。檀度既成。则能助佛扬化也。道慧记曰。大士本不自为。此乃道兼天下之辞也

世尊我等从今无主无亲无救无护无归无趣

案。僧亮曰。主救于国。亲护于家。佛则一切救护也。无救无护。所以无归无趣。僧宗曰。拔其在苦曰救。安其在善曰护。无归趣者。凭心无所也。宝亮曰。去远荫护。如无主也。离近咨承。如无亲也。圣若在世。恶则不起。如救也。善得曰滋。如护也。乖所凭故。故无归趣也

贫穷饥困欲从如来(至)我等微供然后涅槃

案。道生曰。饥渴之苦。譬之生死。苟能无之。义曰为食。今施者。所求取类云尔。僧亮曰。若檀度必成。是则长养将来法身也。法瑶曰。常住之实在方。将得之由佛。故云从如来求也。僧宗曰。标心佛果常住法食。且覆相说之。未灼然也

世尊譬如刹利若婆罗门毗舍首陀

案。僧亮曰。身为四大所成。取譬于四姓也。僧宗曰。四姓之中。趣取一人为譬也

以贫穷故

案。僧亮曰。譬无出世善也

远至他国

案。道生曰。去已所封。入佛化也。僧亮曰。从此三界。之彼佛境。譬造他国也。僧宗曰。涅槃于生死为他。行人标心仰求。故言远至。此乃因中说果。必至者也。智秀曰。生善之境。是出惑之域。故言他也。法智曰。正道于耶道。为他也

役力农作

案。道生曰。为善乖于恒性。自策所以成勤。如农不失时。收果万倍也。僧亮曰。檀是始行。须自策乃成也。道慧记曰。始习之善。与本恶性乖。譬之庸役也。勤策则收果万倍。譬之农作

得好调牛

案。僧亮曰。此下譬已成檀之缘具也。内则异有正见。外则身口无障。唯佛受供。法身得生也。僧宗曰。譬伏身口七支恶也

良田平正

案。僧宗曰。以智慧譬田也。以牛耕田。田以平正为良也。今以身口之善。资成心业。所以得正智慧也。宝亮曰。田有能生之力。若不以牛耕。则能生之力不遂。譬身口之业。能遂意地之用

无诸沙卤恶草荒秽

案。僧亮曰。譬伏九十八使

唯悕天雨

案。僧宗曰。如来纳受所施。则法身得生。如雨之润也。智秀曰。施心为种子也。应有下种之譬。盖文略耳

言调牛者譬身口七(至)拯及无量苦恼众生

案。僧亮曰。若我行立。则众生蒙度也。僧宗曰。若我所设。必蒙受者。大众之施。亦皆然也。明骏曰。若我供蒙受。亦当为我住世。世若有佛。则众生蒙济也

我今所供虽复微少冀得充足如来大众

案。慧朗曰。所说既少。冀凭威神普充大众

我今无主无亲无归愿垂矜愍如罗睺罗

案。昙济曰。国以主为覆护。家以亲为归依。世无圣人。谁为救拔耶。智秀曰。举譬本以结请也

尔时世尊一切种智无上调御

案。僧亮曰。向来所请。非唯供妙。人亦豪贤。而不蒙受。今许纯陀。旨必有在。故集法者。以此二句。仰称至德也

告纯陀曰善哉善哉(至)雨汝身田令生法身

案。道生曰。虽行善有慧。若未解常住。法牙未生也。僧亮曰。檀是万行之始。法身之牙也。敬遗记。僧宗曰。此下讫答五难竟。五章之中。第二章也。雨汝身田者。余经多以说法为雨。此中正明受施。则檀苗增长。如彼雨也。法莲记。僧宗曰。身者举上身口也。田者举上智慧。即意业也。宝亮曰。除断贫穷者。明今日所计。其旨有两。一许受供。二许说法。是则除断二种贫穷也。慧朗述僧宗曰。此中有三阶。此即第一佛詶其所请。许受其供也。若佛许受。则檀牙已生。未必受已檀牙方生也。慧朗曰。漉取因请受供。以明常中。略有十[跳-兆+(轍-車)]。第一佛为外缘生二种善。一者功德。二者智慧。智慧即是所生常解也。功德即是所生相似檀波罗蜜也。能生内因。亦有二种。一者功德种子。即是施心。二者智慧种子。即是推求因果之心也。第二辨能生所生同是一性。谓施心及檀波罗蜜。推求因果之心及常解也。而有新旧之异。何者。智慧推求为旧也。从佛得常解为新也。又施心种子为旧也。从佛得檀波罗蜜为新也。第三广辨二种种子。法判心不出三种。谓善不善无记。此三种心。皆有二义。一谓泛尔。二谓推求。就善推求。即是智慧种子也。泛尔即是功德种子也。第四应广辨功德智慧义。第五论纯陀与佛。互为施主受者也。纯陀以有漏心。运有漏财。施无漏人。是则施者有漏。受者无漏也。佛以无漏心。运无漏法。施有漏人。是则施者无漏。受者有漏也。第六简纯陀与佛。虽复互为施者。而不得互为福田。田有能生之功。滋长之用。佛既功德圆满。岂假田益。第七明佛是决定受者。纯陀是决定施者。既两是决定。佛许受便生檀度。无待运财。到受者所。如人财在异方。悬指为施。即属受者也。第八辨人位。何者。纯陀迹是外凡夫人。以闻佛说常得解。成相似般若。得相似檀度。入内凡夫位。因答五难。即登无漏也。第九辨因施缘施者。谓佛说常也。因施者。谓纯陀舍财也。因亲而缘疏。何者。谓财施事亲而理疏。法施理亲而事疏也。财施资身。所以理疏。法施资神。所以理亲也。而损己舍财。于事为亲。故名为因也。法施无损于我。于事为疏。故名缘也。第十应广释福田义也

汝今于我欲求寿命(至)常命色力安无碍辨

案。道生曰。夫施须食者。使得果五故。五皆归已也。若施不须者。则常五显也。常五显故。方是有常。然则施得常果。必由受者是常故也。僧亮曰。上劝疑问。今开疑宗。何者。昔说从凡至佛。皆是无常。今云施常。言与昔乖。理应疑问也。法瑶曰。此旨有二。何者。一表纯陀所求将来食者。意在显常旨也。二明如来今日能施常者。即是常田也。是则因食以表不食。寄灭以明不灭。经之旨归。显于此也。敬遗记。僧宗曰。自鹿苑至灵鹫。四时次第。极云复倍上数。自有偏方别教。如大云胜鬘之流。此为上根者耳。今日开宗显常。正为下根。故有次第也。宝亮曰。色者当身位也。力者当心位也。色心所成。不念念生灭。故称常命也。如来出世。凡所教化。生一念善者。悉是施人常也。何者。虽复非想八万。犹是烦恼业构。若一豪之善。必远资常果。不感生死。故知。是则常家气分。但此理深。未得便说。今方示耳。智秀曰。今言施汝者。其旨有二。何者。一以纯陀今日施值常田。理成常果。果由田得。故云佛施。二者若纯陀。以一施之因。尚感于常。况于佛积行累劫。而非常耶。慧朗述僧宗曰。此第二阶。就功德门。明施之果也。此五事者。以对无常故。说为常耳。其色及辨才。就迹为言。命力安等三事。就本为论

何以故纯陀食有二果报无差

案。道生曰。居极而言。佛是常故。能施人常。就菩萨为论。体迹未极。交是有须。若必有须。何得忽从粗形。顿成妙常耶。显其必同上言乃令实耳。僧亮曰。所以就佛田明常者。以上言鉾楯。不可不会。故因施生论。何者。以食者得五利故。施者获五果也。若施资食。而为用者。用是无常。果岂常耶。唯佛不假食为用故。能令施者。得无用之福耳。法瑶曰。明菩萨与佛二迹皆权。后得显佛久已是常。非始今也。若是今者。菩萨受食。及以得道。皆亦应实。若是实者。则是无常。今菩萨与佛。同共一身。云何忽然顿得常住不食之身乎。推此而明。常住妙体。别自有旨。非今丈六者也。常住既显。是则受食得道。乃至涅槃。皆是应迹也。僧宗曰。此何以故况释也。彼昔乃作树神。意施尚得常果。况汝今于佛。起一切智心耶。今昔并是法身。冥开不异。果报理同也宝亮曰。答案句直释者。谓今日何故言施汝五事常耶。恐佛意不然。人有一解。小复远取。何者。明昔已是常。今日受供。亦是本常。何以今日方云施常。而昔不言耶。故云受供虽二。得果无差也。道慧记曰。释所以得施其常命者。以施食有二。一食已入有余涅槃。一食已入无余涅槃。各离二魔。除患处同。能办大事。以此二时功用大故

何等为二一者受已(至)令汝具足檀波罗蜜

案。僧亮曰。所以牵学地者。明无常有粗细也。资揣食触食。及分段生死。是粗无常。念念生灭。是细无常。若后身菩萨。岂假于揣食。以顿阶妙常哉。要是金刚。不假食故。妙常即阶耳。所以二施等者。用胜故也。若就权道断有为因果者。而难断故。金刚为习也。果难断故。无学能除也。是以二施报。等无差别也。若假食以断之。内用为胜也。实道虽复不假于食。而起施者。难得想也。故外用胜也。敬遗所记僧宗曰。此旨有二。一发昔教。二遣人封执。物情谓。昔实是菩萨。今寄福等。则常旨自显也。智秀曰。略举始末二施。并值常田。必获常果。汝是二中之一也。慧朗述僧宗曰。此第三阶。举智慧门。释所以等也。宝亮曰。辨福田者。要以罪福相对乃显也。何者。谓一念之善。上至金刚。善善相续。皆福田位也。无明住地。下至四住地。一念之惑能感生死果报。皆罪田也。大判如此。曲捡其旨。不出三对六句也。初一对者。于福中作福。得福来资。前田清净。殷重心施。与田无隔。故来资也。次辨罪田中。作罪得恶来资。如人布施。令前人造恶。则彼此相关。故罪来资也。第二对论福田中。作福不得福来资。谓作意于此人。无心于彼人。及其所送事与心乖。先无意于彼。彼无福来资。虽有心于此而此无其事。复无福来资也。罪田中作罪。而恶不来资者。如人害一阐提。以逆田故。罪不资也。第三对于福田中作恶。而田中无恶来资。但生恶由心罪。则背福无相资之力也。又罪田中作福。如人供养阐提。乃由心边自生福耳。然则辨心各有所以。糜家女人。虽作树神意施。其心无隔。冥相关感也。明骏案。夫福田之大。唯此二时。一谓成佛。二谓涅槃。值此时施。必克常果也。此旨有二。一明今昔虽殊。同获常果。以生纯陀后难也。二明若施值此时。必获常果者。我亦曾值岂得非常耶

尔时纯陀即白佛言(至)无差别者是义不然

案。道生曰。一往云等。未晓其然。须以事设难。然后辨也。僧亮曰。若佛智具足地净用胜。令施者得常。则前不如后也。若后不用。而前用。则后不如前也。此五难中。前四明地不净。后一明佛无用也。法瑶曰。向直云等。未知所以然。今寄不等之难。欲明二迹同是权而不实。若使菩萨果实而非权。则佛亦同分。所以然者。既共一身。佛云何独常。而菩萨不耶。今据佛是常。乃所以显菩萨是权也。敬遗记僧宗曰。难意假执昔教。每使前劣而后胜。若不等之义既成。则常之义坏也。虽许后胜。乃所以不胜。何者。若先是无常。岂容少时便得为常。初就功德智慧满不满为难。第二以众生非众生相对。第三以报非报相对。第四行非行相对。第五用不用相对也。法莲记僧宗曰。五难难行令不等。果亦有差。现见施菩萨行。不如施佛则行胜也。宝亮曰。纯陀意亦难见。而解释者多方。今且先捡佛教。若佛本是法身常身。今日亦是复何所难耶。设若今昔。并是无常。二世复等也。正应约王宫生。推理作难耳。何者。案昔教中。以道树所成佛为实。及至首楞严经。云七百阿僧祇寿者为真。丈六者为应。而二理并妙。非我所知。且见王宫所生烦恼之身。始成佛耳。如法华中弥勒所难也。若推理而言。业与烦恼。能得无常苦报。今烦恼业尽。报亦应无。云何犹有此五阴耶。然亦可是化。非我所知。但今日十地行满。无漏圆足。所得果报。理应是常。若尔者。先受施时节。即未成佛。应是无常。今日是常。二施之报。云何言等耶。昙爱曰。此下第二段有两章。第一难第二答

何以故先受施者烦恼未尽(至)普得具足檀波罗蜜

案。法瑶曰。涅槃居宗。苞含者众。略举三义。以显其体。此据菩萨实迹为难也。若烦恼未尽。则未得种智。以未得故。则累缚犹有。未得解脱。此举解脱为难也。僧宗曰。惑以障明。若一豪不尽。则种智不起。是则智断不具。云何能生檀之福耶。宝亮曰。五难之意。第一难种智有得未得。第二难四魔降与未降。第三难法身登与未登。第四难行因满与未满。第五待食资与不资。此即第一也。法安曰。五难之中。前三难明昔受施时。应除者未除。后次一难。明昔应得不得。第五难用不用

先受施者犹是众生后受施者是天中天

案。僧宗曰。此第二就人作难也。经有两本。亦云犹是众生。盖捉终而望始也。亦云直是。盖言但是行地人耳

先受施者是杂食身(至)二施果报等无差别

案。法瑶曰。此就法身为难也。僧宗曰。虽为食所资。极此一生。故言后边也。既已成佛。惑必尽。故言无烦恼身也

先受施者未能具足(至)二施果报等无差别

案。法瑶曰。此举般若也。若此三事。有具不具。是则常住涅槃。有得不得。云何等耶。敬遗记僧宗曰。举六度。以明万行未满。举五眼。以显众德未成也。唯得肉眼者。此就与夺为名耳。肉眼所见最粗。与其名也。佛名为觉。理然未得也。乃至慧眼者。物情谓。乃可不得佛眼。岂容不得佛慧眼耶。今云既未得佛眼。佛之慧眼。岂可得乎。是则果上慧眼。乃至未得。况佛眼耶。又释云。五眼之中。肉眼天眼在凡地。其余三眼在果上也。谓佛眼最胜。次法次慧。今捉胜之劣者。略中语故。故云乃至也。慧朗述僧宗曰。云具足肉眼乃至慧眼。而不言佛眼者。佛眼无体。但此四眼。所见明了。便是佛眼。故但云四眼具足。已知具佛眼也。智秀曰。因中唯有四眼。前已与其肉眼。次明未得佛眼。今明所以佛眼未得者。因未满也。故云。乃至因地。慧眼亦未得也

世尊先受施者受已食之(至)二施果报等无差别

案。法瑶曰。前三难。明极已未极不得等也。此一难明受用不受用也。受用则获五果。不用则无不应等也。僧宗曰。受用者。则有所资。资故消化。施主还得无常果也。若无受无资应迹而已。理获常报也

佛言善男子如来已于(至)常身法身金刚之身

案。僧亮曰。此总答前四难也。法瑶曰。久非食身。菩萨之迹。不实明矣。以是常故。等施常也。此答第三法身未具难也。僧宗曰。五难之意。虽假为不等。意欲显等。因此释等。常旨宣矣。此先答第三难。而义释五也。难意。唯令前受施者。实是菩萨。今答云久无食身。是则始终皆权也。智秀曰。此正答第三难。兼答第一难也。此正明二时是应。而法身实田。久是常也

善男子未见佛性者(至)二施果报等无差别

案。道生曰。何以知久非食身耶。夫见佛性照极之时。岂待食乎。而云食已见者。答知非实也。僧亮曰。此就实行菩萨。亦有假食为用。与不实用。二斯净也。何者。食之为理。消入百脉。于身成用。及其用时。即见佛性。无复烦恼所以等也

菩萨尔时破坏四魔(至)二施果报等无差别

案。僧亮曰。初成道。破天魔烦恼魔。今日破荫魔死魔。举其大数。故通言四耳。法瑶曰。此答第一难也。夫无常之身。未出魔境。何者。既是累法。即烦恼魔也。是有为故。即阴魔也。是死法故。即死魔也。与天魔同然。岂出其界哉。去破四魔者。岂非义在常住。然常住者。岂双树始得。以始明故。无魔之义显耳。僧宗曰。此答第二直是众生难也。夫惑以障明。亦是牵生之要。今者相与破四。故云等也

菩萨尔时虽不广说(至)二施果报等无差别

案。法瑶曰。答第三难也。久得般若。但说与不说。其时异耳。僧宗曰。答第四六度五眼未修难也。所化之根。有熟未熟。故有语默之殊耳也

善男子如来之身已于无量(至)最后所奉实亦不食

案。僧亮曰。答第五用不用难也。罗汉尚不食。况后身菩萨乎。权之与实。前亦不食。后亦不食也。为诸声闻者。佛若不受。则小志自绝。是故示彼去人不远也。为此大众者。向所以不受供。以显去留之情异也。恐时人杜意。谓不复慈接。不敢请也。法瑶曰。答第四难也。明菩萨实不受用。迹受用耳。今入涅槃。亦是迹受。二受俱迹。非等如何。昙济曰。昔亦无五事果。今亦无矣。昔为小乘故受。今为大众故受。二迹不殊。何疑于不等耶。僧宗曰。答第五难也。二迹俱显。有何优劣乎

尔时大众闻佛世尊(至)是佛子如罗睺罗等无有异

案。僧宗曰。闻佛为大众受食。必有报施之义。亦有可请住之理。故喜也。昙纤曰。此下是四段之第二。大众欢喜。因请住以明常也。昙爱曰。此八段之第三。有两章。第一欢喜叹纯陀。第二请纯陀令请佛也。慧朗述僧宗曰。此下犹是第一段中。七章之第五章。大众叹纯陀也。敬遗记僧宗曰。此施门五章之第三章。大众欢喜也。宝亮曰。大众欢喜有三意。一者晨朝唱灭。不明有时。但恐不及。既仰睹慈颜。故欢喜也。二者向既不受众人所供。但恐徒弃。今闻受纯陀供。复云普为大会。故欢喜也。三者不知何当涅槃。我虽不达佛意。而纯陀善得圣心。今请纯陀。令请佛住。或有住理。是故欢喜也。智秀曰。此下四段之中。第二有三章。第一大众欢喜请纯陀。第二纯陀自庆。申大众意。以请佛。第三佛可其自庆。止其所请也。名解妙义者。美其向者。与佛共论二施之深奥也

尔时大众即说偈言(至)是故应见为稽请调御师

案。僧亮曰。昔佛初成道。观世间难化。欲入涅槃。于是梵王。请转法轮。今汝请佛。得受所供。与彼梵同。梵王是第七天。欲云超第六天也。僧宗曰。此五段之第四。请纯陀令请佛也。明骏案。此四行偈。各有一意。第一行将欲请纯陀故。先叹其有梵王之德。次一行之请纯陀令请佛。次一行明所以应请佛之意。次一行重申为请之至

尔时纯陀欢喜踊跃(至)亦复如是复起礼佛

案。僧宗曰。此第五段。从此入偈。尽十一行半也。喜有二意。一以蒙解受供故喜。二为大众所悦可故喜也。宝亮曰。纯陀欢喜有三意。一意以佛受供故喜。二以檀度既成。入圣流故喜。三为众人所叹故喜也

而说偈言快哉获已利(至)释梵诸天等悉来供养我

案。僧亮曰。初四偈半。别相自庆。内得人身。外值佛世。超六道也。次四偈。总相释已。所以得成檀度者。以外值彼度世之师。内发正愿故也。次两偈为欢喜作譬也。次一偈说天人归命于己。结所以可庆也。宝亮曰。初四行半。庆离六道生死。次二行。庆难值而值。次二行发愿也。次三行叙所喜事也

一切诸世间悉生大苦恼(至)久住于世间

案。僧亮曰。犹如日出时。此半偈。应与犹如虚空中半偈相换也。敬遗记僧宗曰。此下讫哀叹。请门明常。从此讫品。有十别。第一有七行偈。纯陀腾大众意请也。第二佛述纯陀自庆。止所请也。第三纯陀领解。虽知本处不可请。今重请于迹也。第四文殊假为不达。执迹生论也。第五纯陀举贫女火人二譬。以劝修也。第六文殊结此二譬。与纯陀也。第七因请还拂食迹。第八双拂二人之迹。何以然耶。文殊向假为不达。而纯陀每居胜地。物莫之信。故须印可也。第九放光催供。第十纯陀领解。如来述成也。此即第一腾大众请也。慧朗述僧宗曰。此下讫琉璃珠譬。通是第二请门明常。分为两别。何者。前纯陀请佛受供。为上根人。开宗明常住因果。今从此以下至放光催供。因重请为中根人。开常住因果。次从放光催供讫珠譬。因放光动地。二种涅槃相。以开常住因果也。就为中根人说中。分为十一章。第一纯陀腾大众心请佛。第二佛可其自庆。第三违其所请。第四纯陀重请。第五文殊止纯陀。不许有请。第六纯陀讥文殊。正明常果。第七说贫女丈夫二譬。诫劝文殊。第十遣悦念之着。第十一举调御驾驷及金翅鸟两譬。明上能知下。下不能测上。向来往复。盖罔像玄区。岂谓克探理衷乎

大般涅槃经集解卷第四(纯陀品上)大般涅槃经集解卷第五(纯陀品第二卷之第二)

  文殊与纯陀论义　释妙本见丈六以金翅鸟为喻

    纯陀品之第二

佛告纯陀如是如是(至)成就具足檀波罗蜜

案。智秀曰。佛印其喜庆也

不应请佛久住于世(至)诸行性相亦复如是

案。道生曰。应感之事。是佛境界。示同于外。理不可请。内实常存。又何所请耶。僧亮曰。应迹是诸佛境界也。应物而灭。灭不在我。犹形迁而影谢。岂可请耶。实处不灭。复何所请。诸行性相者。性生性灭。性不可请。应如所宜。何可请哉。法瑶曰。应由物感。感息则谢。岂可请耶。僧宗曰。丈六是法身之迹。还是神极所知。故言境界也。应于所应。岂得留耶。诸行性相者。上举境界。明应同所应。今举性相明所应同应也。性语其内。即以迁流潜谢为质。相语其外。取其百年终灭为义也

即为纯陀而说偈言(至)上至诸天身皆亦复如是

案。僧亮曰。证诸行不可请也。僧宗曰。此偈中亦可乱明无常苦等诸过也。今随义关者。初三偈半。无常门。次众苦轮一偈。苦门也。次有道者。谓二十五有。此半偈空门也。次可坏法两偈半。无我门也。已有如斯之过。故云。如蚕处茧。不自在也。此身苦所集一偈半。不净门也

诸欲皆无常故我不贪着(至)今日当涅槃

案。道生曰。以理验知。非实涅槃也。夫从惑有身。身必起惑。何由能反。要从师乃悟。而受悟有解。惑则冥伏。冥伏不起。亦名为灭。而未永灭。若至于无师。然后都尽。谓究竟断矣。然则久已无有。今日舍身。明非实灭。灭既非实。示同奚请耶

我度有彼岸出过一切苦是故于今者唯受上妙乐

案。道生曰。夫有有则有灭。有灭则有苦。既已度有。何有灭苦耶。无苦之极。假名妙乐。假名为受。故无所应请也。僧亮曰。而证于真实者。具欲道已。真实不复灭也究竟断有者。断有即涅槃。言当涅槃是应物。不可请也。我度有彼岸者。此证法身湛然常乐。又不须请也

尔时纯陀白佛言世尊(至)常住于世不入涅槃

案。道生曰。纯陀深得不灭之旨。说其所解。以自陈也。僧亮曰。纯陀当为请主。助佛弘化。上云。诸佛境界无常。如似应身性同诸行。与真身硕异。今欲明此义故。先叹涅槃。非浅识所知也。然纯陀深解迹即本矣。但此丈六。于己有恩。是故愿得常应不舍也。法瑶曰。纯陀既闻应身必灭。法身常住。始悟无请之理。但念智浅。虽复得在大菩萨中。犹不能知法身应身常无常义。以其道未成。犹须佛教。是故因此复致请也。僧宗曰。此下请门之第三也。佛向述其所叹。止其所请。本迹二理。具如前释。今纯陀所领。已知妙本不可请也。而犹悕迹住者。谓丈六之现。事在化物。而为化参差。深浅不一。是则化功未遂也。又佛之虚心。如彼饥人。岂令化功未足。而当见舍。所以复得请也。宝亮曰。纯陀今请凡有二义。一则明己是可教之人。二则自述有所未知。佛应住世。教令成就。指饥人为喻。以显至诚也

尔时文殊师利法王子(至)欲求正法应如是学

案。道生曰。纯陀言迹。似如无灭。故据灭为难也。僧亮曰。文殊欲令纯陀。显释涅槃不灭之义。乃晦居未达。执迹兴难。谓不应请也。敬遗记僧宗曰。请门第四。论义明常也。慧朗述僧宗曰。常住妙有。是则不空。无常断绝。所以而言具空三昧也。宝亮曰。文殊迹居负地。以显纯陀之德。将使时众。舍昔所解。而从今信也。文殊执迹。有二失也。若言丈六是实生灭者。则应道便废。其失一也。丈六以法身为本。本迹虽殊。更无别体。若丈六生灭是实者。则法身之本。岂得独常。是为两失矣

纯陀问言文殊师利(至)若是行者为生灭法

案。僧亮曰。真知如来。应知如等。如来者。乘如实来。所乘既实。果亦应真。故非行也。法瑶曰。此下二人。更共广说无请之理。文殊所据。应身生灭。同诸行相。非请所能住也。纯陀所论。法身无为。不待请而住也。二者各据一边。共相抑扬。以申佛意无请之旨也。昙济曰。纯陀以五事。明如来不同诸行。第一明若同诸行。如彼车轮。第二不得名为天中之天。第三如聚落主。第四明以不同诸行故。如彼力士也。第五明若同诸行。则应如彼长者子也。僧宗曰。此明上不得同下。如来是天中之天。云何乃与诸行同耶。下有五譬。申佛是常。不同有为也。智秀曰。此下有六譬。一况始举四譬。一况正显如来久是无为。后举两譬。戒文殊也。慧朗别述曰。此下举四事以为法说。各有一譬。离之为八也。此第一事法说也。谓佛既是天中之天。岂得与凡人同也

譬如水泡速起速灭(至)一切诸行亦复如是

案。僧亮曰。车轮者。一高一下也。上云众果最胜。岂得复如车轮者耶。智秀曰。此第一譬。谓佛岂同水泡之生灭。车轮之无穷邪。慧朗别述曰。第一譬也。若谓上可以类下。与此二譬同也

我闻诸天寿命极长(至)寿命更促不满百年

案。僧宗曰。以下况上也。如非想之寿。尚八万劫。况如来耶。慧朗别述曰。第二法说也。谓若同诸行。便是昔延而今促。何者。佛昔从天而降。岂得暂在人间。便失天寿耶

如聚落主势得自在(至)勿观如来同于诸行

案。僧宗曰。第三譬初胜后不如也。佛昔道树之下。威神魏魏。如何今遂失势力耶。慧朗别述曰。第二譬也。不容如彼之失势力也

复次文殊为知而说(至)为天中天自在法王

案。慧朗别述曰。第三法说者。若同诸行。则非法王。佛以万行圆满。为三界尊。岂可得言诸行相耶

譬如人王有大力士(至)故称如来应正遍知

案。僧亮曰。王譬前佛。力士譬今佛也。伎能譬十方无畏。佛降四魔。岂是行耶。僧宗曰。第四譬也。如来道超魔境。岂是死法耶。慧朗别述曰。第三譬说也。力士以种种伎能。所以当千佛以万行满故。为三界尊

文殊师利汝今不应忆想分别以如来法同于诸行

案。慧朗别述曰。第四法说。勿空生妄想以常为无常

譬如巨富长者生子(至)如来同于一切诸行

案。道生曰。以佛所说。为证真实之理。本不变也。唯从说者。得悟乃知之耳。所说之理。既不可变。明知其悟亦湛然常存也。僧亮曰。诸佛所师。涅槃法也。若佛无常。法亦无常。故云所说真法亦无信者。慧朗别述曰。第四譬也。彼之家人。所以不复爱是子者。缘有可信相师妄想说也。若人闻汝谓佛无常。汝是可信之人。亦可缘汝而不信也

复次文殊譬如贫女

案。道生曰。上云不应说佛同于诸行。斯则解佛是无为矣。既解而能说。真护法也。引此为譬。以显其旨也。贫者乏法财也。女者以本微善。能生今解也。僧亮曰。上说佛是无为。此旨为长。应物方便。是义为短。护法者。应显其长覆其短也。女譬无常慧。慧有三种。以闻慧入理不深。譬贫也。法瑶曰。向云不应说佛同诸行相。是则内有真解。故能常信此理。可谓护法者也。今真解常住者。必由曩劫微悟之信也。是以目行者为女人。未丰善法为贫也。昙济曰。女譬闻慧能生思慧也。敬遗记僧宗曰。此第五也。前以五譬。抗折文殊。斥引未悟。今此两譬。明能作此修。必得常果也。女以生育为义。明始行菩萨能生常解。怀解转明。义同育也。未有无漏法财。故言贫也。宝亮曰。此下二譬。初借女人能宣常为譬。后说丈夫隐有为之譬也。法莲记僧宗曰。此下二譬。举内外为异耳。女人以护子为譬。显其内解坚正也。丈夫以能刚干为譬。显其外说不可坏也

无有居家救护之者

案。道生曰。行未浓故。不免为恶所坏。本所安者不立。故云无有也。僧亮曰。功德智慧。迭相扶助。譬居家眷属。以无此故。譬之无护也。法瑶曰。昔善未强。不能永固其信。还为五欲众恶所牵。失本所居。微信之家也。内无家善。外无友护也。僧宗曰。既从闻生慧。此解则远感常果。常解在我。有出世之像。是则三界非复其家。而复未获常果。在己两盈之间。故云无居家也。救护者。解力既微。未能仰感善友相奖接也。宝亮曰。佛法正以信首五根为家。始行之人。树德未深。是则佛家未立也。道慧记曰。心离生死。则三界非家也。若卅心满上初地无漏。可称生在佛家。始行去此尚远。故曰无有也

加复病苦

案。一本云穷困。僧亮曰。谓障闻慧之烦恼也。智秀曰。为八苦所病也

饥渴所逼

案。道生曰。众结为病苦。生死为饥渴也。法瑶曰。内无家善。外无友护。是以为恶友众病所加。饥渴所逼也。僧宗曰。无禅定之浆。又阙涅槃法食。故云饥渴

游行乞丐

案。道生曰。善是三界外法。而为恶所坏。来在生死。去家展转。是游行之义。既厌苦求乐。而非本善。应得不得。是乞丐义也。僧亮曰。经离五道。譬游行。生死非所乐之处。譬之乞丐。法瑶曰。为苦所迫。思善以代之。譬如乞丐也。敬遗记僧宗曰。乏定慧之食。修相善以自资。此善不多。兼非己分。义同乞丐也。游行是迟回履历。非速去之像。明相善不能直之出要也。法莲记僧宗曰。去佛果辽远。而常解冥津。有向果之义。故曰游行也

止他客舍

案。道生曰。三界之身。为邪见之宅。为恶所止。于其本善。为他舍也。僧亮曰。人天之果。为逆旅也。法瑶曰。人天之身。惑之所得。出自理外。终卒应无。譬客舍也。昙济曰。生死之中。非其久处。譬之他舍也。智秀曰。常解习因。非生死眷属。为客。五阴有权栖之义。曰舍

寄生一子

案。道生曰。既以如来无为为解。理无偏惑。譬之一子。生在所寄。谓之寄生也。僧亮曰。思慧之明。从闇而生。曰寄。明闇虽殊。所解不异。曰一。必绍佛家。曰子也。法瑶曰。解托阴生。曰寄。真而无二。曰一也。昙济曰。譬思慧也。僧宗曰。菩萨居此阴身。乃怀常解。解是我生。义称子也。宝亮曰。从闻生思。称之为子。智秀曰。常解是一。无生灭之二。曰一子也

是客舍主驱逐令去其产未久

案。道生曰。邪见是受身之本。为舍主也。非拨其解。谓如驱逐也。僧亮曰。无明是受生之本。譬主也。思慧去之渐远。譬驱逐也。法瑶曰。身为其舍。邪识所造。谓之舍主。邪见诽谤。不信常住。为逐义也。宝亮曰。解惑相违。义若驱也。是知一豪之善。必不感生死明矣。慧朗曰。断见与常解相违。而断见是生死之主。故言主人驱客携抱是儿欲至他国。案。一本云其产未久。僧亮曰。思慧始生。喻之未久。坚执不舍。况之携抱。远之常乐。取譬他国也。昙济曰闻思二慧。相与一解。喻之携抱也。修慧应得而未生。譬之欲向他国也

于其中路遇恶风雨(至)蜂螫毒虫之所唼食

案。道生曰。五欲如风雨。诸结如寒苦。恶友如蚊虻也。僧亮曰。障思慧烦恼。譬之寒苦。烦恼之果。譬之唼食也。法瑶曰。佛道长远。修难行苦行。譬之寒苦。不免魔之所恼。譬之唼食。僧宗曰。为邪学所抗折。譬风雨。未免烦恼吞噬善根。譬毒虫也。道慧记曰。生死苦果。譬寒雨。六尘恶贼。譬毒虫也

经由恒河抱儿而度

案。道生曰。怀耶嫉正。必以害加人。譬之河也。执真解而不顾险者。喻抱儿而度也。僧亮曰。已得有为修慧。而无为修慧未得。而无常难度。譬之恒河也。昙济曰。河譬非常师教也。抱儿者。譬执思慧解也。僧宗曰。河譬小乘国也。外国法。若有异执。乃至不共一河饮水。今譬趣他国者。事须经河。而通法大士。怀常解而求佛。亦宜权化异执也

其水漂疾而不放舍

案。僧亮曰。生灭事切。急于暴流。执解不舍。乃为奇特

于是母子遂共俱没

案。僧亮曰。虽在无常之中。而能不生异见。若有诽谤法者。则没命救之。法瑶曰。夫护法者。必居恶世多难之处。必为所嫉。而能虽被流漂。执解不舍。爰致丧命。遂使常住之解。不行于世。人法俱坠。义言母子俱没也。僧宗曰。耶锋盛遏于正说。遂使言屈当时。解不申显。义如子没。人被折辱。义如母没也

如是女人慈念功德命终之后生于梵天

案。僧宗曰。善护常解之果报也。梵者言净。即涅槃也。天者。第一义天

文殊师利若有善男子(至)定是有为定是无为

案。僧亮曰。若未见常理。但尔无言。则不长外恶。何用分别有为无为耶。此下出护法也。宝亮曰。若谓如来定是生灭有为。亦得言是断灭无为也。又曰。不应云佛一向恒同有为。然佛定是无为也。昙爱曰。直案句云。勿说如来定是有为。应说定是无为也。僧宗曰。若但体常而迷迹。非所以为解也。若能说本不乖迹。解迹不背本。乃契中道也。故言不应定说。同于诸行。亦不得云一向不同。若一向不同。则伤迹也。如今未达。但自责而已也

若正见者应说如来(至)生善法故生怜愍心故

案。僧亮曰。说定是无为者。说常以化人所谓如上护法也。生善法者。以善化人。人得善命。是故如来。致有长寿之报。如八河之归海矣。生怜愍者。慈护物命。是长寿之因

如彼贫女在于恒河(至)不求梵天梵天自至

案。慧朗述僧宗曰。不委悉合譬。但撮取要旨。举以为诫劝也

文殊师利如人远行

案。道生曰。此譬不说佛是有为。必以成无为义也。僧亮曰。秉常解以求佛。譬远行也。法瑶曰。前譬护法者。显扬无为。此譬隐覆有为也。始解未深。去佛悬远。譬远行也。僧宗曰。请门第五段也

中路疲极

案。道生曰。正见未浓。而邪心中起也。僧亮曰。经离生死。常解转微也。宝亮曰。谓带相修行者也

寄止他舍卧寐之中

案。道生曰。邪心内昏。譬卧寐也。僧亮曰。乘惑受报。非本所期。曰寄止。流遁既久。遂失常解。说佛为无常。譬眠寐也。昙济曰。生死不可久处。为寄也。智秀曰。虽有微解。惑障慧眼。暂忘所怀。如昏寐也

其室忽然大火卒起

案。道生曰。害逼身命。喻火烧室也。僧亮曰。既生此谤谤。殃及身也。法瑶曰。犹譬耶辨也。昙济曰。始觉故言卒起

即时惊寤

案。道生曰。知非己招。如从眠寤也。僧亮曰。知祸由己招也。宝亮曰。怪耶辨之非。曰惊。寻理不然。曰寤也。道慧记曰。向以暂不缘。今还得解

寻自思惟我于今者定死不疑

案。僧亮曰。谓谤佛之罪。重不可灭。法瑶曰。执正解不从耶言。知必见害也。宝亮曰。谓若从耶道。必入地狱也

具惭愧故以衣缠身

案。道生曰。即以惭愧为衣也。若言佛是有为。无惭愧也。曰誓不重造。譬惭愧。还说佛常。[雨/復]昔所短。喻缠身也。昙济曰。以护常之言缠解常之也

即便命终生忉利天(至)展转常生安乐之处

案。昙济曰。惭愧故生天。护常故解脱。僧宗曰。结果报也。忉利天有卅二臣。譬表卅二相也。八十反者。八十种好也。大梵王者。梵名涅槃。王即佛

以是缘故文殊师利(至)疾成阿耨多罗三藐三菩提

案。僧宗曰。举譬诫劝也

尔时文殊师利法王子(至)具亦当[雨/復]如来有为

案。僧亮曰。佛开常宗。而纯陀广之。说得其致。故叹也。僧宗曰。请门第六也。以火人譬。结与纯陀也。法瑶曰。非直善其能言。亦美其深解也。物谓亡身为法。未有其人。故结指纯陀显不远

有为无为且共置之(至)如是施者诸施中最

案。僧亮曰。欲令广上不食之义。故因催供。以显之也。法瑶曰。上明如来无为。今因催供。以显丈六非是无为。不同行相也。僧宗曰。此请门第七。催供也。宝亮曰。此下催供。第四段也

若比丘比丘尼(至)应当清净随时给与

案。僧亮曰。明时物净物施。必成檀也

如是速施即是具足(至)如来正尔当般涅槃

案。僧亮曰。檀是法身种子。时物是檀种子也。多少者。上已说物。未明心地。今次说施有八种。如论文所释。今明佛僧定清净心。多是持戒人。但物多少不定耳

纯陀言文殊师利汝今何故(至)即是法身非为食身

案。法瑶曰。文殊既催。恐物谓丈六全同凡人。故纯陀复明但示同耳。岂实须哉。僧宗曰。纯陀显法身不食。乃引昔况今也

尔时佛告文殊师利(至)善入甚深大乘经典

案。宝亮曰。纯陀言可佛意。故述成也

文殊师利语纯陀言(至)亦复悦可一切众生

案。僧亮曰。爱念生于偏着。今明如来理合则可。情无偏也。皆悉悦可者。言理未显。故复详之也。慧朗曰。此中遣念有三翻。此即第一遣偏念也

文殊师利言如来于汝(至)我与仁者俱行颠倒

案。慧朗曰。此第二遣一切念也

文殊师利如来无有爱念(至)即是诸佛智慧境界

案。慧朗曰。此第三举譬明无有相之念也。明骏案。自二人傍论以来至此。有三源。前辨常无常义。总拂有为之迹。以显常住妙本。可请不可请义也。第二拂应身之迹。夫食以资身。若虽食而不食。岂身而是实耶。第三拂应心之迹。寄悦可之。以表无念之念。故因此述成。以遣心迹

文殊师利譬如国王(至)直欲试汝诸菩萨事

案。僧亮曰。鸟譬佛也。无量由旬譬观空也。海譬生死也。龟鱼譬六道。己影譬应身。明空有两息也。凡夫者。谓具缚者也。少智者。指二乘也。敬遗记。僧宗曰。此请门第八。拂二大士迹也。慧朗述僧宗曰。此中有两譬。前明下不及上。以鸟譬明上能知下也。后文殊自拂迹也

尔时世尊从其面门(至)纯陀闻已悲塞默然

案。僧亮曰。纯陀昔愿最后设供。申述常住。言理已显。不灭现灭。不食现食。其粗周矣。今文殊先发。然后口告也。法瑶曰。前文殊催纯陀设供。为纯陀所诃。似若文殊前言为虚。是则丈六之身。复都不受人施也。时会之供。便为空设。不遂素心。是故放光照文殊身。以证文殊向言不虚。故宜催也。僧宗曰。请门第九。催供也。上来显常拂迹既毕。物情不复滞迹也。虽食而知不食。故重放光。表迹必去也。道慧记曰。纯陀向请住。而文殊傍论。事既已竟。今放此光。以詶其意也。既不许其请住。所以因光而催供也。慧朗述僧宗曰。从此下。讫琉璃珠譬。为下根开常住因果宗也

佛告纯陀汝所奉施(至)第二第三亦复如是

案。法瑶曰。欲令速设。使时会各遂素心。故三告之

尔时纯陀闻佛语已(至)同声劝佛莫般涅槃

案。僧亮曰。恐一人之诚。不能仰感。故凭大众令共请

尔时世尊复告纯陀莫大啼(至)有为之法多诸过患

案。僧亮曰。非无所益。乱心迷道。非行者所宜。当观其身。释无益之旨也。汝身是所应。所应既不得。住应岂得住耶。宝亮曰。杂毒者。昔教生解。因果未分。亦言杂毒。就今经而谈。金刚以下。虽明解非毒。而其体与苦未相分。故亦言杂毒

于是纯陀复白佛言(至)是故汝今不应啼泣

案。僧亮曰。纯陀重请之意。谓佛慈悲。以应苦众生。今我现苦。所以愿佛留慈应也。佛答意。以去必有益。住则无益也。诸佛法尔者。以生灭为苦。无生灭为乐。故我灭此生灭之苦也

尔时纯陀复白佛言(至)[雨/復]思自惟复生庆悦

案。僧亮曰。如来现同有为也。人知有身为苦。厌苦求灭。所益弘多。所以庆悦也

佛赞纯陀善哉善哉(至)速办所施不宜久停

案。僧亮曰。皆至是处者。现同起灭处也。皆如幻相者。令其观空。以止悲恋之乱也。以方便力者。若诸法不空涉有。不名方便。佛心不应无著也。以佛心无著。证诸法空也。诸佛法尔者。证无著是佛果也。我今受汝食者。证方便。不食而受。盖方便之益。僧宗曰。此下讫品。第十段领解也

尔时纯陀为诸众生(至)从坐而去供办食具

案。僧亮曰。善已今施。必成佛福田也。涅槃难了。若檀行成就。自当了也。道慧记曰。纯陀迹未善解设供之法。故携文殊去也

卷第五(纯陀品下)大般涅槃经集解卷第六(哀叹品卷上)

  释地动　出空不空空等十五法门　合正法宝城譬　释伊字释槃　释若离若不离无常想义　释五十七烦恼义

    哀叹品第三

案。慧朗述僧宗曰。从前品末放口光催供。讫珠譬。犹是请门明常。此为下根说也。有六段。第一放光催供。第二动地大众哀叹。第三说五譬讥请佛也。第四佛劝问又夺其所得也。第五比丘叹昔教。第六说胜修也。敬遗记僧宗曰。哀叹品初。犹属前品纯陀腾大众请。是第二请门明常也。从复次比丘若有疑惑以下。是开宗中。第三劝夺门明常也。有四别。第一夺果。第二夺因。第三举宝珠譬。成昔果所以虚也。第四结会二教也。宝亮曰。大分此品有七段。第一说偈及长行。陈己之苦讥请佛也。第二佛即劝舍昔之所得修也。第三比丘还更请佛住世。教我修方也。第四佛复劝令但随佛教。修三胜修。必获常果也。第五比丘复请若佛果是常者。何不住世。示我胜修耶。第六更劝明今日灭度。为汝有偏执之病。汝但莫保昔日所行为实也。既三劝三请竟。众人始怀一疑云。理若果然者。佛初出生。何不早为我说。第七便会通古今也。道慧记曰。大分此品为四段。第一大众哀叹。第二佛开涅槃宗。第三说胜修。第四会通也。又曰。分为九段。第一将欲涅槃。所以动地。第二大众说偈及譬请佛。第三佛说两偈。止其悲请。第四若有疑惑。开常无常之端。发于众疑。劝其令问。即说三点涅槃也。第五比丘未能受故。所以还叹昔教为是也。第六佛为说胜三修法也。第七比丘更请佛住。佛以迦叶。当为依止。止其两请也。第八还以珠譬。劝其令舍昔之所修。修今胜修也。第九会通昔日不得即说。今日得说之意也。后六段自相属也。智秀曰。从此入长寿品。至童子迦叶问。正说之第二也。大意有六段。第一现动地。表佛必至。第二时众说偈及五譬。请佛住世。第三佛举诸法以劝问。第四说胜修以夺执也。第五说医譬。会通古今。第六段重作六翻。举法以劝也。法安曰。此品是开宗之第二段。有三别。第一讥请。从品初。讫伊字涅槃。第二执昔教请。从快说无常。讫三修也。第三举今教为请。从如佛所说离四倒者。讫品也。三列之中各有两翻。从始讫五譬。是请体。次从佛告比丘以下。答所请也。就第二请中。初从快说以下。执昔教以请也。我既不解。愿住世为说也。次从佛赞比丘以下。詶己所请。云但习今教。得离四倒也。就第三请中。初从离四倒者。讫随佛入涅槃。谓若佛是常。常则不灭。云何不住。教导我耶。次从我以正法付嘱迦叶。以詶己请也。明骏案。此品大分为五段。第一大众见地动。知是表灭。乃哀叹说五譬。以邀请佛也。第二佛说两偈。止其哀叹也。第三举法劝问。讫珠譬也。第四时诸比丘。闻说珠譬。始悟于理。是以发问。昔日何以不即说耶。第五佛以新旧医譬。会通古今也。就初段中。有三章。第一经家叙地动事。第二大众说偈自陈。第三以五譬讥请也。就第二段中。有两章。第一寄言激切。谓莫如凡夫也。第二以偈说法。止其哀情也。就第三段中。有五翻。第一举法劝问。第二比丘执昔所得。不解今旨。第三佛说胜修。夺己所执。第四比丘闻胜闻夺。此则已昔为非佛今为是也。以己未解。仍复致请。谓佛正应住世。教我令解胜修。乃以命要请也。第五佛以珠譬。晓其迷也。第四第五段。不复开也

纯陀去已未久之顷(至)是故此地如是大动

案。僧亮曰。佛与纯陀。说常住感应之义。备于上文。纯陀既去之后。疑者应发。而未即问者。冀佛稽延也。故现必去之征催令问也。六种动义。备之华严经也。此中有两意。前讫众生心动。动中有声。说大小之相也。从兜率天下。至如是大动。明必有大事也。学地有三种。无学地有三种。而五种已过。此第六也。法瑶曰。大士既去。无人扣发。是故动地。以表涅槃。速其劝请之端也。伊字涅槃。因斯而唱也。宝亮曰。此第七相也。此端来意。非为召众。但时人见佛威光恬然。情意小惰。更现此相。以表必去也。此下讫老少二人譬。第一自陈己苦请。而讥佛也。有三意。第一说十一行偈半。正陈苦而请也。第二后两行偈。明佛若在世。有除苦之益也。请竟佛默然故。第三更引事讥佛也。智秀曰。此第一段也。地中有此声者。表两义。一者令知今是大动。二者令知此动为涅槃相也。慧朗曰。前品末放口光。此品初动也。皆是欲为下根人。重说常故也。从放口光讫偈。六段中。第一现涅槃相也。有三章。此第一章

时诸天龙乾闼婆(至)如来见放舍犹如弃涕唾

案。僧亮曰。明佛去之苦也。智秀曰。此下讫五譬。第二段。自陈哀叹。以请佛也

譬如日初出光明甚晖炎(至)譬如须弥山

案。僧亮曰。佛若住世。有如是之益也

世尊譬如国王生育诸子(至)唯愿久住不入涅槃

案。僧亮曰。上两章。备陈去留之损益。申己苦以请佛。而不蒙慈顾。此下讫长行。以五譬过佛也。第一明无善始令终之美。第二明以有为为苦。无为为乐。畏有为故。佛非无为也。第三说无为乐。以子在狱。父不得乐为譬也。第四慈而不等。第五都无慈也。法瑶曰。此譬自言虽得正见。而般若未具。请佛住世。成我般若也。僧宗曰。四部不一譬诸子。明慧不耶。喻端正也。初教定慧。令我修学。生我慧命应追胜慧。教以深理。则慧命不断。佛今既去。胜慧不续。非杀如何。宝亮曰。我未免四魔。而佛见舍。岂非以子付旃陀罗耶

世尊譬如有人善学诸论(至)则不复畏堕于地狱

案。法瑶曰。此譬谓佛具足。若应住世。为我说之。如其涅槃。于诸法畏而不说也。昙济曰。如来如似畏有为也

世尊譬如有人初学作务(至)云何如来得受安乐

案。法瑶曰。此譬明我未得解脱。请佛住世。教我令得也。昙济曰。喻小乘初业也。囹圄者无明也。有人问者菩萨也。敬遗记僧宗曰。声闻教修行。断诸烦恼。为初作也。彼人以能勤故。得罪于囹圄。今明虽断粗惑。而细者不倾。故为阴果之所笼樊也。有人问之受何罪者。天下有无事。傍人为复顾问。不能为益。若世尊果去。则同傍人泛尔无慈者也。又释。以慈悲为官也。宝亮曰。谓佛不应负誓者。昔发四弘愿。处生死度一切众生。云众生病愈。我病乃除。今我幸是可度之数。而佛息化。岂不违誓耶。慧朗述僧宗曰。初学菩萨。怀大慈悲。誓为众生。不舍生死。生死之应。必不可免。如官所收。若众生得度。佛乃安乐。云何今日。独离苦恼耶。有人问者。余大菩萨。问始行也

世尊譬如医王善解方药(至)唯愿久住莫般涅槃

案。法瑶曰。佛若不住。教我令得解脱者。则有秘吝。如彼医也。昙济曰。虽谓有慈。而心存胜负伤平等也

世尊譬如老少病苦之人(至)久住于世勿入涅槃

案。法瑶曰。此譬明己习学始。尔未成法身。请佛住世。咨问修学。法身可成。昙济曰。若有慈者。则应救苦。今既舍苦。岂谓有慈也

尔时世尊告诸比丘(至)远离诸非法自慰受欢乐

案。僧亮曰。以慈愍故。是以现灭。备之前文。但凡夫爱缘悲重。不可理悟。今偏告比丘。以厉诸人也。宝亮曰。此下第二劝也。有三意。第一戒时众。第二总因果中劝。第三劝舍昔日所得。修今伊字也。此即第一对比丘。戒凡夫也。诸佛法尔者。有感则应。感尽归真也。乐不放逸者。教令持戒守心。正忆念者。其修定。下句修慧也。智秀曰。此下第三段。正举诸法。述佛本意。劝令问也。有三别。第一将欲使问。先两偈。止其乱心也。第二广举诸法劝问。第三更举异缘劝问。此即第一。止其哀乱也

复次比丘若有疑惑(至)我当随顺为汝断之

案。道生曰。佛虽为纯陀。说不灭之义。而诸比丘。执昔教不已。今将释之。以明今昔之教。则妙善同也。说一切皆者。本为众生着三界之惑。以遣不空之病耳。言迹既漫。理应致疑。今许其疑问。微言得显。引背归宗也。僧亮曰。开宗有略有广。此广劝问也。诸比丘观四非常。断疑成道。闻佛常住。应于此果生疑。则应问而无问者。必以昔说是实。若以昔说为实终不悟今教也。是故称名。发其疑端。昔说一切空。今言不空。是可疑也。僧宗曰。此开宗之中。第三也。前第一因施明常。第二纯陀腾大众请明常。今此第三劝夺门明常也。所以将夺而先劝问者。向以五譬讥佛。或言吝法。或谓慈偏。今劝其令问上开宗之旨。发今昔二教。显二种不可请。既所未达。今应疑问也。生死虚假。终归于空。涅槃圆极。湛然常存。为不空也。昔说无常。止于三界。今言无常。三界外也。昔以三无为为常。今明妙有以为常也。宝亮曰。此下第二举因果。总劝问也。智秀曰。第二广举诸法。以劝问也

亦当为汝先说甘露然后乃当入于涅槃

案。道生曰。如必不疑不知问者。亦当自为汝说。终不使汝。遂堕疑惑也。僧亮曰。谓汝自有疑。而不能问。我当为说。然后涅槃。宝亮曰。总答前五譬讥请意。自出世以来。说苦无常。除余四倒。今说常乐具足入道。何致终始之讥耶。今昔所说。穷幽微之理。岂有畏法过耶。今入涅槃。广为汝说甘露极理。令得常乐我净之法。有何乖愿耶。今欲令汝识常。与文殊等。岂谓慈偏耶。出世已来。教尔正路。今复示汝甘露妙道。岂曰无慈耶

诸比丘佛出世难人身难得(至)如求金沙优昙钵华

案。僧亮曰。所谓将欲夺之。必固与之。僧宗曰。向来劝问。从此下夺也。有四段。第一夺果。第二夺因。第三举宝珠譬。明昔果所以是虚第四结会二教也。宝亮曰。此下第三偏劝舍昔所得果也。有四意。第一先叹比丘能离五难。并劝也。第二正夺果。第三夺昔所行因。第四劝修取今常果也。智秀曰。此下讫如世伊字。第三别更举异缘劝问也。有三章。一举比丘德。第二举比丘失。第三举佛真实教敕。以劝问

诸比丘离于八难得人身难(至)是故汝等不应放逸

案。僧亮曰。向与今夺也。昔偏执以为足。更不进求。岂非空过放逸人耶。僧宗曰。比丘既勤勤请住。佛不许住。而乃劝问。所举之理。非其境界。绝咨启之方。乃退保所得。息进向之路。承其此念。故有空过之责。举昔苦行。以显大慈之难负

汝等比丘云何庄严(至)值遇宝城取虚伪物

案。僧亮曰。此譬广上事也。城喻涅槃。僧宗曰。佛果排遣累。喻城之防非也。戒防身口外失。如墙也。定水为堑也。慧能决断除恶。如俾倪也。保其所得。谓取虚伪物也。宝亮曰。第二夺果也。宝城无体。为众宝所成。若一德不备。不得称为大涅槃也。昔之所说。乃是涅槃因缘中说耳

汝诸比丘勿以下心(至)未为正法除诸结使

案。宝亮曰。此第三夺已昔日所因也。有四句。唯劝令忘怀两修而德也。虽服袈裟者。此乃始学之初门非涉真之极路也

汝诸比丘今当真实(至)种种烦恼病之良药

案。僧亮曰。真实事者。谓常理也。常理难解。既非散心怯弱所知。故须摄心也。唯有佛日能照。佛日没已。汝等当为无明所覆。云何能见耶。大地是众生共报。佛法亦尔。本为众生故求此。即众生法已。僧宗曰。十力慧日没者。谓时机难差也。草木为众生用者。资益法药。以除患也。既有法药。所以时不可失也。宝亮曰。此第四劝修今因。取今果也。将欲劝修。先以一句诫敕竟。略出常住体相云。如来法性。真实不倒也。昔日亦云法性。而是断灭之教。今日所明常果体。百非所不得。无有亦无无。谓一相无相。不断不常。如此心缘。岂是颠倒耶。即生三法。为修因之方。谓精进摄心勇猛也

我今当令一切众生(至)悉皆安住秘密藏中

案。僧亮曰。入者常住之理。昔为无常所覆。众生不见。今得见故。名之为入也。僧宗曰。上略开常。未出常体。今既夺彼所得。宜显其相也。秘密者。谓十地所不见。唯佛能了也。众德蕴在圆果之中。义和藏也。宝亮曰。住者有三位。谓信见得也。何者。从外凡至九地。通名信住。第十地者。名为见住。唯佛乃居得住位也

我亦复当安住是中入于涅槃

案。僧亮曰。佛得常故。名为住也。为物涅槃佛不灭也。僧宗曰。向指大众。今指如来。明同得不异耳。入者。谓丈六之迹。缘尽。反真。约应不现。故言入也

何等名为秘密之藏(至)名入涅槃如世伊字

案。道生曰。夫照极自然。居宗在上。上不可并。故横必非矣。所除累。近则解脱。于下无不应。兼则色身是俱。非先后故。纵亦非也。三无离理故。别之尤非。是以湛然弗差。犹如伊字。既云常矣。岂有今灭。今灭非实。色身则存也。一言蔽诸。伊字之喻也。僧亮曰。若并者。身能发智。智用满故。三法俱常。智功既胜。故不并也。纵亦不成者。身智之灭。无优劣故也。面上三目者。般若居上。身及解脱。二无胜故。并列在下。此释三德相缘。得常之所由也。若别者不相因也。身得智。不由智得灭。是则俱无也。具此三法。所以谓安住也。名入涅槃者。谓常法无灭。为物故灭也。法瑶曰。三法各异者。体异则有分。有分则无常。岂宜各异而合成涅槃耶。又虽云一一非耳。然离此之外。亦更无也。僧宗曰。并不成者。明功用不同。纵不成者。明义无胜负也。别不成者。明无异体也。解脱亦非者。此总合前两句。若言解脱功用即法身功用者非也。三法各异者。合第三若别句也。言解脱亦非有。唯主灭累一义。不收圆德。文句隐略。得意者。应云解脱。非涅槃所成圆体已。何者。以三德成秘密藏。此收佛地功德斯尽。向者三德。各收一义。是为捉别。云何收尽。故言非涅槃也。宝亮曰。并者。以一时俱有。以为譬也。何者。昔以事断无为为涅槃。而此无为。与身智并故。非今日伊字也。纵者。以前后为目。亦譬昔日无余涅槃也。谓先有身。次有智。后有灭。故言非也。如三目者。上以二句非昔。此句正是于今。谓万德之上。总明涅槃也。三点若别者。谓三德之上。一一偏取。亦不得也。下句云。法身亦非等也。三法各异亦非者。谓各有别体也

尔时诸比丘闻佛世尊(至)于诸想中最为第一

案。道生曰。既闻涅槃如世伊字。始悟昔说无常之旨。止于三界。而远表于常也。僧亮曰。受解请也。闻今伊字之譬。解佛昔说一切无常。是方便也。而此方便。能断三界实结。何快如之。法瑶曰。佛说伊字涅槃之常。是则已说非涅槃者无常也。又自因今解悟昔说无常旨在非佛。乃所以表佛是常。可谓快说也。僧宗曰。向释三义。旨趣幽深。求之于心。冥然分外。交闻唱灭。舍应归本。长与物隔。故愁忧也。快说无常者。伊字之说。非情所解。前涂难涉。退保先教。何以示耶。如来昔教。令我修学无常等观。离三界惑。依教修行。果得出苦。所以不难。今日教者。今虽言常。而我未得。我既未得。事在如来。交见灭度。虽有常言。不睹其事。如其不住。则昔说可凭。是以叹也。象迹为上者。上句叹教。此句叹从教生解也。宝亮曰。从此以下。请中第二文也。若为凡请。大旨有二。第一者。佛说二十五有。作五门观。而佛故是常。得知金刚以还是生死。而后心是常也。我是可教人。佛应住世也。第二佛虽为我说伊字涅槃。不知云何而得也。就此第二请中。有三段。第一明我是可教之人。略有所解。故先以二譬。叹今苦空无常五门除惑。胜于昔日也。第二从帝王。讫醉人譬。正请辞也。第三从叹芭蕉已下。执昔教。以要佛若不住世。我当寻昔所习。通于佛上。修苦无常也。快者。快上纯陀品中五门观也。纯陀品中。说常无常。今但叹无常之理。昔来所观常理。本所未达。且留此理。以为请辞。谓我未解。应住世教我也。我若已解今日常旨。用请何为也。智秀曰。此下第四段夺执也。有四别。第一正执。第二夺执。第三请住。第四佛答。从此讫而有诸见其无是处。第一快昔教。拟为反请也。明骏曰。此下讫无我想劝问中。第二翻上举胜法劝问。既非己所解。乃还执昔教也。有三阶。第一劝昔无常教。于我已解。第二举帝王等譬。明所未解者。在乎今教。而佛不住。教我令解耶。第三举叹无我等教也

若有精勤修集之者(至)无明憍慢及无常想

案。僧亮曰。举三界实结。显无常教之力能也。不说嗔者。以易断故也。法瑶曰。若能勤修无常想者。则不离三界惑及佛上无常想倒。快说之义。其在此也。僧宗曰。想有二种。若习观观空前方便者。不能除结。今取空观。协解无常。即是空慧。作想名说也。若不尔者。还取空前方便伏结。由伏后断。故通言断也。及无常想者。断见无常耳。宝亮曰。此是思惟门中。最后所断者。故偏举。非不先断粗也。及无常想者。兼除佛上倒也

世尊如来若离无常想者(至)无明憍慢及无常想

案。道生曰。上云修无常。能除无常想。想是慧名。似若鉾楯。宜更明之也。若离者。谓不修无常想。则无般若。般若既无。则无解脱。今日岂得入涅槃乎。若不离者。取昔说相。为无常想。则是颠倒。岂得言与慢等俱离耶。僧亮曰。请也。得理观者。境智不相离。如来若常。则离无常想。若离无常想。为物则不应涅槃。上既有为众生之言。因之得有请也。若不离者。若佛不住理数。自灭无常之观。竟不离佛。伊字之譬。更增惑倒也。法瑶曰。向美快说无常想。能除三界常见等惑。及佛上无常想倒。今次叹此想亦能得常也。何以然耶。如来本若不修无常想者。则不知无常在于非佛。常在于佛。云何得修不滥之无常。入伊字涅槃耶。此论今日所解。不谈昔日也。若不离者。此言昔解也。若果修昔无常想者。此无常想。滥该于佛。非唯不识于常。亦未深识无常。岂得能除三界之惑。及佛上无常想倒耶。诸比丘说此得失二句。自陈已解悟无常之旨。成向所言快说之意也。僧宗曰。比丘意言。我未造极。事须灭身然后免苦。今高推如来。不同我者。既曰常住。岂待灭身。方称涅槃耶。若不离者。悬取佛意。若言我亦不离者。即猥与我同。则不应言修无常想为非也。宝亮曰。请辞也。捉前品中。常乐二偈。已离无常句。若寻此语。佛便是离无常想也。不应入涅槃者。此应身乃是法身。之未自在无为。若果不自在。云何言我是常住。若不离者。佛今果入涅槃。便是未离无常想。那得言我已离无常也。智藏曰。离者。灭之异称。想者。空慧之别名。佛向云欲入三点涅槃。若灭空慧。则无般若。岂有三点涅槃可入耶。若不离者。取佛意。若言不灭此慧者。云何昔言灭无常想。是则空慧不得不灭。三点安在也

世尊譬如农夫于秋月时(至)于诸想中无常为最

案。昙济曰。此因讥而致请也。佛若果入涅槃。故知无常想胜也

世尊譬如帝王知命将终(至)便欲放舍入于涅槃

案。僧亮曰。帝王之慈。慈及一国。尚行恩赦。佛慈一切。而不见矜耶。法瑶曰。虽说昔非今是。然未为心用。犹为无明所缚。未得解脱。须佛见教也。宝亮曰。此第二章。请辞也

世尊譬如有人为鬼所持(至)解脱等法如世伊字

案。僧亮曰。世医慈浅。尚不舍病人。况出世良医。而不救我等。法瑶曰。上譬明未得解脱。此譬明未得般若也。僧宗曰。声闻虽断粗结。而细者犹在。佛为良咒师。前譬明果患。此譬明因患也

世尊譬如香象为人所缚(至)便欲放舍入于涅槃

案。道生曰。菩萨如香象。声闻则未然。云何可舍耶。僧亮曰。为佛作过也。谓如来慈等。不得独为声闻现身。亦复余方化菩萨也。若尔者。慈本济急。我既不能自解。故苦重为急。菩萨能解。故苦轻非急也。五十七者。依上结名爱慢无明。横通五行。为十五也。竖通三界。合为四十五也。无常是见。四谛亦通三界。四谛十二。合五十七也。法瑶曰。此譬明未如大法身自在也。僧宗曰。罗汉断烦恼尽。不无习气相承。故言有五十七在耳。又释。不以断见观照智。约三界四谛为十二也。智为细惑所闇。即是无明。亦称烦恼也。宝亮曰。于佛上起三倒。无常苦无我。此三烦恼。显见无作四谛来治也。一谛下有三为十二。并为四十五也。四倒不取空者。空即无我。更无别义。不净本非理观。故不取也

世尊如人病疟值遇良医(至)便欲放舍入于涅槃

案。道生曰。纵依昔教得解。而于余教未了也。僧亮曰。更为佛作过也。若慈必救重。应舍圣从凡者。凡夫计常。故佛应现灭。若尔我有半病。故以疟为譬。佛应救之也。法瑶曰。此譬明无常涅槃也。虽免分段。而变易犹在。为半日病也。宝亮曰。疟是寒热之病。明我等九十八使。都未除也。智秀曰。佛除我粗烦恼。即日不发。而细者。根本犹在未去。如疟之未发也

世尊譬如醉人不自觉知(至)便欲放舍入于涅槃

案。道生曰。半解尚应更教。况全未了耶。僧亮曰。谓声闻之病。全同凡夫。非半日病也。何者。若了三界无常。于佛不应起无常想。说言佛是无常。则不了因缘。具三界常见。理与凡夫同也。法瑶曰。此譬明上所以未得四义者。良由凡夫时。醉醉五欲。情重根钝。是以今日仿佛有解。然犹未醒。云何舍弃。僧宗曰。上四譬为圣人作譬。此通为凡圣也。智勇曰。此譬与上疟譬。事异而意同。同以惑未尽为喻也

世尊譬如有人叹芭蕉树(至)而有诸见亦无是处

案。道生曰。昔亦佛说。今亦佛说。昔解既非。今何必是。是故还执昔解。乃取判于佛也。僧亮曰。谓如来是常。推理而言。理应自在。而我今日。请不得住。便是不得自在。是即昔说无我是实。今说自在应虚也。如佛所说者。今昔皆是佛说。今说何必全是。故引昔取判也。法瑶曰。从快说以来。比丘虽自说解。犹未自审。今欲取定于佛。故先呈昔解。叹无我想为真也。佛若非之。则今解是也。如其不非。今解何必是耶。芭蕉譬明解无我也。浆泽譬真言其身。理自无我。不假言其心解。七叶华。美修无我得入涅槃也。宝亮曰。此第三章。欲还修昔教也

大般涅槃经集解卷第六大般涅槃经集解卷第七(哀叹品第三卷之第二)

  释四倒义　释三倒义　合琉璃珠譬　合新旧医譬

    哀叹品之第二

尔时世尊赞诸比丘善哉善哉汝等善能修无我想

案。道生曰。将夺先与也。智秀曰。此下第四段。为说胜修。夺其所执也。有四章。第一将夺先定其所执也。第二比丘乃更说诸譬。自是而非他。第三佛回譬有在。使比丘成失。第四为说胜修。先许说而未说。先作两翻。明其所修无实义。后正明修也。此即第一章

时诸比丘即白佛言(至)我等善修如是诸想

案。道生曰。既蒙善哉。乃逞余修。以自多也。僧亮曰。既蒙称美。乃更说余想也。不名为圣者。自庆之言也。智秀曰。第二章也

尔时佛告诸比丘言(至)但知文字未达其义

案。道生曰。醉人之譬。以不更修为惑也。徒知昔说无我之名。未达更修之乖义。醉有所归也。僧亮曰。汝以醉为不醉。知醉之名。未达醉不醉义也。僧宗曰。此下夺因也。有四章。第一回醉譬。置比丘上。第二广列八倒。以示大众。免八倒者。可名为修。如其不免。云何名修耶。第三结八倒。与比丘言。非但有轻倒。亦有重倒也。第四为说胜三修法。代其所执也。未达义者。佛果是常。金刚以还是无常。而汝一向请。修常乐为醉。修苦空为不醉义耶。若知于佛果计苦空。生死计常乐。是惑者。此乃真识醉耳。宝亮曰。此下第二劝也。有四章明义。第一自此讫医说三修。先转醉譬。与比丘也。第二从说三修。讫人不知正修诸法。举八倒明两非也。第三从汝诸比丘于苦法中。讫而不知义。举四倒释是非也。第四明两是也。生死作苦无常亦是。佛上作常乐亦是也。智秀曰。此下第三章

何等为义如彼醉人(至)于非转处而生转想

案。僧亮曰。何等以醉为不醉义耶。僧宗曰。义释在下也。如彼醉人者。即回醉譬。与比丘也。谓醉人所见。其实不转。而生转想。佛果实常。而计无常。此即大醉。而自不知。故云不达义也

我者即是佛义(至)憍慢贡高流转生死

案。僧亮曰。知见自在。是佛义也。身无虑解。故以不迁。为法身义。内灭苦是乐。谓涅槃义也。身智涅槃。皆无非法。是净义也。法瑶曰。比丘自说凡夫想倒。今明凡夫我想。乃更为得无我想观。更为失也。醉人之譬。翻然在己也。僧宗曰。更分明显前所以是倒也。我以自在为义。佛以觉了为义。由觉万法。所以自在。应云佛是我义。辞倒也。下句例尔。不以无为为常义者。含三无为。故不取也。今举法身。贵在有体

汝等若言我亦修集(至)我今当说胜三修法

案。道生曰。更修既非。前修示非。故今始得非之。云其修非也。亦以修无实义也。僧亮曰。谓知字知义。为胜修也。法瑶曰。佛今始判昔解为非。故无有实义。今解为是说胜三修也。僧宗曰。下先结八倒与比丘。然后说胜修也。智秀曰。此下第四章

苦者计乐乐者计苦(至)是人不知正修诸法

案。道生曰。具倒非修。理固然矣。而以此人。尤诸比丘也。僧亮曰。先说耶修。以耶显正。相对为四也。法瑶曰。释无实义也。夫解则无偏。惑亦俱断。诸比丘以乐为苦。亦以苦为乐。非但不识乐。亦复不了苦空。是等四倒。常无常各有四也。僧宗曰。一往分八倒者。四在具缚凡夫。四在小乘人也。大通为语。凡圣皆具八也。既不辨真。理不识伪。然推实为论。此中言对圣人。而旨在凡夫。何者。入圣位以上。不假言教。自然信常。经有诚文。上来抑扬。盖为未达者耳。宝亮曰。八倒者。大判有四重。第一明亦得一人具八。一人具四。若谈始终成就。则一人具八。论其现起为言。但有四也。或之体用。性是痴迷。莫问起与不起。悉成就也。第二论其起用。谓若起前四者。则无后四。互相倚伏。故言一人但四也。第三辨俱伏。若信首五根立者。则八倒永伏也。是知后四起时。乃信首五根之前。邻四念处。假名法空。未成就作无常观时。在观心中。起此惑也。论此惑容有可得涉思惟之细不耶时。无明住地惑。为其正体也。何者。见谛惑已伏。复不得起。思惟惑虽非平等。然是虚心事惑不起。故知是无明住地惑也。第四论断道。得正观无偏时。必先除粗。而后除细。不得如相似解俱伏时也。何者。伏必约理傍情。情背者尽伏。莫问粗细也。真观断时。是数法相违。故以浅治粗也

汝诸比丘于苦法中(至)于不净中而生净想

案。道生曰。对起而言。于无我为我者。亦是以无我为我。岂谓真修耶。僧亮曰。已说倒相。今结与比丘也。已免今明其未达也。若识我相。乃得分明识无我也。宝亮曰。将释是非故。先举倒体

世间亦有常乐我净(至)世间法者有字无义

案。道生曰。始欲明胜三修。先说世间本无我实。例见之我。有字无义也

出世间者有字有义

案。道生曰。翻八倒故。名出世间也。下结云。以不倒故。知字知义也。僧亮曰。比丘既不免有倒。则因世间四倒。谓知名而不知义也。法瑶曰。此下始释胜修义。先举世间常乐等倒。以显出世间常不倒者。胜修义也。有字义者。释所以为修也。僧宗曰。佛指比丘尔所计也。出生间亦有者。谓有字有义。所以为胜修也。宝亮曰。下将有释。先开二门。一谓有字无义。二谓有字有义也

何以故世间之法有四颠倒故不知义

案。僧宗曰。择有字无义也。有四倒者。有四则具八

所以者何有想颠倒(至)世间知字而不知义

案。僧宗曰。向举苦空四倒。与常乐四倒作本。今复举三例释。前四倒所由耳。想倒者。想以取假为义。谬执不得法实。忆想推求。由此起倒也。心倒者。第六意识。能缘于理。先由心缘。而后起倒也。见倒者。见能审法。由审成倒。藉此则生于四。而对则八也。宝亮曰。心识一往。捉境谬解。取法不得。名之为倒。后以想心。重来分别。逐心谬解。名曰想倒。见是行阴之心。以想分别。有违不违二义。转重执见。谓言佛是无常。名为见倒也。不说受倒者。受之与想。一类相似。据其中品。所以不明也。见是三家之后。重行阴故说

何等为义无我者即生死我者即如来

案。道生曰。生死不得自在。故曰无我

无常者声闻觉常者如来法身

案。道生曰。二乘不见常。故无常也

苦者一切外道乐者即是涅槃

案。道生曰。反正见故。不得出苦

不净者即有为法净者诸佛菩萨所有正法

案。道生曰。夫横起者。皆有为也

是名不颠倒以不倒故(至)应知如是常乐我净

案。僧亮曰。正说胜三修也。法瑶曰。既明二种四倒。不知其义。次明二种四不倒。知其义者。即文自显。不复记也

时诸比丘白佛言世尊(至)而见放舍欲入涅槃

案。道生曰。既已斥其解非。便应教其修是。故复得请之

如来若见顾念教敕(至)同共正住修于梵行

案。道生曰。若佛涅槃。无复教者。虽修梵行。终不能得离此毒身

我等亦当随佛世尊入于涅槃

案。道生曰。言佛若住世教我者。乃当得随佛入此涅槃也。僧亮曰。上叹昔三修。取定于如来。如来已判。比丘虽悟昔修是倒。未得后修为用。请求教导。顶受修习也。随佛涅槃者。修既是倒。云何与此毒身同止。佛若现灭。随佛而去也。僧宗曰。上请不住。退保昔教。既蒙开释。始知未达。敬服前言。我既有倒。应须除灭。如其不住。欲随佛取灭。寻取灭之意。如似犹协前教。虽不要住。意在未舍。所以不敢公言。执教者。既蒙开释。愧在未达耳。宝亮曰。此下第三请始也。就此中亦有三意。第一直领解。第二请佛住教我胜三修。第三佛若不受我请。今当逐佛入涅槃者。以死要佛也。智秀曰。开说胜修。悟解情薄。今更请佛住。重为已说。云随佛入涅槃者。不谓别有涅槃可入。由佛昔云得涅槃时。必应舍身故。用理切之辞。以为请也

尔时佛告诸比丘汝等不应(至)亦以付嘱摩诃迦叶

案。道生曰。所以付嘱声闻者。明要须兼解。然后得道也。迦叶在佛前出家。以十方佛为师。佛既成道。为佛弟子。苦行第一。深解成就。必可以轨诲后学。故付嘱也。僧亮曰。答请教之言也。教汝遗法。今留在后也。僧宗曰。向以辞倒请住。今明付嘱有人。何患倒之不除也。宝亮曰。第三劝也。就此中有三意。先一非其第一请意。云但修胜修。随灭何益耶。第二出所依止人。迦叶既为依止处者。如佛在世无异。何患欲修胜修。而无地耶。有人解云。此迦叶即是三十四问者也。谓不应然。正是声闻中上座者耳。故六卷云。以声闻乘故。不能流通。非都不能也。是佛大弟子。于时不来故。知先是体常之人

汝等当知先所修集无常苦想非是真实

案。僧亮曰。一切经藏。皆付迦叶比丘。得知前非后是也。法瑶曰。将欲设譬。使其分明知昔解必非。劝学今之所说。故先诫敕之

譬如春时

案。僧亮曰。春者农之始也。无常之教。乃学之始也。法瑶曰。卉物开秀悦情之时。以譬听者机发之时也。时而闻法。莫不开悦也。僧宗曰。譬有三意。初明过去佛边得解譬也。次明失解譬。后明更感今佛闻常发解譬也。众生有善。值过去佛。感应相交。善萌开发。喻彼和适之时也。智秀曰。譬旨有二。前从始讫乃知非真。显学人本有极修当果之解。为佛偏教所益。寻之不能得也。后从是时宝球。讫譬明今日教。显极修之旨。现昔偏教之下求者。终能于中得也。开此二意。以诫学人慎彼前失。慕斯后得也。前譬中有两意。初讫没深水中。正显极修之珠。没于偏教之水也。春至则卉木斯萌。譬感兴而教发。善心荣秀

有诸人等

案。僧亮曰。陈如五人。应闻者也。僧宗曰。应是住前凡夫人。宝亮曰。通譬三乘人也

在大池浴

案。僧亮曰。禀承经教。洗除邪惑。譬大池浴也。僧宗曰。三世佛法通譬也。池中有水。水从池出。请佛法之中。有理有教。理教从佛法出也。宝亮曰。释迦出世。从鹿园至双树。通譬池也

乘船游戏

案。僧亮曰。依经求理。始用闻思。既入理不深。若船之浮水上者也。何者。众生本有四倒之计。谓一切法常。佛欲断之。说一功无常。旨在三界。滥及法身。执教失旨。浮浅之义。无有实功。譬之戏也。敬遗记僧宗曰。游戏者。感闻常教。非不微解。有悦情之谓。法莲记僧宗曰。万善为船。甘乐为戏也

失琉璃宝

案。一本云殊。僧亮曰。经旨不偏。理圆可贵。喻之宝。亦曰珠也。偏取乖中。以譬失也。法瑶曰。言之旨为珠也。不达所诠为失也。僧宗曰。外譬因戏失珠。内合以解所未深。情驰五欲。亡失本解。如失珠也。若论失者。昔计常乖解。已有失义。而以今闻无常之教。方称失者。以昔常名是同失义。不显无常之教。生无常解。遏于常见。失义始彰也。宝亮曰。中道之解。应得不得。名之为失也

没深水中

案。道生曰。常与无常。理本不偏。言兼可珍。而必是应获。由二乘漫修。乖之为失也。乖则永隐。谓没深也。僧亮曰。为权教所[雨/復]。譬深水中也。法瑶曰。常以无常。理必相对。而昔无常之说。未灼然有在。则滥乎佛常。是则常理隐于无常之教。为珠没水也。理必双悟。不应有偏。无常之水。非深如何。僧宗曰。隐覆圆解之珠。学人无有能见之者。曰深。无常之教。印一切法。就言下而求常解。无有可得之理。曰没也。宝亮曰。中道之理。隐在今日涅槃教下。故言没水。非据东西。水为譬也

是时诸人悉共入水求觅是宝

案。僧亮曰。修慧也。求理转深。欲以除惑。譬之入水求宝也。法瑶曰。思慧也。寻教转深。入水义也。失旨宜求。理推应尔。不言其意也。僧宗曰。向以理中有失。今亦理中有求。何者。常解是理中之胜行。人岂容无求胜之意耶。宝亮曰。从闻得思。义言入也

竞捉瓦石草木沙砾各各自谓得琉璃珠

案。僧亮曰。以无常等智。谓之三果也。宝亮曰。依昔经得闻思二慧之解。谓为真理也

欢喜持出乃知非真

案。僧亮曰。罗汉出三界。自知非究竟也。法瑶曰。本谓无常之理。是真言极旨。今闻常说。始知有在。画然有判。不复执在无常教中。是为持出。乃知非真也。僧宗曰。欢喜者。属上向也。于偏教生解。谓为真理。如唱得珠。保悦在心。义称欢喜也。持出乃知非真者。常教既宣。开释二涂。则不复为无常所迷。知先所得。未为理极也。宝亮曰。乘无常之解。来登燸顶。信根成就。决定信佛是常。于时倒望昔教。方知虚说。如持宝出水。知非真也。智秀曰。得修修慧离教。譬持出。出观缘灭。知未来之生。未即都尽。譬乃知非真也。道慧所撰。曰欢喜。持者。昔谓是理。保之为持也。出乃知非真者。说涅槃时也。既入今常教。于昔无常之教为出

是时宝珠犹在水中

案。道生曰。于不得者为故。在水中也。僧亮曰。自知生死未尽。不知佛果常。故为昔言所[雨/復]也。法瑶曰。诠本表旨。使人得之。于人未得。为在诠水之中也。僧宗曰。常教既兴。知昔所行。未为理极。而思修之信珠。未即为心用。犹在理教之下也。宝亮曰。得知昔来经教。尽是常解之诠。但众生惑重。不得正说也

以珠力故水皆澄清

案。道生曰。言旨既现。不复浑迹。珠之力也。僧亮曰。理不可掩。名教自分伊字之譬是也。故曰澄清。僧宗曰。珠譬解珠。是映澈之物。水为之清。思修胜慧。是理照之知。探教不浑也。宝亮曰。既有常信。决知偏教理非是实。理虽非实。未曾相乱。但资向常之解。故言澄清也。智秀曰。缘有此旨。所以能感今日所说。显奠昔教亦是诠极。岂非珠力水澄清耶。道慧所撰曰。惑情乱教。喻之水浊。若果无常。则其迷可久。理非偏教。故妄情可息。息则名教显然。喻之水清

于是大众乃见宝珠故在水下

案。僧亮曰。信佛是常。而请不肯住。以不自在。执昔说以致疑。乃取判于佛。此譬之旨也。法瑶曰。常理既显。方知昔旨。旨在于常。譬故在水下也。僧宗曰。唯有闻慧。未能入理。如未入水。未修胜慧。不名得珠。非不闻慧。义称遥见耳。宝亮曰。既得信解。悉知常旨。遍在昔日教之下

犹如仰观虚空月形

案。僧亮曰。佛说胜修圆教可仰。以譬空中之月也。僧宗曰。思修之心。中道不偏

是时众中有一智人以方便力安徐入水即便得珠

案。道生曰。如说修行。譬之安徐入水也。要在修习我常四法。而实不废方便之义也。修常然后乃解无常。其理始是得来在我。故曰智也。僧亮曰。舍昔修今之譬也。法瑶曰。智人谓菩萨也。修习不滥。无常尔乃得常。以譬入水得珠也。修习得所。不浑浊故。为安徐也。敬遗记僧宗曰。迷多悟寡。可贵可重。故言一人也。以善方便。纵容理味。则教不浑乱。胜修之慧。在我故也。如以安徐入水。水不乱故。所以得珠也。敬遗记僧宗曰。一人譬菩萨也。不执断常。纵容取中。譬之安徐也。道慧所撰曰。谓摄心在理。曰安徐也

汝等比丘不应如是(至)所谓我想常乐净想

案。僧亮曰。此略合譬重劝之也

尔时诸比丘白佛言世尊(至)得入涅槃是义云何

案。道生曰。若昔说无我。实亦表于我者。言教何以专说无我。得离于我。而不说我。今方说耶。僧亮曰。若今修是正。昔日遍说。其义云何耶。法瑶曰。若有我为真。无我非实者。昔日何故不说。幸使我等无谬取之倒。此之二说。如以鉾楯。其趣云何。僧宗曰。此夺果门。第四段也。第一夺果。第二夺因。第三寄宝珠譬。成其所修虚而不实。此第四释会二教。不相乖负也。宝亮曰。此第七段会通两教。自哀叹品来。比丘三请。世尊三劝。而众人唯怀一疑。故知。从卷首至此。未是正说。通为劝问明矣。此疑由是第三劝中生也。若其理皎然。昔日何以不先说耶

佛告诸比丘善哉善哉(至)咨问是义为自断疑

案。僧亮曰。善问得时。能推本定今。以自断疑也。法瑶曰。下引客旧医譬。明古今之说。其旨不殊也。昔叹无我。唯在三界。除三界我耳。不毁佛我也。但彼不解言之旨故。滥佛亦谓无我。今毁滥修无我。非毁生死无我。叹毁虽异。其旨实同。非鉾楯也。僧宗曰。能以二教为征。疑心所以断也。今释二教。则无执昔之迷。权实苟分。疑累断也。明骏案。此下一品之中。第五段会通也所言会通者。明昔所以不说常。今日所以说耳。非谓以昔无常偏教。会今圆教也。是以下譬中云。此乳药者。服与不服。皆是医教。不云碱苦辛酢等味。即乳药也。故知。所言会通者。盖说与不说之意也

譬如国王闇钝少智

案。道生曰。夫受化者。必有解分。垢重者。摄轻故为王也。垢重故智少也

有一医师性复顽嚚

案。道生曰。虽复垢重。而断善犹轻。今取其中。以愚相训。必有师焉

而王不别厚赐俸禄

案。道生曰。耶训会情。宗莫易也

疗治众病纯以乳药(至)是医知乳好丑善恶

案。僧亮乳药者。说六谛二十五谛。皆我见为教。以扶物情。故譬之以乳也。病起根源者。若起于法身者。应以我为药。若起生死。此则非药。此明不识病源也。复不善解者。不知真我法也。僧宗曰。譬有五别。第一明佛未出时。外道化世。第二明始应生王宫。第三明共入见王。稍欲受化。第四明应见成佛。权说偏教。第五明开实显常也。国者。总譬一佛之所化也。以前悟者。譬王也。医者。譬外道也。风起卒暴。譬嗔也。冷性凝结。譬痴也。热性烦浊。譬爱也。此明不识病也。纯服乳者。明不识药也。慧朗所述曰。此譬有两意。初从首。讫疗治众病。无不得差。谓之古譬。盖是今日座席之前譬也。后从其后不久以下。谓之今譬。正为即时为喻也。前明以有执常之病。所以不得为说。后明常病既消。还以无常为患。故为常也

复有明医晓八种术善疗众病知诸方药从远方来

案。僧亮曰。此第二譬也。缘悟时至。菩萨出世。能治生死譬。医八术者。譬除八倒。法身于人为远。义言远方来也。法瑶曰。八术谓慈心等四对。三毒及等分也。善疗众病者。知众生根根也。知诸方药者。善解法相也。法身悬绝。譬远方来也

是时旧医不知咨受反生贡高轻慢之心

案。僧亮曰。见处王宫。受五欲乐。众生不识。起凡夫想也。于时外道自称云。是一切智人。蔑瞿昙也

彼时明医即便依附(至)唯愿为我宣畅解说

案。僧亮曰。将欲去之。必先受之。所以禀彼四禅四空行等法也。法瑶曰。诣彼师门。或咨受常倒也僧宗曰。维摩经云。以无心意无受行。而悉摧伏诸外道。斯盖四摄之中。同事摄也

旧医答言卿今若能(至)随我所能当给走使

案。道生曰。成佛凡四十八年也。一日屈节。则终身成师也。僧亮曰。要终身为弟子。法瑶曰。从得道夜。至涅槃夜。其间凡四十八年。尔时六师。一不降化。与佛角辨抗行。师徒之义未绝。曲意伺机。喻之给使。又释四十八年者。谓四禅八禅也

是时旧医即将客医共入见王

案。僧亮曰。菩萨以受化为国也。示禀其术。知其非道。使师及弟子。举世知非。于悟分转近。有入国见王之义。以为喻也。法瑶曰。耶师所训者。亦可以法而化。为共见也。僧宗曰。此第三譬也。未成佛之前。渐欲背耶。而未全正。两边同信。义言共入也。慧朗曰。于时有五百贾客得度。未度之前。若遇外道。便受耶法。值佛则度。二机不定。故云共入也

是时客医即为王说种种医方及余伎艺

案。道生曰。五戒十善。亦是医方。实以舍下。而似生上为伎艺也

大王当知应善分别(至)此法如是可以疗病

案。道生曰。以定除乱。谓之治国。以慧去结。谓之疗病也

尔时国王闻是语已(至)然后倍复恭敬客医

案。僧亮曰。此第三譬也。使人知耶。后乃显正。洗浴受摩。取草诣树。即入禅定。降魔成佛。于时静身得定。以譬治国。慧能断结。譬治病也。法瑶曰。上来并是成佛之前事。此以下譬成佛后事也。神通等为伎术。三归五戒为方药也。戒以禁非。定以静乱。为治国也。僧宗曰。说生死过患令背。为医方也。令修戒定。为伎术也。以五戒十善。生净土故。即是治国也。以不净止贪。慈悲止嗔。因缘止痴。即是疗病也。佛道既成。耶心殄息。喻如驱出

是时客医作是念言(至)实爱念者当求一愿

案。僧亮曰。此第四譬也。今正是时者。五人应悟之时也。有爱念者。感理冥会。令无差也。当求一愿者。惑从相起。观空则灭。空理无二。故云一也。法瑶曰。佛唯化是愿。但化遂由乎众生。义言求也。昙济曰。一愿者。譬一空门也。僧宗曰。第四譬也。是说四谛。除耶我之时至也。一愿者。世尊所应说者。常与无常。大之与小。今日未得双说。故言一也。于时正在三七日思惟。知众生有从化之理。愿得遂也

王即答言从此右臂及余身分随意所求一切相与

案。僧亮曰。身虽多分。而性空无二。无二则无非我所惜也。僧宗曰。方便智易用。如右臂也。终闻常教。皆有受义。故言一切相与也。慧朗曰。右臂者。取一边之义。譬偏教也

彼客医言王虽许我一切身分然我不敢多有所求

案。僧亮曰。无则无多非所求也。僧宗曰。虽知终当圆说。即时唯可偏教。故云不敢多有求也

今所求者愿王宣令(至)是药毒害多伤损故

案。僧亮曰。我见是众惑之本。譬所损之处多也。僧宗曰。展转相闻。譬之宣令也

若故服者当斩其首(至)常处安乐故求是愿

案。僧亮曰。若起身见。则断慧也。身见断故。无复凡夫横理之惑

时王答言汝之所求(至)若为药者当斩其首

案。道生曰。已受五戒十善之化。此欲为说无常教也。僧亮曰。五人观空得道。一切众生。皆知身内无我。宣令一国之义也。信正背耶。理不为难向。然从命为。盖不足言也。夫万善以信根为首。若以倒见为药。则无信根。为断首之义也

尔时客医和合众药(至)以疗众病无不得差

案。道生曰。譬无常等五门观也。僧亮曰。更思治门。断思惟结也。法瑶曰。辛苦等味。譬无常等观也。前云医方伎艺。谈化之始也。此言辛苦。叙教之终也。一段事毕。故言无不得差也

其后不久王复得病即命是医我今病困当云何治

案。道生曰。执无常教。该于常也。僧亮曰。第五譬也。耶我已灭。不识真我。谓一切法无自在者。谤佛法身。始觉病起也。当云何治者。断惑次第。机来扣佛。致辞如此也。昙济曰。应闻常教。故以无常解为病也。宝亮曰。此下第四譬也。知涅槃机发。所以言病。众生已闻四时教说。心神渐开。推理而言。佛不应无常。而生断灭之见。喻之若病也。智秀曰。得无常解。即谬倒佛上。以其常患亦消。即有无常病起。故言不久也

医占王病应用乳药(至)王今患热正应服乳

案。道生曰。应说常也。僧亮曰。既以无我为倒。应以八自在为治。故云应服乳也。是大妄语者。无我者。旨在生死。而云一切。是则妄语也。颠倒烦恼。能烧众生。取譬患热也。法瑶曰。本以无常之火。焚烧生死。而以滥执佛地。病之甚者。故云患热也。僧宗曰。无常倒心。虚而不实。以谬起故。应云虚热。真常之解。清凉真实。故云应服乳也

时王语医汝今狂耶为热病乎而言服乳能除此病

案。法瑶曰。执无常教。以为理极。此譬未信说常之时也。宝亮曰。譬哀叹品三劝三请

汝先言毒今云何服欲欺我耶

案。道生曰。执昔教难今教也

先医所赞汝言是毒(至)我本旧医定为胜汝

案。僧亮曰。谓前医先觉。故云胜也

是时客医复语王言(至)如彼虫道偶成字耳

案。道生曰。本不在字。则非字矣。耶说不在常。非常说也。僧亮曰。虫不识字。虽字非字。智者岂有识字之怪耶。不别诸病。悉用乳药者。病起于麻麦之我。不可用我而为治。若起八自在之上者。可得用我治彼不识也。僧宗曰。上三修中。广明八倒。但有其名。未得其实。何异虫迹耶

是先旧医不解乳药(至)亦是毒害亦是甘露

案。道生曰。投非其病。则成毒害也。僧亮曰。用得其所。投中其病。是为甘露。不则为毒

云何是药复名甘露若是乳牛不食酒糟滑草麦[麥*戈]

案。道生曰。耶设于常。中实已变。外以如本。而能惑于人。为酒糟也。既生常惑。无常寻起。为滑草也。所说无实。为麦[麩-夫+戈]也。僧亮曰。乳功在乎善养。解我亦由乎说者。无以惑心说我。行则成倒也。酒糟滑草者。释口易下。入腹为患。我见则附情易。安则为病也。我见有名无实。喻如麦[麩-夫+戈]空无实也。法瑶曰。牛者譬佛菩萨也。既以乳譬常教。今以乳从牛出。是则常教。由佛菩萨说也。糟无真味。人之所恶。以况耶说乐净之法。其实是苦实不净也。常倒者。谓湛然不易。而实无时暂停。喻滑草也。麦[麩-夫+戈]内空。以譬无我也。僧宗曰。酒糟者。食则醉乱。怀相在心。则迷真法也。滑草者。其体性利。啖则伤中。譬之利使也。麦[麩-夫+戈]无味。喻浮澹之心。不得理味也。宝亮曰。酒糟麦[麩-夫+戈]。本是虚秏之物。以譬断见。滑草乃一往悦情。喻如着相说常见也

其犊调善

案。僧亮曰。受化弟子善能问难。能使真我之旨显而不谬

放牧之处不在高原亦不下湿

案。道生曰。读诵诸经。已养法身。若专在去结。譬处高源。若从斯起惑。譬处下湿。僧亮曰。慢心高原。染心如下湿。弘通之病。莫过此也。法瑶曰。执我在三界。为下湿。执无我滥佛地。为高原。纵容中道离此患也

饮以清水不令驰走

案。道生曰。无相之说。譬之清水也。僧亮曰。以定水自资。不行乱境也。法瑶曰。饮以中道之水。不驰于二边之散也

不与特牛同共一群

案。僧亮曰。不与恶知识。相亲近也。僧宗曰。特牛譬外道也。特牛无乳。外道无有真常法也

饮食调适行住得所

案。道生曰。授法不偏。为中适也。僧亮曰。调譬诸道品。行住以譬合时则说。不合则止也。法瑶曰。饮以解脱为浆。食以禅悦为味。行则为观。住则为止。止观不失其宜。为中和之道。行住得所也

如是乳者能除诸病(至)其余一切皆名毒害

案。僧宗曰。备上诸德。乳必可服。菩萨善具通法之德。常名可信也

尔时大王闻是语已(至)即便服之病得除愈

案。僧宗曰。即今说也。众中有先悟言下旨者。如王也

寻时宣令一切国内从今已往当服乳药

案。法瑶曰。相劝信常。无执无常。以为极也

国人闻之皆生嗔恨(至)皆怀嗔恨悉集王所

案。道生曰。亲承音旨。犹怀疑惑。何况传闻者耶。法瑶曰。其中犹有执无常者。复须转教。方起深信也

王言汝等不应于我(至)皆服乳药病悉除愈

案。法瑶曰。督厉之辞也。常以无常。皆是佛教。岂得信无常。而不信常耶

汝等比丘当知如来(至)为大医王出现于世

案。僧宗曰。此下合譬也。其文甚略。举其纲纽耳。此合第二佛出世譬也

降伏一切外道邪医(至)我为医王欲伏外道

案。僧宗曰。合第三譬也

故唱是言无我无人(至)为知时故如是无我

案。僧宗曰。合第四譬也

有因缘故亦说有我(至)应当如是修集是法

案。僧宗曰。合第五譬

卷第七大般涅槃经集解卷第八(长寿品第四卷上)

  合老少二人譬　多罗聚落迦叶问

    长寿品第四

佛复告诸比丘汝于戒律(至)我当解说令汝心喜

案。道生曰。欲令问长寿因也。长寿本是入生死。济物之良津。以慈心为本矣。慈之为济。无制戒律。令不作诸恶。然使行善。以之极也。既制戒律。有罪必治。即事如似无慈。谓无慈者。非从疑于戒律。乃是厚诠寿本。不可不问也。问于寿本。是菩萨事理。非声闻所应妄豫。故推之焉。僧亮曰。此中所说。或是比丘所行。故偏劝云。汝于戒律。若有所疑。乃至莫谓如来唯修诸法本性空寂者也。佛初开宗。明施是寿因。纯陀以护法为因。广宗中。以三修为因。虽说三因。未尽寿本。今先举戒后举智。略举始终。明一切万行。皆是寿因。开其问宗。故此先举戒律也。敬遗记僧宗曰。前夺因夺果。释会二教宗致。略举前来。举境劝问。但所举之理。既为深玄。二乘虽疑。思所不及。未能发问。佛知其不能。所以重劝问者。令其高推有在也。所以举戒律令问者。戒是声闻要行。入道之初基也。又一义。声闻不疑戒不趣佛。但疑戒未必致常也。又一义。假使能致常果。未知此戒与昔之戒。云何为别。既怀此疑。疑则应问也。法莲记僧宗曰。前品举空不空等慧境。以劝问。今举戒律万行之因。以劝问也。若因不了者。果亦不究竟。而因有戒定慧也。所以偏问戒律者。戒是声闻所行。由律仪戒资。以得定戒得道共戒也。慧朗述僧宗曰。劝比丘问。凡三重也。前品止其哀叹。便劝令问。因修至此。今此第二又劝也。将欲广开常旨。而戒是万善之本。故举戒以劝问也。宝亮曰。此下第四段。催众令问也。戒是声闻之本。所以举戒而劝问也。智秀曰。上举诸法以为劝。恐诸比丘。惮常理之深。不敢致问。今指复举戒。是常所行事。约就近情。以为劝也。明骏案。前因受供以开常宗。唯有纯陀。利根一闻即悟。设五翻咨难。以辨法身般若解脱。即得重显久是常田也。然而常旨幽微。应须广辨。以大众悲深。顿忘咨决。频仍哀请。爰生傍论。是以放光催供。重显义宗。复因纯陀详本迹二旨。明食非实受。灭岂真亡。而纯陀去后。时众默然。于是动地骇情。复与问首。而哀恋之至。了无咨启。唯深陈哀苦。设譬仰讥。于是世尊。因以二偈。抑其悲情。略举法门。劝其令问。所举所劝。皆是果旨。观彼众心犹迷。愤发乃说三德涅槃。夺其所证。比丘遂乃更执昔教。还复苦请。佛以胜修遣执。以医譬会教也。哀叹苦请。纷纶始息。是故略举常住之因。戒定智慧。劝令咨问。此第二劝也。所以先举戒者。夫十地以大悲为首。五戒以不杀为先。下答长寿因云。大慈大悲。授不杀戒。长寿之因。莫先于戒。是以先劝问也

我已修学一切诸法本性空寂明了通达

案。僧亮曰。说智因也。僧宗曰。言如来穷达性本。得本则握末。必有洗疑之德。故劝问也。宝亮曰。昔明持戒得果。但获断灭空无为耳。佛今意云。我昔所言。断灭空无为者。乃是今日常住家因。汝于此义。应疑可及机而问也。智秀曰。举佛德也。道慧记曰。谓佛先已修行。得至常处。汝今岂得不修戒等行耶。明骏。案。万行终以戒定智慧为本。前句举戒。此举定慧。本性空者。慧之境也。寂者定也。下文比丘。即述此三旨。云不思议也

汝等比丘莫谓如来唯修诸法本性空寂

案。僧亮曰。明万行皆是因也。僧宗曰。空不异昔。恐其疑止。乃更举不空。发其问也

复告比丘若于戒律有所疑者今悉可问

案。慧朗述僧宗曰。第三劝问也

时诸比丘即白佛言(至)无有智慧能问如来

案。僧亮曰。佛果深妙。我智微浅。不能发问也。教诲者。即戒律也。明骏案。释所以不堪问也。即领上三旨。皆不思议故也。境界者。即举上性空也。诸定者。即举上寂义也。教诲者。即举上戒律也

世尊譬如老人年百二十(至)于诸戒律当何所问

案。僧亮曰。如来敕问。必欲流通。而诸声闻。不住有三。一者以智浅。二以寿促。三无眷属。所以不能任持法也

佛告诸比丘汝等今者(至)诸有疑网恣随所问

案。僧亮曰。比丘致辞。未有所推。欲令推诸菩萨。故重敕也

尔时诸比丘白佛言世尊(至)时诸声闻默然而住

案。宝亮曰。向自辞不堪。今举所堪者也。慧诞曰。前劝问意。欲令以譬自陈。后劝问意。令推能菩萨。何以然。大士于此坐中。生下品解。后乃更生中上品解。所以推也。年二十五者。智力强利也。常解美满。喻端政也。备修万善。喻多财也。藉过去微品常解。以生现解。喻父母也。以现在中品解。能生未来上品解。喻妻子也。品品各有种类。喻眷属宗亲也。通为一解故。言悉皆存在也。以如来譬智人。以常理譬金宝。其下文曰。以念念灭故。譬病笃命终也。感后胜解。为命家属也。以解存故理显。义言还得也

尔时佛赞诸比丘言(至)令是妙法久住于世

案。僧亮曰。罗汉心者。少欲知足也。以此二缘者。声闻不具上三事。菩萨具三事也。昙济曰。以此二缘者。一以声闻无眷属。二以菩萨多眷属也。僧宗曰。二因缘者。一谓善能问答。现在有益。二以令久住。未来有益也。慧诞曰。二缘者。一以能问。二以能说。明骏案。二缘者。一者能令法宝久住。二者利安众生也

尔时佛告一切大众(至)第二第三亦复如是

案。僧亮曰。寿命是果之极也。戒归是因之始也。举因果以劝也。明骏案。前品劝问。空不空等。偏举果也。而此品初。又唱戒定智慧。偏举因也。今举若戒若归。因果双称也。戒即万行之本。归即一体三宝也。此下入大众问品。略说之中。第二段也。即以问答。为两翻也。就问中有两量。一为问之渐即长行也。二正问即偈也。长行中有四翻。第一佛普命。第二迦叶奉命。第三佛即许也。第四迦叶谦光也。此即第一命问也

尔时众中有一童子菩萨(至)若佛听者乃敢发言

案。僧亮曰。迦叶自疑。虽在大众之例。惧非应命之人。故有咨也

佛告迦叶如来应供正遍知(至)断汝所疑令汝欢喜

案。僧亮曰。举佛三号。明无法不知。有问皆能答也

尔时迦叶菩萨(至)及因大众善根威德少发问耳

明骏案。奉旨谦光之辞也

即于佛前说偈问曰

案。僧亮曰。此下第二是问分也。凡有三十四问。有四段。第一略。第二广。第三劝信。第四问修行也。第一段中有四问。初两问果。第三问因。第四问经名字。及流通经德。经体已周。名究竟彼岸也。第二段中。有十六问。从开微密。讫天意树也。此中广说有四重。初一问广果。次从得广大已下。讫四倒。有四问。广流通及依人之义也。次有两问。问作善业。及难见性。以广因也。次有九问。从解满字。讫天意树。广文字功德也。上来二十问。广略再说竟也。第三段中。有十问劝信也。所以劝信者。佛由因得。复言涅槃。而说是常。若不更以事释世所难信。故说十问。以释之也。第一问意。佛若从缘无性。不应独常。下答虽从缘得。然有惑则无常。无惑则常也。第二第三举果劝信。初举外后举内也。第四第五说有大慈。如世父母。慈心所说。不欺众生。第六说涅槃。示现不实也。佛常已下四问。证示现也。何者。佛不食而受食。不病而现卧。故知不灭。而现灭也。次有二问。明现在知常受乐。后世识有余无余。化功已讫。所以应现也。第九证不病。第十明说病说灭。皆是密教也。第四段中有四问。第一问依经修行。即五行也。所以问行者。上说经功德。能治四重五逆。治必须行。行此五行。亦不治自差也。第二释所以差。以转近为差。乃举五人。远近为证也。第三请说行义也。第四问性明性有因果。行有违从。识性则从即师子吼问也。不识性即逆即迦叶问也。次两偈说涅槃。因果[洌-歹+(虍-七+廾)]旷。问所不能尽。所以不问也。宝亮所判与此同。不复烦载。昙济曰。第一有四问。正明经体。长寿因果。结经名字。第二开微密。至观三宝。有十六问。广上果及经名字流通也。第三从三乘若无性说微密。有十问劝信也。第四说微妙诸行。有三问。问因经修行也。第五悉有安乐性。一问辨依经行。行之次第也。第六今欲问诸阴。一问拟以憍陈如答也。案。僧宗曰。此经大要。以常果为宗。前纯陀因施明常。为义则略。迦叶今广设所问。重申前旨。广略二问。何以取别多敝教以明常。今设问答。以取悟。然问答大旨。论因说果。明境辨行。条绪虽多。要不出此也。为问之体。悬取答意。所以义旨相苻。无越经致。就此问中。科节略有四别。第一有十三问。明常住因果。次有十九问。叹经功能。次有一问。明依生行。次有一问。明所照之境。就此四中。各有广略。开则有八。合则成四。其中支别。故以四为其绪耳。案。智秀曰。劝旨已着。时宜问也。机在迦叶。故闻命矣。为问之辞。凡三十有四。以义而分。略为三断。可者。经之旨归。以极果为宗。然果之所由。非因不就。故咨启之端。宜其先也。是故第一从始。讫究竟倒彼岸。有五问。问因果结名字也。典诰之体。略已举矣。将欲化传千载。利益无已。然道不自弘。通之由人是故第二从愿佛开微密。讫太白与彗星。凡十问。问通经之法。及能通之人也。虽复人法二理。显然可别。未辨弘之有益。无以奖锐学人。是故第三从云何未发心。讫最胜无上道。凡十九问。问经之势力也。若通而为论。此之三义。亦足通矣。今从事从义。致有别也。明骏案。判问大体。世有六分三段。第一略。第二广。第三劝信也。略问中有八问。第一问长寿因。第二问长寿果。第三问金刚身果。第四问金刚身因。此四问略辨般若法身。第五问解脱。第六问经力。第七问经名。所以约经名辨经力。以问解脱者。有二义。一者此经以常住为宗。而以无累。为名累故。所以无常常故。所以无累也。二者明近远解脱。皆是经力。近则能灭因中三障。远则能辨果地解脱。是以问言。云何于此经。即是问名问力也。究竟到彼岸。即是问解脱也。下名字品云。闻此经名。生四趣者。无有是处。即是近力也。又云。菩萨住此。则能处示现。即是远力也。举七善以答经名也。降伏一切诸结烦恼。及诸魔性。然后要于大般涅槃。放舍身命。即是答究竟到彼岸也。又云。八味具足。举常恒等句。释解脱体也。何者下文。明解脱中。列此八句。一一广释。灼然可见矣。第八问流通依。如六卷泥洹云。菩萨化众生。说法有几种。而此中阙落若有者。于义实便。若不取彼问者。就此语昧。亦有问流通义也。名字品迦叶问云。当何名此经。云何奉持。其旨显矣。下以四相品答也。第二广问。有十六问。初以一问广果地三德。下文从四相品未有余无余涅槃。讫解脱答此也。次有二问。广流通辨人辨法辨耶。辨正四依品。取正法正人。以为依也。耶正品去耶人耶法。以为魔也。次有四问。广因四谛四倒。二问举解惑以明智。即广缘因也。善业难见性。二问举始终。以明正因也。次有二问。广经名字。即满字之与圣行也。次有七问。广经力也。前未发心等四问。广因地灭三障力也。后船师等三问。广辨果地。万惑斯亡。究竟解脱也。第三有十二问劝信。同僧亮法师所释也

云何得长寿

案。僧宗曰。此经首题。虽以解脱标名。若语其圆体。则法身般若。是以创言与问先以以般若为首也。此虽一向而义兼因果。意在于果。不得不问其因。虽有二意。通为一问也。长寿者。一期为寿。期久为长。常果非期。寄言长耳。盖谈慧鉴无穷。即般若也。云何得者。问其因也。宝亮曰。下答云修四无量。授不杀戒为因。得常命法性体为果也。智秀曰。此问有两。第一问云何得。第二问长寿果相也

金刚不坏身

案。僧宗曰。向问般若。此问法身。上明无尽。此明不坏。如世金刚。体不可坏。能坏万物。取譬法身。三相不能移。其神万化。莫能变其体也。宝亮曰。体相身命。实乃不殊。就义而辨。不得无异。身当法体命语始终。故分为二问也。智秀曰。此第三问法身果也

复以何因缘得大坚固力

案。僧宗曰。上句已问果。此下句问因也。下文答以护法为因也。智秀曰。此第四问金刚身因也

云何于此经究竟到彼岸

案。僧宗曰。经之大旨。因果既彰。仍结经名字也。下文言。此经名为大般涅槃。所以言究竟者。经之为用有文有理。文以诠理。理以称文。文理相苻。义无遗阙。是曰经究竟也。人于文理之中。修学成圣。终期佛果。是曰人究竟也。依经流通。当备何德。前名字功德品。既结经名字。始是成经。而经须人弘。非德不传。四相品初。明流通之利。自行兼人。终成大觉彼岸明矣。智秀曰。此第五问经名字。兼受持之益

愿佛开微密广为众生说

案。僧宗曰。此下有九问。广门也。上略门中。明般若法身。今广门中。明解脱也。三德既显。伊字始圆也。开微密者。广说如来二种隐[雨/復]。一谓言隐[雨/復]。二谓形隐[雨/復]。以昔教未着为微也。诠常为密也。宝亮曰。此下广门。凡十六问。此一问正广果用。果者。谓法身般若解脱也。智秀曰。此第六问弘通之法也。下有十问。皆相承而发

云何得广大为众作依止实非阿罗汉量与罗汉等

案。僧宗曰。上略门辨因根。结经名。显流通。今广门中。唯明果不明因。仍辨流通者。故知。经旨意不在因。但以果为宗也。上四相品。明四种法。今此品中。举四依人。彼则寄法显德。此则举位标人也。如来居尊体极。是真罗汉。菩萨似之。但大士踪高。去人悬远。难可别知。乃约四果。仿佛寄心。令人取识也。宝亮曰。下频有四问。皆广流通。此一问。问流通人德量高下。下四依品答也。智秀曰。此第七问。应言何许位人。能得广大之经。可为依止。虽是菩萨。而位齐声闻耶

云何知天魔为众作留难佛说波旬说云何分别知

案。僧宗曰。夫欲通法。应识耶正。天魔外道。阻乱佛法。假形伪说。以迷未达。从其化者。长居生死。当尔之时。四依出世。遏魔扬道也。向云天魔宜识。非言。莫辨魔说佛说。理有分别。是以寄说。以检耶正也

云何诸调御心喜说真谛

案。僧宗曰。广前因义也。上答般若因。云十善四等也。法身因谓护法也。此是相似因果。今就广门。寄境以明也。何者。若遍收其因。则八万四千。略而为语。莫出智慧。慧之所生。生在乎境。境有深浅。故教有偏圆。解亦随教也。如来初开四谛。但言是苦是集。未明苦集不生。及般若之教。始显不生。爰至法华。苦集之相。犹止三界。今日所明。一豪之惑起。则无明住地。乃至金刚苦亦如之。昔日明灭。止于身智。灭既有余。道亦未了。教不究竟。生解亦偏。以解浅益微。则圣心不悦。今日所说。教圆理足。生解亦深。化功遂畅。义言心喜也。智秀曰。此第九问境也

正善具成就显说四颠倒

案。僧宗曰。上举境以成慧。今出惑以形解。所以尔者。夫解惑由教。昔教既偏。解亦为倒。解既为倒。岂具正善耶。又说谛既异。倒亦应殊。趣致相关。故复明也。宝亮曰。此两问。问教下。所明之理。有真伪也。四谛明真。四倒明伪。欲令学者。识其是非。若言称四谛。必是四倒。语合八倒。是则魔也。智秀曰。此第十问翻理相也

云何作善业大仙今当说

案。僧宗曰。此始是穷因之致也。前明持戒护法。未为极因。若照解圆明。始称善业也。就答善业文中。自有五重。相生显之下文也。此一重。明若于性生信为善业之始也。智秀曰。此第十一。问佛性理也。若众生无我。则一化便尽。云何得与善业。以趣佛果耶

云何诸菩萨能见难见性

案。僧宗曰。犹是明第二重显于见性善业之终也。宝亮曰。此第十第十一两问。广因下如来性品答也。作善行是缘因。前所以答中明正因者。欲明行人立心之方。若明识因果性者。则行成中道。若中道行成。则万善便树。故答以正因中道。行即缘因也。智秀曰。第十二问何地大士。能照当果性之理也

云何解满字及与半字义

案。僧宗曰。此下第三重。广流通也。经之为用。有文有理。上略问中。结经名字。名大涅槃。又七善法。叹该文理。今文字一品。先广文用也。经文以十四音。为众音之本。所以言半满者。夫教有偏圆。由机有次绪。如来善得其宜。故言善解满字及半字也。宝亮曰。此下九问。广文字功德下理也。此是第十二问。先定其文字。下文字品答也。智秀曰。此第十三问意。若我之名元自佛者。其余名字。复因谁耶

云何共圣行婆罗迦邻提云何如日月太白与岁星

案。僧宗曰。第四重广流通也。理之为用。不出常与无常。真之与应。此教双明八理相对。应除八倒。事同牝牡文中。但列六行。盖略耳。如日月者。此四譬为成真应故也。日月升天。则万像斯见。此偏举真应。显自在之德

云何未发心而名为菩萨

案。僧宗曰。此下十九问叹经。而初有七问略叹。前四叹因益。后三叹果益也。经有此能未发心人。强令发心。如或从诸佛菩萨边闻。而不生信。将成阐提。以经威力。梦见恶相。即便发心。作菩萨也。宝亮曰。据能灭恶生义也

云何于大众而得无所畏犹如阎浮金无能说其过

案。僧宗曰。既逼令发心。便成菩萨。则上求佛慧。下度群生。功业转胜。理不复畏。天魔外道。异学众也。宝亮曰。恶灭之后。成清净福田也。智秀曰。第十七问经之力。能灭业障也

云何处浊世不污如莲华

案。僧亮曰。非唯自具万行亦胜。处于浊世。以化乎物。不为世法所污。如莲华也。宝亮曰。信慧开发。不复障圣道也。智秀曰。第十八问经之力。能灭报障也

云何处烦恼烦恼不能染如医疗众病不为病所污

案。僧宗曰。向通因果。今偏语因。患重故难拔。菩萨拔之。前止言不污。今明治惑。如凿王譬也。智秀曰。第十九问经力能灭烦恼障也

生死大海中云何作船师

案。僧宗曰。上四问明经威力。使未发心者。令作菩萨。能为医王。虽未成佛。而能因中。已能利益。此明果益言。因经修行。终得成佛。既得成佛。复能乘此大涅槃船。接济众生也

云何舍生死如蛇脱故皮

案。僧亮曰。向乘涅槃船。物见其灭。实则不灭。近识未悟。移譬显之。如蛇脱皮。非为实死。如来亦尔。现灭非真。借以为喻

云何观三宝犹如天意树

案。僧宗曰。若于解者。不假移譬。但悟有先后。致说有重复。洗沸人疑。疑谓现见如来。始王宫生。终双树灭。岂言不灭。故借天树三变。以为喻也

三乘若无性云何而得说犹如乐未生云何名受乐

案。僧宗曰。此下有十二问。广叹经也。依昔经教。明三乘无性。各有涅槃。毕既有殊。性不容同。如其无性。云何上答纯陀。常命色力。常果无差。有则俱有。无亦俱无。如其为无。前不应说。如其已有。有则太早。因中无果。果中无因。而说为有。便是如乐未生。已名受乐。是故文殊腾纯陀之疑。在于此也。就佛下答。以有理故。不得言无。未现用故。不得言有。是则三乘。皆同有性也。宝亮曰。此下有十问。断疑劝信也

云何诸菩萨而得不坏众

案。僧宗曰。明依圆教生解。众魔外道。莫能俎坏。非唯自不可坏。所得眷属。亦复坚固。经之力也

云何为生盲而作眼目导

案。僧宗曰。就广叹经中。亦有因益果益。义不异前。既乘正解。复化愚闇。令开慧眼。犹如盲人导之以目也。宝亮曰。此明内果劝信。若不见此经。虽复共住。如彼生盲。不知是佛因也

云何示多头唯愿大仙说

案。僧宗曰。始则因中。开人慧眼。终则成佛。垂应无方也。宝亮曰。就应现以劝信也

云何说法者增长如月初

案。僧宗曰。向问多头。是咨身密。今问说法。是咨口密。根有利钝。教有浅深。月一日至十五日也。宝亮曰。明佛如父母。不欺于子。随根性而说法。以劝信也

云何复示现究竟于涅槃

案。僧宗曰。向明果益。不在一佛。今就释迦。辨灭不灭。即是乘涅槃船。济众生义也。下文因放光。催纯陀供。说十三偈。广明不灭也。智秀曰。第二十八问。悬见大众。睹佛受食。谓应实死。故问应迹灭不灭义

云何踊进者示人天魔道

案。僧亮曰。昔日偏教。说佛无常。密筌于常。惑者失旨。慧命不生。是为魔道。今圆教既开。能生圆解。终成大觉。是为天道也。宝亮曰。此下频有四问。共证究竟事也。此一问即证未来事毕。已为未来众生。开耶正二门竟矣。于今现在。更无事也。昙纤曰。下文答云。若有不能如是观了。三宝常者。是旃陀罗。即谓魔道。异此者。名天道也

云何知法性而受于法乐

案。僧宗曰。说天魔二道。大众蒙解。得法津泽。心生欢喜。事由今教也。昙纤曰。下文时诸天人大众。闻是法已。心生欢喜。踊跃无量。是即法乐。以答此问也

云何诸菩萨远离一切病

案。僧宗曰。前明无灭。此明无病。下现病品。广明病之不实也。昙纤曰。下文言。今悉见诸菩萨。体貌瑰异。殊大殊妙。唯见佛身。喻如药树。为诸菩萨之所围绕。是则内外无病。答此问也

云何为众生显说于秘密

案。僧宗曰。昔日密语。生人谬执。若无今教。何由遍达。广佛隐言。宣显深旨。生解由经。亦叹教也。昙纤曰。下文今者。如来欲为未来无量众生。作大明故。宣说如是大涅槃经。答此问

云何说毕竟及与不毕竟如其断疑罔云何不定说

案。僧宗曰。昔教明二种人。有病必不可治。此经所明。悉皆能治。由经力胜。亦叹教也。宝亮曰。明阐提逆罪谤法三人。毕竟不能进也。菩萨毕竟。能去声闻之人。遇善友者则进。不遇则退。明不毕竟。下余半偈。还请佛解释也。昙纤曰。下文有余偈等。谓有余者。则不毕竟。无余者。即是毕竟。答此问也。结答云。唯除助道。常乐善法。其余一切者。有余无余也

云何而得近最胜无常道

案。僧宗曰。始则治罪。终为菩萨德力转高。邻于极境。皆由经力。此中并指今教。能开发圆解。物无余疑。经益显矣。宝亮曰。此明五人从四时学。来至今经。教于因果中生信。得近无上道也。昙纤曰。下文尔时大众。以种种物。供养如来已。即发无上道心。无量菩萨。得住初地。即是近无上道。答此问

我今请如来为诸菩萨故愿为说甚深微妙诸行等

案。僧宗曰。四重文中。第三文也。前明因果。一经旨归。既已彰矣。第二叹教。今明依经修行。取于常果。亦欲使彼涉求之徒。向慕前规也。欲论文句。并互相涉。前明果中。亦复说因。今辨因文。亦复明果。乃至明境。亦辨于行。就行文中。亦复论境。是则经文浑互。如似不分。然要当求其纲纽。亦各有在也。愿为说甚深者。十地行愿。非二乘所窥。故言甚深。但行有浅深。浅则说行。深详功德。功德与行。广略虽殊。因义不异也

一切诸法中悉有安乐性唯愿大仙尊为我分别说

案。僧宗曰。行之所生。必由乎境。境中之妙。不过佛性。师子吼是略。迦叶是广也

众生大依止两足尊妙药(至)诸佛之境界

案。僧宗曰。说问既竟。将自收退也。诸阴者。上至诸佛。下及众生。人天五道也。夫圣教不同。斯旨甚深。乃是未达。理应咨问。但情浅智劣。不敢有咨。岂唯我所不敢。乃至精进八住以上。具三不退。亦非境界。是以息问也

大般涅槃经集解卷第八大般涅槃经集解卷第九(长寿品第四卷之第二)

  释长寿因义　出密迹力士杀童子事　出诸羯磨名　出入河归海事　合椋牛譬　释法性义　释无想天受乐事　释一体三宝义

    长寿品之第二

尔时佛赞迦叶菩萨善哉善哉

案。僧亮曰。上说虽显。而义旨未周。故须明也。宝亮曰此下先答长寿因也。开为七段。第一许说。第二戒众。第三总说。第四劝令外化。第五佛自引证。第六正业体相。第七释疑也。智秀曰。此一品答因果两问。即为两别。前答因问中。有三段。第一赞其能问。第二辨长寿因相。第三论义也。明骏案。此下答因问也。大分为两。第一正答。第二迦叶咨难也。就正答中。有五翻。第一从此讫利益众生。先叹其能问也。有三意。初以远齐诸佛。次以近等大士。后称其弘益。以结叹也。第二从我无智力。讫深智慧故。迦叶仰詶。叹旨也。亦有三意。初引蚊蚋为譬。不敢仰齐诸佛。次引藏臣为喻。谓已顶奉恭敬。或有片同菩萨。后自谦光云。所问管劣。岂能旷益。正可自利而已也。第三从谛听以下。讫转为人说。诫使至心。劝令转教也。第四从我以修集已下。举现在为证也。第五正答问。有五阶。夫十地以大悲为首。五戒以不杀为先。是以命问之端。发言在戒。故知。菩萨心戒。无自大悲者矣。今既明寿因。是故第一先举至慈之譬。以明自行也。第二劝行不杀。授以十善五戒。以显外化也。第三俯入三涂。拔现在之苦。广明悲之用也。第四发四弘誓。安慰未来广慈之用也。第五结也。天上者。自近而言远耳

善男子汝今未得(至)如一切智问等无有异

案。僧亮曰。此下第三答问分也。僧宗曰。此问总一经之宏致。收万行之枢机。仰弘圣旨。故重称善以赞也。尔问我答。照理是同。诸佛敷扬。何以异此。故曰等诸佛也。宝亮曰。迦叶之实。未易可详。以迹而取。岂议照与佛齐。既所问理玄。独焉峰秀。为近见之徒。须此叹耳

善男子我坐道场菩提树下(至)则能利益无量众生

案。僧宗曰。非唯仰等诸佛。亦复同昔大士也。昔七处八会。说华严方广。于时十方大士。云集论义。亦尝作此问

尔时迦叶菩萨复白佛言(至)法性虚空甚深之义

案。僧宗曰。佛上虽叹。言过所称。谦退未达。德光愈着也。智慧海者。一则深广。二则藏宝也。法性虚空者。有二种。一则万法本来无性。二则涅槃亦称法性。此非思力所及

世尊譬如国王髻中明珠(至)令我广得深智慧故

案。僧宗曰。谓蒙答旨。顶奉恭敬。如彼藏臣也

尔时佛告迦叶菩萨(至)既听受已转为人说

案。僧亮曰。大乘之法。不为一人守护之。方应无边而流通也。僧宗曰。将答所问事。须诫而敕之。夫宗致幽玄。非轻心所受。虽复言指迦叶。而意在时众也

善男子我以修集如是业故(至)今复为人广说是义

案。僧宗曰。所明不虚。乃引我为证也

善男子譬如王子犯罪系狱(至)大慈大悲大喜大舍

案。僧亮曰。此先譬说。后法说也。菩萨有外行内行。慈是外行之因。八河归海。外行果也。群生是内行因。涅槃佛性。是内行果也。次说三宝一体。重显二果常也。王自回驾者。狱为不净。非王行处。慈故至也。五道是苦。非菩萨所居。亦以慈故。难至而能至也

授不杀戒教修善法(至)随所寿终生于天上

案。僧亮曰。慈本救苦。戒是救苦之本。济慈之行也。生于天上者。因地现报也。僧宗曰。十善四等是要行。四弘誓是要愿也。十善中略指不杀。为长寿因者。盖取其相似义也。余九略不说耳。宝亮曰。别有经明四弘誓。配四谛也。谓未度苦者。说苦谛令度。未免缚者。说集谛令解也。未涅槃者。说灭谛令会也。末安者。说道谛令安也。其心旷故名弘。必能行故名誓也

尔时迦叶菩萨复白佛言(至)实作子想如罗睺罗

案。僧宗曰。此举事为难。谓不等也。物情见昔往往治罪。如似伤慈。故须明也。明骏案。此下第二迦叶难也。难意有两。承上旨云。行慈持戒为因。得长寿为果。今此第一先难令无慈。而犯杀戒。使因义不立也。后第二举现见涅槃。无长寿果也。若有长因。果不容短。果必不长。故知。无因反[雨/復]。两关以成其义也。就前关中。有三翻。第一定子想之慈也。第二举事以金刚神。为成难也。第三举理。以涂割为类也。此即第一定慈也。三种恶人。亦作子想不耶。有两阶。先迦叶定。后佛答也

迦叶菩萨复白佛言(至)同于子想如罗睺罗

案。僧亮曰。慈实不等。以二事为证。一以众生不可等。谓破戒是也。二以菩萨慈事不等。力士所杀童子是也。承佛旨者。佛尚不等。况菩萨乎。僧宗曰。金刚即菩萨也。既承神旨。则二圣共杀。斯不等明矣

佛告迦叶汝今不应(至)同于子想如罗睺罗

案。僧亮曰。白衣毁法。尚加苦治。况出家耶。僧宗曰。圣人与夺。利益有时。未必待化。但迦叶所举之事实是化耳。明骏案。此下佛答有五阶。第一拂迹显童子是化。第二明王法与佛法。曲异以证不杀也。第三以小况大。若放一光。尚与无畏。况当有杀也。第四举三譬。明未后行法。四众能治。破法罪人。得福无量。第五双结二旨。若不治者。得无量罪。能如法治。是我弟子也

善男子譬如国王(至)诸行恶之人有果报故

案。僧亮曰。佛以三事。证平等也。一以羯磨治罪。不断其命。二以光照光是慈果施无畏也。三治众得福。不害于慈也。宝亮曰。人若犹有信者。则不得断命。夫生道万端。何必苟在斯法。比丘自可依法而立德。岂惧讥呵。而坏行耶

善男子汝今当知如来即是(至)具有如是无量势力

案。僧亮曰。得无量福者。先以事况也。将欲灭之者。不悔则灭。能悔则止。彼王以二事故得福。一怜愍人民。二令恶者修善。治法比丘。一以护法。二令修善也。下以翦树拔发。偏与护法。为作譬

善男子未可见法汝欲见者(至)即应驱遣呵责举处

案。僧亮曰。此第三事引证也。明未来护法。得福无量。以明必有深利益也

若善比丘见坏法者(至)是我弟子真声闻也

明骏案。此弟五阶。双结得失也

迦叶菩萨复白佛言(至)若治毁禁是言则失

案。僧宗曰。向以童子为化。显无不等之失。然犹治罪人。于慈成碍。是故引此。涂割二事。以为问

佛告迦叶善男子譬如国王(至)如是教诲得福无量

案。僧宗曰。将欲答难。先举譬也国王譬佛。大臣譬通法菩萨。诸子譬四众。端正譬得理之解不偏也。宝亮曰。明如来以四部弟子。付弘法之人教成就也。假令三部弟子。不从诲喻。不尽成道。而余有一众。不可以少欲而不治也。所以不得罪者。有二意。一无有恶心。二明运慈故也

善男子如来亦尔(至)亦能善知宿世之事

案。僧宗曰。合譬以凡况圣。答难显一子之平等非谬也

迦叶菩萨复白佛言(至)如来不应作如是言

案。宝亮曰。将欲说果。以果难因。现果不长。往因宁等耶。僧宗曰。虽复捉果寻因。而事在难果。即答长寿果问也。智秀曰。犹是难因也。因必是实。理召常果。则不应涅槃。今已果征因。因非实矣。以此而推故。知犹是难因。未是答果也。有两翻。第一难。第二答也。就难中有三阶。第一直谓不应长寿之旨。第二举譬。第三合譬结难。此即第一将欲为难。先领旨也

何以故如知法人能说种种(至)是知法人言行相违

案。智秀曰。此第二阶举譬也

如来所言亦复如是(至)得是短寿不满百年

案。智秀曰。第三阶合譬结难也

佛告迦叶善男子汝今何缘(至)于诸常中最为第一

案。智秀曰。此第二翻佛直呵答而已。上来所明。不应复有如此粗言

迦叶菩萨复白佛言世尊云何如来得寿无量

案。僧宗曰。若语其事。但八十年也。而云诸常法中。最第一者。不应无旨。是故问言云何常也。智秀曰。此下答第二长寿果问也。答问不同。或须重称问以求答。或直尔而问。或因答前余势。仍为答者。此答中有三别。第一正答长寿义。第二设难。第三改正三归。从此讫寿命第一。正答问也。有两意。初迦叶问。后佛答也

佛告迦叶善男子如八大河(至)及诸小河悉入大海

案。道生曰。所以归海者。至下者也。其以众流。为海之水。水亦名为海矣

迦叶如是一切人中天上(至)悉入如来寿命海中

案。道生曰。如来何寿。以百姓为寿耳。谓之寿海

是故如来寿命无量

案。法瑶曰。夫长寿之由。穷不杀之理。然人天之命。亦少分不杀。是则入佛寿命少分因也。故云一切命。皆入佛命海中也。僧宗曰。海之吞纳众流。无有增。咸因地万善。钟于极果。以因满则常也。又胜鬘经言。如来藏即是佛性。在因为藏。在果为佛。非始非终。隐显为异耳。若众生无性者。中间亦可断绝。以其性义不亡。必应成佛。至佛乃常。如众流至海。更无去处。故惑尽行周。得佛自常也。宝亮曰。海是纳流之器。如来之寿。是众命之极。研辨其旨。凡有三义。其两义玄推。一义从文。第一明众生寿命。皆是如来寿命。海内无有过于佛者。第二众生寿命。虽复无量。流转不定。至佛方住。第三明菩萨在行地之日。施众生命。以此为因。得果之日。则不容短促。然经言众生生死。如蚕作茧。非圣所教。而今乃言。施命为因。此实难晓。又言众生可害。而行道者。无有害心。即名施命。此复难解。夫圣人出世。正欲令人断烦恼灭生死。若从此义。应是夺命。而言施命者何耶。夫命者。名之为生。生于真寿。真寿者。即法性身也。是故圣人。使众生修道。显真常之寿。圣意在此。故为施命也

复次迦叶譬如阿耨达池(至)如来亦尔出一切命

案。道生曰。以百姓寿为寿。感必出矣。出必无穷。若陂池也。法瑶曰。此明天人寿命。皆由佛化所得。故曰从如来命出一切命也。僧宗曰。前譬明入。今譬明出也。大品经言。一切天人。刹利大姓。乃至居士。一切皆由菩萨所化也。明因地之时。施一切命。化功则应还于化主。故至佛则常也

迦叶譬如一切诸常法中(至)于诸常中最为第一

案。智秀曰。上海譬虽明形待。因时之命。在果为极。未显终竟不尽。故以此譬。更明无尽如虚空

迦叶譬如诸药醍醐第一(至)于众生中寿命第一

案。智秀曰。赞叹常旨也。解由境生。不无除惑之功。故拟况醍醐

迦叶菩萨复白佛言(至)常宣妙法如注大雨

案。僧宗曰。承机致请也。上乃明妙果是常。未明迹须必灭。今因迦叶致请。明丈六非实。以下况上。则本迹可知矣。宝亮曰。明理既竟。引四事证也。第一借近况远。第二明有常之名。根本在佛。第三引法性为证。第四明一体三宝。唯一极为证。此即第一也。智秀曰。答问显常。已明于前。此下第二。更举三缘为证。此第一引伏难也。既云常。则应常住。既不住。便是无常

迦叶汝今不应于如来所(至)是故现舍入于涅槃

案。宝亮曰。外道五通。尚能延促自在。岂况如来。具以自在。示同毒树

迦叶当知佛是常法(至)既修集已广为人说

案。智秀曰。此章中有两翻。第一难。第二答。答中有两阶。前正况答。此结劝

尔时迦叶菩萨白佛言(至)微尘世性亦不现故

案。僧亮曰。将说内行因果。先难果常也。若果不常现。云何得与世法别也。性者。异道计云。以冥初。为世间性也。法瑶曰。前明如来常理晓然。但据今日现入涅槃。似是虚妄。则与世间所说同也。若无以辨异。则致或者众。故发斯问。使画然有判也。僧宗曰。就答果中。有四章。第一寄言行相违。显本是常也。虽知是常。外道亦言有常。第二释常我之名。本在于佛。为外道所窃。今释其真伪。真则佛法涅槃。其体是常。常即法性。但昔涅槃。亦言法性。二教既同。事须洗释。故第三简今昔二名。同明法性。所明不同。昔明法性。但以单灭。今明法性。常而妙有。极果体圆。备三归之德。是故第四劝厉行人。使归依也。有何异有。诚知本当。但即事为灭也。如即外道。亦有空言。俱无事验。滞言之徒。无以取信。愿佛为释。使真伪有在也。智秀曰。此下第二意。举例重贵也。若同不现者。则应俱是无常

佛告迦叶譬如长者

案。僧亮曰。果不常现。迹不可辨。乃因譬以释之。此譬中有四分义。初譬佛在世。读诵得旨。修成佛也。第二譬佛始灭。得佛遗法。不解深义。犹得人天也。第三譬己智慧。又无慈悲。欲求自度。不解究竟。不成佛果也。第四求常之心。遂生耶见。见多者。则失人天。少则不失也。长者譬佛也。宝亮所释。与此同。唯合第四。为第三耳。僧宗开第四譬。为第五

多有诸牛

案。僧亮曰。经藏也。牛出五味。经生五果也

同共一群

案。僧亮曰。归一解脱也。僧宗曰。虽复十二部中。理味有异。然同一佛说也

付放牧人

案。僧亮曰。弘通菩萨

令逐水草

案。僧亮曰。受学弟子

唯为醍醐不求乳酪

案。僧亮曰。所谓诸佛为一大事因缘。出于世也。法瑶曰。人天为乳酪。二乘为生苏。菩萨为熟苏。唯佛为醍醐耳

彼牧牛者构已自食

案。僧亮曰。读诵得旨

长者命终

案。僧亮曰。佛涅槃也。此下第二譬也

所有诸牛悉为群贼之所抄掠

案。僧亮曰。凡夫不从经旨取解。喻之抄掠也。法瑶曰。外道盗窃遗余经法。谓之抄掠也。宝亮曰。虽复受持。捉相心强。多诸杂伪。不得真理

贼得牛已无有妇女

案。道生曰。作醍醐者。本是妇女所能。若从其受。必有成理。今云无者。譬无弘通之近。贤圣善友。所以无成

即自构将得已而食

案。道生曰。凡夫横取。凡有三焉。此其一也。虽复无师。藉以读诵之善。或受人天。而计之为福。横之一。僧亮曰。去圣曰近。由得人天资也。法瑶曰。虽无出要。亦得少善。譬构将也。宝亮曰。虽无慧方便。非不以相心受持

尔时群贼各相谓言(至)名为世间第一上味

案。僧亮曰。第三譬也。知经大意。以人天渐进。终期为佛也。何方得之者。自知无解无方便也。僧宗曰。虽得常名。不解趣常之实

我等无器

案。僧亮曰。菩萨以大悲为器。忘身济物。自审无之法也。法瑶曰。不知求涅槃之方也。昙济曰。慈戒为万行之器。自知无也。僧宗曰。谓此身非受道器也

设使得乳无安置处

案。僧亮曰。谓设得人天。非求佛之因也。僧宗曰。既云假设。则无得理也。非唯二乘无漏不可。而辨设行地之善。亦非所辨也。智秀曰。非唯无安涅槃极果之处。设得微善如乳。亦无正信之器。为其本也

复共相谓唯有皮囊可以盛之

案。僧亮曰。欲学声闻受身。如皮囊受水。不盛醍醐也。法瑶曰。虽知涅槃方便。而有读诵之善。非正解唯得人天

虽有盛处不知攒摇

案。僧亮曰。攒譬思慧。摇譬修慧。虽自求度。而不生二慧也。僧宗曰。正是无方便之说也。上来诸句。未若此显。但保着人天。不知推求。更有胜此者也。宝亮曰。虽复欲行小乘。不知作假名法空观行

浆犹难得况复生苏

案。道生曰。精纯成苏。余汁为浆。二乘成道。身则是余。苟不解常。乖此远矣。横之二也。僧亮曰。向果譬浆。得果譬苏。既无二慧得之。与向皆不成也。法瑶曰。既不知解说之攒摇。世俗之善。犹尚难得。况二乘果乎。昙济曰。声闻向中七方便。譬浆也。僧宗曰。初地至七地。如生苏。八地至十地。如熟苏。浆非五味之限。今明既不知攒。求胜出之善。乃至住前凡夫。有漏之善。尚不可得。岂况上住真味。生苏当可得耶。宝亮曰。信首五根亦不立

尔时诸贼以醍醐故加之以水

案。僧亮曰。此第四譬也。求常不已。遂生邪见也。法瑶曰。虽知此经。能得常果。而不能知常之所在。更说种种常法。谓加之以水也。僧宗曰。第四譬也。醍醐为物。其质甚清。欲速得故。加水令清。是则清色相似。其味则殊。虽知涅槃是常乐法。欲速得故。乃计此身即是常乐。名同而实异也。譬加以水。则损杂血之乳。若计身为我。则损人天之善也。宝亮曰。此下第三譬。悉起诸耶见也

以水多故乳酪醍醐一切俱失

案。道生曰。又谓经得常住胜解。而不识之。更说种种耶常之法。常耶既增。坏本常味。五时俱失。横之三也。僧亮曰。耶见多者。能断善根。人天俱失。少者由信因果也。法瑶曰。加以倒常之水。坏真常故。五味失也。僧宗曰。第五譬。遂断善根。乃至人天因果顿失也

凡夫亦尔虽有善法皆是如来正法之余

案。道生曰。合譬也。佛经令人得戒定智慧。斯三法者。本是得佛之要道也。彼以取世乐故。失本为余也。取世乐故。为弃也

何以故如来世尊入涅槃后(至)如彼诸贼劫掠群牛

案。道生曰。本不应取。以世乐而取。谓之为盗窃也。僧亮曰。合第二譬也

诸凡夫人虽复得是戒定智慧无有方便不能解脱

案。道生曰。不解戒定智。为常住解脱因义。故不解解说。合二横也

以是义故不能获得(至)不知方便亡失醍醐

案。僧亮曰。合第三第四。无方便譬也。宝亮曰。自凡夫亦尔。至此。合第二譬

又如群贼为醍醐故(至)如彼群贼不得醍醐

案。僧亮曰。此别合上第三譬。上云。多水未被合也。何者。夫耶见有轻重。重者。说无因果。人天都失。轻者。谬计涅槃。或得人天也。僧宗曰。此乃举第四譬。而先合第五譬也。宝亮曰。此合第三譬也。阙不合初耳

是诸凡夫有少梵行(至)如彼群贼加水之乳

案。道生曰。虽更加常。未断善根者。犹以少善。生欲界天。合三横也

而是凡夫实不知因(至)虽复说之而实不知

案。道生曰。尚不知世善。故生天。岂知归三宝耶。僧亮曰。是加水之中。小加者也。不知因修梵行者。人天近因。尚不能知。况出世常因。而能知耶。僧宗曰。修少梵行。受少乐者。合自构而食也。如彼群贼。加水之乳。更举第四譬也。而是凡夫。实不能知。因少梵行者。即是加水也。因名所以。既计身为常。岂达真常所以也。宝亮曰。此下释教也。昔唱外道生天。谓言用耶见为因。今释云。非是因耶见作因。乃是昔曰供养父母。有孝敬之善。为因故也。外道既不知此理。岂知出生死之路。横计颠倒。以成大耶

是故如来出世之后(至)群贼退散牛无损命

案。道生曰。后佛出世。说真常也。僧亮曰。譬后佛出生也。凡夫横求。理本常存。三世诸佛。同共一道也。僧宗曰。上五譬。明外道窃得常名。而无常实。今明常名。始终还于佛也。前合譬已竟。此义生耳

时转轮王即以诸牛(至)一切众生无有患苦

案。僧宗曰。明释迦出也。还以常法。付菩萨

法转轮王出现世时(至)善说世法及出生法

案。道生曰。善说世善。所以得常住之义。况出世乎。凡夫既舍。佛得持还也

为众生故令诸菩萨随而演说

案。道生曰以付菩萨。使得常解。道兼天下

菩萨摩诃萨既得醍醐(至)所谓如来常乐我净

案。僧宗曰。合有二意。前合贼散。后合付菩萨也

以是义故善男子(至)要是如来非是余法

案。道生曰。以上来而言之。常法虚实。居然有在也。智秀曰。结答难也

迦叶应当如是知如来身(至)随我所行至我至处

案。智秀曰。劝受持也

善男子若有修习如是二字(至)即是诸佛之法性也

案。道生曰。法者。无复非法之义也。性者。真极无变之义也。即真而无变。岂有灭耶。今言灭是法性。盖无所灭耳。僧亮曰。菩萨通达法性。成佛涅槃。法性无灭。涅槃常住。此说内行果上义也。凡夫不解空。故不得涅槃。以空证涅槃也。宝亮曰。此下第三证佛果之地。以法性为寿命故。所以长远也。有人解此灭相。为断灭之灭。谓之不然。何者。下文结句云。即是诸佛之法性也。岂是断灭之辞乎。今释云。若能安此二字为寂灭者。佛于此人。真入伊字涅槃。应言。何以故即法性也

迦叶菩萨白佛言世尊(至)我今云何当知是义

案。道生曰。向云灭是法性。似若丈六犹存。丈六若实。故是非法中出也。法性无有非法。何有丈六哉。身与法性。不可得并。而有身所未了也。僧亮曰。执方便为难也。真极无变。谓之法性。必舍身智。然后是耳。今身既不灭。复言是性。霜炎之理。二不俱存。云何当得知是义也。法瑶曰。向言涅槃是佛法性。似若都灭涅槃是法性也。今欲明法性乃是法身常住体也。夫法性者。即是法身者。若以灭尽。为法性者。则为无所有。岂有法身乎。若有法身者。则非灭尽。何有法性乎。二事不得并也。僧宗曰。此第二文也。今教所明法性者。谓圆果无非。故称法。体不可改。故称性。而名与昔同事须料简也

佛告迦叶善男子汝今不应(至)夫法性者无有灭也

案。道生曰。法性照圆。理实常存。至于应感。岂暂废耶。僧亮曰。推本以证末。是则有为。横生灭耳。法性本来非有。故无灭也。如来亦本来非有。岂有灭也

善男子譬如无想天(至)非诸声闻缘觉所知

案。僧亮曰。凡夫受报色心。必须直以想微。二乘不知。名为无想天耳。有漏近事。非汝境界。况无漏乎。僧宗曰。依此经所明。乃至四空。斯皆有色。今无想天。是等四禅中。四凡夫天之最上。那含天之下。有此一地。虽有色身。以其心细。而无色想。唯佛乃知。余无能了

善男子不应说言如来身者(至)非诸声闻缘觉所及

案。僧宗曰。岂况如来妙极。而当可知。昔指孤灭。以为法性。权而非实

善男子汝今不应思量(至)种种方便不可思议

案。智秀曰。诫劝也

复次善男子应当修集(至)修常想者则有归处

案。僧亮曰。佛实不灭。于涅槃后。不闻此经。生实灭想。依异体三宝。出家受戒。不成清净。具足三归。若闻经不信。虽复出家。不能成果也。僧宗曰。此第四文也。向明法性。苟非孤灭。则妙有可归。若能安心。在乎非无。则识真果。故举三归令标。拟有方也。宝亮曰。唯一极位。故是常也。明此三法。是一体而无三。故称无异相也。体是嶷然。故云无常相也。不为三相所迁。故无变异相也。一体三宝者。正辨一佛体之三义也。但以初名当于法体。万想悉是义名。无别体名觉义名异。是故佛宝当体。其余法僧。属义名也。昔说三宝三体各别。今牵昔日法之与僧。置于佛上。故言一佛体之三宝。以觉察之义。为佛宝。体无非法。具众功德。故称法宝。体不隔物。必与理和。号曰僧宝也。若于此三法。为异修者。当知此人。不成清净归依。既谓佛宝未极。云何而得具足戒耶。不言头数咸少。正云戒非上品耳。若依凭常住三归。则得戒具足。夫行从信地而生。今信既未圆。所得之戒。何容具足耶。佛昔自言。我为二乘。今若依凭差别三宝。尚不能得如我作声闻缘觉之近果。况复不依常住三归。而入无漏真圣之位耶。故知。执教解经者。其事必谬矣。智秀曰。此下答问中。第三大意也。以昔明三宝。言旨未周。故归心未正。今辨法性。体备三宝。长存不灭。是则归心须改。故此一章。显正归依也。有三翻。第一佛自明理。劝物归依。第二迦叶设难。佛答。第三迦叶述旨。佛赞成也。三宝无别体。故言无异。不流动故。非无常也。无复改愚成智。故不变易也

善男子譬如因树则有树影(至)譬如闇中有树无影

案。僧亮曰。树譬佛。影譬归依。无树无影。无佛无依也。有树无影者。闇中有树无影。佛虽在而不现。则不成归依也。法瑶曰。明有常理故。得有归依义耳。如有树则有影也。僧宗曰。相承解云。有能归之心。必有所归之理。此解迦叶之难。乃为便也。就文又有不便。旧释此树譬真法身。影譬应身。于前文为便。于难为不便也。此二释。各参一边。未为惬尽。并不消文意。今云有归依者。正言极果妙有是常。则有归依之德。若无此德。则有义亦坏。是故迦叶。就影为难。欲使无归依之德也。智秀曰。能归之心。终能成佛。故以树譬归依之心。影譬所成之佛也。故云因树则有影

迦叶汝不应言有树无影(至)各各异故故使无常

案。僧亮曰。星月有光。树有闇影。但以微故。非肉眼见耳。法身亦尔。非汝所见也。法瑶曰。勿谓不见。便言无也。常住法身。慧眼所见。故归义不无。但肉眼不见。便谓无有常住之归依义耳。品初劝问云若归者。即此常住三归是也。又云若戒者。即前大慈大悲一子想是也。宝亮曰。天眼资细空明。而瞩色故。不同肉眼之用也

迦叶菩萨复白佛言(至)而得长寿善知宿命

案。智秀曰。第三翻。述旨传化有两别。前迦叶领解。后佛赞成也

大般涅槃经集解卷第九大般涅槃经集解卷第十(金刚身品第五　名字功德品第六)

  释百非义　出护法国王护弘法比丘　释开随护法持刀仗白衣行　释受持此经不随四趣　释此经具七善　释此经八味具足

    金刚身品第五

案。道生曰。长寿之与金刚。皆共谈丈六。但内外言之耳。长寿为外应之迹。金刚为内照之实。实照体圆。故无法也。僧亮曰。答问金刚体不可坏也。有人命不尽。而诸根坏。故须两说也。法瑶曰。上明长寿无穷。然未必不念念相续。今明金刚坚固。非念所迁坏也。前因义此显体也僧宗曰。答第二问也。答因答果。即为两段也。宝亮曰。此品前明果后明因。今以果题品也。如来以法性为体。无有无无。百非所不及。绝有相之境也。大分为五。第一初有两行。总辨金刚身相。体常不动。非食所资也。第二从迦叶发问以下。据迹为难也。第三从佛告迦叶以下。将欲答难。且更广明法身。绝百非之相也。第四从如来所以示病苦者。正答迦叶难。释应现无常尘土之意也。第五领解。自说己之体常。兼传被于未闻者也。智秀曰。就答果问中。有四翻。第一两行正答问也。第二迦叶难。第三佛答也。第四劝信

尔时世尊复告迦叶(至)非杂食身即是法身

案。僧亮曰。法者。无非法之义。释非食身也。食所长养。非法横生。名思欲身

迦叶白佛言世尊如佛所说(至)如来今当入涅槃故

案。僧宗曰。迦叶执迹为难。以和妙释

佛告迦叶汝今莫谓(至)坚牢难坏非人天身

案。僧宗曰。寻此释意。从初至非识离心以来。偏明真应不异也。从非识离心以下。就不即以明义也。非人天身者。位过五道也。智秀曰。寻此答旨。有二别。第一先以四科。广解法身之相。第二结也。第一科。从此讫如来之身非身。先明非恶身。以约迦叶难也。第二从是身讫非识。就名相中。辨不生不灭身也。即以两缘释之。初从不集不修以下。明不从集起也。次从无有动摇以下。明在果不复更随缘造业。以此二缘。知法身不生灭也。第三从离心亦不离心以下。带应明本。正显应由本有故。本从于应。以制名也。第四从如来之身成就以下。向虽以三缘。显法身相。皆是名相中者。未尽其美。乃更明法身妙绝众相。非谓无法可名。正以法身德。广非下地方言所能尽耳

非恐怖身

案。僧宗曰。离生死恐怖也

非杂食身

案。僧宗曰。不为四食所养

如来之身非身是身

案。僧亮曰。身以生灭聚积为义。而有真有应也。真身非生灭积聚。故非身也。应身无生不生。无形不形。故是身也。僧宗曰。非形累之身。即是法身之谓也

不生不灭

案。僧宗曰。离有为相

不集不修

案。僧宗曰。非业烦恼

无量无边

案。僧亮曰。身无大小。难可定取也。僧宗曰。法身弥[雨/復]。岂有边表也

无知无形

案。僧亮曰。大悟无知。妙像无形。僧宗曰。知形生于立称。法身妙绝。绝待故也

毕竟清净

案。僧亮曰。有知有形。非清非浊。僧宗曰。双遣乃净也

无有动摇

案。僧亮曰。释清净也。有知则有所不知。有形则有所不形。可动可摇。岂曰净也。僧宗曰。法身凝寂。孰能动耶

无受无行不住不作无味无杂非是有为

案。僧亮曰。此下至非有为。释上无知也。受缘则行。行则有住。住便有作。作必味着。着则杂恶斯集。恶集则体无留停。有为法也。以无此故。非有为也。僧宗曰。位满故。不受住位。故不行。不住生死。故不住也。作即是业。味即烦恼。杂即是果也

非业非果非行非灭非心非数

案。僧亮曰。释非有为也。有为则是业。是果。是行。是灭。由心数而起。非之故无也。僧宗曰。离有余果。故非业非果。离无余果。故非行非灭也。非心心数。离四阴也

不可思议常不可思议

案。僧亮曰。真身如是不可思议。或谓真不可议。应是可议。故曰应即是真常不可议也。僧宗曰。三乘十地。不能量也

无识离心

案。僧亮曰。释上非心也。现分别故。名为识也。能生后有。故名为心。今谓无分别。故非识。不生后有。故非心也。僧宗曰。从此以下。真应双明也

亦不离心

案。僧亮曰。虽不分别。而无事不知也。僧宗曰。上既言无识。谓同木石。拂此疑故。亦不离心也

其心平等

案。僧亮曰。虽知而无知相也。僧宗曰。绝高下故。故言平也。无优劣故。故言等也

无有亦有

案。僧亮曰。无生住灭。故非有。智周三世。故亦有也。僧宗曰。法身无像。故无有。丈六通化。故亦有也

无有去来而亦去来

案。僧宗曰。既无有色。谁去谁来。垂形六道。见有去来

不破不坏不断不绝不出不灭

案。僧亮曰。上云去来。似有破坏出灭。今明无此。以释非有为也。僧宗曰。离四相故。不破乃至不绝也。体非未来故。不出至现在。不灭入过去也

非主亦主

案。僧亮曰。心居物下。故非主。具八自在。故亦主也。僧宗曰。法身妙绝。何依何主。道王三千。故云亦主

非有非无

案。僧亮曰。两非重说。终遣有耳。僧宗曰。不同二十五有。故非有。不同太虚。故非无也。亦曰法身故非有。应迹故非无也

非觉非观非字非不字

案。僧亮曰。非人非天。故非字。应人名人。故非不字也。僧宗曰。离粗细心相。故非觉观也。夫名生于形。无状故无名。应用故有字也

非定非不定

案。僧亮曰。心驰万境。故非定。寂然不动。故非不定也。僧宗曰。能大能小。故非定也。其体常湛。故非不定也

不可见了了见

案。僧亮曰。十地所不睹。故不可见。后身见故。了了见也

无处亦处无宅亦宅

案。僧亮曰。真则非人。无处无宅也。常在五道。故亦处亦宅也

无闇无明

案。僧亮曰。洞鉴三世。故无闇也。现同凡夫。故无明也

无有寂静而亦寂静

案。僧亮曰。无事不为。而常无为。僧宗曰。分身散体。故无寂静也。常果恬然。故言亦寂静也

是无所有不受不施

案。僧亮曰。无二十五有。故无有也。不衣不食。故不受也。功德无增。故无施也。僧宗曰。虽言始有。视听不得。故无有也。位居足地。故不受也。离因相故。故无施也

清净无垢无诤断诤

案。僧亮曰。释上句也。无是无非。故无诤也。僧宗曰。烦恼是诤。以断尽故。故言无也

住无住处

案。僧亮曰。释上无宅亦宅句也。僧宗曰。涅槃无域真所居也

不取不堕

案。僧亮曰。不进求故不取也。不退故不堕也。僧宗曰。因取故堕。不取故不堕也

非法非非法非福田非非福田

案。僧亮曰。绝轨相故非法。化人故非非法也。绝言故非田。应供故非非田

无尽不尽离一切尽

案。僧亮曰。释上句也。湛然故无尽也。僧宗曰。移劫不穷。故言无尽。即是不尽。故离一切尽也

是空离空

案。僧亮曰。无性无相。故是空也。离无常无我。故离空也。僧宗曰。空无生死。即离空也

虽不常住非念念灭

案。僧亮曰。体无生灭。或隐或显。僧宗曰。绝言故。不可名之为常。绝众相故。非念念灭

无有垢浊

案。僧亮曰。释不灭也

无字离字非声非说

案。僧宗曰。释不灭也

亦非修集非称非量

案。僧亮曰。了因非作故。因非修集也。绝思议故。非称量也。僧宗曰。无所进故。非修集也。无相待故。非称量也

非一非异

案。僧亮曰。方圆殊应。故非一也。真性不改。故不异也

非像非相诸相庄严

案。僧亮曰。妙绝众相。而相超世

非勇非畏无寂不寂

案。僧亮曰。摧四魔故非畏也。无静不静。故无寂

无热不热无可睹见无有相貌

案。僧亮曰。动静一体。其相难见

如来度脱一切众生(至)法无有二故不可量

案。僧亮曰。出其事也

无等等

案。僧亮曰。唯佛与佛等也

平如虚空

案。僧亮曰。释等义也

无有相貌同无生性不断不常常行一乘众生见三

案。僧亮曰。无有相貌。出等事也。或三或一释等义

不退不转断一切结不战不触

案。僧亮曰。大乘所无也。僧宗曰。四魔已尽。故不战也。灭于攀缘。故无触也

非性住性

案。僧亮曰。无自性故非性也。不改变易。故住性也

非合非散非长非短(至)非增非损非胜非负

案。僧亮曰。总释上也

如来之身成就如是(至)非有为非无为非世非不世

案。僧亮曰。有知知则不等也

非作非不作

案。僧亮曰。谓是了因非作因也

非依非不依(至)除一法相不可算数

案。僧亮曰。不可一方一数取也。僧宗曰。若谓得一法相。在百非外者。亦除之也。一解云。除方便一法也

般涅槃时不般涅槃

案。僧宗曰。物见有灭。竟不灭也

如来法身皆悉成就如是无量微妙功德

案。僧亮曰。总结上也

迦叶唯有如来乃知是相非诸声闻缘觉所知

案。僧亮曰。结上不思议也

迦叶如是功德成如来身非是杂食所长养身

案。僧亮曰。结上法身妙极。离生死也

迦叶如来真身功德如是(至)为欲调伏诸众生故

案。僧亮曰。结上应身。虽生不生

善男子汝今常知如来之身即金刚身

案。僧亮曰。以本迹相。即双结也

汝从今日常当专心(至)说如来身即是法身

案。僧宗曰。备上众德。本迹相关。其旨显然。劝令受持。广弘化也

迦叶菩萨白佛言世尊(至)亦当为人如是广说

案。智秀曰。领解也

唯然世尊如来法身金刚不坏而未能知所因云何

案。僧亮曰。答问复以何因缘。得大坚固力也。下文举护法为因也。僧宗曰。答因中有四段。第一列三种章门。所谓护法引证开制也。第二广此三也。第三明末代通法人也。第四明不但通经。亦协通律为化也。宝亮曰。就此答中。大分为三。第一总答。以护法为因也。第二佛自引证。我昔亲行此因也。第三从持正法者。不受五戒。广辨护法之相也。护法者。不出二途。一者据万行为端。自守戒行。任持在心。二者不顾形命。但使法弘也。若能弘。建立之心令恶改。而法通者。故佛于下文。叹护法者。自利利人之功胜也。智秀曰。大分此答。为两段。第一举问求答。第二正答也。答中又有二别。一略二广也。此即大分中之第一。举问求答也

佛告迦叶以能护持正法因缘故得成就是金刚身

案。智秀曰。此下正答中。第一略门也。有两翻。此第一直答

迦叶我于往昔护法因缘(至)是金刚身常住不坏

案。僧亮曰。护法法全。是故感得身不可坏也。智秀曰。此第二自举往昔。略为证也

善男子护持正法者(至)守护持戒清净比丘

案。宝亮曰。下文显出家之人。有三品。在家之人。蠲去下品。唯出中上也。若不受五戒。而忘身护法。令法得通者。此实大勇猛也。出家通法之人。所以应与护法白衣持刀杖者俱者。此就末世之中为论耳。智秀曰。此下第二广门也。有三翻。第一明在家人护法。第二引证。第三明出家之人。护法之法也。从此讫非持戒者。得如是名。第一辨在家之人护法。有二翻。第一正明护法。第二迦叶难也。此即第一翻也

迦叶菩萨白佛言世尊(至)当知是辈是秃居士

案。僧亮曰。与刀仗者俱。律有诚制。不名清净。故须问也。僧宗曰。向列三章门。今欲广释护法之相。先假执声闻教中。唯以独静为上。今佛释此非上。以护法为胜也。智秀曰。此下第二翻也。为难之辞。虽在比丘。而实为显在家之人。护法之法

佛告迦叶莫作是语言秃居士

案。僧亮曰。此下举三种比丘。前出中品。次出上品。后出下品也

若有比丘随所至处(至)当知是人无所能为

案。僧亮曰。此举中品比丘也。宝亮曰。昔以持律为上品。今云是中品者。以其不能广利于物。自守而已故也

若有比丘供身之具(至)如法治之驱令还俗

案。僧亮曰。举上品比丘也

若有比丘能作如是(至)非持戒者得如是名

案。僧亮曰。举下品比丘。即结正破戒者也

善男子过去久远无量无边(至)奴婢牛羊非法之物

案。智秀曰。此第二引证。有两章。前引证。后领解也。明骏案。此下引证。有七段。一证弘法比丘。必须强力者为护也。二证世有恶人。必能遮遏弘通之道也。三举在家护法之至也。四显弘赞二人之果报也。五会古今。六迦叶领解。七佛述劝也。此即第一。出通法比丘之缘起也

尔时多有破戒比丘(至)执持刀杖逼是法师

明骏案。第二举恶人。遏弘法者之缘起也

是时国王名曰有德(至)此身当为无量法器

明骏案。第三显护法之人

王于是时得闻法已(至)应当如是受持拥护

案。僧宗曰。六卷泥洹云。王为第二弟子。觉德为第一弟子。而此言王第一者。盖以先生彼国故耳。明骏案。第四显弘护法者。道俗二人之果报也

迦叶尔时王者则我身是(至)成就法身不可坏身

明骏案。第五会古今

迦叶菩萨复白佛言世尊如来常身犹如画石

明骏案。第六领解也

佛告迦叶善男子以是因缘(至)刀剑器杖侍卫法师

明骏案。第七印述劝护法也

迦叶白佛言世尊若诸比丘(至)为是持戒为是破戒

案。僧亮曰。上以不受五戒。名优婆塞。以功补德。若尔者。何必受戒。而名比丘。是故问言有师无师。以定之也。为持为犯者。有师则有戒。亦可以功补过。次问为特为犯也。法瑶曰。随逐守护。迹似破戒。恐无人师之德。欲明此人持戒之德不亏。可师之道逾盛。是以迦叶发斯问也。僧宗曰。此中有二问。初问有师仁之德不耶。二问为持戒破戒耶。昔教比丘。不得与器仗者俱游。故有问也。宝亮曰。所以复有此问者。向虽辨今昔两教之异。又明弘法之处。今先审其位。后明其处也。智秀曰。此下第三明出家之人。护法之方也。有两别。前开两翻问答。后领解赞述也。前两翻问答者。第一举非以显是。第二开制也。此将明非以显是。故迦叶发问

佛告迦叶莫谓是等(至)驱逐令出若杀若害

案。僧宗曰。先答后问也。末世恶人。坏乱法者。为治此人。故应须与持仗者俱。此乃大士之行。非谓破戒者也。智秀曰。正举非以显是也

迦叶菩萨复白佛言(至)游行村落城邑教化

案。智秀曰。第二翻开制也。愿闻开制。所以发问

善男子是故我今听持戒人(至)即得名为第一持戒

案。僧宗曰。不应断命者。事在通法也。又一解不须起断命之意。必是大士。审见机缘。此所不论也。智秀曰。开与持杖者俱行。以通法故也

迦叶夫护法者谓具正见(至)其心弘广譬如大海

案。法瑶曰。明护法比丘。有人师之德。可为师道。故曰为护法之师。持律之师。及以经师。此三各有师道。经有诚文也。僧宗曰。此答前问有师仁之德为无耶。今云。具正见于内。则化流于外。此乃师德着矣。智秀曰。此下凡以三复次释前问也。初明护法之方。次明能治破戒。后明善解律相。此即第一正显师德也

迦叶若有比丘以利养故(至)是名护法无上大师

案。僧宗曰。此第四段也。上明通经。此明通律也。宝亮曰。此显流通处也。杂僧者。以善恶无作。共成此人。故名为杂。但自持戒。不知他事。名愚痴也。清净者。以二缘难坏。一则不求名。二则不违法律也。杂僧可坏。亦有二缘。一则为名利故。研精所受。二者若遇善友。亦能坏恶。而从善也。举此二众。明力能降伏。下出五法。为降伏之方法也

善持律者为欲调伏(至)若是律者则便证知

案。宝亮曰。此出五法也

云何调众生故若诸菩萨(至)如来亦尔不可思议

案。僧宗曰。具此五德。调二种人也。善解一字者。于一一字中。善解言旨也。又释善解满字也。寻此文旨。应云善解一律字也。宝亮曰。五法者。一者调伏众生。二者知轻。三者知重。四者非律不证。五者是律应证也。随机而化。不惮形迹。是调众生也。知四重是知重也。止此知重。非善知也。若知诸篇之中。有重心者。是名知重。从知第二篇以下。是名知轻。亦如知重类也。非律不证者。若是违律所应制者。则应制之。不同用也。是律应证者。能依经律而行。则便赞叹劝诱也

迦叶菩萨白佛言世尊(至)如于镜中见诸色像

案。智秀曰。此第二别也。有两翻。前迦叶。领旨弘化。后佛赞劝也

    名字功德品第六

案。僧亮曰。此经以常住为体。上说寿命金刚之身。及其二因。今说经名字。及流通究竟略说也。法瑶曰。从此入四相品讫善解因缘竟答此问也。上明长寿金刚。是经之极致。为彼行者。修习此经。得其深旨。备乎四德。自正正他。是则能到经彼岸也。僧宗曰。此答第四问也。经之宗要。其唯因果圆极之法。三德为体。但解脱名义。不异昔日。异在二德耳。上来已明法身般若。兼明其因。因果既彰。则则经体已足。故结其名题。明流通也。言名字者。为经题立名耳。下文言名大般涅槃也。智秀曰。夫道流千载。非名不传。须结名字。远闻为益也。应言。云何为经作名字。使受持者。得到彼岸耶。大分为三段。第一叹经功德。第二举问求答。第三迦叶领解也。明骏案。明般若。即慧命无穷。辨法身。则金刚不坏。以显两德也。今此一问。正辨解脱也。而言云何于此经。究竟到彼岸者。以能究竟解因之缚。脱果之累。故得到彼至极之岸也。于此经者。即是请经名也。涅槃彼音。此无以译。以解脱无累灭度等名。训释而已。非含众德也。今昔之异。但以法身般若为别耳。至于解脱之义。终在涅槃。昔为灭烦恼舍身智。置此名也。今日以此名。为经之号。故言云何于此经。究竟至彼岸也。下答云。降伏一切诸结烦恼。及诸魔性。然后要于大般涅槃。放舍身命。故知以涅槃为经名。义在解脱。因辨解脱。以请经名也。此中有四问。问解脱。问经名。问经力。问流通也

尔时如来复告迦叶(至)文字章句所有功德

案。僧亮曰。文字所表理也。法瑶曰。经之宗致。极于金刚长寿者也。是则说经大体。粗略已讫。是以命迦叶。嘱累此经。令受持也。僧宗曰。以文理胜故。有大功德也。善受持者。不必领受所持。持使不失。但在所弘通。化传不绝者也。即是因经解脱。到彼岸矣

若有善男子善女人(至)所得功德我今当说

案。僧宗曰。经所明理。穷源尽性。即是经之究竟也。人能于受持读诵。自行化人。终成大觉。即是人之究竟也。是故此品。及四相品。并明流通。同答此第四问也。明骏案。答经力有二种。此先举因中得经力也。下以云何未发心等四问广也

迦叶菩萨白佛言世尊(至)菩萨摩诃萨云何奉持

案。僧亮曰。将欲依名以辨德也。法瑶曰。迦叶奉被嘱累。未识经名受持方法。此是说经竟。致问之常宜也。明骏案。前偈中语漫。今别标二问也。乃应举四。盖其一隅耳。二问者。问流通。问经名也

佛告迦叶是经名为(至)汝善谛听我今当说

案。僧亮曰。无经不备此七义。所以略第四独法而益。金刚宝藏者。余经说理未周。不得称满足也。僧宗曰。上中下。盖总束是一事耳。义味深[遽-虍+穴]者。此偏叹理也。其文亦善。此偏叹教也。纯备者。法华经言。纯一也。成实论言。独法也。若依昔教释。纯修者。明佛教不与外道说同。而此经兼明。不杂小乘也。具足者。言佛法经教。不如外道待五种经也。于一偈中。其义具足。如诸恶莫作一偈。即具止行二善。此经一偈亦尔。如雪山罗刹所说。即备常无常二义也。清净者。谓此经理。居万累之表也。梵行者。言此经文理。能生人梵行也。金刚宝藏无缺者。此圆教所明。圆果涅槃。备一切德。不同孤灭解脱。犹如宝器藏也。将辨异昔偏教。是故有此第八叹也。宝亮曰。唯此经独有此八也。上中下语。合为一善。欲明涅槃。于诸法中。最上胜故。名为上语也。十地无漏法。为中语也。说生死苦无常。乃至正因性。为下语也。若说此三语。尽不乖法。则名为善也义味深邃者。第二善。偏就理而谈也。三云其文亦善者。亦偏就理上之文明善也。第四纯备善者。语乘体满足也。昔法华所辨乘果。由是无常。即是果乘不备也。因中既无解常之智。故因乘不满也。唯此经体。明因果足。故言纯备也。第五具足善有。此就因果中。为具足也。与前善无异。正是逐义目为名。故分之为二善也。第六清净善者。此经理教真正。于因果中。俱能忘相。故曰清净也。第七梵行善者。此就学者为语。若能称此理而行。便能生行人净心。故曰梵行也。第八金刚宝藏者。此就涅槃之体。总众德作名也

善男子所言大者名之为常如八大河悉归大海

案。僧亮曰。譬众善所集。众恶尽也。智秀曰。文略也。应云所言大涅槃者名常也

此经如是降伏一切(至)是故名曰大般涅槃

案。僧亮曰。及诸魔性者。谓烦恼及天魔也。放舍身命者。谓阴魔死魔也。法瑶曰。下有八义释所以名为大涅槃也。降伏烦恼。明得解脱。放舍身命。明灭化身得法身。能伏烦恼。能放舍身命。即是般若。不得别说。可谓住此三事。为大涅槃也。僧宗曰。此偏叹理也明骏案。答解脱有两处。此举无累义

善男子又如医师有一秘方(至)是故名为大般涅槃

案。僧亮曰。无疾不治。所以称摄一切方也。常乐善法。一切义备。前但说有三。未尽其理。今明涅槃。无义不苞。岂唯法身般若解脱而已乎。僧宗曰。此偏叹教也。明骏案。答流通法。有两处。出其一也

善男子譬如农夫春月下种(至)能令众生度诸有流

案。僧亮曰。经亦互有长短。学者常悕同异。此经无理不备。故希望永息。法瑶曰。比之众经。可名为大矣

善男子如诸迹中(至)于诸经三昧最为第一

案。法瑶曰。前明二经生智优劣。此言三昧诸定。亦复然也

善男子譬如耕田秋耕为胜此经如是诸经中胜

案。法瑶曰。此明福田生善之义。胜乎众经

善男子如诸药中醍醐第一(至)是大涅槃为最第一

案。僧亮曰。欣常保命者。闻说涅槃生热也。法瑶曰。明此经灭恶。胜乎众典

善男子譬如恬苏八味具足(至)是故名为大般涅槃

案。僧亮曰。证上具足义也。法瑶曰。众经所无。在乎此地。明骏案。犹是答解脱问。此举到彼岸义也。下四相品末。释解脱。以广之也

若诸菩萨摩诃萨安住是中(至)是故名为大般涅槃

案。法瑶曰。此明应感无方。示现自在。大之极也。明骏案。犹是答经力问。此举果地得益也。下以船师等三问。广之

迦叶善男子善女人(至)如来常住法僧亦然

案。法瑶曰。此释奉持义也。后四相品。明修行经教。亦奉持义也。明骏案。答流通之法也。下以四相品。广之

迦叶菩萨复白佛言(至)盲无慧眼无明所[雨/復]

案。智秀曰。迦叶领旨赞叹也

大般涅槃经集解卷第十大般涅槃经集解卷第十一(四相品第七)

  释自正等四义　立断食肉制　释波罗提木叉义　释渐渐制戒义

    四相品第七

案。旧本云如来性品。僧亮曰。如来性者。答第五广上因果及文字也。不可重名。此皆是如来因果之性。以性为名焉。四相者。通答第四第五问。何者。已说长寿金刚因果。及经名字。流通经法。经事究竟。是故答第四也。以名字局故。不合流通。佛性名通。故收入佛性品也。法瑶曰。上品迦叶。业问当何名斯经。云何奉持。今日以自正等四。明奉持之义。是故说此自正义。说云应如是持。即结也。又一义。上品略以八义。释大涅槃。今从此下。竟解脱文。广辨大涅槃义也。自正等四事。广般若义。成大涅槃也。从云何当知是无常耶。竟有密藏。开身口密义。显法身无方之能。此就法身。明大涅槃义也。广明解脱义。成大涅槃。要以此三义。显其体者也。前品所问。云何奉持。已出所持之法。今备此四相。能流通经。即是奉持之义。又一义。经旨既竟。便可流通。然流通之人。非德不传。若教圆理备。经之究竟。人能于经教之中。生圆足之解。自行兼人。终成正觉。即人究竟。是故此品。通答二问也。智秀曰。六卷泥洹云。菩萨化众生。说法有几种。此经云。愿佛开教密。问旨虽殊。而所显之理一也。故六卷云。释解脱竟云。是名菩萨成就四法也。昙纤曰。六卷有菩萨化众生。无愿佛开微密。而此有开微密。而无化众生。互有阙也。若具有为胜也。从此讫善解因缘竟。即答说法。有几种。从坏衣等喻。讫广说解脱答阙微密之问也

佛复告迦叶善男子(至)四者善解因缘义

案。僧亮曰。正他者。使人受结。同我所解也。能随问答者。能令人悟。故难答能答也。备上三事之本。由善解因缘也。真此四德。乃能流通经也。案僧宗曰。将欲授人胜理。先须自正。自既已正。便能道被有缘。故第二明正他。就正他门中。逐其胜用。开为四也。言自正者。一谓行正。如律而行。二谓解正。审解佛常。金刚以还。是无常也。先备此德。必能化他也。宝亮曰。名虽有四。理不过二。谓自正正他也。就正他中。离出后二。所以然者。若使不能随问答者。则外化不行。复不明识根性。则说不应机也。如此则于正他不足。故就正他义中。分出二相也。智秀曰。此品有三段。第一明因中四德。正答所问也。第二明果止四相。第三举昔诸不了教。求佛释会。显成四义。即开诸密

迦叶云何自正若佛如来(至)犹如火聚是名自正

案。僧亮曰。因现事为誓也。僧宗曰。别有因缘。出枯树经。佛将比丘。空旷处行。见有洞然格树。即问比丘。此树可抱不。答言不可。又问。设有逼汝。令说佛是无常。若不说者。抱此枯树。汝宁何耶。世尊宁抱火死。即此语中。具二种义。自正正他也。智秀曰。自观己身者。邪见之生。必由身起。故使观身。犹如火聚也

迦叶云何正他佛说法时(至)如来实说故我欢喜

案。僧亮曰。显正他相也。能令受者。得解悟故。是时女人。即其事也。若不先除念子之乱。则不悟常说。所谓善正人也。僧宗曰。此中明菩萨四相。今乃就佛显者。将明穷四之妙。其唯至人也。如来致教。消息根机。说必有益。即是正他。使弘法大士务遵其术也。又一义。欲论益化。其涂自多。自有法说而得益者。有宜但以神通而益者。此中所明。但取说法也。宝亮曰。就此文中。即亦具有能随问答。善解因缘也。何者。对彼有说。即是正他。往复辨理。即是随问答也。知彼机缘。投得其宜。即是解因缘也。未知此女为当是说涅槃之时始来已。不然既来在坐。先怀一疑。后与一念也。疑者。疑佛是一切智不。次念所含儿苏消不消不。怀此二故。听法不入。佛应其心。借以为喻也。智秀曰。亦是引昔诚教。以显今事也

世尊如是为欲调伏(至)同彼外道即便舍去

案。僧亮曰。为女人说法。以证正他之旨也。僧宗曰。世尊如是者。此佛语也。宝亮曰。亦可是女人语也。何必不宿植根深。一闻便悟耶。智秀曰。审是女人语也。世尊后即引。以为例云。我之弟子。亦如是也

复告女人若儿长大(至)令诸弟子悉皆甘嗜

案。僧亮曰。为不消故。说三行也。若能消者。说六行也。僧宗曰。六味者。有为有三。无为有三也。苦以变乐为用。如醋能变甜也。诸法所以流迁。以无常切故也。犹如碱味。能使非碱作碱也。无我之言。不自在故违情。如苦味之不悦人也。乐以悦已为义。犹如甜味人所嗜也。我者。制御自由。物无能碍。如辛味之通发也。常理湛然。一相无别。如淡味之无分别也。以常解之慧火。然八倒之惑薪。以资慧命。喻之为饭也

复告女人汝若有缘(至)以无上秘密之藏付诸菩萨

案。僧亮曰。上说佛在世正他。此说灭后正他也

善男子若有众生谓佛常住(至)则为有佛是名正他

案。智秀曰。夫善依信立。以信为家。以此善心。念念所缘。唯在常住。是则常住法身。亦常在其信家也

迦叶云何能随问答(至)是则名为能随问答

案。僧亮曰。福胜为大者。不损财之福。胜损财之福也。诚为大施。而此问难答。夫滋味者。庸人之所贪。至于对其事者。必生厚薄之念。而能自抑不受。断贪修戒。长养法身。以财用净故。施主不损己财。功德大也。若不抑而受。生贪破戒。增长生死。财用不净。施主损财。而功德少也。此实难答。而能答也。法瑶曰。夫不见可欲。心不乱者。则易见则难也。今施以可欲。而心无深者。是则因施欲故。无欲之怀日新。知足之心更远。岂非难施所欲。乃所以施法也。是为一毫之费。而法施之益弘矣。施名流布。义在于兹也。僧宗曰。前明自正正他。理无不尽。正以外化事中。乖于常虑。人所不达。应须知耳。夫施财为易。施人名闻为难。今就施名闻为释也。何者。诸人持戒。少欲知足。而此施主本意。为显此人令德。不在舍财。是以于绸人广众之中。施所不受。彼既不受。以众人而望之。是则不受者。少欲知足之誉显也。施者。能舍大施之名彰也。智秀曰。此下明义有五翻。第一正解随问答相。第二因事请佛立断肉之制。第三引昔诚教为难。第四举未来之非。成今断肉之制。第五咨请净法也

尔时迦叶菩萨白佛言世尊食肉之人不应施肉

案。道生曰。施尚不可。况亲食乎。苟纵不禁。于长寿何因耶。僧亮曰。不食肉者。有大慈之德也。僧宗曰。因向所论。义势至此。贵明义耳。宝亮曰。所以于今日。顿明断肉制者。昔时众生。习腥秽来久。不得顿制。至今经教。人心纯熟。识理分明。觉此腥秽。自然薄贱。是以今时断肉。其事必行也。因上所言。故云。食肉者尚不应施。况不食者。而当施耶。已不食肉者。有大功德故也。智秀曰。意欲请制。是故因循引前答旨。辄言所见。谓以肉施人非所宜也。智秀曰。释所以不应施也。若不食者。有大功德。岂可不制不应施耶

何以故我见不食肉者(至)护法菩萨应当如是

案。僧亮曰。今说长寿。慈是寿因。害慈宜断。以说得其时故。善知我意也

善男子从今日始不听声闻弟子食肉

明骏案。上说常住之因。谓以大悲。受不杀戒。而今犹复肉食。便是自有伤慈之行。而欲戒人以不杀。无乃愧心乎。戒为众德之本。慈为万行之根。苟伐本害根。枝条安在耶。智秀曰。断肉之制。始此旨也。不听之义。何独声闻。以此而推。菩萨本来。不食肉也

若受檀越信施之时应观是食如子肉想

案。智秀曰。余食尚尔。况复肉乎。子肉想者。别有因缘。在余经也

迦叶菩萨白佛言世尊云何如来不听食肉

案。智秀曰。请闻食肉之为患也

善男子夫食肉者断大慈种

案。道生曰。慈味之浓。莫深肉食。肉食苟浓。必忘慈恻。慈恻之大。谓之种也。种既断。长寿理绝也。僧宗曰。夫杀伤大慈。而啖伤小慈。因小得大。故小慈是大慈种也。又释云。果为大慈。因为小慈。是则因慈。为果慈种也。今既啖肉。违因地之慈。故言断慈种也。惠诞曰。食肉障生厚集善根之小慈也。何有能生种性以上之大慈耶

迦叶又言如来何故(至)当知即是现断肉义

案。僧亮曰。若慈是寿本。食肉害慈者。先听食也。三种净者。谓除见闻疑也。十种不净者。后有成数也。九种者。不见有三。谓未食时喜。食时食已亦喜也。不闻不疑各有三如是也。僧宗曰。三种十种九种。并牵昔制也。三种谓见闻疑也。十种者。下有成文。九种受者。昔日一往唱言。离见闻疑听食。当时虽制。而损命犹多。故第二种制除十之外。离见闻疑。听食也。虽尔而伤损尚多。故第三稍令精尽。向者三事。各有前后方便。一事有三。合成九也。见中三者。谓见断命时。见牵去时。见杀后屠割时。闻中三者。闻杀时。闻牵去时。闻屠割时。疑三者。亦不离见闻也。疑此为是为我杀耶。为他杀耶。乃至前后方便亦疑也。又释疑者。如向在彼家。今于此家得内。情中生疑。为是向肉。为非向肉。亦不得啖。如前后方便生疑。悉不得啖。闻中生疑。类如前也。但见闻事异。各分为三。则成六也。二家之疑。不复分别。同是一疑耳。今常教既兴。一切悉断。此则去滞有渐。不可顿也。又一义。常果要行。事在施命。宜顿断明矣

迦叶菩萨复白佛言(至)何况贪着是鱼肉味

案。僧亮曰。人情而言。滋味甚重。饰好甚轻。轻者尚制。况其重乎

迦叶复言如来若制(至)如是等物亦不应受

案。僧亮曰。若为染着上诸物等。亦不应受。法瑶曰。若为大慈福故。不食肉者。乳酪等味。及以皮革。亦不应受。若以所服之衣。必是坏色。表无贪者。金银等宝。不应受也

善男子不应同彼尼揵所见(至)一切禁戒各有异意

案。法瑶曰。无欲者。贵在损情。岂得同彼异见。以裸形为行道。以绝事为断欲乎

异意故听食三种净肉(至)一切悉断及自死者

案。道生曰。病有二种。谓从意从想。惬情而之。谓之从意。所贪无崖。谓之从想。是以小制损其意也。都制损其想也。僧亮曰。除其贪意。长其慈也。法瑶曰。夫易得者。遇见而生意。难得者。恒想而欲之。是以听食三种净肉。三不净意。自亦消矣。而三种净者。以难得故。想而欲之。次断十种之中。三种净者。复不得食。于十想断矣。唯想十种之外。三种净者。逾难得故。而想之逾染也。今悉断故。一切众想。无复生处。故一切想断矣。宝亮曰。若使于资身之具。损害处甚者。佛便断之。若于事用小复疏者。佛便且开也。众生有虚伪果报。要须所资。若一向顿断。则为形不立也。智秀曰。异想异意。互辞耳。言异彼恶意也

迦叶我从今日制诸弟子不得复食一切肉也

案。智秀曰。结制之也

迦叶其食肉者若行若住(至)闻其肉气悉生恐怖

案。智秀曰。以事见理也

譬如有人近师子已(至)犹不欲视况当近之

案。智秀曰。为食者作譬也

诸食肉者亦复如是(至)悉皆恐怖生畏死想

案。智秀曰。人无害兽之心。兽亦不害于人。是以探鲠虎于山中。狎翔鸥于海上。若既食其肉矣。岂害心而永灭哉。所闻其杀气。生畏死想也

水陆空行有命之类悉舍之走咸言此人是我等怨

案。智秀曰。苟仁恻之未全。良可避矣

是故菩萨不习食肉(至)犹尚不食况当食肉

案。智秀曰。引大士之行。叹不食肉。实可贵也

善男子我涅槃后无量百岁(至)当说是人真我弟子

案。智秀举末法恶事。若有出家。能离此者。是真我弟子也

尔时迦叶复白佛言(至)悉不应食食者得罪

案。智秀曰。为请得食之法也

我今唱是断肉之制(至)是则名为能随问答

案。智秀曰。结上也

迦叶云何善解因缘义(至)云何名波罗提木叉义

案。僧亮曰。戒者时至则制。不至不制。谓善解因缘也。云何名堕。乃至波罗提木叉者。堕是犯罪之称。律是轻重之目。木叉是戒之义名。亦名知足。亦名解脱也。何不说是法门者。若持则得解脱众苦。犯则堕于恶趣。应早制戒。令知轻重也。僧宗曰。夫欲正他。应须善解。若不达根性。反生其累。非谓利物。上于正他文中。亦云消息物情。堪闻便说。与此无异也。总而为语。真非正他。就正他中。前略举一事。因对女人。寄明正他相也。何不先为波斯匿王。说是法门者。国主本知王法。而黑白虽异。除患是同。是以佛听略知戒相。彼国盗至五钱。罪则入死。出家之人。犯者罪应灭摈。至于论罪。每与国主参怀。今问何不顿说经律甚深理耶。此中虽有五句。大意不过二也。初问何不顿制。第二问戒律之相。或时说深者。昔教亦有深浅。如十善五戒是浅。四谛十二缘是深也。若以今教望昔。通为深也。佛初出世。不顿说者。应有因缘也。或名犯不犯者。昔总制云诸恶莫作。既无结罪之文。不说为犯也。及因事别制。则说为犯。云何名堕者。此三通问违不违相。违则名堕。不违为律。云何名木叉者。偏问戒体。此中再明木叉者。前直明戒体也。以其与律相涉。恐人致惑。故复简之。取离身口意之不善。即为戒体。律以取防外之威仪及制篇目。欲简两异。故再出耳。宝亮曰。五问者。第一难。云何不顿说经教。而有深浅说耶。第二难。何不先顿制戒。须犯后方制耶。第三问堕。所言异昔第三篇也。乃总说五篇七聚。皆是堕家果报也。第四问律。律本诠量轻重。即是向辨堕家事也。第五问波罗提木叉者。问无作戒也。智秀曰。有四问。第一问何不顿说经律。后三问不异前释。慧朗曰。律者言类也

佛言波罗提木叉者(至)无所受畜亦名净命

案。僧宗曰。若谈戒体。即是无作。若论其义。则称事究竟也。云知足者。非正释木叉名义。乃就功用心中。以明戒耳。声闻之法。以少欲为业。若尊少欲。则所受无作。日夕增长。举少欲以明戒也。宝亮曰。无作本是顽法。非是解性。岂能止恶。而今得止名者。有三义。一者从因立称。二者缘中得名。三者因中说果也。从因得名者。因止恶之心发也。此法既从止恶生故。故说无作。为止恶也。从缘中受名者。即既受得此戒。防之在心。不为众恶。故言缘中得名者也。因中说果者。因持此戒。心便得静。静故见理。得成无漏。能断相累。名为解脱圣人。故曰无作止恶

堕者名四恶趣(至)以是诸义故名曰堕

案。僧宗曰。三处说堕。前二是受罪之处。后一说其必堕也。僧宗曰。此中三重明堕。初通轻重。次偏明重。后就因明堕也

波罗提木叉者离身口意不善邪业

案。僧亮曰。再说戒者。前说人说。后就戒以辨体也

律者入戒威仪深经善义(至)及不净因缘

案。僧亮曰。入者从也。科罪轻重。障道深浅也。深经善义。及不净因缘者。体既非净。能作不净。如非时食等。皆应遮也。僧宗曰。此释律字也。五部律文。为戒经所明。隐细为深。不乘制旨。身口如法。故言入也。与恶相违。故言善义。遮受不净。百不净物也

亦遮四重十三僧残(至)众多学法七灭诤等

案。僧宗曰。明悉禀承律之旨也

或复有人破一切戒(至)乃至七灭诤法

案。僧亮曰。戒有二种。一者受戒。二者制戒。佛初成道。善来比丘。便受得戒。未有制戒。不知犯故。轻重科目。一切尽破也。僧宗曰。此答前犯不犯句也。言总制之前。冥起诸恶。若使顿制。物情不堪。是以如来。初制诸恶莫作。折其重恶。然后因事制戒也。智秀曰。此下答初问。明所以不顿制者。由闻者不信。必毁谤故也。尔时有善男子以下。因释不得顿制之意。乃更兴一难也

或复有人诽谤正法(至)渐次而制不得一时

案。僧亮曰。尽一切相者。一切恶相也。[雨/復]藏者。不向智者自发也。即情而言。既不知犯。岂知发露。就事而言。为[雨/復]藏耳。不悔亦尔。渐次而制者。说七篇轻重相也。僧宗曰。此答初问也。言人根浅狭。未堪深教。若顿说者。踰增其病。乃至阐提也。尽一切相者。断善根之相也。无有因缘者。无可救因缘也。亦可即是计一切无有因缘也。遂复兹漫者。深谤冥障故也

尔时有善男子善女人(至)是故启请应先制戒

案。僧亮曰。至他方者。于生死而求出。为他也。非法破戒。为迷失也。不见有人可问是非者。不知犯不犯也。十善增上功德者。有五品也。下十善是天人也。中者是声闻。上是缘觉。上中者是菩萨。上上是者佛。证佛知道也。宝亮曰。不得顿制之旨。尚未可明。今更作一问也。答如来亦知是事。如须提那明日应犯。何不今日逆制。有制之法。其自不犯。既必不犯。则不堕恶道也。故言应先制也

佛言善男子若言如来(至)欲令众生入于地狱

案。智秀曰。先举其上难。且一往遮云。不得作此难也

我见一人有堕阿鼻地狱(至)如子想者令入地狱

案。智秀曰。次显佛大悲。有矜救之德

善男子如王国内有纳衣者(至)即以戒善而为补之

案。僧亮曰。衣以障漏。如戒之覆恶也。五重之纳。四重虽穿。漏未出故。不得逆补。漏出则补也。是以舍利弗。请佛制戒。佛言漏未出。故不得制也。后有比丘。逼夜乞食。人谓是鬼。惊怖堕胎。致世讥嫌。以漏法出。故佛乃制戒也。智秀曰。次设两譬。正答难也。前譬直明须恶兴故。然后善补也

善男子譬如转轮圣王(至)然后自行圣王之法

案。智秀曰。此第二譬。显佛所以总制后别制之意也

善男子我亦如是(至)大涅槃中因缘义也

案。智秀曰。双合二譬

复次自正者所谓得是(至)即大涅槃等无有异

案。僧宗曰。此偏据果。将明因时行化。备于四德。终到彼岸。是人究竟既得到果。复以化人。故知四德既备。流通之言。在乎不谬。是故举果信而有征。将便仰慕前规。企而习之

卷第十一大般涅槃经集解卷第十二

  释有余无余涅槃义　开身密不可思议事

    四相品之第二

佛告迦叶若有善男子善女人作如是言如来无常

案。僧亮曰。此下始答第五问也。开昔口密。略为五难。第四第五。举无余涅槃也。第一二三。举有余也。法瑶曰。上来所明。常住已显。今从此下。竟如来无有密藏。开昔无常密教。及身密也。愿佛开微密。即此句也。僧宗曰。答开微问也。上虽明般若法身。异昔涅槃。未洗昔教。今明孤灭。是摧非实。开昔微密之教。即是开言方便。下诸觉花。明王宫非实生。双树非实灭也。宝亮曰。即是广文之始也。开微密之端。明果用也。显法身般若解脱。今先广口密。以明智慧也

云何当知是无常耶(至)为常住法不变易耶

案。法瑶曰。引昔所说。烦恼尽处。有余涅槃也。灭尽无为。竟有何法。可称常耶。僧宗曰。此中诸难。而解者不同。亦四亦五。并无所在。俱是执有余无余。但使灭无之义耳。然难意唯齐言生解。不能深取佛意也。宝亮曰。此下作四难也。第一第三。引有余为难。此第一难也。昔日指烦恼无处为涅槃。直是无物而已。若尔有何常住耶

如佛言曰离诸有者(至)为常住法不变易耶

案。法瑶曰。据昔佛身尽无余涅槃。若身智并灭。谁常住耶。明骏案。若作五难者。开此坏衣譬。为第三难也

如佛言曰离欲寂灭(至)为常住法不变易耶

案。法瑶曰。此复是结尽。有余涅槃也。爱尽无欲也。前诸烦恼。尽是断结也

如佛言曰譬如热铁(至)为常住法不变易耶

案。法瑶曰。此复是身尽。无余涅槃也。但引佛昔譬。辞异而旨同也。明骏案。就此举有余无余涅槃为难。凡有五翻。第一佛自引昔教。以为今难。第二迦叶更构两难。第三佛答。第四结上旨。第五迦叶领解也。就第一翻中。有四阶。第一引昔教。第二诫迦叶。第三释会昔旨。第四举法常为证。此第一阶引昔教

迦叶若有人作如是难者(至)谓如来性是灭尽也

明骏案。第二阶。一往先非异人所执。而诫迦叶也

迦叶灭烦恼者不名为物(至)是句寂静为无有上

案。僧亮曰。此答第一第三第四有余句也。释有余烦恼起作不静。灭之为静。有余灭因也。法瑶曰。答第一第三有余旨也。此两句。结尽无为寂静。尚得常住。何况法身不常住耶。僧宗曰。答有余三复次也。言不名物者。谓非有为中物也。于时[雨/復]相说。故言烦恼尽。意在非生死中物。而汝谬取佛意。谓为都尽。然法身常存。岂有灭耶。此中何以故。释向云不名为物也。言永毕竟者。无惑而不尽。所以治道之功息也。是句寂静者。向已释有而是常。今还举上灭烦恼之句。即是真寂静也。明骏案。此下第三释会昔旨也

灭尽诸相无有遗余(至)如来亦尔常住无变

案。僧亮曰。有为相也。释第二第五复次也。是句鲜白者。有为是垢灭。故为鲜。得是无余灭尽果也。法瑶曰。答第二身尽无余句也。身尽无为。犹得是常。况如来法身。常存不灭者乎。僧宗曰。无余者。生死尽也。岂得承昔离有之言。便谓尽灭耶。但昔为众生。厌苦情深。示有灭苦之迹耳。又一义。众生有计我之病。不得说真我。言隐理显。妙常岂灭。是句鲜白者。既绝诸有。所以鲜白也。三乘之人。犹有无常所住之地。不得称为鲜白之美。唯佛法身。真正无染。故鲜白也

言星流者谓烦恼也(至)是常住法无有变易

案。法瑶曰。答第四无余句也。僧宗曰。答难已毕。更为释譬也

复次迦叶诸佛所师(至)以法常故诸佛亦常

案。僧亮曰。灭是断苦之术。故名师也。上说涅槃常故佛常。未明涅槃所以而常。重明之也。僧宗曰。上已佛教。今就理释。以常师圆极。此理湛然。隐显为异。及人会时。非为始起。人既秉法。法既是常。人岂无常耶。明骏案。第四阶。举所师之法为证也

迦叶菩萨复白佛言(至)亦复如是灭无所至

案。僧亮曰。迦叶取譬意。异乘前譬为难也。法瑶曰。复难有余二句也。佛向答云。明结尽无为是常。如常亦常。复以如来与烦恼俱灭。然后是常。故有此难也。僧宗曰。人情未解。还执铁譬。前句所举。迸铁热与赤色。既灭之后。不知所在。果如所譬。如来应无也。如来人也。烦恼法也。人法两无。俱同铁譬。不应复有也。宝亮曰。人情于答第四难中。疑心未已。今更转譬作难。若如佛言已离烦恼。如彼迸铁灭已无有。法身应常者。我谓。应如砧上之铁。不免无常。彼铁出火则黑。入火则赤。佛亦如是。烦恼灭已。应还生也。智秀曰。蹑前答中云。不在五趣。乘声为难。若不在五趣。则不应有常身。若有常身。则应有处而现见烦恼。如彼迸铁赤色。灭已莫知所至。烦恼灭已。与此譬同也。明骏案。此下第二翻。迦叶更作两难也

又如彼铁热与赤色(至)当知如来即是无常

案。法瑶曰。复难无余二句。义亦同上也。以热譬烦恼。赤色譬佛。谓烦恼灭已。佛亦应灭也。以入无余涅槃故也。僧宗曰。此第二难也。取砧上之铁热与赤色为譬。谓虽当时无耳。本质既在。入火便生也。智秀曰。犹成前难耳。此防佛意。恐佛言赤色。乃可不知所在。而其热犹在。是以复言热与赤色。灭已无有也。明骏案。难意谓。若有常者。应有住处。今烦恼灭已。如来亦灭。二俱无处。莫知所在。常义安寄。第二又如彼铁。更成前难也。以赤色譬烦恼。以热譬身。是则如来。入无余涅槃。烦恼及身。二俱尽矣。云何而言有常可住耶

善男子所言铁者名诸凡夫(至)灭已不生是故名常

案。僧亮曰。我以热及赤色。同譬烦恼也。赤色灭已。铁则不现。烦恼灭已。如来不在五趣中矣。此少分譬耳。若遍譬者。铁则两譬。还赤则譬凡夫。不赤以譬佛也。僧宗曰。前有两难。此先答后难也。汝不得全引铁譬也。鉆上之铁。可譬凡夫。以凡夫伏结。虽至非想。后还复起。佛则不尔。永不复起也。宝亮曰。释与此同。智秀曰。并破二譬。明凡夫。如是或灭复起。故无常身也。明骏案。迦叶向难。意在常处。就佛此答。未正塞其难也。且先结譬。持与凡夫。凡夫虽灭。非究竟灭。灭非究竟。可更还生。如来不尔。故不无常也

迦叶复言如铁色灭已(至)若结还生即是无常

案。僧亮曰。上说凡圣灭异。未释所以。重此难也。宝亮智秀。悉同此释

佛言迦叶汝今不应(至)名曰坏衣斩首破瓶

案。僧亮曰。有灰者。灰虽是有。不还为木。佛是妙有。不还无常也。便有涅槃者。涅槃者。如来结灭。凡夫结灭。灭名虽同。其实大异。凡夫虽灭。而还是有为。与结同相。故无异名。如来灭已。不复还生。灭是无为。更有异名。名涅槃也。僧宗曰。此答初难。前引迸铁。使惑尽人灭。今引燃木。灭已有灰。谓惑尽智存也。智秀曰。木灭有灰。虽非复木。而不无也。烦恼灭已。虽不在五趣。而有常身也。明骏案。以灰譬涅槃。木灭有灰。烦恼灭已。则有涅槃。涅槃虽复不可捉持。无有方所。而可寄言。离凡夫地。得无动处也。可寄言故。故智有常。非灭法故。故非无常也

迦叶如铁冷已可使还热(至)烦恼炽火更不复生

案。僧宗曰。上说结灭是常。未释所以常也。无漏见灭。性灭常故。结不复起。有漏缘有。有非常故。灭而更生。此无漏有漏之大判也。僧宗曰。答向子句难也

迦叶当知无量众生(至)烧彼众生诸烦恼结

明骏案。结上旨也

迦叶复言善哉善哉(至)游诸觉华欢娱受乐

明骏案。始领解也

迦叶复问如佛言曰(至)唯愿如来说其因缘

案。法瑶曰。启发如来身密之端也僧宗曰。秘密之言。虽复已拂。然于一化托生始末。未能不惑。故指事广拂。以开权迹也。有两别。初总就菩萨。第二就释迦迹也

佛告迦叶汝不应言(至)复还安止本所住处

案。僧亮曰。菩萨住涅槃者。以少见佛性。故名为住。以下况上也

善男子复有菩萨摩诃萨(至)复还安止本所住处

明骏案。向指一须弥。今举百亿须弥也。如首楞严中广说

善男子复有菩萨摩诃萨(至)乃至本处亦复如是

明骏案。一毛孔之细。复妙一芥子也

善男子复有菩萨摩诃萨(至)乃至本处亦复如是

明骏案。向举一界三千。今指十方世界也

善男子复有菩萨摩诃萨(至)乃至本处亦复如是

明骏案。向掷一佛世界。今掷微尘世界也

善男子复有菩萨摩诃萨(至)乃至本处亦复如是

明骏案。向云他方。则广远为易。今云已身。以近小为难也

善男子复有菩萨摩诃萨(至)乃至本处亦复如是

明骏案。更以已身为易。以一尘为难也

善男子是菩萨摩诃萨(至)习近爱欲生罗睺罗

明骏案。结菩萨之不思议。以况佛也

善男子我已久住是大涅槃种种示现神通变化

案。僧宗曰。此下显佛不思议。拂法身也

于此三千大千世界(至)如首楞严经中广说

明骏案。总举一化之境有微密之事也

我于三千大千世界(至)亦不毕竟取于涅槃

明骏案。明虽灭而不灭也

或阎浮提示入母胎(至)随顺世间示现入胎

明骏案。显虽生而不生也

善男子此阎浮提林微尼园(至)毁禁戒者示作霜雹

案。僧亮曰。天竺以东为首。以西为后。以北为左。以南为右。东行示始。始有二种。一示婴儿。二明导首。以示自在也。右于事便也。西是后故。示最后身也。北示胜也。四天下中。郁单越胜也。此方春东夏南。秋西冬北。万物春生夏长。秋实冬藏。众功毕也。上福田者。长养功胜。表佛田胜也。七步者。天竺象王生时。出胎即行七步。知是象王。菩萨始生。示自在王相也。唱如是言者。上以身示。此以言说。明是三界自在法王也

于阎浮提生七日已(至)即是诸佛如来法界

明骏案。上来至此。拂一化之始终也

我又示现阎浮提中(至)是故名为常住无变

案。僧亮曰。广明异应迹也。非是见王宫出家之次第也。明骏案。上来至此。但举一天下事

如阎浮提东弗于逮(至)神通变化而无所畏

明骏案。还举大千界事也

迦叶以是缘故汝不应言(至)名曰常住无有变易

明骏案。结旨也

迦叶复言如来云何(至)既灭度已亦无方所

案。僧亮曰。前佛自引口密五事。今迦叶复引昔之密旨。令佛开也

佛言迦叶善男子汝今不应(至)如来体之故名为常

案。僧亮曰。油譬取。明譬烦恼也。而器无常。非如来者。器义相似。少分譬也。如来体之故名为常者。昔但说结灭是常。不说体之者常。是有余也。法瑶曰。上引无余四句。亦是口密。但未正表昔教。是覆相说。今正明也

复次善男子言灯灭者(至)非大涅槃同于灯灭

案。僧亮曰。分段烦恼。因果俱尽。譬如灯灭。犹余身智。非大涅槃。是小涅槃已。不得说言同此灯灭者。分段烦恼未尽。不同灯灭也。覆相说法。谓佛一切结尽。身智亦是涅槃。即大涅槃也。昔总相说。故不辨小大之异名为[雨/復]也

阿那含者非数数来(至)无去来者名阿那含

案。僧亮曰。数数来者。生上退下名来。在色界中。又有一来。而非数数。何者。后云上流阿那含也。流有二种。谓烦恼流道流。烦恼流故生四禅。退生初禅。道流故断初禅结。生四禅也。又不还来二十五有者。阿那含名不还。具缚凡夫。具二十五有。唯欲界备具。不还欲界名不还。不受二身故也

大般涅槃经集解卷第十二大般涅槃经集解卷第十三

  释意密显无常迹义　释教密显解脱义广前名字功德品也

    四相品之第三

尔时迦叶菩萨白佛言(至)唯有密语无有密藏

案。僧亮曰。二密[雨/復]常。前已开发。今释上偈云开微密。不言藏者。以佛无藏故也。自下诸譬。明无短故。所以不藏也。法瑶曰。上来广说身口密义。似若如来必有藏积秘吝之怀。是以迦叶。明佛乃有密语。无有密藏。如来成其所说也。僧宗曰。时众于上。粗已领解。将欲更彰身智。在万累之表。申述昔教未说之意。是以迦叶。命言领解。但昔日[雨/復]相事多。事须广拂。下文对佛捉昔偏教。次第开洗。所谓开微密也。唯有密语者。迦叶探取佛意。言唯有密语。无密藏也。何者。以昔常机未至。不得说常。而无常之教。乃意在于常。岂有秘密耶。宝亮曰。此下将广解脱故。先显圣意。唯有密语无有密藏者。即广意密也。道慧记曰。前开身口密。此开意密也。智秀曰。此下重开口密

譬如幻主机关木人(至)诸佛世尊有秘密藏

案。僧亮曰。幻者术浅。不欲人知。如来不浅。常欲人知。岂名为藏。慧诞曰。幻者所作。但令人见。不令人得。佛则不尔。常愿众生同我所得。岂名为藏耶

佛赞迦叶善哉善哉(至)智者了达则不名藏

案。僧亮曰。此下诸譬。佛成迦叶所说也。秋月虽明。有目乃见。于无目者。名为藏也。佛法亦尔。于智者为显。愚者为[雨/復]也。宝亮曰。佛广说十譬。前八譬。一向明无秘藏。第九譬。释教明所以不先说深法者。为众生故也。第十譬。明众生若不在此五时教中学者。非佛于彼有情故也。此第一譬也

善男子譬如有人积金银(至)是故不得名为秘藏

案。僧亮曰。并是明佛无秘藏义

善男子譬如长者虽有一子(至)昼夜殷勤教其半字

案。僧亮曰。初说小后说大。似如有隐。故以譬申之。众生具缚。应闻具教。理数相感。诣师之义也。心小而闻满字教者。必不能受。譬不速成也。乃说一切诸法无常牵令入。或如将还也。三乘偏教。喻以半字也

而不教诲毗伽罗论何以故以其幼稚力未堪故

案。僧亮曰。大乘六行。满字之譬

善男子假使长者教半字已(至)云何当言如来秘藏

案。智秀曰。明以无大机。致感小教。岂是秘吝[雨/復]藏。而不说耶

佛言善哉善哉善男子(至)所谓如来常存不变

案。智秀曰。合譬结旨也

复次善男子譬如夏月(至)然佛如来实无所藏

案。宝亮曰。若不于佛五时教中学者。岂是佛咎

迦叶复言我定知如来世尊(至)常存无变是义云何

案。僧亮曰。证上半字也。僧宗曰。领解自申所怀也。但昔言未洗。人疑不除。今广引昔偈。令释取以施权之旨也

佛言善男子我为一切声闻(至)云何是人舌不堕落

案。僧宗曰。广出说偈之缘起。以显随时设教之不同也

迦叶复言如佛所说(至)而此去者为至何方

案。僧亮曰。证无藏也。亦欲以下。况上明二乘尚无。况如来也。僧宗曰。前偈证有余涅槃。此偈证无余涅槃也。虽复合牵一偈。意在下半偈耳。迹不可寻者。身智俱亡也。此亦昔言。故应拂也。下释云。近于菩提。菩提涅槃。无有方所。事绝近情。谓难寻也。偈旨如此。谁能解耶

佛言迦叶夫积聚者(至)不贪食者是名知足

案。僧亮曰。明有为有资。尚无藏积。况乃无为不须者耶。宝亮曰。积聚二种。一有为二无为者。谓道积众行。非是世间之财宝也。声闻捉想。心中行道。不得其所。故言有为也。又协相修善。去佛果辽远。终日生死之谓也。无为如来行者。若能谨依六行。修道进德。不取有无之相。故名无为。又若忘相行道。取佛果速。因中说果。亦言无为也

迹难寻者则近无上(至)于大涅槃而般涅槃

案。僧宗曰。去无至者。虽有出苦之名。及其造极。此处无迹。故无至也。是故于此婆罗树间者。谓法身之迹。妙绝难寻。寄大解脱。而示灭也

佛告迦叶所言大者(至)若一人具八则为最胜

案。僧亮曰。答彼问下句云广为众生说也。常旨已宣。今所广者。广大义也。僧宗曰。名字功德品中。非不一往举释大体。而未释大义。是以此中。引八大人觉。取舍容为义也。智秀曰。上云是大涅槃。能建大义。未释所以。今明有大德故。建大义也。明骏案。正广解脱也。上名字功德品。已略明解脱。亦粗释今日所以称大也。极果万德。略举其三。以成秘密之藏。而以解脱一德。用当经题者。涅槃是无累总名。以多义训。取解脱。是其一也。是故问曰。云何于此经。即请经名经力及流通也。究竟到彼岸。即是问解脱也。所以前品答云。降伏一切诸结烦恼。及诸魔性。于大涅槃。放舍身命。已是略显解脱也。阙一问说法有几种。上四相已广前品流通法也。从有余无余涅槃已来。至此具广三德也。后四依品以下。广显流通人也

所言涅槃者无诸疮疣(至)是故名曰大般涅槃

案。僧亮曰。疮譬苦也。以无苦故。名为涅槃。若但自治。不名大灭。灭一切苦。乃名大灭也。悉治已者。谓有信也。虽未即差。已为差因也。僧宗曰。上释大义。此释涅槃义也。疮疣是累。既无疮疣。即是解脱。此中先明能治众生。引医师为喻。下去出体。广明解脱也

大般涅槃者名解脱处(至)甚深义故名大涅槃

案。僧亮曰。金刚后心。烦恼尽处。得涅槃也

迦叶菩萨复白佛言(至)是故涅槃名无疮疣

案。宝亮曰。若依如下文。涅槃能为一切众生。作解脱因缘处也。阎浮提众生。有二种。一者有信。二者无信。释有信者。有二种释。一谓。从佛出世。有随教修行。得信首根立者。悉名治已。自未立已还。有信未定。不免阐提。故束为无信人也。二者值佛。能生一念善已上。乃至信首根立。悉名治已。若不能生一念善者。并为无信也

世尊何等名涅槃善男子夫涅槃者名为解脱

案。僧亮曰。将欲明色之与智。为解脱故。致发斯问。涅槃名解脱者。昔说涅槃。是三事中。解脱今正其名也。敬遗记僧宗曰。圆德妙体。居万累之表。故称解脱也。涅槃是彼国语。就彼释义。应有别辞。此间解脱。即是翻彼释义之名也。昔曰孤灭解脱。所以称涅槃者。以身智为累。故以灭累。为解脱也。智秀曰。此下三翻。第一出体。第二佛以譬显其旨也。第三显譬与所譬同异也。以昔辨解脱。身智俱无。而滥该佛果。是以此第一翻。辨正解脱之名也

迦叶复言所言解脱(至)非诸声闻缘觉所知

案。僧亮曰。或有是色。或非是色者。以无累为解脱。身智无累。亦是解脱。先定之也。二乘解脱者。分段烦恼灭。称为解脱。而身智有为。非解脱也。如来身智无为。得名解脱也。云何住者。谓相假名义得立住。若其无色解脱之名。依何而住。非色者。声闻身智。亦无粗结。直以少故。说为非色耳。僧宗曰。将明无累。先正其体。体苟不无。则孤灭权显。论其枢要。在于色耳。今言声闻非色者。不能垂形六道也。为众生故。说非色者。昔教但言舍身尽灭。不说三事。既无三事。则无法身垂应之色。故言非色也。云何住者。假执昔教。无色为难。欲令佛释二乘之人。非都无色。是故佛以非想为喻。实有细色。说为非色二乘。涅槃亦尔。小应色直是于时不得说也

尔时迦叶菩萨复白佛言(至)大般涅槃行解脱之义

案。僧亮曰。众生所好不同。广赞解脱。明无苦不尽。无乐不备。称情合愿。汲引多矣。僧宗曰。欲使无累之德。显于未闻。故复重谓。即是广为众生说也

佛赞迦叶善哉善哉(至)是故如来不名命终

案。僧亮曰。生老病死。众苦之本。故先明也。再说死者。前明老死。后明病死也。明骏案。此下广名字功德品中。八味具足也。前文唯言五者不老。六者不死。略不云生之与病。此中具述四患也

如来清净无有垢秽(至)生贪夺想解脱不尔

明骏案。广第四清凉也。疮疣斗诤。皆不清凉。因事而广触类长之余效此也

又解脱者名曰安静(至)真解脱者即是如来

明骏案。广三者安也。夫不安者。则求等侣。无上安隐。无忧无喜。不须等侣也

又解脱者无有尘垢(至)真解脱者即是如来

明骏案。广八者快乐也。苦以逼切为义。今明无逼。以显快乐也

又解脱者名无动法(至)真解脱者即是如来

明骏案。广一者常也。无常则流动不停也。今以广大如海为譬。前品以常释大。今此以大释常。反[雨/復]为义。乃至无上上。亦如是也

又解脱者名曰恒法(至)真解脱者即是如来

明骏案。广二者恒也。常以不迁无动嶷然为义。恒以豆然不改为义。亦左右之辞耳。所以未举虚空无际无迹。盖言终曰恒然者也

大般涅槃经集解卷第十三大般涅槃经集解卷第十四

  杂广解脱义　释一等四执义

    四相品之第四

又解脱者名曰甚深(至)真解脱者即是如来

明骏案。前已广上八味竟也。此下更举别义。是二乘所不能入者也。此总叹甚深不可见也

又解脱者名无舍宅(至)真解脱者即是如来

明骏案。杂举众德。随所乐入而解释也

又解脱者名断一切(至)无漏善法断塞诸道

案。僧宗曰。断邪见诸道也

所谓若我无我非我非无我

案。僧宗曰。我者常见。无我者断见也。非我非无我者。此第四家计也。阙第三家。第三家云。亦我则不同第一家。亦非我复不同第二家。所言不同者。谓不全同。乃片同耳。今第四家。复异第三家也。言非我者。不同第三家斥我也。言非无我者。不同第三家斥无我也。虽有此言。及其捡核。亦不得异第三家之也

唯断取着不断我见(至)真解脱者即是如来

案。僧宗曰。生死非我横生我心。此是取着应断也。佛性是理。不断此也

又解脱者名不空空

案。僧亮曰。常乐我净是一实。又解脱众苦是二实。故名不空空

空空者名无所有(至)实无解脱故名空空

案。僧亮曰。尼揵所计解脱。无常乐我净一空。又非解脱二空也。名无所有者。体是无常。又非解脱。无所有者也

真解脱者则不如是(至)而复无有水酒等实

案。僧宗曰。水酒瓶者。为不空空譬也。乃可无水而器不空。明涅槃乃空无生死耳。而常果不空也

解脱亦尔不可说色(至)谁受是常乐我净者

案。僧宗曰。垂形六道处。处见色也

以是义故不可说空及以不空(至)如来即是涅槃

案。僧亮曰。本未释之。贪是结本。相名贪境也。贪与所贪。系缚三有。一切烦恼。由之而起。故生死之数。因果无穷。永断贪故。次第而灭。一切解脱

一切众生怖畏生死(至)阿耨多罗三藐三菩提

案。僧亮曰。上广说解脱。令人归也。法相有三。何者。法相常定。贵其先觉。先觉者归佛也。所觉者。妙归法也。非法不得名觉也。小觉诸法非我。假用境智合用。生死可除。识其合用归僧也。归说行始。此明其终。终得尽苦。名解脱也

迦叶菩萨白佛言世尊(至)非是声闻缘觉所知

案。僧亮曰。涅槃一法具二也。二言俱在当也。佛法僧常者。常即涅槃。常名是一。而三事即涅槃。僧宗曰。如三归之异者。当知涅槃。似不一体。欲令如来释会三归。所以体一而义异之旨也。佛以众生畏生死故。为说三名。非所以别体也。有法名一义异者。此更开释所以得有施三名之竟也。夫施设名义。自有多涂。如佛法僧常。是名一而三义是异。佛以觉为义也。法名不觉者。法以轨为义。非觉义也。涅槃名解脱者。即是无累。彼自有释义也。今解脱者。是翻彼义释也。虚空名非善者非善。非恶也。此证名义俱异者矣。我昔告彼提者。引证三归名义不应一也。就别体法僧。则体义俱异。今就佛上。则其体虽一。逐义为三。不可以体一故。使义不得三也。谓义有三。欲令体亦别也。说一为三者。随方设化。说法不同。三归亦尔也

迦叶复言如佛所说(至)真解脱者即是如来

案。僧亮曰。生灭聚积名身也。分别苦乐名智也。涅槃无此。故名舍也。谁受安乐者。上说种种乐。明非受乐。故发问也。身得安乐者。有食有身。有识分别。名为苦也。无食无身。不生分别。名为乐也。无受乐者。无受理圆。不可以方事喻也。此中诸譬。皆是少分耳。僧宗曰。食已闷者。行地之时。贪嗜五欲。譬之于食。为惑所蔽。如心闷也。出外欲吐者。标心离苦义言出耳。欲除烦恼。吐已还者。修道断结。功登果就。俯入生死。譬如还也。同伴问者。如迦叶今所问也。若言差者。如来解释果地之妙极也。显别昔曰舍身舍智。言虚不实也

迦叶复言不生不灭(至)如来之性即是解脱

案。慧朗曰。迦叶因释解脱。有此句也。故以为难。请重释也

佛告迦叶善男子是事不然(至)不可以譬乌鹊之音

案。僧亮曰。以鸟譬鸟。以声譬声。遍取同鸟。不得相比也。分取可譬佛声也

尔时佛赞迦叶善哉善哉(至)知诸法性皆亦如是

案。僧亮曰。以是因缘者。少分因缘也。无能匹者。非遍喻也。为喻者少分也

迦叶复言云何如来(至)成就满故名大般涅槃

案。僧亮曰。凡圣不可相譬。若分取可借凡以明圣也。虽不具足者。逆罪有二种。一者但以心重。为不具足。二者以心重事重。为具足

迦叶菩萨白佛言世尊(至)当作如是护持正法

案。智秀曰。迦叶领旨。佛赞述也

大般涅槃经集解卷第十四大般涅槃经集解卷第十五(四依品第八)

  释以四果拟菩萨　位释三乘十地　出瞿师罗经魔变作佛事释　正法余八十年前三十年事　释四依人修因久　近辩信不信相

    四依品第八

案。僧亮曰。此品答云何得广大问也。广上依经流通也。四相说其德。此四出其人所住。因说流通者。如来解脱。理幽事远。恐后弘之无人。于常住因果。不生信也。若不信果。则不行因。虽说无益。是故先辩流通也。大分为八段。第一就菩萨地。配四人相。第二显须四依之相也。僧宗宝亮曰。明降魔方法也。第三出流通经时及处所也。智秀曰。广四依人化功也。第四辩四人师及弟子。修因远近也。第五说不信四依之失。信者之德也。僧宗曰。劝信经也。第六明应敬重师也。第七叙四依人之益。谓依经修行。除八种不净。内虽犯戒。不失福田也。僧宗曰。简福田也。宝亮曰泛明福田相也。第八会宗明人。能知法人。即是法不违昔说也

佛复告迦叶善男子(至)为世间依安乐人天

案。僧亮曰。末世通法。非声闻之位。而以配菩萨者。但以声闻法服出家。其身正故配之。菩萨树自正之义也。虽晦迹俗流。而清白无染。量同罗汉也。此下八段之第一。配显四人相也。依声闻所断见谛及欲界思惟。以配菩萨断三界烦恼。始终作二人也。依声闻为三界思惟。以配菩萨所断者。习始终作二人。合为四人。僧宗曰。护正法者。不使耶侵毁也建立者。令法不坠也。忆念者。存而不忘也。智秀曰。此第一段中。有三章。此第一总举数叹德也

何等为四有人出世具烦恼性是名第一

案。僧宗曰。声闻位中。始于内凡夫。终阿罗汉也。菩萨位中。始于住前。终期十地。取少分相似。相拟配也。此从四意止。至世第一法。拟住前三十心。并是折伏道。未得真无漏也。宝亮曰。始得假名法空。伏见谛重执也。智秀曰。此下第二章。列数置位也。依断结经云。得众生空。至第七品。心已上信首五根立。未入真无漏。如声闻人。始于暖法。终世第一法

须陀洹人斯陀含人是名第二

案。僧宗曰。声闻以见谛为粗。思惟为细。菩萨以三界为粗。习气为细。今六位终心。断三界结尽。如须陀洹断见谛尽也。七住始侵习气。如斯陀含侵思惟结也。宝亮曰。从初地讫六地。若一豪惑未尽已来。如须陀洹断见谛惑尽。斯陀含断欲界思惟六品结尽。证果行向。但使欲界一豪惑未尽。犹名斯陀含。以未离欲界故也

阿那含人是名第三

案。僧宗曰。欲界惑尽。侵上二界思惟。不还下界受生。明八地以上。断三界外。若粗若细。不复还三界受生。而七地不尔。容有身在欲界。成七地者。终不得。仍进八地不逐之。名则不显也。论此义势。应通十地。但为赞叹十地。以配第四人故也。宝亮曰。六地满足。后更进。所断讫乎。九地断色心尘。粗障已尽。不复受三界生。故取类第三果人

阿罗汉人是名第四

案。僧宗曰。经言十地菩萨。当知如佛其有象王。视观形容似佛。是故前问云。实非阿罗汉。量与罗汉等也。事乃应喻。声闻罗汉。既位邻于佛。以其智用明胜形仪。量与佛罗汉等也。宝亮曰。罗汉断三界结尽。而习气未除。以类十地菩萨。断色心粗障乃尽。而色心集起之源未断。以为类也。智秀曰。罗汉是四果之极。十地是万行之极。义是同也

是四种人出现于世(至)为世间依安乐人天

案。智秀曰。此下第三章。广显德位也

云何名为具烦恼性(至)是名凡夫非第八人

案。僧宗曰。向合则为四。开则为八。是为声闻之与菩萨。各有其向。则成八也。犹如第十六心。结成初果。十五心已来为近向。五方便为远向今菩萨以六地为果。五地以还为近向。三十心为远向。罗汉以三界尽为果。无碍道以还为向。中闻果向。以意唯拟。是则第八名同。高下为异也。恐人谬解故。复简之言。是住前地之名字。第一从未得假名法空。邻四念处人。名干慧地。第二从得四念处以上。至世第一法。信根立者。名之性地。第三从登苦忍心以去。至未得须陀洹果以来。名八忍地。第四断见谛尽。名为见地。第五得斯陀含果。名为薄地。第六得阿那含果。名离欲地。第七罗汉果。名已辨地。第八辟支佛地。第九菩萨地。第十佛地。从上来作第一数。至八忍地。是圣人位。今言非此第八人。是性地凡夫。为初依也。所以须作此料简者。昔小乘教中十地。有因果两别。从性地至八忍地。皆是须陀洹向。今大乘十地。无因果异。而以性地。作初依时。恐人犹作昔意。谓须陀洹向尽。是初依人。欲指性地。故简出八忍地也

第八人者不名凡夫名为菩萨不名为佛

案。法瑶曰。八人之名。名复滥佛。从佛下数至此地。为第八。从此地上数至佛。复是第八。今以菩萨名之。居然非佛第八也

第二人者名须陀洹(至)名为菩萨已得受记

案。僧亮曰。菩萨有三位。初地得无漏。是心位也。八地无漏。是身位也。第十地。是法王位也。明此第二依。未得八地以上二位也。法瑶曰。制十地为三住处。三住处者。六地已还。未出三界。秽国一住处。七地是二国中间。非净非秽。为一住处。八地已上。相心都尽。名为净国。为一住处。言此第二人。未得七地以上住处故也。僧宗曰。所以复须简名者。圣位有三。而此人是四中之第二。恐滥圣位之第二。故须简也。第三人者。圣之第二。即是四中之第三也。宝亮曰。就第二依人。向上数第三为第二。而第四为第三。虽复未得此位。而已得受记。登圣无漏也

第三人者名阿那含(至)是则名为第三人也

案。僧宗曰。客尘者。以三界外惑为旧。三界内惑为客。以根本为义也。如前品说灯烬。譬后明不还义也

第四人者名阿罗汉(至)名人中胜为归依处

案。慧朗曰。略举三德。释罗汉也。断诸烦恼。释杀贼也。逮得己利。释应供也。所作已辩。释不生也。如序品中所释也

迦叶菩萨白佛言世尊(至)亦无敬念而作依止

案。道生曰。执无常者。必畏常说。如必畏者。四依出化。则成魔矣。僧亮曰。第二说须依者之相也。常说依法不依人。今舍法依人。惧魔道乱真。故下引成经证。魔为乱未。若能依法者。不须依人也。僧宗曰。将明恶世魔以坏乱。要须四依降其方法先假为依之辞耳。就降魔文中。可有五翻。第一引瞿师罗经为难。第二譬明声闻须依菩萨也。第三明菩萨由有经力故解降魔。第四明魔于二乘心无所畏。唯四依人力能降之耳。第五明声闻于外魔生怖畏也。此即第一引经为难也。谓瞿师罗。是须陀洹人。尚不免为魔所坏。况余人耶。下以衔物坚持。喻须陀洹。理当不为魔之所乱。一往于形仪之中。不能不惑耳

佛言善男子于我所说(至)如是作已长夜受乐

案。道生曰。此明说常有真有伪。不可其不信也。僧亮曰。依经法以捡实。则知说者之善恶也。智秀曰。次明世间应须依此四人。受降魔之法也。迦叶前后。凡作两翻难。第一谓魔能现作佛像。真之与伪。何由可分。今此答中有两意。此即第一。且一往许令分善恶也

善男子譬如偷狗夜入人舍(至)如彼偷狗更不复还

案。僧宗曰。魔譬狗也。夫狗欲为盗。必见其外。无守护之人。内有昏夜之闇。是以得入。魔亦如是。外无善友知识。内有无明[雨/復]心。魔得为乱也。闻慧甚卑。喻之婢。使以微明之中。捡魔虚实。以五系之力。魔即去矣。智秀曰。劝行者。以理捡魔。即是捡魔之方也

迦叶白佛言世尊(至)所可言说未必可信

案。僧宗曰。此问意。明四依无益。何者。若力能降魔者。则不假四依。若不能降。则形仪相乱。云何可寻。智秀曰。此第二翻难

佛言迦叶善男子如我所说亦复如是非为不尔

案。僧亮曰。答意云。若菩萨者。非为不尔。我为声闻。故说降魔。以声闻未习大乘故。须依也。依四依故。得降魔之法耳。智秀曰。答有二意。此第一。且一往许之。明审能降魔。实能近涅槃也

善男子我为声闻有肉眼者(至)如此佛乘最上最胜

案。僧亮曰。常理在生死之外。而天眼本以见障外为用。若不能识者。不如肉眼。而能识也。僧宗曰。必能降魔。则不假四依也。我为声闻故说耳。智秀曰。此下正答问。有三翻。此即第一明应学降魔者。唯是声闻。非都未涉佛法人也。故须四依也

善男子譬如有人勇健威猛有怯弱者常来依附

案。僧亮曰。有四弘誓者。譬勇士。畏生死者。譬怯也。宝亮曰。此下有两譬。先明佛在世时。佛教声闻降魔方法。第二恶龙以下。譬佛去后。四依人出。以教声闻降魔法也。勇者。佛有十力四无畏也。怯者。声闻也。智秀曰。此答中第二翻。举四譬。此第一譬也

其勇健人常教怯者(至)修学槊道长钩罥索

案。僧亮曰。譬三修以防恶也。慧朗曰。三慧闻慧如弓。思慧如箭。修慧如[金*羽]等也

又复告言夫斗战者(至)应自生心作勇健意

案。僧亮曰。涉生死之险。如履白刃也。当视人天。生怯弱者。生死倒惑无根。譬彼怯弱也。从理生解。有根难动。自譬勇健也

或时有人无有胆勇(至)不久散坏如彼偷狗

案。僧亮曰。魔如偷狗。设使诈为佛相。其内无法若见声闻。不怖畏者。则不能乱

善男子如来亦尔告诸声闻(至)愁忧不乐复道而去

案。智秀曰。合譬

善男子如彼健人不从他习(至)于是事中终不惊畏

案。僧亮曰。学大乘者。有二事。不须依人。一以积德深厚。二以大乘经力。自能降魔也。此即第一。显菩萨德行。所以无畏也

善男子譬如有人得阿竭陀(至)亦能降伏令不复起

案。僧亮曰。第二譬经力也

复次善男子譬如有龙(至)或以眼视或以气嘘

案。僧亮曰。上云学大乘者。能令魔事不起。而佛在道树下。无魔事。斯言似虚。是故以此一譬。正显菩萨以降魔之力。摄得声闻。兼遣此嫌也。龙譬魔

是故一切师子虎豹(至)或触其身无不丧命

案。僧亮曰。譬二乘也

有善咒者

案。宝亮曰。譬四依也

以咒力故

案。慧朗曰。譬经力也

能令如是诸恶毒龙(至)柔善调顺悉任乘御

案。宝亮曰。正明四依。以经力故。非唯能降魔。亦能摄二乘也

如是等兽见彼善咒即便调伏

案。僧亮曰。蠲出师子等譬。明所以降魔。正为摄取三乘。即是显昔道树降魔之本意也

声闻缘觉亦复如是(至)不生畏惧之心犹行魔业

案。慧朗曰。合诸兽畏龙。龙无所畏也

学大乘者亦复如是(至)因为广说种种妙法

案。慧朗曰。如彼咒者。所以降龙。为调伏诸兽故也

声闻缘觉见调魔已(至)正法之中而作障碍

案。慧朗曰。如彼诸兽见龙降故。所以调伏也

复次善男子声闻缘觉(至)百千亿劫不堕恶道

案。智秀曰。第三翻。结上旨也。明声闻所以应依大乘经。学大乘者。实为可贵也

尔时佛告迦叶菩萨(至)是大涅解微妙经典

案。僧亮曰。第三辨流通时。及处所也。我涅槃后者即是时也。当有诽谤者。即是处所也

迦叶菩萨复白佛言(至)当能拔济是谤法者

案。智秀曰。问有二意。第一问灭后几时。当有诽谤。第二问何等人。能为作救护。欲显四依人也

佛告迦叶善男子(至)然后乃当隐没于地

案。僧亮曰。行之为显。不行为隐。非为都没也。僧宗曰。佛灭度后。正法有五百年。像法亦五百年。今言四十年者。据正法中。佛初涅槃后也。宝亮曰。佛在世凡五十年说法。若与佛同年者已过。其有中年受道者。佛虽涅槃。而此一时人辈。能为流通。正可四十年也。此辈复去。尔后法教理。就讹替也

善男子譬如甘蔗稻米石蜜(至)皆言是味味中第一

案。僧亮曰。为行经者。作譬也。僧宗曰。中有三譬。初譬明不假四依人。次譬明小乘者。不须四依人。后譬明是四依人。后譬明行大乘者。已自流通。何待弘化耶

或复有人纯食粟米(至)我所食者最为第一

案。僧亮曰。譬不行者也。僧宗曰。此人执固弘通者。终不入也

是薄福人受业报故(至)如彼福人食于粳粮

案。慧朗曰。举二譬。以合行不行之处

善男子譬如有王居在深山(至)惧其有尽唯食粟稗

案。僧亮曰。烦恼累多。大乘心弱。譬之险难也。慈悲既少也。不能弘通。譬惜粳粮惧尽不食也。但说小乘。资益至寡。譬唯食粟稗也。僧宗曰。深山险难者。譬弘通之道。非无其路。而崎岖难入也。非无大乘经典。秘而不传。譬贪惜不食也。宝亮曰。小乘化主。譬彼王也。愚痴障重。譬深山也。虽有大乘经典。其味深玄。非己所解。譬之难得。复恐非理。譬惧其有尽

有异国王闻而愍之(至)令我得是希有之味

案。僧宗曰。四依菩萨。乃广写大乘经典。流通彼处。一时从化。譬举国共食也。宝亮曰。四依菩萨。赴彼所感。以譬愍之也。躬自弘通。喻如车载也

善男子是四种人亦复如是(至)因王力故得希有食

案。宝亮曰。合譬也。明向者小乘。深山王者。受四依化。亦遂成菩萨也。仍复广说。昔为小乘。不肯在众。共受持者。止为名闻利养故也。下列五句。一以利养。二为称誉。三为解法。即是欲胜他故。四为依止。要人归附也。五为贸易。其余经者。须更博悉。然后乃与。皆是障法因缘。自非四依。云何能化耶

又善男子是大涅槃(至)大乘经典甚深义故

案。宝亮曰。经所流布。在地则地贵。在人则人尊也。若不尔。以五阴法。如地人是法上之假名也。因此法以成人。人法悉是金刚

迦叶菩萨白佛言世尊(至)却后久近复当还出

案。僧亮曰。第四段。说四依植远近也。远者为师。近者为弟子。示功德之浅深。劝人修习也。僧宗曰。向以深山险难为譬。是知流通之日时处皆难。自非树德深厚。岂能宣化。今辨四依师。从修德之久近也

佛言善男子若我正法(至)于阎浮提雨大法雨

案。道生曰。法理湛然。有何兴何没。但行之则盛。不行则衰耳。僧宗曰。前出四十年是正法五百年初四十年。已一过流布。今明正法将终。余八十年。此四十年正法将尽。复一兴盛也。若二时既过。恶法增长。非德不传。非因不树。欲令时众慕道修因也。僧亮曰。佛般涅槃。四十年后。尔来四依之人。更互为化。凡三百八十年。信受四依也。并前四十年。合为四百二十年。正法唯余八十年在。而四十年中。经法尚流行。四十年后。稍近像末。不复流通。所以尔者。此一时人。尽为四依所化。皆能受持此经。过是以后。于时灭度尽。无复有流通。故言没于地也

迦叶菩萨复白佛言(至)阿耨多罗三藐三菩提心

案。宝亮曰。从此下第四段。明四依人。修因久近

尔时佛赞迦叶善哉善哉(至)如是经与不生诽谤

案。僧亮曰。此下辨初依人。具烦恼性者之因也。经言。初地菩萨。供养微尘诸佛。岂当止八恒沙。便具十地。但说初依功德如此。余三人不复待言也。性地解地。有三种慧。谓闻思修也。是有漏功德。各有三品。熙连河沙得下下闻慧。第八恒河得上上修慧。是为九品。有漏慧满。过是得无漏。入初地也。未来护法之人。供养八恒河沙。始能宣说。恐有退者。以此劝之也。僧宗曰。此中出两家之因。从熙连讫二恒河。是听者之因也。从三河至八河。是说者之因

善男子若有众生于一恒河(至)不能为人分别广说

案。智秀曰。闻慧中品也。前供养熙连河沙。得下品闻慧。唯能不生诽谤。今云爱乐是典也

善男子若有众生于二恒河(至)亦复不能为人广说

案。智秀曰。上品闻慧满也。加以正解信乐。受持读诵。未能为人广说也

若有众生于三恒河沙(至)虽为他说未解深义

案。宝亮曰。此是思慧下品者也。此人假名法空。将立未立。故悉属弟子数也。云未解深义者。未识人根也。前闻慧三人。并是念处人也

若有众生于四恒河沙(至)虽复演说亦不具足

案。僧宗曰。今初依人。具十六分解者。此是分野说耳。文意似不论登住。何者。恶世流通。在人为难。而凡夫具惑。遂能传化。此事可奇。若是登住。不足为难。亦不假问。且具缚之人。虽欲宣通。不必恶世。今言宣通之德。恶世弥盛也。所以初一至八。而后复四。如此增减者。亦有意也。夫造次求理。其功则难。故得一分。及其得理。则先[跳-兆+(轍-車)]易乘。故进八分。既入幽微。神功难故。损之至四也。损四之二。其义亦尔。最后应一而复二者。合束前因之力。将满以企厉。故复至二也。经文既无正显处。是故师说。往往不同也。宝亮曰。就初人上品。三十心满。怀抱所解。分为十六分也。所以参差不调者。凡夫习惑。用有粗细。既中间遇恶友。起一段重惑。心用不均。解何容等。执相难除。故初解一分。习虚不已。藉前解为资。所以顿悟七分。然微相难治。胜解难生。是则交固之执难遣。瞥尔有存。则易忘故。胜解难得

若有众生于五恒河沙(至)十六分中八分之义

案。智秀曰。所以初一乃至八者。其分外解。何应有无量。但既不入可依之限。故不录也。今举其可名得不退者。言一分也

若有众生于六恒河沙(至)十六分中十二分义

案。智秀曰。理既渐深。精解难得。所以先多而后少也

若有众生于七恒河沙(至)十六分中十四分义

案。智秀曰。差池渐积。义同上也

若有众生于八恒河沙(至)必能护持无上正法

案。智秀曰。习解稍积。于一分野之功。始得具足。成初依也

善男子有恶比丘闻我涅槃(至)诽谤拒逆是大乘经

案。僧亮曰。第五辨信不信相。明信四依者得。不信者失。此先明不信者相也。僧宗曰。劝信之意。以闻经之缘。其力不浅。岂得不生深信耶。宝亮曰。此下有七重。第一明涅槃后有不信者之过。第二明信者必能灭恶。第三广显谤法之殃。第四出敬信经者现报。第五明谤法之罪。于涅槃经而悔。其过必灭。亦可成前第二信法人也。第六始出家譬。为信法人作喻也。第七明本无好意。而学大乘者。或有见他得利养故读。或贪名誉故看。虽尔。但众生神明。后自觉知经力之深。此即第一重

善男子汝今应当如是忆持(至)所作恶业皆悉除灭

案。僧亮曰。显信者之相也。宝亮曰。第二明信经人。必能灭恶也

若有不信是经典者(至)不能得至人天善处

案。宝亮曰。第三明不信者现报

若复有人能信如是(至)闻其所说悉皆敬信

案。宝亮曰。第四明信者现报也

若我声闻弟子之中(至)广宣如是大乘经典

案。宝亮曰。上说信者之德。是声闻人。乐行独善。故偏劝也

善男子譬如雾露势虽欲住(至)悉能除灭一切恶业

案。僧亮曰。善有二报。一者灭恶。二者成善。此说灭恶。次说成善也。宝亮曰。第五为向者谤经人作喻。明谤法之罪。若于大涅槃经。而忏悔者。其过必灭。亦可成前第二信人。以除恶故也

复次善男子譬如有人(至)则已堕于十住数中

案。僧亮曰。明生善也。所以言堕十住数者。十住亦不退。此人亦不退故也。下云。一经于耳。生生不失正见。宝亮曰。第六为向得者为喻也。以必堕十地数故也

或有众生是佛弟子(至)如是四人为世间依

案。宝亮曰。向为发轸深信人。譬今第七。此明发家无好意。而学大乘者也。或见他人得利养故。或贪名誉。故读经典。虽然。众生既非木石。后亦自当觉知经力。而得近道。敬遗记僧宗曰。向所说因远。恐人心自绝。故复引之。莫问真伪。但能标心。自有深益也

大般涅槃经集解卷第十五大般涅槃经集解卷第十六

  明敬弘经人不应简老少黑白等　出二果相似譬　出买雪山药譬　会通今昔四依仪

    四依品之第二

善男子汝应供养如是四人

案。僧亮曰。第六段。明敬师之仪也。僧宗曰。四依之德。实可尊贵。能生人善。宜供养也。智秀曰。劝养有四翻。第一正劝。第二辨供养之法。第三问答辨供养之方。第四问答论能现为恶者。此人破戒不。此即第一劝供养也

世尊我当云何识知是人而为供养

案。僧亮曰。四依晦迹。不可别也。智秀曰。此下第二辨供养之法也。佛将欲说。迦叶发问也

佛告迦叶若有建立(至)亦如诸天奉事帝释

案。僧亮曰。内实难知。但观外迹。弘护法者。便应供养

迦叶菩萨白佛言世尊(至)今有所疑唯愿广说

案。僧宗曰。今昔之教既反。请会二说也

若有长宿护持禁戒(至)咨受未闻复当礼不

案。僧宗曰。此中有三问。此第一问也。不名持戒者。不名小乘持戒也

然出家人不应礼敬(至)犹如良田多有稊稗

案。僧宗曰。成前三问也。先简第三。次简初问。后简第二问

又如佛说有知法者(至)如是所说其义未了

案。僧亮曰。二教相违。不应两实。必应一是一虚妄也。亦有所犯者。虽自持戒。不治破戒。法灭不救。亦非我弟子。不治尚犯。况应礼耶。僧宗曰。亦有所犯者。如今日所制。昔日小乘持戒。亦有所犯也。明骏案。又如佛说以下。举今之教以结难也。如佛言曰以下。引昔教以成难也

佛告迦叶善男子我为未来(至)不为声闻弟子说也

案。僧亮曰。答意以所为之人异也。小乘以洁已自度。大乘以济物为怀。不得同日而言也。僧宗曰。制小如昔。劝大如今也。通塞有时。遮开无定也

善男子如我上说正法灭已(至)虽有所犯不名破戒

案。僧亮曰。弘法之人。虽外有所犯。内无所破也。僧宗曰。更举恶世。应须流通。谓或宜默然。或宜同事。或宜纠治。于菩萨道。不名犯戒也。宝亮曰。四人出世。动必观机。是时则行也。要先同其事。然后乃反。故云自所行处。及佛行处。皆善分别也

善男子譬如国王遇病崩亡

案。道生曰。师师净众。莫二其行。有王之义也。僧亮曰。为前方便护法。而不犯戒者。作譬也。国王譬清净持戒有德。一众之主。有生有死也

储君稚小未任绍继

案。僧亮曰。稽古有行。居然可宗。但人未推也。僧宗曰。弟子虽习师德。而年尚少。道未伏物

有栴陀罗丰饶财宝(至)乘国虚弱篡居王位

案。道生曰。肆情为恶。害智慧命。为旃陀罗也。僧宗曰。譬破戒比丘。内多俗术。外丰世财。而同恶相求。摄居僧事。非道而处。为篡夺也

治化未久国人居士婆罗门等亡叛逃走远投他国

案。僧亮曰。无德在正。有非法之科。净戒比丘。不安其所也

虽有在者乃至不欲眼见是王

案。僧亮曰。虽受其说。终不与共布萨自恣。无水乳之知也

或有长音婆罗门等(至)随其生处即是中死

案。僧亮曰。师宗在处。同其说戒。此处得戒。此处破戒。如彼树也

旃陀罗王知其国人(至)遣诸旃陀罗守逻诸道

案。僧亮曰。有护戒者。欲逃避之。而求通无路也。僧宗曰。或使破戒弟子。遏其道也

复于七日击鼓唱令

案。僧亮曰。知诸比丘。不可力制。欲以律治。僧若有罪者。以七灭诤法。唱令僧知也

诸婆罗门有能为我(至)当分半国以为封赏

案。僧亮曰。既知众所不伏。今欲令众僧和合羯磨。为知事也。共知僧事。譬半国也

诸婆罗门虽闻是语(至)有婆罗门种作如是事

案。僧亮曰。清净比丘。师习不尔。岂有与同事理耳

旃陀罗王复作是言(至)半国之封此言不虚

案。僧亮曰。谓若立我为知事之主者。当别结界各自布萨。于彼无妨。若不尔者。遣非法之人。同汝僧事。使汝不得半月说戒也

咒术所致三十三天(至)亦当共分而服食之

案。僧亮曰。向以律募。今以经要也。咒术譬般若。三十三天。譬涅槃也。药者譬常住。当共行经以求常。故譬食也

尔时有一婆罗门子

案。僧亮曰。七世净行。名婆罗门也

年在弱冠

案。僧亮曰。植德八河。譬年也。弱冠者。正明长者宜礼幼者也

修治净行

案。僧亮曰。明自正之义也

长发为相

案。僧亮曰。发生人头。唯长为美。命居德首。以常为上

善知咒术

案。僧亮曰。经律兼明。尽其义也

往至王所白言大王王所敕使我悉能为

案。僧亮曰。晦迹为恶。是其所能也

尔时大王心生欢喜受此童子作灌顶师

案。僧亮曰。即为羯磨。举知僧事

诸婆罗门闻是事已(至)云何乃作旃陀罗师

案。僧亮曰。有未达者。不识其权也

尔时其王即分半国与是童子因共治国经历多时

案。僧亮曰。治乱之间。大法粗道

尔时童子语彼王言(至)而今大王犹不见亲

案。僧亮曰。好恶相同。谓之亲也。我共汝恶。而汝不同我好。故犹未见亲也

时王答言我今云何(至)不死之药犹未共食

案。僧亮曰。说我所好。在乎常住。而此常经。犹未共行

王言善哉大师我实不知师若须者愿便持去

案。僧亮曰。不知有此经。复未知师之所好。便持去者。但行经求常也

是时童子闻王语已即持归家

案。僧亮曰。菩萨以弘通。为心宅也。得经而流布。谓之还家矣。

请诸大臣而共食之

案。僧亮曰。知事既许弘经。于是弘通之人。便有势力。然行经求常。以净戒为本。制恶比丘。皆除不净物。修常住之因。譬共食也

诸臣食已即共白王快哉大师有是甘露不死之药

案。僧亮曰。已得行经之势。向王说经之美也

王既知已语其师言(至)服食甘露而不见分

案。僧亮曰。凶党既尽。恶不孤立。请求依经。以闻常住

尔时童子即便以余杂毒之药与王令服

案。僧亮曰。求常以净戒为本。先令读律。已犯重禁。于已是苦名毒。治其之罪名药也

王既服已须臾药发闷乱躄地无所觉知犹如死人

案。僧亮曰。读律列罪。譬药发也。于外众中。无复通路。譬躄地也。内绝圣胎。譬无所知也。无有慧命。譬如死人也

尔时童子立本储君(至)还绍先王正法治国

案。僧宗曰。还以清净如律之人。为知事也

尔时童子经理是已(至)既醒寤已驱令出国

案。僧亮曰。令受持涅槃经。譬解药也。不经三途。譬醒寤也。不得居众。譬出国也

是时童子虽为是事(至)善能驱遣旃陀罗王

案。智秀曰。菩萨虽复同彼受畜。而无所犯。为诸净行之所叹也

善男子我涅槃后护持正法(至)利益一切诸天人故

案。智秀曰。合譬甚略。唯合菩萨。先示同而后反耳

善男子以是因缘我于经中(至)但为菩萨而说是偈

案。智秀曰。举譬答问。会前二偈之意也

迦叶菩萨白佛言世尊(至)本所受戒为具在不

案。僧亮曰。上已说不犯。所以重问者。虽云现犯。亦须现悔。亦须净戒之人。所犯得除。此是佛法之大。不可不明

佛言善男子汝今不应(至)即应忏悔悔已清净

案。宝亮曰。戒无所失。设复有犯。终不成过

善男子如故堤塘穿穴有孔(至)即能具足不失本戒

案。宝亮曰。戒如堤塘。以定慧为水。若无四依人出世。令改恶从善者。则戒堤塘破坏。定慧之水尽也

善男子于乘缓者乃名为缓(至)虽现破戒不名为缓

案。宝亮曰。乘是护法之纲维。戒是乘家之别事。纲维既立。则万行斯举也。然乘本乘于戒耳。戒若苟无。何所乘耶。是故戒亦不可缓也。向云为物故现同有犯。其实不犯。现若如此。戒实小缓。故言得缓耳

迦叶菩萨白佛言众僧之中(至)破戒持戒云何可识

案。僧亮曰。第七段。说四人之益。依涅槃修行。外除八物。内虽犯戒。不失福田。得名大乘。不应供养而亦得也。不依涅槃修行。外为八物所污。内虽清净。不名福田。不成大乘。应供养而失也。僧宗曰。向明通法德。重劝人供养。但人有真伪。难可别知。故料简清浊。使净秽有分也。智秀曰。此下有三翻。第一迦叶举果有生熟。其相难知为咨。第二佛广释难知而复可知为答。第三迦叶领解也。此即第一也

佛告善男子因大涅槃(至)非是肉眼所能分别

案。僧亮曰。除八不净。则生人净想。是人福田也。名净田者。草壳未分。不生秽想也。僧宗曰。答中有三譬。前譬明众中善恶。一往难知。但见清净威仪。便应供养。凡夫未得天眼。正应以四事观察也。第二譬明真伪既乱。四事观察。乃始终方知。不能交验。应当捡问。寻其所说也。第三譬明苟不能分别。但生平等。则凡圣两获。若徒捡不得。则失圣人。空生纷纭。更成过各。此即第一譬也

复次善男子如迦罗迦林(至)二果相似不可分别

案。僧亮曰。第二譬也。林譬僧坊。迦罗迦譬内外俱粗。镇头迦譬内细外粗。而外相相似也

其果熟时

案。僧亮曰。应受供养时也

有一女人悉皆拾取

案。僧亮曰。修功德人。粗细等诸

镇头迦果才有一分(至)持来诣市而炫卖之

案。僧亮曰。市是贸易之所。喻施主之家。有彼此相资之义也。分僧供养。功由请者。喻如卖也

凡愚小儿复不别故买迦罗迦果啖已命终

案。僧亮曰。识浅情局。喻如小儿。供养粗人。心起恚慢。不生净福。譬若命终

有智人辈闻是事已(至)诸人知已笑而舍去

案。僧亮曰。虽知内细。以其众粗。亦不供养。失福之义也。不成大乘。应得而失。惜哉

善男子大众之中八不净法(至)供养是人若欲供养

案。僧亮曰。略合譬也

应先问言大德(至)食迦罗迦果已而便命终

明骏案。粗细之迹。难以眼识。应先捡访。自当可见。岂宜以粗废细。使玉石俱焚者耶

复次善男子譬如城市有卖药人

案。僧宗曰。第三譬。聚众交易相资之处曰市。譬之僧坊也。卖药人。教化主也

有妙甘药出于雪山亦复多卖其余杂药味甘相似

案。僧亮曰。甘药譬内外俱细者也。雪山譬涅槃经。谓依经修行者。则表裹皆细也。余杂药者。譬外细内粗也。味甘相似者。一往迹细。皆生人净心也

时有诸人咸皆欲买(至)此是雪山甘好妙药

明骏曰。彼卖药人。知药是杂。而欺此买物。意欲令人皆作真想也。教化之主。知此众中。外细乱真。而意欲令人得表裹皆细之福田。故悉赞叹也

时买药者以肉眼故(至)我今已得雪山甘药

案。僧亮曰。不知其内。但观其外。通生净想。得无量福也

迦弃若声闻僧中有真实僧(至)有天眼者乃能分别

案。僧亮曰。若不能分别。但等心供养也

迦叶若优婆塞知是比丘(至)袈裟因缘恭敬礼拜

案。僧亮曰。若必知内粗者。不应以外细而供养

迦叶菩萨复白佛言世尊(至)譬如金刚珍宝异物

案。智秀曰。领所解也

如佛所说是诸比丘(至)应当证知非四种人

案。僧亮曰。第八段会宗也。明人能知法。人即是法。不违昔说也。僧宗曰。二教似反。所以须会。昔说四依。谓依法不依人。乃至依智不依识。是则不使依人。有多过也。自有人是而法非。人非而法是。自有人法俱是。人法俱非者也。而浅识之徒。不能分别。或谓人非。遂失正法。或见人是。乃受耶教。则有失法之过也。是故观令依法也。虽复置人。以取法故。宜简择了不了也。了义者奉行。不了义者勿用也。虽知了义。应废辞华。以存义实。虽复遗文以入理。要宜虚怀以为胜。若不虚怀。则成识者。当依智人之矜抱。勿依凡夫之识着也。此是昔日四依也。若利根人者。不假闻四。但闻一二。已可知矣。若依人。则多过也。今日所以说依人者。昔佛在。世经教。未为人根多利。自能依法。以得于人。涅槃之后。经教穿凿。文理难寻。正当凭信弘通。以取真实也。昔言依法。必是正法。即是法所教人。今言依人。必是体法之人。即是依人所行法也。昔言法。今言人者。盖互举其一耳。下有三章。第一就经释会。第二就律释会。第三结四依名也。宝亮曰。人是总名。法是差品。故使依法。以取人也。及捉法以取人。故是依法耳。今日四人。与佛不异。故但使依人也。虽有四名。但为成初一依耳。何者。言依法不依人。而五阴是成人之法也。义是法下。所以若此语有义。与理相应者。此则可依。若但有语而无义。不可依也。如言阴有神我。但有语也。若言生灭无常。则有义也。了义经者。以三法印。为了义。异此非了义也。依智不依识者。智性取法分明。缘中忘相。所以可依。识本取着。不会法相。不可依也。故知后三为成前一也

佛言善男子依法者(至)是故如来常住不变

案。僧亮曰。证法即是人也。先就极处说也。常住不变者。以常为证也。僧宗曰。释往日所言。依法之旨也。昔令依法。意在常果。法不异人。即曰依人也。今所言人。体常法者。若依此人。即依常法。常果即法性也

若复有言如来无常(至)是法性者不应依止

案。僧亮曰。人不见法。人即非法。依此法者。即依人也。僧宗曰。简去耶人。执教乖理者。不可依也

如上所说四人出世(至)如来密语及能说故

案。僧亮曰。此人解佛所说。解即是法。故可依也。知如来常。若言无常。无是处者。解既同佛。亦即是佛也

若有人能了知如来(至)何况不依是四种人

案。僧亮曰。以下况上。证四依人也

依法者即是法性(至)善男子是名定义

案。僧亮曰。异则是倒。倒即是灭。不可依也

依义不依语者(至)是名依义不依语也

案。僧亮曰。法由义实。次法辩义也。觉了者慧也。所了此实。故以慧表义也。不羸劣者。义深照浅慧。名羸劣。不名觉了也。满足者。照极无遗。境智俱圆也。常住不变。智圆累尽。不复变也。即法常者。常即法也。即名僧常者。得常故。和合常尔也。僧宗曰。释果地功德。智慧圆备也

何等语言所不应依(至)如是等语所不应依

案。僧亮曰。具释如下文也。若为法则通。不为法则塞也

依智不依识者(至)及其经书亦不应依

案。僧亮曰。义由智显。故次义说智也。如实而知名智。智即如来。不如实知。即是识着。着是识业。不可依也

依了义经不依不了义经者(至)入法性者是名了义

案。僧亮曰。由经生智故。次智辨经也

声闻乘法则不应依(至)如是四依应当证知

案。智秀曰。双释可依不可依义也

复次依义者义名质直(至)不可系缚而亦可见

案。僧亮曰。此下第二说会四依也。名义相当。名质直也。亦就佛地说耳。名曰光明者。相当名义互相显发也。不羸劣者。互彰则名义俱尽也。不劣名为智慧者慧是般若。上总三事。今别之也。常住者。法身也。而亦可见者。结尽则证也

若有说言不可见者(至)是故依法不依于人

案。僧亮曰。结此人不可依也

若复有人以微妙语(至)是故依义不依于语

案。僧亮曰。此二依作佛地明故合说

依智者众僧是常无为不变(至)是故依智不依于识

案。僧亮曰。依无漏智。说声闻僧。得无漏智相续常也。无漏断结。终不更起。谓无为不变也。得无作戒。终不作恶。谓不畜八种不净物也。不依识者。断结还起。不可依也

若有说言识作识受(至)是故此识不可依止

案。僧亮曰。引人说为证也。作是无碍道。受是解脱道也。无和合僧者。声闻相续常。是和合常也。无碍解脱。非是识者。无和合常也。和合名无所有者。有漏和合。本无今有。已有还无。无不可说。是故识不可依也

依了义者了义者名为知足(至)不了义经不应依止

案。僧亮曰。此说依法。以经为法。法有了义不了义也。住是中者。解经所说。住其中矣

善男子若有人言如来怜愍(至)如是四法所应依止

案。僧亮曰。为护法故。具此三缘。为继身命。行于法故。不贪聚为轻也

若有戒律阿毗昙修多罗不违是四亦应依止

案。智秀曰。不但四依人说故。可依三藏。与此相应。亦可依止也

若有说言有时非时(至)如是三分亦不应依

案。智秀曰。举非以显是也。非但人说不可。而依三藏。有此说者。亦不应依也

我为肉眼诸众生等(至)是故我今说是四依

案。智秀曰。结会今昔说四依者。皆为示导肉眼者也

法者即是法性(至)了达一切大乘经典

案。智秀曰。第三翻。总举今日之旨。结定真教。以释会本意也

大般涅槃经集解卷第十六大般涅槃经集解卷第十七(分邪正品第九)

  辩十一种邪正事

    分邪正品第九

案。僧亮曰。答云何知天魔。为众作留难也。故是广流通也。法瑶曰。夫邪党嫉正。魔乱真道。能惑始学人。故宜辨其相。是以四依品中。举贼狗毒龙等譬。答问云何作留难也。今此一品。并四谛品。答如来波旬说。何分别知也。同是四十九年教。而善察者。居然异也。智秀曰。问称天魔者。盖是举天。示极魔之胜耳。寻魔之为乱。事不止一。但以言之。为实乱为甚。故问云。如来波旬说。云何分别知也。此虽人法两异。同能乱道。故合成一问也。慧诞曰。此品有四段。从品初至九部经。明魔佛二说。相似而异也。二从九部以下。佛弟子执轻非重。执小非大。迭相诽谤。复是魔也。三从无四波罗夷以下。明大邪见人所说。无善恶理。复是魔也。四从要因持戒以下。通明古今所可乖佛法事。尽是魔说也。今佛之与魔。在家出家。邪见正见。经律通塞。尽释也

尔时迦叶白佛言世尊(至)诸余经律能受持者

案。僧亮曰。持魔经律。是谓依人不依法也。若具四颠倒。即四魔也。僧宗曰。四魔者。魔经魔律魔师及魔弟子也。魔以二事乱法。一以形乱。二以说乱。今先明形乱。次明说乱。就说乱中。略有二。一者乱经。二者乱律。乱经乱律。各有两重。初略后广也。就略乱经中。承佛偏教。执为了义。就略律中。初明一往违反律教。就广乱经中。文句再出。不必从教。正自推度。生此邪解。非功德之人。后明比丘答王有性得罪。亦名乱经也。就广乱律中。可分为七。至彼更分也。宝亮曰。此中辨邪。有二段。一者天魔乱道。二者人作魔。以乱正也

迦叶菩萨白佛言世尊(至)如是等辈复云何知

案。智秀曰。向一翻。先指前四依。以咨佛。既蒙印可。便举先问。以请答也

佛告迦叶我涅槃七百岁后(至)作无漏身坏我正法

案。智秀曰。二种乱中。此形乱也

是魔波旬坏正法时(至)随顺佛所说者即是菩萨

案。智秀曰。此下显言乱也。有十一复次。此第一谓实生王宫也

若有说言如来生时(至)随顺佛所说者即是菩萨

案。智秀曰。第二不信四方各行七步

若有说言菩萨生已(至)随顺佛所说者即是菩萨

案。智秀曰。第三谓佛在后生。应敬礼天。天前出故。不应礼佛也

若有经律说言菩萨(至)随顺佛经律者是名菩萨

案。智秀曰。第四谓实受五欲也

若有说言佛在舍卫(至)随顺佛所说者即是菩萨

案。智秀曰。第五谓佛听受八不净物也

若有说言菩萨为欲供养(至)当知是魔之所说也

案。智秀曰。第六谓佛不能现入诸道。示众伎能也

若有说言菩萨如是(至)随顺佛所说者即是菩萨

案。智秀曰。第七谓戒律一向皆重。又言无有大乘也

复次善男子若有说言(至)随顺佛所说者即是菩萨

案。僧宗曰。从轻重之罪。其性皆重。自此以下。魔说律以乱正也。有七意。此第一。且一往云。言违反律教也。智秀曰。第八谓佛不为功德所成。故身无常也

复有人言或有比丘(至)若能随顺是大菩萨

案。僧宗曰。第三说二人无犯。而犯为犯也。智秀曰。第九谓实不犯。而言犯也

复有说言无四波罗夷(至)当知是人真我弟子

案。僧宗曰。第三说一向毁犯。都无有罪。智秀曰。第十谓无一切戒也。下因迦叶更问。别明异义也

迦叶菩萨白佛言世尊(至)佛法甚深不可思议

案。僧宗曰。第四明九部经中。不说佛性。依教说无。此不犯罪。若说得罪。亦是魔说。为乱律也

迦叶菩萨白佛言世尊(至)不名堕过人法名为菩萨

案。僧宗曰。第五明必能护法。宣通正化。虽唱得道。不名得罪。若说罪者。亦是魔说。为乱律也

若言有犯突吉罗者(至)随顺佛所说者是名菩萨

案。僧宗曰。第六明犯罪果报。又长兼出大乘偷兰之事。诫后人

若有说言常翘一脚(至)当知是人是大菩萨

案。僧宗曰。第七用若九十五种道。皆听出家。亦为乱律也。智秀曰。此第十一。谓佛听畜不如法物。及听出家。亦为魔说也

善男子魔说佛说差别之相今已为汝广宣分别

案。智秀曰。结上旨也

迦叶白佛言世尊我今始知(至)因是得入佛法深义

案。智秀曰。赞叹

佛赞迦叶善哉善哉(至)晓了分别是名黠慧

案。智秀曰。述成也

大般涅槃经集解卷第十七大般涅槃经集解卷第十八(四谛品第十　四倒品第十一　如来性品第十二)

  释四谛义　释四倒义　略释佛性义　贫女金藏譬　女人子病譬　迦叶设十一难责令见有　力士眉间珠譬

    四谛品第十

案。僧亮曰。答云何诸调御。心喜说真谛也。上说魔教为邪。今明佛是调御者也。昔说非苦为苦。以治乐惑。乐惑既治。佛则欢喜。说佛为乐。佛乐是真谛也。僧宗曰。从此讫难见性。广因义也。四谛者。慧所照境也。自鹿苑至乎法华。所说阶级。大有不同。唯此教圆备。将明常住妙因。必资中道观照。然非境无以辨智。故举四谛。以明因相也。宝亮曰。昔说四谛。指在三界。今日之教。理无不该。言虽有四。要在真如寂灭。今说据本而遗末。此旨始显。以称圣心。故曰喜也。然四谛一品。明理周悉。故云由信常住。从人道天中。直出生死。是则必先信常。然后识无常也。若不双解。何得入道。故下灭谛中。曰修苦灭者。逆于外道。今若果修断灭之空。若以苦悟理者。外道亦应正知理不可也。昔为引凡故。有此说耳。若无权教。则下愚息望也

佛复告迦叶所言苦者(至)地狱众生应有圣谛

案。僧亮曰。不见真乐。不名见苦。何者。心虽求乐不识真乐。以三界为乐。不见苦也。不以畜生为决。敬遗记。僧宗曰。一谛中各有四别。初明惑。第二明解第三结圣谛。第四结非谛也。将明中道圆照。先明不解。以相形释义也。初一重明谛之名在照。不在苦也。第二明虽谛名在照。而不在偏执也。明苦有地。不得其所。非唯失理。亦方沦苦也。昔教有余之智。不免于倒。今说理穷。所以真善业也。宝亮曰。一谛中有四重。得谛之名。要将解未了境故。就境以说谛也。苦谛中四者。第一从始。讫多苦恼。明失也。第二从若有能知。讫即生天上。明得也。第三从后解脱时。讫方证知。此证得也。第四从我于本际。讫乃得真智。此证失也。智秀曰。一一谛下。有三意。苦谛中三意者。始讫多受苦恼。第一举其不知出苦谛体相也。从若有能知。讫乃得真智。第二辨从理得果也。从若如是知。讫非苦圣谛。第三结邪正也。慧朗述僧宗。曰辨苦谛有六阶。此第一直平理。谓非正苦为苦谛也

善男子若复有人不知如来(至)增长诸结多受苦恼

案。僧宗曰。第二阶明失也

若有能知如来常住(至)若一经耳即生天上

案。僧宗曰。第三阶明得也

后解脱时乃能证知(至)今得解脱方乃证知

案。僧宗曰。第四证得也

我于本际以不知故(至)始于今日乃得真智

案。僧宗曰。第五证失也

若如是知真是修苦(至)是名为苦非苦圣谛

案。僧宗曰。第六双结得失也

苦集谛者于真法中(至)不得生天及正解脱

案。僧亮曰。真法是集。不生真智者。不生集智也。受不净物。能集生死。是真集。而不生集智。不知法性者。不见佛性也。敬遗记。僧宗曰。此中辨集。文句再出。盖分别出集。所以不识常故也。慧朗记。僧宗曰。辨集灭道。各有五阶。此即第一先明失。举转轮生死。以为过也

若有深智不坏正法

案。僧宗曰。第二阶明得也

以是因缘得生天上及正解脱

案。僧宗曰。第三阶证得也

若有不知苦集谛处(至)流转生死受诸苦恼

案。僧宗曰。第四证失也

若能知法常住不异(至)是名为集非集圣谛

案。僧宗曰。第五双结得失也

苦灭谛者若有多修(至)亦修空法应有灭谛

案。僧亮曰。先非昔所说者。自知今之为是也。昔灭有二种。一性灭。谓空无我也。二灭身智。而如来者非空无我。身智不灭。作灭想坏如来也。敬遗述僧宗曰。生死是空。佛果不空。若谓二处皆空。于果为谬。故言多也。逆外道修空。该一切法。今分别空相。正反于邪。故言逆也。慧朗述僧宗曰。亦有五阶。此第一阶。举惑以明失也

若有说言有如来藏(至)灭除一切烦恼尔乃得入

案。僧宗曰。第二明得也

若发此心一念因缘于诸法中而得自在

案。僧宗曰。第三证得也

若有修习如来密藏(至)在生死中流转受苦

案。僧宗曰。第四证失也

若有作如是修者(至)是名修空非灭圣谛

案。慧朗曰。第五双结得失也

道圣谛者所谓佛法僧宝及正解脱

案。僧宗曰。此中有八阶。此第一先出道境

有诸众生颠倒心言(至)轮转三有久受大苦

案。僧宗曰。第二明失

若能发心见于如来常住无变法僧解脱亦复如是

案。僧宗曰。第三明得

乘此一念于无量世自在果报随意而得

案。僧宗曰。第四证得也

何以我于往昔以四倒故(至)成佛正觉是名道圣谛

案。僧宗曰。第五证失也

若有人言三宝无常(至)真见修习四圣谛法

案。僧宗曰。第六双结得失也

是名四圣谛

案。僧宗曰。第七总结也

迦叶菩萨复白佛言(至)修习甚深四圣谛法

案。僧宗曰。第八领解也

    四倒品第十一

案。僧亮曰。答正善具成就。广说颠倒也。欲令四谛具足。更说四倒。故是流通也。僧宗曰。上举境以明智。此明惑以显解。广显解相。故先列其惑相。明于义乃显。亦如上三修文中。将说胜修。先列八倒也。宝亮曰。答第九问。次明伪理也。智秀曰。上辨四谛。引物生解。但真解难生。喜成僻执。执则成倒也

佛复告迦叶谓四倒者(至)是无常者名大罪苦

案。僧亮曰。先说倒体。亦应对明。但经文略耳。僧宗曰。此下先明苦中生乐想之倒也。乃未应辨非苦中苦想。今显其倒缘。有此计者。谓必得理。遂于生死之中。横计乐想故也。宝亮曰。辨初倒中。有三翻。先明后倒。次明前倒。第三举后倒以结句也。就初明佛上倒中。有四意。第一先开章门。第二释章门。第三云。如来是行苦。第四言佛是坏苦。若如是计者。是则大罪苦人也。智秀曰。辨初倒中有三翻。第一讫而生苦想。此名颠倒。将显苦上有乐迷故。辨苦体也。有二意。初就理中。明其倒相。后是经家。结其倒想也。此即第一。若于乐上。起苦想者。必得苦果。而谓我则受乐。是则于苦而起乐惑

若言如来舍此苦身(至)是名非苦而生苦想

案。僧亮曰。苦有二种。谓行苦坏苦。前云无常变异。是行苦也。今言舍是苦身。谓坏苦也。并列二倒也

是名颠倒

案。智秀曰。第二意经家结其倒名

我若说言如来常者(至)如是说者我则受乐

案。僧亮曰。释生倒之意也。即是我见者。若言佛不生灭者。便是自在。自在是我。我见是众结之本。是故不说佛是常也。宝亮曰。此下第二明前倒也。惑者自谓。若说佛是常。便是计我。我昔此计。得无量罪。今若说佛是无常者。则离我见。故受乐也。智秀曰。正辨苦上起乐见也。有二意。此即第一出其起倒之意也

如来无常即为是苦(至)生乐想故名为颠倒

案。智秀曰。第二意经家结其成倒也

乐生苦想名为颠倒(至)名为颠倒是名初倒

案。僧亮曰。惑者谓。常则不灭。灭则不常。释所以是苦行也。云何舍身者。乐则不应舍而舍。故知是苦。此释所以是坏苦也。宝亮曰。此下第三还举后倒。结前句也。智秀曰。正明乐上起苦见为倒也。有三意。第一约理辨其是倒。第二经家结其成倒。第三出彼见之意也

无常常想常无常想(至)是名第二颠倒

案。僧亮曰。空性是常。见常故常也。不见常者。是无常也。僧宗曰。应言常上。作无常想。名不修空也。生死是空。佛果不空。若说佛果为空者。则失分齐。乖修空之道也。寿命短促者。所执既乖。不得妙常。岂非短促耶

无我我想我无我想(至)是名第三颠倒

案。僧亮曰。无佛性者。佛性无惑。故自在不断。惑故不应自在也。宝亮曰。有两阶。从初讫是名颠倒。先明前倒也。次从佛法有我以下。次明后倒也。虽说有我。无有佛性者。但计神我为我。不说佛性我也

净不净想不净净想(至)我等悉名邪见之人

案。僧亮曰。有两阶。从初讫是灭者是名颠倒。先明后倒也。次从不净净想。讫第四颠倒。明前倒也。迦叶白佛讫品。说四倒竟。迦叶领解也

    如来性品第十二

案。僧亮曰。答云何作善业。大仙今当说以广长寿金刚二果之因也。上略明因故。以慈悲护法为本。今广明因故。从三归终至十地也。法瑶曰。从此。讫若我住者。不离于苦。答云何作善业也。上四依以来。大意明行者。修善护法。是善业也。今明善业所由生者。即佛性。佛性是生善之理。理若无者。善何由生。是则佛性。是作善业之根本也。佛性是正因。善业是缘因也。僧宗曰。前品所明。解则为谛。惑则为倒。但解有微着。微则得生天上。着则名正解脱。今明善业。广其始。以难见性。广其终也。所以言广始解者。境中之妙。不过佛性。说此真境。生其下品闻慧。虽为微解。非不藉此生于胜行。终能见性。是故皆名善业义也。宝亮曰。佛性有四种。谓正因缘。因果及果果也。四名所收。旨无不尽。缘正两因。并是神虑之道。夫避苦求安。愚智同尔。但逐要用。义分为二。取始终常解。无与废之用。录为正因。未有一刹那中。无此解用。唯至佛则不动也。故知。避苦求乐。此之解用。非是善恶因之所感也。以胜鬘经云。自性清净心也。师子吼品云。一种之中道也。而此用者。不乖大理。岂非正耶。缘因者。以万善为体。自一念善以上。皆资生胜果。以藉缘而发。名为缘因也。然此解者。在虑而不恒。始生而不灭。则异于正因也。若无此缘。助则守性而不迁。是故二因。必相须相带也。若缘因之用既足。正因之义亦满。二用俱圆。生死尽矣。金刚后心。称一切智。转因字果。名为果性也。果果者。对生死之称也。于众德之上。更立总名。名大涅槃。以果上立果。名果果也。更无异时。但义有前后耳。若论境界性者。其旨则通。但同是缘助。不复别开也。下文佛自断为四名。谓单因单果。重因重果也。此品分为四科。初有五譬。先定因果性也。第二辨一体三归。劝学者。生信也。第三明三种中道。正谈作善业之行也。第四从难见性以下。仍答第十一问明自非穷照果理。无以彻见因也。智秀曰。此品有三段。第一显得作善业之义。第二明三归。第三约三种中道。以显慧行也

迦叶白佛言世尊二十五有有我不耶

案。道生曰。前云佛法中我。即是佛性。是则二十五有。应有真我。而交不见。犹似无我。教理未显。故有此问也。僧亮曰。将显真归自归未来身中三宝故。先定有无也。法瑶曰。若自审身中有常住三归。则理无异趣。可得勤作众善也。是故先辨有真我佛性。然后广明身中有三归之体。但应归此。而行善业也。僧宗曰。前言生死无我。计有我者。则名为倒。今问定有定无者。意谓。若定无者。则无佛性。若有者。不应言倒也。智秀曰。若生死之中。永无我者。则一化便断。云何而得作善业耶

佛言善男子我者即是如来藏义一切众生悉有

案。僧亮曰。夫如来藏。我及佛性。体一而义异也。具八自在。为我义。乘如实道。名为如来。以不改故。谓佛性也。悉有者。常乐我净。是佛性也。本由行也。有心求得。故因果不断。互得相有因亦有果。果亦有因。故言一切众生悉有也。僧宗曰。答问中有四段。第一寄五譬。辨性之有无。第二劝信。明迷则坠苦。解则资神。以理深难服。岂可不深生仰信耶。虽复仰信。若凭心失所。虽信无益。故劝行人。但归自身三宝。不假近舍自身。远归他佛。能如此解。是则标宗有地。案心得所也。虽复拟心有地。要须万行。趣常之要。事在中道。是故次三归后。明中道劝行。此即善业义也。宝亮曰。问云何作善业。而答之以正因者。欲明作善业者。必须先识因果。若指南不立。则善业不建。故先辨正因也。下频有五譬。正传明此理也。智秀曰。悉有者。悉有当成佛果之性也。以此义故。能令众生。生死相续不绝。得造善业也。昙纤曰。答问有二意。第一言有。第二言虽有而不见也。明骏案。答有两意。第一判有也。第二既云有。而所以不见者。有二理。一者明唯有不见之因。无有见缘。何者。以烦恼[雨/復]故。自无见因。既有惑障之法。佛不得为说。是以自虽不见。不伤于有也。说而不得其所。故言必成倒。下以五譬。备广斯旨也

佛性即是我义

案。道生曰。种相者。自然之性也。佛性必生于诸佛。向云。我即佛藏。今云。佛性即我。互其辞耳

如是我义从本已来(至)是故众生不能得见

案。道生曰。既翳成佛之理。又障见成之明也。僧亮释藏义也。僧宗曰。此理曾不暂无。但以隐显为异也。何者。夫解之与惑。二途而已。若乖理起惑。则生死纷纭。若扶理生解。则涅槃寂静。正以烦恼所覆。则隐而不彰。义称为藏。理非始造。不得言无。未有见用。不得言有。中道之说。则非病。若计已有。则成倒也

善男子如贫女人

案。道生曰。本有佛性。即是慈念众生也。僧宗曰。与有而不见作譬也。女性爱宝也。以不知处。故为贫也。众生愿乐不得所。故生死。法瑶曰。众生有成佛之理。理由慈恻。为女人也。成佛之理。于我未有用。譬贫也。僧宗曰。迦叶向问。使反覆成过。如来今譬。明二俱无患也。理如金藏。不可为无。未现用故。不得有也。女以能生为义。亦牧育为德。譬此行人。必怀常解。取能生之义。道兼未闻。取牧育之德也。宝亮曰。为譬之意有五。第一譬明六道众生。皆有正因。非是起始。第二譬释所以不得即说之意也。时人于此二譬。更生疑惑。谓若必不无应有现用。迦叶因为十一重难也。第三譬总答云。虽复性理不无。而失解起惑。流转生死。岂得现用耶。第四譬上虽已明先得而后失。未明既失而复得。又明众生之中。自有不曾得解。而经离六道者。若于此人。复何必为有。是以今譬广此二旨也。前明虽曾失而后得。次明正因不阻坏。是则经失之与未得。皆不无也。第五譬偏喻得者。明必成之义也。贫女者。譬一切众生也

舍内

案。僧亮曰。五阴相续。取其栖庇之义也。因果之理。不从外来。譬内也

多有真金之藏

案。道生曰。藏者。常乐之理。隐伏未发也。僧亮曰。得金藏者。必能富人。若见佛性。则成佛也。法瑶曰。身中佛性。理必孱然。如彼舍内宝藏之义也。昙济曰。备因果为藏也。僧宗曰。果上法宝。其德无穷。譬多有也。性理宝贵。取譬于金。为惑所隐。义称为藏。智秀曰。性理无二。随众生不一。故言多有也

家人大小无有知者

案。道生曰。共所安故。是为一家也。僧亮曰。凡夫譬小。二乘譬大也。法瑶曰。众生万品不同。为大小也。同居累内。为家人也。俱迷于理。为无有知者也。昙济曰。身有优劣。为大小也。僧宗曰。闻慧为小。修慧为大也。宝亮曰。旷举六道不知故。言小大也。智秀曰。佛法一家之中。凡是学人。佛未说故。谓不知也

时有异人

案。僧亮曰。譬佛也。出三界故为异人也。僧宗曰。佛也。取因果类殊为譬也。昙爱曰。已譬悉有。而不见也。从此下。譬所以不得即说也

善知方便

案。昙济曰。巧显佛性也。昙爱曰。有慈悲力也

语贫女言

案。昙爱曰。机感相发也

我今雇汝

案。昙济曰。遂我本愿也。僧宗曰。拟宜之辨耳。佛性是克期之物。是我分野。不容称雇夫。雇借所收。其利益少。今以无余涅槃。要其断结。小果所获。比常为鲜。如雇借也。众生自除惑而克果。而言佛雇作者。济苦既由乎大悲。虽复彼自断惑。乃至人之要务

汝可为我

案。僧宗曰。佛昔誓愿。尽拔众苦。苦尚不尽。则荷负未毕。若能皆度生死。则逐圣人之本愿。故曰为我也

耘除草秽

案。法瑶曰。先说无我除倒。我之秽而意之所在佛性真我此雇之义也

女人答言我今不能

案。僧亮曰。指偏修之时。道胜修应至不能习常也。法瑶曰。此义言耳。寄明众生。务存利。而无兼化之道。故曰不能也。宝亮曰。众常计常来久。一往不能信无常也。道慧记曰。未信之辞也。要当识有性理分明。然后乃能。自勤其行也

汝若能示我子金藏然后乃当速为汝作

案。僧亮曰。佛若为说真我佛性者。譬求己之金藏也。法瑶曰。拟宜众生。有此理耳。不言其意也。若审知其理。然后修善。如先示我。而后作也。僧宗曰。常机欲发。应为菩萨。则先人而后已。如示子之金藏也。既功在后已。则除惑之义显。取果弥疾。譬速作也。宝亮曰。夫机感小教。大机必熟。终得常乐义言示也。道慧曰。此喻智慧也。若能显示佛性。令得真解。乃能行行也

是人答言我知方便能示汝子

案。道生曰。所言雇者。必能示其金藏耳。僧亮曰。以三达四辩。必能广说也。法瑶曰。如来方便。先说无我。为令众生。兼济理通。理通由佛故。云能示也。慧朗述昙纤曰。子譬未来解也

女人复言我家大小尚自不知况汝能知

案。道生曰。犹是未信之言也。僧亮曰。同身事近。异身则远。近尚不知。况远者乎。法瑶曰。此言其今日。情违于理也。从佛所得。无我之智未明。犹尚不言有我。况佛见我之智圆了。而言有我耶。僧宗曰。若性是我性。我尚不知。岂况非我而知我耶

是人答言我今审能

案。道生曰。理不可没。唯我能知也。僧亮曰。有惑故虽近。而不知。无惑故。虽远而能见也。法瑶曰。此理唯佛能照。始可称审也

女人复言我亦欲见并可示我

案。僧亮曰。理说有旨。知其必自有故。喻彼自求见也。法瑶曰。应闻之机发。譬欲见也。感教由己。譬示也。僧宗曰。被物为先后。乃及己故。言亦欲见也。智秀曰。人我兼利。故云并也

是人即于其家掘出金藏

案。道生曰。除结惑之[雨/復]。为掘。见佛性故。为出金藏也。僧亮曰。偏说无常。常我自显也。法瑶曰。说涅槃之教。显明佛性。以示物也。僧宗曰。性不在他。惑除必见。义称于家而掘出也

女人见已心生欢喜(至)如彼宝藏贫人不知

案。道生曰。伏结仰信。名之为见。未是得也。僧亮曰。闻说佛性。发生微解。善业义也。智秀曰。应感不差。说必会机。喻之欢喜也

善男子我今普示一切众生(至)有真金藏不能得见

案。僧宗曰。合上而不能知譬也

如来今日普示众生(至)心生欢喜归仰如来

案。僧宗曰。合上掘出示之

善男子知方便者即是如来(至)真金藏者即佛性也

案。慧朗曰。重举譬对合也

复次善男子譬如女人

案。道生曰。前明除惑乃见。今明已经受化也。僧亮曰。譬佛也。女有养子之德。佛有慈护之道也。法瑶曰。大意为明昔所以不说。今所以说也。僧宗曰。此譬生前譬中。若果有而不无见者。如来出世。便应早说。何故。遂使众生起无常之倒耶。此譬与新旧医。言相似而意异。彼譬征二教之虚实。此譬咎佛何不早说也。略有五意。第一明过去久远。曾经常解。第二明背化失解。第三明善感释迦。为说偏教。第四虽说常教。而未信也。第五明重说乃断。渐信服也。女人譬过去佛也

生育一子

案。僧亮曰。等视众生。无二之喻也。宝亮曰。有漏相善生。由佛故。譬生育也。智秀曰。谓从佛口生也

婴孩得病

案。道生曰。禀化未浓。譬之婴孩。而为邪我所惑。喻之得病也。僧亮曰。第二失解譬也

是女人愁恼求觅良医

案。僧亮曰。病偏故须医。医病相治。谓如良也。僧宗曰。医之与母。随义为喻。取其长慧解之义譬母。治病之义为医。更无别旨寻觅者。伺其机发。而为治也。智秀曰。善扣法身。法身垂应。应身为医。喻如求觅也

良医既至

案。僧亮曰。可治之机发。在于此时也

合三种药苏乳石蜜与之令服

案。僧亮曰。说有为无常苦无我法。为三对治偏病之良药也。僧宗曰。第三说偏教之譬也

因告女人儿服药已且莫与乳

案。僧亮曰。常教之乳。养善子之法。说无我譬少。说我譬多。皆以乳为喻也。治由权道。譬之告也。以邪我未消。莫说法身是我也。僧宗曰。说常为实智。说无常为权智。于时唯得说权。未得说实。以权实相关义。言告耳。非是不与乳。但与时未至。故云且也。以权慧正说无常实慧。知时未至。不说于常。故云且莫也

须药消已尔乃与之

案。僧亮曰。三界我断。乃可说我。僧宗曰。重倒若除。治道亦谢也

是时女人即以苦味用涂其乳

案。道生曰。无我之教。非物所嗜。为苦味也。僧亮曰。无常无我。滥及法身。有名无实。譬以外涂。僧宗曰。应云医以药涂乳。而云母自涂者。取善养之义便也。又释为表母之与医。无异体也

语其儿言我乳毒涂不可复触

案。僧亮曰。爱染名触。身皆无常。不可爱染也

其儿渴乏欲得母乳闻乳毒气便远舍去

案。僧亮曰。厌患身苦。求无为之乐。闻佛无常。志不求也。法瑶曰。须常住乳故。譬之以渴。此就理为言也。起无我故。背我教而不受。譬之舍去也。此言情也。僧宗曰。计常之习既久。时复欲起。如渴乏也。常名本自于佛。虽是倒执。犹从佛得故。言母乳也。但偏教之切转明。倒心欲起不得。喻之舍去也。又释虽闻偏教之旨。如有归真之理。而偏教既切。圆解不得时发。如闻气故舍去也

至其药消

案。僧亮曰。邪我既断。便是可说真我时也。僧宗曰。第四譬说圆教也

母乃洗乳唤子与之

案。道生曰。今说常我。判二教之分明也。僧亮曰。是可说之机。即为唤子之义也。法瑶曰。常教既兴。无复滥佛之惑。义如洗乳也。宝亮曰。诠常之教如水。所诠之理如乳。义洗也

是时小儿虽复饥渴先闻毒气是故不来

案。僧亮曰。执先偏教。不信后说也。僧宗曰。具如开宗所说

母复语言为汝服药(至)汝便可来饮乳无苦

案。僧亮曰。如新旧医譬也。僧宗曰。第五譬。重显今昔之旨也

其儿闻已渐渐还饮

案。法瑶曰。顶奉今说。无复昔执之谬也

善男子如来亦尔为度一切(至)为除世间诸妄见故

案。僧亮曰。三界虚妄。计之为我。是名妄见也

示现出过世间法故

案。僧亮曰。识其虚妄。即出世间也

复示世间计我虚妄非真实故

案。僧亮曰。释初句麻米之我。理中所无也

修无我法清净身故

案。僧亮曰。释第二句也。僧宗曰。上来至此。略合苏乳等三种药譬也

譬如女人为其子故(至)说言诸法悉无有我

案。僧宗曰。重举第三譬。又合也

如彼女人净洗乳已而唤其子欲令还服

案。僧亮曰。举第四譬也

我今亦尔说如来藏是故比丘不应生怖

案。僧宗曰。合洗乳譬

如彼小儿闻母唤已渐还饮乳

案。僧宗曰。举第五譬

比丘亦尔应自分别如来秘藏不得不有

案。僧宗曰。合从教也

迦叶菩萨白佛言世尊实无有我

案。僧亮曰。上说众生有我。我即佛性。夫有有二种。现在有。当来有也。而有义未分。须以十一事为难。以难现在之有。成当有之旨也。法瑶曰。家中宝藏。以譬众生有大明真我。在其中中矣。迦叶知众有疑。乃设难云。便应已有果性之用

何以故婴儿生时无所知晓(至)以是义故定知无我

案。僧亮曰。皆责现用也。僧宗曰。我以自在为义。而婴儿无知。无有照用。是知无我也

若定有我受生已后(至)是常住者应无坏相

案。僧宗曰。自在者。不应无常也

若无坏相云何而有刹利(至)定知佛性非是常法

案。僧宗曰。举报不等。以证无自在也

若言佛性定是常者(至)妄言绮语贪恚邪见

案。僧宗曰。明因不正。故知无我也

若我性常何故酒后荒醉迷乱

案。僧宗曰。前句明若有我者。不应内心起恶。此句明若有我者。不应随外缘所转也

若我性常盲应见色聋应闻声哑应能语拘癖能行

案。僧宗曰。前明不应因中造恶。此明不应受此恶果

若我性常不应避于火坑大水毒药刀剑恶人禽兽

案。僧宗曰。若有所畏。岂谓自在耶

若我常者本所更事(至)我曾何处见是人耶

案。僧宗曰。有我则常忆。岂应忘耶

若我常者则不应有老少盛衰忆念往事

案。僧宗曰。前诸句悉据心。此一句举色也。若自在必常。心云何而忘也。色云何而变也

若我常者止住何处为在涕唾青黄赤白诸色中耶

案。僧亮曰。上来穷捡理极。今责住处。若不偏在一方。便应遍在众处。此先一一处。以捡其无也

若我常者应遍身中(至)若断身时我亦应断

案。僧宗曰。偏在之无。事已如上。假令遍有。则同麻米。岂曰自在。复云常耶

佛告迦叶善男子譬如王家(至)其人眉间有金刚珠

案。道生曰。明非不有。而非己有也。以智慧之额。致真我之珠也。僧亮曰。答难也。明佛性虽有。于见者成解。不见者成惑。不可言有。故便责现用也。如彼眉珠。显则严身。隐则成病。不可以珠在身故。常责其好。此总答诸难。下更别有譬也。王譬佛。力士譬行人。珠譬解也。佛说因果之性。闻者受解。解圆可责。如在眉间也。法瑶曰。信解佛性中道不偏。犹如眉间之处中也。信知佛性。必为己用。犹彼眉间有此珠也。僧宗曰。此譬意明非无常性。但为惑所映。不得现用。不可以现在未用。便令都无也。此譬有五重意也。第一明过去曾禀圆解。第二明生死流转。遂失本解。第三明虽失本解。善力所感。圣则出世。说偏教也。第四明常机始发。为说圆教。第五重为解释。然后乃信也。旨要所归取。第二失解起惑譬也。明惑滞生死。障于慧目。不得现用。不可言永无也。王家者。家谓处也。言佛化所被之所也。力士以伏强敌。故称大也。所化行人。终摧大恶。如力士也。金刚珠者。明中道信解。能破颠倒。譬之金刚也。宝亮曰。譬有四意。第一生解譬。第二失解譬。第三后佛出世。说偏教也。第四说圆教也。珠者。通取因果六行理解。合为譬也。智秀曰。分此譬为二段。始说忧愁啼哭。明其先解而后失。次从慰喻力士。讫譬。明后佛重说。还得解也。前段中有两阶。此即第一。正明昔日得理解中道信心时也

与余力士较力相扑

案。僧亮曰。邪我于正解。为余也。正解未坚。而与强邪诤辨。喻之较力也。僧宗曰。此第二失解譬。明解微见浅。而起重惑。经离生死也。岂得闻有。而便使现用。现用既无。便谓永失耶。余力士者。喻无明心也。解有摧惑之义。取譬力士。惑有过解之工。亦称力士也。较力者。闻慧未明。而我心时动。解惑相交。喻如较力也。智秀曰。相扑者。互有倚伏之喻也

而彼力士以头触之

案。道生曰。无明为众结之首也。僧亮曰。我见是众结之首。故云以头触之也。僧宗曰。圆解以正信为首。邪心以不信为头。信为不信所侵。如二首相触之

其额上珠寻没肤中

案。僧亮曰。受屈于邪。言谓之没也。有名无实。譬之肤也。法瑶曰。正信微浅。不能自固。遂同说耶见也。僧宗曰。信为不信所陵。圆解则隐也。宝亮曰。佛弟子。以相心说无相。理既无相。幽而难显。外道以相心说相。理则易安。经生死久。遂失本解。逐彼邪计故。言没肤中也。道慧记曰。所以言肤中者。明非永失。寻发不久也

都不自知是珠所在

案。僧亮曰。以邪我为真。不觉失真我也。法瑶曰。以耶惑之首。坏正信之额。正信既破。岂知有佛性耶。虽不知有。而至理孱然。如珠没皮中也。僧宗曰。既超横常之见。则失本所解也。若识常在果。则安得其地。便有所在。既乖其所解。心无常故。云不知所在也。宝亮曰。得失之理。既非所悟。故云都不自知也

其处有疮

案。僧亮曰。以失真我。而成惑倒。倒致生死之苦也。法瑶曰。破正信故。有不信之疮也

即命良医欲自疗治

案。僧亮曰。生死苦切。解缘还感。悟时已至。机来扣圣。命医之义也。僧宗曰。第三譬也。应感道交。有召命之义也。宝亮曰。众生有善有苦。二缘感佛见佛。则能灭苦。故言疗治

时有明医善知方药

案。僧亮曰。医譬佛也。善除八倒。譬知方药也。僧宗曰。即释迦治惑病。故称医。了达经教之方。妙穷渊旨之药

即知是疮因珠入体

案。僧亮曰。缘失解成惑。致有生死也。僧宗曰。医见疮故。知因入体。佛见众生流转五道。知由横起妄常之计。失于本解也

是珠入皮即便停住

案。僧亮曰。知非久失。故曰停住。法瑶曰。佛性之理。终为心用。虽复暂为烦恼所隐。如珠在皮中出不久也。僧宗曰圆解之理。无时暂绝。乃可事有废兴。其理常存。如停住也。宝亮曰。虽复失解于当时。而本机犹不丧也

是时良医寻问力士卿额上珠为何所在

案。道生曰。为说无我。即是表有真我也。僧亮曰。知其不觉失本真我。譬问其所也。法瑶曰。为说无我时也。僧宗曰。说偏教也。横计常见。为失之矣。但常我同失。失名不显。如来出世。为说偏教。夺其邪我。推求所计。知其为谬。失义始彰。如彼力士失珠。虽久不自觉知。医问乃知也。宝亮曰。所以为说无常意。欲申其本解。喻如彼问本珠何在

力士惊答大师医王我额上珠乃无去耶

案。道生曰。不觉失时。闻问乃惊。以漫说谓失。答云如此耶

是珠今者为何所在将非幻化忧愁啼哭

案。道生曰。即谓失之。应求所在。遂谓不存。以为幻化也。僧亮曰。推折五阴。无所得也。化者。计一切法皆空也。啼哭者。悟一切法。唯是八苦也。法瑶曰。学无我观深故。乃至谓不知真我所在也。智秀曰。虽闻偏教。一往未伏。譬惊答也。终信今旨义。言我珠。乃无去耶

是时良医慰喻力士汝今不应生大愁苦

案。道生曰。以其遂谓不存。乃说我以悟之。既理显身中。亦是语知显也。僧亮曰。第二譬也。法有不空。亦有常我。不如所见一切苦也。僧宗曰。第四譬也。依教而行。已断重倒。今常机且发。解释佛果。所以为常。此是物情所安。如慰问也。宝亮曰。此下第四。譬众生根熟。堪闻常住。即涅槃经教。为慰喻之辞也

汝因斗时宝珠入体今在皮裹影现于外

案。僧亮曰。今日之说也。明先时之解。重惑暂迷。昔缘潜发。譬影现于外也。僧宗曰。虽复失解。而理不亡。当时虽复为惑所隐。然其一念之力。必力必牵极果。冥相感召。不得相无。如珠虽在皮裹。而影显于外也

汝等斗时嗔恚毒盛珠陷入体故不自知

案。僧亮曰。谓常解之因犹存。悟在今日。自不知耳。宝亮曰。起惑失解。为毒重故。不自知也

是时力士不信医言(至)汝今云何欺诳于我

案。道生曰。执失不信今说也。僧亮曰。皮里浅近譬现在也。现在有为。唯苦不净。岂见佛性用耶。筋裹深远。以譬未来。以不可见故。明其无也。法瑶曰。佛性清净。若在颂恼之中。则不容尔。若在善中。未有善时。则无佛性。不应可见也。僧宗曰。近是迦叶十一翻难也。宝亮曰。不异前新旧医譬中。诸比丘不信常之辞

时医执镜以照其面珠在镜中明了显现

案。道生曰。智慧之镜。从佛而得。如医执也。僧亮曰。镜以表像。譬圆教也。面有双目。以譬二慧。性在文中。显现了了。如有眼之人照镜中之像也。法瑶曰。唯一往于言。未能即信。若得真解之镜。乃证知也。解从佛得。如医执镜也。僧宗曰。第五譬也。珠虽映彻。皮[雨/復]不知。要须净镜。照之乃见。将明言以诠理。理由言显。如珠现于镜中也。宝亮曰。镜即涅槃教也。面譬众生心也。明骏案。镜即指此譬也。面譬信也。理之与解。左右为喻。同譬珠也。虽未在已。而信解可得。既因譬获悟。如面睹明镜。分明见影。此譬是佛所说。故言医执镜也

力士见已心怀惊怪生奇特想

案。法瑶曰。受教之徒。闻见佛性。方生信解。身中乃有此之胜理。生奇特想也。僧宗曰。解生意表。如惊也。贵重所悟。奇特想也

善男子一切众生亦复如是(至)唯有佛性皆不能见

案。僧宗曰。合失解譬也

而为贪淫嗔恚愚痴(至)愚痴[雨/復]心不知佛性

案。僧亮曰。合初譬也。僧宗曰。合其处有疮也。[雨/復]心者。合都不自知。是珠所在也

如彼力士宝珠在体(至)况复能知有我真性

案。僧亮曰。合第二譬也。僧宗曰。修学无我者。合上乃无去耶。不知我真性者。更合第二譬也。不知无我处者。还道偏执。所修空观。非就善友。习学所得。故非善解也

善男子如来如是说诸众生(至)如是无量不可思议

案。僧亮曰。合第三譬也。僧宗曰。合第五执镜譬也

大般涅槃经集解卷第十八大般涅槃经集解卷第十九

  雪山一味药譬　释佛性五阴中而无失坏　释方等经如甘露毒药　广论三种三归。一者阶梯。二者一体。三者自身未来佛性

    如来性品之第二

复次善男子譬如雪山

案。道生曰。不从佛说而计者。乃更反成其惑也。僧亮曰。上已总答十一难。而佛性不坏。其义未显。又前譬云。珠陷入体。似佛性可坏。今以此譬。明失解所由。佛性不可破坏也。雪山譬五阴身也。法瑶曰。譬众生也。僧宗曰。前譬明起惑乖理。不得现用。此譬明若欲取者。有方则得。乖方则失也。雪山譬金刚。以下因地之神明也

有一味药名曰药味其味极恬

案。僧亮曰。药譬佛性。甜譬常乐也。僧宗曰。见佛性者。治生死之病。譬之药也。乐味者。味体非乐。能生人乐。佛性非乐。会之者出苦。故譬之乐味也。极甜者。甜味则为人所嗜。佛性之理。有识所甘。喻之甜味也。智秀曰。一味者。佛性之理。无生灭之异也

在深丛下人无能见

案。僧亮曰。九住已下。不能得见也。法瑶曰。以烦恼[雨/復]故。虽有佛性。众生不见也。僧宗曰。无有十地慧目。所以不能见也

有人闻香即知其地当有是药

案。道生曰。菩萨说无我之教。表如来真我。譬闻香也。僧亮曰。譬十地菩萨。闻佛说已。能见少分。明性理幽远也。法瑶曰。行者闻说。知烦恼之下。有佛性也。僧宗曰。有谓得闻慧之解也。虽无十地慧眼能见。然信教生解。必知有也。智秀曰。譬过去佛始时微知。如彼闻香。知当有药终能修行。得成佛果也

过去世中有转轮王(至)造作木筒以接是药

案。道生曰。往古诸佛。说无我法。无我之理。如彼木筒。有外无内也。僧亮曰。王譬佛也。唯佛能见能说者也。筒譬圆教也。法瑶曰。明过去佛教。唯复非一。皆表于性。如造木筒。以接药也。僧宗曰。王通譬先佛。若近取者。则迦叶佛也。王欲求药于山故。处处造筒。以接之也譬迦叶世尊。在凡夫之日。备修万行。以求佛果也。宝亮曰。山譬五阴。筒譬经教。处处者。譬十二部也。明先佛欲于众生五阴。得常我性故。说十二部经也。虽说无常。皆为得常。中道之理。故云以接是药也。智秀曰。万行如筒也。行由身起。譬处处造也

是药熟时

案。僧亮曰。闻说领解。无有差谬。以申眉间珠也。法瑶曰。佛性应流通之时。谓显著为熟也。僧宗曰。因力满足。如药熟也。宝亮曰。谓成佛之时也

从地流出

案。法瑶曰。性显著故。出乎烦恼之表也。僧宗曰。因满果现。为佛眼所照也。宝亮曰。因果之理。不出于身外。而明五阴之中。即有者也

集木筒中

案。道生曰。常我之理。应万行之时。义味悉在于经文矣。法瑶曰。佛性理味。备之经教为集也。僧宗曰。果来应因为集也。宝亮曰。显在经教之中也

其味真正

案。僧宗曰。佛性之理。不与伪物同体也。宝亮曰。常理为圆教所诠。为真正也

王既□已其后是药(至)随其流处有种种异

案。道生曰。佛涅槃后。寻研经教。偏执其义。于一味之理。随说成异。取义既偏。受身殊别也。僧亮曰。取解未纯。佛灭法离。人生异解。起种种见。受果不同。以申失解之苦也。法瑶曰。佛涅槃后。各师偏见。故说佛性。种种不同。随其偏执。则受身有殊。如药流处有种种异。僧宗曰。佛性理一。以人执不同。遂有九十五种。既造邪因。受四恶果。如种种味也

是药真味停留在山犹如满月

案。道生曰。不以取之有偏。正理遂坏。不以受身不同。使真我断也

凡人薄福虽以掘凿加功苦至而不能得

案。僧亮曰。虽生异见。不能毁真。圣与凡绝。常乃得显。不坏义也。法瑶曰。见虽异涂。不变佛性。受身不同。佛性不改也。凡夫偏执。虽复竭思。终不能得见正理也。僧宗曰。不与伪杂。为真性也。必在于人。不可迁转。如停留也。圆明不偏。事同月也。凡夫薄福。不能得者。无慧以自修。虽加苦行。如持牛戒。自饿等法。去理逾远。若是伏欲。得无想定。及非想定。计为涅槃。亦为乖方。故言虽复加苦。不能见也。六卷云。理筒不深。言不发无漏也

复有圣王出现于世以福因缘即得是药真正之味

案。僧亮曰。重证不坏之旨也。僧宗曰。即释迦也。言前佛灭后。取之得方者。得也。但众生薄福。求之乖术。直有违不违异。此理常然也。宝亮曰。后佛出世。即得如是中道之解也

善男子如来秘藏其味亦尔(至)无明众生不能得见

案。僧亮曰。合初譬也。僧宗曰。合深丛下。无能见者也

一味药者譬如佛性(至)刹利婆罗门毗舍首陀

案。僧亮曰。合第二譬也。僧宗曰。合种种味也

佛性雄猛难可毁坏(至)一切无能毁坏烧灭

案。僧亮曰。合第三譬也。僧宗曰。此语偏主第十一难。难云若断身时。我亦随断。合答言。不离因地神明而有。故言有耳。岂可责令与阴为一。枝阴灭我断也。宝亮曰。明正因之性。体性不可改变。故无能杀害者。生死血肉。是偏因所感。可得损伤。正因之性。天然非因所生。故不可坏

虽不可坏然不可见(至)以是因缘无能杀者

案。智秀曰。总结上也

迦叶菩萨复白佛言(至)应当无有不善之业

案。僧亮曰。承上语势。有此问也。若性不可杀。似应杀生无罪也。僧宗曰。此难意。欲令解释以不离故。言有耳。非为已有与阴一也

佛告迦叶实有杀生(至)差别之相流转生死

案。道生曰。虽坏五阴。无损佛性。伤五阴故。名曰杀生。不可以佛性无损。谓无不善业也。僧亮曰。因不离果。故言住也。五阴相续。或天或人。人天阴异。此死彼生。故可坏也。皆求乐净。此二不殊。故不可坏。佛以乳毒为譬也。僧宗曰。释所以虽有杀生。而佛性无损也。何者。夫因果之道。义实相关。有因则有果。无因则无果。正以佛性。不离因地神明。故言住阴中耳。岂得责使已有一法。与阴为一。不可伤耶。所以有杀罪者。以五阴是有为相续之法。力为断缘。具四因缘。故有杀罪。罪从断阴边生。不可令阴断。故性亦俱伤。性是常故。阴亦不可坏也。敬遗记曰。住五阴者。依于此身。修缘因之善也。神明为正因。有发生之义。今断此相续。则资生之义废矣。废则取果之义赊。今以因中说果。故言住也。以断五阴相续之义。隔善不生。故得杀罪。非是直以断形质故。成杀罪也。是以供养阐提无福。杀亦无罪也。言得罪者。直以恶心得耳。非隔阴故也。宝亮曰。若论无常虚伪果报。彼生此死。岂当有罪。今得罪之缘。别有以也。若无恶心。及伤田者。都无有罪。下文曰。若杀蚁子。尚有罪报。杀一阐提。则无罪也。明知得杀罪者。一由恶心。二由伤田。彼人之善应相续生。断其命故。不得相次而生。所以得罪。非直断命。而招殃也。佛性住五阴中者。此举缘因佛性也。夫行道成圣。因此阴身。既断彼命已。善不得起也。欲谈罪福之相应。就此义论矣

非圣之人横计于我(至)妄想之相无有真实

案。僧亮曰。凡夫横见。是五阴之因。因虚果伪。所以可坏也

出世我相为名佛性如是计我是名最善

案。道生曰。虽复受身万端。而佛性常存。若能计此得者。实为善也。僧亮曰。佛从性起。性理不变。因实果真。所以不坏

复次善男子譬如有人善知伏藏

案。道生曰。譬横计于我。自以为善知也。宝亮曰。菩萨知此圆理。隐众惑之下。如伏藏也

即取利钁

案。道生曰。以邪智。破柝诸阴也。僧宗曰。谓智力也。宝亮曰。修万行也

掘地直下

案。僧亮曰。菩萨以智慧力。断烦恼也。宝亮曰。观五阴也

磐石沙砾直过无难

案。僧宗曰。所受阴果。皆是慧之所除也。宝亮曰。谓断烦恼也

唯至金刚不能穿彻夫金刚者所有刀斧不能破坏

案。道生曰。佛性不为邪见所穿掘也。僧宗曰。譬佛性也

善男子众生佛性亦复如是(至)是不可思议也

案。僧宗曰。今譬明佛性不可坏也

善男子方等经者犹如甘露亦如毒药

案。道生曰。经教虽以悟物。要当从之者悟也。是以于悟者。为甘露。乖之者。为毒药也

迦叶菩萨复白佛言(至)譬如甘露亦如毒药

案。僧亮曰。请广其义也

佛言善男子汝今欲知如来秘藏真实义不

案。僧亮曰。语寄迦叶。以诫众也

迦叶白言我今实欲得知如来秘藏之义

案。僧亮曰。已说我者。即是佛性。自身有之。便应自归身中三宝。必得常乐。成善业之义也。僧宗曰。第二段也。相生明性。有而是常。乖则为隐。长处生死不违。则显永升常乐。斯则起信之所由。事在于此经。若欲求诠以入理者。岂不得于常住方等。深生信哉。前唱善业。已启其萌。今劝深信长于前解也。宝亮曰。第二段也。劝信一体三归也。又开为十章。第一将说三归。先劝虚坏。若执著者。则乖法相矣。第二明若从四时之教修学。而来闻今所说。成忘怀之人也。第三将说此理。故劝励时众。应效此人。而用心也。第四正说三归。第五明时众。于此极说之理。未能即信。故迦叶还请也。第六佛还更说如此三归差别之相。第七迦叶领解未来一体三归。第八还劝行人。令此时众。发于大志。第九迦叶自劝行人。发迹而行。第十佛还赞成所说之理也。甘露譬常住理。若作不有不无。虚心而缘。即成甘露。若介然有存。是即断常。既不称乎。中道即于此人。而成毒也。此中有四翻。第一佛唱此旨。第二迦叶求解释。第三佛还更问审闻不。第四迦叶重请也。智秀曰。第二段也。上明佛性即我。此既不有善业得与。与善之始。莫过归信。故此一章。先劝依自身常住三宝也。开为七章。第一约人。以褒贬于经。第二正劝。依自身如来之藏。第三说其不解。请求重释。第四佛为广说。詶其请意。第五迦叶领解。以立双归。第六佛即述其今解。戒其先非。第七迦叶发迹以遣疑。讫不生亦不死也

尔时世尊而说偈言(至)或有服甘露寿命得长存

案。僧亮曰。此明修不得时也。如昔鹿园拘伦闻之。反增常见。夭慧命也。今日修之。则得法身也。法瑶曰。此偈明俱寻常典。得旨则命长。失旨则早夭也。僧宗曰。若依教信行。则得不死。如彼甘露。若违则失旨。成毒药也。师说不同。解释亦异。自有一释云。即以圆教之性。为毒药也。此则不然。非唯劝信义失。乃有贬经之过也。此中先举外譬。欲显明经性非是毒也。如世甘露。本非毒药。直以人不能消。义称为毒耳。将明圆教。于倒解者。则伤夭而失。非经也。智秀曰。将欲显理。先约愚智。褒贬经文。初一行半偈。先出服行之人。有能不能。次一行。显出药体。次四行。重举譬也。明药虽是一。而有两异。正由愚智二人。得或成毒成药之义也。直言甘露。未知其旨。次后一行。正释其义。明令人成佛永毕不死之旨也。慧诞曰。将欲劝人见性。以成善业。故先明经旨也。何者。常住之义。永尽生死。其犹甘露。以伤谤法四品。或人义如毒药。若能深识二义。即三归业成。如服甘露而长生。饮毒药而不死也。若不识者。三归不成。如服二药。而致终也

或有服毒生有缘服毒死

案。僧亮曰。譬无常之三宝也。昔日归依。于此则得慧命。今若归者。谤佛法僧。慧命断也。此偈明俱寻无常之教。若得旨则慧命生。失旨则慧命断也。又一义。大乘常典。于智者为甘露。于愚者为毒药。愚者服智者之甘露。而早夭。智者服愚者之毒药。则长生也。僧宗曰。向举譬以明圆教。今举毒譬以显偏教。将明教性是不了。生人倒见。毒义明矣。乃可依经断结。别是一用。所言是毒。不在此也。宝亮曰。更显方等成毒不成之意也。有四品人。谓两师各教二弟子。何者。或服甘露伤命。此第一人。虽复咨受善师之法。不能忘怀取旨。若于此人。则成毒也。或服甘露。得长存者。此第二人。称师所教。而得旨故。成甘露也。或有服毒生者。此第三人。虽从不善执相之师受学。而能称理虚解。故虽是毒而不死也。或缘服毒死者。此第四人。已从不善师学。复不忘怀。齐言取故。谓服毒而死

无碍智甘露所谓大乘典如是大乘典亦名杂毒药

案。僧宗曰。前举譬。此合譬也。亦名毒药者。于人不消。亦有毒义。能服行者。念由于信。劝信明矣。智秀曰。显出药体也

如苏醍醐等及以诸石蜜(至)服之则成毒

案。僧宗曰。前举甘露。其旨略显。更引美譬。彰其非毒。下明愚智两人。其义顿晓也。宝亮曰。有识甘露者。未几复引五味喻也。智秀曰。此下四行。第三意重举譬者。显药体是一。而随愚智为二也

声闻及缘觉大乘为甘露(至)成人中象王

案。僧亮曰。邪我已断。应知真我是甘露也。僧宗曰。向举愚智。未有所蠲。事须分别。今言二乘圣人。若闻圆教。必能服行。此人为甘露也。故知凡夫不能信行。皆为毒药矣。宝亮曰。第二出成甘露之人也。明昔三乘。于今闻说一体三归。尽成甘露之用也。如是劝进者。明依大乘。而修行者。成人中象王也

众生知佛性犹如迦叶等无上甘露味不生亦不死

案。僧亮曰。释成甘露也。以迦叶所知。与众生作法。举所知之事。即不生不死也。宝亮曰。第三戒劝也。明迦叶已知。若众生能如迦叶者。必得不生不死之果也。智秀曰。第四释义也。明所以令人成佛者。以永毕不生不死故也

迦叶汝今当善分别三归如是三归性则是我之性

案。僧亮曰。自在者。是我义。无师自悟者。是觉义。无有非法。是法义。众法和合。是僧义。此四者。体一而名异也。僧宗曰。第三段也。上虽劝信。要令安心有所。故劝分别善识真伪。舍昔伪三。凭今真一也。此则域情无谬。发轸则趣之要道也。就此辩三归中。可有五章差别也。第一以三偈半。一往直劝归真三宝也。第二有十偈。迦叶怀疑。未受今说。第三有四偈半。更为开释。洗彼二疑。第四有四偈。迦叶更执也。前有三疑。滞在有无。而闻释洗也。今真伪未了。便欲两归。第五说长行。更为解释梯橙之意。虚实之旨也。善分别者。分别昔归为权。今归为实也。则我性者。不假舍我自身。而归彼佛也。宝亮曰。下有三偈半。正明三归相也。一往且令舍昔三归。及释迦一体三归。唯劝自归未来身中一体三宝。若此心一立。则三种三归。悉皆成就也。善分别者。别相三宝。与今释迦一体三归。皆不免过。何者。以丈六为佛。以十二部经为法。以三乘圣众为僧。而魔所化形。所说邪法。行魔法者。亦可归依。并是形骸中取。何得免滥耶。若就释迦一体三归。亦不免过。何者。以丈六为迹。法身为本。约本取迹。如为小胜。然同是形骸。魔亦能尔。岂容得免。法僧二宝。亦复如是也。唯自归依我未来身一体三宝。此无失谬。非唯免过。乃成三种德也。一者识前两时所说。三归之失。验归未来为是。既安心有在。岂畏魔来乱其正解耶。二者既有正智。心用则旷。审明金刚心后。真实一体三归。必是我宝。含识众生。理与我同。莫问成佛近远。皆可归凭也。三者既判此宝。审属于我。则明鉴因果。无八倒之惑。何者。此人理然识佛地是常。生死无常。亦何行而不建耶。三心既立。三过又除。所以劝人分别三归。旨在于此也

若能谛观察我性有佛性当知如是人得入秘密藏

案。僧宗曰。性理不殊。正以隐显为异。若舍我归彼。是则弃本从末。非谓真归。是以劝令深识自身当果之生。此识既审。则无始造之滞。终成之惑也。宝亮曰。我性者。是因性也。有佛性者。谓果性也。必有如此解者。审入秘密藏也

知我及我所是人已出世(至)其性义如是

案。僧亮曰。已归未来身中三宝。进行趣极。名知我也。我所者。法僧也。此四体一而义异。佛与我义。义一而名殊也。宝亮曰。知我者。是我未来性也。我所者。谓十地之行。是我所应行也。若能如此知者。已是出世之人也

尔时迦叶复说偈言我今都不知归依三宝处

案。僧亮曰。已舍次第三归。欲归未来三宝。而未来无兆。故不知所归也。法瑶曰。三宝既有真有伪。今欲归之。而作善业。但不知真。者之处也。僧宗曰。昔劝归别。今劝归同。二教相乖。云何取信。故言不知所归之处也。宝亮曰。此下第五段。时众既闻上说。心尚未解。故迦叶今者。一往悉不肯受。何者。我昔所归别体三宝。佛已不听。次归释迦一体三宝。又言不免有过。且释迦一体三归。有而无相也。众生闻无则执断。闻有则执常。以是难立。今又令舍归我未来一体三宝。而未来都无相貌。云何可得立心而归耶

云何当归趣无上无所畏

案。僧亮曰。即辨三宝也。宝亮曰。问意云。若为归三宝得趣无上无畏之地耶

不知三宝处云何作无我

案。僧亮曰。若未来真我。观三界无我者。可以归也。若不能知未来之我。而观无我。何所归耶。法瑶曰。三宝即前我也。无我即前我所也。我所即善业也。夫作善以求常住。要须识真我。三宝以修其业。则常住可得而就也。既不知者。居然不得所作之善也。故曰。云何作无我也。僧宗曰。若既不知真实三宝处者。云何修无我劝行。厌离生死。而起之耶。敬遗记曰。既不知真宝三宝。云何昔教。乃劝令修无我观耶。宝亮曰。既不知归三宝。云何作无我观。而修行也

云何归佛者而得于安慰(至)转得无上利

案。僧亮曰。佛能除畏。故言安慰也。法能断疑。故言自在。僧是福田。故曰无上之利。随义配之。上总此别也。法瑶曰。前推问三宝之处。今问归依之义也。归佛得安慰。归法得自在。归僧得上利。各举一义耳。而归三宝。皆有此义也。僧宗曰。此二偈者。正是真伪之疑也。今云何归佛者。为昔归胜。为今归胜耶。云何得自在者。昔令归法。具四非常。是不自在。今曰归法。具八自在。为何教是实耶。归僧无上利者。昔令归僧。取行法之人。今日之僧。取万德不违之义。定何僧可依。转我善业。得无上利耶。宝亮曰。云何归佛者。谓为归之方法也。归法归僧。亦如此也

云何真实说未来成佛道未来若不成云何归三宝

案。僧亮曰。佛是真实说者。今可仰信未来成佛也。然因能成果。具缚凡夫。未有其因。未来必不即成。云何归依未来三宝耶。法瑶曰。此下三偈半。明因时。亦有三归之义。若知身中有三归之义。归而修善者。即果地三归者也。以此引物。修善劝发。及作善业之义。义在于此耶。僧宗曰。此下六偈半。有无疑也。佛上劝我。归依自身未来佛性。由有性故。事未在我。前兆难知。寻佛向语。为是真实。为非真实也。未来若不成者。虽言成佛。理不必尔。脱当不成。则为徒生归心也。宝亮曰。云何真实说者。愿佛真实说我未来成三宝之相也。未来若不成者。若归未来成佛心不立时。云何名作归依三宝耶

我今无预知当行次第依

案。僧宗曰。为未在我。难可预知。不及还归昔教次第依也。宝亮曰。明未来三宝。难可预知。今当谨依圣教。是佛之说。悉次第而归也

云何未怀妊而作生子想(至)众生业亦然

案。僧亮曰。无因而计果。其事如是也。僧宗曰。夫有子在胎。故称之怀妊。终期必在十月也。若得十地无漏。可譬怀妊。今悠悠凡夫。去果辽邈。未有信善。而说有果。事同都未怀妊。作生子想也。宝亮曰。下三行寄譬。以结未来三归之难。后余二行。更请说真归也

如佛之所说愚者不能知(至)秘密之宝藏

案。僧亮曰。若不知而归。则不成归。故久在生死也。假名优婆塞者。三归不成。岂是真实也。智秀曰。上来十行偈。第三章明今昔三宝。旨深难晓也。迦叶现迷。故陈其不解。请佛重释也。初有三行半。申其即曰。于两教并迷。谓无我观行。不得成就也。有两意。初一行半。正申不知归依之相。及无我观不成。次二行。举昔偏教。以反质也。云若今说是者。昔日何故作是说耶。第二有五行偈。审佛真实之说。用资未来佛也。有两意。初半行。正推求实说之相。恐佛不即显示。以此感佛意也。次四行半。举四失。以要佛必使示其相也。谓四失者。初一行明若不审佛。则无未来可归之过。上半明若不审佛。则未来佛不成。云何有三宝可归耶。既无来佛可归。即下半行结云。无有来佛。为归心之境。可为次第依也。若无依而说有。理不可然。次三行半。广显其失也。第三有一行半。请佛说也。始半行直请。次一行称德而请也

迦叶汝当知我今当为汝善开微密藏令汝疑得断

案。僧宗曰。第三段也。先释有无之疑。次释真伪之疑也。佛性为烦恼所隐称藏。除惑即见。故称开也。宝亮曰。此下有四行半偈。第六段。佛更重说未来归依之胜相。初两偈。且许说而赞叹。次有两偈。正辩真归。后半偈。结今归之真胜也

今当至心听汝于诸菩萨则与第七佛同其一名号

案。僧亮曰。释迦是第七佛也。谓汝之未来法身与我同号。但时有差别。作如是名耳。僧宗曰。贤劫中之第七佛也。非但名同。十号亦等。若尔则来果孱然。疑则断也。慧朗曰。本起经注曰。释迦为能。文为儒。义言能儒。此美迦叶有弘法之功也

归依于佛者真名优婆塞终不更归依其余诸天神

案。僧亮曰。释归佛义也。僧宗曰。此下释真伪之疑也。言昔令汝归别体三宝者。以代邪归。岂是实耶。终不更归天神者。外道杀生祠神。以求心愿。令归丈六。以代祠神之迷。借近以接愚。非谓至极也。归我来身一体三宝。事无乖谬。岂畏有归天神之虑耶

归依于法者则离于杀害

案。僧宗曰。外道九十五种。多以杀为事。今使依十二部经。移其心操也。宝亮曰。若金刚心后。体无非法。则无俟于此依也

归依圣僧者不求于外道如是归三宝则得无所畏

案。僧宗曰。秉正解。以示人善道也。为代此三邪。故说三归。非为理极也。宝亮曰。归佛果无为之僧。便不畏有谬归外道之失也。智秀曰。凡四行半偈。詶所请也。有三意。第一一行。许为说也。第二一行。显今说。为美等迦叶于释迦也。第三两偈半。显推教意也

迦叶白佛言我亦归三宝是名为正路诸佛之境界

案。僧亮曰。迦叶为众导之首。受解自归未来三宝。未来未现。现在成时。则功德亦等。故言亦也。正路者。三归也。三归是趣佛正路也。僧宗曰。不但归今日常住一体。亦归昔教别体三宝也。此下余四行。第七段领解也。智秀曰。迦叶自说。如理双归。初一行。如权而归。次三行。归于今说。初一行。出今日可依法体。次二行。以一行叹此法。一行结其归心也

三宝平等相常有大智性我性及佛性无二无差别

案。僧亮曰。释上亦归义也。僧宗曰。举今日一体也。当来圆果。备有三义。无胜负故。平等也。大智性者。不同孤灭也。无二者。深领旨也

是道佛所赞正进安止处亦名正遍见故为佛所称

案。僧亮曰。释上正路也。僧宗曰。举别体三宝。明我亦不背也。名正遍见。言丈六亦真十号也

我亦趣善逝所赞无上道是最为甘露诸有所无有

案。僧亮曰。自说是真归也

尔时佛告迦叶菩萨(至)则应分别有三归依

案。僧亮曰。上说自归未来一体三宝。将广上所明。先非昔说也。昔日异体依他者。为声闻耳。僧宗曰。今呵迦叶。乃密斥凡夫也。宝亮曰。此下第八段。佛还劝迦叶行也。迦叶既领解于前佛。今更督厉时众。故次有此文也。不应如声闻者。呵其第五段中。我今无预知。当行次第依语也。若为化生故。可说差别三宝也。不然者。则唯一体耳

善男子菩萨应作如是思惟(至)等为众生作归依故

案。僧亮曰。应立誓言与人作依止也。宝亮曰。释劝归依未来自身一体三宝也

若欲尊重法身舍利(至)起塔庙想礼拜供养

案。僧宗曰。佛以智慧为尊也。色身是智所依处。所以得尊也。塔庙与色身不异也

如是众生以我法身(至)及诸智者而作佛事

案。僧亮曰。生盲者。举须依者也。宝亮曰。既有慧眼。应悟未解。开盲者之目也

善男子譬如有人临阵战时(至)如王王子大臣亦尔

案。僧亮曰。为菩萨欲破生死。为依止之譬也。僧宗曰。此答前问。云何得自在。云何不自在耶

善男子菩萨摩诃萨(至)猛利决断应如刚刀

案。僧亮曰。即涅槃者。常乐我净一也。自悟者佛。为上也。所悟者法。法为次也。归法者僧。僧居下也。如彼梯橙者。度众生故。有阶级之差别也。法瑶曰。此答难云。我今预知。当行次第依

迦叶菩萨白佛言世尊(至)八十种好亦不可思议

案。宝亮曰。第九段发劝时众。凭己而用心也

大般涅槃经集解卷第十九大般涅槃经集解卷第二十

  广论中道义　释有无中道　释实相中道　释相续中道　释佛性依持建立义　释象牙雷时生花　百盲人治目譬　贫人见王子净妙刀譬

    如来性品之第三

尔时佛赞迦叶菩萨(至)汝已成就深利智慧

案。僧亮曰。第十段。佛还印可赞述也

我今当更善为汝说入如来藏

案。僧亮曰。已知归处。正应修习以趣之也。此下广辨得失。以显中道之行也。僧宗曰。此下大段第四也。前开善业。辩昔教不说含识有性。则是有倒善业不成。今依圆教。皆有真性。此是正解即善业也。理深难解。亟生诽谤。劝生信解。要须善识来果之相也。虽复标心悬契。非行不阶。是故应修中道观行也。此下辩中道。有十别。第一有两句。先定因果。即是略显十道体相也。第二明乖理为倒。第三明如理为解。第四明如来知其偏发。能善疗治。第五更复举理验其所执。第六寻其起惑之根原也。乃于如来所说偏教。广生谬执。第七明非但直于偏教之中。生无常倒。亦迷昔曰因果之言。生二法想也。第八引般若经灯主品。相续中道。第九寄乳酪譬。重显中道之理。第十叹教。言此经深隐。始是穷理也。宝亮曰。此下大段中第三也。辩三种中道。正明作善业义也。第一明理断常有无中道。第二明实相中道。第三辩相续中道也。就明离有无中道。有五章。第一明失。第二明得。第三总为得失作譬。第四与佛作譬。第五劝行也。明失之中。初先开二句且泛明天下失者之意。第二从若言诸法。皆无有我以下。双举六行。正明失也。初二句者。若计身有神我。即是常见。明如此之人。终不离于苦也。或复有言。佛亦同有神我之我。此第一句也。无我者。若谓此身。乃至滥佛。尽是断灭者。既俱是空法。虽行净行。何所获耶。智秀曰。辨不断不常中道。有五意。第一。从始讫无所利益。正明常住定中道之理也。虽有而不在因中。然果非永无也。第二讫要因断常。明违上所说。则成二见。以为失也。第三讫远离二边。而说真法。辨安心在理。修得中也。第四讫清净佛性。常住不变。释上第二第三两章。明所以有惑解之意也。第五讫虽有去来。常住无变。诫劝学者也

若我住者即是常法(至)修行净行无所利益

案。僧亮曰。先说理不可偏。欲显偏者之失也。所利益者。若一切无我。则修道无果。正辨偏者之失也。僧宗曰。不离苦者。若我在阴。则与阴为一。若我常者。苦亦应常。苦若常者。永不应离。而今苦定可离得知常果不在身中也。六卷云。若使有我。终不经苦。而要经苦故。知无我也。无利益者。若终期灭者。则徒修净行也。宝亮曰。若计此身有神我者。即是常见。此人终不离于苦也。亦复言佛同有神我之我也。无利益者。若言此身该佛。尽是断灭者。既俱是空法。徒修净行。何所益耶

若言诸法皆无有我(至)亦复如是要因断常

案。僧亮曰。此辩偏执者之过也。如虫者。终不离断常也。僧宗曰。第二明乖理取相。起断常之执也。夫生死之中。虽云无我。而性理不亡。神明由之。而不断也。若计一切悉灭。则上乖圆极。下乖因性。谓断见也。若言有真实之我。住在生死之中。常而不灭者。即常见也。言一切行无常者。上明我倒。此明常倒。下明苦乐相对六句也。修一切法常堕常见。堕常见者。欲明凡夫舍捉不定。有时计断。有时计常。如步屈虫也

以是义故修余法苦者(至)远离二边而说真法

案。僧亮曰。以上偏见之失。分别异相也。僧宗曰。此第三意。明如理故解也。所以言余者。若先说佛果。则余生死未说。先说生死。亦如是。宝亮曰。此五别之中。第二明得也。生死是涅槃家余。涅槃亦是生死家余也。以得为善

凡夫愚人于中无疑如羸病人服食苏已气力轻便

案。僧亮曰。凡夫于中。犹尚无疑行道。便易进趣佛果。况圣人乎。释上义也。敬遗记僧宗曰。疑是解津。既有重倒在心。何容知疑耶。气力轻便者。谓羸人不堪多苏。躁动不停。断常不定。捉放易转也。慧朗述僧宗曰。谓凡夫闻已。即得无复疑也。如羸病者服苏。气力得轻便。而鲜举也。宝亮曰。无疑者。结上意也。从如人服苏已下。第三意。总举得失作譬。此服苏之譬。明得失有也。谓智者得理。必有利益。如病人服苏。得气力也。下以四大。譬失者也

有无之法体性不定譬如四大其性不同各自违反

案。僧亮曰。不定谓不偏也。涅槃实故。名妙有也。生死虚故。名为无也。因果相续。一体之中。而有二相。不定者。此明法理不偏也。宝亮曰。为失者作譬也。将作譬故。先举失者所计断常。计断是无。计常是有。既是横计。所以不定也。下引四大其性各异为类。如计常也

良医善知随其偏发(至)清净佛性常住不变

案。僧亮曰。众生烦恼偏发。如来应之。亦有偏教断其偏惑。令会中道。若闻偏说。谓佛性变异也。僧宗曰。第四意也。医即佛也。若常病者。为说偏教。若断病者。为说圆教。乃至三毒不同。亦说三药。以治之也。宝亮曰。第四与佛作譬。如彼良医善知病源。则应病消息也

若言者有知不应染

案。僧亮曰。后文有证也。若定有佛性。是名染着。若定无佛性。是名妄语也。僧宗曰。第五更举理。以验惑为罪也。谓生死有我者。计我之家。何以称染耶。而言染者。当知。邪[言*恭]不称理也。宝亮曰。第五教行人。离于执着也。云未来身一体三宝。不应谓如质像之法。执着而取也

若言无者即是妄语

案。僧宗曰。若圆果之上。无自在我者。圣人何故。字汝为语耶。宝亮曰。若言未来二头三首。都无者。便是妄语也

若言有者不应默然

案。僧亮曰。不应有圣默然也。思益以诸法空。故名圣默然。此无对句也。僧宗曰。若生死有我者。及捡问之时。何故默然耶。宝亮曰。不应如犊子道人之所计也。如此诸句。劝厉行人。应当推理。而会中道

亦复不应戏论诤讼(至)不解如来微密藏故

案。僧亮曰。已说理中无偏。偏执是诤。不偏即了真也。僧宗曰。一等四执。皆有过咎也。即色之过。如僧伽也。离色之过。如卫世师也。计一神我。不一不异。如犊子道人也。断见外道。计一切无。复与前反。皆诤讼也。但求了知者。所执即耶。但当求实相理。岂可轻生执耶

若说于苦愚人便谓(至)我身即有佛性种子

案。僧亮曰。已辩得失。今重劝也。夫正因性常。常则是乐也。敬遗记僧宗曰。此下第六。寻惑源起倒所由也。不达偏教之旨。乃计一切苦也。智者不尔。得教外之旨。不滞偏言也。法莲记僧宗曰。此下第八。迷偏教而起惑之源由也。此中有三番。明人惑教也。第一惑偏教。第二惑圆教。第三双惑偏圆二教也。若说于苦。愚人便谓。无常此第一惑。偏教上但言起惑。未辨起惑之始。今明惑起之根源也。若论次第。应先惑圆教上也。数明此义。知邪计为非。今始惑偏教也。说一切苦。复不能知身有乐性者。上句滥云。佛亦无常。此言未都无佛性也。若无常无我空寂四句。皆是有为也。解脱是无为也。无我是众生空。空寂是法空也。我身即有佛性种子者。众生是正因。为种子也

若说无我凡夫当谓(至)虽有去来常住无变

案。僧亮曰。有为因果。从颠倒起。假名不实也。如幻化者。从缘见也。敬遗记僧宗曰。如净名经云。迦栴延于后广宣其义。非直不达佛地无苦。亦复不识苦之不生。是故致净名诃也。初说苦。次说无常。次说无我。次说空不说不净也。法莲记僧宗曰。如幻化者。大品经云。设有一法。过于涅槃。我亦说之。如幻如梦。此言都空。如八万劫断也。人中师子。虽有去来者。覆相说故。言佛亦灭。而实法身真不灭也

若言无明因缘诸行(至)无二之性即是实性

案。僧亮曰。上以不分别为失。此取因果定相。著有为故为失。下以苦无常无我。显著无为之失也。我与无我。性无有二者。此明第一义中道。离有无二边也。敬遗记僧宗曰。此第八段。曾闻师说。指此名为迷圆教而起惑也。就文而捡。无灼然有异。乃随人释耳。但上已明有无中道。然亦事须明显相续中道。以其义势相涉故也。前三句。就有漏法中。明因果黑白二法。通漏无漏。明因果也。凡夫闻因果之言。便谓天隔。生二法之想。深达之者。体因果之异故。不得言一。因果相关。不得言异也。法莲记僧宗曰。此第二番惑圆教也。闻说法身是常。学地无常。凡夫执言。佛与众生。明无明异。有为无为。各不相关也。偏教亦明十二因缘。何以为异。借以为譬。于明无明。若不了者。况能善达圆教妙理耶。无明为因。明则为果。下有为无为等句皆如是也。宝亮曰。此下第二重。明实相中道也。若直谈昔教偏取生死。空有为实。若就今经为语。乃识神明妙体。真如为实。知金刚心已还。必是苦空无常。佛果必是常乐我净。若作如斯之解。便于两边。皆得实义。成中道行。所以然者。生死体空。亦从本来。无二无别。涅槃体如如。亦本来无相。此是体。识诸法实相之理也。然此中所明。唯斯一途。下所历事。虽多。然其义要不复异也。夫执相者。云因缘之法。有一定性。无明亦有一定性也。两物各不相关。是故佛言。实相之理。彼此俱无也。智秀曰。此下明相续法上。辩不异一段之中道也。有二意。第一说无二之性。即是实性。正显不异。一假名义也。第二从我与无我。性无有二。讫无有二相。第二意。以理相深远。恐闻不即解。乃引诸佛所赞。及大品所明。我亦曾说假一之理。用证今说。明其理甚实。不可不信也

若言应修一切法苦(至)无二之性即是实性

案。敬遗记僧宗曰。寻此语似迷圆教而起惑也。说金刚已还。一切法乐闻此之言。谓天然殊异。斯则迷滞相续假义之一边也。若不依此释者。还就偏教起惑。正言偏教说一切苦。谓秘藏亦苦。凡夫闻此生断见。则念念生灭。前灭后起。都不相关。顿乖相续不异之旨也。法莲记僧宗曰。第三番。人情有疑。谓二人惑二教也。今明一人双惑二教。乃结与一人也。一切法者。是偏教也。凡夫谓二。是圆教也。亦应如前。备有五句。但言苦无我者。依无我观。兼得法空涅槃。亦空兼亦尽矣

我与无我性无有二(至)汝应如是受持顶戴

案。道生曰。因缘不得相离。因缘有故。学得成佛。岂离无我而有我耶。僧宗曰。此第八正理也。如智人所解。因果之相关也。宝亮曰。就昔教之时。不作我无我。若就今教故不俟言也。我者。据佛果。无我者。据生死。论实相之中。则无别也

善男子汝亦应当坚持忆念(至)说我无我无有二相

案。道生曰。彼所明不二之义。亦如今说也。敬遗记僧宗曰。第八段。引昔空教所说中道。以为证也。彼灯主品中。明前炎后炎。俱不能燋。燋亦不离前。后炎也。昔已久说。非独今明。重出谬情。非经不辩也。宝亮曰。第三重明作善业也。就行人而辨相续中道也。此我无我不异上释。然上之所明。据空无异边也。今于此中。谈其相续边也。转此相续一行人之语故。谓之我无我也。所以引般若经为证。相续义者。故如因成假义。若直一也。不名因成。若各异也。亦不名因成。因成者。有能成所成。能成是总也。今相续亦如此。直一亦不相续。若直异。亦不相续。要是前法谢后法起。补此曾有之处。假名中道相续语故。从因至果。喻如五味之相续也。法莲记僧宗曰。第九引经为证。然大品经。乃不说我无我义。说非初心得。非离初心得。成无二之义也

如因乳生酪因酪得生苏(至)因熟苏得醍醐

案。道生曰。举近事。以譬远理也。僧亮曰。三种中道。以因缘为本。但证因缘余者。自明先说正因。如乳酪等法也。后破其横计。成因生之义也。敬遗记僧宗曰。此下第九借譬。以显中道一异之旨也。先举三关。此中不许从自他生。许从乳生。此言未了。下因迦叶致难。有无之义乃彰耳。法莲记僧宗曰。第十借乳酪。为譬亦证成第八无二之旨。而因果相关也。因乳生酪者。后因至果。理不得异。凡圣之理。理相关也。智秀曰。第三次明因果中道。有三番往复也。第一佛自说。第二迦叶难。第三佛答。此下讫无有二相。第一意也

如是酪性为从乳生(至)乃至醍醐亦复如是

案。道生曰。核论理衷。要从缘生。非他非自也。智秀曰。先开三种章门也

若从他生即是他作非是乳生若非乳生乳无所为

案。道生曰。非乳则无。岂从他耶。僧亮曰。若水能生酪。乳复何为。僧宗曰。即他作者。离乳之外。其余万物皆称他

若自生者不应相似(至)定复不复余处来也

案。道生曰。苟能自生。何用必续相。似之后耶。僧亮曰。若自生者。不应须乳也。若必续乳而生。不能无因。非自力也。则不俱生者。以续故不俱。若能自生。亦可俱也。不从余处来者。向以不俱。明不不自生。复似从余处而来。续彼后也。僧宗曰。此难有三重。一谓不应续乳。二谓应与乳并。三谓应异处来也

当知乳中先有酪相

案。道生曰。不从他来。又不自生。唯应乳出故。言先有其相也

甘味多故不能自变乃至醍醐亦复如是

案。僧亮曰。先有酪相者。先有甘也。不能自变者。待醪乃能变多为少。甘多为乳。甘少为酪。故不一也。同是甘性。性不异故。是中道义。宝亮曰。先有酪相者。因中说果。必有故言有也

是牛食啖水草因缘(至)其乳则有色味之异

案。僧亮曰。广以事证耳。宝亮曰。名肥腻者。此为行人作譬也。雪山喻五阴身。草譬因果性六行理也。牛譬行人。若于涅槃因果佛性中学。直向佛果。不经四趣

是诸众生以明无明业因缘故生于二相

案。道生曰。背明成无明故惑不二之相为二相耳。非本二也

若无明转则变为明(至)亦复如是无有二相

案。僧亮曰。众生有心。知苦可厌。知乐可求。不识苦故。名无明也。识则无明。之名转也。是则有明闇之异不一也

迦叶菩萨白佛言世尊(至)乳中有酪是义云何

案。僧亮曰。因缘中道离有无。诸佛上所说。有中道义味。故有问也。僧宗曰。上举三关。明自他有过。许从乳生。理未可见。假作定有定无之难。使中道之旨显也

世尊若言乳中定有酪相(至)何故乳中不生于草

案。僧宗曰。百草之中。亦应有乳。如是乳中。亦有草者。草为因也。乳为果也。若使因中有果者。果中亦可有因。是则反覆有过也

善男子不可定言乳中有酪(至)亦不可说从他而生

案。僧亮曰。甘时无醋。故非有。甘为醋因。故非无也。不从他生者。定由乳出。证因义也。僧宗曰。佛自料简。离二边而得生酪也。上已简不从自生。今不复释也

若言乳中定有酪者(至)乳中定有酪性

案。僧宗曰。黄白恬醋。既不一一种。故知。乳时无有酪也

若言乳中定无酪者(至)不可说言乳中定无酪性

案。僧宗曰。若使乳之无酪。如无菟角者。何故能生于酪。而不生菟角也

若言是酪从他生者(至)不可说言酪从他生

案。僧宗曰。向就定有定无为过。今复料简从他生之为失也。若从他生。水中何以不生酪耶

善男子是牛食啖草因缘故血则变白

案。僧宗曰。三关之过。上已具释。今显正义。非不假缘。得有变义。此明资缘义也

草血灭已众生福力(至)离乳而有无有是处

案。宝亮曰。草乳虽殊。而有相续。成一味之义不得。执云天然为异也

善男子明与无明亦复如是(至)即成醍醐佛性亦尔

案。僧宗曰。众生有感果之力。果有酬因之用。故能转闇为明也。乳之与酪。不得为二。众生与佛。岂得为二。始终相续。假说为一。正可得言从缘而生也

善男子众生薄福不见是草(至)即见佛性成无上道

案。昙纤曰。从此下。答问云何诸菩萨。能见难见性也。宝亮曰。佛性非是作法者。谓正因佛性。非善恶所感。云何可造。故知。神明之体。根本有此法性为源。若无如斯天然之质。神虑之本。其用应改。而其用常尔。当知非始造也。若神明一向从业因缘之所称起。不以此为体者。今云何言毒身之中。有妙药王。所谓佛性。非是作法耶。故知。据正因而为语也。若是果性。则毒身之中。理自无也。复不应以果来依因。若以果来依因者。胜鬘经应言。依生死故。有如来藏。而云依如来藏。有生死。是名善说。不亦即此文乎。大海虽碱。亦有上味者。微理可据也

譬如虚空震雷起云(至)能报佛恩真佛弟子

案。僧亮曰。虚空譬佛。雷譬涅槃经。牙譬众生。花譬见性也。谓佛性由经故见也。僧宗曰。此第十结也

迦叶菩萨白佛言甚奇世尊(至)如汝所叹不违我说

案。僧亮曰。答云何诸菩萨。能见难见性。犹是长寿因也。上辩三归因之始也。此一答问是因之终也。法瑶曰。从若我住者。已来至文字品。答此问也。上三归中。明我性有佛性。似如有神我之性。为佛性也。是以今广明佛性。非有非无。离乎二边。处于中道。无相可执。若执则堕断常二见也。其性玄妙。非二乘所测。十住大士。犹尚暖昧。岂非难见耶。智秀曰。此下答问有四番。第一敬叹佛性。佛即述成。第二举问请答。佛即答也。第三请求立誓。佛即为说也。第四迦叶设难。佛即答也。此即第一敬叹

迦叶菩萨白佛言世尊佛性者云何甚深难见难入

案。智秀曰。此下第二。举问请答也。叹述已竟。更举问也

佛言善男子如百盲人(至)三指示之乃言少见

案。僧亮曰。金錍譬诸经教。一指譬三乘诸经。说三涅槃。实欲显一常住涅槃。文隐义微。譬一指也。二譬法花破二涅槃。一乘虽显。常我未明。譬二指也。三指者。譬今日佛性常乐之说。即便少见者。见已居终也。终则感果理彰。说已便见。始则事微难说。虽示不了。是以经说十地菩萨。见终不见始也。僧宗曰。盲人譬十地已还。生死者也。百者。盖十数之极耳。造医者。善感圣也。宝亮曰。所问难见性者。正因性也。今答中。乃明缘因者。正以得佛果之日。方明识正因也。非唯果性难识。因性亦难知也。下文言。十地知终不知始。是以问在正因。答以缘因

善男子是大涅槃微妙经典(至)如来既说即便少见

案。法瑶曰。十住菩萨。要闻涅槃。乃得仿佛少见佛性。此下明虽闻涅槃。不能得正信有两已也。宝亮曰。就文求义。此实为难。云何行阶。法云犹不知有佛性。方须佛说。乃得见耶。此谓住前卅心中。初十心者。名十住也。第廿心。名为十行。第卅心名十回向。若使菩萨。虽无量劫修行苦行。不闻涅槃经者。信首五根。终不可立。信根立时。正第卅心也。此行人者。要须佛说因果之性。方涉信首耳。如向所论。十住菩萨。非是法云明矣。言少见者。闻佛说后。信慧渐明。故称少见

是菩萨摩诃萨既得见已(至)缘觉之人能得见耶

案。宝亮曰。此下讫犹为无我轮之所惑。向明菩萨。说因果之性。得进首根立。登于初也。至乎十地行满之时。所离障薄。于时。始复仿佛见性八自在我空也。虽观此空。心未沦怙。还入无我心中。以其情未决。故言为无我所惑耳。非是横计佛地。作无我为惑也

复次善男子譬如远观(至)非诸声闻缘觉所及

案。宝亮曰。凡九譬。为难见作譬也

迦叶菩萨白佛言世尊(至)有众生性皆说有我

案。道生曰。问意。若唯佛是我。而难见者。凡夫天隔不应生于我想。我想虽惑。要必有由。若有由者。便非悬绝。云何而言十住菩萨。乃仿佛耶。僧宗曰。理既深玄。名亦应贵。云何世人。亦复自造常乐之名。传之于世耶。智秀曰。此下第四段。虽闻上说。犹未了故。凡夫有我。以为难也

佛言譬如二人共为亲友(至)如是二人互相往反

案。道生曰。彼此相益。有亲友之义也。僧亮曰。答意。谓虽复有由。而理自隔。如下譬也。菩萨道尊。譬之王子。凡夫无德。譬贫人也。互相往反者。弟子受学。师有化功。彼此相益之义也。法瑶曰。感往则应来者也。僧宗曰。往反者。弘化之与所化之人。怀抱相得也。宝亮曰。此譬大意。与前偷牛譬不异。正为四依人出世为喻也。智秀曰。下有三阶。第一显佛曾为众生。先说有我。缘尽舍化。理归圣所也。第二譬众生于后谬执耶。我第三譬释迦今日出世而弘化也。此下讫逃至他国。第一譬也

是时贫人见是王子(至)执持是刀逃至他国

案。道生曰。所说真我。能断众生断见之惑。譬之刀也。僧亮曰。真我常住。谓之一也。自在可悦。谓之好也。解则断惑。喻之刀也。结习永尽。谓净明也。心中贫著者。真我本以断贫为用。而见则起贪明不了也。执持是刀者。谓此真理。唯菩萨能说也。逃至他国者。弘化未毕。未应舍谓逃也去此而之彼。谓至他国

贫人于后寄宿他家即于眠中寱艺言刀刀

案。僧亮曰。从师受解。所解之理。是其安处。譬家也。师去失解。譬他家也。本因必发。暂住不久。譬寄宿也。失解起惑。以譬眠也。惑心说我。不由真解。譬眠中之语也

傍人闻之收至王所时王即语汝言刀者可以示我

案。道生曰。若以实为实。乃成窃耳。以不实为实。然后知非也。应诘求其实义。为索示也。僧亮曰。菩萨既去。圆教亦隐。小乘以无我为化。偏教失中。譬谤也。违化得罪。譬收也。必经断事。譬至王所也。可以示我者。初果已断。示相之我。是其所了。今责求形色自在之相也

是人具以上事答王(至)欲得刀者实不可得

案。道生曰。分裂诘求。实不可得也。僧亮曰。忘现五阴。推不可得也

臣与王子素为亲厚(至)不敢以手棠触况当故取

案。道生曰。若修得为用。是故取耳。得非修故。故名为窃。僧亮曰。释所以忘也。眼视譬闻慧。手触譬思慧。故取譬修慧也。昔闻虽信。意不思议。况起修慧。而取耶。所以忘本解也

王复问言卿所见刀(至)我所见者如羖羊角

案。道生曰。似而非也。一往所见。非实之谓也。僧亮曰。羊角邪曲。而以为正。麻米邪我。凡夫持此。以起慢也

王闻是已欣然而笑

案。僧亮曰。有我是实。而无我非果。是声闻之忧。况无我无实。无我是果理是可欣也

语言汝今随意所至莫大愁怖

案。僧亮曰。我是惑首。五道是[這-言+至]。非我见正不足致忧

我库藏中都无是刀(至)曾见如是刀不言已便崩

案。僧亮曰。谓三藏经。是小乘法藏。真是佛说。无此我相。况于菩萨。闻此我也

寻立余子绍继王位

案。僧亮曰。第二果也

复问群臣汝等曾于(至)皆悉捡挍求索不得

案。僧亮曰。始终皆作无我化也。法瑶曰。经教所明。都无彼人所计之我。况菩萨边闻所计我耶。历举四王。求索不得刀者。明千圣虽异。而经教是同。众生万品。而计我斯一也。次第四王者。千圣相继第四佛也

却后数时先逃王子从他国还归其本土复得为王

案。僧亮曰。释迦成佛

既登王位复问诸臣(至)不见我刀真实之相

案。僧亮曰。登王位者。鹿野之说也。外道计我。不同婆罗门计白。神刹利神赤。首陀神黄。旃陀罗计神黑也。时王大笑者。双树之说。真实相也。法瑶曰。句明四佛皆同。今明未来亦尔。略举一耳

善男子菩萨摩诃萨(至)持净妙刀逃至他国

案。智秀曰。合第一譬也

凡夫愚人说言一切(至)如问刀相答似羊角

案。智秀曰。合第二譬

是诸凡夫次第相续(至)当知即是菩萨相貌

案。智秀曰。合第三譬

大般涅槃经集解卷第二十大般涅槃经集解卷第二十一(文字品第十三　鸟喻品第十四)

  释十四音　释鸟喻　明常无常六行不相离释山顶见平地譬

    文字品第十三

案。僧亮曰。此品答云何解满字及与半字义。广上名字品也。上说虽闻契经。不知佛性。闻涅槃经。知有佛性。十地闻说。犹尚仿佛。佛性始终。皆由经说。问以显之也。法瑶曰。上明佛性难见。十住犹不明了。唯佛能见。是则佛性之理满足。以况满字。非佛性者。皆非满足。以况半字。又况无常教为半字。常教为满字也。又惑之根本为半字。一切善为满字也。僧宗曰。上已广因果。及广流通。然以文理。合为经体。故此品广文。鸟月二喻。广理也。文理既彰。于经无阙矣。智秀曰。前品中。迦叶云。常我之名。不应为凡夫所得。佛举王子为譬。明常我之名。乃由佛有。是以迦叶。因致此问。若常我之名。由佛有者。未知其余名字。复因谁有。所以言。云何解满字。及半字所由也

佛复告迦叶所有种种异论(至)皆是佛说非外道说

案。道生曰。因上所言。凡夫所谓我者。本出于佛。今明外道所说。亦皆如是。然则文字语言当。理者是佛。乖则凡夫。于佛皆成真实。于凡皆成俗谛也

迦叶菩萨白佛言世尊(至)然后能知是法非法

案。僧宗曰。明非但常名。为外道所窃。凡是一切记论。有益之言。皆从佛出也。传云。十四是字。后者名音。字与音合。名为满也。十四未满。为半也。音字合故。有记论也。阴者有为。实法无为也。智秀曰。此品有七段。第一正答问。第二列出十四音。第三约四音结成字义。第四明音所以得有差别。有十四音也。第五明满字半字升降相。第六明知不知相。第七导领劝旨。佛即述也。此第一段有三翻。第一佛先唱文字。皆是佛说。第二迦叶请释根本。第三佛广说字之本义也

迦叶菩萨复白佛言(至)即是如来金刚之身

案。道生曰。彼之字义。名曰不尽。而指法身。今先据涅槃为端也。僧亮曰。其义云何者。问其字体。亦问字义也。有十四音。此答字体也。传云。胡本言字。不言音。译人误也。名涅槃者。此答字义也。佛说字意。本为涅槃。息有为之苦。说字之义也。常故不流者。释音也。涅槃不为生灭所迁流也。僧宗曰。传译云。十四音者。为天下音之本也。如善用宫商。于十四音中。随宜制语。是故为一切字本也。此中但有十二字。余二字零落不传。相承云。悉昙二字是也。智秀曰。此下第二段也。十四音。从恶阿有十二。合则为六也。从迦佉以下。有二十五音。以五为一。合则成五也。并前为十一音也。后有九音。耶罗等合三为一。复得成三。并为十四也。彼此不同。风俗有异。信之译人耳

是十四音名曰字本(至)最为殊胜是故名痾

案。僧亮曰。言十四音。而所别十二者。瑞应经云。书缺二字。以此为证也。宝亮曰。若就此文而断。正应用涅槃为二字。然相传不取。未详所以也

迦者于诸众生起大慈悲(至)大般涅槃是故名摩

案。僧宗曰。三十八音。从十四音出。但就三十八中。前二十五音。是次第从舌本声。次至舌端。次齿。次唇。从第二十六至第三十。此是超越不定。下有八字。皆表长短超声之相。半字为字本者。义生此也。夫致教之体。要先半而后漏。此是前后次第根本耳。迦呿此五字。是舌本音也。遮车此五字。舌中音也。吒他此五字。舌端音也。多他此五字。是舌齿音也。波颇此五字。是唇音也。耶罗和此五字。是超声也。下八字。皆是缩张含吐之异也。昙纤曰。此二十五字。皆前十二字中出。下去诸字。皆不从出也

耶者是诸菩萨在在处处(至)有父母妻子是故名罗

案。智秀曰。十四音。讫此也。此中九字。为三音也

鲁流卢楼如是四字(至)以是故名鲁流卢楼

案。僧亮曰。向来诸字。当字表义。今此四字。共表四义。四义者。谓三宝对法。三宝以善对恶也。对法者。以恶对恶。如调达三逆。种种为恶。越制戒因缘。未来恶也。智秀曰。第三段。结成字义也。正是以音表旨。故目此音为字也。字有满半者。以十四音。用表圆理。目为满字。表未圆理。谓之半字也

吸气舌根随鼻之声(至)皆因舌齿而有差别

案。智秀曰。第四段。明音所以得有十四之音也

如是字义能令众生(至)而不同于阴界入也

案。僧亮曰。身口是文字之因。文字是口业之因。皆是作法也。众生佛性。则不如是者。乃由文字说性。众生得知。人谓。佛性亦由文字。得清净也。今明不了者。从缘生故。是作法也。佛性从缘见。非作法也。不同阴界入者。不可坏也。宝亮曰。佛性虽在阴界入中。而非阴所摄者。真俗两谛。乃是共成一神明法。而俗边恒阴入界。真体恒无为也。以真体无为故。虽在阴。而非阴所摄也。体性不动。而用无暂亏。以用无亏故。取为正因。若无此妙体。为神用之本者。则不应言虽在阴入界中。而非阴入所摄也。故知。理致必尔矣。如脱不尔者。复不可使佛果佛性。倒入阴入界中。而唱非阴界所摄也。即曰谨述诚旨。不敢妄有所作也。智秀曰。为成叹字功也。以此而言。叹字所表既妙。下结劝也

是故众生悉应归依(至)等视众生无有差别

案。僧亮曰。依不坏之性。成不坏之果也。智秀曰。字有所表。故遂感菩萨等视也

是故半字于诸经书记论文章而为根本

案。僧亮曰。说字说音。事已究竟。此结上也

又半字义皆是烦恼(至)修善行者名为满人

案。僧亮曰。上明未与音合之字为半。今明虽合。不得字旨。亦是半也。智秀曰。次下显半字之功。优劣也

如是一切经书记论(至)无阂无著真得解脱

案。僧亮曰。上云一切善法根本。人谓。亦与如来为本。佛无师悟。非字所摄。名离文字。但言半者是不善。满者皆善也

何等名为解了字义(至)是人不知如来之性

案。僧亮曰。已说字竟。次明解与不解。若得出之旨。为解字也。智秀曰。此下第六辩知不知相也

何等名为无字义耶(至)应离半字善解满字

案。僧亮曰。字义者。虽复读诵文字。而行违说旨者。字。则不为是人出也。名为无字。未知常住佛性故也

迦叶菩萨白佛言世尊(至)乐正法者应如是学

案。僧亮曰。第七段。迦叶领旨。佛述成也

    鸟喻品第十四

案。僧亮曰。答问云何共圣行。至太白与彗星也。上说文字。此显文之所表六行。经体具足。法理不偏。六行常俱。以鸟为譬也。法瑶曰。满字者。即是常义。半字者。即无常义。常以无常虽殊。其理致是同。昔说无常。为令得常。得常由乎无常。岂得相离。是则共成一圣。名为共圣行也。僧宗曰。大分此品。为三段。第一则六行体。第二寄因以明六行也。第三就相行以明六也。宝亮曰。此下两品。同广文字下旨。谓常无常六行也。鸟喻品双明六行。月喻品偏明三行。然俱广明理故。共答一问也。此品总别有二门。第一从品初以下。总门也。第二从如来已离忧悲讫品。别门也。智秀曰。此品分为二段。第一从初讫复异豆粟甘蔗。略列六行也。第二从如是诸种讫品。广明六行也。广中别有章门。至彼更关

佛复告迦叶善男子鸟有二种(至)何以故性真实故

案。智秀曰。第一总别六行体也

迦叶白佛言世尊如是等物(至)乃至无我亦复如是

案。僧宗曰。就明六行体中。有三章。此第一就偏教以明常无常也。宝亮曰。上来至此。总门明六行也。智秀曰。此广门中。第二先明常无常也

迦叶菩萨白佛言世尊(至)是名鸳鸯迦邻提鸟

案。僧宗曰。此第二阶。寄真应以明我无我也。至极法身。无有忧悲。即我义。见有忧悲。似如无我也。借无想天。以为况也。无想天报。唯有四阴。不域其方所。虽无住处。要不得无也。近事尚难可知。况法身妙极耶。树神依树。亦如是也。智秀曰。广门第二。明无我也

复次善男子佛法犹如(至)第一微妙坏诸行故

案。僧宗曰。第三阶。明苦乐也

迦叶菩萨白佛言世尊(至)异法是我异法无我

案。僧宗曰。寄因以辨六行也。明放逸则无常苦果。不放逸则常乐果也。长行释偈。小不次第也。先释放逸果。次释不放逸果。次释放逸因。次释不放逸因也。非圣凡夫者。前已释二家因果。今出其人也

如人在地仰观虚空(至)如迦邻提鸳鸯等鸟

案。僧宗曰。第三就相待明六行也。以生死为下。佛果为上。以上知下。所以而常。下不知上。故无常也。寄譬明如来。住智慧之上。见五道生死也。借譬以明见。而物情于譬生滞。故迦叶仰咨。以拂斯迹也

大般涅槃经集解卷第二十一大般涅槃经集解卷第二十二(月喻品第十五　菩萨品第十六)

  释月有六事。以譬法身　释日及岁星譬　释未发菩提心。为作菩提因缘事　释一阐提不受道事

    月喻品第十五

案。法瑶曰。从见月不现。至譬如日出众雾悉除。答云何如日月大白问也。上长寿金刚。明法身体相。名字功德品。结经名也。经之大体。以涅槃为极致。下竟解脱。皆明大涅槃义耳。从四种人竟四到。明弘经人。即是长寿金刚缘因也。从二十五有有我不耶。竟共圣行鸟喻明佛性。即是金刚长寿正因也。一周大明因果义讫。今复明长寿金刚。应感无方之能也。僧宗白。上鸟喻。遍就六行。以明圆理。今月喻。遍明法身真应之德也。宝亮曰。犹答第十二问未竟。更偏明常乐我三德也

佛复告迦叶譬如有人(至)为化众生示有生灭

案。僧亮曰。月譬有六事。此第一明虽生不生。成前品未应物之迹。广常义也。问曰。在前而先答月者。以月事广故也。法瑶曰。明一应之迹始终也。僧宗曰。此譬中有五重。第一举今一化始末。第二明非但于此。乃遍十方也。第三寄月食。辨示有出身血事。而实不可伤也。第四显寿之修短。随感而应也。第五明如来是众圣之王。能为物益也。须弥障故不见者。有四天下。而须弥处中。日月运行。周回旋转也

善男子如此满月余方见满(至)是故名为常住不变

案。僧亮曰。第二事。广上生灭义也。从初至十五日。广生义。自下广灭义也

复次善男子譬如满月(至)如来常住无有变异

案。僧亮曰。第三事。普应六道。随感而现。亦是广生中事也。在在处处者。既大小之器不同。月形亦异。譬六道既殊。迹亦不一也。百由旬者。向举水器。明随处而现。此明去来随人也。僧宗曰。犹是第二事

复次善男子如罗睺罗(至)分别法句如彼医子

案。僧亮曰。第四事。为制戒故。示有出身血等也。法瑶曰。明果报必受也。僧宗曰。第三事也。宝亮曰。此示制戒。凡有三意。第一明法身无损。犹如满月。虽有其事。而无所伤。第二所以无伤。引二人共斗。本无杀心。虽死无罪。第三举医譬。明有此示现。必有利益也

复次善男子如人见月(至)是故如来常住无变

案。僧亮曰。第五事。显现涅槃及业报等也。法瑶曰。前示行恶止善也。此示行善制戒也。僧宗曰。第四事。月实不蚀。似损月。取譬涅槃

复次善男子譬如明月(至)故言如来譬如明月

案。僧亮曰。第六事。佛之功德。略如彼也。僧宗曰。第五事也。法瑶曰。既示行善。制戒止恶。今明乐法众生。从教无厌也

复次善男子譬如日出(至)即是诸佛真实法性

案。僧亮曰。答日问也。有二譬。初取长短为喻。次以损益为譬也

复次善男子譬如众星(至)犹如世人不见昼星

案。僧亮曰。答太白星问也。法瑶曰。譬法身玄妙。寂寞绝于视听之表。于情为隐。唯见丈六。谓之为极。二乘之谓言无。故二乘不见也

复次善男子譬如阴闇(至)不为诸垢之所染故

案。僧亮曰。总以日月。譬三宝灭也。法瑶曰。譬佛在世人。谓体尽丈六。是则无有常住法身。今明涅槃之后。故异上耳

复次善男子譬如黑月(至)如彼日月无有灭没

案。僧亮曰。答慧星问也。谓佛不并兴。若辟支出世。真佛灭度。人生倒见。谓不祥也。僧宗曰。黑月者。以修罗手障。令不见也。又言水精白银为月。以水精边故。如黑月也

复次善男子譬如日出(至)一切诸恶无间罪业

案。僧亮曰。已证佛常。六行已显。今说经功德。及闻经之益。劝人受持。通答二问。云何未发心。而名为菩萨。至犹如阎浮金。无能说其过也。法瑶曰。前日月太白慧星等譬。广上长寿金刚品也。今次广上名字功德品也。一经耳者。起一闻之功。终藉此慧。众恶消除。不言一经历耳。烦恼便尽也。正显此经功能。灭恶生善。齐法身也。竟良医譬。皆明经力也。僧宗曰。经之置品。乃出自后人。随义类而标之耳。谓菩萨品名应在此初。相承。仍旧辄改为难。付之来哲也。宝亮曰。若经生历死。发心之者。名发心菩萨。今言未发心者。就一生之中作论也。此生中。未经发心。但见涅槃经。改恶修善。起弘护之心。便名发心菩萨也。将欲广答此问。故先借日月之光。以譬涅槃经也。智秀曰。此下有三意。第一从此讫答二难。广显经力也。第二次因迦叶举其前问。即是正答所问。第三后广释除阐提之义也

是大涅槃甚深境界(至)正法不断僧宝不灭

案。法瑶曰。此明思慧思惟常住三宝之心

是故应当多修方便(至)阿耨多罗三藐三菩提

案。法瑶曰。此明修慧也。以勤学故。得近无上道。故言不久

是故此经名为无量功德所成

案。法瑶曰。此经正明佛是常住。常住犹三慧而成。今以此三。苞一切行尽。故言无量功德之所成也

亦名菩提不可穷尽

案。法瑶曰。因既无量。果亦无穷。以因果俱无量故。故称大

以不尽故故得称为(至)身无边故名大涅槃

案。法瑶曰。有般若智光故。法身无边。以此二事。名为大涅槃也

    菩萨品第十六

复次善男子如日月光(至)是故复名大般涅槃

案。道生曰。虽未发心。而得为菩提之因。与大权无异。若闻佛性信解。则是菩提心发。乃为因耳。若生诽谤。岂为因耶。僧亮曰。众生受道。必由内信。信之微者。无过四重五逆。善根不断。由如毛发。藉此微善。感涅槃光。成菩提因。得名菩萨。不畏大众。如彼真金。无过可说也。作菩提缘者。菩萨以发心为因。住前三十心是初发心之因。即日未有此心。而有重恶所障。以经力故。得作菩萨也。法瑶曰。向明能灭诸恶。此明能生诸善。发菩提心也。僧宗曰。善根未断。必有丝发许也。经有缘发之力。能令感悟。深自改悔。上求佛慧。下度众生。令未发心作菩萨也。入毛孔者。将明此经力能除闇。称为光也。善以感教。教善相扶。义如入也。所益未深。称毛孔也

迦叶菩萨白佛言世尊(至)云何能断一切烦恼

案。僧亮曰。夫有三障。则不受道。若闻皆作菩提因者。则善恶无差也。如来何故。说四依义者。若一经耳。以是耳识所得。已为菩提因者。何故。昔云依智不依识耶。云何断一切烦恼者。夫不退菩萨。要伏断烦恼。若不解义。云何伏结耶。宝亮曰。两难各有两关。便成四也。初关一往且非今旨也。若三种罪人闻经。便为菩提因者。治戒破戒。复有何殊。第二关。即以四依品结难也。谓治戒者。闻经亦为菩萨。破戒者。亦尔者。何用四依出世。治破戒耶。又如佛言。第二难亦两关。初关即引上鸟喻品云。若能归依一体三宝者。虽有烦恼。如无烦恼。若果一闻此经。便能决信。即令烦恼根虚者。佛四依品中。自说恒沙佛所发心。闻经尚不解义。云何一闻经耳。便断烦恼。第二关。即以理征。结成难也。谓解惑相违也。彼之积德。犹尚未解。而此之经耳。云何除惑耶。智秀曰。有两难。第一云。若三种罪人。心不乐向。而以经力。强令发心者。何须依四依人耶。第二若果发心。便是得理。即能遣惑者。云何彼云三恒河沙佛所发心。犹未解义。此彼二说。未可解也

佛言善男子除一阐提(至)以是义故名为大事

案。僧亮曰。除一阐提者。具三障故也。云何为具。谓不见因果。烦恼障也。说无因果。业障也。世世积恶。今成阐提。报障也。其余众生。闻是经者。谓四重五逆。虽有恶业。闻经生信。必久种功德。非无因也。凡夫下劣。不得闻者。谓不应经耳。闻亦不生信也

迦叶菩萨白佛言世尊(至)未发菩提心者得菩提因

案。僧亮曰。谓此二人。既有业障。应障发心。云何得发耶。僧宗曰。二难既通。今广明经力发心之由

佛告迦叶若有闻是大涅槃(至)大乘妙典真佛所说

案。僧亮曰。见罗刹像者。以有障故。虽复闻经。不即发心。由经发梦。梦见业果。惧苦发心。经之力也。忆念菩提者。发心有强弱也。强者生人中。弱者生三涂。虽受罪报。菩提之心不绝也。法瑶曰。诽谤经者。将绝之时。谤对相现。方生怖惧。临终之时。其心愦乱。谓之梦也。罪对切人。可怖可惧。有过罗刹也。宝亮曰。大论经教。有二时明义也。经言。以下下智。断上上烦恼者。应以昔经。治三种罪。而今涅槃之教。方云能除此惑。则于理相反。云何为中耶。经言下下智。断上上惑者。此据真无漏道。断通为语。今所释两经。正明伏道也。夫起惑之与生善。本在有漏心中。若心重心轻。善恶俱尔也。昔经明理不圆。解亦微鲜。故以轻善伏于轻惑。今经所明。理既周足。信解深胜。故以增上之善。得抑上上之惑。所以知如此者。如戒律中。若犯第二篇。则于二十人中忏方灭。犯第三篇以去。直对手而除。乃至突吉罗罪。责心而遣。若寻此为言。则应轻罪。须多人而灭也。今则不然。故知。昔经理浅。生善则劣。止伏轻惑。今经理深。生福增上。能伏重惑。寻此而推。昔经不能令人得道。明矣

复次善男子如虚空中(至)一阐提辈立菩提因

案。僧亮曰。手疮者。阐提以耶见为手。有善则坏。取譬疮也

复次善男子如马齿草(至)密致犹如金刚不容外物

案。智秀曰。雨降无甄。密致者不受。阐提如是。岂法雨之咎耶

迦叶菩萨白佛言世尊(至)如是所说有何等义

案。僧亮曰。引昔说作恶不悔偈。证阐提不可化也。僧宗曰。更问昔偈。广彰其恶。先举可畏。欲显后偈无畏义也。宝亮曰。此下答第十五问。明三种罪人。闻涅槃经。改悔修善。能为人天之福田也。本时有恶。恒畏大众。今改往修来。则无惧矣。此答中说三偈。初一行作造恶于众有畏之偈

佛言善男子不见者谓(至)崄恶道者谓诸行也

案。宝亮曰。佛自广释也

迦叶复言如佛所说(至)如王夷坦道是义何谓

案。僧亮曰。引昔作罪能悔之偈。证四重可化也。上说发心。今说除恶也。僧宗曰。此答云何于大众得无畏。言依经改悔。广修诸善。众恶消灭。如王夷坦道也。宝亮曰。此第二偈。政明恶时不畏大众。说其本乃恶。今依经改悔者也

佛言善男子见所作者(至)何以故诸佛法尔

案。僧亮曰。至无至处者。无至名无始。从无始已来。尽发露也。又无至名涅槃。以发露能至涅槃也。膏油俱尽者。言佛由行。得自然相好。亦与人俱灭耳。若有菩萨以下。不信二人。用发露功德。回向菩提。即名菩萨也。为阐提毁訾。言无因果。然诸菩萨。不以彼恶。不舍而不救也。宝亮曰。从有生死际。至涅槃以来。所作恶业。尽皆发露。作此心而悔。则无罪而不灭也。猕猴捉水中月者。为阐提作喻。夫水中之月。月之影也。猕猴譬阐提。月譬涅槃。水譬有漏相善。水中月譬涅槃影也。无水则无月影。缘有佛说有漏之善。善本资向涅槃。气分相关也。凡夫修相善。故遏重惑。得人天报。无大粗苦。颠倒谓乐。犹如阐提。见生死中。五欲之乐。谓为真实也

作恶不即受如乳即成酪犹灰[雨/復]火上愚者轻蹈之

案。僧亮曰。作恶方便。及阐提之恶。不即受报。阐提生报。非现报也。如乳即成酪者。乳有现果。明不如此。愚者轻蹈者。愚人见现在。不见未来。以非现报。而轻造之。将出阐提之行。先说偈也。僧宗曰。还释作恶之人。所以造罪。以不见后世故尔。若使前念为恶。后念受报。谁敢为恶。以不见后世故。如灰覆火。愚人所践。不觉烧也。宝亮曰。第三偈。明不依经悔者也

一阐提者名为无目(至)流转生死无有穷已

案。僧亮曰。无目者。谓但见现在。不见未来也。不见罗汉道者。罗汉能断未生。而此人不见也。宝亮曰。譬如王使者。乃应出是罗汉似阐提。而但将菩萨来对。明此罗汉坚信大乘。一向拨法华以前经。云非实而是方便。言中乃以阐提也。王使譬菩萨也。善谈论者。明菩萨四辨也。奉命他国者。舍法身之地。应生死也。宁丧身命。终不匿王说者。乃可为外道所弊。终不唱佛是无常也。譬如莲华者。喻行人也。既协信作罪。若见涅槃日者。其信心必增明也

复次善男子如优钵罗华(至)何以故非法器故

案。僧亮曰。答问云何处浊世不污如莲华。与二人为譬虽有重罪。不障发心。不为罪行污也。法瑶曰。明菩萨能于众无畏。必忘身命。宣弘常住。而恶之世。耶见诽谤其说。而执解不从。不改其操。是处浊世不污。如莲华也。夫能不从外耶者。皆由自己肉眼伏累。不归烦恼污其内心也。故处烦恼。不能染也。四种莲华。生淤泥中不为彼淤泥所污。答处世不污也。次下句。虽有烦恼。终不为所污。以知如来性相力故。至譬良医。答烦恼不染也

大般涅槃经集解卷第二十二大般涅槃经集解卷第二十三

  广举十二种医譬明经力　释船师譬　释蛇脱皮譬释先陀一　名四实义　明改定经文失义旨事　释卖乳加水譬

    菩萨品第二

复次善男子譬如良医(至)唯除必死一阐提辈

案。僧亮曰。答问云何处烦恼。烦恼不能染。如医疗众病。不为病所污也。自下为经作譬也。八术者。一治身。二治眼。三治疮。四治小儿。五治耶。六治毒。七治胎。八占星宿。知所属可治不可治也。一方有二千偈。阿萨阇病。不可治者。喻二重罪。于昔契经。不治之病。明涅槃难治能治也。唯不能治必死病者。不可加治。非难治也。法瑶曰。余契经譬良医。经有八种药。谓苦空无常无我。不净慈心因缘观佛。灭八种病。四倒三毒及等分也。此下有十譬。悉明经有胜力。能拔重罪。八药者。谓八正道也。过八药者。此经理圆。功德力胜。故言过也。宝亮曰。答第十七问也。此第一譬。昔法华以前经教也。至后凡十二譬。至文自述也

复次善男子譬如良医(至)唯除生盲一阐提辈

案。法瑶曰。前言灭八倒。此言生八解。开二乘常住慧眼也

复次善男子譬如良医(至)若丸若散一切诸药

案。法瑶曰。八药譬除八倒病也。僧宗曰。吐下者。明罪报相也。涂身者。身意止观也。灌鼻者。谓数息也。薰身者。即薰禅也。洗者不净观也。丸者总观也。散者别观也

而贫愚人不欲服之

案。僧亮白。重罪既重障发心。故不肯服也。法瑶曰。前明二乘人。灭八倒生八解。此明凡夫及犯重者不信

良医愍念即将是人(至)以药力故所患得除

案。僧亮曰。地狱是其归处。譬舍宅也。畏苦发心。譬强服也。应障不障。譬患除也。夫不信者。以不顾无常。不惧罪对。诽谤以之而生。临终之时。谤罪对现。惧而改悔。于是息谤生信也。无常罪对。是思善之堂。为舍宅也。生必归死为还也。苦相切迫。然后始信。为强与服

女人产者儿衣不出(至)悉令发心除一阐提

案。僧亮曰。犯重之人。有微善根。能生发心。譬女也。未发心时。罪所缠裹。譬儿衣也。地狱之报未除。譬衣不出也。法瑶曰。明今之信。皆由昔善。昔善为母。今信为子也。解不即现。犹儿衣也。烦恼未断。为不出也。闻经则无惑不除。犹子衣即出也

迦叶菩萨白佛言世尊(至)云何能与作菩提因

案。僧亮曰。昔经所明。是二重罪人。闻经不生道果。云何今日。能令作因。更申向旨也

佛言善男子是诸众生(至)以是因缘我命得全

案。僧亮曰。二重罪人。闻经得悟。因果转明。叹此经恩也。法瑶曰。知今之解。藉昔微善。譬处胎也。由经力故生信。除不信之病。与母药也。以母善不朽。所以子解得生。譬我命得全也

奇哉我母受大苦恼(至)作菩提因除一阐提

案。僧亮曰。为罪所缠。譬受苦时也。罪既已久。譬十月。善根不断。譬怀抱也。今得发心。譬生后也。修行无漏。譬推干也。除断结惑。譬去湿也。制身口恶。譬除便利也。受持常乐。譬乳餔也。僧宗曰。行者为母也。方等为药。常解喻子。令人受持。譬与母药也。由经故有慧。譬命全也。修十地行。譬十月也。除爱慢故。譬推干去湿也。得果之日。酬于本期。譬报恩也。力者三十二相。乃至十力也。四部第子。如侍卫也

复次善男子譬如良医(至)唯除大龙一阐提辈

案。僧亮曰。医譬佛也。子譬菩萨也。无上况术。譬佛性常也。若龙若蝮。譬二重罪也。药譬名味句身也。革履譬书之于纸墨也。触诸虫者。譬读诵也。毒为之消。譬发心也。法瑶曰。良医譬经文。子譬常住二字也。欲明但闻二字。已是灭恶。况具闻经耶。灭四重五逆。故譬涂革履。触诸毒虫。毒即消也

复次善男子譬如有人(至)除不横死一阐提辈

案。僧亮曰。毒药譬佛性。以始闻故。譬新也。大众譬有为行也。声者譬读诵也。死者譬烦恼灭也。法瑶曰。常理如药。文字如鼓。以药毒故。闻鼓则死。其理深故。听之者罪灭

复次善男子譬如闇夜(至)于诸善法无所营作

案。僧亮曰。余经所说。理不同故。譬闇也。日譬此经也。重举两者。闻此经。如天之泽万物滋长也。僧宗曰。如法华中八十声闻者误也。彼经云八千声闻也

复次善男子譬如良医(至)其余皆菩萨摩诃萨

案。僧亮曰。医譬此经也。非人譬犯重也。妙药譬常住二字也。使者譬受持此二字者也。速与彼人。譬为说此二字也。自往譬具足得闻也。法瑶曰。凡四部之中。未闻常住者。及外道犯重五逆非法之徒。为他人子也。经为良医。理为妙药。文存传理。为遣使送药也。理贵流通。流通要由文字。为敕语使言卿持此药送与彼人也。闻经之理。众魔恶友。不能为患。犹人有药力。鬼神远去也。僧宗曰。犯四重五逆者。一往闻经。为见使也。思惟于理。为吾威德也。以此二事。其罪得灭也。宝亮曰。此第八譬。明经力彼及外道也。医譬佛也。使譬菩萨。药譬此经也。为彼解说。如送与也

复次善男子譬如聋人(至)所以者何无因缘故

案。宝亮曰。第九偏为阐提作譬也。闻经不能生信。如聋之不闻

复次善男子譬如良医(至)终不能治一阐提辈

案。僧亮曰。犯重戒人。不断善根。方之阐提。微为胜故。譬王也。必入地狱。譬必死病也。报在未来。于今不现。譬腹内也。律能治罪。譬下药也。劝令看律。而不肯信。譬不肯服也。经力发梦。使地狱受苦。狱是下道。譬粪门生疱也。亦受畜生之报。譬虫血杂出也。法瑶曰。卿不见我腹内事者。不信断善根。受地狱报也。应服下药者。阐提初入地狱。便有三念。为自知也。经说胜理。如医白王也。良医术力者。譬常理也。隐处譬地狱也。宝亮曰。第十譬。诸佛善说五时经教也

复次善男子譬如良医(至)必死之人一阐提辈

案。僧亮曰。此语势及之。非义宗也。谓其罪既重。法不能救耳。僧宗曰。上来八譬。悉以咒经也。此两譬佛菩萨也。宝亮曰。第十一譬。由以除八倒为喻也

复次善男子譬如良医(至)最尊最胜众经中王

案。僧亮曰。如来教法。先浅后深。唯涅槃究竟。无惑不除也。宝亮曰。第十二譬。与法华之前经作喻也。除三毒并等分。及四倒故。故言八术。复能博达过八种者。譬涅槃经教。有十二术也。此两譬所以就人为喻者。遣物疑也

复次善男子譬如大船(至)化度众生亦复如是

案。僧亮曰。次答船师问也。生死苦海。人皆求度。而经能劝人修学。佛度生死。更无余道。乘大涅槃。以救苦人也。下二风譬。初譬速度。后譬自庆。皆劝美也。宝亮曰。自前四问。明因中利益。此明果中利益也。有三意。此第一先明诸佛得度已还济众生也。智秀曰。答第十八问。此下三问。皆明经力能为外物作缘。船有二种。一者为众生作境界。正以信教。故便能生善也。二者妙佛住果地。还度生死也

复次善男子譬如有人(至)堕于地狱畜生饿鬼

案。宝亮曰。第二意。度生死所以速者。经之力也。法瑶曰。众生虽有五戒十善。欲度大海。若住此善。则不离生死。闻此经则超越也。僧宗曰。诸行为船。涅槃为风。修行万行。必须圆解常教

复次善男子譬如有人(至)大涅槃经生清净信

案。宝亮曰。第三意自庆也。法瑶曰。众生为苦所切。思善反恶之时。惑经修行。日进无退也。僧宗曰。厉物情也。生死轮转。所以不息。正由不值涅槃之风。岂不深发增上之心耶

复次善男子如蛇脱皮(至)亦名常住无有变易

案。僧亮曰。上说涅槃。能度生死。非余契经。以此释之也。佛之真身是实。涅槃说实。见实则生死尽也。应身非实。契经以之为实。不见实故。生死不尽也。法瑶曰。蛇脱皮者。止明双树一迹耳。虽现舍生死。而迹无生灭。法身常一也。僧宗曰。答第十九问。向云乘涅槃船。济度众生。实无生灭。物以王宫之生。双树之灭为疑。故以此譬拂滞也

复次善男子如庵罗树(至)如来常住无有变易

案。僧亮曰。次答问云何观三宝。犹如天意树也。上劝修经。今说修经之法。有二意。先解如来身密。犹如无意树也。次解口密。如先陀婆也。法瑶曰。天树随意感变。人树逐时而迁。迁变虽异。而树实常存。举人树。则天树可知也。故近取此树。远况三宝也。此譬与船师蛇脱皮。通明一身始终之示现也。僧宗曰。答第二十问。向举蛇譬。一往但明非实灭也。今寄树譬有三时之变。广明初生乃至涅槃一应之迹也。此下有五重明义。第一举树譬。虽有三时之变。实则不灭。第二明口密。能以非常之言。密诠常旨。第三因明三宝兴衰之相。以人不行故。义言灭也。第四劝立丈夫之志。既理由人弘。故抑抗其辞也。第五更出末法三宝衰灭时节之处所也。宝亮曰。开此答中。有三意。第一明三宝有衰盛之相。第二明法灭之相貌也。第三教行者作业也。从此下。先明佛宝现有灭也

善男子如来密语甚深难解(至)凡夫品类所能信也

案。僧亮曰。次显口密也。如彼智臣善解密语。可以类求修经之法也。以先陀婆譬四非常。一名四实。修心常法者。知有常因。能得常果也。僧宗曰。第二明口密也。彼以一名。表四种之实。此一偏教。亦表常我四实理也。有智之人。因四非常。悟于常乐。事同应身。虽有三时。而识法身是常存也

复次善男子如波罗奢树(至)以是众生薄福德故

案。僧亮曰。更以三树。譬涅槃衰灭之时。不解密语。常雨不降。不得常果也。水陆枯悴。譬无人天善也。药无势力。譬余契经也。僧宗曰。此第三炎明三宝衰灭之相。言末代不能流传也

复次善男子如来正法(至)随顺不逆为众生说

案。僧亮曰。上言灭后者。此明法欲尽时。不解密语。受学经者。抄略前后。分作多部。唯诸菩萨。解密语者。不违经旨也

复次善男子如牧牛女(至)复加二分诣市卖之

案。僧亮曰。譬行经之人。广上懒堕求利之事也。僧宗曰。加二不已。乃至于八。无复乳味。诸恶比丘。为利养故。安置浮辞。使理味难解也

时有一人为子纳妇(至)乳之为味诸味中最

案。僧亮曰。一人者。譬密语菩萨。将使弟子为化。绍嗣不绝。譬之纳妇也。化必须法。譬求乳也。求法为物。譬待客也。有法之处。譬之市也。得财乃说。譬索价也。读诵受持。譬用作糜也。僧宗曰。复改换文辞。故是筌常比之。余教不可譬

善男子我涅槃后正法未灭(至)能灭正法色香美味

案。僧亮曰。合第一加水也

是诸恶人虽复读诵(至)庄严文饰无义之语

案。僧亮曰。合第二加

抄前着后抄后着前(至)诸恶比丘是魔伴侣

案。僧亮曰。合第三加

受畜一切不净之物(至)如牧牛女多加水乳

案。僧亮曰。合第四加也。昙纤曰。止取抄前着后。为一加。抄后着前。为二加。前着中后。为三加。中后着前。为四加

诸恶比丘亦复如是(至)以是义故名大涅槃

案。智秀曰。通举上譬略合也

复次善男子若善男子(至)如蜂采味汝亦如是

案。僧宗曰。第四劝立丈夫志也

复次善男子如蚊子泽(至)无上正法将灭不久

案。僧宗曰。第五更出末法三宝衰灭时节之处所也

大般涅槃经集解卷第二十三大般涅槃经集解卷第二十四(大众问品第十七)

  释本有今无偈　释世若无佛非无二乘得二涅槃义　释栴陀罗得受记义　出佛自受纯陀供以化佛受大众供事　佛说十三偈谓假　使乌鸱同一树义

    菩萨品之第三

尔时文殊师利白佛言(至)重为分别令得除断

案。僧亮曰。次答三乘若无性。云何而得说也。上再说因果经体已同。屡劝修行。而未明修法。将说五行。而是修本。更以十问。释疑劝信。所以然者。经之因果。理致幽远。纯陀先知。时众犹故有疑。文殊知疑。而不能决。更以事问也。疑谓。从缘得法。皆是无性。三乘成果。皆从缘得。若佛是常。二乘亦常。二乘无常。佛亦无常。故云无差别也。若二乘是常者。云何乐实未生。而名为受乐耶。僧宗曰。从此讫最胜无上道。悉为广叹也。经之为益。不出因果。前七问中。四问因益。三问果益。一周明义。因果两益。竟于前文。此下文殊。腾纯陀疑。以为广叹。以得解者。由此经也。宝亮曰。纯陀所疑。与迦叶所问。意同而辞异也

佛言善男子云何疑心(至)声闻缘觉无有差别

案。法瑶曰。上明三宝。有时而盛。有时而衰。似非常住。致生疑惑。是以纯陀。示同有疑。文殊申述。扣发大圣也。将显三乘佛性。同归一致。是以三宝。可得而不灭。如其不尔。是则三乘无性。岂同湛然也。僧宗曰。疑谓。本无今有。无常法。如来既是本无今有。就事而求。应是无常。而开宗言常。是故疑也。又迦叶上问三乘无性。便是应无。如其有性。则应见用。二大士之言。辞异有同。佛下引偈。以答两家

尔时世尊即说偈言(至)亦有差别亦无差别

案。僧亮曰。本有今无者。本有烦恼。而无涅槃也。本无今有者。本无般若。而有烦恼也。若谓佛三世。皆有烦恼者。无有是处也。是故缘虽同。而所以为异也。有烦恼故无常。无烦恼故有常

迦叶菩萨白佛言世尊(至)利益安乐一切众生

案。僧亮曰。迦叶为请法之主。以上义隐。须明问以广之也

佛言善男子谛听谛听(至)业报因缘令乳色一

案。僧亮曰。长者譬先佛也。牛譬行人。色异譬三乘也。一人譬今佛也。三乘成佛。报先佛之恩。如祠祀也。得大涅槃一器也。色白譬我乐净也。寻便惊怪。至皆同一色。将释所由。假为惊辞。怪因异而果一也。是人思惟者。谓八万行因果不应异也

善男子声闻缘觉菩萨亦尔(至)所以者何同尽漏故

案。僧亮曰。合前而乳色一

而诸众生言佛菩萨(至)解悟乳相由业因缘

案。僧亮曰。合先怪而后悟

复次善男子譬如金矿(至)以断无量亿烦恼故

案。法瑶曰。前譬明缘因佛性同耳。此明正因果佛性也。明三乘同有此性。修道断结。陶冶成佛。此理非是本有今无。本无今有也

迦叶菩萨白佛言世尊(至)如是说者多有过咎

案。僧亮曰。将问差别。先难无差。谓因亦是有。果亦是有。有义不异。有何差别。众生有性。似如己有。致此难也

若诸众生皆有佛性(至)如来涅槃而不般涅槃

案。僧亮曰。谓若是先有。得便应同。不应有异也

善男子诸佛世尊所得涅槃(至)大般涅槃名为善有

案。僧亮曰。唯佛乃得。故非先有也。若非先有。则二难俱释也。名为有者。有为不善也。三事无为。名为善有也

世若无佛非无二乘(至)出现于世开示三乘

案。僧亮曰。唯佛具善有耳。非佛得者。非善有也。乃有一佛者。善有难成。旷劫乃就也。开示三乘者。三非实有。非先究竟也。法瑶曰。此明二乘不得涅槃义也。涅槃若极。菩萨近之。无佛之世。尚无得者。况二乘耶。而云二乘得者。是不实也。僧宗曰。根有大小。悉有广狭。世无大心众生。为说常果。令作佛者。非无权说二乘得二灭也。以其志小。权说引接。得知虚果未极。何容责使同佛涅槃耶。又释若世间。都无作佛理者。非无二乘得二涅槃。理既不尔。故知二乘权设小果。何得同佛耶。无量劫乃有佛出者。释上句也。谓圆解难固。常倒易生。无善感佛。不得恒现。善机希有。所以时一出世。背化失机。动经劫数。云何说大耶。致教唯以三乘级引。故知。小果权施。而非实也

善男子如汝所言菩萨二乘(至)是故名为大般涅槃

案。僧亮曰。上已总答。更引昔说。别答前难。昔说伊字之譬。及解脱是色。而声闻非色。已说三事善有之义也

迦叶言如佛说者我今始知(至)亦有差别亦无差别

案。僧亮曰。称佛二。说而领解也

迦叶言云何性差别(至)杂诸烦恼亦如是

案。僧亮曰。上已说佛及二乘有异。未说人人各异。故重问也。声闻如乳者。因有远近。声闻菩萨。于佛亦尔也

迦叶复言狗尸那城(至)目楗连等速成佛道

案。僧亮曰。上说声闻凡夫因有近远。而欢喜旃陀罗。在千佛数中。而不说声闻。是则因近而更远。何耶

佛言善男子或有声闻(至)以发速愿故与速记

案。僧亮曰。行有内外。偏行者迟。遍行者速。而声闻偏行外行也。所以然者。先有小心。须偏行以去之。凡夫不尔。是故速也

复次善男子譬如商人(至)护正法者为授远记

案。僧亮曰。此下说凡夫。知声闻志小。自轻已行。若与速记。必有深失。下合譬中。说其事也。商人譬佛。珠譬得记之行也。市卖者。譬授记之辞也。颇梨珠者。譬生死行也

迦叶菩萨复白佛言(至)所得眷属不可阻坏

案。僧亮曰。次答云何诸菩萨。而得不坏众也。因上声闻护法庄严眷属。眷属是佛外果。即以外果劝进也

迦叶菩萨复白佛言(至)以是义故名为肉眼

案。僧亮曰。答云何为生盲。而作眼目导也。次以内果劝信。若不识常果。不知身是常因。对因不见。名生盲也。下不知手足等事。名为无眼者。常是未能见之者。是障外之事。名无眼者也

复次善男子如来常为(至)以是义故名为父母

案。僧亮曰。次答云何示多头唯愿大仙说也。以说劝信。谓说者是佛。佛有大慈。是众生父母之言。不可不信也。所以者何以下。一音所说。各各得解证慈也

复次善男子如人生子(至)而为众生叹说妙法

案。僧亮曰。次答云何说法者。增长如月初。初说无常。后则说常。似如欺人。不慈众生。非父母义。明不正也。故以父母教婴儿。为譬也

    大众问品第十七

案。僧亮曰。事已究竟。佛欲涅槃。大众请佛。以为品名。次答云何复示现究竟于涅槃也。下讫猗卧五事。是现涅槃义也。前后各一事。寄不食不病。证佛不灭而应灭。以显涅槃是示现也。中间闻三事。示一切事讫也。知佛常住。明现在化讫也。说有余无余。未来教讫也。为文殊等受记。菩萨事讫也。五种究竟。故现灭也。法瑶曰。上增长如月初者。先明浅近无常之说也。此言其终极常乐教言示现者。明实不灭。显常住之义也。僧宗曰。答第二十六问也。亦名随喜品。下文大众。闻佛说常。咸皆随喜。又云。纯陀成道。我亦随喜也。偈前长行。末是答问也。偈中明不灭示现之义乃显也

尔时世尊从其面门(至)充满具足持至佛前

案。僧宗曰。意在催供也。宝亮曰。古佛道法。过中不餐。其时既至。不容发言。故放光以显意也。智秀曰。此下长行中。有十事。此即第一。是经家述纯陀蒙光。即知其事。起办供也

尔时有大威德天人(至)前至佛所奉其所施

案。僧亮曰。光明重催。知供时必至。所以感而从也。智秀曰。第二事也

尔时天人及诸众生(至)听诸比丘受此供养

案。僧亮曰。佛已不受。不敢复请。故仰悕大悲。听诸比丘受也。智秀曰。第三事也

时诸比丘知是时故(至)如西方安乐国土

案。智秀曰。第四经家述诸比丘。亦知时而起也

尔时纯陀住于佛前(至)最后具足檀波罗蜜

案。智秀曰。第五重请佛住

尔时一切菩萨摩诃萨(至)所设供具则为唐捐

案。智秀曰。第庆纯陀也

尔时世尊欲令一切(至)自受纯陀所奉设者

案。僧亮曰。化佛不食。表释迦亦然。以显不灭而现灭也。自受纯陀所设者。为应见者。有此说耳。非定尔也。僧宗曰。法身无像。应化何殊。自受纯陀者。示请主有人。显彼无宿愿之异耳。智秀曰。第七事也

尔时纯陀所持粳粮(至)一切大众亦复如是

案。智秀曰。第八事。叙纯陀与大众愿遂。一切欢喜也

尔时大众承佛圣旨(至)所食之物亦无差别

案。智秀曰。第九事。叙大众承佛旨。故能有涅槃之念

是时天人阿修罗等(至)无上调御盲无眼目

案。智秀曰。第十事。向叙怀念。今述发言也

尔时世尊为欲安慰(至)此则是诸佛最上之誓愿

案。僧宗曰。此中说十三偈。无指的文也。正应各除前后四偈。取中央偈也。大意。明佛法身圆极。应而不灭也。前四偈。一往慰喻。后四偈。令其安心有在。不应愁恼。即是答上示现究竟涅槃义也。上言示现。明如来久已成佛。入伊字圆德涅槃。说此妙义。令大众开解即示现。又一义。既妙本不灭。是则应迹。无时不化。但一应不现。亦言灭也。宝亮曰。唱有十三偈。誓唯十二。不知所以而然也。或是偈之零落。不尔者。十三字误。应为十二也。智秀曰。偈中分为四阶。第一有一行半。明久能现入涅槃。其实长存也。第二次有一行。明得涅槃。故久无饥渴之苦也。第三次有十四行半。广举诸譬。明今非实灭。示现灭也。即此十四行中。复有三意。前一行半劝也。中十二行。正显偈旨也。最后一行。结劝意也。第四有四行。举三宝长存。明涅槃相也。有三意。初两行劝。次一行举三宝。劝求常果也。后一行举诸佛誓愿。结成所以劝意也

若有比丘比丘尼(至)观了三宝常者是栴陀罗

案。昙纤曰。次答问云何勇进者。示人天魔道也。明若能随佛发前誓愿。是即天道。不解一体三宝。常乐我净。是名魔道。栴陀罗者。即是杀者。魔之异辞也

若有能知三宝常住(至)无有娆害能留难者

案。智秀曰。次答云何知法性。而受于法乐也。明三宝是真法性。有能知者。则永受安乐也

尔时人天大众阿修罗等(至)鼓天伎乐以供养佛

案。僧亮曰。以此答云何知法性。受于法乐也。时会知佛常住。是知法性受安乐也。谓现在化道已讫。应现灭也

尔时佛告迦叶菩萨言(至)皆知如来是常住法

案。僧亮曰。欲令人说异见。显如来密力。皆是知法性受乐之事也。有两翻。此第一先问迦叶也。宝亮曰。就迦叶答中五事。第一见诸佛甚多。第二见所坐甚小。而能容也。第三见大众各随佛说十三偈。第四见大众各心念言。唯我独得供养释迦。第五见纯陀之供。虽复鲜少。而足大众也

尔时世尊告纯陀言(至)摩诃萨等之所围绕

案。宝亮曰。纯陀自见一事。并前合为六事也。此明现在事毕。从得道已来。所化可利益。有缘得益者。讫于此矣

佛告纯陀汝先所见(至)菩萨所行具足成办

案。宝亮曰。上已广略两重明常。复答二十余问竟。乃结果云。纯陀住十住地。所作成办。当知理教可征也。何应指说陀罗尼咒。而顿有六万四千人。得无生忍者。故知。昔教定是方便。今教定是真实。若昔纯不数。以方便唱云。有人得道者。则下愚入道之心不勤

迦叶菩萨白佛言世尊(至)说是大乘大涅槃经

案。僧亮曰。追答第二十七问。明未来事讫。为开邪正两门。十恶为魔道。十善为天道。使改恶行善。故言未来事讫也

大般涅槃经集解卷第二十四大般涅槃经集解卷第二十五

  释有余无余偈义　论施阐提无福义

    大众问品之第二

世尊一切契经说有余义(至)亦有余义亦无余义

案。僧亮曰。昔说契经。具二种。如法华中。说一解脱。是无余也。复倍上数。是有余也。其余皆尔。法瑶曰。谤法犯重五逆罪等。初无改悔。护法之心。必断善根。向一阐提。此谓亦魔道也。若能常怀惭愧。起护正法之心。以此因缘。戒还如初。谓亦天道也。从此竟弃舍破戒。如除稊稗。答此问也。智秀曰。此下讫第四八戒斋法。正答第十问。云何为众生。广说于秘密也。而先讫除弃破戒。如除稊稗。答第十六问云何诸菩萨远离一切病也。所以尔者。向辨难施有余。仍显离病之法也。破戒之罪。能坏身心。谓之为病。经力能灭。故致此问也

纯陀白佛言世尊如佛所说(至)余一切施皆可赞叹

案。僧亮曰。阐提者。无信等善根。名为阐提。杀之则无从地之罪。施之亦无从地之福。故除之也

纯陀问言云何名为(至)一阐提者其义云何

案。僧亮曰。问已成阐提未成阐提之间也。纯陀意谓。虽未成阐提。此既重恶业人。虽有微善。要与无善根同。是以重问也

佛告纯陀若有比丘(至)亦名趣向一阐提道

案。僧亮曰。成其问也。说四种恶人。永无改悔。趣向阐提也

若复说言无佛法众(至)施其余者一切赞叹

案。僧亮曰。谓法相无边。不可一人知尽无佛法众。虽有因果。亦向阐提也

尔时纯陀复白佛言(至)如是等人名为破戒

案。僧亮曰。三逆谤法。不必有戒。其言破戒。此义云何。若犯四重。至名为破戒者。明比丘害亲谤法。其罪则重于在家。今云何但说破戒也

纯陀复问如是破戒(至)我说是人不为破戒

案。僧亮曰。举二因缘。一生重悔。二勤护法。具此二善。不障解脱。名不破戒

何以故善男子譬如日出(至)有施是者福不足言

案。僧亮曰。上虽说受学大乘。未明能救重罪。是涅槃经也

又善男子犯重罪者(至)施是人者得胜果报

案。僧亮曰。法有深浅。作罪之心。有轻有重。重心作罪。轻心不能灭也。乃广说其相也

善男子譬如女人怀妊垂产(至)有如是等无量果报

案。僧亮曰。譬重心护法。法由人弘。弘法在行。谓戒定智慧。次第相生。今日慧解。藉戒定为因。因譬女也。今解譬子。昔日戒定甚净。必生胜慧。譬垂产。遇值恶缘。而犯重禁。譬国乱也。舍净之秽。譬之他土。以本因力。闻涅槃经。譬天庙也。信常乐净。以譬生子。又闻经说护法功德。能除犯重。譬闻旧邦安隐丰乐。勤加护法。譬携持其子也。欲令本戒清净。譬还本土也。末法耶惑。执偏教者。不受常说。譬水暴急不得度也。遂执常解。没命不舍。譬命终也。虽有破戒本恶。以护法之功。起登大道。为天中也。法瑶曰。为改悔护法者。设譬也。明昔善已有今解之萌。譬怀妊也。天庙者。讲法之处也。闻法改悔。生护法之心。譬生一子也

纯陀复言世尊若一阐提(至)一切所施非无差别

案。僧亮曰。庵罗果者。果能生果。譬善能生善也。种果之法。破核除肉则难生。全核因肉则易生。而犯重罪之人。以譬食果肉也。吐核置地者。核生虽难。犹自可为果种。明虽犯重罪。而犹有微善。可作善种也。破而尝之者。以贪甜故。灭果种也。譬愚痴重故。断征善根也。心生悔恨以下。明果种已断。虽欲将护。果不可生。譬善断不悔。安得生哉。不名阐提者。以不悔故。名阐提耳。非以悔故。名阐提也。法瑶曰。此譬不改悔一阐提之徒。初受戒为食果。破戒为吐核也

纯陀复言何故如来(至)舍弃破戒如除稊稗

案。僧亮曰。是佛弟子。未得清信。亦事尼楗。为说唯施尼楗有福。余则无福。疑以问佛。佛因事答之耳

复次善男子如我昔日(至)一切自在必受安乐

案。法瑶曰。上来所明。无余之义。一周已毕。今次明昔说皆亦有余不尽义也。行者若能了此有余法性。则无八倒之苦。唯受于法乐耳。从此竟品。答云何知法性。而受于法乐也

尔时文殊师利菩萨(至)广问如来如是偈义

案。僧亮曰。女无实德。男不自在。世间无乐。不应起慢。不受佛法也

尔时文殊师利法子(至)如是之人则我弟子

案。僧亮曰。有罪求悔者。须受悔者欢喜也。故但随不逆。必因受悔者而得清净也。故不观作以不作。要内怀重愧。知不悔为恶。悔之为善。故但自观身善不善行

尔时世尊为文殊师利(至)咨问如来如是密教

案。僧亮曰。若罗汉以己譬彼者。凡夫须护。罗汉亦应须护也

尔时文殊师利复说是偈(至)则堕无间狱

案。僧亮曰。无明是众惑之主。譬父也。贪爱性染。譬母也

尔时如来复为文殊师利(至)问于如来如是密语

案。僧亮曰。属师义不成者。制命由师。众义斯备。苦义不成也。不属师义不成者。不从师训。愚闇无知。乐义不成。若得自在。不成就者。不属师故。愚闇无知。不名自在

文殊师利复说偈言(至)我于尔时为说此偈

案。僧亮曰。二偈说八戒功德。八戒以斋为本。释所以斋也。生死之本。食与嫉妒。难卒除也。斋以损食。是厌生死之义也。是以佛诃帝释。漏尽之人。应说此偈。偈在论文。一切有大力者。释不令断食。为断嫉妒。外道厌生断食。身无力故。不能思道断嫉妒也。多病苦者。苟是渐损。不制中前。而制中后者。夜食不消。多得病苦。于道亦妨。一切净行。是八戒也。处中是净。安乐是涅槃也。汝若得病。我亦如是者。明中后斋法。本为凡夫。不为圣人也。第四八戒者。十戒具戒。此二戒是出家戒也。五戒八戒。此二戒是在家戒也。故云第四也

尔时迦叶菩萨白佛言(至)云何复名一切义乎

案。僧亮曰。无余之义。经经皆有。但从始至终。事事皆实也。智秀曰。由佛说法。有今昔两异。愿闻定说也。请答第八问云何说毕竟不毕竟耶。如令今教。定能断疑者。昔何以作不定说

善男子一切者唯除助道(至)汝今所见微妙甚深

案。僧亮曰。欲以一释两遣也。先说无余。其外是有余也。正因缘因。相助断惑。因名助道。说因尽也。果名常乐。说果尽也。所以言善者。常则非善非果。以差别之因果无遗。谓一切也。说皆是实。谓无余也。智秀曰。亦名无余者。正出定教。显佛圆果。因此言是也。其余诸法者。出不定教体也。欲令乐法诸善男子者。释其后意辨不定之说。皆为时情

迦叶菩萨白佛言世尊(至)读诵通利书写经卷

案。法瑶曰。向明知法性。今明所得功德。即是受法乐矣。智秀曰。次答云何而得近最胜无上道也。明持经得功德。自然趣向无上果也

尔时诸天世人及阿修罗(至)诸菩萨等得住初地

案。僧亮曰。初地具檀波罗蜜。佛现身密。受其供养。功行如此。故称初地也。智秀曰。略说中。第三略附嘱也

尔时世尊与文殊师利(至)及与纯陀而授记莂

案。僧亮曰。未得位者入位。已入位者受记。第三菩萨事记也

授记莂已说如是言(至)右胁而卧如彼病人

案。僧亮曰。第五现涅槃事讫也。智秀曰。就付嘱中。有五重。第一天人请。第二佛答。第三天人设供养。第四为受记。第五付嘱也

大般涅槃经集解卷第二十五大般涅槃经集解卷第二十六(现病品第十八)

  出无病因谓怜愍众生施病者药　释五种人谓须陀洹八万劫得菩提乃至辟支佛十千劫得菩提义

    现病品第十八

案。僧亮曰。次答云何诸菩萨远离一切病。病在前品已明。而未释无病。是则示现之义未彰。此品显也。法瑶曰。因佛现病。迦叶得广显无病之因。明菩萨地时久已离病。岂况今耶。是则因病以显不病也。僧宗曰。上来所说。当宗虽举。未有微实。将显至人。患累斯尽。是以先示病相。因请更起光仪显胜。以表无病之旨也。因答第二十九问也。智秀曰。此下是经之第二段。广明义也。又有二别。第一广正说。第二广流通。广正说中有三科。第一广果。即此品也。第二广因。即五行也。第三广佛性。即师子吼迦叶两品也

尔时迦叶菩萨白佛言(至)患苦悉除无复怖畏

案。僧宗曰。此下举八事。仰推如来不应有病也。智秀曰。此下有四翻。第一迦叶举七复次事。推佛无病。第二佛以神力现三种相。第三群生蒙益。请佛说法。第四广述无病以遣时情

世尊一切众生有四毒箭(至)汝等当为大众说法

案。僧宗曰。第一明有病之因。莫过此四箭。如来已离。不应病也

有二因缘则无病苦(至)何缘于今自言有病

案。僧宗曰。第二无病之因。莫过此二。世尊所行。故无病也

世尊世人有病或坐或卧(至)云何默然右胁而卧

案。僧宗曰。第三明如来既无笃病之相。云何有病耶

诸菩萨等凡所给施(至)永断如是三障重病

案。僧宗曰。第四明自昔已来。外化事旷。善功还已。不应有病也

复次世尊菩萨摩诃萨(至)乃于今日唱言有疾

案。僧宗曰。第五明修因之日。备有诸愿。略举九愿。显无病之要旨也

复次世尊世有病者(至)不应说言我今背痛

案。僧宗曰。第六明世人临终之时。不能有所诫敕。高推如来。不应同此

复次世尊世有病者(至)不应默然右胁而卧

案。僧宗曰。第七苟有此迹。必为外道所诮

复次世尊世有病者(至)利益于众生摧伏诸外道

案。僧宗曰。第八借以身力推。比佛必无有病。仍说偈以劝也。智秀曰。此七复次。是第一翻。推佛不应病也

尔时世尊大悲薰心(至)修行恶法除一阐提

案。僧宗曰。前偈请云。大悲今何在。是以经家以佛起故。故云大悲薰心也。智秀曰。此第二翻放三种神力。以利益也

尔时一切天龙鬼神(至)遍至净居悉皆闻之

案。智秀曰。第三翻大众蒙益。广设供养。请说法也

尔时佛告迦叶菩萨(至)便谓如来真实有疾

案。智秀曰。第四翻佛先广显久离病也

迦叶如言如来人中师子(至)亦不毕竟入于涅槃

案。僧亮曰。既广如来永无病理。若言有病。是密教也。因此复得广宣秘密。次答。云何为众生。广说于秘密

迦叶是大涅槃即是诸佛(至)非是声闻缘觉行处

案。法瑶曰。此下讫云何当有诸病苦耶。次答问云何复示现究竟于涅槃

迦叶汝上所问如来何故(至)云何当有诸病苦耶

案。僧亮曰。次答云何复示现究竟于涅槃

迦叶世有三人其病难治(至)供养恭敬为他说者

案。僧亮曰。次答云何说毕竟及与不毕竟也。先说病行者。大众请佛治病。说先治病之行也。药以对病为名。依涅槃修行。无病不治。欲显病行之能。先说诸经。有不治之病也。此三种人。契经所不治。是说毕竟二乘之病。闻余方等。虽发心。不知佛常终。不成佛不名毕竟者。如上诸人。闻涅槃生信。不须外治。自能成佛。断疑说也。得病行之名。事尽于此也。法瑶曰。是大涅槃。即是诸佛甚深禅定。非是二乘所行之处。入此深定。故曰毕竟入于涅槃也。非永尽灭入涅槃故。不名毕竟入于涅槃也。毕竟不毕竟义。存于此也。僧宗曰。毕竟不毕竟。各有其旨。非不定也。但执言失旨。以为不定之说。疑网是生。得旨则知定说。疑网断矣。又一义昔教皆说毕竟永尽。今因现病。以表无病。得显病是密语。因广说如来之密语也

迦叶有五种人于是大乘(至)有病行处非如来也

案。僧亮曰。次答云何而得近最胜无上道也。上云自然得成。今转近为得。但说五人者。以断结定故。凡夫定位。无劫数之限也。八万劫者。后云得菩提心。亦云八万劫住处。是小涅槃。似是菩提心成就耳。思惟烦恼。小乘断之。不必在菩萨。劫数如此。故知偏爱易断。等悲难成也。法瑶曰。因表如来无病得命病者。心之义也。二乘有病。不能发心。要从佛闻法也。夫利根虽不从佛闻法。而自发心。知此二人。所以得近无上道也。昙谶曰。五种人者。从须陀洹。乃至缘觉。以一果准两地。如是以初地二地准初果。乃至九地准缘觉也

大般涅槃经集解卷第二十六大般涅槃经集解卷第二十七(圣行品第十九)

  出求戒方便　释菩萨五支戒　释世教戒正法戒　释性重戒息讥嫌戒　释不折戒等九戒　结持戒果

    圣行品第九

案。僧亮曰。次答问我今请如来。为诸菩萨故。须为说甚深微妙诸行等也。前品已说病行。请其余者。故名等也。五行者。上虽说病行对治烦恼。未说行相及行次第。今说之也。何者要自无缚。能解人缚。故圣行在初也。若解人缚。功由四等。故次说梵行。四等广济。事须神通。神通之道。四禅为胜。故次说天行。神道接物。或愚或智。故次说婴儿行也。如是四行。若在学也。对治烦恼。名为病行。若在无学名如来行。以如来能说能行故也。法瑶曰。所以次明五行者。前二乘凡夫。发无上道心。此心非不远行五行。即前问中。微妙诸行等也。师子吼广明佛性。即前问中。安乐性也。安乐性为正因。微妙行为缘因。非此二因及前发心。何由而得近无上道。是以此答云何而得近最胜无上道也。行虽无量。五实总也。圣行慧照。以谈内也。梵行彼物。以论外也。以此二行通十地矣。婴儿行病行者。是权智方便之所示同也。此行唯八住以上耳。又病行者。苦行也。唯菩萨能行。二乘有病。而不能行。为病行也。天行经不说。故不说也。僧宗曰。前来所辨。论因论果。结经名字。显流通。皆前略后广。经体所明。文理圆备。除惑灭罪。功胜余经。是以从未发心以下十九问。广叹经力。亦备讫前文矣。从此已下。明依经造行。终期极果。即答前第三十三问也。宝亮曰。此下竟十功德。通答第三十三问也。五行正明行体十功德。更广行以理有。此两明立行之方法也。夫万行虽众。而以自行化他两门收矣。令离之为五。就圣行之中。出天行也。梵行中。出婴儿行也。唯病行无体。不的有所属。智秀曰。犹是广詶现病品中迦叶及诸天等。所谓因果之义。上已广果。果由因得。因宜更显。自此以下。讫十功德。重明因义。即是广因义之中第二意也。由业趣果。亦乘果接化。皆是行之义也。言五行者盖一方之数耳

尔时佛告迦叶菩萨(至)所谓大乘大涅槃经

案。法瑶曰。大判辨圣行始终。有三翻。第一从出家已下。明修戒也。第二从不净观已下。明修定也。第三四谛已下。明修慧也。僧宗曰。就辨五行之义。前三各有体也。从二就功用立义。若通而为论。三行之名。皆可名圣也。若别谈功用。取偏显立称。余义则没而不说也。圣者正也。戒定慧为体。谓正直之路。无邪曲也。夫自行化他。乃行之通也。今就戒定智慧。自行之体中。出化他之德。谓天行梵行者也。天者言净。梵亦净也。云何为异。此二名者。就果立称。下文言天者。谓第一义天。又经论并云。各有旨也。梵以对欲界重粗得名。天者以对人为称。经云梵名涅槃。是道欲到也。虽从果立称。而天行以四禅为体。广前定也。梵行以四等为体。广前慧也。戒用浅劣。略而不广。以此三行能治病故字之病行。示同婴儿。即称婴儿行也

迦叶云何菩萨摩诃萨(至)得闻如是大涅槃经

案。僧宗曰。大分圣行可为六段。第一明戒。第二明定。第三明慧。此三段明体既竟。第四叹经。第五辨弘通。第六佛引昔日苦行。为证也。宝亮曰。大判圣行。有四段。第一明戒。第二明定。第三明慧。第四叹经辨流通也。智秀曰。大分圣行中。为两段。第一至无垢藏王。正明圣行体。第二讫品。以行由经立。故叹经也。前已列五行名。此下辨圣行。行由经得。故显闻经。以为根本

闻已生信信已应作(至)复有方等大乘经典

案。僧亮曰。戒定智慧。以信为始。故先显信也。思惟者。金刚长寿。以善业为因。善业所说。自归身中未来三宝也。诸佛世尊者。谓等为众生。作归依处。说自归也。无上道者。经云。知法名佛。知离名法。知无为名僧。僧法自悟者。无上佛大正法。离非法也。众善普集。体是无为。诸佛同得。故名大众正行僧也。复有方等者。谓大乘之中。广说此义也。僧宗曰。说明戒中。有八科。第一明出家戒。即为戒体。第二明非但具出家戒。亦具五支诸戒。备十善等也。第三明从此渐胜。乃至能得上住无漏道共戒也。第四明非但止得道定共戒而已。亦于微细律仪。精持不犯者。既备前四科诸戒。然有行而无愿。则烝生退没故。第五广明诸愿。下有九重愿也。虽有行愿。若非善巧方便。则留住生死故。第六明回向。以我之善。回与众生。共向佛果也。既备上众德。功行转深。必登初地。第七有三翻。释不动名也。第八结释所以得圣行之名也。宝亮曰。辨戒中有六段。第一辨求戒方便。第二正明戒体。第三论戒之深浅。第四发愿以防戒。第五明回向。第六结果也

我今当为爱乐贪求(至)牛羊鸡犬猪豕之属

案。僧亮曰。求欲出家之方便也。此下有三思惟。此第一就闻慧中思惟也

复作是念居家逼迫(至)剃除须发出家学道

案。僧亮曰。第二就思慧中思惟。应出家也

复作是念我今定当(至)护戒之心犹如金刚

案。僧亮曰。第三修慧中思惟。决定出家也。宝亮曰。第二正明持戒体

善男子譬如有人带持浮囊(至)敬重坚固等无差别

案。僧亮曰。海譬生死。浮囊譬戒。罗刹譬烦恼经文自合也。僧宗曰。第一科

菩萨若能如是竖持(至)阿耨多罗三藐三菩提戒

案。僧亮曰。戒有五分身业口业。五戒十戒。二百五十戒。是根本三乘通行也。余四者。是菩萨戒也。觉者。觉三善也。念者。念无相念也。正法戒者。无漏由其内解不可师授也。僧宗曰。第二科也。宝亮曰。五枝戒者。戒体也。根本业戒者。小乘四重戒也。菩萨虽心为先。亦不遗身口也。前后眷属者。从第二篇以下也。是四重之余也。觉清净者。三毒等。悉犯菩萨戒。此明不起也。正念者。谓四十轻戒。亦不犯也。回向者。即上四戒也

迦叶菩萨摩诃萨复有二种(至)白四羯磨然后乃得

案。僧宗曰。第三科明前二戒。犹是有漏。此发无漏心边道共戒也

复次善男子有二种戒(至)与性重戒等无差别

案。僧亮曰。性重戒者。以犯四重。譬如拆石。不可还合。退失圣照。亦致世讥。但内障重故。从重受名也。讥谦戒亦如是也。僧宗曰。第四科明乃至微细不犯也。宝亮曰。第三明或浅深也。夫有作罪者。运三毒而起也。岂有一罪而非性。若云。俗人违法而无罪者。便是圣人为出家者。作罪因缘。理岂然乎。此皆是性也

善男子菩萨摩诃萨(至)是名菩萨摩诃萨护持禁戒

案。僧亮曰。行愿相助。成持戒也。僧宗曰。第五科行。必须愿也。宝亮曰。第四发愿。以防戒也

菩萨摩诃萨护持如是(至)具足成就波罗蜜戒

案。僧亮曰。第六明若方便。故不滞生死也。善戒者。异外道也。不缺者。不犯轻微戒也。不折者。谓不破四禁也。大乘者。离小心也。不退者。若得八住。备三不退也。随顺戒者。菩提戒也。毕竟者。成佛乃得也。又言毕竟不起心相也。波罗蜜者。到无相彼岸也。宝亮曰。第五列诸戒。愿物同我。终不独隮也

善男子菩萨摩诃萨(至)是名菩萨摩诃萨修习圣行

案。僧亮曰。初地也。说圣行果。明戒分所得非直一戒。便获此地。下云。四魔不能动。明戒始终之能耳。僧宗曰。第七科结果也。今初地实云欢喜。而称不动者。正言不为怖畏所动。不堕者。既登初住。无还凡理也。不退者。不起二乘心也。第二释不动云。不为贪恚所动也。第三释不动云。不为四魔所动。理推不应尔。但菩萨舍寿之时。不以死苦移念故耳。宝亮曰。第六结果也。戒定慧悉结在初地。夫不修则已。修则俱修。岂容但戒而无定耶。所以结有前后者。逐义势耳。尔时戒心坚固。所以结之不动耳。定以静摄安忍。即结堪忍也。慧以照了离畏。即结无畏也。戒是定因。因定发慧。以次第也

善男子云何名为圣行(至)以是义故须名圣行

案。僧宗曰。第八科结圣行名也。有圣法举无漏法体也。常观空者。举法界之境。以成圣义也

大般涅槃经集解卷第二十七大般涅槃经集解卷第二十八

  释观三十六物　释四意止观　结定果　出仙豫王杀　婆罗门事　释四谛义　释三苦义　释四谛有漏无漏义　释八苦义

    圣行品之第二

复次善男子菩萨摩诃萨(至)除去皮肉唯观白骨

案。僧亮曰。第二明定门也。有八段。第一总观身。有三十六佛。第二移观。观四色觅我不得。第三观手足支节相柱。为观转明。第四见一切皆青也。此观始成故。第五诸佛现而复隐。令其思而易观。第六观心。是则前观身后观心具三。意止二。既已具。则四亦具也。故第七结堪忍地。第八明既得胜定。必能为物破戒也。此先明身意止也。以人人多于身中计有净也。此即第一观也。宝亮曰。第二门有五段。四念观即四也。第五结果。此下观身无我

复作是念骨色相异(至)即得断除一切色欲

案。僧亮曰。伏断鲜净之欲也。因色起欲未尽下形貌等三。皆因色起也。僧宗曰。第二移观四色。觅我不得也

复作是念如是骨者(至)二姿态欲三细触欲

案。僧宗曰。第三观也

菩萨摩诃萨观青骨时(至)青黄赤白鸽等色光

案。僧宗曰。为观转明。是以第四观青。则一切皆青也

菩萨于是一一诸光明中(至)光中诸佛忽然不现

案。僧亮曰。抱疑来久见像。便问。忽然不见者。观道未明。不答而灭也。僧宗曰。第五诸佛现而复隐。令其思而易观也。宝亮曰。第一身念处观也

复作是念或识是我(至)犹如流水亦复非我

案。僧亮曰。第二心念处观

复作是念若识非我(至)当于何处而生贪欲

案。宝亮曰。第三法念处观

若被骂辱复于何处(至)则堕地狱畜生饿鬼

案。僧亮曰。领佛不答之旨。乃观识求我。又不可得观出入息。或是我者。有息则生。无息则死。观之直是风性。亦复非我息。以风多风。乃四大合成而一性。非我和合。亦无复作是念。悉无有我者。得无我空。见第一义。则见世谛也。僧宗曰。或息是我者。第六即是心意止观也。但见生灭念念流谢。岂有一神常而不灭耶。何处当有受骂辱者。此明无我。但见众法我心自息也。宝亮曰。第四明受念处观也

菩萨尔时作是观已(至)是故名为住堪忍地

案。僧亮曰。结定果也。僧宗曰。堪忍地者。第七结果。谓三地也。三地菩萨。修十二门种。得忍度成就。既能安心忍理。故能于事不起嗔也。宝亮曰。第五结果

迦叶菩萨摩诃萨白佛言(至)菩萨摩诃萨得毁净戒

案。僧亮曰。上浮囊之譬。轻重不犯。而菩萨护法。应化随缘。二言相食。宜项会也。未得不动地者。明未得。犹尚不犯。何况已得。若为摄取众生得毁戒也。僧宗曰。第八明得深定已。能随缘益物。得破戒也。宝亮曰。问意定初依人位也。所以不待辨慧后。而此中问者。以戒定之位。本居五方便中无相行已上。是圣人位也。初依人虽复信根永立。要未得真解。欲为利益之道得破戒。不解言菩萨宁当自堕地狱。不令众生退菩提心。以此因缘。可得破戒而不名为犯也

尔时文殊师利菩萨(至)若堕阿鼻地狱无有是处

案。僧亮曰。至言实须以事证也

尔时佛赞文殊师利(至)乃有如是无量势力

案。僧亮曰。为法断命。即是护法。况直尔出入无期。心同虚空者乎。宝亮曰。引本行为证也。下梵行中。明三无量。当复广其事也

复次迦叶又有圣行所谓四圣谛苦集灭道

案。僧亮曰。说慧也。慧缘真谛。辨真谛有三种。初明四谛。中辨二谛。后略明实谛也。此下尽八字五翻。说四谛也。僧宗曰。慧生由境故寄境以明慧也。有四科明义。第一明四谛。第二明二谛。第三明实谛。第四叹经也。就四谛中有四翻。第一以五重略辨四谛。第二就八苦门。广明苦谛。第三寄菩萨观行。验其所以。是可厌之法。第四略会通二教也。宝亮曰。第三门明慧也。有六段。第一就四谛辨慧。第二就真俗。第三就实谛。第四遣执。第五结慧果。第六明登初地。后进修二十五三昧。进得不动自在。地上至金刚心也。就四谛门中。分为三章。第一有五重。此第一重。略辨四谛也。苦来逼心。心则生恼。谓逼迮相也。烦恼结业。能生来苦。生长相也。生死因尽。寂灭相也。缘中忘相之知大乘道也

迦叶苦者逼迮相(至)灭者寂灭相道者大乘相

案。僧亮曰。逼迫众生也。僧宗曰。第一重以十四种色是苦具。心为苦体。言不起则已。起则为缘所逼。故言逼迫相也。十恶为因。无明为缘。以能生长未来故。故名集也。偏教以三心灭处为灭。圆教以常住之体绝众相。为灭也。破彼三因。以大乘常住之因为道

复次善男子苦者现相(至)灭者除相道者能除相

案。僧亮曰。现恼切故。言现相也。僧宗曰。第二重谓法显现者也。众之为力。能[廷-壬+(同-(一/口)+己)]转行人。受六道苦果。转相也。圆果之体。除一切恶。谓之除也。无漏之体性。能除戒五方便。虽是伏除。未是永断。亦相从为道。取其感果之义。犹集谛摄也。宝亮曰。第二重也。粗着易知。为现相也。因谢果起。转因得果。转相也。灭者。据所除为论也。道者。据除为论也

复次善男子苦者有三相(至)道者修戒定慧

案。僧亮曰。三相者。苦受性苦。能苦众生。谓苦苦也。不苦不乐以求。须为行苦也。乐受灭时生。苦为坏苦也。僧宗曰。第三重释苦义。具在中也。集谓二十五有者。此乃举于所集。以明能集也。宝亮曰。第三重也。昔化下愚。开三受教门。次以三苦。点坏三受也。苦之重者。为苦苦。以果来坏因。明乐受之体。即是苦故。称为坏苦也。通前二心。行缘动求。名为行苦也二十五有。因为集谛。果为灭谛。修戒定慧为道谛

复次善男子有漏法者(至)无漏因者则名为道

案。僧亮曰。有为是苦谛。无为是灭谛。有漏业为苦因。天漏业为道因也。僧宗曰。第四重明有漏因果者。义与毗昙相应也。宝亮曰。重也。指就雨厢易见也

复次善男子八相名苦(至)三念处大悲是名为道

案。僧宗曰。第五重明四谛也。十力乃至大悲为道者。金刚心为无碍。佛心为解脱。有双道之义。故假称道也。宝亮曰。第五重广三苦为八苦也。生苦具二。谓苦苦及坏苦也。以润生之爱从乐受而来。因中说果。即坏苦也。取出生之生。则有苦苦。心即苦体。堕地狱。为苦苦也。怨憎求不得。亦苦苦摄。其余五苦。悉应坏苦摄也

善男子生者出相所谓五种(至)是故名为五盛阴苦

案。僧亮曰。所以总七苦。更作一苦名者。人谓七苦异阴而有。今说即阴是也。僧宗曰。此第二就八苦门。广明苦谛也

大般涅槃经集解卷第二十八大般涅槃经集解卷第二十九

  出功德天黑闇女譬　释死苦

    圣行品之第三

迦叶生之根本凡有如是(至)观于所生已见过患

案。僧亮曰。以凡夫颠倒贪生。而恶老死。明菩萨不尔也。僧宗曰。第三寄观行门。明八苦相也。此中有六譬。皆明凡夫贪生。而菩萨见过。弃而不乐也。宝亮曰。此下第二观过也。有六譬也

迦叶如有女人入于他舍(至)散华供养恭敬礼拜

案。僧亮曰。为菩萨作譬也。菩萨爱生情薄。见生死过。则俱厌也。生是贪悦之本。譬女。五阴是生所住处。譬舍。乘因得果。譬之他也。生理可乐。譬之端正。智以御身。譬之舍主。名以表实。譬问名也。生是善果。其因净故。譬功德也。果非不净譬也。考名责实。问所作也。有生有实。譬能与也

复于门外更见一女(至)汝若不去当断汝命

案。僧亮曰。舍生名死。譬门外也。反生易显。不须辞费也。即持利刀者。医药救生。譬持利刀。以防死也。僧宗曰。死是人之所恶。悲情内故。譬之门外也

女人答言汝甚愚痴(至)我皆不用各随意去

案。智秀曰。生在报前。譬姊。死居报后。譬之妹也

是时二女便共相将(至)是故俱请令住我家

案。僧宗曰。凡夫也。无法财。故喻贫也

迦叶菩萨摩诃萨亦复如是(至)是故贪爱生死二法

案。智秀曰。双合譬也。宝亮曰。此第一以二女譬凡夫。与菩萨相对也

复次迦叶如婆罗门(至)如彼童子取果还弃

案。僧亮曰。幼稚童子。譬始业菩萨见苦不深。未全忘生。如取果已舍。若智行俱深。则不取不舍也。僧宗曰。菩萨是高行之族。以譬婆罗门子。旷劫为地狱所苦。绝人天食也。粪譬阴身。果譬生也。欣生之情。譬欲取也。生之为过。圣之所说。譬智诃也。知贪生之患。譬赧然有愧也。为生天中有五欲乐。譬净洗也。终不爱者。譬还弃也。宝亮曰。此第二以童子譬小菩萨。与大菩萨对也

复次迦叶譬如有人(至)以其不见老病死故

案。僧亮曰。四衢道。譬佛四无量无齐限也。器譬经藏。食譬施戒定。佛为在家之人。初赞施戒。生死之乐。后说无常。赞涅槃乐。此法始终。皆佛说。凡夫贪生。不见后过。圣人见过。不生贪也。又四衢譬四辨。器譬名味句身。食譬施戒定也。卖之譬劝行也。远来饥虚。譬经三途久也。此是何物者。称其所求。问以定之。食主答言者。戒定能得天人之乐。后必无常也。是人闻已者。不为菩萨说也。多与我价者。生天不受四趣之苦也。僧宗曰。说法聚人之处。譬四衢也。化主说人天因果。取人利养如卖也。菩萨虽知天中报妙。见有死患。不欲生故。喻如彼人虽欲买食。为一恶故。所以遂舍也。宝亮曰。此第三以卖食譬释教也。谓若生死之果如此者。圣人何意。说此五戒十善。受人天报耶。此是善不受义之诚证也。此教本接下愚。若不闻人天之乐。凡夫岂背行道耶

复次迦叶譬如毒树(至)下至十岁俱亦受苦

案。僧亮曰。此二譬同显有生有死。修短无异耳。宝亮曰。第四第五二譬。偏据生死果报。唯苦而无乐

复次迦叶如譬崄岸上有草(至)大涅槃经观于生苦

案。僧亮曰。譬菩萨尚不贪天上报。况复欣此人中果耶。僧宗曰。险岸譬五阴身也。草覆譬无明也。岸边甘露。譬妙药报也。大坑譬死苦也。即便取者。贪乐果故。修善因也。脚跌者。永沦生死也。宝亮曰。为外道作譬也。险岸譬非想也。草覆譬彼生死果报。而外道不知计为涅槃也。甘露者。譬禅定乐也。寿千年者。八万劫也。贪其味者。着禅定也。深坑者。生死苦也。脚跌者。外道以非想为涅槃。失理故堕三涂也

迦叶云何菩萨摩诃萨(至)大涅槃经观于老苦

案。僧亮曰。皆与衰坏作譬也。王譬壮色。敌国譬老。他土人民以譬忆念少盛之事也

迦叶云何菩萨摩诃萨(至)大涅槃经观于病苦

案。僧亮曰。端正譬健色。夫人譬爱结。王譬病也。挑一目等。譬坏盛色

迦叶云何菩萨摩诃萨(至)住于大乘大涅槃咒

案。僧亮曰。唯除二禅者。凡死苦一至。无不恼乱。故以灾为譬。菩萨死至。心不乱也。摩罗毒蛇其色黑。若触人衣。戒人衣触其行处。皆死。故名触毒。阿竭多星。八月出也。因星结咒。消四毒也。僧宗曰。病之为苦。破坏浮囊。实为最苦也

复次迦叶譬如有人(至)大涅槃经观于死苦

案。僧亮曰。上来说死。而未说苦。今言于险难处。无有资粮者。诸受根灭。不受根起。名曰死也。不受根起。则生涂断绝。譬险难也。受根不起。不起则无法。无法则不可资用。譬无资粮也。来涂茫茫。莫知所之。譬悬远也。五根皆灭。意识独行。譬无伴侣。业风所飘。求生不住。譬常行也。五道未分。譬不知边际也。遇得生缘。乘痴受生。譬无灯明也。上来诸譬。说欲受生之苦。自此下譬死之苦也。说一切苦。皆由受生。心灭名死。灭不由户。譬无门也。不受根起。譬有处所也。不觉苦乐。譬无痛处。医药不加。譬不可治也。诸根渐灭。强力所不制。譬无遮止也。受根已灭。不可更生。譬不得脱也。生灭根异。外相不改。譬无破坏也。人不喜见。譬愁毒也。不能害人。譬非恶色也。人惧其祸。譬怖畏也。是根皆灭。譬在身也。灭不可见。譬不可觉知也

大般涅槃经集解卷第二十九大般涅槃经集解卷第三十

  出顶生王缘起　会通今昔五盛阴苦义　举昔为释摩男说色有乐义　举昔说善法得乐受义　举昔所说乐受偈　释于下苦生乐想义　释三受苦义　释二乘不知常住乐因是故为说以下苦为乐

    圣行品之第四

迦叶云何菩萨摩诃萨(至)爱别离苦所谓命终

案。僧亮曰。生为五阴之本。爱是众结之本。引先偈为证。罗汉所以无忧无畏者。以爱尽故也。所谓命终者。说其重者耳。此中说一切苦。皆由爱生也

善男子以别离故能生种种(至)现在之世爱别离苦

案。慧朗曰。出缘起显其重者也

善男子云何菩萨摩诃萨(至)大般涅槃观怨憎会苦

案。智秀曰。辨怨憎会苦。即就所受之身。是则常与怨会也

善男子云何菩萨修行大乘(至)迦叶是名苦谛

案。宝亮曰。夫未足之境。所不免也。除佛已还。无非此苦也。五盛阴者。更无别体。即指七苦也

尔时迦叶菩萨摩诃萨(至)五盛阴苦是义不然

案。僧亮曰。谓五阴皆苦。与昔教相违。以昔证今也。僧宗曰。此下第四引昔征今。会通二教也。宝亮曰。第三会通今昔两教也。教有因果。昔已会果。今会因也。昔已点三受悉苦。令物情厌背而进德。其义虽然。竟未及坏因。若使因果俱会。众生何肯修善。唯得且抑福而置。故四时经教。但劝修善以灭恶。于生死身中。习学成圣也。而一切智体。未免无常。但乐果未现。不得坏因。今常住教。与乐果义彰。始得坏因也。我本云。修善乃是菩提之因。非生死之法。有人解言。今教由会果。恐非佛意。昔已会毕。今何得重。故知理不应。然今者将欲会因。故迦叶先捉果。以作难。佛既先遣果。唯苦竟。然后正言。我于昔云何善得乐者。乃是菩提道乐。但此义未明。今始会也

何以故如佛往昔告释摩男(至)若有求者则不名苦

案。僧亮曰。凡举五据。此第一举乐缘。以有求故。不应无乐也。宝亮曰。迦叶先作五难。第一以人天五欲中有乐不应苦也

如佛告诸比丘有三种受苦受乐受不苦不乐受

案。僧亮曰。第二举三受明若无乐者云何有乐受耶。宝亮曰。第二难以三受中有乐受故不应苦也

如佛先为诸比丘说若有人能修行善法则得受乐

案。僧亮曰。第三举所修善因也。因既是善。理有乐果。故以因为证。宝亮曰。第三难以善是乐因。故知不应无乐

又如佛说于善道中(至)意思好法亦复如是

案。僧亮曰。第四举善因。今举六触。即是善果。且以乐因。而得乐果。云何无乐耶。宝亮曰。第四难如树伽于人中。受天报故。知六根所对。无不乐也

如佛说偈持戒则为乐(至)所作众事辨是名为最乐

案。僧亮曰。第五举因果。诸偈通证有乐也。宝亮曰。第五难举昔诚偈为难

世尊如诸经中所说(至)云何当与此义相应

案。智秀曰。总举上事。以求会通也。宝亮曰。难虽有五。不出二途。第一第二第四就果报上作难。第三第五以因征果也

佛告迦叶善哉善哉(至)所说苦想与本不异

案。道生曰。无苦者。体既非苦。而能无苦。而众生以微代重。以为无苦。是曰横计也。僧亮曰。答第一第二第四。谓横乐者。众生犹以下苦。横生乐想。因以为教耳。昔所说乐。约彼横情。终是无乐。今云。皆苦亦无违也。僧宗曰。总答五难也。以众生不识真相故。于下苦中。横生乐想。将恐起此。必堕三涂。且说人天是乐。令修十善五戒。以背恶道。所谓以屑出屑者也。宝亮曰。此下讫三受以来。先答第一第二第四果。报上难也。下苦者。三恶重为上苦。人天轻为下苦。凡夫不觉下苦。横生乐想也

迦叶菩萨白佛言如佛所说(至)上生者所谓天上

案。道生曰。生是生者所贪苦。是苦者所恶。贪则为胜恶。则为剧下生。自是三涂下苦。自是人天而生即是苦。似若下苦。是彼下生。故致问也。僧亮曰。承声为难耳。乃更与三关问也。佛所言下者。轻微为下也。如迦叶所言。以尤重为下也。此第一关也。宝亮曰。物情一往未悟。迦叶今更作二难。佛意以人天为下苦。迦叶以三涂为下苦

若复有人作如是问(至)生于乐想当云何答

案。道生曰。对下苦横生乐想。以为难也。僧亮曰。第二明顾反答。下苦故说乐。知一切皆苦物。今亦以下乐故说苦。当知一切皆乐也。宝亮曰。第二倒并如来向义也。若以三受尽苦者。今以三受尽乐。但以乐微故苦耳

世尊若下苦中生乐想者(至)于下苦中而生乐想

案。道生曰。难意不许下苦生乐。故以此为征也。僧亮曰。第三关若果于轻下之苦而生乐者。一罚北千。千为甚重。一为极轻。而未见应受重苦于轻苦之上。而生乐想者也。故知不以轻苦为乐想也。宝亮曰。此就理为论也。若以人天轻苦。为下苦者。应以一罚轻苦为下苦。若尔者。应缘此一罚。而生乐也

佛告迦叶如是如是如汝所说以是义故无有乐想

案。道生曰。答最后难。前两难自解也。如是一下。不生乐想。是都无乐之验也。僧亮曰。实无乐者。案句解也。是人当受千罚。脱余多苦。于一罚上。横生乐想。昙爱曰。是以不以一下为乐。以脱重为乐。缘脱重之心。实是行苦。凡夫以之为乐。以此一答。并答三难。何者一罚之与千罚。俱是重苦。既不一下为乐。云何而言。于底下之苦。而生乐耶。即答第一难。又是人缘于脱重苦。而横生乐想。云何而言。于下乐生苦想耶。即答第二关。宝亮曰。即此答三难也。今先释横生义。若一下而脱者。到缘一下安之为。岂非妄乐耶。非是受一罚时生乐也

何以故犹如彼人当受千罚(至)于无乐中妄生乐想

案。道生曰。脱千受一。便妄生乐想。无乐信矣。前言于下苦横生乐想。此之谓也。僧宗曰释横义也

迦叶言世尊彼人不以一下(至)以得脱故而生乐想

案。宝亮曰。迦叶云。实无九百九十九。故缘此无。故实有实众也

迦叶是故我昔为释摩男说五阴中乐实不虚也

案。僧亮曰。受责既不以一下为乐故。乐故乐非横也。佛言乐实不虚者。以免受为乐。不可空中说乐也。昙爱曰。迦叶领解非难也。佛即述成也。宝亮曰。释第三实乐义也。三涂中苦。人天实无。无处与佛何异。故知非虚说也

迦叶有三受三苦(至)余二受者所谓行苦坏苦

案。僧亮曰。昔以轻重义。故说三受。今以三苦。故说一切苦所为事异。不相违也。苦受名为三苦者。性摄三苦也。余二受乃苦性之别义也。宝亮曰。答向第二难也。佛前云。三受悉苦。迦叶难云。三受悉乐。佛今举三受唯苦而无乐。岂得难言三受皆乐耶。既于下苦。微故不觉。横生乐想。即答初难。谓于尤重之下苦。生乐想也。苦受具三苦者。若如昔解。直点三受为三苦。是则苦受为苦苦。乐受为坏苦。舍受为行苦也。今明苦受具三苦者。义旨小异于昔。何者若刀杖缘中生心。亦是苦受。失坏缘中生心。亦是苦受。今取刀杖缘中生苦受者。为苦苦。失坏缘中生苦受者。为坏苦。即此苦体。是动求行缘。便是行苦。故言苦受具三苦。非是苦苦具三苦也。余二受各具二苦者。乐受起时。因中说果。即是坏苦。即体是动求行缘。故是行苦。亦得言乐受具二苦也。舍受具二苦者。四禅以上是舍受。然彼众生。舍命之时。亦爱寿命。便是坏苦。其体岂非行缘动求。若尔则舍受具二苦也

善男子以是因缘生死之中(至)是故说言一切皆苦

案。僧亮曰。以轻重因缘也。苦乐性不相离者。三苦不相离也。宝亮曰。实以无三恶苦。故有实乐。苦乐性不相离者。十住无漏之解。从初住至金刚心以来。当分除惑。于无惑边。恒是实乐。而无漏之体。未免世谛。故举体是苦。故言苦乐性不相离也

善男子生死之中实无有乐(至)随顺世间说言有乐

案。僧亮曰。将说乐因。为答第三第五难。故说有为天乐也。宝亮曰。五欲之中。实无熙怡乐也

迦叶菩萨白佛言世尊(至)今作是说其义云何

案。僧亮曰。上义未显。问以成之也。昙谶曰。领解也。宝亮曰。第三第五两难未被答。此重举以请答也

佛言善男子如上所说(至)一切皆苦无有乐想

案。僧亮曰。亦生苦因者。明外物非苦苦因。故说苦也。宝亮曰。答其二难。明此并是因中说果有何虚妄耶

善男子菩萨摩诃萨(至)乃能知是苦因乐因

案。道生曰。二乘不知常住。故不知乐因。僧亮曰。解苦者。解三苦也。无苦者。说下苦为乐。乐非苦也

大般涅槃经集解卷第三十大般涅槃经集解卷第三十一

  广释集谛以爱为体　释二种爱一爱己身一爱所须　又释二种爱一者善爱一者不善爱　举九种事譬爱　释菩萨无苦有谛声闻有苦有谛　广释见灭谛义　广释道谛义　广释道义是一随法有异

    圣行品之第五

善男子云何菩萨摩诃萨(至)分别挍计无量无边

案。僧亮曰。还爱于有者。谓三有也。僧宗曰。前已略说。今是广说。次会通。后明观行也。是阴因缘者。由业烦恼。得未来阴果也。还爱于有者。昔由业烦恼故得身。今复爱三有。复应牵生也。业因缘爱者。宿业故起爱。随所习也。烦恼因缘爱者。如人多嗔。常爱兵器。苦因缘爱者。如人遇病。爱针艾也。宝亮曰。次解集谛明业。及烦恼能构未来生死果报续起。称之为集也。就此辨集谛中。亦有三意。然文中小自左右。不如苦谛中之次。第一解集谛相。第二会通。第三观过。今此中辨集谛。悉据爱使为原。何以然。后能润生。得生由已。故非爱不成业。是以就爱而收集。录感阴之缘尽。然爱性染累。事无不由。故文中广彰述爱。为众缘之首也。爱己身谓正报爱。所须名依报也。如工巧业等。事成保着。玩适在心。称业因缘爱也。若违境起心。复称昔含怒。还修此心。为好为烦恼。因缘爱也。患苦而欲背。若离我而称情。无此苦。而心悦谓苦因缘爱也

善男子爱有二种(至)求大乘者是名为善

案。僧亮曰。结集八苦者。重倒也。爱佛功德轻。故除之也

善男子凡夫爱者名之为集(至)不以爱故而受生也

案。僧亮曰。此经以智知集。名为谛。凡夫以不识集故。集而非谛。菩萨谛而非集。何以故者。释所以。谛而非集也。宝亮曰。夫立爱之名。名生二处。如向所辨。尽是凡夫不善之爱。若兴心乐法。崇善为理。悦情愿求。称之善爱。名虽同。义自两殊。名同心别。各自有归。然善爱虽同。复有二别。若菩萨位怀发轸。不存于缘中离染。称大乘爱。声闻小道。虽欲乐善。但解不称境。每心有存于求善之略乖。遂落不善爱门也。故知二乘行道。不称道。不改心。不得出。何以知之。下句即会凡夫爱者。名之为集。得知二乘执相在怀。未免生死。无有谛用。菩萨造行发家。不以生死为患。既识生死过。于保着之情悚。是以虽爱不名集。若须现生而应物。则不名为爱

迦叶菩萨白佛言世尊(至)独以爱性为五阴因

案。僧宗曰。此会通之文也。昔说不同。请释其由也

佛赞迦叶善哉善哉(至)能生一切业烦恼牙

案。智秀曰。虽复业及烦恼。为辨果之因。然爱为爱生之生也。宝亮曰。第二会通难也。明虽复说有招阴之因不同。然非爱不辨。以三譬显之也

善男子菩萨摩诃萨住是大乘(至)是名如责有余

案。僧亮曰。此下观门也。此但说爱过。不明是集。不集故不除。菩萨不爱而是集。故除也。僧亮曰。观爱之过患也

善男子云何如罗刹(至)观察爱结如是九种

案。僧亮曰。拔舍利弗无上根本者。则有缘起。载彼释论也。又相承释云。于时已至第六住。未得第七住心。有言在住三十心之二十心中

善男子以是义故(至)菩萨摩诃萨有道有真谛

案。僧亮曰。为观不同。而说昔之苦集。唯有三人。因论四人观有差别。语次及之也。菩萨能观苦观。爱无上八患。因论观人差别。以颠倒为苦。三人皆倒。有苦也。以见苦名谛。三人皆见苦。故有谛也。下须跋之。观欲界无常。如病得出色界。是凡夫见苦也。以三人于佛有苦倒故。于谛不得称真也。解苦者。生死也。无苦者。涅槃也。于二不倒。是谓无苦。而有真谛。苦粗集细。凡夫不见集。故无谛也。有集谛者。于佛有倒。受变易之苦。故是集也。识分段因。故有谛也。上但言凡夫是集。不说变易之苦也。宝亮曰。上既说苦集谛竟。今且结成谛用。不成谛用者。课凡夫识非而离过。云凡夫人有苦无谛者。凡愚但粗知逼恼事苦。不谛解苦之所以。故无谛用也。二乘有苦谛者。有逼恼事苦。非不粗解除于苦因。所以得言有谛用也。无真实者。不知佛无苦。由合佛作苦观。故无真实也。诸菩萨解苦无苦者。昔日解苦无苦性空。今日解金刚以还有苦。佛果是无苦。互明辨两厢。所以有真谛也。下余三谛。义例可知。大士双明两轮安法得所。故有真也

善男子云何菩萨摩诃萨(至)大般涅槃观灭圣谛

案。僧亮曰。次观灭谛。大般涅槃是灭谛也。备二义。第一但灭烦恼。第二灭一切相也。法瑶曰。三谛皆不言有二见。此独云。见灭见谛者。何耶。以灭有二种。一佛地灭。二菩萨地灭也。佛灭而非谛。菩萨灭而是谛。谛者。用照审境之谓也。佛息照废审。是则佛无谛而灭也。菩萨有谛有灭者。佛上无道。亦无谛苦。习亦然。又经自明文如此。故唯灭谛。独云见灭见谛。余谛不也。僧宗曰。灭谛文中。阙无会通。可得广义。有观门义也。断除一切烦恼者。昔灭为分灭耳。今灭者。断无明住地以还斯尽也。断则名常者。以有惑未断。则流动迁谢。今惑尽照周。所以常也。宝亮曰。次第三解灭谛上苦集二理。是有漏法。为患处多故。开别观之。今灭道两谛。既是无漏无性。非染累。唯解相会通。有二门之说。灭谛中乃无别会通文。然义推有二。道谛文中。其事自别。今初见灭见灭谛。此两句作章门下相对旨。八句来释。见灭者。见昔灭。见灭谛者。见今日常住真如理。此即会通。亦可得言。上句为灭谛相也。谓断除一切烦恼者。释上见灭句也。烦恼灭故则名常者。释见灭谛句也。灭烦恼火则名寂灭者。释上见灭句也。烦恼灭故得受乐者。释见灭谛句也。菩萨求因缘故名为净者。先释见灭谛句也。永断一切烦恼故名出世者。释见灭句也。以出世故名之为我者。释见灭谛句。下去释见灭句

善男子云何菩萨摩诃萨(至)大般涅槃观道圣谛

案。僧亮曰。此下明道谛。先观道。即是出相。不因苦集。因八圣也。见一切法者。八道亦谛。道谛观道也。灭是果。但观无学。道是因。通观学地也。从常无常。至净观。因果也。无常是因。常是果。下就因果别观。陀罗骠真实主义。求耶是衣。亦庄严义。僧宗曰。先明广义。兼明观行。后明会通耳。所谓常无常者。举道所照之境。以明观体也。常者佛果。无常者金刚以还。是众生数也。金刚为累中物。佛果非累物也。陀罗骠者。借依谛主谛。以释正义也。佛居宗体极。为陀罗骠也

迦叶菩萨白佛言世尊(至)诸佛如来久离错谬

案。僧亮曰。不相应者。今说八是道。昔不说八应非道也。欲闻说道。或略或广。皆是道也。僧宗曰。此下会通今昔也。宝亮曰。佛答诸经悉入道谛。就三因缘辩入也。一者因门。二者缘门。三者道体。不出此三也

尔时世尊赞迦叶菩萨(至)能作如是种种说法

案。僧亮曰。广说道相也。能佐助菩提者。释本义。菩提是智道之政体。以信为本。说信一事。后类可知也。僧宗曰。如是诸经。悉入道谛者。昔说虽可不具。然而莫非道也。随化之所宜。致名不同耳

善男子譬如良医识诸众生(至)随良医教所患得除

案。僧亮曰。并药所禁水不在例者。草石有用。舍藏不俱。而水无碍也。施有行止之异。道则唯通。何者。如经说。世有五人。不赞五事。谓不为悭者。赞叹施等也。僧宗曰。此下有六譬。前三譬明道。是一以应后三譬。后三譬前说广显道。是一也。此譬意明道虽可是一。以众生之病不同。致为药亦异也。宝亮曰。诸药者。譬种种说法不同也。水一种者。譬道也。药性不均。譬一时之宜进道之良荃。取无为之要资

复次善男子如有一人(至)从信根等至八圣道

案。僧亮曰。小异上譬也。从信根等至八圣道者。说一法为信。乃至八道互作其名耳。僧宗曰。第二譬意。明道虽是一。随方施名不同耳

复次善男子譬如金师(至)为众生故种种分别

案。僧亮曰。此以随用作异。为譬也。如来一道。随大小乘根。广略为别耳。从一至九。是三乘杂说。下言大乘一道无二者。三世诸佛。有同见有。无同见无。大乘道也。定慧者。以戒远不说也。见智慧者。推求名见也。了真名慧也。审定名智也。见道者。如得果以初见。为名重。更修习进求上果。名修也。结尽不修。名无学也。五种因利钝。得灭尽定。为名六种。因人因道也。念佛三昧者。唯佛念佛。真得佛相。可名为定。僧宗曰。第三譬明道虽是一。以善巧故。种种说异也。一道者。此明如来随根缘故。致教不同。应前譬也。信行法行道者。此经意与数论为异。论释信行法行。是五方便以还。寻此文意。乃至见谛道中也。信解脱见得。犹是前二。以入思惟。通三果制也。身证者。此二人俱能作身证也。说十力无畏为道者。无进求之义。以其有解脱道义。亦可是缘中说道也。后三譬义可知

复次善男子譬如一火(至)为众生故种种分别

案。僧亮曰。能除是道。此譬同所除也

复次善男子譬如一识(至)为化诸众生故种种分别

案。僧亮曰。色随所依。名有差别。道随小大乘。根殊异者也

复次善男子譬如一色(至)无量众生得度生死

案。僧亮曰。依见者。为名也

大般涅槃经集解卷第三十一大般涅槃经集解卷第三十二

  总会通四谛义　释二谛义　解惑相对释二谛义　虚实相对释二谛义　有无相对释二谛义　假实相对释二谛义　有为无为相对释二谛义　亲疏相对释二谛义　释十谛义　真不真辨实谛　颠倒不颠倒辨实谛　虚妄不虚妄辨实谛　大乘非大乘辨实谛　佛说魔说辨实谛　一道清净无二辨实谛　有常有乐辨实谛　释虚空佛性非谛是实　释四谛当体是实

    圣行品之第六

迦叶菩萨白佛言世尊(至)如来何故唱言不说

案。僧亮曰。上说二乘有谛无实。以不识常。今明见三界苦。亦有浅深。证成上义也。僧宗曰。自上来所说四谛。各当谛下。皆有别释。唯灭谛阙会通文耳。四谛既竟。今总会今昔二教总别之旨也

佛言善男子虽复入犹不名说

案。僧亮曰。此下竟四谛门。第三总会通。明佛所觉了万法。如大地所生之草。而昔为二乘说。如手中草。故迦叶今捉此作问也。问佛所觉了法。如大地草。为当入四谛。为当不入者。应有五谛。佛下答言。悉摄在四谛理。而往取不出四谛。四谛名收。理岂有遗。所以故云。悉摄在四谛。虽言入中。亦犹不名说。何以然。若鉴此境。穷则生智。亦满二乘。但总相知诸法。未曲达其深旨。故生解脱劣。于知法门亦局浅。若解不如佛。当知未穷境。以见境未周。故于此人。而往望得言。取摄则不尽。虽说不名说

善男子知圣谛有二种智(至)我于彼经竟不说之

案。僧亮曰。生灭聚积名阴。亦是苦义。四谛本为声闻。总相说苦。别相知者。非彼经所说也。僧宗曰。若依胜鬘经为论者。有八谛。昔但说四。而无作圣谛。者所未明。今就此经。不但无作。未说作义。亦未究竟。何者。如说阴相。色则有十四种。心则想受行也。此是总相。粗分别之中。智所知也。若就细相辨明者。则如一色阴。为几尘所成。几行业所感。心则念念生灭。几刹那习起相。乃是八住九住所知。故彼经所未辨也

善男子知诸入者名之为门(至)我于彼经亦不说之

案。僧亮曰。入是处义。通识为门义也

善男子知诸界者名之为分(至)我于彼经亦不说之

案。僧宗曰。界分性别。皆是当位之名也。义类如上释。心以能知为性。色以质碍为性

善男子知色坏相是名中智(至)我于彼经亦不说之

案。僧宗曰。向已总举三聚法。今复重举一一阴为为辞耳

善男子知爱因缘能生五阴(至)我于彼经亦不说之

案。僧宗曰。此就四谛门辨受是集。能生五阴是苦。自下者。灭道文也

善男子知世谛者是名中智(至)我于彼经亦不说之

案。僧宗曰。还总收法门。为一世谛。上智所知也。一切行无常。诸法无我。涅槃寂灭者。复收为真谛。言无常等行。生人真解。唯略空门也。涅槃是昔三心所治断处。寂灭无生。第一义谛也

尔时文殊师利菩萨(至)第一义谛其义云何

案。僧亮曰。为义一名异。为名义俱异耶。僧宗曰。上明四谛。其义则狭。今说二谛。其理则广。皆是智境也。所以言四谛狭者。犹此是世谛道中分别为四。今第一义。荡于前四也。又且虚空及非教缘灭。不在四谛中摄。今以二谛而收。则是世谛摄也。智秀曰。将显二谛。先设一问二难也。此即第一问二谛体相也

世尊第一义中有世谛不世谛之中有第一义不

案。道生曰。理无二实。而有二名。如其相有。不应设二。如其相无。二斯妄矣。法瑶曰。将明二谛名异而实同。故第一义之实。即有世谛之实。即有第一义。是以问二谛之实可得相有不耳。不问二名之义可得相有

如其有者即是一谛

案。僧亮曰。若名义俱异。有无一时者。则二不双合。恒是一谛也。法瑶曰。如其一实有二。则二不异实。若二不异实。二则一矣

如其无者将非如来虚妄说耶

案。僧亮曰。若是一谛说有二义者。则应一是虚妄。故云将非虚妄说耶。法瑶曰。如其相无。则二名无实。而有二名者。岂非虚妄耶。僧宗曰。先张两关。以求其旨。若真中有俗。则俗来同真。若俗中有真。则真来同俗。若以真同俗。则唯一世谛。以俗同真。则唯一真谛。不应有二谛之说也。若俗不容真。真不容俗者。是则天然楚越也。若真中必无俗者。而如来说色即空。此则虚妄说也。宝亮曰。世谛以虚妄故有。即体不异空也。若无有而可异于空者。岂有空之可异于有耶。故无而即一体。便二谛之名立也。若有有可无。便是世谛之中。有第一义也。无既无所。无亦无无。可异有也。若有无可异有。便是第一义中。有世谛也。两既不相有。故知有无可有。无无可无。若有有可有。有无可无。此便相有。得知诸法从本已来。空无毫末之相。但于病者为有。于解者常无。文殊致问。为彰此理也

善男子世谛者即第一义谛

案。道生曰。惑者皆以所惑为实。名世谛也。虽云世谛。实不遂异。故是第一义耳。第一义谛。终不变为世谛也。僧亮曰。欲明二皆是妄也。何者。两实则不可相即。既相即以明两无也。法瑶曰。名无二实。唯唯一矣。一实之理。理不可名。岂可即乎。但寄即以遣即名无二实。非有一实。而可即也。僧宗曰。一答两关也。既言即也。岂有楚越之过。即理是同。岂有妄说之失耶。所以言即者。非以空作色。以色作空也。以第一义谛。从本来不可得。今明世谛不可得。不可得者。岂可分别。故言即也。宝亮曰。病者逐生惑。今欲捉己心令住。故唱云世谛。即第一义谛。不于法外觅法。但致即之名。本就异中明耳。非两乖之说

世尊若尔者则无二谛

案。道生曰。若世谛即第一义者。唯有第一义。无世谛也。僧亮曰。深领相即之旨。征昔说有二谬

佛言善男子有善方便(至)一者世法二者出世法

案。道生曰。理如所谈。唯一无二。方便随俗。说为二耳。僧亮曰。法无明相。言语道断。岂可以二谛之名。示众生耶。善乃方便者。假真俗二称。诱道愚近耳。非谓理有二也。僧宗曰。若以不可得义而为论者。则无二也。若有可得而假用。则二名生矣。是则二名之生。约物情而立也。此下有六重解释。第一以解惑相对。第二虚实相对。第三有无相对。即文殊所问也。第四假实相对。第五有为无为相对。第六亲疏相对也。宝亮曰。善巧者。能说不有之有。不无之无。以立二名。而用导物也。然解悟不同。不开六重。更辨其旨。此下第一约凡圣二人。以辨二谛。明有假有之有。无实有可得也。无是因缘之无。亦无无可得也。称此二理而解者。则出世之人。名第一义也。若世人所说者。言有便云性有。言无便谓断灭。是则有无虚谬。俱不着理。故于此人。悉名世谛

善男子如出世人之所知(至)而能知之名第一义谛

案。道生曰。五阴和合。非即非离。无有定相。圣人如其相性而知。胜世人故。名第一义也。僧亮曰。世法者。谓世间八法也。反之即出世矣。出世所知者。三假及空。皆第一义。世人知有。决定有相。如牛定牛。不可为马。亦得实义。是世谛也。僧宗曰。此第一重。五阴和合。称言某甲者。此举凡夫所知。以明惑也。解阴无。此举圣人所知。以明解也

复次善男子或有法(至)苦集灭道名第一义谛

案。道生曰。热炎以不实为实。是则世谛。解其不实。是第一义谛。僧亮曰。实义如苦集等。何以断惑也。僧宗曰。第二重上。与阴和合。以明解感。今说境有虚实者。谓四谛理也。苦真是苦。不可令乐。集灭道皆如此也。世谛取重虚之义。实不可得也。知我众生者。出不实事也。又言诸阴界入者。如小不类。此乃是缘成之法。若计之为实。理不可得。何异轮等喻也。宝亮曰。此第二就虚实以明义。妄有故世谛。称理故真谛也

善男子世法有五种(至)如实而知是名第一义谛

案。道生曰。世之所著。为世谛。知其实故。为第一义。僧亮曰。世谛不出此五种也。初是假名众多。有众分假。相续假。相持假。亦有法假受假。总一切世谛也。下四是别众字。合名句也。众色合为缚也。音声告令为法也。衣服标相。为执着也。无此为第一义也。僧宗曰。第三重于此五法。心无颠倒。如实而知。体不可得。即第一义谛。宝亮曰。第三寄空有。以明义也。有名有用为世谛。性空为第一义

复次善男子若烧若割(至)无死无坏是名第一义谛

案。僧亮曰。此以相续假。名为世谛。以念念灭实法。为第一义也。僧宗曰。第四重就假实明义。如般若经灯炷品所载也。宝亮曰。释同

复次善男子有八苦相(至)无五盛阴是名第一义谛

案。道生曰。有多惑故。为世谛。无多解故。为第一义也。僧亮曰。上说苦是第一义。今说为世谛也。僧宗曰。第五重明金刚以还未免苦。为世谛。唯佛果对八苦相。故名第一义也。宝亮曰。释同

复次善男子譬如一人(至)其实是一而有多名

案。僧亮曰。上明真俗皆是世谛。随世谛利。有多有少。多者名真。少者名俗也

依因父母和合而生名为世谛

案。道生曰。事近远为世谛。得实为第一义

十二因缘和合生者名第一义谛

案。道生曰。解则见故。名第一义。惑之者为世谛也。僧亮曰。知从父母利少。名俗。知十二因缘利多。名真也。僧宗曰。第六重就亲疏为名也。十二因缘为亲者。以见在立果。由过去无明行等也。令父母为其外缘。所以疏也。寻此文旨。本明二谛空有之义。收法则旷。今六重所明。悉就事中。相待炎明此也。旨之所归。在第三句也。宝亮曰。释同

文殊师利菩萨摩诃萨(至)所言实谛其义云何

案。道生曰。就前说不了。如似实谛。全异四谛。故更问也。僧亮曰。问一谛总上六谛。名为实谛也。因上二乘有苦集谛。而不真实。似如二乘实谛不摄。是以明也。法瑶曰。前言二乘实谛。菩萨有之。今问菩萨所以得实谛之义也。僧宗曰。此明慧境之第三辨实谛也。上会四谛。言声闻有苦有苦谛。而无真实。菩萨解苦无苦。而有真实。若解理而真实者。为更有何境。为其所知。故致此问也

佛言善男子言实谛者名曰真法

案。道生曰。常乐我净。名为真法。四谛有之。则名实义也

善男子若法非真不名实谛(至)是则名为实谛之义

案。道生曰。二乘虽有四谛。以无真实惑。成八倒虚空之惑也。纵令得解非大乘也。若体真四谛。则无病也。僧亮曰。佛以七义说实也。真法以体常无变故也。不倒以境智。皆实故也。不虚以言无虚妄故也。大乘以究竟尽苦故也。佛说以所言不谬故也。一道以更无异因故也。常乐以果中无上故也。此表实法无不实也。法瑶曰。常乐我净。为真法。菩萨体之。则无以倒。其解真正。确然不改。可曰为实。智无不审。慧无不识。审识之义。可曰为谛。是以菩萨之解。名曰真法。无有颠倒。无有虚妄。名曰大乘。一道清净者也。备此众义。名曰实谛也。僧宗曰。此实谛明理旷矣。何者。前二谛正摄诠耳。未摄忘诠之旨。今实谛者。即体以辨义。忘诠之处。亦复为实。是则下惑上解。岂有一理而不不尽耶。就文虽有八句。义不出六也。初明佛果行人。是实第二第三颠倒虚妄二句。解惑以明义也。第四第五就教以明实也。第六明因实。第七明果实。今六句所不收悉。还以境实而收之也。第一第七二句。前则据人。后则据法。以此为异也。颠倒虚妄者。据其重处为言也。虚妄者。从未免相惑。金刚心已还。就轻处说也。宝亮曰。七重辨实。第一明果体实也。真法者。法若不真。不名为实。故知神明妙体。非伪因所生。理相虚寂。过有言之表。唯斯一法。可称真而实也。第二就境界辨实。第三就正智为实。耶解非实。第四明大乘是实。小乘非实。第五明教实。昔教所诠。未必尽实。要是佛说。当时有益。是故为实。魔教乱真。能令行人入生死。故言非实。第六一道清净。明因实。一道是一因。若有异因。则非实也。第七常我乐净。明果实也。与第一句。何以为异。彼明果体。据得果时为语。此明佛弟子所行。必定当得此四法故。是为因中说果。以此为异

文殊师利白佛言世尊(至)及与佛性无有差别

案。道生曰。向云四谛有实。名为实谛。而如来虚空。佛性皆是真实。便是四谛真实。合以为三。三有不实。故须分别也。僧亮曰。文殊以常为真实。常法有三。谓果说如来。因说佛性。余说虚空。此三常无差别。可为真实。余法非实也。法瑶曰。已明菩萨得为实谛之义。似与佛齐。故发斯问。将显如来异于菩萨。有实有谛。如来唯实无谛。所以者何。谛者。用照审决之谓。如来理穷道尽。息照废审。湛然永安。是以无谛之名。常住不变。故有实之称。又有一义。夫谛者。定物之名也。如来至寂。出于名数之表。非名之所能定。故下历明四谛。释如来无谛之义也。自斯已还。既未穷理。若穷理体圆。明照审物。可以名定者也。僧宗曰。文殊领解下六句。设难。即是如来者。会三法领解之辞也。所以作此领解者。向虽言同实。如似异与果体为一。故须简也。宝亮曰。此下料简上七门也。就释第一章中有五阶。第一辨异。第二释异。第三结真。第四遣对治。第五还捉苦。以结句也。问意唯虚空等三法。为实谛三法之外。更无差别实谛耶

佛告文殊师利有苦有谛(至)佛性非苦非谛是实

案。僧亮曰。若以不变为实者。有常而不变。无常而不变也。常无常异。实义不异。一切皆实也。非苦非谛者。释实义。学地推求。故有谛不谛。无学无求。故非谛也。法瑶曰。凡夫有苦无谛。二乘有苦有谛。菩萨有谛有实。如来有实无谛也。僧宗曰。此下有五重明也。第一历四谛。明如来不同。次第二释所以不同。第三释人情疑。疑言。乃可不同于四谛。然此三法。何必不别体耶。今明三法一体。所以是常成不同之义。第四结非。第五总结释也。宝亮曰。此第一阶辨异也。遍历四谛。当体皆实。虽当体是实。而非上三法之实。故下言。如来非苦非谛是实。谓极果之实。非四谛之实也

文殊师利所言苦者(至)虚空佛性亦复如是

案。法瑶曰。苦理实尔。可以名定。审为实谛也。又名菩萨辨苦得实。为实谛也。下三谛义亦同也。如来非谛。具如前解。故不句句释。僧宗曰。第二重释所以也。言是无常迁流断坏之法也。宝亮曰。第二阶释异也。何以故。如来之实。非四谛实。苦者是可断除法。如来实不可断除。故不同也

复次善男子所言集者(至)虚空佛性亦复如是

案。僧宗曰。集能令未来五阴和合。又其体是流动也

善男子所言灭者名烦恼灭(至)虚空佛性亦复如是

案。道生曰。案名而言。唯在结灭。不及不灭。结灭害除。理应证知。斯则名谛。谛者。审实为义。故言实耳。非前所言实谛也。僧亮曰。灭谛说以无烦恼无法为灭。不通学地。有常无常。由智证灭。故名证法。如来之性。至不名证。知者由智。称非无。能断烦恼。证非无也。无不能断结。唯是果性。不通学地非常无常。智不自证。非证法也。法瑶曰。灭有二种。一结灭。二涅槃。善有亦名为灭。善有灭即是如来。今言结灭。不言善有灭。是以所言灭者。名烦恼耳。二乘结灭。未极极者。夺之故无常也。佛结都灭。是极灭。无以易之。故为常也。虽是常灭。然体尽是灭结而已。非是如来无方之体。故可以灭名。往定谓之曰谛灭。无生灭可曰为实。是为实谛义也。又就菩萨解。为实谛也。僧宗曰。二乘灭三心。虽复无为。但未是极。更有进求。故称无常。诸佛所断之处。满足于此。无复增进。故为常也。今如来不名灭。非常无常。非二种灭也。名证知者。不名二种所证法也。宝亮曰。体无物故是常。然有满不满。故名无常。如来之性不名为灭者。明如来之灭。非是能灭烦恼之后灭。亦非断无之常。复非可证得也。常住不变者。既是断灭之灭。非真常之寂。直是性非变易。故言常住也

善男子道者能断烦恼(至)虚空佛性亦复如是

案。道生曰。道之名者。在用能通。不及无用也。未极则转进无常。极则常也。僧亮曰。道是灭因。故名能断。无漏不退。故说常也。体是生灭。无常有为。故名修法。如来非道。至非修法。如来不通学地。非灭因。故非道也。虽能除结。非有为道。非常无常。亦非修法也。法瑶曰。夫道之名。生生乎进趣。用功除灭。如来无此。是以非道也。僧宗曰。亦常无常者。言二乘改操。更向佛之义。名无常也。菩萨本自向佛。无所改操。故为常也。如来非道。能断烦恼者。能为解脱道证断也。非常无常。非二种道也。宝亮曰。自四时经教。无有此言。今大乘了义。其旨始判。得知神明。以真俗为质也。无漏解脱。既以寄此果报中。发一得之后。其解常存。但于俗谛用边。自可谢就真为论。则常用而不朽。此亦不关相续之常也。经言。本得不失。以胜者受名。今寻此旨。必非前生后灭之法。下文须言。烦恼亦常无常。从起烦恼后。若未得治道已来。常障行人。虽有此言。但烦恼始终。为道力所治。终归落无常门耳。然道谛始终。更无有一法。复为他所治。故始终成常。正以积十地。明解既满。成于极果。解未满时称因。若满则称果也

复次善男子言真实者(至)佛性者即是真实

案。僧宗曰。第三重释所以为常。以三法无别故尔也。宝亮曰。第三阶结真也

文殊师利有苦有苦因(至)虚空佛性亦复如是

案。法瑶曰。明四谛既周。故结上来所说如来非谛是实之义也。僧宗曰。第四重结非也。宝亮曰。第四阶明四谛。是对治故名实。如实如来非对治故。是真实之实也

苦者有为有漏无乐(至)湛然安乐是实非谛

案。僧宗曰。第五重结释也。宝亮曰。第五阶捉苦以结句也。明如来非是有漏。湛然安乐。所以故是实也

大般涅槃经集解卷第三十二大般涅槃经集解卷第三十三

  广释前七种实谛义　广出外道所执常乐我净

    圣行品之第七

文殊师利白佛言世尊(至)一切颠倒不名为实

案。僧亮曰。上以问真。次问四倒。若不入四谛。实谛摄法不尽。下讫佛说亦尔。一道以下。不难摄实不周。乃则说实不滥耳。法瑶曰。上来明四谛。皆名为实谛。似如颠倒虚妄。非苦集谛所摄。是以发此问也。宝亮曰。释第二境实也。问四谛中有倒。不若有者。云何言实。若四谛无。则四谛之外。应更有法也

佛告文殊师利一切颠倒(至)非不是苦即是苦也

案。法瑶曰。以心想而论。则为颠倒。以性而观。则入苦谛也。宝亮曰。应云皆入苦集谛也。今但言入苦者。据一边

文殊师利言如佛所说(至)所断除故故名实谛

案。宝亮曰。释第三智实也。若智所缘境。无所契当。即是虚妄也

文殊师利言如佛所说(至)是变易法名为不实

案。宝亮曰。释第四乘实。大乘缘中忘相。故实。小乘执相。故不实

文殊师利言如佛所说(至)如是虚妄名为魔说

案。僧亮曰。释第五教实也。但佛说必能利物。魔说生缚。故非实也

文殊师利言如佛所说(至)彼无一道清净无二

案。僧宗曰。非灭生灭想者。谓计非想。为涅槃果。八禅为因也。宝亮曰。释第六一因之实

文殊师利言如佛所说(至)亦复说言诸行是常

案。僧宗曰。谓佛之言。常人所不见。外道计阴为常。交验所计。故应有也。宝亮曰。释第七果实也。文殊执外道所计。历此四法。语在其下。凡二十三句也

云何是常可意不可意(至)若是常者即是实谛

案。宝亮曰。以七事证常也

世尊有诸外道复言有乐(至)上中下故当知有乐

案。僧亮曰。以五事证乐也

世尊有诸外道复言有净(至)以是义故名之为净

案。宝亮曰。以三事证净也

世尊有诸外道复言有我(至)亦得说言我有真谛

案。宝亮曰。以八事证我也

佛言善男子若有沙门(至)诸行若常无有是处

案。宝亮曰。将欲破执。答彼问。先以二十事。诃外道所计

善男子我观诸行悉皆无常(至)无有一法不从缘生

案。僧亮曰。既言是行。理自无常。诸法从缘者。证诸行无常也。法从缘起。本无今有。是名生。已有还无。是为灭也。何者。心以所缘为本。不称所缘故。即谓本无也。而心自横生。是今有也。横生无根。起便自灭。因既如此。果亦应然。故经云。因无常故色无常。此其证也。僧宗曰。外道所计。不得离阴。一一法上。无不从缘。唯佛性不从缘生。非三世摄也

善男子佛性无生无灭(至)之所摄持是故名常

案。僧亮曰。说正因性也。亦从缘见。非从缘生也。何者。行缘求理。理非本无今有。谓不生也。念念常求。谓不灭也。既非生灭。无去无来。亦无三世。因不横起。故非作也。于缘求解。非不作也。不以一法为因。故非名也。说为正因。非无名也。非名非色。乃至阴界不摄。证无名也。阴界有坏。而佛性不灭不摄也。是故称常者。以二义常。一必定得果。二因不可灭

善男子佛性即是如来(至)悉是妄语无有真谛

案。僧亮曰。见性成佛。即性为佛也。如来即法者。法即性空。性空即法。法即佛性也。佛性是有。性空是无。佛见有无名觉也。佛即是法法即是常者。通计二句。见常故常。如来即僧者。见常而常和合也。和合是僧义。师法是弟子义。僧即是常者。师常故得常也。若不知三宝是常。而言常者。名妄语也

诸凡夫先见瓶衣车乘舍宅(至)当知其实非是常也

案。僧亮曰。证不见者。说是妄语也。一切有为皆是无常者。将就有为。说无常义。更以有无相对也。僧宗曰。举其计常中第七句。言前后相续相似语。其体念念生灭。岂有常耶。宝亮曰。计云先见瓶衣等。后时亦识。当知有一神我常故常。故如此也。下去唯有两难。初云。汝心若常。应同佛一切智。用常自无移种。眼识对尘时。应独缘一切法。而今不尔。念念生灭。缘此舍彼。故知心是无常。第二难将境以决心。心若果从缘生而常者。应恒守一法。不得改心易缘也。何以然。心既是常。应常。观无常不得。复缘空无我。而今心遍缘一切境。故知无常也

善男子一切有为皆是无常(至)无为者即是常

案。僧亮曰。将就有为。说无常义。更以有无相对

善男子有为之法凡有二种(至)色法者地水火风

案。僧宗曰。向但言无常。今出其法。不过色心也

善男子心名无常(至)乃至意识异亦如是

案。僧亮曰。心攀境而起。前后相应。共了一缘。此总说。下别说也。眼识性异者。眼识缘现在。意识缘去来。下境界相应亦尔。眼识应独缘一切者。眼识不灭。行在诸根中。在耳之时。亦应见色。识性不异故。若尔。应缘一切法。今不尔者。凡夫倒计为常

复次善男子坏诸行因缘故(至)诸忆念法不应忘失

案。僧亮曰。说无漏行异无漏。能灭诸行也。所谓声闻心性异。乃至外道心者。上明苦乐烦恼。说佛弟子。此说外道。不能分别诸色。正以了为心。了青不可了黄。眼识不能具取色也

善男子心若常者(至)有别异故当知无常

案。宝亮曰。从此以下。并答计常中第四五六三句也。就色心别相。遣其执也

善男子我今于此非色法中(至)先问是事于彼已答

案。僧亮曰。此下略说内外色性。本无今有。已有还无。常所有内色异也

大般涅槃经集解卷第三十三大般涅槃经集解卷第三十四

  破外道所执义　释更转法轮义

    圣行品之第八

复次善男子诸行无我(至)以是义故定知无我

案。僧宗曰。专念忆想。是证常家。第三第四事也。常即自在。所以兼破

复次善男子若诸外道(至)如来如是真实有我

案。僧亮曰。计我之六事也。诸根和合。是假名我。假名但名家称名也

复次善男子若诸外道(至)以是义故定知无我

案。僧亮曰。通破第一第二事。先以口涎破第四事也

善男子是诸外道痴如小儿(至)有真实谛非于外道

案。僧亮曰。我名本在佛地也。外道不识得少许分故。妄计诸行为我。如生盲不见色。说色语之。唯以已之所解为色。终不得色之相

文殊师利白佛言世尊(至)乃作如是分别真谛

案。僧亮曰。四谛二谛。昔来凡是广说。显示应迹。似乖将欲会之故也。法瑶曰。闻上广说四谛真实之义。叹今说实谛。于昔鹿苑。为更转也。僧宗曰。三重明慧。穷理尽性。圣行已毕。迦叶取时众之心。假为不达因。以尽疑也。宝亮曰。一品之中。第四遣执明慧也。若于缘中。虚心属法。则成智慧用也。文殊一问。成有三过。一谓如来实涅槃。二云佛作心转法轮。三谓更转也

佛告文殊师利汝今云何(至)常住不变不般涅槃

案。僧亮曰。转法轮者。谓所说之法。令听悟解。为转也。解以摧惑。为轮也。若佛有说。则是有为有尽。何名涅槃。今无说而物闻。不灭而人自灭。故言不涅槃也。僧宗曰。疑有三意。此释第一意也

善男子若有计我是佛(至)如来方便转于法轮

案。僧亮曰。此下释不转有二意。一以不转说转。二就迹应有转也。此第一意。不转说转也。僧宗曰。释不转有三重。第一极处无转。第二应故有转。第三显极处相。如虚空也

善男子譬如因眼缘色缘明(至)非诸声闻缘觉所知

案。僧宗曰。第二明有转之。义缘有应接之因也

善男子亦尔非生非出(至)非作非造非有为法

案。僧宗曰。第三明极地无心于转。如彼虚空也

善男子诸佛世尊语有二种(至)为诸菩萨说出世语

案。僧亮曰。第四明昔小今大。不应言更。若以益物为更者。四十九年已来。未始不益。不应今日方云更也。僧宗曰。此下释无更义。有九重也。此即第一明教异。谓昔浅而今深也

善男子是诸大众复有二种(至)为诸菩萨转大法轮

案。僧宗曰。第二明乘异。昔为求小者故说。今为求大者说

复次善男子复有二人(至)极下根者即一阐提

案。僧宗曰。第三明根异。昔为中根者说。今为上根者说也

复次善男子求佛道者(至)为上精进转大法轮

案。僧宗曰。第四明精进异。昔为中精进。今为上精进说也

复次善男子我昔于彼(至)阿耨多罗三藐三菩提

案。僧宗曰。第五明得道异。昔八万天人悟须陀洹果。今八十万亿人不退转三菩提也

复次善男子波罗捺城(至)稽首请我转大法轮

案。僧宗曰。第六明请主异。昔日梵王。今日迦叶

复次善男子我昔于彼(至)如实演说常乐我净

案。僧宗曰。第七所明理异。昔说无常。今说常也

复次善男子我昔于彼(至)四维上下亦复如是

案。僧宗曰。第八声之所闻远近异。昔止梵天。今彻十方廿恒沙世界之也

复次善男子诸佛世尊(至)皆悉名为转法轮也

案。僧宗曰。第九明自出世已来。未曾不转法轮。今亦何更之有耶

善男子譬如圣王所有轮宝(至)大涅槃经所行圣行

案。僧宗曰。叹法轮也

迦叶菩萨白佛言世尊(至)则能奉行故名圣行

案。僧亮曰。上已说戒定慧。通菩萨。得称圣行。未知究竟实谛。通学地以不。是故问也。圣名诸佛世尊者。夫究竟实谛。得称圣行。唯佛世尊也。法瑶曰。此下为明圣。不为明行。上来明戒定慧是圣人之所行。非明圣也。圣者正也。如来始当其位。故说佛说圣义也。今但合行说耳。旨不在行也。僧宗曰。上明戒中。已结圣名。今辨三法既竟。复想结圣行。宝亮曰。第五段结果也

善男子是菩萨摩诃萨(至)是故此地名无所畏

案。僧亮曰。前三是因。后四是果。慧能断因果。故总说地德也。亦不畏三恶道者。除恶已渐。故次说之。此三粗故先除也。恶有二种者。此善趣中恶也。不畏受二十五有者。无如上恶。能断二十五有也。法瑶曰。得上戒定慧行。则入此初住地也。离五怖畏。故曰无畏地也。畏贪恚病死等者。即不死不活畏也。阐提等者。离恶名畏也。不畏三恶道。无恶道畏也。不畏沙门。乃至波旬。无大众畏也。前不动地。是入初地之始也。堪忍地。是初地之中。此无畏地。是初地之终。亦可七住。七住三界结尽。始无三畏之畏也。僧宗曰。无畏地者。七地也。前结戒果云。初不动地。次结定果云。第三堪忍地。今结慧果。指第七地也。所以尔者。示行有浅深。结果亦异。言无畏为七地。依常释七地。为远行地。今乃云。无畏者。谓不畏三界果报。故偏称也。宝亮曰。无畏果者。亦同是初地。明慧是解性。不存缘而照。既具有无分别之知。故结之以无畏也。第一无不活畏。以菩萨达万法相空。不假资生。岂畏不活。以不畏故。则不生三毒。故无不活畏也。第二无三恶道畏也。第三无恶名畏。第四无大众威德畏。第五无生死畏。大士不畏受二十五有生死

善男子菩萨摩诃萨(至)所有功德而当可说

案。僧亮曰。智能除结。非定不成。是以因定说智也。若欲吹坏须弥山王。乃至碎身之苦者。地有二果。一灭恶。二神通。两说其名也。所以然者。上说断有。或者便谓。不得入有为化。更出自在之事。以表地名。释其疑也。僧宗曰。此言渐进。向八地也。向七地已。不畏恶道果报。而未免二十五有者。就七地。自有余报身者。今八地以上。一向法身。故言二十五有也。三昧非慧。因定生慧。共相资成也。所以知八地者。言具二十五三昧。能为种种神通。寻神通之用。非近行所为也。宝亮曰。第六段也。若通作结果段者。犹属前文。第五段直结果。在初地既发。初住得无漏正解。后方进修万行。得二十五三昧。断二十五有。结得八地以上自在果。若就此义而分。则成第六也。此二十五三昧。就胜处受名。一一皆摄于众。故名三昧中之王也

大般涅槃经集解卷第三十四大般涅槃经集解卷第三十五

  释从佛出十二部经从十二部经出修多罗从修多罗出方等经从方等经出波若从波若出涅槃义出菩萨在雪山为半偈舍身缘起

    圣行品之第九

尔时众中有一菩萨(至)阿耨多罗三藐三菩提

案。僧亮曰。此经明复说经功德。劝人行经。经即法也。行法虽由人。然灭恶由法也。譬药能治病。虽由人能服。然去病之力在药也。是以法华经云。若骂佛者。是人罪轻。毁经法者。罪则重也。宝亮曰。此下第四段叹经流通也。有四翻。第一无垢藏王叹。第二佛自叹。第三迦叶叹。第四佛引证。成迦叶所叹也。此即第一无垢王叹

时佛赞言善哉善哉(至)无量无边不可称计

案。僧亮曰。佛教从小起。牛譬佛也。乳譬三藏。酪譬三乘杂说也。生苏譬方等。熟苏譬说空般若。醍醐譬涅槃经法也。法难见者。空有也。以般若说空。涅槃说有也。佛难见涅槃。为胜尊重赞叹也。僧宗曰。圣行所以而成功。由经力。生人圆解也。如从牛出乳者。佛说小乘四谛法轮。此是成佛十二年中说也。从乳出酪者。谓十二年后。说三乘通教。大品经是也。酪出生苏者。如思益维摩。抑挫二乘。称扬菩萨也。从生苏出熟苏者。说法花破无三因果也。今此经明佛性常住。穷理尽性。如醍醐也。又出十二部者。小乘十二部也。从十二部出修多罗者。空教修多罗也。但言修多罗者。摄十二部故。但言本耳。出方等理正不耶。二乘等学般若。故以通教。为方等也。出般若者。一乘实慧般若也。从般若出大涅槃者。即今教也。又一解云。此经文小误。般若应为第三。方等应在第四也。宝亮曰。佛如牛也。五味譬五时教也。佛初出世。十二年中。小乘三藏。别相说法轮。置出世之教。始当十二部之名也。从十二年后。通教门中。辨空有。明真俗二谛。理既深广。如从乳出酪。二谛是空解之主。亦是万解之本。所以当修多罗名也。但自通教之前。直明因果。义不辨二谛。忘相故不与本之称。从修多罗出方等经者。自通教说后。述维摩思益。进声闻行。令舍执得解。故以方等经。譬如从酪出生苏也。从方等出般若波罗蜜者。般若言智慧。从说维摩。后明法花。辨一因一果。智慧开明。以譬般若。喻之熟苏也。既说法花经竟。涅槃教与明理具足。犹若醍醐也

迦叶菩萨白佛言世尊(至)恭敬供养尊重赞叹

案。僧宗曰。迦叶是请法之主。自说修行之相。法瑶曰。上来虽明圣行。未尽其美。此章广明慕法情重。舍其身命。不以为难。以此舍心修习圣行往不备。以此苦行。何往而退。圣行之难莫过于此。故以斯行。结圣行之终矣

尔时佛赞迦叶菩萨(至)诸行无常是生灭法

案。智宗曰。先说无常也。以二理必对必应圆说。故谓半如意珠也

说是半偈已便住其前(至)生灭灭已寂灭为乐

智秀曰。说常也。寂灭无苦。以无苦故。名之为乐。无更别乐。故云寂灭

尔时罗刹说是偈已(至)大般涅槃修于圣行

案。僧宗曰。上已赞其所行为难。今引昔事。以证护法之不虚。求法之至也

大般涅槃经集解卷第三十五大般涅槃经集解卷第三十六(梵行品第二十)

  释七善法为梵行谓知法知义等　释十二部经　广辨四无量心　辨爱行人多集喜舍见行人多修慈悲　广释四无量定数　广释怨亲中人有九品义

    梵行品第二十

案。僧亮曰。以四等为体也。本是梵天道。仍本名也。亦云。梵是净义。圣行是自净。四等是净他。自净净他。故得梵名也。得具梵行者。先以七善自正。后能四等正人。称七善者。能具前四以治内。具后三以治外。皆自正义也。宝亮曰。大判此品。有四段。第一举七善为自行之体也。第二从四无量心以下竟六念。正谈外化。第三在体既显。便赞叹流通也。第四阇世证此经。能灭大恶。亦证慈悲有实益也。智秀曰。此品有五段。第一明梵行因。即七善也。第二明梵行体。即四无量也。第三明梵行果。第四叹经。第五以阇世为证也

善男子云何菩萨摩诃萨(至)六者知众七者知尊卑

案。僧亮曰。七善未即为梵行也。就七善中。前五自行。后二外化。能具七善。故能具四无量。成外化也

善男子云何菩萨摩诃萨(至)如是一切名修多罗

案。僧亮曰。修多罗者。含五义。如经叙也。僧宗曰。知法。谓十二部经者。从如是我闻。讫欢喜奉行也。宝亮曰。谓知十二部经也。然此言即是法辩。能识法区分。名相体别。善达其旨。非法辨如何。是以今据之。以取池也。十二部经所明。理无不通。四谛十二缘等法。无一经而不明此理者。所以冠通诸部也。今明其部别者。遂所辨事义。以标其异耳。然十二部名。皆外国音。修多罗者。此称法本。亦言经本。能生观境之智。故称法本。若从如是我闻。下讫欢喜奉行。总于文理。通为十一部作本。正以此义。名修多罗

何等名为祇夜经(至)更不受诸有是名祇夜经

案。僧亮曰。此言重颂偈也。长行已明。更重颂令显取此义。故表殊于余部

何等名为受记经(至)号曰弥勒是名受记经

案。宝亮曰。天竺云和伽罗那也。昔未说四谛以前受记。但记云。十善生天。五戒生人。从通教后。明受记其当来成佛国土名号。谓之受记经。亦以取此受记义为别也

何等名为伽陀经(至)是诸佛教是名伽陀经

案。僧宗曰。除修多罗及诸戒律者。谓除重颂修多罗及重颂戒律也。宝亮曰。此除十一部云直说偈。谓不颂长行。亦以颂他为异也

何等名为优陀那经(至)无问自说是名优陀那

案。僧亮曰。无问自说经也。比丘嫌佛定久。决疑无处。生此念也。寿命极长者。于人是久。于天则不久也。善哉为他不求己利。乃至少欲知足者断疑。欲度众生。致此释也

何等名为尼陀那经(至)渐盈大器是名尼陀那经

案。僧亮曰。所因根本者。先说因缘。后说偈者。是也。僧宗曰。为因缘故说偈。不以偈为因缘也。宝亮曰。随有人犯罪。则因事制戒。故名因缘。以此制戒之因缘。得异于余部也

何等名为阿波陀那经(至)是名阿波陀那经

案。宝亮曰。此云譬喻经。理致虚玄。不可以真言取悟。若不假借外事。无以况所诠也

何等名为伊帝曰多伽经(至)是名伊帝曰多伽

案。僧亮曰。名曰界经者。释迦出世。多辨法性。此经作如是名。过去诸佛作佛。作如是名。名如是语经。僧宗曰。此云如是语经也。过去世佛说经。作如是名字也。释迦名界。以其分别法相界别之义也。鸠留秦佛名甘露鼓。言以毒涂鼓。闻之病除。以理书上竹帛。闻见除病也。宝亮曰。通释迦一化之中所说。名曰界经。乃至迦叶佛名分别空。以过去事证今事也

何等名为阇陀伽经(至)所可受身是名阇陀伽

案。僧宗曰。此云本生经也。宝亮曰。如法华中分本生本事为二。今此中但取过去行菩萨时作粟散王等事义。以为一部也。若举其本生。则生中之事亦随。故据通而迹别也

何等名为毗佛略经(至)犹如虚空是名毗佛略

案。僧宗曰。此云方广经也。宝亮曰。昔十二年中。唯取其文辞句旷。故以为广经。不得称方也。自通教已后。至今涅槃。如雪山菩萨一四句偈。收有为无为二轮理尽。则无所不苞。故谓为方广也

何等名为未曾有经(至)如是等经名未曾有

案。宝亮曰。天竺云阿浮多达磨也。夫希有之事。名未曾有。如大青牛。行瓦钵间。令诸瓦钵。互相棠触。无所伤损。如此等事。悉名未曾有经

何等名为优婆提舍经(至)十二部经名为知法

案。宝亮曰。此云论义经。夫理相幽微。若不假以往复。则于义不彰。故取论议之事。别为一部也。然此十二。尽有文理。如火宅一偈。若修多罗往取。则举体是法本也。若以偈颂往拟。便是祇夜语之。是譬即譬喻经。如此三义。即是三家文。是为无有。有理而无文。但文而无理也

云何菩萨摩诃萨知义(至)广知其义是名知义

案。法瑶曰。若不知义者。则己道未成就。能以解利物耶。是以急须知法及义者也。宝亮曰。第二更无别旨。正以深得此十二名下所以。故名知义也

云何菩萨摩诃萨知时(至)般若波罗蜜是名知时

案。法瑶曰。夫化物要须知时。不尔则失其机。岂成化耶。宝亮曰。第三善知修道之时。则于胜理无阙

云何菩萨摩诃萨知足(至)睡寤语默。是名知足

案。法瑶曰。苟不知足。则唯利是贪。吝而不舍。安能以慈悲救物乎。故宜知足也。宝亮曰。第四于四威仪中。必动静得所。不乖三业而妨道

善男子云何菩萨摩诃萨(至)如是答是名自知

案。法瑶曰。自知兼物之道具。然后可以施化物也。可谓自知矣。宝亮曰。第五若不觉知自己有德。亦于应深进之义失。故能自知有解之少多。更庄严心业也

云何菩萨摩诃萨知众(至)如是问答是名知众

案。法瑶曰。众有群方众类。不可以一方之言。适彼众也。是以知众有群俗之异。类言以应之也。宝亮曰。第六应识国土仪轨之风。若不善知此者。于化道有隔

善男子云何菩萨摩诃萨(至)七善法已得具梵行

案。法瑶曰。知道尊于我上者。则以尊敬之。卑于我下者。则以慈救之。是为七善。成遂四等之要行。故须明也。宝亮曰。第七据行善者。有优劣胜负。如经所列行善。劣者则卑。优者则尊。既具此七法。便能自在适意应物。若如意之宝珠也

复次善男子复有梵行谓慈悲喜舍

案。僧亮曰。初说四无量相。四皆是慈。浅深为四。论有明文。不辞费也。僧宗曰。慈悲喜舍者。乃是慧性。以其用有优劣。一方制名。所以四也。言无量者。所缘为称。如悲拔苦。则有识蒙救。情无偏益。缘于无量。故称无量也。宝亮曰。第二大段明外化之行也。分为七重。第一辩四无量名数。第二明四心浅深。第三显此四行是实。第四且略结三无量。果在初地。就有中位也。第五别结舍果亦在初地。就空为位。第六明四心成后。登初地去。更进修十一空。得胜上无漏。至于十地。既明十一空满。齐金刚心。便频设三譬赞叹故。第七从八种知见。以次第上三譬也。此下讫一子地。第二段明梵行体。即四无量也。有三翻。第一讫名为无量定。无量名得立为四也

迦叶菩萨白佛言世尊(至)推义而言则应有三

案。僧宗曰。此下凡设五重难。此第一举所治之德。既同能治之慈悲。不应有异。所以唯三。不得四也

世尊慈有三缘一缘众生(至)缘如来者名曰无缘

案。僧宗曰。第二难。四心虽殊。而有三缘。谓缘众生。缘法。及无缘也。既所缘是同。唯应一也

世尊慈之所缘一切众生(至)是故应三不应有四

案。僧宗曰。第三难。谓见有父母等者。名众生缘。不见父母。但缘五阴。众生之本。离前二心。即空。为缘境既有。就心从境。唯应有三也

世尊人有二种一者见行(至)是故应二不应有四

案。僧宗曰。第四难。以见爱二人。应为二也。若是见行。必见利根。以强救为能。故唯修慈悲。若爱行之人。志气浮弱。必是钝根。见人胜事。唯有随喜而已。故但有喜舍。所以但应二也

世尊夫无量者名曰无边(至)是故应一不应四也

案。僧宗曰。第五就名字为难。若依正义。释无量者。正以缘无量众生为境。假为不达之辞。乃谬取佛意。谓心体无边际。若称无量。则不翅有四。若存其少。近应一也

佛告迦叶善男子诸佛如来(至)深秘行处不应生疑

案。僧亮曰。此下将欲答难。先显秘密。凡所说法。皆为度人。非浅识所量。不应图度应尔不应尔也。先举因缘是一。而为众生故。凡有所说。多少不同。唯佛能知。是意密也。除生一法者。萨遮尼揵子。父是梵志。母是尼揵。以其不如法生故。为此护其意。不说生也

善男子如来世尊有大方便(至)为调众生岂虚妄耶

案。僧亮曰。次显口密

善男子或有众生贪于财货(至)无所染污犹如莲华

案。僧亮曰。次显身密

善男子应如是知四无量义(至)若有修行生大梵处

案。僧亮曰。总答上难也。生梵天者。有浅有深。上二界皆名大梵。初禅初得其名。明四无量行有浅深。经云。修慈极远。生第三禅。修悲生空处。修喜生识处。修舍生不用处。性有深浅。不应离也

善男子如是无量伴类有四(至)得名为四非一二三

案。僧亮曰。不乐者。嫉妒也。四种烦恼。不可一行顿除。须众行相助。是伴义也。僧宗曰。且以三句。总詶非一二三之难也

善男子如汝所言慈能断嗔(至)伴侣相对分别为四

案。僧亮曰。说性有深浅。治结须伴。有四义也。上云。嗔爱两异。今说嗔有下上。治有深浅。亦待伴也。僧宗曰。汝言慈能断嗔者。此举初难。虽可同治于嗔。然嗔有粗细。慈心断粗。悲心断细。今所断既殊。能断何得独不异耶。自六句释粗细义也。言伴类相对者。慈悲虽为伴类。而相对粗细。故为四耳

复以器故应名为四(至)以是义故应四无减

案。僧亮曰。答见爱二行。俱以因治为难。先答人是法器。而力能行慈。未能及悲。是器有异也。僧宗曰。此答第二。通答第三也。言世间器有大小。四心深浅不同。何得以境使盈缩耶。器以容物为用。境有容心之义。境既有四心。何得不耶。宝亮曰。先答第四难利钝器别。自有能行慈悲。而未能行喜舍。反覆皆然。行于慈悲。自有高下。喜舍亦有浅深。若尔那得难言应二而非四乎

善男子以行分别故应有四(至)无悲喜舍是故有四

案。僧亮曰。兼答因缘二难。虽是因缘。而缘中有异。非一非三也。僧宗曰。答第四难也。若行于慈心。未有悲喜。以四行不同始终一人。行此四德。岂得以利钝为难耶。宝亮曰。答第二第三难也。第二难。言一缘众生。二缘所须之法。佛不须缘。若尔。唯是一众生也。境既是一。但应一也。第三难云。一缘众生。二缘假名空。三缘实法空。是则境三。故应三也。此答意言。虽曰境同。然行人之行。有深有浅。自有能行初一。不能行后三。自有能行第二。不能行第四。云何难言境是同故。应一应三耶

善男子以无量故亦得名四(至)乃得名为无量无边

案。僧亮曰。答第五难。虽无量名同。内外行异。深浅大殊。不应一也。不能得自在三昧。始行菩萨。非无量缘者。与父母无量乐。不以无量众生为缘也。僧宗曰。答第五难。言缘无量众生为境。有四心之别。不言心体通同无际。不可承声为难也。宝亮曰。答第五难。名字虽同。然义有四阶。尽称无量。不得为一也

迦叶菩萨白佛言世尊(至)是名得慈非大慈也

案。僧亮曰。第二说四等成与不成也。始行习慈。要从亲近。从亲起者。烦恼难去。烦恼虽轻。不等怨亲。未成大悲也。僧宗曰。前第一定四无量名教。今第二明慈有浅深也。住下为浅。住上为深。于怨亲中人。非不平等。犹故名浅者。以慈心难成。极有退没。若上住者。不复退也。宝亮曰。第二段辨浅深。谓有漏相。想心名浅。得真无漏。一心具四。故名甚深大无量也

世尊何缘菩萨得如是慈(至)以是义故名大无量

案。僧亮曰。不能一日调伏心者。久修慈者。慈已成就。虽复经生。暂忘修习。一日成就。不从亲起也下诸譬。说嗔难除。明慈难成耳

大般涅槃经集解卷第三十六大般涅槃经集解卷第三十七

  明慈悲有实益　广明慈心中布施发愿事　广明菩萨所修之慈即万行　广明慈益象见师子力士移石卢至长者斯那大多女人及提婆达多憍萨罗贼流离太子

    梵行品之第二

迦叶菩萨白佛言世尊(至)如是之观非虚妄耶

案。僧亮曰。第三门明四等。是实行也。难有两意。此以虚行为难也。僧宗曰。难有三重。此初重云。众生在苦。不蒙救拔。证慈非实也。宝亮曰。此下大段之第三也。明慈是实行。将辨此理故。迦叶先作虚妄之难也。此中凡六翻。此下第一释慈体是实行。迦叶引五事。证其无实之难也

世尊若非虚妄实与乐者(至)威德力故一切受乐

案。僧宗曰。第二重难。如其必益。是则众生必应离苦也

若当真实不得乐者(至)云何得与此义相应

案。僧亮曰。此第二难。明虚行不应得实报也。僧宗曰。第三重难。以果验因。二事相违。虚实未辨。请求解释也

佛言善哉善哉善男子(至)诸佛菩萨真实不虚

案。僧亮曰。初偈说世间慈也。行人以施是实行。故以施福。修世间慈。不及其一况出世间也。何者。虽慈一人。与世之乐。施不得尔。升降可知矣。僧宗曰。就此明慈有实益门中。有五翻为证也。初明修慈实能转境。第二明慈能断烦恼。第三明慈为万善根本。第四明慈即万行。第五引果地之慈。证真实不虚也。佛是穷慈之极。得知因地亦有实益也。虽可有此五翻。若欲对向三问者。此五翻悉证慈有实益。并答初问。下当更题。第二问出别答也。此偈言。慈之功用。乃于诸行为胜。岂但实益而已。不可以声闻是虚。令菩萨益虚也。二问既释。则第三问自然释矣。宝亮曰。佛将答难。先叹之也。偈明实益格量功德。何者。有人止于一人边与慈。欲与其乐。始终必得出生死也。答人虽复供养无量五通神仙。以为福田。不如于一人边起慈。十六分中之一也。供养仙人。乃得生死之报。若拔一人苦。实获出世之利也。又化无量人。得出于生死。当知慈是实也。释慈有实益之义。文齐于此

云何知耶善男子菩萨(至)是实思惟非不真实

案。僧亮曰。五事证慈。此第一明能令境虽不实。而物得实益。如由金得乐。土即为金。若无金生乐。金即为土无异。小大相容。当事皆实。而得其用也

复次善男子云何名为(至)以是故名真实思惟

案。僧亮曰。第二以断结。故知非虚

复次善男子菩萨摩诃萨(至)阿耨多罗三藐三菩提

案。僧亮曰。第三事以慈能生万善。岂得非实耶。僧宗曰。身被毒箭者。谓悭贪箭也。眷属欲令安隐者。诸佛菩萨也。即命良医而为拔箭者。令诸福田。往就乞也。且待莫触者。方复优量。可施不可施。或财物多少。时节可不也。菩萨亦尔。若行施时者。合譬也

复次善男子菩萨摩诃萨(至)常应勤发如是誓愿

案。僧宗曰。言依离身一尺六寸者。如下经文。又曰。衣服离身四寸不堕。便是一边。四寸四边。为一尺六寸也。此则举其四边。彼乃言其一面耳

善男子一切声闻缘觉菩萨(至)以是义故实非虚妄

案。僧亮曰。六度是菩萨别行。说施一事。余五可知也。其余诸行。与三乘共行。由佛说故。以慈为本也。先说人后说法。不净至无我等观。说行相也。燸法至见道修道。说得果深浅也。正勤至八圣道。说深浅法之名也。四禅至无诤三昧。说定名也。他心智至佛智。说智名也。谓皆以慈为本也

善男子能为善者名实思惟(至)如是无量无边功德

案。僧亮曰。第四事说万行即慈。除苦为慈。三乘皆是灭苦。要得实者。则灭苦也。思惟是慈。尽苦名乘也

迦叶菩萨白佛言世尊(至)所修慈心为无利益

案。僧亮曰。第五事明慈。现有实益。故发问

佛言善男子菩萨之慈(至)是实思惟非无利益

案。僧亮曰。有二种必受苦。一以不救故。二以虽得小乐。更增重苦也。谓一阐提者。夫定受苦报。亦非但阐提。余业亦有。而其相难辨也。受苦不定者。谓与乐则得。不与则不得也。遥见师子者。夫不慈之物。有遇之者。则便生惧。大悲之人。有逆值者。实自然生乐。以凭师有在也。僧宗曰。前有两关。同明慈有实益。已遣一关。将显事迹。是故迦叶重有前问。佛即释

善男子我说是慈有无量(至)大涅槃经亦不可思议

案。僧亮曰。明法身无缘。有感斯应。以显大慈之功无出入异者也

大般涅槃经集解卷第三十七大般涅槃经集解卷第三十八

  释极爱一子地义　明佛不为众生作烦恼因缘　明释杀婆罗门以得一子地　明婆罗门入地狱发三念　明杀阐提无罪　出旷野鬼神缘起　发调达之迹　结修舍心果谓空平等地　广释十一空义

    梵行品之第三

复次善男子菩萨摩诃萨(至)得住极爱一子之地

案。僧亮曰。下以五譬。释此地名也。僧宗曰。第四结三无量果也。言极爱一子者。此是第七地也。言七地菩萨见众生在苦。乃至血流洒地。此爱是深于前。为胜也。八地以上。一心具万行。息空有二相。是故没其爱。名受苦平等之称也。此下有五譬。第一譬极爱。第二譬以下有四譬。譬一子。明登地时平等之慈也

善男子云何此地名曰极爱(至)是故此地名曰极爱

案。僧亮曰。第一譬明见善则喜也。僧宗曰。此譬喜无量也

善男子譬如父母见子遇患(至)是故此地名为一子

案。僧亮曰。第二譬明见恶则忧也。僧宗曰。此下四譬。是明病苦。苦有轻重。义推可有慈悲。阙无舍也

善男子如人小时拾取土块(至)是故此地复名一子

案。僧亮曰。第三譬明教行善法也。僧宗曰。左手足头譬之实慧。右手挑出譬方便慧

善男子譬如父母所爱子(至)是故此地复名一子

案。僧亮曰。第四譬入地狱为众生也

善男子譬如父母唯有一子(至)是故此地复名一子

案。僧亮曰。第五譬明不嗔加恶。若嗔加恶。无益之苦。菩萨则不为也。结舍自有别地。今但言三耳

迦叶菩萨白佛言世尊(至)复何因缘不堕地狱

案。僧亮曰。闻上以五譬释地名。今问佛者。为菩萨时。断人命根。既不与地义相称。而不堕地狱。进退未了

若使等视一切众生(至)云何于义不相违背

案。僧宗曰。向举杀婆罗门。以难因地之身业也。今举骂提婆达。以难果地之口业也。若身口如是。意业自可知也。宝亮曰。迦叶作两难。有四关。据始引终。事无遗也。故下更举事。以审佛复不应尔也

世尊须菩提者住虚空地(至)使诸众生起重恶心

案。僧亮曰。声闻尚复。将护彼意。况佛菩萨起重恶耶

佛告迦叶汝今不应至终不为作烦恼因缘

案。僧亮曰。将欲正答。且先借譬。假设之辞。明不为众生作烦恼因缘也。有两意。前明佛实不作。后明不应说也。佉陀罗树作炭。一烧六日乃灭。坚利伤人

善男子如汝所言如来往昔(至)于诸众生终无夺命

案。僧亮曰。正答中有三意。此第一历举六度明。乃是施命。岂云夺命。若于蚁子。尚不无益而杀。况婆罗门耶。举初度。指明现在有益。后举五度。明二世益也。僧宗曰。此下答初难之前关。菩萨之为法。蚁子尚不故杀。况婆罗门。但自此人。设不杀之。亦堕地狱。圣人今为作因缘。故令反迷有速也。若不为其作外缘。则堕坠无已。斯乃所以作解脱因缘。非谓为杀也。因广彰事验。明菩萨所行恒施众生寿命。云何难言断其命耶。然菩萨所施众生长寿。乃是佛果。无为法性之命。无苦之乐。岂复与彼众生生死。三受乐命者乎。故知其理必然也。于时已得此地者。但自慈心故杀。非是恶心故也。设一譬以显之。正为护法。故断其命。令善心得生耳。然菩萨常生此心。随有众生。生善法者。不问好恶。要当为之。是以诸婆罗门命终之后。即生三念。既舍人间报受地狱苦重。即觉所作为鄙。兼得宿命智。知从人道来。知所生是地狱。悟谤经之因缘重。是以致斯报。既知罪业如此。便信敬之志。悔昔所作。即坏本业。生于人天。故得知于常理生信。一诣无不感也。自有解言。生于阿鼻。受苦无间。应不得生三念。一家所解。不惮此为妨。乃可生在无间。不得起乐受耳。何容于苦识之中。都不得生心。而有所坏忆耶。故知此言无妨也

善男子汝向所问杀婆罗门(至)断其命根非恶心也

案。僧宗曰。第二意也。言得此地。故为三念。有利益故杀。所以无罪也

善男子譬如父母唯有一子(至)欲令改往遵修善法

案。僧亮曰。直以慈心杀义为喻。不遍取譬

菩萨意常作是思惟(至)随其方便要当为之

案。僧亮曰。但使有益事。不问善恶也

诸婆罗门命终之后(至)十劫寿命云何名杀

案。僧亮曰。因杀而施命。不起彼烦恼。以证成地义也

善男子若人掘地刈草斫树(至)虽夺其命而非恶心

案。僧亮曰。答上不入地狱难也。上云。善心杀故无罪。似如父母善心杀。复得无罪。故须明也。此言我无恶心。地复无罪。故不堕地狱也。夫得杀罪者。有三种。一由心得罪。如恶心人杀阐提。二由地得罪。如善心人杀善人三由心地共得罪。如不善心人杀善人也。僧宗曰。证无恶心虽杀无罪也。宝亮曰。答初难之后关也。无杀心故。不堕地狱也。以婆罗门悉是阐提。无伤田之义。故知得杀罪者。必我由有恶心。伤彼福田也

善男子婆罗门法若杀蚁子(至)无数千年在地狱中

案。僧亮曰。将明杀婆罗门。无从地得罪义也。先举外道所言。有杀无罪。此说非也

善男子佛及菩萨知杀有三(至)是故虽杀不堕地狱

案。僧亮曰。谓在三者。从地得罪。若不堕此三者。阐提断善根。故无从地得罪义也。僧宗曰。第三意证杀所以无罪也。谓三种之中。必因杀而有利者。尚无有罪。何况不堕三种杀中。而有罪耶

善男子汝上所言如来何故(至)应正遍知知方便故

案。僧亮曰。此下答果上有口过之难也。明以知方便故。莫问语之粗细。但使有益便说。无益则不。此非二乘所知也。僧宗曰。此答中有三意。此第一先明善照机宜。动必有益也。宝亮曰。答第二难。明所以发此言者。要使是时是法。必有利耳。诸佛岂空发言乎

善男子如我一时游彼旷野(至)故示如是种种方便

案。僧宗曰。此第二意。明但必有益。乃至身业苦楚众生。何况粗言耶

善男子我于尔时实不骂辱(至)不应如是生于疑网

案。僧亮曰。第三意。拂迹。明提婆达非实人也。宝亮曰。答后关难也。提婆达多非近情所测。云何堕此狱耶

迦叶菩萨白佛言世尊(至)所谓极爱如一子地

案。僧宗曰。前来第一定四无量名数。第二明浅深。第三明慈有实益。第四结三无量果。此第五叹佛说也

迦叶菩萨白佛言世尊(至)空平等地如须菩提

案。僧亮曰。以小譬大证也。理必平也。僧宗曰。前第四段。结三无量果。第五仍叹佛。此第六结舍果也。此中有八重明义。第一明修舍心故。得空平等地。即善识十一空。为其果也。第二明非但识空。复能深照世谛。出八种知见觉也。既空有两解。故第三明则得四辨以益物也。既有益之迹。执滞之家。谓有四可得。故第四说十无以遣执也。第五文殊举本无今有偈。意存无取无著。以证无著。虽明无以遣有。而复执无以为胜。故第六明反常之说。双遣其患也。乃至反常之旨。尚使当时有益。况有无之教。而非益乎。于是物情迷闷。寄心无所。是以第七明虽无所得。于体理者。终曰有得。故言菩萨得第一义也。言第一义者。即涅槃耳。第八举已有见者。证有得也。如须菩提者。此于声闻中。观空第一。既为时人所知。故借浅以明深也。宝亮曰。第五段结舍果也。亦同在初地。夫四无量行。本相关涉。不得相离。今言得平等地者。是登初地日。得真无漏也。见法体空故。以空平等为名。而所以别结者。欲使人乐此空法。而修行耳。智秀曰。此下第二段也。有三科。第一问果在何地。第二问空是何空。第三说得利者也。此即答其第一问。正辨舍果。明此果在心。则善能照空。从所照受名。谓所得之地。为空平等也

善男子菩萨摩诃萨(至)善能修集诸空法故

案。僧亮曰。释空平等义。以明地相地名也。譬如虚空者。释所以空平等为地者。善修诸法空故也。智秀曰。明本性自空。故无所见。非是不能见法也

迦叶菩萨白佛言世尊云何名空(至)是名内外俱空

案。僧亮曰。内情名内。以二种空观也。一互空。如牛中无马。我无他法。名为空也。二相待名空。无外故无内。何者。父母是外。亦不自外。因内故外也。内中无故。外不可得。外不可得。故无内也。众生寿命。常乐我净。七法横计。亦名为外。大品云。二谛无众生。知众生等。是横计也。虽有性者。七法横故可无耳。佛性不横。故须明也。内法外法。是别也。因别有总。空亦同上。不在二空者。内外二空。不在相待空也。但说二者。别中既无。总中可知也。僧宗曰。十一空。乃此经一时之教也。自大品诸经。乃有十八空。当知空无多少。以遣惑有广狭。故教门不同耳。就十一门中。前五空遣六谛家病也。百论中言。外道计有一总有之法。与一切法合。今前五空。遣其总心。言内中无外。外中无内。有为无为亦如是。岂有总法与法合耶。第六无始。遣二十五谛家之计也。上五空迷果。此冥谛迷因也。人情谓遣向横计。方有空生。今言不待遣横。但其体性自空也。无所有空者。向虽言性空。何以辨耶。今以智捡。都无所有。验所以空也。第一义空者。夫有是生着之处。向借无以遣有。此无于有。其理则胜。是为第一赞叹。以受名也。空空者。物情生执。谓遣有会空。理极于此。执之为胜。复为病也。言本为遣有故说空。岂有空可得耶。大空者。前已遣境。今复遣智。境智双忘。始为大也。内法中无外法故。岂有一总有遍一切处耶。未得为性。已得为三宝也。非内非外者。以众生有为。佛性无为故也。无为。故言非内也。不离众生而有性。故言非外也。内外空者。上二空心弱。不能并观。今心力转胜。故能双观也。八地之心。岂有强弱。示空门有次第耳。唯有佛性。不在二空者。双观二法。虽复内外之异。然有是同。而如来佛性三宝非有法。虽复双观。而内外不摄此四法也。今至双观时。不言无父母。但言无三宝等者。以父母始终不离内外。故不复说。而三宝非内外。故说也。宝亮曰。此第六段。于初地果上。更进修十一空。乃至得十地果。亦如圣行中得初住竟。更修二十五三昧。乃至十地。此十一空。义解者不同。有人作互无解者。恐此非初地所观也。今之所释。谓此十一空。皆是趣道之近门。取极果之要途也。前九空。是九人。各自捉一空以入道。乃至九地。所以者何。明前九空。曾自不辨有深浅之异。至第十第十一。乃辨也。故知各自逐其先所修习所好乐便者。而入道也。今论若得初一空时。余者理然悉得。但逐其所习为有。是为前有四空。更相证成。其次二空。将后以证前。又一空将假来证实。余悉当位辨义也。如观内空时。若见悉空者。知内观成就。不尔。则不成也。观内空。谓直观己五阴为内。若见自五阴。亦见外怨亲中人悉空时。知内空成也。除常乐我之外。财物皆空。何故尔。果头诸法。非内五阴。亦非外五阴。是以除也。又一解。作内观时。佛等四法。财物等悉属外。非我正观故也。佛性非内非外者。正因性是避苦求乐之解。用寻此解。用无时不有。虽在五阴中。然五阴可断除。而此解不可失。终至成佛。是以录此始终之常用。无兴废之法为正因。故作内外观也。此内法中。是我正观故。所以料简也。常住不变者。非是湛然常。但此解未曾不有。故言常也。外空者。亦如是无有。内法者。有人直观外空。亦不见有。内五阴。异外法时。得知外观成也。此中亦尔。佛四法及与正因性。亦复料简也。内外空者。此人发家。内外双观法。不过内外。双观尽空。无所证成也。唯有如来。法僧佛性。不在内外二空者。还简出也。本观生死内外二法耳。三宝等。非生死法。故简也。智秀曰。此下答第二问列空名。并释观法。先列空名。空有十一者。是一方之化法也。寻空无十一。缘遣物病。逐法为别。有十一耳。次释观法。以外道人。计一大我遍一切处。与有分为一也。用初五空。以互无之理。明内外法。不得相有。以破物执。初观内法。即是己身。推寻此身。无外诸法。谓内为空。复除佛性者。缘佛性。虽系众生。然不定于内外。故随宜除之。观内法云无寿命者。无外众生命也。观有为空云无寿命者。即是当果住命也。观无为空云无我者。此捉有为五阴。法体无自在力。名为无我。盖非第一义空无我也。观无始空。破外道人。计八万劫始。是其所不知处。谓为冥谛。以之为常。今观此中。诸法流动无常。此是正破其执。故乐净等诸句相随。并观之耳。此中云寿命者故。是当果常命也。观性空。此破计万法。皆有性病。观无所有空。此破计有无为法。为得绳所系者之病也。寻万有不有。假计为空。自有众生。寻名妄执。闻说法空。谓有此空法。第十次观空。空破其此病云是有者。是所执空也。是无者。明此空是无也。既闻空于此空。复谓此观为是。次复破之云是。是者。出其所是也。非是者。明所是亦无也。第九第一义空。正观无生理。第十一大空。观此能观之智。体不可得。此二空并是无生理。其余九空。悉是随事破病。故说非无生理

善男子有为空者有为之法(至)是名菩萨观无为空

案。僧亮曰。生灭是有为。无生灭是无为也。今说有中无。无有之义。同内外也。僧宗曰。亦互无也。有为是缘成之法。所可言无。无于空也。言内外空等者。举此诸法空。明有为法。是假有无。此诸法也。宝亮曰。有为之法。亦不是三宝等。是无为法。若观有为法空。不见与无为相异者。乃知得有为观成也。举无为法。以证成耳。无为空者。有一人发初便观三无为观。观有余涅槃。作数缘无为。观无余涅槃。作非数缘灭无为。如此观。不见有为异于无为。有为亦空。乃是无为观成。故举有为。以证成也。亦简三宝等法。不同有为无为。若使神明。无此妙本。何故至无为空时。复简正因性耶

云何菩萨摩诃萨观无始空(至)是名菩萨观无始空

案。僧亮曰。外道谓有为无为。皆无始故。名无始空也。僧宗曰。遣真谛之计也。佛法之中。皆由无明诸行。造生死苦。岂有真谛为始邪。今以解心。照知无始。明其所计是空也

云何菩萨观于性空(至)是名菩萨摩诃萨观于性空

案。僧亮曰。法从缘得。以无性名空也。有为从缘得。无为从缘见。皆无性也。僧宗曰。此言诸法体性是空。岂假遣病耶。所以举常无常双来者。以无常是空。故所不论。今谈常乐。乃可于世谛是妙有。然此法既生于相待。待则为假。故相与空也。宝亮曰。无始空性空。俱是除计作名也。菩萨观万法。本来无始。乃至生死。及三宝佛性尽空。此将后以证前也。无性亦如是。岂有冥初世性耶

云何菩萨摩诃萨(至)菩萨摩诃萨观无所有空

案。僧亮曰。此空本就人说也。僧宗曰。此以智验空也。不取无子为譬。为取贫穷之人。言一切空为譬也。宝亮曰。此是习观观空。无所证成。直见一切万法体性皆空。即大品经中所明者也

云何菩萨摩诃萨(至)是名菩萨摩诃萨观第一义空

案。僧亮曰。现在无眼。是有为空也。僧宗曰。举假名实法二法为空也。眼等为空也。眼等为实作者。有业为假名。此二家无生。于有为是胜。故受第一义耳。空乃无假实。约假实以明空耳。宝亮曰。此实法空也。何以言之。无所从来。去无所至。故知实法空。所以举作者。用假名空。证实法空成也。若不见假实异。故知实法空成也

云何菩萨摩诃萨观于空空(至)是名菩萨观于空空

案。僧亮曰。是有是无。是名空空者。谓是有空亦空也。是无空亦空也。以后空空于前空。故立空空。以破执相者之所存也。是是非是。是名空空者。初二是双称上句也。次是双非。次是结句也。所以然者。欲遣后空。不得不本其所空。故双非。然后结句也。僧宗曰。九空是遣有。唯有此空。人情生着。谓有此空。是可得故。所以遣也。是有是无者。谓汝前九空所遣之有。能遣之无。亦无此无也。为遣有故说无。岂有无之可待耶。是则有无斯空。故言空空也。是是非是。是名空空者。物情于遣着之中。展转生患。言向以空遣有。此是相对得称。故宜不可得也。今谓二着俱舍。此心为胜。欲保此舍心。复为患矣。是是者。指环中之旨也。若谓以此为极。亦无此也。是则心之与理。俱不可得。谓空空也。宝亮曰。此是法云地之所得也。空空有二种。如昔小乘观于万有是空。爱着此空。故言此空即是空。亦名作空空也。复有一种观万有是一空。此观空之智。复即体是空。此亦是空空也。今言空者。悉不同上二种空空。何者。从九地以还。至信首五根。非不相貌。信知八自在我空。但九地以来。尽作无我观。乘此无我空观。来至十地。少分见八自在我空。以乘空得空。故言空空。亦即空三昧也。乃是二乘所迷没处者。赞叹此空理妙。非己心所缘也。是有是无者。为二法名也。是有者。谓九地以来。所得无我空。此无我空。由断灭空。又此既是事像之法。故还作有名说也。是无者。是八自在我空也。得此空时。有无之心。皆不行也。若作有取亦不得。作无取亦不得。有无二心既得行。便是中道解。故言是无也。为二法名竟。后结言。是名空空也。是是者。解会此旨。谓平定之意也。还是前九也。所得无我。事像之空也。事像是有法。故言是是也。非是者。还非九地人。谓九地以来。所得空解为极。今则非极。若乘无我空。得八自在我空。得言非是向者九地所得空。故言非是也。故文言。十住尚于是中通达少分。况九地以还得耶。不作此解。则不会经文意也

善男子云何菩萨摩诃萨(至)则得住于虚空等地

案。僧亮曰。与一切有皆空。故名般若。亦空一切相尽。故名大空也。僧宗曰。谓智体亦空也。下二譬。悉美平等之解也。宝亮曰。十地满足。金刚是也。金刚心照万法尽。名学地。一切种智。具佛五眼。称般若波罗蜜智慧满足也

大般涅槃经集解卷第三十八大般涅槃经集解卷第三十九

  广释八种知见觉　广释四无碍　广辨无所得义　广辨神通应化无拘执义　广释反常说法谓真谛说为世谛义等　广明内道外道异相

    梵行品之第四

善男子我今于是大众之中(至)复得名为虚空等地

案。僧亮曰。不为有所系缚。空所迷闷。解脱空有。以释地名也。下以二譬。释功能也。一以不生贪嗔。二多容众生。宝亮曰。第七段广明十一空功用大也。既得金刚心。见一切万法尽。便于缘中。任运无复有滞碍拘执。即是第一叹。后从本有今无偈已去。讫六念处来广之也。第二叹言。如虚空于可爱色。不生贪乐。于不可爱色。亦不生嗔。明住金刚心时。不见可爱之异相。但一相无相下。十无尽来广也。第三叹言。如虚空广大无对。悉能容受一切物。譬得金刚心。如虚空。具一切知见。无所不周。下用八种知见。广此义也。僧宗曰。备上空有双照。故得四辨之利。以化物也。就此有六重释。第一总明一切法有无碍。第二遍就三乘行上。明法无碍。第三明得四无碍不取着也。第四辨能持。第五推因。第六夺二乘所得。以显菩萨备也。智秀曰。此下第三科列闻法得利者也。上明行舍得智。知于无法。此次明非直知无。亦能有无通照也

善男子菩萨摩诃萨(至)如是等法一切知见

案。僧亮曰。次说八种知见出所容事。此第一若行若缘等。总一切法也。在内名性。形外名相。强者名因。弱者名缘也。宝亮曰。此下广明第三譬。八种知见明自行。下四无碍。明外化。第一总因果中知见。若行者。生灭起动之行也。若缘者从缘者从缘而有。傍助为义也。性者内也。相者外也。力强者为因。疏远者为缘也。知众生善恶刹那起动之心也。若根者。利钝根也。若禅定者。知众生得定深浅也。若乘者。大小乘也。若善知识者。善知外缘也。若持戒者。达止恶也。若所施者。善知忘相也。如是一切知见者。总结因果中知见也。第二知外道所行法。不见其得善果也。第三见外道所行法。得三涂果。知改恶向善。得清净解脱果也。第四见常无常也。第五知见逆流沿流。第六知见转障。第七知见佛性。第八知见二谛

复次善男子菩萨摩诃萨(至)得正解脱是名不见

案。僧亮曰。第二事浅名知。与第八同知。耶因不得正果。从初至牛粪之上。明四威仪苦也。衣粗麻衣。至糠汁沸汤。明衣食受苦也。自下明行业苦也。宝亮曰。第二知外道所行法。不见其得善果也

复次善男子菩萨摩诃萨(至)入正解脱是名为知

案。僧亮曰。第二见耶见因必得苦果。知出苦必得解脱。何者。是人虽行邪道。厌苦情至。此厌心出苦。必求正解脱。耶果易知。名见解脱。事远名知也。宝亮曰。第三见外道所行法。得三涂果。知改恶向善。得清净解脱果也

复次善男子菩萨摩诃萨(至)悉有佛性是名为知

案。僧亮曰。第四常无常等合观。初总易知。名见。后别难见。名知也。宝亮曰。第四见常无常

复次善男子菩萨摩诃萨(至)从明入明是名为见

案。僧亮曰。第五知逆随诸流。逆难了故名知。随易了故名见。从信至是。名为知。逆流中言凡夫者。内凡夫断外名逆。未断内名随也。下从明入明人。为明三涂为闇。是外凡夫皆是随耳。宝亮曰。第五知见逆流沿流也

复次善男子菩萨摩诃萨至地狱受报是名为见

案。僧亮曰。第六知转重为轻。转轻为重也。若转重为轻者。向解脱故为知。转轻为重。向生死故。为见也。宝亮曰。第六知见转障也

复有知而不见(至)犹如闇夜所见不了

案。僧亮曰。第七知佛性。因论知见及以如来。非其例也。宝亮曰。第七知见佛性

复有亦见亦知所谓诸佛(至)即是如来五眼所知

案。僧亮曰。第八知二谛也。所以复说真俗者。初说地相。不见诸法。后说地能。无法不知。恐闻者致生有无之惑。说真俗以会之也。真谛无相故。不见不知。非谓事隐不见。与亦见义异。知所惠施。上云。真谛无相不见。似如俗谛。决定有相可见。更说俗谛。知受者三事。假为说名不见。无定相可见。上所言见。皆说知为见也。宝亮曰。第八知见二谛者也

迦叶菩萨白佛言世尊(至)能如是知得何等利

案。僧亮曰。四等以外益为义。今说舍果空平等地。八种知见。于四等中。有何利耶

佛言善男子菩萨摩诃萨(至)辞无碍乐说无碍

案。僧亮曰。慈以外益为利。四无碍者。慈之利也。宝亮曰。次明外化行也。凡有五翻解释。亦即是八种知见。但以自行外化为异也。此先列四无碍名也

法无碍者知一切法(至)即得如是四无碍智

案。僧亮曰。总知名实。名法无碍。随名解义。名义无碍。说名说义。谓辞无碍。说不可尽。谓乐说无碍也。宝亮曰。第一翻法者。识法区分也。义者。言之所以也。辞者。巧便宣通也。乐说者。以无懈心。为众生说也。随字论者。圣人为法立名字。欲使众生识善恶区分。改恶修善也。正音论者。随方俗类得解脱。无不正也。阐陀论者。大集论也。世辩论者。世谛中最利辨也

复次善男子法无碍者(至)种种异说不可穷尽

案。僧亮曰。菩萨知法。本为度人。人不出三乘。以知三乘法为法无碍也。知三终归一。为义无碍。一戒定慧。作多名说。为辞无碍。乐说义与亦同也。宝亮曰。第二翻说三乘法。为法无碍。知理归一。为义无碍。于一法上。作种种名说。为辞无碍。说法无倦。为乐说无碍也

复次善男子法无碍者(至)若取著者不名菩萨

案。僧亮曰。上虽再说。未明无著。今说无著。以成无碍之义。宝亮曰。第三翻以忘相为宗也

迦叶菩萨复白佛言(至)说言知法而不取着

案。僧亮曰。义旨未显。应须系发也。夫不取异相。则不知异。不知异相。不知法也

佛言善男子夫取著者(至)一切凡夫无四无碍

案。僧亮曰。无碍之称。出生死为名。取着之名。不出生死。下出事证也。此先证取着。非无碍也。宝亮曰。迦叶难意。既云得四无碍。云何取着耶。佛今答云。取着之心。本是惑累。则不名无碍。后心菩萨。执相永尽。故名无著也

善男子菩萨摩诃萨(至)菩萨摩诃萨而无所著

案。僧亮曰。证不取着。得四无碍

复次善男子法无碍者(至)而不可尽是名乐说无碍

案。僧亮曰。第四重释法义四事之异耳。宣说一义。必无有义者。如地持山。菩萨所说。无地无山。亦无所持。诸佛境界者。知无地无山无为相也。凡夫境界者。著名求相也。宝亮曰。第四翻得此六法。能持不忘。以不忘为释也

善男子菩萨摩诃萨(至)说世论故得乐说无碍

案。僧亮曰。第五以世谛为法。以第一义为义也。宝亮曰。第五翻以世谛为法无碍。以第一义谛为义无碍者。为小乘人。故作此说也。若依十地经者。第一义谛为法无碍。世谛为义无碍。此为大乘人说故也。空是一类法易知。故名法无碍。世谛虚构区别难知。名义无碍也

善男子声闻缘觉若有得是(至)声闻缘觉真实无有

案。僧亮曰。二乘无因。故无无碍也。宝亮曰。向明得。今明失也

何以故菩萨摩诃萨(至)何故默然而无所说

案。僧亮曰。夫度人出苦。必由说法。若但以神通。证无无四证也

缘觉不能说法度人(至)一切无有四无碍智

案。僧亮曰。别证所以无也

云何声闻无四无碍(至)无此三故无四无碍

案。僧亮曰。声闻从佛闻法。能说法度人。亦知常住佛性。无善方便。于四事中。非无碍耳

复次声闻缘觉不能毕竟(至)是故二乘无四无碍

案。僧亮曰。向别今总。不知众生根世谛疑。不知善说第一义空。故无四无碍也

迦叶菩萨白佛言世尊(至)若具足四无有是处

案。僧亮曰。声闻如四河。菩萨如阿耨达池。佛之如大海也。或有得一者。比凡夫言得四。不必一人具四

迦叶菩萨白佛言世尊(至)说言菩萨而有所得

案。僧亮曰。住虚空无得之地。得八种知见。具四无碍。众生起着。佛将欲遣。故发问也。宝亮曰。上已六重释四辨。人情生着。今拂其封累。以十无以遣之也。僧宗曰。此下辩十无。广上第二譬。明菩萨心不存于有无也。智秀曰。此下讫六念。妄执情迷。易随缘转。既闻说无。复谓终无所得。次以此文。显有所得。汲引信情。文有六别。第一请释本有今无偈。第二明佛能为反常之说。第三正明有所得义。第四明见了了相。第五说偈叹佛及经教。第六请释世间出世间同异也

佛言善男子善哉善哉(至)是故菩萨名无所得

案。僧亮曰。明四无碍。以假得为名。实则无得言虽有异。而义不违地目也。僧宗曰。第一存有得为四倒。无所得为无碍也。宝亮曰。凡有十双相对。此第一有倒无倒为对也

复次善男子无所得者(至)是故菩萨名无所得

案。僧宗曰。第二明闇相对。宝亮曰。慧与无明相对也

复次善男子无所得者(至)是故菩萨名无所得

案。僧宗曰。第三以因果相对。宝亮曰。以生死与涅槃相对

复次善男子无所得者(至)是故菩萨名无所得

案。僧宗曰。第四以因中行相对。宝亮曰。以菩萨乘与二乘相对

复次善男子无所得者(至)是故菩萨名无所得

案。僧宗曰。第五以教相对。宝亮曰。方等小乘对也

复次善男子无所有者(至)是故菩萨名无所得

案。僧宗曰。第六定乱相对。宝亮曰。空三昧与生死轮

复次善男子无所得者(至)是故菩萨名无所得

案。僧宗曰。第七以常无常理相对。宝亮曰。同此释

复次善男子无所得者(至)是故菩萨名无所得

案。僧宗曰。第八以解惑相对。宝亮曰。以第一义与五见相对也

复次善男子无所得者(至)是故菩萨名无所得

案。僧宗曰。第九以因果人相对。宝亮曰。佛与大乘相对也

善男子汝之所问亦无所得(至)是魔眷属非我弟子

案。僧宗曰。第十遣问遣答相对。宝亮曰。同也

迦叶菩萨白佛言世尊(至)离魔眷属为佛弟子

案。僧亮曰。广明无得之义也。所以示者。空是万行之主故也

迦叶菩萨白佛言世尊(至)世尊是义云何

案。僧宗曰。此下第五段也。向十无遣执。其封心稍弭。今欲更引证也。宝亮曰。此下竟六念处。广上第一譬也。物情所执。本以相惑居心。故处处滞碍。则不能得无方致化。今明十地菩萨。金刚心满。烦恼永尽。故能无方隐显。百变自在。故言无所拘执也。迦叶今难意言。若佛果得无拘执。何故上说本有今无之偈。独为纯陀。不普为大众。得知如来未免拘执也

佛言善男子我为化度(至)文殊师利即得解了

案。僧亮曰。佛答意谓。尽说法也。此下先广明本有今无义。后别答问

迦叶菩萨言世尊如文殊等(至)是无常者无有是处

案。僧亮曰。明佛为计着众生说地名无得耳。无计著者。则说地名有得也。文殊解了者。上文殊将问差别无差别义。闻此偈即了也

善男子如来普为诸众生故(至)虽见诸法说言不见

案。僧亮曰。此下正答问也。如毗尼中说。随俗故问也。僧宗曰。此第六段也。自初说十一空。人情闻无。心无所寄。故述八种知见及四无碍之利。既闻有说。更复舍无封有。为遣此滞。还说十无。复洗执情。时众闻空有互说。莫知所厝。如来呵止其心。当寻求教下之意。如来所说。莫非利益反常之说。尚当时为益。岂况空有二说。而更生封执耶。说有为。善知世谛。说无为。明诸法斯空。是则有不乖无。无不背有。岂得乖有无之言。而增其执耶。虽知诸法。说言不知者。假就外道学也。见亦如此也。宝亮曰。此下别答。无拘执相。既言知。复言不知。此是反常之说。明如来住空平等地。能种种说法。自在随意。若尔。汝云何难言。佛有拘执耶。虽知诸法。说言不知者。虽知常住。而唱言无常也。虽见说不见者。佛明见真常。而说言不见也

有相之法说言无相无相之法说言有相

案。僧宗曰。有相之法说无相者。实自不灭。言断灭也。无相之法说有相者。佛实绝相。言菩萨王宫生也。宝亮曰。三十三天。实是生死。而说云。是常我乐净。是谓有相说无相也。无相说有相者。谓说涅槃。是苦无常也

实有无常说言有常(至)我乐净等亦复如是

案。僧亮曰。如阿罗汉未来有生死之相。而说无也。实无究竟之相。说言有也。僧宗曰。实有无常者。谓三十三天说之为常也。实有常者。说偏教滥佛地

三乘之法说言一乘一乘之法随宜说三

案。僧宗曰。三说一者。破异三之惑。说同归之教也。一说三者。昔日方便随宜之教也

略相说广广相说略

案。僧宗曰。如一因缘。广则十二。略则唯因果而已也

四重之法说偷兰遮偷兰遮法说为四重

案。僧宗曰。事现于律也。如僧戒为轻。而尼戒为专

犯说非犯非犯说犯(至)如来明见众生根故

案。僧宗曰。如僧独行非犯。尼则为犯等也

善男子如来虽作如是等说(至)随宜方便则为说之

案。僧亮曰。因虚妄说得法利者。语心则无虚妄。若虚妄而有益。必亦说之。重释上事耶

善男子一切世谛若于如来即是第一义谛

案。僧亮曰。二谛之名。出自佛说。不由凡夫也。假有名为世谛。无有是第一义也。说假有。欲表非有。故于佛是第一义也。僧宗曰。二谛之名。出于佛口。不出凡夫。说于假有。欲表非有。而于如来。常是第一义也。宝亮曰。世谛虽复森罗。于颠倒者。常有也。于无惑者常空。未尝有也。若以佛而取。恒是一谛。然至佛之时。乃知众生是梦。于如来终日不有也。有无可有。无无可无。寂然无相。故于佛尽是第一义也。智秀曰。昔说涅槃。都无身智。言未了义。即是虚故。名为世谛。此之世谛。其实非无法。为佛所鉴。即为第一义也

何以故诸佛世尊为第一义(至)诸佛终不宣说世谛

案。僧亮曰。释上义也。众生著有。佛明非有。说假有以汲之。为令众生知假有非有。若不知非有。佛亦不说假有。何者。虽复假实不同。为患是一。何须说也。僧宗曰。向反常说。令回其解云。如来随方释化。为益不同也。宝亮曰。凡夫要约世谛故。乃识万法无也。故云为令众生。得第一义。故说世谛也

善男子如来有时演说世谛(至)非是声闻缘觉所知

案。僧亮曰。说佛无常。凡夫谓实。是第一也。说第一义。众生谓。佛说于世谛者。佛说常乐。是第一义。凡夫便谓假。是世谛也。宝亮曰。近而取之。假名实法空。皆是世谛。远而取之。九地以来。所得无我空者。亦是世谛。唯有涅槃。体常寂灭。为真谛耳。而物情所谓九住以还得空。负第一义。论理悉是世谛也

善男子是故汝上不应难言(至)云何难言无所得耶

案。僧亮曰。明佛意难会也。闻为计者。众生说无得。是平等地。便谓一切无得。还结上也。僧宗曰。此下第七段。向闻反常。双遣物情迷闷。心无所厝。还说有得。以收其意也。常得涅槃。即第一义也。宝亮曰。佛说无方。岂汝境界耶。智秀曰。第二正答难也。有得之义。即是菩提涅槃

迦叶复言世尊第一义谛(至)亦名菩提亦名涅槃

案。僧亮曰。第一义谛。真实之称也。真法有三种。十一空通智为道也。智即菩提也。结尽无为。名涅槃也。此二皆第一。僧宗曰。第一义理。理应是常。常则无可得。若于事有得。则是无常。欲使如来释所以为常。非始有也

若有菩萨言有得道(至)犹如佛性无得无生

案。僧亮曰。此通难三法也

世尊夫道者非色非不色(至)菩提涅槃亦复如是

案。僧亮曰。偏难于空。明无相可得也。宝亮曰。涅槃是众德上总名也。此三德唯一体。若是可得。应是无常。何故常法无得有。故非常也

佛言如是如是善男子(至)以是义故不可捉持

案。僧亮曰。以苦行等为道。是则无常。以空为道。是则常也。菩萨少见佛性。得名为常。外道伏结。以还生故。故名无常。僧宗曰。先释常必在佛。以有烦恼[雨/復]。故不能得见。得见之日。非始有也。宝亮曰。道若无常。云何能令行人断惑成圣耶

善男子道者虽无色像可见称量可知而实有用

案。僧宗曰。不可令非色而无其体。体居万惑之表。行满则用也

善男子如众生心虽非是色(至)一切菩萨了了见知

案。僧亮曰。见空断惑。有空之用也。了了知见者。以二事证有也。一谓断结。二谓可了了见也。僧宗曰。借众生心。以为况也

善男子见有二种(至)虽如是见初无见相

案。僧亮曰。复以见为证。世间思慧不了。修慧则了也。僧宗曰。此下第八段证有道也。有五翻。此即第一明有见者。故知必有也。宝亮曰。相貌见者。谓九地以还信见也。眼见者。十住了了见也。又释十住见不了。故曰相貌见。佛见满足故称之眼见也

善男子以是因缘我于往昔(至)名为凡夫菩萨亦尔

案。僧亮曰。以见有了不了因缘故。故知有也。引昔所说。见有见相。是世间也。见无见相。是佛菩萨也。僧宗曰。第二翻引昔。已为舍利弗说。故证知有也。宝亮曰。世间不知见者。外道也。所知者。佛与十住。亦知。外道所不知者。佛与十住亦知也。然世间所不知者。谓佛性也。外道不知而起断常之见。菩萨虽知。不言有所知相。是故无拘执也

大般涅槃经集解卷第三十九大般涅槃经集解卷第四十

  辨世间所不知见觉菩萨知见觉　广辩菩萨修戒相　广诫弘通法者之轨则广释六念第一辨十号释婆伽婆等

    梵行品之第五

迦叶菩萨言如佛世尊(至)不名世间不名非世间

案。僧亮曰。不名世间者。不名佛法中在家人也。不名非世间者。不名信根以上人也

尔时迦叶闻是事已(至)众生闻秘藏即得不生灭

案。僧亮曰。说地能已。说梵行粗竟。此叹佛也。初偈明佛善说正道。称为医王。次偈释医王义。备治所治。毕竟不发也。次偈与法设譬。后偈说法体。智秀曰。将欲咨前义旨故。第五先以偈叹佛及经教

迦叶菩萨说是偈已(至)若非世间有何异相

案。僧亮曰。此下说经之能也。依经修行。速得出世。如圣行品末功德藏王所说也。宝亮曰。此下广料简知见觉人也。故迦叶因难。以启发耳。智秀曰。此讫六念。第六段辨菩萨世出世异。有三意。第一约戒定慧。第二约法师仪轨。第三约六念法。明其同异

佛言善男子言菩萨者(至)亦同世间不知见觉

案。僧亮曰。大判菩萨有二种。有世间者。有出世间者。若当持戒清净。心固不动。终得发定生慧。知九十六种道所计者非。知佛法所明理者是也。是信用修行。断二边尽。属知见人也。问此是何处人。是信首五根以上。此人永与生死为隔。无复入三涂之忧。名作出世间菩萨也。若信心不立。持戒不净。虽复见涅槃经信心受持。不识九十六种所计者非。佛法所明者是。此名作四念处。前人是世间菩萨。还结属不知见觉人数也。此下去凡有三重文来料简。初就信慧心中。成就不成就来。简向所解者。即为第一重也。第二就弘法人中料简。若是恶世中持清净。不生诽谤。识知九十六种道所计者非。验佛法所计者。此是出世间菩萨。落知见觉人位也。若当虽复恶世弘通此经。持戒不清净。又生物诽谤。复不识知内外是非。此名世间菩萨。属不知见觉人流也。第三就六念来简。若依涅槃经。作六念处成就。知内外是非者。名出世间菩萨。是知见觉人。若使作六念不成就。由依昔教学。复不识知内外。是非名作世间菩萨。不知见觉者也

菩萨闻是涅槃经已(至)是名菩萨修持净戒

案。僧亮曰。知有佛性。能得常果。而发心者。虽迳生死。不失此念。经之能也。僧宗曰。第三翻明道虽不无。要须戒定慧

戒既清净次修禅定(至)是名菩萨修清净定

案。僧亮曰。闻思慧得非修慧也。明能修二慧。是净定也

戒定已备次修净慧(至)所知见觉非世间也

案。僧亮曰。身中有我。则身大我小。我中有身。则身小我大。是身是我。虽小大皆是。非身非我。两无也。慧能断结。先断于常。牢固不动者。诸见是犯戒之本。见尽戒不动也

善男子菩萨见所持戒(至)而是菩萨所知见觉

案。僧亮曰。上说不悔。由戒而生。未释相生之义。此释相生者也

迦叶复言云何菩萨(至)以净戒故心得欢喜

案。僧亮曰。不因涅槃经持戒。是世间戒。则具四恶。不见佛性出世也

善男子如端正人自见面貌(至)破戒之人亦复如是

案。僧亮曰。面譬净戒。镜譬毗尼。此虽无镜。余经有也

善男子譬如牧牛有二女人(至)以是因缘心则悦乐

案。僧亮曰。上譬一生中有喜有不喜。此譬命终时也。牛譬经教。牧女譬行者。瓶譬人身。酪譬破戒。酹譬持戒。城譬涅槃经。脚跌譬无常。瓶破譬命终。苏已出外。浆不足惜。譬持戒人身利己出。余不足顾。喻欢喜也。苏在酪中与瓶俱失。譬破戒人身利未出。与身俱丧。喻可愁恼也

迦叶复言喜之与乐(至)而是菩萨所知见觉

案。僧亮曰。五法佐助。重释净戒。所以为涅槃因。由得慧等佐助。离五盖故。王五种涅槃。释所以具信等五法。推功于慧。能离盖及见疑。故具五根者。得五解脱也

善男子若我弟子受持读诵(至)不以毁戒受持修集

案。僧亮曰。说五种持经。以明出世。何者。余经所说。未究竟故。不备持之行恶。令人谤经。持经起恶。虽能自利。不能利人。非出世菩萨。是以佛但令出世持经。应究行之义

善男子若我弟子受持读诵(至)非我弟子是魔眷属

案。僧亮曰。无有实功。是名掉戏。若转诸有。名轻动也

复次善男子若我弟子(至)非我弟子是魔眷属

案。僧亮曰。悟时未至。名非时也。处不应闻。名非国也。不如上诫。是灭佛法。说佛法灭。世法炽燃

善男子若欲受持者(至)而是菩萨所知见觉

案。僧亮曰。此经所说。理无不备。说此经时。应具诸说

复次善男子云何复名(至)念僧念戒念施念天

案。僧亮曰。上说出家菩萨六念。则通在家。除生死畏。修六念人。不畏海难。贪宝重货。菩萨不畏生死苦难。贪三宝功德也。畏死者。惧三涂。念戒施天。却死畏也。是始行所修。非出世功德也。若依此经修之。即出世知见。美经之能也。僧宗曰。第五明六念者。向明戒定慧。今举境以显慧之功也。宝亮曰。若作六念成。名出世间菩萨。是知见觉人。若不如是。不名世间知见觉人也

善男子云何念佛(至)说中道故名大法师

案。僧亮曰。此经辩十号有正有杂有略有广。从如来至大法师。此初广。后十号略也。亦可前正后杂也。宝亮曰。念佛中有三翻。第一总举佛果一切功德。第二历十号。第三举成佛之因。佛昔修六度众德。今得常住。万境皆照也。下五念皆真应双明。但文中可见。不假有释也

云何名如来如过去诸佛(至)是故号佛为如来也

案。僧亮曰。如者如佛也。来者。乘因至果也。此果中说如来也。从六波罗蜜者。因中说如来也

云何为应世间之法(至)而供养之故名为应

案。僧亮曰。恶应除善应。集具二德。故应供养也

云何正遍知正者名不颠倒(至)声闻缘觉无有遍知

案。僧亮曰。以知因为正。知果为遍也

云何明行足明者名得无量(至)以是义故名明行足

案。僧亮曰。空行虽非照解。而非垢闇也

云何善逝善者名高(至)成大涅槃故名善逝

案。僧亮曰。涅槃之性。实非有者。生住灭是有为相。涅槃无此。故非有也

云何世间解世间者(至)见世间故故名世间解

案。僧亮曰。因世间言说为有者。非有说有。以明非有

云何无上士上士者(至)是故号佛为无上士

案。僧亮曰。有恶未尽。智与心诤。智胜心故为上也。语可坏者。有诤则可坏

云何调御丈夫自既丈夫(至)是故号佛调御丈夫

案。僧亮曰。应以男形成佛。名丈夫也。释上句。具足法者。释下句也。后调御丈夫。凡四种应深说深。应浅说浅。明善调也

云何天人师师有二种(至)是故号佛为天人师

案。僧亮曰。师有二种者。释上无上师也。亦次解人天二义。明能受道也

云何为佛佛者名觉(至)常得不离见佛世尊

案。僧亮曰。一周明十号也

善男子何故名为如来(至)八十种好金刚之身

案。僧亮曰。重举果称。以说因者。欲令欣果。而行因也。再说因者。前略后广也

又复菩萨于昔无量(至)是名菩萨摩诃萨念佛

案。僧亮曰。生住是有为。自在是无为。修五十心。成此果心也

大般涅槃经集解卷第四十大般涅槃经集解卷第四十一

  释念法无相　念僧为福田　念戒为桥梁　念施为菩提因　念天是第一义天　辨三品入胎差别　解迦叶佛法七日灭义　明涅槃经流通则佛法不灭　明恶世声闻取相失理佛法则灭　出不得食十种肉之数及卖刀酒洛沙等事

    梵行品之第六

云何菩萨摩诃萨念法(至)是名菩萨念法

案。僧亮曰。以涅槃经为法。朝修夕得利。夕修朝得利。故言无时而有现果。法眼所见至无为无数。说十一空。是法无舍宅至毕竟微妙。释空以名法能涅槃也。非色断色者。说真也。而亦是色者。说应也。非因者。非作因也。是因者。智为解脱作了因也

云何念僧诸佛圣僧(至)常不变易是名念僧

案。僧亮曰。诸佛圣僧。至修行正直法。释如法住也。佛师于法。法常故如来常。僧有三义。此释和合及弟子僧义。不可观见至不可思议。义常僧也。一切众生。良祐福田。释福田僧义也

云何念戒菩萨思惟(至)是名菩萨摩诃萨念戒

案。僧亮曰。有戒不破。至诸佛赞叹。说净戒体也。是大方等至妙宝胜幢。美戒也。能生万行譬地。度生死河譬船。庄严众生譬璎珞。能持僧众譬如大姓。洗除烦恼譬灰汁。障诸恶风雨譬舍宅。断诸结缚譬刀剑。无乐不备譬宝珠。所向自在譬脚足。见涅槃路譬眼目。能生众善譬父母。彰烦恼热譬荫凉。升涅槃山譬梯橙。摧诸魔贼譬幢也

云何念施菩萨摩诃萨(至)广说如杂华中

案。僧亮曰。初讫之所赞叹。说成就外功德也。从施众生食则施命。说内功德也

云何念天有四天王处(至)而是菩萨所知见觉

案。僧亮曰。遣三涂之畏也。信戒施闻慧。三界天因。我今具之。无地狱等苦。世天无常。回此功德。以求义天。永离生死。何有生死之畏

善男子若我弟子(至)甚奇甚特不可思议

案。僧亮曰。已说修经者德。今结经不可思议也。僧宗曰。自梵行以来。明四无量慈悲喜舍。而明舍自有八段。文句相生。其义已毕。故今叹经也。有三翻。第一明受持书写功德。则大不比余经。第二寄人以叹经也。言所以得八不思议者。由经力故也。第三寄兴灭叹经。言此经在世则法兴。此经若没则沦翳。既兴灭必由此典。当知众经之胜也。宝亮曰。此以下。是梵行中第三文。叹经流通。就此叹经中。有三翻。第一将法华以前校量。今涅槃具足明六行故胜。然昔经但明三行。是故不如也。第二从复言菩萨不可思议以下。就益人以致叹。此人不从人闻法。恶世中但见此经。能自依六行。而修因取益。犹经力大故尔也。第三从上佛法几时而灭以下。尽就兴废以为叹也。何故尔。自法华以前经。应众生根性。渐进其行。为伏四倒。根机亦熟。便废此教。然大涅槃。是究竟无余之唱。三世诸佛。共宣此理。故无兴废也。智秀曰。此下品中。第四段叹经也。夫行不孤立。立必藉经。故辨行体竟。次叹经也。有三翻。第一约受持。第二约成就不思议。第三约法兴灭。此即第一寄受持之胜负。辨经力之优降也

迦叶菩萨白佛言世尊(至)大般涅槃亦不可思议

案。僧亮曰。将欲致问。先受解也。僧宗曰。此下第二翻。寄人以为叹也。以经力故。得八不思议也

世尊以何义故复言菩萨(至)三藐三菩提因

案。宝亮曰。第一明菩萨得此经。无师自悟。能依六行理。而修因取佛也

善男子如是菩萨未见阿耨(至)是故菩萨不可思议

案。僧亮曰。闻经发心。无有人数。未见菩提之利。而能不惜身命。第一事也

又复不可思议菩萨(至)是故复名不可思议

案。僧亮曰。有两譬。显安苦无厌。第二事也。宝亮曰。菩萨见此经。自能修行。为众生受苦。乃至三涂不厌也

善男子无量众生发菩提心(至)是故复名不可思议

案。僧亮曰。上二菩萨。未阶初地。而心坚固。由经力致尔。重结上二事也。宝亮曰。第四三事。明众生发心虽多。而成就者少。此人见经。而能毕竟不退也

善男子若有唱言我能浮度(至)是故复名不可思议

案。僧亮曰。为发心作譬也。力小而现事大。果其心也。第三事也。宝亮曰。第四事。世人能度生死海。此人能度。取佛果故也

善男子菩萨摩诃萨(至)是故复名不可思议

案。僧亮曰。虽颠倒说。而不染生死。第四事也。案。宝亮曰。第五事。此人为众生说常等。而非虚妄也

善男子人有三品谓上中下(至)是故复名不可思议

案。僧亮曰。凡夫受生颠倒。下者起颠。上者生贪。而六念菩萨。同是凡夫受生。不起贪颠。第五事也。宝亮曰。第六事。此人得经力。能修定学慧。自知入胎出胎等事也

善男子阿耨多罗三藐(至)是故复名不可思议

案。僧亮曰。菩提果。心是因。因果皆不可以事比说。涅槃经说之。菩萨更不师人能灭。菩提能为人说。第六事也。宝亮曰。第七事。佛果真如。有而无。相非人比。类不可取。此因中得此经。故安心修行。复能令他安心。同起极果也

善男子菩萨摩诃萨(至)不可思议口亦如是

案。僧亮曰。离即十善戒也。菩萨无我无我所。而修净戒。轻重不犯。第七事也

善男子从身离身从口离口(至)是故复名不可思议

案。僧亮曰。欲说菩萨善解假名。先说实法无断结。从身作远离。身无作也。余类尔也。慧是实。言实有实法无断结。不能令菩萨。远离异生异灭也。终不生念至非虚妄。善解法假故。言不虚妄。第八事也。宝亮曰。第八事明菩萨远离十恶。而不在离相。不见一法。是身是业及离主者。以空理而求。则不见三业以缘假而求。亦是有也。实有此慧。不能令菩萨远离者。言菩萨不存实慧。虚心会理。故能知从身离身。乃至从慧远离。非身非口。三业既空。十恶斯遣也。无有一法者。上句明缘成假空。此明相续假空。言无一法者。就实法道。常分自灭。前不至后。故无慧远离。旧此下第八翻。明此人由经力故。识假名实法。知因缘虚有。能息三业。不为非法。亦不思议也。止身三恶。故言从身离身。止口四过。故言从口离口。要得慧故。能翻三毒。故言从慧远离非身非口也。实有此慧。然不能离者。明实法之中。无别力用。前生后灭。初不相及慧生之时。无惑可断。惑在之时。复无有慧。要是相续道中。向有而今无。方得辨用也

迦叶菩萨白佛言世尊(至)住当久近几时而灭

案。僧亮曰。欲闻经故。先受解也。当久近住者。问一切佛法也。宝亮曰。此下第三就兴废为叹也。故先审后开问也。智秀曰。就此第三叹中有七翻。论兴废也

善男子若大涅槃经(至)当知尔时佛法未灭

案。僧亮曰。说佛常住一句偈。是此经五行文备称之。是众经之本。人能奉本。则枝条必茂。佛法未灭

善男子若大涅槃经(至)当知佛法将灭不久

案。僧亮曰。经虽流布。而不能信敬。则为将灭不久也。宝亮曰。若行此经者。则其道不废。若弃而从恶。则将灭不久也。智秀曰。第一翻明此经在故。则佛法不灭。故知。理摄众典矣

迦叶菩萨复白佛言世尊(至)是诸如来秘密之藏

案。僧亮曰。理及名句为经。有三种。一谓名字经。二谓章句经。三谓纸墨经。彼时人皆强记。不须纸墨。放纸墨经灭也。有是经不者。若有是经。人应恭敬。经法不应灭。名其无者。则非共有。不应说言此经典者是诸佛秘藏也。僧宗曰。就言语中。非不相负。故致问也。假为二开。意在愿闻不灭之理。乃所以为叹经也。若常教恒在。则不应言灭。以其灭尽。则不应常也。宝亮曰。先作一审。即结两开难也。若迦叶佛法。有此常经。则不得言七日便灭。若其无者。则不得言诸佛秘藏也。智秀曰。第二翻将显兴废之相。先作两开难也

佛言善男子我上说言(至)当知尔时佛法不灭

案。僧亮曰。涅槃经兴二种法。皆不灭也。僧宗曰。以九重法相对。明常法不灭。无常不灭也。宝亮曰。第一事。举世法以音声章句有灭。第一义非世间可毁。故不灭也。智秀曰。第三翻将欲答。先列诸法。略明兴废。在文不在于理

善男子汝向所问迦叶如来(至)所不说故故名为藏

案。僧亮曰。一切诸佛。皆具净秽二土。佛在恶土。开三乘教。先浅后深。渐除诸恶。故名藏也。僧宗曰。迦叶佛时。有此经不者。上已定理。今答其问。言迦叶佛时。岂得无邪。所以法教不传者。于时人根易悟。烦恼减少。不假言教。自能深思幽旨。不可以人不传。故使常理亦丧也。今世众生。多烦恼故。须说此经也。若有众生。我计无我者。出其人。政有如此人。其惑厚重。故须常教以训物心耳。宝亮曰。岂问有无。但十一部不明。故为灭

如人七宝不出外用(至)迦叶佛时有是经不

案。僧亮曰。经为灭重恶故出。若恶不息。经则名隐。经隐故。一切法灭也。宝亮曰。释所以不明者。如外问藏积七宝。要具四种因缘。方出用耳。一为谷贵。二拟贼来赏赉。三为值恶王赎命。四拟财物难得时出用。明佛意亦然。如说四时教。后众生断常见病发。便为说涅槃经。令物情得法味以自充。如为谷贵而须食也。既起烦恼。于行道事发。便为说常教。如贼来运财而赐赏。众生智慧命不续。如值恶王赎命。既起结业。招生死八苦。今说于极理。令解心得发是于生死也。是以众生。起种种病时。如来欲为灭此之恶故。以说此理而导物也。既显秘藏之义如此。便呵迦叶向难。然后正答。明迦叶佛法。于时住世七日后方灭。何以然。此是净土众生。神根[仁-二+(隹/乃)]利。智慧滋多。故七日之中。受持悉得。过是已后。不复须此音声章句。故言其灭。理宝常恒。而不毁也。今此世界。愚痴无智。秽浊居怀。不体于常故。所以须分明宣辨理本常住。岂容灭耶

善男子迦叶佛时所有众生(至)虽有是典不须演说

案。僧亮曰。于时国土严净。无有钝根。不须三种经也

善男子今世众生多诸烦恼(至)何以故常不变

案。僧亮曰。明此国土秽恶。众生喜忘故。具有三种经也。智秀曰。第四正答所问也。明迦叶佛法。理常不灭。正以学者根利。不须言说。由言教不兴。故言灭也

善男子若有众生我见无我(至)不可说言如来法灭

案。僧亮曰。上说多诸烦恼。今说烦恼。相也。宝亮曰。对向七宝譬赎命等句也。若众生断常病起。便说六行。有能安心此理。则慧命增也。乃引[仁-二+(隹/乃)]等六事为誓也。智秀曰。第五翻辨诸须说时也

善男子若佛初出得阿耨(至)当知是法久住于世

案。僧亮曰。明此经隐时。余经亦灭也。行恶法者。恶法互起。起恶涅槃经隐也。僧宗曰。广明佛法灭不灭相。乃有十二句。合为六对。要使道俗相须。方得弘法。得失相形。互辨优劣也。智秀曰。第六翻。广明灭不灭相

善男子我法灭时(至)悉发阿耨多罗三藐三菩提心

案。僧亮曰。上说诸佛法有兴衰。此说释迦法中第六恶也。酪沙者。从波罗奢华中出也。出时纯虫可用除也。有十二万诸大菩萨。至烧一切经典。证涅槃经不灭。直是纸墨文字灭耳。智秀曰。第七翻明释迦法兴灭之相也

大般涅槃经集解卷第四十一大般涅槃经集解卷第四十二

  阿阇世王六臣说邪见事　耆婆慰喻阿阇世王事

    梵行品之第七

尔时王舍大城阿阇世王(至)父王无辜横加逆害

案。僧亮曰。列在品末者。有四意。证经多义。一证慈等怨亲。二证慈有益。三拔五逆重罪。四明若信因果。生重惭愧。发露悔过。加阇世者。为可拔。不如是者。不可救也。此先明造罪之缘起。内具十恶。不见未来。外党凶人。遂兴重逆。昙济曰。有六意。一明慈有有益。二明怨亲等。三明外净众生。四明能除。五明悔过。六明应近善友也。僧宗曰。此下有二意。一者犹是叹经。二者证成梵行有益也。敬遗记曰。有五意。一叹经。第二内臣劝诣佛。第三空中声告劝随耆婆。第四明佛慈无偏。第五明除罪也。又一解云。第一外臣劝以邪师。二证梵行。三示为慈有改悔之方。四示有真知识。五明其父教中是声闻也。此下五段。第一明外臣劝也。宝亮曰。此是梵行品中。大段之第四。证经力用。能除重罪也。有五意。第一上来虽明经有大力。能除重罪。未见其事。今出阇世。亲是其人。以经力故。罪得除也。第二既明四无量心是实益。若不出其相。则何以为验。今故教月受三昧。先除王身之疮。近表慈悲之实也。第三欲明如来一化之中。普为人天作善知识。具足入道之因缘也。显六师为恶友。耆婆为善知。第四示人忏悔之法则。若当有罪。能如阇世者。必灭矣。第五远证三乘慈等也。次第教云。声闻无有慈悲。济拔于物。而频婆娑罗。亲是须陀洹人。能舍重怨。空中有劝也。智秀曰。品中之第五大段。证慈悲有实益义也。文有四别。第一出内有恶因。外随恶缘造恶。第二耆婆为善友。劝其诣佛。第三其父劝也。第四佛自放光。接化之也

因害父已心生悔热(至)有能治者无有是处

案。僧亮曰。次明信有悔

时有大臣名曰月称(至)灭除我罪我当归依

案。僧亮曰。彼国之俗。慰喻之偈。是以人人说之。以晓王意也。富兰那者名也。姓迦叶。其人起断灭之见。故云生法如是也。僧宗曰。此大邪见。谛无因果也

复有一臣名曰藏德(至)除灭我罪我当归依

案。僧亮曰。末伽梨是其字。拘舍离是母字。其人起断常见也。谓七分是常。无善恶是断也。伊师迦草。外皮软脆。内干坚实。譬七法无害者及死者也。七分一一非人。性异不可合为一。故无害者也。若治国法杀。无罪者治。国有刑杀之罪罪。自招死非。杀者罪。法名无法者。答王所言无辜咎也。先王虽无狂滥之罪。不无刑杀之咎。有余报者。有过去罪也。僧宗曰。第二邪见外道。立常见也

复有一臣名曰实得(至)能除我罪我当归依

案。僧亮曰。删阇耶是字。毗罗胝是其母字。其人起见云。一切苦乐。因在过去。而现在无因。未来无果。现在持戒。遮苦果不起。名为解脱。僧宗曰。第三邪见。计一切苦乐。皆过去造也

复有一臣名悉知义(至)除灭我罪我当归依

案。僧亮曰。阿耆多翅舍其字也。钦婆罗衣也。着粗衣苦行。其人起见。谓苦乐之因。亦在过去。若现受苦事。自得解脱。是故种种受苦。投渊赴火五热炙身等也。僧宗曰。此人执断见也

复有大臣名曰吉德(至)能灭我罪我当归依

案。僧亮曰。迦罗鸠驮其字也。迦栴延其姓也。其人谓。一切万物。自在天作。心无惭愧。自在天喜。不入地狱也。僧宗曰。第五此是二十五谛家计也

复有一臣名无所畏(至)能除我罪我当归依

案。僧亮曰。尼犍其字也。若提其母字也。谓因亦过去受生死。迳八万劫苦尽。亦无善恶行道断苦。故言无阿罗汉修道等也。僧宗曰。第六此人计有自然解脱也。宝亮曰。自初至此。别恶友之辞。自下耆婆以去。明善知识事

尔时大医名曰耆婆往(至)王所白言大王得安眠不

案。僧亮曰。向来大臣。并不见因果。言居王位自在得杀。不应愁苦。不进其师也。今耆婆见有因果。已既有罪。理应愁苦。不得安眠。是故问

王以偈答若有能永断(至)盗者未获财不得安隐眠

案。僧亮曰。初四偈说佛也。次五偈半。说菩萨也。次二偈。一谓佛。一谓菩萨也。次三偈说有罪故。不得安眠也。次三偈广说不安眠事也。智秀曰。偈以下凡有四意。初九行半。出得眠也。第二有两行。出得眠人。第三六行。出不得眠法。第四长行自中也

耆婆我今病重于正法王(至)演说法药除我病苦

案。僧亮曰。先自说不治之病。不得忧也。后知病起由心。非草石所疗。自非法王。无可治也

耆婆答言善哉王虽作罪心生重悔而怀惭愧

案。僧亮曰。庆王病轻也。王知父母恩重有惭愧故。心生重悔。露向人惧地狱苦。信有因果。具此五善。王病易治。莫怀怖畏。下一一引佛语证也。僧宗曰。此下有七番说法也。宝亮曰。此下有八番说法也。智秀曰。此下有六番说法也。至处更叙也

大王诸佛世尊常说是言(至)善哉大王具有惭愧

案。僧亮曰。证惭愧也。宝亮曰。第一明具惭愧故。罪可除也

大王且听臣闻佛说(至)罪则除灭清净如本

案。僧亮曰。证悔过也

大王富有二种一者象马(至)多作诸恶不如一善

案。僧亮曰。善从理生。有根力强。恶横故无根。则力弱也。上直提佛语。今以理释也

臣闻佛说修一善心(至)何以故破大恶故

案。僧亮曰。所说证善力强也

大王如佛所说[雨/復]藏者漏(至)说有智者不覆藏罪

案。僧亮曰。第二明王虽作重罪。能坏发露。罪可灭也

善哉大王能信因果(至)云何而言不可救疗

案。僧亮曰。证发露则罪灭也。宝亮曰。第三明王信心不断故可治也。智秀曰。上来至此。第一既非阐提。而有惭愧。罪可灭

如王所言无能治者(至)在拘尸城娑罗双树间

案。僧宗曰。第二说有师故罪可治也。宝亮曰。第四示王医所也。智秀曰。第二明现在既有大师在此。云何言无耶

广为无量阿僧祇等(至)所有重罪即当消灭

案。僧亮曰。示王医所也。所以须具说者。六师皆言其师一切智。故须本末述之。僧宗曰。第三明此师说法药。故罪可治也。宝亮曰。第五耆婆为王。说二谛除罪之法药也。智秀曰。第二句举善。今列法药也

大般涅槃经集解卷第四十二大般涅槃经集解卷第四十三

  耆婆劝阇世王诣佛　广说杂缘起事　出频婆娑罗于空中劝阇世事　释月爱三昧义　为阐提作一柱殿义

    梵行品之第八

王今且听释提桓因(至)所有重罪必当得除

案。僧亮曰。昔未说治罪人有验。今出所治之人为证

大王且听有婆罗门子(至)为无上医非六师也

案。僧亮曰。鸯崛摩罗。此言指鬘也

大王复有须毗罗王子(至)为无上医非六师也

案。僧亮曰。昔有悭贪。今日渴饥。闻说其过。心生惭悔。见水得饮

大王舍婆提国群贼五百(至)为大良医非六师也

案。智秀曰。第四广出诸蒙益之事。明佛有道力。能旷益无穷也

大王若能信臣语者(至)若不见信愿善思之

案。宝亮曰。上至此。第六引现事为证。自佛出世至今。有犯罪而见佛者。无不除灭。云何王罪。独不灭耶

大王诸佛世尊大悲普[雨/復](至)亦当视佛如父母想

案。僧亮曰。恐王思惟。不敢求佛。次说大悲怨亲平等。广出等事也。僧宗曰。第四广引证。以劝王行

大王当知如来不但(至)发阿耨多罗三藐三菩提心

案。僧宗曰。第五明佛普覆。不限一人也。宝亮曰。第七明佛平等无有彼此也。智秀曰。第五佛心不偏。所以能除王罪也

大王假使一月常以衣食(至)到如来所诚心听法

案。僧亮曰。犯罪既重。唯应听法。非财施所能灭也。僧宗曰。第六格量去留。功德多少也。宝亮曰。第八明佛功德智慧因重。能灭人罪也。智秀曰。第六明佛能加益人心。所以见佛。必有福利也

尔时大王答耆婆言(至)深自鄙悼都无去心

案。僧亮曰。不以往为虑。自鄙秽累。非听法眷属。往恐不必接叙也。僧宗曰。第七王自念罪重。无去心也。宝亮曰。虽闻上六种胜说。犹未敢去也

尔时空中寻出声言(至)疮蒸毒热但增无损

案。僧亮曰。证耆婆之言。王罪既重。唯佛能除。故说佛欲涅槃。劝速往也。僧宗曰。第三别也。前外道劝觅邪见师。次耆婆劝也。今其父自劝。令随耆婆语也。宝亮曰。阇世向疑罪重。耻至佛所。其父恐随耶师。今故劝也。智秀曰。此下第三其父以神通之力。劝之令诣佛也

尔时世尊在双树间(至)至无量劫不入涅槃

案。宝亮曰。此明如来见阇世之心。自可救之理。言味而求。正为欲从阇世解常故耳

迦叶菩萨白佛言世尊(至)何故独为阿阇世王

案。宝亮曰。时人不解此旨。故迦叶致问也

佛言善男子是大众中(至)是故闷绝自投于地

案。僧亮曰。圣人现灭。欲以益物。若生定灭之倒。致闷绝之苦者。佛则为之不涅槃也

善男子如我所言(至)大涅槃经亦不可思议

案。僧亮曰。释密语也。前四句出所为之事。后二句说涅槃不灭。不应以佛灭故闷绝也。宝亮曰。释时之疑也。非直一人。并为一切未解常者也。智秀曰。此下有七别。明佛放光引王诣佛。佛为说法。灭王罪也。至彼自言其七事。此即第一先唱密语

尔时世尊大悲导师(至)身疮即愈郁蒸除灭

案。僧亮曰。所以慈光远至者。王闻父诲。地狱苦报。必受不疑。谓罪不可消。自鄙凶秽。佛不接顾。有此二疑。不敢诣佛。慈光远至。二疑俱释也。僧宗曰。此下第五段也。前言为王住世治其心。虽有其言。未见其实。月爱三昧。始为验也。宝亮曰。先治其身。后治心也。智秀曰。第二放光灭苦也

王觉疮愈身体清凉(至)先治王身然后及心

案。僧亮曰。引双树经。称曾闻人说夫劫火。不烧众生。先有三月并照。除众生病。使得修禅上生。月光既出。无病不愈。其时未至。而有妙光。所以喜而问也。答云。应故现光。无定相也。非色非非色。双释真定相也。非青非齐。偏释真也。为度众生者。偏释应也

王言耆婆如来世尊(至)是故复名月爱三昧

案。僧亮曰。七子之中。一子遇病。譬凡夫。六子譬六住。慈本缘苦。若重则慈重。初住已离三涂。六住则永离人天。佛则放舍慈也。智秀曰。第二翻正列放光。灭其身苦事也

王语耆婆我闻如来(至)当有何心往见如来

案。僧亮曰。虽蒙远光。身病得除。闻此经语。惧不敢往也。将无陷入地者。若违经见佛。恐交致此苦也。我观如来者。向引经语。此以情推也。僧宗曰。虽蒙光照。犹以善恶事隔。且惭愧在颜。不欲去也

耆婆答言大王譬如渴人(至)而当不蒙慈悲救济

案。僧亮曰。为阐提说法者。以重况轻。证必济也。兼非王所引之经。若果尚为阐提说法。云何不与恶人坐起耶

王言耆婆我昔曾闻(至)何故如来而为说法

案。僧亮曰。如来言不虚设。云何乃为阐提说法。必不然也。宝亮曰。耆婆申佛意。傍为说法。尚为阐提说法。况王非阐提耶。智秀曰。第三王虽蒙光。心犹未达。请耆婆为决

耆婆答言大王譬如有人(至)语彼医言速疾上车

案。僧宗曰。此下第六说譬。以慰王劝令去。宝亮曰。为阐提说法。凡有三意。如医治病人。一为除现苦。二遣眷属横苦。三息外人诽谤。合譬如此。可知也

尔时良医即自思惟(至)如是病者必死不疑

案。僧亮曰。譬如来为阐提说法。如医审知病者必死。不得不说法。一为病人。二为亲族。诸佛亦尔。不得不说也

大王世尊亦尔于一阐提辈(至)为一阐提而演说法

案。僧亮曰。明阐提说法。有二利不虚。前去凡夫诽谤。后明利益阐提。显说法不空也。譬如净人者。喻未来善根也

王语耆婆若使如来(至)得道之人不入地狱

案。僧亮曰。冀汝捉持者。惧犯罪增生。入地狱也。智秀曰。第七始从耆婆劝命驾。至佛所去也。僧宗曰。第四翻闻法之机发也

大般涅槃经集解卷第四十三大般涅槃经集解卷第四十四(婴儿行品第二十一)

  佛为阿阇世王说二十法门　辨婴儿行

    梵行品之第九

尔时佛告诸大众言(至)犹如微妙真金之山

案。僧亮曰。犹有疑佛不垂慈救。罪不得灭。当知无定相者。定罪以烦恼为定也。无定定者。无定疑心。疑心定者。一断不起

尔时世尊出八种声(至)礼敬毕已却坐一面

案。僧亮曰。言大王者。不直称名。惧其喜过。渐开其心也。无上大师者。知佛慈等真一切智也。智秀曰。第五佛命大王以定其心

尔时佛告阿阇世王言(至)心则放逸无恶不造

案。僧亮曰。王不发菩提心。罪不可灭。发心者。由见凡夫之过。此二十事。说凡夫之过也。僧宗曰。第六为王说法也。有十一翻。此即第一先命观二十事。就身为其相既浅。如似伏惑

阿阇世言如我解佛所说义(至)必定当堕阿鼻地狱

案。僧亮曰。上虽说戒等。五法无常。王爱罪影。犹未怗也

阿阇世王白佛言世尊(至)是故当知杀无定相

案。僧亮曰。去其封罪之报。便从理得解也。宝亮曰。上来至此。且一往总为王说法。以虚忘也

大王如汝所言父王无辜(至)若九非者则应无罪

案。僧亮曰。第二为说生法二空。其观既深。如似断惑也。宝亮曰。此下别为王说法。先开五门。后更以五阶。释此门也。此即第一门。就假名义中说法。以除其罪。谓若能解万法虚假即空。而有为妄有。罪何从生。虚其心故。则无实罪也

大王色有三种过去未来(至)云何说言定入地狱

案。僧亮曰。以五门破定罪相。成王所解也。第一门说是假名。无有定相。僧宗曰。第三翻就三世分之。则无罪也

大王一众所作罪业(至)汝独云何而得业耶

案。僧亮曰。第二门。明一者心念教能杀人。二者心口杀。三者具身口杀。王不具三业。故罪轻也。僧宗曰。第四翻明三业具则罪重。但有心口。而无身业。罪则轻也。宝亮曰。第二明罪福不在因缘中

大王频婆娑罗往有恶心(至)云何而言定入地狱

案。僧亮曰。第三门。明恶有下中上也。下者。谓彼怨我。我还以恶报也。中者无恩于我。以恶加人也。上者有恩于我。又加其恶。王是下恶也。僧宗曰。第五举昔业缘起富罗山事。宝亮曰。第三明先王以宿业所招。非其创罪之始

大王众生狂惑凡有四种(至)若非本心云何得罪

案。僧亮曰。第四门明杀有三。谓重者。邪见杀也。中者嗔杀也。下者贪杀也。王以狂乱心杀。故非定也。僧宗曰。第六举贪狂。以遗其心也。宝亮曰。众生作罪。皆由不自在故。若能识此罪源。则无罪矣

大王譬如幻师于四衢道(至)诸佛世尊知其非真

案。僧亮曰。第五重门也。僧宗曰。第七有六譬。证上第二生法二空。故罪不可得也。宝亮曰。第五有十譬。法体性空无自性。故杀无定

大王杀法杀业杀者杀果(至)虽复因王王实无罪

案。僧亮曰。重显前第二门也。僧宗曰。第八证上第四王但知杀。而身不自杀。则无罪也。宝亮曰。释上第二因缘中。无罪性也

大王如王宫中常敕屠羊(至)于父先王生重忧苦

案。僧亮曰。重显前第二门也。宝亮曰。释上第三门。宿业中无罪也

大王世间之人是爱僮仆(至)王不自在当有何咎

案。僧亮曰。重显前第四门也。僧宗曰。第九成上第六罪由贪狂。宝亮曰。释第四门贪狂也

大王譬如涅槃非有非无(至)无有见者则无果报

案。僧宗曰。第十举世谛涅槃。是有说有罪

常见之人则为非有(至)非有非无而亦是有

案。僧亮曰。重显前第五门也。宝亮曰。释上第五门。万有体空。无性罪也。于有惭愧者。则是非有。何以尔。既生惭愧心。达万法体虚。故于人为无罪也。若于无惭愧者。是则非无也。受果报者。名之为有。谓无智人。终日构因得果。是以不无也。空见之人。则非有者。谓于此人。便无性报也。有见之人非无者。谓于报相者。便不无果报也。有有见者。谓计常之人为有也。无有见者。若无向执相。终无果报也。常见之人者。此是解常之心。故于此人为无也。无常见者。若观生死。令佛尽作无常。则不无果报之生死也。常常见者。此是计常之人。不无于恶果也。以见义故者。经云。于解者为非有。于不解者为非无也

大王夫众生者名出入息(至)不入地狱汝云何入

案。僧亮曰。重显前第一门。僧宗曰。第十一翻。正说法之宗也

尔时阿阇世王如佛所说(至)诸法无常苦空无我

案。僧亮曰。既已得解。即于佛所得。不坏信也。僧宗曰。若解假名是虚者。则无罪而不灭也

世尊我见世间从伊兰子(至)受大苦恼不以为苦

案。僧亮曰。废其非分

尔时摩伽国无量人民(至)即是一切诸佛弟子

案。僧亮曰。己身天身者。因中说果耳。僧宗曰。前言为阇世住者。义现于此

说是语已即以种种(至)了了见佛性犹如文殊等

案。僧亮曰。初九行半叹佛。次六行自发心也。前九行半中。初三行。总叹口四业。次一行半。别叹不恶口。次一行。叹不绮语。次二行。说语之益物也。次二行。叹慈悲也

尔时世尊赞阿阇世王(至)天行品者如杂华说

案。僧亮曰。赞述所叹也

    婴儿行品第二十一

案。僧宗曰。备行三行。其德则喻如婴儿。亦是化婴儿也。此品有三段。第一譬佛。第二从不知苦乐以下。譬菩萨。第三又如婴儿以下。譬众生。明昔所以须说五乘之教也。宝亮曰。此品有五段。第一明佛自作婴儿。第二明菩萨作婴儿。第三明佛方便为化。第四明佛说二乘之果。以为真极。第五明为断见者。说有实众生也

善男子云何名为婴儿行(至)断于无常是名婴儿行

案。僧宗曰。第一譬也

又婴儿者不知苦乐(至)而作声闻辟支佛乘

案。僧亮曰。方便诱引。不即法实。以业为譬。下是其正体。如来菩萨。以譬婴儿者。义似婴儿。广其非行体也。何者。解脱中云。如来有婴儿行。无有是处。此之证也。亦可佛菩萨是婴儿行本。名婴儿行也。僧宗曰。第二譬也

又婴儿行者如彼婴儿(至)然此黄叶实非金也

案。僧亮曰。第三譬。为说三十三天之乐。以免三涂苦也

木牛木马木男木女(至)男女想故名曰婴儿

案。宝亮曰。木牛即第四譬。为说二乘果也。木男即第五譬。为断见者。说有众生也

如来亦尔若有众生(至)亦皆同汝得是五行

案。僧亮曰。先总以三法为譬。杨叶譬人天乘四果。牛马人天等一乘。男女譬众生。啼哭譬造恶业。三十三天者。别合杨叶。所以明者。凡著有不说涅槃。众生厌时至二乘之实。则合牛马。所以然者。以厌生死者。不说人天因也。有断不断者。智烦恼断。习不断也。已下类尔。非金中生金想。至而说为净总。合上四果为净。于非牛马作牛马想。至说非道为道。总合四乘为道。说假名众生。合男女。别堕邪见。堕断灭也。是故如来说有众生者。说假名众生。除其断见。于众生中。作众生想者说计我者普也。于众生破众生见者。明说假名众生。亦破常见。不但此也

大般涅槃经集解卷第四十四大般涅槃经集解卷第四十五(德王品第二十二)

  广出是有三乘无三乘等事　释闻不闻义。谓三世声并不可闻

    德王品第二十二

案。僧亮曰。已说五门。次说行之所得功德也。僧宗曰。此品广前五行也。功德是行中之胜。未至佛果。且有功德也。功德之与行。乃义有因果果耳。如苦乐一法。以能生之义为集。从生之义为苦。今行与功德。亦如是也。十功德中。以初功德。及第二功德。同广圣行。第三第四。同广梵行。第五第六。同广天行。第七至第十。无别所广。并通广上三行也。宝亮曰。五行十功德。盖左右为名也。行以从因向果为义。功德以赞叹受名也。又一解五行是因语。功德是果语也。所以者何。金刚心是因中之极。涅槃是果中之极。自一念以上。通一切行。尽是涅槃之因。虽然金刚已还。亦得具有因果之义。但未测起善之久。近要取前一念为因。能资生后念。后念善得生。必由前念善为因。如是前后念相续者。至佛果有即因即果义。若捉后念而望前念是因。捉前念而望后念是果。是则五行据因。十功德据果也。今十功德。还广前五行。何以知之。圣行以戒定慧为体今初功德。还明三慧。终迄漏尽通为体也。第二功德。以五通为体。慧即是智慧。五通是定家之果。故以此二功德。广圣行也。第三功德。以慈悲为体。第四功德。以十事为体。十事即是喜舍。故用此二。广梵行也。第五功德。以五事为体。第六功德。以金刚三昧为体。此二广天行。天行以八禅定为体故也。五事者。一诸根具。故能修定。二不生边地。以非难故能修定。三诸天护念。四世间爱念。宿植德本。故天护人爱。便能修定。五得宿命智。即是定果也。修此五事。便得天行。金刚三昧。即是众定中之极。故知广天行也。第七第八两功德。广婴儿行。第七以四法为体。谓亲近善友。听闻正法。系念思惟。如说修行。此四本是始行之所行。教婴儿之法。第八以九聚法为体。从断五阴。乃至心善解脱。亦是始教之法。是故得知此二功德。并广婴儿行也。第十功德广病行。而相传用前三种病人。及须陀洹等五种病人。为病行相。今第九功德。还明三种病人也。第十功德。明三十七品。此三十七品。即是彼五种病人。所行之法。是故广病行也。智秀曰。大判一品。凡有二意。初列总叹。第二随辨体。别为十者。盖一涂之法门耳

尔时世尊告光明遍照(至)无有相貌世间所无

案。僧亮曰。此菩萨好修功德命为语对也。一行得二功德。五行具十德也。僧宗曰。二乘心劣。岂能思量耶。非内者。非二乘也。非外者。非外道所能行。非难者。于菩萨不难也。非易者。二乘不能行也。非相非非相者。中道忘相之解。与理冥符。是出世之法也。宝亮曰。今将欲解十功德。故先一往。且总赞叹。云不与二乘共者。二乘之行。本不近道。云何心得行此理耶。故发轸唱云。不无二乘共也。不可思议者。十地真解。离有无之相。岂是有无之心。可图度耶。闻则惊怪者。理玄深寂。岂是执相者。所能解。故曰惊也。非下过之所知。故称怪也。非内非外者。若为有无之所摄。可属内外。既绝有心之境。安得是内是外耶。非难非易者。若修心得所。必会而非难。于不行道者。而息望故。言非易也。非相非非相者。体绝形名。故言非相也。然非不现相而庄严。故亦言非非相也。非是世法者。神解以法性为本。非因之所生。岂是世法。若据体以辨用。义亦因之也。无有相貌者。体既无有无无。岂有相貌可示耶。世间所无者。真体既绝百非。百是岂为世间所据。此总叹功德体也

何等为十一者有五(至)能知如来密藏是为五事

案。僧宗曰。名虽有五。以性而录。理不出三也。何等初一事明闻慧。中二为思慧。后一为修慧也。宝亮曰。义惟五事。虽复不出三慧。然而不可定以初事是闻慧。以第二事为思慧也。但必知总以三慧为体耳。何故然耶。群生根性万差。解有利钝。发解之时节复异。岂可定耶。智秀曰。五事第一第二第五。此三事。即是闻思修慧也。第三第四。此二事就慧。能有所断功用为体也。下文释第五修慧云。虽知众生实无有我。此二句明善照于空。兼达于有。初是众生空。后是法空。次下诸句。明善照于有。兼知于空。通约假名众生。以显义也

何等不闻而能得闻(至)是名不闻而能得闻

案。僧亮曰。第一第二功德。对圣行也。第一说漏尽通。此五事是断漏事。佛性至涅槃有五事。一曰四果。皆说常法。昔所不闻。而今得闻。此辨因也。僧宗曰。向已列数。念明此法。妙绝常伦。事见金刚身品也。宝亮曰。此第一事也。昔日机根未熟。所以未能得闻。今日机缘既发。便感声激。是则昔以无感故不闻。今以因惑而闻也。虽复藉言教而闻。即闻无所闻。故言闻所未闻。理虽如此。自有从不闻得不闻。从闻得不闻者也。第二事语其闻法而致。第三事谈其得解后有所除。第四事明其内解心决。第五事出其所解之境。从此经而知理。然文中释初事。有两重。第一从所谓甚深涅槃微密之义下。正列不闻之法体者。谓大般涅槃。常乐我净也。寻此之旨故。得知功德之名。据于果语。明如此胜果。百非所能尽。是则昔所不闻。而能得闻。第二从复有不闻谓外道经书下。列出不闻。今以邪法所据。明如此等经。悉无如是深密之义。亦因此经而知也

闻已利益者若能听受(至)是名闻已能为利益

案。僧亮曰。第二是利益事得果也。僧宗曰。闻经识旨。得二无碍也。宝亮曰。下去四事。义例相从。推可知也

断疑心者疑有二种(至)是名能断疑惑之心

案。僧宗曰。生疑亦不必皆由此经。若疑二乘为有为无。法华诸经已能除之。此乃遍引耳

慧心正直无邪曲者(至)是名菩萨摩诃萨正直之见

案。僧亮曰。第三第四第五类辨果也。僧宗曰。曲见有二种一谓外道。二谓声闻。今于此经得教下旨。故谓正直解也

能知如来深密义者(至)是名甚深秘密之义

案。僧亮曰。因果难知。甚深义也。佛性是因之深者。无我以下。皆说中道也。僧宗曰。此第五辨修慧也。境不异前。但解力转深耳

尔时光明遍照高贵(至)解佛所说闻不闻义不然

案。僧亮曰。承上所说不闻闻。佛性五事。皆是常法。若常法可闻。不应是常。假难以辨之也。下构六难也。僧宗曰。此难生于初句也。若初句无滞。则余亦通矣。故先以为难也。将欲显诸法不定。远彰空义。故假设不定之难耳。宝亮曰。德王今作定有定无难者。意在时情也。下复有五难。成此初执。合为六难也。凡夫封着。实为可患。闻有则成性执。闻无便成断见。智秀曰。此下有三翻难两翻问。今第一翻中有七句。第一作定难。第二第六第七同作不闻难。第三第四同作闻难。第五一句防难也。不然者。不然闻不闻之旨也

何以故法若有者便应定有(至)便应定无不应灭

案。僧亮曰。意在前关也。闻不闻义。不离此二。若闻作不闻。则有法应灭。若不闻作闻。则无法可生也。此第一难也。僧宗曰。先说两关。令法相是定也。若定有者。可从声教而闻。若定无者。则妙绝于相。永不可闻也。无不应生者。若理绝声教。不可闻声而闻也。有不应灭者。谓声教是可闻之法。不可令不闻也。宝亮曰。夫定有之法。则常可得闻。若必定无。则常不可闻。所以闻所不闻。此义不然

如其闻者是则为闻(至)云何而言闻所不闻

案。道生曰。合难闻不闻也。谓闻不闻。似若闻成不闻。理既不然。便应闻自是闻。不闻自是不闻也。僧亮曰。定有定无。已竟结成难也

世尊若不可闻是为不闻(至)云何而言闻所不闻

案。道生曰。离难闻不闻也。若果不如向言。便是闻复闻也。夫闻不可重闻。犹不可闻必不可闻也。僧亮曰。重难无法不应可闻。如已闻之法。而不可重闻。况本来定无法。而当可闻。宝亮曰。此下频借四譬。结成前难也。此第一譬。明声是可闻法。涅槃既非音声。云何而言闻所不闻耶。智秀曰。第二难也。谓已谢者。不可闻也

譬如去者至则不去去则不至

案。道生曰。譬前合难也。僧亮曰。以此譬前有无各定也。宝亮曰。至则不去。譬闻已不闻法。则不至譬不闻不闻也

亦如生已不生不生(至)不闻不闻亦复如是

案。僧亮曰。以此譬后重难也。宝亮曰。生已不生。譬闻已不闻。不生不生。譬不闻不闻也。得已不得。亦如是也

世尊若不闻者一切众生(至)虽见佛性未得明了

案。道生曰。若不闻复为闻。一往如似可得教义。而闻更作闻。为踬大矣。僧亮曰。第二难也。僧宗曰。兹决难也。不闻之理。可强得者。菩提亦可强得也。仍取佛意。若亦可强得者。十住菩萨见佛性未明了。何不强明了耶。宝亮曰。借菩提为决。若菩提不可强得者。不闻之理。岂可强闻耶

世尊若不闻闻者如来往昔(至)于阿含中复言无师

案。僧亮曰。第三难也。宝亮曰。若不闻之法。要必得闻者。佛应有师。若言无师。云何而说闻所不闻也

若不闻不闻如来得成(至)不闻是经亦应得见

案。道生曰。不闻之理。遂不可闻者。踬亦大也。僧亮曰。第四难也。僧宗曰。逆取佛意。若言改以不闻。此不闻得佛者。弥有过也。宝亮曰。若果自然得道不闻不闻者。众生亦应尔。不假闻此不闻

世尊凡是色者或可见(至)云何而言可得见闻

案。道生曰。更单难前闻义也。僧亮曰。第五难也。僧宗曰。第五第六难。大意相似而第五难小赊。第六难转切也。今此中犹许现在有闻也。宝亮曰。上四难一向反理。此下两难。傍助佛解。明万法无定。佛正承此而答也。难意谓。可见之法。犹有见不见。况涅槃非色非声。云何可得而闻耶

世尊过去已灭则不可闻(至)大涅槃经闻所不闻

案。僧亮曰。第六难也。宝亮曰。亦如第五难意无异。若万法有一定性。则无三世。以无定故。经三世耳。而已过之。声不可闻者。未至亦不闻。现在即生即灭。又不可闻。故论云。诸法取取尘无处。以况涅槃也

尔时世尊赞光明遍照(至)如十住菩萨之所知见

案。道生曰。善其难也。僧亮曰。难其解空也。常与无常。皆从缘有已。而常法从缘。见无常法。从缘生也。缘则是空。空则无见无闻也。唯十地所知耳。宝亮曰。印可其后二难。谓万法无性。如幻如炎等也

时大众中忽然之顷(至)譬如比丘入师子王定

案。僧亮曰。非青见青等。皆表诸法无定也。所以两佛相证者。明法相不异。诸佛道同。法从缘见见则常也。十号不异。法轮亦同也。从缘所生。无常国土。净秽不同。众生善恶亦异耳

尔时文殊师利菩萨白佛言(至)尔时如来默然不说

案。僧亮曰。光以证佛所说。所以不得答也。宝亮曰。时众之疑未去。佛不答也。众生执心既重。若直以理答。不必为彼心用。所以寄事以感其情也

迦叶菩萨复问文殊师利(至)虽相咨问然无答者

案。僧亮曰。文殊应答而不答者。未闻命故也

尔时世尊问文殊师利(至)阿耨多罗三藐三菩提灯

案。僧亮曰。彼满月佛。现此光也。从因而现。因即慧也。无因缘者。常法不从生因生故也。亦有因缘者。从了因见也

佛言文殊师利汝今莫入(至)应以世谛而解脱之

案。僧亮曰。谓深说为第一义。浅说为世谛也。宝亮曰。命使为说光所由来处也

文殊师利言世尊于此东方(至)多有众鸟游集其上

案。僧亮曰。示从缘生法是无常也

复有无量虎狼师子(至)心常怜愍一切众生

案。僧亮曰。说众生净心者。即示净土因也

其佛号曰满月光明(至)菩萨摩诃萨所问等无有异

案。僧亮曰。从缘法常故一也。十号既同。法不异也

彼满月光明佛即告琉璃光(至)是名因缘亦非因缘

案。僧亮曰。具说因缘。即说世谛有来去也

大般涅槃经集解卷第四十五大般涅槃经集解卷第四十六

  琉璃光与佛论生不生义　辨四相常无常义　出往生不动国义　辩涅槃本有举闇中井及七宝等譬　显五种因义谓生因和合因住因增长因远因辨六度有得名波罗蜜有不得义

    德王品之第二

尔时琉璃光菩萨(至)修敬已毕却坐一面

案。僧亮曰。前说此土秽恶者。盖戒行人之常辞

尔时世尊问彼菩萨善男子汝为至来为不至来

案。僧亮曰。上说彼土清净众。欣其来致问。以遣着也。僧宗曰。不异净名昔与文殊。因去来以辨无常也。宝亮曰。假名道中。有彼此去来也

琉璃光菩萨言世尊(至)若是无常亦无有来

案。僧亮曰。诸法生灭。不相知也。至则此生。不至则彼灭。生灭理隔。并无来也。宝亮曰。假名相续道中有来有至。实法则无

若人见有众生性者(至)常乐我净则无去来

案。僧亮曰。已说诸法。无去无来。今明见去来者。是颠倒也。宝亮曰。寄斥此中时众勿取相憍慢。见有去来。而听法也

世尊且置斯事欲有所问唯垂哀愍少见听许

案。僧亮曰。自彼之此。正欲问所不知。非欲陈已所知略酬既竟。故云且置也

佛言善男子随意所问(至)是故应当专心听受

案。僧亮曰。有三意。一往许问。第二叹法难值。第三诫其听法之难也

时琉璃光菩萨摩诃萨(至)大涅槃经闻所不闻

案。道生曰。虽复无据会亦同涂。是以远来致斯请也。僧亮曰。既蒙许旨。即咨所问也。僧宗曰。问与德王同也。但举其初问。余后不复列也

尔时如来赞言善哉善哉(至)是则名为闻所不闻

案。僧亮曰。彼来诸人。或有不及。是以致诫也。恐时来会者。生高下之心。是以寄言大士。乃密诫余人也。宝亮曰。能如是解。亦即是闻不闻也

善男子有不闻闻有不闻不闻有闻不闻有闻闻

案。道生曰。佛说而彼听。即显闻矣。更与四句。以尽其美也。僧亮曰。答前有应定有之难也。谓有为之法。虽有而修道。则无不修。则有何得难言有必定有也。答初难已。五难自释也。僧宗曰。此四句。二句浑法。二句定理。有浑有定。岂可一句执定耶。有不闻闻者。若声未生之时。为不闻。众缘会在于现。是则名为向不闻法今得闻也。理亦如是。虽不可闻。非不假诠以入理。岂可定说耶。有不闻不闻者。此一句还定理也。有闻不闻者。复是浑句也。前难意欲使定是闻者。不可为不闻故。此云闻不闻也。谓已闻之声。谢在过去者。不可重闻矣。有闻闻者。还定声教是可闻也。谓前声亦生耳识。后声亦生耳闻也。宝亮曰。正答问也。此四句并置涅槃之上。初不闻闻者。不闻谓涅槃也。未有机感。所以名为不闻。今日缘发则闻。故云本所不闻今得闻也。有不闻不闻者。此不闻与前不闻。言同而旨异。前举涅槃体不可闻。此举众生无感机故。不闻斯理也。又一解。前不闻法身灭。闻与不闻但闻。众生惑故见耳。是则虽闻即不闻也。有闻不闻者。众生有缘惑故一往得闻。若更不进德。后不复重闻。故言闻不闻也。有闻闻者。初有惑故得闻。后更进德。则有重闻之义也。智秀曰。此通遣诸难也。体绝名相。非是可闻之法。藉缘具故。得闻其名。谓不闻者闻也。不闻者。涅槃之理。于无德者。无能闻之缘也。闻不闻者。声是闻法。一谢之后。不可重闻也。闻闻者。可闻之法从缘。而前念后念皆可闻

善男子如不生生(至)不至不至至不至至至

案。僧亮曰。生义易了。故举以譬闻也。至不至亦如是也

世尊云何不生生善男子(至)初出胎时是名不生生

案。僧亮曰。有为是世谛也僧宗曰。五阴为因。行人为果。因果相成。为安住也。宝亮曰。未出胎为不生。出胎为生故言不生者生

云何不生不生善男子(至)是名不生不生

案。僧亮曰。内法有为中。无不生者。言涅槃也。僧宗曰。始终求其生相。永不可得

云何生不生善男子世谛死时是名生不生

案。僧亮曰。死时者最后念也。后念是生。生是生过。是则非生也。宝亮曰。本有今无。故言生者不生也

云何生生善男子(至)念念生故是名生生

案。僧亮曰。前念后念。相续不断也。宝亮曰生生不断凡夫相也

四住菩萨名生不生何以故生自在故是名内法

案。僧亮曰。三住见谛结尽。四住欲界思惟结尽。于欲界生。虽生不生。以生自在故也。僧宗曰。愿力故生。非向生生者。宝亮曰。四住断见谛烦恼尽。故生是现生。非实业生也

云何外法未生生未生未生生未生生生

案。僧亮曰。所以前言不。而此言未者。以内有涅槃可得言不。外无涅槃。故云未也。宝亮曰。义类前也。唯未生未生。应云不生生生为便也

善男子譬如种子未生芽时(至)是名外法生生

案。僧亮曰。已增长最后身。是名牙生过是则非也牙是未生。如牙增长者。牙生未增。是名生生者也

琉璃光菩萨摩诃萨(至)为是常耶是无常乎

案。僧亮曰。已说世谛。生是假生。但外计四相。谓生是实法。今破其横计。使假生之义立。是故问也。有六句问也。僧宗曰。更设六难。犹成前六难也。如来向以四句解释。初句问不闻难。借生以况闻。今移闻难生者。若于生义有滞。则闻义亦壅也。若于生义通释。则闻旨亦释。此有三闻相对为六。前难生相。不能生法。既不生法。则法不可生。犹执定成前意也。中二难为自他难也。后二有无难也。寻此难相承蹑之。意由佛向解未生法。是无而见在假因缘故生。当知理不闻。假言故闻。琉离光承前言致难。今先难生体也。生若是常者。先张二闻也。言生相若常有漏。不应有生也。何以然耶。生既是常。法体无常。二理天乖。既云天乖。何体以常乃至无常之法耶。欲使有漏不从相生也。宝亮曰。上来既明生生等四句。于执相者。谓言有漏法外。别有一生相。来生有漏法起故。琉璃光今者作难。今佛会通。若论理而言正是法起时名生法。无时名灭。无别有生相。来生法。其难意既尔。下据事来作三关难。一难开两关。便成六重。就一关中。先定后结难。定初关。言有漏法若有生者。为是常故。能生是无常。故能生下。即结难言。生若是常有漏之法。则无有生。若别有一生相。是常而生法者。则所生之法。则无有生。若生若别有一生相。是常而生法者。则所生之法。亦应从生相皆常也。而今现见有漏法。念念无常。得如此法。不为无常生相之所生。则有漏之法无生相。是以言有漏之法。则无有生也。智秀曰。初二句作常无常难。欲使常则寂然不动。无功用力故。岂能生法耶。无常则体不自立。力不及。法亦不能生他也。次二句作自生生他难。初明生之为法理不自生也。若生他为生。无漏涅槃。不即是生相。便是于生为他。何故不能生此他耶。而必不能。故知生相生他为生。义则不然。次复二句就本有本无为难。若生已有之法。则不假更生。若生无法使有则应能使虚空成有也

生若是常有漏之法则无有生

案。道生曰。横起故有生。生若常者。则不得生于有漏。有漏无生。何由起耶。僧亮曰。第一句以本无今有为生也。若有漏无生。则非有漏。有漏横起是名为生。无漏不横。故非生也。无常之性。生时即灭即灭之生。不能生物。则有漏无生。无生即常。亦非有漏也。宝亮曰。若法不为生相所生。则有漏之法。无生相。若无生相。则非有漏

生若无常则有漏是常

案。道生曰。虽得生有漏。而无常在。生不在有漏。故有漏常也。僧亮曰。第二句也。宝亮曰。若不为三相所相。则有漏之法。理应是常也

世尊若生能自生生无自性

案。这生曰。若变成所生。则无复自性也。僧亮曰第三句生无自性者。自生则一体有二也。一谓能生。二谓受生。受则非能。能则非受。失其性也。宝亮曰。亦应先定难也。应云为是自性。能生于法。为是因缘。故能生耶。今阙此定也

若能生他以何因缘不生无漏

案。道生曰。第四句也。无漏于有漏为他。若有生他之能。亦应有能。生无漏之能也。僧宗曰。十地无漏。非不发始从缘。当不据此为言也。乃是神明妙体者耳。此妙体绝于有无。不从因生。岂非知善耶

世尊若未生时有生者云何于今乃名为生

案。道生曰。早应名生。今何脱耶。僧亮曰。第五句也若未生时有法。有法则名为生。云何于今乃名为生耶。僧宗曰。此难使法不从生相生也。宝亮曰。亦应先定也。此初关谓。若先已得生名者。何故后时方名生耶

若未生时无生者何故不说虚空为生

案。道生曰。虚空亦本无也。僧亮曰。第六句也未生是无法。虚空亦是无。若生于无者。何故不说虚空为生耶。宝亮曰。若有为法。本傍无相及力者。彼起此亦起。彼灭此亦灭正得俱时而已。云何能生于法。若俱无相及力者而得生有为法。何故不说虚空为生耶

佛言善哉善哉善男子不生生不可说

案。道生曰。答第六句也。僧亮曰。先答第六句也。生是假名。不可定说也。不生是无而生能生无。亦不可定说也。僧宗曰。先答第六难也。不生即虚空。欲令虚空生者。不可说也。宝亮曰。后关七种章门。下自次第释也。初六句。悉作不定答。后一句明因缘故得生也。不生生不可说者。第一句明无定不生性。亦无定生性。云何可定说耶

生生亦不可说

案。道生曰。答第五句也。僧亮曰。第五句也。生是已有。已有更生。亦不可定说也。僧宗曰。次答第五难。不可说生已生之法。则有重生之过也。宝亮曰。亦无一定生之性。故不可说也

生不生亦不可说

案。道生曰。对明第六门也。僧亮曰。上二句说生法有无也。此说生相能生有无也。不生是无而生能生无。故不可定也。僧宗曰。人情展转生疑。若无已生故来生者。便是生于不可生者耶。今言亦不可如此说也。宝亮曰。亦无定生定不生之性。故不可说

不生不生亦不可说

案。道生曰。对明第五问。僧亮曰。若不生死者。亦不可定也。僧宗曰。逆取其意也。惑者复谓若如上答。便是可生者自生。不可生者自不生。今言亦不可作此说也。宝亮曰。亦无定不生。定不生故。言以修道故不可定

生亦不可说

案。道生曰。复有生不生。今离之。亦不可也。僧亮曰。离法之外。别有生相者。亦不可定说也。僧宗曰。不复遣惑。此别遣生体耳。借生遣不生。岂有生之可得耶。宝亮曰。前四句。遣一执。不可谓有定性。今第五第六两句。直遣生相。不可谓离法之外。别有一生相者也

不生亦不可说

案。道生曰。前已离生。今离不生也。僧亮曰。若法无生相。亦不可定说也。此六句。通答后二句也。僧宗曰。生本对不生。生既不可得。岂有不生而可得耶。宝亮曰。亦不可定说法外。若无别生之相。便使法体。不复得生也

有因缘故亦可得说

案。僧宗曰。因缘谓与他为他。因虽不自生。而有生他之义。答第四第三问也。生是生他。不生无漏。后更别答也。僧宗曰。遣之稍精。转入第一义谛时。情迷闷故。说有因缘也。宝亮曰。上六句明不定。此第七句。明缘合故生。不合则不生也

云何不生生不可说(至)何以故以其生故

案。道生曰。释答二问七句也。既云不生。而言其生。是则不生为生也。僧亮曰。生名起。不生则无起。若名为生者。是则起。无起为起。何可说耶。僧宗曰。重释所以也。云何一向都无。而忽然得生。故知有可生之理也。宝亮曰。不生者。今生云何定说。生者。生耶。不生者定不生耶

云何生生不可说生生故生生生故不生亦不可说

案。道生曰。生若先生。今则不应复生也。僧亮曰。生生故生者。先定生生之名。谓以生生故。生生也。生故不生者。故前生也。不生后生也。以前生生故。后生不生也。僧宗曰。难者。欲使已有法。在未来及在时生也。今言生故不生者。未来不生也。生生故生者。现在有生也宝亮曰。生生故生者。此一句先立位也。凡夫生生相续。故名作生。亦无一定性也。下云生故不生者。形得故得名。何处有一定生之性也

云何生不生不可说(至)生不自生故不可说

案。僧亮曰。生即名为生者。先定生名也。生生不自生者。必生可生法。不生不生法也。僧宗曰。未生之无。不同菟角。故云生即名为生也。宝亮曰。正以因缘和合。便名为生。因缘不会。便名不生

云何不生不生不可说(至)何以故以修道得故

案。僧亮曰。涅槃不生。故不可说者。以可学得。故名生也。僧宗曰。不生之法不过涅槃。尚以修道故得。岂谓不生都不生耶。宝亮曰。万善具则得涅槃。岂可定说耶

云何生亦不可说以生无故

案。僧亮曰。果法虽有。而生无也。僧宗曰。上四句答难。遣执已毕。今直遣生体也。宝亮曰。偏遣生相也

云何不生不可说以有得故

案。僧亮曰。有得即有作。有作即是生也。僧宗曰。若必有不生可说。则永无生也。宝亮曰。有为则生。云何定说耶

云何有因缘故亦可得说(至)以是义故亦可得说

案。僧亮曰。为生作因者。无明至有。是十法为生作因。是生他不自生之义也。僧宗曰。世谛道中。为生作因也。宝亮曰。若前十因谢。次生法起。即名作生。故得说为生

善男子汝今莫入甚深空定何以故大众钝故

案。僧亮曰。甚深空定者。求法定相。则空是深也。僧宗曰。遮其前意。故言莫入空定也。宝亮曰。上来所说。寄有以谈理。更试之言莫谓据此而说

善男子有为之法生亦是常以无常生亦无常

案。道生曰。答常无常问也。有为相续而常。故云生亦常也。僧亮曰。答初二句也。有为之称也。论其生灭有为之法。从而起生也。相续故住也。变故异也。减故坏也。四相一时现在法起是有应常以起时。有住以生续减为住无常故生无常也。僧宗曰。非一向常。亦一向无常。以常无常故。得生法耳。生生相续。故言常也。宝亮曰。法外无别生相。但当生分其位不改。亦得言常。以住来隔故。便名无常也。四相当分位。义皆然也

住亦是常以生生故住亦无常

案。僧亮曰。住亦是有。有亦应常。以先后二生故。住亦无常也。僧宗曰。此住为生来。生其体故。不得恒住。所以无常也

异亦是常以法无常异亦无常

案。僧亮曰。以变法名异。法无常故。异亦应尔也。僧宗曰。亦应类前句云。异亦是常。以坏无常。异亦无常也。此互其文耳。今举法者。尔所生能生。同是有为也。又其前云。生若无常。则有漏是常。就言中相关。故此一句。明法亦是无常也

坏亦是常以本无今有故(至)能断灭故故名无常

案。僧亮曰。法在终灭。始终体满。得受有名。此之有者。本无今有。故无常也。僧宗曰。本无今有之性。其义不常。以是坏故。坏亦无常也

善男子有漏之法未生之时(至)父母和合则便有生

案。僧亮曰。未生时。已有生性者。作恶是横。必招横果。未生之已有生理。善性不横。不招横果。无漏无生理也。答上无漏不生句也。僧宗曰。上言何以不生灭谛无漏。今明灭谛不可为相所生。乃可了因所感耳。宝亮曰。通释第三句以下四句难也

尔时琉离光菩萨(至)复欲咨禀唯垂听许

案。僧亮曰。领解并为无畏菩萨问也

尔时世尊告无畏菩萨(至)利智捷疾闻则能解

案。宝亮曰。问有二意。一问何业生净国。二问彼诸菩萨何业。而得是大威德耶

尔时世尊即说偈言(至)诸佛秘密藏则生不动国

案。僧亮曰。满月世尊。所以不于彼答者。事现于此八万四千。一闻而悟。云问不持释。而自解也。彼土菩萨。愧其愚钝。必愿生净国琉璃光所以问也。宝亮曰。凡二十一行偈。明修十善离十恶。故生彼国。先答第一问

尔时无畏菩萨摩诃萨(至)所造业缘得生彼国

案。僧亮曰。领解

是光明遍照高贵德王(至)紧那罗摩睺罗伽等

案。僧亮曰。自既未悟。因请法之次。为众重请也。僧宗曰。无畏更申德王之问。以请答也。宝亮曰。所以请佛答德王前至不至等问者。即是遣无畏后问也。义现于下也

尔时世尊即告光明遍照(至)何因缘故未至不至

案。宝亮曰。下文次第释也

善男子夫不至者是大涅槃(至)烦恼因缘故名至至

案。僧亮曰。钝根之流。才非一往。重须解释也。上以到不到。譬闻不闻。今先释譬也

善男子闻所不闻亦复如是(至)以是义故名不闻闻

案。僧亮曰。既以释譬。还合闻等四句也。此四于六难中。答初难。兼答第二第三第四难也。不闻闻者。释第二难。因涅槃经闻所不闻。释第三第四难。名字可闻。释第五第六难。非有为故。至不说故。三法非音声。不可闻。般若绝众相。不可有无说也。法身无定形。不可以天人见也。故涅槃不可说也。得闻名故者。虽复身智无定称。四名不可说异。常乐之名可闻也。宝亮曰。释义既竟。所以复举闻闻等句。以结之者。为与后说之本

尔时光明遍照高贵德王(至)云何说言常乐我净

案。僧亮曰。第一难。若断烦恼得者。则应无常也。僧宗曰。乘声有此难也。凡有六难。此第一举本无今有为征也。宝亮曰。若是本无而今有者。云得得称常耶

复次世尊凡因庄严(至)成就涅槃因缘故名无常

案。僧亮曰。第二难。因庄严得者。亦是无常也。宝亮曰。凡世间因庄严而成。若使涅槃亦因万行以庄严者。云何而得称常也

复次世尊有名无常(至)以是义故名为无常

案。僧亮曰。第三难。若是可得者。则是无常也。宝亮曰。凡有法者皆是无常。佛昔云。三乘圣人。若有涅槃。以此义故。应是无常也

复次世尊可见之法(至)则得断除一切烦恼

案。僧亮曰。第四难。可见故。则无常也。宝亮曰。若见涅槃。而断烦恼者。不容是常也

复次世尊譬如虚空(至)若不如是云何名常

案。僧亮曰。第五难。不共有故。则无常也。僧宗曰。既不平等。云何言常。宝亮曰。若是常者。应如虚空。而有得不得。故不应常也

譬如有人恭敬供养(至)如其无者云何可说

案。僧亮曰。第六难。有名故无常也。僧宗曰。不免名故。故知无常。宝亮曰。若有常乐我净之异者。亦不得。称常也

尔时世尊告光明遍照(至)非本无今有是故为常

案。僧亮曰。答第一难。涅槃非本有者。涅槃以性灭为因。身智以相续灭为因。因非本无。果非本有也。有为因是无常。果亦无常。无为因常。果亦常也。诸佛所师法也。法常故。诸佛常也。僧宗曰。前有六难。今但答四。余后二难。粗故不答也。此答初难云。涅槃非本无今有也。宝亮曰。非本无今有者。所谓生死依如来藏也。故一家义云。神明是虑知之性。但于缘中迷。故起生死。若理缘解发。则伪灭真存。有万德之用者也

善男子如闇室中井(至)不应说言本无今有

案。宝亮曰。无明覆故不见。非本无今有明矣

善男子汝言因庄严故(至)以自庄严然后乃见

案。僧亮曰。答第二难也。无烦恼处。是真涅槃。此处寂灭。不可庄严。汝自庄严求耳。非庄严涅槃也。宝亮曰。除障故真显。判非惑尽之时方有真生也

善男子譬如地下有八味水(至)则便得之涅槃亦尔

案。僧亮曰。答第三难也。宝亮曰。地下之水。人不知故。谓之为无。穿掘必见。岂谓始有。涅槃真体。修善了出。非生因所造。岂无常耶

譬如盲人不见日月(至)先自有之非适今也

案。僧亮白。答四难也。宝亮曰。致涅槃之名。理有二途。一就二用立称。二就体相为字。此乃据体为论也。就真而辩用者。其万德亦常也

善男子如人有罪系之囹圄(至)妻子眷属涅槃亦尔

案。僧亮曰。答第五难也。宝亮曰。第五一难。虽引三譬。今此一答。亦总释矣。如彼世人。若恭谨则常安。而行违则触网也。而父母常自本有。但众生生死颠倒。岂涅槃始有耶

善男子汝言因缘故(至)乃得名为大涅槃因

案。僧亮曰。既已别答。更追释涅槃因。是了因非作因。故常也。宝亮曰。更举第二问重释也。向云非庄严所成。今云从了因而现。不从生因生也

尔时光明遍照高贵德王(至)此是涅槃此是大涅槃

案。僧亮曰。修经见空。会通二谛。得成六度。此是檀。此是波罗蜜者。见第一义。则见世谛也。宝亮曰。德王因此解释。更作两问。一谓。云何六度。名波罗蜜。而有不得名者。二问云何涅槃。云何大涅槃也

善男子云何是施非波罗蜜(至)如杂华经中广说

案。僧亮曰。于相中有檀非檀不说空也。乃不见施者受者也。宝亮曰。正答初问也。夫行门之体。必应忘怀。若见有行之可行。便成分别。是以菩萨。用心得所。故不见有能施所施。不见有行之可行。而能大施。修因取果。不乖中道。若如此者。即谓波罗蜜也。所以尔者。正由菩萨忘三达诸法虚假。不见有施者受者。一无性相。若无此空解。则不得称波罗蜜也。故经言。见有乞者。然后乃施。是而非波罗蜜也

大般涅槃经集解卷第四十六大般涅槃经集解卷第四十七

  辨护法等四种罪人不定义　论阐提断善根义　广辩诸佛非天非非天等事　辨三漏义　辨七漏义

    德王品之第二

善男子云何菩萨摩诃萨(至)是名不闻而闻

案。僧亮曰。上说有为作因无常。涅槃从了因得则常。若尔者。十二部经。皆是涅槃了因。即是经也。文深义奥。非二乘所闻也。声闻缘觉经中。无阐提有佛性。所以重说此事者。欲发德王问也

光明遍照高贵德王(至)何故名为一阐提耶

案。僧亮曰。德王以二难。初以佛性一难。成前第五涅槃不定之义。若佛性是善。应遮地狱及阐提也。性若常者。应遮令不无常也。僧宗曰。此问之生。由前而来。前六难。初句令本无今有。如来已释此义。明非是始有。言佛性之理。万化之表。生死之外。其旨已彰。其令承本有之言。便谓与阴为一。阴既无常。使性亦无常。此中有八句。前三句难使不得已有。若有则应见用。无则金刚谢时方有。还复成本无今有。若本无今有。便是无常也。下五句不定难。大意皆欲佛果是无常。成前六句无常难也。寻不定难之来由。前佛答高贵。明不定之理。今难言。若以不定使不问。可得闻者。便应还生也。初难言。若有佛性。则应有用。便应遮地狱。而令四禁五逆之人。不免恶道。当知身中非是本有。若非本有。则无常也。第二难言。若身有性。此性既常。便应有常乐之用。何故复言。无常乐我耶。若无常我。则身中不得有性也。第三难言。阐提断善。而佛性既云已有。便应为阐提所断。若汝言虽有。不可断者。复不得言无常乐我。若言即时未有。则是本无之义。又且若有性。不可令断者。即阐提之义。不定反覆致难也。犯四重名不定者。先就邪定中。四种人是不定。故无常也。第二就正定聚中。二乘人是不定。故无常也。第三就如来明不定。第四就涅槃明不定。第五总举一切法通因果。皆为不定。下至阐提。上至诸佛。阐提穷恶之原。以其不定。得成佛者。如来是尽善之极。亦以不定之义。还为生死。虽有五句。意在难果也。宝亮曰。德王第二问。后卷方答。何故尔。向答初问后言。犯重禁人。及一阐提。尽有佛性。今于此经。而得闻之。德王今因斯语。复更作二难。佛正得先遣此义。故来假答向大小涅槃之相也。后二难中。初难有五关。若使犯重及一阐提等有佛性者。佛性是善。何故堕于地狱。第二关言。若使是等。必有佛性。不应言无有常乐我净。第三关言。若断善根。名一阐提。佛性是善。何故不断。第四关言。若佛性果断。复云何言是常乐我净。第五关言。若佛性不断。则不应得受一阐提名也。虽有此五关。皆展转相成。共结一难。智秀曰。由佛答前难云。涅槃非本无今有。体非闻法。此第三翻。更复设难执阐提无性。及以不定。使涅槃体。还成本无今有。便是无常可闻之法也。初三句为难虽异。意正欲令佛性非是本有。涅槃应是本无今有。不得非是闻法。后五句作不定难责。使诸法皆悉不定。涅槃既尔。应还为无常成闻法也

世尊犯四重禁名为不定(至)一阐提等当得涅槃

案。僧亮曰。第二难阐提不应成佛。何者。四人是邪定。若邪定不定。正定亦应不定。若不定者。涅槃则非常。若有常乐。则阐提不应成佛也。宝亮曰。此下作不定难。且前并列不定之事。然后结难。若阐提不定。后还成佛者。万法皆然。涅槃既是万法之数。亦应不定。还可作生死。法瑶曰。若更是不定。当知无有常乐也

尔时世尊告光明遍照(至)吾当为汝分别演说

案。宝亮曰。将欲答难。先赞其得理兼识之也

善男子一阐提者亦不决定(至)以不决定是故能得

案。僧亮曰。先答后问也。僧宗曰。就答中先答第四。其前引四种邪定为难。令且举阐提。后更历四人出也。次答第三。义势兼答第一第二。下答二乘竟。未答第五。先答涅槃第六句也。初句实如汝语。正以不定故得佛。但法不可一类。欲使涅槃亦是不定。何以故尔。夫法有有同异。若是有为。则备三种。以其体无常故。是相续假。以其无自性故。有一时因成假也。相待得称故。有相待假。答涅槃唯可名中相待耳。以如此义故。亦义称不定。以其是常。免二假之相。故可为实不定也。僧亮曰。未是正答。且略举第二问。以虚众人之心。令体万法无定相也。智秀曰。所以别答前问难者。欲明阐提成佛。知所断之善。非是佛性。为成答前三难义耳。此第一先举第四难。第四事偏别答第四难者。欲明阐提后得成佛。故知因中所断之善。非是佛性。为成答前三难义耳

如汝所言佛性不断(至)非有漏非无漏是故不断

案。僧亮曰。答第三也。从理名内。不从理名外。内外皆是性。不可断也。僧宗曰。此下答前三中第三句。其前难意。欲阐提善根既断。性亦应断。今答言。善有二种。内之与外。意业善为内。身口业善为外。佛性非内外。故非无常也。阐提佛性。既是当有。非为已有。岂可责令遮地狱。既言当有。岂得有常乐我净义。势可得兼当第一第二难也。复有二种。更广明佛性不同此也。此言无漏。是因地无漏也。非常者。佛性不同三心灭处。及三无为常也。若断已得名阐提者。言起作之善是可断。后复还得故。以断起作之善。故称阐提。佛性理常。性相恒尔。岂可断耶。宝亮曰。正举第一问来答我上言。譬提有佛性。唯有正因性。本不论有缘因。何故作此之难。而令断生已得善故。受阐提名也。善有二种。一内二外者。若意地所生善名内。从身口所生善为外。正因之性。非此内外善摄。故不断也。漏有漏者。若狭相所起之善名有漏。若于缘中称境解。不与惑俱。名之无漏。明正因性亦非此二善。是故不断也。常无常者。昔于灭谛中善名常。从缘中所起者。名无常。正因性亦非常善无常善。所以不断也。而正因佛性若可断。则应同上所列善。而今不然。故知不断。正断缘中所生善故。得一阐提名也

复有二种一者常(至)佛性非常非无常是故不断

案。僧亮曰。正因是常。缘因是无常也

若是断者则应还得(至)若断已得名一阐提

案。僧亮曰。明起作法力相倾夺。起邪见断善根入地狱。起正见则断阐提遮地狱。佛性非起作。不能遮地狱无常。及阐提通答前三难也

犯四重者亦是不定(至)见一切法是无常相

案。僧亮曰。犯四重者。更称后难答也。宝亮曰。此下答第二问。明阐提虽当时断善根。后若善根发时。其必成佛。无有中间停者。若是定者。云何成佛耶。涅槃乃可是万法之数。其体用是定故。不得同生死虚伪也。真体不动。迹无定相。先说十譬。明万法是虚。后广明化物也

善男子亦有定相(至)得阿耨多罗三藐三菩提心

案。僧亮曰。谓涅槃者。对二十五有。故为定也

善男子如来今于拘尸城(至)如来涅槃亦复如是

案。僧亮曰。涅槃有大小。亦多义。今唯大涅槃。常乐我净四义是定。余义皆不定也。如有为法。无常苦定。余义不定也。二端不可烧者。明其应二身不可灭也。宝亮曰。此下乃至非说非非说。当知如来之身。非如来。非不如来。是故如来不定

善男子当知如来亦复不定(至)以是义故如来不定

案。僧亮曰。前非天一句。四种天明如来并非也。从非人以下。先列竟。后次第释也

善男子何故如来不名世天(至)是故如来亦非非定

案。僧亮曰。说众生相者。自言我是人中师子。诸法各各别异相者。如眼不见香。耳不睹色。诸佛不尔也。唯有一相者。可以法身为目。不可以六根分别也。金刚身品云。除一法相。不可以人天一相而名也。如来法界者。如来法性也。久已远离诸相者。上明三十二相。下明如来久离此事也。善知诸相者。随众生应见诸相。善知应之也。虚空相故者。空无分别。如来不尔

如来非有漏何以故(至)如来永断是故非漏

案。僧宗曰。此下释非漏。先总明非三漏。从三漏后起七漏。二是漏。五是助漏因缘。其或有从治道制名。或从因受称。将说起见故。先明疑心。此是见之所由也。又一释。生六种见者。此正见见漏。体无别有。思惟漏。义克可知。宝亮曰。诸佛所以能如此乘迹体尽。无一切漏。具一切德。故有所运。为绝人天之境。而凡夫具诸漏故。故无此神德。下去因即广明凡夫起漏之过患。若寻其漏。原不出见谛思惟。两漏为本。正有此两漏。能广生诸漏。今一方明漏。大分七种。若离三漏为七。亦终不离见谛思惟。七漏者。第一见谛漏。第二思惟漏。第三根漏。第四离漏。第五亲近漏。第六受漏。第七念漏。下去次第。解此七门。述其过患。行人若当依此大涅槃作观解。其漏即灭。常升无为也。智秀曰。此下明七漏中。始举三漏。正出见谛思惟。为正漏体。次出疑见。是别显见谛漏也

复次一切凡夫不见有漏(至)常修圣行是故无漏

案。僧亮曰。下释七漏也。有漏见漏是实漏。余五是漏因说也。于有漏中。分为见漏。从疑生故。先明也。以凡夫不见有漏过故也。僧宗曰。前二为章门。言我见我者。是假我。而见为实我。亦可佛地是真我。而计为麻麦我也。我见无我者。佛实是我。计为无我也。无我计我者。于生死常计我也。生六种见。决定有我者。起身见也。无我者断见也。无我见我者。如眠是无我。见于净色也。我见我者。以定力。见未来相续不断。我见无我者。若以捉四阴为我。见色为非我。可举一我自释无在也。我作受知。此三句为一。此用为小异不出身见也。若不尔。前决定为章门。后分我作知。更为三句也。宝亮曰。此下正出漏体。明此七漏皆不离见谛思惟。然众生痴重。种种妄计。皆不得法实。因是疑见生六种心者。在始二心。决定有我。决定无我。是总句。恐非六之数。我见我者。第一心。但有假名我。以凡夫计。有一性我之法也。我见无我者。第二心。佛实是真我。横计为无我也。无我见我者。第三心。实无神我。然是假名。假名我执者。言是实性我也。下余三心。谓作者受者知者。而凡夫妄计。所以成邪见。如来永断此漏源。是故非漏

善男子凡夫不能善摄五根(至)观欲如是多诸过患

案。僧亮曰。下次明根漏。依六根所起。名曰根漏。若能摄六根静三业。制不为非。其恶则止。若就所对治。名曰戒漏也

复次菩萨摩诃萨观诸众生(至)永断根本是故非漏

案。僧亮曰。二十五里譬二界。以摄相为喻也。王譬佛。一臣譬菩萨。油钵譬念慧。断汝命者失念慧。故慧命断也。一人拔刀者。譬精进见净。不生色相。至识亦如是。明真俗。观真则无色。观俗则见苦。不作生相。至不作因相。生灭是行苦。因是集也。释真中。尚无苦集。况净色观也。和合相者。释俗和合。是苦是集也

复次善男子复有离漏(至)思惟其义是名为离

案。僧亮曰。离者。以行经为离。先说离体也。宝亮曰。此下明恶漏。若从治道。名为离漏。如昔教明恶生恶马恶知识等。若能长人恶法。教令避也。就今经为论。直睹之为生死无我。即得远离。何以然。既体诸佛所师法。便知生死是虚妄。依如来藏有故。不假远避也。从云何亲近漏下。第五若亲近衣服饮食。则生人贪染。断于慧命。若不着此四事。便善日夜增。恶法稍断。若据所对治。名之近漏

何以故善男子我都不见(至)亦复如是心不造恶

案。僧亮曰。上说行经者。此说经是离也

善男子譬如世间有善咒术(至)有如是等无量功德

案。僧亮曰。师教长良弟子恭。由此二事。能灭恶也。咒术以下。广譬经能者也

大般涅槃经集解卷第四十七大般涅槃经集解卷第四十八

  出通法缘起　广辩离漏　广辩念漏　四毒蛇譬　五栴陀罗譬　一诈亲譬　空聚落譬　六大贼譬　河譬　草筏譬

    德王品之第四

善男子若有人能书写是经(至)是经难遇过优昙华

案。智秀曰。向明如来非天非人亦天亦人。今出其事。以证不虚

善男子我念过去无量无边(至)唯能受持一偈文句

案。智秀曰。广出缘起。以证不虚。兼明所闻之偈。以验经力。又显求法之至者也

如来证涅槃永断于生死(至)如来甚深秘密之德

案。智秀曰。广叹经力。以显离恶之胜缘也

以是义故能受持者(至)况于如来是故非漏

案。宝亮曰。结离漏也。生死即虚妄。依如来藏有故。不假远避也

云何亲近漏一切凡夫(至)是故如来不名有漏

案。宝亮曰。若亲近衣食。生人贪染。断人慧命。若能远离。则善法增长

复次善男子一切凡夫(至)如来世尊非是有漏

案。僧亮曰。受漏者。因三受后起。若就治道。应名定漏也。苦受后生烦恼为嗔觉。乐受后起贪觉也

复次善男子凡夫若遇(至)舍离众恶趣向善道

案。僧亮曰。第七念漏也。起三受时。未是烦恼。觉苦乐已。更生邪念。念苦乐方生烦恼。故念为漏因。圣人觉苦乐已。不生邪念。故不起生漏也。为心身造种种苦者。为邪身心相故无苦不更。明见身之过也。宝亮曰。下第七明念漏。由邪念因缘故起漏。名之念漏。若就治道。称为行漏。所以言身心苦恼。起种种恶者。夫苦恼之名。本是果报。而凡夫愚痴。不达宿业所招。便呼嗟非分。谓苦不可忍。既内狭颠倒。不以理自处。于轻苦之中。发缘更重。若当识因果性体。前世因作。如此安心。岂容生漏。正由物于此二途无解。又于生死之中。妄生乐想。保着为实。邪念横生。故起种种恶。若是圣人。以道居心。终日处苦。不觉为苦。处乐不以为乐。是故不生漏也。今菩萨觉过。故修假名法空。断于苦本。是以此下。就八事作五阶譬辨。若安心所从于圣言。必诸漏永息。涅槃可期。如其不尔。生死常续。八事者。从观四大去。讫登上大山。五阶者。第一得假名空。第二得实法空。第三明两空。成后八真无漏。断见谛烦恼尽。得须陀洹果。第四从得初果后。更进断三界思惟结尽。至罗汉果。第五从断三界外惑尽。乃至得大涅槃也

善男子譬如有王以四毒蛇(至)心生惶怖舍箧逃走

案。僧亮曰。第一譬。以假名无明烦恼之主譬王。经称四大。譬四蛇也。盛有漏身。以譬一箧。使其将护。譬瞻养也。消息失所身坏命终。譬戮之都市也。见老死之苦。譬恐怖。知无实我。譬逃走。宝亮曰。王譬佛也。四毒蛇者。喻四大也。盛一箧者。如说四大。以成一身也。令人养食者。令观此身作苦空无常。若就有中解者。欲依此四大身上。得行道进德。故须将养也。摩洗其身者。即教作空观。令识四大过。便善法续起。喻如摩洗也。若使不观四大是虚。爱着己身。必断慧命。义如戮之都市也。其人闻王切令者。菩萨即承佛教。观四大过也。舍箧逃走者。即谛观此身。唯见四大常虚假。无有一实。故得假名空。欲论四大五阴。及与六入。尽成众生。同得作假名空观。但随其初观。捉法而入空。同之内凡夫。而文不可并说。故阶级明之也

王时复遣五栴陀罗(至)见后五人遂疾舍去

案。僧亮曰。第二譬。得五阴空。实法空。见阴是实。能劫善则。譬栴陀罗。智以断惑譬刀。而害事交至。譬拔也。出空见有。譬回顾。已见假空。解实则易。譬疾去也。宝亮曰。譬观五阴。作实法空观也

是时五人以恶之方便(至)汝可来还其人不信

案。僧亮曰。第三譬。破二爱已。得假实二。诸结渐薄。唯实法爱难去。譬恶方便。入观见空。譬藏刀。出观起爱。譬诈亲。欲令起着。譬还来。观空断爱。譬不信也。宝亮曰。虽得假实二空解。然出有心中。还于五阴上起爱。故更捉五阴而观。未能即得。喻如藏所持刀也。起爱从情。如诈亲也

投一聚落欲自隐匿(至)求物不得即便坐地

案。僧亮曰。第四譬。既成初果。缘假起慢。不勤修道。知内入假实。譬空聚。染着假名。不以患。藏隐不见真我。譬无人。不见实阴。譬无物。不复进修。譬坐地也。宝亮曰。既得六入空。入无相行。断见谛惑。证须陀洹果。是一止息处也

闻空中声咄哉男子(至)汝当云何而得免之

案。僧亮曰。第五譬。断二界思惟结。垂其先解为因。进求上果。譬闻空声。说其先解。譬无居民。染着假名。譬今夜。因有内惑外尘得入。譬六贼。能生众结。譬命不全。断慢成果。譬舍去也。宝亮曰。得须陀洹果后。出观心中。起思惟门惑受生。既乘本见谛。无漏解见。思惟门中受生。惑为过欲。更观六尘空。进断所余结故。义言如闻空中声也

尔时其人恐怖渐遂增复舍而去

案。僧亮曰。复得六尘空解。无漏转深。断思惟门惑。三界结尽。证罗汉果也

路值一河河水漂急(至)心意泰然恐怖消除

案。僧亮曰。第六譬也。断无色界思惟及习。彼烦恼难断。譬河漂急也。定多慧少。譬无船筏。必假以道。譬取草木也。上地苦轻。有深定乐。而行者乐故。譬更思惟。知是苦已。譬推筏入河。定道难用。必须众善相助。譬身手皆动也。宝亮曰。断无明住地惑。得于佛果。乃通三界内外。皆是河义。而今取无明住地惑难断者。为河也。即取草木为筏者。于三界外。既未有有治道。欲修行万善。以趣极果也。从我设住此下。说蛇贼所害者。若指断三界结尽。而终未免于蛇贼。既与已相邻。云何相免。宁当任无明住地。或牵于生死。终不为彼蛇贼所害也。即推草筏者。思惟既定。便修万行。运实智方便智。即达涅槃岸。登上高山也。从观身如箧下。还次第合向八事五阶也

菩萨摩诃萨得闻受持(至)背之驰趣修八圣道

案。僧亮曰。观四大。合第一譬。四种毒者。见譬眠也。解譬身也。气从口出。譬声香也。味从口入。譬啮也

五旃陀罗者即是五阴(至)涉路而去无所顾留

案。僧亮曰。观五阴。合第二譬也

诈亲善者名为贪爱(至)及一诈亲涉路不回

案。僧亮曰。观爱贪。合第三譬也。见不见闻不闻。至后还不见者。入观则了。出观则生惑。二乘亦尔。本为向初果。为譬因说爱之难除耳

空聚落者即内六入(至)及六大贼怖着正路

案。僧亮曰。观六入。合第四譬也。凡夫不生空想者。于圣理悬远也

六大贼者即外六尘(至)舍空聚落涉路而去

案。僧亮曰。患从外来。劫内功德。譬之贼也。合第五譬也

路值一河者即是烦恼(至)及一阐提悉皆不定

案。僧亮曰。依譬次第。应观断无色思惟烦恼及习为河也。合第六譬也

大般涅槃经集解卷第四十八大般涅槃经集解卷第四十九

  释大涅槃小涅槃义。举有山大山等喻　释声闻习气义　释有因缘名及无因缘名义　释五神通义　辨二种神通。一与外道共。一与二乘共　辨涅槃非音声之音

    德王品之第五

尔时光明遍照高贵德王(至)云何涅槃云何大涅槃

案。僧亮曰。所以重问者。虽说断漏。能得涅槃常乐我净。不说我乐自在之用。涅槃之义未障故也。宝亮曰。次下答德王第二问也。上闻不闻中。佛答六难竟。更设二问。佛答一问竟。今更举第二问。以请释也

尔时佛赞光明遍照(至)是名涅槃非大涅槃

案。僧亮曰。涅槃虽有多义。会是无苦之称。得息苦者。皆得名焉。宝亮曰。今借十譬。以辨大小之相异。正以无苦乐。故名涅槃也。若得少食。以除饥苦。亦名涅槃。但不得名大涅槃。如是十种譬。其义一例。小海亦名海。大海亦名海。若除少苦。名小涅槃。若除苦都尽。名大涅槃。其文中自广彰云。二乘人八万劫。乃至一万劫。名小涅槃者。上乘三处。明皆言到佛果。今此中说名小涅槃。其义云何。若欲于我前。不言行八万劫竟名小。未行八万劫之前。随其所得住处。以此义为小。及其行八万劫竟得佛。由名大涅槃。而此旨于一部之中。虽复说异。亦莫测其然。要随义而安也

善男子若凡夫人及以声闻(至)乃得名为大涅槃也

案。僧亮曰。凡夫因世俗。声闻因圣道者。更释非之义也。还生烦恼者。释凡夫也。有习气者。释声闻也

善男子譬如有处能受众流(至)之所得故故名为大

案。僧亮曰。前说人实。后说法实。合海譬也。河城等皆合也。十譬之中。唯不合地及天中天二譬也

云何复名为大涅槃(至)以是义故名大涅槃

案。僧亮曰。八自在者。各有文也。一者不小能小。不多能多也。二者以小为大也。三者以重为轻也。四者以三事体。心色不移。无处不至。所作事一。而见者不同也。五者一根知六尘也。六者见法如空也。七者得一切法也。八者不可见。令一切见

复次善男子譬如宝藏(至)具足成就初分功德

案。僧亮曰。无为名大。释常住故。故称大也

复次善男子云何菩萨(至)昔所不得而今乃得

案。僧亮曰。诸漏既尽。则具神通。皆圣行功德也。今见者。谓眼通。更就所得中分别也。今闻者。耳通也。今到者。如意通也。今知者。他心宿命也。宝亮曰。第二功德。以五通为体。此五是一方之所须。菩萨化道之要用。第一修天眼通。须见众生身业。二修天耳通。闻其口业。三修他心通。知其心业。虽知三业。若不达其过去。有善恶之厚薄可化。亦于化道有阙。故次修宿命通。而下愚之流。难以玄言。必须运身到彼。然后受化。故第五次修身通。今就文所辨。先明身通。昔明身通。直据色身转变而已。今谈色心自在。修短所通。适物所宜。而经亦有言如意通。亦名身通。若立身通。则没如意名言。若立如意。便废身通。若如昔教明五通。是禅定家果。要因定后。方能发通。就今涅槃经明五通。尽是智慧之异用。故菩萨摩诃萨。依六行教学。不取有无相。但使物感称根而应。如一家所解。此五通必是菩萨家化。方非外道凡夫声闻之伎。何以知耶。若实是凡夫。云何得有此法。而在外道中唱言有者。皆是应迹。外道虽言得禅定。而无有道思慧。所以无此神德也。声闻人观解既不成。复不能即在定。而变通亦由已安。法不得所。复未能忘怀。故发家唱云。菩萨所得通。不与外道声闻二乘等共之

通有二种一者内二者外(至)昔所不得而今得之

案。僧亮曰。不与外道。共五通也。一心作一者。释不与二乘及外道共。但举二乘外道可知也。宝亮曰。虽言二乘人。一心作一。不得众多。此正表二乘不得道之意。声闻入定发通。要须定前作意。作意若一。在定唯能一变。若作意作五事。便能现五变。虽在定。并发五耳。由得言一心作一。何以然。由其前方便有五故。若极利根者。在定亦容可得二变。此皆据教迹作。诸菩萨则不然。发辄修德。以旷被为怀。及至物感。则称本心。随力而现。不假兴意。若无六行解者。则不能一心现五通身也

又复云何昔所不得(至)昔所不得而今得之

案。僧亮曰。如意说名自在。于自在中。分作变化。初对凡夫。故言不尔

复次善男子菩萨摩诃萨(至)而诸众生各各见异

案。僧亮曰。得异耳根者。有三事异。一者下地闻土地。二远及恒沙。三耳识不取相。是不闻而闻。初无音声相者。菩萨耳识。真俗兼见。故不取相

复次善男子云何菩萨(至)昔所不闻而今得闻

案。僧亮曰。此下明天耳通。而文中叙相。皆是初学之方法。昔小乘明天耳通。耳识取声。然后生智。二心更相资导。故合二心为通。天眼通亦尔。今用此经中。学得天耳天眼。乃至得通。六识之用。即是智慧。故天眼通。即中作二谛观。此经既理教真正。明有为无为二理炳然。心行大法。生解亦大。若始行之流。则未及此也

尔时光明遍照高贵德王(至)云何而言无定无果

案。僧亮曰。即是定果相者。若作因定善。即是果相者。从善因生。即是果也

尔时如来赞言善哉善哉(至)凡所演说无定果相

案。僧亮曰。答意谓。若刀是定因。面是定果者。云何颠倒耶

善男子夫涅槃者实非声果(至)吾当为汝更分别说

案。僧亮曰。上说一切因果不定。此说涅槃常法非果

善男子若有善男子(至)故得阿耨多罗三藐三菩提

案。僧亮曰。一字不作字相。一句不作句相。从经理门。可说为闻因之成果。不如是者。则非闻也

善男子如汝所言闻恶声故(至)昔所不闻而今得闻

案。僧亮曰。涅槃非果。可如上说。三恶是果。声是定因。须更说之

善男子云何昔所不见(至)昔所不见而今得见

案。僧亮曰。若依欲界四大者。依欲界定。修得天眼通。悉是骨相者。天眼识能见不净。诸法定相。见因缘相者。空有两见也。宝亮曰。此下明天眼通。此明天眼通。不但见色。亦见众生善恶心。乃至知第一义谛故。所以作知名说也

若见众生所有色相(至)昔所不知而今得知

案。僧亮曰。知大小根者。乘色故知根也。一触衣知心者。因身知根同。乘色知心。义属天眼。故下知见两名也

复次善男子云何昔所不知(至)昔所不知而今得知

案。僧亮曰。次明宿命通也

复次善男子云何昔所不知(至)具足成就第二功德

案。僧亮曰。须陀洹十六心者。三谛由灭见也。昔见灭未彻。三谛不明。既已见灭。遍四谛起念现前。其心甚远。是果十六心也。宝亮曰。下去次明他心通。知须陀洹初心。次第至十六心者。声闻人欲知初心捉法不能得。若利根者。要至第七心方知。若钝根者。至第十六心方知。菩萨不尔。十六心一一次第差别尽知也

大般涅槃经集解卷第四十九大般涅槃经集解卷第五十

  辨四量心　广辩十事灭除有余断除业缘　辩戒有五种心下中上上上上中上　辩百福德成三十二相之一相及八十种好　辩涅槃经能令众生离二十五有　广辨金刚三昧

    德王品之第六

复次善男子云何菩萨(至)成就具足第三功德

案。僧亮曰。第三四等行功德也。舍慈得慈者。世间之慈。则缘亲与乐也。若怨亲同等。是则无缘也。假慈是世谛。实慈是第一义谛也。亦可有相缘者。是世谛。无相缘。是第一义谛也。宝亮曰。第三功德。以慈悲为体。舍世谛慈。得第一义慈者。此非空第一义。欲明菩萨得真无相慈。现前不从缘得。若凡夫行慈。必须见缘则方生。菩萨不然。心常怀慈悲。不待缘后方发故。所以舍世谛虚妄之慈。得真实第一无相之慈。既解慈体竟。下便出三事。就所无来明慈。第一舍阐提等得相之慈。第二舍黄门等妪弱之慈。第三舍二乘无如理解之意。既舍此三慈。得真无相如来之慈

复次善男子云何菩萨摩诃萨(至)十者断除二边

案。僧亮曰。具四等成十功德。说行一周也。宝亮曰。第四功德。以十事为体。十事即是喜舍。自身决定是喜相。余多是舍也

云何根深难可倾拔(至)修大涅槃根深难拔

案。僧亮曰。不放逸者。总万行之名也。下十根是其事也。僧宗曰。不放逸体。即智慧性。所谓信根者。释所以难拔也。宝亮曰。第一云根深难拔者。诸不放逸。失不放逸。乃有别心。无有别行。如精进之流。正背一切恶。不涉五欲。唯修善为德。此心若立。无行不成。唯佛是极不放逸人。故又言不放逸。乃是无上道之根本。众善皆从之所生。下去作十二譬。来明不放逸行胜也

云何于身作决定想(至)于自身中生决定想

案。僧亮曰。十根不拔。自知决定成佛也。宝亮曰。第二自身生决定者。从昔教来。学者未体乎大理。见法未分明。不知身为佛因。今于此教。识因果性。知神明妙体。生死依如来藏。有决定修。行因取果。心无移易。亦不非时证。唯旷被为德。既如此勇决。来果必克。宝亮曰。第三不观福田者。若如昔教法。必应先选择福田。然后行施。此本是化下愚之辞。今六行菩萨。心既体理。复有异凡夫之念处故。所以不问是田非田。但以舍为德。一切皆施。若纤毫有存。即成分别。若不怀此心。终不会理也

云何菩萨不观福田(至)不观福田及非福田

案。僧亮曰。心已决定菩提要行。唯先度人。不观田与非田也

云何名为净佛国土(至)是名菩萨修净佛土

案。僧亮曰。行慈者。乃未始不益众生。向举施。言因时之益。此修净土。是果时益也。僧宗曰。此中偏出愿耳。亦如维摩经中。为化众生。而取佛土也。宝亮曰。第四修净佛土者。劝修行十善。除于十恶。若十善满。众恶永尽。功德圆备。至金刚心。后无土之土。此为真净。若降此以还。悉于形中辩净。今菩萨发愿。修行此德。为接引下愚。示备善之基渐也

云何菩萨摩诃萨灭除有余(至)摩诃萨灭除有余

案。僧亮曰。所以二事合释者。欲通说余有也。何者。菩萨得无缘慈。现不起恶。过去有善恶余业。能累行者。根业重别为二事。有轻不数。虽轻是患。通欲释之。三事并称余业。是名余有者。是障二果无知也。僧宗曰。四果善业。岂可灭耶。以能润者灭故。所润干枯。不能感果。谓之业灭。余有者。二乘人。各证所得无为果也。无结无业。而转二果者。言无三界结业。而报身犹存。正是有余涅槃。要舍报身。得于无余。所言二者。二家同转。亦言无余。于前为二也。若依数经。转钝作利。今言如来。不复同此菩萨。以经力故能灭也。宝亮曰。第五曰。灭除有余。第六断除业缘。今为三章门。解此二事。一余报。二余有。余报者。此明习性报。如过去多欲。虽出地狱来生人中。亦多欲等也。余业者。即是人天中。受报未尽者是也。余有者。此明三界外习障。如小乘无知等。转钝作利也

云何菩萨修清净身(至)菩萨摩诃萨修于净身

案。僧亮曰。五种心者。五品心得五品。或至正见亦尔。名初发心者。具五十心。名壹决定心。名满足者。具五十定心。名满足一福也。僧宗曰。五品心。修十善为十。若此心成就。复有五十。是以百福。凡成三千二百。为三十二相也。宝亮曰。第七修清净身者。初后不杀戒。有五种心。论万行不出十善。十善满足。则得成佛。菩萨初在性地时。持一戒。有五品心。若持十戒。则成五十心。三十心满。登初住。又持十戒。复成五十。具有百心。名百福德。如是十地无漏具足。后时成佛。还来应三十。故有三十二相。今言百福成一相者。若就十地。有万福。应言成百相。何故言成三十二解者。意言三十二。是一方之所须。若一一相来取尽具万福。所以复修八十种好者。因世八十人。事八十神。然凡夫得相来久。所事之神。欲使各各相异。如来今欲化此人等故。一时之中。令此人于佛身上。各各见其所事之神。既见佛身上。有己家所事者。便来归依。受佛之化。下从十二日去。尽是列己家所事神之名

云何菩萨了知诸缘(至)是名菩萨了知诸缘

案。僧亮曰。断烦恼修菩提。知断结缘中解缚。说了诸缘也。宝亮曰。第八了知诸缘者。正善知境界。于万法不取相。既体因缘。以为虚假。即有为不有。既知有无可有。无亦无可无。正体性如此。故称了知诸缘

云何菩萨离诸怨敌(至)是名菩萨离诸怨敌

案。僧亮曰。了缘则烦恼尽。是以说之。谤方等相。烦恼非定怨。此说定怨也。宝亮曰。第九离怨敌者。自不此经中学。终不能得除烦恼之怨敌。故五住菩萨。除色界结尽。下地粗惑已断。所余未治者。不名为怨。尽用为道也

云何菩萨远离二边(至)具足成就第四功德

案。僧亮曰。因果为二。谓烦恼尽因果灭。得常住也。宝亮曰。除二边者。二十五有因果无明爱都尽也

尔时光明遍照高贵德王(至)世界无不庄严严净

案。僧亮曰。土有二种。佛行报有众生行报佛王土。始法身无定相。无定方所。众生土有净有秽。初成道要处众生净土。何者。由众生行熟。应净众生。不出恶土。自报土无方。不须说名也。无胜土是众生土。言净土者。初成佛处也。今此世界清净者。弥勒成佛时。此世界变净。应净众生。亦不出净土也。宝亮曰。既列解十事竟。时众有不达之流。谓言。释迦唯修九事。不修于净土。是以德王。为申疑而致问。佛下答云。十方诸佛。无有不修十事者。答一因不满。不得成佛。何容我独阙斯行。由世痴人言。此方有日月。他方无。作如此之疑者。与痴人何异。设譬既竟。于下愚之流。信心未立。故佛悬指西方无胜佛国。以示物云。是我之本国。今之所居者。是现来此化故。得知寻于此言无。一佛应世。无秽无净。其事如初功德中所明。此间既说东方满月如来之净。满月佛于彼。复何容疑释迦所王是秽。答当彼土纯净。心无所执。亦不容与此间德王。作定有定无难同故。得知彼此两国。各辨其一边。令众生尽得进行也

复次善男子云何菩萨(至)具足如是五事功德

案。僧亮曰。第五第六天行功德也。而经文不出。依余经四禅是天行。此五是修禅之本也。僧宗曰。悉是定家之缘也。若诸根及生边地者。何能修禅定耶。宝亮曰。第五功德。以五事为体。第一第二以离难故。能修定。第三第四以宿殖因缘故。天护人爱。第五事即是定果。即既解五事竟。德王今执昔教作难。昔言因布施故。得此五事。今云何言因大涅槃经。得五事耶。佛答云。昔日因布施得五事者。不定不常。今因涅槃。得此五事。是定是常。乃至得无漏故。得知法华以前教。无入道者。若使有实得道。不应言非无漏。寻斯之语。当知无会理也

光明遍照高贵德王(至)具足成就第五功德

案。僧亮曰。是定是常。一一对前五事。渴爱之病者。对不定下四。亦有分有果者。有三有分果。无常变异。金刚三昧者。具上五事。必得四禅。金刚三昧。定中之胜。说其德也。宝亮曰。俱是明定。前浅后深。此中三段。第一就空行中成就万行。第二明是众定王万行之果。第三明非唯了空亦是万有也

复次善男子云何菩萨(至)具足成就第六功德

案。宝亮曰。第六功德。以金刚三昧为体。金刚三昧即一切智。于时集谛累尽。体由是苦无常。苦果亦谢。无学佛果。任运而来。则金刚心时。始是功用心满。名为学佛。不得称无学。所以说金刚众定之极。就此一切德中。略科为八段。第一从悉能破散一切诸法下。明得金刚定时。知世谛理穷。第二从住是地中。乃至不见一众生实下。明悉见真谛理周。第三从一切三昧。悉来归属下。明得此定时。一切三昧。皆来归属金刚三昧。第四从譬如有人在大海浴下。明得此定时。非唯归属而已。即用此众定为体。一心之中。得用一切定也。第五从若有菩萨。住金刚定。见一切法无障碍下。明得天眼通满。第六从如由乾陀已下。明漏尽通满。第七从若有菩萨。住金刚三昧。于一念中。能变身如佛下。明身通用备。第八从譬如金刚。若在日中。色则不定下。频有三譬。来赞叹金刚三昧。能种种变应。无不益物也。所以证金刚心时。结累永尽。照理周者。正以此文为据也

菩萨摩诃萨修大涅槃(至)乃至具足般若波罗蜜

案。僧宗曰。第一叹就空行中。成就万行也

善男子譬如金刚所拟之处(至)修集一切诸余三昧

案。僧宗曰。第二明是众定之王。万行之果

善男子若有菩萨安住如是(至)乃至十方亦复如是

案。僧宗曰。第三明非唯了空。亦见于有也

善男子如由乾陀山(至)而初无心言我能灭

案。僧亮曰。第四明能灭一切惑也

若有菩萨安住如是(至)各随本解而得闻之

案。僧宗曰。第五明能有运变之力也

菩萨安住如是三昧(至)见一切法如本无相

案。僧亮曰。第六更举空境。言诸德所以成就。良由善识空也

何故名为金刚三昧(至)具足成就第六功德

案。僧亮曰。具上五事。必得四禅。金刚三昧。定中之胜。说其德也。能有二种。一坏有。二成六度也。无不碎坏者。为上坏有作譬。悉来归属者。将与成万行为譬。先说法之所归。下六是其譬也。无有障碍者。说六通广金刚之能。先总诸通。后但别说三通耳。僧宗曰。第七释金刚之名也

大般涅槃经集解卷第五十

涅槃经集解七十一卷。去享保年中。获西大寺经藏古本。书写之焉。彼本黄卷赤轴。古代雅物。偶阙九轴。厥所阙者。自四十一。迄第五十。其中唯存第四十三。予叹其不全备。索之诸方。闻武府东睿山凌云院。前大僧正实观秘藏之。其本又自第一。至第十之十轴逸矣。尝戒坛院慧光。赴东都之日。与实观相语。而欲令互寄补其阙。幸得实观本跋记。以延历寺本。校阅云尔。不日缮写。情愿果遂。僧正亦补。其阙焉。今年庚申。闲暇之间。欲补西大寺古本之阙。手自以粗纸调经卷。自三月二十日。迄五月二十三日。摩挲病眼。九轴写之。庄严既毕。以纳于彼寺矣。不年而三本全备。不亦说乎。功德普及三界灵。种因遂感四德果

时元文第五岁次庚申六月下弦

东大寺真言新禅两院前兼住戒坛院前长官宝生院闲人成庆寓于北林精舍谨记。春秋五十六。夏腊通三十八。别二十八大般涅槃经集解卷第五十一

  广辩涅槃近因　亲近善友　专心听法　出舍利弗病举床诣佛听法事　如法修行　广辩涅槃佛性八种七种六种等事　释虚空义　释烦恼断处涅槃义　引昔告魔三月当涅槃事　释涅槃名

    德王品之第七

复次善男子云何菩萨摩诃萨(至)四者如法修行

案。僧亮曰。第七第八。广婴儿行功德也。此四种德。是始行所行。婴儿之德。作近因者。以反耶为近因也。僧宗曰。从第七至第十。悉总广前行也。今第七。亦以三慧为体也。初功德辩由经力。此明三慧。由善知识。以此为异耳。宝亮曰。第七功德。以四法为体。此四法是教婴儿之行。谓亲近善友。专心听法。系念思惟。如法修行。故命篇唱云。唯此四法。是涅槃近因。若言如外道苦行。谓此为是者。无有是处。然此中明四法。大判有三翻。第一翻有三譬。总就一法明四法。其文中自合。第二翻。从善知识者。谓菩萨佛声闻辟支佛下。略别明四法。今此翻中。取二乘为善友。然前翻中。事不分别。故谓为总。善知识者。能训人善道。同己所行。彼我齐意。俱得离苦。斯为善知识相也

善男子譬如有人身遇众病(至)而常教化无有疲厌

案。僧亮曰。此三譬通为四法近涅槃。作譬也。僧宗曰。就此叹中。有两翻。前总叹。后别叹也。总叹有四重。此即第一举四譬。先显善知识之德也

善男子善知识者所谓菩萨(至)声闻人中信方等者

案。僧宗曰。第二出其人也。虽此人外。非善知识。略亦尽矣

何故名为善知识耶(至)以是义故名善知识

案。僧亮曰。别说四法义也。离十恶者。释善知识。常如善事。若我不生恶者。是如法而说。而行者也。益我有二。如法说者。言益也。如法行者。不言之益也。有善法故。说益事转深。为众生者。是善不为非善也。僧宗曰。第三释善知识义。略举其德也

善男子如空中月从初一日(至)以其亲近善知识故

案。僧亮曰。说譬以显之也。善法日增者。是中四分。说善法相。此第一也。僧宗曰。第四劝人。依善知识也。以五重辨依之有益。此第一总叹也

因是亲近复得了达(至)甚深义者名为听法

案。宝亮曰。第二益也

听法者则是大乘方等经典(至)以修集故得大涅槃

案。僧亮曰。第二释专心听法也。僧宗曰。第三前总明了达十二部经。此别明义也。宝亮曰。此明听闻正法也

善男子譬如病人虽闻医教(至)是名菩萨系念思惟

案。僧亮曰。第三系念思惟也。僧宗曰。第四叹定也

云何名为如法修行(至)终不毕竟入于涅槃

案。僧亮曰。第四如法修行也。上说因法。此说果法也。僧宗曰。前三叹辨闻慧。第四一叹辨思慧。此第五叹辨修慧也

善男子第一真实善知识者(至)则得近于大般涅槃

案。僧亮曰。第三重说也。先辨四法之第一善知识也

云何菩萨听法因缘(至)则得近于大般涅槃

案。僧亮曰。广第二专心听法也。僧宗曰。种种功德。即是此中所明。亲善知识。乃至如说修行。十种慰喻。谓以八圣道。分尽智无生智也。宝亮曰。此下广明四法。明菩萨与佛。别物几尽故。所以属第一善知识。就下文去明四法。章门悉别。事义可寻。不能广释。说须陀洹四功德者。举昔事来。证听法力大。即是向来所明之四法也。十种慰喻者。八圣道为八。正见心解脱为十。正见即无生智。心解脱是尽智也。此即是其先来所知之法。但病苦因缘。不能复缘。令更为说。令已忘苦。而缘法也

云何菩萨思惟因缘(至)则得近于大般涅槃

案。僧亮曰。广第三系念思惟也

云何菩萨如法修行(至)七我八净是名涅槃

案。道生曰。尽者。结习都尽也。善性者。理妙为善。反本为性也。实者。体是常也。真者。见常故也。常者。不见常则不常也。乐者。常故也。我者。常故自在也。净者。垢尽故也

复有八事何等为八(至)七者无我八者无常

案。僧生曰。凡夫结断。亦名涅槃。故及之也。未都尽故。不名为尽。于缚有解。亦名解脱也。善性者。亦是妙善也。不实不真者。不见常故也。无常乃至不净者。还起结故。是故无也

复有六相一者解脱(至)如来法僧实相虚空

案。僧宗曰。更释如法修行。善识诸法真伪。可以造行也。若真不真。下文广列真伪也。言不识七法之相。虽修非真。若善识七法。谓真也。涅槃者。果地大涅槃也。佛性通因果也。如来谓果地人也。法者。分佛僧余名法也。僧者。亦通因果。实相者。总一切法无非实也。虚空者。太虚空耳。言不知此七法。名为不实体。七法之相。名为真实也。有八者。先释佛果八事也。一尽者。谓尽一切惑也。翻恶既尽。即称善性也。虚伪之法既尽。故真实独存也。下对四非常。通前为八也。复有八事者。此明外道涅槃。一解脱者。非不伏结也。当时翻恶为善性也。不实不真者。伏而复生。未是照理也。下四非常者。既未登极果。有为之法也。复有六相者。二乘也。一解脱者。随分用无漏所引得无为也。翻恶故为善。三不实四不真者。更须断有余苦。证有余灭。更有胜极灭。已所未得故。为不真实也。五安乐者。以其脱三界重苦。故少分乐。秉得无漏。此是净法。体是迁流。故不得常。未得八自在我。故无我。有与有脱。故示果是未极故也。若依世俗道者。释外道所以不真之旨也。云何六相者。释二乘也。所以不复释佛果八者。已释二种未极。相形可知也。不名知佛性者。其义名异。故言不知也。宝亮曰。此下次解如法修行。若能了知七事。是真如法修行。七事者。备如经列。第一知涅槃有三种。先知佛果涅槃有八事。次知外道伏结涅槃八事。三知声闻指断灭空。作涅槃六事。若如此知。涅槃有究竟。可谓是真如法修行者也

云何菩萨知于佛性(至)是名菩萨知于佛性

案。僧宗曰。佛性有六者。就释性中。前四似偏。知果。第五当见似缘因之性也。其中道之照。非伪法故真也。一者可证余六如上者。更加果智来。证得此性也。宝亮曰。是九地所得者也。一常者。缘因之善。一得不失。常法观故常也。二即体能除惑故净。三对虚故称实。四是清升故名善。五则当见果性。六对伪故名真。复有七者。即十地佛性。加可证者。谓少见果性。余六如上说也

云何菩萨知如来相(至)是名菩萨知如来相

案。道生曰。如来既人之名也。觉者。从结使眠觉也。善相者。涅槃惑灭。得本称性。如来直善而已也。常乐我净者。言似有不来。而实常来为相也。解脱者。人似未脱。而实解脱为相也。真实者。见常而常。则其人矣。示道者。示物正路也。可见者。示同于人。故见也。宝亮曰。如来即觉相者。谓极果法身。真实佛宝。体常乐我净者。具众德也。示道可见者。次明应佛宝也。若真应知。此则是善。如法修行也

云何菩萨知于法相(至)是名菩萨知于法相

案。道生曰。无非法为法也。在人显焉。而宣通于物。使人行善为主故。先举善不善也。得理为善。乖理为不善。皆当其实。乃为法矣。常不常乃至净不净者。要在无倒于四。是法之正体也。若知不知者。法无无知故。复以知不知为法也。若解不解者。弘法在言。得旨为解。故复以解不解为法也。若真不真者。乖真为非法故。复以真不真为法也。若修不修者。弘法贵在修学故。复以修不修为法也。若师不师者。法表成师故。复以师不师为法也。若实不实者。既真则实。实显则定乎是非。故复以为法也。僧宗曰。善不善者分二宝。其余一切。悉为法也。就文而寻。似通别未分二名之法。及其施名。致义既分。二宝别故。法与实相。广狭有分也。宝亮曰。知法者。双知六行真俗二谛也

云何菩萨知于僧相(至)是名菩萨知于僧相

案。道生曰。虽多无相。各一人耳。而法不可异。然后成众无异。则常和则恒乐。非外所坏。名之为我。不容致漏。称曰为净也。弟子相者。众非独悟。居然有师也。可见之相者。众理在人。故可见也。善者。莫能有违。斯则常善也。真不真乃至实不实者。性本是真。举体无伪。未能究理。何以为实也。僧宗曰。谓常乐我净者。先举果地僧也。是弟子相者。因地僧也。可见相者。修中道解。见佛性也。宝亮曰。若极异体。和如是真僧也。若学地三乘圣众。是弟子相也。若知此二种僧别。亦是如法修行者也

云何菩萨知于实相(至)虚空等法差别之相

案。道生曰。常无常乃至净不净者。实相言理。故与法不同也。人自乖之。倒于四耳。四中无倒。理之本矣。善不善者。乖理故不善。反之则成善也。若有若无。若见若不见者。理隐似无。又若无可见也。若涅槃解脱及断者。乖理成缚。得理则涅槃解脱及断也。若知不知者。理中无有不知也。若证不证者。理隐似若难明。而昼然可证知也。若修不修者。修必得用也。是名实相。非是涅槃等者。此七义理同。而义趣不一。不一皆异前后。会之为足也。僧宗曰。常无常者。当相为实也。宝亮曰。亦无异上实谛中义也

善男子菩萨摩诃萨(至)为众生故说有世谛

案。道生曰。不见虚空者。虚空自表无空知空者。为不见空。今以譬理结句后明也。若是无物名虚空者。如是虚空。乃名为实者。有虚空相。则是三界之物。以无物故。乃是真实也。以是实故。则名常无者。无物之空。理无移易。为常无也。以常无故。无乐我净者。既无空相。亦无常乐我净。义在于无。不得云有。乃是所以有也。譬如世间无物名空者。形相空耳。而取无物。为无相空譬也。僧宗曰。唯慧眼见者。如无而见也。以光明故。故名空者。以其有通光之用为空耳。虚空是太虚也。是物无之字。外道恒言虚空可造作。若解虚空。非可造作之法。亦是如法修行也。故佛下借譬。言犹如世谛。实无其性。直自为众生说有此因缘。然世谛从本来是空。未曾暂有。今虚空亦然。直以物无处。故名虚空。何处复有虚空之可得乎

善男子涅槃之体亦复如是(至)三菩提时名菩提乐

案。道生曰。涅槃之体者。涅槃自表无涅槃。同于虚空也。断烦恼处者。以断处名灭。乃所以无灭也。即是常者。无灭之灭。则是常乐。不令同虚空矣。寂灭之乐者。既云是乐。恐滥故须明也。如来有二种乐者。谓无知之乐也。实相三乐。一者受乐者。横计虽非无为。亦设斯乐也。佛性一乐者。菩萨佛性无乐。以当有菩提乐也。僧宗曰。涅槃之体。直是断烦恼者。政言解脱众累以众累之无。以为涅槃也。即常乐者。就智上说无。岂非常乐耶。虽非受乐不同。三受之乐。而是寂无苦。故称乐也。如来二种乐者。以其不通因地。故无受乐。实相通因果。故备三乐也。佛性一乐者。天真之理。非神明义。故非觉知与受乐。得菩提时。名菩提乐者。即是寂灭乐也。更展转施名。故言菩提乐耳。宝亮曰。明涅槃之体也。亦如虚空。无有住处。佛果妙体。真如无相。岂得有处所可寻。然法性无性相。如虚空之无异。而所以异者。异在于至虚。既就体相作论。恐人怀疑。后更就用来辨。故举常乐我。来标其相也。佛有二乐者。寂灭乐处体相作语。觉知乐就用来辩也。实相有三种乐者。受乐者实是虚中实。余二不异上。是果显真实乐。佛性唯一乐。以当见故也

尔时光明遍照高贵德王(至)云何发是虚妄之言

案。僧亮曰。有三重难。第一证身智灭是涅槃。非直烦恼灭也。第二证习灭是涅槃。非直烦恼灭也。第三证身灭三事即涅槃也。自期三月者。以时事重。证身智灭是涅槃也。僧宗曰。此难之生。由前释涅槃。言直是断处。承言为难。此有四句断处。不应是涅槃也。难意引昔教。欲使涅槃同于空无也。初难言。魔来启请。何故不入。佛自答。未有多闻弟子。当知以身智尽处。非直烦恼尽也。第二举以菩萨决断故。知不必断处是也。第三魔复启请。佛答言。却后三月。当入而此当入之言。发自佛口。岂直断处。第四难意。取初成佛。便是涅槃。前第三成初句。今第四为成第二。宝亮曰。此下因于上。明涅槃直是诸佛断烦恼处。物便致疑。谓言犹是昔日有余涅槃故。德王今者作问来遣。凡据三种。谕婴儿事。明涅槃之虚实也。第一执无余应是。有余应非。何以然。如来昔在尼连禅河边。告魔王言。我今未入。第二难。从若断烦恼非涅槃下。讫我今此身。即是涅槃来。非但无余是。有余复应是也。何故尔。佛昔告生名婆罗门言。我今此身。即是涅槃。如来身未灭。而言即是者。不当用有余作涅槃耶。第三难言。论理不应。两是不尔。应一是一非。若二俱非。佛云何发是虚妄之言也。然此中。难辞虽多。正难意不出此三。从在毗舍离国以下。悉来证第一难。无余应是涅槃意。如来既自期三月。不当即用死灭。为涅槃耶

尔时世尊告光明遍照(至)凡所发言诚谛无虚

案。僧宗曰。答四难也。宝亮曰。答第三难。明自非机感。佛则不言。以物情所宜故。有此说也

善男子如汝所言波旬往昔(至)便谓如来入般涅槃

案。僧亮曰。默无所说。便是涅槃者。答初难也。宝亮曰。此下答第一难。明魔王不识涅槃之真体。谓佛直尔。默然不说法。便是涅槃也

善男子如来不说佛法众僧(至)清净二法无差别耳

案。宝亮曰。就略答中。先开三句。释所以覆相说之意也。明佛初出世。众生智浅。未堪深法。不得说同体三宝。上得说断灭无余。作常住清净无差别也

善男子佛亦不说佛及佛性(至)常恒不变无差别耳

案。僧亮曰。第二释。亦不说佛性与涅槃是一体。但说无余空涅槃。作常恒不变者也

善男子佛亦不说涅槃实相(至)常不变易无差别耳

案。宝亮曰。第三释。明于时亦不得说涅槃实相是一体。唯得说无余空。作常相实不变易无差别也

善男子尔时我诸声闻弟子(至)却后三月当般涅槃

案。宝亮曰。所以唯得说无余空作实者。为有放逸弟子故也

善男子因如是等恶比丘故(至)而我实不毕竟灭度

案。僧亮曰。答第三难。三宝义异。常住清净不异故。说一不三也。宝亮曰。广呵声闻弟子之失。叹识六行之得也。若果会偏学。已会圣者。此中不应言声闻之人。是魔眷属。非我弟子

善男子如生盲人不见日月(至)却后三月我当涅槃

案。宝亮曰。为声闻作譬也

善男子如来悬见迦叶菩萨(至)却后三月当般涅槃

案。宝亮曰。明直是如来。现婴儿行。接化下愚。宜须此说也

善男子何因缘故我于往昔(至)魔王波旬不般涅槃

案。僧亮曰。答第四举昔旨。以成难也。僧宗曰。举第一难以答也。昔言未有多闻弟子者。欲为五比丘等。故言不入。非即是真涅槃也。宝亮曰。次答向未有多闻弟子意。我尔时为一人故。根栽应熟。所以不入涅槃

善男子有名涅槃非大涅槃(至)亦得称为大般涅槃

案。僧亮曰。答第二难也。明见佛性故。得名常乐。若不见佛性。则习气未尽。不得常我。但分段苦尽。得名乐净耳。僧宗曰。答第二问也。明菩萨少分断故。未足可名也。宝亮曰。次答第二有余难也。昔指烦恼无处。为有余。不指身智尽。今日据身心上立。随行人所断。除因灭果。故称之为有名涅槃也。

善男子般涅言不槃者言织(至)无障碍义乃名涅槃

案。僧宗曰。广释不织等义。为成真涅槃义者也

善男子有优楼迦迦毗罗(至)具足成就第七功德

案。僧亮曰。既已事证。重释涅槃名义于灭有也。断烦恼不名涅槃者。断烦恼是智也。烦恼不生是灭也。僧宗曰。已明菩萨未极。唯佛是极。则第四难。自然释也。宝亮曰。此是因中小分无苦。非一切苦尽。故不名大涅槃也。佛果妙体。生死既尽。无患累体。不复生烦恼。具一切德。始名大涅槃。非直是烦恼无处也。是故。以五法同体来证。今涅槃。与昔日异也。何者。为五。一明佛不更起烦恼。二明体穷如理。三明鉴境已周。四明普应无滞。五明体是实相。既备此五德。妙有常存。岂非今昔涅槃之异耶

大般涅槃经集解卷第五十一大般涅槃经集解卷第五十二

  广释心性本净不与贪俱　四句释贪义有心共贪俱生不共贪灭等

    德王品之第八

善男子云何菩萨摩诃萨(至)心善解脱慧善解脱

案。僧亮曰。凡九法声闻。求佛次第也。初四法。分段因果中。三法修行大乘。后二法成佛事也。宝亮曰。九事下文。自次第释也。五阴为果。五见为因。因断故。言断阴耳。宝亮曰。夫功德之名。是赞叹之称。而第八功德。以九聚法为体。始学者之所行。资涅槃之要路。大论九聚。不出两意。初有二聚。明其所离。后七聚法。谈其所得也。其所离者。谓除于五阴。及于五见。若述其所得。乃有七聚。七聚之中。复不出自行外化。故守护一事。反与四等。通为被物。然此两事。要于旷济边美。就化他而作位。余六念等五聚。悉据自德。而受名也

善男子云何菩萨除断五事(至)以是义故方便令断

案。僧亮曰。小乘厌苦。除断五阴也。宝亮曰。既依六行。理以忘怀。亦无有善。不而树故。积劫为心师。要依此理教。而得出也。是以始学之家。先观五阴为本。既达身是虚。必修善而断。故今先观五阴为始也。受者百八者。此是一方之数。受是三受。三受有二种。谓净受不净受。就六根中作位。两受皆然。则一根中有六。若六根具六。便六六三十六。就三世中往分。便成百八受

云何菩萨远离五事(至)是故菩萨防护不近

案。僧亮曰。欲灭五阴。先除五见也。宝亮曰。第二聚也。见是推求之性。耶执之重位。因于此五。能广生六十二见。菩萨知此是生死之本所以防而不起也

云何菩萨成就六事(至)是名菩萨成就六事

案。僧亮曰。道见由道。次第说道也。闻修定在死尸间。多怖畏。令修六念。以除其畏也。僧宗曰。前三念是外念。次戒施是内行。后念无是未来果也。宝亮曰。第三聚也。自佛出世。便有此六矣。梵行品已广释也

云何菩萨修集五事(至)是故菩萨勤心修集

案。僧亮曰。由念成定。初四禅后一是慧。具此四法。则离分段苦也。僧宗曰。初知定者。谓禅定也。以音声刺起觉知之心下。次明诸禅也。寂定者。二禅定坚固。不为觉观所乱。诸识灭为寂定也。身心快乐者三禅乐支满是也。无乐者。四禅以上至非想。无四受之相。因此四定。能发首楞严也。宝亮曰。第四聚五事。一谓知定。初禅定犹未免觉观。故受知名。二寂定者。二禅觉观已灭。心虑转静。外缘难动。故称寂定。三受快乐定者。二禅犹为喜所漂流。未若三禅喜踊已断。身心怡泰。故受快乐之名。四无乐定者。四禅灭乐。无复有分别之念。以舍受为体。故称无乐定也。若能得此四定。于缘中忘相。称真俗二谛。智慧解穷。名首楞严定也

云何菩萨守护一事(至)是故菩萨守护一法

案。僧亮曰。始发心求佛也。宝亮曰。第五聚也。谓菩提之心。菩提名道。此行人始习心也。一则远求佛果。二为拔彼苍生。若能守护。此心必克菩提也

云何菩萨亲近四事(至)是故菩萨系心亲近

案。僧亮曰。长养菩提。由四无量也。宝亮曰。第六聚也。向虽辨发心。若不造行。则果无由得。今明外化。以与四等三心。愿彼我同安。若习此慈。成登于初地。虽有四异。通为一慈。但从其始学。就阶级而明耳

云何菩萨信顺一实(至)是故菩萨信顺不逆

案。僧亮曰。四等成就。得入大乘也。宝亮曰。第七聚也。实谓大乘无相之解。菩萨知取相为过。舍相是道理。归一实。更无异涂也

云何菩萨心善解脱(至)昔所不至而今得至

案。僧亮曰。入大乘故。然后具有二事也。宝亮曰。余第八第九两聚。但义分为二心。所以不自在。由爱着为碍。若鉴境虑明。必由无障。今烦恼既尽。无惑可拘。闇用都除。名心解脱。若有迷之时。于境不明。今无碍可障智。故名慧解脱。然初学之家。必从浅之深。故先据阴为始。成智慧为终也

尔时光明遍照高贵德王(至)心解脱者是义不然

案。僧宗曰。难前第八心不应解脱。寻初以实法为难。广设譬。明心无缚解也。第二难意贪亦是有。以心本有贪性。则不可得解。第三言见相。然后方生者。以此证贪。不但在于心中。境中亦有贪也。正以心中有贪。境亦有贪。体性如之。岂可改耶。第四难。言不定也。若于一缘。定起贪者。则定以不净观除之。今一境。或时生贪。或生嗔痴也。心亦不定。或起于贪。或起嗔痴。是则心之与境。二俱不定。既为不定。则不可断。既不可断。则无解脱也。宝亮曰。于未达之流。触事成执。便谓心本无系。不应称为解脱。故德王今者。出四家定性之执。谓佛解释。证耶非而显正是也。第一家云。六识初造缘。当于心位。然贪嗔用起。要在行阴前识心之时。既未有贪。云何言系下。便引八事来。证成心无系义。第二家执言。贪亦是有。明贪嗔乃至解脱。悉一时并有。事如束竹。但用有前后。故不作二种譬来证也。第三家执。从譬如钻火下去。明众缘中。各有少注贪。如五缘生眼识。一一缘中。尽有识性用。要聚合共生贪也。第四家执言。心亦不定贪与解脱。为自性。悉不从因缘

何以故心本无系(至)何等因缘而能得系

案。僧亮曰。上说得三解脱之行。得中道空义。将说中道。先说不会中者。有三也。先说因中无果者。心本不系者。如眼识取色。未有烦恼。不为烦恼所系也。僧宗曰。贪与净心。一起一灭。未曾相值。所谓诸法不相待。乃至一念不住也

如人构角本无乳相(至)云何贪结能系于心

案。僧亮曰。心时无贪。则非贪因。因尚不生。何因而系心也

世尊譬如押沙油不可得(至)云何而言心得解脱

案。僧亮曰。心与贪垢。净秽不俱也。何能污心者。设贪后起。前心已过去。一有一无。何能污心也

世尊贪亦是有若贪无者(至)若心有贪云何见相

案。僧宗曰。第二难也。譬如人见尽女者。此防伏释也。他人通言。遇缘起贪。贪由于境。何必在心。若作此通者。今复以譬遮之也。如画女生贪之时。此画岂是贪耶。当知在心也

然后方生不见相者(至)诸佛菩萨而不生耶

案。僧亮曰。第二说本有贪。以贪为性。亦无解脱也。此明不独心有。缘中亦有也。僧宗曰。第三文也。若境中有贪。而心复有贪性。二处相资。其性则重。故堕恶道

世尊心亦不定若心定者(至)修大涅槃心得解脱

案。僧亮曰。第三不定门。明心定则无贪。不定则无心。皆无解脱。下类尔也。僧宗曰。第四难也

尔时世尊告光明遍照(至)一切诸法无自性故

案。僧亮曰。上三难。求法定相。求定皆无善。其能解也。僧宗曰。答第一难也。亦不为贪之所系者。实法则无系也。亦非不系者。假名道有系也。解脱非解脱。亦如是也。非有非无者。实法当分自灭。故非有移时不灭。以其相续。而言非无终一法也。非过去者。非过去独有缚解。乃至见伏。未来亦尔。言假名相续。经移三世。得言本缚今解也。正以如假实之旨。则初难释也。宝亮曰。将欲非其所执故。先略解正义。然后破其执心也。亦不为贪结系者。前识心未起贪。故言不系。亦非不系者。此语有二种。一实录中辩系。二假名相续中明系。如先起一念贪。自未有治道来翻。得言心常被系缚。此是实录系也若相续道语用后来。系前乃行。心方起贪。要后心起贪。染累于前。亦非不系也。非是解脱者。道心起时。无惑可断。故非解脱也。本痴而今解。亦非不解脱也。若因缘未会。故言非有。缘会便起。故言非无也。非三世者。明三世中。当体即灭。过去已无。未来未起。现在不停。云何有贪。何以故。法无自性也

善男子有诸外道作如是言(至)色有着义心有贪性

案。宝亮曰。次非外道耶执也。先第三家为始至第一。然后非第四家也。非第三家言。外道无智。云众之中。各有贪性。此悉是耶执

复言凡夫心有贪性(至)虽作此说是义不然

案。僧亮曰。成其偏见。非先所说有者之失。悉无有果者。成说无之过也。僧宗曰。正义所明。诸法无定。缘会则有。缘离则无。以无定故。其二难自除也。宝亮曰。次非第二家

有诸凡夫复作是言(至)粗无常故果亦无常

案。宝亮曰。非第一家执也。谓细广则常。粗故无常。如识心无贪。第四方有贪也

善男子有诸凡夫复作是言(至)轮回六趣具受生死

案。宝亮曰。非第四家也。有为生灭之法。悉从缘起。故非自然也

善男子譬如枷犬系之于柱(至)从非想退还三恶趣

案。僧亮曰。细即是常。粗即无常者。微尘合则成缘。散则归本。尘常而缘无常。尘无缘也。不能知心因缘者。着因果有无。不知心因缘也。宝亮曰。以六譬总呵外道之计也

善男子诸佛菩萨终不定说(至)非有非无果

案。僧亮曰。已说有无者之偏。欲明四执。皆不会中道。答第三不定难也。僧宗曰。答第四难也。有无不可定说。但有则众缘故生。一境起三乃至无量。亦复何嫌。但使识解惑之缘耳。宝亮曰。下去解正义。将明中道。故先出耶说。若当定作此四句。计因中有果。因中无果。半有半无。非有非无。皆不免生死。必系属于魔说。若从容称当中途。不乖正理。心无所执。此名中道。诸佛菩萨。虽说说法非有非无。亦不决定有也。若是有者。可得定说有。即不有亦无。无可无。云何决定。如五缘生眼识。若少一缘。识则不生。然此识亦不定属一缘。复非中间缘具便发。而非有非无。以从因缘起。故名为有。体无自性。便说为无。若作如此之说。体万法虚。离有离无。是名正义

若言因中先定有果(至)不知心相及以贪相

案。僧亮曰。释所以不说见说者之过也。宝亮曰。既已略明因缘之法。非定有定无。下即出惑体以对之。从缘起。所以非无也。贪无自性。所以非有也。贪之与解脱。皆无自性也

善男子诸佛菩萨显示中道(至)非有非无而不决定

案。僧亮曰。非无不偏。故名中也。虽复中名是同。中义异故。言不定也

所以者何因眼因色因明因心因念识则得生

案。僧亮曰。识于四因非无

是识决定不在眼中色中心中念中亦非中间

案。僧亮曰。识性是一。五处求之。不可得故非有

非有非无从缘生故(至)说言诸法非有非无

案。僧亮曰。称名解义也。心于因中。非有非无。是俗谛中道也。即论心性从因生故有。无自生故无。是真俗中道也。若就空本而言。此有亦无。此无亦无。是真谛中道

善男子诸佛菩萨终不定说(至)本无贪性故说非有

案。僧亮曰。已说中道。方得正论。心性不定

善男子从因缘故心则生贪(至)二者随大涅槃

案。僧亮曰。心既不定。则缚解从缘生也

善男子有因缘故心共贪生(至)不共贪生不共贪灭

案。僧亮曰。开为四句。明于大理则通一切心。第一句云。心共贪生。共贪俱灭者。此言不得局取。若就文为语。似如行者起贪。经三相谢。其生相时。有住灭。已无恐义必不然。故一家解云。小复长取。若行人起一念贪经。莫问其性灭。得言常痴。何故尔。既用法性为神解。主于生死。俗谛用边。自可三相。就真谛边。往取痴义恒在此。既是翻真之用。若无解来遣。那得已无。故下文言。烦恼亦常。断常烦恼。故名无常。所以四时经教。未出神明之妙体。唯就生死边为论。但言起一念惑。三相即谢灭。故继之为成就。亦不道有所属。而唱此成就者。乃意在于真边。今教方得现此意。故唱烦恼常。得知起贪后。从来得治道。来生相时亦痴。住灭时亦痴。故言共贪生。共贪但灭也。第二句有共贪生。不共贪灭者。若起惑已后。未得治道。常共贪俱生。今明从四念处观去。至得无漏。永不复与贪俱。故后解现前。无复本痴。故不共贪灭。亦不道三相生灭法也。第三句有不共贪生。共贪俱灭者。若菩萨已得真解。无复有贪。而示现有贪。为接物生。若令道心得成者。此名不共贪生。共贪俱灭也。第四句言不共贪生。不共贪灭者。谓诸佛菩萨不动地。自罗汉辟支之流。皆正观现前。皆不复与贪俱也

云何心共贪生共贪俱灭(至)心共贪生不共贪灭

案。僧亮曰。俱生俱灭者。从死也。俱生不俱灭者。生死涅槃两从也

云何不共贪生共贪俱灭(至)心性本净性本不净

案。宝亮曰。二句但涅槃也。除不动地者。初不动地。有共贪生。而不共贪灭者。故除之也

善男子是心不与贪结和合亦复不与嗔痴和合

案。僧亮曰。上说共生。人谓。心贪一时和合。今明不尔也。宝亮曰。定其位也。若心在此。而贪居于彼。可使两来共合。理既不然。云何和合耶。亦非不和合。遇境即起。但无别合法可得也。若净心行缘。则名为善。不净心行境。便名为恶。故诸佛菩萨。破贪欲尽。无复惑障。故心得解脱。凡夫之人。具贪欲结。烦恼所缠。常居中也

善男子譬如日月虽为烟尘(至)从因缘故心得解脱

案。僧亮曰。人谓。不一时故。贪不能障心。以烟云为譬。虽远而能障也。宝亮曰。此下诸譬。明外道凡夫。及与魔王。俱乐生死五欲。永无出期。下自有合

善男子譬如雪山悬峻之处(至)摛捕弥猴负之归家

案。僧亮曰。雪山者。与缚解为譬。俱不能行者。譬解脱也。人不能行者。譬初缚后解也。二俱能行者。譬俱生俱灭。在生死也

善男子譬如国王安住己界(至)系属魔者心不清净

案。僧亮曰。总譬不从理是缚。从理是解。大明缚解也

复次善男子若见诸法(至)具足成就第八功德

案。僧亮曰。显见法之惑。是不从理也。说见有三。初广断常见也。中但说有。后说我见是本也

大般涅槃经集解卷第五十二大般涅槃经集解卷第五十三

  辨信　辨直心　辨戒　辨善友　辨多闻　论阐提有佛性义　释阐提名　释九地菩萨见法有性所以不见佛性　明法佛有二种说一者有性二者无性为众生故说为法性为诸贤圣说无法性　辨菩萨无所见即一切法　辨大涅槃空　出阿难不见空事　辨信不信相

    德王菩萨品之第九

复次善男子云何菩萨(至)四者亲近善友五者多闻

案。僧亮曰。第九病行功德也。病行说五行之始也。信为行首。故先说也。质直者。信恶则不作。信善则勤行。故次说直心也。身口之恶须戒。故次说戒也。行善须师。故次说善友。近善友而闻法。故次多闻也。僧宗曰。既通广前三行。随明戒定。有相似处。即杂广上义也。宝亮曰。以此法为体。从信心为始。乃至多闻

云何为信菩萨摩诃萨(至)修大涅槃成就初事

案。僧亮曰。信三宝者。知归处也。然归必须行。以施为行始。次说施也。行即是乘。乘有实假。次说二谛。以一乘是第一。二乘是世谛。下释云。速得解脱者。小乘是迟。今说为速。于小者是速。若不说小。则永处生死。说则离故。故名速也。圣人性者。不坏信也。宝亮曰。夫信有三品。从外凡夫。讫闻慧中人。悉通名为信。信乃万阶。要居不定位故。来为下品。若信首五根立。至世第一法。名曰中品信。受得真无生解。去至九地。通为上品信。然此中所明。信取于中品。何以故。因此信立。资之入空。登见谛道。自此以前。下品之信。非不远藉。但未是坚固。位既未定。所以不录。若远途而相承理故忘言。然入佛法海。要须信为首。此心亦立。佛法中宝。自然次生。是故今者。先标归三宝为初。表信立之始也。虽复信有三宝。若不信有行六度之因。其行亦不成。是以经文广列所信之事。然此中列信境出二种。第一义谛。无信于二谛者。信生死是忘有。即体无性。此据大品以来。开空有二门。后更称信。第一义谛者。信神明妙体。真如之第一。故知。今教所明真者。非昔教之性空。若此信一立。便识生死虚妄。依如来藏。有修道断痴。除因灭果。显出法性之涅槃也

云何直心菩萨摩诃萨(至)若生烦恼则堕恶趣

案。僧亮曰。先就化物边辨直心。后更约事。明但使关理莫闻耶正。皆称直也

如是菩萨若见众生(至)发阿耨多罗三藐三菩提心

案。僧亮曰。终不说之者。说恶增二罪。赞善长二福也。云何为善。所谓佛性者。善中之少。唯阐提也。宝亮曰。谓正因性也。唯此为真善。而非是缘中所生者。若举用来明者。能得于善果。亦名曰善。为物说言。身中有佛性。令心欢喜。发心行道

尔时光明遍照(至)发阿耨多罗三藐三菩提心

案。僧亮曰。难意谓。若阐提闻赞佛性。而发心速者。上云不治之义。则非也。举上五行之始。阐提不可治之文。此第一难也。僧宗曰。第一有三种病人者。难直心也。言不应叹佛性。发菩提心也。何以尔耶。上说三种有自然可差。有毕竟可治者。如其自差。则不假叹性。知其必死。虽叹何益。虽引三人。意欲取二人为难。宝亮曰。德王仍设五难。所以建章唱言。初发五事。悉得成就者。若此五事成。则能除病。若不成就。便不能治病。今去还明三种病人。故知广病行。第一难言。如来上说三种病人。第三人闻法不闻法。自然得佛。今云何言赞叹佛性。令众生方发心耶

世尊若遇善友诸佛(至)得阿耨多罗三藐三菩提故

案。僧亮曰。第二难也。僧宗曰。第二难言。不能发心。复不然也。若言有性。必当成佛。宝亮曰。第二难言。第一人若闻法不闻法。皆不能发。是亦不然。此人有佛性。佛性是善。自能向佛。佛何故言都不能发心耶

世尊如佛所说何等名为(至)云何佛说断诸善根

案。僧亮曰。第三难也。僧宗曰。第三难言不可治。若遇不遇。俱不可治者。夫为恶不过阐提。此人既有佛性。此不可断。当知断善之言。未为理实也。如佛昔说十二部经善有二种者。此第三家子句言。既不断佛性。便是性在身中。既在身中。便应遮地狱。此就见用为难也。宝亮曰。第三难不应受阐提名。就此难中。开为两关。若阐提有佛性。佛性是善。何故言断诸善根。名一阐提耶。后关言。如佛昔说十二部经善有二种。一常二无常者。难意。用正因性善作常。缘因善作无常。若如此缘中所生善。虚而无力。可不能遮地狱。正因性是常。力用应强。何故不遮一阐提不入地狱耶

如佛往昔说十二部经(至)作如是说言一阐提

案。僧亮曰。第四难也

世尊若因佛性发阿耨多罗(至)三菩提无有是处

案。僧亮曰。第四难也。僧宗曰。第四难言因佛性。自然成佛。不假广说十二部经。宝亮曰。第四难从若因佛性。发无上道心。下明佛性力强。应自然成佛。何须广说十二部经。劝人修行。下即引二譬来。助其成难。喻正因力。应自至于佛也

世尊诸佛如来说因果性(至)如是之义云何相应

案。僧亮曰。第六难也。僧宗曰。第五执因中已有佛性。故得成佛也。宝亮曰。第五难言。说因果性。非有非无。亦复不然。若因中无果。云何能生佛菩提树。正以有故。能生也

尔时世尊赞言善哉善哉(至)能摧波旬所立胜幢

案。僧亮曰。将欲答问。先赞叹也。僧宗曰。答中先答第二。次答第三。次答第三家子句。因答子句。义势似答第一第四。别答第五也。宝亮曰。将欲答难。先赞叹之。明已问得时。师徒二人。互相称誉也

善男子如我上说三种病人(至)若不遇者则不可愈

案。宝亮曰。释二乘人。何以故。此人有九因缘不能去。若无此九事则去。何者为九。一知食不安。而反食者。二乘人自知已所得果。不如于他。而强执为是也。二多食者。二乘人求果心并故。所以不能远取佛果也。三宿食未消。而更食者。有漏中四倒。伏而未断。而今更起佛上四倒也。四大小便利。不随时者。执相心固。断结不以理也。五病时不随医教者。不行菩萨大乘之化也。六不随瞻病教者。不从善知识也。七强耐不吐者。强执二乘果为是。不舍小而从大也。八夜行者。无明心多也。九房室过差者。欲速灭此身。无余之乐。正有九病。若闻法即回心而去。如其不回。则难可开化

善男子如我上说若遇不遇(至)若不值遇则不能发

案。宝亮曰。答初难也。僧宗曰。先腾三种病人。未是答也。宝亮曰。先释第三人。决定去者。此人殖因久。自能向佛。不假闻法

如我上说若遇善友诸佛菩萨(至)何以故以命尽故

案。僧亮曰。答第二第三难也。僧宗曰。答第二难也。其难言。既遇与不遇。悉不能发。此人当得菩提。今答言。阐提时断善根。及其后生善之时。非复阐提。此人遇与不遇。俱不离阐提心。是故言不可治。不言断当性也。宝亮曰。答第二难。言若阐提有佛性。决定不去。是亦不善。佛答意云。我言不能去者。此当阐提心时语耳。不言舍阐提心后。亦不能去也。其未舍阐提位时。虽有佛性。而非是善若舍此心后。非复一阐提。云何不能去耶

善男子一阐名信提名不具(至)诸善法故名一阐提

案。僧亮曰。答第四难也。僧宗曰。此答第三难。其难言不断佛法。云何言断善根。今答言。一阐名信。提名不具。信不具故。名一阐提。岂以无师佛性。名阐提耶。宝亮曰。次答第三难。难言。阐提有佛性。云何名断善根。佛今答言。不具。信故。名一阐提。明佛性非信。善亦不从具生。众生五阴。是发信心之具。正因佛性既非善。又不从五阴具生。云何可断。若正因佛性。从五阴具生。然则众生五阴。是发佛性之具。经亦不应言佛性非信。众生非具。以此义推。当知。众生五阴。依正因性有。非是正因性。依五阴有。然此中推检。与胜鬘经明义一种生死。依如来藏有也。非如来藏。依生死故。得知文义微证理[目*交]然矣。下去诸句义例亦尔。但佛性非是缘中所生之善。又非是不善。何以尔。正因之性。既不从方便而得。云何可断。然能得善果。复非不善。阐提乃断缘中所生者。故得一阐提名也

善男子如汝所言(至)即堕三趣故名一阐提

案。僧亮曰。答第五难也。僧宗曰。答第三子句也。以当有故言有。既非已有。云何责能遮地狱耶。譬如王闻箜篌音者。此成向答也。言欲闻其音。必须方便。不可一往而求。佛性亦尔。要假方法也。因此仍答第一第四难也。其第四言。若有佛性理然自成。何须说十二部经。今答言。虽是有性。要须说。亦如箜篌之音也。第一难言。若必不差。则不须治。今答言。虽不可差。既不断佛性。若闻说十二部经。则为外缘之益也。宝亮曰。牵第三难后关来。仍答第四难云。一阐提实无果性。若使有缘因之善。可遮已不入地狱。即既无缘因善。云何得遮耶。登即引譬。明凡夫愚痴。无有智慧。闻佛说众生身有佛性。谓言此五阴身。即时已有一切种智。十力无畏。不假修行。卧地自成。责佛现有此不当是无道用心。然众生之身。即时乃有正因。要应积德修道。灭无明障。闇黑都尽。佛性方显。缘具之时。尔乃有用。其事如箜篌。要须众缘具。故声方出耳。今一阐提。正断于信心。故堕三恶道也

善男子如汝所说若乳无酪(至)不讼彼缺名质直心

案。僧亮曰。答第六难也。僧宗曰。答第五难。今言不得一向已有。以当有故言有也。如乳卧至一月。则不生酪。若以一渧。颇求树汁。至即成酪。以其缘具足也。若乳中先有酪者。何须待缘耶。难作能作者。言政以具此直心等五事。所以能为此难忍之事。乃至不惜躯命。深识空相故尔也。宝亮曰。答第五难。执因中有果。今明万法从缘。无有自性。若缘会则有。未会便无。岂容因中已有果。若已有果。何须众缘。以无性故。故得成佛也。答难既竟。还举前结句。以是义故。菩萨常赞人善。故名直心。结句后偏就菩萨心。约事来明直心也

复次善男子云何菩萨质直(至)是名菩萨质直心也

案。宝亮曰。向解释未周。便致问难。答既已毕。更修前宗也。宝亮曰。答难已竟。举前以结旨也

云何菩萨修治于戒(至)修大涅槃是第三戒

案。僧亮曰。尸波罗蜜者。无上四恶。能度苦海之称也。宝亮曰。戒从信生。道心既正。所发之戒。不见戒相。为波罗蜜也

云何菩萨亲近善友(至)具足第四真善知识

案。僧亮曰。一主浣衣者。知垢净故。应教不净观也。一金师子者。知风火之气。应教数息也。宝亮曰。真善友者。唯诸佛也。今命篇举菩萨者。以具上三心。能近善友。复能为人。作善友也。未具足故。乃引事为证

云何菩萨具足多闻(至)成就第五具足多闻

案。僧亮曰。多闻本使息苦。不必文广事多。唯在理深除惑耳。宝亮曰。第五具足多闻者。若随言而取。唯是闻慧。不通思修。然此中释意。恐备合三慧。今辩多闻。便有六阶。从浅之深。靡所不收。第一就小乘十二部。明多闻。第二重置于十一部。唯取方广经。亦名具足多闻。第三除法华以前经。十二部唯受持。今涅槃经为多闻也。第四就一四句偈。如雪山菩萨中说。第五直据常住二字。第偏谈法性妙体。如如常不说法。绝于言相。以为多闻。若能如此冥至理。最为第一多闻

善男子若有善男子善女人(至)难忍难施亦复如是

案。僧亮曰。难施能施者。作义是总。施义是别也。何者。外事横来。能安为忍。舍由内起。能安为施也

善男子譬如父母唯有一子(至)何以故修空三昧故

案。僧亮曰。举二事。一谓慈悲。二谓解空。以此二事。不见其难。故能为难事也。宝亮曰。次从难作能作。下去开为三事来。赞叹上成就五法人。正以资上所解。便悟万法虚假。有所施为。不问自他。无复分别。若微有所存。便乖于理。何故如此。正集空智力尔。终日为物。竟无所为也

尔时光明遍照高贵德王(至)虽复修空不能令空

案。僧亮曰。欲明修空之为益。故假难以显之也。僧宗曰。一切诸法。性自空者。承前言为难。前言以善识空。能为难忍。今问识空之旨。设二难也。若性自空。空则无见。若性不空。虽修何益。僧亮曰。时众于此空理。恒生怖畏心。未能顿忘。故德王因此。仍设二难。去物执有之心也。佛上言修空三昧。无复嗔喜。今将开两关。故先定言一切诸法。为当体性自空。为万法不空。菩萨修定之智强。使作空耶。仍结初难云。若性自空。何须修空耶。第二难云。若性自不空。云何修空。其令空耶

善男子一切诸法性本自空(至)诸佛菩萨是魔眷属

案。僧亮曰。非地水火风。不离地水火风者。五根是假色。是则根一。而大四故。第一义空不离四。而说俗谛空也。俗谛空故。无一等四。执为空也。非青非黄。破实色亦尔。非有非无者。具三中道空也。以相似相续似常也。凡夫不了。说有说常也。宝亮曰。就佛下答去。先遣第二难言。一切诸法。性本自空。万有若是可得不空。有竟无可有。岂有可得有乎。既不可得。故知。从本来不异空。但于病者为有。于觉者常无。故一家所引。如虚空华。于不病者。未尝有也。虽于病者为有。于不病为无。而不病之者。亦非不知。病者之妄见。故圣监之日。二智无亏。是以梵行中言。一切世谛。于如来尽是第一义谛也。从色性不可得。下更据法来明。先破假名色。非四大者。明地水火风。本来性空。无有自体。此明真谛不离地水火风者。不离四大有用。此是因缘虚构。但有名用。明俗谛也。非青黄赤白者。次破实法色。明青黄色等。本来不有。此是真谛。不离青黄等者。亦是虚构因缘妄有。但有名用。此明俗谛。有竟不有。亦无有可有。无竟不无。亦无无所无。法相如此。岂不空耶。正以菩萨具上五事。见万法空。所以无复嗔喜

善男子一切诸法性本自空(至)见一切法性皆空寂

案。僧亮曰。次举初问来答。法虽自空。若不修空。则不识有为不有。要须体有。方得会空也。因此下即借譬来辨。如一切法。性无常故。灭能灭者。非别有一灭法能灭。即法体起时。字之曰性。法体灭时。谓之名灭。明万法亦然。直体性空。故修空见空。亦无有一空法。来空此空也。虽引譬证体相是空。但人情。于上譬中生疑。今且据向塔喻。为语也

光明遍照高贵德王菩萨(至)空是无法为何所见

案。僧亮曰。空者。便承闻为难。异物本无具难碱。物本无碱性。而使作碱者。非空则为倒也。若唯空复无所见。更成前难也

善男子是空三昧见不空法(至)夜为夜相云何颠倒

案。僧亮曰。法无常故。灭能灭者。如木无常。火能焚之。生能生之者。牙有生相。水谷能生也。善男子见不空者。答其初难。不言性不可空。就世谛假。用于众生心之所见不空。今如假而识即是照空。是以非倒也。如贪等。但就世谛是有。得恶果报。乃至色性。亦如是也。若凡夫定执为实。可使是倒。明菩萨不作此解。非倒也。以夜为昼。则为倒。此明如假而知。如空而识。岂为倒哉

善男子一切菩萨住九地者(至)以不见故则见佛性

案。僧亮曰。见法有性者。见空则见常也。九地不见常。以不见空。是故十地。但少见也。宝亮曰。经文正自如此。故知。九地以来。唯见无我空。非真无相理也。既所观是事。无非真我空。故言。见法有相。非是执性见有。正以修无我多故。未能见佛性也

诸佛菩萨有二种说(至)以是义故修空见空

案。僧亮曰。虽渐教说有。终期为空者。见法空故。修空三昧。令得见空。无法性者。亦修空故。以是义故。修空见空也。宝亮曰。有法性者。云有世谛用也。无法性者。明本来是空。正以不见空故。令修空。以得空。是以修空三昧也。亦因修空故。见诸法空也

善男子汝言见空空是无法(至)见一切法性无所有

案。僧亮曰。法性无有。菩萨则无所见。与法理会。假称为见。实非见也。宝亮曰。次答后关也。实如汝问。若存有所见。非谓为见。菩萨所见。故见佛性也

善男子菩萨不但因见三昧(至)见一切法皆悉是空

案。僧亮曰。不但三昧见空。六度亦空也。宝亮曰。遍历六度万行。明无性相

是故我在迦毗罗城(至)成就具足第九功德

案。僧亮曰。举事以证释也

善男子云何菩萨修大涅槃(至)入大涅槃常乐我净

案。僧亮曰。以自涅槃。复能教人。令得涅槃为体也。此先说自得者也。僧宗曰。第十功德。以三十七品为体者。此三十七品。即有戒定慧。可以广前。随于三行之中。有明戒定慧处。悉可以广也。何等众生。于此经不生信者。言于经生信。则能行三十七品。终得成佛。若不生信。则永沦生死。明十功德既毕。冥诫未来。可不染生敬信也

为诸众生分别解说(至)若不信者轮回生死

案。僧亮曰。教人令得

尔时光明遍照高贵德王(至)于是经中不生恭敬

案。僧亮曰。上说有信者得。不信者不得。今问信不信相也

善男子我涅槃后有声闻(至)是名甘露贸易毒药

案。僧亮曰。说破戒者不信

以如是等恶比丘故(至)不能信顺是涅槃经

案。僧亮曰。破见者。不信也

善男子当尔之时若有众生(至)即见佛性入于涅槃

案。僧亮曰。还结信者。不治自差也

尔时光明遍照高贵德王(至)具足成就第十功德

案。僧亮曰。领解也

大般涅槃经集解卷第五十三大般涅槃经集解卷第五十四(师子吼品第廿三)

  举十一事释师子吼义　师子吼六问问佛性　答第一问　答第二问　答第三问　答第四问　显众生不见佛性无明[雨/復]故又未能度十二缘河犹如菟马　辨十二因缘因重果义　辨十二因缘甚深不断不常非二乘所见　辨见十二缘智有四种　辨十二缘则是中道佛性

    师子吼品第二十三

案。僧亮曰。答第三十四问。一切诸法中。悉有安乐性。唯愿大仙尊。为我分别说。上长寿金刚因果五行十功德。义有多涂。大而言之。不离涅槃。因果佛性。今明性名虽同。因果相异。识之则不违。如师子吼问是也。不识则违。后迦叶问是也。说法既久。人情已怠。故命众令问。而师子吼好问佛性。即以问者。为品名也。僧宗曰。自前以来。第一明经理教。是经之正经也。既教圆理满。能灭恶生善。力用弥旷。胜于余典。故第二广叹也。既如此胜益。岂可不依经修行。故第三广明五行十功德也。夫行之所生。专在照境。境中之妙。唯佛性。自此下答第三十四问。一切诸法中。悉有安乐性也。夫圣人互相影响。知答时在此。因机致问发言。虽复对师子吼。而其旨所指。实答迦叶问也。宝亮曰。师子吼迦叶。同答第三十四问。上已明行体。今次明所发行之缘。若当不识因果之性。则不成中道。故次就缘中。以问行也。今者广明因果性体。使物识而行成。早出于生死。智秀曰。经之大段第三。重明佛性义也。大判有八段。第一设六问。并答论佛性。第二明中道。第三明缚解。第四辩修道。第五明转障。第六劝。第七辨不退。第八广叹也。明骏案。前五行十功德广行。此下两品广境也。大判八段。不异此释

尔时佛告一切大众(至)有来问我不能答者

案。僧亮曰。上说因果。皆名佛性。若不说识其异。则因果俱昧。昧则生疑。疑则有无未判。故命令决疑也。僧宗曰。将明因果佛性之境故。先广列所疑。劝令问也。僧亮曰。发悟不同。机缘不一。今宜须缦。告为众人之道故。历举法问以为。宝亮曰。大判师子吼所论。不过十段。第一师子吼有六问。佛有六答。先往复辨彰。定因果性体。夫修道若心无所据。则行亦难进。故先明因果性。令指南有在。第二劝信。若于因果性中。信心未决者。劝依十二部经。约应佛观因观果。观如来身口二业。所以而现。若为于物。不为己身。而现世者。得知天下有至极妙果。其理必然。令可得相与修因往趣也。第三明缚解。若于此因果性。信心不立者。则名为缚。若能安于大理。深生决信。则谓为解。第四辨修道。若欲从缚得解。要因修道。故次缚解后。明有道可修。第五明转障。但群生闻此玄言。难为心用。若不以近事来诱。则无容入理。故云。应修身戒心慧。能转重业。人天中轻受。如其不尔。轻业重受。故第六因明劝修。欲得速离重障。要须修道。若不如此。难得离障。第七出能修道人。众生既闻有修道。未知修之方法。故今广明其相。第八叹修道人德。凡夫心志狭劣。谓言日一麻一米。苦难可忍。是以次辨此人之德。明行法得味。不觉为劳。居苦接化。如三禅乐。第九叹经。自不此经中觉。则无由行成。有不思之德。第十叹佛经句。佛居化主。而能便苍生。蒙法得乐。恩德如此。那可不叹

尔时会中有一菩萨(至)如来大慈复垂听许

案。僧亮曰。纵佛不命问。次已至慈旨爰降。即闻命矣。宝亮曰。众时得悟。宜在于师子吼故。所以应机而出

尔时佛告诸大众言(至)是故今于我前欲师子吼

案。僧亮曰。不谈问者之德。则听者不至。故厚加赞叹也。欲师子吼者。师子是无畏之号。唯佛乃具。十地菩萨具三行。能学佛吼。德亦不浅也。宝亮曰。所以先赞叹劝大众。设敬供养者。欲使受悟者。发殷重心故也

善男子如师子王自知身力(至)能师子吼真师子王

案。僧亮曰。叙佛吼之义。初身力智是果也。三行是其本。佛具此众德。故能吼也。四足是戒。三行譬岩穴。振尾出声者。出大悲之事。宝亮曰。身者法身也。力者十力也。牙齿者。一切种智用也。四足者。四如意足也。安住岩穴者。四禅深寂也。振尾出声者。大慈悲也

晨朝出穴频申欠呿四向顾望发声震吼

案。僧亮曰。此四德者。头捋吼益之相也。宝亮曰。此下正述如来。应三界化众生也。晨朝者。众生机发开悟之谓也。赴彼之感。出四禅之穴也。频申者。放光动地也。欠呿者说法也。四向顾望者。譬四无碍智也

为十一事何等十一(至)诸大香象怖走失粪

案。僧亮曰。说为益事也

诸善男子如彼野干(至)终不能作师子吼也

案。僧亮曰。举声闻无师子吼也

若师子子始满三年则能哮吼如师子王

案。僧亮曰。举菩萨有师子吼也

善男子如来正觉智慧牙抓(至)安住四禅清净窟宅

案。僧亮曰。合前穴中事也

为诸众生而师子吼摧破魔军

案。僧亮曰。合第一现作师子也

示众十力

案。僧亮曰。合第二试自身力故也

开佛行处

案。僧亮曰。合第三为令住处净故也

为诸耶见作归依所

案。僧亮曰。合第四为令诸子知处所故也

安抚生死怖畏之众

案。僧亮曰。合第五为群辈。无怖心故也

觉悟无明睡眠众生

案。僧亮曰。合第六为令眠者。得觉悟也

行恶法者为作悔心

案。僧亮曰。合第七放逸诸兽不放逸

开示耶见一切众生令知六师非师子吼故

案。僧亮曰。合第八为令诸兽来依付故也

破富兰那等憍慢心故

案。僧亮曰。合第九调香象故也

为令二乘生悔心故(至)诸菩萨等生大力心故

案。僧亮曰。合第十也

为令正见四部之众(至)四部徒党不生怖畏故

案。僧亮曰。合十一

从圣行梵行天行窟宅(至)如来常住无有变易

案。僧亮曰。合后四譬。说所吼之法。互说令义尽

善男子声闻缘觉虽复随逐(至)而亦不能作师子吼

案。僧亮曰。合野干也

十住菩萨若能修行是三行处当知是则能师子吼

案。僧亮曰。合师子子。三年必能吼也

诸善男子是师子菩萨(至)供养恭敬尊重赞叹

案。僧亮曰。举譬总结劝恭敬也

尔时世尊告师子吼(至)汝欲问者今可随意

案。僧亮曰。赞叹既毕。重劝问也

师子吼菩萨摩诃萨白佛言世尊云何为佛性

案。道生曰。问佛性体也。僧亮曰。第二问佛性体也。僧宗曰。凡六问。前三问。问因果性。后三问。问见义以证有也。此问果性也。果是宗极。所以命言先问也。下答以觉了神慧。体相下改为性也。本有天真之理。在乎万化之表。行满照周。始会此理。不离神慧。而说性也。宝亮曰。举因果两体为问也。为者言作也。谓作若为名果性体。作若为名二因性体耶

以何义故名为佛性

案。僧亮曰。第二问性义也。僧宗曰。此问因性也。谓不改之义。可得在果。而因中。以何理而称性耶。宝亮曰。责所以因果性体。有何所以。得受性名耶

何故复名常乐我净

案。道生曰。从以何义故至此。第二问也。既问佛性。以种生为义。以若生灭。故云何故复名常乐我净耶。僧亮曰。第三问所以得称常等四义也。僧宗曰。通因果问也。宝亮曰。偏问果性。何故独称常乐我净耶

若一切众生有佛性者(至)一切众生所有佛性

案。道生曰。若佛性不可得断。便已有力用。而亲在人体。理应可见。何故不见耶。僧亮曰。第四问若身中必有。何故不自见耶。僧宗曰。举见以辨有无义也。宝亮曰。此问障法也。若必有者。何故不见

十住菩萨住何等法不了了见佛住何法而了了见

案。道生曰。不疑菩萨不了了。仍嫌得见耳。佛性妙绝。备众善乃见。菩萨住何等法。而得见耶。僧亮曰。第五问也。僧宗曰。下有二难。同显见义。而此问据行也。宝亮曰。此问除障法也

十住菩萨以何等眼不了了见佛以何眼而了了见

案。道生曰。既云得见。以何眼见耶。乃以佛对之耳。僧亮曰。第六问也。僧宗曰。前据行以辨见。此据眼者。正以因之异也。宝亮曰。问所以不了。十地何眼故不了。佛五眼之中。用何眼。而独了了耶

佛告善哉善哉善男子(至)诸佛世尊以何眼见

案。僧亮曰。福德智慧。义有短长也。何者。夫作罪则从情为易。修福则逆心为难。难则自策乃成。易则不课自起。以苦灭乐兴。谓福以得不丧谓德也。是则一切众善。无非福德。于中了真者。别名为慧耳。是以无学之地。皆得具其二也。僧宗曰。前后致叹。盖发时人之心耳。宝亮曰。明具此庄严。乃识此因果之理也

师子吼菩萨言世尊(至)云何名为福德庄严

案。僧亮曰。将辨其相。发问以起予。僧宗曰。请释其旨。欲兴后问

善男子慧庄严者(至)乃至般若非般若波罗蜜

案。僧亮曰。目地为行。皆以理解为称。悉是慧也。凡夫取相之福。不能度生死。非福乃至非般若也。僧宗曰。下有三重释也。此第一以住下为福。上住为智慧也。宝亮曰。第一从初地至十地。取缘中忘相正观无漏空解。为慧庄严也。取十地观智。为福德庄严也。乃是双要。是从义取判也

复次善男子慧庄严者(至)声闻缘觉九住菩萨

案。僧亮曰。声闻至九地。有重到未尽。不能少见佛性。不得称慧。上说凡夫。此说圣人

复次善男子福德庄严(至)无有无果报无碍常住

案。僧亮曰。学法为福德。无学为智慧也

善男子汝今具足是二庄严(至)是二庄严能答是义

案。僧亮曰。结二庄严。兴问答也

师子吼菩萨摩诃萨言(至)一种二种者是凡夫相

案。僧亮曰。上说缘有名福德。凡夫法。若尔者。诸法中无二。具二者。不应问。况能答耶

佛言善男子若有菩萨(至)则能解知一种二种

案。僧亮曰。能知一种二种者。一是涅槃。二是生死。皆就有中差别具二。乃见不应言有皆是到

若言诸法无一二者(至)一切诸法无一无二

案。僧亮曰。谓说有无。皆是世谛差别者也

善男子若言一二(至)具二庄严者能问能答

案。僧亮曰。凡夫不见常。不见无常也

善男子汝问云何为佛性者(至)吾当为汝分别解说

案。僧亮曰。将欲答问。先举问而诫令善听

善男子佛性者名第一义空

道生曰。答问佛性体也。要当先见不空。然后见空乃第一义。第一义空。已有不空矣。佛始见之。故唯佛是佛性也。十住菩萨。亦得名见。下至大乘学者。又得名焉。所以举第一义空。为佛性者。良以义类是同。而该下学。用进后徒。不拘常义。而无非是。必可以答无畏问也。僧亮曰。佛智之境。是因性也。僧宗曰。答初问也。初问果。今答云。以觉了为佛。下改名性。为第一义空。举境以辨果智之用也。境下不过常以无常。常是理中之极。故称第一义也。空者金刚。以是体是苦集。不免坏败。故可空也。宝亮曰。第一问有两意。今答亦二别。且先出果性。佛果如如。以法性为体。无一切相。出百非之表。故名第一义空也

第一义空名为智慧

案。道生曰。不兼见不名智慧也。僧亮曰。佛照境之智。是果性也。所以境智双举者。智以照境为能。境若不深。无以显智之能。若智照不明。无以表境之深。要以境智相发。智功乃显也。第一义者是涅槃。涅槃真俗皆实。总名第一义也。空者是生死。生死是俗皆虚。总名为空也。僧宗曰。向已举境。今明善识第一之与空者。即名佛果能照之智慧也。宝亮曰。既解果性。今先举体以取智。若不据用以辨体。无以表因果性异。故明佛果众德。唯以第一义空。为体也

所言空者不见空与不空

案。道生曰。单取前句。非第一义也。僧亮曰。释境空也。生死以痴为本。无所见故也。僧宗曰。简二乘人也。二乘人在无生平等之时。亦称第一。佛果居生死之表。亦称第一人情疑是相滥。是故简之。谓二乘皆不见空不空也。宝亮曰。佛果体圆。中道之解究竟。于时不复见空与不空为异。但一相无相。空与不空。无可为异。故云。唯有智者。能见空不空。六行之解。悉尔也

智者见空及与不空常与无常苦之与乐我与无我

案。道生曰。明兼见者也。僧亮曰。释境第一义也。涅槃以智为主。除颠倒故。不空也。僧宗曰。双识二理。谓佛菩萨也

空者一切生死

案。僧亮曰。重释空也。生死真则无性。俗则无常。故名空也

不空者谓大涅槃(至)我者谓大涅槃

案。僧亮曰。重释第一义也。涅槃真亦无性。俗则常住。故名不空也。宝亮曰。昔明世谛为有。以第一义谛为无。今明生死虚假。空无自体。故名为空。涅槃真实妙有。故名不空。是以一家所解。生死二时是不有。涅槃亦有二时不无也。何者。构因之日。即体虚伪。及至观解。照无一实。故两时推求。并无自性。悉是颠倒妄有。今众生神解。因时已有。修道所除。俗尽真现。两时不空也。所以称涅槃不空。生死为空矣

见一切空不见不空(至)不见我者不名中道

案。道生曰。不偏见者。佛性体也。僧亮曰。释佛智也。先辨偏见者。非佛以非是显是也。僧宗曰。理而为论。岂有不识耶。就教而言。但一向唯作空解。解偏故。不名中道也

中道者名为佛性

案。僧亮曰。举不偏之见。以显照无不周。所以称佛也。僧宗曰。指果地性也。宝亮曰。佛果佛性。方是解中道之理耳

以是义故佛性常恒无有变易

案。道生曰。不偏则无不真矣。僧亮曰。结智所以是佛也。照周则惑尽。惑尽则无变易也。宝亮曰。遂果性体也。向言见一切空。不见不空。不名中道。下举二乘不见。以对明

无明[雨/復]故令诸众生不能得见

案。道生曰。不可以不见为无常也。僧亮曰。答第三问也。境界常有。而[雨/復]故不见

声闻缘觉见一切空(至)无中道故不见佛性

案。僧亮曰。显不见之人也。不见境故。智亦俱亡也。宝亮曰。三乘观道。偏不见第一义空。故不行中道。中道之行既不成。云何能得见佛性耶

善男子不见中道者(至)二定苦行三苦乐行

案。道生曰。三种皆与见中道名也。有真见者。居然自别也。僧亮曰。辨正因缘因性也。凡夫二乘。即情为见非见也。明因有耶正。亦有远近。以三种别之也。僧宗曰。从此下答第二问也。答中凡有三种。初明正因。第二明缘因。第三明境界因。其前问云。生死无常。复以何理。亦称性耶。今先收因地三种人。神明斯尽。以其有正因之义。必有成佛之理。非木石也。因中说果。亦称为性耳。宝亮曰。第二重辨出缘因正因二因性之体也。佛今出三种中道。一定乐行。二定苦行。三苦乐行。云此三人。尽称见中道。故菩萨居定乐行者。解称真俗二谛。终归除苦得乐。津济六道。缘因行成就。可为正位。而凡夫居在苦中。心无厌背。云何见中道耶。故一家解云。夫中道有二途。自有谛二中中道。自有理中中道。二谛中中道解。即是缘因性也。理中中道。即是一切众生。避苦求乐。解正因佛性。夫中道之义。本是称理之心。然有神识者。无一刹那心中无有此解。天下苦实可避。乐实可求。既用心得所。岂非中道。若苦不可避。而欲强厌。乐不可得。而欲强求。此便乖理。然今此心。既不乖大理。云何非解。但此解是境中之用。非造缘之知。亦非善恶因之所生。若善因所生耶。唯应人天中有。三涂应无。若恶因所生耶。则应三涂独有。人天应无。而今莫问人天六道。无一刹那。无此解故。故知此解。乃是妙本之异用。无变改之心也。是以胜鬘经说。出如来藏。与自性清净心。冥会此旨。然则经经微据。理自彰矣。苦乐行。谓声闻缘觉者。二乘人非不厌背求出世之意。故名为乐。封执居心。不免生死。故名为苦。但二谛中中道解不成。非不是善。故属缘因。摄正因性故。自宜有然。今者出三种中道。以为二因之体。二因乃同用真如为体。今唯得据用来辨

定乐行者所谓菩萨摩诃萨(至)阿鼻地狱如三禅乐

案。僧亮曰。见涅槃常乐。知生死幻伪。安之为化。以为苦也。僧宗曰。从初地乃至十地菩萨。致苦众生。其心甘乐。如三禅也

定苦行者谓诸凡夫

案。僧亮曰。不识真乐。不觉惑苦。常行颠倒。谬以道也

苦乐行者谓声闻缘觉(至)行于苦乐作中道想

案。僧亮曰。二乘比之。于凡为乐。方之菩萨为苦。于此二间。情以为足。故云作中道想也。僧宗曰。从苦法忍。至缘一觉。以其不能安生死。以化物说之为苦。以其解苦性空。于凡夫为胜。亦小小化物。故谓苦乐行也

以是义故虽有佛性而不能见

案。僧亮曰。结二乘凡夫。虽有而不见

善男子如汝所言以何义故(至)三菩提中道种子

案。道生曰。一切诸佛。莫不由佛而生。是以前佛。是后佛之种类也。僧亮曰。已说因果二性。今通释二性得名之所由。答第二问也。性有二义。一谓种类相生。二谓守分不改。今言种子者。通说因性。亦通是种矣。僧宗曰。举其问而答也。向三种心。能生菩提之功。故称为性耳。非是果故。称性也。宝亮曰。答第二问。有两重。初直答因果性之所以。次更明上三人。释所以有三异之意也。此第一重。先明果。佛性中道解。见理周悉也。中道种子者。次答正因因缘。明子能得果也。先明果性所以。今明缘正二因所以也

复次善男子道有三种谓上下中

案。道生曰。前言三种中道。但取兼见。为佛性体。而中必能通故。故云道耳。今明三道。取其能通。明真道有在也。僧亮曰。通辨二因二果也。下者正因。上者缘因。中者后身菩萨。及佛果也。僧宗曰。上明正因竟。今收因地之善。明缘因也。凡夫为下。二乘为上。菩萨为中也。宝亮曰。此第二重也。次开因果两厢。明上见中道者。若计梵天是常。是则向者定苦行人也。计三宝无常者。是向苦乐行人也。中者是向定乐行人

下者梵天无常谬见是常

案。道生曰。背道非实。名为凡夫。凡夫故为下也。僧亮曰。以其沉沦之义。沿流为下也。僧宗曰。既言谬计。何得言善。今取为缘因者。以其伏结。修六行。摄心于禅道耳。此乃非胜道。要有善义。故不得不取也。宝亮曰。凡夫一向居苦。但有正因也

上者生死无常(至)阿耨多罗三藐三菩提故

案。道生曰。与真反也。苟是实者。生死为无上。是以义称为上矣。僧亮曰。二乘不见佛果常故。于生死无常。不可为谬也。了非为是。谓之计生死为常也。僧宗曰。此释二乘人也。谬见常者。其倾正使已尽。唯余习气。约教而言。二乘犹有八倒之习。如三修所明也。今不取习义为缘因。正取无漏善为缘因。上者凡圣二位。彼凡既下。此圣宜言上也。宝亮曰。二乘行不得中道。然非不是缘因性。若能改于固执。必得上果

中者名第一义空无常见无常常见于常

案。道生曰。无有得第一义空者。故不名下也。僧亮曰。见三界过。见涅槃常。以不到故。逆流为上也。僧宗曰。菩萨识第一义空。所以言中也。以离凡夫之下。非二乘之上也。宝亮曰。释上定乐行人也。菩萨称而解终归。用此第一义空为体也

第一义空不名为下何以故一切凡夫所不得故

案。僧亮曰。凡夫以沿流为下。以不得故。于凡不名为上。证非下也。宝亮曰。明二乘不能会此第一义空。故不名中道。若发真解。乃得无上菩提也。凡夫不能得故。所以不名为者。是下也

不名为上何以故即是上故

案。道生曰。上道非上。从意为上耳。宝亮曰。反流尽源。故即上也。僧宗曰。既出二重之上。与佛不殊。亦义得为上。中道解故。称为中耳。宝亮曰。初地以上。有当分之解。与佛解不殊。但未满足为异耳。二乘人未有此解。岂得同称为上耳

诸佛菩萨所修之道不上不下以是义故名为中道

案。僧亮曰。第一义空。唯佛乃见。今该取菩萨者。以后身少见佛性。方之九地。名见中道者也

复次善男子生死本际(至)生老病死之苦是名中道

案。道生曰。即生死为中道者。明本有也。僧亮曰。说境界因也。但说生死。不说涅槃为异耳。无明是现在苦本。爱是未来苦本也。明二世之苦。以惑为本。具一切空也。是名中道者。三种是中道也。僧宗曰。此下释境界性也。就此中有八翻明义。此下第一翻。即是答第三问也。略举二世之因。而过去世中。但取无明。现世中。但取有爱也。无明为现在本际。有爱为未来本际。此之因果。即为中道也。宝亮曰。答第三问也。先释众生。所以不能见中道之意。正以无明有爱。生死不绝故也。是名中道者。名十二因缘也

如是中道能破生死故名为中

案。僧亮曰。道偏则不能破病。不偏者。则能破病。以破病故。名之为中也。僧宗曰。此境生智。智能破故。所以称为破也。宝亮曰。若能观十二因缘生。称理之解。必能破生死也

以是义故中道之法名为佛性

案。僧亮曰。中道智是佛也。道为智因故。说因为性耳。宝亮曰。既如因缘理而照。生中道之解。得名缘因佛性也

是故佛性常乐我净

案。道生曰。本有种生。非起灭之谓。是以常乐无为耳。僧亮曰。以中道常故。佛性常也。僧宗曰。言性理是常。众生以惑覆故。不得常用。虽未得常用。要是常因。承此句。可以义合第三问也。宝亮曰。照既穷源。生死苦尽。所以言常也

以诸众生不能见故(至)无常无乐无我无净

案。僧亮曰。不见三种中道。故无常也

善男子譬如贫人家有宝藏(至)是人即得常乐我净

案。僧亮曰。有而不见者为譬也

佛性亦尔众生不见(至)众生即得常乐我净

案。僧亮曰。合譬也义与善业喻同也。宝亮曰。释旨亦不异上佛性品中意也。答第三问竟此也

复次善男子众生起见(至)如是观智是名佛性

案。道生曰。十二因缘为中道。明众生是本有也。若常则不应有苦。若断则无成佛之理。如是中道观者。则见佛性也。僧亮曰。上说境界。今说智者缘因也。智能断除断常之惑。无谬断常之过也。僧宗曰。第二翻也。谓失解则断常。得解则不断不常。故借惑以辨观体也。宝亮曰。上已答三问竟。此文复何意来。故一家所解。凡为二义。一则通论众生不识因缘之病。二为定因果性有所在。其意云何。众生既即身有佛性。而所以不得用者。正由不体有为无为故起。常等病。谬解在心。故不能得此常乐我净。向来明此因果性。即不离十二因缘。使物情识理。不此外觅法。正有斯二意。故次辨此理。其大旨乃尔。复就此文中。略分有九意。第一先明观十二因缘得所不得所。若先安法性无为理。离断离常。称境。而知成缘因佛性。若当缘境不称境。不安无为。执断执常。乖中道行。第二正开重因重果。定因果性。明此因果俱不离十二因缘。第三正辨出因果性体相。第四判因果性位。第五叹十二因缘。因果性理之甚深。第六明众生虽与此十二因缘共俱。而不觉不知。唯十住菩萨与佛。能穷鉴此深理。故见因缘之始终。第七明行人既观智穷深。断生死因缘相续虚伪果尽。便彻见法性。即用此深法为体。得成灵觉。第八辨观因缘之智有阶级。生解有浅深。第九总收结句。今从众生起见下。为第一意之始。凡夫正起断起常。乖生灭道。不识法相。理外行心。故不名中道也。无常无断。乃名中道者。若就生死边为论。据识生灭道为语。恐此意不然。何以故。世谛虚妄有。即体如幻。终归灭无。岂不断不常。唯神明妙体。法性无为。始可得称不断不常。能心缘此理。不取有无相。方得名中道。既称此理解。便识因缘虚。观照智生。即名缘因佛性。若能如此解。名为得法

二乘之人虽观因缘犹亦不得名为佛性

案。道生曰。灭于死者。乃曰涅槃。苟日不见。岂能得乎无。有得义故。以不得为名。况不观者耶。僧亮曰。明二乘空观。未除断常。不得胜因之名也。僧宗曰。第三翻以二乘人。得理不深。所以不见也。宝亮曰。二谛中中道之解既不成。云何见佛性耶

佛性虽常以诸众生无明[雨/復]故不能得见

案。宝亮曰。因果性常。无明[雨/復]故。所以不见

又未能渡十二缘河犹如菟马何以故不见佛性故

案。道生曰。如菟马者。二乘观也。菟马度河。不得河底。以况众生无明所[雨/復]。不见理也。僧亮曰。明观浅也。不见因缘始故。不断常见。不见因缘终故。不断断见也。宝亮曰。第二说三乘同观无生。但见理不同。有深浅之异。借菟马度河。为譬也

善男子是观十二因缘智慧(至)十二因缘名为佛性

案。僧宗曰。十二因缘生之性也。宝亮曰。此智慧于有为无为两理上。生是缘因性也。取观因缘之智。名缘因性。而体是避苦求乐之解。名正因性。二种双显也

善男子譬如胡苽名为热病(至)十二因缘亦复如是

案。道生曰。向明十二因缘观智。该取因时。名为佛性。故以胡苽为譬。真见因缘。然后果成者。非其譬矣。僧亮曰。上说因为种子。是谓种性相生也。今说种子为性。是因中说果。所以为异耳。宝亮曰。为上二因作譬也。虽复非佛。以能得佛果。故名佛性

善男子佛性者有因有因因有果有果果

案。道生曰。向佛性名中。有因有果。故今明因果有属也。僧亮曰。上说因果事已周。悉是会上宗也。分空为两因。分第一义为两果。明因果相承。不离因缘。皆无自性也。僧宗曰。第四翻也。有因者十二因缘。为智作因也。因因者。即是智慧。此智为菩提作因。菩提为涅槃作因。是为因家之因。故言因因也。有果有果果者。菩提是果。而涅槃又是菩提家果也。宝亮曰。第二意。正定因果性也。明此因果性。即用十二因缘为体也。有因者正因也。论理应以正因为因因。以正是因缘之因故也。今但正因性。至佛不改。当因位而言因也。因因者。缘因性。有移动不定。故有重因之号也。果者。谓菩提也。种智是万行果。故受果名也。涅槃对生死得称。是为果上立果。故云果果也

有因者即十二因缘

案。僧亮曰。十二因缘。能生观智。故名因也

因因者即是智慧

安。道生曰。智解十二因缘。是因佛性也。今分为二。以理由解得。从理故成佛果。理为佛因也。解既得理。解为理因。是谓因之因也。僧亮曰。观智于涅槃为因因也。以菩提智是涅槃观智。是菩提故。所以不于菩提为因因者。欲周历四法故耳

有果者即是阿耨多罗三藐三菩提

案。僧亮曰。菩提于观智为果也

果果者即是无上大般涅槃

案。道生曰。成佛得大涅槃。是佛性也。今亦分为二。成佛从理。而至是果也。既成得大涅槃。义在于后。是谓果之果也。僧亮曰。涅槃是菩提之果。望观智而言是果果义也

善男子譬如无明为因(至)识亦果亦果果佛性亦尔

案。道生曰。因果同为譬耳。作因果不同。前二分为四。此乃为三。此为异也。僧亮曰。举十二因缘。相生为类也。僧宗曰。无明为行作因。故言因也。此行复为识作因。若类前句。还以行为因因也。一以从前因而生。二以与识作因。故言因因也。而文句言无明为因因。亦应以十二因缘为因因。如似不类也。消息取耳。宝亮曰。为因果立譬也。就三法上。互望之。有因因果义也

善男子以是义故十二因缘(至)不来不去非因非果

案。道生曰。缘生非实。故不出。缘散必灭。故不常。前后故不一。不离故不二也。来去之义类生灭也。非作因故非因。非因故非果也。僧亮曰。不出不灭者。从缘故空无涅槃。是不出。无生死故不灭。下类尔。非因非果者。无前者为因。无后者为果也。僧宗曰。第五翻。举理以成中道观智之用也。不出者。不出至现在也。不灭者。不一向断灭。其有续生于后义也。不常者。即是不出。不断者即不灭也。非一者。因果异故也。非异者。始终相续为一。不来不去者。不从未来来至。现在亦无一物入过去也。非因非果者。非异因家之果。非异果家之因也。宝亮曰。第三意。上明因果性。不离十二因缘。今次出其体相。明十二因缘。正用此真如法性无相无为为体。若如昔教一向谈空。恐圣旨不在。若一向是空。何须赞叹。因缘甚深。故知为显今教也

善男子是因非果如佛性

案。道生曰。佛性是种生义。故是因非果也。僧亮曰。正因性。于四法最是。僧宗曰。此下第六因果门也。谓十二因缘境界性也

是果非因如大涅槃

案。道生曰。涅槃是究竟义故。唯果而非因也。僧亮曰。无复果也。僧宗曰。极果报也

是因是果如十二因缘所生之法

案。道生曰。乖理为作有。皆因缘生也。无不因无不果也。僧亮曰。观智也。于正因为果。于菩提为因也。僧宗曰。取观照之智。通因果也

非因非果名为佛性

案。道生曰。不从因有。又非更造也

非因果故常恒无变

案。道生曰。作有故起灭。得本自然。无起灭矣。僧亮曰。菩提果性。非因所作。所以名第一义也。僧宗曰。谓三菩提也。非因故非因。不为生所生故非果也。以非生因所得故。所以常恒也。宝亮曰。第四意。明判因果性位也。是因者正因也。正因唯得居因位。不得称果也。是果非因者。涅槃也。唯得名果。不得称因也。是因是果者。缘因性有。即因即果义也。非因非果者。还遣向言涅槃名果。万行是因。物情执言。谓是生因生果。今遣言。涅槃之体。百非所不得。非生因之因。复非生因之果。无名无相。岂是因是果耶

以是义故我经中说(至)非诸声闻缘觉所及

案。道生曰。因果之义。备于十二因缘中矣。十住菩萨。其犹病诸。况二乘乎。僧亮曰。以上空有二门辨义。皆非二乘所测也。举昔所说三事。证因缘理甚深。一叹理甚深。二众生不知。三唯佛能了。下别释也。僧宗曰。第七翻。非二乘所智。故曰无知无见也

以何义故甚深甚深(至)无有虑知和合而有

案。僧亮曰。第一证甚深也。僧宗曰。释甚深也。续故不断。灭故不常。故能辨果也。虽念念灭者。以相似种类。遂有一用也。宝亮曰。第五意。赞叹十二因缘理深。本叹此理深者。乃意在神明体真。不论生死。生死虚构。有何甚深。而所以独叹十二因缘。不叹五阴十二入十八界等者。是等因成假名法门。非始终相续。十二因缘是始终法门。故就此为叹也。无知无见者。理既深远。岂易可知见。唯佛行满。得具足见。十住仿佛见也。不可思惟者。法性理幽。唯佛境界。非是二乘下地可思忖也。以何义故。名甚深者。此下去正释因缘之体。所以甚深之意。明众生行业。不常不断。而果报不忘。众生若造业。直以虚伪神明为体。应逐三相无常。若逐三相所作善恶业。云何得在。而起业后。经百千万劫。由自得报故。知有法性。为神解主。常继真不灭。其体既无兴废。用那得灭。若得解以后。痴用乃可无。后未有解来常痴。故是业。业即是痴。障智之义。呼为烦恼。招生感果。因之为业。即一体而义分也。虽念念灭。无所失者。既真俗共为神明。俗边乃可三相灭。就真边往取。痴义常存。故无所失也。虽无作者。虽无有如神我作者。而不无作业也。虽无受者。虽无有如十六知见神我受者。而有因必得果也。无有虑知和合有者。亦无有如外道所计神我和合知者。然有因故牵果。理数相感召。如其无此法性为体。起业之后。寄致何处。昔经乃唱。有成就之语。定若为成就耶

一切众生虽与十二(至)不见知故无有始终

案。道生曰。不从作有。岂有始乎。既不见知。何有终也

十住菩萨唯见其终不见其始

案。道生曰。十住几见仿佛其终也。始既无际。穷理乃睹也。僧亮曰。证不见者也。僧宗曰。十二因缘。至金刚时断故。其终易了。寻其本源。不可而知也

诸佛世尊见始见终以是义故诸佛了了得见佛性

案。僧亮曰。证唯佛能见也。僧宗曰。始无源而照。正以始于无始。如净名言从痴有爱。岂知始乎。胜鬘亦云。无始无明也

善男子一切众生不能见于十二因缘是故轮转

案。僧亮曰。举不见之损以结也

善男子如蚕作茧自生死(至)流转生死犹如拍鞠

案。僧亮曰。为不见者。为譬也。宝亮曰。第六意。众生虽与此理共俱。而不觉知故。作因得苦。无穷无已。唯诸佛菩萨。觉知此理。修因感果。穷此因缘。故知始知终。今言十住菩萨。知终不知始者。恐此非实论。何以知。然佛既始终但见。何容十住指知终不知始。亦应彿彷知始。而今但言知终不知始者。此正为课不行道者。云十住菩萨。三阿僧祇行道。尚不知始。况不行者而知。若约事作行。有终可据。始既微末难寻。故但言知终。理而为语。则始终俱仿佛。知唯佛一人。独了了穷。鉴此十二因缘。得见佛性

善男子是故我于诸经中说(至)十二缘者即是见法

案。道生曰。法者理实之名也。见十二缘。始见常无常。为见法也。僧亮曰。举昔经证见者之益也。灭苦是佛。故云即是见佛也

见法者即是见佛

案。道生曰。体法为佛。法即佛矣

佛者即是佛性何以故一切诸佛以此为性

案。道生曰。夫体法者。冥合自然一切诸佛。莫不皆然。所以法为佛性也。僧亮曰。举今说以会昔旨也。宝亮曰。第七意。明解穷达源。若生死顿尽。即名见真法。以见此真法故。即名见佛。大觉现前。无复闇障。即用此真如法性为体。成一切种智也。若神明不以此法性为源。经那得言见十二缘。即名见法。若是见生死法。常住佛果。复那得云。用此法为体。若当是生死空。如于昔教。应同灰身灭智。复不得称常。常法复无始生义。故知神解用此为本。直除灭虚伪。显出此真常之旨。其事如下富那外道之说譬也

善男子观十二缘智(至)得阿耨多罗三藐三菩提道

案。僧亮曰。凡夫不见所以令受苦也。而见有深浅。苦灭不同。不见佛性者。中道是佛性。二乘偏见。不见中道也。僧宗曰。第八翻。谓四种人。浅深观之。唯上上观。乃穷故知深也。宝亮曰。第八意。次明观十二缘智。阶级定相。向言十二因缘理深。无知无见。唯佛能穷。鉴其始终。今故次明降佛以还。亦得观此理。但观而未达。故发解有深浅。阶级有四异。下智得声闻道。中智得缘觉道。上智得住十住地。唯上上智者。见因缘穷。故成无上道。此言得声闻道。恐非是实行者。若寄言诱愚。故宜无嫌也

以是义故十二因缘名为佛性(至)佛者名为涅槃

案。僧亮曰。第一义空。名为中道。还结上宗也。此二总涅槃生死。不偏境智。皆名中道也。僧宗曰。谓境界性也。第一义空者。谓照境之智也。名中道者。谓智照不偏也。中道名佛性者。解圆成极果也。即涅槃者。果之果也。宝亮曰。第九意。总收结会。明四种佛性。皆不离十二因缘。既言穷此理得成佛。因果佛性。岂得离于十二缘。故言十二因缘。名为佛性。佛性即第一义空者。乃远结于上佛果。佛性中道解满。万德皆备。唯用此第一义空为体。若通欲取结四种佛性尽。同用此第一义空为体。然今结意。恐据果性为言也

尔时师子吼菩萨(至)一切众生何用修道

案。僧亮曰。问意。谓若因亦佛性。果亦佛性。名义无差者。何用修道。以求成佛耶。僧宗曰。此难之生。由佛上说见。法即是佛。佛即佛性。人情于此言中。新生此疑。若佛与佛性不异者。是则有性。则有佛。何假修道耶。宝亮曰。此下去为释疑。而生问。此疑藉何而起。因上答三问。后定因果性。物便生疑。若因果佛性。俱不离十二因缘。是则因性与果性。竟自无差别。何用修道。既致疑有两。故下答亦二无有差别。以为一问。何用修道。为第二问。故佛下答去开为三问答。两问即为二段。第二劝令忘怀。今言是义不然者。先遣也

佛言善男子如汝所问(至)然诸众生悉未具足

案。僧亮曰。夫一豪知见。皆是佛理未足者名因性。具足者名果性。性名虽同具不具异也。僧宗曰。就答中有五重。又明虽复当性。然要须修道也

善男子譬如有人恶心害母(至)三十二相八十种好

案。僧亮曰。释言有者。以未来定得故名有。非今有也。僧宗曰。第一重。寄现有业故。必招当果。佛性亦尔。云何不须修道耶

以是义故我于此经(至)成阿耨多罗三藐三菩提故

案。僧亮曰。举昔偈为证也。僧宗曰。第二重举偈。以况因果不并也。有烦恼则无涅槃。岂得不须修道耶

善男子譬如有人家有乳酪(至)一切众生悉有佛性

案。僧亮曰。凡有心者。向言定得。今明有心求乐。求者皆得。但迟速为论耳。僧宗曰。第三重。乳必生酪。所以须醪。暖等必生。所以须修道也。宝亮曰。先答初问。明佛与佛性。虽无差别。要自悉未具是。至于得佛之时。乃可无差。而今未得。云何无别。故下即寄譬。来明未来有义。现在时中。无有当果。故言有非己有之有也。众生亦尔。悉皆有心者。下文言。正因者。谓诸众生。而此中云。心是若用避苦求乐。解为正因者。若为会此文耶。各自有对。此云心。是对果地种智为语。言众生是者。对佛时行人为语。若论其正位。由取避苦求乐。解用为位也

善男子毕竟有二种(至)诸结覆故众生不见

案。僧亮曰。上言定得菩提。毕竟得。今说不但得果。亦得因也。庄严是因。亦是世间也。一乘者。佛智是乘之究竟。说乘名也。僧宗曰。第四重。借因以况果也。庄严毕竟。犹在因中。众生成就因理。岂况果性。在生死之外。而当不须修道耶。宝亮曰。答第二问。明应须修道。庄严毕竟者。谓金刚心也。究竟毕竟者。无学果也。世间毕竟者。还是金刚心时。体由未免苦无常。故言世间也。出世毕竟者。还是无学果。体免离三相。故言出世也。庄严毕竟。据万行为言。究竟毕竟。道众生所得佛果一乘。但众生有此佛果一乘。正由无明障覆故。不能得见理。若如此急应修道。那得难言不须修道耶

复次善男子佛性者(至)成阿耨多罗三藐三菩提

案。道生曰。佛性义现。莫先于此。故即以为名乌

善男子首楞严三昧者(至)首楞严定名为佛性

案。僧亮曰。果性名随果有能为名不一也。依文而言。此五名并是无学也。宝亮曰。明首楞严。是三世诸佛之母。能生一切种智。明众生亦有。但不修集故。不能得成无上菩提。首楞严有五种名者。随义为五位。第一以坚固为名。二以智慧为目。三以能摧得称。四以仗物为况。五以觉察为旨。正是一金刚心。逐义异故。有多种名

善男子我于一时(至)为众生故说名为我

案。道生曰。我名本出常存不断。佛性不断。则是其义。故以名之。非实是也

善男子如来有因缘故(至)而说无我得自在故

案。道生曰。常故自在。是我义也。应感无端。此之自在。从彼而出。本非我故。复名无我也。僧亮曰。上说因非性说性。今明非我说我。乐净亦尔。佛性实非我者。因无自在非我。有因缘至非虚妄。前除断灭之惑。后去计常之倒。皆非虚也。为世界故者。为除世人麻米之我也。宝亮曰。第五证当有之义也。于时梵志。闻当有之义。悉发道心。岂得不修道耶。僧宗曰。我于一时。住尼连禅河下。第三文劝时众。应忘怀取法。佛语无方。不可闻此一边而执着也。如昔佛一时为梵志。说正因佛性为我。佛性实非我。正以善巧方便。应众生根。令物悟道。岂可闻说此正因性为我。而生执耶。若尔我所言。众生当得佛。故言有不得。便执言。众生有佛性。不须修道也

大般涅槃经集解卷第五十四大般涅槃经集解卷第五十五

  答第五问明十住菩萨见不了了诸佛见了了　广辩八大人觉　辩十二头陀　释师子吼问戒则无因涅槃无果义　广释重因重果义　辩涅槃无因而是果义　辩佛性非果义　辩性因了因义

    师子吼品之第二

尔时师子吼菩萨摩诃萨言(至)一切众生不能得见

案。僧亮曰。问意谓佛性雄猛。譬金刚力士。自身有之。何故不见耶。以证无也。僧宗曰。举第四问。以请答也

佛言善男子譬如色法(至)三昧力故能得明了

案。僧亮曰。凡夫无目。对眼不辨。圣人有导。微远能见。佛以二人能见。以证有也。就此答中。有八翻。此第一翻。明佛性是有。但烦恼[雨/復]故。慧眼不开。不能见耳。宝亮曰。此下去次答第四问。就答此问中。有三番明义。第一直明法体障故不见。第二借十二因缘来。证一切众生等共有佛性。第三举物离着。今从譬如色法下。第一段佛性虽有。但众生为烦恼障故。不得见。若能破三种惑。见谛思惟无明住地。烦恼都尽。则见佛性也

善男子若有人见一切诸法(至)首楞严定名为毕竟

案。僧亮曰。第二明若如中道而见。则见佛性。若乖中道。则不见非无是理也

善男子譬如初月虽不可见(至)亦不得言无佛性也

案。僧宗曰。第三明其理幽微。非常情所了。如彼初月。不得言无

善男子佛性者所谓十力(至)一切众生悉有佛性

案。僧亮曰。生死无常。称一切。三宝常故。不名一切也。僧宗曰。第四上虽明当有。未知何为体。今显出其体。乃是生死之外也。理既深远。若欲见。自非破三重惑障。则无由睹见也。三惑者。谓见谛思惟无明住地也

善男子十二因缘一切众生(至)一切众生悉有佛性

案。僧亮曰。亦内者。正见也。亦外者。耶见也。等有者。未来有也。僧宗曰。十二因缘共有者。第五文借近况远。言具十二者。始终为语耳。若胎中死。则无十二。而言具者。成就故也。亦内者现在有也。外者未来未用。义称外耳。入胎五分四根未具者。言入胎有五阴。以四根未具之时。于时。但有名色也。深习一爱。名受者。当知爱即受分。诸经每以其为无记者。以其感果力微故也。内外贪求。为取者。贪着内身。及贪身外。因此生四取。故名取。取谓取于来果也。为内外事。起口业为有者。因向贪求。起增上爱。运于身心动作之用。说业也。现在识名未来生者。世异而已。其余悉名老死也。色界众生。无三受者。不具苦受。故言无耳。三触者苦触也。三种爱者。如寒得火。病爱汤药。悉苦因缘。爱言上界无。如此爱但有舍。乐上生爱也。无老病者。乃有念念老耳。岂有发白面皱。亦无四大坏死。以其凡夫。是伏结之道。后还退堕。生欲界时。得具十二佛性亦尔

善男子雪山有草名为忍辱(至)不可说言无佛性也

案。僧宗曰。雪山譬佛。草譬涅槃经。上说倒障。不见佛性。今说所以有障。不读涅槃经故也。僧宗曰。第六翻。上虽明十力无畏。但果去人远。宝亮曰。第二翻。众生虽复当时有具不具。要始终经理。三世中得言悉成就有十二。明佛性亦然。未来必有也

善男子佛性者亦色非色(至)非诸声闻缘觉所知

案。僧宗曰。第七翻。明十住所以不见。以其理故也。为成此义故。假设状貌。不亦易可知耶。亦色者。垂形六道也。非色者。理绝形色也。非色非非色者。双遣也。亦一者理无二也。非一者。说三乘也。文中自有具释

善男子佛性者非阴界入(至)无边功德之所成就

案。僧亮曰。涅槃经说性如是不读则不见也。僧宗曰。第八更寄譬显非内非外之理也。烦恼[雨/復]故非内。惑尽则见故非外也。宝亮曰。第三翻。遣执。凡欲学者。莫承声而着。若闻色是佛性。不得言唯色是而心非。复闻四阴是佛性。亦不得言唯心是而色非。但圣人说法。随时逐物。所须岂可定执耶

尔时师子吼菩萨摩诃萨(至)成就几法得了了见

案。僧亮曰。举第五门。僧宗曰。答第五门也。迦叶更举前问。以请答也

善男子菩萨具足成就十法(至)以大涅槃教化众生

案。僧宗曰。今言成就十法。非不是行。但未具足。故不见耳。有五重解释。此第一总明十法浅深为异也。宝亮曰。次举第五问来请答。佛言。菩萨正行此十法。未满足故。见不明了。佛得此十法。已满故。见佛性了了。既问除障法。故佛下有五番来。广解此十法。更无余义也

师子吼菩萨言世尊(至)虽见佛性而不明了

案。僧亮曰。十法者。前八法。犹是八大人觉耳。后二法。一赞叹解脱。二以涅槃教化为异成十也。有五翻此第一

复次善男子出家之人(至)虽见佛性而不明了

案。僧亮曰。第二辨出乐。以出家在林离俗。匆务远离。正体余者非也。寂静乐者。得禅定也。永灭乐者。得无漏也。毕竟乐者。得二涅槃也。僧宗曰。第二偏就观门。以辨十法也

复次善男子菩萨摩诃萨(至)虽见佛性而不明了

案。僧亮曰。第三随从天行。是名正定。以此方知四禅是天行者也。僧宗曰。第三就比丘于此经修行。以明十法也

复次善男子夫少欲者(至)虽见佛性而不明了

案。僧亮曰。第四以十二头陀为少欲。行转除也。僧宗曰。第四离聚落。以辨十法也

复次善男子为多欲故(至)虽见佛性而不明了

案。僧亮曰。第五翻也。及五种者。解脱五欲乐也。僧宗曰。第五就现相。以明十法

善男子如汝所言十住菩萨(至)见于佛性而得明了

案。僧宗曰。举第六问也。今言。以佛眼故了了。菩萨以慧眼。故不了了也。宝亮曰。如所言十住菩萨。以何眼见。而不相了者。此下去次答第六问。佛言菩萨。唯得四眼。用慧眼。故不明了。佛具足五眼。照了穷源。故见佛性了了也。下去有数重解。十住菩萨。由为菩提作行。故见不明了。十住菩萨。唯自知得佛。不知他有佛性者。亦是不了义之辞。烦恼本障智慧。十住菩萨。断惑垂尽。何容指自知作佛。不知他有佛性。他惑亦不能障我智不理。今所以有此言者。为辨难易相。明以成佛者。得言易知。未成道人。事迹幽隐难知。故有此之说也

善男子慧眼见故不得明了(至)心不生信不名闻见

案。僧亮曰。称第六问佛何眼见故也。初得名慧。满足佛为菩提。行者进趣名行。住十住故者。应去不去名住也。住不住者。不应去而住非住也。又云不去不住。十住在生灭境。故有去住。佛不生不灭。不去不住也。僧宗曰。就答中有四翻。第一明佛与菩萨。见有了不了。第二明乃至十地。尚不了了。况其余耶。至极虽复妙绝。非常情所察。若因迹寻本。可以知也。第三修戒定为因。则其理也。第四结闻见之理。以晓前宗也。此则第一翻也

善男子若有善男子善女人(至)当云何观而得知耶

案。僧亮曰。六种问答。是第二观门也。僧宗曰。此下第二翻也。宝亮曰。此下师子吼。大段之第二也。上六问六答。已定因果性。使物识因果。修德集业。若当于此深理。未能领悟。信心不立者。劝使约应佛。依十二部经教因果。就事以生信也。凡开五门。此下第一观果也

善男子一切众生实不能知(至)一者眼见二者闻见

案。僧亮曰。先观果性。观之粗也。宝亮曰。佛虽劝观。但物情不解。故师子吼问。明一切众生。实不能测知如来心相。当云何得知。佛言当依二法。一者眼见如来身业。二闻佛所说教法。唯依此二事。得知如来心相。若见如来身业。有三十二相。在世运动。为为众生。为为利养。若见说法。一向为物。不自为己。得知此人可尊可重。必非生死果报所为。若无此妙极来应。众生云何得斯之身处世救苦。必应可信。果既如之。必有妙因。是以劝人。依十二部经。约应佛观如来心用。可得信知因果之性也。但文十别。事义自显矣

若见如来所有身业(至)为谁受身是名眼见

案。僧亮曰。云何受身者。有二种。有自在不自在。知如来自在也。何故受身者。知如来为众生故受也。为谁受身者。为中有等不等。明如来等众生也。僧亮曰。云何而受是身者。乃知感应之道。而不能知所以尔耶。谓以大悲之心。故受身也

若观如来云何说法(至)应当依是二种因缘

案。僧亮曰。不破烦恼者。真谛也。非不破者。世谛也。真俗中。非破非不破者。是真谛。亦是俗谛。何者。非尽能破也。五人能破非不破也。皆说真俗中道。不自言师。亦可俗谛中道。初二种云何知者。第二观门。观缘因也。因成就名眼见。又闻见因不成就。虽识佛。不名眼见。亦非闻见也。二种者。外细内粗。内细外粗。善恶难知者也

师子吼菩萨白佛言世尊(至)唯依是二不可得知

案。僧亮曰。第三门因缘也。因成就名眼见。亦是闻见。因不成就。虽识佛不名眼见。亦非闻见也。二种者。外细内粗。内细外粗。善恶难知也。宝亮曰。第二文约佛弟子所行法观因。佛唯极果。无因可观。若不举弟子所行。则无以为验。佛果若不真。那得信佛语者。尽得实解。故知其理必可信。今者师子吼。先举上庵罗果喻四品人来验。若内外俱熟。内外俱生。此亦易别。余外熟内生。外生内熟。此之二人。云何得知。佛言。此实难知。虽曰难知。当以四法来验。必知真实。若论此四法。正是共住智慧。开共住为二。智慧为两。故成四句。若用此四法。则知持戒破戒

佛言善哉善哉善男子(至)然后得知持戒破戒

案。僧宗曰。四人常近。犹不可知。况复如来。而可测耶

善男子戒有二种持者亦二(至)为为利养为究竟持

案。僧亮曰。以因缘故。受持禁戒者。或为自度。或为人天也。若不为究竟非究竟持也。僧宗曰。此第三翻也。要修究竟戒者。乃能见也。宝亮曰。下欲以此究竟不究竟。来证戒成就不成就。若究竟持戒者。名为眼见闻见。若不究竟持戒。亦不名眼见闻见。自信首五根立以上人。悉属究竟持戒数。若从一信已后。终入内凡夫。相续不舍。乃至成佛。亦名究竟戒

善男子如来戒者无有因缘(至)毕竟持戒究竟持戒

案。僧亮曰。性不为恶。自然得戒。是究竟戒也。不生嗔碍者。亦性不为恶也

善男子我昔一时与舍利弗(至)三藐三菩提

案。僧亮曰。出证因中无恶。果有此力也。宝亮曰。证如来持戒最胜也

复有二种一为利养(至)及以如来持戒之人

案。僧亮曰。重释。而正法者。是究竟也

复有二种一性自能持(至)及以如来亦名闻见

案。僧亮曰。即是无因缘戒也。旷世修习。恶心永灭。善成性也

复有二种一声闻戒(至)能见佛性如来涅槃

案。僧亮曰。声闻厌生死。行乖涅槃。非见法也

师子吼菩萨言世尊(至)何以故法性尔故

案。僧亮曰。释究竟义。亦明从戒生法。终至涅槃。皆是缘因义也。曰推因也。有十一重相释

师子吼菩萨言世尊(至)云何得名我乐净耶

案。僧亮曰。上说持戒。至涅槃因果相乘生因了因。未辨涅槃从何因有。故发问也。僧宗曰。难意欲令戒则无因故常。涅槃有因故无常也。宝亮曰。戒前既无因。应是常。涅槃以解脱为因。便应无常

佛言善哉善哉善男子(至)谛听谛听当为汝说

案。僧亮曰。将欲答难。先举往事。以证得理。而灭之先

戒亦有因因听正法(至)一者听法二者思惟义

案。宝亮曰。戒是有为。从听法而生。为生因

善男子信心者(至)亦因亦因因亦果亦果果

案。僧亮曰。亦因者。听法是信心之因也。因因者。信心复是听法之因也。今与因为因。名为因因。亦果者。信心听法之果也。亦果者。听法是信心果也。与果互得相生。皆是因是果。故名有为

善男子譬如尼干立拒举瓶互为因果不得相离

案。僧亮曰。信心听法。互为因果。不得相离。指据此二。为因因果果也

善男子如无明缘行(至)亦因亦因因亦果亦果果

案。僧亮曰。借此以显手因果义也。无明为因。行为果。自有行后。还起轻烦恼。说为无明。是明轻重前后。互相生起。迭为因果。亦得重因重果义也

善男子生能生法(至)生生不自生赖生故生

案。僧亮曰。借毗昙家义。寄明重因重果之旨也。小生唯生一法。大生乃生八法。是则小生大生。更为因果。亦有重因重果义也。不能自生者。大生三体。不能自生也。由生生生者。由小生来生其体也。生生不自生者。生大生之生不自生。亦赖大生故生也

是故二生亦因亦因因(至)信心听法亦复如是

案。僧亮曰。举一事二义。以为类释也

善男子是果非因(至)名果烦恼者名为过过

案。僧亮曰。上说戒等是因是果。体是有为也。今明涅槃是果。非因非有为。非有为故。不从因有也。上果故者。人求无苦。以无苦为上也。沙门果故者。断生死也。过过者。皆说苦法也。烦恼是过。又生苦故。是为过过也。僧宗曰。向已答戒信二法。互为因果。是故无常。今明涅槃。是了因家果。所以常也。是上果者。释所以是胜也。宝亮曰。既判戒亦有因。知戒非是常。不定便位。涅槃唯得名果。不复更为他作因。故是果非因

善男子涅槃无因而体是果(至)无有因故故称涅槃

案。僧亮曰。有为之法。是因是果故苦也。涅槃是果无因。故非苦也。僧宗曰。无生因也。宝亮曰。体是果者。了因之果也

师子吼菩萨言如佛所说(至)有时无因故名涅槃

案。僧亮曰。难意。不以不善为因。故言无。非一切无也。故取六无之中有时无也

佛言善男子汝今所说(至)何故名因以了因故

案。僧亮曰。彼所举者。皆有为共相。形对涅槃真我。不可与无我为匹也。以是义故。是因者。上二因。是果者。上二果也。涅槃是果非因。佛性是因非果。若涅槃但果而非苦者。佛性亦但因。不应是苦也。非沙门果者。非彼二果。非不是余果是苦也。是了因者。非彼二因。明是了因非生因也宝亮曰。当知涅槃之体。毕竟无因。如无我无我所也。虽引初句为答。后即遣也。明涅槃不同世法。所以常也。是因非果者。还据正因佛性。正因唯住因位。不得名果也。非因生故者。正因佛性。既非善恶因之所生。唯一用不移。至佛不移。至佛不动。故非因生法也。体既非因所生。亦非息心家果也。了因故者。非但缘因是了因。正因亦是了因。何者。若众生无厌求乐心者。一念善不能作也。由有此解故。可得熟果。是故正因亦远为佛作了因也

善男子因有二种(至)地水粪等是名了因

案。道生曰。俱是作法。亦相比而言之耳。宝亮曰。泛明一切缘正二因义。但使于果力强。便是生因。弱者属了因也

复有生因谓六波罗蜜阿耨多罗三藐三菩提

案。道生曰。此下明皆非作法。然生了之义。于兹而显也。由六度而成菩提。故曰生也。宝亮曰。六度取菩提义力强。故名为生因

复有了因谓佛性阿耨多罗三藐三菩提

案。僧宗曰。此有三种相对。通而言之。唯是了因。以拜果义强。为生因也。生者能拜无令有也。了者了已有也。就文而言。小不次。推义。第三重应在第二也。第一重取住前六度。与佛性相对。佛性虽为正因。若语拜果之力。非檀等诸度。则不得果。于了为强。义说生也。僧亮曰。正因佛性。取果力不如。故唯得作了因也

复有了因谓六波罗蜜佛性

案。僧宗曰。此取九地以还。于果义弱为了也。宝亮曰。因中六度。去佛果远。唯得为三菩提。作了因也

复有生因谓首楞严三昧阿耨多罗三藐三菩提

案。僧宗曰。谓十住也。宝亮曰。金刚心力强。生佛果速。故谓正因

复有了因谓八正道阿耨多罗三藐三菩提

案。僧宗曰。八正是偏行。以其义弱。故为了也。宝亮曰。二乘行远。但得作了因也

复有生因所谓信心六波罗蜜

案。僧亮曰。本无今有。是生也。本有今见。是了也。如无常见常是生。无常见无常是了也。僧宗曰。此取登住至三住也。比八正义强。故名生也。所以得知三住者。以住信忍地。今言信心六度也。宝亮曰。大乘行近。故名生也

师子吼言世尊如佛所说(至)云何可见佛性亦尔

案。僧亮曰。观门第三。通观因果也。辨见闻亦异。以了为见。不了为闻。宝亮曰。第三因果合观也。师子吼举百非。以明如来云何可见耶

佛言善男子佛身二种(至)故名众生悉有佛性

案。僧亮曰。方便示现。是名为见者。以示现故。色声皆名见也。解脱之身。亦名闻见也。余悉尔。僧宗曰。第四翻领理前宗也。宝亮曰。佛还约眼见闻见二事。劝信也。一常者。谓法身也。无常者。应身也。可见者。佛与十住菩萨。不可见者。谓一切众生。十住与佛。可名眼见。九住以来。一向是信者。故属闻见也。佛见佛性。了了分明。故言如色。十住以还。见不分明。故言非色也

大般涅槃经集解卷第五十五大般涅槃经集解卷第五十六

  辨因果非有非无义　广辨正因缘因义　广辨了因缘因义　师子吼更设七翻难责无佛性　第一谓人无性人可作天天可作人义故知无性　第二论阐提断善根故知无佛性　第三有初发心故知无佛性　第四退故知无佛性　第五证万善是性离善则无性　第六因有强弱故知无性　第七以菩提心本无今有故知无佛性　下广答七难　广辨退不退性　辨修三十二相等

    师子吼品之第三

师子吼菩萨言世尊(至)说言佛性非内非外

案。僧亮曰。观门第四。观于因中。非有非无也。难意谓。若如上乳中有酪。力士额珠者。便因中已有。云何非有非无耶。僧宗曰。大段之第二也。上答六难。明佛性之理。其义不伦。今师子吼欲成前中道之旨。假为定有定无之难。如来解释。不可一向定有。亦不可一向定无。故为中道义也。初五种执有为难。下七句执无也。佛性不内者。即时未有也。非外者。不离因而有果也。乳中有酪金刚力士者。推理寻说。克终验始。便为已有也。宝亮曰。第四翻观因中无果。今先开章门。非内非外。与因中无果。作章门也。然非失坏。乃远为下第五因中立性作章门。内者正因。外者缘因。明有神识者。皆有避苦求乐之解。始终用不改。故名为内。缘因之善。托外缘而生。有时而有。有时而无。故名为外。明此二因之中。都无有果。故言非内非外。因中虽无有果。非无缘正二因。此二因未来必得佛果。既将明因中无果。故师子吼取外之谬执。谓因中已有果。如乳中以有酪。若乳中果有酪。当知众生身中。已有佛也。今云何言佛性非内非外耶。外道计生因生果故。因中有果。过至于内。义所以无失者。不言乳中已有酪也。但有因。故言有。明众生佛性亦然。非即身中已有。一切种智亦有因。故言有众生佛性。若无此天然之质。为神解之主。终不修因。除迷求解。正以神明之道。异于木石。可得莹饰。故习解虚衿。断生死累尽。有万工现前。所以种为一切智。岂得言众生有此法性为体。使即时有果。如外道所计生因生果耶。其大意乃尔。故下云。凡作五执。细而寻之。乃不翅五。要而为据事异。便成五别。此第一直执因中有果。何以知之。众生生法。各有时节。但说时有异。非因中都无。故知乳中有酪也

佛言善男子我亦不说(至)酪从乳生故言有酪

案。僧亮曰。答意非无从生之义。故言有耳。僧宗曰。不言乳已有酪。以果由生。故言有耳

世尊一切生法各有时节

案。僧亮曰。若以从生为有者。苏亦从乳生。何不次乳有苏耶。僧宗曰。难意谓。乳酪未始不并。但出时有前后也

善男子乳时无酪亦无生苏(至)是故我言乳中无酪

案。僧亮曰。证乳中有酪。亦五味。一以事证。一以知证也。僧宗曰。此下就理中解释

如其有者何故不得(至)乃至醍醐亦复如是

案。僧亮曰。若乳之时有酪。应有二能。更有二名也。宝亮曰。一往破其执也。若乳中有酪。世人不应但名为乳。亦应先有二种名字

善男子因有二种(至)故言乳中而有酪性

案。僧亮曰。因虽无果。而力有近远。远名缘因。近名正因。答生有次第也。僧宗曰。谓乳之于酪。是正因故。说言有耳。非已有也。宝亮曰。破执既竟。还正义本。谓乳为正因。醪暖作缘因。了出酪也

师子吼言世尊若乳无酪(至)何故不从角中生耶

案。僧亮曰。若无而能生者。角亦无酪。独何从乳而不从角耶。宝亮曰。同是无酪。角亦应有。而角不生。但乳能生。说知先有也

善男子角亦生酪(至)是故我说正因缘因

案。僧亮曰。显缘因之义。亦能生酪。证无而能生者也。僧宗曰。以求酪之人。必取乳故。故知乳是正因也。宝亮曰。纵论以明。理非正答

师子吼言若使乳中(至)何故不生二俱无故

案。僧亮曰。欲证有缘因之义。故更问也。僧宗曰。回换譬耳。义同前释。宝亮曰。二俱是无。而一生一不生。故知先定有明矣

善男子乳亦能生庵摩罗树(至)乳中不生庵摩罗树

案。僧亮曰。以水灌则生。以乳灌则长疾。证缘因之力。无而能生也。宝亮曰。以二事破其执也。前翻纵谈乳亦能生树。后一翻举四大之质。金玉有本。不可同论酪之与树。自各有正因耳

世尊如佛所说有二种因(至)缘因者谓六波罗蜜

案。僧亮曰。含识之类。厌苦求乐。性之常也。虽人天同。此性不异。杂惑名正因。除惑名缘因。无惑可除。名之为佛

师子吼言世尊我今定知(至)是故当知乳有酪性

案。僧亮曰。更以人知为证。广其事耳。宝亮曰。第二执也。求酪之人。取乳不取水。知乳中定先有

善男子如汝所问是义不然(至)而见长者是义不然

案。僧亮曰。以取刀之知。并通难也。虽取刀照面。刀本无面。岂以取乳为酪。而言乳已有酪耶。宝亮曰。此中有四重难。第一眼光到境乃见。则火应烧眼。第二若至境而见。不应生疑。第三眼光是色。水亦是色。二俱是碍。唯可见水。云何乃见水中鱼石耶。第四防难。若言不到故见。何故不见壁外物耶

善男子如汝所言乳有酪者(至)未食之时食应是命

案。僧亮曰。广举证也。宝亮曰。举近事以况远理。验乳中先无酪

善男子一切诸法(至)三世有法无有是处

案。僧亮曰。举偈结释也。宝亮曰。还举正义。以明正理

善男子一切诸法因缘故生(至)应有佛身如我今也

案。僧亮曰。若已有者。应有果佛相好之用。如我今也

众生佛性不破不坏(至)少能见之如金刚珠

案。僧亮曰。明佛性是常。众生用之。如身中虚空。而得生长。是空之用。空非三世。以众生有虚空界故。有空用也。佛性亦非三世。而是众生有也。以解惑相碍。相碍故惑灭。惑灭乃用故。说为未有也

善男子众生佛性诸佛境界(至)解脱生死得大涅槃

案。僧亮曰。证有而不能知

师子吼菩萨言世尊(至)虚空无性故无缘因

案。僧亮曰。上破正因。此下破缘因。将欲破故。先立正因。有须缘因之义。虚空无果。故不假也。僧宗曰。第三翻证有也。以定有故。须缘因为了耳。宝亮曰。以有正因。故须缘因。虚空无故。无此二因。故知有也

佛言善男子若使乳中定有性者何须缘因

案。僧亮曰。若已有者。何须缘因也。僧宗曰。若已有者。复何须了因耶。宝亮曰。且一往答云。若须缘因而得者。岂是已有耶

师子吼菩萨言世尊(至)定知乳中先有酪性

案。僧亮曰。举闇中之物。虽是本有。不了不见。以证了因之用。不得言已有不须了也。宝亮曰。举现事以救义也

善男子若使乳中定有酪性(至)若是了因复何须了

案。僧亮曰。甜多为乳。醋多为酪。若乳时有酪。醋味已足。醋即自了。何须醪暖了也。宝亮曰。向以无了因故。所以乳而非酪。若使先已有酪。即是了因。复何须了。下广难其义也

善男子若是了因性是了者(至)若是不了何能了他

案。僧亮曰。若有醋性。不能自了。何能为他。而作了耶。僧宗曰。若了因不能自了。更须了者。何能了他耶

若言了因有二种性(至)云何了因而独有二

案。僧亮曰。有为力差。守分为性。火是一法。何得有二也。又云。若火自了。了所了异。了则是因。所了是果。一法得有二耶。宝亮曰。仍破外道执。性是定法。恒守一位。不得有二用也。谓汝言了因。为当自了。复能了他。若当自了。又能了他。则非自性。何者。汝执了因。唯是一法。云何有二用耶。了因若二。乳又应二者。乳亦应自了。复是了酪也。若尔者。何须外缘。方亦复现耶

师子吼言世尊如世人言(至)了因亦尔自了了他

案。僧亮曰。数是万法之一。自数数他。了因亦尔也。宝亮曰。当我分复满一人数。故知有二用。举此以救义也

佛言善男子了因若尔(至)不能自了亦不了他

案。僧亮曰。要须智性者。知数自他。色非自数也。宝亮曰。佛答意谓。数者。是神虑故。能数我色他色。所以言汝执了因者。本是色法。云何两用耶

善男子一切众生有佛性者(至)是了因者已同酪坏

案。僧亮曰。已同酪坏者。自了之义。上已破

若言因中定有果者(至)从师受已渐渐增益

案。僧亮曰。若定慧之果定有性。不得增长。然从师受已。渐渐增益。知本无也

若言师教是了因者(至)戒定智慧令得增长

案。僧亮曰。初白之时。戒自未有。羯磨竟后。戒乃成就。是则应了。未有为有。非了已有。令增长也

师子吼菩萨言世尊(至)云何得名有乳有酪

案。僧亮曰。若乳中无酪。复无了因。云何有乳。而答云有酪耶。僧宗曰。以名字证是有耳。宝亮曰。第四执也。现见就卖乳者买酪。故知乳即是酪也

善男子世间答难凡有三种(至)有佛性以当见故

案。僧亮曰。正义宗也。终以定当有。故言有耳。宝亮曰。用转答以释难。明因中说果。故言有非已有言有也

师子吼言世尊如佛所说(至)言一切众生悉有佛性

案。僧亮曰。上明二因无果。似与俗乖。今欲会之。如世人说有。以将有耳。乃因问以系扬也。宝亮曰。过去已灭。未来未至。云何名有耶

佛告善男子过去名有(至)悉有佛性实不虚妄

案。僧亮曰。凡四譬。前一譬显过去有。后三譬显未来有也。宝亮曰。虽复曾有当有。于今为无。亦非定无。如麻是现在。油是未来。因果时异。岂得因中有果耶。是以一家作义。每依经推理。往往见人多作因中有果之责。经有诚文。殆不假释。前佛性品中已云。毒身之中。有妙药王。所谓佛性非是作法。此亦不言佛非作法。若言佛亦非作法者。则众生身中已有于果也

师子吼言一切众生(至)当知众生悉有佛性

案。僧亮曰。上别破二因。说有是未来。今师子吼。更以事证因中先有。欲广有者之过耳。僧宗曰。第一执以正因证有性也。宝亮曰。第五谓正因之中。应已有微微佛故。能令众生。得无上道耳。若正因中都无者。何不名作缘因耶

佛言善男子若言子中(至)今则有之当有何咎

案。僧亮曰。若言细障故不见者。言为细所障耳。非八事中障也。常应不见者。若为细障。障常是细。常不应见也。本无粗相者。若性细者。粗则本无。常如是粗。本无见性者。粗故可见。粗是见因见本无性也。宝亮曰。若言正因中已有者。何故不见耶。且就树为论。不同世间八缘。而不见者。当知因不应先有果

师子吼言如佛所说(至)作了因故令细得粗

案。僧亮曰。救义云了因。了细令粗粗故可见。非常不可见也

佛言善男子若本有者(至)石蜜治热黑蜜治冷

案。僧亮曰。二俱无者。上说有粗。粗不须了。若本无粗。粗了何所了。若言了无令有者。亦应能生佉陀罗树。若本有烧。烧不得生。不一时者。责三相不一时用事。黑蜜治冷者。明法从缘异。无定性也

师子吼菩萨言世尊(至)故得阿耨多罗三藐三菩提

案。僧亮曰。更以七难。明佛无性。而成显佛性非无。成上不失坏之义。初以天人证佛性无成也。宝亮曰。第五翻观因中立性也。虽难有七。然多执缘。难使无正因也。此第一难云。若因中本无者。则无正因。唯有缘因。故得佛耳

若诸众生有佛性者(至)若非常者不名佛性

案。僧亮曰。第二难。若性因缘成菩提心。是性阐提不应断。断则非性也。宝亮曰。佛若以菩提心名为佛性者。现见阐提断善根。是则阐提无佛性。云何言众生悉有佛性耶

若诸众生有佛性者何故名为初发心耶

案。僧亮曰。第三难。性常不应有初也。宝亮曰。既有初发者。则未发心时无佛性。若尔。便是用发心善作佛性。云何言众生悉有耶

云何而言是毗跋致(至)当知是人无有佛性

案。僧亮曰。第四难。性常不应有退也。宝亮曰。若有退不退者。是则退者。无有佛性。岂是悉有耶

世尊菩萨摩诃萨一心趣向(至)何须是法而作因缘

案。僧亮曰。第五难。证万善是性。离善无性也。宝亮曰。略举缘因。谓能成佛者。唯此缘因。故知无有正因佛性。但是缘因也

世尊如乳不假缘必当成酪(至)当知众生悉无佛性

案。僧亮曰。第六难。五味相生。因有强弱。乳强故不假外缘也。宝亮曰。举经为证。昔说三乘僧常。若尔者。则应常住僧位。云何成佛耶

如佛上说僧宝是常(至)一切众生应无佛性

案。僧亮曰。第七难也。若菩提心。本无今有者。果亦应尔也。宝亮曰。若众生先无三菩提。今方有者。是则本无今有。故知先无也。与上难前后为异耳

佛言善哉善哉善男子(至)一切众生实有佛性

案。僧亮曰。答第一初果从理成。必得不失。则称性也。不从理成。或得或失非性也。是以人天之果有惑。非从性有也。佛果无惑。从性有故。答第一难也。宝亮曰。人天无定可是无性。佛性不同此也。如人天之业。至佛方住。中间无停者。云何无正因耶

汝言众生若有佛性(至)心是无常佛性常故

案。僧亮曰。答第三难。正因无初。无初故常也。发心是缘因正因也。僧宗曰。兼答第七门也。宝亮曰。发心非正因佛性也。佛性是常。心是无常。是故善心有时而有。有时而无。唯正因性用。常而不改

汝言何故有退心者(至)以迟得故名之为退

案。僧亮曰。答第四难也。宝亮曰。明善心不退也。善心不生则已。生则无退。善若可退。云何成佛耶。但以迟得。故名退耳

此菩提心实非佛性(至)菩提之心实非佛性

案。僧亮曰。答第五难也。宝亮曰。还答第二问也。明菩提之心。实非正因也。我言悉有者。谓正因佛性也。断缘中所生善。故名一阐提也

善男子汝言众生若有佛性(至)得见佛性然后得佛

案。僧亮曰。答第六难也。宝亮曰。答第五难也。明虽有正因。要须缘助。如金石之有金。藉众缘乃得

汝言众生悉有佛性(至)三藐三菩提如石出金

案。僧亮曰。前无此问。恐零落也。僧宗曰。此问义生也。因答前问。仍遣其惑耳

善男子汝言僧常(至)是故我说僧有佛性

案。僧亮曰。答第七难也。宝亮曰。答第六难也。明昔言僧常者。以前佛后佛僧宝恒自相续。岂谓嶷然常耶。十二因缘常者。有佛无佛。正因之性无改。故言常也。第七难。义同第三。无别答

善男子汝言众生若有佛性(至)我当为汝分别解说

案。僧宗曰。重答第四问也。此下广释退相也。宝亮曰。答难已竟。下作三翻。明始终无退义

善男子菩萨摩诃萨(至)不退之心不名佛性

案。僧亮曰。观缘具不退。不具则退也。僧宗曰。明以迟得故言退。非为永失也。宝亮曰。正辨不退之由也

善男子汝不可以有退心故(至)及一阐提悉有佛性

案。僧亮曰。为退不进者。为譬也。僧宗曰。不可言退。故无佛性也。宝亮曰。第二翻退不退人。未来同得成佛也

师子吼言世尊云何菩萨有退不退

案。僧亮曰。缘有行愿。上但广愿。未广其行。故发问也

善男子若有菩萨修集如来(至)如是四法皆悉是常

案。僧亮曰。如是四法。皆悉是常者。众生业性。三因一果。常故不可思议七也。僧宗曰。能如是者名不退。不尔者。则为退矣。宝亮曰。举三十二相业劝业。为用此义故。广明退不退之相也

以是常故不可思议(至)以不见故不得涅槃

案。僧亮曰。业果即众生。即正因性也。名为常者。烦恼故言常耳。断常烦恼者。上言因果皆常。未辨常有长短之因。以结惑故常。结惑尽者。则因灭矣。果以无惑故常。常故不变易也。宝亮曰。一说既竟赞叹。明一切众生及诸佛境界业果佛性悉不可思议。佛果等四法虽常。但众生起烦恼。业障[雨/復]故。常痴无解。来翻云何非常耶。上言烦恼之常者。正出此文也。始终为所除。故言断常烦恼名无常耳

大般涅槃经集解卷第五十六大般涅槃经集解卷第五十七

  辨缚解义　辨前后五阴相续以蜡印为譬　名色系缚众生众生系缚名色　明烦恼与习手为因果　广辨八喻谓逆喻现喻等　广释灯譬圣道义　释须陀洹虽生恶国犹自持戒　引香山师子为譬　广辩戒定慧相不可得　释十六恶律仪　释生义与涅槃义皆不生不灭　释佛性非一非二义

    师子吼品之第四

师子吼言世尊如佛所说(至)以是二因应无缚解

案。僧亮曰。第三门辩缚解也。若如上说因果之观。必从缚得脱也。僧宗曰。此下复有四段。探其义。并从中道而来也。前中道论义。初以五句执有。后以七句执无。佛释云。不可一向定有。不可一向定无。今此下犹欲成其前执也。以缚解修道。二问成前有执。转障劝修。成前无执也。所以知缚解成其有执。谓若因中有佛性。为惑所缠。故称为缚。从因至果得脱。故称为解。若因时无性。后方有因。本无故则无有缚。果时自起。生在累外。复无所解也。以此二因者。正因即神明。缘因即万善。此自是有为。居在于缚。乃至金刚亦未免于惑。是则金刚为累。生在于前。佛心无累。起在于后。岂有从缚至解耶。宝亮曰。大文第三明缚解之相也。若于向者。观因观果。信心得立。承此修道者。则名为解。若于此因果六行之中。信心不立。则名为缚。今将明此理。故先作难。若如佛所说。应无缚解。何以然耶。我先言正因中有佛。故须缘了出。而佛言正因之内。都无有果。然则有缚之时。举体无缚。及其解时。亦未曾有缚。云何而言。从缚得解。下引事如五阴迁流。念念生灭。法相如此。谁缚谁解。就此文中。凡有五段。第一明行人。于三世中。阴阴相传。第二出起缚之体相。第三辩解体之方法。第四明缚解不相离。第五论子果缚异。智秀曰。上明中道。虽复理相显然。但学者根殊。晓则成解。迷则致缚。为奖学者。使顺缚而就解。此下第三次辩缚解明义。凡有五翻。第一约不异段。第二明业尽果谢。理不可移。第三讫灯生闇灭。明果谢之后后。果必来续也。第四蜡印譬。明阴所以续由。果因之理。必相开故也。第五炎。明中阴果报相从也

是五阴者念念生灭如其生灭谁缚谁解

案。僧亮曰。若因中佛性。为结所缚者。结灭则解。名义可寻也。今五阴生灭。前垢后净。一灭一生。初不相及。谁缚谁解也

世尊因此五阴生后五阴(至)众生亦尔云何缚解

案。僧亮曰。为外人作通也。若不至则无缚者。亦应无生也。僧宗曰。物情多疑此理。是故致问。若中道义圆。则生解亦圆。以承此见性。若乖之一豪。则永远正路。此五阴者。引阴证不相及义为譬。以成其执也。言此阴自灭。不至彼阴。二阴同缚。尚不相至。岂况佛性。而从缚得解。若有缚解。当知因中已有性也

善男子谛听谛听(至)如灯生闇灭灯灭闇生

案。僧亮曰。答意是相续假名众生有结。以中阴续死阴。以生阴续中阴。众苦名之为缚。不在因中有果也。僧宗曰。就二阴释相传之义。其难欲使已有性。在于身中。从惑得解也。今明不假已有一性。夫因果本自相召。有因则有因。有果则有果。不得言都无。在因为缚。从因至果为解。若论实法。则前不至后。相续为论。则本缚今解

善男子如蜡印印泥(至)如印印泥印坏文成

案。僧亮曰。印譬前阴。文譬后阴也。僧宗曰。重为二阴作譬也。以火融蜡灭。而泥文自生。此时而现。不得言蜡文变为泥文。文非泥出者。非泥离蜡自然而出也。不余处来者。由蜡而来也。以况现阴中阴义也。以行业之火故。令现阴灭。中阴阴生。亦不得言中阴离现而生。亦不得言余处生。由现阴为因也。宝亮曰。蜡喻死时行人。印喻死时五阴。泥喻中阴行人。泥上之文。喻中阴五阴。不变在泥者。死时之阴。与行人亦不变作中阴中人也。文非泥出者。中阴五阴。不直从人生也。不余处来者。复不别从余处得中阴中五阴也。以印因缘而生文者。因死时之阴。得中阴阴也。现在阴灭。中阴阴生者。合向者印灭。文成句也。是现在阴。终不变为中阴五阴者。合向蜡印不变在泥句也。中阴五阴亦非自生者。合向文非泥出句也。不从余来者。合向不余处来。句也。因现阴下。合向以印因缘而生是文也

名虽无差而时节各异(至)如印印泥印坏文成

案。僧宗曰。非肉眼见者。其色细妙。天眼乃见耳。三种食者。思食即过去业也。此中有冷暖触成身。意地四心及五识。诸心相连。无段食也。中阴二种善与恶者。向明以前阴为蜡。中阴为泥。今复明从中阴。向受生处也。宝亮曰。中阴报妙。唯天眼识所睹。亦无段食。而自资故。随其用业善恶之所感。心用之粗细。后父母和会。各随业觅生。以成己身。起三烦恼。交会缠着。中阴阴坏。后阴续起。如印坏之文成

生时诸根有具不具(至)以是义故名五阴生

案。僧亮曰。虽无差时节各异者。时虽是一。而一生一灭。用不同也。宝亮曰。第二出缚体也。随业成早晚。生三毒因缘。业结乱起。系缚于生死也

是人若得亲近于佛(至)以是义故名五阴灭

案。僧亮曰。断烦恼业受生死。名解脱耳。宝亮曰。第三出解体也。系缚轮转。自非深观境界。无以除生死苦也

师子吼言空中无刺云何言拔阴无系者云何系缚

案。僧亮曰。上云。阴不断名缚。而未说系主。故设难也。宝亮曰。第四正明缚解不离众生。离缚解之外。无别有众生。但因成假名。离因无果。若以惑成人。名人为缚。以解成人。名人为解。将明此理。故难云。空本无刺可拔。阴亦无缚可解

佛言善男子以烦恼锁(至)无烦恼故名为解脱

案。僧亮曰。生生不断。由烦恼系也。宝亮曰。五阴法外。更无别人。束五阴作人也。若五阴有缚。名人为缚。若五阴解。名人为解。如柱持屋。无别屋外有柱也

善男子如卷合掌系缚等三(至)无烦恼故名为解脱

案。僧亮曰。指合成卷。而指散卷灭。合散成灭。不异于指。烦恼亦尔也

善男子如说名色系缚众生(至)亦名众生系缚名色

案。僧亮曰。阴长结短。容有相缚。而名色众生。无长无短。更以为譬也。宝亮曰。因成假名。更无别法起。其旨始显也

师子吼言世尊如眼不自见(至)是故我言众生解脱

案。僧亮曰。二手合时。更无异法。而来合者。合一是果。手二是因。而离手无合也。名色众生亦尔。宝亮曰。若名色异众者者。可得言缚。今名色与缚一体。如眼不自见。云何名色系缚名色耶。佛答。以二手共合。更无别合法。即手为合故。即名色为缚也

师子吼言世尊若有名色(至)未离名色亦应系缚

案。僧亮曰。名色众生。二无长短。致此难也。宝亮曰。第五明子果缚异

善男子解脱二种(至)油若尽者灭则无疑

案。僧亮曰。名色三种。谓是因是果。非因非果。烦恼与习。互为因果。以烦恼阴是果。佛性众生亦是名色。非因果也。宝亮曰。罗汉已断子缚尽。虽有名色。非生死因。但果报数尽。非治道所除也

善男子所言油者喻诸烦恼(至)若得断者则入涅槃

案。僧亮曰。有或者。则处处受生。故名众生。或尽不生。不名众生。名入涅槃。宝亮曰。灯譬果缚。油譬子缚也

师子吼言世尊灯之与油(至)云何如来喻之于灯

案。僧亮曰。以明譬众生。后以众生譬灯。即以明为灯。油是生因。今烦恼是众生成因。竟以何为譬耳。宝亮曰。师子吼还更执明灯之与油。二物各异。若言众生即缚者。此非譬也

佛言善男子喻有八种(至)七先后喻八遍喻

案。僧亮曰。欲明譬有多种。此少分譬也。此下广辨逆与不逆诸譬也。宝亮曰。引八喻。明譬法不全取。前所喻者。盖少分耳

云何顺喻如经中说(至)更无别车众生亦尔

案。僧亮曰。举八种之意。意在少分也

善男子若欲得合彼灯喻者(至)不为诸有之所污染

案。僧亮曰。炎譬金刚。习尽则灭也

师子吼言世尊众生五阴(至)谁有受教修集道者

案。僧亮曰。第四修道门。从缚得解。功由众行道之义也。说修道。以积习为义也。有为主无。亦无系住。何有修道。僧宗曰。大段之第四明修道也。成前执有之难也。若因中有性。为惑所缠。从因至果。除惑说修。既有除惑之功。则修道义立。若因中无性。则唯是生灭。念念无常。当体自灭。谁有修道。至涅槃耶。就修道中。可有八段。第一明相续修道有益。第二明修之方法也。第三明道平等。第四寄处所以明道。第五寄人明道。第六遣着就无相境界。第七更举无十相。劝修其因。第八重举极果。令修十相之因。心不断者。言虽念念灭。要相续缚解不断也。宝亮曰。就辩修道之中。开为十段。第一明众生神识。虽念念灭。得有修道之义。第二明修道得法不得法。若忘怀得理。即出生死。第三明道性平等。第四明处道。第五明时道。第六明人道。第七遣执明道。第八出能修道人。第九辨定慧相资。第十广因果结句也

佛言善男子一切众生(至)勤精进心信心定心

案。僧亮曰。三慧是道。始从闻思也。念是闻慧。慧是思慧。发心是修慧。是六次第也

如是等法虽念念生灭(至)相续不断故名修道

案。僧亮曰。说有修集道者。以相续为集也

师子吼言世尊如是等法(至)亦相似相续云何修集

案。僧亮曰。张两关难也。称上六心。言皆念念生灭。不能除结也。第二关云。若相似者。下则常下。亦无修力也。宝亮曰。问有两意。一意。若念念灭者。体不自固。则无增长。二意。若从下生中。从中上。则非相似相续

佛言善男子如灯虽念念灭(至)亦能增长树林草木

案。僧亮曰。答初关难也。宝亮曰。先遣初意也。明一神解。虽念念生灭。要冥相资。故得有用也

善男子汝言念念灭(至)则能破坏一切烦恼

案。僧亮曰。答第二关难也。宝亮曰。次遣第二。意明心是知解之性。虽改代不常。要相续不断。理数目增进也

师子吼言世尊如佛所说(至)云何而得不作恶业

案。僧亮曰。举佛昔说修道相似不相似。譬为证也。宝亮曰。将欲重咨。先领佛昔所说。佛言心不断故。得念念增长。若尔。须陀洹人亦应无漏。无漏相次。云何。舍无漏。而生恶国耶。然须陀洹人。得见谛无漏。无三漏业。乃是三住菩萨之位。何应受边地报耶。是故一家捡理。义不应尔。如凡夫中小有福力。尚不生边地。况须陀洹人。当受此报乎。今言生恶国者。舍见谛无漏清净五阴。起思惟门烦恼。故言生恶国也

佛言善男子须陀洹者(至)以道力故不作恶业

案。僧亮曰。见结不起。故不失须陀洹名也

善男子譬如香山有师子王(至)以道力故不作诸恶

案。僧亮曰。香山。譬得初果时五阴。师子王。譬初果无漏。鸟兽见谛惑也。山譬恶国阴也

善男子譬如有人服食甘露(至)须陀洹阴亦复如是

案。僧亮曰。广举诸证不失

师子吼菩萨白佛言世尊(至)云何修定云何修慧

案。僧亮曰。此下明修义也。宝亮曰。第二段明修道得法不得法也。但自为不兼于物。名不得法。此下有三翻明义也

佛言善男子若有人(至)修戒定慧是名声闻

案。僧亮曰。第一翻直双说相对。明得法也

善男子云何复名修集于戒(至)是则名为修集智慧

案。僧亮曰。第二重就能破大恶。以明得法也

善男子修集戒者为身寂静(至)为得常乐我净法故

案。僧亮曰。广释修戒定慧相也。宝亮曰。第三明要心大果名得法也

师子吼言世尊如佛所说(至)是故涅槃无因无果

案。僧亮曰。难意承上戒定次第相生。而得称常。其义未显。故问也。若由智得灭。灭是本无今有。有即是生。生即是灭。直以不更生更灭名常者。生亦如是。即生即灭。不更生更灭。亦应常也。宝亮曰。是生虽复当体。不辩住灭。名之为常。要有始终不恒。故非涅槃也

师子吼言世尊众生为悉(至)亦不应说佛性如空

案。僧亮曰。因有三种。正因缘因则别。境界因则共也。何者。三达智。一法不知。则非佛三世因缘也。各各有则无常者。谓彼佛所知。此佛不知。不知故惑不尽。佛应无常也。宝亮曰。第三段明道性平等也。将欲广明此理。故先作问也

佛言善男子众生佛性(至)众生佛性亦复如是

案。僧亮曰。总答三因。明皆共有平等也。宝亮曰。在果之日。有六道差别。成佛之后。如是无异也

师子吼言如佛所说(至)而是佛性常一无变

案。僧亮曰。广举众譬以释同修而无碍也

大般涅槃经集解卷第五十七大般涅槃经集解卷第五十八

  广出俱尸城缘起　广出俱尸城涅槃缘起　广出须达缘起　广出逐外道缘起

    师子吼品之第五

师子吼言世尊十六大国(至)拘尸那城入般涅槃

案。僧亮曰。众生有待处漏尽。此下将辨处为道。故发问也。宝亮曰。修道之第四。文人寄处。所以明道也。大意有五因缘。第一为益人旷远。第二欲报地往恩。第三为欲还此中正受。第四为果彼本愿。第五为逐外道也

善男子汝不应言拘尸那城(至)边地弊恶隘陋小城

案。僧亮曰。先答不应谓此为隘陋也

善男子我念往昔过恒沙劫(至)我眷属者受恩能报

案。僧亮曰。明此是初发心处。故在此也。宝亮曰。第二报地恩也

复次善男子往昔众生(至)娑罗树间三昧正受

案。僧亮曰。明此是往昔出家修道之处也。宝亮曰。第三欲还此中。三昧正受故也

善男子我念往昔过无量劫(至)敷扬演说大涅槃经

案。僧亮曰。明此是发愿之处也。宝亮曰。四果本愿也

善男子我初出家未得阿耨(至)我时默然已受彼请

案。僧亮曰。为洴沙王有请。故所以来此也

善男子我初得阿耨多罗(至)我即往彼受王供养

案。僧亮曰。此下皆为逐外道故。次第至此。外道于此。必受化故。故来此也。宝亮曰。第五为逐外道。兼先受此受故也

外道六师相与集聚(至)我时受已即住其中

案。僧亮曰。因出须达所起祇洹精舍事也

是时六师心生嫉妒悉共集诣波斯匿王

案。僧亮曰。此下广说外道之辞也

作如是言大王当知(至)六师之徒欢喜而出

案。僧亮曰。王知有益。是故许之

时波斯匿王即敕严驾(至)阿耨多罗三藐三菩提心

案。僧亮曰。外道虽复未降。而所益已多也

是时六师各相谓言(至)阿耨多罗三藐三菩提心

案。僧亮曰。随其所至。略已遍也

大般涅槃经集解卷第五十八大般涅槃经集解卷第五十九

  广出与六师论我无我义　广释娑罗双树缘起　广释二月十五日缘起　广释一切法性无住住义　广释涅槃无相义　广释定慧舍相奢摩他等相

    师子吼品之第六

尔时六师周遍六城(至)唯说如来常乐我净

案。僧亮曰。师子吼能令眠者觉悟也。佛说中道。能悟偏执之眠也。宝亮曰。外道既穷于此处。故求欲论义也

尔时六师复作是言(至)向喻于眼见者喻我

案。僧亮曰。根机不同。俱是执着。而憍陈如。闻无常以受道。六师因我乐。以反真也。闻我则欣同。故说已解以自多。而此说非色为我。谓与佛解不同也。宝亮曰。此中往复。不异下先尼中。但自犹有徒众。未有所称。至于徒党都尽。十师方现受降伏。归还正道也

佛告六师若言见者(至)闻见六尘当知无我

案。僧亮曰。此下有三开。难所执我。此即第一难。谓根非我。应如人向之异。一向之中。具见闻也

所引向喻虽经百年(至)年迈根熟亦应无异

案。僧亮曰。第三难。向辨无用。知见非向。今明根熟则昧。故知见色根非是我也

人向异故见内见外(至)若不见者云何有我

案。僧亮曰。第三难。若不内外俱见。岂是于我耶

六师复言瞿昙若无我者(至)有我者即常乐净

案。僧亮曰。明见属众缘。无别见者也

六师言瞿昙色亦非我(至)遍一切处犹如虚空

案。僧亮曰。然色等以因缘故。具有四过。我所以说。我相同虚空。不以因缘成遍一切处。难以分数分也。湛然常住。不可生灭。而能知能见。常御诸情也

佛言若遍有者则不应言(至)若无常者云何云遍

案。僧亮曰。有两开。此第一难。言汝我既是见者。今物若遍。见亦应遍。遍则无物。物则不遍也

若遍有者五道之中(至)云何而言转受人天

案。僧亮曰。第二难也。若遍五道。则一时合者。不得舍人受天也

汝言遍者一耶多耶我若一者则无父子怨亲中人

案。僧亮曰。第三难也。既言是一。云何有尊卑之异耶

我若多者一切众生(至)善业恶业愚智差别

案。僧亮曰。第四难也。若各有自在之生。岂有愚智之别耶。造业亦理然是同也

昙瞿众生我者无有边际(至)众生业果不得无差

案。僧亮曰。外道救义但救多我之切也。我有遍常。不遍常法。非法不遍也。常我虽遍。然行法则智。行非法则愚。不得无差也

佛言六师法与非法(至)若不尔者云何言遍

案。僧亮曰。我若遍者。应各各具二。具二者。业根应等。若不尔。云何言遍耶

瞿昙譬如一室灯百千灯(至)修善行恶不相杂合

案。僧亮曰。救义意。如灯之小大。皆遍一室。不容以小故不遍也

汝等若言我如灯者(至)众生我者则不如是

案。僧亮曰。破此执有三开。此第一从缘生故。缘大灯大。所以能有异也。我不从缘。不应异也。宝亮曰。灯之与明。悉从缘有。我既不尔。云何为喻灯明。要有本有末。在主之炎为本。譬上之明为末。成我不从身出。出住在异处。故无我也

明从灯出住在异处(至)从身而出住在异处

案。僧亮曰。第二难也。灯与明异。我与法非法不异。若异者。我则不遍也

彼灯光明与闇共住(至)当知初明与闇共住

案。僧亮曰。第三难也。初灯小故。不能破于大闇。与闇共住。闇处无明。明则不遍也

瞿昙若无我者谁作善恶(至)师子吼者名大涅槃

案。僧亮曰。不作无善恶也。恶是作业。必应有作者。我是作者。作者是有为无常也

善男子东方双者破于无常(至)大寂定者名大涅槃

案。僧亮曰。八树拟八法也。八法于兹而显也。犹明处是耳

师子吼言世尊如来何故(至)我于二月入大涅槃

案。僧亮曰。有待时漏尽者。时节即道也。说如来真实者。就起四倒之时破说者。六时者。犹是三时各分为二也。宝亮曰。修道之第五文。次时为道也。既是众生入道之津。由遣其横计之情。令觉虚而安理也

师子吼言如来初生(至)而是母人实不死也

案。僧亮曰。以初生乃至初得道。皆方便。非圆极故。因未满而显之也。今所明理圆。寄满月也

师子吼菩萨言世尊何等比丘能庄严此娑罗双树

案。僧亮曰。修道之第六。寄人以明道。所谓待伴漏尽也

善男子若有比丘受持读诵(至)常住于此娑罗树木

案。僧亮曰。法由人弘。故问弘法之人也。宝亮曰。众生根性不同。若应以千人为缘。少一人则不悟。要须数足。今略数人。若广列者。其事亦难。具可顿显也

佛言善男子一切诸法(至)汝云何言愿如来住

案。僧亮曰。修道之第七文。次遣着。以明道也。道者。忘怀为德。如其存住。即便背道。今就此门中有三翻。皆是遣执也

善男子凡言住者名为色法(至)南西北方四维上下

案。宝亮曰。第一释疑云。如来既入涅槃。便不得自在。今遣此执也。佛已断一切色缚。累尽而体无相。若不达于空。可存有去住也

善男子若有说言身口意恶(至)于拘尸城亦无是处

案。僧亮曰。有为相续。故住竟无实住。如来永断有为。不应请住也。宝亮曰。第二遣执。向既辨道相。但空理难安。于下愚未悟故。引譬以明。理谓必然。功夫行善。不可使得恶果。亦不可使行恶得善果。两因既不可使。回换明道。是无相无为。竟何所住耶

善男子如来今于此拘尸城(至)以是因缘入禅定窟

案。僧亮曰。上云。涅槃无生无诸有。如来即涅槃。而言。王宫之生。双树之灭。谓以出动为生。入寂为灭。应物之迹也。何故入禅定窟者。将显现灭之旨。以益当时。故发问也。宝亮曰。劝行佛所入定。为化众生。得无相涅槃也

师子吼言世尊无相定者(至)以是义故涅槃名常

案。僧亮曰。重问涅槃无相义也。明涅槃之中无十相之苦。欲令行者修因。起之为乐。知着相为失。无相为得也。说道有广有略。初从灭定。讫时方广门也。今略门有二。但说始终此定也

师子吼言世尊何等比丘(至)修集舍相是名三相

案。僧亮曰。已说涅槃无相之利。利由因得。故问也。时时修集。至是名三相。一是修时。一是应修时也。定能除乱。慧除颠倒。舍调迟速。略问举要。此三者涅槃之要行也。宝亮曰。修道之第八文也。出能修道人。明菩萨无时不修定慧舍三法。故言时时也

师子吼言世尊云何名为(至)慧舍二相亦复如是

案。僧亮曰。若心在缘。不散为定。念念取缘。皆不散也。心在一境。至不名三昧。若心相续。一境名定也。如其非定非一切智者。缘四则非定。所以互破者。修定慧为一切智。一切智者。无法不知。名一切智。审定名智。一体具二。不具非一切智也。非一切智云何名定者。若不余缘。不知一切。非直失一切。亦复失知下。以行为异耳。定慧亦如是者。亦以非定破慧。非慧破定也。宝亮曰。既唱此三名。时众有疑。故师子吼。于一法中。作三难也。举定为隅耳。慧舍亦然也。此第一谓。众生自有三昧。何须修耶。第二难云。定本摄心一境。佛既遍缘万境。便应非定也。第三难云。若以一行得三昧者。是则六度之中。唯一禅是。余五应非。若定不能生智。亦非定也

佛言善男子如汝所言(至)如是余缘亦一境故

案。宝亮曰。先遣第二难。唯使一境中得定。则一切境悉静照。故言如是余缘亦一境也

行亦如是

案。宝亮曰。答第三难也。夫六度之行。无非是静。悉缘中解用。岂非智耶

又言众生先有三昧(至)云何而言不须修集

案。僧亮曰。答意虽分分别四谛。皆得重缘。亦定亦智。善三昧者。为涅槃修善三昧。非心住境。便是涅槃因也。宝亮曰。答第一难也。此言三昧。名善三昧。一切众生心行。虽有善恶。不取此心为定也

以住如是善三昧中(至)见佛性者名为舍相

案。僧亮曰。此下广说善不善相也。宝亮曰。此下凡有三翻。明此三法也。第一直总明定慧舍相。第二从奢摩他。名为能灭。以去别解。此三法也。第三从奢摩他有二种。世间出世间以下。偏释定慧二法也。十住菩萨智慧力多三昧力少者。若摄心在境。不驰荡外缘。目之为定。十住菩萨未居极位。不免企上之心。故义言智多定少耳。此非了义言也

奢摩他者名为能灭(至)亦名不行是名为舍

案。宝亮曰。第二释也。奢摩他。此名为定。此中以五种义释定也毗婆舍那。此言智慧。此文中有六义释也。忧毕叉者。此言舍。据空解为目。文中有四义释也

善男子奢摩他者有二种(至)善男子是名三昧相

案。僧亮曰。上总说。今别三相之能也。宝亮曰。第三别释定慧深浅之相。舍无别体。故不分门也。此中自有二意。一正各辨定慧深浅之相。第二明修定慧有所为。定中深浅相者。世间曰有相定。出世间名无相定也。此先辨定深浅相也

善男子慧有二种(至)复有四种所谓观四真谛

案。僧亮曰。下别说定慧二体。舍无别体。不说也。宝亮曰。辨慧之深浅相也

善男子为三事故修奢摩他(至)为破一切诸烦恼故

案。僧亮曰。上说三相多能。今说为能中要者。故修也。宝亮曰。第二重。次明修定慧有所为也。先有三句明定。后有三句明慧。合定慧二门。凡成六句释义也

大般涅槃经集解卷第五十九大般涅槃经集解卷第六十

  犹明奢摩他毗婆舍那　辨断烦恼义显二种灭谓性灭毕竟灭　以三空三昧配定慧舍相　明成就十法见无相涅槃　辨施畜生得百倍报及施阐提千倍报　广辨轻重业定不定业及报定时不定等　广辨菩萨无三涂业见受报事　出调达与佛为商主缘起　出迦罗富王刑婆罗门缘起　释修道力转重业为轻业

    师子吼品之第七

师子吼言世尊如经中说(至)何故复修奢摩他耶

案。僧亮曰。上品末慧能破结。今明非直慧功。要须三法合用。故先说定耳。宝亮曰。修道之第九也。明定慧相资。上既出能修道之人。今次辨定慧合用。故先问也。若智慧能治惑。何须修定。凡夫谓智慧能断惑故。谓烦恼如事像。为智慧所除也。佛今就五门中。释无断义。若不修定。则不达见。五门者。第一就实法。第二就空门。第三就到不到。第四明伴非伴。第五推性灭。此五门中捡。并无破义

佛言善男子汝言毗婆舍那(至)明能破闇无有是处

案。僧亮曰。能知诸法自生自灭。慧不能破。非定心见也。宝亮曰。第一门。智慧生时。三相所迁。当体自灭。实法道中。有何能破所破者耶

善男子谁有智慧谁有烦恼(至)如其无者则无所破

案。僧亮曰。第二门。辨破与不破。无主故空也。宝亮曰。第二门体性俱空。故无能破也

善男子若言智慧能破烦恼(至)而能破者是义不然

案。僧亮曰。第三门有无也。智起则有。故名到起则无。故不到也。初念应破者。一念破一切结。是则不到者。如明闇相违。明起闇以过去。明不及闇不到。则同凡夫也。宝亮曰。第三门语势。如以智到烦恼时破。不到时不破。义意不尔也。谓能破者。为当智到行人心时能破。为当未到破耶若未到而破。则凡夫应破。若到故破者。则初念应破。而今行人有无量念。若初念不破。则不须后念。若果初到便破。是则不到也。智慧念念生灭。初不相及。有何到不到义。若言到不到合故能破。亦无此义

复次毗婆舍那破烦恼者(至)毗婆舍那亦复如是

案。僧亮曰。第四门明伴非伴门也。宝亮曰。第四门辨八正道中。为一道能破。共故能破。若一能破。则不须具修于八。若一不能。八亦不能。乃举盲者为譬。以晓之也

善男子如地坚性火热性(至)决定不能破诸烦恼

案。僧亮曰。第五门辨灭不灭也。烦恼性灭。智不能灭。若性不灭。智亦不能灭。先以五大为譬。坚他作亦应尔也。宝亮曰。第五门。开此中为三意。明亦无断义。初以四大为况。各当自性。谁使之然耶。次意云。若言如盐性碱强。令异物碱。智慧强令烦恼灭者。亦不然也。后意云。烦恼与智慧。俱念念灭。而言智慧能断。亦不然也

善男子如盐性碱令异物碱(至)智慧之性不破烦恼

案。僧亮曰。明结性非灭智不能灭。若以碱能令淡。譬智能灭结也。是义不然。何故者。咸淡不俱。碱生之时。淡已过去也。过去自灭。非碱灭也。若法无灭。云何智慧强令灭者。若过去法灭。非自灭者。云何强令耶。云何而言能灭惑。他法者为外家生。意通上强难也。谓智明力强。惑闇性弱。智能灭惑者。亦不然。何者。二法皆生时即灭。生死强弱。何能灭他也

善男子一切诸法有二种灭(至)生异灭异无造作者

案。僧亮曰。物有强令他灭。理不可然。引而破之。一念念如水。灭已续生。即上性灭也。如火焚薪。更不复续。毕竟灭也。应有余烬者。色非虑解。不待方便。任运应起是有也。火缘横夺。故有余烬存。可言强灭。心待方便。未来未有。非强灭也。宝亮曰。上五门说法。明无所断。今从性灭究竟灭下去。定于法相。烦恼亦起即谢。不假治道。故言性灭。究竟灭者。就得解作语。从起一念痴后。则于万境上不识。若修道得解。于万境上悉明。迷用永不起。名为究竟灭。夫道生之时。亦无烦恼可断。若解无断而断。名为正义也。本无解时常痴。若一刹那明起。于境悉达。第二运去。方受断名。前一念无所形。故不得名也。若至第二念去。云向痴今解。本不断今断也

善男子若修集定(至)乃至阿耨多罗三藐三菩提

案。僧亮曰。由心不教慧。得见空定之用。能大利益者。断烦恼利也。宝亮曰。劝行人。若不修定。则不得正智正见。亦不体上五门破不破之义也

善男子菩萨摩诃萨具足(至)菩萨定慧亦复如是

案。僧亮曰。第三舍用。舍无别法为体也。执急则断者。草缓则失。急则断也。专空着断。譬定多也。舍空著有。譬慧少也。于空不空。于有不有。定慧等舍之用也。宝亮曰。此下正辨定慧相资合用之意

善男子譬如工匠甘鐹盛金(至)修是二法能大利益

案。僧亮曰。甘鐹譬定。挠搅譬慧也

善男子菩萨摩诃萨(至)是则名为大涅槃乐

案。僧亮曰。上说断结。下说一切德。皆由三法所成也

善男子定相者名空三昧(至)是名菩萨行菩提道

案。僧亮曰。有相观生死也。无相观涅槃也

师子吼言世尊云何菩萨知时非时

案。僧亮曰。将释上时非时之义故门也

善男子菩萨摩诃萨(至)是名菩萨知时非时

案。僧亮曰。不宜修智者。智增则慢甚

若有菩萨勤修积集(至)是名菩萨知时非时

案。僧亮曰。不宜修定者。是人根钝。烦恼势盛。自疑犯戒。皆由着定。所以宜修空慧也

善男子若有菩萨定慧二法(至)以是因缘得相涅槃

案。僧亮曰。二法虽等。烦恼提起。应更两修。能制烦恼。然后舍也

师子吼言世尊无十相故(至)即得明了见于佛性

案。僧亮曰。将为始行之人。更问涅槃十有余名。显无相之利。令始行修之信也。宝亮曰。此下修道之第十文也。广因果以结句。若具此十法。则能见佛性。得无相涅槃也

师子吼言世尊菩萨摩诃萨(至)是名菩萨信心具足

案。僧亮曰。信心具足者。信为行始故居十法之初也

二戒具足云何名为(至)则能明见涅槃无相

案。僧亮曰。释备十行也。可断者谓生死。不可断者涅槃。从缘生者有为。从缘见者无为也。果亦如之

师子吼言世尊如佛先告(至)三菩提是义云何

案。僧亮曰。第五转障门。修道转业次道说也。纯陀受报。未有尽期。云何得成三菩提耶。僧宗曰。上缚解修道。成因中已有之难。今转障劝修。成前无性七执。所以尔者。其云下至畜生。上穷诸佛。皆为福田。若施之者。则福报无尽。岂不以因中无性。永在三有耶。就转障中。有五段文。初明善恶业转障体。第二明菩萨以愿力。生地狱中。非为实生。简出此也。第三还正业体。上言业可转。人情谓。业报浑乱。故更辨。虽复有转。然业报之义。岂可彰耶。第四明上虽言转。今出其人。第五明人行何行。故能转耶。明以如此行故转。即出转业之行也。宝亮曰。将明业不定。故先引昔教定业作难。非唯恶业障道。善业亦能障。如昔说。若重心作业。必受果报。若尔纯陀今者。重心施佛。受人天果报无尽。何当入圣耶

世尊如佛经中若施畜生(至)阿耨多罗三藐三菩提

案。僧亮曰。此明地胜报不可尽业障也。僧宗曰。施畜生者。举偏教为难也。施阐提者。取其人类也。下极畜生。上穷诸佛。善恶同然。其报无尽。都不明转义。是以牵此为难。依如昔教。世尊受纯陀之供。则护报无量。何有见佛性成佛时耶

世尊经中复说若人重心(至)云何复得见于佛性

案。僧宗曰。第二难。以心重故。果应无尽也

世尊经中复说施三种人(至)二父母三如来

案。僧宗曰。第三举三种病人。起慈悲之重。父母以恩养边重。如来以四中最胜。施此三。其福则等。引此为证也

世尊经中复说佛告阿难(至)色无色业亦复如是

案。僧宗曰。第四举昔成说。如其无三业者。必成菩提。是则众生未曾无此之业。则感报无穷。何时当成菩提耶

世尊如法句偈非空非海中(至)脱之不受业

案。僧宗曰。第五举必报不可免也

又阿尼楼驮言世尊(至)具足成就檀波罗蜜

案。僧宗曰。第六举一食之施。尚得八万劫果。以浅况深也

世尊若善果报不可尽者(至)阿耨多罗三藐三菩提

案。僧亮曰。此明心胜也。僧宗曰。第七以善业。类不善业。乃至阐提受报无穷。则无佛性也

佛言善哉善哉善男子(至)佛十力中业力最深

案。僧亮曰。业已久灭。果在后生。此理难见。喜生疑谤。故言深心也。僧宗曰。将答所问。故先致叹也

善男子有诸众生(至)为度彼故作如是说

案。僧亮曰。开昔定说门也。僧宗曰。昔说重报。不可转移。为人不信。故作定说。若穷捡于理。则不如是。夫业乃非不得果。但更有余缘。脱其前果。故言可转也。宝亮曰。本为下愚无智者说也。众生于中。不信得果。故唱言是定也

善男子一切作业有轻有重(至)一决定二不决定

案。僧亮曰。开今不定门。是为一切不定也。宝亮曰。此下一往先开三门。第一辨不定。第二出愚智。第三出二人所行之法

善男子或有人言恶业无果(至)一切作业无不得果

案。僧亮曰。释昔定说门也

善男子或有重业可得作轻(至)虽不定得亦非不得

案。僧亮曰。从作业有轻有重。此第一翻。明业皆不定

善男子一切众生凡有二种(至)现也轻业地狱重受

案。僧亮曰。释不定门也。唯有愚智者。释所以不定者由人也。重恶轻受。非都不受也。僧宗曰。此正释转义也。言愚人造业。乃应得轻苦。以其不知惭愧修善之方。则罪障日夜增长。回此轻报。地狱重受。若是智人。昔曾造恶种此业势。既感三途。亦感轻苦。以其有修身戒心慧之缘。遂使重苦之报。不复受也。但受头痛等苦故。义唱为转也。宝亮曰。此第二出愚智二人也

师子吼言世尊若如是者(至)清净梵行及解脱果

案。僧亮曰。难意若定受者。可修梵行。求解脱不定。何用求离耶。僧宗曰。业既不定。会当转恶生善也。宝亮曰。此下第三出愚智二人所行之法也。将欲明义。故师子吼先作此难云。若必不定。则自得去。何用修道耶

佛言善男子若一切业(至)则修梵行及解脱果

案。僧亮曰。答意若以决定。云何可脱。缘不定故。所以须修梵行。以求解脱耳。僧宗曰。正以法相不定故。可得修有转义也。若使定不可转者。恶家常应为恶。乃至少时作业。应少时受

善男子若能远离一切恶业(至)云何而有修道涅槃

案。僧亮曰。重举诸业。谓若定者。则有如是失也。宝亮曰。正以不定故须修道。若必定者。修道何益耶

善男子业有二种定以不定

案。僧亮曰。此下广前三门。后又重举愚智二人。总结句。并合前后凡七门

定业有二一报定二时定(至)所谓现受生受后受

案。僧亮曰。释上定不定业也。优婆塞戒说。业有四种。一报定时定。二报定时不定。三时定报不定。四时不定报不定也。今说二者。以初二报定。合为一也。僧宗曰。向已明有转。今广出报定世定。为彰可转之义。言报之为理。不出世定报定。若世报俱之。此家为重。若报定世不定。此为第二。若世定报不定。此为第三。若报世俱不定。此为第四。宝亮曰。此下竟三报业。悉为证初第一门业性不定意业有二种。定以不定。今开四句明业体。第一时定报不定。此人作业之时。莫问轻重。但是猛利心中作也。作业成后。更经营运誓心来逐此业。名为业定。若此时差。则永不复受也。报定时不定者。此人作业之时。心极殷重。未必决断。复无誓心。故或现受生受后受也。俱不定者。作时不重。又不决断也。二俱定者。与上相违

善男子若定心作善恶等(至)供养三宝是名定业

案。僧亮曰。释定业也。宝亮曰。此四句。第一。第二。第四。于愚人悉定也。若智人者。四句皆不定。愚人无身戒心慧故。所以皆成定报也

善男子智者善根深固难动(至)一切诸业不名决定

案。僧亮曰。释不定业也

菩萨摩诃萨无地狱业(至)非现生后受是恶业

案。僧亮曰。已断定业不定业。不定业愿受之证。一切业不定。令地狱空者。说生之益也。宝亮曰。智人有此四德故。皆不定也。所以菩萨恒在地狱。开悟众生。若其业定。何能使物离苦。升人天进德也

复次善男子是贤劫中(至)非现生后受是恶业

案。僧亮曰。前说无地狱业。此说无业而现受。宝亮曰。明诸菩萨化生其中。以证业之不定

复次善男子是贤劫中(至)非现生后受是恶业

案。僧亮曰。次说无饿鬼业亦现受也

善男子我于贤劫生屠脍家(至)非现生后受是恶业

案。僧亮曰。次说无十六恶律仪。亦现受也

善男子是贤劫中复生边地(至)非现生后受是恶业

案。僧亮曰。次说无八难等执障

善男子我念往昔(至)是名菩萨摩诃萨说现世报

案。僧亮曰。广出提婆达多。往昔缘起事耳

善男子我念往昔(至)是名菩萨摩诃萨说现世报

案。僧亮曰。又广举缘起。重证久来无也

善男子善业生报后报(至)一切诸业悉得现报

案。僧亮曰。向明现报。今举生后亦如是。皆是慈善愿力。亦现受也

不善恶业得现报者(至)是名恶业现受果报

案。僧亮曰。向明以善业愿受。今明以恶受也

生报者如一阐提犯四重禁及五逆罪

案。僧亮曰。此三人皆重。故生报也。唯人能起此业。而人身小。受苦少故。不得现受也

后报者如持戒人深发誓愿(至)转轮圣王教化众生

案。僧亮曰。净戒身报。得净戒身。及转轮王。非一身可集。故后报受也

善男子若业定得现世报者(至)无善藏者轻业重受

案。僧亮曰。现报业轻。不能得后报。后报业重。故现生正报也。宝亮曰。凡有十二譬。广上第二门出愚智二人事也。盖欲显智者之解。愚者之蔽。可不诫哉

大般涅槃经集解卷第六十大般涅槃经集解卷第六十一

  广辨转障义　广释修身义举四蛇一箧为喻　广释修戒义　广释修心义　广释修慧义　重明修身戒心慧义　重明转重为轻转轻为重义　师子吼重举六事为难谓不须修道　佛举恒河七人譬明应须修道广答前难　明佛性常故不在因中如十二因缘无定住处

    师子吼品之第八

师子吼菩萨言世尊(至)地狱重报现世轻受

案。僧亮曰。上说愚智二譬。未说二人所行。今说身戒心慧。是智者所行。以证道能转障也。僧宗曰。此下广明二种善恶业相也。谓人用如此业则转。用如此业。则不转也。宝亮曰。此下第三广上二人所行之法也。将明所行法故。一往先举二人也。就此中。明清净梵行。凡有三种也。若依今日经教。修身戒心慧。一切业悉不定。修身者。作四念处观。修戒者净身口意。得正语正业戒。修身者。得释定。修慧者。入无漏解。若修此四法。则转重业而轻受。论此义实难解。若修相善。遏重用轻。理亦可然。而今修此四法。乃是无漏。初无漏力。自能治重者。余轻业非已家之力。自人天中受。何转之有。理实无轻。今有此言。为于愚人。愚人既闻此之说。便欲勤修。若修此四成就。则重者先遣也。余业在人天中受者。本是向者。重家之眷属。凡作此重业。要有方便。非忽然顿重。若使无向四法。莫问轻重。并受地狱报。今既修四力。所余轻者。不能独得重报。于人天轻受。故云转重为轻。转轻为重义亦然。轻业本应得人天。既无心戒力。遂将此业。在三涂中受。亦非轻业得重处也

佛言一切众生凡有二种(至)身戒心慧是名愚痴

案。僧亮曰。下有复次。明此四法寄一深浅广略为辞耳。此且总判愚智二途也。辨修不修也

云何名为不修身(至)不修圣行名不修慧

案。僧亮曰。第一翻。五根是身业。亦是烦恼。导首故说也

复次不修身者不能具足(至)不修慧者不修梵行故

案。僧亮曰。第二翻。戒以防身。戒不具足。谓不修身也

复次不修身者不能观身(至)不善护心名不修慧

案。僧亮曰。第三翻。就观门为义

复次不修身者不能深观(至)不能具足般若波罗蜜

案。僧亮曰。第四翻。就无常门。为义也

复次不修身者贪着我身(至)不能分别善恶等法

案。僧亮曰。第五翻。重明上不观为果也

复次不修身者不断我见(至)不修慧者不断痴心

案。僧亮曰。第六翻。不断身见。故不名修也。宝亮曰。上来至此就相涉之义以明四法。若能行此四法。必得其所者。则成智人也

复次不修身者不能观身(至)往日供给衣食之恩

案。僧亮曰。第七翻。不能观身。五种过患。此有五阶。明五门也。此总明五门过患也。宝亮曰。此下讫金翅鸟。第二历别明四法也

善男子譬如有王畜四毒蛇(至)若一大嗔则能坏身

案。僧亮曰。譬苦门也

善男子如人久病应当至心(至)一切众生身亦如是

案。僧亮曰。譬无常门

善男子亦如芭蕉内无坚实一切众生身亦如是

案。僧亮曰。譬空无性门也

善男子如蛇鼠狼各各相于(至)众生四大亦复如是

案。僧亮曰。譬不自在门也

善男子譬如鹅王不乐冢墓(至)作如是观不名修身

案。僧亮曰。凡七譬。不净门也。七种者。一种子不净。二住处不净。三出门不净。四体性不净。五九孔不净。六诸虫不净。七污净物衣服

不修戒者善男子若不能观(至)如是观者名不修戒

案。僧亮曰。恶者不见其过。善者能识其罪。身应观其过。戒慧应识其能也

不修心者不能观心(至)不能如是观者名不修心

案。僧亮曰。着相之心。众患之主

不修慧者不观智慧(至)不能如是观者不名修慧

案。僧亮曰。真慧佛菩萨母。有能修习名种子也

善男子第一义中(至)若有如是见者名不修慧

案。僧亮曰。第七翻。此最深也。身是假也。戒心慧亦如是。宝亮曰。此下正明修。此四法得所之意也。谓若妄修者。则此四速成。如其有存。虽行无益。此第一义。非空之第一也。但明凡夫有执实之计心。据此为第一耳。若见身是实。不从因缘作如斯。修身非谓修也。余亦如此也

善男子若有不修身戒心慧(至)若似地狱有何苦事

案。僧亮曰。谓不修四法。定取罪相。言是我有。虽闻智说。不生恐怖也

譬如苍蝇为唾所粘(至)是人罪业亦复如是

案。僧亮曰。重显愚人。[雨/復]藏不悔。遂长小成大。举三譬以为喻也

师子吼菩萨言世尊是人何故令现轻报转地狱受

案。僧亮曰。上说不修四事。未说所以不修。欲明具下诸恶。故登问也。宝亮曰。上已广略六门。此四法竟。今此下第七更举二人结句。广辨愚人之恶。略明智人之善也

佛言善男子一切众生(至)现世轻报地狱重受

案。僧亮曰。举两翻五事。释所以不修四事。而能转轻为重

师子吼言世尊何等人能转地狱报现世轻受

案。僧亮曰。向明愚者之失。今明智者之得。是以次有咨也

善男子若有修集身戒心慧(至)地狱果报现世轻受

案。僧亮曰。解空故罪。所以不除者。以其人心不着故

是人设作极重恶业(至)能令地狱重报现世轻受

案。僧亮曰。罪恶以横生故。无根空解。以从理故力大。是以真金虽少。犹胜积华

善男子以是义故非一切业(至)亦非一切众生定受

案。僧亮曰。总结上旨也

师子吼菩萨言世尊(至)悉不得是大般涅槃

案。僧亮曰。第六劝修也。以道能转障。故劝修也。有两难。此第一若言业不定障而性是定因者定胜不定。何故不以性故得耶。僧宗曰。犹成前无性七执。谓若有性。则自然成佛。何须劝修。正以劝修方得。故知得佛之时。始有性也。凡有四段。第一五难。令因中无性。若必有者。自然至佛。佛以七种人总答也。第二明如来所见。真实明了。不同凡夫。凡夫如盲人问象。如来则会中道。故不须劝也。第三出佛性体。以验不谬也。第四正劝令修也。宝亮曰。若欲近离重障。远取佛果。莫过修道。所以劝也

世尊若一切众生有佛性者(至)何须修集八圣道耶

案。僧亮曰。第二难也。性是定因。因力则强。强故不须修道相助也。宝亮曰。下去凡五翻。上来至此。第一翻。师子吼难。若众生有正因佛性。何不率尔而得涅槃。而方修虚假之缘因耶

世尊如此经中说有病人(至)何以故以佛性故

案。僧亮曰。此下有六事。证不修道。以成第二难。此第一事举经也。宝亮曰。第二翻。若众生有正因。正因之力。应自然成佛。何用修道。下举五事。以证成此难。明不假道力

世尊譬如日月无有能遮(至)不以修集圣道力故

案。僧亮曰。此中举三事。一举日月自然。至頞多山。二举河必归海。三举阐提必入地狱。皆不假因缘也。宝亮曰。此中举三事为证也

世尊若一阐提犯四重禁(至)非因修集然后得也

案。僧亮曰。第五事明得菩提。不由修道。乃关佛性。以证业不定障也。宝亮曰。第四事也

世尊譬如磁石去铁虽远(至)是故不须勤修集道

案。僧亮曰。第六事更无别法。直以性故。两吸铁也。宝亮曰。此第五事也

佛言善哉善哉善男子(至)离诸怨贼受大快乐

案。僧亮曰。答初难也。七人皆具手足譬佛性。习浮者度。不习不度。譬修道也。众生亦尔。皆有佛性。不修圣道。不得涅槃。是烦恼过也。众生以三事入生死。一以洗浴。譬断烦恼。二以恐怖。譬畏生死苦。三以采花。譬修功德也。僧宗曰。下取阐提。上至诸佛。为七人也。若为洗浴者。言无漏圣人。能永断烦恼。如洗浴去垢也。或为恐怖者。声闻二乘。怖畏四魔。或为采花凡夫。贪世五欲。以悦其情。此三种人。各有所为。故同入河中。运其身手。明若凡若圣。期心不同。故生死河中。各修其善。随其力用不同。故有七种之别也。宝亮曰。今将恒河中。七人答第一难。如恒河边。七人悉有手足。若不习浮。不能得度。众生虽有佛性。要久习缘因善。方乃得成佛。云何难言。率尔行道。而得佛耶。此中借恒河为譬者。用生死为河。明众生虽复在生死河中。要未识生死。及至观解信圣之语。方觉其过。故言入河。入河之意。凡为三义。第一譬除烦恼。第二畏生死八苦。第三如修万善。此恒河中七人。虽尽曾为一阐提来。要当时行异。第三人信常故畏行成。资斯之解。仍得出生死也

善男子生死大河亦复如是(至)如恒河边第一人也

案。僧亮曰。第一人谓阐提也

善男子一阐提辈有六因缘(至)是故常没三恶道中

案。僧宗曰。初譬外凡夫。乃至阐提以无智慧正见之心。不习修道之浮故

第二人者发意欲度(至)如恒河边第二人也

案。僧亮曰。第二暂出还没。不习浮者。本不修戒定慧也。僧宗曰。虽复习观。四意止而智力未深。其人犹退。言没已还出者。以其习观见理义为出。未可是名故。言出已复没也。力大故出者。既观无常苦等。于外凡为大力也。不习浮者。如观力浅故也

第三人者发意欲度(至)如恒河边第三人也

案。僧亮曰。譬得暖法已上也。僧宗曰。五根已立。乃至见谛十五心已来。悉不退位也

第四人者发意欲度(至)如恒河边第四人也

案。僧亮曰。譬四果也。僧宗曰。观四方者。谓四果人。观谛平等也。住者习浮故不没。小乘不希更进。故如住也。不知出处。故观方者。夫真知出者。于生死化物。若巧方便。所以知出。二乘不知大士之慧。故言不知出也

第五人者发意欲度(至)如恒河边第五人也

案。僧亮曰。譬缘觉无自悟小胜声闻也。僧宗曰。缘觉也。言观方已去者。其比于声闻。根力为胜。虽不向佛。以断习而侵三界外惑。故义言去也

第六人者发意欲度(至)如恒河边第六人也

案。僧亮曰。譬菩萨也。僧宗曰。初地已上。乃至十地也。浅处者。初地所断。不及二乘。积因已久。善力薰修。于一念中。称量生死。其惑虽在。而断之不难。是则生死有崖。所以言之浅处也

第七人者发意欲度(至)大高山者喻大涅槃

案。僧亮曰。譬佛也。僧宗曰。大山谓涅槃也

善男子是恒河边如是诸人(至)一切众生不得涅槃

案。僧宗曰。悉具手足。不习浮者。虽有佛性。不修习道。何由得佛耶。此譬既释。则五难自消

善男子譬如良医(至)即得阿耨多罗三藐三菩提

案。僧亮曰。手足习浮之因。不习戒定慧故。不能渡河

善男子汝言众生悉有佛性(至)不修圣道故不得见

案。僧亮曰。答第二难也。先举最后证。谓譬菩提。灌绠汲取譬八圣道也。僧宗曰。举第五事别答。明有果如磁石故。岂可不须修道耶。宝亮曰。答第二难。石能吸铁。若缘不具。则不能也。众生亦尔。虽有佛性。若不修道。则不得也。有人行旷野者。譬凡夫行生死也。渴乏者。厌苦情发也。遇井者。涅槃经教也。极深者。因果性理难知也。虽不见水。当知必有。因果性虽难知。未来必有也。求觅灌绠者。譬修道也。井虽有水。无灌不得。众生佛性。云何不修道而见耶

善男子如汝所说世有病人(至)诸菩萨等说如是义

案。僧亮曰。答初证也。分段烦恼尽。任运自成佛耳。僧宗曰。举第三事也。所以言悉差。乃为六住菩萨。岂是常流。而当不须修耶

善男子譬如虚空于诸众生(至)以定得故言一切有

案。僧亮曰。下举三事。非内非外。为譬也。虚空非内外。而众现用。佛性非内外。故众生必有用也。僧宗曰。就因而求。故言非有。不离因而有果。故言非无也。非无因出者。要籍了因乃见也。非此作此受者。非即身修因。即身受果。非此作彼受者。捉一人终始。虽为不同。而非止此身。修习缘因。未来乃见。义称非此作彼受也。彼作彼受者。非是异人修善。异人见性也。非无作无受者。要须修因。其理不得异。岂是终始无作。而不受果耶。宝亮曰。此下第三历正因性也。虚空非五阴内。亦非五阴外。以得佛故。言众生悉有耳

善男子譬如众生造作诸业(至)时节和合而得果报

案。僧亮曰。为因性得果为譬也。业非内外者。如施非独我故非内。得非受者故非外也。是二中间。不可得故。非有非无也。施从因得。非本无今有。不从外。来非无因出也。灭故不一。非此作此受。续故不异。非此作彼受也。由因得果。非无作无受。以时节和合。须众缘和合。得果报也

众生佛性亦复如是(至)尔时得见不名为作

案。僧亮曰。从了因见。故非本无今有也。内谓缘因。外谓正因。遍因无内外也。因中不可得。故非有。从二因见。故非无也。亦非遍因。故非此彼。非无因缘。以修道得见。故非余来也。非无因也。通答中间三证也

善男子汝言如磁石者(至)有佛无佛法界常住

案。僧亮曰。惑谓因能作果。今说因有故果出。因不作异也。以薪不作火。故无有作者。以薪无则火灭。故无有坏者也。僧宗曰。重答第五问。仍释异法合故。异法出生。岂关以佛性。吸菩提耶

善男子若言佛性住众生中(至)一切众生悉有佛性

案。僧亮曰。不以一法为体。无住法界。总十八界也。入阴亦尔。十二因缘。遍在三世无住处。名常。果入虚空亦尔。譬佛性非是一法。圆取则得。偏执则失。四大亦无有业者。四大力虽均等。至各不相似。四力皆等。坚濡色异者。由因异果无作者也

大般涅槃经集解卷第六十一大般涅槃经集解卷第六十二

  举盲人说象譬　明佛性不即六法不离六法义　明佛性十二因缘信等　辨菩萨不退相日食一麻一豆等事　出菩萨以身施众生发愿事　出菩萨为众生受苦不退事　出天海八种不思议譬

    师子吼品之第九

善男子譬如有王告一大臣(至)以是故说色为佛性

案。僧亮曰。各以手触者。譬闻见也。同不说象体。偏见非象。亦非不说者。各得其分。非不说也。色是佛性者。正因性异。成果亦异。以偏着为失也。如金色是一槃蛇为异也。僧宗曰。第二翻也。明如来说性不同。凡夫既真而无谬。故应修也。王者譬佛。臣者譬常住经教。象譬教下理也。盲者随所触而说象。众生无慧。乃计阴说我也。说离阴有我者。此计太过。下当非之也。非即六法。不离六法者。以五阴成假名人。佛性在果。岂即六法非因。无以感果。故言不离也。宝亮曰。盲人触象。若一一而望。不得象体。然复不得离此而有象也。外道凡夫。捉五阴及离阴。一一计非佛性。然始终不离此六法也。有诸外道。虽说有我。而实无我者。破第六别计五阴外有我。谓五阴假合。名为众生。无别五阴外有我也

或有说言受是佛性(至)乃至非我不离我

案。僧亮曰。上举色。今举心历心。称四阴也

善男子有诸外道虽说有我(至)第一义空故名佛性

案。僧亮曰。就惑情为离也。故是即阴我相续不断耳。后还正之。谓离阴别我也

善男子大慈大悲名为佛性(至)佛性者即是如来

案。僧亮曰。说缘因性。众生必得。故名有也。相续不异。即如来也。僧宗曰。第三出佛性体也。宝亮曰。第四历缘因四无量行。即是缘因。善菩萨常行。如影随形也。佛性名如来者。行四无量。近得初住一字之地。远则圆满得佛。故名如来也

佛性者名大信心(至)一切众生悉有佛性

案。僧亮曰。举六法门。助显其旨也

善男子如上所说种种诸法(至)一切众生悉有佛性

案。僧亮曰。总结上旨也

善男子若说色是佛性者(至)乃至说识亦复如是

案。僧亮曰。若说色是佛性。余非者。耶见众生。闻必起倒也

善男子若诸众生了佛性者(至)兼复赞叹礼拜问说

案。僧亮曰。既劝修此经名。故说修者之福也。僧宗曰。第四正劝修也。宝亮曰。第五结劝。明应须修道之意也

善男子若有已于过去无量(至)然后乃得闻是经名

案。僧亮曰。叹修者之因也

善男子佛性不可思议(至)大涅槃经亦不可思议

案。僧亮曰。叹三宝佛性经法不可议。显劝修之旨不虚也

师子吼菩萨言世尊(至)得阿耨多罗三藐三菩提

案。僧亮曰。师子吼领。并叙时众得利益。佛即印述也

师子吼言世尊云何不退(至)阿耨多罗三藐三菩提

案。僧宗曰。此下修道之第七也。向以有性故。所以劝修。言修行者。功业转深。不复退转。若不能深识经旨。者则有退转也。如此苦行。多是住前。言因经修行。无利益事。尚为之。岂况有益。而当不为此。明人于经修行。得其理味。永不复退也。宝亮曰。此下修道之第七。正出修道人相。上来虽劝其修道。诸人咸然。不知修道之法。佛今略示其相。若能作如此苦行者是也

善男子菩萨摩诃萨(至)是名不退菩提之相

案。僧亮曰。第七不退相门也。修道必生死。但生死多难。不能自知退与不退。次辨不退相也

复次善男子菩萨摩诃萨(至)是故复名不可思议

案。僧亮曰。第八叹不退菩萨。不思议德也。受后边身者。上说具烦恼性地解地。今说后身义其始终。但举其两端耳。僧宗曰。第八明上地菩萨。备诸胜德也。宝亮曰。叹修道人之德也。人谓苦不可忍。今云。若能立心修道。虽为众生受苦。如三禅乐也

善男子大涅槃经亦复如是(至)彼大海有八不思议

案。僧亮曰。第九叹经。佛及菩萨。功德智慧。经实其本。故赞叹也。僧宗曰。上言人由经益。则经有资成人义。故次叹也。宝亮曰。海有八德。以譬经也。一者因众生之福海则渐深。众生有感。所以经教次第。从浅至深也。二逐风而行。诸佛菩萨。随缘而化也。三河水入者。明涅槃纳众命之器也。下去类尔也

师子吼言世尊若言如来(至)云何独令我受化身

案。僧亮曰。第十叹佛也。以经典佛说理应叹也。但说由慈生。故先问也。宝亮曰。四生之中。化生最胜。而佛为众生。故胎生。恩德之重。所以致叹也

尔时师子吼菩萨合掌长跪右膝着地以偈赞佛

案。僧宗曰。如来是王化之主道被苍生。所以最后兴叹也

如来无量功德聚(至)能吼无量师子吼

案。僧亮曰。彼国以偈为咏歌也。盖盛德之至道也

大般涅槃经集解卷第六十二

弘安八年乙酉三月十日于西大寺宝塔院　为补阙书写之毕　　　　唐人诚心大般涅槃经集解卷第六十三(迦叶菩萨品第二十四)

  广释善星断善根义　出善星未断善根之前坏欲界结获得四禅事　出善星说苦德尼干缘起事　释断善根义　释断善根佛性不断义　释佛性如虚空非三世摄　释阐提身口业皆非善义　释所以听善星出家意

    迦叶菩萨品第二十四

案。僧亮曰。夫为行同有违不违。前师子吼品。辨不违。此品论违也。何者。前品所说。虽有佛性。要修善以成之。此品所说。虽有佛性。而断善者塞之。故知俱论性。而有违不违之异也。法瑶曰。前品广说佛性不一。或因或果。非因非果。或因或缘。或善非善。或言心是。或言心非。或言离阴。或不如是。众说虽非一途。而佛性一也。是则不可偏执一法为是。而余法非也。迦叶今引四十九年。不定之说。偏执者。皆失佛意。谓执往既失。执今岂得耶。若有偏执上所说者。皆不得佛意也。经有明文。下至烦恼诸结众生。五阴善法。皆是佛性。又说性非内非外。亦内亦外。非有非无。亦有亦无。又就阐提。或善根人。四句互明佛性。复引恒河七人。不离佛性水。又言如是七人。若善不善。若方便道。若解脱道。若因若果。悉是佛性。经文如此。岂可以一法偏执乎。若不寻结始末所论。佛性各举一边。以为决定。但以果为佛性者。恐失其知旨矣。前品明生死河中有七人。明不但佛性力故。自得菩提。不修道耶。今明涅槃河中。有七种人。阐提人。闻涅槃经。然后诽谤不信。断善根耳。然涅槃声先冥以远益。谓入涅槃河中。况余六人耶。今明七人虽异。而皆不离佛性水中。虽复两品同明。而所论硕异也。僧宗曰。上第三十四问安乐性。向师子吼发斯论。而所显之旨。犹有未了。今还成本问也。前明阐提虽断善根。犹有佛性。今因善星。广释阐提断善之方。及还生之由。明所断者。是起作之善故。则正因之义存也。释还生之由。所以缘因之理足也。亦以因果相望。则中道详矣。二圣相成。俱显妙旨。但辨理周悉。未必文广也。大分品有六。第一明断善根。第二辨还生。第三明中道。第四显修道。第五劝。第六叹佛也。宝亮曰。师子吼迦叶。但论佛性。其大旨为异者。师子吼就次第从理为谈。迦叶就违背边为论也。师子吼所说。直论从因至果。附理信心。不言先断善根。后更生之义也。迦叶所说。亦言从因次修。然其行未立。还断信心。成一阐提。后厌情还发。能生于善。更进趣取佛。正以此为异。是则师子吼。虽明断善。未辨还生。今迦叶所论。明断善之后。更生之义也。大分为九门。第一明断善根相。第二释所以断善。良由众生根性不定也。第三辨诤论。由根性异。故感教各别。致令互执。乖于中道也。第四广明执着。起邪见之过。正以根性不定。不体佛教。各随所执。诽谤失旨也。第五明后从悉自拔得还生善根也。第六明同得常果。第七释异生死以三漏为因。故感报无常。佛果以真解为资。遣漏尽而体常。第八叹经。第九叹佛也。道慧私记曰。师子吼所问。双树间事。迦叶所问。从得道已来事。科简始末以为异也。又此品就人明性。前品就法明性也。智秀曰。大分此品为六段。第一明断善根。而佛性不断。第二明还生善根。第三明非内外非有无中道。第四明不诤。第五明梵行。第六叹佛也

迦叶菩萨白佛言世尊(至)为大医师作大药王

案。僧亮曰。此下第一明断善根人。断善根相也。将欲设难。无叙师子吼所释。善星比丘。是不可治人也。僧宗曰。就明断善根中。自有六翻。第一明如来慈非不平等。正以善星不受。非如来失。第二广列过失之事也。第三明断三世善也。第四明如来具知根力。能知转下。作中等也。第五广明诤论。释由物情不达教下之旨。致生深罪也。第六明所以断善根。广起邪见也。智秀曰。第一段中六别。第一论断善根。第二明根不定。第三明诤论。第四明执着。第五明邪见也

善星比丘是佛菩萨时子

案。僧亮曰。此下举三事证非不可治也。令先明有深重。故云何不救也。宝亮曰。此下第一难。何不先为善星说法也

出家之后受持读诵分别解说十二部经

案。僧亮曰。次明其有信非都无也

坏欲界结获得四禅

案。僧亮曰。次明善星不无念等善根也

云何如来记说善星(至)地狱劫住不可治人

案。僧亮曰。略结难也

如来何故不先为其演说正法后为菩萨

案。僧亮曰。治病在于始起可治之时。不先治之。要有漏时。非等慈也

如来世尊若不能救(至)有大慈愍有大方便

案。僧亮曰。若可治而不治。是无慈也。宝亮曰。第二责无慈悲。第三喻无方便也

佛言善男子譬如父母(至)当先教谁知世间事

案。僧亮曰。先答父慈等也。虽复教有先后。而不违慈义。以譬佛慈等无偏也。宝亮曰。此下先答第二难也。我久知其当断善根。故于尔许年中。接引说法。为后世作益也

迦叶菩萨白佛言世尊(至)为慈念故次复教之

案。僧亮曰。人以知见为乐。父慈虽等。然有能速成者。应先教也

善男子如来亦尔(至)为生后世诸善种子

案。僧亮曰。合譬之意。意在不偏必有利益。广弘一灯之化者。应先教也

善男子如三种田(至)第三喻一阐提

案。僧亮曰。义如上释

善男子如大师子杀香象时(至)演说法时功用无二

案。僧亮曰。终用一方便力耳。上明虽复先后。而慈用实等。今明三时方便。常尽其力也。宝亮曰。答第三难也。明佛非无大方便。但于善星。方便不显耳。如彼师子。于二狩之间。虽等其力。菟则不设也

善男子我于一时住王舍城(至)而彼都无信受之心

案。僧亮曰。凡举三事。此第一缘起也。薄拘罗是恶鬼之名。夫化之所被。以信为本。而阐提断信。释所以不受化也。僧宗曰。此下第二广说断善之过也。宝亮曰。此下正明善星断善根之相。兼证释向第二第三答也。佛虽有大慈方便。而善星净信。意难出故。无所益也

善男子我于一时在迦尸国(至)而彼绝无信受之心

案。僧亮曰。第二缘起。宝亮曰。既以不信为心。亦遮人为信故。心死虫置佛迹上。使耳目之徒生异想也

善男子我于一时与善星(至)而彼绝无信受之心

案。僧亮曰。第三缘起也。虽复同列不信。而此一事。偏论反舌。罔没尊圣。弥见其心矣。所以二问苦得者。欲知即事。与佛语相应已不也。而苦得既已。身验所以反根。善星因而诫之也。宝亮曰。圣化无方。应物非一。彼既心怀妒。云何可救也

善男子善星比丘虽复读诵(至)而我真实谓无因果

案。僧亮曰。此明无慧也。若善由解生。则不可断。不从解生。遇耶则断。昔虽诵读。不由解生。亦不可救。答第二难也。善知相法者。知有二种现知相知也。言佛非现知非一切知也。僧宗曰。虽受十二部经。不解旨故。所以退谤。乃至断善根。况不受持。云何救耶

善男子汝若不信(至)生身陷入堕阿鼻地狱

案。僧亮曰。虚言无效。不如验实也。陷地狱者。慈不积无以灭身。罪熟报至。所以陷也

善男子善星比丘虽入佛法(至)罗刹大鬼之所杀害

案。僧亮曰。佛说三乘因果。而善星竟不获一。以无信故。所以无所得也。放逸故。恶知识故者。放逸即内患。恶友即外缘。备此二恶。终断善根。虽入大海。无获者无信慧之人。虽入法海。亦无所获。自戮而死者。譬放逸。恶鬼所杀者。譬恶友也。僧宗曰。记彼必入地狱。一往如似不慈而是大慈也。何以尔耶。若不记者。则长人耶信也

善男子是故如来以怜愍故(至)以恶邪故不舍恶见

案。僧亮曰。答第三难也。虽以怜愍为说。以其放逸。终不可改也

善男子我从昔来见是善星(至)斯下之人地狱劫住

案。僧亮曰。答第四难也。若内有微善。可方便外授者。斯人可度也。若内无微善。虽外方便。亦无如之何也。宝亮曰。答第一难也。善星若有微豪善者。岂容记其是地狱劫住不可治人耶。由是其一阐提故耳

善男子譬如有人没清厕中(至)是故不得拔其地狱

案。僧亮曰。手挠之譬大方便。头发譬微善也。宝亮曰。虽有未来之善。而现在重恶。无以资发。故二世皆伏断也

迦叶菩萨言世尊如来何故记彼当堕阿鼻地狱

案。僧亮曰。善星见佛生嗔。即入地狱。佛住似如不慈。欲请以释故。致此问也

善男子善星比丘多有眷属(至)乃至无有毛发许

案。僧亮曰。答意若不往不记者。外则长人众恶。内则久受重罪。是以先记必入地狱。及今往彼。果陷无间。岂是无慈。乃所以灭其恶因也。真实无二者。以人闻佛言故。不信善星之语。则不增外恶。令其受罪少也

善男子我久知是善星比丘(至)是名如来第五解力

案。僧亮曰。不出外故。不生人罪也。第五解力者。谓十力中性力也

世尊一阐提辈以何因缘无有善法

案。僧亮曰。上说现在。无有信慧。名断善根。未明五根。及未来善。故发问也。僧宗曰。此下第三明断二世善也。智秀曰。此下第二段。显断善根义也。六翻明义。此第一求断善根之相

善男子一阐提辈断善根故(至)杀一阐提无有杀罪

案。僧亮曰。杀生以害故罪。阐提无善。但得恶心之罪。无杀罪也

世尊一阐提者终无善法是故名为一阐提耶

案。僧亮曰。将欲咨问。未来善义。故先明此定。谓阐提善根。终意不起耶。智秀曰。第二翻。举终竟以定佛也

佛言如是如是

案。僧亮曰。终竟之义。乃有近远。一生乃至一劫欲开其论端。故且答如是也

世尊一切众生有三种善(至)断诸善法名一阐提耶

案。僧亮曰。举三世为义。取未来应生。即今未生。所以不可断也。终竟之旨。未即可见。智秀曰。第三翻。责未来之法。未起则不可断。不应以断善。故成阐提

善男子断有二种(至)是故我言断诸善根

案。僧亮曰。灭而不续。名之断也。性断障断者。心有三种。善不善无记。若如常人。起不善无记心时。虽无善心。直是心不并缘。故善心不续。是谓性断。以其现在无耶见故。不名障断。阐提现有重耶见障。使未来之不生于现在。是名具二断也。法瑶曰。益前有无之问也。以现在无故。得言断善根。未来有故。得言悉有佛性也

善男子譬如有人没清厕中(至)是故名为不可救济

案。僧亮曰。譬意为显障断非究竟断也。未来之善。虽有起力。交为现在邪见所障。不得起故。不能济苦也

以佛性因缘则可得救(至)一阐提辈亦复如是

案。僧亮曰。谓正因性也。断缘因善根。非断正因也。由正因力故。久善还生。非三世者。释不断义也。正因是相续常。常故无去来也。如败子者。既以不善无记为正因。二法力弱。现在世中。必不生善。以败子为譬也

世尊一阐提辈不断佛性(至)云何说言断一切善

案。僧亮曰。乘上正因不断之辞。以为问也。正因之力。必感佛果。果善因善。二俱不断。故知非阐提也智秀曰。第四翻承上不断性之旨。仍以为难也。佛性是善。阐提不能断。云何成阐提也

善男子若诸众生现在世中(至)则不得名一阐提也

案。僧亮曰。佛性是善。若现有佛性。则非阐提。明正因是种子性义。不以为缘因性也

如世间中众生我性(至)当见故故言众生悉有佛性

案。僧亮曰。以世我为譬。以证现无之义也。以当见故者。上言众生现在。无有常名。悉有苦故。以当见为有。非现有也

以是义故十住菩萨具足庄严乃得少见

案。僧亮曰。上云当见为有。此说见之时也。以少见名因。全见名果。因名为得。果是所得。今以得为佛性者。因中说果也

迦叶菩萨言世尊佛性者常(至)如其生者非是善乎

案。僧亮曰。上云佛性是常。无有三世。又云。佛性未来当见。此前后相食。则常义未显。故以空微之也。智秀曰。第五翻。有两句难。第一责性非三世。不应复云未来。第二责既有慈爱。岂容非善也

佛言善哉善哉善男子(至)非过去非未来非现在

案。僧亮曰。述成上义无三世也

一切众生有三种身(至)未来身净故说佛性

案。僧亮曰。谓所说佛性。因中说果耳。非前后二言。相食之过也

世尊如佛所说义如是者(至)一切众生悉有佛性

案。僧亮曰。难言。若佛性是常。常则无生无灭。非有为相。何故说言众生悉有也。智秀曰。第六翻有两关难。初若非三世者。现在众生。不应有也。后云若众生有者。应与众生同体也

善男子众生佛性虽现在无不可言无

案。僧亮曰。虽无现相。而终得为用。以终得用故。于众生为有也

如虚空性虽无现在不得言无

案。僧亮曰。空无现相。而得言众生有现在用。佛性亦尔。虽非现有。而现在众生。亦得有用也

一切众生虽复无常而是佛性常住无变

案。僧亮曰。将欲广辨。以定譬性。故重举二门也

是故我于此经中说(至)犹如虚空非内非外

案。僧亮曰。以言无内无外者。明是常也

如其是虚空有内外者(至)众生佛性亦复如是

案。僧亮曰。若有内外。则非一也。若有分数。则非常也。内无外。外无中。中无内。岂曰遍耶

如汝所言一阐提辈(至)一阐提业亦复如是

案。僧亮曰。心为善恶之主。而为邪见所坏。虽有慈念之至。终不成善。义现譬中

善男子如来具足知诸根力(至)说一切法无有定相

案。僧亮曰。此下第二分也。说根性不可定可进可退也。说退以诫之。说进以劝之。谓劝诫分也。僧宗曰。此下第四明如来知根力故。能转下作中。以根不定故。可进可退。如来终不舍置也

迦叶菩萨白佛言世尊(至)以何因缘听其出家

案。僧亮曰。上说知根。未说知根之利也。而听善星出家。不得佛法之利。以迹而观。似不知人利。故发问也

佛言善男子我于往昔(至)我为如来具足十力

案。僧亮曰。说知根之利也。宝亮曰。佛知善星。当断善根。故将其出家。令生微善。开后世之资。且若不出家。则横长物恶。为此因缘所以携其入道也。然经家已显调达是迹。竟未发善星之权。以此而言。经文不应止有此也。捡理求义。例应非实。盖未尽也

善男子佛观众生具足善法(至)能断善根具不善根

案。僧亮曰。说退因也。退因有四。一不亲善友。二虽近不听正法。三虽听法。不思惟义。四虽思义。不如说行

善男子如来复知是人现世(至)尔时则能还生善根

案。僧亮曰。说进因也。进因亦四。略举近善友。听正法二因

善男子譬如有泉去村不远(至)名为具足诸知根力

案。僧亮曰。明退是暂尔耳。而生善。是必定也。泉譬佛果。村譬三界。水譬常乐。渴譬八苦。智人譬佛。无异路譬八苦可厌。常乐可欣。八道定也

尔时世尊取地少土(至)不比十方所有土也

案。僧亮曰。明退者。虽复不久。而退者甚多也。进虽必定。而进者少也

善男子有人舍身还得人身(至)能入涅槃如[打-丁+瓜]上土

案。僧亮曰。进者从明入明也

舍人身已得三恶身(至)如十方界所有地土

案。僧亮曰。明退者从明入冥。从冥入冥也

善男子护持禁戒精勤不懈(至)如十方界所有地土

案。僧亮曰。上总说一切众生。此别举出家人。及信涅槃经为异耳

善男子如来善知众生如是(至)是故称佛具知根力

案。僧亮曰。结上旨也

大般涅槃经集解卷第六十三大般涅槃经集解卷第六十四

  广说诤论凡二十科　第一释于一名法说无量名一义无量名无量义说无量名乃至第一义中说世谛等　不为五种人说五种法谓不为悭者赞布施等　广释所以语魔王云过三月当涅槃缘起　第二释我无我诤论　第三释有中阴无中阴　第四释有退无退诤论　第五释如来是有为或是无为

    迦叶品之第二

迦叶菩萨白佛言世尊(至)亦知未来众生诸根

案。僧亮曰。第三诤论分也。上云。具四德则进。不具则退。而善友不过于佛。正法不过佛说。如使后人于佛所说。起诤论者。则不得善思。故不如法行。四德。所以不具。皆由佛说不定。如似如来说不应机。故发问也。僧宗曰。第五广明诤论也。有三翻。第一出诤论以咎佛。第二如来广释以遣着。第三释诤论也。此下第一列二十一诤论。以咎佛也。宝亮曰。将欲解释诤论。故逆作难云。佛既知众生三世。诸根利钝差别。何不定说。乃使物诤耶。智秀曰。辨诤论中。唯有问答两翻。前迦叶以诤论为难后佛释也

如是众生于佛灭后(至)何故今日不决定说

案。宝亮曰。凡列二十对四十家诤。请佛释也。道慧记曰。迦叶发问。凡有四十诤论。两两相对。合为二十。就章门之中。乃有四十二也。合章门中。第十九两句言。或说佛性。即众生有。离众生有。或说四重五逆阐提。皆有佛性。或说言无。合此二句。所以为四十也

佛告迦叶善男子如是之义(至)乃是智慧之所能知

案。僧亮曰。佛所说义。有权有实。识性是着。不达二义。偏执起诤。智能了达。不执不诤也

若有智者我于是人(至)亦复谓我作不定说

案。僧亮曰。智者见法。法理无二。谓佛说实不说权也。无智不见法故。佛说权道。谓道有权实说不定也。谓我作不定说者。自不见法。谓佛说有二。所以起诤论也。僧宗曰。第二释着言之惑也。随方释化。岂是凡夫六识所知。是以不解此意。故生此诤论耳。智者理归一致。及其化物方便故也。说本迹不相违。故言不二也。于愚者。不解偏执。谓呼二也。宝亮曰。将欲释难。且一往总解云。如是之义。非六识所知。乃是智者所达也。众生根性不等。须法药不同。何得定说耶。是故一家。恒劝行者。若体解此诸诤论。名通达佛法也。佛所说法。本一时之益。生后解之资。应纵容取旨。岂得偏执。但学者自乖于理。岂是佛之过耶

善男子如来所有一切善行(至)悉为疗治一切病苦

案。僧亮曰。谓愚智不同。应须调伏。所以说不得定也

善男子如来世尊为国土故(至)一切法中作二种说

案。僧亮曰。说不定之事。证众生不同。如制皮物。寒国则开。温土则制也。时节者。如初说无我。后说我也。他语者。佛说少见佛性。为后身菩萨。非自为也。为人故者。说不净观是道。为多爱人说。不为多嗔人也。为根故者。如为利根。则略说法要。为钝根人。广说法要也

于一名法说无量名(至)于无量义说无量名

案。僧亮曰。法是事体。名是义因。义是名实。内外之称。各有总别。僧宗曰。明如来说法不定。岂可承此而生执着耶。就一名一义。绮互为言。寻求下释。各存其旨也

云何一名说无量名(至)是名一名作无量名

案。僧亮曰。般涅此言无。亦言不。槃者言生。亦言出也。胡音多含。皆是出生死之名。亦是出生死之义。一名一义也。僧宗曰。一名者。取其无果之名。而种种不同也。道慧记曰。涅槃是一名。涅槃体是一名之治也。更就涅槃体上。作种种名。故言于一名法。说无量名也。智秀曰。捉一名以取法。随此名法。有无量义相。说无量名。非谓一名作无量名也

云何一义说无量名(至)是名一义说无量名

案。僧亮曰。无生出。虽出生无。而名义皆异。即无量有无量名也。犹如帝释者。第二天主之义。谓义一也。与涅槃义同。以异事为证耳。僧宗曰。一义说无量名者。此是义名。为存其义名耳。道慧记曰。帝释一义也。于一义上。复立诸名。故言于一义中。说无量名也

云何于无量义说无量名(至)无量义中说无量名

案。僧亮曰。存其异义也

复有一义说无量名(至)是名一义说无量名

案。僧亮曰。阴以聚积为义。虽有多名。而聚积之义一也。僧宗曰。亦名道者。此就缘中说耳。以其阴能生道故

善男子世尊为众生故(至)故名如来知诸根力

案。僧亮曰。第一义者。小乘以苦集为第一。非空第一也。谓解脱身也。所谓因果者。分三世为十二。宣是因果为略。下苦义是总别相为广也。皆是应根不定之事。僧宗曰。第一义说为世谛者。实是法身。而说为丈六。谓有生老病死也。世谛说第一义者。憍陈如实是世谛。以解空故。从解为称。名阿若憍陈如也。道慧曰。向来所明。一名说无量名。乃至世谛说第一义。悉明不可定执也

善男子我若当于如是等义(至)具足成就知诸根力

案。僧亮曰。上一名说无量名。广略等义。应根说法。福处未了。况余人乎。僧宗曰。以如来随人随时根不同。说法亦异。谓知根力也

是故我于余经中说(至)非诸声闻缘觉所知

案。僧亮曰。生不信心者。以赞信政。是对治。须反治者乃得说也。僧宗曰自有人。应复反治为药者。自非善知根力。何能尔耶

善男子如汝所言佛涅槃后(至)如来名无上力士

案。僧亮曰。答问先总后别也。总中有二翻。初广后略。此略分也。上云物有愚智。人根不一。法名义不定。说不得定。此云末俗颠倒。不解说旨。自生诤论。非佛咎也。非唯一性说十二部经。以众生性行不一。经有十二。引诸佛为证也。僧宗曰。此下第三段。广释诤论也。第五解力者。十力中谓性力也

善男子若言如来毕竟涅槃(至)如来意故作如是说

案。僧亮曰。此下别答也。法身有真有应。真身是常。应身无常。或者见应灭。谓真亦灭。闻真身常。谓应身亦常。所以起诤也。宝亮曰。佛此二说。皆各有为。但执者乖衷。是以成诤。此释第一诤论

善男子是香山中有诸仙人(至)即时获得阿罗汉果

案。僧秀曰。下举五事。此第二悟道缘起也

善男子拘尸那城有诸力士(至)一切皆发菩提之心

案。智秀曰。此第二发菩提心缘起也

善男子拘尸城有一工巧(至)汝可往告纯陀令知

案。智秀曰。第三成檀波罗蜜缘起也

善男子王舍城中有五通仙(至)其人闻已当得尽漏

案。僧亮曰。第四拔邪见根缘起也

善男子罗阅只王频婆娑罗(至)如来定说毕竟涅槃

案。僧亮曰。第五灭罪缘起也

善男子菩萨二种一者实义(至)终不毕竟入于涅槃

案。僧亮曰。始学者。未有知见。是假名菩萨。不达权道。谓丈六是真若闻无常。便生退心。为是说丈六无有变易也。僧宗曰。假名菩萨。谓凡夫人。假得此名。故生执着。非圣人也。为是假名菩萨。故言如来常住不变。有诸凡夫不解。谓终不变易。入于涅槃。伤于应灭。故成诤论也。宝亮曰。佛所以唱入涅槃。为欲使应闻深法者速来。故有此说。不毕竟者。为进学人。入信首五根故。所以唱常也。若欲结两家之过。于闻人涅槃者。事同灰身。于闻不毕竟者。谓言佛常如事像。然中道义求。唱言入者。权而不实。言入者。湛。然无相也。智秀曰。出闻权道得益之人也

善男子有诸众生生于断见(至)善恶果报实有受者

案。僧亮曰。我者有真有俗。俗故说有。真故说无也。说俗为断。说真为常。而或者闻俗有故。谓真亦有。闻真无故。谓俗亦无。起诤论也。僧宗曰。第二诤论。如来为除断见故。说善恶之业。实有受者也。以经生受果。意在相续。一行人。一神明。相续说用。假名为我。不达斯旨。谬计有实神我不灭。处处受生。宝亮曰。破彼断见。说有相续。假名我用。而谬执之徒。便言有神也。若闻破无神我教。便谓八自在亦无也。以两执各异。所以成诤。若中道而言。善见王者。即我身是。为断见人说耳。言无我者。为计神我故说也。非无八自在我也。是故得言有亦无也

云何知有善男子过去之世(至)定说有我及有我所

案。僧亮曰。我者。情灵之总号也。众生寿者。常用之别名。名有十六。而义言三世。总去来今。假名为一故。即我身是也。而或者谓。佛别说一我。从昔至。至今。始终不变。故起诤也

又我一时为诸众生说言我者即是性也

案。僧亮曰。积习所成。故说之为性也

所谓内外因缘十二因缘(至)唱言如来定说有我

案。僧亮曰。列习成事也

善男子复于异时有一比丘(至)说言比丘无我我所

案。僧亮曰。以比丘执定我为问。故答无定我也。比丘三问。皆是执着。一问名。二问实。三问缘。是以如来。遮其实计。故云无我我所也

眼者即是本无今有(至)无有舍阴及受阴者

案。僧亮曰。计我者说有情是我。今即情以辨也

如汝所问云何我者我即期也

案。僧亮曰。因与果会。是名期也。何者。善必福应恶必祸应克无差也。此明业果不断。答问名也

谁是我者即是业也

案。僧亮曰。招果不差。是业之力也。答问实

何缘我者即是爱也

案。僧亮曰。业力受果。缘受故受。答问缘也

比丘譬如二手相拍(至)三因缘故名之为我

案。僧亮曰。处处生。名为众生。缘由业爱三事不绝。名之为我。此为计断众。说我之所由义

比丘一切众生色不是我(至)唱言如来定说无我

案。僧亮曰。已说我义。是曰缘所成。乃破定我。不离一果。上句破一。下句破异也。举外道所见。重破一异之执。先释不异。后释不一也

善男子我于经中复作是言(至)唱言佛说定无中阴

案。僧亮曰。佛说业弱报迟者。有中阴。业强报速者。无中阴。而惑者闻有。谓一切有。闻无言一切无。故起诤也。僧宗曰。第三诤论。佛说中阴为生阴。在方便也。若论下至阿毗。上极四空。此一向无中阴也。中间或有或无。此正义也。宝亮曰。言有言无。未必域判。但业有定不定。定者则有。不定者则无。若中道为论。亦有亦无也

善男子我于经中复说有退(至)生烦恼故则便退失

案。僧亮曰。烦恼有二种。一谓受生。二障禅定也。受生重故。修无漏断。断则不起。障定轻故。不修无漏。遇缘还起。是以退定起障。定烦恼也。不退无漏。不起受生烦恼也。虽不起烦恼。而退禅定。故无漏不现在前也。譬室有毒蛇。因灯得见。虽灯灭不见终不入室。诸法性空因定得见。虽退定不见。而不起烦恼也。或者闻定退言无漏亦退。闻无漏不退。言定亦不退也。僧宗曰。第四诤论也。若四意止。以还未得正信。或时有退。入暖法已。一向不退。乃至罗汉也。若是无漏。则不退。若是有漏。或有退也。钝根则退。利则不退也。无漏之性。照理而生。一得不丧。但退有漏定。无漏不现前耳。宝亮曰。罗汉根有利钝也。六住已来。悉伏断障定烦恼也。受生烦恼。不复更起犹如燋炭。不复为木。但障定无知。既是伏断若利根者。出无漏观。欲还入即时得入。钝根者。出观后。欲还入则难。更须作意。方得入故。名为退也。或者罗汉退来。起欲界思惟。成须陀洹也。言不退者。谓禅定亦不退。所以成诤也。复有比丘名瞿[土*(系-小)](至)唱言如来定说无退。案僧亮曰。瞿提是那含人。六反退定。不得尽漏。第七修得恐失故自害。未死之间。诸漏得尽。魔王谓是学人命终。乃绕其尸。求觅其识。既不能得。白佛言。汝弟子未尽漏而死佛答。此人永拔受根已。入涅槃也。六种罗汉。引退分为证也。僧宗曰。立退无漏义者。引此为据。谓罗汉果。有漏无漏一切退也

善男子我于经中说如来身(至)定说佛身是无为法

案。僧亮曰。释同是涅槃。直以念念生灭。不生不灭。为异也。非学者。以金刚名学。种智初起。名无学。法身不生不灭。无二相也。佛出世。及不出世。常住不动者。以应为出。不应则不出也。然应常不生灭也。不解我意者。谓定是有为。定是无为。无为则常。有为无常也。僧宗曰。第五诤论。闻说灭者。谓无法身。闻法身不灭。谓应迹亦常。向我无我。就隔身为论。此据现在为义也。宝亮曰。闻应身无常。谓无法身。若闻常住。复同外计。两说天乖。故成诤也

大般涅槃经集解卷第六十四大般涅槃经集解卷第六十五

  第六释十二因缘或是有为或是无为　第七释或说心常或说无常　第八释五欲乐或障道或不障道　第九释暖顶忍世第一法或在欲界或在三界　第十释或谓布施唯在意业或是五阴　第十一释或有三无为或无三无为　第十二释或有造色或无造色　第十三释有无作色无无作色　第十四释或有心数或无心数　第十五释二十五有或五六七八有　第十六释一分优婆塞义　第十七释犯重失戒或不失义　第十八释或说四果人成佛或说不成　第十九释佛性即众生有离众生有　第二十释有十方佛无十方佛

    迦叶品之第三

善男子我经中说云何名为(至)十二因缘定是有为

案。僧亮曰。有为无常。无为是常。二种一断灭无常。非众生数也。二不断灭无常。十二因缘也。常亦有二。生灭常者。十二缘也。不生灭常者。谓涅槃也。是为十二因缘亦常无常。而或者闻因缘生灭。便与草木同尽。闻不生灭。谓与涅槃一相。起诤论也。僧宗曰。第六诤论也。若论正义。十二因果相生。至佛乃尽也。今执有为。所以成谬者。谓从生至老死。断而不复续。乖于相续也。言无为者。谓都无断也。宝亮曰。十二因缘。实是有为。言有为者。所以成诤者。以其不作因果相续有为故也。谓各各当体断灭。无复因果相故也

我又一时告诸比丘(至)有佛无佛性相常住

案。僧亮曰。以相续不异故。名为常也

善男子有十二缘不从缘生(至)说十二缘定是无为

案。僧亮曰。虽引四句。但取初句。释生惑之由也。不从缘生者。未与缘合也。从缘生非十二缘者。以不具十二。故言非也。宝亮曰。第二句云有十二缘。不从缘生。谓未来世。十二枝者。未来未起。故言不从缘生耳。而或者谓常故不从缘生。此本据昔教为语也。然执者。各偏言有为。无复相续二家悉乖。故诤也

善男子我经中说一切众生(至)唱言如来说心定常

案。僧亮曰。色有异相。故说坏。而心无异相。故说常也。或者闻色坏而心常。便谓心不生灭。下至上也。僧宗曰。第七诤论也。若论正义。实法则前灭而后生也。假名则始终为一也。或者闻说心。则上行不解相续。言有此心。常而不灭。向上受生也

善男子我于一时为频婆(至)唱言如来说心定断

案。僧亮曰。闻五阴俱坏。便谓心亦如色有大小长短等异也。僧宗曰。闻说无常。谓舍此阴身。心亦断灭。不复续也。宝亮曰。言常则一向不灭。言断则顿无相续。所以成诤也

善男子我经中说我诸弟子(至)说受五欲定遮正道

案。僧亮曰。外道以断事为道。故卧灰食糠也。佛法不尔。而或者闻在欲不障。谓欲心现前。亦不障道也。闻欲心是障。便谓香华等事。亦能障道。故起诤也

善男子我经中说远离烦恼(至)说第一法在无色界

案。僧亮曰。说罗汉果也。欲界无在罗汉也。三界定皆能修第一法。入见谛道。唯除非想一地。下三皆欲能佛随事异说。而或者。各当所闻。偏执生诤也。修第一法时。能伏见结。名远离。未见四谛。未究竟断故。未得解脱。在于初禅。至第四禅者。欲界定少慧多。无色定多慧少。色界定慧等易用。故说其易处也。或者便谓上下皆不能也。得阿那含果者。此经无超越说。得第三果者。三空下结已经伏断。见真谛时。无漏观利。虽经初果。终不住也。今说其住处耳。僧宗曰。第九诤论也。若论正义。欲界心及四禅心。悉能作世第一法观也。三空亦可得有。但此地心难用。是以人不从难多取易。地地皆悉是伏结。尔时未得真无漏。若利根者。身在欲界。悉能悬满上地心。能伏上地结也。钝根者。未必能尔。要须次第生也为利根故。说第一法。在欲界。不解佛意。谓一向欲界。不得用禅地心也。若闻说四禅作四法观。为从根本地心。谓一向不用欲界。乖中道故。所以诤也。宝亮曰。理而谈者。三界心尽。得作第一法也。自有入未得八禅。但得欲界电光定。仍用此定。作假名法空观。故佛说此人。即用欲界心作也。自有得八禅定。作假名法空者。复自有人。先伏结至三空。于彼地遇圣。即用三空定。作第一法者。而或者不解。亦闻欲界心作。便言上二界不得。闻上三界得作。复言欲界不得。故成诤也。智秀曰。二界皆得作第一法也。明骏案。上来所释。皆依成实论义也。若依数义。唯二界得作耳。彼四空定一向不得。何者。谓从上品忍以上。犹不得缘。况第一法。似无漏者。而当得作耶。义相食。详之明哲耳

善男子我经中说四种施中(至)唱言如来说施唯意

案。僧亮曰。身口意业。皆是施体。有净不净。则福厚不净。福薄净。必由信有心净也。初三。一具二净。余二互有信心。虽有优劣。皆得称净。而或者闻说净施由信。信是意业。便谓施具在意。故起诤也

善男子我于一时复作是说(至)唱言佛说施即五阴

案。僧亮曰。佛因中说果。谓五事施也。或者闻是食即施业。外可施之物。无非是施。五阴摄法断尽。故言施即五阴。僧宗曰。第十诤论也。就正义而言者。心为施等之主。色以助成。身口助意。但身口非情灵之法。闻说二种是净。便谓唯一意业。不关身口。闻说施是五事。便谓但色非心。复为诤也。宝亮曰。若有行道来久。舍心成就。一切时中。常行故。佛为此人。说施即是意。不待身口方成也。自复有人。善根微劣。须身口助成。方能惠施。若不动身口。直兴心念。不成施业。佛为此人。说施具是五阴也。或者取佛意谬。若闻说施唯意者。则都不关身口也。言具五阴者。要须备三业。两执各偏。是故成诤论也

善男子我于一时宣说涅槃(至)唱言佛说无三无为

案。僧亮曰。佛说二谛。世谛有因。因有二种。一有法用。二无法用。无法用者。三无为也。有法用者。谓五阴也。或者闻涅槃能断生死。便言有无为法。法入所摄也。闻其无法。谓无涅槃。能断生死。起诤论也。灯灭直明灭而已。更无灭法生也。涅槃亦尔。直烦恼灭。更无法生也。以烦恼灭。生死不续。是无法之用。名虚空也。是总相空。故称常称遍也。世间无马等空。是别相空。亦以无法为空。借以为譬。以别相故。非常非遍也。非智缘灭者。智缘灭出世间无漏。非智缘灭。世间无漏。虽世出世之异。灭义是常。与虚空同。称三无为。外道不得无漏断结。结灭而还生。不得称常。僧宗曰。第十一诤论也。就正义而言者。非无三无为。别三法耳。宝亮曰。或者谓空中无物。不可分别。唯是一空。无三无为也。此中佛意。亦得言有。亦得言无。空无别法。故言无。逐义往寻。故言有也

善男子我于一时为目犍连(至)唱言如来说有涅槃

案。僧亮曰。称为涅槃。谓章句也。圣所践者。谓之迹也。永不退失。谓毕竟也。无有八苦。谓无畏也。疗生死病。谓大师也。果智忍无阂三昧。皆随异义名也。与法同相。名大法界。断老病死。名甘露味也。无可取名难见也

复于一时我为目连(至)决定说有虚空无为

案。僧亮曰。若有性者。性不可坏。以其无性。名不牢固。名为虚空者。无性无法。无法有用。与虚空同性。即以为名也。食下回转者。说一切音声。两有相寻。食不得下。音声不发。以无一有食下声发。说空之用也。或者闻空有用。谓有空法。法入色入摄也

复于一时为目连说(至)决定说有非智缘灭

案。僧亮曰。从智缘而灭者。谓不从出世无漏智也。暖顶以上。至世第一法。是世间无漏。永断三恶报也。宝亮曰。若为智缘所灭。亦名智缘无为。空既无物容。复异于虚空。亦称虚空无为。空中无复可数。便名为非数缘无为。不解意者。闻无则不得随义有三。闻有便言三。各别体。以事像取故成诤论也

善男子我又一时为跋波(至)决定说言色是四大

案。僧亮曰。四大名色者。色法有五。四大是假说四。则说见都尽。声由四大而发。举本则摄末也。决定说言色是四大者。谓有色处。四大常俱。水中有火。汤中有冷。空中之声。亦有四大失旨也。僧宗曰。十二诤论也。若谓正义。以色香味成四大。四大复成眼等五根。虽曰十四种色。若性性摄。则不出四大。若四大为因。五根为果。不离果有因。得言为因所成。闻说四大名色。不解性摄。谓唯有四大。无余色也。闻说因四大造所。可言造根由大成。离因无果。乃至忽滑。若依四大品所明。皆悉不分四大。不辨此语。谓过去四大。造三世色。言现在身口业色所由而有。由过去三十四大力强。故能造也。现在造二世。未来唯造一世。不得佛意。复为诤论也。宝亮曰。有人谓。四大力强。能造色等。而色等力劣。不能造四大。常作此计。佛又一时为比丘。说五阴尽空。何者为色。色即四大。便言四大不能造色。又复一时说四大造色。所谓方圆等者。此是相内待之因耳。闻此说者。便言四大定能造色。若论中道。若论正义者。应言亦造不造。何者。因四大有方圆等。众假色起故。亦言造也。前六四大。后亦四大。便无有造。五尘亦尔。因细成粗故。亦得云色造色。前既是色。后亦是色。故言不造。诸人不解。闻造便令一切悉造。闻不造谓一切不造。两造失中道。所以成诤也

善男子我复说言譬如因镜(至)是名造色犹如响像

案。僧亮曰。四大假名有用。坚持风动。水润火熟。色得生长。如因镜像现也

我诸弟子闻是说已(至)说有四大则有造色

案。僧亮曰。言四大能造。非所造也。色是所造。非能造也

或有四大无有造色

案。僧亮曰。言四大是假。为实法所造。色等实法非造。佛说造。造四大亦造色。譬如束竹相扶得立。上二家偏执。皆不得佛意也

善男子往昔一时菩提王子(至)不名失戒犹名持戒

案。僧亮曰。无作是戒体。此说十善戒。身口七支。从作色生无作色。无作为色。余三不从作生。不名色也。僧宗曰。第十三诤论也。若论正义。无作非心。虽非色心。不得无也。此是善法性违恶。以果中说因故。言无作是色也。从色发得。以因为名耳。或者闻此不解故。谓无作是色也。宝亮曰。为菩提王子。说无作是色者。若直言心是戒。王子便谓起恶心时。所受之戒皆失。则无戒可持。故于身口七支。说得无作戒也。谬取佛意者。便言直以无作是戒。不复关心也。又说戒即是遮制恶法。若心不作恶即是戒。闻此说。便言都无无作戒。所以成诤也

以何因缘名无作色非异色因不作异色因果

案。僧亮曰。非异色因者。身口作法是色性。三种善恶无记也。戒以善作为因。善作异于不善无记。名异色异色因也。不作异色因果者。无作是异色因之果。言无异为因。无此果同之果也。僧宗曰。非异色因者。异色即是无作体。若余色不发无作。非无作之因。如无记身口。及山河之色是也。既言非异色家因。异色亦非其果也。若身口善色。能发无作者。是异色之因。异色亦是其果。以从善色发得。故言无作也。不解故。便言即无作为色也。宝亮曰。非异色因者。异色谓心也。明非直用心作因也。非异是因家果者。此戒亦非独心家之果。要以色心合用。方名为戒善也。道慧记曰。此明欲发无作。要先正身合掌。作异常之色。乃能发得此无作果也。智秀曰。心非身口。谓之异色也。身口无作。不从之而生。故云非异色为因也。不作异色因果者。不为心作果。故言不作异色因家之果也。慧朗别述一解曰。无作是异色。谓若非异色之因。则不作异色之果

善男子我诸弟子闻是说已(至)唱言佛说有无作色

案。僧亮曰。佛意无作非色。以因色生。从因名色。不解佛意。谓无作是色性

善男子我于余经作如是言(至)决定宣说无无作色

案。僧亮曰。誓不作恶。生无作戒。能遮恶法也。不作恶名为持戒者。不作恶时。无作独生。戒性明净。曰持戒也。若起作恶。戒与恶并。戒不明净。违本誓故。不名持戒。不解佛意。闻说不作。谓更无作法生无无作也

善男子我于经中作如是说(至)一切凡夫亦复如是

案。僧亮曰。经说苦乐。以心为主。心有解惑。惑名无明。解名正见。正见是乐因。无明是苦本。此二是心之异能也。立为数法。五阴是苦。从无明生。说痴过患也。僧宗曰。第十四诤也。或说有心数。或说无心数也。若论正义。心之与数。亦有亦无。言有数者。前后次第而生。言无数者。谓不一时并有也。宝亮曰。佛一时说。莫问凡圣。五阴尽因无明故得。乃至十二支亦尔。有人不解。便言止是一无明。而中间无复因果相生。直是一物常尔。但作异名异说。是有十二支。便唱言无心数也。智秀曰。因佛说十二缘。两段因果。二家生执。初明过去因。有三事改常。一者从无明支。长出爱取支。二者转行支。作有名说也。三者就果上说。即因名。次辨五果。其异有五。一者改识为受。二者即果上说因名。三者于名色后。广出诸支。四者略触受二支。五者约受支说。即果名也。或者因之执无心数。次说三因二果。于说三因。二事改常。一者受支前。长出眼识等。二者转作业名。说于二果。二事改常。一者改生支为识。二者分老死。广作诸支名。由云想等。非即是触也。或者因此执有心数。并头而生也。道慧记曰。夫心前后差别。名为数耳。若计前后。犹是一心。都无心数。此亦失。若言一时之中。别有心数俱生者。亦为失也

从无明生爱当知是爱(至)是有即是无明爱取

案。僧亮曰。此说现生烦恼。明数无别法。直是缘中起。或轻重为四也。何者。心不了缘。非好取好。名为无明者。着好生染。名为爱也。爱性贪求。是名为取。起身口业。名之为有。所以言即是者。本名不亏。但从重改称体。有兼立为别数也。僧宗曰。若论因果。次第相生。前因后果。则不一时也。自有未必次第。如无明为行作因。自有从粗烦恼。还起于细。乃至爱受尽得。有更造起义。此是次第缘相生也。无明即爱爱即者。始终是一神明。虽复因果为异。然不得离。故言即也

从有生受当知是受(至)是故受者即十二枝

案。僧亮曰。受是初识支也。识能受生。故名受也。道慧记曰。当知是受即是行有。此未来识支。从今世业识支。从今世业所得故。即是行有也。此业亦名为行。亦名为有也。从受因缘。生名色无明爱取有行者。此并未来一生中事也。此事名色下。应有六入触受等。略无此三支也。受触识六入等。是故受者。即十二支者。此复是后身中事也。以未来生中。无明爱取有行故。复生后身受触识六入等也。六入等者。此略不出下诸支名。故言等也。受者。故是初生识支耳。触识者。是即名色支也。四阴曰名。四阴之体。正是心及心数耳。故今言触识者。此举心及数。是为四阴也。道慧述昙纤曰。此中诸支名。常时隐而不出者。今则备列也。别曰。夫心心数法。名数甚多。若制为十二因缘者。通三世制也。辨三世心数。从无明生爱。讫即是无明爱取。此明过去心数。凡有四法。若就十二因缘为义。前三义总为无明。支爱取是无明分故。得通为一支也。当知即是者。明果不离因而有。故即之耳。凡夫不解。谓即一体无次第相生心数。此为失也。从有生受。讫更取有行。此明现在心数也。受者。是初受生识。故以受为名也。行有者。随义更异名说也。就十二因缘为义。略无六入触受三支也。无明爱此二总为支。取即取支。有行即有支也。受触识六入等者。略不列触受也。若就十二因缘为义。受即是生支。余悉总为支也。是故受者。助十二支者也。受是现在受生之识。识是受生之主。据其主。则三世俱有十二矣

善男子我诸弟子闻是说已(至)唱言如来说无心数

案。僧亮曰。闻说此已。即谓无心数。唯是一心。前后用之。不许有想受诸数

善男子我于经中作如是说(至)唱言如来说有心数

案。僧亮曰。恶智是识之第一缘也。所以说为缘者。明缘间识昧。必生爱取。因触而生者。识在缘。是名为触。后但名识。体一义异也。然非是触者。触初取缘则昧。众数续生则明。明昧性殊言非也。说有心数者。闻非触。谓数性异。与触俱起。取缘不同。与心体别。失旨也。僧宗曰。闻说四法生眼识。乃至受取相生。不解前后。谓呼一时并有。乃至不善心二十一心也。俱不尝复为诤也。宝亮曰。初造缘识。因眼识后起想受爱取有等。然非初识。诸人便言别有一更乐触。能和合生诸心数。复非是心。故言有心数也。佛意者。亦得言有。亦得言无。前亦是心。后亦是心。故无别心数也。因境取缘。故众心来共缘一境。心家之数。亦得有心数也。有人不解。闻有使心别自有数。闻无便谓即是一心。中间不得生灭故。是以成诤也。道慧记曰。取名为业者。重者名为业也。触缘想受者。生乐受也。从乐后受生爱。爱后广生诸善心数也。因触而生者。因六识后生。然非是触者。从识后次第生想受等。名为心数。凡夫不解。谓别有心数法。此为失也

善男子我或时说唯有一有(至)说有五有或言六有

案。僧亮曰。有众生有五阴。名众生阴。是有为也。二者谓因果也。三者谓三界也。四者谓四生也。五者谓五道。六者为六趣也。七者谓七识处也。八者谓八神生也。或云。是八禅此不摄有。尽似非人。九者谓九众生居也。不得佛意。不解广略。直以五六为定也。僧宗曰。第十五诤论也。佛说一有至二十五。皆是随方释化

善男子我往一时(至)唱言如来说八戒斋具受乃得

案。僧亮曰。不具受得者。不一时受五也。以其心弱。不能誓止五恶。故不能生戒。一时受五。则心强能生也。不能具持。便舍四留一。是名一分也。不违佛意。谓单受一戒。不得戒也。具受乃得者。以一日一夜为具。何者。在家戒有二种。一终身。二不终身。不终身者。以心为期。或一日。或十五日。或一日一夜。或但一月。成但一夜皆得成斋。经有证。迦旃所。乃至一时念。以时念促故。心若不能发戒。答言不成也。或者闻之。以一日一夜为定限。多少皆不成斋。失旨也。僧宗曰。第十六诤论也。若论正义。五戒随受持多少。随得其福。若八戒。或一日乃至一时。但应具修乃得。此异五戒。闻说五戒可分受。谓八戒亦可分得也。闻八戒具受乃得。谓五戒亦尔也。宝亮曰。一分优婆塞者。佛一时说。受三归已。五戒中受一戒。名为一分。物情不解。便言。佛说五戒中。但受一戒。便具得五。复成诤论。又为一人说。或一日一夜。是善不名得斋者。本语一日一夜。但一时一念。不名作斋。是人善即是得戒。或者不解。谓言不得斋。亦不得戒。所以诤也。道慧记曰。一分优婆塞者。先受五戒竟。然后舍四持一。是一分也。若使发家一戒者。此不能发得无作也。若言优婆塞发家不具受得者。此失旨也。夫八戒斋。昨日夜受。乃至作二日受一日受皆得。若单一日一夜。一念一时。此皆名得善。非得八斋斋戒也。记曰。夫斋者。过中不食。一日一夜清素。谓之为斋。八戒者。为庄严此斋故。谓八戒斋耳。但一念一时。受八戒者。非不得也。但斋不成就。故言得善。不名得斋。凡夫不解。谓须一日一夜具受。方得八戒斋法。此为失也

善男子我于经中作如是说(至)犯重禁已失比丘戒

案。僧亮曰。名杀贼。谓杀烦恼贼。由于净戒。能生净慧。名圣所受戒。犯重戒已。破于圣戒。不名比丘。失比丘者。闻失圣所受戒。谓一切皆失。失旨也。僧宗曰。第十七诤论也。若论正义者。犯四重戒。是所破者不生。所不破者悉在也。道慧曰。随所犯失也。宝亮记曰。不能生无漏耳。非为都失戒也。犹有破戒在。而言犯重都失。非比丘戒者。失旨也

善男子我于经中为纯陀说(至)犯四重已不失禁戒

案。僧亮曰。受道者。谓八圣道也。此三皆是净戒。得具无漏名到。世间无漏名受。未至名示。即是污道者。清净能至涅槃。名为道也。污者不净非道。不失禁戒。谓净戒常在。与恶业共生名污。如玉投泥名污玉。失旨也。僧宗曰。闻说不生。便言一切都失。闻说污道。便言。犯重不失禁戒也。宝亮曰。今云污道者。由犯戒污行。不得圣道。但不达之流。亦闻失。莫问犯不犯尽失。若闻污。莫问犯不犯悉污不失。是故成诤论。毕竟到道者。无漏戒也。示道者。信道五根中戒也。受道者。外凡夫戒也。道慧记曰。正义者。犯重之人。但有污戒在耳。净戒则失也。或者谓。净戒失故。污戒亦失也。谓不失污戒者。言净戒亦不失。皆失旨也。毕竟道者。谓一身中。得罗汉也。示道者。须陀洹向也。受道者。初果乃至第三果也。污道者。破戒者也。又曰。竟道罗汉也。示道三果也。亦曰无相行也。受道自果以来也。又曰。五善以来。及外凡夫持戒者也。智秀曰。到道者。得真无漏者也。示道者。信根已立者也。受道者。始能承受。信根未立也。此三皆以戒善为体也。污道者。犯于重禁。用所犯罪。行余净戒也

善男子我于经中告诸比丘(至)至阿罗汉不得佛道

案。僧亮曰。至佛更无异路。名一也。皆得佛道者。八万行具能至佛。故名道。闻一乘一缘。谓声闻已具。是则失旨也。僧宗曰。第十八诤论也。闻说一乘一道。谓唯有一道。则伤方便也。闻说须陀洹分流。乃至罗汉。言唯一向永不作佛。并失佛意。成诤论也。宝亮曰。诸人唱言。四果皆得佛道。理实得佛。所以言诤者。以其言得者。谓即时得。不道未来故也。言不得。便谓始终断灭。一向不得。所以成诤也

善男子我于此经说言佛性(至)众生佛性离众生有

案。僧亮曰。第九地佛性有因有果。因即众生非难也。果非众生。系属于因。亦不说离也。而或者以众生无常。便言其离。是则失旨也。僧宗曰。第十九诤论也。若论正义。佛性于中道。而言因与果异。不得言即不离因而得果。不得异也。闻说同于虚空。谓一向离众生外。别有此性。都不相关。闻说实藏。便言已有。在于因中。皆不当理。为诤论也

善男子我又说言众生佛性(至)众生佛性离众生有

案。僧亮曰。正因及果。二性是常。佛以虚空为譬。离与不离。义同上释也

善男子我又复说众生佛性(至)众生佛性离众生有

案。僧亮曰。义同上释也

善男子我又复说众生者(至)悉有佛性或说言无

案。僧亮曰。如盲说象。盲问乳等。总结上事。明不见者。说不得实。所以诤也

善男子我于处处经中(至)诸大乘经中说有十方佛

案。僧亮曰。若有二佛。众生则不生难遭之想。而或者闻此说已。谓十方界皆无。所以起诤也。僧宗曰。第二十诤论也。若论正义者。就应用之中。此间一化。唯有二佛。不解此意者。言十方无余佛也。闻说有十方佛。便言。俱有十方佛。无别法身。是则伤于本迹。二论相诤。俱失理也。宝亮曰。众生闻有十方佛。作是念。若此闻佛法严念。我当向彼间佛学也。欲捉物心。故云一世间中无二佛也。若闻有者。便言。佛佛不相关。若言无者。但得有一。是故诤论也

善男子如是诤讼是佛境界非诸声闻缘觉所知

案。僧亮曰。众生有三众。二乘人根在正定。于向诤事。虽不自见。而能从此。生信断疑。宝亮曰。上既列诤论竟。今还结也。明如此之理。非浅识所知。佛是一切智人。随根施作。无非益物。唯智者乃知也

若人于是生疑心者(至)生决定者是名执着

案。僧亮曰。信等五根。能断烦恼也。众生二种。有爱多。有见多。而爱多者。于二说生疑。若从善友。必能生信。以断疑也

迦叶菩萨白佛言世尊(至)不能放舍是名执着

案。僧亮曰。见多则执。执则着也。宝亮曰。此下是大段中。第四也。明执着故起邪见。断善根之相也。凡愚妄计。尽是无明。皆不称理。故六十二见。通名为疑。但于邪执之时。自有决不决心。然正理而于皆是不了之心故。此下文句。佛广解阐提起过之源。以已之痴。推无因果。易可见也

迦叶复言世尊如是执着(至)不能摧坏诸疑网故

案。僧亮曰。执者之信。不从解生。虽信即不信也。何者。信无我之心。必不信世谛之我。故信即不信。谓非善也。不能坏诸疑网者。以净信断疑。而信不从理。不成净信。不能断疑也

迦叶复言世尊如是人者(至)是人亦当名著名疑

案。僧亮曰。谓执者。于所执不疑也。不疑即是疑者。佛语皆实不虚。虽复偏执不疑。已为二说所坏。信不成就。即是疑也

善男子是可名定亦得名疑(至)是人何故生于疑心

案。僧亮曰。疑从二种见闻觉知法生。今以见类闻也。疑由佛二说。须陀洹无二说也

迦叶言世尊如佛所说(至)是故我言不了故疑

案。僧亮曰。广释疑缘。皆由先经见闻。后则疑也

大般涅槃经集解卷第六十五大般涅槃经集解卷第六十六

  广释一阐提计无因果事　论阐提生善根义　论阐提断三世善根义　明断善根人有佛性义　广释九住八住等五种六种七种佛性义　广说解佛性不同皆失中道

    迦叶品之第四

迦叶菩萨白佛言世尊(至)善男子断善根者

案。僧亮曰。将欲咨问断善者。先问疑着是谁耶

迦叶言世尊何等人辈能断善根

案。僧亮曰。问利钝二根。何者能断善耶

善男子若有聪明黠慧利根能善分别

案。僧亮曰。有世智辨聪。利根之人。能断善根。僧宗曰。第六翻广明起耶见。故断善根也

远离善友不听正法不善思惟不如法住

案。僧亮曰。断善之与正定。皆由利根。何者。若外亲善友。则正。若外离善友。则断也。此说断善之始。第四譬邪见分也

如是之人能断善根(至)当知是人能断善根

案。僧亮曰。向明断善由邪见不信。今说生邪见所由也。道慧记曰。邪见破言无施有六事也

复作是念无父无母(至)当知是人能断善根

案。道慧记曰。谓无父母有六事也

复作是念一切世间(至)是故当知无善恶果

案。道慧记曰。谓无善恶有三事也

复作是念一切世间(至)作是观时能断善根

案。道慧记曰。举六事。破圣道涅槃。兼无圣人也

善男子若有众生深见如是(至)及三恶道破僧亦尔

案。僧亮曰。结能断善根者。必是利智。不得正解。从痴起见。推求谬执故也

迦叶菩萨白佛言世尊(至)何时当能还生善根

案。僧亮曰。第五生善分。从塞求通也。偏执者。不能分别。能断善根。不执者。则能分别。还生善根。下说佛性不定。事须分别。即是生善之义也。僧宗曰。大段之第二。明还生善也。宝亮曰。大段之第五。明还生善也。众生虽复断于善根。而于受苦之中。得厌苦心发故。还生善根。相续不断。以至佛也。然就此文中。言辞甚旷。略分为五别。第一先明还生善根。定因果之性。第二明中道行。第三引佛三种语。令物虚怀。明佛语无方。不可定执。第四明佛性有无。第五辨得失。以结上也

佛言善男子是人二时(至)初入地狱出地狱时

案。僧亮曰。初受苦时。心则生悔。善则还生也。若受苦已切。心乱迷浊。不知生悔。临出之时。乃至悔也。僧宗曰。此利根人也。宝亮曰。若极利根。如五百婆罗门等。止入地狱。即能生善。以此人聪明故也。亦由先来未经大苦。今报生地狱。即觉苦重。便能思惟推寻。悟所作非理。即得改心也。若神根小。复不如至。出地狱时。在后余报。方能改愅也。其中万涂。不可定也。道慧记曰。初入之时。受苦始尔。神明未惛。犹得正识。后出地狱。所受苦轻。展其生心。所以二时。得生善也

善男子善有三种(至)断三世因故名为断

案。僧亮曰。过去已灭无。故不可断。未来未至。故不待言也。断三世因名断者。以现在一念善心为因。能生后善。今以邪见障此善心。不得生故。名断三世因也。僧宗曰。明断三世善也。是故不名断过去果者。若过去因。感果已定。报在后生。此报当来必受。故不断也。即此报家之因。因亦是定。亦不可断也。文中略故。但言不断果耳。过去之因。感果在当。因体已灭。云何可断耶。断三世因。名断善根者。若现在有善。即是现善。此善应过去。即过去善也。现在之善。当来相续。即名未来善也。今以此身。成一阐提。恶业现前。故现善应生不得生。即是断现善也。此善若生。便谢过去。以不生故。故无所谢。即是断过去善也。此当来种类。应续而不得续。即是断未来也。从义而言。此之文略。何者。现善能感来果。今断现不起。是则断因。既曰断因。果无从生。岂非断果。亦应云。断果以略故。但举因耳。宝亮曰。夫生善为理。皆三世中也。若过去曾起者。理不可断。但约现在。遮未来故。谓之断二世也。此中云断三世因者。若现在所起之善。此善即谢在过去。为过去之因也。现在善发。由曾起之善。力用相资也。未来善起。亦由现在为因。因故使种类相续也。今现在既断。便是三世之中。善因不起。故言断三世因也

迦叶菩萨白佛言世尊(至)为是未来为遍三世

案。僧亮曰。凡有四问。此第一问。夫有法不应三世。今定何世所摄耶。僧宗曰。凡有二问。初问佛性三世摄不。次问阐提现在有佛性不。若有。不应言断善根也。若无不应言断善根也。若无不应悉有也。宝亮曰。凡有三难。第一举果性作难。问断善根人。有佛性者。此佛性为在过去。为在未来。为在现在。为遍三世。若使佛性。在三世者。云何言常耶。第二难云。若断善根人。有佛性。是善岂得言断。若使无者。佛云何言断耶。第三遮佛意。若谓亦有亦断者。复不得言佛性是常也。道慧记曰。问有三重。二重如上。第三重谓。若不全有全无者。应半有半无也。故云亦有亦断也。智秀曰。将欲为难。先定佛性。三世之中。在何世耶。下作三翻难也

若过去者云何名常(至)三实四善五净六可见

案。僧亮曰。第二难也。本无今有。是现在也。已有还无。是过去也。将有未起。名未来也。法在三世。是无常也。佛说性常。次以常义决之。必定当得。证未来也。必定可见。证现在也。佛性有六者。引佛说也。二证性常。二证可见也。智秀曰。第一约就三世。为定难也。初令是常。非三世摄。后就二世责。令是世摄。不得是常也

若断善根有佛性者(至)一切众生悉有佛性

案。僧亮曰。第三难也。智秀曰。第二举佛性。是善一句。为双关难也。若阐提有性。不应言断善。善若断者。性不应有也

若言佛性亦有亦断云何如来复说是常

案。僧亮曰。第四难也。四难之意。皆责佛说不定也。智秀曰。第三引佛所说常教。为防难也。佛性若常。是则定法。若不定者。不得言常也

佛言善男子如来世尊(至)三者随问答四者置答

案。僧亮曰。佛意。夫诤以偏执失中。今法理不同。答有四种。不可一向定说也。僧宗曰。今先牵四种答者。意在分别答也。宝亮曰。未是正答难也。且举佛有四种语法耳。下次第解释。以分别答为答也。智秀曰。四种答问。别是一科法门。今取分别及置答。以释其难。故先总列四章门。下别释也

善男子云何定答(至)有如法住是名定答

案。僧亮曰。理无二故。不须分别。谓定答也

云何分别答如我所说(至)名为道谛是名分别答

案。僧亮曰。说有二种。谓法说义说也。法说总而略。义说别而广。故云分别答也

云何随问答如我所说(至)为贪嗔痴说一切烧

案。僧亮曰。有义自分别。不假问答者。自有法总义别。须问而后答者。举如来诚旨。以为释也

善男子如来十力四无所畏(至)六少见是名分别答

案。僧亮曰。先答第二问。佛性有常无常。事须分别。不可执常为问也。七事者。具八自在。四乐四净。无漏见法性。皆名真实。无学法门。皆得少见也。僧宗曰。将欲提其第二问故。先举果地诸德。及后身菩萨法出分别答也。宝亮曰。十力等乃至佛性七事。皆是果地佛性也。后身菩萨佛性有六者。十住佛性中。多明缘因性也。一常者。十地少见真我常。故言亦常也。无漏之解。一得不失。亦言常也。二净者。除烦恼之秽也。三真者。不杂伪也。四实者。体用非虚也。五善者。纯净心也。六少见者。谓果性如此分别也。道慧记曰。答初问也。明此佛性则非三世。而是常。自余则是三世摄也。智秀曰。答初难。明佛性虽复名义是一。然在果得为七。在因则六。便为不定。岂可闻断三世因故。便执佛性。为三世所摄。谓是无常。作定难耶

如汝先问断善根人(至)得名为有是名分别答

案。僧亮曰。称其第三问也。答其有无两关难也。僧宗曰。今明断善根。人悉有如上诸三昧及菩萨性也。答意谓。汝问若有。则不名断善根。我言当有善根。岂得言一切有佛性者。我言无者。现在竟不可得。未来必有。岂得断善根耶。是二障未来者。正次现在。具有烦恼障。未来不得速成佛。故言无耳。非是永无。名分别答也。宝亮曰。且答第二难也。谓断善根人。亦果果头七种佛性。亦言十住六种缘因之性。是二种佛性。障未来故。名之为无耳。定当得故。名为有也。但以现在惑障。两种性不现故。便字曰无。岂得云断善根人。无佛性耶。智秀曰。明二种性。现在无故。不在断例。以别断余善故。阐提义成。以当有故。言悉有也

如来佛性非过去非现在(至)未具见故名为未来

案。僧亮曰。兼答初难也。难云。性有三世。今明非三世不可说有。便三世摄。少可见故。名现在者。以少见故。名后身也。过去具但二世也。未具见故。名未来者。未具见即少分见也。学身说有。去来非无学也。法瑶曰。答前为过去。为未来。为现在。为遍三世问也。须分别之。佛果非三世。佛缘性三世也。缘因体又是因者。又是果者。故曰佛性。因故三世。果亦三世也。正果佛性。非三世也。故言果非三世也。后身菩萨。因缘观智。即是佛种性。此初一念为现在未满足为未来。过去无也。十住观智。由因而生。观智佛性故。亦得名为佛性。此佛性亦有因法。亦有果法。皆三世也。未有正果佛性故。不得言非三世也。僧宗曰。答初问也。问云。若三世者。则是无常。今答云。性有因果。若是果性则常。非是三世。若是因性。如后身菩萨。见在少见故。亦得言现在。未全明了故。亦得言未来也。言其现在未来因。故言尔也。实非三世。若得果时。则不得尔。正以在因之时。必当见故。义言其当也。以现在少见。便义言其见也。即非三世。岂为无常。及至五种。明阐提当必有故。亦得言有。始是分别答也。宝亮曰。答第一难也。明佛性非在三世中。复不为三世所摄也。后身佛性在三世者。明缘因性。现在少分见故。得名现在。未来方得具足。亦名未来也。道慧记曰。此释第一难。兼释第二难也。又曰此正答第一问也。又曰此合结释二问也。智秀曰。此下故是答第二难。兼释初定性所在也。三世摄者。其在因也。不摄者。在果也

如来未得阿耨多罗(至)果亦如是是名分别答

案。僧亮曰。从学至无学。相续有二说。佛性果亦如是者。亦三世摄也。僧亮曰。若未得无上道果时。故是缘因佛性。悉三世摄。果则不然者。谓佛果性也。有三世者。十住以还。缘因性有非者。佛果佛性也。后身菩萨佛性因故。亦三世摄。果亦如是者。此是十住以还缘因性。前念为因。后念为果。亦三世摄也

九住菩萨佛性六种(至)果亦如是是名分别答

案。僧亮曰。已断结习。粗惑已灭。说常不同。后身常也。宝亮曰。既一向在观。无复出入。故余常名也

八住菩萨下至六住(至)果亦如是是名分别答

案。僧亮曰。八住下至六住。未断见习。故说无常。无三界烦恼。故说善也。宝亮曰。九住十住。同得常名。而八住以还无者。故知八地初心。犹应有出入观也。中忍已上虽无。夺不与名也

五住菩萨下至初住佛性五事(至)四可见五善不善

案。僧亮曰。善不善者。类三界烦恼。说不善也。宝亮曰。善是缘因。不善是境界因也。六住虽有无色界细惑。为苦用轻。不甚迫心。故不与境界名也

善男子是五种佛性(至)故得言有是名分别答

案。僧亮曰。上称第三问。兼答第一广分别已竟。今还结第三也。七种六种是缘因。阐提现在无也。五事有不善。虽是烦恼。非断善烦恼。于阐提亦是当有也。宝亮曰。上来所明。佛性断善根人。必皆得故。故言有也

若有说言断善根者定有佛性定无佛性是名置答

案。僧亮曰。答第四问也。明有是未来有无是现在无也。答以决定。而佛性不定。若作定说。而疑者不决。不应置答。若说不定。所疑以决。不须重答。是名置答也。法瑶曰。答前亦有亦断问也。断善根故。不得言定有也。善根还生。不得言定无也。可言亦有无者。此明万善缘因性也。宝亮曰。答第三难也。答意云。不可定说有。不可定说断。若言定有定无。此名置答也

迦叶菩萨言世尊我闻不答(至)何因缘答而名置答

案。僧亮曰。如余经说。不答名为置答。故发问也

善男子我亦不说置而不答乃说置答

案。僧亮曰。语少也。应云不但说置而不答。乃名置答。义现于下也

善男子如是置答复有二种(至)以是义故得名置答

案。僧亮曰。一不答名置也。二答而置也。不答而置者。止无义之问也。答而置者。去其偏着之情也。宝亮曰。自有不答。亦名置答。自有答而呵止。不为解释。亦名置答也。佛今用后解故云遮止。莫着也。道慧记曰。我亦不说置而不答者。不答乃名置答也。又曰。亦不说不答。是置答也。又曰。亦不说置不答也。乃置而为答也。一者遮故遮其执也。二者莫着不听其定着也。两种置答。通有此二义也。又曰。遮止者。是说置答也。莫著者。是默然置答也

迦叶菩萨白佛言世尊(至)非是过去现在未来

案。僧亮曰。上未说因体。今更问也。僧宗曰。更问出体相。令人识也。宝亮曰。上解佛果非三世。其义乃了。但果名滥于生死。迦叶致问。显此旨也。智秀曰。上虽明性。从于因果三世摄不摄义。未出其体。今发问以显之也

佛言善男子五阴二种(至)亦非过去现在未来

案。僧亮曰。此普是因中也。始者为因。金刚为果。犹是有为。不免三世也。言亦非谓佛果也。宝亮曰。因之与果。俱三世摄。前念五阴为因。后念五阴为果。故因果俱三世也。非三世者。唯果佛性独脱也。智秀曰。正答问也。若是变易地带应。故具五也

善男子一切无明烦恼等结(至)如来佛性犹如醍醐

案。僧亮曰。正因性也。上说佛及十地佛性不同。未说凡夫佛性。今从凡夫至佛。更以譬说辨其精粗也。得善五阴者。缘因性有漏善。须陀洹以上。辨无漏有精粗。从正因生也。僧宗曰。此辨正因性也。言此神明是佛正因。因此能生善五阴。乃至菩提。以众生如杂血。以有烦恼在体故也。如众生皆精血得成。明虽有佛性。要假万善。得成佛也。须陀洹。斯陀含。同断欲界思惟未尽。有少善故。佛性如乳也。那含断欲界尽。譬酪。罗汉三界惑尽。譬生苏。缘觉至十地菩萨。断三界外惑。如熟苏。佛如醍醐也。宝亮曰。分别两问既竟。更总收一切万法。无明等死。无非佛性。或正因。或缘因。或境界因。随义往取。尽能助果。故是佛性。通论既竟。欲使其旨无遗。仍该明凡夫令事都尽。是以谈众生佛性。如杂血乳。善恶未分。义言杂也。乃至众生佛性。阶给之异。如文所说也。智秀曰。上唯明菩萨。未出凡夫及小圣人。又虽明佛性可得。盖约因中诸人说为不同。然未释其所以。故此中并显之。明因中诸法。皆有能得之义。以此为异也

善男子现在烦恼(至)佛性亦尔是名分别答

案。僧亮曰。草譬凡圣佛性也。牛譬后身菩萨也。牛食草即成醍醐。譬后身见性。即成佛也。僧宗曰。以有现在烦恼。故不得睹。岂得言无耶

迦叶菩萨白佛言世尊(至)断善根人有佛性耶

案。僧亮曰。广上置答。未来未起。阐提不应说有佛性也。僧宗曰。犹执见有为难也。宝亮曰。明义粗障欲结还生之旨。故迦叶更致此问也。智秀曰。迦叶亦同未违。所以有问也

佛言善男子如诸众生(至)佛性力因缘故还生善根

案。僧亮曰。凡有者。有三世也。众生是相续假名。总三世为一有皆属之。终不能生果者。明未至无用。三有用别。现有则能断也。未有则生也。故说定无矣。僧宗曰。有过去业。现在有果。未来业未起。故不得有果也。佛性乃非三世。而现有烦恼故。善业则无。以不见佛性。便义说为断。非为永断。以未来佛性因缘。故还得生也。宝亮曰。佛今还以譬辨。如众生有过去业。故招现在果。虽有未来。而业未有。故不能生果。果虽未生。以现在烦恼因缘故。能断善根。以未来善业因缘力故。故能还生也。智秀曰。佛约业以明义也。有业则得果。有众生则能得佛。故言有佛性耳

迦叶言世尊未来云何能生善根

案。僧亮曰。上言未生无果。今问其生义也。道慧记曰。问意以未来无善。云何能生于善耶

善男子犹如灯日(至)亦复如是是名分别答

案。僧亮曰。法起名生也。日性是明。虽复未起。性自无闇。名为破闇。善恶之性。性自相违。善生则恶灭也。宝亮曰。此人乘过去善为因。现在善知识为缘。则能灭恶生善也。智秀曰。虽未出性能破闇。佛性未来。能生善根。其如此也。是少分譬。可善消息取之

迦叶菩萨白佛言世尊(至)众生佛性非内非外

案。僧亮曰。广上分别答也。以偏执生诤。终断善根。分别中道。去其偏执。此皆答不得定说之义也。法瑶曰。色阴为外。四阴为内。缘因性耳。正因佛性非色。非内非外也。上来非内非外。非有非无。中道义也。是以复发斯问也。僧宗曰。此大段第三也。若论得旨。则不假复明。犹人未解故。尔就上明还生明佛性三世摄。将来作佛。要修善故得作佛。自下中道观。是以次明此中道。可有七段。第一以合用明中道。第二非有非无。以释成内外明中道。第三寄乳酪遣执。以明中道。第四明如来有随自意语。明如来所解。不同凡夫。正以不善。解诸法因果。随物而说。岂可随语生着耶。第五明寄七种语以遣着。有因语果语。自有因中说果。自有果中说因。云何于此生着。第六还定因果。明有果时无因。因时何得已有果耶。第七寄七种人譬明也。云何言非内非外者。难佛前句也。宝亮曰。此下第二大段。明中道佛果。佛性非内非外。上师子吼品。以明果非即正因中有。亦非缘因中已有。然复不离五阴得故。言非内非外。今此中明一切法善恶等。尽是佛性。恐人情迷故。迦叶谬领。即捉上语作难也。谓若一切法。尽是佛性者。是为无一法而非者。上何故言佛性非内非外耶。智秀曰。上明当性是众生有。复言即是五阴。恐物情偏执。用乖理衷。此第三大段。为除惑执。辨明中道。显当果之性。非是有无离于内外也。有三别。第一从此讫三种。正显中道性。非内非外离有无。第二讫恒河譬。最后随自意语。举如意语。可得随缘。说为多种。况明佛性。不可定执耶。第三科简虚空与佛性之异也

佛言善男子何因缘故(至)众生佛性是中道耶

案。僧亮曰。谓汝先已解。解则不应复问。而今问者。则是失解也。僧宗曰。指前师子吼品。已广明中道。今不应复问也。宝亮曰。此中佛意。谓我之所言。非内非外者。乃果性不在内不在外。此为中道耳。汝何忽失意作此问也。慧朗述昙爱曰。上云不善五阴。及善五阴。悉佛性故。迦叶复问。若使五阴是佛性者。云何而说非内非外耶。欲令广释内外有无二种中道。道慧记曰。圣说不定。中道之理。既不可定执。众生云何作定执耶。欲令去着会中道故。发问求解也

迦叶言世尊我实不失意(至)不能解故故发斯问

案。僧亮曰。迦叶承旨。仍拂迹也

善男子众生不解即是中道或时有解或有不解

案。僧亮曰。明一切法。皆是中道。不应偏执也。僧宗曰。众生不解即是中道者。谓不解即惑。惑时无解。是则非内。解时无惑。是则非外。故云即是中道。宝亮曰。谓众生不解。无有自性故。次此下云。或时有解。或时无解。解与不解。二俱从缘。众生亦是从缘。相与无性。尽是中道。但使不执令二彼俱虚也。若不如是。是则偏着矣。道慧记曰。分中道文为八段。第一明内外中道。第二辨有。第三去执。第四显三种语。亦是去执。第五显七种语。第六简定因果。第七以七人通譬因果。第八偏为果作譬也。此第一明内外中道也。智秀曰。迦叶已申其执意。意在为物。佛自此下广显中道也

善男子我为众生得开解故说言佛性非内非外

案。智秀曰。此下二种。辨中道。此下第一先明非内非外中道。以破异人所执也。后第二寄六种因缘。虚空菟角等。明不有不无中道

何以故凡夫众生或言佛性(至)离阴而有犹如虚空

案。僧亮曰。举异执也。略有二种。第一器中果者。虽器无果。而性在阴中。离阴则无也。第二如虚空者。佛性是常。五阴无常。如空性阴所不摄也

是故如来说于中道(至)故名中道是名分别答

案。僧亮曰。常是果性。无常是因性。二俱性不偏。名为中也。僧宗曰。凡夫所计。理则不然。佛性之理。理非内外。先举六入。以显义也。若言但内二。俱不当也。今言佛性。假内假外。合用者。即有正因。即有境界因。不离此而成。故就合用之功。以为中道也。就辨合用中。有五翻。此即第一翻也

复次善男子云何名为非内非外(至)是名分别答

案。僧宗曰。第二就缘因。以明合用也

复次善男子或言佛性(至)亦名内外是名中道

案。僧宗曰。第三就果上真应。明合用也

复次善男子或有说言(至)亦名内外是名中道

案。僧宗曰。第四就闻慧思慧。以明合用也

复次善男子或有说言(至)亦内亦外是名中道

案。僧宗曰。第五略举行。明合用也。大意为显因果非内非外耳。支流有此五翻。明合用也

复次善男子或有说言(至)亦内亦外是名中道

案。僧宗曰。宝珠以常现为内。金藏以不现为外也

善男子众生佛性非有非无(至)众生佛性非有非无

案。僧亮曰。辨有无相续中道也。虚空于人。不可见有常。不可见定有也。佛性亦不可见有非常。不可见不定有。有不同空。是有中道也。菟角于人。是无定无也。佛性于人。是无不定无。是无中道也。非有非无者。非虚空之有。非无非菟角之无。亦有者。是当有也。亦无者。是现无也。僧宗曰。此第二以非有非无。释内外也。言所以尔者。正以非有故非内。正以非无故非外。佛性虽有。非如虚空者。言虚空体无。故见在于人有用。佛性见虽无。而当必有。不同空也。无故不同菟角者。言菟角是永无。此性非永无。故不同也。宝亮曰。外道计虚空是定性有法。然佛性虽有。而是当有之有。不同外道所计之有也。又不同菟角之无。菟角必不生。佛性是可生。岂得同此之永无之无也。道慧记曰。明虚空于现在虽有。而虚空终不可睹见。而佛性之有。可以心眼了了睹见也。内则是有。外则是无。不内故非有。不外故非无。所以是有无中道也。智秀曰。第二寄六因缘。辨非有非无中道也。此第一因缘也

善男子若有人问是种子中(至)众生佛性亦复如是

案。僧亮曰。以譬申其旨也。时节有异。其体是一者。花果是树分。而树是有分。树分则时异。有分则体一。体一则有。时异则无也。僧宗曰。明诸法非先有无。况正因佛性。非有无也。宝亮曰。外道计言。外四大力强。能增长内四大。而内四大力弱。不能增长外四大也。今佛言不尔。无有外四大力。独能增长内四大者。何以然。如谷子是内。地水等是外。若言力强故能增者。何故水土与谷子。初并时不即生。要待后时方生。而不尔。当知先有谷子为正因。后得水土为缘因。故次第得生。何容直外四大力。能增长于内四大耶。智秀曰。第二因缘寄辨种子。以明理也。所以者何。以下逆取伏难之意也。明虽复果不即子而有果必关子。虽复时节先后而始终。得为不异一假。故得称言子有于果也

若言众生中有佛性者(至)应定答言亦生不生

案。僧亮曰。已释中道竟。今举其以明乖中道也。有净不净者。释学与无学。相续是一。不净名学。谓众生也。净名无学。谓佛也。岂容学中。别有无学耶。定言亦生不生者。中道之旨既显。合结劝。令识定答之要也。智秀曰。复释一伏难也。缘闻上说。及释伏难。便生执云。别有果法。已在因中。今明众生即是者。约不异假以明众生当得作故。故言即是以义而推。不得别有果法已在因中也

大般涅槃经集解卷第六十六大般涅槃经集解卷第六十七

  广明中道因果相生举乳酪为譬　广辨七种语因语果语等　举恒河中七种众生譬　释第一常没所谓一阐提　释第二暂出还没谓信不具足等　释第三出已则住谓闻法思惟如法而住等　释第四出以遍观四方广释暖顶忍十六行　释须陀洹所断烦恼犹如四十里水其余在者如一毛渧乃至衔物坚持等譬释第五遍观已行即斯陀含

    迦叶品之第五

世尊如世人说乳中有酪是义云何

案。僧亮曰。别举偏执者。所说欲障其过也。智秀曰。此下第三因缘。举世人所说。因中有果。故能生果。咨佛以求解也。道慧记曰。故如师子吼中。亦作先已有难。此中引出。欲令佛广明非有非无理也

善男子若有说言乳中有酪(至)若言无酪是名虚妄

案。僧亮曰。有早计之过也。僧宗曰。第三寄譬。以遣着也。若言已有。即是执着。即是常见。若言都无。复为妄语也。智秀曰。佛以两复。次释此问也。初一复次先破妄。后一复次设反质之难。若使乳酪是一者。酪何不在前出也

离是二事应定说言(至)乳生冷病酪生热病

案。僧宗曰。因时无果。故言亦无。必能生果。故言亦有也。色味异者。乳白而甜。酪黄而酢也

善男子若言乳中有酪性者(至)先无今有是无常法

案。僧亮曰。计常之家。说因中有果。其过不同。一谓乳中有酪。微不可见。如器中有果。而果与器异。二谓乳即是酪。酪即是乳。俱名随时变。其体常一。故云名有先后。其实无异也。道慧记曰。若使五味一时而有者。谁作次第。先乳次酪。乃至醍醐耶。智秀曰。未见闻有酪在乳前。必同时者。乳有何缘必不后。酪不在前。故知乳时必无酪

善男子若有说言乳有酪性(至)心不等故故名虚妄

案。僧亮曰。为水生意也。谓汝若以见从乳生酪。不从水生。证乳有酪性。此非证也。何者乳是近因。酪是远因。汝见近。不见远也。其实二俱是因。而言一有一无。此心不等也。智秀曰。此下第四因缘。取彼异人执意也。其云所以得知乳已。有酪性者。以能生酪故。如水无酪。故不生也。此中有四。复次破之。第一责令草中亦有乳。作必不等之难。第二责令酪中有出乳之过。第三引经为证。第四举四因和合。故生眼识。正说因有生果之理也。此即第一难也

善男子若言乳中定有酪者(至)非有酪性非无酪性

案。僧亮曰。若使乳酪二性是一者。则应互为因果也。僧宗曰。并责也。若使因中有果者。果中亦应有因也。智秀曰。第二难也。既云一时有则同有也

善男子是故如来于是经中(至)应说众生佛性亦无

案。智秀曰。第三引经为证。显中道也

善男子四事和合生于眼识(至)乳中酪性亦复如是

案。僧亮曰。此四事和合。而三是色性唯识。一事非是色性。既因果性异。以此证无也。僧宗曰。更举显譬。明因中无也。如四事和合。故生识。就空明之中求识。云何可得耶。智秀曰。第四正说因有生果之理也

若有说言水无酪性(至)从此四事应生耳识

案。僧亮曰。因有近远。近名正因。远名缘因。缘因则同。正因则异。故言异因异果也。僧宗曰。法生不同。非是有生性也。乳是酪因故生。余非因故不生也。如酪唯是乳果。非余家之果也。智秀曰。第五因缘也。举余因法中无果。以证乳中有酪性也。以三复次破之也。初举异因异果。明以正因故。酪从乳有。不从水生。又举生识及取苏法。以成酪从乳有。不得托水也。第二引经为证。第三举监性碱。直显因中本无酪果性也

善男子离于方便乳中得酪(至)亦应如是离方便得

案。僧宗曰。离谓多方便也。如以一渧。颇求树汁。即便成酪。而生苏亦尔。要假五缘。当知生法不同也。亦应离方便者。亦应离多方便也。智秀曰。犹第一复次中一事。助成难也

善男子是故我于是经中说(至)故法有因灭故法无

案。智秀曰。第二复次引经为证也

善男子如盐性碱能令非碱(至)以余缘故而得碱也

案。僧宗曰。重证无性也。智秀曰。第三复次。直显因中无果

若言一切不碱之物(至)不碱之物亦复如是

案。僧亮曰。为外生意。答上难也。谓不碱之物。虽有碱性微故。不知求外碱以发也。僧宗曰。并其有性也。若言不碱之物。有碱性故。须监发者。今见不碱之物。置碱物中。其味则正可得。而盐中亦有微不碱性耶。若尔者。碱与不碱。各有二性。何故不合之时。不可独用耶。故知诸法先无果也。智秀曰。第六因缘也以三复次破之。第一责各有二性。第二由其故执。因中非无果体。如要假外四大而增故。仍及质责之。若先有者。不应次第也。第三更举尸利沙果。以证因中无先有果。此即第一也

若言外四大种力能增长(至)四大亦复如是

案。僧亮曰。若五味次第。已有者。不应假言一切法皆假外也。智秀曰。第二复次反责。不应次第也

若说从外四大增内四大(至)不因于外四大而增

案。僧亮曰。四大力均。自有力生长。内不增外。外不增内也。僧宗曰。并其义也。若言外法有内者。今不见内能增外也。智秀曰。第三复次。更举尸利涉果。以证因中先无果之旨

善男子如我所说十二部(至)如是等经名随自意说

案。僧亮曰。经教所辨。法相本宣佛意。上以明法不定。此明佛意不定也。僧宗曰。第四段也。明如来善知法相。能随自意语。如为欲界。说父母生身。不说无明。岂可承此言。而执着耶。宝亮曰。第三段遣着也。明佛语无方。不可偏执。劝学者虚怀也。言随自意语者。佛是识法之人。当法相而说也。智秀曰。此下第二段。更寄一如意语随缘。得为多种之说。况显佛性中道。岂可偏执耶。有四翻。第一正寄语不定。明性不定也。第二明佛性。亦得作有无也。第三举恒河为譬。第四简得失也。道慧记曰。上已明内外中道。有无中道理。不可定执竟。今复明佛说不定。或随自意。或随他意。云何定执耶

云何名为随他意说(至)善哉长者是名随他意说

案。僧亮曰。佛意不恶。名随他意也。僧宗曰。世间所说。佛亦随说名。名随自他。若非是理。随他而说。是名随他也。宝亮曰。应释人根。非究竟之说。名随他语也

云何名为随自他说(至)说无是处是名随他说

案。僧亮曰。随三世智人所说。不相乖背也

善男子如我所说十住菩萨(至)是名随自他意说

案。僧亮曰。因近则果易见。因远则难知。以自见不见众生。故名为少见也。僧宗曰。十地于佛不名为见。随意故说。为少见也。宝亮曰。师子吼中。已两三处。解释此义例也

善男子如来或时为一法故(至)然不离于阴界入也

案。僧亮曰。一法一因。无量法无量因说得其本。则一摄无量也。因善知识者。说信心则已摄尽也。菩提有二因。谓一从他闻法。即是善知识也。二谓内自思惟。即信心为本也。不离阴界入者。此三摄法斯尽也

善男子如来说法为众生故(至)是名如意语

案。僧亮曰。如意语者。谓苦不如意。乐如意也。众生厌苦。欲求如意。佛应根说七。皆令得也。七语皆为如意。而第七别受其名。若应根说七。说不得定。不应说语者。法无此理。不应说而说。欲令众生。改恶修善也。僧宗曰。第五段遣着也。谓有时因中说果。有时果中说因。岂可承此言。而生执耶。因果语者。谓从过去业生。亦能造未来果也。宝亮曰。文中自释同是劝学者之辞耳

善男子如来复有随自意语(至)十二因缘是名为无

案。僧亮曰。更广上自意分别中道有无义异也。何者上明有是当有。无是现无。今辩有无。皆是现在。故重须分别也。僧宗曰。第六段定因果。明佛性有之与无义也。有者。谓十力四无所畏。妙有之法。即是果性也。既得果则无过去诸不善无记业等。当知果时无因。因时岂有果耶。是谓定因果。不得杂也。宝亮曰。第四段明佛性有无义。凡三翻。第一就二门明有无。第二就四门明有无。第三就七门。明有无也

善男子如有无善不善(至)何况出世第一义谛

案。僧亮曰。广上有无也。谓善是有。不善是无。非因缘是有。因缘是无。乃至一阐提说。亦复如是。一一反上。释自意语义也。僧宗曰。向举章门。欲类下句言。岂唯因果不杂。还就因中善不善。亦不得杂也。宝亮曰。上来至此。第一就二门。明有无也。明果时。有十力等诸三昧。因时唯有善不善无记等。无十力等也

善男子或有佛性一阐提有(至)众生云何一向作解

案。僧亮曰。阐提有善人无者。谓断善之邪见。是因是障。阐提有之。善根人无也。阐提无而善根人有者。谓善法缘因力。能除障。善根人有。阐提无也。无记非障非除。故二人俱有。无学果性。二人俱无也。僧宗曰。阐提有者。更辨佛性。不得杂之意也。阐提断一切善尽。唯有大恶。以其恶时无善。因时何得已有果耶。此恶即是神明。异于土木。当有成佛之义。亦得名为正因性也。宝亮曰。第二就四门。以明有无也。十恶是阐提。境界佛性。此人后时。还能厌恶。而起缘生之善。因中说果。故言阐提有也。善人有者。谓缘因性也。二人俱有者。谓正因性也。二人俱无者。谓果性也

善男子如恒河中(至)水陆俱行者即是龟也

案。僧亮曰。河譬涅槃经。七种众生者。经说七种佛性。有无义异也。一是现有。六是现无。三世有者。一是现在。而六是过去。未来亦名中道也。僧宗曰。第七段明因果不离也。河中有七种众生。涅槃经中。有七种凡圣。所以知不杂者。言乃至龟方称到岸。尔前六种。犹在河中。在河则不名至岸。因中岂有果耶。宝亮曰。第三翻。就七人。以明有无也。常没谓阐提也。暂出还没。谓具缚凡夫。暂生世善。还入生死也。出已住。谓信等五根立也。遍观四方。谓须陀洹果也。观已行者。谓斯陀含也。行已复住。谓那含也。水陆俱行。谓得罗汉。以上乃至大涅槃。总为第七人也

善男子如是微妙大涅槃河(至)即外道书非是佛经

案。僧亮曰。前邪念邪语。谤涅槃罪渐重。为断善之因也

是人尔时远离善友(至)故名常没如恒河中大鱼

案。僧亮曰。广显谤法者之过也

善男子我虽复说一阐提等(至)修施戒善是名常没

案。僧亮曰。上说三道。此说五道也。僧宗曰。未阶暖法已还。悉有退义。为第二人也。如善星修得四禅。起不善入三恶也。宝亮曰。闻经生信。故名为出。而五事不具足。故于中起三毒。还堕第二人数也。若自知此五事不具。凭善友进行。信根立者。属第三住位也。智秀曰。五德不圆。终断佛性也

善男子有四善事获得恶果(至)如上二人亦复如是

案。僧亮曰。施戒是出生死之法名出。经譬饭也。为有故没生死名没。经譬毒也。谓之杂毒之饭。又生信为出。终断善根为没。是以后出善星。即第二人也。第一人烦恼厚重。必入剧苦。故曰身重处深。第二人虽复起谤。而将来必以善自资。故曰身重处浅也。宝亮曰。此下次第。释上五事所不具足之意也

善男子或复有人乐着三有(至)是故名为不具足

案。僧亮曰。二种涅槃。一谓五分法身。出生无故。名为涅槃。二谓结尽无为也。阐提无故。故言不必一切皆有也。不信有得道人者。谓圣自然不不学也。无因果者。无善果也

是人成就不具足信(至)是故名为戒不具足

案。僧宗曰。从戒戒者。道共戒也。不具无作者。无漏戒。能息于作。名无作也

是人不具信戒二事(至)是故名为闻不具足

案。僧亮曰。因列多闻。炎明余义也

是人不具如是三事(至)是故名为施不具足

案。僧亮曰。财施浅事。犹非所能。况法施乎

是人不具如上四事(至)是故名为智不具足

案。僧亮曰。涅槃是有无之总号。如来是身智有名也。解脱是灭结之无有无一也

是人不具如是五事(至)见明故出身重故没

案。僧亮曰。增善为第三。增恶为第二。于同行中。自以为胜者。同己所见。为人中胜也。宝亮曰。释五事既竟。先明第二人之过。后彰第三人之德。一增善法者。释第三人。一增恶法者。释第二人也。第二人不能求近善友。故改造恶入生死。成暂出还没。此人若深自知见行不具足。则求进。成第三住人也

第二之人深自知见(至)终不复没是名为住

案。僧亮曰。第三人也。僧宗曰。求近善友。得为暖法。成第三人。永不复退也

我佛法中其谁是耶(至)如是等众亦复如是

案。僧亮曰。舍利弗等。得暖法位。正定聚也。僧宗曰。舍利弗曾经第三人来。从本受名。以证不退义也

是故我于经中说偈(至)获得解脱安隐住

案。僧亮曰。引诫偈。叹能住也

善男子知不具足凡有五事(至)如是观已次得暖法

案。僧亮曰。次得暖法者。断外凡夫。入正定聚。初住位住。僧宗曰。贪欲多观不净者。此明第三人观行。渐进入暖法也。宝亮曰。更举五法者。复有所为也。谓第二人。若值好善友应病与药者。成第三人。若不尔。则还成第二人也。人有利钝。利者观假名空。即仍取法空。要达两厢理竟。方乃出观。至于暖法。结成住人。钝者不能如此。假名空便出。信根亦立。成第三住人。故结有两时。非暖法独成住人。初善根不成也。暖法是法空之初。第二善根之始。去无漏火犹远。故以暖为况也。智秀曰。次第复观十二因缘者。四谛入小乘道。乃是三乘分流。入此中相。复观十二因缘者。别是一方随缘入道耳

迦叶菩萨白佛言世尊(至)说言暖法因善友生

案。僧亮曰。明暖法唯慧。非是五阴。以色决之也。僧宗曰。迦叶何容不解暖名。盖同物故也

佛言善男子如汝所问(至)一切众生皆有暖法

案。僧亮曰。如此暖法。一切皆有。今所言者。不如是也

善男子如是暖法是色界法(至)一切众生不必悉有

案。僧亮曰。暖通三界。有七十三人。但言色界明非一切有也。六行者。无常苦因集生缘也僧宗曰。不言欲界一向不得暖观。少故言不耳。遮其一切有难。作此答也。宝亮曰。要得上地定方能作暖法也。何以然。定位在上地故也。非欲界不能。独色界能。下自出七十三人。通三界尽能作暖观也。又一解。以果来系。因欲界直修摄身。口得人天乐果。名身行报。色界心静。不驰荡外缘。名心行报。故知是上果法也。言欲界有定者。是根本禅定方便。但携利根人。能即用此摄入无漏也。色界虽有禅定。能作暖法。要是内弟子非外道也。若具十六行。方成暖法。外道唯能作十六行中之二。及苦下初门之四。云何成暖法观耶

迦叶菩萨白佛言世尊(至)自性是暖非他故暖

案。僧亮曰。慧性自了。非他了也。宝亮曰。更作两问。定其位也。第一问云何受暖名。为二问为自性是暖。为他暖耶。佛今且答后问。明自性是暖

迦叶菩萨言世尊如来先说(至)为十六行行即是智

案。僧亮曰。因于信心者。信为暖因。明无因无果也。即是智慧者。破我见。必由智慧。非信等也。十六行者。法不出有为无为。有为有四行。无为有四行。有无必当有因。因在有为有漏集也。有为无漏道也。此二各有四行十六也。宝亮曰。迦叶举马师满宿。无有信心。当知信是暖法。佛言乃是暖因。非正是暖也

善男子如汝所问何因缘故(至)烟者即是修道断结

案。僧亮曰。八道火相者。无漏能烧烦恼名火。暖法为因故名相也。宝亮曰。答第二问。明是八圣道之相。故名暖。如攒火先有暖也

迦叶菩萨复白佛言世尊(至)云何能为无漏道相

案。僧亮曰。报得色界五阴者。上言色界法。即明报也。宝亮曰。暖法既有为有漏。由能作因。报得色界。云何得为无漏道相耶

佛言善男子如是如是(至)而能与彼正道作相

案。僧亮曰。厌故观行者。十六是观。观昧未免于爱。爱故受生也。宝亮曰。策故观行者。正一心中。此两用故。知善义资出。以相故招生。乃至一豪之善。皆不感生死

得暖法人七十三种(至)作五逆罪犯四重禁

案。僧亮曰。上说暖法。此说行人。若未伏欲界烦恼。而三界烦恼。具名具缚凡夫。谓一种人也。若断一品名不具。至九品为九。通前欲界具十。上除悲七地。各有九人。不复能断善根。僧宗曰。大意言此七十三人。悉能作暖观也。欲界有十初禅。至不用处。凡七地。七九六十三。通欲界十。为七十三也。欲界结九品。若是具缚凡夫。非不粗伏。非是伏九品次第者。别为一人。若依数经家义。要先得初禅心。方伏欲界结。要得上地心。伏下地结。依论主则不得尔。如使暖法人。得初禅心。伏欲界结。若是利根人。不假须上地心。正用自他心。自从四意。止渐入暖法。入见谛成圣果。若钝根人。要须修上地胜定。快方能伏下地也。宝亮曰。佛初出世。要先度一切外道。然外道伏结法用。亦不知有见谛思惟之别。但知厌下求上。作九品伏法所以尔者见谛结本。以我见与断常为源。外道既不伏此结。然与思惟类同者。何为不伏。但自伏见谛结不成就。是以佛今但就伏三界九品思惟惑。作七十三人。不就见谛也。然始伏取定。事乃相准。要暖观成后。皆智慧之用。欲界十人者。取曾伏思惟。或为九品作九人。其初一人。都未经伏结。何故尔。此人先虽不作心伏惑。亦遭贤值圣。便从教行。行作苦无常观。得假名法空。成暖法观。所以为一人。若曾作心用九品伏惑者。后入道亦如初。一人法不异也。如是从欲果讫。至无所有处一地有九。就欲界未曾伏结者。为一是则七地有九。便是七九六十三。就欲界十人。合为七十三人也。欲界何故有十。而上界唯九。然向上界生。无有不伏下地惑。而得上生去者。生上界人既无有。如欲界不曾伏惑者。故但有九人也。智秀曰。不于想非非想制人者。依小乘经。明凡夫仰无所假。不能伏烦恼故也

是人二种一遇善友(至)遇善友者遍观四方

案。僧亮曰。释暖法之能。暂出还没者。若遇恶友。住内凡夫。没在人天。不速成果也。僧宗曰。从此分解。取第四人也。第三人必不退。而言二种者。此言未得暖。在四念处时。遇善友则进修入道。若遇恶友。尚不得暖。况圣果耶。宝亮曰。不异前释。遇善友成住人。遇恶友。则还没也

观四方者即是顶法(至)四方者即是四谛

案。僧亮曰。第四人从顶以上。住行迟速。不为恶友所缚。从四念处。至世第一法。有五品善根。下中上。上中。上上也。四念为下。暖法为中。顶法为上。忍法上中。第一法上上也。念前诸法不定。不入五品。在二品上名顶也。四方譬四谛。观行转远言遍。释顶义也。性是五阴者。具身见等诸业名凡夫。重则名外。轻者名内。暖法断重之始。慧心弱故。未能令身口诸数。皆背重恶。顶心已强。使身口诸业。不起重恶身。口善业。皆是顶法。故言性是五阴也。亦缘四谛者。明智慧是行主行行说之也。次得忍法者。重见将终次立忍。智心未周泰名忍也。次得世第一法者。经有内外凡夫。若未断内名世。断内外尽名第一也。此五人得世间无漏。亦圣亦凡也。苦法忍者。出世无漏。断内凡夫。但说忍智。以见灭为见谛道。不见灭不见苦等。言色等有性。有性则常。常则是乐。乐则不苦。见色无性。因缘假合。起唯苦起。灭唯苦灭。始见苦忍。见苦无生。是为见苦。初称苦忍。明其见灭。但说苦名。余可知也。夫断结有三种。一从理不从厌。谓菩萨也。二从厌不从理。谓外道也。三从厌从理。谓声闻也。菩萨从理。名无生法忍。声闻乘厌通苦为名。辨大小道异也。忍性是慧者。缘空是慧。缘有是想也。缘于一谛讫。见断烦恼者。一谛谓灭也。见断者。四谛所断也。一智断四。故言乃至也。如胜鬘云。以一智断四住烦恼。亦得四断智功德。又云。无世间上上智。以四智渐至上上智。出世无漏也。僧宗曰。顶法人。虽缘四谛。而集空心少。见有意多也。阴者言有。亦名聚积。明此观心。存有情多。故言性是也。乃至忍法小胜。亦性是五阴也。世第一法名性。是五根者。得理转深。移阴作根名也。言第一法。心能为无漏作根。苦忍缘于一谛。若论前暖法。第一法尔时。能习缘一谛。既有心多无心少。没无名但与有名也。从顶以上。见断烦恼。至须陀洹果。为第四人也。宝亮曰。正以此第三住人。遇善友得信首五根立。资斯之解。入见谛道。断示相惑尽。成须陀洹人也。缘一谛者。得四谛平等。正观现前。无复四异。唯空慧相随。若在五方便时。犹有想受等异。缘四谛之别。今者苦忍初心。会无相故。得缘灭谛名也

迦叶菩萨白佛言世尊(至)二者非因见因三者疑网

案。僧亮曰。一谛者。断结一时见谛。可以为证也。僧宗曰。欲闻会二经也。此中有四问。下次第答也。宝亮曰。此第一问。请会教也

世尊何因缘故名须陀洹遍观四方

案。僧亮曰。第二问何故名遍观四方也

复何因缘名须陀洹

案。宝亮曰。第三问得名之意也

复何因缘说须陀洹喻以错鱼

案。宝亮曰。第四问所以喻取譬于鱼

佛言善男子须陀洹人(至)是故如来方便说三

案。僧亮曰。常所起者。身见疑也。难识者。难可断也。烦恼因者。身见也。对治怨贼者。戒定慧也。方便说三者。释所以但说重也。僧宗曰。身见诸惑之本。[雨/復]于慧品。戒取违于正道。[雨/復]于戒品。疑则遍[雨/復]。触事不成。此三所以重分别。则无量也。宝亮曰。以三重者除故。四十里水。亦自枯矣

如汝所问何因缘故(至)坏大怨者谓四颠倒

案。僧亮曰。答第二问也。内外者。爱结是内。嗔慢是外也。宝亮曰。须陀洹人。观于四谛。得四种功德。二据所得。二据所除也

如汝所问何因缘故(至)以逆流故名须陀洹

案。宝亮曰。非对番名。但义中训释耳。谓断见谛一厢结尽。不复遂生死流。故受此名

迦叶菩萨言世尊若从是义(至)不得名为须陀洹耶

案。僧亮曰。若从此义。斯陀含以上。皆逆流也。名不应异。宝亮曰。三果皆备上二义。何犹初果耶

善男子从须陀洹(至)须陀洹果至阿罗汉果

案。僧亮曰。先断得名是旧。后断更名为客也。是人亦名须陀洹者。是第二果人。初果无二名也。解脱者。解身也。僧宗曰。凡夫名是旧。须陀洹名是客。又云。圣中作客旧须陀洹名旧。三果名客。故以先得名须陀洹也。流二种者。伏结涅槃永断道也。亦名菩萨者。向以佛名须陀洹以上同化也。今以下同上也。一者利根。二者钝根者。炎解义也。宝亮曰。一切众生。名有新旧。但未得圣者。有凡夫时名得。已后更立新字异名。更互乃至佛也

善男子如汝所问何因缘故(至)是故坚持其心不动

案。僧亮曰。喻以错鱼。凡四事下。自合譬也。宝亮曰。错鱼有四事。喻初果有四德

迦叶菩萨白佛言世尊(至)何故不名为须陀洹

案。僧亮曰。上云先得。今问为先得道。为先得果。为定之也。宝亮曰。问有两关。一问苦忍。二问超越人也

善男子以初果故名须陀洹

案。僧亮曰。定所言初者。在果不在道也。僧宗曰。一答则两难。皆塞也。何者苦忍先得而非果。所以名向超越那含果。而非初。所以不名须陀洹也。宝亮曰。先答也

如汝所问外道之人(至)具足八智及十六行

案。僧亮曰。那含非初得也。尔时八智具十六行者明超者是初得。僧宗曰。若依数经。须陀洹证六智为果。未得尽无生。未得根本禅心。不得他心智等。非证果之心。是则无八智。亦言少分尽无生也。今一解云。见智比智观见。在四谛为四。过去未来。四谛为比。是则合谛分世。为八智十六行。若合世分谛。言此人具得。此故证须陀洹也。宝亮曰。明无此超法。彼家所以作此义者。用等智断结。故凡夫时。以断思惟烦恼。后断见谛结尽。直超证那含。今明等智本是伏结。非永断道。及见理生解。要先断见谛。次断思惟。此人直经果心。而过不出观非是超也。尔时具八智者。那含不复观四谛比现八智作因。唯用一灭谛智。为因得果。岂得以第三果。名须陀洹耶

迦叶言世尊得阿那含(至)何故不得名须陀洹

案。僧亮曰。将第三果。亦得此法。还复并也。宝亮曰。明此那含人。亦得八智。同作十六行观

善男子有漏十六行有二种(至)以是因缘喻以错鱼

案。僧亮曰。共者。内外凡夫。共舍凡得圣故名。初果阿那含。以迳二果非初舍。所以共也。暖法已前外凡夫。亦得行十六行。内外共也。不共文隐。暖法以上。及四果皆不共。何者后摄以为果知共。不但有漏也。向果暖法已上皆向也。是世间无漏。通称无漏。八智亦尔。说超者道比智成果。舍七不舍八。此言舍八。非但十六世俗。不断结。无超越明矣。佛有超语。迦叶问者何也。能伏三空结者。利根于下。以有厌也。迳初二果不住。至第三乃住。佛为住处。说超惑者。谓不经初果失旨也。迦叶问正以缘一谛者灭谛也。无穷生死。为四倒所迷。暖法以来。须别缘四谛。助成初果。重倒已灭。不须四也。僧宗曰。分解各有处也。须陀洹见谛道中行。阿那含思惟道中行也。有漏十六行二种者。凡五方便。都名有漏。若四意止。则外凡夫共。所以尔者。言四意止。人犹可有退。还外凡夫。理与外未得分隔。是以名共。若入暖法。法根立转。得法空照理。永不复退。分绝凡夫。故名不共也。无漏十六行。二种初入见谛。未得须陀洹果。尔时名若第十六心证果。名为得果。八智亦有二种。若是第十五心已还。尔时见智比智。悉名为向。若第十六心证果已。尔时作见比智。观四谛。名得果观。须陀洹舍共。得不共者。不言舍前四意止。中前久已舍。今言舍者。还是见谛中十五心。同是向中共行十六也。今舍无漏共。得果不共也。若当证果时。乃不作十六行。但使在果心。自不复与向共。乃至舍向八智。得得果八智。那含不如是者。言须陀洹分解见谛。向中行初成。须陀洹那含。已经二果。分解思惟也。果异向异。岂得同耶。须陀洹缘四谛。那含缘一谛者。还就与脱受名耳。犹如世第一法。亦皆缘平尔时见有情多。识空意少。若入无相行。是则空心胜。是以从不如地第一法。约有受名。无相行乃未能都妄有心。但空缘明胜。约无受名。今须陀洹。亦缘一谛平等。正以不及那含。还名言缘四谛。实不缘四也。宝亮曰。此答意。始终次第。辨行阶级。然后释所以不得之意也。有漏二种者。谓四念前十六行。此与外凡夫共。从四念以上十六于时不复共也。无漏二种者。向果者。苦法忍已上。至十五是果者。得须陀洹时。乃无十六之别。但证本所行。故言具十六也。八智亦二者义如上也。然无相行中。亦无八。但目因时名也。舍共十六者。四念前也。得不共者。内凡夫也。舍向果八智者。苦忍以上十五心也。得得果八智者。果时明了也。那含不如是者。正释二人因异也。得须陀洹果后唯观一灭谛。不复以十六行八智为因。云何名那含为初果耶

遍观已行者即是斯陀含人(至)遍观方已为食故行

案。僧亮曰。第五人。进修思惟。故名行也。僧宗曰。既经初果。观于四谛。今复行向涉思惟。断粗贪粗嗔思惟六品也。宝亮曰。第五斯陀含人。为断三毒故。进修涉道。义如错鱼为食故行也

大般涅槃经集解卷第六十七大般涅槃经集解卷第六十八

  释第六行已复住广辨阿那含　释第七到彼岸广辨罗汉乃至诸佛　辨二人谤佛法僧一以不信故谤二以谬解故谤　释七种果谓方便果报恩果等　释佛性非有如虚空非无如菟角义　广释佛性如虚空义　广释佛不与世诤世间说有佛亦说有义　广释三漏义　广释十二因缘辨触增长生三种受

    迦叶品之第六

行已复住喻阿那含得食已住(至)七无色界般涅槃

案。僧亮曰。欲结下三品。尽名行已住。上二界名住。二者贪着色无色者。非是现灭。皆是上行人。通在住位。此应有行名。盖文脱耳。若不尔者。后行般涅槃。竟无所释也。五种者。行有迟疾。分为五种。七种者。分五为六。不足为八。以七中有同名者也。僧宗曰。既断欲界思惟尽。生于上地。受胜果报。贪着禅味。故所以住也。阿那含。凡二种者。且开二种。下文别曲明。见在得那含。以根利故。进修即得罗汉。二者。既得免苦。贪着乐报。住禅受生也。那含有五种者。此下广释那含也。宝亮曰。随宜说法。教门不同。或二五六七。并当一时所感。今初开二门者。第一。现般人。第二。从中阴以上。悉通名上流。此亦收那含位尽也。次五门者。从中阴以上。受初禅正生者。分四人。既受初禅正生竟。后改报去。二禅亦通。来作上流人说。虽有五名。收亦尽也。次六门者。五如上。以前二门中。初人为六也。七门者。亦如上。取生色界乐定者也。虽有此四门不同。当一门收之。亦无遗矣

行般涅槃复有二种(至)一者具精进定二者不具

案。僧亮曰。若前文不脱落。此文则无所释也。前四太疾。后二太迟。从第二至第四。独当行名。即昔说上行流人。今说上流异耳。一者精进讫。二者不具。通释七人所以迟疾不同。入出随意。名自在。不具前二人是也。宝亮曰。次释上四章门也。先释初二门中。第二上行人。若受二身。是利根人。若从二禅去。讫四禅中生者。是钝根人也。又有二种。一精进无自在定者。此人于定道不利。虽能精进。还入定取无漏。不即得故。无自在定也。二懈怠有自在定者。此人于定道通利。欲入即得。而不精进也。复有二种。一者具二。二者不具者。亦是利钝也

善男子欲色众生有二种业(至)是故名为中般涅槃

案。僧亮曰。受生业者。烦恼行也。作业者。身口合行受生业也。四种心讫。故名为中。此自心为中也。学无学者。无漏心也。非学非无学者。有漏善。及无记舍寿。不用无漏也。僧宗曰。言受身者。愿生身也。此那含。既根利。已久厌欲界中生。及其舍欲界身之中阴时。仍此中灭。不愿受色地生也。作业者。修四无量诸善功德也。有四种心者。言中阴。那含人涅槃时。于此四中。二是涅槃心也。非学非无学者。成果时。在无生心。此无生心。既非复那含。而言那含。在中阴有此心者。仍那含名。若初入中阴。是那含及其将入涅槃之时。已得罗汉。此无生心。非是尽无生二智。是以不得名无学也。二者学心者。言未得罗汉之时。进求故。为学心者。三无学心者。谓罗汉。尽无生二智。名无学心也。四非学非无学心。谓成罗汉报无记心也。取二种非学非无学。入涅槃也。中间二心。则非也。前非学非无学者。此观空心。不为断结成果。但游观空。为欲入涅槃也。取后非学非无学。若依四分毗昙中解罗汉。任运得入涅槃。是以中阴入时唯用二心。中间二心不用也。宝亮曰。次解五门中之初人。一作业者。即是色界正报业。二受生业者。是色界润生业。色界但受中阴报。而得涅槃也。舍欲界身。未至色界者。就人为语。如似从四行而未至。然理捡不尔。亦不测初禅中中阴几时。若取况人中三七日论利根人亦生中阴。即得道者。如始离欲界。若极钝根人。尽三七日得者。如舍欲至色界边也。一非学非无学者。世俗善心。二学者。正观真解心。三无学者。亦是正观。而非活结心。四非学非无学者。无记心。今用也俗善心。及无记心。得入涅槃。余二心中。不得死灭也

受身涅槃复有二种(至)是故名为受身涅槃

案。僧亮曰。受身义。在初生也。与昔生般涅槃同。今云。尽寿与生。义不同也。是人受身。然后断者。辨异于中涅槃也。僧宗曰。二种者。言受身具二种业也。智秀曰。以尽寿之言滥。故设问也。宝亮曰。受身涅槃者。次解第二人。此人受初禅正生。断三界结尽。即成罗汉。名受身涅槃也

善男子行般涅槃者常修行道(至)是名无行般涅槃

案。僧亮曰。行已无行。受身中利钝差别。宝亮曰。行般涅槃者。次解第三人。但受初禅正生者。根有三品利钝之殊。此人最钝。穷生中行道。然后得果。名行般涅槃也。道慧记曰。或更二身者。更出第三行涅槃中不同人也。如论家但云初禅中有三人。此言或二身四身。非上行。是则不但初禅也

上流般涅槃者若有人得(至)至第四禅亦复如是

案。僧亮曰。伏结生第四禅。以烦恼流退。通流则进。上下回流名上流。异常说也。僧宗曰。言得四禅后时。起初禅爱心。退生初禅。若依数论。则无生退。亦可言此身唯在初禅。悬得四禅心后。时还起初禅爱心。故言退。实非是生退也。从此道流。则还断结。至四禅也。宝亮曰。解第五人。从解初禅正生。受二禅报以上。通名上流人也。若有人得第四禅已。退生初禅者。但此语。非是明。那含人断下地。三禅中惑已尽。云何退生。此是烦恼流人。凡夫之位。既解那含人。何故牵此。正为遣物疑。若从下向上。亦名上流。从上流。然是事法尔。其况若为如似风从东来名东风。水从西来名东流。是则据风为言。从所来处为名。水而为语。就所向处为谈。此之二人事亦同。斯恐寻者乖谬故。所以牵凡夫来简正。以道流者。名那含人。不取烦恼流者。为上流人也

是四禅中复有二种(至)乐论议者处五净居

案。僧亮曰。一入无色界者。即是上流。分为无色界故。是流中差别也。二乐智者。释所以分四禅定慧等。无色定。多慧少修。等乐慧不乐定。一内二外者。内己身。外他身。中阴定慧。虽弱其道勇健。烦恼粗。过患易见。独得涅槃也。宝亮曰。次解第四门中第七人。但自初。二门中第一现灭人。不解。次六门中第六人。亦不释。何以然。正言此人神根最利。能一身之中。顿辩四果。其旨无曲。意易而不陈。如其不尔。亦莫测其由也。夫众生所乐不同。若乐论议者。则生五净居。若乐寂静者。必生无色界也

复有二种一者修薰禅(至)则能呵责无色界定

案。僧亮曰。如是二人。一修薰禅。二则不修。修者。则回四禅中业。别异处受生。二不修者。则无斯业如数。经家作薰禅法云。从无漏心出。薰有漏善。使明理。若如斯。便圣人更起业。经云。何言圣人。毕故不造新。当知。今所论者。乃本是昔四禅中业。直是圣人运无漏力。自在能转彼本业。若别处生。更无别因。问何故尔。四禅中凡圣同所。每多諠杂。不能生深智慧故。所以回此业。别余处生。若生彼。则与凡报隔。便静照在心。智慧日明。是以。经称乐论议者生五净居也。既解六人竟。物还于向释中涅槃者。生两疑故

迦叶菩萨白佛言世尊(至)欲界有中涅槃色界则无

案。宝亮曰。迦叶为问。第一问言。中涅槃。又神根若利何不现在入涅槃耶。第二问云。何故欲界有中涅槃。色界独无也

佛言善男子是人现在(至)是故不得现在涅槃

案。宝亮曰。佛不次第答。先答初问言。此人神情虽利。于现在入道缘不具故。所以须在中阴中。不得现在灭也

善男子如汝所问何因缘故(至)悭贪嗔恚是故名住

案。僧亮曰。次答。后问。言欲界受生是苦地。犹须外依资。报身得立。然即用此为迫恼缘。故到来观欲界。为发悟之由。所以欲界有中阴。上界是禅地。不待外资。又无大苦。故无有中涅槃也

善男子到彼岸者喻阿罗汉(至)是故喻以水陆俱行

案。宝亮曰。解第七人。从罗汉以上。至于诸佛。通名为一人故。借喻于神龟能水陆俱行。但水陆两事。如文所合。世间河中。虽有七种之别。同不离于水。涅槃中亦尔。乃有七人之异。亦通不离佛性之水。但佛性之义。随事而收。或缘因。或境界。如是众多。若因。若果。尽是佛性

善男子如恒河中七种众生(至)是名如来随意语

案。僧亮曰。释皆是佛方便也

迦叶菩萨言世尊若有因(至)云何沙门云何沙门果

案。僧亮曰。明果是常。成彼岸义也。僧宗曰。更问。涅槃无因体。不应是果也。宝亮曰。更与两问。一谓若涅槃无因。云何名果。二问。涅槃亦称沙门。云何为沙门。名沙门果耶

善男子一切世间有七种果(至)即无量世所修善法

案。僧亮曰。举此七种。意欲取最后远离果也

善男子如世间法或说生因(至)唯有了因无有生因

案。僧亮曰。有为法。生因有二种。一以业生名生因。二以近。为生因也。了因亦二种。一以果不生名了。二以远为了。有为法起。因有所生名生因。而生因有近有远。远则名了也。出世亦如是者。出世无为。无为无起因。无所生。名了因。有近远。近则名生因。生因者。烦恼不生即涅槃。身口意净。皆断烦恼。三脱是近。名生因。亦为涅槃而作了因者。三十七品。亦有近远。远名了因。了了见于涅槃。说无有生因。答上问也。见涅槃是果。无生因故。得称常。宝亮曰。明涅槃是了因之果。非生因所生。三脱门等。于烦恼作不生。为强故设生。生不因也

善男子如汝所问云何沙门(至)是名沙门沙门果

案。僧亮曰。先说道果体。下自释名义也。欲答第二问。言沙门那者。即八正道也

迦叶菩萨言世尊何因缘故(至)是故得名为沙门那

案。僧亮曰。有为羸劣名之。六道差别名道。八道从所断得名也。宝亮曰。此言乏道。唯生死是。乏道能不息一切烦恼果报。具八圣道。德行盈满。业累消尽。名沙门果也

善男子阿罗汉人修是道者(至)名阿罗汉得到彼岸

案。僧亮曰。释彼岸法。上五分是总。此广解脱智见身度彼岸之义也。宝亮曰。举四智结也。明具此四德满。即名到彼岸也

如阿罗汉辟支佛(至)以得果故名为具足

案。僧亮曰。得无上道。乃名具足。唯佛一也。通称菩萨者。以道同也。方于二乘。亦是彼岸也

善男子是七众生不修身(至)度生死河到于彼岸

案。僧亮曰。上已广明其义。此更略显

若有说言一阐提人(至)若言不得是名虚妄

案。僧亮曰。谓现得不得。未来得不得。早计名著。证性为虚妄也

善男子是七种人或有一人具七或有七人各一

案。僧亮曰。一人具七者。言三世一人。各一者。坏现在也。宝亮曰。假名一人。当来必具足也。僧宗曰。始终为论。佛亦曾为阐提。故一人具七也。当位而谈。则一人各一也

善男子若有人心口异相(至)当知是人谤佛法僧

案。僧亮曰。已说七性有无相。定异见异说。则谤佛也。异相心见。与七相异口说亦尔。下自有释也。八圣道分。讫非凡夫得者。得则现不得。未来不得。未来不得明谤。僧宗曰。若语其体。果时自果。不善时自不善。言因果不离也。若有阐提。已得菩提。或都不得悉名谤佛法僧也。宝亮曰。此下。是还生善中第五文。举得失结句。先广明失过也。下一两句。双明。虽举失事故。冥消息其文。不可即文而用也

若有说言众生佛性(至)随意语故名三藐三佛陀

案。僧亮曰。空于众生是有。常不可见。佛性亦有。修道则见。非无如菟角者。菟角现无。不可方便得。佛性亦无。可方便得。虚空常故者。常不可见。菟角无故者。无不可生也。亦有亦无者。有是将有。无是现无也。有故破菟角者。将有可有。不同菟角。无故破虚空者。现在虽不见。终必可见。不同空也

迦叶菩萨言世尊如佛所说(至)云何名为如虚空耶

案。僧亮曰。大段之第六。辨常门也。所以辨常者。能分别佛性。还生善根。善得常果。明常唯有二种。一无常。虚空是也。二有常。佛性是也。无常。不可学得。有常。修道则见。欲令人识常果。修常因。不以梵天等为常。经初以来。以空譬性。上云有不如虚空。今问昔说譬之意也。僧宗曰。问意。若佛性非三世摄。而名为有者。虚空亦非三世所摄。亦应是有。此并问也。宝亮曰。物情于因果性理既决。便欲修因。若不识果。则无以进行故。举体非三世所摄故。所以有识者未来同得也。上师子吼。虽明果体。是常。竟未正论此体有无之异。今科简虚空虽常。而性是无。涅槃妙有。其性湛然。乃同非三世。而有有无之异也

善男子虚空之性非过去(至)我说佛性犹如虚空

案。僧亮曰。空有四义。可以譬性。一无三世。二非物。三无内外。四无挂碍也。僧宗曰。佛意。非此三法故。说名为有也。烦恼对涅槃。阐提对如来。无情对佛性。此三对故。为有虚空无对。岂得为有。宝亮曰。今就此一段说中。有四番明义。第一。辨佛果体常。异虚空之常。两常虽同。其旨甚别。第二。物还致疑。若两常同非三世所摄。何不俱名为有。而一有一无。佛释言。其常乃同。要一有对治。可名为有。而虚空直是物。无无所对治。故是无也。第三。遣外道横计虚空是有义。第四。引证。明三世智人。皆如是说也。今初门中。略出数事。明其异相。然文中。佛说其旨。理自彰也

迦叶菩萨白佛言世尊(至)无情之物是名佛性

案。僧亮曰。外道。说空是有法。故须明也。如来身心之总号。性是悟解之别名。涅槃灭苦之都称。三义异而常一。别称为非涅槃名为涅槃者。世谛有法。有无是非相对。虚空。世谛说无。一切烦恼有为之法者。烦恼是因。有为是果。因果是苦灭为乐。一阐提至辟支佛者。六度是如道。乘如道来。故名如来。此等不乘如道。菩萨乘而未至。故蠲之也。无情之物者。无情。无悟解之性。非性也

善男子一切世间无非虚空(至)离四阴已无有虚空

案。僧亮曰。世间住空。无有非空之处对空。故无对无非四大对于四大者。色性非空。住在空中。无非空对空者。心依大起。亦无非大对大。何得名四大为有耶。佛不答者。以其非决。以置答为答。何者。六识。所依各异。五识依大。意识不依。无色不住空。故非决也。涅槃是有讫。安隐彼岸者。此皆本不得今得。空无此义也。离于如是。说讫三世摄等。如来佛性三法等离。三法是有为。虚空若同者。同在三法之外也。世人说。讫不得不三世摄者。佛说二法聚色无色。至可见不可见。色。是四大。非色。是心数也。僧宗曰。无非四大对。此问粗故。置答也。如此人。说空非色是心数者。此下广明耶解。并不得受相也。宝亮曰。第二问之始。正释异意。举于虚空。以决涅槃。今两同为有。佛今答言。虽同是常。要佛果有对治。而不无。明如来佛性涅槃三法。同有所治。故是有也。故下去二释此三义。为非涅槃者。是生死法。正对治。此生死虚伪果尽。故名涅槃。为非如来者。阐提二乘之流。执相心重。不能称如理而解。如来。能断此不如之解。得于如解故。所以名如来也。为非佛性者。众生所以不见佛性。良由有烦恼业报。假依果而资身。佛既断业报尽。无复所须。则穷鉴佛性之理。明闇障之义。倾今对治此业报尽。故名佛性也。一切世间。无非虚空对于虚空。世间无有一物而非虚空。复为虚空所治者那得。难云。虚空是有耶解意。虽然于物情未去。故迦叶复因此后更设一并。若虚空无所对治。不得为有。今四大起时。亦无所对治。何故独名四大为有。虚空为无。决辞既尔。佛今将解。故无非言。虚空亦同涅槃是有者。其义不然。何以故。明涅槃是有。可见可证。能作种种应色。备有八我万用。皎然可得。是有现见处。虚空无斯之用。云何为有耶。既非其如此。然后答难。从若离于如是法外更有法者下。已对向决。若使离如是法。外别有一法。而是有者。必三世所摄。虚空若同是有。应三世摄。是无常法。答理既申。佛还引事。更到难迦叶言。如世人说虚空。名为无色无对。若虚空非色而是有者。应即心数法。若是心数。不得不是三世所摄。同四阴也

复次善男子诸外道言(至)若三世摄云何言常

案。僧亮曰。外道说虚空是色。有对可见。佛说非色无对不可见也。宝亮曰。第三文。破外道所执。正义明虚空是无。而外家计有。是故须破。汝若言虚空是光明。复计之为住处者。即是色法。若是色法。便有方所。即三世所摄。是无常住法也。夫虚空不离三法者。佛更作相来破。夫万法有无。不离此三。汝计虚空。在何法中。空者。直取无物处名空也。实者。如色法柱木等。是也。空实者。是有无之际也。若言虚空住空法中。便应无常。何以故。此虚空。不遍实处。与空实即是分数。若是分数。复不免无常。余实与空实。二法更相践。破意如前。同有不遍之过也

善男子若复说言夫虚空者(至)虚空若尔应是无常

案。僧亮曰。实处无故。则不遍。应是无常。二处无者。实处无空。空处无实也

善男子世间人说一切法中(至)虚空无阂与有并合

案。僧亮曰。各有处所。名一切有。所执处有二。则俱无常者随物。宝亮曰。既作此三句破竟。后还结言虚空是无也。又如世人说一切无絓阂处名虚空者。佛更假设作难。若无絓阂名虚空。此虚空。一切尽具足。遍有为有处。无处为当分有。若具足有。余处则无。一切处不可得遍。汝。虚空是有。云何能遍。若不遍便是可数。彼此之法。是无常也。又若有人说。虚空无碍。与有并合。亦无此理也

又复说言虚空在物如器中果是故当知无有虚空

案。僧亮曰。鸟动树静名异。两羊相触者。二俱动。名共也。二双指合在一处者。指先有空。空先有指。有二空二有。合在一处也。若有空业合物空则无常者。物住空动。动则无常。物则不遍者。物不遍故动。不遍故无常。下说空不遍之过也。虚空若常物亦应常者。若物动无空。空则不遍。不遍而常。物亦应常。若空与物同。亦常无常者。无有是处者。若言空常。先有物起。后合。先有是遍。后合不遍。遍者是常。不遍无常。无有是处也。先无有合。讫是无常法者。若已合共合则合有先后。后合本无。先合亦尔。皆无常也。先无器时。讫云何。言遍者。器则本无今有。未有器时。应有住处。处异空异。不应言常言遍也。僧宗曰。若使虚空离空有住者。上难其合。今难其离也。若空与有合。是则空同于有。则离空而住也。有物亦应离空住者。并难也。谓有物合。则应离有唯空也。宝亮曰。又言。虚空在物。如器中果。二俱不然。故先假作三法。来破其并合之执。下别破虚空在器之计。若与有并合。则有三种合法。一异业合。如飞鸟集树者。树本不动。来向树故。言异业也。二业共合。如两羊相触者。二物俱动。故言二业也。三已合共合者。如二双指合在一处。本时两合。今复来共合。故言已合共合也。先作此三句竟。下次第难破。若言异业共合。异则有二。一是动者。鸟也。不动者。树也。若尔。万有本不动如树。汝虚空如鸟动来。共物合。是无常也。若言物与空合。物复不遍。若当不遍。是分数法

善男子若有说言指住之处(至)虚空无故非三世摄

案。僧亮曰。佛说有依空住者。而惑者言。有空佉为有所依。即因缘住。因果同相。因无常故。果亦无常也。宝亮曰。既破诸外道所计竟。后还结言虚空是无物。故名常。非是有法。佛性常。而是有故。非三世摄也

善男子我终不与世间(至)世智者说无我亦说无

案。僧亮曰。第七辨因门也。所以辨因者。上云唯三法是常。余悉无常。与世间异。异则生诤。今辨因异故果异。从理说异。与世智同说。不与世诤也。僧宗曰。此下。第四段明修道也。宝亮曰。佛言世间智者。即是菩萨者。此下去大段中第七文。释两因异。将明此理。故先承上宗。作难。世间智人。说五阴是无常。佛独说我是常。既说不相随。便成世间诤。佛云何言远离颠倒。不与世诤耶。佛今答言。凡夫以三漏为因故。感苦无常。佛。用真无生解为缘。除于漏因。无复无常故。即体是常。其因各异。岂同世间。如此则称理而谈。乖诤何生。今就此文中。凡广略三番。释生死用三漏为因故无常。佛不用此为因。故常也。第一正明凡夫不识三漏为过。第二辨其起漏之源。第三明漏所感果唯苦无乐。然此三番。圣人识过。达其漏源。观其发解。故能除灭三漏。成八正道也

迦叶菩萨言世尊菩萨摩诃萨(至)如优昙钵罗华

案。僧亮曰。若从理说不诤。见理必由于行故问之也。宝亮曰。佛略列十法也

迦叶菩萨白佛言世尊(至)智者说无我亦说无

案。僧亮曰。请定有无之义也

迦叶菩萨白佛言世尊(至)是故说是常恒无变

案。僧亮曰。将明因果执异为难。若事同而说异。应是沾污也。已离三种以下。若从理说。则不诤。说与见异。何得不诤耶。凡夫之色以下。明因果事不同。说不到故。不污不诤也

迦叶菩萨言世尊云何为色(至)知病所在然后授药

案。僧亮曰。问从答离。见过则离。不见则从也。问略而答广

善男子如人将盲至棘林中(至)虽受果报果报轻微

案。僧亮曰。明离恶有渐。知罪过已。从人天果报说过。得二世之利。果报轻微者。苦由痴起。见过则痴轻故也。宝亮曰。如人将盲至棘林者。盲喻凡夫。与棘林譬三漏。还此三漏。将众生受苦果报也。舍之而还者。如果起因谢也。设复得出身体坏尽者。设复后时厌苦修道。必具经受八苦也

善男子有四种人一作业时(至)饿鬼畜生人天果报

案。僧亮曰。作业时重。受报时轻者。作时不见过。受报时见。如是四种

是故我于契经中说(至)不为世法之所沾污

案。僧亮曰。远离烦恼观行有五。一者观体。二者观因。三者观果。四者观轻重。五勤修道。此是常第二下三文中自现也

迦叶菩萨复白佛言世尊(至)即是贪因嗔因痴因

案。僧亮曰。广上观心行于缘不得法。皆是无明。录其重者。分为欲有。欲界。命资外存欲情重。名为欲漏。上界痴轻。直名为有。内恶觉观。讫生于欲漏者。漏。是贪等烦恼。内外缘生。觉观是想。缘是外想。是故一切讫是名欲漏。缘非欲也。能生欲者欲。从欲生者欲漏也。我及我所者。不能分别阴界。皆是无明。欲知其是总也。贪因痴因者。三烦恼。录其重者。无明通轻重。得为痴因也。宝亮曰。第二番。先释三漏名义。后辩其相因起漏之源。凡夫。所为不能忘怀。唯自是为失。故成漏因。圣人以道自处。心无所存。故成道缘也。或时因中说果者。夫无漏解。本非果报。从所发处为名。故说无漏为果。迦叶向问有无漏果。复言。智者断诸果报。今诸圣人。云何得有。佛答云。真实无有无漏果报。得知无漏。是散灭生死法。非复集谛。而解者称此。无漏但不系三界。由感变易果者。恐非圣意。而今大乘了义。佛自断云。真实无有无漏果报。岂更感生死果。成于集谛。而胜鬘经。称无漏业为因。无明住地为缘者。别自有意。不关用无漏为集谛也。五阴。是业烦恼家果。寄他无常苦报。上依善知识理缘中。发得此无漏解。故云是果。捡理而谈。实非果也。或从心身到梵天边者。亦是因中说果。心者。是定因。此定能得梵天身

迦叶菩萨白佛言世尊(至)四大远因烦恼亦尔

案。僧亮曰。互为因果者。非女取女。名无明也。分别好恶。名不善也。取好恶已。更增女相。如是九品。互为因果也。子是近因讫烦恼亦尔者。虽互相生。而女相是远。好恶相是近也

迦叶菩萨白佛言世尊(至)从无明生阴入界等

案。僧亮曰。是内无明。讫其内。外因者。是烦恼。内外因能生无明。名无明。如说色等名欲也

迦叶菩萨白佛言世尊(至)智者当观生烦恼因

案。僧亮曰。广第二造作何行。讫受谁房舍者。是时恶友共住是处。事与行同外为异。受深心供养房舍也。转下作中者。与上事增长为异也

迦叶菩萨白佛言世尊(至)而能生长种种烦恼

案。僧亮曰。欲明烦恼。亦以过去烦恼为因也。如一器中者。无始以来。起无量烦恼。种子中虽暂伏。遇爱则生也

迦叶菩萨言世尊智者云何(至)如是烦恼受诸恶果

案。僧亮曰。广第三。三种。苦苦坏苦行苦。无常亦尔也

迦叶菩萨言世尊有无漏果(至)能灭一切烦恼果报

案。僧亮曰。圣人诸阴。是烦恼果。若断果。不应有圣也。因中说果者。凡言断报因。名断报耳。是名因中说果。无漏非报因。不在断中。我从心身者。定是心。梵天是定报。定能得身。名定为身。无有无漏果报者。无苦乐报。更不生漏者。不生漏即是涅槃。无法可断

迦叶菩萨白佛言世尊(至)是名身中有妙药王

案。僧亮曰。略第四。广第五修道。有惑名众生。无惑非众生。是烦恼因果。从惑生惑。无道可修。明八道。亦以烦恼为因发。一因二果。讫果恶故子恶。因过明果现。与未来为子。三世皆恶。先喻雪山。说身中有妙药王者。考事则异先譬。不应有能修如是清净梵行者。涅槃八道。能至涅槃。名梵也。宝亮曰。下第三番明三漏。今迦叶发初难云。若以烦恼因果。俱是恶法。云何言众生身中有妙药王。但譬法不同。上说妙药王。譬正因佛性。今此中云。妙药王者。谓无漏解也。佛今答言。如世间从子得果。此果。有还与子作因者。有不能者。如今谷子。从过去谷生。名其为果。然此子。又能生未来谷。还成因义。枝叶等物。虽从因生。不复更能为后因。明烦恼亦尔。从过去惑因。得今五阴。于今果上。更起未来因。果报连续。此便有即因即果义。既借譬如上。下即出事。一有烦恼果。是烦恼因者。是因即果即子义。二是果非因者。谓无漏解。既寄此果报中。修得此解。更不生后。唯果非报。故名为清净梵行也

迦叶菩萨白佛言世尊(至)是则名为清净梵行

案。僧亮曰。有义未彰。重问。烦恼果非烦恼因者。烦恼起有因缘。似过去烦恼为因。现相为缘。因缘皆到。若以无相为缘。则因到缘不到。是果非因。名为梵行也

大般涅槃经集解卷第六十八大般涅槃经集解卷第六十九

  辨三种业谓身口意　辨四种报谓黑报白报杂报不黑不白报　广辨烦恼业更相生义　论世第一法有漏无漏义　广辨三十七品作九种名说谓主胜导等　广辨十想　广辨七想

    迦叶品之第七

善男子众生观受知是一切(至)断和合故则不生受

案。僧亮曰。释爱是因。以我为乐。则生爱着也。十二因缘。所作善恶者。以生死为乐。不能离故。名受时也。何因缘生者。次观受因。因复有因。从微至着。明可断也。不因自在天生者。雅因要得其正也。皆从缘合而生者。缘合则非自非他。生无定主也。即是爱者。乐受生爱。爱生乐受。互为因果也。是和合中者。从合故非有。合生故非无。断合则不生也。宝亮曰。此下去观六种法。谓受想触欲业苦。唯触一法。无别观寄诸门也。所以先观受者。一切惑起。莫不由受。故先观受过。就观受中。观先受因。次观受果报轻重。三观受之灭处也。内外漏因心外境上生。漏尽因三受起也。如是受何因缘生者。次观受因。如是因缘。复从何生者。为次第种种观因。终非是无因而生。不从想生者。别是外道所计无想天想非想阴之想也。若有此因生。应当先断此受因也。因缘即是受者。从过去灭心受作因生也。非有受者。因缘中无有性受。非无受者。不离因缘有也

善男子智者观因已(至)是则名为清净梵行

案。僧亮曰。若不观果苦。则不厌受。断受因故。次观果也。受因缘得解脱者。乐生则系。乐灭则脱也。断我我所者。知无宰主也。有少灭处者。三慧断结。以闻思断粗。名小毕竟。修慧断微。名毕竟解脱也。知从八正。即便修集者。八道无漏。是修慧也。增长身心者。八道向灭。而增长违道也。何因缘故。能增长耶。触因缘者。谓闻思观远因。修慧观近因。下观果也。非明无明者。有漏善及无记也。杂食爱者。能令生死不断也。宝亮曰。观因既竟。次观果者。得三恶苦报。此三恶果。虽都是四心家报。要不离于受也。何等受。能作爱因。何等爱。能作受因。此明更互相生义。爱亦能作受因。受亦能作爱因也。观因果轻重既竟。故次第三观受灭处。若得信首五根。二空成就。名作少灭。至正观无漏。名为大灭也。是道观受有三相者。即三受相。然此三受。能增长行阴中身心烦恼也。何因缘故。能增长者。从三触因缘故生。第一无明触者。烦恼触也。第二明触者。能生无漏八正道也。第三非明无明触者。世俗善心也。如是受亦名为因。亦名为果者。从触生名果。能生受故。亦名因也。观受作三门既竟。今次复观爱果报者。因爱而生。所以须观也。智者观爱。复有二种杂食。爱者四食也。无食爱者。断四食得无漏也。若欲断爱。先断受因。近因是受。远因是触。因果尽断。所以得八正道。即名清净梵行

复次善男子智者当观(至)想受灭故名为解脱

案。僧亮曰。二事何因缘生者。爱受是生死之本。更观近因也。知因想生者。想取假名。而倒有轻重。重为爱因。轻为受因也。见色不生贪者。释受因。着好生贪好相。是假眼识见色。未得假想。取假想受得好恶。轻为受因。及观受时。亦不生贪者。释爱因。受从倒生。受初得好时。未生倒想。取常乐已。乃至贪爱。重为爱因也。想有三种者。少有二种。一缘小。二住缘时少。至无量亦尔也。未定者。散心缘不定。亦住时少。欲界定粗。亦尔也。无色界无色。不为外缘所动。住定久。云何说耶。想受灭名解脱者。释佛所以说想受。为漏因也。宝亮曰。智者当观受爱二事。从何而生。知从想生者。此下次第二门。观想即假法相。故名为想。凡颠倒妄缘。皆不得法实。是想三种者。若想像小缘。名为小想。想像大缘。名为大想。想像无量缘。名无量想也。复有小想。谓未入定者。欲界电光定。复有大想。谓已入定者。八禅地定也。复有无量想者。十一切入也。若三想灭故。则受灭。想受既灭。便名解脱也

迦叶菩萨言世尊灭一切法(至)闻者亦解说于众生

案。僧亮曰。解法者。法别众生总。总别相因。说一则知二。心数相因。受想居要。受想可断。知余亦可断。说亦尔也。应亲近者。唯说杂法解者。亦杂也。宝亮曰。迦叶因此语后即问。若为说想受灭。名解脱耶。佛答言。如来或时。因众生说。闻而解者。如先为大迦叶。说众生灭时。善法则灭。但法由人弘。若人不复行。便法不流转故。以以言众生以明法也。因法说于众生。闻而亦解。说于众生者。如为阿难说。若有法。能生烦恼者。便不应亲近。即恶知识。若有法。能生善者。便应亲近。即是善知识。既说可亲近法。不可亲近法。故物即得因法解善众生。不善众生。是则善者可亲。不善者不可亲

善男子如来虽说想受二灭(至)虽有毒草亦有妙药

案。僧亮曰。无若想者。世谛辨法名想。世所共传。名流布也。世谛有二。一理。二倒。缘广假名是理。计有一异是倒。倒则生着也。宝亮曰。虽说想受二灭。则以总明一切法灭也。想因触生故。次观触有二种。因无明识。起想受烦恼也。因明识。断烦恼得解脱也。触本寄诸门。故不别观也

复次善男子智者观欲(至)虽有毒草亦有妙药

案。僧亮曰。即是色声者。先观欲因。因有内外。色等是外。到想是内也。便生于受者。即欲也。欲无别法。倒想多为欲。乐名受也。十恶后想起。名十恶想也。以恶父母者。杀害是行报。地狱生报也。宝亮曰。次第三观欲。欲即五尘。明五尘非欲。能生于欲。因中说果。故名为欲。所以观者。因五尘故。生识着识。故生想。因想故生受。因受故生行阴中爱欲也。然从五尘至受。皆是欲因也。但识过患少故。不作别门观也

复次善男子智者如是(至)造作三种身口意业

案。僧亮曰。次当观业者。八苦以生为本。烦恼与业合行。然后受生也。次观业。受想触欲。即烦恼者。惑性皆是烦恼。以始末轻重为异。能别名触。无别门也。以通是想受之因。一作生业。二作受业者。资业受生名生。能得生报名受也。善男子。身口二业者。造作是业义。意性造作。不作从生身口具二也。以因故得名为业者。身口非作性。因意得名也。正业是意。期业是身口者。性是善恶名正也。应他善恶名期也。先发故名意。讫得名为正者。此正释也。谓先发为主。从他为应也。即无明触者。业能通四。欲说苦因。但说无明也。宝亮曰。智者观欲已。当观业者。第四门明受想触欲。即是烦恼。此烦恼能作业者。即十二因缘中行枝也。不作受业者。不作润生结报业。何以故。初作业时。要未改报。便未用润生惑也。如是烦恼共行。有二种。谓生业受业者。欲明烦恼。始终不相离。更互得作因作业。亦得作受生业。故还来来取。观业既竟。便次观因。因即无明触。因此无明痴。识于缘中取着。乃至生行阴中业也。观因亦竟。即次观业所得果报。上上善生阎浮提者。此论受道边胜。异昔教之说。虽复两教不同。各自有意。余三天下义例。悉殊昔其旨。是等不复别释

善男子智者如是观业因已(至)果报者名无漏业

案。僧亮曰。作业时垢者。释业名也。因不善故。果报苦也

迦叶菩萨白佛言世尊(至)虽有毒草亦有妙药

案。僧亮曰。是义有二。一者亦果亦报。二者唯果非报。唯果非报者。果是报因。此名则通。以因报因。此名则别。有漏具二。无漏唯一也。善男子。无有报故者。业从报制名。为苦乐受是正报。苦性黑。乐性白。以乐治苦。名对治灭苦乐寂静也。有定受报处者。黑在三涂。白在人天也。郁单越于世乐为上。于道乐为下也

复次善男子智者观业观烦恼已(至)苦因缘生苦

案。僧亮曰。是二所得者。观苦二法合行。涅槃得果名。二果即苦也。离一切受生者。生是苦本。故先说生也。复观烦恼因缘者。次观四道业及烦恼是因。苦道是果。因果通名有道。四道相生。莫识其次也。宝亮曰。智者观业已。次观业烦恼所得果者。第五门观苦。明业烦恼与苦。更互相生。六道因缘。俱无微乐。故圣人令断苦而修道

善男子智者能作如是观(至)当知是人能断众苦

案。僧亮曰。不造新业。坏故业者。十二因缘总三苦。见三苦。坏一切业也。观一切地狱者。观苦苦也。复观人天者。别观坏苦也。深观三界诸苦者。别观行苦也。智者若能观苦八种者。总结也

善男子智者深观是八苦已(至)虽有毒草亦有妙药

案。僧亮曰。求身求财者。身是内命。财是外命也。作业者。作善恶也。增长者。长善恶也。作业。作意业。作果。作身口业。即是取也。爱取是轻重之名。轻为重因。取是果也。经云。习近五欲。是名为爱。内外贪求。是名为取。知是轻重也。爱因缘取。取因缘爱者。爱取有增。次为因灭。以为因性有增减。明其可断也

迦叶菩萨白佛言世尊(至)悉是何等一切法耶

案。僧亮曰。第八美经之德也。净则涅槃。因即是行。涅槃三法。皆是因。无法非因。言一切法是。而义不决定。言旨未显。故定之也。善不善诸法之本。以本摄末。亦同一切善知识。摄一切梵行也。宝亮曰。大段中第八文。次明叹经。若依此学。必出生死。成清净梵行。昔教所明理未正。与生死未相分解。故不成真梵行。今就此中赞叹。凡有三番。第一总就境智为叹。第二偏就三十七品无漏智体为叹。第三历十想取远资发义为叹。今迦叶既问。故佛答言一切是。此通就境智为言。夫境能发解。智生有由。所以通束为清净梵行。虽有此判。其旨未显。故迦叶更举诸法问。一切法不定。如来今者。定以何法。为一切耶。佛又答言。大涅槃经。乃是一切法之宝藏。故知此经理正具明六行。能生人信慧。速出生死。是以莫问彼法此法。皆因涅槃生。亦即因此境智。得大涅槃。所以尽得作清净梵行。故下频作三十余事。赞叹此经之力用也

佛言善哉善哉善男子(至)现在诸佛之父母也

案。僧亮曰。一切法谓经法也。能济穷乏。谓之宝。无宝不备名藏也。此经说佛性果。能出生死名宝。说果则无法不常。说因则无法非性名藏也。自大海以下譬藏。猛风以下譬宝也

善男子是故此经摄一切法(至)即是卅七助道之法

案。僧亮曰。先说正因。更说缘因之近者也。宝亮曰。上已总就境智。今正取真无漏体。明真无相解。不与惑俱故。所以得名清净梵行也。五方便中。虽是相似解。要体未免惑。由是颠倒故。非清净梵行也

善男子若离如是三十七品(至)是故不得名净梵行

案。僧亮曰。不说有漏为梵行者。道品二种。为说无漏相续。至涅槃名行也

迦叶菩萨白佛言世尊(至)是故得名清净梵行

案。僧亮曰。举五识无烦恼非倒。以决之也。非男生男想者。五识取男女未了。未成烦恼。非令不取。取相是倒。能生贪嗔也

善男子若有菩萨于三十七(至)毕竟名为大般涅槃

案。僧亮曰。此九句。初七是因。后二是果也。若知因果功用差别。则知梵行也。宝亮曰。转卅七名。作九位说也。何故尔。凡夫无解。谓言位定不得作多少说也。今明法相无定故。转为九位。就九位中分。唯分定慧。遗于戒。能助生定慧。非正道体。是故不取也。分九名为四意。第一有四位。就上中下品为名也。第二有三位。据工用为名也。第三一位。就当分所除为因也。第四最后一位。标果受称也。初四就渐增进受名者。初第一念无漏。能与后解作资。故名初品无漏为根也。第二念无漏为因者。能生后力转强。故称因也。第三念无漏名受者。如三受心后。即生烦恼。今此中义亦同。既解慧稍深。转能摄生后无漏。故名为受也。第四念名增者。此无漏念念增明故。所以受增名。然后从初住以上。次第相生。讫至金刚心。地地中。皆有此四法。故知斯四。就稍稍增进受名也。次有三法就工用受名者。明品品中。尽有此三。何以知之。主名为念。能守境也。导名为定者。因念守境。于缘中静虑。而得定也。胜名为慧者。定虽能守境。令心不散。若无胜慧。或无容遣。此能除力胜故。名之为胜。若尔从初住以上。金刚以还。当地于念念之中。皆有此三义。然无别心也。智实者。此是第八法。亦应是公用。然法小异。何故尔。言实名解脱。从初住解去。当地中谈无。或不论能治。今者明其所除。据行人所得无为功德。就无缚边作语也。第九知毕者。就极处为言。据涅槃果体为旨

善男子善欲即是初发道心(至)毕竟者即大涅槃

案。僧亮曰。初发道心者。欲救众生。能发菩提。欲有三种善为道根。或说慧说信者。欲为发心之本。触是入行之始。名因缘。根有利钝。利慧在初信因缘。故说诸恶烦恼。因信求法。终断烦恼。皆是信力。至其成果。为信解脱。受时作善恶者。受苦乐受。善友说道。乐修则进。摄取道品。不乐则退。故言受时也。生诸烦恼者。释之也。求乐则生。乐即能断。因善思者。虽乐修道。要识其对治。应善思惟。宜修则修。道品日增。要须专念者。宜修勤修。念不念缘。成定之主。能为善分别。说智为最胜。心定见法名分别。究尽名智。初得为导。转明为胜。证解脱时者。证有无也。解脱者。有余涅槃也。出生死为实。毕竟者是无余涅槃也。宝亮曰。向者佛一往列名。今下去次第。更作五重来解。今第一释云。根本是欲。欲者。欲乐之心也。因名明触者。触对前理。故名明触也。摄取名受者。摄受诸行。故名受也。增名善思者。是得理之胜心也。守境不移故。称主名为念也。导名定者。摄心一缘也。胜名智慧者。谓破烦恼也。实名解脱者。则智体无累缚也。毕竟名涅槃者。据工用都满也。从善欲即是初发心者。下第二重解。从初一念无漏。讫至成佛。名之善欲。由是善欲。能得成佛。故名为根本。如来先说不放逸为本。今乃说欲者。明欲是根本。以不放逸助成故。名为缘因。若众生无所知时。依佛得解故。名佛为根本。今者众生有知。自证得之时。要因欲心也。明触者。或说为慧。或说为信。义无所在。从信得解故。解来惑遣。谓之明触也。受名摄取者。能摄生万善。众恶永消。如受后起业。道生必除也。因善思惟。得理转深。能破烦恼。故名增也。然观解治结。要赖专念。故名念为主也。得定之时。能见万法。故名为导也。于诸解之中。智慧最胜。故得胜名也。虽得四禅神通安乐。不名为实。若坏烦恼证解脱时。方是真实。故名知实也。若断除少苦。不名毕竟。要得大涅槃。无一切苦。究竟无为。方称毕竟也

复次善男子善爱念心(至)获得果报名为增长

案。僧亮曰。厌苦欲灭名善。是故名触者。灭苦须法在善友。经说道一心谛受。受则能善思惟者。受已思义道品增。白四羯磨。以戒为出家。白四得戒之本。名触。名因。二种戒者。戒为道根名摄。即是初发讫。即是相似不断。譬四品善根。下中上。下品名根。中品名因。中与下相似也。增者。讫能生相似上品。灭中品名相似。能生上上。名生相似。上上似上也。起中下为增根。即是作讫。增即可用。譬炊米为粮。炊成名因。饭时是用也。宝亮曰。下余三种。瞩文易见。然凡天执着。谓言唯真无漏。得作九名。故今处处。施此九位。高下无定。乃至十二因缘。名字亦得作此。九说既数重释竟。人由未解。故迦叶更问。前知根等三法。云何有异。佛还作数重释。此三法正上中下品。次第相生。因果用异。故得此三名也

迦叶菩萨白佛言世尊(至)乃至得称优婆夷义

案。僧亮曰。上九法说道品次第功用差别。未说行义。说十相是所行之法也。宝亮曰。第三番历十想为叹。若依此经修十想。莫问凡圣。例皆通叹。何意尔。昔教明理不周。修十想不成。依今所说。凡圣修行。悉不乖理。所以通叹十想者。谓厌离食想。世间不可乐想。死想。此三是始观。次有四想者。无常苦无我多过罪。此四是涉理观。得理小深。后余三想。离想灭想无爱想。是入圣观也。就文中。先观无常想。先观粗。后观细也。从远离常慢下。第二次修苦想也。从非我我所者。下第三次观无我想也。从智者观无我已以下。第四次观厌离食想也。从具足如是四想下。第五次修世间不可乐想也。又从有智之人。已修世间不可乐想下。第六次修死想也

迦叶菩萨言世尊云何名为(至)是则名为粗无常也

案。僧亮曰。一内。二外者。有情是内。无情是外。次观闻者。闻贤圣所说也。无车轮许者。地肥果实。家内种殖。皆悉丰足也

既观粗已次观细者(至)故受盛法复是苦

案。僧亮曰。十时者。出胎名现在。未生名未来。终不渐长者。不念念灭也。内外各二者内则饥渴。外则寒热。观坏苦也。无常器。即是行。观行苦也

善男子智者复观生即是苦(至)若一若多二俱无我

案。僧亮曰。有异和合者。说法异。和合异。和合即无性无我。无有一法。能为作者。此破作者。和合故灭者。因灭果灭。和合灭也

智者如是观无我已(至)是名成就厌离食想

案。僧亮曰。虽得无我等观。今饥则须食。寒欲得衣。故生烦恼。食生贪故。先观食也。如被剥牛者。物触则苦也。如火聚者。思愿后身。后身如火也。三百鉾者。识本乐缘。缘皆是苦也

迦叶菩萨言世尊智者观食(至)不空食于国中信施

案。僧亮曰。令与相似者。观米如虫。糗如骨末也

善男子智者具足如是四想(至)是名智者善修死想

案。僧亮曰。次修死想。无常生灭。灭已不续。名死也

智者具足如上六想(至)则得称可沙门之相

案。僧亮曰。又从若具足如上六想即七想因下。次第七修多过罪想。不复解多过罪。直作七句来释。一常修想者。常修上六想也。二乐修想者。乐修上六想也。三无嗔想者。修六想时。心都无嗔也。四无妒想者。修此六想时。心无有妒也。五善愿者。修上六想。常非誓愿也。六无慢想者。修此六想。不怀慢心也。七三昧想者。若修上六想。常求三昧也。能呵三界者。解第八远离想也。灭除三界者。解第九灭想也。不生爱著者。解第十无爱想也

尔时迦叶菩萨即于佛前(至)解脱即是大涅槃

案。宝亮曰。大段第九叹佛也

大般涅槃经集解卷第六十九大般涅槃经集解卷第七十(憍陈如品第廿五)

  释灭无常色获得常色　破外道论阇提首那第一　婆私咤第二　先尼第三　迦叶第四　富那第五

    憍陈如品第二十五

案。僧亮曰。第四流通分也。陈如是弟子之长。先受偏悟。今得圆解。委以流通。不亦宜乎。法瑶曰。说经将讫。外道悟解者众。诸人最后受悟者。故付嘱最初悟者也。又一夫靡不有初。鲜克有终。有始有卒者。其唯圣人乎。陈如最初。闻五阴无常。今最后闻常而悟也。僧宗曰。因果佛性中道。备于前矣。是以故命陈如。更定因果。说生死五阴无常佛果常也。宝亮曰。上已三重说竟今此第四。次明付嘱流通。捡付嘱之事。不似余经。既顾问阿难。并述已之德。而体为流通故。所以命篇。先对陈如。论于五众。欲以徒众仪轨戒律法用付嘱有在也。又以文辞章句。一切经藏。嘱累阿难。以深理付弘广也。智秀曰。广明义中。第二分也。重以说付传法者。名付嘱说也。寻之下文经来不尽。何以知其然。文为证也。本为付嘱。命觅阿难。阿难至。乃使度须跋。付嘱之言。遂□□。以理而推。义在可知。凡付二事。一者人。二者法。人者即是所度十外道。缘陈如年高德尊。堪为师范。所以嘱也。由阿难弘广。于传化有缘。所以说种付之。一品之中。有四意。第一说常无常法。第二明外道无沙门法。第三列外道来诣佛法。第四正破外道。道慧记曰。陈如既居上生。又先亲是外道。出家已来。为外道所伏。故命以付嘱

尔时世尊告憍陈如(至)受想行识亦复如是

案。僧亮曰。色即是缚者。说有为之过也。智秀曰。第一意。略说因果常无常也

憍陈如若有人能如是知者(至)在大众中作师子吼

案。僧亮曰。沙门婆罗门。二名皆是寂静之称。法理常定。不知则乱。知则常。静能知常与无常。则具二法。若离佛法。不偏之人。及悉皆无也。智秀曰。第二意

尔时外道有无量人(至)我若胜彼当事我

案。僧亮曰。无有静法。终无静人。身口之业皆是假称。乃因而集聚。议与诤道也

尔时多有无量外道(至)佛告王且止我自知时

案。僧亮曰。外国法。欲大论义。先白国主也。智秀曰。第三意。列外道来也

尔时众中有婆罗门(至)所得涅槃亦应无常

案。僧亮曰。外道说涅槃法异。谓不从因生。所以难佛。若从因生。不应常也。僧宗曰。难意以因无常故。果不得独常也。宝亮曰。此十邪师。盖接化有缘。现迹归降。以示大理源也。凡与外道。论议往复之法。不得款怀。要先于事中。却令其心濡然。后言理也。此一外道。计二十五谛。言性常者。是已所计世性也。此下正破外道也

瞿昙又说从因故生(至)得解。脱者云何言常

案。僧亮曰。以二道类之。第二难

瞿昙亦说色从缘生(至)是常是一遍一切处

案。僧亮曰。涅槃是阴。是无常法。离阴是审。不从因生。无因生涅槃。第三难

瞿昙亦说从因生者(至)涅槃即是常乐我净

案。僧亮曰。通难四义。第四难也

若瞿昙说亦常无常(至)佛即我身是也。是义云何

案。僧亮曰。难佛名也。谓言缘从生法。有常无常。二言非佛自说。是佛义云何耶。第五难也

佛言婆罗门如汝所说(至)法之因耶如是瞿昙

案。僧亮曰。谓世性。亦名冥初。内众生。外非众生。因常而果无常

佛言婆罗门云何作因瞿昙从性生大从大生慢

案。僧亮曰。从性生大。从大生慢者。五大慢是识也。先说二法。未是谛数明二十四法。是色非色。大论色慢摄非色。互共相生。皆是无常。性则不尔。百论云。从冥初生觉。说十一根义。次其性从此粗说。义虽不以次。大义同耳。彼觉此慢。互其辞也。僧宗曰。冥者八万劫外。冥然不见。此不改言性也。慢即我心。只计我故。起慢于前人也。宝亮曰。从性生大者。是觉也。觉万法故。言大也。从大生慢者。即是从觉。生我心也

从慢生十六法所谓地水(至)果是常者有何等过

案。僧亮曰。前云大生慢。此慢之与大。互生义。次应色香。从粗说耳。从五法生者。次第说也。色生火。声生空。香生地。味生水。触生风。或说一尘生一。或云五尘共生。一尘偏多。五知根者。火生眼。空生耳。地生鼻。水生舌。风生身。身觉触。此言触也。或言一大生。或言五大共生。一大偏多。次五业及意五大共。五大共生。是多少。亦说意根。是色法二十一法。色之差别。根本有三。三是慢之差别。皆从性生者。言小隐。应说二十四法。有何等过者。汝果无过。我果有何过耶。答初难也。宝亮曰。生十六法者。谓从我心生五微尘。从微尘生五大。从五大生十一作根也。此二十五谛。皆因世性生也

婆罗门汝等法中有二因不(至)了因者如灯照物

案。僧亮曰。作果是生。不作是了

佛言是二种因因性是一(至)即同了不不也瞿昙

案。僧亮曰。生亲了疏。因相以定。亲不可疏。疏不可亲。是因相不者。疏不生果。虽不能生果。故疏因之义。即用了不。不也瞿昙。因果相。同与不同。生因则同。了因不同也。宝亮曰。以此而言。不关论理。直是相折却耳

佛言我法虽从无常(至)乃至意法亦复如是

案。僧亮曰。从因生法。有常无常。所谓二也。二语无二者。常亦有实。无常亦实。实故无二也。曾从先旧以下。说诸佛无异语。同名无二。非谓一佛也。虽名二语。了一语者。为说有无空。上云有同说有。无同说无。俗谛辨相二语。真谛三相一语。为了直说俗。俗无定相也。云何二语了一语者。释俗有假有。俗无假无二也。真则非有非无一也。宝亮曰。三世诸佛。亦说生因所得是无常。了因所得是常

婆罗门言瞿昙善能分别(至)佛言善哉已解

案。僧亮曰。如是语义者。因二果一之义。我今未解者。解未解所譬。说四真谛讫。亦二亦一。说诸法因果。因果则无定性。着相则二。三相一也。宝亮曰。心既款伏。还请佛说法。佛直说四谛。亦二亦一已。即领解云。凡夫见有彼此苦之则。故言二。圣人观苦即空。无彼此异。知一不一。心会平等

婆罗门言世尊我今闻法(至)即于坐处得阿罗汉果

案。僧亮曰。既云理无偏悟。今既常无常。双解应成。菩萨何故。犹言得罗汉道。夫座席未尝无小乘小德小智。圣教有始终接下愚之要。故假示小道。使物心稍开。所以十师。皆悟近悟也

复有梵志姓婆私吒(至)无烦恼为涅槃耶如是梵志

案。僧亮曰。涅槃名灭。灭有二种。谓性灭。相续灭。性是灭无。故言如是也。宝亮曰。亦无所执。直捉常无常。以问佛耳

婆私吒言瞿昙世间四种(至)云何言有常乐我净

案。僧亮曰。除烦恼之无。同于已灭之无。已灭非常。何得独称常耶

佛言善男子如是涅槃(至)是故名为异相互无

案。僧亮曰。涅槃之中。毕竟不灭。亦非灭无也。宝亮曰。非三种之无。乃至有分同互无。涅槃若有。岂无常耶

婆私吒言瞿昙若以异无(至)说言涅槃常乐我净

案。僧亮曰。难意谓。若以无烦恼为无。而涅槃非无。牛形马为异。无牛亦无三。无皆无常也

佛言善男子如汝所说(至)是故得称常乐我净

案。僧亮曰。牛马互无。则无性无常。不对治无常。不得称常。涅槃对病为譬也

婆私吒言世尊如来为我(至)复当胜彼瞿昙沙门

案。僧亮曰。云何无常者。未识无常之法。不知对治之义。所以请解也

尔时众中复有梵志(至)亦如是问佛皆默然

案。僧亮曰。假名无定执之问者。常置答也。宝亮曰。欲令其先立义故。所以默然也

先尼言瞿昙若一切众生(至)瞿昙何故默然不答

案。僧亮曰。立义谓定有。不宜答也。是一。是遍是作者。以三义证有也作者是立义之本意。遍之与一。证常耳。何者。不遍则有分。不一则有数。物有分数。是无常也

佛言先尼汝说是我(至)一切智人亦如是说

案。僧亮曰。智同则说有。明说无则非智也

佛言善男子若我周遍(至)修诸善法为受天身

案。僧亮曰。生死因果。心作心受。众生皆有五道之业。一心不并起。不一时受。汝谓。我作我受。我遍五道。应一时受报也。宝亮曰。若五道有报。何为修善。以灭恶耶

先尼言瞿昙我法中我(至)修诸善法生于天上

案。僧亮曰。后云。未得道时。是作得道。则常身二故。说我二耳。我不二也

佛言善男子如汝所说(至)若作身无云何言遍

案。僧亮曰。遍者遍三世也。若先无常后常者。作身则有身。我灭则身无也

瞿昙我所立我亦在作中(至)是故我我亦遍亦常

案。僧亮曰。谓在作不失遍。在灭不失常。以舍譬身。以舍主譬我。舍烧主出。主常舍无常。何咎。宝亮曰。以世喭为证。世人亦言烧舍。不言烧主也

佛言善男子如汝说我(至)是则违背世出世法

案。僧亮曰。世间虚空是遍。常无常色非色。皆有空也。若使此我。则应遍常无常色非色。云何以人舍不遍。为譬耶

先尼言我亦不说一切众生(至)乃说一人各有一我

案。僧亮曰。外道计我。有二种。一谓共。一谓遍。而先尼不计共。而言遍也。以终始不变。为一耳。宝亮曰。救义意谓。各有一我。不伤遍也

佛言善男子若言一人(至)若不遍者是则无常

案。僧亮曰。若各有自在之主。见闻应同。如令遍者。草树亦应见闻也

先尼言瞿昙一切众生(至)佛得闻时天得应闻

案。僧亮曰。救义云。我遇法则善。遇非法则恶。不得等也

佛言善男子法与非法(至)何以故业平等故

案。宝亮曰。将欲为难。先定其法是业非业耶。答云。是业所作。言若是业作。即是同法。云何言异耶

先尼言瞿昙譬如一室(至)其明无差喻众生我

案。僧亮曰。救义云。百灯同室。明遍而炷不遍。不可以明遍。责炷亦应遍也。百人百我。我虽遍。而法非法不遍

佛言善男子汝说灯明(至)何得复以炷明为喻

案。僧亮曰。炷是明。离炷无明。汝所言法及非法。则不如是。云何以一譬异耶

善男子汝意若谓炷之与明(至)法非法我三事即一

案。僧亮曰。上受异炷之明。今说明不异炷。于汝非譬。于我是譬。何者。炷是假名。以色触为体。色即是明。明不异炷。我是假名。以二法为体。我不异二法也。宝亮曰。以即事为难。若谓炷明不相关者。现见炷大明盛。离炷无明也

先尼言瞿昙汝引灯喻(至)于我则吉于汝不吉

案。僧亮曰。外道谓。法有定性。吉则定吉。不吉则一切不吉也。佛破之云。我无定执。教汝离执也

先尼言瞿昙汝先责我(至)以是推之真是不平等

案。僧亮曰。反难云。若佛以执为非。不报为是。即不平

佛言善男子如我不平(至)同诸圣人得平等故

案。僧亮曰。生死以执着为累。我以无报为是。汝以无执为非。今破汝非。即是两吉。岂不平乎

先尼言瞿昙我常是平(至)云何言我是不平耶

案。僧亮曰。以己所计遍为平等

善男子汝亦说言当受地狱(至)何因缘故说我作耶

案。僧亮曰。我以自在为义。云何造恶不作善耶

善男子众生苦乐实从因缘(至)乃至身根亦复如是

案。僧亮曰。作从我而作者。我即无常也

汝意若谓我虽能见(至)汝立我见亦复如是

案。僧亮曰。火因花烧。非花烧也。识因眼见。非眼见也

先尼言瞿昙如人执镰(至)一切烦恼亦应如是

案。僧亮曰。镰人各异。能有所作。离眼无我。现事可验

先尼言瞿昙我有二种(至)既灭坏已终不更生

案。僧亮曰。又立苦乐之我作我。若无知时。作烦恼受苦也。知时则修道断结也

佛言善男子所言知者(至)一切畜生何故不得

案。僧亮曰。我则本来清净。不为苦缚。不应为乐。而修诸善。而求解脱。若谓不从因缘者。畜生亦应得

先尼言瞿昙若无我者(至)及有我所我作我受

案。僧亮曰。先尼三事证我。义可立极此也

先尼言瞿昙说无我我所何缘复说常乐我净

案。僧亮曰。及咨所疑也

佛言善男子我亦不说(至)我今宣说常乐我净

案。僧亮曰。先尼心乐四法。以我为常乐。若我从倒说。内外皆无。故问云。瞿昙何缘。复说常耶。今答云。灭内外入。名之为净。非求无常也。汝以内外入是常。所以是倒也

先尼言世尊唯愿大慈(至)一切烦恼先当离慢

案。僧亮曰。先尼慢重。先令离重。轻者自灭也

先尼言世尊如是如是(至)清净梵行证阿罗汉果

案。僧亮曰。虽离诸见。于诸阴中。爱心未尽。起众生想。今观诸阴。无自性。无他性。法心灭故。众生想灭

外道众中复有梵志(至)瞿昙何故默然不答

案。宝亮曰。迦叶计。身则异命。命则异身。身虽无常。其命是常。命是常故。中间所以不断也

善男子我说身命皆从因缘(至)一向而说身异命异

案。僧亮曰。一切皆从缘生。是无常法。所以言即是者。不离身有命。不离命有身也。身异命异者。身当法体。命谈始终如此

梵志言世尊唯愿为我(至)经五日已得阿罗汉果

案。僧亮曰。闻法反迷。悟道证也

外道众中复有梵志名曰富那(至)非如去非不如去

案。宝亮曰。富那计六十二见。就五阴上。计一阴作四句。四五凡二十也。如去不如去。亦如此。应三法成六十。此妄计。皆以断常为本。所以成六十二见

佛言富那我不说世间虚实(至)不得说有东西南北

案。宝亮曰。若虚怀于万法。则明识四谛。离生死系缚

富那言请说一喻唯愿听采(至)漏尽证得阿罗汉果

案。宝亮曰。便开悟也。大村譬四谛。娑罗林喻二十五有生死。夫生死是理外之法故况之外也。中有一树。喻佛昔凡夫时也。先林而生者。喻昔二十五有众生。后修十地无漏法也。足一百年者。谓十地行也。是时林主灌之以水者。过去诸佛。为己外缘。进生己善。或授之别记也。其树陈朽。下譬佛断烦恼障尽也。唯贞实在者。虚伪生死。五阴既尽。唯余神明妙本。无为法性。真实法在也。外道设譬。领悟如此。况复学者。而不仰信者耶

大般涅槃经集解卷第七十大般涅槃经集解卷第七十一

  梵志名净第六　犊子梵志第七　纳衣梵志第八　弘广婆罗门第九　阿难为魔所娆事　说阿难初为侍者缘起　为须跋陀说法

    憍陈如品下

复有梵志名曰清净(至)乃至非如去非不如去

案。僧亮曰。闻常无常。并是倒。不知倒之所由。故问也。宝亮曰。论义更无所执。直捉六十二见。来问也。佛即为说所以离六十二见之方。于是而悟罗汉道

梵志言瞿昙众生知何法故(至)是人能知常与无常

案。僧亮曰。知何法者。已知病起。次问灭病之方

梵志言世尊我已知解(至)诸漏永尽得阿罗汉果

案。僧亮曰。因在先名故也。果在后名新也

犊子梵志复作是言(至)彼若问者当随意答

案。僧亮曰。犊子以所见问佛。欲观其同异耳。外道所见不同。或说无善恶果报。或说有善恶无道。或说有道不修得。或说男得女不得。或说出家得在家不得。或说离欲。得在欲不得。二问也。宝亮曰。亦无定执也。佛所以默者。欲申己之迹。非置答之谓也

佛言犊子善哉善哉(至)平等雨于优婆塞优婆夷

案。僧亮曰。三种善不善。及十种善不善者。三是出世。十通世间也。宝亮曰。佛今答起三善离十恶。终断一切障。成圣道也

世尊若诸外道欲来出家(至)还其尸所大设供养

案。僧亮曰。四月试者。外道本异见。假服偷法。皆四月试。如其不尔。不必试也。宝亮曰。如优婆塞戒经云六月试。盖随机故。有此法耳。而犊子出家。于十五日后。方得初果者。感应之道。其事不同。着于此也

纳衣梵志复作是言(至)善不善身是义不然

案。僧亮曰。说无因果。所以作阐提者。以其谓善恶有性。不从因缘。非无善恶故也。宝亮曰。寻众生之始无源。故谓善恶皆自然也

何以故如瞿昙说因烦恼故(至)皆有自性不从因缘

案。僧亮曰。第一事。谓先后皆不可一时。以身类一切法。皆无因也。宝亮曰。先作三关难。第一定烦恼。举身之先后也

复次瞿昙坚是地性(至)自性故有非因缘生

案。僧亮曰。第二以空类五大。以五大类一切也。宝亮曰。下举七事证义也。此第一事。证各有自性也

复次瞿昙世间之法(至)云何说言从于因缘

案。僧亮曰。第三如木不由善恶。而性有曲直之用。五道性有善恶。随生处而得名也。宝亮曰。第二证以用有定。故无因缘

复次瞿昙一切众生(至)一切法中各有自性

案。僧亮曰。第四以类求物。各有性也。宝亮曰。第三证也

复次瞿昙如瞿昙说(至)生一切法以自性故

案。僧亮曰。第五以五尘非贪之因。食嗔自生也。宝亮曰。第四事也

复次瞿昙我见世人(至)各有自性不由因缘

案。僧亮曰。第六谓。若有因。不应一同。而得苦乐二果也。宝亮曰。第五事也

复次瞿昙世间小儿(至)一切诸法各有自性

案。僧亮曰。第七谓。忧喜无因也。宝亮曰。第六事

复次瞿昙世法有二(至)有自性故不从因缘

案。僧亮曰。第八是故外计。虚空有用有名。葂角无用无名也。宝亮曰。第七事也。七事悉是证自然耳

佛言善男子如汝所言(至)同五大者无有是处

案。僧亮曰。先破第二。明诸大无常。故无性也。宝亮曰。若使万法。从五大者。万法无常。五大亦应无常也

善男子汝言用处定故(至)说一切法有自性也

案。僧亮曰。答第三也。若名义有因。实亦有因也。宝亮曰。答第二也。明竹木初生。本无箭鎙之性。工匠乃成。岂非因缘耶

善男子汝言如龟陆生(至)无有自性无有一性

案。僧亮曰。答第四也。明龟若无缘。亦可入火也。宝亮曰。答第三证。皆由行业。岂得无缘耶

善男子汝言身为在先(至)何因缘故而作是难

案。僧亮曰。答第一难也。汝性亦无前后。而我因缘。亦无先后。云何为难也。宝亮曰。破三证竟。答其上所执也。且一往总非。明不应为难也

善男子一切众生身及烦恼(至)皆从因缘无有自性

案。僧亮曰。汝有一时。而无因果。我缘有一时。而有因果也。如炷之与明以下。若不见身因。便言无因者。汝亦不见瓶因。不应说泥是瓶因也。宝亮曰。正答也。云身及烦恼。一时而有。此言似不关众生之始也。正应是捉十二因缘中。识枝时语也。夫受生为体。要须备起润业润生。若但有润业。无润生爱。则不为结报。故识支之起。虽由润业。若不更起润生。则报不相续。于时。身与烦恼。得言一时而有。虽复一时。要因烦恼而有身也。若言身不在先。知无因者。现见瓶等。不无因缘也

善男子若言一切法(至)亦应如是精勤持戒

案。僧亮曰。谓汝法能生名大。若无因缘。不应说大也。宝亮曰。身先因缘。亦同此也

善男子汝言五大有定坚性(至)故不得说自性故坚

案。僧亮曰。此等有香。香属地故也。宝亮曰。重破初证也。彼以苏[萉-巴+(日/(句-口+匕))]为地。而有时同水。岂有自性耶

善男子白腊鈆锡铜铁金银(至)云何说言定名火性

案。僧亮曰。此有明色。色属火也。宝亮曰。火不定。以流时水性。动时风性。热时火性。坚时地性。亦非自性也

善男子水性名流若水冻时(至)从因缘见非无因缘

案。僧亮曰。是坚守性。故名为水。然流动性同。若动不失流守性。不名为为风耶。若动不名风以下。若湿多属水。冻时坚多应属地也。岂是从缘得名乎。宝亮曰。若冻时犹属水者。波本因风而动。应名波为风若不名波为风。亦不应冻为水也

善男子汝言非因五尘生贪(至)生贪解脱无有是处

案。僧亮曰。答第五难。非因者。正因也。贪有二因者。觉观是内因。六尘是外因。因内生外

善男子汝言具足诸根(至)无有自性皆从因缘

案。僧亮曰。答第六难。有好施而贫。悭贪而富。应与诸根同难。故先答后业果。正答根具大富。修时不兼。受报则别耳

善男子如汝所言世间小儿(至)是身因缘烦恼与业

案。僧亮曰。答第七难。若笑是自性。则应常笑。如火休热。则常热也。不答第八虚空菟角。皆置答也

梵志言世尊如其是身(至)除三界烦恼得阿罗汉果

案。僧亮曰。还请佛为说身因。闻即悟也

复有婆罗门名曰弘广(至)能发无上广大之心

案。僧亮曰。弘广晦迹。引诸无知。应弘此经。时将显迹。现所闻不远也。宝亮曰。更无所执。直作心念试佛。佛即知其所念。复过己心所见。于是即伏。故憍陈如先难己所为。佛即显其迹也

佛言止止憍陈如(至)汝今能发如是大心

案。僧亮曰。入则入涅槃。出则出生死也

尔时世尊知已即告憍陈如(至)阿难比丘今为所在

案。僧亮曰。经之流通有二人。自上弘广所持须跋以下。应付嘱阿难也。后文似尔。亦可理付弘广。而文付阿难。宝亮曰。此下去。正显流通之意也。问阿难所在。有三缘。一欲显阿难。有八不思议之德。二为流通经。三为名须跋故

憍陈如言世尊阿难比丘(至)不来至此大众之中

案。僧亮曰。魔欲使佛法。无所付嘱灭不流传故。恼乱阿难也。宝亮曰。所以是表阿难之德。虽不在坐。而能受持

尔时文殊师利菩萨摩诃萨(至)问憍陈如阿难所在

案。僧亮曰。欲显阿难德故。所以发问

尔时世尊告文殊师利(至)若佛听者谓往给侍

案。僧亮曰。明阿难有二事。一是亲属。人所敬信。二受持佛语。无有漏失也

文殊师利阿难事我(至)八者具足从闻生智

案。僧亮曰。叙阿难有三意。第一叙进止所为。有八不思议之德。必堪弘通。第二引证。明七佛弟子。有八德者。皆通使流通。第三正释文殊问

文殊师利毗婆尸佛侍者(至)阿难比丘为多闻藏

案。僧亮曰。第二引七佛为例也

善男子如汝所说此大众中(至)阿难所闻自能宣通

案。僧亮曰。第三正答问也

文殊师利阿难比丘(至)至心礼敬却住一面

案。宝亮曰。时将欲至。命文殊以咒解魔。召阿难还也

佛告阿难是娑罗林外(至)与须跋陀还至佛所

案。僧亮曰。习未尽者。乃伏欲界结。未伏习也

时须跋陀到已问讯(至)即得涅槃是义云何

案。僧亮曰。慢人不欲自受屈。故假称外。明得失在彼。不在于我也。宝亮曰。须跋所执。现在苦乐。尽是过去。不因现在。故受投岩赴火。令苦尽也

佛言善男子有沙门(至)是故我今责汝过去业

案。僧亮曰。恐传者之谬所定也

彼人若言瞿昙我实不知(至)唯过去业非现在耶

案。僧亮曰。下苦因缘得中上苦不者。问得展转用不耶。若言得者。是则不定。云何定言断过去业耶

复应问言是现在苦(至)过去已尽云何有苦

案。僧亮曰。若过去有苦。应与业俱尽。不应重受也。宝亮曰。若现在苦行。能断过去业者。此苦行业。复用何断耶

仁者如是苦行能令乐业(至)是事不然何以故仁者

案。僧亮曰。次问转无苦乐。四禅以上业。无漏无报。何因缘受是苦行者。既不能坏。又不能转。何故受耶

譬如有人为王除怨(至)过去本业受苦乐也

案。僧亮曰。证有现报也。不必尽因过去业也

仁者若以断业因缘力故(至)心喻于林身喻于树

案。僧亮曰。偿不可毕。遮则不受也。若以受苦为偿者。畜生应得道也。先当调心者。身喻于树。林多而树少。四阴譬林。色阴譬树。怖从心生。不从色也

须跋陀言世尊我已先调伏(至)受于恶身况其余者

案。宝亮曰。佛呵之已。能除粗想。何不血除细想耶

世尊云何能断一切诸有(至)上智观故得无上菩提

案。僧亮曰。有假空实空。而外道伏结。缘有不缘空。缘空是实想也。宝亮曰。唯有二谛。忘相为实想。实以慧断烦恼。作想名说。此其旨也

说是法时十千菩萨(至)须跋陀罗得阿罗汉果

案。宝亮曰。得一生实想者。正一生后得佛也。若是无明住地报。则不可以一生二生往格也。乃约应而辨耳。若寻余经比例。便是未尽。此土无缘。立以不悉来也

大般涅槃经集解卷第七十一(终)

观应二年(辛卯)卯月十日。于大和州大御轮寺。点写之了

自观应元年九月二十四日。至同二年四月十日。一部七十一卷。为每年讲赞本。一笔点之了。偏为奉助兴正菩萨御愿而已

    大御轮寺金刚资　圆宗(生年六十五度以四十五)


大般涅槃经玄义

    No. 1765 [cf. Nos. 375, 1766, 1767]

大般涅槃经玄义卷上

        隋天台沙门灌顶撰

夫正道幽寂无始无终。妙理虚玄非新非故。无始而言其始者。谓之无明生死。无终而语其终者。即是种智涅槃。无明生死本自有之名之为故。种智涅槃修因方克目之为新。此经乃于非始之始。分别佛性三因之殊。还就无终之终。辨于涅槃三德极果之别。若佛性之因非因。涅槃之果非果。是则因如不异果如。果如不异因如。若因如不异果如。非止涅槃之如非新。佛性之如亦复非新。若果如不异因如。非止佛性之如非故。涅槃之如亦复非故。是则佛性涅槃因果之如。皆是非新非故。非新非故之理即是法身。非新而新之果即是摩诃般若。既有非新而新种智之圆极。则非故之故无明生死患累究竟斯亡目之解脱。此则三德之义宛然。不纵不横妙等伊字。但众生利钝不同。是以大圣赴缘之教亦有顿渐之别。顿则譬于忍辱之草牛食即得醍醐。渐则五味阶级次第圆满。或有不定根缘为赴此机所说教门非顿非渐。喻之置毒于乳也。皆是能仁妙穷权实巧赴根缘。化他利物罄无乖爽。今此大经为欲开通往昔教门。显发如来方便密义故。于娑罗双树大师子吼。师子吼者名决定说。决定说者说一切众生悉有佛性如来毕竟不入涅槃。不入涅槃即是入于无上大乘大般涅槃。此经若具依梵本。应云摩诃般涅槃那修多罗。摩诃言大般涅槃那此翻灭度。释此三字具依两义一别二通。第一别释者大即法身。故此经云。所言大者其性广博犹若虚空。其性即法性法性即法身也。灭者即是解脱。解脱二种。烦恼生死永灭。免斯因果患累即解脱义也。所言度者即是摩诃般若。故大论云。信为能入智为能度。当知别以三字标今经之目。即是三德之异名也。第二通释。大者谓大法身大般若大解脱也。灭者即是三德皆寂灭也。度者即是三德皆究竟圆满也。故通以三字标名表三德。皆大寂灭究竟也。别通之义虽殊。然并是用非果之果无上秘密之极果。以标一教之首也。修多罗即是圣教之总名。有翻无翻事在别释。若具依梵本。应言摩诃般涅槃那。今翻为大灭度。大若虚空不因小相。又其性广博多所容受。又名不可思议诸佛之法界。是为三义释大也。灭者灭二十五有及虚伪物。又得二十五三昧种种示现。又生灭灭已。寂灭为乐。是为三义释灭也。度者度于不度。又度于度。又度此彼之彼岸。亦度非彼非此之彼岸。譬如神龟水陆俱度。是为三义释度也。总揽三法三目三点名大般涅槃。金刚宝藏满足无缺。不纵不横不并不别微妙秘密以当其体。常住不变恒安清凉不老不死以当其宗。置毒佛性遍五味中味味杀人。震大毒鼓虽无心欲闻闻之皆死。八大自在我以当其用。常住二字无上醍醐与诸典别决定之吼以当其教。名含体摄常宗毒用极教之相也

玄义开为五重

  一释名　二释体　三释宗　四释用　五释教

释名又五。谓翻通无假绝。翻者四说。谓无有亦有亦无非有非无。初言无者。天竺五处不同。东南中三方奢切小殊。西北两处大异。如言摩诃。摩醯。泥曰。泥洹。此则三方。如言洹隶槃那。般涅槃那。此则二方。类如此间楚夏耳。有人以泥曰目双卷。泥洹目六卷。涅槃目大本。是义皆不然。双卷明八十无常。六卷明金刚不毁。岂可以方言简义。毗婆沙云涅槃那。今经无那字。盖译人存略耳。肇论以摩诃涅槃。为彼土正音。古今承用。其各说者凡有五家。一广州大亮云。一名含众名。译家所以不翻。正在此也。名下之义。可作异释。如言大者。莫先为义。一切诸法莫先于此。又大常也。又大是神通之极号。常乐之都名。故不可翻也。二云名字是色声之法。不可一名累书众名一义叠说众义。所以不可翻也。三云。名是义上之名。义是名下之义。名既是一。义岂可多。但一名而多训。例如此间息字。或训子息。或训长息。或训止住之息。或训暂时消息。或训报示消息。若据一失诸。故不可翻。四云。一名多义如先陀婆一名四实。关涉处多不可翻也。五云秖先陀婆一语随时各用。智臣善解契会王心。涅槃亦尔。初出言涅槃。涅槃即生也。将逝言涅槃。涅槃即灭也。但此无密语翻彼密义。故言无翻也。二云有翻者。梁武云。佛具四等随其类音溥告众生。若不可翻此土便应隔化。四等亦是不遍。引释论般若尊重智慧轻薄。既得以轻代重。何得不以真丹。单别翻天竺兼含。既可得翻且举十家。一竺道生。时人呼为涅槃圣。翻为灭。引文云。闻佛唱灭悲哀请住。魔王所以劝令速灭(云云)。二庄严大斌。翻为寂灭。引文云。生灭灭已寂灭为乐。前家止灭于生。后家灭生复灭于灭。故言寂灭(云云)。三白马爱。翻为秘藏。引文云。皆悉安住秘密藏中(云云)。四长干影。翻为安乐。引文云。如人病差名为安乐。安乐名涅槃。五定林柔。翻为无累解脱。既无创疣即无累也。六太昌宗。翻为解脱。引四相品云。涅槃名解脱。迦叶品云。慈悲即真解脱。解脱即大涅槃。七梁武。翻为不生。引文云。断烦恼者。不名涅槃。不生烦恼乃名涅槃。八肇论。云无为亦云灭度。九会稽基。偏用无为一义为翻也。十开善光宅。同用灭度。引文云。大觉世尊将欲涅槃。引六卷云。大牟尼尊今当灭度。彼此两存正是翻也。例大本称娑罗双树。六卷云坚固林。又引法华长行云。中夜当入涅槃。后偈云佛此夜灭度。又引华严云。古来今佛无般涅槃。除化众生方便灭度。又引遗教。佛临涅槃略说教诫。又云。时将欲过我欲灭度。是为十家明有翻也。三明亦可翻亦不可翻者。睿师云。秦言谬者定之以方册。梵音不可变者即而书之。匠者之公谨受者之重慎。今经翻摩诃为大。般涅槃三字存梵音。是则一字可翻三字不可翻。梵汉双题正应在此。四云大名不可思议。故非可翻非不可翻。今明。汉人多不晓梵即有众说。莫知孰是。世既咸用开善未能异之。今虽同其翻不用其义。同翻者摩诃此翻为大。般涅此翻为灭。槃那此翻为度。是为大灭度也。有翻无翻四家竟。次出开善四解。一云。灭据法度据人。生死之法灭已还无。生死之人转而作佛。二云灭名目无。灭有还无故。度名目有。从此至彼故。实法道边人法俱灭。相续道中人法俱度。三云。灭是有余度是无余。有余涅槃既未究竟止可是灭。无余永免方得是度。四云。灭是本有今无之义。而加之以度者是永免之名。欲明凡夫之死亦得是灭而非永免不得称度。观师难初解云。若生死之法灭无。生死之人附何而度。若生死假人转得成佛。生死之法何不转为涅槃。今研初解是何等义。若依声闻法者。三果生死未并灭假人不永度。若第四果凡法因虽灭凡法果未灭。假人犹未度。若灰身灭智假法俱寂。寂则不论度。又不得作佛。若菩萨法者。凡法都不灭假人又不度。是谁法灭何等人度。如此往推非三藏义也。若依声闻菩萨共法者。三乘之人同以无言说道断烦恼入第一义。即体生死法是涅槃法不论灭与不灭。即生死人是涅槃人。不论度与不度。既无法可灭何用以灭目之。既无人可度用度目谁。如此推之则非通教义也。若独菩萨法非但灭生死之伪法。亦灭涅槃之真法。非但度生死之凡人。亦度出世之圣人。彼师言不涉真法语不论圣人。以此往推非别教义也。若就佛法者。灭之与度。不纵不横无二无别。彼师分灭异度离法论人。如此往推非圆教义也。既非小。非共。非菩萨。非佛。并非先圣之法言。则不敢道也(云云)。今研第二解。若以灭目无以度目有者。若受此有无。犹是苦谛。执此有无犹是集谛。修此有无犹是道谛。尽此有无犹是灭谛。灭谛之真尚不可以有无名之。云何以有无名大涅槃。如此往推非三藏真义。若以灭目无以度目有。若双目生死生死本自不然。今则无灭。生死既无灭以灭目谁。生死本自不然那得是有。非有则无度法亦无度者。度复目谁。既不可以灭度目于生死。云何以灭度目于涅槃。疆以疣赘累彼虚空。以此推之非是声闻菩萨共法。若以灭目无以度目有者。此以名召法以法应名。名物尚存为见所缚。云何以见义释大涅槃。若以灭目无门以度目有门者。为目小门。为目大门。小门能通拙所通伪。贫住化城久已被弃。云何以拙能通释大涅槃。若以灭目无以度目有。明真俗二谛者。此是偏邪二边。云何以二边释中道大涅槃。如此往推则非菩萨法也。若以灭目无。以度目有。有不关无。无不关有。灭非是度。度异于灭。纵横狼藉。劫掠群牛不解钻摇。浆犹难得况酥醍醐。如此往推则非佛法。既非小乘。非共乘。非菩萨乘。非佛乘。是何等义邪(云云)。今研第三解。若有余涅槃既未究竟止可是灭。无余永免方得称度者。亦应灭度。四住非是究竟灭度。尘沙方得称度。又灭度尘沙亦非究竟。灭度无明。方得称度。又灭度无明亦非究竟灭度。究竟灭度方得称度。以后望前前非究竟。第二第三亦非究竟。何得以初番灭度释大涅槃(云云)。今研第四解。凡夫已有还无得是灭。亦应凡夫从此至彼便应是度。若凡夫非度凡夫亦复非灭。若圣人已有还无亦得是灭。圣人从此至彼复应是度。若凡圣俱度俱灭若为论异。若同凡圣则近陜非高广。若异凡圣亦非高广。非高故则非无上。非广故则有边涯。云何以此释大涅槃。若具研四解。应作四四十六番。今但十番而已。余皆可知。明哲自解何俟多言。时人以开善为长故薳研之。余人置而不言耳。翻名已如前说。释其大义者。大有三义。一理大。二智大。三用大。释论谓大多胜。大取包广。多取含摄。胜取秀出。今言。法身法界遍一切处。是广大义。报身智境照发相应不可穷尽。是含摄义。应身自在无能遏绝。是胜出义。于一大字三法具足不纵不横不可思议。名秘密藏。秘密藏者即大涅槃。释般涅为灭。灭有三义。谓性灭圆灭方便灭。性灭者理性至寂非生非起。生起不能喧动故名性灭。圆灭者。照无不遍。发无不足。明穷境极故名圆灭。方便灭者。权巧妙能。逗必会取必克故名方便灭。如是三灭即三解脱。无缚无脱。是性净解脱。因果毕竟。是圆净解脱。巧顺机宜无染无累。是方便净解脱。于一灭字三脱具足不纵不横不可思议。故名三点。三点者即大涅槃。释槃那为度。度有三义。谓实相究竟度。智究竟度。事究竟度。实相度者。诸佛之师也。非此非彼亦非中流。非能非所无始无终故名实相度。佛师度故诸佛亦度。论云。智度大道佛善来。智度大海佛穷底。即其义也。智度者如如智称如如境。函大盖大照发相应故名智度。论云。智度相义佛无碍。即其义也。事度者自度度他。彼我利益无不究竟。慈悲誓愿一切周悉故名事度。如此三度即三般若。实相般若是一切种智与诸佛同体。观照般若即一切智与诸佛同意。文字般若即道种智与诸佛同事。于一度字三智具足不纵不横不可思议。故名面上三目。三目者即大涅槃。今作三番九义。浅深别异各各不同者。虽复多含摄胜未是今经正意。文云。法身亦非。那可单作三身释大。文云。解脱亦非。那可单作三脱释灭。文云。般若亦非。那可单作三智释度。故知单释非今经意。意者文云。三法具足名大般涅槃。三法即三智三智即三点。三法即九法九法即三法。三法即九法是不纵。九法即三法是不横。不并不别亦复如是。不三而三不一而一所以名秘密藏。摄一切法悉入其中。是诸佛体。是诸佛师都名总号。乃为具足称大涅槃。意在此耳。一智三智三智一智。所以名一面三目。涅槃亦耳。一脱三脱三脱一脱。所以名为伊字三点。涅槃亦尔。体意及事。不得相离不得相混。不可言言不可思思故名大涅槃。二释通名者。涅槃之名遍布诸处。安乐一意亘十法界皆称安乐。梵行品云。寒地狱中若遇热风以之为乐。热地狱中若遇寒风以之为乐。如是安乐亦名涅槃。猕猴得酒则能起舞腾枝跃树。秋水卒至河伯欣然鱼鳖噞喁歕沫戏沼。如是安乐亦名涅槃。饿鬼饥渴得水食饱满则得安乐。如是安乐亦名涅槃。修罗怖畏得归依处则得安乐。如是安乐亦名涅槃。如贫得藏如病得差。则得安乐。如是安乐亦名涅槃。檀提婆罗门。饱食抚腹。我今此身即是涅槃。此计欲界果报法为涅槃。阿罗罗仙得无想定。此计色界法为涅槃。郁头蓝弗得非想定。此计无色界法为涅槃。文云。断欲界结则得安乐。乃至断无色界结则得安乐。如是安乐亦名涅槃。此多用善因为涅槃也。若三十三天常乐我净用善果为涅槃也。若修二乘者。多贪欲人得不净观则得安乐。如是安乐亦名涅槃。乃至数息慈心念佛因缘亦如是。此计二乘方便法为涅槃也。若断三界烦恼。八万六万。四万二万。一万住处。则得安乐。如是安乐亦名涅槃。此计二乘果法为涅槃也。释论云。菩萨从初发心。常观涅槃行道。初心菩萨亦名涅槃。此文云。十住菩萨虽见不了了亦名涅槃。诸佛法王圣主住处。乃得名为大般涅槃也。涅槃之名随情逐事浩荡若此。盖是通名也。达摩郁多罗翻此法胜。解云。烦恼灭名有余涅槃。引经云。灭诸烦恼名为涅槃。离于生死名无余涅槃。引经云。离诸有者。乃名涅槃。此就所灭。释二种涅槃也。二乘所得二涅槃。若于如来皆是有余。唯佛乃是无余。引胜鬘云。二乘是有余如来是无余。昔灭是尽今灭非尽。经云。不应生灭尽想。涅槃非灭。非灭故常也。若依郁多之解。乃是通涅槃。今昔相对一涂之说。若擘肌分理义则不然。何者二乘有余无余。所灭则异真谛则同。若于如来皆是有余。唯佛是无余者。若尔二乘既是有余涅槃。子缚断破无明。入菩萨位见佛性。生死身谢即应同佛入无余涅槃。何事被诃言非。不断烦恼。不到彼岸破除草庵。若此等皆无分者云何对佛是有余涅槃。又若二乘有余无余对佛而得是有余涅槃者。自地狱已上至菩萨已还例应如此。若诸涅槃皆不可得然。二乘安是。故知郁多罗之说不可依也。问安乐之名通十法界。佛性四德名复云何。答经云。一切诸法中悉有安乐性。一切众生悉有佛性。岂非佛性通耶。文云。二十五有有我不耶。答言有我。寱言刀刀。又杨树黄叶等岂非四德通耶。然名乃该通义不得混。应作三番四句料拣。初四句。谓通别亦通亦别非通非别。通者如向说。别者各有所以。六道以安身适性为安乐。犹起烦恼恶因。招生死苦果。安乐义不成。要断烦恼使苦乐不复随身忧喜不复随心。得有余无余灰身灭智。隔别生死入于涅槃者则与六道别也。菩萨从初心为一切众生观涅槃行道。望二乘是别望佛犹通。即是亦通亦别也。诸佛究竟大般涅槃。非六道之通非二乘之别。即非通非别之安乐也。又安乐之名。或是病非药或是药非病。或亦药亦病或非病非药。是病者长者没已。劫掠群牛[穀-禾+牛]乳自食。浆酪醍醐一切皆失。如来去后钞窃正法常乐之名。如虫食木偶得成字不识是非。广起颠倒沉沦生死。随其流处有种种名。或辛或酸。故知三界四倒但是病而非药。为治此病说四非常倒泻斯病。病去惑尽名入涅槃。文云。三种病中无三种药。三种药中无三种病。此小涅槃但药而非病。虽复病去而药不亡。还执此药而复成病。文云。其后不久王复得病。当知四非常亦药亦病也。治此病故还用常乐我净而倒泻之。故斥无常病说于新伊。是胜三修不同凡夫之倒病。不同二乘之偏药故名非药非病。又新伊但是药而非病。正法正性非药非病之安乐也。又小而非大大而非小。亦小亦大非小非大。小者二乘也。虽断烦恼犹有习气。我身我衣我去我来。谓佛与己等。唯有常净无有我乐。三宝差别则是习气。所以为小也。云何名大。诸佛如来竖出九界横收一切。无边底故常。大丈夫故常。能化度一切故常。不可思议故常。具八自在故我。断苦乐故乐。大寂故乐。一切知故乐。身常故乐。有大净故。业净身净心净。是故名为大涅槃。菩萨望下为亦大。望上为亦小。凡夫六道不断通惑故非小。无四德故非大。例前应就理为非小非大。互显令易解耳。前一番从地狱已上料拣。次一番从外道已上料拣。次一番从二乘已上料拣。问如此料拣六道二乘既非安乐。何故强说为涅槃耶。答通有四悉檀因缘故则作通说。云何更别问耶。所以作通说者为悦众生故。引导生善故。破坏诸恶故。显昔第一义故。通说无咎。又佛常依三谛说法。依俗故说六道安乐。依真故说二乘安乐。依中故说佛菩萨安乐。又不离俗而有真中。尚得即俗即真即中。何意不得六道说通安乐是涅槃耶。龙树云。因缘所生法。即空即假即中。是其义也。三释无名者。先出旧解。一云。真如实际等是真谛名。佛果涅槃常乐我净等是俗谛名。而言涅槃无名者。无生死患累之名而有美妙之名也。引互无为证。涅槃无生死之名。生死无涅槃之名耳。二云。真谛涅槃俱无名无相。名相所不及。言语道断心行处灭。引肇论江河竞注而不流。日月历天而不周。岂有名于其间哉。三云。真谛无名。佛果涅槃虽复冥真。犹是续待二假。故涅槃不得无名也。初家。真俗俱有名。第二家。真俗俱无名。第三家。真无名俗有名。应更有第四家。执真有名俗无名未见执者。若定执此堕四倒见。若以四为方便正是三藏四门。何者若引互无。有美妙之名者。断奠是三藏有门。能通是有所通是非有。何得用小乘能通释大涅槃所通。指荒涂为宝所。认鱼目是明珠。大无所以。若言真谛涅槃皆无名者。秖是三藏空门。若言真谛无名佛果涅槃犹是续待二假者。秖是三藏亦有亦无门。复应有计非有非无门者。未见其人也。然三藏涅槃。既非数法。尚不是一何得有四。四者能通之门耳。不可以能通为所通。纵令跨节是通教四门者。亦不可以通教能通为通教所通何得以共能通。释别所通。又跨节为别教能通者。亦不得以别能通为别所通。那得以别能通释圆所通。将此望之节节无意窈然大远。故不用此无名释大涅槃(云云)。问古来传译什师命世。升堂入室一肇而已。肇作涅槃无名论其词虚豁洋洋满耳。世人玩味卷不释手意复云何。答高僧盛德日月在怀。既不亲承其门难见。钻仰遗文管窥而已。观其旨趣不出四句。其论云。有余无余涅槃者。良是出处之异号应物之假名。若无圣人知无者谁。若无圣人谁与道游。即其有句也。寂寥虚豁不可以形名得。微妙无相不可以有心知。岂有名于其间哉。即其无句也。果有其所以不有。故不可得而有。有其所以不无。故不可得而无耳。恍忽窈冥其中有精。本之有境则五阴永灭。推之无乡则幽灵不竭。即其亦有亦无句也。然则有无绝于内。称谓沦于外。视听之所不暨。四空之所昏昧。而欲以有无题牓标其方域者。不亦邈哉。即其非有非无句也。然其作论谈大意不在小。不可谓是三藏四句也。文云。超度有流言不涉界外之流。大患永灭不灭涅槃之患。故不可谓是别圆四句也。辨差中云。三车出于火宅。俱出生死。无为一也。此以三三于无。非无有三。如来结习都尽。声闻结尽习不尽。尽者去尺无尺。去寸无寸。修短在于尺寸。不在无也。智鉴有浅深德行有厚薄。虽俱至彼岸而升降不同。彼岸岂异。异自我耳。以此推之归宗指极。在于三人同以无言说道断烦恼入涅槃。文义孱然何可隐讳。故知是通教四句也。夫通教诠理非有非数。而以有无四句为通道之门。若执门求所通。其失一也。又通教体法之观非如来本怀随自意语。乃是俯提枝末随他意语。故婴儿行云。不知苦乐昼夜亲疏等相。不能造作大小诸事名曰婴儿。不知苦乐是泯忧喜。不知昼夜是齐明暗。不知亲疏是等憎爱。不作大小是亡巨细。三人同学体观。喻之以婴儿。俱证无为喻之以入水。论其智德喻之以三兽。论其断德喻之以灰断。宗在他经要非此典。那忽将彼释。此其失二也。又法华教起已破化城。一切诸菩萨。疑网悉已除。千二百罗汉。悉亦当作佛。佛开通教。方便之门示真实相。云何迫欣三兽更建草庵。其失三也。又聋瞆之徒不在法华席者。于哀叹品中更为分别。汝先所修。悉是颠倒。我先所说亦非实语。斥故显新指劣明胜。云何违经波动水浪握捉瓦砾持作月形。其失四也。然纲维既阙网目安寄。执佛法之遗弃谓是真实。徒施于十演终非三德明矣。今言涅槃无名。涅槃者指三德涅槃也。无名者无六道安乐之名也。又无三藏有门见有得道。获有余无余涅槃之名。亦无见空得道。亦无亦空亦有得道。亦无非空非有得道。获有余无余涅槃之名也。又无三乘共行十地有门得道。获有余无余涅槃之名也。亦无空门。亦空亦有门。非空非有门得道。获有余无余涅槃之名也。又无别教有门得道常住涅槃之名也。亦无空门。亦空亦有门。非空非有门得道。获常住涅槃之名也。无如是等诸方便之名。从所离故。故言无名。从所得故。故言涅槃。此即圆教有门之意也。又非离诸名外。别一涅槃。即诸名无名。便是涅槃。故言涅槃无名。此圆教空门意也。又从所离故。故言无名。从能离故。故言涅槃。能所合称。故言涅槃无名。此圆教亦空亦有门意也。若有能所则大有名。何谓无名。今无能所称为涅槃无名。此是圆教非有非无门意也。门虽有四。涅槃非四也(云云)。无名之意。超度尔许诸涅槃名。然后乃显圆当四门大般涅槃。诸师都未尝分别一两节目。即道无名。无何等名。名曰无名。疑误后生今所不用也。故梵行品云。无缘慈者。不缘众生亦不缘法缘。于如来故名无缘。今亦例此无六道之名无四圣之名。而有秘藏涅槃之名故言。涅槃无名也。四释假名者。德王初云。涅槃非名非相。云何而言可得见闻。不可见故无相。不可闻故无名。佛以佛眼佛耳尚不见闻。况复下地及与凡夫而能见闻。大悲方便动树训风举扇喻月。能令机缘而得见闻。其见闻者实无见闻而言见闻。迦叶品云。涅槃一名有无量名。亦名无生无出。乃至亦名甘露亦名吉祥。凡列二十五种示其无量。悉为众生而假施设。文云。如坻罗婆夷名为食油。实不食油无有因缘。强为立名名为食油。如经广说。涅槃亦尔。无有因缘强为立名名为涅槃。智度云。名假施设。受假施设。法假施设。实非色心而言色心。是法假施设。于色心上更设五阴十二入十八界等是受假施设。于阴入界上。更立张王李赵等是名假施设。亦如揽色香味触是法假施设。于四微上。更作根茎枝叶等是受假施设。根茎之上更立枫栴柹柏等名是名假施设。是大涅槃亦复如是。强指此实法名为佛师。是佛秘藏是法假施设。于佛师上更复分别法身般若解脱三点是受假施设。于三点上更立名字大般涅槃是名假施设。或复呼为洲渚窟宅。或复呼为乳糜妙味。或复呼为醍醐上药。或复呼为一阐提。或复呼为一破戒明镜。譬说虚空不可得无障碍如是岂非名假施设。当知从地狱已上。至佛已还皆言安乐者悉假名也。大论云。众生无上者佛是。法无上者涅槃是。所以设此假名者。欲令众生知名非名。名不在内亦不在外。亦不在中间亦不常自有。大品云。菩萨菩萨但有字。佛佛但有字。是字不住。亦不不住。是字无所有故。涅槃亦尔。涅槃不在法身。文云。法身亦非。又涅槃不在般若。文云。般若亦非。又涅槃不在解脱。文云。解脱亦非。三德中各各求皆不可得。三法合求亦不可得。故智度云。若人见般若是则为被缚。若不见般若。是亦为被缚。若人见般若。是为得解脱。若不见般若是亦得解脱。法身解脱亦如是。譬如幻化物不可见而见。见而不可见。是事为希有。此经名为微妙不可思议。但假名字名此三身为秘密藏涅槃。但假名字。名此三般若。为摩醯三目涅槃。但假名字名三解脱名三点涅槃。但假名字具足三法名大涅槃。但假名字引导众生。譬如空拳。为喜小儿。为引小儿。为止啼儿。为教黠儿。其事办已。散指舒拳拳无拳矣。涅槃亦尔。以新伊悦之。以新伊引进之。以新伊破之。以新伊悟之。是为假名四种利益。得利益已。宁复执名而起诤乎。假立有名既尔。假立无名。假立亦有亦无名。假立非有非无名亦如是(云云)。应说将跨来因缘(云云)。又如治噎法(云云)。五释绝名者。有人以无释绝。亡有而存无。无则不绝。非今所用。有人以离释绝。言涅槃之中无有诸有。此尚非小乘义。亦所不用。有人以灭释绝。言灭诸烦恼。悉无所有犹如火灭。存于涅槃者。经称是邪解邪难。此岂可用耶。有人引经云。如大香象顿绝羁锁自恣而去。将此释绝者。此乃三修比丘。偏叹菩萨所绝一边。义未具足。同上无名之意非今绝名也。若言语相逐对无说有。乃至对有无说非有非无等。待对不息言则不绝。若以心分别。介尔动念心起想即痴。心亦不绝。心既不绝言那得绝。若知心是攀缘三界。攀缘三界生灭是无常苦空无我。息此攀缘心无所得。心绝故其言亦绝。此乃修习言语道断心行处灭。非真绝也。若入见谛苦忍明发世谛死时名生不生。身子云。吾闻解脱之中。无有言说。亦是解脱之中无有分别。此则真证言语道断心行处灭。盖三藏绝意。指此一绝凡绝几许人法况复余耶。然入真时绝出观不绝。何者。真俗异故。一绝一不绝待对宛然。云何名绝。若能道远乎哉。即事而真。圣远乎哉体之即神。见色与盲等。闻声与响等。其说法者无说无示。其分别者无所分别。无绝无不绝而名为绝。此亦方便道中。言语道断心行处灭。若空慧相应入第一义。豁然清净无能绝无所绝。无绝者无绝法。此通教绝名意也。此虽冥真未冥中。虽断通未断别。净名云。结习未尽。华则着身。下文云。无明未吐。回转日月。如疟病者。对界内说界外。想通惑对别惑是则不绝。若能以大涅槃心修行五行具十功德。是时一向专求大涅槃行。无复界内之心。无复界内之说。如是方便。亦名言语道断心行处灭。而未是冥中。若发中道所得功德不与声闻辟支佛共。昔所不得而今得之。昔所不绝而今绝之。盖是别教绝名意也。然证绝之时乃同圆极。而修时梯蹬江河回曲。何者。发心不能遍法界。故法界外更有法故不名绝法。拙行不能行一行是如来行。如来行外更有行故不名绝行。非无上方便。方便上更有方便非绝方便。若圆发心观大涅槃诸心法界。法界外更无复法界。独一法界故称绝法界。又如经复有一行是如来行。如来行外更无复行故名独绝行。又如经正直舍方便但说无上道。尼俱耶洲直入西海犹如直绳。是绝方便。绝方便绝者。如经断绝一切疑网心。故名为解脱。三藏四门即是法界。即如来行即上方便。何者。生死即是涅槃。况声闻法生决定心宁起疑网。通教四门亦即法界。共乘疑网断故。别教四门即是法界。菩萨乘疑网断故。是名断绝一切疑网之心。名独绝解脱。唯说一法界不说余法界。唯思一法界不思余法界。是为方便道中。言语道断心行处灭。是圆方便亦有四门。若谓一切法绝是法界唯一法界。此约有门绝名也。若谓法界尚无法界宁有其余。此约空门绝名也。若谓法界微妙一法即三法三法即一法。此就亦有亦无门绝名也。若谓法界不可思议。此就非有非无门绝名也。此皆方便道。若谓开示悟入如以金鎞抉其眼膜。二指三指。了了分明。是名究竟绝言。言满法界而无一言。心满法界而无一念。是为圆教绝名意也。然诸经绝名其旨非一。华严云。如执虚空风如画虚空中。说之已自难何况以示人。净名云。诸法不相待一念不住故。又诸菩萨言于言。文殊言无言。净名杜口绝言。善吉云。我无所说不觉不得。龙树云。若法为待成。是法还成待。今则无因待。亦无所成法。今经云。譬如虚空不因小空名为大也。涅槃亦尔。不因小相名大涅槃。云何小相。从二乘所证乃至生死安乐皆是小相。不因此小而名大也。又云。譬如有法不可称量不可思议。乃名为大。涅槃亦尔。不可称量不可思议。故名为大。当知绝名涅槃其义显矣。斯文甚多。逗缘亦异不可一概。今以四句料拣。谓不绝绝。非绝非不绝。绝绝。云何不绝。如前六道安乐等。云何为绝。如三藏通共等。云何非绝非不绝。如别四门等。云何绝绝。圆四门是也。云何绝绝。绝能绝所。故言绝绝。从别教四门已下名为所绝。从圆教四门名为能绝。以能绝绝所绝。能绝亦绝。如前火木然于草已亦复自然。当知。绝名与无名为异。义在此也。故言绝绝。次总结释名一章开为五重。都是圆教四门意也。若大涅槃名真善妙有。本自有之非适今也。此是有门义。故作翻名同名释之。若大涅槃空迦毗罗城空此是空门义。故作无名释之。若大涅槃亦色非色。此是亦空亦有门义。故作假名释之。若大涅槃名为中道遮二边故。此即非空非有门义。故作绝名释之。夫大涅槃者。尚非是一。云何为四。四者门也。门以标理。有种种名。如天帝释有千种名。解脱亦尔。多诸名字。名字功德品云。涅槃是名其余称叹是则为字。若尔涅槃是总。而当机立之为名。三点等及余一切皆属于字。若法身当机是总已复为名。涅槃及一切物已复属字。若尔更互无定。虽复无定今既定以涅槃为名。若定不定若总若别皆无待对。悉是不可思议。悉是大绝。故名绝大涅槃也

第二释涅槃体。先出旧解。庄严云。佛果涅槃出二谛外非真俗摄。凡夫以惑因感果是浮虚世谛。假体即空故是真谛。佛果非惑因所感故非世谛。不可复空故非真谛。引仁王经云。超度世谛第一义谛。住第十一萨云若地也。开善云。佛果涅槃还为二谛所摄。体是续待二假故是世谛。即此二假可空故是真谛。佛果灵智亦复冥真也。冶城秀云。佛果涅槃非世谛。是真谛微妙寂绝。故云世谛死时名生不生。龙光云。佛果涅槃具相续相待二假即世谛。乃即真之义而不冥真。若冥真同顽境。即无灵智故非真谛也。有人难此四解。若佛果出此二谛外即应非有为非无为。汝义中那云佛果一向是无为。若为二谛所摄佛果应是亦有为亦无为。若佛果是真谛。真谛不可说于众生无用。若佛果是俗谛佛果一向是有为。此皆成论师说。自相矛盾都不惬人情。亦不称肇论。论云。不可形名得不可有心知。言之失其真。知之反其愚。有之乖其性。无之伤其躯。肇意推之堕在四见。佛法边外尚非小涅槃门况小涅槃体。尚非小涅槃门体焉得是共别涅槃门体。尚不是共别门体何得是大涅槃体耶。经云。是诸人等。春阳之月。乘船游戏。失琉璃宝。即共入水。竞捉瓦石欢喜持出。谓琉璃珠。都非真宝。是珠澄渟清净故在水中。犹如仰观虚空月形超然独远。非众人所执。亦非众盲所触。古来复约三聚论涅槃体言。佛地一向有心聚。一向无无作聚。色聚亦有亦无。无粗色有妙色。引经因灭是色获得常色。六卷云。妙色湛然常安隐(云云)。又一解。色是顽阂。不可研进。故佛地无色无无作。唯有灵智独存。经道色者能应为无穷之色。又妙果显现义说为非色。引文。愿诸众生灭一切色。入于无色大般涅槃。又分别两界有色一界无色。又四空无色者无粗色耳。三界并有色。界外变易则无色。六地已还身在分段故有色。七地已上身在界外则无色。又七地是两国中间犹有光影色。八地已上则无色。又言金心犹有色。故经言。意生身者虽无一期寿命但有念念生灭名为变易。故言意生身。身者犹有色也。唯佛地无复色耳。无作者金刚已前皆有无作。唯金心无心无无作也。有人难此义。若涅槃定有色。应有长短质像。须依食住处。若定无色心无所依。岂可有心而无色。若色顽须离心是取相何意不离。如是等释皆是妄语。犹如盲跛。见佛亦盲跛。王语诸臣我库藏中无如是刀。不须多难也

大般涅槃经玄义卷上大般涅槃经玄义卷下

        隋天台沙门灌顶撰

古来复约三性。明涅槃体。言佛地。一向是善性。一向非恶性。无记性亦有亦无(云云)。光宅云。常住佛果。有两种无记。一知解无记。二果报无记。如棋书射御。阐提亦有故非是善。佛地亦有故非是恶。即是无记性也。果报者。如生死苦无常报。既非是恶。只是无记。涅槃地常乐我净亦非是善。直是无记。开善庄严并言。佛无无记。唯一善性。知解无记。有多释。庄严云。是善性。开善云通三性。在阐提是恶。在佛是善。在余人是无记。言果报者。生死中多有异具故。果报可是无记佛果报何以是无记。佛果唯一习果。无复报法岂得类此是无记。以习善既满。并成习果也。夫三性者。若有若无。只是世俗尚不是真。何得用此释涅槃体。此皆数论之极说安处佛体。如野人暴背献至尊耳。今明涅槃体者。上来释名论无。无一切方便。论绝绝能绝所。名下妙理宁可思议。德王云。大般涅槃非色非声。云何而言可得见闻。古来诸师云何以色为涅槃体。又经云。夫涅槃者。不从因生。体非是果。古来诸师云何以佛果释涅槃体。又涅槃之体无定无果。古来诸师云何谓涅槃体定是一法。当知其体非色非声。非因非果。非一非异。非诸声闻缘觉所知。亦非十住能了了见。不能默已。强作五种言之。一约性净涅槃。二约法身德。三约一谛。四约不生不生。五约正性。初论性净。总指一部。次论法身指哀叹。次论一谛指圣行。次论不生指德王。次论正性。指师子吼迦叶等。不可备引。斑驳略周耳。性净者。净有三种。一方便净。二圆净。三性净。方便净者。呕和善巧权能逗物。住首楞严。建于大义。或一阎浮提。或一四天下。或一大千界。或十方土。随诸众生应可调伏种种示现。无生而生。王宫七步。无灭而灭。倚卧双林。是以晨朝放光。大声遍告。正觉世尊将欲涅槃。若有所疑今速可问。为最后问。所以三界躄踊。八部悲号。献供填空。流血洒地。高幢翳诸日月。广盖遍覆大千。如经广说。乃至下者作九法界身。非生现生。非灭现灭。不前不后。一时等现。然于寂灭。无所损减。于诸生死。无染无累。故名方便净涅槃也。圆净者。因圆果满。毕竟成就。原其初基。以大涅槃心。行如来行。持戒不杀。拥护正法。广宣流布。利益众生。回向大乘。感得金刚坚固之体。法身常身圆满具足。获大涅槃。修道得故。安住于此秘密藏中。复能颁宣广说。一切悉有佛性。施与一切。常命色力安无碍辩。虽破烦恼亦无所破。虽圆智慧。亦无能圆。虽施众生。不得众生及以施相。是名圆净涅槃也。性净者。非修非得。非作业非与业。本自有之。非适今也。冲湛寂静。不生不灭。虽在波浊。波浊不能昏动。犹如仰观虚空月形。五翳不能翳。虽复随流苦酢其味真正。停留在山。虽没肤中。脓血之所不染。故名性净涅槃也。此三涅槃。不可相离。即三而一。不可相混。即一而三。虽复一三。即非一三。虽非一三。而复一三。会之弥分。派之弥合。横之弥高。竖之弥阔。微妙莫测。不可思议。今欲分别令易解故。总唱涅槃。即是其名。专据性净。以当其体。指于圆净。即是其宗。方便善巧。以为其用。作此分别。即是其教。虽复分别。都是一法。所谓大乘。大般涅槃。若得此意。无俟多言。其未解者。更重复说耳。二约法身德者。德有三种。一法身德。二般若德。三解脱德。法身者。即是金刚竖固之体。非色即色。非色非非色。而名为真善妙色。真故非色。善故即色。妙故非色非非色。又真即是空。善即是假。妙即是中。例一切法。亦复如是。以是义故。名为佛法名佛法界。摄一切法。名法身藏。名法身德也。般若德者。即是无上调御。一切种智。名大涅槃。明净之镜。此镜一照一切照。照中故是镜。照真故是净。照俗故是明。明故则像亮假显。净故瑕尽真显。镜故体圆中显。三智一心中得故。言明净镜。摄一切法。故称调御。是佛智藏。名般若德也。解脱德者。即是如来自在解脱。其性广博无缚无脱。是广博义。体缚即脱。是远离义。调伏众生。是无创疣义。如是解脱。摄一切法。亦名解脱藏。亦名解脱德。如是三德。不可相离。文云。法身亦非。乃至解脱亦非如是三德不可相混。文云。三点具足。无有缺减。当知虽一而三。虽三而一。虽复三一。而非三一。虽非三一。而三而一。不可思议。摄一切法。摄一切人。文云。我及诸子。四部之众。悉皆入中。微妙难思。为若此。今欲分别令易解故总唱秘藏。以当其名。法身摄一切法。不纵不横。以当其体。般若摄一切法。如一面三目。以当其宗。解脱摄一切法。如三点伊。以当其用。如此敷演。即是其教。非但经体义明。余义亦显(云云)。三约一谛者。世人解谛。或境或智或教非无此义。今用理释谛。理当即境正。境正即智教皆正。以理释谛其义为允。有四种四谛。一生灭四谛。集是能生。苦是所生。能生生所生。所生还生能生。苦集回转。生死无已。道名能坏。灭是所坏。所坏亦坏能坏。能坏亦坏所坏。更互生灭。故称生灭四谛。若论其相。逼迫生长能除所除等是也。如经。二无生四谛者。推苦集之本。本自不生。不生故则无苦集。既无所坏。亦无能坏。故称无生四谛。论其相者。解苦无苦。而有真谛。集道灭亦如是。如经。三无量四谛者。分别校计苦集灭道。有无量相。非诸声闻缘觉所知。如经。四一实四谛者。解苦无苦。而有于实。乃至解灭无灭。而有于实。实者。非苦非苦因。非苦尽。非苦对。而是一实。乃至灭亦如是是名一实四谛。具如经。非离生灭四谛。别有一实四谛。即达生灭而是一实四谛。无生无量。亦复如是。一中有无量。无量中有一。不可思议。不可说示。强欲分别令易解故。总唱一实四谛。即是名也。取一灭谛。即是其体。故胜鬘云。一依者。即一灭谛也。道谛以当其宗。取道谛所治。以当其用。调御心喜。说此真谛。即名为教。虽差别说。只是一无差别法耳(此中遗一章)。五约正性者。性有五种。谓正性因性因因性果性果果性。正性者。非因非因因。非果非果果。是名正性。因性者。十二因缘。因因性者。十二因缘所生智慧。果性者。三藐三菩提。果果性者。大般涅槃。今且约一事论之。五阴下所以。即正因佛性。五阴即因性。观五阴生智慧。是因因性。此智慧增成。是果性。智慧所灭。是果果性。于阴既然。余一切法亦尔。当知五性亦非条别。即一而五。即五而一。一而不混五。五而不离一。不可思议。不可说示。强欲分别令易解故。指果果性为名。指正性为体。指因因性果性为宗。指因性为用。作此分别五性为教。虽复分别。只是一法。更无差别。若人能如此解者。非但识体。于名宗用教。触事冷然。为未解者更论宗耳

第三明涅槃宗者。有人言。宗体不异。是义不然。何者。若论至理。二即不二。不二即二。此则宜然。若论名事。不二不可为二。二不可为不二。既立宗体。宁得是同。宗者要也。修行喉[示*禁]莫过因果。此经明因。略有三种。一破无常修常。如哀叹品。以常乐我。斥诸比丘无常。苦无我。虚伪不真。宜应舍离。今当为汝说胜三修。此是破无常修于常。能得常果显于非常非无常。烦恼为薪。智慧为火。以是因缘。成涅槃食。令诸弟子。悉皆甘嗜。劣三修是烦恼薪。胜三修是智慧火。非常非无常。是涅槃食。四众安住秘密藏中。即是甘嗜。又云。如来体之。是故为常。体者履也。履而行之。法常故佛亦常。亦是法非常非无常故。佛亦非常非无常也。问初为纯陀。直说一常。次明常住二字。次斥诸比丘。云胜三修。何意增减。答皆是今昔相对。昔说四非常。总是一无常。今论四德总是一常。举总常破总无常耳。昔说生死无常。而复流动。今以常破生死。以住破流动。故举二字。以破二耳。诸比丘置事缘理。但修三想。今举胜理破劣理但用三修(云云)。二者。以大涅槃心修从浅至深。次第行学。如圣行中。专行五行。初谓戒定慧。居家如牢狱。梵行若虚空。从头至足。其中唯有发毛爪齿大小肠胃。观察八苦五盛阴等。次解苦无苦。而有真谛。次分别校计。苦集灭道。无量无边。次非苦非集非道非灭而有实谛。广说如经。修是行已。得二十五三昧。住大涅槃。况出诸佛功德。不复可说。当知从浅至深。成因克果。显非因非果。始终莫不以常为宗。德王品中亦如是。初观四大如箧五阴如害。六尘如贼。爱如怨诈。烦恼如河。八正如筏。运手动足截流而去。得到彼岸。戒定如动足。智慧如运手。涅槃是彼岸。师子吼中。亦如是。初从少欲知足。乃至住大涅槃。又善修戒。不见戒因戒果戒一戒二等。是名善修。定慧等。亦复如是。原始要终。皆宗常住。以常为宗明矣。三者如圣行中云。复有一行是如来行。所谓大乘大般涅槃。大乘即是修因。涅槃即是得果。大乘为因。何所不运。大涅槃果何所不克。一切无阂人。一道出生死。莫复过此。大略可知不复委说。但此文中。处处论行。或修十想或知根知欲。种种不同。不出三种。初破无常而修常。即是以圆接小接通意也。次以大涅槃心修无常。次修于常。即是从渐入顿次第别意也。后即无常而修于常。即圆顿人也。虽三不同。悉以常为因归宗常果。住大涅槃。等无有异。故文云。因虽无常。而果是常。即第二番意也。余例可知(云云)。问明体一章。即识五意。明宗亦尔否。答例然宗有三义。一宗本。二宗要。三宗助。宗本者。诸行皆以大涅槃心为本。本立道生。如无纲目不立。无皮毛靡附。涅槃心为本故。其宗得立也。宗要者行之宗要。要在于常。行会于常。能显非常非无常。如七曜之环北辰。似万川之注东海。行以常为要。亦复如是。宗助者。助名气力也。常宗得成赖于资助。或人助。或教助。或行助。或道助。由助得力。故言宗助。总此三。宗是释名。专论宗本即体意。专明宗要即宗意。专明宗助即用意。分别此三。异余法门。即教意

第四释涅槃用者。为三。一本用。二当用。三自在起用。本用者。先出旧解。灵味小亮云。生死之中。本有真神之性。如弊帛裹黄金。像堕在深泥。天眼者捉取净洗开裹。黄金像宛然。真神佛体万德咸具而为烦恼所覆。若能断惑佛体自现。力士额珠贫女宝藏井中七宝。闇室瓶盆等喻亦复如是。此皆本有有此功用也。新安述小山瑶解云。众生心神不断。正因佛性附此。众生而未具万德必当有成佛之理。取必成之理为本有用也。开善庄严云。正因佛性一法无二理。但约本有始有两时。若本有神助有当果之理。若能修行金心谢种觉起名为始有。始有之理本已有之。引如来性。贫女额珠闇室等。证本有。引师子迦叶明乳中无酪。但酪从乳生故言有酪。酪非本有。必假醪暖。种植胡麻。答言有油。油须捣压乃可得耳。又引佛性。三世众生未来当有清净庄严之身。此证当有。双取二文。意与瑶师不异。又引木石之流。无有成佛之理。则非本有之用。众生必应作佛。今犹是因。因是本有。果是始有。本有有始有之理。即是功用义也。有人难初义。若言众生身中。已有佛果。此则因中有果过。食中已有粪。童女已有儿。若已具佛果何故住烦恼中坐不肯出耶。何故不放光动地。故文云若言有者。何故默然正破此执耳。次难第二有得佛之理。此理若常为相续常为凝然常。若相续常何谓本有佛果之理。若凝然常则因中有果过同于前。难第三家。若言本有具始有。亦应本有常住。复有无常。本有只得是常不得无常者。本有只本有那得有始有。又若本有有始有亦应无常有于常。无常不得有于常。本有那得有始有。又本有有始有则了因有生因。若了因了本有是常。生因生始有是无常。不得相有者今本有那得有始有耶。鹬蚌相扼更互是非。由来久矣。今当宣明此义。若定执本有当有。非三藏通教之宗。乃是别圆四门意。本有是有门。当有是无门。双取是亦有亦无门。双遣是非有非无门。别家偏据不融门理两失。为圆家所破。何者若执本有之用譬之树木。工匠揆则任曲者梁用。直者桁用。长者槊用。短者箭用。本有之用。亦复如是。佛即破之。草木生时无梁箭用。工匠所裁。因缘获用。若裁曲为直。曲无梁用。展直为曲直无桁用。割长为筹长无槊用。折短为薪短无箭用。何得苦执本有之用。经云。三世有法无有是处。何得苦执本有当有。当本不立胜用安在耶。若专难破复失适缘。何者理非本非当。非亦本当非非本当。有四利益。或言本有即是常用。或言当有即是无常用。或亦当亦本即常无常双用。或非当非本。即双非不用之用。本有常用摄一切法何得无三门用。三门亦摄一切法。何得无本有常用文云。大般涅槃是诸佛法界。即其义也。是为圆教赴缘。论此四用大获利益不同旧义(云云)。二当有用者先出旧解。解有三。一云理出万惑之外须除惑都尽乃可见之。譬十重纸裹柱虽除九重终不见柱。并尽乃见。二引渐备经明一切智慧皆渐渐满不可一期并悟也。三云真谛可渐知佛果可顿得。何者即俗而真。更非远物所以真可分知。佛果超在惑外。不即生死故不可渐知。有人难初义。若理不可渐见惑岂可渐除。既不见理由何除惑。若言理可渐见夫理若是分。可作分知。理既圆通若为渐解。若初见称后见与后无异不名渐见。若初不称后不名顿见(云云)。若言见真者须渐。得佛须顿。是义不然。释论云。若如法观佛般若与涅槃。是三则一相。华严云。虚妄多分别生死涅槃异。迷惑圣贤法。不识无上道。真与涅槃既其不异。云何真渐果顿耶。今明。诸解更相驰逐。水动珠昏。然理非远近。见理之智宁得渐顿。智若渐顿宁得称理。如方入圆殊不相应。如理而解解如于理。不见相而见。无所得即是得耳。有因缘故亦得渐顿。此中应有四句。渐渐渐顿顿渐顿顿。渐渐尚非渐顿。况复顿渐。渐顿尚非顿渐况复顿顿。法华玄广说。顿渐者无差别中差别耳。顿顿者差别中无差别耳。三种修三种见明宗中意是也。渐顿修渐顿见者。是不定观意也。渐更不同又开四句。渐修渐见。渐修顿见。渐修顿渐见。渐修非顿渐见。见此一句意余三句亦可解。四四十六句不同。当知显体之用甚多。那只作一两种解耶。文云王家力士一人当千。种种技艺能胜千。故一人当千。又云。譬如大地草木为众生用。我法亦尔。当知用同草木比大力士。故知用不一也。旧论照境之用不同。问。俗有三世流动万境去来佛智若为照之。若逐境去来则生灭无常。若不逐境去来则不与境相称。由此一问七解不同。冶城嵩云。佛智乃无大期死灭。犹有念念流动逐境去来。此人临终舌烂口中浪语之过现验也。二药师解。佛智体是常住。用是无常逐境去来。此解亦违经。经云。若正见者当说如来定是无为。那忽体是无为用是有为。三光宅云。若无常之智照常住境而不逐境是常。今常住之智照无常之境。岂应逐境无常。此亦不可。四作九世照境义明。此境虽在未来。复有当现在当过去义。今遂来现在及过去我皆照竟。所以不生灭也。此亦不可。向在未来时犹是当现在未正现在。今遂来在现在即作正现在。照当知已息。岂不生灭耶。五作逆照义云。如来道迎正觉时初一念并逆照万境。从初流来至后成佛并皆照竟。后万境自有去来我都不更新照。如天子初登极时。并付制法后人犯者。随轻重治不更复制也。此亦不可。佛智照境何尝暂息忽言初照后都不照。纵令如此终不与境相称。六开善云。佛在因日导发初心已能横照数境竖照数时。次入初地一念横照百法竖照百时。二地千法乃至佛地一念横照万法竖照万时。如悬镜高台。此亦不可。镜照先无而后有未免无常之难。七灵味更借虚空为喻。万物在空空不生灭物自去来。此亦不然。佛智灵知岂同顽空。今明三藏教中二谛不相即。故二智各照。所以诸解喧喧若此。若通教中。二谛相即二智二而不二。尚无此诤。况复三谛即一谛。一谛即三谛。三智即一智一智即三智。一照即一切照。一切照即一照。非一非一切不可思议。宁复有此微浅问答耶。又开善解。佛智照真与真冥。无复智境之异。智体与真境都复不殊。约位分别。凡夫不冥不会。因中圣人会而不冥。佛果亦冥亦会。第二解云。佛智是灵知真谛是无知。二体既殊。岂可并有知同无知。但会之既极詺之为冥。岂得有冥异会。慧印三昧经云。冥不冥寂不寂。肇论亦有用冥体寂之语。今难。佛之真智既其冥真与真不异。佛之俗智亦应冥俗与俗不异。佛虽知幻而非幻人。若尔佛虽知俗不可冥俗。佛虽冥真不可同真。不应作如此冥真冥俗义。冥真不出二乘。冥俗不出凡夫境界。云何得是佛智用耶(云云)。三自在起用。用遍法界广不可委。文云譬如大地一切草木为众生用。我法亦尔。当知胜用无量无边。且约三种。一不可思议用。二二鸟双游用。三善恶邪正双摄用。不可思议用者。旧释有七。一云令他见须弥入芥子。其实不入。唯应度者乃能见之。此解不可。若不入者何谓神通。二解实入。但佛神力蹙大令小开小令大。此亦不可。若尔乃以大容小何谓以小容大。三解不知入与不入。既是不可思议。那可定判入与不入。此亦不可。佛果上地皆是不可思议。尽应不可解。余者尽言可解。至此一义独言不知耶。四若有则相妨。小大皆空故相容。此亦不可。若其皆可何所论入。亦无大小也。五大中有小性小中有大性。以芥子之大性容须弥之小性。此亦不可。若执定性过同外道。又似毗昙。又还是大容于小。何谓以小容大。六地论解。大无大相。不无无相之大。小无小相。不无无相之小。以无相之小。容无相之大。无相之大。还入无相之小。此亦不可。大小本是相既言无相那有大小。若有大小应是有相。若定无相还同空也。七兴皇云。诸法本无大小。因缘假名相待假说大为小。假说小为大。说大为小。小是大小。说小为大。大是小大。故得相容。此亦不可。大不自大。待小为大。小不自小。待大为小。此堕他性义。自性大小尚不能相容。他性大小那得相容。今明小不自小亦不由大故小。大不自大亦不由小故大因缘故小大。亦不离大离小。不在内外两中间。亦不常自有。不可思议。大亦如是。通达此理故即事而真。唯应度者见不思议。须弥之高广入于不思议芥子之微小。是名以不思议之大入于不思议之小。住首楞严能建大义如经广说(云云)。一往明。不思议用在于道后。其理实通。乃至善恶邪正等例如是。所谓四趣是邪人天为正。又三界是邪二乘为正。又二乘偏邪菩萨为正(云云)。邪正两用亦遍法界。四趣是恶人天是善。又三界悉是恶二乘是善。又二乘是恶菩萨为善。此用亦遍法界。三界皆悉无常二乘是三无为常。又二乘是无常菩萨是常。常无常用亦遍法界。其门略义广也。常无常双用者俱亡二边。如鸟喻品中说。即是一时双用也。前后倒泻即是异时偏用。宜一时即并用。宜前后即单用。不必一种。用自在故。善恶双用。如迦叶品中说。善星至恶尚能摄受令得出家。况复善者宁当不摄。或双用或前后(云云)。三邪正善恶俱摄者。陈如品中说。邪即外道。正即陈如弘广。邪即诸魔。正即阿难。平等皆摄。巧施妙用。游诸世间作大利益。若见此意即是自在之用。善巧四随称机利益。住首楞严种种示现不动法性。其见闻者无不蒙益。此义可知不俟多说(云云)。问此一章五意云何。答例前可解。若总论三用即释名意。若专本用即是体意。若专当用即是宗意。若专自在用。即是用意。若分别三用即是教意

第五释教相者。为二。一增数。二经来缘起。增数者。谓一乳二字三修四教五味也。所言乳者此名则通。外道言教亦称为乳。文云。是时旧医纯用乳药。二乘言教亦称为乳。阿含云。舍利弗是所生母。目连是乳母。二人说法生养四众。后文亦云。声闻缘觉佛性如乳。菩萨教行亦称为乳。故云手出香色乳。施令得饱满。佛教亦称为乳。故目连腾请云。譬如犊子其生未久若不得乳必死无疑。又云。医占王病定须服乳。乳名既通。若为分别。旧医偷教。窃取乳名。不解其义。而为相续悦意转动薄皮所诳起四颠倒毒乱心中多所伤害。即邪教也。二乘乳者。佛以方便合三种药。谓碱苦酢。二乘之人用此方便。为于四众治彼邪乳。如以楔出楔。此以四非常教名为乳也。菩萨乳者。以大慈大悲。随诸众生应以何法而得度脱随而说之。或说方便法。或说真实法。或治邪常。或治无常。称彼机缘令得饱满。是名菩萨教乳也。佛教乳者。究竟真实如经。其犊调善不驰不住。不处高原。亦不下湿。不食酒糟麦[麥*弋]滑草。不与特牛同共一群。故其乳多德最为第一。正显涅槃之教是最上乳也。又外道教如驴乳。亨之成粪。从其教者堕落三涂。二乘教如羊鹿乳。亨之成酪。从其教者升出生死。菩萨教如下品牛乳。亨之成酥。从其教者革凡成圣。亦革圣成无上道。佛教如上品牛乳。从佛教者即得安住秘密藏中。当知涅槃教乳最上最妙。问何故于一乳中多种分别。答此经意尔。如本有一偈四出证义明无差别差别等。例作此说之无咎。又德王中不闻闻不生生等。皆作四句。今亦例尔。邪乳名乳乳。二乘名乳不乳。菩萨名不乳乳。佛是非乳非不乳。意高例尽子何须惑。二字者世亦二字。出世亦二字。上上出世亦二字。今文亦二字。二字既通。复须分别。世二字者。如瑞应云。太子乘羊车。诣师学书。师教二字。谓梵佉娄。此二字应诠世间礼乐医方技艺治政之法。故是世间二字也。又云梵字应如金光明中说出欲论。明修梵法叹梵执故。是出欲论也。佉娄字应是无量胜论。明十善法叹释天报。善能攻恶故言胜论。总而言之世间二字也。谢灵运云。梵佉娄是人名。其撮诸广字为略。如此间仓雅之类。从人立名故言梵佉娄。虽复广略还是世间之二字。出世二字者婴儿行云。婆和二字。所谓有为无为为二字也。若出世与出世上上共为二字者。即是半满为二字也。众经同以鹿苑说为半字。摩诃衍所说为满字。小大相对共为二字。又诸师释此满字不同。地人云。涅槃六行俱明是满字。法华是大乘非满字。由是无常。此都非义。不须论难(云云)。兴皇嘲诸师作五满。半边满竖满[卄/積]足满共满具足满。今不委论(云云)。今明半满二字更为五意。一直是半。二对半满。三带半满。四废半满。五开半满。如鹿苑无常此直半无满。若方等之流。说无常逗小。又弹小褒大此正对半明满。若大品通三人共学是带半明满。若法华正直舍方便。是废半明满。亦有开权显实。即开半明满。若此经斥劣辨胜。即废半明满。一切众生悉有佛性。须跋陀罗得罗汉果。即开半明满。而复对破生死流动明于常住二字。常破生死。住破流动。此亦是废半明满。一切诸法中悉有安乐性。又是开半明满。故知二字虽通不可一概。今之常住二字。于诸字中最尊最胜其义可知。又结为四句。二乘无常是半非满。一乘是满非半。若斥小带小等是亦半亦满。若世间非半又非满。大意可知(云云)。三三修者有邪三修劣三修胜三修。邪三修谓世间颠倒。随邪师教见相似相续谓为常。适意可悦谓为乐。转动运为谓是我。愚惑所覆如执掣电。如蛾如蚕追求无厌。如渴饮碱唐无毫益。亦是厌下苦粗障。攀上胜妙出故名邪三修。劣三修者。依半教破于邪执。无常碱味破其执澹。无乐苦味破其执甜。无我酢味破其执辣。三界皆无常诸有悉非乐。一切空无我无我所。能破欲染色无色染无明掉慢疑。如诸迹中象迹为最。于诸想中无常为最。如经广说是名劣三修。胜三修者。依佛胜教。破于劣修。谓常乐我法身常恒无有变易游诸觉华欢娱受乐。具八自在无能遏绝。如是修者。入秘密藏名胜三修。又邪修是世伊。劣修是故伊。胜修是新伊。大涅槃理即非新非故伊。今经即是新伊胜修最尊最上之教也。四四教者。此该佛一化。名相理趣别有疏本(云云)。三藏教者。谓戒定慧藏。为彼婴儿梯蹬出苦畏惮长远止息化城。即小乘法也。菩萨以大涅槃心修即成圣行。如经浮囊白骨八苦等观。即其文义也。通教者。三乘共学近远俱通。若能前进亦可得去。即摩诃衍法也。菩萨以大涅槃心修即成圣行。如经解苦无苦而有真谛。乃至解道无道而有真谛。即其文义也。别教者。别在菩萨不与二乘人共。所行事理非彼境界。即独菩萨法也。若以大涅槃心修即成圣行。如经苦有无量相。分别校计有无量种。非诸声闻缘觉所知。乃至道亦如是。即其文义也。圆教者。即事而理。一教一切教。一切教一教。非一非一切不可思议。随佛自意是佛境界。非诸二乘下地所知。如经非苦非谛有实。乃至非道非谛有实。是名一实谛。即其文义也。菩萨大涅槃心修即是圆心。圆心为本行于众行。从浅至深。届极而止。如放金刚到际则住。当知圣行之一意即是渐顿之教。亦名渐圆教。此乃文中一种耳。复有一行是如来行。所谓大乘大般涅槃者。即发轸仍顿仍圆一切诸法悉入其中。众流悉碱无非性海。渐圆与顿圆更无别异。历次第门故言渐耳。今经乃具二文。从胜受名即是圆顿之教。于诸教中最为尊上也。若类通异名者即是四藏。三藏是声闻藏。通是杂藏。别是菩萨藏。圆是佛藏。上能摄下佛藏第一也。若例四句。三藏是闻闻。通是闻不闻。别是不闻闻。圆是不闻不闻。乃至生生等例可解。五五味者。即五种牛味正譬说教次第。不应以浅深意取。若谓初浅后深是义不然。文云医占王病定须服乳。又云如得乳糜更无所须。无所须者即真解脱。真解脱者即大涅槃。此岂浅耶。文云如水乳杂卧至一月终不成酪。若以一滴颇求树汁投之于中即便成酪。众生佛性亦复如是。若本有者何故待缘。如此酪譬不可浅也。文云。譬如甜酥八味具足。是大涅槃亦复如是。当知此酥其况深矣。文云。阿罗汉辟支佛犹如醍醐。如此醍醐不可言深。若初味定浅。后味定深。防文害义。若作次第意释者则无过咎。牛者譬佛。大觉朗然圆明成就。如血变为乳具足在牛。从牛出乳譬佛初说也。即寂灭道场从法界体流出法界法教诸菩萨。如日初出先照高山。故言从牛出乳也。次从乳出酪者。为小机不堪。如聋如哑。隐其无量神德。示丈六身。覆如来藏。但说三藏以贫所乐法。随宜方便。令章凡成圣。故华严大后次说三藏之小。如从乳后即有于酪也。次从酪出生酥者。譬三藏之后以大诃小挫其取证败种坏根无生无用。先与后夺如亨酪作生酥也。次从生酥出熟酥者。譬方等之后。委业领财使诸声闻转教教菩萨也。次从熟酥出醍醐者。譬般若已后付财定性与记作佛。故文云八千声闻于法华中得记作佛。见如来性如秋收冬藏更无所作。无所作者即究竟也。夫众生不见佛性智手指撝。或作大说。或作小说。或诃责说。或教化说。或定天性说。众生若见佛性则静乎。双树指撝毕矣。息教二河法流竭矣。如牛出乳极至醍醐。诸佛布教极于见性。今经是最后之说喻彼醍醐。一切诸药悉入其中。叹于横广。在四味之上叹其竖高。故此经处处叹教不可思议。只是叹于上妙之乳常住二字最后新伊极圆之教醍醐妙味耳。种种名目只是一法。一法者只是佛师诸菩萨母。佛菩萨辩所不能宣。凡夫千舌岂解揄扬。二乘百盲安能舞手者哉。五味义具在法华玄中说。又从增一至五。总诸说者即释名意。若专五所以是体意。若专五所以设诸名相是宗意。若专对破是用意。若分别其相是教意。准前可知。不复委释(云云)。二经来缘起又二。一经缘起。二疏缘起。经缘起者。有双卷六卷大本。双卷明八十入灭不辨常住。盖小缘所感三藏教也。六卷与大本皆明常住。俱是大缘所感。同座异闻。例如大小品耳。又云小本是法显于天竺钞。初分翻为六卷。大本上帙是道猛赍来。斯乃广略二文耳。世犹惑焉。若是异闻那忽问词答旨两本皆同。若是钞者只应存略那忽前后。大本则如来说偷狗。六卷迦叶问偷狗。大本偈说三归。六卷长行说三归。解云问词答旨所同处少不同处多。昔钞梵文尚无前后。秦人翻译逐意奚互。于二义无妨也。昔道猛亡身天竺唯赍五品还。谓寿命。金刚身。名字功德。如来性。大众问等品。到西凉州值沮渠蒙逊割据陇后自号玄始。其号三年请昙无罗谶。共猛译五品得二十卷。逊恨文义不圆。再遣使外国。更得八品。谓病行。圣行。梵行。婴儿行。德王。师子吼。迦叶。陈如等品。又翻二十卷合成四十轴。传于北方。玄始五年乃得究讫。是时姚苌复号弘始。弘始非玄始。玄始五年即晋恭帝元熙元年。次入宋武刘裕。得四年。次入宋文帝。文帝尚斯典。敕道场寺慧观。乌衣寺慧严。此二高明名盖净众。康乐县令谢灵运。抗世逸群一人而已。更共治定开寿命。足序纯陀哀叹。开如来性。足四相四依邪正四谛四倒文字鸟喻月喻菩萨凡十二品。足前合二十五品。掣三十六卷。则一万余偈。谶云经义已足。其文未尽。余有三品。谓付嘱烧身分舍利。二万言未来秦地耳。小亮云。是罗什足品。由来关中不闻涅槃。恐其言为谬。经录称谢灵运足品相承信用。初三人欲删略百句解脱。俱梦黑神威猛责数刚切。汝以凡庸改圣人言义。其过大矣。若不止者以金刚杵碎之如尘。因不敢删略。但去质存华。如啼泣面目肿。改为恋慕增悲恸。如呜啑我口改为如爱子法。故其文璀璨皆此例焉。经者通名也。如法华疏说。序品第一者亦如彼(云云)。二疏缘起者。余以童年给侍摄静。摄静授大涅槃。诵将欲半。走虽不敏愿闻旨趣。于是负笈天台。心欣蓝染。登山甫尔仍逢出谷。不惟菲薄奉从帝庭。师既香涂二宫。光曜七众。道俗参请门堂交络。虽钦渴甘露如俟河清。讵可得乎。尝面请斯典。降旨垂许。有期无日。逮金陵土崩师徒雨散。后会匡岭。复属虔刘。爰西向江陵。仍遭雾露。敕征师江浦。顶疾滞豫章。始举颿南湖。已闻东还台岳。秋至佛陇冬逢人灭。叹伊余之法障奚可胜言。昔五百群盲七回追佛。祇洹一狗听两钟鸣唯疆唯沈无见无得。入山出谷浮坠溯江。希闻斯典竟不获闻。日既隐于重崖。盲龟眠于海底。冯光想木讵可得乎。余乃扫墓植树。更伏灰场口诵石偈思愆毕世事不由已。迫不得止戴函负封西考阙庭。私去公还经涂八载。日严诤论追入咸阳值桃林水奔而夜亡其伴。又被谗为巫收往幽蓟。乘冰济北马陷身存临危履薄生行死地。悼慓兢兢宁可尽言。昔裹粮千里担簦于东南。负罪三谗驱驰于西北。若听若思二涂俱丧。情不能已寻诸旧疏。将疏勘经不与文会。怏怏终日恒若病诸效。群盲之触象。学独梦之谈刀。以大业十年十月十日庐于天台之南。管窥智者义意辄为解释。运丁隋末寇盗纵横。海闹山喧无处纸笔。匿影沃洲。阴林席箭推度圣文。衣殚粮尽亏其次第。于是怀挟鄙志托命遂安。草本略通放笔仍病。县令邓氏呼讲净名。曳疾应之。事不兼举寄疏他舍。他舍被烧廓然荡尽。冥持此本得免灰扬。重寄栅城。海寇冲突玉石俱罄。萧亮提挟复获安存。所谓焦不能烧贼不能得。再蒙灵异重厉微诚。更往遂安披寻补削。复值军火食息无宁。乃卜安洲。安洲者微澜四绕绝人兽之踪。峰连伟括兼二山之美。左临水镜澄彻鉴心。右带蕖池红葩悦目。修竹冷风胜白牙团扇。蒌茜翠草加戴氏重席。云霞镂糅于松桂。五彩羞其绘图。猿麏和韵于蝉蛙。八音陋其弦管。雅有高致丰趣冥伦。仍莳粟拾薪勤兼晓夜。暨染笔已来凡历五载。何年不遭军火。何月不见干戈。菜食水赍冰床雪被。孤居独处梦抽思乙。词既野质意不会文。其玄义一卷释文十二卷用纸七百张。有崖易迨空海难遍。盲寱偏知敢称圆识。特是不负本怀遽兹石火。卷舒常住之卷。酬报乎身手。赞叹解脱之法。仰谢于心口。粗耘毒草微养药王。螳[虫*敖]萤熠非能抗曜也

大般涅槃经玄义卷下


大般涅槃经义记

    No. 1764 [cf. No. 374]

大般涅槃经义记卷第一(之上)

        隋净影寺沙门释慧远述

圣教万差。要唯有二。谓声闻藏及菩萨藏。教声闻法名声闻藏。教菩萨法名菩萨藏。声闻藏中所教有二。一声闻声闻。二缘觉声闻。声闻声闻者。是人先来求声闻道。常乐观察四真谛法。成声闻性。于最后身。值佛为说四真谛法。而得悟道。本声闻性。今复闻声而得悟道。是故名曰声闻声闻。如经中说。求声闻者为说四谛。据此为言。缘觉声闻者。是人本来求缘觉道。常乐观察十二缘法。于最后身。值佛为说十二缘法。而得悟道。本缘觉性。于最后身闻声悟道。是故名为缘觉声闻。如经中说。为求缘觉者说十二缘法。就斯为论。是二虽殊。同求小法。藉教处等。是故对斯二人所说。为声闻藏。菩萨藏中。所教之人亦有二种。一渐。二顿。言渐入者。是人过去曾习大法。中间学小。后还入大。大从小入。谓之为渐。故经说言。除先修习学小乘者。我今亦令入是法中。此是渐入。言顿悟者。有诸众生。久习大乘相应善根。今始见佛。则能入大。大不由小。目之为顿。故经说言。或有众生。世世已来常受我化。始见我身。闻我所说。则皆信受。入如来慧。此是顿悟。渐入菩萨始小终大。顿悟之人一往入深。顿渐虽殊。以其当时受大处一。是故对斯二人所说。为菩萨藏。圣教虽众。不出此二。故龙树云。佛灭度后。迦叶阿难。于王舍城。结集三藏。为声闻藏。文殊阿难。于铁围山。集摩诃衍经。为菩萨藏。地持亦云。佛为声闻菩萨行出苦道。说修多罗。结集经者。集为二藏。以说声闻所行。为声闻藏。说菩萨所行。为菩萨藏。彼论复云。十二部中。唯方广部是菩萨藏。余十一部是声闻藏。此经亦云。唯方广部菩萨所持。余十一部二乘所持。菩萨所持犹菩萨藏。二乘所持犹声闻藏。故知圣说无出此二。此二亦名大乘小乘半满教等。名虽改变。其义不殊。今此经者。二藏之中菩萨藏收。渐教众生长养法门。故下文言。先教半字。后教满字。已知教之分齐。次释其名。今言大涅槃者。乃是标经别部名也。经名不同。乃有多种。或有当法。或复就人。或时随事。或从喻况。或就人法。或从法喻。或随事法。其例非一。今此经者从法为名。法谓诸佛大涅槃果。故始举之。此名不足。若依梵本。名为摩诃般涅槃那。摩诃名大。叹胜之词。涅槃有三。谓声闻缘觉及佛所得。简别前二不加。是故言大。体实绝待。寄对显之。大义有六。一常故名大。故下文言。大名为常。二胜故名大。如世胜人。名为大人。故下文言。是人若能安住正法。名人中胜。胜故名大。涅槃如是。三广故名大。故下文言。大名广博。体穷法界。名性广博。四多故名大。故下文言。譬如大藏。多诸珍异。涅槃如是。多有种种妙法珍宝。故名为大。五高故名大。故下文言。譬如大山。人不能上。故名大山。涅槃如是。凡夫二乘乃至十住不能到故。名之为大。六深故名大。如海渊深。名为大海。故下文言。大者名为不可思议。渊深难测。名不可思。大体不同。略有三种。一者体大。谓性净涅槃。体穷真性。义充法界。二者相大。谓方便涅槃。过无不尽。德无不备。三者用大。谓应化涅槃。妙用旷周。巧化无尽。故下文言。大般涅槃能建大义。义犹用也。具斯三义。是故言大。所言般者。此翻名入。入义有三。一就实以论。息妄归真。从因趣果。名之为入。二据化辨入。示灭有因。现亡身智。趣入无为。三就真应相对说入。息化归真。今此所论备具三义。言涅槃者。有人释言。非梵非汉。直是佛语。若论佛语。一切皆是。岂独涅槃。故下文言。种种异论文章咒术。皆是佛说。虽是佛说。不离方言。若离方言。佛则无说。云何而言非梵非汉。有人复言。是天竺语。名总万德。此方更无一名能翻。故存梵本。名曰涅槃。涅槃之体。实备万德。涅槃一名非尽万德。若使涅槃名含万德。是则宣说万德之时。不应随德。更立名字。欲说万德。更立别名。明知非总。若言此方无名能翻。此义不然。如下文中如来随类普告众生。今日如来将欲涅槃。随音异告。云何叵翻。今正相翻。名之为灭。随义傍翻。名别多种。或云不生。或云不灭。或称不燃。或言不织。或曰寂静。或名无为。或云无相。如是非一。云何得知是灭非总。今此且以四义验之。一就昔以求。如来昔于余契经中。每常宣说。生死因果尽无之处。以为涅槃。今日涅槃名不异昔。何忽是总。二据终以验。如来今于婆罗树间。大音普告云今涅槃。众生闻已。咸皆悲恼。诣佛请住。若使涅槃名总万德。是则宣唱万德示人。众生应喜。何故悲泣诣佛请住。以斯准验。明知非总。三准定方言。其外国人。见人死灭。咸皆称言某甲涅槃。世人死灭。何德可总。四取文为证。如下文中佛叹纯陀。能知如来云同众生。方便涅槃。世间众生何曾有彼万德涅槃。可以示同。盖乃如来同世尽灭。名示涅槃。又法华中。日月灯佛说法华竟。于夜后分。入般涅槃。下偈颂云。佛此夜灭度。如薪尽火灭。明知涅槃是灭非总。问曰。若言涅槃名灭。下文说言。诸结火灭名为灭度。离觉观故。名曰涅槃。是则涅槃与灭义异。云何而言涅槃名灭。释言。外国灭有多名。所谓涅槃毗尼及与弥留陀等。以名多故。随其异义。各施异名。故灭觉观说为涅槃。诸结火灭。更作异称。此翻名灭。此方名少。涅槃毗尼弥留陀等。同翻名灭。其犹外国菩提末伽。此俱名道。何者是灭。灭有四义。一是事灭。灭生死因。尽生死果。二是德灭。舍修安寂。故名为灭。又佛真德离相离性。亦名为灭。言离相者。如净醍醐。体虽是有。而无青黄赤白等相。亦如一切众生心识。体虽是有。而无大小长短等相。涅槃亦尔。体虽是有。而无一相无何等相。如下文说。谓无色声香味触相。无生住灭男女等相。乃至无有自相可取。言离性者。大涅槃中。诸德同体。共相集成。无有一德别守自性。如就诸德宣说常义。离诸德外。无别有一常性可得。诸义齐然。故下文言。又非别异。故成涅槃。三是应灭。随化世间。示灭有因。现亡身智。四是理灭。如经中说。一苦灭谛。一切众生毕竟寂灭。即涅槃相。如是等也。理灭有二。一是相空。妄想诸法。空无自实。二是真空。如来藏中恒沙佛法。离相离性。言离相者。如马鸣说。谓非有相。非无相。非非有相非非无相。非有无俱相。非自相。非他相。非非自相非非他相。非自他俱相。如是一切妄心分别。悉不相应。唯证境界。言离性者。是诸佛法同一体性。互相集成。不离不脱。不断不异。以同体故。无有一法别守自性。灭义虽众。要唯此四。此四灭中理灭为本。由见相空。成前事灭。由见真空。成前德灭。依德起用。便有应灭。若以分相说前三灭。以为涅槃。摄相论之。四灭俱是。问曰。此经具明诸义。何故偏言大涅槃乎。涅槃为宗。故偏言耳。亦可诸义不可备彰。且举涅槃那者名息。今略不举。息有三义。一息生死有为因果。趣入无为。名之为息。二息修契实。名之为息。故下文言。若能断除三十七品所行之事。是名涅槃。三息化归真。名之为息。此举所诠。经为能诠。外国正音名修多罗。此翻名线。以能贯穿一切法相。如线贯华。是故就喻说之为线。而言经者。线能贯华。经能持纬。其用相似。故复名经。若依俗训。经者常也。教之一法。经古历今。恒有曰常。

寿命品者。依多品经。名为序品。依小品经。名寿命品。诸经立品。大例有三。或有从广。或复就略。或当相以名。此言寿命。从略言耳。以下迦叶偈请之后。明其慈悲不杀因缘。得寿命长。就此彰名。名寿命品。命限称寿。神慧不断。目之为命。品者品别。亦可品者是其品类。随其所明类类同聚。故言品类。此经合有十三章别。此品建始。故称第一

此经始终。文别有五。一者序分。二纯陀下开宗显德分。三三告下辩修成德分。四若人能知是名沙门婆罗门下破邪通正分。五如来灭度阇维供养分。此后一分。外国不来。化必有由。故先明序。由序既兴。宜显所明。故次第二开宗显德。宗谓诸佛圆极妙果。果成由因。故次第三辩修成德。真法既开。欲以所明传化不绝。故次第四破邪通正。故下文中对破外道。以通正义。对破众魔。以通正说。为化既周。迁影归寂。故次第五如来示灭。人天大众。阇维供养。问曰。诸人多以三分。科判此经。今以何故离分为五。释言。准依胜鬘经等。三分科文。实有道理。故彼经中十五章前。别有由序。十五章后别立流通。此经判文不得同彼。以第五分非流通故。又诸论者作论解经。多亦不以三分科文。五中初一化益方便。中三正益。后之一分化讫取灭。就初序中义要有二。一发起序。二证信序。辩此二序略有五门。一释名义并显立意。二明两序名之差别并显得失。三明二序名之通局。四定二序文之前却。五随文解释。就初门中。先释名义。言发起者。佛将说经。先托时处。神力集众。发起所说。名为发起。以此发起。与说为由。名发起序。言证信者。阿难昔时禀承佛说。欲以所闻传之末代。先对众生。言如是法我从佛闻。证成可信。名为证信。以此证信。与传经为由。名证信序。名义如是。次显立意。何故有二。由经二故。经正是一。何曾有二。经体虽一。约时就人。故得分二。一如来所说经。二阿难所传经。如来所说。益在当时。阿难所传传之末代。对斯二经。故立两序。对佛所说立发起序。对阿难所传立证信序。第二门中。先明二序名之差别。后辩得失。名别有四。一当相以名。名为发起。及以证信。二就人为名。名如来序及阿难序。发起序者。如来所为名如来序。证信序者。阿难所作名阿难序。三就时为名。名现在序及未来序。如来序者名现在序。阿难序者名未来序。四对经为名。名经前序及经后序。如来序者名为经前。阿难序者说为经后。此名佛说以之为经。约对此经。以别前后。彼证信序更有一名。名遗教序。佛将灭度。遗言教置。故曰遗教。名别如此。次明得失。此四对中。证信发起名义无爽。第二对中。阿难序者名亦无过。道如来序。义有不足。云何不足。如说胜鬘。有佛化主王及夫人旃提胜鬘五人影响。共为发起。诸经发起多不独佛。若使发起名如来序。失他余人发起之义。以如来序有过须废。阿难序者对亦不立。第三对中现在无爽。未来不便。是义云何。若使如来现在说经。所立之序名为现在。阿难传时亦是现在所立之序。何为非现。若对如来现在说时。阿难之序遂名未来。是则对于阿难传时。如来之序应名过去。佛虽过去。正取说时以为现在。阿难亦尔。对佛虽未。正取传时。亦是现在。二俱现在。何可偏名一为未来。良以未来有过须废。所对现在。事亦不立。第四对中经前无过。经后不便。若道经后。云何名序。若说为序。则非经后。当知二序约对二经。皆是经前。不可偏判一为经后。良以经后不便须废。所对经前。义亦不立。良以诸名斯皆有过。故今释者偏存证信发起之称。第三明其名之通局。通则二序俱名证信。齐号发起。立序之意。皆为生信。故通名证信。同为发起。故齐号发起。今为别二序。故如来序偏名发起。阿难序者偏号证信。等为别序。随便以彰。便义如何。阿难小圣。惧人轻谤。立序之意专为生信。故今释者望其本意。名阿难序以为证信。如来大圣。人皆重信。立序之意多为起发。不专为信。故今释者望其本意。说为发起。第四定其文之前却。先叙异说。次辩得失。后显正义。异说云何。昔来相传。言证信中句别有五。一如是。二我闻。三一时。四住处。五同闻。后来释者更加一佛。通余说六异说如此。言得失者。如是我闻判为证信。此言当理。是其得也。一时佛等定判经后。此言乖理。是其失也。是义云何。先以事征。后以文证。言事征者。一时佛等若是经后。经前无佛。谁之说经。无时无处。说何所托。经前无众。说何所被。赖藉此等。起发所说。何得一向判为经后。人复救言。事虽经前后引来证成可信。故判经后。若尔何独五句六句。正说已前但可有事。所有言说皆后引来。如此经中流血已前。当时但可有事而已。是中言说。悉是阿难后时引来。然下文中六种相等虽后引来。得判经前。一时佛等。何为不尔。以斯推验。一时佛等定判经后。实非道理。事验如此。今以文证。如彼地论。解佛在于第二七日他化天说。言时处等。校量显胜。此法胜故在于初时及胜处说。佛将说经。先托时处表彰法胜。然后起说明知时处经前起发。又法华论释法华经。义亦同。尔彼言何故在王舍城只阇崛山。此法胜故寄处表法。然后起说。明非经后。得失如是。次显正义。如是我闻一向证信。一时佛下义有两兼。取其当时起发之义。判为发起。阿难引来证成可信。判为证信。义既两兼。不可偏取。第五门中。先解如是我闻之言。三门辩释。一解如是我闻有之所由。二明立意。三释其文。如是我闻何因缘有。由佛教故。佛何故教。阿难请故。彼何缘请。阿尼楼驮教故。彼何因教。由见阿难心忧恼故。阿难比丘何故忧恼。由见如来般涅槃故。佛将灭度。在双林间。北首而卧。阿难尔时以佛将灭。心怀悲恼。莫能自胜。阿尼楼驮开觉阿难。汝传法人。何不请佛未来世事。徒悲何益。阿难对曰。我今心没忧海。知何所问。阿尼楼驮遂教阿难请佛四事。一问佛灭后。诸比丘等以何为师。二问比丘依何而住。三问恶性比丘云何共居。四问一切经首当置何字。阿难闻之。心少惺悟。受教请佛。佛依答之。诸比丘等以何为师者。当依波罗提木叉为师。若我住世。无异于此。木叉是戒。比丘所学。故说为师。一切比丘依何住者。当依四念处住。何谓四念。所谓比丘观内身循身观。精勤一心。除世贪忧。如是观外身内外身受心法亦如是。是谓比丘所依住处。故经说言。若住四念名自境界。不为魔缚。若住五欲名他境界。为魔所缚。恶性比丘云何共住者。梵檀治之。若调为说离有无经。梵檀是其默不共语。一切经首置何字者。当置如是我闻一时佛在某方某丛林等。由佛本教。故有斯言。言立意者。为生物信。云何生信。言如是者。阿难彰己自信佛语。道佛所说以为如是。令他众生同已生信。言我闻者。阿难自是不足之人。若道此法是我所说。人多不信。道我闻故。人多生信。生信如是。信有何义。而为生乎。信者是其入法初门。摄法上首。凡入佛法要先生信故华严中说信为手。如人有手。至珍宝所随意采取若当无手。空无所获。信亦如是。入佛法者有信心手。随意采取道法之宝。若无信心。空无所得。次释其文。先解如是。于中初先就人以定。然后解释。定之云何。昔来多就阿难以释。阿难所传如佛所说。故名为如。简去相似。故复云是。究寻此言。就佛以释。非就阿难。何以得知。如大智论言。如是者信顺之词。其信者言是事如是。不信者言是事不如是。阿难彰已信顺佛语。名佛所说。以为如是。又温室经初云。阿难曰。吾从佛闻如是。故知阿难名佛所说。以为如是。但方言不同。彼温室经顺此方语。故说从佛闻于如是。余经多顺外国人语。先举如是。后彰我闻。定之粗尔。释之云何。言如是者。解有两义。一约法解。阿难道彼如来所说如于诸法。故名为如。说理如理。说事如事。说因如因。说果如果。如是一切如法之言。是当道理。故曰如是。良以乖法。名为非故。如法之言得称为是。二约人解。阿难道今释迦所说。如于过去一切佛说。故名为如。如诸佛说。是当道理。故曰如是。良以乖佛所说为非。如诸佛说得名为是。言我闻者。阿难对彼未来众生道已餐说。故曰我闻。闻实是耳。云何称我。诸根之别皆我用具。就主以名。故曰我闻。法中无人。云何就主宣说我闻。释言。法中虽无定主。非无假名。绾御众生。故得称我。譬如四兵合以为军。虽无定主。亦得称言我军勇健。我军胜彼。此亦同尔。问曰。阿难得理圣人。以何义故同凡说我。释言。阿难虽复说我。不同凡夫。云何不同。说我有三。一见心说我。谓诸凡夫我见未亡。于此心中称说有我。二慢心说我。谓诸学人我见虽亡。我慢犹在。于此心中宣说有我。三世流布我谓无学人见慢已除。随世流布。称说有我。阿难当于结集法时。身居无学。见慢已除。随世流布。称说有我。是故不同。问曰。无我是胜。有我不如。何不从胜就劣说我。答。化我众生。法须如是。若不说我。何由可得标别彼此。令人识知。是故至佛化我众生。皆自说我。一时已下义虽两兼。对前一向证信序故。今偏就其发起以释。于中初先就佛明处。与大已下就佛明众。时则兼通。前中有三。一明化时。二明化主。三明化处。言一时者。为化时也。释此时中。先叙异说。次辨过非。后显正义。言异说者。昔来相传。言佛说时。阿难闻时更无先后。简去传谬。成上我闻。故云一时。异说如是。辩过云何。先以事征。后以文证。言事征者。阿难是佛得道夜生。佛成道已。过六七日。即便说经。若依大乘。过二七日。佛便说经。阿难尔时犹在怀抱。身不预会。度二十年方始出家。三十年后方为侍者。自斯已前所说诸经。多不亲闻。虽不亲闻。而所集经皆云一时。判知一时非简传之词。又小乘中。不得说言阿难是权。何由得言说听一时。以斯推验。定知人语。不可辄依。云何得知阿难是佛得道夜生。为证此义。须知阿难立字因缘。阿难陀者是外国语。此名欢喜。喜有三缘。一过去因缘。释迦过去行菩萨时。见过去世释迦文佛。父名净饭。母名摩耶。侍者弟子名曰阿难。国土眷属与今不别。因即发愿。愿我当来成得佛道。如今无异。由斯本愿。今得果成。故今侍者还字阿难。二现在因缘。阿难端正。人见皆欢。故字欢喜。三父母立字。父母何缘与字欢喜。喜时生故。何者喜时。佛得道时。如来十九踰城出家。既出家已。五年习定。六年自饿。父王知子身极微劣。常恐不全。菩萨后时知饿非道。受食乳糜。欲取正觉。魔作是念。若佛成道。空我境界。曼道未成。当败其志。遂率官属十八亿万。将诸苦具。来怖菩萨。菩萨尔时入胜意慈定。令魔眷属颠倒堕落。魔既被降。便作是念。菩萨力大。非我能胜。当恼其父。遂便往诣净饭宫上。唱如是言。大王当知。悉达太子昨夜死矣王闻是语从床而堕犹若鱼王热沙所烁良久乃苏念子在家当为轮王何期出家空无所获。未久之间菩提树神以佛道成。遂持天华庆贺父王净饭宫上唱如是言地天太子昨夜道成。明星出时降魔兵众。得成佛道。故以天华。用相庆贺。王闻生疑。向者有天言我子死。今复有天云子成道。何者可信。菩提神曰。我言可信。向者是魔故相恼耳。王便作念。我子在家当为轮王。今日出家为法轮王。彼此无失。向者闻死。今忽闻活。一重大喜。复闻道成。两重大喜。未久之间。王弟斛饭夜生阿难。寅抱诣王。弟于昨夜生此一男。王便对曰。我子成道。汝复生男。众庆并集。与字欢喜。以斯推验。阿难定是得道夜生。何缘得言说听一时。事验如此。次以文证。如转法轮经。宣说阿难结集法时。先升高座。而说偈言。佛初说法时。尔时我不见。如是展转闻。佛游波罗奈。为五比丘众。转四谛法轮。然彼经首亦云一时。彼言传闻。复云一时。明知一时非简传谬。辩过如是。次辩正义。盖乃如来为化之辰。说之为时。化时众多。简别余时。是故言一。此云何知。如彼地经大本之中。云言尔时佛在天中。及其别传。改尔为一。尔时之言不可成上。改尔为一。宁不属下。诸经之中大有此例。如下文中。我于一时在尸首林。我于一时在迦尸国。我于一时在王舍城。我于一时在恒河岸。如是非一。所言佛者。标其化主。此翻名觉。觉有两义。一觉察名觉。如人觉贼。二觉悟名觉。如人睡寤。言觉察者对烦恼障。烦恼侵害。事等如贼。唯圣觉知不为其害。故名为觉。言觉悟者对其智障。无明昏寝。事等如睡。圣慧一起。朗然大悟。如睡得寤。故名为觉。无明有二。一性结无明。迷覆实性。对除彼故。觉穷自实如来藏性。故名为觉。二事中无知。不了世谛。对除彼故。觉知一切善恶无记三聚之法。故名为觉。故地持云。于义饶益聚。非义饶益聚。非义非非义饶益聚。平等开觉。故名为佛。义聚是善。非义不善。非义非非义是其无记。于此悉知。故名觉矣。既能自觉。复能觉他。觉行穷满。名之为佛。自觉简凡。觉他简异声闻缘觉。觉行穷满彰异菩萨。是故独此偏名为佛。在拘尸国等。是化处也。处别有四。一国。二地。三河。四林。游化处中。目之为在。拘尸国者。从城为名。此云软草。阿含经中名曰茅城。力士地者。约人别处。国界宽漫。故复别指。诸力士子生于此处。是故名为力士生地。阿利罗跋提河边。约河别处。生地犹宽。故复辩之。此方翻名金沙河也。娑罗树者。约林别处。河犹宽长。故复曲指此。方翻名坚固林也。冬夏不改。名坚固林。何故在此国树二处。下文自解地河二处当亦有以。文中不辩。不可辄言。有人于此寄事表法。言拘尸城。是仙人城。仙人长命表佛长寿。力士生地表佛大力。不为四魔之所摧伏。金沙河者。表涅槃河有佛性沙。坚固林者。表示如来真身坚固不可破坏。或可如此。但非经说。未可为定。自下第二就佛明众。三门分别。一就佛分别。二就众分别。三就佛众相对分别。为知化相。是故宜须就佛分别。为知所化新旧之异。是故宜须就众分别。为识其文。是故宜须佛众参论。言就佛者。佛现六相。一出声。二放光。三动地。四变林。五净土。六摄光归口。于此六中。先辩正义。后非异说。正义如何通则此六斯皆表灭。与灭为相。于中别分。前三召众。后三起说。就前三中。两门分别。一表灭分别。初一声相。令知灭时及知灭人。第二光相。令知灭处。第三动地。彰灭决定。示灭不贳。二召众分别。初一声相。告灭令知。为使众生恋圣故来。第二光相。令知灭处。并除恼碍。前闻圣灭。有心欲赴。恼碍婴缠。莫能自运。故放慈光。除其恼碍。故下文言。其中众生遇斯光者。罪垢烦恼一切消除。第三地动催令速集。故下大众睹相催集。后三相中亦两门分别。一表灭分别。第一变林。改常住处显圣必去。第二净土。示所归处。彰圣必赴。第三摄光。示化已周。彰灭不贳。二敦励众心起说分别。初一变林。此方众集。见圣犹在。望佛不灭。求法心贳。佛为敦励。变林现灭。以增求心。第二净土。他方众集。见佛犹在。望佛不灭。求法心贳。佛为敦励。变土现灭。以增求心。前虽知灭。谓灭不即。恋情犹贳。受法不殷。故复敦励。摄光归口。彰化已周。示灭在今。令增渴仰。闻法即受。正义如是。次非异说。于中有三。一破多相。有人于此建立七相六种如前。加一现堂。通前为七。若林上现堂。堂为别相。堂下有池。池亦应异。池中有华。华亦应别。池华严堂不可别分。堂为严林。何得为别。故下文中现堂之后。方言尔时娑罗树林种种庄严甚可爱乐。如郁单越欢喜之园明知不别。二破少相。有人于此但立四相。动地净土非涅槃相。故但有四。何故动地非涅槃相。以众哀泣。故令地动。非佛所现。故非灭相。何故净土非涅槃相。净土由于大众心净。非佛所现。又净殊好。故非灭相。若言动地由众哀泣。非表灭相。何故大众见动止悲。相催诣佛。见动相催。何为非相。若动非相。大众因何共相抑止。若言土净。由众心净。非佛所现。全非灭相。何故下言佛神力故地皆柔软。不言由心。若土严净。便非灭相。庄严树林。何得为相。彼得为相。此亦同尔。三破异表。有人说言。第一声相为表灭时。不表余义。声中举时。便名表时。声中道佛将欲涅槃。何为不表。人复说言。光示灭处。不表余义。若尔文中应言众生遇光知处。不应说言众生遇光罪垢烦恼皆悉消除。人复说言。何故变林得表灭者。林白死相。故得表灭。此乃鲜白。非是艾白。故下文言。其林变白。犹如白鹤。甚可爱乐。林白可爱。云何死相。人复说言。净土为欲显说净法。不为表灭。此同前破。严林表灭。净土似彼。何为不表。此是第一就佛分别。第二别就徒众分别。开合不定。或分为二。唯新与旧。离合为三。一列旧众。二列新众。三尔时娑罗吉祥已下总结新旧。文别有五。一明旧众。二声光已下明其新众睹相增悲相催诣佛。三时有无量大弟子下明前旧众睹相增悲。四复有八十百千已下明新众云集。五吉祥已下总结众集。若随众别。有四十八。新旧比丘。兼尼为三。始从一恒乃至十恒。通前十三。二十恒下乃至林白。有二十四。通前合为三十七众。林白已后。梵众新集。并有十方菩萨新来。通前合为四十八也。若分欲天色无色天。并分四方无量无数无边身。众即无限。旧传五十四众之言。一向非是。此第二门就众分别。第三佛众合明之中。文有十二。一明旧众。二声光召新。三明新众睹相增悲。第四如来动地催集。五明诸众见动相催云集佛所。六明如来变林敦励。七重明诸众睹相增悲云集献供。八总结众集。九变土令净。十众因土净普见十方。十一如来摄光。十二众因摄光悲叹流血。下即依此十二段文。次第解释。就初段中。言尔时者。集众时也。谓佛在于拘尸国时。言世尊者。是集众人。佛备众德。为世钦重。故号世尊。与大已下是所集众。以身兼彼。称之为与。大比丘者。标别其众。大者外国名曰摩诃。此翻有三。一名为多。如世多人名为大众。二名为胜。胜过余众。三名为大。旷备高德。比丘梵语。此翻有五。一名怖魔。初出家时。令魔战怯。魔性垢弊。惧他胜己故生怯怖。二名乞士。既出家已。无所贮畜。乞求自活。三名净命。以正乞求。离于邪命。四名破恶。持戒离过。五名净持戒。以离恶故。持戒清净。五中初一就始彰名。中二据次。后二就终。八十亿百千。列其数也。前后围绕。彰其所在。在佛前后。围绕如来。自下第二声光召新。先声后光。音声是语。表召分明。故先出之。二月十五日者。出声时也。垂灭曰临。晨朝出声。后夜当灭。去灭不遥。故曰临也。此说化灭以为涅槃。又复息化归真。亦名涅槃。问曰。何故此时涅槃。下经自释。依阿含经。如来八月八日涅槃。此经下文亦有此相。故下文言。须跋陀罗竟安居已。当至我所。是故我昔告魔波旬。过三月已。吾当涅槃。今言二月十五日者。当是见闻不同故尔。以佛神力。明出声人。亦得名为声发所由。此是如来如意通力。非余通等。通有几种。而言非余。通有四种。一是幻通。转变外事。二如意通。运变自身。大音普告。三法智通。通达诸法。四圣自在通。能于苦中生于乐想。于乐事中生于苦想。苦乐法中生不苦乐想。不随缘变名圣自在。今出大音。是其第二如意通矣。出大音下正明出声。出大音声。是其总也。音谓言音。谓梵汉等音体是声。下别显之。大有三义。一宽远故大。二普告故大。三说大事故名为大。其声遍满乃至有顶。是其初大。傍遍余方。上极有顶。悲想是其三有之穷。故曰有顶。上明所至。余略不辩。当知十方随所至处。皆从阿鼻。上至有顶。非独此界随类普告。第二大也。梵中梵语。汉中汉言。名随类音。此乃一音令人异解。非作多音。有缘齐悟。故曰普告。今日已下第三大也。于中有二。一告圣今灭。为令众生恋圣故来。二举疑劝问。欲使众生为益故集。又唱圣灭。欲令众生献供请住。以摄功德。举疑劝问。为使众生云集请法。以生智慧。前唱灭中言今日者。告示灭时。言如来等。告语灭人。将欲涅槃。告其灭事。人中如来应正遍知。是自利德。乘如实道来成正觉。故曰如来。应者是其应供之号。诸过永断。证灭相应。故名为应。又应供养。亦名为应。正遍知者。理无偏邪。故名为正。于理穷照。称曰遍知。自德无量。且举此三。怜愍已下是利他德。初怜愍等显利他相。大觉世尊举利他号。利他相中。怜为慈怜。愍为悲愍。此二内心。覆者覆令善法增长。护者防护使其离恶。此二外相。等视众生显前怜愍。等视正辩如罗睺罗。类以显之。为作归等。显前覆护。作归法说。屋等喻况。利他号中。大觉佛号。言世尊者是世尊号。化德无量。略举此耳。将欲涅槃。是告灭事。垂灭曰将。下劝问中。一切众生有疑悉问。彰己无偏。欲令齐问。举一齐余。故名一切。众法成生。故曰众生。又多死生。亦名众生。有疑须决。故悉可问。为最后问。显己定灭。欲令必问。何故此中无众悲叹。乍闻唱灭。必未审定。悲恼相微。为是不说。又设有悲。悲相同后。故不别论。光明之中。初明如来放光普照。其中已下。明诸众生蒙光获益。初中。尔时放光时也。言世尊者。放光人也。于晨朝时。重复明时。日时宽长。故复曲指。从其面门。明放光处。口是面门。何故此放。佛一一相备含多用。宁可具责。又复如来面门放光多为授记。下说众生皆有佛性悉当作佛。即是普授众生记别。故此放之。下明放光。放种种光。总以标举。其明杂色。总显其相。青黄赤等。别以显之。别有六色。光遍已下辩光分齐。近照三千。远至十方三千世界。如论中说。千四天下合之为一。名小千界。数小至千。复合为一。名中千界。数中至千。复合为一。名为大千。此三千界名世界刹。同时成坏。故合为一。光今遍之。人言此光与下所摄光相别异。云何知异。此六彼五。故知不同。此照十方。下但覆会。明知别异。计应无别。何以得知。下文说言。所放光明还从口入。自下更无放光之处。故知是一。若尔。何故此六下五。一义解云。颇梨玛瑙为一杂色。故下说五。外国相传。所放光中。摄五留一。以通正法。故下说五。或可如此。何故此中云照十方。下言覆会。盖随所照众生故尔。此中所照众生未集。故随所照。言至十方。下众皆集。故随所照。云言覆会。若下所摄唯覆一会。何故下言必于十方所作已辩。将是最后涅槃之相。既言十方所作已辩。明与此同。下明众生蒙光益中。其中六趣。举其所益。谓前光明所照之中六趣众生皆得益也。人天修罗及三恶道为因所向故名六趣。道别不同故亦名道。经或说五。离合故尔。六中修罗摄入何道。经论不同。依毗昙论。摄入鬼道。依法念经。摄入鬼畜。如彼罗睺阿修罗王。是师子儿。名为畜生。依伽陀经。是天鬼畜三趣所摄。毗摩之母。天女所生。名之为天。是故经言汝本是天。又复经中名为劣天。今此利分以为六趣。遇斯光者简去无缘。罪垢烦恼。一切消除。正明利益。罪名罪报。即是报障。垢是业障。烦恼即是烦恼障也。遇佛光故。三障皆除。亦可罪垢是其恶业。业与烦恼。遇光皆灭。自下第三明其新众睹相增悲。是诸众生。举悲哀人。见闻是已。生悲所由。见光闻声。名见闻已。下显悲相。心大忧恼。意业憔恼。举声啼等。口业伤叹。举手拍头。身业悲恼。身恼不同。或有悲切不能自裁。举手拍头。捶胸大叫。或有自抑内心难忍。身体战栗。涕泣哽咽。问曰。何故拍头捶胸。有人释言。拍头显己失于导首。捶胸彰己心胸不畅。未必如此。盖乃世人悲怨之相。世人悲怨相别种种。或有拍头。或复捶胸。或有拍手。或时拍颊。或复蹋地。何必一一别有所表。自下第四动地催集。言尔时者。动地时也。下正明动。大地山海皆悉震动。彰大异小。故下文言。独地动者名为地动。山河海水一切动者名大地动。是中略无动地所由。若具应言。以佛神力故地震动。自下第五明诸大众见动相催云集佛所。于中有三。一明诸众见动相催。二时有无量大弟子下明其旧众睹相增悲。三复有八十百千已下明新众云集。初中有三。应上三相。初应地动相催诣佛。二互相执下应前光相而为伤叹。三复作是言世间空下应前声相重为伤叹。初中有二。一共相抑止。且各裁抑莫大愁苦。若不诣佛。徒悲无益。故相抑止。望留圣住。未敢专决。故言且抑莫大愁苦。二当疾往下共相驱催。三相频现。圣灭不赊。故须疾诣。头面礼等明催所为。为请佛住。礼敬身请。头面己尊。佛足彼卑。以己至尊。礼接彼卑。显敬殷至。劝下口请。请佛住世一劫及减。有人释言。请住一劫为显满字。请减一劫为表半字。此何必尔。若此大众已知满字。便解佛常。何劳请住。盖乃大众自许之词。多望一劫。脱若不遂。望灭一劫。下应光相。于中有三。初相执手共相开慰。同失所尊。故相执手。二复作言下发言伤叹。世间虚空。伤失所尊。时中无佛。故言世空。众生福下伤己失利。由佛灭度。无人教善。故生福尽。无人示恶教令裁断。故不善业增长出世。十恶是其不善诸业。恶本性成。加以现起。故言增长。流行世间。名为出世。非是增长过出世法。何故此中为此伤叹。前蒙佛光。罪垢消除。圣若一去。我等罪业谁能复灭。故为此叹。三仁等已下共相驱催。速往速往正相。驱催不久。必入须速。所以下应声相而为伤叹。复作是言。世空世空。伤失所尊。何故重言。人言。前空伤失如来。后空失法。当应不然。直是大众怨嗟之深。重言空耳。如世间人。得称意事。快哉快哉。得违意事。祸哉祸哉。何必重言即有异表。我等已下伤己失利。我等从今无救护等。对上声中怜愍覆护而为伤叹。一旦远下。对上声中举疑劝问而为伤叹。前中初言我等从今。明无救时。先来有师。失荫在后。故言从今。无有救护。无离恶处。现恶无救。当恶无护。无所宗仰。无集善处。言贫穷者。彰无宗损。谓无法财。言孤露者。显无救失。无人救护。所以孤露。后中初言一旦远者。就始为言。设有疑佛断。后疑不定。故言设有。当复问谁以除疑也。此三段中。初应地动共相抑止。后二略无文之隐显。第二段中。共相开慰。余二略无。亦是隐显。初二段中。共相驱催。后一略无。亦是隐显。后两段中。发言伤叹。初段略无。亦是隐显道理齐等。自下第二明其旧众睹相增悲。云何知此是前旧众。文不说来。故知旧众。下简未集。不简此众。故知是旧。以是旧故。六卷经中全无此文。问曰。憍梵佛灭度时。在忉利天。文不说来。下亦不简。而非旧众。今此所辩。何必不然。释言不同。依大智论。佛灭度后。结集法时。唯说憍梵在天不来。遣人往唤。唤亦不来。不言更有。故知不同。时有无量诸大弟子。标别其人。学在佛后。故名为弟。从佛化生。故复言子。迦旃延等列其名字。遇佛光下睹相增悲。先别。后结。别中遇光其身战等。身业不安。心浊意恼。发声大唤。口言伤叹。如是下结。问曰。罗汉已离坏苦。何故悲恼。释言。罗汉于世法中。忧悲已断。于佛境界。不能自裁。故生悲恼。其犹迦叶及阿难等。世间五欲不能倾败。大树紧那鼓琉璃琴。摩诃迦叶不觉起舞。阿难比丘不觉歌吟。大树紧那是其菩萨。上人五欲。小乘不堪。此亦相似。亦可现悲。生众恋意。自下第三新众云集。何故须集。所为有八。一为请住。故上文言疾至佛所。劝请如来莫般涅槃。二为献供。故下诸众辩供奉佛。三为阇维。故下文言为欲阇毗如来身故。四为决疑。故下文言并可礼敬请决所疑。五为显法。故下文言为显如来方便密教。六为众生。故下文言为益众生。七为论难。如下文中十仙云集。八为观看。如律中说。佛灭度后。摩诃迦叶见一尼干手持天华寻路而行。问从何来。尼干对曰。从拘尸来。见世尊不。答言我见。平安已不。答言。灭来已过七日。我从彼会持此华来。如是等辈。直为观看。来意如是。今此所列具前六意。所以来集。文中初先随数多少。渐增以列。二十恒河大香象下乱列诸众。前渐增中。初列道众。四恒已下明常流众。道众德尊数少故先。常流行卑数多故后。道法众中。先列出家。后列在家。以出家者形尊数少。是故先列。在家形卑数多故后。出家众中。先列声闻。后列菩萨。诸经多尔。何故而然。泛解有四。一远近分别。声闻之人常随如来。因明佛后。随近先列。如上所列比丘众是。菩萨不尔。故在后论。何故声闻多近如来。释有两义。一声闻智劣。未闲道法。虽得圣果。进止威仪常须佛教。是故如来乃至灭度常为制戒。二声闻众现蒙佛度。舍凡成圣。荷恩深重。虽得漏尽。常随供养。故近如来。菩萨两义。故不近佛。一智解殊胜。深闲道法。不假佛教。二随感现化。故不近佛。此是第一远近分别。二形相分别。声闻之人。执持威仪。形相端严。世共尊敬。故列在先。菩萨随化。身无定准。形仪不整。故列在后。三就德分别。亦得名为约教分别。如龙树说。教有二种。一秘密教二显示教。秘密教中。菩萨德尊。理应在前。如华严经。显示教中。罗汉辟支同佛漏尽。人多重敬。宜在先列。菩萨随化。现处诸漏。若闻菩萨在罗汉上。人多惊怪。故列在后。如大品等。今依显示先列声闻。四就数分别。声闻众少。故列在先。菩萨众多。故彰在后。虽有四义。此中具依后三释之。声闻众中先列比丘。后列尼众。比丘人尊数少故先。尼众形卑数多故后。比丘众中文别有三。一列众叹德。二睹相增悲。三云集佛所。就初段中。先列其众。举数辩众。文显可知。下叹其德。初先总叹。次别。后结。皆阿罗汉是总叹也。罗汉梵语。此名无生。随义傍翻。亦名无著。无生报亡。无著因尽。心得下别。别中初先叹其德备。加栴檀下叹其众纯。叹德备中。准下叹尼。最初少一诸漏已尽。通其所少。文别八句。句虽有八。体唯有四。所谓四智。前四正叹。后四重显。所少漏尽。明我生尽。准毗婆沙。生尽即是断集之智。故尽诸漏。名我生尽。心得自在。明梵行立。依毗婆沙。是修道智。道行成满。进任从意。名心自在。所作已辩。即是所作已辩智也。依毗婆沙。是证灭智。证灭功成。名所作辩。离恼是其不受后有。准毗婆沙。是断苦智。今言离恼。举因显果。由离恼故不受后有。此之四义广如后释。调根显初诸漏已尽。从眼至意。生识名根。善调诸根。故不生漏。如龙有威。显前自在。成慧显前所作已辩。斯乃成就众生空慧。逮得己利。显前离恼。烦恼损己。故离烦恼名为己利。逮名为至。亦曰及矣。下叹众纯。有行共俱。故如檀林栴檀围绕。备断同聚。如师子王师子围绕。行德普熏。其犹栴檀。断德摧恶。状同师子。上来别叹。成就下结。成无量等结叹前德。一切皆等结叹前人。从佛化生。名佛真子。第二睹相增悲之中。初明见光。次相驱催。后增悲哽。恋情深重。沸血将出。故体血现如波罗华。六卷经云。如日初出。照青树叶。赤脉皆现。自下第三云集佛所。于中先明集之所为。为益众生。句别有五。为欲利益安乐众生一句是总。中三是别。成就大乘第一空行。大乘法化。大乘离相。故名空行。显发如来方便密教。小乘法化。无小权施。故名方便。权言覆实。名为密教。为不断绝种种说法。世间法化。世行参差。名为种种。亦可此三同成大乘。成就大乘第一空行。令其入证。显发已下令入阿含。显发密教。令知昔权。弃而不从。不断说法。令修今实。是义云何。由诸比丘集诣佛所。佛教修学大乘空行。他闻同入。故令他成。由其诣佛。佛对破小。彰昔是权。论昔覆实。名显如来方便密教。由其诣佛。佛教修习大乘诸行。名为不断种种说法。为生调伏一句总结。上来五句明集所为。疾至佛所。正明云集。稽首佛等。到已设敬。列尼众中。先实后权。实中三分。与比丘同。就初段中。先列其众。列名举数。辩众可知。下叹其德。一切亦是。大阿罗汉。是总叹也。诸漏已下是别叹也。别中准上。文少不足。前比丘中先叹德备。后叹众纯。今此略无叹众之文。就叹德中。准叹比丘。末后少一逮得己利。通其所少。文亦八句。所叹四知与上无别。诸漏尽者。烦恼连注。其犹疮漏。故名为漏。漏别有三。所谓欲有无明漏等。下当具辩。三漏非一。是故言诸。无学断竟。名之为尽。余如前释。亦于晨下睹相增悲。亦欲利下云集佛所。文如上说。明权众中。于尼众中复有诸尼。皆是菩萨。拂权显实。人中龙下就实叹德。先叹自德。人中之龙彰其人尊。龙是一切畜生中上。此诸尼等。人中最胜。与龙相似。约喻名人。名人中龙。位阶已下明其位极。位阶十住。简异前九安住不动简异初住。下叹利他。为化现女是化他身。常修无量是化他心。四无量义。下当别论。得自在力能化作佛。是化他能。通力自在。故能作佛。次列菩萨。文亦有三。与比丘同。初中有四。一列其众。二略叹德。三列其名。四广叹德。初列众中。一恒举数。菩萨摩诃萨者。标其众别。菩萨梵语。此方翻之名道众生。此人求道。内怀道行。以道成人。名道众生。问曰。二乘之人并皆求道。斯有道行。何故菩萨独得其名。释言。贤圣。名有通别。通则须陀乃至诸佛。名同无别。如下文说。别则各异。今为分别。贤圣不同。故此菩萨偏得名为道众生也。何故如此。释有三义。一就愿心望果分别。唯此众生求大菩提余悉不求。是故独此名道众生。故地论言。上决定愿成大菩提。偈言菩萨故。二就解心望理分别。凡夫著有。二乘住无。有无乖中。不会中道。是故不得名道众生。唯此菩萨妙舍有无。契会中道。是故独此名道众生。三就行分别。入佛法中有三种门。一教。二义。三者是行。教浅义深。行为最胜。声闻软根。从教为名。声者是教。餐声悟解。故号声闻。缘觉次胜从义立称。缘者是义。于缘悟解。故名缘觉。菩萨最胜。就行彰名。以能成就自利利他俱利之道。故名菩萨。故地持云。声闻缘觉但能自度。菩萨不尔。自度度他。是名道胜。以道胜故。名道众生摩诃萨者。此翻名大。大有三种。如地论说。一者愿大。期大菩提。二者行大。旷集诸度。三利众生大。四摄等益。人中龙下第二略叹。先叹自德。方便现身叹利他德。第三列名。名别可知。其心皆下第四广叹。广中初别。成如是下总以结叹。别中叹其三世功德。先叹现德。次过。后未。此三世中。皆叹自利利他之德。就现在中。先叹自德。句别有五。前四摄法。后一护法。就前四中。敬重大乘。是自分始。乘者是其行之功用。行能运通。名之为乘。乘别有三。所谓声闻缘觉佛乘。诸佛所乘。前二不加。故名为大。安住大乘。是自分终。修成不退。故曰安住。深解大乘。是胜进始。于未修处。观照分明。故曰深解。爱乐大乘。是胜进终。于前所解。乐欲修行。上来摄法守护大乘。是护法行。不令他人诽谤毁灭。故言守护。是义如下金刚身品具广分别。上叹自德。下叹利他。善随世间。世间法化。世间有二。一众生世间。二器世间。今此善随众生世间。众生云何得名世间。世者是时。间者名中。所化众生不出时中。故名世间。作是誓下出世法化。已于过下叹过去德。先叹自利。已于过去修持净戒。是离恶行。善持所行。是摄善行。解未解下叹利他德。解未解者小乘法化。绍三宝等大乘法化。此如华严明法品说。彼有三番。能令众生发菩提心。令佛宝不断。开示演说十二部经甚深法藏。令法宝不断。受持一切威仪行法。令僧宝不断。其第二番赞叹大愿。令佛宝不断。分别显示十二缘起。令法宝不断。修六和敬。令僧宝不断。其第三番。下佛种子于众生田。生正觉芽。令佛宝不断。护持法藏。不惜身命。令法宝不断。善御大众。心无忧悔。令僧宝不断。此三番中亦有阶降。先就佛宝。彰其阶降。初番能令发菩提心。起求佛愿。第二番中赞大愿者。赞起行愿。令其修习。第三番中下佛种子于生田者。化成行种。次就法宝。彰其阶降。初番演说十二部经。是其教法。第二番中显示缘起。是其理法。第三番中护持法者。是其行法。下就僧宝。彰其阶降。初番受持威仪法者。僧行方便。第二番中修六和者。行成不乖。第三番中善御大众。德熟摄他。下叹未来。于未来世当转法轮。是利他德。未来成佛。故能转法。以大严等。是自利德。谓以功德智慧庄严。而自严也。上来别叹。下总结之。成如是等结前自利。等观生下结前利他。上来第一列众叹德。增悲云集。并同前释。问曰。何故上来诸众不明献供。以出家者无为法住。无所贮畜。故无奉献。自下次明在家二众。以优婆塞形尊数少。故在前列。优婆夷等形卑数多。彰之在后。优婆塞中文别有四。一列众叹德。二于晨朝下辩供奉佛。三世尊知下如来不受。四不果却住。此之四分。诸众多同。宜审记知。初中有四。一列其众。二恒举数。前说一恒。今增说二。问曰。现观人类不多。今此何故独优婆塞有其二恒。余众渐多。释言。今此三千同聚。故有二恒。又随报别。一处之中有多种人。斯皆云集。故有二恒。如法华中。众生见劫尽。大火所烧时。天人常充满。如是等也。下诸众中恒数渐增。其例皆尔。诸优婆塞标别其众。此云近住。近善而居。亦名善宿男。怀善而住。名为善宿。又亦名为清信士也。二受持下略叹其德。受持五戒。明离重过。威仪具足。彰离轻罪。五戒是其在家正行。故偏叹之。三其名下列其名字。四深乐已下广叹其德。于中初叹护烦恼行。亦欲乐下叹护小乘行。护烦恼中。初总。次别。后总结之。深乐观察诸对治门。是其总也。此下所观皆能治过。故名治门。所谓下别。治门无量。今此略举六种门矣。初苦乐等。是八修门。观生死法。无常苦等。观涅槃法。常乐净等。二实不实者。是二谛门。真谛为实。世谛不实。三归非归。是忻厌门。归向三宝。名为归依。背离邪法。名非归依。亦可趣向出世涅槃。名为归依。连背生死。名非归依。四生非生者。是假实门。五阴非生。所成假人。名为众生。五恒非恒等。是因果门。恒与非恒。是其果门。涅槃是恒。生死非恒。安与非安。是因行门。善行是安。恶行非安。亦可无漏圣行是安。有漏非安。六为无为等。是四谛门。为无为者是其苦谛。有为是苦。色法心法非色心法。是有为也。无为非苦。相对故来。虚空数灭非数灭等。是无为也。断者是集。可断名断。不断非集。相对故来。涅槃是灭。非涅槃者相对故来。增上是道。以殊胜故。非增上者相对故来。常乐已下第三总结。护小乘中。初别。后结。别中唯叹现未功德。不叹过去。以优婆塞迹居近行。故略不叹。就叹现中。自他并叹。文有三对。初对行始。第二行次。第三行终。亦欲乐闻无上大乘。是自利始。对前称亦。如闻为他。是利他始。此是初对。善持净戒。渴仰大乘。是自利次。持戒离过。渴大修善。既自充足。复充余渴。是利他次。此第二对。善能摄等。是自利终。句别有三。前之两句明摄法行。摄无上智。求大果也。爱乐大乘。学大因也。亦可摄取无上智慧求于证法。爱乐大乘求于教法。守护一句是护法行。善能随下是利他终。善随世间。世间法化。度未度等小乘法化。度未度者令度苦果。解未解者令断集因。绍三宝等大乘法化。此第三对。下叹未来当转利他。以大严等是其自利。以大庄严是摄善行。深味净戒是离过行。上来别叹。下总结之。悉能成等结前自利。于众生等结上利他。自下第二辩供养佛。以在家者。有供可奉。故下辩之。文别有四。一辩诸供具。二复作念如来今者受我供下。念佛受已当入涅槃。心怀悲恼。三各各赍下持供奉佛。四举声号下哀请佛受。前中有二。一财供养。二各作是念一切众生若有乏下明行供养。财中有八。一辩香木。二具宝幢。三持宝盖。四作众乐。五擎妙华。六赍众香。七备食具。八严处所。就初段中。亦于晨朝。辩木时也。为欲阇毗。辩木所为。此云焚尸。人人各取。正明辩木。其栴檀等是其木体。光香华幡。严木之事。车马二种运木之具。第二宝幢加以网严。第三宝盖杂以华饰。是华台中多有黑蜂。何故在此。蜂多依华。何故云黑。人言为表无明众生容有所表。文中不说。不可辄定。何故道此是蜂出声。有所陈说。所以举之。伎乐华香。文别可知。第七食中。为佛及僧辩食是总。下别显之。香薪德水成食之缘。苦酢辛等食之体味。下有三德。显食殊胜。成食缘中。八功德水之所成者。清净不臭。轻冷软美。饮时调适。饮已无患。是其八也。清净色入。不臭香入。轻冷及软。此三触入。美为味入。后二法入。此八是其水之功能。水家之德。故名功德。食体味中。六味总举。苦等列名。下说甜酥。八味具足。今此言六。其义何耶。然六与八离合言耳。合即说六。离即为八。分甘为三。一不苦名甘。翻对苦味。二不酢名甘。翻对酢味。三不辛名甘。翻对辛味。其犹咸淡二味相翻。外国语中应有别名。此无异称。通说为甘。后三德中先举后列。言轻软者。是食功能。食之令人身轻体软。言净洁者。食体精纯。无余秽污。言如法者。受用顺道。非酒肉等。第八处中。先到。后严。初严其地。次座。后树。诸优婆塞现居人报。安能严座如须弥山。释言。此等虽居人位。并是出世不思菩萨。故能如是。又是如来三昧法门之所示现。故能如此。下皆同尔。上来等一明财供养。下明行供。亦名法供。地持名为至处道供。于中有三。初作是念。一切众生若有乏等。念众生心。二作是施时离欲嗔等。护烦恼心。三无余思下求菩提心。无余思惟。求世福乐。唯期菩提。求佛果也。皆已安住于菩萨道。具佛因也。又复前句是求佛愿。皆以安等是求佛行。上来第一辩诸供具。复作念下是第二段。念受当灭。心怀悲恼。各各赍下是第三段。持供奉佛。举声号下是第四段。哀请佛受。初先号泣。复相谓下发言伤叹。便自举下正请佛受。举身身请。而曰口请。上来第二辩供奉佛。自下第三如来不受。言知时者。不受所以。知今非是受供之时。故曰知时。何者受时。受时有二。一许受时。纯陀章中。二正受时。大众问品。前许受时显示佛常。后正受时显涅槃常。今非彼时所以不受。言默然者。明不受相。何故须默。如来大人。体道少欲。若受不受多皆默然。云何可别。现相令知。言不受者。正明不受。释意有四。一欲令诸众齐有献奉。故此不受。若受此供。余众绝意。何敢更献。二为使纯陀献供显法。故此不受。若受此供。纯陀何敢更生献意。三欲令诸众于施重心。故此不受。至后大众问品之中。方为受之。四于此处未对纯陀显佛常义。恐彼诸众施无所趣故此不受。下对纯陀显常已竟。众问品中等为受之。今对此供不受既然。下余众中不受例尔。自下第四不果却住。初先不果。后悲却住。于中初法。次以喻显。供佛善根可爱如子。如来不受。名病丧亡。所设虚弃。名送冢间。无善复本。名为归还。施心不申。名为怅恨。下合可知。优婆夷中。文亦有四。一列众叹德。二辩供奉佛。三如来不受。四不果却住。初中有四。第一列众。三恒举数。诸优婆夷标别其众。此云近住女。亦云善宿女。义同前释。二受持下略叹其德。亦如上解。三列其名。四广叹其德。于中初别。后总结叹。别中有四。初能堪任护持法等。护小乘行。二呵责家法。护烦恼行。三自观下广护烦恼。四深乐下广护小乘。初中悉能护持正法。是护法行。为度已下是摄人行。第二段中呵家法者。呵责自家五阴身法。呵义如后。第三段中。文别有二。一观过生厌。二以是缘下修治断除。前中初先观身五过。宁以牛下二事显失。是故当下总结生厌。初观过中。先观身苦。观身如蛇。是其内苦。譬如四蛇性相乖反。四大如是。地坚而重。风动而轻。水湿而冷。火燥而热。各相乖反。故如四蛇。诸虫唼食是其外苦。苦别无量。略举此二。是身臭下观身不净。不净有五。一种子不净。现在父母精血为种。过去烦恼结业为种。二住处不净。在母腹中。生藏之下。熟藏之上。安置己体。三自体不净。三十六物共成己体。四自相不净。九孔常流。五毕竟不净。此身死已。虫食成粪。火烧为灰。埋之为土。至竟无净。今此文中略举三种。身臭贪缚。种子不净。现在父母精血为种。故身臭秽。过去贪爱烦恼为种。名贪狱缚。身如死狗。自体不净。九孔常流。自相不净。两眼两耳。两鼻及口。大小便道。是九孔也。身如城下。观身无我。于中初先当相观察。寄托城喻。明身虚假。文相可知。如是身城诸佛弃下。寄人显法。诸佛弃舍。彰实无我。凡愚常味贪等止住。明着是痴。又佛弃舍。举圣呵凡。凡愚味着。责凡异圣。是身不坚。如芦苇等。观身是空。下观无常。初先正观。谁有智下寄圣显过。前中泛论无常有三。一分段无常。六道果报。三世分异。二念无常。念念迁谢。三者自性不成实无常。有法虚集。都无自性。今略论二。是身无常念念不住。是念无常如电光等。喻以况之。是身易下分段无常。是身易坏如河岸等。观生易死。先法后喻。不久已下观死易至。上来正观。谁有智者当乐此身。举圣不乐。明身可厌。上来第一观身五过。自下第二二事显失。两义释之。一难易分别。牛迹盛海。丸地如枣乃至如尘。是事至难。犹可为之。具说身过。毕竟叵得。二多少分别。大海深广。牛迹盛之。数亦可尽。大地宽广。丸之如枣乃至如尘。数亦可尽。身患多彼。具说叵尽。是故当舍。如弃涕唾。是第三段总结生厌。上来第一观过生厌。以是缘下修治断除。以是观身多过因缘。故修空等而为对治。空无相愿。广如别章。就第四段广护小中。叹其现在未来功德。不叹过去。义同前释。现中叹其自利利他。文别三对。初对行始。第二行次。第三行终。深乐咨受。自行始也。闻已演说。利他始也。此是初对护本愿等。自行次也。护持本愿。守菩提心。毁呰女下起菩提行。先厌有为。次忻无为。厌有为中。毁呰女等现过能厌。破坏生等当过能灭。渴仰大乘是趣无为。既自充下利他次也。此第二对。深乐大下是自行终。深乐守护。就实叹德。深乐还是摄法之行。守护还是护法之行。虽现女下拂权显实。善能随下是利他终。善随世间世间法化。度未度等小乘法化。令度苦果。解其集因。绍三宝下大乘法化。此第三对。叹未来中。当转利他。以大严等叹其自利。以大庄严是摄善行。坚持禁戒是离恶行。上来别叹。下总结之。皆悉成等结前自利。于诸生等结上利他。上来第一列众叹德。后三可知。上明道众。下列常流。先列离车。以此人供多前少后。故次列之。文别有四。一列众叹德二辩供奉佛。三如来不受。四佛力住空。就初段中。先列众。次叹德。后列其名。初列众中。四恒举数。离车辩众。离车梵语。有人传释。此名迭治。是其王种。迭治国事。故云迭治。下列诸王。过于五恒。夫人七恒。王种应多。今此何故但有四恒。有缘者来。无缘不集。多少何定。次叹其德。先别。后结。别中有三。一护法行。二愿令我下明护法愿。三常欲乐下明护法心。此三段中。皆利自他。护法行中。为求法故善修戒等。是摄法行。此即自利。摧伏异等是护法行。此即利他。摧伏异学坏正法者。是摧邪行。异学外道邪见无信。怀正内学。破戒无行。并以王力而摧伏之。常相谓下是通正行。常相谓言相率弘法。当以金等。舍财通道。供人使学。故令甘露久住于世。佛法能除烦恼燋渴。故如甘露。宽广难穷。名无尽法。润邃叵测。名深奥藏。护法愿中愿我常学。是摄法愿。此即自利。诽谤已下是护法愿。此即利他于中四句。前二罚恶。后二赏善。前罚恶中若有谤等。外道毁正。断舌令息。若出家等内学犯戒。罢以清众。下赏善中有能乐等。在俗有信。敬事若尊。若有僧下出家有行。喜助如亲。故令得力。护法心中常欲闻等。是摄法心。即是自利。亦为人说。是通法心。即是利他。上来别叹。下总结之。列名可知。此初段竟。次二可解。第四段中初明离车。不果悲恼。后以佛力令其住空。何故而然。以诸离车专情护法。护法功高。故令住空使人仿习。七多罗者。一多罗树去地七仞。一仞七尺。一树合有四十九尺。七树合有三百四十三尺。次列大臣及诸长者。亦以人供多前少后。故次列之。文亦有四。一列众叹德。辩众叹德。列名可知。二辩供奉佛。五倍前者。当应望彼最初说五。三如来不受。四佛力住空。此亦护法。故令住空。次列诸王。亦以人供多前少后。故此列之。文别有六。一列其众。二辩供具。三叹其德。四持供奉佛。五如来不受。六不果却住。就初段中。先明所集。除阿阇下简所未集。世上杀父。愧惧情深。故此未来。下列其名。以何义故。不列其数。当以诸王过于五恒。不满六恒。分齐难彰。故隐不列。第二可知。第三叹中。先自后他。自中四句。前之两句舍邪归正。后之两句弃小学大。利他可知。后三易解。次列夫人。亦以人供多前少后。故此列之。文别有四。一列众叹德。二辩供奉佛。三如来不受。四不果却住。初中有四。一列其众。二叹其德。三列其名。四重叹德。初列众中。七恒夫人。正列所集。除阿阇下简所未集。世王未至。夫人亦尔。随王未来。第二叹中为度现女。是利他德。常观身等。是自利德。列名可知。第四叹中。初明自利。安住摄善。修戒防恶。怜下利他。后三可知。次列天女。文别有六。一列其众。二作是言下详宜献奉。三叹其德。四辩供奉佛。五如来不受。六不果却住。初段可知。第二段中。初相告劝。观他所设。我等亦下自欲献奉。于中有四。一许有奉献。二念佛受已。当入涅槃。显必须为。三明最后。供佛至难。彰必须作。四举如来灭后世空。明今应供。第三叹中。先别。后结。别中叹其现未功德。不叹过去。义同前释。现中叹其自利利他。文有三对。初对行始。第二行次。第三行终。爱乐欲闻。自利始也。闻已为人。利他始也。此是初对。渴仰大乘。自利次也。既自充下利他次也。此第二对。守护大等。自利终也。于中先明摄善之行。此以护法为摄善行。守大是总。若有异下别显护相。持戒仪具。是离过行。善能随下是利他终。善随世间。世间法化。度未度等。出世法化。此第三对。下叹未来。当转法等是其利他。以大严等。是其自利。上来别叹。下总结之。成如是德。结前自利。等慈生下结上利他。第四辩供奉佛之中。文别有四。一严辩供事。供事有十。所谓香木。盖。帐。幢。甘膳。伎乐。床座。灯。华。二念佛将灭。心怀悲恼。三为生诣佛。文同前释。四请佛受供。后二可知。龙等众中。多先列众。次辩供奉佛。后如来不受下不果却住。文显可知。上来随数渐增。以列二十恒河。大香象下乱列诸众。尔时阎浮比丘及尼一切集者。与上何别而复列之。前唯无学。此通上下。凡圣皆集。故云一切。唯除迦叶阿难众者。阿难林外为魔所娆。故此未至。迦叶后来。佛现双足。广益多人。故此未集。问曰。如来般涅槃时。憍梵波提在天不来。何故不简。释言。迦叶及与阿难。今虽未至。后必当来。故此简之。憍梵在天。毕竟不来。故今不简。如此流例亦应非一。此第五竟。自下第六如来变林以敦众心。何故须尔。新众既来。见佛犹在。望圣不灭。恋情容赊。故佛变林。表灭敦励。文中初辩。次类。后合。辩中初先变林令白。明是鲜白。故说如鹤。何故现白。人言白色。是树死相。为表圣灭。此如前破。又人复云。白是色本。显佛归本。或容可尔。但非经说。未可专定。次现宝堂。映发双林。人亦就此。种种异表。难知且止。下现泉池。妙华盈满。映饰宝堂。类合可知。准此合文。定知林堂非是别相。现堂之后方言树林。种种庄严甚可爱等。自下第七重明诸众睹相增悲。献奉供养。于中有二。一明此方所集诸众。睹相增悲。献奉供养。二尔时东方去此已下。明他方众云集献供。就初段中。先明睹相。皆悉悲感。是增悲也。名前变林。为涅槃相。下明献供。问曰。此等是前众不。释言。欲天及阿修罗。是上所列天及修罗二众所摄。今复举之。故前文中标列四王。今复重举。余亦如是。梵众新来。如下所列。欲天修罗既是前众。何故至此。方论献供。释言。此等向前空来。既至双林。见众施设。方生献意。故此列之。故下相谓。汝观人天。大设供养。我等亦供。亦可前者人供俱来。其中人供。渐次增者。前即具列。或有人多而供减少。或复人少而供增多。前列不便。故此辩之。于中有六。一明欲界地天献供。二明欲界空天献供。三诸梵献供。四毗摩质多修罗献供。五魔王献供。六大自在天王献供。此等随供。渐增以列。初中有三。一四王帝释详议献奉。二四王献供。三帝释献供。初中汝等观天人等。观他施设。我等亦下。自欲献奉。若我最下举益相观。四王献中。先标供主。须弥四面有四那干呵罗山。去地四万二千由旬。纵广亦尔。上有四王。东方天王名提头赖吒。此云持国。领诸天众并乾闼婆及毗舍阇二部鬼神。南方天王名毗楼勒叉。此云增长主。领诸天众并鸠槃荼及薜荔多二部鬼神。西方天王名毗楼博叉。此云杂语。领诸天众及龙富单那二部鬼神。北方天王名毗沙门。此云多闻。领诸天众及夜叉罗刹二部鬼神。是故向前鬼神王中。列毗沙门。此等四王今来献奉。所设已下辩供奉佛。倍过前者。倍过上来一切所设。下佛不受。不果却住。帝释献中。先标供主。释提桓因。忉利天王此翻名为能为天王。三十三天。兼列其众。须弥顶上有其三十三处之别。当中释居。面各八国。臣民所住。故通说为三十三天。次明献供。倍过前者。倍过四王。亦可倍前一切所设。如来不受。不果同前。乃至第六所设已下。是其欲界空天献供。始从夜摩。乃至他化。皆来献奉。文相可知。诸梵献中。文别有五。一总明梵众。一切来集。上至有顶。一切来者。所谓至于色界有顶。无色无形。所以不说。亦可上至非想有顶。四空无色。彼云何来。释言。凡夫二乘不见。故云无色。事实有之。故得说来。故阿含中。说舍利弗般涅槃时。无色诸天咸来泪下。如春细雨。华严亦云。菩萨鼻根闻无色界宫殿之香。此经下文亦说有色。故至非想。悉皆来耳。以色界上悉皆离欲。通名梵众。二尔时下标别供主。前所集中有设不设。故别举之。此应是彼中间梵王。云何得知。其幡短者。但悬梵宫。明知非上。亦可是其三禅梵王。三辩供奉佛。四如来不受。五不果却住。毗摩献中。先标其主。此大菩萨。故放身光。过于梵天。盖覆千界。辩供不受。不果同前。魔王献中。文别有六。一标供主。并叹所作。二辩供奉佛。三献神咒。四请佛受供。五佛许受咒。不受其供。六不果却住。初中欲界魔王波旬标列供主。魔罗梵语。此云杀者。害人善故。波旬梵语。此云极恶。依于佛法而得善利。不念酬报。反欲加毁。故名极恶。他化天上别有魔界。通亦是其他化天摄。故今说为欲界魔王。此多菩萨随化示作。故引眷属。来此供养。开地狱下叹其所为。先救狱苦。后摄魔民。救狱苦中。初明所与。后明所去。所与是何。与乐与善。开狱施水。是与乐也。因告已下是与善也。乘前施水。兼劝以善。故曰因告。汝无能为。彰所不堪。不堪供佛。唯当已下量其所堪。教修善意。初教念佛。后教随喜。当令汝下明修利益。生死昏寝。说之为夜。轮转无际。谓之为长。得善自宁。名为获安。此明所与。魔于地狱悉除刀下明其所云。为除刀剑。注雨灭火。此是众生恶业果报。魔复安能为之除遣。直尔不得。由前教劝。念佛随喜。罪垢消薄。故得灭除。又魔是其不思菩萨。有逢遇者。必定是其宿世善人。受报可转。故为除之。如人贫穷。虽是果报。可以财救。彼亦同尔。上救狱苦。下摄魔民。以佛神力。生心所由。复发是心。重起化意。令诸已下诫舍斗具。魔专坏乱。坏人善时。多以斗具。恐怖行者。今劝舍之。第二辩供。文显可知。就第三段献咒文中。别有六段。一自宣已心。彰已爱法。二男子女人为供养下明咒所为。为于一切诸持法者。三啅枳下正宣咒词。四是咒能下辩咒功能。五为伏已下明说咒意。六若有能下明持者获益。亦得名为举益劝持。初中我等爱乐大乘。是摄法心。守护大乘。是护法心。魔多虚诈。惧佛不信。故发此言。显已诚意。第二段中。明已为护受法之人。说咒以防。人通真伪。为道为人。名之为真。为身为财。说以为伪。文中具论。应有三分。一举其真。二辩其伪。三或真伪下双牒真伪。彰已为说。文但有二。略不举真。伪者尚为。真则亡言。故略不举。伪中有五。为供养者。为得衣食卧具汤药四事供养。受持经法。为怖畏者。畏现诸苦当来恶道。为诳他者。欺诳他人令其敬已。为财利者。为得金银仓库等物。为随他者。为他抑遣。自无诚意。为斯五事。受是大乘。所以名伪。通则受于一切经法。斯皆是伪。今对此经。且云受大。伪乃无量。且举斯五。五中怖畏。一向为身。供养财利一向为财。诳他随他。通为身财。下牒所为或真牒前所少真也。或伪牒上所辩伪也。我为是人除畏说咒。总明为说。益事非一。除畏功强。是以偏举。第三咒词。何故不翻。翻改失用多不神验。所以不翻。又复咒词未必专是天竺人语。翻者不解。是以不译。诸经咒词不翻多尔。第四能中。语义不足。若具应言。是咒能令诸失心者。怖者说者。不断法者。离诸怖畏。离畏如后持益中说。故此不举。言失心者。伪中之劣。此前伪中为供诳他。为财随他。四种人也。此等失于出离善心。故名失心。言怖畏者。伪中之胜。谓前伪中为怖畏也。言说法者。真中之胜。所谓宣说大乘经法。不断法者。真中之劣。所谓不断小乘法者。权化不绝。名不断法。以此咒力。通护一切四部众故。大小通举。此四种人。咒皆能令除灭怖畏。第五明魔说咒意中。先别。后结。别中四句。前二为人。后二为法。就为人中。初言为伏外道故者。对前说者不断法者。彰说所为。为使此人宣通正法。降伏外道。故为说咒。防护其人。护己身者。对前失心及怖畏者。彰说所为。为使彼人得此神咒。防护己身。受持经法。故为说咒。就为法中。护正法者。护小乘法。魔意为护小乘法故。说咒护前不断法者。护大乘者。魔意为护大乘法故。说咒护前说大法者。说如是咒。总以结之。第六持者。获益之中。初获法益。先列。后结。文中可知。持是咒者。我等护下获其人益。持者我护。如龟藏六。护前失心及怖畏者。令无衰恼。龟藏四足头尾为六。我不谀谄。至诚益力。助前说者不断法者。令增说力。欲令未来传法之人。知魔实护。决意弘法。故说不谄至诚益矣。上来六段。合为第三。献奉神咒。第四请佛受供可知。第五段中。初不受供。次为受咒。后明受意。为安四众。准此定知。魔意通为诸持法者。非唯此经下默不受。第六不果却住同前大自在中。先标供主。大自在者。犹是魔醯首罗天王。如龙树说。五净居上。别有菩萨净居天处。名摩醯首罗。十地菩萨多生其中。今来献供。所设已下辩供奉佛。于中有三。一辩供过前。持至佛所。二白佛已下彰已供微。显佛田重。三是故下请佛哀受。初段可知。第二段中。别有三文。一彰已供微。二若以三千大千已下举多显少。三何以下释。前中初法。次喻。后合。法说可知。喻中初先别举五喻。就初喻中。蚊喻自己。我喻如来。余四可知。岂当有下结前微少。不能益多。何者是少。自在所献。何者是多。所谓如来净土依果。但结后四。初喻不论。岂益大海。结前第二明一掬水不益大海。喻已所献。不益如来净土依果。岂益日明。结前第三明一小灯不益多日。岂益众华。结前第四明其一华不益众华。岂益须弥。结前第五明一亭历不益须弥。下合可知。上来第一正辩供微。自下第二举多显少。佛德恩深。假以三千大千世界满中供具。而为供养。尚不足言。我等所设。宁不微少。自下第三举佛恩深。释前供少。何故问也。何故三千大千供养犹名不足。下对释之。以佛为生。常于地狱畜生饿鬼。受苦救拔。故以三千大千供养。犹名不足。地狱外国名曰泥犁。地持释云。增上可厌。名为泥犁。杂心释言。不可乐故名为地狱。其义一也。此之二义皆对厌心。以彰其过。非是当相。当相正解。就处彰名。地下牢狱。是其生处。故云地狱。言饿鬼者。杂心释云。以从他求。故名饿鬼。又常饥渴。故名为饿。恐怯多畏。故名为鬼。言畜生者。杂心释云。以傍行故名为畜生。此乃辩相。非解名义。正解从主畜养作名。一切世人或为啖食。或为驱使。畜养此生。片从此义。故名畜生。诸恶趣者。谓修罗等。佛为众生。常于此处受苦救拔。故合多供。自佛至此。合为第二彰已供微。自下第三请佛哀受。是佛为生。常于恶趣受苦救拔。故今应愍受我微供。何故此中无佛不受。不果却住。有人释言。他方客至。故略无之。当应不然。纵使客至。何妨不受不果却住。直是经家略不云耳

大般涅槃经义记卷第一　　　　　　　　　　　誂赖寿阇梨应永三年十月日以劝修寺大经藏书写了　　　　　　　　法印权大僧都贤宝大般涅槃经义记卷第一(之下)

        隋净影寺沙门释慧远述

自下第二明他方众云集献供。彼他方众何故至此。泛释有三。一自为故来。欲来此处供养请法。供养起福。请法生智。故下文言。汝持此饭奉献彼佛。并可礼敬请决所疑。何不即于彼方佛所供养请法。而来至此。于此佛所。有宿缘故。如说大品普明远来。如是等也。二为他故来。于中有二。一为此土众生故来。此土众生应见彼来生善根故。二为彼土众生故来。彼土众生于此佛所。有宿因缘应见生善。德力微劣。莫能自运。故彼菩萨导引使来。故下无边身中持彼无量众生。令来至此。此是第二为他故来。三为影响显法故来。文中宣说四方无量无边身来。先列东方。文别有六。一列彼国及佛名字。二彰彼佛告无边身令来至此。三无边身奉命至此。四到已献供。五如来不受。六不果却住。就初段中。言东方者。示其所在。去此无量。彰其远近。土名意乐。列彼土名。佛号空下彰彼佛名。虚空别名。如来应等是其通号。诸佛皆有此二名字。化身须别。故立别名。实德须显。故立通称。通称有十。如下广释。第二告中。先彰此国。彼有佛下彰此化主。欲般涅槃汝可往下劝来供养。以生功德。并可礼下劝来请法。生于智慧。礼敬身请。请决口请。第三无边承命来此。随化从于东方而来。实则平等法身中现。故名为来。准下琉璃放光应尔。今就化相。文别有九。一敬辞彼佛。欲来至此。二将来此处。先现瑞相。三明此处睹相惊怖。四文殊安慰。五明此众寻言见彼。六文殊告众。以佛力故。当见九方。七明大众知彼来已。如来定灭。咸皆悲叹。八明大众以无边身威德之力。见其神变。九明无边身量分齐。唯佛所睹。余不能见。初无边身即受教等。是初段也。应时此下第二段也。六种动者。如地经说。所谓动涌振觉吼起。于是众下是第三段明众惊怖。何故如是。以此菩萨威德尊重。深可惊畏。故令众怖。又彼来已。如来定灭。大苦将至。事理如此。故使众畏。下琉璃来。何故不尔。彼来为欲开发实义。令人证入。又欲导人往生净土。胜益将至。故令众乐。无边今来。众意未纯。为增恋仰。故使惊畏。化随时变。不可一定。时文殊下是第四段文殊安慰。初劝莫怖。何以下释。是故下结。尔时大众悉遥见下。是第五段寻言见彼。文殊师利复告已下。是第六段文殊预记。明以佛力当见九方。何处得见。谓下如来变土中见。彼乃泛见十方佛国。非唯见于无边来处。无边来处唯在四方。尔时大众各相谓下。是第七段大众伤叹。大人既来。圣灭不遥。故叹世空。是时大众一切悉下。是第八段。明众以彼无边之力。见其神变。于中有二。一见其神变。二以是菩萨神通力下明见所由。前中有三。一见其身并及眷属。二一一毛下见其身中国土人民。三尔时无边与无量菩萨围绕已下。见其所持供养之具。初段可知。第二段中。初见国土。是一一城各有八万四千王下见其人民。于中三有。一见其受乐。二是中已下见其修善。三安止已下见其伤叹。初中先见人王受乐。后见人民。文显可知。见修善中。初明所闻。纯闻大乘。华中各有师子座下明其所说。纯说大乘。其衣微妙出三界者。出世净报。故过三界。或有众生书持已下明其所修。纯修大乘。见伤叹中。安止无量。于自身已。牒前起后。令舍世乐生其厌心。皆言世空增其恋心。恋圣惧灭。发言伤叹。此等所见。为实为化。释言应实。若实。何故在于无边身中而住。释言。身土相依不定。或身依土。如常所见。或土依身。如华严说。诸佛国土所依不定。或依菩萨天冠中住。或在菩萨衣文中住。或在力士掌中而住。或依普贤愿力而住。今在无边毛孔中住。何足可怪。上来第二见其身中国土人民。自下第三见所持供。尔时无边示神通已。牒前起后。下明供事。先明香华幡盖等事。种种多也。无量广也。谓一一种皆有无量。下明饮食。上妙香美。食体胜也。若闻垢灭。资用胜也。上来第一见其神变。以是菩萨神通力下。是第二段。结明大众得见所由。从众悉见无边身来。合为第八。自下第九明其无边身量分齐。唯佛所睹。余不能见。身大无边量同空者。量同彼界虚空佛也。亦可同于法性虚空。上来大众唯睹其化。实则宽广。如于法界三世诸佛。法身体同。故唯佛知。余不能见。等行菩萨。亦应见之。今略不论。上来九段。合为第三承命来此。第四献供。第五不受。第六却住。文显可知。下辩余方无边身来。南西北方彰其来处。亦有无量无边身者。辩列其人。谓一一方各有无量无数菩萨。字无边身。同来献供。非谓一方各有一来。供倍前者。南方所设。倍过东方并上所献。乃至北方倍过三方无边所设及上所奉。越请不受。超举却住。故曰乃至。自下第八总结众集。于中有四。一明娑罗众集多少。纵广三十二由旬处。大众充满。此处生善。名吉祥地。其一由旬有四十里。三十二由旬。合有一千二百八十里。众皆充满。前优婆塞庄严处中十二由旬。此中三十二由旬。下师子中四十由旬。何故不等。当应三广住处故尔。与法华同。二尔时四方无边身下释防疑难。疑相云何。无边身大。三十二由旬。其处至狭。安得相受。复容余众。故今释之。四方无边。所坐之处或如锥头针锋尘许。故得相受。人多说言。有其十方无边身来。准前验此。唯有四方。三十方下明众皆集。于中先明他方众集。唯止菩萨。及阎浮下此方众集。杂类皆聚。先明人集。除迦叶等。乃至已下余众皆集。十六行恶。如下师子品中宣说。四陀那婆下明所集众。皆舍恶念慈心相视。于中初法。次喻。后合。下简阐提。自下第九变土令净。三千大千净之分齐。以佛神力。土净所由。地皆软等。正明土净。犹如西方。类显净相。其土常净。物本见秽。由前心善。佛力转之。今始见净。名为变土。理实变心。自下第十明诸大众。由土清净。彻见十方微尘数刹。于中初法。次喻。后合。文殊向前言以佛力当见九方。指此事耳。此见十方。何故言九。前者告时。已见东方。对此所见。故偏言九。下第十一如来化周。摄光归口。前放六光。何故言五此如上释。颇梨码瑙合为杂色。是以言五。又外国人相传释云。所放六中。留一传法。故但收五。前照十方。今此何故但言覆会。亦如上释。随其所照众生故尔。示化已周。故从口入。下第十二明诸大众睹相悲恼。于中有四。一睹相惊恐。见光入口。皆大恐怖。内心惊也。身毛皆竖。形不安也。二复作言下辨光入意。三何期已下发言伤叹。所伤有四。一伤已苦。现今悲恼。当坠生死。是其苦也。无虑卒至。故曰何期。哉是助词。怨嗟之甚。重言以叹。二一旦下伤不受供。昔行四等饶益世间。今废名舍。四无量心如下具论。不受供养。是舍离相。三圣慧永灭。伤失明师。圣慧除闇。如日如月。故从喻名。四法船沉没。伤法早灭。法能泛济。从喻名船。此第三竟。四呜呼下悲怨懊恼。悲怨过增。流血洒地。此序分讫

经第二

第二开宗显德分中。先叙异说。次辨得失。后显正义。异说如何。昔来相传。从此至后迦叶品来。同为正宗。正宗之中粗判有二。细分有六。粗判二者。唯略与广。初至众品是其略说。众品已后是其广说。细分六者。略中有三。一明佛现果。二三告下显其缘因。三二十五有有我不下彰佛性正因。广中亦三。初大众问品广前现果。二现病已下广上缘因。三师子品下广前正因。异说如此。次辨得失。昔来所传。粗看似是。细穷则非。两义辨之。一准问以验。二即文以求。准问验者。若众品前与众品后广略别者。便应两处别问别答。何缘略中与广为问。广文之中与略作答。然三告下迦叶广问。如来广答广答未竟。忽尔中分。前略后广。不亦枉乎。三告已下并问通答。明是一分。非别广略。又若六分。一次第说。是则应在纯陀章初。并问使托。然后并答。不应纯陀哀叹章后方始为问。纯陀哀叹二章之后。别为问答。明知与前分齐全别。不得相从合为六分。若使纯陀哀叹所辨。与后义异。不得一处并问并答。三告已后并问并答。明是一分。不得与前合为六分。准问如是。次须即文验其是非。就前所立六分之中。初分明果。第二分中辨明缘因。粗有此相。若言二十五有已下至后众品。通皆明其佛性正因。是义不然。如下文中辨明菩萨。见难见性。解字半满。未发心者得为菩萨。于众无畏。处在浊世。不污如华。处在烦恼。烦恼不染。观察三宝。得不坏众。为诸生盲作眼目导。此答九问。皆明菩萨缘因之行。云何得名佛性正因。又如下说。如来现化如迦邻提。日月岁星。佛为船师。佛舍生死。如蛇脱皮。佛示多头。说如初月。此答八问。皆明如来现果作用。云何得名佛性正因。人复释言。虽辨此义。宗显佛性。故名正因。文既不说。云何得知。尔许经文偏显佛性。是大难解。又若此等实不论性。而言显性。纯陀哀叹。实不辨因。应名显因。三告已下实不说果。应名显果。然说果处不可名因。说因之处不可名果。不说性处。云何强抑令使说性。良以世人不识其文。妄为此判。六分科文。大过在斯。人言众品广前现果。是亦不然。云何不然。下众品中。具答七问。答初一问。明佛常住。可使名果。答后六问皆明因行。云何得名广前现果。又言师子迦叶二品广前正因。是亦不然。准下问答。后迦叶品乃明如来德用善巧。能益阐提。非为显性。云何得名广前正因。以斯验求。六分定非。次显正义。此经始终文别五分。备如前判。上来序分此极哀叹。第二开宗显德分也。三告已下是其第三辨修成德。若能知此是名沙门婆罗门下。是其第四破邪通正。第五一分如来灭度。人天大众阇维供养。外国不来。五中初分化益方便。中三正益。末后一分化讫取灭。中间三分正化益中益人有三。文别有四。细分有六。益人三者。化益凡夫声闻菩萨。是其三也。文别四者。从初讫尽星喻已来。化益声闻令其学大。故下文中多明如来破小归大。二譬如日出众雾除下。化益凡夫令入佛法。故下文中多明化益三罪人等令入佛法。三圣行已下化益菩萨。故下文中纯明菩萨所修所证。四迦叶品下尽陈如品。化益凡夫。故下文中明化阐提诸魔外道令入佛法。细分六者。前第二中相别分二。从初极尽大众问品。多明化益有罪凡夫。令离三罪趣入佛法。现病一品。多明化益有苦凡夫。现通说法。令其离苦。第四重明化益凡中。相别亦二。初迦叶品。明化阐提令信佛法。陈如品中。化魔外道令归佛法。通余说六。中间三分益人如是。就初开宗显德分中四句释之。一辨开宗显德之义。宗谓常果。开有二种。一者拂应显真名开。二者破小显大名开。纯陀章中拂应显真。名为开宗。哀叹章中破小显大。说为开宗。良以常宗。昔为无常化迹所隐。故须拂应显真以开。昔为小乘言迹所覆。故须破小显大以开。二就人辨开。人有二种。一是所寄。二是所为。所寄是佛。所为众生。所为众生身有常性。惑障所覆。而不觉知。犹如贫女宅中宝藏莫能知者。今欲即忘显真令入。但就妄辨真理。在难彰故。寄佛以开。虽说佛常。意显众生身有常性。令其趣入。三对人辩开。人有二种。一圣化所对。影响之流。二圣化所为。当机之众。纯陀文殊是其影响。诸比丘等无常学人是其所为。所为智劣。分外常义不能咨启。是故先于纯陀章中。对其影响。开示常法。因前开宗。诸比丘等。于常法中渐能悟入。故哀叹下对其所为。广解常义。四分文解释。纯陀章中对其影响。开示如来菩提报常。哀叹章中对其所为。显明如来涅槃法常。此二何异。而须别论。通释是一。一切诸德寂名涅槃。虚通无碍悉名菩提。随相别分。非无差异。异有三种。一因果分别。因名菩提。菩提是道。因中所行通人趣果。故悉名道。果名涅槃。涅槃是灭。至果舍修。无为安寂。故悉名灭。二行断别说。一切行德悉名菩提。一切断德齐称涅槃。三就性净方便别论。如下文说。生因所起方便之果。悉名菩提。了因所显性净之果。说为涅槃。今依后门。方便报粗。为是先明。性净法细。故在后辩。问曰。此经涅槃为宗。今以何故宣说菩提。释言分相。菩提涅槃两门各别。若据摄相。互得相成。今据摄相。故说菩萨。亦成涅槃。亦可此经具明菩提涅槃常果。经初题言大涅槃者。名不尽法。且举一边。不具言耳。纯陀章中义二文三。言义二者。一明如来真身常住。二明如来应身无常。问曰。真常昔来隐覆。今可须开。应是旧化。昔来恒见。何劳说乎。释言应身虽是旧化。昔来言实。今方言应。是故须辩。又复权隐导引化废。故须明应。明佛真常。欲令众生趣入无为。显佛应灭。为使众生同厌有为。文别三者。初佛对纯陀开真辨应。二纯陀白佛如是如是诚如圣下。纯陀对文殊广显前真。三从光照文殊已下。佛对纯陀广显前应。前中初因纯陀献供。明佛应受。实则无待无差故常。二尔时大众闻佛世尊普为已下。因纯陀请住。明佛应灭。实即不迁。无为故常。前中初因纯陀启请。略开常法。二纯陀白佛二施无差不然已下。因纯陀设难。广解常义。就初段中。先请。后答。请中初先标列请人。尔时会中彰其所在。有优婆塞标别其人。此实大圣示居始学导引不及。是拘尸城出其住处。工巧之子彰其种姓。名曰纯陀。辩其名讳。与其同类十五人俱。兼列其众。问曰。此等是上所列优婆塞不。释言非是。云何知非。前从远来。此是旧众。又复向前优婆塞等。已辨食具。献佛不受。今此纯陀未有施设。下蒙佛许。方始备辩。故知不同。若非前众。向前序中。何故不列拘尸旧众。不列者多。何独责此。下正为请。为令世间得善果故。意业方便。菩萨悲深。凡所施作。无不为物。故今献供。为世得善。善谓善因。果是乐果。纯陀自献。云何令世得善果乎。由献成佛。化他同己。故令得之。舍身已下身业方便。威仪有四。行住坐卧。今舍坐仪。进诣佛所。从座而起显其舍相。偏袒右肩示有所作。右膝着地释有三义。一右膝有力。跪能安人。二右膝有力。起止便易。二右多躁动。着地令安。故坐禅人右手右足皆令在下。合掌向佛为专其心。悲泣堕泪求佛哀怜。愍世长苦。伤己沉溺。并缘佛去。所以悲泣。顶礼佛足显己虔至。顶是己尊。足是佛卑。以尊接卑。显敬之极。而白佛下口言正请。先请受供。如刹利下请佛说法。我今所供虽复微下重请受供。纯陀因前大众献供。如来不受。故先请供。请供为福。求智依法。故次请法。前虽请供。惧畏如来同上不受。故复重请。前请供中。初先为他我等从今无主已下第二自为。就为他中。先请受供。后显所为。文显可知。就自为中。先彰所为。后请受供。文之左右。明所为中句别有八。初六无人。次一无法。后一结求。从今无主。无离恶处。言无亲者无集善处。对先有佛。故说从今。无救无护明无主失。现恶无救。当恶无护。无归无趣明无亲失。始无所归。终无所趣。此六无人。贫穷饥困明无善法。欲从如来求将来食。结己所求。以从今后无主亲等。故从如来求将来食。供佛期果。说之为求。当来佛果济己虚乏。就喻名食。又是现在施食家果。从因名食。上明所为。唯愿已下结请受供。唯是专义。专求受供。故曰唯愿。食竟取灭。名后涅槃。纯陀今者非直献供。亦欲请住。何故言中听佛涅槃。事不并说。且乞受供。蒙受供已然后请住。又复纯陀为佛将灭。最后献供不得请住。若请佛住不得为灭。请佛受供。下次请法。初先自为。拯及已下第二为他。与前左右。就自为中。初喻。次合。唯愿已下结请令说。喻中六句。如刹利等。是第一句。喻于自己求法之人。刹利王种。婆罗门者。净行高良。毗舍中庶。首陀杂役。此四性中。趣举一种贫者为喻。不具取四。人言举此。为欲要请。佛若说法。我同刹利及婆罗门。佛若不说。我即同于毗舍首陀。若尔世人可得天雨。即名刹利及婆罗门。不得天雨。便为毗舍及与首陀。义无斯理。以贫穷故是第二句。喻已所乏。远至他下是第三句。喻昔所作。纯陀昔日舍邪归正。邪正疏异。故名为远。归投佛法。名至他国。行因资果。名役力作。得好已下是第四句。喻己所有。无诸沙下是第五句。喻已所无。唯悕天下是第六句。喻己所求。合中不次。而复不尽。先合后三。却合初二。故云不次。第三不合故言不尽。先合第四。言调牛者。牒举前喻。喻身口七。合之显法。此明有行。纯陀先来为优婆塞。除身三邪。离口四过。是其七也。良田平正。牒举前喻。喻慧显法。此明有解。纯陀先来修习小解。能为大因。故名为田。正解不邪。称曰平正。通则过去所修大解。斯名智慧。次合第五无诸沙等。牒举前喻。喻除烦恼。合以显法。纯陀昔来所断见惑。如彼沙卤。所断修惑如草株杌。亦可所断四住之地如彼沙卤。四住所起如草株杌。世尊已下合第六句。我今身有调牛良田牒前第四。除去株杌牒前第五。求法依此。所以牒之。唯悕已下正合第六。如来合天。甘露法雨合前雨也。约喻名法。名甘露雨。四姓我是合第一句。贫法财宝合第二句。上来合竟。唯愿哀愍除断我贫。结请令说。上来自为。下明为他。拯犹济也。因说广济。名拯无量苦恼众生。下重请供。我供虽少。谦己供微。如下文说饭唯八斛。故言微少。所奉虽少。望得广充。辨少兼多。是以言虽。问曰。纯陀下为如来。庄严处所。令三千界如安乐国。应堪多辩。何故微少。释言。纯陀实能多辨。为欲寄少。显示如来不思议力。令众归信。故下大众见此神变。皆大欢喜。冀得充足。如来大众申己广意。冀犹望也。望以此食充足佛众。如维摩诘取饭一钵望充一切。为此言者。欲使如来遂己心愿。演少为多。令诸大众睹佛神变。欢喜信乐。我今无主无亲已下请佛哀受。此还牒上无主亲等请佛怜愍。求佛深怜。乞同罗睺。罗睺是佛生身之子。慈爱深重。诸怜众生。多取为类。下佛答之。尔时世尊举酬答人。一切种智无上调御。举酬答德。于一切法种别而知。名一切智。自调调他。调御中极。名无上调御。别即种智。是能说德。无上调御是受供德。自调心故。能受物养。通则义等。一切智故。能为说法。能受其供。并知说时。及与受时。无上调故。能调众生。为之说法。为之受供。告纯陀下明酬答词。先总叹善所请事好。是故言善。哉是助词。由请契当。重言以叹。下正答之。先许说法。后许受供。何故与前请词不次。良以纯陀意专献供。故先请受。佛意在法。故先说法。我今为汝除断贫穷。对上请中唯愿哀愍除断我贫。由说得果。故断贫穷。此明所去。无上法雨雨汝身田。对上请中唯悕法雨。依前身口七支授法。名雨汝身。依前智慧良田授法。名雨汝田。约喻名法。是故名雨。由说起彼法身种子。名生法芽。此明所与。许受供中。汝今于我欲求寿等。牒其所求。名前所求。将来之食为寿命等。我当说下正许受供。由佛受供令彼得果。是故云施。常田植福。得报不迁。是以言常。寿命色等是其果体。现在施食能令受者得其寿命。色力安辩。五事利益。故于未来还得此果。何以下释。初先征问。问有两意。一问行因。自能得果。我以何故云言施汝。二问五果。是有为法。我以何故言施汝常。下别释之。先解施常。释意如何。由我常故。能施汝常。然今文中但解佛常。佛常既成。彼常自显。不劳更辩。问曰。何不望直就彼所得解常。乃就佛乎。释云。彼常当来未现。冥冥难彰。故就佛论。佛常为昔。权迹所隐。今须拂权以显其实。故约二时无差以显呼言纯陀。起发其心。施食有二。果报无差。正解常义。施食有二。文少难解。若具应言受施食人有二。翻者为欲四字成文。略去初受。此云何知。下就受者以辩二故。果无差者。拂权显实。随化以论。前受施时是因非果。后受施时是果非因。因果两差。即是无常。据实。二时无非佛果。果报无差。所以是常。问曰。上言此段因于纯陀献供。明佛无待。故名为常。今以何故无差释常。释言。无差犹是无待。今昔两时并无假待。故曰无差。下辨二相。先问。后辩。一者受已得菩提者。未成佛前。先受二女所奉乳糜。然后成佛。阿耨菩提是外国语。此云无上正真正道。阿之言无。耨多罗言上。三之言正。藐之言真。三复名正。菩提名道。二者受已入于涅槃。指今所受。上来解常。下释施义。我今受汝最后供养。令汝具檀未来得果。故名为施。此是法施。非余施也。上来因请略开常法。自下第二因纯陀设难。广解常义。纯陀先难无差之言乖昔所闻。是以难之。如佛所说二施果报无差不然。牒以总非。何以故下广显不然。先自征责。我以何故道佛不然。下举五事难破无差。成前不然。一就田为难。第二就人。第三就身。第四就因。第五就缘。受施是田。故先就田。田者是人。故次就人。人必有体。故次约身。身必有本。故次就因。身有假藉。故次就缘。此五难中例应有三。一彰昔异今。二明今异昔。三结破无差。然今文中有具不具。就初田中。但有前二。初彰昔异今。先受施者烦恼未尽。断德不成。未成种智。智德未备。未能令生具足檀者。生福不胜。二明今异昔。后受施者烦恼已尽。明断德成。已成种智。明智德备。令生具足。明生福胜。三应结破。文中略无。第二人中亦应具三。文但有二。初言先受。直是众生。彰昔异今。前受施时生死未尽。犹是众多生死所摄。故名众生。二后受下明今异昔。如下文中。天有五种。一是世天。大智论中名假号天。谓世人王名为天子。或云天王。二者生天。从四天王乃至非想。三者净天。从须陀洹乃至辟支。四者义天。从初地上乃至法云诸菩萨等解达空义。故名义天。五第一义天。谓佛如来见性穷极。名第一义佛于如是五天之中。最为上天。名天中天。三应结破。文略无也。就难身中文具有三。一彰昔异今。先受施者是杂食身。约缘辩身。烦恼身者约因辩身。从烦恼生。生烦恼故。是后边身。无常身者当相辩身。后边简前。生死之穷。故曰后边。无常异后。迁机未息。故名无常。二明今异昔。后受施者无烦恼身。翻前烦恼。金刚别论。非是翻前。其身难坏。故如金刚。法身翻前杂食之身。诸功德法集成佛身。故名法身。常翻无常。无边翻边。问曰。纯陀难破无差成佛无常。今言如来后受施时。法身常身无边身等。已知佛常。何须更难。释言。纯陀道佛常者。一得不退。故名为常。非是凝然。故得为难。亦可纯陀且纵佛常令与昔差。今昔既差。还是无常。难意如是。三云何下结破无差。就因难中文亦有三。一彰昔异今。先受施者未具檀等明行未圆。六度之义广如别章。唯得肉下彰解不具。何故五眼乃名为解。于五眼中佛慧法眼。是智解故。五眼之义亦如别章。于五眼中。肉眼为始。天眼为次。慧眼第三。法眼第四。佛眼第五。于此五中。肉眼先有。故云唯得。余四修起。尔时未得。就未得中。天眼凡法。今废不论。余三圣智。今此辩之。就此三中。从下向上。应当说言未得慧眼乃至佛眼。今此文中。从上向下。是故说言未得佛眼乃至慧眼。越法名乃。此约三乘别教言耳。据实菩萨亦分具五眼。二明今异昔。后受施者已具檀等明其行圆。以此诸度修在菩萨。成在佛故。具佛眼等彰其解具。就圣眼中从上向下。故云具佛乃至慧眼。天肉不论。三云何下结破无差。就缘难中文亦有三。初言先受入腹消等彰昔异今。二后受已下明今异昔。无五果者。无食所成色力寿等五事果也。三云何下结破无差。下佛释难。与问不次。初先就身释成无差。第二就因。第三就人。第四就田。第五就缘。身是德体。故先就之。身必有本。故次就因。身能成人。故次就人。身能受供。故次就田。身有假待。故次就缘。就此五中例应有三。一彰昔同今。二明今同昔。三结成无差。然今文中有无不等。就初身中但有前一。无后两句。文显可知。第二因中亦应具三。文中但有第一第三。略无第二。就初段中。释难不尽。云何不尽。向前难中。言先受施。六度不具。五眼不足。今但释眼。六度不论。就五眼中但释佛眼。余四不解。故云不尽。一义既通。余类可知。故不具释。云何得知偏释佛眼。照见佛性。是佛眼故。文中初言未见佛性。名烦恼身杂食身等。约前显实。亦得名为约果显因。显之云何。未见佛性名烦恼身。杂食后边。无常身故。向前宣说。无量劫来无有食身烦恼身等。明知我于无量劫来已见佛性。已见性故。先有佛眼。菩萨尔时受饮食下约真显应。显之云何。实则如来无量劫来已是常身。已见佛性。而言尔时受饮食已入金刚定。始见佛性。得菩提者。明知是应。是故我下结成无差。良以今昔同见性故。二果无差。第三人中。文具有三。初言尔时破坏四魔。彰昔同今。烦恼阴死及与天魔。是其四也。破烦恼魔。离生死因。破坏天魔。离生死缘。破阴破死。离生死果。破此四魔。故非众生。二今入下明今同昔。三是故下结成无差。第四田中文亦有三。初言尔时虽不广等彰昔同今。释难不尽。向前难云。前受施者烦恼未尽。未成种智。未能令人具足檀度。然今直释。有智便罴。余皆不论。此明如来前受施时。虽不广说十二部经。先已通达。是故我先具一切智。十二部经下当具辨。二今入下明今同昔。三是故下结成无差。第五缘中亦应具三。一彰昔同今。二明今同昔。三结成无差。今有前二。略无第三。初中如来于无量劫不受饮食。正显其实。为声闻下拂权显实。先举昔权。言受难陀难陀波罗所奉乳者。昔有二女。长名难陀。少名难陀波罗。共牧千牛。于一时中。构千牛乳用饮百头。复构百头用饮十头。复构十头用饮一头。构一牛乳。煮以为糜。糜在空中七尺而沸。女见奇异。不敢自食。用上树神。佛在树下。二女不知。到已遇见。遂即奉献。故今举之。上来举权。即是显应。我实不食。拂之显实。我今为下是第二段明今同昔。为于此会受汝所奉。应同昔也。实亦不食。真同昔也。问曰。应身为一向食。亦有不食。佛化种种非是一向。如转女身经说佛应身如全段金刚。无生熟藏。无大小便。无出入息。凡所受食持至十方。施诸大会。自无所食。故知应身亦有不食。今据一化。且言食也。自下第二因纯陀请住。明佛应灭。实即不迁。无为故常。纯陀先请。如来后答。请中有二。一众推纯陀以为请主。二纯陀喜下为众正请。前中初先总明众喜。尔时大众举欢喜人。闻佛普为大会受供。明喜所由。欢喜踊跃正明欢喜。喜有二意。一纯陀献供。普为大众。如来今受。众则有分。所以欢喜。彼成时能度我故。二纯陀为众献奉供养。如来为受。为众请住。佛亦应留。豫望佛住。是故欢喜。二同声下别显喜意。别中有二。初尽长行。显初喜意。下有四偈显后喜意。前长行中初叹后归。善哉叹也。南无归也。以其所成檀行可尚。故众同叹。所成可伏。故众同归。叹中初言善哉希有。是总叹也。汝今立下是别叹也。别中有四。一准德验字。叹名不虚。二叹得名利。三叹愿满足。四叹成五难。于初段中别有四句。一叹名不虚。二言纯陀下释其名义。三汝今建下彰其实德。如地经中十波罗蜜有大义利。同名大义。纯陀献佛。成就檀度。名建大义。四是故下就德结名。能立大义。故名纯陀。问曰。纯陀所建大义。今时始立。名字先有。今云何言从义立名。名曰纯陀解云。贤圣所有名字。虽是父母生时建立。冥与德会。如维摩诘名无垢称。如须菩提名曰空生。如是等也。自下第二叹得名利。由佛受供。美响遐布称得大名。由得名故。众皆归从。成摄他行。说得大利。自下第三叹其愿满。纯陀过去迦叶佛时曾起供佛。摄功德愿。彼愿今遂。名德愿满。又于现在起供佛心。亦是纯陀摄功德愿。此愿得遂。名德愿满。自下第四叹成五难。甚奇纯陀。总以标叹下别显之。何者是五。一人身难得。二佛世难值。三信心难生。四经法难闻。五后供难成。生在人中是初难也。下举余四。复得难得无上之利。总以标举。于人身上更得四难。故云复得。人身世利。后四出世名无上利。下别列之。于中先明佛出世难。如优昙华世间希有。喻说彰难。此方名为灵瑞华也。轮王出世。此华乃现。名世希有。佛出世难。合喻显难。下约此佛明后四难。差别可知。以此皆于难出佛边而成就故。所以极难。上来叹竟。下归命中。初归纯陀供佛之行。虽受人下归命纯陀供佛之心。行能度物。故归其行。心专为物。故归其心。前归行中。初法。次喻。后合。下结法中。初言南无纯陀。是归命词。梵言南无。此言归命。诚心归命。重言显之。汝已具檀。出所归事。喻中如月乃至无翳。喻前所归。秋月正喻纯陀之身。十五日夜喻佛灭时。净满无翳喻成檀行。一切众生无不瞻仰。喻上能归。合中初言汝亦如是。合上如月净满无翳。而为我下合一切生无不瞻仰。下牒结之。先牒前法。佛受汝供令汝具檀。牒上所归。南无纯陀牒上能归。是故已下合之同喻。是汝具檀。故说如月。众咸归汝。故说一切无不瞻仰。下归纯陀供佛心中。南无纯陀。归命之词。虽受人下出所归事。虽受人身心如佛心。正出所归。身劣心胜。举劣兼胜。是故云虽。佛心为物。纯陀亦尔。是故云如汝真佛子。叹人显心。心如佛故。终能绍继。名真佛子。如罗睺罗。类以显之。纯陀是佛法身之子。罗睺是佛生身之子。子义不异。是以言如。自下第二显后喜意。推为请主。偈请之中。初之一偈推为请主。第二一偈正劝令请。第三一偈彰请所为。为留佛住。身口益物。第四一偈结劝令请。初中上半叹其人尊。以人尊故堪为导首。为众启请。所以叹之。解有两义。一约纯陀内心以释。纯陀之心为物如佛。是故虽复生在人趣。已超第六天道之上。二约纯陀请德以解。佛初成时。初禅梵王请佛说法。纯陀今者请德同彼。是故虽复生在人中。已超第六他化天上。我及一切今故稽首推为请主。第二偈中。上之半偈举佛灭事。下之半偈正劝令请。第三偈中。上之半偈为留佛住身业益物。演说已下半偈之文。为留佛住口业益物。无上甘露是大乘法。为佛智者之所称赞。愿住演说。第四偈中。上半明其不请有损。解有二义。一现在悲苦身命不全。二流转生死慧命不全。下之半偈结劝令请。此偈须记。纯陀下还述此为请

上来大众共推纯陀以为请主。自下第二纯陀为请。于中初明纯陀心喜。彼何故喜。还有二意。一蒙佛受供。成檀故喜。二准前类后。望留佛住。所以生喜。文中初法。次以喻显。父母卒丧忽还活者。解有二义。一就檀行以释还活。供佛善根可尊可重。如世父母。佛前不受人天供养。名为卒丧。今受纯陀所奉供养。如似还活。二就佛解。佛如父母。向前唱灭。名为卒丧。纯陀今者准前验后。望留佛住。说为还活。下合可知。次以身礼。下以口请。偈言巧妙。少字之中能摄多义。故以偈请。于中偈有十八行半。判以为二。初十偈半庆前所得。下之八偈启请于后。对前大众叹成五难。所以庆前。对上大众四偈推请。所以请后。此二即显喜中二意。问曰。纯陀今为请住。直请便足。何劳庆前。欲使如来述后同前。故须庆前。于中初偈庆得人身。快哉获利。庆喜之词。下出所庆。善得人身。彰己所得。得身修善。故名善得。蠲除贪等明己所离。蠲贪恚等明断恶因。举除贪恚等取离痴。永离三恶明离苦果。依六卷经。此离泥犁地狱之苦。今以人身胜过三涂。故言永离三恶道也。第二一偈庆得值佛。快哉庆词。下出所庆。遇得金聚值调御师。明己所得。先喻后法。不惧堕畜。彰己所离值佛除痴。故离畜生。前得人身应离地狱。隐别彰通。后值佛等亦应通离。隐通彰别。文之左右。次一偈半庆得生信及与闻法。先彰所得。佛如优昙。明佛希有。下对此佛明其生信。闻法为难。值生信难。庆生信也。遇己种善。庆闻法也。下明所离。永灭饿鬼。生信所离。信乐供养。故离饿鬼。亦复损减修罗种者。闻法所离。闻法除疑。故离修罗。下有七偈。庆成檀度。于中有二。初之五偈举其所庆。下之两偈彰己欢喜。前五偈中。初明所得。度人天下彰其所离。前所得中。芥子投针佛出难是。明佛难值。举佛难值。明于佛所成檀至难。先举难事。后约显佛。我已具檀。明于向前难值佛所成檀可庆。下明所离。度人天死总明所离。佛不染下别明所离。于中有二。一以己檀行上求佛果。故得度于人天生死。二一切烦恼摧破已下。不将檀行求人天报。故得度于人天生死。前中先明佛出生死。生世难下用己檀行。回以求之。明佛出中。佛不染世。离生死缘。缘谓烦恼。善断有种。离生死因。因谓业行。非想是其三有之穷。名为有顶。佛断其种。下即亡言。度生死流。离生死果。下以檀度愿求之中。初明生世为人至难。举此为显难得身中所起檀行。唯应求佛。不应求余。彼云何难。如下文说。舍于人身还生人中。如爪上土。值佛世下明佛难逢。先法后喻。举此为显难值佛边所成檀行。唯应求佛。不应求余。我今奉食愿无上报。正愿求佛。求前不染。乃至永渡生死流。佛名无上报。以求此报。故得度于人天生死。下明不求人天之中。一切恼结摧破不坚。破人天因。行檀求佛。故能破之。我于此下离人天果。我今此处不求天人。未得不求。谓今于此供佛所成檀行之处。不求未来人天之身。设使得之心亦不乐。已得不受。上来五偈举己所庆。下明欢喜。于中初法。次喻。后合。下结可知。上来庆前。自下请后。述前大众四偈所劝即为请也。下八偈中。初之一偈。述前大众第一偈意。明众推已以为请主。次有两偈。述前大众第二偈意。为之正请。次有三偈。述前大众第三偈意。彰请所为。为留佛住。身口益物。此亦即明圣住有益。下有两偈。述前大众第四偈意。明众有苦。此亦即显圣去有损。就初偈中。我得现报最胜上处。述上偈中汝虽生人已超六天。由佛受供。得为大众摄法上首。名得现报最胜上处。释梵天等悉来供我。述上偈中我及一切今稽首请。次二偈中。初至高声唱无调御。述上偈中人中胜尊今当涅槃。明众悲苦。一切世间悉生苦恼。以知世尊欲入涅槃。明众心苦。高声唱言世无调御。明众口怨。道佛涅槃名无调御。不应舍生应视如子。述上偈中汝应愍我唯速请佛。为之正请。次三偈中。如来在僧。述上偈中久住世间利无量众。明住身益。僧犹是前无量众矣。演无上法。述前偈中演智所赞无上甘露。明住口益。如须弥山安处大海。显前如来在僧之益。须弥宝成。映发大海。佛众德成。显发大众。佛智能下显前演说无上法益。佛智能断我等无明。除无明地。如虚空中起云清凉。喻以显之。佛如虚空。说如起云。由断无明。四住不生。犹如日出。除云光照。喻以显之。断除四住。由灭无明。故如日出。除云光照。斯乃本末互相显示。下两偈中。初偈述上第四偈中汝若不请我命不全。是诸众生啼泣面肿。明现悲苦身命不全。悉为生死苦水所漂。明没生死慧命不全。后偈述上是故应见为启请调御师。以是故者。以众啼泣生死漂故。应长信者。对前啼泣请佛住也。众谓佛灭。所以啼泣。佛应久住。长其常信。为断生死。对前生死苦水所漂。请佛断也。久住于世。总以结请。下佛答之。文还有二。一述前所庆。二不应请下违其后请。前中先述所成五难。汝今已下述劝令喜。前中初言如是如是如汝所说。总述其言。佛出世下别述其言。上有五难。今述其三。人身闻法略而不举。于中先明如来难出。下约此佛明其值遇生信等难。下劝令喜。于中初言莫大愁苦。劝苦愁心。应生踊等教生喜心。得值如来最后供等。举上后难。成前应喜。下违请中。文别有二。一明如来化必须灭不应请住。二从离欲善思已下。明真常存不应请住。前则显应。后则开真。前中有二。一正违其请。不应请佛久住于世。二汝今观下明化须灭。成前不应。于中初先明应须灭。彰请不应。即为纯陀而说偈下九偈半文。明有叵乐。成请不应。前中初言汝观佛境悉无常者。明应境界之无常也。应身分齐名佛境界。随化示灭故曰无常。斯乃如来得大涅槃。不舍世间常共无常。诸行性相亦如是者。以圣类凡。五阴诸法迁流名行。同佛无常。故云如是。正应先明诸行无常。后类于佛。今此何故先说诸佛境界无常。后类诸行。释言。取义左右不同。若欲知佛有为无常。举行以类。若欲令人知行无常。举佛以类。然今化意。为使众生因佛无常。知有为行无常可厌。故先举佛。后类诸行。自下第二明有叵乐。成请不应。为纯陀说。经家总举。下正说之。于中合有九偈半文。前九广明有为多过。未后半偈结己不乐。前九偈中明有为法五非常过。初三偈半明其无常。次一偈明苦。次半偈明空。次两偈半明其无我。下一偈半明其不净。空与无我。有何差别。空是法空。无我是其众生无我。初中约就生老病死。以说无常。初偈明其生法无常。一切世间生皆归死。明无常宽遍。寿虽无量要必当尽。明无常决定。生无常故。皆死必尽。次有三句。明老无常。夫盛有衰。合会别离。泛举世事。类身必老。壮年不停。正明老体。盛色病侵一句明病。下一偈半明死无常。命为死吞。当相辨死。无法常下举类显死。无有法常举法以类。诸王自在势力无双一切迁动。举人以类。寿亦如是。约类显死。就明苦中。初有半偈。明其粗苦。言众苦者是其重苦。内有生老病死等苦。外有种种逼迫等苦。名为众苦。无际无息是其深苦。过去无际。未来无息。下半明其生灭细苦。三界无常明苦所以。诸有无乐正明其苦。良以三界皆无常故。三有之中悉无有乐。就明空中。有道性相一切空者。三有六道因缘虚集。求其性相。一切空也。假中无性名为性空。缘假亦无名为相空。明无我中。初之二偈正明无我。下有半偈约智显过。前两偈中。初一偈半就生死果以说无我。后之半偈就生死因以明无我。前偈半中。初偈正辨。后半结之。前正辨中。可坏流动。约无常义以显无我。常有忧等。约其苦过以显无我。忧患心苦。恐等身苦。就身苦中。恐怖诸恶是其外苦。老病死等是其内苦。亦可忧者是其心苦。患是身苦。此二并举。是故名等。恐怖诸恶出其所忧。老病死等出其所患。上来正辨。下次结之。是诸无边是总结也。是前诸过细分广多。故曰无边。易坏怨侵是别结也。易坏结前可坏流动。怨侵结前常有忧等。上来就果。下就因说。烦恼所缠法说以论。如蚕处茧。类以显之。唯是妄想烦恼所缠。故无我体。上来正辨。何有智者而当乐此。约智显过。下明不净。此身苦集一切不净。果体不净。扼缚痈疮根本无利。种子不净。扼者四扼。所谓欲有无明及见。欲界烦恼除无明见。名为欲扼。色无色界一切烦恼除无明见。名为有扼。三界无明名无明扼。三界诸见名为见扼。此等四种能令众生为苦所扼。故名为扼。如杂心释。缚谓四缚。名同四扼。痈疮是漏。漏有三种。所谓欲有及无明漏。广如下释用此以为身之根本。故无义利。上至天身皆亦如是。明其分齐。下至地狱。上至天身。皆是苦集。根本无利。故是不净。上来广辨五非常过。诸欲无常故我不贪。总结舍离。上有五过以何义故偏言无常。无常在初。故偏说之。亦可诸义互以相显。且言无常。上来第一明应须灭不应请住。自下第二明真常存不应请住。于中偈文多少不定。凡有三别。依一经本但有两偈。依一经本有五偈半。依一经本有六行偈。六行者是。今依解释。于中分二。前三偈半明真常住。彰其不应请住所以。后两偈半正劝不应。前明应中。先劝不应。后出不应请住所以。今此先明不应所以。后劝不应。文之左右。前三偈半明真常中。分之为四。一断集证真。二究竟断下除苦得灭。三我渡有下明其除苦得灭故乐。四以是缘下明其断集证真故常。初中离欲。明其断集诸过皆断。欲过深重。受生之本。三毒之首。故偏说离。善思已下明其证真。善思是其趣证方便。而证真实。正明入证。如来藏性是其真实。舍妄契真。说以为证。第二段中究竟断有。明其除苦。今当涅槃。明其得灭。实自久证。对今息化。始归其实。故言今日当涅槃矣。第三段中。我渡有岸牒前断有。已得过苦牒前涅槃。涅槃之果超出众苦。故言过苦。下约此义以明佛乐。以过诸苦。故于今者纯受上乐。第四段中以是缘者。以初段中离欲因缘。证无戏边。犹初段中善思证实。妄心分别名为戏论。得实除舍故名为证无戏论边。下约此义明佛常住。永断缠缚今入涅槃。离无常因。以前离欲故断缠缚。缠有十种。谓无惭。无愧。睡悔。悭。愱。掉。眠。忿。覆。此是十也。通则诸结。斯名缠矣。缚如上辨。我无老病寿命不尽。离无常果。由前证实。故命不尽。上来第一明佛常住。自下第二彰请不应。于中分二。初一偈半对向永断。诸缠缚等劝其莫思。下有一偈。对前今者纯受上乐。劝其莫啼。前中初言我今涅槃犹如火灭。对前文中永断缠缚今入涅槃。明己诸过毕竟永灭。纯陀不应思如来者。对上我无老病死等。劝其莫思。莫思如来有老病死诸过之义。当观如来如须弥山。对前文中寿命不尽。教其正观。正观如来常住不动如须弥山。后中初言我入涅槃受第一乐。牒前文中是故今者纯受上乐。诸佛如是不应啼哭。结劝止悲

上来第一佛对纯陀开真辨应。自下纯陀对于文殊广显前真。又复前来佛对纯陀。以理正教。生其常解。自下文殊反试纯陀。坚其常解。然下纯陀对于文殊。还显向前两段中真。先对后段。广显如来不灭之真。如来次后自当广下。广显如来无待之真。乘言便故。从后向前次第显之。初中有四。一纯陀乘言启请为由。二文殊反试。三纯陀因试自申己解。四文殊述赞坚其常解。初中有三。第一纯陀述佛前言彰己智微。不能思佛涅槃深义。故须佛住。二我今与下明己所解。高参上流。闻说堪受。敢留佛住。三譬如饥下请佛深怜必为己住。初中如是诚如圣教。总述佛语。依旧经本。向前偈中佛劝纯陀。不应思量如来之义。故今述之我今智微。何能思量如来深义。别述佛言。以我智微。不能思量如来涅槃。故须佛住。第二请中。初法。次喻。后合。下结。法中明己内有常解。故与文殊法王子等。喻中幼年初出家者。习道未久名为幼年。常解始生名初出家。未有常行名未受具。解常处同名堕僧数。合中初言我亦如是。正合前喻。以佛菩萨神通力故得在如是菩萨数者。纯陀明己在数所以。以现佛力过去菩萨教化之力。生我常解。故在如是大菩萨数。是故下结。是我有解。上同菩萨堪受法故。故请佛住。第三请中。如饥无吐。立喻请佛。佛常思化。如世饥人。愿莫舍我。名不变吐。愿使已下约喻求佛。愿如饥人。莫舍我等入涅槃去。第二文殊反试之中。先呵。后教。初文殊告汝今不应发是言等。是呵词也。明佛无常。是故不应。汝今观下是教词也。教观如来有为无常。息其请意。汝今当观诸行性相。正教起观。小乘法中佛是有为。诸行所摄。若观诸行性相无常。自然知佛终归尽灭。不应请住。如是观行具空三昧。举益劝。由观无常。知法无性。故具空定。欲求正法应如是学。结劝修习。欲求空法。应当如是。学观有为性相无常。第三纯陀显己解中。初先受前文殊所教。以理观佛。非是有为。短寿喻下以己所知。教呵文殊。前中初言夫如来者天上人中最尊最胜。直立道理。下约此理推验如来。明非有为。于中初明同于有为非尊非胜。力士喻下明是尊胜。必破有为。前中有二。一正明如来是其有为非尊非胜。二复次文殊为如说下重审文殊。前中有四。初如是如来岂是行者。审定其言。二若是行下纵以示过。明同诸行。则有生灭流转之过。三我闻下明有生灭流转之过。便非尊胜。四是故下结呵文殊。就初段中。如是如来牒上之词。所谓如是天上人中最胜如来。岂是行耶。审定其言。疑问不决故言岂耶。第二段中。若是行者牒其所立。下就显过。于中初先就佛明过。一切行下类以显之。前中初言为生灭法。法说明有生灭之过。譬如水泡速起速灭。喻说明有。生灭之过。往来流转。法说明有流转之过。犹如车轮。立喻彰过。下类显中一切诸行亦如是者。生死诸行亦同有此二种过也。诸行例然。佛是有为。何独不尔。第三段中。初就生灭。明佛不得为尊为胜。如聚落下就前流转。明佛不得为尊为胜。前中我闻诸天极长。举凡验圣。亦得名为辨凡过圣。如四天王寿五百岁。乃至非想寿八万劫。名为极长。云何世尊是天中天不满百年。准凡责圣。亦得名为彰圣劣凡。世尊既是天中之天。寿应无量。云何命短不满百年。不满百故不得名为天中之天最尊最胜。下就流转明非尊中。初先立喻。如聚落主。喻佛得为三千化主。势力自在能制他者。喻佛自在能调众生。其后贫贱人所轻者。喻佛流转为人轻也。为他使者。反为他化。所以下释。下合显法。世尊亦尔。合聚落主势力自在能制伏他。同于诸行。合其福尽。不得称为天中之天。合其贫贱为人轻也。何以下释。即是合上失势力故。第四结中。是故文殊勿观如来同诸行者。以同诸行。便有生灭流转之过。不得名为天中天故。莫观如来同有为行非尊非胜。自下第二重审文殊。文殊高人。喜有异见。故须审之。复次文殊为知而说不知而说。审定其言。为当知佛定是有为。说同诸行。为当不知闇心妄说。设使已下纵以示过。设知如来同于诸行。命报短促。不得名为天中之天。流转不定。如聚落主。不得名为自在法王。上来明佛同于有为非尊非胜。自下第二明是尊胜必破有为。破离四魔有为生死。方得名为三界尊故。于中先喻。次合。后结。喻中有三。一佛破有为喻。二如是力士王所爱下世共尊敬喻。三所以下佛是无为喻。初中如王有力士者。众生有其感圣之力。为佛随从。故名为王。佛能摧破四魔强敌。名为力士。力当千者当敌四魔。更无降者魔不能伏。故称当千。结佛力胜。第二段中。如是力士牒佛如来。王所爱念为世尊仰。偏赐爵等别加敬养。第三段中。所以得称当千人者。问前起后。是人未必力敌千者。简前起后未必专以破障之力。当敌千人种种伎能。能胜千者。具足种种无为功德。过千人也。故称结之。如来下合。依前三段次第合之。合初段中。如来亦尔合前力士。降烦恼等合力当千。更无降者。降烦恼魔。断生死因。降伏天魔。摧生死缘。降阴及死。离生死果。以降此四。故非有为。是故如来名三界尊。合第二段王所爱念偏赐爵禄。如彼已下举喻以帖。偏帖初段。以是缘下合第三段。以是缘者牒前显后。以佛破坏有为因缘。成就种种无为功德。成就种种无量真德。合上种种伎能胜千。故称如来应正遍知。合前喻中故称当千。文殊不应忆想如来同于诸行。总以结呵。上来纯陀受文殊教。以理推验。佛非有为。自下纯陀以己所知。教呵文殊。于中先呵。贫女下教。呵中先喻。譬如巨富长者生子。喻凡感圣。感圣之人内有道机。名富长者。感圣出现名为生子。相师占之有短寿相。喻前文殊说佛有为。文殊相师观佛名占。说佛今灭名短寿相。父母闻下喻世轻贱。父母闻等喻明感圣道机众生闻短不爱。知佛不能常流法化。名为不任绍继家嗣。由是不爱。观同凡夫声闻缘觉。名视如草。夫短寿下喻明其余。无道众生闻短不敬。次合显法。若使如来同诸行者。合前生子有短寿相。亦复不为世间敬者。超合不为沙门等敬。如来所说不变真法亦无受者。却合父母不复爱等。以不爱故所说不受。是故文殊不应说下总以结呵。自下纯陀以己所知反教文殊。于中两喻。初贫女喻反教文殊。显佛无为。后大人喻。反教文殊覆佛有为。前中先喻。次劝。后合。喻中六句。一处苦求善喻。二止他已下依教主解喻。三是客舍下教授令出喻。四其产未下怀解向果喻。五于其中路遇恶已下逢苦不退喻。六慈念已下赏解得果。喻初中贫女喻修行人无德称贫。能生常解。故名为女。无境安心名无居家。离善知识名无救护。烦恼婴缠名加病苦。无法充神名饥渴逼。访友游行。求法乞丐。第二句中止他客舍生一子者。名佛为他。大乘教法是佛摄人所安止处。名为客舍。依教曰止。起解名生。终能结继故说为子。第三句中是客舍主驱逐去者。佛是舍主。教授向果名驱逐去。亦可教令舍诠求实。名驱逐去。第四句中其产未久携抱是儿至他国者。解生不遥名为未久。怀解在心名抱是儿。悕心向果名为欲至。无上菩提是佛住处。名为他国。第五句中于修行时。名为中路。触对尘境名遇风雨。起恶招苦逼切自身。名寒苦至。加为恶友侵害善法。名为毒虫之所唼食。中逢小乘名经恒河。赏解求出名抱儿渡。小乘众生共相逼劝。名水漂疾。守解不从名不放舍。乃至为彼小乘所杀。人丧道废。是故名为母子俱没。未必有此。盖乃假设过分为言。纵使有此。亦须坚守。第六句中如是女人生梵天者。喻诸菩萨赏解功德终得菩提。上来立喻。下次教劝。于中有二。一劝愚人一切莫说。二若正见下劝其智者定说无为。前中文殊欲护正法勿说如来同于诸行。劝其莫说。良以愚人心未见法。言多谬失。是故劝其一切莫说。次教莫着。唯当自责我今愚痴。劝舍解心。如来正法不可思议。教生信心。是故已下结劝莫说。是如来法不可思故。不应定说有为无为。下劝智者定说无为。若正见者应说如来定是无为。以理正劝。何以下释。先问。后解。由说无为。令人正解起修趣向。名生善法。不说有为令人舍谤不堕三恶。名生怜愍。下次合喻。前六句中。但合后二。如女在河爱念子等。牒前第五。护法菩萨亦应如是。宁舍身等。举法以合。以说如来同无为下合第六句。于中有二。一明得果。二明其人得果自然。前得果中。初先正合。如彼女下举喻以帖。何以下释。云何护下显护法相。谓说如来同于无为。所谓同于涅槃无为。亦得同于法性无为。下自然中。初先举法。后以喻帖。文中可知。下教文殊覆有为中。初先立喻。次劝。后合。喻中有六。一行修中废喻。二寄止下退住小乘喻。三卧寐下闻。说无常喻。四即时惊下惧说滥佛喻。五具惭愧下正言覆佛喻。六生忉利下覆佛得果喻。就初句中。起修长久名为远行。行修中废名为疲极。第二句中。止他舍者小乘之法。是小乘人所安止处。名为他舍。退住名止。暂停名奇。第三句中。大解未发名卧寐中。闻说无常烧诸世间。名室忽然大火卒起。权教忽施。所以言卒。第四句中觉知无常滥佛之过。名即惊悟。愁虑佛身为彼无常。权教所隐。名自思惟。我于今者定死不疑。此以自身喻于佛身。诸佛法身是己体故。第五句中。具惭愧故衣缠身者。佛现无常。似若身丑。耻佛无常名具惭愧。说佛真常隐佛无常。名衣缠身。护佛至死名即命终。第六句中。生忉利天。喻得三十二相之果。满八十返作大梵王。喻得如来八十种好。满百千世为轮王等。喻得十八不共法等无量功德。上来立喻。下次教劝。于中文有六句三对。一邪正相对。有惭愧者不应观佛同于诸行。明正不应。外道邪见可说如来同于诸行。彰邪所应。二持犯相对。持戒比丘不应如是生有为想。明持不应。若言如来是有为下彰犯所为若言有为即是妄语。明有罪因。死入地狱彰有罪果。三心言相对。如来无为不应说言如来有为。劝舍邪言。汝从今日应舍无智求正智等。劝舍邪心。上来教劝。若能下合。前六句中但合第六。文相可知。上来第三纯陀因试自显己解。自下第四文殊述叹坚其常解。文殊叹言善哉善哉。是总叹也。下别叹之。别中初先约贫女喻反叹纯陀。汝今已作长寿因缘。叹其所成。能知如来是常法等。叹其所解。是常总也。不变无为是其别也。离细生灭名不变易。离粗分段名曰无为。亦可如来真身无生。名曰无为。以无终灭。说为不变。下复约前火人之喻。反叹纯陀。汝今如是善覆如来有为相等。叹其所说。于中先法。后以喻帖。以是善心生忉利下。叹其所得。于中先喻。汝亦下合。汝亦如是善覆有为。合前以是善心言也。必定当得三十二相合生忉利。八十种好合为梵王。十八不共无量寿命合为轮王。不在生死合不生恶。常受安乐合常受乐。上来四段合为第一显佛无为。自下第二明佛无待。于中有四。一明如来身患已亡。二佛告已下如来述赞。三因前言重明如来心患已尽。四文殊言如是如是如汝说下文殊述赞。就初段中。文殊初先催供反试。纯陀言下。纯陀以理明佛无待。文殊催中。先止前言。下正催之。止前言中如来次后自当广说。推说归佛。佛哀叹下广显己常。名后自说。我与汝下自相抑止。我之与汝俱覆有为。息其论心。有为无为且共置者。止其论言。暂停非永。故言且置。下正催中句别有四。一催令速施。二如是施下叹胜劝为。何故此施偏得为最。解有三义。一因此施广显法化。故得为最。二佛食此已入大涅槃。所为事大故施为最。三如来垂灭。道众斯集。供奉宽广。故得为最。三若比丘下举类显胜。然此泛举一切比丘比丘尼等。远行疲极。随时给施。具檀种子。类今亦然。不言此会。四若有最后施佛已下。举灭重催。上来文殊催供反试。自下纯陀明佛无待。施中四句。一呵文殊。汝今何故自贪此食令我时施。问曰。文殊为佛催供。纯陀何故呵责文殊自贪此食。释言。文殊为佛催供。元由自己须食心起。自己须食。谓佛亦然。纯陀深测。就本以呵。故云何故自贪此食。又复文殊向前催供为佛及僧。文殊是僧。为己催食。是故呵之。汝今何故自贪此食。道其自贪明佛无待。二如来昔下正明无待。于中举昔苦行以验。三汝今实谓如来已下审定文殊。四我定知下申己所解。彰佛无待。第二如来赞纯陀中。初对文殊印可纯陀。文殊深智明练是非。对之述可。以显纯陀所言决定。善哉已下正对纯陀而为述叹。纯陀如学。人多不信故。佛述可令人归信。汝成大智正是叹词。善人已下显大智相。入犹解也。谓解大乘经中深义。自下第三重明如来心患已尽。何因辨此。由向如来述可纯陀。似有爱憎。故下遣之。于中有二。一明如来体无分别。二如国王下明佛出过分别境界。前中有四。一因文殊反试明佛无偏。二文殊言如来于汝及以我下。因文殊反试明佛无悦。三如来无有爱念想下显前第二。四等视一切如罗睺下显前第一。初中文殊先为反试。语纯陀言汝谓如来是无为者。牒其上言。如来之身即是长寿。自述其语。若作是下明佛悦可。纯陀答言非独悦我亦悦一切。明佛无偏。第二段中。初文殊言如来于汝及我一切皆悉悦可。文殊反试。纯陀答下明佛无悦。于中有四。一总呵文殊。汝不应言如来悦可。二夫悦可下明悦可过。过有四重。悦可一重。倒想两重。生死三重。有为四重。三结呵文殊。句谓如来是其有为。据后以呵。四纵以示过。若言有为我与仁者俱行颠倒。言佛悦可即是有为。故是颠倒。自下第三明佛无爱。成前第二无悦可义。如来无有爱念之想。正明无爱。夫爱念下举过彰离。先举其过。夫爱念者总以标举。如彼已下寄喻显过。如世母牛爱念子故。虽复饥渴行求水草。若足不足。忽然还归到其子所。喻明世人有爱念故。虽复行化饶益他人。若竟不竟。忽然放舍还益所亲。佛无此念。对过彰离自下第四举佛等慈。成上第一无偏之义。等视一切如罗睺罗。正明等慈。如是念者是佛境界。结德属人

上来明佛体无分别。下明出过分别境界。于中两喻。初喻明其近不及远。亦得名为钝不及利。后喻明其下不测上。前中先喻。譬如国王调御驾驷。喻佛胜出。久习胜慧名调驾驷。欲令驴及无有是处。喻己不及。下合可知。下不测中。先喻。后法。喻中偏明上能知下。如金翅鸟喻佛真身。升虚空者喻佛真身。住法性空无量由旬。显证深远。此明证智。下观海者喻佛教智。照知世间生死大海悉见水性鱼鳖等者。喻见众生愚智差别。及见己影。喻见自己应身随世。法中偏明下不测上。文之左右。凡夫小智不能量者。明凡二乘不能知上。二乘之人名之小智。我与仁者亦复如是不能量者。明诸菩萨不能知上。纯陀道己及与文殊。亦如向前凡夫小智不能量也。道己及与文殊不量。类诸菩萨一切皆尔

上来明佛心患已尽。自下第四文殊述赞。何故须然。文殊高人。言设非理。人多从受。故赞纯陀令人归信。如是如是印可其言。我于此下回解归己。彰己先解。成其说是。直欲试下拂会上言。自己久知。专为试彼。是故云直。试汝纯陀同诸菩萨所解之事。故云试汝诸菩萨事。由前纯陀自言己解。己与诸大菩萨齐等。故须试之

自下第三佛对纯陀广显前应。问曰。直尔辨直便足。何劳说应。释言。权隐导引化废。故须辨应。其义何也。若不明佛应身有灭。无由使人厌舍有为。若不明佛应身受供。无由使人成就檀行。趣入无为。故须辨应。文中有四。初佛催供明佛有待。二尔时纯陀闻佛语已举声啼下明应有为。三如来不欲久住已下。对前第二明应有灭。四我今受汝所献供下。对上第一明应有受。问曰。何故有此四段。良以翻前成上故尔。四中前二翻上纯陀所辨二真。后之两段成前如来所显二应。故有四段。是义云何。向前纯陀初明如来真身无为。后显如来真身无待。今乘言便。从后向前次第翻之。初段翻后真身无待明应有待。第二翻前真身无为明应有为。后之两段成上如来所辨二应。如来向前初明如来应身有受。后明如来应身有灭。今乘言便。从后向前次第成之。第三成上应身有灭。第四成前应身有受。初中有二。一光照文殊身业催供。二言告纯陀口业催供。前中有三。一光照文殊。何故须然。上来文中纯陀辨真。文殊显应。今欲述成文殊所显。故光照之。又复文殊前已催供。如来今欲令其重催。是以光照。又佛大人望直发言自为催食。于化不便。故照文殊令其先催。然后助劝。第二文殊遇光知表。催令速施。遇斯光者身遇光也。知是事者内心知也。知佛灭事亦知放光为催供事。寻告已下口言催也。先辨光意。佛现是相。不久涅槃。次劝速施。下劝纯陀令知光意。佛放是光为催汝供。非无因缘。三纯陀闻已悲塞默然。佛口催中圣意殷勤。郑重至三。上来第一明应有待。自下第二明应有为。于中纯陀先请为由。后佛答之。请中有二。一闻如来正尔涅槃悲号啼哭。二复白众下求众共请。一人之感未若多人。故求众请。答中还二。一对前悲哭。劝之莫啼。二当观已下对前请住。劝观五非。明应有为不可久住。初先劝观空无我义。坏器已下劝观无常。当观诸行如杂毒食。劝观其苦。有为多过劝观不净。三十六物集成己体。名多过患。自下第三明应有灭。文别有四。一纯陀请。二如来答。三纯陀领解。四如来述赞。初中有二。一对前如来莫啼之言。明佛不住悲啼难止。二唯愿已下对上如来劝观有为。请佛哀怜为我久住。请意如何。虽知如来自厌有为。愿佛怜我。为我等故久住于世。又复我等有斯五过。未能舍离。愿佛慈怜久住于世教我舍离。答中亦二。一对上后请。明为怜汝今入涅槃。二汝今观下对上初请。明有为法不可久住。劝令止悲。前中四句。一呵其请词。汝不应言怜我故住。二我以怜下显己化意翻其请词。我以怜汝。对前唯愿怜愍我也。及一切者。对前及诸众生言也。今入涅槃。翻前久住勿入言也。云何以怜今入涅槃。为令众生同舍有为趣入无为。故曰怜愍。三何以下释显怜相。我以何故今入涅槃名为怜汝。诸佛法尔有为亦然。对问辨释。诸佛为化。法尔尽灭。故云法尔。有为同佛。故名亦然。令诸众生知佛法尔有为亦然。厌离有为。故名怜愍。此与向前诸佛境界皆悉无常。诸行亦然。其义相似。四是故下显前有为亦然之相。有为无常。生已不住。明同如来有为无常。无常故苦寂灭乐者。明同如来灭已为乐。下对初请。劝止悲中。先对向前如来不欲久住之言。明有为法多过难住。是故已下。对上文中我当云何而不啼哭。结劝止悲。前中汝观一切行杂劝其观苦。诸法无我劝观无我。无常不住劝观无常。此身多有无量过患劝观不净。犹如水泡劝观其空。是故汝今不应啼者。是有为法。具前诸过。不可住故。不应啼泣。第三纯陀领解之中。如是如是诚如尊教。总述佛语。如佛所说一切皆是。故曰如是。下别对之。虽知如来方便涅槃。而我不能不怀苦恼。对佛后劝不应啼泣。显悲难止。覆自思下对佛前答。明己欢喜。由佛示灭。知有为过。趣入无为。所以欢喜。第四如来述赞之中。初对向前。虽知如来方便涅槃而为赞叹。善哉叹词。能知已下出其所叹。汝今已下对前不能不怀苦恼而为开解。于中有三。一明如来化必须灭。二不应思下明佛寿命长短难测不应愁恼。三一切法下明佛于有心不染着。令求舍离不应愁恼。初中先喻。如娑罗娑鸟喻佛应身。春阳月者是养子月。喻诸众生道机熟时。皆共集彼阿耨池者。喻佛同归尽灭大池。鸟入大池引子同入。佛入涅槃为引众生趣入无为。下次合之。诸佛亦尔合娑罗娑鸟。皆至是处合春阳月。集阿耨池。所谓至于尽灭之处。第二句中不应思佛长寿短寿。以理诫劝长短难测。故不应思。第三句中一切诸法皆如幻者。明有虚妄。如来在中以方便力无所染着。明佛不染在而不着。故曰方便。何以下释。诸佛于有法皆不染。故曰法尔。以不着故今入涅槃。不应愁恼。上来第三明应有灭。自下第四明应有受。于中有二。一佛许受供催令速施。二纯陀奉命归家辨供。前中复二。对上纯陀自为之心许为受供。二汝若为生作福田下。对上纯陀为他之心催令速施。前中我今受汝所献。正许受供。为欲令汝渡生死者。明己受意。若诸人天于后供下叹益劝为。谓得如来不动果报。何以故下释得所以。以我是生良福田故。供者皆得。对为他中。汝欲为生作福田者。举其所求。速辨权施。就明纯陀办供之中。句别有三。初言为生得度脱故。低头饮泪。强抑哀情。若不供佛求度生死。徒悲无益。故须强抑裁己哀情便泪不堕。名为饮泪。二白佛下领佛前劝。明己现在不能思量佛寿长短。于中先明当来能知。我等今下明现不知。此名如来应化示灭以为涅槃。真身当住为非涅槃。若我成佛堪为众生作福田时。知佛化灭名知涅槃。知真常存名非涅槃。现在未知如来化灭。故言我等不能思量如来涅槃。亦不知佛真身常住。名非涅槃。三尔时下辞佛辨供。纯陀献供。须人教示。故与文殊相随而去

上来第一对其影响明菩提报常。自下第二对其所为明涅槃法常。于中初先动地为由。时天龙下比丘哀请如来为说。前中有三。一正明地动。二动有二下泛明地动大小差别。三从兜率下明动所为。就初段中。其去未久明地动时。是时大地六种动者。正明地动。地动有六。如地经说。一动。二涌。三起。四振。五觉。六吼。乃至梵世明动分齐。第二段中先举二数。次列两名。或有地动是小动也。或大地动是大动也。依如地经动别有三。谓动遍动等遍。动也一处动者直名为动。前后次第周遍动者名为遍动。一时遍动名等遍动。今摄为二。初直动者名之为小。遍及等遍说之为大。下广辨之。句别有五。第一就动以辨大小。动如车掉。第二就吼。地中出声。三就振起。振则下去。起如面起。第四就涌。涌如泉沸。第五就觉。令人觉知。文相可解。此集经者所分别耳。第三段中。初集经家泛明所为。如来八相成道之中。且就六相以明所为。一从兜率下阎浮时。二初生时。三出家时。四成佛时。五转法时。六涅槃时。上生兜率及住胎中二时不论。今日已下地动声中自辨所为。故下文言人非人等闻是语已身毛皆竖。自下第二比丘哀请佛为宣说。于此分中。义二文四。言义二者。一明如来三事涅槃。二时诸比丘闻佛世尊定涅槃下明四法实。义言文四者。一诸比丘等哀请为由。二佛告比丘莫如凡夫诸天人下。如来为说三事涅槃。三诸比丘闻佛世尊定涅槃下。比丘重复哀请为由。四佛告比丘谛听已下。如来为说四法实义。第一段中。初明大众睹相悲哀。先举悲人。闻是语已悲哀所由。谓闻向前地动声中。今日如来将入涅槃如是大动。身毛已下正明悲哀。先身后口。下请佛住。于中有二。一举如来去住损益求请如来。二偈后长行举圣去不应征请如来。前中偈有十三行半。分之为二。初十一偈半明圣去有损。末后两偈明圣住有益。损中有四。初四行半明己无救。次有四偈彰己无依。次有一偈举圣去不还成前无救。下有二偈举佛放舍成前无依。第一段中初有二偈明无救者。后两偈半明无救损。无救者中。初有半偈自宣己心。次有半偈明无救者。后之一偈彰己悲苦。无救损中。初法。次喻。后合。下结。贫穷无救是法说也。贫无善财。恶无救护。犹如下喻。众生下合。是故下结。其次四偈明无依中。初偈明无功德所依。先喻。后合。我等合人。失萨合前。国无君主及法味者。合前饥饿。第二一偈明己悲苦。先法。后喻。第三一偈无慧所依。大仙涅槃佛日坠地。无所依人。法水枯涸。无所依法。我等定死。明无依损。慧命不续故名定死。第四一偈明己悲苦。先法。后喻。其次一偈举佛不还。成无救中。初之半偈举佛不还。后之半偈彰己无救。其次两偈举佛放舍。成无依中。初有偈半明己悲苦。后之半偈怨佛放舍成已无依。上明去损。下彰住益。初一偈半明佛住世令人离苦。初偈立喻。后半合之。如来通光合前三句。能除我苦合后一句。下有半偈明能生善。先法。后喻。自下第二明去不应征请如来。请别有五。两义名之。一约所化以别五请。别之云何。一所化有本请。二所化堪受请。三所化未出请。四所化未齐请。五所化迷惑请。二就能化以别五请。别之云何。一明如来有始无终请。二有怖未除请。三所作未讫请。四所为未等请。五未同慈导请。第一请中。初喻。次合。唯愿已下结请佛住。喻中如王喻佛如来。生育诸子喻诸比丘。从佛化起故言生育。道机不邪名貌端正。圣心慈怜名常爱念。劝教三学名教伎艺所习皆成名悉通利。此喻有始。下况无终。佛舍灭度令诸比丘为其变易生死所切。名为将付魁脍令杀。下次合之。我等今日为法王子合前王子。蒙佛教诲合教伎艺。已具正见合悉通利。亦可合前形貌端正。此合有始。下合无终。愿莫放舍反合付杀。如其放舍顺合付杀。结请可知。第二请中。初明如来有畏未除。若使已下请住除畏。前中先喻。有人喻佛。善学论者喻自知法。复于此论而生畏者。惧他不信。下次合之。如来亦尔合前有人。通达法者合学诸论。所谓通达大乘诸法。于法畏者合于此论而生怖畏。畏人不信堕于地狱。下请住中。若使如来久住于世说甘露味充足一切。请住说法。名大乘法以为甘露。如是众生则不复畏堕地狱者。明说利益。谓于如是所化众生。如来不复畏其不信堕于地狱。第三请中。先喻。后合。喻中如人初学作务为官所收闭囹圄者。喻佛化始随物在。有有人喻佛。本在因时始习化人。名学作务。感圣之机名之为官。感佛在有名官所收。恒随不舍名闭囹圄。古旧方狱名为囹圄。有人问下喻化未讫不得自安。有人问之汝受何事。假问起发。同行之流名为有人。问佛在于三有所以。名受何事。答曰我今受大苦者。假答显德。为物辛劝名受大苦。若其脱下喻明化讫方得受乐。下次合之。世尊亦尔合有人也。为我等故修诸苦行。合初学作为官所收。我等今者未免生死云何如来得受乐者。合有人问汝受何事答言我今受大苦恼。我未出苦。佛今正应为我受苦。云何舍我自受安乐。若脱受乐。略而不合。第四请中文别有三。一明如来所为不等。二如来于法应无悭下以理责佛。三唯愿下结请佛住。初中先喻。医王喻佛善解方药。喻佛能知大乘秘法。偏教子者喻教文殊。不教余者。喻佛不教诸比丘等。下次合之。如来亦尔。合医解药。独以秘藏偏教文殊。合以秘方偏教其子。遗弃我等合不教余外受学者。第二责中。初明如来于法无悭责同世医。后明如来于人无偏责同世医。前中初言如来于法应无悭者。量圣异凡。以理测寻。未敢专决。是以言应。如彼医王偏教子等。责圣同凡。后中初言彼医所以不能普教。情存胜负。简凡异圣。如来之心终无胜负。量圣异凡。何不见诲。责圣同凡。第三结请。文显可知。第五请中。先喻。后合。喻中譬如老少病人。比丘喻己离善行险彰己迷惑。更有人等喻佛如来应见示导。异人喻佛。见之怜愍喻应怜已。即便示等喻应教已。合中初先合己迷惑。我亦如是是总合也。所谓下别。唯愿已下约前异人请佛示导。唯愿示我甘露正道。请佛说法。无上涅槃能除热恼。故曰甘露。约喻名法说为正道。久住世等请佛不灭。然此二请。下佛对之有顺有违。宜审记之

大般涅槃经义记卷第一(之下)应永三年十月日以劝修寺大经藏本誂弘清阿阇梨书写了　　　　　　　法印权大僧都　贤宝涅槃义记卷第二

        隋净影寺沙门释慧远述

上来比丘哀请为由。目下第二如来为说。文别有二。一对前众悲抑止哀情。二复次比丘下对前众请正为宣说。以众悲哀妨乱受法。故先抑止。于中初先止其悲相。为说偈下开解其心。前中如来先劝止悲。后明大众闻劝悲止。如来劝中。汝等比丘莫如凡夫诸天等诫劝悲止。比丘爱尽。是故不应如诸凡夫。良以比丘正是所为。故偏诫之。此文虽复言对比丘。意兼大众。故下大众闻说止悲。当勤精进敬修善念。下明比丘闻说止悲。初先法说。如人下喻。虽裁外相内悲难止。故如殡子止不啼哭。下开其心。于中两偈。前偈以理劝舍悲苦。后偈依善劝生欢喜。前中开意不应愁苦。正劝止悲。诸佛法尔是故当默。以理开解。后中初先教修善法。乐不放逸教修戒行。守心正念教修定行。远离非法教修慧行。慧能治过名离非法。亦可初句乐不放逸劝修慧学慧是波若不放逸根。名不放逸。守心正念劝修定学。远离非法劝修戒学。戒离诸过名离非法。慰意受乐劝令生喜。慰意当前汝等开意。受乐当前不应愁苦。自下第二对请为说。于中有三。一举疑劝问。二亦当为汝先说已下对上所请。许说违住。三佛出世下正为宣说。初中如来惧诸比丘不堪咨启。故举劝问。于中初先举疑令问。后许酬答。前中比丘有疑当问。是总劝也。若空下别。别中略举十四种门以劝其问。若空不空义有多含。若就生死涅槃相对。生死名空。涅槃不空。故下文言。空者所谓一切生死。言不空者谓大涅槃。若就二谛相对以论。义则不定。若说相空以为真谛。真谛名空。世谛不空。若说真实如来藏性以为真谛。真谛不空。世谛名空。以不实故。故胜鬘中妄法名为空如来藏。真法名为不空藏矣。若常无常义亦多含。若以生死涅槃相对。生死无常。涅槃是常。二谛相对。世谛无常。真谛是常。若依非依义亦多含。邪正相对。三宝可依。外道非依。真妄相对。真法可依。妄法叵依。故胜鬘中说如来藏以为一依。若去不去义亦多含。邪正相对。正行出离名之为去。邪行沉没说为不去。因果相对。因名为去。果则不去。若归不归义亦多含。大小相对。小乘趣大名为有归。大无所趣说为不归。因果相对。因则有归。果则无归。若恒非恒。与前若常无常何别。通释是一。于中别分。不生名常。不灭曰恒。义亦多含。染净相对。生死非恒。涅槃是恒。二谛相对。真谛名恒。世谛非恒。若断若常义亦多含。染净相对。生死终断。涅槃是常。真妄相对。妄想可断。真识是常。若众生非众生义亦多含。内外相对。内是众生。外非众生。假实相对。假是众生。实非众生。空有相对。有是众生。空非众生。就人相对。佛非众生。离生死故。余是众生。若有若无义亦多含。若就有为无为分别。三有为法名之为有。三无为法说之为无。若就二谛相对分别。有为无为同名为有。无我我所说之为无。如地持说。若就人论。凡有生死而无涅槃。圣有涅槃而无生死。如下文说。若实不实义亦多含。染净相对。生死不实。涅槃名实。权实相对。一乘是实。三乘不实。真妄相对。妄情不实。佛性是实。二谛相对。世谛不实。真谛为实。浅深相对。三谛非实。一实为实。若真不真义亦多含。染净相对。生死不真。涅槃是真。二谛相对。真谛为真。世谛不真。若灭不灭义亦多含。四谛相对。灭谛是灭。余三非灭。真妄相对。妄法可灭。真法不灭。若密不密。就教论之。大小不定。或小教名密。大教不密。小乘覆实名之为密。大教显实故名不密。或大教名密。小教不密。大乘深隐故名为密。小乘粗显故名不密。若二不二。就乘论之。权分大小说之为二。实唯一大名为不二。如是种种有疑今问。总以结劝。我当随顺为汝断者。许为酬答。自下第二对上所请许说违住。亦当为汝先说甘露。是许说也。对前许答故云亦当。望后取灭名为先说。然后涅槃违其请住。向前比丘第五请中。云言示我甘露正道。故许为说。复言久住勿入涅槃。故今违之。自下第三正为宣说。于中有二。劝舍昔伪令修今真。二我今当令一切生下。就真为说三事涅槃。正酬上请。前中有三。一双夺因果劝修今真。二云何庄严正法城下。别夺昔果劝修今真。三汝等虽得出家已下。别夺昔因劝修今真。就初段中。先夺昔伪。我于往下劝修今真。夺昔伪中。先明昔来所得是难。离八难下牒以夺之。前中初先法说明难。难有六种。一佛出世难。二得人身难。三值佛出世难。四生信难。五能忍难忍明闻法难。忍犹可也。难信之法而能忍可。故名为难。亦可忍者解之别称。于难解法而能解知。故名为难。六具禁戒得罗汉难。具戒是因。罗汉是果。六中初一就佛说难。后五约就比丘辩难。下喻显之。如求金沙喻后五难。求金于沙甚难可得。生死法中求是五事。至极难得。如优昙华。喻佛出难。上来明其所得是难。自下第二牒以夺之。离八难者。牒举向前六难所离。比丘得向后五难时。即离八难。故今举之。言八难者。三涂为三。生盲聋等以为第四。世智辩聪以为第五。佛前佛后以为第六。郁单为七。长寿天处以为第八。八中前三在下三趣。次四在人。后一在天。得人身故离三涂难。值佛离于佛前佛后。生信离于世智辩聪邪见之难。闻法离于盲聋等难。具戒得果离于郁单长寿天难。彼无得故。得人身下牒其所得。后五难中偏牒初二。初二亦是大乘所依。不须夺破。故偏牒之。得人身难牒前第一。汝等遇我牒前第二。不应空过约就前二。夺后三种。于小乘中虽有信等。望于大乘。全无所得。故曰空过。上来夺伪。下劝修真。句别有四。一举己昔因。二今得下举己今果。所成果德超过二乘。故曰无上。得大涅槃。不舍世间。无碍善巧。故曰方便。三为汝等下就己昔因明修所为。欲使众生荷恩受行。舍身手等犹前苦行。四是故下就己今果结劝修习。我为汝等求得如是无上果故。不应放逸弃而不学。别夺果中。初辩今真。汝今遇下约真夺伪。前中云何庄严法城。问以起发。涅槃正法似世宝城。法从喻称。名法宝城。此法宝城云何庄严。下对显之。具种种德总显庄严。戒定智慧为墙堑等别显庄严。戒能防非故说为墙。定意深静说之为堑。慧能观照名为埤堄。就下约真夺伪之中。汝今遇是不应取此虚伪物者。正劝舍伪。譬如已下明取伪失。先喻。后合。汝诸已下结劝舍伪。别夺因中。先夺昔伪。今当已下劝修今真。前中四句。一夺出家。二夺染衣。三夺乞食。四夺剃发。文显可知。劝修真中。我今真实教敕汝等。总以标许。下别教之。于中有三。一明现在三宝缘具劝令勤修。我今现在佛宝缘具。大众和合僧宝缘具。法性不倒法实缘具。是故已下结劝修习。当勤精进摄心勇猛。劝修善法。摧诸结使教断恶法。二十力没下举圣灭有损催令速修。名佛以为十力慧日。佛灭度后无人教汝断除闇障。是故当为无明所覆。曼佛今在当应速修。三譬如下叹法多益令其必修。先喻。后合。我法亦尔合地药草。出生妙等合为生用。出生妙善甘露法味明能生善。而为众生病之良药明能灭恶。下众因此所夺所劝而为启请。宜须记之。上夺昔伪劝修今真。自下第二就真为说三事涅槃。文别有三。一许安众生令住秘藏。二我亦下自许安住。三何等下显其所住秘藏之相。初中当令一切生者凡夫众生。及我子者菩萨名子。以诸菩萨德堪绍继。故说为子。四部众者。谓声闻众在家出家各分男女。故有四部。同教令证大般涅槃。名安秘藏。大般涅槃昔隐不说。故名秘密。权教所覆。故复名藏。故下文言十一部中所不说故。名之为藏。又于其中包含诸德。亦名为藏。第二段中。我亦复当安住是中入涅槃者。自许安住。已住同他。是故言亦。实则久住。对今息化始入名当。息化归真名入涅槃。第三段中。何等秘藏牒问起发。下对显之。应先解释三事涅槃然后释文。义如别章。文中先喻。喻中初言犹如伊字。总举喻事。此乃举其胡书伊字。下辩喻相。文有四句。前后不次。若正应言三点若并则不成伊。纵亦不成。三点若别。亦不得成。如摩醯首罗面上三目乃得成伊。准合应尔。但今文中。先举纵并。次举摩醯三目成伊。却明别异。道如摩醯面上三目。立喻显喻。合中初言我亦如是。合初伊字。此言不足。若具应言。我之所得秘密之藏亦复如是。下别合之。先合不成。解脱之法亦非涅槃。乃至般若亦非涅槃。合上纵并不得成伊。三法各别亦非涅槃。合上文中三点若别亦不成也。此成不成别章具论。今此略以三义释之。一就真应相对分别。应化三事无常生灭。不成涅槃。以不成故今须灭之。真德三事方成涅槃。以真成故。今入其中。二约性净方便分别。方便三事菩提门收。不成涅槃。性净三事方成涅槃。此经偏明性净之果为涅槃故。三就性净总别分别。别分不成。总摄则成。如彼三点别不成伊。总摄则成。我今安住如是三下。合如摩醯首罗三目乃得成伊。此乃安住真常三事。亦可安住性净三事。故成涅槃。所住虽常。为化众生。灭应归之。故言为生名入涅槃。所谓入于化灭涅槃。故下大众闻之悲啼。如世伊字举喻以帖。随法粗分。上来明其三事涅槃。自下显其四法实义。若作四分科判其文。前二段竟。自下第三比丘重复哀请为由。闻佛世尊定当涅槃皆悉忧等。明众哀泣。稽首下请。稽首身请。白佛口请。口请有三。一叹昔以请。二如帝王下比丘举己有惑以请。三如有人叹芭蕉下叹己。以请。比丘何因叹昔为请。由佛向前别夺果中告诸比丘汝等不应取虚伪物。故今比丘反叹昔日所得法真能观想胜。欲使如来翻。之显真。何故第二举惑以请。由佛向前别夺因中劝断结使。十力灭已汝等当为无明所覆。我法能为病之良药。故今比丘举己有惑请佛住断。何故第三叹己有解。由佛向前双夺比丘因果之中告诸比丘汝等遇我不应空过不应放逸。故今自叹善修无我故非放逸。以修无我能得涅槃故非空过。作此语者。欲使如来翻己所解。更明正修。下依此三。如来别答。宜须记知。初中为四。一因佛今灭。反叹昔教。彰己昔日所得法真非是虚伪。二如众生迹下彰己昔日能观想胜非是虚伪。三如来若离无常想下。难破如来安住之义。明佛定灭。成初段中无常法真。四如农夫下重叹昔日能观想胜。成前第二能观想胜。初中快说无常苦等。反叹昔教。比丘何因叹佛昔说。由佛今灭。佛今定灭。明法定是无常苦空。法既如是。昔言当法。是以言快。何故叹者。为显自己所得无常苦空法真。使佛翻之更显真法。第二段中。先喻。次合。后显胜相。喻中生迹喻不净等五度门观。象迹喻于无常苦空无我等观。象迹宽大广破故胜。合中初言是无常想亦如是者。合前象迹。此文略少。若具应言是无常苦无我等想亦复如是。文中就始且言无常。此实是慧。以想名说。何故如是。诸心心法更相受名。如四念处体实是慧而名为念。此亦同彼。又复此慧取相名想。于诸想中最第一者。合前一切迹中为上。下显胜相。若有勤修能除欲爱乃至憍慢。明能断除修道烦恼得有余果。欲界欲爱色无色爱三界贪使。无明憍慢是三界中痴慢二使。嗔在欲界。得那含时已能断除。故略不论。修无常想皆能灭之。亦断见惑。文中举终。始则可知。及无常想明能灭智证无余果。亦灭苦空无我等想。且说无常。自下第三难破如来安住之义。明佛定灭。成前第一无常法真。于三事中。且就波若难破住义。余类可知。然今约前无常之想。进退作难。以无常想与彼波若同是慧故。难意如何。如来若离此无常想。更有常法于中安住。安住则不灭。今则不应入于涅槃。今入涅槃。明佛离此无常想外更无常法可以安住。若佛不离此无常想。毕竟安住如是想中。此想便常不可断灭。云何昔言修无常想能灭烦恼及无常想。修无常想。还能灭于无常之想。何处安住而言不离。离与不离皆无住义。明佛定灭。佛定灭故无常理定无常法真。第四重显能观胜中。初先正叹。下牒结之。前中先喻上说象迹广破故胜。此说秋耕永尽故胜。下合可知。下牒结中。先牒耕喻。乘言便故。次牒迹喻。于诸想下总合显胜。第二大段举惑请中。文别为五。初二彰己无明未遣请佛住断。次二彰己四住未亡请佛住断。后一彰己倒想未除请佛住断。比丘何因举斯请断。由佛向前别夺因中。云言十力既灭没已汝等当为无明所覆。故举无明请佛教断。由佛向前劝摧结使。故举四住请佛住断。由佛前言我法能为病之良药。故举倒想请佛住断。问曰。经说二乘能断四住烦恼。比丘应无。今以何故。请断四住。解言。四住有粗有细。粗者久无。细者犹在。故今请断。又问倒想与前四住无明何别。而别请断。解言。倒想是无明起。四住家因。故别请断。云何得知。如地持说。如是如实凡愚不知起八妄想。故知倒想是无明起。即彼宣说八种妄想能生见慢贪恚痴事。故知倒想是四住因。五中初二有何差别。前一彰己无明未断。后一显己无明在故。不得如来三事涅槃。次二何别。前一彰己四住未断。后一显己四住在故不得安乐。故有五别。就初请中。初先立喻。帝王喻佛。知终恩赦狱囚脱者。喻佛垂灭应教众生。除灭无明。如来今下约喻求佛。我等今下彰己未出征请佛住。第二请中。初先立喻。如人鬼持。比丘喻己为无明缚。遇良咒师咒力除差。喻佛能救。是中少一身得安乐。下约求佛。如来亦尔合良咒师。为声闻等求佛同前咒力除鬼。令得安下合同病人身得安乐。此举波若及与解脱。等于法身。如世伊字。约喻别法。大乘三事如世伊字。小乘三事或纵或并。或复别异。不似伊字今言如伊。即显不同小乘三事第三请中初先立喻。我未已下彰己未同。云何已下征请佛住。喻中如象为人缚者。喻佛菩萨本为四住烦恼所缚。人喻惑境。羁锁喻惑。缠心名缚。虽有良师不能制者。喻上五欲及众魔等不能系缚。顿绝羁锁自恣去者。喻佛菩萨断障出去。次约前喻彰己未同。我未如是未同香象。未脱五十七烦恼者自未见文。有人传言。出佛毗婆沙。佛毗婆沙有十八卷。彼说见惑有其五十。所谓十使迷覆五阴。修惑有七。欲界有四。贪恚痴慢。上界有三。除嗔有余。义甚契当。但佛毗婆沙。经录中无。不知是非。云何已下征请佛住。第四请中。亦先立喻。次约显己。云何已下征请佛住。喻中初言如人病疟。喻佛菩萨本为使缚。细使在心未发如疟。值遇良医所苦除者。喻佛菩萨。值遇过佛闻法除障。次约显己。我亦如是多诸患等。明己同于向前病人。四住残结殃累身心。名多患苦。见为邪命。爱为热病。虽遇已下彰己未同所苦除者。虽遇如来病未愈者。恶法未离。未得无上安隐常乐。净德未成。云何已下征请佛住。第五请中。初先立喻。次约显法。后请佛住。喻中有二。一喻己迷惑。二时有良医与药已下喻佛能治。前中初言譬如醉人。举其喻事。醉人喻己。无明住地及妄根尘能生倒想。喻之如酒。惑心起妄。说之为醉。下显醉过。过有三种。一喻起烦恼。二言语下喻明造业。三卧粪秽下喻明受苦。起烦恼中。不自觉知不识亲疏母女姊妹。喻己有痴。不知自体如来藏性本寂无为。名不自知。不知妄心亲迷真起。名不识亲。不知妄境从妄心生。名不识疏。不识此等。故名为痴。迷荒淫乱喻起倒想。想谓八妄。如地持说。喻造业中。言语口业。放逸身业。受苦可知。第二喻佛能治之中。初治醉体。还自已下除其醉过。治醉体中。良师喻佛。说法授人名与药服。受法修行名为服已。舍离痴惑不取妄境。名为吐酒。除醉过中。悟解自体本性清净。名为自忆。翻前不自觉知言也。识知亲疏。名之与识。翻前不识亲疏等也。心怀惭愧深自克等。翻前迷荒淫乱等也。言语放逸卧粪秽中略不翻之。下约显法。于中还二。一约前喻。明己迷惑。二约后喻。明佛能治。请佛说法。前中先合譬如醉人。我亦如是合前人也。往昔已来情色所醉。合前醉也。情谓五根。色谓五尘。此根举尘生惑之缘。故说为酒。依此生结惑乱己心。名情色醉。下合醉过。不自觉知不识亲等略而不合。贪嗜五欲合前淫乱。非母母想乃至非生作众生想。合前迷荒。言语放逸略而不合。是故轮转受生死苦。合卧粪秽。如彼醉人举喻以帖。自下第二约前良师能治之喻。请佛说法。如来今当施我法药。请同良师。与药服也。令我还吐烦恼酒者。合服已吐。而我未下彰己未同醒悟之人。征请佛住。就第三段叹己请中。文别有三。第一比丘因佛上言汝等遇我不应放逸不应空过。叹己善修。欲使如来翻明胜修。二如来述赞。三比丘闻赞乘言起过。就初段中有五复次。前三复次叹己善修。后二明己所修殊胜。复就前中。初一复次责情显理。彰己善修。后二复次观法离我明己善修。前中先喻。次合显法。我等已下结己善修。喻中如人叹芭蕉树以为实者。喻凡计我。芭蕉喻身。说我为实。无有是处责情显理。合中众生合上人也。若叹我等合叹芭蕉以为实也。亦无是处合无是处。我等以下结己善修。亦能修习无常想等。无我治胜。所以偏说。就后二中。前一复次观五阴法无其我用。先喻后合。后一复次观五阴法无其我体。先喻次合。我等已下结己善修。后二叹己所修胜中。前一能除修惑故胜。于中引佛昔说显之。贪嗔痴慢斯皆除断。且说除慢。余类可知。后一能除见惑故胜。先喻。后合。修无我想合前空也。而有诸见无是处者。合上鸟迹现无是处。第二如来述赞之中。善哉叹辞。汝等善修出其所叹。于有为过。此实能治。故佛叹之。第三乘言起过之中。初先起过。如人醉下自是非他。前起过者起何等过。以佛叹其有为法中善修无我。乘于佛地起无常等无为四倒。故名起过。比丘白佛我等不但修无我想亦更修习其余想者。不但于彼凡夫阴中修无我想。亦更于彼佛果阴中修无常苦无我等想。然此正得名于佛地起无常苦无我等想。不得名为无为法中起无常苦无我等想。何故如是。若知无为终不起于无常等倒。以何义故不说不净。不净事观。故不论之。又于如来无漏法中。人多不取以为不净。故不说之。理实具有。问曰。比丘于佛所得一切法中皆起此想。有不起处。释云。比丘于佛所得数灭涅槃。其唯起于无我之想。终不计为无常苦等。于佛身智具起倒想。以己所得仰类佛故。就下自是非他之中。初先非他。后便自是。前中初先立喻非他。人喻凡夫及诸菩萨。痴惑乱心说之为醉。心志浊闷名为瞑眩。山河石等喻凡五阴。日月星辰喻佛五阴。妄见称视。取为常乐我净之法。翻违前境名悉回转。视山河等皆悉回转。喻凡妄计下地五阴为常乐等。视日月等皆悉回转。喻诸菩萨计佛五阴为常乐等。声闻之人悉用为倒。故名回转。若不修下法说非他。先举凡夫及诸菩萨为不修人。下就显非。如是之人不名为圣明无正解。多放逸等明有邪过。放逸是因。生死是果。道不修者是其放逸。显己修故不名放逸。不放逸故。佛上不应言我放逸。上来非他。以是因缘我等善修。自是言也。以不修习无常等想不名为圣。多诸放逸流转因缘。故我所修得名为善。上来比丘哀请为由。自下第四如来为说四法实义以酬上请。依上三请。从后向前次第答之。先对第三自叹之辞。更为演说胜修之法。二比丘白佛如佛所说若离四倒则得了知常乐我下。对前第二请住之辞明己不住。三汝等当知先所修习无常苦等非真实下。对上第一叹昔之请教其甄简。初中如来先敕谛听后为宣说。说中有二。一夺昔伪修。二何等为义无我者名生死下教其真修。前中复二。一明比丘具足八倒故修非真。二世间亦有常乐我下。彰彼八倒依三倒生。前中复二。一对前比丘自是非他。明诸比丘无为法中具足四倒。二汝等若言我亦修下。对上比丘乘言起过。明诸比丘有为法中具足四倒。有为四倒犹未除遣。云何自叹我等善修无常苦等。前中有三。一牒以总呵。二何等义下广显不达。三汝等比丘云何而言有我想下总以结呵。初中汝向所引醉喻。牒前比丘非他之辞。但知文字不达义者。呵以显过。所谓但知回转名字。不达名下非回转义。第二广中何等为义。征问起发。此问不足。若具应言云何不达何等名为所未达义。准答应尔。下对显之。先对向者所少之问。明其未达。我者已下对前文中所有之问辩出其义。前中初先明诸比丘自是回转。次明不达。后以喻帖。明回转中。如彼醉人见上日月实非回转生回转想。牒前比丘非他之言。比丘前说见山河等悉皆回转。今此何故但举日月。释云。山河乃至屋舍喻凡五阴。日月星辰喻佛五阴。于凡五阴计常乐等名回转者。正当道理。不须非毁。为是不牒。见佛五阴为常乐等名回转者。乖违法理。所以偏牒。推过比丘。众生亦下约就前喻明诸比丘自是回转。众生亦尔合前醉人。此名比丘以为众生。为诸烦恼无明所覆。合前醉体。烦恼四住。无明即是无明住地。生颠倒下合前回转。生颠倒心总明回转。我计无我乃至计苦别明回转。下明不达。以为恼覆不达所以。虽生此想不达义者正明不达。虽生无常无我等想。不达常乐我净等义。如彼醉人举喻以帖。上明未达。下次辩义。常乐我净理实遍通一切佛法。然今隐显。我偏就人。余三就法。我是佛者。自在名我。自在之用在于佛人。故说为我。又复我者人之别称。故就佛人而说其我。常法身者。法身佛体显本法成。性出自古。体无变异。明常义显。故说为常。乐涅槃者。涅槃是灭。灭离众苦寂乐义显。故说为乐。净是法者。谓三宝中法宝之体。能治垢染。故说为净。上来第二广明未达。汝等已下总以结呵。我是佛义。善取我者称当佛义。汝等比丘云何而言有我想者憍慢贡高流转生死。比丘上言若有不修苦无常等。名有我想。亦应说言无常想等。对初我义且云我想。比丘上言多诸放逸。今名慢高。下明比丘有为法中具足四倒。文中有三。一呵其所取。二我今当下举真显伪。三苦计乐下正明比丘有为法中具足四倒。不应自叹善修苦等。就初段中。汝等若言我亦倒习无常苦等。牒其上言。比丘上言我等不但修无我想。亦更修习其余诸想。谓无常苦无我想等。故今牒之。是三种修无有实义。以理呵夺。于佛常乐我净法中而修苦等。故无实义。以何义故不明不净。义如上释。第二段中。我今当说胜三修者。下说常乐我净四修。但今翻对前三伪修。故言三耳。道己当说胜三修法。即显比丘所修不实。第三段中。文复有三。一泛举八倒。二有如是等下明八倒中有为四倒不知正修。三汝诸比丘于苦法下结彼四倒属诸比丘。初中应先解八倒义然后释文。义如别章。文中初言苦者计乐乐者计苦是倒法者。生死实苦。妄计为乐。涅槃实乐。横计为苦。故是颠倒。余三类尔。前已宣说无为四倒。今此何故重复论之。盖乃举前类后故尔。比丘不但无为法中具足四倒。有为法中亦具四倒。故通举之。又复惧人闻说常乐我净是倒。一向入于苦无常等四颠倒中。为遮此过。故说八种悉是颠倒。第二段中。有如是等四倒法者。就前八中偏牒有为四颠倒也。是人不知正修法者。不知无常苦无我等微细四修。又亦不知常乐我净四种真修。第三结倒属比丘中。汝诸比丘苦中生乐乃至不净生净想者。解有二义。一就众生分齐以说。比丘虽复观众生空断除正使。习气未尽。故起常乐我净等想。二约诸法分齐以论。诸比丘等未得法空。故于诸法起常乐等四倒之想。以不知法自性无常。故起常想。不知诸法自性坏苦虚集行苦。故生乐想。不知法空故起我想。不知诸法净相本寂故生净想。此想未除。云何自叹善修无常无我等乎。上来第一明诸比丘具足八倒。自下第二彰彼八倒从三倒生。八倒三倒有何差别。而言依三生八倒乎。是中三倒是迷理倒。迷诸法如。建立生死涅槃法相。不同小乘所说三倒。八倒是其迷法相倒。迷前所立生死染法建立常等。迷前所立涅槃净法起无常等。于彼三倒所立法中而起八倒。故说依生。文中初明有为四倒依三倒生。以三倒下明无为倒依三倒生。前中有四。一明世间及出世间并皆有其常乐我净。二分虚实。世间常等有字无义。出世常等有字有义。三何以下解释世间无义所以。于中先问。何故世间偏独无义。下对释之。以有常乐我净四倒。不知真实常等正义。所以无之。四所以下解释世间有倒所以。正明四倒依三倒生。于中先问所以世间有四颠倒。下对释之。以有心想见倒故尔。七识心体是其心倒。妄取法相名为想倒。于所取相建立定实名为见倒。亦可妄想谓有诸法名为想倒。重起心缘缘前所想名为心倒。于心所缘执定分明名为见倒。广如别章。此应具论。下次明其无为四倒依三倒生。句别有二。一明世人以三倒故乐中见苦。乃至净中见其不净。二以颠倒下明其世间有颠倒故。但知无常苦等名字。不知常乐我净正义。上来第一夺昔伪修。从此已下第二大段教其真修。于中有三。第一泛明八法实义。二是名下约义辩修。三若欲下就所修中简胜劝学。初中先问。云何为义。下对辩释。是中正意。为明常乐我净四义。约对以辩。通明苦等。常乐我净理实齐通。但今隐显。如来名我。义同前解。法身名常。亦如上释。涅槃名乐。灭离苦故。法宝名净。能治障故。苦无常等理亦齐通。但今隐显。就生死人偏说无我。往来流转不自在故。就二乘人宣说无常。终归灭故。就外道人宣说其苦。外道所作是苦因故。通就一切有为之法宣说不净。能染污故。第二约义以辩修中。是名不倒约法辩修。如法正解故名不倒。以不倒故知字义者。知八法名知八法义而不迷惑。第三简胜劝学之中。简取常等令人修习。若欲远离四颠倒者。离前无常苦等四倒。向说比丘具足八倒。今此何故但言离四。无常等四比丘所保。正违出世常乐我净。故偏举之。常等四倒非彼所保。力虽未及。当必厌断。故不举之。应知已下劝知常等四种正义。上来一段答上比丘第三所请。自下次答向前第二有惑之请明佛不住。于中比丘乘佛前言重请起发。下佛答之。请中有四。初比丘白佛如佛所说离四倒者则知常等。牒佛前言。二如来今者永无倒下明佛离倒具知常等。三若已了知常乐已下征请佛住。若佛已知常乐我净。何故不住一劫半劫教导我等而欲涅槃。四若见顾下要请佛住。于中先举住益要请。若住教我常乐净等我当至心顶受修习。若入已下举彼如来去损要请。若佛不住入于涅槃。我等何能与是毒身同共止住修治梵行。我亦随佛入于尽灭涅槃中去。文意正尔。不劳异解。下佛答之。明己正法悉付迦叶不须我住。于中先呵。汝等不应作如是语。我住则修。不住随灭。我今已下明不住意。于中初法。次喻。后合。法中初明所有正法悉付迦叶。后明迦叶作依同佛。问曰。下说一切声闻及大迦叶悉常无常。应以大乘付诸菩萨令法久住不付声闻。今云何言无上正法悉付迦叶。释言。付法分别有三。一约时分别。时有二种。一始终常付。付诸菩萨。以诸菩萨常能受持流布不绝。所以偏付。声闻弟子大迦叶等悉皆无常不能流通。所以不付。二随时别付。通付声闻及诸菩萨。如付法藏说。声闻弟子虽复不能常流法化。亦能一时匡化益物。故通付之。今言正法悉付迦叶。义当后门。以彼迦叶佛灭度后二十年中弘通正法。所以付之。下言大乘付诸菩萨。义当前门。二约人分别。义别有三。一凡圣通付。如下文说。如来今以无上正法付嘱诸王大臣宰相四部众等。二简凡付圣。唯付声闻及诸菩萨。如付法藏说。三简小付大。唯付菩萨。如下文说。今此文中言付迦叶。义当第二。下付菩萨。义当第三。三约法分别。义别有三。一大小分别。小付声闻。大付菩萨。故下文说十二部经唯方广部菩萨所持。余十一部二乘所持。二就大乘浅深分别。浅付声闻。深付菩萨。故龙树说波若义浅付嘱声闻。法华义深付诸菩萨。波若多说破相空理未显实义。故名为浅。法华宣说声闻作佛显其有性。故名为深。三就深经教义分别。论其教法通付声闻。义付菩萨。故下文言。今问阿难欲令受持大涅槃经。阿难比丘所未闻者。弘广菩萨当能流通。良以付法有斯多义。故此所说与后不同。喻合可知。汝等当知先所修下。第三大段对上初请教其甄简。于中初先正教取舍遣其执心。比丘白下为之会通遣其疑心。前中有二。一对上比丘叹昔所修无常想胜。以理呵夺。二春时喻下对前比丘叹昔所解无常苦空无我法真。教其甄简。初中当知先所修习无常苦想非真实者。以理正夺。无我等想亦非真实。略不备举。后中先喻。后约教劝。喻中有三。一求真取伪喻。二持出下知伪非真喻。三是时宝珠犹在水下舍伪取真喻。前段喻中。初喻闻慧。次思。后修。佛初出世名为春时。比丘非一说为诸人。昔教为池。诸比丘等依教除障。名在池浴。寻教起闻称曰乘船。得法畅心说为游戏。闻说苦等迷覆常乐我净真法。名为失珠。权教所隐名没深水。此喻闻慧。下次喻思。思教求义名共入水求觅是宝。下喻修慧。人别证法名为竞捉。所证苦等悉非真理。名为瓦石。取伪为真故言自谓得琉璃珠。得法适心。所以欢喜。第二知伪非真喻中。得旨舍诠。故言持出。悟解苦等非是实理。名知非真。第三舍伪取真喻中。还初喻闻。次思。后修。常乐真理犹为权隐。故言宝珠犹在水中。由理别故权实教分。故言珠力水则澄清。水之一事况于二教。浊喻权教。清喻实教。寻诠悟旨故言见珠。犹在水下。理未即心。故言如观虚空月形。此喻闻慧。次喻思慧。比丘众中能解常者以为一人。巧观求真名方便力。依教审思名安徐入。下喻修慧。修心证实名即得珠

下约前喻教劝比丘。句别有四。一约初喻呵其取伪。二约第三教其取真。三约第二劝知昔伪。四重约第三劝取今真。初中汝等不应修习无常等想以为实者。约喻以呵。如彼人下举喻类责。汝等应当善学方便处处常修常乐净等。约第三喻教修趣实。生生恒习故云处处。复应当知先所修习四法相貌悉是颠倒。约第二喻劝知昔伪。下重约第三劝修今真。欲得如是修诸想者举其所求。如智出珠约喻以劝。所谓我等辩出所修。下为会通。今言异昔故须会通。于中且就我与无我一对会通。余类可知。比丘先问昔说无我修学有益能断烦恼得入涅槃。今复说我以为真实。是义云何。下佛答之。先叹。后会。会中先喻。次合显法。如大医下牒以结劝。喻中有二。一昔说无我喻。二其后不久王复病下今说真我喻。前中复二。一外道说我喻。二时有明医从远方下圣说无我喻。外道说中。如王闇钝明所化愚。如舍利等在俗之时各有匡领。故说为王。内无解慧名为闇钝。所知浅狭故曰少智。有一医下明能化痴。于中有四。一能化人痴。二所化不别。三重明其能化人痴。四重彰其所化不别。就初段中。富兰那等六师之徒邪法训世名为医师。心不觉法名之为顽。口无正言说以为嚣。自下第二所化不别。加以敬养名赐俸禄。自下第三重复广前能化人痴。疗治众病纯以乳者不知广治。说我为乳。亦复不知病起已下不知正治。于中初言不知病等。明不识病。虽知乳药复不善解。明不别药。风冷热病悉教服乳。明不解治。风病喻嗔。以躁急故。冷病喻痴。以顽騃故。热病喻贪。以烧心故。烦恼非一名一切病。齐教计我名悉服乳。自下第四重复明其所化不别。不别是医知乳好丑及善恶者。好丑据体。善恶论用。第二圣说无我喻中文别有三。一如来出现喻。二是时旧医不知咨下反迹同邪喻。三是时客医即为王下破邪通正喻。初中明医喻佛如来。能宣治法故说为医。晓八术者喻佛如来明识根药。何者八术。一知病体。二知病因。三知病相。四知病处。或在五脏或在支节。五知病时。平旦发者是如此病。如是等也。六者知药。识其药体。七者知治。知如此药治如是病。八者知禁。知如是病服如是药忌如是食。如是等也。善疗知方八中差别。从真现应名远方来。第二反迹同邪喻中文别有五。一外道不识。反生贡高喻。外道不知请佛为师名不知咨。不知从佛听闻正法名不知受。谓己胜佛名反贡高。谓佛劣己名生轻慢。二如来迂德示受邪化喻。先思。后请。思中明医即便依附请为师者请人为师。咨受方者谓受其法。下正请中。语旧医言我今请仁以为师范。请其人也。唯愿宣等受其法也。三外道要请喻。外道要佛为己弟子顺教奉行。名给走使。要佛一化常为弟子。是故说言四十八年。如来在世四十九载。除后宣说涅槃之年。是故但云四十八耳。四如来权从喻。明医受教我当如是。权从所要。随我所能明不专从。既言随我。明非一向从彼要也。五徒众共匡喻。即将客医共入见者徒众共知。如佛昔日从于阿蓝迦蓝等学。彼后共佛同知僧事。此之谓也。亦可此中邪正两师共察众机。名共见王。上来五句合为第二反迹同邪。第三破邪通正喻中先遣邪人。客医作念欲教王下破其邪法。前中复二。一为说正法。二尔时王下摈遣邪人。前中初言即为王说种种医法及余伎艺。正为说法。医方是其治恶之法。伎艺是其集善之法。又复医方是自行法。伎艺是其化他之法。大王当知应善分别。劝知得失。今昔相滥故须分别。此法如是可以治国可以疗病。叹胜令受。所说伎艺可以治国。治国化他。所说医方可以疗病。疗病自行。下遣邪人。尔时国王闻是语已方知旧等。知旧劣新。所以摈遣。然后已下知新胜旧。故加倍敬。破邪法中文亦有二。一破邪法。二尔时客医以种种下授其正法。与前左右。初中有四。一请施法化。二王即答下彼闻敬从。三彼客医下正施法化。四时王答下彼闻奉行。就初段中。先思。后请。客医作念欲教王者今正是时。内心思也。机熟在今故云是时。即语王下发言正请。物机顺圣名实爱念。请施法化名求一愿。第二段中。王即答言从此右臂及余身分一切与者。机显圣心。义说为答。受小之机摄道方便名为右臂。一世所行名余身分。皆从圣化名随意求。自无顾执名一切与。第三段中别有四句。一直劝断我。二所以下明断无损。三若欲下立制断我。四断乳已终更无下明断有益。就初句中。王虽许我一切身分牒前所许。然我不敢多有求者明化不顿。大机未熟未可顿摄。名不多求。今所求下正劝断我。道今所求明不同后。诸比丘等在俗之时各有匡领。如王统国。佛昔化之自断我心兼。劝余众。故言愿王宣令国内不得更服旧医乳药。第二句中。所以征问。下对释之是药毒害多伤损故不得服者。着我之心招苦障道。名多伤损。第三句中服斩首者。断其出世法身之首。第四句中断已更无横死之者不堕生死。常受乐者受涅槃乐。故求是愿结明化意。上来四句合为第三正施法化。第四彼闻奉行喻中。王答汝求不足言者。明堪断我。此亦是其根性中语。对后化人。名初受小。为不足言。寻为宣令一切国等顺教断我。为药斩首举过劝断。上来四段合为第一正破邪义。下授正法。以种种味和合药者。谓无常苦无我等味合之为治。以疗众病无不差者。用治众惑无不灭也。第二今说真我喻中文别有五。一患机感圣喻。二医占王下圣说真我喻。三汝今狂下初闻不受喻。四是时客医复语王下圣为会通喻。五王闻语已赞言已下领解修行喻。初中不久王复病者。喻诸比丘因学无我遂于佛地起无我倒。我心息已即便计佛以为无我。故云不久。患机感圣名为命医。有病感治。义言我今病重欲死当云何治。执见情深故云病重。断绝常命名困欲死。请问治方名云何治。第二段中医占王病应用乳者审病拟药。无我之病非我不治。故云应用。寻白王下正为说我。于中有三。一喻授真我。二我于先下毁昔赞今令人乐受。我先断乳是妄语者。是毁昔也。自名向前断乳之言以为妄语。亦可名前所断乳药以为妄语。是彼旧医妄语药故。彼说滥真所以毁之。今若服者最能除病。是赞今也。三王今患下彰病显治令人信受。第三初闻不受喻中。初言狂耶为热病乎。呵责其人。而言已下呵责其言。初先直呵。而言服乳能除此病。汝先言下举昔征今。先医赞下举旧责新。如汝言下赞旧毁新。第四圣为会通喻中初呵不应。如虫食下广显不应。先喻。次合。王言云何不解已下问答重显。然此文中以喻况喻用之显法。虫喻旧医。远况外道。推求治方名为食木。远况外道推求五阴。有成字者近况旧医说乳为药。名当好乳名为成字。远喻外道说我为治偶当真我。此虫不知是字非字。喻彼旧医不能自知是药非药。远况外道不能自知是理非理。智人见之终不唱言是虫解字亦不惊怪。喻世智者口不宣唱旧医解药心亦不怪。远喻智者口不宣唱外道解我心亦不怪。下次合之。然此文中以喻合喻。举彼旧医妄说乳药合虫食木。初言旧医亦尔不别诸病悉与乳药。合虫食木。如彼虫下举喻以帖。是先旧下合虫不解。是先旧医合是虫也。不解乳药好之与善。合不知字。不解乳药丑之与恶。合不知非字。好丑善恶备如上辩。智人见等略而不合。自下问答重显向前不解之相。初先总问云何不解。客医答下对问略辩。下复广显先解甘露。初问次辩。若是牸牛喻诸菩萨。不食酒糟滑草麦糗喻离烦恼。酒糟喻痴。滑草喻贪。麦糗喻嗔。断名不食。解心柔顺名犊调善。游观境界名放牧处。离有离无名不高原亦不下湿。餐受正教名饮清流。起行详审名不驰走。远恶知识故言不与特牛同群。教授以时名饮餧调。适止观调停名行住得所。依此证我堪为真治。是故说言如是乳者能除诸病。是则下结。下解毒药。文显可知。上来会通。第五领解修行喻中。初先自行。后劝他修。自中王闻赞言始知领解辞也。即服病除修得益也。就劝他中句别有四。一劝他修行。二国人下始闻不受。先呵其人。初嗔。后呵。受他邪语名鬼所持。自生邪想名狂颠耶。下呵其言。先呵。后嗔。文显可知。三王闻下推佛免过。先劝莫嗔。而下推佛。非下免过。四彼闻奉行。上来立喻。下次合之。先合昔说无我之喻。为调生下合后今说真我之喻。就前昔说无我喻中文有两段。一外道说我喻。二圣说无我喻。备如上辩。今但合后圣说无我。就所合中。喻文有三。一如来出世喻。二反迹同邪喻。三破邪通正喻。亦如上辩。今此但合初后两段。中间不合。比丘当知如来应等亦复如是为医出世。合上第一复有明医晓八术也。降伏已下超合第三破邪通正。于中喻文有其两段。一遣邪人。二破邪法。如前广辩。今具合之。降伏一切外道邪医唱如是言我为医王。合遣邪人。欲伏外道故唱是言无我已下。合破邪法。于中初言无我人等。正合断乳。比丘当知诸外道下。悬取后喻呵其所立。是中未合食木之喻。是故如来唱言无我。结说所以。以彼外道所说之我如虫食木偶成字故我言无我。为调生下合后圣说真我之喻。喻文有五。一患机感圣喻。二圣说真我喻。三初闻不受喻。四圣为会通喻。五领解修行喻。备如上辩。然今但合第二第四。余三不合。为调生故为知时故如是无我有因缘故亦说有我。合第二段王应乳服。为诸比丘除无我倒。名为调生知诸比丘应受大时。名为知时。有此因缘故说其我。如彼医下合第四段会通之文。然上文中初立如虫食木之喻。次合旧医。时王问下问答广显。今但合后重显之文。余略不合。如彼良医善知于乳是药非药。牒举前喻。向前明医广辩其乳有是甘露妙药之义。名知是药。亦辩是毒名知非药。下约显法。非如凡夫所计我等。合知非药。于中先举外道说我差别种种。如来说我不如是下对之辩非。何者我下合知是药。先问。次辩。涅槃之体不同生死诳相虚假。名之为实。出离情妄说之为真。体无迁转是故云常。为众德本说之为主。诸行所托故复名依。体无生灭名不变易。是名下结。自下第三牒以结劝。如彼医等牒举前喻。如来亦等牒举上法。汝等已下结劝修习。第三辩习成德分中四句分别。一解辩修成德之义。上明果德。果由因成。从此已下广辩行修成前果德。故云辩修成德分矣。二就人分别。人有二种。一是所寄。二是所为。所寄是佛。所为众生。所为众生身有常性。非行不显。显性之行必由学成。学依法起。故须寄佛广辩其因为所学法。虽说佛因。为使众生学之起行。三对人分别。人有二种。一是影响。二是所为。迦叶德王师子吼等。是其影响。憍陈如等无常学人。是其所为。所为之人智解微劣。分外常因不能咨启。故先对彼影响论之。由前广辩所为之人便能悟入。故后重复对之以显。四分文解释。就此分中大段有二。从此尽后迦叶品来。广对影响辩修成德。陈如品初。对其所为无常学人憍陈如等辩修成德。与前开宗显德相似。就初段中粗分有二。初请。后答。偈来是请。偈后是答。细分有五。一如来劝问。二尔时会中有菩萨下迦叶请问。三佛赞下如来赞问。四迦叶白佛我无智下迦叶谦问。五谛听下如来答问。就初段中。先告比丘。后告大众。比丘所为。故先告之。亦可乘上哀叹章中。对其言便。是以先告。彼辞不堪高推菩萨。故后告众。前中有三。一直告令问。二重劝令问。三举益劝问。良以圣意丁宁故尔。就初告中。佛先劝问。我已修下比丘自夸拒劝不问。汝等莫下佛呵令问。初中佛告汝于戒律有疑问者。正劝令问。得常因中戒学为首。又复戒律比丘所习故劝令问。我当解说许为酬答。令汝心喜彰己善答。比丘拒中我已修学一切诸法本性空者。人解不定。有人释言。此是佛语。如来道已知法空寂。欲令比丘就之咨问。依六卷经。此比丘语。故彼经中比丘白佛我已修法本性空寂了了通达。比丘道已我于诸法先已通达何须更问。五阴是其一切诸法。比丘观法但从缘生无有本性。名性空寂。解过始学名了了达。下佛呵中莫谓如来唯修诸法本性空者。如来彰己更有大乘不空之德。明须问也。故经说言。诸佛如来不以得此一无分别法说名为佛。第二告中初佛劝问。汝于戒律有疑可问。下诸比丘谦己不堪。于中有三。一明己无智不堪发问。二譬如老下明己无力不能受持。三从我今无智已下结己不堪。初中我等无智能问。正明不堪。所以下释。如来境界不可思者。明慧难测。智慧分齐名为境界。佛智深广超出余人。余心不及故名不思。余言不逮称曰不议。所有诸定不可思者。明定难测。所演教诲不可思者。明戒难测。亦可初句总明不思。后二是别。别中初证。后一是教。是故已下结己不堪。第二明己无力持中。先喻。后合。喻中有五。一喻自己无能持德。二有一人下喻明如来不应付己。三是时老下喻明自已不应辄受。四而是老下明受者失。五财主行下明付者失。初中如人年百二十。比丘喻己有重烦恼。取老为喻。不取其数。身婴长病喻有变易。因果未除心好寂止。名寝床席。不堪随有行化众生。名不能起。悲愿薄少名力虚劣。取灭不遥名命无几。第二段中一人喻佛。具法称富。随感迁化。故言缘事欲至他方。大乘正法喻百斤金。取重为况。不取其数。用付比丘名付老人。作其言下显委付相。或十年还二十年还。彰还不定。根熟早来不熟晚至。是以言或。令法住持称佛本化。义言还我。第三段中是时老人即便受者。比丘喻己非分辄受。第四段中诸比丘等无有受法传化弟子可以付嘱。名无继嗣。无常迁逼说为病笃。灭身归无称曰命终。所付之法无人禀行。名皆散失。第五段中此方有感如来复化。名为行还。本法全灭名债索无所。如是痴下呵以显过。是故行下结以明失。下次合之。前五句中但合第一第三第四。我等声闻亦复如是合第一句。虽闻已下合第三句。不能受下合第四句。如彼老下举喻以帖。上来第二明己无力不能受持。我今无智当何所问。是第三段结己不堪。前两段中就初以结。第三告中。初佛劝问。次诸比丘高推菩萨。后佛述赞。初中佛告汝今若问能益一切。举益劝问。是故已下结劝所以。就明比丘推菩萨中。初推菩萨。我等智慧如蚊虻下谦己不堪。时声闻下谦已默住。初中先喻。次合。后结。喻中有五。与前相似。一喻菩萨有能持德。二亦有人下喻佛应付。三有壮人下喻菩萨应受。四其人遇病命家属下明受者得。五智者下喻付者得。初中如人年二十五。喻诸菩萨法身充盛。取少为喻。不取其数。智解不邪故曰端正。具众善法名多财宝。父母妻子眷属宗亲。如维摩说智度为母方便父等。第二段中类前称亦。有人喻佛。委法菩萨名寄宝物。语其人下显委付相。义同上释。第三段中壮人护物如已有者。如己自心所证法也。第四段中菩萨于此感化已周。名为遇病。告传法人名命家属。语其所付是诸佛法。名他所有。劝令坚持复圣本化。义言来索悉皆还之。第五段中智者善量喻佛善付。圣复本化名为行还。先所委法住持如本。义言索物皆得无失。下次合之。文中但合第二第四。合第二中。世尊亦尔合前富人。若以佛法付迦叶等。举失显得。反合应付。先明其失。何以下释。如彼老下举喻类显。是故应下彰得异失。正合应付。以诸菩萨善能问下合第四句。先举其法与前少异。向前喻中明由付后财无损失。今此合中明诸菩萨能善问答法得久住。言左右耳。如彼壮下举喻以帖。上来合竟。以是义故菩萨能问结推菩萨。上来仰推菩萨能问。次谦。后默。文显可知。第三如来述赞之中。先叹自谦。后述推他。前中善哉正是叹辞。得无漏心阿罗汉心出其所叹。不自高举名无漏心。不着吾我名罗汉心。我亦曾下述上推他。我亦曾念以此二缘应付菩萨令法住者。念诸菩萨能问能答二种因缘。故应付之。亦可曾念付嘱声闻疾灭因缘。付诸菩萨久住因缘应付菩萨。上告比丘。以彼自谦高推菩萨。故下告众。于中亦三。就初告中先举五果。下劝问因。果中偏举寿命辩才。余略不举。劝问因中。若戒离恶。若归集善。劝之问也。圣意殷勤故至二三。自下第二迦叶请问。于中粗二。一请由序。第二正请。细分有七。一标列请人。二彰问所由。明由佛力。三请佛求听。四如来听许。五蒙听许问。六欲问承力。第七正问。初言众中彰其所在。有菩萨下辩列其人。本是多罗出其生处。姓大迦叶彰其氏族。婆罗门种明其种姓。年在幼稚辩其老少。第二段中明因佛力所以发问。举此为彰所问契当。第三段中从座起等身业方便。而白口请。第四段中先听其问。后许为说。第五可知。第六段中。初先彰己智微故承。如来已下明其所对可畏故承。于中初先明佛可畏。是众会下菩萨可畏。今当已下明己承力。佛可畏中句别有四。一叹佛德巍巍高胜。二叹佛众精纯无杂。三叹佛身。犹如金刚明身坚也。色如琉璃明身净也。四叹佛众智慧深广。就明菩萨可畏之中。初明菩萨皆成广德。是大众前岂敢发问明其可畏。下承力中。初承佛力。后承众力。第七问中佛前说偈经家序列。何故偈请。偈言巧约。少字之中能摄多义。故以偈请。下列请辞。三门分别。一定问多少。昔来相传云此偈中三十六问。准法验答。此中具有四十二问。人复所以言三十六。说共圣行乃至岁星合为一问。众生大依两足妙药。今欲问阴而我无智。不以为问。是故但云三十六矣。彼共圣行乃至岁星四种譬喻。下皆别答。何得为一。若以此等共一云何便为一问。初偈之中云何得寿金刚不坏。亦应为一。彼得分二。此别何疑。众生大依两足妙药今欲问阴。此等下文皆有别答。何为非问多少如此二彰问差别。问别有六。一者疑问。亦名请问。如言云何得长寿等。二者求问。如言愿佛开微蜜等。三者难问。如言三乘若无性等。四者责问。如言如其断疑云何不定说等。五者赞问。如言众生大依止等。迦叶欲难。将夺先与而为赞叹。是故虽赞而得为问。六者谦问。如下文言。今欲问荫我无智等。谦己不堪而起后说。故名谦问。问别如此。三分文辩释。偈判有二。初问学法。云何得近无上道下问其学行。此云何知。如下大众问品之末。将答学行。迦叶请云唯愿说是大涅槃中所得功德。判知前法后是学行。学法学行有何差别。而须别问泛论有四。一理事分别。法通理事。行唯在事。二内外分别。法通内外。行德唯内。三三性分别。法通三性。观三性法皆得起行。行唯在善。此说善行。不论余义。四自他分别。法通自他。他人之行得为己法。己家之行得为他法。行则不尔。彼此各别。今此所论义当后门。彼前学法。外国名为正法实义分。彼后学行。外国名为准法修成分。又前学法外国名为法性虚空分。彼后学行外国名为智慧大海分。此乃依下经文名之。故下文中迦叶自言我无智力能问如来智慧大海法性虚空。名虽有异其义不殊。就学法中。初先对上纯陀章中五事报果。问菩提因。云何复示现究竟涅槃下。对前哀叹章中涅槃之果以问其因。菩提从于生因所生。涅槃由其了因所得。故别为问。前中有二。一教贤圣趣菩提行。谓教声闻趣大菩提。二从云何未发心下明教凡夫趣菩提行。前中复三。一问随缘造修之行。二从云何诸调御下问其舍相入证之行。三从云何共圣行下问其证实成果之行。亦名证实起用之行。前问随缘造修行中。初对五果问其行体。云何得广大为众作依下问行所依。初言云何得长寿者。对前长寿问其得因。不问其果。下答慈悲不杀故得。问曰。前说施食故得。今以何故重问其因。释言。寿命有二种因。一者养因。所谓施食。如世养母。二者生因。所谓慈悲不杀等行。如世生母。前说施食其因未圆。故复问之。余皆同尔。道言云何得金刚身。问其色因。亦不问果。此一云何通问两事。下答护法因缘故得。复以何因得坚固力。对上力果问其得因。下文之中与身同答。云何于经究竟到岸。问安乐因。此经宗显常乐之果。常乐之果是经旨趣。名经彼岸。到经彼岸方得安乐。此经彼岸云何得到。下佛答之。受持此经名字功德。便得到之。到之究极说为究竟。愿开微密广为生说。问辩才因。准六卷经。此问稍隐。六卷经言。菩萨为众生说法有几种。下佛答之。能说之德有其四种。自正。正他。能随问答。善解因缘。所说之法有其三种。法身解脱摩诃波若。将彼验此。此问略少。若具应言愿佛开微密菩萨依此法广为众生说。故下文中佛开三事令菩萨说。由为他说故得辩才。上问行体。下问所依。于中两偈。初之一偈正问所依。云何得广大为众作依止。人虽实非诸佛罗汉。而能化益与佛罗汉化功等者。我等依之。下答四依。是其人也。后之一偈问所不依。云何知魔为众留难。问其邪人。邪人滥圣故问舍之。佛说魔说云何别知。问其邪法。邪法滥正故问舍之。下佛具辩

上来第一问其随缘造修之行。下问舍相入证之行。于中先问入证行体。云何菩萨能见已下问证所依。与前相似。问证体中差别有三。一寻相趣实。二辩邪归正。三舍相入证。云何调御心喜说谛。寻相趣实。诸调是佛无作四谛。说称佛心。名心喜说。此义云何。下佛广辩。何者是其不喜说谛而言喜说。有作四谛随情局说。非尽道理。不畅圣意。名不喜说。辩谛何为。谛是法相。藏是法实。为证其实故须辩相。正善具成演说四倒。辩邪归正。呼佛以为正善具成。请说四倒。亦可正善具成就者。举问所为。我等欲得正善具成愿说四倒。令我舍离成彼正善。云何作善大仙今说。是其第三舍相入证。云何作善正是问辞。问意云何。释有三义。一据修为问。凡夫二乘皆作善业不得菩提。菩萨云何修作善业能得菩提。此乃问行以求其理。下佛答之。舍离有无趣入中道。如是修善便得菩提。二对果为问。若使当来有果可得。可须修善。若无所得。云何作善。下佛答之。众生有性当必得果。如子在胎定生不久。但当修善。三望理为问。我今不知所趣入处云何作善。与下文中不知三宝处云何作无我其言相似。下佛答之。有如来藏可以趣入。宜作善业。唯愿仙说请佛酬答。如来长寿故名大仙。上来问其入证行体。下问所依。所依有二。一明见性必由依经二明解经必由解字。云何菩萨见难见性。问初义也。性既难见。菩萨何因能得见之。下答依经所以能见。云何解满及以半字。问后义也。字之半满备有多义。下佛为辩。故令得解。云何诸调至此。第二问其舍相入证之行。自下第三问其证实成果之行。亦名证实起用之行。于中明佛身口意行。云何共圣至迦邻提。问佛意业。名佛为圣。佛所成行名为圣行。诸佛如来得大涅槃不舍世间。不舍世间而入涅槃。无常共常。常共无常。乃至苦乐我无我等类亦同尔。故名为共。此相云何。下以喻显。如娑罗鸟及迦邻提游止共俱不相舍离。日月及星此三喻佛身口二业。下皆别答。偈初至此。大段第一问其教圣趣菩提行。下问教凡趣菩提行。于中有二。一明法力得菩提义。二从云何观三宝下明其修力得菩提义。前中有三。一明法力资人发心。二于大众得无畏下明其法力资人成行。三生死下明其法力资人得果。初问云何未发心人令使发心得为菩萨。下答此经入于众生心毛孔中。令灭重罪故使发心。第二法力资成行中。云何于众而得无畏如金无过。明法资成灭罪之行。一阐提等谤法罪人名为大众。云何于中独得无畏。如世间金无能说其瑕秽之过。下答依经忏灭诸罪。令诸罪业至无至处。故得无畏如金无过。云何处浊不污已下明法资成灭烦恼行。云何处浊不污如华。就人为问。浊有五种。今此且论烦恼见浊。云何令向发心菩萨处此浊中不污如华。下答由经故得不污。云何处烦恼烦恼不染如医疗病不为病污。就法为问。经法云何有染不染。不能令人灭除烦恼污经势力。故名为染。如世医师治病不差污其医道

若能令人灭除烦恼不污经力。故名不染。如世医师治病皆差不污医道。故今问之。云何是经处恼不染如医不污。下答此经能灭众生一切烦恼如医差病。故得不染。第三法力得果之中。初问云何作船师者。问化他德。下答如来得涅槃船。故能济渡为大船师。云何舍生死如蛇脱皮。问自利德。下答如来灭而常存。故得如蛇脱皮不死。分别有二。一据修入辨舍妄契实。如蛇不死。二就息化归真以释灭应归真。如蛇不死。上来第一明其法力得菩提义。自下第二明其修力得菩提义。于中亦三。一明观解。二云何菩萨得不坏下依解起行。三示多头下明依行得果。初中约就三宝佛性以明观解。初言云何观三宝者。约就三宝问其观解。所观三宝随缘不定。如天意树随天意转。此观云何。下佛答之。化随物变而实常存。三乘无性云何说等。约就佛性明其观解。于中初先当法正难。难意如何。三乘之人若无别性。云何而得别说三乘。别说三乘。明知三乘各别有性。如乐未生云何名乐。约喻类征。如乐未生不可名乐。乐受生已方得名乐。三乘亦尔要有三性。故得说三。下佛答之。明三乘人同一佛性更无别性。无别性故无别三乘。故下文言世若无佛非无二乘得二涅槃。一切世间唯一佛乘。是故无别二乘涅槃。以无别故二乘之人终必同得一大涅槃。次明起行。云何菩萨得不坏众。问其自行。自行成就同诸菩萨不可乖异。名不坏众。故下文言菩萨勤加精进护法所得眷属不可破坏。云何为盲作眼目导。问利他行。亦可此二同问利他。得不坏众是摄人行。由勤护法人皆乐从故不可坏。为盲作导是开化行。下明得果。初言云何示多头者。随类异说。云何说者增如目初。随机渐说。此文颠倒而复不足。若正应言云何说者增如初月。若具应言云何说者增长众生如世父母教于初生十六月儿。准答应尔。小儿初生十六月时言语不正。父母为教先同其言后教正语。佛亦如是。先随众生说小乘法。后为说大。故今问之。偈初至此。对上五果问菩提因。自下对上涅槃之果以问其因。于中七问。初言云何复示涅槃。标问其果。为欲简上菩提之因。故须问之。问意如何。如来今者究竟入于尽灭涅槃。云何复得示现世间。下答如来终不毕竟入于涅槃。故常示现在于世间。此常示现即是诸佛善有涅槃。下对此果以问其因。于中六问。前三问其证道行因。即是自利。后三问其教道行因。即是利他。问证行中。云何勇进示人天道。正问证体。此文不足。若具应言云何勇者示于人天及诸魔梵沙门等道。此乃名佛为勇进者。佛大勇猛最精进故。愿示人等出世正道令得涅槃。下佛示之。观察三宝常住同真。我性佛性无二无别。是其正道。下次问其得证利益。云何知性而受法乐。问其证法得乐之益。云何菩萨离一切病。问其证法除障之益。下问教行。于中迦叶问教权实。知之求果。云何说密。问教权实。此言略少。若具应言云何说密及不秘密。权教隐实名为秘密。实教显了名不秘密。云何毕竟及不毕竟。问其教旨。深名毕竟。浅不毕竟。如其断疑云何不定。总就前二征责说意。余人有疑。可不定说。佛已断疑。今以何故作不定说。下答化人不同故尔。偈初至此明其学法。下明学行。于中有三。一明随缘造修之行。二一切法中有乐性下明其舍相入证之行。三众生大依下明其证实成果之行。亦名证实起用之行。三中初二明诸贤圣所修之行。后一明佛化凡夫行。问曰。向前学法之中菩提涅槃两因别因。此学行中何故不尔。释言。辩法理须离广。理须委具。故前别问。依法成行。成行不异。所以合说。互从皆得。初造修中。五行世间。十德出世。初言云何近无上道。问世间行。出世真德是无上道。地前所行亲成彼德。故名为近。此相云何。我今请下问出世行。我请如来自宣己心。为菩萨故彰请所为。愿说甚深微妙诸佛正明所请。地上真德契实名深。离相称妙。十德非一名为诸行。愿佛说之。因修入证。下次问之。一切法中悉有乐性。举其所证。五阴是法。凡圣五阴同有佛性。故言一切悉有乐性。亦有常性我净性等。今旦明乐。人多好故。唯愿仙下请佛宣说。请为何义。为欲证入。然此文中单问所证。不问能证。至下将答。师子具问。彼言云何为佛性等。问其所证。佛住何法见性了等。问其能证。准彼类此理亦应齐。直以偈迮略不具问。因证成果。证寂起用。下次问之。众生大依问佛身业。两足妙药问佛口业。今欲问阴我无智等问佛意业。亦可初句辩明如来人为物依。为令阐提于佛生信。第二彰佛法为妙药。为令阐提于佛教法舍谤生信。第三彰佛智德渊深所知独绝。为令阐提于佛义法仰推成信。初言众生大依止者。是其赞问。赞叹如来能为物依。迦叶欲难将夺先与。故先赞叹。是故虽赞而名为问。迦叶是中何不即难。释言不得。下举善星难佛无慈无大方便非物依止。难辞极广。若此为难。言则繁多。不成偈义。故赞便罢。两足妙药亦是赞问。赞佛所说能为妙药。迦叶欲难将夺先与。故先赞叹。是故虽叹而名为问。迦叶此中何不即难。此亦不得。下举二十一对诤论。难佛所说非是妙药。若此为难。难辞繁广。不成偈颂。故叹便罢。今欲问阴我无智等。是其谦问。谦己不知而起后说。故得为问。令欲问阴自宣己心。下说五阴有其二种。一佛性五阴。二法相五阴。就佛性中有善不善。佛果五阴。法相阴中有因有果。故名诸阴。我无智下彰此诸阴唯佛所知余人不测。故下如来答此问时。名为如来随自意语。于中初明自己不知。次明精进菩萨不知。迦叶自身住第十地。当应名彼十地满心以为精进诸菩萨也。以彼学穷趣佛无间。故曰精进。如是深下明唯佛知。如是等深牒前诸阴。独佛能知故曰佛境。道此语者。为彰法深唯佛独知。令人仰推舍谤成信。自下第三如来赞问。善哉总叹。下别叹之。别中有三。一叹所问上同如来。二叹所问中等菩萨。三叹所问下益众生。就初叹中。初明迦叶智未同佛。后彰迦叶问等如来。所以可叹。第二叹中我坐道场亦曾问等。举华严中菩萨问也。然其所问句义功德等无异者。彰彼同此。彼中所问佛因佛果共此不殊。第三可知

第四迦叶谦问之中。初谦己问。譬如王下己彰慕持。前中初法。次喻。后合。不能咨问智慧大海。犹前学行。法性虚空犹前学法。如来向前叹其善问。迦叶何故谦己不能。各有所以。迦叶所问契当法相。故佛赞叹。迦叶忖己承力方堪。自力不能。所以谦问。下慕持中先喻次合。何以下释。文显可知。第五如来答问之中。依上所问次第答之。尽此品来答上初问。于中初明长寿之因。二菩萨如是修习此业得寿长下明因得果。前中初先正辩因体。二迦叶白佛是义深隐我未解下拂去迹碍。初中有四。一就所寄许说如来长寿之业。二菩萨以是业因缘下就其所为。明诸菩萨以业得寿劝听劝说。三我以修下重就所寄。明己先修今已得果。四如王子下重就所为。明现修因当必得报。初中如来先敕其听。后许说因。第二段中。初明菩萨由业得寿。是故已下结劝听受。若业能下重举前业。约果取业。故言能为菩提因者。应当诚下劝为人说。牒前听受令依说也。第三段中。我以修习如是业故。彰己先修。下明所得。今得菩提是自利果。为人广说外化行果。又得菩提是其果体。说是果用。第四段中初明现因。以如是等业因缘下明当得果。前中先喻。喻中两句。初至怜愍喻利他心。王喻菩萨。子喻众生。起业烦恼名为犯罪。沉没三有说为系狱。菩萨慈念名为怜愍。二躬自下喻利他行。身随诸有济拔众生。名自回驾至其系所。下次合之。初至大舍合上初句。明利他心。菩萨应护一切众生同子想者合上王子。生大慈等合上怜愍。授不杀下合第二句。明利他行。于中初明善法利益。安慰已下乐事饶益。前中初先化益菩萨。亦当安下化益凡夫。脱未脱下化益二乘。化菩萨中授不杀戒教令离恶。理实通受一切禁戒。但不杀戒是长寿因。故偏说之。教修善法劝令行善。化凡夫中。亦当安正一切众生五戒十善化益人天。五戒人法。十善天法。下利三涂恶趣众生教修善法。名为拔济。化二乘中。初先教化令出生死。脱未脱者脱生死因。度未度者度生死果。未涅槃下令得涅槃。上来善益。安慰一切苦恼生等乐事饶益。上明现因。下明得报。于中先明得出世果。以是业缘得寿命长。正明得果。于慧自在出其命体。圣慧能持诸德不坏。故说为命。是以经中舍利目连须菩提等皆名慧命。佛慧无碍故名自在。寿终生天得世间果。自下第二拂去迹疑。于中有二。一拂去昔日不慈之迹。二如佛所言则不等视同子想下。拂去今日不等之迹。前中有四。第一迦叶以理请问。第二如来以理正答。第三迦叶执迹为难。第四如来拂迹释通。文别可知。初中迦叶先牒上言彰己未解。次呵如来。不应说言菩萨修等。所以下释。人有善恶。何由可等。恶有六阶。一者阐提。二谤方等。三作五逆。四犯重禁。五作十恶。六犯一切威仪之罪。今应具列。略举中三。云何当下结明难等。第二如来以理正答明己实等。第三迦叶执迹难中。先举昔事。事如经说。是金刚下牒以征佛。第四如来拂迹释中。初就化犯释去前难。后就实犯彰己慈益。前中先呵。次辩化事。为欲驱下彰己化意。就实犯中。初就现犯明己慈益。未可见法汝欲见下。就其当犯明己慈益。前中初意。次口。后身。意中先举四种恶人。略无五逆及威仪罪。我于是下明己慈益。口中。如王有犯诛戮而不放舍。明凡异佛。如来世尊不如是下彰佛异凡。异有二种。一世间人王见犯罪者以苦报治。佛则不尔。为遮其苦。二世间人王治罪之时。人虽未悔亦不放舍。佛则不尔。有悔皆恕。初言世尊下如是也。总明不同。下别显之。别中先举七羯磨法。次明化意。后总结叹。初中第一驱遣羯磨。犹是律中摈羯磨也。阿湿波等在聚落中行恶污家。如来立法驱摈令去。名驱遣羯磨。呵责羯磨者。如律中说。智慧卢醯那好喜斗诤。口出刀釰。共相骂辱。令僧尘垢。如来立法呵责令止。名呵责羯磨。置羯磨者。犹是律中依止羯磨。僧刍比丘愚痴无智。数忏数犯。不能自制。如来立法令依有德。故曰依止。安置在于有德人边。名置羯磨。举罪羯磨者。义当律中遮不至白衣家羯磨。善法比丘讥骂檀越。檀越反报恚恨舍去。如来立法令忏檀越。遮抑不听。不至其家。名遮不至白衣家羯磨。举罪示之。令忏檀越。故复名为举罪羯磨。不可见羯磨者。犹是律中不见罪举。阐陀比丘犯罪不识。如来立法。举出众外。有利皆夺。待见方解。名不见罪举。灭羯磨者。犹是律中不忏罪举。还是阐陀作罪识知而不忏灭。如来立法举出众外。待忏方解。名不忏罪举。伏令灭罪。故此名为灭罪羯磨。不舍恶见。犹是律中不舍恶见举。阿利吒比丘说欲不障道。如来立法举出众外。待舍方解。名为不舍恶见举也。如来所以与谤法下明己化意。此即不同世间人王。即是施下总以结叹。制恶防苦名施无畏。身业益中若放一光若二若五。正明身益。五色光中或放一二光乃至五种。具有已下总以结叹。上来就其现犯明益。下就当犯。未可见法汝欲见等。总标许说。末代化仪迦叶未知。名未可见。下正为说。初国王喻教治众生。毒树一喻劝治徒众。白发一喻治自眷属。前中初法。次喻。后合。法中先教治罚恶人。当知已下明治有益。喻中四句。一喻所治。未来恶人身为众主。故说为王。多犯禁戒名专暴恶。造恶不已人皆厌贱。名遇重病。有邻王下喻能治人。持法之人说为邻王。知恶曰闻。集善比丘名兴兵来。欲往治罚名规殄灭。三时病王下所治降伏。四如是邻下能治得福。合中持法亦如是等合第二句。得福无量合第四句。第二段中但喻无合。长者喻于持法比丘。众喻田宅。生毒喻于造恶之人。斫喻治罚。第三段中先喻。次合。后举得失劝人奉行。喻中壮人喻持法者。首生白发喻眷属中造恶之人。愧而剪拔喻教驱遣。合文可知。就下劝中先失后得。上来第一拂去昔日不慈之迹。下拂现在不等之迹。迦叶先问。如佛所言则不等视如罗睺罗。执言征行。执前如来治罚之言。征无等行。若有一人以刀害下执行征言。若治毁禁是言则失。结以显过。等言失也。下佛释通。先喻。次合。后结彰等。喻中有三。一立喻相。二反问迦叶。三迦叶正答。初中王等喻佛如来。未来学人名为诸子。从佛化生以言产有。道机不邪名为端正。识达因果称曰黠慧。若二三四多少不定。恶人有六。如上所列。于此六中。阐提无信不可摄化。今废不论。威仪过轻。今此不说。就余四中。造作十恶及犯四重。说以为二。加以五逆通前说三。复加谤法通余说四。以何义故不说其一。欲于其中有留有驱。故不说一。玄委当来传法之人令其摄化。名付严师。而作言下显委付相。于中初先付令教善劝教学人。名君为我教诏诸子。令成三学。名威仪等悉令成就。下付治恶。我今四子就君受学牒前所付。于中有犯四重五逆及谤正法。此三罪人依法摈徙。名为三子病杖而死。于弟子中有犯十恶轻罪之人亦须治罪。名余一子必当苦治。罚恶清众当佛本意。是故说言虽丧三子我终不恨。反问可知。迦叶答中。初先依理总答不也。何以下释。合中有四。一合前喻。二就所委反问迦叶。三迦叶正答。四如来约之显己无罪。初中如来合前王等。视坏法者等如一子合产诸子。如来以法付诸王等合付严师。向前喻中举人彰付。今此合中就法论之。左右言耳。应当劝下合君为我教诏诸子。令得增上戒定慧下合威仪等悉令成就。若有不学乃至应治合上三子病杖而死。唯有一子必当苦治。后之三段文显可知。上来合竟。自下第三结以彰等。先就所寄如来结等。是名已下就其所为菩萨结等。上来明因。自下第二明因得果。于中初明果体常住。即是自德。应当修习佛法众僧而作常下。就常辩归明利他德。前中初明果体常住。二迦叶白佛世出世法有何别下。寄对辩异彰其不同。前中有三。初言菩萨修习此业得寿命长善知宿世。略明得果。二迦叶白下问答广辩。三迦叶当知佛是常下结劝修学。初段可知。第二广中有三问答。第一迦叶执因征果难佛无常。如来答之。明己是常。第二迦叶闻常不解请佛宣说。如来为辩。第三迦叶执真难应。如来为释。初中迦叶先牒佛言呵不应说。何以故下以理征责成前不应。于中有二。一举因征果难佛无常。二从如来将无已下。准果验因疑无慈行。就初难中。先喻。后合。喻中有二。一言行相违喻。名佛以为知法之人。佛说常果酬遂常因。名说种种孝真之法。因为父母。果为子故。摄义就已名至家中。以无常果乖违常因。名以瓦石打掷父母。二而是下叹因责果喻。先叹其因。如是父母举佛昔因。得果所依名良福田。能生常果名多利益。此因叵得名难遭遇。应以常果而酬遂之。名应供养。下责今果。无常之果乖违常因。名反恼害。下次合之。先合初句。是知法人言行相违牒次前喻。如来所言亦如是者举法以合。菩萨修下合第二句。菩萨修等应得长寿合前叹因。今者已下合后责果。第二举果验因之中。将无于生有怨憎想。明无慈心。世尊昔日作何恶下明无善行。下佛答之。汝今何缘。呵其难辞翻上后难。如来长寿于诸寿下。明佛体常对上初难。诸寿中胜是佛报常。所得常法诸常中最。是佛法常。第二段中迦叶先请。下佛为解。有四复次。前二复次明常所以。后二复次显常殊胜。就前二中。初一明其诸命同入所以名常。先喻。后合。人中天上地及虚空悉入如来寿命海者。解有二义。一就自行趣果以论。佛在因中具有无量人天善业齐应得果。今皆共感如来之命。是以云入。二约他以辩。一切人天所有寿命皆在如来寿命限中。故说为入。第二明其出生多命故得为常。于中先喻。阿耨达池从主立称。此方正翻名无热恼。傍名清凉。无热恼龙居其中故。出四河者。经说不定。或云出八。或复言出二十大河。各有所以。言出四者。此池在于香山之顶。于山四面有四兽头。东方金象。口出恒河。南方银牛。口中流出辛头大河。西琉璃马。口中流出悉陀大河。北颇梨师子。口中流出博叉大河。言二十者。如阿含说。四河去池四十里外各出四河。通本二十随方赴海。言出八者。佛出山东。东方五河人皆具见备取为喻。余方大河有大名声人皆同知。亦取为喻。通前说八。余方小河无大名声。人多不知。故不举之。所以言八。今但云四。下次合之。如来亦尔出一切命。解有两义。一就自己化用以论。化起多命名出一切。二就如来化他以说。教他令得是故云出。后二复次明常胜中。前明法常。后显报常。并先立喻后合可知。第三段中迦叶先难。若佛是常何不住世一劫半劫。下佛答之。先呵。后释。释中有二。初举劣显胜明佛实常。先举其劣。如是五通尚得已下牒劣显胜。以是下结。二如来此身是变化下彰灭是应。先明是应。为度已下显己化意。上来三番合为第二问答广辩

下劝修学。初先劝知。次劝修行。后劝宣说。文中可知。上来第一明佛体常。自下第二寄对辩异显其不同。于中初明不同凡夫。涅槃义者即是诸佛之法性下不同二乘。汝今不应思量如来何处住下不同菩萨。前中迦叶先问起发。后佛答之。问中有二。一问佛差别。二如佛言下难使无别。于中先举邪正。二常若言已下就之设难。先难如来同其世常。何以故下释彼世常同于佛常。佛答有三。一明邪异正。二是故如来出世已下辩正异邪。三以是义下结劝修学。就初段中。先喻。次合。有难解者下重显之。喻中七句。一过佛说经喻。二长者终下外道窃法喻。三贼得牛下无师自构喻。四各相谓下学佛求常喻。五我等无下求常不得喻。六以醍醐下妄加己情喻。七以水多下加情损失喻。初中长者喻于如来。牛喻行法。行门差别名色种种。同显一诠名共一群。委修行者随缘习学。名付牧人随逐水草。为得涅槃不期余报。名为醍醐不求乳酪。菩萨如彼牧牛之者。依法思量说之为构。得义充神名之为食。第二段中过佛迁化名为命终。诸外道等盗佛正法安置己典。名为群贼之所抄掠。第三段中彼无善巧解释之师名无妇女。出情图度名自构将。忆想作解用以充神名得已食。第四段中彼大长者畜养此牛但为醍醐。远寻圣意。我等已下学佛求常。夫醍醐下叹其所求。第五段中外道自忖身无道机。名为无器。此乃就其根性中语。依法修善名为得乳。无有道机录彼善行名无安处。外道唯有世俗善机。收录彼善。故言相谓唯有皮囊可以盛之。不能观察破相求实。是故说之不知攒摇。正观名攒。傍推曰摇。世善叵生名浆难得。道果绝分名况生苏。第六段中以醍醐故加以水者。为得常果于生死中妄想建立。宣说梵天自在天等以为常乐。第七段中以水多故一切失者。由加妄情失于世善。名为失乳。失于贤圣所修道行。名为失酪。不得涅槃名失醍醐。此等应得不得名失。下次合之。前七句中但合五句第一第四略而不合。合第二中。初先正合。何以下释。如彼贼下举喻以帖。次合第三。凡夫虽得戒定智慧合贼得牛。无有方便不知解说合无妇女。次合第五。以是义故不能获得常戒定等。合浆难得况复生苏。如彼贼下举喻以帖。次合第六。群贼加水牒举前喻。凡夫亦下举法以合。次合第七。实亦不得解脱涅槃。合乳酪等一切俱失。如彼贼下举喻以帖。上来合竟。自下第三重显向前加水之相。凡夫所修人天善行如所加乳。妄说常等名为加水。文中先明所加之乳。举法喻帖。如是凡夫实不知下明其加水。文显可知。上来第一明邪异正。自下第二辩正异邪。初先法说。次喻。后合。是故如来出世之后乃为演说常等法说。是破外道妄说常乐我净法故

佛为正说常乐净等。喻中六句。一如来出现喻。轮王喻佛。化现世间名出于世。二福德力下外道退散喻。三牛无损下正法无损喻四王以诸牛付一牧下付人修学喻。佛以正法付诸菩萨。名付牧人多巧便者。五是人下修学得常喻。菩萨巧修证会常法名得醍醐。六醍醐下得常广益喻。以己所得化他同证令出生死。名无患苦。合中圣王出现世时合上初句。诸凡夫下合第二句。先合。后帖。如来善说世出世法合第三句牛无损命。为众生下合第四句付一牧人。为众生故令诸菩萨随而演说。菩萨既得合第五句是人方便即得醍醐。正应说言既得常果。法从喻称。故云醍醐。复令已下合第六句。然上喻中云无患苦。今此合中言得常乐。言左右耳。上来第二辩正异邪。自下第三结劝修学。先结。后劝。结中初言以是义者。以佛不同世间之义。如来常等结明常义。唯在如来不在余人。此常法称要是已下。结明常名唯在如来不在余法。下次劝之。初先劝知。后劝修学。劝学有三。一劝修学常住二字。常是法常。住是报常。依法住故。二明修者随佛所行至佛至处。修同如来名随我行。得果同佛名至我处。又修报常名随我行。证会法常名至我处。三明修者佛为涅槃。言修二字为灭相者。修佛常住为大涅槃寂灭之相。以此二法离相离性。故称为灭。当知如来则于其人为涅槃者。大般涅槃独显其心。故云为般。准下解释涅槃之义。道理正尔。不得异释。上来第一不同凡夫。自下第二不同二乘。于中有三。一明涅槃唯是佛法。第二迦叶执小难大。第三如来辩大异小。就初段中。涅槃义者牒佛向前为般涅槃。即是诸佛之法性者。约人辩法。明异二乘。第二段中。先请。后难。请中初言佛法性者其义云何。咨请佛义。我今欲下求请佛说。难中四句。一有性无身难。夫法性者牒佛向前涅槃法性。即是舍身准小类大。谓同小乘舍身舍智方为涅槃。言舍身者名无所有。释大同小。同于小乘灭无所有。若无所有身云何存。执无难有。二身若存下有身无性难。身若存者纵听有身。云何而言身有法性。难破有性。由身存故不得灭身以为涅槃。故无法性。三身有性下双牒并征。道言身者牒后有身。有法性者牒前有性。云何存者就以并征。若言有身法性之义云何得存。若有法性。法性是无。身云何存。四我今下彰己不知。请佛释通。佛答有四。一明法性非无。二明二乘不知。三明佛身非无。四明二乘不知。文别可见。就初段中。汝不应说灭是法性呵其难辞。夫性无灭正显非无。第二段中就喻以明。二乘不知仰类佛德。如无想天成就色阴而无色想。举其喻事。第四禅中广果天处。有诸外道修无想定生于彼中。初生有想中间想灭。经五百劫命欲尽时。心想还生。便谤涅槃。终入地狱。佛今举之。彼想灭时但有色阴。而无色阴所依之想。亦无依色攀缘之想。名无色想。不应问下彰其难知。彼无想天虽无粗想。非无细想所有心识。二乘不知。故不应问。喻明如来生死虽灭真德常存。所有真德非二乘知故不应问。云何住者问其色阴。云何受乐问其受阴。云何行者问其行阴。云何想者问其想阴。云何见闻问其识阴。此皆不应。如来境下显前不应问之所以。无想天报唯佛境界非二乘知。故不应问。所况佛德类亦同尔。第三段中不应说言如来身灭。明身非无。又明佛身非是无常迁灭之法。是故不应说身是灭。第四段中就法以明二乘不知。如是灭法牒前涅槃。是佛境界明唯佛知。非诸已下明非二乘之所知也。自下第三不同菩萨。于中三句。一劝迦叶不应思量。何处住者思佛色阴。何处行者思佛行阴。何处见者思佛识阴。何处乐者思佛受阴。略不云想。此皆不应。以佛平等法门之身。妙出情外。无一处在而无不在。故不应思。二如是义下明其不知。成前不应思量之义。不知同小。是故云亦。三诸佛下举佛不思。成前不知。诸佛法身是法性身。种种方便是佛报身。报德差别故云种种。方便修生故名方便。亦可法身是佛真身。种种方便是佛应身。皆不可思。故彼不知。上来第一明佛体常即是自德。自下第二就常说归明摄他德。于中有三。一就常辩归。二迦叶闻说领解修行。三如来述赞。初中应修佛法及僧而作常想。总劝修学。亦应说言作无异想及无变想。但今文中乘上所辩但劝修常。余略不论。是三法下别教修学。先开三门。次广辩释。若言如来异法僧下破邪显正。前开门中言是三法无异想者。明非别体。一佛体上随义分三。故无别异。无无常者体非生灭。不同变易。无变异者体无终尽。不同分段。准释应尔。约此三门教除邪想。下广辩之。先广无异。次广第二无无常义。后广无变。此三段中文有隐显。广无异中单反无顺。无无常中反顺双举。解无变中唯顺无反。互从皆得。辩无异中于三修异请净三归则无依处。明无初始归趣之心。清净三归。非是其人所趣向处。名无归处。禁戒不具明无中间正修之行。趣真行阙。所以不具。诸行皆阙。离恶在初。故但云戒。终不能得声闻缘觉菩提果者。明无究竟所成之果。三乘之果并皆不成。故云不得声闻等果。不得菩提义则可尔。云何不得声闻缘觉。解言。若人一向不闻一体三归作别异想。容得声闻缘觉之果。若曾闻说一体三归诽谤不受。作别异想。此即是其谤方等人罪过五逆。人天之报尚不可阶。况能证得二乘道果。若能于下解释第二无无常义。先顺。后反。顺中初法。次喻。后合。法中若能于是不思修常想者。则有归处。明有初始归向之心。常住三归是其所向。故有归处。准前应言禁戒具足能得声闻缘觉等果。略不具论。喻中如树喻上初段如来体常。则有树影喻此后段三归义常。依佛常体开此三归摄人之用。故如因树则有树影。合中如来亦尔。总合。有常法故合前树也。则有归处合有树影。非是无常总结为常。下反释之。若言如来是无常者。举彼异见。则非世人所归依处。辩过以非。无常灭去谁为物归。自下第三释无变异。迦叶初先举闇无影。欲令如来同之变异。下佛答之。明影常有显佛无变。于中先明如来恒有无眼不具。先喻。后合。如彼闇下明诸众生不见时节。先喻。后合。佛灭度后合彼闇时。说言无常合不见影。上来广辩。自下第三破邪显正。且就初门破邪显正。余二可知。若言如来异法僧者。举其异见。则不能成三归依处以理示过。如汝已下约喻显过。三归各别不即常性。故是无常

上来第一教示真归。自下迦叶领解修行。于中有三。一以真归。上开父母。乃至七世无始皆开。但随世俗且言七世。又七世来爱习未舍。可以摄化。故说开之。七世父母随生何道。迦叶皆往而为开化。如佛升天为母说法。二我今下中益己身。三既自下下利众生。有信众生直为广说。无信众生惧伏令学

第三如来述赞之中。初叹护法。次叹益人。以善益人故曰不欺下明得果

金刚身品者。此品之中具答二问。一答云何得金刚身。二答何因得坚固力。此二因同。一处答之。于此二中。就始以标。是故名为金刚身品。下文之中具辩五身。何故偏名金刚身品。不可并题。且举金刚就第一问。偏云金刚。此品有四。一明得身。二总结叹。三迦叶领解。四如来述赞。就初段中。先明其果。而未能知所因已下辩其得因。向前品中先因后果。今乘前便。先果后因。就明果中。先略。后广。如来身者是常住身乃至法身。是其略也。身体不迁名常住身。不为缘沮名不坏身。不坏之义如世金刚。是故就喻名金刚身。不假资成名非杂食身。唯以法成名为法身。下广显之。迦叶先问。如来次答。下迦叶领解。问中有二。一牒佛所说明己不见。二唯见下举佛化迹彰己所见。先明所见无常坏等。坏翻不坏。尘翻金刚。食翻非食。等者等于血肉之身。翻前法身。何以下释。以入涅槃故非常等。此义上来佛数解释。迦叶何故仍为此问。为起说故。又以世人执见难舍。欲令如来重为破遣。故复举之。答中有四。一就所见以呵。二如来之身无量亿劫坚牢已下。就所不见以教。三如是功德成如来身非食身下。就前所呵以破。亦名为释。四汝今当知如来之身即金刚下。就前所教以劝。初中莫谓是呵辞也。第二教中文别有三。一辩德广教。二如来法身皆悉成下总以结叹。三唯有如来乃知已下。明前迦叶不见所以。初中先约过去以教。如来非身是身已下就现以教。般涅槃时不般已下就后以教。初言如来无量亿劫坚牢难坏。举本显今。现中初言非身是身开列章门。有过皆舍名为非身。有德斯备称为是身。不生灭下广以显之。于中所有遣相之言。成前非身。辩德之辞显上是身。唯可如是总相粗判。不可碎分。非身是身。不可说下牒以结叹。非身是身牒前所辩。不可宣说明其出言。除一法等彰其离相。除一法相明非一相。不可算数明非异相。就后教中。般涅槃时不般涅槃。明实不灭。上来广教。如来法身皆悉成下第二总结。唯如来下是第三段释前迦叶不见所以。良以佛身唯如来知。非诸声闻缘觉知故。迦叶不见。迦叶示同二乘不见。故今举此释其不见。上来第二如来教竟。自下第三就前第一所呵以破。于中三句。前之两句举佛真德破其所见。后之一句举佛应病释其所见。前两句中。如是功德成如来身非是杂食。破前迦叶唯见食身。如来真身功德如是云何复得诸疾苦等。破前迦叶所见无常破坏之身。言无危等即是显佛坚固力也。第三句中明佛为生示现病苦。故令迦叶见佛无常破坏身等。自下第四就上第二所教以劝。先劝令知如来之身即是金刚。次劝令思。思佛金刚非是食身。后劝令说。说佛法身。上来第二如来广答。自下第三迦叶领解。于中初先领佛前言彰己解知。次受佛前劝。彰己常思。后受佛劝。彰己宣说。上来明果。下次辩因。迦叶初先领前问后。以为起发。唯然法身金刚不坏。是领前也。而未能下是问后也。佛答有二。一明护法以为身因。二是故护法优婆塞等应执刀下明护法人德行相貌。前中有四。一略明护法以为身因。二我于往昔下略引已为证。三护持法者不受戒下广明护法以为身因。四过去已下广引已为证。初二可知。第三段中初明在家俗人护法不受五戒不修威仪劝其舍小。小乘法中善优婆塞不畜刀杖。不得护法。为是不受。应持刀等教其习大。迦叶白下出家护法。初先迦叶反问起发。若有比丘离于守护是真比丘取中为上。若随守护是秃居士取上作下。戒中宣说。持刀杖者比丘不得为之说法。今有随者犯戒无行。是故说之为秃居士。下佛先呵。莫说如是上品比丘为秃居士。下正为辩。先明中品。次明上品。后显下品。明中品中。先彰其得。次辩其失。后结显过。得中初明自行之得。有来问下明利他得。自中初言供身趣足。有节量行。读诵经等有修善行。利他可知。下次明失。虽能如是然故不能作师子吼。不能宣说大乘教法。不为师子之所围绕。不能流通大乘行法。不能大乘善法摄人。是故不为师子围绕。不能行违摄化恶人。是故不能降伏非法。下结过中。如是比丘不能自利及利众生。就前失中。结以显过。虽能持下就前得中结以显过。就上品中。初彰其失。次辩其得。后劝修学。失中供身亦常足者无节量行。就明得中复能持戒是自利德。能师子下是利他德。于中有三。一能宣通大乘教法。二利益安下明能流行大乘行法。三若有比丘能如是下劝人防护。前中初总。修多下别。经有十二。以何义故但言九部。释言。诸经辩义不定。或时大小合为十二。小乘法中宣说十一。略无方广。小乘未说方广理故。大乘经法合为方广。大乘为显方广理故。故地持云。十二部中唯方广部是菩萨藏。余十一部是声闻藏。此经亦尔。故下文言十一部经二乘所持。方广一部菩萨所持。或大乘小乘各说九部。如法华说。小乘法中略无受记无问自说及与方广。故但有九。小乘之中未说行因作佛之义。故无授记。法浅易咨故无自说。未辩广理故无方广。大乘法中略无因缘譬喻论义。故但有九。大乘众生利根易悟。不假因缘譬喻论义。方始悟解。是以略无。或随义具论大乘小乘皆有十二。今据一门且说九部。以如是下总以结之。第二段中初依经唱制。若有比丘畜如是下依法治罪。于中初先如法治罚。如来先下引说证成。明合治罚。就第三段劝人护中。初举未来留难之事。是说法者设命终下彰益劝为。以是缘下劝人防护。上来辩得第三结劝文显可知。就明下品比丘之中。如是破戒名秃居士者。名前破戒害法师人为秃居士。非持戒者得是名字。简上异下。就第四段广引证中文别有四。一举往事。有德国王生阿閦国作第一弟子者。所谓声闻四果之中第一人也。觉德生彼作第二弟子者。是四果中第二人也。二结劝护法。三会通古今。初先会通。护正法者得如是下叹因成果。迦叶白下述叹所成。四结劝护法。自下第二明护法人德行相貌。先明在家德行相貌。后论出家。前中初言是故护法优婆塞等。乘前以劝。是护法者有大果故。应持刀杖护持法人。若受已下正明护法德行相貌。受小五戒不持刀杖护说法人。不名大乘。不受五戒持杖护法。乃名大乘。下总结劝。就明出家德行相中。初迦叶问。为有师耶为无师乎。问持法人师德有无。为是持戒为是破戒。问持法人师行持犯。下佛答之。先对后问。明持非犯。谓具正下对其初问明有师德。前中先呵。莫谓是等为破戒人。下释有四。一举未来留难之事。二迦叶请。当于尔时云何行化。三如来答。为是我听持法比丘随俗通化。此即明其比丘无犯。四若诸国下乘明能护俗人无犯。于中初明诸国王等虽持刀杖是持非犯。次劝莫杀。后结其人第一持戒。就答初问明有德中。初明其人三业善正具有师行。众有三下善摄徒众。具有师能。亦名师益。善持律下通经达律。体圣化仪。具有师德。就初段中先明有行。若有比丘以利养下举恶显善。明有行中先明自行。谓具正见意业善也。能广宣下口业善也。终不捉下身业善也。摧伏已下明能利他。是名已下结前自利。能为生下结上利他。举恶可知。明师能中先举三众。次列三名。身虽不犯。与破戒者和杂一处。名犯戒杂僧。自身无犯。见己弟子有犯教悔。他犯舍置。名愚痴僧。自净净他名清净僧。次辩优劣。破戒杂僧为利同犯。故易可坏。净僧不尔。故不可坏。痴僧未必为利同犯。又不能异。故废不论。下广辩释。虽辩前二。意显第三。明师德中。初明知律。后明善经。就知律中。先开五门。次释。后结。前开门中。善持律者总以标举。下列五名。为欲调伏利众生故。是第一门。所谓菩萨权化方便行非通道。若轻第二。若重第三。非律不证是其第四。是律便证是其第五。广释可知。结中善解一字义者解一律字。善持契经亦如是者。亦同知律。且有五门。一知菩萨权行方便。第二知浅。第三知深。四是经应证。五非经不证。上来第一明因得果。自下第二总以结叹。佛法不思结叹前因。如来不思结叹上果。迦叶白下。大段第三领解奉行。初先领解。如是如是诚如圣教。领前广说佛法不思。如来亦尔领后结叹。故知已下彰己奉行。先许自行。后为他说。自下第四如来述赞。先总叹善。次劝正学。后明学益

名字功德品者。此经名中说大涅槃功德之法。摄旨从诠。是故说为名字功德。广辩此义。故云名字功德品也。此品答上云何于经究竟到岸。辩经名德。令人奉持穷经旨趣。名到经岸。此乃明其安乐之因。持经名德。近离恶道。终得究竟常乐之果。名得安乐。文中有二。一辩经名德劝人受持使到经岸。二迦叶领解。前中复三。第一总举经名功德劝令受持。二闻是经名生四趣下彰益劝持。此即明得世间安乐。三所得功德我今说下辩德教持。此即明得出世安乐。就初段中汝应受持经名章句所有德者。此经名中说大涅槃所有功德。摄旨从诠。故曰名字。所有功德持之得乐故应受持。第二段中闻生四趣无是处者。正举闻益。闻有三品。一者上品。称经而闻。不作闻相不作声相不作字相不作句相。乃至不取一切法相。是人毕竟不生四趣。除悲愿力。二者中品。虽未离相善心听受。暂时不生非永不入。三者下品。微末善心听受此经。远为未来出离因缘。非即不生。今此所论是其上品。故生四趣无是处也。何以下释。良以此经无量诸佛所修习故。闻之不生三涂修罗是四恶趣。第三段中所得功德我今说者。总标许说。谓彼诸佛所得功德今当说矣。次迦叶请。当何名经问经名字。此经之中具说多义。当于何义而名此经。云何持者问奉持仪。下佛答之。此经名为大般涅槃。答其初问。上语善等答其后问。于中有二。一叹经殊胜令人敬持。二汝今听下辩经名德令人乐持。三若欲于此大般涅槃而涅槃下正教奉持。依经学常名为奉持。初中有四。一叹教善。二叹义深。三叹文善。四叹义备。叹教善中随其经文。初中后别为上中下。合法称机能生行心。故名为善。第二句中义味深者名义为味。不同余处名字为味。义能津心令人爱乐如世美味故名为味。与下文中譬如甘蔗数数煎煮得种种味。其义相似。第三句中其文善者。言辞才巧不增不减。故曰文善。第四句中。纯具梵行明其行圆。宝藏无缺彰其理圆。亦可纯备彰其因圆。宝藏无缺明其果满。经有此胜故劝奉持。自下第三辩经名德令人乐持。先总敕听许为宣说。上已许说。迦叶遂请。不得即说。故今重敕许为宣说。下正说中有八复次。初一正出经名功德。次四明其经教功德。后三彰其经义功德。教为此岸。义为彼岸。初中大者名之为常。依于大名辩其大德。此经具有六义释大。已如上辩。今此且以常义显之。如八河下依涅槃名辩涅槃德。先喻后合。此经如是降伏一切诸结烦恼及诸魔性。破相趣寂。此经所辩同前八河。故曰如是。降伏烦恼离烦恼魔。及诸魔性灭余三魔。然后要于大般涅槃放舍身命。证实舍相证实除妄。无妄可在。是故云舍。名大涅槃总以结之。次四教中初一教圆。先喻后合。次一教极。先喻后合。后二教胜。于中前一广破故胜。初先法说。次喻后合。后一复次永尽故胜。先喻后合。后三义中初二义体。后一义用。体中前一灭恶故胜。先喻后合。后一备善。初先立喻。八味具者。就六味中分甘为三。故有八味。一不苦名甘。二不酢名甘。三不辛名甘。是名三也。下约显法。初总次别。不生名常。不灭曰恒。永绝危怖故名为安。离烦恼热名为清凉。不老不死离烦恼果。断诸恶业名为无垢。离恶业果故曰快乐。下总结之。下一复次明义用中就菩萨说。佛则可知。名德如是应善奉持

自下第三教奉持仪。依经学常名。为奉持。上来答问。自下迦叶领解劝学。先自领解。如来法僧不可思者。领向末后三宝常义。涅槃不思领前叹胜辩经名德。下劝他学。先明学益。后彰不学。有其过损

如来性品者。此品之中。备论多法。二十五有有我不下一段经文辩如来性。今从彼文以题品目。盖乃摄广从略名矣。如来之藏能为佛因名如来性。广辩斯义名如来性。于此品中备答多问。四相一章答前问中愿开微密广为生说。准六卷经。前问略少。若具为问。应言愿佛开于微密菩萨依之为众生说。故此文中佛就涅槃微密藏中开三事义。令菩萨说。以答上问。此明何义。今此为显无碍辩因。无碍辩才由为众生说法故得。故此辩之。就此品中三门分别。一科判经文。二就人辩定。三随文解释。科判如何。四相一章文别有二。一明四相能开之德。二复次自正所谓得是大涅槃下明所开法。次就人定。人有二种。一是所寄。二是所为。所寄是佛。所为菩萨。所寄之佛即是能教。所为菩萨即是所教。若就所寄。初番四相是其如来能开之德。故下文中就佛释之。复次自正所谓得是大涅槃下。是其如来所开之法。如来就于大涅槃中开示三事名开微密。若就所为。初番四相是其菩萨能说之德。故此经中创始标宗。云言菩萨开示涅槃有四相义。下复结言菩萨如是分别开示大般涅槃有四相义。六卷经中亦同此说。故彼经言。菩萨具足四种相义。能为众生说大涅槃。复次自正所谓得是大涅槃下。是其菩萨所说之法。依佛所开为他说故。此与向前长寿品中辩义相似。彼就所寄。名为如来长寿之业。彼就所为。说言菩萨以是业缘得寿命长。金刚身品所明亦尔。就人如是。次随文释。能开德中文别有四。一总标举。二列四名。三广辩释。第四总结。初中菩萨开示涅槃有四相者。就所教人明能开德。所教菩萨具足四德方能为人说大涅槃。故云菩萨开示涅槃有四相义。故六卷经云。菩萨具足四种相义。能为众生说大涅槃。次列四名。先问后列。此四通论皆是利他。是说德故。于中分别。前一自利。自行非邪故云自正。后三利他。正化众生令离邪过。故名正他。此一正是化他行体。后二化德能随问答。明知法药。于法自在随问巧答。名随问答。善解因缘识达根性。善知随机授化因缘。名解因缘。第三释中先解自正。初问。次释。后牒总结。释中有二。一约教法以明自正。二若言如来法僧已下。约就常义以明自正。前中假就比丘说之。若佛如来见佛因缘而有说者。假举如来验诫之言。佛于一时见大火聚炽然因缘。便告比丘。汝宁抱是炽然火聚。宁说如来十二部经及秘密藏云波旬说。名见因缘而有所说。譬如已下对问以明比丘自正。举彼类显菩萨自正。故云譬如十二小教。秘藏大教。自正心坚。故宁抱火不敢说此为波旬说。何故而然。欲明抱火但坏一身。谤法能坏无量世身。又复抱火但坏肉身。谤法之罪能坏法身。为是不说。后自正中句别有五。一知他宣说三宝无常有大衰损。自侵损己。欺人损他。邪法教他名为欺人。二宁以刀下自制不为。宁刀断舌不说无常。与前抱火其事相似。三若闻他下闻说不受。四于此下见说生怜。怜彼当受无量苦故。五如来法僧不可思下以理自遮。上来释竟。自观已下牒以总结。自观己身犹如火聚。是牒前也。前二段中就初以牒。此明菩萨自观己身犹如比丘宁抱大火。是名结也。就正他中。初问。次辩。第三总结。辩中有二。一明如来当时善授。二复告女人汝有缘下后时善付。前中有四。一明女人养子之仪。始必与苏。二约之显化始须授小。三复明女人养子之仪。大须与食。四约之显化终须授大。初中六句。一明如来当说法时。有一女人。多含儿酥。来至佛会。顾念其子。不知消不。二佛知故问汝含儿酥不知消不。佛为此问。具有三意。一欲令女人安心听法。二欲彰女人善授儿苏。约之明佛善能授法。三欲对之说消不消类显自己能量众生堪与不堪。此是第二。三女闻请佛。于中初先叹佛知心。次请如来教示多少。后请如来说消不消。四如来为辩。汝儿所食即消增寿。五女闻欢喜。于中初言心大踊跃。闻消故喜。复作言下庆实故喜。六结叹如来。世尊如是为调众生善能分别说消不消。此谁结叹。有人释言女人叹佛。复有人言是佛自叹。当应是其集经者叹。上来六句合为第一。自下第二约之显化。亦说诸法无我无常。明其昔日唯得说小。亦同女人始与儿苏。是故言亦。亦可同前说消不消。故云亦说。若佛世尊先说常下。彰其昔日不得说大。良以昔日凡情未遣故不得说。若为说大。便言此法与外道同。即便舍去。自下第三复明女人养子之仪。大须与食。文显可知。我之所有声闻已下。是第四段约之显化明终说大。于中初言我之所有声闻弟子如汝婴儿不消常住先说苦等。举昔显今。若我弟子功德备下明今异昔。于中四句。一明弟子功德已备堪修大乘为说六味。如儿长大能消难消应当与食。所化如是。应授六法。法从喻称。故云六味。二云何下列其六名。具应有八。约世六味但说六种。以净不净二义粗显故不论也。下还说有。三彼世间下分定优劣。三是世间。三是出世。先明世间。彼世间中有三种味。总以标举。谓无常等列其名字。下明出世。于中先明成涅槃饭。烦恼为彼智火所焚。名之为薪。智焚惑薪故复名火。相因得名。以焚惑薪故成涅槃。法从喻称说之为饭。谓常乐下就彼涅槃列出三昧。四令诸下就六味中简胜劝学。令诸弟子甘嗜涅槃常乐我味。上来第一当时善授。自下第二明后善付。于中有三。一明大乘应付菩萨不付声闻。二何以下释菩萨知常。二乘弟子谓佛灭故。三以是义下总以结叹。初中如来先教女人行驱恶子宝示善子。女人白下印可佛语。姊下如来约之显化。我涅槃时合前女人欲至他处。无上佛法不与声闻合驱恶子。如汝下帖要当付。下合付善子。如汝下帖。第二释中先问起发。驱恶违等。故问何故。下对释之。句别有四。一明声闻谓佛灭度我实不灭。举理显非。二如汝下举事类显。三明菩萨说佛不灭。四如汝下举喻类显。第三段中。以是义故无上秘藏付于菩萨。结上初段。以是菩萨如善子故秘藏应付。若有众生谓佛常下。叹后段中菩萨知常。若知佛常。佛于其人常存不灭。故于其家则为有佛。是名下结。能随问中初牒前问。次释。后结。下因其言乘唱肉制。释中且就布施一门明随问答。余类可知。于中先问。若有人来假举问人。问佛以下假举问辞。施是舍财。不舍钱财成施至难。故举问之。下明随答。于中初先五句别答。良以此等舍心成就。故得名施。前人不受。故财不损。举此即欲显此经中不净物等悉不应受。如是施下总以结之。施名流布遍至他方。结成大施寄名显之。所舍宽多故名大施。又因舍故前人不受。得显此经遮制之义。因财通法。故名大施。财宝不失结成不损。是名下结。下因向前断酒肉者施酒肉言。故从此下乘唱断肉。文别有九。一因迦叶请正宣肉制。二迦叶白佛云何如来不听食下明断肉意。三迦叶言如来何故先听食下会通昔言。四迦叶言如来若制不食肉下明制分齐。五如来所制各有异下泛明一切立制之意。六我从今日制弟子下明食肉过。七我涅槃后无量岁下辩食肉人。八迦叶白诸比丘等因他活下辩开遮仪。九若我广下总结肉制。此亦即是持戒门中能随问答。初中迦叶先问起发。食肉之人不应施肉。以理直请。何以下释。下佛先叹。次唱断肉。后举余食况肉不应。何故偏言声闻弟子不听食肉。菩萨先制如楞伽说。是中但制小乘故也。自下第二明断肉意。迦叶先问云何不听。下佛答之。断大慈种是以不听。地上大慈地前名种。第三会通昔言之中有三问答。初问食肉断大慈种云何如来先听比丘食三净肉。不见闻疑是三净也。佛答随事渐断故尔。言听食净为断不净。二问如来已听比丘食三净肉。何缘于中十种不净九种清净而复不听。十种不净下文自数。人蛇象马驴狗师子猪狐猕猴。是其十也。于此十中不见闻疑他为己杀。是故摄入三种净中。生世机嫌故名不净。九种清净自未见文。人传释之。前十种外余众生中不见他杀。亦无闻疑及不为已即以为四。先乾自死及与鸟残通前为七。不期偶得及他自杀请已而食。通前为九。下佛答之。此亦是我随事渐制。三问如来随事渐制。何故昔日赞肉为美。佛答有二。一明叹余食。二举衣况食成己不叹。此第三竟。第四立制分齐之中迦叶先请。若制食肉。五种牛味胡麻油等。佛亦应断。下佛呵之。不应同彼尼干所见。第五泛明立制意中。一切立制各有异意总以标举。下别显之。言异意故听食三者。意为断却余不净肉。言中听食三种净肉。心与言别。故云异意。言异想故断十种者。想犹意也。为欲于彼三种净中以渐遮断。是故且言断十不净。此异前意。名为异想。言异想故一切断者。为欲于彼十种之外一切悉断。故今宣唱九净亦断。此乃异前渐断之想。故复称异。第六广明食肉过中先举前制。从今不得食一切肉。下广辩过。初先法说。次喻。后合。是故已下结明菩萨不食肉义。于中初明菩萨不食。为度已下拂权显实。如是已下举净显秽。第七辩明食肉人中。初外善内恶。尔时复下内外俱恶。第八广明开遮之中迦叶先请。乞食杂肉云何得食。佛教可解。第九结制。文显可知。解因缘中。先问。次释。第三总结。释中有四。一问。二答。三难。四通。就初问中。为彰如来善解随机渐化因缘。反责如来经不顿说律不顿制。如有四众假举问人。来问我下假举问辞。辞中有二。一责如来经不顿说。二或名犯下呵责如来律不顿制。经中初先责不顿说。或说深下呵其渐说。责不顿中。如是义者谓佛常义。如来初出何不即为波斯匿王说是深义。责不顿说。佛初出时波斯匿王其母命终。王甚忧恼。佛为开解。说佛缘觉及弟子众皆悉无常。故今对之责不顿说。或时说深或时说浅。呵其渐说。昔为波斯说佛无常名之为浅。今日说常以之为深。下就律中。或名为犯或名不犯呵其渐制。如来初出未广制戒名为不犯。后广制戒名之为犯。云何随下责不先制。然此文中直举三名请佛解释以为责本。责相未显。待佛解竟。至后难中。责相方显。云何堕者问其所防。所防之罪能随地狱畜生鬼等。故名为堕。律及木叉问其能防。能防教法说之为律。律者是其诠量为义。诠量轻重持犯得失能防行法。说为木叉。此云解脱。解脱业非故名解脱。遗教亦云。戒是正顺解脱之本故名波罗提木叉也。此相云何。下佛答之。文别有四。一明戒律不得顿制。若当顿制。有人便破一切禁戒。二或复有人诽谤已下。明其经法不得顿说。若当顿说。有人便谤一切诸法。三如是等人自言聪下。重就经法明顿说过。由顿说故能谤之人自言聪明不肯改悔。四轻重之罪皆悉覆下。重就戒律明顿制过。由顿制故破戒之人坚覆不悔。初中有二。一对上问中云何堕等释显其义。二或有人尽破戒下。对上问中或名为犯或名不犯。明其戒律不得顿制制则顿犯。前中有四。一释木叉明能防行。二解堕义彰所防罪。三重释木叉明所诠行。四解律义彰能诠教。两处解释木叉何别。前约遮过以解木叉。后约性罪以释木叉。初中佛言提木叉者牒举所问。名为知足转名显示。成就威仪无所受畜正辩其相。亦名净命转名显示。解此义竟。前责即显。若使木叉有如是义。何不先制。待诸比丘犯竟方制。就解堕中先释后结。释中三番。前二就其受报以解。后一就其造因以释。就前二中初一通对四趣以论。依如律中唯第三篇名之为堕。此则不尔。犯五篇戒堕四恶趣通名为堕。后一偏对地狱以释。堕于地狱乃至阿鼻论其迟速过于暴雨。正解堕义。八大狱中阿鼻最下。故曰乃至。生阿鼻者其业必重。趣报无间。故过暴雨。闻者已下明说堕意。闻者持戒不犯威仪。修离过行。不犯性罪名坚持戒。遮过亦离名不犯威仪。修习知足不受不净。修离着行。下就造因以释堕义。由造因故长养地狱畜生饿鬼。以是义下总以结之。释此堕竟。前责即显。堕有是义。何不先说。待诸众生犯竟方制。第三重解木叉之中。离身口意不善邪业明离性罪。辩此义竟。前责即显。木叉如是。何不先制。待诸比丘犯竟方制。就解律中入戒威仪。明顺戒法。入犹顺也。制断重罪名为入戒。遮离轻过名入威仪。深经善义明顺经法。前一入字贯通此句。遮受一切及不净缘。显入深经善义之相。亦遮重等显前入戒威仪之相。辩此义竟。前责亦显。律有此义何不先制。待诸比丘犯竟方制。上来第一释前问中云何堕等。或有人下对上问中或名为犯或名不犯。明其不得顿制所以。若当顿制。有人闻戒广多难持。破一切戒。为是不得。云何已下辩其所破。上来第一明其戒律不得顿制。或复有人诽谤已下。第二大段彰其经法不得顿说。于中初言或有诽谤甚深经法。闻说常义谤同外道。及一阐提具足成就尽一切相无因缘者。闻说大乘甚深空义。尽谤真谛一切法相。无世因缘成一阐提。为是不得。如是等人自言我聪。是第三段重明向前谤经之人坚执难舍。自谓聪明能解深义。故执不舍。轻重之罪皆悉覆下。是第四段重明向前破戒之人覆藏不悔。于中初明犯罪覆藏。先法。后喻。如是已下明由不悔令罪增长。是诸已下牒以结成不得顿制。是诸比丘所犯不发牒前覆藏。所犯滋蔓牒前增长。是故下结。上来第二如来答竟。第三难中文别有二。一对前如来解释堕义责不先制。二如多人下对上解律及解木叉责不先制。前中尔时男子女人假举问人。自下难辞。如来久知如是事者。明佛先知向前堕义。何不先制责咎如来。如来久知犯罪堕于恶道之事。何不先制使诸众生犯竟方制。将无欲令众生入狱。就后难中。初明世人迷谬无知。先喻。后合。如来应下征责如来不为先说。于中初先以理征佛。次释。后结。征中如来应先为说。总明应说。敕诸比丘此是犯等。别明应说。释中先征。我以何故征责如来应先为说。如来能知及能说故。如来正觉知见正道。是能知也。唯有如来能说十善。是能说也。能说十善是止善法。增上功德是作善法。此二行法。及其义味是其理法。是故下结。是佛能知及能说故。我清先制。第四通中。对前两难还有两释。先对初段将无令生入阿鼻狱而自免过。如王已下对向后难。明为众生不得先制。前中约就三业释之。若言如来能说十善是则视生如罗睺罗云何难言将无令生入阿鼻狱牒前问辞。明己口业利益众生。是故不欲令生入狱。我见一人堕阿鼻下。明己身业久住益物是故不欲令生入狱。我于众生有大慈下。明己内心慈益众生是故不欲令生入狱。释后难中有三复次。前二起化渐次以释之。后一拂权显实以释。前中初明化人次第。如轮王下行法次第。化次第中先喻后合。喻中初言如王国内喻三千界。有纳衣者喻佛如来。补衣之人名衲衣者。衣喻众生。见生造过名衣有孔。制戒防禁名后方补。人言略教以之为衣。一向非是。合中如来合纳衣者。见诸众生合前见衣。有入阿鼻合衣有孔。即以戒补合上方补。第二行法次第之中先喻后合。喻中明王先说十善。次有恶者堕过渐断。后诸众生渐行圣王所说善法。合中初言我亦如是合前转王。虽有所说合说十善。不得先下合后恶者随事渐断。乐法生下合后自行圣王之法。就后拂权显实之中先喻后合。如来法僧不可思者。明其三宝实德不思。能说法者及闻法者不可思者。明其佛僧权德不思。说者是佛。闻者所谓六群比丘须题那等。皆是不思解脱菩萨。示为起教。不可执此以为定责。是名下结

上来第三广释四相。自下第四释已总结。菩萨如是开示四相。就人总结。此四菩萨能开之德。故就结之。是名大乘大涅槃中因缘义也。就法别结。涅槃经中说是四相。故就结之。理应具结。解缘在后。故偏结之。余三略也。上来明其能开之德。自下第二明所开法。于中有三。一就涅槃微妙义中开出般若。二若男子女人作如是言如来无常下。就涅槃中开出法身。三迦叶白佛如佛昔说无所积聚下。就涅槃中开出解脱。前中初明波若四相。假使有人作是言下。结彼四相即大涅槃。上来所辩是能开德。是故结之以属菩萨。自下四相是所开法。是故结之以属涅槃。就初段中自正标举。谓得涅槃释显其相正他标举。我为比丘说常不变。释显其相随问标举。下释可知因缘标举。下释其相。先举二乘不解因缘不解深义正明不解。不闻已下彰彼二乘不解所由。由其不闻。不闻伊字。不闻今喻。不闻解脱涅槃波若。成秘密藏。不闻今法。然上文中宣说法身解脱波若成秘密藏。此说解脱涅槃波若。成秘密藏。何故不同。大涅槃中诸德同体皆相集成。互举皆得。我今已下明佛善解为之开示。就结四相。即涅槃中初问起发。次就譬喻反质问者。不也已下问者正答。自正已下约之显法。明自正等皆即涅槃故得为一。明法身中初明如来法身体常。如佛言曰我已久渡烦恼海下。拂去迹疑成其常义。前中初先问答辩常。二迦叶领解。三佛述成。就初段中有三问答。初执昔日事尽之无难。佛无常。下佛答之。生死因果是无常法。如来断尽故名为常。第二迦叶乘言重难。如彼迸铁热与赤色灭已无有。如来亦尔。灭已无有。说何为常。下佛答之。所断烦恼更不重生。故得名常。第三迦叶难破如来不重生义。如铁冷已还置火中赤色复生。如来若尔。烦恼灭已应还生结。不得为常。佛下转喻释成不生显有常义。如彼燃木灭已有灰更不作木。如来亦尔。烦恼灭已法身常存更不生结。故得为常。就初难中。若有男女假举问人。作是言下假举问辞。如来无常是总难也。云何知下广显无常。先问后辩辩。中有五。初一复次举佛昔说有余之灭。难佛无常。第二复次举佛昔说无余之灭难佛无常。次二复次重举昔日有余之灭难佛无常。下一复次双举有余无余二灭难佛无常。初中先举如来昔言于中。初法。次喻。后合。云何已下约之结难难破无常。第二难中先举昔说无余之灭。言离诸有名涅槃者舍相趣寂。三有果报名为诸有。又复二十五有之果亦名诸有。离之名为无余涅槃。是涅槃中无有诸有。证寂离相。云何已下执昔征今。次二之中皆先举昔有余之灭。后约结难。文中可知。第五难中先举昔偈。云何已下就之结难。前举偈中如佛言者如来昔因陀骠比丘宣说此偈。彼知僧事。为其慈地比丘尼谤遂入涅槃。有人犹疑不知其人实犯以不。佛为清之。故说此偈。今举征佛。于中初偈立喻显法。随相论之。假人为铁。究而穷之。真心为铁。铁外之火喻烦恼境。即铁之热喻烦恼性。赤色喻于烦恼之相。所观之理喻之于鍖。观解如槌。观理破结说之为打。烦恼不集名为星流。后更不续名散已灭。苦报永亡六道之中更无生处。以是义故莫知所在。得正合。得正解脱亦复如是。总以合之。已渡下别。已渡淫欲诸有淤泥合打星流。散已寻灭为清陀骠。偏言渡淫。得无动处不知所至。合后莫知所在言也。云何为常执昔征今。下佛答中先呵后释。呵中若人作如是难。名为邪难。对于向前假问之人而为呵责。迦叶汝亦不应已下兼诫迦叶。释中初先当问正解。明佛永断无常之法故得为常。诸佛所师所谓法下。辩明如来证常故常。当问解中释难不尽。前五句中但释初二及解第五。第三第四同初难故略而不释。释初难中句别有三。一明如来所断烦恼毕竟永尽。故非无常。言灭烦恼不名物者。不得名为无常之物。何以下释。先问后解。所断烦恼永毕竟故。不得名为无常物矣。二是故下结成常义。三是句下叹以显胜。所谓是此灭烦恼句。烦恼灭故不复驱驰生死往来。故云寂静。超过凡夫二乘近学。故无有上。释第二中亦有三句。与前不次。初明如来所断生死毕竟永尽。故非无常。灭尽诸相无有余者。谓灭三界生死诸相所断穷尽。故曰无余。前言毕竟。此云无余。言左右耳。二是句鲜白难以显胜。生死报亡由离惑染。故曰鲜白。前彰寂静。此云鲜白。亦左右言。三常住下结成常义。常住不退总明常也。所断生死更不重起。故常不退。下别显之。是故涅槃名曰常住。明涅槃常。是不退故涅槃常矣。如来亦尔。明法身常。常同涅槃。故云亦尔。释第五中文别有二。一解前喻明非无常。星流举偈。谓烦恼者被破烦恼。散已灭等牒举偈文。谓诸如来烦恼灭已合散已灭不在五趣。合向偈中莫知所在。二是故下结成常义。是佛惑灭不在五趣。故得为常。上来第一当问正解。明断无常故得为常。自下明佛证常故常。诸佛所师所谓法者举所证法。如来藏性成德所依故名佛师。是故如来恭敬供养明能证行。是佛师故如来敬养。佛本因中所修诸行内顺真性名为恭敬。熏真成德说为供养。以法常故诸佛亦常。证实成德。法性缘起成佛报果。法性常故报佛亦常。第二对中迦叶先难。就佛所释三句之中偏难后句。难辞有三一就热灭为难。若烦恼火灭明佛因亡。斯乃名彼即铁之热以之为火。非铁外火。约喻名法名烦恼火。如来亦灭明佛果灭。是故如来无常住处。结破佛常。二迸铁下就赤灭为难。先举前喻。如赤色灭喻佛现起烦恼因灭。赤色喻于烦恼之相。莫知所至喻佛报灭。下约显法。如来烦恼亦复如是。合赤色灭。灭无所至。还合向前莫知所至。三又如铁下双就热赤二灭设难。又如彼铁热与赤色灭已无有。举喻类法。如来亦下辩法同喻。如来亦尔灭已无常合前赤灭。烦恼火灭便入涅槃即是无常。合前热灭。下佛答之。以不重生释成常义。于中初先简凡异圣。所言铁者名诸凡夫。推喻属凡。何故须推。世间之铁冷热不恒。佛前取其少分为喻。惧人取其数冷数热难佛无常。故今推彼数冷数热不恒之铁以同凡夫。凡夫之人虽灭烦恼。灭已复生。故名无常。释凡同喻。如来不下辩圣异凡。以不重生故得名常。第三对中迦叶初先难破如来不重生义。如铁灭已还置火中赤色复生。辩喻类法。如来若尔应还生结。征佛同喻。下佛转喻释不重生成前常义。于中初先呵其难辞明非无常。何以故下明佛是常。先问后辩。如来是常总立常义。下广释成。于中初明自结永断故得为常。无量生下能断他结故得为常。自中初先转喻显常。如铁已下复喻解难。前中初喻次合后喻。此则是其说后喻也。彼彼燃木灭已有灰。立喻显法。燃木有灰喻有常体。灰不为木喻结不生故得为常。烦恼灭已便有涅槃。约喻显法。谓有真实常乐涅槃。如彼灰矣。为牢其义故。坏衣下更以多喻显成常义。下复就彼烧铁之喻释去其难。如铁冷已可使还热辩喻异法。良以彼铁少分似法。故前为喻。非为全同。故今彰异。如来不尔。彰法异喻。如来不尔总明其异。断烦恼等别明其异。断烦恼已毕竟清凉。已生惑亡烦恼炽火更不复生。当结不起。断他结中。初明无量众生如铁冷而复热。我以慧下明己能灭。如火烧木永更不生。上来第一问答广明如来身常。善哉已下第二领解佛言已下第三述成。于中初喻。圣王喻佛。素在后宫喻在阎浮。或时游观在后园者喻佛息化入大涅槃。王虽不在诸婇女中喻佛不在众生化中。亦不得言圣王命终喻佛常存。次合显法。如来亦尔。合前圣王素在后宫。虽不现于阎浮提界。超合不在诸婇女中。入涅槃者合游后园。不名无常合不命终。下重显之。出无量恼明其所离。入涅槃等彰其所得。于中初明得涅槃乐。游诸觉下得菩提乐。上来明佛法身体常。自下第二拂去迹疑。化迹滥真。故须拂遣。于中初先拂去形迹。二迦叶复言如来云何名常住下拂去言迹。拂形迹中迦叶先问。如佛言曰我已久渡烦恼大海。牒佛前言名前出于无量烦恼为久渡也。若佛已下执迹为难。若佛已渡何缘复共邪轮陀罗举实征迹。以是因缘当知未渡执迹疑实。唯愿已下请佛释通。下佛答之。先呵难辞。能建下释。释意如何。明昔纳妃生子之事。是大涅槃所起德用。非实烦恼。释相如何。泛举涅槃所起德用类以释之。大般涅槃能建大义总举类答。义犹用也。建犹起也。大般涅槃能起大用。用相非一。名建大义。下广辩之。于中初先敕听劝说诫莫生疑。下为说之。文别有四。一举菩萨住大涅槃能建大义仰愿如来。二我已久住是涅槃下。正就如来明建大义。三若有菩萨安住已下结前第一。四以是缘下就前第二结答上问。初中有二。一明所菩萨证实起犯。二菩萨所可示现已下以下况上明佛无欲。前中合有八复次文。初七别论。后一总结。道言菩萨住涅槃者。于大涅槃随分克证。故名为住。所住涅槃性是缘起作用之法。是故入中无心现化。三昧法力自然能现无障碍化。如如意珠无心分别自然能雨一切宝物。下举菩萨类佛可知。第二明佛能建义中。初明如来住大涅槃种种现化。于此三千大千界下广显化相。以是故下结用归体。广显化中初明如来阎浮现化。次类余方及三千界。下举二十五有之义指首楞严。何者是其二十五有。如下文说。欲界十四。谓四恶趣四天下人及六欲天。色界有七。谓四禅处中间梵王无想净居。无色有四。谓四空处。通前合为二十五有。何因举此指首楞严。明佛二十五有之中斯皆现化。不能具列。故指彼经。第三重结菩萨可知。以是缘下就前第二结答上问。以是如来住大涅槃起种种化。示现纳妃生子因缘。故汝不应言罗睺罗实是佛子。何以下释。久离烦恼常不变故。上来第一拂去形迹。自下第二拂去言迹。于中先拂尽灭言迹。迦叶复言我今定知如来世尊无所秘下。拂去昔日无常言迹。前中有三。一拂去灭迹明佛善有。二迦叶领解。三如来述可。前中迦叶先问起发。后佛答之。问中如来云何名常。呵佛说常。如佛言下难破佛常。如灯灭已无有方所。举佛昔言。如来亦尔灭无所有。推佛同喻。灭已无有说何为常。此难同上何劳更为。前者难佛。如来对问直解佛常。昔言未遣故此重问。又复向前难佛非常。佛答明常。迦叶是中难佛非有。佛答明有。与前意别。故复问之。下佛答中先明如来是有非无。言灯灭者是罗汉下。推灭属小释会昔言。前中有二。一明如来常而是有。二虽不俱下辩明如来有而是常。前中先呵。汝不应言灯灭无有如来亦尔。下为辩释。释中先喻。次合显法。下问迦叶。迦叶后答。喻中两句。第一依真起惑之喻。男女喻于起惑之人依真起惑。名燃灯时。如来藏性为妄所依。说与灯炉。真随妄转。随妄广狭故云大小。无明遍覆名满中油。依无明地生于四住。妄分别心如油起明。本存末随。故言油在其明犹存。二若油尽下是其灭惑显真之喻。若油尽已明亦俱尽。是灭惑喻。断无明地名油尽亡。四住随亡名明俱尽。显真之喻。文中略无。若具应言明虽灭尽灯炉犹存。喻中虽无。合中具有。下次合之。起惑之喻今略不合。但合灭惑显真之喻。其明灭者喻烦恼灭。合灭惑喻。文少不足。若具应言其油尽者喻无明灭。但昔教中唯说灯灭。不说油灭。故略不合。明虽灭下合显真喻。明虽灭尽灯炉犹在。举喻显法。如来亦尔烦恼虽灭法身常存。辩法同喻。法身常存宁同灯灭一向是无。反问反答文显可知。虽不俱下明有是常。迦叶初先执喻同法难佛无常。下佛答之。简法异喻明佛是常。先呵难词。下为辩释。释中初明法身体常。一切法下明佛报常。前中初言如世间器如来世尊无上法器。约喻显法。如来法身本为妄依。容受妄想。故名法器。是故前以灯炉为譬。而器无常非如来也。辩法异喻。异故是常。明报常中一切法中涅槃法常。举本显末。所谓性净涅槃法常。如来体之名为常者。名为报常。自下第二推灭属小释会昔言。彰昔所说灯灭涅槃是小非大。于中有四。一明罗汉所得涅槃同于灯灭。第二举彼阿那含人有障未尽显罗汉灭。三因言即释。阿那含人为不还义。第四举彼阿含有还显前不还。初言灯灭。即是罗汉所证涅槃。正会昔言以灭贪等释成灭义。第二段中阿那含者名曰有贪。以有贪故不同灯灭。举有显灭。阿那含人上二界中贪痴慢在。贪过重故所以偏说。是故我下对有彰灭。是阿那含有贪未尽。罗汉断故。我昔说之同于灯灭。说小隐大故云覆相。非大涅槃同于灯灭彰灭分齐。第三段中有三复次。解阿那含为不还义。于中初二就处辩释。非数数来。就欲界释。于欲界中不数数来。故名不还。又不还来二十五有。通就色界无色界释。阿那含人于彼二十五有之中。随所生处更不重生。故名不还。下一复次就报以释。更不受于臭虫身等。故名不还。第四段中两番举彼那含有还。显前不还。此名须陀斯陀含人以为那含。若更受身名为那含。不受身者名阿那含。显向后句有去来者名为那含。无去来者名阿那含。显前两句

上来第一拂去灭迹明佛。善有自下第二迦叶领解。领解如来无秘藏义说灭彰小。论有显大。故无秘藏。于中初明如来无藏。何以下释。如来昔日说小隐大故有密语。心无吝惜故无秘藏。如幻已下举世秘藏彰佛不同。下佛述赞。善哉赞也。如来无藏是述可也。何以下释。有九复次。一明如来言无隐覆故无秘藏。二心无悭吝故无秘藏。三法无缺少故无秘藏。四无所贪惜故无秘藏。五慈爱深重故无秘藏。六恶根永尽故无秘藏。七言无过失故无秘藏。八量化以宜故无秘藏。九法雨等润故无秘藏。初复次中先喻次合。下约愚智以辩是非。次二之中皆先立喻。后明佛无。第四门中先立藏喻。后明不同。如来不尔总明不同。不负世下别明不同。不负世者对前负债以显不同。佛本发心不欲许将世法授人。为是不负。虽负已下对畏债主隐不欲现以显不同。佛本发心许教众生出世之法。彼犹未得是故名负。心恒欲与故无秘藏。何以下释。第五门中先喻后合。第六第七二复次中。皆先立其秘藏之喻。后明佛无。第八量化以宜之中初明如来量宜授小故无秘藏。如彼长者子既大下随机授大故无秘藏。前中有四。一立喻显法。二反问迦叶。迦叶正答。三佛叹其言。四约之显法。初中长者喻佛如来。所教声闻名为一子。圣意愍念名常怜爱。如来以其大机未熟。悬委当佛教化开导。名将诣师欲令受学。虑彼赊晚名惧不速。摄之从己名寻将还。勤教学小名教半字。未授以大故言不教毗伽罗论。何以下释。第二反问迦叶答中有二问答。初就所教反问迦叶。迦叶正答。后就能教反问迦叶。迦叶正答。不也总答。何以下释。释中初明长者无秘。先问后解。者何已下明佛无藏。先问后释。释中初明妒吝是藏。下明佛无。第三叹中。善哉总叹。下述其言。第四约喻显法之中。初合教半。下合不教毗伽罗论。先合毗伽。以声闻下合力未堪。是故已下合不教诲。下次明其授大无藏。初反明藏。先喻后合。如来不下顺明不藏。初法。次喻。后合可知。第九法雨等润之中。初先立喻。夏月注雨喻佛等说。令农夫等喻明众生得益不同。非龙咎等喻佛无过。下合可知。迦叶复言我今定下拂去昔日无常言迹。迦叶初先领前问后以为起发。我今定知如来无藏是领前也。如佛说等是问后也。于中先牒如来上言直非不然。何以下释。先举昔偈。次举今常。下问云何。佛答之中先会昔言。我今为下辩释今常。前中我为声闻教半而说是偈。略举昔言。波斯匿下广明昔日起说所由。我为下结。辩今常中初先约人明说今常。若有人下诫舍无常。下明解脱。文别有五。一明涅槃为解脱处。二迦叶言何等名涅槃下。就处开出解脱之德。三是故解脱成无量下结叹显胜。第四迦叶领解。第五如来结劝修学。初中有二。一举昔偈请佛解释。欲于其中辩出涅槃为解脱处。二所言大者其性广下。就处辩释涅槃之相。前中先问。问中初先举偈总问。无所积聚。是八觉中少欲之行。未得不求于食知足。即知足行。已得节量。如鸟飞空迹不可得。是其第八不戏论行。鸟喻贤圣。空喻法性。证实离相难以相求。如鸟飞空迹不可寻。略举此三。中间寂静精进正念禅定智慧略而不举。此偈意趣后半为大涅槃解脱之处。是义云何请佛释之。谁得已下就人别问。下佛为释。于中初明善法积聚贤圣所有。僧有二下恶法积聚贤圣所无。前中初言夫积聚者名曰财宝。总明积聚。善法是其贤圣财宝。积有二下就人别分。先举次列。小乘善行生灭有为。大乘善行常故无为。下就人论。恶法积中文别有三。一辩二僧举数列名。小乘无常故名有为。大乘行常故曰无为。二佛就有为明无积等。先定其人。下就辩德。先明无积。初先正辩。若有说下非邪显正。次明知足。初先正辩。若有贪下举过显德。迹难寻者牒举偈文。谓近无上菩提道者。二乘所证渐近佛道。是人虽去无所至者。灭身归寂故无所至。三迦叶因前领解无为。于中但明无积难寻。知足不论。无积聚中句别有三。一举下况上。有为之僧尚无积聚。况无为僧。第二辩出无为僧体即是如来。三就如来释无积义。如来云何当有积聚。就佛自行明无积聚。不积世间资生之物。夫积聚下就佛外化以明无积。先明积过。吝法不说名为藏匿。是故已下对过辩无。所说无吝。云何名藏。以无藏匿名无积聚。人谓此言解上无藏。故判属前。一向非是。下次就佛辩迹难寻。先举偈文。释有四句。一直辩出难寻法体。所谓涅槃。二无日月下明难寻相。离一切相故不可寻。三彰涅槃是如来处。常存不变。欲就此处开解脱德。故说为处。四明佛趣入。以是涅槃是如来处。故今至此而般涅槃。上解昔偈辩出涅槃为解脱处。自下第二就处辩其涅槃之相。文别有三。一释向前大涅槃义。二彰此涅槃是解脱处。三于前文中有难解者问答重显。就初段中先解大义。三义释之。初言大者其性广博。以广释大。二如人下以常释大。但喻无合。与上文中所言大者名之为常。其义相似。三以胜释大。胜有二种。初言是人若住正法名人中胜。住正故胜。如我说下备德故胜。如我所说八大人觉。举余经中所说八觉。为一人下就人分别。为一人有成在一人。为多人有修在多人。若一人具八则为胜者就成显胜。一人是佛。佛备八德。故名为胜。胜故名大。次释涅槃。言涅槃者名无疮疣。自利以释。疮疣是漏。自无诸漏故名涅槃。譬如人下化他以释。先喻后合。喻中有二。一阎浮施化喻。如人喻彼阎浮众生。起惑切己名毒箭射。流转生死名多受苦。逢佛圣师名遇良医。佛教断惑名为拔箭。劝修道法名傅妙药。令出生死名为离苦。得大涅槃名受安乐。二余方现化喻。此方感尽余方现化名游城聚。有惑斯救。故言随有疮疣之处即往疗治。下次合之。先合初喻。如来亦尔为大医王合前良医。见阎浮提苦恼众生合如有人。被淫怒等合前箭射。受大苦切合多受苦。为说大乘合傅妙药。为拔毒箭令离苦等略而不合。疗治此下合其后喻。复至他方合游城等。诸有毒处合上随有疮疣之处。作佛为治合往其所为疗众苦。故名大般总以结之。自下第二彰此涅槃是解脱处。大般涅槃名解脱处。正辩其相。随有生处于中示现明体起用。用即是其解脱德也。得大涅槃能现此用。故名涅槃为解脱处。以是真下结用显体。寂而常用名甚深义。不同小乘名大涅槃。自下第三有难解者问答重显。显前令他无疮疣义。有两问答。初就喻为问。世医悉治一切疮不。佛答不定。后就法为难。先牒佛语。下就设难。若言治已。云何有未得涅槃者。若未悉得。云何上言疗治此已欲至他方。佛答不定。先举二人。次列其名。后就其人明治不治。除一阐下简去不治。就其所治结成涅槃无疮疣义。从偈至此明解脱处。自下第二开解脱德。于中有四。一就涅槃开解脱德。二迦叶言解脱为色为非色下明解脱体。三唯愿哀愍重垂广下彰解脱相。四迦叶言不生不灭为解脱下拂遣诠况。初中迦叶先问起发。何等涅槃征体起用。下佛答之。名为解脱。第二段中有二问答。迦叶初问所言解脱为色非色。亦应问言。是心非心。就色以辩。心则可知。故略不问。下佛答中对小辩大。或色非色开列二门。次显其相。二乘解脱唯是断结数灭无为。未得诸佛常住真色。又未得佛化用之色。故名非色。诸佛解脱真身常住。及随化缘现种种形。故名为色。随化所现即是诸佛共世间身。真身常住即是诸佛法门之身。是义云何。如海十相同体义分。佛亦如是。诸根相好皆遍法界同体义分。不如应化彼此别异。以同体故用眼为门。诸根相好及佛刹土莫不皆是。一眼中现。余亦如是。如华严云。三世一切劫。及与诸佛刹。诸根心心法。及与虚妄法。于一佛身中。一切悉显现。是故说辨菩提无量无有边。是故下结。如来为诸声闻已下会通昔言。诸佛解脱虽复是色。昔为声闻说为非色。第二迦叶就小征问。二乘解脱若非是色云何得住。下佛答之。答意如何。彰彼二乘所得解脱亦色非色。以是色故二乘得住。于中先喻。中有二。一明非想亦色非色。佛说非色。四空有色诸经大同。华严宣说菩萨鼻根闻无色界宫殿之香。阿含经中说舍利弗般涅槃时。色无色天空中泪下如春细雨。波阇波提般涅槃时。色无色天佛前侧立。此云亦色与彼相似。二如是下就人正辩。是佛境界非二乘知。下合显法。解脱亦尔亦色非色说为非色亦想非想说为非想。合上初句。问曰声闻缘觉解脱云何亦色。云何亦想。而复言非。释言。二乘入涅槃时事识根尘一切皆灭故说非色。及与非想妄识真识及其根尘一切皆在。故云亦色及与亦想。是义云何。二乘之人入涅槃时虽灭事识。妄心犹在。说为亦想。以心在故妄心所现妄想根尘亦在不亡。说为亦色。如睡未寤梦心所起根尘不灭。又二乘人入涅槃时真心不灭。名为亦想。二乘之实是如来藏。如来之藏是佛法身。是法身中具佛眼耳鼻舌等性。名为亦色。故经说言众生身中有如来眼如来耳等。以佛法身共众生性无别体故。故下文中说四谛实即是如来。声闻缘觉解脱之中具有此义。是故说为亦色非色亦想非想。如是义下合上后句。唯佛境界非二乘知

涅槃义记卷第二应永三年五月二十四日加修补书失字了　　　　　　　法印权大僧正　贤宝涅槃义记第三

        隋净影寺沙门释慧远述

自下第三辨解脱相。迦叶先请。唯愿重说。对前辨体说以为重。下佛先叹。后为辨释以义相从。于中有其九十四句。随别细分有一百九句。第二十二无逼切中别有七句。第二十三无动义中别有四句。第二十五希有义中有其二句。第二十六虚寂义中亦有两句。第三十甚深义中亦有二句。第五十一平等义中亦有两句。第六十七无迮狭中有其三句。余各为一。是故别分有一百九句。一一句中齐应有五。一列名。二解释。三结。四即如来。五难解者重复分别。然今文中多少不定。或有初无后。或有后无初。或有中间而无初后。就解释中或但法说。或兼喻况。喻有反顺。其顺喻者解脱亦尔。其反喻者解脱不尔。法喻相对。前却不定。或有初法次喻后合。或有先喻次法后喻。或有先法后喻。便罢。文相不定。今初句中先列其名。名离系缚。次释其相。两喻两合略无结文。次即如来为简向前二乘解脱故即如来。如下文中亦即涅槃虚空佛性决定菩提一切佛法。以彼类余。余皆同尔。不能烦广。故前诸句唯即如来。如春已下重复显之。先喻后合。余类可知。名断一切有为之法出生一切无漏善法者。是第八十九明离诸见。先列其名。断有为法明离邪见。出无漏法明具正见。次释其相。先解断漏。断塞诸道总明断漏。断诸外道所有邪见名断诸道。下别显之。若我有见无我空见非我无我非有无见。此说似真。以其定计不称法理。故须断之。唯断取着。不断我见。释前出生无漏善法。所谓佛性彰所不断。此言不足。若具应言名解佛性。性即真脱总以结之。下即如来名不空空。是第九十明异外道所得解脱。先列其名。外道解脱虚诳无实名为空空。真不同彼名不空空。次释其相。先解空空。言空空者无所有。释其空义。即是外道尼干解脱。就人指斥。而是尼干实无解脱。就人解空。真不如是明有异空。结即可知。名果不空。第九十一明非有无。先列其名。名中不足。若具应言名不空空。为简前门。单云不空。次释其相。释中初先约喻显法。彼瓶遇缘则有破下。简法异喻。前中有三。一立喻显法。水酒酪瓶举其喻体。下辨喻相。于中初就水酒等瓶明空不空。虽无水等是空义也。犹故得名为水等瓶不空义也。以有瓶体名为不空。非谓有其残水酒等名为不空。与上文中明虽灭尽灯炉犹存其义相似。如是瓶下明空不空。不可偏定。若言空下破他空义。若言定空则不得有瓶体色香味触等事。破其定空。若言不空复无水等。破定不空。二约喻显法。解脱亦尔。合前瓶体。下合喻相。不可说色及与非色。合前虽无水酒等时犹故得名水酒等瓶。不可说空及以不空。合前不可说空不空。若言空下合前若空则不得有色香味触若言不空而无水等。以是下结。三重法喻相对广辨。于中初先就法明空。空者谓无二十五有明无苦。果及诸烦恼明无惑因。无一切苦及一切相复明无果。以无二十五有果故则远众苦。亦离无常无我等相。故说以为无一切苦及一切相。言无一切有为行者明无业因。善恶二业名有为行。初一无字贯通诸句。如瓶无酪举喻以帖。下次就法以明不空。谓实善色常乐我净诸根相好名为善色。如瓶已下举喻以帖。是故解脱犹如彼瓶结法同喻。上来约喻以辨解脱。人谓解脱全同彼喻。故下辨异。彼瓶遇缘则有破坏明喻异法。解脱不尔。辨法异喻。结即可知。名曰离爱第九十二明离爱疑。名中略故但云离爱。初先列名。次释其相。先立反喻。下明不同。得大菩提更无所求所以离爱。于果决了所以无疑。下结即佛。重显可知。断诸有贪第九十三明其远离生死因果。先列其名。断有明离生死之果。断贪明离生死之因。次释其相。句别有六。前二略显。断一切相显前断有。谓断无常苦等诸相。断一切缚显前断贪。下四广显。断一切烦恼明断惑因。一切生死明断惑果。一切因缘明断业因。一切果报明断业果。初一断字贯通诸句。略无结辞。下即如来并即涅槃一切生下第九十四明离怖畏得受安乐。就此门中。初释。次结。后即佛等。有难解者下重分别。初中先法文少不足。若具应言一切众生怖畏生死故受三归以三归故得受安乐。次以喻显。鹿畏猎师喻生怖畏生死烦恼。既得免下喻受三归。得受安乐喻其所少。下合可知。乐即解脱总以结之。下以解脱即如来等。佛法无量。然今且以七门相即。无尽是其法性虚空决定是惠。良以此等同体义分。故得相即。此门既然。上亦应尔。略不具论。有难解者下重显之。有何难解。向前宣说受三归依似若是别。复言解脱即如来等似若是一。一异相反故须释之。又复前言以三归故则得安乐滥同受乐。故下显异。有二问答。前一问答释显三归一异之义。后一问答明乐非受。就初问下。若涅槃佛性决定如来是一义者。云何说三执一疑三。向前宣说七法相即。今且举四。此问不足。若具应言归依既别彼涅槃等云何即一。准答应有。且举一边。一边可知。佛答有三。一就三论一。二从有法名一已下就一辨三。三如来或时说一为三三为一下。双就一三叹以显深。前中初明一切众生以怖畏故求三归依。故有三别。以三归故证知佛性决定涅槃。所证同体故得为一。第二段中初先以理彰三是别。是故我下引说证别。前中初先泛明诸法名义一异。当法施名唯有二门。一名义俱一。二名义俱异。法有体用总别同异。就体就总就同施名。名义俱一。就用随别逐异施名。名义俱异。隐显互论具有四句。一名义俱一。二名义俱异。备如向辨。三名一义异。就体就总就同施名。摄义从诠说为名一。随用随别随异施名。摄诠从旨说为义异。四义一名异。翻前可知。今于四中且列两门。有法名一义异是第三门。有法名义俱异是第二门。次辨其相。解初门中。先牒。次释。佛等皆常。依常施名。摄旨从诠故曰名一。佛等义别。摄诠从旨名为义异。是名下结。解后门中。先牒。次释。佛法僧等义门各异。依之施名。名亦不同。故四俱异。佛名为觉。是其翻名。即是解义。法名不觉。非是翻名亦非解义。斯乃对佛简异之辞。僧名和合。翻名解义。涅槃名脱。是其解义。非是翻名。空名非善。简异之辞。非翻非释。法性虚空不同行善。故名非善。无碍简他亦是辨相。是为下结。下约前义彰其三归。是别非一。就下引说证别之中先举昔说。是故三归不得为一结成别义。前中初告波阇波提供养众僧即供三归。波阇波提是佛姨母。生七日母便命终。波阇乳养。佛后出家。波阇恋忆。手自织成金缕之[疊*毛]。待佛还宫拟用奉佛。佛后还国。波阇波提遂用奉献。佛时告曰。恩爱心施无大功德。当供养僧。若供众僧。即供三归。故今举之。波阇次问。后佛为解。以三义别。是故不一。前辨一义。次辨异义。自下第三双就一异结叹显深。如来或时说一为三。牒上后段佛性等一。就之宣说三归差别。说三为一牒上初段就三归依宣说佛性涅槃等一。如是之义是佛境等叹以显深。上来明前解脱之中三归依等一异之义。下次明前所得安乐是寂非受。迦叶先问如佛所说毕竟安乐名涅槃者是义云何。直请其相。请显寂乐。夫涅槃下难破受乐。下佛答之。句别有四。一对初请彰其涅槃唯是寂乐。二断一切下对向后难明其涅槃非是受乐。三若言下难破受乐成前第二。四是故下结前寂乐以为涅槃解脱之义。初中先喻。喻有四句。一自出生死喻。有人喻佛。佛昔因中起业烦恼名为食已。受苦心闷。求出三界断除结业名出欲吐。正能断除名得吐也。二现化随物喻。自出生死俯应随物名复回还。三假问显德喻。同行菩萨名为同伴。请问如来生死尽未名得差不。而复还来怪佛在苦。四假答显德喻。诸苦已尽名答已差。证寂永安名得安乐。下次合之。如来亦尔毕竟远离二十五有合上初句。永得已下合第四句身得安乐。第二段中断一切受名无受者五受斯断。如是无受名常乐者叹以显胜。问曰。下说灭无常色获得常色。受想行识亦复如是。云何说言佛无受乐。释言。受中有其二种。一受境界违顺等事。二证法相应摄受正法故名为受。今言无者无其初受。下言得者得其后受。两言不违。后二可知。从上唯愿重垂广来

第三大段明解脱相。自下第四拂去诠况。何故须拂。上来借喻拟况解脱。人谓解脱全问诸喻。故下拂之。于中有二。一明上来所立诸喻非喻为喻。二云何如来作二说下明喻非喻不得定说。前中有三。一明上喻非喻为喻。二真解脱者一切人天无能匹下明其非喻为喻所以。三如无比下类显非喻为喻之相。就初段中。先明非喻。如来有时以因缘下彰其为喻。明非喻中有四问答。初迦叶问不生不灭是解脱耶。佛答言是。第二迦叶执喻同法。若不生灭为解脱者。世间虚空亦无生灭应是解脱。佛答不然。三迦叶问何故不然。如来反问迦兰等声同乌鹊不。第四迦叶以理正答。如来赞叹。迦叶答中不也总答。下别显之。句别有四。初乌鹊声比命命等不可为比明下劣上。二迦叶言迦兰迦下明上遇下。于中迦叶先明过下。次责如来。无异葶下显佛不应。三佛与空下约喻显法。四迦兰迦声可喻佛下辨喻显法。迦兰喻佛。不喻乌鹊。彰其声妙。以声妙故用况解脱。不比虚空。佛叹可知。上来一段广明非喻。如来有时以因缘下明其为喻。所谓有时化他因缘引空喻晓。所况佛德故即如来。此初段竟。自下第二解释非喻为喻所以。真解脱者一切无过解前非喻。为化生下释前为喻。为化显前有因缘矣。自下第三类显非喻为喻之相。先举其类。言非喻者如无比物不可引喻。略举非喻。有因缘故可得引喻。略举为喻。如经中下即事指斥。下约显法。不可以喻喻真解脱明其非喻。为化生下明其为喻。以诸譬下明上诸喻悉皆是其非喻为喻。上来第一明前诸喻非喻为喻。自下第二明喻非喻不得定说。迦叶先问若当是喻一向言喻若当非喻一向言非云何如来作二种说。下佛答之。明法不定。故不定说。文别有四。初害佛喻。明佛法身非喻为喻不得定说。二害母喻。明佛报身非喻为喻不得定说。三以是因缘我说种种譬喻已下结前第二。乘言便故。四或有因缘亦可喻下结前第一。初中有四。一如来立喻。二反问迦叶。三迦叶正答。四如来赞叹。就立喻中。举佛法身不可得杀类明非喻。欲害得罪类显为喻。初言有人喻佛应身。内具四辨名执刀剑。怒意说真名以嗔心。欲以众喻况佛法身。说相逼真名害如来。法身平等不随相变故言如来和无嗔色。下次反问。是人当得坏如来身是其一问。成逆罪不复是二问。迦叶答中初辨喻相。后约显法。喻中初先对上初问明佛叵杀显成非喻。直以恶心对向后问明由恶心。故成无间显成为喻。前中初言不也总答。佛不可杀故言不也。何以故下释成叵杀。如来身界不可坏者对问辨释。身性名界。人身分齐亦名身界。法身离相故不可坏。者何已下转释不坏所以征问。佛所以身偏不可坏。以无身者明身离相故不可坏。唯法性下明身体寂故不可坏。是人已下结成不坏。答后问中。直以恶心成无间者化意违真名为恶心。成其譬喻言说之事名成无间。无间之义后别具论。下约显法。以是因缘引诸譬喻知实法者偏约后句明为喻也。以是恶心亦得成就无间因缘。佛引诸喻得令大众知佛真法。亦应约初明其非喻。略不明也。佛赞可知。第二段中文亦有四。一如来立喻。二反问迦叶。三迦叶正答。四如来赞叹。初中恶人喻佛应身。说相侵真故名恶人。欲以诸喻显示报身。喻相逼真名之为害。真为化本故名为母。化在三有名住野田。在诸相中名在[卄/積]下。报佛以其大悲愿力资化不绝名母送食。应身如来内缘真德名为见己。便起说意名生恶心。备具四辨名前磨刀。报身如来明鉴化意名母知己。从化随相名入[卄/積]中。应以利辨随其喻相。广说真德名绕[卄/積]斫。畅圣化心名斫己喜。念己说已名生杀想。真体离相名从[卄/積]出。安住实际名至家中。反问可知。迦叶答中先辨喻相。后约显法。喻中初言不可定说若说有母身应坏身若不坏云何言有。明其无罪显成非喻。若说无下明其有罪彰其为喻。以是缘下约喻显法。偏约后句明其有喻。初略不论。佛赞可知。自下第三结前第二。以是因缘我说种种喻真解脱结成有喻。绕[卄/積]遍斫名说种种。虽以无量阿僧祇下结成无喻。下结第一。或有因缘亦可为喻结成有喻。或有因缘不可喻者结成无喻。从上何等名涅槃来合为第二开解脱德。自下第三结叹显胜。于中有三。初二叹后解脱之德。是故解脱成就如是无量德者就法结叹。具前百德故曰无量。趣涅槃者涅槃如来亦有如是无量功德就人结叹。如来是其求涅槃人名趣涅槃者。证大涅槃成如来身是故名为涅槃如来。前辨解脱皆即如来是故。如来亦有如是无量功德。末后一句结前第一解脱之处。以有如是解脱德故名大涅槃。自下第四迦叶领解。我今始知如来至处为无有尽重领向前解脱之处。向前广辨解脱处中迦叶领解如是涅槃是如来处常不变易。故今重领。我今始知如来至处为无有尽。对昔不知名今为始。无尽犹前常住义也。处若无尽当知寿命亦无尽者领解脱德。法无尽故成人无尽。此即领上解脱德中如来无有生老病死。名命无尽。自下第五结叹劝学。善哉能护是叹辞也。叹前领解。若有欲下劝学辞也

长寿至此明其行体。自下第二辨行所依。于中初先正明所依。下说邪正离所不依。前中辨明四依菩萨为所依人。此即答上云何得广大为众作依止实非阿罗汉而与罗汉等。彼问如何云何得彼广大为众作依止人。虽未同于诸佛罗汉。化功同彼佛罗汉者我欲依止。故今答之明有四人能为众生作依止处如佛无异堪可依止。文中初先正明四人为所依处。如佛所说。依四法下对法会通。此亦即明行所依法。前中有二。一明四人德行相貌。二我今不依是四人下劝人依止教人供养。初中有四。一总举四人总叹其德。二别列四人总叹其德。三别牒四人别显其德。四总结四人总叹其德。就初段中先举四人。以此四人依经成德。又此经中之所宣说。故言是大涅槃经中有四种人。下叹其德。护法立法忆念正法是通法行。即是自利。身能匡护不令他人轻谤毁呰名护正法。如上广说。口能竖成名建正法。心思不忘名忆念法。能多已下是益人行。即是利他。能多利益出世法化。怜愍世等世间法化。怜愍世间是利他心。为世依下是利他行。人为物依。法能安乐。人天可化。故偏论之。亦可怜愍慈念三涂。为世依等近益人天。第二段中先列四人。何等征问。有人出等辨列其名。四依之义广如别章。今且释名。有人出世具烦恼性名第一者。所谓种性解行地人。仁王经中说种性上方为法师自前未能。故知非是种性已前。下文宣说供佛五恒方堪为依故非善趣。文中说之。具烦恼性非第八人明非地上。如来灭后现化益物名为出世。五住惑中无偏尽处名具烦恼。问曰。地持宣说种性具足二净。今以何故言具烦恼。解言。地持望于二乘故说二净。此对地上名具烦恼。须陀斯陀名第二者。须陀此方名为逆流。逆生死流。亦名抵债。抵三涂债。又亦名为修集无漏。位分何处。须陀有三。一者守果。初地满心。二者摄因。初地始心已去皆是。三者进向。上尽二地皆名须陀。合说前二为须陀洹。故地论中宣说初地以为见道。斯陀含者此名频来。于欲界地更来更生。亦名住薄。依如小乘。欲界修道九品惑中断六三在故云住薄。若依大乘。三界修惑皆能薄之。故地经言欲色有缚无明缚等皆悉微薄。位分何处。分别有三。一者守果。在第三地。故地经中宣说三地诸缚微薄。二者摄因。二地已下渐断修惑通名斯陀。三者进向。上尽七地。合此三种通名斯陀。何故此二合为一依。以此二人功用行同供佛解义过前劣后。所以合之。阿那含者此名不还。依如小乘。于欲界中更不受生故名不还。若依大乘。不还起于爱佛烦恼故名不还。位分何处。分别有三。一者守果。在第八地。爱佛烦恼此处断故。二者摄因。四地已上同名那含。修习顺忍向八地故。三者进向。上尽九地。合说后二为阿那含。以于此处同舍功用供佛解义过前劣后。所以为一。阿罗汉者此名无著。断有因故。亦名无生。尽苦果故。位分何处。分别有三。一者守果。在第十地。二者摄因。九地已上同名罗汉。三者进向。上尽金刚。合说后二为阿罗汉。以此同在究竟地故。理实佛是高美其人。故同佛称。此皆菩萨何故乃用声闻凡夫名字名之。此虽菩萨位分与彼小乘粗同。欲令未来所化凡夫二乘人等准小知大。故用名之。下叹德中偏叹利人。与前相似。通法不论。自下第二别牒别叹。先辨初依。于中初问。次辨。后结。非第八下对余辨异。辨中有四。初能奉等是自利行。奉戒离恶建法修善。二从佛已下是自利解。三转为已下是利他行。为说八觉令其进善。有犯教悔使其离恶。四善知下是利他解。善达菩萨权化之仪名知方便秘密之法。名凡总结。凡有内外。此是内凡。六道分段残报之中无偏尽处。故名内凡。下辨异中。非第八人对上辨异。何者第八而言非乎。准毗婆沙。名须陀洹以为第八。对见道前七方便故。故彼论中问言云何为八人。所谓信坚及与法坚。钝根之人入见谛道名为信坚。利名法坚。外国相传言更有八。一初发心人而未有行。二有相行。憎厌生死乐修善法。三无相行人。学观空理破离欣厌。见人行恶心无忿怒。见人修善亦不欣庆。四方便行人。虽见法空而常随有起诸善行。此四在于善趣位中。五者习种。六者性种。七者解行。八者圣种。初依地前未同圣种故非第八。第八人者不名凡夫彰后异前。不名凡夫简异初依。名为菩萨当相以论。不名为佛别异于后。第二依中。初牒。次释。后总结之。未得已下对余辨异。就广释中句别有六。前五修善。后一离恶。就前五中初四自利。后一利他。就自利中。若得正法是自分始。闻法名得。受持正法是自分终。念诵名持。从佛闻法是胜进始。如其闻下是胜进终。此等自利。转下利他。离恶可知。是名总结。下辨异中。未得第二第三住处对后辨异。于四果中须陀未得斯陀住处。斯陀未得那含住处。名为菩萨已得授记对前显异。不同前凡故名菩萨。交能八相成道度人故为佛记。依如地持。地前菩萨亦为佛记。但初地上能于十方广受多记。故偏说之。第三依中。初牒。次辨。后总结之。辨中有三。一辨其行相。二阿那含者义何谓下释其名义。三住返下重叹其德。就初段中先彰离过。若说无我有是处下明摄对治。前离过中先列九过。悉无是处总结彰离。就九过中。前之八句行德不纯。说我一句智解不明。就前八句中。初之三句恶业不除。中间两句烦恼未尽。后之三句果报未净。业中初言诽谤法者谤佛教法。答言听下违佛行法。此二背正。受外一句彰其学邪。就烦恼中。客尘烦恼是五住起。后起名客。坌污称尘。诸旧烦恼是五住地先成名旧。苦中初言若藏舍利法身未显。舍利名身。如来藏性是佛法身。苦覆名藏。外病所恼四大所侵此之二句报身未净。说我一句理解不明。悉无是处总结彰离。下摄治中。若说无我翻前说我。说着世法翻受外典。若说大乘翻谤正法言听畜等。若所受身八万户虫亦无是处翻前舍利。永离淫欲翻前客尘。乃至梦中不失不净翻离诸旧。临终生畏亦无是处翻为外病之所恼害四大所侵。就释名中先问起发。是人不还如上诸过对问辨释。下重叹中。往返周旋是利他德。趣寂名往。随有称返。名菩萨下是自利德。名为菩萨已得授记明其因成。不久得下彰其果熟。是名总结。第四依中。初牒。次辨。后总结之。辨中有三。一叹其德。约就小乘罗汉叹之。断诸烦恼明我生尽。舍于重担明不受后有。苦是重担。不受名舍。逮得己利是梵行立。所作已辨是所作辨。二彰其位分。三重叹德。得自在智是自利德。随人所乐种种悉现是利他德。此二自分。如所庄严是自利德。谓具功德智慧庄严欲成佛道即能得成是利他德。所谓八相巧便度物。此二胜进。能成如是名阿罗汉。牒以总结。自下第四总以结叹。是名四人是总结也。下总叹之。出现于世能多利等正叹其德。人天最等寄对显胜。人天中最对下彰出。如如来对上明等。问曰。菩萨安能等佛化下众生功力齐故。此则答上实非罗汉与罗汉等。自下第二劝人依止教人供养。先劝依止以摄智慧。汝应供养如是人下教人供养以摄功德。前中有二。一教人捡验。二我涅槃后当有无量百千众生诽谤已下劝人依止。下供养中亦有此二。至时当辨。初教验中先教捡验。二是大涅槃不可消下叹经殊胜。令人修习降魔依正。就初验中有二问答。前一问答正教捡验。后一问答出所教人。就初问中。迦叶白佛我今不依是四种人总明不依。何以下释。先问。后解。明有诸魔滥同四人故不可依。于中有三。一举佛昔言明魔能乱正。二魔等尚下以昔类今明四人有滥。三坐卧下显其滥相彰己不依。初中如来何因教彼瞿师降魔。如来昔曾为瞿师罗说四真谛。彼悟初果。如来去后降魔来惑乱。化作佛身告言长者。我向与汝说法不尽。于四谛外更有一种神我谛在。长者推寻都无此理。遂往请佛。佛即教之。若魔作佛。汝当捡校知己降伏。第二可知。第三段中坐卧空等明其形滥。以是缘下彰己不依。或有所说明其口滥。不能禀下彰己不依。不能禀受不受四人所说之法。亦无敬念而作依者。不依四人以为师首。下佛答之。先述其言。于我生疑尚不应受况如是等四依之人。次劝简择。是故应当善分别知。正劝简择。有魔乱正故劝分别。善不善等出其所知。四依是善。魔化不善。依真可作。依魔叵作。如是作下明知利益。下教捡验。先喻后合。喻中有三。一魔来乱正喻。魔如偷狗。四依之形名为人舍。伺人不觉魔盗为之说名夜入。二佛教捡验喻。声闻人中觉大乘者名为婢使。觉知是魔即应驱骂令复本形名疾出去。彼若不去神咒怖之名夺汝命。三偷狗下魔去不还喻。合中但合后之两句。汝等从今亦应如是降伏波旬合上婢使若觉驱骂。汝今不应作如是像合疾出去。若故作者五系系汝合不出者当断汝命。咒能缚其手足及头名之五系。此合第二。魔闻已下合第三句。先合后帖。自下第二出所教人。迦叶先问。于中初就上人设难。上品之人自能降魔近于涅槃不假四依。如来不应教其捡验。如是四人所可言下就下人设难。下品之人不能捡验四依所说未必可信。如来不应劝依四人。前中如佛为瞿师说。举佛昔事。若能如是降伏魔者重复牒之。亦可得近大涅槃者明能自知。瞿师是其须陀洹人。望大涅槃定能趣向。以之为近。以理测寻未敢专决。故云亦可。如来何必说是四人为依处者明不假依。良以此人自能降伏近涅槃故。如来未必宣说四人以为依处。不说在佛未敢自决。故名何必。就彼下人设难之中文少不足。若具应言凡夫之人不能捡验四人所说未必可信云何如来劝人依止。下佛答之。先述其言。如我所说非为不尔。下出所教。但教声闻缘觉降魔。不教菩萨。何等声闻缘觉须教从初发意乃至无学。问曰。瞿师是初果人。已能降魔不为魔惑。云何无学犹须佛教。释言。望彼小乘之法。苦忍已上见法分明。魔不能惑。不假佛教。望大乘法。乃至无学犹为魔乱。故须佛教。故下阿难虽得初果犹为六万四千亿魔之所惑乱。文中初别。后总结之。别中四对。第一肉眼佛眼相对。声闻肉眼故须佛教。菩萨佛眼不假佛教。二如有人下勇怯相对。声闻怯故佛教降魔。菩萨勇健不假佛教。三如有龙下明其有力无力相对。声闻无力故须佛教。菩萨自有降魔之力不假佛也。四声闻缘觉于烦恼下明其有畏无畏相对。二乘之人怖畏烦恼故须佛教。菩萨无畏不假佛教。就初对中。我为声闻有肉眼说不为学大。正辨所教。谁是学大。所谓善趣五阶菩萨。彼自见法魔不能惑。是故不须教其降魔。声闻之人虽有已下彰其二人眼别不同。成其须教不须教义。声闻之人虽有天眼见诸色像。于大乘法不能都见故名肉眼。学大乘者虽有肉眼不见远色。照见佛乘名为佛眼。何以下释。以大乘经名为佛乘。此乘最上。菩萨见之故名佛眼。第二对中初明声闻怯故须教。如彼健人不从他下明菩萨勇故不须教。前中先喻。喻别有四。一佛教声闻习学降魔喻。二或时有人素无已下魔来乱正喻。三汝于是下正教降魔。四如是辈下魔退不还喻。初中两句。一声闻依佛喻。有人喻佛。佛具无畏称曰勇健。十力摧邪说为威猛。声闻畏魔名为怯者。凭佛免怖名来依附。二佛教降魔喻。常教怯者。总明教也。下别教之。别中初教降魔之德。后教降心。前教德中修定持弓。习慧执箭。起通槊道。四辨长钩。神咒罥索下教心中。虽如履刃不应生怖劝舍怖心。对邪危崄故如履刃。当视已下教生勇心。先教轻他。后教自勇第二魔来乱正喻中。有人喻魔。素无胆勇诈作健相喻乱正心。内情虚怯名无胆勇。外现无畏名诈健相。执持弓等喻乱正德。邪定为弓。邪辨如刀。邪智邪通名种种杖以自严也。来至阵下明乱正相。来至身乱。大唤口乱。口宣大乘名为大唤。后二可知。合中依上次第合之。先合初段。如来亦尔合如有人勇健威猛。告诸声闻不应畏魔合勇健人常教怯者乃至应自作勇健想。若魔波旬化作佛下合第二段。问曰。是中教验四依。何故乃云化作佛身。盖乃举上类下故尔。又亦举昔类今故尔。化作佛身尚须不畏。何况四依。汝当精下合第三段。时魔已下合第四段。就明菩萨不须教中。文别有三。一人能降魔故不须教。二阿竭陀下法力灭邪故不须教。前中初喻。学大下合。得闻下释。于中初明智慧深明闻经不怖故须教。何以故下殖福久远于魔不畏故不须教。后明法力灭邪之中。初先立喻。人喻菩萨。药喻大乘。不畏蛇等明人不畏。亦能消下彰法能灭。合中大乘合阿竭陀。不畏魔等合上不畏一切蛇等。亦能降下合上能消一切毒等。第三段中先喻后合。喻中粗二。细分为四。粗分二者。一声闻从邪喻。二有善咒下菩萨摧邪喻。细分四者。一魔行邪化喻。二是故一切师子已下声闻从邪喻。三有善咒下菩萨摧邪喻。四如是等兽见善咒下所化从正喻。释初段中。有龙喻魔。忌他胜己名妒。好坏他善称弊。欲败他善名害人时。身业惑乱名为眼视。口言惑乱说为气嘘。第二段中初喻从魔。后喻从损。是故一切乃至皆畏喻从魔化。师子虎等喻于声闻。为魔惑乱伏从魔化。故言皆畏。是等恶下喻从魔损。或闻声者闻其口言。或见形者见其身化。或触身者同其心行。情近名触。无不丧者丧其慧命。第三段中有善咒者喻于菩萨。以咒力者大乘法力。能令龙等皆悉调善任为乘者明降魔能化。彼诸魔及声闻人同归大乘名为调善。堪为受法传化弟子名任御乘。第四段中如是等兽见彼善咒即便调者。魔及二乘见彼菩萨善说大乘即便归也。合中不次。先合第二。却合第一。次合第三。后合第四。声闻缘觉亦复如是。合第二中师子虎等。见魔皆怖合第二中皆生怖畏。闻声见形触身丧命略而不合。而魔已下却合初段。而魔不怖合初段中有龙妒弊。犹行魔业合初段中欲害人时眼视气嘘。学大乘下合第三段。学大如是合第三中有善咒者。见诸声闻怖畏事于大不信。明化所为。非正合前。先以方便降伏魔下合第三中能令龙等皆悉调善任为御乘。于中先以神通方便降伏诸魔。后为说法。然上喻中龙及诸兽皆悉调善任为御乘。今此但合龙为御乘。余略不合。声闻缘觉见调魔下合第四段。于中初明见人生怖。于此大下于法生信。作是言下离于不信。第四对中。初明二乘怖畏烦恼故须佛教。后明菩萨不畏烦恼故佛不教。学大乘者有如是力叹大异小。上来四对广辨所教。以是下结。以前所辨四对因缘。但教二乘。不教菩萨。上来第一教人验依。自下第二叹经殊胜令人习学降魔依正。是大涅槃甚奇甚特当法正叹。若有闻下寄人显胜。于中两句。前明信希。后明信益。上来第一教人捡验。自下第二明其四依弘护利益劝人依止。于中有三。一明四人于正法时弘护利益。二迦叶白佛如来灭后四十年下明其四人于像法时弘护利益。三以是因缘我说四人为世依下结明四人能为物依。前中初明四依弘护。是经流处即是金刚。下还叹经胜令人爱乐凭依修学。初中如来先彰未来多人谤经明须四依。次迦叶请于佛灭后久近便谤问废灭时。有何等下问弘护人。下佛答中先答初问。如有王下答其后问。前中初言我涅槃后四十年中广行流布明法兴时。何因缘故此时偏兴。佛灭度后迦叶持法经二十年。阿难持法亦二十年。此之二人亲睹佛化。行法似佛。故令法兴。迦叶向前直问废时。佛今为欲对兴辨废。故明兴时。然后乃当隐没地者明法废时。当处不行故言没地。如甘蔗下辨明向前兴废所由。人学故兴。不学故废。先喻后合。喻中有四。初甘蔗等喻明法体。二随有处下寄人显胜。三或有人下明废所由。由人弃大学小故废。弃大学小名食粟米。习读世典名及稗子。取劣为胜故言第一。学小由昔名受报故。四若是福下明兴所由。由人弃小学大故兴。耳初不闻粟稗之名喻不闻小。唯食粳粮喻纯学大。合中依前次第合之。涅槃如是合上初段。钝根薄福不乐闻者反合第二。然上喻中举彼福人贪乐爱着显经殊胜。合中举其钝根薄福不乐听闻显经深重。言之左右。如彼薄福增恶已下合第三段。先牒后合。或有众生其心甘下合第四段。先合后帖

自下第二答其后问明弘护人。先喻后合。喻中有三。一边地众生弃大学小喻。二有异王下四依弘化喻。三其王得下所化众生得法修行喻。就初段中。王喻边地匡化之人。各有统领故说为王。身居边地名在深山崄难之处。有涅槃经名有甘蔗粳粮石蜜。有而难具。辨得兼失。是故云虽。以其难得贪借积聚不敢啖食喻不学大。既在边地全部叵备名为难得。如北天竺。唯有六卷。不具全部。为名为利书写此经名贪积聚。不能依法自学教他名不敢食。惧其有尽唯食粟稗喻明学小。以其残缺辨义不周。恐问难通名惧有尽。专学小乘名食粟稗。第二段中有异国王喻四依人。闻怜笑者怜之弃大笑其学小。车载稻粮而送与者。音声语言以之为车。说经授彼名载稻粮而送与之。亦可纸素竹帛为车抄经授彼名载与之。第三段中其王得者边地化主自闻经法。即便分张举国食者劝他同习。民既食下所化之人荷恩喜赞。顺教奉修名为食已。庆沾法利所以皆喜。领荷四依弘化之恩。是故咸言因彼王故得希有食。合中但合后之两段。初段在于第二闻之怜笑中合。更无别合。合第二中四人如是合异国王。为法大将释为王义。依化不并故言四中或有一人见合闻也。下明所见。举初段中所况之事为所见耳。见于他方无量菩萨合深山王。现虽学小宿有大授故名菩萨。虽学大乘合上虽有甘蔗稻等。自书写下合前贪惜积聚之言。自书令他合积聚也。为利养等合贪惜也。虽书经卷专期信施名为利养。悕求美赞说为称誉。唯增博知不为起行名为了法。合他附己名为依止。用之贸小名博余经。不能广为他人宣说合惧有尽不敢啖食。故持是经送至彼者合载稻粮而送与之。令发已下明送所为。发心起愿。安住兴行。菩萨得下合第三段。菩萨得已合王得已。即便广说合前分张。令无量众得受法味合举国食。食已皆喜略而不合。皆悉是此一菩萨下合作是言因彼王故得希有食。先法后帖。法中是此一菩萨力合国王也。是向四中或一人也。所未闻经悉令得闻合得希食。喻帖可知。上来第一广明四人正法时中弘护利益。自下第二叹经殊胜。句别有四。前二叹胜令人信乐。后二学益使人修习。就前二中。是经流处即是金刚寄处显胜。处胜难坏故如金刚。是中诸人亦如金刚寄人显胜。义同前释。就后二中初明学益。若有生下明不学损。于学益中。若听不退成因益也。所愿悉得得果益也。汝等应下结劝受持。不学损中先明不听。甚可怜愍失大损也。何以下释。第二像时弘护益中文别有二。一明四依于像法时弘护利益。二有恶比丘闻我已下显经殊胜令人爱乐凭依习学。就初段中有二问答。前一问答明兴废时。迦叶先问如来灭后四十年中是经广流过是没者牒上所辨。久近还出。对灭问兴。下佛答之。若我正法余八十年前四十年是经复当雨法雨者。释迦正法有五百年。五百年中后八十年中前四十年。此经重兴于阎浮提雨大法雨。良以法通有时故尔。下一问答对兴辨废。就彼废时明依弘化。迦叶先问。问有二句。一举法灭时。二谁能已下问弘护人。前举灭中准下有六。一正法灭时。二正戒毁时。三非法盛时。四增破戒时。五一切圣人隐不现时。六畜一切不净物时。今但有五。后一略无。六中前四就法辨时。正法灭者经法灭时。正戒毁者律法毁时。言非法者下文名为非法盛时。对前法灭。言增长者下文名为增长破戒。对前毁戒。后之两句就人辨时。无如法众生。下文名为一切圣人隐不现时。此明无善。畜不净物明其有恶。就下请问弘护人中。谁能听等正问其人。唯愿已下请佛宣说。令菩萨下明说利益。准依地持。此以护法为增上缘。故得不退菩提之心。下佛答之。先叹。后辨。人别有十。前九在于善趣已上乃至法云。后一是其善趣已前初发心人。以善趣上于佛灭后交能护法。是以先论。初发心者久乃方堪。故回后说。就前九中初五是其善趣菩萨。后四是其四依之人。就善趣中先辨初人。句别有二。一护法行。因熙连佛所发菩提心。熙连是其恒河眷属。于此河中一沙一佛。于尔许佛所发菩提心方能护法行。二护法行恶世不谤。第二人中句别有三。一护法行因。一恒佛所发菩提心。二护法行。不谤同前加以爱乐。三明所不能。不能广说。第三人中句别亦三。一护法行因。二恒发心。二护法行。恶世不谤。信乐同前加能受持。三明所不能。不能广说。第四人中句亦有三。一护法行因。三恒发心。二护法行。余行如上加能广说。三明所不能。不能解义。第五人中亦有三句。一护法行因。四恒发心。二护法行。余行同前加能解义。十六分中得其一分。云何十六。于此经中所有义味摄为十六。如说一慈为十六分。一斤以为十六两等。三明所不能。虽能说法亦不具足。此五同在善趣位中。下四在于习种已上。就初依中句别有三。一护法因。五恒佛所发菩提心。二弘法行。恶世不谤受持广说。三得义多少。十六分中得其八分。第二依中亦有三句。前二如上。三得义多少于前残余八分之中更得其半。通前十二。第三依中句亦有三。前二如上。三得义多少于前残余四分之中更得其半。通前十四。第四依中初先正辨。善知如来所有法下重复结之。前中亦三。一护法因。八恒发心。二护法行。于中四对自利利他。一自能不谤读诵书写亦教他书。二自能听受亦劝他人。三为怜众生自供养经亦劝他人。四自敬重读诵礼拜亦劝他为。此之四对合为第二。三得义多少具足十六。理实此人于前残余二分之中更得其半。通前十五。末后一分唯佛所证。以此学穷于佛所观证照分明。故云具解尽其义味。所谓已下出其所解。谓佛常住显时之果。众生有性隐时之因。上来正辨。下复结之。善知如来所有法藏结前第三。供养已下结前第一。建立已下结前第二。问曰。四依初劣后胜。何故得义初多后少。释云。粗义浮浅易知故初得多。细义难精故后得少。又复粗者随诠相别少为多分。细义就实。阶降相微多为少分。分数虽少。其义实广。问曰。若言粗义易知初处得多。细义难精后得少者。何故经言初地得百二地得千。如是转多。解言。辨义泛有两门。一就摄义。从诠门中辨得多少。二就舍诠证实门中明得多少。从诠门中分别有四。一约一诠始终别论。初得多义。后时得少。从诠之义具显文中。初得闻持成就之处依文具解。故初得多。后设重思委审而已。无多异见故后得少。故此经中初依之人得八分义。第二依人更得四分。乃至第四但得两分。二约一诠以终摄始。初时得少后时得多故。此经中初依但得八分之义。乃至第四得十六分。三约多诠始终别论。初得义少闻教少故。终得义多闻教多故。故第十地能受诸佛云雨说法。依其所闻亦知多义。四约多诠以终摄始。初得少义。后时得多。理在易知。就其舍诠证实门中别分有二。一约就地位始终别论。初时得少。封教心多见理昧故。终时得多。以能舍诠见理明故。二以终摄始。初少后多。理在可知。地经所说是其舍诠证实之义。故后得多。不同在斯。上来明其善趣已上菩萨护法。下次明其初心护法。句别有三。一明现在初发心者当能护法。二是故下劝人识知为励初心故劝知之。三何以下释。自下第二叹经殊胜。于中举彼信谤损益以显经胜。文别有四。一明其谤。二明其信。三明谤损。四彰信益。谤中初明诸恶比丘闻佛涅槃内心不愁。今日已下发言唱怏。先总唱快。后出快事。如是下结。第二信中先劝忆持。下正明信。于中初明具德众生能自信持。其余生下明其信者能化益他。有乐为说正明化他。其人闻下明他德益。他闻灭罪是其益也。第三损中文别有四。一明现损。二命终下明其当损。三若临终下重明现损。四如是之人不至善下复明当损。第四益中差别有三。一明闻经久信有益。二如有人出家已下明始信有益。三或有生下明微信有益。久信之益在于地上。始信之益在于地前种性解行。微信之益善趣已前。久信益中初先明其自信有益。若我已下化他有益。自信益中初明信者经力庄身人皆乐见。国王已下经力严口。有所言说悉皆敬信。化他益中先劝传说。若我声闻弟子之中举所劝人。此实菩萨传佛教法故名声闻。如法华说我等今者真是声闻以佛道声令一切闻如是等也。欲行希事标其所求名修大乘。为行第一希有之事当广说大正劝传说。譬如已下明说有益。能令闻者除灭罪障。先喻后合。第二始信有益之中先喻后合。喻中如人地前人也。出家剃发喻始发心归信大乘。舍离邪谤名出剃发。虽服袈裟喻明依教书写读诵。未受戒下喻未有行。未受十戒喻未修习十地之行。尚自未受沙弥十戒。何况具戒。具戒喻佛。或有长者来请众僧寄对显胜。喻有众生作请菩萨而欲供养。未受戒者即与大众俱共受请。喻始信者高参出世大菩萨数。虽未已下牒以结之。合中若有发心始学合如有人出家剃发。书写读诵合服袈裟。未阶十住合未受得沙弥十戒。已堕十数合有长者来请众僧未受戒者即与大众俱共受请乃至堕数。第三微信有益之中或有众生是佛弟子或非弟子标举其人。善趣菩萨内有信心名为弟子。常没无信名非弟子。若因贪怖听受是经乃至一偈闻已不谤明其微信。当知是人已近菩提彰其有益。上怜种性名近菩提。上来两段广明四人弘护利益。自下第三结明四人为世间依。以是因缘我说四人为世依者。以是四人像正二时弘法因缘。我说为依。如是下释。以无邪谤故说为依。是故下结。上来第一劝人依止以摄智慧。自下第二劝人供养以生功德。于中有二。一直劝供养。二众僧之中有四人下教其捡验。与前相似。然上文中先教捡验。后劝依止。今此文中先劝供养。后教捡验。文之左右。前中有三。一总劝供养。二别教供养。三从偈后长行已下有难解者问答会通。初总可知。第二别中迦叶先请。我当云何识知是人闻所供人。我当云何而为供养问供养仪。下佛先以长行略教。后偈广教。略中若有建立法人应从启请答其初问。当舍身等答其后问。广中如我于是经说总标说处。下显说相。初一偈半教敬而畏。后一偈半教重而爱。前中初半明所供人答上初问。后之一偈明供养仪答上后问。先法后喻。后偈半中初半还明所供养人答上初问。后偈还明供养之仪仪答上后问。先法后喻。第三问答会通之中有两问答。前一问答明其四人合可供养。后一问答彰其四人本戒具在成前合供。就初问中。如佛所说供养师长正应如是领前所解。领前偈中若老应供恭敬礼拜。今有疑下问所不解。问上解中若少应供恭敬礼拜。于中初言有疑愿说举疑总问。若有长下列疑别问。别中先作三句审问。然出家下举佛今昔二时之言请佛会通。如佛言曰持戒比丘亦有犯下存昔非今令佛解释。于初段中初先老少相对作问。第二持犯。第三道俗。第二段中先举昔言。又如佛下举佛今语。如是二下双牒二言请佛会通。就举昔中。对上三问还有三句。然出家人不敬在家对前第三明佛旧仪。然佛法中年少已下对前第一明佛旧仪。于中先辨。以是下释。是故下结。如佛言下对上第二明佛旧仪。此举昔言。从此已下举佛今时所说偈辞。下双牒之请佛决通。如是二句是牒前也。昔为一句。今为一句。其义云何正请决通。将非虚妄征以起答。昔今若是言说是虚。今言若是昔说是虚。二处未定及为疑责。故曰将非。道言将非明已是虚。第三存昔非今之中。偏就持犯存昔征今。老少道俗略而不说。于中两句。前一弘经明持戒人不合敬犯。如佛言曰持戒比丘亦有所犯举佛旧言。佛昔宣说敬犯得罪故言亦犯。何故如来作如是说以昔征今敬犯得罪。何故今说有知法者一切供养恭敬礼拜不简持犯。下一受经明犯戒人唯合治罚不合供养。世尊亦于经中说言听治破戒举佛旧言。如是所说其义未了以昔征今。破戒之人理合治故。今时所说有知法者。一切供养不简持犯。其义未了。下佛答中文别有三。一就所教人而为会通。二如我上说下就所供人以会其言。三以是因缘我亦不为声闻已下总以结会。就初段中。我为菩萨不为声闻。即是会通今昔两言。昔为声闻说小敬大犯敬持戒俗人敬道。今为菩萨故说知法一切皆敬。问曰。何故前教声闻降魔凭依不教菩萨。此为菩萨不为声闻。解云。此等举之左右。前者就本说为声闻。今以习大名为菩萨。第二段中初明四人实持非犯理合供养。是故我昔覆相说下明其四人实长非幼。故合供养是道非俗。初中兼辨更不别论。前中初言如我上说指前总会。如佛前说像正二时四依弘化。故合供养。正法灭下别以会之。于中初法次喻后合。法中有四。一明未来邪兴正灭为弘护时。二是四人下明其四人和光护法。三如是四人为护法下彰其四人是持非犯。四明其人合可供养。四中前三文义俱有。后之一段义有文无。文虽不说。准下喻合理必须有。就初段中正法灭者经法灭时。毁正戒者律法毁时。增长破戒时对前毁戒。非法盛时对前法灭。此之四句约法辨时。圣人不现无善人时。受畜一切有恶人时。此之二句就人辨时。第二段中初明四依出现于世。见比丘下同事摄物。虽见已下明为护法见犯不举。就初段中。依化不并故云四中。一人出世为师匡化。故须出家。此即对前迦叶所问明道非俗。故合礼敬。同事摄中。初见所化比丘非法各各受等明其无行。净不净下彰其无解。净与不净一切不知不知理法。是律非律亦复不识不识教法。是人为下同事摄取。为摄向前诸恶比丘与之同事。犹如日光与尘和合名共和光。不同尘下明实常异。不同尘者明其行异。形聚心乖如光异尘名不同尘。自所行处及佛行处善能别知明其解异。顺起所修名自行处。行非通道名佛行处。皆能知也。第三见犯默不举中初默不举。何以下释。是故下结。上来第二明其四人和光护法。如是四人为护法故不名破戒。是第三段明实不犯。第四合供。文略不辨。喻中有四。一邪兴正灭喻。喻上初段。二尔时有一婆罗门下四依弘化喻。喻前第二。三是时童子虽为是事犹不失下自行无犯喻。喻前第三。四其余居士婆罗门等闻所作下合可供养喻。喻上第四所少一段。初中有五。一化主迁灭喻。二有旃陀罗下邪兴废正喻。三治未久下正众离坏喻。四栴陀罗王知国人下邪徒壅正喻。五复七日下患机感圣喻。初中如王喻佛如来。众生感尽名为遇病。圣化还灭说为崩亡。善趣菩萨当绍佛化名为储君。化德未成说为雅小。未堪遥化名未绍继。第二句中诸恶比丘名栴陀罗。口具邪辨名丰财宝。亦可此等广积资产名丰财宝。故上说其受畜一切不净物等。以其豪富人皆辅从名多眷属。贵势党援名以强力。待正衰废名伺虚弱。身为众主名篡王位。第三句中邪化不遥正便离背名治未久。国人已下正明众坏。正众有三谓下中上。下品之流睹恶不忍身归异所。故言国人远投他国。中品之类形聚心乖。故言在者乃至不欲眼见是王。上品之人见恶能忍形无异昔名不离土。先辨。后喻。一众分三名正离坏。第四句中彼恶比丘闻正违背名知国人逃叛者众。使其恶党为作留碍名遣栴陀守逻诸道。第五句中别复有四。一患机感圣喻。二始行不从喻。三不从有损喻。四从之有益喻。初中感圣各有期限故云七日。机发招圣名为击鼓。感圣显彰名为唱令。仰感四人为己匠首。是故义言请婆罗门。有能为我作灌顶师。师能以法灌其心顶名灌顶师。化善归彼名半国封而为爵赏。亦可徒众后必共匡名以半国为爵赏也。第二始行不从喻中。诸婆罗门悉无来者明身不从。各作言下明口不从。第三不从有损喻中损事显彰名作是言。始行之流守正不从名无一人为我师者。败正同邪。故言要令诸婆罗门与栴陀罗共住止等。共住止宿明其身同。同其事业明其行同。第四同化有益喻中半国不虚两释同前。大涅槃经所诠常法终必同修。名咒所致不死之药当共分食。第二四依弘化喻中文别有二。一四依从邪喻。二尔时童子语其王下破邪通正喻。前中五句。一内备化德喻。二现化随物喻。三化称物机喻。四始行嗔嫌喻。五化善师己喻。亦名徒众共匡喻。就初句中诸佛净行名婆罗门。依从化生名婆罗门子。依化不并是故言一。法身充美名在弱冠。持戒无犯名修净行。大悲垂接名长发相。博通圣教名善咒术。第二句中化赴物机名至王所。化现物情义言百王。随人所求皆能俯应名王所敕我悉能为。第三句中化称物情名王欢喜。物情爱乐名受童子作灌顶师。第四句中诸婆罗门闻皆生嗔内心嗔嫌。责此已下口言呵责。呵正同邪。是故责言汝婆罗门云何乃作栴陀罗师。第五句中化善师彼名分半国与是童子。亦可统众与之共匡名分半国与童子也。同化日久名共治国经历多年。上来从邪。自下第二破邪通正。于中有四。一通正喻。二尔时童子以余杂下是摧邪喻。三尔时童子立本储君还为王下是立正喻。四尔时童子经理是下是遣邪喻。前中八句。初之五句摄正归己。后之三句以正化彼。前中初句怨彼疏碍化显物心名为语王。亦可口言告示名语。我舍家法来作王师教王咒术彰己益彼明己先来舍正从邪。化授小法名舍家法。来作王师教王咒术而今大王犹不见亲怨彼疏己。大乘未同习名不见亲。二彼闻怪闻。怪闻所怨故言云何不亲汝耶。三申己所怨。过佛所证常住之法名为先王不死之药。彼未同修名不共食。四王言善下推化四依。闻说喜从故唱善哉。彰己昔来未体化意名实不知。大乘法化推归菩萨名愿持去。五是时下摄正归己。摄法从己名取还家。上来一段摄正归己。自下三句以正化彼。初请大臣而共食者化其弟子。弟子患轻所以先化。以法摄受名为请臣。自行大乘劝彼同修名共食之。二弟子劝师以理晓示名共自王。叹依有法故言快哉大师有是不死药也。三师闻乐受同劝悟解名为知己。怨不早闻。故言云何独与诸臣服食甘露而不见分。上来第一喻明通正。自下第二喻明摧邪。依先为说责罪之法名杂毒药。使彼听受名为与服。彼恶比丘闻为服己忽便生愧故言须臾。法行于心名为药发。心生悔愧名为闷乱。知己弊下退舍高意名为躄地。悔愧情深故无觉知犹如死人。自下第三喻明立正。于中初先立正代邪合彼善趣。立阶菩萨匡绍佛化名立储君还以为王。复本正化故云还也。作是言下呵邪劝正。初先呵邪。正法之座理非破戒。恶人处之故言御座法不应令栴陀罗升。破戒恶人而为众主自古未有。故言昔来未曾闻见栴陀罗为王。恶人匡众义无斯理。故言栴陀治国理民无有是处。下明劝正匡绍佛化菩萨所宜。故言汝今应绍先王如法治国。自下第四喻明遣邪。尔时童子经理是已牒前生后。经理废邪立正事已。复以解药与栴陀者。忏罪之法名为解药。授之令忏名与栴陀。除罪心喜说为醒悟。彼犯重罪。虽复忏竟犹须摈遣令远清众。名驱出竟。自下第三喻明四依自行无犯。是行童子虽为是者。虽为向前同邪之事。从邪通正辨得兼失。故名虽也。自行无犯名犹不失婆罗门法。自下第四喻明四依合可供养。始行菩萨名余居士。婆罗门等睹其巧化名闻所作。嗟其独绝名叹未有。赞言善下出其所叹。下合有四。与前不次。先合第一。护法已下合前第二。尔时菩萨若见已下超合第四明合供养。若有人见护法人下却合第三明实无犯。就初段中我涅槃后。合前国王遇病崩亡储君稚小未任绍等。第二段中护法菩萨亦复如是。合上有一婆罗门子年在弱冠修持净行长发相等。以方便力与破戒僧同其事业。合往王所乃至共治经历多年。余略不合。第三段中文别有四。一劝供养。二以是缘下结会上言。三如彼下举喻以帖。四善哉下约喻显法。就初段中尔时菩萨举所劝人。此乃名彼能供之人以为菩萨。声闻人中学大乘者是能供人。若见有人虽多犯者举所供人。即往已下正劝供养。恭敬礼拜明身供养。四事已下明财供养。财供有三。一自有奉上。二自无求与。三为是下明为供故得畜八种不净之物。于中四句。一明得畜八不净物。何等为八。如彼善生优婆塞经具列其名。一畜田宅。二种殖根栽。三贮聚稻粟居监求利。四畜奴婢人民。五畜养群畜。六畜金银钱宝。七畜象牙金银刻镂诸宝大床绵褥[毯-炎+瞿]氀。八畜一切铜钱釜镬。畜此八种能污净戒故名不净。二何以下释。三尔时下明畜无罪。四何以下释。上来劝供。自下第二结会上言。以是缘者以是四依摧邪立正通法因缘。我此经中说是二偈令诸菩萨供养法者。后二可知。此第三竟。第四自行无犯之中句别有四。一举谤得罪彰其无犯。二护法下明实无犯成谤得罪。三有比丘下举犯显持。四菩萨下明持异犯。先明无犯。何以下释。从上如我先说至此。合为初段。明其四人是持非犯故令供养。自下第二明其四人是长非幼故令供养。是彼四人实是久行为化始行。故我经中覆相说言。若少应供理实长宿。前就所教而为会通。此就所供而为会通。以是缘下第三结会。前两段中就初以结。以是声闻不知四依权化因缘。我今不为声闻说偈。菩萨知故我为说偈。就会通中有二问答。前一问答明其四人合可供养。下一问答明四依人本戒具在成前应供。良以菩萨本受行违通法之戒。今时所为称当本戒故得具在。文中迦叶先问起发。如是菩萨于戒极缓以为一句牒举前事。同恶犯戒名为极缓。本戒在不为第二句正为征问。下佛先呵。何以下释。先问。后解。解中有二。一对向后句明戒具在。二于乘缓下对向前句明戒不缓。前中初明自行清净故戒具在。如堤塘下令他戒净故戒具在。若有清净持戒已下结明戒在。自行净中。本所受戒如本不失明专护持。设有已下明犯已悔。令他净中先喻后合。就前喻中初先反明不治有损。遮水之阜名为堤塘。喻于众法众法损坏名穿有孔。水喻众僧。僧行缺减名为淋漏。何以下释。若有已下顺明持益。四依为人秉法为治僧行无损名水不出。就下合中先合治益。菩萨亦尔合向有人。虽与彼戒同其僧事所有戒律不如堤塘穿穴淋漏合水不出。下次合初不治之损。言何以故征前起后。何故戒律不如堤塘。若无已下举后显前反以释之。若无清净持戒之人合初句中无人治故。僧则损下合初句中提塘有孔水则淋漏。第三结中。若有清净持戒之人牒举四依。即能已下结明戒在。下对初句明戒不缓。句别有三。一泛立道理。于乘缓者乃名为缓于戒缓者不名为缓。不能和光以通大乘名于乘缓。视法贳闲故名为缓。又违菩萨大乘正戒故名为缓。破戒通法名于戒缓。为法心急故不名缓。又顺菩萨大乘正戒故不名缓。二明菩萨于乘不缓。即得名为于戒不缓。为法毁戒名于大乘心不懈慢。本受戒时要期如是。称当大戒故名本戒。名本戒故于戒不缓。三为护法下辨明其人。以法灭罪成戒不缓。为护法故以大乘水而自洗浴。故得无罪。所弘大乘能除罪垢。故名为水。护法灭罪名自洗浴。是大乘水自洗浴故虽破不缓。上劝供养。自下第二教其捡验。前已验竟。何劳重验。释言。前者魔化为依邪来乱正故教捡验。今此四依亦同破戒以正滥邪故复须验。迦叶先请。如来次教。迦叶下复领解赞叹。请中初言众僧之中有四种人。法说明滥。内熟外生。外熟内生。内外俱生。内外俱熟。是四种人如庵罗果喻说明滥。破戒持戒云何可识请佛教示。下佛教中。因大涅槃则易可知总教验法。云何因下别教验法。先问后辨。泛论验法验说必依三藏广教能定是非。验行必须加以四观。共住久处智慧观察是其四也。共住久处验其身行。智慧观察验其心行。身有难知易觉之别。其易觉者共住即知。共住不练加以久处。心中亦有难易之别。其易识者慧验即知。若慧不了加以观察。准教验心名为智慧。以理测寻说为观察。自下文中教以四观捡验其行。于中三喻。初田夫喻。教其共住久处捡验。第二林喻。教以智慧。第三药喻。教以观察。初中先喻。喻中初至名为净田喻明共住。众僧如田能生福故。殖福之人如似田夫。供僧生福如种稻谷。僧中恶行如似[禾*秀]稗。简恶供善故名芸除。粗瞻似好名肉眼观。名为净田至其成下喻明久处。似谷之[禾*秀]似稻之稗不可别故至成方异。所况如是。微恶难识加以久处方知其别。下次合之。先合初段。如是八事能污染僧合前[禾*秀]稗。畜八不净名为八事。如草秽田名污染僧。若能除却合上芸除。以肉眼观即知净者合肉眼观名为净田。若有持下合其后段至成各异。持戒破戒不作恶时难下分别反明未熟难可别异。若恶彰下正合成熟草谷各异。若恶彰露则易可知合草异谷。如[禾*秀]以下举喻以帖。僧中亦尔合谷异草。僧如净田故云亦尔。若离不净明其离过。八不净物能有损害名毒蛇法。是名已下结叹显胜。应为已下明合供养。非肉眼下明唯久处方能识知。智慧验中先喻后合。喻中有四。一邪正交参喻。二其果熟下无智滥传喻。三凡愚已下愚人不别喻。四有智下智人能别喻。初中迦罗喻破戒僧。破戒者饶名树众多。镇头喻于四依之人。依化不并是故云一。依化同邪名果相似不可分别。第二无智滥传喻中。依及邪人名随己解。起说教人名果熟时。有一女者喻滥传人。女有多义。是中唯邪无智为喻。邪正并纳名皆拾取。邪多正少故言镇头才有一分迦罗十分。邪正滥传名女不识。在众宣唱名诣市卖。第三句中凡愚小儿喻滥受人。小儿无智故取为喻。不识同前名复不别。弃正取邪名买迦罗。以受邪法坠堕三恶名啖命终。第四句中有智人辈喻能别人。知彼愚人受邪有损名闻是事。推得所从故言何处。持是果来答其闻处名示方所。智者知彼邪多正少。故言是方多有迦罗唯一镇头。弃邪不受名笑舍去。合中但合第一第三及与第四。不合第二。合初段中。大众之中入不净法亦复如是合迦罗林。此文略少。若具应言受畜八种不净法人亦复如是。于是众中多有受畜。如是八法合树众多。唯一持戒不受不净合唯一树名镇头迦。知畜非法。然与同事不相舍离合果相似。如彼林下举喻以帖。此初段竟。次合第二三愚人不别。有优婆塞合愚小儿。见是诸人多有非法并不恭敬反合不别买迦罗果啖己命终谓不敬养是四依人。喻中彰其通取之遇。合中明其并舍之失。皆是不别。举之左右。下合第四智人能别。于中四句。一教审问八不净物佛听畜不。二彼若言听更教审问。如是之人得共布萨羯磨以不。三彼若言得复教受经以验其说。如是问已皆言八事如来悉听举彼邪答。下教捡验。祇洹比丘或言金银佛所听畜举昔邪言。或言不听举昔正语。有言听者牒前邪人。是不听者牒前正人。不与共等明正摈邪。不与共住说戒自恣明法不同。乃至不共一河饮等明事不同。汝等云何言佛听畜以昔征今。四教其呵劝。佛天中天虽复受之汝等众僧亦不应畜对上初答劝自不受。佛为利他故得受之。众僧自为故不应畜。若有受下对上后答明有受者不应共同。先劝不同。若共说下明同有损。先法后喻。观察验中初先立喻。次合。后劝。喻中准合具应有三。一邪正交参喻。二愚人不别喻。三智人能别喻。今此文中但有前二。略无第三。就初段中城市喻众。有卖药人喻说法者。有妙甘药出于雪山喻说正法出涅槃经。亦卖杂药喻说邪法。邪言顺情名为味甘。邪说滥真故曰相似。第二愚人不别喻中诸人欲买然不识者始时不别。至卖药下中间不别。初问次答。是人下与。与其邪法名以杂药。叹非为是故言此是雪山甘药。时卖下取闇昧之心不达邪正。故言肉眼不能善别。闻说听受名买持去。复作言下终时不别取非为是。故言我得雪山甘药。合中有二。先合初段。若声闻众合前城市。乃至四依亦名声闻。四依出世现为声闻化众生故。有假名僧合城市中卖毒药人。实无僧德假与僧名。名假名僧。有真实僧合卖雪山妙药之人。四依之人实有僧德名真实僧。和合僧者合味相似。邪正交参名和合僧。更无别人。若持戒下合前第二明愚不别。先合后帖。谁是持下是第三段。合上所少明智能别。谁持谁破就行分别。谁真谁假就人分别。此举所知。有天眼者乃能分别彰其能知。谓有三乘净天眼者乃能知耳。劝中三句。一明未来有破戒人不应给施礼拜供养。二有受畜不净物者亦不应施礼拜供养。三重戒劝有破戒者不应以被袈裟因缘恭敬礼拜。破戒过重故偏举之。自下第三领解赞叹。善哉叹辞。余言领解。说真我受法说领解。如金刚等喻说领解。上来对问正明人依。自下第二对昔会通。昔法今人二言相异故须会之。亦即明其行所依法。迦叶先问。问中先举昔所说法非四种人对人征问。前中如说。当依四法总举昔言。何等下别。如是下结。下佛为会。于中应先解四依义。如别章说。文中有二。第一辨法即人以会。今所论法即四人故。依今法者亦依四人。昔所辨法异四人故。依今人者不依昔法。第二简法异人以会。人法异故。人为肉眼。法为慧眼。前中两番。一从体起用以辨四依。二从复次依义已下据果寻因以辨四依。就初番中初辨后结。辨中初先明其依法。法是诸佛大涅槃体。故先辨之。次明依义。义谓法身解脱般若一切种德。依体有德故次论之。次明依智。智谓诸佛一切种智。依德起于阿含智用。故次辨之。第四明其依了义经。经谓诸佛大乘教法。依智起说故次明之。初依法中文别有四。一正明依法不依于人。二如上所说四种人下简真异伪。明向所说不依人者不依邪人。非谓不依四依人也。三依法者即法性下明其依人不依于法。谓依向前即法之人不依向前即人之法。四若人破戒为利益下简伪异真。明向依人依于真实即法之人。非谓依于破戒之人。就初段中先明依法。句别有四。一出法体谓大涅槃。二一切下明大涅槃即于法性。一切佛法犹前涅槃。法性是其无始法性。显本法性以成涅槃。故即法性为简对治。断结涅槃故即法性。三明法性即于如来。显法成人故得即之。为简小乘所证法性故即如来。又为明佛同法可依故即如来。四明佛即常。如来是佛即法性故。故常不变。为简如来无常化身故须说常。若复言下明不依人。声闻缘觉言佛无常不见法性。不见性故不应依止。第二简真异伪之中初明四人即法可依。若有人能了知已下。举劣况胜明四可依。谓举善趣五阶菩萨以况四人。前中初言如上所说。四人出世应当依止正明可依。何以下释。于中先征。昔说依法不依于人。今以何故言人可依。下释有二。一明其人能解深义故可依止。二如是四人即如来下能解密教故可依止。前中初言善解如来微密藏者知前涅槃。能知如来常不变等知前佛常。先顺后反。前有四句。然今且对最初及后以说知也。下知教中初明四人即名如来。何以下释。先征后解。能解密语明解同佛。及能说者明说同佛。以此同佛故名如来。举劣况中先举其劣。若有人者善趣位中五阶人也。能知如来深密藏者知前涅槃。及知如来常不变等知前佛常。先顺后反下牒况胜。如是之人尚可依止何况四人。第三依人不依法中文有三对。一定上人法。前依法者即是法性。不依人者即是声闻。二用前法即所依人。谓法性者即是如来。并用前人即所证法。谓声闻者即是有为。小乘之法无常流转故曰有为。三明向前所即人法有其可依不可依义。如来常住是故可依。有为无常故不可依。第四简伪异真之中。若人破戒明其无行。为利养故说佛无常明其无解。如是之人不应依止。此义决了故名定义。此明向前所依人者依于如来不依如是破戒之人。就明依义不依语中。先举。后释。初明依义。先辩。后结。辩中有六。前三即是涅槃三事。义名觉了是其波若。波若观照故名觉了。觉了义者名不羸劣是其解脱。障累斯尽故不羸劣。言不羸劣名满足者是其法身。法身圆备名曰满足。后三是其三宝功德。满足义者名如来常是其佛宝。如来常者即是法常是其法宝。法常即是僧是其僧宝。是名下结。何等已下明不依语。初问次辩。辩中有三。一世俗诸论绮饰文辞不可依止二如佛说下。虚妄邪经诈称佛说不可依止。亦可如佛于余经中宣说世俗无量邪经不可依止。三又唱下谤佛之言不可依止。如是可结。就明依智不依识中先举后释。释中有四。初言智者即是如来明依佛智。二若有下明其不依声闻之识。三若知如来即法身下依菩萨智。四若见如来方便身下明其不依凡夫之识。于中初明不依于识。若复有下明人及说皆不可依。此句与前第二何别。前彰迷真。此明惑应。依了经中先举后辩。辩中明其小乘不了故不可依。大乘了义所以可依。文有七对。前六明其了不了义。后之一对明其可依不可依义。前六对中初二就因明了不了。前解后行。次一就果。次一就因。后二就果。果中前一约就菩提。后约涅槃。亦可六中前二就因。次一就果。次一就教。后二就义。第七对中初明小乘不了叵依。声闻乘法则不应依。正明不依。何以下释。先征后解。解中四句。一明小乘权而不了。先法后喻。二声闻乘者如初耕下明不应依。三如是名为不了义也。结前第一。四是故不应依声闻乘结前第二。下次明其大乘可依。句别有四。初大乘法则应依者正明可依。二何以下明大了义成前应依。先征后解。明佛为度诸众生故以方便力善说大乘穷深决了是故应依。三是故应依结前第一。四是名了义结前第二。如是四下总以结之。第二番中初明依义。义谓果德。第二依法。法谓法性。第三依智。智谓僧行。第四依经。经谓教法。四中前二就果说依。后二就因。义是果体是以先明。果依法成。故次辨法。智是因体是以先明。因由法成故后辩经。又复前果由因而成。故须明智。前法必藉教诠方显故须论经。文中初二一处合论。先明依义。次明依法。第三明其不依于人。第四彰其不依于语。义中准前具亦应六。今但举四。法身解脱波若如来。略无法僧。初言复次义名质直是其法身。身无邪曲故曰质直。直名光明。是其波若。慧无闇障故名光明。明名不劣即是解脱。名曰如来是其佛宝。下重显之。明名智慧辨波若体。直名常住彰法身义。常以身住不随时变故曰质直。次明依法。如来常者名为依法总以标举。下别显之。常与无边当相论法。不变名常。义多体广故曰无边。不可思下对情辩法。初明非有而亦可见。彰法非无。前非有中不可思议明离心相。不可执缚明离色相。体实不无所以可见。若有说言不可见者所不应依明不依人。是故下结。若以妙语宣说无常所不应依明不依语。妙尚叵依何况粗鄙。是故下结。第三依中先明依智。初举次辩。众僧是常无为不变是其证智。不畜不净是其教智。是故已下结明应依。下亦明其不依于识。不依识者总以标举。次辩其相。若有说言识作识受无和合僧举其邪识。执实谤假所以是邪。何以下释。和名无有无所有者则无有常。何处有僧。是故已下结成不依。依了义中先明依了。后明不了。就依了中初明义了。名知足等行法中了。亦于如来随宜所说不生执着。言佛亦是无常苦等义法中了。是名下结。若有能下明依了义。依前二了名为能住。如来等中所依殊胜。名为已得住第一义。是故下结。下次明其不依不了。先举后释。释中初先就义法中明不了经不可依止。若有人言如来怜下约就行法明不了经不可依止。前中初先广辩不了。后结不依。明不了中文别有四。一举昔日不了义经。如经说者如昔小乘经中所说。一切烧者。昔说三毒烧诸众生故名为烧。如下文说。亦可昔说无常之火烧诸世间故名为烧。宣说诸法斯皆彼烧故云一切。无常苦等类亦同尔。是名下结。以说一切言无简别故名不了。二何以下释不了义。言何以故征前起后。一切烧等何故不了。不能解了如是义故对以释之。依止生心不能解向烧等诸义局在有为故名不了。三令诸下明不了损。令堕阿鼻正明其损。令他依之乃至谤佛无常苦等成谤方等故堕阿鼻。所以下释。于中先问所以今堕。以取著者对问释之。闻说一切无常烧等决定坚执言佛亦然。故曰取着。四一切烧者谓如来下辩不了相。先辩后结。文相可知。不应依者结成不依。下约行法明不了经。不可依中初先反举了义可依以显不了。若有说言时非时下翻对前了正明不了。前中四句。一就人语明了义经。二结下依。三若有戒下泛就教法明了义经。四结可依。初中若言如来怜愍善知时宜说轻为重说重为轻略明了义。时别有四。如下具辩。于此时中若有檀越。丰非护法不为净施。受畜一切不净之物佛说为重。翻此名轻。下广显之。于中有四。一观弟子有诸檀越。重物即遮。无则听畜。二虽无檀越。丰时即遮。俭时听畜。三虽俭时不为护法。如来则遮。为护听畜。四虽护法不依净施。如来则遮。净施听畜。于此四中如来所遮名为说重。如来所听名为说轻。如是四法所应依止结明可依。就下约教明了义中若有戒等不违四者不违前四。亦应依止结明可依。就下正明不了义中句亦有四。一就人语以明不了。有时非时翻上第二。俭名有时。不俭非时。有护不护翻前第三。余之两句略而不翻。道言如来悉听受畜不净之物。故名不了。二如是言下结明不依。三若有戒下就其教法以明不了。四如是下结明非依。名彼三藏以为三分。上来辩法即人以会。自下简法异人以会。于中初先明人异法。二法者已下辩法异人。前中初言我为肉眼不为慧眼正明异法。以肉眼者不识法故为说人依。是故下结。是肉眼者不识法故。我今为之说人四依。就后辩法异人之中。辩法体状彰彼肉眼不能照见。唯为慧眼。前两番中就初以别。后略不举。声闻人中学大乘者名为肉眼。一切菩萨名为慧眼

下明邪正。答上问中云何知魔为众留难。佛说魔说云何别知。何故辩此。释有三义。一为明四人摧邪通正能为物依。二为明众生须依所以。故经说言应依四人有四魔故。三欲令人识邪不从离所不依。文中有三。一因迦叶请略举四魔。二因迦叶请广辨四魔。三因迦叶领解如来述赞。初中如上四人应依问前起后。下佛答之。如我所说应当依止正答前问。何以下释。以有四魔惑乱众生。是故必须依仗四依。何等已下辩出四魔。先问后辩。余处多说烦恼阴死及与天魔而为四种。是中唯就天魔说四。四相云何。一义分别。魔及弟子相对为二。所说经律复以为二。合为四种。四中前二是其魔人。后二魔法。举人答上。云何知魔为众留难。举法答上。佛说魔说云何别知。又更分别。四种皆悉就人以说。说经魔一。说律魔二。受经魔三。受律魔四。第二广中迦叶先问。如佛所说有四种魔牒佛前言。下就作问。于中准答。问少不足。应有三问。一问诸魔以何等形坏乱正法。二问魔说及佛所说云何可别。三问随魔随佛教者云何可知。三中初一问其魔师。次一问法。后问弟子。又复初一问其形滥。中问说滥。后问受滥。然今文中但有后二。略无初句。准答必须下佛答之。先对向前所少一问。魔坏法时作是言下对向文中所有两问。就初段中我般涅槃七百岁后明坏法时。是魔波旬举坏法人。渐坏我法。正明坏法。譬如已下明坏法相。先喻后合。二中初总次别后结。就后段中初广后结。广中十对。一就佛下生以辩邪正。二就如来现行七步以明正邪。三就天神敬奉之事以辩邪正。四就如来娉妻之事以辩邪正。五就制戒以辩邪正。六就如来种种技能以辩邪正。七大小相对以辩邪正。八就佛身以明邪正。九就戒行持犯之事以辩邪正。第十约就内外道法以明邪正。十中前四成道前事。次一是其成道后事。次一通明一化之事。后四还明成道后事。十中皆先明说邪正对向初问。后辩受人对向后问。就初对中先辩魔说。文别有三。一说如来因爱受生。二明生已不为世敬。三说如来唯修布施苦行成佛不修余德。次明佛说但翻初句。明佛应生非因爱欲。第二对中说佛初生现行七步叵信为邪。说佛现行可信为正。第三对中说佛初生入天祠中天神不敬以之为邪。敬事为正。第四对中说佛在家贪心娉妻实受欲乐以之为邪。说佛应作以之为正。第五对中说佛听畜不净之物以之为邪。言佛制断名之为正。第六对中说佛不具种种技能以之为邪。于中有六。一说如来为供天神故入天寺。所以入下举正显邪。若言不下非邪显正。若言如来为调天人故入天寺为不尔者。比言乖理名无是处。二说如来不能入于外道诸论知其威仪文章伎艺。三说如来不能和合仆使斗诤。四说如来不为男女王臣所敬。五说如来不知和合一切诸药。于中初先明其不知。次明不知故名如来。后明若知则堕邪见。六说如来唯能处中不能具足种种巧便随顺世间。下说如来具种种德名之为正。亦有六句。一明如来为菩萨时为调众生示入天寺翻前第一。二明如来外学法中出家修道知其威仪文章伎艺翻前第二。三明如来能和斗诤翻上第三。四明如来为世钦敬翻前第四。五亦能示下明佛随世亦能示现和合诸药而非邪见翻上第五。六为度下明佛为度诸众生故种种方便随顺世法不唯处中翻前第六。第七对中执小非大名之为邪。知大外小说以为正。邪中有二。一执小非大。二是人复言如是经律我当受下学小舍大。初中复二。一执小律非于大律。二如来先说九部法下偏执小经非于大经。律中五句。一举佛昔制。如来昔于小乘律中宣说五篇轻重之罪及偷兰遮。其性皆重故今举之。同招大苦故言皆重。二我等律下举小属己。三我久忍下彰己信受嫌他不信。四我当下执小舍大。小乘戒法名为己律。大乘戒法名为汝律。故今说言我当云何自舍己律就汝律耶。五汝所有下推大为邪。故言汝律是魔所说。经中有三。一明魔人执小非大。二未来之世当有已下佛呵显过。三我又说下明己说大成彼邪谬。初中有六。一举九部证无方等。二举如来无量小经证无方等。三如其有下推方等经为调达说。四如是等下推为魔说。先推后释。五如是言下推他经有道己经无。六我经律下妄引佛说证是为非。此初段竟。未来之世当有如是诸恶比丘。是第二段佛呵显过。第三段中别有三句。一佛自彰己过九部经说有方等。二若有人下明正者之得。三若有说下明谤者之失。先明其谤。后结得罪。上来第一执小非大。自下第二学小舍大。如是经律我当受持。正明学小。何以下释。知足少欲因中之道。断除烦恼因中之灭。智慧是其果中之道。涅槃是其果中之灭。此前四种通名善法。小乘经律与此为本名善法因。以善因故我今受持。如是说者非我弟子呵以显过。次辩其正。若有说言如来为度说方等经真我弟子正显其正。若有不受方等经下呵邪显正。如是经律是佛所说结明前正。若不如是是魔所说结明上邪。下明受人。第八对中说佛不为无量德成名之为邪。于中初明如来不为无量德成。唯得空法。宣说以下明说无我不顺世间。是故假言无量德成。如是下结。说佛具为无量德成名之为正。先辩后结。下明受人。第九对中约就持犯以明邪正。文别有四。一就无犯以辩邪正。二复有说言无波罗夷下就有犯义以辩邪正。三迦叶白佛如上所说一切众生有佛性下问答重显无犯中义。四犯突吉忉利天上八百万下重显向前有犯中义。就初段中先辩邪正。后显受人。辩邪正中无犯说犯名之为邪。无犯复复说为无犯以之为正。此二文中言有左右。前明邪中偏说小乘知足之人以为无犯。说此无犯以为有犯故名为邪。后明正中偏说大乘正见之人以为无犯。说此无犯以为无犯故名为正。理实齐通。就初邪中先明无犯。若说是人得罪已下对之辩邪。前中有四。一略明无犯。二何以下释。三广明无犯。四何以下释。就初略中或有比丘实不毁犯波罗夷罪正明无犯。如下文说有诸比丘少欲知足住空闲处。人谓是圣礼拜赞叹比丘不受名实不犯。众人已下明邪见人谓此比丘实犯重罪。如是已下如来以理彰其无犯。第二释中初先征问。我以何故道其无犯。下对释之。于中举犯以显无犯。我常说言四波罗夷若犯一者犹如折石正举犯过。若有自说得过人下辩其犯相。何以故下释显犯相。如是人下结成犯过。谓退出世圣人之法。第三广明无犯之中文别有五。一明比丘少欲知足住空闲处。二明王与大臣谓之是圣。三比丘闻下比丘不受。四王与大臣转谓是圣。五结成无犯。初段可知。第二段中初念其人现得罗汉。后叹其人当得菩提。第三段中文别复三。一彰己现在未得道果劝王莫说。二唯愿下明不知足过请王莫说。于中初先请王勿说。不知足者乃至已下明不知足相。我今已下明不知足过。三知足行下举知足得彰己乐受。于中初明知足之得为佛称赞。是故已下明己乐受。又知足下明知足相。第四段中王初自叹师得罗汉。次告国人咸使同知。是故已下国人闻之率共称赞。第五段中初叹其人自行清净。以是缘下能生他福。如是已下结成无犯。上来第三广明无犯。何以下释。文显可知。上明无犯。下对辩邪。若说如是无犯之人为得罪者是魔所说。就明正中先辩后结。辩中有四。一说身有性。二是虽下彰其无犯。三有比丘即出家下思得菩提。四如是之人虽未得下还明无犯。初中三句。一明比丘说佛秘藏言一切生皆有佛性以有性故断烦恼结即得菩提。二若王下假问显法。先问后答。问中比丘汝作佛不是其一问。有佛性不是第二问。答中我今定有佛性先答后问。成以不成未能审之答其初问。三王言下王闻领解比丘印可。此初段竟。第二段中明说有性称当道理不犯重罪。第三可解。第四段中别有三句。一明其人虽未证果得福无量。以菩提心广大意故。二假使下彰其无犯假举邪言类以破之。若彼得罪。一切比丘皆同其人。自念得果齐应犯罪一切不犯。彼亦如之。三何以下双释前二。于中先问。何故其人得福无罪。我于住下举己类显。举己住修今得菩提。类显彼人当必得果成念无罪。往昔常离不净物等明修缘因。亦自知等知有正因。是故我今得成菩提成自利果。有大慈悲成利他果。彼人同我当得菩提。故自念己当得菩提。称当道理得福无罪。上来广辨。如是下结。受人可知。上来第一约就无犯以辩邪正。自下第二约就有犯以辩邪正。有犯说无名之为邪。有犯说犯以之为正。就前邪中初辩后结。辩中有五。一说无罪报。二若言佛说欲行淫下明淫非过。三或犯四下明其诸罪不障解脱。四如来说突吉罗下明罪有报是佛怖人而无真实。五波罗夷至突吉下明五篇戒非佛所制。下辩正中还翻此五宜审记之。就初段中初说无罪。若有比丘犯如是下明无罪报。初先设难。若犯此等堕地狱者诸外道等无戒可犯齐应生天。何以下释。是故下结。第二段中句别有四。一举如来听诸比丘罢道行淫证非性罪。二复应下明淫旧法非我过咎。三如来在下明淫不障生天解脱成前第一。四古今有下结前第二。第三段中明一切罪不障解脱。文显可知。第四段中举佛昔说突吉罗罪如忉利天八百万岁堕于地狱。但是怖人明无实报。且说突吉。余者类尔。第五段中明五篇诸罪律师妄作假称佛制。如是言下结邪异正。正中有三。一明有罪报翻前第一。二我于经中亦说有下明一切罪皆是佛制翻上第五。三若不持戒云何见下明罪障脱翻前第三。余之二段略而不翻。初中有五。一明诸罪受报无限劝人防护。二有律师下明其宣说无罪报人不应亲近。三如佛说下举佛昔言成前叵亲。先举昔言。若过一者谓说戒时诵过一戒。名妄语者于此时中有罪覆藏名默妄语。不见后者谓此妄语不招当苦名不见后。以不见故诸罪皆覆名无恶不造。是故已下结成叵亲。是于如是默妄语罪不见后世。便于诸恶无不造故。向前宣说都无罪报不应亲近。此第三竟。四我法下举轻况重成前有罪。我佛法中清净如是是举轻也。乃至默妄突吉罗罪亦悉不听。故云我法清净如是。况复已下以轻况重成重有罪。五是故下结劝防护。初先劝护。如是等法若不守下呵人不护。上来第一合有五句明其罪报。第二可知。第三段中若不持戒云何见性正明诸罪能障解脱。一切众生下明其离罪方得解脱。九部经下释疑显法。疑相云何。昔教之中不言有性。云何说言持戒见性。故今释云。九部经中无方等故不说有性。经虽不说理实有之故持得见。下明受人辩正隐邪。自下第三重显向前无犯中义。有二问答。前一问答重显初段正中之义。后一问答重显初段邪中之义。向前正中有何不了而须重显。前说有性当得菩提。不犯重罪宣说有性。不犯须释故今重论。又复向前宣说不犯未明其犯。故今重辩。向前邪中有何不了更须重显。前说比丘少欲住空他赞不犯未明犯义。故须辩之。前问答中先明不犯。若有不能作如是说下明其有犯。不犯有三。一说有不犯。二譬如有人说大海下说无不犯。三有外道下宣说非有非无不犯。初中先问。问因何生。因于向前九部经中不说性生。上说一切众生有性。九部经中未曾说性。如其说有乖违圣教。云何不犯波罗夷罪。下佛答之。经虽不说。所言当理。是故不犯。第二说无不犯文中先喻。次合。何以下释。释中初明二乘之人不知佛性。以是义故说无不犯。如是境下彰性唯是如来所知。释显二乘不知所以。若人不下明二乘人不闻秘藏故不知性。何等已下辩出秘藏。谓方等经。第三段中先明佛性非有非无。若有说下明其无犯。前中初言有诸外道或说断常举邪显正。如来不下辩正异邪。不犯可知。上明不犯。下次论犯。于中有三。一就性明犯。二我已成下就菩提说犯。三以是义下因人不解妄取成犯。叹法不思令人仰推舍犯成持。初中不能作如是说名为犯者。不说身中实有佛性。惑障不见乃云定无名犯重罪。第二段中若言我已成就菩提说因有果。何以故下释成有义。以是缘下结成有义。此显犯相。当知是下结明有犯。宣说因中已有方便菩提之果。所以成犯。何以故下释成犯义。有性未修不得菩提举是显非。第三段中以是义故佛法甚深不可思者以人不解妄取成犯。故法甚深不可思议。下次显上邪中之义。迦叶先请。有王问者假以言之。以上文中王叹比丘比丘不受为不犯戒。故今此中还言王问。上说比丘少欲住空王叹不受不名犯戒。云何许犯堕过人法。下佛为辩。于中初先正对前问明诸比丘为利诈善犯过人法。复有比丘为建立下简真异伪明其不犯。犯中初明为利诈善欲令他人知己乞士。如是比丘多愚痴下为利诈善欲令他人知己是圣。下结为犯。明不犯中初为通教法现圣无犯。复言我今亦有性下为通证法说己身中有性不犯。作是下结。初中五句。一为建正法住空寂处欲令他人谓己是圣。二令他敬信。三因他敬信悉来附己。四因来附己令起行以通正法。五光扬下因他附己化令生解以通正法。谓令众生解佛所说轻重之义。第二段中句别有三。一为教他故说己身中有性得果。我今身中亦有佛性明现有因。有经名下明当得果。我成佛道得菩提果。尽烦恼结得涅槃果。二广为下说他有性。三我与汝下明己及他以有性故当具佛因成就佛果。我之与汝俱当安住如来道地明具佛因。所谓住于十地之道。成下得果。于中初明成菩提果。无量下得涅槃果。作是说下总结无犯。自下第四重显向前有犯中义。于中初言犯突吉罗忉利天上八百万岁堕地狱中况偷兰遮。翻上邪中说突吉罗八百万岁堕在地狱如来怖人。故今明其实堕不虚。举轻况重。故言何况故犯偷兰。此中重罪通名偷兰。不唯方便。此大乘下翻上邪中五篇诸罪非是佛制。明一切罪皆是佛制。先制盗戒。次制杀戒饮酒妄语。后制邪淫。以制淫中问答重显。故回在后。就制盗中句别有三。一总举偷兰劝人莫亲。二何等下三番别显。三如是比丘名无根下总呵显过。制杀等中文相可知。下制淫戒。即是翻上行淫非过明是过矣。初先正制。迦叶白下问答重显。先问后答。答中初先正答前问明梦不犯。下乘教之。句别有五。一教于淫欲当生秽想。二教于女人莫生爱想。三梦行淫己教生悔意。四教比丘生厌食想。食是淫因故教厌之。五若生淫心教疾舍离。如是下结。下明受人

第十对中先辩邪正。后论受人。外法名邪。内法称正。邪中有四。一说外道苦行邪法以为正道。二说如来听度恶人及无根等。三说如来听畜种种不净之物。于中初先辩其所听。除是已下就所不听明邪异正。四言如来说草木等皆有寿命如是四种名魔所说。下辩正中但翻三句。第二一句略而不翻。我亦不听常翘一脚乃至害生方道咒术翻前第一。轲具已下翻上第三及翻第四。于中初先呵邪显正。我唯听下辩正异邪。我唯听食五种味等正翻第三。我说四大无寿命者正翻第四。若有下结。上来十对广辩邪正魔说佛说差别。已下总以结之。迦叶白下是第三段因迦叶领如来述赞。长寿至此合为第一明其随缘造修之行。自下第二明其舍相入证之行。证中初先正明证行。众生薄福不见已下明证所依。与上相似。正明证中差别有三。初四谛一章辩相趣实。四倒一章辩邪归正。二十五有有我不下舍相入证。初明四谛即是答上云何诸调心喜说谛。今此辩明无作四谛。畅佛化意名心喜说。辩谛何为。谛是法相。如来藏性是其谛实。欲令众生寻相趣实故须说谛。四谛之义如别章释。于中如来初广辩谛。后迦叶领解初中先别。后总结之。别中苦集灭道为四。就明苦中文别有二。一辩相异实。二若人下明实异相。就初段中。前言苦者不名圣谛正明异实。今此宣说诸佛法身如来藏性以为苦实。苦相非实故苦非谛。何以下释。初先征问。我以何故言苦非谛。若言已下非邪显正。若当苦事是苦圣谛。牛等有苦应有圣谛。问曰。此等岂无圣谛。释言。此等体实即是。于其情分所觉不真故得言非。如下文说有苦有谛有实。苦尚非谛焉得为实。就下辩实异相之中。约就愚智显法是非。义要有二。一约愚辩非。二约智明是。文有三对。一明愚智迷悟得失。二彰其损益。三双结非是。就初对中先迷后悟。迷中有二。一正明其迷。二明迷有失。迷中若人不知如来甚深境界迷如来藏佛性境界。不知如来微密法身谓是食身非是法身迷佛法身。不知如来道德威力迷佛报身。亦可前句迷于佛心。后迷佛德。问曰。如来法身道德非是苦法。云何迷此名迷苦谛。释言。此等虽非苦相而是苦实。故迷此等名迷苦谛。是义云何。苦之实性是如来藏。如来藏者乃是一切凡佛之体。据佛以望本来常净。藏外无一生死可得。故如来藏即是佛身即是佛德。就凡以论。彼如来藏为妄所覆。所覆之藏与后显时法身为本。说为佛因。说为佛性。如此佛性与彼实谛及佛法身无二无别。故下文言有苦有谛有实乃至有道有谛有实。是实谛者即是如来。佛性虚空以无别故。今说佛身及佛诸德以为苦实。迷此苦实名迷苦谛。余谛亦尔。下明迷失。是名为苦总明迷失。迷真生苦故名为苦。何以下释。以不知故法见非法非法见法明有苦因。不知犹是迷之别称。迷佛法身谓是食身非是法身。是故名为法见非法。生死虚无是其非法。妄取为有故言见法。当知是下明有苦果。必堕恶道是三涂果。轮转生死是人天果。此前一对总报因果。增长诸结复明苦因。多受苦恼复明苦果。此后一对别报因果。亦可前对是分段果后是变易。悟中初先正明其悟。后明悟得。悟中若知如来常住无有变易是其眼见。或闻常住二字音声是其闻见。常是法常。住是报常。就明得中初先正辩。我于本下引己为证。前中初言若一经耳即生天上离三涂苦。后解脱下离人天苦。后解脱时乃能证知如来常住从始趣终。既证已下据终寻始。引己证中。我于本际以不知故轮转生死反举迷失。始于今下翻之显得。文少不足。若具应言始于今日乃得真智以真智故出离生死。上明迷悟。下明损益。若如是知真是修苦多所利益明前悟益。见苦实性名真修苦。若不知下彰前迷损。第三结中先结悟是。后结迷非。次明集谛。先举。下释。释中还约愚智显之。文有三对。一明愚智迷悟得失。二明损益。三结是非。就初对中先迷后悟。迷中初言于真法中不生真智明迷集谛。如来藏性是其真法。无心悟解名不生智。受不净下明迷有失。于中初至不知法性明有集因。受不净物所谓奴婢明其无行。能以非法言是法下彰其无解。能以非法言是法等不解行法。以是因缘不知法性不识理法。以不知下明有集果。先明受苦。不得已下彰其失乐。不得生天失世间乐。及正解脱失出世乐。悟中初言若有深知明知集谛。知集实性故曰深知。不坏已下明悟有得。不坏正法明无集因。以是因下明无集果。得生天上无三涂果。及正解脱无人天果。第二对中但明迷损。略无悟益。若有不知苦集谛处而言正法无有常等牒举前迷名如来藏为苦集处。以是缘下正明其损。第三结中先结悟是。后结迷非。次明灭谛。于中有四。一举灭法。二就人辩修。三结前法。四结前修。初段可知。第二修中迷悟并明。文有两对。一明愚智迷悟得失。二明损益。就初对中先迷后悟。迷中若有修习空法正明其迷。名不善下彰其迷失。是为不善总明迷失。取空违实故名不善。何以下释。灭一切法违佛真德。说灭唯是结尽无为。谤无真德故灭一切。坏如来藏违佛真性。说灭唯空而无真实。以是义故坏如来藏。作是修下牒以结过。次明其悟。于中初先教其趣入令其悟解。若发已下明悟有得。前中初言修苦灭者逆于外道辩正异邪。知灭体性是如来藏。不同外道一向取空。故名为逆。若言修下破邪显正。初举外道邪修类破。若有说下以理正教。藏体不空是以言有。有相如何。如经中说。一苦灭谛是如来藏。如来藏者是真识心。是真心中具有一切恒沙佛法。所谓智慧三昧神通解脱等法。如妄心中具有恒沙诸烦恼法。是心与法同一体性。不离不异。如来藏中具有是义。故名为有。藏体虽有而为惑隐不可得见。断烦恼已定必得之。故知是有。如人迷解正方可见。故得名有。下明悟得。所谓若发知藏之心下极一念。藉此因缘生死妄法不能为障。佛性真法证知无碍。名于诸法悉得自在。第二对中先损后益。损中若修如来密藏无我空寂牒举前迷。取彼空理为如来藏名修密藏无我空也。于无量世在生死中流转受苦正明有损。取空谤实故在生死名受诸苦。益中若有不作如是牒举前悟。反空求实名不如是。有恼疾除正明有益。何以下释。以知藏故达妄本无故疾灭恼。上来第二广辨其修。是名灭谛是第三段结明前法。若能已下是第四段结明前修。若能如是是我弟子结明悟是。若有不下结上迷非

道中亦四。一明道法。二就人辨修。三结前法。四结前修。初中道者总以标举。谓佛法僧及正解脱指其道体。于中别分如来法僧是其道缘。及正解脱正是道体。此乃是其有为解脱。第二修中迷悟并论。先迷后悟。迷中初先正明其迷。以此因下明迷有失。前中初言有诸众生颠倒心言无佛法等明其所谤。生死流下彰其所立。宣说一切唯是生死犹如幻化。修集是见结明其迷。迷失可知。悟中若能发心见等。正明其悟。乘此以下明悟有得。于中先辨。何以故下引己为证彰悟有益。于中初先征前起后。何故见常使于果报随意而得。我于往昔以四倒等举损显益。今已灭下正明有益。是名道谛是第二段结明前法。若有人下是第四段结明前修。先结迷非。后结悟是。唯应结道。据后摄前是故乘言真见修习四圣谛法。是名总结。领解可知。自下第二辩邪归正。此即答上正善具成宣说四倒。欲令众生舍邪归正。是以论之。文中初辩。后迦叶领。辩中初言谓四倒者总以标举。实有八倒。何以言四。为四对故。下广辩之。初先明其苦乐二倒。先明乐倒。次明苦倒。后总结之。是中乐倒少异余处。余处直说生死之苦以之为乐名为乐倒。此中宣说迷佛真乐妄取为苦名大罪。苦取此罪苦以为乐因望得受乐。名为苦中生于乐倒。文中有其六句三对。一明众生妄计佛乐以之为苦。二说彼倒心以为罪苦。此二一对三释佛为苦成上初句。四说前罪苦以之为乐。此二一对。五难破佛乐成佛为苦成上初句。六结前计苦为乐是倒。此二一对。就初句中非苦为苦名曰颠倒总以标举。下释其相。非苦如来解其所迷。生倒想者谓佛无常彰其所立无常故苦。第二句中若说如来是无常者牒前倒想名大罪苦结以为苦。此是罪过与苦作因。故名罪苦。第三句中若言如来舍此苦身入于涅槃举灭证苦。是名下结。第四句中我若说言如来常者即是我见有无量罪。畏乐为苦。是故应下取苦为乐。取彼颠倒罪苦为乐。言是故者是说佛常有无量罪故应说佛无常。说佛无常谓当道理。是以复言如是说者我即受乐。第五句中如来无常即为苦者自立苦义。此乃名前如来舍身入于涅槃以为无常无常故苦。亦可无常是其有为生灭行苦故言是苦。若是苦有云何生乐难破佛乐成佛为苦。第六句中苦中生乐名为倒者。谓于颠倒罪苦之中妄取为乐故名颠倒。次明苦倒。乐生苦想名为颠倒总以标举。次广释之。于中三句。一迷乐计苦。乐即如来辩其所迷。道言苦者如来无常明其所立。若说已下牒以结之。二破乐成苦。如来常住是名为乐反以纵立。若我说常云何复得入于涅槃举应难破。三难破非苦成佛非乐。若言非苦举他所立。云何舍身而取灭度举应难破。上来广释。以于乐中生苦下结。是名初倒总结前二。谓四对中初对到也。第二对中无常常想常无常想是名颠倒总以标举。次释其相。于中但明无常计常常计无常。上来数辩。今略不论。言无常者名不修空明无常所以。不修空故寿命短促正明无常。由不证空随有流变故命短促此明所迷。若有说下明其所立。是名下结。名第二倒总以结之。第三对中无我我想我无我想是名颠倒总以标举。下释其相。先明我倒。世间之人亦说有我正举我倒。佛性亦尔。举正显邪。世人虽下明邪异正。是则下结。下次明其无我之倒。佛法有我即是佛性举其所迷。世间说下明其所立。世说无我正明起倒。是名下结。若言已下引说证无。准验斯言破相之空定非佛性。名为下结。是名第三总以结之。第四对中净不净想不净净想是颠倒法总以标举。下广辩之。于中先明净计不净。净者即是如来常等辩其所迷。若有说下彰其所立。下明净倒。不净净想名颠倒者总以标举。若有说下广以辩之。若说身中无一不净正明起倒。以无不净定当入下举终显始成其净义。涅槃之果名清净处。如来说下破秽显净。是名下结。名第四倒总以结之。领解可知。示同始行故言自前悉名邪见。自下第三舍相入证。答上问中云何作善大仙今说。彼问如何。释有三义。一据修作问。凡夫二乘皆作善业不得菩提。菩萨云何修作善业能得菩提。下佛教之。舍离有无趣入中道。如是作善便得菩提。二对果为问。若使当来有果可得可须修善。若无可得云何作善。下佛答中。明诸众生现有佛性当必得果。如子在胎定生不久但须修善。三对理为问。我今不知所趣入处云何作善。下佛答之。有如来藏可以趣入宣修善业。文中有二。一明众生有如来性可以趣入。二方等经如甘露下教人趣入。前即所证。后即能证。前中复二。一正明有性。二迦叶白佛实无我下问答重显。前中初明凡夫众生有性不见。婴孩喻下明二乘人有性不见。前中先问二十五有有我不也。问由何生。如来向言世虽说我无有佛性。迦叶知有所以为问。下佛答之。佛性之义如别章释。文中初法次喻后合。法中三句。初言我者即如来藏指斥我体。望直说我惧同情取。以是义故对藏以说。如来藏者佛性异名论其体也。是真识心于此心中该含法界恒沙佛法。故名为藏。又为无量烦恼所藏亦名为藏。如来法身蕴此藏中名如来藏。又此藏中出生如来。是故亦名为如来藏。二一切下明众生有。一切众生有如来藏能为佛因名有佛性。如睡心中有觉悟性。亦如矿石有金银性如是一切。此性是其众生自实故名为我。以是我故一切有性即名有我。何不望直说生有我。乃先说性方言是我。此如前释。望直说我惧同情取。故说有性就之辩我。我义不同。凡有四种。一自实名我。所谓一切诸法体实。二自在名我。谓八自在。如下文说。三是假名集用之我。如下所说六法中我。五阴诸法集成我人。四是外道所立神我。今所论我是其初门。三如是我下明诸众生不见所由。由烦恼覆故不能见。道言本来为恼所覆即显不同八自在我。道言常为烦恼所覆即显不同世谛假名无常之我。道言一切众生不见即显不同外道神我。喻中有三。一凡夫有性惑障不见喻。二有异人下佛始为说彼闻不见喻。三即于其家掘出已下终为开示彼闻悟解喻。初中贫女喻诸凡夫。无德称贫。能生真解故名为女。五阴为舍。即阴有性故言舍内多有金藏。自己心识名为家人。心有粗细利钝之珠说为大小。不觉自身有如来性名无知者。亦可二十五有众生名为家人。人有胜劣名为大小。不同解性名无知者。第二段中文有三对。一佛劝修行彼要见性喻。二如来许示彼闻不信喻。三佛害己能彼闻求见喻。就初对中有异人等喻佛劝修。佛超群俗名为异人。善解造修显性之法名知方便。以法告示名语女人。劝之断障令善益彼名雇除草。下要见性。女即答言我不能也。反要见性机显圣心义称为答。若无所证不肯修断名我不能。若能示下顺要见性。未来解心假现修生名为我子。若佛显性今我当求解心证见故云若示我子金藏。为性勤修名为速作。第二对中我知方便能示汝子。如来许示。女人答下彼闻不信。我家大小义如前解。性在我身我尚不知。况佛异人能知我性能示我子。第三对中是人复言我审能者佛因彰己能知能示。女人答下彼闻求见。非直求于当来证见。亦求现在。随文解见。是故说言我亦欲见并可示我。上来三对合为第二佛始为说彼闻不见。自下第三终为开示彼闻悟解。即于其家掘出金藏喻佛开示。如来今于众生身中开示佛性。名于其家掘出金藏。女人见下喻明众生因说悟解。寻说解性名为见己。解性释心故云生喜。妄中见真故生奇想。解法敬佛名宗是人。合中初先依文正合。善方便下随事重合。前正合中依上三段次第合之。佛性如是合初段中舍内金藏。一切众生不能见者合前家人大小不见。如彼宝藏贫人不知举喻以帖。宝藏帖性。贫人不知帖生不见。我今普示众生佛性为烦恼覆合第二段。向前喻中文有三对。今总合之。如彼贫下举喻以帖。如来今日普示众生诸觉宝藏合第三中即于其家掘出金藏。所谓佛性指其藏体。而众生下合第三中女见生喜。宗仰如来合宗是人。就下随事重合之中事别有三。一能开人。二所示者。三所开金。善方便者举能开人即是如来对法以合。贫女人者举所示人即一切生对法以合。金举所开即佛性者对法以合。就明声闻有性之中先喻后合。喻中有三。一昔说无我喻。二因告女下无我覆真喻。三遂至下今说真我喻。就初段中女喻如来。佛能养化故说为女。佛于过去化诸众生令起大机名生一子。所化众生法身未增名为婴孩。起惑计我名为得病。佛心慈怜说为愁恼。访求化义名笕医师。化仪现心名医师来。说无常苦无我等治名合三药。苏乳石密举其药体。劝之修习名与令服。第二段中句别有三。一化义现心喻。二是时女下权言覆实喻。三小儿渴下所化众生执权舍实喻。就初句中正说无我兼遮说我名为因。告为化之仪现于圣心名告女人。如来昔教声闻弟子修学无我名服药已。未得受我名莫与乳。暂停非永以是言且。我患既除无我治废名药消已。方得说我名乃与之。第二权言覆实喻中佛说无我隐覆真我。故言女人苦味涂乳。诫令舍我名母语儿。我乳毒涂真为权隐。未可受习名不可触。第三执权舍实喻中所化众生大欲渐起名为儿渴。厌小心生说之为乏。求佛真我名欲母乳。执昔权言名闻毒气。未肯从真名远舍去。上来三句合为第二。第三今说真我喻中别有四句。一为说真我喻。二始闻不受喻。三佛为会通喻。四领受修行喻。就初句中我患既除无我治废名至药消。佛以大教拂权显实名母以水净洗其乳。以法招引名唤其子。劝学真我名与汝乳。第二句中大欲转殷名为饥渴。保昔权言未肯受大名闻毒气是故不来。第三句中化显物心名母语儿。为汝服药以毒涂乳明己昔说无我所由。汝药消下明今宣说真我所以。药消洗意义同前解。今学非过名饮无苦。第四句中所化声闻闻佛会通名儿闻已。修学真我名还饮乳。学之不顿故言渐渐。合中依上三段之文次第合之。合初段中如来亦尔合前女人。为度已下合医既来合三种药与之令服。于中三句。前之两句破离能取。后之一句破遣所取。就前二中初破我见。后破余见。就初句中为度一切教修无我。量病受法。如是修下明学有宣。永断我心明其所离。谓离我见。入涅槃者彰其所得。得小涅槃。第二句中为除妄见令其离障。谓离边邪戒见取等。示现出法令修对治。谓示出世无漏道法令其习学。前断我见明其证灭。此断余见令修圣道言之隐显。理实齐等。第三句中复示世间计我非真令舍妄我。世人多计五阴为我。今知此我虚妄不真。修无我法清净身者令学无我。观身无我。见身空寂。不于身中妄立神主名清净身。亦可初句令成断德。故经说言永断我心入于涅槃。后之两句令成行德。行中前句断除四见修习净心。后句除我修清净身。亦得说言初句令人证无学果。故经说言永断我心入于涅槃。后二令人修起学因。因中前句断除四见修起正智。后句除我修习净身。虽有多义。初门应善。喻如已下合第二段。喻中三句但合第二。先举前喻。后合可知。如彼女下合第三段。喻中四句但合第一第三第四。第二一句略而不合。如彼女人洗乳唤子欲令还服举前喻中初句之文。我今亦尔说如来藏举法以合。是故比丘不应生怖合第三句我乳洗竟饮乳无苦。如彼小儿闻唤还饮举前喻中第四句文。比丘亦尔举法以合。应自分别如来秘藏不得不有约喻以劝。上来一段正明众生有性不见。自下第二问答重显。有二问答。第一迦叶执相征实难无佛性。如来辩实异相以答。第二迦叶执实征相难无杀生。如来辩相异实以答。就初难中有十二句。前二难上一切众生悉有我性。后十难前从本以来常有之义。就前二中迦叶白佛实无有我反佛前言。何以下释。先自征责。然后显无。生时无知以相验实。若有我下以实责相。以是义下结成无义。第二句中以有终没证成无我。后十句中第一以其差别之义难破性常。若皆有性是常住者牒佛前义。应无坏者约实征相。相别名坏。若性是常。常法不异。一切众生应无种种差别坏相。若无坏下难破无坏成相差别。今见已下以相差别难破性常。业缘不同明其因别。诸趣各异彰其果别。因果既别何处得常。第二以有胜负难破性常。第三以有杀盗淫等诸不善业难破性常。第四以其饮酒醉乱难无性常。第五以其盲不见色聋不闻等难破性常。第六以避火坑毒等难无性常。第七所更后便忘失难无性常。第八以有老少等别难破性常。第九句中就处以征。第十句中约杀以责。下佛答之。初力士喻答前二难明性是有。下雪山喻答后十难显性是常。就明有中初喻次合。如来秘藏如是已下结叹经胜。喻中有三。一凡夫起惑覆障佛性喻。二即命下二乘习空不见真我喻。三时良医慰力士下佛为显实令彼证见喻。三中初段还显向前贫女喻中凡夫不见。第二显前婴孩喻中二乘不见。第三成前两段之中佛开令见。就初段中王喻如来。三千世界佛所化处名为王家。凡夫众生惑性增强名为力士。心有佛性故言眉间有金刚珠。诸恶知识名余力士。由近恶友彼此烦恼同皆现起。故云捔力。相领善法名为相扑。心对惑缘名头抵触。心中之性为相隐覆名额上珠寻没肤中。隐而不觉名不自知。是珠所在由性隐覆多受诸苦名处有疮。第二段中别有四句。一患机感圣喻。二时有明下佛知机病喻。三医寻问下征情责实喻。四力士惊下彼闻舍我喻。就初句中患机感圣名为命医。求佛除障名欲自治。第二句中佛为明医。深闲治法名知方药。知苦由于迷理而生。故言知疮因珠入体。佛性虽隐在于现在浅近身中名珠入皮。现有不灭故曰停住。第三句中如来出世以理征凡故言良医寻问力士。责其心中所计吾我名额上珠为何所在。然诸众生所计之我原从佛性真我处起。真我隐没。便于无处妄计有之。佛今无处征使知无。令于有处起意趣求。故今征问为何所在。第四句中明诸凡夫被圣征穷。方觉无我。乍见无我翻违旧意。故云惊答我额上珠乃无去耶。既觉神空。谓呼佛性真我亦无。故言是珠今何所在。疑同有为虚妄无实。是故说言将非幻化。退心声闻虽复退大。暂时学小心恒不畅名愁啼哭。如舍利弗每伤是也。第三段中句别有四。一佛为显实喻。二不信医下始闻不受喻。三执镜下佛重显示喻。四力士见下彼闻悟解喻。就初句中退心声闻失大愁恼。如来显性以安其心名慰力士。有性必得是故劝言不应愁苦。汝因斗时宝珠入体明隐所由。由对惑缘性隐身中名珠入体。今在皮裹示其所在。住于现在浅近身中不在未来深远之身名在皮裹影现于外。证有不虚相现圣心名影现外。汝曹斗下明诸众生不见所以。曹犹辈也。由惑炽盛故隐不知。第二句中始闻不受名不信医。若在皮下显不信相。现身名皮。未来世中证性之身深远如筋。性在现身名在皮裹。现在身中脓血不净何缘不出。性在未来深远身中名在筋里。当有现无不应可见。迷理疑教故言云何欺诳于我。第三句中重为显示大涅槃经。能有显了说之为镜。佛以此经显照物心名为照面。心中之性修显在经名镜中现。第四句中彼闻悟解寻说知性名为见已。怪妄有真故言惊怪。庆妄有真故生奇想。就下合中依上三段次第合之。合初段中。众生如是合前力士。不近知识合与力士角力相扑。虽有不见合都不知是珠所在。而为贪等合没肤中。故堕已下合处有疮。贪淫嗔恚愚痴覆下合第二段。前有四句但合第四。于中先明二乘之人本为惑覆不见佛性。如彼力下明由不见专觉无我。如彼力士宝珠在体谓呼失去牒举前喻。众生亦下举法以合。以不近友不知密藏故修无我。喻如已下明二乘人修无我故不见真我。喻如非圣虽说有我不知我性举凡显圣。凡未同圣故云非圣。我弟子下辩圣同凡。声闻弟子同前凡夫不知真我故云如是。下广之。不知亲近善知识故修无我者。谓不亲近大乘知识专修无我。亦复不知无我处者。不知无我正在有为。尚自不知无我真性况复能知有我性者举浅况深明不知我。举浅拟深是以言尚。法空以为无我真性。一切诸法实无我故。二乘之人但知生空不解法空。名为不知无我真性。无我易解犹尚不知。况复能知有我真性。善男子下合第三段。向前喻中句别有四。今合第一第二第四。第三不合。如来如是说诸众生皆有佛性合上初句。喻如良医示力士珠举喻以帖。是诸众生为烦恼覆不识佛性合第二句始闻不信。若尽已下合第四句因说悟解。先举其法。后以喻帖。上来合竟。如来秘藏如是无量不可思者。是第三段结叹经胜。由经见性所以叹之。大涅槃经名为秘藏。所辩义广故言无量。所显义深名不可思。亦可此言结叹佛性。性名秘藏。广名无量。深名不思。上来一喻答初二问明生有性。自下一喻答后十句无常之难明性是常。于中初喻次合后结。喻中有六。一众生有性惑障不见喻。二有人闻下举其见者证性是有喻。三王既没下随缘转变喻。四是药真下体常一味喻。五凡夫薄下举凡不见显性深胜喻。六复有王下举后证见明性是常喻。就初句中雪山有药其味极甜喻生有性。山喻五阴。药喻佛性。名曰乐味列名显法。食能生乐故名乐味。喻明佛性证成胜乐。其味极甜辩相显法。喻明佛性体味精纯。在深丛下喻诸众生惑障不见。丛喻烦恼。烦恼覆障故不能见。第二句中有人闻香知地有药。举彼菩萨闻见佛性证性是有。人喻菩萨。依经闻名名为闻香。知身有性故言知地当有是药。实有称言名为当有。不言当来方始有矣。过有王下举佛证见明性是有。过佛为王。欲于自身求佛性名于雪山。为见佛性世世修道故言为药在在处处造作木筒以接是药。行勋满足理从缘显名药熟时。阴身中现名从地出。显在行心名集木筒。证会本性名味真正。第三句中王既没已喻佛灭后。性从缘变故言是药或酢碱等。如是一下释别所由。随处故尔。亦得名为结别所以。此即答上后十难中前九难也。明性随缘故有差别胜负等异。第四句中是药真味停留在山犹如满月答第十难。明性体常不可断绝。第五句中凡人喻于凡夫二乘始行菩萨。显性行微名为薄福。想心推求故说钁斲。勤求不见说言加功困苦不得。第六句中后佛为王。果成名出。显性缘具名福因缘。证性体实名得药味。合中第二略而不合。余皆合之。合初句中。如来秘藏合雪山药。其味亦尔合名乐味其味极甜。为烦恼覆合在丛下。无明众生不能见者合人不见。一切已下超合第三。一味喻性合前文中如是一味。以烦恼故出种种味合随流处有种种味。谓地狱等显种种相。亦即合前或酢碱等。佛性雄下合第四段真味在山。于中初先正就佛性明不可杀。如我性下以性即藏成不可杀。前中初言佛性雄猛难可沮坏是故无有能杀害者正明佛性他不能杀。若有杀下反明佛性他不能杀。如是佛性终不可断结明前正。若可断者无有是处结明后反。后段之中初性即藏。后明叵坏。虽不可下合第五段。凡夫钁斲困苦不得。若得成下合第六段。上来合竟。以是因缘无能杀者结答上问成不可断。前六段中偏就四段结答上矣。上来迦叶执相征实难无佛性。如来辩实异相以答。自下迦叶执实征相难无杀生。如来辩相异实以答。难意如何。若性叵杀应无不善。下佛答之。明相异性故有杀生。以有杀故有不善业。文中初先正对前问明有杀生。必定当下结叹法深。前中初言实有杀生总明有杀。何以下释。释中有二。一明佛性不离阴相杀之有罪。翻前问中无不善业。二非圣下明其阴相不即佛性是故可杀。翻前无杀。前中初明性不离阴故坏五阴名曰杀生。以违性故明知由杀堕坠恶趣。后明由业有刹利等种种差别。后中初明众生我相异于佛性是故可杀。譬如已下明诸众生阴法异性是故可杀。前中两句。一明妄异真。非圣之人横计我等举彼凡我。如是已下辩妄异真。二出世我下明真异妄。出世我相名为佛性举彼真我。如是计我名为最善叹真异妄。阴异性中约智辩异。五阴可思佛性叵测是以不同。于中先喻。次约显法。以是义下结阴可杀。喻中有人。喻求性人。闻身有性名知伏藏。用己明心观阴求性名取利[钁-(目*目)+賏]斲地直下。正意名直。磐石砂砾直过无难明相异性。阴中细者名石砂砾。思无不彻名过无难。唯至已下辩性异相。性如金刚。情不入实名至金刚。不能穿彻实义出情故言金刚刀斧不坏。合中佛性亦复如是合前伏藏。一切论者及天魔等合上有人。一切沙门婆罗门等名为论者。此等皆是求性之人所以举之。所不能坏合至金刚。不能穿彻五阴相等却合斲地磐石砂砾直过无难。先举其法。后以喻帖。性如金刚不可沮坏合夫金刚力斧不坏。下次结之。以是五阴是起作相可坏义故。坏五阴者名为杀生。上来正答。下叹显深。性虽常住而阴可杀。阴虽可杀而性恒常。故知佛法不可思议

上明有性。下教证入。于中有二。一教三归趣入之始。二更为汝说入如来藏下教示中道趣入之终。前中如来先教趣入。迦叶白佛我知问下迦叶奉行如来述赞。前中有三。一因迦叶请略教趣入。二尔时迦叶复说偈下迦叶彰己不识真归。亦复不知归之所以。反依昔别如来重教。三迦叶白佛我亦归下迦叶彰己相实通归。佛教甄简。就初段中。如来初先略言起发迦叶启请。后佛偈答。前中四句。第一如来彰经深重明如甘露亦似毒药。二迦叶请。三如来试问欲知藏不。四迦叶请。就初句中言如甘露亦如毒者。于信能益故如甘露。于谤能损故似毒药。道此何为。三归真性由经趣入。故说甘露令人信乐。明是毒药使人舍谤。此义未显。故第二请如来何缘说方等经譬如甘露复以毒药。欲求秘藏须知乐不。故第三问欲知藏不。彼闻欣踊。故第四请云我欲知。下佛答中有十一偈。初七偈半对上初请明此经法如甘如毒。后三偈半对向后请教入秘藏。就前段中初四偈半正就经法明如甘露亦如毒药。后之三偈就人以显。前中初有两行半偈以其二喻咒于一法。后之两偈以其一喻况于一法。复就前中初一偈半立喻显法。喻中初偈甘露为喻。即约愚智明损明益。后半以其毒药为喻。亦约愚智明损明益。下一偈合。于中前半合上甘露。道言无碍智甘露者。此涅槃经于彼无碍智慧之人得名甘露。所谓大乘斥出其体。如是大乘名亦毒药合后半偈。先牒向者后句大乘。下就明毒翻前甘露。就下一喻况一法中初偈立喻。如苏醍醐及以石蜜举其喻体。此诸事中取一为喻。非是并取。服消则药不消则毒明其损益。后偈合之。方等如是合苏醍醐及石蜜等。智为甘露合消为药。不知成毒合后不消则为毒药。就人辩中偏举智者。愚略不论。于中初偈名二乘中学大乘人以为智者。声闻缘觉举其智者。大为甘露约人显法。如诸味中乳最第一辩法同喻。中间一偈说菩萨人以为智者。如是勤进标举智者。以诸菩萨求佛无间故曰勤进。依大乘等约之显法。依于大乘凭教入证。得至已下因证成果。得至涅槃到涅槃果。成人象王成就佛果。所成之佛人中最胜。犹如象王畜中力胜。约喻名法名人象王。涅槃是其性净涅槃。唯可修显不可修作。故言得至。佛据方便从因修辩是故言成。依大乘法能成此德故言甘露。末后一偈说凡夫中解佛性人以为智者。众生知性标举智者。如迦叶等叹以显胜。解同菩萨故如迦叶诸菩萨等。无上甘露不生不死约之显法。依此大乘甘露法味证会常住成就常果。故无生死。已能成就无生死果故名甘露。就下教入秘藏之中。先应解释三归之义。义如别章。然后释文。文中有四。初有半偈总劝分别。次有半偈正教秘藏。次一偈半彰益劝观。末后一偈结叹显胜。初中汝当善分别者。三归有二。一是别相。二是一体。随其事相三归各异名为别相。论其实性三归体同名为一体。佛今劝人舍别取同。故言当善分别三归。就正教中。如是三归则我性者牒前所劝一体三归。此三归性则是我性。如上所辩。佛性真我名为我性。此之我性据佛以论。即是诸佛法身自体。以佛法身共众生体无二性故。若性无二。何故众生名为佛性佛名法身。释言。若此据佛以论。性外更无烦恼可得。是故佛性即是诸佛清净法身。若据凡取实为妄隐。与后显时净德为本。便名佛性。二义虽异论体不殊。是故佛归即是我性。据法以论。此我即是诸法之体。故法即我。据僧以论。此义即是僧之体实。故僧即我。故三归性即是我性。道此何为。欲使众生于自身中求三归依。依彼三归趣入自实如来藏性。彰益劝中粗判有二。初偈明其证实之益。后半明其出相之益略分有四。一标举实观。审观名谛。我有佛性。言义不足。若具应言我有法性及与僧性。以偈要迮不具言之。说彼我性为佛体性名有佛性。亦可说之为佛因性故名佛性。二当知下明观利益。由观我性有佛性等故入秘藏。三知我下重举实观。我者犹是向前我性。我所犹是向前佛性及法僧性。此三皆是我中所有故云我所。四是人下明观利益。证实离相无世可在故得出世。下结叹中前半叹胜。后半结之。第二番中初先迦叶彰己不知反依昔别。后佛重教。前中迦叶复说偈言经家序列。下举所说。有其十偈。相从为三。初有五偈迦叶彰己不识真归亦复不知归之所以反依昔别。次有两偈审定有无。下有三偈举佛前说不知之损请佛教示。前五偈中初四行半迦叶彰己不识真归及归所以。末后半偈反依昔别。前中初偈明己不知始心归趣。次有半偈彰己不知正修所行。后之三偈明己不知究竟所成。就初偈中。我都不知归三宝处明己不知。三俱不知名都不知。云何当下问归趣法。佛果是其无上无畏云何归趣。次半偈中。不知三处彰己不知。云何作者问佛修法。所修诸行不同真我故名无我。亦可所起缘修对治性非真实故名无我。此无我行云何许作。后三偈中。初之两偈别问三归。后一总问。就前别中初问归佛。云何归佛问归所以。云何劝我归依此佛。准答如是。非问所归。下皆同尔。而得安慰问归所成。果绝危怖名为安慰。云何许得。次问归法。云何归法愿为我说问归所以。云何劝我归依此法。云何自在及不自在问其所成。所证真我名为自在。方便行德不同真我名不自在。云何许得。亦可诸佛八自在我名为自在。缘修对治性是流变名不自在。前句云何得自在者问其所成。后句云何不自在者问其所行。下问归僧。云何归僧问归所以。云何劝我归依此僧。转得无上问其所成。佛果穷极名无上利。此无上利云何转得。上来别问。下总问之。云何真说未来成道是顺问也。若具为文。应言此事道理云何愿佛为我真实宣说未来实得成佛道不。未来不成云何归三反以征问。未来若无果德可成。云何劝我归依三宝。上来彰己不识真归。自下半偈反归昔别。我今无预知彼未来成与不成。当行次第别相三归。于别相中。佛上法中僧以为下。故云次第。第二审定有无之中偈文有二。初之七句就喻审定。末后一句将喻类法。就前喻中初之半偈就无反征。令未怀妊云何已作生子之想。佛亦如是。身中未有三归真性。云何已作成佛之想。若必在下就有述可。若必在胎则名有子。可其有义。子若处胎定生不久述其生义。三归如是。若在身中则名为有。身中若有定成不久。是名子义总以结定是名为子无有之义。众生业然将喻类法。亦得名为辩法同喻。众生身中三归真性能生当果名众生业。同子有无故名亦然。第三段中偈文有三。初之一偈牒佛上言明不知损。其次一偈明己不知请佛断疑。末后一偈明佛能知请佛宣说。就初偈中。如佛所说愚者不知牒佛上言。如来向前四谛章中宣说愚人不知道谛。于道谛中不知三宝常住不变谓是灭法。以不知故轮转生死。故今牒之明己不知。请佛断中初有半偈明己不知。迦叶现今身为俗人名优婆塞。但归别相未归一体无真归行。故曰假名不知真义。显假名相不知一体真三归义。以不知故当有所损。唯愿断疑正请宣说。明佛知中。如来大智明佛能知。唯垂已下请佛宣说。唯垂分别总请宣说。愿说宝藏别请宣说。下佛教中依上三段从后向前次第答之。初偈敕告许为宣说。对上迦叶第三段请。其次一偈明有不无。对前迦叶第二段请。后两偈半明归利益。对上迦叶初段之请。初中迦叶汝当知者敕告之辞。我今为汝许为宣说善开密藏彰己所说。对前请中愿说宝藏。令汝断疑明说利益。对前请中除断我疑。第二偈中当至心听敕诫之辞。汝于已下明三归性是有不无。汝是迦叶及于一切诸菩萨等。内有真实三归之性与我释迦名字不殊。名第七佛同一名号。于七佛中释迦最后名第七佛。释迦是性。此翻名能。牟尼是字。此翻名满。众生身中法身充满与牟尼尊德满不殊。故与第七同一名号。三归真性含识同有。何故偏云汝于菩萨。彼求见故佛对说有。有义实通有应同于一切诸佛。何故但言同第七佛。以第七佛名为满故。自下一段明归利益对上初请。云何对乎。前问云何归佛归法及以归僧问归所以。今明归依真性三归永离邪过故须归依。又前问言云何当趣无上无畏。今明如是归三宝者则得无畏如是答也。就此文中先答向前云何归佛归法僧等。末后半偈答上云何当趣无畏。前中初言归依佛者标牒所问。下明归益显归所以。真名优婆顺正之益。归佛行成故得真名优婆塞也。三归之中并应论此。就始偏彰。终不更归其余天神离邪之益。若当归依别相之佛。此身虽不归余天神。以其依行未成就故。后生容使归余天神。若就我性归真佛者归真行成。终更不归余天余神。天谓梵天自在等。天神谓世间种种鬼神。归依法者标牒所问。则离杀害明归利益显归所以。若归别相三乘之法。此身之中虽离杀害。以其依行未成就故。余身容使归依外道杀害众生祀祠之法。若就我性归真法者归真行成。永更不归其余外道杀害之法。归依僧者标牒所问。不求外道明归利益显归所以。若归别相三乘之僧。此身虽不依于外道。以其依行未成就故。余生之中容使更归其余外道。归此一体真实僧者归真行成。永更不归其余外道。如是归三则得无畏答上云何当趣无畏。以归如是一体三宝断离邪过。故得成佛永无所畏。第三番中迦叶初先相实通归。偈后长行佛教甄简。前中四偈。初偈归昔别相三宝。余偈归今一体三宝。前归别中我亦归三正明归别。归别同一是故言亦。下叹显胜明归所以。是名正路菩萨所依。诸佛境界是佛所托。依之成佛名佛境界。亦可别相三宝中佛是佛所为。别相中法是佛所说。别相中僧是佛所化名佛境界。后三偈中初之一偈举其所归一体三宝。次有一偈举佛叹胜明归所以。次有半偈彰己归依。后半自叹明归所以。初中三宝平等相者同体义分。不同别相佛胜次法僧以为劣。故云平等。常有大性辩出前三。此名佛性为大智性。我性之中常有佛性。故言常有大智性耳。理实亦有法性僧性。遏迮不论。我性佛性无二无别显前平等。亦与法性僧性无别。略不具论。以三归性皆即我性故曰平等。次一偈中初有两句。明此真归菩萨所行故为佛叹。后之两句明此真归是佛所证故为佛赞。前两句中先明佛赞。如来向前赞叹一体以为无上第一之尊。故言是道佛所叹矣。正进安处出其所赞。明是菩萨正精进者所安止处。后两句中先举所赞。此之一归非直是彼正进安处。亦名诸佛正遍知者之所证见。下明佛叹。以正遍者所证见故为佛称赞。前对之中先明佛赞。后出所赞。后对之中先举所叹。后明佛叹。文之左右。次半偈中我亦趣善逝所赞无上道明己归依一体。三宝同向别相是以言亦。善逝所赞义如前解。后半偈中是最甘露诸有无有。迦叶自叹明归所以。治病中胜名最甘露。离相中极妙出三有故言诸有所无有矣。下佛对之教其甄简。于中初略菩萨应作。如是思下广教甄简。略中有三。一劝舍昔别。不应如诸声闻凡夫分别三宝。二于此下劝学一体。于中先明大无三别。所以下释。释相可知。三为欲化下会通昔别。为化说三正会昔别。若欲下劝。广中亦三。与前不次。一劝学一体。二如来者名无上下会通昔别。三是故汝今不应受下劝舍昔别。前中先教自学真归。若欲尊下教他修学。自中但教修学佛归。法僧二归略而不论。初言菩萨作是思惟我今此身归依于佛舍相趣实。念舍情相求己身中法身之佛名为归佛。若即此下证实舍相。舍妄证实名自成佛。自成佛时自外更无他佛可求。故不恭敬诸余世尊。何以下释。初先征问何故不敬。诸佛平等等为作依对问释之。诸佛体同名为平等。用此等身与物为依。故诸众生到所依处。即与诸佛法身体同更无别异。说不恭敬诸余世尊。非谓彼此德等不敬。教他学中文别有二。一教他行。二譬如人下明教他心。教他行中初教凡夫舍伪归真。若有分别三归依下教于二乘舍别归一。于生盲下双牒以结。就教凡中先教归佛。句别有二。一教众生归佛法身。二亦令下教他众生归己法身。前中若尊法身舍利应敬塔庙寻相趣入。此法身者佛法性身。舍利胡语。此翻名身。胡汉并举。故言尊重法身舍利。法身无相难以趣求。故教敬塔以尊法身。良以法身无处不在。故敬塔庙即得名为敬佛法身。所以下释。初先征问为重法身所以礼敬塔庙者何。为下释之。以诸众生不见法身。为欲度彼故教敬塔寻相趣入。举此为欲类于自身。第二句中亦令众生于我身中起塔庙想。准前类后。归己同前是故言亦。亦以菩萨法身难见。故教众生敬己阴身而为趣向。己身即是法身住处故名塔庙。何不令生于自身中起塔庙想。乃令众生于菩萨身起塔想乎。释言。令生于自身中起塔想者。即是向前自行门摄。今明菩萨利他之行。故教众生于菩萨身起塔庙想。如是下释。以诸众生用我法身为归依处。故令于我五阴身中起塔庙想。次教归法。一切众生皆归非真邪伪之法举其所教。亦即显其须教所以。别相不实故曰非真。理外妄立称曰邪伪。亦可名彼外道邪法以为非真邪伪之法。我当次第为说真法教令归实。先教别相。后教一体。故云次第。亦可先教真佛次教真法故云次第。下教归僧。又有归依非真僧者举其所教。亦即显其教之所以。归别相众名非真僧。亦可名彼外道邪人为非真僧。我当为作真归僧处教令趣实。菩萨教彼于己身中求真实僧。故言为作真归僧处。上来教凡。下教二乘。若有分别三归依者举其所化。小乘众生唯取别相名分别三。我当为下化之归一。一佛性中义别三归。故言为化一归依处无三差别。自下第三双牒以结。于生盲众为作眼目牒前教凡。复为声闻缘觉作归牒教二乘。如是下结。教凡归真名为无量恶诸众生而作佛事。教小归一名为智者而作佛事。上来一段明教他行。自下第二明教他心。于中有二。一对凡夫作真归心。二作是思下对二乘人作一归心。前中先喻。喻别有三。第一王喻。喻教菩萨于诸众生作佛归心自欲与彼作佛归覆。二王子喻。喻教菩萨于诸众生作法归心自欲与彼作法归覆。第三臣喻。喻教菩萨于诸众生作僧归心自欲与彼作僧归覆。就初喻中如人是王。喻于菩萨教人破相名临阵时。念己胜他故言我于是中第一。以能教他破舍别相归心佛故。念他归己故言一切悉依时我。谓依菩萨舍妄归真。又依菩萨我之真性故言依我。第二喻中亦如王子。喻于菩萨念己能教其余众生舍离妄法归依真法。故言思惟我当调伏其余王子。念己堪能绍继佛处说佛真法。名绍大王霸王之业。念己所解胜过余人名为自在。念能令他同来归己。故言令诸王子见归。是故已下劝生大意。自念为物作归处故不应生于下劣想也。第三喻中如王王子牒前类后王牒初喻子牒第二大臣亦尔明后同前。念己于余小臣中胜故言亦尔。菩萨下合。如王王子及如大臣故言如是。上来对凡起真归心。下对二乘起一归心。菩萨先思云何三事与我一体。下佛教示。我示三事即是涅槃故名一体。然经论中说一不定。若就涅槃开示三归。宣说三归即涅槃体。若就佛性开示三归。宣说三归即是佛性。若就真谛开示三归。宣说三归即真谛体。故下文言若能计三宝常住同真谛此即是佛最上誓愿。若就常义开示三归。宣说三归同一常体。故下文言我不说佛法众僧有差别相唯说常恒无有变易无差别耳。若就不二法门辩三。三即不二。故经说言佛即是法法即是僧。此之三宝皆无为相与虚空等一切法亦尔。故曰一体如是一切。今言三事即是涅槃一门言尔。上来第一教学一体。自下第二会通昔别。先举昔别。为欲下会。前中如来名无上士。法说彰别。胜过法僧故曰无上。譬如已下喻说显别。别相三宝合为人身。头最为上喻佛最胜。非余支等喻明别相法僧不如。下合可知。下次会之。为欲化度诸世间故示现别相。如世梯橙。佛高次法僧以为下。是故汝下大段第三劝舍昔别。于中初先劝舍别相。言是故者别相三归。为度世间方便示故。不应受持如凡愚人所知三归。汝于大下劝舍别心。定心舍别。故言决断应如刚刀

上来第一佛教趣入。自下第二迦叶奉行如来述赞。于中有四。第一迦叶彰己先解明今奉行。二如来述劝。三迦叶叹深。四如来述赞。初中有四。第一迦叶彰己自知为他故问。二欲令如来下明己问意庆蒙佛答。三我亦安下明己自行转为他说。四亦当证下明己自证转劝他人。就初段中先明自知。我为已下明问为他。于菩提中决意求实名大勇者。我为此人问于无垢清净行处。证实之智是其无垢清净之行。真性三归是其行处。第二段中欲令如来为菩萨等明己问意。真性三归是奇特事。能诠之教名方等经。为使如来分别奇特称扬方等。所以发问。如来悲下庆蒙佛答。第三段中我亦安住明己自行。同佛称亦所说已下明为他说。于中初言所说菩萨清净行处牒佛上言。即是宣说大涅槃经指斥其相。我今亦下明己传说。为他宣说大涅槃经故言我今广为众生称扬秘藏。说经同佛是故言亦。第四段中亦当证知三归依处明己自证。同佛称亦。若有生下转劝他人。于中初先劝他生信。其有宣下劝他宣说。是故声闻缘觉已下劝他归依。劝他信中若有众生能信涅槃举能信人。则能了达三归依处明信利益。何以下释。以此秘藏涅槃经中说有佛性。故信是经了三归处。劝他说中其有说者举其说人。皆言身中尽有佛性明其说相。如是之人则不远求明说利益。何以下释。以己身有三归性于未来世当成三宝。故不远求三归依处。劝他依中言是故者。是我身中有三归性。未来即当成三宝故。声闻缘觉及余凡夫皆应归依我之真性恭敬礼拜。起修趣顺名敬礼拜。亦可菩萨自说为我。是我身中有三归性。是故声闻缘觉众生皆应于我恭敬礼拜。与上文中亦令众生于我身中起塔庙想其言相似。上来第一迦叶奉行。自下第二如来述劝。以是信经及与说经有大益故。应当正学大乘经典。自下第三迦叶叹深。佛性不思叹其性因。相好不思叹所成果。随相似别实即真性。是故不思。自下第四如来述赞。善哉正叹。汝成深智出其善事

涅槃经义记第三涅槃义记卷第四

        隋净影寺沙门释慧远述

上来第一教示三归趣入之始。自下第二教其中道趣入之终。于中初先法说以教。如因乳下喻说以教。法中有四。一许教趣入。二若我住下正教趣入。三我与无我性无二下结劝受持。四我先于下引说证成。初言我今更为汝说入如来藏许教入也。对前云更。更说在后是以言当。委说名善。显实令证名说入藏。第二教中文别有四。一对凡夫断常偏见明法相二。二凡夫于中无疑已下对遣凡夫有无二见明理无二。三若说苦下对二乘偏见明相实二。四若言无明缘行已下对遣二乘差别二见明实无二。第一第三两二何别。第一宣说生死涅槃法相之二。第三宣说因缘法相实性之二。第二第四无二何别。第二段中宣说法性有无不二。第四段中明其实性前后不二。如乳酪等牛味不二。并显诸法相实不二。就初段中先明凡夫断常偏见。以是义下对破情见明法相二。明凡夫见中文有五对。初对明过。中三正辨断常二相。后一明其见起所由。就初对中若我住者举其常见。常见之人说有神我住五阴中名为我住。即是常法不离于苦就之显过。外道宣说神我是常。故从其意说为常法。五阴是苦。我住阴中名不离苦。若无我者举其断见。断见之人说无生灭假名之我乃至涅槃真我亦无通名无我。修行无益就之彰过。以无我故无所资润。故无所益。中三对中初对约就我无我见以别断常。第二约就常无常见。第三约就苦乐二见。就初对中若言诸法皆无有我牒前无我。生死涅槃二俱无我故曰皆无。即是断见结断异常。若言我住牒前我见。即是常见结常异断。第二对中若言一切行无常者举无常见。此说生死涅槃之法二俱断灭故曰无常。非是前后流变无常。即是断见结断异常。诸行常者举其常见。谓说五阴诸行皆常。复是常见结常异断。第三对中若言苦者举其苦见。此说世间假乐全无乃至涅槃真乐亦无通名苦见。即是断见结断异常。若言乐者举其乐见。说生死中定有真乐名为乐见。复是常见结常异断。下明二见起之所由。由常起断。由断起常。于中初法次喻后合。法中修常堕断见者求常不得故生断见。修一切断前常见者求断不得故生常见。喻中因前移后足者断常二见互为前后。合文可知。上来第一明凡偏见自下第二对破偏见明法相二。先辨后结。辨中三对。一苦乐相对以辨二法。二我无我对。三常无常对。于中无常苦与无我是生死法。常乐及我是涅槃法。生死法中苦名不善是生死因。无我烦恼是生死缘。无常财物是生死果。理实齐通。隐显言之。涅槃法中乐名为善是其圣道。我名秘藏是其涅槃。常名佛法僧正解脱是其菩提。理亦齐通。隐显故耳。就初对中以是义者。以是凡夫偏取皆是断常义故。理须并学修余法苦皆名不善修余法乐名为善者。学观名修。苦是生死。乐是涅槃。相对辨异是以言余。不善苦因。因从果称故名为苦。亦可苦果从因以目说为不善。善是乐因。因从果称说之为乐。亦可乐果从因以名故说为善。第二对中修法无我是生死法。生死无实又不自在故名无我。烦恼是其生死之缘。以有烦恼所受不实不得自在。从果立称故曰无我。亦可无我从本以名说为烦恼。又此烦恼性是不实不自在法故名无我。是故无我即是烦恼。修余常者是涅槃法。此正是我举常显之。良以说我喜同情取。法以常别名曰秘藏。正是涅槃。涅槃真我微隐称秘。备德曰藏。所谓涅槃斥其体相。妙出诸有名无窟宅。修余无常是生死法。即财物者生死果报名为财物。修余常者是涅槃法。谓佛法等斥其体相。此之佛法是菩提耳。下次结之。当知如是佛法中道当相正结。离二说真显其中义。离前凡夫断常二边故名中道。非无二中。自下第二对遣凡夫有无二见明理无二。于中有二。初明凡夫二见乖中。二如四大下佛教无二。前中两句。初言凡夫于中无疑彰彼凡夫不识中道。凡夫于彼无二中道无心攀缘故不生疑。尚不生疑乌能识知。二羸病下彰彼凡夫建立二相。初先立喻。病人喻凡。解劣称羸。闇惑婴心说以为病。餐受邪法名服苏已。取有着无名力轻便。苏性软弱。病人服之体无坚强。随物倾倚名力轻便。邪法如是。凡夫听受取有着无不能正住。如力轻便。有无不定合以显法。下明如来破遣情二教以无二。于中有四。一对向后段有无之病许教除断。二开示已下对向前段。于中无疑许教趣入。三若言有者智不应下对前第一正教除断。四若言有者不应默下对前第二正教起入。就初段中先喻后合。喻中四大其性不同各相反者喻前有无二见相反。良医善知随其偏发而消息者喻明如来知过偏强而为除断。合中初句四大不同略而不合。但合后句良医消息。如来亦尔于生如医合前良医。知诸烦恼体相差别合前善知。而为除断合前偏发而消息之。除断之相如后文说。第二段中开示秘藏清净佛性常不变者对前凡夫。于中无疑许为开示令其趣入。开相如后。自下第三正显向前为除断相。若言有者智不应染教断有见。若闻法有。有智之人不应染着取为定有。若言无者即是妄语教舍无见。若说一切诸佛皆无。乖违法理故是妄语。自下第四正显向前开示秘藏佛性之义。明其佛性非有非无。若言有者不应默然明性非无以非无故应为他人说性实有。不应默然。彼云何有。分别有二。一法佛性从本已来且过恒沙一切佛法。如矿中金。二报佛性从本已来于其心中有可出生一切德义。如矿中金有可造作庄严具义。亦复不应戏论诤讼彰性非有。云何非有。分别亦二。一法佛性离一切相离一切性。故名非有。云何离相。如净醍醐。体虽是有而无青黄赤白等相。亦如一切众生心识。体虽是有而无大小长短等相。佛性如是。体虽实有而无一相。云何离性。如来藏中具过恒沙一切佛法。不离不脱不异。是诸佛法同一体性互相集成。未有一法别守自性。故言离性。二报佛性本来但有可生之义而未有体。如树子中而无树体。性既如是。于中执定无不乖理。故劝舍之。文中初言亦复不应戏论诤讼正劝舍有。舍有同前。是以言亦。前劝舍无更劝舍有所以言复。若执定有言不应法。即名戏论。执有乖空。是故劝舍。以有此过故劝不应。但求了等教取正义。舍情专理故曰但求。所求如理即是其论诸法真性。凡夫已下举过劝舍。道言戏论诤讼不解即显不者堪能解也。问曰。今此说非有无。与彼向前第三段中破有破无。有何差别更复重来。释言。前者为破情见。今此所论为明道理。又复前者就彼世谛因缘法中破定有无。今此正显如来藏性非有无义。与前不同。所以更辩。自下第三对彼二乘偏见之过明相实三。良以二乘执相迷实。故佛就相辨实教之。文别有五。前三就其染相显实。后二就其净相显实。此五番中例应有三。一举佛昔说。二明愚人执相迷实。三明智者解相知实。但今文中言有隐显或有具者有不具者。就初番中但有堕二。略无第三。若说于苦是第一句举佛昔言。佛昔于彼小乘法中说身皆苦。愚人便谓身是无常一切苦等是第二句。此名声闻以为愚人或名凡夫。以不知实故名愚人。心不会正故不名圣说为凡夫。谓身无常苦之所以说一切苦。正执为苦。此明执相。复不能知身有乐性彰其迷实应举智者。翻前可知故略不举。第二番中三句备有。若说无常是第一句举佛昔言。凡计无常譬如坏器是第二句。此名声闻以为凡夫。寻言执相故计一切皆是无常。如坏喻显。此文略少。准前应言复不能知身有常性不知常性即是迷实。有智人下。是第三句。应当分别总劝分别。不应已下别教分别。不应尽言一切无常劝舍执相。何以故下教令知实。言何以故征前起后。何故不应尽言无常。我身即有佛性种子正教以实

第三番中若说无我是第一句举佛昔言。凡夫当谓一切无我是第二句。彰彼二乘执相迷实。然此文中但明执相。略无迷实。智者已下是第三句。明其智者解相知实。应当分别无我假名劝其知相。劝知无我局在假名不实法中。如是知已不应生疑劝其知实。知彼无我局在假名不实法已。不应于彼真实法中疑谓无我。第四番中若言如来秘藏空寂是第一句举佛昔言。此说涅槃以为秘藏。如来昔于小乘法中宣说涅槃一向灭无故云空寂。又佛昔于破相教中说涅槃法一向空无亦名空寂。凡夫闻之生断灭见是第二句。彰彼二乘执相迷实。谓佛如来般涅槃后一向断灭。此明执相略无迷实。有智人下是第三句。明其智者解相知实。应当分别如来是常无有变易劝其知实。略无智相。若具应言应当分别如来化灭实是常住无有变易。第五番中若说解脱喻如幻化是第一句举佛昔言。此说菩提以为解脱。如是昔于破相教中说佛解脱幻化无实。故大品云若有一法过涅槃者我亦说之如幻如化何况涅槃。故今举之。凡夫当下是第二句。彰彼愚人执相迷实。谓佛所得真实解脱犹如幻化终归磨灭。此明执相。略无迷实。有智人下是第三句。彰彼智者解相知实。应当分别人中师子虽有去来明其知相。名佛以为人中师子。化生名来。应灭称去。常住无变明其知实。自下第四对遣二乘差别二见明实无二。良以二乘未体法实。见法流变便谓定别。故须破遣以明无二。并遣二乘相实二见以明不二。以二乘人闻前无常苦无我中有常等性。便谓彼性与苦无我等相别体同聚。故须破遣以明无二。文中六对。前之三对破遣二乘前后别见以明无二。后之三对破遣二乘相实二见以明无二。前三对中云何无二。如麦因果前后虽别麦性不二。乃至一切乳酪等别牛味不二。诸法像此。明无明等虽复别异实性不二。一真心体随缘转变为诸法故。故下文言与诸结俱名为无明。与善法俱说之为明。后之三对云何无二。如人夜闇见绳为蛇。同体义分体性无二。亦如有人迷南作北。此南与北体性无二。诸法如是。迷如来藏以为生死。生死之体是如来藏。故曰无二。前三对中初番结业相对说二。约对此二以明无二。第二业果相对说二。第三善恶相对说二。法相无量且举此三。余类可知。就初对中若言无明因缘诸行举佛昔言。无明烦恼诸行是业。凡夫闻下明其愚人定执为二。此还名彼二乘为凡。以未证会无二实故妄心取相说为分别。谓彼无明与行定别名生二想。明与无明列其二名。明犹是行。行中明胜。对彼无明彰二相显。故偏举之。智者已下寄就智者明性无二。一真识体随缘转变为明无明。故性无二如一水性随缘清浊水性无二。无二即实牒以结之。行识相对文显可知。第三对中若言善等举佛昔言。十善十恶举其业体。可作不可作约人辨业。十善可作。十恶叵作。善道恶道对果辨业。十善通人至于人天名为善道。十恶通人到于三趣名为恶道。白法黑法随相辨业。善业鲜净名之为白。恶业鄙秽以之为黑。凡二智一义同前释。自下三对约就向前第三段中相实之二以明无二。然上文中备有五句。今且约就初之三句以明无二。余类可知。若言应修一切苦者举上初句。凡谓二者此犹名彼二乘为凡。二乘之人闻前苦中有其乐性谓全别体故言谓二。智者了达性无二者寄智显理。菩萨智者知实起相。相即是实名了无二。无二即实牒以结之。若言无常牒上第二。如来秘藏亦无常者。犹前文中凡夫计身悉皆无常。声闻之人于昔教中闻说无常便谓生死乃至秘藏皆悉无常。故今举之。彼二乘人于昔教中未闻秘藏。云何说言谓佛秘藏亦是无常。彼虽不闻而言一切悉是无常。言无甄简。秘藏亦是一切之限。故得说言如来秘藏亦是无常。凡谓二者由彼二乘昔谓一切悉无常故。佛前教之明无常性。彼闻说常谓与无常一向别体故言谓二。智了无二义同前解。一切无我牒前第三。如来秘藏亦无我者。犹前凡谓一切佛法悉无有我。彼二乘人于昔教中闻说无我。便谓生死乃至佛法一切无我。故今举之。凡谓二者由彼二乘昔谓一切悉无我故。佛上教之无我法中有真我。彼闻设我谓与无我迢然别体。故言谓二。智了无二义如上辨。上来四段合为第二正教趣入。自下第三结劝受持。句别有四。一结叹前义。二我今于下结叹前教。三我无我下劝持前义。四汝亦应下劝持前教。就前句中我与无我性无有二牒举前义。前义众多就后以牒。如来秘藏其义如是就之以结。不可下叹。第二句中我今于是一切功德成就经中皆悉说者。上来辩理能令众生依之成德。故名一切功德成经。此即是共叹美之辞。如来藏中所有语义于此经中具已说竟名皆说已。此是结辞。第三句中据后以劝。是故偏言我与无我无二应持。第四句中劝持教法。同义称亦。如我先下大段第四引说证成。此应引彼大品经说证成此义。从上更说入如来藏至此第一法说教入。自下第二喻说教入。先举喻事。如是酪性为从乳下广辨喻相约之显法。文别有四。一破定有无。显前第二有无不二。二是牛食啖水草已下明乳酪等前后性同。显上第四前后无二。三迦叶白下广前第一有无不二。四是牛食啖草因缘下广前第二前后不二。初中有四。一就乳酪三句审定。从乳为一。从自为二。从他为三。二乃至下以前类后。三就前三句难破后二成初乳生。四乃至下将前类后。初二可知。第三段中难破自生明其非有。难破从他成初乳生显其非无。破从他中。若从他生举其异说。此名水等以之为他。对破可知。次破从自。若自生者举他异说。宣说乳中先有酪性还生后酪名为自生。故今举之。下对破遣。不应相似相续生者。以酪自生破从乳生。酪从酪生不从乳故。是乳不应相似相续而生后酪。乳相似酪故言相似。酪生接乳名为相续。道其相似明乳酪因。云言相续明酪乳果。若相续生则不俱者。以从乳生破酪自生。以从前乳续生酪故。明知先无酪之自性。与乳俱时而生后酪。若不俱生五种之味不一时者将初类后若无酪性与乳俱时而生后酪。是则乳中亦无生苏乃至醍醐。是故五味不得一时。虽不一下释成初句明从乳生。虽不得一时简前自生。定复不从余处来也简前他生。谓不从余水草中来。当知乳中先有酪相正明乳生。乳有酪性。酪性是其酪果家相。如暖火相非有酪体。甘味多故不能自变明假缘生。此言即是释防外难。难意如何。若乳有酪何故假缘。假缘生故明知乳中先无酪性。无酪性故不从乳生。故今释之。乳中实有甘味多故不能自变。故假酢缘方始得生。下第四段。以前类后。文显可知。此初段意也。第二段中初先立喻。后约显法。喻中明能生所生前后虽别性同不二。以类无明及诸行等前后虽别实性无二。文中初言是牛食啖水草因缘血变成乳明前后二。下约此二明性无二。食甘乳甜食苦。乳苦食肥腻草纯得醍醐明性无二。食草与谷所出之乳色味各异。食谷乳好食草乳恶明性无二。下约显法。以明无明生于二相合食水草。血变成乳明法相二。若无明转则为明者合食甘草乳则甜等明性不二。一切诸法亦复如是以初类后。无有二相结成二。无二之义亦如上辨。自下第三广破有无成前第一。先问后答。于前问中先难定有。后难定无。由佛向说乳有酪相故难定有。恐佛被难转立无义。故难定无。前难有中如佛所说乳中有酪是义云何牒以直问。下就设难。难有四句。一以生难有。若言乳中定有酪相细故不见举佛有义。云何说下以生难破。从乳新生明非本有。二若本无下立理重征。本无今有可名为生。如其先有云何名生。三若言乳中定有已下举因类破。草是乳因。举彼草中先有性乳。类破乳中先有性酪。若言乳中定有酪相重牒前有。草应有乳正类破之。四如是乳中亦应有草举果类破恐佛被征说草有乳。故今类破乳应有草。斯乃举果反类其因。下难定无。句别有三。以生破无。言云何因乳而得生酪以生难破。从乳生酪明非本无。二若本无下破无得生。先举本无得生之言。何故已下次以破之。若本无酪而得生酪。本亦无草何故不生。乳不生草草可本无。乳中生酪明酪非无。下佛答之。先列三门明皆不可。不定有无正答前难。不从他生遍防异计。言不定有成初段中不自生义。不定无者成初段中从乳生义。不从他者成初段中非他生义。下广显之。先破定有。初牒次破。若乳有酪体味应同。云何而得体味各异。乳冷酪热是其体异。乳甜酪酢是其味异。其色亦异略而不辨。体味各异明非本有。是故下结。次破定无。先牒次破。乳中何故不生兔角。以无不生显生非无。是义云何。若乳无酪而得生酪。乳无兔角何故不生。乳无兔角不可生角。乳生于酪明酪非无。置毒乳中酪则杀人。以终验始显非本无。是故下结。次破从他。先牒次破。若从他生。水是其他。何故于中不生于酪。水不生酪明不从他。是故下结。自下第四广显不二成前第二。初先立喻。明无明下约之显法。以是缘下结会前喻。佛性亦尔举法以帖。喻中有四。一就乳因果建立二相。喻明无明法相之二。二是乳虽从草血出下就乳因果明性无二。喻明无明实性不二。三是乳灭下就酪因果建立二相。喻行识等法相之二。四是故不得定言已下就酪因果明性无二。喻行识等实性不二。初中是牛食草因缘血则变白从因生果。牛喻众生。心纳惑缘名为啖草。起无明支喻况如血。无明起行名血变白。草血灭已福力成乳。因谢果兴亦得名为缘力生果。为彰因果前后别异故说灭已。犊子福力变血成乳。故言众生福力成乳。是义云何。牸牛喻于无明众生。造业众生从前而起说为犊子。以此众生宿业熏习转前无明而起后行。如彼犊子福力成乳。第二段中是乳虽从草血而出不得言二正明无二。草血出乳是其别异。辨异兼一是以言虽。转前作后是故不得一向定二。唯得已下释成无二。唯从草血因缘生乳非余处来。是故不得一向定二。酪至已下以初类后。以是义下结成无二。以是乳等从前生后。性无别故同名牛味。牛味同故名为无二。第三段中是乳灭已因缘成酪正辨其二。前乳灭已更假余缘方得成酪。所以名二。何等下释。是故下结。是酪假于酢暖等生故名从缘。乃至已下以前类后。第四段中是故不得定言乳中无有酪相正明无二。是酪从于乳中生故。不得定言乳中无酪相。而生后酪故性无二。从他生者离乳而有无有是处破他定二。从他生者举异见人。离乳而有举异见言。无有是处以理正非。离乳有酪无是处故。明非定二。上来立喻。下合显法。但合初对。后类可知。明与无明亦复如是。合前食草血变成乳明法相二。若与烦恼诸结俱下合前是乳虽从草血不得二等。于中初先正解无二。一佛性体与诸结俱名为无明。与善法俱名之为明。明与无明体性无二。何者性体。谓真识心。故地经中说十二缘皆真心作如梦所为皆报心作。是故已下结成无二。以是因缘下结会前喻以明无明二。因缘故我先宣说雪山腻草牛若食者即成醍醐。佛性亦尔举法以帖。此明佛性。同彼腻草及与醍醐前后性一故云亦尔。由性一故彼无明转即变为明。如是一切。四谛至此正明证行。自下第二入证所依。于中有二。一明菩萨依经见性。答上问中云何菩萨见难见性。二种种异论皆佛说下明诸菩萨依字解经。答上问中云何解满字及与半字义。初中有三。一明菩萨依经见性。二迦叶白甚奇已下明二乘人依经见性。三迦叶白佛非圣凡夫有生性下明凡夫人依经见性。初之一分正答前问。后二乘辨。此三分中皆初明其佛性难见后明能见。就初段中先明难见。若刹利下明诸菩萨依经见性明难见中句别有四。一略喻难见。所谓[牛*孛]牛众生薄福不见雪山肥腻之草。二佛性下合。三如大海下广喻难见。于中海喻喻妄含真。雪山之喻。喻真含妄。四众生下合。于中初先合喻明有。所谓已下出其有体。恐畏世人执法同喻。故说佛性非是作法。但为已下明诸众生不见所由。此即明其难见义也。下明菩萨依经见中。若刹利等断除即见成无上道明诸菩萨断惑证见。菩萨处世不出四姓。故说刹利婆罗门等。譬如已下明诸菩萨依经解见。先喻。次合。后叹劝学。喻中先顺。若无下反就。顺喻中法身如空。震雷喻于大涅槃经。从真现应普覆世间名为起云。一切象牙喻众生心。人传外国上象有三。一优钵罗象。二拘物头象。三分陀利象。此等皆悉从牙以别。于天雷时牙上有其优钵罗华文像生者。说之以为优钵罗象。余二亦尔。以此等一切象牙喻众生心。众生心中佛性显了故言生华。下反喻中。佛未宣说涅槃经时名无雷震。众生心中性不显了名华不生。性不显故唯得宣说众生无我。不得言我故无名字。合中有四。一明凡不见合前反喻。二若得闻下明菩萨能见合前顺喻。三虽闻下明二乘不见合前反喻。四闻是经下明菩萨能见合前顺喻。就初段中佛性如是合天雷时牙中华生。恼覆不见合华不生。是故我说众生无我合无名字。是诸众生恼覆不见故说无我。第二段中若闻是经则见佛性合雷华生。明诸菩萨依经见性。如象牙华举喻以帖。此从凡夫进为菩萨。第三段中虽闻契经不闻是经不知如来微妙相者重合无雷华则不生。此明二乘虽闻小乘契经诸定以其不闻涅槃经故不知如来法身体相。如无雷下举喻以帖。第四段中闻是经已即知佛性重合雷时象牙华生。明诸菩萨依经见性。喻已下举喻以帖。此从声闻进为菩萨。下叹劝学。于中五句。前四叹胜。后一劝学。前四句中初明由经得知佛性。二以是义下结叹经胜。以闻是经知佛性故。说大涅槃为秘密藏。三增长下明向由经增长法身。从小至大名增法身。四以能长下结叹经胜。以能长养法身大义。故得名为大般涅槃。下劝学中。若有习学能报佛恩上顺圣心。真佛弟子上顺佛法。就明二乘见性之中先明难见。迦叶白佛佛性微细云何肉眼而能得见下明二乘人依经得见。前中有四。第一迦叶明性难见。二乘不服不能听受。证会在心故曰不服。二如来述可。汝叹性深二乘不服不违我说。三迦叶请佛难见之相。四如来广辨。于中有二。一举菩萨见性不了以显二乘不能得见。二所有佛性如是深下举佛独知彰彼二乘不能得见。前中先明菩萨不了。如是菩萨位阶十下以大况小明小不见。就明菩萨见不了中初明菩萨假佛少见。下因见伤叹。前中先喻。喻有四句。一自不见性喻。十地菩萨各修十度说为百人。因分所修未能见实故说为盲。二为治目下请佛求解喻。为治慧眼请佛听法名造良医。三是时下佛为说法。喻诸佛良医为说涅槃。破其闇障开发慧眼。名为金錍抉其眼膜。四以一指下因说悟解喻。经初一说名一指示。中间重说名二指示。初闻未解如一指示盲答未见。重闻方解如以二指三指示之乃言少见。下次合之。先合初句。大涅槃经如来未说亦复如是彰盲所由。如医未以金錍抉膜其人眼盲。无量菩萨虽具足行诸波罗蜜乃至十住合彼百人。犹未见性合上盲也。随相修行故不见性。第二一句为治造医略而不合。如来既说合第三句金錍抉膜。即便少见合第四句二三指示乃言少见。于中别论十地少见。余者皆未。通则欢喜乃至法云未闻此经皆不见性。闻则俱见。非唯十地。下伤叹中见已咸言甚奇世尊叹佛能开。我等流下伤已宿盲不识真我妄为虚法之所惑乱。上来广明菩萨不了。自下第二举之以况小目不见。如是菩萨位阶。十地尚不了。了知见佛性。况声闻等总举况小。复次已下别举况小。有九复次。初复次中先明菩萨见性不了。后况二乘。余中但明菩萨不了。略不况小。皆初立喻。后合可知。自下第二举佛独知彰彼二乘不能得见。于中先明佛性甚深唯佛能知。次明二乘不能知及。智者已下结劝分别。上来广明佛性难见。下明二乘依经能见。迦叶先请佛性微细云何肉眼而能得见。下佛答之。先明二乘依经信见。如是佛性唯佛知下彰彼二乘不能证见。前中先喻。次合显法。是故已下结劝学经。第三明凡见性之中初明难见。凡夫说我不当性故。若有凡夫能善说下还明依经故能见性。前中迦叶先问起发。问由前生。如来向说佛性甚深唯佛能知二乘不及。故今问之。非圣凡夫有众生性皆说有我。是则凡夫亦能知性。云何佛说唯佛能知二乘不及。下佛答之。明凡说我虚妄不真故不知性。于中初先辨妄异真明凡不见。今日如来所说我下简真异妄彰性难见。前中先喻后合显法。喻文有五。一菩萨过去宣说真我众生得闻喻。二王子后时捉持是下迁化他土喻。三于是贫人后于他下寻名妄执喻。四傍人闻下声闻四果征情责实喻。五先逃王子从他国下圣复本化辨邪异正喻。初中二人共为亲者喻凡菩萨。机感相顺故名亲友。一是王子一是贫贱辨前二人。王子菩萨从佛王法之所化生故名王子。贫贱喻凡。贫无善财。互相往反显前亲友。物机顺圣说之为往。圣起称反。贫凡之人从圣闻我名见王子有一好刀。真我无垢说之为净。真我离相故复称妙。理中精上故名第一。闻说爱乐名心贪着。第二段中王子捉刀逃他国者。怀法在心名捉是刀。迁化异境名逃他国。第三段中明诸凡夫于圣灭后外道法中安心住意名于他家寄卧止宿。昏闇心中妄说有我名眠。梦中寱语刀刀。第四段中喻明四果征情责实。前二别论。后二总举。就初果中傍人闻之收至王者。喻七方便摄情诣实。凡夫我心未入圣来恒常成就。我心虽成而于其中得起观解。观与惑俱故曰傍人。自觉己心我想未除义说为闻。须陀圣解说之为王。由观转增心中使性随观诣圣名收至王。时王问下喻圣征情。于中初先自征己心。即问臣下傍推他人。前征自中文别有三。一问得处彼具答之。二问刀相彼具答之。三王闻怪笑。初中先问。答有四句。初言是人具以上答正答见处。二王今设下明今实无。于现身中总别推求我不可得。故言设使屠割臣身分张手足刀不可得。三臣与王下重辨见处。名闻为见。四乃至下重明现在无之所以。乃至不敢解心撑触况当证取为是现无。此初段竟。第二段中王问是刀相貌何类喻问我相。见如羊角喻答不真。第三段中初闻怪笑。语言已下知虚放舍。知彼凡夫所说之我有名无实。假名不实。不须穷断。是故语言随意所至。彼至何处。至于世俗假名法中。假名之我一切皆虚不须征断。故复告言莫生忧怖。我库藏下辨理呵情。谓于声闻法藏之中都无有我。何处当于菩萨边闻。上来自征。下推他人。傍问他人见我以不名问群臣。汝见刀不推穷未竟。须陀心谢名已崩背。寻立已下明第二果征情验实。二果心现名立余子绍继王位。斯陀含果从前习生故名为子。圣智现前统摄诸德咸来归属名绍王位。复问已下征情责实。但问他人。文别有三。一问见不彼答言见。二问见相彼具答之。三王闻怪责故言何处有是相刀。次第已下明后二果征情责实。总举而已。上来第四四果责实。自下第五喻圣复化辨邪异正。待此众生道机熟时。先去菩萨还来现化名后数时先逃王子从他国还来至本土。成佛度人名得为王。既登已下征情责实。文还有三。一问见不彼答言见。二问见相彼具答之。但诸众生计我非一。故今答者种种不同。三王闻怪笑。卿等不见辨邪异正。下次合之。依前五段次第以合。菩萨如是出现于世说我真相合上初段。说已舍去合第二段。喻如已下举喻以帖。凡夫已下合第三段。如彼贫下举喻以帖。声闻已下合第四段。初先正合。菩萨已下举本显今。是诸凡下明今由昔。前正合中先合初问。声闻缘觉合上四王。问生我相合问刀相。次合前答。如是生下合王怪笑呵其不知。先举其法。下以喻帖。菩萨如是说于我等举本显今。由本菩萨宣说真我。故今凡夫种种说我。是诸凡夫次第起见明今由昔。由昔凡夫妄说有我相续至今。故今说我。为断已下合第五段。初先正合。喻如已下举喻以帖。上来第一辨妄异真明凡说我非是佛性故不见性。今日已下是第二段简真异妄明今所说佛性真我非凡所见故性难听。于中先出真我之体。如是性下辨法同喻。上来广明佛性难见。若有凡下明诸凡夫依经善说得名为见。于中初明能善说者言顺佛法。后明说者人是菩萨。从此已下答上云何解满字等。解经由字是以辨之。于中有四。第一如来略言起发。二迦叶白下问答广辨。三迦叶领解。四如来述叹。初中如来何因说言种种异论皆是佛说。因前说我从菩萨闻。故类一切皆是佛说。如来何意作如是语。欲使众生习学文字以知经法故发此言。第二段中初先问答辨字半满。何等名为解了字下明解满字半字之义。前中先辨半满之义然后释文。半满之义泛论有三。一就字体以别半满。彼悉昙章生字根本说之为半。所生余章文字具足名之为满。又十二章悉名为半。自余经书记论为满。二约所诠以别半满。宣说世法名之为半。说出世法以之为满。又出世中说小名半。说大名满。此义如前四相章说。三约所生以别半满。如下文说生烦恼者名为半字生善名满。又生善中生世善者名之为半。生出世善说以为满。就出世中生小乘行名之为半。生大名满。今此文中唯就初门及第三门初义辨之。文中有四。一就字体以辨半满。悉昙一章名之为半。余皆为满。二是故半字于诸经下结彼半字能为满本。三又半字义皆是烦恼之根本下约就所生以辨半满。生烦恼者名之为半。生善名满。四如是一切经书记论皆因半下结满依半。初中有四。一迦叶略问云何如来说字根本。二如来略答。于中初明半字为本。名悉昙章以为初半。持诸已下显其本相。持诸记等明持世法。持诸阴等持出世法。以持此等故名为本持。义云何如。下文说如地如山如云如眼如母等也。凡夫人下寄学显本。学是半字知法非法故说为本。是法犹前诸记论等。凡夫知法必依于字。故偏说之。三迦叶重问字义云何。四如来广辨。于中有二。一别解字义。二吸气下总辨字相。初中应先广辨胡章然后释文。胡章之中有十二章。其悉昙章以为第一。于中合有五十二字。悉昙两字是题章名。余是章体。所谓恶阿亿伊郁忧咽野乌炮庵阿。迦佉伽[口*恒]俄吒咃荼袒拏多他陀弹那遮车阇膳若波颇婆滼摩蛇啰罗啝奢沙娑呵荼。鲁流卢楼。鲁流卢楼外国正音名为亿。力伊离栗离此是初章。问曰。前后两荼何别。前长后短。就此章中迦佉已下三十四字是其字体。初十二字是生字音。末后四字是呼字音。将初十二呼彼迦等生字之时。有单有复。其单呼者依后四中栗离二音。其复呼者用后亿力伊离二音单复呼中并有长声短声之别。故有四音。前后合说有十六音。而经说言十四音者。前十二中后二助音非是正音。故除此二说十四音。初章如是。将初十二单呼迦等三十四字为第二章。用十二音呼一迦字生十二字即为一遍。乃至呼荼类亦同尔。三十四遍合为一章。就复呼中有其十章。相状如何。就彼三十四字体中。前之五五二十五字是其毗声。备如下辨。蛇罗等九是其超声。亦如下说。就毗声中有其五句。最初迦字历配其余三十三字入十二音为第三章。以迦配佉入十二音生十二字以为一遍。乃至配荼类亦同尔。是则合有三十三遍为一章矣。取初句中末后俄字历配其余三十三字入十二音为第四章。第二句中最后拏字历配余字入十二音为第五章。第三句中最后那字历配余字入十二音为第六章。第四句中最后若字历配余字入十二音为第七章。第五句中最后摩字历配余字入十二音为第八章。就超声中具有九字。取前四字历配余字入十二音复作四章。通前合为十二章矣。若以诸字尽具相配入十二音。通合应有三十六章。不能烦广。略举斯耳。今此偏说悉昙一章以为半字半名字本。是义云何。今言半者。以悉昙章显此经中一切义体而未广辨故名为半。依于此义广开以为一部之经方名为满。此半与满大乘不同。向前四相章中。小乘为半。大乘为满。良以是中半亦是大。是故学之得解此经。即此半字与广为本故名字本文中初就恶阿等音以辨字义。次就迦佉伽[口*恒]俄等三十四字以辨字义。后就鲁流卢楼四字以辨字义。就初音中有十二字。而经文中云十四音。义如前解。除却后二加后鲁流卢楼四字为十四耳。文中初音有十四音名为字义总以摽举所言字者名涅槃等总显其义。字者外国名阿察罗此方义翻名为无尽。与彼涅槃常义相同故名涅槃。问曰。此章是外国人世俗所学用表世事。今以何故云涅槃法是其字义。释言。文字诠表不定。用表世事事为字义。用表佛法法为字义。乃至此方急就章等类亦同尔。故今宣说涅槃等法以为字义。下释可知。是十四音名为字本重复摽举。恶者已下别显其义。上来第一别解字义。自下第二总辩字相。句别有六。初吸气等明发字相。二长短等明字体相。初十二字是长短声。前之六字初短后长。后之六字前长后短。其迦佉等二十五字是其毗声。伽佉等五是喉中声。吒咃等五上齶中声。多他等五是舌头声。遮车等五是齿中声。波颇等五是唇中声。随其流类毗比(夫必反)一处故曰毗声。今略不举。后蛇啰等九字是其超声。不同毗声故名超也。三随音解义明字本相。字为义本。故令众生寻之解义。四皆因等明字所依。五如是下明字功能。能令众生口业清净。六佛性下辨性异相。于中初辨。何以下释。是故下结。佛性净故众生同归。性理一故菩萨视生等无差别。上来第一就其字体以别半满。是故半下是第二段结前半字能为满本

又半字下是第三段约就所生以别半满。初先法说。生烦恼者名之为半。生善名满。后以喻显。如是一切经书已下是第四段结满依半。于中初明经书记论皆依半字。若言已下辨真异相。初先辨异。何以下释。是故下结。迦叶初白言来至此明字半满。下次明解。于中有三。一正明解。二若有随下反举不解令人舍离。三是故汝今应离半下劝舍不解令习正解。初中先问何等名为解了字义。知下释。知如来出世灭半字者此如上说。生烦恼者名为半字故佛灭之。亦应知佛显示满字。文略不辩。是故下结。明不解中初明随逐半字之义。后明随逐无字之义。随半字中生烦恼者为半字故。有人随之不能解了如来之性。又诠世谛为半字故。有人随之不能解知如来之性。又诠小乘为半字故。有人随之不能解知如来之性。随无字中先问次辨。辨中初明随逐恶法无有善字。又无字下明随小法不知大乘名随无字。我今已说随逐无字总以结之。上来第二反明不解。第三结劝。文显可知。上来第二问答广辨解字半满。第三领解。第四述赞。文显可知。四谛至此大段第二明其舍相入证之行。自下第三明其证实成果之行。亦名证实起用之行。于此分中具答四问。一答云何共圣行如娑罗娑鸟及迦陵提。二答如日。三答如月。四答如星。答此四问明佛果德。德体难彰寄用显示。用谓三业。答初一问明佛意业起化作用。答后三问明佛身口起化作用。答初问中以所依法常无常等。性不相离。依之成德。德亦如之。是故如来无常共常。常共无常。乃至苦乐类亦同尔。如彼诸鸟不相舍离。文中有二一明如来不舍世间而入涅槃无常共常苦共乐等。前中初略。迦叶下广。略中先喻鸟二总举。迦陵鸳鸯列其名字。游止共俱显其共义。同类不离非是鸳鸯不离迦陵。下约显法。苦无常等亦复如是合前诸鸟不相舍离。此三与彼常乐我等不相舍离。非直此三不相舍离。广中迦叶初问发起云何苦等如彼诸鸟。下佛答之。先辩共法。如稻米下明其共义。是故我言异法常下总以结之。就初段中明苦乐等互相简别。故名为异。第二段中遍明无常共常之义。余类可知。于中五喻。一稻麻等喻。二庵罗树喻。三金非喻。四胡麻喻。五众流赴海喻。五中前四喻明行共。后之一种喻明法共。初中先喻。后合显法。喻中有二。一明喻同法。二迦叶白下简喻异法。明同法中先举喻事。如是种下就之辨共。始时转变故名无常。果熟不变故说为常。以无常中即有常性。故无常转即变为常。何以下释。性真实者彼稻麻等成熟不改故名性实。由说稻等常而性实滥同于法故下辨异。句别有四。一迦叶问此等若常同如来耶。二如来答。先呵后教。呵中不应作如是说以理直呵。何以故下将事类责。汝今不应结呵令舍。教中唯除佛性涅槃简法异喻。亦得名为简真异相。更无一下辨喻异法。亦得名为辩相异实。直以世下释会前语。三迦叶领解。四如来述赞。上来立喻。下约显法。虽修一切皆言无常合上萌芽至华无常。闻是经下合熟名常。何以下释。是名下结。下四喻中皆先立喻后约显法。结文可知。自下第二辩明如来得大涅槃不舍世间常共无常乐共苦等。于中有四。一我共无我。二佛法犹如鸳鸯共下明乐共苦。三异法我下重复明其我共无我。四同诸烦恼所造有下明常共无常。就初段中先辩后结。辨中迦叶先问起发如来无忧何故称忧。于中先明如来无忧。夫忧悲下广举忧悲明佛悉无。何故已下征佛说忧。上来何曾道佛有忧。今作此征。佛前婴孩喻中云言。如女生子婴孩得病是女愁恼。佛亦如是。故今征责。下佛答之。答中论法其唯有二。一明佛无忧。二明随化有忧。无忧是我。有忧无我。喻别有七。一无想天喻。二树神喻。三非想天喻。四虚空舍宅喻。五众生心喻。六是幻喻。七上中下喻。经文有五。一举无想及树神喻约之显法。二举无想及非想喻约之显法。三举空舍众生心识及无想喻约之显法。四举幻喻约之显法。五举上中下人之喻约之显法。就初段中先喻后合。喻中先举无想天喻。后举树神类显无想。前中初言无想天者举其喻事。名为无想明其非有。若无想下彰其非无。以是义下结无定处。以其无想而有寿命故无定处。以此难知故下举彼树神显之。譬如树神依树而住举其喻事。不得定言依枝节等明其非有。虽无定下显其非无。无想如是约后显前。下约显法。句别有三。初佛法亦尔甚深难解总叹显深。二如来实无忧悲苦恼明实无爱即是有我。三而于生下彰化有爱明共无我。第二段中初举无想及非想喻。下约显法。句别有三。一明实无忧即是有我。二若言已下彰化有忧明共无我。于中三句破无显有。三以是义下总叹显深。佛不思等类叹显深。有忧无忧是佛境界正叹显深。第三段中先举空舍。众生心识及无想喻空舍喻中初明不住亦非不住。以是下结。凡夫人下破其定住。于中先举凡夫所见。次破。后释。心及无想类之可解。下约显法。句别百三。初言如来忧悲如是总明不有不无之义。二若无忧下别明非无。三若言有下别明非有。第四段中先举幻喻。下约显法。句别有三。一明佛有忧。二明实无忧无有真实正明无忧。如来已入于涅槃等释显无忧。若谓已下约就愚智取舍得失成佛无忧。三有愁无愁无能知者总叹显深。第五段中先举上中下人之喻。下约显法。句别有四。一举二乘齐知自地合前中人唯知中下不知于上。二如来不尔合前上人能知于上及知中下。悉知自地合知上也。及以他地合知中下。是故如来名无碍智叹以显胜。一切悉知故曰无碍。示现随世显无碍相。三凡夫下举凡不知合前下人。能知下法不知中上。文中偏合不能知上。余略不合。四有愁无愁唯佛能知重合上人能知于上。上来广辨我共无我。以是下结。先结其法。后以喻帖。第二明乐共苦之中文别有四。一明如来得乐共苦利益众生。二是名下结。三诸行苦下明诸众生因佛教化离苦得乐。四以是下结。初中佛法犹如鸳鸯举法同喻。是伽陵下辨喻显法。喻有两句。一是得乐随苦之喻。迦陵鸳鸯喻佛如来。五浊增时名为盛夏。烦恼炽盛名为水长。佛选正法化人令住名选高原安置其子。为养结之。二是舍苦归乐之喻。息化归真故曰随本安隐而游。下约显法。如来如是化无量生安住正法合上初句。如彼已下举喻以帖。如来亦下合向后句。是名下结。第三段中初先辨出苦乐二门。诸行是苦。涅槃是乐。迦叶白下明诸众生舍苦得乐。先问起发。于中但问得乐之义。略不问苦。下佛答之。苦乐具辨。意为明乐举苦显之。文中初先长行略答。次偈后解释。略中我说诸行和合名为老死偏释苦义。举前问中言有左右。但言诸行和合为苦。即知不合是涅槃乐。故不具论。偈中初偈明苦乐果。前半乐果。后半苦果。后偈明其苦乐二因。前半乐因。后半苦因。下广释中初先正解。云何已下就人显之。前正解中。若放逸者名有为法为第一苦释前偈下半。不放逸者名涅槃等解前偈上半。若趣诸行是名死处受第一苦释后偈下半。若至涅槃名不死等解后偈上半。若至涅槃则名不死受最妙乐解不死处。若不放逸虽集诸行亦名常乐不破坏身。解释偈中不放逸者得不死处。随化众生现集诸行实无罪过。是故亦名常乐不死。就人显中先问后辩。文中可知。以是下结以前诸义。故苦异乐乐异苦也。自下第三重明我共无我之义。何故重辨。前说如来我共无我。未明宣说无我所以。故下辨之。于中初言异法是我异法无我总以标举。佛性是我。有为无我。下释有三。一明众生不见真我。二是故下佛随其意为说无我。三所以下释。初中先喻。人喻二乘。在烦恼中名为在地。学求如理名观虚空。但见相空不见佛性名不见迹。下合显法。众生合人。无天眼者喻中无文。非是合前。别明众生不见所由。以诸众生无其第一义天眼故不见佛性。在烦恼中合前在地。仰观虚空略而不合。不见自身有如来性合不见迹。第二句中。言是故者是诸众生不见性故佛说无我。无我覆我名为密教。第三释中先问后解。以无眼者不见真我横计我故。须说无我对以破之。因烦恼下是第四段常共无常。于中先明众生无常。精勤已下明佛共之。前中因烦所造有为正明无常。是故下结。因诸烦恼所造有为是无常故异于常法。常不同此故异无常。下明共中先偈后释。偈文之中前偈上半明佛自住解脱山顶。即是常义。下半见凡。即共无常。一切有为生灭理齐故说为平。是凡住处目之为地。凡未入理故名旷野。佛于此处常见凡夫。就后偈中初之三句明佛日住智慧台殿除灭忧患。即是常义。亦见生忧名共无常。由见众生心常忧念名见生忧。释中有三。一略释偈文。二问答广辩。三难解者问答重显。略中如来悉断烦恼住智山者释前偈中初之两句及后偈中前之三句。断无量恼住智慧者释后偈中初三句也。言住山者释前偈中初二句也。见生常在无量烦恼释前偈中后之二句及后偈中末后一句。广中先问。迦叶白佛所说不然牒以直非何以故下显不然相。先自征问。后其相显难辞有二。一对后偈中初之三句以为征问。难意如何。有忧喜人可须升彼智慧台殿以防忧患。佛入涅槃无忧无喜。何须升彼智慧台殿。二复当下对彼前偈及后偈中见众生忧而为征问。难意如何。住解脱者不见我人众生等相。云何如来住解脱山而见众生。下佛答之。先解前难。释意如何。智慧台殿正是涅槃。佛住是中故无忧喜。云何难言佛无忧喜不应升彼智慧台殿。文中初明智慧台殿即是涅槃。后明如来住之无忧。于中初明如来无忧。有忧愁下举凡有忧显佛无之。须弥山下释其后难。释意如何。明佛虽住解脱山顶随化众生所以见之。文中有三。一释前偈中初之二句明佛自住解脱山顶。二地者下释前偈中后之二句明见凡夫。三如来愍下释后偈中末后一句明见有忧。前中初言须弥山者谓正解脱。解释偈中山顶言也。勤精进者喻须弥山无有动转。解释偈中精勤勇者处于山顶。以无动转故名为住

第二段中句别有四。一解其地。谓有为行。平及旷野略而不论。二是诸凡下解释凡夫。三其智惠下解释见义。佛智惠者正觉凡夫在有为地造作诸行故名为见。四离有下释于常义。离有常住名曰如来。是故如来常见凡夫。上来四句合为一段。解前偈中后半偈竟。第三段中具足应释见众生忧。直释有忧。略不解见。若更解见。不异前故。如来愍生为毒所中正解有忧。是故下结。第三问答重显之中迦叶先问。如来有忧不名等觉。下佛释会。皆有因缘总以释通。随有已下别以释通。随有众生应受化处于中示现释成有忧。虽现已下释成无忧。如迦陵下举喻对显

上来明佛意业作用。下约日月星宿三喻明佛身口二业作用。于中初约日月二喻明佛身口化现之用。后约星喻明佛身口化灭之用。就月喻中文别有六。一明如来体无起尽示有生灭。二如此满月余见半下喻明如来体无亏盈示有增减。三如满月一切现下喻明如来体无差别应物有众。四如罗睺下喻明如来体无衰损示受侵恼。五如月六月一蚀下喻明如来体无修促示有长短。六如明月众生乐见下喻明如来体无违顺示有乐厌。就初段中先喻后合。第二段中先喻次合。如是众生所见已下重辨前喻。如来身下重约显法。第三段中先喻后合。第四段中文别有三。一正明如来体无衰损示受侵恼。先喻后合。二如二人下明化受恼害者无罪。于中先喻。次约显法。如来如是于未来下结明化意。三如良医勤教子下明化所为为制戒律故受侵恼。先喻后合。喻中有二。一当时善教。二灭后得益。合中亦尔。先合现教。欲令比丘于佛灭下合后得益。后两段中皆先立喻。后合可知。就日喻中文别有三。一喻佛身业。二如来所说方等已下喻佛口业。三而如来性实无下结。身中先举三时之喻。后约显法。口中有三。一明如来所说大乘于未来世传法之人利益广多犹如夏雨。二明如来所说小法令二乘人多生厌离犹如冬雨多致冷病。三明如来所说大乘微密教诲能令菩萨善芽开敷犹如春雨多有出生。结中偏就身业以结。身无长短。为世间故示有修促。实无长短。即是诸佛真法性身。下约星喻明佛化灭。喻事有三。一是昼星不现之喻。二阴闇日月不现之喻。三是彗星夜现之喻。于中初喻正答上问。后二举之助以显法。昼星一喻喻佛灭后二乘不见。先喻后合。二乘倒想如彼日光映障如来不能得见。阴闇彗喻佛灭后凡夫不见。阴闇之喻正明灭时凡夫不见。先喻后合。彗星之喻明辟支佛出现世时凡生灭想。闻辟支佛出无佛世故生灭想。于中先喻。次约显法。而如来下明实不灭。上来教圣趣菩提行。自下第二明教凡夫趣菩提行。于中有二。一明法力得菩提义。二庵罗树观三宝下明其修力得菩提义。前中有三。一明法力令人发心。二如佛说不见义下法力起行。三如大船下法力得果。后中亦三。至时当辨。法力发心答上问中云何未发心而名为菩萨。今明经力令人发心故为菩萨。于中有四。一明经力灭罪发心。二迦叶白如佛所说大涅槃光入毛孔下出其分齐除一阐提。三迦叶白云何未发菩提心者作菩提因下就上初段明经令人发心之相。四如空中兴大云下就前第二广显发心分齐之相除一阐提。就初段中先明经力令人灭罪。如日月光诸明最下明经力故令人发心。前中四句。一经力灭罪。二是大涅槃甚深已下叹经深胜。三以是义下劝人修学。四是故此经名无量下重叹经胜。前中初言譬如日中众雾悉除喻经灭罪。后合可知。第二叹经。文相可解。第三劝中应于如来生常心等劝人正知。是故应当多修是典劝人勤学。是人不久常得已下明其正知勤学之益。第四叹中是故此经无量德成叹其德广。以修习者当得菩提。故为无量功德所成。亦名菩提不可尽者叹其德常。以前三宝不断灭故名不可尽。以不尽故名大涅槃以常显大。有善光下以广显大。善光用广。身无边者明其体广。具此二广名大涅槃。上来灭罪。第二令人发心之中先叹经胜。初喻。后合。何以下释。令人发心故得为胜。言入众生诸毛孔者。凡夫众生善根狭小。受法之器犹如毛孔。是故就名心毛孔。经亦入身中令其发心。是故下结。以能广益名大涅槃。第二发心分齐之中迦叶先问。问中有二。一牒上后段经力发心对彼四依而为征问。二又如佛下牒上初段经力灭罪对彼四依弟子为问。前中初言大涅槃光入生毛孔作菩提因是义不然牒以直非。何以下释。先自征责。后显非意。犯四禁等光明入身作菩提因与净持戒有何差别责下同上。此名四依为净持戒修诸善者。犯罪闻经即能发心与彼何别。若无差别如来何故说四依义以问责别。若无差别。如来何故偏说四人为物依止。不说犯禁五逆等人为世依乎。第二难中若闻涅槃一经于耳则断烦恼如来云何先说有人恒沙佛所发菩提心不解义者举此征前。如来前于四依章中宣说熙连乃至三恒佛所发心闻经不解。故今对之而为征问。诸罪人等一闻涅槃能灭烦恼。何故前说恒沙佛所发菩提心闻经不解。若不解义云何能断执前征此。心不见理乌能断结。下佛答之。但答初难。后难自遣。故不别解。答意如何。明今闻经能发心者即是义趣。上品之人闻经能解一分之义。是故经力能令其人除罪发心。非极凡下一阐提等云何得知。唯是四依上品弟子。上说有人四恒佛所发菩提心方能解于一分之义。解义之人方能灭罪。今闻经者能灭重罪。明知是善解义之人非。是余者故下说为大菩萨矣。文中有三。一简定其人除一阐提。余闻能作菩提因缘。阐提有三。一下品阐提断一切善。二中品阐提无出世善。三上品阐提。虽少求出邪谤未舍今皆除之。二法声已下明由闻经得菩提果。由闻此经进入住分。是故必定当得菩提。住分即是习种已上。问曰。此人云何许闻定得菩提。如下第二功德中说不作闻相不作声相不作字相不作句相乃至不取一切法相故得菩提。非取相闻堪能得之。三何以下释。释中有三。一明久供多佛善人得闻是经薄福不闻。问曰。供殖几许诸佛得闻是经。释言。闻经义通始终。今此所论是其解义能灭罪者。当应供养四恒诸佛方得闻矣。二所以下释显前句。所以薄福不得听闻。此涅槃经是其大事。大德之人能闻大事。斯下不闻。是故薄福不能得闻。三何等下辨前大事。先问。次辨以是下结。自下第三就上初段明经令人发心之相。迦叶先问。云何未发作菩提因。下佛为辨。于中文别六句三对。一明人违经。言我不用发菩提心诽谤正法。二是人下明经益人。令于现在梦睹罗刹发菩提心。后生余道续复忆念。良以是中不信为过。是故梦睹罗刹怖之。下明经法为良医中行犯为失。是故令其梦堕地狱。此是初对。三当知下明前被怖发心之人是大非小。善趣中极故言是大摩诃萨也。四以是义下结明经力益人之义。此第二对。五是名菩萨发心因下结明菩萨发心所由。六以是义下结叹经法。是真非伪以能益人。故知是经真佛所说。此第三对。自下第四就上第二广明发心分齐之相除一阐提。喻别有十。相从为八。第七第八共显一义。第九第十共显一义。余各为一。是故言八。八中前四正明令人发心之相除一阐提。后之四喻还成前四。就前四中初一明共一阐提人无受法心。是故此经不能令发。先喻后合。第二彰其善根难生。先喻后合。第三明其恶心难清。先喻后合。第四明其罪障难治。于中初明能益善人。后明不能利益阐提。前中先喻。喻文有二。一明能治。二不念下明无简别一切普治。又复前段能治恶业。后治烦恼。前中药树喻涅槃经。名曰药王药中最胜喻此经胜。若和已下喻明能治。独法不治。要与行心相应乃治。是以说言若和酪浆若蜜苏等。此喻常乐我净等观。别观名末。总观称丸。涂疮喻戒。熏身喻定。涂目喻慧。听闻名见。受行曰嗅。能除罪业故曰能灭一切诸病。就后段中初不作念一切生等喻无简别。虽不生下喻明能灭一切烦恼。下合显法。先合初段。涅槃如是合前药树。能除一切众生恶等合和酪浆。乃至除灭一切诸病。意恶名内。身口名外。此明灭恶。诸有未发菩提心下明能生善。喻中无文别以论之。何以故下合前药王诸药中胜。先合后帖。下合第二。若有修习及不修者合不作念一切众生若取我根不取叶等。若闻敬信烦恼皆灭合能除灭一切病苦。下明不能利益阐提。先法后喻。自下四喻重成前四。从后向前次第成之。初之一喻成前第四明一阐提无受药器故药不治。先喻后合。其次一喻成前第三明一阐提恶心难破故不可清。先喻后合。其次二喻其显一义成上第二明一阐提善根难生。于中先明余人善根可以还生不同阐提。先喻后合。如佉陀下明一阐提善根叵生不同余人。先喻后合。末后两喻共显一义成上第一明阐提人无受法心。先喻次合。后喻重显。自下第二明其法力令人成行。于中初明灭罪之行。譬如莲华为日照下明其对治灭烦恼行。前明灭罪。即是答上云何于众而得无畏。今明菩萨忏悔灭罪。故于阐提大众之中独得无畏。文中有三。一明阐提可畏。二云何见下明菩萨无畏。三从作恶不即受下明一阐提不畏所以并教菩萨对治舍畏。初中迦叶先举昔偈请佛解释。如佛说偈总以标举。不见善等正举偈辞。初之两句明可畏事。言不见者明无正行。言唯见者明有邪解。恶可作者明有邪行。第三一句结成可畏。末后一句喻显可畏。有何等义结请令答。下佛为释。前之两句一处释之。先解初句。次解第二。文显可知。以是故下双就前二明其不能趣向善法。于中初先总明阐提无心趣善。何等已下别以显之。先明善法。趣涅槃下举善显恶明无趣向。是处已下释第三句。是处可畏谓谤正法出所畏事。谁应已下出其畏人何以下释。何故余人不生怖畏唯是智者。以谤法人无有善心及方便故。无有善心彰其无行。及方便者明其无解。崄恶已下释第四句。谓向生死有为诸行。第二菩萨无畏之中迦叶初问如佛所说总以标举。云何见等正举偈辞。初之两句明无畏行。见所作者是自利行。自见已罪忏悔发露名见所作。云何得善是利他行。何处不怖正明无畏。如王夷道喻以显之。是义何谓结请令答。下佛为解。第二一句回之寂后。自余三句在前解释。见所作者牒举初句。发露下释。但解所作略不解见。发露诸恶从生死际悉皆发露随相忏悔。至无至处灭罪相忏。观罪空寂究竟到于无所至处。是故名为至无至处。以是义下释第三句。恶因既尽故无所畏。如王已下释第四句。先举其喻。后约显法。复次已下释第二句得善法义。于中初先广就阐提明其不见一切所作。若菩萨下用已善根回向摄取为得善法。前中有三。一明阐提不能自见已之所作。先明不见。是一阐下明其不畏。以是义下彰无所得。二假使下明诸如来亦复不见阐提所作。谓不能作阿耨菩提。三又复下明一阐提不能见于如来所作。先问后辨。所谓不见如来所作总明不见。下别显之。别中两句。一不见佛口业所作。说生有性阐提不见。先辨后结。二不见佛身业所作。见应无常。不知真身常存不变。先辨后释。下明菩萨回向摄中初以已善施与阐提。何以下释。自下第三辨明阐提不畏所以并教菩萨对治舍离。先举偈文。作恶不即受如乳即成酪辨明阐提不畏所以。乳得醪暖交变成酪。作恶不尔。现在造作未来方受。不能即时交受苦果如乳成酪。犹灰覆火愚者轻蹈正明无畏。现报如灰。当苦如火。现报隔障说之为覆。愚人轻欺造恶临逼名之为蹈。下释有四。一明阐提诈说大乘诽谤小乘以为作恶。二如王使下教诸菩萨弘法舍离。三有一阐提作罗汉下明一阐提诈说小乘诽谤大乘以为作恶。四是故当知大乘已下叹经殊胜令人习学对治前过。就初段中先明作恶。下明所作不即受果如乳成酪。灰覆愚蹈略而不论。前作恶中文别有三。一明阐提实不见小无慧目故。二如罗汉下实不学大。两喻两合。如阿罗汉不行生死喻一阐提不学大乘。无目下合。如阿罗汉勤修慈心喻一阐提勤舍大乘。一阐下合。三若人说下诈说大乘诽谤小乘。先明谤小。信受大下诈说大乘。初明说大。是人虽下明实不信。如是说下结以显过。如是恶人不速受果如乳成酪释第二句。自下第二教诸菩萨亡身弘法以治前过。初先立喻。王喻如来。使喻菩萨。能宣法化名善谈论。善顺物机名巧方便。受佛委付传化末代是故名为奉命他国。传佛真言亡身不改故云宁丧不匿王教。下合显法。智者亦尔合前王使。善论巧便略而不合。于凡合前奉命他国。不惜已下合前宁丧不匿王教。自下第三明一阐提诈小谤大。先明作恶。就中初明诈小谤大。诸凡夫下明凡不识。谓真罗汉是大菩萨。是一阐下广显其过。初明身过。见他得下明其心过。作是言下明其口过。上明作恶。是人作下明不即受如乳成酪。如灰覆火愚者轻蹈。自下第四叹经殊胜令人习学治舍前过。初先法说。是故当知大乘经典必定净者是谤大乘名邪恶故当知大乘必定净也。次喻后合。下明对治烦恼行中。初答处浊不污如花明人依法能离烦恼。后答云何处恼不染明法资人能治烦恼。前中三喻。一莲华喻。二优钵罗喻。三清风喻。莲华一喻正答上问。后二乘举助以显法。此三喻中初喻生善。先喻。次合。是故我下举说证成。彼一阐提下彰其分齐除却阐提。第二明其所生善法不为惑染。先喻。次合。何以下释。第三风喻明能灭惑。先喻。次合。后除阐提。如良医下答上云何处恼不染。如医疗病不为病污。医师疗病若不除愈污其医道。差则不污。经法如是。若不能治众生烦恼污经势力。除则不污。此明经法资人灭惑。文中初别。后总结叹。别中经文有十复次。初八复次法为良医。后二明其诸佛菩萨人为良医。意为明法。法藉人通。故说人矣。法中四对。初二复次大小相对。举小显大。辨大过小。次二复次就其所生解行相对。前一生解。后一起行。次二复次理教相对。前一复次教能资理。后一复次理能资教。后二复次就所摄化难易相对。前一复次易化善人经能摄益。后一复次难化恶人经能强益。就初对中前一复次举小显大。先喻后合。喻中良医喻小乘经。解八药者正是八术。八中有药名解八药。喻小乘中备合药法。灭一切病喻能治惑唯除必死彰其分齐。明不能治犯四禁等。合中契经诸定如是合前良医。能治一切合灭一切。而不能下合除必死。小乘力微不能广治。故犯四禁五无间等望于小乘齐名必死。不同大乘唯说阐提为必死耳。下一复次明大过小。先喻后合。喻中良医喻涅槃经。过八术者明大过小。能除病苦喻治烦恼。不治必死除却阐提。合喻可知。第二对中初明生解。先喻后合。喻中良医喻涅槃经。以药治盲令见日等喻能生解。唯不能下彰其分齐。合文可知。下一复次明能起行。初先正辨。迦叶白下问答重显。前中初喻。次合显法。后简阐提。喻中良医喻涅槃经。善解八术喻备治法。下显治能。先治烦恼。女人产下明治恶业。治烦恼中句别有二。一明经能治。二贫愚下明经强治。前中为治一切病苦出其所治。与种种等彰其能治。与种种方授其教法。吐下诸药授以行法。行能遣障名吐下药。涂身起戒。熏药生定。灌鼻已下明起智慧。受法灌鼻。别观名散。总观称丸。下强治中凡夫众生无福称贫。无慧曰愚。闻经不受名不欲服。经能亲益名贤愍念。令于梦中观见地狱名将还舍。地狱是其罪人归处故名舍宅。怖令信受名强与服。法力遣障名所患除。明治业中三罪之人能生出世菩提心子故说为女。起菩提心名为产时。三罪婴缠说为儿衣。不能除遣故云未出。授以法药名与令服。三罪除遣名为已出。除障行立名令婴儿安乐无患。合中涅槃亦复如是合医解术。所至之处合医治病与种种方吐下药等。若至舍宅合贫愚人不欲服之。将还舍宅强与令服除无量恼合以药力所患得除。犯四禁下合女产时儿衣未出与服即出。未发心下合令婴儿安乐无患。除一阐提彰其分齐就下问答重显之中先问。次答。后除阐提。迦叶发问执小征大。犯四禁等于小乘中名为极恶名断多罗。云何能与作菩提因。下佛答之。答意如何。犯四禁等其罪虽重。经之威力能使其人梦堕地狱生悔发心。是故能与作菩提因。文中有二。一明现益。二犯四禁下明其当益。现中有五。一明经力益人之相能使其人梦堕地狱。二因见生悔。三悟已生信。信知此经有大果报益人之力。是其经法功用之果名大果报。非余果也。四如彼已下明心成已领荷法恩寄喻显之。菩提之心从障始出。如彼婴儿随修增长名渐长大。知法神验故云常念是医最良。信此经中具明治法名善方药。自念本昔在障未出名本在胎。发心之人说之为母。经法被人名与母药。人得法故出离苦患名身安稳。以人安故菩提之心坚固不坏。故云以是我命得全。五奇哉下明心成已领荷本昔修行者恩。起行酬报借喻显之。念本行者在重恶中而能发求出离之心。是故叹言奇哉我母。勤发大心名受大苦。多时渐习名满十月怀抱我胎。生心之后谨意防护令其离过安住善法故言生后推干去湿除去不净。听法资助说之以为乳哺长养。坚守大心不令小乘异见沮坏名护我身。以是义故理须酬报。依心起行令彼行者离苦永安义云报恩。色养侍等显报恩相。子于父母和色瞻养名为色养。菩提之心顺益行人义云色养。常随行人说为侍卫。起行利人名随供养。上来五句合为现益。当益可知。如此得益唯是善人故除阐提。第三对中前一复次明教资理如咒咒药。后一复次明理资教如药涂鼓。前中先喻。良医喻此大涅槃经。医子喻佛。佛德从于经法出生故名医子。于此经中辨义渊邃名知深奥。具明治法名知除毒无上咒术。若恶毒等出其所治。蛇喻四重。龙喻五逆。蝮喻谤法。下明能治。教法如咒。教显治法名咒药良。用法资人名涂革屣。得法之心能灭诸罪名触毒虫毒为之消。准合是中文少不足。若具应言以咒药力身得安乐。唯除一毒彰其分齐。下次合之。涅槃如是合前良医。良医之子略而不合。所知深奥乃至除毒无上咒术亦略不合。若有众生犯四重等合恶毒蛇若龙若蝮。悉能消灭合以咒术咒药令良触诸毒虫毒为之消。如药下帖。未发心下合前所少身得安乐。唯除一下合除一龙。理资教中初先正辨。如闇已下叹经殊胜。前中先喻。有人喻经。以杂毒药用涂大鼓喻理资教。以佛菩萨亲所证理资成教法名杂毒药用涂大鼓。对众宣唱若众人中系之发声。虽无心下彰其治能。唯除一人彰其分齐。下合显法。涅槃如是合如有人毒药涂鼓。在在处处诸行众中合众人中击之发声。为有行者宣说是经。是以说言诸行众中。有闻声下合闻皆死。然向喻中直明无心欲闻皆死。有心欲闻及不欲闻皆悉不论。今此合中具以论之。初言有闻贪等皆灭明初地上上品之人闻经灭惑。如彼众中有心欲闻闻之皆死。其中虽有无心已下明种性上中品之人闻经灭惑。如彼众中无心欲闻闻之皆死。彼种性上虽不觉知涅槃经力能灭烦恼。法力薰资冥使灭惑。犯四禁下明种性前下品之人闻经灭惑。如彼众中不欲闻者闻之亦死。此下品人得益同前。言亦为作菩提因缘渐断烦恼。除不横下合除一人不横死者。上来正明理法资教。下叹经胜。文有三喻。前二明能利益善人。后一彰其不益阐提。就前二中日喻明其起因之益。先喻后合。两喻彰其得果之益。先喻次合。如法华下指余显此。下明不能益阐提中先喻后合。第四对中前一复次明其有信易化善人经能摄益。后一复次明其无信难化恶人经能强益。前复次中初明经法能益善人。如聋人下明其不能利益阐提。前中先喻。次约显法。当知是人真菩萨下辩定其人。喻中如医喻涅槃经。闻他人子举其所益。名佛如来以为他人。佛所化众名他人子。以法对人义说为闻。非人所持须益所以。三罪婴缠名非人持。寻以药下喻经能益。于中三句。一明教益。二卿若迟下明其理益。三若彼下双明理教二种利益。就初句中寻以妙药对治行法。并遣使者是其教法。从理发教传其对治行法授人义云遣使。摄化之仪具彰在诠义称敕使。起教专为传法授人。故言卿持此药与彼。彼人闻法罪障消除。故言若遇诸恶鬼神以药力故悉当远去。第二句中卿若迟晚教益不速吾自往者理显物心。有机必摄故言终不令彼枉死。第三句中若彼见使牒上初句。及吾威德牒第二句。苦除得乐彰其利益。次合显法。涅槃如是合上良医。若比丘等合他人子。有能受持如是经典乃至为作菩提因缘超合见使及吾威德苦除身乐。若犯四禁乃至毒持却合向前非人所持。法从喻称故说四重及五逆罪以为邪鬼。闻是经典诸恶皆灭合以妙药并遣一使乃至终不使彼枉死。如是医下举喻以帖。下辨人中句别有四。一明前比丘乃至外道为经益者真是菩萨。二何以下释。先征后解。以得闻经及能念知如来常故。闻经即是向前见使。念常即是向前见医。三暂得闻下举始况终。暂得闻经尚得如是念如来常何况书等。四除阐提下彰其分齐。除一阐提余皆菩萨。善趣已前通名阐提。下明不能益一阐提中先喻次合。何以下释。下一复次明无信人经能强益。于中初益有道机者。知必死下简去阐提。前中先喻。良医喻经。一切医方无不通达喻此经中具明治法。兼复广知无量咒术喻经威力。力用广多故曰无量。是医见下明其治能。文有三对。一始化不信。于此经中显物机病义称为见。所化众生自在如王。说彼众生过有重罪定堕地狱。故言王今有必死病。下明不信。不信之情反经称答。过往之罪冥伏在身现不可睹。故言不见我腹内事云何而言有必死病。二重劝不用。以法对机义称医答。闻经不受名不见信。劝修治法是故说言应服下药。障除乃觉故言下后王自验之。彼闻不用名不肯服。三强化乃受。尔时良医重举此经。以咒力者喻经威力。令王粪门遍生疮者令彼未来恶报相现。未来苦报是彼罪人后分之果。是故说为粪门疮疱。梦中睹见故名为生。饿鬼畜生种种苦难梦中皆现名为兼下虫血杂出。睹之生畏名王见已生大怖惧。赞彼已下荷恩赞叹。下合显法。涅槃如是合前良医乃至广知无量咒术。于诸众生有欲无欲悉能令彼烦恼崩者合医见王乃至[病-丙+帶]下虫血杂出。此中唯化无欲众生。有欲前化今乘举之。是诸众生乃至梦下合见生怖生乃至敬医犹如父母。先合后帖。下简阐提。先喻后合。上来广明经法为医。下二复次以人为医。经由人传是以论之。前一复次通说诸佛菩萨为医。后一偏说佛为良医。化凡之医义通上下。故前通说诸佛菩萨以为良医。教圣之医局唯在上。故后偏说如来为医。前中先喻。良医喻于诸佛菩萨。善知八种喻备化德。悉能疗等明其化能。唯不能下简去阐提。下合可知。后中先喻。次合显法。后简阐提。喻中如医喻佛如来。善知八等喻自知法。善知八术喻知小乘后过八术喻知大乘。下明教他。先教小乘。如是渐下喻教大乘。合中如来合前良医。应正遍知合知八术乃至博达过于八术。下合教他。初明教小。先教其子诸比丘等谓声闻人。方便除恼教其离障修学净等教其摄治。修学净身不坚固想教无常观。谓水陆下教其苦空无我等观。先牒前喻。下约显法。水喻身苦如水上泡。陆喻身苦如芭蕉树。山涧喻于烦恼无我如涧空虚。下明教大。如来如是教弟子等牒前生后。合上渐渐教八事已。然后已下正明教大。为其子下合次教余最上妙术。上来广辨良医之相。是大乘下结叹显胜。前所辨中有人有法。以法为主故偏叹之。于中初先当法正叹。当知已下约喻显胜。第三法力得果之中义别有二。一明如来外化行果。二如蛇下辩明如来自利行果。前明外化。即是答上生死大海中云何作船师。今明如来得涅槃船周旋往返济度众生。故能于彼生死海中得作船师。文中有二。一明涅槃以之为船佛为船师正答上问。二如人在海欲度已下乘说涅槃为之为风。彼涅槃中有证有教。证能济度故说为船。教能击发故说为风。前中有二。一明如来得涅槃船能渡众生。二如有船下明其化益本末次第。前中先喻。船喻涅槃。从此至彼喻从生死到大菩提。从彼至此喻从菩提还至生死。次合显法。如来如是合乘船人。乘大涅槃正合前船。周旋往返合此至彼合彼至此。在在已下辨明化益。以是下结。化次第中先喻后合。就说涅槃以为风中。文别有二。第一正说涅槃为风。二如人不遇风王已下明涅槃风思求乃得不求不得。前中先喻。如人在海乘船欲度喻须风人。若得顺下明得风益。若不得下明不得损。下合显法。先合须人。若得值下合得风益。若不值下合不得损。后中先喻。如人不遇久住大海喻不值损。作是思下喻求法心。如是念下喻得法益。作是言下喻庆善辞。下合显法。先合初句不遇之损。未遇如是大涅槃下合求风心。是诸众生如是求下合得风益。方知真下合庆喜辞。先生奇想。次叹善哉。后生净信。下明自德。即是答上云何舍死如蛇脱皮。今明如来随化示灭其实不死故如蛇矣。文中有二。一明如来如蛇脱皮其实不死正答上问。二如金师下乘明如来得实起用体常不变。前中四句。第一如来立喻反问。二迦叶正答。第三如来举法反问。四迦叶正答。文显可知。后中先喻金师喻佛。得好真金喻得真实缘起法身。作种种器喻起化身。次合显法。如来亦尔合前金师。于二十五下合作诸器。初先正合。为化已下辨真化意。是故下结。虽复示现常住不变合好真金。自下第二明其修力得菩提义。于中有三。一起观解二迦叶白云何当得不坏已下依解起行。三如来为生作父母下依行得果。前观解中初观三宝趣实之诠。今此纯陀犹有疑下观三乘性所入之理。如地持中。于八解处而起观解。今且说四。三宝为三。三乘之性即是彼中真实之义。前观三宝答上云何观三宝矣。今明三宝随物转变而实常在。如天意树随天意转而实不死。先观佛宝。于中有四。一如来立喻反问迦叶如树三变实灭不耶。二迦叶正答。第三如来约之显佛。四迦叶述赞。后观法僧。于中但明法之盛衰。僧随法说更不别论。能兴法者即是僧盛。能损法者即是僧衰。故不别说。文别有三。一明经法兴废所由。二无有不求男子身下就兴废时明经有力无力之别。三如过夏名秋已下明废兴处。初中先明法兴所由。由有智者解佛密语。如波罗奢下辨明经法衰废所由。由无敬信加情不学。前中初法。次喻后合。下总结之。法中但彰如来密语甚深难解。略不明其智者能解。喻合等中皆具论之。喻中先喻。如来密语有智臣下喻智能解。前中告臣先陀婆来总喻密语。王喻如来。臣喻菩萨。先陀喻佛一切密语。非有所局。下别显之。于中初先牒总开别。次列四名。如是下结。先陀山名。于此山中出好盐器水马等事。将处目事。是故四种同名先陀。下次明其智人能解。智臣善知总明能解。若王洗下别明能解。如是下结。合中先合王之密语。大乘如是合先陀婆。准合求之。彼先陀婆所况之法有总有别。总喻大乘。别喻如来法僧解脱及与佛性。理实通喻一切密语。且论斯耳。良以所况有斯总别。故今合中总以大乘合先陀婆。下明智人能解之中。举佛法等五种之法合先陀婆。有四无常合有四实。此大乘中具有八实。说佛法僧解脱佛性权化之德有无常苦无我不净。说佛法僧解脱佛性真体常乐我净等义。是为八实。若通空有具有十实。今此且举无常等四以合前喻。是故但言有四无常。盖乃是其不尽语也。四中唯一是其无常。今云何言有四无常。释言。辩义有二种门。一分相门。唯一无常苦等则非。二摄相门。无常为主统摄诸义悉成无常。苦等亦然。今据摄相。是故四种俱名无常。下次合其智臣能解。先合初总。次合其别。后合结文。大乘智臣应当善知是合初总。若佛出下是合其别。别中有五。一就佛宝明解密语。二就法宝。三就僧宝。四就解脱。五就佛性。此五种中皆有权实。权中具有无常苦空无我等义。实中具有常乐我净善有等义。但今文中就前四种彰权隐实。就后一种彰实隐权。文之左右。又前四中权义齐通。但今文中就初佛宝偏说无常。就法说苦。就僧偏说无我之义。就解脱中偏说空义。盖亦是其文之显隐。就佛宝中若佛初出为众生说如来涅槃合索先陀。佛涅槃中备含多义。虽有多义总名涅槃。是故此言似总先陀。智臣当知此是如来为计常者说无常等合前智臣奉水等也。菩萨智者能解佛语从喻名臣。下皆同尔就法宝中或复说言正法当灭合索先陀。正法灭中备含多义。虽有多义统名法灭故似先陀。智臣应下合奉盐等。由法灭故人多造恶受诸苦报。故偏就之以明苦也。就僧宝中或就我病众僧破坏合索先陀。此正明僧举佛助显。众僧破中备含多义。虽有多义总名僧坏故似先陀。智臣当知为计我者说无我等合前智臣奉器等也。众僧破坏虚假义显。是故就之偏明无我。就解脱中或说空者是正解脱合索先陀。智臣智下合奉马等。以正解脱离有相显。是故就之偏明空义。前辩空义彰其所解。下不动等出其所密。于中有三。一明解脱是不动义。初举。次释。是故下结。二明解脱亦是无相。初举。次释。故名下结。三明解脱亦是其常不变易义。初举。次释。是故下结。解脱之中备此多义。佛偏说空是以言密。或说一切众生有性合索先陀。于佛性中备含多义。虽具多义总名佛性故似先陀。智臣当知此是如来说于常法欲令修常合奉水等。于多义中偏显如来说常之意名解密语。是诸比丘各解已下合后结文。于中先合。如彼智臣义知王意举喻以帖。上来合竟。下次结之。先结密语。如是大王亦有密语牒举前喻。何况已下约之显佛。是故已下结成佛语难解之义。下次结其智人能解。唯智能解简圣异凡。非凡能信彰凡异圣。上明法兴。下彰衰废。于中有三。一明众生不敬故废。二如来正法将灭已下明诸众生不学故废。三牧牛女下明诸众生加情故废。初中先喻。波罗奢等值旱不生喻此经废。水陆所生皆悉枯等喻余经废。次合显法。涅槃如是合波罗等。不敬合旱。无威合后不生华实。水陆生等略而不合。何以故下释前不敬。以不知故。者何已下释前不知。以薄福故。第二段中初明众生不学故废。唯菩萨下简圣异凡。前中初法。不知无解。懒堕无行。次喻。后合。哀哉已下如来伤叹。当来可畏伤其学小。苦哉已下伤不习大。圣简下中初明菩萨自取实义。后为他说。第三段中先喻后合。喻中有四。一妄加已情喻。二诣市已下妄说授人喻。三取还家下薄淡无味喻。四虽复无下校量显胜喻。初中有其四重加水。人说种种。今且约就一斗论之。初加二升。后三亦然。初牧牛女喻其正法垂末众生。余牧牛女喻彼像法初时众生。近城女者喻彼像法垂末众生。近于末法故曰近城。城中女者喻末法时传法众生。巧伪多故未必专定。大况粗尔。第二段中文别四句。初诣市卖在众宣唱喻。二有一人下行者餐受喻。其真修行者言为子者为于无上菩提心子。言纳妇者纳诸行妇。当须好乳瞻宾客者喻须好法以授众生。诣众听受名至市买。三是卖乳下多索利养喻。四是人答下听者别知喻。此第二竟。第三段中纳法在心名取还家。思惟简择名煮作糜。都无正理名无乳味。第四句中虽复无味于苦千倍明胜小乘。何以下释。合中还四。合初段中先别后总。别中初言我涅槃后诸恶比丘抄略是经分作多分合初加水。如彼六卷小泥洹是。是人虽读灭除要义安置一世间庄严之语合第二加水。抄前着后后着前等合第三加水。先合后呵。受畜不净言佛听许合第四加。水上来别合。如牧牛下总合显过。先举其喻。后约显过。杂以世语错定是经令人不得正说正学。是恶比丘为利养故下合第二段于中但合多索价数。余略不合。如彼卖乳贫穷女下合第三段。先牒前喻。后约显法。虽无味下合第四段。初先正合。如彼下帖。何以下释。喻如下帖。以是下结。上来第一正明废兴。自下第二就废兴时明经有力无力之别。初就兴时明经有力。如蚊子泽不能令下。就衰废时明经无力。前中有三。一明世人无有不求男子身者。今虽不求当必求之。二何以下广显女过成男可求。于中初先总彰其过。女是众恶之所住处。如蚊子下有四复次别以显之。三以是义下劝人学经舍女成男。于中有五。一正劝学经舍女成男。二迦叶领解。三佛述叹。四迦叶谦逊。五如来重赞。初中有四。一劝学是经呵女求男。二何以下释。以此经中有丈夫相故劝修学以求男身。谓佛性者是佛法身本体证之。然后成第一雄猛无上大夫。故须修习求男子身。三若人下辩男女相。泛辩有三。一就形分别。形相可知。二就心分别。刚决为男。柔弱为女。三就解分别。解真为男以正直故。不解为女以邪曲故。今据后论。文有四句。一明男子不知佛性则无男相。先辩后释。二明男子不知佛性佛说为女。女则亡言。三明女人能知佛性佛说其人有丈夫相。四明女人能知佛性佛说为男男。则亡言。此之四句合为第三。四是大乘下叹经劝学。先叹后劝。上来四段合为第一。后四可知。下就废时明无力。先喻次合。如蚊子泽不能沾洽众生心地。下乘明其法灭尽相。此经先灭当处不行名没于地。当知已下明此灭时余经悉灭。自下第三明兴废处。此经遍盛在南天竺先喻后合。废在罽宾。句别有四。一正明灭处。罽宾有王名弥罗堀。然付法中师子比丘传法人丧故令法灭。此小灭处。大灭在于拘腅弥国。二明灭时人心不同有信不信。三明此经灭尽之时余经悉灭。何故而然。以此经中具辨邪正彰其佛说魔说之别。有此经时邪不滥正。故令一切诸经得住。此经灭后邪说滥真。故令一切余经悉灭。四告得法菩萨令知。欲使弘护所以告之。上明三宝。下次观察三乘之性。此文答上三乘无性云何得说。彼问如何。若使三乘无别体性。云何而得别说三乘。佛今答之。明三乘人同一佛性更无别性。无别性故一乘之外无别二乘。故下文言世若无佛非无二乘得二涅槃。一切世间唯一佛乘故无二乘别得涅槃。此文虽答迦叶上问。兼遣纯陀无常之疑。由释彼疑是故文殊重问发起

文中有六。第一文殊举纯陀疑请佛释通。二佛遣出疑许为除断。三文殊正问。四如来释通。五文殊领解。六有难解者迦叶对佛问答广论。就初段中今此纯陀犹有疑者总举彼疑。疑由何生。由前佛答五难而起。佛前答云。未见佛性名无常身杂食身等。如来已于无量劫来已见佛性。纯陀向前还家办供。路中思量如来常住。以得知见佛性力者。无量劫前未见性时应见无常。若本无常后亦应尔故生此疑。对上五难故言犹有。纯陀何故不自请决令文殊问。文殊即是纯陀导首。知疑为请正是其宜。何足可怪。如地经中解脱众首知众深疑为之偈请。于此相似。唯愿分别请佛释通。第二可知。第三段中纯陀心疑如来常住以见佛性牒佛上言。下就设难。若见佛性而为常者本未见时应是无常以后推前。若本无常后亦应尔将前类后。何以故下举事类征。以是义下结以显过。同皆无常故与声闻缘觉无别。文殊上来举彼纯陀佛上之疑令佛解释。文殊是中亦自有疑。疑彼凡夫二乘人等为当与佛一向定别。亦有究竟无别之义。故下文言文殊师利将欲问我。我知其意即为宣说。文殊师利即得解了。又复下言不但正为纯陀说偈亦为文殊。故知文殊今亦有疑。文殊玄知佛释纯陀疑心竟时已疑亦遣。故默不问。第四释中初举偈正答。本有今无本无今有自立道理。此之偈义随人不定。若就佛论。佛于过去无量劫前名之为本。即就彼时说之为今。佛于过去无量劫前有生死身名为本有。当于尔时无常法身说为今无。佛于过去无量劫前无常法身名为本无。当于尔时有生死身说为今有。若就凡夫二乘论之。望于当果宣说未成佛前为本。还即说此未成佛前以之为今。彼于现在有生死身名为本有。无常法身说为今无。又于现在无常法身名为本无。现有生死无常之身故曰今有。三世有法无是处者破他定义。此言不足。若具应言三世无法亦无是处。此偈随人亦复不定。若就佛论。佛本所有生死之身。三世恒有无是处故今已断离。本无法身三世恒无。无是处故佛今已得。若就凡夫二乘论之。彼本所有生死之身三世恒有无是处故当必除断。彼本所无常住法身三世恒无无是处故当必修证。以是义故。诸佛菩萨声闻缘觉亦有差别亦无差别就人结答。以前偈中所辩义故诸佛菩萨声闻缘觉亦有差别亦无差别。将此偈义就佛解释。交异二乘故有差别。是义如何。如来本昔所有生死三世恒有无是处故。无量劫来断之已竟。佛本所无常住法身三世恒无无是处故。无量劫来修成已竟。此异二乘故有差别。将此偈义就二乘解。当同如来故无差别。是义云何。声闻缘觉本有生死三世恒有无是处故未来当断。二乘所无常住法身三世恒无无是处故未来当得。当断当得与佛不异故无差别。道言差别释去向前纯陀所疑。如来生死三世恒有无有是处佛今断竟。何得难言佛本无常后亦应尔。常住真法三世恒无无是处故佛今证得交异二乘。何得难言如来无常与彼二乘一向无别。道言无差。释去文殊自己所疑答并迦叶偈中之问。声闻缘觉当舍无常当证常法共佛无异。释去文殊心中之疑。二乘之人当同佛得。何得难言三乘之人各别有性。第五文殊领解可知。自下第六有难解者迦叶对佛问答重显。有何难解。向前虽说人有差别无差别义。佛性差别无差别义犹自未显。故下辩之。于中有二。一问性无差如来广释。第二云何性差别下问性差别如来广解。前中有三。一明三乘佛性无差别。二迦叶白若一切生有佛性者佛与众生有何差下明三乘人得果无别由性一故。三我今始知差无差下迦叶领解。前中迦叶先问起发。如佛所说佛菩萨等性无差别唯愿广说利益众生。下佛答之。先敕。后解。文别有三。一约乳喻明性无差。二约金喻明性无别。三于前义中有难解者重复明之。前中先喻。喻有四句。一三乘差别喻。二是人后时为祀祠下就相辩性喻。三见其乳色同一白下始见惊怪喻。四是人思下久思悟解喻。初中长者喻佛如来。若长者子喻大菩萨已证性者。多有诸牛喻三乘众生。三乘相异名种种色。付一牧人委行化者。守护将养令其摄化。第二句中是人有时为祀祠等释有二义。一约佛以解。言是人者谓长者人喻佛如来。为祀祠者谓以性理养诸贤圣。尽构诸牛着一器者尽说三乘同有佛性。显在一诠名著一器。二约所委菩萨以释。言是人者谓牧牛人喻修行者。为祀祠者为资菩提。尽构诸牛着一器者具观三乘同有佛性。显一观心名著一器。第三句中见乳同色寻便惊等释有二义。一对上初义就佛所化凡夫二乘以释其言。凡夫二乘闻佛宣说三乘性一名为见乳同一白色。执相疑性名寻惊怪牛色各异乳云何一。二对上后义约就修行菩萨以解。修行菩萨证性一味名见其乳同一白色。执相疑真故言寻怪牛色各异乳云何一。第四句中是人思等释有二义。一对上初义约就凡夫二乘以解。凡夫二乘久后思量知由诸圣显性行同故令性一。如人思量犊子众生感乳业同故令乳一。二对上后义约就修行菩萨以释。修行菩萨久思由圣显性行同故令性一。此三句中虽各二义。准下合文初义应善。下说声闻凡夫疑故。下合显法。声闻缘觉菩萨亦尔合初句中多有诸牛有种种色。第二一句略而不合。同一性下合第三句。于中先合见乳一色。同一佛性正合前喻。犹如下帖。所以下释。而诸众生言佛以下合寻怪等而诸众生言佛菩萨声闻缘觉而有差别合寻惊性牛色各异。有诸声闻凡夫之人疑于三乘云何无别合乳云何皆同一色。是诸众生久后解下合第四句。先合后帖。第二段中初先立喻。金矿喻于三乘之人。陶炼滓秽消融成金喻除妄染而得成佛。成佛可重名直无量。次合显法。声闻缘觉菩萨亦尔合前金矿皆得成就。同一佛性合融成金。何以故下合炼滓秽。先问起发。何故同一。除烦恼故释同所以。如彼金下举喻以帖。是以下结。终成不殊故始性一。自下第三重复显前初段中义。明前疑人久后思量得解所由。由闻涅槃秘藏故解。于中初辩。如彼已下举喻对显。声闻凡夫后成佛时。如彼长者知乳一相而不怪也。何以故下释前知性同一所由。由断烦恼。自下第二明由性一得果无别。举果无别成无别乘。迦叶先难。难中有二。一难同使别。二若诸众生皆有性下难别使同。难同使别为彰二乘现无所得。难别使同为显二乘当同佛得。前中若生有佛性者牒佛前言。佛与众生有何差别约性征相。性理既同众生共佛有何差别。如是说下结以显过。佛同众生上下混滥名多过咎。就后难中句别有二。一以性同征破别得。若诸众生皆有佛性何因缘故舍利弗等以小涅槃而般涅槃。乃至菩萨于大涅槃而般涅槃。二以性同责不同得。如是等人若同佛性何故不同如来涅槃而般涅槃。亦有经言不般涅槃所谓不般二乘涅槃。下佛答之。文还有二。一对上初难明佛涅槃二乘不得故有差别。于中初辩。以是义下结大异小。二乘已得数灭涅槃不名得佛大般涅槃。故大般涅槃名为善有。二世若无下对向后难明二乘人无别得果当同佛得故无别乘。于中还二。一对向初征明舍利等无别涅槃。二如汝言下对向后责明二乘人当同佛得。前中初言世若无佛非无二乘得二涅槃。反明二乘无别所得。若正应言一切世间唯一佛乘故无二乘得二种涅槃。此犹经中十方佛土唯一佛乘无二无三。迦叶言下问答重显。迦叶先问是义云何。下佛释之。释意如何。明无量劫乃有一佛出现于世。由佛难出。为化众生权开三乘而度脱之。非实有三。所以言无。第二段中如汝所言菩萨二乘无差别者牒前问辞。迦叶于向初番问中说言菩萨声闻缘觉性无差别唯愿广说。佛今将欲述其所问辩明三乘所得无别。故今牒之。我先于此已说其义诸阿罗汉无有善有明二乘人现无别得。佛于向前四相章中说诸罗汉所得涅槃犹如灯灭无有善有。故今指彼明二乘人所得非有。亦可次前宣说如来善有涅槃二乘不得。今指彼也。举现无得成其当来同佛得矣。何以故下正明二乘当同佛得。言何以故征前起后。何故罗汉现无善有。诸罗汉下释后显前。以其当得大涅槃故故现无之。于中初先正明罗汉当得涅槃。以是义下结叹涅槃为毕竟乐。以诸罗汉究竟所归。故知涅槃有毕竟乐。是故已下结叹涅槃以之为大。三乘同归故得名大。自下第三迦叶领解。前两段中就后领之。迦叶初言始知差别无差别义略言领解。声闻缘觉现无善有名为差别。当同佛得名无差别。何以下释。遍释无别。于中初法次喻后结。同证涅槃故悉名常。以是义下结成差别无差别义

上来第一问性无差如来广释。自下第二问性有差如来广解。性体虽一约缘有异故须辩之。于此文中有三问答。初问性差。如来遍就圣人答之。第二迦叶就凡重问。如来为辩。第三以凡对圣为难。如来为释。初问可知。如来答中先别后结。别中约人就喻显异。声闻如乳。缘觉如酪。菩萨如似生熟二苏。地前如生。地上如熟。亦可七地已还如生。八地已上如似熟苏。佛如醍醐。以是下结。就菩萨中生熟两分应有五阶。合故云四。第二问中一切众生性相云何偏问凡夫。下佛还复约喻答之。先喻后合。以此通前。喻别有六。始从杂血乃至醍醐此六况法。前劫不定。凡有四别。一义如向。第二如后迦叶中说。凡夫佛性如杂血乳。须陀斯陀断少烦恼如出血乳。那含如酪。罗汉佛性如似生苏。缘觉菩萨如彼熟苏。佛如醍醐。第三义者。凡夫二乘及大乘中善趣佛性如杂血乳。种性解行如出血乳。初地如酪。二地已上如似生苏。八地已上如似熟苏。佛如醍醐。第四义者。解行已前如杂血乳。初地佛性如出血乳。二地已上佛性如酪。八地已上性如生苏。后身佛性如似熟苏。佛如醍醐。末后二义义有文无。文虽不说理必有之。第三番中迦叶初先举凡对圣难佛所说。如佛向说凡性不如声闻性胜。凡性既劣。如来何故说拘尸城欢喜旃陀贤劫作佛。声闻性胜。如来何故不记舍利及目连等速成佛道。下佛答之。答意如。何彰彼欢喜虽为旃陀实是菩萨。佛于诸圣随愿迟速与记不同。欢喜旃陀以发速愿故与速记。非记凡夫不得为难。文中有三。一明如来随愿迟速与记不同。有声闻等愿久护法则与迟记。若发速愿便与速记。二如商人下明随化宜不得授彼声闻速记。三以是下结。就初段中文相可知。问曰。声闻缘觉之人安能速成而说速愿与速记乎。释言。二乘定入大乘。于入大后成有早晚故说迟速。第二段中先喻后合。喻中四句。一佛说声闻速疾成佛喻。商人喻佛心。中备具菩提胜法是故说云有无价宝。名声闻众以之为市。以大菩提授声闻人云其速成。令使行因以筫其果名诣市卖。二愚人见下声闻轻笑喻。如世人言何处当有无价之宝市中唱卖。所说如是。何处当有大菩提果授声闻人云其速成。三宝主唱下如来称赞喻。云授汝者是大菩提。四闻复笑下凡夫轻笑喻。合中声闻缘觉如是合第二句。初先正合。如彼下帖。于未来下合第四句明凡轻笑。以是义下第三结之。前两段中就初以结。上明观解。下次起行。初明自行。迦叶复曰何因缘下明利他行。前明自行答上云何得不坏众。文中迦叶初问起发。上虽为问去问既遥。将答重请上下多然。下佛答之。精勤护法便与护法菩萨行同。不可求异名得眷属不可破坏。亦可是中唯明利他。上来一段明摄人行。由勤护法物皆乐从故得眷属不可破坏。自下明其开化之行。此即答上云何为盲作眼目导。于中有二。一明众生无法自沾唇口干焦菩萨须润。二明众生盲无惠目菩萨须导。后之一段正答上问。前乘论之。前中先问。下佛为辩。于中初法次喻后合。后中四句。一明凡夫不知佛常犹如生盲。二若知下举圣显凡彰彼地前信行菩萨能知佛常。佛说其人虽有肉眼而名天眼能见佛常。名为第一义天眼也。此前一对。三复次若有能知已下举大显小。彰彼地上证行菩萨能知佛常。佛说是等名为天眼。四虽有天下明小异大。彰二乘人不知佛常。虽有天眼而名肉眼。先辩次释。乃至不识自身手足明不自见佛性真我。佛性真我是已体性名为自身。真性三归已所依用说为手足。不能见此故名肉眼。不令他识明不见他。以不见他真身手足故名肉眼。以是下结。此后两句复为一对

自下第三明行得果。于中有二。一明如来随类异说。二如人生下随机巧说。随类异说答上云何示多头矣。于中初明如来为生而作父母。所以下释。种种形类以一音说各各得解解释有三。一就真论一。如来以一法蠡声说。众生于中各各得解。如一真身众生异见。常寂之声是法蠡声于净耳者无时不闻。于不净耳无时暂闻。故曰常寂。二约法论一。佛说一苦众生于中各各异解。集灭道等一切皆然。故经说云佛以一音演说法众生各各随所解。三约方言以论其一如来具作一梵音说。众生于中各各得解。余亦如是。故经说言佛以一音演说法众生随类各得解。今此所明据后言之。以是下结

自下第二随机巧说答上问中云何说者增如月初。准此验前前问颠倒。若正应言增如初月。亦复不足。若具应言云何说者增长众生如世父母教于初生十六月儿。小儿初生十六月时言语未了。父母为教示同其言。佛亦如是。为教众生。先同不正。后示正语。文中有四。一立喻反问。二迦叶正答。三约喻显法反迦叶。四迦叶正答。先答后释

一切大众所问品者。上来广明菩提之因。下次明其涅槃之因。因诸大众请以论之。就斯以显故云大众所问品也。于此品中文别有三。第一如来现相起发。二时天人阿修罗下明诸大众伤叹为由。三尔时世尊为慰喻下对之显法。初中复三。第一如来催供起发。二尔时世尊欲令一切众生满下受供起发。三尔时树林其地狭下食供起发。就催供中文复有三。一放光直催。二因众遮抑放光重催。三因纯陀请住口言更催。初中三句。一光照纯陀。二纯陀遇光持供奉佛。三天人遮抑。初先身遮。后便口抑。第二催中句别有六。一光照大众。二大众遇光寻听纯陀。三大众时供进诣佛所求请如来听比丘受。四比丘知时执持衣钵欲受其供。五纯陀为佛庄严处所令三千界如安乐国。六纯陀重复启请佛住。文皆可知。第三催中。句别有二。一佛口催供。二大众闻已仰庆纯陀伤已不果。上来催供。第二受中句别有四。第一如来为满众望化无量身受大众供。二释迦自身受纯陀供。三纯陀大众见佛神变心生欢喜。四大众念佛受供当灭心怀悲喜。初段可知。第二段中初明释迦自身受供。次明纯陀所供多少。纯陀有力实能多献。为显佛力令众尊敬。故献斯耳。下明佛力充足一切。依如余经佛有三身。一者真身谓法与报。二者应身应现受形修道成佛。三是化身依应起化。然今文中化身受供即是化身。释迦受供即是应身。下偈所说真身常住即是真身。此第二竟。第三段中纯陀先喜。后类大众。第四段中承佛圣旨作是念者。因此悲念广有发起。故承圣旨以兴念也。旨犹意耳。念佛受已当入涅槃是故生悲。庆蒙受供所以欢喜。此第二竟。第三食中先明住处小能容多。后明所食味无差别。此等皆是涅槃法门缘起示现不可事取。故下大众知见此事名知法性受法乐矣。此初段竟

第二大众伤叹之中。时天人等啼泣悲叹总以标举。下出叹辞。而作是言乃至当复更供养谁伤已更无值福之处。从今永离盲无眼目伤已更无生智之处

自下第三对之显法。于此文中具答七问。答初一问明涅槃果。答后六问明涅槃因。明涅槃果。答上问中云何复示现究竟于涅槃。问意如何。如来今者究竟入于尽灭涅槃。云何复常示现世间教化众生。佛今答之。明已终不究竟涅槃。故常示现在于世间真得名为大涅槃矣。问曰。向前哀叹章中已具明其涅槃果竟。今此何故重复明乎。解云。前辩涅槃体常。未曾宣说涅槃用常。故须明之。又复上来明菩提因。今此若不举涅槃果对之显因。因与前滥。为别其因故须标举涅槃之果。又复上说菩提因中多皆举果对之显因。是故前明得长寿中举果显因。此亦似彼故须举果。就明因中答前三问明其证行。答后三问明其教行。契会常住是其证行。通教权实是其教行。证行自利。教行利他。就证行中初答云何示人天道正明证体。第二超答云何离病明其得证除障之益第三起答云何知性而受法乐明其得证生乐之益。后教行中三问通答。文中从初尽偈已来答初两问明涅槃果并显证体。偈后长行答次两问明证利益。今者如来欲为未来作大明下答后三问明其教行。前中初言为慰大众而说偈者明说偈意显佛常住止其悲情名为慰耳。下明慰辞。依此文中有其二十一行半偈。外国本中唯十三偈。初十四偈两两为一。即作七偈。次两偈半复合为一。通前八偈。末后五偈各别为一。故有十三。良以方言不同故尔。外国偈法字句含多。此方略少。为是翻译多少不等。于中随义分以为四。初之两偈许说涅槃。其次两偈许为说导。次十三偈半正说涅槃。末后四偈正为说道。前中初半开晓众心。中间一偈举已所得常乐涅槃。后半许说。第二段中初之一偈举涅槃果说为说因。准验此文。定知此品明涅槃因不须致疑。中间半偈明说利益后半劝修。第三段中十二行半合为六偈。正说涅槃。前之十行两两为一。后两行半合之为一。一一偈中皆先立其假设之喻。次约彼喻反明如来毕竟涅槃。后翻彼喻正明如来不入涅槃。不入涅槃是佛常住善有义也。末后一偈结劝止悲。是佛常住不灭义故。应乐此法不应啼哭。第四段中分之为四。初一偈半教修正道。次有半偈明修利益。次有一偈结劝修习。后之一偈结叹显胜。前中初偈劝观佛常。先劝后教。后半教劝。法僧亦常。以前类后是故通言三宝皆常。文显可知。第二益中是获大护法说明益。真常三归能护众生故名为护。覆护中胜是以言大。由正知故为彼覆护是以言护如咒生果喻说显益。三宝如咒。身如枯树。归真三宝能成行德。如咒枯树能生果实。第三段中是名三宝是结词也。余是劝也。初劝听受。次劝生喜。后劝发心。第四段中初半牒前。计犹劝也。三宝皆用真谛为体名同真谛。下半结叹。此是出世菩提心体名上誓愿。与地经中愿善体同。次下文中先答云何离一切病。尔时天人阿修罗下答上云何知性受乐。前中初明远离心病。若有能知三法常下远离身病。见实除惑故离心病。证常灭苦故离身病。前中四句。一明依前最上誓愿而发愿者无有愚痴诸惑皆遣。痴为患本故偏说之。二明其人堪受物养。三明其人于世最上如阿罗汉。此谓如佛阿罗汉也。四举失显得。不能观察三宝常住。以无常想坏灭三宝。是故其人如旃陀罗。离身病中若有能知三宝常住明治病行。离苦安乐明无内病。无娆害者明无外病。答知法性受法乐中文别有三。一明大众知性受乐。二明迦叶知性受乐。三明纯陀知性受乐。大众知性证入初地。迦叶纯陀入第十地名为受乐。明众知中初正明众知法受乐。知佛常下荷恩供养。前中四句。一明天人阿修罗等闻法身喜。二灭除垢障善灭诸盖。离烦恼障心无高下。远离智障证实平等。远离分别染净等心故无高下。三由灭障威德清净。四由心喜颜貌怡悦。此即初观喜地相也。与法华中诸菩萨等闻佛寿量得益相似。论释彼中间说寿量得菩提者初地证智。此得欢喜正与彼同。喜相在初故此论之。后迦叶等知法性中更不明喜。就明迦叶知法性中。如来初先试问起发。迦叶后答。已见总答。下别显之。于中八句。一见无量化佛受供。二见佛众住处无碍。三见大众闻偈发心。其文颠倒。若正应言复见大众闻佛宣说十三偈法悉发誓愿。四知大众各谓如来独受其供。五假使下知彼纯陀所献微少佛力普充。六知此事唯菩萨知。七知此事如来巧现。八知大众悟解佛常。此等皆是依三昧心入佛境界相应名见。非唯事相目睹而已

就明纯陀知法性中文别有四。一如来问。二纯陀答。三如来为辩。第四迦叶领解随喜。纯陀答中实尔总答。下别显之。于中四句。一见前化佛相好严身。二今悉下见彼化佛变为菩萨体貌镶异。亦可见前人天大众闻偈发心悉为菩萨。三见释迦身如药树。四见为诸菩萨围绕。佛为辩中初明向前所见诸佛是已化作。为益众生令喜故为。四明向前所见菩萨行德不思能作佛事。后明纯陀所成行位。迦叶喜中初尔佛语。后明随喜

上明证因。自下明其教行之因。通教权实用化众生是其因也。于此因中答上三问。一答说密。二答说竟及不毕竟。三答断疑。云何不定通答不别。文中有三。第一迦叶领前问后。如来略答。二纯陀文殊迦叶广问。如来广答。三迦叶领解。如来述赞初中迦叶先问发起。今者如来欲为未来作大明故说大涅槃是领前也。一切契经说有余义无余义耶是问后也。下佛答之。诸经所说有所不了名为有余。显义决了称曰无余。有余答上密不毕竟。无余答上不密毕竟

广中先对纯陀文殊明有余义。何等名为无余义下对彼迦叶明无余义。欲令已下总结说意。有余义中七番举偈。人云六度。初偈是檀。次二是戒。次一是忍。次一精进。次一智慧。后一禅定。求相微隐又不次第。未必专依六度门说。但是经中有余之言泛举会通

初偈约就布施之言以明有余。于中合有八番问答。纯陀初问布施一切皆可赞叹是义云何。如来答之。唯除一人余皆可叹。二纯陀重问云何除一。佛答如此经中破戒。第三纯陀问其破戒。佛为辩之。谓一阐提余施可叹。第四纯陀乘言更问阐提云何。佛为辩之。于中初明向阐提人。唯除已下简义异恶。前中初明谤正法人趣向阐提。次明四重五逆之人趣向阐提。后明谤无三宝之人趣向阐提。第五纯陀问非阐提破戒之相。如来为辩四重五逆谤法人是。第六纯陀问此破戒可救以不。下佛为辩明其可救。于中初总次别后总。有缘可拔是初总也。若被下别。别中有三。一犯重可救。二谤法可救。三五逆可救。前中先明犯重之人可救之行。行别有五。一惭愧自责生改悔心。二起护法意。三见护法者身往供养。四见读诵者身往听受。五自通利已广为他说。我说已下明其可救。于中如来先说其人不为破戒。何以下释。由经灭罪故非破戒。初喻。次合。是故下结。就谤法中初先明其忏悔可救。若犯已下明不忏过。前中先明可救之行忏悔归法。句别有四。一略明悔过。二略明归法。三自今已下广明悔过。四除此下广明归法。譬如世人依地而倒还依地起。谤法亦尔。于法起谤还依法灭。若能已下举施得福成其可救。不忏过中道言若犯如上恶者谤法之恶。犯已下至一月半月覆藏不忏。施之福少。何况多时。就五逆中初先明其忏悔可救。后明其人不悔之过。前中先明可救之行。惭愧生悔起护法心。下明可救。先说其人不名五逆。若施已下举施得福成其可救。不忏之过文显可知。上来别竟。下次总明前三罪人可救所以。于中初法次喻后合。法中偏明四重可救合中通说。四重五逆谤法一种略而不辩。法中犯重。汝听我说敕听许说。应生已下教生善心。若施已下举施得福成其可救。喻中五句。一造过流转喻。二在一下依教生善喻。三闻其下怀善归本喻。四中路下逢苦不退喻。五命终下赏善得果喻。初中如女喻三罪人。能生善子故说为女。内有道机名曰怀妊。道心将发故言垂产。如来藏性是所依处说以为国。造过迷覆名国荒乱。流转生死名逃他土。第二句中天庙喻于大涅槃经。依经发心名在天庙即便生产。第三句中闻说佛性常乐我净名闻旧邦安隐丰熟。怀善趣向名将其子欲还本土。第四句中修时逢苦名路值河。苦切陵人名水暴急。持善不失名负是儿。行修之始未能免苦名不得度。赏善至死故云自念我今宁与一处并命终不独度。人丧道废故言念已母子俱没。第五句中命终生天喻得菩提。以慈念子欲令得度明果由因。而是下结。合中四重五无间罪合上初句。生护法心合第二句。虽复已下合第五句。第七纯陀问彼阐提能生悔者施得果不。下佛先呵。后为辩释。释中有二。一明阐提断善根故不可得生。不可生故不能自悔敬养三宝。二以是义下明供其人不得大果。前中如来初先立喻。次问纯陀。后纯陀答。下佛约之显彼阐提。前立喻中人喻阐提。阐提先断方便之善名为食果。未断生得故云吐核。犹成在心义言置地。而复念下断生得善。缘彼善中无因果理以为美胜。故言核中应有甘味。邪心缘善名为还取。谤无坏善名破尝之。由断善故名利断绝。众苦皆集名味极苦。逢苦追变名心悔恨。畏失现在得乐之国名失果种。口还说有名即收拾。念虑在心名种于地。数说有善名加修治。又引三藏成有善义名苏油乳随时溉灌。反问可知。纯陀答中不也总答。下广显之。彼人设续大涅槃经善亦不生故言假使天降甘雨亦不生也。下佛约之以显阐提。阐提如是合前人也。烧燃善根合前食果破核尝等。当于已下合种不生。初先正合。若生已下反以合之。自下第二明施阐提不得大果为辩斯义。乘以通明一切布施果报差别。于中初总。何以下释。是故下结。总中初言以是义者以彼阐提烧燃善根不可还生。布施其人无大报故。一切所施非无差别。释结可知。第八纯陀征说所由。一切所施果报既别。如来何故昔说此偈言一切施皆可赞叹。下佛为辩。于中四句。一正明所因。二亦为下兼明所为。三如斯偈下为释偈义。四当知下以理正劝。就初句中有缘总答。王舍城下别以显之。彼优婆塞心无净信。疑施无报。来问如来佛欲令其修行布施。故说此偈。后三可知

第二偈中佛先举偈。文殊次难。后佛释通。初中如来昔为诫约波斯匿王妃后太子故说此偈。两偈上半诫约妃后。两偈下半诫诸王子。以其慢高故须诫之。一切江河必有曲者喻诸妃后谄曲向王为王宠爱不应慢高。一切丛林必名木者喻王自在必受安乐。王子未同不应生慢。女人必谄合前上半。自在必乐合前后半。文殊难中从座起等启诸方便。下出难辞。于中有三。一直非前偈。二佛所说下总诸佛解。三何以下别难前偈。言何以故征前起后。于此已下显有余相。先明前偈上半有余。文别有二。一举事正征。于此有河端直不曲举事征言。如是河下明佛未说。唯愿已下请佛解释。令诸已下明说有益。二譬如下责说不尽。先喻。次合。虽作已下请佛会通。一切丛下明其前偈下半有余。先辩后释。一切女下明其后偈上半有余。先辩后释。一切自下明其后偈下半有余。先辩后释。有自在者转轮圣帝如来法王不属死王简去乐者。十地所作转轮圣帝同法王不属死魔可使安乐。释梵已下明余无常不得言乐。若得常下举常显之。如来释中文别有三。一叹问敕听。二譬如下明说为物自言无过。三尔时下赞问所为。初段可知。第二段中初喻次合。以是义下结成有余。喻文有二。一量宜授法喻。长者喻彼妃后太子。身婴病苦喻起慢过。良医喻佛。观机名诊。为说治法名为合药。病者贪多喻彼所化过分求法医语已下喻佛量之。二汝勿谓下自言无失喻。合中还二。先合初段。文殊已下合其后段。前中初言如来亦尔总合前医。为诸王等合前长者。因波斯等合婴重病。为欲调等合医诊之。故说偈等合为合药。合后段中初劝文殊知佛无失。如此已下重显无失令其信受。结文可知。此第二竟。第三重叹。文相可知

第三偈中文殊先问。文殊复说经家叙列下显问辞。辞中有四。一举佛昔偈。此偈本为世王说之。阿阇世王为调婆达教令杀父还来责佛。云何如来听其出家使其教我为此恶事。佛时偈答。于他语言随顺不逆教用佛语如法悔除。亦不观他作以不作遮抑世王责佛之言。不须观佛作与不作。但自观身善不善行。二如是说下总非佛语。三于他语下随别以征。先征如来。初之半偈于他不逆。唯愿正说请令正解。何以故下彰昔不正。言何以故征前起后。世尊常下显不正相。佛毁外道自叹弟子。云何得名于他不逆。声闻向正叹小乘人。若护戒等叹大乘人。如来何故于九部下征后一偈。于彼小乘九部经中见有毁他即便呵啧。云何说言亦不观他作与不作。四如是偈下总以结请。佛答有二。一明此偈不为一切唯为世王。二复次下明此兼为持戒人中见他过者不为好心治他过者。前中有四。一明此偈不为一切唯为世王。二若无因下泛明诸佛非无因说将来类已。三阿阇世下正明本昔说偈所因。世王害父不自克责反来责佛。如来有智熟见调达无量世来常欲害佛。云何如来听其出家。故我答之。初先偈答。佛告已下直言呵啧。四以是下结说所为。第二段中初明此偈为持戒中见他过者。若复已下明其不为受他教诲转教他者

第四番中初佛举偈。如来本昔可诫猎师故说此偈。次文殊问。后佛释通。门中文殊先反佛语。非一切畏杖非一切爱命直非佛语。怒已为喻勤作方便道佛无实勤作如是。方便之言不尽道理。次明如来所说不尽。何以故下显不尽相。初先征问下广显之。先明初句畏杖有余。彼阿罗汉转轮王等无能害者。云何说言一言畏杖。问曰。经说害阿罗汉犯于逆罪。今云何言如阿罗汉无能害乎。释言。罗汉现在报身乃是凡夫分段业果。理亦可杀。彼未来世变易法身不可杀害。今论此也。勇士已下明第二句爱命有余。若言恕下明后半偈是其有余。先牒偈文总显有余。何以下释。过有三种。一以已喻彼阿罗汉人则有见已同凡之过。同彼凡夫有其我想及以命想。若有此想则应拥护。不听他人打骂毁辱。二以已喻彼凡夫便有见阿罗汉同已之过。见阿罗汉同已行人。凡夫造作生死诸行故名行人。故上文言崄恶道者谓诸行也。若见罗汉同已行人则是耶见死入地狱。三以已喻彼凡夫便有同罗汉过。云何同乎如阿罗汉不害众生。众生亦应不害罗汉。而诸众生杀害罗汉。不同罗汉不害众生。云何得名以已喻彼。如来释中文别有三。一述前问明凡与圣不得相喻。我想在凡。无杀害想在阿罗汉。二明昔日说偈所因。勿谓无因而逆说者明非无因。昔日已下彰有所因。因于猎师杀鹿请佛故说斯偈。说前一偈咒愿猎师令同佛寿。亦可此言咒愿彼鹿。说后一偈呵诫猎师令舍杀业。三叹文殊能问密教

第五偈中文殊先问。如来后释

第六番中如来先举昔所说偈。此偈本为女人说之。彼女厌离属夫之苦。故佛为说。一切属他则名为苦令厌女身。一切由已自在安乐令求男子。一切憍慢势极暴恶诫诸男子令舍慢高。贤善之人一切爱念令诸男子修贤善行。次文殊问。先总明佛所说不尽请说因缘。何以故下随别以征。言何以故征前起后。如长者下显不尽相。于中先明初偈有余。文别有三。一举学以征。二如王子下举不学以征。三是故下结非昔说。初中三句。一举学事审问如来。如长者子从师学时为属师不。二若属下约之征偈。若属师者义不成就征前半偈。明属他者苦义不成。由从师学得知见乐。云何说言属师则苦。若不属下征后半偈。明安乐者一切由已自在不成。若不属者亦不成就明安乐者由已不成。此人所有知见之乐从师学得则非不属。不属之义既不成就。如来昔言由已安乐明是有余。若得自在亦不成就明安乐者自在不成。此人所有知见之乐从师学得则非自在。自在之义既不成就。如来昔言自在安乐明是有余。三是故下结成有余。第二段中句亦有三。一举世人不学之事。譬如王子无所综习明其自在。触事不成彰有闇苦。是亦自在结明初句。愚闇常苦结明后句。二如是下约之征偈。若言自在义亦不成征下半偈明自在者安乐不成。彼虽自在愚闇苦故乐义不成。若言属他义不成者征前半偈明有苦者属他不成。此人虽有愚闇之苦而不属师。以是义故有苦之者属义不成。三以是义故结成有余。此二段竟。第三结非。文中可解。下次征问后偈上半。先牒偈文明是有余。次辩。后结。下次征问后偈下半。先牒偈文明是有余。次辩其相。如人内犯四重禁等先恶后善。持法之人见已不爱。若有贤等先善后恶。护法之人见亦不爱。以是义下结非圣言。佛答有三。一明如来有因缘故说有余义。二有女下正明所因。三善哉下叹问所为

第七偈中文殊先问。文殊复说经家叙列。下出问辞。问辞有二。一举佛昔偈。如来本昔为羖羝德而说此偈。彼习自饿。佛欲教之修八戒斋。故说此偈。一切众生依饮食存。非彼外道习自饿法。一切依食云何自饿。一切大力心无嫉妒佛自免过。佛非外道。似有嫉妒。故自勉过明已大力。虽非外道而非嫉妒。一切因食而多得病劝修斋法断数数食。一切修行而得受乐教修八戒。二约之征佛若言因食而得病者。佛今受彼纯陀饮食将无如来怖畏病苦。佛答有四。一略反前偈明非一切二释答前难。若诸众生因食得病。即令如来同之有病。汝得病苦我亦应得。汝得病苦而我不得。世间众生因食得病。云何令我同之畏病。三何以下广显前偈非一切义。言何以故征前起后。我以何故言非一切。下对显之。先明偈中非一切生皆依食存。句别有三。一总明如来及圣弟子悉皆不食。问曰。罗汉辟支佛人云何不食。释言。此等现在报身是其凡夫分段业果犹须食资。度此身后未来所受变易之报更不须食。又阿罗汉有实有化。实者须食。化则不须。故下文言我诸弟子不可思议。故不须食。二若言下别明如来身无羸瘦得金刚身故无所食。三我弟子下别明弟子不可思议故无所食。下次明其非一切大力心无嫉妒。先牒偈文明其有余。如世人下反以显之。无嫉妒人不妨无力。大力之人何妨有妒。次明偈中非一切因食而得病苦。先牒偈文明其有余。亦见有下即事显之。下明偈中非一切净行悉受安乐。先牒偈文明其有余。世间亦下即事显之。以是义下总结前偈悉是有余。此第三竟。四明说所因。欲受第四八戒斋者。有言于彼明六斋中受第四斋。亦可于彼小乘法中有二种戒。一者尽形。二者日夜。尽形戒中有其五戒十戒具戒。约对彼故。宣说八戒以为第四

上来第一广明有余。自下第二明其无余。迦叶先问。何等名为无余义者正问无余。云何复名一切义乎简去有余。自有诸法望上有余望下无余。义有两兼不名一切。今所问者问其一向无余之法不杂有余。故云一切。下佛答之。唯除助道常乐善法是名一切亦名无余名正对前问。其余诸法亦名有余亦名无余举非显是。此言除者是其除取。非是除去。如世人言何物能见答言除眼余皆不见。此亦似彼唯除助道常乐善法一向无余。自余一切亦名有余亦名无余。助道是因。常乐是果。此等一向是其无余。故云一切亦名无余。自余诸法望深有余。望浅无余。欲令已下总结说意。前略次广

自下第三迦叶领解如来述赞

长寿至此广明学法自下第二明其学行。于中先明显行由序。圣行已下正明行体。序中有五。第一迦叶问经功德如来叹深不肯宣说。二大众偈请。彼迦叶等犹故未至唯愿小住除断我疑。佛答迦叶及阿难等能断众疑不须我住。第三大众以佛不许谓佛交灭设供奉佛。佛时现疾示欲取灭。第四迦叶知众心殷请止病言。如来因请身现无病。第五大众知佛无病请佛说法。如来欲说口现无病。五中前三望上流通。望后为序。良以望前为流通故此品明之。后二唯得望后为序故在后品。初中先请。唯愿说是大涅槃中所有功德。下佛答之。明其闻经名字功德唯佛能知余不能说况受持等。何由可说。然此经中乃至依经修成功德。亦名受持读诵书写。故下文中名十功德。以为受持书写功德。第二请中大众先请。时诸天等标列请人。异口同音显其请相。请心同故发言不异。下列请辞。前三偈半启请佛住。后之半偈请佛说法。就请住中初偈举彼三宝难思彰佛去留无碍请住。后两偈半举其有缘未至请住。请说可知。下佛答中初之一偈正答前请明迦叶等能断众疑不须我住不须我说。后一偈半释去众疑。佛前说言阿难勤进能断众疑。大众便念阿难向来不闻此经云何能得断一切疑。故生愁恼。佛今释遣。阿难多闻自然解了常及无常能断众疑不须忧恼。第三番中大众初先设供奉佛发心获益。下佛现病示将灭相。文别有四。一与文殊迦叶等记。二诫敕大众自修其心慎莫放逸。三彰已背病委法文殊及迦叶等。四现有疾右胁即卧

现病品者。向前为病人皆谓实。此品广明如来无病方显前病应现为之。名现病品。此品两请备如向判。然今迦叶先请如来止其病言。后佛因之身现无病。前中初先长行直请。后偈颂重请。直请有七。一明如来无病因果不应言病。二有二因下明佛旷修无病之行不应言病。三世有病人或坐卧下明无病相不应告病。四诸菩萨凡所施下明佛旷修无病之愿不应言病。五世有病人不能坐下明佛唱病生于世人尽灭之想不应言病。六世有病人身羸损下说病生于外道诽谤不应言病。七世有病人四大增下辩明如来诸力具足不应言病

初中有三。一明如来无其病果。二有四毒下举无病因成前无果。三今日下结呵病言。初段可知。第二段中先举病因贪等列名十使。皆是以此四种缘事而生现能发业招集病果故偏举之。次明生果。后明佛无

第二明修无病行中有二因缘则无病苦总以标举。次列其名。先问后列。一者怜愍。所谓慈悲利众生心。二给施等明其四摄益众生行。如来往下明佛具摄不应言病。常行爱语是爱语摄。利益众生不令苦恼是利行摄。施病医药是布施摄。略无同事。何缘结呵

第三明佛无病相中先举世人病患之相。次约责佛。后呵说病。责中四句。前三呵佛不教善人。后一责佛不治恶人。就前三中初句呵佛不教声闻学大乘行。二何缘下呵佛不教起大乘解。三何故下呵佛不教坚菩提愿。余文可知

第四明修无病愿中有十一句。初施医药施与众生求一切智。二为除众生三障重病。先列三名。次辩其相。辩烦恼中依如毗昙唯有十使十缠六垢。依成实论烦恼无量。此同成实。依此说烦恼故。就明慢中具应有八。今此文中略无大慢。故但有七。又此憍慢成实论中名为慢。八中五种约人以别。初言慢者如成实释。缘于下人及等处起。于等计等此过轻故直名为慢。此无所陵。何故名慢。成实释言。是中有其取我相过故说为慢。若无我想终不自高亦不计等。所少大慢其唯缘于等境界起。于等自天名为大。慢慢不如慢及与憍慢缘上境生。他实过已自谓胜彼。此过最重慢中之慢名曰慢慢。他人过已分齐玄绝。便言我今少不如彼。陵他多边名不如慢。于其父母师长等边不能尊敬名为憍慢。亦名傲慢。余有三种约法以别。报我陵人名我慢。此我是其八慢之体。无德自高名为邪慢。又复恃其恶法陵人名为邪慢。未得上法自谓已得名增上慢。余皆可知。就业障中五逆罪重故偏说之。就报障中谤法阐提应是业障何故名报。以此二种多世积习方始成就故说为报。如是三下总以结之。余愿可解

第五生世灭尽之想

第六生彼外道谤中皆先立喻。次合显法。后呵说病

第七明佛诸力具中初明如来身力具足。世界成下德力具足。今者何故右胁卧下总以结呵。就初段中先明世人病患无力。如来四大无不和下彰佛不同。于中有三。一明如来无不和适身力具足。二如十小牛下挍量显胜明佛力具。三一切凡夫身中节下辩其身相成力不等。就明如来德力具中文别有二。一略明如来坐金刚座逮得十力不应如彼婴孩小儿。愚无智下广显不应。于中先明小儿愚痴无智无能随意偃侧无人讥呵。下明如来智德殊胜不应同之。句别有五。一明如来有智异凡。二人中龙下有通异凡。三无上仙下明无惑异凡。永断疑网无见谛惑。已拔毒箭除修道惑。四进止止威仪异凡。五具足下明无畏异凡

偈颂请中文有七偈。前六正请后一结请。正中初偈颂上文中第七诸力具足以请。次有三偈颂上文中第五第六凡夫外道谓灭以请。于中初偈明诸凡夫睹化谓实中间一偈明不见真。第三一偈举圣显凡。后之两偈颂上文中第二第四旷修无病行愿以请。三世世尊大悲为本举佛本因。如是慈悲今何所在以昔征今。今舍众生入般涅槃似无慈悲故言何在。若无大悲则不名佛准行验人。佛若涅槃则不名常以应征真。下结请中前之三句结为余人。末后二句结为外道

下佛因请身现无病。文别有三。一身现无病。二放光益物。三心无疑下出华益物。初中世尊大悲熏心起化所因。知生各念起化所缘。知众并有求法之心名各各念。将顺利益起化所为。前说学法是少分益。后说学行是毕竟益。为顺如是。毕竟利益故现无病。即从卧下正现无病。第二放光益物可知。第三出华益物之中初明世尊心无疑虑。不虑大众不堪受法。次以相好庄严其身。后于身上出妙莲华。文别有三。一明出华。二于华中放光出声济拔三涂。三华中现佛利益人天。初段可知。第二段中先救地狱。次救饿鬼。后救畜生。救地狱中文别有四。一放光救济八大狱中苦恼众生。二出音声说如来藏。言生有性令生人天。三放光救济眷属狱中苦恼众生。前八地狱各别有其十六眷属。谓八寒冰及八炎火。彼一一狱面各有四。谓二寒冰及二炎火故有十六。然今文中偏举寒冰无八炎火。八中前四就声彰名。阿波波等并是寒声。优钵罗等就色彰名。冻诸罪人身体红赤似优钵罗即以为名。余亦如是。此等遇光皆悉除灭。四出音声说如来藏令生人天。下救饿鬼畜生之中皆先放光。后出音声。以如来藏众生体实故偏说之。众生闻之故离三涂得生人天。第三华现化佛益中初明化佛相好严身。次明化佛现通说法利益人天。先现神通。或说阴下明其说法。或有世尊左胁出下重明现通。或有世尊师子吼下复明说法。尔时于此阎浮提下明诸众生见闻获益

自下第五大众请说。佛将为说口现无病。前中尔时一切天等标列请人。悉共同下见佛无病赞喜共请。先赞。次喜说。己踊跃明其心喜。或歌口喜。舞等身喜。次供下请。先列请辞偈。后明其声及远近。请辞之中四句为偈。有七偈半。随行说偈有十五偈。前十四偈是其正请。正请之中初之两偈举彼如来能知以请。次二举佛本愿以请。次八举佛能益以请。后二举佛不灭以请。明能益中初之四偈明诸众生不知有损。后之四偈明佛能益。前四偈中初二正明不知之损。后二出其所不知事。后四偈中初二明佛当能利益。后二明佛已能利益。余皆可知。下佛将说口现无病。先叹迦叶。将述其言故先叹之。我于往下正显无病。叹迦叶中善哉总叹。汝已下别。是故能问总以结叹。初中先叹迦叶智慧。已曾供下叹其福德。具二庄严方始能问。故并叹之。前叹智中初叹迦叶内具证智。汝已成就乐说辩者叹其教智。具此二智方堪咨问。是以并叹。证中汝已具足深慧叹成深智。证实称深虽相曰妙。不为诸魔外道破坏叹具坚智。以智坚故邪人不坏。汝已安住不为诸邪恶风倾动叹具正智。以智正故邪法不动

就下正显无病之中还述迦叶请中七义以显无病。文别有五。第一述上第一复次明已久来无病因果。二过去下述前第四复次明已旷修无病行愿。三我今实无一切疾下对前第五第六复次凡夫外道生尽灭想明已实无一切病苦。四汝先所问如来何故倚卧已下述前第三明无病相。五世有三人病难治下述前第七明已德具不同余人所以无病

就初段中无量劫来已除病根明无病因。永离倚卧明无病果

第二段中明已过去为无上胜如来弟子受持是经回向菩提。以是力故今无诸病。先明所修。我从是下彰其所离。于中明离三对因果。烦恼业缘是其恶因。恶道苦果。诽谤法等复是恶因。受黄门等复是苦果。反逆父等复是恶因。诸苦是果。此诸过患皆未曾有

第三段中初先彰已实无诸病。所以下释。久离故无。是诸众生不知已下彰彼凡夫外道众生不知密语。谓佛实病。如言已下广显病言是密非实类以显之。先举其类。类有十一。前之十句就佛彰密。后一泛就余人显密。前十句中道如言者指斥之辞。如佛昔言故曰如言。非是汝言。若经本中有汝言者宜须治故。末后一句中云何为密。道理人死身心俱灭。而佛昔说修善之人死时心去。不尽道理。所以名密。于中先举昔时密言。而是心下辩实显密。上来举类。下约显病。我今言病亦复如是总约显病。如来密教顾命文殊别约显病。如来正觉实无病实等彰实无病。亦不毕竟入涅槃下举佛不灭成前无病。是大涅槃即佛深定辩大涅槃成前不灭

第四段中先牒问辞。虚空之性亦无起下明已如空故无病相。先喻后合

第五段中辩明如来德行穷满诸过已尽超过余人故无有病于中有二。第一泛举三种病人。二从迦叶有五人下就前三中广辩第二。对之以显如来无病。前三人者。凡夫为一。二乘为二。菩萨为三。先明凡夫。世有三人其病难治总以标举。谤等列名。如是三下显难治相。于中初法次喻后合。次明声闻。先喻后合。下明菩萨。先喻次合。后辩具相。问曰。此是何处菩萨。下师子中宣说是其六住菩萨。如地持说。种性初住。解行第二。净心第三。行迹第四。决定第五。毕竟第六。此六是其定聚所摄。故值善友不值善友。若得闻法若不闻法。定得菩提。若复通论。善趣亦是。故为怖畏利养谀谄诳他等事书写是经

自下第二广就向前中品病人别为五门对之显佛。何故偏举中品显佛。以其中品是小乘人。小乘是其大乘家对。举小彰大明大义显。所以偏举。于中初先总举五人于大有病。非是如来据小罗汉辟支无病今对于大亦得有病。何等已下别显五人对之显佛。先征后辩

辩初人中句别有六。一明其人断结多少。谓断三结。所谓身见戒取及疑。问曰。经说须陀洹人所断烦恼如四十里水。其余在者如毛一渧。今以何故偏言断三。此义如后迦叶中释。二明所得。得须陀果义如下解。三明所离不堕三恶。四明其人得灭远近。人天七返得入涅槃。七返是其十四生死。若通中阴二十八生便得入于小乘涅槃。五是名下结。六明其人趣大远近。过八万劫得大菩提。所谓得于性地菩提。问曰。菩提应在极果云何性地已名菩提。释言。菩提有通有局。局在后际。通该始终。故大品中宣说菩提有五种别。所谓发心伏明出到及与无上。发心在于善趣位中。伏心在于种性已上。明在地上。出到在于七地已去。无上在佛。故种性上得名菩提

第二人中先总标举。下辩其相。句别有五。一明其人断结多少。断前三结加薄三毒。二明所得。得斯陀果。此名住薄。亦曰频来。三得灭远近。欲界人天一往一来便得涅槃。四是名下结。五趣大远近

第三人中先总标举。下辩其相。句亦有五。一断结多少。断五下结。三结如上。加断贪欲嗔恚为五。所断身见戒取及疑。准依成实。具有两义。名为下结。一是人下凡夫所起。二障下果故名为下。唯障初果。若依毗昙唯有一种。人下名下。彼说三结唯凡起故。非障下果名为下结。彼说三结或障初果或障第二或障第三。不唯障于须陀下果。是故不得说障下果名为下结。是义云何。若次第人所断三结障于初果。超越斯陀所断三结障第二果。超越那含所断三结障第三果。是故不唯障于下果名为下结。贪欲嗔恚以界下故名为下结。二明所得得那含果。义如上释。余三可知

第四人中先总标举。下辩其相。句别有五。一断结多少。永断三结。余处宣说断五上结。色无色染痴慢掉戏是其五也。二明所得。得阿罗汉是有为果。烦恼无余入涅槃者是无为果。三简异缘觉。假师得度。不同辟支独一之行。四是名下结。五趣大远近。问曰。须陀斯陀那含此之三人向无学果时无多校。何缘向大尔许阶降。释言。此等进至无学然后向大。所挍无多。若彼三人不求无学径向大者心有残结。障道力强。道行难成。故有如此。又须陀等傥生上界方至无学。时亦不少。故挍多劫

第五人中先总标举。辟支有因道同罗汉。故不别论。又此利根一入圣道至果方出。中无出理。故不别说。但明其果。下辩其相。句别有六。一断结多少。与罗汉同。二明所得。得辟支道是有为果。辟胡故语。此曰缘觉。断有二义。一就所观法门以释。此人观察十二缘法。从缘得觉。故名缘觉。二就得道因缘以释。藉现事缘而得觉悟。故名缘觉。烦恼无余入涅槃者得无为果。三真是下简别罗汉。辟支独成不假师度。如彼骐驎单有一角。故曰麒麟独一之行。四是名下结。五趣大远近。六是名下简异如来。名有病行非如来也。据终云非。类前皆尔。故略不论

涅槃义记卷第四应永三年五月二日加修复拭老眼书补阙字了　　　　　法师权大僧都贤宝(生年六十四)涅槃义记卷第五

        隋净影寺沙门释慧远述

圣行品者。上来第一显行由序。下正辩行。行别有三。初尽十德明其随缘造修之行。二师子一品明其舍相入证之行。三后迦叶品明其证实成果之行。亦名证实起用之行。随缘造修外国名为准法修成分。舍相入证外国名为离诸放逸入证分。证实成宗外国名为慈光善巧住持分。名虽别异。其义不殊。问曰。何故前学法中菩提涅槃二因别说。学行不尔。互从皆得。但是明法理须委具故前别论。依法成行行成不异故不别分。随缘行中五行地前。十德地上。此云何知下说五行所成之果并在地上。判知五行在于地前。下说十德云非世法。世间所无明是地上。前明五行答上云何近无上道。名后十德为无上道。云何得近。下辨五行能成彼德故得近之。于五行中先辨圣行。因以摽品名圣行品。此五行中文别有五。一总劝修习。二别教五行。三总结劝。四迦叶领解。五明此五行利益弘广多人同得。前中初先劝学五行。复有一行谓如来下辨行所依依佛行法。就劝学中先总劝思。思由教起。故言于是大涅槃经专思五行。次列五名。言圣行者就人彰名。诸佛菩萨会正名圣。圣人所行故名圣行。言梵行者随义立称。梵名为净。清净之行名为梵行。言天行者亦随义名。天有多义。具如下说今取净义。净天之行故名天行。外国多名自净名净净他名梵。此方名少。通说为净。犹如菩提末伽外国别名。此通名道。亦如涅槃及与毗尼此通名灭。言病行者约对彰名。行能治病故病行。婴儿行者就喻立称。行离诸过如彼婴儿。无所辨了名婴儿行。名义如是。体相云何。具论圣行门有无量。今此但说戒定智惠以为圣行。地持宣说空无相愿灭尽正受以为圣住。圣住犹是圣行义矣。空无相愿犹是惠行。灭尽正受犹是定行。具论梵行门亦无量。今此经中说七善法四无量心以为梵行。地持唯说四无量心以为梵住。彼中梵住犹此梵行。天行一种此中不说。指杂华经。地持论中宣说八禅以为天住。彼中天住犹此天行。忏悔前罪是其病行。不起后过是婴儿行。五中前三明摄善法。后二离过。一一广释备如后文。当修是五结劝修习。上来五种正明行体。复有一行谓如来行辨行所依。谓依如来先成之德修习趣入。亦可五行是其教行显性成行是如来行。显如来性以成行故。所修五行依彼以成。故须辨之。准下惠中叹经似尔。谓涅槃经就诠指实。实德难彰故寄诠显。如下文中诸行之后叹经胜者。当知显此如来行也。此初段竟

第二别教五行之中尽此品来教修圣行。梵行一品教修梵行。婴儿一品教婴儿行。天行一种玄指杂华。病行一种一向不论。何者是乎。有人释言。前品所论五种之人有病行处是其病行。彼是声闻缘觉病行。何关菩萨。又前所论杂病之行今此所教治病之行与前大别。何得指前。又前品中未标五行。以何义故豫说病行。判无斯理。若前非是。何者是乎。梵行品末阇王忏罪治病之法应是病行。故下文中世王杀父即是心病。身疮增剧是其身病。佛放慈光治其身病。为说妙法除其心病。治此两病故名病行。若彼忏罪非是病行应有所指。不应直尔。问曰。若彼是病行者。何故在于梵行品说。释言。一品备论多法。诸经同有。不足可怪。又问。若彼兼论病行。何故偏名梵行品乎。此例亦多。如上如来性品中具明多法。题章偏名如来性品。此亦似彼。但经立品差别种种。或有从初。或复就后。或有据中。或复当相。非可一定。问曰。若彼是病行者。何故文中不标不结。释言。辨义大例有二。一当法直论须标须结。第二寄人寄事表法。直尔举人举事便罢。诸经多尔。然下文中寄人表法。寄彼世王忏悔灭除害父之逆。以显菩萨忏悔灭除一切罪障以为病行。不唯将彼世王忏悔害父之逆以为菩萨一切病行。故无标结。亦可彼文义有两兼忏悔灭罪是王病行。为救一切逆罪众生兼令多人发菩提心是王梵行。以有两兼。是故不得偏就一义标举以结。就圣行中初戒。次定。后明智惠。义次第故

戒圣行中初问。次辨。后结下释。云何菩萨所修圣行是初问也。若彼下辨。辨中有二。第一明其因分所修。即得住于初不动下果分所成。因在地前。果在地上。诸行齐尔

因中有四。一从师闻法。二因闻生信。三因信起思。四即至下因思起修。有人依下近友闻法思惟修行。四义科分。观其文势似若不然。如前所科。别更是其一行次第。菩萨若从声闻如来得闻是经是初段也。此乃菩萨传佛教法名曰声闻。非小乘人。如法华说我等今者真是声闻以佛道声令一切闻。此应似彼。闻已生信是第二段。信已应下是第三段。于中有三。一思准正法弃舍家业。二复作念下观行求出。三作是下定意降魔

初中有二。一思正法。二我今下为求彼法舍世所有。前中诸佛有无上道是其果法。有大正法是其理法。果依理成故须辨之。大众正行是其因行。亦名行法。复有方等是其教法。因由教起所以须辨。亦可诸佛有无上道是其佛宝。有大正法是其法宝。大众正行是其僧宝。此三所诠。复有方等是其能诠。第二段中我今爱乐贪求大乘明已所求。舍所爱下彰已所弃

第二段中句别有四。一观在家多过。道言迫迮犹如牢狱明其有苦。烦恼由生彰其有恶。二观出家多益。宽广如空翻前初句明其有乐。善法因增翻向后句明其有善。三明在家于已无利。不得尽寿净修梵行。四我今应下正意求出

第三段中初明菩萨定意出家。我今定当出家修道。次明降魔波旬生苦。菩萨复当与我兴诤。后明菩萨无心战诤

下起修中初修自行。悉已施下明利他行。菩萨所行无出此故。前自行中先修戒行。作是愿下大誓自要。前即是其自分之行。后即是其胜进之愿。前中有四。一明受戒。二既出家下明其持戒。三戒有二种一受世下重辨前受。四戒有二种一性重下重显前持

初受戒中直明出家受戒方便。略不彰受。具论受相如律中说。即至僧坊是出家处。见如来等出家所依。若见如来及佛弟子正举其人。威仪具足诸根寂静明身可敬。心和灭障明心可重。即至已下正明出家。第二持中初略。次广。后总结之。下明持益具五支戒。略中先明持戒之行。既出家已奉持禁支慎重不为。威仪不缺护轻不作。进止安详显前威仪。无所触犯显前奉戒。乃至小下明护戒心。先法后喻。此前略也。广中先举浮囊之譬。人喻菩萨。浮囊喻戒。海喻生死。罗刹喻于诸烦恼心欲得破戒。怪而不与喻持戒心。所乞多少文中自合。下约显法。菩萨护戒亦复如是总合前喻。如彼渡人总以喻帖。菩萨如是护戒时下别合前喻。向前喻中阶别有五。合中有六。不取其数。正取轻重等护为义。道言破戒令汝安隐得涅槃者假设为言。亦可名彼之犯戒乐为涅槃也。上来广竟。持四重禁及突吉罗等无别者总以结之。下明持益具五支戒。先总标举。支谓支别。下列其名。具足根本业清净者离其根本不善业道。前后眷属余清净者离其业道前后方便。非诸恶觉觉清净者离八恶觉。护持正念念清净者修六念心助成戒行。回向阿耨三菩提者用戒求佛。此等分别如杂心论

自下第三重辨前受。先举二数。次列两名。随世言教要期纳法名受世戒。证理离恶名得正戒。下辨其相。得正法戒。证理戒故。终不为恶

自下第四重辩前持。先举二数。次列。后辨。下明菩萨持轻等重。就辨相中性重可知。息世讥中先牒次辨。辨中有四。一不非法取。二破坏成下不非法费。三田宅下不非法畜。四不观象斗马斗已下不非法行。初二可知。第三段中句别有八。一不畜田宅种植等事。二不畜象下不畜畜生。三童男子下不畜奴婢。四金银下明其不畜诸宝贵物。五一切谷下不畜食具。六所受衣下不畜长衣。第七不畜根子已下明其不畜五生种。八不畜宝下不畜种种憍奢之具。余皆可知。是名下结

持戒愿中有十二句。初一对境起愿自制。其次六句对彼施主衣般服食卧具汤药房舍礼拜起愿自诫。后五就已眼等五根起愿自防

上来自利。下明利他。于中初以戒善施之。以是因下愿其得戒。句别有十。初之一句愿今护戒。后之九句愿令得戒。止戒名净。作戒称善。不缺不析显前净戒。不犯性戒名不缺戒。远离遮过名不折戒。亦可离轻名不缺戒。不犯重过名不折戒。折犹破也。大乘戒等显前善戒。种性已上名大乘戒。初地已上名不退戒。二地已上名随顺戒。八地已上名毕竟戒。佛地名具波罗蜜戒。以果度故随义论之。地地皆具

上来明其因分所修。下次明其果分所成。即得住于初不动地总明所成不动之义。粗分有二。一初不动在初地上。二后不动在八地上。今修戒者得住初地。简后不动是以言初。下辩其相。先列四门。如须弥下三番辩释。文显可知

上来广辩。是名圣行总以结之。云何下释。于中有三。三一解圣行。先问后释。诸佛菩萨圣人行故名为圣行。二解圣人。先问后释。释有四义。初之一义约法解圣。有圣法故名为圣人。常观空等显前圣法。后之三义约行解圣。初约三学。次约七财。后约七觉三以是义下就人结行。准后定惠此应叹经。文略无也

次明定行。有人释言。四念惠性非是定行。若使四念一向是惠不为定者。彼俱生戒应名道戒不名定戒。彼俱生戒得名定戒。四念为定竟有何妨。又若四念是惠性故不得为定。八禅等智亦是惠数应不名定。彼得名定。此复何疑。又复八禅以定为主。于中等智十智门收。四念虽复用惠为主。于中定教何为不得定学所摄。当知诸行一一门中具一切义。随义论之何所不通而今居定。以此文中依戒起定。数之次第。故说念处以为定学

文中初先明其行体。下叹经胜令人习学。前中初明因分所修。得堪忍下果分所成。因分修中初先明其四念方便。作是观时得四念下明四念成。前方便中初就身处观察无我。复作是念或识是下就心念处观察无我。若识非下就受念处观察无我。略无法念。良以是中就身受心观察无我。即是总相法念处观故不论法。就身念中初观不净就明无我。复即是念骨是我下观察净色以为无我。前中初先观身不净。从头至足唯有发等三十六物。下明无我。谁有见我征责我体。于前所观不净物中何谁有我我属谁者责我所属。于前所观不净物中系属何谁我住何处征我所在。谁属我者责法属我。此即征破四种着我。初句征破色即是我。第二征破色是我所。第三征破色中之我。第四征破我中之色。就净观中文别有四。一略观骨就明无我。二略观骨色就明无我。三广观骨以显无我。四广观骨色就明无我。就初段中骨是我那离骨是乎观求方便。除去皮下正明骨观。第二段中句别有三。初复作是念骨色相等正观骨色。二如是骨色亦非我下就明无我。先明非我。何以下释。三作是观时即得断下明观利益能除色欲。第三段中文别有二。一观诸骨相因假立。初总。次列。后总结之。二得是观下明观利益能断三欲。先举后列。第四段中句别有五。一观骨色遍满十方。二于眉间出五色光。三光中见佛。四征问我相。五破相心成佛相便灭

心念处中或识是我故使诸佛不为我说因前疑后。复观识下正明观心生灭非我。受念处中初观无我破离受者。而于何处生贪欲下破离受心。破受者中文别有三。一观出息入息非我。若识非我出息入息或能是我因前疑后。复念出息入息是风正明非我。第二观察四大非我。风是四大寻前起后。是四大中风大所收。四大之中何者是我推以求实。地性非我正知无我。第三观察色心非我。初先法说。此身一切悉无有我明其理无。唯有心风和合示现彰其假有。次喻后合。破受心中而于何处生此贪欲破离乐受。乐与贪俱。无处生贪则亦无乐。若被骂下破离苦受。苦与嗔俱。无处生嗔则亦无苦。于中有二。一就骂破嗔。句别有三。一观人空故能破嗔。若被骂辱何处生嗔能骂人空。而我此身三十六物不净臭等所骂人空。二观法空。故能破嗔。若闻其骂即思何声而见骂者总以推求。一一音声不能骂等别释无骂。念念细分语义不成故不能骂。三以是义下总结不应。以前二义故不应嗔。二就打破嗔。文别有二。一观此打由有我身不应嗔他。于中初法次喻后合。法中初思打从何生。次知因手刀杖我身。我今已下以理自遮不应嗔他。二我若不忍心则散下恐增后苦所以须忍。于中五句

上来广明念处方便。作是观已得四念处明念处成

上来明修。下明所成。得堪忍地总明所成。下释其相。初忍烦恼亦忍寒等明能忍苦。略无忍业。是名下结

上来第一正明定行。下叹经胜。文有三对。一迦叶问未得不动颇有因缘得破戒不佛答言有。第二迦叶言敬诺问何者是乎如来为辩。辩中三句。一明菩萨破戒因缘令他众生受持是经。广为人说不退菩提。尔时得破。道言为经而得破戒显经胜矣。又欲令人破戒弘经。二菩萨尔时应作念下教起破意。三以是因下结成得破。此两对竟。三文殊以理彰此犯戒不堕地狱如来述成。于中先赞。我念往下引已证成。于中初先广引昔事。为护大乘杀婆罗门从是已来不堕地狱。拥护已下结叹护法。有大势力令人护持。文相且尔。义有不消。迦叶向问未住不动得破戒不。佛答言有。文殊即说如此破戒不堕地狱。如来今者举昔仙豫杀波罗门不堕地狱释成前义。下说仙豫住极爱地。极爱地上与前未住不动大别。云何为证。释言。是中不欲取其位分高下相当为证。正取为法破戒无过而为证也。行违护法。义通上下。乃至佛证亦得无妨

次明惠行。于中有二。一明行体。二无垢下叹经令学。前中复二。一因分所修。二则得住于无畏地下果分所成

因分修中初辩。次结。后释其名。辩中有二。一以言显实令人趣入。二如来临般方便转下拂言显寂令人舍着。前中有三。一观四谛。二知世谛者名中智下明观二谛。三文殊白佛所言实谛义云何下明观一实。观此三重以明慧行。此乃观入之次第耳。前四谛中应先解释四谛之义然后释文。义如别章。文中有十。一总标举。二列四名。三苦者逼下略释其义。义四苦者现下略辩其相。五苦有三下略辩其体。六有漏二下略分染净因果差别。七八相名苦下随相广辩。八生者出相下约谛明观。九是四圣谛诸佛世尊次第说下结说利益。十昔佛一时在尸首下彰谛宽广摄法周尽。亦得名为简大异小。十中初七直明谛法。次一论观。第九门结说利益。第十一门彰其所观备摄周尽

有四总举。苦等列名

第三番中苦是逼者解有二义。一就粗苦。违境逼心而生内恼故名为苦。二就细苦。有为生灭共相催切名为逼迫。逼迮不安故名为苦。集能生者生长当苦。始起多生。终成曰长。寂灭相者息苦止集故云寂灭。大乘相者正论其道虚通为义。若论乘也运通为义。体通名道。用通名乘。借彼用通以显体通故说为乘。今此所论是无作道。简异小乘是以言大。此等皆是谛之义相故名为相

第四番中苦者现相。随何世中当分现起更不生后是苦之相。集转相者转生后苦是集之相。灭除相者息除生死因果无处是灭之相。道能除者能除生死因果之法是道之相

第五番中苦有三相总以标举。下列其名。此之三苦解有四义。一对缘分别。缘别内外。内心涉求名之为内。自余名外。外有违顺。刀杖等违。已身命财亲戚之类说以为顺。外中违缘能生内恼故名为苦。从斯苦缘生于苦心。从苦生苦故名为外。外中顺缘在能生乐。坏能生苦。缘坏致恼故名为苦。内心涉求因之为行。厌行生恼名为行苦。第二约缘就体分别。心性是苦。苦上加苦故名苦苦。加何等苦。所谓加前对缘三苦同名苦苦。有为之法必当败坏名为坏苦。即此有为迁流名行。行性不安名为行苦。第三约就三种无常以别三苦。就彼分段无常分齐宣说苦苦。心性是苦。于性苦上加以三世分段粗苦。故名苦苦。又以三世分段粗苦显法性苦亦名苦苦。就念无常宣说坏苦。彼念无常迁流破坏故名坏苦。是则向前第二门中行坏二苦至此门中同名坏苦。就彼自性不成实无常宣说行苦。同体四相互相集起故名为行。虚集之行体无自性。自性无安故名行苦。故经说言五受阴洞达空无所起是苦义。第四诸过相显以明三苦。以苦显苦名为苦苦。谓以粗苦显于细苦。以无常显苦名为坏苦。以无我显苦名为行苦。诸法无我因缘虚集故名为行。苦义如上。集灭可知。道义众多。略举三学。戒定道具慧为道体。第六番中先就有漏以明因果。次就无漏以明因果。后就辩谛。先染后净欣厌故然。先果后因逆观故尔。第七段中分苦为八。先举后列。报起名生。生时有苦。故名生苦衰变名老。老时有苦故曰老苦。违损名病。病时有苦名曰病苦。阴坏称死死。时有若名为死苦。又复生等体性是苦故名生苦乃至死苦。所好分张名爱别离。因离致恼名爱别苦。所恶强集名怨憎会。因会生恼名怨憎会苦。所悕不称名求不得。因求致恼名求不得苦。五阴炽盛名五盛阴苦。又苦阴中盛前七苦名五盛阴苦。正则应名五阴盛苦。道中偏说果德为道。前第五中偏说其因。此偏说果。言之隐显道理齐等

自下第八约谛辩观。先观苦谛。于中初先广辩八苦。后约明观。前中初言生者出相总显生义。下别显之。先举后列。言初出者识支是其一报之始。故名为初。报起名生。言至终者名色望前说以为终。言增长者即前名色增为六入。此三胎内。出胎可知。言种类者出胎已后乃至老死一报之中运运新起皆名为生。次明老苦。先问后辩。于中初二粗细分别。从始至终运运衰变名念念老。一报之穷年垂根熟名终身老。后二约就时别以分。从初乃至盛年已前衰变之事名增长老。年衰已后名灭坏老。次论病苦。先问后辩。增数论之。初言四大互不调总释病苦。次分为二。先举。次列。下辩可知。次分为三。三有两门。初三约就因缘分别。先举后列。宿因招病名为业报。现逢恶缘而致病苦名不离恶对。节交生病名时代谢。后三约就因缘名受。三义分别。先举后辩。文显可知。次明死苦。先明后辩。增数论之。初言舍身总释死苦。次分为二。先举次列。下辩其相。命尽有三牒以举数。下列其名。正报虽亡依报犹存名为命尽非是福尽。依报灭坏正报犹存名为福尽非是命尽。依正俱亡名福命尽。外缘有三牒以举数。下辩可知。上来增数二门分别。次分为三。先举。次列。后辩可知。如是名曰死为大苦总以结之。次明爱离。先问次解。开合论之。所爱破坏总释爱离。次分为二。先举后辩。分别校下细分为多。是名下结。怨憎会中先问次辩。增数论之。不爱共集总释怨会。次分为三。先举后列。如是三趣分别校下随别分多。如是下结。求不得中先问次辩。后结可知。五盛阴中先问次辩。后总结之

下明观苦。文别有四。一观苦相。第二会通。三观苦实。四一切声闻辟支佛下重复会通

观苦相中先观生苦。文别有三。一明生过。二约之辨观。三总结之。过中三句。一明生苦能为七本。二夫衰老下举生宽遍成生为本。于中初先举老显生。三界受下辩生异老。三是故下结

观中有六。一明菩萨畏死舍生。二童子喻。辩明菩萨不同近行求生断死。三卖食喻。不同凡夫为生造因。四毒树喻。明死苦宽遍成生可厌。五粪秽喻。明死苦宽长成生可厌。六崄岸喻。明生杂妄乐令人贪惑成生可畏

初中先法次喻后合。法中众生颠倒覆心贪生厌死举凡显圣。菩萨不尔初生见过彰圣异凡。喻中亦二。一喻菩萨厌死舍生。二是时二女复共相将至一贫下喻明凡夫贪生爱死前中复二。一喻菩萨观行之始厌死贪生。二女人答言汝甚痴下喻观终成生死俱弃。前中复二。一贪生喻。二于门外下是恶死喻。贪生喻中句别有四。一生相现前喻。二主人见下审生名字喻。三主人问下审生功能喻。四主人闻下贪乐受生喻。初中如女喻其生相。生顺人情故说为女。当来之生欲起入于现阴身中名入他舍。又此凡法欲起入于菩萨身中名入他舍。生相姝好名女端正。诸根丰美名貌环丽。众乐自随名以璎珞庄严其身。第三句中菩萨主人观生名见。审生名问。审生名字并推所属故言字何。系属于谁生相现心义称为答。我是德天假以名之。第三句中菩萨重审名主人问。审生功能故言至处为何所作。生相现心故言女答。随所生处依报自随故言至处能与种种金银等也。第四句中菩萨观心见生功能名为闻已。贪生名喜。知生由善故言我福故令汝来。造善求生故言烧香散华供养。自下第二喻恶死中亦有四句。一死相现前喻。二见已问下审死名字喻。三问何故名黑闇下审死功能喻。四主人问下菩萨厌死喻。初中门外更见女者。生观之后别见死相故云门外。是生流类故说为女。死相弊恶名形丑陋。乐事衰灭名衣弊坏。诸苦随逐名诸垢腻。形色枯悴名皮皱裂其色艾白。第二句中观瞩称见。审境名宇并推所属故言宇何系属谁家。死境现心义称为答。我字黑闇假以名之第三句中征名求义故问何故名为黑闇。女人答下正辩死能。死相一现依报顿舍故言能令其家财宝一切衰耗。第四句中菩萨观见名为闻已。修习明慧名持利力。呵啧死过故作是言汝若不去当断汝命。观空破灭名断命也。上来第一观行之始贪生厌死

自下第二观行终成生死俱弃。于中有四。一生死相随喻。二主人还入问功德下审生定死喻。三主人即言若有已下生死俱厌喻四主人见下除离心喜喻。初中三句。初女答言汝甚愚痴以法责情。厌死求生不应法理故曰愚痴。不知断生以去老死名无智惠。二主人问下以情审法喻。三女人答下法理现心喻。生起死前故言我姊。生死相随故云常与进止共俱。断死必须先绝其生故言驱我亦当驱彼。第二审生定死喻中。主人还入问功德天外有一女云是汝妹为实是不以情审法。功德天言实是妹下法来现心。于中初明死法随生。随故称妹。次明生死相随不舍。随所住下明其生死作业各异。若爱我下明爱与憎义无偏属。第三生死俱厌喻中。若有如是好恶事者双牒生死。生好死恶。我俱不用生死俱厌。各随意去生死俱遣。是时二女俱共相将还其所止生死俱离。舍圣之凡名还所止。第四句中见去心喜。文显可知。上喻菩萨。下喻凡夫贪生受死。于中四句。初言二女复共相将至一贫家喻明生死随逐凡夫。无德财故说为贫家。二贫人见下喻明凡夫生死俱受。始见心喜即请已下造业求之。三功德言下准圣责凡。我为他驱汝复何缘俱请我住。四贫人言汝念我下辩凡异圣。生随凡情名汝念我。凡夫贪生并受老死故言以汝当复敬彼。是故俱请结答前责也。合中先合菩萨俱厌。凡夫愚下合凡俱受

自下第二不同近行求生断死。先喻后合。喻中四句。一近行求生喻。近行菩萨始修净行名婆罗门。幼稚童子为苦煎迫名为饥逼。悕求人天杂死之生名见粪中有庵罗果即便取之。粪喻老死。果喻生也。二久行呵责喻。圣行菩萨名为智者。嫌彼求生故责之言汝婆罗门种姓清净何故取是人粪中果。三童子闻下始行菩萨辩生所为喻。耻已求生名闻已愧。彰已内心实不贪生名我不食。为欲依生除断老死名为洗净。断老死已并生俱舍名还弃之。四智者语下久行重呵喻。汝痴直呵。若还弃者本不应取责以显痴。合中菩萨亦如是等合向第二及第四句。如彼智下举喻以帖。凡夫之人欣生恶死合向第一及第三句。如彼童下举喻以帖

自下第三不同凡夫为生造因。先喻后合。喻中有二。一喻菩萨知生有死不为造因。二即作言下喻凡不知为生造业。前中四句。一喻说人举果观求。二有人远下喻明菩萨闻说审问。三食主答下喻明说者叹生辨死。四是人闻下喻明菩萨闻说厌离。就初句中四众集处名四衢道。有人喻于说法之者。器喻教法。具说当来人天乐果名盛满食。说彼生中具有色力安乐等事名色香具。劝人行因以资其果名欲卖之。第二句中有人喻于圣行菩萨。久流生死名为远来。无乐自充故曰饥虚。厌苦疲顿名为羸乏。闻说彼果乐事丰足名见饭食色香味具。审其所说名指之言此是何物。第三句中食主答言此是上食色香味具叹生殊胜。若食此下就人辨益。人受彼生名食此食。得色得力明其有乐。能除饥渴彰其无苦。多有天人以为眷属名得见天。此前叹生。唯有一患所谓命终彰其有死。第四句中是人闻已即作是念不用色等不求来生。亦不用死厌患当死。下明凡夫为生造业。即作是言食是食已若命终者何用卖之喻明菩萨征说所为。受生必死何用劝求。食主答下喻显说意。有智不买简圣异凡。唯愚不知多与我买彰凡异圣。凡夫不知生必有死名愚不知。为求彼生多行善因名多与价。合中还二。先合智人知过不求。凡夫愚下合愚不知多与我价

自下第四举死宽遍成生可厌。于中先举毒树之喻。后合可知

自下第五举死宽长成生可厌。先举粪喻。后合可知

自下第六明生杂妄乐令人贪或成生可畏。先喻后合。喻中三句。一生杂妄乐喻。崄岸喻于人天之身。临堕三涂故名为崄。于彼生中愚闇障心名为草覆。于彼生处妄乐牵情名于岸边多有甘露。修因纳得名有食者。天报延长名寿千年。处斯无苦名永除病。受之多庆名安稳乐。二凡夫贪惑喻。凡求彼乐名为贪味。不知彼乐临坠三涂故言不知下有深坑。造善求之名前欲取。不觉命尽名为脚跌。颠坠三涂名尘坑死。三菩萨舍离喻。合中菩萨亦如是等合第三句。尚不欲受天上妙食况复人中举上况下。法从喻称故说为食。凡夫人下合第二句。乃于地狱吞啖铁丸况复人天以下况上

前明生过。次论观行。下双结之。以如是喻及余无量当知生苦结前生过。是名菩萨住涅槃等结前观行

次观老苦。于中初问次辩后结。辩中初略。譬如池下广。略中三句。一明老所为能为咳逆上气等事。二明所坏。能坏勇等八种之事。进谓精进。持谓持戒亦可忆持。三明所作。能作背偻懈怠懒等三种之事。广中合有十五譬喻共显老过。结中初言以如是喻及余无量当知老苦结前所观。菩萨修等结前能观

次观病苦。于中初问次辩后结。辩中有三。一初五复次广显病过。二病因缘下明其六种起病因缘。谓苦恼等是其现缘。破坏浮囊拨撤桥梁是其过因。过为此事故现有病。三亦能却下明其所损。所损有六。就后结中先结病苦。后结能观

次观死苦。于中初问次辩后结。辩中初有十二复次广显死过。下有十句辩其死相。死者是其害身之所名崄难处。无物自资可以超度名无资粮。一死长往名去处远。无人将送名无伴侣。一受身已运运趣死无时暂停名为常行。未测近远名不知边际。亦可凡夫受身恒死名为常行。多少难测名不知边际。一入死分昏沉难出名为深邃。诸根灭坏六识无用故曰幽闇无有灯明。命尽便死无所由从是故名为入无门户。死不离身名有处所。最后一念命尽之时无所觉者名无痛处。世医拱手名不可治。向之难裁名无所止。时至必迁名不得脱。此人身死不灭他阴名无破坏。世人见者莫不忧怖名见愁毒。死灭无处更无异相恶色可生名非恶色。见者惊恐名令人怖。身终即死名在身边。时分难测名不觉知。结中还初结其死苦。后结观心

爱别离中先问后辩。略无结文。辩中初略。今当下广。略中三句。一总明爱别为众苦本。二如说下别明爱心为众苦本。先举偈颂。因爱生爱因爱生怖正明苦本。若离于爱何爱何怖反明苦本。爱因缘下重复显之。三爱别离者谓命终下别明别离为众苦本。先解别离。后明生苦。广中今当分别显示总以标举。过去已下正辩其相。先举往事。菩萨尚忆过去已下以昔况今

怨憎会中先问。次辩。后总结之。辩中有二。一观怨会。于中初法次喻后合。二如人已下修治舍离。先喻后合

求不得中先问后辩。辩中一切尽求是总。有二下别。五盛可知

是名苦谛总以结之

自下第二会通苦谛。昔日说乐。今时说苦。今昔相乖故须会通。迦叶先问。问中有三。一牒佛所说。五阴皆苦直非不然。阴盛是总故偏牒之。二何以下释。三如诸经下征问请会。初段可知。第二释中何故征问。下对辩非。于中初明凡夫有乐。偈中明其贤圣有乐。凡有乐中翻前所说五盛阴苦明五阴中悉皆有乐。昔告摩男若色苦等明色有乐。约求显之。先反后顺。如告比丘有三受等明受有乐。如佛先说若人修善则得乐者明行有乐。又如佛说于善道中六触受乐论者不同。若依毗昙触是行阴。依如成实说想为触。则是此句就想明乐。眼见色等识阴有乐。圣有乐中初之二偈是小乘因。次一偈半是大乘因。次有半偈是小乘果。下有一偈是大乘果。小乘因中初之一偈明持戒乐。次有半偈明修惠乐。下之半偈明修定乐。大乘因中初偈利他。后半自利。八大觉中偏举少欲知足智慧。余略不举。大小二果文中可知

第三段中如诸经中所说乐相其义如是牒佛昔言。如佛今说举佛今语。云何当与此义相应双就今昔相对征问。昔说有乐云何与此苦义相应

下佛会通。先数后会。文中别有四。第一会前六触受乐。眼见好色乃至意思。二迦叶言彼人不以一下生乐会为摩男说色有乐。三有三受下会前三受。四迦叶白若随俗说是妄不下会前有人修善受乐。并会偈中贤圣善乐

就初段中先略后广。一切众生于下苦中横生乐等会通昔言。生灭行苦损恼相微故名下苦。凡夫众生未觉此苦。于此苦中横生乐想。故我昔说六触受乐乃至意思好法受乐。是故今说与本不异会今同昔。是于下苦横生乐故今所说。苦与昔所迷下苦不异。又复我今就彼下苦宣说苦想。与彼横生乐想不乖故言不异。迦叶白下是其广也。先难后释。难有三句。一以细类粗难。二若复有人作是问下举乐反辨难。三若下苦中生乐想下执事征理难。就初难中以彼微细生灭行苦类三涂中粗重八苦。令皆生乐是其难也。文中初言如佛所说于下苦中生乐想者牒佛前言。下生已下将细类粗。三涂之中粗重八苦是其弊下故名为下。迦叶闻前微下苦中得生乐想。便征如来欲令三涂弊下苦中亦得生乐。故言下生下老病等亦应生乐。下者所谓三恶已下辩其下相。于中约对中上显之。此之一番粗有似难。细推非难云何非难。如来所说轻微名下。以苦微故不彰粗乐故生乐想。迦叶所举弊下名下。此苦粗重与乐正违云何生乐所以非难。故佛不答。宜须记知。第二难中假举他问请佛教答。如来若说下苦生乐。他若反并一切皆乐。但诸众生于下乐中生于苦想。于中乐中生无苦乐想。于上乐中方生乐想。当云何答。第三难中迦叶执事征理以难。如来若说下苦生乐。未见有人当受千罚初一下时已生乐想。初一下时不生乐想。云何说言下苦生乐。下苦之处已不生乐。明知世人乐处生乐。乐处生故非一切苦。下佛答之。前三难中但答后二。初一非难所以不答。文中如来先印迦叶第三难辞。用此印辞释去向前第二句难。如是如是总述其言。如汝说下别述其言。如汝所说初一下上不生于乐。道理实是。以一下上不生乐故无有乐相。既无乐相云何难言乐上生苦。何以故下正解向前第三句难。言何以故征前起后。既无乐相我何以故说上苦中而生于乐。下对释之。犹如彼人当受千罚受一下已即得脱者便生乐想。是故我说于无乐处妄生乐也。无乐犹前下苦义也

自下第二会为摩男说色有乐。迦叶初先难前起后。彼人不以一下生乐以得脱故而生乐想。下佛印之。即是会上。言是故者是得脱处而生乐故。昔告摩男五阴法中色阴有乐是实不虚。人天五阴得离三涂粗重之苦故乐不虚。前者略故单云色阴。此中具故五阴通论

自下第三会上三受。文别有四。一举三受三苦为问。二辩其相。三就受明苦。四以是下结。初段可知。第二辩中先辩三受。所谓苦乐不苦不乐列其名字。逼恼名苦。适悦名乐。中容受心不同前二名不苦不乐。又舍前二亦得名舍。此三心法纳境称受。名义如是体相云何。分别有四。一当相分别。如彼成实受相品说。损减身心名为苦受。增益身心名为乐受。非损非益名不苦不乐。二对因分别。一切恶果斯名为苦。一切善果说为乐舍。是义云何。若依杂心。三禅已下一切善果斯名为乐。四禅已上一切善果斯名为舍。若依成实。善分为二。一欲界散善。二上界定善。散善之中增上业果说为乐受。下品之乐说为舍受。以此微乐难觉知故。问曰。苦中亦有微下不善业果何不名舍。偏说下乐为舍受乎。释言。苦果违害之法。性与情返。微有即觉。故入苦中。不得名舍。乐果顺情非切心法。微者难觉故分为舍。又复一切苦乐二受皆用微细行苦为体。于行苦上宣说苦受。苦受必重为心所觉。故不名舍。于行苦上宣说乐受。乐受必微。于中上者为心觉适。当相名乐。轻微之者非心能觉。转名说舍。定善之中下善业果说之为乐。四禅已上胜善所得说之为舍。以彼寂静难觉知故。三对缘分别。缘有三差。谓违顺中。违缘逼恼名为苦受。顺缘生适名为乐受。与二相违名不苦不乐。四约时分别。于中约对三缘辩时。若对违缘。相应时苦。离时生乐。久离则舍。若对顺缘。初受生乐。中受时舍。久受则苦。或有顺缘相应时乐。离时生苦。久离则舍。若对中缘初受时舍。久受生苦。离时生乐。或有中缘初受时舍。久受乐着则生乐受。离时生苦。三受如此。更有多义。广如别章五阴中说。下辩三苦亦如别章释。自下第三就受明苦。苦受之中备具三苦。先举后列。于苦受中违缘逼恼名为苦苦。缘坏致恼名为坏苦。厌行生恼名曰行苦。又心性是苦于理性苦上加前三苦通名苦苦。即彼心体无常坏灭名为坏苦。即此心体迁流名行。行流不安名为行苦。又复前后无常破坏同名坏苦。同体四相虚集名行。虚集之行体无自性。自性无安名为行苦。余之二受各具二苦。所谓行坏。与向后门三苦之中行坏苦同。问曰。何故就受明苦。为彰昔日所说三受皆是苦故今说为苦。第四结中句别有四。前之两句就乐结苦。后之两句就苦结乐。就乐结苦成今所说一切皆苦。就苦结乐成其昔日说苦为乐。以是因缘生死之中实有乐受是第一句结成有乐。以生死中有三受故实有乐受。以苦乐性不相舍离是故说言一切皆苦是第三句结成有苦。以三苦故生死无乐。无乐犹是苦之义也。但佛菩萨随世说乐是第四句就苦结乐

自下第四会上有人修善受乐并会贤圣诸受乐偈。迦叶初先征前起后。若随俗说是虚妄不牒以总问。如佛所说修行善者则受乐等别举以问。于中先举修善受乐。次举贤圣诸受乐偈。下问虚不。若是妄下举佛离妄征破妄说成乐是实。下佛会之。先会贤圣诸受乐偈。如上所说诸受乐偈总牒前偈。即是菩提道之根本别会偈中大乘之乐。亦能长养阿耨菩提别会偈中小乘之乐。远能趣向故曰长养。以是下结。譬如已下会前凡夫修善受乐。会意如何。明此善法与乐作因名之为乐。亦能生苦故复名苦。寄喻显之。先明生乐。后彰生苦

上来第二会通苦谛。菩萨于八解苦无苦是第三段明观苦实。是苦实中无有苦相故曰无苦。一切声闻辟支佛下是第四段重复会通。以二乘人不知有为生灭善法。能为无上菩提乐因。佛为是人于下苦中宣说有乐。唯有菩萨住大涅槃知彼善法能为无上菩提乐因。亦为生死变易苦因。故说为苦。亦说为乐

次观集谛。先问后辩。辩中有四。一明集体二迦叶白下会通集谛。三凡有九下广显集过。四凡夫有苦无谛已下结观虚实。初中观集是阴因缘总观集义。下出集体。集体众多据强说爱。于中初先开合辩相。从一至多。爱有二种善不善下辩定是非。前中初先总说为一。所谓集者还爱于有。从有果生还复爱着未来有果是以言还。次分为二。二有两门。初约内外以分二种。后约已得未得分二。次分为三。三有两门。一约界分三。二约烦恼业苦分三。爱能起业名业因缘。缘爱生诸结名烦恼因缘。爱能招苦名苦因缘。次分为四。后分为五。下随所须分为无量。就后辩定是非之中。初以菩萨对凡说二。先举。次列。后辩可知。后以菩萨对小说二。先举。后列。下辩是非。凡爱是集。菩萨则非。何以下释。二乘如何道理。二乘亦集。望分段果得言非集。望变易果得言是集。虽有是义。文略不说

第二会中迦叶先问。下佛先赞。后为会之。先会昔言。如汝所说非为非因。但阴已下会通今语。以爱增上故偏说之。于中初总。譬如下别。别中三句。一明爱心烦恼随逐。二明爱心结业依住。三明爱心润生苦报。皆先立喻。后合可知

自下第三广显集过。先举九数。次列九名。初门缚圣。次六损凡。次一败圣。后一恼凡。次释后结

第四结观虚实之中。因结集观乘辩余三。今先辩其谛义浅深。后约人论。苦有三重。一苦。二谛。三者是实。逼恼是苦。因缘有无法相不谬目之为谛。穷其本体是如来藏性。如来藏性由来不起。今亦无灭。自性常寂。苦体实然故名为实。余亦如是。今约此义彰观差别。为明菩萨兼举凡夫二乘显之。苦中初言以是义故凡夫有苦而无谛者。以前凡夫所有之爱但名为集不名谛故。苦中亦尔。但有其苦而无其谛所以有苦。未有智解知见法相所以无谛。尚无有谛焉得见实。声闻缘觉有苦有谛而无实者。此人现有分段残果。当有变易生死正果。故言有苦。知苦因缘假有无性名有苦谛。未穷苦本所以无实。诸菩萨等解若无苦是故无苦。而有实者菩萨变易生死未尽亦应有苦。以其证实解苦无苦故隐不论。知苦实性名为解苦。不见苦相故云无苦。是故下结。良以是人解苦无苦是故无苦。既知法相亦知苦实名为真谛。集亦如是。灭道谛中偏约二乘以显菩萨。声闻缘觉断惑有灭未穷法实所以非真。菩萨断惑所以有真。道亦如是

次观灭谛。于中初举次辨后结。举中初言菩萨见灭明见灭相。见于灭谛明见灭实。辨中五句。前四明灭。后一辨谛。前四句中初句明常。第三明净。第四明我。末后句中离十三相以为真谛。十三相者。所谓色声香味触相即以为五。男二相通前为七。生住灭相通前为十。苦乐及与不苦不乐通前十三。此十三中前之十相下文多说。后之三相唯此论之。论实反望由来无此是故于此不取相貌。无相可取。是灭中极。故名毕竟寂灭真谛

次观道谛。于中初问次辨后结。辩中有二。一出道谛。二迦叶白下会通道谛。前中先喻。后约显法。因八圣道见一切法常无常等见无常等合见粗物。见常法等合见细物。于中细分有十七门。相从为七。初常无常有为无为法相分别。生死之法无常有为。涅槃之法常而无为。二生非生物与非物依正分别。众生正报。物是依报。三苦乐等因果分别。初苦乐等是其生死涅槃之果。下恼非总业及非业。是其生死涅槃之因。四实非实等理行分别。实与非实是其理也。真谛名实。世谛不实。乘与非常是其行也。三乘是乘。世善非乘。五知无知等境智分别。知与无知是其智也。圣慧是知。凡识无知。下陀罗骠非陀罗骠求那非求那是其境也。陀罗主谛。求那依谛。六见非见等色心分别。七道非道解行分别。道与非道是其行也。解与非解是其解

就会通中迦叶先问。若八是道义不相应牒以总非。何以下释。初先征问。下广辩之。于中先举如来昔言有十四句。若八圣下对今征责。句别有四。一举今所说八圣为道。征昔为虚。二若彼诸经非虚妄下以昔不虚征佛昔曰不说八正。三若彼不下以昔不说责佛错谬。四然我下明佛离错请释所以。下佛先叹。后为释会。先法后喻。法中如是悉入道谛通会昔言。如我所说若有信下别会初句。是故已下信已无错。如来善下明已说意。喻中有六。一水药喻。明道体一随治为多二水名喻。明道体一随欲分多。此诸水名当应是其异因别语。亦可梵语之差别耳。第三金喻。明道体一随根为多。先喻后合。合中增数次第辩之。复说三种见智慧者。如小乘中见道八忍是见非智。推求名见。与疑得俱未得决断故不名智。尽无生智是智非见。于境决断故得名智。是息求心非推求性故不名见。余无漏慧亦见亦智。慧义则通。就四门中小乘分三。见修无学。大乘为一。通名佛道。就五门中依如成实。信行法行在见道前。钝名信行。利名法行。见道已上名信解脱及与见倒。钝名信脱。利名见倒。依中阿含。信行法行在于见道。利钝如前。信脱见倒在于修道。利钝如上。于彼那含罗汉人中得灭定者说为身证。余皆可知。是道一下总以结之。此是第三。第四火喻成上第一明道是一随治分多。第五识喻成前第三明道是一随根分多。第六色喻成前第二明道是一随欲分多。皆先立喻。后合可知

上来第八广明观谛。自下第九结说利益。是四圣谛诸佛世尊次第说之是结说也。以是因缘无量众生得度生死明利益也

自下第十明其四谛摄法周尽。亦得名为简大异小。下文之中有二问答。从初问答明谛摄法。从后问答明大异小。就前问中迦叶先举如来昔言。昔佛一时在恒河岸尸首林中举佛所在。取其树叶举佛所作。告比丘等举佛所问。比丘言等举昔所答。我所觉等举昔所辩。我所觉法如大地草。所宣说者如手中叶。下就为问。世尊尔时说如是言如来所了无量诸法牒佛前言。若入四谛则为已说若不入者应有五谛进退征问。下佛先叹后为辩释。如是诸法悉在四谛。就后问中迦叶复言如是等法若在四谛如来何故唱言不说重征昔言。下佛为解。虽复入中犹不名说略答其问。总故入中。别不名说。下广释之。先征何故。下对辩释。先分二智。初举。次列下就人论共有三智。下智在凡彼不知谛所以不说。下约辩谛。中智所知是有作谛亦名有量。上智所知是无作谛亦名无量。有作无作约行分别。据小所观。望后更有大乘谛观可以修作名为有作。据大所观。望后更无余观可作名为无作。有量无量就法分别。解有三义。一宽狭分别。小乘所观苦集二谛止在分段。因之与果灭道二谛唯是分段。因果对治观法局限故名有量。大乘所观苦集该于分段变易二种因果。灭道统收分段变易两种对治。观法宽广故名无量。二浅深分别。小乘法中观谛浅近。如毗昙说。苦者实苦不可令乐。乃至宣说道是实道更无余义。又如成实说。观四谛假有无性以为至极更无余义。以斯浅近故名有量。大乘法中论其破相穷空毕竟乃至因缘法相亦无。语其显实宣说甚深如来藏性以为谛实。故胜鬘云。于圣谛处说如来藏。以此穷深故曰无量。三粗细分别。声闻于谛总相粗知不能微细故名有量。菩萨于谛所知微细。如一苦中能知无量微尘数苦。余亦如是。故曰无量。今此所论据后言耳。上智所知无量四谛昔经未辩故不名说。明苦谛中句别有八。阴入界三。就五阴中别分有五。故有八句。余三谛中各有一句。文皆可知

知世谛下。大段第二约就二谛以论圣行。于中有二。一乘上所辩约就二智以明二谛。二文殊白下问答广辩。前中总相知于世谛是名中智。随别细故是名上智。故三法印为第一义是名中智。知彼真实如来藏中恒沙佛法无量无边为第一义是名上智

下广辩中有二问答。前一问答明谛体一。不相离故。后一问答明谛相异。浅深别故。就前问中先牒二谛总问云何。次就二谛问相有不。下就设难。如其有者即是一谛。就有征难。如其无者将非虚妄就无遮责。下佛答之。世即第一。以相即故亦得相有

第二文殊执即征别。若二相即便无二谛。下佛答之。有善方便随生说二总明有二。若随言下别显二相。先举二数。次列二名。二谛之义如章广辩。下广释中文有八番。初番约人以释其名。世人知者名为世谛。出世人知名第一义。后之七番当法辩相。于佛法中粗分有二。唯大与小细分有四。一立性宗。小乘中浅。宣说诸法各有体性。二破性宗。小乘中深。宣说诸法假有无性。三破相宗。大乘中浅。破遣诸法因缘之相宣说诸佛毕竟空寂。四显实宗。大乘中深。宣说妄情所取诸法毕竟不有真实法界常住不坏。于此四中皆有二谛。下七番中。初三是其立性宗中所辩二谛。次二是其破性宗中所辩二谛。次一是其破相宗中所辩二谛。后一是其显实宗中所辩二谛。今此文中以深摄浅故偏论之

就初宗中具说有七。一情理分别。妄情所取我众生等以为世谛。无我之理为第一义。二假实分别。瓶衣车乘舍宅军众如是一切假名之有名为世谛。阴界入等实法之有为第一义。故杂心云。若法分别时舍名则说等世俗也分别无所舍是名第一义。三理事分别。阴界入等事有为世。四谛十六行法相道理为第一义。四缚解分别。苦集是世。灭道第一。五有为无为分别。苦集及道理中非上同为世谛。灭谛精胜说为第一。六空有分别。于彼四谛十六行中除空无我皆名世谛。空与无我理中精妙说为第一。七行教分别。教名世谛。行名第一。故杂心云。经律阿毗昙是名俗正法。三十七觉品是名第一义。今此但彰初之三门。余略不辨。第一先就情理分二。五阴和合称言某申。凡随所称计有我人。是名世谛。圣人解阴无有某甲。离阴亦无。名第一义。第二约就假实分二。先明二法有名有实是其实法。阴界入等依名求有体可得故言有实。有名无实是其假法。瓶衣车乘舍宅军众如是一切假施其名。推求无体故曰无实。下就辩谛。假为世谛。实为第一。第三约就事理分二。事为世谛。理为第一。事有假实。如我众生乃至兔角旋火轮等是。其假中。诸阴界入是其实事。此等一切同名世谛。苦集灭道法相道理为第一义

下次就其破性宗中以辩二谛。于中两门。前门就其假法空有以辩二谛。后门就其实法空有以辩二谛。就前门中先明世谛。世法有五总以标举。次列五名。下辩后结。于是五法心无颠倒名第一者。故其性空不立定性名无颠倒。就后门中无烧割等名第一者。诸法性空名第一义

下次就其破相宗中以辩二谛。八苦之相以为世谛。无八苦相为第一义。问曰。此宗所辩二谛与前何别。释云。前说因缘假有以为世谛。此宗宣说妄相之有以为世谛。前宗宣说无性之空为第一义。此宗宣说无相之空为第一义。有斯别耳

次就第四显实宗中以辩二谛。事相缘起以为世谛。法性缘起名第一义。先喻后合。喻相云何。譬如一人随用分多。若其走时名为走者。收刈之时名收刈者。如是一切。诸法如是。父母生边名为世谛。因缘生边名为第一。因缘所生泛有六重。一事因缘生。如毗昙说二法因缘生。唯苦无常生灭法数。三假因缘生。如成实说。四是妄相因缘所生犹如幻化。五是妄想因缘所生如梦所见。六是真实因缘所生。所谓佛性十二因缘如水起波。前五缘生并是世谛。今据第六故名第一

自下第三约一实谛以明圣行。文别有二。一问答略辩。二问答广辩。略中文殊先问起发。所言实谛其义云何。佛答有七。从真乃至常乐我净。七中初门直指实体。实名真法当相正辩。若法非真不名实谛反以显之。后之六门随义分别。于中三对。初二一对所遣分别。次二一对行教分别。后二一对因果分别。就初对中前离四倒。后出妄想。心想见等是其妄想。实谛无倒正辩其相。无倒名实牒以结之。实谛无妄正辩其相。妄不名实反以显之。第二对中实名大乘约行实分别实。是佛说约教分别。第三对中实名一道就因分别。实名常等就果分别

下广释之。解初门中文殊先问。若以真实为实谛者牒上初门。下对佛等而为请门。若是真法即是如来虚空佛性。若即如来虚空佛性。如是三法便无差别。此如来者是其真实法身如来。如来是果。佛性是因。若论虚空非因非果。彼前实谛据佛以论毕竟清净。于此体上更无生死妄染可得故即如来。就凡论之。犹为生死妄想所覆。与后显时净德为本。故名佛性。就实论实。实则平等。离一切性故曰虚空。良以此三皆即实谛故无差别。下佛答之。述其所问即为答矣。文中有三。一总明如来虚空佛性非苦集等。亦非彼谛而是其实。二所言苦者为无常下别释如来虚空佛性非苦集等。但是其实。三复次真者即如来下别释如来虚空佛性非是彼谛但是其实。初中两番。一就苦等明其浅深三种差别。苦中三者。三苦之八事苦差别直名为苦。即此苦法因缘有无法相不谬说之为谛。不同向前一实之谛所依不空如来藏性名之为实。集中三者。诸业烦恼说之为集。谛实如上。灭中三者。数灭无为直名为灭。谛实如上。道中三者。戒定慧等直名为道。谛实如上。二明如来虚空佛性不同前二。但即其实。如来有二。一报。二法。若论报身即灭即道。今说法身。是故乃至非灭非道。自下第二别释如来虚空佛性。不同苦集灭道四事。但即其实。苦中五句。一辩苦相。所言苦者牒前有苦。下辩其相。苦性非恒故曰无常。苦体虚妄见实则舍故云可断。二是实下就苦显实。苦家实性是一实谛故名为实。不同向前所非之谛。三明如来不同前相。言非苦者不同向前所牒之苦。非无常者不同向前为无常相。非可断者不同向前是可断相。四是故下辩明如来唯即前实。以是如来不同向前苦等相故唯是其实。五以如来类空佛性。集中亦五。一辩集相。所言集者牒前有集。下辩其相。能令阴生正显集义名苦无常。傍论集过。集体生灭。生灭交切故名为苦。集体迁流故曰无常。问曰。无常苦无我等是其苦行。今以何义说之为集。释言。苦等有别有通。别则苦中唯有无我等。更无余义。集中唯有因集有缘。苦上设有因集等义判属集中。集中虽有无常等义判入苦中。通则苦中亦有集义。故彼十二因缘法中苦果生后同名因缘。因缘犹是集之别称。集中亦有无常等义。故此文中说集以为无常与苦。义虽通有。苦中用彼无常苦等以为正义。因集有等以为兼义。故名苦谛。集中用彼因集有等以为正义。苦无常等以之为兼。故名集谛。今就通义故说集谛。为无常苦是可断相彰集体虚。见实则舍故名可断。二是为下就集显实。集家实性是一实谛故名实谛。不同向前所非之谛。三如来下辩明如来不同前相。如来非集不同向前所牒之集。非阴因者不同向前能令阴生。非可断相不同向前是可断相。亦应说言非无常相。文略故无。四是下辩明如来唯即前实。以是如来不同集相故是实谛。五以如来类空佛性。灭中亦五。一明灭相。所言灭者牒前有灭。下类其相。名灭烦恼正显灭义。亦常无常随义分别。先举后释。二乘所得有二种义名曰无常。一终须迁转趣向大乘故曰无常。二二乘之人虽入涅槃。于未来世心想还生。心想生故灭则不恒。故曰无常。亦名证法对心显灭。二是为下就灭显实。灭之实性是一实谛故名实。三明如来不同灭相。不名灭者不同向前所牒灭谛。不名能灭不同向前名灭烦恼。非常无常不同向前亦常无常。不名证知不同向前亦名证法。法身如来古今平等。不同灭谛除障始克。故不名证。四常住下辩明如来唯即前实。体真常住故名实谛。五以如来类空佛性。道中亦五。一辩道相。道者牒前。下辩其相。能断烦恼彰道功能。亦常无常显其体义。二乘之道一向无常。大乘之中有常无常。真道是常。缘治无常。可修法有道是心法可以进习故名可修。二是名下就道辨实。三明如来不同道相。如来非道不同向前所牒之道。如来非能断烦恼者不同向前能断烦恼。非常无常不同向前亦常无常。非可修者不同向前是可修法。四常住下辩明如来唯即前实。以常住故名为实谛。五以如来类空佛性

自下第三别释如来虚空佛生非谛是实。于中有二。一以真法即如来等。二有苦因下明如来等不同彼谛唯其是实。先总后别。总中初先并举四谛。言有苦者举前苦谛。有苦因者牒前集谛。有苦尽者牒前灭谛。有苦对者牒前道谛。次明如来不同彼谛。如来非苦不同苦谛。乃至非对不同道谛。中越集灭故曰乃至。是故下结。结彼如来是实非谛。后以如来类空佛性。别中偏明不同苦谛。余略不论。苦者有为有漏无乐辩其谛相。如来非为非漏安乐明佛不同。是实非谛总以结之。虚空佛性略而不论

明不倒中文殊先问。如佛所说不倒名实牒佛前言。若尔谛中有四倒不就谛审问。如其有下就之设难。若四谛中有四倒者是则实谛不离四倒。云何上言无有颠倒名为实谛一切颠倒不名为实。下佛为释。一切颠倒皆入苦谛略明倒心是苦非实倒应是集。报心为体。报心是苦。从体以名故云入苦。又此倒心与苦作因生苦名苦。以是苦故四谛中有。不名实谛。如众生下广明倒心是苦非实。于中初先法说明倒。譬如已下喻说显倒。如是倒下明倒是苦

明不妄中文殊先问。如佛所说不妄是实牒佛前言若尔虚妄则非实谛以理审问。佛答有二。一明虚妄是苦非实。二声闻下明离虚妄方得为实。前中初言一切虚妄皆入苦谛略明虚妄是苦非实。理实妄体亦是集谛。报心为体。从体以名故说为苦。如众生下广明虚妄是苦非实。后中先明诸圣不行故名虚妄。后明诸圣断离名实

明大乘中文殊先问。如佛所说大乘是实牒佛前言。当知声闻缘觉不实以理审问。下佛为辩。彰彼二乘亦实不实。先举后释

明佛说中文殊先问。佛答有二。一明魔说苦集谛摄而非实谛。二凡是下辨定魔说

明一道中文殊先问。如佛所说一道无二牒佛前言。外道亦说一道无二若言一下相对为问。若言一道与外何别责其差别。若无差下难破无别。若内与外无差别者是则内外二道清净。云何上言一道清净。下佛答之。先明外道但有苦集而无灭道。于非灭下释无所以。妄生忆想是故实无。于中先明外道之人非灭道中生灭道想。四空非灭妄生灭想。彼因非道妄生道想。余亦如是。次明外道非因果中生因果想。果犹是灭。因是道也。以是义下结彼外道实无一道清净之义

第七常乐我净等中文殊先问。如佛所说常乐我净是实义者牒佛前言。诸外道下举外翻内。诸外道有佛法中无略翻其内。何以下释种种说有。常乐下结。释中先问。下广辨辩。明诸外道广说诸行常乐我常。故外道有。佛说诸行无常苦等。所以应无。文中初明外道计常。次乐。次净。后明计我

常中初略次广后结。诸外道辈亦说是常是初略也。谓说五阴诸行常矣。云何下广。先征后辩。有八复次。一以可意不可意报受之不失证成常义。先直立常。若言已下难破无常。以是义下结成已常。二以杀生为因不亡证成常义。先自立常。若言已下难破无常。三系心下以彼世人专念不忘证成常义。先自立常。若无常下难破无常。四一切忆下以其所想不灭证常。若无常下难破无常。五诸所作业下以所久习增长证常。六算数下以其算数增长证常。先立常义。次破无常。以一不灭得至二下结成已常。七如读诵下以其读诵渐增证常。亦初立常。次破无常。后结常义。八瓶衣下以其一切诸物不灭证成常义。后结可知

次明计乐。复言有乐总以标举。云何下广。有五复次。一以受者得可意报证成有乐。先略。次广。以是下结。二以生人求望心故证成有乐。先明有乐。次破无乐。以求下结。三以布施能为乐因证成有乐。先举。次辩。是故下结。四以触数能为乐缘证成有乐。先明有乐。次破无乐。后结有乐。五以上中下乐差别证成有乐。先举。次辩。后总结之

次明计净。先举后辩。有三复次。一生人欲心证成有净。二金银等诸实净物证成有净。三以诸仙阿罗汉等五阴净器证成有净。于中初举次辩后结

下明计我。先总标举。下别显之。有八复次。一以眼等我之用具证成有我。先立我义。后破无我。二以有我相证成有我。有我略举。云何知下问答略辩。何等已下问答广辩。是故下结。三以能别知证成有我。先举。次辩。是故下结。四执镰下以有作用证成有我。五即于生时欲得乳等宿习不亡证成有我。六以瓶衣车乘等事和合益人证成有我。先略标举。譬如下辩。是故下结。七以遮故证成有我。先自立我。次破无我下牒结成。八以伴故证成有我。先略标举。云何下辩。如是下结

上来广辩。以是义故外道亦说我有真谛总以结之

下佛破之。文别有四。第一广呵。第二广破。第三重呵。第四结破。初中若有常乐我净非沙门等如来总呵。何以故下如来广呵。先征后辩。于中合有二十二句。第二破中依前四计次第破之。就破常中初总次别后总结破。前总破中是诸外道迷惑颠倒言诸行常呵其所立。诸行若常无有是处非其所立。我观诸行悉皆无常翻其所立

就别破中云何知耶征前起后。下正破之。所破有八。如上广辩。一以可意不可意报受之不失证成有常。二以杀生业缘不坏证成有常。三以专念不忘证常。四以所想不灭证常。五以习业增长证常。六以算数增长证常。七以读诵增长证常。八以一切瓶衣车乘山河大地相似不灭证成有常。如来今此先破初二。次破第八中五复次一处破之

破初二中文别有四。一明诸行从缘生故悉是无常。二佛性下举常显之。三以是义下结前第一。四是诸外道不见性下对前二明诸外道不得常法所可言说悉皆非常

初中有二。一泛明诸法从因缘生悉是无常。二是诸外道无一法下正明外道所计常者无有一法不从缘生故是无常。外道多计五阴为常。五阴法中何有一法不从缘生为是无常

第二破中初先明其佛性是常。后以佛性即于三宝类明三宝亦皆是常。前中十句。一明佛性无生无灭所以是常。二明佛性无去无来不迁动故。三明佛性非三世摄不流变故。四明佛性非因所作非无因作。非因生故非因作为。了因了故非无因作。五明佛性非作非作者。佛性之性不生涅槃故名非作。亦不使他生涅槃果名非作者。六明佛性非相非无相。非无相众相永绝所以非相。法界门备故非无相。七明佛性非是有名亦非无名。就实论实。实外更无名字可得所以非名。就缘称性。性为名显故非无名。八明佛性非名非色。不同四阴所以非名。不同色阴故曰非色。九明佛性非长非短。离色相故。十明佛性非阴界入之所摄持。实不同相所以不能。是故名常总以结之。下以佛性类即三宝。于中初以性即如来。如来即法。法即是常。后以常义即于如来。如来即僧。僧即是常

自下第三结前第一。于中先明从缘生法悉不名常。是诸外下明诸外道所计常者无不缘生故是无常。自下第四明诸外道不见常法。所说常者悉是妄语无有真常

诸凡夫下超破第八。于中先明外道所计其实非常。虚空已下举常显之。前中初先牒其所计。当知已下明其非常。一切有下出非常法。就下举常显无常中句别有五。一明虚空无为故常。此名法性以为虚空。非太虚也。二明佛性无为故常。三以空即性。四以佛性即已如来。如来即无为无为即常。五以常即法。法即是僧。僧即无为。无为即常

有为之法凡有二下破向中间五句计常。于中初先分法为二。后就此二破其所计

前中初言有为有二总以标举。色非色法别列其名。下辩其相。非色所谓心心数法。六识是心。想等是数。色谓四大。依如成实。色有十四。五根五尘及以四大。若依毗昙。色有十一。五根五尘及法入中无作之色。今以何义偏说四大。唯依成实。大是尘果。复是根因。举因知果故不说根。举果知因故不说尘。若依毗昙。四大是其造色之本。故偏举之。举本收末故不说。余。若依佛陀提婆所立说。色唯四大。外更无造色。今说似彼佛陀提婆

下就此二破其所立。说心无常破前第三第五第六及与第七。以此四种就心计故说色无常。破前第四所想不灭。以此一种就色计故

就初心中。心名无常总以标举。何以下释。以是下结。释中初言何以故者征前起后。性是已下举后显前心无常义。先开四门。性是一门。明其六识体性名异。故是无常。攀缘第二。明其六识缘境各别。相应第三。明其六识相应法界。分别第四。明其种种义门分别心非是常。下依此门次第辩之。眼识性异乃至意异广上初门。色境界异乃至法异广上第二眼识相应异乃至意识相应异者广上第三。想受等数是相应法。眼识俱者不至余识名相应异。余亦皆尔

心若常者眼识应独缘一切下广前第四。于中合有十一复次。初五复次更以余义破遣心常。次三复次正破前执。次二复次重以余义破遣心常。后一复次正破前执

就前五中初以一识不能独缘一切诸法破遣心常。二以因缘可破坏义破遣心常。三以对治行门各异破遣心常。四以众生心性各别破遣心常。五以多分别破遣心常

初中心若常者。眼识应独缘一切法破他计常。常则不灭。是故应独缘一切法。且征眼识。余略不论。眼识异下自显无常。以法相似念念生下释彼凡夫计常所以

第二句中以诸因缘可破坏故亦名无常略以标举。差别名坏。眼等诸识因缘各异。故曰差别。亦可破灭名之坏。眼等诸识藉缘而生。缘阙不起故名破坏。下辩可知。第三句中别有四句。一自明无常坏行因缘。心名无常略以标举。观行之心能坏生死有为诸行故名彼观以为破坏。诸行因缘坏行缘异故心无常。所谓下列二心若常下破他计常。常则定住。是故修习无常想者。尚不得观苦空无我。况复得观常乐我净。三以是义下对前第二结明外道执常之过。以计常者坚著有为。不能观察无为义故。外道法中不能摄取常乐我净。四善男下对前第一结明心法定是无常。此第三竟

第四句中心性异故名为无常略以标举。下别显之。先明一切贤圣心异。一切外道心有三下明其正见凡夫心异。一切外道告所对人。心有三下对彼外道明其正见凡夫心异。是中未明外道心异。在后别论。正见凡夫心有三种。一作业心。二受报心。三烦恼心。作业心中有三举数。列名可知。乐相应等是受报心。贪相应等是烦恼心。下次明其外道心异。一切外道心相亦异略以标举。下别显之。所谓愚痴相应异等是烦恼心。进止心异是作业心

第五句中心若常者亦复不能分别诸色。以多分别破心定常。常则不动。安能分别种种诸色。所谓青等出所分别

上来五句别以余义破遣心常。次下三句正破前执。心若常者诸忆念法不应忘失破前第三专念证常。常应定住何缘忘失。所念忘失判知非常。心若常者凡所读诵不应增长破前第七读诵增长。常应定住何缘增长。心若常者不应说言已作今作破前第六算数增长。于中初先破他计常。就算数中数竟已作。正数今作。未数当作。常法一定。云何得有已作今作。若有已。作今作已下正显无常

次下二句复以余义破遣心常。心若常者不应分别怨亲中人。心若常者不应说言我物他物若生若死

下一复次正破前执。心若常者虽有作业不应增长破前第五作业增长。常法一定云何增长

以是义下总以结破

下次宣说色法无常破前第四所想不灭。于中初先结前生后。我今于此非色法中宣说无常其义已显是结前也。复当为汝说色无常是生后也。次广明之。有十复次。一本无今生生已还灭故是无常。于中初总。次就内外别以显之。是故下结。二所有下明内外色随时变异故是无常。三内外味异故是无常。四内外力异故是无常。五明内外状貌各异故是无常。略但说内。六明内外果报各异故是无常。七明内外名字异故悉是无常。八内外色坏已还合故是无常。九内外色随时渐生故是无常。十内外灭异故是无常。凡夫已下解释凡夫计常所以。以见相似相续而生所以计常

上来第二广破计常。以是义下总以结之

无常即苦破前计乐。苦则不净破前计净。我因迦叶先问已答指上广显。如来于前群牛喻中。因迦叶问广明外道毕竟无有常乐我净。故指显之

下次破我。诸行无我总破也。下别破之。计我有八广如上辩。一有我用具证知有我。二有我相故知有我。谓俯仰等。三别知故定知有我。见人食果口中生涎。四有我用故知有我。谓执镰等。五宿习故明知有我。六诸事和合利益我故明知有我。七遮故有我。八伴故有我。今此文中依名正破。但破五句。谓破第二第三第五第七第八。以义会之八句皆破。但不次第四对记之。其第一对先破第一次破第四。其第二对先破第七次破第八。其第三对先破第六却破第五。其第四对先破第二后破第三

就初对中先破第一我之用具。具谓六根。六中前五是其色法意是心法。故今就其色心以破总一切法。谓色非色略举二法。下就破我。于中先明色法非我。初举。次释。以是下结。下明心法。非色非我略以标举。何以下辩。心从缘生是故非我。以专念下超破第四我之作业。是中如来不当所执题以正破。取彼常中专念忆想破我作业。何故而然。专念忆想通亦是其我作业故。于中先就专念破我。初举直非念性非我若以专念。为我性下举妄征破。下复就其忆想破我。若以忆想知有我者举其所立。无忆知无反其所立。如说已下广举无忆破其有我。先举世人相问之事。下明破我。有我不问。问故无我

第二对中先破第七遮故有我。于中有二。一以佛遮破其有我。二以外道不遮破我。前中初先牒其所立。遮故知无反其所立。下广显之。于中初明有我不遮。如调婆达终不言非举事类显。我亦如是我终不遮当法正辩。下明有遮定知无我。下就不遮明无我中。若以遮故知有我者牒其所立。汝今不遮定应无我即取其义反以破之。下破第八伴故有我。先牒所立。以无伴故应无有我略翻其言。良以真我无有伴故。有伴之者应无有我。下广显之。于中先明真我无伴。有法无伴谓如来等类以显之。我亦如是实无伴者正明如来真我无伴。以是义下结伴非我

第三对中先破第六诸事和合利益于我。外道取彼世人所说诸事和合益我之言执定有我。故今破之。明但假名都无实事。于中初先牒其所立。下对破之。无我法中亦有我名彰名无实。如贫贱下举事类显。如我死下破名有实。如言我死举世人语。若我死者我则杀我依名征实。若诸外道闻言益我即谓有我。如死言我我亦应死。若我死者此我便是可杀之我。是故说言我则杀我。而我叵杀简实异名。假名杀我结名无实。如矬人下举事类显。以是义下结成无我。下破第五宿习有我。先牒所立。下正破之。若有我者不应执持粪秽等举事反征。以是义下结成无我。以是执持粪秽等故定知无我。一切生下释彼婴儿求乳所以。是故下结

第四对中先破第二以相证我。于中初先牒所立。下对破之。相故无我是其一门。无相亦无是第二门。若人睡时不进止等显上后门无相亦无。若以进止俯仰已下显上初门。于中先举木人类破。后举如来真我对显。真我无相明相非我。下破第三别知证我。先牒所立。以忆念下明诸众生生涎所以。下就破我。于中先明涎非是我。次明真我非涎喜等。以是下结上来破竟

自下第三重复呵责。于中初法次喻后合。法中初明诸外道等自无所知。次明外道于佛法中取少许分妄计常等。后明外道实不能知常乐我净。喻中如盲不识乳色喻自无知。便同已下喻于佛法取少许分妄计常等。于中四句。别喻妄立常乐我净。虽闻已下喻实不知常乐我净。合中外道亦复如是合不识乳妄说声等。终不已下合终不得乳之真色

以是义下是第四段重复结破。以是外道所立非故。我佛法中乃有真谛非外道也

上说四谛二谛一实合为初段。以言显实令人证入。自下第二拂言显寂令人舍着。于中有三。第一文殊取相赞叹而为起发。第二如来对言破遣。第三文殊彰问所为自解为他。初中文殊闻前四谛二谛一实深释其心故为赞叹。于中三句。一取如来般涅槃相。二取如来转法轮相。三取更转无上之相。佛昔初成在婆罗捺已转四谛。今入涅槃重复说之。故今赞言如来临般涅槃方更转于无上法轮乃作如是分别真谛

下佛破遣。文还有三。一遣如来般涅槃相。二若有计我是佛以下遣转法轮相。三诸佛世尊诸有二下遣其更转无上之相。初中佛告汝今云何故于如来生涅槃相呵其取灭。上来数明如来常住。文殊今言与前相反故为此呵。如来实常不般涅槃明佛不灭

第二段中文别有四。一明佛无著自不见转。二若言常下明佛体常所以无转。三譬如因眼缘色已下明说虚假成佛不转。四虚空非生非出以下明佛体寂所以无转

初中复四。一举世人果中计我。二明佛无。三举世人因中计我。四明佛无。初中六句。前五我见。后一我慢就我见中初一通就人法起行计。道言若有计我是佛就人计我。我成菩提就法计所。取彼菩提为我所成故云我所。次二偏就法中起计。前句就其涅槃起计。我即是法。计法为我。法是我所。计法为所。取法以为我之所得故云我所。后句约就菩提起计。我即是道。计道为我。道即我所。计道为所。取道以为我之所行故云我所。下二偏就人中起计。我即世尊。计彼世尊以为我体。世尊即所。计彼世尊以为我所。我即声闻。计彼声闻以为我体。声闻即所。计彼声闻以为我所。圣有四阶。声闻缘觉菩萨及佛举上及下。中略不论。亦可此说佛为声闻。果中计故。以佛道声令一切闻故曰声闻。前五我见。我能说法余人不能。是其我慢。第二段中明佛永无。文显可知。自下第三因中计我。于中初明计身为我。我是信下计行为我。身中三句。一计眼等六根为我。二计色等六尘为我。三计地等四大为我。行中亦三。初计信心多闻为我迷行方便。次计檀等六度为我迷其行体。后计三十七品为我迷其道法。第四段中明佛永无。文显可知。上来四段合为第一明佛无著自不见转

自下第二明佛体常所以无转。文中可知

第三明转虚假之中初五复次明转虚假非佛独转。后总结叹。转唯佛境。二乘不知。前五何别。若欲别分。初一明转非有为法。第二非生。第三非出。第四非作。第五非造。通则此五共显一义。初中先喻。喻有三句。一举喻事。二眼不念下明其实无。三如是等下明见假有。次合显法。先合初句。如来亦尔举能说人。因六波罗蜜三十七品举所说法。觉了诸法举能说智。因咽喉等起说所依。言语音声能说之辞。为憍陈如举所为人。初说名转正明所说。以是义故不名轮法合前第二。第三一句略而不合。下结其相。不转即法。法即如来。无转即是法之实性。法性即是如来体也。余四番中文相例同。结叹可知

自下第四明佛体寂所以无转。然此文中意为明佛非生出等。乘举虚空佛性类之。先就虚空明非生出。作造有为生之与出对因分别。始起名生。终现名出。作造对。缘始为名作。终辩曰造。有为是总。次就如来。后就佛性

自下第三破遣更转无上之相。于中有三。一遣更转。二遣无上。三总结呵。就初段中云何遣更若是一法重复宣说可名为更。今昔全别何得言更。于中文有八番辩异。一明语别。语犹教也。先举。次列。后辩可知。二随欲别。昔为求小。今为求大。三随根别。昔为中根。今为上根。下根凡夫不堪闻谛。故不为之。四起行别。五得益别。六请主别。七所说别。八远近别。昔出音声闻于梵天。今出音声闻于二十恒沙世界

自下第二遣无上相。明佛所说皆是法轮何得偏叹今为无上。于中初先总明如来今昔所说悉是法轮。如圣王下别显轮义。文有三番。一通就灭恶生善解轮。二偏用灭恶。三偏据生善。皆先立喻。后合可知。自下第三总以结呵。是故汝今不应赞叹如来方更转法轮者。文殊前言转无上轮名为赞。叹诸佛世尊今昔所说悉是法轮。灭恶生善益众生故不应偏叹今为无上。今昔所说迢然别故不应言佛更转法轮

上来第二如来破遣。自下文殊彰问所为自解为他。我于无义非为不达彰已解也。所以问下明为他也。我久知下显已解相

上来第一广辩慧行。是名下结。迦叶白下释其名义有二问答。偏就佛解。文相可知。后一问答通就一切。迦叶先问若是佛行则非声闻缘觉行也。下佛为释。先就佛论。是佛所证是佛所说故名圣行。是诸世尊安住涅槃是佛证也。开示分别是佛说也。以是下结。下就余辩。是声闻等所闻所行故名圣行。声闻缘觉菩萨闻已是其闻也。则能奉行是其行也。故名下结

上来明其因分所行。下次明其果分所成。谓得无畏自在之地诸过皆灭故得无畏。妙德圆成故得自在。无畏自在始成初地。余地渐增至佛穷满。文中初明得无畏地。次明菩萨得自在地。菩萨所成如是无量。况诸佛下举劣况胜

前中先明得无畏地。若有住下辩无畏相。从得二十五三昧下明无畏治。相中得明离六种怖畏。初言不畏贪恚痴等离烦恼畏。离贪心故不惧不活。是故亦名离不活畏。第二不畏生老病死得离死畏。第三不畏堕地狱等离恶道畏。第四恶有二种已下离恶业畏。恶业是其恶名之本。除本末无。是故亦名杂恶名畏。先举二数。次列两名。六道之中皆得造业。人及修罗造业最重故偏举之。下辩其相。偏显人恶。有三举数。阐提谤经犯重列之。五逆之罪不局人中。余趣分有。故略不举。下明菩萨断除不畏。第五不畏沙门已下明离大众威德畏也。第六不畏受二十五有明离生死流转怖畏。六中前五与地经同。后一彼无。上来广辩。是故下结

无畏治中初先明其三昧之体。菩萨入是诸三昧王。若欲已下明三昧用。三昧体中初言菩萨得二十五三昧坏二十五有总以标举。如楞伽说。入初地时得是三昧故破诸有。问曰。初地生死未尽。何能破坏二十五有。释言。生死有其二种。一是分段。二是变易。分段之中有其善道恶道之别。恶道残气初地时尽。善道之中有粗有细。粗尽初地。细至佛地。初地离粗。故说能坏二十五有。曲细论之。如彼二种生死章中具广分别。次广辩列。下总结叹。是名得二十五三昧断二十五有是总结也。如是三昧名三昧王是叹胜也。三昧中胜故说为王。以是王故一一之中备摄无量百千眷属。三昧用中五句可知

次明自在。菩萨入是三昧王已得自在地牒前生后正显其得。下辩其相。依如地经自在有十。一命自在随意任持。二心自在无量三昧自在趣入。三物自在无量净土随意示现。四业自在现生后时随意住时。五生自在一切世界随意现生。六愿自在一切时处随意成佛。七信解自在一切世界佛满示现。八如意自在一切佛国随心转变。九法自在无边法明随意现入。十智自在具佛如来一切种智。今此略明一生自在。于中初法次喻后合。下就地狱显其生相。先明为物生于地狱。次明菩萨不以业生彰因不同。后明菩萨不受大苦显果不同

就下举劣况胜之中。菩萨所成尚不可说先举劣也。况佛可说是况胜也

上来第一广明慧行。自下叹经令人修学。文别有二。一因无垢显经殊胜。二因迦叶明持有益。前中初先无垢藏王牒前诸佛菩萨功德。比挍度量显此经胜。后佛述成。前中初言有一菩萨名无垢藏标别诸人。有大威等彰其诸德。即从座等启请方便。自下正请。申已所解请佛述可而为请矣。如佛所说诸佛菩萨成无量德实不可说领佛前言。我意犹谓不如是经申已所解。何以下释。是经能生阿耨菩提故佛菩萨功德不及。问曰。此经是其言教。阿耨菩提是其果证。教浅证深。何故菩提不及是经。释言。此中偏名宣说佛性之诠法身之教以之为经。所诠即是性净因果。所生是其方便因果。性净为本。方便为末。末不如本故佛菩萨功德不及。准后佛答其义如是。下佛先赞。次印其言。如是如是如汝所说。后述其语。于中更举余大乘经对此涅槃校量显胜。成前余德不及之义。于中初法次喻后合。法中是诸大乘经典虽复成就无量功德泛举余经。欲比已下约对此经以显不及。喻中从牛乃至醍醐合有六阶。虽举六阶意在醍醐。苏出醍醐从下生上。醍醐最上明上过下。若有服下显其胜义。若有服者众病皆除治广故胜。诸药悉入德备故胜。一醍醐中备诸药能故云悉入。合中从佛乃至涅槃亦有六阶。次第合前。佛亦如是合上牛也。此说应身以之为佛。从佛出于十二部经合牛出乳。此说一切小乘经法为十二部。出修多罗合乳出酪。此明大教为修多罗。藉小开大名之为出。于大乘中随别细分亦具十二。今此总相名修多罗。后之四重俱是大乘。于大乘中诠事之教名修多罗。谓说一切施戒等事。从修多罗出方等者合出生苏。于大乘中宣说一切破相空理名方等经。因事显理是故名出。谓说施者受者财物不可得等。从方等经出般若者合出熟苏。究竟证空离相证实之慧名为般若。依理起慧是故名出。约行辩教亦得名为出般若经。然此般若即是向前菩提能也。言从般若出涅槃者合出醍醐。般若了因。了出无始法性涅槃是故名出。约实辩教亦得名为出涅槃经。文中初言出大涅槃辩法同喻。犹如醍醐举喻以牒。醍醐喻性。性即如来约喻显法。此乃即于法身如来非即报身。报身功德不及此经故不即之。以是义下叹法同喻。唯叹如来。略不叹性。如彼醍醐一切诸药悉入其中。如来法身亦复如是。一切功德悉入其中。是故说言如来功德无量无边。自下第二因彼迦叶明持有益。迦叶初先自誓弘经。后佛述可。前中有三。第一迦叶领佛前言显经殊胜。二我闻下明其世人不学者痴。三我于今下自誓弘通。于中初先自欲书写读诵通利。道言剥皮而为纸等明爱深重显经殊胜。然后已下化他令持先为其说。若有众生贪着已下摄之令受。于中六句。初之一句布施摄取。第二爱语。后四利行。略无同事。就利行中初于凡下威逼令读。第二慢高敬事令学。第三诽谤摧伏令读。第四爱乐赞叹令学。下佛先叹。汝今以此善心已下明持有益。就前叹中善哉总叹。汝甚已下五句别叹。始心爱好名爱大乘。贪求属己名贪大乘。正能领纳名受大乘。于所受法味着不舍名味大乘。于所味法信教尊重奉顺修行名信大乘乃至供养。明持益中初正明益。过去已下引往证成。前中汝以善心因缘当超无量诸菩萨前得成菩提明其超证。汝亦复当如我已下明其超说。引往证中文别有三。一明己所行。二明己所成。三以己类彼。明所行中初先举己往昔苦行即是所试。我作如是苦行时下明其捡验即是能试。于中有三。一明帝释始见惊怪欲往验试。二尔时帝释即自变下正往验试。三尔时罗刹还复已下验试已讫释复本形体忏辞去。前中有四。一始见惊怪。二即共下赞其所为。三尔时众中有一天下量其所作。四如是之事实难信下明须验试。初二可知。第三段中三人量之。初一天子言求帝处。第二仙天道其不求。第三帝释乘言述赞。第二人中先标其人。下明所说。先劝莫虑。次举外道苦行类之。后明菩萨苦行所为。世有大士为众生等泛举一切菩萨所作。如我解下将此类彼。帝释叹中如汝言者牒前所说。是人已下三句述可。一明其人能以善法摄取众生。二有佛树下明能灭除众生烦恼。三是人未来作善逝下明能益己。自下第四明须验试。文别有四。一明其难信。二许往验试。三重明难信。四重验试。前中初先总明难信。何以下释。大仙我见如是下结。释中无量百千众生发菩提心见少因缘于菩提动。法说难信。下喻显之。二喻二合。第二许往验试之中我今要当自往试之正许验试。知其堪下出其所验。于中初法次喻后合。是苦行者亦复如是是总合也。我虽下别。持戒深智合车二轮及鸟两翼。持戒是福。深智是解。有行无解不能至果。如车一轮不能运载。如鸟一翼不堪飞翔。第三重明难信之中先举二喻。后合可知。第四重明许验试中初命大仙求与共试。譬如已下明其须试。先喻后合。金须三试。苦行亦尔。帝释于下现可畏形说可畏食催令速施示可畏事。是三试也。第二正往验试之中两义科文。第一就其能试以科。文别有五。第一帝释现可畏形。第二辩才次第已下说可爱法。三大婆罗门汝今不应问我已下说可畏食。四若能舍身谛听已下说可爱法。五说是偈已作是言下催令速施示可畏事。此之一番直科便罢。更不解释。宜审记知。第二就其所试科文分之为四。一闻前半偈心生欢喜。二即从坐起以手举下访求说人。三我时即复语罗刹言若说偈竟我当终身为弟子下求后半偈。四我于尔时深思已下为偈舍身。前中初明帝释说偈。后明菩萨闻偈心喜。帝释说中初明帝释化作罗刹往至雪山起说方便。辩才已下正明说偈。说是半下伫立令见。闻偈喜中初先法说。次举八喻。后合可知。第二访求说人之中句别有四。一求说人举发顾视。向偈谁说略求说人。尔时亦下唯见罗刹。谁开已下广访说人。我于尔下唯见罗刹。二复作念下知是罗刹。先疑彼说。覆复已下疑其不堪。我于尔下重疑彼说。三我今当下正往请问。初思欲问。次身往彼。后便正问。四我问是已即答我下彼闻拒讳。第三求后半偈之中菩萨六请罗刹六答。一请说偈求为弟子。罗刹辞饥不肯为说。二问其所食。彼惧人怖不肯即说。三菩萨重问罗刹便说。四请说偈许为舍身。彼闻不信。第五菩萨彰己实能。彼闻敕听许为宣说。六我于尔时闻是事下施座重请。彼便为说。于中初先正为说偈。偈后长行催令舍身。文皆可知。第四为偈舍身之中句别有六。一闻偈深思处处书写。二即便下欲为舍身。第三树神问其所为菩萨酬答。第四树神问偈利益菩萨为辩。五我为下明舍所为并兴广愿。六正舍身空声称赞。上来第二正往验试。自下第三释复本形礼忏辞去。先复本形。次礼称赞忏谢求度。后便辞去。上来第一明己所行。自下第二明己所成。先牒往因。以是因下正明所成。超十二劫弥勒前者。经中说言超越九劫。今以何义说超十二。释言。有以释迦元初发心之时在弥勒后。是十二劫。彼于三大僧祇劫中勤精进故超越三劫。至彼第三阿僧祇满百劫之初。值弗沙佛勤加赞叹并以余行复超九劫。余经就后说超九劫。今此通论说超十二。此之超劫三藏教中说之为实。大乘法中是权非实。实则菩萨种性已上。行修齐等成无先后。我得如是无量功德皆由供法结果由因。第三段中以己类彼。文显可知。是名圣行总以结之

梵行品者。下明梵行因以标品名梵行品。此品有三。一正明梵行。二王舍大城阿阇世下寄。就世王忏悔灭罪以显病行。三举天行悬指杂华。前中初先正明梵行。二若我弟子受持读诵十二部经与方等经无差别下别经令学。初中复二。一因分所修。二得住极爱一子地下果分所成。前中复二。一说七善以为梵行明化他智。第二宣说四无量心以为梵行明化他心。有人别说知见觉等以为梵行是所不应。下因引证乘以论之。云何即说别为梵行

就七善中文别有四。一问答总举。云何梵行是其问也。住七善法得具梵行是其总也。以此七种顺益众生故名为善二问答列名。何等问也。下列其名。七中初一知其教法。第二一门知其理法。后之五门知其行法。于中前三知自行法。后二知其利他行法。自中初二知己所行。知时集善。知足离过。自知一门知己所成。下利他中言知众者知其所化人之差别。知尊卑者知其所化人之优劣

三广辩释。解知法中先问起发。次解。后结解中菩萨知十二部经总以标举。次列其名。是中应先广解其义。义如别章。文中初言修多罗者此翻名綖。圣人言说能贯诸法如綖贯华故名为綖。随义傍翻乃有众多。言祇夜者此翻名为重颂之偈。故仁王中就此说空名重颂偈。如以偈重颂修多罗中所说法义。名曰祇夜。言授记者外国名为和伽罗那。行因得果名之为记。圣说示人目之为授。言伽陀者此翻名为不重颂偈。故仁王中就此说空名不重颂。如直以偈辞辩宣诸法名曰伽陀。优陀那者此翻名为无问自说。不因咨启而自宣唱名无问自说。尼陀那者此翻名为因缘经也。藉现事缘而有宣唱名因缘经。阿波陀那此名譬喻。立喻显法名譬喻经。伊帝曰多伽者此云本事。宣说他人往古之事名本事经。阇陀伽者此名本生。自说己身往昔之事名本生经毗佛略者此名方广。理正曰方。包富曰广。教从理目名方广经。阿浮陀达磨者此翻名为未曾有经。青牛行钵白狗听法诸天身量大地动等旷古希奇名未曾有。辩说斯事名未曾有经。优波提舍者此名论义。问答辩法名论义经。下广释之。修多罗中先问后辩言从如是乃至奉行名修多罗者修多罗中义别有三。一总相修多罗。始从如是乃至奉行一切通名为修多罗。二别相修多罗。就前总相修多罗中分出十一。余十一部所不收者还复摄在修多罗中名为别相。三本相修多罗。亦名略相。于彼别相十二部中初略标举名修多罗。后广释者随别名之。今此所论是其总相修多罗也。问曰。如是我闻等言阿难后时撰集方有。佛今云何已言如是乃至奉行名修多罗。释言。如来悬据未来故为此说。又佛在时诸弟子等随分撰集亦有经卷。彼经卷中结集之法与未来同。佛今据之故云如是乃至奉行名修多罗。释祇夜中先问次辨后总结之。辨中先辨修多罗相。尔时复有利根已下对修多罗明重颂偈以为祇夜。解授记中先问次辨后总结之。辨中且就弥勒说之。阿逸多者此云无胜。释伽陀中先问次辨后结可知。优陀那中先问起发。次辨。后结。辨中先明如来入定为天说法。次明比丘念佛所作。下明如来从禅定起无问自说。于中如来先告比丘。诸天长寿何故道此。为欲释遣比丘疑念。以天长寿如来暂时为天说法。于其人间已过一夜。下叹比丘所修之行。善哉利他叹其外化。余叹自利。自中具有八大人觉。今此偏叹少欲知足寂静三行。余略不叹。余皆初问次辨后结。文中可知。若能已下总结知法

知义可解。就知时中先问起发。次辩。后结。辩中六句。初止举舍是其内观方便之行。任供佛等是其随缘造修之行。如是时中任供佛师是摄法行。任修施等是其依法造修之行

就知足中先问起发。次辩。后结。辩中初言谓饮食等外中知足。行住坐等内中知足。行住坐卧身业知足。睡之与寤意业知足。语之与默口业知足

就自知中先问。次辩。后总结之。辩中十句。前五知己五品善根。后五知己三业所作。来去身业。正念善行是其意业。正念离恶。善行修善。问答口业

就知众中先问。次辩。后总结之。辩中初先知其众别。应于已下知其化仪。行来坐起是身业化。说法问答是口业化

知尊卑中先问。次辩。后总结之。辩中凡有八种二法。要唯近友闻法思惟如说修行。初三亲近。次二闻法。次一思惟。后二修行

上来第三依名广释。是名菩萨住大乘下第四总结

就四无量明梵行中文别有五。一略标举慈悲喜舍是其梵行。二迦叶白若多修下制定其数。三夫无量心有四种下约就大小辩定优劣。四颇有菩萨得慈悲喜非大已下明修成相。亦得名为分定大小。五迦叶白除无利益与利乐下明四无量实益不虚。就初段中复有梵行总以标举。谓慈悲等辩列其名。四无量义广如别章。此应具论。第二段中迦叶先问。问中有四。前之两番执三难四。第三一番执二难四。末后一番执一难四。就前二中初番约就治门设难。慈悲同治应三非四。后番约就三缘设难。于中有四。一略辩三缘。先举。次列。后类悲等。二就之结难。若从是义应三非四。三广辩三缘。于中先就慈行分三。后类悲等泛辩三缘乃有三义。第一直就化益分别。如此经说。缘诸众生欲与其乐名众生缘。缘诸众生所须三物而施与之是名法缘。缘如来者名曰无缘。义如经辩。第二化益观入分别。前二化益。后一观入。如地经说。缘诸众生欲与其乐名众生缘。缘其一切化众生法名曰法缘。缘法空寂名为无缘。第三亦就化益观入以分三缘。初一化益。后二观入。如地持论及此经说。缘生与乐名众生缘。缘生无我但是因缘五阴法数名曰法缘。观彼阴空名曰无缘。此等具释广如别章。今此文中且依初后两义辩释。就初义中生缘法缘辩释可解。就无缘中缘于如来是名无缘略以标举。下广释之。慈者多缘贫穷众生。如来大师永离贫穷受第一乐。若缘众生则不缘佛。约众生缘以显无缘。众生缘中不缘如来故曰无缘。法亦如是约对法缘以显无缘。法缘之时欲与众生不欲与佛故曰如是。以法缘中不缘佛故名曰无缘。以是下结。以前二中不缘如来故曰无缘。当相应名如来缘矣。问曰。何故缘于如来为益众生。若益众生应是法缘。何故不名为法缘乎。通亦是法。但佛是人故不名法。又为简别世间法故不名法缘。若佛是人即是众生。何故不名众生缘乎。通则如来亦是众生。为欲简别所益众生故不名之。就后义中缘生与乐名众生缘破众生相。见一切法皆从缘生名曰法缘。问曰。不见众生之相云何行慈。解有两义。一念众生妄为我人之所缠缚深可哀伤所以生慈。二为众生说如斯法是则与生第一义乐故名为慈。不住法相及众生相名曰无缘。此中不住众生之相与前不见父母妻子亲属何别。前破生性。此破生相。由见法空依法所成假生亦无。故言不住众生相矣。不住法相云何行慈。还有两义。一念众生妄为有法之所缠缚深可哀伤。所以生慈。二念为生说如斯法。是则与生第一义乐。故名为慈。问曰无生云何复言与生义乐。释有两义。一明菩萨虽不见有众生定性。非不见有假名众生。故得与乐。此义当前法缘之中与乐之义。二明菩萨见法空故乃至假名众生亦无。以此空义破一切法及众生相。众生闻之便舍有相证诸法空。得空之时离本有相羁碍之苦。便说菩萨与生义乐。其实不见众生可与。此义当后无缘之中与乐之义。下以此义类余悲等。上来第三广辩三缘四。是故下就之结难。是三缘故应三非四。上来两番执三难四。人有二下执二难四。先举二人见爱列名。下明所修。见行多嗔故修慈悲。爱多嫉妒故修喜舍。是故已下就人结难。夫无量下执一难四。夫无量者名曰无边边不可得故名无量辩其名义。次就设难。若无量者则应是一不应言四以总征别。若言四者何得无量以别征总。有四可数故非无量。是故下结。佛答有三。一类答前问。二是无量心体性四下总答前问。亦名通答。三如汝所言慈断嗔下别问前答。前中初以说法不定类四无量。或有众生贪财货下化人不定类四无量。说不定中如来为生宣说法要秘密难知总以标举。下别显之。别中初明开合不定。如来有大方便已下法相不定

前中且说十二缘法以论开合。先广论之。如一因缘为众生下举彼因缘类显无量。广中或一。总十二缘唯一有为。或分为二。唯因与果。过去世中无明与行。现在世中爱取及有是其因分。现在识等未来生死是其果分。或说为三。烦恼业苦。无明爱取是烦恼道。行有二分是其业道。余因缘分是其苦道。问曰。无明及与爱取俱是烦恼。何故过去偏说无明现彰爱取。理实齐等。为分世别。隐显异论。等为分世。非无所以。解有两义。一本末别。无明是本故先论之。爱取是末故在现说。二强弱分别。迷其本际。建集生死无明力强是以先说。牵生当果爱取力强是以后辩。又问行有同皆是业。何故过去偏彰其行现在说有。理实亦齐。为分世别。隐显异论。等是隐显。非无所以。过去之业集起已竟。是故当相说之为行。未来之果由业故有。是故就能说之为有。又问识等问是苦果。何故现在偏说识等未来说生死。理亦齐等。但现在世生起已竟是故当相宣说识等。未来未起令人生。厌故说生死。或分为四。无明及行生与老死。举无明支摄爱摄取。举行摄有。举生摄识。举老病死摄彼名色六入触受。或说为五。所谓受爱取有及生。举受摄彼识名色等。举爱举取摄彼无明。举有摄行。举生摄彼老病死等。或说为六。三世因果。或说为七。谓识名色六入触受及与爱取。举彼识等摄生老死。举爱举取摄彼无明。略无行有。或说为八。除无明行生及老死。说余八种。举彼识等摄生老死。举爱取有摄无明行。所以除之。或说九种。除前三支摄入余中。是以除之。亦应说十。文略不辩。或说十一。除生一法摄入余中。或说十二。如为迦叶。迦叶先是缘觉性人。故佛为说十二缘法而得悟道。下以因缘类显无量。如一因缘为众生故种种分别牒前所辩无量。以是义下结劝舍疑。就下法相不定之中初总。次别。后结非虚。如来世尊有大方便是初总也。无常下别。别中细分有十二对。初之四对约就生死涅槃分别。生死之法实无常苦无我不净。如来随化为众生说三十三天常乐我净。如来实是常乐我净。随化宣说无常苦等。次下两对依正分别。于非众生说众生等是其正报。五阴非生如来随俗说为众生。即彼世俗假名众生。如来就实说非众生。亦可如来体真常住名非众生。佛随化故说为众生。生死凡夫实是众生。佛破我人说非众生。非物说物物说非物是其依报。于理非物如来随俗宣说为物。世俗诸物就理说非。次下两对理事分别。非实说实实说非实就理分别。世俗虚假名为非实。如来随俗说为世谛。四真谛等名为说实。即此实者如来就理说为非实。又复妄法情有理无。如来于中说为二谛名为说实。佛性是实随妄流转说为生死名说非实。非境说境境说非境就事分别。三界虚妄但一心作心外无法故曰非境。随心妄取如来说境即彼妄境就实言无名说非境。次下两对就十二缘相对分别。十二缘中观法多种。如彼七十七智观中先观生支起病老死。次第逆推乃至最后观彼无明能起于行。今约此义以举因缘。非生说生生说非生是初观也。于理非生随俗说生。随俗之生就理说非。乃至无明说明明说无明是后观也。越其余支故曰乃至。痴闇之心体是无明妄取分别如来说明。即彼妄明体是痴闇故说无明。下有两对境智分别。非色说色色说非色就境分别。于理非色随俗说色。世谛之色就理言非。非道说道道说非道就智分别。类色可解。如来以是无量已下总结非虚

上来第一以说不定类四无量。自下第二化人不定类四无量。于中先明化人不定。应如已下类四无量。前中初以四句广辩。初三身化。后一口化。如来如是于无量下结成非虚。先明非虚。如来虽处众恶已下释成非虚。处恶不染故无妄罪

上来类答。自下总答。亦名通答。于中有四。一体性不同故立四种。文中直言是无量心体性有四。略不具论。何者是乎。爱怜之心是慈之性。恻怆之怀是悲之性。庆悦之意是喜之性。忘怀之虑是舍之性。心无存着故曰忘怀。二果报不同故立四种。文中直言生大梵处不别论之。依余经中修慈极远生遍净处。修悲极远生于空处。修喜极远生于识处。修舍极远生无所有。具释所以广如别章。三伴侣不同故立四种。先就慈悲明相伴助。慈欲与乐。无悲除苦乐则不生故须修悲。悲欲拔苦。无慈与乐苦则不去故须修慈。是二相须故须并修。次以喜心伴助前二。慈欲与乐。悲欲拔苦。若无喜心除其嫉妒。是则拔苦与乐不胜。故须修喜。喜欲庆物。若无慈悲拔苦与乐知何所庆。故修前二。是三相须故须齐修。次以舍心伴助前三。前三虽欲拔苦与乐庆利众生。若无舍心是则拔苦与乐庆物不得齐等。故须修舍。舍离欲等若无前三拔苦与乐庆利众生知复就何以说平等。故修前三伴助后舍。又复前三是其有行。后一空行。若无空舍是则前三便成爱见。若无前三是则舍心于空滞没。是四相须故须并修。是故名四总以结之。四对治不同故立四种。修慈断贪。修悲断嗔。喜断不乐。舍除贪恚。是其治也。问曰。慈心是无嗔性云何断贪。释言。慈心正能断嗔。傍能治贪。以不贪故能舍已乐惠施众生故能断贪。经说修喜能断嫉妒。今以何故说除不乐。两言虽异共成一义。若有嫉妒。见他得利热烦不乐。由离嫉妒故无不乐。问曰。毗昙说舍无量是无贪性。今云何言能断贪嗔。释言。修舍有始有终。始终通论贪嗔俱治。据终偏于上亲所成。于上亲所舍离贪爱。故毗昙中说为无贪。以是名四非一二三结答前问

自下别答。依上四句次第释之。先解初问。慈悲二心虽俱治嗔。治嗔不同故得分四。文中初先牒其问辞总呵不应。何以下释。以是义下总以结答。是故已下举上伴侣相资不同助以显别。释中初征。下对释之。明嗔有二。一粗二细。修慈断粗。修悲治细。故得立四。于中六番。初番就中先举二嗔。次列两名。后约辩治。夺命之嗔粗重易舍故慈能断。鞭挞之忿轻微难离修悲方治。以是下结。第二番中先举二嗔。次列。后治。嗔众生者应生处生。或容浮薄故慈能治。嗔非众生不应处起。性必深重修悲方治。第三番中先举二嗔。次列。后治。有缘生嗔。性容轻薄故慈能治。无缘生嗔。性必深利故悲能治。第四番中先举二嗔。次列。后治。若藉过去久远因缘而生嗔者去因玄远嗔容轻微故慈能治。若藉现在因缘生嗔亲相起发嗔必增强修悲方治。第五番中先举二嗔。次列。后治。嗔圣人者不应处生易可除舍故慈能治。嗔凡夫者可嗔处生难可除遣修悲方治。第六番中先举二嗔。次列。后治。上嗔易断故慈能治。中嗔难去修悲方治。极微细者修慧方断是以不论。以是义下结答前问。是故以下牒上伴侣相资之义助以显别

复以器下答上第二三缘之难。随彼三缘应说为三。但以器别故说为四。受化之人名之为器。复以器故应名为四总以标举。器若有慈则不得有悲喜舍心别以显之。无乐众生是慈之器。有苦众生是悲之器。得乐众生是喜之器。究竟解脱是舍之器。于彼器中应生慈处则不得生悲喜舍心。余亦如是。以是下结

以行分下答第三难。前言见行多修慈悲爱修喜舍是故应二。佛今答之。行时有别是故应四。行分应四总以标举。若行慈下别以显之

以无量故亦得名四答第四难。向前难言无量应一。若言四种则非无量。佛今答之。良以具足四种无量故得言四

自下第三约就大小辩定优劣。如来先辩。第二领解。如来辩中先举四数。夫无量者则有四种。次列四名。次辩其相。解初门中先问后辩。缘多众生故名为缘。而不能得自在三昧。与乐艰难故非自在。辩第二中先问后释。如缘父母兄弟眷属与乐心易故名自在。所缘狭少故非无量。既非无量云何上言是无量心有四种乎。盖乃是其无量中分故名无量。如一比丘众僧中分亦名众僧。此亦如是。后二门中皆初征问。后辩可知。以是义下就人辩定。以是义故名四无量非诸声闻缘觉所知乃是诸佛如来境界辩大异小。以是亦缘亦自在者在佛菩萨不在余故。非二乘知是如来境。如是四下辩小异大。于中初言声闻缘觉虽名无量少不足言分小异大。诸佛菩萨则得名为无量无边明大异小。领解可知

自下第四明修成相。亦得名为分定大小。始修名小。终成名大。始修之时缘观分别心有所缘则有所不缘故名为小。又难成就故名为小。终成之时灭去缘观心如虚空无所分别等众生界平等摄取故名为大。又成不退过余始学故名为大。文中先明始修之小。菩萨住于初地已下明其出世所成之大。就所修中有二问答。前一问答明修非大。后一问答辩明所修非大所以。前中先问。颇有菩萨住大涅槃得慈悲心非是大不。菩萨人大。涅槃法大。依此所得应当是大而有非者。理在难知故为此问。下佛答之。言有总答。若于下别。是名得慈。非大下结

别中应先辩修得义然后辩文。义有三门。一就生缘以明修得。二就法缘。三就无缘

众生缘中得有二种。一离欲得。二方便得。离欲得者凡夫先来曾依诸禅修四无量。后退诸禅无量亦失。后断下结。得上禅时本失无量。与禅俱得名离欲得。虽复得之而未现前。更起方便修习乃现名方便得。修之云何。先分众生以为七品。怨亲各三谓下中上。中容为一故有七品。良以中人无多阶异故合为一。此经及与毗婆沙论同为七品。人言九品当应谬耳。修法云何。经论不同。依如成实。修前三种在先于彼上亲所起。乃至末后上怨所成。亲所易益。怨难利故。至第七品即名为舍。以平等故。是义云何。先缘上亲欲与上乐。于中亲所欲与中乐。于下亲所欲与下乐是第一品。次缘中亲欲与上乐。于下亲所欲与中乐。于中人所欲与下乐是第二品。如是次第乃至末后于上怨所同前六品齐与上乐。修慈既然。悲喜亦尔。唯有拔苦庆喜为异。前之六品唯得名慈乃至名喜。至第七品拔苦与乐庆物义边名慈悲喜。平等义边即名为舍。若依毗昙。修前三种与成实同。然彼宗中至第七品正得名为慈悲及喜三行成就。不得名舍。以是亲想非是中容。忘怀心故以非舍故别须修习。修法如何。先缘中人而修舍想是第一品。以中人所先无怨亲易修舍故。次缘下怨而修舍想是第二品。次缘中怨而修舍想是第三品。次缘上怨而修舍想是第四品。怨想易遣故并除之。次缘下亲而修舍想是第五品。次缘中亲而修舍想是第六品。后缘上亲而修舍想是第七品。前六是其修舍方便。后一舍成。以其最后上亲所成。故杂心中说舍无量为无贪性。亲想难离故后除之。毗昙如是。大乘法中与昙毗同。故地持中前三之外别修舍心。问曰。前三益众生心可须修习。后一是其背化之心何劳修乎。释言。若不修舍无量。是则前三虽能齐益。多先益亲后及其怨。又无舍心益亲心易利怨心难。为除是过故须修舍。又无空舍前之三种便成爱见故须修舍。众生缘慈修之如是。次修法缘

法缘之中义别有七。一观众生唯是五阴事相之法无我无人而修慈心。二观众生唯是五阴生灭法数无我无人。三观众生体是因缘假名法数如土木城无我无人。四观众生体是妄相虚幻之法如揵闼婆城无我无人。五观众生体是妄想情有之法如梦所见无我无人。六观众生体是真实如来藏性缘起集成五阴法数无我无人。七观众生体是真实如来藏性缘起法界无我无人修习慈心。余亦如是

次明无缘。无缘有四。一观五阴虚假无性。二观五阴空寂无相乃至因缘假名亦无。三观五阴妄想所见由来无法。四观五阴体是真如。从本已来不起不灭而修慈心。余亦如是。修成之义具应如此。但今文中唯就生缘以辩修相。余略不论

众生缘中唯明修慈。余略不辩。文中有二。一分慈境。二于上亲下约境修慈。境中初先据要分三。后离为七。三中菩萨于诸众生三品分别总以标举。亲怨中人列其名字。下分此三以之为七。亲中分三谓上中下。怨憎亦尔。即以为六。中品不分是以不论。通之为七。下约修慈。于上亲中与增上乐是第一品。于中下亲亦复平等与增上乐。即是第二及第三品。第四一品于中人所与增上乐。文略不说。于上怨中与少分乐。于中怨所与中品乐。于下怨所与增上乐。是第五品。如是转修于上怨中与中品乐。于中下怨等与上乐。是第六品。转复修习于上中下等与上乐。是第七品。下重显之。若上怨中与上乐者名慈心成辩后异前。菩萨尔时于父母所及上怨所得平等心显其成相。上来别竟。是名下结

自下第二辩前所修非大所以。迦叶先问。世尊何缘得如是慈犹不名大。下佛为释。以难成故不名大者略释非大。何以故下广释非大。于中初法。如豌豆下四喻显之

下次明其所成是大。文别有二。第一正明所成是大。二先得世下举小显大。前中菩萨住于初地名曰大慈就处总指。下别显之。言何以故征前起后。下对释之。句别有三

一于阐提大恶众生堪忍不嗔故名大慈。先举阐提次明不嗔。以是下结

二能广益故名为大。除无利益名大慈者明能拔苦。欲与利乐名大悲者明能与乐。余处多说慈能与乐悲能拔苦。今以何故说慈拔苦悲与乐乎。释言。慈心正欲与乐。若不除苦乐则不生故说除苦。又与乐故苦事不起故说除苦。悲心正欲拔众生苦。若不与乐苦则不去故说与乐。又除苦故乐事得生故说与乐。于生心喜名大喜者。见生得利等皆庆之故名大喜。舍中泛论具有七种。一心性平等名之为舍。二于众生舍离一切怨亲之碍故名为舍。三见众生究竟解脱放舍名舍。四舍一切贪嗔等过故名为舍。五证空平等舍离众相故名为舍。六以己善根施与众生名之为舍。七利众生无所悕望故名为舍。故维摩云。有所福祐无所悕望故名为舍。今此且依三义释之。无所拥护名为大舍是前第二舍离怨亲。以无偏亲故无拥护。若不见我法相己身见一切法平等名舍是前第五行空平等名之为舍。自舍己乐施与他人是名大舍是前第六舍五善根与他名舍。问曰。已善云何施他。愿以己善饶益于彼。后得乐时如愿能益故名为施。此是第二广益名大

四三唯四无量能令已下能生广行故名为大。唯四能令增长具足六波罗蜜辩胜过劣。余不必尔举劣显胜

上来正明所成是大。自下第二举小显大。先得世间四无量心然后乃发三菩提心方得出世正明菩萨从小入大。因世已下总以结之

自下第五明四无量实益不虚。迦叶先作无益之难。后佛明益。难中有三。一明慈观不真。二若非虚妄实与乐下明慈无实益。三若实不得乐如佛所说我念往下执因疑果

前中初法次喻后合。下结明虚。法中世尊除无利益牒前大慈。与利乐者牒前大悲。实无所为略显不真。如是思惟即是虚等广显不真。喻中有五。合文可知。虽口发下结以明虚

第二难中若非虚妄实与乐者以理定佛。而诸众生何故不以佛菩萨力一切受乐即事以征

第三难中执因疑果。若当真实不得乐者牒上虚因。如佛说下举其实果。若不实者云何得与此义相应执因疑果。就举果中如佛说等别明慈果。独修慈心乃得下结。别中先明修慈生梵。次为帝释。后作轮王。生梵正报。帝释轮王是余残果。余文可知

下佛先叹。说偈下答。答中还三。一对上后难辩明慈心有实果报。二夫修慈者实非妄下对上初难明其慈观是实不虚。三迦叶白菩萨思惟悉是真下对前第二辩明慈心有实利益

初中四偈。其第一偈对一众生明其劣慈。其第二偈对一切生以显胜悲。先举悲心。是名已下叹以显胜。后之两偈举他广施对上劣慈比校不及。显前胜悲果实无穷。设使五通明福田净。五通行净故偏举之。悉满大地彰福田多。有自在主奉施所安。象马种种明施物广。其自在主能为广施故偏举之。此施得果虽复无量。欲比向前一众生中所修一慈。十六分中不及其一。况能令加。十六亦是一数之门。如一斤物十六两等。于彼劣慈尚不相比。何况胜悲

第二段中夫修慈者实非妄想谛是真实总明慈实。若是声闻缘觉已下别明慈实。慈若有无非有无下就实叹胜。初总可知

别中初先开列两门。若是声闻缘觉之慈是名虚妄。是第一门举妄题真。虽复生心不能实益故名虚妄。诸佛菩萨是实不虚。是第二门辩真异妄

下广显之。云何知耶征前起后。云何得知二乘慈虚佛菩萨实。下对显之。先广后门明佛菩萨慈是真实。慈若无常是声闻下广上初门辩明声闻缘觉慈虚。明佛菩萨慈是实中先明菩萨慈是真实。能为善者名实思下明佛慈实。菩萨慈中三门辩实。一有实用故名为实。二能为实治故名为实。三能生实行故名为实。初中先别。当知下结。别中观土以为金等约就外法以明实用。观实众生为非生等约就内法以明实用

第二段中先问。次辩。以是下结。辩中谓能断除烦恼总明实治。夫修慈下别明实治

第三段中四无量心能为一切诸善根本总明慈等能生实行。下别显之。别中且就一慈以论。余类可知。于中先明出生大乘不共善法。声闻缘觉菩萨诸佛慈为本下出生三乘共行善法

前不共中四无量心皆能出生。且论慈行。慈行实能生一切善。且说布施。若不见贪无缘生慈若不生慈则不能施反明无慈不能行施。以施因下顺明有慈故能行施。此言略少。若具应言由见贫穷故生慈心。由生慈心故能行施。以施因缘令生得乐

所谓已下广辩施相。先列施物。如是施时心无系下明其施心。心中有二。一自行心净。二菩萨施时慈心等下化他心净

自中依如相续解脱说施有五。一者无障。亦名无疑。谓行施时断离悭障。二者无顾。不求名利及与恩报。三者无过。修行施时不离烦恼无方便过。四无妄想。心无分别。五回向菩提。今此具有

先明无障。如是施时心无系缚明其无悭。不生贪着彰其无贪。远离此二故云无障。次明回向。以施回向阿耨菩提

下明余三。无顾无过合为一门。无妄想者别作一门。文中初先开列两门。心无依止是第一门。略明无顾及明无过。妄想永断是第二门。略明无妄

下广显之。先广无依。句别有八。一不为怖而行布施。二不为名。三不为利。四不求人天所受快乐。五不生憍慢。谓于受者及他人所不起慢高。六不望前人现在反报。七不诳他。以其实物如实施与。八不求富贵。此之八句广上无依。此八句中第五不慢第七不诳广显无过。余显无顾

凡行施下广前妄断。于中初先正明离妄。菩萨若见持戒以下举过彰离

前中初明不著有相。虽不见下不着无相。常行施故

后中初法次喻后合。法中初明由分别故不能行施。次明菩萨不行施故不具檀度。后明菩萨不具檀故不得菩萨

喻中但喻向前初句。于中有四。一由乞生悭喻。二其人下诸佛菩萨教修惠施喻。三彼人下妄想分别喻。四如是痴下分别妨施喻。初中如人喻彼悭者。箭喻乞人。由彼乞求发其悭病名被毒箭。第二段中诸佛菩萨亲益其人名为眷属。为令其人破离悭病安住善法名欲安隐为除毒矣。访求施法名为命医。教依施法发遣乞者名为拔箭。第三段中由生分别停其施意是故说言且待莫触。我今已下正显分别。于中有三。一分别乞人推其来处故言是箭从何方来。问其遣者故言谁射为是刹利婆罗门等。二分别其行。竹耶柳耶分别其戒。戒有坚软。坚者如竹。软者如柳。其镞铁下分别其慧。慧能破障故说为镞。慧依教生是故问言何治所出。慧有坚软故复问言刚耶。柔耶其毛已下分别其定。定能正心如毛直箭。故以喻之。定必在人。人有凡圣。是以问言是何鸟翼乌耶鹫耶。三分别乞辞。由彼乞辞能生悭病故说为毒。辞有自作他教之别。是故问言为从作生自然而有。辞有美恶故言人毒蛇毒耶。此第三竟。第四段中明由分别妨行施业。是以呵言如是痴人竟未能知寻便命终

合中初言菩萨亦尔合初人也。若行施时第二段。分别受等合第三段。终不能下合第四段。于中还三。一由分别不能行施。二不行施故不具檀度。三不具檀故不得菩提

上来一段自行心净。自下第二化他心净。于中初明化他之心。布施食时常作愿下明化他心愿。中具明四无量心。皆初法说。后喻显之。愿中有八。文显可知

上来明慈出生大乘不共善法。下次明慈出生三乘共行善法。于中初总次别后结。总中声闻缘觉等善慈为根本明末依本。菩萨修慈能生如是无量善根明本生末。慈为众生修诸善行故生一切。所谓下别。于中先明生二乘善。菩萨佛智生大乘善。二乘善中有方便道见道修道及无学道。从初乃至世第一来明方便道。方便道中初至三观声闻观行。十二缘等缘觉观行。燸等四心通明声闻缘觉观行。就初分中。所谓不净出息入息五停心观具应有五。且举此二。无常生灭是其总相。四念处者是其别相。四念处观依行次第。先别后总。今据说时先总后别。七方便者且就色说。余类可知。所谓观色色集色灭色对治道色味色过及与色出。依如毗昙。前四在于四现忍心乃至见道。后三修道。若依成实。此七同在闻思地中。三观处者。依如毗昙。观阴界入名三观处。此观在于总相念处。若依成实。观法无常苦与无我名三观处。此观在于四现忍中此等。皆是声闻观行。十二因缘无我观者是缘觉观。暖顶已上二乘同观更无差别。言见道者。依如成实。见四谛空名为见道。若依毗昙。见于四谛十六圣行从苦法忍至道比忍此十五心名为见道。言修道者。道比智后重缘谛理断诸烦恼名为修道。此句是总。正勤等别。别中先明三十七品。义通上下。今此偏就修道中说。次说四禅。广如别章。四无量心如上广辩。八解脱者。内有色相外观色一。内无色相外观色二。净色解脱以为第三。空处第四。识处第五。无所有处以为第六。非想解脱以为第七。灭尽解脱以为第八。义如别章。八胜处者。分前三脱以为八处。内有色相外观色少是初胜处。内有色相外观色多第二胜处。内无色相外观色少第三胜处。内无色相外观色多第四胜处。青黄赤白复以为四。通前八也。八中初二是初解脱。次二是其第二解脱。后四是其第三解脱。一切入者十一切入。依余经论。青黄赤白地水火风是其八种。空处识处复以为二。通前为十。若依此经。于前十中除火一切加无所有以为十矣。空无相愿论说不同。依如毗昙。分十六行以为三门。空无我行名为空门。灭下四行为无相门。余名无愿。若依成实。观法性空名为空门。于此空中无相可取名无相门。于此空中无有贪求愿行之心名无愿门。无诤已下明无学道。于中先明无诤三昧。利根罗汉观察欲界一切众生知起烦恼起将护心不与其竞名无诤三昧。下明六通。知他心智是他心通。及诸通者所谓身通天眼天耳。知本际者是宿命通。下声闻智及缘觉智是漏尽通。上来出生小乘善法。问曰。此明菩萨慈实能生实行。今云何说生二乘善。菩萨亦修二乘善故。菩萨佛智生大乘善。上来别竟。如是下结。如是等善慈为根本结末依本。以是义下结慈是实。若人问下重显向前慈为行本。初先假问。后对显之。以是义下重结慈实

上来广明菩萨慈实。自下广明佛慈是实。有十六句。一一句中先就慈行开出余义。次以彼义即于慈心。后以慈心即于如来。文显可知

上来广明诸佛菩萨慈是实竟。下次广前声闻缘觉慈是虚妄。有十六句。一一句中皆先就慈辩无常苦无我等过。次以彼过即于慈心。后以彼慈即声闻人。文亦可知

上来第二别明慈实。悲若有无非有无下是第三段就实叹胜。于中有二。一叹慈深。二住涅槃修如是慈。虽复安于睡眠已下明修利益

前中初先正叹慈深。慈若不可思议已下叹其所学成慈不思。就正叹中慈若有无非有非无辩慈体相。诸佛菩萨有其真实平等大慈名之为有。攀缘心断目之为无。离一切相离一切性故名非有。于一慈中备含法界一切种德故曰非无。如是已下牒以叹深。以此行深故非声闻缘觉所思。叹所学中慈若不思牒前类后。法不思下正叹所学成慈不思。法不思者叹其教法。性不思者叹其理法。如来不思叹其果法。亦可初二叹所依法。如来不思叹所依人

明修益中先明修益。是大涅槃微妙已下还叹所学成前修益。前中先别。夫修下结。别中五句。依余经中说修慈心有十一利。谓卧安觉安天护人爱下毒不兵水火不丧眠无恶梦死生梵天在所得利。今此文中别列五种。余总结之。初言菩萨虽安睡眠而不眠者是初卧安。心寂似眠而实非眠。勤精进故释不眠义。虽常寤悟亦无寤者第二觉安。内心明了故名寤寤。非是从眠始得寤寤故名无寤。以无眠故释无寤义。眠中天护即是第三天护义也。诸天敬念故名为护。菩萨不假名亦无护。不行恶故释不假护。眠无恶梦是第九利。无不善等释无恶梦。命终生梵是第十利。随化有生。实则无之。得自在者释无生义。夫修慈者成如是德总结余六。叹所学中大涅槃经亦成如是无量功德叹所学法。诸佛亦成无量功德叹所学人。良以此等具无量德。是故依之成慈无量

迦叶白下大段第三却答向前第二番难明慈实益。于中先明慈有实益。夫无量者不可思下就实叹胜。前中有三。一明菩萨慈有实益。二我说是慈有无量下明佛慈实益。三以是义故菩萨修慈即是实下结以显实。初中迦叶重难起发。难辞同上。初言菩萨所有是实声闻缘觉非真实者牒佛前言。下就设难。一切众生何故不以菩萨威力等受快乐以实征益。若一切生不得乐下以无利益难破慈实。下佛答之。初法次喻后合下结。法中菩萨慈非不益总答前问。下别释之。于中先明众生受苦有定不定。下约此二明益不等。喻中如人见师子等自然生畏喻见如来实能益者而得利益。夜行见杭亦生畏者喻见菩萨始学慈者亦得利益。此未明佛举类菩萨。下次合之。如是诸人自然生畏牒前夜行见杭生畏。众生如是见修慈者自然受乐约以显法。以是下结。自下第二明佛慈实。我说是慈有无量门就宽通举。一慈门中备含法界一切种德名无量门如上文说。慈者即是真实思惟。慈即大乘即菩提等是无量门。又复如彼维摩经说。行寂灭慈无所生故。行不热慈无烦恼故。乃至行于安乐慈等。常知亦是无量门矣。所谓通者随别以标。于无量中且就一通以显慈实。如提婆下即事显之。于中略举八种成事明慈实益。悲喜如是。类显余行。何不论舍。舍行平等起益相微所以不说。向前先明菩萨慈实。次明佛实。以是义下就初以结

上来第一明慈实益。下叹显胜。无量不思正叹慈深。下叹余义助成慈行。菩萨所行不可思议赞叹慈因。诸佛所行不可思议赞叹慈果。大涅槃经不可思者赞叹慈法

上来明其因分所修。下次明其果分所成。于中初明四无量果。八知见下明前所修七善法果。无量果中前三有行共得一种极爱之果。后一空行独得一种空平等果。前中有四。一明菩萨修慈悲喜得住极爱一子之地。二迦叶白下拂去化迹成前极爱一子之义。三迦叶领解。四如来述赞

就初段中先总标举。修慈悲喜得住极爱一子之地。极爱一子在于初地。见善心喜名为极爱。睹恶愍念称曰一子。下别显之。初先双问。下对释之。有五复次。前一复次解释极爱。后四复次释成一子。于中前三悲怜如子。后一复次随逐如子。就前三中初见众生起烦恼时悲怜如子。于中初喻次合后结

二见造业悲怜如子。初先立喻。法身未增名为小时。造恶在身名取土等置于口中。菩萨观知名父母见。惧招当苦名恐为患。以定拔心名左捉头。巧智教断名右挑出。次合显法。菩萨如是合前父母。见诸众生合前见已。法身未增合前小时。行身等业合取土等置于口中。则以智拔合右挑出。左手捉头略而不合。不欲令下合恐为患。是故下结

三见受苦悲怜如子。先喻次合。菩萨亦尔合前父母。见一阐提合所爱子。堕于地狱合舍终亡。愿与俱生合与并命。何以下释。是故下结

下明随逐。先喻次合。菩萨如是合前父母。见诸众生合有一子。若堕地狱畜生饿鬼合前睡也。造作善恶合行住等。造善如行。在恶如似住坐卧等。常念不舍合心常念。若行诸恶不生嗔等合有罪咎。善言诱喻不加其恶。是故下结

自下第二拂遣化迹。迦叶先问。问中先举如来所说彰已不解。下出所疑征问如来。随事有二。一以极爱征佛昔日为仙豫王杀婆罗门。二以极爱责佛今日呵骂调达。就前难中具应有四。一问菩萨住一子地既能如是。佛昔云何为仙豫王断绝尔许婆罗门命。二问尔时得此地不。三问尔时若得此地应护众生何故断命。四问尔时若不得此极爱之地何因缘故不随地狱。准答应尔。但今文中唯有三问。略无第二。文中虽无。理必须之。就后难中句别有三。一责如来等视一切如罗睺罗。何缘呵骂提婆达多令生嗔恚出佛身血。二责如来何缘复记当堕地狱受罪一劫。三举须菩提善护物心上责如来。于中初先明须菩提善护物心。先就乞食明护物心。后就行住坐卧四事明护物心。次以须菩上类菩萨。后以菩萨上责如来。菩萨若得一子地者何缘如来发粗恶言使彼调达起重恶心

下佛答中先呵难辞。次自勉过。后正解释。汝不应言如来为生作烦恼缘是呵辞也。迦叶向言如来何故骂提婆达痴人无羞食人[口*弟]唾令生嗔恨名为如来作烦恼缘。故牒呵之

假使已下自勉过也。有九复次。初七复次假喻勉过。宁与毒下有一复次以理诫劝。如来真下有一复次举益翻损。真实为生断除烦恼。云何为作烦恼因缘

下正解中依前两难次第辩释。就初难中依如上文但有三句。具应有四。备如向辩。下依此四次第释之

汝言往昔杀婆罗门牒向初句。下释有二。一举畜况人明已不杀。尚不杀蚁况婆罗门无恶心故。二常作下举益翻损明已不杀。菩萨常作种种方便惠施寿命总明益也。夫施食下约就六度别明化益。以是义下总以结之

汝向所问杀婆罗门时得是地不牒第二句所少之问。准此牒辞向前定有。我时已得当问正答

以爱念下释第三句。向前问言若得此地则应护念何故断命。今明菩萨以爱念故断其命根非是恶心。文中初言爱故断命是其总也。譬如下别。别中有二。一以轻夺重故非恶心。先喻后合。二常思下举益翻损。于中初言菩萨思惟以何因缘能令众生发起信等是巧杀心。诸婆罗门命终已下是巧杀益以是义下结已非杀

有人堀下释第四句。向前问言若当尔时不得此地何因缘故不入地狱。然今具释应有三义。一于尔时已得此地为是不入。二无恶心。三以所杀诸婆罗门都无善根为是不入。文中但彰后之二义。初一不论。于中先明无恶心故不入地狱。婆罗门法杀害蚁下明婆罗门都无善根杀之不入三品杀中为是不入

前中举彼恶心残害草木等事入于地狱反显自已于婆罗门无恶心杀为是不入。文别有四。一举恶心残害非情反问迦叶入地狱不。二迦叶正答明入地狱。三佛赞其言。四以所答反显自己无恶心故不入地狱。初段可知。第二段中迦叶初先取意以答。如我解佛所说义者应堕地狱。何以下释。释中先举如来昔日明于非情不得恶心。后明恶心故堕地狱。并皆先问后答可知。第三段中佛先叹善。后劝应持。第四段中别有四句。一牒前恶心堕于地狱明己昔日实无恶心为是不入。二何以下举已怜益成无恶心。先征后辩。三所以下显怜益相。先征后辩。善知因缘诸方便者是巧杀智。知杀因缘生其善根名知因缘。知加少苦后得大乐故曰方便。以方便力令种善者是巧杀益。由杀堕狱生其悔心名种善根。四以是下结成昔杀非恶心义

自下第二明婆罗门全无善根为是杀之不入地狱。于中有三。一举外道三品邪杀。二佛及菩萨知杀三下翻对前邪明三正杀。三若有能杀一阐提下明己昔日杀婆罗门不入三品正杀之中。以是义故不入地狱。初段可知。第二段中先举。次列。后辩其相。明三品杀齐入地狱不同外道。第三段中别有四句。第一泛明杀阐提者不入三杀。二彼诸下明婆罗门悉是阐提。三譬如下明杀阐提都无罪报。先喻后合。四何以下明婆罗门是一阐提无信等根是故杀之不入地狱。问曰。下说布施畜生得百倍报施一阐提得千倍报。是则阐提胜过畜生。何故杀之轻于畜生。释言。施杀义应齐等。而下文中言施阐提胜畜生者。观相行施。彼一阐提人报胜畜。对之行施其心多重故胜畜生。今此文中言杀轻者。观根行杀。以知阐提全无善根杀无恶意。是故无罪。不同畜生

次释后难。明己实不骂提婆达示化为之。于中初先牒问总呵。何以下释。释中有二。一举化类答。二我实不下就实正答

类中先举口化类答。二如我一时游旷野下举身类答。口中诸佛凡所发言不可思议总以标举。下别显之。具应有八。一柔软实语于化无宜如来不说。二柔软实语于化有宜如来宣说。三柔软虚语于化无宜如来不说。四柔软虚语于化有宜如来宣说。五粗犷实语于化无宜如来不说。六粗犷实语于化有宜如来宣说。七粗犷虚语于化无宜如来不说。八粗犷虚语于化有宜如来宣说。今此文中但有三句。初先明其柔软实语于化无宜如来不说。先辩语相。文中最初少一柔软。或有实者语当前事称己心想。为世爱者惬悦人情。言非时者不应物机。言非法者不当法理。不为益者于人无宜。前三虽好。以后三过所以不说。次明粗犷虚妄之言于化无宜如来不说。先辩语相。粗犷翻前所少柔软。虚妄翻实。不爱翻爱。非时非法不益同前。下结不说。第三明其粗犷实语于化有宜如来宣说。先辩语相。粗犷同前。真实翻虚。时翻非时。法翻非法。能为利益翻上不益。不悦同前闻者不爱。次明宣说。何以下释

身业类中佛化无量。略举七事。文显可知

上来类答。自下正等。文别有四。一佛自彰己不骂调达。二明调达实无所作。三是故汝下就前第一结呵难辞。四汝于佛下对前第二结劝舍疑。初段可知。第二段中初明调达实非凡夫。谓不愚痴乃至非是一阐提等。次明调达实非二乘。后叹显胜。非二乘境唯佛所知。后二可解

上来第二拂去化迹成其极爱一子之义。自下第三迦叶领解明问有宜。初甘蔗喻明问益已。后真金喻彰问益他。前中先喻。我亦如是合煮甘蔗人。从佛数闻合数煎煮。下次合其得种种味。多得总合。谓下别合。言出味者是出家乐。离欲味者是远离乐。寂灭味者是寂灭乐。言道味者是菩提乐。如地持说。此四种中初一是戒。次二是定。后一是慧。亦可出味明其出苦离欲断集寂灭证灭道味修道

明益他中先喻后合。如来亦尔合前真金。郑重咨问合数烧等。则得见闻甚深义等合转明净调和柔软光色微妙。令深行者受持奉修无量众生发菩提心。合价难量深行奉修起行求之无量发心。起愿求之是故名为价难量矣。然后为诸人天宗等合后乃为人天宝重

自下第四如来述赞。先叹问意。以是义下明己答意

涅槃义记卷第五应永三年六月二日拭老眼补阙字了可哀可哀　　　　　法印权大僧都贤宝(生年六十四)涅槃义记卷第六

        隋净影寺沙门释慧远述

下明舍果。文别有三。一问答略辨。二问答广释。三住是地于一切法无滞碍下释显地名。略中迦叶初先领前问后起发。修慈悲喜得一子地是领前也。修舍得何是问后也。下佛先赞。后为辩释。修舍得住空平等地总以标举。如须菩提就人类显。菩萨所得胜过须菩以粗况细且言如耳。亦可须菩实是菩萨。证空渊深。故就指斥。下别显之。于中初法次喻后合。法中住空不见父等是众生空。不见阴等是其法空。众生寿命复明生空。与前何别。前离生性法空前得。此离生相法空后得。依法所成假生亦无。喻文可知。合中诸法亦复如是无有父母乃至寿命就法以合明其空义。菩萨见下就人以合明得空地

广中先问。但问空理不问能见。下佛答之。文别有四。一明空义。二约空辩观。三从菩萨得如是下就向后段结明观益。四我今于是众中说下就上初段结明说益

初中空义开合非一。今据一门且论十一。前十相空。后一真空。就彼妄情所取法中以明空义名为相空。就真识中以辩空义名曰真空。亦得说言前十境空后一智空。真智空矣。于妄分齐情外有法。破之显寂。故前十种就境明空。据实以求心外无法。一切诸法皆即真心。真心体寂。故后一种就智说空。故地论言一切法如说自体空名智自空。就前十中初八以无破有为空。第九以有遣无为空。第十以其非有非无双破有无名之为空。与地经中十平等同。就前八中初七明其众生及法无性故空。后一明其众生及法无相故空。因缘假中而无定性名无性空。毕竟空中无因缘相名无相空。就前七中初六明其众生无性即是生空。后一明其诸法无性即是法空。复前六中初五就其现在观空。后一就其过去观空。现中初三就内外事以观空理。后二就其有为无为法相观空就前三中众生为内。非情为外。就内法中观无神主众生寿命名为内空。未空法体。观彼外法非我我所故名外空。又复观彼舍宅丛林车乘等事虚假无实亦名外空。未空法体。内外合观名内外空。何故须合。解有两义。一随人分别。人有三种。一着内情多须教观内。二着外情多须教观外。三内外俱着须教合观。二就观行始终分别。凡夫本来谓内有我故先观内。内未不得谓外有之故复观外。向者观内不及其外。观外之时复不及内。于此二中犹疑有我故须合观。问曰。诸法总知即易。别知则难。故二乘人但能总相知于苦等不能别知。菩萨方能差别异知。云何今此先别后总。释言。诸法有其二种。一者同相。二者别相。空无我等诸法齐观总通名为同相。色受想等事相各异名为别相。于此二中若欲寻同以知其别。总易别难。故先观总。后观其别。若欲寻别以知其同。别易总难。故先别观。后为总观。今依后门。先别后总。此前三种就事明空。有为无为就法明空。苦无常等生灭法数是其有为。虚空数灭非数减等是其无为。有为法中无我我所名有为空。非空法体。无为法中无我我所名无为空。是中亦未空其法体。问曰。向前内外等中离合为三。今此有为无为法中何故不然。释言。准置理亦无伤。但今为明内外二法同是有故。合观则易。是故第三内外总观有为无为。有无位别。合观则难。故无总矣。此前五种就现观空。无始空者更无别法。但就过去观前五空名无始空。何不就当说无终空。准置应得。故地持中三世俱观。但今为明过去之法起患根本。无始已来所执着处故须观之。过现既空。类后可知。不就后说无终空矣。又三世法次第相生。过为现本。现为当本。现法易观故先观之。现由过生。故就其本说无始空。本坏末随。故不就后说无终空。又问者尔六通之中亦应如是但知过现。何用天眼知未来乎。释言不类。六通知事。三世事别故须别知。此观空理。理同可推故不别论。上来六种明其生空。次辩法空。言性空者观法虚假无有自性名为性空。上来七门是无性空。无所有者见因缘相亦无所有名无所有空。此无相空。是以下言如人无子名之为空。非是就子明无性空。亦如贫人无物名空。非是就物明无性空。上来八空以无破有。第一义空以有破无。名前八空为第一义。一切诸法空而常有。故非定无。非定无故无第一义自性可得。是故名为第二义空。上来九空别破有无。第十空空有无双遣。又前九空遣有无性。第十遣其有无别相。前有及无二俱是空故曰空空。是义云何。因缘之法有无同体。以同体故无法为有有法为无。无为有故有即非有。有为无故无即非无。非有非无故曰空空。此前十门破遣情相以明空理。第十一空就实辩空。真心离相故名为空。又真识中旷备法界恒沙佛法。是诸佛法同一体性互相集成。未有一门别守自性。故说为空。法界皆空。空宁不大。是以就实说为大空。但就实中经说不同。地经之中就隐论之。故彼宣说阿梨耶识以为大空。此就显时。故说波若以为大空。即彼真识显为波若。非是妄治缘照波若。波若体寂故曰大空

上来明空。下约辨观。先观内空。于中初问次辩后结。辩中义三。文别有四。言义三者。一观内中无彼妄计众生寿命常乐我净。二于此空中无其外物。三于此空中无佛法僧及与佛性。以此相空未及实故。始从内空乃至无始例有此三。但于空中所无异耳

文别四者。一观内中无有父母众生寿命乃至无彼妄情所讨常乐我净。二于此空中无佛法僧。三于此空中无外财物。问曰。内中无外财物应是互无。今以何义说为理空。释言。内中无外财物实是互无。但今于彼内空之中无外财物。故是理空。下外空中无内物等类皆同尔。应当知之。四于此空中无其佛性。是内法中虽有佛性穷实明有。而是佛性非内非外随相说无。今此正明内中无人未辩余义故无佛性。是中唯应说性非内非外乘论。所以下释。先问后断。以性常住故非内非外。良以内空随法治空。佛性是常。与彼全别所以不在

次观外空。外亦如是举后类前。三义同前故云如是。无有内法彰其异义。向前宣说内空之中无外财物。今此宣说外空之中无内阴法。有斯异耳

次观内外。内外如是举后类前。三义同一故曰如是。唯有已下解释如来法僧佛性不在三空。于中先举。何以下释。是故下结。是名内外总以结之

有为空中先牒次释。后总结之。释中有为悉皆是空是总释也。所谓下别。别中二义备如上辩。一有为法中无彼横计众生寿命常乐我净。二于此空中无内外事。三于此空中无佛法僧及与佛性。文中先明无内外事。常乐已下明无妄计常乐我净众生寿命。如来已下明此空中无佛法僧及与佛性。第一义者犹是佛性。相不及实是故皆空。是中已下别释此空无佛性义。文显可知

无为空中先问。次辩。后总结之。辩中无为悉皆是空总以标举。所谓下别。别中三义备如上辩。一无为空中无有横计众生寿命常乐我净。是中未空无为法体。二于此空中无内外事及有为法。三于此空中无佛法僧及与佛性义。唯此三文有六句。一明此空中无苦无常不净无我有为之法。所谓已下少一无字。若具应言谓无无常苦无我等。二明此空中无阴界入内外之事。三明此空中无众生寿命此正所空。四重就初句明无有为有漏之法。王重就第二明无一切内外之事。六明此空中无佛法僧及与佛性。佛等四法非是有为亦非无为略以标举。性善下释性是善故非无为者。就无为中虚空非数灭体是无记。佛等是善。故不在中。之无为中世俗等智断结数灭体虽是善以粗浅故。佛等不同。如此之义今略不论。常非有为。理在易知。是中正应明非无为。有为是其无为家对。乘以论之

无始空中先问起发。次辩。后结。辩中生死无始悉空总以标举。所谓下别。别中三义备如上辩。初明无彼妄情所计常乐我净众生寿命。二明此空中无佛法僧及与佛性。三明此空中无彼内外有为无为一切诸法。文中但明无无为法。余略不论

就性空中初问起发。次辩。后结。辩中菩萨观一切法本性皆空总以标举。谓阴下别。谓阴界入无常苦等举有为法。常乐我净举无为法。常乐我净有其二种。一是方便常乐我净从缘修生本无自性。二者自体常乐我净性出自古。今就初门宣说性空。后门即是大空所摄。今此不论。如是等法不见本性总就明空。从缘始集本无自性是以不见。此等即说法体无性。不同前六法中无人。虽说性空未空因缘假名之相。故不同后无所有空。问曰。向前六空之中并简如来法僧佛性。此性空中何故不然。释言。今此通就报果常乐我净以明性空。常乐我净是佛法僧所以不简。又佛常乐我净报果通亦名性。以是义故相不简佛性。下余空中不简例然

无所有中先问。次辩。后总结之。辩中先明假名人相本无所有。愚痴人下明其因缘假名法相本无所有。前中先喻。如人无子言舍空者子相亦无。不但无性。毕竟观空无有亲爱约之显法。此无人相不同前六空无人性。后中先喻愚痴之人言诸方空明其所异。愚人虽说诸方是空。于事分齐方实不空。贫穷之人言一切空彰其所同。贫穷之人言无物者物相亦无。非直无性。如是所计或空不空重辩前喻。贫人所计实无所有故言或空。愚人所计事实不空名或不空。下约显法。菩萨观空如贫无物一切皆空。不同愚人不空言空

第一义中先问。次辩。后总结之。辩中初先明第一义。后就说空。前中初先就眼说空。后类诸法。后中先问。何等名为第一义空。有业有报故非定无。非定无故第一义空。以其因缘假有破无。不将性有而破彼无。故复说言不见作者。如是下结

就空空中先问。次辩。后总结之。辩中四句。一寄对显深。乃是声闻缘觉迷处。二正辩其相。是有是无是名空空就诠辩理。是有牒前第一义空。第一义空以有破无故言是有。言是无者牒前八空。前八空中以无破有故曰是无。就此有无以说空义故曰空空。是是非是是名空空破诠显理。前句虽复就诠辩理非留彼诠故复破之。是向有是。是向无是。两俱非是方名空空。非留有无说为空空。是义云何。已如上辩。因缘诸法有无同体。以同体故说无为有说有为无。无为有故有即非有。有为无故无即非无。非有非无故曰空空。三十住下就人显深。十住菩萨尚通少分犹如微尘。何况余人。四如是空空亦不同下寄对显异。声闻所得论说不同。毗昙法中说声闻人先观五阴非我我所直名为空。后观前智亦复非是我及我所故曰空空。成实法中先观生法空无自性直名为空。后观前智亦空无性故曰空空。今此所论离有无相故曰不同。上来十空与地经中十法平等其义相似。彼中初一总相明空。余九是别。别中初七以无破有同此初八。彼中第八以有破无同此第九。彼中后一以非有无双破有无同此空空就大空中先问。次辩

诸佛菩萨灭观波若。离一切相离一切性故名为空。言离相者如净醍醐。体虽是有而无青黄赤白等相。亦如一切众生心识。体虽是有而无大小长短等相。此亦如是。无何等相。谓非有相。亦非无相。非非有相。非非无相。非有无俱相。亦无自相。亦无他相。亦无非自他相。亦无自他俱相。如是一切妄心分别悉不相应。言离性者此波若中旷备法界恒沙佛法。是诸佛法同一体性。以同体故无有一法别守自性。故名为空。此空深广是以言大。又龙树云。十八空观名小智慧门。灭观波若名大智慧门。大慧体寂故名大空。此义犹是地经之中自体本空智自空矣。是名下结。上来第二广明空观

自下第三结明观益。为此观时得住空地

四我今下结明说益。谓说空时十恒河沙诸菩萨等得住空地

前略次广

自下第三释显地名。文有三句。前二离障清净如空故名空地。后一摄德宽广如空故曰空地。就前三中初离痴见。后离贪嗔。先喻后合。第三句中先喻后合。文皆可知

自下次明七善法果。以修七善化他智故成就出世一切智德是其果也。于中初明具八知见。得何利下得四无碍。前八知见所知宽广名一切智。后四无碍所知自在名无碍智。随相分别。由前知时知足自知知众及与知尊卑故具八知见。由前知法及知义故得四无碍。通则俱得。八知见中先总后别。于一切法亦见亦知是其总也。于中略以二门分别。一辩知见同异之义。二明知见取法差别。言同异者知之与见通释是一。分别有异。异有五种。一约明智以别其异。如下文说智慧了法名之为知。天眼照境说以为见。二约一境始终分别。初解名知。穷证显了方名为见。三约一境是非分别。如下文说知行邪法得解脱者无有是处名之为知。知行邪法必堕地狱所知决了故说为见。余亦如是。四约别境粗细分别。如下文说不善因果浮粗易了观瞩分明说之为见。善法因果微细难识观照难明说之为知。如善不善世出世间小乘大乘若因若果皆亦如是。五约别境深浅分别。世谛粗浅知之显了说名为见。真谛幽深见之难明故说为知。故下文中知常无常苦乐等相名之为见。了知佛性如来法身说名为知。又复二谛差别易了观照分明说之为见。一实深玄照见难明说名为知。知见同异。辨之略尔。次明知见取法差别。别有三种。一知而不见。如下文说知诸众生习行邪法。不见其人得解脱果。如是一切。二亦见亦知。如下文说见生造恶堕于恶道。知生修善生于天人及得解脱。如是一切。三亦见亦知不见不知。如下文说随俗言说有男女等可见可知。若随圣人秘藏之言。无有男女舍宅等事不可见知。如是一切。何故不说见而不知。知易见难。但见皆知。故不说之。知见取法有此差别。今此总中据要即举。是故直言亦见亦知

若行下别。别中初先开列章门。第二总结。第三广辨。第四总结。前开门中准结应有八门。然今文中少一若说故但有七。就八门中初一知非。后七知是。前知非中若行缘者。知邪法缘是不得出离解脱故曰行缘。后知是中。初二知其因果道理。后五知其修行之法。就前二中若性若相此之一门知其二谛法相道理了知佛性名之为性。知其苦乐常无常等法相差别目之为相。若因若缘此之一门知因果事。知恶因缘堕于恶道善业因缘生于善趣及得解脱故曰因缘。就后五中。初一知其修心次第。次一知其所依之人。次二知其所修行业。后一知其所依之法。就初修心次第之中。心是众生信乐之心。根是众生大小乘根。依此所生世俗善法名为禅定。依此所生出世圣道说以为乘。此四知人修心次第始终相成故合为一。其次一门所依人中若知识者知佛菩萨为善知识。其次两门所修行中初若持戒知其戒行。下说其有身戒心慧。今略举戒。言若施者知其施行。末后所少若说一门知行依法。上来别竟如是等法一切知见总以结之

下次广辩。与前不次。先广初门。若行若缘住是地中知而不见总以标举。下辩其相。先广明知。后显不见。文相可解

下次超广第三因缘。复次菩萨亦见亦知总以标举。下别显之。行邪堕恶粗显易了。观瞩分明故说为见。修善得脱微隐难识观照难明。故不名见说以为知。

下次却广第二门中若性若相。复次菩萨亦见亦知总以标举。下别显之。常无常等是其世谛。法相粗显易可辨了。知之分明故名为见。无常苦等是生死法。常乐我等是佛方便涅槃之法。如来法身众生佛性深细难测。知之难明。故不名见但说为知。于中先明知佛法身。后明知性

次广第四心根禅乘。复次菩萨亦见亦知总以标举。下别显之。于此门中智知名知。眼见名见。初知众生心根禅乘正广前门。后见众生生死出没对以论之。前中初问次辩后结。辩中知生信心成者解前若心。求于大乘断前若根。依根趣法故说为求。乘根别。所趣各异。今举求大。小略不论。是人顺等解于向前若禅若乘。顺流是禅。逆流正住及与到岸是前乘也。修世八禅是凡夫法。随顺生死故名顺流。修习圣道出离生死故名逆流乃至到岸。下辩可知。见中初问次辩后结。辩中初言菩萨修梵明见所依。以净天眼举其能见。下明所见。初见众生造恶下坠。次见众生修善上升。后见众生转轮出没。从三涂出还入三涂名闇入闇。从三涂出上生人天名闇入明。舍人天身坠落三涂名明入闇。善趣相入名明入明

自下超广第六若戒。前直举戒。今此具明身戒心慧。复次菩萨亦知亦见总以标举。下别显之。初知众生修身戒等正广前门后。见不修行身戒心等对以论之。就前知中先辩后结。辩中有二。一见修吾身戒心慧清净行故转重令轻。身戒心慧广如下辩。二云何下见修忏悔灭罪行故转重令轻。先问后辩。忏悔发露是灭罪行。后更不作惭愧成就是防过行。供养三宝是归善行。常自呵责是悔过行。以是业缘转重令轻。见中初问次辩后结。辩中有二。一见不修身戒心慧清净行故转轻令重。二是人少思不能忏下见其不修忏悔发露灭罪行故转轻令重

下次却广第五门中若善知识彼善知识有其三品。一下品知识。知而不见谓从种性乃至九地诸菩萨等知一切生皆有佛性。虽复知之而为烦恼覆蔽己心不能得见。二中品知识。所谓十住诸菩萨等知诸众生皆有佛性见不明了。如夜所见喻以显之。三上品知识。谓佛如来见一切生皆有佛性见之了了

下次超广第八若说。复有见知不见不知总以标举。下别显之。随世语言。有其男女瓶盆车乘舍宅等事可以知见。名见名知。依于圣人破相密语无男女等可见可知。名不知见

下次广辩第七若施。有知不见总以标举。下辩其相。依教世谛有施可解故名为知。知所舍财名知所施。知供三宝名知供处。知受施人名受知者。知施为因后受果报名知因果。知如是等名为知施。于第一义无施可见故名不见。翻前可见。上来广辩下总结之。知有八种牒上所知。上亦有见且举其知。即是如来五眼所知结会余德。前随世语见男女等是其肉眼。前以天眼见造善恶受苦乐等是其天眼。前随圣言不见男女舍宅车乘及所施等是其慧眼。前见行缘及常无常苦乐等相辨知众生心根禅乘。如是一切是其法眼。前知如来法身佛性是其佛眼

自下第二明无碍智。于中有二。一明菩萨具八知见得四无碍。二迦叶白如佛光说梵行品下就四无碍明得不得。前中迦叶初问起发。能如是知得何等利。下佛答之文别有四一明所得。得四无碍。二列四名。三广辩相。四声闻缘觉若得是四无是处下就人辩足。菩萨知见得四无碍是初段也法义辞乐第二列名。义如别章。此应具论

第三广中五义分别。依如地经。说四无碍有十一种。二总就二谛观入论四。二就自相。三就同相。四就行相。五就说相。六就智相。七无我慢相。八大乘小乘相。九菩萨地相。十如来地相。十一作住持相。广释如彼。地持论中别有一门通前十二。彼地持中说知教法名法无碍。知诸法相名义无碍。此名二谛。为诸法相知法名字为辞无碍。随音异说名乐说无碍。今此且以五义辩之。于中初番不与地持十地说同。后四粗同地经所说。其五是何。一约教义以别四种。知一切教及法名字名法无碍。知二谛义名义无碍。知诸世论名辞无碍。随字论者广辩字相。正音论者辩定语音。阐陀论者巧妙言辞。如似此方诗颂之流。世辩论者广辩世事。依前三种起说自在随人心欲名乐说无碍。凡所演说无障碍者言辞流滑无有忽滞。不可动转言辞楷正。无所畏省所说决定。不畏他人有已得失名无畏省难可催伏。是名下结

二约大乘小乘辩四。依如地经。了知一乘名法无碍。知三乘别名义无碍。今此经中知三乘别名法无碍。了知一乘名义无碍。有斯左右。于一法中作种种名说不可尽名辞无碍。依前名义种种异说多劫不尽称人心欲名乐说无碍

第三约就无我慢相以辩四种。初先正辩。依如地经。于第二义心无取著名法无碍。了知世谛心无取著名义无碍。今此经中于世谛法而不取著名法无碍。于第一义心无取著名义无碍。有此左右。于法名字知而不著名辞无碍。于说不著名乐说无碍。何以下辩。若取著者不名菩萨返以释之。道言取着不名菩萨即显菩萨法不取着

迦叶白下问答重显。迦叶先难。若不取着则不知法以不取着难破有知。若知法者则是取着以有所知难破不着。若知不着则无所知双牒以征。虽言有知以不着故还无所知。云何如来说知不着结非上言。下佛答之。初先正明菩萨无著。以是缘下引说证成。前中初言夫取著者不名无碍以为一门举失显得。无所取着乃名无碍复为一门辩得异失。是故以下广上初门明著有失。于中初言有取著者心无无碍。人非菩萨但名凡夫。何故取著名凡下辨。句别有四。一明凡夫取着于色乃至着识。二着故生贪。三贪故系缚故不得免生老病死及诸烦恼。是故下结。是故取著名为凡夫结成向前人非菩萨。是取著者有前过故名为凡夫。以是义下结成向前心无无碍。以取著者贪缚义故无四无碍

菩萨已于无量劫下广上后门明不取得。句别有六。一明菩萨无量劫来知法知义。二知法义故于色不着乃至于识。三不着故不生贪心。四不贪故不为色等之所系缚。五不缚故脱生老死一切烦恼。六以是下结。上来正明菩萨无著。以是缘下引说证成。于中初法次喻后合。以是下结

第四约就修多罗说相辩四无碍。知字不忘名法无碍。于中初法。次举六喻。下合显法。知彼字义名义无碍。虽知名字而不知义举劣显胜。得义无碍则知于义辩胜过劣。云何知下正辩其相。于中先问。谓地下辨。先解向前法中六喻。后约显法。自以言辞宣说前义名辞无碍。于中初明以种种辞演说一义亦无有义名辞无碍。犹如已下即事以显。此等世法假有实无故曰无义。何故已下释无所以。初先征问。失义已下举有显无。真实之义佛菩萨境。辞是凡境。所以无义以是义故得辞无碍总以结之。说前辞义不可穷尽名为乐说

第五约就二谛观入以别四种。与地经中初总同矣。于此门中了知世谛名法无碍。知第二义名义无碍。习毗伽罗生智之论名辞无碍。修余世论名乐说无碍。所谓习前随字论等。以此门中摄法宽多久字乃穷。是故皆言无量劫修

上来广辩。自下第四就人辩定。亦得名为简大异小。于中初明声闻缘觉无四无碍。迦叶白下问答会通。前中初先总明二乘无四无碍。何以故下别明二乘无四无碍。声闻缘觉不能毕竟知辞义下复总明其声闻缘觉无四无碍。就初总中声闻缘觉得四无碍无有是处正明不得。九部经下拂权显实明其不得。先举昔权。后拂显实

就下别中先问起发。昔时言得。今以何义道其不得。下对释之。于中先明缘觉不得。后辩声闻。就缘觉中初总明其无四无碍。何故默下别明不得。是故缘觉一切无下总以结之。就初总中菩萨度生修四无碍举大显小。缘觉修寂。若化众生但现神通默无所说。云何当有辩小异大。别中先明无辞无乐。何故默然征前起后。下对释之。于中先明缘觉之人不能说法令人得燸。乃至不能令人发于三菩提心。何以下释。以无经故。是故下结。不能说故无辞无乐。次明无法。句别有四。一明其人。虽知于法无法无碍。二何以下释无所以。缘觉知字无字无碍。为是无之。三何以下辨。前无字无碍所以。不知常住二字故无。四是故下结。下明无义。虽知于义无义无碍正明其无。真知义下举大显小成其无义。以是下结。上来别解。是故缘觉无四无碍总以结之

下次别明声闻无四。先问后解。于中先明声闻之人无三善巧。次别。后结。上来别明二乘无竟

下复总显。声闻缘觉不能毕竟知辞知义略以摽举。辞为乐本。义为法原。故偏举之。下别解释。于中七句。前三解释无义所以。无自在智。知于境界无无碍智。无有十力四无所畏无一切智。不能度于十二缘河无清净智。后四解释无辞所以。一不知根。二未能下不能知于应根之法。三不知欲。四不能善下不能知于应欲之法。是故下结

上来广辩二乘无竟

下次会通。今言异昔故须会之。迦叶先问。若声闻等一切无者牒佛今语。云何已下以今征昔。虽举舍利及大目连为取拘絺。如其无下重复结征。下佛为会。文别有三。一对胜彰劣。明二乘人四无碍智劣于菩萨故今说无。二我为凡下对劣显胜。胜过凡夫故昔言有。三声闻人或得一下以理辩释。前中初先举其喻事。如是已下明实不等。下约显法。第二句中初明为凡说拘絺罗无碍第一汝问如是总以结会。第三句中或得一者四无碍中趣得一种。二亦如是。成前为凡说其第一。具四无碍成前不及菩萨之义

上来正辩四无碍竟

下就无碍明得不得。初说无得今人舍着。如来先为纯陀说下宣说有得使人证入。明无得中迦叶初先难破有得成其无得。次佛述成广明无得。迦叶下复显已问意。就初难中如佛先说梵行品中菩萨知见得四无碍牒佛上言。菩萨知见则无所得亦无有心言无所得辩正道理。菩萨得正知见之时不取有相故无所得。不取无相故亦无心。言无所得是菩萨下以实无得破佛有得。于中先牒向前无得。若使已下征破有得。云何已下结非佛语。下佛先叹。后述其言广明无得。有十复次。前九复次以言遣相明其无得。后一复次以言遣言明其无得。就前九中初一正就四无碍智以明无得。后八傍就余义说之。余义是其无碍眷属。所以通辩。初复次中无所得者名四无碍当相正辩。菩萨无碍证实方成。证实离相故名无得。何以故下破遣有得成前无得。何故征问。下对显之。得名为碍。碍名四倒。反举有得。情取名得。得妨实慧故名为碍。碍是常乐我净四倒故复指之。菩萨无倒故得无碍破得显无。是故下结。后八番中初就解惑相对分别。第二生死涅槃相对。第三大乘小乘相对。第四方等十一部相对。第五空定有心相对。第六常乐我净之法与彼无常苦无我等八法相对。第七一门情理相对。第八大小菩提相对。下还就此宣说有得。宜审记知

就初对中句别有二。一当相正辩。无所得者名为智慧。菩萨得慧故无所得。二破遣有得成前无得。先举有得。次明菩萨断故无得。是故下结。余对例尔。文皆可知。上来九番以言遣相明其无得

第十番中汝问无得我说无得以言遣言明无所得。咽咳舌齿和合出声。为问为说实则不有故无所得。若说有得是魔眷属非我弟子举过劝舍

自下迦叶显已问意。于中先明如来宣说无得之益。令多众生断有相心。以是事下明已问意

自下第二次明有得。于中初先略明有得。如文殊等讵有几下广明有得。前中迦叶先举上偈请问如来。以此偈中备含得义故举请佛。下佛答之。先明此偈普为一切。彰一切人悉有所得。时文殊下彰彼文殊先已解知不须更说。前中约对四人辩之。一明为化凡夫众生而说是偈。彰彼凡夫有所得义。凡夫之人现有生死染污之法名为本有。现无出世涅槃净法说为今无。现无出世涅槃净法故名本无。现有生死染污之法说为今有。凡夫本有生死之法三世常有无是处故当必除舍。本无净法三世常无无是处故当必得之。故非无得。二亦为下明为声闻辟支佛说。即显二乘有所得义。义同前解。二乘现有无常苦等名为本有。现无诸佛常乐净等说为今无。现无诸佛常乐净等名为本无。现有无常苦无我等说为今有。二乘本有无常苦等三世常有无是处故当必除舍。本时所无常乐净等三世常无无是处故当必得之。故非无得。三明此偈为文殊说。言对文殊即是通为诸菩萨说。即显菩萨有所得义。义如前释。四明此偈为纯陀说彰佛有得。纯陀向前疑佛不得常住之法。故对其人明佛有得。义如上解。以此会通不但说佛。是以说言不但正为纯陀一人

下明文殊先已解知不劳更说。文殊将问我知为说即得解者。道前三乘同性中说彼得解也。以此验求。明知文殊前有问意。但默不彰。为此语者彰前偈义文殊解意不劳更释。欲使迦叶更为余人启请起发上来略辩

次广论。迦叶先请。如文殊等讵有几人简胜异劣。唯愿更说为下启请。下佛初先敕听许说。后为辩释。文别有二。一正解前偈明佛有得。二如来普为诸众生下就佛化他明他有得。前中八番。今先对上十无得法辩其同异。然后释文。言同异者。此八番中五番同上。第一番中涅槃波若同前十中第二智慧第三涅槃。第三番中常乐我净同前第七。第六番中毕竟空定同前第六。第七一乘同前第四。第八方等同前第五。余皆不同。何故不同。法门无量趣举皆得

今初番中约就波若及大涅槃宣说有得。文别有三。一释偈中本有今无。本有烦恼今无涅槃。即说本昔有烦恼时以之为今。无涅槃者望方便净无体故无。望性净果未显故无。二解偈中本无今有。本无波若今有烦恼。三若沙门下解释三世无有是处。本有烦恼三世恒有无是处故佛今断尽。此明有断。即显本昔所无涅槃及与波若三世恒无无是处故今已证会。此明有得

第二约就如来法身宣说有得。句亦有三。一解偈中本有今无本。时但有父母生身无佛法身。此乃如来法报两身通名法身。望佛报身无体故无。望佛法身未显故无。二释偈中本无今有。三若沙门下释三世有无是处义。本时所有生死之身三世恒有无是处故佛今断除。此明有断。即显本昔所无法身三世常无无是处故佛今得之。此明有得。第三约就常乐我净宣说有得。三句同前。第四约就六度明得。第五约就三十七品无边之身以明有得。第六约就空定说得。第七约就一乘辩得。第八约就方等经典宣说有得。文皆三句。类上可知

自下次明化他有得。文别有二。一略明有得。二迦叶言第一义谛亦名道下广明有得。又前略中就第一义明其有得。广中就通菩提涅槃以明有得。略中有三。一明如来随化众生种种异说。二一切世谛若于如来即第一下明佛化意。为使众生得第一义故说世谛。三是故汝先不应难下明诸众生因化有得非无现得。前中五句。一明如来随化众生种种异说。二何以下释。三明如来所说不虚。四何以下释。五明众生因妄得益。佛亦说之。初中如来普为众生虽知诸法说不知者。随顺世谛说知诸法。于第二义无法可知故云不知。虽见诸法说不见者类同前释。此义如上八知见中具广分别。有相之法说无相者。世谛有相于第一义宣说无相。无相之法说有相者翻前可知。实有无常说有当者。生死无常宣说其中有常法性。常说无常翻前可知。又如佛说三十三天常乐我净。此亦是其无常说常。如来实常随化示灭。此亦是其常说无常。乐我净等类皆同尔。三乘说一一说三者随化三乘。就实论一真实一乘随化分三。略相说广广说略者如上文说。十二因缘总名有为名广说略。一有为中开分十二名略说广。如是一切

此前就经。下就律辩。四重之法说偷兰者如僧祇律。盗人四钱三角已上名波罗夷。四分律等说为偷兰。是事云何。彼说十九摩沙迦成一吉利沙。一吉利沙分为四分。盗得一分即名犯重。是故说为四钱三角。摩沙应是古大铜钱。偷兰遮法说四重者翻前即是。犯说非犯非犯说犯者。如八不净俭畜非犯丰则成犯。如是一切。轻罪说重重说轻者。如四分中于他财物烧埋坏色犯波罗夷。十诵律中犯越毗尼突吉罗罪。又四分中着白色衣犯波逸提。不点而畜犯突吉罗。僧祇律中着白色衣犯突吉罗。不点而畜犯波逸提。又四分中说有女人父母夫主不听强度。其和上尼犯波逸提。僧祇律中说犯僧残。诸如是等名重说轻轻说重也。何以下释。明见根异故说不同。余句可解

自下第二明佛化意。为使众生得第一义说前世谛。于中四句。一明向前所说世谛若于如来即第一义。二何以下释。如来为显第一义谛宣说世谛故即第一。三亦今下明为第一说世谛意。为使众生得第一义故为第一宣说世谛。先顺后反。四如来有时演说世下辩明如来化意难测。如来说世众生谓佛说第一者。如佛昔说苦集灭道。小乘众生取为真谛。有说第一众生谓佛说世谛者。如说佛性为阴界入十二缘等。众生便谓同已所解取为世谛。下结难解。此唯佛境非二乘知。为此语者欲使众生于向异说不应定执取为世谛。佛意皆为显第一义

自下第三明诸众生因化有得。于中有二。一呵前显后。如来说法为令众生得第一故不应难言菩萨无得。二菩萨常下举彼菩萨得第一义成前不应

自下第二广明有得。向前宣说得第一义。未说得道菩提涅槃。故下辩之。迦叶先难。有得乖上所以难之。于中先牒向前所得第一义谛。共道菩提涅槃相即。即显此三皆有得义。下就设难难破有得。前中初言第一义谛牒上所得。第一义谛下即道。道者外国名曰末伽。如四谛中所说道谛。菩提胡语。此亦名道。此二何别。通则是一。别则末伽是其因道。菩提果道。外国名多。因果二道别立名字。此方名少。显法含通。故因与果通名为道。涅槃是灭。此三通于性净方便。今此所论即于性净。云何第一亦名为道。解有三义。一体义虚通即名为道。二约人分别。凡时实义据圣望之。体无壅障即名为道。三约修分别。凡时实义从缘显了说之为道。亦名菩提及与涅槃义皆同尔。下就设难。难辞有二。一明此三常故无得。二夫道者非色已下明此三法无相无得。前中四句。一明此三得则无常。二何以下明此三法常故无得。先征后解。解中初法。后以喻显。三如世物下成向初句明得无常。先喻后合。四法若常下成向后句明常无得。先法后喻。第二无相无得难中先明道法无相无得。后类菩提及与涅槃

下佛答中如是如是印前第一名道菩提及与涅槃。道有二下释名后难明其有得。文还有二。一对前难明常而有得。二道之性相实不生下对上后难明无相有得。前中三番。一就道等各分二种常与无常。二就人以辩。言外道道名无常者。八禅等智是其凡夫外道所修名外道道。是无常也。内道常者。三乘圣道同名为常。以不退故。内中更分小乘无常大乘是常。今略不论。菩提之中小名无常。大名为常。小乘菩提性是生灭故说无常。外道法中令无菩提故不就论。就涅槃中外脱无常内脱常者。外道凡夫六行断结所得无为名外解脱。退转不定故曰无常。三乘圣人所得涅槃名内解脱。不退故常。内中细分。小乘无常。故下文言声闻涅槃但有乐净而无我常。大乘是常今略不辩。三牒取前常就明有得。偏牒大乘道等三事。不开小乘。于中先牒。一切生下及明众生惑障不得。而众生下顺明众生修道能得。先辩后结

就明无相有得之中先明道等无相而有。如其无下就有明得。前中初法次喻后合。合中具三。法说文中但明其道。余略不论。道之性相实不生灭不可捉持明道无相。虽无色下明其有用。道实有体。体相难彰举用显之故言有用。喻中先明众生心识无相而有。以类道等真法是有。此文良验宜审记知

以是义下举说证成。于中初明心如城主。次明须护。先反后顺。以不护下明护有益。先反后顺。下双结之。得名真实结明前益。护者得彼人天涅槃名为真实不护不得名不真实结明前损。上来喻显。道下合之。明此三法亦有亦常是以可见

自下第二就有明得。文别有四。一略明有得。二见有二下广明有得。三以是因缘我于往昔告舍利下引说证得。四迦叶言下释经显得。略中初言如其无者云何能断一切烦恼难破无义成有可得。以其有故了了知见正明有得

广中初先泛举二见。先举。次列。后辩其相。如人眼根清净已下约此二见明其有得。先立见喻。次约显法。下明菩萨虽见不取。文皆可知

就引证中文有四句。一明世间不知见觉诸佛菩萨能知见觉。二明世间所知见觉诸佛菩萨亦知见觉。三约前二明凡异圣。四约前义辩圣异凡。前中初言以是缘者。以佛菩萨见道菩提涅槃因缘。昔告舍利一切世间不知见觉诸佛菩萨悉知见觉。此三何别。通释是一。于中分别义有多含今此且以两门分别。一就行分别。二约位别。言就行者闻慧为知。思求称觉。修证名见。又闻及思通名为知。修观明白说之为见。证会名觉。又闻思修通名为知。证照名见。于前二后重观名觉。言约位者地前名知。初地名见。二地已上重观名觉。亦得地前名之为知。十地名见。佛地名觉。第二可知。第三段中约对前二明凡异圣。世间众生不知见觉亦不自知不知见觉。对上初段明痴异圣。世间众生所知见觉便自说言我知见觉。对向后段明慢异圣。第四段中辩圣异凡。如来一切悉知见觉亦不自言。顺明如来异于凡夫。于中先明有慧异凡。亦不自言我知见觉无慢异凡。次类菩萨。何以故下反明如来异于凡夫。后类菩萨

自下第四释经显得。释前所斥证中之义。人即就此别更建立知见觉义以为梵行。诸是辩行佛皆标举。若知见觉别是梵行。佛何故不举斯应别举。复有梵行谓知见觉乃重解向前所斤昔经中义。何得别立断经意势。于此文中有两问答。前一问答解前经中世间不知不见觉法。并辩世人知见觉法以显菩萨能知见觉。后一问答解前经中世间不知菩萨能知异世间义。前中迦叶先问起发。如来次辩。迦叶下复荷恩赞叹。如来辩中文别有四。一辩出世间不知见法。初就佛性明世不知。先顺后反。次就十二部经等法明世不知。先顺。后反。是名下结。二辩出世间知见觉法。先问。次辩。后总结之。三明菩萨能知见觉。四举谤者得罪成前是实。菩萨如是知见觉已若言不知为虚妄等。对向后段能知见人明谤得罪。若男女下对向初段所知见法明谤得罪。此过深重。惧人为之。故佛广辩今人舍远。自下迦叶闻前所说荷恩赞叹。经家先举。下列叹辞。辞有四偈。前二对上谤者得罪叹佛能救。后二对上如来辩说知见觉法令菩萨知叹佛能益。前两偈中初之半偈叹佛有慈。后一偈半叹佛有悲。善拔众毒故称大医明未治者如来能治。后之一偈明已治者佛令不起。于中前半举劣显胜。后之半偈辩胜过劣。后两偈中初之一偈约喻显法。后之一偈当法正叹

自下第二解前经中世间不知菩萨能知异世间义。迦叶先问。如佛所说一切世间不知见觉菩萨能者牒佛昔言。下就此言进退两征。初问菩萨若是世间不应说言世间不知菩萨能知。后问菩萨若非世间有何等异

佛答有二。一明菩萨是世非世。二汝言已下辩明与世同异之义。前中菩萨亦世非世略以标举。下辩其相。善趣菩萨未知见觉名为世间。种性已上能知见觉说为非世

后中汝言有何异者牒前问辞。次许宣说。下广辩之。先就同前世间菩萨以明不异。初闻是经信敬发心是则名为世间菩萨举不异人。一切世间不知见觉如是菩萨亦同不知显不异相。信敬发心非不异世。今此偏就未知见觉说为同矣。菩萨闻是涅槃经下就上所辩非世菩萨以明其异。闻是经已知有世间不知见觉应是菩萨所知见觉闻慧异世。知已即思我当云何方便修习得知见觉思慧异世

覆复念下修慧异世。于中初明自分之行异于世间。六念已下胜进之心异于世间

前中初明自利行异。若我弟子受持读诵大涅槃经有破戒下外化行异。自中有三。一明菩萨始修三学修在地前。二以修慧故所受持戒牢固已下约就三学明其行修次第成义。成在地上。三菩萨净戒五法佐下辩明菩萨能成所以

初中先戒次定后慧。戒中四句。一因前思惟便得正知。知由净戒。二因知正修故于未来戒常清净。三明修利。以戒净故常无憍慢邪见疑网。终不言佛毕竟涅槃。四是名下结

定中三句。一结前生后。戒即净已次修净定。二明修益。益有二种。一得正念不忘之益。次修定故正念不忘总以标举。所谓下别。一切有性是其理法。十二部经是其教法。诸佛世尊常乐我净是其果法。安住方等悉见佛性是其行法。于此四法忆而不忘。二得净慧证空之益。以修定故得十一空。此二合为第二修益。三是名下结

慧中亦三。一结前生后。戒定已。备次修净慧。二明修益。以修慧故破四身见趣入出世。且约色说。初不计着身中有我即是不计色中我也。我中有身即是不计我中色也。是身是我即是不计色为我也。非身非我即是不计色为我所。就色既然。乃至就识类亦同尔。今此文中总就五阴故但说四。若就五阴历别论之便有二十。分别起处便有六十五种计我。相状如何。于五阴中先就色说。色阴望余有其十三。有人宣说色体是我即以为一。有人宣说色体非我但是我所。此我所中即有四种。有人宣说受阴为我。色阴与彼受我为所。乃至有人说识为我。色阴与彼识我为所故有四种。通前为五。有人宣说色者是其我之窟宅。我居其中。于此门中即有四种。有人宣说受阴为我来住色中。乃至有人说识为我来住色中。故有四种。通前为九。有人宣说我者是其色之窟宅。色住其中。于此门中亦有四种。有人宣说受阴是我色来入中。乃至有人说识是我色来住中故有四种。通前十三。最初我见。后之十二是我所见。色望余阴辩之既然。余阴相望辩之类尔。五阴之中各有十三。是故通说有六十五。此等诸见修慧悉断。三是名下结。此地前行唯得说三。不得分十。未见性故

自下第二次明行修次第成义。初先略辩。迦叶言下问答广显。略中十阶。始从持戒乃至见性。准下少一得大涅槃。通彼合有十一阶矣。此十一中前十是因。后一是果。就前十中初四是其戒学差别。次二是定。后四是慧。然今文中先明持戒。次即就戒结异世间。后明不悔乃至见性。下复就之结异世间。前明戒中初先法说。以修慧故戒牢不动。次喻。后合。尔时下结。是名已下结异世间。下明不悔乃至见性及后结异。文显可知

广中先问。下佛为辩。于中初先举失显得。即是明世异于出世。先辩后结。辩中初明世戒不净翻前第一。先总标举。何以下释。四义释之。为于有者凡夫持戒为三有果。所以不净。性不定者易可退败。不毕竟者体非精上。此三劣也。不能广益彰其狭也。次是下结。余无悔等文显可知

菩萨净下辩胜过劣。即是出世异世间义。先辩后结。辩中初明菩萨戒净翻前第一清净戒者。戒非戒故翻前世间戒不清净。不取戒相名戒非戒。非为有者翻前为有。定者翻前性不定也。言毕竟者翻不毕竟。为众生者翻前不为。是名下结

次明不悔。于中初法。次举三喻。下合显法

次明欢喜。于中有三。第一正明持戒欢喜。初法次喻后合可知

第二反举破戒不善对以显前。亦先法说。次喻。后合。三如牧牛下双就二人明忧明喜。初先立喻。譬如二女喻持犯人。牛喻如来。从佛受法名牧牛女。一持酪瓶一持浆瓶喻彼二人所受戒法。瓶喻自身。酪之与浆正喻戒法。破戒之人于所受中未有出生。如彼酪中未有出生故说为酪。持戒之人于所受中已多出生故说如浆。俱共至城齐心趣果。而欲卖者行因贸果。于路脚[跳-兆+殳]二瓶破者喻彼二人身坏命终。因尽脚跌。果丧瓶被。一喜一愁喻彼二人欣戚不同。持戒之人于所受戒已多出生。所失微少所以欢喜。破戒之人于所受戒未有出生。所失利大所以愁恼。下合显法。持戒破戒亦复如是合前二女。持戒心喜合持浆女。瓶破欢喜破戒不喜略不举合。次明悦乐。于中初明因喜生乐。迦叶言下对喜辩异。先问后辩。辩中四番。一约因别。二约果别。观于生死知已不受所以生喜。观大涅槃知已定得所以生乐。三就体别。下喜上乐。四约法。别有漏世共离之生喜。无漏不共得之生乐。余者可知。是名净戒非世间戒就初以结

自下第三辩明菩萨能持所以。先辩后结。辩中具有六种五法。前四修始。次一修次。后一修成。就前四中初一五种是助戒法。先举后列。离五盖故是助定法。如别章释。后二五种是助慧法。所见清净离五见故明其离见。见净摄治。离见除障。身见边见邪见戒取及与见取是五见也。心无疑网离五疑故明其离疑。无疑摄治。离五除障。先举后列。修次摄成文显可知。是名已下结异世间

上来第一自行异世。下明利他。先辩后结。辩中四番。前之三番举过劝舍。后之一番举得劝修。就前三中第一不得破戒传经。第二不得调戏轻动。第三不得非法说经。初中有四。一破戒传经生人讥呵。二缘是下由讥呵故随于地狱。三受持下如来呵责。四如是人下如来诫约。宁不受读不得破戒而传是经。第二番中句别有五。一如来诫约。有说经者不得调动。二身为下辩调动相。三若我下明调动持经生他讥毁。四令他随狱。五如来结呵。则是众生大恶知识。第三番中句别有四。一如来诫约。有传经者一切不得非法宣说。莫非时者观前众生忧恼病患贪着诸欲无心求时不得为说。莫非国者小乘国中不得宣说。莫不请等直言可知。莫灭法者不得彼此共相非毁。言莫炽燃世法说者不得教人习学此经求世名利。二明非时乃至炽燃生世讥呵。三令他随狱。四如来结呵。就下举得劝修之中句别有四。一教说者当净其身。于中先举十种所为。后劝净身。其十种中前九为成阿含教行。后一为证。就前九中初一为受。后八为说。八中前五为说大乘。后三说小。大中初言说涅槃者说佛果法说佛性者宣说理法。说秘藏者是前二诠。说大乘者宣说行法。说方等者是大乘诠。下说小中说声闻者是声闻人有为之行。说辟支者说缘觉人有为之行。说解脱者说前二乘无为涅槃。见佛性者自欲求证。欲为此事当先净身。二以净身无人讥呵。三无人呵故敬信发心。如来结叹。则是众生善知识等。是名已下结异世间

自下第二就胜进心明异世间。先问次辩。后总结异。辩中初先总举六念。守境名念。佛等六种生念境界故名念处。次列六名。义如别章。此应具论。六中前三是所学法。次二所行。后一所求。下广释之。先明念佛。初问。次辩。后总结之。辩中有二。一念佛果。二何故如来乃至婆伽有是名下念因成果。前中先明所念佛德。若男若女能如是下明能念益。就所念中初列十种名称功德。常不变下举德显名。云何名如来下依名辩德。初中如来乃至世尊是佛通名。一切诸名皆有通别。佛亦如是。释迦弥勒无量寿等是其别名。如来等十是其通名。化相须分故立别名。实德齐同故立通称。通德无量。依德施名名亦无边。今据一门且论十种。十中前五自德之名。后五是其化他德号。自中初二以为一对。前一道圆。后一灭极。言如来者多义如下。依龙树释。乘如实道来成正觉故曰如来。言应供者多义如下。要而论之。证灭相应故名为应。复应供养供名为应。后三一对。前二因圆。后一果极。就前二中初一解圆。后一行圆。正通知者多义如下。当相论之。理无偏邪故名为正。于理穷照说为遍知。明行足者多义如下。明是证行。行是教行。证心清净离闇称明。旷集诸善说之为行。此二圆满名明行足。言善逝者多义如下。当相论之。善者名好。逝之言去。如来好去故云善逝。如来德满更何处去。如言好去虽无去处非不能去。如劫尽火虽无所烧非不能烧。此亦如是

下利他中初四是别。世尊是总。别中初一明化他智。善解世间名世间解。次二明其化他之能。调御丈夫能调物心。佛自丈夫能调丈夫。是故名为调御丈夫。天人师者能授以法。能以善法匠益天人名天人师。如来实是六道之师。人天益多故偏说之。佛者明其化他行德。此翻名觉。自觉觉他觉行穷满故称为佛。言世尊者。佛备众德为世钦重故号世尊

自下第二举德显名。初明自德。大师子吼明利他德。大沙门下复明自德。于中初明福德殊胜。无师已下智慧深妙。句别有十。初句总叹无师自悟。中八别显。言疾智者知法峻利。一念能知。一切诸法。言大智者知法深广。此二为门。利显前疾。余显前大。所知渊深故名深智。出障清净名解脱智。高出余人名不共智。知法宽多名广普智。位分高极名毕竟智。智成总结。人中象下复明利他。人中象等明佛人尊。调人师下明能益物。能调物心名调人师。以法惠人名大施主。以法匠世名大法师。此句是总。下别显之。别中九句。前八能知。后一能说。前八犹上七善法矣。以知法者是上知法。以知义者是前知义。以知时者是前知时。以知足者是前知足。以知我者是前自知。知大众者是前知众知性知根知尊卑

自下第三依名辨德。解如来中先问后释。释中三番。一约教辩释。如过去佛所说不变略以标举。云何下释。二约证辩释。六波罗蜜是能证行。十一空者是所证理。三约权实二德辩释。随宜开三是佛权德。寿命无量是佛实德

解应供中先问后解。解中有五。前三就其自德说应。后二就其化他说应。就前三中初一通举一切世法明佛应断。次一就前一切法中简取四魔粗重之过明佛应断。后一就前四魔之中简取烦恼增上重恶明佛应断。就后二中初一明佛应化众生。后一明生应供如来正遍知中先问后释。释中有五。前之四番明大异小。后之一番举小显大。就前四中初二明其舍邪归正。前句明舍四倒烦恼后句明舍苦行邪业。正名苦行释其正也。苦行正见外道所修是故名正。又此苦行正是苦因故名为正。遍知苦行定有苦果明佛离也。次一复次舍凡入圣。正名世中举其正义。断常世边非断非常是世间中。中故称正。下明遍知。知修中道得大菩提故曰遍知。下一复次舍小归大。正名可数举其小也。可数可量正是小乘故名为正。言遍知者不可数等明佛舍小住大乘也。下一举小显大可知

解明行中先问后释。释中有四。初一据果寻因以释。明者是其菩提善果。行足是因。乘戒慧足得菩提果名明行足。戒者是福。福有无量。离恶为首故偏举戒。慧者是智。福智具足。故得菩提。第二偏就果德以释。明咒行吉足者名果是名世义举世语义。下约显法。咒名解脱吉名菩提果名涅槃名明行足。三就从因趣果以释。明光行业足者名果是名世义举世语义。下约显法。所言光者名不放逸是起行心。业名六度是所起行。此二是因得菩提果。四就行修入证以解。前解明义。正是证体。三明举数。次列三名。菩萨明者因中证智。言佛明者果中证智。无明明者是所证理。理非智慧故曰无明。能生智明从其所生故复称明。故论说言说智智处俱名波若。如世五欲生欲名欲。下辩可知。后释行足从修入证。行者为生修诸善业是证方便。足者见性是入证矣。以是下结

解善逝中先问后释。释有三义。第一偏就果德以释。善者名高逝名不高是世间义举世语义。下约显法。高名菩提位分高出。不高佛心。佛心无慢。是故下结。二就发心趣果解释。善名知识逝者名为善知识果是世间义举世语义。次约显法。善知识者即初发心明起愿因。果名涅槃明其得果。下重显之。不舍初心得涅槃者得大涅槃不舍菩萨所行故也。是故下结。三就证性得果以释。善好逝有是世间义举世语义。次约显法。好名见性是其证行。有名涅槃明得果也。下重显前涅槃有义。今此借彼世俗有名而显涅槃。恐畏世人取同世有。故须拂遣以显非有。于中初法。涅槃非有诸佛因世说言有者。涅槃离相涅槃离性故言非有。非令无法。言离相者无有自相亦无他相。言离性者万德同体互相集成。未有一德别守自性。虽复非有。诸佛借彼世俗有名而演说之。次以喻显。如世间之实无有子。因他有子说言有子。亦如世人实无有道。因他出世圣人有道。宣说世俗凡夫有道。下合显法。涅槃亦尔实无有相因世间有说之为有。诸佛成下约法显人

世间解中先问后释。释中六番。初一约就五阴世间明佛有解。第二约就五欲世间明佛有解。第三约就国土世间明佛有解。第四约就众生世间明佛有解。第五约就八法世间明佛有解。世名莲华解名不污是名世义举世语义。次约显法。莲华如来言不污者如来不为世法所污。利哀毁誉称讥苦乐是世八法。是故下结。第六通约一切世间明佛有解。此为明佛通论菩萨。又世间解名佛菩萨略以标举。解世间故名世间解。何以下释。初法次喻。因食得命名食为命因从果称。诸佛菩萨解世间故名世解者果从因称。有此左右。下合可知

无上士中先问后释。释中五番。此五是彼地持所说七无上中五无上也。初一无断是断无上。第二无诤是正无上。彼有四正。谓正威仪正戒正见及与正命。此中无诤是彼正见。第三门中语不可坏是智无上。寄言显之。第四上座是身无上。第五门中无新无故是住无上。彼道无上神力无上此中略无

解调御中先问后释。释中初言既自丈夫以为一门。复调丈夫复为一门。实非丈夫非不丈夫因调丈夫故名丈夫显上初门。一切男下显向后门。于中先明所化丈夫。后明如来能调之义。前中初言若男若女若具四法则名丈夫总以标举。何等下列。具足下结。若有男子无此四下举非显是。就明如来能调之中初先法说。次喻。后合。御者调马无有定下明佛过世

天人师中先问后辩。辩中初先明佛是师。天者已下解佛以为天人师义。前中初明因法教人故名为师。昔未得下果法教人故名为师。因中初先教人修善。次教离恶。后总结之。善中初先泛举二师。善教恶教列其名字。诸佛已下明佛菩萨为世善师。初先正教。何等已下辩出善体。教离恶中先教众生远离身恶正教远离。何以下释。释中有二。一明身恶可离故教。先顺后反。二若众生下明离有益是故教离。先反后顺。下教果中昔未得等九句别教。是故下结。解佛以为天人师中初六复次广解天义。次四复次广释人义。人天多义且举斯耳。下解如来为天人师。初先标举。何以下释。是故下结

就解佛中先问后释。佛者名觉翻名总释。自觉觉他别以显之。譬如已下显自觉相。先喻后合。觉有两义备如上辩。今此偏就觉察释之。是故下结

次释婆伽。先举后解。七义释之。前举世尊此解婆伽。皆是佛号。趣举皆得。前明所念。若男若女下辩明能念之利益也

上来念果。自下第二念因成果。何故如来至婆伽婆而有大名征前起后。下对释之。于中有四。一与佛因行。二是故下明行得果。三又复下举佛因心。四是故下明心得果。初中先明敬上之行。常为生下摄下之行。先修六度。后起无量。第二得果文显可知。第二心中初修信等常为法利不为食利。次持经法为安众生不自为己。何以下释。先开三门。修出世心是第一门厌有为心。出家心者是第二门求善之心。无为心者是第三门趣理之心。下广显之初十五心。广前出世。无量心下有其六心广前无为。调心已下三十一心广前出家。于中初有二十四心是自利心。无声闻下七心利他

广念众生。故无声闻缘觉之心。知诸众生根欲性等名善知心。知于法界名界知心。知众生界名生界心。知诸世界名住界心摄化自在名自在界心。第四得果文显可知

是名念佛总以结之

就念法中初问次辩后总结之。辩中初先思法最胜。因是已下彰法功能。唯此已下辩法体相。与上诸佛法身相似。求相叵得而有大用

僧中初问次辩后结。辩中初言诸佛圣僧如法而住总显其相。诸佛方始僧行究竟故亦名僧。下别显之。受正直法起行之始。随顺修行起行之次。不可睹等明修成相。先明德体。一切生下辩其德相。一切众生良祐福田利他德胜。虽为已下自德殊胜

戒中初问次辩后结。辩中初先明戒体相。若住是戒得须陀下明持所为。前中初言不破不漏不坏不杂辩其戒相。不犯四重名为不破。不作四重前后方便故曰不漏。不犯余戒名为不坏。离余方便故称不杂。虽无形等辩其戒体。虽无形色而可护持不同眼根所对之色。虽无触对善修可具不同耳等所对之色。依如毗昙。是法尘中无作之色此经下文数处但说五根五尘十种之色。不说有其无作之色。良以受戒但是色法而无色事故不说之。此义至下诤论之中更别论之。此前明受。无过咎者明其持戒。诸佛菩萨之所叹下明其戒能。先法后喻

持所为中初不求小。何以下释。若我住戒得菩提下明其求大。何以下释

施中初问。次辩其相。后指杂叶。辩中有四。一略辩施能。能为阿耨三菩提因。二佛菩萨亲近修下起意修习。三若不施下广辩施能。四佛菩萨修集已下起意修集。第三能中有其四种。一能严四众。以财摄故四众敬从故曰能严。二能伏烦恼。三为十方众生称赞。四能得果。谓得常乐我净四义辩力无碍

就念天中初问。次辩。后总结之。辩中初明不求生天。何以下释。后求义天。何以下释。是名菩萨非世间下总结异世

品初至此广论梵行。下叹经胜令人修学。于中初先叹经殊胜令人修学。无上佛法住当久下辩经兴废令人护持。前中有二。一当法正叹。二以何义故复名菩萨不思议下寄人显胜。前中如来初以此经对余小经比校显胜。迦叶后领。前中初言若我弟子受十二部及以受持大涅槃经无差不然正比显胜。何以下释。以是下结。自下迦叶领解述叹。涅槃不思领叹前经。佛法众僧不思议者述叹所说。菩萨不思述叹修人。菩提涅槃不思议者叹人所得

就下寄人显胜之中迦叶先问。如来次辨。迦叶后领。辩中初明世间菩萨依经起行不可思议。菩提不可以喻比下明出世间菩萨依经成德不思。世间菩萨有三种心是故不思。一求菩提心。二又菩萨见生死过非是声闻缘觉及下念众生心。三无量众生发菩提心见生死过即便退下厌有为心。出世菩萨亦有此三。至时当辩求菩提中初辩后结。辩中有四。一读此经故虽无人教自能发心。二既发心下明依此经能起精进。三正使下明依此经发心不退。于中初先过重自要不舍念心。何以下释。释中先举无益之苦用以自诫。若我为于菩提已下明有益苦理必须忍。四我为菩提正使碎身如微尘下明依此经精进不退。于中初先过重自要不舍精进。何以下释。释中初明精进能为菩提之因故不应退。如是菩萨未见以下举始况终。上来广辩。是故已下结成不思

念生心中初先法说。次喻后合。法中有二。一见生死过二乘不及而能为生受苦不厌故名不思。二为众生地狱受苦如三禅乐甘处不厌故名不思。喻合可知

厌有心中有六复次。一于生死勇猛不退故不可思。二若有人言我能浮下能度生死。三有人藕根。悬须弥下称量生死。四已于无量阿僧祇下正见生死。五从如人入水已下处苦不害。六人有三下受生不惑。具斯六事故不可思

初中无量众生发心见生死过即便退没举劣显胜。菩萨不下辩胜过劣。虽未阶下牒以叹胜。名欢喜地为初不动

第三段中文别有四。一如来立喻反问迦叶。有人说言我能渡海可思议不。迦叶答佛明其不定。若阿修罗渡则可思。人渡不思。或思不思略以答之。何以下释。此明修罗能渡可思喻佛如来能渡可思。第二如来就人重问迦叶答佛明其不定。圣渡可思凡渡不思。此明圣人能渡可思喻明地上菩萨能渡是可思议。

第三如来就凡重问。彼答不思。第四如来约后所答辩明地前始行菩萨能度生死不可思议。于中先明凡不能渡。后显菩萨能渡不思

第三段中如来初先立喻反问。有人藕丝悬须弥山可思议不。迦叶正答明不可思。下佛约之明此菩萨一念能量一切生死不可思议第四段中辩明菩萨常观生死无常苦等。而于其中为诸众生分别佛性常乐我净。虽说常等而于生死不起倒见是故不思

第五段中辩明菩萨行业清净在生死中不为其害是故不思。先喻后合

第六段中辩明菩萨于受生时正知入胎不同世人是故不思。于中初先举凡显圣。先举。次列。后辩其相。下明菩萨不同彼凡为是不思

下明出世菩萨不思。亦有三种。一证菩提行。二益众生行。三离有为行。初中菩提不可喻比所证深也。菩提真性离相无为故不可比。如维摩说寂灭是菩提灭诸相故。不观是菩提离诸缘故。不行是菩提无忆念故。无比是菩提不可喻故。如是等也。心亦不可以喻比者证心寂灭无相无缘故不可比。而可说者菩提及心虽不可比而得宣说。心证菩提故不可思。良以是心本从缘染。后息妄染。内照实性所以可说。行证之时法从心现。不从外来。故无师咨而能自得阿耨菩提

得是法下是其第二益众生行不可思也

有身离下是其第三离有为行不可思也。于中初先随相说离。不见一下就实明离。前中初先标列三业。身离非口是其身业。口离非身是其口业。非身非口而亦远离是其意业。三业相异故皆言非。下辩可知。就实离中初就身说。菩萨不见一法是身不取身相。不见是业不取杀盗邪淫业相。及离主者不取离行及离者相。而有离者离前相故诸业永无毕竟不起故云离矣。是故不思总以结叹。次就口说。类身可知。下就意说。从身离身从口离口简前异后。从慧远离非身非口简后异前。下正辩释。先明无离。而自说下后明有离。是故不思总以结叹。前中初先明慧无离。次菩萨终不生已下明无离想。慧无离中初先正辩。慧不能破火不烧下类显余法。前中初言实有此慧然不能令菩萨远离略以标举。得此慧时见法平等。以平等故不见智慧以为能离。亦无烦恼以为所离。故不能令菩萨离矣。何以下释。初先征问。问意可知。无一下释。无有一法能坏能作明无能离。智慧空故无法能坏。我人空故无人修慧故无能作。有为法性异生异灭明无所离。此名三毒为有为法。此有为法念念生灭则无自性故便无所离。是故下结

类余法中先明无能。以有为下明其无所。前中初言慧不能破牒前类后。火不烧下明后同前。于中初先类显色法。生不能下类显非色非心之法。此乃类显法外四相。义如下释。贪不能下类显心法。此等皆空故不能矣。就无所中以有为法生灭无性故无所烧乃至无痴。上来就慧广明无离。下明无想。以法无故菩萨不念我慧破恼

前明无离。而自说下就前无离以明有离。得此解时一切烦恼终不起故以有此德是故不思

自下迦叶领解述叹。我今始知菩萨不思领叹前人。佛法众僧大涅槃经不可思议叹其所学。及受持者叹持经人。菩提涅槃不可思者叹所持法。亦可叹其所得法矣

上来叹胜。自下第二辩经兴废令人护持。文别有五。一明涅槃经兴废所由令人护持。二我亲从佛闻是义下明涅槃经常在不灭令人敬举。三若佛初出来有弟子解深义下泛明余经兴废所由令人护持。四我法灭时声闻弟子或说有神或说神空下泛明余经常在不灭令人敬学。五尔时大众闻是语已啼即止下明诸大众闻法不灭发心修学。初中迦叶先请起发。无上佛法几时而住请问兴时。几时而灭请问废时。下佛为辩。先明兴时。若大涅槃有是五行圣梵天等修行故兴。有能受等传教故兴。先自读诵。后令他敬。尔时下结。下明其废。我诸弟子犯戒造恶无行故废。万能敬等轻教故废。先自不敬。后令他轻。当知下结

自下第二辩明此经常存不灭令人敬学。于中初就迦叶佛时辩明此经常在不灭。若有众生我见无我下就余佛时辩明此经常存不灭。何故先就迦叶佛时说不灭乎。迦叶佛法住世七日即便灭尽似无此经。故先就之明有不灭。迦叶先问。问由何生。因前而起。如来上言大涅槃经有行不灭。迦叶佛时众生有行。何故彼法七日便灭。故为斯问。问有四句。一举昔所闻。我亲从佛受如是义。迦叶佛法七日灭尽。二审定如来。迦叶如来有是经不。三就有设难。若其有者云何言灭。四就无设难。若其无者云何说言大涅槃经诸佛秘藏

下佛答之。先对初句明已昔说。迦叶佛法七日灭者小乘法灭大乘不灭。汝向所问迦叶如来有是经不下对前第二明迦叶佛实有不无。迦叶佛时所有众生贪欲薄下对上第三明迦叶佛虽有此经众生纯善不假为说是故言灭。四迦叶佛法实不灭下对前第四明虽言灭常存不变。故得名为诸佛秘藏。而中有二。一正明法体有灭不灭。二若我弟子受时已下劝人受持令使此经于人不灭。就明法体灭不灭中。如我上说唯有文殊乃解是义今当重说至心听者。牒举向前有得中义。今欲就之明灭不灭。是故重牒敕听许说。下广辩之。就前之中三世恒有无有是处明其有灭。就上文中三世恒无无有是处明其不灭。文有九句。此九犹前有得之中八种义矣。但就向前方等经中开为两句故有九耳。第一就前取着之心中道实义明灭不灭。取着之心此名世谛。中道实义此名第一。先举次列后辩可知。余句皆尔。第二就前常乐我净无常苦等明灭不灭。第三就前大小乘法明灭不灭。二乘所持是小乘法。菩萨所持是大乘法。第四就前苦行之心六波罗蜜明灭不灭。苦行之心此名为外。六波罗蜜此名为内。第五就前烦恼涅槃明灭不灭。烦恼有为。涅槃无为。第六就前父母和身金刚法身明灭不灭。父母和合名为可得。金刚法身名不可得。第七就前杂食之身无边之身明灭不灭。杂食之身世俗同有名为共法。无边之身世俗所无名不共法。第八第九就前方等十一部经明灭不灭。于中初番就处分别。人中有灭。天中无灭。后之一番当相分别。十一有灭。方等无灭。虽举九番意取第九以答前问

上来第二正就法体明灭不灭。若我弟子受持已下劝人受持读诵解说令使此经于人不灭

下次对前第二句问明迦叶佛有经不无。先举问辞。下为辩释。释有五段。一正答前问明涅槃经诸佛秘藏一切皆有。二何以下因前言故乘解藏义。三是人所以藏积已下因前解藏乘明诸佛藏积所以。四若是经典灭不现下就藏显灭。五大涅槃常不变下就其初句结呵问辞。初段可知

第二段中初先征问。何故名藏。下对释之。诸佛虽有十一部经不说性等正解藏义。十一部经所不说下重牒前法将喻类显

第三段中先喻后合。喻中是人所以藏积征前起后为未来事对问总释。何等未来重问起后。下广释之。迦叶佛时名今释迦出世之时以为未来。为后出用故藏积之。于中五句。前四明其为未来世须出所以。一谓谷贵。未来比丘畜八不净。净财难得故名谷贵。二贼来侵国。有恶比丘宣说邪法坏乱四众名贼侵国。三值遇恶王为欲赎命。诸恶比丘说佛无常究竟灭尽如似杀佛。名值恶三。佛说此经言已常在如似赎命。四道路涩难财难得时。有诸比丘读诵世典不敬佛经。佛经难闻名财难得。末后一句乃当出用结明应出。合中诸佛秘藏如是合前财物。为未来世合为未来。诸恶比丘畜不净物合前谷贵。为四众说合贼侵国。如来毕竟入于涅槃合为赎命。读诵世典不敬佛经合财难得。如是等恶现于世时如来为灭则为演说合乃出用

第四段中就藏显灭。秘藏不现名为灭矣

第五段中约就初段明大涅槃常在不变。反呵问辞。云何难言有是经不

下次对上第三句难明迦叶佛虽有此经以不说故得言其灭。于中有二。第一正明迦叶佛时无四所为有经不说是故言灭。二今世下举今显昔。前中初言迦叶佛时众生贪薄翻前第一明谷不贵。以贪薄故不畜人种不净之物。智慧滋多乃至如象翻前第四明财易得。以有信慧持法不忘故非难得。智慧滋多明有解也。调柔易化有大威德明有信也。总持不忘如大象王明有念也。念持多法故如象王多有胜持。世界清净翻前第二彰彼佛时无贼侵国无恶比丘宣说邪法坏乱四众所以清净。一切悉知如来终不毕竟涅槃翻前第三明无恶王不须赎命。虽有是典不须演说翻前出用

第二举今显昔之中。今世众生多诸烦恼翻前第一多烦恼故畜人不净。愚痴已下翻前第二。愚痴喜忘翻前总持不忘之言。愚痴覆心所以喜忘。无有智慧翻前慧多。多诸疑网信根不立翻前调柔易化之言。世界不净翻前第三。一切咸谓如来无常翻前第四。是故演说翻前虽有不须演说

下次对上第四句难明迦叶佛不说名灭。法实不灭故得名为诸佛秘藏。先辩后释

上来偏就迦叶如来明涅槃经常有不灭。自下泛就余佛如来明涅槃经常存不灭。于中有二。一明众生异见生时诸佛乃说是涅槃经。二宁说故嘴尽大海下就不说时明实不灭。有六复次。皆先举其假设之言。后显不灭

自下第三泛明余经兴废所由令人护持。文有六对。一有解义不解义对。无解则灭。有解则住。二者有无檀越相对。无则法灭。有则法住。第三贪利不贪利对。贪利说经佛法则灭。无贪则住。四起诤讼不诤讼对。诤则法灭。不诤则住。五畜不畜对。畜不净物自称得圣佛法则灭。不畜不净不自称圣佛法则住。六种种异说不异说对。各执所见异说则灭。不执己见不作异说佛法则住

我法灭时有声闻下大段第四泛明余经常在不灭令人敬学。于中有六。一明法灭相。二尔时凡夫各共说下大众闻灭咸皆伤叹。三而我正法实不灭下因众伤叹明法不灭。此前一重。四当于尔时阎浮内下重显灭相。五尔时拘尸无量众下明众伤叹。六迦叶告下因众伤叹重明不灭。此复一重。初中有二。第一通论始终灭相。由诸弟子或说有神或说神空或说中阴或复言无如是种种故令法灭。二从尔时拘睒弥下偏就最终以显灭相。于中先举邪正二师。次列邪正二种徒众。下明邪正二师所说。后明邪正二众所作。事如经说。余皆可知

第五大众闻法不灭发心修学。文亦可解

品初至此明其梵行

自下第二寄就世王忏悔逆罪以显菩萨治病之行。问曰。若此显病行者何故文中不举不结。辨法有二。一当相直论。二寄事表法。当相论者须举须结。寄事表者举事便罢。今此文中寄事表法故无举结。文中虽不言是病行。治病之相快成显著。若此非者应有指斥。不应直尔。又问若此显病行者。何故与前章门不次。良以世王此处来故。又复此例上下非一。如前八种知见之中先开八门。后释不次。又复如下第二德中先列五门。后解不次。此亦似彼。未足可怪。文中有四。一明世王造作逆罪以为起病。二因害父下明王有信愧彰病可治。三尔时其母字韦提下明王病重余医异药不能救疗。四尔时大医名耆婆下明王重病唯佛法药之所能治

初中世王举起病人。下彰其病。病中有二。一明世王先具三恶。其性弊恶喜行杀戮是身恶也。具口四过是口恶也。贪恚愚痴是意恶也。二明世王现造逆罪。先明逆因。因谓三毒。其心炽盛明其有嗔。唯见现在不见未来纯以恶人而为眷属彰其有痴。贪着现乐显其有贪。父王无事横加逆害正造逆罪

第二段中句别有二。一明王有愧。因害心热身诸璎珞伎乐不御愧深失乐。遍体生创臭不可近悔增致苦。二明王有信。信有罪报故自念言我今此身已受华报狱苦不远

第三段中文别有二。一明王病重余药不疗。二时有大臣名月称下彰王病重余医不治。前中初先母为抚疮。后王对之明其非治。此亦即明世王有解。疮从心生非四大起是识病也。众生能治无有是处是知治也。第二段中六臣详劝世王不从。六臣即是六师弟子。其六师者。一富兰那迦叶空见外道。二末伽离常见外道。三删阇那一因见外道。四阿耆多翅舍自然见外道。五伽罗鸠驮迦旃延自在天因见外道。六尼乾陀不须修道外道。是故六臣各随所习用以劝王。初中有四。第一月称问王安否。二王答不安并复伤已罪无灭处。三大臣闻已开解王心示王归处。四王审未从。初段可知。第二段中先明不安。又无医下伤无灭处。第三段中先对世王不安之言开解王心。于中初先直劝莫愁。如王言下以理开解。如王所言世无医下对王向前无医之言示王归处。先牒后示。示中有五。一列师名。二叹师德。三常为下明师所说。四示其师处。五劝王归从。乃至耆婆劝王归佛亦有此五。宜须记知。第四段中王熟知邪不能顿违。是故且言审能我归。一中既然。余皆同尔。第二臣中四分如上

第三臣中四分同前。第三分中光安王心。后示归处。安王心中先以理开。后劝莫愁。以理开中两义开解。第一以其王法开解。先王若是修解脱人杀之有罪。为王治国杀之无过。二以先王宿业开解。先王宿世自有罪业故杀无罪。文中有四。一泛明一切无义不同。或有全无名之为无。或非或少或隐名无。二虽言少法名为无下就前无中明其少无实非无法。三愿王留下就人分别。明一切生皆有往业说言无罪少故名无。四若使下明其先王自有罪业故杀无罪。前中八句。初之两句以彼全无共非法无相对分别。次有五句。以彼全无共少法无相对分别。末后一句以彼全无共隐覆无相对分别。虽举多义为取少无。此初段竟。第二可知。第三段中愿王留神一切众生皆有余业正明有罪。以业缘下举果证有。举一切生为将类王。第四段中约对前义明王有罪杀之无过。余皆可知

第四臣中恒河已南施生无福恒河已北害生无罪。盖且言耳。不劳异释

自下第四明王重病唯佛能治。于中有五。第一耆婆试察王心问王安否。二答不安并复伤己罪无灭处。三耆婆叹王有愧可救并示灭处。四王耻未从众人共劝。五王因众劝诣佛忏悔

初中大医名曰耆婆标举劝人。耆婆胡语此云长命。初生之日弃之巷首而得不死故号长命。其人善医故称大医。往至王所白言安否试察王心。无愧则安。有愧不安。不安可救故须试问。为成世王治病之行故医问之

第二段中世王初先彰已不安。今我又无。无上医下伤无灭处。前中初先泛举一切。二不安人。偈后长行明已未同安眠之人同不安者。初中偈答总以标举。下列答辞。有十七行半。初十一行半明安眠人。后之六偈明不安者

前十一行半相从为四。初有四偈明佛安眠。次五偈半菩萨安眠。次有一偈出初段中安眠之人。所谓诸佛。末后一偈出第二中安眠之人。所谓菩萨。初四偈中前二明佛断烦恼障故得安眠。于中前偈明断烦恼。后偈明由断烦恼故证大涅槃。若得涅槃是其自德。演说深义明利他德。名婆罗门总以结叹。自净净他故得称为真婆罗门。第三一偈离业故安。远离三耶身口意净。第四一偈除苦故安。身心无烦正明离苦。安住静等明其得乐

菩萨安中初之四偈自行安眠。后一偈半外化安眠。前四偈中初三离业。后一明离烦恼及苦。前中初偈明离口恶。心无取着不爱自身。远离怨仇不憎他人。此二明离恶口之因。常和无净正离口过。第二一偈明离意恶。若不造恶明其离过。心常惭愧信恶有报明其摄治。第三一偈明离身恶。敬养父母不害生命明其离杀。不盗他物明其离盗。略无离淫。第四偈中调伏诸根亲近知识明其摄治。破坏四魔明其离障。破烦恼魔明离烦恼。破阴破死彰其离苦。破坏天魔明离烦恼及苦因缘。下利他中初先明其自心离相。吉与不吉是善恶因。苦乐是果。证实离相故皆不见。次明为生转轮生死。若能下结

第三段中谁得安眠对初四偈而为征问。谓佛指出。深观已下明安所以。观空三昧是初段中前之三偈离烦恼业。身心不动是初段中第四一偈身心无恼安住静等

第四段中谁得安眠对第二段而为征问。谓慈悲是就人指斥。菩萨常行益物。是故就德说为慈悲。常修已下明安所以。慈悲常不放逸是第二中初之四偈自利之德。视众如子是第二中后一偈半化他之德

就后六偈明不安中初之三偈有恶不安。后之三偈有苦不安。前中初偈由痴造恶。第二一偈由贪造恶。第三由近恶友造恶。后三偈中明有七苦不得安眠。初偈明有病苦不安。于王有怨死苦不安。余五明有求不得苦所以不安。上来泛举安不安人

自下正明已之不安。于中有四。一明已病重。先举后辨。二一切良下彰已难治。先辨后释。三如鱼下举喻类已显已不安。六喻显之。四我曾问下引说验已成已不安。上来第一明已不安。今我无下伤无灭处

自下第三耆婆叹王示王灭处。于中初先对王不安赞叹于王。迦毗罗下对王向前无医之语示王灭处。叹中有二。一对王向前喻已不安叹王有愧。即约此愧彰病非重明非叵治。二善哉大王能信已下对王向前引说验已叹王有信。即约此信彰病非重明非叵治。于此二中彰病非重翻上初段。明非叵治翻上第二。初中有四。一叹王有愧。二智有二下明忏能灭罪劝王忏悔。三富有二下明善能破恶劝王修善。四如佛说覆藏漏下明发露灭罪劝王发露。初中五句。一乘王前言劝王惭愧。二诸佛世尊常说已下引佛昔言明惭与愧能救众生故非叵治。先举后列。三从惭者自不作下辩惭愧相。三番辩之。四无惭愧下举失显得。五善哉明王非重下结叹世王能具惭愧

第二段中句别有三。一引佛昔言明智与愚并皆有二。举此合王舍愚同智。二虽先下明其智者忏能灭罪。于中初法次喻后合。三王若下劝王忏悔

第三段中文别有三。一明善胜恶。先喻后合。二臣闻下明善破恶。初先法说。次举三喻。后合显法。三虽名小下叹胜令修。先叹后释

第四段中文别有四。一引佛昔言明覆者漏不覆无漏。二发露下偏释不覆无漏之义。三若覆下明覆罪增不覆罪灭。四是故下结明智者不覆藏罪令王周之。初段可知。第二段中初总明其发露忏悔故得无漏。若作已下别明发露故得无漏。若悔已下别明忏悔故得无漏。初先法说。次喻。后合。后二可解

就下叹王有信之中耆婆初先叹王有信劝王莫愁。世王前者引说验已身口意恶必堕地狱名信因果。若有已下明有信故王罪非重非不可治。不同阐提所以非重。有信可救故非叵治。于中初先举重显轻。大王今者非一阐下明轻异重。前中有四。一明阐提造罪不悔彰其重病。二如是人下明不可治。于中初法次喻后合。三云何下对向初段辨出其人。四诸佛世尊所不能下对第二重显叵治。先举后释。上来叹竟

自下第二示王灭处。如王所言无能治者牒王上语。下正示之。文亦有五。一列佛名。二无师下赞叹佛德。三今者下示其佛处。四而为下明佛所说。五王今听下劝王归从。初中言字悉达多者此云成利

第二叹中初叹自德。大慈悲下叹其利他。自中初言无师自得是总叹也。下别显之。相好严身叹佛福德。具力无畏叹佛智惠。叹利他中大慈大悲叹利他心。随善生下叹利他行。行分三业。随善生等叹佛身业。知时说等叹佛口业。佛口业中知时而说非时不说语能应机。实语至一语体清净。实语净语明不妄语。当事名实。称相曰净。妙语一种明不恶口。义语法语明不绮语。语能益人名为义语。语能称法故曰法语。一语明其不两舌也。令生离恼语能益物。知生根等叹佛意业。知生根性晓物心器下知法药。随宜方便无不通达是方便智。其智高等是佛实智。位极名高。智能穷法名深名广。智能灭障故如金刚破一切恶。今下示处

明所说中。为无量僧说种种法总以标举。次别显之。王若闻下明佛所说于王有宜。别中初言若有无者。世谛名有。真谛曰无。亦得宣说真谛名有有实性故。世谛名无无真实故。有为生死。无为涅槃。有漏是集。无漏是道。若烦恼果是其苦谛。若善法果是其灭谛。若色色阴。非色余阴。真谛异彼故言非色及非非色。若我涅槃。无我生死。真谛异彼故言非我及非非我。乃至非世非非世等类亦同然。三乘是乘。世间非乘。真谛异彼故言非乘及非非乘。自身作业还自受果名自作自受。现世造业他世受果名自作他受。就现无因亦无果报名无作无受。真谛离相能除罪障故言王闻无作无受重罪即灭

自下第五劝王归从。文别有三。一举十三种人得益成事类劝于王。二大悲普下明佛慈普去王疑心。三假使一月常以衣下明佛一切诸缘中胜生王去心。前中先举。后总结劝。举中初有五复次文明佛能益。次一复次举彼目连能益显佛。次四复次复明佛益。次一复次举舍利弗能益显佛。后二复次复明佛益。结劝可知。第二段中初先略明如来悲普正法弘广。怨亲等下十三复次广显悲普。第三段中有五复次比挍度量以显佛胜令王必去

上来第三耆婆叹王示王归处

自下第四因王愧耻不敢见佛众人共劝。文有三对。一王对耆婆明佛尊高念已罪重不敢往见父王来劝。二王闻父劝悔愧情深闷绝躄地佛光照触而为接劝。亦名引劝。三王犹战恐不敢见佛耆婆重劝

初中先明世王不去父王后劝。王不去中先叹如来佛众清高。吾今已下自耻不往。初中五句。一明如来佛众俱调。调柔心也。二佛众俱净。清净身也。三佛众俱寂。寂静口也。此叹有善。四明无贪。贪爱断也。五明无恼。嗔痴灭也。此明无恶。后中初先念己罪重不敢见佛。吾设往下惧往无宜。卿虽劝下结已不去

父王劝中初举法灭催令速去。后举狱苦怖令定去。前中初有十一句文明法将灭。大怖已下六句之文明恶将至。佛日已下明佛灭后王罪无治。后中七句。初句明王身有重罪定入阿鼻。中间五句辨阿鼻相。唯愿已下一句结劝。辨中初句释名显过。泛解无间有四种义。一趣报无间。人中舍寿即入阿鼻间无住处。二身形无间。阿鼻大城八万由旬一人入中身亦遍满。一切人入身亦如是间无空处。三寿命无间。一生其中寿命一劫间无断绝。四受苦无间。一生其中苦苦相续无乐暂间故曰无间。今此且依后义释之。二假使下辨其身相。此即是其身形无间。三寒地狱下举轻显重。四四方下辨其苦相五作一逆下辨因定果。依如毗昙。随罪多少各别一劫。今此所说共在一劫。轻重为异。阿含经中所说同此

第二对中世王初先闻劝闷躄。下佛见之慈光照触而为接劝。前中世王初闻惶怖仰问是谁。父王次答并重诫劝。世王后闻悔愧闷躄。世王三义所以闷躄。一恐佛交灭已罪无治。故下如来见阿阇世闷绝躄地许为住世。二惧狱苦交至。三愧父情深是以闷躄

佛光照中初许为王久住于世。后以光照。前中有二。一佛见世王闷绝躄地许为住世至无量劫。二问答辩释。前中言住无量劫者解有两义。一就真论。世王不知如来常住所以闷绝。佛今为显令知佛常是故名住至无量劫。二就应辨。应中有二。一对世王假设为言。若使世王重罪不灭佛则为住至无量劫。彼罪若灭不须佛住。二对世王流类以释。世王流类广多无尽。如来为之常在世间。不入涅槃。是故名住至无量劫。问答辨中迦叶先问如来当为无量众故何故独言为阿阇世。佛答有二。第一偏对世王释之。今此众中无人谓我定入涅槃世王谓入故偏为之。二对世王流类辨释。我言为于阿阇世者盖乃为于世王流类非独世王。于中初先总牒前语彰彼未解。何以下释。如来密语不可思下结叹显深。释中先征。何故言密。下对释之。于中六番。前四对人。后二就法。就前四中明其为者泛为一切。阿阇世者偏论阿阇世王般类。四番何别。初言为者泛为一切凡夫众生。言阿阇者举阿阇世般取一切五逆众生。第二番中明其为者为于一切有为众生。凡夫二乘通名有为。先举后释。阿阇世者举阿阇世般取具足烦恼众生。第三番中明其为者为于未见佛性众生。解行已前通名不见。亦可九地已还菩萨未眼见故通名不见。先举后释。见佛性者不名众生故不为之。阿阇世者举阿阇世般取未发菩提心者。第四番中明其为者为于阿难迦叶二众。阿阇世者举阿阇世般取世王后宫妃姤及王舍城一切妇女。后之两番虽复就法约人辨之。前番约就所化辩释。后番约就能化辩释。此两番中为与阿阇辨其世字。三义别解。就前番中初先辨定三字之义。所言为者为于佛性。为令众生见于佛性是以言为。言阿阇者此名不生。世是梵语。此翻名怨。次约人论。人有迷悟。若就迷者。将不生义与性相属迷。惑之人不生性故。若就悟者。牵不生义与怨相属。悟解之人不生怨故。文中初先就迷辨释。不生性故烦恼怨生彰彼迷人无治有障。烦恼怨生不见佛性彰彼迷人有障无治。下次就其悟者辨释。不生烦恼故则见佛性彰彼悟者无障有治。以见性故则住涅槃是名不生彰彼悟者有治无障。由见佛性不生烦恼故住涅槃名曰不生是故名为为阿阇世总以结之。下次就其能化人释。于中先定三字之义。言阿阇者名曰不生。其不生者是其涅槃。世名世法。为名不污。为有何义得名不污。若佛在世自有爱着即名为污。为他处之故名不污。次将此义就佛辨释。若佛在世为世八法之所染污则须舍世疾入涅槃。以佛有世世间八法不能污故。于无量劫常在世间不入涅槃。八法如上。是故下结

下总结叹。密语不思当相正叹。佛法僧等叹其所说成语不思

自下第二佛光照触而为接劝。于中有四。一佛入三昧放光照王王觉疮愈。第二问答辨光所从。第三问答明光来意。四释光明名义。初段可知。第二段中有两问答。一王疑异光审问耆婆。王以已罪不谓如来有光照已故为此问。耆答言非。二王问谁放。耆答佛光。句别有四。一明此光是佛所放。于佛平等法门身中现阿含光名为放矣。佛光常定王今始见是以言放。二辨光实性。是光无根乃至非白。三明光相。为度故现。四拂相显实。是光虽尔实不可见乃至非白

第三段中有两问答。初王问耆婆彼天中天何因放光。耆答为王。恐王喜过且言以为。以王先下明为所由。由王上言世无良医治我身心。故放此光先治王身。后及王心。准斯驱求真是病行。王言已下重复怪问。如来世尊亦见念耶。不望故尔。耆答正为。于中有二。一明王有病故佛偏为。二佛于众生不观已下明王有善故使佛为。前中先喻。一人喻佛。七子喻于六住菩萨及种性前善趣众生。一子遇病喻种性前善趣众生起业烦恼。父母之心非不平等。喻佛平等。然于病者心则偏多喻佛偏怜罪恶众生。次合显法。如来亦尔合前父母。于诸众生非不平等合非不等。然于罪者心即偏重。合于病子心则偏多。人有七子一子遇病今略不合。下重显之。放逸佛念显前偏显。不放心舍举轻显重。何等已下显出不放。先问后辨。如地持说种性解行即以为二。初地净心以为第三。二地以上行迹为四。八地九地决定为五。第十毕竟以为第六。道不放逸六住菩萨。则知放逸在六住前

明有善中初明如来不观众生种性等别而为摄化。后明如来有善便念。道此语者明王者善。故便佛为

自下第四释光名义。耆婆初辨此是如来月爱光明。下复辨之。先问后答。有六复次。前五解月。后一释爱。就前五中初三就其生善以释。初一开发始心如月。第二进发行意如月。后一终令成办如月。皆先立喻后合可知。后二就其灭恶以释。前句取彼月光渐灭喻此三昧渐灭烦恼。后句取彼月能除热喻此三昧能除烦恼。亦先立喻后合显法。释爱可知

第三对中世王初先彰已不去。耆婆后劝。前中四句。一举昔所闻辨明如来不近恶人。于中初法。次举四喻。后合可知。二我当下明已不去。三我观下自测如来不近恶人四是故下结已不去

耆婆劝中初先劝王专意求佛。先举六喻。下劝同之。如来尚下举佛为彼阐提说法去王疑怖。于中有三。一举如来为阐提说以咒于王明去有宜。二王闻怪问我闻阐提不信不闻不观得义。何故如来为之说法。言不信者无行方便。下明无行。言不闻者无其闻慧。不能观者无其思慧。不得义理无其修慧。三耆婆广辨。于中先喻。次合显法。后明如来为说所以。喻中极多合文至少难可具合。又复诸喻或取少分或多或全未必尽取故难具合。今此且可粗略而已。文中有五。一阐提断善喻。二诸家亲下征善感圣喻。三尔时良医即自思下佛观物机喻。四思惟是已寻与使下乘机赴化喻。五语瞻病者吾剧据下权时放舍喻。初中有二。一邪心未明说之如梦。二邪心决了说为梦已。前中有人喻断善者起恶邪见名遇重病。邪心未明说为夜梦。善有二种。一者方便。二者生得。断方便善唯生得在是故名为升一柱殿。心贪五欲名服苏油。身恒处之故曰涂身。身居违境名为卧灰。心缘起嗔故曰食灰。心缘无因无果之理名攀。枯树心与疑俱犹预不定名与猕猴行住坐卧。心在恶中名没泥水。退失诸善名堕楼殿。高山树木。无惭愧法以自庄身名著青黄赤黑色衣。造恶畅心名喜歌舞。恶觉现心名见乌鹫狐狸之属。恶觉害善如乌鹫等残杀为事。故以为喻。退失信慧名齿发落。无戒遮身称曰裸形。心缘恶境故说枕狗。沉没一切诸烦恼中名卧粪秽。亦可常没三恶道中无心求出名卧粪秽。与断善人共相亲附名与亡者行住坐卧。心行渐同故曰携手。吞灭善法名为食啖。恶道因成名蛇满路。游之趣向三恶道处名从中过。倒爱缠缚名与被发女人相抱。外道邪戒用自遮防名多罗叶以为衣服。依于外道邪法起修名乘驴车。背善向恶名正南游。南方是火向之最恶故取为喻。邪心决了名为梦已。善法燋损名心愁恼。邪心转盛名病踰增

第二微善感圣喻中断善根人过去善业名家亲属。发生现善故曰遣使。善生感圣名为命医。善行不圆名体缺短。五根不备名根不具。烦恼覆障名蒙尘土。少于惭愧名著坏衣。依于过佛余残善法而起此善名乘故车。机显圣心名为语医。感圣不贳是以言速。欲令如来乘于昔法而往教化名疾上车

第三如来观机喻中句别有五。初句喻观现善微劣故言见使相貌不吉。劣善不能对治耶病故曰难治。占日喻观起行之心。心有善时恶时之别。占星喻观所成使性。占时喻观乐欲之心。下观福德喻观生得。信等五根前事虽无。若当生得善根未断则可疗治。无则叵救故言若无虽吉何益

第四随机起化喻中文别有四。一喻如来升兜率时观物机病。先别后结。难识叵合。二我若不往非良师下喻佛下生阎浮提时观物机病。先别后结。事亦难识。三尔时即入病人舍下喻出家时观物机病。出家先于外道法中修习所行名入病舍。四医见是已问瞻病下喻成道后观机为说。于中先别。尔时良医见如是下总结难治。别中初问次嗅后触。初问喻明心行不定。亲化菩萨如瞻病者。如来对问彼具答之。次嗅喻明口言不定。嗅喻恶言。香喻善语。后触喻明身行不定

第五权时放舍喻中。如来告彼亲化菩萨彰已更欲迁化异境名语瞻病吾今剧务。斯后化度名当更来。随情所堪授以世法名随所须恣意勿遮。舍之取灭名即还家。彼起微善感圣名曰使到。如来知其未堪受化即未从就。是以告使我事未讫。兼未合药。明已余方为化未周名事未讫。佛未量机以授其法名未合药。喻相难识不可尽合。设有合者未可专定。下次合之。世尊亦尔合上医师。一阐提辈合前第一并合第二。善知根性合上第三。而为说法合上第四

下明如来为说所以。先问后解。解中初明为息余人讥谤故说。佛若不说余人当言佛无慈悲。后明为益阐提故说。于中初明为令生善。譬如已下令出三涂。就生善中初明阐提生善不同佛为说法。复有二下举根不同成生有异。前中先举。次列两名。下明如来为之说法。泛论阐提具有三种。一者上品现闻经法微能生信。二者中品现闻经法不信不谤。远能发生未来善根。三者下品现闻不信诽谤不受。今举前二。第三不信佛不为说故略不举。下举根中先举。次列。下明其人生善不同。后结如来不空说法。就明为拔三涂苦中。先喻。次合。是故已下结佛为说

自下第五世王受劝诣佛忏悔。于中有三。一严驾诣佛灭罪由序。二尔时佛告阿阇世下佛为说法除灭王罪。三辞退还宫。初中有四。一受劝许往而未即发耆婆催劝。二即命下严驾向佛。三于前路下道闻二言心生惶恐。如来许为作决定心。四王到双林如来顾命去王疑心。初中有二。一世王受劝择时许往。若使如来审如是者所谓审为阐提说法。二耆婆催劝。劝有四句。一明佛法不择时日。二时王病重不应选时。先举世事。后约以劝。三明诣佛得益齐等。四结劝令往

第二段中句别有五。一敕臣严办。二臣答已具。三严驾向佛。四拘尸大众咸皆睹见。五佛叹善友。先叹后释

第三段中初明世王道闻二言心生惶恐。佛告已下如来许为作决定心。前中初明道闻二言。闻流离王遇火烧死。瞿迦比丘生入阿鼻。是一言也。彼流利王杀害其父。闻佛记说当彼烧死。遂便乘船入于后园海中避之。阿鼻之火即就海中吸之将去。瞿迦比丘是舍利弗目连弟子。于一时中谤此二师俱犯重罪故入阿鼻。闻须那刹诣佛灭罪是二言也。吾今已下明王惶怖求与耆婆同载一象。设我当下求之救免。设我当堕冀汝捉持。先求后释。如来许为作定心中。佛先告众世王有疑我为作定是义云何。世王向者道闻二言便生疑念。不知如来肯见救济令如须那。为当不救令如流离瞿迦离等堕阿鼻狱。准下见佛除疑决定。疑意正尔。佛下领命令其知佛定欲救济名作定心。持一切下问答辨释。彼持一切先为请问。诸法无定云何言定。下佛先叹。后为辨释。我为世王作决定心总明作定。何以故下别显作定。先问后解。解中有四。一以王疑不定类法不定。王疑可破当知诸法悉无定相。二是故下结。是王疑心可破坏故。我为世王作决定心。三当知下以王心不定类罪不定。于中先明王心不定。若彼王心是决定下将心类罪明罪不定。先反后顺。四是故下结

自下第四王到双树如来顾。命去王疑心。于中有四。一王到双树仰瞻如来相好殊妙。二如来顾命去王疑处。三迦叶菩萨语持一切明佛为王已作决定。四世王欢喜设供奉佛礼敬却住。初段可知

第二段中曲有四句。第一如来发言呼命。八种声者如梵摩喻经说。一最好声。其声清雅。二易了声。有所言说辨了易解。三调和声。大小得中。四柔软声。其声柔软令人喜闻。五不误声。言无错谬。六不女声。其声雄朗。七尊慧声。言无战怯。如世尊重有慧之人言无战怯。佛声亦尔。八深远声。犹如雷震。惧王喜过不即题名。是故总相呼言大王。二王闻惊疑。于此众中谁为大王。我罪无福如来不应称为大王。三如来重复题名以呼。四世王闻之除疑欢喜。先明欢喜。真知如下明其除疑。第三可知第四段中世王初先彰已欢喜。次设供养。后礼却住

自下第二佛为说法除灭王罪。于中如来先敕许说。下正说之。说中有三。一教事观生王愧心。二自我招殃造兹重下破遣罪相去王执心。三譬如涅槃非有无下明罪实性令王观入正灭王罪。就初段中如来先教。后阿阇世领解生性。如来教中先明观益。若不系下明不观损。益中有四。一教观身。二明观益。三教观心。四明观益。就观身中凡夫常当观二十事总以标举。次别显之。二十事中前十四句观身无其第一义乐具足诸苦。后六观已迷或颠倒。前十四句相从为四。初二观已无第一义乐。我此身中空无无漏无无漏果。空无善本无无漏因。次二观身具足诸苦。我此生死未得调顺有生死因。不能舍恶名未调顺。堕坠深坑无处不畏有生死果。沉没三涂名堕深坑。于人天中受身皆苦。以是义故无处不畏。次二对前第一义乐教起求心。以何方便得见佛性求其观行。云何修定得见佛性求其止行。又复前句求随有行。云何修定求入寂行。下八对前具足诸苦教生厌心。于中前七教观重苦。后之一句教观深苦。就前七中生死常苦无常我净教观生死之通过也。八难已下教观生死之别过也。八难难离是障道过。恒为怨等是轮转过。于中前二明人天中轮转之过。恒为怨逐明共有障。五阴是怨。生便有定故言恒逐。无法遮有彰其无治。后之三句明三涂中轮转之过。三恶未脱有三涂果。具恶邪见未度逆津有三涂因。具恶邪见有烦恼也。未度逆津有恶业也。邪见五逆三涂定因是故偏举。前明重苦。生死无际未得其边明深苦也。上来明无第一义乐具足诸苦。下六明已迷或颠倒。于中前四泛立道理。后二对理明已迷或。就前四中不作诸业不得果报明非无因。无有我作他人受报明非异因。不作乐因终无乐果明非倒因。若有造业果终不失明非无果。就后二中因无明生亦因而死由迷前理受生死果。去来现在常行放逸由迷前理造生死因。凡夫常下总以结之。上来第一正劝观身。作是观下明观利益

尔时次第观心生下教观心法。次第观心生住灭相教观心也。次观止等教观心法。观生灭已知心相下明观利益。知心至戒终不作恶明离恶因。无死畏等明离苦果。上明观益。若不系下明不观损上来佛教

下明世王领解生愧。文显可知

自下第二破遣罪相去王执心。文别有二。一就杀父因缘以破。二众生狂或凡有四下约心以破。前中有四。第一世王执有定罪定堕地狱。二如来略破。亦名类破。三世王领解。四如来广破。亦名正破。初中六句。自我招殃是第一句执已得罪。造兹重恶是第二句执罪定重。父王第三执有定父。无辜第四执父无过。横加逆害是第五句执有定杀。是二十事设观不观定堕地狱是第六句执定堕狱。此之六句下佛别破。宜审记知

佛告已下如来略破。一切诸法性相无常无有决定举法类破。王云何言定堕阿鼻当言正呵。前六句中就后以呵

自下第三世王领解。若一切法无定相者我之杀罪亦应不定将法类罪。若杀定者一切诸法则非不定以罪类法。前句顺类。后句反类

佛言已下如来广破。先叹后破。王前领解是以须叹。王前有执是故须破。叹中善哉是总叹也。诸佛下别。是故下结。就下破中所破有六。如上所执自我招殃乃至必定堕阿鼻狱。文别有三。一破前六中定父定杀。即约此二破入地狱。二众生作罪凡有二下破前六中自我招殃造兹重恶。即约此二破入地狱。三先王自作还自受下重破向前自我招殃并破无辜。即约此二破入地狱。地狱所畏是故三处皆悉破之。就初段中先破定父。凡夫众生于是色下破其定杀。若色是父可杀害下破入地狱。就初段中如王所言父王无辜横加逆害牒王前语。此为破父。余乘举来。何者是下正破其父。于中初就阴入界等三科法门征责其父。若色是下别就五阴征破实父。若色是父四阴应非纵色破心。若四是父色亦应非纵心破色。若色非色合为父者无有是处双破色心以为父义。何以下释。以色非色性无合故。不可色心合以为父。就破杀中偏就色破。以色质碍可残害故。凡夫于色妄生父想举其所计。如是色阴亦不可害对之总破。叵害同心是以言亦。何以下释。于中先问。何故色阴亦不可害。下对释之。释中四句。一分色为十。五根五尘是其十也。如毗昙中说有十一。五根五尘及无作色。成实法中说有十四。五根五尘及与四大。今以何故偏说十种。释言。四大于此经中是触尘收故不别论。彼无作色于此经中但是色法而无色相。成身相隐是以不说

二就十中简一去九。唯色一种可见可持乃至可缚。余九不尔故可不杀。唯色一种一色尘也。为眼照瞩故言可见。可得捉持故言可持。轻重可称。长短可量。可得牵挽亦可系缚。是以可杀。依如毗昙。色相可见。色形可量。方圆大小可度量故。色性可持可牵可缚。质等法故。可称是触。若依成实。色唯可见。可称是触。可持可量可牵可缚是假名色。法尘所收。今此何故说色可见乃至可缚。释言。此说多同毗昙。色相可见。色形可量。色性可持可牵可缚。可称重触。不离色辨相从名色

三虽可见下就彼一色破去见等。虽可见缚上牒所辨。上有六句。举初举后。是以但言可见缚矣。粗相论之。色相可见乃至可缚。细分则无。辨有兼无是以言虽。性不住下翻有显无。色性无常一念则有。初生次住终异后灭故曰不住。以不住故不可得见乃至叵缚

四色相下结成无杀。色之体相如是不住乃至叵缚云何可杀。下约前二破入地狱。句别有六。一就十色简一去九。若色是父可杀可害获罪报者余九应非。若九非者则应无罪。二就一色明有可杀义。先举三数。次列三名。下就分别。于中先明过现叵杀。初举后释。过色已灭故不可杀。现色暂现念念自灭故不可杀。下就未来明有杀义遮不起故。三如是下以前可杀不可杀义成色不定。四以色不定成杀不定。五以杀不定成报不定。六以报不定破入地狱。报既不定云何说言定入地狱

自下第二破自招殃造兹重恶。即约此二破入地狱。先破定重。若敕侍臣立斩王下破自招殃。频婆娑罗往有恶下破入地狱。破定重中初泛先举一切众生作业有二。次列两名。后辨其相。心口作轻。身口心作说之为重。下约此二辨王所作。心念口说身不作者所得报轻重辨前轻。下将验王。大王昔日口不敕杀但言削足。是则王罪轻于彼轻。何得言重。下次破其自我招殃。前言招殃。此云得罪。眼目异辞。初先直破。王若得罪诸佛世尊亦应得下举佛类破。就直破中举重况轻成王无罪。若敕侍臣立斩王首坐时乃斩犹不得罪是举重也。谓不得斩坐王之头于彼坐王不敕斩故。况王不敕云何得罪是况轻也。敕杀之中坐起之别犹不得罪。况王昔日但言削足不敕令杀。云何得其杀父之罪。是中但破正杀之罪。不言削足令无有罪。下类破之。何故须类。王有余执由我削足令父命尽。我于正杀不得无罪。佛今类破。若由削足令父命尽王于正杀而得罪者。诸佛于杀亦有缘由亦应得罪。佛于此杀虽有缘由而不得罪。王于正杀虽有缘由云何得其正杀之罪。文中初言若王得罪诸佛世尊亦应得罪略举类破。何以下释。初先征问。下对释之。明佛于杀亦有缘由故应得罪。是中不欲明佛得罪。举佛如来于杀有缘而不得罪。成彼世王于杀有缘不得正罪。文中四句。一明先王由供诸佛故得为王。先顺后返。二若不为下明由作王故被杀害反以显之。三若汝杀父当有罪下以王类佛令佛得罪。四若佛世尊无得罪下以佛类王成王无罪。诸佛于杀亦有缘由而不得罪。汝独云何偏得杀罪

下次破其定入地狱。举彼先王类以破之。先王作罪悔而不入。王今悔愧云何定入。文中有四。一明类彼女曾于往昔游行猎鹿杀害仙人。二明仙人临终生怒遂发恶愿。三王闻悔愧。四举类世王。是王如是尚得轻受不入地狱况王不尔。而当地狱受果报也。解有两义。一就因辨况。先王过去心念加害口言敕杀其罪则重。世王今日心虽念害口不敕杀其罪则轻。先王重罪以忏悔故尚得轻受。况王不尔。不同先王口言敕杀而于地狱定受果报。二就果辨况。先王作罪还生愧悔。世王作罪亦生悔心。先王作罪悔得轻受不入地狱。以彼况王何独不尔偏于地狱定受果报

自下第三重破向前自我招殃并破无辜。即约此二破入地狱。先破自招。如王言下破其无辜。频婆娑罗于现世下破入地狱。前中如来举彼先王自作自受破阿阇世自招之言。故今说言先王自作还自受之云何令王而得杀罪。自我招殃前已破竟何劳重破。前以世王口不敕杀破其招殃。今以先王自作自受破阿阇世自招之言。有斯不同是故重破。破无辜中如王所言父无辜者牒王上言。下对破之。云何言无对以总征。夫有罪下对以广破。有罪有报无恶无报泛立道理。汝父无辜云何有报以理征破。破入狱中句别有三。一以频婆现受善报及以恶果。明王不定。二以王不定成杀不定。三以杀不定破定入狱

上来就杀因缘以破。自下第二就心以破。于中有二。一明罪实无去王执心。二如王宫中常敕屠下就其假有遣王怖心。前中复二。第一明其惺悟是垢狂乱是净无情过故。二如幻师下明狂惑是垢惺悟是净知无法故。于事分齐惺悟是垢狂乱是净。于理分齐狂惑是垢惺悟是净。前中有四。一明四狂作恶无罪。二约以类王。三明昏醉作恶无罪。四约以类王。就初段中先举。次列。后明无罪。我弟子中四狂作恶我终不记是人犯惑正明无罪。是人所作不至三恶举果显因成因无罪。若还得下举惺显狂成狂无罪。后三可知。狂惑是垢惺悟净中文别有三。一约愚智明杀非真破其实有。二杀法下明知杀无罪破其定有。三有众生于日出下明因杀无罪破其定有。初中七番明罪非真。皆先立喻。后合可知

第二段中文别有二。一举佛类王明知无罪。二举喻类王明知无罪。前中如来先自彰已知杀无罪。言杀法者是杀方法谓咒药等。言杀业者正是断命。言杀果者因杀受报。及解脱者除杀得脱。佛于此事皆悉了知而无有罪。何故无罪。无恶心故。王虽知下以佛类王明王无罪。如来广知犹尚无罪。王唯知杀云何有罪。前五事中偏知一杀故曰唯知。如佛及王知杀无罪。一切众生知杀例然。问曰。若知悉无罪者云何佛说众生有罪。释言。众生所有罪者别由恶心不由知杀。若无恶心虽复知杀而无有罪。佛今斥就知杀义边所以言无。恶心教杀非今无罪。故下如来别教灭除。举喻类中先举其喻。如人知酒不饮不醉。亦如知火不触不烧。下将类王。王亦如是虽复知杀若无杀意云何有罪。自下第三因杀无罪。此明因杀不得正罪。非谓令无削足之罪。非令无故下文之中别教除灭。文中举事类显因杀不得罪义。于中初明世间众生因于日月作种种罪。先顺后反。虽因已下彰彼日月实不得罪。可将类王。杀虽因王王亦不得正杀之罪。问曰。因杀若无罪者云何佛说众生有罪。释言。因杀不得正罪故佛说无。恶心教杀非命无罪故佛说有。上来第一明罪体无

自下第二就其假有遣王怖心。于中两番。一举羊类父呵王偏惧。二推罪属爱与王解过遣王忧怖。忧怖过增妨乱受法故须遣之。前中初言如王宫中常敕屠羊心初无惧云何于父独生惧心呵王偏惧。虽复已下明人与畜宝命齐等责王偏惧。后中初明世间众生是爱僮仆不得自在。为爱使

下明为爱使故行杀戮。设有已下推罪属爱。王不自下明王无过遣王爱怖

上来第二破遣罪相去王执心

自下第三明罪实性教王观入正灭王罪。于中有三。一佛为说法。二尔时世王如佛说下明阿阇世闻法灭罪欢喜发心。三尔时世尊赞阿阇下如来述赞。初中有二。一明罪体相。二夫众生者名出入息下教生观入。前中先举涅槃为譬。后将类杀。问曰。杀浅涅槃义深云何以深而况浅乎。释言。是中以易况难。就涅槃法明非有无。理在易知。就杀辨之相在难识。故今举彼易知涅槃以况杀矣。喻中涅槃非有非无明涅槃体。于迷非有。于解非无。而亦是有是有圆也。下类杀中初总。次别后总结之。杀亦如是虽非有无而亦是有是其总也。非有非无论其业体。而亦是有彰其业能能有果故。惭愧下别。别中三番。一就有义明非有无。二就破有入空义中明非有无。三就破空显实义中明非有无。就初事中惭愧之人则是非有能灭除故。无惭愧者则为非无不能灭故。此论业体。受果报者名之为有彰其业能能得果故

第二门中空见非有能灭除故。有见非无不能灭故。此明业体。有有见者亦名有等障其业能能得果故。于中初辨。何以下释。有有见者得果报故正解有义。于有见有名有有见。无有见者则无果报举无显有

第三门中常见之人则为非有能断灭故。证见常种名曰常见。证常之时见法本寂无罪可起所以能灭。无常见者则为非无不能灭故。取着空义名无常见。不能见实永除无想令罪息灭。所以非无。此论业体。常常见者不得无下彰其业能能得报故。于中初举。何以下释。于常法性计为定常名常常见。执取之心悉是烦恼。能助杀业得恶报故名有恶果。是故下结。空空见者亦有恶报故前宣说。无常见者则为非无。今据细论。鹿类可知。是故偏言常常见者有恶果矣。上来别释。以是义下总以结之。上来第一明罪体相。下教观入灭除王罪。还就向前三番教之。一就上有门明有杀罪生王愧心。令王作其惭愧非有。二色无常下就前破有入。空门中教王观入令王作其空见非有。三杀无常下就前破空显实门中教王观入令王作其常见非有。就初番中夫众生者名出入息立众生相。断出入息故名为杀建立杀相。诸佛随俗亦说有杀明有不虚。以有杀故应生惭愧

第二番中句别有五。一教观无常。色是无常当相辨理。色之因缘亦无常者将果类因。从无常因生色云何常以因显果。乃至识无常者当相辨理。谓从受阴至识无常识之因缘亦无常者将果类因。从无常因生灭云何常以因显果。二以无常显于苦义三以苦义显于空义四以空义显于无我。五以无常苦空无我显成无杀

第三番中句别有三。一教世王舍虚入实。言杀无常得常涅槃者据实返望由来无阴阴。既不有知复就何宣说无常。舍离五阴无常之相是以言杀。盖乃是其无杀为杀。以离相故证法本寂。是故名为得常涅槃。杀苦得乐乃至杀于无我得我类亦同然。所证真实如来藏体。不变称常。寂灭云乐。不虚曰实。自实名我。又法自在亦名为我。二若教下明观利益。上与佛同。三我亦杀下以同破别。我杀无常苦空无我不入地狱汝云何入据斯以驱。空浅有深其理不虚上来第一佛为说法。自下第二明阿阇世闻法灭罪欢喜发心。于中有五。一阿阇世如教正观。二即白佛下欢喜自庆。三我今见佛以是见下重起愿心。四语耆婆下重自喜庆。五以种种下庆蒙法利供养赞叹回向发愿。初段可知

第二段中所庆有五。一庆有所解。二我曾闻下庆蒙佛恩。三我亦闻下庆有所同。四我见世间从伊兰下庆有所生。五我若不遇如来已下庆有所免。初中先明今日所解知色无常乃至知识亦知余义就治言耳。我本若知则不作罪伤本不解反以言之。第二句中我昔闻佛常为众生而作父母举昔所闻。虽闻已下彰昔未审。今则已下明今定知。世王正解蒙佛教生。故今知佛为生父母。第三句中先举昔闻。虽闻已下彰昔未审。我今来下明今始知。常乐我净世王未证故略不论。第四句中我见世间从伊兰子生伊兰树不见伊兰生栴檀树举昔不见。今见伊兰生栴檀树明今始见。伊兰子者我身是也约喻显已。第五句中庆免地狱反以显之。此第二竟

第三重起愿心之中文别有三。一自行兼他。由王发愿令无量人发菩提心。二以如是下他利兼自。由彼发心王罪微薄。三王及下总结皆发。前中先明王自发愿。后令他发。前中我今见佛功德破坏众生烦恼恶心略起愿意。佛言已下如来记叹。若我审下重兴大愿。他发可知

第二段中先明他发。后明世王重。罪得薄。第三可知

就第四段重自庆中先庆所得。后庆得为诸佛弟子。前中初先列已所得。谓得出世净天之身长命常身令诸众生发菩提下辨其所得。菩萨化他即是自受是故令生发菩提心名得天身长命常身。自下第五庆蒙法利供养赞叹回向发愿。初先供养。次为赞叹。我今见下明其回向。我遇恶下明其发愿。叹中有其九行半偈。初七行半叹佛口业。次有一偈叹佛意业。末后一偈叹佛身业。就口业中初有三偈叹不妄语。次一偈半叹不恶口。次有半偈叹不两舌。后两偈半叹不绮语。不妄语中实语一门明其当法。微妙一门明能显法。善巧句等七句之文广显前妙。末后一偈广显前实。就显妙中善巧于句以为一门。言能顺教。善巧于义复为一门。语能显义。甚深秘藏为众显示广前善义。所有广言为众略语广前答句。具足是语善能疗生总以结叹。就广实中若有众生闻是语者闻前善巧句义等语。若信不信定知佛说显其实义。众生于法信谤不同。是故有其信与不信。世王自道我今定知是佛所说终无虚妄。不恶口中初明如来自言柔软。次明为他所以说粗。后明粗濡同归第一。是故已下结已归敬。不两舌中明佛常作和合之言名为一味。如海喻之。不绮语中佛语称法无有绮异名第一谛。以言称法故无无义明其语净。下明益人。于中初偈能说广法令人入实。后之一偈善说深法令人舍相。意业可知。身中慈悲现化所因。为众苦行随物起化。如着鬼魅喻前慈悲。狂乱多作喻前苦行。就回向中有其三偈。初偈自利。用己善根回向菩提。后二利他。于中初偈用己善根愿求三宝常在益物。后偈用善愿破众生四魔恶病

愿中三偈。初偈自利愿不造恶。后二利他。于中初半愿生发心。次有半偈愿生思佛。次有半偈愿生破恼。末后半偈愿生见性

自下第三如来述赞。于中初就现在赞叹。汝昔已下就过已叹。从今已下就当述劝。先劝后释。此第二竟

自下第三世王还宫

天行品者如杂华说。品中第三明其天行。天行正是菩萨八禅。今不广说。玄指杂华。依佛名经。杂华犹是华严经矣

婴儿品者。五行之中前四已竟。今次解释婴儿行义。名婴儿品。不起后过是婴儿义。文中初问次辨后结。辨中有二。一明佛菩萨自德婴儿。二如婴儿啼哭时下明佛菩萨化婴儿故名婴儿行。前中先明如来婴儿。后明菩萨。就如来中四番辨释。初番通就三业以释。后三偏就口业而辨。前中先喻。不能起住明婴儿心。不能来去明婴儿身。不能语言明婴儿口。下约显法。文显可知。后二可解。是中为明菩萨五行。何故说佛。举佛为令菩萨学故

就菩萨中初就化他心无分别解婴儿行。后就自行离过以释。文皆可知

就化婴儿名婴儿中先喻后合。喻中先别。后总结之。别中杨华喻化凡夫。木牛木马喻化二乘。木男木少喻说众生化小菩萨。喻化凡中句别有四。初婴儿啼时喻化所随。众生造恶名为啼哭。二父母下喻明化相父母喻佛。杨树黄叶喻天果报。劝其止恶故言莫啼。假说天报以为常乐我净之法。授之令得名与汝金。三婴儿见下喻明化益闻说天乐。为求得故止不为恶名儿已见生真金想便止不啼。四然此下明化非真。喻化二乘及小菩萨一处论之。准前类合应有四句。文中少初婴儿啼时但有后三。木牛木马木男木女喻显化相。木马木牛喻小乘法。木男木女喻众生相。婴儿见下喻明化益。据后且言生男女相实非男女明化非真。据后偏言实非男女。以是下结。据后偏言作男女想名婴儿行

下合显法。如来亦尔合前父母。下明化益。然上喻中杨叶之喻一处别论。牛马男女一处而举。今此合中杨叶牛马一处合之。木男木女在后别合。文之左右。就合杨叶牛马喻中文别有四。一合明化凡。二若有众生厌生死下合明化小。三如彼婴儿于非合下就前化凡明佛非虚。四如彼婴儿于非牛下就前化小明佛化意。初中依上喻中四句次第合之。若有众生欲造众恶合上初句婴儿啼时。如来为下合第二句父母即以杨树黄叶语言莫啼我与汝金。众生闻下合第三句婴儿见已即止不啼。实是生死无常已下合第四句实非金也

第二段中若有众生厌生死时合初所少婴儿啼时。如来则为说于二乘合第二句木牛木马。实无二乘超合第四明化非真。以二死故知生死下却合第三明其化益。以二乘故知生无过见涅槃乐向小之益。以是见下趣大之益。由得小故便知有大。已所不得起意趣求是其益也。则能自知有断不断明知集也。知分段因是已所断。变易之因已所未断。有真不真是知苦也。实知分段生死之苦名之为真。未能了知变易之苦故曰非真。有修非修是知道也。知修小道不修大道。有得不得是知灭也。知已但得小乘之灭不得大灭

第三段中如彼婴儿于非金中而生金想举化所随偏举其喻。如来亦尔于不净中而说为净举佛化相偏举其法。以得第一则无虚妄明佛不虚

第四段中如彼婴儿于非牛马生牛马想若有众生于非道中作真道想举化所随法喻并举。如来亦说非道为道举佛化相。小非真道说为道矣。非道之中实无已下明佛化意。小实非道能生大道。微因缘故佛说为道。下次明其化小菩萨。如彼婴儿于非男女生男女想起化所随偏举其喻。如来亦下合第二句明佛化想。而实无生超合第四实非男女明化小真。若佛如来说无已下却合第三即止不啼明化有益。于中有二。一约世谛众生之相合止不啼。二若于众生破众生下约就真谛合止不啼。前中如来说无众生一切众生即堕耶见反明有啼。是故如来说有众生顺明不啼。此言略少。若具应言如来说有众生相故则破耶见。约真谛中若于众生作生想者则不能破反明有啼。若于众生破众生下顺明不啼。是名总结。上来第二别教五行

若有男女受持已下第三结劝迦叶自下第四大段迦叶领解。佛言已下第五大段明此经法利益弘广多人同得

德王品者当法应名十功德品。今从请人以题章目。人以德成。德谓福智二种庄严。光明遍照是智庄严。内智圆满光遍法界名光遍照。高贵德王是福庄严。以福殊胜是故名为高贵德王。具斯德者方堪咨启。故从题品名光遍照德王品也

就此品中四门分别。一对问分别。此品答上愿说甚深微妙诸行。以此十德契实名深离相称妙。二辨来意。何故次辨。向前五行世间所修。此十出世世间行满便得出世。故次辨之。云何得知此十出世。下文宣说非是世法。世间所无故知出世。若论相似功德善根地前亦有。三列其德名。经中不辨。今此且可准义名之。一入智功德。闻思修证次等观入。二起通功德。善起五通妙用自在。三大无量功德。成就具足无缘大慈。四十事利益成就功德。从根难拔终离二边。五是五事报果功德。从根完具乃至第五得宿命智。六心自在功德。谓金刚三昧。第七修习对治功德。谓近善友闻思修行。第八对治成就功德。谓离五事乃至慧心二种解脱。第九利习正道功德。谓信心持戒近友具足多闻。第十正道成就功德。谓三十七品。十中前六自分功德。后四胜进。此第三门。四分文辨释。此品有二。一正辨德。二若须施等信是语下叹经劝学。前中初先总就德体叹以显深。何等十下随修辨相。体则果分。前中初言修大涅槃得十功德总举德体。下叹显深。文有九句。前三出情。后六离相。就前三中不与声闻辟支佛共明过二乘不可思议超出近学。地前缘知不能测及名不可思。闻者惊怪胜过凡夫。闻生诽谤故曰惊怪。下六句中还约前三以显离相。非内非外异凡夫法。内谓六根。外谓六尘。内外为别。真德异彼是以言非。良以此十体同法性义无不在故不同彼。十二入法内外别矣。非离非易异二乘法。依大涅槃修之可得故曰非离。依余契经修之叵得所以非易。非相非非相异地前法。舍相方成故言非相。妙用随缘名非非相。下三重显。非是世法显非内外。谓非世俗凡夫法也。无有相貌显前非相。世间所无显前非易。上来叹深。下次辨相。何等征问。下对显之。就初德中先辨后结。辨中有四。一缘标举。二列五名。三广辨释。四离解者问答重显。一者有五是总举也。闻等列名。此五犹是闻思修证。初一是闻。次有两门通闻及思。第四一门通闻思修。第五是证。不闻闻者涅槃等法离相叵闻。今依此经而得闻知名不闻闻。闻已益者因闻及思知教知义名闻已益。能断疑者依闻及思能除闇或故曰断疑。慧心正者因闻思修能离邪曲故曰正直。知密藏者佛性涅槃菩提答法是其密藏。因经证会故曰能知。是为总结

下广释之。解初门中先问次释。释中先举所闻法体。非有无下就法广明不闻闻义。前中初言谓深密藏总以标举。下别显之。先举佛性。次明三宝。佛等无别明三体同。三宝常等明三义门。此即菩提。下障涅槃。诸佛毕竟不涅槃者不入灰尽灭身涅槃。常不变者住大涅槃不变易也

下就前法明不闻闻。但就涅槃。余类可知。文中有三。一明涅槃妙离众相。凡时不闻。得圣乃闻。二明一切外道法中所未曾闻今时得闻。三明一切小乘法中所未曾闻今乃得闻。初中先明涅槃之法离相难闻。如来涅槃非有无者佛大涅槃非有生死非无众德。非有为者无生住灭。非无为者妙用繁与。非有漏者结患斯亡。非无漏者现起诸结。言非色者离无常色。非非色者得金刚身。言非名者言语道断。非非名者德响遐布。言非相者断离十相。非非相者具足相好。复随众生现种种形名非非相。言非有者妙出三有。非非有者实德不无。言非物者无有窟宅。非非物者有妙净土。非因果者苦集永亡。又复如来实证平等故无因果。言非待者实证亡对。非非待者藉缘方语。言非明者缘观心息。言非闇者昏障永除。言非出者不舍世间。非非出者得大涅槃。言非常者随化流转。非不常者体恒不变。言非断者常行有漏。非不断者永断诸结。言非始者性出自古。言非终者无有终尽。非过去等体出三世。非阴入界十二因缘体绝命相。非不阴等随化现有。下总结之。如是等法昔所不闻而今得闻。第二番中先明不闻。所谓一切外道经书总以标举。次别举之。四毗陀等是其别也。外国有其四大论师。一婆耶婆造四毗陀论。亦名违陀。本是一名。传之音异。此翻名智。能生智故。一亿力毗陀。明其事大忏悔之法。二耶受毗陀。明其布施祠祀之法。三阿他毗陀。又亦名为阿闼婆毗陀。本是一名。传之音异。明其一切斗战　法。四三摩毗陀。明知异国斗诤之法。知此生智故名知论。第二论师名婆尼尼。造毗伽罗论。此名记论。辨明一切音声名字章句等法。第三论师名迦毗罗。是黄显仙。造僧佉经。此名五顶。明从冥性生于二十五谛之义。如下文说。第四论师名优楼佉。是青目仙。造卫世师经。此名最胜。明六谛义。主谛依谛总谛别谛作谛无障谛是其六也。此等诸论今具列之。一切咒等通举余法。下总结之。如是等经初未曾闻。今于此经而得闻知

第三番中明余小乘。十一部中亦无如是涅槃深义。今因此经而得闻知。是名下结

闻已益中先牒。次释。有十复次。前九明其起因之益。后一彰其趣果之益。因中前八自利之益。后一利他。自中初四闻经之益。后四彰其思义之益。闻经益中初一复次法说明益。后三喻显。皆先立喻。后合可知。第三喻中放千光者盖且言耳

思义益中前三复次明知理法。后一知行。就知理中初知真谛。听经知名举劣显胜。若能书等辨胜过劣。次知世谛。听受知名举劣显胜。若能书等辨胜过劣。下知一实。听经未见举劣显胜。书写读等辨胜过劣

知行法中初就檀行举劣显胜辨胜过劣。后显余行。上来自利。下明利他。于中明具四无碍慧利他行也。但明闻益。略不说思。若听是经知法知义具二无碍内备化德。于诸沙门婆罗门下具辞具乐化他用也。前明起因。不从他闻知近菩提趣果益也。寻经悟解故不从他而能自知。是名下结。能断疑中初牒次释。有七复次。第一断除名义中疑。第二断除佛果上疑。第三断除三乘中疑。第四断除法相中疑。第五断除情计中疑。第六断除佛生上疑。第七断除世事中疑。七中初三闻思共断。后四单说闻经断疑。就初门中先举二疑。次列。后断。闻断疑名。思断疑义。第二门中先举五疑。次列。后断。闻断第一彼疑应故。思断后四彼疑真故。第三门中先举三疑。次列。后断。闻经断疑三乘之相。思义断疑三乘之性。第四门中不闻是经其心多疑总举所断。次别显之。句别十六。相从为九。初有四句合为第一。生死涅槃法相中疑。次有两句合为第二众生中疑。若命非命疑诸众生命根有无。若生非生疑彼假人有之与无。若竟不竟为第三门三乘中疑。大乘毕竟小乘不竟。若他若过为第四门三世中疑。他世未来。疑于未来有报无报。疑于过去有因无因。若有若无为第五门有无中疑。有无合通不可备论。若苦已下有其四句合为第六四谛中疑。若法非法为第七门邪正中疑。若善非善是第八门行业中疑。若空非空为第九门二谛中疑。下明此疑闻经悉断。第五门中不闻多疑总举所断。次别显之。于中有五。一于五阴疑或不知何者是我。二六根对我疑惑不知何谁能见乃至能知。三五阴对我疑惑不知何谁受报。四五阴对我疑惑不知谁至后世。五于生死疑惑不知为有始终为无始终。下明此疑听经悉断。第六门中先举一疑。疑阐提等佛性有无。下明闻断。第七门中先举疑心。谓疑世间边无边等。下明闻断。是名下结

惠心直中先牒次释。释中有三。一乘前显过。明有疑者所见不正。二一切凡下就人辨曲。谓凡二乘。三云何下广辨曲相翻之显正。于中有四。一明凡邪曲。二翻之显正。三明声闻缘觉邪曲。四翻之显正。凡夫曲中先问后辨。于有漏中见常乐等于如来所见无常等八倒邪曲。见众生等我见邪曲。计非想处以为涅槃见自在天有八圣道见取邪曲。此皆取劣以为胜故。又此非道以为道故。亦得名为戒取邪曲。有见断见边见耶曲。第二段中若闻是经闻慧断曲。修行圣行修恶断曲。第三段中先问后辨。执佛八相成道为实是其曲也。第四段中听经悉断闻慧断曲。若能书等。思慧断曲。修行涅槃修慧断曲。是名下结

知密藏中初牒次释。释中有二。一知涅槃佛性菩提三种真法为知密藏。二复次下明知世法因缘之理为知密藏。于中初问次辨后结。辨中六句。虽知无我不失业果明非无果。虽知阴灭善恶不亡明非无因。此二一对。虽有诸业不得作者无造业人。虽有至处无有去者无受报人。此二一对。虽有系缚无受缚者无被缚人。虽有涅槃亦无灭者无得脱人。此二一对。以此所知非定有无妙离断常故名甚深

上来广释

自下第四有难解者问答重显。于中但显

闻不闻义。以前所说不闻乖闻闻乖不闻故。须重释。余者可解故不重论。就此文中对人有三。显义亦三。文别有四。对人三者。一对德王。二对琉璃。三对无畏。显义三者。第一正辨闻不闻义。二为化益新来菩萨明生不生。三为起发此土众生往生净国辨明往生净土之义。文别四者。一德王为闻如来赞叹。二琉璃为问如来辨释。三无畏启请如来为说。四偈后长行。因无畏请远答德王最初所问。前中德王初先为问。后佛赞叹。问中如我解佛所说是义不然牒以总非。下广显非。先征后难。于中有二。一正难破不闻闻义。二凡是色下彰实异相明不可闻。前中六句。初二一对约法有无征定所说明闻不闻不得并立。次二一对约就能闻所闻之法亦为征责明闻不闻不得并立。后二一对就时征责明闻不闻不得并立。初中有四。一就法征定明有与无不得并立。法若有者便应定有立有非无。法若无者便应定无立无非有。由佛前说涅槃之法非有非无故为此征。二无不应下以法有无类定生灭明不并立。无不应生立灭非生。有不应灭存生破灭。三如其下以前生灭两义不俱类闻不闻不

并立。如其闻者是则为闻以生类闻明唯是闻不得不闻。若不闻者则为不闻以前灭义类显不闻唯定不闻不得为闻。四云何言下结非圣说。闻与不闻既非并立。云何圣言闻所不闻

第二对中初就法正征。次喻。后合。法中约就能闻所闻互以为难。若不可闻是为不闻就所设难。若彼涅槃佛性等法定不可闻。是则一向名为不闻。不得名为不闻而闻。若已闻者则更不闻就能设难。若能闻心已得闻竟。则更不得闻于不闻。若从是义。正得一向说之为闻。不得宣说闻于不闻。何以下释。初先征责。何故闻已则更不得闻于不闻。下对显之。已得闻故正得名为闻于可闻。不得名为闻于不闻。云何言下总以结呵。喻中生到反得三事共显一义。亦可去到喻闻涅槃。生与不生喻显佛性。得与不得喻显菩提。就初喻中将去喻闻。到喻不闻。譬如去者喻能闻人。到则不去类显初句。如彼世人已得到者不可言去。所况如是。诸佛菩萨已得涅槃。不闻法竟不得言闻。去则不到类显后句。如彼世人在路去时不得名到。所况如是。已得闻者则更不得闻于不闻。第二喻中将生喻闻。不生喻于不闻之义。生已不生类显后句。如彼生相生诸法时不得说言生于不生。所况如是。已得闻时不得宣说闻于不闻。不生不生类向前句。如彼虚空不可生故正名不生不得言生。所况即是。不可闻法正名不闻不得言闻。第三喻中将得喻闻。不得喻于不闻之义。得已不得类向后句。如彼十四不相应中有一非色非心之得能得诸法。今取为喻。即彼诸得得诸法时不得名为得于不得。所况如是。已得闻持不得说为闻于不闻。不得不得类显前句。如兔角等不可得法正名不得。不可说之为不得得。所况如是。不可闻法正名不闻。不得说之为不闻闻。上来立喻。闻已不闻不闻不闻亦复如是合之显法。闻已不得举向后句以合前喻。不闻不闻举上初句以合前喻。第三对中初句就其未闻之时难破有闻。明其唯是不闻不闻非不闻闻。后句就其不闻之时难破不闻彰先有闻。先有闻　后得圣时闻于可闻非闻不闻。前中世尊若不闻闻者审定如来未闻之时已有闻性名不闻闻。下就设难。难有三阶。一就地前凡夫设难。若未闻时已有闻者。一切众生未有菩提即应有之。未得涅槃亦应得之。未见佛性亦应见之。二就十住菩萨设难。若未闻时已有闻者。云何说言十住菩萨虽见佛性未得明了。三就佛设难。若未闻时已有闻者。如来本昔从谁得闻。若有闻处何故如来于阿含中说言无师。后中初言若不闻不闻审定如来未闻之时令无闻性名不闻不闻。下就设难。难意如何。若佛如来本未闻时一向无闻。后得菩提及见佛性。一切众生未闻之时亦无有闻。亦应同佛得成菩提见于佛性。一切众生不得菩提不见佛性。可得宣说本无有闻。佛得菩提见佛性故明本有闻。本有闻故佛令闻时闻于先闻。非闻不闻

涅槃义记卷第六应永三岁五月二十日加修补书入关字了　　　　　　　　　法印权大僧都贤宝涅槃义记卷第七

        隋净影寺沙门释慧远述

上来难破闻不闻义。自下第二辩实异相明不可闻。然今且就涅槃一法明不可闻。余类可知。于中有二。一明涅槃不同色声故不可闻。二明涅槃非三世摄故不可闻。前中两句。一举粗显细明色与声可得见闻。凡是色法或是可见不可见者。色有三种。一可见有对谓眼所行。二不可见有对谓耳鼻舌身所对之色。三不可见无对谓法尘中无作之色。此三种中初一可见余不可见是以言惑。又色尘中现在可见过未叵见亦得言惑。声亦如是。惑是可闻不可闻者现在可闻过未叵闻。二辨细异粗明大涅槃不同色声。云何而言可得见闻

后中亦二。一就三世音声推求。明其不得闻于涅槃。过去已灭不可闻者过声已灭不可寻之闻于涅槃。未来求至亦不闻者未来音声以未至故不可寻之闻于涅槃。现在听时不名闻者当现听时耳但闻声未得寻声取彼涅槃。是故听时亦不得名闻于涅槃。闻已声灭更不闻者听竟声灭更无取寻。故亦不得闻于涅槃。二就涅槃法体推求明三世故不可闻涅槃。亦非过去现未。正明涅槃体非三世。若非三下明叵说闻。云何言下结非圣说

上来第一德王为难。下佛叹之。善哉总叹。汝今下别。别中有二。一叹其所解。二叹其所同。解中汝知一切诸法如幻炎等叹其解空。画水迹等叹解无常。如泡沫等叹解无我。无苦乐等叹其解苦。无乐苦相无苦苦实。故经说言五阴洞达空无所起是苦义矣。问曰。德王上来难佛闻不闻义。如来何故叹知幻等。以前德王知法虚幻无常生灭三世推求都无闻义。故为此叹。次叹所同明如十地之所知见。德王自位在于何处如十地乎。下说德王久已成就菩提功德化无量生令住菩提。初地已上皆名成就菩提功德。然今德王或可是佛示居学地或在学穷。所解同余十住菩萨故言如也。如经叹佛如三世佛所说不变。此亦似彼。如来是中何故不答。有言客至无客不答。圣化容豫岂有此妨。但佛巧化为留此答兼益新来诸菩萨等故此不答

自下第二琉璃为问如来酬答。于中有六。一琉璃将来先现光相。二辨光所从。三琉璃身至设供奉佛。四问答拂遣来去之相。五问答辨法。六琉璃闻法欢喜领解。文别可知。圣化有由故先现相。相有所从故次辨之。现相须应故次身来。来相覆真故次拂遣。来为显法故次辨法。得法称心故须领解

先辨光相。时大众中明现光处。忽然之顷明现光时。有大光明正明现光。非青色下显其光相。琉璃菩萨从于平等实证身中放阿含光令人睹见。是故大众非青见青乃至非见而得见也。大众过光身心快乐明光利益。先法后喻。问曰。何故无边放光令此众怖。琉璃放光令此众乐。盖随化宜不同故尔。云何不同。无边将来为表圣灭。欲使此众觉世不安故令众怖。今此琉璃所放光者为欲显法令众证入。胜益将至故使众乐

自下第二辨光所从。文别有二。一明此光从其平等实证中发。二就其化相明从东方琉璃边来。前中初先寄默彰寂。尔时世尊问文殊下以言显实。前寄默中初文殊问佛默不答。光来之处寂灭离言故默显之。佛证穷深故先默显。文殊从佛悟解寂义。故次第二迦叶转问文殊不答。迦叶复从文殊悟解。故次第三无边转问迦叶不答。无边复从迦叶悟解。故次第四净住王问无边不答。众圣同证。是故乃至五百相问皆默不答。以言显中如来先问。文殊下以七句广辨。前之六句就实显实明无因缘。后之一句约相显实明有因缘。因灭无明得菩提灯故有此光

上来显实。下就化辨。于中如来初先教说莫入第一。应以世谛而解说之。文殊下辨。于中有三。一此彰彼事。二彼彰此事。三结答如来。此彰彼中文别有四。一彰彼国土人民之事。二彰彼化主。三随所住下彰彼所说共此不殊。四琉璃光问满月光下彰彼所问与此不异

彼彰此中文别有五。一满月光佛彰此世界人民之事。二彰此化主。三大悲纯下彰此所说共彼不殊。四彼有菩萨名光明下彰此所问与彼不异。五佛今答下彼劝琉璃令来至此。问曰。何故不此劝向彼。解有五义。一彼土众生于此佛所有宿因缘故劝来此。此众于彼未必有缘故不劝往。二此土众生宜见彼来请法获益故劝来此。彼众于此未必有宜故不劝往。三欲令彼诸菩萨来导引此众往生净土化益弘多故劝来此。此众若往无如是利故不劝往。四欲令彼新行菩萨来此恶界增长悲愿故劝来此。此众若往无如是利故不劝往。五德王于彼若有化益佛亦劝往。非起此说故不论之

彼琉璃下是第三段文殊举彼琉璃将来结答如来。此第二竟。第三大段琉璃来至供佛可知

自下第四问答拂遣来去之相。佛先试问。为到者来不到者来。琉璃下答。初先就身以明无来。次就法辨。后就心显明诸过尽故无有来。初中世尊到亦不来不到亦不来者解有二义。一就应身无常以释。应身达此名之为到。在路灭者名为不到。论其到者此处新生不从彼来故不名来。其不到者在路即灭不来至此故亦不来。二就真身常义以释。向来应身到与不到于真常寂由来不动故并不来。我观此义都无有来总以结之。到与不到二俱无来故曰都无。次就法辨。诸行若常亦不来者同向后解。若是无常亦无来者如向前释。此名五阴以为诸行。下就心显。句别有八。前三远离凡夫之过故无去来。初离我见。次离憍慢。后离取行。或见二取名为取行。后五远离二乘之过。初二后一迷大之过。中间二句执小之过

自下第五问答辨法。于中有二。一欲问求听如来听许。二琉璃正问如来为辨。前中初先琉璃欲问请佛求听。且置斯事息止前言不来去之义。且说叵尽故言且置。欲有所问自宣己心。唯垂哀等请佛听许。下佛听之。随意问者正听其问。今正是时催令速问。我当已下许说于后。所以下释。所以我言今正是时以佛难值法难闻故。诸佛难值如优昙华佛难值也。法亦如是难可闻等法难闻也。于中先明小法难闻。难闻如佛是以言亦。十二部中方等复难明大难闻。是故已下结劝专听

琉璃正问如来答中文别有二。一琉璃自为问闻不闻如来为解。二琉璃为他问生不生如来为释。此云何知。下文自辨。故下琉璃领解之中云我蒙佛解闻不闻。故闻不闻偏是自为。亦令八万四千菩萨知生不生。明生不生偏是为他。问曰。何故闻与不闻偏是自为。生与不生偏是为他。以闻不闻就真分别其义渊深故偏自为。彼生不生辨其世谛因缘法相其义粗近故偏为他。理实所问无不为他。为分自利利他行异故为此别。问曰。等为差别两行。以何义故不先为他。解有三义。一起行次第。要先自行方能利他故先自为。二闻不闻琉璃菩萨本国先问。今乘彼请是以先问。三闻不闻是初德体乘。上所辨是故先问。问曰。若言起行次第要先自为。何故如来下诫琉璃先为他人后为自身。释言。生心起行各异。若论生心要先为他。一切所行悲为本故。若论起行要先自行后方益他。下就起心。此就起行。故别不同

就初段中琉璃先请。既蒙听许兼被诫敕经家序列。如来前言随意所问是蒙听也。是故应当专心能受是诫敕也。即白云何闻所不闻正是请辞佛答有四。一赞其善问明已能答。二敕听许说。三教示听义。四随问正解。初中善哉是叹辞也。汝今欲等明已能答。于中六句。前四明已有其说能。次一有心。后一有法。就前四中汝欲尽海举其所求。正值已下明已能说。汝有疑镞举其所患。我为医等明已能治。汝于佛等举其所迷。我有慧等明已能示。汝欲渡等举其所出。我能为等明已能运。明有心中。汝于我等举彼亲爱。我于汝等显已慈怜。明有法中。汝贪法宝举其所须。值我有等。明已能施

第二敕中先敕次许后教善听严励其心

第三教中先别后结。别中有其二十一句。相从为三。初有八句教离凡心。次七教舍二乘之心。后六教修菩萨之心

教离凡中初闻法敬信教离疑谤。二至心听受教离宽怠。三恭敬尊重教离轻末。四于正法下教离憎恶。五莫念贪下教离垢心。六莫观下教离嫌心。七既闻法下教离慢心。八莫为已下教离妄想异求之心

次七教离二乘心中。初四教离二乘狭心。亦莫生念我听法已先自度身然后度人苦中狭也。前教离凡兼劝舍小故云亦莫。先自解身然后解人集中狭也。先自安身然后安人道中狭也。先自涅槃后令他人灭中狭也。后三教离二乘小心。于佛法僧应生等想教舍别心。于生死中生大苦想教舍着心。变易生死实是大苦。莫谓为乐于中乐着。于大涅槃应生常等教离倒心

下六教修菩萨心中。初先为他教修广心。亦名教修念众生心。当为大乘莫为二乘教修大心。亦名教修求佛智心。后之四句教修深心。亦名教修离有为心。于中初二教离见心。于一切法当无所住不住无也。亦莫专执一切法相不执有也。于法莫贪教离爱心。常生知法见法之心教离痴心。若能如是名闻不闻总结彰益

自下第四随问正解。初先解释闻不闻义。后以生列类以显之。前中四句。有何差别。准下释之法有二种。一是生死可闻之法。二是涅槃离闻之法。人亦有二。一凡二圣。将凡将圣对彼涅槃为前两句。圣于涅槃不闻之法堪能听受名不闻闻。凡于涅槃不闻之法不能听受名不闻不闻。将凡将圣。对彼生死为后两句。圣于生死可闻之法不复餐受名闻不闻。凡于生死可闻之法餐受不息故曰闻闻。四中初句正答前问。举凡显圣故有第二。举染显净故有第三及与第四

就后类中先生后到各有四句。下文自释

自下第二琉璃自前问生不生令佛解释。使彼新来菩萨解知。其到不到。下答德王初问之中佛自广释今此不论。文中有四。一问二答三难四通。世尊云何不生生者是初问也。向前四句理应齐问。就始言耳

第二答中先就内论。后就外辩。众生是内非情为外。内中先释。后总结之。释中初言安住世谛初出胎时名不生生解上初句。在世谛者方乃受生故说住世。又世谛中受身不坏亦名住世。初出胎时正解生义。初则简后。出胎异前。是名下结。本未生时名为不生。出时名生。前后合说名不生生。云何不生不生问第二句。是大涅槃无生相者涅槃体寂是一不生。而复不为生相所生是二不生。是名下结。是中不欲明涅槃法。约涅槃法明生死身不生不生。要得涅槃方乃得为不生不生。故就论之。云何生不生问第三句。世谛死时释显其相。此名现报以为世谛。世谛是生死名不生。是名下结。云何生生问第四句。下释有四。一就人总指。一切凡夫名为生生。良以圣人生不相续故指凡夫。二何以下释。先问次解。生生不断就分段无常解生生义。一切有漏念念生者就念无常解生生义。是名下结。三从四住菩萨已下举圣显凡。四住菩萨名生不生故凡名生生。炎地菩萨名为四住。地相入之中三地已还名为世间。四地已上名为出世。四住菩萨舍彼世间证入出世无生行慧名生不生。四何以下释彼四住生不生义。先问次解。以彼于生除断自在。故本生者今更不生。是名下结。是名内法。后就外法中先问起发。云何外法未生生者问上初句。不生不生问第二句。生不生者问第三句。言生生者问第四句。后释其相。解初问中如种未生解未生义。得四大等解其生义。是名下结。解第二中先问次解。譬如败种解前未生。及未遇缘解后未生。如是等辈举此类余。名未下结。解第三中先问次解。如牙生已解初生义。不增长者解后未生。是名下结。释第四句中先问次解。如牙增长正解生生。若生不生则无增长举生不生显前生生。义与上相似。如是一切举此类余。是名下结。问曰。何故就内外事明此四义。为彰诸法义无偏定无偏定故一切可空

琉璃白下第三设难。难有六句。初二难上一切有漏念念有生。前有何隐而须难乎。解言前说有漏法体念念有生。法外生相前犹未辨。故此难之令佛解释。后四难上不生生等四句之义。前何不尽而复重难。前就内外粗事以释。未将生相对法而辩。故此重难令佛辩之

前中初言有漏之法若有生者就前有漏牒举生相。此乃举彼法外生相非法体生欲就设难所以举之。为常无常进退审定。下就设难。五句分别。一定法体。色心及与非色非心是有漏法。二约前法辩四相义。四相有二。一法体四相。色心等法念念之间各有四相。初生次住终异后灭。二法外四相。色等法边同时别有生等四相。总相论四。细分有八。谓四大相及四随相。亦名小相。彼大生边有一小生。乃至灭边有一小灭。以前四种相法宽多故名为大。后之四种相用狭少名为小。此八相从说以为四。此之四相就能为名。所言生者能生他故名之为生。非是住前始起之生。乃至灭相能灭他故名之为灭。非是异后尽坏之灭。克论体性此八皆有。初生次住终异后灭。四相如是。今此偏就法外四相以论生义。三就生相明常无常当知此生亦常无常。如下文说。于事分齐色等法边恒有此生故名为常。于法分齐此之生相运运起尽一谢往者更不重现故曰无常。四显难意。琉璃今者次使如来就生解释常无常有无之义。令彼新来菩萨解知故反难之。五随文解释。先难常义。生若是常举前所定。有漏之法则无有生约法难破。有漏无常。无常法边云何得有常住之生。有漏边有明知无常。下难无常。生若无常牒前所定。一起谢往更不重来故曰无常。则有漏是常约法难破。生若无常一起谢往更不重来。有漏法边便无有生。无生迁改为是应常。然有漏法性是无常恒有生相随而迁改。明知生相非是无常

后四难中。第一难上生生之义。第二难上生不生义。第三难上不生生义。第四难上不生不生义。此将生相对法为难。以何义故不依前次。良以初二自他相对。后二幼时有无相对。随此便故不依前次

就前二中初句偏就能生设难。后句约对所生设难。初难云何。若彼生相还能自生可名生生。生不自生云何得名为生生乎。难意如是。然彼生相但能生于色心等法不能自生故今反举。若生自生生无自性以理难破。若有自性可以生起故可白生。生无自性云何自生。问曰。前说色等法边别有非色非心生相。今云何言生无自性。解云此相判为能生。能生之外更无所生法之自性故日无也。第二云何。若彼生相能得生他非生之法。如来可说为生不生。不能生他非生之法。云何得名为生不生。难意如是。然彼生相但能生于自家共起可生之法。不能生他无为无漏不可生法。故今反举。若能生他以何因缘不生无漏以理难破。若能生他以何因缘不生无为无漏之法。不能生故非生不生

就后二中初句约就未生之时难破有生。后句约就未生之时难破无生。初句云何。若未生时已有其生。如来可就说不生生。未生之时不得有生。如来云何说不生生。难意如是。然色等法起时名生。未起之时不得名生。故今反举。未生有生云何于今乃名为生以理难破。未生之时已先有生。云何于今现起之时方名为生。后句云何。若未生时全无生性。如来可说不生不生。未生之时已有生性。云何佛说不生不生。难意如是。然有为法先未生时虽无生事已有生性。故今反举。未生无生何故不说虚空为生以理难破。若有为法本无生性后得生者。虚空本来亦无生性何故不生。虚空不生。可先无生有为可生明本有生。本有生故非不生不生

自下第四如来释通。善哉叹问。下正辩释。文别有四。一牒前六难明不可说遣人定执。二有因缘下明前可说令人求解。三从云何不生生下释前第一不可说义。四云何有因亦可说下释前第二可说之义

就初段中言不生生不可说者牒前琉璃第五所难明不可说。道言生生不可说者牒前琉璃第三所难明不可说。言生不生不可说者牒前琉璃第四所难明不可说。不生不生不可说者牒上琉璃第六所难明不可说。生不可说者明前琉璃第一所难常有之生不可定说。言不生不可说者明前琉璃第二所难生相灭后有漏法边一向无生不可定说。此等皆悉不可定说名不可说非全不说。问曰。何故明此六句皆不可说。为显诸法义无偏定。不偏定故六义并具。是义云何。以不生生不可定故有生生义。是义云何。下以后生破初不生。明有为法未生之时有可生性。不可定说以为不生。非不生故将彼生相生如是等可生法时。即得名为生于可生。是故得有生生之义。以彼生生不可定故有生不生义。是义云何。下约初生破却后生。明有为法为他生相之所生故名之为生。体性非生体非生故将彼生相生此法时即得名为生于不生。是故得有生不生义。以生不生不可说故有生生义及不生不生义。是义云何。下以初生破后不生。明有为法与他生相之所生故体非不生。非不生故将彼生相生此法时即名生生。是故得有生生之义。下文复以后句不生破却初生。明初生相能生色等非生法故名之为生。体性非生。能生所生性皆非生即得名为不生不生。是故得有不生不生义。以不生不生不可说故有不生生义。是义云何。下说涅槃不生之法亦有生故。不生之法得有生义。涅槃既然余法类尔。是故得有不生生义。复以生义不偏定故有不生义。不生不定故有生义。问曰。何故立此六义。为明诸法义不偏定。以不定故一切可空

第二段中有因缘故亦可说者明从因缘六皆可说。是义云何。法外生相能生色等可生之法是故得有生生之义。即彼色等体非生相名为不生。法外生相生此色等非生之法名生不生。于未生时已有生性是故得有不生生义。于未生时未有生事故有不生不生之义。于事分齐色等法边恒有生相故有生义。于法分齐运运起尽一谢往者更无来理是故得有无生之义

第三段中依前六句次第释之。云何不生生不可说者牒问初句。下释其相。偏以后生破初不生成不可说。言不生者牒初不生。名为生者是后生也。不生之时有可生义。云何可得定说不生。下重显之。何故问也。以生故者以可生故不可一向定说不生

云何生生不可说者牒问第二。下释其相。以前生相破后法生成不可说。生生故生明前起后。初一生字牒举生相。次言生者明前生相能生诸法。言故生者彰彼诸法由相生故方始得生。生生故不生以前破后。有为诸法由彼相生方得生故无定生性故言不生。不可说者以不生故不可说生。亦可前后二生俱破。生生故生破前生也。前一相生。生诸法故说之为生。自体非生。非生故不生破后生也。后一法生。为他生故说之为生。自体非生。不可说者前后二生皆不可说。云何生不生不可说者牒问第三。生即名生以前破后。良以生者即名生故非定不生。生不自生以后破前。向前生相但能生他故名为生。自体非生。体非生故名为不生。以不生故不可定说以之为生。不可说者生与不生皆悉不定故不可说

云何不生不生不可说者牒问第四。言不生者名为涅槃。辩前不生涅槃常寂故曰不生。涅槃不生故不可说。释后不生不可说也。涅槃从缘有可生故不可定说为以不生。何以下释。从修证得义说为生。非是办无令有名生。是中不欲明涅槃生。举彼涅槃不生之法有可生义。类显世间不生之法有生义矣。生不可说牒问第五。以生无者生相无常。一灭去者更不重来故曰生无。是故不可定说为生。云何不生不可说者牒问第六。以有得者随事恒有。生相可得是故不可定说不生

第四段中云何有缘亦可说者牒问前门。下对释之。十因缘法为生作因。以是义故亦可得说是总释也。十二缘中前十因缘与第十一生支作因故得说生。亦可名彼持地论中所说十因以之为十。此能遍与诸法作因故得说生。下别释之。先教听仪莫入空定大众钝故。下正为解。前六难中但解初二及释第四。余略不论。解初二中因论生相剩辨余三。文中先别。后总显之。别中初先泛辨四相常无常义。然后释文。就事分齐四相名常。恒与色等诸法俱故。于法分齐四俱无常。四相相催无停住故。是义云何。如上所辨四相细分差别有八。此八同时互相催切。大生力故除其自体令余七相及所随法一时俱生。小生力故令大生生。大住力故除其自体令余七相及所随法一时俱住。小住力故令大住住。乃至第四大灭力故除其自体令余七相及所随法一时俱灭。小灭力故令大灭灭。是故诸相及彼法体皆有初生次住终异后灭之义故是无常。次释其文。先解生相有为之法生亦常者法边恒有以住无常。生无常者住虽恒有为用暂尔名住无常。由此迁生故生无常。生之无常具由四相住用近生是故偏说。住亦常者法边恒有以生无常。住无常者生虽恒有用亦暂尔名生无常。由斯迁住故住无常。住之无常亦由诸相生用近住故偏说之。下异与坏义类可知。上来别解。下总释之。言以性故生住异坏皆是常者随事分齐各自守性恒有为常。念念灭故不说常者于法分齐运运迁灭故是无常。理实念念亦生住异。据终说灭。是大涅槃能断灭故名无常者治灭无常

有漏法下释上文中第四难也。向前难言若能生他以何因缘不生无漏。故今释之。有漏之法未生之时已有生性故生能生。无为无漏本无生性是故生相不能得生。文中初法。后举三喻类以显之。问曰。何故不释余难解此难竟即知生相生有漏法非是自生。故第三难不劳更释。又此文中说有漏法未生之时已有生性。第五第六未生之时有生无生。其难已遣故更不论

上来第五问答辩法。自下第六琉璃领解。先踊在空七多罗树。下正领解。我蒙教诲因大涅槃解闻不闻自身领解。领佛向前教已听仪名蒙如来殷勤教诲。领佛向前解闻不闻名因涅槃解闻不闻。亦令八万四千菩萨解生不生代众领解。准此定知闻与不闻为已故问。生与不生为他故问。此二是前知密藏中两种义也

自下第三无畏请问生净土义如来为辩。文别有四。一琉璃菩萨结前举后以为起发。我今已解是结前也。无畏欲咨唯垂听许是举后也。二如来听许。三无畏正问。先起后问。问有四句。初造何业生不动界问其下人所修福因。二其土菩萨云何而得智慧成等问下品人所修智因。此往生者即名以为其土菩萨。三人中下问上品人所修福因。此文略少。若具应言此造何业生彼得为人中象王有大威德具修诸行。四利智下问其上人所修智因。此文亦略。若具应言此造何业生彼国土利智捷疾闻则能解。上来第三无畏正问

四如来为辩。于中文有二十一偈。初十二偈答上初问明下品人所修福因。次有两偈答上第二问明下品人所修智因。次有五偈答前第三明上品人所修福因。末后两偈答前第四明上品人所修智因。就初段中前之十偈明离恶行。谓离十恶。偈别论一。文显可知。问曰此十应是上业何故名下。为世修习故不名上。回求净土故得往生。后之两偈明作善行。第二段中初偈明为悕利世福书写是经以为智因。后偈明为悕利世福读诵是经以为智因。为世修习所以非上。回之求去故得往生。第三段中初之两偈明修戒行以为福因。于中前偈自身无犯。后偈明其能治他过。后之三偈明修施行以为福因。第四段中初偈明其供养说者以为智因。后偈明其自身书写受持读诵以为智因

自下第四远答德王最初所问。无畏初先领前举上请佛酬答。我今已知造业得生是领前也。光明遍照普为怜等是举上也。如来若等是请答也。下佛答之。先赞德王敕听许说。有因缘下正为宣说。于中先举到不到等类答前问。闻所不闻亦如是下当问正答。问曰。何不望直正答在先类乎。释言如来兼欲使人解知向前到不到义故先类之。于中初先开列四门。四中前二对彼涅槃不到之法明凡未到圣人已到。后二约对生死恶法明圣不到凡夫人到。下广释之。何因缘故未到不到牒问初门。夫不到者是大涅槃解后不到。凡夫未下释初未到。凡夫未到总以标举。以有贪下别以显之。以有贪等有惑不到。身业已下恶业不到。以是下结。何因缘故不到到者牒问第二。言不到者名大涅槃解初不到。何义到下解释后到。永断贪等无惑故到。永断身等离业故到。以是下结。须陀洹下就人辨之。何因缘故名到不到牒问第三。到者名为二十五有释初到义。次别显之。是名下结。声闻已下解后不到。于中先明自行不到。为化度下明诸菩萨下化众生示现处中亦名为到。何因缘故名到到者牒问第四。到者即是二十五有解初到义。一切凡下解释后到也

下正答之。闻所不闻亦复如是者总举类前。次列四名。义如上解。问曰。此四云何答上德王六难。释言德王难别三对。一一对中义皆有四。两立两破。一立闻闻。二即约此难破如来闻不闻义。三立不闻不闻。四即约此难破如来不闻闻义。佛今随其所立所破并为存之。故列四门以答上难。云何下释。但释初门。余三类上到不到等其义可知。故略不论。于中有三。一就涅槃解不闻闻。二云何菩萨不闻闻下就彼三宝佛性等义解不闻闻。三如佛先说修大涅槃闻不闻中有涅槃下于前义中有难解者问答重明。初中复三。一正就涅槃解不闻闻。二德王白下问答重论。三德王白佛云何布施不得名为波罗蜜下于前第二重显义中有难解者问答重释

初中先问。次对释之。先解不闻名大涅槃出不闻体。何故已下释不闻义。先征后解。非有为者不同生死有为之法可以言论故不可闻。非音声者不同能诠音声性故不可得闻。不可说者不同名字可宣说故不可得闻。下释闻义。先征后解。以是下结

自下第二问答重显。德王先难。佛说涅槃不可得闻云何复言常乐我净而可得闻略征前言。何以故下广显不应。先自征责。我以何故呵佛不应。下对显非。难意有三。一明涅槃体是无常不应宣说有常可闻。二明涅槃有名可闻即是无常。三明是常无名可闻。难意如是

难辞有七。一明涅槃断烦恼得本无今有故是无常。二因庄严得故是无常。三有故无常。四以可见故是无常。五不平等故所以无常。六因恭敬得是以无常。七有名故当知无常。七中初六显初难意。末后一番显后二意

就初难中断烦恼者名得涅槃若未断者名为不得辩涅槃相。以是义下明此涅槃本无今有。若世间下彰其无常类以显之。初先泛举。譬如瓶下即事以显。涅槃若下约之征法。第二难中。初先泛明一切世法因庄严得悉名无常。次约显法。涅槃若尔应是无常。何等已下辨庄严相

第三难中。初先泛明一切有法悉皆无常。若涅槃下约之显法。如佛昔下引佛昔言明涅槃有。以是义下结成无常

第四难中。初先泛明可见之法悉是无常。如佛已下约之显法

第五难中句别有四。一立等喻。譬如虚空等无障碍故名为常。二约喻征法。若涅槃等何故众生有得不得责其不等。若不等下以其不等结成无常。三重立等喻。四约喻征法。若涅槃等一人得时多人应得一人断结多人亦断征令齐等。若不如是云何名常以其不等征破常义

第六难中。初先泛明因恭敬得悉是无常。次约显法。涅槃亦尔不名为常。何以故下广明涅槃因恭敬得。以是义下结成无常。第七难中。初先辩列有名无常。如其无下明常无名故不可说。云何已下结破可闻

下佛答之。前七难中但答五问。第五第七略而不答。答初难中答意如何。明诸众生因断烦恼始见涅槃。而彼涅槃本有非今故得为常。文中初法次喻后合。法中有四。一明涅槃本有非今。二明众生不见谓无。三明菩萨修道始见。四明虽始见法非今有。初中有二。一明涅槃体非本无。文有反顺。涅槃体非本无今有是其顺也。若涅槃体本无今有则非无漏常住之法是其反也。问曰。方便断结涅槃。本无今有岂非无漏。释言。此等实是方便断结无漏。但非自体本净无漏故云非也。二有佛下明其常有约佛显之。随相论之。有佛成道证会始有。无佛证会涅槃则无。实则涅槃古今不变故曰常住。此初段竟。后三可知。问曰。下说涅槃是其了因之果。能了之因既非本有。所了涅槃何容非始。解有三义。一就一人始终分别。涅槃既是了因之果。明在显时。果虽显时性是本有。今据果德反谈本性故言本有。二就凡佛二人分别。凡佛虽殊实性无二。以无二故众生佛性即是诸佛大涅槃果。何故如是。彼大涅槃众生迷覆未得显了。是故不得名涅槃果。然所迷法与后显时净德为本故名佛性。故下文言涅槃因者所谓佛性。即此佛性据佛望之由来清净无障无染。是故即名大涅槃果。故经说言一切众生毕竟寂灭即涅槃相不复更灭。良以于佛本来常净是涅槃故。今说非是本无今有。于凡未得是涅槃故。下文宣说了因所得。第三约缘就实分别。缘有染净。实则常湛。实从染缘说之为因。因在凡时。实从净缘说之为果。果在显时。废缘论实。实外无缘。知复约何说因说果。良以就实非因果故。今说涅槃本有非今随缘当显。故下宣说了因所得。上来法说。次以喻况。于中还四。先喻初段明大涅槃本有非今。闇室喻于众生之身。井及七宝喻涅槃法。人亦知者寄知显有。闇故不见喻前第二恼覆不见。有智人下喻上第三。是人于此终不念下喻上第四。合中亦四。涅槃亦尔本有非今合上初段。烦恼闇故众生不见合前第二。大智已下合上第三。是故已下合前第四

次答第二。先牒总非。何以下释。先征后解。解意如何。明诸众生因于庄严往见涅槃。非大涅槃假于庄严故得为常。文中有三。一明涅槃体绝众相。二以是义下结成常义。三见以无量阿僧祇下明诸众生因严乃见。初中涅槃非生出者涅槃无有始生终出。又非因生亦非缘出。非实虚者妙出情妄故曰非虚。虚既不有知复对何以说其实故曰非实。是以经言。其实见者尚不见实何况非实。又涅槃体不同妄情所取定实故曰非实。不同世俗虚假之相故曰非虚。非作生者如下文说。非作因起非生因生。非是有漏有为法者体性常净故非有漏。体无生灭名非有为。不同色声故非见闻。不可退散。故曰非堕。体无终尽所以非死。万义同体故非别异。义别千殊故曰非同。体无动转故非往还。体无流变非三世摄是故名为非去来今。义别尘算所以非一。体如一味所以非多。不同质像故非长短方圆尖斜。不同所取故言非相。不同能取故曰非想。不同四阴故曰非名。不同色阴故名非色。不作生因生于他法故曰非因。不从他生是以非果。以非神生故言非我。非我所有名非我所。后二可知譬如盲下答第四难。明虽始见见于本有故非无常。于中两喻二合可知

汝言因下答第六难。先牒总非。何以下释。先征后解。解意如何。明大涅槃非五因成。从了因显所以是常。于中初明非五因成。先举五因。次列后释。下明涅槃非作因生是了因显。先举二因。次列。后释。下持涅槃对因辩之。于中先明涅槃之法非作因生唯了因显。次出了因所谓三十七道品法六波罗蜜。下复约对涅槃大小明因不同。布施持戒乃至波若是涅槃因。不得名为大涅槃因。六波罗蜜乃得名为大涅槃因。道品亦尔。三十七品是涅槃因。无量僧祇助菩提法方得名为大涅槃因。此等差别下文自释。问曰。向前第五句难何故不答。如来解前第一难中明诸众生闇故不见修故始见。众生虽有见与不见涅槃恒有故得名常。彼难即遣所以不释。又问向前第七句难何故不解。下文宣说涅槃无名强与立名。此难即遣为是不释

自下第三重辩向前布施等行是波罗蜜非波罗蜜。并复显其涅槃大小。德王先问。佛答有二。一教修正解令其自知。二云何施下随问为释。前中有三。一教舍着心。于施等法不见不闻。二教修生解心。解知二谛。三由前二自知檀等。初段可知。第二段中解法唯二一知世谛。二知真谛。文别有三。一略开二门。知见法界是第一门明知真谛。界名为性。悟解法性名知法界。解了实相是第二门明知世谛知法虚幻是其世谛。诸法之实名解实相。二广辩释。先解初门。句别有二。一明所知。知二无我空无所有是法无我。无有和合觉知之相是人无我。二明所离。得无漏相无所作相。不着檀等名无漏相。不见檀等可以作起名无作相。如幻已下解释后门。句别有二。一明所知。知法如幻乃至空虚。先别后结。二明所离。无贪嗔痴不闻不见。解法虚妄灭诸法故无贪嗔痴。于彼檀等心无分别名不见闻。上来释竟。三双结之。是名真实结前真谛。安住实相结后世谛。顺观名安。上来第二教生解心。自下第三明由前二便能自知是波罗蜜非波罗蜜。乃至能知涅槃大小

上来第一教修正解。自下第二随问为解。于中但释施等差别。涅槃大小在后别论此须记知。就所释中广解檀行。余指杂华。就解檀中先广后结。广中约就四修辩之。言四修者如地持说。一决定修正意不动。二专心修不杂余想。三者常修恒作不息。四无罪修行时离过。文中初言见乞乃与非波罗蜜无乞自与是波罗蜜。就专心修以别是非。若时时修非波罗蜜若修常施是波罗蜜。此就常修以别是非。若施已悔非波罗蜜施已无悔是波罗蜜。就决定修以别是非。菩萨于财生四怖心欢喜施者显前菩萨不悔所以。以于己财常怖王贼水火侵。夺于舍不悔。下有二对。就无罪修以别是非。一望报有罪非波罗蜜。不望无罪是波罗蜜。二若为恐下杂过有罪非波罗蜜。离过无罪是波罗蜜。就辩非中为恐怖者或畏前人舍财与之。或畏世间种种衰恼施求脆脱问曰。前说生怖行施是波罗蜜。此亦生怖何故非也。解言前者于财生怖喜施无悔。是故得名檀波罗蜜。此无舍意为脱衰恼而行布施是故非也。为名闻者施求称誉。为利养者以利求利。家法施者承袭父祖自无诚意。为天欲者求报心施。为憍慢者为令乞人于己敬畏。为胜他者为欲胜过其余施主。为来报者为得未来人中乐果并期他人交来报已。如市易下喻以显过。若人修下结以显非。下明是中先法后喻。法中初明离有为心。为方等下求无为心为利已下念众生心。喻中有五。文皆可知。上来广辩大涅槃中。如是义下总以结之。余戒忍等具释难尽故指杂华。涅槃大小此应具辩。经文言广故留在后。此略不论。上来第一偏就涅槃一法之中明闻不闻。自下第二更就余法明不闻闻。于中有二。一正就佛等明不闻闻。二德王白下问答重显前中云何牒问起发。下对辩之。文别有四。一总标举。十二部中深邃之义昔所不闻今具闻之。二对昔辩异。昔唯闻名今得闻义。三约人分异。二乘之人唯闻十二部经名字不闻其义今得闻之。四就法正辩。法别有四。第一如来常乐我净。第二如来不毕竟灭。第三三宝佛性无差。第四犯重乃至阐提悉有佛性。于此文中。先明二乘昔所不闻。后明今闻

下重显中德王先难。如来次答。德王白佛诚如圣下德王领解。就初难中难辞有二。一难破向前罪人有性。二犯四重禁名不定下难破向前佛有常乐我净之义。显成如来不毕竟灭。就难性中句别有三。一约堕地狱难破有性。若犯重等有佛性者性是善法应遮地狱。此等云何复堕地狱。以堕地狱明知无性。二约无常等难破有性。若使此等有佛性者性是常乐我净之法。云何此等无常无乐无我不净。以无常等明知无性。三约断善难破有性。于中三句。一约相征性。若使此等有佛性者性是善法。一阐提人断善根人所有佛性云何不断。二从相征性。佛性若断云何复言常乐我净。三约性征相。若性不断即是有善云何得名一阐提耶。此之三句下文别答。宜审记知。此初难竟

第二难中论其难辞。将下类上明佛不定。难意有三。一明佛不定破前佛有常乐我净。二明佛不定欲使如来述已所问。显成如来不毕竟灭。故下文中德王领解。如是如是诚如圣教一切诸法悉皆不定以不定故如来亦不毕竟涅槃。三明佛不定彰阐提等当无所得成现无性。故下文言若无常等云何说言一阐提等当得涅槃

文中有二。一以下类上明佛不定。二云何不定下就佛不定。难破常等。前中有四。一明凡不定。先明不定若。决定下难破定。义二明须陀至辟支佛一切不定。先明不定。若须陀下难破定义。三若犯四重不决定下牒前凡夫二乘不定类佛不定。四若佛不定涅槃体性亦不定下以佛不定类佛所得一切诸法明皆不定

上来一段明佛不定。自下第二就前不定难破常等。云何不定。征前起后。下对辩之。句前有五。一重明前阐提不定。若一阐提除谤法心则成佛道故知不定。前所辩中阐提最下故偏举之。余类可知。二以阐提不定类佛不定。如来亦应入涅槃已还出不入。三以佛不定类涅槃不定。若佛如是入已还出涅槃之性则为不定。四以涅槃不定难破常等涅槃不定。当知无有常乐我净。五云何下结以显过。涅槃若无常乐我净云何佛说一阐提等当得涅槃。佛答有三。一叹其能问。二敕听许说。三正答之。叹中初言善哉总叹。为欲下别。别中有三。一叹问所为。二汝已亲下叹问所因。三我不见下叹问殊胜。问所为中为益众生怜念世间明其为益。凡夫二乘为欲利益令得乐也。怜愍慈念使出苦也。为欲增长偏益菩萨故问总结。问所因中因福因智。汝已亲近是因福也。久已通等是因智也。福中初先明其自利。汝已亲近无量诸佛自利始也。于佛种善自利次也。成就菩提自利终也。准法华论。初地已上名得菩提。德王今已住第十地故说久成。降伏已下明其利他。降魔邪耶令得菩提化令入正。智中久通诸佛秘藏明具证智。已问过佛明具教智。叹问胜中言我不见若天人等能问是义举劣显胜。此初段竟。敕听可知

下正答中对问唯二。文别有三。一述成向前第二难中阐提不定。二如汝言下正答初难。三犯四重下答其后难。问曰。阐提不定之义依问未至何故先述。解言先明阐提不定能得菩提。显后所释一阐提人佛性不断。义便故尔

就初段中一阐提者亦不决定略述前问。若定不得反显不定。不定故得顺显不定

第二段中释难不尽。前难有三。一举堕地狱难破有性。二举无常等难破有性。三约断善难破有性。今答第三。初二不答。初难与下第九德中难辞相似。释不异彼故此不答。其第二难如后师子品中解释故此不答。答第三中先举难辞。难辞之中备有三句。就后以举。下正辩释。难中三句备如上辩。一约相征性。若犯重等有佛性辩。一阐提人断善根时所有佛性云何不断。二从相征性。佛性若断云何复言常乐我净。三约性征相。佛性不断何故名为一阐提耶。此文之中先答初句。答意如何。明其佛性不入一切方便善中为是不断。于中约对三种二善明性不同。第一约对内外二善明性不同。先举次列。如下文说意善名内身口名外此二可断。下明佛性不同此二所以不断。第二约对漏无漏善明性不同。先举次列。三有善法名为有漏。三乘圣道名为无漏此二可断。问曰。无漏云何可断。应生不生故名为断。非断已生。下明佛性不同此二是故不断。第三约对常无常善明性不同。先举次列。妄善无常真善是常此二可断。问曰。常善如何可断。义同无漏不生名断。非断已生。下明佛性不同此二是以不断

下次答其第二句难。答意如何。明性不断故得名为常乐我净。于中初言若是断者则应还得反释不断。若不还得则不名断顺释不断。约得显之。凡是一切可断之法当时虽断后必还得。佛性无有还得之义明知不断。以不断故如来说为常乐我净。下次答其第三句难。答意如何。明其佛性虽不可断其余善根是可断故名一阐提。文中说言若断已得名阐提者。余方便善可断已得未得之间名一阐提。非已得竟名一阐提

自下第三答上后段不定之难论其答辞。述前所问明佛不定。语其答意备有三义。一明如来体不定故虽现世间而常不同以不同故常乐我净。二明如来体不定故虽得涅槃不舍世间常随诸有。常随有故不毕竟灭。三明如来不决定故在有恒常。以其常故一阐提等当必得之。以当得故现有佛性

文中先广。以是因缘佛不定下总以结之。广中随人要唯有三。一明凡夫不定。二明二乘不定。三明佛不定。文别有四。一明凡不定终得涅槃。二明诸佛涅槃法定彰彼凡夫当有所得。三明声闻缘觉不定终得菩提。四明佛不定用而常寂彰彼二乘当有所得

就初段中先法后喻。法中初明凡人不定。后论凡法。人中但明犯重谤法五逆不定。阐提不定前已辩竟故此不论。法中初就四尘法门以说不定。色与色相俱不定者。碍是色性。青黄赤等形现可睹名为色相。香味触中亦有性相。性皆是碍与色体同故略不举。相别各异故偏举之。生至无明就十二缘以明不定。十二缘中观法多途。依彼七十七智观门。先观生相能起老死。如是逆推乃至最后。观察无明能起诸行。今依此门以举因缘故言生相至无明相。阴者是其五阴法门。入者是其十二入门。界者是其十八界门。二十五有及与四生各是一门。前七别举。法相众多不可备列故复通举。乃至一切此等皆悉从缘集起缘离散坏故皆不定。下以喻况。喻别有三。皆先立喻后合显法。上来第一明凡不定。自下第二明佛所得涅槃法定。亦定略举。下重显之。云何为定问其定义。常乐我净对问辩之。在何处耶问其定体。所谓涅槃就法指斥。第三二乘不定可知

第四明佛不定之中文别有二。一明如来化灭不定灭而常存。二当知如来亦不定下辩明如来化现不定用而常寂。前中有四。一明如来随化现灭。二一切所有声闻已下明二乘人不知佛化取为定灭。三当知下明实不灭。四以是义下结成不定。初中先明如来现灭。令诸已下彰灭所为。所为有四。一欲令诸人恋慕如来生大忧苦。二欲使诸众设大供养。三欲令诸人阇维佛身。以何义故千端[疊*毛]中唯留二端。即事以求。在外一端为遮灰土。儭身一端为净舍利。若论所表。为显如来外离尘染内德常净。亦得表佛真应恒在。四为使众生分散舍利广兴供养。余三可知

第二段中当知如来亦复不定总以标举。下别显之。别中初先开列章门。后广辩释。前开门中若合地狱畜生饿鬼。有十九门。分之则有二十一门。就初门中。先明非天。次明非非。下双结之。明非天中如来非天总以标举。何以下释。上来数说佛天中天。今以何故言佛非天。下对释之。先举四天。次列四名。世间天者智度论中名假合天。净天义天智度论中通名净天。次辩其相。下将如来对之显非。然众生下明非非天。是故下结。余门可知

下广解中解之不尽而复不次。于前门中非有非无非名非说及非如来四门不释故言不尽。十九门中第十二门非漏无漏回之在后故云不次。问曰。何故不释此四非有非无非名非说。此三种门解释非常非非常中其义具显为是不释。其非如来与非众生非非众生其义大同故亦不论。非漏无漏以何义故回之在后。以其义广故在后释

就解非常非无常中有七复次释彼非常。有八复次解非非常。文皆可知

就解非漏非无漏中先解非漏开合不定。总之唯一。或分为二。一是见漏。二谓修漏。或说为三。如经中说欲有无明是其三也。或分为七。如下师子吼品中说。成实论中具列其名。一是见漏。谓见谛惑。二是修漏。谓修道惑。三是根漏。谓眼等根能生诸漏。故名根漏。四名恶漏。所谓一切恶象恶马恶知识等。生烦恼者悉名为恶。恶能生漏故名恶漏。五亲近漏。谓衣食等生贪因缘近而生漏名亲近漏。六名受漏。如下文说受三恶觉能生诸漏故名受漏。不名受数以为受漏。三恶觉者如地经说。欲觉嗔觉及以恼觉是其三也。七名念漏。邪念起漏故名念漏。七中前二是其漏体。后五是其生漏因缘。根恶亲近是生漏缘。受念二种是生漏因。细分有十。见中分二。谓见与疑。修中分三。欲有无明。通余根等故合有十。若依下说受想触欲具有十四。广则无量

今此所论别分有十。合之为七。对此七门明佛无之

先对修道三漏为说。如来无漏标牒前门。断三故无略释其相。下广辩之。先列三漏。若摄见惑通入三中。是则欲界一切烦恼除却无明悉名欲漏。色无色界一切烦恼除去无明斯名有漏。三界无明名无明漏。若分见惑在修惑外。是则欲界一切烦恼除无明见疑名为欲漏。色无色界一切烦恼除无明见疑名为有漏。三界无明除迷谛者名无明漏。今依后门。下明佛无

自下第二明无见漏。先辩漏相。后明佛无。就明漏中初疑后见。疑中初言凡不见漏生疑所由。由于无明不见故疑。云何已下明由不见故生疑心。先问后辩。辩中初总次别后结。如是疑见覆生心者疑心推求故曰疑见。下明起见。疑后心决即名见也。生六总举。下别显之。有我有见。无我空见。良以疑心疑有疑无故从疑后生此二见。我见我者从前微我生重我见。如地持中从我妄想生身见事。我见无我从前我见生于空见。推有不得故还计无。与前因断起常相似。前执法体。我作我受执有我用见神有能作业受报。是名下结。上来明漏。下明佛无。如来永断正明佛无。菩萨永下举劣显胜

自下第三明无根漏。于中有三。一辨漏过。二明菩萨修道断漏。三况如来明佛无漏。就初过中有七复次。初二明离第一义乐。后五复次明具诸苦。于前二中初一明离涅槃之因。先法次喻后合可知。后一明离涅槃之果。先喻后合。就后五中初二造业。皆先立喻。后合可知。次一令人受三涂苦。先法后喻。次一起惑。驰骋五尘生烦恼故。先法后喻。后一令人沉没三有受人天苦。单法无喻

第二菩萨修道断中文别有三。一明护根。二有念慧故不见我下明其离尘。三菩萨尔时五根净下总结彰益。初中有四。一善护根。二怖畏下明护根所为。为畏烦恼为得诸善。三若能下明护有宜。若能护根则能摄心。若能摄心则能护根。于中初法次喻后合。四若得闻下修治护根。先修念慧为护根法。闻经得智是修慧也。则得专念是修念也。下明护根。初法次喻下合可知

次明离尘。于中有二。一修正治。二如屋下用之离过。前修治中。初观真谛。生土石下观察世谛。观真谛中先观生空。见一切下观察法空。观生空中句别有四。一不见我。二不见我所。三不见众生。四不见所用。前二一对破离我性。于五阴中不取色阴以为我体名不见我。无我体状名不见相。不取余阴为我所有名不见所。无所体状名不见相。将色对余分别既然。余阴相望分别亦尔。后二一对破遣因缘假名我相。于内不见众生之相。于外不见我所受用。上来观察无我我所通名我空。见一切法同法性相明见法空。法性本寂。今见色等同彼法性本来常寂。名见一切同法性相。此观真谛。生于土石瓦砾之相明观世谛。知彼世谛虚诳不真。故生土石瓦砾等相

上来修治。下用离过。分别有二。一对前治中众生空观明众生中对治离过。二知五欲下对前治中法空之观明诸法中对治离过。前中文有四句两对。初依前治中不见我相不见我所断除见惑。先喻后合如屋喻也。见众生等合以显法。二依前治中不见我相不见我所断除爱慧。于中初明菩萨不贪。一切凡下举凡显圣。凡见众生故起烦恼明凡异圣。菩萨念慧于生不贪辩圣异凡。此前一对。三依前治中不见众生及所受用断除见惑。于中初法次喻后合。法中不着众生相者以别分总。无生可著作种种者唯见五阴差别法也。喻中画师以众杂彩作众像者喻诸菩萨观察五阴成众生也。若男女等喻彼六道众生差别。凡无智等喻凡所有。画师子等喻圣知无。合中菩萨亦如是者合前画师。于法异相观于一相合以众彩画作众像若男女等。谓于五阴异法之相观察成于一众生相。凡夫无智生男女相略而不合。终不生于众生之相合前画师知无男女。先合后释。四依前治中不见众生及所受用断除爱患。由观五阴无人相故虽复睹见端正女人不生贪着。何以下释。此后一对

上来第一依生空观对治离过。自下第二依法空观对治离过。于中有三。一观五欲无常苦过。二复次下观察五欲能令众生轮转之过。三以是生死行苦已下念慧舍离。初中观欲无有欢乐法说明苦。不得暂停法说无常。如犬啮等喻说明苦。如水泡等喻说无常。观欲如是多诸过恶总以结之

第二段中初观众生为五欲故人天之中受苦无穷。无量劫来或在已下于三涂中受苦无极。菩萨如是深观下结

第三段中初先法说。次喻。后合。以是行苦不失念慧是法说也。以是五欲生死因行多受苦故坚守念慧。喻中三句。一五欲充满喻。大众喻于五欲境界。宽多名大。满二十里明其所在。于彼二十五有之中除下地狱及四空处。是故但言满二十里。亦有经言二十五里通相具论。二王敕下佛教菩萨坚守念慧喻王喻如来。臣喻菩萨。教守念慧名敕一臣持一油钵。令度五欲名经中过。教其坚守名莫倾覆。举过遮防故言若弃当断汝命。失一念慧慧命不续名弃一渧断汝命也。说涅槃经名遣一人。显过示人。名为拔刀。于所背处说过令厌名为在后随而怖之。三臣受下菩萨奉行喻。于中三句。一奉教坚持喻。二经历下对境自防喻。三是人以是怖因缘下念慧成就喻。合中但合菩萨奉行喻。于中三句次第合之。菩萨如是于生死中不失念慧合臣受教尽心坚持。虽见已下合第二句。若见下已合第三句。念慧成故虽见净色不生色相。乃至不作和合之相

前明护根。次明离尘

自下第三总结彰益。先明所成成护根戒。后明所离离于根漏。于中初先举凡显圣。菩萨永下辨圣异凡

下明佛无

自下第四明离恶漏。于中先明菩萨离漏。后明佛无。菩萨离中初总。次别。后总结之。复有离漏是初总也。复更有一离漏之行名有离漏。非举漏体。欲为下别。别中欲为甘露佛果明离所为。云何离下正明离相。先问后辩。辩中有四。第一观人修经离漏。二所谓恶者谓恶象下观恶得失失者离之。三自观身如病已下护身离漏。四观恶象及恶知识等无二下观恶轻重重者离之初中复四。一观自修经。二如良师。下明修有益。三汝信我下观供持人。四我念过下引昔类。今明供有益初中若能修大涅槃是名为离正劝修经。何以下释。以此经胜故偏劝修。举小显大彰其胜也

第二益中曲有三段。一明修经有离恶益。二如善咒下明修经者有脱苦益。三若有人能书写已下明修经者为佛忆念摄受之益。初中先喻。良师喻佛。说大涅槃劝人修学名教弟子。众生依行便能离过故言受者心不造恶。下合可知

第二益中初先正辩。后总结叹。辩中先喻。下合显法。涅槃如是合善咒术。若一经耳七劫不堕合前一闻七年不为毒药中等。此句明其始闻之益。若有书等必得菩提合前诵者乃至命尽无有众恶此句明其久学之益结叹可知

第三益中亦初正辩。后总结叹。辩中有五。一明书写乃至思义真佛弟子。二为佛所见。三为佛所念。四为佛随逐与其同住。五受其施。先明受施。后以梦验。结叹可知

上来第二明修有益。自下第三劝供持人。汝信我语总劝生信。供人获益相在难知故劝生信。欲见我下明供所为。所为有九。初三对佛明供所为。次四对法。次一对障。言八魔者烦恼阴死及与天魔是其四种。无常无乐无我无常无为四倒。复以为四。八中前四大小通论。后之四种唯大非小。以其小乘未说无常苦无我等为颠倒故。下一对彼人天之乐明供所为。见有受下正劝供养。先劝后释

第四辩明供养益中。先举往事用以类今。以是因缘涅槃不思结叹经胜。以是义下明持离漏

上来四段合为第一劝人持经以离恶漏。自下第二观恶得失失者偏离。先出恶体。如是等下辩其得失。有三复次。初二约对烦恼分别。前因后缘。后一约对业行分别。云何离下出其治行。先问次辩。是故下结。为生喜下明离所为

自下第三护身离漏。文别有四。一明护身。观身多过而犹护之。二何以下释。释中七句。三常当下明须常护。四何以下释。释中初法。先反后顺。次立八喻。下合可知

自下第四观漏轻重。于中有四。一观恶友与恶象等。二何以下释。俱坏身者彼恶象等坏现在身。恶知识者坏未来身。三观恶友过恶象等。是故菩萨于恶象等心不怖惧。于恶知识生怖畏心。四何以下释。于中先作六句校量。是故已下随重偏离。先总。次别。下总结之。凡夫不离是故生漏举凡显圣。菩萨离等辨圣异凡。菩萨尚下以因况果明佛无漏

自下第五明佛如来无亲近漏。文别有三。一明漏体。二菩萨断。三明佛无。明漏体中先问次辩后结可知。菩萨断中先辩后结。辩中初明见过舍离。若须衣下所须皆受。先别后总。别中别就衣食房舍医药四事明受所为。于中初法次喻后合。受四供养为菩提下是其总也。先受。后释。是故下结。举凡显圣明菩萨断。佛无可知

自下第六明无受漏。文别有三。一明漏体。二菩萨断。三明佛无。明漏体中初先法说。一切凡夫虽护身心犹生三觉正明漏体。何者三觉。一是欲觉。思求一切可意之事。二是嗔觉亦名慧觉。念他违己思欲嗔彼。三者恼觉亦名害觉。念欲加害。广有八觉。此三过重故偏论之。以是缘下明其漏过。次喻后合下释可知。菩萨断中先别后结。广中有三。一观过生厌。二菩萨或时有因缘下裁而不受。三何以故下释不受意。厌中初总次别后结。菩萨眼净见三觉过有种种恶是初总也。常与下别。别中十句初七远离第一义乐后三具苦。就前七中常与众生作三乘怨明违行过。次有五句明违解过。于中初句迷于理法令无量生不见佛性。其次两句迷于生死涅槃之法生颠倒心。谓佛世尊无常乐等是迷涅槃。一切众生有常乐等是迷生死。下有两句迷于行法。无三言有迷其权法。一乘言无迷其实法。此五违解。下一违圣。为佛菩萨之所呵责。就后三中是三恶觉害我及他起业之过。诸恶常随生烦恼过。即为三缚连缀众生招苦之过。菩萨常作如是下结

上来生厌。下次不受于中初法。三中就始是故且言生欲不受。次立五喻。下合可知

自下第三明不受意。先同后释。于中有二。一为他不受。二我常自称为出家下自为不受。为他有四。一坏世福田。二欺诳施主。三为世同呵。四损他施果。众生知我是良田等是初句也。我自不下第二句也。于中初明受三恶觉欺诳施主。我于往下举本类今明欺有损。流转生死堕三恶道。我若恶心受人施下是第三句为世同呵。若我恶觉受人施下是第四句损他施果。或令施主果减无报正明损他。恶觉在心身非净田故令施主果报减少。为恶外彰生彼邪见故令施主空无果报。恶心受施则与施主而为怨仇结以显过。失彼施报故言怨仇。施主于我起子想等举彼责己明诳不应。何以故下释以显过

就自为中文亦有四。一念自己是出家人不应为恶。二人身难得如优昙下明其善时难逢易失不应起恶。三从我名沙门已下显前第一明己高人不应为恶。四世有六处难可值下显前第二明逢善时不应为恶

初中有三。一念自己是出家人不应起恶起恶则非。二明出家身口相应不应则非。三念己出家原为起善取恶则非。于中初法。次举六喻。下合可知

第二段中人身难得如来难值法难见闻。此等明其善时难逢。人命不停过山水下好时易失四喻显之。第三段中始从沙门乃至比丘念己是此五种高人不应起恶

第四段中六处难值我今已得总以标举。次别后结。下总结之于中初明菩萨能断一切凡下举凡显圣。佛无可知

自下第七明无念漏。文别有三。一明漏体。二明菩萨断。三明佛无。明漏体中。凡夫若遇身心苦恼起种种恶总明凡夫邪念起漏。若得身下别明起漏。以作恶下明恶有损。何以下释。无念慧故。是名下结

菩萨断中初法次喻后合下结。法中初思昔来造恶流转生死远三乘路。次生怖畏。下明修断。舍恶所厌。向善所欣

喻中有六。始从四蛇乃至大河。初以四蛇喻于四大。于中有二。一喻如来说大怖人。王喻如来佛说四大集成己身。以总收别故说为盛。四大性反又能害人故说为蛇。佛说四大易动难调必须将护名令人养。一大不调名一生嗔。佛说随大生患各异名我准法。患起杀人众情共睹名戮都市。二喻菩萨闻过厌舍。人喻菩萨。闻佛向前示过之言名闻切令畏厌名怖。修离称走

次以旃陀喻于五阴。于中亦二。一喻如来说阴怖人。王还喻佛。如来复说五阴怖人名遣旃陀。阴有何义似于旃陀。其旃陀罗杀人为事。五阴前后共相摧灭其义像彼故以为喻。五阴生灭伤切如刀。圣说示人显露名拔。对其所欣说此为后。二喻菩萨闻过厌舍。人喻菩萨。反观生死名为回。顾知五阴过名见五人。专情厌背名疾舍去。次以诈亲喻其爱心。五阴相续生灭难觉名恶方便藏所持刀。五阴生爱名遣一人。生爱难觉故复称密。实危害相顺人情名诈亲善。爱能留连寄言显之故曰语言汝可还来。其人不信喻明菩萨知过不从

次以空聚喻于六入。归心六入名投一聚。六根是其神识依处故名聚落。望观六入以免其过名欲自隐。正意观察名入聚中。自观六根求我不得名看诸舍。都不见人观他六根亦空无人名执瓦器悉空无物。既不见人求物不得双牒前二。停止不进名即坐地。次以大贼喻于六尘。诸佛如来悬言教授名闻空声。呵其中住故言咄哉。牒前呵诫故言此聚空无居民。举彼六尘怖之令进故言是夜六大贼来。六尘害善故名为贼。闇心中现名为夜来。取着六尘伤失慧命故言设遇命将不全。当云何勉令求出意。下喻菩萨闻过生厌

下以大河喻诸烦恼。烦恼漂没故说为河。修中始觉故言路值。教起不贳名为漂急。无道能越名无船筏。厌过情深故言怖畏。修习诸行以为对治名取种种草木为筏。重观得失名更思惟。观住多失故言设住当为蛇等之所危害。虑进有苦故言若渡筏不可依。为断烦恼乃至丧身名没水死。舍退从进故言宁死终不为彼蛇贼所害。举初取后且言蛇贼。修治拟障名推草筏置之水中。人依行进名身倚上。求心手抱。厌观脚蹋。正断截流渐进名去。到大涅槃名达彼岸。受乐安隐。离苦无患。心意泰然显前安隐。恐怖消除彰前无患

下次合之。先合初喻。菩萨合前惶怖之人。得闻涅槃合闻切令观身如箧合下四蛇。地水火风如四毒蛇举以略合

下广合之。有九复次。初三如蛇。次一过蛇。次四如蛇。后一过蛇。初三如中初一复次能害如蛇。言见毒等辩喻显法。见毒喻火。热增赤现故说为见。触毒喻蛇。地增身重故名为触。嘘毒喻风。风吹曰嘘。亦有经本说为气毒其义相似。啮毒喻水。水渍名啮。四大亦可彰法同喻。二性别如蛇。三常害如蛇。次一过者四蛇杀人不至三恶。四大杀人必至三恶。以身病时多作罪故。次四如中初一明其牵人作恶。为四大身多作罪故。第二明其独能为害。第三明其性相乖反。第四明其难可亲近。后一过者四蛇可以咒药疗治。四大不尔。如自喜下合人舍走。于中先举诸佛菩萨同皆舍离明其可厌。菩萨思下修治舍离

次合第二。先合旃陀。后合舍去。前中初言五旃陀罗即是五阴举喻略合。云何下广。广中有其十六复次。初七观阴如旃陀罗。菩萨观阴过旃陀下有九复次。观察五阴过旃陀罗。有智人下合去可知。次合第三诈亲之喻。先合诈亲。后合不信。前中初言诈亲名爱举喻略合。下七复次广以合之。七中前五明如诈亲。后二明过。前中初一不觉害人。第二明其常伺人便。第三覆心令无见闻。见不见者凡夫二乘见生死过。以爱覆心还复不见。闻不闻者闻大菩提功德福利。以爱覆心还复不闻。第四明其无善诈现。第五明其相虚无实。后二过中初一明其始终难离。后一明其远近难知

一切众生以爱结下合上不信。于中初先反明凡夫信爱故住。后明菩萨不信故去。前中初言众生以爱远大涅槃近生死等正显其过。是故我下引说显过。言三垢者当应是其三毒垢也。以彼爱结远大涅槃近生死故。世尊说之为三垢中贪欲垢也。于现在事以无明下彰彼凡夫不离所以。怨诈不害有智人下辩明菩萨不信故去

次合空聚。于中先合空聚之喻。后明菩萨修治舍离。前中初言聚即六人举喻略合。下广合中有六复次。前五如聚。后一过聚。就前五中初空无人。观内六入空无所有犹如空聚合投一聚。如彼怖下合入聚中窥看诸舍不见人等。先牒前喻。下合显法。菩萨如是合上怖人。谛观六入空无所有合看诸舍都不见人。不见众生。一物之实合捉瓦器悉空无物。是故下结。二明凡所迷。三菩萨方觉。四烦恼住处。于中三句。一明烦恼处中安乐。二明烦恼处之不怖。三明烦恼同依。五明空无物生人有想。后一过者世间聚落或时有人或时无人。六入不尔一向无人。智者知下辩明菩萨修治舍离。何故是中已言六贼。舍远空聚元由畏贼故此举之

次合六贼。先合六贼。后合舍去。前中初言贼即六尘举喻略合。下广合中。有十四复次。初五复次明尘如贼。次一过贼。能劫三世一切善故。次六复如。后二复过。能劫三界一切善故。合去可知

下合河喻。先合彼河。后合求渡。前中初言河即烦恼举喻略合。下广合之。于中有其十二复次。初五如河。次三过河。于中初一明坏身心及诸善法。二能漂溺三界人天。三唯菩萨六行能渡。世河不尔。次二如河。后二过河。于中初明阐提没中余不能救。后明二乘七觉不竭。河不如是。是以言过。如畏人下合上求度文别有三。一合畏故取草为筏。先牒前喻。后合可知。二依乘此下超合向前推筏水中身倚而去。三修涅槃者作是思下却合更思我设住此当为蛇等之所危害。宁没水死终不为彼蛇贼所害。以忍受故不生漏者结明菩萨能断念漏。菩萨尚下举因况果明佛无漏

上来广明如来非漏。云何如来非无漏下明非无漏。先问后辩

上来广明一切不定。以是缘下总以结之。先结如来。后结凡夫。二乘不定略而不结

前问次答。德王白下德王领解。诚如圣教一切不定领佛前言。以不定故当知如来亦不毕竟入于涅槃领佛前意。以斯验求。前说不定宗显如来不毕竟灭以成上义

前就涅槃明不闻闻。次就如来佛性等法明不闻闻

自下第三于前文中有未解者问答重显。显前何义。前就涅槃不闻闻中明布施等是涅槃因六波罗蜜大涅槃因。德王前者牒问如来。如来于彼但为解释布施等行是波罗蜜非波罗蜜。未为解释涅槃大小。故今此中问答显之。德王先问。如佛先说修大涅槃不闻闻中有涅槃大涅槃领佛前言。云何涅槃云何大涅槃请佛解释

下佛先叹。后正答之。答中初先分小异大。大名不可思议已下释大异小。前中有四。一立喻以分。二约喻显法。三释前法。四解前喻。初列十喻是第一段。涅槃亦尔有涅槃大涅槃是第二段

云何已下是第三段。于中初先明小异大。常乐我净乃名大下彰大异小。前中初问云何涅槃。下对释之。释中初明欲界涅槃是小非大。若凡夫下明凡二乘断结涅槃是小非大

前中初列五种涅槃。五中前四说欲界乐以为涅槃。后一宣说欲界善法以为涅槃。观骨去贪云何欲善。此欲界中思慧观行伏结非断故名欲界。次明此五是小非大。何以下释。明此五种翻对疾过故名涅槃。非毕竟尽所以非大。以饥渴故显初非大。病显第二。怖显第三。略不举贫。贪显第五

下次明其凡夫二乘断结涅槃是小非大。先举后释。举中先就欲界辨之。若凡声闻标人别法。或因世俗或因圣道约治显灭。六行断结名世俗道。十六行断名为圣道。分相论之。凡用世俗。声闻偏用圣道断结。以实具论。凡夫如上。声闻通用。于中分别曲有三义。一见修分别。断见谛惑但用圣道。断修道惑二道并用。二就修中约地分别。断欲界结至无取有二道并治。非想一地唯局圣道。等智断结攀上断下。非想一地无上可攀所以不断。三就欲界至无所有约人分别。利人偏用圣道断结。钝人不定。或用圣道或世俗道。今且分相。凡用世俗圣用圣道断欲界结亦名涅槃。约障辩灭。能断初禅至非想等。举上二界结尽涅槃。凡夫断结至无所有。声闻断结通尽非想。此皆非大

上来举竟。下次释之。言何以故征前起后。此等能断三界烦恼何故非大。下对释之。还生烦恼释前凡夫断结非大。不能永尽所以非大。有习气下释前声闻断结非大。四义释之。一残结未尽所以非大。二迷同执别所以非大。三迷别执同所以非大。四所得非是常乐我净所以非大。就初段中有习气故略以标举。云何下广。先问次释。声闻缘觉有烦恼气对问总释。所谓下别。谓我身等有为法中烦恼余习。诸佛如来入于涅槃等无为法中烦恼余习。诸佛如来入于涅槃谓佛实灭。此迷如来涅槃之性。无乐无我唯有常净四义不具此迷涅槃。二乘何故计佛涅槃无我无乐唯在常净。彼不见实。又谓如来无常迁逼不得自在故说无我。谓佛心灭无所觉知故说无乐。言佛永灭故说为常。灭去惑累所以言净。问曰。上说声闻于佛具起四倒。今以何故但言起二。释言声闻实于佛身具起四倒。佛身有故于佛涅槃唯起二倒。涅槃无为是常净故。问曰。下说二乘涅槃但有乐净而无我常。今此文中何故异彼。解云。二乘说佛涅槃同已所得有寂灭乐。谓佛灭后同已灰尽无觉知乐故言无乐。大乘说彼小乘涅槃终须迁转。又所灭心当必还生。故曰无常。小乘谓已所得涅槃究竟永寂。将已所得类佛涅槃故说为常。问曰。此倒二乘正起。云何名为烦恼习气。解云。前明凡夫邪曲具起八倒。学小凡夫亦于如来起此倒心。二乘犹起故说为习。又对二乘所断烦恼有此残结故说为习。是名下结。此初段竟

佛法众僧有差别相是第二段迷同执别。如来毕竟入涅槃下是第三段迷别执同。不知如来别异二乘谓同二乘毕竟涅槃。声闻缘觉诸佛涅槃等无差别。以是义下结明非大。何以故下是第四段明其所得。体非常乐我净法故所以非大。先征后辩。问曰。下说二乘涅槃有乐有净。今以何故说之皆无。此通宣说身智等故。又设分有少故名无

上来一段明小异大常乐我净乃名大者彰大异小

自下第四广释前喻。释之不尽。前十喻中但释海河山城众生及人六门。地王天道四门不释。王之大小辩城具显不劳更释。就所释中皆初立喻后约显法

辩河喻中。声闻缘觉乃至十住不见佛性名为涅槃非大涅槃者涅槃大小进退不定乃有三阶。一简圣异凡。凡夫所得一向是小。三乘贤圣所得皆大。问曰。二乘所得涅槃云何名大。分大为小故小即大。故经说言汝等所行是菩萨道。所行既尔所得亦然二简大异小。凡夫二乘所得名小。佛菩萨得通名为大。故上文言菩萨住于大般涅槃种种示观。三简果异因。凡夫二乘菩萨所得斯名为小。以未见　断惑不穷不得常乐我净等故。诸佛所得独名为大。以见佛性断惑究竟具足常乐我净法故。此义如下。第七德中具广分别。今此所论义当后门

辩城喻中八万乃至一万处者。此就三昧法门辨处。就解人中结名大夫

上来第一分小异大。自下第二释大异小。三义释之。一叹深显大。二对因显大。三备德显大。初中大名不可思议总叹显深。下别显之。众生不信对下显深。佛菩萨见寄上显深。前言菩萨所得非大。今以何义言菩萨见。以诸菩萨未能穷证前说非大。随分契会故此云见

对因显中先问后释。多因缘得故名为大。于中初法次喻后合

备德显中云何复名重问起发。下对释之。明具常乐我净义故名之为大。先明我义。初法后喻。法中有四。一举大我释大涅槃。二举自在释成大我。三广显自在成彼大我。四就大我结大涅槃。有大我故名大涅槃是初段也。涅槃无我大自在故名为大我第二段也。宣说有我惧同情取故说无我。虽无神主而有自在故名为我。云何名为大自在下第三段也。先征后辩。有八举数。进任由己故名自在。下辩其相。一多少自在。二大小自在。三轻举自在。四自在自在。亦得名为所作自在。于中有三。一示无量形各令有心。佛心充遍故令有之。二作一事令人异辩。三住一土十方齐现。五根用自在。一一根中具一切用。六知法自在一切诸法自然现心而无分别。七起说自在于教于义说之无尽。虽有所说心无分别。八遍满自在。身充法界。此第三竟。如是大我名涅槃下是第四段。就我结成涅槃大义。下以喻显。大涅槃中具八自在名多珍异。德义旷周名曰无边。皆先立喻后合可知

次以大乐显涅槃大。先总标举。下别显之。初举四数大涅槃中无有受乐。但有此下四种乐故名之为乐。下辩其相。先问后释。一断受乐。二寂静乐。三觉知乐。四不坏乐。亦名常乐。断受乐者地持论中说灭尽定以为断受。此说涅槃。文中有三。一正明断受以之为乐。二乐有二下对彼凡夫乐受辩异。三有三受下对彼凡夫舍受辩异。前中断乐列其名字。此言即显断受义也。诸受皆断乐受最胜。对胜以彰偏言断乐。不断乐下释彼断受以为乐义。先反后顺。以不断乐名为苦故。断去乐受得名为乐。反中初言不断乐者则名为苦。如上文说名为坏苦名为行苦。若有苦者不名大乐不得名为涅槃大乐。顺中断乐则无有苦翻向初句。无苦无乐名为大乐翻向后句。无彼乐受则无行坏二种苦故名无苦乐。涅槃之性无苦乐下明断受乐是涅槃。以是义下将义显体成涅槃大

次对凡夫乐受辩异。说乐滥彼故须辩异。先举。次列。下辩其异。凡乐无常是故无乐简凡异圣。诸佛常乐故名大乐彰圣异凡

下对凡夫舍受辩异。前说断乐相同舍受故须辩异。先举三受。次列三名。下就辩异。不苦不乐是亦为苦舍异涅槃。是亦名为行苦坏苦。涅槃虽同不苦不乐然名大乐涅槃异舍。以大乐下将义显体成涅槃大

寂静乐中先列其名。此犹是前寂灭乐也。息苦名寂。涅槃性寂彰彼寂乐是涅槃乐。何以下释。以大寂下将义显体成涅槃大

觉知乐中先列其名。非一切下释知为乐。先反后顺。以大乐下将义显体成涅槃大

不坏乐中先列其名。生死法中破坏名苦。是故涅槃不坏名乐。身若坏下释彼不坏以为乐义。先反后顺。以大乐下将义显体成涅槃大

世间名下释难显常成涅槃大。释何等难。德王上言涅槃有名即是无常。佛今释之。涅槃之名无而强立故得为常。常故名大。经文之中虽不言常其义正当。文中有二。一明涅槃无名强立。二譬如有法不可称下约前所显彰涅槃大。前中初先泛明一切世俗名字置立不同。先举二门。后辩可知。下约显法。涅槃如是无因强立同向后门。于中初法次喻后合。下明大中。先喻后合

下以净义显涅槃大。净故名大总以标举。下别显之。先问举数。何等四下问以辩相。初一果净。第二因净。此二断德。第三身净。第四心净。此二行德。如地持中亦说四净。一者身净。二者心净。三境界净。四者智净。彼身与心与此相似。境净智净与此不同。法门差别不可一等

初果净中二十五有名为不净。能断名净正解净义。净即涅槃摄德归体。亦名有下拂疑显德。疑有二种。一无。二有。闻前永断二十五有谓言全无。故今拂遣如是涅槃亦得名有。闻其说有谓同世有。故复拂遣涅槃非有随俗说有。于中初法次喻后合。此论断德故言非有。若据身心二净以论实有非无

第二门中业净列名。次辩其相。凡业不净举秽显净。佛业清净彰净异秽。以大净下将义显体成涅槃大

第三门中身净列名。次辩其相。身若无常举秽显净。如来常下彰净异秽。以大净下将义显体成涅槃大

第四门中心净列名。次辩其相。有漏不净举秽显净。佛无漏下彰净异秽。以大净下将义显体成涅槃大

是名初德总以结之

第二德中初问。次辩。后总结之。辩中宣说五通为体。义如别章。此应具论。文中初先开列章门。昔所不得而今得者是身通中转变神通。凡夫二乘所不能得菩萨得之。余皆如是。不见而见是天眼通。不闻而闻是天耳通。不到而到是身通中飞行神通。十方远处余人不到菩萨能到。此与初门同是身通。何不一处在此别列。为彰身中作用别故。不知今知是其他心宿命二通。下辩其相。解初门中文别有三。一问答总显。二别对二乘彰昔不得而今得义。三别对凡夫。初中先问。所谓神通对问略辩

第二段中先举二数。内外列名。随事作用名之为外。依理发通说之为内。下辩其相。明其外者与外道共。不说以为昔所未得。内中有于大小之别。大与小异是故名为昔所未得。辩外可知。内中初先牒以举数。次列二名。下显不同。菩萨所得不与声闻辟支佛共略显不同。下广显之。先问次辩。二乘神通一心一作不得众多明小异大。菩萨不下彰大异小。先辩后释。以得涅槃之势力故。是则下结

自下第三别对凡夫明昔不得。又复云何重问起发。身心自在对问略辩。何以下释。于中初先明凡异圣。凡夫身心不得自在总明异圣。或心随身或身随心别显异圣。云何下释。菩萨不下辩圣异凡。是则下结

复次菩萨所现身下超释第四不到而到。何故不次。此与初门同是身通。故因向前辩明菩萨身心自在不相随逐。乘即就之明能到也。于此文中有七复次。一明菩萨所现身相多如微尘遍至十方。二能变身细如微尘遍至十方。三能化大身入一尘中。四能以一声遍闻十方。五能身心大小自在不相随逐。六能身心作业自在不相随逐。七能以一身令人异见。初中先辩。后总结之

第二段中何故复名昔所未到重问起发。下对释之。声闻辟支所不能到举小显大。菩萨能到明大异小。是故下结。一切声闻辟支佛等重显前小。声闻辟支不能变身如细微尘至恒沙界是一不及。身若动时心亦随动是二不及。菩萨不下重显前大。菩萨不尔心虽不动翻向后句。身无不至翻向初句。是名下结。第三段中初明菩萨能化大身入一尘中。菩萨化身如三千界是其一能。以此大身入一尘身是其二能。其身尔时亦不随小是其三能。次举小显大声闻缘觉虽复化身如三千界同向初能。不能以此入微尘身翻前第二。于此事中尚不能下翻前第三。是名下结。第四段中初明菩萨能以一音令三千界众生悉闻。次明菩萨心不自念。后明菩萨口不自说。于中初先正明不说。若言已下举过彰离。先举其过。后彰离也。以是下结。第五段中明能身心大小自在不相随逐。一切凡夫身心相随举凡显圣。菩萨不下彰圣异凡。先辩。次释。以是下结

第六段中辩明菩萨作业自在不相随逐。先辩后结。辩中三对。菩萨无量阿僧祇劫远酒不饮而心亦动是第一对。远酒不饮明身寂静。心无不为故称亦动。心无悲苦身亦流泪是第二对。心常住于第一义中不见众生故无悲苦。随化忧酸故身流泪。实无恐怖身亦战栗是第三对。心常安寂故无恐怖。为物惊恐故身战栗

第七可知

下次解释不闻而闻。初先正辩。德王言下问答重显。前中云何牒问发起。下释有四。一取相修。先取声相而为方便。是义云何。菩萨先得四根本禅极令纯熟。然后取彼种种声相。或小作大想或远作近相还入定中。定后复作。如是多返。后入定中发生智慧。以一无碍断障通壅。然后随意欲闻即闻。二以修集下明取相成。能闻无量三千界声。三复转下明破相修。四得异耳下明离相成。得异耳根异声闻等总明所成。何以下释。释中有三。一上下不同。二乘依于初禅四大所成耳根。唯闻初禅已下音声。上则不闻。余地类然。菩萨随依何地发通上下普闻。二宽狭不同。二乘唯闻一三千界所有音声不能无量。菩萨悉能。以是下结。三缘心不同。二乘取相。菩萨初无闻声之相。乃至不作定相果相。以是下结

自下第二问答重显。前有何难而复显乎。前说菩萨虽闻音声不作闻相乃至不作定相果相。此义难解故须更明。有两问答。初难向前无定无果如来为解。德王下复乘言重难如来为解

就初难中若佛所说不作定果是义不然牒以直非。何以下释。释中先征。下对辩非。于中先就善果设难。后就恶果。善中初言如来先说若闻是经必得菩提牒佛上言。佛前如来性品之中言闻是经定得菩提故今牒之。今云何下征破此言。若得菩提牒举前义。即是定下征此所说。就恶难中闻恶声故则生恶心生恶心故则至三涂直立道理。若至已下征破不定

下佛先叹。后为辩释。先答善果。答其所问后酬恶果。善中初先释通此语明无定果。汝言若人闻我说下解通上言明其闻经得菩提义。前中初明诸佛如来不作定说。夫涅槃者非声果下明其法体定不定义

前中初先反举说非明佛不说。先举佛说。下显其非。非佛是魔明其人非。生死之相远涅槃相明其行非。何以故下正明不说。先征后辩。辩中初明佛说不定。譬如刀下破他定说。先举刀喻。次就破定。以是义下约之显法

下明法体定不定中。先明不定。亦可定下明其定义。明不定中初辩后结。辩中四句。一正明涅槃体非声果。性出自古不依言教。方便修生故非声果。二若使涅槃是声果下破邪显正。若是声果本无今有。方便修生故非常法。三譬如下显向后句。先喻后合。喻中初言譬如世间从因生法举其喻事。有因有果无因无果因无常故果亦无常显其喻相。所以下释。先问后解。因果相作故是无常。因亦作果明因无常。如三月谷望后名因望前名果。以是果故因非定因所以无常。果亦作因明果无常。如八月谷望前名果望后是因。以是因故果非定果所以无常。以是下结。以是因果迭相作故诸法不定。法不定故一切无常。若使涅槃从因生下合之显法。此第三竟。四而是涅槃不从因下显前第一明非声果。不从因生故非声果。上来广辩。以是义下结成不定

上明不定。下次明定。涅槃亦定亦可言果略以标举。定如下释。了因所显故名为果。云何下释。先问后解。三义释之。常乐我净就德辩定。无生老等离过论定。一阐提等约人明定

上来解释此德之中无定无果

自下释上闻涅槃经得菩提义。先牒难词道其不解。次敕许说。下正为释。谓闻是经不作字相不作句相。乃至不取一切法相方得菩提。非取相得

上来就善释通其难。下次就恶。先牒直非。何以下释。于中三句。初非恶声乃是恶心对问略释。二者何下重为显之。虽闻恶声心不生恶是故当知非因恶声释前非以恶声而至。而诸众生因烦恼下释前是果乃是恶心。三若声定下破其定义。若声有定诸有闻者悉应生恶以声征心。或生不生当知无定以心破声。以无定下约心显声

自下第二德王重难。声若不定云何菩萨不闻而闻。佛答可知

次释天眼。先问后解。解中初言菩萨修经先取明等。修通方便。修之方法与天耳同。以修习故得异眼。下明修所成。准前天耳亦应有其两修两成。今略不辩。得异眼根异声闻等略明不同。云何异下广显不同。先问后辩。辩中有二。一明小异大。二彰大异小。小异大中略有三种。一依地不同。始从欲界乃至四禅随用何地四大成眼。但见自地及下地色不见上地。问曰天眼依于四禅根本定生。欲界无定不起天眼。今云何言若依欲界四大眼根不见初禅。释言此义论者不同。若依毗昙。身在欲界修天眼者。依于上禅发得上地清净四大所造眼根。与欲界眼同在一处。用之远见。一向不用欲果之眼而见远色。如在欲界。乃至三禅修上天眼类之同尔。若依成实。身在欲界修天眼者以依上禅修天眼故令欲界眼清净远见。不说上禅别生眼根与下地眼一处远见。如人服药令眼明净。彼亦同尔。如在欲界乃至三禅修上天眼类亦同然。此经所说多同毗昙。欲界地中实无依禅所生天眼非无欲界有报天眼。六欲诸天亦有修道得罗汉故今通说之。故言欲界四大眼根不见初禅。二自他不同。声闻缘觉但见外色不见自眼。三宽狭不同。声闻缘觉极远唯见一三千界不能宽多

大异小中有八复次。一明菩萨报得眼根不修从习常能见己微妙色身悉是骨相不同二乘

二虽见他下明能远见心无取着。先辩后结。辩中虽见恒河沙世界能远见也。不作色等无取着也。无取有四。一于色中不取有相。二作因缘相知非有无。三不作见下于见及眼不取有相。四唯见缘下于眼见中知非有无。为明眼见非定有无。约色显示。唯见缘者见色是其眼见家缘。若无此色眼则不见故名为缘。非因缘者见色空寂。无法可为眼见家缘。下广显之。云何因缘牒问初门。色是眼缘当义正解。色是眼家生见缘也。若色非下难破非缘以成缘义。以是义下结色为缘。非因缘者牒向后门。菩萨虽见不生色想故曰非缘。以是义下结异二乘。此第二竟

三以是义故一时遍下明能顿见不同二乘。顿见十方一切佛故

四以是义故能见尘下所见微细不同二乘

五以是异故虽见自下能见自眼不同二乘

六见色无常不同二乘

七见众生三十六物不净充满不同二乘

八见色知相不同二乘。于中乘明触衣知根。此一复次义有两兼。从前犹明不见能见。从后即显不知能知。文别有四。一明眼见色知根大小。二明触衣知根善恶。三以是义下结成知义。以是义故昔所不知而今知者结前触衣知根为知。以一见故昔所不知而今知者结前见色知根为知。简触衣知根故言一见。四以此知下结成见义。良以见色知根义故昔所不见而今见也

下次解释不知能知。于此门中义分有二。一知他心。二知宿命。文别有三。一知他心性。二知宿命。三知他心相

初中先问。下释有二。一破情显理知有常无。二云何知下破空显实知无常有。前中初言虽知贪等是知有也。辩有兼无是以言虽。心法无量且举烦恼。初不作下是知无也。于中有二。一离有相。不取心王名不作心。不取想等名不作数。不见有人能起彼心名不作众生。亦不见心攀缘境界名不作物。二修空相。修第一义毕竟空相正明修空。何以下释。以常修集性相空故名毕竟空。于因缘中无有定实名为空性。因缘亦无故曰空相。以修下结

就后破空显实门中云何为知。知无有我无有我所是知无也。知诸众生皆有性下是知有也。知生有性正明知有。以佛性下约果显有。如此皆下就人辩异。以是下结。准验斯文以空为穷判知不了

次论宿命。先问次辩。菩萨修经念过去等修通方便。于一念下明其所成异于二乘。得殊异智异声闻等总明其异。云何下别。别有多门。然今且明缘心不同。声闻缘觉念过去世而作种性至怨憎相明小异大。彼知性空未能空于因缘之相。缘相不泯人相还立故有种性怨憎等相。菩萨不下明大异小。法相既无人相安寄。故无种性至怨憎相。于中初先明离有相后修空相。是名下结

下次明知他心之相。先问次辩。菩萨修经得他心智异声闻等总显其异。下别显之。别中初约凡心辩异。二乘别知。菩萨能顿。于中初问次辩后结。下约圣心。初举次辩。菩萨一念知须陀洹十六心别。二乘不能。依成实论。亦约须陀十六圣心明知差别。与此少异。彼中乃就迟速辩异。菩萨之人欲知初心即能知之。余心亦尔。缘觉之人欲知第三至第七心方乃知之。何故偏言欲知第三。第三心者是苦比忍。其他心通依上禅起。欲知他人无漏心时还缘观上无漏之心同地易知。于彼观上无漏心中苦比为首故偏言之。以何义故至第七心方乃知乎。第七心者是集此忍。缘觉欲知苦比忍心拟意观察。彼心已谢起苦比智。缘觉寻观追而不及。即于上界集上伺之。彼须陀洹已舍上苦。缘欲界集起集法忍及集法智。从比智后复缘上集起集比忍及集比智。彼缘觉人由前集上伺求之力集比忍生即便觉知。是故偏言至第七心方能知矣。声闻之人欲知第三次第急寻。至第十六道比智心方始得知。有此不同是为第二是总结也

第三德中初问。次辩。后总结之。辩中宣说慈无量心以为德体。四无量心皆是此德且就初举。又复诸行有分相门有摄相门。若据分别四行各别。若据摄相举一为首余皆入中。今就摄相故举一慈统收余三。文中初言舍慈得慈得慈不从缘略以标举。谓舍一切攀缘之慈得彼平等无缘大慈。此无缘慈证实以成。据实反望由来无缘知从何生。故说得时不从因缘。下别显之。别中有四。初番约法舍相得实。后三约人舍伪会真。就初番中先问后辩。辩中约境舍世谛慈得真谛慈。若约心识舍妄识慈得真识慈。若据行修舍缘观慈得无缘慈。后三何别。初舍凡夫善法之慈得菩萨慈。第二舍彼凡夫之人不善之慈得如来慈。彼阐提等何处有慈而言舍乎。解云。此等同类同行亦相亲爱名为慈矣。问曰菩萨云何已得如来之慈。于佛深慈随分克证故名为得。问曰。所得如来之慈与前句中菩萨之慈有何差别。解言顺化巧益之义是菩萨慈。行非通道名如来慈。故维摩中菩萨行非名通佛道。第三舍彼凡夫二乘取相之慈得无缘慈。先问后辩。凡夫取着众生之相。二乘取着诸法之相。故须舍之。彼黄门等云何名慈。黄门无根二根女人淫情相爱名之为慈。屠脍猎师养猪鸡等爱好所杀亦名为慈。明所得中初辩后释。是名下结

第四德中初问起发。次释。后结。有难解者问答重显。释中宣说十事为体。先初举数。次列其名。根深难拔明能立始。不放逸心能为佛本故名为根。与实相俱增长不坏名深难拔。二于自身生定想者彰能趣终。自念己身定得菩提名生定想。下八具行。前五摄福。后三摄智。福中初二修净土行。不观福田及非福田修施净土。心有分别得土不净故不观田及与非田。平等心施能净佛土。修净土者修戒净土。以修戒故得土严净。后三是其起法身行。灭除有余断除业缘离秽身行。除断残苦名灭有余。断离残集名除业缘。业是正因。烦恼为缘。下文释中此之二门通名有余。有余有三。一烦恼余犹此缘也。二是余业犹此业也。三是余苦犹此有余。修净身者摄净身行。精修十善故能净身。后摄智中了知。诸缘明摄对治。下二离障。离诸怨敌。除障道过。断业烦恼及破八魔名离怨敌。断除二过离生死过。亡因绝果名除二边

下广释之。解初门中初问次辩。根名不放正出根体。谨摄之心是不放逸。次解根义。先问后辩。谓菩提根对果正论。诸佛善本皆不放逸重复显之。不放逸故余善增下解深难拔。拔则不增。增故不拔。于中初举余善转增正明难拔。以能增下叹以显胜。此二为门。如诸迹下显向后门最胜之义。十二复次。皆初立喻后合可知。以是义下显向初门令善增长。于中初先乘前显后。以前门中不放逸法令余善增故深难拔。云何下释。先问次辩。以增长下结成难拔。以是义下总结初行

第二行中初问次辩。辩中于身生决定等明起定心。不作狭等离不定心。先开三门。不狭一门。不小第二。不变第三。下重显之。不作声闻辟支佛心释前不小。不作魔心及自乐心乐生死心释前不变。常为众生求慈悲心释前不狭。是名下结。初先略结。我于来下牒以重结

第三门中初问次辩后总结之。辩中有二。一举劣显胜。先辩福田。若有念下明偏执过。偏执此等为福田故。福田至少名为狭劣

二辩胜过劣。于中初明菩萨观生无非福田。常观诸佛所说已下观一切施齐得净报。前中初言观一切生无非福田总翻前过。何以下释。先问后解。以善修集。异念处故对问略释。平等法性是众生体。菩萨独观余人不见名异念处。菩萨修此故观一切无非福田。下重显之。修异念故见诸众生本性皆净故无持戒毁禁之别观一切施得净报中。说施虽四后得净故总以标举。下别显之。先明四施。初问次列。下广释之。解初问中初门次辩。施者具有戒闻智慧有世谛行。知施及果有世谛解。受者破戒入第一义坏世谛行。专著邪见证第一义坏世谛解。是名下结。余门类尔。下次明其俱得净报。于此四中持戒正见得世净报。破戒邪见得出世间离相净报。持戒正见得世净报相显易知不劳解释。破戒邪见得净福报义隐难识今偏释之。文中初言若如是者云何复言得净果报征前起后。若如向来施及受者破戒邪见是为极恶。云何说言俱得净报。下释有四。初言无施无报故净对问略释。坏世谛相证第一义故名为净。二若不见下翻犯为持成得净报见第一义。无施报者行无罪过解不远理。是故此人不名破戒专著邪见。三若依声闻言不见下释通向前持犯二言。以何义故不见施等前说以为破戒邪见。今复说为不名破戒专著邪见。故今释之。依声闻法不见施等名为破戒名为邪见。若依是经名持正见。四有异念下释大异小。何故依此大涅槃经偏得名为持戒正见。依小不尔故今须释。有异念处菩萨修集是故不见持戒破戒施及报等名持名正

以是义下总结此行

第四行中初问次辩。辩中菩萨自离十恶愿益众生故能净土。是名下结

次解第五及第六门。前分二门。今此通合名为有余。于中初问次辩后结。辩中初举。次列三名。烦恼余报是生死缘。余业是因。此二犹前所断业缘。余有是其生死之果。此犹是前所灭有余

下广释之。烦恼余报就凡夫说。余业就彼小乘人中学人宣说。余有就彼小乘人中无学人说。盖隐显耳。烦恼余中先问次辩。烦恼无量。今且就其贪嗔痴慢四使说之。以此四使缘事而起受恶果故。一一之中皆初习起。次堕三涂。后生人中受其余报。皆有在家出家之别。下明菩萨对治修断

余业之中。先问次辩。凡夫所作名凡夫业。声闻所受名声闻业。下就声闻差别论之。须陀洹人七有业者总相论之。依智度论。须陀洹人天上人中七返往来受十四生。今就往来总言七有。斯陀二有细别论之。彼于欲界天上人中一往一来便般涅槃故说二有。阿那含人受色有者。那含亦受无色有业。就下论之。下明菩萨对治修断

明余有中。初问次辩。言阿罗汉得阿罗汉果辟支佛得辟支果者标别其人。余有在于无学果处所以举之。无业无结而转二果正辩其相。分段结业无学已尽故无结业。而彼结业二家残果无学犹有。更须转灭名转二果。是名下结。如是三下总牒结断

修净身中先问后释。释中有三。一明修习三十二相。于一一相百福修之。言百福者。五品心中修行十善即为五十。始修五十终成五十合为百福。用此成满三十二相名修净身。此明共因。下师子中说不共因。左右言耳。二明修习八十种好。先问后辩。今此但明修之所为不辩修法。诸经例无。文中初先明世众生事八十神。次明菩萨为之修好。何以下释。以是下结。三总明其修身所为。有四复次。明为菩提故修相好。皆初立喻后合可知。以是下结

了知缘中先问次解。解中先就色法明知。不见相者不见青黄赤白等相。不见缘者不见生色之因缘也。又亦不见四大以为造色因缘。不见体者不见质碍以为色体。不见出者不见色法初生出也。不见法。灭者不见色法终尽灭也。不见一者不取总相。不见异者不取别相。不见见者不见有人能见色也。不见相者不见能见之相貌也。不见受者不见有人领受色也。何以下释。知法但是因缘虚集。如色一切亦如是者以色类余一切法也。是名下结

离怨敌中初牒次解。解中先明离烦恼怨。次离业怨。后离魔怨。离烦恼中先明是怨。后明非怨。前就自行烦恼是怨。后就化他烦恼非怨。此怨非怨义通上下。大位分之。初至四住行修求出烦恼为怨。五地已上起化。随物烦恼非怨。今随位别。离业怨中先问后辩。辩中先出业怨之体。谓谤方等。下明菩萨畏而舍离。离魔怨中先举八魔。下明菩萨修治舍离。八魔如前恶漏中说

离二边中先问次辩。二十五有是其果边。及爱因边。菩萨常离。是名下结。是名第四总结此德

有难解者下重显之。德王先问。问意如何。如来向说修净佛土自居秽国事与言乖故今问之。如来何故但修九事不修净土。下佛答之。先明自己往修十事有净土因。若使已下明已现明净土之果。前中先明已修十事。一切已下举他类己

明有果中句别有六。一明此非秽。若使世界不净充满佛于中出无有是处正明非秽。汝莫谓等诫舍秽想。二汝当知下明已他方更有净土。言我不出阎浮提界明更有也。三如有人下显向初句明此非秽。先喻后合。喻中假举愚人为说。日月喻净。有人宣说此有日月他方无者无有义理。若有宣说他方有净此方无者亦无义理。将此日月况他有净。乍读迷人。准义可知。四西方下显前第二明已他方更有净土。五为化众生故于此下明阎浮提之秽为化众生诸佛共俱。六慈氏已下明阎浮提之净诸佛同处

第五德中初问次辩后总结之。辩中五事。报果为体。先举五数。次列五名。前四福德。后一智慧。福中初二。自报具足。后之二种为他敬养。以是下结。德王言下问答料简。问相可知。下佛先叹后正答之。各有异义。当为汝说总标许说。下以六番广辩可知

第六德中初问次辩。辩中金刚三昧为体义如别章。此应具论。文中初言菩萨修得金刚三昧总以标举。下别显之。别中二十四复次文辩广其相。前二十一正辩其相。后三释名。前正辩中相从为四。初三复次明能破义。次七复次明最胜义。次四复次明能照义。后七复次明无分别义

能破义中初一破法。第二破人。第三破障。就破法中安住是中悉。破诸法。总以标举。下别显之。别中见法无常动相以无常义破坏诸法。恐怖因等以苦破法。恐怖因缘是苦因也。病苦劫盗是苦果也。念念灭坏无有真实无我破法。一切魔境无可见相以空破法。次破人相。于中约就六度破之。先顺后反。明破障中初先立喻。譬如金刚拟无不碎明能破障。金刚无损障。不能坏。下合可知

次七复次明最胜中。初一复次体精故胜。如宝立喻。下合可知。第二复次行主故胜。初先法说。何以故者征前起后。何故最胜。下对释之。修是三昧一切来属。次喻后合。下五复次明其其破障摄善力胜。初二破障。前破四住。后破无明。破四住中先立其喻。如人喻于四住烦恼。违害众善名国怨仇。众善违背名人厌患。此定能断名有人杀。众行归仰名无不赞。下合可知。破无明中亦先立喻。如人喻于无明住地。无明力大故云盛壮。故胜鬘云无明住地其力最大。余行不治名无当者。更有人者喻金刚定。能破无明名能伏之。众行归依名世称美。下合显法。金刚如是合更有人。力能摧伏合力能伏。以是义下合世称美。次一摄善。如人在海立喻显法。下合可知。次一复次明破障力胜。前明能治。此明广治。先喻后合。下一复次明摄善力胜。前者明其以终摄始。此句明其以上摄下。先喻后合。此七复次明最胜义

次四复次能照义中。初一复次见法无碍。先法。次喻。后明不着。第二复次见法生灭。如坐四衢立喻显法。人喻此定。安住正法名坐四衢。见生来去喻见一切诸法生灭。下合可知。第三复次能见远法。先喻后合。第四复次能见远国。先喻后合。文皆可知

后七复次无分别中。前三复次于自行中心无分别。后四复次化他行中心无分别。前自行中初一复次明自灭障。如由乾陀立喻显法。下合可知。下二复次明于向前灭障行中心无分别。前复次中金刚为喻。后复次中池水火等六事为喻。合之可知。后四复次于化他行无分别中初二身业。次一口业。后一通于身口二业。于此三业心无分别。前身业中初一复次变身为佛满恒沙界心无分别。后一复次一念能至恒河沙界心无分别。次一口中一念说法能断十方恒沙世界众生烦恼心无分别。下一通明身口业中先明身口二种化相。以一音说是其口业。示现一色是其身业。安住一处复明身业。演说一法复明口业。下明菩萨心无分别。虽见生等不取人相。虽见色等不取法相。于中初辩。何以下释。辩中初言虽见色等不取苦相。见烦恼等不取集相。见八圣等不取道相。见涅槃等不取灭相。释中初问何故皆无。下对释之。法本无相正解前无。以三昧下明见所由

上来辩相。下释名义。何故名为金刚三昧问以起发。如金刚下三义释之。一不定义。如世金刚若置日中色则不定。此定如是于大众中现种种身。二最胜义。如世金刚体精胜故无能平价。此定如是无能平量。三势力义。如世金刚除贫去毒有大势力。此定如是若有得者离烦恼苦诸魔邪毒

是名总结上来六德是其自分。下四胜进。于胜进中初明修习对治功德。先问次辩。辩中初先总明四法为涅槃因。先思后知。知中初顺次反后释。即知四法为涅槃因是其顺也。若言勤等是其反也。所以下释

次列四名。先问后列

下广释之。释中五番随文以求。前三总释。后二别解。约行论之。初之一番明离过义。第二一番明摄善义。第三一番重明离过。后之两番复明摄善

就初番中先喻后合。喻中如人有病至医喻近善友。医为说药喻闻正法。至心善受喻系念思。随教合等喻如说行。下合下知

第二番中先喻后合。喻中如王乃至咨臣其法云何喻近善友。王喻行人。欲依正法修治行心名如法治。欲令已行出障安隐是故名为令民安乐。问友行义名咨智臣其法云何。诸臣即下喻闻正法。宣说过佛行法授与名以先王旧法为说。王既闻下喻系念思。如法治下喻如说行。下合可知

第三番中重明离过。与初何别。前据菩萨明离轻恶。此就凡夫彰离重过。亦先立喻。初喻近友。如人遇病近友所以。有善知识喻其善友。略无近相。而语已下喻闻正法。其人至下喻系念思。即往彼下喻如说行。下合文中先合近友。闻法之喻略而不合。至心信等合明思惟。菩萨思量为益众生舍过求出。是故宣说四无量心为系念思。少者已下合明修行。文皆可知

自下二番重明摄善。与前何别。前第二番总明摄善。下别显之。于中初番上下通论。后之一番简胜去劣

就初番中先明近友。文别有二。一正明近友。二若有亲下明近友益。前中有六。一知识心。有聪明者常教不倦。二知识人。亦名为体。谓佛菩萨声闻辟支。三知识义。何故名为问以起发。下辩可知。四知识仪。如法而说如说而行是其仪也。先举后辩。辩中三番。初番约就离恶分别。后二约就教善分别。先果后因。五知识法。为生求乐见过不说是其法也。于中初举。何等下辩。不求自乐常为众生就心论法。见过不说就口明法。以是下结。六知识益。空月喻说。下合可知

上来明友。下明近益。若近知识未有戒等起行之益。未有令有已有令广复得了达十二部等生解之益

次明听法。于中有三。一大小通举。谓能听受十二部经名为听法。二简小取大。听方等经名为听法。三于大乘中简劣取胜。听涅槃经名为听法。于中初言真听法者听大涅槃总以标举。大涅槃中闻佛性下别显所闻。所闻有其六句三对。一闻佛性隐时之因。二闻如来毕竟不灭显时之果。此二一对。三闻八道能证之行。四闻十一空所证之理。此二一对。五闻发心得大菩提。六闻发心得大涅槃。此二一对

次明思惟。文别有二。第一约就十二因缘对治之法明系念思。二约三三昧对治之行明系念思。前中先喻。病闻医教及药名字不能愈病喻简前闻。以服得差喻须后思。次合后结。后中初问复以何义名系念思。次辩后结。辩中初言谓三三昧略以标举。次列后辩

下明修行。云何征问。下对辩之。辩中初明依法修行。法者即是常乐我下明所行法。前中初言修行即檀乃至波若明修正行。知阴入等明修正解。后明法中初言。法者即常乐等明法体相。解大涅槃甚深义下约解显法

上来一番上下通论

自下一番简胜去劣先明近友。文别有二。一明佛菩萨以为善友。二以是亲友因缘已下明近有益

前明友中有八复次。初一复次能调物心。中六复次巧为善益。后一复次内心平等。初中第一善知识者谓佛菩萨简胜去劣。简去声闻辟支佛等。何以下释。初先征问。常以三种善调伏故对问略解。下别显之。先问。次列。以是下结。中六复次巧为益中初二复次能化离过。次二复次能教生善。次一复次复化离过。下一复次复教生善。初二复次化离过中。前一化人令离恶因。后一化人令渡若果。离恶因中佛及菩萨为大医故名善知识略以标举。何以下释。释中初法次喻后合。以是下结。令渡苦中如大船师立喻显法。次合后结。次二复次教生善中。前一复次教生善因。初法次喻后合下结。后一复次教得乐果。初先立喻。上药喻于诸佛菩萨。见喻睹形。触者喻于亲近听法。念喻依行。次合后结。文皆可知。次一复次化离过中。如香山中阿耨池等举妄显真。世人妄说阿耨达池浴能灭罪故今举之。除此已往何等实下辩真异妄。先问。次辩。所以下释。以是下结。下一复次教生善中先喻次合。以是下结。此六复次巧为善益。譬如良医善八术下第八复次明佛菩萨内心平等。先喻次合。以是下结

上明善友。以是亲下明近有益

次明听法。先问后辩。辩中初先正明闻法得近涅槃。我处处下引说彰益。前中经文有五复次。初一法说。后四喻况。法中初言以听法故则具信根。乃至佛果明听有益。是故下结。是中正明由听得佛。道须陀等乘以论之

下四喻中初长者喻明能诫远。第二镜喻明能示近。第三商喻明能导远。第四象喻明能制近。初中先喻。喻中初至亦莫交游喻所闻法。长者喻友。子喻行人。遣至他国喻教向佛。行因贸果名市所须。说诸地中障治之相名示道路通塞之处。教防诸过名复诫之。淫女喻于五欲境界。劝之舍离名无亲爱。习近五欲能坏法身绝其慧命失功德财。故言若亲丧身殒命及以财宝。弊恶之人喻恶知识。教其舍远名莫交游。其子敬下喻修行者闻法利益。次合显法。菩萨为生敷演法要亦复如是合前长者遣子他国市易所须。示诸众生诸道通塞合示道路通塞之处。而复诫之乃至莫交略而不合。是等闻法合敬父教。远离诸恶合身安隐。具足善法合获宝货。以是下结。后三门中皆先立喻次合后结。文显可知

上来广明闻法有益。自下引说证成有益。文别有四。一明听法能离五盖。二能离畏。三能离痴。四灭苦恼。就初段中我处处说听离五盖明有所离。修七觉分明有所起。以修七下明有所成。第二段中以听法故须陀离怖正明所离。者何已下即事以显。先征后辩。四功德者如毗婆沙说。近友闻法思义修行是其四也。十慰谕者如中阿含舍利教化病经中说。彼有长者字须达多。身有重病。子时遣使问讯世尊并请舍利希屈一顾。舍利遂往。须达见来即欲下床。舍利便止别坐一床慰谕长者莫怖莫怖。所以者何诸凡夫人成就不信。身坏命终堕于恶道生地狱中。长者今日已有上信以是信故能灭苦痛生极乐处。或得斯陀或得阿那长者先得须陀洹果为是不说。此初慰谕。善戒第二。多闻第三。惠施第四。善慧第五。正见第六。正志第七。正解第八。正脱第九。正智第十。一一之中慰谕之辞皆与初同。十中前五是世间善。后五出世。就出世中正见正志是无碍道。慧名正见。正思惟者名为正志。正解正脱是解脱道。慧名正解。余心心法说名正脱。学等见者名为正智。学人重观四谛之理名学等见。以是下结。何以下释。此是第二听法离怖。自下第三明由听法能离愚痴。能知世人三种别故。先举三人。次列。下辩。后明听法能具了知。以是下结。自下第四明由听法能灭苦恼。先举舍利往事显之以是下结

次明思惟。先问后辩。有五复次。初三离过。次一生善。后一通明离过生善。就前三中初离五欲次离四倒。后离四相。文皆可识

下明修行。文有三番。第一总明离过修善以为修行。初问次辩后结可知。第二别明观法离过以为修行。初问次辩后结可知

第三别明知法成善以为修行。先问后辩。有二举数。实与不实列其名字

下释其相。先解不实。下解其实。先问后释。释中初先开列七门。后广辩释。前开门中涅槃是果。佛性是因。如来法僧即是菩提。实相世谛。虚空真谛。知此七法名实修行。有人一向说空为性。准此七门明空非性

释中有二。一通就诸法以彰七别。二诸佛如来烦恼不起名涅槃下就佛论七明七无别

初中先解涅槃之义。初问。次释。后总结之。释中初明八义涅槃知大异小。先问次辩后结可知。后八及六知小异大。于中有四。一举凡夫八事涅槃。二列小乘六事涅槃。具应有八。无常无我略而不举。三有凡下解凡涅槃。先举次释后结可知。四云何下解小涅槃。先问后释。前隐无常释中有之。若如是下结前异后。名知涅槃非佛性等

次解佛性。先问次释。前六后七皆就因说。随相别分我是佛义在因不论。乐者是其涅槃之义。通则因中亦有涅槃。乐随涅槃因中亦有。故下文说菩萨涅槃有乐有净。别则涅槃唯在佛果。乐随涅槃在因不说。故下文言。诸佛如来不生烦恼故有涅槃。菩萨虽断非是不生故无涅槃。无涅槃故不说乐矣。据实通论因中性体亦有我乐。是名下结

次解如来。先问次辩。有十一相。是觉相者如来是人。觉知法也。善等可知。是名下结

次解知法。先问次辩。法通染净是故具有善不善等。亦十一对。是名下结

次解知僧。先问次辩。辩中有九。常乐我净大乘僧也。弟子相下小乘僧也。现禀圣教名弟子相。人粗易睹故言可见。行顺名善。真与不实下文自解。先解善义。何故征问。一切声闻当得佛道故名为善。下释是真。何故征问。现悟法性故得名真。是名下结。次释实相。先问次辩。依大品经偏名真谛以为实相。此经下文亦说真谛以为实相。今此所论是其世谛。是世谛故生死涅槃染净诸法一切皆是。是故若常若无常等斯名实相。有十三对。是名下结。是名实相非涅槃等结此异余。是名菩萨修大涅槃知涅槃等差别之相结前异后。结前六门异后虚空名差别相。又知前六各各不同亦名差别

次释虚空。初先正解。下举涅槃类显虚空。前中初明菩萨知空。后辩空相

知中四句。初言菩萨修大涅槃不见虚空略明菩萨离相不见。证空之时不见空外别更有心。以无心故不见心外别更有空。空外无心即无能见。心外无空便无所见故不见空。二何以下释成不见。初先征问。菩萨修经应当见空。今以何故道其不见。佛及菩萨虽有五眼所不见者对问辩释。五眼名义备如上辩。五眼中慧实能见空。但见空时不见空外有眼能见。以无眼故亦无眼外有空可见。故曰不见。三唯有慧下就前不见略说为见。此慧犹前五中慧眼。此慧证空无所见时真名见空。故云唯慧乃能见耳。四慧眼所见。无可见下释前不见以为见义。良以有见乖前不见故今释之。此云见者无法可见故名为见

上明能知。下次辩其虚空体相。粗分有二。细分有六。粗分二者。初至众生与虚空性俱无实来略辩空相。如人说下广显空相。细分六者。略中有三。一法说明空。二空名无下喻说明空。借世太虚类显理空。三众生性下举浅类深。以众生空类显法空。下广文中还广此三故有六分

就前略中先释初段。若是无物名虚空者牒前慧眼所见无法说以为空。此说本来自体无法以为虚空。非是有物除以为空。如是虚空名为实者辩真异伪。不同妄情破法为空故名为实。以是实故名常无者明空非始本来常寂。不同对治破有始空故曰常无。又此空理不同诸佛果德常住故曰常无。以常无故无乐我净彰空异有。不同有法有我乐净是以言无。又亦不同妄情所取我乐及净故说为无。非无理净。第二喻中空名无法无法名空牒前法说。譬如世间无物名空举喻类显。世间太虚是其本来自体无物。与彼法性理空相似故举类之。虚空之性亦如是等辩法同喻。第三举浅类深之中。众生之性与虚空性俱无实者。生空是其众生之性。虚空是前所辩法空。浅深虽殊俱是本来自体无性故名为空

上来三段略辩空义

下重广之。文亦有三。一广显前法。二如世间下广显前喻。三犹如世下广前第三举浅类深。就初段中两征两释。初何以故征前法说以起于后。前法说中说言无物名为虚空。复言此空名为常无。故今征问。无物名空何故言常。下对释之。如人说言除物作空举他异说。而是虚空实不可作破之显理。以不可作故名为无。言何以故乘言重征。菩萨观解破相为空。今何以故言空叵作。下对释之。初先正解无作之义。若可作下破作成无。前中初言无所有故正解无作。空是无法云何可作。以无有故当知无空是虚空性牒以结之。以彼虚空无所有故当知自体无法之空是虚空性由是叵作。破有作中若可作者举他所立。则名无常征以显过。若无常者不名虚空责以显非

上来一段广前法说。自下第二广显前喻。何故须显。前举太虚以类理空。一切世人多说太虚别有体性。若别有性不得名空。便乖所说。今须破有以成无义。故须重显。文中初言如世人说虚空无色无碍不变。是故世称虚空之法为第五大举他所立。而是虚空实无有性破之显无。以光明故故名虚空实无虚空释有显无。光故名空是释有也。实无虚空是显无也。世人于彼日光明中见无异物便生空相说言有空。而此虚空实无所有。此说实无为虚空矣

自下第三广前略中举浅类深。前举生性类空无性。今举世谛助以显之。如彼世谛实无其性为生说有。虚空如是实无其性。为众生故说有虚空

前正辩空。下举涅槃类以显之。于中有五。一正举涅槃为类前空。二涅槃即下简有异空。三涅槃虽下因明涅槃常乐我净。乘彰涅槃寂乐非受。四诸佛下因明涅槃寂灭之乐。乘明佛等乐相差别。五德王白下于前义中有难解者问答重显。初中涅槃亦复如是总举类空。无相义齐故云如是无有住处。直是诸佛断烦恼处故名涅槃辩相续空

第二句中涅槃即是常乐我净简有异空。何故须简。前说虚空无我乐净。今说涅槃亦如虚空。惧畏世人取彼涅槃全同虚空无我乐净故须简之。简之云何。空是无理无我乐净。涅槃果德体是有故具足四义。是故说言涅槃即是常乐我净

第三句中涅槃虽乐非是受乐是寂乐者。前说是乐惧同世受故复辩之。于中先明虽乐非受。后明唯是寂灭之乐。分相如是。若据摄相。佛智即是大涅槃中波若所收。是即涅槃亦有知乐。故上文中宣说涅槃具足四乐断受寂灭觉知不坏。今说非受当前断受。今说寂灭当前寂乐。觉知是佛故今不论。不坏是常所以不辩

自下第四因前宣说涅槃寂乐。乘明佛等乐相差别。佛有二乐。灭离诸苦故有寂乐。证法适神故有知乐。实相世谛义通染净故有三乐。就生死法宣说实相则有受乐。就佛果德宣说实相则有寂乐及觉知乐。佛性体寂唯一寂乐。以未显故无觉知乐。以当见故得菩提时亦有菩提觉知乐也

自下第五于前义中隐者重释。何故须然。如来昔说身智尽处以为涅槃。今说诸佛烦恼尽处是其涅槃。二言相乖故须重释。又佛昔说烦恼断处身为涅槃。今此宣说涅槃如空体无所有。两言相异故须辩释

德王先问。问中初别。后总结呵。别中有五。相从为三。尼连告魔是第一句。菩萨已断是第二句。昔告生名是第三句。毗舍告魔是第四句。为力士说后夜涅槃是第五句。相从三者。前之两句执彼身智尽灭之处以为涅槃。难破烦恼断处为是。第三一句执惑断处身之与智即为涅槃。难破向前涅槃如空无有住处。后之两句还执身智灭为涅槃。难破烦恼断处为是

初句难中若烦恼断是涅槃者是义不然牒以总非。何以下释。先自征责。如来往等举佛昔言征以显非。如来昔日断烦恼竟而言未入明断非是

第二句中曲有两句。若断是者诸菩萨等于无量劫已断烦恼何故不得称为涅槃。是第一句准上责下。佛断得是菩萨亦断以何义故不名涅槃。此亦即是准下征上。菩萨断处不名涅槃明佛断处亦非涅槃。俱是断处何缘独称诸佛有之菩萨无耶。是第二句举同责别。断处不殊何故佛有菩萨偏无。此亦即是准下验上。菩萨有断而无涅槃明佛涅槃非是断处。此之二句下佛别答宜审记知

第三问中执惑断处身之与智即为涅槃。难破向前涅槃如空无有住处。若断非者逆取佛意。恐佛被征说惑断处身非涅槃。故举难之。何故如来昔告生名我今此身即是涅槃举说以征。昔说身是云何上言涅槃如空无有住处

第四句中先举魔请。次举佛答。下就设难。于中先难身尽为非。若断已下难其烦恼尽处为是

第五句中若使尔时是涅槃者重审如来。云何以下征已显非。断烦恼时已是涅槃。云何方为拘尸力士说言后夜当般涅槃

上来别难。如来诚实云何发是虚妄之言总以结呵

下佛释通。先对未后结呵之言而自免过。如汝言下依前别问而为广答。前中若言得广长舌当知如来于无量劫已离妄语正自免过彰已非虚一切佛下举他类已成已非虚

后释难中答之不尽而复不次。前五难中但答三句。第三第五略而不答。故云不尽。不尽所以后当别解。就所答中先答第四次答第一后答第二故曰不次

答第四中义意云何。明已先来断烦恼处实是涅槃。涅槃常恒无有变易随化众生唱言当般。就此答中先解魔昔请灭所由。尔时我诸声闻已下明已昔日许灭所以。初中汝言波旬请者牒上问辞。下对辩释。于中先明魔不知真故请我灭。初法次喻后合可知。如来不说佛法僧下明已体常成魔不知。文有三番。一就三宝明常无差。三宝相别故佛不说。佛等无差常净义等故说无差。常无差故佛体是常。魔不知此故请我灭。二就佛佛性及与涅槃明常无差。此三义异故佛不说此等无差。以其因果人法别故。常恒不变彼此齐等故说无差。常无差故佛体常住。魔不知此故请我灭。三就涅槃实相二法明常无差。此二义别故佛不说此二无差。义如上辩。常恒不变彼此齐等故说无老。魔不知此故请我灭释许灭中初为恶人许魔当灭。悬见已下明为善人许魔当灭。前中初先正为恶人斗诤违佛故佛唱灭。因如是下约前唱灭乘明愚智取舍得失。是故我于毗舍离下明已昔日唱灭所由。初段可知

第二段中文别有六。一明如来因恶比丘唱言当灭声闻弟子不见不闻谓佛实灭。二　唯菩萨下明诸菩萨常见常闻不言佛灭。三声闻弟子虽复言下明前声闻所见不实虽言如来入般涅槃佛实不灭。此三为本。四若我所有声闻已下就前第一明妄取失非我弟子是魔伴党。五若言如来不入已下就前第二明正取得真佛弟子非魔伴党。先顺后反。六如长者下就前第三广明声闻所见不实。有五复次。皆先立喻。后合可知

第三结中是故我于毗舍告言当涅槃者。前二段中就初以结。是我为彼恶比丘故告言涅槃。上来明为恶人唱灭

自下明为善人唱灭。于中明为七种善人故唱当灭。始从迦叶乃至须那顺跋陀罗竟安居已至我所者过夏安居。案此如来秋中涅槃。阿含经中说佛八月八日涅槃与此相应。而此经中上下多说二月涅槃。当是见闻不同故尔。此释德王第四难竟

次释初难。答意云何。明已先来断烦恼处已是涅槃。为益众生未息化迹。故昔告魔未入涅槃。文中初言何缘我昔尼连告魔自问起发。下自解释。明已欲为七种善人宣说法要故不许灭。所为无量且举斯耳

有名已下答第二难。难中两句。菩萨已断何故不得称为涅槃是第一句。俱是断处何故佛有菩萨无耶是第二句。今此别答。先答初句。涅言不下答第二句。就初句中答意如何。明诸菩萨断烦恼处得名涅槃。但不见性断烦恼故不得名大。就后句中答意云何。明其涅者但是不义非是断义。菩萨虽复断诸烦恼不能不生不得称可涅槃不义。是故佛有菩萨无也。答意如是

就前句中先明菩萨断处非大。后明如来断处是大。明菩萨中有名涅槃非大涅槃略以标举。云何下释。先问后解。两义释之。一不见佛性而断烦恼断不究竟故不名大。二不见性故所得涅槃但有乐净而无我常。四义不备故不名大。下明佛中若见佛性断恼名大翻向初句。以见性故名常乐等翻向后句

答后句中初先定其涅槃名义是不非断。断烦恼者不名已下依名显法。前中文有十一复次。初七后四如来自解第八一番取他所说证成不义。然此文中涅定名不。初句中辩余更不论。槃含多义句句皆异

下显法中明断烦恼非是不义。故断烦恼不名涅槃。不生烦恼是其不义故名涅槃。断烦恼者不名涅槃释上难中菩萨无也。不生烦恼释上难中独佛有之。问曰何故菩萨断结不名不生。诸佛断处偏名不生。释有三义。一就惑分别。菩萨虽复随分断结断之不尽心中更起故非不生。佛断穷尽永更不起故曰不生。二约心分别。菩萨虽复断粗烦恼。七识心在心性生灭故非不生。佛唯真心。真心常住故曰不生。三约理分别。菩萨见有烦恼可断非本不起故非不生。佛证法如知诸烦恼由来不起亦无今灭故曰不生。问曰德王前为五难。上答其三。第三第五何故不释。答上第二第四难时余二可解为是不答。云何可解。如来答向第四难中言为力士告魔当灭。与第五中为力士说后夜当灭其言相似何劳更答。又复答前第二难中明烦恼断或名涅槃。或复说之为大涅槃。第三句中难破烦恼断处为非。其义已显何劳更释。故无别答

上来第一通就诸法以彰七别。自下第二就佛论七明七无别。于中就佛但明五义。法僧二门略而不辩。佛不起恼名涅槃者就佛以明涅槃之义。智慧无碍名如来者就佛辩释如来之义。非凡夫等名佛性者就佛解释佛性之义。身心智慧满无量土名虚空者就佛解释虚空之义。常住不变名实相者就佛解释实相之义。以是如来不涅槃者以佛常住不变易故。实不毕竟永入涅槃是名第七总以结之

第八德中初问起发。次辩。后结。辩中宣说八法为体。今先辩列。下广释之。八中前七摄行方便。后一成就。就前七中初二是其离有为行。次三是其求菩提行。后二是其摄众生行。就前二中除五事者断除五阴离生死果。离五事者远离五见灭生死因。又除五事离生死法。远离五事除障道法。又除五事离生漏处。远离五事正除漏体。次三种中成六修五趣菩提行。谓成六念修习五定。守护一事摄菩提愿。后二种中亲近四事化众生心谓四无量。信顺一实度众生法谓一乘道。此七方便。下一成德。断除五住性结烦恼。真心出障名心解脱。离事无知世智自在名慧解脱

下广释之

解初门中先问后释。释中有五。一总标举。二列五名。三总释阴义。先问次解。六义释之。能令众生生死相续不离重担。此之二义就过解释。依之造因故令众生生死相续。依之受报故令众生不离重担。分散聚合。此之二句当义正解。阴是众义亦是聚义。分散众也。聚合聚也。细分无量故曰分散。合说为五故云聚合。三世所摄。求义不得辩阴性相。阴相无常故三世摄。阴性虚假穷本无实故求不得。以是下结

四别显阴相约智显之。先明色阴。色中初先明其非有。为世说下彰其非无。明非有中虽见色阴不见其相略明非有。辩有兼无是以言虽。何以下释。于十色中求性不得故不见相。五根五尘是其十色。此经上下多说十色不论无作。当以无作色相微隐成身不显故不说之。上明非有。为世界故说言为阴明其非无

次明受阴。受有百八明受非无。受中离合多少不定。或总为一。唯一受阴。或分为二。身受心受。依五根生名为身受。依意根生名为心受。或说为三。谓苦乐舍。或离为五。所谓苦乐忧喜及舍。于五识中逼恼名苦。适悦称乐。意识地中逼恼名忧。适悦称喜。六识地中中容受心说之为舍。或分为六。所谓六识相应之受。或分十八。于六识中各具三受苦乐及舍。或复分为三十六受。前十八中各有染净。或分百八。如龙树说。前三十六三世分之。广则无量。今据一门且论百八。虽见已下明其非有。虽见初无略明非有。辩有兼无是以言虽。何以下释。无实故无。是故下结

后想行等略举类前。同前色受非有非无故曰如是。此第四竟五明菩萨观过断除。深见五阴。生烦恼本方便断之

次离五事。先问后辩。辩中有四。一举五数。二列五名。此义如彼十使章辩。初身见者亦名我见。取身为我。从其所取故名身见。计身为我。从其所立故称我见。言边见者断常差中故说为边。谤无因果乖违法理故名邪见。言戒取者亦名净见。取戒等法以为真道。从其所执故名戒取。取为真净。从其所立故名净见。今从所执说为戒取。然此非直取戒为道。亦取布施礼拜等善以为真道。取戒者多但名戒取。故杂心云此应名为戒等取也。经中略等但云戒取。言见取者取诸见。等以之为正以为第一故云见取。然此非直取着诸见。亦取梵天自在天等以为第一。出世之法取见者多且云见取。故杂心云此亦应名为见等取。经中略等但云见取。第三明其五见之过。因是能生六十二见增烦恼过。六十二见出梵动经。如别章说。因是诸见生死不绝生苦之过。四是故下明诸菩萨见过断除。以是五见增长烦恼生苦果故防之不近

次解成六。初问。次辩。后总结之

次辩修五。先问后释。释中五定总以标举。次列五名。五中前四是其事定。知定初禅。与觉观俱故名为知。寂定二禅。觉观止息故说为寂身心快乐是第三禅。彼乐最胜故名快乐。无乐四禅乃至非想。首楞严者是其理定。名如下释。修是五下明修利益。是故下结

次明守一。先问后辩。辩中初言谓菩提心出一事体。菩提心义如别章辩。菩萨常下明其守护。初法次喻后合可知。因如是下明护利益。是故下结

亲四事中先问后辩。谓四举数。慈等列名。因是四下明修利益。是故下结。次明信一。先问后辩。了知众生皆归一道一谓大乘正明信一。诸佛已下知一为三三而是一。是故下结

下明二脱。初先正辩。德王言下问答重显。前中初言云何心脱问以起发。贪等永灭是名心脱对问辩释。贪恚痴等是其五住性结烦恼。断绝此故真心得脱。云何慧脱问以起发。于一切法知无障碍名慧解脱对问辩释。事中无知能障世智。以断彼故能于一切世谛法中知无障碍。下就其中开出五通显于一切无障碍义。因慧解脱不闻而闻是天耳通。不见而见是天眼通。不到而到是其身通。他心宿命略而不辩

自下问答重显向前心解脱义。何故须显。心定有贪则不可脱。心定无贪则不须脱。性无相有方有脱义故须重辩。德王先问。如佛所说心脱不然牒以总非。何以故下广显非义。先征非意。下对显之。文别有三。一约真心明本无贪难无解脱。二贪亦有下约就妄心明本有贪难无解脱。三心不定下明心及贪人及境界一切不定难无解脱。三毒之中约贪设难。余类可知

就初难中有九复次。初一复次总明无贪亦无解脱。中六复次偏明无贪。后二复次单明无脱。初复次中先明无贪。后明无脱解。无贪中心本无系正明无贪。所以下释。先征起发。现见有贪所以言无。下对释之。是心本性不为贪等诸结所缚故言无系。何者心性。废真论妄空为心性。穷其实体真识为性。如昏梦心报心为性。说空为性亦无系缚。说真为性亦无系缚。如人梦中虽被系缚于报实无。上明无缚。若本无系云何言脱明无解脱

中六复次明无贪中。前五复次就真以求明心无贪。后一复次明妄异真贪不污心。先论前五初复次中初先法说明心无贪。次喻后合。法说可知。喻中初言如人[穀-禾+牛]角本无乳相虽加功力乳无由出顺喻明无。角喻真心。人喻惑境。惑境动心名为[穀-禾+牛]角。真心无贪名无乳相。虽对尘境贪结不生名加功力乳无由出。[穀-禾+牛]乳之者不如是下反喻明无。举有显无故说为反。乳喻妄心。妄境牵心名[穀-禾+牛]乳者。不同真心本性无贪名不如是。下显不相。暂对尘境名加功少。贪结多起名乳多出。亦可后句[穀-禾+牛]乳之喻举彼世间有事显无不须别合。下合显法。心亦如是合前角也。本无贪者合本无乳。今云何有约前加功乳无由出征破有贪

第二句中举佛菩萨类破凡有。若凡心中本无贪性后方有者。诸佛菩萨本无贪相今悉应有。佛菩萨无不可使有。凡心本无何缘得有

后三句中皆先立喻。后合明无。文显可知。后一明妄不污真中当知贪心二理各异故复有之何能污心法说不污。贪妄心真。真妄两别故言各异。以各异故设有贪结不能污彼真识之心。次喻后合。此六复次偏明无贪

下二复次单明无脱。于中初句以喻无贪难破有脱。若心无贪名解脱者诸佛菩萨何故不拔虚空中刺。空中无刺不可得拔。心中无贪云何辩脱。偏征诸佛菩萨不拔。明空无刺毕竟叵拔。后句约就三世推求明无解脱。于中初法。过去世心不名脱者过心已灭故无解脱。未来世心亦无脱者未来未至故亦无脱。现在世心不与道共明现无脱。惑心现时道心不现云何得脱。何等世心名解脱者总以结征。次以喻显。喻中与法言有左右。向前法中明所缚心三世无脱。喻中乃说能破之灯三世无破。有此左右。下合可知

自下第二约就妄心明本有贪难无解脱。有七复次。前五明其心中有贪。后二明其缘中有贪。就前五中初一复次睹缘生染证贪是有。第二复次非缘生染证贪是有。第三复次举脱证有。第四复次释难成有。第五复次举无显有

初复次中贪亦有者总相明有。若贪无下破无成有。若因女下约缘显有。见女生贪明贪实有。以贪堕恶举果证有

如见画下第二复次非缘生染证贪是有。见画生贪正明贪有。画女非是可贪境界而见生贪。明知心中先有贪性。以生贪故得种种罪举罪显有。若本无下破无成有。破相可知

若心无下第三复次举脱显有。若心无贪如来云何说心解脱。说心脱故明贪实有

若心有下第四复次释难成有。若心有贪云何见相然后生贪举他难辞。我今现下对难释通明贪是有。现见贪心得恶果报明贪非无。嗔痴如是类显余结

如众生下第五复次举无显有。举无神我显有贪也。如生无我凡夫横计不堕三恶是举无也。云何贪者于无女下是显有也。是义云何。众生身中无神我故凡夫于中虽横计我不堕三恶。若使贪结同我实无起贪之者亦应同前不堕三恶。云何贪者堕三恶道。贪者堕恶明贪是有不同我无。言意如是。然计我者论说不同。依如成实亦堕恶道。毗昙宣说身边二见是无记故不堕三恶。今说与彼毗昙义同。地持亦尔。故地持云起身见人不谤所知不因此见堕于恶道。正与此同。言无女中生女想者。画像非女世人见之生女想也。何故不举女中生贪堕三恶道偏举此乎。为显堕恶专由心中所有贪性不由境生

上来广明心中有贪。下二复次明缘有贪。前一复次正明缘有。后一复次约人明有。前中先喻。譬如钻木而生于火喻明缘有。然是火性众缘无下破无成有。下合显法。贪亦如是合钻生火。色中无下合向后句破无成有。后复次中若缘无贪举他无义。云何已下破无成有。破之云何。色等缘中有贪性故凡近生贪。圣远不生。道理应然。若众缘中无贪性者凡夫近之亦应不生。云何众生偏独生贪佛等不生。众生近缘偏独生贪明缘有贪

自下第三明心及贪人及贪境一切不定难无解脱。以不定故出则还没云何解脱。于中有三。一举心不定难破解脱。心亦不定立不定义。若心定下难破他定。定则不变云何得有贪嗔等别。若不定下以心不定难破解脱。心不定故出则。还没云何得脱

二举贪不定难破解脱。贪亦不定立不定义。若不定者云何因之生三恶道以已不定难破佛定。贪既不定云何世尊说因贪心定生三恶。是中亦应以贪不定难破解脱。文中略无

三举人举境二种不定难破解脱。贪者境界二俱不定立不定义。贪者是人。境是外缘。何以下释。俱缘一色生患各异故知不定。是故下结。若俱不下牒前不定难破解脱

下佛答之。先叹后释。释中有二。一辩理总答。二有外道下随问别答。总中初言是心不为贪结系者心性净也。亦非不系心相染也。非解脱者对前不系明非除障始得解脱。非不脱者对非不系明其从缘有始脱也。言非有者心性本净无缚解也。言非无者从缘染净有缚脱也。言非现在非来来者体净平等离三世也。亦应说言非不过去未来现在。文中略无。何以下释。以一切法皆无自性是故不得一向定说

下别答中大判有四。一破邪归正。二佛菩萨终不定说因有果下辩正异邪。三若言因中先定有下重非前邪。四诸佛菩萨显中道下重明前正。初中有三。一前举第二本有之执呵以显过。二复言凡夫心有贪下举前第三不定之执呵以显过。三有凡夫复言因中悉无果下举前第一本无之执呵以显过。何故不次。一切凡夫执有者多先举以非。执无过重后举广呵。不定之执无此两义据中而辩为是不次

前中有二。一明凡计有。二一切。凡夫无明盲下呵以显过。前中有四。一执因有果。二若众缘中本无性下举空显有。三所以下显前第一。四唯有虚空无取已下显前第二

初中外道作如是言因缘和合有果生者以因生果证本有性

第二段中若众缘中本无生性而能生者举他无义。下将虚空对之显有。虚空无生亦应生果征空齐有。俱是本无何故不生。虚空不生非因已下辩有异空。异相如何。空不生果由其非因。有法是因明有果性。以众缘中有果性故合则生果

第三段中所以者何征前起后。此有见人自征立意。下对显之。句别有四。一以人取证因有果。二若无性下破无成有。三若是可取可作已下结成第一。四若无果下结破第二。就初句中先举世人所取之事。次以人取明能生果。后以生果证性本有。文皆可知。第二句中若无性者举他无义。一物之中应生一切破之成有。等是无性。彼泥土等一物之中何故不生彼墙壁等一切诸物。不生异物但生一物明知所生非本无性。第三句中若可取者彼泥土等是可取也。言可作者如彼泥土可作墙壁彩作画像缕作衣等。言可出者泥土出墙彩出像等。当知是中必先有果结成有性。第四句中若无果者举他无义。人不取等对之以破。翻前可知。所以至此合为第三。显成向前第一段中执因有果

自下第四举空显有。显成向前第二段中举空显有。于中初言唯有虚空无取作故能生一切明空异有。无人取空空不作物名无取作。以有因下彰有异空即事显之。尼呴陀子唯得住于尼呴陀树不住余树明知彼树先有子性。此名树果以之为子非是种子。余亦如是

上来广举凡夫有见。一切凡夫无明所盲作是定说色有着义心有贪性呵以显过

自下第二举前德王不定之执呵以显非。复言凡夫心有贪性及解脱性遇缘生贪及解脱等举其所立。虽作此说是义不然呵以显非。此言似正而复非理故言虽说。心之体性随缘定缚遇缘永脱非全不定。所以不然

自下第三对前德王本无之执呵以显非。先举无见。无见有二。一无果见。二有凡复言心无因下明无因见。无果见中有凡复言一切因中悉无有果总明无果。因有二下别释无果。揽因成果更无别体故言无果。先举二因。粗细列名。常与无常辨其二相。细者所谓邻空微尘。不可分张不可破坏故名为常。粗谓粗尘。可分可坏故曰无常。从微细下明因成果彰果无常。于中先明从微细因转成粗因如从细尘集成粗尘。次明粗因集成粗果如从粗尘成埿团等。后明粗因是无常故成果无常。以细微尘分于粗尘。粗尘不立名因无常。将此粗因分埿团等彼复不立名果无常

下明无因。有凡复言心贪无因举他无义。以时节下释成无义。随时节生明本无因

下佛呵之。偏就向前无因以呵。向前宣说心贪无因。今且说心明无因过。贪类可知。文中有三。一明宣说无因有损。二何以下彰彼凡夫说无所以。三以不观下结以显过。前中初先法说彰损。如枷下喻。喻别有五。初之一喻别举别合。后之四喻并举总合。第二段中初何以故征问起发。何故凡夫说心无因。下对释之。唯观果报不观因故。初先法说。次喻。后合。结过可知

上来第一破邪归正。自下第二辩正异邪。终不定说因中有果不同向前有见人也。因中无果不同向前无见人也。及有无果非有无果不同向前不定人也

自下第三重非前邪若言因中先定有果及无果等牒上邪说。皆魔伴等非以显过。魔伴属魔明有结业。即是爱人明有烦恼。不断生死明有苦报。此明无行。不知心贪彰其无解

自下第四重显前正。于中有三。一对前德王本有之执明其妄心因缘之法性非本有。二是心不与贪结合下对前德王本无之执明其真法性非本无。三一切众生从缘贪下对前德王不定之执明非不定。初中有二。一对前外道不知心相明心缘性非是本有。二终不说心有净下对前外道不知贪相明贪缘生非是本有。前中初言诸佛菩萨显示中道总以标举。何以故下以非有无释成中道者。何以下释非有无。六识心中且就一种眼识释之。余类可知。句别有四。一正明眼识非有非无。因眼色等而生眼识所以非无。不在眼等所以非有。二结非有无。非有结前不在眼等。非无结前因眼等生。三从缘下释非有无。四是故下结非有无

涅槃义记卷第七应永三年八月十日加修复拭老眼补阙字可哀可哀　　　　　法印权大僧都贤宝(生年六十四)翌年十二月中出御室御经藏本誂隆禅僧都补阙字了颇以证本也可喜可喜涅槃义记卷第八

        隋净影寺沙门释慧远述

自下第二明贪缘生非是本有。通脱说之。于中有三。一略明贪脱从缘集生非是本有。二从缘生贪从缘脱贪广辩其相。三以是义故诸佛菩萨不定说下总以结之

前中初先开列二门。终不定说心有净性是其一门。及不净性复为一门。次总释之。净不净性无住处故不作定说。下别释之。从缘生贪故说非无明无净性。本无贪性故说非有明无染性。广中初先开列两门。从缘生贪则为一门明无净性。从缘心脱复为一门明无染性。次列二缘。先标后列。随于生死是其染缘。随大涅槃是其净缘。下约二缘对贪明脱四门辩之。先列后解

于初门中先问后释。此门偏就凡夫说之。若凡未断修习贪心如是之人共贪生灭就起者说。现起贪欲名为修习。一切生下就成者说。于中初法次喻后合。下重释之。法中一切不断贪心共生灭者。有人虽复得定伏贪而未断除。使性在心故共生灭。次以喻显。欲界众生一切皆有初地味者此名初禅。以为初地。禅有三种。一者净禅。所谓上界有漏净心。二无漏禅。谛理之静。三者味禅。分别有三。一就通以论。初禅地中一切烦恼通名味禅。味着境界故名为味。禅地法故说之为禅。二偏就爱说。爱心着境与定相似说为味禅。三正论体。为上界中烦恼心边相应定数是味禅体。故杂心云。味为爱相应。味禅如是。此之味禅欲界众生皆具有之。一切染法味断已来在下其必成就上故。问曰。何故偏说味禅。净及无漏修习方有。不同味定身在下地于上地中未断之处性常成就。故取为喻。问曰。味禅下皆成上。以何义故偏说初地。且举初地余类可知故略不论。又问何故偏说欲界众生皆有。欲界众生望初地味未起而有。似彼贪欲不起而有。故偏举之。在初禅者现起说有理在易知何待言论。二禅已上不成下味为是不说。若修不修常成就者显前皆有。遇缘得者显前成就。言因缘下显前缘相。次合后释。文皆可知

次释第二。先问后解。此门约就三人释之。一就声闻外凡中说。有缘生贪骨观治之名不共灭。此望起惑。若望使性。骨观不除犹与贪灭。二就声闻内凡上说。暖等已上未证四果有缘生贪。证果时灭。向中亦灭就显说果。三就不动菩萨释之。得不动时心共贪生不共贪灭。从前七地入八地时名得不动。前七地中有。爱佛心名共贪生。八地舍之名不共灭。故地经云。佛心菩提心涅槃心等一切不行。况世间心

次释第三。先问后解。此门唯就菩萨释之。自无贪爱名不共生。随他现起名共贪灭

次释第四。先问后解。此门约就四人释之。一就罗汉。二就辟支。三就如来。四除不动就余菩萨。何故如是十地菩萨分为三阶。初至七地功用之位合为一阶。恶贪为过。善贪为治。未说为患。于此位中不善之贪一向不行。故不共生亦不共灭。善贪非患故不说之。八地菩萨独为一阶。善贪为患。无贪为治。于此位中始背。善贪未能舍离名共贪生。终能除尽名不共灭。非是一向不共生灭故今除之。九地已上合为一阶。望彼善贪一向全无。是故说为不共生灭。以有是义故除不动。其余菩萨悉皆名为不共生灭

前略次广以是义下第三总结。以是义故不决定说心有净性及不净性

自下第二对前德王本无之执明非本无。真识之心本为惑覆。非先无染。而不与彼贪结等合。非本无净。本有染故所以可脱。文中有二。一就凡时明心相染而体性净。二诸佛菩萨永破贪下约就前义明有解脱。前中初法次喻后合。准喻法中文少不足。若具应言是心虽为贪欲嗔痴之所覆蔽而不与彼贪结等合。文中直明不合便罢。被覆不论。喻中初言为烟等覆是以不见喻前所少。日月喻于真心之体。烟等喻于贪等诸结。日月虽明而为烟云尘雾等覆。真心如是性虽清净而为惑覆。虽不见下喻前不与贪结等合。烟云尘雾及修罗手是其五翳。下合显法。心亦如是以因缘故生于贪结合前日月为烟等覆。众生虽下合上日月不与翳合。于中初先正明不合。若是下释。贪即贪性明妄异真。不贪即是不贪性者明真异妄。不贪之心不能作贪真不作妄。贪结之心不能不贪妄不作真。以是下结。此义犹是胜鬘经中自性净心不染而染染而不染。此初段竟

诸佛菩萨永破贪等约就前义明有解脱

自下第三对上德王不定之难明非不定。从恶因缘心则定缚。从善因缘心定解脱。故非不定。于中初先开列两门。一切众生从缘生贪是定缚门。从缘心脱是定解门。下广释之。先解初门。初别后结。别中有六。一为魔缚。二五欲缚。三倒见缚。四有见缚。五我见缚。六邪业缚

初中先喻。喻中有四。一法位差别喻。雪山通喻三界出道。人喻诸魔。猕猴喻凡。悬峻之处人与猕猴不能行者喻出世道魔及余凡不能行也。或复有处猕猴能行人不能者喻上二界余凡能到魔不能至。或复有处二俱能者喻欲界地魔及余凡皆能行也。举此为取□□住处。就之以显魔能惑凡

二诸魔惑凡喻。人与猕猴能行处者牒前第三。猎师以胶置案上者以五欲胶置于人天之案上也。捕猕猴者用惑凡也。问曰。五欲众生业果何关魔事。说魔以欲置人天案此非一切。今此且举魔所作者。如魔将女惑持世等。三凡夫被惑喻。猕猴痴故往手触者。五根之中多先以眼视其色也。触已粘者见生爱也。言欲脱者五根取境互相易代名为欲脱。非欲解脱。触境皆贪斯名粘着。如是五处悉无脱者于五根中皆生着也。四为魔摄持喻。猎师杖贯负还家者邪法之杖入心名贯。摄为魔民名负还家

下次合之。文别有五。初言崄者喻佛菩萨所得正道合初段中悬峻之处。二猕猴者喻诸凡下合第二段。向前说言人与猕猴能行处者猎师粘胶置之案上故今合之。猕猴喻凡。猎师喻魔。黐胶喻于贪欲境界。文中略故但言喻贪。三人与猕猴俱不能下重合初段。四凡夫之人五欲缚下合第三段触皆被粘悉无得脱。五令魔波旬自在将下合第四段杖贯负归。先合后帖

上来魔缚。如国王下是其第二为五欲缚。得失相显。先喻。次合。后重辩之

云何名为系属魔下是其第三为倒见缚。先问。次辩。后总结之

复次若见诸法真下是其第四为有见缚。有见犹是法着我心。先辩后结。复次若见我是色下是其第五为我见缚。此乃宣说二十身见为我见矣。先辩后结

我声闻下是其第六为邪业缚。初辩后结。辩中初言离十二部修外典籍明无正解。不解出家寂灭业等明无正行。上来六门广明被缚。以是因缘心共贪等总结显过。下次广上。从缘解脱亦非不净是故我说心得解脱总以标举。次别显之。前六缚中但翻后门。若不受等明其行正。为涅槃等彰其解正。当知是下总以结叹。是名第八总以结之

第九德中初问。次辩。后总结之。辩中具以五德为体。初先总举。次列。后释。下叹其能。菩萨修经初发五事是总举也。于十德中后四胜进胜中初一修习对治。次一明其对治成就。次一明其正道修习正道成就。此德是其修习正道。望后道成说以为初。是故名为初发五事。次列五名。先征后列。信者是其摄行方便。于法决定故名为信。后四正行。前二摄福。为善不曲名为直心。防过不作说之为戒。后二摄智。亲师求法名近善友。闻法博受故曰多闻。下广释之。信中初问次解后结。辩中有三。一对境辩信。二若沙门下叹以显胜。三虽有下明信离相。初中先辩。后总结之。辩中有八。如地持说。信佛法僧即以为三。信佛菩萨神通之力通前为四。信因及果通前为五。信真实义通前为七。谓信菩提有大义利。信得方便通前为八。谓信菩萨所修学道。今此所说与彼地持大同少异。信于三宝是彼初三。施有果报是彼第五。信因信果信二谛者是彼第六。信真实义信一乘道为生分三。彼中略无。亦可此言即是彼中信佛菩萨神通力也。分一为三是说自在。亦名神力。信第一义是彼第七信得义也。无上菩提义利中极名第一义。非是理义。理义是前二谛中收。信善方便是彼第八得方便也。自下第二叹以显胜。若沙门等所不能坏叹其信坚。得圣人性叹信所成。有此信者堪为佛种名圣人性。修行施等得近涅槃不堕生死叹信利益。能离生死近大涅槃。初就施论。后类戒等。是名下结

自下第三明信离相证实以成。故虽有信而亦不见我有此信。是为初事总以结之。次释直心。文别有二。一就外化明其直心。二复次云何质直心下就自利行以明直心。前中先问次辩后结。辩中初论。德王白下问答重显。前正论中文别有二。一明菩萨正直不曲。二虽见下明心虽直而巧随物不同世人愚直恼他。前中于生作质直者明修直心。一切生下明离曲心。一切众生遇缘生曲举凡显圣。菩萨不下辩圣异凡。菩萨不尔正明异凡。何以下释。善解诸法悉因缘者解知邪曲是生死缘。巧随物中初明菩萨见恶不说。何以下释。后明菩萨见善赞叹。云何下释。先出善体。后显赞意。为令众生闻性发心。下重显前赞性令人发心之义德生先难。难意如何。明有佛性自然得佛何假赞叹。文中初言如佛所说菩萨赞性令生发心是义不然牒以直非。何以故下广释显非。先征非意。下对辩之。辩中先牒上三病人。若言遇已下就所牒中将上类下明皆自得不假叹性。就牒前中有喻有合。今先牒喻。如来初开涅槃经时说有三种总以标举。如来向前现病品中说有三人。故今指彼为初开时。说学行中彼为始也。下别牒之。一切众生亦如是下牒上合文。众生如是是总合也余是别合。先合中人。次下后上。何故与前所说不次回上在后。欲约设难故不同前。下就设难。初言遇与不遇悉发如来云何说言赞性令生发心。就前所牒上人设难。若过不过。悉不发下就前所牒下人设难。执上类下明皆自得不假赞性。于中难辞有六复次。相从为四。难辞六者。一明阐提有性得佛。难破佛说不作佛义。二如说何等名为一阐提下明一阐提性善不断。难破佛说断善根义。三如佛昔说十二部下明其阐提性善常在。难破佛说入地狱义。四佛性不断非阐提下明性不断。难破断善作阐提义。五若因佛性发菩提下明有佛性自然向佛。难责如来为说法义。六从佛说因果性下明其因中定有果性能得菩提。难破佛说因无果义。相从四者。第四一难与第二同。第五一难与初难同。故下无答。宜审记知

就初难中名遇不遇。悉不能发是义不然牒以直非。何以下释。如是之人当得菩提略释显非。第二难中初牒如来断善之言直非不然。何以下释。不断佛性略释显非。性理不断云何说断重释显非。第三难中先牒向前初功德中所说二善常列其名字。下就设难。无常可断可堕地狱。常善不断何故不遮。第四难中佛性不断非一阐提自立道理。如来何故说言阐提非破佛语

第五难中若因佛性发菩提者直举道理。何故为说十二部经责佛为说。譬如已下广明有性自然得佛成说不应。有两复次。前中先喻。后合显法。菩提之心亦如是者明诸众生但一发心佛性力故自然得佛如河赴海。不假如来为说方得。后中先喻下合可知

第六难中先牒直非。如佛所说因中果性非有无者是义不然。何以下释。先征后辩。初就譬喻明因有果成佛不然。以是下结

下佛答之。先叹后释。叹中初言善哉总叹。有二下别。先叹问益希中泛举六种二人明皆希有。为取第六举余类之。益中转法显正之益。枯十二等破生死益。能与魔下摧邪之益。下释难辞。释意如何。如中品人值友闻法则能发心。不值不闻则不能发。我就此人说赞佛性令其发心。不为上下。文中有四。一辩释三喻。二约显法。三一阐提亦得已下释去难辞。四结已须赞。初段可知。第二段中约喻显法。上品人上难辞即遣。我为中人说赞佛性令生发心。何得就上难我不须。文显可知

第三段中释去向前下人上难。难辞有六。佛但释四。第四一难同于第二。第五一难同于第一。故无别释。解初难中明阐提人亦有得佛不得佛义。舍阐提心即便得佛。不舍不得。不得说言一向定得。于中先明阐提亦得。所以下释。发菩提心非阐提故。下明不得。以何缘故说阐提得征前德王说得之言。实不得者正明不得。如命尽下喻显不得。阐名信下释第二难。于中文别有八复次。辩义唯二。一明佛性不断所由。不入所断善根中故。二明断善为阐提义断绝余善名阐提故。八复次中前六可解。第七番中初明阐提断无常善名一阐提。后明佛性不同所断。佛性是常不同无常为是不断。非善不善不同前善为是不断。于中初明非善不善。何以下释。先解非善。后释非不。第八番中又善法者生已得故明相异性。性非生得辩性异相。以断生得名一阐提就相论断。何者是其生得善乎。信等五根宿习令成。生便得之名生得善。以何义故偏断此善名一阐提。方便之善前已说故。断善根时先起方便邪思惟心。后起九品重恶邪见正断善根。前方便心断方便善。后九重邪断生得善。前第二句就始为言说断方便。此就后说论断生得

下次解释第三句难。如汝所言阐提有性何故不遮地狱之罪牒其难辞。下对释之。明阐提中无有佛性故不能遮三恶道苦。是义云何。果性能遮三恶道苦。因性不能。阐提有因未有果性为是不遮。文中初明阐提无性。阐提无性云何遮下彰其不遮。前中阐提无有佛性法说明无。如王下喻。喻有八句。一众性闻性喻。王喻众生。箜篌喻身。声喻佛性。性净称妙。闻皆爱好名心耽着情无舍离。二即告下随闻推求喻。臣喻如来。众性问佛性之所从名告智臣声出何处。三大臣答下圣为开示喻。说性从于五阴中现名箜篌出。四五复语下请圣求见喻。求见性体名特声来。五臣即答下就因辨果喻。说阴为性开晓总心名持箜篌置于五前。就因辩果故云是声。六王语箜篌出声已下即相求性喻。亦名求性不得喻也。箜篌出声总相求性。求不得方性不显了名声不出。即断弦下别相求性。随一一阴破折分张求性不得名断弦等声亦不出。七王即嗔下不解谤圣喻。八臣白王下圣为解释喻。夫取声者法不如是呵情妄取。以众缘下显示证仪具行方见。名以众缘巧修乃悟名善方便声乃出耳

下合显法。佛性如是合初句中箜篌声也。无有者因菩萨住处合第六句求声不得。方便可见合第八句方便声出。以可见故得菩提者见得成佛也。上来广明阐提无性

下明不遮阐提不见。云何能遮正明不遮。若一阐提有信已下反显不遮。以不信下顺显不遮如汝所说乳无酪下释第六难。先牒难辞。下对显非。于中初法次喻后合。法中愚人作如是说呵邪乖正。智终不言辩正异邪。何以下释。以无性故智不言有。喻中三句。一无缘下出证酪本无。二如水乳下异缘不出证酪本无。三颇求下得缘方出证酪本无。下合显法。佛性如是合乳酪性假缘可见。假缘可得合得颇求即便成酪。待缘后成即是无性合若本有何故待缘。上来广答

以是义故常赞人善名质直心结答上问

前就化他。下就自行明质直心。先问次辩。后叹下结。辩中菩萨常不犯恶离过心直设有过下悔过心直。初明悔过。若人问下寄问显直。有五问答。文皆可知。以直心下叹以显益。信有佛性顺理之益。不名阐提离邪之益。名佛弟子归正之益。若受衣等消施之益。是名下结

次明持戒。先问。次辩。后总结之。辩中初离凡夫之过次离小乘。后修大乘。离凡过中句别有三。一离凡夫异求之过。不为生天不意恐怖而持禁戒。二离外道邪戒之过。不受狗戒鸡牛戒等。三离凡夫毁犯之过。不邪四重名不破戒。离重方便名不缺戒。不犯轻过名不瑕戒。离轻方便名不杂戒。此离凡过。不求小果名为不作声闻之戒。此句明离小乘之过。下明修大。受尸罗戒学戒方便。得具不慢戒成离相

次明近友。先问。次辩。后总结之。辩中先明菩萨善友。次明佛友。我身即是就已总指。是故能断富伽罗下举其性昔十二种事显已真友。以是义下总叹友益令人亲近。何故阿难说半梵行不知性因。从支生故。佛知今善及与往因皆从友生故说具行。是名下结

次明多闻。先问次辩。六番简要令人量分而听受之。是名下结

上来广释。自下第四叹其行能。于中初明依前五种能起自利。如父母下明能利他。前自利中先开三门。难作能作是精进行。难忍能忍是忍辱行。难施能施是其檀行。次辩其相。后明离着虽复能作不念我作就初离着。忍施如是类后两门

下利他中初起慈行。若子遇下明起悲行。于诸众生不嗔喜下明喜舍行。慈中先喻后合可知。悲中先喻。喻中初明有病为治。后不计恩。下合显法。先合为治。终不念下合不计恩。于中初先不念自己为生除恼。先顺后反。唯作念下无念众生可为说法令断烦恼。下明喜舍。于诸众生不嗔是喜不喜是舍。初先正辩。德王白下问答重显。前正辩中初先法说。菩萨于生不嗔不喜略举喜舍。何以下释。以善修集空三昧故不生嗔喜。次以喻显。林喻菩萨。火等喻于能恼之人。而是林下喻无嗔喜。下合可知

下重显之。显前善修空三昧义。德王先问。如来次答。答中不尽下重显之。就初问中先为两定。法性自空是一定也。空空故空是二定也。法体不空以其空观强破使空名空空故空。下就设难。若性自空不应修空然后见空就初设难。云何如来言修见空结非圣言。若性不空虽复修空不能令空就后设难。法体不空何观能空

下佛答之。于中初明法体自空翻答后难。以相似下明由菩萨修空见空翻答初难。前中初言法性本空总立空义。何以下释。先征后解。一切诸法不可得故总释法空。色性已下随法别解。先就色论。后类余法。色不可得总明色空。下广释之。云何色性征问起发。下对辩释。明非有无为色体性。文别有四。一约四大明非有无。二约青等明非有无。三牒正破邪。四结成空义。初中约就地水火风破遣色相。破之云何。色非地等明色非有。不离地等彰色非无。是义云何。色者是其四大家相如镜中像。大是色体如即像镜。就大别分色相不立故非地等四大和合。色相存立故说不离。第二段中约就青等破遣色性。破之云何。非青黄等明色非有。不离青等彰色非无。是义云何。色者正以质碍为性。青黄赤等是色之相。相别碍通。彼青黄等虚幻不真。如阳炎水相有性无。性既不有。知复说何以为定碍故非青等。即就青等义说为碍故言不离。自下第三牒正破邪。非有非无是牒正也。非有牒前非地水等非青黄等。非无牒前不离地等不离青等。云何当言色有自性是破邪也。既非有无云何有性。自下第四结成空义。以性叵得故说为空。此明色空。一切如是类显余法

上来广明法性自空翻答后难

下明菩萨修空见空翻答前难。由凡计有故须菩萨修空见空。文别有四。一明凡夫见有所由。由见诸法续相似相。二明菩萨见空所以。以修向前信等五事故能见空。三若沙门下就前凡夫明有见过。若沙门等举有见人。此等乖理故偏举之。见法不空举有见情。下彰其过。非沙门等明其人非。不得修等彰其行非。谓不能得涅槃因果违圣顺魔。四一切法本自空下明前菩萨修空见空。于中有二。一以法显心。由法性空故令菩萨修空见空。二如盐下以心显法。由习空想故令诸法不空作空。前据真谛故说性空令菩萨见。后就世谛故说菩萨修空三昧不空使空。前中初言法本性空。亦因菩萨修空见空当法正辩。由法性空故令菩萨修而见空。理虽常空。人迷不见。故因修空方始见空。下以喻显。于中先举无常力为喻。如一切法性无常故灭能灭之分段无常。先顺后反。有为之法有生相故生能生之有灭相故灭能灭之是念无常。以色心碍体有可生可灭义故。法外四相能生能灭。下复举其苦义为喻。良以诸法性是苦故苦能苦之。第二以心显法之中先举八喻。如盐性碱喻修空想。心碱异物喻能空法。余亦如是。下合可知

前问次答。于前义中有难解者下重显之。德王先问。后佛为释。问中两门。一对上后段以心显法执法性有难定是倒。二若空三昧唯见空下对向初段以法显心执法定无难定无见。前中德王复作是言若盐能令非碱作碱牒举前喻。修空三昧若如是者牒举前合。后征显过当如是定非善非妙。性是颠倒是乖法理所以非善。定不称法故曰非妙。观有作空故生颠倒。就后难中若空三昧唯见空者牒上菩萨修空见空。下就设难。空是无法为何所见。下佛答中先解初难。汝言空无为何见下释去后难。前中有三。二翻前难辞明空三昧见空非倒。三住九地下翻前难辞明空三昧见空是善。三有二说下翻前难辞明空三昧具空是妙。初中有二。一正翻前难明空三昧是空非倒。二以世间人见有女下遮防外难明圣随俗说有非倒。就前见空非颠倒中是空三昧见不空法能令空寂述成上义即为一门。然非颠倒翻答前难复为一门。如盐作碱三昧如是不空作空显上初门。贪是有下显向后门。于中先明贪与色境皆是倒有。以是义下翻对倒有辩明菩萨见空非倒。前中先明贪是倒有。后明色境亦是倒有。贪中直明是有便罢。略不论。倒贪是有性非是空性正明贪有。贪若空下破无成有。贪如是空不应随狱是破无也。若随地狱云何是空显成有也。下次明其色是倒有。句别有四。一明色是有。二何等下明色其倒。先征后辩。三以颠倒下显色是倒。约贪显之。倒故生贪正明是倒。若色非倒云何生贪难破非倒。四以生贪下显色是有约贪显之。以生贪故非不是有下次翻前辩明菩萨见空非倒。以是义故修空非倒总明非倒。以前色贪倒有义故。修空翻之不名颠倒。一切凡下别明非倒。凡夫见女即生女相举凡显圣。菩萨不下辩圣异凡。菩萨虽见不生女相翻前色有以明不倒。以不生等翻前贪有以明不倒。上来正明见空非倒。自下第二遮防外难明圣随俗说有非倒。何因道此。向者宣说凡生女相。圣人不生名非颠倒。若尔圣人亦说有女应是颠倒为遮此难故今释之。圣随俗说故非颠倒。文中初明菩萨随世亦说为女。若见男下明其非倒。见男说女是则颠倒反显不倒。是故我下引说证成

自下第二翻前难辞明空三昧是空是善。以修空者见佛性故。于中先明取有迷性彰有不善。若见性下明空见性彰空见善。前中初言住九地者举有见人。谓从欢喜乃至善慧。见法有性举有见心。破相未穷故见有性。以是见故不见佛性彰有不善。有见覆真不见性故名为不善。问曰。凡夫二乘人等亦见有性。何故偏举九地菩萨。九地高胜尚不见空不见佛性。余则亡言故略不举。明空善中若见佛性则不复见一切法性悟实舍相。以修空相不见法性则见佛性舍相证实。修空见性故名为善。谁能如是。十地及佛

自下第三翻前难辞明空三昧见空是妙。说有为凡空为圣故。先举二说。有无列名。下就人论。为生说有明有是粗。为圣说无明空是妙。为圣说无总以标举。次别显之。为不空者修空见空为前九地令入空也。无法性者亦修空故为第十地证穷空也。以是下结。以前两义故亦宣说修空见空

上来三段释初难意下次释其第二句难。汝言空无为何所见牒其难辞。下为辩释无见为见。文中有二。一述前难辞明无所见。二是故菩萨见一切下即就无见以说其见。前中初言如是如是实无所见总述其言以明不见。无所见者即无有下略辩不见。修涅槃下辩明菩萨不见所由。以修涅槃故无所见。初先正辩。若有见下举有见过成前不见下明见中初先明其菩萨见空。是故我下明佛见空。诸佛菩萨修如是下总结修益。就初段中是故菩萨见一切无乘前总显。是前有见不见佛性乃至不得入涅槃故。菩萨见法悉无所有。菩萨不但因见已下历法别显。是故下结。后二可知

是名第九总以结之

第十德中先问次辩。三十七品得入涅槃是自利德。为众生说涅槃佛性是利他德

上来辩德。若须陀下品中第二叹经令学。于中有三。一明信谤损益。二德王白下问答广辩信谤之相。三德王领解。初中须陀乃至菩萨信是语者得入涅槃彰信有益。若不信者轮回生死明谤有损。第二段中德王先问。但问谤人略不问信。下佛答中先广明谤。下略论信。谤中初言我灭度后声闻弟子正出其人。下明不信。文别有四。一略明不信。愚痴无解。破戒无行。喜生诤讼毁正立邪。舍十二部诵外道典显前愚痴。受畜不净显前破戒。言是佛听显前净讼。二呵以显过。先开五门。后广辩之。三以如是恶比丘下广明不信。于中初明害持法人欲立制度遮他习学。何以故下说是为非。初先总非。所以下释。释中五句

四是人下结答前问。若有众生信此经下明其信人。解半句者或常或住

下领解中解一句者解常及住。是名第十远结前德

师子品者上明随缘造修之行。下明舍相入证之行。因师子吼启请宣说故就请人以题章自名师子吼品。此人内证师子吼定能吼所问故名其人为师子吼。此品答上一切法中悉有乐性唯愿世尊为我分别。然上问中单问所证。今此品中具以显之。下说佛性是其所证。下明见行是其能证。故外国人名此以为离诸放逸入证分矣

此品有二。一问答辩法。二若有众生欲得了了见佛性下叹经劝学。三品末偈文师子闻法荷恩赞叹。前中有六。一如来劝问。二师子许问。此二一对。三如来听问。四师子正问。此二一对。五如来赞问。六如来答问。此第三对

初中如来先泛举疑以劝其问。下许酬答。初中法门差别无量。今此且举十门劝之。一三宝门。二四谛门。谓实不实。实是真谛。不实世谛。四八修门。观生死法为无我等。观涅槃法以为我等。五三乘门。权有三乘。实无三乘。六佛性门。众生有性。外法无性。七假实门。假有众生实无众生。八有无门。有无多含。九真妄门佛性是真。妄情不真。十因果门。有因无因有果无果出世因果。有作无作有业无业有报无报世间因果。亦可前对性净因果后对方便。今恣汝者总劝令问。吾当为下许为酬答。我不见等明已能答

自下第二师子许问。于中师子先许咨问。会有菩萨名师子吼标列其人。从坐起等启请方便。白佛已下彰已欲问庆蒙佛听。下佛对之。劝人供养。先劝供养。者何以下释劝供养。是故应下结劝供养。前中汝等深敬尊重劝意供养。言赞叹者劝口供养。以种种等劝身供养释中所以征劝所由。下明其人欲师子吼故应供养。于中有二。一明其人宿善今成欲师子吼故今供养。二如师子王下明吼同佛故应供养。先喻后合喻中先举师子之王喻佛如来。野干下举师子之子喻此菩萨。是中为明师子菩萨欲吼应供何故明佛。彰此菩萨吼同佛故。亦即明佛能酬答故

前中有四。一能吼德。二晨朝下明将吼相。三为十一下明吼所为。四水性下明吼势力。初中师子喻佛如来。无畏自在故说为王。圣慧内照名为自知。六度行体说以为身。十力雄猛说之为力。破邪之智名为牙齿。明利难敌故曰锋芒。四如意定智德所依故说为足。又能进趣故说为足。定依净戒故曰据地。宁心四禅名安岩穴。振大悲尾出妙法声。若有下结

第二相中启化之初名为晨朝。从德现化称言出穴。现通摧慢名曰频申。许说进善义称欠呿。照察物机名四顾望。初陈法化名为发声。法响踰盛故曰振吼

就所为中为十一事总以标举下别显之

下吼势中要分为二。一益正众。二摧邪人。细分有四。水性潜没。合正学中出家之众深入正法。陆行藏伏合正学中在家之众安住正法。飞者堕落合邪学中诸魔颠堕。香象失粪合邪学中外道退散

上来喻佛。下喻菩萨。如彼野干百年不能举劣显胜。明二乘人不能吼也。若师子子三年能吼辩胜过劣。喻明菩萨能师子吼

下合显法。先就如来合师子王。文别有五。一合初段能吼之德。二摧破下超合第三吼之所为。三为令正见四部众下合第四段吼之势力。四从圣行下却合第二将吼之相。五四足据下重合初段能吼之德

就初段中如来合前师子王也。正觉合前自知言也。智慧牙爪合牙齿也。喻中无爪。合中有之。四如意足合前四足。欲进念慧是其四耳。六波罗蜜满足之身合前身也。果德圆备故云满足。十力合力。大悲合尾。安住四禅合安岩穴。为诸众生而师子吼合前出声

第二超合吼所为中摧破魔军合坏实非师子言也。示众十力合试自力。开佛行处合令处净。为邪作归令为诸子知处所也。安抚生死合为群辈无怖心也。觉悟无明合为眠者得觉悟也。行恶作悔合放逸兽不放逸也。开示邪见令知六师非师子者合为诸兽来依附也。破富兰等合为调伏大香象也。令二乘悔合教子息。为教五住诸菩萨等合为庄严自眷属也。五住之名经文不列。准义论之进退不定。一义分别种性为一。解行为二。净心为三。二地已上行迹为四。八地已上合为第二义者。地前为一名为信地。净心为二。行迹为三。八地九地决定为四。十地毕竟以为第五。第三依彼五忍永别。地前伏忍合以为一。初二三地信忍为二。四五六地顺忍为三。七八九地无生忍四。十地寂灭以为第五。皆得无伤第三超合吼势力中令正四众于邪四部不生畏者合初水性潜没深渊陆行藏伏。出家二众合其水性。在家二众合彼陆行。飞堕象走略而不合。若合不异吼所为中第一及与第九句故

第四却合将吼相中圣梵天行合岩穴也。约喻名法说为窟宅。地持说此以为三住。与此窟宅其义相似。圣梵二行广如上辩。天行犹是八禅定也。上有五行。今以何义但说三行。良以此三是摄善行。余二离过。善正所依故偏论之。频申而出牒举前喻。为破憍慢约之显法。现胜神通故能破慢。欠呿牒喻。为生善者约之显法。如上文中举疑劝问许为解释为生物善。四顾牒喻。为令众生得四无碍约之显法。观众堪受四辩之机为说令成四无碍智

第五重合能吼德中四足据地牒举前喻。令生安住尸波罗蜜显其化意。自住净戒故令他具师子吼者牒上喻中若具如是能师子吼名决定说总约显法。说一切众生悉有佛性如来常住别约显法

上来合佛。下就菩萨合师子子。声闻缘觉虽逐如来不能吼者合前野干不能吼也。十地修三能师子吼合师子子始满三年即能哮吼。三行犹是圣梵天行

上来释劝。是师子下结劝供养

世尊告下是第三段如来听问

师子白下是第四段师子正问。问中八句。前四问其所证之性。后四问其能证之行。就前四中云何为性问其性体。云何许法是其佛性。以何义故名佛性者问性名义。何故复名常乐我净问性体义。何故一切众生不见就人征责。此言即是问性有无。若实有性一切众生何故不见。众生不见当应无性。就后四中十住住何佛住何法问证性行。十住何眼。佛以何眼。问证性智。亦可前二问福德行。后二问其智慧行也

自下第五如来赞问。于中有三。一佛叹师子具二庄严能知能问。二师子言云何慧下辩二严相。三师子言若有二严不应问下辩所问法就初段中善哉总叹。若人下别。别中初明为法咨启必具二严。次列两名。下叹其能。具二严者能知向前所问八义

第二段中师子初问云何福慧。下佛为释。二庄严义广如别章。此应具论。文中先辩二庄严相。汝今具下叹其二能

前中三番。一约十地体德分别。证体是慧。余德名福。故今说言慧庄严者谓从一地乃至十地福庄严者檀至波若非波若波罗蜜。是义云何。檀等六行各有二种。一随事造修。非波罗蜜不能到于诸法实性非是自性清净度故。令理成者是波罗蜜到法实性是其自性清净度故。然今文中分取波若。是波罗蜜为慧庄严见法实故。前之五度及波若中非波罗蜜悉判为福。不能见法如实性故。良以波若波罗蜜多行成在十地。是十地体。故就位论。谓从一地乃至十地。余非地体。当相以辩故言谓檀乃至波若。于波若中有非福德者宜须简别。故复说言非是波若波罗蜜矣。二就人分别。慧庄严者谓佛及与十地菩萨。文中略故直言菩萨不言十地。良以十地与佛同能眼见佛性。故合为慧。声闻缘觉乃至九地皆悉不能眼见佛性。同判为福。三体用分别。诸佛菩萨有二种行一是德体性实离相。二是德用起化随物。今言福者有为有漏有有果报有碍非常是凡夫法是其德用。用有起作故曰有为。示起染过名为有漏。现六道身名有果报。随化起灭是故非常。所作似凡名凡夫法。此犹是前常与无常。慧庄严者无为无漏无有果等是其德体。体无起作故非有为。出障清净名为无漏。六道身断故无果报。生灭永夷称曰常住。此犹是前无常共常

上来直辩。二庄严相。下叹其能。汝具此二能问深义。我具此二能答深义。是中不欲明已能答。为显二种庄严功能。准下此中文少不足。若具应言汝具二严能问甚深一二之义。我具二严能答甚深一二之义。故下师子乘之为问不知何因。文中略无一二之言

第三段中师子先问。问意如何。明一与二相粗易识不假二严方能问答。而佛说具方能问答。所以问之。文中有二。一乘言正难。二所以下释。前中菩萨具二庄严则不应问一种二种。难前菩萨具二能问。具二庄严应当解法无一无二。何缘正能问一问二。云何世尊说言能答一种二种。难前我具二严能答。然此问中言有隐显。准后类前前应有二。一自立道理。具二庄严不应问于一种二种。二征破佛语。云何说言具二庄严能问一二。准前类后后亦应二。一自立道理。具二庄严不应答于一种二种。二征破佛语。云何说言具二庄严能答一二。今前句中偏举道理略无征辞。后句之中偏举征辞略不立理。准此验前必知向者有其一种二种之言。亦可此言准义为问。向前问中导言佛性众生不见即是其二。佛菩萨见即是其一。如来就之说为深义故。今师子取以为难。就下释中先自征责。我有何以为此征问。释中诸法无一无二举深形浅。一种二种是凡夫相明浅非深。一二既是凡夫之相。何假具严方能问答下佛答之。文还有二。一翻答初段明具二严方能问答一种二种。于中偏就菩萨答之。若有菩萨无二庄严不知一二反答前问。具二能知顺答前问。二翻答后段明其一二深而非浅。于中先翻无一无二。后翻一二是凡夫相。前中若言无一无二是义不然牒以直非。何以下释。先征非意。下对释之。若无一二云何得说无一无二。由有一二故得就之说无一二。若全无者对何宣说无一无二。下翻一二是凡相中若言一二是凡夫相牒其难辞。是乃十住非凡夫相翻其难辞。何以下释。先征后解。于中先出一二法体。一谓涅槃。二谓生死。次释其义。涅槃体常不变故一。生死常爱无明等前后分异是故言二。皆初征问。后释可知。下就人定。明一与二并非凡相。凡夫例惑不能解知生死无常涅槃常故。以是下结。以非凡夫所知义故具二庄严方能问答

自下第六如来答问。于中经文粗判有二。一略显证义。二佛性者非内非外然非失下广显证义。细分有四。一对前八问略显证法。二若男女欲见如来应当修习十二部下约对前法劝修趣入略明证行。三性非内外然非失下广显证法。四师子言无相定者名涅槃下约对前法劝修趣入广明证行。就初段中先答前四问明所证法。师子吼言菩萨具几见不了下答后四问明能证法。佛性是其所证之法。诸佛菩萨证性之行。为他施习为能证法。此二须记答前四中初就众生现性答问。师子白佛佛与佛性无差别者一切众生何用修下就诸众生当性答问。性非当现约缘言耳。就现性中文别有二。一对上初问辩出性体。即约此体明其佛性常乐我净众生不见。此一分中答上三问。正答第一兼答第四。二如汝言以何义故名佛性下对第二问解性名义。即约此义明其佛性常乐我净众生不见。此一分中亦答三问。正答第二兼答第四

就初段中先对初问辩出性体以是义故佛性常下超答第三明其佛性常乐我净。无明覆下超对第四明诸众生不见所由

初中汝言云何为性牒举前问谛听许说。下正答之。就中宣说三义为性。一第一义空以为佛性。二智慧为性。三中道为性

性者名为第一义空是初门也。佛性门中旷备法界一切种义。今此且就一空门说。就染说性喜同情取故说为空。性云何空略有二义。一离相名空。体虽真有而无一相。如净醍醐而无青黄赤白等相。亦如一切众生心识体虽是有而无大小长短等相。又如佛身体实妙有而无一相。无何等相。如马鸣说谓非有相。亦非无相。非非有相非非无相。非有无俱相。亦非一相。亦非异相。非非一相非非异相。非一异俱相。亦非自相。亦非他相。非非自相非非他相。非自他俱相。如是一切妄心分别悉不相应唯证境界。二离性名空众生佛性即如来藏。如来藏中广备法界恒沙佛法。是诸佛法同一体性互相集成。无有一法别守自性故说为空。空义如是第一义空名为智慧明空与慧更无别。体离相义边故说是空。觉照义边是故慧门。故无别体而第二门。良以说空喜同断灭故说为慧。既言是空云何名慧。解有四义。一空是慧境故名智慧。故龙树言说智智处皆名波若。二依此空理出生佛慧。因中说果故名智慧。其犹世人说食为命。三就体说。此之佛性虽名为空体是真心。心是觉性故名智慧。故华严云一切众生心微尘中有无师智无碍智广大智等。马鸣论中说为本觉。问曰。凡时未有智解。以何义故得名为觉。论自释言从本以来有大智慧光明义故。遍照一切法界义故。自性清净识知义故名之为觉。是义云何。真心体中具过恒沙一切佛法心于彼法同体照明。由来无障名照法界故名智慧。四约人分别。凡佛虽殊体性无别。体无别故将凡取性性名为因。据佛取性性即佛果。故上宣说苦集等实即是如来。是佛果故名为智慧所言空者不见空下是第三门中道为性。于中约就愚智显之。文别有四。一明愚人偏见。二智。者下明智人正见。三见一切下明前愚人所见非中。四中道者名佛性下明前智人所见是中就初段中所言空者标别愚人。愚谓二乘。二乘唯见生死法空。故言空者亦得说言若无常者及无我者。就始言耳。下言不见空与不空彰其所迷。二乘之人但能见空不能见空及与不空。故言不见空与不空。非全不见。此言略少。若具应言不见苦乐乃至不见我及无我。类初可知略不具论。人言空者牒前理空。云言水见空不空者导前空理非智慧故不能见空及与不空。粗看似是。细穷则非。空理不见何待言论。第二段中初言智者标别解人。人谓菩萨人言智者牒前智慧。乍看似是。审思则非。前空与慧并是所显中道之性。今言智者标举解人约之辩中。非牒前智。见空不空乃至无我彰其所解。空者一切生死已下辩其所解。自下第三明前愚人所见非中。见一切空不见不空不名中者约空不空以显非中。二乘唯见生死法空不能见于涅槃不空。偏故非中。乃至见于一切无我不见我者不名中道。约我无我以显非中。超苦无常故言乃至。义同前解

第四段中中道名性。言少不足。若具应言见空不空乃至见我及与无我是名中道如是中道名为佛性。翻前可知故不具论。由见空等知法非有。见不空等知法非无故名为中。说此中道为佛性矣。上来一段对上初问辩出性体以是义下超答第三明性是其常乐我净乘前显后。以是第一义空为性。智慧中道为佛性故常恒不变。亦应宣说我乐及净类常可知。略不具辩

无明覆下答第四问明诸众生不见所由。无明覆故令生不见别明凡夫不见所由。声闻已下别明二乘不见所由。于中初明声闻缘觉但见空等不见不空乃至于我。次明不得第一义空。后明不能行于中道。下明不能见于佛性。中有三下总明凡夫二乘不见。见中有三略以标举。此于中道正见邪见通名见中。次列三名。下辩其相。解定乐中菩萨邻生虽处阿鼻如三禅者为物甘处。如似世人乐三禅乐。非谓在中乐如三禅。言定苦行谓凡夫者。凡夫唯有生死之苦故名定苦。声闻缘觉行于苦乐作中道者有变易苦。以离分段得小涅槃名之为乐。二乘住此作中道想。以是义下双结后二不见佛性

下次答上第二句问解性名义。即就明其常乐我净众生不见。如汝所言以何义故名佛性者牒举前问。下释有三。一总明佛性是其菩提。中道有三下别明佛性是其中道。三十二缘智即是阿耨菩提种下别明佛性是其种子。初中即是中道种者性是中道而与菩提作种子也

第二段中三番辩中一通就理行以辩中道。二生死本际凡有二下偏就十二因缘之理以说中道。三众生起见凡有二下偏就十二因缘观行以显中道。是中举行为约显理。就初段中道有三种略以标举。次列三名。正辩中道余二显之。此上中下异于余处。余处所辩下法为下。中法为中。上法为上。今此所论下劣之法名上名下。据此下法向上望之有上可趣名为上道。向下望之下有三涂可以趣向说名下道。胜上之法说以为中。据此胜法向上望之无上可趣不名上道。向下望之不退趣入凡夫心中不名下道。不上不下故说为中。下释其相。下牒初门。梵天无常谬见常者此上求心。下有三涂可以趣向故名下道。上牒第二。生死无常谬见是常三宝是常计无常者。此是例惑求下之心。上有菩提终可趣向故曰上道。何以下释。先问起发。能得最上阿耨菩萨对问辩释。不将此心得上菩提。有此心者终得菩提故曰能得。中牒第三。下释其相。先辩后结。辩中四句。第一宣说第一义空理法为中。二从无常见无常下说行为中。三第一义空不名已下释前第一理法为中。第一义空不名为下非下故中。何以下释。凡夫不得故不名下。不名为上非上故中。何以下释。先征后解。体即是上更无上法可与为道故不名上。四诸佛菩萨所修已下释前第二行法为中。不上不下。义同前解。上来别释。以是下结

上来通就理行说中

自下第二偏就因缘理法明中。于中先明因缘中道。是故佛性常乐我下明性是其常乐我净众生不见。前中先辩因缘之相。生死本际凡有二种无明与爱举生死因。无明是其现苦家本。本亦有行略而不彰。有爱是其当苦家本。此名爱结以之为有。爱三有故。现在亦有取及有支略而不辩。是二中间有生老病死举生死果。此举缘相下就说中是名中道就缘辩中。问曰因缘云何为中。解有六义。一就破离断常分别于事分齐十二因缘次第相生。后藉前起是故非常。前能生后所以非断非常非断故名为中。二破我分别。因缘法中无我无人。以无我故因缘之法亦非我所则为非有。因缘相生故复非无。非有非无名为中道。三破性分别。十二缘法但集从缘无有自性所以非有。因缘相生是故非无。非有非无故名为中。四破相分别。因缘之法诳相而有穷理本无。不但无性。相亦叵得。如阳炎水近观之时非直无于水性而已水相亦无。穷理本无名为非有。诳相似有说为非无。非有非无名为中道。五破想分别。十二缘法更细推求心外无法。但是妄想自心所见。如梦所见皆是心起。以心起故于理本无名为非有。妄心自现说为非无。非有非无名为中道。六就实分别。十二因缘穷其本性真心所起如梦所作皆报心起。故地经说十二因缘皆真心作。真心即是如来藏性。古今常湛清净不变。何有因缘起作可得所以非有。随妄流转集起生死说为非无。非有非无故名中道。又彼真心离性名为非有。体具法界恒沙佛法说为非无。非有非无名为中道。六中前五虚妄不真生灭流转。非是常乐我净之法。不能究竟为佛真种。今此不论。第六一门体真常乐我净之法能为佛种今名中道。与经中说生死二法是如来藏其言相似。如是中道能破生死故名中道释为中义。中道即是因缘实性。是实性中无因缘相故破生死。生死之有着边故起。故破生死名为中道。以是中道名佛性者结中为性。以是中道能破生死成佛义故得名佛性

下次明其常乐我净。众生不见一处合论于中初法次喻后合。法中初言是故佛性常乐我净乘前显后。是前中道能破生死为佛性故。佛性得为常乐我净。以诸众生不能见故无常乐等辩相显实。此即明其众生不见。性实非下彰实异相成前不见。喻中贫人家有宝藏喻前性体常乐我净。是人已下喻上众生不能见等。有善知识而语已下喻佛性实非无常苦等寄得显之。于中先喻诸佛菩萨开化令得而语化始。即以方便令见化终。以得见下喻诸众生同化得见。合中佛性合前宝藏众生不见。有知识下合前知识而语等也。上来偏就因缘理法以论中道

自下第三偏就因缘观行说中。于中初先正辩中道。性虽常下还明不见略不宣说常乐我净。就正辩中先对凡夫以明中道。众生起见凡有二种一常二断不名中道举边显中。无常断下明中异边。无常无断名中道者正辩中义。即是观照十二缘智出其中体。如是观智名佛性者结中为性。下对二乘以显中道。二乘虽观不名佛性明小非中。二乘但能见因缘相不及其实故非中道不名佛性。是中亦应明佛菩萨观行是中。义不异前故略不论。上来辩中。下明众生不见佛性故无中道。佛性虽常为无明覆不能得见明凡不见。又未能度十二缘等明小不见初先法说次以喻显。二乘观法未能及实。故如兔马不得水底。何以下释。以凡二乘不见佛性故能观智不名中道。上来三番合为第二偏解中道

自下第三偏明种子。文还有三与前相似。于前三中从后向前次第说种。先就第三因缘观行以说种子。以是义下就前第二因缘之理以说种子。性者有因有因因下就前第一因缘理行以说种子。初中是观十二缘智即是阿耨菩提种者牒上第三因缘观智就说种也

第二番中初先法说。以是义故十二因缘名佛性者乘前显后。以前所生因缘观智得为种故能生因缘名为佛性。性犹种也。次以喻显。譬如胡瓜名为热病立喻显法。何以故下释喻显法。能与热病作因缘故名为热病。下合显法。因缘如是能生向前因缘观智故名佛性

第三番中文别有三。一就向前理行二门说为种子。二非因果故常恒已下还明常乐我净之义三以是故我经说下还明不见。初中为分理之与行二种因别须明二果为辩因果。通对非因非果以说故有五种。一是因性犹是向前因缘之理。二因因性犹是向前因缘观智。三是果性是前观智所生之果。四果果性是前因缘中道之果。因缘之理显为果故。五非因果性前四处体。彼体从缘说为前四。废缘就实说为第五非因果性。文中初先一番广辩是因非果。如佛性下结别其相。初中前四一处辩释。非因果性在后别论。释前四中初法。次喻。后合显之。法中初先开列四门。下牒辩释。因牒初门。即十二缘斥其体相。十二缘法近生观智远为涅槃正因种子故名为因。言因因者牒第二门。即是智慧斥其体相。观因缘智依前因缘从因起因故曰因因。果牒第三。即是菩提斥其体相。此前观智所生果也。言果果者牒第四门。即大涅槃斥其体相。此前十二因缘家果。因缘之理显为此果名大涅槃。向前菩提望于前因已受果名。涅槃是彼果家之果故名果果。理实菩提及与涅槃并有性净方便之义。但今文中方便之果偏名菩提。性净之果偏号涅槃。上下多然。性净就体彰寂显故。问曰何故性净之因直名为因。方便之因名为因因。及至果中方便之果直名为果。性净之果名为果果。释言互从皆得无伤。但彼因中从本起末。因缘之理是行根本故直名因。方便之因从前起故名曰因因。至果之时摄末归本。方便菩提对前满足已受果称。德成归本故名性净以为果果

次以喻显。如无明为因诸行为果行因识果立喻显法。以是义下辩喻显法。向前法中四法相对彰其重因累果之别。今此喻中三法相对何故如是。喻取少分不可全同。又为显其所生行德。因果虽殊体无别故。以是义者。以前无明生行之义行生识义。彼无明体亦因亦因因者两法相对。无明是彼行果家因故直名因。三法相望行支已是识果家因无明是彼行因家因故曰因因。文义且然。将喻拟法全不相似。准法论喻应说行支以为因因。从因生故。准喻谈法应因缘以为因因。因家因故。盖亦是其少分喻耳。亦可向前因缘之理非直是因亦是因因。故今宣说无明为因及与因因以况彼义。云何为因。望涅槃果直为因故。云何因因。与观智因而为因故。言识亦果亦果果者两法相对。识支是彼因家之果故直名果。三法相望行支望前已是果竟。识支是彼果家之果故名果果。文义且然。将喻拟法而不相当。准法验喻。行支亦果识支果果。准喻论法。涅槃名果果。此亦是其少分言耳。亦可于彼涅槃之上具有果义及果果义。故今宣说识支为果及与果果以况彼义。云何为果。望彼因缘直为果故。云何果果。与菩提果而为果故。佛性亦尔合以显法。上来广释前四门竟

下释第五非因果性。以是义故十二因缘不出等者。以前因缘中道之理体是常乐我净义故。常住不动不出不灭乃至非果。此不出等释有两门。一依世谛缘相解释。如中论说因缘假集无有一法自性可生名为不出。亦无一法自性可尽说为不灭。分分尽谢称曰不常。运运新生故曰不断。前后分异名为不一。从前起后非余处来故言不二。缘集始生非本至今故曰不来。因谢果兴非前到后所以不去。前无自性所以非因。后无自性是故非果。二就真谛缘实解释。因缘实性不从缘生是故不出。不从缘尽故曰不灭。体无定性所以非常。不可断灭是故非断。体备法界恒沙佛性故曰非一。诸法同体不离不异故曰非二。不从缘变故无去来。亦无隐显故非因果。良以就实以论其体。体外无缘是故不可约缘说出乃至因果。此后一义与圣行中辩性相似。今此所论义当后门。云何得知。此中辩释非因果性。即是真谛常乐我净不变之法。故上说言因缘中道常乐我净。前问所辩乃是世谛无常苦空无我之法。三乘同知。故非此义。上来一番广辩五义

自下重复结别其相。是因非果如佛性者结前第一。指法名如。因缘之理能为佛因故名佛性。是果非因如大涅槃结前第四。如同前释。即前佛性显名涅槃。是因是果如十二缘所生法者结前第二及第三门。因缘观智从因缘生名十二缘所生之法。非因非果名佛性者结第五门。此乃诸佛离缘平等法身之体故名佛性

上来第一广明向前理行二门为种子义。非因果故常恒无变是第二段明其常乐我净之义。文但辩常余略不论。就前五中非因非果不随缘变正是常义。故偏牒之就明常矣

自下第三明其不见。先举昔说明缘甚深众生不见。以何义下释显不见。前中初言以是义者。以是因缘从缘转变为因为果。体性常恒非因果故。我经中说甚深甚深无知无见。于中四句。十二因缘甚深甚深为第一句。直叹法深明凡二乘不见所由。无知无见不可思惟为第二句明凡不见。乃是诸佛菩萨境界为第三句寄人显深。非诸声闻缘觉所及为第四句明小不见。此举昔说。下释显之。前四句中初句别解。后之三句一处释之。解初句中何义甚深问以起发。不断常等对问正解。是中直就缘相辩深。因缘实性即是向前非因果性。若更辩深不异于前故略不论。良以缘实非定有无非断常故。依之起相相亦如是。故举缘相以显其实。文中六句摄为三对。初二一对当法分别。众生业行不断不常而得果者明非无果。业行若常亦不得果常不变故。断亦不得不生后故。不断不常方乃得果。虽念念灭而无所失明不失因。因体虽复念念尽灭能生之力常不失也。次二一对约人分别。虽无作者而有作业明其无有造业之人而有行业。虽无受者而有果报明其无有受报之人而得有果。无作无受即明非有。而有业果即显非无。下二一对约人就法而为分别。受者虽灭果不败亡约人分别。受人虽灭得果不亡。无有虑知知合而有就法分别。根尘识等三事别分知不可得名无虑知。此三和合便有知生名和合有。又一念心四相分别知不可得亦名无知。前后和合假名知生名和合有。问曰。何不即用此义以为缘实。而言此中就相辩深。释言此等若即是实即是佛性。二乘知此应知佛性。何故上言声闻缘觉虽观因缘不名佛性。又此所辩唯是世谛空无常苦无我之理若是佛性。佛性便非常乐我净。云何上言因缘中道名为佛性如是佛性常乐我净。又上文言从缘生法悉是无常。佛性常故不从缘生。明此所说但是缘相非是性体。上来解释初句甚深。下次解释后之三句。于中分二。一解向前无知见等明凡不见。即举向前佛菩萨境对以显之。二观缘智凡有四下解释向前二乘不及。还举向前佛菩萨境对以显之。前中有四。一明凡不见。二十住下明佛菩萨见。三一切众生不能见下明前凡夫不见之损。四是故我下明佛菩萨知见之益。初中众生虽与共行而不见者明不能解。不见知故无始终者明不能灭。起来始未有尽时名为无终。第二段中十住见终不见始者。见已生死至佛当尽名为见终。不知根本起之所由名不见始。诸佛世尊见始终者。见因缘法原起所由亦见尽时名见始终。以是了了得见性者。佛性是其因缘之本。故佛如来见始如终名见佛性。第三段中一切众生不见因缘是故转轮法说明损。次喻后合。下复喻显。第四益中言是故者乘前显后。是凡不见有大损故。我经中说知见有益。若人见缘即见法者见法实也。因缘之体是法性故。即见佛者见佛实也。因缘实性据佛望之由来清净毕竟无染。即是诸佛法身之体。是故见之名为见佛佛。即性者彼佛法身据凡望之为惑隐覆。与后显时净德为本故名佛性。何以下释。一切诸佛同用此理以为自性故名佛性。佛性是佛自体性故

上来四段合为第一。自下第二释前声闻缘觉不及辩。举诸佛菩萨对显。是观缘智凡有四种总以标举。次列四名。下中二门解非声闻缘觉所及。上及上上释前诸佛菩萨境界。次解后结。以是义故十二因缘名佛性者。以上上智观十二缘得菩提故十二缘法得名佛性。下以佛性历即余义性理精上名第一义。离相名空。出离断常即名中道。即是诸佛法身自体故名为佛。离此之外无别佛故。据佛望之即是诸佛大涅槃果。离此更无别涅槃故。故经说言佛知众生取涅槃相不复更灭

上来就彼众生现性答前四问。自下就彼众生当性答前四问。总相虽然。于中细求唯答第一。云何为性辩答第四众生不见。第二第三略而不答。易解故尔。说彼当来佛果为性。名义显了何须更释。云何名性。佛是常等理在灼然何劳更解常乐我净。就所释中师子白佛佛与佛性无差别者一切众生何用修道重难起发。由佛前说佛性即佛故为此难。下佛释之。释意如何。明诸众生虽有佛性显用在当当果未有故须修道。文中初言汝问不然牒以总非。下广辩释。文别有六。一说菩提为性明凡未有。二说一乘为性明凡未有。三说首楞严定以为佛性明凡未有。四说我为性明凡未有。五说十力四无畏等以为佛性明凡未有。六说一切佛性为性明凡未有

初中有三。一直明佛性当有现无。二举偈证成。三释偈显成。前中初法次喻后合。法中初言佛与佛性虽无差别牒其难辞。现性与彼当果体同故曰无差。辩同兼异是以言虽。然诸众生悉未具者翻其难辞。众生未证故曰未具。凡皆未具是以言悉。以未具故必须修道。喻中四句。一立喻显法。二何以下释。三是故我下引证成喻。四何以下释。初中如人恶心害母喻有性因。害母之罪定入地狱如彼佛性定得菩提故取为喻。害已生悔喻有惑障。以善况恶。三业虽善故名狱人喻诸众生三业虽恶定得菩提。第二释中何故问也。定当堕故对问略释。是人虽无地狱阴等犹名狱人对问广释。第三列经第四释经。文显可知。下合显法。一切众生定得菩提故说有性明其当有。一切众生真未有下彰其现无。上来一段直明佛性当有现无

以是义下举偈证成。先标说处。下列偈文。前之半偈自立道理明惑与性两法不并。下之半偈遮他异说明惑与性有无非恒。下释偈文。显成当有现无之义。于中初言有者三种泛举有义。次列三名。下就人辩辩中有三。一约三世明有不同。二以是义下举说证成一切有性。三乃至下别释罪人有佛性义。初中先明未来世有该通上下。一切众生未来皆当定得菩提故悉有性。次明现有唯论下人。下人现在唯有烦恼。是故现在无其相好果德佛性。下明过有偏论上人。上人过去有断烦恼。是故现在得见佛性。虽举三世为就前二明诸众生当有现无

第二举说证皆有中。以是义故我常宣说一切有者释有通别。通则以前未来有故说一切生悉有佛性

第三偏释罪人有中初先法说。次喻。后合。法中初言一阐提等亦有性者直明其有。前已宣说一切有性何须别说阐提等有。阐提谤法及五逆等有性难知故须别论。下重辩之。现无当有。言阐提等无有善法佛性亦善明其现无。举一阐提等余罪人。彼现无善果性亦善。故彼现在无有佛性。以未来有。故阐提等悉有性者明其当有。何以下释。以定得故说未来有。上来法说

下次喻显人喻向前一阐提等。家有乳酪喻现有因。有人问下明当有果。酪实非下辩其有义

下合显法。众生亦尔合前人也。悉皆有心合有乳酪。凡有心者定得菩提。合有人问汝有苏耶答言我有。以是义故我说一切悉有佛性合以定得故言有苏。凡有心者皆有真识觉知性故定得菩提。外草木等无真心故终无得义。此乃宣说能知之性。若论所知境界之性一切皆有不局有心

自下第二一乘为性。先出性体。后明众生有而不见。前中初先辩二毕竟。后约论性辩二竟中先总标举。望小大极故名毕竟。因果不同故分二种。次列两名。因能严果故曰庄严。果德穷满称曰究竟。世及出世约位分毕。十地已还通名世间。皆是变易世间摄故。佛名出世。下辩体相。庄严是其六波罗蜜究竟一乘。下约性辩。文显可知

下明众生有而不见。先明其有。以是我说一切有者正明其有。以是众生所得一乘为佛性故我说一切众生有之。一切众生悉有一乘释成有义。以无明下明诸众生不见所由。先法次喻后合可知

自下第三首楞为性。先广辩相。后释名义。前中四段。一明首楞是其佛性。二一切众生悉有已下明诸众生有而不见。三首楞严有五名下彰首楞严名别不同显首楞严即是佛性。四一切众生具三定下还明众生有而不见。就初段中性即首楞会名显示。两名虽殊会体不别是以言即。性如醍醐辩所即性。性通因果。因似乳酪。果如醍醐。性即首楞故须辩之。即是一切诸佛母者彰性功能成即首楞。首楞严者此翻名为一切事竟。良以佛性是诸佛母能生一切诸佛德。故得即首楞一切事竟。首楞严故而令诸佛常乐我净。彰首楞严三昧功能成即佛性。以首楞严能令诸佛常乐我净。故即佛性佛母之义

第二段中一切众生有首楞严明其当有。以不修故不能见者彰其不见

第三段中初先法说。首楞五名总以标举。次列五名。虽举五名正欲明其是佛性义。随其所作处处得名总以结之。次以喻显。如一三昧得种种名。或名为禅。或名定根。如是非一。首楞如是辩法同喻

第四段中先明一切众生具有。下明不见。前中一切具三种定泛以通举。谓上中下列其三名。下辩其相。上谓佛性显其初门。何故佛性得名上定。说首楞严为佛性故。以是故言一切有者就人明有。以说佛性为上定故一切有之。中者一切具足初禅显第二门。有缘能修无缘不能明得不定。下出其缘。所谓火灾及坏欲结以是故言一切具中就人结有。下者十中心数定者辩第三门。十地广辩如杂心论。想欲触慧念思解脱忆定及受是其十也。此十遍通一切心中名通大地。以是故言一切具下就人结有。虽辩中下意显上矣。上来明有

下明不见。一切众生悉有佛性不能见者明凡不见。十住虽下举圣显凡。十住菩萨见上不了何况凡夫。上来广说首楞为性众生不见

下解名义。首楞事竟严名坚者翻名解义。毕竟而坚名首楞严牒以结之。以是首楞名佛性者结首楞严以为佛性。以能造作果德事竟故名佛性

自下第四说我为性。于中先说我为佛性。师子言下明诸众生有而不见前中有四。一明如来说我所由。二我亦不说悉无我下正明说我。三梵志闻下说我之益。四是佛性实非我下如来辩定我无我义。初中有四。一佛为起化尼连洗浴水陆同观。二明外道睹佛受乐嫌佛说断。三如来反问说断所由。四外道引佛所说以答辩难如来无我之义。文皆可知

第二正为说我之中句亦有四。初我亦不说一切无我反其所闻明不说断。二我常说下显所不闻明恒说我。于中初先说一切生悉有佛性。性岂非下就性辩我。望直说我惧同情取。故先辩性后就我论。三以是义下结初不说。四一切众生不见性下就前所说明凡不见。亦即反推断见属彼。一切众生不见性故无常我等名说断见

第三益中。初明梵志闻我发心。后明诸畜闻我发心舍离恶身

第四辩定我无我中。初明佛性实非是我为生说我。问曰。上来数说佛性是其真我。今以何故说实非我。释言。佛性备含多义。亦有我义及无我义。亦有非我义。但向为彼我见外道爱喜我故偏说为我。虽为说我恐畏同彼先所建立。故复拂遣明实非我。此说非我亦是化耳。有因缘下明虽异说而非虚妄。于中通对佛我显之。句别有四。一明如来无我说我而非虚妄。二明如来说我为无我而非虚妄。随化说此故曰有缘。三辩初句佛性无我如来说我。佛性未有八自在用故名无我。四辩第二如来是我。佛说无我。如来具有八自在用故名为我。上来正说我为佛性

下明众生有而不见。师子先问。若一切生悉有佛性如力士者牒佛前言。佛上宣说众生佛性如彼力士额上宝珠故今牒之。何故不见征问如来。下佛为辩。先明众生不见所由。如月初下彰其是有。前中有二。一明凡夫盲故不见。二明二乘倒故不见。前中为明凡夫不见举佛菩萨见以显之。于中先喻。色喻性体。盲不见者喻凡不见。虽复不见不得言无喻明性有。有目见者喻佛菩萨有眼能见。下合显法。佛性合色。众生不见合盲不见。十住已下合有目见。于中先明菩萨分见如来全见。次以喻显。菩萨分见如夜见色。如来全见如昼见色。下明菩萨从昧得明。于中先立治眼之喻。下约显法。十地如是虽见不了合眼肤翳见色不了。以首楞下合以药力得了了见。医喻如来略而不合

下明二乘不见之中。先明二乘有倒不见。后举诸佛菩萨显之。前中初言见一切法无常我等非一切法亦无常等。泛明倒见不见佛性。言一切者名生死下辩法显倒。声闻已下就人指斥。下举诸佛菩萨显中。先明十住菩萨少见。见一切法无常我等明见生死一切法也。非一切法分见常等见涅槃也。此明菩萨分见所由。以是义故十分见一正明少见。下明如来全见佛性。见一切法无常我等非一切法见常乐等明见所由。以是义下正明全见。先法后喻。以是义下结叹首楞。由其见故。上来明凡二乘不见

如月初下彰性是有。先喻后合。文显可知

自下第五说力无畏大悲三念以为佛性。于中有三。一说力等以为佛性。二一切生悉有已下明众生有。三雪山下明诸众生藉教不同有见不见。初段可知

第二段中初先法说明众生有。次喻。后合。法中一切众生悉有直明有性。三种破下举得显有。于中先举断烦恼得显性是有。断贪嗔痴名为三种破烦恼也。一阐提下举断业得显性是有。以是义下总结性有

次喻显之。十二因缘等共有之亦内亦外略以标举。十二因缘即为一门。一切众生等共有之亦内亦外复为一门。就共有中现所具者名之为内。当有现无说以为外。下广释之。先广初门。何等十二问以起发。次辩其相。初二可知。现初受胎名为识者泛论识支。有其三种。一种子心识。过去世中造业已后所有心识为业烦恼之所熏故能生于后名为识支若复通论。过业烦恼相应心识亦是识种。二求生心识名为识支。谓中阴心。三初生心识名为识支。谓现报中最初一念染污心识。于彼父母精血之所妄想起于华池等爱。今此偏说受生心识以为识支。故言现在受胎名识。入胎五分四根未具名名色者。毗婆沙释。从识至于现身死来合有十时。胎内五时胎外五时。胎内五时名为五分。此五分中分为三支。最初一念说为识支。第二念后四根未具判为名色。色少心初合但有身根。未具眼耳鼻舌四根名四未具。是时身根说之为色。四阴曰名。色相形现当相名色。四阴心法冥漠难彰。非名不别。故从诠目说之为名。故楞伽云以名宣说无色四阴称曰名矣。具足四根未名触时名六入者。前五分中根具后判为六入。后四简前。未触异后。前色增长分为五入。前名增长说为意入。未别苦乐是名触。者出胎已后匍匐已前意识地中未能了别苦乐增异名为未别。五识地中触境方觉故名为触。染习一爱名为受者。毗婆沙说。爱有二种。一者食爱。二者色爱爱着女色。匍匐已后但有食爱。未有第二色爱已来说为受支。习近五欲是名爱者。色爱已起未有追求色境界来说为爱支。内外贪求名为取者内色为内。财事为外。贪求是时说为取支。为内外事起身等业名为有者。为财为色造业粗显。现世世识名未来生现在名色六入触受名未来世老病死等将前类后。是名总结

次广第二众生等有。亦内亦外。一切众生虽有十二或有未具总以标举。所具是内。未具是外。次别显之。先就欲界众生以论。歌罗罗死则无十二是未具也。于彼胎内五分之中。初分名为歌罗罗时。此时死者有前四支不具后八名无十二。所有四支即名为内。所无名外。从生至死具十二者斯名为内。次就色界众生以论。色界众生无三受者但有乐舍而无苦受。无三触者但有乐舍相应之触无有苦受相应触也。无三爱者但有乐舍所生之爱名无三爱。无老病者一切诸天悉无老病。所有是内。所无是外。亦名具者现虽不有以当有故亦名有具。下就无色众生论之。无色乃至无老病者。无色众生无其色支不具五入。触受及爱与色界同。亦无老病亦名具者当有同故。上来别论。以定得下总释其义。欲界众生现虽不具后生当备。上界众生在上虽无生下必具。故说一切众生等有。喻相如是。下合显法。佛性亦尔合十二缘。一切生下合等有之

上来第二明众生有

自下第三明诸众生依教不同有见。初先立喻。雪山喻佛。草名忍辱喻涅槃经。牛喻菩萨。食出醍醐喻学是经得见佛性。异草喻于小乘经法。牛喻声闻。食无醍醐喻学小经不见佛性。虽无已下明虽不见不得言无。下合显法。佛性亦尔是总合也。余文别合。与前不次。先合雪山及忍辱草。次合异草。若能听下就前忍辱合牛食者即成醍醐。牛食异草则无醍醐略而不合。十二部中虽不闻者不可说无。合向末后虽无醍醐不可说言无忍辱草。问曰。向说忍辱草者喻涅槃经。今合不可说无忍辱。正应道言不涅槃。何得乃言不无佛性。性是经旨。故言不可说无佛性

自下第六说一切法以为佛性。于中有四。一辩性体相。二叹经叹性令人习学。三重辩性相。四叹经叹性令人习学

就初段中先开九门。后广辩释。释中乃有十二门别。后非苦乐非我无我非空不空。前开门中略不标列。当是本中漏脱故尔。下释可知

第二段中若人思经如是之义则见性者举思见性叹经胜也。思前所说十二门义故能见性。佛性不思是佛境等。叹性深也

第三段中曲有四句。一明佛性非阴界入。二明佛性非本无今有已有还无。三明佛性可从缘见。四明佛性非内非外。于中先别铁色为喻。铁喻众生。黑色喻性。火喻烦恼。赤喻佛性随缘成染。合之可知。下别草木种子为喻。略无合文

第四段中大涅槃经具无量德叹经德广。佛性亦等叹性德备。上来一段答前四问明所证法

自下第二答后四问明能证法。先答前二。师子初先重问起发。下佛答之但明菩萨具足几法。略不论佛。与下所说见性行同故此不辩。明菩萨中先举十数。此十并是因分所行。故虽见性而不明了。次列十名。前八自利。后二利他。前八犹是八大人觉。于中初言少欲知足是离着行。未得法中而起少欲。已得知足。余六是其摄善之行。寂静修止。精进修作。正念正定止行成就。系心在法名为正念。法来摄心不动名定。正慧作成。见法名慧。解脱即是不戏论也。是止作果。离缚称脱。下化他中赞叹解脱令其爱好。大涅槃化正授以法

下广释之。于中五番。一一番中备含多法不可别名。就初番中先辩后结。辩中少欲知足二行一处论之。师子先问。少欲知足有何差别。下佛为辩。初先正辩。菩萨修集大涅槃明修所为。前中有三。一偏对染法彰其二别。二有少欲不知足下偏就净法彰其二别。三少欲知足复有二下双对染净彰其二别。初中四翻。一不求不取名为少欲。得少不恨名为知足。二少有所欲名为法事于世资生一向不忧名为知足。三离三恶欲并离二十五有之爱。及于未来所欲事中不贪不求。是名少欲。先离三欲。初举。次列。下辩其相。自身欲为一切众首令一切众皆随从已名为恶欲。欲令世人谓已是圣名为大欲。欲得生天及在人中富贵自在名为欲欲。不为此害名为少欲。第二言离二十五爱名少欲者不爱二十五有受身。第三不求未来事者不求未来五欲之事是名少欲。于前所欲得而不着说为知足。此第三番。四不求他敬名为少欲。得物不聚说为知足

次众净论。先开四门。下辩其相。道言少欲谓须陀者须陀洹人但求罗汉心不慕大故名少欲。道言知足谓辟支者。辟支佛人证无学果生知足想故名知足。出无佛世不知有大更可趣求故无所欲。少欲知足谓罗汉者。愚法之人得无学果生究竟想名为知足。不愚法者知有大乘终须修学。已离重苦求去心微故名少欲。不少不足谓菩萨者。于自所得不生足想名不知足。广愿求佛名不少欲

第三双就染净辩中。先举二数。次列两名。谓善不善。下辩其相

上来广辩。下明修为。为见佛性故修此二

就寂静中先举二数。身心列名。下辩其相。初先当法二门分别。下随人异四门分别。当法辩中两义释之。一约身心二恶分别。离身三恶名身寂静。杀盗邪淫是身三恶。离意三恶名心寂静。贪嗔邪见是意三恶二约起惑始终分别。身寂静者不近四众不预四众。所营事业离烦恼缘。心寂静者不集贪等离烦恼体。随人毕中为开白门。下辩可解

精进念定智慧解脱及赞解脱六门可知

说涅槃中分别有五。四暴犹是四流烦恼

下总结之。此十是其因分行故。菩萨虽见见性不了。第二番中先辩后结。辩中少欲知足二行一处释之。先举四病。造业求有名为有欲。次明四治。谓四圣种。下就四治结为少欲知足二行

寂静有四。先举次列。言出乐者地持论中名出家乐。出家学道解脱家难名出家乐。寂静乐者地持名为远离乐也。离于欲恶得初禅定名远离乐。永灭乐者地持名为寂灭乐也。二禅为首觉观止息名寂灭乐。毕竟乐者地持名为菩提乐也。无漏圣道永断烦恼名毕竟乐。此四乐中。初一是戒。中二是定。后一是慧。得四总结

具四精进名精进者谓四正勤。四念可知。言具四禅名四定者谓四如意。亦可是其色界四禅。此四力强故偏举之。见四实故名正慧者见四谛也。余皆可知第三番中先辩后结。文显可解

第四番中先辩后结。辩中修习十三头陀名为少欲。十二头陀经说多种。然今且依一相论之。处中有六。一住空处。余经论中名兰若处。去村五百弓名为空处。二端坐不卧。三在树下。四在冢间。五在露地。六随有草处而坐其上。食中有三。一者乞食。二随得为足。余经论中名一揣食。亦名节量食。三名一坐食。亦名一食。衣中有三。一畜三衣。二粪扫衣。他所弃衣名为粪扫。三着毳衣。余经论中说为纳衣。鸟兽细毛名之为毳。此之十二如别章中具广分别。修此十二名为少欲。行此不悔说为知足。次五可解。言离七漏名解脱者广如上说。见漏修漏根恶亲近受念七也。赞解脱中所列十相少异余处。上下多说。远离五尘生住灭法并男女相以之为十。此中说离生老病死五尘无常以为十也。无常犹是生住灭耳

第五番中先辩后结。辩中初先破离恶欲名为少欲。行如来行名为知足。由前二种得近涅槃及五种乐名为寂静。但云五果不列其名。如上文中涅槃四乐加以受乐得是五乐。不知是非又地持中说有五乐。一名因乐谓情尘触及爱果业。二名受乐谓身心受。三苦对治众苦息已有乐知生。四断受乐谓灭尽定。五无罪乐所谓出家远离寂灭及菩提乐。不知此说当彼以不。余皆可知。以具几法是中应答。文中略无

如汝言下答后二问。先牒问辞。下释有六。一正对前问就眼分别。十住菩萨慧眼见故不得明了。慧眼见空不见实故。佛眼见性故得明了。证实之智是其佛眼。二就行分别。为菩提行见性不了。不为行者见性了了。证实之时不见已外更有菩提可为行故。三约位分别。住十住地见性不了。无住无去见性了了。证实之时不见十地可以住中名为不住。亦无佛果可以趣向称曰不去。四对因分别。十住菩萨智慧因故见性不了。佛断因果故得了了。证实之时实外无缘。知复约何说因说果。故断因果方得了了。五约境分别。十住不能觉一切法见性不了。佛觉一切故得了了。良以十住缘观未尽。缘未尽故心有所在。是故不能觉一切法至佛息缘真心平等无处不在。无不在故无有一法在于心外。亦无一心在于法外。心与法界同体照明故觉一切。六就眼见闻见分别。先举二数。次列两名。下就人论两阶辩异一佛与十住相对分别。诸佛眼见故得了了。十住闻见故不了了。下明十住不了之相。唯能自知定得菩提。不知众生悉有佛性。二十住已上共九地下相对分别。佛与十地同为眼见故得了了十住菩萨眼见自身得菩提故。九地已还是其闻见。初言一切乃至九地闻见佛性正明闻见。若闻一切众生有下辩闻分齐。闻生有性不信之者不名闻见。能信已后方是闻见。何处众生闻能生信。若论成就种性已上少分生信。十信亦能。从初答问讫来至此四段之中。第一大段略明证法

自下第二约对前法劝修趣入略明证行。文别有三。一依向前能证行法教见如来。二复有二种一为利养二为法下依于向前所证理法教见佛性三师子言如佛所说见于如来及见佛性义云何下双显前二。问曰佛性是所证法可须教见。如来非理何须教见。释言见性必由相入。佛是性相故须教见。今此文中教见如来趣入佛性。下第四段广证行中教见涅槃趣入佛性。义之左右。就初教见如来之中文别有三。一教寻经知见佛身。二师子吼言众生不知如来心下教其寻相知见佛心。三如佛说庵罗果下教以四亲知见佛行。盖乃教入之次第也。初中若有男子女人欲见如来标示所求。应当修下正教见法。寻教受持读诵解说知佛身相名见如来。如上金刚身品中说。亦如维摩阿閦品说。自下第二教见佛心。师子先问。一切众生不知佛心云何得知。下佛教之。一切众生实不能知略述其言。次正教示。后总结之。就正教中教依二见以测佛心。先举次列。若见以下六门广辩。一观佛身业名为眼见。观佛口业名为闻见。二见佛妙色名为眼见。闻佛妙声名为闻见。三观如来神通现化但为众生不为利养名为眼见观佛以其他心智通观察众生为说法时但为众生不为利养名为闻见。四观如来受身所为名为眼见。说法所为名为闻见。云何受者慈悲故受不以受结。何故受者为益众生不为利己。为谁受者等为一切。云何说者慈悲心说不为利养。何故说者为益众生不为利己。为谁说者等为一切。五观如来他人以身加毁不嗔名为眼见。他人以口骂辱不恼是名闻见。六观如来八相成道名为眼见。闻八相时一切言说以为闻见。于中先闻未成道前所有言说。既成道下闻成道后所有言说。梵王先请。如来次违。梵王下复举利重请。下佛因请为之宣说。于中初先敕听许说。下明所说。宣说中道总明所说。次别显之。别有五句。初三约就化行辩中。次一约就化人说中。后一约就化益论中。就前三中初句化人断结行中明其中道。不破诸结明其非有。此如上说。无慧能破无惑可破名不破结。非不能破彰其非无随相论治有惑可断故非不破。又复圣人证实之时无惑可生亦名为破。非破不破是名中道牒以结之。第二化人度苦行中明其中道。不度众生明其非有。于理无人可化度苦名为不度。非不度生彰其非无。随世度人令出诸苦名非不度。是名结之。此二离障。第三化人成善行中明其中道。非一切成明其非有。于理无人可化成善故言非成。亦非不成彰其非无。随世化人成三乘善故非不成。是名结之。上来约就化行辩中。次一就其化人说中。不自言师明不自高。不言第子彰其不下。是名结之。下一就其化益论中。说不为利明无所得。非不得果明非无得。是名结之。上来别显。下总叹之。正实时真叹其语净。软言合法名为正语。离妄不虚说为实语。言无乖离应时乖合故曰时语。言无绮异称当法理说为真语。言不虚发语能益人微妙第一语能合法。上来广辩。如来心实不可见下总以结之

自下第三教见佛行。师子先问。如先所说庵罗果喻四种人等牒佛上言。有人行细心不实等辩前四人。是初二种云何可知就之为问。如佛所说虽依是二不可得知重牒征问。如佛所说四种人中虽依是二不可知也

下佛先叹。次述其言。所喻二人实难可知。下教捡验。于中先教能验之行。或有二下教示所验。前中先举四亲近行。初二验身。后二验心。广如上释。具足四下结叹四能。教所验中戒有二种举其所受。持者亦二举其持戒。究竟不竟双列二名。下辩其相令人识知。有人以缘受持禁戒明不究竟。为其世事因缘受持名有因缘。智者观下教其捡验。如来戒下明其究竟。于中有四。一明如来不为世事因缘受持故名究竟。二以是义下举因况果明佛究竟。毕竟究竟正是一义。重言显胜。亦可毕竟胜过菩萨。究竟过前不究竟戒。三我昔下即事以显。四不究竟戒尚不能下举劣显胜成佛究竟。不究竟戒尚不能得二乘道果况大菩提。佛戒能得无上菩提明究竟戒

自下第二教见佛性于中有三。一教见性。二持戒比丘虽不愿下明所修行能相起发。三师子言若因持戒得不悔下问答料简。初中行别有十四阶。始从持戒乃至见性。戒中得失相形显之。凡有五对。一所为分别。先举次列下显得失。为利持戒不见佛性及与如来。为法能见。二浅深分别。先举次列下辩其相。三就为自为他分别。先举次列下显得失。四自持他教相对分别。先举次列下辩其相。五大小分别。先举次列下辩其相。后显得失。受声闻戒不见佛性及与如来。受菩萨戒则能见之

下明不悔乃至见性。师子先问。下佛辩之。先辩后结

第二段中明前诸行能相起发。得初后随

第三段中师子先难。若因持戒得不悔果因于解脱得涅槃果牒佛前言。戒则无因涅槃无果以理征定。下就设难。戒若无因则名为常就前设难。不从因生故名为常。涅槃有因则无常下就后设难。然此不难涅槃无果。唯难向前从解脱因得涅槃义。先以有因难破常义。后难乐等。前难常中有因无常是略语也。若尔已下是广难也。若彼涅槃实尔有因。本无今有便是无常。如灯喻真。下难乐等。涅槃若尔云何得名我乐及净。下佛先叹。善哉总叹。汝曾下别。无量佛所种善能问叹问所因。不失本等叹能不忘。次敕许说。下为解释。先解初难明戒有因彰戒非常。文有五句。一明戒行因于听法。二明听法因于近友。三明近友因于信心。四明信心因于闻法及思惟义。五明信心与彼听法互相因起。于中初法次喻后合。法中信心因于听法听法因信正明相起。如是二法亦因亦因因亦果亦果果双牒重显。信心是彼听法家因故名亦因。听法复彼因作因名亦因因。听法望信义亦同尔。信心是其听法家果故名亦果。听法是彼果家之果故名果果。听法望信义亦同尔。喻中尼干立拒举瓶色法为喻。如无明等心法为喻。问曰无明缘行可尔。云何行支能缘无明。解有两义。一前后分别。从前无明生于其行。行后还复生于无明。谓生[雨/復]业受生无明。二同时分别。前无明时亦有业思。后行支时亦有无明。互相因起。余亦如是。生能生下举其非色非心之法以为譬喻。大小八相广如上辩。今明此八互相因起。于中且就大小二生明相因起。余类可知。生能生法不自生者彼大生相但能生于色心等法不能自生。其犹世间眼不自见指不自触。不自生故由生生生明其大生由小生生小。生偏能生于大生故名生生大生。为此生生所生名生生生。生生不自生赖生生者明其小生由大生生。小生虽复能生大生不能自生。不自生故赖大生生。如是二生亦因亦因因亦果亦果果双牒重显。解不异前。下合可知

次答后难。辩明涅槃无因生故得名为常。于中有三。一正明涅槃是果无因。二是因非果名佛性下举彼佛性是因非果。对显涅槃是果无因。三因有二下简彼菩提异于涅槃。是中宣说性净之果以为涅槃。方便之果说为菩提。是故涅槃不从因生菩提得为生因所生。前中复三。一明涅槃是果非因。二明涅槃无因是果。三以是义下总以结之。就初段中是果非因谓大涅槃总以标举。涅槃为彼了因所显故名为果。而不生他是以非因。又不同彼佛性唯因故曰非因。虽言非因宗显是果。何以下释。先问后解。但解是果。句别有六。初之一句对劣显果。涅槃一切果德中上故云上果。是上果故名为果矣。次有两句对因显果。谓沙门果婆罗门果。沙门名息。八圣道分能息烦恼故名沙门。涅槃由彼显了而得名沙门果。婆罗门者此名净行。三十七品能治烦恼故云净行。涅槃为彼显了而得名婆罗门果。后之三句对障显果。断生死者断除分段变易生死方始证得故名为果。破烦恼者破五住结方始证得故名为果。为诸烦恼所呵责者体违惑染故名为果。一切烦恼违反涅槃故名呵责。言烦恼者名为过过显前呵责。烦恼体是过患之法而呵涅槃。与彼涅槃而为过失故名过过

自下第二辩明涅槃无因是果。初先正辩。师子言下问答重显。前中初言涅槃无因而体是果总以标举。涅槃不为生因所生是以无因。是果如上。虽举是果意显无因。何以下释。先顺次反后释名义以显无因。顺中七句。无生灭者常故无因。无所作者不从作生所以无因。非有为者不藉缘造是以无因。此三是本。下重显之。是无为者显非有为。常不变显非生灭。下无处所及无始终显无所作。若有处所则可造作。无处所故不可造作。又若始微终着之法则有造作。无如是义故无造作。上来顺解。言若有因则不得称为涅槃者反释无因。槃言因下释名显无。上来正辩

下重问答显无因义。师子先问。如佛所说涅槃无因是义不然非破令无。下牒佛说推为六中。有时无因非一向无。若言无者则合六无牒以总推。次辩六无。皆初列名后辩可知。涅槃亦下别明涅槃合彼六中有时无因

下佛答之。先取其义明同毕竟。世法涅槃终不对下简有异无明全不同。良以无因似彼世法毕竟不我故说为同。彼毕竟无乃无于我涅槃有我故说不同。初中汝说如是六义何故不引毕竟无者以喻涅槃乃取时牒以教呵。涅槃之体毕竟无因。如无我等释同毕竟。第二辩明不同义中世法涅槃终不相对是故六事不得为喻略显不同。名前六无以为世法。就世以求唯空无我无有涅槃真我可得。知复将何对于世。以无涅槃真我为对。故说世法毕竟无我。若有真我以为对者无我我所不名毕竟。若当就彼涅槃以求唯是真我无有世法无我可得。知复将何对于涅槃。以无对故不得宣说涅槃同彼世间之法毕竟无我。为是六事不得为喻。下重释之。一切诸法悉无有我彰毕竟无不同涅槃。而此涅槃真实有我释其涅槃不同毕竟。以是义下第三总结。以是前说六义是果七义无同。故涅槃法无因是果。上来第一正明涅槃是果无因

自下第二举彼佛性是因非果对显涅槃是果非因。于中初言是因非果名为佛性略以标举。下释其相。先解非因生故是因非果明性非是生因家果。非沙门果故名非果明性非是了因家果。何故名因以了因故释是因也。因有二种。一法佛性。二报佛性。如来藏体是法佛性。于此体上有可出生报佛之义名报佛性。其法佛性望彼涅槃性净之果。但是了因而非生因。故下文言涅槃因者所谓佛性。佛性之性不生涅槃云何为了。彼如来藏性是真法研之则明。从本已来有可显了成涅槃义故名了因。如瓶中灯有可见义瓶破则见。其报佛性望彼菩提方便之果是其生因。从本已来有可出生菩提之义故名生因。今从初义。是故说言以了因故佛性是因

自下第三简彼菩提异于涅槃。方便菩提从因生故。先举二因。生了列名。次辩其相。生法名生证了名了通相分别。了因非一且就灯辩。烦恼生因父母了因别就内论。谷等生因地等了因偏就外说。下约显法。六句三对。初二一对。六度佛性望大菩提以分生了。六度为性。佛性为了。六度有二。一缘修六度。正能熏生方便菩提故名生因。二真行六度。正能集成方便菩提亦名生因。满为果故。由见佛性成菩提智。如似色尘发生眼识故名了因。此初对中佛性六度及菩提果即为根本。下皆望此以别生了。宜须识知。次二一对。望初对中佛性菩提以别生了。望前佛性以为了因。六波罗蜜能了性故。望前菩提宣说生因。首楞严定生菩提故。此首楞严犹前佛性。了彼成德名首楞严。此首楞严为缘熏发。于其体上菩提得生故名因生。如依金体起庄严具非前后生。后二一对。望初对中六度菩提以别生了。望前菩提宣说了因。八正能了大菩提故。是义云何。真心之体先为治熏。菩提德生。其德虽生犹为缘治之所隐覆不得显现。更修八道观真无妄息去缘治令真心中诸德显了故名了因。望前六度宣说生因。信心能生六度行故

前教见佛。次教见性。自下第三双显前二。师子先问。如佛所说见于如来及见佛性是义云何。问其见相。如来之身无相貌下难其可见。于中先明佛身离相不可得见。后类佛性

下佛答之。先对初问辩见相。如来之身有二种下释去后难明其可见。前中先明见如来相。佛身二种略标所见。常与无常列其二名。下约此二彰其见相。其无常者为度众生方便示现应化之身。可以目睹名为眼见常者真实解脱之身亦名眼见亦名闻见。初闻生信名为闻见。终证显了说为眼见

下明见性。两门分别。一可见不可见相对分别。佛性二种总以标举。可见不可见列其二名。其眼见者名为可见。自余一切名不可见。下辩其相。言可见者十住诸佛可眼见也。言不可见九地已下一切众生同非眼见名不可见。二眼见闻见相对分别。其眼见者十住诸佛眼见众生所有佛性。于中别分十住唯见己身佛性。佛见众生所有佛性。今此自他所有佛性通名众生所有性故。宣说十住诸佛如来眼见众生所有性矣。其闻见者一切众生乃至九住闻有何处有佛性一切此如上辩。定能闻见种性已上。通则十信闻性不谤亦名闻见。此答初问

下释后难。明佛与性皆是可见。于中有二。一明佛身有色非色。二明佛性有色非色。三总就此二明色眼见非色闻见。初中如来有二举数。次列两名。下辩其相。色者解脱实德身也。诸根相好皆遍法界无碍自在故曰解脱。非色如来亦断色者六道身灭故曰非色

性中两门。一佛望余人相对分二。先举二数。次列。下辩。色谓菩提果德性也。佛见分明故名为色。非色凡夫乃至十住就人显示。十住菩萨见不了了名非色者释非色义就胜解释。余类可知。是故偏言十住不了。问曰已知佛见了了名之为色。余见不了名为非色。性实如何。释言佛性相空体有。相空非色。体有义边亦色亦心。体是真识故名为心。体是法身。眼耳鼻舌诸根之性故说为色。故经说言众生身中有如来眼如来耳等。今欲约之明见不见是故偏说为色非色。此一门竟

二菩萨及佛望余说二。先举。次列。下辩其相。道言色者谓佛菩萨就人显示。初地已上见性分明同名为色。非色众生就人显示。地前众生见性不了名为非色。问曰前说唯佛是色今以何故地上所见亦悉名色。色有体用。如来藏中色性法门是其色体。依此集起凡圣色身是其色用。体唯佛穷故前宣说佛见是色。真用之色地上渐见。见一切法皆从真起。故今复说佛菩萨见悉皆是色。第三段中色者眼见非色闻者。于前所说佛及性中色皆眼见非色皆闻见。准斯地上一切菩萨皆得名为眼见。佛及菩萨所有佛性皆名色故。从见如来至此第二。劝修趣入略明证行

自下第三广明证法。于中有二。一广上初中所证理法。二一切众生不可思下广上初中能证行法。问曰前说有何不尽更须广乎。释言前者直出性体。未曾就人辩定有无。故今显之。又前约就菩提因果明能证法。未就涅槃因果以论。故下辩之。又复前者明佛菩萨行修见性。未明凡夫二乘修见。故下辩之。明有缚解修道等也。就初段中先开章门。后广辩释。性非内外然非失坏是开门也。众生身中即未有果名为非内。而有其因说为非外。以有因故必定得果名非失坏。其因现有果是当有故名悉有

下广释之。先就向前第二段中众生当性明凡未有显成非内。师子吼言乳中无酪麻无油下广就向前第一段中众生现性明凡不无显前非外。汝不可以有退心故言无性下明有性因终必得果显非失坏。初中有二。一约乳酪转变因果明性非有。二约树子相生因果明性非有。前中有五。一师子吼当相立有佛破明无。二若乳无酪角亦无下师子以其非异因生证性定有佛破明无。二若乳无酪乳中亦无庵摩罗下师子以其不生异果证性定有佛破明无。四我今定知乳有酪下师子以其人取证有佛破明无。我若乳无酪云何佛说二因已下师子以其缘正二因证性定有佛破明无。就初段中有二问答。初师子吼牒佛上言执为定有。如佛所说众生有性如乳中酪金刚力士牒上因性。诸佛佛性如净醍醐牒上果性。云何说言非内非外将前微此。此问之中正征非内非外随来。下佛对之。明性非有。于中且就酪喻以答。我亦不说乳中有酪酪从乳生故言有酪释有显无。下师子吼乘言立有。乳实有酪。但一切法生各有时。酪法在于乳后而生非是先无。下佛对破。句别有四。一反有立无。二以二名破有立无。三举后类前。四释有显无。就初句中乳时无酪亦无苏等自立无义。一切众生亦谓是乳举世同知证成无义。是故下结

自下第二以名破有成其无义。如其有者何故不得二种名字就乳正征。乳中有酪何故不得乳酪二名偏名为乳。如人二能举事类征

自下第三举后类前成前无义。先举后酪以类前乳。酪时无乳苏至醍醐自明酪时无其余味。酪时无乳果中无因。无生苏等因中无果。众生亦谓非乳苏等举他证无。酪时既无一切余味。乳亦如是何得有酪。乃至醍醐亦如是者彰后生苏乃至醍醐并无余味

自下第四释有显无。乳是酪因故言有酪非有酪体。文中初先举其二因。次列。后释。下就结有

自下第二师子以其非异因生证乳有酪如来对破。有二问答。师子初言若乳无酪角中亦无何不从生举异因难。下佛印取角亦生酪。何以下释。角性暖故为缘生酪。如来何意说角生酪。为欲将角类显乳故。类之云何。角能生酪角中无酪。乳中生酪何得有酪。师子下以人取为难。若角生酪求酪之人何不取角。下佛为释。我说二因角缘非正故人不取

自下第三师子以其不生异果证乳有酪如来对破。有二问答。师子初问若乳无酪今方有者乳中本无庵摩罗树何故不生举异果难。下佛先印。乳亦能生庵摩罗树。乳灌一夜生五尺故。如来何意说乳能生庵摩罗树。为欲将树类显乳故。类之云何。乳能生树。乳中无树。乳中生酪何得有酪。若一切下释去难辞。若一切法一因生者汝可难言何故不生。明因别故不生庵摩。如四大下明果异故不生庵摩。举彼四大造色各异。类明乳等生法各异。以是下结。以是因别果异义故不生庵摩。师子下复因喻请法。如佛向说正因缘因佛性是何。下佛为释二因所摄。正谓众生。缘谓六度。良以众生真妄集成其犹矿石。真妄成故能为离妄净德之本故曰正因。诸度但能除妄显真故说为缘。此望何果。释言望彼性净之果。众生实性以为正因。六度为缘。理在灼然望彼方便菩提之果义有两兼。一众生佛性以为正因。六度为缘。报佛之性正能生彼菩提果故。故下文言佛性正因发心缘因以此二因得菩提果。二六度正因佛性缘因。法佛之性不能正生菩提果。故故上文言复有了因佛性菩提。复有生因六波罗蜜阿耨菩提。正即是正。了即是缘

自下第四师子以其人取证有如来对破。师子初言我今定知乳有酪性总相立有。何以下释。以人取故明知定有。是故下结。下佛对破。文别有三。一正破所执。二明当服苏今患臭下呵其妄取。三如有纸下教其正义。初中有四。一以人取破其定有。二何故卖人但取乳下以人不取破其定有。三世人无子故求娉下还以人取破其定有。四若乳有酪何故一时不见已下以人不见破其定有。初中有三。第一如来以人取刀类破师子人取证有。汝问不然牒以直非。何故下释。一切众生欲见面像即便取刀举事类征。人虽取刀刀中无面。求酪取乳何得有酪

第二师子乘言执有如来对彼。师子初言以是义故乳有酪性准刀立有。以人取刀刀有面性。乳亦如是定有酪性。若刀无面何故取刀破无成有。佛答有三。一以所见颠倒来破。若刀有面何故颠倒。欲见南面而睹北像故曰颠倒。二以所见长阔。来破。有面应定何故竖刀则见面长横刀见阔。第三约就自他以破。若是自面应当似己何故见长。亦应责言何故见阔。且责一边。若是他面何得称言是己面像。若因己面见他面者。何故不见驴马等像

三师子吼乘言救义。如来随破。师子救言刀面非长眼光到彼寻刀看面是故见长。亦应说言光到见阔。且举一边。下佛破之。光实不到总翻其言。何以下释。句别有六。前五破其光到方见。后一破其光去不到亦能得见。前五句中初以远近一时能见明光不到。眼光若到远应迟见。二以不见中间诸物证光不到若到应见。三见火不烧明光不到若到应烧。四遥见生疑明光不到。眼光若到到看应审何故生疑。五能见于水精物等明光不到。下次破其不到能见。因前被破人喜救义。眼光虽去无障碍处光到而见。有障碍处不到亦见。故今牒之若不到见。下就设难。等不到见何故但见水精中物而不见于壁外之色。如人上墙见墙外事眼光若去往至墙上何故不见壁外之色。上来六句广破光到。是故已下总以结非。上来第一还以人取破其定有

自下第二以人不取破其定有。汝言有酪牒上执辞何故卖人但取乳价不责酪直就乳正征。偏取乳价。不责酪直明知无酪。卖草马下举事类征

自下第三重以人取破其定有。世人无子故求娉妇举其取事。下就破有。句别有二。以先有儿征为非女。若先怀妊便是其妇何得言女。二若是女下以先是女难破有儿。句别有四。一牒以直非。若言是女先有儿性故应嫂者是义不然。二何以下破有儿性亦应有孙过分类征。若女生儿得有儿性。女中之儿亦应有儿故言有孙。三若有下破其有孙。恐其破征齐立有孙故复破之。若有其孙是儿与孙便是兄弟。何以下释。一腹生故。四是故下结无非有。以有儿性有前过故我说无儿。自下第四以人不见破其先有。先就乳等责其不见。次就树征。后类乳等。上来四段合为第一破其所执

自下第二呵其妄取。明当服苏今已患臭立喻呵责。言乳有酪亦复如是合喻呵责。知酪后出先生有想

自下第三教其正义。文别有二。一明性非有。二众生佛性不破坏下明性非无。前中有四。一喻说非有。喻别有三。文显可知。二一切法本无有性法说非有。三举前偈证成非有。四偈后释义以显非有。一切诸法因缘生灭泛明诸法非是本有。若众生内有佛性者应有佛身。如我今者正明佛性本无非有。此说无果不言无因。问曰经说众生身中有佛眼耳鼻舌身等如我不异。此说言无有何所以。释言佛性有其二种。一法佛性。本有法体与佛无别。隐显为异。如在矿金与出矿金多少无殊净秽为异。二报佛性。本无法体。但于向前法佛性上有其方便可生之义。如矿中金有可造作庄严具义。亦如树子不腐不坏有可生义。非先有树已在子中。以余经说。是法佛性此经言无是法佛性不相乖反

第二明性非无之中文别有四。初众生性不破坏等法说明有。二如众生中所有空下喻说明有。于中初明虚空是有。若使众生无虚空下破无成有。以是义下引说证有。虚空界者是名虚空结空为有。三佛性如是合喻明有。四十住下就人分别。有四。一明佛性佛菩萨见。二非是下明非凡夫二乘所见。三是故下明不见损。四见佛性下明见知益

自下第五师子以其缘正二因证性本有如来对破。师子先问。众生有性如乳中酪自立有义。若乳无酪云何佛说有二因等破无成有。虚空无性故无缘因举无显有。佛破有三。一就喻破有。二就法破有。第三双就法喻破有。初中三番。第一如来对问正破。若使乳中定有酪者何须缘因待缘方有明知本无

第二师子乘言救有如来难破。师子初言以有性故故须缘因总立有义。何以下释。为欲明见故须缘因。初先法说。次以喻显。喻别有三。乳中下合。是故下结。是故虽有要须了因结明须了。以是义故先有酪性结成有酪。下佛破之。文别有二。一约性酪征立性了。二若是了因复下须下难破性了成无性酪。前中初言若使乳中有酪性者牒其所立。即是了因征立性了。乳中既得有其性酪。酪由了有。明知乳中即有性了

就后难破性了之中文别有四。初若是了因复何须了以内征外。乳中先自有其了因何须乳外醪暖为了。此即以外破内。现见要须外事了因明知乳内先无性了。性了既无乌有性酪

二若是了因性是了下征令自了。征相云何。若是乳中所有了因性是了者常应自了。使人眼见不能自了。使人眼见明性非了。既无性了宁有性酪。三若是不了何能了他难破了他。难相云何。乳中了因不能自了。何能了他乳中之酪令其性有

四若言了因有二种下难破俱了。云何难破。乳中性了能自显了能复了他。乳中之酪义无斯理。文中初言若了有二自了了他是义不然举以直非。了因一法云何有二以理征责。若有二下将乳类破。若有二者乳亦应二准了责之。责之云何。乳中了因得有自了了他二种。乳亦应二。一者有自性之酪。二有了因所了之酪。若乳无二云何了因而独有二以乳破了。乳中既无两种之酪云何乳中独有二了。了无二故不能自了亦不了他。何能了他乳中性酪令其有乎。此第二番

第三师子乘言救义。如世人言我共八人自数数他。了因亦尔自了了他。下佛对破。了因若尔则非了因准喻破了。了因同彼我共八人故曰若尔。自色不能自数数他。了因同彼不能自了亦不了他何成了因。是故说言则非了因。何以下释。数者能数自色他色故得言八辩其数相。标牒数者智慧能数。自色他色是其所数。就所数中自色为一他色有七故名为八。次定是非。而此八中自己色性不能辩了己体为一他色为七名无了相。此显非也。无了相故要须智性乃数自他此彰是也。下约破了。是此了因同。其自色不能自数及数他故。不能自了亦不了他。上来第一就喻破有。自下第二就法破有。句别有四。一一切众生有佛性性何故修习无量功德难破有性此名佛果为佛性性。众生身中已有佛果何须修习。二若言修习是了因者已同酪坏难破须了。师子立意性体虽有须修了之令现。故举破之。已同酪坏指同。前酪前酪喻中若有性酪应有性了。若性是了何须外缘以为了因。破此同彼名同酪坏。三若言因中定有果下重破有性成上初句。若言因中定有果者戒定智慧则无增长以理正破。前初句中有不须修。此句之中有无增长。左右言耳。我见世人本无渐增举见验非。四若言师教是了因下重破能了成前第二。若言师教是了因者举其能了。前第二中行为能了。此说师教以为能了。言左右耳。当受教时受者未有戒定智慧辩其道理。始闻未行是故未有若是了因应了未有云何乃了戒定智慧令得增长就之设难。难意云何。若彼师教是其了因正应了向所未有者戒定智慧今其使有。云何乃了性戒定慧令得增长。问曰上来何曾说有性戒定慧而为此难。彼立因中所有果性即是自性戒定智慧故为此难

自下第三双就法喻破其本有。有二问答。初师子门。若了因无云何得名有乳有酪以理直请。下佛答之。先立三答。次辩其相。举后答前名为转答。默止令解说为默答。异法相并令疑舍取名为疑答。指文可知下。就三中初门对门我今转答总以标示。如世人言有乳有酪以定得故得名有者就喻转答。牛食水草定得乳故说言有乳。有乳之者定得酪故名为有酪。佛性亦尔有生有性以当见故就法转答

下师子吼重复设难。佛说不然牒说总非。下广显非。文别有三。初过去已灭未来未到云何名有总难法喻。现若不有正得名无云何乃言当有名有。此正难当过去类之。二若言下别难前喻。若言当有是义不然牒喻以非。如世间人见无儿息便言无子举事类征。世人无儿正得言无不得言有。乳中无酪正可说无。云何说言当有名有。三一切生下别难上法。一切众生现无佛性正可说无云何言有

下佛答之。于中初先泛立有义。后就答问。就立有中正明当有通论过去。文别有四。一明过有。如橘从芽其生异一切甘甜。熟已乃酢酢由本子故名过有。二明当有。如种胡麻预说有油。三重明过有。如人骂王多年受殃。四重明当有。如问陶师预答有瓶。上来立有。下就答难。乳中有酪就喻以答。众生性下就法以答。佛性如是略明当有。欲见已下广显当有。欲见佛性应当观察时节形色。是故我说一切有者未来净身得见佛性。是故名为时节形色

上来第一就其乳酪转变因果破定有性。自下第二就其树子相生因果破其有性。文别有三。一师子吼当相立者如来对破。二如佛说二种因下师子以其缘正二因证性本有佛破明无。三若尼拘无性何不出油下师子以其不生异证性本有佛破明无。初中师子先立有义。一切无性云何而得阿耨菩提。以因故得。因谓佛性法说明有。一切无性云何而得破无成有。以因故得明有非无。何等因下出其因体。若尼拘下喻说明有。喻中尼拘正立其喻。如瞿昙下转喻显喻。尼拘陀子亦如是下合喻显喻。如世尊下帖喻显喻明有佛性。佛性如是合喻明者。下佛且就尼拘之喻以破其有。汝言子中有尼拘陀是义不然牒以总非。如其有者何故不见略以征破。如世间下广以征破。于中先举世间八种不见因缘。次明尼拘不同彼八责其不见。若言细下遮其同义。初先正破。本无粗下以理教示。破中若言细障不见是义不然牒以总非。人谓子中尼拘陀树同前第五细故不见。亦同第六障故不见。故牒非之。何以下释。先征后辩。树相粗等破前细也。子中之树必具根茎枝叶等事故言相粗。若言性细云何增长遮其救义。恐其宣说性细事粗故为此遮。若障不见常应不见破前障也。汝立性树障亦应性有性障故常应不见。下教示中本无粗相今则见等明粗本无。本无见性今则见等明见本无。子亦如是本无树下类以教之。所生之树同粗同见本无今有竟有何咎

自下第二师子以其缘正二因证有本性佛破明无。师子初言如说二因尼拘陀子以了因故令细得粗乘言救义。由佛前言若性细者云何增长故为此救。佛破有四。初若本有何须了者难破有树。二若本无下难破无粗若无粗性了何所了是一破也。本无粗性竟何所了。若本无粗了故生粗何故不生佉陀罗树是二破也。二俱无故释破所以。粗与佉陀并皆先无何不俱生。三细不见下责其不见。若细不见粗应可见法说以责。如一尘下喻说以责。如是子中粗应可见合喻以责。何以故下辩相以责。辩明子中树有多果果有多子子有多树故名为粗。四若尼拘子有性生下举烧类破。于中四句。一将树类烧。若子生树便言有树见子被烧本应有烧。二若本有烧树不应生难破有烧。师子被征喜立性烧故须难破。三若一切法本有生下难破生灭两性并立。师子被征喜于树中建立两性。生性故生灭性故烧故复破之。破意云何。子中生灭两性既并。以何义故先生后灭不得一时。四以是义下结成无性

自下第二师子以其不生异果证性本有佛破明无。有二问答。初师子言若尼拘陀无树生树亦无有油何不出油。下佛印取明亦生油师。子重征。何故不名胡麻油也。下佛为释。非胡麻故当问正解。如火下喻。尼拘下合。甘蔗下喻。文显可知。上来第一明众生中即未有果显前非内。下明有因彰前非外。师子先作无性之难。下佛释通。难中准答有十二。句文中少一。其十二者。一以业得果难破有性。二若生有性何缘阐提断善根下举一阐提断善堕狱难破有性。三若菩提心是佛性下举一阐提断菩提心虽破发心为佛性义。四若生有性何故名为初发心。下举初发心难破有性。五云何而言毗跋致下举退不退难破有性。六一心趣下执缘为正难破有性。七如乳下举有佛性征破假缘。八若定有性行人何故见三恶下举有佛性征破有退。九亦不须修六波罗蜜多下举修乃得证无佛性。其第十句举有佛性责人不见。文中略无。其第十一僧若常下举僧常住无作佛义难破有性。其第十二众生本无菩提心十举菩提心本无今有类性本无。准答定尔不得增减

就初句中师子初言乳中无酪麻无油等牒佛上来无性之言。如佛先下破佛前来有性之语。何以故下自立无义。先征后辩。人天无性故可作等举近类远。菩萨以业得菩提等将远类近

第二句中若生有性牒佛有义。何因缘下举事难破

第三句中若菩提心是佛性者逆取佛意。下对征破。一阐提等不应能断是一征也。佛性常法云何可断若可断者云何言常是二征也。若非常者不名佛性是三征也

第四句中若生有性牒其有义。何故名为初发心耶对以征破。此还约就发心为性故为此征。性是常法云何初发

第五句中文少不足。若具应言若有佛性云何而言是毗跋致阿毗跋致。毗跋名退。阿毗不退。佛性常住云何得有退不退义。毗跋致者当知无性以退证无

第六句中别有两句。一执缘为正。二难破别性。前中初言一心趣向是求佛心。大慈悲等念众生心。此二一对。见生死等厌有为心。观涅槃等求无为心。此二一对。信三宝等是归善行。受持禁戒是离非行。此二一对。上来举如是等法名为佛性执之为正。自下第二难破别性。若离上来一心趣等别有佛性。何须此等而作因缘

第七句中乳不假缘必当成酪举其所同。不假人功水瓶绳攒名不假缘。非全不假醪暖等缘生苏不下彰其所异。众生亦尔有佛性者应离缘得征同前乳

第八句中先定有义。行人何故见三恶等举退难破

第九句中先以有性难破须修。非不因下以其须修难破有性

第十所少已如上辩

第十一中以僧常住无作佛义难破有性。如佛先说僧宝是常举佛先言。如其常者则非无常以理审定。非无常下难破得果。僧若常下以不得果难破有性

第十二中初先明其菩提之心及菩提果本无今有。次将类性。以是义下结成无性

下佛先叹。后为辩释。释难不尽而复不次。前十二中但释九句。第二第六及第十二略而不解故云不尽。就所释中先答第一第四第八。却答第三第七第九第十及第十一。后答第五故云不次。文中初言一切众生实有佛性翻答第一明有非无。汝言有性不应初发牒第四句。下为辩释。心非佛性明性异心。何以下释

汝言何故有退心者牒第八句。下为辩释。明有性故不毕竟退。实无退心正明无退。若有退下难破有退成心无退。以迟得下释成退义成非永退。以斯准验。但令一念发心求佛定得菩提无退灭理

此菩提心实非性下答第三句。向前问言若菩提心是佛性者一阐提等不应能断。今明此心非佛性故阐提能断。文中初言心非佛性略为释非。何以故下释显非义。先征后辩。一阐提等断善堕狱举断显非。若菩提心是佛性下破是显非。两句破之。初明若心是佛性者是心则常。一阐提辈不能得断不名阐提。而菩提心为人断绝成阐提故明知非性。后明若心是佛性者则非无常。是无常故明知非性。上来释非。是故下结

次答第七。汝言有性不应假缘如乳成酪是义不然牒问总非。何以故下释显非义。先征后辩。若言五缘成于生苏牒前问中所异之喻。佛性如是辩性同之

譬如已下答第九句。向前问言若有佛性不应须修六波罗蜜。今此约喻明虽有性要修乃得。文中先喻。后合显法。喻中众石有金有银有铜有铁喻生有性。众石喻于种种众生各有性也。俱禀四大一名一实而其所出各各不同。喻诸众生得果各异。俱禀四大喻诸众生同以阴成。言一名者同一矿石。喻诸众生同名众生。言一实者同用四大以为体实。喻诸众五阴为实。而其所出各不同者喻性别故得果各异。要假众缘然后出生喻诸众生假缘得果。是故当知本无已下喻明佛果在因未有道其本无。显必假缘。下合显法。众生佛性合前众石有金银等。不名为佛合本无金。以诸因缘和合见等合假众缘然后出生

次答第十所少之句。汝言有性何故不见牒其问辞。准此牒辞外国经本定有此问。不然总非。何以下释。缘未合故无缘不见。以是义下得缘方见。先举二因。缘正列名。正因佛性缘因发心辩定二因。以二因缘得菩提者明因得果。佛性望于菩提之果说为正因。此文最显。如石出金举喻类显

汝言僧下答第十一。明僧常住皆由佛性不得说言僧常无性。先牒问辞。下为辩释。释中四番。第一明其圣弟子僧常由佛性。二明十二部经之僧常由佛性。三明十二因缘之僧常由佛性。四明佛僧常由佛性。四十初番就僧说僧。中二就法。后一就佛。问曰佛法云何名僧。释言分相佛法非僧。通论皆有和合之义故悉名僧。就初番中先总释名。下别显之。先举二数。次列后辩。世僧声闻义僧菩萨。良以菩萨证真成德故名义和。下就二僧明常无常。世僧未能证性成德所以无常。义僧证僧所以常住。于中先明佛性是常。下明义僧常同佛性。常由佛性何得难言僧常无性

第二番中复次有僧谓法和合总以标举。谓十二部辩出僧体。十二部经言义相扶名和名僧。十二部常故我说僧常就之辨常。此直论常不辩十二常之所以。持实论之佛性常故能诠教常。教常由性那得言无

第三番中僧名和合总释名义。下别显之。名十二缘出其僧体。十二因缘相顺不乖故名为僧。十二缘中亦有性下明十二缘由性故常常而有性。先明有性。十二缘常佛性亦尔约性显常。依本显末应当说言佛性是常因缘亦尔。但今文中举末推本。是故说言十二缘常佛性亦尔。问曰因缘是生死法云何名常。释有两义。第一摄法从人就事。三世流转实是无常。第二废人以论其法。清净法界缘起集成。因缘法门无所属着无有彼此古今恒定故名为常。故下文言十二因缘无有住处故得为常。下文复言十二因缘有佛无佛性相常住。华严亦说十二因缘是无为法。此等皆说因缘法门不论其事。如十二因一切诸法例皆同尔。故下文中宣说法阴法界法入悉无住处故齐名常。然今且说因缘常矣。此因缘中旷备法界洹沙　义莫不皆常。非唯一相。第四番中僧名佛和举其僧体。佛德无乖故名僧。是故我说僧有性者明僧有性。佛是僧故僧有佛性僧是常。理在易知故略不论

下答第五有毗跋致阿毗跋致。以此言广故在后答。汝言有性云何有退有不退者牒举问辞。次敕许说。下广释之。文别有四。一广明退。二明不退。三明不退不名佛性。四明退者不无佛性。初中有五。一十三法退。二六种法退。三一因缘退。谓闻苦行其心退。四五种法退。五二种法退。明不退中初问。次辩。后总结叹。叹中初言亦名施主明能益他。能摄佛法施众生故。见如来等彰其益已。能调已下复明益他。善能护下复明益已。此第二竟。以是义故不退之心不名佛性是第三段明前不退不名佛性

汝不可以有退心故言无性下是第四段明退心人不无佛性。然此一文义有两兼。近则明前退心之人不无佛性显其非外。远则广上然不失坏举修得果明本有性故非外。以有性故终必得果名不失坏。于中有二。一明退人终必得果。二师子言云何有退不退以下明退心人终所起行。初中不可以有退心言无佛性遮其无见。二譬如二人俱闻已下举得显有。以是义故我经说下结成有性。就举得中先喻后合。喻中有四。一二人俱发喻。二路值下访问所求喻。三闻是事已一人悔下有进有退喻。四时悔还者见是事下退人后得喻。初中二人喻修行者。进退两分说为二人。俱闻他方有七宝等喻闻正法。说生死外有佛可求名闻他方。山喻涅槃。泉喻佛性。有能到者永断贫等闻到有益。得涅槃财名断贫穷。证性常住名增寿命。唯路悬等闻修有苦。时彼二人俱欲共往喻起思惟思欲趣向。一人严下喻明修行。先明二人起行因别。相与前进正明修行

第二段中路值一人多赍宝等喻逢如来。便前问等喻问所求。其人若下喻佛为说。先明所求有实不虚。后彰往者有苦不谬

第三段中先明二人进退两心。先退后进。是时二人一则悔下进退两行。先退后进

第四段中悔人后得文显可知

合中宝山喻涅槃等合上初段。所逢人下合第二段。一人还下合第三段。初先正合进退两人。下约论性。明人虽退性常不变。于中初法次喻后合。菩提道中终无退下合第四段退人后得。先出道理。菩提道中终无退者虽退还复必当得故。次举前喻后合可知。前喻及合合为第二举得显有。自下第三结成有性。以退心人终得义故我经中说一切有性

上来第一明退心人终必得果

自下第二明所起行。师子先问。云何有退终得不退。下佛为辩。于中初先总举赞叹。若修三十二相业缘得名不退是总举也。名菩萨下是叹胜也。修此业者名道众生故名菩萨。道生中大名摩诃萨等。坚守正道名不动转。能摄菩提饶益众生名怜。一切。超过二乘名胜一切声闻缘觉。更无退失名阿毗跋。次别显之。后总结叹

上来广前所证理法下次广上能证行法。何故须广。前约菩提因之与果明能证法未论涅槃故下辩之。又上文中明佛菩萨有行有眼能见佛性。未明凡夫二乘人等证行有无。故下辩之。明凡二乘亦有缚解修得之义。文中初先开列四门。下广辩释。其四门者众生不思是第一门。佛境不思是第二门。业果不思是第三门。佛性不思是第四问。四中初一是修证人无一神主而能相续究竟得果故曰不思。后三证法佛境是果。大般涅槃是佛境界。随化去流实则常恒故曰不思。业果佛性此二是因。业果缘因缘因之行前后相起。能生为业。所生为果。业果不断。究竟佛德故曰不思。佛性正因。性随缘染而无失坏。终可显了成大涅槃故曰不思。是中宗意不欲明性。举性为成大涅槃矣。何以下释。如是四法皆悉是常常故不思是总释也。佛境佛性是常可知。一切众生云何名常。一切众生真识为体。真为体故起相不绝故名为常。所修业果云何名常。亦以真识依持力故起行不断故名为常

下别释之。初先广前众生不思。有二因下广前业果不可思议。众生佛性为悉共有为各各下广前佛性不可思议。十六国下广前佛境不可思议。初中有三。一就前际明诸众生常不可思。二断常下约就后际明诸众生常不可思。三是故下结。初中众生烦恼覆障故名常者以如来藏依持力故烦恼不断。常为彼覆故名为常。第二段中初明众生断却先际。常有烦恼故名无常。所受乐下明证后蹬涅槃常法故得名常。前中初言断常烦恼故名无常以理正辩。若言已下破他定常常不可断。何故修习八圣道分为断众苦众苦若断即名无常翻邪显正。证常可知。第三结中是故我言众生恼覆不见佛性不得涅槃顺结初段。反结后段。云何结初。顺明众生从本已来常为恼覆故不见性不得涅槃。云何结后。反明众生烦恼覆故不见佛性不得涅槃。即显断故能见佛性得大涅槃故名为常

下次广上业果不思。文中有二。一明缚解业果不思。二师子言众生阴空谁受教下明其修道业果不思。前明缚解令人断缚以求解脱。后彰修道便人修业以求其果。就缚解中有五问答。前三就凡明有缚解。后二就彼二乘之人明有缚解。就前三中初师子吼广以多义难无缚解如来释有。第二师子举无我人难无缚解。如来释有。第三师子乘言重难如来为解。初中师子广以三义难无缚解。一举如来所说二因难无缚解。一切净法有二因生故应无缚。一切染法有二因生故应无解。二举五阴生灭无人难无缚解。三举五阴前后生灭不常不断难无缚解。以不常故前不至后故应无缚。以不断故后生不绝故应无解。难意如是。文中初法次喻后合。下就结难

下佛答之。先敕许说。后正为解。前三难中但释后一明其有缚。若得亲下彰其有解。缚中有三。一从现起中。二名无差下从中起生。三生时诸根具不具下从生起缚。初中先明现阴死相。法喻及合文显可知。下明从现起中阴相。先法次喻。喻中有二。一举灯生闇灭为喻。二举印印泥为喻。印喻有四。初印印泥印与泥合明现起中喻。二印灭下现灭中成喻。三而是下前不至后喻。四文非下后藉前生喻。下合显法。就印喻中但合后三。现灭中生合第二句。是现在下合第三句。中阴五阴亦非自下合第四句。如印印下举喻以帖。但牒第二

自下第二明中起生。于中先辩中阴之相。中阴二下明中起生。前中三句。一约对现阴辩其同异。名虽无差是其同也。五阴名同故曰无差。时节各异是辩异也。时别中现故曰各异。二约眼分别。现阴粗故肉眼能见。中阴细故唯天眼见。三约食分别。现阴粗故多藉揣食。中阴细故多藉三食。所谓思触及与识食。意犹识也。四食如何。论释不同。依如成实饼果饭等名为揣食。思求揣食令命不绝名为思食。冷暖等触名为触食。心识持身令不灭坏名为识食。若依毗昙一切色法持身不坏悉名揣食。心数法中思为思食。触为触食。六识心王名为识食。此经所说多同毗昙。然今从多宣说中阴但有三食。理实于中亦有揣食。如杂心说食何等物。女人中阴还食人中所食香气。余亦如是

下明起生。先法后喻。法中五句。一明中阴有二种思谓善与恶。二明中阴起二觉观谓善与恶。恶业熏心生于恶念名恶觉观。善业熏心生于善念名善觉观。三于父母交会之时乘业趣向。四到生处起三烦恼。男人受生于母生爱。见母是已交会女人所以生爱。于父生嗔。见父是其所竞男子所以生嗔。父精出时谓是已许畅已淫精是以欢喜。此谓已有是见。烦恼三毒分之是痴分摄。女人受生翻前可知。五以是下明由三惑坏中起生。上来法说如印喻之

自下第三明从生阴起于系缚。四句辩之。一明生时根具不具。为依具根集起烦恼所以论之。二明依根发生烦恼。生爱生痴及生倒见。三明烦恼发生诸业业生烦恼。四结成缚义。是名系缚结成子缚。以是义故名五阴生结成果缚

上来明缚。下次明解。初法次喻后合下结。法中初明亲近善人。便得闻下听闻正法。以闻法下明系念思。得大慧下明如说行。行有八句。喻合及结文皆可知第二对中师子初先举无我人难无缚解。空中无刺。云何言拔难无解也。阴无系者云何系缚难无缚也。下佛答之。明有烦恼系缚五阴名色缚生所以有缚。离此名解。文中先明烦恼系阴离之名解。后彰名色系缚众生离之名解。前中初法。法中明缚略不论解。烦恼缚法揽之成阴名缚五阴。恼阴同体故言无别。下约喻缚解双论。两喻两合文显可知。下次明其名色缚生离之名解。如说名色系缚众生明其有缚。名色犹是向前五阴。揽之成人名缚众生。名色若灭则无众生彰其有解。离名色已无别众生离众生已无别名色约就前解明人与法同体无别。以同体故但离名色则无众生。但离众生亦无名色。亦名名色系缚生等约就前缚明人与法同体无别。以同体故但有名色则缚众生。但有众生亦缚名色。第三对中师子初先执人异法难破向前名色缚生生缚名色。初言如眼不自见等自立道理。云何如来说言名色系缚名色难破佛义。何以故下释显难意。先自征责。如来上来未曾宣说名色还复系缚名色。我以何故为此难问。下对释之。如来向前宣说名色即是众生复言众生即是名色以是义故若言名色系缚众生即是名色系缚名色

下佛答之。答意如何。彰彼名色集成众生生外更无故说即是。假实相缚非实缚实。是故不得宣说名色还缚名色。文中初先就缚正答。先喻次合后结可知。若离已下就解以答。良以生法无别体故远离名色。即得名为众生解脱。是故下结

上来就凡明有缚解。下论二乘有两问答。师子初先乘前难后。若有名色是系缚者诸阿罗汉未离名色亦应系缚。佛答有二。一约有余涅槃以答。二譬如下约就无余涅槃以答。前中初先泛举二脱。次列其名。断生死因名为子断。灭生死果名为果断。下约二脱以答其问。答意如何。明阿罗汉现无烦恼故无子缚。阴身未灭故有果缚。文有四句。一明罗汉已断子缚。二未断果下明有果缚。于中初先明其有缚。不见佛性不得菩提彰其无解。三以是义故可言果缚结前第二。不得说言名色系缚结前第一

下就无余以答其问。明阿罗汉现断烦恼后报不生是故一切系缚悉无。文中先喻。如油未尽明则不灭反喻罗汉因灭果存。若油尽者灭即无疑顺喻罗汉因尽果丧。下合显法。先合反喻。若得断下合后顺喻

自下师子乘佛前言难喻乖法。初言灯油二性各异明喻异法。灯热油冷名性各异。众生烦恼不如是等彰法异喻。众生烦恼则不如是总明其异。下别显之。别中三番。一明众生即是烦恼。二明众生即是五阴。三明烦恼即是五阴。以此相即故不同喻。云何已下结难征佛法喻迢别。云何如来取灯为喻

下佛答之。答意如何。明前喻者但取少分非是全喻。文中有四。一举八喻彰其所异。二凡所引喻不必尽下立少分喻彰其所同。三离水无下准于前法更立异喻。四若欲得合彼灯喻下唯于前喻更立异法

就初段中先举八喻。喻实有十。简去少分及与多分故但言八。次列其名。下广辩释。虽举八喻为对最后遍喻辩异余乘论之

第二段中初先泛论。一切引喻不必尽取或取少分或多或全。次立两种少分之喻。我言灯者约之显前

第三段中准于前法更立异喻。两喻两合。文显可知

第四段中准于前喻更立异法用合灯喻。谛听我说敕听许说。下正合之。合以显法。炷喻二十五有之身。油喻爱结。明喻智慧。除破黑闇喻灭无明。暖喻圣道。如灯油尽明炎则灭牒举其喻。众生爱尽合油尽也。其明灭者喻智慧灭。其炎灭者喻彼变易生死果灭。此等灭故证见佛性。见佛性故虽有真实法身名色不能缚系。亦可应化名色不缚。以不缚故虽现在于二十五有不为其污

下次明其修道业果。初明有修。如说偈下明所修行。前中经文有三问答。初师子吼举无我人难无修道。众生阴空谁有受教修集道者。下佛答之。明虽无人而有念心智慧心等相续不断故有修道。第二师子乘言重问。念等尽灭无所成辩又无增长云何有修。于中初言如是等法念念灭者牒佛前言难无成辩。是念念灭重牒前言。难无增长。准下答文此言略少。若具应言是念念灭云何增长。亦相似下牒佛前言明定相似难无增长。云何修习总以结征

下佛答之。先对初句明有成辩。汝言念念灭云何增下对第二句明虽生灭而有增长。如犊子下对第三句虽念念灭明后过前非定相似。初中如灯虽念念灭而破闇冥喻有成辩。次合显法。下复重举三喻显之。此即是其先后喻也。第二段中言念念灭云何增长举其难意。心不断故名为增长法说明增。如人诵下五喻显之。第三段中初先立喻明有增长。譬如犊子生便求乳实无人教举其喻。虽念念灭初饥后饱故不相似明后过前。若相似者不应异生破定相似。若言相似不应异饥更有饱生下约显法。众生修道亦复如是合前犊子生便求乳。初虽未下合前初饥后饱等言

自下第三师子举彼须陀洹人生于恶国难破向前增长之义。文中初言须陀洹人虽生恶国犹故持戒不杀盗等举佛旧言。下就设难。难中有三。初须陀洹阴即此处灭不生恶国修道亦尔不至恶者将身类道明不至后。须陀以前无道之身名为恶国。无漏圣王不居中故。后得道身名为净国。无漏居故。彼现五阴不至恶国。圣道亦尔道不至后。后则劣前云何相似。尚不相似焉有增长如犊饮乳。二若相似下难后似前。若后似前何故不生净妙国土而生恶国。三若恶国阴非须陀下遮佛非义。若佛宣说生恶国者。非须陀洹故不似前。云何不作杀盗等恶

下佛答之文别有四。先答第三。次答第二。复答第三。却答第一。故有四文。初言须陀虽生恶国终不失于须陀名者答第三中若恶国阴非须陀洹。明虽生恶不得言非。阴不相似是故我引犊子为喻答第二难明后过前。非直相似是故说言阴不相似。如犊饮乳初饥后饱云何不似。去涅槃界近于前故

虽生恶国以道力故不作恶者释第三中云何而得不作恶业明由道力。初先法说。如香山下四喻显之。就初喻中譬如香山有师子王喻须陀洹现阴身中有无漏道。一切鸟兽无敢近者喻恶不生。有时是王至雪山者喻无漏道流至末后得道身中。一切鸟兽犹不住者不敢住于空香山中。彼空香山喻须陀洹中间所受无道之身。由前道故恶业不行。下合可知。后之三喻并举总合文皆可识

须陀洹阴于此灭下却答初难。先答初中须陀洹阴于此处灭不至恶国。明后所受犹故是其须陀洹阴非全不至。文中初法次喻后合。譬如人下答初难中修道亦尔不至恶国。明后还得非全不至。初先立喻。如人巨富喻须陀洹现备圣德。唯有一子喻须陀洹现在造作次生之业。先已终没喻彼生业起已谢往。其子有子在他土者彼业所生未来之果名子有子。果起在当名在他土。其人终已喻须陀洹现报迁灭。孙闻是已收其产业喻须陀洹无道身中起无漏得。得彼过去所修圣道。所得圣道过修非今名知财货。非其所作得之无障名为收取无遮护者。何以下释。相续□□名为姓一。下合可知

上明有修。下次明其所修业果。师子先问。如来次答。有难解者下复重显

初中师子先举昔偈。偈中上半明三学因。后半明得涅槃之果。此即是上业果不思。下问云何但问上半。下佛答中先解上半明三学行。坏疑心者为修道下释后半偈明近涅槃。又释前半明其行体。释后半偈明次第成。前中三番。初番明其护小乘行。第二明其破凡夫行。第三明其息烦恼行。亦可初番总利自他。修为众生名为利他。心无取着说为自利。第二一番偏明利他。第三一番偏明自利。初中先别。后总结之。别中先戒。戒中初先举劣显胜。云何真下辩胜过劣。先问次释。若为度脱一切生等是利他也。如是修时不见戒等是自利也。不见戒者不见戒体。体谓色等。不见相者不见戒行防禁之相。余者可知。若能下结

定中亦先举劣显胜。初问次辩。后结显过。云何真下辩胜过劣。先问次辩。初为生等明其利他。句别十二。作是行下彰其自利。不见三昧不见定体。体谓定数。不见相者不见定心寂静之相。余者可知。若能下结

慧中亦先举劣显胜。初问次辩后结显过。云何真下辩胜过劣。先问次辩。先明其利他。如是修下明其自利。不见慧者不见慧体。体谓慧数。不见相者不见智慧能分别相。余者可解。是则下结。上来广辩

下总结之。修集如是戒定慧等结前胜也。不能已下结上劣也

第二番中先明修戒。为破十六恶律仪者。杂心论中宣说十二。彼十二中十种同此。所谓屠羊养猪养鸡捕鱼捕鸟猎师作贼魁脍狱卒及与咒龙。两种异此屠犬伺猎能为下结

次明修定。先问次辩能断一切三昧是其总也。所谓下别。无身三昧是空处定。无边心者是识处定。缘无边识名无边心。净聚三昧无所有定。能于多缘心聚一处故名净聚。世边三昧依之起于有边之见。世断三昧依定计断。世性三昧依之计于八万劫外有其冥性。世丈夫者依定计有冥初丈夫。非相可知。若能下结

慧中初问次辩其相。能破世见是其总也。所谓下别。别中有七。一能破于二十身见。一一阴中各有四句。二常即我下破断常见。先常后断。三作名我下破我我所见。见我为我。色为我所。作受互论故有两句。四无作无受自生已下破自然见。五无作无受悉自在天破无因见。六无作无受悉时节下破时节见。七作受悉无破五大见。若能下结

第三番中修戒净身破身口恶。修定静心破离意恶。此除事过。修慧坏疑破迷理过

下次解释杂亲近涅槃。句别有十。前四自为坏疑为修是一句也。修为见性是两句也。见性为得阿耨菩提是三句也。为得涅槃是四句也。下六为他。为断众生一切生死断其苦果。一切烦恼断其惑因。一切有者为断众生二十五有。一切界者断其三界。一切谛者断苦集谛。初一为断贯此诸句。此五为生断离有为。断生至谛为得常等为令众生证入无为

前问次答。有疑难解者自下重复问答显之。有三问答显前涅槃。初师子吼执粗同细。若不生灭是涅槃者四相中生亦不生灭。以何义故不名涅槃。生相云何不生不灭。彼已起竟更不重生故名不生。生相非灭故言不灭。下佛为释。先述其言不生不灭而有始终释非涅槃

第二师子乘言重难。若无始终即是涅槃生死之法亦无始终何故不得名为涅槃下。佛答之是生死法悉有因果故非涅槃。何以下释。涅槃之体无因果故。第三师子乘言重难。夫涅槃者亦有因果总翻佛语。次别难之。先举昔偈难破无因。偈后长行举佛昔言难破无果。我今当说沙门道果举佛略。言沙门下举佛释辞。沙门三学。道谓八正。果谓涅槃。世尊已下就之结难。云何说下总征圣言。下佛答之。涅槃因者所谓佛性释通昔偈。佛性之性不生涅槃故言无因解通今语。能破烦恼故名大果释通昔言。不从道生故曰非果解通今语。故无因果就今双结

下次广上佛性不思。有四问答。师子初问性之一异。先为两定。众生佛性为悉共有为各各有若共有等就初设难。一得菩提一切同得法说难也如。二十下喻说难也。佛性若下合喻难也。若各各等就后设难。若各各有则是无常以理正征何以下释可算数故。然佛说下举昔征今。佛昔说性不一不二云何各有。若各各下以今征昔若佛今说各各别有云何昔今诸佛平等佛性如空。下佛答之。初先法说。性不一二略立其宗。佛性如空一切共有明不二也。佛等犹前诸佛平等。如空犹前佛性如空若修即见明不一也。次以喻显。草名忍辱喻前共有。牛若食下喻修即见。下合可知

第二师子乘言重难正难佛性。因前说言修道见故兼难圣道。就难性中先就前喻进退两定。一耶多耶。下就设难。如其一者牛食则尽难破别得。如草是一牛食则尽余者无分。若性是一一人得时余者无分云何说言修者皆见。如其多者云何而言性亦如是难破一义。其草若多性亦应多云何说言众生佛性同共有之如忍辱草。下难圣道。如佛所说修道见性是义不然牒以总非。何以下释。道若一者如忍辱草则应有尽执一难破别得之义。道若多下执别难破具得之义。其道既多云何一人能具修习。既不具修云何名得萨婆若智。萨婆梵语。此翻名为一切智也。下佛答之正。为解性。因其问故通论圣道。释意云何。明法虽一不妨别得。文中先举道树二喻。次约显法。后举门桥良医三喻。下约显法

第三师子乘言重难。先难前喻。初牒直非。何以下释。先在路者于后则妨云何无障难破初喻。余亦皆尔。类破后四。圣道性下准喻难法。可佛答中偏解圣道佛性可知。如汝所说义不相应总非难辞。下广辩释。先明前喻少分非全一切众生同无明下更立全喻约之显法。前中我喻少非一切总明非全。下别显之。世间道等明喻异法。无漏道下彰法异喻。言无漏道则不如是总翻前喻。下别翻之。令生无疑翻前障碍。平等无二翻前无等。无有彼此翻前彼此。如是正道能为佛性作了因下叹以显胜。先法后喻。就后更立全喻之中十二因缘众生等有立喻显法。所修已下辩法同喻。所修如是合前因缘。等断众生烦恼已下合上平等。胎卵湿化是其四生。界谓三界。有者所谓二十五有。道谓六道。其有证者彼此知见无有障碍。远答向前第二难中道若多者云何具修。今明证者彼此知见无有障碍故可具修故名萨婆远答向前亦不得名萨婆若智。第四师子重难向前。佛性一义众生身异云何性一。下佛为辩。先喻后合。文显可知

涅槃义记卷第八应永三年六月十三日拭老眼补朽阙之处了　　　　　　　　法印权大僧都(生年六十四)涅槃义记卷第九

        隋净影寺沙门释慧远述

下次广上佛境不思。境谓涅槃。随化示灭实德常存。实德虽存妙寂离相故曰不思。斯德难彰。今寄化灭趣入以显。欲使众生学佛舍相趣入其中。于中有四。一寄灭处显真涅槃。二寄灭时显真涅槃。三寄严林显真涅槃。四寄灭身以显证入

处中有二。一寄城处对破外道明大涅槃常乐我净。二寄林处明大涅槃常乐我净。就城处中师子初问。问意有三。一问何故舍六大城而来至此。二问何故在此涅槃。三问拘尸弊恶之处如来何故于中涅槃。下佛别答。先对后问。汝不应言弊恶隘小略翻其言。应言微妙以理教示。何以下释。诸佛菩萨所行之处法说略释。如贱人下三喻显示。次合。下结。我念昔下答第二问。有三复次。一于往昔曾于此处闻佛名号修行十善。为报地恩故来在此。二曾此处修四无量。三曾此处见佛发心故来在此。我初出下对其初问明为追逐诸外道故舍六之此。先明舍六。后到拘尸破邪显正。先别后结。别中有三。一明六师先往拘尸增物邪见。二我见是下如来后到翻邪显正。三尔时六师作是言下明诸外道执邪乱正如来对破。初段可知

第二段中初明如来怜此众生邪师所惑。广请菩萨大师子吼。虽于空下明集菩萨吼之所以。师子吼者说一切下出其所吼。说无常乐辨生死法。说佛常等显涅槃法

第三段中初明如来破邪显正。诸外道言若言如来常乐我下明诸外道舍邪归正。前中有二。一破外道即法计我。二六师言色非我下破彼外道异法计我。前中初约六根破我。六师若言色是我外就五阴破我。就根破中先破邪执。诸佛菩萨所见真下显示正义。前破邪中文别有二。一外道立我如来对破。二外道征佛如来为释。前中初先外道立我。瞿昙有我我亦有我说邪乱正。下辨我相。于六根中且约眼说。见者名我法说以立。次喻后合。下佛对破。见者名我是义不然牒以总非何以下释。有三复次。一根用不俱破定有我。人在一向六根俱用辩其喻相。若定有下征法同喻。若一根中不能已下以法求喻破定有我。二根用不恒破定有我。汝所引喻虽经百年因见无异辩其喻相。眼根若下征法同喻明知无我。三根用一向破定有我。人向异故见内见外辩其喻相。眼根若下征法同喻。若不见下明法乖喻破定有我

自下外道反征如来。若无我者谁能见邪。下佛为释。先明四事和合名见。次明无我。下明众生颠倒见我。上来破邪显正可知

下就五阴破定有我。文别有四。一破其邪。二显其正。三复破邪。四复显正。初中先就色阴以破类其余四。就色阴中初先破我。后破常等。就破我中若色是我是亦不然举以总非。何以故下广显其非。五句破之。若色是我不应丑陋是一破也。何故复有四姓差别是二破也。何故属他是三破也。诸根缺漏是四破也。何不作天受地狱等是五破也。若不能下总以结破。下破常等并类余阴。文皆可知。上来破邪。如来永下显示正义。复次色下重复破邪。如来身下重显王义

下次破其异阴计我。还初破邪。后显正义。就破邪中文有四对。第一外道因前被破立异阴我。言色至识悉非是我我遍一切犹如虚空。下佛对破。有三复次。一就见征破。若遍有者则不应言我物不见据本以征。若我周遍本来恒遍一切处色常应具见。不应说言我初不见。若初不见后方见者。见则本无便是无常云何言遍。二就趣以征。若我遍者五道之中应具有身令征令齐有。惧立齐有。下复征破。若具有者五道之中应各受报。云何说言转离三涂受人天身。三就一异征破。先为两定。一耶多耶。若一则无父子等者难破一遍。我若多下难破多遍。若多而遍此人之我遍彼身中。彼人之我遍此身中。一切众生五根业慧悉应齐等不应有别。惧彼立等。下复难破。若当齐等云何说言根具不具难破根等。善业恶业难破业等。愚智差别难破慧等

第二外道乘言救义。我者无边法与非法分齐各别。以其别故修善法者则得好身。行非法者则得恶身故有差别。下佛对破。若如是者我则不遍以别征遍。我若遍下以遍征别。遍则此我到彼身中。彼我亦到此人身中。是故善人亦应有恶。恶人亦应有其善业。善恶既通身报宁异。若不尔下结非其遍

第三外道立喻救义。譬如一室燃百千灯灯别明通。我亦如是如明遍通。修善行恶如灯各别不相杂合。下佛对破。言我如灯是义不然牒以总非。何以故下广显非义。句别有三。一明从缘有随灯增长我不如是不得为喻。二明从灯出住在异处我不如是不得为喻。三明与闇俱我不如是不与无我同在一处。以是义故不得为喻。文中初言明与闇共略以标举。何以下释。如燃一灯照则不了正论灯明与闇共住。多灯乃了举多显少。若初灯破不须后灯约初征后。若须后灯知初共住将后证前

第四外道反征如来。若无我者谁作善恶。下佛先以四义别破。若我作者云何名常如其常者云何有时作善作恶是一破也。若有时作云何复得言我无边是二破也。若我作者云何行恶是三破也。若我知者云何生疑众生无我是四破也。以是义下总以结破

上来破邪。下显正义。明佛常乐我净及空。文显可知

上来第一破邪显正。若言如来常乐我净下明诸外道舍邪归正

上来广明佛到拘尸破邪显正。以是因缘我于已下总以结之

次就林处以显涅槃。先别后结。别中有四。一寄八树表彰八修。二因此众生护娑罗林令诸弟子学之护法。三因四王护娑罗林即令护法。四以此林华果常茂能益众生表已能益声闻诸众。以是下结

次寄灭时以显涅槃。于中初寄二月以显。师子先问。下佛答之。先别后结。别中四句。一明二月人多生于常乐我净四倒之心。佛为破之显示如来常乐我净。先破常倒。次乐我净。二为表如来二种法身谓真与应。三冬不涅槃显示智者不乐如来无常尽灭。二月涅槃显示智者爱乐如来常乐我净。四以二月种殖等事表彰弟子修诸善法。于中有四。一以种殖喻诸众生闻法发心种诸善根。二江河盈满喻十方界菩萨云集。三百兽孚乳表诸弟子种诸善根。四华果敷荣表示弟子修七觉华得四道果

下次就其十五日时表彰涅槃师子先问。生等四时皆以八日何故涅槃独十五日。下佛先叹。后为辩释。释中有三。一十五日时月无亏盈表佛涅槃无有亏盈。二十五日时月盛圆满为十一事显佛德满为十一事利益众生。三我真实不入已下约就初段明佛不灭愚人谓灭。先法后喻

自下第三寄就严林以显涅槃。师子先问。下佛为辩。德人显处故曰庄严。正为明佛乘论弟子弟子无量略举六人。通佛有七。一一人中皆初佛辨。后师子吼就人领解。辨舍利中先叹其智。于怨亲下叹其心行。智中十句。大智是总。利等是别。于理速入名为利智。于事速解说为疾智。断障自在名解脱智。于理穷照名甚深智。世义博通称曰广智。穷佛教海名无胜智。故经说言唯除佛世尊。一切众生类欲比舍利弗智慧及多闻于十六分中不能及其一。何有胜者故名无胜。所知不谬名为实智。具成慧根总以结之

自下第四寄就灭身显已证入大涅槃义内。证难彰故寄灭身趣入显之。于中有四。一师子请住。二如来不许。三师子吼问佛灭意。四如来为辨。初中师子乘前请住。唯有如来乃能严林无则不端唯愿大慈为严常住

下佛答之。先明不住。后彰欲去。明不住中合有二十七复次文广显不住。要摄为四。初一复次以理反呵。诸法无住云何请住。二凡言住下有六复次。广明如来住过永尽不应请住。三夫无住者名无边身下有十二复次。广明如来无住德备不应请住。四若有说言身口意恶得善果下有八复次。广举一切毕竟无事显佛无住。初先广举。后将类佛

前明不住。下明欲去。如来于此入大三昧深禅定窟众不见故名入涅槃。此乃寄人显彰实证令人学也。问曰上说如来毕竟常在世间不入涅槃。今以何故言已不住定入涅槃。释言佛德有四种门。一共世门。恒在世间未曾暂灭。二住寂门。未曾暂出。第三反寂起用之门。现化随物。第四息用归寂之门。舍化归真。前据初门彰已在世毕竟不灭。今就第四故说不住入涅槃矣

师子下复问佛灭意。何故如来入禅定窟。下佛广以十四复次明入所为。虽有多门宗意令人学佛趣入。以是下结

从非内外讫来至此。大段第三广显证法。自下第四劝修趣入广显证行。此与向前第二段中证行何别而须重论。前第二中教见如来以趣实证。今此文中教见涅槃是一异也。又前文中直明持戒乃至见性为趣证行未就人别。此中就人彰行阶降是二异也

就此文中阶别有四。初教修三。是初地上入证之行。次教修十。是种性上乃至解行趣证之行。如佛昔告纯陀已下教修四种转业之德。是善趣中趣证之行。师子吼言一切众生悉有佛性应当修下。就常没人劝修圣道为行趣证

初中有二。一重明向前无相涅槃。二何等比丘能断十下教修趣入。与下第二修十之中其义相似。前明无相涅槃之中师子先问。无相定者名大涅槃以何因缘名为无相。下佛为辨。初明远离十种相故名为无相。先举次列后结可知。夫着相下佛为劝修。乘明愚智取舍得失。先明取失。句别有六。后彰舍得。句亦有六

教修入中初略。次广。后总结叹。略中初问何等比丘能断十相。下佛为辨。数数修三则断十相总以标举。修时不一故云数数。有经亦云时时修也。次别后结

广中先问云何名为定慧舍者问其行相。定是已下难破行义。先难其定。后类慧舍

就难定中定是三昧一切皆有云何方言修集三昧执通难别。心数法中有一定数。众生皆有执此通有难破别修。若心在下执别难通。执住一法是其三昧。令余皆非名为难通。法有总别。总名为缘。别名为行。行缘应通。为分总别隐显异名。总法可以通相缘知。故从缘心说之为缘。别法唯是观行推求方与相应。故从行心说之为行。今此文中先就总缘执别难通。若心一境则名三昧自立道理。此执别也。若更余缘不名三昧难破他义。异缘散动云何名定。此难通也。如其不定非一切智约定难知。散心所缘乃是想识云何名智。举此为欲与定为过。非一切智云何名定约智难定。不能生智云何名定。又复不与一切智俱易可倾动云何名定。下约别行执别难通。若以一行得三昧者自立道理。余行亦非难破他义。若非三昧非一切智约定难智。非一切智云何名定约智难定。慧舍如是类前难后。虽言如是于中细求有同有异。同异如何。约就凡圣执通难别三行皆同。一切众生皆有慧数亦有舍数。云何方言修集慧舍。约对境界执别难通。三行各异异相如何。前难定中心住一境名为三昧。余缘则非。就难慧中知一切法名一切智。知一则非。难相云何。若知一切名一切智知一应非。知一若非所依之定不名三昧。若非三昧云何名智。就难舍中舍定之舍难与慧同。舍慧之舍难与定同

下佛答之。先释后难却答初问。就释难中先解后番执别难通。却释初番执通难别。执别难中先解初番总缘上难。先牒直非。何以下释。如是余缘亦一境者随其分别各住一境。何为非定。行亦如是类解后番别行上难

上来解释执别难通。下次释去执通难别。先就定解。言生先有是义不然牒以直非。所以下释。言三昧者名善三昧简恶无记。众生未有简圣异凡。云何言下结非难辞。以住前下约前三昧类显慧舍。不同一切众生所有慧舍二数

上来一段释遣后难。下解初问。前问云何定慧舍相佛今为辨。是中应先广解三义然后释文。义如别章文中八番。一约境分别。二就人分别。三当相分别。亦得名为就能分别。四开合辨相。五明修所为。六明相资助。第七约就三三昧门以别三行。第八约就修时辨异

就初番中境别众多如别章释。然今且约事法论之。事法该通且就色说。安心色事名为三昧。如世八禅。若能观色常无常等名为慧相。定慧等修舍离偏习名为舍相。于中初法次喻后合

第二就人分别可知

第三当相分别之中定有五句。初句能灭粗重烦恼。第二能除粗重恶业。此二修始。第三能息轻微之业。后二能离轻微烦恼。此三行终。以是下结慧中六句。名为正见正见真谛。亦名了见了见世谛。能见遍见广前正见。能见于理。知尽称遍。次第别相广前了见。知法不乱名次第见。随法异知名别相见。是名总结。舍中四句。名曰平等定慧齐修。亦名不诤舍离偏习。此二约就定慧论舍。又名不观不观有无。亦名不行不行有无。此二约就如理辨舍。是名总结

第四开合辨相之中偏论定慧。定中增数次第辨之先分为二。二有两门。一就位分。二世俗八禅名为世间。无漏出世。二约修分二。亦得名为就人分二。先举。次列。下就人辨。次增说三。文显可知。次增说四。下品净定喜为下地烦恼所败名为退分。非是已退。又为自地烦恼所杂亦名退分。中品净定坚守自地不为下地烦恼所败名为住分。又不为于自地烦恼之所陵杂亦名为住。上品净定能厌自地欣求上静名胜进分。能作大益是决定分。有漏心中学观谛理趣向圣道名决定分。能生圣道名作大益。次增说五。先总标举。五智总显。下列其名。无食初禅离揣食故。无过三昧亦是初禅。离欲恶故。身意清净一心三昧是第二禅。离六识中觉观粗动名身意净。内净一处名为一心。因果俱乐是第三禅。常念三昧是四禅止。得时不动故曰常念。次增说六。前五犹是五停心观。观事住心。但此于彼五停心中略无第四分折界入。分彼第五阿那般那以之为二。故亦有五。数息义边以为第四。阿那般那念觉观过生心厌离说为第五念觉观矣。后一理观。次增说七。七有两门。前七就行定觉为主。余六皆是定家眷属相从名定。后七就人。次增说八。谓八解脱义如别章。第八门中灭尽解脱经论大同。唯成实中说烦恼灭以为第八。次增说九。谓九次第定。此九唯取根本禅体转相趣入不通方便。次增说十。谓十一切入。少异余处。无火一切加无所有是其异也。何故如是。此乃为破事火外道。是故除却火一切入。为成十数加无所有。十一切入广如别章。此应具论

次就慧中增数论之。初说二种。见道已前名为世间。地上出世。次增说三。先举次列。波若名慧。毗婆舍那此名为观。阇那名智。下辨其相。于中两番。初约人论。言波若者一切众生所谓凡夫。凡夫众生同有慧数。毗婆圣人所谓二乘。二乘能观四真谛法名毗婆舍。阇那所谓诸佛菩萨。以佛菩萨有一切智故名阇那。下随境别。波若别相知世谛法。毗婆总相知第一义。阇那破相知一实谛。次增说四。知四真谛。广应无量且举斯耳

自下第五明修所为论定论慧。略不明舍。修定为三。一为不放逸厌伏烦恼。二庄严大智依之发慧。三为得自在依之起通。修慧为三。一观生死为知若过。二增诸善为息恶业。三为破烦恼

自下第六明相资助亦不论舍。师子先问。如经中说毗婆舍那能破烦恼执慧独能。是一问也。何故复修舍摩他耶疑不假定。是二问也

佛答有二。一正对前问明偏有失双修有得。二具二法广明双益

前中有二。一翻前执明慧不破。二若修定下释去后疑彰必须定。前中毗婆能破不然牒问总非。何以下释。释中广明智慧不破。明此何为。若取智慧能破烦恼。是取相心不能灭惑。不见智慧能破烦恼。不见烦恼以为所破。是破相心方能令惑毕竟不生。今此为成出世正治故明不破。与上文中智慧不破烦恼而总其义相似。文中有十。相从为四。初一复次明慧不破。次一复次举无我人成慧不破。次七复明智慧不破。后一复次复举无我成慧不破

初复次中有慧无恼有恼无慧。云何言破法说以征。如明喻显

第二段中明无我人。谁有慧恼而言慧破难其有破。如其无下彰其无破

第三段中有七复次。第一约就到不到义难其慧破。先为两定。若慧能破为到不到。下就设难。难别有三。第一偏难不到能破。若不到破凡应破者圣慧不与烦恼相到能破烦恼。凡亦不到何故不破。二若到下偏难到破。若到破者初念应破征初独破不假后慧。是义云何。初念慧起与惑相对此应能破。后念不到应当不破。若后不破何用后慧。若初不破后亦不破遮他救义难后共破。他人救言初不独破故须后念与前共破。故今难之。初念到惑尚不能破后念不到云何能破。若初到破是则不到遮他救义难破后到。他人救言初念到惑后念亦到是故俱破。故今难之。若初到破在后破者便是不到。隔初念故。后既不到何得说言到故方破。云何说言慧能破者总以结呵。三若到不到而能破下双难二关。因前难故他人救言初念到破后念不到亦皆能破。故今牒举非其不然。不然之相备如前难。若言到破如上后难。言不到破如上初难。此初复次二就伴独难慧能破。若毗婆舍能破烦恼为独为伴进退两定。下就设难。若独能破菩萨何故修八正道难其独破。若伴已下难其伴破。若伴故破独则不破约伴破独。若独不破伴亦不破约独破伴。先法次喻后合可知

三如地下明惑性灭不假慧破。如地坚等立喻显法。明其四大各有自性非因缘作。如四大下约之显法。明惑自断不由智慧。若是断下征破由慧。以是义下结慧不破

四如盐下明不灭法慧不能破。先举直非。如盐性碱令异碱等举他立喻。智慧性灭令法灭者举他法说。不然总非。何以下释。若法不灭云何智慧强能令灭

五若言盐下明慧性灭不能灭他。先举直非。若言盐碱令异物碱举他立喻。慧灭亦尔举他法说。不然总非。何以下释。慧性自灭云何灭他。以是下结

六法有二下明解与惑二俱性灭无相破义。先举二灭。性及毕竟列其二名。下就设难。若性灭者云何而言智慧能灭

七若言慧灭如火烧下明所破结。无相可见彰慧不破。于中有三。一不同世物被烧可见。二不同树木被斫可见。三不同外道离六大城拘尸那现为是不破。此七复次合为第三广就智慧明不能破

自下第四还举无我成慧不破。诸法性空谁令生灭是法无我。异生异灭无造作者是人无我。唯法生灭更无我人故无作者。人法并无谁修智慧破诸烦恼。此翻初执彰慧不破

若修定下释去后疑显必须定。于中有三。一明修有益。若修集定得正知见。二以是义下引说彰益。三若不修下举损显益。初先反明不修之损。若不修定世事不了况于出世举近况远明无出益。若无定下明无世益。平处颠坠违行过也。人天平处颠坠三涂。心缘异等违事过也。心缘异法口宣异言口业错谬。耳闻异声心解异义意业错谬。欲造异字手书异文身业错谬。下显修益。修则大益成因益也。乃至菩提得果益也

上来第一正对前问彰偏有过双修有益。自下第二广显双益。于中有二。一明二行相资之益。二修是二法调摄根下趣果之益。前中初言具二大益总以标举。定智列名。如刈已下八番广辨。皆初立喻。后约显法。八中初三离过行中明相资助。次一就其摄善行中明相资助。次一复就离过行中明相资助。后三复就摄善行中明相资助。以是下结

趣果益中初向菩提。四倒暴下明向涅槃。向菩提中先离有为。不久成下趣向无为。为欲成下能益众生。离有为中初修二法能调五根。堪忍已下不随惑缘。常能远下内息恶觉。不随缘中初忍违缘不生嗔忿。不为利下能忍顺缘不生贪染。不为邪下识达邪法不起痴见。亦可初明修二调根。堪忍已下不随惑缘。于中六句。一外忍违缘。二常摄下内离嗔恼。此二一对。三不为利下外离顺缘。四客尘下内除贪染。此二一对。五不为邪下外远邪法。六常能下内舍恶觉。此二一对。除皆可知

向涅槃中先辩后结。辩中有六。一不动行。修是二法不为四倒外道邪术三法所动。二受乐行。常受妙乐。三觉知行。能解深义。四重明不动。苦乐不及。五重明受乐。为世敬叹。六重明觉知。初见生死及非生死明知法相。了法界等明知法性。是则下结

自下第七约三三昧以别三门。说空三昧以之为定。住第一义心不动故。无愿名慧。慧见生死生厌离故。无相名舍。舍众相故

自下第八约时分别。初先略辨。师子言下问答广论。文显可知

前略次广。若修三下总以结叹

次教修十。于中还初明涅槃果。后教修人。与前相似。果中师子初先领前。问后起发。无十相故名大涅槃是领前也。以何缘故名无生等是问后也。问有十一。下佛为释。诸结火灭名灭度者灭烦恼障。言离觉观名涅槃者灭除智障。除舍妄智名离觉观。由离觉观得为涅槃寂静之义故名涅槃。与下文中断除三十七品所行名为涅槃其义相似。问曰涅槃此翻名灭。盖乃胡汉相翻而已。今云何言诸结火灭名为灭度。离觉观故曰涅槃。释言外国名字众多。故于灭中随义不同立种种名。或名涅槃。或弥留陀。或曰毗尼。如是非一。故彼外国诸结火灭名弥留陀。离觉观者说为涅槃。此方名少。同翻为灭。其犹外国菩提末伽此同名道。但今文中为别两义。弥留陀灭翻为汉言名为灭度。涅槃之灭仍存胡本说为涅槃。经中此例亦应不少

教修入中师子先问。成几能见无相涅槃至无所有。下佛为辨。先举次列。十中初信起行方便。后九正行。信中初列。云何下释。先问次辨。辨中有二。一修正信。二离邪信。修正信中地持有八。广如上辨。此但有五。信佛法僧即为三也。信十方佛方便示现是彼信佛菩萨神力。今略论佛。一切有性即是彼中信真实义。通前为五。此明正信。不信如来生老死等明离邪信。是名下结

就后九中初戒离恶。后八修善。戒中初列。云何下释。先问次辨。辨中有二。一举过劝舍。二辨净教修。前举过。中偏举淫过。以难离故。于中四番简粗论细。文显可知。后辨净中明舍诸根唯求实义。是名结之

就后八中初一近友摄善方便。后七正行。七中初一明修止行。止谓寂静。后六作行。作中精进提作善心。后五所作。五中初一起菩提愿。所谓六念。后四明起菩提之行。初一利他。软语列名。次辨其相。言实语者不妄语也。妙语先问不恶口也。言时语者合时善言不两舌也。言真语者不绮语也。是名结之。次一自利。护法列名。次辨其相。先自护持。后见他学随顺供养。是名下结。次一利他。有乏施与。后一自利。具慧列名。次辨其相。知四种法。一观佛果常乐我净。二观众生有性正因。三观染净二种法相。观二总举。所谓下别。空等生死。下不空等是其涅槃。四观真妄对治修舍。异法可断所谓妄想。异法不断所谓真识。此二先际。异法缘生有作行因藉缘熏发真行始起名从缘生。异法缘见无作行因藉缘显了真性始现名从缘见。此二中际。异法缘果方便菩提从因修生故名缘果。异非缘果性净涅槃不从因生名非缘果。此二后际。是名结之。具十能见总以结叹

自下第三明善趣中修习转业趣证之行。于中有三。一泛明一切诸业不定终可转灭。二一切众生不定业多定业少下明转业相。三如佛说非一切业定得果下明转业行

前中有四。一问。二答。三难。四通。问中初明善业定障。谤方等下恶业定障。举善显恶。善中偏就纯陀设难。以彼供佛福无尽故。初言如佛先告纯陀汝已见性得涅槃等是义云何牒以总问。佛前大众问品之中与纯陀记。今牒以问。下广引圣言彰彼纯陀善业为障无得佛义。于中六句。初一引经明上田行施受报无尽无得佛义。先举昔经。后难纯陀。第三引经明重田行施受报无尽无得佛义。第四引经明业能障无三界业定得菩提有故不得。第五引经明业定障非空非海脱之不受。第六引经举劣况胜。举阿那律以况纯陀。下明恶业定障之中举善类恶。明不可尽无有见性得菩提义

自下第二如来酬答。先叹问益。唯有二人泛以标举。次彰其益。得无量德生善之益。能竭生等除障之益。际魔怨等摧邪之益。能转法轮通正之益。一问二答列其二名。虽叹二人意显问者。次明如来业力最深堪能酬答。十中业力深于余人非深余力

下正答之。于中有四。一略明众生于业不信佛为说定。二一切作下略明业体有定不定。于中初明业有轻重。下明此二有定不定。三或有人下广明众生于业不信佛为说定成前第一。先明不信。或有人言恶业无果不信之人自立无义。若言已下破有成无。经说气嘘是旃陀罗。杀人无量。临欲终时见舍利弗深起善心得生天上。鸯掘摩罗邪师所败杀害多人取指为鬘望得生天。蒙佛开化得罗汉果。故今举之。难破定有成恶无果。以是义下结破他有成已无义。以是造恶生天及得解脱义故。当知佛说一切作业有定得果不定得果。我为除下明佛为断向前邪见。故于经中说一切业无不得果此第三段

四或有重下广明业体有定不定成前第二。于中有四。一明业不定。或重作轻或轻作重。二非一切下就人分别。非一切人业皆不定唯愚与智。若有愚人轻业作重。有智之人重业作轻。三是故当知非一切下显前第一轻重相作。非一切业悉定得果故重作轻。亦非不得故轻作重。四一切处凡有二下显前第二唯愚与智。有二举数。愚智列名。下名此二转业不同。智人慧力故令地狱极重之业现世轻受。愚痴之人邪见力故现世轻业地狱重受

自下第三师子设难。若如前说诸业不定不能招苦。何须求于梵行之因及解脱果

自下第四如来释通。于中四对。其第一对略非邪难略显正义。其第二对略释前二。其第三对广显前二。其第四对双结前二。就初对中若一切定则不应求梵行解脱略非邪难。业定得果不可断离。何劳修习梵行解脱。以不定故则修梵行求解脱果略显正义。不定可离故须修断。下重明其须修所以。若离恶业则得善果顺明须修。若远善业则得恶果反明须修。此初对竟

第二对中若一切定则不应求修集道等还非邪难成上初句。一切圣人所以修下还现正义成上后句。先问圣人修道之意。下对辨释。为坏定业得轻报故不定之业无果报故所以修道。此两对竟第三对中初广非邪难成上初句。业有二下广显正义成向后句。前非邪中先别后结。别中四门。一明业定则无修道得解脱过。若一切定举其邪执。下就显过。则不应求修习圣道是一过也。若远修道得解脱者无有是处是二过也。方便之果名为解脱。不得解脱得涅槃者亦无是处是三过也。性净之果名为涅槃

二明业定受报无尽无解脱过。若一切定举其邪执。下就显过。一世所作纯善之业应永受乐乐无尽过。一世所作极重恶业亦应永受苦苦无尽过。业果若尔无修道等无解脱过

三明业定六道四生所作之业无互受过。人作人受就趣征定。且就人征余道可知。婆罗门作婆罗门受就姓征定。且就婆罗余姓可知。下就设难。若如是者则不应有下姓下有是一难也。婆罗门作婆罗门受故无下姓。谓无毗舍首陀等也。人作人受故无下有。谓无地狱畜生等也。人应常人婆罗门应常婆罗门是二难也

四明业定老少作业无互受过。小时作业应小受等明少作业无互受过。老时作等明老作业无互受过。先就恶业难无少受。老时作恶生地狱中。初生之时不应受苦至老方受。初生即受明业不起。下就善业难无少受。老时不杀至后身中不应有其壮年之寿。若无壮寿云何至老业不失故举因显果

上来别破。业若无失云何而有修道涅槃总以结非。前四番中就初以结

上来破邪。下显正义先举二业。次列两名。定以不定业别有八。相从为四。要摄唯二。所言八者现报业中定得果者以之为一。不定得者复以为一。生报后报各有此二。通合为六。不定系属三时业中定得果者以之为一。不定得者复以为一。通前为八。相从四者就前定属三时业中定得果者合之为一。名时报俱定。彼三时中不定得者合之为一。名为时定而报不定。此为二也。就前不定三时业中定得果者说以为一。名为报定而时不定。就前不定三时业中不定得者复以为一。名为时报二俱不定。通善为四。要摄二者。于前四中时报俱定及彼报定而时不定相从为一。名为定业。受报定故。于前四中时报不定及彼时定而报不定相从为一。名不定业。报不定故。故今说为定以不定。下辨其相。文别有四。一略明定。二智者善根深固难下略明不定。三从菩萨无地狱下重明前定。四若业不得三种报下重明不定。就初段中先辨定业。若定心下出定业体。前中先明时报俱定。定业有二牒以举数。报定时定列其名字。义如前释下明报定时不定业。或有报定而时不定略以标举。缘合则受解报定也。或三时受所谓现生后解时不定。三时不定是以言或。下次出其定业之体。若定心作作已信等心坚故定。此是时报俱定之业。若发誓愿供养三宝境胜故定。此是报定时不定业。是名总结

第二略明不定业中。智者善根深难动等约就智人明重不定。愚痴人下约就愚人明轻不定。以是下结

自下第三重明前定。于中初先简去菩萨应化之业。以非三时定业摄故我念往昔与提婆下正明定业。前简化中有八复次。初一复次地狱中化。次一复次畜生中化。次一复次饿鬼中化。后五复次人道中化。略不论天。八中皆初辨其化相。后显非实

正明定中文别有三。第一明其现报善业。于中初约提婆害眼以明现报。后约迦罗害身明现。第二举彼现报善业类显生报后报善业及不善中三报定业。三从菩萨得菩提下重复显之。先辨三相。若业定得现世报下解释定义。前中初明现报之业善恶通论。得菩提时悉得现报是其善也。不善现下是其恶也。次论生报。单彰不善。恶业易成得果速故。后唯明善。善业难成得果迟故。下解定义。若业得现则不能得生报后报就现解定。菩萨三十二相业下就后解定。生略不论

上来第三重明定业。若业。不得三种报者是名不定是第四段重明不定。从上业有二种至此广显正义。前广非邪。后广显正。第三对竟

自下第四双结前二。若言业定则不得有修梵行等结非前邪。则不得有修行解脱违道过也。非我弟子是魔眷属违师过也。若言诸业定不定下结前正义。先明顺道。真我弟子明其顺师。从初至此问答难通合为第一泛明诸业体性不定有可转义

自下第二明转业相。于中有三一明众生不定业多定业至少故有修转。二正明转相。三喻广显。初段可知。第二段中先举二人。次就明转。愚转有四。一不定作定。二现作生。三轻作重。四人中业地狱中受。智人亦四。一定作不定。二应生现受。三重作轻。四地狱人受。次列二名。下重嘱当。第三段中十一复次。皆先立喻。后约显法

自下第三明转业行。师子先问。如佛说等领佛前言。下约为问。云何现轻地狱重受问彼愚人转业之行。云何众生地狱重业现世轻受问彼智人转业之行。佛答有四。一明转人谓愚与智。二明转行谓身戒等。三若有不修于小恶下约行彰转。四总结答。初段可知

第二段中若有修习身戒心慧是智人行。身戒戒学。心是定学。慧是慧学。中明愚行。若有不修身戒心慧是名愚痴略以标举。下广辨之。于中八番。前七明无世谛之行。后一明无真谛之行。就前七中初之五番约业分别。一一番中辨法众多不可别名。第一番中道言不修七种戒者不修身三口四戒也。第二番中道言不修三种相者所谓不修止举舍相

第六约就烦恼分别。不修身者不断身见如是等也

第七约就苦报分别于此门中十四复次明不修身。初五复次明其不能观身无常。如痈已下有二复次明不观苦。如芭蕉下有二复次明不观空。譬如芭蕉生实则枯喻众生身著有沉没。亦如芭蕉内无坚实喻众生身内无真实。如蛇鼠下有一复次不观无我。不知己身唯是四大无我人故。如鹅王下有次复次不观不净。前三约就欲界身说。初一明身自体不净。次一明身种子及与毕竟不净。后一明身自相自体住处不净。如上园下就色界说。戒等可知

第八明无真谛行中若见身者见有身体。好丑名相。往业为因。身即是果。众色集成名为身聚。总一别二。自此他彼。除身名灭。外色身等。上来七门名为自修。修人名者。见有此相名不修身。若见戒者见有戒体。防止戒相。修时名因。成时名果。圣上凡下。多戒名聚。总一别二。自此他彼。息过名灭。又离戒相亦名戒灭。余善名等。修上七门名为戒修。修人名者。戒能到果名波罗蜜。见如是相名不修戒。若见心者见有心体。攀缘心相。往业名因。报心名果。多心名聚。心王名心。想等名数。总一别二。自此他彼。断离名灭。心法名等。修及修者义同前解。上中下心分别种种。善等可知。见如是相名不修心。若见慧者见有慧体。体谓慧数。觉知慧相。始修名因。终成曰果。多慧名聚。总一别二。自此他彼。惑尽治息名为慧灭。檀等诸行慧家眷属名为慧等。上中下慧分别不定。利钝可知。修及修者义同前释。见如是相名不修慧

自下第三约行论转。先愚后智。愚中有三。一不修故转不修上来身戒心慧。二以怖畏下无心故转无出离心。初先法说。如苍蝇下三喻显示。皆初立喻。后合可知。三师子言下明其无善有恶故转。先问后答。答中两种五法辨之

智人转中师子先问。佛答有三。一有修故转。具修上来身戒心慧。二是人设下有心故转。知善大力能修习故。初先法说明善力大。如[疊*毛]华下四喻显示。下合可知。三念已亲下有善故转。于中有六。一近善人。二修正见。三读诵经法。四见受供养。五供事三宝。六信方等如来常恒众生有性。是人能下结成能转。此第三竟

以是义下第四结答

自下第四就常没人劝修趣证。师子先问。问意如何。诸业不定不能为障。众生有性应当自然修道得果。何故不得。文中初言若一切业不定得果牒佛前言明业非障。一切众生悉有性下明有性故应当自然修道得果。初言众生悉有佛性。执有性体住众生中。应当修下执有性用难破段修。此之两执下佛别答宜审记知。于中先就涅槃为难。若一切生有佛性下就菩提设难。此佛别答亦须记知。前涅槃中执性有能起因之用责不得果。应修八道执起因也。明诸众生有佛性故应当自然修集八道。何缘众生不得涅槃责不得果。就菩提中执性有能得果之用责须修道。文有总别。初一切生有佛性故定得菩提何须修道就人总难。如此经下随人别难。此总与别下佛别答亦须记知总中有性定得菩提执性得果。何须修等责须修因。别中有三。初明上人由性得果不假修道。如日月下明其中人由性得果不假修道。若一阐下明其下人由性得果不须修道就上人中先举前说上品病人。一切生下约之显法。何以下释明由佛性就中人中句别有四。一明中人由性得果。先举三喻。日月四河及阐提等不入地狱是三喻也。一切生下约之显法。二何以下释明由佛性。三以是义下明由佛性不假修道。四以性下释明由佛性

就下人中初先法说明不假修。若阐提等不得菩提应须修道反明不假。以因性下顺明不假。磁石喻显。下合可知此等三人下文别答亦须记知

下佛答之。先翻后执。明性离缘不独能用要假修道。若言佛性住众生下对破初执明无定性。住众生中前中先释涅槃上难。若修道者得菩提下释去向前菩提上难。就涅槃中初明众生以不修道不得涅槃。非我咎下明由烦恼是故不得。前中先喻次合后结。前中河边有七种人总以标举。河喻生死。七人通喻一切凡圣。众生本来常在生死。何故言边。身虽恒在心未观入是以言边。又对未起。亦得言边。为洗浴等明入所为。为除业垢而观生死名为洗浴。为离烦恼而观生死名畏寇贼。为集诸善而观生死名为采华。观生死过名入河中。下别显之。合文之中先合初总生死如是合前河也。七人还合七种人也。言畏烦恼合畏寇。贼洗浴采华略而不合。发意欲度合入河中。下别合之。于中先辨七人之相然后释文。泛论七人有其两门。一别行门。二共行门。别行之中三乘各七。小乘七者阐提常没。常没三涂。外凡有信及至暖顶名出已没。忍心已上名出已住见道观方斯陀行去观方已行。那含果上名行已住。阿罗汉果名上高山。中乘七人准小可知。唯最后身独悟为异。大乘七者善趣位前判为常没。善趣位中名出已没。故地持言善趣之人数退数进。习种已上名出已住。初地观方。二地已去名观已行。八地已上名行已住。佛为上山。共行七者略有三门。一开小合大。二乘因中开为六人。如上初门罗汉辟支菩萨及佛合为第七。此义如下迦叶品说。二开大合小以论七人。凡夫二乘通名常没。常没分段变易世间。大乘人中分为后六。如上后门。三大小俱开。外凡常没常没三有。小乘法中五停心观乃至暖顶名出已没。忍世第一名出已住。四沙门果名为观方。辟支佛人名观已行。行于十二因缘法故。菩萨之人名行已住。佛为上山。今此所说就共行中末后言耳。虽举七人宗显初人不得所由。就常没人观修道故。通则为明前之五人不得所以

次释其文。就初人中先合。次帖。下广明其断善因缘。一种六法。两种五法。一种三法明其断善。下余六人。皆初正合次帖下结。文显可知

下总结之。河边诸人皆具手足而不能度结前喻也。众生亦等结前合也。众生合人佛法僧等合有手足。涅槃似山而生不得合不能度。上来第一明由不学不得涅槃

自下第二明由烦恼所以不得。于中如来对上难中。何缘不得明非如来圣道等过皆由烦恼。初先法说于中先明非佛等过次推烦恼。以是下结。次以喻显喻中。但明非如来过。余略不论喻别有五。下合可知

下就菩提释去前难。难有总别。先释总难。如汝所言世有病下解其别难。总中有三。一直立道理。要修圣道方得菩提。二汝言下牒问赞叹。三若言下牒问呵责。良以问者说由佛性定得菩提。当其正因生果之义。故牒赞叹。言不须修违其缘因得果之义。故牒呵责。初段可知

第三叹中汝言众生有佛性故得菩提者正牒问辞。如磁石者佛自立喻成其所说。人谓此言解上问中磁石之语为是致惑。问中磁石在后别解。今佛自举磁石之喻述成问辞。善哉正叹。以性因缘故得菩提辨理以述

第三呵中若言不须修集道者是义不然牒以总非。譬如人下辨正显非。于中七喻。前之一喻别举别合。后之六喻并举总合

下释别难。随前所难。上中下人次第释之。先就上人释去难辞。汝说病人悉得差者牒其问辞。我为六住菩萨说者简胜异劣。六住菩萨方能自得。凡夫二乘何由能尔故须修道。六住之义如上具辨

次就中人释答其难。释意如何。向前问言众生有性无有能遮不得菩提不须修道。今明佛性众生未得故须修道。文中有三。一约空喻明其理性。非内非外非因果性是其理也。性非内故假修方得。性非外故修者必得。二约财喻明其果性非彼非此。性非此故假修方得。性非彼故修者必得。三约业喻明其因性非内非外非有无等。义意同前

初中先喻。后合显法。妄中无真名为非内。真不离妄说为非外。由非内故假修方得。由非外故修者必得

第二段中先喻后合。喻中如人财在异方明其非此。虽不现下彰其非彼。于中初先假问显之。何以下释。合中佛性亦复如是合前财也。言非此者合在异方。证会在当故言非此。言非彼者合言我许。以定得下合前定得

第三段中先喻后合喻中如生造作诸业若善若恶总举喻事。下别显之。句别有九。一非内非外。造已谢往身内即无说为非内。系属造人名曰非外。二非有非无。业谢在往现无法体故言非有。成在过去所以非无。三明非是本无今有。先造已竟故非本无今始有也。四明此业非无因出。由造故有故非无因。五非此作此受。现世造因来世方受。故非此作即此受也。六非此作彼受。非此人作他人受也。七非彼作彼受。由因作果。非果自作。故非彼作还彼受也。八非无作无受。由业作果故非无作。有果酬因故非无受。九明时节和合得果。下次合之。佛性如是合所造业。非本无今有合前第三。非内非外合前第一。非有非无合前第二。言非此者合前第五非此作此受言。非彼者合前第七非彼作彼受。非余来者合前第六非此作彼受。非无因缘合前第四非无因出。亦非一切众生不见合前第八非无作无受。有菩萨下合前第九时合得果。初先正合。下重显之。时谓十住显前时也。修八圣等显前因缘。尔时名见不名为作显前得见。性出自古不从缘生。故唯名见下名作矣

下次释去下人上难。释之如何。向前难言一阐提等有佛性故定得菩提。如彼磁石性能吸铁何用修道。佛今答之。彰彼磁石自不吸铁得缘方吸。佛性亦尔故须修道。文中先解磁石之喻。次约显性。无明不能吸诸行下转喻显成。前中初先正明磁石自不吸铁得缘方吸。如猛火下立喻助显。下复合之。初中有二。一明磁石自不吸铁。二异法下彰彼磁石得缘方吸。就初段中汝言如石是义不然牒以直非。此言略少。若具应云汝言佛性如彼磁石自能吸铁是义不然。何以故下释以显非。先自征责。我以何故道汝不然。下对释之。石不吸铁为是言非。者何以下释显不吸。先为征问。熟见吸铁所以言不。故下释之。石无心业欲吸彼铁为是言不

就后段中正明磁石得缘方吸。兼举无缘不吸显之。文中初言异法有故异法出生正明磁石得缘方吸。异法无故异法灭坏兼辨慈石无缘不吸。无有作者就向初句明吸无心。无有坏者就向后句明不吸无心。言异法有异法生者。法别有三。一石。二铁。三别须人时石就铁。于中石铁两事相望。亦得宣说异有异生。石铁两别俱名异法。良以彼铁异法有故慈石异法出生吸义。三法相望。亦得宣说异有异生。人石两殊俱名异法。良以彼人异法有故磁石异法出生吸义。异法无故异法灭坏准前可知

喻中有六。初言如火喻前慈石。不能焚薪喻不吸铁。亦以无心故言不焚。火出薪坏喻前异法有故出生

第二喻中葵藿随日还喻磁石。亦无敬等喻不吸铁。异法性等喻前异有异法出生。余喻及合文皆可知。性同前喻。故言如是离缘不能吸得菩提转喻显中无明不能吸诸行者离缘不生。余亦如是。亦得名为无明缘行得缘能生余亦如是。此理恒定故言有佛无佛常住。上来第一对破后执明须修道

自下第二对破初执明无定性住众生中。于中先明性之体状。若诸众生了佛性下劝修趣入。前中有四。一破佛性住众生中。二如四大下破众生中定有佛性。三如王告下对前第一广明佛性不即不离。四如来常住即名我下对前第二广明众生不有不无

初中若言性住生中举前所执。前说一切众生有性名住生中。常无住下就以破之。初先法说次喻后合。法中初言常法无住辨正道理。若住无常破邪显正。喻中有六。初举十二因缘为喻。如十二缘无定住处显前无住。若有住下显前有住即是无常。问曰因缘是众生体云何无住复名常乎。释言从人就事以论。缘实有住不得言常。废人泛论十二因缘相生之理无所定属故无住处。相生理定未曾暂无故名为常。二举如来法身为喻。三举法界。四举法入。五举法阴。此亦泛论阴界入法名法界等。六举虚空。佛性下合

自下第二破众生中。定有佛性明诸众生当得名有。非谓身中已有果体。文中有二。一明佛性时至则现。二一切生不退性下明诸众生定得名有。前中先喻。下约显法。法喻如何。如彼四大坚湿暖等无心相异而体各别法性自尔。喻明佛性无心欲出时至则现法性自尔。喻中四大举其喻事。次辨喻相。造色功齐名力均等。力虽均等体性各异故有坚湿暖动之别。所造各异故有赤白黄黑之殊。下总释之。而是四大亦无业者无有心业欲相别异。异法界故不相似者四大不同名异法界。故令坚等各不相似。佛性亦尔合前四大。异法界故时至现者合异法界各不相似。佛性异彼兔角之无。是故众生修道时至即便显现。又复妄法修至则灭。佛性异彼修至则现名异法界

自下第二具以五义说众生有。一明众生无有退灭佛性之理故名为有。此句约就先际以说。二阿毗跋致故名为有。阿毗跋致此名不退。证得之时永无退转故知定有。此句约就中际以说。下三约就后际以说。于中初言以当有故名为有者。解有两义一方便果当生名有。二性净果当显名有。以现众生常定得果故说其有。此句是总。下二是别。以定得者据方便果。以现有因故当定得。以定见者望性净果。以现有因故当定见。是故下结

自下第三广明佛性不即不离。先喻次合。有难下者。下重分别。喻中有六。一如来说经显性示人喻。王喻如来。臣喻此经。象喻佛性盲喻众生。佛以音声显说经法名告一臣。说经显性以示众生名牵一象以示众盲。二尔时臣下经法显性喻。经为圣说名受王敕。令人共读名集众盲。显性令知名以象示。三时彼盲下众生知性喻。想心攀缘名以手触。四臣还自下化法被人反显圣心喻。化显圣心名为白王。显性已讫名为示竟。五尔时王下如来检问众生异答喻。于中有四。一问见不。二答已见。三问见相。四答所见。各随意解种种异答。六如彼众盲不说象下不即不离喻。彼不说象明其不即亦非不说。离是无象彰其不离

下次合之。王喻如来应正遍等合前第一。是诸众生闻说已下超合第五。喻中所触事别有八。合中有六。五阴为五。五阴和合集成我人以为第六。就此六中皆初立性。何以下释。释中初法次喻后合。如彼盲人各各说下合前第六不即不离。先举前喻。次合显法。是故总结。是义云何。如彼麦性不离芽茎。乃至果实别有麦性名为不离。芽茎枝叶前后变改。麦性常定说为不即。性望六法其状像此。然向说我滥同外道所说之我。故下辨异。外道说我实无有我并邪异正众生我者即五阴等显正异邪。于中初法下喻显之。喻别有六。初之一喻别举别合。后之五喻辨举总合

自下第四广明众生不有不无。初明不无。以当得故若我说色是佛性下彰其不有。阴非性故。前中初别。后总结之。别中八门。一说我为性。二说四无量以为佛性。三说信为性。四说极爱一子为性。五说第四根力为性。六说十二因缘为性。佛性名为十二因缘略以标举。义如上解。何以下释。以因缘故如来常者。如来穷证十二缘体故得为常。证成佛常故名佛性。一切生下明诸众生定有如是因缘实性名有佛性。此说因缘滥同生死十二缘相故下辨异。此十二缘即是佛性。性即如来。第七宣说四无碍智以为佛性。第八宣说顶三昧门以为佛性

上来别论。如我上说种种法下总以结之。明前诸法当得名有。十二因缘是众生体。云何说言当得名有。证会在当故名当得。非体在当

前明非无。下显非有。初先不说色阴为性。后类余阴

上来分合合为第一明性体状。下劝修证。若生了性则不须修反劝修证。十住修下顺劝修证。于中有四。一明十住虽修少见。二况不修下以圣况凡明凡不见必须修道。三如文殊下彰彼文殊久修乃见。四云何下以大形小明小不见必须修道

品初至此合为第一问答辨法。自下第二叹经劝学。初先劝学。佛性不可思议已下叹经殊胜。前中有三。一劝修生欲见佛性应自持经。二见有下劝供持人。三若有下举经难闻令人敬学

下叹经中文别有三。一叹人不思将以类经。二大涅槃经亦如是下辨经同人。三如大海下当法正叹。就叹人中位别有三。一就十信叹其依经生信不思。二师子言云何不退菩萨已下就种性上叹其依经起行不思。三菩萨了了知见无下就初地上叹其依经成德不思。初中有三。一正叹依经生信不思。二师子言下举多不信成信不思。三善男下明经多益。现得闻者当必能信。初中五句。前四明其所信不思。后一彰其能信不思。此互相显。就前四中初一明其佛性不思。第二明其三宝不思。三就前第一明诸众生有性不思。四就前第二明其佛宝体德不思。以此经中所信之法故举显信。能信可知

第二段中师子初言如佛所说能信不思述佛前言。是大众下举多不信成信不思。第三可知

自下第二明种性上起行不思。文别有二。一明菩萨起行不退。二复次菩萨不可思下叹其所行为不思议。前中师子先问起发。云何菩萨自知不退。下佛为辨先别后结别中初于无益苦中自试其心。为破苦下有益苦中自坚其心。益中有四。一与乐行中坚心不退。二为法下求法行中坚心不退。三为破一切众生苦下救苦行中坚心不退。四修度下六摄善行中坚心不退。初段可知。第二段中初燃身求法坚心不退。复次菩萨具烦恼下余苦求法坚心不退。第三段中初救饥苦。后救病苦。前中先于余时救饥。于饥世下。饥馑劫时能救物饥。前余时中先总后别总中初明受身救物。虽受畜身终不造下辨定其因。于中初明不造新业。若未来下明用故业。先法次喻。过去恶业如鬼在身。悲愿力故一切悉受。如以咒力鬼相悉现。下合可知。问曰此等所受之身分段变易二种生中何生所摄。释言分段以是有漏恶业果故。问曰。若此是分段者何故胜鬘说种性上为变易死。释言种性以上菩萨有五种身。一法性身。如地持说六入殊胜无始法尔。二实报身。谓从先来修善所得。三应化身。依前起用。四变易身。所谓缘照无漏业果。五分段身。所谓三界有漏业果。五中初二是其真身。第三是应。于前真中有反易杂。于前应中有分段杂。彼胜鬘中言变易死据第四门。今言分段当第五门。不相乖背。上来总竟。受罴下别。救病苦中初明菩萨于病劫时能救病苦。若有众生为鬼病下于余时中能救病苦。第四段中修善不退。文显可知。上来别竟

作是愿时名不退下总以结之。上来第一明种性上起行不退

自下第二叹其不思。复次不思总以标举。何以下释。释有八番。文显可知

下明出世成德不思。初言菩萨了了知见无众生等。内证平等名不思议。受后边下八相巧化名不思议。初生兜率。文别有四。一总明菩萨生兜率天为不思议。二何以下解释菩萨偏生所以。先问后解。胜故偏生。欲界中胜总以标举。下别显之。下天放逸上天闇钝形对余天显此报胜。修戒修施得上下身修施戒定得兜率者形对余天显此胜。欲界乱地云何有定。此非八禅。欲界地中念佛三昧生彼天中。故言修定得兜率身。三毁呰下彰圣异凡。菩萨毁有终不造作兜率业等正明异凡。何以下释。释意如何。辨明菩萨一切处生皆得教化成就众生非唯兜率。是故于彼不偏贪爱造业求生。四生兜率有三胜下辨胜过劣。于中有四。一明菩萨三事报胜。三深乐下明其因胜。问曰前说不造业生。今云何言有因胜乎。释言不造有漏业生而有大悲愿力为因故云因胜。三如是三事虽胜已下就前三事明清净胜。他见不妒。自心不慢。四不造命下就前三事以显胜相

第二次明退来入胎。于中初明兜率退时大地振动。下以二义释动所以。文显可知。入胎住胎出胎可解。余略不论

上来叹人。大涅槃经亦复如是不可思者是第二段辨经同人

如海已下是第三段当法正叹。先喻次合。有难解者下重分别。喻中先举。次列八名。下辨其相。一一之中各有三事。一众生福力令海渐深易可趣入。二顺风行从畔渐远亦名渐深。三河水入中遂水渐进亦名渐深。余中二事文略不辨

合中初言。涅槃如是有八不思合初总也。次别合之。初门可知。第二门中初先就人以显其深。后就说论深。人中初就如来明深。次就凡夫。后就二乘。二乘能得阿耨菩提是一不思。二乘之人心无烦恼身无住处而不名常是二不思。下就说中辨法众多不可具论。余文可解

是故此经如海总结

前喻。次合。下重显之。师子先问。若言如来不生不灭名为深者牒佛向前合喻之言。有四生下约之为问。问意如何。前说如来无生无灭便无生缚。既无生缚于生自在。何故于彼四生之中不受化生乃受胎生。于中初先总举四生次列其名。义如别章。后就人辨。下约设难。佛得自在何因缘故不受化生。下佛答之。一切众生四生所生简凡异圣。得圣法已不得如本。卵生湿生辨圣异凡。此释如来无下二生。劫初已下解不化生。有八复次。一明如来劫初不出故不化生。何故不出。劫初众生烦恼未发又无道器。二明如来托胜通法故不化生。生处尊胜凡所说法人皆信故。三为教人孝养之业故不化生。是义云何。化生之人无父无母。知复云何教人敬养。于中初言父作子业子作父业子作父业泛举世事。父必作于养子之业。子必作于敬父之业。如来世尊若受化下明已须同反以论之。文相可知。四假亲护法故不化生。先举二数。次列两名。下辨。后结。辨中先顺后反可知。五居尊息慢故不化生。是义云何。佛生王种破诸众生恃性憍憍。六受胎息谤故不化生。是义云何。佛亲圆具世尚言幻何况全无。七为残身留益世间故不化生。是义云何。夫化生者身必化灭无复残形何以益世。故不化生。八为同诸佛故不化生。是义云何。三世诸佛化胎众生法皆胎生故佛同之。诸佛何故皆受胎生。义如前七。又为增长同生之力故受胎生

自下第三师子荷恩领解赞叹

迦叶品者学行有三。一随缘造修向前五行十功德是。二舍相入证。师子品是。三证实成果亦名起用。此品论之。是义由于迦叶启请而得宣唱。故就请人以显章目名迦叶品。此品之中义意唯二。一举化阐提彰佛德行。二举佛德行明能化益一阐提义。故下文中赞叹此经名阐提杖。一阐提人因之得起

文中有二。一明如来妙用善行能益阐提。二品末迦叶领解赞叹。前中有三。一答上问中众生大依明佛身业。二迦叶白如来具足知诸根力是故能知一切生下答上问中两足妙药明佛口叶。三迦叶白断三世因名断善下答上问中今欲问阴而我无智如是甚深唯佛境界明佛意业。又答初问辨明如来为人物依为令阐提于佛生信。答第二问明佛所说法为妙药为令阐提于佛教法舍谤生信。答第三问明佛智胜所知独绝为令阐提于佛义法仰推成信。初中迦叶先问起发。前已问竟何劳更问。去问遥远故须重问上下多然。此问与前有何差别。迦叶前者直为赞问。赞叹如来能为物依。今于此处具为两问。一赞。二难。从初乃至作大药王是其赞问。善星是佛菩萨子下是其难问。迦叶前者何不即难至此方为。前者若举善星为难言辞浮广不成偈义。故前不难。由前不难此须为之。此中何不望直为难先为赞乎。将夺先与。为难法尔。故先赞叹。叹中初言如来怜愍一切众生叹佛有慈为利他心。不调已下叹有方便为利他智于中七句。前四化能。不调能调拔恶始也。不净能净拔恶终也。无归作归救苦始也。未脱能脱救苦终也。后三化德。具八自在救苦之德。为大医师作大药王拔恶之德。知病如医。差病似药

如来先与。下正征夺。为彰如来慈悲行化故举善星恶人为难。就此文中难意有二。一难佛无慈翻前第一。二难无方便翻上第二。文要有三。一举佛记善星比丘是一阐提地狱劫住彰佛无慈。二不可治下举佛宣说善星叵治明无方便。三若不能救善星已下双结前二。句别有七。善星是佛菩萨时子是第一句明其形近。此应是佛党弟庶儿故说为子。出家之后诵持读诵十二部经坏欲界结获得四禅是第二句彰其行亲。云何记说是一阐提地狱劫住是第三句责佛记说成佛无慈。不可治人是第四句责佛如来摄化不行。不能行化故言叵治。何故不先为其说法是第五句责佛如来授化不善。若不能救云何得名有大慈悲是第六句结佛无慈。云何得名有大方便是第七句结无方便。下佛别答。宜审记知

就佛答中答问不尽而复不次。前七句中但答后六故言不尽。就所答中先答第五。次答第四。次答第二。次答第六。次答第三。后答第七。故云不次

先答第五何不先为善星说法。于中有二。一明如来随化所宜不得先为善星说法。二如师子下明虽不先心无增减。前中六番皆先立喻反问迦叶。次迦叶答。后佛约之以显所说。后中先喻后合可知

我于一时住王舍下答第四句。明说善星叵治所以。有五复次。一明善星反被拘执恐怖如来。二扫灭佛迹。三见尼干服食酒糟言是罗汉违反佛语。四见苦得言是罗汉故违佛语。五佛为说法无心信受。初二身恶。次二口恶。后一意恶

善星虽复读诵已下却答第二明虽禅诵而不可救。先彰其过。下与迦叶身往验试。前中四句。一明善星虽复读诵心不解义。二明善星得禅还失。三起恶邪谤无佛答。四我尔时下佛为说法无心信受。身验可知

善星虽入佛法已下超答第六明已有慈。于中有三。一明已有慈。二若本贪下彰已慈深。三我弟子下举他同怜显已慈实。初中复三。一明善星亡失善法先法后喻。二又如下断坏法身。先喻后合。喻中自戮自心坏善。罗刹所杀恶友坏善。合文可知。三明佛慈次怜愍故言多伤叹。常说善星多诸放逸。第二明已慈深之中先喻次合下结可知第三显已慈实之中先法后喻

我于多年常与已下却答第三明说善星是一阐提狱住所以。于中有四。一明已多年摄化不得。二由化不得说为阐提地狱劫住。三明说所为。四明说不虚。初中多年与相随者。佛二十年摄为侍者故言多年。就第二中初先法说。次喻。后合。法中初明有善不说。以其宣下无善故说。喻合亦尔。就第三中迦叶先问。何故记说。佛答可知。就第四中初明如来所说无二。声闻已下举劣显胜

善星常为无量生下答第七问。明有方便两义辨之。一化益分别。益有二种。一摄善星多年共住不令在外教人作恶名有方便。二摄善星令其出家不使在俗多起罪过名有方便。二化德分别。化德有二。一就佛解力明有方便。二就佛根力明有方便。就解力中初明善星常为众生说无善恶。我久知下佛惧其人邪化多损摄令共住。我若远下明共住意。是名解力总以结之

就根力中文别有三。一知断善根。二如来具足知根力下知生善根。三佛观众生具善法下通知生断。初知断中有五问答相因而起。迦叶初问阐提何缘无有善法。佛答阐提断善故无。阐提断善是其总答。众生悉有信等五根阐提永断是其别答。以是义下约杀显无

第二迦叶乘言定佛一阐提者无善法耶。佛答如是

第三迦叶乘言难佛。三世善中未来不断云何言无。初言众生有三种善泛尔通举。过未现在列言三名。阐提不能断未来善云何说断就之结难

下佛答之。文别有三。一明有断。二如人

下明断善人有其可救不可救义。三如朽败下明所断善有其可生不可生义。初中应先明断善义然后释文。义有十门。一明断相。断有三道。一方便道。观有因果以之为非。观无因果以之为是。二无碍道。见有为非。三解脱道。见无为是。无碍解脱各有九品。始从下下乃至上上与彼等智断结相似

第二约对二种善法彰断差别。言二善者。一方便善谓现所起闻思修等。二生得善过习今成。前三道中初方便道断方便善。无碍解脱断生得善。三约因果二善明断。若约善因以论其断。断三世因名断善根。是义云何。邪心现前断过去善。生现之义名断过因。现不起故不生未来名断现因。当善不生不能起后名断未来。故下文言断三世因名断善根。就过去中生现可断。生未来义终不可断故后得生。若约善果以论其断。唯断现在及遮未来不断过去。起已谢往不可断故。故此说言现在善灭及障未来名断善根。四就趣分别。唯在人中不通余道。人能思求起异见故。五就人中利钝分别。如下文说要是利根能推求者非是愚钝。破僧亦尔。六就时分别。多世积习方能断善非是一世。故上文中说为报障。七就处分别。唯在阎浮不通余方。阎浮众生。心穴利故。八明所因。由闻大乘空相应经执无谤有故断善根。故地持云是人闻于难解空经。于如实说一向不解作不正思言一切无。九明轻重。一切恶中此过最重更无过者。以断一切诸善根故。十明断善还生之义。彼何时生。如下文说。入地狱时出地狱时。轻者入时重者出时还生善根。问曰出时善恶无记三性心中何心中生。一向不是善心中生。先无善故。多在不善疑心中生。问曰善恶正相乖反。云何于彼不善心边得生善根。释言善恶二心相反不得并生。得善之得体非色心与心不妨。故得于彼不善边生。如从上地生下地时染污心边得下善根。此亦如之

次释其文。断有二种总以标举。次列其名。具是二下牒以结之

第二可救不可救中初约行善现在叵救。后约性善未来可救。行中先喻。如人没厕喻一阐提断灭善根趣向地狱。一毛来没喻过去善生未来义阐提不断。虽一未没不能胜身喻彼善根不遮地狱。次约显法。阐提如是合人没厕。虽未来世当有善根合向唯有一毛未没。而不能救地狱之苦合不胜身。未来之世虽可救下牒以结之下约性善明可救中。佛性因缘则可救者性非过去未来现在。故无断者明定可救。由性不断定可见故。

第三可生不可生中明其所断善根不生。先喻后合。文显可知

第四迦叶乘言重难。如来向说佛性不断云何名为断一切善。下佛答之。明性非现是故有断。于中有三。一总明众生现无佛性故得断善为一阐提。反以论之。先法后喻。若生现有不名阐提是法说也。解有两义。一性体常住非三世摄故非现有。二众生未见故名现无。如世间中众生我法举喻显。之现在妄中于情分声全无佛性。如众生中毕竟无我故取为喻。二佛性常下显向初义。彰性体常非三世摄故非现有。先顺后反。佛性是常三世不摄是顺显也。三世若摄名为无常是反显也。三佛性未来以当见下显向后义。当见名有非是现。有故名现无。佛性未来以当见故言众生有正举当见成其现无。以是义下出当见处。以是当见名有义故。十住具严乃得少见

第五迦叶乘言重难。难有两句。一难前佛性。性如虚空如来何故说为未来。二难上阐提无善之义。若言阐提断故无善一阐提辈于同学等亦生爱念岂非善乎。下佛先叹。后正答之。先答佛性。初先正解。有难解者问答重显。就正解中性如虚空非过去等述其所立。一切众生有三身下释其所难。初先正解。后类显之。就正解中一切众生有三种身泛以通举。过未现在列其三名。未来身净而得性故我言未来正解所问。此乃明其未来身得性非未来。就类显中举先其类。我为众生说因为果说果为因略以标举。是故经中说命为食见色名触略辨其相。说因为果如似世人说食为命。四大名色。今略不举。说果为因其犹世人说命为食见色名触。今偏论之。色是造色谓青黄等。触者所谓能造四大。色实非触。说果为因是故见色名为触矣。人言见色名为触者一向不是。未来身净故说佛性约类显法。未来身净如前命也。如食也。若就前句类显佛性。食因非命。说因为果故名为命所显如是。性因非是未来身果。说因为果故名佛性以为未来。若就后句类显佛性。命非食因。说果为因故名为食。色触亦然。所显如是。未来之果实非佛性。说果为因故说未来身净为性

上来一番当问正解。有难解者下重显之。迦叶先问。若如佛说未来身净可说有性。众生现在未有净身何故如来说一切生皆有佛性。佛答有三。一明佛性虽无现用而体不无故得言有。性虽现无无现用也。不可言无不无体也。如空喻显。空性无现喻向初句。不得言无喻向后句。二明佛性常住不灭故得言有。众生无常辨相异性。而性常住辨性异相。三明佛性虽复非内而复非外故得言有。于中初法次喻后合

此答初问。下答后问。汝言不然牒问总非。何以下释。释中初法次喻后合。法中初先举其所作。阐提若有身口意业就具以举。取业求业约惑以举。见心造业名为取业。爱心造业名为求业。施业解业当相以举。阐提亦有舍财名施。亦有读诵分别名解。如是皆邪。结明无善。何以下释。喻合可知。上来知断

自下第二知生善根。于中有三。一知众生根转不定。如来具足知诸根力总以标举。故能分别上中下根略显知相。能知转等广显知相。是故下结。二知诸根生断不定。以不定故或断还生顺明不定。若根定下反明不定。是故下结。三随知行答。迦叶先问佛具根力定知善星当断善根。以何因缘听其出家。佛答有三。一遮其现罪故听出家。在俗为王当坏法故。二生其当善故听出家。远生未来出世善故。若不出家亦断善等举损显益。今出家等彰益异损。三是故下结。先顺后反

自下第三双知生断。于中有三。一知断善。佛观众生具善不善知先所成。是人虽具不久能断知其当断。何以下释。不能近友听法思量如说修故。以是下结

二知生善。如来复知是人现等法说明知。次以喻显。泉喻菩提。村喻生死。离生死外即是菩提故言不远。果德纯妙称曰甘美。众行圆备名具八德。生善之人厌有名热求出称渴。发心趣向名为欲往。智者喻佛。知其定去故曰无疑。何以下释。下合可知

三知生断多少之义于中如来先取地土反问迦叶。迦叶次答。下佛约之以显生断多少之义。句别有四。一知未来趣善者少。二知未来向恶者多。三护持下知其现在修善者少。四毁戒下知其现在作恶者多

自下第二答上问中两足妙药。于中迦叶先问发起。前已问竟何劳更问。去问远故。此问与前有何差别。前直赞问赞佛所说。法为妙药。今于此处具为两门。一赞。二难。初至亦知未来诸根是其赞问。如是众生于佛灭下是其难问。迦叶前者何不即难至此方为。前者若举二十一对诤论难佛。言辞浮广不成偈义为是不难。由前不难故此为之今此何不望直为难。先为赞乎。将夺先与。为难法尔。故先叹之。叹中如来具足根力牒佛前言。下明所知。所知有三。一知众生上中下根。二知诸根利钝差别。三知众生现未根别

下对设难。难意如何。佛具根力说应当机。何因缘故作不定说。令未来人各执圣言起诤断善。于中先举二十一对诤论之言。下责如来。何故今日作不定说

下佛答之。明己所说皆是众生病之良药。愚人不解故起诤论。文中有四。第一总答。二若如来毕竟已下随问别答。三如是诤讼是佛境下总叹显深令人仰推。四若人于是生疑心者犹能摧坏无量恼下明取舍得失令人舍着。初总答中文别有二。一当法略答。二于一名下约类广答。略中有四。一叹法深。如是之义非六识识唯智慧知。二约对愚智彰说不同。于有智者不作二说。智亦谓佛不作二说。于无智者作不定说。彼亦谓佛作不定说。是义云何。今且约初涅槃辨之。余类可知。佛于智者宣说应身入于涅槃真身不入。随其别法各施一言名不二说。智人解此。故亦谓佛不作二说愚人于法多喜偏执。闻佛应灭谓一向灭。佛为破之说真不灭。闻真不灭谓应亦然。佛为破之说应有灭。两言相反名不定说。彼亦谓佛作不定说。三彰己所说各为病治并是妙药。所有一切悉为调生法说明也。譬如医等喻说明也。四明所说不定所以。为国土者处别故异。为他语者随解故异。为人故者随生故异。人有愚智大小等别故说不同。为众根者随机故异为是等故于一法中作二种说

就下广中文别有四。一就法举类。二是故随人随意已下约之显法。三五种众生不应为说五种法下约人举类。四如汝所言佛涅槃下约之显法。此四段中前二一对法相不定。后二一对随人不定。就初段中类别有三。一明诸法一异不定。二广略不定。三浅深不定。三中初门一处辨之。后之两门一处并举。就初类中先开三门。言一名法说无量名者显体之名名法不殊名一名法。此法体中义别众多随别施名。是故得于一名法中说无量名。于一义中说无量名者诸义同体互相集成。一备一切一切成一。良以一中备一切故。随之施名名亦众多。故于一义说无量名。于无量义说无量名者随其别义各施异名。故得于彼无量义中说无量名

下广辨之。云何一名说无量名牒问初门。于中具就涅槃辨之。余法类尔。云何一义说无量名牒问第二。于中具就帝释辨之。帝释胡语。此翻名为能作天主。憍尸迦者是其本姓。过去世时波罗奈国有婆罗门。姓憍尸迦。好修福业。与其同友三十二人共为邑义。憍尸命终为忉利王。余为辅臣。佛依本姓呼为憍尸。于中或有从宝从幢种种名之。云何无量义说无量名牒问第三具就佛论。具八智者。佛知生死无常与苦无我不净。知涅槃法常乐我净名为八智。亦可更有。文中不列。义不尽者下重论之。复有一义说无量名重牒前门。如阴一义。亦名阴者当义施名。余皆傍立。亦名倒者能生倒心故名为倒。如五尘境生欲。亦名谛者有漏五阴是苦集谛。无漏五阴是其道谛。名四念者色阴身念。受阴受念。识阴心念。想行法念。名四食者段食是色。故色阴中有其段食。识阴识食。行中具有思食触食。受想不论。四识住者有漏阴中除识一种。自余四阴为识所依。名四识住。亦名有者所谓三有二十五有。亦名道者所谓六道。亦名时者现生后时。亦可是其生住灭时。名众生者因中说果亦名为世。第一义者相名世谛。体名第一。名三修者色名身戒。余四名心。名因果者善恶五阴说为集因。报阴名果。名烦恼者有漏五阴从烦恼生。能生烦恼故名烦恼。名解脱者无漏五阴。三世转轮名十二因缘。集成假人名声闻等。三世分异名过去等。是名结之。此初类竟

下举广略浅深为类。如来为生广中说略略中说广以为一门广略不定第一义谛说为世谛世谛说为第一义谛复为一门浅深不定。云何名为广中说下释显初门。云何第一说世谛下释显后门。如汝得法故名阿若憍陈如者。阿之言无。若之言智。陈如是姓。证无成智故名无智

上来举类。下约显法。句别有四。一顺明如来随人不同差别异说名知根力。二反明定说不具根力。谓于向前所诤义中作定说者不称物机。是故不名具知根力。三重显初句明随人别不得定说。于中初明所化众生受法各异。先喻后合。喻中象负非驴胜者喻明菩萨所受行法二乘不堪。下合可知。次明如来随之异说。何以下释。四若使下显前第二明佛定说不具根力

自下第三约人举类。于中初约五种恶人以举其类。是故我先告舍利下约就利钝二人举类。前中有三。一举昔言明五众生不应还为说五种法。问曰经说悭贪众生教行布施乃至痴者教修智慧。今以何故不信人前不赞正信。乃至痴前不赞智慧。释言随人不同故尔。若人内有出世道机厌患已过。则须当病为说对治。悭为说施。乃至痴者为说智慧。若无道机不厌已过则须将护。不信人前不赞正信。乃至痴前不赞智慧。二何为故下释前不得为说所以。若说不名知根怜生。三何以下释前不名知根怜生。是人闻说起恶受苦。是故不名怜生知根

就约利钝举类之中初告舍利为利勿广为钝莫略。问曰利人堪受多法应为广说。钝人不能摄受多法应为略说。今以何故为利不广为钝不略。释言广略有其二种。一约法分别。辨宣多法名之为广说少称略。若从是义广为利人能多受故。略为钝者不堪受故。二就说分别。于一法中多言名广少语称略。若从是义。略为利人少言能解。广为钝人多言方悟。舍利次答。后佛述成

自下第四约之显法。文别有四。一牒其所问。玄呵诤者颠倒因缘不得正见是故不能自利利他。二明已随物不得定说。三十方下举他类已。于中初明一切诸佛化生不同故说十二。次明十二为他非自。下结诸佛随解异说名具解力。四佛自彰已具足根解二种力故知人现未断善及脱。先牒二力。次辨。后结。以具二力故名力士

上来总答。自下第二随问别答。于中应先辨其诤相。起诤虽众约法唯三。一大小见异故起诤论。如说涅槃不涅槃等。二就大中见别起诤。如说佛性即离有等。三就小中见别起诤。如说罗汉退不退等。凡夫二乘通名为小。次辨释义。世人解诤多不以理。学毗昙者偏助毗昙。学成实者偏佐成实。此乃助诤。何成辨理。和谐通取是释义也

文中先辨如来涅槃不涅槃义。三句释之。一辨诤相。有人闻佛应身有灭谓真亦然。有人闻说真身常存谓应同尔所以成诤。二须论理。理则兼通。于真常存随化有灭不得偏取。三次释文。若言如来毕竟涅槃及不涅槃是人不解双牒总呵。下别显之。先明如来为物说灭凡闻起诤昔为五人说佛涅槃。一为诸仙。二为力士。三为纯陀。四为须跋。五为世王。第七德中为七人说。今略论五。下明如来说不涅槃凡闻起诤。为小菩萨闻灭心退故说佛常。愚人不解。谓定不灭

第二次辨有我无我。于中还初辨其诤相。有人闻说众生无我。谓呼世俗假我亦无。有人闻说假名之我。便立性实所以成诤。次辨道理。理则兼通。阴合成人名为有我。阴别无人名为无我。下释其文。于中初明如来说我凡闻起诤有两复次。文显可知。后说无我凡闻起诤。圣说无中初有比丘问佛我义。次佛对破。下明比丘闻而得果。问中世尊云何名我问其我因。我缘我者问其我缘。就佛破中无我我所总明无我。眼者已下略显无义。虽有业下广显无义。于中有四。一略就因果以明无我。二无舍阴下略就五阴以明无我。三如汝问下广就因果以明无我。于中初法次喻后合。法中初言云何我者牒其初问。即是期者对问辨释。指报为我。报由结业期会而生故名为期。谁及何缘相显可知。喻中二手喻前业爱。声喻期也。合中初言我亦如是总合前喻。下别合之。众生合声。业爱合前二手相拍。此三和合名为我故无别我人。四一切生下广就五阴以明无我。句别有三。一明阴无我。二诸外道下破有归无。明诸外道计阴作我离阴更无。三如幻下辨法显无。五阴诸行皆如幻化无常乐等故无有我。第三比丘得益可知第三次辨中阴有无。先辨诤相。毗昙法中说除四空余一切处定有中阴。成实法中说一切无所以成诤。次辨道理。理则不偏。亦有亦无。极重恶业趣向阿鼻。前念人间后念已在。中无经停则无中阴。趣向四空亦无中阴。余皆具有不得偏取。文中初明如来说有凡闻起诤。有四复次。一说众生三事受身父母中阴。第二宣说中般那含。三说中阴根具明了。四说中阴形色好恶愚人闻此谓一切有。下明说无凡闻起诤。有四复次。一说五逆趣向阿鼻无其中阴。二说昙摩趣向阿鼻无其中阴。三为犊子说无中阴。四说无色无其中阴。愚闻不解谓一切无

第四次辨阿罗汉人有退无退。先辨诤有相人宣说一切罗汉悉皆有退。此别师义不同毗昙。成实宣说一切不退所以成诤。次须论理。理则不偏。是义云何。分别有五。一约惑分别。烦恼有二。一受生烦恼。于受生时起贪等结。二障道烦恼。现起染污妨碍圣道。彼阿罗汉受生烦恼一向不起名为不退。障道烦恼得有起义名为有退。二约烦恼因缘分别。惑起有三。一性使不断为因故起。二以不正思惟故起。三缘力故起。如见女色生贪欲等。阿罗汉人无前二因而起烦恼名为不退。缘力生结名为有退。谓见增上可贪境界暂尔生贪。还即摄心断之令灭。三约道分别。道有二种。一者有漏等智断结。二者无漏圣道断结。等智断结则有退转。无漏断结则无退转。四约修分别。散乱有退。专修无退。五就根分别。钝根有退。利根无退。义既如是不得偏执。文中初明如来说退凡闻起诤。有五复次。一者为于懈怠比丘说退有五。二说罗汉虽无内因不离外缘所以有退。三举瞿坻证成有退。四举时不时二种解脱证成有退。五举六种罗汉证成有退。退思护住胜进不动是六罗汉。下说不退凡闻起净。有二复次。一明罗汉所断烦恼。犹如燋炭不还为木所以不退。二明罗汉于彼三种烦恼因中已断二种故言不退。先举三数。次列三名。下明所断

第五次辨佛身有为无为之义。应先辨诤。诤相可知。次论道理。理则不偏。是义云何佛身二种。一共世间身随世生灭。二是平等法门之身常寂不动。义既两兼不得偏执。文中初说佛身有为凡闻起诤。后说无为凡闻起诤

第六次辨十二因缘有为无为。先辨诤相。有人一向宣说有为。有人一向定说无为。所以成诤。次辨道理。理则不偏。是义云何。释有两门。一就人论事。三世流转是其有为。直据因缘相生之理。古今常定无一念间。而无此法是其无为。第二直就因缘事中现起之者名曰有为。在未来者现未起用说作无为。义既两兼不得偏取。文中初说因缘有为凡闻起诤。后说无为凡闻起诤。于中两义。备如向辨。我又一时说十二因缘有佛无佛性相常住是初义也。有十二缘不从缘下是后义也。先开四门。后广辨释。文显可知。虽举四门为取第一不从缘生为无为也

第七次辨心常心断。应先辨诤。诤相可知。次须论理。理则不偏。亦常亦断相续不绝故说为常。运运尽谢所以名断。义既两兼不得偏取。文相可知

第八次明五欲障道不障道义。应先辨诤。诤相可知。次应论理。亦障不障。不障下果能障那含及罗汉果。义既两兼。不得偏执。文显可知

第九次辨世第一法。欲界所摄色无色摄。先辨诤相。三人起诤。一家宣说定欲界摄。一家宣说定色界摄。一家宣说定无色摄。次须论理。理则不定。亦得名为欲界所摄。解有三义。一依定说。依于欲界电光常起名欲界摄。二约惑说。依未来禅断欲界结而未穷尽修起此法。欲过未尽而起此法名欲界摄。三依身说。此法必依欲界身起名欲界摄。亦得名为色界所摄。释有两义。一依定说。依于色界六地禅起名色界摄。二约惑说。欲界爱尽色爱未尽修起此法名色界摄。亦得名为无色界摄。论宗不同。若依毗昙唯约惑说。无色界结未断未尽修起此法。是故名为无色界摄。若依成实解有两义。一依定说。依无色定亦得修起。故从所依名无色摄。二约惑说。义同毗昙。义既如是不得偏执。经文之中先就欲界明说起诤。我经中说未离欲界未得解脱。犹如欲界修第一法。三种义中偏就第二约惑说也。凡闻不解谓定欲界。次就色界明说起诤。我说暖顶至世第一在于初禅至第四者。两种义中偏就初门依定说也。愚闻定谓色界所摄。下就无色明说起诤。我说外道先已得断四禅烦恼修集暖顶至世第一观四真谛得那含者。义同毗昙偏约惑说。凡闻不解定谓无色。所以成诤

第十次辨布施之义。先辨诤相。有人宣说施唯是意。有人宣说是五阴性。次须论理。主唯是意。眷属五阴。文中初先说施是意凡闻起诤。说施四种泛以通举。次辨后结。前三是净。下明愚人闻说有信名为净施谓施唯意。下明说施是其五阴凡闻起诤。先举五数。次列五名。下总结之。五中色力及与辨才是其色阴。安乐受阴。命则不定。依如毗昙别有非色非心命根是行阴收。地持论等亦同此说。成实法中色心相续名之为命。则五阴摄。愚人闻此便言五阴皆是施体

第十一门辨三无为有无之义。先辨诤相。毗昙法中说三无为一向是有。以是有故若人谤无便得大罪。又复无法则不生心。三无为法为心所缘。得生心故明知是有。成实法中说为定无。以谤无故所以得罪。以谤不有。又彼论中无亦生心。如缘镜像梦中事等并是无法亦得生心。云何不生。诤相如是。次辨道理。理则无偏。亦有亦无。望有为法彼一向无。如瓶破已更何所有。望理论之得名为有。除事始有。非是本来自体无故。故地持云有为无为名之为有。无我我所名无有也。理既如是。不得偏取。文中初明如来说无凡闻起诤。我说涅槃离烦恼等明其数灭无为是无先法后喻。言虚空下明其虚空无为是无。初先正辨。譬如已下即事显之。非智缘下明非数灭无为是无。初先正辨。如其有下破有成无。愚人闻此谓无无为。下明说有凡闻起诤。于中先明数灭是有。可以言论名为章句。为心游履名为是路。所归中极名毕竟处。得之安稳名无所畏。为人习学名为大师。为道所克说为大果。为智穷证名毕竟智。为心所安名为大忍。常寂不动名为三昧。果德分齐名为法界。能除一切生死憔渴说为甘露。非凡能证故曰难见。此直明有。若说无下举谤显有。眼不牢下明其虚空无为是有有人未得须陀已下明非数灭无为是有。忍法已去更不退转无复重堕三涂之义。是故无量三恶道报。至此忍时皆非数灭。上来明有。愚人闻此谓一向有。所以成诤

第十二门次辨色法是四大造非四大造。先辨诤相。具论有三。一依佛陀提婆所说。色即四大无别造色。二依毗昙。四大是本名为能造。余青黄等是其所造。此当毗昙。三依成实。四大是假色香味触四尘集成不造诸色。今此文中偏举前二。第三不论。诤相如是次辨道理。四大有二。一实。二假。坚湿暖动四触为大名之为实。所依大地河池之水草木火等揽诸尘成说为假名假名四大不造诸色经论大同。实触四大望于诸色亦造不造。是义云何。色香味触同一体性互相集成。如海十相同体相成。所言四大即四尘中触尘所收。彼虽同体。随义别分。四大是本说之为体。余者是末说之为相。体则如镜。相则如彼镜中之像。以同体故体外无别。色法可造名无造色。此异毗昙。体相别故。依体相现名有造色。异于初诤。义既兼通不可偏取。问曰四尘同体相成。何故偏说四大为本。释言色法以碍为性。以触对故色性名碍。故以坚湿暖等四触为诸色本。文中初明说大为色凡闻起诤。文别有三。一教跋波观色断爱。二跋波问色。如来为说四大名色。就本以指。自余四阴心法难彰非名不显。就诠立目说之为名。三明愚人闻之起诤。下说造色凡闻起诤。譬如因镜则有像现立喻明造。色亦如是因四大故则有造色合喻明造。色合彼像。四大合镜。下列所造。言粗细者是所造色。大物名粗。小物称细。此粗与细毗昙不说。言涩滑者是所造触。青黄赤白长短方圆及与斜角复是造色。轻重寒热及与饥渴复是造触。寒者毗昙说之为冷热者毗昙造触中无。当应地大增强为热与冷相对。烟云尘雾复是造色。依如毗昙更有高下。光影明闇正不正等并是造色。此中略无。是名总结。犹如响像借喻显之。能造四大如镜如谷。所造之色如响如像。下明弟子不解起诤

第十三门明无作戒是色非色。先辨诤相。毗昙法中说无作戒一向是色四大所造。成实法中一向说为非色非心。诤相如是。次辨道理。小乘所受无作之戒亦色非色是其色法故名为色。而非色事故曰非色。是义云何。所受是其身口止业从身口生防禁身口故名色法。此直受得。遮制之法如结界处。亦如僧制未有事相故非色事。大乘所受是色心法非色心事。大乘通受防心戒故。今且论小。义既如是。人闻色法即便取之以为色事。所以不解。闻非色事便取以为非色心法亦是不解。文中初先说戒为色凡闻起诤。句别有五。一菩提王子说心为戒。若发恶心则便失戒。二如来对破说戒为色。以是色故其心虽在恶无记中犹名持戒。三王子请问。以何因缘名无作色。四如来为解。非异色因又复不作异色因果。以是因缘名无作色。此相微隐。三义释之。一约方便报色辨异。非异色因不同报色。方便之色依于报起而不同报故名异色。报色是彼异色家本名异色因。戒不同彼是以言非。道言不作异因果者明戒不同方便之色。方便之色依报色起。是向异色因家之果。无作异彼故言不作异色因果。二约方便因果辨异。方便之色别报称异。此异色中受戒方便名异色因。作戒之体名异色果。无作异彼故非异因不作异果。三约方便受持辨异。方便色中受戒名因。身口作持名异色果。无作异彼故非异因不作异果。不同此等名无作色。虽有三释。第二应善。受法相望以辨异故。此第四竟。五因圣说凡闻起诤。下说非色凡闻起诤。戒者即是遮止恶法正明非色。方便要期发得遮制心口之法未是事相故名非色。若不作恶是名持戒举持显受。下明弟子闻说起诤

第十四门明有心数无心数义。先辨诤相。毗昙法中宣说同时别有诸数。与心别体。相应造缘。成实法中唯说一心。随用先后分为多数。不说同时别有诸数。佛陀提婆所说亦尔。次辨道理。理则心法。亦得有数亦得无数。是义云何。分别有二。一粗细分别。心有三重。一者事识谓六识心。二者妄识谓七识心。三者真识谓八识心。彼事识中一向有数。诸心心法各各别故。真识之中一向无数。一切心法同一体故。故维摩云离一切数心如虚空。妄识之中粗有细无。是义云何。彼妄识中义别六重。如马鸣说。一无明住地二者业识。依前无明不觉妄念忽然而动动故名业。三者转识。依前业识心相渐粗转起外境。四者现识。依前转识所起妄境应现自心。五者智识。于前现识所现法中分别染净违顺等别。六相续识。向前智识所取之法漂鼓自心。心随妄境相乘不断名相续识。六中前四心想微细。不说心外别有诸数共心相应。故论说为不相应染。后二浮粗心与数别。共心相应。故论说为心相应染。此是第一粗细分别。二就事识随义分别。亦有亦无。唯一知性随用分多。非令心外别有诸数。故言非有。譬如一金作种种器。非是金外别有器体。随用别分。想行受等各守自相得言有数。如金与器非无差别。金器虽别时无先后。心法如是今此且就事识论之。事识之中义既如是。人闻不解偏执成诤。闻说心外无别诸数便言定一。闻说有数便言与心迢然别体若言定一。金时应当无其诸器。若言定别器应非金。心法一异准此可知

次释其文。文中初说心法相即凡闻起诤。就所说中文别有三。一明圣人报身五阴从无明生。二将圣类凡凡亦如是。三就凡中明其心法展转相心更无别数。今此所明十二因缘少异余处。异相如何。余处所辨过去因中彰无明行。今此具论无明爱取及与行有。又复余处现在果中说识名色六入触受。今此唯说受及名色。又复余处现在因中说爱取有。今此通说无明爱取及与行有。又复余处未来果中说生老死。此说受触识与六入。十二因缘齐通三世。隐显互论皆得无伤。文中先别。后总结之。别中先明过去之因。从无明生爱当知是爱即无明者。无明之心对境深着即名为爱。是故此爱即是无明。从爱生取当知是取即无明爱者。即前爱心取着境界即名为取。体性不殊是故此取即无明爱。从取生有是有即是无明等者。即前取心起业名有。是故此有即无明等。次论现果。从有生受即行有者。此名识支以之为受。识支即是现报之体。从因纳得故名为受。即前有支转为此受。是故此受即前行有。亦应即前无明爱等。就近言之。从爱因缘生名色者受增为名。所托精血说之为色。从受生于无明爱取有及行者。从现报受起后因也。从受因缘生受触识六入等者。从现报识转起未来生死果也。亦应宣说名色即受。乃至宣说六入即受。以下结中说受即于十二支故略而不论。上来别举。是故受支即十二缘总结无别。受心向前即于过去无明爱等。向后即于名色等故即十二支

下明如来说有心数凡闻起诤。就所说中具应明其过因现过现因当果。而此文中略无当果。辨过因中初言眼色明欲四法生眼识者。虽举四法为取恶欲为无明支。欲即无明正显其相。此是过去无明支也。欲性求时即名爱者过去爱也。爱缘取者过去取也。取缘业者过去行也。此言略少。若具应言取缘有者名之为业。次明现果。业缘识者生现识支。识缘名色起名色支。名色缘六入者起六入支。六入缘触起现触数名触。下依此触生诸心法。触缘想受起现受支通想说之。触缘爱者起现爱支。触缘信进定慧等法起现有之。如是等法因触而生。然非触者结明其异。由言非触故诸弟子执有别数

第十五门辨明五有六有之义。先辨诤相。有人一向宣说五有。有人说六所以成诤。次辨道理。五六不定。合则说五。开分说六。言其六者恶有三品。上生地狱。中生畜生。下生饿鬼。善亦有三。上善生天。中善生人。下生修罗。言其五者。依毗昙等修罗是鬼摄入鬼道。法念经中摄入鬼畜。罗睺修罗是师子儿摄入畜中。伽陀经鬼畜及天三趣所摄故但说五。义既如是不得偏执。文中初言说一有者总之唯是一有为果。或说二者善道恶道。三谓三界。四谓四生。五谓五趣。六谓六道。所言七者谓七识住。欲界人天合之为一。初禅为二。二禅为三。三禅为四。空处为五。识处为六。无所有处以为第七。此之七处心识乐安故名识住。问曰何故不名受住想行住等。释言住义理实齐通。识是心王是故偏说。问曰欲界有三恶道。何故不说。论言三恶有苦煎迫识不乐安是故不论。又问色界具有四禅。彼第四禅何故不说。论言彼处有无想定残害心识识不乐居故非识住。又四禅中有净居天趣入涅槃不欲久安故非识住。问曰无色有四空处。非想一地何故不说。论言非想有灭尽空亦残心识识不乐安故非识住。所言八者谓八福生。人中富贵即以为一。彼六欲天复以为六。初禅已上合之为一。故合有八。亦可地狱鬼畜修罗并人为五。及三界天合为八也。所言九者九众生居。欲界人天合之为一。初禅为二。二禅为三。三禅为四。无想天处以为第五。加四空处合以为九。问曰向前七识住中不说无想及非想天。今以何故说为生居。释言此处残害心识故非识住。不灭众生是故说为众生居矣。又问三恶何故不说。众生同厌为是不论。第四禅中除无想天余有八天。众生乐住何故不说。杂心释言彼四禅中有五净居乐求涅槃不欲久住。是故不说为众生居。余有福生福爱广果。或求净居或求无色或求涅槃不欲久住。是故不说为众生居。二十五有如上辨列。所说如是。弟子不解。随别异执。所以成诤

第十六门诤其五戒及与八戒具不具得。余对皆悉共诤一法。今此乃于二种法中别起二诤。拷实具论。五戒门中别有两诤。八戒亦尔。五中二者。依如毗昙五戒要须具受乃得。但就持中或持一者名为一分。持二戒者名为少分。持三持四名为多分。备持五戒名为具足。不畜妻者名为断淫。若依成实及大智论分受亦得。受一戒者名为一分。受二小分。受三受四名为多分。全受名具。加不畜妻名为断淫。今此偏举成实一诤。毗昙所立略而不举。道理如何。受五戒者亦有分得不分得义。是义云何。受五戒时先归三宝。归三宝时具得成体名为具得。如昔比丘三语得戒。后列戒相。问能时不别举别问。若堪持者答言能持。若不堪者答言不能。约就此时名不具得。义既如是。毗昙法中闻三归时全得戒体。便言戒相亦不分得。所以成诤成实法中闻列戒相随堪分受。谓体亦尔所以成诤。文中有三。一释摩男请问如来优婆塞义。如来为解。二摩男重请一分之义。如来为释。三人闻起诤。五戒之义广如别章。此应具论。就八戒中准依余论具有两诤。毗昙所说八戒必须一日一夜具受乃得不得增减。成实所说且言日夜多少皆得。今此偏举毗昙一诤。成实不论。道理如何。八戒斋中亦有具得不具得义。若论受斋局唯在于一日一夜名为具得。一日一夜是斋分故。若直受戒时分不定名不具得。义既如是。毗昙法中闻斋日夜谓戒亦然所以成诤。成实法中闻戒不定谓斋亦尔所以成诤。文中迦旃初举己说问佛是非。次佛为辨。或一日等但得戒善不名得斋。一日一夜方成斋故。下明弟子不解起诤。八戒之义广如别章。此应具论

第十七门犯重失戒不失戒义。先辨诤相。有人宣说犯重失戒有言不失。次辨道理。亦失不失。失其受力故名为失。不失受体名为不失。犹如燋种无力有体。义既如是。不须偏执。文中初明犯重之过凡闻起诤。后说犯重但名污道凡闻起诤。罗汉比丘名毕竟到。见道已上名为示道。示犹见也。七方便人名为受道。外凡造过名为污道

第十八门明二乘人有得作佛不作佛义。先辨诤相。诤相可知。次须论理。亦作不作。守小不作舍小便作。义既两兼。不得偏执。文先明作。言一乘者乘行一也。言一道者道法一也。言一行者是乘体也。言一缘者道法体也。法是行缘故名为缘。据大摄小。其唯一故皆当作佛。愚闻不解。便言定作。如来复说须陀洹等得小涅槃。愚人不解。便言二乘定不作佛

第十九门辨明佛性即离之义。先辨诤相。有人宣说五阴之相即是佛性。有人说离。次须论理。理则佛性不即不离。实不同相故言不即。相实是性非令相外名为不离。义既如是。不得偏执。文中但明说性不即凡闻起诤。不离一边略而不举。若欲更辨不异后门为是。不说。明不即中有四复次。一说性六事人谓定离。二说性如空人谓定离。三说性如似宅中宝藏人谓定离。四说犯禁及阐提等皆有佛性人谓定离

第二十门明阐提等有性无性。先辨诤相。有人宣说众生定有。有言定无所以成诤。次须论理。理则不定。生死身中即无佛果名为不有。不无佛因说为不无。又如下说四种佛性。一阐提人有不善阴及理佛性名为不无。无善五阴及佛果性名为不有。文中有三。一佛说有性我说众生即佛性等法说明有。次喻后合。二如我为王说箜篌下佛说性无。先喻后合。三明众生闻之不解作种种说或有或无

第二十一门有十方佛无十方佛。先辨诤相。有人闻说一国。无有二佛俱出。便言一向无十方佛。有人宣说有十方佛。次辨道理。初非后是。文中初说一国无二人闻起诤。后佛宣说有十方佛不彰起诤。以当理故

上来别答。如是诤论是佛境界是第三段结叹显深令人仰推

若人于是生疑心下是第四段明其愚智取舍得失令人舍着

若人生疑犹能摧坏无量烦恼如须弥山舍着得也。举劣显胜。疑有二种。一是邪见前方便疑。唯增情惑不能破结。二是解心前方便疑。能破决定邪见烦恼。今据后门是故说疑能破烦恼如须弥矣。疑者犹能摧坏无量邪执烦恼如须弥山况正见者。若于是中生决定下取着失也。于中决定是名执着总显其过

迦叶白下问答广辨。有九问答。前八问答明断善根。后一问答明生善根。就前八中初二问答明执着义。次四问答明疑惑义。后二问答明疑及着断善根义就明着中初一问答明执着相后一问答明着善恶。文显可知

就明疑中迦叶初言如是人者本自不疑云何说言不坏疑网乘前为问。佛前说言执着之人不坏疑网故名不善故今问之。此人由来于法不疑云何不坏。下佛答之。夫不疑者于正义中心不决了即是疑也

第二迦叶乘言重问。若执着人于法不疑即名疑者。有人决谓须陀洹人不堕恶道。是人亦应名著名疑。下佛答之。是可名定不得名疑对问略释。下广释之。初先明疑。后显不疑。就明就中初三譬喻广显疑相。一切众生先见二物。后更生疑结成疑义。何以下释。于二物中心不决了所以生疑。我亦不下翻对前疑以显不疑我于须陀无二说故彼人不疑

第三迦叶乘言重问。如佛所说要先现见然后疑者牒佛前言。有人未见亦复生疑总翻佛语。下别显之。何等征问。所谓涅槃就法以辨。一切众生从本以来不见涅槃亦复生疑明不由见。譬如有人路值浊水喻说以显。下佛答之。先解其法。后释其喻。法中涅槃即是苦断非涅槃者即是苦也直立道理。一切生下明人皆由先见生疑非不先见。见有二种总以标举。见苦非苦列其二名。苦非苦者即饥渴等辨其二相。下明众生因见生疑。见已生疑当有毕竟离是苦不正明生疑。是故下结。下释其喻。先牒问辞总非不然。何以下释。是人先于余处见水有浅有深。是故于此未到之处而生疑心。不知为当同于昔浅为同旧深第四迦叶乘言重问。是人先见深浅水时已不生疑。何故于今而复生疑。下佛答之。本未行处心不决了是故生疑

下二问答明疑及着断善根中初一问答出疑着人。是谁问也。断善答也后一问答正明断善。世尊何人能断善根乘前请问。下佛答之。初先略答。离是四下随别广答。若有深见无因果下总以结之。略中总明黠慧利根善能分别简利异钝。远离友等简恶异善。良以不能近友闻法正思修行故断善根。如是能断总以结之

广中有四。一谤无施。二谤无父母。三谤无因果。四谤无圣人。谤无施中有六复次。一明无施若有施者。现行施时舍财为因。未来还应得无财果。二施者受者财物无常故无布施。三施主施人色力寿命安乐辨才。受者受已作善恶业。所作善恶施主不得。明知色力寿命等果施者不得。于中初法次喻后合。下结无施。四施物无记明无善果。五施者是意无见无对。非是色法云何可施。六施佛像命过父母。无受施者云何有报

第二谤无父母之中有六复次。初直设难。若言父母是众生因则应常生。以不常生明知父母非众生因。二若言父母是众生因因无缺少。所生之子一人应具男女二根。然无具者明知非因。三眼见众生不似父母明知非因。四众生父母同于四无明知非因。先举四无。次明父母同彼四无。下就设难。若言是因父母死时子不必死明知非因。五有化生及湿生等明知父母非众生因。六举诸鸟得身各异明知非因

第三谤无因果之中有三复次。一现见世人行善有苦造恶得乐明无果报。二谬引圣说。有人修善堕坠三涂。有人行恶上生人天。明无果报。三举圣人所说不定证无果报

第四谤无圣人之中有九复次。一有烦恼时道不能坏。无烦恼时道则无用。明无圣人。先总说无。何以故下破有成无。于中先明有烦恼时道不能破。后明无时道无所用。下牒结无

二人不斋得明知无道。于中三句。一明十二因缘斋等。二八正下征道同之。三而今下以不齐得证成无道。此是第二

三圣人犹有共凡夫法证无圣道。谓饮食等

四以圣人犹有烦恼业苦不尽明无圣人。于中先明圣有烦恼圣人受乐明有贪也亦骂辱等明有嗔也。复有嫉妒及憍慢等受于苦乐明圣有苦。作善恶等明圣有业。是因缘下结无圣人。若有道下难无圣道

五道性多怜不应待人修习方得。待修方得明无圣道。于中有五。一明圣人法多怜愍。二何故下明怜由道。三若道性怜下征破须修。四如其无下难道非怜。五结无圣道。此是第五

六不同四大令人齐得明无圣道。于中初明四大斋等。若有圣下征道同大。然今已下不同证无

七就涅槃一异征无。文别有六。一就一设难若诸圣人有一涅槃当知无圣正征令无。何以下释。常法无得无可取舍故无圣人。二就多设难。若诸圣人涅槃多者道则无常正征显过。何以下释可数法故。三重就一设难。涅槃若一一人得时应一切得。四重就多设难。涅槃若多则是有边云何名常。第五双就一多设难。若涅槃一解脱是多如盖是一牙。舌是多是义不然双牒以非。何故下释。随一一人所得各异非一切得则是有边。边则无常云何得名为涅槃乎。涅槃若无谁为圣人。六是故下结无圣人。此是第七

八道不假缘应一切得不一切得明无圣道。于中初明道非缘得。何故一切不作圣人约法征人。若一切下以不齐得结无圣道

九难破道因成无圣道。于中先举二种道因。谓闻及思。修即是道故不举修。下就设难。先难有因。此二因缘若有因生所从因缘复从谁生。如是展转有无穷过。下难无因。若此二事不从因生一切众生何故不得

前略次广。下总结之。若有深见无因无果能断信等正结断善。下辩其相。非愚非天非三恶趣破僧亦尔类以显之

前八问答明其断善。下一问答明其生善。迦叶先问何时当生。下佛答中初对前问正明生时。或初入狱怖畏时生。或出地狱罪尽时生。善有三下彰彼善根得生所由。由过去善所生当果不断故生。先举三善。次列三名。过去善因虽复灭尽果报未就是故不名断过去果彰所不断。由此不断当善得生。断三世因名断善者举其所断显所不断。义如上释。断其过去生现之义名断过因。现不起故不能生后名断现因。后不生故复不生后名断来因。唯断此因不断过家当来之果。故善得生

自下第三答上问中今欲问阴而我无智如是甚深唯佛境界下明如来善知诸阴以答其问。此是如来随自意语不与他共。是故迦叶乃至精进菩萨不知。唯佛境界。辨此何为。为彰如来智德渊深所知独绝。令彼阐提于佛义法仰推成信。文中有二。一明佛能知佛性五阴。二我终不与世间净下明佛能知法相五阴。知佛性阴为化阐提令生信解。知法相阴为化阐提令修治行。佛性阴中要唯有三。一不善五阴。二善五阴。三佛果五阴。细分有七。始从常没乃至第七水陆俱行。法相阴中粗分有二。一凡。二圣。细分有四。一知染果。二知染因。三知净果。四知净因。具知此等名知诸阴佛性阴中文别有六。一约四答辨性体状。二约三语彰性分齐。三约一语明性周尽。四约七语明说性意。五重约如来随自意语明性渊深。唯佛独知余人不测去人取谤。六约虚空辨性同异遣人耶执。此六段中初二一对为化阐提令生信解。于中初段广就四答辨性体状化令生解。后段明性唯佛独知乃至十住菩萨不了。令彼阐提自舍己执仰推成信。次二一对为化阐提令起愿求。于中初段明阴界入摄性周尽示其求处。后段明佛说性之意为令阐提知佛说意舍过趣求。后二一对为化阐提令离邪过。于中初段重约如来随自意语明其佛性唯佛独知余人不测诚劝舍谤。故下文中明说定有及与定无悉皆名为谤佛法僧令人舍远。后段约空辨性同异令舍邪解

就初段中先问后答。问中迦叶乘前所明断善根义。即就其人以问佛性。令断善人于己身性生信解故。于中有二。一就时征问。性为过去未来现在。二如来亦说佛性六下就人征问。问一阐提佛性有无。此佛别答。宣审记知。前中初言若断三因名断善根牒佛前言。断善根人即有佛性牒佛上语。下就征问。如是佛性为过为现为是未来为遍三世进退审定。下就设难。若过征前。云何名常以理征责。谢往之法何得称常。佛性亦常当知非过以理验非。以理测寻未敢专决是以言亦。若未牒前。云何名常以理征责。现无当有何得名常。何故已下遮佛无常成非未来。如来若说性是无常故在未来。无常不定何故佛说一切众生必定当得此反征也。若必定得云何言断顺以难之。定得之法体即常住。云何说言阐提现断令在未来。但令未来即是现断故为此征。若现牒前。复云何常以理征责。现起之法本无今有已有还无故不名常。何故已下遮佛无常成非现在。若言无常迁转不定何故复言常而可见

上来第一就时征问。自下第二就人征问难彼阐提有无之义。于中先举如来所说六种佛性。若断善下就人设难。前中如来说性有六牒佛上言。佛前第七功德之中说斯六种故今牒之。下列其名。名如上释。此明因性故隐我乐。义如上解。下文具就五种六种七种佛性明阐提人有无之义。今但举六。言略故尔。就人难中若断善根有佛性者不名断善执有征无。若无佛性云何复言一切皆有执无征有。若言佛性亦有亦断云何说常双牒以征。有而可断便同有为云何说常

下佛答之。先立四答。后就辨性。明四答中先举。次列下辨其相。定中初问次辨后结。辨中五句前二世俗因果法定。后三出世因果法定。分别答中初问次辨。于中且就四谛辨之。是名下结。随问答中初问次辨。四句两对。一说无常。二随问以答。三说法烧。四随问以答。一门略而不辨。十力已下就前四答以辨佛性。文别有四。第一就其分别答门明性体状。二就置答破离偏着。三迦叶白云何名因亦过去下重显向前分别中义。四众生佛性非有无下。重显向前置答中义。就初段中要分为二。一就如来后身佛性以答前问二就九住已还佛性收答前问。细分有四。一就如来后身佛性明阐提人有无之义答上后问。二如来佛性非过去下就彼如来后身佛性明是三世非三世义答上初问。三九住下明九地下所有佛性有是三世非三世义答上初问。乘前便故先以论之。四是五种下就九地下所有佛性明阐提人有无之义答上后问

初中有三。一明如来佛性体状。二明后身佛性体状。三双就前二明阐提人有无之义。初中十力四无畏等彰其性体。则有七事辨其性义。先举次列。不还名常自在曰我。永安称乐。无垢曰净。离妄名真。不虚曰实。体顺称善。准后此中更应立一名曰全见。文略不辨。是名下结。第二段中亦应先出后身性体。然后辨义。体略不论。今唯辨义。后身有六标别举数。十地学穷名曰后身。理性一味上下义齐。行性差殊前后不等。今论行性。十地劣佛故但说六。次列其名。常净真实及善同前。我之与乐理实齐有。随义隐显。在因不说。何故如是。此如上释。我是佛义在因不论。乐者是其涅槃之义。据相断结名为涅槃因中亦有。乐随涅槃亦通在因。故上文说菩萨涅槃有乐有净。就实诸佛不生烦恼方名涅槃。乐随涅槃唯在佛果。今从后义故不说乐。后身菩萨于己佛性十分见一故名少见。是名下结。第三段中如汝先问断善根人有佛性者牒其问辞。亦有如来后身佛性明其有也。是二佛性障未来故得名为无彰其无义。定得名有释成有义。无义已显不劳更释。是名下结。此初段竟第二段中文别有四。一局明如来果德佛性非是过去未来现在证实返望。由来无相知复约何宣说三世。故非过去未来现在。二局明后身已上佛性现在未来。经释可知。三就佛佛性始终通论。地前名因。初地已上随分克证通名为果。如来未得阿耨菩提佛性因故亦过等者地前佛性随妄流转故是过去未来现在。果则不尔有是三世非三世者初地已上不同地前一向三世故言不尔。十地已还是其三世渐次证故。至佛则非义如前解。四就后身菩萨佛性始终通论。亦解行前名为性因。地上名果。后身性因亦过去等。义如前释。果亦如是同前因也。此第二竟

第三段中三阶论之。九地一阶。六七八地为第二阶。五地至初为第三阶。就初阶中九住有六标别举数。次列其名。五种如前。言可见者先已闻知。不久眼见故曰可见。下就此性约时分别。地前名因。地上名果因是三世。果亦如是。第二阶中八住至六佛性五事标别举数。次列其名。真实净善可见同前。略不说常。何故而然。此亦是其隐显言耳。如上文说常者是其法身之义。佛及后身眼见佛性显法成身。常随法身故彼有之。九地菩萨虽未眼见闻见明了。知如来藏是己自体摄法成身。常随法身彼亦有之。八地已还未得同彼故不说常。若尔何故得说善净及与真实。解亦有以。依上文说净是法义。法宝义宽。上下同依。净随法说故通不局。问曰若净义通上下皆名净者。如地经说前之七地行于染净菩萨之道不名纯净。今此何故一向名净。彼据行修前之七地功用未息有净不净。今依此经净是法义。法义该通。净亦如之。真之与实是实谛义。实谛理通。真实随之义无所局。善者是其圣道之义。五地已前波若未明顺忍不极细慢犹在名善不善。六地已上波若深明细慢已尽故唯名善。今论八地至六地性。故虽无常而有净善及与真实。下就此性约时分别。地前名因。地上名果。因是三世。果亦如之。义同前释。第三阶中五地至初佛性五事标别举数。次列其名。净及真实可见同前。善不善者。于此位中渐修圣道随分离过故名为善。破有未穷细慢未尽故名不善。亦应宣说因是过去未来现在果亦如是。类前可知。略不具论。此第三竟

自下第四就九地还所有佛性明阐提人有无之义。先牒前性。是五种者牒前两种五种佛性。六种性者牒前九地六种佛性。后身六种此不须。牒前第二中已举后身六种佛性明阐提人有无义竟。此何须牒。七种佛性亦不须牒当是翻者乘势举来不须所以。亦同向者后身六种。下就所牒明阐提人有无之义。当得名有。略不说无

上来第一就分别答明性体状。自下第二就其置答破离取着。于中初先略就置答破定有无。迦叶言下问答重显。迦叶先问。我闻不答乃名置答今者何缘答名置答。下佛为释。我亦不说置而不答乃说置答。反其所闻。如是置下正为辨释。有二总举。遮止莫着列其二名。谓遮取无莫听著有。下释如是无劳异解。以是下结

自下第三重显向前分别中义。于中有四。一显前三世非三世义。二须陀斯陀断少已下显上阐提有无之义。三未来云何能生善下重显后段。四若言五阴是佛性下重显初段。就初段中迦叶先问。云何因是过现未来。果亦过去现在未来。亦非过去现在未来。佛答有二。一正对前问明因三世果通是非。二从一切无明已下辨出法体。前中初言五阴二种总以标举。因果列名。此如上释。地前名因。地上名果。下就此二约时分异。因是过去现在未来地前之性。果亦过去现在未来谓从初地乃至十地。亦非过去现在未来所谓佛果。并如上释

下出体中先法后喻。法中一切无明等结悉是佛性辨出向前三世因体。何以下释。此虽烦恼佛性因故名为佛性。此初地上佛性家因名佛性因。从无明等得善五阴是名佛性辨出向前三世果体。从善五阴获得菩提辨出向前非三世果

喻中有二。一约血乳生出血乳。明不善阴生善五阴。是故我先说生佛性如杂血乳辨法同喻。是从不善生善阴故。佛于此经先明三乘。同性之中说生佛性。如杂血者已下约喻显法。血者即是无明行等约喻以显不善五阴。乳即善阴约喻以显善五阴也

二约精血成身之喻明从不善及善五阴得果五阴。于中初法次喻后合。法中是故我说从恼及善五阴得菩提者。从善不善二种五阴得佛果故。佛说从恼及善五阴得菩提也。喻中初言如众生身喻菩提果。皆从精血喻从烦恼及善五阴而得果也。合文可知上来第一显前三世非三世义

自下第二显前阐提有无之义。先明现无。迦叶白下彰其当有。前中先举五种善性从须陀洹乃至如来为彰阐提现在所无。故偏举善。此中所辨与上少异。上明三乘同性之中说声闻性如出血乳。缘觉如酪。菩萨之人如生熟苏。佛如醍醐。今此所说开始合终皆得无伤。问曰诸处多以缘觉共声闻合。今有何义缘觉之人与菩萨人合为熟苏。释言缘觉其心狭劣与声闻同。是故余处与声闻合。今以缘觉一向无退与菩萨同。故与菩萨同为熟苏。下约此性明阐提人现障故无。初法次喻后合下结

明当有中迦叶先问。五六七等若未来有现在便无。云何说言断善有性。佛答有二。一望果阴明一阐提未来断惑得了了见故说为有。二是故下望善五阴明一阐提未来佛性还生善根故说为有。前中初喻有过去业现在得果。喻明阐提富得名有。阐提未来修善五阴名过去业。得果五阴名得果报。有未来下喻明阐提现在未得。有未来业喻阐提人当起善阴。以未生故终不生果喻阐提人过去未终善五阴故现在未得佛果五阴。下合显法。有现烦恼明非现得合未来业以不生生故终不生果。若无烦恼一切应当了了见性明阐提人当见名有。合有过业现得受报

自下第二以生当善说性为有。是断善人以现烦恼能断善根明现不生。未来性力还生善根彰生在当。此第二竟

自下第三重显向前后段中义。迦叶初问。未来云何能生善根。下佛答之。先立二喻。未来灯日虽复未生亦能破闇是一喻也。现虽未生当能破之。未来之生能生众生是二喻也。十二缘中未来生支能生众生。次合后结

自下第四重显向前初段中义。初迦叶问。向前宣说三种五阴以为佛性若阴是性性便是内。云何说言性非内外。次佛答之。先呵失意。我先不说众生佛性为中道者为之辨释。如来前于师子品中广解佛性为中道义故今指之。此明佛性虽就阴论非令同阴。故非内外名为中道。迦叶下复彰已问意。我不失意幡对前呵。直以众生于中不解故发斯问对佛说中彰已问意。如来下复显已说意。众生不解即是中道就妄显真。不解之情体是中道或解不解明诸众生迷悟不等。为对不解显已说意。所以举之。我为众生得开解故说非内外明已语意。何以下释。先征后辨。文有七番。一就五阴宣说中道。第二就其十二入法。第三就其内外道法。四就佛色心。五就内思及与闻法。六就檀行及余五度。七就譬喻。文别可知。七中第一第二第七就不善阴以明中道。第三第五及第六番就善五阴以明中道。第四一番就佛五阴以明中道。于一一中皆先举边后翻说中。上来四段合为第三重显向前分别中义

自下第四重显向前置答中义。于中有二。一明佛性非有非无。二有人问下约理破情。亦得名为破情显理。成前遮止莫着之义。初中复二。一约法报二种佛性明非有无。二亦有无下偏就报佛一种佛性明非有无。法报两性云何非有而复非无。泛解有二。一就体说之。法佛之性本有法体。如矿中金名为非无。报佛之性本无法体。但有方便可生之义。如子中树说为非有。此之一义如下文说。二约对辨。如此中说法佛之性是可见有。不同虚空不可见有故名非有。报佛之性是可生无。不同兔角不可生无故曰非无。法报两性有无如是直就一种。报佛性中云何非有复言非无。如下文释因中无果名为非有。有可生义说为非无。以有斯义今并论之。就初段中性非有无略以标举。所以下释。是故非有非无总结。释中先问。下对辨之。先明非有明法佛性不同虚空不可见有故曰非有。不说无法以为非有。佛性虽有非如虚空略以标举。何以下释。虚空虽以无量方便不可得见彰空异性。佛性可见辨性异空。是故下结。良以虚空说无为有故有叵见。法佛之性说有为有故有可见。下明非无。明报佛性不同兔角不可生无故曰非无。非说有法以为非无。佛性虽无不同兔角略以标举。何以下释。龟毛兔角虽以方便不可得生彰无异性。佛性可生辨性异无。是故下结。良以兔角是毕竟无故无叵生彼报佛性是其有时未生之无故无可生。是故佛性非有非无总以结之

自下第二约就一种报佛佛性明非有无。亦有亦无略以标举。云何下释。有无合下约就有无明非有无。是故下结。上来就性明非有无。自下第二约理破情。亦得名为破情显理成前遮止莫着之义。破却定无成前遮止。破遣定有成上莫着。文中有三。一约树子相生因果破定有无。二约乳酪转变因果破定有无。三约盐喻缘助因果破定有无。就初段中有两问答初一问答明有无义。后一问答明生不生。前中先就树喻假问。是种子中有果无耶下佛答之。先辨喻相后约显性。喻中应答亦有亦无略以标举。何以下释。以是下结。所以下释。时节有异释前无也。其体是一释前有也。子果性一故言有果。合中佛性亦复如是合前有无。若言已下合时有异其体是一。先合体一。若言生中别有佛性是义不然非他异说。何以故下正明体一。真妄和合集成众生。即此众生可作佛义名为佛性。是故佛性即是众生。又如世间麦芽麦茎乃至麦果同一麦性。麦性即是芽茎叶等。佛因佛果同一佛性。佛性即是众生等也。由即是故凡佛性一。直以时异有净不净合前时异

下次明其生不生义。先问后答。军喻无法。次就乳酪破定有无。于中初先正就乳酪破定有无。后约四缘生眼识等显酪有无。前中先问。后佛答之。先辨喻相。后约显性。喻中有四。一当相正破。二以相生前后征破。三举因类破。四举果类破。初中有二。一破定有无。说有执着对破此有成上莫着。言无虚妄对破此无成上遮止。二离是下显正道理。离是二事应定说言亦有亦无略显道理。何故下释。先释有义。初问次辨后结可知。后释无义。初问后辨。乳白酪黄名为色异。乳甘酪酢名为味异。乳冷酪热名为性异。文略不道治异生异。文相可知

自下第二以其相生前后征破。句别有五。一以理正征。若乳有酪酪即是乳其性是一。何因缘故乳在先出酪不先生。二难破有缘。若有因缘令乳先生酪不前出。一切世人何故不说。三以无因缘责酪不先。若无因缘令乳先生。以何义故酪不先出。四以酪不先责其次第。若酪不先谁作次第。乳酪生苏乃至醍醐。五是故下结。是异非

自下第三举因类破。水草是其生乳之因举之类破。乳中有酪。句别有四。一举执直非。若有说言乳有酪性故能生酪水无酪性不能生酪是义不然。二何以下释。先征后解。水草亦有对问略释。者何以下征问重解。三举执重非。若言乳有水草无者是名虚妄。前非其法。此非其见。四何以下释。心不平等故名虚妄。此第三竟

自下第四举果类破。酪是乳果举之类乳。句别有四。一举果正类。若言乳中定有酪者酪中亦应定有乳性。二责其因缘。若俱相有何因缘故乳中生酪酪不出乳。三以无因缘证酪本无。若无因缘使彼酪果不出于乳。酪自不出。是即酪中无其乳性。酪既无乳。乳亦无酪。当知是酪本无今有。四是故下结。是异非。是乳生酪无酪性故智者当知乳非有酪亦非无酪

上来辨喻。下约显性。前四段中约初显之。先破定执。是乳有酪名为执着。是乳无酪名虚妄故。如来经中说定有性是名执着。无名虚妄。下显正义。应说佛性亦有亦无

上来正辨乳酪有无。下约四缘生识显之。于中先明四缘生识。后显乳酪。前中初言四缘生识眼色明欲举其喻事。次就此事明非有无。是眼识性非眼色等明其非有。从和合生彰其非无。如是眼识本无今有已有还无。是故当知无有本性。释前非有非无易知。略而不解

下约前喻以显乳酪于中有三。一显正义。二破邪说。三举说证成。乳中酪性亦复如是是显正也。如前眼识非有非无。若有说下是破邪也。邪说云何立有之。家以略不从。水中出生证乳定有故今破之。先牒直非。何以故下释以显非。释相如何。明乳与酪因果各别。水为乳因。乳为酪因。何得以水不能生酪。便言乳中定有酪性。文中有四。初一切法异因异果泛立道理。二亦非下约就前理释去邪执。亦非一因生一切果是故一水不能生于乳酪二果。非一切果从一因生是故乳酪二种之果。不唯从于一水而生。三如从下举彼四缘生识不同类显乳酪。如前四事生于眼识不可从此生耳识等类水生乳不得生酪。四离方便下举彼苏酪生因不同类显乳酪。云何类乎。苏酪因别此不生彼。乳酪因别。生乳之水不生于酪。文中初明苏酪因别。离于方便乳中得酪酪因异苏。所谓离于人功方便。酪出生苏不得如是苏因异酪。下约此别破其偏执。智者不可见离方便从乳得酪。酪出生苏亦应如是离方便得。不可见乳从水草生。令酪亦尔从水草生。上来第二破其邪说

是故义下是第三段举说证成。是前乳酪同彼四缘所生眼识本无今有已有还无。故我说言因生法有因灭法无

自下第三约就盐喻破定有无。初先略破。若言已下因救广破。就初略中先举盐喻。下就破执。若非碱物先有碱性世人何故更求盐耶破他先有。下彰先无。于中先明碱非先有以余缘故而得碱也明非自有

广中先举邪人救义。次非不然。何以故下随救广破。前中即用盐喻为法。于中初法次喻后合。法中若言不碱之物皆有碱性微故不知。由此微性盐能令碱正立有义。若本无下破无成有。喻中种子自有四大喻不碱物先有碱性。缘外增长喻盐令碱。合喻可知

是义不然总非前说。下随救辞广以破之。于中先就盐喻以破。后就种子四大以破。前中初言不碱之物先有碱性牒其救辞。盐亦应有微不碱性举盐类微。是盐若有如是二下破盐二性。恐人被微立盐二性故须遮破。于中初举。何缘下微。是故知下结盐无二。如盐以下以盐无二类破余物。盐中既无微不碱性。不碱物中云何有碱

下次破其种子之喻。先牒直非。何以故下释以显非。三句破之。一以先后次第微破。二以外类内。三以内类外。次第说故。是初破也。若使子中即有芽茎乃至果实便是一时。何故子先乃至果后。子先果后次第说故明知先无

不从已下是第二句以外类内。明外四大从缘集生先无自性。内亦如是。何得先有。于中为显四大缘生泛举诸法类以显之。不从方便乳中得酪简酪异余。谓不假于人工方便生苏乃至一切诸法皆不如是非方便得明余异酪。四大如是明外四大类同诸法皆方便得。彼外四大从缘增长先无自性。内亦如是何得先有

若说已下是第三句以内类外破他救义。他人救言从外四大增内四大故内有性。不见从内增外四大故外无性。故今举内类同于外明内四大亦有不藉外大增长应先无性。即事显之。如尸利沙果先无形质。见昂星时果则出生足长五寸。如是果者实不因于外四大增。亦应同外先无自性

自下第二就三种语辨性分齐。于中先辨三种之语。后约显性。前中初先举昔所说。云何下释释随自中先问。次辨。后总结之。辨中有二。一就比丘明随意语。二就如来。前中六句。一诸比丘问舍利弗受身之因。二舍利反呵不为宣说。三比丘自说。四共诣佛所向佛说之。五舍利弗问佛是非。六如来普印。就佛明中舍利初问。如来后辨。如是下结。释随他中初问。次辨。后总结之。辨中随彼长者意解用以显已名随他意。于中有三。一芭吒难佛。二如来将彼用以自解。三说罪怖之彼闻惶恐悔过求救。初段可知

第二段中句别有四。一如来反定。幻幻之人名幻人耶彼答言善。二如来反问。知旃陀不彼答言知。三如来反征。汝知旃陀是旃陀不彼答言非。四如来将彼类显自己。明已知幻而非幻人第三段中句别有四。第一如来说罪怖之。彼闻得罪求欲与财。何故如是。波斯匿王先有成教。有犯佛者罚财入官。彼闻得罪谓招此坐故求与财。二如来为辨。罪非失财谓堕三恶。彼闻惶怖请佛救免。三佛为说法彼闻得果忏谢归依。四如来赞叹

随自他中初问次辨后结可知

下约辨性。十住少见名随他意。先辨后释。说一切生皆有佛性不断不灭终得菩提名随自意。说一切生皆有佛性恼覆不见彼此同知名随自意

自下第三就其一语明阴界入摄性周尽。先论一语。后约辨性。前中如来或为一法说无量法总以标举。为彰一法摄法周尽说无量法同归一法。如经中下三番显之。中约辨性。文显可知

自下第四约就七语辨明宣说佛性所为。为令众生不放逸故。先辨七语。后约论性。前中如来说有七语总以标举。次列七名。因中说果名为因语果中说因名为果语。说现在法望前为果望后为因名因果语。立喻显法名为喻语。假举世间不应有事而显诸法名不应语。随世流布说男女等名世流布语。有所宣说令他众生从已化意名如意语。虽举七语为约后一明已为生说性之意

下广释之。解因语中初问。次释。后总结之。果语亦然。因果语中先问次辨。如经中说众生现在六入触因略以标举。众生现存六入及触是过去世业行家果。现所造业复为来因名因果语。下重显之。名过去业果释为果语。如来亦说为未来业是业因缘得未来果释为因语。是名结之。次三可知。如意语中先问次辨。辨中五句。一呵毁禁令人持戒称已化意名如意语。此就凡夫。二赞须陀令人生善称已化意名如意语。此就二乘。三赞菩萨令人发心称已化意名如意语。此就菩萨此三约人。四说三恶令人修善此宣其事。五说一切烧及与无我令人厌离此彰其理。此二就法

下约论性。说诸众生悉有佛性令人趣求舍离放逸称已化意名如意语

依宝性论。为五义故说生有性。一为众生于自身中生怯弱心谓已无性绝分不求。二为轻慢余众生故说生有性。彼当作佛云何可轻。故法华中不轻菩萨若见四众高声唱言汝当作佛我不轻汝。以知众生有佛性故。三为妄执我众生故宣说佛性不同情取。故胜鬘云如来藏者非我众生非命非人。四为执着虚妄法故宣说佛性不同所取。五为诽谤真如来藏谓是空寂断灭无法。故说佛性是真是实常乐我净。今此为令不放逸者同彼初义

自下第五重就向前随自意语。彰性渊深唯佛独知余人不测诫劝舍谤。如来复有随自意语总以标举。下别显之。于中有二。第一略明佛性有无诫劝舍着二如恒河下广辨有无诫劝舍着。略中有四。一明性有无。二举人不解诫劝舍着。三重辨有无。四重诫舍着

就初段中先就如来明性有无。后类余人。佛中先举有无二门。次列后辨。如有无下类显余法。如前所辨佛性有无如是一切善不善等恶法悉无善法皆有。是名下结。乃至阐提佛性有无亦如是者降佛已下始从后身乃至阐提佛性有无。类上可知故言如是。所言异者善根之人望上有恶而无善法。望下有善而无恶法。阐提一向有恶无善

自下第二明前所说众生不解诫劝舍着。我虽说性众生不解明凡不解。佛如是等随自意语举佛独知成凡不解。如是语者后身不解况于二乘。其余菩萨彰圣不解。我往一时在耆阇下举浅况深成圣不解

自下第三重辨有无。或有佛性一阐提有善根无者。有不善性无其善性。佛性缘起为不善阴。故不善阴名为佛性。阐提有此。或有佛性善根人有阐提无者。初地已上名善根人。通则种性已上菩萨斯名善人。彼有善性无不善性。或有佛性二人俱有俱有理性。或性二俱无俱无果性

自下第四重诫舍着。若解如是四句义者不应难言定有定无正劝舍着。若言众生悉有性不举佛独知遮其偏着。如来如是随自意下牒佛独知呵其偏着。备前四义。众生云何一向作解广中有二。一就人明性。二是七人不修身戒心慧已下诫劝舍着。前中有三。一举喻相约之显法。二如恒河中七种众生不离水下辨其喻意约之显法。三迦叶言若有因则有果下于前义中有难解者问答重显

就初段中先举喻相。后约显法。喻中先举次列后辨。法中初言涅槃河中有七众生。合初总前师子中宣说生死以为恒河。此说涅槃经法为河生死为水。经中所说从凡至佛为七众生。皆是水性喻不离性

次列其名。三门分别。一就三乘别行分别。二就三乘共行分别。三就三乘通行分别

别行七者。声闻缘觉菩萨及佛各有七人。声闻七者。大位分之外凡常没。五停心后乃至暖顶名出已没。忍心及与世第一法名出已住。苦忍已去名为观方。斯陀行去名观已行。那含果后名行已住。罗汉名为水陆俱行。缘觉七人相同声闻。唯有最后独悟为异。菩萨七者阐提常没。始学发心名出已没善趣名住。信不坏故。习种观方。性种名为观方已行。故华严中名为十行。解行名为行已复住。初地已上水陆俱行。佛七人者外凡常没。善趣名为出已还没。种性已上说之为住。初地观方。二地已去名观已行。八地已上名行已住。如来名为水陆俱行

共行七中三门分别。一开小合大以论七人。于中前六与向声闻七人之中初六人同。罗汉辟支菩萨及佛通皆名为水陆俱行。二开大合小。凡夫二乘悉名常没。常没凡夫二乘地中余之六种与向如来七人之中后六人同。三大小俱开。此义如前。师子品说外凡常没。五停至顶名出已没。忍世第一名出已住。须陀乃至阿罗汉果名观四方。辟支名为观方已行。菩萨名为行已复住。如来名为水陆俱行

通行七者。一一人中皆通三乘。今此偏就通行论七。但下文中初二后一彰通隐别。中间四人偏举小乘略不论大

下辨其相。于中具列十八种人就之论七。言十八者。一是阐提。二是信善求有凡夫。三是信善求出凡夫。四五停心。五别相念处。六十二缘观。此即是其总相念处。七暖。八顶。九忍。十世第一法。十一见道。十二须陀。十三斯陀。十四那含。十五罗汉。十六辟支。十七菩萨。十八是佛。此十八中初之一人直名常没。常没三涂。其第二人义有两兼。望其三有名为常没。望其三涂名出已没。次有四人义皆两兼。一遇恶友暂出还没。还没三有。二遇善友坚住不退即为住人。次有两人皆具三义。一遇恶友暂出还没。二遇善友坚住不退即为住人。三学观四谛名为观方。其次两人义有两兼。一名为住。二学观谛名为观方。次有两人直名观方。从此已后皆有住义。隐而不彰。次一名为观方已行。次一名为行已复住。后四名为水陆俱行

就初人中先牒。次辨。后以喻帖。辨中有二。一明其人没之所以。二恶住者则有六下广显没相。前中初明闻法诽谤无信故没。远善友下于善不修无行故没。前无信中言有人者谓阐提人。闻涅槃等举所谤法。于中有三。一闻说如来。二一切生下闻说佛性。三一阐提下闻说菩提。下彰其谤。闻已不信即作是念明其心谤。念涅槃经是外道书作是言等明其口谤。下无行中明其不能近友闻法思惟修习。文显可知

上来第一明没所以

下显没相。文别有四。一略举六事。二是名下就之辨没。初先结前。何故下释。三所言下广释前六。四是人具足如上六下广显前没。是人具足如上六事能断善等明造恶因。是因缘下明没恶道。是人身口心业重下没不能出。何以下释。心不生善明无治因。无量佛出不闻不见明离治缘。是故下结。上来广辨。如恒河下举喻以帖

涅槃义记卷第九奥书损失可惜可惜涅槃义记卷第十

        隋净影寺沙门释慧远述

自下第二明其信善求有凡夫。此有两义。一常没义。常没三有。二有暂出还没之义。还没三涂。文中先明常没之义。复有常没非一阐提简前起后。何者下辨。是名下结。下明还没。句别有四。一明四善得恶果报初举。次列。后总结之。二就其人明出没义。若修是四名没已出出已还没略以标举。下广释之。先释初没。次释其出。后解还没。文皆可知三引说证成。偈中前二造业故没。后二彰其烦恼故没。四举喻以帖。先举其喻。如上二下将法以帖。如上偈中烦恼及业二种之人如彼大鱼暂出还没故言如是

自下第三明其信善求出凡夫。此有两义。一遇恶友暂出还没。二遇善友出已即住。文中有二。一总辨其人。二是人不具如是五下就之开分退住两义

前中有四。初言有人乐着三有是名为没牒前起后。出从彼来是故牒之。二得闻下对没辨出。三何缘下释显出义。离恶生善故名为出。先问次辨后结可知。四是人虽下明出不具。于中初明信心不具。是人虽信亦不具足总以标举。下别显之有七复次。一就佛涅槃明信不具。直信涅槃常乐我净不信如来二单就涅槃明信不具。彼说有二。一者有为。二者无为。无为涅槃常乐我净。有为无常无我乐净。三就佛性明信不具。虽信佛性是众生有不信一切众生有之。四就信体以明不具但信不具。五约起因明信不具。但从闻生不从思生。六约圣道明信不具。但信有道不信得者。七约三宝因果法相明信不具。于中先举邪正两信。次列后辨。下就正信以彰不具。虽信三宝不信同体。虽信因果不信得者。故名不具第二明其戒不具成不具信。戒亦不具牒前起后总明不具。下别显之。有七复次。一约起因明戒不具。名前信心以为戒因。第二唯有威仪之戒无其戒戒名戒不具。定道无作从威仪戒生。从戒生戒故名戒戒。于中初问。后对辨之。先举次列后辨下结。有有作戒无无作戒名戒不具。始修名作。成名无作。于中初举次列后辨。是故下结。四虽持于身口之戒杂于邪命名戒不具。五有求戒而无舍戒名戒不具。无舍相戒名无舍戒。第六有其求有之戒无随道戒名戒不具。七善恶通信心无简别名戒不具。于中先举善恶二戒。次列后释。下辨后结

第三明其闻不具足。信戒不具闻亦不具牒前起后总明不具。下别显之。有四复次。第一约就十二部经明闻不具。但信六部不信六部且言六部理实论之。于十二中随所不信皆名不具。二虽受六部不能读诵为他解说名闻不具三虽受六部但为论义为胜他等名闻不具。第四近友闻法思惟如说修行乃至解脱不具此等名闻不具。于中先举具足之闻。是人无下对之以显闻不具足。前中初言我说闻具总以标举。云何下别。先问后辨。于中先明亲近善友。是诸师等于是人下明闻正法。得智慧已能善思下系念思惟。得正义已身心寂静明如说行。于中六句。次第可知下对前义明闻不具。相亦可识

第四明其施不具足。不具足三施亦不具牒前起后总明不具。下别显之。有三复次。第一约就财法二施以明不具。财施求有法施不尽故名不具。先举次列后辨下结。第二约就凡圣二施以彰不具。于中先举次列解释后辨下结。第三约就受法之人明施不具。受已所信即便供养。受所不信则不供养。故名不具

第五明其慧不具足。不具上四慧亦不具牒前起后总明不具。下别显之。有五复次。第一不能分别如来常与无常名慧不具。二于此经中宣说如来即解脱等不能分别名慧不具。三于此经中宣说梵行即如来等不能分别名慧不具。四不能分别性即如来如来即是不共法等名慧不具。五不能分别四真谛等名慧不具

上来第一总辨其人。下就其人辨退彰住。不具有二牒前开后。不具上来信等五事。增善增恶列其二名。下辨其相。先明增恶暂出还没。于中先明增恶之行。谁是已下出增恶人。如大鱼下举喻以牒。前中初问次辨后结。辨中有二。一增恶因。三业不净故增已下明受恶果。因中有三。一明其人痴慢自高。是人不见已不具足是其痴也。自言具等是慢高也。二是故亲下亲近恶友故增恶法。于中初明亲近恶友。既近已下明闻邪法。闻已喜下随闻生着。起于慢下习行恶法。起慢烦恼。多行造业。三因放逸下亲近在家故增恶法。初近在家。次乐闻说在家之事离出家法。以是因下正明增恶。以是因缘增长恶法明起烦恼。身等不净明造恶业上增恶因。受果可知。前增恶行。下出其人。谁是征问。谓提婆等对问以辨。于中四众次第列之

下明增善出已即住。于中有四。一增善行。二出其人。三释住义。四引说证成。就初段中先明近友。近善友故乐咨未闻明闻正法。受已思者明能思惟善思惟已能如法下明依法行。如法住故增长善法结成增善。增善法故终不复没是名为住结成住义。次出其人。谁是问也。谓舍利弗等对问以辨。于中四众次第列之。舍利弗等是阿罗汉水陆俱行。今以何故说之为住。有人释言舍利弗等于昔经中水陆俱行。于今经中但名为住。此义不然。云何不然。于今经中正应宣说菩萨之人为大乘住。何故宣说声闻为住。又小乘中四果之人。于大乘中未到贤首。云何已名大乘中住。但舍利等于小乘中具一切行。是故其人得名为住。亦名观方。乃至亦得名为俱行。今说其人本因为住。非得果后方名为住。良以此等已证圣果彰住义显故就指之。如是等下总结为住。次释住义。先问后辨。辨中初法次喻后合。初言乐见善光明者进善故住。以是缘下不退故住。喻合可知。下引证中初之两偈小乘中住。若人分别明修正解。至心求果彰其所欣。若能呵有明其所厌。名住总结。后之四偈大乘中住。于中初二宿善故住。后二明其现修故住。于中明其近友闻法思惟修行。行中初因。后明得果

自下第四明五停心人。此具两义。一遇恶友暂出还没。二值善友出已即住。然今文中总举其人。略不辨其退住两义。于中四句。一牒前起后总举其过。智不具足是牒前也。前说信等五行不具据后以牒。是故偏言智不具耳。凡有五事是举过也。贪欲嗔痴着我觉观是其五事。二是人知下为治前过亲近善友。三如是下善友观过为说对治。愚痴多者为说因缘。文略不辨。与其所说十二缘同故略不举。着我分析十八界者。杂心论中说观六界。所谓地水火风空识。前初德中亦同彼说。此观十八皆得破我。此义广释如五度章。四明其人闻已受行

自下第五次明别相念处之人。是人亦具退住两义。文略不辨。于中初言行已次得四念处者牒前起后。身受心法列其四名。别观色阴为身念处。别观受阴为受念处识阴为心。想行为法。故名别相。此义广释如道品章

次第复得十二缘者是其第六总相念处。余经论中约就五阴以明总念。总观五缘为空无我法念处故。是中约就十二缘说观十二缘皆空无我亦是总相法念处观。就一切法皆悉得作总念处观非止五阴。此亦具有退住两义。文略不说

自下第七明暖心人。暖等四心如别章释此应具论。暖心人中具有三义。一遇恶友出已还没二遇善友坚住不退。三学观四谛即名观方。文中初先牒前生后。迦叶白下问答广显。如是等人终不断下就之开分退住等别。初段可知

应中有三。一简别异通彰其分齐。二释名辨体。第三明其得人多少。初中迦叶先问起发。问中执通以非其别。一切众生悉有暖法立通非别。迦叶前闻观因缘后方始得暖。是故立通非其别矣。何以故下辨通破别。先征后辨。如佛所说三种和合名为众生总举昔说。寿暖及识别举昔说。此说火大以之为暖。四大之中火大持故身不淤坏。以此功强故偏举之。暖即是色。识即是心。寿非色心。三聚成生故昔说此合为众生。若从是义一切先有明暖宽通。云有说言因善友生征破别义下佛答之。明今所说是局非通。四番释之。一约人辨释。如汝所问至一阐提皆悉有之彰通异别。我今所说要因方便简别异通。以是义下结非先说。是故已下结非齐有。二约界辨释。如是暖法是色界法彰别非通。若言一切众生有下破通成别。欲界无下结非齐有。三约内道外道辨释。色界虽有非一切有彰别非通何以下释。内有外无故非一切。以是下结。四就内外约境辨释。一切外道观六行简外异内。外道断结攀上厌下如断欲结。先观欲界一切有漏为苦为粗或复为障。观初禅地为止为妙或复为出名为六行。始观之时六行俱观。终成之时于上于下各观一行不具观六。我诸弟子具足十六彰内异外。言十六者。苦下有四谓苦无常空与无我。集下有四因集有缘。灭下有四尽止妙出。道下有四道如迹乘。是十六下结非齐有

自下第二释名辨体。迦叶初问。所言暖法云何名暖问其名义。为自性暖为他故暖问其体性。下佛答中先答后问却答初问。细分有四。一对上后问辨定暖体。二迦叶下问答重显。三如汝问下对上初问释其名义。四迦叶白下问答重显。初中性暖非因他者暖体是慧。非是同时更有暖体因之说暖。问曰下说暖者即是圣道火相。此则因他。云何说言非因他暖。释言暖法用慧为体。智慧之体因他圣火名之为暖。非因他暖方名为暖名非因他

第二段中迦叶先问。问由何生。由佛向言自性是暖未出其性故问令出。问相如何。迦叶先闻马师无信便无暖法疑暖是信故复问之。如来先说马师无暖举彼如来昔时总言。何以故下举佛解词。无信故无当知已下约彼昔言执信为暖。下佛答之。信非是暖翻其所执。何以故下释通昔语因信生暖。马师无信暖法不生故说其无。夫暖是慧正出暖体。何以下释。观四谛故总约四谛证暖是慧。是故名下约对别行证暖是慧。是谛观故名十六行。行故是慧

第三段中先牒问辞。下为辨释。圣道火相故名为暖。于中初法次喻后合

第四段中迦叶先问明暖是有不应能与圣道作相。是有法者是三有法。是有为者为作有果。是法报。得色界五阴故名有者。约果显因明其体是三有法也。是因缘故名有为者能与色界五阴作因。造作彼阴故名有为。云何能为无漏道相结征佛语。佛答如是如汝说者印前暖心有为有法。如是暖下翻上不能与道作相。于中初法次喻后合。是故下结。法中明暖虽复是有还能破有故为道相。喻中如人喻修行者。马喻暖心。人依行进故名为乘。味着暖心名为亦爱。厌患诸有策修暖心说为亦策。合中初言暖心亦尔合前马也。爱故受生合前亦爱。厌故观行合上亦策。问曰此暖为当自爱为更有法爱着此暖。若暖自爱马应自爱非人爱马。若更有法爱着此暖。爱着之心自可受生无关暖事。何由举此成暖有为。释言上地味禅烦恼爱着暖心非暖自爱。然彼暖心为爱润故上界受身故名有为。又问策者为暖自策为更有法策于暖心。若暖自策马应自打。若更有法策于暖心。彼能策者可能与彼圣道作相。暖心非策安能与彼圣道作相。释言暖前方便之心厌畏生死修起暖心名之为策。非暖自策。由彼策暖令暖向圣。是故名为圣道作相。结文可知

上来第二释名辨体。下次明其得人多少。得暖法人七十三种总以标举。次辨其相。有人从来未断烦恼此具缚人初修入暖即以为一。问曰暖心其必依于未来禅起。彼禅起时应断烦恼。云何得有具缚入暖。释言未必未来定心皆断烦恼。有人修定初得住心是未来禅。未依此定作六行观故不断结。依此住心修起暖法名为具缚。依未来禅作六行观断欲界结。始从一品乃至九品即为九人。通前为十。进修等智断初禅结至无所有。地地之中各有九品为六十三。通前合为七十三人。非想一地无上可攀等智不断所以不论。文中初言欲界具十就欲总举。是人具恼十中第一。断一至九复为九人。通前十也。如欲初禅至无所有亦复如是明后六十三种人别。是名下结

上来第二广辨其相。下就其人分其退住观方等别。如是等人则不复能断善根等明其住义。如杂心中暖等唯不断灭善根作一阐提犹作五逆犯四重禁。此中乃至五逆四重亦皆不作不作故住。是人二下明其还没观方之义。先举次列后辨可知

自下第八明顶法人。此人亦具退住观方三种之义。文略不辨。文中初言观方即顶乘前起后。退穷名顶。前学观方。彼观增长即名为顶。虽是五阴辨其体性。与此相应定共无作即为色阴。心王识阴。受数受阴。想数想阴。其余心法名为行阴。亦缘四谛故名观方释观方义。观谛同前是以言亦。亦可同后

自下第九明忍法人。此人具有住及观方二种之义。文略不辨。文中初言顶次得忍乘前起后。安住名忍。亦五阴性亦缘四谛解观方义

自下第十明世第一。是人亦具住及观方。文略不论。次得第一乘前起后。世间中极名世第一。次辨其性。经文不同。有经说言性是五阴义如上解。复有经言性是五根所谓信进念定慧等。慧为正主。余伴助之。亦缘四谛辨观方义。世第一法唯有一念。余论宣说于菩谛下唯缘一行。今以何故说缘四谛。释言谛观有其二种。一者行修现在所起。二者得修未来所成。世第一法现在所修唯观一行。未来傍于四谛增明。今就得修名缘四谛

下第十一明其见谛十五心人。断见谛惑有十六心八忍八智。言八忍者。观欲四谛有四法忍。观上四谛有四比忍。言八智者观欲四谛有四法智。观上四谛有四比智。此十六中前十五心名为见道。今次辨之。此人唯有观方一义。住义通后显故不论。文中初先明苦法忍是人次第得苦法忍乘前起后忍性是慧辨其体性。何故前来皆言五阴此独摄慧。理实相似。以见道中见法明白慧用增强故偏说之。缘一谛者明观方义。于苦谛下趣缘一行。若爱行人或观苦行或无常行。见行之人或观空行或无我行。问曰向前世第一法现缘一行之中就其未来得修名缘四谛。此苦法忍何故不然而言缘一。释言有以。世第一法犹在世间宽容之限。于未来世傍修宽多故言缘四。苦忍等心是峻疾道傍修狭少。未来但于同谛四行而得增明不及余谛故言缘一。乃至见断举余忍智

下第十二明须陀洹。彼第十六道比智心是须陀体。此人唯有一观方义。文中有三。一略标举。二举辨释。三结法同喻。初中言得须陀果者标举所得。是名第四遍观方者辨法同喻。前暖等中虽学观方而未成就。苦忍等心观方成就而未周遍。至此周遍故言遍观。方即四谛辨其所观

广中迦叶初问起发。如来次答。迦叶白佛先得道故名须陀下于前义中有难解者问答重显。前中迦叶具为四问。一问须陀断惑多少。如佛先说须陀所断犹如纵广四十里水在如一渧举佛昔言。此中云何说断三结举多征少。如来前于现病品中说断三结得须陀洹故今征之。下列三名。非因见因是戒取也。乌鸡戒等非真灭因妄谓是因。是故名为非因见因。余二可知。二问须陀遍观方义。三问其名。何因缘故名须陀洹。四问须陀喻错鱼义。下佛依问次第辨释

释初问中文别有三。一当相正解。二是三对下约治以论。三有众生下随化以释。就初段中先开二门重为一门。亦摄一切须陀所断为第二门。下广释之。先解初重。于中先喻。如王游等举其喻事。何以下释。重故偏说。是三如是合以显法。如世人王重故偏说。何缘下释。先问后解。一切众生常所起者多行故重。如病数发名为重病。微难识者沉隐故重。如病难别名为重病。是三难断力强故重。此解初门。能为一切烦恼因者释上后门。云何能为一切恼因。就十使中五见及疑见道时尽与其断名。贪嗔痴慢见断不尽不与断称。就所断中三本三随。身见是本边见是随。戒取是本见取是随。疑使是本邪见是随。以是义故宣说三结为一切因

自下第二约治辨释。以是三结是戒定慧三行大怨故偏说之。此义如彼毗婆沙说。身见是其戒学大怨。由见神常苦乐不变不畏业果纵情作罪。片从此义说为戒怨。戒取定怨。取戒为道妨修禅定离欲道故。人取欲界散善为道妨修上地禅定法故。疑为慧怨。于法疑惑防正智故

自下第三随化以释。有诸众生闻须陀洹断无量结则生退心故但说三

次答第二。先牒问词。下对辨释。观获四事总以标举。次列下辨。解初可知。释第二中悉能呵责内外恼者。于十使中迷理生者名内烦恼。缘事生者名外烦恼。后二可知

次答第三。先牒正解。迦叶言下问答重显。是须陀洹凡有二下乘辨须陀洹利钝差别。前中先牒。后对辨释。须陀名义具应有三。一名修习无漏。二名逆流。三名抵债抵三涂债。文中但就前二释之。须名无漏陀洹修习是初义也。须名流等第二义也。须者名流此释须义。下释陀洹。陀洹名逆。先举二流。顺逆列名。以逆流下正显陀洹。下重显中迦叶先问。若从是义何缘斯陀至阿罗汉不名须陀执通征别。若从上来修习无漏逆生死义名须陀者。斯陀含等齐有是义。何故不悉名须陀洹。偏名初果为须陀洹。佛答有二。一正对前问偏明须陀一种名字有通有局。二是人亦名须陀洹下乘辨一切贤圣名字明有通局。前中先明须陀名通。一切众生名有二下彰其局义。通中须陀乃至诸佛亦名须陀正显通义。若斯陀含乃至诸佛无须陀洹云何得名斯陀至佛反解通义。是义云何。若斯陀含不修无漏不逆生死云何名薄。乃至诸佛不修无漏不逆生死云何名觉。局中明唯初果之人名须陀洹余皆不得。于中初先简圣异凡。生名有二凡以标举。客旧列名。下就辨异。凡有世名彰凡异圣既得道已更为立名须陀洹辨圣异凡。以先得下简初异后。以先得故名须陀洹彰初异后。以后得故名斯陀者明后异初。上来直辨须陀一名通局之义。下次泛论一切圣名通局之义。文但彰通略不显局。句别有四。初言是人亦名须陀乃至佛者明其初果具一切名。二流有二下明余贤圣具一切名。为明余圣皆悉得名须陀洹故须立二流。先举次列。有为功德名为解脱。无为功德说为涅槃。一切圣人皆具此二亦名须陀就人分别。具前二流逆于生死。是故一切悉名须陀。非但一切得名须陀亦名斯陀乃至名佛。三须陀者名菩萨下就上初段释初果人具一切名。于中但解名佛菩萨。余类可知略而不辨。须陀恒者亦名菩萨略以标举。何以下释。其菩萨者名道众生。以求道故名道众生。故今释之。明小乘中菩提之道即是罗汉。尽无生智须陀求此故名菩萨。须陀洹人亦名为觉略以标举。何以下释。正觉见道断烦恼者正观谛理断烦恼也。觉因果者谓能觉知苦果集因灭果道因。正觉共道不共道者所观圣行望阴是共望谛不共。于四谛下行义各别故名不共。前三谛下一一诸行皆通五阴故名为共。以有此义故须陀洹得名为佛。四斯陀下就前第二释余贤圣具一切名。于中偏明小乘贤圣具佛菩萨二种名字。大具小名略而不辨。故今文中说言斯陀乃至罗汉亦复如是。亦如须陀名佛菩萨

上来第二问答重显。自下第三乘明须陀利钝差别须陀有二总以标举。利钝列名。下辨其相。先辨钝人约生辨之。须陀极钝天上人中七返受生方得涅槃。少极二生。故今说言人天七返举其极钝。复有五种明余五阶。下别列之。六返至二是其五也。利人现在获得须陀至阿罗汉辨其利人。问曰一返何故不论。释言须陀具有八品。七返至一即为七品。现般为八。八中七返至二定钝。现般定利。文中具辨一返不定。有人利根应得现般。以诸因缘现在不得经生乃得此则是利。有人钝根现在世中勤修不得经生乃得此即是钝。利钝不定故隐不论。下次答其第四句问。先牒问词。下对辨释。[魚*昔]鱼有四就喻举数。骨细轻等就喻列名。下约显法。衔物坚中初约喻显法。如魔王下引昔证成

前问次答。自下第三于前义中有难解者问答重显。重显向前释名中义有两问答。就初问中迦叶初先进退两定。为先得道名须陀洹。为初果故名须陀洹。下就设难。若先得道名须陀洹。苦法忍时何故不得名须陀洹。若以初果名须陀洹。外道之人先断烦恼至无所有得那含时何故不名为须陀洹。此举超越那含为难。云何超越。斯陀那含并有超义。有人凡时依世净禅作六行观断欲界结五品尽来入见谛道。至第十六道比智时犹故名为次第须陀。若断六七八品尽来入见谛道。至第十六道比智时不作须陀。超证第二斯陀含果。斯陀含人所断烦恼先已断故。断欲结尽至无所有后入见道。至第十六道比智时不作须陀及斯陀含。超证第三阿那含果。那含所断先已尽故。超越如是。云何作难。若次第人至第十六道比智时以初果故名须陀者。彼超越人先断欲尽至无所有入见谛道。至第十六道比智时亦初得果。何故不得名须陀洹而名那含。下佛答之。以初果故名须陀洹释去初难。良以初果名须陀故。苦法忍时未是初果。是故不得名须陀洹。如汝问下释去后难。先牒门辞。下对辨释。释意如何。明初果人名须陀洹超越那含超证第三非初果人。是故不得名须陀洹。文中初言以初果故名须陀洹正答其问。是人尔时具足八智及十六行辨初果相。四法四比是其八智。苦无常等是十六行。是人但于现在道下为一行观。未来傍于十六增明名具十六。迦叶下复重执为难。越超那含亦具八智具十六行。何故不名为须陀洹。下佛对之。明唯须陀得为初果故名须陀。彼证第三非是初果不名须陀。文中偏对次第那含辨释须陀为初果义。超越那含一向不论。彼非常行之次第故。于中文二。一就行修明初异后。二须陀洹缘四谛下约对境明初异后。前中初先明初异后。阿那含人则不如是彰后异初。是故下结。初异后中明须陀洹舍凡入圣舍向得果故名初果。于中先分十六行别。次分八智。后约此二解释须陀为初果义。初中先分有漏十六以为二种。有二举数。共与不共列其二名。是义云何。彼十六行约界上下有三十二。于一一行重观名共单观不共。为辨此义须明暖等四心差别。于彼上下三十二行止观来去多心观察名之为暖。多观未明名暖方便。多观分明名暖成就。于一一行止观来去以渐略之。乃至于彼一一行下各一心观名之为顶。二心观前名为方便。后一心观名为成就。此一心观与后忍中初观相似。如增上忍似第一法。于一一行各一心观名忍初心。更复从后向前略之。乃至最后唯缘欲界苦下一行名之为忍。欲界苦下二行观前名忍方便一行名成。于前忍心末后所缘重一心观名世第一

问曰善行多应弥好何故须略。如迦旃延阿毗昙云譬如富人欲适他土患其财多转以易钱。犹嫌钱重转以易金。犹患金重以金转易大价宝珠持至他方。行者如是。欲入出道患彼有漏多行烦开故渐略之。此四阶中初二重观名共十六。后二单观名为丕共。下分无漏有二举数。向得列名。于彼见道十五心中所观名向。道比智时所观名得。道比智心单缘一行云何得有十六行别。释言彼现虽缘一行未来傍于十六增明。故得果时亦具十六。次论八智。有二举数。向得列名。向果八者。见谛道中唯有四法及三比智。何处有八。向有近远。见谛道前四现忍心学观四谛名为远向。此十智中一等智摄。见谛道中复有七智合为八耳。问曰向前十六行中向果十六不摄有漏。向果智中何义通摄。释言向前十六行中有漏无漏两处别论。故向果中不摄有漏。此八智中有漏无漏不别宣说故通摄之。何故不别。彼见道前唯一等智更无异义故不别说。得果八者。得果之时舍见道中无漏七智更起新得。得彼七智通以为果。并道比智合为八矣。前远向中有漏等智得果不舍亦无新得不摄为果故但有八。下约前二解释须陀为初果义。是须陀人舍共十六得不共十六。舍向八智得果八智。故名初果。此文略小。若具应言舍共十六得不共十六。舍有漏十六。得无漏十六。舍向十六得果十六。舍向八智得果八智。准初类后中间可知故略不举。舍共十六得不共者。不行名舍。非得断舍。舍向八智得果八者。向果八中初一等智入圣道时不行名舍。与前舍共十六相似非得断舍。余之七智证初果时得断名舍。前一等智舍而不得。后七无漏舍而更得。通道比智合为八耳

上来一段明初异后。阿那含人则不如是彰后异初。次第那含不如须陀舍共十六得不共等。是故不得名为初果。非初果故不名须陀。是故下结。就始结之。是须陀人是初果故偏名须陀。文相如是。又更分别前三果人各有二向。一者共向。二者不共向。见道之心通向三果名为共。向。次第之人入见谛道向须陀洹。先断欲结六品尽者入见谛道向斯陀含。欲结尽者入见谛道向阿那含。故名共向。暖等四心偏向须陀。须陀果后进断欲结乃至第六无碍道来偏向斯陀。斯陀果后进断欲结乃至第九无碍道来偏向那含。名不共向一切莫不皆修暖等趣入见道。何故见道偏名共向。暖等四心不名共向偏向须陀。释言见道印证超越斯陀那含。先所修得结尽无为故通向之。暖等四心未能而证。是故不能向余二果偏向须陀。义既如是。彼次第人具依须陀。共与不共二种向后而得圣果故名须陀。彼超越人唯从须陀不共向后而得圣果。不从须陀共向得果。是故不得名须陀洹。彼超越人入见谛道但得名为超越家向。不得名为须陀向故。前约行修明初异后

下约境论须陀洹人缘于四谛明初异后。那含缘一彰后异初。于四谛中趣缘一种断欲界结不同须陀。此亦辨其次第那含不论超越。彼非常行之次第故。是故下结

上来广辨。以是义下结法同喻

下第十三明观已行。初略标举。系心修行辨其行相。如彼[魚*昔]鱼彰法同喻

下第十四明行已住。先略标举。行已后住谓阿那含以为一门。得食已住复为一门。下广辨之。先广初门。劫广后门前中有三。一开合辨相。二欲色众生有二业下依前广释。三迦叶白中般利下于前义中有难解者问答重显。初中有四。一通就上下宣说二种。二就色界已上说五。三通就上下说七。四偏就无色说二说三。就初段中有二举数。下辨可知

第二段中先举后列。言中般者论释不同。依如成实舍欲界身向色界去中间受身而得般故名为中般。彼论不立中阴身故。此及毗昙舍欲上升中阴身中而得般故名为中般。无别受生受身般者。余处名为生般那含。与行无行同在一处。随义分异。异相如何。经论不同。凡有三别。依如毗昙舍欲上升至色界中随在何处最初受身。于此身中初生得般名为生般。即此生中有利根人观察十六圣行得般名为行般。又复观察苦集及道有为之行而得般故亦名行般。即此生中有钝根人修习有漏等智断结。不观十六圣行断结。如此得般名无行般。又设观谛但观灭谛无为胜法方能得般名无行般。此后二人皆悉尽寿方始得般不同初人。此三人中生般最利。行般为次。无行最钝。若依成实生般同前最为利根。无行为次。是人自知定得涅槃不勤行道尽寿得般名无行般。行般最钝。精勤行道尽寿得般名为行般。此经所说受身般者同成实中行般那含。精勤行道尽寿得般名受身般。此中行般与成实中生般相似。精勤行道不至寿终而得涅槃名为行般。此中无行与成实同不勤行道尽寿得般名无行般。上流般者色界已上随在何处二生已后而得般者名上流般。于中细分乃有四种。一上流般。次第受身至广果天而得涅槃。二者乐慧。至广果天不得涅槃生五净居。三者乐定。至广果天不得涅槃生无色界。四不定般。未至广果中间得般。此四通说以为上流

自下第三通就上下说七。先说六种。前五如上。加一现般。就现般中细分有二。一直现般。现依凡身修得那含终至涅槃。二转世现般圣人身上经生已后修得那含终至涅槃。于中有四。一须陀果上经生得般。二斯陀行中经生得般。三斯陀果上经生得般。四那含行中经生得般。是故转世四处而来。旧言转世三处来者其言谬耳。次增说七。于前六上加无色般。此无色般与上流中乐定何别而须别论。释言不同。彼乐定者从广果去。此无色般从欲界去经生无色。故须别论。如成实中宣说十一。现般为一。转世为二。中般为三。生中三人通前为六。乐定乐慧通前为八。信脱见到及与身证通前十一。前八可知。于前八中钝名信脱。利名见到。得灭尽定名为身证。彼十一中略无上流及不定般

自下第四偏就无色说二说三。此与向前无色界般有何差别而须别论。释言不同。前无色般从欲界去初生无色。此下所论是无色中经生已后上行般者。与前不同故须别论。文中初先辨明其果。复有二下辨定其因。果中初言行般涅槃复有二种标别举数。无色界中上行得般故名行般。非前五中第三行般。五中行般下文别释。此上行般准因有三。文举两边且言二耳。二身四身别其名字。受二名利受四名钝辨释其相。是义云何。无色界中有四空处。那含于中终不重生。若从欲界生四空处一身得般名无色般。若从初禅乃至广果生四空处一身得般名上流中乐定那含。此前二人生无色界一身不得二身已后方始得般名上行般。于中具论受二身者名之为利。三身名中。四身名钝。今举两边中略不说。因中有其两种二法。初一二法是中品因。后一二法是前利钝两品家因。是义云何。具精进定受于二身。互无一边受于三身。进定并无方受四身前二法中先举后列。勤修观解名为精进。定心难现名不自在。懈怠有定翻前可知。后二法中先举后列

上来第一开合辨相。自下第二依前广释。但解向前五种那含。先解中般文别有三。一约业辨中先举二业。作受列名。造缘初起名为作业。为爱所润能生后果名受生业。下约显中中涅槃者有作无受故中涅槃。二约处辨中舍欲界身未至色界以利根故于中涅槃。三约心辨中先举四心。次列四名。初言非学非无学者是受生心受中阴生。言学心者是无漏因。言无学者是无漏果。后言非学非无学者是命终心舍中阴身。如杂心说罗汉报生心及与威仪意。随顺心灭故趣向般涅槃。下约此四明中涅槃。先问次辨。四中后二是涅槃心。初二即非。无学之心证有余灭。非学无学入无余灭。是故后二名涅槃心。是故下结

下次解受身。初先正辨。迦叶言下问答重显。前中初先辨其二业。次明其人依叶受身。后明其人依身得般。此与成实行般相似。下重显之。先问后答。文显可知

次解行般。常修行道并以有为三昧之力能断烦恼不尽受命入于涅槃名为行般。此与成实生般相似

次释无行。是人懈怠解无行义三昧力故尽寿得般名无行般

次解上流。于中先明退上生下。流有二下从下向上。先举二流。次列其名。退上善法而生下结名烦恼流。又断下结生。上烦恼亦得名为烦恼流也治道渐增名为道流。下约道流解上流义。初至四禅亦复如是明广果下上流之义。复有二下明广果上上流之义。于中有三。一略分二人。二如是二人一乐已下辨因显果。三是名下结别其相。初段可知

第二段中文复有四。一明乐定乐慧之别。先辨所乐。后显所入。二明薰禅不薰禅异。如是二人。一者修禅有五阶。差二者不修略以标举。下重辨其五阶修相。先问次列。后约论果。是义云何。此人修得四禅定已先薰四禅。先入四禅无漏心中。次入四禅有漏心中。后入四禅无漏心中。是一一中多心相续以渐略之。乃至一一各别二心名为薰禅。方便道成各别一心名薰禅成。成中合有五重往来。有十五心。十心无漏。五心有漏。次薰三禅。次二。次初。作法同前。此五番中初番为下。第二为中。第三为上。第四上中。第五上上。第四禅中修下便罢生无烦天。此名少广。至中便止生无热天。至上便休生善何见。至上中者生善见天。至上上者生阿迦尼吒。此名无小。若不退者欲界命终径生五净。以下三禅爱结尽故所以不生。四禅有爱是故往生。如此生者不名上流。若有退者于下三禅乃至广果后还断结重修薰禅方生净居。如此往者方名上流。此第二竟。三重明乐定乐慧之相。一乐论义是乐慧也。二乐寂静是乐定也。乐静无色乐论五净约因显果。四重明薰禅不薰禅异。与前何别而复更论。前是初薰。此是退后生上重薰。复二总举。薰与不薰列其二名。薰义如前。薰入五净不薰无色约因显果。尽寿而般明无中灭

上来第二辩因显果。自下第三结别其相。是名上流是总结也。下彰其别。欲入无色则不能得五阶修禅。若修薰禅则呵无色为是定别

上来第二依前广释。自下第三有难解者问答重显。重显向前中般那含。初问次答。后明中般上中下别。问中初言中涅槃者则是利根何不现在入涅槃者就时征问。何故欲界有中涅槃色界则无就处征问下佛答之。先答初问明有三缘现在不得。一四大羸劣不能修道故不现得。二资具少故不现得。初先正辨。我昔已下引事证成。无量众生应入已下总以结之。三有众生乐多教化故不现得。如汝问下答其后问。先牒后释。有四复次。一约内外因缘分别。欲界烦恼因缘有二总以标举。内外列名。使性为内。尘境为外。以欲界中有外可厌故有中般。上界无彼外缘可厌故无中般。二约色欲二爱分别。先举次列。着外五欲资生之具名为欲爱。爱着女色名为色爱。欲界地中有此可厌故有中般。上界无此故无中般。三约悭等粗过分别。欲界有其悭贪嗔妒无惭愧等可以厌恶故有中般。上界无此故无中般。第四约其心性分别。欲界性健故有中般。得四果故。上界不尔故无中般

前问次答。下次明其上中下别。先举次列下辨可知

前广那含。下次广上得食已住。喻以错鱼得食已住牒举前喻。是人亦尔约之显法。云何下释。有六复次。一上界受身故名已住。二不受欲界一切趣身故名为住。此二就果。下四就因。三断无量结少在名住。四终不造共凡夫事故名为住。五自无畏令他无畏故名为住。自无罪恶故自无畏。不恼害他故他不畏。六能远离色欲二爱及悭贪等故名为住

下次明其罗汉辟支菩萨及佛以为俱行到彼岸义。到彼岸者喻罗汉等略举其人。下辨其相。如龟俱行牒举上喻。下约显法。于中先明护根如龟。先问次辨。是故下结。下明其人似龟俱行。水喻世间陆喻出世出其行处。下明俱行。能观烦恼如龟行水。到于彼岸如龟行陆。是故下结

前分七人。下明有性。先举其喻。后约显法。如恒河中七种众生虽有龟鱼不离于水是举其喻。不离水性非是不离河中之水。河中之水喻于生死。众生水性喻于佛性。为是须别。下约显法。如是微妙大涅槃中合恒河也。阐提至佛合七众生。虽有异名合前虽有龟鱼之名。不离佛性合不离水。下重辨之。是七众生总牒七人。若善法者别牒信善求有凡夫。并牒信善求出凡夫。若不善者别牒最初常没阐提。若方便道别牒五停至世第一七方便人。若解脱道别牒苦忍乃至须陀。若次第道别牒斯陀乃至那含。若因别牒罗汉辟支及上菩萨。是佛因故。若果牒佛。亦可若因牒三乘因。若果牒彼三乘之果。悉是佛性就之论理。是名如来随自意语结以显深

自下第三于前义中有难解者问答重显。重显向前到彼岸义。前言罗汉乃至诸佛到于彼岸。其岸未彰故下辨之。到复未显故下须释。先论彼岸。后彰其到。前中迦叶初问起发。于中先问大乘彼岸。有因有果无因无果泛立道理。涅槃名果常故无因举佛上言。如来于前师子品中广明涅槃是果无因。故今举之。下就设难。若无因者云何名果。为此难者欲使如来辨因显果令人修证。下复问其小乘彼岸。亦名沙门举小乘因。名沙门果举小乘果。下问云何。征问欲使如来具辨令人修证。下佛答之先对初问明大涅槃有因故果非全无因。是中为明涅槃有因。乘举一切类以显之。先举七果。次列七名。下广辨果约之显因。就第四门余残果中得第三身延年益寿是其果体。下明远因。复言即是延年益寿。谓衣食等能延年者能益寿者说为远因不论寿体。第七门中先辨果体。即是涅槃离一切恼。下约辨因。三番论之。一总相分别。一切善法是涅槃因。二近远分别。先举次列后辨可知。三生了分别。于中先举世间生了。次约论出。出世亦有生了二因。下辨其相。三解脱门三十七品为一切恼不生生因亦为涅槃作了因者。望方便果说为生因。方便之果能灭烦恼故令一切烦恼不生。能灭烦恼使不生故体是有法。从因修起故三解脱三十七品能为彼果而作生因。非是直望数灭无为而说生因。即前生因能了性净涅槃之果说为了因。是故下结

下答后问。辨明小乘所到彼岸。于中初先牒问略辨。先牒问辞。次辨。后结

迦叶言下问答重显。先问何缘八正道者名沙门那。下佛为解。其沙门那正翻名息息众过故。从斯得果名沙门果。文中三番。一能息乏名沙门那。沙门名乏举其所息。为业烦恼驱驰六道所以名乏。那者名道举其能息。此出那体非解那义。那义名息。故五度中阿那出息般那入息。如是道者断一切乏正解那义。断一切乏故名为息。下牒结之断一切道牒前能断一切乏道。以是义者以是圣道断乏义故。名八正道为沙门那从斯得果名沙门果。二能息恶名沙门那。如世乐静亦名沙门举世名义。此名略少。若具应言乐静息乱名沙门那。如是道者亦如是下约之显法。三息下为上名沙门那。如世下人能作上人是名沙门举世名义。如是道下约之显法

前解彼岸。下释到义。于中先明小乘到岸菩萨佛下明大到岸。小中先明罗汉到岸。后论辟支。罗汉到中义别三番。一约沙门及沙门果解释到岸。罗汉修前沙门之道得沙门果名到彼岸。二约五分法身明到。初举次列下释后结。三约四智解释到岸。四智之义广如别章。此应具论。文中初举。次广辨释。我生已尽依毗婆沙是断集智。依胜鬘经是断苦智。文中初言永断三世生因缘者明其因亡。亦断三界五阴身者彰其果丧。准毗婆沙举其显前。若准胜鬘举前显后。梵行已立依毗婆沙是修道智。若依胜鬘是证灭智。文中初言所修梵行已毕竟者彰其因圆。又舍学道明其果极。准毗婆沙举后显前。若依胜鬘举前显后。所作已辨依毗婆沙是证灭智。依胜鬘经是修道智。文中初言如本所求今已得者明其果极。修道得果彰其因圆。准毗婆沙举后显前。若依胜鬘举前显后。不受后有依毗婆沙是断苦智。若依胜鬘是断集智。故胜鬘云所断烦恼更不受后名不受后。文中初言获得尽智明其因亡。无生智者彰其果丧。准毗婆沙举前显后。若准胜鬘举后显前。前举次释。以是下结。下解辟支到彼岸义。如前罗汉辟支亦尔

下次明其大乘到岸。菩萨及佛具六波罗蜜名到彼岸举因显果。是佛菩萨得菩提下约果显因。先辨后释。文显可知

从如恒河至此第一广明七人悉有佛性

自下第二诫劝舍着。于中有二。一举信谤诫劝舍着。二佛性不名一法已下明性唯是佛随意语诫劝舍着。前中初先广显谤相令人舍远。若言阐提未生善下举谤显信令人习学。前明谤中文别有三。一约七人行修得失以显谤相。二约七人通局之义以显谤相。三明前二起谤所由。就初段中别有三句。一明七人不修之失。不修身等即能造作五逆等罪常没三涂故名为失。二明七人行修之得。近友闻法思惟修学得到彼岸故名为得。三约显谤。良以七人不修身等常沉没故。言一阐提定得菩提是名染着。又以七人近友闻法思惟修行到彼岸故道言阐提一向不得无上菩提是名虚妄

第二段中先明七人通局之义。始终通论一人具七。前后别分七人各一。下约显谤。于中初就菩提明谤。次就圣道。后就佛性。就菩提中良以七人各别一故心口异想言一阐提定得菩提谤佛法僧。现未得故。内心乖法名为异想。口言乖法称曰异说。又以一人具足七故说言阐提不得菩提是亦名为谤佛法僧。当来得故。就圣道中良以七人各别一故说言八道凡夫所得谤佛法僧。现未得故。又以一人具足七故道言八道非凡夫得是亦名为谤佛法僧。以当得故。就佛性中亦以七人各别一故有人说言凡夫众生有佛性性谤佛法僧。现未证故。亦以一人具足七故道言众生定无佛性是亦名为谤佛法僧。当必得故

自下第三明谤所由。由无信解是故我说二种人谤略以标举。不信不解列其二名。若人信心无有慧下彰此二人生过不同。有信无智增长无明。有智无信增长邪见。不信之人嗔恚心下明俱起谤。不信之人嗔恚故谤。无智慧人不解故谤。是故我下结成昔说

上来明谤。自下第二举谤显信。文别有四。一就菩提反举其谤。若说阐提未生善根便得菩提是一谤也。若言阐提舍一阐提次于异身则得菩提是二谤也。二就菩提翻谤明信。若说阐提生善不断后得菩提不名为谤。三就佛性反举其谤。于中初明说有成谤。谓说众生有其报佛果德佛性常乐我净不作不生恼覆不见当知是人谤佛法僧。下复明其说无成谤。说阐提人无法佛性犹如兔角从方便生本无今有已有还无是亦名为谤佛法僧。亦可前说众生身中已有果体所以成谤后说无因所以成谤。四就佛性翻谤明信先举所说后结不谤。前中四句。初言非有如虚空等简是异非。解有两义。一约佛性因果分别。非现有果如彼虚空。非现无因如彼兔角一向全无。二约法报二性分别。非现有其报佛体性如世虚空本来有体。非现无其法佛之性如彼兔角本来无体。如上文中说法佛性不如虚空不可得见。说报佛性不如兔角不可得生。此中所说与前左右。二何以下辨非异是。解亦有二。一约佛性因果分别。虚空常有不如佛性果非本有。兔角恒无不如性因非是本无。二约法报二性分别。虚空常有不如报佛性非本有。兔角恒无不如法佛性非本无。此前一对。三是故下正辨道理。解亦有二。一约佛性因果分别。是前不同虚空等故本来有因而无其果。二约法报二性分别。是前不同虚空等故本来但有法佛性体无报佛体四有故破下约是破非。佛性有故破他说性无如兔角。佛性无故破他说性有如虚空。此后一对。前举所说。如是不谤结成信义

前举信谤诫劝舍着。下明佛性。佛随意语余人不知诫劝舍着。于中四句。一明佛性不定一法乃至万法一切皆是。二明此等或因说果或果说因。三结此说是其如来随自意语。四明如来随意语故名如来等。如来外国名为多陀阿伽度阿罗呵者此名应供三藐三佛此翻名为正真正觉

目下第六约就虚空辨性同异令舍邪解。良以上来数说佛性犹如虚空。人谓全同故须辨异。次前说性不如虚空。人谓全别故须说同。文中初先明性似空。迦叶白言如来佛性非三世下彰性异空。前中迦叶先问起发。如佛所说性如虚空云何如也。下佛为辨。先辨后结。辨中有三。一明佛性非三世摄如似虚空二非内外如似虚空。三无挂碍如似虚空。前中初言空非过去未来现在佛性亦尔略辨同义。善男子下广显同义。于中有四。一广明虚空非三世摄。二佛性亦尔辨法同喻。三虚空无故非三世摄结前第一。四佛性常故非三世摄释前第二。初中复二。一正明虚空非三世摄。二以空无下破有显空成非三世。前中先别。后总结之。别中初言空非过去略以标举。何以下释。无现略解。下重显之现起之法缘离谢往可说过去空无现起故无过去。无现略举。何以下释。无未略解。下重显之。未来之法从缘始集可名现在。空不如是故无现在。无未略举。何以下释。无现过去对问略解。下重显之。若是现起谢往之法未起未谢说为未来。空不如是故无未来。以是下结。自下第二破有显空成非三世。以诸外道说空为有故须破之。有即三世所以须破。以空无故无有三世正辨其无。不以有故破有显无。次喻后合。无物是空释成无义。上来广明空非三世。佛性亦尔辨法同喻。虚空无下结前第一。佛性常下释前第二。佛性常故非三世摄略明佛性非三所以。如来已得菩提已下就人显之。佛得果时证穷性实知性本来常寂不动。故所有性。一切佛法常无变易。以是义下结法同喻

自下第二明非内外如似虚空。虚空无故非内非外明喻似法。佛性常故非内非外辨法同喻

自下第三明无挂碍。如是无碍名为虚空明喻似法。如来得已一切无碍辨法同喻。亦以如来得菩提时证穷法实见一切法平等无碍故就论之。故言佛性犹如虚空结法同喻

上来三番广明如空。以是下结。以是三义似空因缘我说如空

下次辨异。文别有四。第一迦叶征喻同法令空是有。二佛为辨异。第三迦叶举喻类空令空是有。四佛重辨异。初中如来佛性涅槃非三世摄而名为有举法类空。虚空亦非三世所摄何故非有征空同法下佛为辨。明涅槃等有处无故对无说有。虚空之体无处不有是故不得对无名有。于中初先辨法异空。为非涅槃名为涅槃为非如来名为如来为非佛性名为佛性略以标举。下广释之。先解涅槃。初问后释。一切烦恼有为生死非是涅槃。为破如来有为烦恼非涅槃故宣说涅槃以此为有。次释如来。先牒后解。阐提乃至辟支佛等非是如来。为破此等非如来故宣说如来以之为有。下解佛性。先牒后释。墙壁瓦石无情之物非是佛性。为简此等非佛性故说性为有。性有二种。一能知性。谓真识心。此真识心众生有之外法即无。故上说言夫佛性者谓众生也。又妄心处有此真心。无妄心处即无真心。故上说言凡有心者悉有佛性。二所知性。所谓有无非有无等一切法门。此通内外不唯在内。今此所论约初言耳。一切世间无非虚空对于虚空辨空异法。一切世间无有一处而无虚空知复对何说空为有

第三迦叶举彼四大类空令有。云何为类。若佛宣说世间无有一处无空不得对无说空为有。世间色处悉有四大。亦无有处而无四大无无可对。亦应不得说大为有。世间无有无四大处可以形对而犹得名四大为有。世间虽复无处无空可以形对何为不得说空为有。迦叶此言如来不答何故不答。以非问故云何非问。世间空处则无四大。对彼无故说大为有。无有一处而无虚空。知对何无说空为有。为是不答

自下第四如来重复对上初问简法异空。若言涅槃。非三世摄虚空亦尔是义不然牒以总非。何以下释。释中有三。一明法异空。二虚空性下明空异法。三是故我说佛性常下总结其异。就初段中涅槃是有总明异空。下别显之。为智所照名为可见。为心契会名为可证。具足平等法门之身及不思议变化之身故云是色。可为行者寻求趣入名为足迹。可以言论称曰章句。体备万德称之为有。德状殊分说之为相。为心攀历故曰名缘。众圣同趣名归依处。离世纷动说为寂静。体无闇障名曰光明。永绝危怖称曰安隐。究竟所到故云彼岸。是故得名非三世摄总以结之

自下第二明空异法。空无是法是故名无明空是无。若有离下破有显无。先破其有却显其无。以诸外道计空为有故先破遣。于中合有十一复次。初一约就非色心法破空是有。次一约心破空是有。后九约色破空是有

初中若离如是等法更有法者举他所立。谓离向前涅般之法。应三世摄以理征责。虚空若同是有法者重牒所立。不得非是三世所摄以理遮责

第二约心破空有中。世人说空名无色等举他所立。即心数者征同心法。若同心下征为三世。若三世下征为四阴。是故离下结成无空

就后九番约色破中。初破虚空体是光明。二破物住处以为虚空。三破空次第。第四破其空实等三以为虚空。五破空可作。六破无碍处以为虚空。七破虚空与物共合。八破指住处以为虚空。九破虚空为物所依

初中外道言空是光举他所立。若是光下征令是色。虚空若下征令无常。是无常下征为三世。若三世下以是三世征为非空。亦可说下立空为常。翻破前执虚空是常。便非三世乃至非色。云何外道说为光明。就其意解说空为常。未可专决故云亦可

第二番中人言虚空即是住处举他所立。若有住下征为色法。而一切下征为无常。三世所摄征为三世。虚空亦下明空是常三世不摄。翻破前执常非三世即非色法云何言处。若说处下结以显非

第三番中复有说空即是次第举他所立。如去墙壁空相渐现名为次第。若是次下征为数法。若可数下征为三世。若三世下征为无常

第四番中夫虚空者不离三法举他所立。一空二实三者空实列他所立。有人宣说无物之处是虚空界是故言空。复有人言物住之处是虚空界是以言实。有云并是故言空实。下就破之。若言空是牒举初句。空是无常征以显非。何以下释。实处无故所以无常。若言实是牒举第二。空亦无常征以显非。何以下释。若空实是牒举第三。空亦无常征以显非。何以下释。二处互无故是无常。是故已下结空为无

第五番中如说虚空是可作法举他所立。如说去等辨他所立。一切作下征令无常。于中初法次喻后合

第六番中世说法中无挂碍处名为虚空举他所立。于一法所为具为分进退征定。下对破之。若具处有余处则无破其具边。若分有下破其分边。若分可数是一过也。可数无常是二过也

第七番中先举他说总非不然。说空无碍与有共合是一门也。复言在物如器中果是二门也。此二皆非故曰不然。何以故下释以显非。先破初门。若言并合即有三种征定所立异等列名。空静物动两聚一处名异业合。如鸟集树类以显之。鸟喻物业。树喻空业。空物俱动两聚一处名共业合。如羊相触类以显之。物前空缩物退空进故说如似两羊相触。有说此物先与空合彼物亦先与空共合。两合同聚已合共合。是义云何。如树先与虚空共合。鸟复先与虚空共合。鸟来上树则得名为已合共合如是一切。如二双指合在一处类以显之。下就破遣。若异业合牒举初门。则有二分定其二业。初业空业列其二名。下就破之。于中有二。一以合破常。二若言虚空是常已下约常破合。前中初言若空合物空即无常是一破也。同物无常方名为合不同无常不名合故。若物合空物即不遍如其不遍是亦无常是二破也。此义云何。物业不遍将不遍物与空共合。空随有物亦应不遍。以不遍故空应无常

就下约常破合之中。若言空常与动物合是义不然举以总非。何以故下释以显非。若空是常物亦应常明物有其同空之过。物若无常空亦无常明空有其同物之过。若言虚空亦常无常遮其并立。前人被征喜立两义故举以非。虚空一法云何是常。复名无常以有此过是故不得说空合物

次破第二共业相合。先牒总非。何以故下释以显非。虚空名遍直立道理。若与业下征有齐空令有亦遍。若是遍下征令齐遍。若一切下征令齐合。不应说下责其分合

下破第三已合共合。先牒总非。何以故下释以显非。于中初法次喻后合。法中先无后方合者明其共合无常所以。先无后有是无常者正明共合有无常过。是故已下结破共合。喻合可知。此初门竟

次破第二空住物中先牒直非。何以故下释以显非。于中先就无器时破。如是虚空先无器时住在何处责其住处。若有住下明有住处虚空即多。彼空住处先有虚空如有器中所盛虚空在彼住是以言多。如其多下以多破常。有多有少云何名常。云何言遍以多破遍。此处遍多何得言遍。下复就其有器时破。若使虚空离空有住举其处破。器中之空未有器时余空处住。器起之时舍本空处来器中住。是故名为离空有住。有物亦应离虚空住将有类破。世间有物先依空住。余物起时亦应舍空余有中住。世间有物无有能得离虚空住。虚空亦尔。云何而得舍本空处来有中住。是故当知无有虚空结空为无

下第八番破指住处以为虚空。与前第二物住之处名为虚空大况相似。破法不同故须更论。若有说言指住之处名为虚空举他所立。当知已下征令无常。何以下释。于中初明指住之处名为空故随指有方。一切常下明有方所必是无常。于中先明常法无方。以有方下明有方故必是无常。若无常下明是无常不离五阴。要离已下明非五阴是无非有

下第九番破彼虚空为物所依。于中有三。第一泛明依他住法悉是无常。举此为显所依之法是无常矣。二譬如下举本显末。明其所依是无常故能依无常。于中四对。一草木依地。二地依于水。三水依于风。四风依虚空。为显第四举余类之。一一对中皆初明其末来依本。后就本中辨明无常类显于末。是中宣说虚空无常令风无常从他意说非佛自义。论佛自义虚空无法不为物依。三若无常下以空无常破常破遍。此乃反难非显正义。若论正义空是常遍则非无常。非无常故非物所依

上来合有十一复次破空是有。虚空无故非过去下显空是无。先法后喻

前第一段明法异空。次第二段彰空异法。下总结异。法异空故我说佛性常非三世。空异法故无非三世

断三世因名断善来明佛能知佛性五阴化生信解

自下第二明佛能知法相五阴化起治行。于中粗二。一知染阴。二知净阴。细分有四。一知染果谓凡五阴。二知染因谓业烦恼。三知净果谓佛五阴。四知净因所谓圣道。具知此相名知诸阴。文中有三。一知常无常二种果阴。二迦叶白云何色从烦恼生下辨因显果。三迦叶白如佛所说三漏已下广论其因。前中初明生死五阴。迦叶白佛智者即是菩萨已下明佛五阴

初中有四。第一如来略明自己不与世诤。二何以下显不诤相。说有说无皆同智者故曰不诤。三迦叶言下显向初段不诤所由。先问后辨。辨中初举次列十名。此十与前师子吼中修十相似。信戒近友正与前同。内善思惟前名寂静。精进正念亦与前同。是中智慧前为第十此为第七。正语乐法亦与前同。怜愍众生前名惠施。如是下结。四迦叶白下显前第二说有说无先。问后辨。文显可知。自下第三明佛五阴。先问后答。问中初先定其智者。即是菩萨一切圣人。下就设难。难有四句。一责佛不同世智说有。世智说阴有其无常苦空无我。如来云何不同其说乃说佛身常恒无变。二责佛不同世智说无。世智说阴无常乐等如来云何说言是有。三责佛不与世诤之言。作如是说云何不诤。四责佛远离颠倒之言。于中四句。一以理明佛远离三倒。二列三名。三应说下明佛离倒应说佛色是无常等。四今乃下以佛说常征破离倒。下佛答中初明凡色从烦恼生彰其智者说有无常苦空所以。后明佛色远烦恼成彰已宣说常恒所由

上来明果。自下第二辨因显果。于中有四。一明凡佛二种阴因。二明得果。三结法属人。四结答上问。前中先明凡夫阴因。初问起发。云何为色从烦恼生且问色阴。余类可知。下佛为辨。烦恼有三总以标举。欲有无明列其三名

智者应下明佛阴因。于中有五。一直观漏因。二明须观因。三观漏果。四观漏轻重。五修道断漏。初中有四。一观漏过。二教生厌想。三教修断意。四因修能。初中复四。一略观漏过。智者应观三漏过患。二所以下略明观益。知罪过已能远离故。初问后辨。辨中先法后喻可知。三如人将下对向初段重显漏过。先喻后合。喻中如人喻彼三漏。漏盲喻凡夫。盲无慧目惑起牵之至生死处名为将盲至棘林中。惑性无常起已谢往名舍之还。亦可此惑性成在心暂起牵人还入性中名舍之还。凡无慧目处苦难脱故言盲人于后难出。假设得脱众苦备经故言设出身体坏尽。下合显过。凡合盲人。不见漏过合其盲也则随顺行合前被将至棘林中。四如其见下对前第二明知利益。见则远离知过报微略明知益。有四人下广显知益。于中初先泛举四人。次列四名。若人能下约就此四明知利益。能观烦恼作受但轻对一二三以劝观过。自下第二教生厌想。智人作念我应远离已起过中生心欲离。又复已下未起过中制意不作。何以下释

自下第三教修断意。句别有四。一念修有益。我若修道当因是力破坏诸苦。二是人观下由前思念令惑轻薄。三既见下由惑轻薄心生欢喜。四复作念下知道力大决意修习。自下第四因修得离。初离烦恼。后明离苦

上来第一直观漏因。是故我于经中说等举昔所说明须观因。是前观漏有利益故我说应当观漏及因。何以下释。于中无明下观之失。先问后辨。后明观益。先问后辨。辨中初法次喻后合

自下第三次观漏果。于中初先结前生后。知从善下正观漏果。观果报下明观利益

自下第四观漏轻重。于中初先结前生后。观轻重已先离重下随知渐断。智者若知烦恼因下是第五段修道断漏。于中初法次喻后合

上来广辨凡佛阴因

自下第二明因得果。初言若人能知烦恼烦恼因等明向后段佛因得果乘言便故。若不能下明上初段凡因得果

自下第三结法属人。初知烦恼烦恼因等结前无漏得果属佛。先结属佛。后就明常。不知恼下结上有漏得果属凡。先结属凡。后就其人明阴无常

自下第四结答上问。迦叶向前责佛所说不同智者。并责如来不名不诤。佛今答之。先定智者谓佛菩萨。一切圣也下约之答问。菩萨诸佛说是二义我亦如是明已所说同诸智者。谓说上来凡夫五阴从烦恼生是无常苦。诸佛五阴不从恼生是常乐我名为二义。是故我说不与世诤。结成已说不与物诤

上来第二辨因得果。自下第三广辨其因。于中偏明无漏之因有漏不说。文别有五。一修道断漏。二迦叶白云何名为清净行下辨出道体。三有漏法亦复能作无漏因下彰道分齐。四若有知根知因已下明摄道法。五迦叶言毕竟即是涅槃已下明趣道仪。亦名修习趣道方便。前中初先断除烦恼。次明断业。后明断苦。断烦恼中初断漏体。观受知是漏近因下断漏因缘。前中有四。一观漏体。二观漏因。三观漏果。四修道断漏。观漏体中迦叶初问。云何名欲乃至无明。下佛答之。先解欲漏。初言内觉因外缘等正解欲漏。是故我下引说证成。次辨有漏。初先正辨。后简欲过。下解无明文别有三。一当相正解。二无明即是一切本下彰无明过能为惑本。三迦叶白下于前义中有难解者问答重显。前中初言不能了知我及我处不别内外正辨其相。我及我所泛解有四。一神主为我诸阴为所。不知此无名曰无明。二假人名我假法为所。不知此无名为无明。三内法名我外法为所。不知此无称曰无明。四佛性名我真中所有德义差别说为我所。故上文言知我我所是人出世不识此义名曰无明。内之与外解亦多种。一众生名内外法为外。不了此无名曰无明。二阴界等事相名外苦无常等法相为内。不识此等名曰无明。三有法为外空理为内。不识此等名为无明。四真法为内情相为外。不识此等名曰无明。五真性为内真用为外。不识此等名为无明。名为下结

第二段中初言无明即诸漏本正辨其过。何以下释。无明因缘于阴入界忆想作相名众生等明依无明生于三倒。以是因缘生一切漏谓依三倒生余四倒及贪嗔等一切诸结。故名无明为诸漏本。是故我下引说证成第三问答重显之中有两问答。迦叶初先举昔征今。如来昔说不善思惟生贪嗔等今何因缘乃说无明。下佛为释。释有三句。一彰无明及不善思互相增长。二其能生下明此二种同能生长诸余烦恼。于中初先泛论一切生长烦恼皆悉名为烦恼因缘。谓六尘等。下明亲近烦恼因缘生烦恼者悉是无明不善思惟。是故此二同能生长一切烦恼。三如子下分定亲疏。如子生芽子是近因四大远因。烦恼亦尔。不善思惟以为近因无明为远。迦叶下复举前征后。如来前说无明是漏云何复言因无明故生于诸漏。下佛为释。释中有三。一说根本无明住地为无明漏。余三倒等粗起烦恼同为所生。文中初言无明漏者是内无明无明地也。内迷真如不了不见故名为内。因于无明生诸漏者是内外因。辨其所生生三倒等粗起烦恼与彼所起而为因也。就所起中三倒之心迷覆无常苦空无我因缘之理立为定有名之为内。四颠倒等于前所立定有法中不了不识颠倒建立我我所等名之为外。二直就前所生法中分取三倒。内迷之心为无明漏。四颠倒等粗起烦恼同为所生。文中初言说无明漏是名内倒是三倒也。下辨其相。不识无常苦空无我故名为内。若说一切烦恼因缘是名不知外我我所。是四倒等粗起烦恼于阴界等粗事法中不了不识横计为我或为我所名为不识外我我所。三一切无明为无明漏生阴界等生死之果。文中初言说无明漏无始无终是其一切无明惑也。不简本末始终之别一切通说为无明漏名无始终。不道无明前无原始后无终尽名无始终。从此一切无明烦恼生阴界等

次观漏因。有两问答。迦叶初先举佛昔言请佛辨释。佛答有四。一教观察生烦恼缘。何缘生恼是其总也。造作下别。二教观察转烦恼缘。何缘转下如是等也。三作是观下明观利益。四是故我下结成昔说以答前问。迦叶下复重问如来。众生一身云何能起种种烦恼。佛为辨之。先喻后合

次观漏果。有二问答。迦叶先请云何观果。下佛为辨。文别有三。一教观诸漏能生苦果。于中先明生恶趣果。后生人天。人天之身物多贪着故就辨过令人厌离。得人天身即是无常苦空无我明具四过。下复显其苦无常相。得三苦者所谓苦苦坏苦行苦。三无常者谓生住灭。又复分段念性不成亦是三也。二教观漏能生恶业。能令众生作五逆等。三教智者励意不造。我得是身不应生恼受恶果报。迦叶下复将无漏果对前征问。句别有三。一乘佛前言问无漏果在断中不。于中初言有无漏果举其法体。复言智者断诸果报牒佛前言。无漏果报在断中不正对征问。上明圣人求无漏果云何言断。于中初言诸得道人有无漏果举其法体。下就设难。如其智者求无漏果云何佛说一切智者应断果报。三问圣人断诸果报云何得有无漏果报。为此难者欲使如来解无漏果异前所断是以难之。下佛为释。释意如何。明无漏法体非是果亦无复报。是故不入所断报中。圣人虽求不妨断除有漏之果。虽复断除有漏之果不妨有。文中有三。一明无漏体非是果。从他世间果报作名名无漏果。为辨此义文中泛举诸法类显。如来或时因中说果果中说因略开二门如世人等寄就世人言说显之。我亦如等就已所说显之。是中正取因中说果类显圣人无漏果报因中说果。二一切圣下明无漏法不生后果。但诸圣人修道力故更不生漏。此不生漏由道故得名无漏果。文中初言一切圣人无无漏果明不生后。一切圣人修道果报更不生漏故名果者。无漏功德望道名果。三有智之人如是观下明观利益

自下第四修道断漏。初先正辨。迦叶白下问答料简。有两问答。迦叶初以众生烦恼因果俱恶难破有修。文别有四。一明烦恼因果俱恶。二难破有修。三明众生即于烦恼。四难破有修。初中先法次喻后合。法中四句。一明众生从烦恼起。二明烦恼是恶非善。三明烦恼能生是恶所生亦恶。四就烦恼分定因果。先举次列。后明俱恶。喻文可知。合中四句。一明因果俱是众生。二明因果俱是烦恼。三明烦恼即是众生。四明众生即是烦恼。余三可知。下佛答之。先叹次敕后为辨释。迦叶下复以诸烦恼相生不绝难破有修。佛为释之。明有烦恼不作后因故有修道。先喻后合。前次断烦恼。下次明断烦恼因缘。受想触欲是惑因缘。先明断受。次明断想。后明断欲。触即在于受想中说更不别论就断受中文还有四。一观受体。二观受因。三观受果报。四修道断受

前观受中句别有六。一观受心。能为一切漏之近因谓内外者。断一切漏无明三倒名为内漏。余名为外。二明由受不绝诸漏。三明由受不出三有。四明由受发生三倒。五明由受起于爱结。六明由受发生诸业。初先正辨。是故我下引说证成。是故智下结观劝察

次观受因。句别有六。一推受所因。二若因缘下知受无因。三复观下知受不从自在等生。四是受皆从和合已下知从爱生。五是和合下知受体性非有非无。六是故下结意断除

次观受果。于中初先结前生后。下正观察。文别有三。一观受生缚。谓能招苦断灭善根。二能生解脱。三明观利益除因离果。作是观时不作受因略明观益。下广显之。先问后辨。何受作爱推受所生。何爱生受推爱所生。若能深下明观利益

下次明其修道断受。文有广略。略中五句。一推爱受在何处灭。二因观便知见有少灭即知当有毕竟灭处。三因知生信。四推脱所因知从八正。五知已正修。下广显之。云何八正问前起后。下对辨之。文别有五。一观三受能增身心。二观察受因。三重复观受。四观受果。五随知断除。就初段中先举三受。次列其名。后彰三过能增身心

第二段中何因能增触因缘也。征前起后。下广辨之。先举三触。次列其名。触是心数生一切法。今随所生开分为三。如杂心中宣说五种增语及有对明无明处中是其五也。增语有对约识分别。意识相应能发语言名增语触。五识相应触对现境名有对触。后三约法。能生圣道名为明触。生烦恼者名无明触。余名处中亦名非明非无明触。今彰后三略无前二。下辨其相。明即八正。余增身心及三种受。是故我下随过断除

第三段中初明受心亦因亦果。当观已下劝人观察。云何下释。是故下结

第四段中智观受已复能观爱结前生后。受报名爱总辨其相。有二下别。先举。次列。下辨其相。言杂食爱因生老等其言颠倒。若正应言是生老等一切有因无食可知

自下第五随知断除。于中三句。一教反推不断食爱不离生等。二教反推不断受因不得道果。三是故下依次正断。先断触数。次受。次爱。后结名道。若有能下结成有修

涅槃义记卷第十(之上)应永三年十月日加修复补朽失处了　　　　　　　　　　　老比丘贤宝涅槃义记卷第十(之下)

        隋净影寺沙门释慧远述

下次观想。于中亦四。一正观想。二观想因。三观想果。四修道断想

初中有五。一寻末推本。观前受爱从于想生。二广显想过。三正明观想。四知想分齐。五明断有益。初段可知。第二段中初何以故征前起后。次对辨过。众生见色亦不生贪简识异想。受亦不生简受异想。若于色下正显想过。是故已下结劝观想。第三段中云何观想问以起发。念一切生未得正道皆有倒想对问略辨。云何倒想重问起发下对广论。第四段中明想分齐。差别说三。先举。次列。下辨其相。三番辨之。一约境分别。小因缘生名为小想。如是等也。二约定分别。未入名小。已入名大。十一切入名为无量。三约界分别。欲小。色大。无色无量。第五段中初先正明断想利益。三想灭故受想得脱。迦叶下复问答重显。迦叶初先执通难别。灭一切法名为解脱。云何如来说想受灭名为解脱。下佛为释。释意如何。明想与受是惑根本举本摄末。故虽说二而摄一切。文中如来举类显之。类相如何。有法依人。说人解法。有人依法。说法解人。所类如是。一切烦恼依想受生故说想受即知一切烦恼皆灭。类中初言如来或时因生说法闻者解法因法说生闻者解生略以标举。次辨其相。下约显法虽说想受即已总说一切可断

次观想因。文别有三。一正观想因。二生起后果三于前因中有难解者问答重显。前中四句。一结前生后。二是无量下寻果知因。三触有二下就因分别。先举次列后辨可知。四观触生想。此初段竟。第二可知。第三段中有两问答。迦叶初先执圣同凡明圣有倒请佛释遣。文中初言若以因此烦恼之想生倒想者牒佛上言。前文说言因烦恼触生于倒想今还牒前。何故乃云因烦恼想生于倒想。准依成实说想为触。触即是想。故今迦叶就想以牒。若依毗昙触与想俱。从伴以牒。是故说言从烦恼想生于倒想。下就所牒约圣作问。圣有倒想而无烦恼是义云何。如来反问云何圣人而有倒想。迦叶下复辨倒对佛。佛下为释。明凡着想可名颠倒。圣人俱有世流布想云何颠倒。先举二想。次列。后释。释中圣人有世流布就圣正解。一切凡下举凡显圣。先辨后结。观果修断文皆可知

下明观欲。文还有四。一正观欲。二观欲因。三观欲果。四修断欲。就初段中欲心为体。文偏举境。智者观欲即是色等略以标举。即是如来因中说果释为欲义。此五非欲能生欲心。因中说果故名为欲。从此生欲实非欲也。释显其相。次观欲因。当知欲心倒想为因。文中有五。一明痴人于前色等贪求受之生于倒想。贪求欲也。欲起贪求先生倒想。二依想生受。三依前倒想生十种想。言十想者。所谓色声香味触想。生住灭想及男女想。前五倒想即以为五。加起后五名生十想。亦可于前五尘境界重起心想通余说十。四明依想所生欲心能造恶业。五结劝观想。观果修断文皆可知

下次观业文还有四。一观业体。二观业因。三观业果。四修道断业。前中初先结前生后。何以故下辨明须观业之所以。以前烦恼能作生业及受业故。先征后辨。受想触等牒前烦恼。能作生业不作定业隐终论始。初发善恶能生后果名作生业。未润受果名不作受。如是烦恼与业共行即有二者始终通辨。前作生业更润生果通前说二。生受列名。是故下结。是前烦恼能为二业故须观之。下辨业相。约具说三。初举。次列。下广分别。四义辨之。一业及业果相对分别身口二种起作名业。从意业生故名业果。意能思量造作名业。不从业生故不名果。以业因故即名为业释以显之。二内外分别。身口名外。意业名内。三生受分别。义如前释。四期正分别。正业名意期业身口略分二相。依前意业身口之中期会而成。故名身口以为期业。先发。下释。是故下结

次观业因。于中初先结前生后。下正辨之。爱无明触是其因也。从无明触生于爱心。从爱起于身口意业

次观业果。于中初先结前生后。下正辨之。辨中有二。一约黑白四业分别。二约善恶二业分别。前中先举。次列四名。义如别章。此应具论。下辨其相。迦叶白下问答料简。迦叶初问。次前宣说无漏无报。今云何言有其不黑不白报乎。下佛答之。明无漏法从有漏生故得名果。不生后果故不名报。于中约对有漏显之。先举二数。次列。下辨。四中前三亦果亦报。从前因生故名为果。更生后果故名为报。不黑不白是果非报。义如前解。迦叶下复重为征问。无漏非黑何不名白。下佛为释。无有报故是一义也。以无果报白相不显故不名白。对黑名白是二义也。有漏之善对黑名白。无漏双对是故名为不黑不白。又此绝对是故亦名不黑不白。我今乃下重释初义。名为寂静重显第二。以寂静故绝黑白相名不黑白。下约善恶二业明果。如是业者有定受处总以标举。如十恶下略分生处。下广显之。十恶有三谓上中下。上生地狱。中生畜生。下生饿鬼。依大智论善业亦三谓上中下。上品生天。中品生人。下品修罗。今此偏约人道分四。初举。次列。下辨生处。下生郁单。中生弗娑。上生瞿耶。上上阎浮。问曰上说北方为上。今以何故下生郁单上上阎浮。此各有以。若论果报北方为上阎浮为下。若论起道阎浮最胜郁单最劣。今望起道故说上善生阎浮提下生郁单。下明修断。智人作念云何断果推求断法。复作念下明知断义。是故下断。是即下结

下明观苦。文亦有四。一正观苦。二观苦因。三观苦果。四修道断苦。前中初言观业恼已次观是二所得果报结前生后。是报即下斥其果体。既知是苦即离受生明观利益。知苦断集故离受生。智者复观烦恼缘下广辨苦相。于中有四。一观十二因缘之苦。二观五道三观三界。四观八苦。前中初列十二因缘。次总结之。后明观益。十二因缘义别有六。一约五世明十二缘。如彼七十七智中说。二约三世。三约二世。四约一世前后分别。五就同时别体分别。六就同时同体分别。后之五门如别章释。此中约就五世分别。过去过去立其二支。烦恼因缘生烦恼者。从彼过去过去烦恼生于其次过去无明。业因缘故生烦恼者。从彼过去过去业行生于其次过去无明。其次过去亦立二支。烦恼因缘生于业者过去无明生于行支。业生苦者谓从前行生现识支。现在世中立其四支。言苦因缘生烦恼者谓从现在识等五果起于爱取。烦恼因缘生于有者从现爱取起现有支。有生苦者从现有支生次未来生老死支。有生有者从现有支生未来有。现在世中善恶二业为自分因。远生未来善恶业故。其次未来立其三支。有生业者未来业行前后相生。言业因缘生烦恼者从未来世所造之业起未来世润生烦恼。烦恼生苦者从未来世润生烦恼生于未来未来生支。未来未来唯立一支。苦生苦者从彼未来未来生支即生彼世老死支也。上来广辨。下次结之。智者若观当知是人能观业苦就要略结。之言略少。若具应言是人能观烦恼业苦。何以下释。如上所观即是生死十二因缘。十二因缘体是烦恼业苦所收。是故观者名为能观烦恼业苦。若人能下明观利益。由观厌故不造新业能坏故业。次观五道。先观地狱。初总标举。观一乃至百三十六别以显之。大狱有八。一等活地狱。二黑绳地狱。三名众合。四名叫唤。五大叫唤。六热地狱。七大热地狱。八阿鼻地狱。是八大狱一一各有十六眷属。通本合有百三十六。一一狱下辨其苦相。皆是已下辨因令断。次观鬼畜。下观人天。此第二竟。次观三界。皆从恼业略以标举。下广显之。两喻两合。下观八苦。指上广显

上来观苦。次观苦因。于中初先结前生后。即爱无明正出因体。下辨其相。两义分别。一就求身求财分二。先举次列。二俱是苦辨过令厌。是故当下辨因令断。二就贪身贪色分二。先举次列。爱身名内。着色名外。下彰其过三番辨之。一偏约起业。以彰其过。内能作业。外能增长。现贪身乐造作罪业名为作业。着外色境令罪炽盛名为增长。二通望业果以彰其过。内能作业。外作业果。为求后身造诸业行名为作业。由贪色境于受身时润生后报名作业果。由内作业故断内爱。业即得断。由外作果故断外爱。果即得断。三偏望苦果以彰其过。内生来苦。外生现苦。内贪己身造业趣求故生来苦。外贪色欲追求生恼故生现苦

次观苦果。爱取烦恼从现苦生名为苦果。今此观之。于中初先结前生后。下正辨之。苦果即取约苦明取。受心亦是据终以举。爱果名取约爱明取。是取因缘即内外爱约取明爱。内外如上。即有爱苦约末显本。取从爱生。故有取者即有其爱。爱从苦起。故有爱者即有其苦。又复取者远从苦生。是故有取亦知有苦。亦可此言约本显末。是取非直从爱而生亦能生爱。故有取者即便有爱。故下文言取因缘爱由爱受苦故言有苦

下明修断。句别有四。一观爱取互相因起。二知断爱取业苦不生。三正修断。四若人下结。上来第一修道断漏

自下第二辨出道体。于中初说大般涅槃经以为道法。后说三十七菩提分以为道行。法中迦叶初先总问。云何梵行。如来总答。一切法是。迦叶重问。一切不定何等一切。下佛先叹。后为辨之。涅槃经是。于中初以四十二句别叹经胜。后总结叹

行中初言我说此经虽摄一切梵行即是三十七道正出道体。下叹显要。若离不得声闻果等反叹显要。以是缘下顺叹显要。何以下释。释中四句。明道性能成其要义

自下第三明道分齐。有四问答。迦叶初问。有漏能作无漏法因以何义故不名梵行。下佛答之。有漏颠倒故非梵行。第二迦叶问世第一为漏无漏。佛答有漏。第三迦叶就之设难。彼性不倒何故不名为净梵行。佛答第一为无漏因。似于无漏向无漏故不名颠倒。一念不续故非梵行。第四迦叶举彼众生五识作难。五识非倒复非一念以何义故不名梵行。迦叶以彼五识之心取境不谬故言不倒。前后数起各非一念。不言一一多念相续名非一念。佛答五识有漏颠倒故非梵行。先举次释。增漏名漏解为漏也。着想倒等释为倒也。问曰着想是想非识。今以何故宣说五识以为着想。依如成实。想是通名意识所收。若依毗昙。想是心法非六识体。然是通数与六识俱。此经所说多同毗昙。五识之心与倒想俱。从伴以彰名为倒想。三十七品性非倒下举是显非成前非梵

自下第四明摄道法。根等九种是其道法。修起名摄。文中初先略以标举。若知根因乃至毕竟名净梵行。迦叶白下问答广论。先问后答。答中先赞。后为辨释。释中初先通解九法。根本因增。云何异下别释初三差别之相

前通解中合有五番。初番定体。中间三番约修辨相。后一类释。就初番中初八是因。终一是果。因中八种。即是十种。通大地中八之数也。十通地者。如毗昙说。想欲触慧。念思解脱。忆定及受。除想及忆。余者皆是。根是欲数。因是触数。摄是受数。增是思数。主是念数导是定数。胜是慧数。实解脱数。于此八中受念定慧。道品法中具列其名。余虽不列道理具有。问曰此思与道品中正思何别。彼是觉数此是思数两体全别。问曰何故偏举此八。以此通数常相随逐成道要故。问曰想忆亦是通数何故不举。想于趣道远方便中非不有力。正道之中假之义微。忆于道法无大功力为是不举。余别心法有无不定故略不举。从斯道因得涅槃果名为毕竟

中间三番约修辨中。初就出世成熟行中以别九法。次就从始趣终门中以别九法。后就从小入大门中以别九法。就初番中先解欲心以为根义。于中初法。次以喻显。喻别有四。迦叶白下问答会通。有两问答。迦叶先举不放逸心对欲征问。下佛为释。欲是生因。不放了因。迦叶下复举佛对问。如来为释。初知因佛自证因欲。次解明触以为因义。先问后解。解中合有十阶九对。此九对中藉前生后悉名为触。非唯一种。就初对中先定触体。或说为慧或说为修此为取信对慧辨之。下将信心对近善友以解触义。近友望闻即复名触。如是一切。次解受心以为摄义。先牒后释。释中受时能作善恶总相通论。受因缘故生烦恼等约对显治。增等可知。解毕竟中虽得世乐出世乐等简非异是。若能断等彰是异非。要息缘治方为涅槃毕竟寂静无为之义。故断三十七品所行名涅槃矣。妄智是障故须断之。是故我下结彼涅槃为毕竟义

自下第二直就大乘从始至终以别九法。初四可知。因是四法能生长道欲念定智举法大多。长一欲字。当以念心共欲相随。并伴通举故有此欲。与禅支中忆念相似。彼正明念通忆而举。此亦同然。余皆可知

第三番中从小向大以别九法。文亦可解上来三番合为第三约修广辨。下次类显。约十二缘类显九法。欲名识者识心缘境义说为欲。六入触对六尘境界义说为触。受能领纳故名为摄。无明迷惑增长业行故名为增。名无明心为无明识。名之与色是报体性故说为主。爱能导生诸烦恼结故名为导爱中增强方名为取故说为胜。有实得果故说为实。生老病死因缘中极名曰毕竟。此等皆就相似义说不依次第

上来一段通释九法。下次别解。根因及增三法差别。以此三义粗况相似故须辨异。先问后辨。辨中五番。初番直就起因辨异。根即初发因即相似续生似前。增灭相似生相似者舍前自分更起胜进。二就起因得果辨异。根即是作初作因也。因即果者由前作因牵生当果。所生当果与后现时果用为本故名当果。以之为因彼果现用说之为增。下重显之。未来之果以未受故名之为因受时名增。三就增因得果起用三义辨异。根即求者造因求果得即因者所得之果能为用本故名为因。用即增者依果起用说之为增。四约位辨异。根即见道因即修道增即无学。五缘正二因得果辨异。根即正因如世种子。因即方便如世水土。得果名增

自下第五明趣道仪。亦说名为趣道方便。迦叶先问毕竟涅槃云何可得。下佛为辨。明修十想故得涅槃。于中有四。一开章门。二总结叹。三广辨释。四总结叹

前中初举。下列其名。名中初六明摄对治。后四离过。治中初三观法通义。后三观于内外之事。后离过中观过生厌名多过想。无碍正断名为离想。解脱证除名为灭想证寂离染名无爱想。若约位分。地前修厌名多过想。见道断惑名为离想。修道除结名为灭想。无学清净名无爱想。此四犹是地经之中依厌离灭回向于舍。第二段中结叹可知

第三释中初六摄治一处辨释。初先正辨。后明观益能成七想。前正辨中初观无常。先问后辨。辨中有三。一观色无常。二观心无常。三总结叹。就观色中文复有三。一分人为二。初发久行。二分法为二。谓粗与细。三就人辨观。先就初发明其观粗。后就久行彰其观细。粗中约就内外起观。众生名内。外物名外。先开二门。次辨。后结。辨中有四。一就所见内法起观。二就所见外法起观。三就所闻内法起观。四就所闻外法起观。初中四句。一观众生五时变异故是无常。二观众生肥瘦不定故是无常。三观众生贫富不定故是无常。四观众生善恶不定故是无常。文皆可识。第二所见外法无常。文亦可知。第三所闻内无常中既观见法复观闻法结前生后。下正辨之。初观诸天。次观劫初一切众生。后观轮王。第四所闻外法无常。文亦可知。上来辨竟。是故当知内外无常总以结之

前明观粗。下就久行明其观细。既观粗已次观细者结前生后。下正辨之。于中初问次辨后结。辨中初就未来之法观细无常。后就现在。就未来中于内外色乃至微尘在未来时已是无常略以标举。何以下释。释中初以可破坏相显细无常。后以十时前后变改显细无常。现中有三。一观人盛衰显细无常。二观四大及四威仪显细无常。三观内外各有二触能为苦因显细无常。于中初观内外各有二种苦因。饥渴寒热出其因体。饥渴内因。寒热外因。复观是下用前所观显法无常。下结可知

上来观色。下次观心。如内外色心法亦尔举色类心。何以下释。释中初言行六处者缘境不同显心无常。或生喜等改变不定显心无常

前色次心。下总结叹。是故当知色非色法悉无常者结无常义。菩萨能下结无常观。智者修已远离常慢赞明修益

苦中初先结前生后。次辨。后结。辨中有四。一总观苦因于无常。二观无常故受生老病死之苦。三观无常故受于苦苦。四观无常故生五盛阴

次观无我。于中初以无常及苦显法无我。智复观苦即无常下破情显理。于中有五。一以苦无常破定有我。苦即无常无常即苦观法非我。若苦无常云何说下征破情执。苦非我下重显非我。众生云何说言有我重破情执。二以和合无性破我。观一切法有异和合总明法和。不从一和生一切法亦非一法是一切果别显法和。一切和合皆无自性总明无性。亦无一性亦无异下别显无性。诸法若有如是相下结破说我。三观诸法无独能作破定有我。一切法中无一能作别推无作。若一不下以一类余明皆无作。四观诸法无独生灭破定有我。于中初明不独生灭。次明诸法和合生灭。是法生已众生倒想言是和合从和合生明凡倒惑。众生宣说生灭和合从于神我和合而生。众生倒想无有真下破情显无。五就一异破定有我。于中先推何因缘故众生说我。下正破之。于中先就一异以定。次就破之。先就一破。后就多破。一多俱无总以结破

次明厌食。于中初先结前生后。次辨。后结。辨中先教修习厌想。后教正愿。前教厌中初观四食无常苦等是可厌恶。后观段食不净生厌。复就前中先别后结。别中先观段食生厌。有三复次。一观诸法无常苦等不应为食起三种恶若为贪食起三种恶所得财共苦无分者。二观由食生身心苦。苦中得食不应贪乐。三观饮食能增长身。我为舍身不应贪食。观余三食及后总结文皆可知。观不净中初先正辨。迦叶言下辨观虚实。前中初举。何以下释。是名下结。后中先问后答可知。教修愿中先举邪愿诫之令舍。后举正愿叹之令学

次明修世不可乐想。于中初先结前生后。下正辨之。辨中有五。初一切处皆悉具有生老病死故不可乐。二一切处无进不退故不可乐。三一切世间具受苦乐流转不定故不可乐。四观世间舍宅已下明一切物无不是苦。五观世间非归依处故不可乐

次明死想。于中初先结前生后。次辨。后结。辨中初先正修死想。我今设得七日已下励意修道。前中有二。一观念无常。先法次喻。迦叶言下问答辨相。二智者观命系属死下观分段无常。于中初先观命属死。智复观命如河岸下观死坏命。先举六喻。后合可知。下以死想励意修道

上来起观。下明观益。能成七想。如上六想即七想因牒前生后。下辨七想。初问次列。畏死勤修名常修想。乐求常法名乐修想。观诸众生为苦煎迫生慈愍心不欲恼害名无嗔想。念诸众生无常流变无所恃怙不生嫉忌名无妒想。于乞食时常修正愿名善愿想。观身无我舍离慢高名无慢想。厌离世间专心定意名于三昧自在想也。下叹显胜。先叹有行。名善解下叹其有解。前中初先叹其自行。名大医下叹其利他。自中初言是名沙门名婆罗门叹其人也。以能息恶故名沙门。梵行无染名婆罗门。下叹其行。先叹因圆。到岸果极。因中寂静洁解脱叹其断德。不起恶业名为寂静。离烦恼染说为净洁。免离众苦说为解脱。智者正见叹其智德。知过求出故名智者。识是达非称曰正见。到果可知。利他可识。下明解中是名善解如来密者解上如来随自随他随自他等三种语也。亦知诸佛七种语者知上因语至如意语。初先自知。后断他疑下释后四。能呵三界释多过想。远离三界释前离想。灭除三界释上灭想。于三界中不生爱着释无爱想

自下第四总以结叹。是名具十是总结也。若有具下是其叹也

上来第一问答辨法。自下迦叶荷思赞叹

陈如品者。就此辨修成德分中大判分二。三告至此约对影响辨修成德。由前广论诸比丘等便能悟入。故下第二重复对之辨修成德。所为人中陈如为首。佛偏对之。即就其人以题章目名陈如品。就此品中初至获得寂静色来是其辨修成德所摄。因灭无常苦空等阴名为辨修。证得常乐我净等阴说为成德。有十五句。初之六句约对果阴辨修成德。色无明下有其九句。约对因阴辨修成德。准验斯文。旧人相传言佛无色大成谬矣

若有人能如是知下第四破邪通正分也。于此分中对破外道以通正义。对破众魔以通正说。故名破邪通正分也。文中有三。一赞正毁邪以召邪徒。二邪众云集。三如来对破

初中复三。一赞其正。若人能知是名沙门名婆罗门明其有人。具足沙门婆罗门法明其有法。二毁其邪。初先直非。若离佛法无有沙门无婆罗门明其无人。亦无沙门婆罗门法彰其无法。一切外道虚假诈下举诈显无。初先直辨。何以下释。三我常下彰己所吼类劝陈如。赞正毁邪名师子吼

第二段中文别有四。一诸外道闻毁咸嗔求欲告佛。云已众中有人有法。二诸外道诽毁如来以相安慰。三因前诽毁有人赞佛众闻求试。四诣王求听王引见佛。初中先嗔。后共详议。第二段中四人发言。初人言佛所作如狂不足可忧。第二言佛宣说常等诱我弟子深是可愁。第三言佛妖幻不真不久磨灭不须愁虑。第四言已愁恼为物彰已能灭以安众心。此第二竟

第三段中文亦有四。初有外道叹佛有德不应与诤。二众闻嗔呵。三因众呵广叹佛德。四众闻求试。文皆可知。第四段中文亦有四。一共诣王所王见嗔呵。二赞王求试王复嫌责。毁王赞已王便听许。四王引诣佛彰彼欲问请佛为答。文皆可识。此第二段邪众云集

自下第三如来对破以通正义。问人有十。始从阇提终至须跋。此十人中三门分别。一就见分别。阇提婆私邪见外道。说涅槃法为无常故。先尼迦叶我见外道。富那及净边见外道。犊子是其疑心外道。疑道有无并疑得者。纳衣是其自然外道。说一切法皆自然有不从缘生。此亦其是边见所摄。弘广须跋戒取外道。弘广执取乞食为道。须跋执取苦行为道

二所显分别。对初二人明涅槃法。对彼阇提明了因所显性净涅槃。对婆私吒明断障所得方便涅槃。对次四人明其理法。于中初对先尼迦叶明无我理。对后二人明非断常中道之理。对后四人明圣道法。对彼犊子明其有道及有得者。对彼纳衣明道缘生非是自然。对彼弘广明修者得不修不得。对彼须跋明调心是道非是苦行。实观是道非世八禅

三随文辨释。就初人中文别有四。一标举问人。二执邪难佛。如来对破。三请佛正义。如来为解。四求出家。如来能许。初段可知

第二段中先难后释。难中初先难破涅槃常乐我净。若瞿昙说亦常已下遮佛二语。前中先别。后总结难。别中初先难破常义。先定如来。汝说涅槃是常法耶。佛答如是。下就设难。若常不然牒以总非。何以下释。如世间法举事类征。瞿昙常说修无常下当法正难。有四复次。一修无常想获得涅槃故是无常。二断贪等以为涅槃故是无常。三从因解脱故是无常。四明涅槃若同五阴即是无常。若离五阴即是虚空。于中初明五阴缘生故是无常。后将解脱对之征难。同即无常。异即是空。若同虚空即非因生难我乐净。各别一句。一切因生皆无常下总以结难。阇提恐佛被征转计宣说亦常亦无常等故下遮之。于中三句。一逆取佛说推为二语。瞿昙若说亦常无常亦苦乐等岂非二语。二列昔所闻明佛无二。三瞿昙今下约之征佛。说于二语自言是佛是义云何

下佛答中先对前难解涅槃常。却对后遮明已无二。前解常中初先取其所立性因决通已义。汝等法中有二因下就其所解生了二因释通已义

前中有六。一共要定。我今问汝随汝意答彼答言善。二问汝性为常无常彼答是常。三问是性能作一切内外因耶彼答如是。四佛问云何彼具辨之。道言从性生大等者此迦毗罗仙人所计。彼仙获得世俗五通。见过去世八万劫事。八万劫外通力不及冥然不见。便作是言八万劫外不应无法应有冥性。从彼冥性起于最初觉知之心名为生大。以此受生之原首故。百论之中名初生觉。从此复起彼中阴中受生我心说之为慢。我是慢故。百论之中说为我心。从此我心生二种法。一色二心。色中合有二十一种。谓从我心生五微尘。所谓色声香味及触。从五微尘生于五大。所谓地水火风及空。从彼五大生于五根。所谓眼耳鼻舌及身。从彼色尘生于火大。火大生眼。眼还见色。从彼声尘生于空大。空大成耳。耳还闻声。从彼香尘生于地大。地大生鼻。鼻还闻香。从彼味尘生于水大。水大生舌。舌还别味。从彼触尘生于风大。风大生身。身还觉触。彼说五尘俱生五大大俱生根。向前所论从强为言。此前十五并五业根及心平等根。通前合有二十一法。五业根者手脚口声男根女根。心平等者是其内心。五大齐成故曰平等。大齐成故心识多依。色法如是。所生心中有其三种。谓染粗黑。染者是贪。粗者是嗔。黑者是痴。此三皆是受生烦恼。于受生时男即于母生爱名染。于父生嗔名之为粗。女翻可知。无明不了说之为黑。通色合有二十四也。然今文中先明生色。初言从慢生十六法谓地水等据末超举。五大五根五作业根及心平等是十六法从五法生谓色声等却举五尘。下明心法。是二十一根本有三总以标举。染等列名。染者名爱会名显示。是二十五皆因性生总以结之。前所生中有二十六。大慢为二。色法之中有二十一。心法有三。今以何故言二十五。五业根中男女二根随人不并。是故但云二十五矣。此四段竟。五佛问大等是常无常。彼答性常大等无常。六佛取其言决通已义。如汝法中因虽是常而果无常。我佛法中因虽无常果常何过。此初段竟

自下第二就其所解生了二因释通已义。有七复次。一问汝法有二因不彼答言有。二问云何彼列其名。三问其相彼具辨之。四问二因得相作不彼答不得。五问二种虽不相作有因相不彼答言有。六问了因同所了不彼答不同。七佛取所答释通已义。我法虽从无常之因获得涅槃而非无常

上来一段对其前难解涅槃常。自下第二对其后遮明无二语。于中有三。一对上问中瞿昙若说亦常无常亦苦乐等岂非二语明已不二。了因得法是其常乐我净义故佛说常等。生因得法无有常乐我净义故佛说无常苦无我等。是故如来所说有二结成前二。如是二语无有二者就前二语释成无二。于一法中各施一言故曰无二。是故下结。二对上问中我曾闻说佛无二语明已无二称昔所闻。于中初言如汝所闻佛出于世无有二语牒前问词。是言善哉叹昔所闻。所闻当今故曰善哉。三对上问中瞿昙今者说于二语言佛我是是义云何明已无二故得是佛。于中两句。一对诸佛明语无二。一切诸佛所说无差是故说言佛无二语正明无二。云何无下释无差相。了因所得同说有其常乐我净名同说有。生因所得同说无其常乐我净名同说无。二约诸法明语无二。如来世尊虽名二语为了一语正明无二。云何下释。先问后解。为使阇提更解异法。故就眼等而解释之。眼色两别名为二语。生识义同名为一语。乃至意法亦复如是

上来第二执邪难佛如来对破。自下第三请佛正义如来为说。于中有三。一请正义如来为解。二彼彰已解如来反试。三彼申已解如来述赞。初中先请二语了一。如来约就四谛辨之。第二可知。第三段中阇提初先自宣已解。言苦凡二圣人一者。凡夫但知六道事别名之为二。圣知皆苦所以言一。乃至道谛凡夫但知行事差别名之为二。圣知诸行道义不殊故名为一。佛赞可知。此第三竟

自下第四彼求出家如来听许。于中初求如来敕度。陈如度之。彼获圣果

第二人中文亦有四。一举问人。二执邪难佛如来对破。三请佛正义如来为说。四婆私证果辞佛取灭。初段可知

第二段中有四问答。一问如来涅槃常耶。佛答如是。二问如来将不宣说无为涅槃。佛答如是。三难如来若是无者便同四无。云何言有常乐我净。于中初先辨立四无。下将涅槃对之设难。下佛答之。辨明涅槃但是互无非余三种。如是涅槃非先无者不同第一。一切众生从本已来有涅槃性故非先无。亦非灭无不同第二。一证永寂故非灭无非毕竟无不同第四。诸佛有故。同异无下明同第三。先总标举。下别显之。先就世事辨互无相。后约显法。此第三番

四重征如来若是异无涅槃便非常乐我净。下佛答之。彰世互无。即带三无故是无常。涅槃之法唯是互无不兼余义故是常等。于中三句。一简粗异细。汝说异无牒其所立。有三种无总显其相。下别显之。牛马悉是先无后有有未有无。已有还无有已灭无。异相无者如汝所说有其互无。佛若更辨不异婆私。故言异相如汝所说世间互无。带此三无故是无常。二辨细异粗。向前三无涅槃中无是故涅槃常乐我净。三世有病下就彼涅槃互无法中广解常义。以诸烦恼是无常故。涅槃无之得名为常。于中三句。一立喻显法。先举三病。次列三药。下彰病治不得相有。二约喻显法。先举三过。次列三治。下彰过治不得相有。三就之辨释常无常等。三种病中无三药故生死无常无我乐净。三种药中无三病故涅槃得有常乐我净。此第二竟

自下第三彼请正义如来为说。于中亦三。一请正义如来为说。二彼彰已下如来反试。三彼申已解如来述赞

自下第四明婆私吒证果取灭。于中有四。一佛彰其人已得罗汉劝施衣钵陈如施之。二凭陈如请佛忏谢并辞取灭陈如为通。三佛彰其人宿善今成已得正果劝供其尸陈如往供。四垂灭现变外道轻谤

先尼迦叶同皆计我。先尼所计亦即亦离。作身是即。常身是离。迦叶执异

就先尼中文亦有四。一举问人。二执我难佛如来对破。三请正义如来为说。四求出家如来听许

第二段中先尼初先问佛我义佛默不答。郑重至三。佛欲令其自立我义随而对破故默不答。先尼下复自立我义如来对破。彼立我中众生有我遍一切处以为一门。是一两门。作者三门。何故默然责佛不答。此佛别破宜须记知

就破遍中有四复次。一定其所立。汝说是我遍一切处。二先尼为定。不但我说一切智人亦如是说。如来对破。若我遍者应当五道一时受报。若一时受汝等何缘不造众恶为遮地狱修善求天。三先尼被征建立二我。常身作身。为作身我故须离恶以防地狱修善生天。如来对破。汝常身我遍一切处。若作身有即是无常。若作身无我即不遍。四先尼被征重复救义。我所立我亦在作中亦是常法法说救义。如失火等喻说救义。我亦下合。是故下结。文显可知下佛破之。先破法说。后破其喻。就破法中汝说亦遍亦常不然牒以总非。何以下释。于中初先以理正征。遍即有二常与无常复有二种色与无色。法外是常。在法无常。法外非色。在法是色。是故若下重复结征。若一切有亦常无常亦色无色不得偏常不得偏色。就破喻中若舍主出不名无常是义不然牒以总非。何以下释。舍不名主主不名舍异烧异出故得如是简喻异法。烧舍异人名为异烧。人出异舍称曰异出。我即不下简法异喻。不尔略简。何以下释。以我遍故在色中者我即是色色即是我。在色外者无色即我我即无色。云何言下结呵其言

次破其一。有八复次。初牒正破。汝意若谓一切众生同一我者牒其所立。违世出世略示其过。何以下释。初明违世。此即彼等违其出世。是故若下结以显过

二先尼救义。我亦不说一切众生同于一我乃说一人各有一我。如来对破。若言各有是为多我是义不然牒以总非。何以下释。于中初先以遍破别。汝说我遍若遍一切一切众生业根应同见闻无别。若天得见非佛得下以别破遍。若不遍下以其不遍难破常义

三先尼救义。其我虽遍法与非法不遍一切是故众生业根不同见闻各别。如来征定。法与非法非业作耶。作业名业。因作所成罪福等行名法非法

四先尼为定。是业所作。如来征破。若法非法是业作者即是同法云何言异牒以略征。何以下释。于中初法次喻后合。法中初言佛得业处有天得我天得业处有佛得我明我互遍。天得佛得是其人名。佛得作时天得亦作明业互造。彼此之我充遍一切共造业故。法与非法亦应如是征令因同。我遍一切同造业故。法与非法若如是下征令果同。喻中初言从子出果子终不思我唯当作婆罗门果不与刹利毗舍等作正立等喻。明外种子随其种者即为作果无所简别。何以下释。合中初言法与非法亦如是等。正合前喻。何以下释。业平等故应通不别。彼此共造故曰业等

第五先尼立喻救义。下佛对破。先牒总非。何以下释。释中有三。一以光遍室类我周遍破无互造。二若法非法无有我下以灯光明不遍炷中破我周遍。三汝意若谓炷明别下以明即炷破我异法。初中何故征前起后。下对辨非。室异灯异是灯光明亦在炷边亦遍室中辨其喻相。何故须道室异灯异。为显灯光遍于异处类彼神我充遍异处。下将类我。汝所言我若如是者如前灯光在于炷边。亦遍室中。法非法边俱应有我同前灯光在于炷边。我中亦应有法非法同前灯光亦遍室中。明遍室故明中有炷。我周遍故我中亦应有法非法。以我在于法非法边。我中有其法非法故。诸业共造不得别异。第二段中若法非法无有我者不得言遍明法同喻有不遍过。是义云何。炷中无明。我若似明法非法中即无有我。若法非法无有我者何得说言我遍一切。若俱有者何得复以炷明为喻明我周遍有乖喻过。是义云何。若说我遍法非法中与灯前别。汝复何得以炷喻于法与非法光明喻我。第三段中汝意若谓炷明别异举其所立。何因缘故炷增明盛炷枯明灭破别显即。下约征法。于中有二。一明我异法有乖喻过。是义云何。前辨灯喻明不离炷。彼所立我与法全别。故今征之。是故不应以法非法喻于灯炷光明无差喻之于我。是灯光明不异于炷不同汝我。与法非法一向别故。不应以炷喻法非法明喻于我。文中颠倒故言不应以法非法喻于灯炷。二何以下明我同喻有其即法无常之过是义云何。灯明即炷。若我同之。法与非法应当是一不得言别。文中初言何以故者征前起后。我前何故责汝不应以明喻我炷喻法等。下对显过。汝所立我若同灯喻与法非法三事即一不得言别。此第五竟

自下第六先尼责佛所说不吉。汝所引喻是事不吉总责如来。何以下释。灯喻若吉我已引竟如其不吉何须复说。下佛答之。辨明此喻于汝不吉故将破汝。于我是吉故我宣说。文中有三。一如来总对。我所引喻都亦不作吉与不吉随汝意说。二约喻征责。三如是喻下正对其言辨吉不吉。初段可知。第二段中别有四句。一正其喻相。是喻亦说即炷有明离炷有明。炷增明增炷枯明灭名之为即。明遍室中亦在炷边说之为离。举此即离为取即义。破彼先尼我与法异。二汝心不下准喻呵责。喻中有即亦有异义。汝心不等一向立异说炷别喻法与非法明别喻我。三是故下如来重复显已责意。是汝不等偏执离故。我今责汝即炷有明离炷有明即离有明。是初句中即离之喻。法即有等准喻类法。喻中既有即炷有明法亦应尔。法即有我我即有法非法即我我即非法。四汝今下准法重责。准喻推法。法中亦有即离之义。汝今何故但受离边不受即边。此第二竟。自下第三正对其言辨吉不吉。初明此喻于汝不吉故用破汝。次明此喻于我是吉故我说之。汝意若下遮其异责。彼闻佛语喜生心想。若我不吉汝亦不吉故今遮之。先举直非。何以下释。先举世人自力自害。后推同之

七先尼重复责佛不平。先责。次释。以是下结。下佛答之。于中两句。一将我不平破汝不平令汝得平即是我吉。佛正乖邪名我不平。破邪同正名令汝平。是佛化善名为我吉。二将我不平破汝不平令汝得平即是我平。邪正相翻故我与汝俱名不平。以正破邪名我不平。破汝不平使彼同正名令汝平。佛正同彼名为我平。何以下释

八先尼重复说我为平。如来对破。句别有三。一就五趣当受征破。先取其言。后约征责。二就父母生子以破。先取其言。后约破之。三重就五趣求离以破

自下第三破我作者。文别有二。一佛难先尼先尼救义如来对破。二先尼难佛如来释通。前中有四。一难破我作。二汝意若谓身作已下难破先尼身作我受。三若言不是身作已下破无作受。四先尼言我有二下难破先尼我知我脱。初中先牒。总非不然。何以故下广显其非。有七复次。一以造作苦事难破。我是默法何由作苦。初先正破。若言是苦非我作下遮苦无因。二众生苦乐实从缘下举苦乐等不定难破。三汝说已下举其十时变异难破。四亦有盛下举共盛衰不定难破。五云何一人有利钝下举其利钝不定难破。一人身中信等五根利钝不定明知无我。六云何说下以其口说无我难破。七汝意若谓离眼见下约见难破。于中有三。一破我能见。初牒直非。何以下释。若离眼已别有我见何须此眼。余根亦尔。二破因眼见。汝意若谓我虽能见要因于眼是亦不然牒以总非。何以下释。举喻类显。如须曼那能烧大村举其喻事。须曼人名。云何能烧因火能烧定其喻相。下约显法。见亦如是虽言我见见实是眼。三因先尼立喻救义随之转破。句别有四。一辨喻异法难破我作。喻中人镰各别有体。故人执镰能有所作。根外无我云何说言我因根作。二就手有无难破我作。先定有无。下就设难。若我有手何不自执。若我无手不能执镰云何我作。三辨刈是镰难破我作。若我能刈何故因镰。四明人镰作业各别难破我作。先辨人业。次辨镰业。下约显法。众生见法亦复如是总约显法。眼能见下别约显法。眼如镰也。若从缘下举理结呵。此初段竟

自下第二难破身作我能受义。先牒直非。何以下释

自下第三若言不是身作已下破无作受。先举后破。两义破之。何缘求脱是一破也。得解脱已更生身恼是二破也

自下第四难破我知我得解脱。于中先尼先立二我以救前义。由佛前言若身不作我非因受何故求脱得解脱己身恼更生。故今救之。我有二种知与无知。无知得身。知我得脱。更无因缘。知我脱中初明知我能离于身。如坏瓶下能离烦恼。先喻后合。下佛破之。先破我知。智能知耶我能知乎进退两定。下就难破。若智能知何故言我存智破我。若我知者何故求智存我破智。汝意若下破我因智而能得知。先举其见。同华喻坏指同前破。前者破我因眼能见如须曼那能烧大村烧实是火。此亦同彼。虽言我知实是智知。下约喻显。譬如刺树刺自能刺不得说言树执刺刺。智亦如是智自能知云何说言我执智知。下破我脱。汝我得脱举前所立。无知我得知我得耶进退定之。若无知得犹具烦恼破无知得。无知之我性是痴騃。得脱犹痴名具烦恼。若知得下破知得脱。于中先就有根破之。若知得脱得解脱已应具五根是一破也。何以下释。离根之外无别知故。若具诸根云何复名得解脱耶是二破也。下复就其无根以破。若言我净。离于五根云何说言遍五道有破我离根。五道之身五根为体。既无五根云何言遍。以何缘下破我清净。于中三句。一以我净责须修善。二譬如下以我清净责须断结。先喻后合。三汝意若谓不从缘下遮脱无因。先尼被征喜立无因故须遮破

上来第一先尼救义如来难破。自下第二先尼难佛如来释通。于中有五。一难如来若无我者谁能忆念。下佛反破。若有我者何缘复忘是一破也。何因缘故念于恶等是二破也。二难如来若无我者谁见谁闻。下佛为解。于中初明和合见闻。如苏面下和合说我。前中初法次喻后合。如是眼识不在眼下明和无性。若是因缘和合生下呵说有我。是故我下结识虚幻。是识缘和无自性故我说如幻。云何下释。下明和合说我之中先喻后合。三先尼问佛。若无我者云何说言我见闻等。下佛先破。若我见闻何缘复言汝所作罪我不见闻。下为辨释。虽无定实假名言我。先喻后合。四先尼问佛。若无我者谁出声言我作受等。下佛为解。初法次喻后合可知。五先尼问佛。无我我所何缘复说常乐我净。下佛为解。初明不说根尘及识为常乐等。下明灭此方得名为常乐我净。先辨后结

上来第二执邪问佛如来对破。自下第三请佛正义如来为解。于中还三。一请佛义如来为说。有两问答。前一问答呵舍慢高。后一问答正为解义。二彼彰已解如来反试。三彼申己解。色非自者色法虚幻无自性也。言非他者无神我性。非众生者无阴所成众生体也。余亦如是

四彼求出家。佛命善来即获道果

第四人中文亦有四。一举问人。二执邪问佛如来对破。三请佛正义如来为说。四求出家如来听许

第二段中文别有二。一问如来身命一异如来不答。欲令立义随而对破故默不答。二迦叶自立身命定异如来对破。有五问答。一立异义如来翻破明身与命皆从因缘不得定异。二举世事证不从缘如来反问。三彼出其事如来翻答亦从因缘。四问佛缘相如来为辨。五就法征问。有人舍身未得后身谁为因缘。如来为释。先出其缘。次辨一异。有因缘故身即是命命即身者。现阴相续名之为命。此命即身。有因缘故身命异者。舍现阴身趣向后世中间相续不断命命。此命异于现阴之身名之为异。亦可非色非心命根。通亦是其五阴身摄名之为即。于中别分色心与彼命根别体说之为异。此即与异同藉缘生故曰有缘。不应已下呵说定异

自下第三请佛正义如来为说。于中亦三。一请佛义如来为解。二彰己解如来反试。三彼申己解

第四段中初求出家次佛听许。陈如后度。彼获圣果

次下两人边见外道。同皆建立十四难义。就富那中文四如上。初举问人。二执邪问佛如来对破。有两问答。一举外道十四难经问佛说不。佛答不说。常无常等妨入圣道名之为难。又乖正法亦名为难。难别不同。宣说十四。常无常论有其四种。有人宣说神及世间定常为一。无常为二。亦常无常以为第三。非常非无常以为第四。边无边论亦有四种。有人宣说神及世间有边为一。无边为二。亦边无边以为第三。非边非无边以为第四。如不如等亦有四句。如来灭后如去为一。如从前来去向后世故名如去。不如第二。有人宣说身死永灭不如前来向后世去名不如去。亦如不如以为第三。有人宣说身与神异身死神在如从前来向后世去名亦如去。身即永灭不如前来向后世去名不如去。非如不如以为第四。有人宣说神如虚空不可说去及以不去名非如去非不如去。此为十二。有人宣说身命定一有说定异通前十四。此之十四龙树广释。别章具论。富那下复重问如来。见何罪过不作是说。如来为辨。若作是说心有取执名为见取。取执所缘名为见处。见能集起未来苦果名为见行。造作邪行名为见业。坚执所缘名为见着。为见系缚常在三有名为见缚。因见生苦名为见苦。取非为是名为见取。由见便有三涂可怖名为见怖。为见烧燃名为见热。缠心不离名为见缠。凡夫人下明由前见多受苦恼。我见是下结已不说。此第二竟

三请佛正义如来为说。于中有二。一请佛义如来为说。二请说已下领解赞叹。前中有三。一问如来何见何着何所宣说。佛答无著但有见说。夫见著者名生死等明无著也。名为见等明有见说。二重问佛何见何说。佛答能见能说四谛。于中初明所见所说。故能远下明由正见能有所离。是故我下明由正见能有所得。具净梵行得出世因获得出果。三问如来何缘得身非东西等。下佛为辨。先共可定。我今问汝随汝意答。下正辨之。句别有五。一问汝前燃火知不彼答言知。二问火灭汝知灭不彼答言知。三问彼火燃从何来灭何所至彼具答之。四问火灭至何方所彼具答之。五取其所答用显已身

领解叹中初请说喻。如来次听。下正说喻约之显法。村者喻于二十五有。林喻众圣。一树喻佛。起行久远名先林生。林主喻于大涅槃经。宣说益人名灌以水。称机巧益名随时修。障根腐败名树陈朽。妄染斯除名皮肤落。实德明显名唯贞在。显法可知。此第三竟

四求出家佛命善来彼证圣果第六人中文亦有四。一举问人。二举邪问佛如来为辨。净与富那同皆建立十四难义。佛前已对富那破竟。净今此处不敢更立。直问世人取舍所由。如来为解。初问众生不知何法见世常等。佛答不知色阴至识。后问众生知何法故不见常等。佛答知色乃至于识。三请佛正义如来为说。于中亦三。类上可知。四求出家如来听许

对下四人辨明道法。对彼犊子明其有道及有得者。对彼纳衣明道缘生非是自然。对彼弘广明修者得不修不得。对彼须跋明调心是道非是苦身。圣慧是道非世八禅

对犊子中文别有三。一举问人。二问佛义如来为辨。三求出家如来听许。第二段中文别有三。一彰己欲问佛默不答。良以犊子数来见佛情喜赊慢不堪受法。佛为严励故默不答。二犊子重请如来听问。言我与汝共为亲友义无二者通情无别故言无二。三犊子正请如来为说。于中复三。一问其法如来为说。二问其人如来为辨。三领解赞叹。前问法中先问善法如来为辨。次问恶法如来为辨。后双问之如来为辨。我能广说简略说之示说分齐。下正说之。于中先说三善三恶。次为宣说十善十恶。我今已下双结前二。若我已下结明知益。就问人中初就罗汉问有得不。佛答无量。次就那含问有得不。佛答无量。断五下结如上具辨。后就须陀及斯陀含问有得不佛答无量。三领解赞叹。文显可知。此第二竟

自下第三彼求出家如来听许。句别有六。一问如来外道出家几月试之。佛答四月不必一种。二求出家佛敕令度。三陈如度之彼悟初果。四重请佛法如来为说。五彼修得果辞佛取灭比丘为通。六佛敕供养比丘往供

第八人中文亦有四。一举问人。二执邪难佛如来对破。三请正义如来为说。四求出家如来听许。第二段中纳衣初先建立自性。后佛对破。前中准破应有十句。文但有九。第六少一。五根性纳见闻觉知证法自性。文中虽少准破必有。其第一句难破身因成法自性。如瞿昙说作善不善得身亦然举以总非。何以故下别难显非。如瞿昙说因能获身重举佛说。若因恼得身为在先烦恼在先进退征定。次就设难。若烦恼先谁之所作。若身在先云何说言因恼得身。下结显非。若烦恼先是亦不可结非初句。若身在先是亦不可结非后句。先后一时义俱不可双非两关并破一时。是故我下结成自性。二就五大建立自性类一切法。于中先明五大自性非因缘有。下将类法。若有一法非因缘有一切亦应非因缘有以大类法。若有一法从于因缘何因五大不从因缘以法类大。三众生善身及不善下明得解脱自性非因。初先正辨。是故下结。此之一句正违道法。如来对破。明道缘生非是自然。宜审记知。四有定用下明一切法用处各定证有自性。先就外论。后类众生。五一切众生性各异下明诸众生禀性各异证有自性。于中初法次喻后合。第六番中所少一句明其五根性能见闻乃至觉触明法自性。文虽不说准答定有。七如说贪下难破如来五尘生结成法自性。先牒直非何以下释。释中五句。一明众生睡时离尘亦生贪等明非尘生。二举胎中亦生贪等明非尘生

三明众生初出胎时未能分别亦生贪等明非尘生。四明仙圣在无尘处亦生贪等明非尘生。五明众生有因五尘生不贪等明非尘生。此第七番。八见世人根不具下以诸众生依正不等证成自性非因缘义。九以小儿啼喜不定证法自性。第十以其虚空之有兔角之无不从缘生证法自性。于中先举次列后辨。是故下结

下佛对破。其文不次。先破第二五大类法。次破第四第五第三第十第一。重破第二。下复破彼第六第七第八第九。以何义故先破第二五大类法。五大正是外道所立是以先破。文中初先牒以总非。何以故下别征显非。是中但破五大类法未破五大。汝大是常何缘一切不悉是常准大征法难破纳衣以大类法。世物无常是五大性何因缘故不是无常准法征大难破纳衣以法类大。若五大常世间之物亦应是常类责纳衣以大自性类法自性。是故汝下约类结非。是五大常世间之物不是常故。汝说五大有其自性令一切法皆有自性无有是处。次破第四用定证性。先牒直非。何以下释。从因得名从因得义略释显非。云何下广。是故下结。次破第五。汝言如龟性入水等举以总非。何以故下破以显非。次破第三。善不善身得脱非因。汝言自性不须教习是义不然举以总非。何以下释。释中三句。一即事以验。今见有教缘教增长是故当知解脱非性。二以外道杀羊祠祀而求净身明脱非性。三以三语证脱非无。先举次列。下就征责。若脱自性不从作生何故世中有是三语欲作作时及说作已。次破第十。以空兔角不从因缘类法有性。若言诸法有自性者举其所立。当知诸法各有定性纵以审定。下对破之。若有定性甘蔗一物何缘作浆作石蜜等是一破也。若有定性圣人何故饮甘蔗等是二破也。汝说有性云何说喻是三破也。次破第一。先非难词。后为正解。前非难中汝言身先烦恼先者是义不然牒以总非。何故下释。若我当说身在先者汝可难言汝亦同我反举己说呵其难词。身不在先何因缘故而作是难顺举己说非其难词。是义云何。若我曾说身在先生。汝今纳衣可得难言瞿昙汝亦同我身先无因应是自性。我说是身不在先生。何因缘故而作是难言身无因令是自性

下为正解。于中有二。一身望无明同时相依。如梦中身依于睡心。二身望四住前后相依。先依无明起四住地。依四住地集起身报。问曰无明依何而生。依真识生。真识依何。真法常住犹如虚空更无所依。文中先明同时相依。一切众生身及烦恼俱无先后一时有者与无明地一时有也。问曰前说依无明地起于四住。依四住地方始有身云何一时。释言无明始终常有。身起之时必依无明故说一时。如梦中身必依睡心。虽一时有因恼有身终不因身而有烦恼分定本末。汝意若下遮防异难。先举难词。直非不然。何以下释。类以显之。如炷与明虽复一时明要依炷非炷依明彼亦同尔。下次明其前后相依。汝意若谓身不在先知无因者是义不然总非无见。此言略少。若具应言汝意若谓身不在先有因缘故知无因者是义不然。何以下释。释中三句。一遮说无因。若以身先无因缘故名为无者汝不应说正遮说无。一切有因举理显非。二教说有因。若言不见身先因缘故不说者。今见瓶等从因缘生何故不说。正教说因。如瓶已下举粗类细成须说因。三若见下总结诸法从缘无性。瓶因所见身因不见。一切从因无有自性。自下重破。第二句中五大自性。何故须重。前虽破其五大类法未破大体故重破之。于中有三。一约五大破法自性。若言一切悉有自性无因缘者举其所立。汝何因缘说于五大责说有因。是五大性即是因缘辨因破性。二呵以五大类法自性。五大因缘虽复如是不应说法皆同五大当相正呵。外道宣说五大自性因缘悉无。佛今权纵是以说言五大因缘虽复如是悉无所有。亦不应说一切诸法皆同五大因缘悉无。如世人下举事类责。汝将五大类一切法皆有自性。与世人说出家之人持戒精进旃陀罗等亦应精进持戒相似。三正破五大。汝说五大有定坚性我观是性转故不定举以总破。有定坚性就始为言。若具应言有定坚湿暖动等性。下别破之。先破地大。苏蜡胡胶于汝法中名之为地举其所立。是地不定或同水等以转破之。次破火大。白蜡锡等于汝法中名之为火举其所立。下破可知。下破风水。水性名流辨定水相。若水冻时不名为地故名水者定其所立。何因缘故波动之时不名为风举风决破。若动不名风举风征定。冻时亦应不名为水举水决破。是义云何。水性名流。与寒冷合便成冻结。风性飘动与水和合便成波浪两义相似。今就征责。水性名流若水冻时不从冷缘说之为地。仍就本性说为水者。风与水合成波之时应从本性说之为风。何因缘故波动之时不名为风乃名为水。若波动时不就本性说之为风。乃从水缘说为水者。冻时亦应不就本性说之为水。应从冷缘说之为地。下以此二类显诸法。若水从缘可变为地风从因缘可为水者。诸法皆尔。何得说言一切诸法不从因缘。下次破前第六所少五根性能见闻觉知。先牒直非。何以故下破以显非。自性不转立其道理。若言下破。是故下结。第七汝言非因五尘生贪解脱是义不然牒以总非。何以下释。释意如何。彰彼五尘虽不作因生贪解脱非不作缘。文中初言生贪解脱虽不因尘简缘异因。恶觉观等简因异缘。因生外增双辨二能。是故已下结呵难词。次破第八依正不等证法自性。先举直非。何以故下释以显非。于中先释次破后结。释中众生从业有报对难总释。有三下别先举。次列。下就辨释贪富诸根是业各异。故根具者不必有财。财宝丰者不必具根。破结可知。次破第九小儿啼喜证法自性。先牒直非。何以下破。是故下结。此第二竟

自下第三请佛正义如来为说。文亦有三。一请佛义如来为解。有三问答。文显可知。二彼彰已解如来反试。三彼申已解如来赞叹

第四段中彼求出家。佛命善来即获道果

第九人中文别有三。一举问人。二问佛义如来为说。三闻法发心。第二段中文别有四。一问如来心中所念佛为辨之。二彼闻怪问如来为解。三问八圣能令众生得尽灭不如来不答。四问默意陈如为释。若有问世有边无边如来不答类显默意。八圣是直涅槃常下当问正解。若修便得不修不得为是如来不得定答。于中初法。次以喻显。城喻涅槃。涅槃绝漏名无孔窍。门喻八正。守者喻佛。佛具明解名聪有智。善达物机名善分别。有机教入名之为放。无机未教说之为遮。所知众生进退难定故言不知出入多少。定知入者斯由八正。故言知入皆由此门。下合可知

第三闻法发心之中。弘广初先闻法赞叹发菩提心。自身欲作守门之者。陈如次叹。下佛呵之

第十人中文别有五。一佛问陈如阿难所在。陈如具答。二文殊问佛顾命之意。如来为释。三令文殊往救阿难。四阿难至令命须跋。五须跋至佛破显法

就初段中如来先问。何故问者备有三意。一欲以法付嘱令传。二欲使之呼命须跋。三欲因问知魔惑乱说咒降伏以通正法。陈如答中在娑罗外十二由旬彰其所在。为六万下明不来所由。于中初总。是诸魔下别以显之。别中初明魔惑阿难。何故如是。阿难是其传法藏人。恐佛付法令传末代所以乱之。于中初先化身为佛。次口说法。后身现通。下明阿难为魔惑乱不得赴集。阿难何故现为魔娆。欲使如来说咒降伏以通法故。阿难作念如来神变昔未见等为魔身乱。诸佛所说各不同等为魔口惑。下明阿难受苦无救所以不定

第二段中文殊先问。无量菩萨皆能持法何须顾问阿难所在。佛答有三。一明阿难德过众圣故佛偏问。二明不付菩萨所由。三明偏付阿难所以。前中复三。一明阿难未侍佛前先备三愿。二明阿难侍佛已来具八不思。三明阿难有持经八德故佛问之。初中有三。一佛自彰已昔于僧中求索侍人。五百罗汉皆求侍佛如来不受。二目连观佛心在阿难共往令作阿难不从。三目连以佛心念告劝彼方侍佛。于中四对。一目连总告汝今未知阿难请说。二目连为说彼求三愿。三目连为请如来听许。四目连反报彼方侍佛。道此语者为明阿难智过诸圣。此初段竟。第二可知。第三持经八德之中初举次列。后明阿难同余佛持。下总结之。此初段竟。第二不付菩萨可知。第三明付阿难之中初明阿难随闻具。持。故佛顾问欲令持经。次明阿难所未闻者弘广流布。深证之法阿难未闻菩萨能流一切菩萨智德宽大斯名弘广。亦可名前弘广梵志以为弘广。彼大菩萨故能流通。下明阿难所闻之者自能宣布

自下第三佛令文殊往求阿难。于中五句。一示其所在。二教往救。三文殊往救。四魔放阿难。五阿难被放寻与文殊共来见佛。第二段中曲有七句。一教宣咒仪。汝可往彼发大声言诸魔谛听如来今说大陀罗尼。二天龙下举多人同敬显咒殊胜。三十恒沙下举多佛共说显咒要胜。四能转下辨咒功能。五若受下明行咒仪。六当知下明行有益。七宣咒词。余皆可知

自下第四明阿难至令呼须跋。于中三句。一佛教往呼。二阿难往。三须跋来。初中先举所唤之人。次教呼词。后明阿难往呼必得。何以下释。后二可知

自下第五明须跋至佛破显法。于中有三。一执邪问佛如来对破。二云何能断一切有下请佛正义如来为说。三因佛为说多人获益。初中有二。一须跋欲问如来听许。二有沙门下须跋正问如来对破。于中有二。一举他所说请问如来如来对破。二世尊我已先调心下举自所得请问如来如来对破。前即破其苦行为因。后即破其非想为果

前中须跋先举他说请问如来。良以此非须跋自计。是故说言有沙门等作如是言众生苦乐皆随本业受苦能坏是义云何。佛破有二。一就他人自见以破。二我实不知从师已下就彼他人推师以破。前中有二。一破邪归正。二我佛法中有过业下辨正异邪。后中亦二。至时当辨。就初破邪归正之中文有四番。一对前问。若沙门等有作是说我为怜愍当往问之仁者实作如是说不。二彼若见答实作是说我复穷之仁者见不。先举答辞。我如是说是总答也。何以下释。释中四番。一见众生行恶饶财身得自在。修善贫穷不得自在。二见有人多役功力求财不得。有人不求自然得之。三见不杀反更中夭喜杀保寿。四见修净行有得解脱有不得者。是故下结。是前诸义故我宣说苦乐由本不由现在。下明如来穷诰之言。五句穷之。文显可知。此第二番。三彼若见答我实不知。我复引喻而为呵责。责相云何。如人被箭医师为拔。虽经多年忆之了了终不忘失。若使苦行实能为汝破坏往业。如医拔箭汝应常忆何缘不知。汝既不知云何说言现在苦行能坏过业。四彼人若引我之所说证知过业。我复语之此是比知不名真知。文中先举彼人所引。瞿昙汝今亦有过业何独责我过去业者总举佛说证有过业。瞿昙经中亦说已下别举佛说证有过业。又复举此为欲彰已见果知因非是不知。下佛责之。如是知者名为比知不名真知。我佛法中从因知果从果知因显比知相。既无真知。何得定说专由过业

上来四番合为第一破邪归正。自下第二辨正异邪。三番辨异。我佛法中有过去业。有现在业。汝即不尔唯过无现。是一异也。汝法不从方便断业。我法不尔从方便断。是二异也。汝业尽已即得苦尽。我即不尔。烦恼尽已业苦即尽。是三异也。是故责汝总以结呵

推师破中文亦有二。一破邪归正。二仁者定有过去业下辨正异邪。前中有四。一前人若言我实不知师作是说。我即问之汝师是谁。二若彼见答是富兰那。我复穷责汝昔何不一一启请大师实知过去业不。三彼师若言我实不知。我即教呵汝复云何受是师语。四彼师若言我实知之我即教破。破辞有四。一就现缘教令征破。先教审问。下苦因缘受中上苦不。乃至上缘受中下苦不。何者是其上中下缘。如一斛火以之为下。两斛为中。三斛为上如是一切。彼若言不我教征破。若依下缘唯生下苦。乃至上缘唯生上苦。是即此苦依现缘生。师云何说苦乐之报唯过去业不藉现缘。二约过因教令征破。先教征问。是现在苦过去有不。下就设难。若过去有。过去之业受之已尽。云何复受今日之身。若过去无唯现在有。云何复言众生苦乐皆过去业。三约后治教令征破。先教征问。若现苦行能坏过业。现在苦行复以何破。下就设难。如其不破此苦即常不可断灭。云何说言得苦解脱。若言更有苦行来坏。前苦行时过业已尽。云何得有后时之苦坏前苦行。四就转业教令征破。先教征问。如是苦行能令乐业受苦果不。乃至无报作定报不。下就征责。具应有二。一就不能而为征责。若言不能汝复何缘受是苦行。二就能设难。若言其能如是苦行能令苦业受于乐果。当苦行时何不受乐乃受于苦。就能设难文中略无

就后辨正异邪之中初就业果辨正异邪。仁者若以断业已下就其治断辨正异邪。前中有四。初言仁者定有过业现在因缘明有过因及有现缘。二是故下偏明过因。因恼生业因业受报。三仁者当知一切生下重明众生有过去因及现在缘。先举后释。四二者若说众生受下偏明现缘。若说众生受苦受乐定由过业是义不然非邪显正。何以故下辨正异邪。于中四句。一就乐事明由现缘。二如人杀下就其苦事明由现缘。三一切众生现在因下双就苦乐明由现缘。四是故下结

下就治断辨正异邪。句别有四。一就断业呵邪显正。仁者若以断业得脱一切圣人不得解脱举以示过。何以下释。众生过去业行广多无有始终。若以苦行受之无尽故无脱理。二是故我下辨正异邪。是业广多受叵尽故我说修道。是道能遮无始终业故得解脱。三就苦身呵邪显正。仁者若受苦行得道一切畜生悉应得道。四是故下辨正异邪。初先法说。是受苦行无得道故先当调心不调伏身。次以喻显。以应调心不调身故我经中说当斫伐林莫斫伐树。心过宽通事等如林。身过局别相似于树。举通收别故应伐林。别不摄通故不伐树。何以下释。从林生怖故应伐林。不从树生故不伐树。盗贼依林名林生怖。下合可知。上来须跋举他所说如来对破

自下第二举自所得如来对破。须跋先自彰己调心。如来反问云何能调。须跋次复显己调相。若别论之。应从欲界至无所有次第别断以求上静。但今文中总略论之。先断欲结得色界定。次断色结得无色定。后就无色断下三空得非想定。下佛破之。云何能调总呵其言。汝今所得犹名想下明其所得是想非灭。汝已先能呵责粗下呵着细想。汝师郁头蓝弗已下举师类呵。事如经说

上来破邪。自下第二请佛正义。如来为解。有三问答。初问云何能断诸有。佛答若观实相能断。二问实相如来略答。无相之相名为实相。三问云何无相之相。下佛为释。初先正解。是名实相名法界下结叹显胜。前中初先历就诸法明无相相。如是等相随所灭下解彼无相为实相义。如是等相随所灭处名真实相对前略解。一切诸法皆是虚假随其灭处名真实者重复显之。问曰经说一切诸法无起无灭。今云何言相灭名实。释言理体实无起灭。无起灭法缘起成相。相起覆真名为不实。息相称本故得名实。其状似何。如水性冷随火变热。是火灭已水冷如本称本水性故名为实。下结叹中先结后叹。结中五名。一名实相。义如前释。二名法界。界名为性。亦名界别。如来藏中恒沙法别故名法界。此之实相是法界中一门之义故名法界。三名毕竟智。离相穷极称曰毕竟。是智体性名之为智。又智行处亦名为智。故论说言说智智处同名般若。四名第一义谛。此理精胜故名第一。所以称义。实故名谛。五名第一义空。下牒叹胜。言是相者牒前实相。言法界者牒前第二。毕竟智者牒前第三。第一义谛牒前第四。第一义空牒前第五。下智观故得声闻等叹显胜也

自下第三因前所说众人获益。于中先明余人获益。后彰须跋得罗汉果。前中先明菩萨获益。次论二乘。后彰凡夫。菩萨人中阶别有九。从少至多渐次论之。或有菩萨经一生已便证实相名一生实相。经二生已证得法界名二生法界。五智印者知一切法无常苦空无我寂灭是其五也。问曰无相空理不殊何以得益有此差别。释言相息便证实性。是实性中法界门别。故令入者得益各异。又一部中所得利益此中并说。不唯闻空。此第四竟

第五分中如来灭度。人天大众阇维供养。外国不来由来不尽。故无付属奉行等言

大般涅槃经义记卷第十应永三年十月日以劝修寺大经藏本誂良秀阿阇梨书写了全部十帖当卷损失之故新所书补之也　法印权大僧都贤宝(六十四)宽政五年冬十一月十三日挍正此书全帙了愿以此功德共诸众生速证四德涅槃　　　　　　菩萨沙弥典寿(生年三十六)


大般若波罗蜜多经般若理趣分述赞

    No. 1695 [cf. No. 220(10)]

大般若波罗蜜多经般若理趣分述赞卷第一

        大慈恩寺沙门　基撰

  稽首离性相　　心言本空寂
  常住真三宝　　及我亲教尊
  理趣甚深法　　非我所能赞
  今依尊智悲　　加持力故说

瑜伽论第八十二云。诸说法师将欲开阐先当赞佛。或略或广。略赞佛者由五种相。一者妙色具三十二大丈夫相圆满庄严。八十随好间饰支体。光明照耀如大金山。二者寂静端严殊妙诸根闲寂。其心晏然。已能善得最上调顺寂止究竟。已能善到第一调顺寂止彼岸。善能密护降伏诸根。为丈夫龙无误失故。丈夫牛王御大众故。丈夫良马心调善故。清净无挠如澄泉池。已能永拔烦恼习气。三者胜智。谓于三世及非世法无碍无著。四者正行六度四摄自他利行皆悉圆满。五者威德谓诸如来神通游戏威德炽盛。复有六赞。功德圆满故。离垢染故。无浊秽故。无与等故。唯利有情以为业故。于此业用有堪能故。广赞无边皆如彼说。既赞佛已要成十法名说法师。言十法者一者善于法义谓六法十义善能解故。二者能广宣说。谓多闻闻持其闻积集。三者具足无畏。胜大众中宣说正法无所怯惧。声不嘶掉腋不流汗念无忘失。四者言词善巧语工圆满。八支成就言词具足处众说法。五者善方便说。谓二十种善巧方便宣说正法。如以时殷重等。六者具足成就法随法行。不唯听闻以为究竟。如其所说即如是行。七者威仪具足。谓说法时手足不乱头不动摇。面无变易鼻不改异。进止往来威仪庠序。八者勇猛精进常乐听闻所未闻法。于已闻法转令明净。不舍瑜伽不舍作意。心不舍离内奢摩他。九者无有厌倦。谓为四众广宣妙法身心无倦。十者具足忍力。谓骂弄诃责终不返报若被轻蔑不生忿憾乃至广说。其听法者。是说法师说正法时应安处他令住恭敬无倒听闻。谓由一因或乃至十。一者恭敬听法。现前能证利益安乐。此有四句如菩萨地法处中说。二者一善建立一切法。离诸过失具大义故。二说者听者所设劬劳有胜果故。三者。一能令众生舍恶趣故。二得善趣故。三速能引摄涅槃因故。如是三事要由恭敬听闻方得。四者。一能善了达契经等故。二如是正法能令众生舍诸不善摄受诸善。若善听者能受舍故。三由此舍受舍离恶因所招后苦故。四速证涅槃故五者。一谓我今当闻所未闻。二闻已研究。三当断疑网。四弃背诸见。五我当以慧通达一切甚深句义。此显三慧。初二显闻。次二显思。后一显修。六者。一为欲敬报大师恩德。谓佛为我行于无量难行苦行。求得此法云何今者而不听闻。二观自义利。三究竟能离一切热恼。四善顺正仪。五易可见了。六诸聪慧者内证所知。七者。谓我当集七种正法知法知义乃至广说尊卑差别。八者。一佛法易得乃至亦为旃荼罗等而开示故。二易学行住坐卧皆得修故。三能引发增上生果决定胜果。四初善五中善六后善七感现乐果。八引后乐故。九者。谓能解脱九种世间逼迫事故。一能出生死大牢狱故。二永断贪等坚牢缚故。三弃舍七财贫。建立七财富故。四超度善行闻正法俭。建立善行闻正法丰故。五灭无明闇起智明故。六度四暴流升涅槃岸故。七究竟能疗烦恼病故。八解脱一切贪爱罥故。九能度无始生死旷野稠林行故。十者。一恭敬听法得思择力。由此能受闻法胜利。如法求财不以非法。深见过患而受用之乃至第十能引一切世间出世间静虑解脱等持等至。广如彼说。说者听者先住上法方可说听。若不住此徒设劬劳终无大果

将赞经文略以四门解释。一叙经宗旨。二显经体性。三彰经胜德。四释经本文

叙经宗旨者佛灭度后九百年间有应真大士。厥名清辨。身同数论之仪。示无朋党之执。心处释迦之理宗无偏滞之情。时人号为妙吉祥菩萨。神异圣德广如别记。彼造掌珍论云。凡所知境略有二种。一者有为二者无为。以诸愚夫不正觉了胜义谛理有为无为无颠倒性。妄执诸法自性差别。增益种种邪见罥网。如世有一无智画师画作可畏药刃鬼像或女人像。眩目乱意谓为实有。执实有故自起惊怖。或生贪染于彼境界众多计度。增长分别诸见罥网。若正觉知胜义谛理有为无为无颠倒性。尔时如世有智画师不执彼为真实自性。非如前说有为无为境界差别以自缠裹如蚕处茧。彼非有故无分别慧趣入行成然证出世无分别智。要须积集能坏一切邪见眼膜。无倒观空安缮那药。如是积集无倒观空。要藉能遣一切所缘自性闻慧故。应听此般若深经。依此所说以为宗者真性有为空如幻。缘生故。无为无有实不起似空花。此中世俗许少分有。若依胜义一切皆空。此中画师有智无智怖染譬喻。喻佛菩萨一切异生。自业所招返生憎爱。智者知画俱于平等不生怖染。弥勒中边颂曰虚妄分别有于此。二都无。此中唯有空于彼亦有此。故说一切法非空非不空。有无及有故是即契中道。此以无所执有有无为。以为宗广如常说

二显经体性者。般若有五。一者实相。二者观照。三者文字。四者境界。谓真俗二谛。五者眷属谓一切福智如开题中已略显示。经体有二。一者文二者义。文字是文。四种是义。实相是般若性。观照是般若相。文字是般若因。境界是般若境。眷属是般若伴。故此五种皆名般若。龙猛释言。就胜义谛一切皆空。教既无教无不教。体亦无体无不体。于俗谛中亦可说有。句言章论声为教体广如清辨般若灯说。护法释言。教体有四。一摄相归性体。般若论说。应化非真佛亦非说法者。说法不二取无说离言相。此经下言。一切有情及法皆即真如故。甚深般若波罗蜜多亦即真如。无垢称言。文字性离。无有文字。是即解脱。解脱相者即诸法也。又一切法亦如也。故知教体性即真如。二摄余归识体故。十地言。三界唯心。二十唯识言。谓余相续识差别故令余相续差别识生展转互为增上缘。故说者听者心为教体。三摄假随实体。对法论说。成所引声者谓诸圣所说。故知但取声为教体。摄名等假法随实声说故。四相用别论体。能说法者识上所现声名句文以为教体。以假及实为教体故。十地论云。说者听者俱以二事而得究竟。一者声二善字。由熏习力唯识变力于说法者识心之上聚集现故。如别章说不能烦引

三彰经胜德者。此经总名般若理趣。准义名别有十四种。一此一切法甚深微妙清净法门。若闻已信受得八胜果。一乃至当坐妙菩提座一切障盖皆不能染。谓烦恼障业障法障虽多积集而不能染。二虽造种种极重恶业而易消灭。三不堕恶趣。四若能受持日日读诵精勤无间。如理思惟彼于此生定得一切法平等性金刚等持。五于一切法皆得自在。六恒受一切胜妙喜乐。七当经十六大菩萨生定得如来执金刚性。八疾证无上正等菩提。二者寂静法性现等觉门。若有闻已信解受持读诵修习得二胜果。一乃至当坐妙菩提座虽造一切极重恶业。而能超越一切恶趣。二疾证无上正等菩提。三者调伏众恶普胜法门。若有闻已信解受持读诵修习得四胜果。一假使杀害三界所有一切有情。而不由斯堕于地狱傍生鬼界。以能调伏一切烦恼及随烦恼恶业等故。二常生善趣受胜妙乐。三修诸菩萨摩诃萨行。四疾证无上正等菩提。四者平等智印清净法门。若有闻已信解受持读诵修习得三胜果。一虽住一切贪嗔痴等客尘烦恼垢秽聚中。而犹莲花不为一切客尘垢秽过失所染。二常能修习菩萨胜行。三疾证无上正等菩提。五者灌顶法门得二胜果。六者如来智印金刚法门得五胜果。七者离诸戏论轮字法门得二胜果。八者入广大轮平等性法门得二胜果。九者真净供养无上法门得二胜果。十者能善调伏智藏法门得六种果。十一者性平等性最胜法门得三胜果。十二者一切有情住持遍满胜藏法门得二胜果。十三者无边无际究竟理趣金刚法门得三胜果。十四者甚深理趣最胜法门。能受持者有十八胜德。一一切障灭。二随心所欲无不成辨。三是诸佛母。四能诵持者一切罪灭。五常见诸佛。六得宿住智。七若有情类未多佛所植众善根。久发大愿。于此般若波罗蜜多甚深理趣最胜法门不能听闻书写读诵供养恭敬思惟修习。要多佛所植众善根。久发大愿。乃能于此甚深理趣最胜法门。下至听闻一句一字。况能具足读诵受持。八若诸有情供养恭敬尊重赞叹八十殑伽沙等俱胝那庾多佛。乃能具足闻此般若波罗蜜多甚深理趣。乃至十三诸天常随拥护。十四终不横死。十五不枉遭衰患。十六诸佛菩萨常共护持令一切时善增恶减。十七于诸佛土随愿往生。十八乃至菩提不堕恶趣。诸有情类受持此经定获无边胜利功德。我今略说如是少分

四释经本文者

经曰。如是我闻

述曰。于此经中略有三分。初从如是乃至圆满清白梵行。是序分也。尔时世尊为诸菩萨说一切法甚深微妙乃至略说如是少分。是正宗分也。时薄伽梵乃至奉行。是流通分也。佛地三名科。与古来别如彼论说。今解三别。一文前由致述分。二应机广说分。三感悟修行分。此之三科今古名字随义应悉。就初分中依天亲菩萨灯论偈中分之为六。彼云。前三明弟子后三证师说。第一如是弟子之信。如是之言今说不虚。第二我闻显非传受。第三一时闻法有时也。智度论云。说时方人令生信故。四主五处六机。今依佛地论初分有五。一总显已闻。如是我闻。二时三主四处五机。今依此经开之为六。前五如佛地。第六叹法有十胜德。宣说正法初中后善等。然此序述佛教安置亦是佛说。集法经云。阿难问四事。以何为师依何法住。如何治恶性经首置何言。佛言戒能训诲可以为师。念处破倒依之而住。梵法默伏彼恶人。一切经初皆标六事。初是正行次是正解后辨治障修解行之缘。然此三门必依圣教故。但四问不减不增。智度论云。阿[少/兔]楼驮教阿难请四事。大悲经说优波离教。今谓二人同教。又广明结集因缘。如别抄记。真谛云。微细律明。阿难升座出法藏时。身如诸佛具诸相好。今勘集藏传亦作此说。下座之时复本之形。众疑有三。一疑佛慈悲从涅槃起更说妙法。二疑有佛从他方来住此说法。三疑阿难转身成佛为众说法。故经初言如是我闻。为令生信。言如是者法花注云。如是感应之瑞。如以顺机受名。是以无非立称。众生以无非为感。如来以顺机为应。传经者以名教出于感应故云如是。此应肇公解也。又注无量义经言。至人说法但为显如。唯如为是故言如是。瑶公云。以离五谤名为如是。前四句离增益等谤。第五如是此经因果非非有非非无名戏论谤。第四句名愚痴谤。光宅云。如是将传所闻。前题举一部也。如是一部经义我亲从佛闻。即为我闻作呼彻也。梁武帝云。如是如斯之言是佛所说故言如是。上来五解并是吉藏法师之所引也。真谛及长耳皆云。如是有三。一就佛。三世诸佛共说不异名如。以同说故称是。由斯可信以同说故。二就理明。诸法实相古今不异故名为如。如如而说故称为是。既称理言不增不减决定可信故称如是。三就人。以阿难望佛教所传不异故名为如。无非曰是。此上三解净法师等之所引也。又解。如是之言标一部之玄宗即真俗二谛。真为如俗为是。欲显所诠不异二故。又所言顺理曰如。遮其虚妄为是。又显诠于二智教为二智之因。如所有性为如尽所有性为是。故下云一切智道相智一切相智是也。又标福智显是二严之因福为如智为是也。又教顺于理曰如依教修行为是。又境为如智为是。所乘能乘实相观照以标首也。又如是者吉祥词也。欲显经首皆致此言。异外道等一切经初置阿忧二字。又如是者指斥词也。指下一部之所明也。上来八解皆此方先德之所传释。又如是言依四义转。一依譬喻。如有说言如是富贵如毗沙门。如是所传所闻之法如佛所说。定为利乐方便之因。或当所说如是文句如我昔闻。二依教诲。如有说言汝当如是读诵经论。此中如是远即佛之教诲。近即传法者之教诲也或告时众如是当听我昔所闻。三依问答。如是我闻如是演说。谓有问言。汝当所说昔定闻耶。故此答言如是我闻。四依许可如有说言我当为汝如是而思如是而作如是而说。谓结集时诸菩萨众咸共请言。如汝所闻当如是说。传法菩萨便许可言。如是当说如我所闻。或信可言。是事如是。谓如是法我昔曾闻。此事如是齐此当说定无有异。上来四解并佛地论亲光菩萨等解。又如是者信顺之辞。故智度论云。如是我闻生信也信受奉行生智也。信为能入智为能度。信为入法之初基智为究竟之玄术。信即所言之理顺。顺即师资之道成。由信故所说之法皆可顺从。由顺故说听。二徒师资建立。于此信中略为十释所。以须初令生信。一成唯识云。信如水清珠能清浊水。能治不信自性浑浊。所以兵食信三信不可弃。二瑜伽云。信为欲依欲为精进依。故入一切法欲为根本。作意所生触所集起受所引摄。定为增上慧为最胜解脱为坚固。出离为后边信既为欲依。所以初说。三学佛法者如大龙象以信为手。以舍为牙以念为颈以慧为头。于其两肩担集善法。此乃大毗婆沙说也。四法为诸佛手信为众生手。故俱舍言拔众生出生死泥也。正宗既为佛手。序分生信则为众生手。两手相接故登彼岸出生死泥。次下两解最胜军王经意。五泛大溟海假手以行舟渡生死河须信以发慧。六游大旷野以手持杖捍御群贼游生死原以其信手持智慧刀御烦恼贼。七见珍财宝手以采拾。闻法宝假信而方得。八信为圣财之初故初令起。显扬云。七圣财者谓信戒闻舍慧惭愧。故初令生信也。九信者趣圣位之梯橙故四十心以信为初有信根信力。有信根故万善因此而生。有信力故四魔不能屈伏。十诸论云。信者能越恶道离贫贱因。故有四不坏信。由斯义故一切经初置如是言为令生信。言我闻者传法菩萨自指己身。言如是法亲从佛闻故名我闻。我谓于诸蕴世俗之假者。然我有三。一妄所执我。谓诸外道及诸异生所横计我。或同虚空或如芥子。二假施设我谓常乐我净随引二乘于无我中施设为我。令舍无我小乘之果。谓如经言诸佛或说我或时说无我。诸法实相中无我无非我。谓为声闻说无常等除凡夫时所计四倒。说无有情我但法有因。故后为菩萨说常乐等。除二乘时所起四失。由此诸法本性皆离我无我等说为常我。故假设也。三世流布我。谓世共传张王等姓天授等名世流之我。今传法者随顺世间自指之言称之为我。不同前二。非妄执故非假施设。然体即是无我之我也。问诸佛说法本除我执何故阿难不称名字乃称于我。答以理而言亦应称字。略有三义但总称我。一示不乖俗。宗虽显真言不乖俗。虽无有我仍立我名欲显真谛不离俗故。二我者主宰自在之义。阿难多闻闻持其闻积集。三慧齐备文义并持。于圣教中总持自在。若称阿难闻如是法虽指己体无于法中得自在义。欲显于法自在义成故称我闻不称庆喜。三我者亲义。世间共言我见闻此将为亲证。若但总称言阿难闻或非亲闻从他传受。今显亲闻世尊所说非他传闻故称我也。由此三义不称庆喜但总曰我闻。闻者谓即耳根发识听受所说。今废耳别就我总称故名我闻。诸部计闻说各不等。今依大乘根识心所境至和合方名为闻。然根五义胜于识等故名为闻。对法及龙树皆作此说。若但闻声即唯在耳。通缘名等亦在意中。由此唯意独应名闻。故瑜伽言。闻谓比量。耳名闻者亲闻于声与意为门。而闻教者由耳闻。故因闻所成总名为闻。因耳而得故耳名闻。然耳不能亲取诸法差别名等。如闻所成地从方便说。因闻成法并名耳闻。如观第二月见旋火轮等。如毗留离王为杀诸释种语皆唯意识。自耳不缘故。问阿难于时亲见佛说亦亲觉知佛说。何故不言如是我见我觉我知。但言我闻。答有三义。一欲证深理欲悟所诠要依闻教。见觉知等非初达理。虽亦实见等但得言我闻。二娑婆世界以音声为佛事。欲显异于诸佛国土故但言闻。诸余佛土或以光明妙香味等为佛事者。经首亦得言我见觉知等。今显异彼故但言闻。三欲显智觉菩提要因熏习方得。若不听闻正法三慧无由得生。故经首言闻。令熏习增长有漏无漏。递相增长能生出世世间果等。故但言闻。问大般若等佛自说言。我从成道终至涅槃于其中间不说一字。何故庆喜谤佛说法自称我闻。又升摄波叶喻经言。已所说法如手中叶。未所说法如林中叶。明佛说法今言我闻复言不说一何乖返。答曰。佛地论说。有义如来慈悲本愿增上缘力闻者识上文义相生。此文义相虽亲依自善根力起而就强缘名为佛说。由耳根力自心变现故名我闻。此师意说。佛有三法谓定智悲。三法为体实不说法。由本因中愿利生故大悲恒起。众生久修遇佛善业。今时成熟。自识心上闻佛说法变似教生。而实不说。如曾参之母啮指曾参心痛知母唤而还。母实无言但有念子之意。风云相感其子心疼变似母唤之相。急归果如所说。今佛如母众生喻参。有言无言其类相似。亦如女人请比丘说法。比丘私去。实不为说。女人得道。言由比丘之恩。以比丘为增上缘。心厌生死遂得证果。众生以佛为增上缘。自心变似三乘教起。从强缘论名为佛说。佛实无言。此言我闻其义亦尔。有义闻者善根本愿增上缘力如来识上文义相生。此文义相是佛利他善根所起名为佛说。闻者识心虽不亲得然似彼相分明显说。故名我闻。此师意说。佛有五蕴十八界等。实有说法利他事业。虽无分利不起攀缘任运恒时随机说法作大利乐。如末尼珠及天帝鼓虽无有心为雨众宝。及为天帝有说不说。天帝善业感彼力故鼓任运鸣。天帝闻之而自严警。今佛亦尔。无心分别说与不说。众生善业闻法因熟如来任运现说法事。此中说法譬如幻人为幻人说法。名字性离无有文字。是即解脱。非如妄执名定属法实有能说能听所说故佛说言不说一字。夫说法者无说无示等。若如幻士为幻人说即是非无。故经说言说法非有亦非无。待因缘故诸法立也。佛既说法庆喜亲闻。故名我闻。此中二解。初是龙军无性等一类师解。后是护法亲光一师之义。应知说此如是我闻意避增减异分过失。谓如是法我从佛闻。非他展转。显示闻者有所堪能。诸有所闻皆离增减异分过失。非如愚夫无所堪能。诸有所闻或不能离增减异分。结集法时传佛教者依如来教初说此言。为令众生恭敬信受言。如是法我从佛闻。文义决定无所增减。是故闻者应正闻已如理思惟常勤修学

经曰。一时

述曰。第二明说教时分。即化辰也。法王启化之日大众嘉会之时。此就刹那相续无断说听究竟。随其分位总名一时。不尔字等说听时异。云何名一。此中不定约刹那。亦不定约相续。亦不定约四时八时及十二时并成道竟若干时节名为一时。但是说听二徒共相会遇。说听究竟总名一时。由能说者得陀罗尼说一字。时于余一切悉已演说。或能听者得净耳根解一字。时于余一切悉能解了。或能说者经多刹那或复多劫。其能听者亦或乃至多劫听闻。故不可定一念多劫之时节也。由于一会听者之机有利有钝。如来神力延短念为长劫。促长劫为短劫。时分别故论有二解。一者此时有为法上分位假立。谓道理时。说听之人五蕴诸行刹那生灭无定时体。有酬前引后现在假法。即说所酬所引之法假名过去及现在世。听说二徒五蕴假法事绪究竟假说为时。故总名一时。如算师等以一算子经历诸位名为一十百千万等。其实一物横竖不同得名有异。此说听者现五蕴法曾有名过去。当有名未来。现有名现在。即名为时说为三世。今此三世事绪究竟总名一时。二者此时说听二徒识心之上变作行相。三时体起。即是世识。谓是一念或复多劫事绪究竟假名一时。如人梦中梦见多生生死谓三世迁流。觉竟但有一虚妄心知无三世。今以理说时体亦尔。但有妄心变似三世。事绪究竟总名一时。由义说故唯意所缘行蕴．法处．法界所摄。何不别说十二时等。如净秽处昼夜时分诸方不定。处则方定故于时中但总言一。问。处中有净秽不定但说一。诸方时不同何妨亦定说。凡夫见秽处知圣居净土。何不别论。此时说准余知别时。答或一刹那或复多劫不可定说。准不解故。由是总相但言一时。其延促劫量或唯识。以促延或所执。以双泯或依他。以妄法或实性。以平等或圣力。以加持故有延促。无劳疑惑。义准应释

经曰。薄伽梵

述曰。自下第三别说教主。欲叹法出胜人其法必胜。显教主中有二。初标名后叹德。此标名也。古名婆伽婆义当世尊之号。然义犹阙所以不翻。汉无此言也。瑜伽第八十三卷云。坦然安坐妙菩提座任运摧灭一切魔军。大势力故名薄伽梵。佛地论言谓。薄伽声依六义转。自在炽盛与端严名称吉祥及尊贵。如是六种义差别应知总名为薄伽。此中意说若有为此薄伽声目必具此德。如是一切如来具有于一切种皆不能离。是故如来名薄伽梵。谓诸如来永不系属诸烦恼故具自在义。炎猛智火所烧练故具炽盛义。妙三十二大丈夫相所庄饰故具端严义。一切殊胜功德圆满无不知故具名称义。一切世间亲近供养咸称赞故具吉祥义。具一切德常起方便。利益安乐一切有情无懈疲故具尊贵义。或能破坏四魔怨故名薄伽梵。四魔怨者谓。烦恼．蕴．死．自在天魔。破诸有情所修善等名之为魔。入第三劫破烦恼死魔。将至金刚心取破其天魔。解脱道起破其蕴魔。若论其相金刚心时破烦恼魔。菩提树下破自在天魔。舍第五分寿入无余灭破其蕴魔。更留三月破其死魔。若其实义恼乱菩萨皆名烦恼。二障俱是。金刚心起永破烦恼魔。二障种有故解脱道起永破蕴死二魔。此依二死作论。其伏天魔不见文说。今依一义。十信菩萨八相成道已应伏天魔。或十住第六心始伏天魔。是中永离生死出三界故可伏天魔。或入初地即伏天魔。佛地论初地已上离粗四魔。随情取舍。故破四魔名薄伽梵。问佛具十号。何故经首佛教庆喜说此名也。答由此一名世咸尊重故诸外道皆称本师名薄伽梵。又此一名总摄众德余名不尔。是故经首皆置此名。然诸经首虽标教主然各不同。且如新译称赞大乘功德经。住法界藏诸佛所行众宝庄严大功德殿法性土中即法身说。其佛地经处最胜光耀七宝庄严。乃至广说大宝花王之所建立大宫殿中。十八圆满净土之中报身所说。其此经首虽彰佛实德然稍异余经。所居即在他化自在天王宫中末尼殿内。化身所说。然法性土虽唯佛居标德严花菩萨亦在彼会。其净土中虽但菩萨经中亦说有诸天龙。此经虽但说他化宫列众但标十地圆满诸大菩萨。此等总明一质异见。金刚论说。应化非真佛亦非说法者。说法不二取无说离言相。推功归本以法身为身。余身非身。法身为说二说非说。体依聚义总名为身。法身总为身说之依身说之本。二身方起非是常身及非常说般若但以法性为宗。意在亡相。二身二说皆有相故名非身说。实此二身亦有身说。欲显大乘名义深远证二空理方能知说。故假妙土以显经深。法性土中言说称赞大乘功德经。理实严花但居净土不居法性土。法性土中无身无说。菩萨何由有听闻等。又为显正智内证真空名居法性土。后智起悲化名居净土等。亦无过失。天龙八部见居化土。其佛地经欲显十八圆满净土之相。所说五法如来实德。寄净土说以显经深。其实菩萨正智契真亦居法性。天龙闻法亦居化土。其此般若观照证实相。一切菩萨及与如来亡相为本。实皆居法性身现居净土。然显悲深慈厚叹报身之德。言居化土而说。其听法者亦但标胜人与佛实德相称。寄化土以彰。别意如下当说。今言薄伽梵随应当说。即显三身皆能说法徒众皆有住三土义。唯标报身之德。然则不见经文居自报土说。由此应准佛德及处以知佛土。今此薄伽梵准下别德。即报身实德所居之处。即是化土彰胜身以显法胜。举化处以显经深。欲显悲智皆是事法修生。不言法性之身土也

经曰。(一)妙善成就一切如来金刚住持平等性智种种希有殊胜功德。(二)已能善获一切如来灌顶宝冠超过三界。(三)已能善得一切如来遍金刚智大观自在。(四)已得圆满一切如来决定诸法大妙智印。(五)已善圆证一切如来毕竟空寂平等性印。(六)于诸能作所作事业皆得善巧成辨无余。(七)一切有情种种希愿随其无罪皆能满足。(八)已善安住三世平等常无断尽广大遍照。(九)身语心性犹若金刚等诸如来无动无坏

述曰。此中九句叹如来德。依诸经论略为三释。第一且依此经文解。其第一句总叹如来兼以下德。余之八句别叹如来列诸德异。然下正宗有十四段以显世尊十四实德。今此初句总标众德余句别属功德法门。金刚住持平等性智者举次第二灌顶宝冠超过三界德。即是十四段中第三段。调伏众恶普胜法门。亦是第五法王灌顶智藏法门之所显也。举下一德二种法门。其种种希有殊胜功德者。总指余七句所有胜德。余十二段所有法门。不可一一具足烈故。此总解已。别解释者妙者功德微细故。善者非佛不恻故。又内道不了名妙外道不知名善。又智深难测名妙福细叵识为善。言成就者自在任运能现前义。又克获圆满名为成就。一切如来者欲显佛德诸佛共故。由此共故佛德可尊。是真实德梵云达他揭多。古云多陀阿伽度。此云如来。菩萨地说言。无虚妄故名如来。涅槃经云。如过去佛说契经等不变改故名之为如。从波罗蜜三十七品十一空来至涅槃故名为来。此意说言。如诸佛等而说妙法。从修万行来至涅槃故言不虚。是如来义。又言不虚常行谛语来至佛位故名如来。瑜伽论云。十号之中初是总序。若住生死由行妙行去至佛位名苏揭多。号为善逝。古云修伽陀也。若住彼岸因如成佛号曰如来。一揭多言义通来去。如言蜜多通离到义。此亦如是。金刚者喻也。平等性智能调众恶降伏烦恼普胜一切名曰金刚。如于金刚能摧坏故。言住持者至法王位能为一切三界胜主。世间所有胜法皆是此智之所住持。令其不坏名住。助其生长名持。又此平等智是诸智藏。一切福智以此为因。此能住持一切佛德能灭诸惑名金刚住持。此是平等性智之作用也。内能住持外能摧坏。平等性智者非是四智中第二平等性智也。毕竟空寂平等法性能证之智名平等性智。即无分别智正能断惑为无间道。犹若金刚即妙观智中之正智也。若为住持众德之本。为能摧坏之根本。智即圆镜中平等性智。若能摧坏着生死涅槃住无所住。即第七识所成平等性智。若能摧坏二乘异生一切烦恼住于慈悲利他功德。即成所作平等性智。今以正义即诸智中随其所应证性平等。皆能坏分别及二障等。诸德之本名为金刚住持平等性智。一切菩萨根本所求如灌顶位之宝冠也。性是无漏。离三界系永无分别。此牒次下第一德已。余德非一名为种种。无始未得名为希有。唯佛乃成故名殊胜。积力道成名为功德。此总含下。下自当知。第二句云。已能善获一切如来灌顶宝冠超过三界者。即下十四段中第三调伏众恶普胜法门。及第五灌顶智藏法门所显。下经解言。若以世间灌顶位施当得出世灌顶位果。西域世间刹帝利种太子。将受帝王之位先请有德婆罗门等以为师傅。乘千里象取四大海水。以吉祥茅沾彼海水。洒太子顶令其净洁。作大吉祥四方归伏方受王位。古翻经云刹利水浇头王。今新翻云刹帝利种灌顶大王。王身必是刹帝利种。请婆罗门以为师傅灌其头顶。以婆罗门性修梵行净戒之族故。刹帝利请灌其顶。此乃效习受法王位之仪式也。谓第十地究竟菩萨生色界上大自在宫。莲华台中将起金刚定受佛之位。胜诸菩萨菩萨中尊。佛之长子名为太子。十方诸佛是其师傅。各舒慧手及右臂手以三世佛清净法水灌洒其顶。顶谓心首及其头首。除无始来二障垢秽有漏染污遍满清净无漏洁白殊胜法王位。如世太子既灌顶已将受王位。戴王之冠着王之服处王之殿。佛法太子亦复如是。将受法王法主之位戴佛之冠。谓一切智一切种智。是佛心首所戴持故。即是观照波罗蜜多。此功德法真实珍宝。七圣财中名为慧财。故此冠冤名为宝冠。服二际佛功德法衣即是惭愧柔和忍辱之上衣也。此智慧冠是大智藏。一切善法因此生故处十方佛空寂宝殿。由戴如是冠衣等故。无始恶友以烦恼水浇其心顶。生死心首所戴愚痴丑恶冠冤。生死所著无惭无愧刚强佷戾嗔恚恶服。悉得消灭永为弃舍。永更不入三界牢狱。故名降伏众恶普胜法门。亦名灌顶智藏法门。由如是故为三界主出诸有漏生死系缚超三界也。自体无漏名为遍也。故下经云。若以世间灌顶位施当得出世法王位果。第三句云遍金刚智大观自在者。即下十四段中第十二一切有情住持遍满胜藏法门。谓佛具证一切有情皆如来藏。普贤菩萨自体遍故。能证如来藏遍诸有情。此能证智名遍金刚智。摧灭生死一切障故。然由悲故观诸有情身语心行。可济拔者应时为现。故诸有情皆金刚藏。以金刚藏所灌洒故皆正法藏。一切皆随正语转故皆妙业藏。一切事业加行依故。由观有情而起三业故曰观自在。于求念者如应利乐无失时处法器等。故大观自在。如龟兹国圣苾刍尼所现事也。第四句云决定诸法大妙智印者。即下十四段中第二寂静法性般若理趣现等觉门。总一切法不过有二。一智二境。智谓金刚智。境谓一切法。又有二种一能诠二所诠。能诠谓法。所诠谓义。今显世尊于二二种诸法之中决定悟解无有疑惑。能知此智名大妙智印。此智印定二二种法。离诸疑网非凡愚所测名之为妙。神用难思复名为大。即观有智印定诸法无疑惑也。第五句云一切如来毕竟空寂平等性印者。即下十四段中五法门也。第一一切诸法甚深微妙清净法门。第四平等智印清净法门。第七离诸戏论轮字法门。第八入广大轮平等性法门。第十一性平等性最胜法门。谓昔妄想计诸法有。今离妄想计执永除。所执既无所证亦满。诸妄永弃名为清净。此诸妄想毕竟体空。世出世间染净等法无不空寂。空寂之体性即真如。即一切法平等之性。此理决定遍诸法中名之为印。佛得此如一切圆满故名善证。然中边论解二十空中毕竟空云。为于有情常作饶益而观空故名毕竟空。此意说言。为有情故别观于空或观所为有情为空。此观有情等毕竟不可得毕竟即空名毕竟空。此毕竟空寂一切有情一切法中皆悉平等。是诸人法平等之性印定诸法定毕竟空。若计所执若二空理皆毕竟空故。此解即是第一一切法甚深微妙清净法门之大义也。自余四门准下应悉。恐文繁广故不并释。第六句云于诸能作所作事业皆得善巧成办无余者。当下十四段中第十能善调伏智藏法门之所显德。所调伏者谓诸缠垢忿恚等过。谓佛世尊自能调伏忿恚等过。亦能调伏一切有情缠垢等失。随其大小善恶事缘起缠垢等。如来善巧皆能调伏。成辨此智一切皆尽更无遗余。故佛世尊自智圆满伏众恶患。亦能调伏诸有情等缠垢等患。亦令乃至得佛菩提。是名善巧成辨无余。但是能伏诸缠垢等。所有方便皆悉成辨故言善巧成辨无余。智慧善巧名能作事业。所伏忿等名所作事业。又智慧方便名能作事。其所调伏身语意业令离缠垢名所作事。此叹世尊具智方便善能调伏自他忿等一切无余。第七句云一切有情种种希愿随其无罪皆能满足者。显下十四段中第十四甚深理趣最胜法门。谓佛世尊由具般若波罗蜜多方便善巧成立胜智。善辨一切清净事业能令诸有皆得清净。又以贪等调伏世间。普遍恒时乃至诸有皆令清净。自然调伏。又大贪等能得清净大乐大财。三界自在常能坚固。饶益有情由斯陀罗尼。以隐密言词说其神咒。能受持者一切障灭。随心所欲无不成辨。乃至广说若离烦恼恶业。诸愿世出世间若今若后。由无罪故悉能满足。若起烦恼恶业根本由有罪故。如是诸愿皆不与之。故说世尊不夺有情一切诸愿。然不皆与。要除无罪若起烦恼及起恶愿虽有至诚亦定不与。如如意珠所发善愿一切皆得。第八句云已善安住三世平等。常无断尽广大遍照者。显下十四段中第十三段无边无际究竟理趣金刚法门。此意总显般若波罗蜜多。若体若用弘广深远不异最胜　是故如来无边无际一味究竟。能观般若体用广大所以无边。能遍照故所以无际。由无断故所以一味。由无尽故所以最胜。故能观智妙知三世。知过未世犹如现在名为平等。又观照智无边无际一味究竟。能观三世若理若事。事事分明皆善了达故名平等。其理一相亦名平等。若理若事皆能了达。故平等言通其理事。常无断尽。广大遍照智之用也。善安住者能观之智妙达三际名善安住。理事之中皆无谬乱名善安住。于一切时智用遍了是此意也。第九句云身语心性犹若金刚。等诸如来无动无坏者。显下十四段中第六段如来智印金刚法门。显第九段真净供养无上法门。佛具摄受一切如来金刚身印能证一切佛之法身具摄诸佛金刚语印于一切法得自在转。具摄诸佛金刚心印于一切定当得自在。具摄诸佛金刚智印能得无上妙身语心。犹如金刚。无动无坏不为烦恼之所鼓动。不为外道魔王破坏。令其三业有所动坏。以佛三业智为前导。离诸过失。不可破坏令起过失。故无动坏。无动坏者与一切佛功德无差。故名为等。等诸如来即上诸门所说一切如来之妙义也。此如金刚不可动坏。殊胜三业。由昔因中如法三业供养诸佛为法供养故至佛位。得是果也。真净供养所得报故不可动坏。或此三业非外道恶友所动。非天魔邪朋所坏故。犹若金刚。破灭生死所有三业。三业性者即三业体。更无他义。此中九句显佛世尊下十四段经所显功德。今叹佛德欲令众生知佛具德起殷重心。敬受所说或闻此已当发胜心。欣求证得。或显世尊具此诸德超过一切。是故所说甚深理趣最为殊胜可依修学。第二又解。依诸经中说佛具有二十一德。别配此等九句。经文金刚住持平等性智者。谓佛不二现行一向无障殊胜功德。及显逮得一切佛平等性。得一切佛相似事业殊胜功德。如是一句总显二德。谓佛世尊离诸凡夫现行生死起诸杂染住着生死。离二乘者现行涅槃一向弃背利乐他事。住着涅槃。世尊无彼现行二障。是故说名不二现行。悲智遍故生死涅槃二俱不住故名平等。能破此二障故假喻金刚。住无所住无住涅槃故名住持。住持悲智故又逮得一切佛平等性。谓所证理等能证智等所成身等。意业悲行悉皆平等。由此平等能坏生死故名金刚。平等为依能持众德故名住持。今但举一。此等甚多故名种种殊胜功德。经第二句云灌顶宝冠超过三界即佛三德。一者一切菩萨正所求智。二者极于法界。三者所行无碍。此中初句成就佛种不断方便殊胜功德。谓诸菩萨为令佛种无断绝故勤修加行非二乘等。是故佛智唯诸菩萨正所应求。由此灌顶法王子位唯第十地。着佛宝冠绍佛之位。非二乘等。谓令众生求听般若甚深经典拟成种觉。亦是绍继法王之位。是故若障破灭众生不令修学般若经典。即为断绝诸佛种子。此第二句证得果相殊胜功德。谓得穷极清净法界。此净法界修道之果。观照心中常现前。故喻于头上所戴宝冠。宝冠即是身之上饰。法界亦是功德根本。故喻宝冠。此第三句降伏魔怨殊胜功德。谓所行者即色等境。此所行境扰乱心故障碍善。故说名魔怨。诸佛世尊心善安住极悦意境。亦不能乱。所有功德极善成满。一切恶境不能为碍。以能摧伏一切境界。一切所行不能拘碍离系缚法。故至佛位超过三界。此第二句世尊之德。无始不成今时始得名之为获。第三句云遍金刚智大观自在即佛三德。一不可转法。二住于佛住。三于一切行成就大觉。此中初句降伏外道殊胜功德。谓佛正法一切外道不能退转。降伏彼已显自正道。以由成就遍金刚智说甚深法降伏外道。又由成就遍诸法智。能说深法降诸外道。故说此智喻若金刚。言遍智者遍解诸法一切智也。此第二句观所化生殊胜功德。谓住大悲昼夜六时观世间故。此第三句于一切乘所化有情。能随所应示现自身殊胜功德。谓遍了知一切有情性行差别。如其所应现自身。故大观自在。若观有情心行差别不自在者。不能随类即现其身。由此既能随应现者。故知佛具遍智大观自在故也。又初句言遍金刚智是二十一功德之智总句最清净觉。谓于一切有为无为所应觉境正开觉故。净妙圆满正开觉故。又于如所有性尽所有性正开觉故名遍金刚智。此中二德今显创圆名之为得。第四句云决定诸法大妙智印者。此智十地分已得之。今显满也。显二种德。一于一切法智无疑滞。二于诸法智无有疑惑。此中初句断一切疑殊胜功德。谓于诸法已得能除一切疑惑决定智。故此第二句妙善了达一切法智。能随所应恒正教诲殊胜功德。谓于诸法怀疑惑者。无有力能随应教诲。唯佛世尊证见诸法。智善决定。能随所应无倒教诲无休废。故若于诸法不决定者理即不然。又得三法印诸行无常有为别印。涅槃寂静无为别印。诸法无我二法遍印。此三妙理印定诸法。称之为印。佛得此智名为智印。第五句云毕竟空寂平等性印者显二种德。一得佛无二住胜彼岸。二证无中边佛地平等。此中初句自性身分殊胜功德。佛无二住即是法身真如为体无差别相。于中一切二相分别皆不现行。缘彼胜定常住其中。故名为住。即无二住名胜彼岸。佛已穷到故名为得。此之法身诸佛共有平等之性。要除二我。观二我空寂方始圆证。此第二句证真如相殊胜功德。谓真如相远离一切有为无为中边相故。远离方处中边相故。即是佛地平等法性。由证此故遍知诸法。于中不染。此真如理印于诸法。契毕竟空。方能证会佛皆圆证。第六句云于诸能作所作事业皆得善巧成辨无余者。此显世尊二种功德。一其身流布一切世界。二其所成立不可思议。此中第一句现从睹史多天宫来下殊胜功德。谓现化身普于一切世界洲渚同时流下入母胎故。谓即八相示现成道。此即世尊能作事业皆得善巧　化身既尔他报身等随应化现理亦如是。此第二句安立法教殊胜功德。谓佛安立一切法教超过一切寻思境故。是则名为所作事业皆得善巧。三劫修因本为有情。现身说法作大利乐。今既圆满故名善巧成辨无余。第七句云一切有情种种希愿随其无罪皆能满足。此显世尊二种功德。一趣无相法。二不相间杂。如来解脱妙智究竟。此中初句调伏方便殊胜功德。无相法者即是涅槃。佛善了知三乘有情随彼堪能调伏方便。如实为说令彼趣证无相法故。此意说言一切有情求出生死皆得涅槃。三乘妙愿由无罪故佛皆能满。此第二句受用身分殊胜功德。谓受用身不相间杂。一切如来受用身体各各别故。如来妙智能令一切有情解脱故。言如来解脱妙智。佛于此智已得究竟。如来此智不相间杂。于净佛土现受用身。亦不相杂。大集会中现种种身。与诸菩萨受用法乐。亦不相杂。如来于此智所现身亦到究竟。此意即显如来之智及所现身已得究竟。随诸有情一切无罪所乐所愿。皆能为现方便拔济令离生死。故名满足。第八句云已善安住三世平等常无断尽广大遍照。此显世尊三种功德。一游于三世平等法性。二尽虚空性。三穷未来际。此中初句记别三世殊胜功德。谓如现在记别过去未来世事皆无碍。故谓记般若于东北方最后兴盛最初灭之。乃至正法灭尽时事。于瞻波国记法当灭。如正法灭经当广说相。又记菩提树边二石菩萨身若灭尽正法当灭。今没至胸事可验矣。记阿输迦为轮王事即其证也。此后二句自利利他二德无尽殊胜功德。谓如虚空经成坏劫性常无尽。如来一切真实功德亦复如是常无断尽如未来际无有尽期。利他功德亦复如是。穷未来际常作一切有情利益安乐事。故广大遍照。即无断尽真实功德之照用也。第九句云身语心性犹若金刚等诸如来无动无坏者。此显世尊二种功德。一到无障处。二凡所现身不可分别。此中初句已修一切障结对治殊胜功德。谓已修习一切二障对治圣道。已到解脱一切障处。所依所趣故名为处。由此如来所有三业皆善无漏。犹如金刚以一切佛非余动坏。此第二句能正摄受无染自身殊胜功德。谓佛自身非是虚妄分别所起。无烦恼业生杂染故。以如来身非　杂染分别起故。不可分别故。佛三业由离过失犹若金刚不可动坏。等一切佛。此中九句文义开合总叹二十一德。此中且依佛地初释。恐文繁广不录后师。摄大乘等随应广说。不能一一。第三又解。此九句经初四句叹报身。第一句总叹四智微圆报身实德不论法界。第二句叹道胜位尊。第三句叹悲深智遍二果齐圆。第四句叹慧广智德。总印一切有空事理。证不谬故。第五句叹照寂断德。此叹法身。下四句叹化身。第六句叹成巧恩德。第七句总叹神通轮能满胜愿。第八句叹记心轮能为说法。第九句叹漏尽轮能现离染教诫教授。第一句总叹四智微圆报身实德中。言金刚者总喻四智所依真如。性能摧坏并名金刚。非皆正有摧坏事用。言住持者圆镜智也。即是证于金刚真如之住持者。此为世出世间众善之本。又为余智之根本。故名为住持。依佛地经有九圆镜喻。一如依圆镜众像影现。喻如来智镜诸处．境．识．众像影现故由此名为一切智者。故佛身诸德此能住持。又由镜智自余相续出世世善诸处．境．识皆依镜智而得生。故名为住持。二又如圆镜无动无摇。众生观察自身得失。为欲存德舍诸失。喻如来镜智悬法界幢无间断故无所动摇。无数众生观于染净为欲存净舍诸染故。三如镜善鉴鉴净无垢光明遍照。喻如来镜智离二障垢。极善磨莹为定摄持。鉴净无垢作大利乐事名光明遍照。四如镜依缘本质种种影相生起。喻如来镜智恒依缘故智影相生。五如镜周莹其面于一切处为诸影像遍起依缘。喻如来镜智不断。无量众善行莹为诸三乘智影依缘。六如镜大地大山宫舍大影可得。而镜不等大影之量。喻如来镜智十地影现。世出世善一切影现而智不同彼之分量。七又如圆镜非处障质影像起缘。喻如来镜智非恶友摄闻不正法障碍众生智影起缘彼非器故。八又如圆镜非处闇质影像起缘。喻如来镜智非处乐恶愚昧众生智影起缘。彼非器故。愚昧重故虽有三宝良田生长一切善法。不欲听受不乐归依返信外道。岂非愚痴尤重覆蔽。故云非器。九又如圆镜非处远质影像起缘。喻如来智镜非处不净感匮法业。不信众生智影起缘。彼非器故。由前身中诽谤正法经无量劫不闻正法自业障故。或由无性不信因缘非圣法器故非彼缘。由此九喻随其所应与自他身．有性无性．世出世善为因缘故名为住持。平等性者谓十平等。一诸相增上喜爱平等法性。谓于相好生喜爱故今证法性悉皆平等。二一切领受缘起平等法性谓内外缘起。三远离异相非相平等法性。色等诸法变坏等相不相似故名为异相。远离各别异相即是共相。如是共相以非相为相即法平等性。故经说言。一切诸法皆同一相。所谓非相。四弘济大慈平等法性。慈有三种一有情缘。缘有情为境初发心菩萨修。二法缘。缘正法为境。修正行菩萨多分修。缘教生故。三无缘。缘真如为境。无生忍菩萨多修。此慈虽有所缘缘法界故亦名无缘。无分别故。佛皆具有平等福业。长时无间殷重无余。故名弘济。五无待大悲平等法性。二乘之悲不拔一切唯拔欲界暂时而转。如来普拔遍缘三界恒时而转无所观待。恒救不舍能拔三苦所苦有情。等如一子不生分别。此子非子及拔不拔。如来证得大菩提已恒作是念。我常安立一切有情诸善根本。若未悟者我当开悟。此亦三种准慈应说。六随诸众生所乐示现平等法性。如来虽居无戏论位由平等智增上力故大圆镜智相应净识现琉璃等微妙色身。令诸有情善根成就自心变似如是身相。谓自心外见如来身。七一切有情敬受所说平等法性。随众生乐如是语业发生欢喜。如来即现由悲愿故说必称机不虚捐也。虽有众生不顺佛语此是化作或当有益后必信受。八世间寂静皆同一味平等法性。有漏五蕴名为世间即彼息灭名为寂静。生死涅槃二俱平等故名一味。又所执世间本性无故名为寂静。此即显如无差别故名为一味。九世间诸法苦乐一味平等法性。世间有八谓利．衰．毁．誉．称．讥．苦．乐。得可意事名利。失可意事名衰。不现诽拨名毁。不现赞美名誉。现前赞美名称。现前诽拨名讥。逼恼身心名苦。适悦身心名乐。圣者居中恒常一味得利不高遇衰不下。乃至遇苦无患得乐无爱。应如虚空平等一味。十修植无量功德究竟平等法性。功德即是菩提分等熏种长养成熟解脱名为修植。具此十德名平等性智。又有二平等。谓一切有情平等。诸佛平等。如摄大乘等解。转第七得。因昔有我此彼不等。今离我故名等平等。种种希有殊胜功德者即妙观智及成事智。各有十因。妙观察智十种因者。一建立因。此智住持一切陀罗尼门三摩地门无碍辨说诸佛妙法。谓十力等。二生起因。此智能为顿起一切所知无碍妙智种种无量相识因缘。谓一切智能顿了知一切境相。一切境相顿起生因也。三欢喜因。此智可玩。波罗蜜多．菩提分法．十力．无畏．不共佛法之所庄严甚可爱乐。四分别因。此智之上世及出世衰盛因果三乘圆证无余。观察妙饰间烈。世间恶趣善趣以为衰盛因果。出世以二乘大乘为衰盛因果也。又有异解如佛地第五。五受用因。此智助平等智为增上缘。击发镜智相应净识现受用身。种种众会威德炽盛雨大法雨。为令十地诸大菩萨受大法乐。亦助成智现变化身。乃至为令地前所化受用法乐。六趣差别因。此智之上无边因果五趣差别具足显现。七界差别因。此智之上无边因果三界差别具足显现。八雨大法雨因。此智之上诸佛菩萨威神所引广大甚深教法可得。九降伏怨敌因。此智之上一切天魔外道异论所不倾动。甚深法界教法可得。十断一切疑因。妙观察智不愚一切自相共相之所围绕故。此中广辨自共相体。此等十因广说其相如佛地论。成所作智十种因者谓三业化。一身业化。此有三种。一现神通化。由是如来示现种种工巧等处摧伏诸伎傲慢众生。以是善巧方便力故引诸众生令入圣教成熟解脱。二现受生化。由是如来往诸众生种种生处示同类生而居尊位。由其示现同类生故摄伏一切异类众生。三现业果化由。是如来示现领受本事本生难修诸行。如契经说。如来先世迦叶佛时作是骂言。何处沙门剃除鬓发有大菩提。无上菩提极难得。故由彼恶业今受如是难行苦果。此言亦是为止恶行现化所作。若不尔者何有系属一生。菩萨已曾亲事无量如来植诸善本。性忆宿命。更起如是动语恶行。当知此言为欲化度宜闻此言而得度者。令于佛所离此言故。二语业化。此亦三种。一庆慰语化。由是如来宣畅种种随所乐法。文义巧妙小智。众生初闻尚信。谓佛言音具六十德。诸凡愚慧暂时得闻尚生信解。何况其余聪愍者慧。二方便语化。由是如来立正学处毁诸放逸赞不放逸。又复建立随信行人随法行等。由大悲故。为诸有情安立学处令伏诸恶修世间善。安立圣道分位差别。令入正道出离三界。三辨扬语化。由是如来断诸众生无量疑惑。谓成事智随诸众生意乐差别现化语业。说种种义断诸疑惑。谓发一音表一切义令诸有情随类获益。佛以一音演说诸法众生随类各得解。等此由如来本愿所引不思议力。若作化身一质异见利乐事成。三意业化。此有四种。一决择意化。由是如来决择众生八万四千心行差别。谓诸有情八万四千诸垢尘劳心行差别。此能障碍八万四千波罗蜜多陀罗尼门三摩地等。如贤劫经广说其相。所谓最初修习行法波罗蜜多。乃至最后分布佛体波罗蜜多三百五十。一一皆具六到彼岸。如是总有二千一百。对治贪嗔痴及等分有情心行差别八千四百。除四大种及六无义所生过失。十转合数八万四千。修习此故后得成就八万四千陀罗尼门三摩地等。此犹略说。广则无量。二造作意化。由是如来观诸众生所行之行行与不行若德若失。为令取舍造作对治。谓随观察一切有情所行之行。若诸恶行不行有德行即有失。若诸善行行即有德不行有失。如是观察为欲令彼取德舍失。于德造作住持对治于失造作远离对治。三发起意化。由是如来为欲宣说彼对治故显彼所乐名句字身。谓随众生所乐说法令起爱乐发生对治。四受领意化。由是如来于定不定返问置记为记别。故随其所应受领去来现在等义。此四即是一向分别返问置记四种论说。谓三宝性良福田等此三业化即三神变。谓神通记说教戒三种。由此义故说佛世尊名大圣智药。能除一切烦恼病故。妙观察智成所作智各有十因故名种种希有功德。此句总显报身实德故以四智初门赞述。余色非色诸有为德皆是四智品类摄故。第二句云灌顶宝冠超过三界此叹道胜位尊。出第十地灌顶位已戴佛宝冠殊胜妙智身净无漏。离诸系缚非界所摄故。名超过由此二乘异生外道位皆卑下故。十地云有此净土出过三界。第十地菩萨当生其中。彼土处所不离三界以离系缚故名超也非彼摄故。如来之身亦复如是。非有漏故名为超过非离三界别处生也。第三句云遍金刚智大观自在者叹悲深智广二果齐圆。因中修行自利利他悲智为因果道成满。果既了知诸法名遍金刚智。能证遍智能摧二障故喻金刚。或所破二障坚牢难坏亦喻金刚。能证遍破犹如金刚烦恼所知。真实妙智名遍金刚智。得此智觉能悲拔济一切有情。自利智圆利他悲满名观自在。随其众生三业求愿即能悲拔无有遗漏名大观自在。显佛诸德莫过此二。摄法周尽随应广摄　第四句云决定诸法大妙智印者叹慧广智德。总印一切有空事理证不谬故。智有二种二种无智皆已断尽故得二智。有为智能知有为定无常。无为智能知无为定寂静。此二无我印法定然必无犹预故。用广大名大妙智印。若无此智于法不能决定智起。第五句云毕竟空寂平等性印者叹照寂断德。此叹法身要断二障方证二空。二空之理印定诸法。诸法平等皆由二空。由二空门证此法性名平等性。然毕竟空但能入门非平等性。平等性者真如之体非空非有。今从方便名毕竟空。由观有情为毕竟空所证得故。佛已圆得故名为证。第六句云于诸能作所作事业皆得善巧成辨无余者。下四句叹化身。此叹成巧恩德。谓佛世尊大悲熏煮六时驱逼。为利有情为现方便报身化身。如应说法利乐菩萨及二乘等。其平等智击发镜智。为诸菩萨现他报身。妙观察智于中说法断众疑网。成所作智击发镜智起变化身。为二乘等现化身语。妙观察智于中说法断诸疑网。成所作智现三业化。总有十种。如此中解释初句总德中解。此成事智及平等性智名为能作事业。其十种化平等智等之所作事名为所作事业。世尊于此能作所作皆得善巧成辨无余。一切皆得善巧满故。第七句云一切有情种种希愿随其无罪皆能满足者。叹神通轮能满胜愿。由佛具有神通威力。一切有情世及出世诸无罪愿皆能满足。然不皆与故说为能。恐诸有情增恶业故。谓见贫者常求其财应亦施与。然得财已增长恶业所以不与。摄大乘云宁使贫乏于财位远离恶趣诸恶行。勿彼起过乱诸根能感当来众苦器诸根缺等。类此应知。若求智门无罪福慧然必皆与。如末利夫人愿为王妃后获圣果。五百圣种愿见佛身说本生事。迦叶夫妇愿为道心夫妻眷属后得圣果。阿育王女愿得钱施后为王女。此等皆是无罪之愿皆能满足。不同父母亦与其子有罪之愿无罪希愿则不能与。又现神通随其宜现佛则为现满足所求。如为优楼频螺迦叶三人等现神通事。如为调伏劫比拏等现大神通令其入道。皆满胜愿也。第八句已善安住三世平等常无断尽广大遍照者。叹佛世尊记心轮能为说法。天眼通知现在世如知人间牛产犊事。生死智知未来知未来婆罗门等旃遮谤已后自败事。亦知郁头蓝子生天已为着翅狸后入地狱事。以宿住智知下乞儿久发善根。为其说法拔济饶益记别三世而为说法。行利乐事无有差别名为平等。能观此智相续现前常无断尽无所不知广大遍照。第九句云身语心性犹若金刚等诸如来无动无坏者。叹漏尽轮能现离染教诫教授。三身之中惑业皆尽故似金刚等于诸佛。不为一切外道天魔生死恶友之所动乱破坏。令起恶业等也。由三业中一切漏尽故能教诫教授众生故名漏尽。如对法论第一疏解。又第四解。此中九句初之一句总叹四智法身报身。次有二句叹位尊德广。次三句别叹三德。后三句别叹三神变。欲令众生闻佛功德生胜欢喜殷重闻法起趣求故。佛具此德以叹经初令知所说最胜妙故

般若理趣分疏卷第一终大般若波罗蜜多经般若理趣分述赞卷第二

        大慈恩寺沙门　基撰

经曰。是薄伽梵住欲界顶他化自在天王宫中

赞曰。自下第四明说教处。于化土中略彰四德以显经胜举化胜。处以表报身及法身土亦含实德。第一处尊胜在欲极天他化宫故。第二同居胜诸佛曾游大宝殿故。第三严丽胜无价末尼蓥众宝故。第四爱重胜贤圣天仙所欣乐故。此文第一处尊胜也。是薄伽梵者指说教主即能住人。住者依止居处之义。欲者贪爱即是淫触段食之贪。界者族类疆畔之义。界由欲生能生于欲名为欲界。如胡椒饮如金刚环。顶者头顶高极之义。此于欲界六欲天中最高胜处名欲界顶。虽言胜处仍未显名为显天名故。经次言他化自在诸天福力随欲所须如应即现。然第五天业既殊胜。则不如是随欲化物。但以生得变化之力变作种种所须之具而受用之。今第六天业更殊胜。虽有众具随欲即现亦能自变化作众具而不受用。要待他天变为乐具。自方受用业力胜故。由如是义名他化天。就此天中非无贵贱臣主等别。今处彼天贵主所居非住臣贱下恶天处。故经复言天王宫中。欲显法尊说必依于上极胜处非于余下也。如证菩提要金刚座。说此胜法必他化宫。如十地经依胜处也。此表报身住无漏净土之中。亦表法身住离贪欲究竟极处清净法界。证此法者能作利他之胜事。故亦为利他处于净土及法性。无分别智及后得智神用无方名为自在。此乃诸天法王曾居之宫室也。故余经言毕竟空寂以为舍。故三身利物各各别。故所居之土亦各别也。寄在天宫彰处尊而法胜。标居界顶显妙理以幽深也

经曰。一切如来尝所游处咸共称美大宝藏殿

赞曰。此即第二同居胜也。尝者曾也。游谓游陟。处谓安处。唯一佛住诸佛不居则非好处。今显十方过现诸佛皆曾于此他化天宫游陟安处。诸圣共履故知胜处。设后诸佛现虽不住皆共称扬赞美其宫。称者称扬美者叹美。天王宫中舍有无量。今佛居彼大宝藏殿。众珍所成名之为宝。以宝为藏名为宝藏。宝藏即殿名宝藏殿。殿既高广复以贵宝之所庄严名为大宝。佛居天宫内大宝藏殿中住也。此意总表报法二身无分别智及后得智居过现佛曾所游处。并共称美大宝藏殿。亦显诸佛共居同赞故知处胜。佛受用身住报土及后得智分别法性义名为游。无分别智住法性土游戏如理号为处。由受用土具十八德法性之土具含万善。所以诸佛常共赞叹此二土故名共称美。称者称扬显名言之所不及。美者叹美假言诠以谈实德。广同法界名大。万德所成名宝。含容众善名藏。空寂之室名殿。报法二身初后二智常居此处。说法利他诸佛同居彰共游而处丽。三明并赞示具德以号藏

经曰。其殿无价末尼所成种种珍奇间杂严饰

赞曰。自下第三庄严胜也。于中有三。一明总严二列别严三列余严。此总严也。梵云末尼此云如意。其殿既以无价如意神珠所成。加以帝青大青石藏杵藏四宝四色七珍七光间错庄严朱紫交映。此意总表法性之殿如如意珠。无为万德之所严蓥。受用土殿般若为体同彼末尼。有为众善之所庄饰义同间杂严饰其殿。二大殿二身所居。如如意珠随欲所求一切皆得。末尼无价更饰之以七珍境。智莫方加严之以万德。此其总严也

经曰。众色交映放大光明

赞曰。自下第二列别严也。于中总有十四别严。此有二严也。七珍间错所以众色交映。四辉[(起-走+光)-巳+光]耀故能放大光明。又朱紫相杂举事而论交映。素黄飞彩离质而放光明。此意总表法性无著约缘。涅槃分四譬犹交映任物以成众色。又智分真俗似众色而交映。此二齐垂教彩。若色以放光明。既有照耀之功兼资破闇之力故。此二句即是二严

经曰。宝铎金铃处处悬列微风吹动出和雅音

赞曰。此有四严。一悬宝铎。二列金铃。三吹动以微风。四发音而和雅。既铿锵以振响足观听以明心。此意运以六通同宝铎。而振骇飞乎四辩若金铃。而惊济随机往利处处之义显然愍物宣扬。悬列之言攸显。若不大悲之风飘扇七辩之音无发。故知感应道成智悲之德被也。言七辩者所谓捷辩。迅辩。应辩。无疏谬辩。无断尽辩。凡所演说丰义味辩。一切世间最胜妙辩。六通等义并如下释

经曰。绮盖缯旛华幢彩拂宝珠缨络半满月等

赞曰。此有八严。罗盖扶疏飞圆华而孕绮。霞旛飘扬曳曲[彰-章+(卄/果)]以疑虹。华幢肃以干云。彩拂严而曳地。明珠磊磊映明银星。珍缨络络洁逾金镜。轮低翠岭同浮半月之晖。璧挂青岩如含满月之彩。即其化土所居天宫赞丽饰也。此意总显报法二土。四无量如绮盖以荫群生。四总持若缯旛而转众恶。三三摩地喻彼华幢。百千功德所庄饰故。四种摄事譬斯彩拂。垂遍含生拂尘垢故。四总持三三昧皆如下释。四无量摄事等不异常谈。三念住为宝珠恒时平等故。四弘愿为缨络助严众行故。无畏为半月能破外道消除邪恶故。十力为满月能破天魔令除诸恶故。或以六度为宝珠通摄万行故。三念住者谓一分赞不生爱。一分毁不生嗔。于一会中半赞半毁不爱不恚。于此三中但住大舍名为念住。四弘愿者一未离苦愿离。二未得乐愿得。三未发心修断愿发心修断。四未成佛者愿早成佛。无畏十力至下当知。此上第二列别严也

经曰。种种杂饰而用庄严

赞曰。此即第三列余严也。末尼六殿大严如是。子细别严今总彰举。所谓户牖轩窗甍栋兰楯皆随具有。即显解脱。胜处。遍处。无诤。愿智。永断习气。一切种妙智百千功德。所严二土有为无为理应尔故

经曰。贤圣天仙之所爱乐

赞曰。此即第四宝重胜也。五乘凡夫曰贤。三乘证果曰圣。五趣之极曰天。人有神德曰仙。宝而重之为爱。欣求倾渴为乐。此化土也。今显三乘之中若凡若圣俱生爱重欣求趣证。名为爱乐。此显法报二身随应土也

经曰。与八十亿大菩萨俱

赞曰。自下第五教所被机。然此经中实通凡圣如下经云。金刚手等诸大菩萨及余天众闻佛所说信受奉行。金刚手等圣人众也。余天等者凡夫众也。故知此会凡圣两集。又准化处在他化宫。显居化土理然。天宫非是净土。若准十地诸大菩萨者即应化处不说天宫。由此人处影显。可知处说天宫彰凡夫皆居秽土。众标菩萨明大士咸处净方。然则教迹幽深非愚所测故。乃但题菩萨。应此通机。化处举胜而说天宫。听众标尊但言菩萨。理兼通也。又法门仲邃但被一乘之人。玄宗寥廓遂隔二乘之众也。此被机中文势有四。一举数二陈德三列名四彰轨。此举数也。与者兼并及会之义。十万为亿八十亿者八百万也。所言大者略有四义。一数大八百万菩萨会集听法故。二德大皆具总持等诸大功德故。三业大并具妙辩才说法利生故。四名大如金刚手等十地满名故。菩萨俱者显教深妙唯被上机。欲令有情得希有法精勤渴仰信受奉行故

经曰。一切皆具陀罗尼门三摩地门无碍妙辩

赞曰。下陈德也于中有二。初列名后例指。此列名也。陀罗尼者此云总持以念慧为性。此有四种。法义及明咒能得菩萨忍。法谓能诠于一名等中持诸名等故。义谓所诠于一义中持诸义故。咒如下说。能得菩萨忍者谓有一咒速得菩萨无生法忍。弥勒菩萨说壹胝密胝吉胝思羼底(丁履反)钵陀腻莎诃。三摩地者此云等持旧云三昧。谓诸有漏无漏等定皆能平等持心于境名曰等持。谓大空等三三昧等。无碍妙辩谓法义词辩说无碍。初之二德举自利行。第三之德举利他行。此三体性。依处。修法。得位。一切义门如别处说

经曰。如是等类无量功德设经多劫说不能尽

述曰。此指例也。劫者时分。菩萨修因时行并大故赞功德经劫不穷。谓转法轮无生忍等恐文繁广故例指也。何故须赞菩萨功德。为舍众生轻慢心故。有作是言。诸声闻众久修梵行诸菩萨众应当敬礼。又令众生起净心故。菩萨尚有如是功德何况如来。故诸有情至心归礼并愿速证

经曰。其名曰金刚手菩萨摩诃萨‘观自在菩萨摩诃萨虚空藏菩萨摩诃萨金刚拳菩萨摩诃萨妙吉祥菩萨摩诃萨大空藏菩萨摩诃萨发心即转法轮菩萨摩诃萨’摧伏一切魔怨菩萨摩诃萨

述曰。下列名也。此有八人举其胜者。言菩萨摩诃萨者菩提言觉即一切智。萨埵言有情即求菩提之有情也。此通三乘。摩诃言大萨埵如前为简取大故言摩诃萨。又菩提者所求之果智境也。言萨埵者所为拔济之有情悲境也。即是自利利他二德。又萨埵者是勇健义。精进勇猛求大菩提故言菩萨。此后二解许通凡圣。今取第十金刚心者故复说言摩诃萨也。言金刚手手者取义执义。常起信手取诸功德故。起智慧手执受金刚本法性故。又信智二手犹如金刚坚固难坏非邪恶友所能坏故。观自在者即观世音。观谓观察观诸有情身语心性。受苦恶时或祈念时应时为拔往诣救护名观自在。神用无方得自在故。虚空藏者以空为藏藏诸珍宝。见诸有情贫无财宝从虚空中雨种种宝施贫乏故。金刚拳者拳者破坏击碎之能。发起坚固智慧之拳击破生死烦恼业等。如以金刚拳击碎诸物因以名也。妙吉祥者即文殊师利先云妙德。妙者善义。由善能作胜福利事饶益有情名妙吉祥也。大空藏者。大空即是遍满法界。真如空理以此为藏。为诸有情说大空法。以此法施令诸有情皆获种种圣法财宝名大空藏。发心即转法轮者。轮谓摧伏移转之义。法谓教法如法轮章说法轮义。此大菩萨从初发心终至十地凡所举措身语意业皆为有情说深妙理转大法轮行饶益故。摧伏一切魔怨者。魔谓四魔如前已说。此四能破有情善事为众生怨。此大菩萨住金刚心离分段死及诸烦恼故能摧伏一切魔怨。此八名中金刚手智取善为名。观自在悲拔苦为号虚空藏济贫为字。金刚拳破恶为能妙吉祥作善为目。大空藏显真为称。转法轮说法为利。摧伏魔怨害贼为益。或智慧慈悲一对或显真显妄一对。拳如妄法故或显有为无为善法一对。或进善破恶一对。随其所应准名知义

经曰。如是上首有八百万大菩萨众前后围绕

赞曰。此第四彰轨也。八百万者八十亿也。言前后者以方为首故有前后。各见世尊在其前坐为其说法。既无背面宁有前后。如珠星而拱朗月。譬金山而辅妙高。若众梵之绕梵王。似诸天之围天帝。尊人重道渴法希益。翘注一心冀闻深致

经曰。宣说正法初中后善文义巧妙纯一圆满清白梵行

赞曰。此即第六叹法胜德。宣说正法是总句也。刊定可轨离邪分别名为正法。宣显未闻为初开智说彰旧理为久悟人。初中等者总有十德以彰教胜。瑜伽师论八十三云。一初善二中善三后善四文巧五义妙六纯一七圆满八清净九鲜白十梵行。彼自释言。初善者谓听闻时生欢喜故。由法殊胜初有听闻即令生喜。中善者谓修行时无有艰苦远离二边。依中行故既听闻已正修行时远离苦乐邪怠二边。依处中行以求出世故中善也。后善者谓极究竟离诸垢故。及一切究竟离欲为后边故。谓佛言教理极究竟性离诸垢能现涅槃。依修行者能离欲故。文巧者谓善缉缀名身等故。及八语具得圆满故。八十一云。先首美妙显了易解乐闻无依不逆无边名八语具。如彼广说。其能诠文善能缉缀。义妙者。谓能引发胜利乐故。其所诠义能引利乐。纯一者。谓不与一切外道共故。其所说法唯佛能说诸外道等不能说故。所说法中非杂外道邪恶法故。圆满者。谓无限量故最尊胜故教广无限义深无量其修学者功德无量故最尊胜。清净者。谓自性解脱故其所说法一刹那中亦无过失。离三毒根离诸系缚故性解脱非有三毒而起说故。鲜白者。谓相缚解脱故。非唯一念无其过失相续论之亦离诸过。又前清净法体离过此中鲜白能令觉者身亦鲜白。梵行者。谓八支圣道此出梵行之体当知此道由纯一等四种妙相之所显说故。八圣道名为梵行。若依此解与古不同。此上十德总显经胜

经曰。尔时世尊‘为诸菩萨说一切法甚深微妙般若理趣清净法门此门’即是菩萨句义

赞曰。自下明第二应机广说分。于中总有十四段经。合之为三。初六段明菩萨境。次六段明菩萨行。后二段明菩萨果。一切佛教所诠义理不离此三。说境先令知法染净因果善恶此可欣厌此可修断。说行次令知依境起行修断之法。说果后令知行行得果殊胜之相。初六段明境复分为三。初二段明体境。第一甚深微妙清净法门。即是对妄显真实相真如境体。第二寂静法性现等觉门。即是除闇显于观照正智境体。真如是性正智是相。说有前后下皆准知。次二段明行境。第三调伏众恶普胜法门。由观实相能伏众恶。第四平等智印清净法门。由观观照智慧照明。后二段明果境。第五法王灌顶智藏法门。显由二行得位财果。第六如来智印金刚法门。显由二行得自体果。次六段明行复分为三。初二段明依实相断修之相。第七离诸戏论轮字法门。由观无相断分别故。第八入广大轮平等法门。由观平等修证真故。次二段明依观照修断之相。第九真净供养无上法门。由依观照修真供养故。第十能善调伏智藏法门。由依观照能除忿等故。后二段明依二法遍修之相。第十一性平等性最胜法门。修观实相一切人法平等遍满故。第十二有情住持胜藏法门。修观观照遍诸人法皆善缘故。由观前六境而起六行。已后二段明得果。第十三无边无际究竟法门。得二果时广深一味极殊胜故自利果德。第十四甚深理趣无上法门。得二果已自利利他为三界主随诸有情所愿皆证利他果德。就第一段甚深微妙清净法门。即是对妄显真实相真如境体。中文分为三。初叙世尊所说法门之名。次叙世尊所说理趣之义。后叙世尊所说法门之德。此即第一叙法门之号。尔时者发端义。处天宫众云集所化机感法王应现说听悬会故言尔时。世尊者能说教主。为诸菩萨所被深机。说一切法。有为无为诸法体事。甚深微妙法性真如非凡所测名曰甚深。二乘莫知复称微妙。般若理趣即深妙法理。谓法性道理义理。趣谓意况所趣旨趣。此意即说般若之文所诠深趣观照般若所取意趣。自性洁白名清离诸垢染名净。门者虚通趣入之道。即显照理会证之由。欲证二空要闻此教理。依之修学方可会真。不知何名强名门也。此门是何。此门即是菩萨句义。菩萨三义已释如前。言句义者句谓能诠声之差别。不说文名但说句者。句诠义周非文名故。义谓所诠法之差别。不说自体但说义者。法义圆被非自体故。句既能诠所诠唯义欲显此教能诠一一皆圆满。故所诠一一亦周被故。举宽能诠及宽所诠。文名体法皆已摄故。欲求菩提于有情之类起大悲智而起修学及求菩提。发勇猛者名为菩萨。今此理趣能诠之教即是能诠菩萨之句。所诠之理即是所诠菩萨之义。若依此教而行此义证此理者名为菩萨。后道满时名之为佛遂舍因名。此言菩萨略有三位。一初发心二修正行三证法性。三位皆须依此修学。方可得证故名为门

经曰。云何名为菩萨句义

赞曰。自下第二叙佛所说理趣之义。于中有三。初佛自问。次述其义。后劝修学此初问也

经曰。谓极妙乐清净句义是菩萨句义

赞曰。自下述其义。于中有二。初释其义后释所由。若依清辨世俗可有胜义皆空今说正义空寂。若依护法应依下释。就释义中合有四十一句义。释菩萨句义。复分为二。初有十门明菩萨修果清净句义以显菩萨所有句义。后色蕴空寂下三十一门依诸法本性及所由空寂清净句义以显菩萨所有句义。就初十门明菩萨修果清净句义以显菩萨句义之中复分为五。然菩萨修略有五种。所谓集总修。无相修。无功用修。炽盛修。无喜足修。谓集一切总为一聚简要修习初修行者诸恶皆断诸善皆修诸生皆度。或观一切为骨琐等或观此身从头至足唯脓血等名集总修。于离十相真法界中遣事差别而修习故名无相修。渐修行者应观无相。为令此修纯熟自在不假功力任运现前。名无功用修。虽无功用修有胜劣为令增胜说炽盛修。或虽炽盛恐有少所得便生喜足。谓且修此余何用为为令勿厌乃至菩提名无喜足修。今显菩萨得转依时地前名为益力损能转。由习惭愧及胜解故益圣道力损二障能。亦可分得五修之果。十地正证正行五修。今此十句显五修果至文当知。此即第一顺清净分无所分别。无相现行当来佛果名清净分。此能引彼故名顺。如佛轮王鲜白盖等无所分别无相现行。由得于此顺清净分。无分别故。悟极妙乐即无漏智。地上正证地前分得。若有分别不顺清净得苦恶果。今无分别顺清净分故极妙乐苦果永无。触无相乐故。此极妙乐非分别引生故名清净。能诠此句。此句所诠即是菩萨句义。诠辨闻行即此。是故下文所说菩萨句义并准此知。更不重释

经曰。诸见永寂‘清净句义是菩萨句义微妙适悦清净句义’是菩萨句义

赞曰。此中二句义。即五果中离种种想得法苑乐。由见永寂故离诸相。诸相多由诸见生故。由得法苑乐故微妙适悦。诸见者五见等。地前地上伏断无余故言永寂。以法界为苑于中游玩故。于此喜悦名法苑乐。证会名得。如王宫外上妙园苑游戏其中受胜喜乐。法界亦尔。求证正证皆生乐故

经曰。渴爱永息‘清净句义是菩萨句义胎藏超越清净句义是菩萨句义众德庄严清净句义’是菩萨句义

赞曰。此中三句。渴爱者谓贪欲由渴爱生故名渴爱。谓如鹿渴遥见阳烟将以为水。而起贪求奔走往趣。有情亦尔。由烦恼渴见不净物谓以为净。广起贪求故名渴爱。此润生惑以爱为先或通发业。诸烦恼等贪为首故。此但举之。地前渐伏地上能除故名永息。由因灭故苦果不生。是故胎藏亦能超越。举一胎生意离分段处变易故。此之生死因果既亡遂得殊胜变易异熟。故于地前种相好因化成八相。十地之位得诸相好清净功德庄严其身。恶法既亡胜果斯起即是念念消融一切粗重依止有漏身器。依止本识鞕强不安名为粗重。如痈疮等。三苦迫逼不安稳故。若在地前由闻般若修行无相。令闻熏增销融本识依上粗重如大良药销众病块。若在十地正能断之名销融也。粗重既灭故渴爱息。胎藏超越得无粗重。众德庄严爱能润发。下缘生中自当广说。胎藏身者。瑜伽论说胎藏有八位。已结凝箭内稀名羯剌滥位。表里如酪未至肉位名頞部昙位。若已成肉仍极柔软名闭尸位。若已坚厚稍堪摩触名健南位。肉转增长支分相现名钵罗赊佉位。此后发毛爪生位眼等根生位依处分明愿名形位。然由先业或母恶缘令此胎藏或发或色或皮或支变异而生。由业及母多习灰盐等味令发毛稀鲜。由业及母多习燸热令色黑黯。近寒室等令色白生。多啖热食色极赤生。由业及母多习淫欲皮或癣疥或癞等。由业及母多习驰走跳踯威仪或倒或屈支分缺减。女居左胁倚背向腹。男居右胁倚腹向背。胎成满时其母不堪持此重胎。内风便起发生苦痛。又此业报生分风起令头向下足便向上。胎衣缠裹而趣产门。其正出时胎衣遂裂分之两腋。生产门时名正生位。时令其母苦痛无量胎身亦尔。此大般若第五百八十九卷说。此胎藏身三十六物不净所成。一发毛二爪三齿四皮革五血六肉七筋八脉九骨十髓十一心十二肝十三肺十四肾十五脾十六胆十七胞十八胃十九大肠二十小肠二十一屎二十二尿二十三洟二十四唾二十五涎二十六泪二十七垢二十八汗二十九淡三十脓三十一肪三十二[月*冊]三十三脑三十四膜三十五[強-弓+目]三十六聍。既生长已次起六触。次随世学次耽家室。次造生业次受色等苦乐境界。次随其业流随五趣复受此身。菩萨不尔。随愿受生设入母胎。即至钵罗赊佉位自无恶业。亦不令母习近恶缘自损发等。亦不令母受诸苦恼。既生长已亦无如前所说恶过。唯以悲智受生为业故名超越。变易之身无是事也。具三十二相八十随好故名众德庄严。悲智熏修得是身故

经曰。意极猗适‘清净句义是菩萨句义得大光明清净句义’是菩萨句义

赞曰。此中二句义即是能正了知无量无分限相大法光明。得达法界等十方无边无分量相故极猗适。显照行故名法光明。既能广达契会法性证真妙理意极猗适。能了此智分明显照名法光明。此二离垢故名清净

经曰。身善安乐‘清净句义是菩萨句义语善安乐清净句义是菩萨句义意善安乐清净句义’是菩萨句义

赞曰。此中三句即是第五为令法身圆满成辨能正摄受后后胜因。第十地名圆满在佛地名成辨感此之因最是殊胜说为胜因。即是此中三业安乐清净之义。正由前位意善安乐语身二业助安乐故。后后法身圆满成辨。三业不净逼迫现前便无安乐。后后法身无由成辨。此上十句义明菩萨修果清净句义。以显菩萨所有句义。此中清净若是染者离过清净。若善者修习清净。菩萨句义不离此。故地前分得地上正证。故益力转在地前位

经曰。色蕴空寂‘清净句义是菩萨句义受想行识蕴空寂清净句义是菩萨句义眼处空寂清净句义是菩萨句义耳鼻舌身意处空寂清净句义是菩萨句义色处空寂清净句义是菩萨句义声香味触法处空寂清净句义是菩萨句义眼界空寂清净句义是菩萨句义耳鼻舌身意界空寂清净句义是菩萨句义色界空寂清净句义是菩萨句义声香味触法界空寂清净句义是菩萨句义眼识界空寂清净句义是菩萨句义耳鼻舌身意识界空寂清净句义’是菩萨句义

赞曰。自下第二三十一门依诸法本性及所由空寂清净句义以显菩萨所有句义。于中分二。初有二十六门明世俗胜义法所依所从本性空寂清净句义。以显菩萨所有句义。第二善非善下五对通染净法差别本性空寂清净句义。以显菩萨所有句义。初中分三。初有九门唯明世俗法所依本性空寂清净句义。以显菩萨所有句义。次有十六门唯明胜义法所从本性空寂句义。以显菩萨所有句义。后有一门总明世俗及胜义法所依本性空寂清净句义以显菩萨所有句义。初中九门即分为九。此所牒中有三句义。即三科法。且如凡夫遍计所执色蕴等法。本来空寂空寂即清净。但有妄心境都无故。依他门有本性亦空。经自说言。色如聚沫受喻浮泡想同阳焰行类芭蕉识犹幻事。色如聚沫者。速增减故水界生故。思饮食味水所生故。不可捼接故。非如泥团可令转变造作余物故。又实非聚似聚显现乃能发起有情解故。受喻浮泡者。三和合生不久坚住相似法故。谓下有水上有天雨傍风所击有浮泡生。三和合为缘生受亦尔。触等心所法略不说为缘又速疾谢起不坚住故。想同阳焰者。飙动性故。无量种相变异生故。令于所缘发颠倒故。令其境界极显了故。由此分别男女等相成差别故。行类芭蕉者。不坚实故。枝叶广大速即坏故。如明眼人持利刃入于林。取端直芭蕉柱截其根披枝叶。彼于其中都无所获。何况有实。谓圣弟子以妙慧刃于五趣林。取作受我见名之为柱截其根。断我见故。委细简择名披枝叶。唯有种种思等诸行差别法故。何况有余常恒之我故如芭蕉。识犹幻事者。譬如幻士住四衢道造作四种诸幻化事。言幻士者喻随福非福不动行识。住四衢道者住四识住。四幻事者谓象马等此虽可见而无真实象马等事。如是应知随福等识住四识住虽有作受我等之相然无真实我性可得。又识于中隐其实性外现异相犹如幻像。故知依他亦性空寂。幻法上无自然性故名之为空。圆成之体实理而说非空不空。由依二空门方可显证亦可名空。故三种法皆名为空。上护法解。清辨释言。又世俗妄说色等可有胜义入真色等皆无。故本空寂如第二月妄有即真无。故本皆空寂下诸空寂皆准此知。并应二解。但解其法不解理也。诠空寂句。所显空寂。即是菩萨能诠之句。所诠之义。依此证此名菩萨。故集聚荷担是蕴义。出生是处义。因性族类是界义。变碍名色。领纳名受。取像名想。造作名行。了别名识。以心所中受想二法资助心强。修禅无色此二用胜。外道说为生死因。故别名为蕴。蕴但摄有为无为非聚故。出生名处根不坏。境现前能生于识。故根及境别得处名。所生之识不开为处此亦通无为。为境生识故。六根有取各自境用故立别名。六境为根各别取故所以名别。性义因义名之为界。故开六识立十八界。亦通无为。为破有情识烦恼执对上中下三根差别说此三科。三科并通有漏无漏。余义并如诸论处说

经曰。眼触空寂‘清净句义是菩萨句义耳鼻舌身意触空寂清净句义是菩萨句义眼触为缘所生诸受空寂清净句义是菩萨句义耳鼻舌身意触为缘所生诸受空寂清净句义’是菩萨句义

赞曰。此中二句义。于心所中举二为首。以有三位五位别故。根等生时近而胜故。能生心所触等强故。触谓触对即是触数。令心心所同触于境名之为触。触由根境识三和生。能和三种故诸经论名为三和。由根变异引触起时胜彼识境故名眼触乃至意触。由触分别领似三和生心所用诸心所中故先说触。受能同触五三位别。近而相顺但说六触为缘所生六种受数不说一切。又此二法说为有支说为异熟故同蕴等。说其空寂所有句义即是菩萨所有句义。不说自余诸心所等

经曰。地界空寂‘清净句义是菩萨句义水火风空识界空寂清净句义’是菩萨句义

赞曰。此一法门即是六界成众生者。四大可知。所言空者即内身中空界之色。识谓八识。此中但说三种根本。谓色所依但说四大。行动所依说空界。内身无此空界之色不得动故。心所所依但说于识。论其根本故但说六根。成积聚形故说四大。能起分别故说于识。能有往来转动等业故说空寂不增不减

经曰。苦圣谛空寂‘清净句义是菩萨句义集灭道圣谛空寂清净句义’是菩萨句义

赞曰。此一法门即是四谛。为二乘者差别安立故名世俗。苦者逼迫不安稳不可乐义。即有漏法一切皆是。一切有情及器世界并是苦故。烦恼业苦并是苦故。果苦有三或说有八。三谓行苦苦苦坏苦。八谓生苦老苦病苦死苦怨憎会苦爱别离苦求不得苦。略摄一切五取蕴苦。生苦有二因。一众苦所逼。二余苦所依。谓于母胎生熟藏间具受种种极不净物所逼迫苦。正出胎时复受支体逼切大苦。由有生故老病死等众苦随逐。老苦者时分变坏苦故云云。病苦者大种变异苦故云云。死苦者寿命变坏苦故云云。余苦可解。各各应知以古来说。谛者实义。苦真是苦更无异苦故名为谛。凡夫不知唯圣所识。圣者之谛故名圣谛。集者因义。谓烦恼业能集生苦故。苦摄有漏集除苦果。灭者择灭即是涅槃。此有四种。道谓圣道。通运路迳所由之义。即诸圣行无漏有为。初二有漏后二无漏。此四妙理体一真如。由依诠别以分四种故性清净

经曰。因缘空寂‘清净句义是菩萨句义等无间缘所缘缘增上缘空寂清净句义’是菩萨句义

赞曰。亲能辨体生长诸法名之为因。以因为缘故曰因缘。缘谓缘藉四缘通称。即除佛果因位七识见相分等能熏种者名曰因缘。种通诸位自类相生及生现者皆名因缘。皆亲辨体生自果故。等无间者即心心所各自识聚。前望于后为无间缘。等有二义。一相似名等。且心所中前亦一受后亦一受。以体等故名曰相似。二力齐等名之为等。或前念一法等与后一法为无间缘。前念一切等能与后一法为无间缘故名等无间缘。是开道义。如前念眼识与后自眼识聚为无间缘。非与耳等或与并生。多少不等故。所缘缘者境有体法能生心等名之为缘。心等之上带彼境相。说所取境名为所缘。具二支义有所简别。增上缘者是威势义。与彼威势令生等故。等无间缘体唯心心所。其所缘缘通一切法。此二缘唯待心心所为果故。因缘之体通一切有为其果亦尔。其增上缘体果俱通一切法尽

经曰。无明空寂‘清净句义是菩萨句义行识名色六处触受爱取有生老死空寂清净句义’是菩萨句义

赞曰。此十二缘起中无明以痴为体发业之惑。行通三业非福及福不动之业。此二皆通现行种子。识唯本识。名色通五蕴。六处唯六根。触受二法唯异熟性。当体为体。识支以下五唯种子。爱唯贪爱以为自体。取通一切烦恼为性。此二亦通现行种子。有体合用六支为体。谓爱取二润。前行等已下六支当果现起。后有果生说名为有。有唯是种子。从中有位至本有位未衰变。来所有五蕴皆名生支。从衰变位乃至命终所有五蕴名为老死。谓由无明造善恶行熏于本识。与识等五相感属已。爱取合润。此前六支当果可生名之为有。趣相生起名之为生。衰变命终名之为死。十二有支体唯有漏。如唯识等广说其相

经曰。布施波罗蜜多空寂‘清净句义是菩萨句义净戒安忍精进静虑般若波罗蜜多空寂清净句义’是菩萨句义

赞曰。自下第二有十六门。明胜义法所由本性空寂句义。以显菩萨所有句义。于中有三。一明行有六门。二明位有二门。三明德有八门。行中有三。一总六度行。二所观理行。三别修起行。此即初也。施有三种。谓财法无畏此以无贪及彼所起二业为性。戒有三种。谓律仪摄善饶益有情。此以受菩萨戒时三业为性。安忍有三种。谓安受苦耐怨害谛察法。此中如次以无嗔精进审慧及彼所起三业为性。精进有三。谓被甲摄善利乐。精进此三以勤及彼所起三业为体。静虑有三。谓安住引发辨事。静虑此三但以等持为性。般若有三。谓加行正智后智。般若此三皆以择法为性。此前所说但说自性。若并眷属一一皆以一切俱行功德为性。何故此六名到彼岸。由七最胜所摄受故。一安住胜要有菩萨性。二依止胜要大菩提心。三意乐胜要悲愍有情。四事业胜要具行一切。五巧便胜要无相智所摄。六回向胜要回向菩提。七清净胜要不为二障杂。由具七义名到彼岸。不尔即非。由斯施等皆有四句。一施非波罗蜜不具七胜故。二波罗蜜非施见他行施自具七故。三亦施亦波罗蜜自行施复具七故。四非施非波罗蜜自不行施见他行施不生随喜故。修此六度有其五种。一依止任持修。二依止作意修。三依止意乐修。四依止方便修。五依止自在修。第一依止任持修有四。一依因修。谓依种性力修习正行。二依止报修。谓由胜身修习正行。三依止愿修。谓由本愿修习正行。四依简择慧修习正行。第二依止作意修亦有四。一依胜解于度一切相应契经起增上解。二依爱味于度见胜功德深生爱味。三依随喜于一切有情所行六度深生随喜。四依意乐修于自他当来胜品六度深生愿乐。第三依止意乐修有六。一无厌意乐如施无厌者。谓菩萨于一刹那以三千大千世界七宝唯布施一有情。又以殑伽沙等身命布施。如是布施住殑伽沙劫如于一有情。如是乃至于一切有情界如是施。时皆令于无上菩提速得成就菩萨尔时犹不厌足名施无厌意乐。二施广大意乐。菩萨如是展转相续无一刹那有退有断。乃至究竟坐菩提座名施广大意乐。三欢喜意乐。菩萨如是行施之时。于来求者生大欢喜。来求之者虽生欢喜不如菩萨名施欢喜意乐。四恩德意乐。菩萨如是行施之时。观彼求者于我已身有大恩德。不见已身于彼有恩。由资助我无上菩提故名施恩德意乐。五无染意乐。菩萨如是虽于无量诸有情所兴大施福。而不祈报恩当来异熟名施无染意乐。六善好意乐。菩萨如是以所修行广大施聚所得异熟施诸有情不自为己。又以此福共诸有情回向无上正等菩提名施善好意乐。广说余五度如对法等。第四依止方便修。谓由无分别智观察三轮皆清净故。由此速成所修行故。第五依止自在修。有三。一身自在谓自性受用身。二行自在谓变化身等。示现诸有情一切种同法行故。三说自在。谓说六度一切种差别无有滞碍故

经曰。真如空寂‘清净句义是菩萨句义法界法性不虚妄性不变异性平等性离生性法定法住实际虚空界不思议界空寂清净句义’是菩萨句义

赞曰。第二所观理行。此前应说二十空等。以空即空寂。名字既同不应臾立所以不说。此真如等体虽即空寂之所显名字既别所以别立。此中八名。体一真如。真谓真实显非虚妄。如谓如常表无变异。即是湛然不虚妄义。遮妄显常名真如也。法界者三乘妙法所依相故。法性者一切诸法真实本体。不虚妄性者离妄颠倒不妄性也。不变异性者谓一切时不改转故。平等性者遍诸法故。离生性者。生谓生梗如生食等。此即虚妄有漏诸法离此生梗坚强之性。又生者生灭。离生灭体名离生性。实际者无倒所缘故。实谓无颠倒此处究竟故名为际。过无我性更无所求故。此中文略但举八名。第一会中有十二名。对法等中有其六名。体但一如名有差别。约其所治随其诠别故成多种

经曰。四静虑‘空寂清净句义是菩萨句义四无量四无色定空寂清净句义’是菩萨句义

赞曰。自下第三别修起行。于中有四。一禅无色行。二菩提分行。三解脱门行。四别对治行。此即初也。静其心专一虑定慧齐均功德殊胜得静虑名。离欲恶不善法。有寻有伺离生喜乐初静虑。第二离寻伺喜静虑。第三已离喜乐静虑。第四已离寻伺喜乐舍念清净静虑。此等总说初二三四以为名别。更无别名。唯在色地通有无漏。四无量者慈悲喜舍。与乐名慈无嗔为性。拔苦名悲不害为性。不离乐为喜不嫉善根为自性。令利益为舍舍善根为性。通有无漏遍在四禅境行俱宽故名无量。四无色者谓空识无边无所有处非想非非想处。此通有无漏三乘俱起

经曰。四念住空寂‘清净句义是菩萨句义四正断四神足五根五力七等觉支八圣道支空寂清净句义’是菩萨句义

赞曰。此即第二菩提分行。四念住者身受心法。以慧为性。慧由相应之念住此四境之中名为念住。四正断者。一律仪断。谓已生恶法为令断故生欲策励。二断断。谓未生恶法为令不生故生欲策励。三修习断。谓未生善法为令生故乃至策心持心。四防护断。谓于已生善法为欲令住。乃至策心持心。此四种以精进为体。策发于慧自能渐伏名为正断。四神足者欲勤心观。由此四故引生于定故。四神足以定为体。运转最胜自在为神由定能得能证于此故名神足。五根者信进念定慧。生出世法此为上首故名为根。此五于诸出世法中深生胜解。清信难伏说名为力。天魔外道及沙门等不能伏故。此五随名各自为体。七等觉支者谓择法精进喜轻安定舍及念为七。此七唯无漏在见道位起。觉者择法。支谓支分。择法觉是觉亦觉支。余觉支而非觉如其自名即为其体。此七能遍观诸法故立以等名。等是遍义。八圣道支者正见正思惟正精进正语正业及正命正念及正定。语业命三戒蕴所摄。余体如名修道位起。诸圣有学由八支摄行迹正道能无余。断一切烦恼能于解脱究竟作证。是故此八名圣道支。合此三十七种道品总以十一法而为自体。一慧即四念住慧根力择法觉正见支。二精进即四正断精进根力精进觉支正精进。三定即四神足定根力定觉支正定。四信即信根力。五念即念根力念觉支正念。六欲即四神足。七喜受即喜觉支。八轻安即安觉支。九舍即舍觉支。十寻即正思惟实体即慧。十一色即无表戒正语业命。此中假实．修法．废立．开合．学摄体支．对辨．并如别钞

经曰。空解脱门‘空寂清净句义是菩萨句义地相无愿解脱门空寂清净句义’是菩萨句义

赞曰。自下第三解脱门行。观空无我名之为空。观灭离相名为无相。观苦集道诸有为法不生愿求名为无愿。由此三种能入谛理。名之为门。体是无漏法。复能证解脱故名解脱。若但言空无相无愿即通三慧。定之与散通有无漏。若言三昧即唯修慧。唯定非散通有无漏。言解脱门即唯修慧。唯定非散不通有漏。此三或总或别缘谛如余处说。又除见说空。离爱说无愿。离无明说无相

经曰。八解脱空寂‘清净句义是菩萨句义八胜处九次第定十遍处空寂清净句义’是菩萨句义

述曰。自下第四别对治行。八解脱者一内有色观诸色。二内无色观诸色。三净解脱身作证。四空处。五识处。六无所有处。七非想非非想处。八灭尽解脱。谓诸圣者能顺无漏能离诸障名为解脱。八胜处者一内有色观外色少若好若恶若劣若胜。于彼诸色胜知胜见得如实相。二内有色观外色多。余如前说下准此知。三内无色想观外色少。四内无色想观外色多。五内无色想观外诸色若青青显青现青光。六内无色想观外色黄。七内无色想观外色赤。八内无色想观外色白。胜伏所缘名为胜处。九次第定者谓四静虑四无色及灭尽定。粗细渐次上下次故。十遍处者谓地水火风青黄赤白空识无边处。观遍一切其量广大名为遍处。此等体性。增减。所由无量义门如别处说

经曰。极喜地‘空寂清净句义是菩萨句义离垢地发光地焰慧地极难胜地现前地远行地不动地云无法善慧地空寂清净句义’是菩萨句义

赞曰。自下第二明胜义位。于中有二。初大乘位后三乘位。此即初也。但明因中菩萨十地。一极喜地。初获圣性具证二空。能益自他生大喜故。二离垢地。具净尸罗远离能起微细毁犯烦恼垢故。三发光地。成就胜定大法总持能发无边妙慧光故。四焰慧地。安住最胜菩提分法烧烦恼薪慧焰增故。五极难胜地。真俗两智行相互违合令相应极难胜故。六现前地住缘起智引无分别最胜般若令现前故。七远行地。至无相住功用后边出过世间二乘道故。八不动地。无分别智任运相续相用烦恼不能动故。九善慧地。成就微妙四无碍解能遍十方善说法故。十法云地。大法智云含众德水。弊如空粗重充满法身故。此地总以有为无为一切功德以为自性。与所修行为胜依持。令得生长。故名为地

经曰。净观地‘空寂清净句义是菩萨句义种性地第八地具见地薄地离欲地已办地独觉地菩萨地如来地空寂清净句义’是菩萨句义

赞曰。此即第二明三乘位。初二地中略有二释。一云净观地。在解脱分位及前三善根。种性地唯在世第一法。故婆娑云。有说种性地法亦可说有退。二解云。净观地唯在解脱分位未为谛观。种性未定但净修心观身受等故名净观。种性地通在四善根。暖等位中种性方定不可转故。第八地谓预流向。从阿罗汉向前数故。即住见道前十五心。具见地者谓预流果。此位具足十六心故。薄地谓一来。于欲界九品惑已断六品故。离欲地谓不还。决定全离欲界惑故。已辨地者谓阿罗汉。我生已尽所作已辨故。余之三地随名释义。前唯一乘今通师弟长短作说。故十地别

经曰。一切陀罗尼门‘空寂清净句义是菩萨句义一切三摩地门空寂清净句义’是菩萨句义

赞曰。自下第三明所成德。依行入位成此德故。于中有八德。此即第一引生诸德。一是总持门。二是等持门。前此经序。菩萨德中已略解讫。由此二种引生诸德故

经曰。五眼空寂‘清净句义是菩萨句义六神通空寂清净句义’是菩萨句义

赞曰。此即第二观照化生德。五眼者谓肉天慧法及佛眼。照了导义名之为眼。六神通者一神境通二天耳通三心差别通四宿住随念通五死生通六漏尽通。运转自在名神事无障拥名通。此二体性如经广说。及如瑜伽论第五十四六十九对法论中第十四卷等文解释

经曰。如来十力‘空寂清净句义是菩萨句义四无所畏四无碍解大慈大悲大喜大舍十八佛不共法空寂清净句义’是菩萨句义

赞曰。此即第三降伏不共德。十力者一处非处智力。二自业智力。三静虑解脱等持等至智力。四根胜劣智力。五种种胜解智力。六种种界智力。七遍趣行智力。八宿住随念智力。九死生智力。十漏尽智力。由与利生功德相应毕竟胜伏一切魔怨。大威力故说名为力。总以信等五根为性。四无畏者一正等觉无畏二漏尽无畏三障法无畏四出苦道无畏。于大众中正师子吼。沙门魔梵无能难者故名无畏。四无碍解者一法无碍解。二义无碍解。三训词无碍解四辩才无碍解。通达无碍名无碍解。大慈大悲大喜大舍者遍缘三界。周及四生行境宽广故名为大。慈悲等相如前已说。四无量境狭在欲色。通在三乘。假实观摄。此唯佛具境行宽遍通在三界。唯是实观。十八佛不共法者。一身无误失越杌等。二无卒暴扬声等。三无忘失念久所作等。四无不定心恒在定故。五无种种相生死涅槃等。六无不择舍利乐等。此上六种由所知障有此习故。七者欲无退。八精进无退。九念无退。十定无退。十一慧无退。十二解脱无退。此上六种依所知障修断事中而无退减。十三身业智为前导。十四语业智为前导。十五意业智为前导。十六知过去。十七知未来。十八知现在无差无碍。此上六种亦由有彼所知障习。此十八法唯佛所有。非二乘等故名不共。余体义门废立增减如瑜伽等广说其相。然此大经亦具宣说应勘异同

经曰。三十二相‘空寂清净句义是菩萨句义八十随好空寂清净句义’是菩萨句义

赞曰。此即第四相好殊异德。今依大般若波罗蜜多经卷第三百八十一。佛言善现云何如来应正等觉三十二大士相。善现。世尊足下有平满相。妙善安住犹如奁底。地虽高下随足所蹈皆悉坦然无不等触是为第一。世尊足下千辐轮文辋毂众相无不圆满是为第二。世尊手足皆悉柔软如睹罗绵胜过一切是为第三。世尊手足一一指间犹如雁王咸有鞔网。金色交络文同绮画是为第四。世尊手足所有诸指圆满纤长甚可爱乐是为第五。世尊足跟广长圆满与趺相称胜余有情是为第六。世尊足趺修高充满柔软妙好与跟相称是为第七。世尊双腨渐次纤圆如医泥耶仙鹿王腨是为第八。世尊双臂修直佣圆如象王鼻平立摩膝是为第九。世尊阴相势峰藏密其犹龙马亦如象王是为第十。世尊毛孔各一毛生柔润绀青右旋宛转是第十一。世尊发毛端皆上靡右旋宛转柔润绀青严金色身甚可爱乐是第十二。世尊身皮细薄润滑尘垢水等皆所不住是第十三。世尊身皮皆真金色光洁晃曜如妙金台众宝庄严众所乐见是第十四。世尊两足二手掌中颈及双肩七处充满是第十五。世尊肩项圆满殊妙是第十六。世尊髆腋悉皆充实是第十七。世尊容仪洪满端直是第十八。世尊身相修广端严是第十九。世尊体相纵广量等周匝圆满如诺瞿陀是第二十。世尊颔臆并身上半威容广大如师子王是二十一。世尊常光面各一寻是二十二。世尊齿相四十齐平净密根深白逾珂雪是二十三。世尊四牙鲜白锋利是二十四。世尊常得味中上味喉脉直故。能引身中诸支节脉所有上味风热淡病不能为杂。由彼不杂脉离沉浮延缩坏损拥曲等过。能正吞咽津液通流故身心适常得上味是二十五。世尊舌相薄净广长能覆面轮至耳发际是二十六。世尊梵音词韵和雅随众多少无不等闻。其声洪震犹如天鼓。发言婉约如频迦音是二十七。世尊眼睫犹若牛王绀青齐整不相杂乱是二十八。世尊眼睛绀青鲜白红环间饰映洁分明是二十九。世尊面轮其犹满月眉相皎净如天帝弓是第三十。世尊眉间有白毫相右旋柔软如睹罗绵鲜白光净逾珂雪等是三十一。世尊顶上乌瑟腻沙高显周圆犹如天盖是三十二。善现是名三十二大士相。善现云何如来应正等觉八十随好。善现世尊指爪狭长薄润光洁鲜净如花赤铜是为第一。世尊手足指圆纤长佣直柔软节骨不现是为第二。世尊手足各等无差于诸指间悉皆充密是为第三。世尊手足圆满如意软净光泽色如莲华是为第四。世尊筋脉盘结坚固深隐不现是为第五。世尊两踝俱隐不现是为第六。世尊行步直进庠审如龙象王是为第七。世尊行步威容齐肃如师子王是为第八。世尊行步安平庠序不过不减犹如牛王是为第九。世尊行步进止仪雅犹如鹅王是为第十。世尊回顾必皆右旋如龙象王举身随转是第十一。世尊支节渐次佣圆妙善安布是第十二。世尊骨节交结无隙犹若龙盘是第十三。世尊膝轮妙善安布坚固圆满是第十四。世尊隐处其文妙好威势具足圆满清净是第十五。世尊身支润滑柔软光悦鲜净尘垢不着是第十六。世尊身容敦肃无畏常不怯弱是第十七。世尊身支坚固稠密善相属着是第十八。世尊身支安定敦重曾不掉动圆满无坏是第十九。世尊身相犹如仙王周匝端严光净离翳是第二十。世尊身有周匝圆光于行等时恒自照曜是二十一。世尊腹形方正无欠柔软不现众相庄严是二十二。世尊脐深右旋圆妙清净光泽是二十三。世尊脐厚不窊不凸周匝妙好是二十四。世尊皮肤远离疥癣亦无黡点疣赘等过是二十五。世尊手掌充满柔软足下安平是二十六。世尊手文深长明直润泽不断是二十七。世尊唇色光润丹晖如频婆果上下相称是二十八。世尊面门不长不短不大不小如量端严是二十九。世尊舌相软薄广长如赤铜色是第三十。世尊发声威震深远如象王吼明朗清彻是三十一。世尊音韵美妙具足如深谷响是三十二。世尊鼻高修而且直其孔不现是三十三。世尊诸齿方整鲜白是三十四。世尊诸牙圆白光洁渐次锋利是三十五。世尊眼净青白分明是三十六。世尊眼相修广譬如青莲花叶甚可爱乐是三十七。世尊眼睫上下齐整稠密不白是三十八。世尊双眉长而不白致而细软是三十九。世尊双眉绮靡顺次绀琉璃色是第四十。世尊双眉高显光润形如满月是四十一。世尊耳厚广大修长轮埵成就是四十二。世尊两耳绮丽齐平离众过失是四十三。世尊容仪能令见者无损无染皆生爱敬是四十四。世尊额广圆满平正形相殊妙是四十五。世尊身分上半圆满如师子王威严无对是四十六。世尊首发修长绀青稠密不白是四十七。世尊首发香洁细软润泽旋转是四十八。世尊首发齐整无乱亦不交杂是四十九。世尊首发坚固不断永无[土*(虒-儿+巾)]落是第五十。世尊首发光滑殊妙尘垢不着是五十一。世尊身分坚固充实逾那罗延是五十二。世尊身体长大端直是五十三。世尊诸窍清净圆好是五十四。世尊身支势力殊胜无与等者是五十五。世尊身相众所乐观尝无厌足是五十六。世尊面轮修广得所皎洁光净如秋满月是五十七。世尊颜貌舒泰光显含笑先言唯向不背是五十八。世尊面貌光泽熙怡远离频蹙青赤等过是五十九。世尊身支清净无垢常无臭秽是第六十。世尊所有诸毛孔中常出如意微妙之香是六十一。世尊面门常出最上殊胜之香是六十二。世尊首相周圆妙好如末达那亦犹天盖是六十三。世尊身毛绀青光净如孔雀项红晖绮饰色类赤铜是六十四。世尊法音随众大小不增不减应理无差是六十五。世尊顶相无能见者是六十六。世尊手足指约分明庄严妙好如赤铜色是六十七。世尊行时其足去地如四指量而现印文是六十八。世尊自持不待他卫身无倾动亦不逶迤是六十九。世尊威德远震一切恶心见喜恐怖见安是第七十。世尊音声不高不下随众生意和悦与言是七十一。世尊能随诸有情类言音意乐而为说法是七十二。世尊一音演说正法随有情类各令得解是七十三。世尊说法咸依次第必有因缘言无不善是七十四。世尊等观诸有情类赞善毁恶而无爱憎是七十五。世尊所为先观后作轨范具足令识善净是七十六。世尊相好一切有情无能观尽是七十七。世尊顶骨坚实圆满是七十八。世尊颜容常少不老好巡旧处是七十九。世尊手足及胸臆前俱有吉祥喜旋德相文同绮画色类朱丹是第八十。善现是名八十随好。善现如来应正等觉成就如是诸相好故身光任运能照三千大千世界无不遍满。若作意时即能普照无量无边无数世界。然为怜愍诸有情故摄光常照面各一寻。若纵身光即日月等所有光明皆常不现。诸有情类便不能知昼夜半月日时岁数。所作事业即不得成。佛声任运能遍三千大千世界。若作意时即能遍满无量无边无数世界。然为利乐诸有情故声随众量不减不增。善现如是功德胜利我先菩萨位修行般若波罗蜜多时已能成辨。故今相好圆满庄严一切有情见者欢喜。皆获殊胜利益安乐。如是善现菩萨摩诃萨行深般若波罗蜜多时能以财法二种布施摄诸有情。是为甚奇希有之法

经曰。无忘失法‘空寂清净句义是菩萨句义恒住舍性空寂清净句义’是菩萨句义

赞曰。此即第五常记平等德。谓诸如来常随记念若事若处若如若时。有所为作皆随正念。普于一切所作事业。普于一切方处差别。普于一切所作方便。普于一切时分差别念无忘失。常住正念名无忘念。恒住舍性者谓六恒住法。于六根门不忧不喜。但起正舍平等观境

经曰。一切智‘空寂清净句义是菩萨句义道相智一切相智空寂清净句义’是菩萨句义

赞曰。此即第六觉了空有德。观空性智名一切智。即正体智观有智中分之为二。一观无漏道。一观所余法相。相者相状差别之相即后得智。智观无漏道此名道相智。观所余法名一切相智。一切种智分为二故

经曰。一切菩萨‘摩诃萨行空寂清净句义是菩萨句义诸佛无上正等菩提空寂清净句义’是菩萨句义

赞曰。此即第七第八二门。明因果位二满总德。此上所说诸功德等若在因位名菩萨行。若在果位名佛菩提。菩提觉义。其菩提智及菩提断一切并名为菩提。故有为无为一切功德随应皆摄在此二故

经曰。一切异生法‘空寂清净句义是菩萨句义一切预流一来不还阿罗汉独觉菩萨如来法空寂清净句义’是菩萨句义

赞曰。此即第三总明世俗胜义法所依本性空寂句义。以显菩萨所有句义。一切异生唯在凡位。以业烦恼轮回六趣。异圣者生故名异生。一切预流等并是圣位。预流向果并名预流。无间渐超三界见道诸烦恼尽。十五心来皆名为向。第十六心名之为果。预圣流故名为预流。即此进向三界见惑并已断尽。欲界修道前五品尽名一来向。六品尽时名之为果。此于欲界唯有一生。如从人中得第二果舍此身已次生天中。天中没已来生人中便得无学故名一来。即此进向已断见惑尽。欲界修惑断七八品名不还向。欲界修惑要皆断尽。余地不定。心不还生于欲界故名为不还。阿罗汉者名之为应。一应永害烦恼贼。二应不后受分段生。三应受妙供养。三界见惑并皆断尽。初定已上所有修惑或多或少。乃至非想八品解脱九品无间已前能断尽者名阿罗汉向。三界见修并俱断尽名阿罗汉果。以上果向无间解脱皆准此说。此观谛理若思风动树悟十二缘起。不藉善友自得菩提。或麟角或众出名为独觉。十地已去名为菩萨。法云地后号曰如来。此亦并是初二十六门。明世俗胜义法所依所从本性空寂清净句义。以显菩萨所有句义。自下第二五对十门。通染净法差别本性空寂清净句义。以显菩萨所有句义

经曰。一切善非善法‘空寂清净句义是菩萨句义一切有记无记法有漏无漏法有为无为法世间出世间法空寂清净句义’是菩萨句义

赞曰。顺理益物名之为善通有无为。与此相违名为非善。即不善无记自体殊胜。及有当果可记别故名之为记。即善不善与此相违名为无记。与烦恼漏相应相杂相随增长名为有漏。漏是流漏义。于六根门当流泄故毁之名漏。无漏翻此。为之言作亦名为生。有作有生名曰有为。与此相违名曰无为。体用显现迁流名世。堕虚伪中名之为间。与此相违名出世间。此等差别所依本性真如空寂清净句义。以显菩萨所有句义。妄即真故性即相故

经曰。所以者何

赞曰。大文第二释其所由。于中有二初问后释。此初问也。谓此诸法清净句义即是菩萨所有句义。此义之所以者何谓也

经曰。以一切法‘自性空故’自性远离

赞曰。下释所由如幻[少/兔]等世俗妄有胜义。知空故说诸法空寂句义即是菩萨所有句义。故言诸法自性空故释上所由。为欲显发般若尊胜以自性空释远离等。由此诸法胜义自性空无性故远离虚妄颠倒相也

经曰。由远离故‘自性寂静由寂静故自性清净由清净故甚深般若波罗蜜多’最胜甚深

赞曰。生死嚣烦真如寂静故由远离。自性亦静烦恼有染空性清净故由寂静显体清净。此意总显。由一切法自性空故空寂句义即是菩萨所有句义。诸法既空故离虚妄离虚妄故体无嚣动故性寂静。既无嚣动自性空寂故非染污自性清净。自性清净者显般若最胜清净。观照悟此本性清净真相自体本来清净。故文字等甚深般若最胜清净。清辨护法二释随应

经曰。如是般若‘波罗蜜多当知即是菩萨句义诸菩萨众’皆应修学

赞曰。此即第三结劝修学。文字般若即菩萨句义。求此学此名为句故。余四般若名菩萨义。菩萨之教诠此四故。既成菩萨由此五种。五种即是菩萨能诠所诠之义。诸菩萨中下位望进胜上位者。应勤精进学此五种

经曰。佛说如是‘菩萨句义般若理趣’清净法已

赞曰。自下第三叙佛所说法门之德。于中有二。初结前义以发经端。后正告陈所说之德此即初也

经曰。告金刚手‘菩萨等言若有得闻此一切法甚深微妙般若理趣清净法门深信受者乃至当坐妙菩提座一切障盖皆不能染谓烦恼障业障法障虽多积集而不能染虽造种种极重恶业而易消灭’不堕恶趣

赞曰。于中复二。初明闻经深信受果。后明受持精勤等果。所以但告金刚手者欲令有情取一切佛大珍宝故。闻者听闻信者能顺受者领纳。殷重供养恭敬名深。此意总显。听闻信顺领纳殷重始从今日乃至菩提三障五盖皆不能染。盖谓五盖。谓贪欲于乐出家位。嗔恚于觉邪行位。惛沉睡眠掉举恶作及与疑盖于止举舍位。能覆蔽心名之为盖。障者障碍障道不生碍灭不证。此有三种经文自列。若小乘中以数行烦恼难可伏除名烦恼障。以杀父等五种逆业名为业障。合三恶趣人趣北洲及无想天名异熟障。然不见说别有法障。然今此文障解脱惑名烦恼障。萨遮尼犍子经以破塔坏寺等为五逆。像法决疑经说有七逆。然不离尼犍子经所说五种名为业障。言法障者前异熟障亦名法障。感遗法业名为法障。或去世时障碍正法障他修定。不种闻法所有种子所以今生于法不闻不信不悟名为法障。集者作也积者积造。虽多积集而不能染由解法空不乐生死。虽起烦恼重业障法以经威力定不能染。染者染污令感苦果等名为染也。又虽造种种极重恶业由体性空烦恼不坚。故而易消灭易消灭故不堕恶趣。业既易亡恶果宁起。由法性空诸法实理体实远鉴三障故销

经曰。若能受持‘日日读诵精勤无间如理思惟彼于此生定得一切法平等性金刚等持于一切法皆得自在恒受一切’胜妙喜乐

赞曰。下明受持精勤等果。言受持者爱乐宝重领受在心持之不忘。如念子等不忘在心。日日读者披文诵者暗说。精者专精勤者勇励身心。日夜六时中无间隙如其理趣而谛思惟。彼于此生现报果也。定得一切法平等性真如理也。金刚等持者等持谓定金刚者喻。能破分别着相烦恼。谓观一切法平等性真如空理所有等持能破分别着相颠倒故名金刚。又真如理名曰金刚。缘此之定名金刚等持。谓能受持心心不忘日日读诵精勤思惟如是法性故得此定。当起胜慧破诸分别颠倒着相。今时证此金刚等持闻思位中相应定。此中但有五种法行。谓听闻．受持．披读．讽诵．思惟五种。略无书写供养施他开演修行五种互影显故。其实而论行十法行并得此果。读诵尚得况能演说及修行等。于一切法皆得自在者未体真空理事皆拥。体真远鉴于理既通故得自在。自在者无碍义。恒受一切胜妙喜乐者于法著有忧有恚。于真会空于俗体妄。既无忧恚故得恒时受妙喜乐。既闻法性真喜未曾得故

经曰。当经十六‘大菩萨生定得如来执金刚性疾证无上’正等菩提

赞曰。世尊自说善修神足能住一劫或一劫余。菩萨十六大生即义当十六劫。金刚性者谓。真如性能破裂生死过失名为金刚。诸法之体故名为性。执者受义亲领受之故名为执。即正体智能缘于空。或执金刚之性即是真如。经十六生得此真性故。由于此经行前法行能超生死。不经僧祇经十六劫便入初地。以经所明实相之理有大神验。闻此法等故超生死无边劫量。既尔故能疾证无上菩提。此中所说现在定得金刚等持。于法自在受胜喜乐。后生之障皆不能染不堕恶趣。得金刚性疾得菩提经力故也

般若理趣分疏卷第二终大般若波罗蜜多经般若理趣分述赞卷第三

        大慈恩寺沙门　基撰

经曰。尔时世尊复依遍照如来之相

赞曰。上来第一明实相境法。此下第二寂静法性现等觉门。即是观照正智体境前门。真性此明智相。于中亦三。初叙佛说法门之号。此门有二。初明所依如来之相。后陈所说法门之名。此即初也。前门明性。本体之法不说为相。下门是义所以称相。如来总体别有多能。今依一义即是遍照如来之相。相谓义相相状。非是分别有相之相。今于无相之法后说义相之相。由一切智一切种智断惑游观二种智故。于一切法皆能了知名为遍照。遍照之智即如来相。今依此体相而说于法门故名为依遍照之相

经曰。为诸菩萨‘宣说般若波罗蜜多一切如来寂静法性其深理趣’现等觉门

赞曰。此陈所说法门之名。一切如来寂静法性甚深理趣者。即前所说实相妙法是一切佛寂静法性甚深理趣。现等觉门者现谓显现现前明了亲证之义。等者遍义觉谓照义。此意即显无分别智明了亲能遍照法性。现等觉体即无分别智。门者通由入趣之义。以能诠法等为由为通入趣法性。无分别智由此深教等为由能入现等觉故

经曰。谓金刚平等性‘现等觉门以大菩提坚实难坏’如金刚故

赞曰。此下第二有四门。第一能断生死性坚实故金刚平等性。现等觉者能破生死。现等之觉犹如金刚。以智所证法性菩提坚牢真实难可破坏若破金刚故。能证智名金刚智。金刚般若名曰金刚义亦同此。以所证如性坚实故能证之智亦如金刚能破生死

经曰。义平等性‘现等觉门以大菩提’其义一故

赞曰。此即第二观察所诠智。一切有为无为等义皆悉平等。以法本性真如菩提其义一故性无差别

经曰。法平等性‘现等觉门以大菩提’自性净故

赞曰。此即第三观察能诠智。以所证理大菩提性自性清净故。于能诠教悟其平等

经曰。一切法平等性‘现等觉门以大菩提于一切法’无分别故

赞曰。此即第四通证诸法智。一切法者有为无为诸法之中皆现等觉。以法本性于诸法中无有分别故。能证智证诸法时皆亦不分别。故法本性亦性平等。由如空中种种云雾如屏风上种种像貌。空及屏风并无分别。云及画像种种相起

经曰。佛说如是‘寂静法性般若理趣’现等觉已

赞曰。自下第三结叹法德此即结也

经曰。告金刚手‘菩萨等言若有得闻如是四种般若理趣现等觉门信解受持读诵修习乃至当坐妙菩提座虽造一切极重恶业而能超越一切恶趣疾证无上’正等菩提

赞曰。此即叹德。然准经中有十法行。此中但说有六法行。一闻二信解三受持四读五诵六修习。始从今日于十法行初首行时。乃至未来坐菩提座成佛已来。虽造一切极重恶业谓见中邪见业中意业逆中破和合僧等。虽皆具造由悟解故不为被染。而能超越一切恶趣。由闻经行等大威神力此诸恶业作不增长故不堕于三恶道等。乃至速证无上菩提。计此功德应与前同。但为别赞经之胜用故各别说

经曰。尔时世尊‘复依调伏一切恶法释迦牟尼’如来之相

赞曰。自下第二有二段经明行境法。于中有二。初段调伏众恶普胜法门。由观实相能伏众恶。后段平等智印清净法门。由观观照智慧照明。今此初段于中有三。初明所说法门之号。于中有二。初明所依如来之相。此为初也。一切恶法者二障分别因果分别染净分别悉能除也。释迦者能义牟尼者寂默义。能调众恶离诸諠动。諠动之法谓生死法。故名能寂默如来之相。依此调伏一切恶法能寂如来之相说此法门也

经曰。为诸菩萨‘宣说般若波罗蜜多摄受一切法平等性甚深理趣’普胜法门

赞曰。此陈所说法门之名。摄受一切法平等性者谓摄一切染净因果皆入平等性法界中。由此故能普胜众恶由此法门名普胜法

经曰。谓贪欲性‘无戏论故嗔恚性亦无戏论嗔恚性无戏论故愚痴性亦无戏论愚痴性无戏论故犹预性亦无戏论犹预性无戏论故诸见性亦无戏论诸见性无戏论故’憍慢性亦无戏论

赞曰。此下第二正说法门于中有三。初别说生死惑业苦法性无戏论。次陈诸染净法性无戏论。后说般若亦无戏论结归深趣。初中复三。一明烦恼性无戏论二明业三明果。烦恼中有二。初明根本后明随惑。此根本也。根本有六由此为本一切烦恼皆得生长。谓贪欲性。无戏论者谓染妄法性即真如。真如之法体无戏论。戏论者谓分别相名言相寻思相。由戏论故执着染净有所分别。分别故生死生。知无戏论染净亡。染净亡性无分别。无分别故生死灭故能除恶。下皆准知。初三三毒。犹预者疑。诸见谓五见即耶推度。憍谓憍逸。慢谓七慢恃已陵人名之为慢。此六根本真如本性。性无戏论性无戏论故能离分别。契此本性离分别无戏论一切恶法悉能降伏

经曰。憍慢性无戏论故‘诸缠性亦无戏论诸缠性无戏论故’烦恼垢性亦无戏论

赞曰。此明随惑。缠谓数数增盛现前缠绕于心故名缠也。此有八种谓惛沉睡眠于止为障。掉举恶作于举为障。嫉悭于舍为障。无惭无愧于戒为障故但立八。垢有六种谓害恨恼及谄诳憍。垢秽众生故名为垢。此六相粗毁责之甚立以垢名

经曰。烦恼垢性‘无戏论故诸恶业性亦无戏论诸恶业性无戏论故诸果报性’亦无戏论

赞曰。上惑无戏论业果亦复然。总名生死法性无戏论。证此无戏论故离生死一切恶法

经曰。诸果报性‘无戏论故杂染法性亦无戏论杂染法性无戏论故清净法性亦无戏论清净法性无戏论故一切法性’亦无戏论

赞曰。此第二明诸染净法性无戏论。杂染者总摄一切有漏法尽与染杂故。清净者总摄一切无漏法尽。一切法者总摄一切有漏无漏有为无为生死有情。先染后净先别后总。义次第故

经曰。一切法性‘无戏论故当知般若波罗蜜多’亦无戏论

赞曰。由所观境性无戏论能观之智亦无戏论。如实知故。由此境智悉无戏论故离生死一切分别。降伏一切恶法皆尽

经曰。佛说如是‘调伏众恶般若理趣’普胜法已

赞曰。自下第三叹此经德意此结前已

经曰。告金刚手‘菩萨等言若有得闻如是般若波罗蜜多甚深理趣信解受持读诵修习假使杀害三界所摄一切有情而不由斯堕于地狱傍生鬼界以能调伏一切烦恼及随烦恼’恶业等故

赞曰。以经威力能调众恶故是杀罪并得销除。由悟法性起斯胜行故此大罪不招恶果。以经威力善能调伏一切烦恼及随烦恼恶业等故。设有是罪不招恶果。相缚缚众生亦由粗重缚善。后双修止观方乃俱解脱。一切恶业从烦恼生一切烦恼从分别起。今离戏论断诸分别。分别既尽惑业亦亡。故此大罪闻经信解定得消灭

经曰。常生善趣‘受胜妙乐修诸菩萨摩诃萨行疾证无上’正等菩提

赞曰。上能除恶下能摄善。于中二果。一世间果二出世果

经曰。尔时世尊‘复依性净如来之相为诸菩萨宣说般若波罗蜜多一切法平等性观自在妙智印甚深理趣’清净法门

赞曰。此第四段由观观照智慧照明。以显行境界。文中有三并同前解。由能观智证会诸法本性清净故分别相智皆离之名为性净今名得清净。一切法平等性者即是真如观自在悲行也。妙智印者智行也。又此观自在即妙智印印一切法平等故。余文可知

经曰。谓一切贪欲‘本性清净极照明故能令世间嗔恚清净一切嗔恚本性清净极照明故能令世间愚痴清净一切愚痴本性清净极照明故能令世间疑惑清净一切疑惑本性清净极照明故能令世间见趣清净一切见趣本性清净极照明故能令世间’憍慢清净

赞曰。此文有三同前文说。前文是境此文是智。照明前故。谓于贪欲本性真如清净境中极照明故。能照明者即是智。以贪欲为本生于嗔等故

经曰。一切憍慢‘本性清净极照明故能令世间缠结清净一切缠结本性清净极照明故能令世间’垢秽清净

述曰。此明于随烦恼本性清净极照明也。缠垢等义并如前解。所言结者即是九结。谓爱．恚．慢．无明．见取．疑．嫉．悭．结。结是结缚。能和合苦难可解故名之为结

经曰。一切垢秽‘本性清净极照明故能令世间恶法清净一切恶法本性清净极照明故能令世间’生死清净

赞曰。上明惑此明业果。以生死业逼迫果业故名恶法。言生死者谓异熟果即前恶业所招苦果

经曰。一切生死‘本性清净极照明故能令世间’诸法清净

赞曰。世间诸法即杂染法总摄有漏。自下第二总摄诸法

经曰。以一切法‘本性清净极照明故能令世间’有情清净

赞曰。由有漏法成有情故。故有漏后明其有情

经曰。一切有情‘本性清净极照明故能令世间’一切智清净

赞曰。出世间中一切智为本。举此摄余清净法尽。三乘总观诸无我智名一切智

经曰。以一切智‘本性清净极照明故能令世间甚深般若波罗蜜多’最胜清净

赞曰。此即第三般若清净。由能照明一切法性本性清净故能观智最胜清净。与所缘境极相应故

经曰。佛说如是‘平等智印般若理趣’清净法已

赞曰。自下第三文陈经胜德。平等智印者谓一切法性无戏论。能观之智名平等智印

经曰。告金刚手‘菩萨等言若有得闻如是般若波罗蜜多清净理趣信解受持读诵修习虽住一切贪嗔痴等客尘烦恼垢秽聚中而犹莲华不为一切客尘垢秽’过失所染

赞曰。由能观智观染净法本性清净故住烦恼不为染污。悟本性故此说离过

经曰。常能修习‘菩萨胜行疾证无上’正等菩提

赞曰。此释得善果。由起法行悟于真智故常修习菩萨胜行。乃至终后疾证菩提

经曰。尔时世尊‘复依一切三界胜主’如来之相

赞曰。明境六中自下第三有二段经明果法境。于二段中初段法王灌顶智藏法门。显由二行得财位果。后段如来智印金刚法门。显由二行得自体果。今此初段于中有三准前应释。初标所说法门号中文复有二。初明所依如来之相。后明所说法门之名。此即初也。三界之宅扰攘无安。烦恼虫兽诸苦恼火无量逼切。种种惊怖令有情等危难并生。由佛世尊如大长者怜愍诸子方便拔济故佛世尊称三界主。佛为法王故言胜主。依此尊位以说法门

经曰。为诸菩萨‘宣说般若波罗蜜多一切如来和合灌顶甚深理趣’智藏法门

赞曰。此明所说法门之号。至第十地将受如来法王位时。一切十方如来和合咸灌其顶。如刹帝利受王位法。今此菩萨受佛尊位以何法水灌洒其顶令作吉祥。谓一切佛智慧法水有殊胜智。出生诸德含容诸德譬如于藏。以此智水灌菩萨顶令无始来二障垢尽一切如来吉祥功德皆悉圆满。今说此法令依趣入。是故称门

经曰。谓以世间‘灌顶位施当得三界法王位果以出世间无上义施当得一切希愿满足以出世间无上法施于一切法当得自在若以世间财食等施当得一切身语心乐若以种种财法等施能令布施波罗蜜多’速得圆满

赞曰。自下第二正显所说法门。六度不同随成六段。施中有五一位施二义施三法施四财施五总无畏施。其实五施一一并得多果。此中且说五相似果。若舍荣贵位而修正法当得成佛为三界法王。由施义味顺于理故当来希愿悉皆满足。因以法施当能达解一切佛法。财食因施充益三业。故于当来得乐三业。若以种种财法等施者谓以财法摄取众生令其无畏名无畏施。菩提心经说。愿行财施要有五种。一至心二信心三随时四自手五如法。如有颂言施者殊胜信等具足。恭敬应时自手施等。又有颂言利他加行于有情不简有力及无力。于一切时一切施随力所能广说法饶益。不应施有五。非理财不应施不净故酒及毒不应施乱生故。罝罗机网不应施恼生故。刀杖弓箭不应施害生故。音乐女色不应施坏净心故。施有五利一常近贤圣二众生乐见三入众宗敬四好名流布五作菩提因。无著菩萨说。谓修六种意乐一广大二长时三欢喜四荷恩五大志六纯善。于此六中起三作意。一爱重二随喜三欣乐。闻此六种但当能起一念信心。尚能发生无量福聚诸恶业障亦当销灭。何况菩萨

经曰。受持种种‘清净禁戒能令净戒波罗蜜多速得圆满于一切事修学安忍能令安忍波罗蜜多速得圆满于一切时修习精进能令精进波罗蜜多速得圆满于一切境修行静虑能令静虑波罗蜜多速得圆满于一切法常修妙慧能令般若波罗蜜多’速得圆满

赞曰。三种戒法皆能圆满。草结鹅珠而能不坏。三戒非一故言种种。事事能忍一切时能勤无懈疲故。于一切境能静虑无散乱心故。于一切法修慧皆能简择故。行此六度得六果报。一富贵二大生三大朋属四大业成就五无恼缚垢六达五明。能作义利如摄大乘广说其相

经曰。佛说如是‘灌顶法门般若理趣智藏法已告金刚手菩萨等言若有得闻如是灌顶甚深理趣智藏法门信解受持读诵修习速能满足诸菩萨行疾证无上’正等菩提

赞曰。由闻六度菩萨行成。所求菩提亦能速得

经曰。尔时世尊‘复依一切如来智印持一切佛秘密法门如来之相为诸菩萨宣说般若波罗蜜多一切如来住持智印甚深理趣’金刚法门

赞曰。此第二段如来智印金刚法门。显由二行得自体果。文有三等并同前释。此即第一标所说法门之号。以妙智印任持一切佛甚深法。佛甚深法体性难知名为秘密。以一智印持诸佛法一切佛法并入此故名为任持。今说此法令勤趣入故名为门。以能破坏一切生死智体坚实故名金刚

经曰。谓具摄受‘一切如来金刚身印当证一切如来法身若具摄受一切如来金刚语印于一切法’当得自在

赞曰。由在因中别行如来三业因印得果之时得如金刚法身等果

经曰。若具摄受‘一切如来金刚心印于一切定当得自在若具摄受一切如来金刚智印能得最上妙身语心犹若金刚’无动无坏

赞曰。由在因中具行三业金刚智印得果之时能得最上妙身语心。谓如金刚不为耶友所动不为生死所坏。此中意说。别行三业殊胜之因别得三果。具行三业所有胜因总得一果。三业坚实犹如金刚不可动坏

经曰。佛说如是‘如来智印般若理趣金刚法已告金刚手菩萨等言若有得闻如是智印甚深理趣金刚法门信解受持读诵修习一切事业皆能成办常与一切胜事和合所欲修行一切胜智诸胜福业’皆速圆满

赞曰。自下第三叹此经德。一切事业皆得成辨者谓诸无罪顺理善事。常与一切胜事和合者现在后生常与胜事和合相应。衰减等事皆悉远离所修福慧皆速圆满。此说因位所得胜利

经曰。当得最胜‘净身语心犹若金刚不可破坏疾证无上’正等菩提

赞曰。此说未来所得果位殊胜妙果

经曰。尔时世尊‘复依一切无戏论法如来之相为诸菩萨宣说般若波罗蜜多甚深理趣’轮字法门

赞曰。上六段经明胜境讫。次有六段当明胜行。复分为三。初二段显依实相断修之相。次二段显依观照修断之相。后二段显依二法遍修之相。就初二段显依实相断修相中有二。初离诸戏论轮字法门。由观真如断分别故。后入广大轮平等性门。由观平等修证真故。此下初段文势有三。初标所说法门之号。中复分为二。初辨所依如来之相。真如法性离诸分别离言说道故。无戏论即是依于法身之相。轮字法门者轮有二义。一周圆义二摧坏义。由观真如性无戏论遍一切法故名周圆。由观此故离分别执摧坏生死一切执着故名摧坏。诠此轮理所有法门名轮字法。教能诠显故名为门。由闻此教遂起轮行。起轮行已得轮果得轮果已复为他转。如是展转

经曰。谓一切法‘空无自性故一切法无相离众相故一切法无愿’无所愿故

赞曰。以下第二正陈所说于中有四。初三解脱门境。遍计所执一切皆空。圆成无相。依他无愿。又此三种皆通三性。又但有二谓妄与真。真妄皆通有三种故。非我有名空。离十名无相。不希名无愿

经曰。一切法远离‘无所著故一切法寂静’永寂灭故

赞曰。此即第二离着离生

经曰。一切法无常‘性常无故一切法无乐非可乐故一切法无我不自在故一切法无净’离净相故

赞曰。此即第三离四倒执

经曰。一切法不可得‘推寻其性不可得故一切法不思议思议其性无所有故一切法无所有众缘和合假施设故一切法无戏论本性空寂离言说故一切法本性净甚深般若波罗蜜多’本性净故

赞曰。此第四离诸执着也。无如所执有所得故。寻思之心言说之议不可思议故。法假施设无实有故。法性离言无戏论故法性本净。实相般若本性净故此既是法性。诸法随本体故皆是空

经曰。佛说如是‘离诸戏论般若理趣轮字法已告金刚手菩萨等言若有得闻此无戏论般若理趣轮字法门信解受持读诵修习于一切法得无碍智疾证无上’正等菩提

赞曰。此即第三叹经胜德达法性空。故于诸法得无碍智

经曰。尔时世尊‘复依一切如来轮摄如来之相为诸菩萨宣说般若波罗蜜多入广大轮甚深理趣’平等性门

赞曰。此即第二入广大轮平等性门。由观平等修证真故。于中有三此标所说法门之名。前明轮字未明摄法。今明诸法皆真所摄。圆满周备离执着故。此遍满故名为广大。无法不摄故名平等。诸法本体故名为性

经曰。谓入金刚‘平等性能入一切如来性轮故入义平等性能入一切菩萨性轮故入法平等性能入一切’法性轮故

赞曰。自下第二正陈所说于中有三。初别明性轮后总明性轮。别明性轮中有三。初明圣者性轮二明法性轮三明有情性轮。初中有三。初明佛性轮。法身本性能破生死坚实难坏如金刚故。菩萨之法依教所诠以行修证故。义平等名菩萨性。佛亦应是义平等性。以离能诠坚实之义别名金刚不名为义。菩萨证此未得金刚圆满法性。但立义名。其二能诠总名为法。法谓教法。欲显所诠因果胜法能诠之教并摄入于法性轮故。随顺说别性并即真

经曰。入蕴平等性‘能入一切蕴性轮故入处平等性能入一切处性轮故入界平等性能入一切’界性轮故

赞曰。自下第二明法性轮于中有三。初别法次通法后位法。别法中有七。此初三科也。义别说三体真法性

经曰。入谛平等性‘能入一切谛性轮故入缘起平等性能入一切缘起性轮故入宝平等性能入一切宝性轮故入食平等性能入一切’食性轮故

赞曰。此四别法。谛谓四谛。缘起有十二宝谓三宝食谓四食。谓段触思及与识食香味触三名为段食。触谓触数第六识俱。思谓思数即第六俱。识谓识蕴即唯第八。随缘说四摄归法性

经曰。入善法平等性‘能入一切善法性轮故入非善法平等性能入一切非善法性轮故入有记法平等性能入一切有记法性轮故入无记法平等性能入一切无记法性轮故入有漏法平等性能入一切有漏法性轮故入无漏法平等性能入一切无漏法性轮故入有为法平等性能入一切有为法性轮故入无为法平等性能入一切无为法性轮故入世间法平等性能入一切世间法性轮故入出世间法平等性能入一切’出世间法性轮故

赞曰。此即第二明诸通法入法性轮于中有五。其义如文。此五通在人法二种

经曰。入异生法‘平等性能入一切异生法性轮故入声闻法平等性能入一切声闻法性轮故入独觉法平等性能入一切独觉法性轮故入菩萨法平等性能入一切菩萨法性轮故入如来法平等性’能入如来法性轮故

赞曰。此即第三明诸位法入法性轮于中有五。一凡法四圣法如应当知

经曰。入有情‘平等性能入一切’有情性轮故

赞曰。此即第三明有情入本性轮

经曰。入一切平等性能入一切性轮故

赞曰。此即第二总明性轮。若圣若凡若人若法一切皆入本性轮故。欲显一切皆归本性广大轮摄

经曰。佛说如是‘入广大轮般若理趣平等性已告金刚手菩萨等言若有得闻如是轮性甚深理趣平等性门信解受持读诵修习能善悟入诸平等性疾证无上’正等菩提

赞曰。此即第三叹经胜德。由闻此故现在后生能善悟入诸平等性。学悟证悟皆善悟入。乃至究竟疾得菩提

经曰。尔时世尊‘复依一切广受供养真净器田如来之相为诸菩萨宣说般若波罗蜜多一切供养甚深理趣’无上法门

赞曰。明行中自下两段。显依观照修断之相。初段真净供养无上法门。由依观照修供养故。后段能善调伏智藏法门。由依观照除忿等故。此即初也。于中有三。初标所说法门之号。广受供养真净器田者由佛因行具真供养能行一切真法行故。成佛之时一切满足三业纯净。堪能广受众生供养。真实法器与诸众生。作真净田故名无上。其二乘等虽真福田非无上故

经曰。谓发无上正等觉心‘于诸如来广设供养摄护正法于诸如来广设供养修行一切波罗蜜多于诸如来广设供养修行一切菩提分法于诸如来广设供养修行一切总持等持于诸如来广设供养修行一切五眼六通于诸如来广设供养修行一切静虑解脱于诸如来广设供养修行一切慈悲喜舍于诸如来广设供养修行一切佛不共法于诸如来’广设供养

赞曰。自下正说由在因中行正供养后为净因。于中有三。初修习行次观察行后法行行。此即初也。就中复三。初发心行。次摄护行。后修习行。于诸供养中法供养为最胜。天王会云。二人远离王贼等所不能侵大宝藏。百千万劫法难闻得闻不持不施等。大菩提心护正法如教修行心寂静自利利他心平等。是则名真供养佛。大菩提心者佛自说言。如诸菩萨最初发心下劣一念福德果报。为千万劫说不能尽况经多劫。譬如大海初渐起时当知皆为乃至无价宝珠作所住处。一切宝珠皆海生故。三千大千世界初起当知便为二十五有一切众生作依止处。菩萨发心亦复如是。初渐起时普为一切无量众生作依止处。菩萨发心慈悲为首。譬如虚空无不普覆。虚空无量故众生无量。众生无量故菩萨发心亦复如是。以能遍覆一切世界一切生故。若菩萨亲近善知识。供养诸佛．修集善根．志求胜法．心常柔和。遭苦能忍．慈悲淳厚．深心平等。信乐大乘。求佛智慧。若人能具如是十法乃能发于阿耨多罗三藐三菩提心。广如经说。摄护正法者摄谓摄受摄持。即是胜鬘摄受正法。护谓拥护护念即是护念付嘱正法。摄受拥护为法城堑不惜身命以设供养。波罗蜜多以下是修习行。于中有七。总持者谓陀罗尼。等持者谓三摩地。静虑谓四静虑。解脱谓八解脱。慈悲喜舍即四无量。一切佛不共法者菩萨地说。诸佛世尊有百四十不共佛法。谓诸如来三十二相．八十随好．四一切种清净．十力．四无所畏．三念住．三不护．大悲．无忘失法．永害习气．及一切种妙智。是名一切佛不共法。其三十二相八十随好十力四无所畏大悲无忘失法并如前辨。四一切种清净者。一一切种所依清净。烦恼粗重习气皆永尽故。又于自体如自所欲取住舍中自在而住。二一切种所缘清净。谓于种种若化若变若所显现一切所缘皆自在转。三一切种心清净。诸心粗重永远离故一切善根皆积集故。四一切种智清净。无明粗重永远离故。又遍所知智无障碍智自在转。三念住者谓诸如来于其长夜有如是欲。如何当令诸有情类于我善说法毗奈耶无倒行中如实随住。如是长夜欲乐法主化御众时。若所希欲或遂不遂不生杂染。由三念住略所显故。此三复由三众别。一一向正行。二一向邪行。三一分正行一分邪行。不生喜患但生大舍。三不护者谓诸如来三业清净现行。永害习气者。谓诸如来或于动转或于瞻视或于言论或于安住似有烦恼。所起作业多不现行。一切习气皆断无余。一切种妙智者总于诸法无颠倒智。所余佛法如前已说

经曰。观一切法若常若无常‘皆不可得于诸如来广设供养观一切法若乐若苦皆不可得于诸如来广设供养观一切法若我若无我皆不可得于诸如来广设供养观一切法若净若不净皆不可得于诸如来’广设供养

赞曰。自下第二观察行相于中复三。一离四倒行二三门行。三离着生灭行。此则初也。异生多执身受心法以为净乐我常。为破彼故说四谛理。既无常无乐无我无净。令压生死趣求二乘。二乘遂执真实有彼无常等四。既有法执附着小果不欲大乘。世尊后说大般涅槃常乐我净令舍小果趣求大乘。彼闻厌舍遂得佛果。此二俱是引摄方便非实道理。诸法实非此二四种。故有说言诸佛或说我或时说非我。诸法实相中无我无非我。余三亦尔。今观实相以设供养故观诸法常无常等皆不可得

经曰。观一切法若空若不空‘皆不可得于诸如来广设供养观一切法若有相若无相皆不可得于诸如来广设供养观一切法若有愿若无愿皆不可得于诸如来’广设供养

赞曰。此即第二三门行也。若是二乘观苦为空即空无我行故。观集道全苦谛少分为无愿行。观于灭谛为无相行。欣厌事成。若大乘者观遍计所执实我法为空行。观依他起为无愿行。观圆成实为无相行。又三皆通。空无相无愿并破凡夫妄想分别我法执等。故不空是凡执有愿有相并皆如是。其空等行此皆趣入方便之门。据理实相非空不空有愿无愿有相无相。今观实相故不可得。推前一法达一切故。故论说言。舜若多者名为空性。法性非空空之性故

经曰。观一切法若远离‘若不远离皆不可得于诸如来广设供养观一切法若寂静若不寂静皆不可得于诸如来’广设供养

赞曰。凡夫妄想乐着生死性不寂静有不远离及不寂静。为破彼故说为远离及于寂静。依于远离及寂静门破彼病。故以入于真名为远离及寂静等。据实法体非远不远非静不静。静不静等皆是入门故非法性。以实相体名言路绝寻思道息故远离等皆不可得

经曰。于深般若‘波罗蜜多书写听闻受持读诵思惟修习广为有情宣说流布或自供养或转施他于诸如来’广设供养

赞曰。自下第三行门法行行。一书写二听闻。三受持。爱乐宝重不离于心。生死威仪愿相随故。四读五诵六思惟七修习如说行也。八广为有情宣说流布。九自供养十施他。此十名为行法行行。此中皆得自作教他赞叹随喜庆慰。供养之中说自言者以对施他且复言自。据实而言自供教他赞叹随喜庆慰并得供养。施他书写乃至教他施他赞叹等事并名法行名为供养。行十法行者获福聚无量胜故无尽故。由摄他不息。广如中边论说

经曰。佛说如‘是真净供养甚深理趣无上法已告金刚手菩萨等言若有得闻如是供养般若理趣无上法门信解受持读诵修习速能圆满诸菩萨行疾证无上’正等菩提

赞曰。此即第三叹经胜德。以法供养即菩萨行故菩萨行速得圆满

经曰。尔时世尊‘复依一切能善调伏如来之相为诸菩萨宣说般若波罗蜜多摄受智密调伏有情甚深理趣’智藏法门

赞曰。明依观照修行相中自下第二能善调伏智藏法门。由依观照除忿等故文意有三准前应释。此即第一总标所说法门之名。能善调伏者能除忿等名善调伏。摄受智密调伏有情者观照之智微妙名密。此智为藏具能摄受一切诸佛法所有功德名为摄受。亦名智藏。以此智藏能除自他忿恚等过故名调伏。此门义显。由观照智达法本性忿恚恶法并能调伏

经曰。谓一切有情‘平等性即忿平等性一切有情调伏性即忿调伏性一切有情真法性即忿真法性一切有情真如性即忿真如性一切有情法界性即忿法界性一切有情离生性即忿离生性一切有情实际性即忿实际性一切有情本空性即忿本空性一切有情无相性即忿无相性一切有情无愿性即忿无愿性一切有情远离性即忿远离性一切有情寂静性即忿寂静性一切有情不可得性即忿不可得性一切有情无所有性即忿无所有性一切有情难思议性即忿难思议性一切有情无戏论性即忿无戏论性一切有情如金刚性’即忿如金刚性

赞曰。此下第二正陈所说文中有二。初说十七实相即忿实相。后释所由。此即初也。文分为五。初以不二除断无变三种实相以即于忿。他忿之时应作此念。法既平等何有嗔忿。法既离染忿能调我。法既无变忿性亦然。何须分别见他生忿而起恚恼。作此观已故一切惑皆悉除灭。下皆准知。第二以实常德性灭破真境四种实相以即于忿。第三以非有离相不求三种实相以即于忿。第四以断染法离生二种以即于忿。第五以无得虚伪深妙离言坚实五种以即于忿。如其次第一一配之。此中法门如前已辨故不解释。烦恼之中嗔忿为重此中偏举。论实通余一切染也。以忿即真知本染尽。有情起忿有情本性即忿本性。人法本性皆即实相。无二分故。既知此已不见忿等故不应生烦恼之过

经曰。所以者何‘一切有情真调伏性即是无上正等菩提亦是般若波罗蜜多亦是诸佛’一切智智

赞曰。自下第二释其所由。以有情本调伏性。实相即是法身无上正等菩提。此说实相本性菩提。亦是能观观照般若法性法相体不异故。如刀之利体无别故。由此故知忿之本性亦是诸佛一切智智。此有多解真智俗智各得一名。第二解云一切智者佛也。又言智者佛所成智。此本性般若即佛之智。以忿即真如亦即佛之智。故烦恼性即是觉分。更无异故。又复觉知是烦恼故永不起之。法性本同用不异故。又调伏性即是实相。菩提亦是实相。般若亦是诸佛智之本性。本性名智智之本故。四名虽有别体一故相即。智及智处皆名般若。义意同故

经曰。佛说如是‘能善调伏甚深理趣智藏法已告金刚手菩萨等言若有得闻如是调伏般若理趣智藏法门信解受持读诵修习能自调伏忿恚等过亦能调伏’一切有情

赞曰。自下第三叹经胜德。此杂染失忿恚等者通诸染也

经曰。常生善趣‘受诸妙乐现世怨敌’皆起慈心

赞曰。此即第二世间胜果。忿唯不善起必招苦。今离忿等故生善趣受胜乐果以无忿故。不恼于他故现怨家慈心相向

经曰。能善修行‘诸菩萨行疾证无上’正等菩提

赞曰。此即出世胜善果也

经曰。尔时世尊‘复依一切能善建立性平等法如来之相为诸菩萨宣说般若波罗蜜多一切法性甚深理趣’最胜法门

赞曰。明行之中总有六段。自下末后二段显依二法遍修之相。此段性平等性最胜法门。修观实相人法平等皆遍满故。后段有情住持胜藏法门。修观观照遍诸人法皆善缘故。此中有三此即第一总标所说法门之号。能善建立性平等法者性平等法谓即真如遍于人法名性平等。此真实性不可施设言说分别。今施设为性平等法故名建立。真实法性故名最胜法。令趣入故名为门

经曰。谓一切有情‘性平等故甚深般若波罗蜜多亦性平等一切法性平等故甚深般若波罗蜜多亦性平等一切有情性调伏故甚深般若波罗蜜多亦性调伏一切法性调伏故甚深般若波罗蜜多亦性调伏一切有情有实义故甚深般若波罗蜜多亦有实义一切法有实义故甚深般若波罗蜜多’亦有实义

赞曰。此下第二正陈所说于中有六。第一以人法遍满离染真理三种以即般若。皆同前门。第三名无变。此名真理者前名真法此名实义故。世出世间莫过二种。一有情二法。悟此二种即是般若波罗蜜多观照之智。二种本性即成是实相般若波罗蜜多故皆相即

经曰。一切有情即真如故‘甚深般若波罗蜜多亦即真如一切法即真如故甚深般若波罗蜜多亦即真如一切有情即法界故甚深般若波罗蜜多亦即法界一切法即法界故甚深般若波罗蜜多亦即法界一切有情即法性故甚深般若波罗蜜多亦即法性一切法即法性故甚深般若波罗蜜多亦即法性一切有情即实际故甚深般若波罗蜜多亦即实际一切法即实际故甚深般若波罗蜜多’亦即实际

赞曰。第二以人法实常德性法体真境四种以即般若

经曰。一切有情即本空故‘甚深般若波罗蜜多亦即本空一切法即本空故甚深般若波罗蜜多亦即本空一切有情即无相故甚深般若波罗蜜多亦即无相一切法即无相故甚深般若波罗蜜多亦即无相一切有情即无愿故甚深般若波罗蜜多亦即无愿一切法即无愿故甚深般若波罗蜜多’亦即无愿

赞曰。第三以人法非有离相不求三种以即般若

经曰。一切有情即远离故‘甚深般若波罗蜜多亦即远离一切法即远离故甚深般若波罗蜜多亦即远离一切有情即寂静故甚深般若波罗蜜多亦即寂静一切法即寂静故甚深般若波罗蜜多’亦即寂静

赞曰。第四以人法离染离生二种以即般若

经曰。一切有情不可得故‘甚深般若波罗蜜多亦不可得一切法不可得故甚深般若波罗蜜多亦不可得一切有情无所有故甚深般若波罗蜜多亦无所有一切法无所有故甚深般若波罗蜜多亦无所有一切有情不思议故甚深般若波罗蜜多亦不思议一切法不思议故甚深般若波罗蜜多亦不思议一切有情无戏论故甚深般若波罗蜜多亦无戏论一切法无戏论故甚深般若波罗蜜多’亦无戏论

赞曰。第五以人法无得虚伪深妙离言四种以即般若

经曰。一切有情无边际故‘甚深般若波罗蜜多亦无边际一切法无边际故甚深般若波罗蜜多亦无边际一切有情有业用故当知般若波罗蜜多亦有业用一切法有业用故当知般若波罗蜜多’亦有业用

赞曰。第六以人法广大作用二种即于般若。以境广大智亦如是。以境具有流转业用般若亦有观照境界除断之用

经曰。佛说如是‘性平等性甚深理趣最胜法已告金刚手菩萨等言若有得闻如是平等般若理趣最胜法门信解受持读诵修习则能通达平等法性甚深般若’波罗蜜多

赞曰。第三叹德。性平等性者真如实相体性平等人法本性故名性平等性。则能通达平等法性由闻信等此性平等威神力故。故能通达平等法性。平等法性即深般若波罗蜜多。深般若波罗蜜多义合二种。一实相二观照。今达实相由观本性遍人法故。前文所即深般若者即是观照。不尔如何实相般若亦有业用

经曰。于诸有情‘心无挂碍疾证无上’正等菩提

赞曰。所依法性尚能通达。能依人法理亦无碍。挂者障也碍者拘碍。通达人法亦无障碍。达所依故能依亦达

经曰。尔时世尊‘复依一切住持藏法如来之相为诸菩萨宣说般若波罗蜜多一切有情住持遍满甚深理趣’胜藏法门

赞曰。此第二段有情住持胜藏法门。修观观照遍诸人法皆善缘故。文中有三此即第一。标所说法门之名就中复二。初说依相后说其名。住持藏法者。住谓住止谓如来藏等无始有情皆依之住。或此先住诸有情中。持谓住持谓如来藏等住持有情。为有情本亦能住持一切佛法所有种子。藏法者谓如来藏即无为中含容无边佛功德故名之为藏。一切有情住持遍满谓如来藏遍满依住有情身心。能持一切佛法功德。此即一切殊胜宝藏。诠此教法名为法门。如来藏义是根本名。故不说余金刚藏等

经曰。谓一切有情‘皆如来藏普贤菩萨’自体遍故

赞曰。自下第二正陈所说于中有四。此即第一。一切有情皆如来藏者如来藏者即是真如在缠之名。出缠之时名法身故。藏谓库藏诸佛所有一切功德皆在其中名如来藏。现行功德未能起故不名法身。又此真性正实如来藏在缠中名如来藏。一切众生皆有真理故胜鬘云。夫生死者是如来藏。普贤菩萨自体遍故者。贤谓贤善。遍体三业一切贤善故名普贤。菩萨证此普贤善理。又其自体普皆贤善。三业等法一切皆贤。由是菩萨所证真理。能证有为自体等法。一切调顺并皆贤善又由此性体遍三业能令三业普皆贤善故名普贤。然今菩萨普贤本性即如来藏。故说普贤菩萨自体遍有情体故。有情者皆如来藏。废用显体名普贤遍

经曰。一切有情‘皆金刚藏以金刚藏’所灌洒故

赞曰。此即第二。一切有情皆金刚藏即如来藏。坚实难坏能有破裂生死之德名金刚藏。金刚藏菩萨能证于此金刚藏理。亦能获得金刚藏智名金刚藏。然今一切有情本体皆金刚藏。然以般若金刚藏教灌洒身心悉得坚实破裂生死坚固之法。故知有情皆金刚藏。灌者入身心之义。洒者破生死之业。以彼展转金刚藏教所灌洒时破生死故

经曰。一切有情‘皆正法藏一切皆随’正语转故

赞曰。此即第三。一切有情皆正法藏正法即是般若真教。藏谓库藏一切有情皆是正法之库藏也。以诸有情皆能随顺正语转故。言正语者谓顺理语即是。契经谓诸有情皆能随顺正语而转。转谓动转能依正语圣教法行得坚实法故。有情性相并名有情。从诸有情发起正语。故诸有情名正法藏

经曰。一切有情‘皆妙业藏一切事业’加行依故

赞曰。此即第四。一切有情皆妙业藏。妙业即是菩萨所有诸善三业藏。义同前。一切有情皆是菩萨妙业库藏。菩萨欲起诸善事业皆为有情。或为证彼有情本性或欲拔彼生死苦恼发起加行。故有情是加行所依。所依即藏。从诸有情起妙业故。上来四种第一法体谈本藏故。第二法用破生死故。第三教依无倒本故。第四德依诸德本故。若不能晓与此相违

经曰。佛说如是‘有情住持甚深理趣胜藏法已告金刚手菩萨等言若有得闻如是遍满般若理趣胜藏法门信解受持读诵修习则能通达胜藏法性疾证无上’正等菩提

赞曰。自下第三叹经胜德。胜藏法性即如来藏等四种胜藏。法本性故。由今闻等故后通达

经曰。尔时世尊‘复依究竟无边际法如来之相为诸菩萨宣说般若波罗蜜多究竟住持法义平等’金刚法门

赞曰。自下第三二段明行得果于中分二。初无边无际究竟法门。得二果时广深一味极殊胜故自利果德。后甚深理趣无上法门。得二果已自利利他为三界主随诸有情所愿皆从。利他果德。此即初段。就此初段中文有其三。此即第一总标所说法门之号。于中复二。初说所依后辨其名。究竟者最胜义。第一义无上义穷极义。无边者广无际者深。此意说言。佛身最胜广深之法。究竟住持法义平等者。究竟者同前释。住者依止持者住持。法者能诠文字之教。义者所诠理趣之义。平等者相似义不异义。金刚者坚实义能破义。谓最胜依止住持教理不异破坏生死。法门谓法义皆能无边际等故。又究竟住持住持一切诸佛法故。法义平等相顺无二。金刚法者能破生死坚实法门

经曰。谓甚深般若‘波罗蜜多无边故一切如来’亦无边

赞曰。此下第二正陈所说。前性平等性最胜法门中。说一切有情无边等故甚深般若波罗蜜多亦无边。般若既通实相观照文字等五。三身如来随亦无边。实相之理法身无边。观照之智报身无边。依此二种化身应物随缘。即现业用无边。无边者广量难测故。诸根相好一一无边。无限善根所引生故

经曰。甚深般若‘波罗蜜多无际故一切如来’亦无际

赞曰。无际者深妙难知故。亦由三劫难修所得故。深般若名为无际。此成三身亦名无际。非是二乘凡夫等类十地菩萨所能知故

经曰。甚深般若‘波罗蜜多一味故一切法’亦一味

赞曰。此能观观照及所观理方便等五法皆一味故名为平等。一味者一相义。谓无相和合义无分别义。又一味者坚实故离苦乐相无欢戚故。其一切法若教若义皆亦一味。随二般若无乖诤故。佛地经说。譬如三十三天未入杂林。终不能于若事若受无我我所和合受用。若入杂林即无分别随意受用。由此杂林有如是德能令诸天入此林者。天诸果报若事若受无所思惟和合受用。如是菩萨若未证得无生法忍终不能得平等之心平等之舍。乃与一切声闻独觉无有差别。有二想故。彼不能住受用和合一味事智。若已证得无生法忍遣二想故得平等心。遂与声闻独觉差别。由平等心而能住舍受用和合一味事智。彼论说言。三十三天有一杂林诸天和合福力所感。令诸天众不在此林宫殿等事苦乐受等胜劣有异。有我我所差别受用。若在此林若事若受都无胜劣。皆同上妙无我我所和合受用。能令平等和合受用故名杂林。此由诸天各修平等和合福业增上力故。令彼诸天本识变现同处同时同一相法。由彼杂林增上力故。令彼转识亦同变现虽各受用而谓无别。如是地前地上菩萨差别无差别亦复如是。二相无相所引生故未得无生及得别。故即彼经云。又如种种大小众流未入大海各别所依。异水少水水有增减。随其水业所作各异。少分依持水族生命。若入大海无别所依水无差别水无限量水无增减。所作业一广大依持水族生命。如是菩萨若未证入如来清净法界大海各别所依。异智少智智有增减。随其智业所作各异。少分众生成熟善根之所依止。若已证入如来清净法界大海无别所依。智无限量智无增减受用和合一味事智无量众生成熟善根之所依止。彼论说言。水别所依种种地方为所依故。菩萨所依别别如来为所依故。异水者清浊灰美水差别故。菩萨异智者各别胜解所修成故。所余法譬随义可知。菩萨既然。故修成时成佛之位三身万德各唯一味

经曰。甚深般若‘波罗蜜多究竟故一切法’亦究竟

赞曰。此观照及境文字等五最胜第一名为究竟。诸法及义随般若亦尔。此中意显。由深般若因位．文字．眷属．境界．无边无际一味究竟。所行之行得三身果。所说法义随身亦尔。有深般若诸法本性。本性既一味究竟故法亦尔

经曰。佛说如是‘无边无际究竟理趣金刚法已告金刚手菩萨等言若有得闻如是究竟般若理趣金刚法门信解受持读诵修习一切障法皆悉消除定得如来执金刚性疾证无上’正等菩提

赞曰。此即第三叹经胜德。既闻般若及佛三身所有法义无边际等。一切障法皆悉销除定得如来执金刚性。谓领受此能破生死真实本性真如法界。疾证无上正等菩提。此中具有灭恶摄善二种胜德

经曰。尔时世尊‘复依遍照如来之相为诸菩萨宣说般若波罗蜜多得诸如来秘密法性及一切法无戏论性大乐金刚不空神咒金刚法门初中后位最胜第一甚深理趣’无上法门

赞曰。此第二段甚深理趣无上法门。得二果已自利利他为三界主随诸有情所愿皆从利他果德。遍照智者即一切智一切种智。如睡梦觉如莲华开。通达诸法遍能自利及利他尽名为遍照。得诸如来秘密法性。得谓获证。谓此法门能得秘密等。可贵可重名秘幽隐难知名密。即是有为一切殊胜幽微诸法谓菩提是。及一切法无戏论性即真法界。离诸名言及分别故。大乐者得无漏乐。乐有五种。一因乐二受乐三苦对治乐四断受乐五无恼害乐。此中有四。一出离乐二远离乐三菩提乐四涅槃乐。今得此五及后四种故言大乐。遍满法界俱是乐故。金刚者能破义一切障法悉能破故。不空者显此妙法非空无果必有灵验殊胜异果名为不空。神咒者神谓圣德理事自在。咒谓总持谓十方佛共有圣德名之为神。以一略言具一切佛法所有功德。破灭一切生死怨敌。总含诸德故名总持。此名为咒。金刚法性者诸佛般若坚实诸法此为第一故名法性。此上所诠法门所得行。以下总是能得法门。初中后位者谓此经中初说中说后说三位。或发心修行证得三位。或听闻修行离欲三位。此为最胜无二第一无上法行。由此法门最第一故能证如来秘密法性等

经曰。谓大贪等‘最胜成就令大菩萨’大乐最胜成就

赞曰。自下第二正陈所说文中有二。初以三复次说菩萨行十恶业道等因所得果利。后三复次说陀罗尼。初中有三复次。初复次中有二。初明恶业道贪等为因所得果利。后明善业道般若为因所得果利。明贪等为因中初明自利果。后明利他果。明自利果中明由贪等为因展转得四种果。一由贪等为因得大乐。二大乐为因得大觉。三大觉为因得能降四魔。四降四魔为因得自在。云何名为谓大贪等最胜成就。所谓菩萨于其因中翻其生死十恶业道。自行出世十恶业道。一能杀生。谓断众生生死流转断是杀义。二不与取。无有与者自然摄取是无他求自摄益义。三欲邪行。了知欲为邪而修于正行。若分别欲实知唯邪如有颂言。佛说贪恚痴皆从分别起。净不净颠倒此亦为缘生。净不净颠倒为缘而有者彼自性皆无故显非真实。四妄语。若于妄中能说为妄。如有颂言一切虚妄法世尊如实说。于虚妄法中诸行最虚妄。五离间语。云何贝戍尼谓常居最胜空。贝戍尼言显目离间语密诠常胜空。贝表胜义戍表空义尼表常义。今取密义。六粗恶语。云何波鲁师谓善安住所知彼岸。此波鲁师显目粗恶语密诠住彼岸。彼岸即是一切智。佛于其中能善安住名波鲁师。七绮间语。若正说法品类差别。八贪欲。摄大乘说若有数数欲自证得无上静虑。此意但说从散引生但言贪定。谓起大贪欲欲无上菩提。贪于生死度脱有情名为贪欲。九嗔恚。若于其心能正憎害一切烦恼。已断已灭是憎害义。十邪见。若一切处遍行邪性皆如实见。即见一切虚妄分别邪乱为性。虽诸菩萨密行十恶业道今举意业大贪为首。据实通行三业为因。由此菩萨最胜成就行此十因故感前五种乐。胜于凡位所有诸乐故名最胜。又大乐者谓五修果离种种相得法苑乐。如前已辨

经曰。大乐最胜成就‘令大菩萨一切如来’大觉最胜成就

赞曰。证得五乐法苑乐故能得大觉觉自及他若理若事。菩萨位得一切佛因佛位名得大觉圆满

经曰。一切如来‘大觉最胜成就令大菩萨降伏一切’大魔最胜成就

赞曰。由觉事理自他邪正故能永断四种大魔

经曰。降伏一切‘大魔最胜成就令大菩萨普大三界’自在最胜成就

赞曰。由降四魔超过三界。得尊位果故普大三界。不为生死四魔所坏故名自在。略说自在有其十种。谓寿自在。心自在。众具自在。此三因施度圆满。业自在生自在由戒度圆满。胜解自在由忍度圆满。愿自在由勤度圆满。神力自在由定度圆满。智自在法自在由般若度圆满。如摄论等第九卷说。此十自在以宗而说名自利果。证得之时亦有分位故佛自在普大于三界。故有颂言。天地此界多闻室。逝宫天处十方无。丈夫牛王大沙门。寻地山林遍无等故佛世尊普大三界。略而言之清净法界大圆镜智平等性智妙观察智成所作智福德智慧二种庄严故为最胜

经曰。普大三界‘自在最胜成就令大菩萨能无遗余拔有情界利益安乐一切有情’毕竟大乐最胜成就

赞曰。上明自利下明利他于中有二。初明广大第一之心利他之行。所以者何。下后明常心不颠倒心利他之行。能无遗余拔有情界者即所有众生。众生所摄卵生胎生湿生化生若有色若无色若有想若无想若非有想若非无想并皆拔苦而与其乐。无一众生非悲智境故无遗余。遗者遗落失没之义。余者剩杖残不尽义。拔谓拔济拔诸有情无一有情遗落失没剩杖残丛而不拔者。意乐遍满十方三界五趣四生。故名广大心也。利益安乐毕竟大乐最胜成就者利益有十利。谓菩萨地说。一纯利．二共利．三利益种类利．四安乐种类利．五因摄利．六果摄利．七此世利．八他世利．九毕竟利．十不毕竟利。安乐有五如前已说。又摄善名利益离恶名安乐。等有十对解如唯识疏。毕竟大乐所谓涅槃金刚经云。我皆令入无余涅槃。彼通三乘但说涅槃不说余者。今取菩提及涅槃乐。即是有为无为一切无漏所有功德。令诸有情怡适调顺无所违损。无所逼恼故名大乐。即第一心欲令有情住极胜处故名第一

经曰。所以者何‘乃至生死流转住处有胜智者齐此常能以无等法饶益有情’不入寂灭

赞曰。所以者何征其所由拔诸有情能无遗余致涅槃界之所以者何谓是也乃至生死流转住处者能尽未来时无限也。能随十方一切有情生死流转之时时名节。十方世界住处所在即显处广时广。有胜智者谓能共离我及我所。离人法执名胜智者。生法二智悉皆圆满即是其言心不颠倒也。名胜智者离二执故。齐此常能以无等法饶益有情不入寂灭。齐十方界处齐未来际生死之时。常能以此第一最胜无等类法利乐有情。有情无限入涅槃期不可穷尽故。胜智者随诸有情不入寂灭。何以故。以无法执及有情执无自他相故。利有情常无穷尽。如世父母拔济男女心生悲愍无自他相。不惮劬劳故能长时生悲济意。菩萨亦尔。故名常心。因中四心既圆满已故至佛位能益有情无尽限期。常能济拔十方法界皆度脱尽。即是金刚四种心因得四果也

经曰。又以般若‘波罗蜜多方便善巧成立胜智善办一切清净事业能令诸有’皆得清净

赞曰。初复次中上来以贪等为因所得果利。此以般若为因所得果利。方便者由智慧力随诸有情病行机器意乐应时即为显现说法等事。故名方便。曲顺时宜令其入道之前加行名为方便。如在路行见人逐兔。他问见不应坐答言。我实不见为护杀事即现坐相云我不见。非是立时我不见也。不犯妄言护杀事成。菩萨亦尔。欲令众生舍伪入真。于无名法以名字说随其轻重时节所宜。应机而说令其入道。以象表无象以言表无言。不称其真故名方便。妙得其趣应物随时处事之间。亦不曾失故名善巧。成立胜智由此善巧为其因故。果得胜智。胜智即是二智所摄。方便善巧波罗蜜多。智之差别有其二种。一回向二拔济此回向也。究竟归一切智故。善辨一切清净事业者谓神通．记心．漏尽．三种。福智二因自他二利一切善事悉皆善辨。能令诸有皆得清净者三有九有因果双亡。生死染污悉皆销灭故名清净。即一切恶悉皆除灭。前贪等为因虽有二利宗在利他。起四种心此以般若为因能修善尽能除恶尽。菩提之心既有三种所得果利亦有其三。虽前门说贪等为因体即般若以异名说。一切皆以般若为性。此上总是初复次解

经曰。又以贪等‘调伏世间普遍恒时乃至诸有皆令清净’自然调伏

赞曰。自下第二重解贪等所得果利于中有二。初明利他后明自利。此利他也。谓以贪等调伏世间等者谓佛菩萨观诸有情多悭所蔽。虽有珍财不能修福亦不自用。如割身肉深生痛惜。菩萨知其因悭所蔽增长恶业当堕恶趣无有出期。遂起大贪集其财宝。令舍悭吝不起恶业。菩萨实是后得智中大悲之心起此贪等。不为己身名利诸众眷属恭敬。故起一贪增百千善。由是善财求善知识。遇见一王杀缚鞭杖无量众生。善财心悔王语之言。此诸众生愚钝恨悷若不苦楚终不调伏。故我苦之。善财方解如仙誉国王杀五百波罗门更增功德。此亦如是。一切十恶所有业道皆准此知。故起贪时菩萨大利

经曰。又如莲华‘形色光净不为一切秽物所染如是贪等饶益世间住过有过’常不能染

赞曰。此明贪等自利之行。菩萨身心起此贪等形色光净。不为一切秽物烦恼所能染污。故留烦恼助愿受生作大自在。若是佛者似其贪等以此贪等饶益有情。设住烦恼过失之心住余有漏善无记心名为有过。过是漏义。于此三性一切时中不能染污。如莲华等虽出泥中泥不能染。菩萨之心亦复如是

经曰。又大贪等‘能得清净大乐大财三界自在常能坚固’饶益有情

赞曰。此即第三复次重释。又大贪等者谓我贪等。贪名贪好。恐身造恶当堕生死。贪为自身修道离苦。故维摩云。宁起我见如须弥山不起空见如毛发许。以空邪见无断修故。若贪有我恐增恶名便增修道。因以贪等果得大乐七种圣财法界珍财为三界主。不为过染得十自在。于一切时于一切处于一切事坚固饶益一切有情。有情饶益即菩萨利。此中三种由昔因中或在果位能以贪等为因修习。故在果位得果无边。初是实行为返恶故说相似贪。第二大悲所逼说相似贪。第三为求利己说相似贪。然正起行生死烦恼恶业皆灭。故染贪等一切皆亡如何说起

经曰。尔时如来‘即说神咒

纳慕薄伽筏帝(一)钵剌壤波啰弭多曳(二)薄底(丁履反下同)筏攃(七葛反)罗曳(三)罨跛履弭多窭拏曳(四)萨缚呾他揭多跛履布视多曳(五)萨缚呾他揭多奴壤多奴壤多邲壤多曳(六)呾侄他(七)钵剌[口*兮](一第反下同)钵剌[口*兮](八)莫诃钵剌[口*兮](九)钵剌壤婆娑羯囇(十)钵剌壤路迦羯囇(十一)案驮迦啰毗谈末泥(十二)悉递(十三)苏悉递(十四)悉殿都漫薄伽筏底(十五)萨防伽孙达囇(十六)薄底筏攃囇(十七)钵剌娑履多喝悉帝(十八)参磨湿嚩娑羯囇(十九)勃[口*陀]勃[口*陀](二十)悉[口*陀]悉陀(二十一)剑波剑波(二十二)浙罗浙罗(二十三)曷逻嚩曷逻嚩(二十四)阿揭车阿揭车(二十五)薄伽筏底(二十六)么毗滥婆(二十七)莎诃(二十八)

如是神咒三世诸佛皆共宣说同所护念能受持者一切障灭随心所欲无不成辨疾证无上正等菩提

尔时如来复说神咒

纳慕薄伽筏帝(一)钵剌壤波啰弭多曳(二)呾侄他(三)牟尼达谜(四)僧揭洛诃达谜(五)遏奴揭洛诃达谜(六)毗目底达谜(七)萨驮奴揭洛诃达谜(八)吠室洛末拏达谜(九)参漫多奴跛履筏剌呾那达谜(十)窭拏僧揭洛诃达谜(十一)萨缚迦罗跛履波剌那达谜(十二)莎诃(十三)

如是神咒是诸佛母能诵持者一切罪灭常见诸佛得宿住智疾证无上正等菩提

尔时如来复说神咒

纳慕薄伽筏帝(一)钵剌壤波啰弭多曳(二)怛侄他(三)室囇曳(四)室囇曳(五)室囇曳(六)室囇曳细(七)莎诃(八)

如是神咒具大威力能受持者业障消除所闻正法总持不忘疾证无上’正等菩提

赞曰。自下第二段三复次咒。此第一咒。叹德如文。诸佛口同说心皆共护念。护者加持念者记忆。诸佛之心加持不忘。随心所欲除诸恶愿善者皆从。其第二咒叹德之中出生诸佛名之为母。一切诸佛生其本故。宿住智者所生之处皆得妙智知过去世住劫等事。善恶因果皆能了知。即宿住智。其第三咒叹德之中具大威者众德庄严一切敬畏。力者能伏一切。所闻正法总持不忘者得法义持。念慧明记应永不忘。故此中所释逐彼叹文。所余异文准义可解

经曰。尔时世尊‘说是咒已告金刚手菩萨等言若诸有情于每日旦至心听诵如是般若波罗蜜多甚深理趣最胜法门无间断者诸恶业障皆得消灭诸胜喜乐’常现在前

赞曰。自下第三叹经胜德于中分二。初别叹此处一段法门。第二总叹一卷经德。就初之中文有其三。初叹灭恶摄善德。次叹种因方遇德。后叹所在应尊德。初叹之中初总叹断恶得善德。后别叹引生诸善德。此为初也

经曰。大乐金刚‘不空神咒现身必得究竟成满一切如来金刚秘密最胜成就不久当得大执金刚’及如来性

赞曰。自下别叹引生诸善德。于中有三。一成满大乐金刚咒。二成就金刚秘秘法。此即教行及理法宝现前必得。三得执金刚如来性此在佛位大执金刚谓佛真智。如来性者即是法身果法宝也。此后二果因位不成故言当得至佛得故

经曰。若有情类‘未多佛所植众善根久发大愿于此般若波罗蜜多甚深理趣最胜法门不能听闻书写读诵供养恭敬’思惟修习

赞曰。此下第二种因方遇德。凡所修习行愿必兼。若先无二不能于此起十法行。于中有七。一听闻二书写三读四诵五供养恭敬六思惟七修习。余三法行亦复如是。谓施他受持开演三种。此中之书写尚由因遇。况复受持等。此等都明无因不遇

经曰。要多佛所‘植众善根久发大愿乃能于此甚深理趣最胜法门下至听闻一句一字况能具足’读诵受持

赞曰。自下正论有因方遇。其文可解。义准前知。不能具说十种并然

经曰。若诸有情‘供养恭敬尊重赞叹八十殑伽沙等俱胝那庾多佛乃能具足闻此般若波罗蜜多’甚深理趣

赞曰。上明一句一字尚假先因。此明从首至终故资多行。四事俱罗号为供养。三业虔奉立恭敬名。顶载殷勤复称尊重。先谈不已又名赞叹。殑伽者恒神之名。等者相似。佛数齐均与沙相似。此河之中纯沙无石。如今渭水无石唯沙。俱胝者百万也。那庾多者万万也。一颗沙为一俱胝那庾多。佛令供养等八十殑伽沙百万之万万佛。乃能具足闻此深经。不尔。无能具闻深义。以经深理非是小智下愚所知。故假大因。今方修遇。欢哉今者幸遇灵文

经曰。若他方所‘流行此经一切天人阿素洛等皆应供养如佛制多有置此经在身或手诸天人等’皆应礼敬

赞曰。自下第三所在应尊德。在处处尊在人人贵。随文可解。佛制多者旧云支提。即塔庙。塔庙安置化身遗骨尚可敬严。况此法身能无供养

经曰。若有情类‘受持此经多俱胝劫得宿住智常勤精进修诸善法恶魔外道不能稽留四大天王及余天众常随拥卫未曾暂舍终不横死枉遭衰患诸佛菩萨常共护持令一切时善增恶减于诸佛土随愿往生乃至菩提’不堕恶趣

赞曰。自下第二总叹一卷经之胜德。于中有二。初略别叹。后总结叹。此即初也。于中有十德。一多劫得宿住智。二所生常精进修善。三魔等不稽留。四诸天常卫护。五终不横死。六无枉衰患衰。谓祸起衰家败身。患谓染疾终无此事。七佛及菩萨常所护念。八令恶灭善生。九随愿生佛土。十从今日后乃至菩提不堕三恶趣。恶趣之言通摄人中三种恶趣。皆亦不堕。谓无形黄门二形女人

经曰。诸有情类‘受持此经定获无边胜利功德我今略说’如是少分

赞曰。此总结叹也。所诠真相穷本性之甚深。能诠教门因玄宗之极妙。受持者获利无边未可具言故说少分故。修行者欲证此德当勤修学究竟取证。方知此经胜利无尽

经曰。时薄伽梵‘说是经已金刚手等诸大菩萨及余天众闻佛所说皆大欢喜’信受奉行

赞曰。此即第三感悟修行分。诸大菩萨集报土之上人。及余天众会化身之大士。皆感如来盛说能悟寂止之宏宗。顺领深心修行散席

般若理趣分疏卷第三大尾　　　　　　享保丙申岁十月吉日　　　　　　京兆吉田元信


大方广佛华严经疏卷

    No. 1735 [cf. Nos. 279, 1736]

大方广佛华严经疏卷第一(并序)

        唐清凉山大华严寺沙门澄观撰

往复无际。动静一源。含众妙而有余。超言思而迥出者。其唯法界欤。剖裂玄微。昭廓心境。穷理尽性。彻果该因。汪洋冲融。广大悉备者。其唯大方广佛华严经焉。故我世尊十身初满。正觉始成。乘愿行以弥纶。混虚空为体性。富有万德。荡无纤尘。湛智海之澄波。虚含万象。皦性空之满月。顿落百川。不起树王。罗七处于法界。无违后际。畅九会于初成。尽宏廓之幽宗。被难思之海会。圆音落落。该十刹而顿周。主伴重重。极十方而齐唱。虽空空绝迹。而义天之星象灿然。湛湛亡言。而教海之波烂浩浣。若乃千门潜注。与众典为洪源。万德交归。摄群经为眷属。其为旨也。冥真体于万化之域。显德相于重玄之门。用繁兴以恒如。智周鉴而常静。真妄交彻。即凡心而见佛心。事理双修。依本智而求佛智。理随事变。则一多缘起之无边。事得理融。则千差涉入而无碍。故得十身历然而相作。六位不乱而更收。广大即入于无间。尘毛包纳而无外。炳然齐现。犹彼芥瓶。具足同时。方之海滴。一多无碍。等虚室之千灯。隐显俱成。似秋空之片月。重重交映。若帝网之垂珠。念念圆融。类夕梦之经世。法门重叠。若云起长空。万行芬披。比华开锦上。若夫高不可仰。则积行菩萨曝腮鳞于龙门。深不可窥。则上德声闻杜视听于嘉会。见闻为种。八难超十地之阶。解行在躬。一生圆旷劫之果。师子奋迅。众海顿证于林中。象王回旋。六千道成于言下。启明东庙。智满不异于初心。寄位南求。因圆不逾于毛孔。剖微尘之经卷。则念念果成。尽众生之愿门。则尘尘行满。真可谓常恒之妙说。通方之洪规。称性之极谈。一乘之要轨也。寻斯玄旨。却览余经。其犹杲日丽天。夺众景之耀。须弥横海。落群峰之高。是以菩萨搜秘于龙宫。大贤阐扬于东夏。顾惟正法之代。尚匿清辉。幸哉像季之时。偶斯玄化。况逢

圣主。得在灵山。竭思幽宗。岂无庆跃。题称大方广佛华严经者。即无尽修多罗之总名。世主妙严品第一者。即众篇义类之别目。大以旷兼无际。方以正法自持。广则称体而周。佛谓觉斯玄妙。华喻功德万行。严谓饰法成人。经乃注无竭之涌泉。贯玄凝之妙义。摄无边之海会。作终古之常规。佛及诸王。并称世主。法门依正。俱曰妙严。分义类以彰品名。冠群篇而称第一。斯经有三十九品。此品建初。故云大方广佛华严经

    世主妙严品第一

  归命十方极三际　　尘刹圆明调御师
  法界功德大悲云　　毗卢遮那大智海
  所住甚深真法性　　所流圆满修多罗
  一一尘方佛会中　　普贤文殊诸大士
  我今欲以一毛智　　测量无边法界空
  愿承三宝同体慈　　句句冥符诸佛意
  俾令法眼常无缺　　尽众生界如普贤
  回兹胜善洽群生　　速证菩提常乐果

将释经义。总启十门。一教起因缘。二藏教所摄。三义理分齐。四教所被机。五教体浅深。六宗趣通局。七部类品会。八传译感通。九总释经题。十别解文义

初因缘者。夫圣人设教必有由致。若须弥巨海大因方为倾摇。今摇如来融金之德山。动深广之智海。非小缘矣。故下经。云非以一缘非以一事。如来出现而得成就。出现本为大华严故。先因后缘各开十义。以显无尽因。十义者。一法应尔故。二酬宿因故。三顺机感故。四为教本故。五显果德故。六彰地位故。七说胜行故。八示真法故。九开因性故。十利今后故。言法尔者。夫王道坦坦千古同规。一乘玄门诸佛齐证。故一切佛。法尔皆于无尽世界。常转如是无尽法轮。令诸众生反本还源。穷未来际。无有休息。故不思议品中明。一切诸佛能于一身化现不可说不可说佛刹微尘数头。一一头化尔所舌。一一舌出尔所音声。乃至文字句义。一一充满一切法界无有穷尽。斯则处以毛端横该法界。时以刹那竖穷劫海。处则顿起时则常起。不待别因。但随见闻说。有初成九会之别。诸慈悲者。于无尽中略此流传。令寻于此见无边法。如观牖隙见无际空。而此时处即同无尽。以一处即一切处。一时即一切时故。二酬宿因者。何以法尔如是转耶。宿因深故。夫根深则果茂。源远则流长。宿因既深教起亦大。深大云何。我佛世尊。创蹑玄踪栖神妙寂。悲智双运行愿齐周。是以妄想弗翦而廓彻性空。灵鉴匪磨而顿朗万法。乃以无障碍解脱阐斯沙门。宿因虽多略有二种。一者大愿力故。现相品云。毗卢遮那佛愿力周法界一切国土中。恒转无上轮。兜率偈云如来不出世。亦无有涅槃。以本大愿力。示现自在法。诸会佛加皆言愿力。及余诸文成证非一。二者昔行力故。谓无量劫依愿起行。行成得果方能顿演。故主山神偈云。往修胜行无有边。今获神通亦无量。法门广辟如尘数。悉使众生深悟喜。三顺机感者。谓昔因法尔虽能常遍。约可流传皆由机感。离机说法无所用故。其犹上有白月下资澄潭。潭清影现。机感应生。故兜率偈云。见佛亦复然。必假众善业。十方诸佛告功德林。言及诸菩萨众善根力故。解脱月云。此众无诸垢志解悉明洁等。皆是机感。广显机感。如第四教所被机中。然此机感通于现未。诸会当机即是现在。今之闻者。是未来机。四为教本者。谓非海无以潜流。非本无以垂末。将欲逐机渐施末教。先示本法顿演此经。然亦有二。一为开渐之本。出现品云。如日初出先照高山故。二为摄末之本。如日没时还照高山故。无不从此法界流。无不还归此法界故。法华亦云。始见我身。闻我所说。即皆信受。入如来慧。此渐本也。次云除先修习学小乘者。即开渐也。又云。我今亦令得闻是经入于佛慧。即摄末归本也。斯则法华亦指此经以为本矣。五显果德者。谓此本法中显佛胜德。令诸菩萨信向证故。不识宝玉不得其用。不知此德安能仰求。然果德有二。一依果。谓华藏世界海等。二正果。如来十身等。此二无碍以为佛德。然依正无碍通有六句。一依内现依。如尘中刹海。二正内现正。如毛孔现佛。三正内现依。四依内现正。五依内现依正六正内现正依。其文非一。又有四句。一或唯依。佛即刹故。二或唯正。刹即佛故。三俱。四泯。思之可知。随举一门则摄一切。并如下说。六彰地位者。为显菩萨修行佛因。一道至果有阶差故。夫圣人之大宝曰位。若无此位行无成故。此亦二种。一行布门。立位差别故。二圆融门。一位即摄一切位故。一一位满即至佛故。初地云。一地之中。具摄一切诸地功德。信该果海。初发心时便成正觉等。然此二无碍。以行布是教相施设。圆融是理性德用。相是即性之相。故行布不碍圆融。性是即相之性。故圆融不碍行布。圆融不碍行布。故一为无量。行布不碍圆融。故无量为一。无量为一。故融通隐隐。一为无量故涉入重重。故世亲以六相圆融。上下之文非一。七说胜行者。欲登妙位非行不阶。故君子不患无位。患己不立。行亦二种。一顿成诸行。一行一切行。故十住品云。一即是多多即一等。普贤行品说。一断一切断等故。二遍成诸行。此即行布。谓自大菩提心体相功德。乃至等觉中行。此二无碍例如位说。八示真法者。欲成行位须解法理。不体理事行亦非真。故兜率偈云。不了真实法。诸佛故兴世。此亦二种。一显事理无碍法。二显事事无碍法。并如义分齐说。九开因性者。谓上因果理事。皆由众生性有。若性非金玉虽琢不成宝器。良以众生包性德而为体。依智海以为源。但相变体殊。情生智隔。今令知心合体达本情亡。故谈斯经以为显示。亦有二种。一以言显示令其知有。二使其修行悟入显现。如下破尘出经卷等。亦如法华云。唯以一大事因缘故出现于世。所谓开示悟入佛之知见。众生等有故言唯一。十利今后者。既等有其分。故广利无边。此亦二种。一利今。即佛在当机。二利后。即今之见闻。发心品云。我等诸佛护持此法。令未来世一切菩萨未曾闻者。皆悉得闻。此益复二。一令得见闻为坚种。故出现品云。如人食少金刚终竟不消等。二令起行成证入故出现。又云。设有菩萨。无量百千亿那由他劫。行六波罗蜜。修习种种菩提分法。若未闻此如来不思议大威德法门。或时闻已。不信不解不顺不入。不得名为真实菩萨。以不能生如来家故。若闻此法信解随顺悟入。当知此人生如来家。乃至深入如来无量境界。良以有作之修。多劫终成败坏。无心体极一念便契佛家。贤首品云。十刹尘数如来所。悉皆承事尽一劫。若于此品能诵持。其福最胜过于彼等。又此利益别对前九成十种益。谓一闻法尔。则知常遍成见闻益。二闻本行。愿学佛发兴。成发心益。三闻机感。知法由善起。成造修益。四闻为本。知其义圆。成顿得益。五闻果德。则信乐愿齐。成灭障益。六闻位。期心证入。成摄位益。七闻行。发意修行。成起行益。八闻法。决须解了。成称性益。九闻因。知一切皆同。成转利益。十总具前九成速证益。故前九因皆为今益。亦可前一一门皆成十益。可以意得。因上十义故此教兴。发心品中有十所因。彼云。以佛神力故。世尊本愿力故等。因缘相参。对会因缘。可以意得。二明说经缘者。一切经首说时方人等。皆是缘起。今有十缘。一依时。二依处。三依主。四依三昧。五依现相。六依说者。七依听者。八依德本。九依请者。十依加者。今初依时。夫心冥至道则混一古今。法界无生。本亡时分。下经偈云。诸佛得菩提。实不计于日。况无涯之说。念劫圆融哉。今以无时之时。略显十重时别。初唯一念。二尽七日。三遍三际。四摄同类劫。五收异类劫。六以念摄劫。七劫念重收。八异类界时。九彼此相入。十以本收末。谓以非劫为劫故。于前十时。恒演此经。又此十种随一圆收。依此说时则无终始。亦随见闻说初成等。如前法尔中辩。若依此时则迥异余教。而余教时不出于此。或说三七六七等。随见闻故。广如旨归。第二依处者。夫智穷真际能所两亡。假说依真而非国土。况刹尘即入染净参融。圆满教之普周。难以分其处别。然真非事外。不坏所依。以上无时之时遍非处之处。然有言。此经在秽土说。居摩竭等故。有云。处净土说。在华藏故。有云。如实义者。二种身土无定异处。即于一处见闻异故。上之三义。后一近宗。然说此经处。净秽无碍通局交彻。各二四句。初净秽中。谓或唯染或唯净。如前二义。或俱华藏内娑婆故。或泯染净相。尽同一法界故。又或唯染。摩竭等覆净相故。或唯净。其地金刚染相尽故。或俱。隐显无碍故。或俱非。各相形夺二相尽故。次明通局交彻二四句者。谓或局。此一界故。或通。该十方故。或俱。即此即遍故。或泯。二相尽故。又或局。此界摄一切故。或通。此入一切故。或俱。即摄即入故。或泯。形夺相尽故。又以一尘例刹。亦有四句可知。若从陜至宽。略显十处。初此阎浮七处九会而周法界。如升须弥品。二周百亿同类一界。亦遍法界。如光明觉品。三遍异类树形等刹。四遍刹种。五遍华藏。六遍余刹海若种若刹。七遍前六类刹尘。皆有同异类刹。八尽虚空界。容一一毛端之处。各有无边刹海。九犹帝网。十余佛同。然上十类一一各遍法界。而前九正是遮那说法之处。然说十住等处。虽复各遍法界乃至尘毛。为门不同。亦无杂乱。若约十住与十行等。全位相摄。则彼此互无。各遍法界。若约诸位相资。则此彼互有。同遍法界。一一品会准此知之。十余佛同者。此佛既尔余佛亦然。故诸会结通皆云。我等诸佛亦如是说。然主主不相见。伴伴不相见。主伴伴主则互相见。若互不相见。即各遍法界。互相见故。同遍法界。亦无杂乱。亦无障碍。又上十处共为缘起举一全收。以一一处称法性故。而随前一一时皆遍此诸处。又随一一处皆具前时。顿说此经。此犹约器世间说。若约智正觉及众生世间。即一一佛身支节毛孔。皆摄无尽重重之刹。普贤众生一一皆尔。并是遮那说经之处。第三依主者。夫真身寥廓。与法界合其体。包罗无外。与万化齐其用。穷源莫二执迹多端。一身多身经论异说。今说此经。佛为真为应为一为多。若言真者。何名释迦。居娑婆界人天同见。若云应者。那言遮那。处莲华藏大菩萨见。见佛法身。若云一者。何以多处别现。若云异者。何以复言而不分身。故说此经佛并非前说。即是法界无尽身云。真应相融一多无碍。即卢遮那是释迦故。常在此处。即他处故。远在他方恒住此故。身不分异。亦非一故。同时异处。一身圆满。皆全现故。一切菩萨不能思故。今先明十身。后彰无碍。言十身者。自有二义。一约融三世间为十者。一众生身。二国土身。三业报身。四声闻身。五缘觉身。六菩萨身。七如来身。八智身。九法身。十虚空身。二就佛上自有十身。一菩提身。二愿身。三化身。四力持身。五相好庄严身。六威势身。七意生身。八福德身。九法身。十智身。广显其相如第八地。及离世间品辩。言无碍者。略有十义。一用周无碍。谓于上念劫刹尘等处。遮那佛现法界身云。业用无边悉周遍故。经云。如于此处见佛坐。一切尘中亦如是等。其文非一。二相遍无碍。谓于上差别用中。各摄一切业用故。三寂用无碍。无私成故。四依起无碍。无心顿现。海印力故。五真应无碍。应即同法一味平等故。六分圆无碍。一一身分即具全身故。七因果无碍。不碍现因故。八依正无碍。不碍现依故。九潜入无碍。入众生界。如如来藏。虽作众生不失自性故。故出现品云。佛智潜入众生心。又云。众生心中有佛。成正觉等。又亦摄一切众生。在一毛孔善化。天王云。汝应观佛。一毛孔。一切众生悉在中等。十圆通无碍。谓此佛身即理即事。即一即多。即依即正。即人即法。即此即彼。即情即非情。即深即广。即因即果。即三身即十身。同一无碍法界身云。以此身云。遍前时处。常说华严。是知或说报身在色究竟。约摄报说。或说报身在余净土。约引摄说。或说舍那坐千叶华。摄二地说。或说登地方见。约胜机说。或分三异。从体相用说。俱非此经真实之义。设分三十不同。亦权实对说。若不融前义。亦失经宗。第四依三昧者。夫动静。唯物圣岂然。乎。示轨后徒。明将有说。必须静鉴前理。受诸佛加。从定起而发言。言必真当。言必真当故。受者之心。自然笃矣。故于诸会。多明入定。为说经缘。有不入者。至文当说。其所入定。皆尽法源。业用难思。第五依现相者。谓法性寂寥。虽无诸相。无相之相。不碍繁兴。起教多端。相非一准。或放光动刹。或华雨香云。皆为发起。故诸会之内。将欲说法。多先放光。通表智光。以被物故。然有二种。一不坏次第光。随位增微故。二圆通无碍光。随一一光。皆结通故。随处放异。总有十光。各有所表。至文当知。其动地等。多在说后。则但是庆闻。如十地中。虽是庆前。义兼起后。则是教缘。第六依说人者。法无废兴。弘之由人。下文云。佛法无人说。虽慧莫能了。今此能说。通三世间。开即为五。谓佛菩萨声闻众生及器。更开为十。谓加三世。微尘。毛孔。器及有情。各有分圆故。毛孔微尘即是分说。此上诸说。通三世故。故普贤行品云。佛说众生说。及以国土说。三世如是说等。广则无量。法界品中类非一故。如僧祇随好。即是佛说。余会多菩萨说。法界品初有声闻说。诸善友等多菩萨说。亦名众生说。菩提树等即器界说。至文当知。其能说人用法不同。或用音声。或用妙色等。如教体中辩。第七依听人者。子期云。丧百牙辍弦若无听者。终无有说。即下诸众略有十类。至文当明。除当机众。余皆是缘。第八依德本者。川有珠而不枯。山有玉而增润。内无德本。外岂能谈。然唯约说者。前人此法故。略有二类。一者智慧最为首故。十方诸佛。告金刚幢言。及由汝智慧清净故。告金刚藏言。亦是汝胜智力故。二者余行愿力。十方诸佛。告普贤言。亦以汝修一切诸行愿力故。十方诸佛。告法慧言。及汝所修诸善根力。令汝入是三昧。而演说法。若感者善根。若化主行愿。皆属说因。第九依请人者。若约慈悲深厚。亦有无问自谈。若约敬法重人。要须诚请后说。初心识昧。未解咨求。上智慈悲。腾疑启请。然有二类。一者言请。二者念请。诸会有无现相品当辩。第十依能加者。夫圣无常应。应于克诚。心冥至极。故得佛加。然若佛自说则不俟加。如第九会。因人有说。要假上加。其第八会。行依法修。不异前故。略无有加。二七不入定。故无有加。余皆具有。所以加者。欲显诸佛同加即同说故。一说一切说故。亦显果海无言因相可说故。若尔僧祇随好应非一切。表微细难知故。超出因果故。然施设不同。不应一准。加有二种。一者显加。具于三业。二者冥加。但与智令说。普光法界。无显有冥。余皆具二。显必有冥故。余至下明。教起因缘竟。第二藏教所摄中二。先藏摄后教摄。前中亦二。先藏后摄。今初。藏谓三藏二藏。通称藏者。以含摄故。世亲摄论第一。庄严论第四。皆云彼三及二。云何名藏。答云。由摄故。谓摄一切所应知义。摄即包含。言三藏者。一修多罗藏。二毗柰耶藏。三阿毗达磨藏。初中先辩名。后显相。今初。亦名修妒路。亦名素怛缆。此皆梵音楚夏。古译为契经。智论之中。名为经藏。契谓契理。契机。经谓贯穿摄化。即契理合机之经。依主受名。契经即藏。持业释也。复云。正翻名线。线能贯华。经能持纬。此方不贵线称。故存于经。有云。案五印度。呼线席经井索。圣教。皆曰修多罗。则经正是敌对。斥于古德。经非敌对。今更详之。若一名四实。皆为敌对。则古如所破。若兼顺义。经自属于席经。敌对应名圣教。故梁摄论。译为圣教。彼论云。有阿毗达磨。非是圣教。为成圣教故。加修多罗名。古德见此儒墨皆称为经。遂借彼席经。以目圣教。则双含二义。俱顺两方。借义助名。更加契字。拣异席经。甚为允当。二显相者。西域四名。所目虽殊。意义相似。故同称修多罗。而圣教多含具上三义。故杂心云。经有五义。一曰涌泉。二曰出生。三曰显示。四曰绳墨。五曰结鬘。涌泉则注而无竭。出生则展转滋多。义同井索。有汲引故。显示正是圣教。显事理故。绳墨则揩定正邪。亦是绳之为经。能持于纬。同席经义。结鬘同线。线能贯华。结成鬘故。总上五义。不出贯摄。故佛地论第一云。能贯能摄故名为经。以佛圣教贯穿摄持所应说义所化生故。此或贯摄通所说所化。或贯穿法相。摄持所化。又世亲摄论释贯穿云。谓能贯穿依故相故法故义故。依者谓于是处由此为此而有所说。相者谓世俗谛相胜义谛相。法者谓蕴界处。缘起谛食静虑无量无色解脱胜处遍处菩提分无碍解无诤等。义者随顺密意说等。瑜伽二十五。显扬二十。大同此说。余义至十二分中当明。第二毗柰耶藏。初名。后相。前中亦名毗尼。梵言之略耳。此翻为调伏。谓调练三业。制伏过非。调练通于止作。制伏唯明止恶。就所诠之行彰名。即调伏之藏。或能诠藏。有调伏之能。即有财释。契经藏中类有此释。毗尼或翻为灭。灭有三义。一灭业非。二灭烦恼。三得灭果。或名尸罗。具云翅怛罗。此云清凉。离热恼因。得清凉果故。亦名波罗提木叉。此云别解脱。此就因得名。然有二义。一拣异定道。名之为别。二三业七支各各防非故名为别。亦翻为随顺解脱。此据果立。随顺有为无为二种解脱果故。亦名性善。如十诵律。亦名守信。如昔所受实能持故。后显相者。前名之中已含止作。即毗尼相。若别说者。世亲摄论云。毗柰耶有四义。谓犯罪故。等起故。还净故。出离故。广如彼论。第三阿毗达磨藏。阿毗名对。达磨云法。法有二种。一胜义法。谓即涅槃。是善是常故。名为胜。二法相法。通四圣谛。相者性也。状也。二俱名相。法既有二对亦二义。一者对向。谓向前涅槃。二者对观。观前四谛。其能对者皆无漏净慧。及相应心所等。由对果对境。分二对名故。慧但是对而非是法。非所对故。言对法者。法之对故。故对法藏。特名慧论。旧译为无比法。以诠慧胜故。世亲摄论云。阿毗达磨有四义。谓对故。数故。伏故。通故。对义同前。数者于一一法。数数宣说。训释言辞。自共相等无量差别故。伏者由此具足论处所等能胜伏地论故。通者此能通释素怛缆义故。亦名优婆提含。此云论义。亦名磨怛理迦。此云本母。谓以教与义为本为母。亦云依藏。生解。藏为解母。本即是母。亦名摩夷。此云行母。依藏成行故。行之母故。然此三藏。约其所诠。略有二门。一者克性则经诠三学。戒唯戒心二学。论唯慧学。如摄论说。二约兼正则三藏之中经正诠定。毗尼诠戒。论诠于慧。兼各通三。第二明二藏者。一声闻藏。二菩萨藏。即由前三藏。诠示声闻理行果。故名声闻藏。诠示菩萨理行果。故名菩萨藏。故庄严论第四云。此三藏由上下乘差别故。复为声闻藏及菩萨藏。摄大乘同此。此就二乘理果同故。合之。若约教行别故。即开三乘以为三藏。如普超等经。又由缘觉多不藉教。出无佛世。佛在世时摄属声闻故。但分为二。即是大小半满不同。第二明所摄者。此经三藏之中。正唯修多罗摄。兼诠余二。十藏等品广显戒故。问明等品显论义故。若就修多罗中以义拣教。则唯十藏摄。具足主伴显无尽故。教义融故。二藏之中唯菩萨藏。若分权实。但菩萨藏一分所摄。权不摄故。若约此摄。乃至声闻。亦此经摄。此能包含。无量乘故。拣于权实。至下立教中明。已辩藏摄。第二明教摄者。教有二种。一者通相。十二分教。亦分大小。至下十藏品辩。二者诸宗立教不同。今当略释。夫教海冲深。法云弥漫。智光无际。妙辩叵穷。以无言之言。诠言绝之理。以无变之变。应无穷之机。极位所承。凡情难挹。今乘理教之力。略启四门。一大意合离。二今古违顺。三分宗立教。四总相会通。今初。且西域东夏弘阐之流。于一代圣言。或开宗分教。或直释经文。以皆含得失故耳。且不分之。意略有五焉。一则理本一味。殊涂同归故。不可分也。二一音普应。一雨普滋故。三原圣本意。为一事故。四随一一文。众解不同故。五多种说法。成枝流故。以斯五义。故不可分。分之乃令情构异端。是非竞作。故以不分。为得。其分教者。亦有多义。一理虽一味诠有浅深。故须分之使知权实。二约佛虽则一音。就机差而教别。三本意未申。随他意语而有异故。四言有通别。就显说故。五虽分权实。须善会佛意。有开显故。又王之密语。所为别故。不识权实。以深为浅。失于大利。以浅为深。虚其功故。庄严圣教令深广故。诸圣教中。自有分故。诸大菩萨亦开教故。以斯多义。开则得多而失少。合则得少而失多。但能虚己求宗。不可分而分之。亦何爽于大旨。故今分之。第二古今违顺。曲分为二。先叙此方。后明西域。今初。诸释虽众。略叙数家。勒为五门。一立一音教。谓如来一代之教。不离一音。然有二师。一后魏菩提流支云。如来一音同时报万。大小并陈。二姚秦罗什法师云。佛一圆音平等无二。无思普应。机闻自殊。非谓言音本陈大小。故维摩经云。佛以一音演说法。众生各各随所解。上之二师。初则佛音具异。后则异自在机。各得圆音一义。然并为教本。不分之意耳。第二立二种教。自有四家。一西秦昙牟谶三藏。立半满教。即声闻藏。为半字教。菩萨藏。为满字教。隋远法师。亦同此立。斯则文据涅槃。盖是对小显大。通相之意。未于大中显有权实。亦含半满。二隋远法师。立渐顿二教。谓约渐悟机。大由小起。所设具有三乘。故名为渐。若约顿机。直往于大。不由于小。名之为顿。此虽约机。说有渐顿。而所说法不出半满。三唐初印法师。亦立二教。一屈曲教。谓释迦经。以逐机性随计破着故。如涅槃等。二平道教。谓舍那经。以逐法性自在说故。如华严经。又此二教略有四异。一主异。谓释迦化身。兴虑舍那十身异故。二处异。谓娑婆界木树草座。与华藏界中宝树宝座等异故。三众异。谓为声闻及菩萨说。与唯菩萨及极位同说异故。四说异。谓局处之说。与该通十方之说异故。此约化仪以判。然华严虽有随诸众生各别调伏。皆是称性善巧。一时顿演。涅槃等虽说一极。或对权显实。或会异归同。一切如来。或说不说。故云屈曲。约释迦为主。则未显十身。十身为主。必具释迦。娑婆之处。未融华藏。华藏之处。必融娑婆。略云四异。异实有多。诚如所判。但以屈曲之内。未显法之权实耳。四齐朝隐士刘虬。亦立渐顿二教。谓华严经名为顿教。余皆名渐。始自鹿苑。终于双林。从小之大故。然此经。如日初出先照高山。即是顿义。慈龙降雨。以证渐义。于理可然。渐约五时。次下当辩。第三立三种教。亦有三家。一南中诸师。同立三教。谓于前渐顿。加不定教。由渐中。先小后大。而央掘经六年之内即说。为遮此难故立不定。谓别有一经。虽非顿摄。而明佛性常住。即胜鬘金光明等。是为偏方不定教也。渐中开合。诸师不同。或但分为二。即是半满。或分为三。即武丘山岌法师。谓十二年前。见有得道。名有相教。十二年后。齐至法华。见空得道。名无相教。最后双照。一切众生佛性。阐提作佛。名常住教。此与唐三藏三时之教。大同。至叙西域中说。真谛三藏。依金光明。立转照持三轮之教。亦大同此。而时节小异。谓七年前说四谛。名转法轮。七年后说般若具转照二轮。以空照有故。三十年后具转照持。以双照空有持前二故。或分为四。即宋朝岌法师。谓于前三时。无相之后。常住之前。指法华经。为同归教。以会三归一。万善悉向菩提故。或开为五。然有二家。一道场慧观等。于无相之后。同归之前。指净名思益等。为抑扬教。二者即前刘公。不开抑扬。而有教之初。取提胃经。为人天教。上来诸师。皆于渐中。约时开异。若不加不定之教。则招难尤多。以初有大故。虽加不定。犹有妨难。略显五时之妨。余可例知。初明十二年前为有相者。自违成论。成论云。我今正明三藏中实义。实义即空。又阿含中云。无是老死。即法空也。无谁老死。即生空也。又智论云。三藏中明法空为大空。摩诃衍中明十方空为大空。皆显小乘已有二空。若云第二时说空者。十二年后。方制广戒。岂唯说空。又智论云。从得道夜。乃至涅槃。常说般若。岂前不说空。若云第二时中未显常住者。实相般若岂无常耶。涅槃亦说佛性。亦名般若。是知实相般若即是正因佛性。观照即为了因。又般若离四句。何曾存空。般若不坏四句。岂无妙有。是知小大各有四门。而但言初有次空者。各得一门之意耳。若云第三时中但名抑扬亦非常者。净名云。佛身无为不堕诸数。观身实相观佛亦然。岂无常耶。般若亦云。二乘智慧。犹如萤光。菩萨一日学智。如日之照。岂非抑扬。若云第四时中但显同归亦未明常者。寿量品云。常住不灭。又方便品云。世间相常住等。岂无常耶。五以涅槃。为常住者。当教可尔。而涅槃之时。亦有小乘之见。如阿含中说如来涅槃之相故。若以人天为初者。提胃虽说戒善。得道。皆通三乘。故彼经云。提胃得不起法忍。又违密迹经中。第二七日说三乘故。然上五时等。皆以约时克定。则有所乖。拣去不定。从多分说。亦有理在。二后魏光统律师。承习佛陀三藏。亦立三教。谓渐顿圆。初为根未熟者。先说无常。后方说常。先空后不空等。如是渐次。故名为渐。二为根熟之辈。于一法门。具足演说常无常空不空等。一切具说。更无由渐。故名为顿。三为于上达分阶佛境之者。说于如来无碍解脱究竟果德圆满秘密自在法门。故名为圆。此亦约化仪。说有前后耳。意明今时堪受顿者。必昔曾受化故。云根熟。上达之言。义兼地前。分阶佛境。即谓地上。于理亦通。三隋末唐初吉藏法师。依法华第五。立三种法轮。一始见我身。闻我所说。即皆信受。入如来慧。即根本法轮。二除先修习学小乘者。即枝末法轮。三我今亦令得闻是经入于佛慧。即摄末归本法轮。此判全约化仪。据法但有大小。然法华为于一类开显本末。若将定判一代圣教。收义不尽。以法华之前。亦有大故。岂般若等皆为枝末。又无量义云佛一切时说大小故

大方广佛华严经疏卷第一大方广佛华严经疏卷第二

        唐清凉山大华严寺沙门澄观撰

第四立四教者。略有四家。一梁朝光宅法师。依法华第二。立四乘教。谓临门三车。即是权教三乘。四衢等赐。即实教大乘。以临门牛车亦同羊鹿。俱不得故。并无体故。诸子皆索故。是知三皆虚指。以为方便。此则前三是三乘。后一是一乘。无乖教理。若唯说法华为实。则抑诸般若及诸大乘了义之经。是知昔大亦有权实。法华但会昔权。故说三皆虚指。昔实不滞方便故不会之。若约会权归实。即是会三为一。若破小显大。即是会二归一。若开权显实。则三是一。更无别一。故彼经云。汝等所行是菩萨道。先所出内。是子所知。若废权立实。义说为四。如揽三点以成一伊。点别非伊。伊具三点。昔三既别。实不兼权。今一全兼。成四无爽。若依昔未显说一切具有如来知见。根败之种。今并说成。则今昔有异。于文有据。义亦极成。二陈隋二代天台智者。承南岳思大师。立四教。云一三藏教。此教明因缘生灭四真谛理。正教小乘旁化菩萨。二者通教。通者同也。三乘同禀故。此教明因缘即空无生四真谛理。是摩诃衍之初门。正为菩萨。旁通二乘。大品云。欲得声闻乘。当学般若波罗蜜等。然教理智断行位因果皆通。浅深不同。于共般若。唯共于浅。三别教。别即不共。不共二乘人说故。此教正明因缘假名无量四真谛理。的化菩萨。不涉二乘。故声闻在座如聋如盲。不名不共而云别者。兼欲拣非圆故。以一因迥出。一果不融。历别而修。不得因果圆融故。四圆教。圆以不偏为义。此教正明不思议因缘。二谛中道。事理具足。不偏不别。但化最上利根之人。故名为圆。华严经云。显现自在力。为说圆满经。无量诸众生。悉受菩提记等。别则教理等皆别。圆则教等皆圆。又此四教由三观起。从假入空。析体异故。有初二教。从空入假。从假入中。有别教起。三观一心中得有圆教起。又此四教。不局定一部。一部之中。容有多故。又更以四种化仪收之。谓顿渐不定秘密。顿渐同前岌公。后二。谓一音异解。若互相知。名为不定。互不相知。即名秘密。此师立义。理致圆备。但三藏教名义。似小滥。以余三教亦有三故。所以尔者。良以智论之中多詺小乘为三藏故。成实论中亦自说云。我今欲说三藏中实义故。初对旧医戒定慧故。立此三事。迢然不同。异后三教。通教意融三故。别教依一法性而显三故。圆教三一无障碍故。所以不名小乘教者。此教亦有大乘。六度菩萨。三十四心断结成真佛故。故藏通别圆之义。四教互有。而核其定实。余三不成。唯成当教中义耳。但判华严兼于圆别。以就登地已上。约寄位行布。为别义故。名异义同。亦无大过。三唐初海东元晓法师。亦立四教。一三乘别教。如四谛缘起经等。二三乘通教。如般若深密经等。三一乘分教。如梵网经等。四一乘满教。如华严经等。然三乘共学。名三乘教。于中未明法空。名别相教。说诸法空。是为通教。不共二乘。名一乘教。于中未显普法。名随分教。具明普法。名圆满教。然此大同天台。但合别圆。加一乘分耳。自言且依乘门。略立四种。非谓此四遍摄一切。故无有失。四贤首弟子宛公。依宝性论。立四种教。论云。有四种众生。不识如来藏。如生盲人。一者凡夫。二者声闻。三者辟支佛。四者初心菩萨。言四教者。一迷真异执教。当彼凡夫。二真一分半教。当彼二乘。三真一分满教。当彼初心菩萨。四真具分满教。即当彼识如来藏者。初教谓诸外道迷于真理。广起异计。二谓小乘。于真如随缘不变二分义中。唯说生空所显之理。故名为半。如涅槃半字。三谓但得不变。不得随缘。故名一分。而双辩二空。故名为满。四由具随缘不变二义。故名具分。广如彼说。然今判圣教。那参邪说。若对教主。应如此方先立三教。或如西域。分内外及六师等。又依涅槃。为半满者。后二既满。不应复有一分之言。既但得不变一分。岂名为满。又涅槃半满。岂唯约二空。岂彼不说妙有。而诃空耶。故其所立。未为允当。第五立五教。略有二家。一波颇三藏立。一四谛教。谓四阿含等。二无相教。谓诸般若。三观行教。谓华严经。四安乐教。谓涅槃经。说常乐故。五守护教。谓大集经说守护正法事故。此释名局。以观行等皆互有故。二贤首所立五教。至下当知。第二叙西域者。即今性相二宗元出彼方。故名西域。谓那烂陀寺同时有二大德。一名戒贤。二名智光。戒贤远承弥勒无著。近踵护法难陀。依深密等经瑜伽等论。立三种教。以法相大乘而为了义。即唐三藏之所宗师。谓佛初于鹿苑。转四谛小乘法轮。说诸有为法皆从缘生。以破外道自性因等。又缘生无我翻外有我。然犹未说法无我理。即四阿含等是。第二时中。虽依遍计所执。而说诸法自性皆空。翻彼小乘。然于依他圆成犹未说有。即诸部般若等经。第三时中。就大乘正理。具说三性三无性等。方为尽理。即解深密经等。是故于彼三时。初堕有边。次堕空边。俱非了义。后时具说遍计性空。余二为有。契会中道。方为了义。此依深密。所判。二智光论师。远承文殊龙树。近禀青目清辩。依般若等经中观等论。亦立三时教。以明无相大乘为真了义。谓佛初鹿苑说小。明心镜俱有。次于中时。为彼中根。说法相大乘境空心有唯识道理。以根犹劣。未能全入平等真空。故后第三时。为上根说无相大乘辩心境俱空。平等一味为真了义。又初渐破外道自性等故。说因缘生法决定是有。次渐破小乘缘生实有之执故。说依他似有。以彼怖畏此真空故。由存假名。而接引之。后时方就究竟。而说缘生即空平等一味。此三次第。如智光论师般若灯论释中引大乘妙智经说。然此二三时。并不能断一代时教。以各有据互相违故。各别为于一类机故。深密经意。为于一类餐般若者。闻平等空。拨无因果。不了空有无二故。第三时。为其分析于一法上空有之义。其妙智经。则以一类闻说三性迷唯识者。未能忘心观缘起者。定谓似有故。令总忘心境。即事而真。得斯意者。则不相违。然欲会二宗。须知二宗立义。有多差别。略叙数条。一者一乘三乘别。二一性五性别。三唯心真妄别。四真如随缘凝然别。五三性空有即离别。六生佛不增不减别。七二谛空有即离别。八四相一时前后别。九能所断证即离别。十佛身无为有为别。且初二义者。由性有五。一不同故。令乘有三。一权实。如法相宗意。以一乘为权。三乘为实故。深密三时教中。初皆不成。次一向成。是为若过若不及。皆非了义。第三时中。有性者成。无性不成。方为了义。故云普为发趣一切乘者。又初二卷中。皆云一乘是密意说。故知是权。又胜鬘经。以一乘为方便故。大般若五百九十三中。善勇猛菩萨言。唯愿世尊哀愍我等。为具宣说如来境智。若有情类。于声闻乘性决定者。闻此法已。速能证得自无漏地。于独觉乘性决定者。闻此法已。速依自乘而得出离。于无上乘性决定者。闻此法已。速证无上正等菩提。若有情类。虽未已入正性离生。而于三乘性不定者。闻此法已。皆发无上正等觉心。深密第二大意同此。又云。一切趣寂声闻种性补特伽罗。虽蒙诸佛施设种种勇猛加行方便化导。终不能令当坐道场证阿耨多罗三藐三菩提。又十轮第九亦说。三乘各定差别。皆以性定五故。故楞伽中。佛告大慧。有五种种性。一声闻乘性。二辟支佛乘性。三如来乘性。四不定乘性。五者无性。大庄严论及瑜伽论。皆同此说。善戒地持。虽但说二种性。一有种性。二无种性。亦云无种性人。无种性故。虽复勤行精进。终不能得无上菩提。但以人天善根。而成熟之无性。瑜伽亦同此说。若法性宗意。则以三乘是权。一乘为实。法华经云。十方佛土中。唯有一乘法。无二亦无三。除佛方便说。又云。初以三乘引导众生。然后但以大乘而度脱之。以性唯一故。故云诸佛两足尊知法常无性。又第三云。一相一味究竟涅槃常寂灭相。涅槃亦云。佛性者名为一乘。师子吼者名决定说。决定宣说一切众生皆有佛性。凡是有心定当作佛。三十三又云。一切众生同有佛性。皆同一乘一解脱一因一果同一甘露。一切当得常乐我净。是名一味。又法华第三云。我灭度后复有弟子。不闻是经。不知不觉菩萨所行。自于所得功德生灭度想。当入涅槃。我于余国作佛。更有异名。是人虽生灭度之想。入于涅槃。而于彼土求佛智慧。得闻是经。唯以佛乘而得灭度等。智论九十五亦同此说。明知。趣寂决定回心。法华论中四声闻内决定及增上慢。此二根未熟故。菩萨与记方便令发心。既云未熟。明必当熟。方便令发。即菩提心。不可不顺己宗。判为论错。入楞伽第二第四第七。皆同说二乘无实涅槃。但是三昧力故。后必当得无上菩提。法华论中。意亦同此。皆是假说涅槃。故云三昧。胜鬘亦云。言诸二乘得涅槃者。是佛方便。又无上依经宝性佛性二论皆说。入灭二乘。于三界外。更受变易。密严经中。二乘毕无灰断永灭。如是经论。其文非一。永寂声闻。必无明矣。涅槃第九菩萨品中。广明阐提断善不能发心。当文即云。彼一阐提虽有佛性。而为无量罪垢所缠。不能得出。如蚕处茧。此则有而非无。又云。或有佛性一阐提有。善根人无等。则知无有无种性人。况前引楞伽五性自迷其文。彼经第五性云。五者无性。谓一阐提。此有二种。一者焚烧一切善根。即谤菩萨藏。二者怜愍一切众生界。即是菩萨。若有众生不入涅槃。我亦不入。大慧白言。此二何者常不入涅槃。佛言。菩萨常不入涅槃。非焚烧一切善根者。以知诸法本来涅槃。不舍一切诸众生故。此意则明菩萨入而不入。既云菩萨常不入。非阐提者。则明阐提后必入矣。况经自云复以如来神力故。或时善根生耶。庄严第五。无性亦有二种。一是时边。二者毕竟时边。谓暂时之无即前阐提。毕竟谓永无。即大悲菩萨。是知前来所引大般若深密等经皆是未说法华之前。就其长时云定性无性非永定永无。诸论随佛方便成立故。云定无耳。故宝性佛性等论皆说。以一阐提谤大乘因。依无量时说无佛性。非谓究竟无清净性。若谓法华是第二时教。为引不定二乘故。说一切悉皆成佛。而犹未说定性不成。故名密意。非了义者。何以自判法华为第三时教。谁敢判于法华。为不了耶。妙智经中。及梁摄论成立正法中。皆以一乘居三乘后。故真谛三藏部异执记云。三十八年后。说解节经等。无量义云。四十年后。说法华经。明知法华居后。故经云临欲终时。若不信法华居后涅槃临终。居然可信。岂不亦以一乘一性破三五耶。若以般若。为第二时。法华为第三时。于理即通。复自违深密第三时中。普为发趣一切乘者。以法华破三故。明知深密三时。不能定断一切圣教。以未居最后故。且约显一类义。故分三耳。义如前说。若将法华。望之应有四时。以一乘教。破前三乘故。若谓佛性有二。一者理性。二者行性理性定有。行性或无。斯言可尔。故涅槃云。或有佛性善根人有阐提人无。即是行性。或有佛性二人俱有。即是理性。然涅槃依于理性明其等有。故云凡是有心定当作佛。不言凡是有行定当作佛。若谓理性定有。容趣寂不成。则违教理。是知阐提不作佛者。以作佛非阐提故。乃抑扬当时耳。若谓法华入灭后信一乘。即是变化权声闻者。权必化实。无实化谁。又岂不误于一类怯弱。好灭众生。是知趣寂。皆是法华前意耳。又胜鬘经云。若如来随彼所欲。而方便说。即是一乘。无有二乘。二乘入于一乘。一乘者即第一义乘。此意明随欲方便而说二乘。明知即是一乘。无有二矣。不晓此意。将上方便。连下一乘而读之。辄断一乘。以为方便。惑之甚矣。又彼经中。广破二乘。云无涅槃。又云。此经断一切疑。决定了义入一乘道。岂说一乘。以为方便。设有方便之言。尚在法华之前。况复无耶。法华云。此经难信难解。佛现在世。犹多怨嫉。况灭度后。诚哉斯言。若信执三乘五性。不信一乘一性者。深为可愍。故百喻经第二中。王改聚落。五由旬为三由旬喻。以喻方便于一说三。后人但信于三不信于一。即其事也。上约二宗各别所据。则互相违。反若会释者。亦不相违。谓就机则三。约法则一。新熏则五。本有无二。若入理双拂。则三一两亡。若约佛化仪。则能三能一。是故竞执。是非。达无违诤。大集五部。虽异不离法界。涅槃各说身因。佛许无非正说。余义次下当会古今违顺竟。第三立教开宗。分二。一以义分教。二依教分宗。今初以义分教。教类有五。即贤首所立。广有别章。大同天台。但加顿教。今先用之。后总会通。有不安者颇为改易。言五教者。一小乘教。二大乘始教。三终教。四顿教。五圆教。初即天台藏教。二始教者。亦名分教。以深密第二第三时教。同许定性二乘俱不成佛。故今合之总为一教。此既未尽大乘法理。故立为初。有不成佛。故名为分。三终教者。亦名实教。定性二乘。无性阐提。悉当成佛。方尽大乘至极之说。故立为终。以称实理。故名为实。上二教并依地位渐次修成。故总名为渐。四顿教者。但一念不生。即名为佛。不依地位渐次。而说故立为顿。如思益云。得诸法正性者。不从一地。至于一地。楞伽云。初地即为八。乃至无所有何次等。不同前渐次位修行。不同于后圆融具德。故立名顿。顿诠此理。故名顿教。天台所以不立者。以四教中皆有一绝言故。今乃开者。顿显绝言。别为一类。离念机故。即顺禅宗。五圆教者。明一位即一切位。一切位即一位。是故十信满心。即摄五位成正觉等。依普贤法界帝网重重主伴具足。故名圆教。如此经等说。若约所说法相者。初小乘中。但说七十五法。但说人空。纵少说法空。亦不明显。但依六识三毒。建立染净根本。故阿含云。贪恚愚痴是世间根本等。未尽法源。故多诤论。部执不同。二始教中。广说法相。少说法性。所说法性。即法相数。说有百法决择分明。故少诤论。说有八识。唯是生灭。依生灭识。建立生死及涅槃因。法尔种子。有无永别。是故五性决定不同。既所立识。唯业惑生故。所立真如。常恒不变。不许随缘。依他起性。似有不无。非即无性真空圆成。说经空义。但约所执。既言三性五性不同故。说一分众生决不成佛。名生界不减。真俗二谛。迢然不同。非断非常。果生因灭。同时四相。灭表后无。根本后得。缘境断惑。义说双观决定别照。以有为智。证无为理。义说不异而实非一。既出世智。依生灭识种故。四智心品。为相所迁。佛果报身。有为无漏。如是义类。广有众多。具如瑜伽杂集等说。三终教中。少说法相。多说法性。所说法相。亦会归性。所立八识。通如来藏。随缘成立。不生灭与生灭和合。而成非一非异。一切众生。平等一性。但是真如。随缘成立。依他无性。即是圆成。一理齐平。故说生界佛界不增不减。第一义空。该通真妄。真非俗外。即俗而真故。虽空不断。虽有不常。四相同时。体性即灭。缘境断惑。不二而二。有能所断。二而不二。说为内证。照惑无本。即是智体。照体无自。即是证如。非智外如。为智所证。非如外智。能证于如。世出世智。依如来藏。始本不二。则有为无为非一非异。故佛化身即常即法。不堕诸数。况于报体。即体之智。非相所迁。如是义类。亦有众多。次第对上。如楞伽等经起信等论。若会上二宗。广如别说。四顿教中。总不说法相。唯辩真性。亦无八识差别之相。一切所有。唯是妄想。一切法界。唯是绝言。五法三自性俱空。八识二无我双遣。诃教劝离。毁相泯心。生心即妄。不生即佛。亦无佛无不佛。无生无不生。如净名默住显不二等。是其意也。五圆教中。所说唯是无尽法界。性海圆融。缘起无碍。相即相入。如因陀罗网重重无际。微细相容。主伴无尽。十十法门。各摄法界。义分齐中。当具宣说。二依教开宗。宗乃有十。如经宗中辩。第四总相会通。曲分为二。先通会诸教。后会化仪前后。今初。诸德立教。各自所据。今虽立五。亦会取诸说。略有五重。一或总为一。谓唯是如来一大善巧。摄生方便。一音所演。则前之二师立一音者。不失道理。二或开为二。此更有三。一对小显大。初是半字。后四皆满。则无违二藏等言。二对权显实。前则二是三乘。后三为一乘。则不违法华四乘。三者三四二教。虽则泯二异前。而对三显一。曲巧顺机。后一直显本法。一向不共。如智论说。此同印公平道屈曲。三或分为三。初一小乘。次一三乘。后三一乘。或唯后一是不共一乘。智论指此以为不共。大品等经。共二乘说故。此三亦顺四乘。又梁论第八云。如来成立正法有三种。一立小乘。二立三乘。三立一乘。第三最胜故。名善成立。此亦同妙智经。真谛三藏部异执疏第二卷中。亦同此说。四或分为四。此亦二门。一中间三教。存三泯二别。故开之为四。一别教小乘。如四阿含等。二同教三乘。如深密等。三同教一乘。如法华等。四别教一乘。如华严经。二约历位。无位开渐及顿。故分为四。总合二三。以为渐教。余皆如名。五或分为五。如前所立。以渐中有始终故。然取多分。略指数经。实非局判。以一经中容多教故。第二化仪前后者。今辩如来一代时教。略启十门。一本末差别门。二依本起末门。三摄末归本门。四本末无碍门。五随机不定门。六显密同时门。七一时顿演门。八寂寞无言门。九该通三际门。十重重无尽门。初中本末同时始终一类。各无异说。然有三位。一若小乘中。则初度陈如。后度须跋。中间亦唯说小益小。如四阿含经及五部律。二若约三乘。则始终说三通益三机。如密迹经等。三若约一乘。则始终唯为圆机说于圆极。如华严等。其中不通小乘。复摄九世该于前后。更无异说。然此三类。依于此世根性定者。常闻如上一类之法。故佛所演各通始终。更无前后。二依本起末门。此有五类。谓初为菩萨说大。二为缘觉。三为声闻。四为善根众生。五为邪定。如出现品。日照高山及三千。初成喻中广辩其相。皆明先大后小。约法名从本起末。以于一佛乘分别说三故。十八本二皆大乘出故。约机各是一类之机。非约一机前后大小。三摄末归本门者。依无量义初时说小。次说中乘。后时说大。故法华亦云。初转四谛深密妙智虽复二时三一不同。皆先小后大。四本末无碍门者。谓初举照山王之极说。明非本无以垂末。后显归大海之异流。明非末无以归本。故本末交映与夺相资。方为摄生之善巧矣。是故通论总有五位。一根本一乘。如华严经。二密意小乘。三密意大乘。四显了三乘。上三如深密。五破异一乘。如法华。上之四门圆通无碍。是则前后即无前后。无前后之前后耳。五随机不定门者。此上四门。初门明三类机始末常定。次门明五类机异时常定。第三门明一类机自浅之深。第四门明二类机。初机闻顿后机从浅至深。更有一类不定之机。或从小乘次入三乘。后入一乘。亦有从小直入一乘。或多类机随闻一句。异解不同。六显密同时者。若异闻互知是显不定。若互不相知即是秘密密显同时亦无前后。七上来诸门。一时顿演。八从初得道乃至涅槃。不说一句。九此上诸门尽通三际。十上之九门。随处随时重重无尽。皆无前后。后之二门。正是华严境界。融取前八。亦不离华严之用。第三义理分齐。已知此经总属圆教。未知圆义分齐云何。然此教海宏深包含无外。色空交映德用重重。语其横收全收五教。乃至人天总无不包。方显深广。其犹百川不摄大海。大海必摄百川。虽摄百川同一碱味。故随一适迥异百川。前之四教不摄于圆。圆必摄四。虽摄于四圆以贯之。故十善五戒亦圆教摄。上非三四。况初二耶。斯则有其所通无其所局。故此圆教语广名无量乘。语深唯显一乘。一乘有二。一同教一乘。同顿同实故。二别教一乘。唯圆融具德故。以别该同皆圆教摄。今显别教一乘。略显四门。一明所依体事。二摄归真实。三彰其无碍。四周遍含容。各有十门。以显无尽。初中十者。一教义。二理事。三境智。四行位。五因果。六依正。七体用。八人法。九逆顺。十应感。教即能诠。即前五教。乃至光香等。义即所诠。即五教等一切义理。理即生空所显。二空所显无性真如等理。事即色心身。方等事。余可思准。第二摄归真实者。即真空绝相。经云。法性本空寂。无取亦无见。性空即是佛。不可得思量。亦有十义。如法界观。第三彰其无碍。然上十对皆悉无碍。今且约事理以显无碍。亦有十门。一理遍于事门。谓无分限之理。全遍分限事中。故一一纤尘理皆圆足。二事遍于理门。谓有分之事。全同无分之理。故一小尘即遍法界。由上二义互该彻故。皆同一性。故出现品云。如来成正觉时。于其身中。普见一切众生成正觉。乃至普见一切众生入涅槃。皆同一性。所谓无性。理遍事故。一成一切成。事遍同理。故说都无所成。经云。譬如虚空无成无坏。一性无性。即是佛性。故涅槃云。佛性名第一义空。第一义空名为智慧。又出现云。无一众生不具如来智慧。无不有者。即一乘义也。三依理成事门。谓事无别体要因理成。如揽水成波故。于中有二。一明具分唯识变故。觉林菩萨偈云。心如工画师能画诸世间。五阴悉从生。无法而不造。此明唯心义也。何以得知是具分耶。次颂云。如心佛亦尔。如佛众生然。应知佛与心。体性皆无尽。既是即佛之心。明非独妄心而已。二明真如随缘成故。问明品文殊难云。心性是一。云何见有种种差别。即缘性相违难。觉首答云。法性本无生。示现而有生。即真如随缘答。又云。诸法无作用。亦无有体性。明随缘不失自性。即同胜鬘。依如来藏有生死。依如来藏有涅槃等。四事能显理门。谓由事揽理成故。事虚而理实。依他无性即是圆成。如波相虚令水现故。夜摩偈云。云何说诸蕴。诸蕴有何性。蕴性不可灭。是故说无生。分别此诸蕴。其性本空寂。空故不可灭。此是无生义。众生既如是。诸佛亦复然。佛及诸佛法。自性无所有。又十忍品云。譬如谷响从缘所起。而与法性无有相违。须弥顶偈云。了知一切法。自性无所有。如是等文遍于九会。五以理夺事门。谓事既全理则事尽无遗。如水夺波波相全尽。故说生佛不增不减。出现品云。譬如虚空。一切世界若成若坏。常无增减。何以故。虚空无生故。诸佛菩提亦复如是。若成正觉不成正觉。亦无增减。何以故。菩提无相故。乃至云。设一切众生。于一念中悉成正觉。与不成正觉等无有异。皆以无相平等故。不增不减经亦同此说。非约一分众生不成佛者。说无增减耳。六事能隐理门。谓真理随缘而成事法遂令事显理不现也。如水成波动显静隐故。法身流转五道。名曰众生。财首偈云。世间所言说一切是分别。未曾有一法得入于法性等。七真理即事门。谓凡是真理。必非事外。以是法无我理故。空即色故理即是事。方为真理。第七回向云。法性不违法相等故。八事法即理门。谓缘集必无自性。举体即真故。上之二门。正明二谛不相违义。如湿不违波波不违湿。举体相即故。夜摩偈云。如金与金色其性无差别。法非法亦然。体性无有异。此亦喻于如来之藏与阿赖耶。展转无别。又由事即理故。虽有不常理即事故。虽空不断。又由事理相即故。起灭同时。须弥偈云。一切凡夫行。莫不速归尽。其性如虚空故。说无有尽。智者说无尽。此亦无所说。自性无尽故。得有难思尽等。则同时四相不待后无。亦令究竟断证离于能所。十地品云。非初非中后。非言辞所及。回向品云。无有智外如为智所入。亦无如外智。能证于如等。九真理非事门。即妄之真异于妄故。如湿非动。十事法非理门。即真之妄异于真故。如动非湿故。惭愧林偈云。如色与非色。此二不为一。又云。如相与无相。生死又涅槃。分别各不同等。上七八二门。明事理非异。九十二门明事理非一。故为无为。非一非异。第四回向云。于有为界示无为法。而不灭坏有为之相。于无为界示有为法。而不分别无为之性。上之十事。同一缘起故。云无碍。约理望事。则有成有坏有即有离。事望于理。有隐有显。有一有异。逆顺自在。无障无碍。同时顿起。深思令观明现。以成理事圆融无碍观也。第四周遍含容。即事事无碍。且依古德。显十玄门。于中文二。先正辩玄门。二明其所以。今初。一同时具足相应门。二广陜自在无碍门。三一多相容不同门。四诸法相即自在门。五秘密隐显俱成门。六微细相容安立门。七因陀罗网境界门。八托事显法生解门。九十世隔法异成门。十主伴圆明具德门。此之十门同一缘起无碍圆融。随其一门。即具一切。今且于前十中。取一事法明具后十门。如下文中。一莲华叶或一微尘。则具教等十对。同时相应具足圆满。亦具后之九门。及彼门中所具教等以是总故。故下文云。一切法门无尽海。同会一法道场中。华藏颂云。华藏世界所有尘。一一尘中见法界。一尘尚具况一叶耶。二即彼华叶普周法界。而不坏本位以分即无分无分即分。广陜自在无障无碍。十定品云。有一莲华尽十方际。而不妨外有可见。是故或唯广无际。或分限历然。或即广即陜。或广陜俱泯。或具前四。以是解境故。或绝前五。以是行境故。下皆准此。然此广陜亦名纯杂。普周法界故。纯一无二不坏本位。则不妨于杂。万行例然。三即此华叶舒已遍入一切法中。即摄一切。令入己内。舒摄同时。既无障碍。是故镕融。或有四句六句思之。下云。以一佛土满十方。十方入一亦无余。若一与一切对辩。则摄入各具四句。谓一入一切一切入一。一入一一切入一切。互摄亦然。四此一华叶废己同他。举体全是彼一切法。而恒摄他同己。令彼一切即是己体。一多相即混无障碍。解行境别。六句同前。下云知一即多多即一等。五华能摄彼则一显多隐。一切摄华则一隐多显。显显不俱。隐隐不并。隐显显隐同时无碍。全摄俱泯。存亡俱成。句数同前。下云。东方入正受。西方从定起等。如八日月隐显同时。六此华叶中微细刹等。一切诸法炳然齐现。下云。于一尘中一切国土旷然安住。又于一毛端处。有不可说诸如来。及第九回向微细中说。七此华叶一一微尘中。各现无边刹海。刹海之中。复有微尘。彼诸尘内。复有刹海。如是重重不可穷尽。非是心识思量境界。如天帝殿珠网覆上。一明珠内万像俱现。珠珠皆尔。此珠明彻互相现影影复现影。而无穷尽。下云。如因陀罗网世界等。亦如镜灯重重交光。佛佛无尽。八见此华叶。即是见于无尽法界。非是托此别有所表。下文云。此华盖等从无生法忍之所起等。九即此一华。既其遍一切处。亦复该一切时。谓三世各三。摄为一念故。为十世。以时无别体。依华以立华既无碍。时亦如之。是故晋经云。过去无量劫。安置未来今未来无量劫。回置过去世等。普贤行云。过去中未来。未来中现在等。又云。无量劫即一念。一念即无量劫等。时无别体故不别立。以为所依。十此圆教。法理无孤起。必摄眷属随生。下云。此华即有十世界微尘数华以为眷属。又如一方为主十方为伴。余方亦尔。是故主主伴伴各不相见。主伴伴主圆明具德。举华既尔。一尘等事亦然。如此事华既带同时等十义。具此十门。而此事等具余教等十门。则为百门。事法既尔。余教义等具百亦然。则为千门。如教义等有此千门。彼同时门中。亦具百门。余广陜等例尔。亦有千门。若重重取之。亦至无尽。于此十门。圆明显了。则常入法界重重之境。第二明德用所因。问有何因缘。令此诸法得有如是混融无碍。答因广难陈。略提十类。一唯心所现故。二法无定性故。三缘起相由故。四法性融通故。五如幻梦故。六如影像故。七因无限故。八佛证穷故。九深定用故。十神通解脱故。十中随一即能令彼诸法混融无碍。十中前六通约法性为德相。因法尔如是。后二皆是业用。义通因果。七约起修。义通德相业用。八约果德。唯是德相故。前之十门。通德相业用。约佛则用亦德相。德上用故。约机则相亦称用。令知相故。即用之相。染净双融。即相之用。能染能净。故相及用。不分两别。初唯心现者。一切诸法。真心所现。如大海水举体成波。以一切法无非一心故。大小等相。随心回转。即入无碍。二法无定性者。既唯心现从缘而生。无有定性。性相俱离。小非定小故。能容太虚而有余。以同大之无外故。大非定大故。能入小尘而无间。以同小之无内故。是则等太虚之微尘。含如尘之广刹。有何难哉。旧经十住品云。金刚围山数无量。悉能安置一毛端。欲知至大有小相。菩萨以是初发心。一非定一故。能是一切。多非定多故。能是一。边非定边故。能即中。中非定中故。能即边。延促静乱等。一一皆然。三缘起相由者。谓大法界中。缘起法海义门无量。约就圆宗。略举十门。以释前义。谓缘起法要具此十义。缘方起故。阙则不成。一诸缘各异义。谓大缘起中诸缘相望。要须体用各别。不相杂乱。方成缘起。若杂乱者。失本缘法。缘起不成。此则诸缘各各守自一位。文云。多中无一性。一亦无有多。二互遍相资义。谓此诸缘要互相遍应方成缘起。如一缘遍应多缘。各与彼多全为一故。此一则具多个一也。若此一缘。不具多一。则资应不遍不成缘起。此则一一各具一切。下文云。知以一故众知以众故一。三俱存无碍义。谓凡是一缘。要具前二。方成缘起。以要住自一。方能遍应。遍应多缘。方是一故。是故唯一。多一自在。无碍镕融。有其六句。一或举体全住。是唯一也。或举体遍应。是多一也。或俱存。或双泯。或总合。或全离。皆思之可见。文云。诸法无所依。但从和合起。此上三门。总明缘起本法竟。四异体相入义。谓诸门力用递相依持。互形夺故。各全有力全无力义。缘起方成。如论云。因不生缘生故。缘不生自因生故。若各唯有力无无力。则有多果过。一一各生故。若各唯无力无有力。则有无果过。以同非缘俱不生故。是故缘起要互相依具力无力。如阙一缘一切不成。余亦如是。是故一能持多。一是有力能持于多。多依于一。多是无力。潜入一内。由一有力必不与多有力俱。是故无有一而不摄多也。由多无力必不与一无力俱。是故无有多而不入一也。如一持多依既尔。多持一依亦然。反上思之。如一望多有依有持。全力无力常含多在己中。潜入己在多中。同时无碍。多望于一。当知亦尔。俱存双泯。二句无碍思之。五异体相即义。谓诸缘相望全体形夺。有有体无体义缘起方成。若阙一缘。余不成起故。缘义则坏。得此一缘。令一切成起。所起成故。缘义方立。是故一缘。是能起能成故有体。多缘是所起所成故无体。由一有体不得与多有体俱。多无体必不得与一无体俱。是故无有不多之一。无有不一之多。一多既尔。多一亦然。反上思之。如一望多有有体无体故。能摄他同己。废己同他。同时无碍。多望于一当知亦尔。准前思之。俱存双泯二句无碍。亦思之可见。六体用双融义。谓诸缘法。要力用交涉。全体融合。方成缘起。是故圆通亦有六句。一以体无不用故。举体全用则唯有相入。无相即义。二以用无不体故。举用全体则唯有相即。无相入也。三归体之用不碍用。全用之体不失体。是则无碍双存。亦入亦即自在俱现。四全用之体。体泯。全体之用。用亡。非即非入圆融一味。五合前四句。同一缘起无碍俱存。六泯前五句。绝待离言冥同性海。此上三门。于初异体门中显义理竟。七同体相入义。谓前一缘所有多一与彼一缘体无别故。名为同体。又由此一缘应多缘故。有此多一。所应多缘既相即入。令此多一亦有即入也。先明相入。谓一缘有力能持多一。多一无力依彼一缘。是故一能摄多多便入一。一入多摄反上应知。余义余句准前思之。八同体相即义。谓前一缘所具多一。亦有有体无体之义。故亦相即。以多一无体。由本一成多即一也。由本一有体能作多一。令一摄多。如一有多空既尔。多有一空亦然。余义余句。并准前思之。九俱融无碍义。谓亦同前体用双融。即入自在。亦有六句准前应知。此上三门。于前第二同体门中辩义理竟。十同异圆满义。谓以前九门总合为一大缘起。令多种义门同时具足也。由住一遍应故。有广陜自在门。由就体就用故。有相即相入门。由异体相容具微细门。异体相即具隐显门。又就用相入为显。令就体相即为隐。即显入隐亦然。又由异门即入为显。令同体即入为隐。同显异隐亦然。又由异体相入。带同体相入具帝网门。由此大缘起即无碍法界故。有托事显法门。显于时中故。有十世门相关互摄故。有主伴门。此第十圆满一门。就前第三门中。以辩义理。故下文云。菩萨善观缘起法。于一法中解众多。众多法中解了一。又云。一中解无量。无量中解一。了彼互生起。当成无所畏等。皆其义也。上来缘起相由门竟。第四法性融通门者。谓若唯约事则互相碍不可即入。若唯约理则唯一味。无可即入。今则理事融通具斯无碍。谓不异理之一事。具摄理时。令彼不异理之多事。随所依理皆于一中现。若一中摄理不尽。则真理有分限失。若一中摄理尽。多事不随理现。则事在理外失。今既一事之中全摄理尽。多事岂不依中现。华藏品云。华藏世界所有尘。一一尘中见法界。法界即事法界矣。斯即总意。别亦具十玄门。一既真理。与一切法而共相应。摄理无遗。即是诸门诸法同时具足。二事既如理能包。亦如理广遍。而不坏陜相故。有广陜纯杂无碍门。又性常平等故纯。普摄诸法故杂。三理既遍在一切多事故。令一事随理遍一切中。遍理全在一事则一切随理。在一事中故。有一多相容门。四真理既不离诸法。则一事即是真理真理即是一切事故。是故此一即彼一切事。一切即一。反上可知故。有相即自在门。五由真理在事各全非分故。正在此时彼说为隐。正在彼时此即为隐故。有隐显门。六真理既普。摄诸法。带彼能依之事。顿在一中故。有微细门。七此全摄理故。能现一切。彼全摄理同此顿现。此现彼时。彼能现所现俱现此中。彼现此时。此能现所现亦现彼中。如是重重无尽故。有帝网门。以真如毕竟无尽故。八即事同理故。随举一事即真法门。故有托事门。九以真如遍在昼夜日月年劫皆全在故。在日之时不异在劫故。有十世异成门。况时因法有。法融时不融耶。十此事即理时不碍与余一切恒相应故。有主伴门。故一理融通十门具矣。五如幻梦者。犹如幻师。能幻一物以为种种幻。种种物以为一物等。经云。或现须臾作百年等。一切诸法。业幻所作故。一异无碍。言如梦者。如梦中所见广大。未移枕上历时久远未经斯须。故论云。处梦谓经年。觉乃须臾顷。故时虽无量摄在一刹那。六如影像者。一切万法。略有二义。一皆如明镜含明。了性一心所成故。二分别所现如影像故。由初义故为能现。由后义故为所现。故一切法互为镜像。如镜互照。而不坏本相。下经云。远物近物。虽皆影现。影不随物。而有远近等。七因无限者。谓诸佛菩萨昔在因中。常修缘起无性等观。大愿回向等。称法界修。及余无量殊胜因故。今如所起果具斯无碍。八佛证穷者。由冥真性得如性用。故经云。无比功德故能尔。九深定用者。谓海印定等诸三昧力故。贤首品云。入微尘数诸三昧。一一出生尘等定。而彼微尘亦不增等。十神通解脱者。谓由十通及不思议等解脱故。不思议法品十种解脱中云。于一尘中建立三世一切佛法等。由上十因。令前教义等十对。具上同时等十门。以为别教一乘义之分齐

大方广佛华严经疏卷第二大方广佛华严经疏卷第三

        唐清凉山大华严寺沙门澄观撰

第四教所被机者。夫教因机显离机无言。上说义理弘深。未委被何根器。若明能应者十身圆音。今直彰所被。通有十类。前五拣非器。后五彰所为。前中一无信非器。以闻生诽谤堕恶道故。二违真非器。依傍此经以求名利。不净说法集邪善故。下经云。忘失菩提心修诸善根。是为魔业。三乖实非器。谓如言取文超情至理不入心故。论云。随声取义有五过失。上三皆是凡愚。故下文云。此经不入余众生手。四陜劣非器。谓一切二乘。出现品云。一切二乘不闻此经。何况受持。故虽在座如聋如瞽。五守权非器。谓三乘共教诸菩萨等。随宗所修行布行位。不信圆融具德之法故。下经云。设有菩萨无量亿那由他劫行六波罗蜜。不闻此经。或时闻已。不信不解不顺不入。不得名为真实菩萨故。后五显所为中一正为。谓是一乘圆机故。出现品云。此经不为余众生说。即通指前五。唯为乘不思议乘菩萨说。即正为之机。谓一运一切运。圆融行位即深不思议。又能遍达诸教。即广不思议故。文云。非余境界之所知。普贤行人方得入等。二兼为。谓即时虽未悟入。而能信向成种。如出现品食金刚喻故。地狱天子十地顿超。大海劫火不能为障。约未悟入故名为兼。三引为。即前权教菩萨。不受圆融之法故。十地之中寄位显胜。借其三乘行布之名。彼谓同于我法。后因熏习方信入圆融。以离此普法无所归故。权教极果无实事故。四者权为。即是二乘。谓既不闻。况于受持。故诸菩萨权示声闻。或在法会。而聋盲彰其绝分。或示在道而启悟知可回心。五远为谓诸凡夫外道阐提悉有佛性。今虽不信后必当入故。出现品云。如来智慧大药王树。唯除二处。不能为作生长利益。所谓二乘堕无为坑。及坏善根。非器众生溺大邪见贪爱之水。然亦于彼曾无厌舍。前三非器。是溺邪见。第四非器。是堕深坑故皆拣之。今四及五明佛无厌舍故。示而诱之熏其成种。又彼品中。明不信毁谤亦种善根。谓谤虽堕恶道。由闻历耳终醒悟故。又云。如日亦与生盲作利益故。又如大海潜流喻中明。无不具有如来智慧故。又破尘出经卷喻中。若除妄想皆见佛智故。此皆明有自性住性。即是所为。况法性圆融感应交彻。无有一法而非所被。第五教体浅深者。无尽教海体性难思。从浅至深略明十体。一音声言语体。二名句文身体。三通取四法体。上三皆能诠体。四通摄所诠体。五诸法显义体。六摄境唯心体。七会缘入实体。八理事无碍体。九事事无碍体。十海印炳现体。十中前五唯体。后五亦体亦性。又前四通小。后六唯大。前七通三乘。后三唯一乘。前八约同教。后二唯别教。就前三中。大小乘中通用四法。一声。二名。三句。四文。取舍不同。各有三说。小乘三者。婆沙一百二十六云。如是佛教以何为体。一云。应作是说语业为体。谓佛语言。唱辞评论。语音。语路。语业。语表是。谓佛教。其名句文。但显佛教作用。不欲开示佛教自体。发智论中亦同此说。二云。名等为体。谓名身句身文身。次第行列次第安布。次第连合故。声但依于展转因故。谓语起名。名能显义。评家意取语业为体。杂心论同俱舍。俱舍论云。牟尼说法蕴数有八十千。彼体语或名。此色行蕴摄。谓若语为教体即色蕴摄。名为教体。即行蕴摄。此乃双存前二。情无去取。故致或言。正理论中意符名等故。彼第三释前颂竟。又云。诠义如实故名佛教。名能诠义故教是名。由是佛教定名为体。举名为首。以摄句文。显宗第三亦同此说。三者然俱舍意。情无去取。若取其双存。即合四法以为教体。若经部意亦唯取声。故正理十四破彼师云。汝不应立名句文身。即声为体。大乘有三。大意同前。一云。摄假从实以声为体。离声无别名句等故。深密第五云。如来言音略有三种。一契经等。既云言音有三。明以声为教体。杂集论云。成所引声谓诸圣所说。二云以体从用名等为体。能诠诸法自性差别。二所依故。故无性论破经部云。诸契经句语为自性。不应理故。成唯识第二。亦破彼云。若名句文不异声者。法辞无碍境应无别。唯识云。此三离声虽无别体。而假实异。亦不即声。三云。声名句文合为其体。由前二说皆有理教。为定量故。深密第四云。不可舍于言说文字。而能宣说故。净名云。有以音声言语文字。而作佛事故。十地论云。说者以二事说。听者以二事闻。谓善声善字故。以余之意亦应双取。若就前二有去取者。宁依名等。良以音声一种。正就佛说容为教体。流传后代书之竹帛。曾何有声。岂无教体。书虽是色亦与名等为所依故。亦色蕴摄。前净名十地通取四者。但言所用非正显体。仁王云。是名句味诸佛所说故。然大小诸宗。虽通用四法而理不同。谓萨婆多宗四法皆有实体。经部声有实体。名等是假。若大乘中。或有四皆非实。或有四皆如空。俱不立故。净名云。文字性离。无有文字是则解脱。十地论释空中风相等云。风喻音声。画喻名字。皆不可取。佛藏经云。诸法如毫厘不空者。则诸佛不出世。又下云诸法毕竟空。无有毫末相。有说四皆事理无碍。或说四皆圆融故。宗不同也。第四通摄所诠体者。瑜伽八十一云。谓契经体略有二种。一文。二义。文是所依。义是能依。如是二种总名一切所知境界。即依于六文显于十义。此明教义相成。若不诠义教文何用。故通取所诠成契经体。又十住品云。文随于义义随于文。文义相随理无舛谬。方为真教。又瑜伽云。佛菩萨等是能说者。语是能说相。名句文身是所说相。故皆通取。不同前义克取所说。第五诸法显义体者。谓但能显义理。一切诸法皆为教体。净名第三云。有以光明而作佛事。有以诸菩萨而作佛事。有以佛所化人而作佛事。有以佛菩提树衣服卧具。乃至八万四千诸烦恼门。众生为之疲劳。诸佛即以此法而作佛事。又十卷楞伽第四云。大慧非一切佛土言语说法故。有佛国土。直视不瞬。口无言说名为说法。乃至云。有佛国土动身名说。又香积世界餐香饭而三昧显。极乐佛国听风柯而正念成。丝竹可以传心。目击以之存道。既语默视瞬皆说。则见闻觉知尽听。苟能得法契神。何必要因言说。况华严性海云台宝网。同演妙音。毛孔光明皆能说法。华香云树即法界之法门。刹土众生本十身之正体。于何非教耶。下云刹说众生说。三世一切说。又云。一切世间诸境界。皆悉能令转法轮等。其文非一。第六摄境唯心体者。总收前五并不离识。唯识等云。一切所有唯心现故。起信亦云。依一心法有二种门。一心真如门。二心生灭门。然此二门。皆各总摄一切法。以此二门不相离故。梵行品云。知一切法即心自性故。唯心现。然有二门。一本影相对。二说听全收。前中通就诸教以成四句。一唯本无影。谓即小乘不知唯识故。二亦本亦影。谓大乘初教。谓佛自宣说。若文若义。皆是如来妙观察智相应净识之所显现。名本质教故。佛地论第一云。有义。闻者善根本愿增上缘力。如来识上文义相生。此文义相。是佛利他善根所起。名为佛说。若闻者识上所变文义。名为影像。佛地论云。如来慈悲本愿增上缘力。闻者识上文义相生。此文义相。虽亲依自善根力起。而就强缘名为佛说故。二十唯识论云。展转增上力二识成决定。护法论师等。皆立此义。然云文义相生。复说五心集现。谓如说诸行无常即有四声四字四名。一句及所诠义。此十四相。于闻者识上聚集显现。然西方多释。今略举其一。谓如说诸字。有率尔寻求二心。然未定知诸字所属。无决定心。次说行字。由先熏习连带解生。有三心起。谓率尔寻求决定。以决定知诸字所属一切行故。闻诸行字。虽知自性然未知义。为令知义复说无字。但有二心。谓率尔寻求。未有决定。以未定知无字所属。后说常字。由前字力展转熏习。连后字生具起五心。谓率尔寻求决定染净等流。于最后时。四字周圆方能解义。总十二心。初二。次三。次二。后五。故有十四相。义如前说。余如别章。三唯影无本。谓大乘实教。离众生心佛果无有色声功德。唯有如如及如如智。独存。大悲大智为增上缘。令彼所化根熟。众生心中现佛色声说法。是故圣教。唯是众生心中影像。夜摩偈云。诸佛无有法。佛于何有说。但随其自心。谓说如是法。龙军坚慧诸论师等。并立此义。四非本非影。如顿教说。非直心外无佛色声。众生心内影像亦空。性本离故。亡言绝虑即无教之教耳。须弥偈云。法性本空寂。无取亦无见。性空即是佛不可得思量。净名云。其说法者。无说无示。其听法者无闻无得。龙树等宗多立此义。此前四说总合为一。圆融无碍。自浅之深摄众生故。第二说听全收成二四句。一约同教以成四句。谓一佛真心外无别众生。以众生真心即佛真心故。则唯说无听故。所说教唯佛所现。二众生心外更无别佛。以佛真心即众生真心故。则唯听无说故。所说教即众生自现。梵行品云。知一切法即心自性等。三佛真心现时。不碍众生真心现故。说听双存。二教齐立。四佛即众生故非佛。众生即佛故非众生。互夺双亡则说听斯寂。故净名云。其说法者无说无示。其听法者无闻无得。二约别教以明四句。谓由不坏相生佛互在故。一众生全在佛中故。则果门摄法无遗。生尚在佛心中。况所说教不唯佛现故。出现品云。如来成正觉时。于其身中普见一切众生成正觉。乃至普见一切众生入涅槃。又佛性论第二如来藏品云。一切众生悉在如来智内。故名为藏。以如如智称如如境故。一切众生决定无有出如如境者。并为如来之所摄持。故名为藏众生为如来藏。又下出现品中明。三世劫刹众生所有心念根欲。尚皆一身顿现。况佛智广大如虚空耶。二佛在众生心中故。则因门摄法无遗。佛尚在于心中。况所说教非众生心现。故出现品云。菩萨摩诃萨应知。自心念念常有佛成正觉。何以故。诸佛如来不离此心成正觉故。如自心一切众生心亦复如是。悉有佛成正觉。此明佛证众生心中真如成佛故。本觉无异。以始同本。总在众生心中。从体起用。应化身时。即是众生心中真如用大。更无别佛。如起信中多明此义。而是自心体用。今以此经心佛众生无差别故。佛证众生之体。用众生之用。三由前生佛互相在时各实非虚。则因果交彻。随一圣教全在二心。故众生心中佛。为佛心中众生说法。佛心中众生。听众生心中佛说法。四由生全在佛则同佛非生。佛全在生则同生非佛。两相形夺二位齐融。即随一圣教俱非二心。则佛心中众生无听。众生心中佛无说。是以贤首品云。因缘所生无有生。诸佛法身非是身。又偈赞品云。如来不说法。亦不度众生。大般若四百二十五云。我从得道来不说一字汝亦不闻等。是故此四于一圣教圆融无碍。方为究竟甚深唯识道理。第七会缘入实体者。前来六门同入一实故。亦有二义。一以本收末。二会相显性。前中以诸圣教从真流故。不异于真。故摄论中名为真如所流十二分教。唯识第十释胜流真如云。谓此真如所流教法。于余教法最为胜故。彼宗虽不立真如随缘。而说佛正体智证最清净法界。而于后得安立教法。名为如流。以本收末。亦名如为教体。二会相显性者。谓彼一切差别教法。从缘无性即是真如。是故虚相本尽真性本现。如来言说皆顺于如故。金刚三昧经云。如我说者义语非文。众生说者文语非义。仁王二谛品云。大王法轮者。法本如应颂如。乃至论议如等。此经明教即是如。不说如皆是教。若取诸法显义皆为教体。一切法皆如也则无如非教。第八理事无碍体者。谓一切教法虽举体即真。不碍十二分等事相宛然显现。虽真如举体为一切。不碍一味湛然平等。由如无碍。佛之音声亦顺如无碍。皆与如智而相应故。如前义分齐中广明。第九事事无碍体者。文义皆圆。文即圆音。此中亦具十种玄门。现相品云。佛演一妙音周闻十方国。众音悉具足。法雨皆充遍。即同时具足相应体。十住品云。欲具演说一句法。阿僧祇劫无有尽。而令文义各不同。菩萨以此初发心。即广陜无碍。体亦名纯杂教。一句不坏陜也纯也。文义不同广也。杂也。又云。于一法中解众多。众多法中解了一等。皆一多相容教也。出现品云。如来音声普入一切。譬如书字等。此亦相入即相容也。十住又云。一即是多。多即一。文随于义义随文。即相即教体。出现品云。道场皆闻不出众外。各各随解。即隐显教体也。又云。如来言音唯是一味。随诸众生心器异故。无量差别。亦隐显教体。亦纯杂教也。又云。如来于一语言中。演说无边契经海。如善口女等即微细教也。阿僧祇品云。于彼一一修多罗。分别诸法。不可说。于彼一一诸法中。又说诸法。不可说等。一法既尔。余法亦然。交映重重无尽无尽。即帝网教也。触事皆法。即托事生解教也。一念顿演。即十世教也。如诸会中此方所说十住等。十方亦尔。即主伴教也。若随说一法一门。皆有无量修多罗为眷属等。即眷属教。虽不得为主亦是伴类。此且约言说。若类通诸法皆为教体。即所诠义。义即普法具十玄门。如义分齐。第十海印炳现体者。如前差别无尽教法。皆是如来海印定中。同时炳现。设所化机亦同缘起炳现定中。是故唯以三昧为教体。如出现品辩。此约果位。若约因位。圆信亦得印现。贤首品云。如是一切皆能现海印三昧神通力。以上十门该罗收摄。未有一法而非教体。然后二门正是经宗。融取前八无所遗矣。第六宗趣通别者。语之所尚曰宗。宗之所归曰趣。先明其通后显于别。前中通论一代佛教。诸部异计各是一宗。谓十八本二各不同故。以义相从更复合之。然隋朝大衍法师。总立四宗。一因缘宗。谓萨婆多。二假名宗。谓即经部。三不真宗。谓诸般若。四真实宗。谓法性真理佛性等教。又此四宗初名立性。二名破性。三名破相。四名显实。初二小乘。后二大乘。各初浅后深。此亦有理。但收义不尽。以十八部中但判二故。今总收一代时教。以为十宗。第一我法俱有宗。谓犊子部等。彼立三聚。一有为。二无为。三非二聚。非二即我。又立五法藏。谓三世为三。无为为四。第五不可说藏。我在其中。以不可说为有为无为故。然此一部。诸部论师共推不受。呼为附佛法外道。以诸外道所计虽殊皆立我故。二法有我无宗。谓萨婆多等。彼立诸法不离色心。或立三世无为。或分五类皆无有我。以无我故。异外道计。又于有为之中立正因缘。以破外道邪因无因。然西域邪见虽九十五种。或计二十五谛从冥生等。或计六句和合生等。或谓自在梵天等生。或谓时方微尘虚空宿作等。而为世间及涅槃本。统收所计不出四见。谓数论计一。胜论计异。勒沙婆计亦一亦异。若提子计非一非异。若计一者。则谓因中有果。若计异者。则谓因中无果。三则亦有亦无。四则非有非无。余诸异计皆不出此。虽多不同。就其结过不出二种。从虚空自然生。即是无因。余皆邪因。此方儒道二教亦不出此。如庄老皆计自然。谓人法地地法天。天法道道法自然。若以自然为因能生万物。即是邪因。若谓万物自然而生。如鹤之白如乌之黑。即是无因。周易云。易有太极是生两仪。两仪生四象。四象生八卦。八卦定吉凶。吉凶生大业者。太极为因即是邪因。若谓一阴一阳之谓道。即计阴阳变易能生万物。亦是邪因。若计一为虚无自然。则亦无因。然无因邪因乃成大过。谓自然虚空等生应常生故。以不知三界由乎我心。从痴有爱流转无极。迷正因缘故异计纷然。安知因缘性空真如妙有。言有滥同释教者。皆是佛法之余。同于涅槃盗牛之喻。乳色虽同不能善取醍醐。况抨驴乳安成酥酪。广明异计。如瑜伽第六。显扬第九第十。婆沙十一十二。及金七十论说。中百等论亦广破之。今但说正因缘已总破诸计。是如佛法之浅浅。已胜外道之深深。三法无去来宗。谓大众部等。说有现在及无为耳。其过未之法体用俱无。四现通假实宗。谓说假部。就前现在之中法在蕴为实。在界处为假。其成实论经部师即是此类。五俗妄真实宗。即说出世部等。谓世俗是假以虚妄故。出世反上。六诸法但名宗。谓一说部等。一切我法唯有假名。无实体故七三性空有宗。谓遍计是空。依圆有故。八真空绝相宗。谓心境两亡直显体故。九空有无碍宗。谓互融双绝而不碍两存。真如随缘具恒沙德故。十圆融具德宗。谓事事无碍主伴具足无尽自在故。然此十宗后后深于前前。前四唯小。五六通大小。后四唯大乘。七即法相宗。八即无相宗。后二即法性宗。又七即始教。八即顿教。九即终教。十即圆教。又第七亦名二谛俱有宗。谓胜义真实故不无世俗。因果不失故是有。如深密瑜伽等第八亦名二谛双绝宗。谓胜义离相故。非有世俗。缘生如幻故是无。如掌珍颂云。真性有为空如幻缘生故。无为无有实不起似空华等。即般若三论中一分之义。九二谛无碍宗。如维摩法华等。义如前显。然十宗五教。互有宽陜。教则一经容有多教。宗则一宗容具多经。随何经中皆此宗故。若局判一经以为一教。则抑诸大乘。又夫立教。必须断证阶位等殊。立宗但明所尚差别。前之六宗执法有异故分六宗。断证次位不离八辈合为一教。余义如前立教中辩。第二显别宗者。一切诸经各自有宗。今此别明此经宗趣。然楞伽云一切法不生。不应立是宗者。斯言遣滞。若无宗之宗则宗说兼畅。略以二门分别。先叙异解后申今义。前中略举十说。一衍法师以无碍法界为宗。二裕法师。以甚深法界心境为宗。谓法界门中义分为境。诸佛证之以成净土。法界即是一心。诸佛证之以成法身。是故初品中云。无尽平等妙法界。皆悉充满如来身。末后明入法界品。故知唯以法界为宗。三有说。以缘起为宗。法界缘起相即入故。四有云。以唯识为宗。经说三界唯一心现心。如工画师故。五敏印二师同以因果为宗。谓此经广明菩萨行位之因。及显所成果德。下文不离此故。六远法师以华严三昧为宗。谓因行之华能严佛果故。七笈多三藏。以四十二贤圣观行为宗。说其行位令成观故。八有说言。以海印三昧为宗。逆顺理事乃至帝网。如海波澄一时现故。九光统律师。以因果理实为宗。以因果是所成行位。理实是所依法界故。十贤首以前各互阙故。总以因果缘起理实法界以为宗趣。谓前之二师。但得所依法界。三四二师但明缘起。五六唯明因果。七唯因修八唯果用。并皆互阙。故贤首意。取光统而加缘起法界之言。由光统师以因果即缘起。理实即法界故不开之。贤首以因果是缘起中别义。理实是法界中别义。故加总名。以法界有事理及无碍故。缘起体上之用故。所以加之。二申今解者。依后二师而颇为改易。若取言略摄尽。应言法界缘起不思议为宗。若取言具。于第十师加不思议。此则摄一总题。理实即大方。缘起即方广。法界总该前二。因果即佛华严。观其总题已知别义。而法界等言。诸经容有。未显特异故。以不思议贯之。则法界等皆不思议故为经宗。所以龙树指此为大不思议经。斯良证也。净名但明作用不思议解脱。盖是一分之义。未显法界融通等不思议故。不同也。若就题中分体宗用。则以理实为体。缘起为用。因果为宗。寻宗令趣理实体故。法界总摄上三。今释前义略分为二。一释名。二显义。今初。法界名体。广如本品。今略申其二。一事法界。二理法界。二法俱含持轨二界。则性分不同互用皆通。二显义中曲有四门。第一别开法界以成因果。谓普贤法界为因。遮那法界为果。是故因果不离理实法界。于中十事五对即五周因果。一所信因果。二差别因果。三平等因果。四成行因果。五证入因果。下当指文。而此因果互为宗趣。一经始终不离因果故。但因果为宗。不违所依法界。第二会融因果以同法界。法界门中。亦有十事五对互为宗趣。一教义相对。谓举教为宗显义为趣。或以义为宗显教为趣。以辩义深令教胜故。二人法相对。举人为宗令知法为趣。举法为宗令得人为趣。三理事相对。举事意令趣理故。举理意在融事故。四境智相对。举所观境令成观智故。举修成智令证同真境故。五因果相对。举彼修因令证果故。举其胜果劝修因故。五对别明是宗之趣。五对相即为宗即趣。上五周因果。不离此五对之法。即事理法界。况因果无性当体同真。所以但用法界为宗。亦不违因果。第三法界因果分明显示。亦有十义五对。一无等境。此有二位。一在缠性净法界。为所信境。二出缠最清净法界为所证境。二无等心此亦二义。一大菩提心。为普贤行本故。二信悲智等随行起故。三无等行。此亦二义。一差别行。各别修故。二普贤行。一即一切故。四无等位。此亦二义。一行布位。比证别故。二圆融位。一证一切证故。五无等果。此亦二义。一修生果。今始成故。二修显果本自具故。此上五对。各初句为宗。后句为趣。又上五中。初一真法界。二即缘起。又二三四皆缘起因。后一缘起果故。光统具用二义为宗。无所违矣。第四法界因果双融俱离性相。混然无碍自在。亦有十义。一由离相故因果不异法界。即因果非因果也。此即相为宗离相为趣。或离相为宗。亡因果为趣下九准思。二由离性故。法界不异因果。即法界非法界也。三由离性不泯性故。法界即因果时法界宛然。则以非法界为法界也。四由离相不坏相故。因果即法界时因果历然。则以非因果为因果也。五离相不异离性故。因果法界双泯俱融。迥超言虑。六由不坏不异不泯故。因果法界俱存。现前烂然可见。七由五六存泯复不异故。超视听之妙法。无不恒通见闻。绝思议之深义。未尝碍于言念。八由法界性融不可分故。即法界之因果各同时全摄法界。无不皆尽。九因果各全摄法界时。因果随法界。各互于因果中现。是故佛中有菩萨。普贤中有佛也。十因果二位。各随差别之法。无不该摄法界故。一一法一一行。一一位一一德。皆各总摄无尽无尽帝网重重诸法门海。是谓华严无尽宗趣。上之四门。初一即体之用。次一即用之体。三即体用双显。四即体用镕融。又初一即因果缘起。次一即理实法界。三即双明。后一即不思议。既以第四融前。则四门一揆。故即照而遮。即遮而照。双照双遮圆明一观。契斯宗趣矣。第七部类品会者。既知旨趣冲深未审能诠文言广陜。于中有四。一彰本部。二显品会。三明支类。四辩论释。初中性海之诠。常说遍说。言穷法界难可限量。今自陜之宽略为十类。一略本经。即今所传八十卷本。及旧译六十卷。皆是十万偈中之略译未尽故。二下本经。谓摩诃衍藏。是文殊师利与阿难海。于铁围山间结集此经。收入龙宫。龙树菩萨往龙宫。见此大不思议经。有其三本。下本有十万偈四十八品。龙树诵得流传于世故。智度论名此为不思议经。有十万偈。梁摄论中名百千经。西域记。说遮拘槃国有此具本。三中本经。即彼所见。有四十九万八千八百偈。一千二百品。四上本经。即彼所见。有十三千大千世界微尘数偈。一四天下微尘数品。此上二本。非阎浮提人心力能持。故不传之。五普眼经。即海云所持。以大海量墨。须弥聚笔书此普眼法门一品中一门。一门中一法。一法中一义。一义中一句不得少分。何况能尽。但是入深法界菩萨陀罗尼力之所能持。已下诸经。并非凡力能受。六同说经。谓约一类须弥山形世界。遍于虚空容毛端处。以言声说无有穷尽。如不思议法品云。如一佛身。以神通力转如是等差别法轮。一切世法无能为喻。如是尽虚空界。一一毛端分量之处。乃至一一化身。皆如是说。音声文字句义一一充满法界等。又阿僧祇品云。光中见佛不可说。佛所说法不可说。乃至于彼一一修多罗。分别法门不可说等。此意但约一类音声说法。已不可结集。岂下位能持。七异说经。谓树形等世界既异。其中众生报类亦别。如来于彼现身立教施设不同。不可定其色与非色言非言等。则部类难量。八主伴经。谓遮那所说。虽遍法界然与诸佛互为主伴。如说十住时。十方来证。皆言我国皆说等。则前七经皆有主伴。九眷属经。谓余根器不能闻此通方之说。随宜说教令入此门。皆为此经胜方便。故名为眷属。故下经云。普眼修多罗。以佛刹微尘数修多罗为眷属等。则前八皆有眷属。十圆满经。谓此上诸本。总融为一无尽大修多罗海。随一会一品一句一文。皆摄一切无有分限。故现相品云。毗卢遮那佛愿力周法界一切国土中恒转无上轮等故。七十三中名圆满因轮此之谓也。第二品会差别者。即显今经与晋译同异。今经九会。以晋经第七会初阙十定品重会普光。故唯八会。今有三十九品。初会有六品。彼经唯三十四。由初会中唯有二品。一世间净眼品。即今世主品。二卢舍那品。即今现相已下五品。初会阙四兼阙十定。故唯三十四品。余诸品会大同名有小异。至文当显。第三明支类者。于中复二。先显支流即别行经。藏中兜沙经一卷。是名号品。菩萨本业经一卷。是净行品。小十住经一卷。是十住品。大十住经四卷。及渐备一切智德经四卷。并是十地品。等目菩萨所问三昧经二卷。是十定品。无边功德经一卷。是寿量品。如来性起微密藏经二卷。是出现品。度世经六卷。是离世间品。罗摩伽经三卷。是入法界品。此等并是随器受持大本支出。二明流类。谓修慈经一卷。金刚鬘经十卷。如来不思议境界经一卷。并是华严流类而非本部别行。或是别行来未尽者。未敢详定。余如纂灵记辩。第四论释者。略举其四。一龙树既得下本。遂造大不思议论。亦十万颂备传西域。此方十住毗婆沙论十六卷。即是彼论释十地中初之二地。二世亲菩萨。造十地论释十地品。魏朝勒那三藏。又菩提流支各翻一本。光统奏请。令二三藏参成一本为十二卷。即今见传。三北齐刘谦之。于清凉山感通造论六百卷。备释一经。四后魏僧灵辩。于五台山顶戴此经。行道一载。遂悟玄旨。造论一百卷。亦传于世。第八传译感通分二。先明翻译年代。后明传通感征。前中此经前后通唯二译。并其补阙四本不同。一晋义熙十四年。北天竺三藏。佛度跋陀罗。此云觉贤。于杨州谢司空寺翻梵本。三万六千颂成晋经五十卷。或六十卷。沙门法业笔受。慧严慧观润色。谢司空寺者。即今润州兴严寺是。由兴华严故。二大唐永隆元年中。天竺三藏地婆诃罗。此云日照。于西京大原寺。译出入法界品内两处脱文。一从摩耶夫人。后至弥勒菩萨前中间天主光等十善知识。二从弥勒菩萨后至三千大千世尊微尘数善知识前中间。文殊申手过一百一十由旬按善财顶。十五行经。大德道成律师薄尘法师大乘基法师等同译。复礼法师润文。依六十卷本为定。三证圣元年。于阗三藏实叉难陀。此云喜学。于东都佛授记寺再译旧文。兼补诸阙。计益九千颂。通旧总四万五千颂。合成唐本八十卷。大德义净三藏。弘景禅师圆测法师神英法师法宝法师贤首法师等同译。复礼法师缀文。四即于前第三本中。虽益数处却脱日照三藏所补文殊。按善财顶之文。即贤首法师。以新旧两经勘。以梵本将日照补文。安喜学脱处。遂得文续义连。其文之要至下当辩。今之所传即第四本。其第三本先已流传。故今世上之经。犹多脱者即第三本。愿诸达识见阙而续之。二明传通感应者。自晋译微言则双童现瑞。唐翻至教则甘露呈祥。冥卫昭然亲纡御笔。论成西域则地震光流。志彻清凉则感通玄悟。其书写则经辉五色。楮香四达冬葵发艳瑞鸟衔华。读诵则眇然履空。焕若临镜。每含舍利适会神僧。涌地现金色之身。升天止修罗之阵。观行则无生入证。偈赞排空。海神听而时雨滂沱。天童迎而大水弥漫。讲说则华梵通韵人天共遵。洪水断流神光入宇。良以一文之妙摄义无遗。故一偈之功能破地狱。盥掌之水尚拯生灵故读诵思修功齐种智。宿生何幸感遇斯文。其事迹昭彰备于传记。第九总释名题中。先解经题后明品称。今初。总题包于别义。该难思之法门。无名之中。强以十门分别。一通显得名。二对辩开合。三具彰义类。四别释得名。五展演无穷。六卷摄相尽。七展卷无碍。八以义圆收。九摄归一心。十泯同平等。今初。诸经得名有其多种。或以人为目。或以法为名。人有请说等殊。法有法喻等别。或体或用或果或因。乍复乍单其类繁广。今经受称亦多种不同。一从数彰名。如梁摄论第十胜相中云。百千经者。是华严经有十万颂是也。二从喻受名。如涅槃及观佛三昧经。名此经为杂华经。以万行交杂缘起集成故。三从法彰名。如智论释嘱累品。名此经为不思议解脱经。四从义用受名。如下离世间品及出现品。各有十名者是。依今梵本。云摩诃毗佛略勃陀健拏骠诃修多罗。此云大方广佛杂华严饰经。今略杂饰字耳。前三异名义多总略。二品十目多从别义。又局当品。故今译者具以六字为名。则人法双题。法喻齐举。具体具用有果有因理尽义圆故标经首。二对辩开合者。题中七字有十事五对。一教义相对。谓经之一字是能诠教。大等六字是所诠义。二就义中法喻一对。谓大等是法。华严是喻。三就法中人法一对。谓大方广是所证无障碍法。佛是能证之人。亦名境智一对。四就法中拣持一对。大之一字是拣方。广是持。即拣大异小。拣实异权。拣果异因。亦是体用一对。大方是体大方无隅故。广即是用。五就人中。借下华字以喻其因。即因果一对。佛是果故。是以单用华字则但喻因。若合以华严。则亦喻上之四字。至下当明。三具彰义类者。谓大等七字义皆无量。并略以十义释之。初明大十义者。一体大。谓若相若用等。皆同真性而常遍故。即是大字。涅槃云。所言大者名之为常。此明体不变易。如人最长故名为大。又云大者。其性广博犹如虚空。此明体遍。二者相大。谓恒沙性德无不具故。互相即入微细重重等。具十玄门。皆其相故。即经方字方者法也。三用大。谓业用周普如体遍故。即经广字。涅槃云。又大者。能建大义即是约用。良以涅槃无广。广与大同故。以广释大。方广无大。大与广合故。以大释广。今经具有故各配之四果大。谓智断依正普周法界故。即经佛字。五因大。谓发菩提心起解行愿证。精勤匪懈成诸位故。即经华字。六智大。谓大智为主。运诸万行遍严一切无所遗故。即经严字。七者教大。谓一文一句无不结通。遍于一切十方三际重重无尽故。即是经字。八者义大。谓所诠法尽穷法界。乃至帝网无所遗故。即总是六字。九者境大。以上法门。普以无尽一一为化境故。十者业大。谓尽三际时穷法界处。常将此法利益众生。无休息故。如摄大乘等七种大性。不离于此。二方十义者。方者法也。即前十大皆名为法。谓体法相法等。三广十义者。广者多也。用多繁兴。包无不尽故。则前十皆多。即明一遍一切名之为大。一摄一切名之为广。亦可反此。此约离释。若合释方广二字。亦有十义。一广依义。谓言教繁广为生依故。二广说义。宣说广大甚深法故。三广破义。破一切障无有余故。四广超义。无有诸法能比类故。五广治义。具摄无边对治之法。为能治故。六广摄义。通摄无边异类法故。七广德义。具摄二严诸胜德故。八广生义。能生无量广大果海故。九广绝义。非是心识称量所能知故。十广知义。具足种智破邪见障无有余故此之十义。前四即杂集第十一中四义。后六即入大乘论第一中六义。四解佛十义者。即是十佛。大即法界佛。方即本性佛。广即涅槃佛。及随乐佛。佛即成正觉佛。华即愿佛。及三昧佛。严即业报佛。经即住持佛。总不离心。七字皆是心佛。释十佛义。如八地中及离世间品辩。又佛地论第一说。佛亦具十义。谓具一切智一切种智。离烦恼障及所知障。于一切法一切种相。能自开觉。亦能开觉一切有情。如睡梦觉如莲华开。故名为佛。又真谛引真实论。亦有十义恐繁不引

五释华十义者。一含实义。表于法界含性德故。二光净义。本智明显故。三微妙义。一一诸行同法界故。四适悦义。顺物机故。五引果义。行为生因起正觉故。六端正义。行与愿俱无所缺故。七无染义。一一行门三昧俱故。八巧成义。所修德业善巧成故。九芬馥义。众德住持流馨弥远故。十开敷义。众行敷荣令心开觉故。然华有二种。一草木华喻万行因。然或因与果俱。或不与俱。二严身华通金玉等。喻于神通众相等。唯与果俱。前十义中。一五九十局于草木。余通二华。六释严者。即上十华同严一佛为严不同。亦是十义。又上十华。如次严前十佛。即是十义而总别无碍。更有十义。一用因严果以成人是佛华严。果由因得故。二以果严因。以显胜成果之后。令一一因行皆无际故。三以人严法而显用。谓佛旷劫修因。方显法之体用故。四以法严人以显圆。若不得法之体用。因果不能圆妙故。五以体严用。以令周。谓用不得体不周遍故。六以用严体而知本。若无大用。不显体本之广大故。七以体严相而知妙。谓相若有体。便即入重重故。八以相严体以明玄体。若无相不显体深玄故。九以义严教超言念。由所诠难思能诠言离故。十诸因互严以融摄。如禅非智无以穷其寂。智非禅无以深其照等。又上来互严。皆有相资相即四句。今且约理行互严。以明。初相资四句者。一理由修显故。以行华严理。二行从理发。则以理华严行。梁摄论云。无不从此法界流。无不还证此法身故。三理行俱融不二而二。非真流之行。无以契真。非起行之真不从行显。良以体融行而因圆。行该真而果满。是故标为佛华严也。四理行俱泯二而不二。以理之行故非行。行之理故非理。是则能所两亡超情绝相。非严非不严。是谓华严。相即四句。理行全收准思可见。则法喻交映昭然有在。七释经十义。杂心五义。已见上文。佛地论有二义。一贯穿所说。二摄持所化。即杂心结鬘一义合之应除结鬘开成六义。依此方训复有四义。一常二法并如前辩。三经义。即众生径路四典义。令见闻正法故。宝云经中亦有十义。恐繁不引。第四别释得名者。先得后释。先得名者。大以当体受名。常遍为义。常则竖无初际。遍则横该无外。方以就法得名。轨持为义。双持体相轨生物解故。广以从用得名。包博为义。包则广容博则广遍。佛以就人得名。觉照为义。照则朗万法之幽邃。觉则悟大夜之重昏。华以从喻得名。感果严身为义。感果则万行圆成。严身则众德备体。严以功用受名。资庄为义。谓资广大之体用。庄真应之佛身。经以能诠得名。摄持为义。持性相之无尽。摄众生之无边。后释名者。一就法中体用相对。大之方广。谓有体之相用故。方广之大。有相用之体故。皆依主释。若相即者。即持业释。二就人中果行相望。佛之华。非因位之行故。华之佛。非余行之佛故。亦通相即。三以人法相对。大方广之佛华严。非小权乘之佛等故。佛华严之大方广。非因位所得法故。相即可知。四教义相对。亦通二释。教望于义。及前人望于法。兼通有财。并可思准。第五展演无穷者。谓初于最清净法界。开为理智两门。即涅槃菩提之异。又理开体用即大方广。智开因果即佛华严。总连合成诠。即题中经字。又展此目以为初会。初会总故。十海是理。十智是智。十海之中含于体用。十智之中亦含因果。又华藏世界及遮那遍中。即依正二果皆是佛字。大威光太子略示因华。彼二所证所观即大方广。即总成一会。所信因果体用。又展此会。以成后八四周因果。各因是华果即是佛。其所修所证之体用。即大方广。又展此九会遍周十方。谓如第二会光明觉品辩一类之会已遍十方。余会亦尔。又展此诸会各有主伴。如说十住。十方菩萨皆来证云。十方国土皆说此法。则前遍法界之会。各有重重主伴。乃至遍于尘刹异类界等。无尽时会。皆不出大方广佛华严清净法界。第六卷摄相尽者。谓从后渐卷乃至不出九会。九会不离初会。初会不离总题。总题不出理智。非理不智故理外无智。非智不理故智外无理。则理智不二。亦摄智从理。离体无用摄用归体。体性自离。故体即非体。本来清净强名之清净法界。是以极从无尽乃至一字无字。皆摄华严性海。无有遗余。第七展卷无碍者。谓正前展时即后常卷。正后卷时即前常展。展时即卷故。无量无边法门海。一言演说尽无余。卷时即展故。如来于一语言中。演说无边契经海。第八以义圆收者。上来诸门。或以七字摄尽。如前已辩。或以教义摄尽。或以理智摄尽。或以人法摄尽。或信解行证摄尽。或唯普贤文殊毗卢遮那三圣摄尽。谓大方广即普贤。普贤表所证法界故。华严即文殊。文殊表能证故。佛即遮那具能所故。又大即普贤。普贤菩萨自体遍故。方广即文殊。文殊表即体之智故。华即普贤。普贤行故。严即文殊。文殊以解起行故。佛即圆解行之。普贤文殊证法界体用之普贤文殊。成毗卢遮那光明遍照。第九摄归一心者。上来诸门乃至无尽。不离一心。一心即法界故。起信云。所言法者。谓众生心。心体即大。心之本。智即方广。观心起行即华严。觉心性相即是佛。觉非外来。全同所觉故理智不殊。理智形夺双亡寂照。则念念皆是华严性海。第十泯同平等者。为未了者令了自心。若知触物皆心方了心性故。梵行品云。知一切法即心自性。则成就慧身不由他悟。然今学法之者。多弃内而外求。习禅之者。好亡缘而内照。并为偏执俱滞二边。既心境如如则平等无碍。余曾莹两面镜。鉴一盏灯置一尊容。而重重交光佛佛无尽。见夫心境互照本智双入。心中悟无尽之境。境上了难思之心。心境重重智照斯在。又即心了境界之佛。即境见唯心如来。心佛重重而本觉性一。皆取之不可得。则心境两亡。照之不可穷则理智交彻。心境既尔。境境相望心心互研。万化纷纶皆一致也。唯证相应名佛华严矣。第二释品名者。梵云萨婆噜鸡印拏徕骠诃柰耶钵攞叵婆娜忙钵里勿多。此云一切世间主庄严法门威德名品。今文存略。世者时也。即是世间主者君也。谓即诸王及佛。然世间有三。一器世间即是化处。二众生世间即所化机。三智正觉世间即能化主。主则唯二诸王及佛。主于器界及众生故。佛非世间。从所统受称。妙谓法门体用深广难思。即主之所得。严谓严饰。乃有多义。一器世间严。谓其地坚固等。二众生世间严。谓众海各具法门威德故。三智正觉世间严。谓于一切法成最正觉。三业普周法门无尽故。所以长行诸王之严。偈颂赞德皆显严佛。众生不严不感佛兴。正觉不严不能为主。器界不严非真佛处。复由佛严显遇者有德。众生严辅显佛超胜。如是互严亦为妙严。诸经无此广严故。但初名序品。今明序已兼正。故广赞诸严。以为华严之由序。旧云。世间净眼品者。谓所得法眼能净世间。故净即严义。余如前说

大方广佛华严经疏卷第三大方广佛华严经疏卷第四

        唐清凉山大华严寺沙门澄观撰

等十别解文义者。然此经。文富义博。势变多端。况一义一文包摄法界。是以古德明十例科判。欲显难思。其第一名本末部类。但显此经无尽非科今文。前已具明。故今略之。加前后钩锁亦有十例。一本部三分科。二问答相属科。三以文从义科。四前后襵叠科。五前后钩锁科。六随品长分科。七随其本会科。八本末大位科。九本末遍收科。十主伴无尽科。初本部三分者。谓序正流通。初品为序分。现相品下为正宗。流通有无古有七释。一光统律师。以法界品为流通。由入法界广无边故。二隋远法师。以法界品内善财下属流通。寄人显法故。三裕法师。以法界品后偈为流通。以叹德无尽故。四有云。末后二颂为流通。以结说无尽叹益劝修故。五或云。经来未尽。故无流通。六或云。以余眷属经为此流通。以彼是此所流出故。七或云。此经总无流通。以法无尽说无休息故。故诸会各无流通。不同大般若诸会皆有流通故。此上七解各是一理。而前六皆有第七独无。若义会之应成四句。一有序正无流通。如第七。二唯正宗无二分。由自初暨后。皆显玄微并悟物故。初虽列众而叹佛德。后虽寄人有修相故。三具三分。四俱不可说。即言亡言故。约义包含不可局取。今依具三以分三分之兴。弥天高判冥符西域。今古同遵所以三者。夫圣人设教必有其渐。将命微言先彰由致。故受之以序分。由致既彰当机受法。故受之以正宗。正宗既陈务于开济。非但笃于时会。复令末叶传芳。永耀法灯明明无尽。故受之以流通。非唯一部当会当品等。皆容有之故依三也。虽六解皆通。今依第二。以奇人进修示物有分流通相故。故慈氏云。若有敬慕心。亦当如是学。初之一解。令正宗中阙于证入。第三但属善财之一相故。末后二偈。但结偈中佛德。非通一部。十行等末类有此偈。经来未尽。未必在后眷属流通。但约义故。故依远公。二问答相属科者。古云。此九会中。大位问答总有五番。第一会中。大众起四十问。或当会答尽。名举果劝乐生信分。二从第二会初有四十问。至第七会末答尽。名修因契果生解分。中间虽有诸问。并是随说随问。非是大位问答。不思议品不问因故。三第八会初起二百句问。当会答尽。名托法进修成行分。四第九会初起六十句问。如来自入师子频申三昧。现相答名顿证法界分。五福城东善财求法等别问别答。名历位渐证分。古德以善财犹属正宗。故今既判入流通。则前唯四兼取流通。以为五分未爽通涂。三以文从义科者。此经一部有五周因果。即为五分。初会中一周因果。谓先显舍那果德。后遮那一品。明彼本因名所信因果。二从第二会至第七会中随好品。名差别因果。谓二十六品辩因。后三品明果。亦名生解因果。三普贤行品辩因。出现品明果。即明平等因果。非差别显故。亦名出现因果。四第八会初明五位因。后明八相果。名出世因果。亦名成行因果。五第九会中。初明佛果大用。后显菩萨起用修因。名证入因果。因果二门俱证入。故各分因异果亦为十也。四前后襵叠科者。一部分二。谓前九会是本会。亦是佛会。佛为主故。从文殊至福城东已后。并是末会。亦是菩萨会。以诸善知识为会主故。二就前中亦二。初八会明所成解行。后一显所证法界。三就前中复二。初七会明历位修成行。后一明圆融周普行。四前中复二。初明修生因果。后普贤下二品。明修显因果。五就前复二。初明修生因。后不思议法等三品。明修生果。六就前复二。四明位中因行。后十定下。六品明位后之行。七就前复二。初明地前比行。后第六一会。明十地证行。八就前亦二。初明位前十信行。后第三会已去三会。明入位三贤行。九就前亦二。初明所信佛果法。后问明品下三品。明能依能信菩萨行。十就前中复二。初会明佛依报果。后名号下三品。明佛正报果。五前后钩锁科。亦分为十。一第一会为依报因果。前明依报果。后毗卢遮那品辩因。二更取毗卢遮那。及第二会初三品。为正报因果。前因后果。三以名号至菩萨住处。名依起因果。依于本有而修起故。前果后因。四从问明品至随好品。明差别因果。前因后果。五取不思议下至普贤行品。为圆融因果。前果后因。以不思议等与前为果。果别于因。与后为果则一一融摄。然有六义证成。一因果相属科中。多先果后因故。二四十八后未有证成。普贤行后有证成者。结属前故。三普贤品初。无别发起。便即蹑前云。略示如来少分境故。四以义明之。不思议法显佛德难思。一一圆融故。五前虽有问不思议品初重念问故。六第二会初已有三业。为差别果故。由斯六义故。普贤行品得属前因。六取普贤行及出现品。为平等因果前因后果。七取出现及离世间品。为出现因果。前果后因。成佛涅槃亦因现故。非说真成由离世间为因方能现世。八离世间品为成行因果通辩行故。具因果故。九取离世间品及法界品。为法界因果。前因后果由离世间称法界故。故因不依位果唯证入。十法界一品自为证入因果。先果后因。其善财已下亦为无尽因果。先因后果故。历事至普贤一毛因则无尽。普贤说佛德过虚空。而果无尽以为流通。故不明之。六随品长分科者长分为十。一通辩教起因缘分。二现相品下明佛果无涯。大用分三。毗卢遮那品举彼往因证成分。四名号下三品。明大用应机普周分。五问明品下至十地品末。明诸位差别令修分。六十定品下至随好品末。明差别因圆果满分。七普贤行品下二品。明普行因成现果分。八离世间品明因果超绝世间分。九法界品中前分。明大众顿证法界分。十尔时文殊下。明一人历位渐证分。七随其本会科者。亦为十分一初会名举果令信分。二第二会明能信成德分。三第三会初贤十住分。四第四会中贤十行分。五第五会上贤十向分。六第六会圣位十地分。七第七会因圆果满分。八第八会普贤大行分。九第九会初行成证入分。十善财下善友教证分。八本末大位科者。本会为九。末会有五十五。总为六十四分。九本末遍收科者。先九会为九分。文殊为六千比丘说法。为第十分。及善财历一百一十善知识。总一百二十分。若开诸龙及三乘会。及弥勒后文殊普贤三人。便成一百二十五。以慈氏云此长者子经由一百一十善知识已然后而来至于我所。则弥勒已前已有一百一十故。及三千大千世界微尘数善友。其分数弥多。若合为一则一百二十六分。十主伴无尽科者。一一会一一品一一法。皆结通十方。如此间说十方虚空法界一切世界。乃至一切尘中皆如是说。此结主经也。又彼一一会等。皆有他方尘数菩萨来证法。此结伴也。即主伴相与周遍法界。重叠无尽。是则段数亦无尽无尽也。上来十例各显一理。然亦无尽。若依常用应依三分。谓初品为序。现相品下正宗。法界品内尔时文殊师利从善住楼阁出下明流通。序中就文分二。初此土序。二结通十方无尽世界序。初中复二。初证信序。后尔时如来道场下发起序。然此二序广如常解。今但略陈。初证信者。若原其所由。则阿难请问如来令置。如智度论及大悲经说。若核其所以意有六焉。一为异外道故。外道经首。皆立阿优以为吉故。此约如是。二为息诤论故。智度论云。若不推从佛闻言自制作。则诤论起。故今废我从闻。闻从佛来故经传历代妙轨不辍。此局我闻。三为离增减过故。佛地论云。应知说此如是我闻。意避增减异分过失。谓如是法我亲从佛闻。文义决定非谓传闻有增减失。四为断众疑故。真论引律云。结集法时。阿难升座变身如佛。众起三疑。一疑大师涅槃重起。二疑他方佛来。三疑阿难转身成佛。说此如是我闻三疑顿断。既言我闻即非佛明矣。上二义通约信闻。五为生信故智论云。说时方人令生信故。此局后四。六为顺同三世佛故。此通六种。若准佛地论科为五事。一总显已闻。二教起时分。三别显教主。四彰教起处。五显所被机。今依智论开初总显已闻。作信闻二种为六成就。一信。二闻。三时。四主。五处。六众。然信闻二事。文局初首义通九会。时主二种文义俱通。处众二事文义俱局。随相则尔约实互融。上来略依三分二序。然此经体势少异。故依五分释文。而合后二名依人证入。就第一举果分中。或科为十。一教起因缘分。即初一品。二大众同请分。三面光集众分。四毫光示法分。五眉间出众分。已上在第二品内。六普贤三昧分。七诸佛同加分。八法主起定分。九大众重请分。已上在第三品内。十正陈法海分。在后三品内。若以义从文。且分为三。一教起因缘分。二现相下说法仪式分。三世界成就下正陈所说分。就初分中亦分为十。一总显已闻。二一时下标主时处。三始成正觉别明时分。四其地下别显处严。五尔时世尊下教主难思。六有十佛世界下众海云集。七从尔时如来道场下称扬赞德。八尔时如来师子座下座内众流。九尔时华藏下天地征祥。十如此世界下。结通无尽。今即初也。如是我闻者。谓如是一部经义。我昔亲从佛闻故。佛地论云。谓传佛教者。言如是之事我昔曾闻。如是总言依四义转。一依譬喻。二依教诲。三依问答。四依许可。具如彼论。余更有释意不殊前。此上总合信闻。若离释者。先释如是信成就也。智论云。佛法大海信为能入。智为能度。信者言是事如是。不信者言是事不如是。故肇公云。如是者。即信顺之辞也。信则所言之理顺。顺则师资之道成。经无丰约。非信不传。故称如是。有云。圣人说法但为显如。唯如为是故称如是。此唯约所诠之理。次真谛三藏云。真不违俗名之为如。俗顺于真称之为是。真俗无二故称如是。此约所诠理事。若云如斯之言是佛所说。则唯约能诠。有云。如者当理之言。言理相顺。谓之如也。是者无非之称。此明说事如事说理如理。明能诠之教。称于事理也。融公云。如是者。感应之端也。如以顺机受名。是以无非为称。众生以无非为感。如来以顺机为应。经以言教出于感应。故云如是。此兼对机。上来诸释各是一途。更有诸释。言异意同。若依生物之信。应如智论及佛地合释。若取敌对阿优。应如真谛所释。今当广之。外谓阿之言无。优之言有。万法虽众不出有无。此即断常之计。今云。如即真空。是即妙有。既无俗外之真。故空而非断。无真外之俗。故有而非常。即对破邪宗以彰中道。一代时教不出于斯。故云如是。若华严宗□无障碍法界曰如。唯此无非为是。应随教门深浅。以显如是不同。二我闻者闻成就也。将欲传之于未闻。若有言而不传便是徒设。不在能说贵在能传故。次明我闻。我即阿难。闻谓亲自听闻。云何称我即诸蕴假者。此用何闻。若依大小乘法相。各有三说。一耳闻非识。二识闻非耳。三缘合方闻。然或具四缘八缘等。虽因耳处废别从总。故称我闻。法虽无我言语便故。随顺世间故称我闻。非邪慢心而有所说。若依无相。我既无我。闻亦无闻。从缘空故而不坏假名。即不闻闻耳。若约法性。此经旨趣。传法菩萨。以我无我不二之真我。根境非一异之妙耳闻无碍法界之法门也。然阿难所不闻经。或云展转传闻。或云。如来重说。或云。得深三昧。或自然能通。上皆就迹而说实。是大权菩萨影响弘传。如不思议境界经。斯为良证。但随机教别。故见闻不同。上来总显已闻竟。第二标主时处者。即三成就。言一时者时成就也。时者亦随世假立时分。一者拣异余时。如来说经时有无量。不能别举。一言略周。故云一时。如涅槃云。一时佛在恒河岸等。即法王启运嘉会之时也。亦可机教一时。谓上言如是言。虽当理若不会时。亦为虚唱。今明物机感圣圣能垂应。凡圣道交不失良机。故云一时。佛者主成就也。具云勃陀。此云觉者。谓自他觉满之者。虽具十号佛义包含。故偏明之。义见题中。三在摩竭下处成就也。真身无在而无不在。故次辩之。摩竭提国者。通举说处。此云无毒害。以国法无刑戮故。表能化法。或云遍聪慧。聪慧之人遍其国故。表所化机。阿兰若法者。别举说场也。阿兰若者。此云无諠诤。即事静也。法者所证真理。二障业苦諠杂斯尽也。事理俱寂故加法言。菩提场者。菩提云觉。即能证大智圆明究竟也。场者证菩提之处也。然事处即天地之中。王舍城之西二百里。金刚座上。约法则万行皆是道场。理智相会之所。故为表所说如所证。故不移其处说之。若圆融时处等。并如前说。第三别明时分者。前标一时未知何时。故今别显是初成佛时。亦彰大师出现时也。此教胜故众教本故。在于初时。初言尚总几日之初。九会之文同此初不。略为三解。一约不坏前后相说。才成初七说前五会。第二七日说十地等。第九一会乃在后时。以祇园身子皆后时故。常恒之说不妨后时。虽能顿说有所表故。初五信解行愿最在初故。故皆云不离道树。第六会因地证位居其次深。故无不起菩提树言。法界极证最在于后故。亦显二乘绝见闻故。虽异处别时亦不相离。为寄秽土以显净故。须前后耳。若尔世亲那云初七不说但思惟行因缘行耶。世亲才见十地。即为论释。或则未穷广文。或则知见有异未全克定。菩提流支意大同此。二顺论释。九会皆在二七日后。二七非久亦名始成。三约实圆融释。皆在初成一念之中。一音顿演七处九会无尽之文。海印定中一时印现以应机出世机感即应。应即有说无非时失故。祇园身子。盖是九世相收。重会之言亦犹灯光涉入。故法界放光。亦见菩萨遍坐道场成正觉故。此经十地之初无二七之言。二七之言顺别机故。故诸经论。显初说时有多差别。谓普耀密迹二经。第二七日即说三乘。法华过三七日方云说小。四分律中六七。兴显行经七七。五分八七。智论五十七日。有云。与十二游经一年大同。时既不定说亦不同。皆根器所宜见闻有异约佛赴机无时不说。望器无感未曾有说。登地恒见常说一味之经。就佛而言无说不说。若摄方便。皆一乘之印现差别耳。无涯之说不应局执故。应总摄以为十重。如前已辩。上显时分。次释成正觉义。约教不同。小乘三十四心断结。五分法身初圆。名成正觉。是实非化。大乘之中约化八相示成。约报十地行满四智创圆。名曰始成正觉。据实即古今情亡心无初相。名之曰始。无念而照。目之为正。见心常住称之曰觉。始本无二目之为成。约法身自觉圣智。无成无不成。若依此经。以十佛法界之身云。遍因陀罗网无尽之时处。念念初初为物而现。具足主伴摄三世间。此初即摄无量劫之初无际之初。一成一切成无成无不成。一觉一切觉无觉无不觉。言穷虑寂不坏假名。故云始成正觉。如出现品及不思议法品广显。摄前诸说。皆一乘之所现也。第四别显处严者。然此下处主及众。即三世间严。三中前二即如来依正。众即净土辅翼不空。今初器界严者。即广于前场之严。显成前觉之妙。异于余经之处。于中四事各十种严。明即染显净即为四别。第一地严。第二树严。第三宫殿严。第四师子座严。然此诸严各具三释。一约事可知。二表法。谓地表心地法身。树表菩提。宫殿表无住涅槃。座表法空等。三就因行。谓一以穷心地法身之因。报得增上金刚之地。二以般若为因。三以悲智相导为因。四亦以法空为因。然或一因行成一切严或一切行成一严。或一行成一严。或一切行成一切严。以通融别纯杂无碍。今但明一行一严显所表故。然各摄无尽之德故。四事皆有十句。初总后别。今且就文各分为四。今初心地十句分四者。第一总显地体。二四地相具德。三四地上具严。四一举因结用。今初标以坚固释以金刚。诸教或云。木树草座。多云座是金刚。今全地金刚。则权实斯显彻华藏故。广如彼品次上妙下地相具德。约因释者。一宝轮者。一摄一切圆行致故。二及众宝华开觉悦他故。三清净摩尼圆净明彻故。以上三行用严心地故。结云以为严饰。上皆形色四即显色。谓青黄等殊。名诸色相种种重叠深广如海。互相映发。等彼波澜或诸色俱生。或更相摄入。含虚莹彻。现势多端。名无边显现。此由隐显自在定散无碍。随机利行之所致也。三摩尼下。明地上严者。一宝幢曲有五句。一摩尼为体。二三光音明用。四五网缨辩饰。就因行者。降魔伏外为幢。智光常照慈音外悦愿行交罗戒香芬馥。四摄周垂故。二摩尼雨宝表神通如意。随机变现雨法宝故。三妙华散地。亦多因行遍严心故。四宝树行列者。德行建立故。四佛神力下举因结用。佛力者出所因也。严具多门别说难尽故。总云一切悉现。或于树中现。或于上诸严具及地中现。明一一行中皆道场故。第二觉树严者。即大智因感有十一句分四。初一总显高胜。长耸迥露圆妙独出故。约因即智超数表为高。本性不昧为显。成物具德曰殊。更无二真为特。约果树即菩提。二金刚下六句。明体摄众德。一身是金刚金刚三昧本智因故。正行成立为树身也。二干是琉璃。本智发解内外明彻故。三杂宝枝条。解随境差故。四条假叶以为严。智资定而深照。宝叶虽异共成一荫。百千定门同归一寂。自荫荫他也。五宝华异色在树。分枝承光色。同于地布影。表神通等法依定有差。俱承智光影现心地。六华虽不同。果皆如意无边行海。同趣菩提。若自利果成内则含辉。若身心湛寂外便发焰。若触境斯明。若利他果立未熟。则含辉解生佛相。已熟则发焰还流教光。体如之行所成果。无异因之果故。与华间列故。下经云。菩萨妙法树。生于直心地等。三其树下三句。明妙用自在展转成益。初依菩提智放教智光。次依智光雨圆明法宝。后教成悲智。即菩萨现前。无心行成。故如云出。四又以下一句。举因结用。谓佛力为因。流音演法以如如力。则智演法音。音还如性故。无尽极广多故。无尽竖长故。无穷无间故。称恒也。第三如来所处下。明佛宫殿严十句分四。初一总明分量。宫可覆育即是慈悲。殿可朝宗。所谓圆寂。悲智相导。若楼阁相依。广者无边法无外故。博者不隘法内空故。严者。庄饰具众相故。丽者。华美法义备故。充十方者。称法性故。二众色下二句。体相圆备

一体是摩尼积德镕融之所成故。二相严多种。神通等法悲寂用故。三诸庄严下六句。妙用自在。一众行发光洒法如云。云更多义至下当辩。二光幢独出。萃者聚也。即承光聚影而成。谓悲寂交际承智起应降魔超出故。三内容众海无边菩萨。即道场外者亦在其中。即依中有正。亦果中有因。即明涅槃众圣冥会。四声光宝网网者。为防禽秽以益殿严。犹大教网。外防恶见内益悲寂。教皆圆妙以宝而成。故能出佛智光。圆音妙说言不思议音。略有四义。一音声繁广。二所说难量。三声即无义。四一具一切。五出生果用。即正报大用在此依中。依正混融参而不杂。明依大涅槃能建大义。故曰出生。六无染现染。众生是正居处。是依染违性净不言出生。妄无自体还依真现。四又以下举因显广。谓德广难陈故。今总结由佛力故。一念顿包事理染净一切法界。况多念耶。然上充遍十方。即通局无碍。集菩萨众出佛神通。即摄入无碍。现生含宅即染净无碍。悉包法界广陜无碍。一念即能延促无碍。又集菩萨因果无碍。出佛神通依正无碍。十种宫殿。此应说之。第四其师子下。师子座严十句分四。初一总显形胜。师子座者。人中师子处之。又说无畏之法故。得法空者何所畏哉。空乃高而无上。深不可测。广而无外边不可穷。妙乃即事而真。好谓具德无缺。二摩尼下六句体德圆备。一座台。摩尼即处中正可依处。摩尼随映有差。法空随缘成异。中道妙理正是可依。二周座华网。即外相无染交映本空。三净宝为轮。轮谓台之处中周匝。轮围即具德周遍。四华缨周垂。诸觉诸通垂化周摄。五宝严填饰堂等略举。凡诸总包无处不严。故云备体。显于法空全收万像。无事非理故。六宝树间饰间上物象也。即菩萨妙法树。随化分枝随因感果。并依无相义曰周回。凡圣相资名为间列。三摩尼光下二句。妙用广大。一净宝出光如云。涉入法空亦尔。一一智中知一切法。一一法体显一切智。为互照也。二主伴宝用互相发挥。谓佛化摩尼能作佛事。智论云。轮王宝珠但随人意能雨宝物。天宝堪能随天使令佛宝十方能作佛事。菩萨宝珠亦能分作。如文殊师利冠中毗楞伽宝珠。十方诸佛于中显现。今菩萨髻珠即是其类。下文云集菩萨髻珠亦尔。用此严座者。凡初成佛。皆一切诸佛现形灌顶一切菩萨亲授敬养。故因果宝珠俱来莹烛。如来从果起用。故云化现。理圆解满义曰珠王。菩萨心顶智照圆净。故曰髻中妙宝。寂照照寂。皆莹净照烛。四复以下一句。佛加广演佛境如空。故云广大。有感斯至为无不及。显教皆从法空所流。是故所流还周法界。非智不显故云佛力。显处严竟。第五尔时世尊下。明教主难思。前但云佛。未显是何身佛。又但云始成正觉。未知成相云何。故今显之。谓具十种深广功德。即是遮那十种无尽法界身云。遍于法界成正觉也。非权应身。文分为二。先总后别。今初总辩。即菩提身具无尽德为世所尊。座相现时身即安处。智处诸法无前后故。于一切法示所觉境。即二谛三谛无尽法也。成最正觉示能觉智。开悟称觉离倒为正。至极名最获得名成。此当相解。若拣别者。凡夫倒惑佛觉重昏。二乘虽觉不名为正。但知法有未知法空。但悟我空未知我有。有厌生死空沈涅槃。颠倒未除岂得称正。设许称正亦未名最。菩萨虽正有上有修。不得称最。设位极称最亦未得名成。我佛独能故。云成最正觉。谓如量如理了了究竟。已出微细所知障故。后智入下。别中。即约十德别显十身。文即分十。一三业普周。二威势超胜。三福德深广。四随意受生。五相好周圆。六愿身演法。七化身自在。八法身弥纶。九智身穷性相之源。十力持身持自他依正。今初。即别显菩提身之相也。以成菩提时。得无量清净三轮故。文中先法后喻。法中三。先意次身后语。今初意业。即释上成正觉。言前云于一切法。此云三世。乃横竖影略耳。智入平等是正觉成也。智即二智三智四智。无障碍智。二智者即如理如量也。此复有二。一以如量智达俗。名入三世。以如理智证真名悉平等。故佛地论云。以二智觉二谛是也。二者证差别性即无差别故。三世即平等。瑜伽云。如其胜义觉诸法。故名等正觉。言三智者。即俗智真智中道智也。此亦二义。一真俗互泯双遮辩中则三世平等二相两亡。方为智入二真俗虽即。而不坏相即双照明中。此二觉三谛之境。境既双泯而双现。智亦寂照而双流。为无障碍智。觉无障碍境为正觉也。言四智者。即圆镜等四智也。通缘三世境故。并入三世。言平等者。镜智离分别。故依持平等。平等性智证平等性故。妙观察智观察平等。成所作智普利平等。四智圆融一句摄尽。下身语等皆是四智之所发现。四智圆融无二性故。修生本有非一异故。不失经宗。然上能觉即成上菩提。就其所觉即法身也。理智无二为真法身。二其身下身业也。通三世间故云一切。此正觉身以是十身之总故。此其身通于三身十身无不充满。法身普遍世所同依故。智身证理如理遍故。色身无碍亦同理遍。并是圆遍而非分遍。谓一切世间一一纤尘等处。佛皆圆满。总看亦现别看亦现。又国土等。即是我身土等。体外无别我故。我即土等。我之体外无土等故。余一一身互望融摄。犹多灯光各互相遍。三其音下语业也。顺有三义。一顺异类言音。经云。一切众生语言法。一言演说尽无余故。二顺所宜说法。如来于一语言中。演说无边契经海故。三则顺遍佛以一妙音周闻十方国故。二譬如下喻显。通喻三业。然佛三业非喻能喻。唯虚空真如略可显示。更以余喻便为谤佛。然虚空喻有同不同。故下经云。解如来身非如虚空。一切妙法所圆满等。此显不同。今分取同义。同义多种如下十忍品。今有二喻开成四义一含摄喻。兼无分别义。二普遍喻兼遍入义。以此四喻喻意业者。下经云。佛智广大同虚空故。此总喻也。量智包含而普遍理智无分别而证入。又大圆镜智纯净圆德。现种依持能现能生身土智影。即含摄义。下经云。菩提智普现一切众生心念根欲等。而无所现。无所现言无有分别。平等性智观一切法自他有情。悉皆平等亦无分别。无分别言显无差别故。下经云。于一切义无所观察等。是以太虚能含众像。众像不能含太虚。太虚不分别众像。众像乃差别。太虚以况我法不能容佛智。佛智乃能容我法。有我法者分别如来。是如来者不分别我法。二普遍喻中。妙观察智无不遍知。即普遍义。成所作智曲成无遗。即随入义。又下经云。佛智广大同虚空。普遍一切众生心。此即体遍。悉了世间诸妄想。此约智遍。又云。得一切法界等心。此约证遍。智性全同于色性故。此约理遍。云何遍入不坏能所。有证知故。故下经云。世间诸国土。一切皆随入智身无有色。非彼所能见。由随于如即入无所入故云平等。是以虚空遍入国土。国土不遍入虚空。有国土处。必有虚空。有虚空处或无国土。虚空之于国土。平等随入。国土之于虚空。自有彼此。虚空可喻佛智。国土可喻三世。三世有处佛智必在其中。佛智知处三世或无其体。佛智之于三世平等随入。三世之于佛智。自有始终。此犹约不二而二说耳。若二而不二。国土虚空三世佛智同一性故。皆互相入举一全收。普遍亦然。三世间圆融。则言思道断。故名佛智为不思议也。次以二喻喻身业者。一毛尚容法界全分。必含众像出现身业第二喻云。譬如虚空宽广。非色而能显现一切诸色。而彼虚空无有分别。亦无戏论。合云如来身亦复如是。一切众生诸善根业皆得成就。即含摄义。而如来身无有分别。即第二义。佛身充满于法界。即普遍义。又云。譬如虚空遍至一切色非色处。非至非不至。如来身亦复如是。遍一切法一切国土等。即普遍义。亦非至非不至。即平等随入义。次以四义喻语业者。如来于一语言中。具一切语言故。舍支天鼓无心出故。如来音声无不至故。应知。如来音声无断绝。普入法界故。又云。如来音声无邪曲。即平等义。随其信解令欢喜故。即随入义。以空一喻遍喻三业。故云正觉得无量清净三轮。明文昭然。非是穿凿。菩提身竟。第二身恒下。威势身超胜。谓随诸有情所乐。示现受用身土影像差别。无不周遍。言一切道场者。略有十种。一智身遍坐法性道场。二法身非坐而坐道场。三法门身安坐万行道场四幻化身安坐水月道场。此四义便故来。若正约威势身。略辩六类道场。一遍一切同类世界道场。如名号品等说。二一切异类世界。谓树形等。如世界成就品。三一切世界种中。四一切世界海中。并如华藏说。五一切微尘中。文云。如于此会见佛坐。一切尘中亦如是等。六刹尘帝网无尽道场。并前十种故云一切。言菩萨众中威光赫奕者。正显威势超胜胜于胜者故。独言菩萨非不超余。如日轮出照明世界。约喻以显映山出没无隐显故。处处全现无异体故。喻遍坐道场。大明流空余辉掩辉。赫日之照难究其涯。喻彼威光超映菩萨。菩萨不能测也。既云照世则终益生盲。先照高山独言菩萨。第三三世下。福德身深广。三世佛德昔皆遍学。今三际已断垢习斯亡。故众福皆净。第四而恒下。随意受生。一随他意处处受生。二随自意能无不生。谓慈悲般若恒共相应感而遂通。穷未来际。第五无边色下。相好庄严身色无尽。故名色无边。十莲华藏微尘数相名相无边。而皆称真则一一无边。诸相随好放光。常光皆称法界故云圆满。广处陜处皆圆现。故名无差别。第六演一切法。如布大云即愿身。演法谓雨大法雨断一切疑。故下经云。毗卢遮那佛愿力。周法界一切国土中。恒转无上轮。然经二句上法下喻。文含多意。一云喻于身雨为说法。法喻影略。又先兴慈云后霔法雨一云一雨所润不同亦随物机宜云雨各异掩尘蔽日普覆无心等。第七一一。下化身自在。谓于大众会能现无边作用差别。皆自在故。文中二。先明广容谓于如来身一一毛头。容一切刹而无障碍。无碍有二义。一以一小毛现多大刹。则一多大小无碍。二此毛多刹。与彼毛多刹参而不杂。则隐显无碍。后各现下。普遍以广容不碍普遍故。还于前毛内刹中神力调生。若广遍十方示现种种变化三业成所作事。居然易了。第八身遍下。法身弥纶以法为身。本来湛遍故无来往。依法现色还如法身在此即是在彼。亦不待往来。第九智入下。智身穷性相之源。相别曰诸性皆空寂。性静故寂。相无故空。第十三世诸佛下。力持身。能持自他依正。于中先持正报。神谓妙智。变谓现身。转变变现俱名为变。皆能持之。尚持于他况于自事。后段亦然。后一切佛土下。能持依报。横尽诸土竖穷诸劫。所有严事常持令现。上约十身。若约三身者。则初三段皆名报身。而恒下化身。身遍十方下法身。就报身中。前一自受用报。后二即他受用报。故云处菩萨众。以诸教中说三身四身。成说等别。今皆圆融。于一始成无不顿具十身为正。三四义兼。又毛内调生光中持刹。如空普遍等。亦即国土等十身三世间之圆融。岂报化之云别。是知略以十德叹于教主。其一一德无不圆融。当去情思之矣

大方广佛华严经疏卷第四大方广佛华严经疏卷第五

        唐清凉山大华严寺沙门澄观撰

第六有十佛世界下。明众海云集。众虽深广难测略启十门。一集意。二集因。三辩类。四定数。五权实。六地位。七前后。八有无。九闻不闻。十释文。今初。来至佛所。何所为耶。有十义故。一为影响为主伴故二。为作辅翼得圆满故如普贤等常随之众。三为守护如来。如执金刚等。诸佛住处常勤护故。四为庄严。如道场神等。常为严净佛宫殿故。五为供养。如偈赞即正行供养。华幢等即财供养故。六为发起此经。诸请难者即其事故。七为闻法获益。当机领悟即其类故。八为表法。诸首诸林表信行等。皆同名故。及座出菩萨等显奇特故。亦通表万行俱成佛故。九为顺证。佛菩萨等证说不虚故。十为翻显。即声闻不闻显法不共故。为斯多意所以众海云集。非唯证信而已也。第二集因亦有十因。一曾与毗卢遮那如来。同集善根故。二蒙佛四摄曾摄受故。三往在生死闻圆法故。四曾发大心护一切故。五往发大愿愿事佛故。六随逐如来无厌足故。七乐闻正法心无倦故。八善能散灭我慢心故。九福智已净身周遍故。十同一法性善根大海之所生故。为此多义得预斯会。中有集因亦通集意。及随诸众各有别因。可以思准。第三辩类。即上集意便成十类。一影响众。二常随众。三守护众。四严会众。五供养众。六发起众。七当机众。八表法众。九证法众。十显法众。准前可知。第四定数者。称法界众焉能数知。即文而言。九会都数。总有一百七十五众。都序之中有四十一众。谓同生有一。异生三十九。师子座中一。若兼取前菩提树中所流。及宫殿中无边菩萨。总四十三众。此四十三遍于九会。第一会中有二众。谓新集十方众。佛眉间众添成四十五。第二会有新旧二众。第三四会各有四众。谓新旧及证法众天众。第五会一百一十一众。谓新旧众升天品内供养众。有一百七并天众证法众。第六会四众。谓天众同生异生证法众。七八两会。各唯一众。谓普贤等旧众。第九会三众。谓菩萨声闻及天王等旧众。旧众虽重随会别故并皆取之。然此诸众或总为一。一乘众故。或分为二。以有实众及化众故。或可为三人天神故。或为四。佛菩萨人非人故。或五非人开天神故。或六加畜生故。或七天分欲色故。或八菩萨有此界他界故。或九他方有主伴故。或十加声闻故。或一百七十五如前说故。或无量无边义类多方故。一一或以佛刹尘数等为量故。又如新集菩萨。毛光出众。例上皆尔。故一一众皆无分齐。此犹约相别。若融摄。一一会中皆具一百七十五众。以称法界缘起之会。互相在故。上且约一界。若通十方及异类刹尘。帝网无尽无尽。是为华严海会众数。第五权实者。夫能对扬圣教影响其迹。靡不是权。当机之流多皆是实。诸教所明秽土之中。杂类菩萨声闻皆通权实。地前是实地上是权。法身无生生五道故。净土菩萨唯实。实报生故。杂类声闻是权。摄论云。欲令净土不空。化作杂类众故。若依此经。同生异生皆通权实。海印定现实德摄故。随缘随位而示现故。第二会初云。莫不皆是一生补处故。对前十类辩权实者。影响一众自有二类。一果德众。谓能加证法。诸佛互为主伴非权非实。若位极菩萨影响一向是权故。有经云。昔为释迦师。今为佛弟子。二尊不并化故。我为菩萨等当机唯实。余八通权实。第六地位者。有说。一切皆是果位。以是舍那海印现故。或说。一切皆因果海。非可见闻。世尊亦是因者。识所现故。或皆通因果。果得不舍因随类现故。因位愿力助佛化故。当机之流正修趣故。或俱非因果。缘起大众因真性故。将此对前权实。则果位一向权。因位通权实。若对前十类影响证法通因果。余八唯因。因位高下难以准定。第七前后者。初列菩萨后列余众者。表从本以起末。下赞即后明菩萨者。表寻末归本。良以本末无二故。二文互举。又从本流末。必先小后大故。自在天为末。摄末归本必从深至浅故。先明自在。然皆显法界缘起逆顺自在故也。又表四十位。一一皆彻因门。并该果海故。互举前后。令物不作优劣之解故。第八有无者。亦有十类。一约界无无色。二约趣无地狱。此二非器故。若约转生有地狱天子。若约所益亦通无色。三界皆益故。三约洲但列阎浮。余三略无故。或成难故。四约乘无二乘不共教故。下为显法亦不见闻故。智度论云。若小乘经初唯列声闻。若大乘经初具列菩萨声闻。若一乘经初唯列菩萨。故指此经为不共教。或大乘经唯列小者。为引摄故。如金刚经或唯列大亦属大乘。主伴不具故。主伴具者。必是一乘。五约部无四众。未说小教故。六约主无人王王未知故。七约三聚无邪定。彼障隔故。生盲之流但冥益故。八约内外。无外道非彼测故。九约诸天。无无想入邪定故。十约善恶。无恶魔不为违害。天中摄故。上十且随相说。圆融应有即无所不具。第九闻不闻者。约权前后皆互得闻。约实当会自闻。纵不起前而趣于后。亦各不相知。若约顿机。许一时顿领。上之九门且从显著。略为此释。中本广本。或隐或显不可执文。第十释文。第一会中前总四十众。大分为二。初一同生余是异生。故论云。解脱月是同生众故。又云。同生众请。则知兼有地前。明知不约地位。余释云云。不符论意。云何名为同异生耶。然有二义。一谓杂类。作诸异生种种形故。菩萨得法性身。同人作一类菩萨形故。二菩萨为同者。通诸位故。神等为异。法界差别德故。其四十众文皆有三。一标数辩类。二列名总结。三摄德周圆。今初同生众中。第一标数辩类中。先辩数。佛世界者下辩世界。略有三类。一世界。二种。三海。今云世界则非种非海。权实共许。一三千界一佛化境故。或名佛刹佛土。皆准此也。微尘者。七极微量也。谓抹三千界并为微尘。一尘为一菩萨。则数已难量矣。况举十数表无尽耶。菩萨摩诃萨者。辩类也。即拣非余众。具云菩提萨埵摩诃萨埵。今从略耳。然有三释。一菩提是所求佛果。萨埵是所化众生。即悲智所缘之境。从境立名故名菩萨。二菩提是所求之果。萨埵是能求之人。能所合目故名菩萨。三萨埵此云勇猛。谓于大菩提勇猛求故。摩诃云大。大有四义。一者愿大。求大菩提故。二行大。二利成就故。三时大。经三无数劫故。四德大。具足一乘诸功德故。前二通地前。后二或唯地上。更有诸大亦不出此。此等并是舍那佛内眷属。动止常随。故云所共围绕。二其名下列名结数。先列其名后结略显广。今初。夫圣人无名为物立称。虽得名千差而多依行德。行德皆具而随宜别标。先十同名普者。显具法界总相德故。后十异名者。显具法界别相德故。总别相融同一法界。今初十名之普是别之总。普下十异显即普能别。普义方成。此是古今诸佛。同行普贤之行。随于诸位差别不同。纵成正觉。亦普行摄故。先明之。言普贤者。体性周遍曰普。随缘成德曰贤。此约自体。又曲济无遗曰普。邻极亚圣曰贤。此约诸位普贤。又德周法界曰普。至顺调善曰贤。此约当位普贤。又果无不穷曰普。不舍因门曰贤。此约佛后普贤。位中普贤悲智双运。佛后普贤智海已满。而运即智之悲。寂而常用穷未来际。又一即一切曰普。一切即一曰贤。此约融摄。所以先列者为上首故。法门主故。法界体故。一切菩萨无不乘故。无一如来非此成故。令诸闻者见自身中。如来藏性行普行故。上虽多义离释。今从别称合释。无处不贤名曰普贤。即体普也。此一为总。余九为别。二德普。谓称性之德充于法界。以为最胜。委照无遗如灯之光。三慧普。遍照严刹决定高出故。四行普。内行圆净智焰外烛。故称为妙。五音普。具一切音。演佛净土深广高出之行故。六智普。照佛法界无尽境故。七心普。智宝严于心顶。通行等华高出物表故。八觉普。遍觉性相声皆悦机。故无不归者。九福普。障无不净称真无尽故。十相普。无光相之光相。遍益众生故。六相圆融思之。二海月下。十异名菩萨。一海月光大明者。十德十山皆依大海。十地十度皆依佛智。海中看月净而且深。依智严刹深而且净如海。即大如月即明。故以名也。二讲如雷震故曰云音。辩才汛滟犹如海光。又海上有光天涯无际。佛智起用一念普周。净惑无穷名无垢藏。三修治二严犹如净宝。秘密高显故有髻言。四法王出现作用自在。二严圆满为功德光。五勇猛化生不染化相。雨法玄妙如解髻珠。六慈云智日互相资映。长劫普应高出如幢。七坚利智慧与精进俱。故得称大智为行本。若齐为寿因。八戒等行发是为香焰。种智高直故曰光幢。九智光遍照是大明德。称真适物名深美音。十大智发光遍照佛境。令福非福相福亦称大。二如是等下。结略显广。第三此诸菩萨下。摄德圆满中二。初别叹胜德。后总结多门。初中亦二。初二句就缘叹。余就行叹。今初。初句往因同行显主伴有由。后句从德海生明生为辅翼。言毗卢遮那者。毗即遍也。卢遮那光明照义。回就方言应云光明遍照。然有二义。一身光遍照尽空乃至尘道。二智光遍照真俗重重法界。身智能所合为一身。圆明独耀具德无边。故立斯号。又毗者种种义。卢遮障义。那者尽义入义。即种种障尽。种种德圆。故普贤观经云。释迦牟尼名毗卢遮那遍一切处。即身亦遍非唯光遍。又云。其佛住处名常寂光。即土亦光矣。又云。常波罗蜜所摄成处。我波罗蜜所安立处。即德圆义。又云。净波罗蜜灭有相处。即障尽义。又云。乐波罗蜜不住身心相处。不见有无诸法相处。即证入义。又云。如寂解脱乃至般若波罗蜜是色常住法故。明皆即应即真为本师矣。此经文证本品当辩。言共集善根者。即备道资粮。言修菩萨行者。即作所应作。云何共集。互为主伴故。主伴有三。一回向主伴。二同行主伴。三如相主伴。皆称共集。后句言善根海生者。谓佛德无边。积妙法宝智定盈洽。故称为海。从生有四。一从自佛善根海生。谓已圆十身故。二从本师海生。佛为胜缘曾已摄受授法。令行得成满故。三与遮那同于余佛海生。以上云共集故。四从法性佛海生。以上德海诸佛共同。平等一味。但称性修即是从生。不拣自他故。梵本云与佛同一善根海生。第二诸波罗蜜下。就行德以叹。夫大士。必崇德广业虚心外身。崇德故进齐佛果。广业故行弥法界。虚心故智周万法而不为外身。故功流来际。而非已。故德难名矣。略分为三一明自分因行德。二胜进果行德。三二行无碍德。初中亦三。一自利行圆。二利他行满。三证理位极。今初有三句。一诸度行满。谓六度十度八万四千。多劫积集究尽事理。故云圆满。二慧眼下。十眼明彻分别名慧。照瞩称眼。障医斯尽智无不瞩。故云明彻。五眼之中慧眼观理。理无异味。故云等观。十眼之中慧眼观事。事无不见故名等观。是则委见其事为明。深达其性为彻。欲以一眼含诸具通事理。但举其慧。三于诸下。深定已满。三昧者此云等持。远离沉掉平等持心。趣一境故。而云诸者。其余诸缘亦一境故。真如三昧为其定体。随境入别尘数多端。故云诸也。横则无定不穷。[監-皿+豆]则深入无际。故云具足。定障永亡故云清净。第二辩才下。利他行满有三句即三轮化益。一语含四辩即正教轮。辩谓巧显深理。才谓巧应机宜。万法咸演则广大无涯。千难殊对则无竭尽。故如海也。又海遇风缘则洪浪云涌。智逢机请则口辩波腾。请者既许。无边辩亦广大无尽。二具佛下。身业神通轮。谓三业无失智深叵挠。为具佛功德故。得外仪俨若。肃然可敬。三知众生下。意业记心轮。根义总明文含性欲。言如应者。根有生熟化不失时。器有大小授法无谬。化谓教化。即应摄受者而摄受之。伏谓调伏。即应折伏者而折伏之。由此具行入正法故。第三入法界藏下。证理位极。亦三句。一证理法。谓以大智证入平等真法界藏。依佛性论说有五藏。一如来藏。谓在缠含果法故。二自性清净藏。谓在缠不染。三法身藏。谓果位为功德所依。四出世间上上藏。谓出缠超过二乘菩萨。五法界藏。谓通因果外持一切染净有为。故名法界。内含一切恒沙性德。故复名藏。此义宽通故今证入。言智无差别者。所证之藏平等。要无分别方契此。则智自无差。即由上义能所不殊。又此能证智与所证藏冥合一味。无有境智之异。故云无差。此复有二。一同无相故。下经云。无有少法为智所入。亦无少智而入于法。二同法界故。则能所各互摄尽故。下云无有智外如为智所入。智摄如尽故。亦无如外知能证于如。如全摄智故。若皆一味。岂令智同于境而无智耶。古德释云。智相尽故。不有能令智相尽。故不无。不尔岂令诸相皆尽而智独存。是故于境则不碍真而恒俗。于智则不碍寂而恒照。即境智非一。境则不碍俗而恒真。智则不废照而恒寂。即境智非异。境则空有无二。智则寂照双融。故云无差别也。上来所释。约真理寂寥与止寂相顺。俗谛流动与观照相顺。起信等中且为此释。未尽其源。以令照真不得名照。照俗之时不得即寂故。今正释者。谓言用则同而异。由境不能照智有照故。言寂则异而同。境智无异味故。同故无心于彼此忘心契合故。异故不失于照功。智异木石故。故名真智证理。境则唯寂智则寂而常照。若约照俗。则以后得智照差别之境。若约融真俗者。境则真俗不二。智则权实双行。亦为一味而不失止。以虽双行而即寂故。若约三观及融境智。至下当辩。二证佛下。明证果法。言解脱者。谓作用自在。如不思议法品说。于一念中建立三世一切佛事等。总有十种广如彼说。即用而真故。甚深用无涯畔故。广大上穷彼际故云证也。三能随下。明得位极。谓普贤身遍于六位。随在一位。以愿海力持于一切。故旧经云在于一地。普摄一切诸地功德。今此文顺西国。若顺此方。应云能以方便随入一地。以愿海力摄持一切地也。然有引梵本广明此中句数开合不同。不必应尔。何者夫译梵为唐诚乃不易。苟文小左右贵于旨不乖中。若理不可通。则正之以梵本。译人意近则会之。以旧经言异意同。何必广引。言恒与智俱者。明智穷来际文含二义。一望前。谓虽在因中一地。而愿力持一切地功德。皆与智俱尽未来际。不离一地。如一地余地亦尔。是故因门尽于未来。恒是一一诸位菩萨不见作佛时。二望后。以尽未来之大智。入如来之果海也。虽有二义顺前义胜。第二了达下。明胜进果行。分二。一得果法。二起果用。今初有四句。一入佛密境。此有二意。一佛即密境。以三业业具非余测故。谓非色现色。摩尼不能喻其多。非量现量。应持不能穷其顶。不分而遍。一多不足异其体。全法为身。一毛不可穷其际。此身秘密也。佛言声也非近非远。目连寻之无际。身子对而不闻。非自非他。若天鼓之无从。犹谷响而缘发。无边法海卷之在一言。无内圆音展之该万类。是谓佛口密也。意则无私成事。等觉尚不能知。密之至也。皆广大无涯超绝奇特。故云希有。二佛之密境即谓一乘。如来知见禅定解脱。深入无际帝网之境时乃说之。故云希有。久默斯要甚为秘密。又权实隐显唯佛方知。故云秘密。今洞见其源故云了达。二善知下。入佛平等亦有二意。一佛佛平等。谓一切诸佛体性平等。法身无二故。智慧平等德无增减故。内用平等悲愿普应故。二者佛所证法平等。即第一义。此二无二。称此而了。故名善知。三已践下。明得佛位。谓佛有十地。如大乘同性经说。一甚深难知。广明地。乃至第十名毗卢遮那藏海智地。此十同是佛地。约德用成别。今普光明当其第一。普即广义。光明即明甚深难知。此文虽略。义在普中。举初摄后。理实皆践。又普光明亦十地之总。总不出于普法智光故。四入于下证佛三昧。谓海印等定。皆深广如海。并通一实故得称门。第二于一切下。明起果用。文有三业。一现佛身业遍世同事。二同佛意业总持大法。三得佛语业能转法轮。不退有四。一称理不退。无改说故。二应机不退。无虚发故。三利益不退。闻已必定故。四调伏不退。天魔外道不能动故。复有四种不退。谓信位证念。今当第四念不退也。第三一切如来下。二行无碍德。谓引摄佛德不碍修因故。文有五句。一引摄佛德。然有二义。一则行成摄果。二则诸佛同加。二一切下。随佛遍生不拣净秽也。三已曾下。供佛集福。十方无边三世无际。此一切佛皆供养故。欢庆有遇不住福相故。长时无厌。四一切下。长为辅翼义通真应。五恒以下。悲愿调生。不以偏小利物。唯以同体普愿摄物令证菩提。方显智体圆足。第二成就下。总结多门无得而称也。菩萨之德焉言不可周。宜以类取。故云如是无量。第二大段异生众中。总三十九众相从为三。第一杂类诸神众。第二阿修罗下。八部四王众。第三三十三天下。欲色诸天众。今初有十九众。通名神者灵只不测故。文皆三段。第一标数辩类。第二列名结数。第三摄德圆满。今第一金刚神众。初辩类中。以执持此杵守护佛故。然一一类皆通有所表。如地表心地。海表德海等。观其叹德则知通意。今此表般若坚利导于众行到彼岸故。二所谓下列名结数。然诸众立名。皆随所得法门为物立称。一那罗延者。此云坚固。由见佛妙色皆不可坏。故受此名。二见佛身毛犹如日轮现种种光速摧障恼。故名曰幢三见佛身光映蔽一切。犹如须弥显于大海。神通等法如华开敷故。四圆音随类如雷震故。五现为世主。以美妙根令物悟故。六智光演法令爱乐故。七宝饰妙相如华严树。方便警物如雷震音。八福深相妙炳着光明。如师子王处众无畏。九慈眼视物为吉祥目。神通之焰密现物前故。十雨此严具及光明故。下诸众皆类此知。至得法处名当自显。恐厌繁文。下略不释。第三皆于下摄德圆满。十句分二。初二句总彰愿行。由昔愿力得预法会。常为亲侍。由今行满故能遍侍。后积集下别显满相。一福积净业。二智达定境。事定之境随事百千。理定之境即真如实相不思议定则以无碍而为其境。今皆智照故云明达。三通随佛住。四入用难思。五处众超绝。六应物调生。七随佛化形。八护佛住处。文并可知。第二身众神文三。同前初辩类。有二义。一身谓神之自身。众即同生同名。及所随者。凡有其一必更有二。共有其三。三故名众。能所合目。名身众神。二约所主。谓此类神。专以变化多身为佛事故。二名三德。文并可知。第三足行神亦有二义。一谓依止足行众生及守护故。如下善见比丘足行之神。持华承足故。下德中恋仰如来二足所行处。即道路神。通表修行履佛所行故。第四道场神。从所依所守得名。下诸神众类皆同此。言道场者。非唯护佛道场。但有庄严道场之处。即于中护故。下德中愿供养佛。表护万行道场及修行者故。第五主城神。表行德防御法城心城故。如摩耶处说。德中以己德行严佛宫殿者。一佛殿为所守之最。莹饰为尊佛故。二主伴善根互融摄故。三莹饰自心佛安处故。第六主地神。表深重愿荷负行德故。亦表心地为依持故。第七主山神。通表万德高胜性皆闲寂。别表智德最高故。德中云。得清净眼。名中多有光称。第八主林神。表以无漏智导于众行。森耸建立故。德中云。皆有可爱光明。第九主药神。表行德伏惑资益法身。若约利他则三业不空。如药树王故。下德中性皆离垢。即伏惑去病也。仁慈祐物。即进善补益也。名中总名主药。药既不同。神神各别。吉祥者主香茅之类也。清净光明谓乳石之流。名称普闻。如药树王雪山忍草等。明见十方谓眼药等。约法准之。第十主稼神。稼者树五谷也。表万行法味资益自他。他自益称心故。德中大喜成就。十一主河神。即河伯之流也。表法河流注润益群品。又于生死瀑流拯彼漂溺。江河淮济清浊俱河故。生死法流此神皆主。德中勤益生者。谓遇沿流则平波息浪。逢溯泳则微风轻动。水性之属。深止而住居。陆行之流富生而应采。导百川而去害。灌万顷而开利。为勤作意利益众生。约所表法随意消息。十二主海神。即海若之辈。表具含万德一一深广也。名中三。名远尘离垢者。瑜伽八十六云。现断烦恼离故远尘。彼随眠离系故离垢。今约近事。尘谓尘境垢即烦恼。六根对境。了彼性空故曰远尘。众惑不行诚为离垢。心境相藉离垢由于远尘。十三主水神者。通上河海等水。及雨露霜雪等也。表法水含润等多义理故。德中。拯溺为救济危为护。谓已溺邪见贪爱水者救之。将沈者护之而为利益。即云雨等润发生万物也。法合可知。十四主火神。即宋无忌之流也。以显智慧火烧烦恼薪。成熟善品破无明闇耳。德中。夫火有二能。一能为益。二能为损。今用益止损表法亦尔。示慧光以去闇用益也。除惑苦之热恼止损也。十五主风神。通表方便无住无所不摧。别表如下十六主空神。表法性空别即离染周遍等。亦各如名辩。德中若情尘乱起翳本性空。智日高升则情云自卷。空有日而廓尔无际。智合理而杳然无涯。故云尔耳。十七主方神。即东方青帝等类也。表显邪正方隅。使行无迷倒。德中身智教光无不引摄名普放也。无时不放所以称恒。如日周天故相续不绝。十八主夜神。表于无明黑闇生死长夜。导以慧明令知正路。德中。夜分亡寝是曰勤修翻彼长迷故以法为乐。十九主昼神。于昼摄化显行德恒明也。德中。先修正解后勤正行。有信无解增长无明。有解无信还生邪见。信因解净解藉信深。昼之义也。上来多主器界故但名神。准梵本除金刚神。余皆女神。表慈育故。菩萨同于彼类以摄众生。自下摄领有情。皆受王称。并是丈夫。第二八部四王众。文有八段。前四杂类。后四能统是天王。所统是八部。今初。阿修罗亦云阿素落。梵音楚夏耳。婆沙译为非天。佛地论云。天趣所摄。以多行谄媚无天实行。故曰非天。依阿毗昙亦鬼趣摄。谄曲覆故。正法念经鬼畜二摄。以罗睺阿修罗是师子子故。伽陀经天鬼畜摄。具上说故。由此或开六趣。或合为五。多好斗诤怀胜负故。或居众相山中。或居海下。如正法念说。然有大力者。广修福故。今之修福有怀胜负谄媚心者多生其中。罗睺此云摄恼。以能将手隐摄日月。令天恼故。二毗摩此云丝也。质多罗种种也。谓此王能以一丝幻作种种事故。德中。实者因果俱慢故。权应偏摧非不断余。故云及也。二迦楼罗昔云金翅。正云妙翅。以翅有种种宝色庄严故。此就状翻。若敌对翻此云大嗉项。以常着龙于嗉中故。此鸟能食消鱼龙七宝。然鸟及龙各具四生。谓卵胎湿化。后后胜前前。劣不能食胜。谓卵生鸟不能食胎等。胜能啖劣。化食四生。如增一辩。以化食化暂得充虚。亦表菩萨摄生故。离世间品云。菩萨迦楼罗如意为坚足。乃至抟撮人天龙。安置涅槃岸。大速疾力者。增一中说。此鸟食龙。从金刚山顶铁杈树下。入海取龙。水未合间还至本树。是为速疾。大海处摄持力者。即是摄彼命将尽者食之。而龙受三归及袈裟一缕在身则不可取。菩萨亦尔。如前引离世间品说。又出现云。取善根熟众生。置佛法中。此为命尽。若心有邪归。断见所覆则不可取。普观海者。即周四天下求命尽龙。德中。大方便力。即虽了众生空。而能入有。是十力止观也。普能救摄即鼓生死大爱海水。取善根熟者也如出现品说。三紧那罗者。此云疑神。谓顶有一角。形乃似人面极端正。见者生疑。为是人耶为非人耶。因此立称。依杂心论畜生道摄。亦云歌神以能歌咏。是天帝执法乐神。即四王眷属。表菩萨示众生形而非众生。常以法乐娱众生故。德中。要勤观察则得法乐怡神。自他兼乐为自在游戏。四摩睺罗伽者此云大腹行。即蟒之类。亦表菩萨遍行一切而无所行也。德中。此类聋騃故。令方便舍痴。五夜叉王。初一是北方天王。即毗沙门是也。若从能领是天众摄。今从所领为名。然四王各领二部。从一立称。夜叉此云轻捷。飞空速疾故。亦云苦活。此天又领一部名罗刹。此云可畏。名中云毗沙门者。此云多闻以福德之名闻四方故。此一是天夜叉之王。余九是夜叉。夜叉即王。虽一是天又从所领。况九皆夜叉故非天众。下三例然。如龙中娑竭罗王。岂是天耶。德中。此类飞空啖人。故菩萨示为其王翻加守护。亦令爱见罗刹不害法身慧命也。六龙王亦初一是天。即西方天王。毗楼博叉。唐三藏译云丑目。毗楼丑也。博叉目也。日照三藏译云。毗遍也多也。楼者具云噜波。此云色也。博吃叉此云诸根也。谓眼等诸根有种种色。故以为名。此不必丑也。此王主二部。谓龙及富单那。富单那者。此云热病鬼也。娑竭罗此云海也。于大海中此最尊故。独得其名。德叉迦旧云多舌。以嗜语故。正云能害于所害德叉者能害也。迦者所害也。谓若嗔嘘视人畜皆死也。无热恼者。即阿耨达池之龙也。诸龙有四热恼。今皆离故。四热至下当释。智论云。此龙是七地菩萨。须弥藏经云。是马形龙主。又一切龙总有五种形类。一象形。善住龙王为主。二蛇形。难陀龙王为主。三马形。阿那婆达多龙王为主。四鱼形。婆楼那龙王为主。五虾蟆形。摩那斯龙王为主。德中。外则云行雨施散去炎毒。内则慈云广被法雨普沾。散业惑苦之热恼。七鸠槃茶王。初一是南方天王。即毗楼勒叉。此云增长主。谓能令自他善根增长故。此王更领一部。谓薜荔多。薜荔多者此云魇魅鬼。余如音义。德中。此类障碍深重故。偏明无碍。自学权实无碍。法界智光以利众生。八乾闼婆此云寻香。谓诸乐儿不事生业。但寻诸家饮食香气。即往设乐求食自活。因此世人号诸乐人为乾闼婆。彼能执乐故以名焉。亦云食香。止十宝山间食诸香粖。即帝释执乐神也。帝释须乐。此王身有相现。提头赖吒即东方天王。此云持国。谓护持国土安众生故。此从所领为名。更领一部名毗舍阇。此云啖精气。谓啖有情及五谷精气故。德中。大法即大缘起法也。信解故。欢喜深心故。爱重既欢既重故。不替修行。第三月天子下。十二段明欲色诸天众。天者自在义。光明义。清净义。智论云。天有三种。一人天谓帝王。二生天谓欲色等。三净天谓佛菩萨第一义天。今通后二。然诸天寿之长短。身之大小。衣服轻重宫殿胜劣。俱舍十一。及瑜伽等论。起世等经皆广辩之。恐繁不叙。文中先有七段。明欲界天。后有五段明色界天。前中即分为七。今初。月天子。月者缺也。有亏缺故。下面颇胝迦宝水精所成。能冷能照。表菩萨得清凉慈照生死夜。如云菩萨清凉月等。名中初一是总。虽标总称即受别名。下皆准此。德中。显发众生心宝者。水珠。见月则流润发光。净心遇缘则慈流智发。生了既发正因显然。生由性成则了非外入。生与不生无二发乃发其本心故。显发双辩。二日天子。日者实也。常充实故。下面亦颇胝迦宝火精所成。能热能照。表菩萨智照故。又日以阳德月以阴灵。一能破暗。表根本破惑。一能清凉表后得益物。又依宝性论。法日有四义。一破暗如慧。二照现如智。三轮净如解脱。四上三不相离如同法界也。名中可畏敬幢者。为恶者畏其照明。为善者敬其办业。以斯超出故以名幢。德中。居者办业成就本行等利益也。生长谷稼开敷觉华等。为增长善根。如出现品。三三十三天者。佛地论等皆云妙高山。四面各有八大天王。帝释居中故有三十三也。下释天名皆依佛地。名中言释迦等者。释迦能也。因陀罗主也。具足应云释迦提桓因陀罗。提桓天也。即云能天主。抚育劝善能为天主故。更有异释如音义说。德中。言发起广大业者。令修普贤行故。以此天居地天之顶。总御四洲。虽胜事颇多犹惧修罗之敌。若修善者众即天侣增威。苟为恶者多即诸天减少。故多好劝发。况受佛付嘱大权应为。至如坚常啼之心。施雪山之偈。成尸毗大行。破卢志巨悭。谈般若于善法堂中。扬大教于如来会下等。皆是发起广大业也。四须夜摩天。须者。善也。妙也。夜摩时也。具云善时分天。论云。随时受乐故名时分天。又大集经。此天用莲华开合以明昼夜。又云。赤莲华开为昼。白莲华开为夜。故云时分也。随此时别受乐亦殊。故大论云随时受乐也。德中。心恒喜足者。喜足在于第四。今慕上而修。五兜率天王。此云喜足。论云。后身菩萨于彼教化。多修喜足之行故得少意悦为喜。更不求余为足。德中。彼天是诸佛上生之处。故令修念佛三昧也。召体曰名。响颁人天为号。通号别名皆悉念也。不计一方故云一切。以诸如来同一法界体德均故。念即明记而慧逾增持而不忘。故无间断。以佛为境何五尘之能惑哉。六化乐天王。论云。乐自变化作诸乐具。以自娱乐。又但受自所化乐不犯他。故名为善化也。变谓转变。转粗为妙。化谓化现无而忽有。德中。以出世化故得解脱。七他化自在天王。论云。令他化作乐具以自娱乐。显己自在故。名中寂静境门者。境为入理之处。即是门也。根无躁动故称寂静。根即门也。根无取着方见境空。合为门也。故鸯掘经云。明见来入门具足无减修。德中。物我自在即广大法门。第二色界。诸天众有五众。以第四禅有二众故。然四静虑摄天多少。下经频列。至十藏品当会释之。多依十八。初静虑四。二三各摄三天。皆举最上以胜摄劣故但列一。下文说颂遍观诸天。第四静虑自摄九天。上五小乘圣居非此正被异生位中。广果至极。故今列之。大自在天三千界主。所以别列。今初大梵天王众。佛地论云。离欲寂静故名为梵。具云梵摩。此云清洁寂静。谓创离欲染故名清洁。得根本定名为寂静。尸弃此云持髻。谓此梵王顶。有肉髻似螺形故。亦名螺髻。或云火顶。以火灾至此故。貌如童子。身白银色。衣金色衣。禅悦为食。德中。本修慈心得生梵世。等流相续还愍众生。好请转法轮。故智光照物不为污行。故身光发挥。若有遇之身心悦乐。第二光音天。二禅第三天也。智论亦云。第二禅通名光音。彼天语时口出净光故。有云。彼无寻伺言语亦无用。光当语故名光音。瑜伽名极光净。谓净光遍照自他处故。德中。定生喜乐离寻伺。故得寂静名。然凡得之舍动求静。故非广大味定之喜。非无碍法。今菩萨即动而静。不散不味是为广大无碍法门也。第三遍净天。此天离喜身心遍净故。德中。身心遍净未为广大。物我无二普益世间。方为广大也。第四广果天。即第四禅第三天。于异生善果此最广故。所有功德胜下三故。德中。此天离八灾患世中最寂。今以实智住本寂之宫。第五大自在者。梵云摩醯首罗是也。于三千界最自在故。智论第二云。此天有八臂三目。乘白牛执白拂。一念之间能知大千雨滴。下经同此。准智论第十一。过五净居有十住菩萨住处。亦名净居。号大自在天王。又三乘中立此为净土。是报身所居。约实但是第十地菩萨摄。报之果多作彼王耳。德中。三界之顶非无相不超。非离相求故所行平等。然上释名叹德。多从义便以顺类殊。若约实德无不互有。皆可虚求众海云集竟

大方广佛华严经疏卷第五大方广佛华严经疏卷第六

        唐清凉山大华严寺沙门澄观撰

    世主妙严品第一(从第二经尽第五经)

自下大文第七称扬赞德分。亦是发起序。文中有三。第一总结威仪住。第二此诸众下。总显德行因缘。第三所谓下。别明得法赞佛。前中有三。初结众集。次明相异。后显意同。今初。数广德深故名众海。起于自地集空道场。多数大身重重无碍云之象也。又浮云无心龙吟则起。菩萨无住佛现爰来。二无边下相异也。不唯上列。故云品类无边。旋环不空故云周匝遍满。大小等形妍媸等色。部主徒从各有区分。故云差别。三随所下意同也。随所来方参而不杂。皆得见佛各对目前。其犹百川各全睹月。同无异念。故曰一心。谛瞩钦承瞻而且仰。不唯直睹丈六。乃彻见法界身云。第二总显德行因缘者。以上列中随宜别叹。今方总显德行齐均。又与下。别得法门以为总故。前同生众中共集善根亦是别故。又前共集明主伴所由。今曾摄受显眷属所以。影略其文。此文多势且分为三。初明离障见净。二如是下受化根深。三种无量下德行圆备。初后是因中一是缘。以因夺缘。大众自见以缘夺因。佛力令见因缘和合。无定亲疏故因缘间说。又初段德行现深。后二因缘宿着久摄。今见即缘成因。感应道交故常居佛会。今初离障见净者。烦恼即烦恼障也。心垢即所知障也。此障翳心迷所知故。言一切者谓分别俱生。若种若现。言余习者。二障气分粗重。粗重如毕陵上慢迦叶不安。今皆位极菩萨智现情亡。证理达事心镜莹净。故云已离。若诸位圆融。一断一切断。亦通初位。言摧重障山者。通以喻显。以能摧道摧二障山。障体坚厚崇耸如山。又别则智障菩提惑障圆寂。通则俱障及一切佛法。故名为重。言见佛无碍者。断障果也。然有二义。一就能见以明无碍。由断二碍智明理显。理显故见法性身。智明故见佛智身。理智冥一见无碍身。无碍亦即涅槃。二约所见明无碍者。具十无碍已如上说。第二如是下。受化根深。于中初总后别。初中如是者。指前断障之众。劫海者。明摄时旷远。言四摄者。即摄化之方。谓布施爱语利行同事。布施是摄缘与彼资持故。爱语是摄体。正示损益故。利行是摄处。安住善处故。同事谓释疑。令彼决定故。后一一下别示摄相。于中向言劫海曾摄。何所摄耶。谓一一佛所。何时摄耶。种善根时。将何法摄。谓种种方便。摄相云何。谓教化成熟。教化约始成熟。就终摄意云何。令其安立一切智道。道者因也。谓唯为佛果修佛因耳。第三种无量下。德行圆备。前摄何益。令德圆故。于中先辩因圆。后入果海。今初文有五句。一种无量善。已超七地殊胜善根故。二悉已下。已超八地大愿满故。三所行下。已超十地行满障净故。四于出离下。前明德圆。此具出道一道无量道。已超生死不住涅槃。故云善出。五常见下。结成见佛。谓德高十地是以常见。非比量见故曰分明。不取色相名为照了。又尘毛刹海佛遍重重。有德斯睹名分明照了。二以胜解力下。入果海也。此一段文望前是别。总具德中别入果故。望后是总。四十众中解脱标故。今且属前。于中二。初乘因入果。是比智知。如见鸾翔知太虚可冲。瞩龙跃知宏海可泛也。谓以胜解力印可佛言知福慧之深远。以信解力赡仰佛化。知慈悲之广大。是入如来功德大海。亦是胜解印持果德。二得于下。明分得果用。言解脱门者。佛果障寂大用无碍。故称解脱。真解脱者。即是如来通智。游入故号门也。众各证契故名为得。此解脱即门。佛得其总众海得别。又佛解脱但名解脱。众所得法称之为门。以能通入彼果用故。此解脱之门。又众所得法。离障自在名为解脱。智所入处亦名为门。以因解脱入果解脱。亦称为门。此解脱即门。然总别圆融因果交彻。重重无碍方为真解脱门。故下或叹佛果德。或叹因行。或约天等所得欲影显。故次游戏神通。正明入相。游戏者出入自在。神通者难测无壅故。约观心者。心境无碍称为解脱。由此入理故号为门。若以门为门非能通矣。门即如实。何所通耶。正入双亡为真门矣。如此入者。则本觉湛然名穷果海。真非妄外则因果圆融。心境无涯则解脱无际矣。第三所谓下。别明得法赞佛。四十众中。各先长行得法。即经家序列。后说偈赞即当时所陈。然众集偈赞并在一时。文不累书故编之作次。而各得一者。显佛德无尽故。乘别入总。尽众不能及故。故海慧云。如来境界无有边。各随解脱能观见。而普贤得十者。显等佛无尽故。文中先异生众。后同生众。前中三。初诸天。次八部。后诸神。今初分二。先色天后欲天。前中有五。今初自在天。长行十法第一法界等者。即法身解脱也。法界虚空界即用。所遍处空即事空。法界之言义兼事理。谓非但遍空。亦遍空内色心等事。及空有称真之理。又但言空则一重遍。今云法界则重重皆遍。何者。谓空界容一一尘处及彼事物一一尘中。皆称真故。各有无边刹海。佛身大用皆悉充满故。下颂云无穷尽也。言寂静者体也。然有二义。一明前大用。用无用相不碍常寂。二由此智用即寂同真。是故随一一用遍一切处也。言方便者用也。亦有二义。一明前寂无寂相不碍大用。二内同真性不碍外应群机。故云方便寂用无碍。所以称力。二普观一切法悉自在者。智身解脱也。此有三义。一以普眼于一切法。无不能观。二观一切法不坏事而全理。三于一法中见一切而无碍。并名自在。三知一切法不生等者。自共相解脱也。亦有二义。一知不生等内证真理。二无功用行外应群机。然不生等佛法之体。释有多门略申一两。一别释。以不生灭约境。不来去约行。初不生灭略有五义。一就遍计。由是妄执无法可生灭也。又情有即是理无。故不生也。理无即是情有。故不灭也。不灭不生是一法也。又求遍计相。不可得故。不生能显无相性故不灭。不灭即不生。亦一法也。二就缘起性。谓法无自体揽缘而起。即生无生。既本不生故。无可灭也。又缘起无性故不生。无性缘起故不灭。中论云。以有空义故。一切法得成。是故不生即不灭。不灭即不生。为一物也。又推缘无起故不生。能显无生性故不灭。三约圆成性。谓非是有为。故无彼生灭相也。又非妄心境故不生。圣智所证故不灭。又体非迁变故不生。随缘令法起故不灭。不灭即不生。为一物也。四通就三性混融。于一法上。就遍计故不生。就圆成故不灭。就依他故。亦不生亦不灭。就三无性故非不生非不灭。五然此四句合为一聚。圆融无碍顿思可见。二不来不去者。约行谓正智背舍妄执而无去。向证真理而不来。又依体起用而不去。应机现前而不来。又往应群机而不去。恒归寂灭而不来。不来即是不去无二为一味也。由此大智无念应机。如摩尼天鼓无思成事。故云无功用行也。二通释者。不生不灭亦可约行。不来不去亦可约境。谓妄念斯寂犹若虚空。何生何灭。又虽起大用见心无生。用谢归寂了本无灭。又常称真理寂照居怀。于此心中有何生灭。此约行释不生灭也。约境释不来去者。犹如空华无可去来。又缘会即来。来无所从故无来。缘谢而去。去无所至故无去。又诸法即如如岂来去。三展转释又何以不生灭。由无来去故。何以不来去。由无生灭故。又既无来去。则非一非异。不生不灭则无断无常。智契前理故无功用。不碍生等故云行也。是则不生之生。生之不生。无功用故常寂行故。常用寂用无二。是于功用得解脱也。斯为正法之要。义味难尽无厌繁文。四现见一切法等者。观义解脱也。现见之言拣比知故。真实相言。略有三义。一以智观事实事不虚故。故下经文。观有为法如实相故。二以慧观理实。所谓无相。无相不相名为实相。三以无碍智知无二实。穷实故深尽边故广。称智慧海。不为相缚是解脱门。五与众生等者。慈障解脱也。离诸危怖曰安。适悦身心为乐。见佛则获二利故安乐也。烦恼不生故得定也。佛德难思故乐。定无边斯为大方便也。六令观等者。悲障解脱也。众生痴故造业。造业故受苦。闇故不见未来。不见未来即颠堕。故大怖之极莫越愚痴。令观本寂则痴相本空。尚不造善。岂当为恶。七善入等者。业障解脱也。佛现十方是无边境。了无依性称为善入。尚不依佛宁造业思。八普往十方等者。即无相解脱门也。虽身应十方寂然不动。智宣诸法怕尔无依不取于相。如如不动故。九入佛等者。即名相解脱也。佛智契如名入寂境。寂而能应故。普遍十方身智发光。又令物入无相故静。无名故寂。十中此天王名。与前列中少倒。前名极精进名称光。上下诸文多有此例。或义存名异。或广略参差。皆译者不善会耳。法门名住自等者。此离二取相能益自他解脱门。自悟处者。即离觉所觉。自觉圣智常现前也。而以无边等者。谓缘无边法界。度无边众生。得广大菩提也。二上首说偈中二。先彰说仪。后明正说。今初。焰海是当众上首。仰承佛力为众申心。十地论云。承佛力者显无我慢。普观十方示无偏心。今观己众通局小异耳。然颂总有四种。一名阿耨窣睹婆颂。此不问长行与偈。但数字满三十二。即为一偈。二名伽陀。此云讽颂。或名不颂颂。不颂长行故。或名直颂。谓直以偈说法故。三名祇夜。此云应颂。四名嗢驮南。此云集施颂。谓以少言摄集多义。施他诵持故。今此即伽陀颂也。下皆准之。为何意故经多立颂。略有八义。一少字摄多义故。二诸赞叹者多以偈颂故。三为纯根重说故。四为后来之徒故。五随意乐故。六易受持故。七增明前说故。八长行未说故。今此正唯前二。义兼五六。二正说中。十偈次第。各一法门结集。取此以为长行。非此颂前也。然此中长行。与偈有多不同。谓偈字则定长行多少不同。而长行则约天得法。偈中即是叹佛。此必然也。若二文互望。或因果之殊。或体用有别。或互相影略。或难易更陈。或法喻不同。或能所递举故。传授者善消息之。二文相映于义易了。今初天中初二句。即前所遍法界虚空。兼明能遍。佛身。则十身皆遍。无穷尽者。一出现无尽。若高山之出云。二非灭尽法。犹虚空之常住。次句寂静也由无性故。不可取为一异俱不俱等。后句方便合二为力。此偈是说者自法故不结天名。下并准知。二中初句是上自在佛为法王。于法自在故。次句观也第三句普也。后句结法属人为他说故。然其结名义同法门。恐繁不配。他皆仿此。三中初句无功用也。不思议是标。离分别是释。次句即不生等。相即生等无即不义。第三句即行也。长行约要先知法无生。方得成无功用。偈则要无分别。方能见法无生。内证与外用同时。所以二文前后。四中初句明广。次句明深。即上智慧海也。第三句自见法实。故能令物不迷事理。五中初句方便定也。次二句与安乐也。六中初句即前痴闇。谓长迷妄境镇覆真心也。次句即令观寂静。次句因灭无明。则得炽然三菩提明。是前灭义。七中初二句。即善入无边境。无边境即所应处也。无有比善也。次句无性者感而应故。无依者思念寂故。由此能令物不造业八中初二句即普往十方说法。次一句即不动无依。九中初句。即入寂静境。次二句即普现光明。十中初十一字。即无边境为所缘。求菩提即自所悟处。次句既缘其境。必起通化。前文略耳。第二明第四禅广果天。长行十法中。一普观等者。此应根授法。明于不知根说法无果障中得解脱也。断疑生信是说法果故。谓观机识病称根说法。药病无谬故疑除疾愈。二中随忆念言。略有二意。一随念何佛如名应之。二随念有浅深。令见佛有粗妙。此于现身得解脱也。三中法性平等者。唯一味也。无所依者。离能所也。庄严身者。证真庄严即非庄严。故虽现世间还如法性。不依诸有。此于有依得解脱也。四中知世间法者。谓众生世间心法各异。知已随宜现通说法。故云安立。一念速安。非人天外道所能思议。以此庄严如来教海。此于安立教法迟钝障得解脱也。五一毛等者。约偈不思议解脱力也。无碍有二义。一唯就所现。则毛中多刹自互无碍。二双就能所。一毛不大而多刹不小。一多大小皆无碍也。又由无大小相故。此于取着障得解脱也。六普门者。一门摄一切门。名为普门。随一一门。各全收法界故。于其中观察法界。深智契达故名为入。此于随相中得解脱。七中众生无边根器各异。应形说法种种不同。既根熟不休故穷劫长现。此于畏苦不化生障得解脱。八中观一切等者。谓观事入理理超情表。云不思议。此于诸业报得解脱。九中法门无边出者。为要根器万品故。出要难思。此于着相得解脱。十中种种方便。但随所应终成种智。名入佛法。以大悲出现皆等雨故。此于不欲利生得解脱。上云出要令离妄苦。今云入法令得真乐也。颂中观己众内三类天者。上五净居非所被故。十偈次第一如长行。初中前二句。即所疑境界。境界之言。通分齐所观。普令者观根为说故。生信解者断疑也。信佛大用分齐难测故。断佛上疑生其正解。信佛所观之境。则断法上疑。亦生正解。谓如有疑云。为存因果非真空耶。为是空故无因果耶。今明只由真空能立因果。因果立故乃是真空也。第四句释一切之言。佛以利生为意乐故。既该一切故广大无尽。二中初句即忆念。次二句令见佛。三中初句。则法性平等无依。次二句即庄严身。谓如法性为严。故无依处。四中初一句。即了一切世间。次二句。即一念安立不思议庄严海。五中初二句。即毛孔现刹。上云不思议佛刹。但以横多。今云过去。乃竖穷前际。皆示现者。如镜现像。次一句是无障碍。令应度者见即佛神通。依佛镜智而观。乃法性恒尔。六中初二句即普门。次一句即法界。末句义兼于入。七中初二句。即为一切众生种种出现。次句即无边劫常现前。谓约机隐显佛无去来。故常现也。八中初句。即观一切世间也。次二句。即入不思议法也。若约理论深。是深非甚。今不坏事而即理。故曰甚深。全揽理以成事。名为幽奥处。兼上二法常寂然。释上义也。以诸法即寂故。不可以理事思也。九中初二句。示一切众生。次一句显出要法。十中初二句。即观应化众生。次句令入佛法。第三明三禅长行十法。第一门即寂普现名为方便。说即是道。由说入佛解脱海故。此于体用有碍得解脱也。又方便言。亦通入解脱之方便也。第二门随一切等者。谓不能普现得解脱也。光影之言。略有二释。一谓因光发影。影但似质而不似光。依智现形形随众乐。不随自智。随乐即应名普示现。二水中之月亦名光影。谓佛月不来影现心水。影多似月少似于水。谓水动则流光荡漾。水浊则似晦魄。临池若止而且清。则圆璧皎皎。此亦随自他意也。此就天王且随天众所乐。偈就于佛无不应也。第三门佛境界有二。一如如法性是佛证境。二十方国土是佛化境。严净亦二。离相息妄则严如境万行回向则严化境。此二无碍大方便也。此于无巧庄严得解脱也。第四随诸等者。谓大悲深厚故。随入生死众生无边故。永流转而示导也。此于无大悲舍众生障得解脱也。第五门佛调众生。或折或摄或兼二行。虽悲愿多门。皆令趣无上道。若忆念此。居然受化不滞于权。此于胜所缘有忘念障得解脱也。第六得普门等者佛以称法性之总持。包摄一切总持故。云普门。复能流演无尽故。得称海。此于闻思有忘失障得解脱也。第七门。谓佛出难值引之令值。信心难生劝之令生。信含众德。所以名藏。下经云。信为宝藏第一财故。此于嫉妒邪见障得解脱也。第八能令等者。上令信佛此令信法。仰依即信领解便喜信可趣入喜则奉行。因得解脱名而出离。此于迷覆众生障出离道。得解脱也。第九门。谓众生界法界。调伏界虚空界。皆无边无尽。菩萨悲智以方便界。开示法界。行调伏界等虚空界。于有限碍障中得解脱故。第十观众生等者。由悲故怜愍。由智故观察。观察烦恼知病行。已化而度之。此于无悲无方便障。得解脱也。颂中十一颂。初十次第如前长行。依梵本列名中。此长行阙第十一天。彼名星宿音妙庄严天王。下言妙音者略而未回。第一颂中初二句。是了达方便。依法性而现故。后二句说即是道。说不思议解脱。令众同归。二中初二句。明光影普现无依故如影。第三句成上二义。以无生故如影无依。略不明随天所乐。三中初句标方便。无量劫修兼显大义。次二句。正明方便严佛境界。四中初二句。即众生永流转。谓无明所盲覆本净心。造业受身故恒居生死。次句即随而示之。五中总相颂佛调生行。初句高次句深后句广。六中初二句即普门陀罗尼。次一句即所流出。示教者示其善恶教。使修行称性无偏。故遍而无尽。七中初二句值佛。次句生信藏。不信则佛难值。正信唯佛能生。既值佛生信。反覆相成今之一遇。何得不信。八中初二句。即所闻之法。以无性为法之真性。次句即令众生信喜。出离净则出不信浊。成无漏故。九中初句能调伏人。前因此果耳。化众生界即调伏行。无边无尽为不思议。思惟悦生是名为入。十中初二句。即众生无量烦恼。谓利钝二使。爱见罗刹皆甚可怖也。次一句。以悲愍之以智令离。十一中既阙长行。对名略显。初二句星宿庄严义也。谓佛光流于法界。粲若星罗。次句即妙音庄严化众生事。不出三轮。上云妙音。举一立称耳。若长行立名。应云得放光现佛三轮摄化解脱门。第四二禅长行十法。初中二义。一内证真乐。经论共说乐。有五种。谓一因。二果。三苦对除。四断受。五无恼害。无恼害乐更有四种。谓出家远离乐。禅定适悦乐。菩提觉法乐。涅槃寂静乐。今当第四。若通取受字兼禅定菩提则含因果。言恒受者。以无所受受诸受故。若待境界即非恒也。二而能降下。外建大义。降神现相除苦因果。此于涅槃体用障。得解脱也。第二门。谓无缘大悲与性海相应。拔世忧患故出生喜乐。无尽名藏。此于恼害心得解脱。三一念等者。修福德因。感依正果福之力也。虽多人多劫所感念劫融之顿现。此于时劫得解脱也。第四门。谓以佛力不动成住坏三皆如空劫。常清净也。此于迁变得解脱也。五爱乐等者。谓信乐佛菩萨法。敬奉修行。则二障得解脱也。第六门。地谓地智义。谓证净。即离念超心地也。方便者。教导及入地之由。入住出等也。以无尽辩演无尽法。故能经劫。七一切等者。通有二义。一现多身兴多供供多佛。皆称真故名大方便。即长行意。二一念八相遍法界。故名大方便。即偈中意。于上自在名为解脱。八于定慧障得解脱。九果满应机。是于现身化生。无堪任性得解脱。十见佛大愿云爱乐随学。此于自轻障得解脱。二颂中十偈次第依前。今初前三句。明寂静乐。通举因乐以显果乐。后句降现之用。二中初句即所相应海。次句即能应大悲。大悲荷物故名为地。次句即生喜藏。忧除故。喜患除故乐。三中初句能现。次二所现。四中初二句。即普使成住等。次一句颂如虚空清净。以三灾弥纶。而净土不毁故。然三四二偈似如前却。且顺文释耳。五中初二句。咸敬奉是爱乐。余是圣人。次一句。即上法及信受也。六中初句经劫住。次二句即地义。方便无边。是一切也。七中通颂八相普周。略无供养。八中初句是前智慧。次句神通。次句无尽及海。以随根令净是深广故。九中初二句。即德海满足。次句出现世间。十中三句。通明前昔誓愿力。第四句。结中便显深信爱乐藏。以文云大欢喜故。第五初禅长行十法中。一普住等者。大用应机故普遍说法。用而常寂故行净无染。得心无行故行净。了境无相故无染。二佛为定境。住定则所见深故。三普入等者。法海难量名不思议。一言演尽名为普入。四圆音随类名音声海要无分别方入佛声。五能忆等者。化生即是趣菩提行故。以宿住智明记。六众生报异随业有差。佛示现受令生正信。七于法自在方能随类调生。八佛身无相。等法性之清净。现而同化。为寂灭之行矣。九不着诸有故。能常现三业。无边更无可依。十观性无相犹如虚空。何有可尽。察用随宜。如击水文随击随生。复何可尽。偈中先上首观众。开成四天合则梵身。即众亦有。经云梵众梵身梵辅。梵眷属身即是众。辅即眷属。十偈。初中初句。法身普遍道场。次句智光说法。次句行净无染。境相智行既亡。则大用影像亦寂。后句通以喻显。云不离空空不碍云。以况寂用。二中初二句。入禅之境。如来法身即是心性。若能观之为上定故。次句示入方便。虽多同入一寂。三中初句即不思议法。次二句明普入义。以一言说尽故。一言说尽之辩。劫海亦不能穷。显法无尽也。约能包则一言说尽。约能久则劫海莫穷。然一言但说刹尘。未是无尽。设欲一言尽者。则二三两句相违。一言说尽。劫海更何所演而得无穷。更有所演前则不尽。又不可重说。若欲通者。总望则可说尽。隐映重重则不可尽。如击水文小击大击遍击。各随文生。尽未来际击尽未来文生。为难思法也。四中圆音之义。文略有三义。一广无边。二别诠表。三无分别。如次三句。余如出现品辩。五中初二句。即教化众生方便行。三世诸佛皆以利他为向菩提。自清净业故。次句前就梵王。故云忆念。今据如来故身现耳。一毛尚现何况全身。六中初句业相差别。次句报相差别。次句现同世间。七中前二句。即随类调生。调法自在故。能随类广遍。次句显明前义无思成事故。八中初二句。明佛体性。即前清净寂灭。不可尽下略显四义如空。次句佛用应现为行。既皆如化不失寂灭。九中初二句。所现无有边。次句勤现无依着。十中初二句。常思大用无尽。谓安住大悲宫。能现大事故。次句常观法体无尽。自下第二欲界诸天。文有七段。第一他化天王。长行十法中。一谓现众生前自在调伏。使其成熟化法无尽。故名为藏。二观世乐相。皆苦故应舍。观世乐性即入圣乐。三随乐断疑令起正行。四一言普摄诸义。遍于时处为物而说。五仿佛修慈。六示现等者。大悲十力摧彼慢高。而无摧心。故云示现。七以智慧光照诸世间。令离三毒之闇。则无恶趣之果。嗔痴障重故。与偈互陈。八十方等者。为念佛三昧纯熟故。随念何佛即能得见。如休舍解脱等。九应念现成。十普入等者。寂用自在现世调生。总名威力。偈中亦十。初中初句体遍。次句用周故能现前。次句教藏能成。后句所成自在。开于法藏悟深法门。即成熟也。二中初二句二乐。次句令入。三四可知。五中三句。共显如来大慈。初二句举劣显胜。次句以喻正显。谓世慈有相。若须弥之高大海之广。终可倾尽。佛慈称性。若芥子之空投刃之地。即不可尽。又如空有普覆常摄。广容无碍难坏无尽。略举一无尽耳。六七与八文亦可知。九中初二句。明佛体普遍无成不成。次句随众生心现成正觉。十中普现十方。即普入一切世间。余皆威力自在。第二化乐天长行十一法中。一为物开示诸业。如化化虽体虚而有作用为力。业亦从缘无性而报不亡。二舍离等者。攀取缘虑是惑病之本。若心。境无得则舍攀缘。三闇灭智生如月盈缺。四示现等者。梵声微妙故云悦意。应遍十方故云无边。五知一切等者。此有三义。一福德之相。有十莲华藏世界微尘数。故无有尽。二谓清净慈门等无限因所生故。一一因果皆称真故。一一即无有尽。皆同虚空。三大慈悲行是福德相。使盲聋视听等。皆慈善根力故。涅槃经中。有闻赞佛为大福德。怒云。生经七日母便命终。岂谓大福德相。赞者云。年志俱盛而不卒暴。打之不嗔骂之不报。是故我言大福德相。怒者闻而心伏。故慈为无尽福相。然与前义相成。六三达圆智了三世劫。此就天王且言宿住耳。七开悟等者。此门阙偈。上下文中屡有开悟。即同法华开示悟入。以开摄示以悟摄入。谓开示约能化。悟入约所化。彼论云。开者无上义。谓除一切智智更无余事。即双开菩提涅槃。谓以知见之性为涅槃。知见之相为菩提。众生本有障翳不现佛为开除。则本智显故。示者同义。三乘同法身故。悟者不知义。不知唯一实事故。今令知成报身菩提故。入者令证不退转地故。即是因义。为证初地已上为菩提涅槃因故。广如彼释。八称性之光有阿难遍。九一切等者。谓契理具修长劫无倦。故众魔外道所不能摧。十善恶等殊苦乐等异。皆知性相。十一示现等者。无边品类一毛顿现。更无来去尤显难思。偈中脱于第七。唯有十偈。初中初句总。次句开示。后二句显如化力。差别业者果不亡故。二中初句所攀缘。后二无得。然缘境有二。一真二妄。真佛有缘亦成妄惑。况于妄耶。种种观者五求不得故。谓佛有耶常见为惑。谓佛无耶邪见深厚。四句百非所不能加。故无所有。非唯一佛十方亦然。应化示现非真实。故求实无得即见真身。真即无缘佛尚应舍。何况余境。三四可知。五中初二句福德相。次句无尽相。相好者经云。尽人中福不及一天。乃至云尽世间福不及如来一相等。六中约天之智普知。约佛一毛能现。七中初二句。明毛孔过空。谓灵智证理非如虚空。真理超事故亦非比。无限理智不可分析。随其少分即融摄重重。故一毛之量便越虚空。次句别示越相。谓毛孔不大而无涯。即广陜无碍故。杜绝思议之境。前即一光外展。今即一毛内广。文绮互耳。一毛本自遍空十方。岂得难满。八中初句长时修。次句无余修。次句无间修。具此三修故进力难坏。而言广大波罗蜜者。至第五经释。九中初句。总显业之性相即缘生。果报之不亡。便是无性之非有故。不可有无思也。次句。佛如是说天如是知。次句以法性示业性。十中初二句。小一现大多为一难思。次句现时不来不现不去。又难思也。第三知足天长行十法中。第一天得总相法门。诸佛将兴皆生彼天。下生之时普应法界。顿阐华严为圆满法。二尽虚空等者。光明色身皆遍空界。了不可取故云清净。三以净愿力灭惑业苦。四五可知。六普化等者。普即无偏。常即无间。示其真乐即如来藏。七自觉智境佛已入之。故示物同悟。八以净福坚菩提心。九谓仰观下化。十即照现迅疾也。偈中。初偈前半即出世义。上句体智俱遍。下句悲用皆普。后半即圆满教轮。前句即实之权为妙门。后句会权入实为圆满。二中可知。三中初二句。以行净愿。次句杂染本空故。前令灭佛法本具故。今令满妄尽真显。二言相成。四初中二句。依体普现。若月入百川。寻影之月月体不分。即体之用用弥法界。体用交彻故不思议。次句称根说法。五中前半。即所净之众生。具三杂染故。于中上句标。下句略示惑相。慢是根本憍逸随惑。憍谓染自盛事。慢谓恃己陵他。放逸即是纵荡。憍谓染法所依。慢能长沦生死。放逸众惑之本。故偏举此三。荡者动也。谓境风鼓击飘荡驰散。次句能净法门。谓不取于相当体寂故。六七及八文并可知。九中通显上既亲近必当敬养闻法以闻调他。为真供养。列名中云星宿幢。今故庄严与长行互出。十中前半。所知众生心。上句标深广。下句显相。念虑不住多于草。故广也。深者有三义。一恒转如流故不住。二本体寂然故不动。三从缘妄起无别所依。次句即一念悉知。第四时分天十法。一善根若发忧恼自除。二以无限方便。普证法身之境。三悲摧惑苦故名为轮。四以三达智知机授法。五陀罗尼等者。总持入理故名为门。以慧为体。故云光明。若取助伴则兼念定。念即明记故能忆持。定乃心一常无忘失。四无碍等。一切诸法。皆是所持。六可知。七转法等者。转法示菩提之道。即是成熟众生之方便。八十眼圆见随宜往调。九超出等者。超出业障使离恶因。不随魔作舍恶缘也。十等雨法雨诱令进善。使彼受行。诲令断恶得心清净。此就于天偈通一切。偈中亦十。初偈通显。前半彰已已离。后半开发能离善根。二三四五文并可知。六中初句即业性。言广大者。一念造一切故。无穷尽者。未得对治无能止故。有多门故。次句善入智了。自入开示令他入。次句入门多种。七八亦可知。九中初句见佛为缘。次二见佛二益。一正智生必内超业障。二佛为真导岂外逐魔缘。既不随魔安造魔业。十魔并离故致诸言。十亦可知。第五三十三天众长行。有十一法。初中承力故忆念。念过去佛者。曾入此天故。三世有二。一亦念未来。二过去。自互相望亦有三世。生大喜者境殊胜故。庆自福故。二能令等者。然佛身无染净大小。亦无胜劣犹若虚空。云屯即闇日朗即明。色昏即劣物隔言小。今妄云尽而智光照。故清净。性空现故。广大妙色显故无比。皆解脱力故曰能令。三大慈不拣怨亲。若云无心而普覆。四恒见等者。人天世主多恃威德。故佛现超之令其敬喜。五知其因果差别。使物勤修。因果并得名福。六开示等者。示佛调生令菩萨仿习。七初成后坏住时转变。乃至毛孔细刹。皆悉知之。言转变者。福人出世则琳琅现矣。薄福者出则荆棘生焉。八忆念等者。佛毛现因调行。天忆则能思齐。九一切诸乐以佛为因。具胜德故。就乐增胜说诸天耳。十开示等者。受生善根即念佛力。开示令不迷惑。则去放逸而进修。十一疑自疑他疑理疑事。有多种种。如闻空疑断闻有疑常。闻双是则疑其两分。闻双非疑无所据。又闻空疑有闻有疑空等。互相疑也。今开之使悟。偈中亦有十一。初中云平等者。化仪同故。又但以世俗文字数故说有三世。非谓如来有去来今。二中初句广大。次句无比。次句清净。然古德明通有六义。一广谓总法界为身故。二遍全遍一尘至十方故。三妙色即无色。无色之色故。四胜无有比故。五益利物无涯故。六用光破闇故。三中前半即慈云。上句果大。下句因深。一切佛法依慈悲。慈悲又依方便立。俱称深广故致海言。次句即普覆也。次后六偈文并可知。十中初二句。即前善根少功德者。以少况多彰因为胜。次句即人天受生。故离三恶怖。十一中初句。即能开之法是寂灭智通。次二句由普应故。疑皆断也。第六日天长行十一法。既为日天多辩光益。初一名及法门。皆是总也。谓佛身智光。犹如彼日无私而照。是曰净光此光体也。次辩光用略有四义。一约心高下齐明。故名普照。二约处则穷十方界。三约时尽于未来。四约功用常无间断。如斯利益即大智之功。二以一切等者。众生本有佛智。如海潜流。今佛以随彼彼类身设种种方便。务在开悟令其证入。三众生爱染漂泊无依。佛德无碍应为其主。随修绝染名净功德。一行契理即曰无边。况其具修耶。四修一切等者。以智导悲为物受苦。故深欢喜。五谓体离障惑用而遂通。故云无碍。若身若智俱得称光。周而不偏故云普照。身心明利是益精爽。爽明也。大集经云。国王护法。增长三种精气。一地精气。谓五谷丰熟。二众生精气。谓形貌端严无诸疾疫。三善法精气。谓修施戒信等。今文正在第三。益其福智义兼前二。法力远资故。六净光等者。身智二光净物身心。信解深广于何不喜。七昼则勤心修善业故。八大悲海等者。谓无缘大悲坐于道树。出多奇宝故。色相宝者。应言宝色相圆明可贵故。以宝为体。宝庄严故具十莲华藏

故云种种。一一色相用周法界。名现无边境。如是皆从大悲海流。悲海包纳不拣贤愚故。九慧除痴翳法眼则净。净见法界法界即藏。藏如前说。十发生等者。谓于佛所发生清净心。曾一供养能令其福续至菩提故。如出现品食金刚喻。况相续耶。十一使物居业莫越日光。令人进德宁过法义。偈中亦有十一。初中前半净光普照。后半常为利益灭恶生善。破愚为智等为多方便。二三可知。四中前半即一切苦行。此有四难。一背己利世难。二行相唯苦难。三处经诸有难。四时劫无量难。于此具行故云一切。次句明深心欢喜。亦有四义。一为物苦行满本愿故。义在初句。二智照苦性本空寂故。即光明照空。三遍净无染非杂毒故。即遍净如空。四自他有果非无利故。即第三句全。五六可知。光网之义如贤首品。七中通明举劣显胜。以辩难思。故能成办诸妙功德。言世不及者。世虽多光益非究竟。佛光虽少必彻真源。不可尽故以一况诸。八九与十文亦可知。十一中初句。即能照法门。犹一日宫千光并照。随举一法有无量门。然有二义。一约相类。如一无常门有生老病死聚散合离。得失成坏三灾四相。外器内身刹那一期。生灭转变染净隐显。皆无常门余亦如是。二就性融不可尽也。次二句普运照义。一日周天则日日无尽。一门历事则劫劫难穷。方便多门终归一极。广者无边。大者无上。第七月天长行十法。初名法亦总。谓光有身智二殊。法界亦事理两别。事即机之身心及所依刹。身光照身令觉照刹令净。智光照心破痴照理令显。身智二光相即。则所照四法亦融。以之称普。并除惑障俱得净名。二观察等者。悲心普观授以多法。令入无边法界。三众生藏识皆名心海。前七转识名攀缘转。转谓转生。亦流转也。缘境非一立种种名。故经云。藏识海常住。境界风所动。种种诸识浪。腾跃而转生。喻云。洪波鼓溟壑。无有断绝期。既知机殊随应授法。四与一切众生等者。谓示物圣乐令得初地。此乐本有染而不染。为不思议。五谓以菩提心为家。二利为作业。并以身口为牛利智为犁。耕于心地下闻熏种。生信解芽起正行茎。开诸觉华获菩提果。自利则以不放逸随时守护。利他则以能化大愿守护。不令魔惑禽兽侵犯。从因至果得成就也。六慈悲等者。谓慈护现乐悲救其苦。令见因果断恶修善。名真救护。七以佛智风持大悲月。使明见正觉离苦清凉。八开示等者。一切法有二种。一足所迷。谓缘起不实故如幻。缘成故无性。二是能迷。谓遍计无物故如空。妄计故无相。又缘起法有二义。一无相如空。则荡尽无所有。是相空也。二无自性如幻。则业果恒不失。即性空也。此二不二为一缘起。是故两喻共显一法。既不迷能所则悟真如。成正智火。九悲愿为物现相好形。是大业也。十普断等者。毛光普演何疑不断。偈中亦十。初二可知。三中初句。即心海攀缘转。若以生灭八识。即彼第八亦名为转。以恒转故云念念殊。恒故非断转故非常。新新而生。念念而灭。念念殊故体恒不即。彼如来藏功德常具义亦不离。如彼瀑流。离水无流离流无水。又如海波涛有漂溺故。多畜养故。法合思之。次句明了知谓此识深细唯佛智知故。次句示心海性。即是佛智不令外求称机故喜。四中初二句。明失圣乐。圣安乐者。即圣智涅槃。本有今无故沉迷妄苦。次句明与示其性有。乐非苦外名不思议。见性得乐性即是门。五中但是法说。如来即田主也。悲佃物田为利入有。是所作业。为利同于求果入有似于耕犁。说法即是下种。劝善正当守护令熟可知。六中前悲救护。语其本心。此明智光彰其所用。悲智相导能真救也。七中初句。佛为福依月为凉本。次句应言大风持宫。而今云尔即是转喻。大地如佛宫室如福。次句即照现义。亦清凉义。八中可知。九中初句。佛如虚空。大业性也。次句大业体也。不利众生非大业故。次句大业相依光有影。可以知动静。依镜有像可以辩妍媸。然彼影像无自性相。如来相好当知亦尔。十亦可知天众竟

大方广佛华严经疏卷第六大方广佛华严经疏卷第七

        唐清凉山大华严寺沙门澄观撰

(已下入第三经)自下第二有八段。明八部四王众。初四段皆初一是天义如前释。今初乾闼婆王长行十法。初一即东方天王。谓摄受折伏逆顺多端。善巧应机故名自在。二普见等者。谓令众生见佛一切功德严。佛一毛而为利益。一一皆尔。故云普见。三以慈愍方便除忧则喜生。忧苦既如海广深。喜乐亦难尽名藏。然则世之忧喜生乎利害。利害存乎情伪。苦乐存乎吉凶。吉凶存乎爱恶。爱恶尽则吉凶苦乐皆亡。情伪息则利害忧喜永断。如此方为永断忧苦。喜乐生焉。四永断等者。谓得决定智光。则邪惑永断。五谓慈云普荫。材与不材皆凉。慧泽广沾。三草二木咸发。六现广等者。现身益物也。称性普应故广大。具相清净故妙好。七佛出说法是大名称。佛法众僧俱称为宝。令此远闻义云普散。八现一切等者。身光普照尘不能染。见者必欢。智光悦机惑累不生。又欢喜也。故云大喜。九法水遍滋菩提实行。行既树立见者必欢。无复二乘一切皆菩提树也。十善入等者。一多无碍名为佛境。天王智达故云善入。偈中亦十。前五可知。六中初句现身。次二句一切获安乐也。世间即一切也。无尽乐总显也。谓佛现于世足履影覆。若在人天现增快乐。若在下苦七日之中身心安乐。乃至终获涅槃之乐。故云无尽。次句别示出世因果之乐。先因后果。先世后出世皆次第义。又总取偈意。佛身清净是解脱因。生无尽乐是解脱果。世无尽乐又解脱因。能现净身又解脱果。又佛身清净是乐见因。乐见即为清净身果。众生乐见是安乐因。无尽安乐是乐见果。无尽安乐是净身因。能现净业是无尽果。如是展转因果名次第成。七中初二句。宝所济机。坚谓难坏密谓无隙间。无空处智不得生。次句正散宝也。八中结句。应云普放宝光如是见。而云妙音译者之误。妙音属前师子幢故。九中初二句。法水普滋。次句道树普荣也。又方便多门是开权也。入菩提行是显实也。种种方便但为一乘是普滋也。十中初二句佛境也。次句安乐也。佛力能现无所动者。遮妄见也。非促多劫就一刹那。非展刹那受于多劫。本相如故名无所动。随应度者佛力令见。第二鸠槃茶王长行十法中。初即南方天王。谓内惑外仇皆名怨害。安住忍力并能伏之。二修习等者。二利之行趣果曰门。深广难穷名无边海。三知其现欲如应化伏。四普成就等者。钝识者现之以通。利智者示之以法。遍世多劫名普成就。并如虚空故云清净。俱能照世即是光明。三轮化生是所作业。五世间惑苦可畏不安菩提涅槃安隐无畏。万行为其因。道则无畏灭果成矣。六消竭等者。爱欲漂流深广如海。智日赫照则妄竭真明。七谓于诸趣普现身云。耀通明等之电光也。八普放等者。身智光明遣除二障。九多劫修悲究竟灭苦。为不退转。悲多方便故复名藏。为安众生所以开示。十普现等者。称性神通。无来去而流转。偈中初偈。通显明佛已灭怨。怨之大者莫越憍慢。有之则卑陋。灭之则端严。次四偈可知。六中初句。欲海欲为苦本。云具众苦。次二句消竭。既欲恶止当说善行。七中初句普现身云。次句明等电光故云种种。次句兼明雷雨。雷有二义。一远震二发生。谓蛰虫发动草木发萌。圆音之雷可以思准。余三可知。第三龙王众。准偈及梵本皆有十一。长行脱第五。但有十法。初一即西方天王法门。及第二如偈当释。三与偈文通有六义。一诸趣是化处。二净音是化具。三佛名是化法。四神通是化本。五众生是化机。五随乐是化意。四普现等者。谓一毛普现无边依正。以毛称性能广容故。广容即是普遍。故能现之佛还自住于毛孔。所现刹中能所无杂。依正区分大小宛然。名建立差别。五静法云。准梵本有焰龙王。得一切众生嗔痴盖缠。如来慈愍令除灭解脱门。谓大慈居怀则三毒俱灭。六开示等者。佛大慈悲是福德海。二资粮满然后得。故众生慈福即是百川。佛毛示现以表同体。既知同体自然朝宗。因示悟入故得大喜乐。七慈音智俱故云清净。净无贪爱何畏何忧。八示现等者。谓于身中现身土也。九观佛昔行深广。故爱乐欢喜。海言通二。谓欢喜供养。十示现等者。谓为众演音故云示现。音有四义。一类多谓一切。二普遍谓平等。三称根清雅故云悦意。四一音随类故云无碍。无碍即方便也。十一谓此无热龙住清凉池出香美水。流注四海导引百川。时布慈云降澍甘泽。是故能灭诸世间苦。偈有十一。初中诸龙有四热恼。名炽然苦。今并有治。一金翅所食苦。初句为治。以观佛法同三归故。二行欲时复本身苦。三鳞甲细虫苦。并第二句为治。学佛等利故。四热砂着身苦。后二句为治。以不堪虫痒热砂中[馬*展]。今大悲哀愍故能治之。有说四苦无鳞甲细虫。而有风吹宝衣露身之苦。亦以第二句治之。就龙且说龙趣。末句约佛通拔畏涂。二中此就佛论示现。前约龙云能转。又前一念时促。今一毛处小。二文影略。余九可知。但第五偈即前所脱。第四夜叉王众长行十法。初一即北方天王。得以无边等者。谓善者自乐不待加哀。恶者必苦心则偏重。巧救多门故云无边。又此天能伏恶鬼。令不犯众生是救护也。二普观悲救。救苦护善不滞空有。故云方便。三恶业障重名甚羸恶。又羸无善力。谓一阐提。恶即弊恶。谤方等者。明示妙理是谓资益。四仿佛叹佛。得名闻果。五悲智二照合为一心。与法身俱故恒观察。六妙音说法利益多端。唯应度者声暨能益。七教广理深。一句能演即是普入。八令物离邪则能住。正为守护矣。然住正道者。则不分别是邪是正。云不思议。九集福德因受快乐果。由身智光得增长也。十念佛修因生十力果。天未证极故云随顺。偈中亦十文显可知。第五摩睺罗伽众十法。一普现威光名为神通。不动性净示涅槃因。故云方便。依因集德。必得无依涅槃。二除惑契寂是清净因。清凉悦乐是涅槃果。三善者善之。不善者佛亦善之。善不善觉亦亡。乃入本净。四福非福相深不可着。非福现福名自在相。佛佛无二是平等相。五无智黑因如灯开示。怖畏苦果如幢为归。六以知佛德同空齐己一性。故欢喜也。七见理决断。闻深不怖闻浅不疑。闻非深非浅意而有勇。八风不倾为勇猛力。既以自正必能正他。为救护主。八往修喜因故见念皆喜。九见理智成则缘不动。智为行本诸度悉圆。亦犹海纳百川。更不流矣。十开生等理示佛等应。破情不等令悟性等。为平等道。十偈如次文显可知。第六紧那罗王十法。一世喜乐业。皆因佛生。二闻深适神故法喜无上。终得涅槃无尽安乐。三佛德深广信亦包含。四音演真法令闻。故妄忧除而意悦。五达境唯心而本空。则安立众生于觉悟。六难遇益生所以示现。相严常住名为妙色。七大智普慈是二严果。一切智因。是能生业。八业细难穷自观示物。九神通益物无间称恒。十知机巧化谓摄心。正智御心如境。十颂次第文并可知。第七迦楼罗王。依贤首静法。皆云准颂长行脱第五执持王。一智无著故见无碍。悲普观故通悉调。二遍坐觉树名住法界。现通说法名为教化。三进策诸度往修故成。四境界如偈文。难思则入方为勇猛。五诸本多脱。遇一本有文。云大海处摄持力迦楼罗王。得能竭众生烦恼海解脱门。多是古疏本脱。今依有本。然偈约能竭说佛福智。六众生无边故成就智多。七城有三义。一防外敌。二养人众。三开门引摄。今言法城通教理行果。行契理教则无不俱严故。各有三义。谓了心城之性空。则众惑不入。见恒沙性德则万行爰增。道无不通则自他引摄。便能契果。绝百非以成解脱。养众德以全法身。开般若而无不通矣。方显教城无非养所诠旨。句句通神。有斯多义故。偈云广大叵穷。重重四门故无数量究竟能阐唯我世尊。八法身无相故不可坏。体即真如凡圣平等。无分别智安住证会。名成就力。九现同类形方便调伏。十众生殁生皆由行业。佛生死智方能普入。颂文如次配释可知。但第五偈。或有前脱故略释之。初二句甚深广大。次句福智相严。行通因果因深果远。已不思议复有一行。是如来行。所谓大乘大般涅槃。则行为果果皆绝言道。佛行。如出现品。第八阿修罗王十法。一修罗尊胜等须弥之高。如来威光蔽十方大众。众生各见真胜主也。二彼能以一丝作种种事。今一刹那。现于多劫调生等事。三以多法门入佛境界。则苦灭心净。种种法门亦如幻也。下云。苫末罗即巧幻梵音。四多劫多苦为物非己。如尸毗救鸽萨埵投崖。已是丈夫最胜严饰。况终克寂智万德以严。翻显无利勤苦诚为可丑。既为物而行。故有大眷属。五以大幻通力动刹悟机。不怖众生斯为大力。大力婆稚华梵异耳。六开种种权门。安众生于一极之乐。权为入大之本。故皆佛智因权实不迷斯为遍照。七万善顺理普不可坏。斯解脱处。何染不亡功归正觉。故偈云。佛力如是修者坚固妙严。八悲用智故普令无疑。主斯事者广大因慧。九供事修善有胜德故。十普入诸趣。明处无不遍。偈云三世时无不均。同有佛性名为决定。具上三义平等行焉。不宣实义非善音也。此上一段及后夜神。皆结归名。上下例然。恐繁不释。颂文如次可知。自下第三诸神众。有十九众。今初主昼神十法。一智了物心如空入色。光照身器如日合空。身遍器中如像在镜。世间主力能摄此身。此身之性等世间。故皆入观机故名普入。所入之处即为宫殿。二义圆称机故满心成益。三身法二光皆可爱乐。四法雨润种。已含实者解开。善未芽者信发。五无法不悟名普明力。旷劫修集成智庄严。六方便开示世乐亦苦。令其悟入。见理法乐如欢喜地也。七如来身云。就体则非有无。约机则差别遍于十方。不可谓之无。约佛则称真法界。不可谓之有。此则随缘非有之法身。恒不异事而显现。以化寂灭非无之众生。恒不异真而成立。即无差别之差别也。八处危者护之令安。有苦者救之令乐。九众生闇于多欲。故沉沦长夜。以法开晓喜足为先。喜足智俱是功德力。能令离苦得安乐故。十有觉德行故名称普闻。既福广名高故不虚其益。偈文可知。第二主夜神十法。初七夜神。是善财十地善友。见解深广。弥显众海法门难思。一普德净光。即善财离垢地善友。彼名全同法门。名寂静禅定乐普游步。普游步言。即大勇健也。寂静禅定乐。即是定体。现法乐住。故名为乐。大勇健者。即是定用。健则堪能勇则无畏。谓见佛净机游戏神通。故名勇健。亦游步也。勇健广大。故称普德。无惑智俱可谓净光。二即发光地善友。彼名喜目观察众生。解脱名大势力普喜幢。谓此解脱德无不备化无不周。名大势力。即今广大身。惑俱净无不乐见。故云普喜。悲为德相。即幢义也。观察普喜名为喜目。三即焰慧地善友。彼名普救众生妙德。护世精气方是救生。由护生故显德之妙也。法门全同。次第又当。谓感必现前。调令清净故。四即难胜地善友。彼名寂静音海。法门名念念出生广大喜庄严。念念出生即积集义。见佛利生故生大喜庄严。二义。一见佛修欢喜。因严。乐见果故。二积集此喜神自庄严。由定发音名寂静音。深广如海。五即现前地善友。彼云守护一切城增长威力。偈云尸利。以梵音含于二义。一云吉祥。二翻为守故。下译跋陀室利以为贤首。又以首字音同义别。彼为头首。法界品中乃为守护。皆译者方言少融耳。若以义会。增长威力即是普现吉祥正当次第法门又同彼云甚深自在妙音解脱。妙音故悦意。悦则意净。即寂能演。故名自在。六即远行地善友。彼云开敷一切树华。一切开敷即普发也。法门彼云菩萨出生广大喜光明。文少倒略耳。旧经云。菩萨无量欢喜知足光明。知足满足文相近也。谓能知如来巧智。示法大福威光。故曰光明。佛以福智满足物心。则含喜名藏。七即不动地善友。彼名大愿精进力救护一切众生法门名教化众生令生善根。教化开悟文异义同。令生成熟始终异耳。谓现通示相。皆为调化。一切善根皆令生长。平等护育即救护一切。精进大愿故能为之。今文略耳。八念念久修恒遍救护。是无边慈也。此与善财欢喜地善友。似同而文多异。又非其次。故但直释。九于三毒难坏众生。以大悲门现庄严身故。石室留影毒龙革心。况现身耶。十本为众生。故成自德令他乐满。偈中十偈如次。初中初句。解脱之力能观。次句即寂静乐。神以此定观佛此体。故下经云。普见三世佛而无取着。以知如来无相性相本空故。故云寂静虚空相也。次句即大勇健。准下经则自他兼净也。次句定果也。上约佛说。若约天说。即四句皆是定用。以住此解脱。能见佛体用因果故。二三可知。四中称理遍喜。为广大无边。纵内心不摇而外现威怒。更深难测。五以寂故能遍。六以众生本来自尽故是寂灭。是以智穷妄末理无不显。妄彻真源惑无不尽。喜方满足余四可知。第三主方神十法。一现身说法令悟得果。皆救护力。二神通示相。是能成办业。众生出苦。是所成办业。三法光破闇。闇断智生。智与法喜俱生。断以寂灭为乐。四普现说法。闻必惑灭故不唐劳。五圣人无名随物立名。贵在生德及灭惑耳。六七可知。八业同性空并不失报。俱无差异。性相无碍为自在力。说能感报令除恶业。说业性空善业亦亡。九前约说业性相。令物绝业。此约知业差别拟随机化。十世人靡不有初。鲜克有终。今圣人有志有能故。所作究竟。世人以人随欲不能兼亡。今有慈有愍故令物喜。谓十波罗蜜无不究竟。四无量心令物欢喜。颂中次第配释可知。第四主空神长行十法。一智慧造理。则十眼广照日月。合空则万像历然。二身智二光遍入法界。三佛身如空是无边境。无生无染为吉祥风。四广说圣道。则离三障安住二空。五上求下化名广大行。为安众生如妙髻焉。六沉生死之厄难。悲智光以济之。七不碍福智相导。是谓胜力八惑由智遣。九妙音善说。十不坏本处。而称周十方。偈中十颂如次。三中空有四义含于五法。一离能取生即绝妄想。二离所取相无相无名。三境无自性即是如如。四心无所得是为正智。迷如以成名相。妄想是生。悟名相之本。如执翻成智。如外无智智体即如。此二犹空寂照无碍。如斯见佛是曰吉祥。四中。长行及列。并名安住。今云圆光。圆光表智。安住表定。二事相资前后互举。并能灭障于理无违。六中生死海者。瑜伽七十云。五法相似生死得大海名。一处无边相似故。二甚深故。三难度故。四不可饮故。五大宝所依故。释曰。由前四义众生流转。由第五义菩萨入之。且约分喻。第九十云。由三相故不同水海。一自性不同分。谓水海唯色一分。二沦没不同。唯人畜故。唯没身故。三超度不同。未断欲者亦能度故。生死海反上可思。余七偈可知。第五主风神十法。一以方便风合智日光。智入深法而无障碍。身入世间而无影像。二菩萨以求菩提之大心。持称真之供具。等虚空之广大。不碍事之繁多。而以全法之身。一念供无边之佛。如彼风力无不成也。三长风忽来浮云散灭。慈风忽起惑苦病亡。四福智庄严之风。摧坏如山之障。五十力降魔。十军皆殄。独名竭水者欲爱为初故。六毛孔慈音灭除五怖。若百窍异吹遍吼悦机。七智入实相故妙辩如海。如风击树故能下垂。八调生方便为智所入。故名为藏。九禅定宫殿必定慧双游。故能灭痴闇。约佛则动寂无二。见必灭痴。十日月明照非风不运。智行无碍方便力焉。十偈可知(已下入第四经)第六主火神长行十法。有云。准梵本此脱第四。一以进力现世除物无明。以最初故偏从火义。二惑有二义。一漂二恼。善巧回转则能息之。三称性之福相惑不动。与大悲合自利不动。俱能摄德无尽名藏。四有云。准梵本神名胜上蕊光普照。法门名普能除烦恼尘。谓劫海行满故。今能现通灭惑。偈云。众妙宫神同前列名。众妙即胜上义耳。然诸本多无。或有本。则具云众妙宫殿主火神得大慈悲广荫众生解脱门。恐是传写脱漏耳。五光明照耀等者。日光合空等空无际。智符实相称实无边。虽旷劫修成全同本有。穷灵极数妙尽难思。实为惑本。即是正因。智照心源即是了因。如空与日。今略申十义。以辩难思。一谓日与空非即非离。二非住非不住。三而日善作破闇良缘显空之要。四虽复灭闇显空。空无损益。五理实无损。事以推之闇蔽永除。性乃无增。空界所含万像皆现。六而此虚空性虽清净。若无日光则有闇起。七非以虚空空故自能除闇。闇若除者必假日光。八日若无空无光无照。空若无日闇不自除。九然此闇性无来无去。日之体相亦不生不灭。十但有日照空则乾坤洞晓。以智慧日照心性空。亦有十义准喻思之。非唯释此文。亦乃远通众经该罗前后。六体寂发照名寂静光。以斯成福庄严身相七八可知。九分别法相永离不了愚痴。悟法实性便无执着之见。十以行扶愿故能现世。作师子吼。颂加第四余并可知。第七主水神长行十法。一无缘大慈是曰平等。二无边行法庄严自他。三寂然不动以观机。感而遂通以随摄。若冬则积雪凝白。夏则无处不流。四妙音演佛深旨。令悟妙法旋澓。五身智二光遍觉开化。大充法界清净无垢。六清净法界性相俱绝。德无不见则大用不亡。七众生不穷故大悲无尽。满而不溢有知足义焉。流止从缘斯为自在。八处处见佛。故大喜无穷。喜从佛生即佛名藏。若聆泉流之响无不悦也。九性相无碍之福。故能普现神通。若空色相映之流。威光荡漾。十调生行广如空无边。用靡暂停。如空无尽。偈中第一偈。前半辩一相因果。次句例余。后句辩益。初言清净者。离过无缘故。门如尘数者随宜利乐故。以慈为因得妙相果。以相为因得无厌果。然如来相有纯有杂。此就纯门。若以杂门则随一相一毛。皆收如来法界行尽。亦相相皆尔。纯杂无碍因果相融。圆成非分成故。佛一相一毛即同法界无有分量。今此神从一慈门。入无尽相耳。此约十身之相。若三十二相之因。但说一相一因。如智度瑜伽等论。涅槃大集等经。至相海品当引第五偈。初言无尽以显光常。次充法界以辩光遍。不思议者以显光深。非色现色。非青黄而青黄故。其第三句是显光用。余九可知。第八主海神十法。颂脱第三。一为物供佛。是等施福得众宝相。以庄严身。二巧随根欲说法护善。使其长成。三谓演深广法体烦恼空。梵本偈云一切世间众导师。法云大雨不可测。消竭无穷诸苦海。此离垢尘入法门。若准此文。乃竭苦海。四若见佛境则惑亡苦息。准现经文。三是烦恼。四是于苦。若依梵本前苦后惑。既译人脱漏。致使文义参差。故古德云。脱第四颂。结名既同故知脱第三。恒住波浪者。即是普用水为宫殿。五以智灭痴。六为行所迁一切皆苦。菩提因起则生灭苦亡。便得涅槃寂灭安乐。七将智灭痴。未免于见。了痴见性痴见自亡。真妄等观是佛境也。八一切众生有佛种性。圆明可贵具德称宝。佛眼普观佛智普示。正因令显如出金藏。大心若起如种生芽。故云出生。缘了二因为能悟之妙道。九了如不取则心不摇动。湛如停海。万德攸归故须弥可倾。魔岂能娆。一念降魔如本行集。十入法界定。如法界遍偈可知。第九主河神十法。一行成雨法。若霈然洪霔灭惑生德。若悬河迅流无所滞碍。二现身息恼若泉涧洗心。三真实涤垢慈智相资。若碧沼澄潭空色交映。故名离尘净眼。四圆音遍益若崩浪发响。五拯救漂溺。六善根无惑可谓清凉。若阿耨达池永无热恼。七施门无量令彼无悭。若蕴藻菱莲普令物喜。八行福契实故见无不欣。若深湖广陂是为广德。九方便慧力杂染皆净慈。彼怨害嗔反成欢。若万顷波澄光映天下十总收万善令会涅槃。若彼百川咸会大海。会海由智名海德光明。偈亦可知。第十主稼神十法。一功德智慧。二种法味资成佛身。二喜乐由于苦除。三众生为所净之境。四悲深故通广。五下种物田必至果无坏。六智敷物信获果称华。七慈眼视物故福聚无量。慈则恬和怡悦。偈云胜道。八以行成佛故始成即宣。九懈于修习忧恼。是生勤策诸根众恶清净。十随根为说遂求故喜。偈文可知。第十一主药神十法十颂。一顺情则易摄。逆意则难调。故普观之。二三可知。四始学者以名为实宾。大士以名为佛事。五以慈善根力。放月爱等光。身心两病才念便灭。六迷理迷报。二愚盲冥起惑造业。备受众苦。佛以正法金[金*畀]开其智眼。令明见三谛。故云清净。七八可知。九无爱见之大悲生物德故名藏。十世医疗治虽瘥还生。永灭生德无先念佛。因病因光皆是方便。谓佛有无边相。相有无边好。好放无边光。光摄无边众。言随念者佛德齐均。随缘随乐趣称一佛。三昧易成。敬一心浓余尽然矣况心凝觉路闇蹈大方。颂可知。第十二主林神十法十颂。一佛德无边皆依智海。含德流光所以名藏。二等众生悲是为广大。一一离障名普清净。三一切胜因皆为佛道。各各心净则种种芽生。四一切功德庄严一毛。一一皆然。故佛为德聚。良以佛果缆因。皆圆成非分成。是故一因生一切果。一果收一切因。皆圆融无碍耳。五智通万法是曰普门。客尘不生故曰清净。悟如日照顿周法界。功如拂镜说智渐明。明是本明渐为圆渐。六知遍趣行如应布法。七了音声性皆同佛音。故无不可意。能令世间皆闻佛音。方云清净。八昔行称周法界是广大境。神通普令物见仿。而行之。如下喜目即其事也。九众生谄佞自不修德。宁有进贤之心。今福智益他。则物我兼利。偈云譣诐即谄佞也。十敬念则佛兴。佛兴则庄严德藏。障重者。不念不见于佛岂无常哉。故应见常见也第十三主山神十法。一寂而常照故光无不阐。二相光熟机。皆慈善根力。如涅槃广明。三修因严根本为顺物故。瞩莲目而欣乐。睹月面而欢心。或见诸根一一皆周法界。喜益深矣。四如空不染故长劫无怠。五痴故长眠。唯福智之能觉。次三可知。九若睡若寤皆令闻法进行。斯为佛业。如大璎珞经说过去有佛凡欲说法。令大众眠梦中说法。令增善根觉得道果。涅槃亦云。其人梦中见罗刹像等。亦表万法皆梦。大梦之夜。必有大觉之明。十称性法门无边大义。一音能演是出现也。第十四主地神十法。一念念无间平等普观。修慈护法故得金刚之体。金刚即内照之实也。二一毛福力顿现众福。三证入无生不碍严刹。四一向为他。五观机出现名为游戏。六现净惑身方调物惑。七内具德海现威力身。如地含海润发生百谷。百谷苗稼皆地香毛故。八长行一言尽摄无余。偈颂则一言普遍无极。九焰云普遍。令物离垢为性。十法能摄持心行。如金刚之轮。佛则不动现世。若须弥出海。此下颂中。亦有二句结法属人。可以意得。第十五主城神十法。有云。脱第九法。十颂具足。一光等方便成熟利益。二应病与药令得服行。三护法法存则物受福德。教理行果皆有护也。四悲救无尽名藏。五了佛大智。六方便现身。七同修佛德。八迷真俗理故云愚闇佛出开示令其悟入。本迷无始犹若生盲虽闻譬喻竟不识乳。唯佛出世方能晓之。九准梵本。云香幢庄严髻主城神。得破一切烦恼臭气。出生一切智性香气解脱门。谓正使为臭物。残习为臭气。智性为香体。利物为香气。香气若高山之出云。称智性而无尽。臭气若香风之卷雾。等性空之无边。烦恼则尘习双亡。智慧则自他兼利。有本亦具云。香髻庄严主城神。得开发众生清净妙智解脱门。亦恐传写之脱漏耳。义不异前。偈云现梦中者。梦是神游。亦见闻之气分也。梦中尚调况于觉悟。如迦旃延为弟子现梦境界等。十二障五盖重叠如山。非智光明莫之能破。第十六道场神十一法。十一偈。一出现字两用。谓有佛出现。即出现庄严具。而为供养。佛昔如是神以大愿仿之。二对物成行令物仿之。施为行先故偈偏举。三梦觉皆化则时处俱遍。四外宝内眼重重难舍。为物说行故云能雨。五清净焰形神。前列中无。谓色相道场俱妙庄严。并为熟物。六疑境界者。以唯心为正念。疑法性者。以无得为正念。实则无正无邪。方称曰正。无念不念是真念矣。诸念不生正念方生耳。故随根雨法断疑生智。七辩才雨法称根故喜。八深广赞佛。故名实双美。九树王眷属并如经初。十即前身遍十方。而无来往。智入诸相了法空寂也。十一种种力者。佛有无量力故。因行亦然。皆严具显示。既是道场之神故。得道场事中解脱。第十七足行神十法。初二可知。三内则念念安于理事。外则处处建立道场。四举足下足海印发辉。诸有威仪无非佛事。五以华以光雨宝雨法。六众生无边是佛化境。见佛闻法故生欢喜。七圆音警物。等栴檀之香风。暂一熏修觉身心之调顺。余三可知。第十八身众神十法。一净喜境界神者。初列处。名华髻庄严。或是名广略举其半。或梵音相类。译者之误未勘梵本。法门初三可知。四相即无相。故如空遍住。空非独虚亦遍于色。住非分住一尘亦周。如芥子空即不可尽。身与法性不可分故。五威仪施化无心顿现。斯即佛境难以言思。六佛为良田出世难遇。一兴微供果获五常。略言色力。亦有常命安乐辩才。此五皆常方云满足。受报无尽故悉离贫穷。七齿光除垢。表所说净故。八有染于五尘。无慈于六趣者。愚痴魔业也。体五欲性虚己兼亡。彼业斯转而名云守护。摄持者。善守根门摄散持德。则远魔矣。然魔事惑。不出三毒及慢。魔恼众生不出三事。谓上妙五欲及诸苦。具为说邪法。则三毒是生。三毒内着即为魔业。今守护觉察魔如之何。即偈中解脱道也。九有三意。一身虽周于法界。多示为王摄御自在故。二八相处于王宫俯接物故。三法界。菩提树下法王宫故。十迷于本空故有妄苦。无漏本有是净善根。第十九金刚神长行十法。一见如来身普现非别。岂唯凡现之处即无边相。亦随一一色相。皆无有边。次四可知。但第五神。初卷中名诸根美妙。今但云妙臂。文义俱阙。又加天主。以现为世主故。六法海深奥槃节差别。巧说令现无有遗余。七约神且说宝饰为严。巧摄己众。约佛方便相好为严无不摄也。八因深故大福为能严。果胜故德相皆明足。九恶谓十恶。险者恶之因也。能陷自他及险道故。十若以现文则摩尼髻是所雨。若以义取此神名摩尼髻亦得髻是能雨一切菩萨严具是所雨。表菩萨智光圆满故。偈中第六云漩澓者水之漩流洄澓之处。一甚深故。二回转故。三难渡故。法海漩澓亦然。一唯佛能究故。二真妄相循难穷初后故。三闻空谓空则沈于漩澓。闻有谓有等皆类此知。故云一切差别义也。余并可知。上来异生众竟

(已下入第五经)自下第二同生众。文分为三。初明普贤菩萨得一切法门。次十普菩萨各得一门。后十异名菩萨各一法门。此三各有长行及颂。就初普贤长行中二。初总标所入。二别显十门。今初二句先指陈法体。次辩法功能。今初言不思议者。谓数过图度理绝言思。故言方便海者谓不动真而成事。巧以因门契果。故云方便。后入如来下。辩法功能。谓证入因圆趣入果海故。然前后但明以别入总。故各得一解脱门。犹如百川一一入海。今明以总入总如海入海。故得难思解脱门复称能入为方便海。以普贤是同异二众之上首故。二所谓下。别显十门以彰无尽。一严土调生调随所化众生取佛土故。一切佛土者。竖通四土横该法界。横竖相融故。一尘一刹皆广大严净。故云一切。演最妙法故。令所调究竟出离。二佛遍尘道诣彼修德。乃了彼境。三通辩安立菩萨六种功德。一位。二愿。余四在偈。四身普应机演所证法。五国土不同所敬各异。故随宜立称成益不空如名号品。六尘中现身说菩萨行境。七以时随法融。令三世劫及劫中成坏一念中现。无所障碍。然事通能所。能成坏事谓火水及风。所成坏事天地万像。八菩萨根海虽繁广多类。但能入自所知境界。岂能测量佛无边法。则显前来众海未测佛德。普贤能知此理。九明如来身体同虚空用周法界。第十摄因成果。故云一切菩萨行入一切智也。妙音宣此故云显示。此亦别释标中第二句。颂中次第如前十门。第一偈。前半严净佛国。后半调伏众生。兼显人法为严之义。佛子有三。一者外子。谓诸凡夫未能绍继佛家事故。二者庶子。谓诸二乘不从如来大法生故。三者真子。谓大菩萨从大法喜正所生故。此言清净意显第三。最妙法者。拣非权少。昔以妙法净所化心。故所感土亦有清净佛子来生其国还雨妙法。二中前半明总遍别中后半明体用无碍。亦是总遍总中三中四句即前四义。一修十胜行。二起十方便。三所证十如。四正证法界。成萨婆若地位为总。余五为别。四中前半普现身。后半演所证。次四偈可知。九中初句智身。次句智身等法身后二句。化用等法身之周遍。略举正觉实通一切。故上云种种。十中三句摄因后句成果。第二十普菩萨各得一门。第一菩萨前列名中无。以前与普贤共为十普。今普贤别说故加为十。以表圆足。然偈文具十。长行中第七菩萨及法门俱脱。又脱第八菩萨法门。及第九菩萨名至文当知。十中第一严处说法。皆名为严。二尘尘皆成正觉。已为无尽。方是正觉一门。有如是等无量成正觉门。如出现品辩。随所成正觉门调生亦尔。故云成熟不思议众生界。三修行福海严出刹海。四以深妙智观难思境故。多处不迷多劫不厌。五如一逝多林会。顿现一切净土。会会皆尔。念念现殊。六法界舍摄无尽。故名为藏。观佛法界之身。一毛即无分限。七梵本中名普觉悦意声菩萨。得亲近承事一切佛。供养藏解脱门。谓佛昔行因无佛不供。今成佛果无众不归。犹如百川驰流趣海。八准梵本。应云普清净无尽福威光菩萨。得出生一切神变广大加持解脱门。谓遍刹充尘劫穷来际。皆佛加持之力。九梵本中。即普宝髻华幢菩萨。得普入一切世间行。出生菩萨无边行门解脱门。即今经中威光菩萨法门。是由脱第八法门及第九菩萨之名。遂令第九法门系于第八之下。译者之谬也。谓若无大悲不入生死。则不能出菩萨行门。如不入海安能得宝。此即化他成己。十即依体起用。颂文前已配释。欲表菩萨法门互入。故不结法属人后段亦然。第三十异名菩萨。亦各一法长行中。一得成菩萨四种方便。一地位。二度行。三调生即行位所作。四严刹通二利因果也。或一地一度满。或地地诸度满。此一为总下九皆别。然不出上四多显调生。谓二遍转法轮。三普示灭惑。四普严场会。五以法随机。六为物永存。七法印悟物。八顿显终始。九同佛往修。十光显如来难思之境。以偈对释文并可知。唯第六偈略须开示。初句所证性净法身。言无相者。示真如相。身即体义在缠不染。出障非净。凡圣必同故云平等。次句出缠法身也。真如出烦恼障。故云离垢。出所知障故云光明又尘习双亡。故云离垢。真智圆满故曰光明。净法身者拣于在缠。后半体用无碍身。由出缠故应用无方。约理即是体用无碍。约用则止观双运。故得果则寂照为身。即用之体故寂。即体之用故智。体用既无不在佛身何有量耶。故能普应十方。此句正显化用故。经云。水银和真金。能涂诸色像。智慧与法身处处应现。往即斯义也

大方广佛华严经疏卷第七大方广佛华严经疏卷第八

        唐清凉山大华严寺沙门澄观撰

自下第八。明座内众流分。于中长分十段。一明出处。二显众类。三列众名。四结众数。五兴云供。六供众海。七敬绕佛。八座本方。九叹德能。十申偈赞。今初座即是总。宝等为别。如是已下结广从略。非独轮等故云一切。所以此能出者。良以。座该法界依正。混融一一纤尘。无不广容普遍。座所遍刹恒在座中。故从中出。非是化也若约法空之因。及法空之座。则万行为严能生菩萨。二一一下。显众类皆菩萨故。三其名下列众名。出处既多名亦多种。略举上首十名耳。即如次十方。四如是等下结众数。严具非一故。有众多刹尘。五此诸菩萨下兴供云。六彼诸下供众海。众多菩萨各兴刹尘供云。已重叠难思。况相续不绝。而诸供具皆称云者。乃有多义。谓色相显然。智揽无性从法性空无生法起能现所现。迥无所依应用而来故。来无所从。用谢而去故。去无所至。而能含慈润霔法雨。益万物重重无碍。有云像焉。上下诸文云义皆尔。七现是云已下。明敬绕佛。顺向殷重瞻望不足。乃至百千。八随其下。坐本方参而不杂也。如师子子亦师子故菩萨座亦名师子。自化自坐者。自心智现还自安处故。诸佛菩萨坐多跏趺者。为物轨故。智论引偈云。若结跏趺坐身安入三昧等。九是诸菩萨下。叹其德能者。有十二句。初总余别。别显一一各是一种清净广大。略束为三。初三明三业清净广大。一智证普法。二身随佛行。三语入辩海中。一义求亦通三业。次三明得法清净广大。一获自分解脱。二住胜进果位。三遍具诸持。普门地言即同经初已践如来普光明地。后五福智清净广大。初二正明。后三重显。今初中一智安理事故云善住。二福无不修故生信喜。然三世平等经初已明。今更略示。谓依生及佛善住平等。且依佛说佛佛平等。法身智身无增减故。若依众生。生生平等烦恼业苦有支皆等。若生佛相望者。凡夫现在等佛过去。进修得果等佛现在。成佛究竟等佛常住。此约三世互望。烦恼佛则本有今无。众生则本无今有。菩提则众生本有今无诸佛则本无今有。约迷悟异则说本今。涅槃之性非三世摄。故知三世有法无有是处。若以性净而说。则佛与众生现今平等。而不妨迷悟之殊。是故三乘亦有差别。亦无差别。众生寂灭即是法身。法身随缘即是众生故。寂灭非无之众生。恒不异真而成立。随缘非有之法身。恒不异事而显现是故染净三世一切诸法。无不平等。况称性互收。如是解者。名为善住一切智地。如地能生终归于地。万法依于佛智究竟。还至一切智也。后三重显中。一净前福障故。令诸福无边清净。二成上智慧。由观法界虚空。三近胜缘故成前二十。尔时下说偈赞佛中。十菩萨各别说偈。即为十段。就初海慧颂中。叹佛身座。初五叹佛身具德。一赞智慧。二赞功德。三神通。四因深。五果胜。后五叹所坐严丽。此众既从座现。故多叹座。文并可知。第二雷音菩萨十颂叹座及地。文分三别。初四直叹座可知。次三叹于场地。即转显座严。于中初一总显因深德广。故严事难思。金刚下别显。末后一句结莹宝座。后三偈叹地上之严。于中前二地神兴供严。后一佛力展转严。第三众宝光髻菩萨赞中。独赞场地殊异德。十颂分二前五德用圆备。后五法化流通。言如佛座上所应演者。九会五周之文。一化随宜之说。已具演于场地之中。第四大智日颂叹佛所处宫殿。十颂分二。初一总明。次段赞处彰人。故此偈标人显处。凝者严整之貌。睟者视也。谓肃然而视。后九别明。于中二。前四明宫殿体摄众德。即广其前半。后五明妙用自在。即广其后半。今初。初一宫殿虽耀佛坐增明。即广前炳然照耀宫殿中也。次二颂略辩七严。结以智海。广上凝睟处法堂也。谓内持宝柱檐垂金铃。外列门阶上罗华帐。宝树交映宝璎周垂。为七严也。闼小门也。洞达也。如云布者。重重无量次次相承也。上云凝睟则目视不瞬。特由内无识浪故云智海湛然。次一颂。罗以宝网列以香幢。布以焰明覆以严具。结云超世。即广上世尊处法堂也。光如云布者。若彩云向日上下齐明也。后五中。一罗身云以调生。正显前文现十方土。二宝树现三世之严。三略举多严。四即上诸严卷摄多严重重佛坐。五结叹无尽主伴云会。第五不思议菩萨。通赞场树自在德。十颂分二。初一总显。谓宿因愿力深广难思。神通现缘生果严净。后九别显分三。初五叹树具德严场。于中初二身干森耸。次二枝叶荫映。后一华果芬辉。二有一偈。叹场地。莲网谓莲华布地则下转光轮。宝网罗空则云间响发。三有三偈。叹树自在。初一收入。后二出生。第六百目菩萨颂中。双叹场树备德。自在法化宣流。前九偈各一门。后一结严周遍并显可知。第七金焰颂。叹佛十方功德。一颂一力下。诸经文屡明十力。是佛不共之德。佛佛等有菩萨缘此发心。梵行品云。复应修习。一一力中有无量义。悉应咨问。故不可不知。然大般若五十三。显扬第四。对法第十四广辩。今略以七门分别。一立意。二释名。三自性。四作业。五次第。六差别。七释文。然了其名则知作业。对文料拣差别易见。故将作业差别。并释别名。并于释文中显。今初立意者。智论意云。显佛大人有真实力。令外道心伏。二乘希向菩萨仿之。能成办大事。终获其果故须辩之。如来唯一诸法实相智力。此力有十种用。故说为十。谓于十境皆委悉正知故。由时品类相续分别。有无量力。度人因缘故但说十。足办其事。谓以初力。知可度不可度。次业力。知有障无障。以定力知味着不味着。以根力知智多少。以欲力知所乐。以性力知深心所趣。以至处力筹量众生解脱门。以宿命力分别先所从来以生死力分别生处好丑。以漏尽力知众生得涅槃佛以此十度生审谛故但说十。第二释名。初总后别。今初总名力者。能摧怨敌义。不可屈伏义。故说名力。瑜伽云。与一切种。饶益一切有情。功能具相应故。毕竟胜伏一切魔怨。大威力故。说名为力。对法云。善除众魔善记问论。故十名力。十者是数。带数释也。别名至文当释。三自性者。瑜伽五十七云。佛具知根慧根为体。对法论云。若定若慧。及彼相应诸心心所为性。菩萨地。总以五根为性。统其文义应具六种。一最胜体故。决择分中慧根为性。二引生体。对法兼定。三克实体。菩萨地云。五根为性由慧胜故。且说十力慧为自性。所以但言处非处等智力。不言信进等力。四相应体。对法兼取相应心法。四蕴为性。五眷属体。五蕴为体。定共道共无漏色等。助为体故。此虽无文理必应尔。遮犯戒垢助摧怨故。六依此经。融一切法以为其性。无碍法界理应尔故。四作业者。即是辩相至文当显。五次第者。诸文或有前。却各有所由。此文所列次第。与十住全同。净行品则界在解前。梵行品禅定解脱当其第三。宿命居天眼之后。余同此。次瑜伽四十九。及智论二十七。亦禅居第三。余同此次。且依论明次第者。智论云。初力为总余九为别。于初力中分别有九故。初一力通知万法。下九展转开之。谓初令知因缘果报。故起业力。次业烦恼故缚净。禅定解脱故。解令去缚就解。次根有利钝。钝者为有造业。利者为不生故。集业由善恶二欲成上下根。此二种欲由二种性。以有种种性因缘故。行二种道。谓善道恶道。次知其过去审彼未来。次以方便坏其因缘果报相续。故说漏尽。瑜伽有多门次第广如第五十说。上来依论次第。而今禅居第七者。二论梵行。为对自业。有离欲不离欲。故禅居第三。此经十住为对遍趣行。有清净不清净。故居第七。若习欲成性即界居欲后若由性起欲则界居欲前。若执常者先说宿住。若为执断先辩其天眼。余无别理故经论皆定。六差别者。谓此十力展转相望。亦有差别。亦无差别。至文当明。七释文。然此经宗异义。皆融摄故。一一力中具摄十力。乃至包尽法界。是以宿命乃云智包三世。天眼则见尽法界。非唯见尽。佛眼如空即是法界。非唯智包。亦能毛孔顿现。业力即观法性。岂唯但是有为。约门有殊故他宗不坏。第一偈即处非处智力。谓善因乐果斯有是处。善因苦果无有是处。恶因苦果等例上可知。处者建立义。依义起义。能建立果与果为依。能起果法故立处名。于此正知故名智力。其作业者。即如实知因之与果。及能降伏无因恶因种种诤论。既遍知已可度者度。不可度者为作因缘。文中上半往因。下半显智力。于诸境界正解明了。即辩此力通知一切法也。第二偈。即过未现在业报智力。瑜伽名自业智力。今言一切业者。谓于三世中善等三业。及顺现等皆名自业。于自所作受用果业。如实知故。与初何别。若正了知所造善等业感爱等果。此由初力。若了能造善恶等业感爱等果。是自业力。文中上半往因。下半现果。第三偈。即根胜劣智力。谓信等五根。此软中上名为胜劣。于此正知。及能于彼如应如宜。为说正法。即是作业。偈中三句往因。一句今果。四即种种解智力。亦名胜解。谓若从他起信以为其先。或观诸法以为其先。成软中上爱乐名种种胜解。亦名为欲。欲谓信喜好乐。如或贪财利或好名闻。好定好慧种种不同。如来正知。令舍不净。增长于净。此与前根何异根约宿成智有多少。解约现起好乐不同。论云。若照诸根为先。彼彼法中种种意乐。是根智力。若正分别意乐差别。是解智力。在文可见。五即种种界智力。界即性也谓或一二三四五乘性等。或贪嗔痴等分行等。乃至八万四千行名种种性。性即种子即解现行。故智论云。性名积集相。又九十云。性内欲外用性作业必受果报。欲或不尔。瑜伽云。若照胜解所起相似种子。此由解力。若照即彼种子差别。由界智力。若习欲成性。复云何别。欲唯大地一数。性通诸数。即宽陜不同也。智论云。习欲成性性名深心。事欲名随缘起。若性即种子与根何异。根唯信等优劣。性通善恶不同。以信等望果宽长。能生人天三乘圣道。为道之根。三善根但是翻对不望果义。尚不名根。况性通于恶。岂得同耶。偈云悉能显现毛孔中者。谓非唯佛智如空包纳众生之性。毛孔内空亦现众生之界耳。六即一切至处道智力。论名遍趣行智力。遍即一切。趣即至也。行即道也。谓诸众生种种所行。若出离行不出离行。各能至果。如行有漏行生五道中。行无漏行至涅槃果。名遍趣行。若知如是种类行迹趣入。此由界智。若知即彼行迹一切品类。如是行迹能令杂染。如是行迹能令清净。此由遍趣智力。初力处对非处。此中但明至处。又初力指因。为得果之处。此约果是酬因之处。故不同也。经中初句总标。次一念即能知迅速。下十二字。所知时处。后一句委悉开示。七即禅定解脱三昧智力。净行品中。加于染净通漏无漏故。佛皆善知。及知依此所得诸果。故名智力。此与自业智力何别。若了诸有能修诸定。即彼能入而非所。余名自业力。若了依如是静虑等定。现三神变。无倒教授所化有情。此由静虑智力。偈中上半所知。下半善用。言佛为示现者。示其诸定现三神变。令有情喜使涤烦恼。即令去染而得清净。八即宿住随念智力。谓过去境本生本事住宿世。故名为宿住。于此宿住而起随念。念俱行智名宿住智力。瑜伽云。若知前际随念一切趣因。是遍趣力。若知前际名姓。苦乐等事名宿住力。此与智论云何会释。谓彼论云。但知宿命所经。不知诸业因缘相续。但名为通凡夫亦得。若兼知业因缘相续则名为明。二乘能得。若知上二无量无边则名为力。斯则力亦知因矣故应通云。若但知因是遍趣力。若双知者。即宿住力。瑜伽为对遍趣之因。故但云果耳。文中初句标。能念智包三世者。三世全在佛智之中。况于随念。不知三世从门别。故但云宿住。刹那悉现即包现之时极促现毛孔中。即能现之处至微。第三句。即所现所念之事广。第四句结归智力。非唯能念亦能现也。九天眼智力。独此从所依以立名也。若从境者。瑜伽名生死智力。谓死此生彼堕善恶趣。大小好丑皆能正知。知前际生死。名为宿住。要知后际得此力名。今文乃云佛眼者。若约五眼。余眼在佛皆佛眼故。此非经宗。今依十眼。佛眼能见如来十力故。故此一力即摄十力。举一为例余九皆然。文中初句体大。次句用广。次句用胜。以无等故。后句结其甚深。故唯佛能演。既言普见法界非局未来。约宗别故。于未来门普见法界也。十漏尽智力。于自解脱无惑无疑。亦知众生漏尽涅槃。于此正知名为智力。文中。初二句所断。诸结即现行。随眠即种子。习气即余习。二乘不能尽习亦不能尽他漏。故不名力。后半显佛能灭。然上十力智即是体。力即是用。然智即力更无别性。此中宿住随念相应智力。是邻近释。自余从境皆依主释设天眼从所依。亦依主释。若宿住是境。随念相应智力。亦依主释。然此十力望于自事。各于自事中。大如水能净如火能烧。各有自力。若约总摄初力为大。若约办得涅槃漏尽为大。若以无碍解脱而为根本。则平等平等。第八法界颂中。叹佛往修十度行满。今得果圆。十一颂分二。初一总余十别。今初也。佛威神力略有三类。一者俱生力。谓风不动衣等。二者圣威力。谓通明等种种功德。三者法威力。谓波罗蜜圆满法力。令五根中无诸非净。四支百节有无量力。故名坚固不可坏法身常身无边之身。言遍十方者即无边身。广大示现谓变化身。无分别者。平等智身。大菩提行者。波罗蜜身。昔所满足者。众行先成。皆令见者。大果今出。二有十颂别显二颂一度。皆上半往修因。下半今得果。十度之义。十行十地一经始末亦多辩之。须粗识其相。略启十门。一释名。二出体。三辩相。四建立。五次第。六相摄。七修证。八约教。九观心。十释文。今初又二。先通名后别称。今初。通称波罗蜜多者。唯识云。要七最胜之所摄受。方可建立波罗蜜多。一安住最胜谓要安住菩萨种性。二依止最胜。谓要依止大菩提心。三意乐最胜。谓要慈愍一切有情。四事业最胜。谓要具行一切事业。五巧便最胜。谓要无相智之所摄受。六回向最胜。谓要回向无上菩提七清净最胜。谓要不为二障间杂。即三时无悔。若七随阙非到彼岸。故此十度应各四句分别。其别称及出体。三辨相至文当释。四建立者。为十地中对治十障证十真如。故但有十。为对六蔽渐修佛法。渐熟有情故但说六。六中前三增上生道。感大财体及眷属故。后三决定胜道。能伏烦恼成熟有情及佛法故。又前三饶益有情。施财不恼忍彼恼故。后三对治烦恼。勤修加行永伏永灭故。又由前三故不住涅槃。由后三故不住生死。能为无住涅槃资粮。后唯四者助六令满。方便助前三。愿助精进。力助静虑智助般若。如深密说。五次第者。谓由前前引发后后。及由后后持净前前。又前前粗后后细。易难修习次第如是。六相摄者。此十一一皆摄一切波罗蜜多。互相顺故。般若论云。檀义摄于六。资生无畏法等。智论云。有未庄严波罗蜜即不摄者。有已庄严波罗蜜即相摄者。今此经文必具摄十。若但说六六摄后四。若开为十。第六唯摄无分别智。后四皆是后得智摄。七修证者。五位通修佛方究竟。十约因位总有三名。谓初无数劫。施等势力尚微。被烦恼伏。但名波罗蜜多。第二劫去势力渐增。能伏烦恼。名近波罗蜜多。第三僧祇势力转增能毕竟伏一切烦恼。名大波罗蜜多。故上下文中。屡言广大波罗蜜也。八约教者。诸教可思此教要须一一融摄。彻果该因。九观心者可以意得。十释文中。第一偈明施度。辍己惠人名之为施。即以无贪及所起三业。而为其性。此有三种。谓财法无畏。止半因中大悲行施。已该此三。此悲亦是七最胜中前三最胜。下半果中财能资身。无畏益心。法资法身。故得果身身最殊妙。三皆悦物故见者必喜。亦由具七最胜故。身殊妙也。二戒度。防非止恶名之为戒。即受学菩萨戒时。三业为性。戒有三种律仪摄善得净身果。摄众生戒能除物苦。遍十方者。无作戒身等众生故。三忍者。堪受诸法未能忘怀名之为忍。此约生忍。又忍即忍可。忍即是慧。双忍事理。即以无嗔精进审慧及彼所起三业为性。忍亦有三。谓耐怨害忍。安受苦忍。谛察法忍。偈云。信解真实即谛察法也。色相圆满前二忍果。放净光明第三忍果。四精进者。练心于法名之为精。精心务达目之为进。以勤及所起三业为性。亦有三种。一被甲。二摄善。三利乐。初句通前二。以被甲精进。瑜伽释云。设千大劫为一日夜处于地狱。唯为脱一众生故。次句即第三。下半通三果也。因既离身心相故。果能身遍十方。五禅者梵云禅那。此云静虑。即以等持为性。亦有三种。谓安住引发办事。既引起神通办利生事。故见者深喜。现法乐住诸惑不行。又资慧断惑。故见者惑灭。六般若者。般若梵言。此翻为慧。推求谛理名之慧也。此及后四。皆择法为体。亦有三种。一生空无分别。二法空无分别。三俱空无分别。摄论以加行正体后得为三。约六度说。璎珞以照有照无及照中道。而为三者。唯约法空。三观之义至下当明。慧导万行。故云修诸行海。言具足者。具上三也。因如有目。故果获身智二光能灭诸闇。七方便者。即善巧也。方谓方法便谓便宜。下四但各二种。今初谓回向方便。拔济方便。文云。种种化生。即拔济善巧。所修成就。兼于回向菩提。所化无边。果得十方而横遍。为物取果竖穷来际而不休。八愿者。即希求要誓。有义。即以欲胜解及信为性。亦有二种。谓求菩提愿利乐他愿。由初愿故出现世间。由后愿故救生不息。九力者。不可屈伏故随思随修。任运成就。亦有二种。谓思择修习。今言法力。即思择诸法而修习故。摄论由此二力。令前六度无间现前。经云成自然力。即无师而成。不习而无不利。何能坏哉。十智度。决断名智谓如实觉了。亦有二种。谓受用法乐智。成熟有情智。无性论云。由施等六成此智。复由此智成立六种。名受法乐。由此妙智能正了知此施戒等。饶益有情。经云普门智。总含二智。别配即初句成熟有情。次句即受用法乐。此二无二故。成无碍力舒光普照。第九云音颂。述菩提树摩尼果中。叹佛往修十地行果。十一颂分二。初一总举。谓佛果大用。由昔地行及结说处。余十次第各述一地。地义当品广明。今皆略述而已。初地略述四义。一加行多劫。诸论皆说地前为一僧祇。已为无量。更有异说恐厌繁文。二标入地名。三出生广智。谓生如来家见法实性。得妙观察平等性智故。四普见佛海。同下愿智果中。二地四义。一举法标名。二别地行相。三修行时分。四供佛多少。三地四义。一举法标名。世间中极云积福德。二修诸禅定。三忍度偏多。四闻持广博。四地四义。一叹慧标名。世无等故二了道品境异凡夫故。二起慈悲异小乘故。四净身土离身见故。五地四义。一标入地。谓积集福智故云普藏。十平等心故曰等门。三标地名。三真俗极违会令相顺。四谛法俗境无不等观。六地有四。一叹行。二标名。三正显行相。即了缘起法。四明地用。得十空三昧故。七地有四。一先标果用。二照达群机。三双行巧摄。四寄行标名。八地四义。一别地行相。二明净土果。三略释地名。四叹地结说。九地四义。一标地作用。二善达教法。三标示地名。四广行多劫。十地有四。一标起地名。二含藏法雨。三能蔽如空粗重。四深广难测。故云佛境。诸偈多有结说文并可知。第十善勇猛说颂仪中。前文多皆观众会。此观十方者。观众表无偏心。观方表说周遍。二文影略。十颂叹佛体用应机自在德。文分为三。初一总显。次八别明。后一结叹归佛。一一颂中各有四义。今初总叹佛令物悟入福智。有四义者。一多众。二心异。三悟智。四了福庄严即福也。亦通二严。皆佛令尔故显众德即为叹佛。别中一见佛体用。亦四义。一起愿。二具行。三见体。四见用。二见法身。一胜故无等。二净故无碍。三大故周遍。四深广故包含。三见佛色身。一色妙。谓如金等。二相具十华藏相等。三光盛。谓常放等。四随机变。谓三尺无边等。四见佛智身。一无碍。无二碍故。真俗无碍故。二等空称法性故。三知根。四巧现。五了佛音声。一音普遍。二说应器。三言同类。四应无碍。六见佛光明。一多种。二遍照。三见佛。四现变。七见佛毛光。一显光名。二明出处。三示往因。四令信悟。八见佛福相。一见福相。二了福因。三示因体。四明见处。后一结叹德广。一数多。二深广。三用普。四结说。谓推功归佛谦己无能。上来总明第八大叚座内众流竟。自下第九明天地征祥。谓动地兴供即是显证。上来佛成正觉。众海云集。各申庆赞显佛高深。而下称机情上协佛愿。故世主为之兴供。天地为之呈祥。就文分二。先动地后兴供。前中三。一动处。二动因。三动相。今初自陜之宽。且云华藏。约下结通。实周法界。诸天重重并华藏之内。故云其地何所不该。又染净融故。虽标摩竭而地震华藏。二动因中就主显胜。但明佛力感应道交。亦由物机。然泛明动因。总有其十。今当转法轮亦兼成道余如别章。三动相者。其地下是震即是声。动即是形声兼吼击。形兼起踊。故有六种。此六各三成十八相。摇扬不安为动。自下渐高为起。忽然腾举为踊。隐隐出声为震。雄声郁遏为吼。砰磕发响为击。十八相者。唯一方动直尔名动。四方若次第。若一时动者名为遍动。若八方次第。或一时动名普遍动。又四方八方十方如次名三相动。又一方独动。十方次第动。十方同时动。又为三相。余五例之。然动何所为。依胜思惟梵天经。所为有七。一令诸魔怖故。二为说法时。大众心不散乱故。三令放逸者生觉知故。四令众生知法相故。五令众生观说法处故。六令成熟者得解脱故。七令随顺问正义故。此上七缘正是今经所为。地论有四。非当此文。上约外器。若心地圣贤地法性地。亦有震动等义可以虚求。二兴供中三。一标数。同生之众亦得称主。为物依故。二所谓下略列。三此诸下结遍。第十如此下结通无尽。文分有二。一结华藏内。二结华藏外。前中亦二。先举此界。二其华藏下。类华藏中一切世界。于中三。初类众海兴供。一切世界者。谓华藏中有十不可说佛刹微尘数世界种。一一种中。各有不可说不可说佛刹微尘数世界。彼等一切诸世界中悉有世主而为供养。二其一切下。类佛坐道场。然有二义。一彼诸世主。各供当处之佛。二彼诸世主。亦供此佛。此佛亦坐彼界道场。三一一下类结大众得法。于中有十一句。为闻法得益。得益有三。一闻益。各各信解故。谓信其言而解其义。二思益。谓于所对审缘虑故。三修益。修益有七。一修门。谓三昧方便故。二修法。谓资粮助道故。三修果契理成就故。四修益。随有所得成法喜故。五修转。各各趣入无量乘门。及众生界故。六修同悟解法门。合先圣故。七修极。修极有三。一大悲极。入佛神通境。入佛神通境。但为益生故此成恩德。二大智极。入佛力境。如来力境悲智超绝。无能及故成佛智德。三自在极。入如来解脱门。尽一切障心境自在。成佛断德。亦即是前诸解脱门。二如于此下。结华藏外谓以华藏例于法界。各有此会同为一大法界会。方是华严无尽说耳。上来十段。总明教起因缘分竟

大方广佛华严经疏卷第八大方广佛华严经疏卷第九

        唐清凉山大华严寺沙门澄观撰

    如来现相品第二(此下第二正宗分从第六经尽第十一)

将释此品四门分别。一来意。二释名。三宗趣。四释文。然下诸品多用此四。若有增减至文当辩。今初来意中二。先分来后品来。今初三分之中自下正宗。由致既彰正宗宜显故次来也。四分之中。已明教起因缘。次辩说法仪式。故次来也。二品来者。曲有二义。一前辩众集。今显疑现相。二前明旧众今辩新集。故次来也。二释名者。一分名者。正宗正陈宗旨。拣序流通。若四分中。名举果劝乐生信者。举依正果劝物信乐。是故亦名所信因果。亦名说佛依果会。以从多说故。二品名者。如来是能现之人。相是所现之法。现通能所能所合说。体用双陈以立其称。然如来现相各有五义。以成其十。如来五者。一就理显。谓法性名如。出障名来。二唯就行。瑜伽云。言无虚妄故名如来。涅槃三十二亦同此说。三理智合说。转法轮论云。第一义谛名如。正觉名来。正觉第一义谛。故名如来。此与成实大同。四离相说。般若云。如来者。无所从来亦无所去。故名如来。五融摄说。谓一如无二如。若理若智若开若合。无不皆如。故名为如。如外无法来亦即如。如是来者是真如来。现相五者。一现面门光相。召十方众。二现眉间光相。示说法主。三振动刹网以警群机。四佛前现华表说依果。五白毫出众表教从佛流。如是等相。是如来现相品中辩此。故以为名。三宗趣者。亦二。一分宗。三分正宗。已如上说。四分之宗。即以佛果无边刹海。具三世间无尽自在。故以为宗。令诸菩萨发生净信修行涉求。以之为趣。二品宗者。以光相表示为宗。令上智玄悟为趣。四释文者。此下二品。说法仪式是当分方便。即分为二。初现相品为远方便。后三昧品为近方便。今初一品大分为六。一众海同请。二光召有缘。三所召云奔。四现瑞表说。五称扬佛德。六结通无穷。今初先以五门料拣诸会请问之殊。一问之有无。二所问法异。三能问人别四仪式不同。五疑之权实。初中前二后二。此四有问中五皆无。谓初会标果起因故问。第二会寻因至果故问。但因有升降寄六会以答之。果无差别。第七当会答也。然诸会更有问者。并当会别义以总收之。或重明于前非大位问。第八会明因果纯熟。故须有问。谓行修无碍。六位顿成。故当会答。第七会明称性因果。故别有问。谓俱入法界无差别故。亦当会答。四处都有三百一十句问。谓初及第二。各四十问。第八二百。第九三十。中本广本问则难思。二所问异者。初两会问果广因略。为成信解故。第八会问因广果略。为成行故。第九会问全同初会。而因举主佛之因。明因是果因显唯证故。三能问人异者。初及第九。皆同生异生二众齐问。以所问法众同依故。第二会中唯同生问。以所入位同生胜故。八唯同生。一人自问。以造修之行各自成故。四请问仪式。复有二义。一约言念。二约通别。初中请有二种。一言二念。答亦有二。一言答二示相。交络相望应成九句。在文唯四。初会之中具二问答。谓现相品长行念请供声言请。初光示法主现华表义。现众表教。即示相答。三昧品中以言重请。下之三品亦以言答。第二会唯念请。如来初相答。菩萨言说答。佛心自在不待兴言。佛力殊胜现相能答。第八会言请言答。此显菩萨不同佛故。第九会念请示相答。显以心传心。唯证相应离言说故。二通别者。初后二会别问通答。二八两会别问别答。又初会。亦得是别问别答。次文当明。第五疑之权实者。问诸王菩萨位皆圆极。何得有疑。有云。为众生疑故有云。希佛果故。又显因果悬隔故。然上二解初权后实。并皆有理可通余教。然此经中。若实若权。无非法界之疑。以疑为有力。与所说证为缘起故。此事旧尔海印顿现。疑之与答念念常疑念念常断。其犹像模因模之高成像之下。因模之下成像之高。缘起法界理应尔故。次正释文。文分二别。先长行念请。后供声偈请。前中亦二。先举人标念。谓尽于众海皆希佛境。并欲利生成缘起门。故标同念。二云何下。正显问端。有四十句。且分二别。前二十句直尔疑念请。后二十句引例举法请。准义二文皆应具举。互有影略不欲繁辞。故下偈中。更不引例。合二处文直尔请说。第二会中亦有此二。而引例中问同此直请。正欲显于诸佛道同影略之义。又四十句中。初二十句问果。后十问因。中间十句明化用普周。通问依正染净因果。前是所求后是所行。中是所知故。分是举果故先问果。据斯义类亦可分三。今以两段皆有结请。故但分二。前中亦二。先正疑念后明结请。今初前十句问。德用圆满。后十句问。体相显著。今初十句文唯有八偈。有神通及自在二问。世界成就品初答中亦同此。有今文阙者。或是脱漏或是义含。无能摄取之中。摄此二故。故下法界品中。阙无能摄取及与神通。唯有自在。故此三事合则可一。开则为三故出没不同。言佛地者。即智德分位。然此经宗通收万德故。广则无量。略有十种。如上所引同性经说。然体不出五。谓清净法界及与四智。以斯五法摄大觉性具。如佛地经。及彼论说。然要唯有二。无所不摄。谓真理妙智融而无二。是诸佛地。并有生成住持功能。故名为地。此句为总该摄诸德。下明佛果。皆答斯问。二佛境界下。诸句皆别明佛地之德。言境界者悲智所缘故。亦分齐故。广亦无量略有十种。如出现及问明不思议品广说。然出现多明体遍。不思议品。以辩超胜故云十种无比境界。问明该其因果体用。小有不同至文当知。若准瑜伽。如来境界谓五界差别。一有情界。二世界。三法界。四调伏界。五调伏加行界。或说要唯有四。一所缘真俗。二所住刹海。三所起业用。四所应摄化。并如下说。此与瑜伽大同。总唯有二。谓佛即境约分齐说。或佛之境。约所观化等。今文多显佛之境也。三佛加持者。谓佛胜力任持。令有所作。广亦无量略有十种。如不思议法品及法云地说。离世间品。十种佛所摄持亦其例也。然不出三类。一如加持化身及舍利等。二如加耆婆入火不烧等。三如加非情。作佛事等。此与神通宽陜不同。谓六通中。唯神境一有加持故。今此加持即是神力。四所行者是佛所作。或说十种。如不思议品云。诸佛世尊有十种化。不失时等。亦是所行之行。如出现品。谓无碍行。是如来行等。或大悲摄生。或大智造缘无思成事。方便善巧所作究竟。皆名为行。然约人望行。标云所行。既是所作实通能所故不同彼境界之中。彼智所观所应摄化但就所故。况所望不同。故不相滥。若准瑜伽七十八中引深密经佛答文殊。此二别相云所行。谓一切种如来。共有不思议无量功德庄严净土如来境界。谓一切种。五界差别。五界如前。五佛力者。即佛大力自在广有无量。略说有十。即处非处等。又有十种。谓广大力等。如不思议品。六无畏者。无诸畏惧故。离世间品说有十种无畏。或说四种如常所明。昔云。前四是异二乘功德。佛力是破魔功德。无畏是伏外道功德。未必全尔。十力无畏亦不共二乘故。然上来多明大智功德。七佛三昧者。谓佛果等持数过尘算。如师子嚬申等。略说十种。如不思议品说。佛有无量不思议三昧等。八准答及颂名佛神通者。谓依定发起无碍神用。或说有十如十通品。不思议品云。一切诸佛有无边际无碍解脱。示现无尽大神通力。十通唯局菩萨。或说有六如常所辩。然名通大小。九准答及颂名佛自在。谓所作任意无碍成就故。广有无量或说百种。谓于众生自在等。各有十故略有十种。谓命自在等。并如离世间品说。不思议品亦说有十。谓诸佛世尊于一切法。皆悉自在等。十无能摄取者。颂名无能制伏。答中名无能毁坏。谓佛所作无有天上人中。沙门魔梵。及诸二乘大菩萨等。神力能制。是故旧经翻为佛胜法也。略有十种。如不思议品。诸佛有十种最胜法等。若取无能毁坏即十种大那罗延幢勇健法。是上之十问。多在不思议品。至下当知。二云何是诸佛眼下。十句问体相显著。谓六根三业。于身业中开常光为身光。放光为光明故有十句。不思议法品。诸佛有十种法。普遍无量无边法界。谓无边际眼等。离世间品一一各以十门辩释。又出现品说佛三业。各具十义。然诸经论。说佛常光一寻。准不思议品常妙光明不可说不可说。种种色相以为严好。为光明藏。出生无量圆满光明。普照十方无有障碍。然放光则有时不放。如诸会面门毫相所放之类。然相海品。其一一相常放光明。斯即放光亦通常光。而分别者。常即湛遍。放则见有去来故。言佛智者。广即无量。略说有十。体不出五。谓清净智及大圆镜等四智。要唯有二。谓根本后得。总摄唯一。诸法实相无障碍智。此之十句多如相海及随好品。二惟愿下结请。将欲引例故。且结请。二又十方下。引例举法请。亦分为二。初引例后结请。今初分二。前十句问化用普周。后十句问因德深广。今初文唯有九阙安立海。一世界海者。是化用处。如华藏品。二众生海是所化机。即刹中所持。三准答及颂名法界安立海。如世界成就品。通明法界所安立海。起具因缘等故。若因缘者。贤首云。所化生法也。亦是前二。于法界中施设安立故。诸经论皆说世谛。为安立谛。然安立言。梵云柰耶而义多含。或云理趣。或云方便。或云法式。或云法门。或云安立故。知即安立法式也。四佛海者。能化主也。如华藏品广举其名。亦如不思议等。品五波罗蜜海者。化所成行如离世间品。六佛解脱海者。化所得果如法界品。七佛变化海者。临机神变化难化众生。即身业化也。如诸会不起而遍。光明觉品长行身业阿僧祇等。皆是其文。八佛演说海者。称根说法语业化也。如四谛品。九佛名号海。随机立称如名号品。十佛寿量海者。随器所感住世修短。如寿量品。二及一切下。问因德深广中。一创于生死立大誓愿。二胜进大心趣求佛果。三积集菩提福智资粮。四运诸菩萨从因至果。五慈悲喜舍。四菩萨行。六谓永背业惑证契真理。余四可知。然此十句有通有别。别则初二寄十信。次二十住。次一十行。次一十向。以向出离故。次三登地已上。后一等觉。此约横论一切菩萨。若约通说各通始终。即竖论一切菩萨也。故此十句文通行位。然皆普摄法界深广无边。故云海也。并如下诸会说。二愿佛下结请。既是引例故致亦言。此四十句答文在何问有通局。答亦如之。通即诸会与此相应皆是答此。上所引者居然当之。谓前众海既是九会常随。岂得此问局于初会。岂复众海问不尽耶。故知。初会为总九会同答此问。而为分意别故诸分初皆重举诸问。则显分分之中皆通因果等故。则从此尽光明觉答十海问。问明已下答十因问。不思议品下。答二十句果。至下当知。又就四十问。十海为总九会同答十海。一世界成就品。答世界安立海。二华藏品。答世界海。遮那但引因释成现相三昧。但是说法由致。并非别答海问。三名号品。答如来名号海。四四谛品答演说海。五光明觉至十忍品。别答十句因问。通答众生海。修因之人即所化生故。六阿僧祇品。答变化海。长行举数。欲显化用难量故。偈中广明变化重重微细难说。七寿量住处。皆答寿量海。八不思议等五品。别答二十句果问。总明佛海。就德深广以显佛故。九第八会答波罗蜜海。总摄诸位皆成行故。十第九会。答解脱海。证入法界起大用故。问中为次与答异者。问约本有修成自行化他。而为次第。谓先有世界众生。则有佛出修因得果故。波罗蜜海是因。解脱是果。余四皆大用。谓临机变化随宜说法称物立名。随物修短。答中先人后己故。大用四海居先。自利因果二海居后。又众生一海。亦可通在。九海皆为生故。种种随宜。显生多故。若约局言当会答尽。此复有二。一现相答。下文当示。二者言说答。此亦有二。一经来未尽。二答二兼余成就品当引。第二尔时下。供声偈请中分二。先明因缘。后正说偈。今初前请在念。佛虽已知今请彰言使大众同晓。前既为法兴供。今乃以供宣心。不因拊击。故曰自然。非无因缘。即菩萨威力。同异生众皆菩萨也。又表身口为供具故。供具皆即法界体故。二正说偈中。十颂分二。初三叹德请。后七举法请。前中亦二。初二叹佛明具说因。后一叹众明具说缘。今初也。前偈即悲之智已满。为物现身。后偈即智之悲已圆。能断疑除苦。有悲必普。有智必能。故应说也。后一叹众请中。前半叹众显无异念。后半结请明说则断疑。后举法请中分三。初四述前初十句问。小有不次。但取文便。及余一切广大法者。结例所余。谓二十句外佛无边德。亦愿说之。不思议品广说余门。诸说果处皆答此也。次一颂。述前体相显著十句。略示可知。后二颂述化用普周十句之问。现文唯七。以佛海中。舍于神变寿量名号。以此三海不离佛故不问因者。长行名通诸会故列因疑。今彰初分请当会答。又显此会因略果广。第二会果略因广故。第二尔时世尊下。明光召有缘分。长分为十。一放光意。以领念故。供声易了故。略不明念但疑法。何以放光现相答故。答相云何。谓佛三昧力加持放光。令菩萨来远远能为。此即佛地境界。是佛所行无摄无畏故。此为总意。若别明者。如文思之。又召来菩萨。亦是言答。上之十问。至文当知。二即于下。明光依处。面门即口。言众齿者。表四十问。教道遐舒。口生真子故。咀法滋味益法身故。总处放者。此会总故。三放佛下。显光体随机多演故。四所谓下列光明。略列十名。皆从体用立称。五如是下结光数。六一一下彰眷属。七其光下。辩色相。众宝隐映表教道含容。八普照下。明光应远。九彼世界下。彼众感通。十以佛下。偈声命召即通举十号示为所归。十偈在文且分为五。初六偈自彰因果已圆。劝同观礼。于中初一总明二利因满。成正遍知。次一毛光开觉。是明行足。次一颂往来诸趣。是世间解。一念解脱可谓善逝。次一云成正觉。即佛义焉。次一大音演寂。谓无上士。随心开觉。是调御丈夫。次一诸力皆圆。即天人师也。二有一颂明众海已集。引例劝归。既云已雨诸云为供。是应供也。为对引例故不当次。三一颂圆音随机见必蒙益。结云两足尊。即世尊也。四一颂义海顿演。宜速及时。如三世佛大愿而来。故结云如来也。五一颂特命有缘。是光本意。第三尔时十方下。所召云奔。文分为三。第一同会道场。第二现自在用。第三声光自述。今初。亦三。初总明。二所谓下别显。三如是等下总结。别中十方即为十段。一一方中皆有十事。一定方。二土海。三世界。四佛名。五主菩萨。六眷属数。七至佛所。八兴供云。九申礼献供。十化座安坐。此中应有世界种。名略不说耳。其东方供云应有十种。而但九者。涂香烧香二文合故。言各现者。主伴一一皆现也。重重无碍各遍虚空。一一可观名不散灭。十方化座体相各异。而皆同名莲华藏师子之座者。师子之义已见上文。莲华藏言。通有三意。一约菩萨表含藏开敷故。二约所诠将说依报故。三约诸会通显华严故。上下还于本方坐者。佛圆回身皆见面故。异于余宗但八方故。三总结中文有其八。一略示前文云如是等。二总明海数。谓十亿刹尘。以上来所列是华藏鳞次之海。口光各照一亿十方。故有十也。上二段前别中所无。三结主。四结件。五结来至。六结兴供。七结礼献。八结安坐。既为总结故阙定方。已至会中。故阙初海等三事。第二如是坐已下。现自在用即为叹德。谓尘尘近佛念念益生。文有其八一明诸菩萨毛孔现光。二光现菩萨。三菩萨入尘。四尘含广刹。五刹有如来。六菩萨往供。七助佛扬化。八所化成益。初二可知。三中言安立海所有微尘者。略有二义。一一切施设依正等尘。一一称真故。二约观心。众生意识所缘。即是法界。例依名相分别而转。是谓安立妄故为尘。体皆可依是名大刹。皆有觉性是曰如来。此明菩提证入众生性海。四中可知。五随世俗故说有三世。全称性故并在尘中。六中供养者。通财及法。七于念念下。助佛扬化。及第八念念中下。所化成益。于中贤首对前开悟。以三义释之。一别配释。二圆通释。三各别释。初者谓以前十法门。对后所成十益。一门得其一益。二三前却余并如次。一以梦自在门。梦中警觉造恶众生。令得断恶免苦益故。二以菩萨行门令人正定。三以现诸天殁生门。令生天受乐。以放逸则殁。克念便生故。上三人天乘。四以动刹现无常令厌。以叹佛神变令欣成二乘益。下皆大乘。五以严刹大愿令修福求向。六以摄生言词令发大心。以佛音声即同体大悲故。七以佛云雨法。令入菩萨不退之位。已上三位在地前三贤。八以照遍满法界土及神变令得初地已上智眼见平等法。九以佛普现遍法界解脱力。令得八地已上大力大愿无尽智净国土益。十以普贤建道场。令住佛果大愿海。言生如来家者。入佛果位故生。非是初地已上生佛家也。二圆通者。此上十法。于此十益一一遍通。谓或一法成十益或十法成一益。如是亘遍无所障碍。三各别者。谓前十法门。各自开悟世界海微尘数众生。此以法为益。后十益但言须弥尘数。不言刹尘之国。则是己身以人为益。既各别释则梦自在门。亦显一切皆如梦故。延促等无碍故云自在。余并可知。此上菩萨法化。始从放光终于得益。顺数八段。若逆推十二金叠无尽。一其十须弥尘数众生。得益方在一国。余一切土皆尔。故云一一国土各令等也。二此一切土益在一念时中余一切念时皆尔。故云念念中也。三如是念念之益。方是一法门。所开悟一一法门皆尔。四彼多法门。方是一念所用。余念念所用法门亦尔。五彼多念法门方论一广刹。如一广刹。如是十刹尘数广刹皆尔。六彼多广刹方论一尘内。如一尘一切安立中诸尘亦然。七如上诸尘。方是一安立海。如一安立海遍法界诸安立海亦然。八遍法界安立海中业用。方是一化菩萨所化。如一化菩萨。十世界海化菩萨。一一皆然。九诸化菩萨。方是一光所现。如一光一一光亦然。十彼十刹尘数光明。方是一毛孔现。如一毛孔遍身。一一毛孔皆然。十一彼遍身毛孔。方是一菩萨。如一菩萨。有如是十亿佛刹微尘数。各世界海微尘数菩萨。遍身毛孔皆尔。十二上来所明。十一重作用。方论来此一会。如此一会。于余佛会亦复如是。此后一段偈文具之。又上十二重。一一开之为二。便成二十四重。且如一念望一切念。即是二义。类例相似合之为一。余十一重准此思之。如是重叠无尽。各周法界。唯智顿观非心识境。华严海会大用皆然。第三光声自述。前既光声召命。今亦光声自述。菩萨位极用穷深广。若非自述时众难知。十颂分二。初一总明。兼陈说处。后九别显德用殊胜。文分为三。初三通显体用自在。初偈悲智相导。度众生而不疲。次偈空有双观。入法门而常寂。后偈物我无滞。故化他而自清。次五颂。别叙前现自在与前影略。一身遍十方智观寂灭。即显不唯来此会也。二身光普入智眼遍观。三住一毛端遍动诸刹。况乎于上处宝莲华。四尘尘多身。门门化异。举一殁生门可以例诸。五念劫无碍结由证深。念劫既融故。于念念能作法性无碍者。分与无分皆无碍故。谓证理不唯无分。故在一切处而全在一法。一切法亦然。各有四句身等不唯分。故常在此而无不在思之。后一偈结广有归。普贤胜行皆入。非独向来所陈故。能光中演斯自在。大文第四现瑞表法。上所现相。但召有缘众集。将陈故重现斯瑞。瑞文有三。初光示法主。二现华表义。三现众表教。法藉人弘故先明主义。为教本故在教前。今初示主。文分为六。一意。二体。三名。四相。五展。六收。今初可知。二放眉间光即光体也。眉间者。表离二边故。于体不计有无二边。于义不着常无常等诸法相边。于行不习苦乐二边。于道不住邪正二边。于人不执因果二边。于教不说世出世二边。于谛不见真俗二边。于化不定权实二边。是故为众放眉间光。三此光下辩光名。菩萨智光者。令得能知智也。普照十方藏者。令照所知境也。藏有三义。一智光含德无尽故。二以十方刹海各于尘内重含诸刹故。三亦通于五藏。以言智光故。照初二藏令菩萨证。照次二藏令菩萨成。证则得于涅槃。成则得于菩提。照第五藏令化令净。三中后二如下业中。四其状下显相。谓色如灯云犹日月。洞照周遍润泽雨法雨故。具如相海品。五遍照下展即光业用。于中分五。一所照分齐。谓尽十方一切佛刹。二光所现。谓土及众生。三动刹网。以诸世界重叠影现。交互相当。犹如网孔。四尘现如来。五随机雨法。略举三法皆下所显。初法轮云示其所行。二出离云示其所度。三大愿云示说法主。谓将说普法。令知法主大愿。普周刹尘内故。第六作是下。收则示有终归。证从佛流。眉间出光修因顺果故须右绕。自下升高故从足入。履佛所行方证入故。第二尔时佛前下。现华表义文有二别。一总标华现为坐。所现中方众。故通表所诠佛华严故。别表华藏佛所净故。故于佛前出此莲华。既通表华严亦具同时具足等十门及教义等。而其本意正表义耳。忽然现者。依理起事难测量故。二其华下显具德严。文亦有二。先标十种显德无尽。后所谓下。别列十句。前六体备众德。后四妙用自在。今初。莲子住处。有含藏之义。故名为藏表示法门。一含一切。华藏之名由此而立。后妙用中。一念况多摩尼宝王。即前藏体。影现佛身。即依正无碍。既发多声声皆演法。第三此华生下。现众表教。文略有三。一现众时。言一念者华生无间表教义相应。二现众处。谓白毫中表教从所证净法界所流。为众教源。如白为色本。三有菩萨下。正明众现。亦分为三。一主属齐现遍诠诸法。故云一切所诠圆满。是曰胜音圆教法门。必摄眷属故。下文云。世界海微尘数修多罗。以为眷属。权实无碍故曰俱时。二右绕下。申敬就座。主伴虽殊并修因顺果。故右绕如来。文义相随故。依华坐。正助不等台须有差。上义依理明故忽然而现。今教由人立。故众从佛流。亦如涅槃从牛出乳。三其一切下。彰其德业。主教是宗故偏叹主。文有十句。略为二解。一竖配十地。此明普摄十地功德。一句一地。初地欢喜得智证如。二地性戒。是佛所行。三地多闻入法身海。四行道品。善友是依。五地总行现通利物。六观法界般若现前。七功用已终。故佛与力。八无生无动住三昧心。九为法师见无边法。十具于大尽三昧等圆。初地尚摄诸地功德。况于后后不具前前。二横就极位释者。一理智了真。二量智入行。三证穷法身。四常观受用。五毛现神变。六念观法门七外感佛加。八内安身定。九竖见来际。十横无不圆。故此十句摄为五对。若横若竖能证必具。故为二释

大方广佛华严经疏卷第九大方广佛华严经疏卷第十

        唐清凉山大华严寺沙门澄观撰

大文第五称扬佛德。既现既至任力称扬。自申罔极之情。显佛无涯之德。文分为二。初一眉间菩萨赞。后十十方菩萨赞。新众才集佛便现瑞。文不累书故编成次。以赞德相类结集。并之一处。乘现胜音之次。先举胜音之偈。后十菩萨即如次十方。昔人不晓斯文。便将后十为胜音眷属。非唯章疏之失。亦乃翻译有违。何者。且眉间出众。即主伴皆赞。十方来众寂无一言。主伴礼仪一何疏索。况准法界品例来者皆有赞词。细寻菩萨之名。与前十方如次相似。但由译人不审致。令名小乖差。至下文中一一对辩。今初。胜音文分二。先说偈仪。后正说偈。下十例然。偈中总相赞佛。亦舍诸问思之可知。十颂分三。初三直就佛叹。次六约众叹佛。三有一偈双结主伴。初中三偈。皆叹如来体用无碍。于中初一不动本而周遍。则十身圆融遍四法界。后二不坏小相而广容。上则事如理故。此则事含理故。于中前一偈半。一毛摄三世间。后半类余。谓遍法界内皆有佛身。无有一毛不含刹海。又一毛表解脱门。诸佛菩萨智所住故。现多刹海者。门门皆是净土因故。次六偈约众叹者。圣贤辅翼显主胜故。六偈总明主伴皆遍于中。初二总身总相遍。后四总身遍别中。既微细难思故。唯普智方知普行方立。三双结可知。第二十方菩萨赞德。十方即为十段。今初。东方。言众中者。大众海中前列名处。名观察胜法莲华幢。幢相高出。王是超胜。此喻相似。光慧即是所喻幢体偈中赞佛真应二身。密答上佛地。如来智等摄佛地故。十颂分二。初三赞真后七赞应。赞真必体用双美。赞应唯约用明。欲显门差实非体外。今初也。于中初一赞智身。次一赞法身。后一双结智。含四智法即法界五法具矣。智中上半正体证真。下半后起随俗。又句各一智。初句大圆镜智。行相深细故。次句平等性智。自他平等即法界故。次句妙观察智。于自共相无碍转故。末句成所作智。成就利他导世事故。二赞法身中。上半体相皆同。同有二义。一本性法身体同。言无依者。无住本故。无差别者。体无二故。二已证法身相同。力无畏等皆无异故。此则无碍慧身不依一切。离诸分别是无差别。下半用同。能现能生身土智影皆无二故。即法身无色应物现形。三双结者。上半结智。上句根本下句后得。下半结法。但举其用体通上下。以智契如故。金光明说如如及如如智。为法身故。后七赞应分三。初一随乐现应。不思议者随缘无边故。光明觉云。亿那由劫共思量。色相威德转无边等。次四身光演法。初一化身演法。望前应身即重化也。次二毛光演法。后一结叹难量。法轮义如别说。后二偈成道起通。上皆圆融亦有十身。且从一义耳。第二南方。法喜菩萨。前云集中。名普照法海慧。会义亦同。光明即照法故。十颂叹佛寂用应机德。答前境界。法身显现即分齐境。无生无体。即所观境。众生国土皆所化境。于中分三。初四依真起应。于中分二。先一偈显真。佛身常者第一义。常出三世故。智符于理湛然常照。显者离二障故。现者常在前故。不同众生自体常也。法界悉充满者。诸根相好一一无边无限。福智所庄严故。次二句音恒用普。恒自受用广大法乐故。下三偈起用。初一普随物乐。次一感应道交。后一法光无际。二有三偈体用无碍。于中初二句。约相无生现生。次二句约性无住而住。次一偈约用无去住而普周。后偈体用双拂。谓无体拂上无生。无生为佛法体故。今体即非体。无住处者拂约性二句。亦无生可得拂示生句。下半拂前第二偈约用。用如影故。三有三偈明真应无尽。一法云无尽。二众会无尽。三身相无尽。无尽相言兼真身故。终不尽者全同体故。第三西方香焰菩萨。前名月光香焰普庄严。此中光即月光。明慧即是智慧庄严。十颂赞佛身含众海。即答加持问。由加能入故。于中前九赞众海。则佛德可知。后一结德归佛。前中初一总余八别。别中二。前四平遍一切。于中初一智身入刹尘。次一色身普现用。后二释成前义。一普贤行圆故。二身心平等故。后有四偈。明微细入于毛孔刹中。而作用故。后一结中非唯一会。一切菩萨皆入佛身。方为赞佛。第四北方菩萨。此同本名但加慧字。然此十颂。叹佛依体起用转大法轮。答前佛行。佛以转法化生。为其行故。文中分三。初二句总。次八偈半别。后一偈结。别中赞佛十化。初二句现受生化。处处受生身云遍故。次一偈赞神通化。末句虽云转法意在通用。三有三句赞业果化。一切诸刹名号不同者。示同趣类业报名字。故上三依身。四随应演妙法者。即辩扬化。随应则能断彼疑故。五一偈劝赞励化。妙音赞励故。六一偈庆慰化。普雨法雨。令彼进修无生法故。上三语业。七有一偈。领受意化领问受取。演昔行故。八有一偈决择意化。决择有情心行差别。及拣诸法性相不同。方能普化故。九一偈发起意化。发起宿善及三乘大行。为善调故。十有一偈造作意化。建立佛法事义。种种皆令见故依实起用即是化身故。说化身无别心色。此之十化。与佛地经次第无违。但令相融不违经旨。末后一偈。结归斯会可知。第五东北方法海菩萨。前众集中。名最胜光明灯无尽功德藏。法海可当最胜光明。义与慧同。功德藏名前后无别。无尽二字前有后无。十颂赞佛摄胜眷属。答佛力问。寄赞菩萨。实由佛力故。结云住力地中文中。初一智满得法。即为总相。如是方便门者。此有二意。一指前。谓具前三轮之化故。能周遍一一国土。二即下九别为如是方便也。余九别相共赞七事。一赞普演大音。有三种大。一者处大。一一国故。二者义大。说佛所行故。三者体大。周闻十方故。二赞时无空过。念念观法证真实故。三能入胜处。诸佛身中修净国故。四于染无碍。尘中证法而周行故。五能入佛境。见佛神力入行处故。行处有二。一智行处。谓十力境。二佛化处。谓器及众生。六有三颂。善入音声。初入大音。次入妙音。后入一切音。七一颂善知诸地。言从地者即出心也。而得地者即住入也。力地中者即佛地也。所获法者结上方便也。第六东南方慧灯菩萨。名全同前。十颂赞诸菩萨悟入深广。由三昧力见佛三昧。即答三昧问也。于中分四。初二叹见佛真体。一见佛离相。二见佛自在。言离众相者。般若云。离一切诸相。则名诸佛。慈氏论云。但离四相即离一切。谓名义自性及差别也。言自在者。由菩萨定慧双运。故见佛自在也。次四颂明悟法。一证深理法愿力而现。二悟多行法福智成形。三达果法体无不遍。四了教法深广难知。三有二颂叹身业普应。一深二广。云坚密者齐佛体用。坚即金刚之身。密谓三密之一。即一而多。故遍一切。即大而小。故现尘中。无功之应。故无相而现。若约法门。此身即如来藏性也。不可破坏故坚。深而难见故密。众生尘心无不皆具。本自有之。故曰无生。体绝百非。故曰无相。众生六根是谓诸国。四后二颂。叹得佛加持。一此佛力。二余佛力。第七西南方。前列名处。云普华光焰髻。少同多异。十颂叹佛摄生自在德。答前自在问。文分为三。初六摄生无遗。次二寂用无碍。后二大用无涯。今初文二。初二能摄。谓身语深广。前偈语后偈身。身中上半体。客尘不染故。下半用。随物见异故。亦是释疑。为物现相不乖如空。后四偈所摄。初偈何人能了内信外摄者。次偈以何眼见唯胜非劣。次偈了见何法。谓一切法地地三心。后偈何位究竟菩萨地尽。至入佛海。次二寂用无碍中。初偈用遍出兴。体无来往。后偈即用恒寂随解自差。后三大用无涯者。初一一毛皆普现通。后一一身各遍转法。第八西北方菩萨。前名无尽光摩尼王。此云威德慧即摩尼王。法喻异耳。十颂叹佛出现说法皆周遍德。答无畏问。说法无异故。于中分三。初二总显身光遍应。次七辩其所作。后一结用归本。辩所作中分二。初三明光照无遗。后四演法周遍。一遍尘内外法界刹中。二遍佛身中一切刹内。三明所转性相。四明能转圆音。后一结用归本。不可得故。第九下方菩萨。前名法界光焰慧。此云普明。即前光焰。十颂赞佛境胜用菩萨能入。答神通问。文云。各各现故。于中二。前三显佛境胜用。先半偈标其体。谓妙身色相。后二颂半辩其用。后七菩萨能入。谓入佛境界。于中三。初二具德故知见。次三知见成益。后二结用速疾。并可知。第十上方菩萨。此与前名颠倒而已。十颂赞佛圆音现身神变自在。答无能摄取问。谓此愿力普周。无能令不取故。于中分三。初三颂叹佛圆音雨法德。然具十义。一唯一妙音一梵音故。二遍闻一切称法性故。三此一即多事理融故。四彼一一音雨多法雨。五彼法各具一切文词。六各同一切众生之音。七此音各各遍一切处。八所说各显性净之理。九各令一切普得见闻。十各各皆得究竟之益。上之十义。从一妙音展转开之。具十无尽。方曰圆音文处可见。次四叹佛现身无碍德。初偈解脱力故。现处周细。次偈法身力故。现相即虚。后二偈。以般若德发挥前偈。初偈释下半。言影像者显无方所故。谓光东则影西。光西则影东。质对像生来无所从。质谢像亡去无所至。故此影像即空无体。后偈释上半。言如空者。不可取等故。故虽现形犹如水月。平等如空。后三叹佛神变自在德。一则毛孔广容。二则愿能普遍。三举少况多。又上略配十句。其中具有四十句。意不能繁指。第六大段。结通无穷分中分二。初举此。二应知下类彼。言四天下者。意在阎浮言总意别。既以结通菩萨云集尤显上叹。是彼十方。远方便竟

    普贤三昧品第三(入第七经初)

将释此品四门同前。初来意者。前众既集光示法主。今将说法。是故法主入定受加为近方便。故次来也。二释名者。普贤明说法主。以说普法故。三昧是业用。以非证不宣。故此则人法合举。普贤之三昧。亦此三昧是普贤所有。又三昧境界名为普贤。一切如来藏身为普贤故。此则普贤即三昧。拣余定也。若准梵本普贤三昧威德神变品。威德神变皆定之用。摄用从体。但云三昧也。纵佛加光赞皆因定故。余会入定受加起定即说。同为一品。今此开者。文多义广劝修学故。言义广者。建立普贤之行愿故。故此比余粗相。而说四同六异。言四同者。入住加出。言六异者。一数异。余会入起唯一。此会入起俱多故。二者类异。类余方故。三利益异。定起多人益故。四光赞异。如来毛孔光明赞故。五众请异。从定起已待众请故。六证相异。余会经终方有证相。此品益已即便地动雨云等故。四五二种十地虽有而不具六。今此具六故别立品。以此说果余皆因故。又为诸会本故。总故。七八九会虽是果定。说通因果。又非总故。三宗趣者。入法界定法界佛加为宗。令法界众成法界德为趣。望于后品。亦说世界海为趣。四释文者。文有六分。一三昧分。二加持分。三起定分。四作证分。五毛光赞德分。六大众偈请分。初中有二。一明此界入定。二类通十方。就初分三。一承力入定。二彰定名字。三明定体用。今初有六。一时。说偈竟时。二主。显佛普德。唯普贤故。三处。依如来者常对佛故。四所依座。大集云。菩萨得莲华陀罗尼故。说法处皆有莲华表所入三昧自性无染含果法故。五所依因。谓所入深广要承力故。六正入三昧心境冥故。二此三昧下。彰定名字。毗卢遮那前已广释。复有释言。广大生息。具此三义名如来藏身。身即体也依也。此有二种。一者修成。二者本性。本性者凡圣俱成。修成者唯诸佛有。诸佛有者。慈悲无边故名为广。智慧无上故称为大。生相已尽故云生息。涅槃云。离有常住故名如来。万德含摄是谓藏身。即是出缠之法身也。言本性者。谓即藏识包含种子。建立趣生故名为广。本觉现量与佛等故。名之为大。新新生故名之为生。染净苦乐所不能动。故名为息。即上法身在缠名藏。谓空不空。空为能藏。藏不空故。若以光明遍照。解毗卢遮那。毗卢遮那即是能观大智。如来藏身即所观深理。凡虽理有佛智方照。又毗卢遮那亦通本有。本有真实识知遍照法界义故。斯即本觉迷而不知不得其用。唯佛觉此能无不为。故云一切诸佛。拣非凡也。亦非因也。显于依正离如来藏无别自体。故入此也。贤首释云。诸佛遍于一切。即显诸佛无不周遍法界刹海。及彼尘中所有诸刹。诸刹尘中复有诸刹。如是重重不可穷尽。言如来藏身者。明即此遍刹之身。包容所遍法界刹海。无不皆在如来身中。故名藏身。是故融通总有四句。一身遍刹海。二刹在身中。三身遍身内刹。四刹入遍刹身。即内即外依正混融。无碍无障。是此三昧所作。故以为名。将说此法故入兹定。三普入下明体相用。此定相用无量无边。皆悉依于如来藏说。略举其要。句有十三门乃有十。以后二门。收五句。故摄为六对。后之二门各一对故。文有四节。义唯有三。至下当明。言六对者。初二句明体用一对。谓无分别智证平等性。以为定体。影现法界为胜用也。谓以因因性证彼因性。成彼果性显果果性。如是佛性则具七义。一真二实。三善四常。五乐六我。七者清净。生佛之性本末不殊。况佛果。果岂不平等。佛平等性即如来藏。是故但入如来藏身。即是已入佛平等性。此为第一契合佛性门也。言胜用者。即示众影像门。谓能现能生身土智影也。次二深广一对。广者无边。不在内外故。大者无上究竟实际故。无碍者无所障故。同于虚空。成上三义。通为广大无碍门。后句即入法海漩澓门。漩即深也。三有二句出纳一对。初出生三昧门。谓若自相若共相等。一切三昧皆从此生。此为诸定本故。后摄受法界门。终归此故。法界体性故。四有二句境智一对。初句能成佛智门。谓不体此理非佛智故。后示现诸境门。然安立言总有三种。一者世界安立依报。二者圣教安立妙义。三者观智。安立谛相。皆法界藏显示现前。五有二句。即依正含容门。为内外含容对。谓内含因果智力。外令尘容法界。由尘全依法界藏现。同真性故。六有三句。即成就摄持门。为成持人法对。谓初成果人功德大愿。后持法轮令不断绝。由斯玄理法眼常全故。上言四节者。初四句明无幽不入。释上毗卢遮那遍照之义。次四句无德不生。释上一切诸佛之义。次二句内外含容。释上藏义。后三句。成德持法释上身义。言义唯有三者。体相用也入平等性是定体也。广大同空是定相也。余皆定用。此三圆融总为无碍普贤三昧。二如此下。类通十方及诸尘道。于中有二。初举此。后如是下类彼。类彼中二。初明平遍法界。后明重叠无尽。前中十一句。初一总明。谓尽穷法界。后十别指以彰曲尽。一尽虚空界。二于空中尽十方处。三于十方中遍三世时。四于三世中微细物处。谓毛端等。五凡诸小隙无碍之处。六或广大百千由旬等处。七人天日月光明等处八尽佛眼见处。九尽神力到处。十佛身能现之处。此第十句有二义。一者结上国土之言。通十一段。二者成下。以是身内之刹为微细故。二及此下。重叠遍中略有四重。一尽法界尘。言及此国土者。指前十处之国也。二尘中多刹。三刹中多佛。四一一佛前有多普贤。于上诸处皆入此定故。普贤身不分普遍粗细。深广平满重叠。此处入定。类通既然。法界入定类通亦尔。故约主定。佛前唯一普贤。一切一故。若就类通。佛前各有尘数一一切故。第二尔时一一下。加分有三。初口加。次意加。后身加。初中有四。一诸佛现前以此口加后无结通故。此总举重重时处。一一普贤前也。二彼诸下。赞其得定。此虽果定菩萨门入。故云菩萨三昧。三佛子下。明得定所由。所由有三。一伴佛同加。佛佛道同故。二主佛本愿。此二为缘。三自修行愿是入定因。又上三义。前前由于后后。余岂无斯行耶。法门主故。表说普法故。四所谓下。辩加所为。此文二势。一辩加所为。二显上行愿之相。故云所谓也。所为谓何。为转法轮故。有十一句。初总余别。别中初一总摄十智。余九即是十海。一即安立海。二即众生及业海。三即世界海。四即佛海。五即名号寿量。及解脱海。变化大用皆功德故。六即波罗蜜海。到实相岸故。七即转法轮海。八即根海。九即演说海。与下十智令知此十。二尔时下。明意加。于中有二。先加后释。前中亦二。先此土后类通。前中与十种智。初一总。谓与果海之智。而言与者。佛力灌注令增长故。一切智性即果海也。智性即力无倾动故。具十力故。末后智字即能入也。余九为别。即是成就品中十智。由与此智故。后能说彼智观彼十海。而文少不次。一即第三法界安立海智。安立无边量故。二即第四佛海。佛海唯佛分齐之境。三即第一。四即第二。众生业海。业因微细故云广大。五含二句。一即第八佛神变海。解脱作用即是神变。神变依定加三昧言。二含三世智。下文一念知三世。由佛不思议解脱力故。由加总句故。合此二六即第五。七即第九。八即第七愿海以愿力故。入法界中一切世界。九即第十建立演说。又菩萨根更有多义。修十善道有三善根。修诸地度。精进为根。摄受正法。信慧为根。摄养众生。慈悲为根。为成佛道。悲智为根。种种差别善知故。二如此下类通可知。第二何以故下。释所因中二。先征。意云诸佛有力能与。有慈能普。何以十智偏加普贤。释云。普贤得此三昧法尔应与。三是时下。身加中亦二。初此土。后如此下类通。前中复二。先佛手摩顶。明加彼摄受。又准梵本明十方佛身皆不来此舒臂不必长。而同时摩顶。各全触顶互不相碍。皆是如来自在业用。二其手下。辩手相用。于中十句。以显无尽。前五德相圆备。谓佣纤直等。故云相好庄严。后复出下。五句明妙用自在。意明此手亘十方。而包三世。收因果而该人法。深广体用无边自在。非言能说也。后结通可知。第三尔时下。起定分。所作事竟故。于中二。初此界后类通十方。前中亦二。初起定后众益。前中亦二。初起主定。二起眷属定。于中亦二。初总谓一起一切起。由此妙定。即是一切三昧海故。余定为门皆入此故。彼全同此。亦受海名。二所谓下别辩尘数既多略列其十。一即能知智三昧。谓无一念暂差。故云念念无差。而不废遍知为善巧智。二即所知尘境。上能所一对。三现广刹。四现居处。即于世界总别一对。楞伽经云。如来藏识。顿现一切身器。及诸受用器。即广刹。受用即是舍宅。五知心念差别。六知身相名字。即众生色心一对。七知广处。八知广身。即依正一对。虽说微尘。意彰佛广虚空无方。有物处则现。唯如来藏是实物有。依此建立处所各别。随菩萨行。刹有净秽。随众生业趣类别故。微尘中佛复有一义。谓如来藏是真佛身。其体广大无能知者。恒在六七微尘之中。一一有情各有藏识。故云各有无边大身。九从知一切法理趣者。上八约事别别门显。此约理趣总该诸法。故云一切。大般若经理趣分。说诸法皆空。无生无灭无自性性。离一切相不可愿求。然第一义湛然常住。当知即是此如来藏。思益经说。处处避空皆不离空。深密经说理趣有六。一者真义理趣。谓二障净智所行真实。二证得理趣。谓于真义得如实知。三教导理趣。谓自证已开示众生。此三为本后三解释。四离二边理趣。谓有问言。云何名为真义理趣。应答彼言。非有非无非常非断。五不思议理趣。谓有问言。云何证得。应答彼言。谓不思议。若于诸法远离戏论。尔时证得真胜义性。故知言说皆非真义。六随众生所乐理趣。谓有问言。云何教导。应答彼言。随诸众生意乐各异。顺彼所欲方便开示。彼真义者。即此藏身。彼不思议即此三昧。无著菩萨说四意趣。释一切经亦理趣也。如摄论辩。上来九句。唯第三四从现得名。余七皆从所知立称。如此等类。有一切世界海微尘数。合为一定。即知此定是一切定耳。二普贤下。大众得益。初标益时分。亦是得益所由。后其诸下。正明得益。减数说九。初五得菩萨法门。句各一义。皆以前定含此诸义故。又此五句后后成前前。后四得佛果法。即如来三业。一得照藏身之实智。二得藏身力用之权智。三身毛现刹。四应垂八相义兼口转。亦以藏身含此义故。普贤出定他人益者。感应道交故。如春萌芽阳气久满。东风一拂众蕊齐敷。诸菩萨众积善以深。久同行愿才观胜境。万德顿圆。冥显双资。于何不可。二如此下类通可知。第四尔时下。现相作证分。然得益心喜。喜则地动及有诸瑞。诸会闻竟得益。故现相居后。此会虽即未闻。已先得益。故先现瑞。以此会辩果显殊胜故。文中有四。一世界微动。兼出瑞因由。因果二力。言微动者。是前相故。二众宝庄严。三出音说法。四佛会雨宝。略举十种以显无尽。前三事相宝。后七法化传通宝。并是出世善根所生。第五普雨如是十种云已下。毛光赞德分。于中二。初结前生后。后正显偈词。词中十颂分三。初一总述前定。次八别显遍相。后一结赞所由。别显中二。前二偈半直述前遍。后五偈半举因显遍。于中二。初半偈缘力遍。后五因力遍。于中四。初偈即体而用故遍。前半体后半用。身相如空法性身也。依真而住法性土也。随机普应受用化也。问法性身土为别不别。别则不名法性。性无二故。不别则无能依所依。答经论异说。统收法身略有十种。土随身显。乃有五重。一依佛地论。唯以清净法界。而为法身。亦以法性而为其土。性虽一味。随身土相而分二别。智论云。在有情数中名为佛性。在非情数中名为法性。假说能所而实无差。唯识云。虽此身土体无差别而属佛法性相异故。谓法性属佛。为法性身。法性属法为法性土。性随相异故云尔也。今言如虚空者。唯识论云。此之身土俱非色摄。虽不可说形量大小。然随事相其量无边。譬如虚空遍一切处。故如虚空言通喻身土。二或唯大智而为法身。所证真如为法性土。无性摄论云。无垢无挂碍智为法身故。若尔云何言相如虚空。智体无碍同虚空故。三亦智亦如而为法身。梁摄论及金光明皆云。唯如如及如如智独存。名法身故。此则身含如智上则唯如。四境智双泯而为法身。经云。如来法身。非心非境土亦随尔。依于此义。诸契经中皆说如来身土无二。此则依真之言显无能所。方曰依真成如空义。五此上四句。合为一无碍法身。随说皆得土亦如之。六此上总别五句。相融形夺泯兹五说。迥然无寄以为法身。土亦如也。此上单就境智以辩。七通摄五分及悲愿等所行。恒沙功德。无不皆是此法身收。以修生功德必证理故。融摄无碍。即此所证真如体大。为法性土。依于此义身土迥异。今言身相即诸功德。言如虚空即身之性。下经亦云。解如来身非如虚空。一切功德无量妙法。所圆满故。八通收报化色相功德。无不皆是此法身收。故摄论中。三十二相等皆法身摄。然有三义。一相即如故。归理法身。二智所现故属智法身。三当相并是功德法。故名为法身。其所依土。则通性相净秽无碍。我此土净而汝不见。众生见烧净土不毁。色即是如相即非相。身土事理交互依持。通有四句。谓色身依色相土色身依法性土。法身依法性土。及依色相故。又以单双互望。亦成五句。谓色相身依法性色相土等准以思之。此上犹通诸大乘教。九通摄三种世间。皆为一大法身。具十佛故。其三身等。并此中智正觉摄故。土亦如之。即如空身而示普身。于何不具此唯华严。十土分权实唯有第九属于此经。若据融摄及摄同教。总前九义为一总句。是谓如来无碍身土。普贤亦尔。义随隐显。不可累安。达者寻文无生局见。上言土有五重者。一唯法性属前三身。二者双泯属于第四。三具性相五六七八所依。四融三世间属于第九。五总前诸义即第十依。二普贤安住下。一偈半大愿故遍。兼显遍于正中之依也。重重皆遍。今不见者机不应故。不见即是虚空身故。亦遍不见处故。三有一偈半。明所现超胜。四有一偈。果德已满不舍因门。第三一偈。结赞所由者。自在难思现无不普。标入一定实则普游。非佛光云安能赞述。第六大众赞请分。前众问。佛佛示法主众睹定起故。赞请普贤。前但旧众。此通新旧故云一切。所问同前故。但略举。十颂分三。初八叹主请。彰其能说。次一举法请。正陈所疑。后一叹众请。明有堪闻之器。前中二。初五颂叹普贤因果深广德。明有说因。后三叹能遍尘刹雨法德。明有说果。今初偈各一义。初一赞己净法身。三句明因一句明果。因有三义。一因修法生义通缘了。二由大愿起即是缘因。三依如来藏证真平等。此为正因。真如即是不空。虚空即是空藏。平等与藏通上二义。二赞遍住佛刹。第三句遍因余皆遍相。因中具智庄严故。能等照具功德严令无不睹。三赞近佛。四赞常定。实境中者。不随想转故。曹者辈也。五赞度生曲尽。微尘者。细处有多众生故。二有三颂。说法果中。初一赞常演大法。如空之言下喻广大。前喻无尽无差。次一赞说无等法。无等有二。一能说力胜具二严故二。所说无等。说佛所行故。后一颂举因结果。显德有由旷劫因圆故。故能云雨说法。二一颂举法请中。前品所问虽有多门。统其要归。莫过三种世间故。今三句各显其一。又前问总该诸会。此令当会答故。末后一颂叹众请。亦名自述此有二义。一恭敬一心内堪受法。二诸佛随喜。外有胜缘故应说也。说则上顺佛心。下随物欲

大方广佛华严经疏卷第十大方广佛华严经疏卷第十一

        唐清凉山大华严寺沙门澄观撰

    世界成就品第四

初来意者。前说缘既具。此下正陈所说。总明果相别答法界安立海问。故此品来。二释名者。世谓三世。堕去来今故。界谓方分有彼此故。又世谓隐覆界亦分齐。谓诸有为可破坏。世即隐覆无为不可坏。法从真性起同无为法即隐覆有为可破坏。世各不相杂。是其分齐。是故感娑婆者。对华藏而见娑婆。感华藏者对娑婆而见华藏。成就者。即能成之缘。谓十缘等。能所合目。若以世界之成就。即依主释也。准梵本中。云世界海成就。下文辩海译人略也。意云。佛果依正闻修方起。众生业报本自有之。故但标世界耳。三宗趣者。标列无边胜德。广释所知世界海为宗。然其意趣乃有多种。一令诸菩萨发大信解悟入为趣。谓令知佛及菩萨大悲行海广覆无边尽众生界。仿而行故。世界无边悉严净故。众生无边悉化度故。刹由心异。当净自心及他心故。世界重重无尽无尽。以大行愿悉充满故。佛界生界非一非异。能正了知成大智故。未能了者。熏成种故。皆意趣也。亦为显此深意故此品来。故下颂云。离诸谄诳心清净。常乐慈悲性欢喜。志欲广大深信人。彼闻此法生欣悦。若不闻此无边无尽无二之境。滞于权小。普贤行愿何由可成。故普贤自说为令众生等文。皆是此品之意趣也。四释文者。三品正陈法海。于中分二。初二品明果。后一品辩因。然有二意。一约兼明则前二品。通答前三十句果问。后一品答前十句因问。说因为欲成果。从多而说分明举果。二将前二品。望前品末三问。通答依正。若望下广文。正明于依傍显于正。留其正报后分广故。于中初品通辩诸佛及诸众生所有刹海。后品别明本师之所严净。又此品明成刹之缘。后品别辩果相故。此品答安立之问。其中虽明形等亦是缘故。今初分二。先总标纲要。即为本分。后正陈本义。即是说分。前中亦二。先承力遍观。后牒问许说。今初。上入三昧内契其源。今云遍观外审其相。十海之义已如问释。但小不次耳。但观于十已含余三十佛海之中具身等故。大愿之中含因等故。第二如是观察已下。牒问许说。于中分四。一牒问略叹。二许说分齐。三说所成益。四赞胜诫听。今初分二。先结前生后。后佛子下正牒称叹。即从后向前。牒上果问三十句也。初十句。牒上世界海等十问。观乃观海叹乃叹智者。智之与海反覆相成。谓前自智观海微细难知。知唯佛智方能究尽。海难思故佛智难思。佛智难思故海为深广。若尔何不说智。而但说海。智离海境安知其相。又表唯所证知故但说海。十智望海与问开合小异。名或小差。谓一中前问及观。但云世界海。今加成坏望前与智中亦有成坏之言。此乃广略之异耳。言清净智者。离所知障决断分明故。初句贯下置清净言。余皆略也。然皆以多故。广故深故细故。重叠难知。迥超言念皆云不思议也。二知众生业海者。众生即报类差别。业即善恶等殊。从此别义观中开为二句。而因果虽殊。同是所化众生故。此及问并与智中。并合为一。三即世界都称。或化众生法。谓安立施设方便轨则等也。四能化诸佛数量无边。五即所化根欲差别难知。而问中合在后之五海。五海皆须知根欲故。六即所应之时。前就所观但云三世。今就佛智故云一念能知其问及与智。皆云佛解脱海者。以一念普知三世。是佛不思议解脱故。七称性大愿为现身说法。遍化之因故。前问是名号海及寿量海。与智之中名普入法界。一切世界海智。皆由愿力故也。八应机作用神变无方。九转称性大法轮海。若据问中。摄法轮海在演说中。若约向观。摄演说海在法轮中。今此开二演说。第十谓随方施设言音差别。及法轮随机故。与智中亦开名佛音声智。二清净下十句。牒上六根三业十问。向十约智明不思议。此下直就法体为不思议。又望前问开合影略。显无尽故。以总收别。但广身光等。一应机之身修短难测。二现金银等色类无边。三十莲华藏刹尘数相好过于此。四圆光大小随机无尽。五随缘放光色类非一。六常光如焰具众宝色。七圆音无尽深广难测。八三轮摄化。谓神足等。九调令成益得果不空然。其调伏曲有三种。一者始终软语应将摄者而将摄故。二者始终粗语。应折伏者而折伏故。三者有时软语。有时粗语。应成熟者而成熟故。由具此三故无空过。三安住佛地下。十句牒上最初德用圆备十问。前问中。略无变化及自在二句。以摄在无能摄取句中。义如前会亦以前文十海有故。神变属身自在属智。余并可知。第二如是等下。许说分齐。谓具足说故。承佛力者当会佛也。若言具者。何以下文唯说安立及世界海耶。经来不尽故。又虽说二世界海。亦已通具三十句问。谓界必有生而依住故。有佛现故。安立异故。行业感故。余可意求。第三为令下。说所成益。十句摄为五对。一证智成福对。二严刹绍种对。亦即时处对。三显义演教对。四生善灭恶对。五净业普愿对。文并可知。此亦通为一经教起之所因也。此十亦对前十海十智。恐繁不会。第四是时普贤下。赞胜劝听中文二。初长行辩意。后偈颂正显。今初十一句。初一总标。谓令闻法必生喜故。余十别显喜义。亦为五对。初二乐法生信对。二证性立愿对。三了真入俗对。四持法示佛对。五开法增智对。如文并显。二正颂中。十颂分二。初八赞后二劝。前中亦二。初二明佛出现意。后六辩定法器。于中初一拣非器。次四示法器。后一结归佛力。及后二劝文并可知。然通此十偈。亦是牒问以赞。前长行总显难思。此下略示难思之相。而三十句间列不次。含义并足。欲委配释。恐厌繁文。第二广陈本义分中分二。初结集生起。二诸佛子下。普贤显说。于三十句果问中。广释世界安立海问。余并摄之。文分为二。初标举章门。后依章别释。今初分三。一立数显同。二征数列异。三结略显广。今初。先告佛子者。使时情注其耳目也。世界广深目之为海。谓积刹成种积种成海。海无别体世界都名。然事类。广多略举其十。以表无尽。三世同说彰其要胜。又显说决定无改易也。二微列中。一明揽缘成立。二成已依住。三外状区分。四内体差别。五宝等庄校。六垢秽不生。七佛出差殊。八劫住修短。九随业改变。十包容必均。此十亦摄十八圆满。后品当会。三诸佛子下。结略显广。言世界海尘者。智犹难测。言岂具陈。非证法云安受兹说然上十事。于一一刹多少不定。具缘一种。或一或二或三或多。或成四句。谓一成一。一成一切等。清净一种或一或多。或亦无之。以有纯秽刹故。其次七事各各唯一。谓依空住者。非依光等故。余准思之。其无差别一切皆具。以约体性平等。佛力融摄故说无差。所以染净皆具也。有云。一切世界相望。互同名无差者。则违下经文。经云。一一世界海。有世界海尘数。无差别故。若依相望互同。则无有差别之事。若将此十望刹种者。具缘一种多少不定。不得云一。以其种中含有多类刹故。清净一事不得定言有无。以其种中必含净秽故。其无差别多少亦均。佛出劫住随业转变。不得云一。依形体严不得云多。以其刹种别有体等故。若以此十。独望刹海形体依住庄严等四。许其唯一。余必兼多故。经云。一一世界海有种种形故。今言。有世界海尘数者。约融摄无尽之说也。有云。约一一刹海中所有诸刹。各各一因等故。有刹海尘数者。孟浪之甚。何者。且如刹海中刹虽多。岂如刹海尽末为尘之多。若欲相同。即一尘一缘方得相似。何得以一刹一缘。充一刹多尘之数。况积具缘等十。有刹海之尘。其一具缘。自有刹海尘数。是则通有刹海微尘数个刹海微尘数矣。一刹一缘一依一体。安得充耶。亦不得言通一切世界海说。以下依住云一一世界海。有世界海尘数。所依住故。第二依章。别释者。十事不同则为十段。一一皆有长行与偈。长行中各三。谓标释结。今初。起具因缘。标中略举十种通成三世一切佛刹。二何者下释。然佛土之义。虽有多种不出其三。一法性土。二受用土。二变化土。若开受用有自有他则成四土。统为二种。谓净及秽。或性及相。融而为一。有异余宗。又此净土一质不成。净秽亏盈。异质不成。一理齐平。有质不成。搜源则冥。无质不成。缘起万形故。形夺圆融无有障碍。土既不等因缘亦殊。今文十中。初三通显。次四别明。后三则融摄转变。言初三者。一如来神力者。谓一切净秽等土。皆是如来通慧力成。为物而取。拟将普应。佛应统之。皆称佛土故。莲华藏海佛所严净。而内含净秽。然就佛言之。故无国而不净也。既即秽而净故不思议。二法如是者。梵云达磨多。此云法尔。或曰法性。若是法性。即以本识如来藏身。为所依持。恒顿变起外诸器界。若云法尔者。谓有问言。何以诸佛众生起于刹土。答云。法应如是不可致诘。若会此二。谓法应如是藏识变起。三众生业力者。业有善恶国有净秽。故净名以万行为因。又云。众生之类是菩萨佛土。谓法性虽一随业成异。佛随异类取土摄生。涅槃微善。观经三心等其类非一。上三。初因二缘三因。次四别明者。有因有缘。初一自受用土因。大圆镜智之所成故。二变化土因。谓众生菩萨共构一缘。各随行业来生其国。凡圣同居。三四二种他受用土因。然初即初地以上。如十大愿中修净土愿是也。后即八地已上功用。不退行之所成故。八地中有净土分。后三融摄者。通于因缘。初一即八地已上。搅大海为酥酪。变大地为黄金。以染为净以净为染。自在摄生故。十自在中有刹自在。穷其因者。清净胜解。胜解印持随心变故。次一谓成正觉时。其身充满十方世界微尘刹土。念劫圆融一时成立。由二种因。一善根所流语因中也。二成道势力。明果用也。此一受用变化相融也。即如经初。即摩竭陀地坚固等。后一无问。成与不成常能融摄。又前是妙觉。此是等觉。其法性土。通为诸土之体。穷其因者。有正有助。谓法尔为其正因。以一切智。及总以诸因而为缘因故。其后三亦融前土。非有别体。又此十事展转生起。谓诸佛土总由佛力。何以由之。法如是故法尔云何而有异耶。业不同故。众生由业。佛复由何成。一切智之所变故。生佛有异。何以凡圣同居同构一缘故。何以复有纯菩萨国。菩萨愿行力故。既由行业何可转变。胜解自在故。云何复得融摄重重。佛及普贤自在力故。结略显广如前已释。第二偈颂。多以果显因。文有九偈束为八段。第一偈颂佛神力。据此无边刹海。皆遮那严净。则下严华藏犹是分明。理实而言愿周法界。次一超。颂众生菩萨同集善根。三一颂。颂第四成一切智自受用土因。前半因后半果。成唯识云。大圆镜智相应净识。由昔所修自利无漏纯净佛土因缘成熟。从初成佛尽未来际。相续变为纯净佛土。周圆无际众宝庄严。配经可见。四一颂。颂第六严净愿力。及第七不退行愿。修诸行海无有边者。论云。谓平等性智。大慈悲力。由昔所修利他无漏。纯净佛土因缘成熟。随住十地菩萨所宜变为净土。或小或大。或劣或胜。前后改变。上经。虽云愿力非无有行。为分功用有无。长行成其二句。皆他受用故。偈为一。初句颂第六。次句颂第七。以八地已上念念入法流。心心趣佛境故。后之半偈。通其二文。五一偈。却颂第三众生行业。加造业因烦恼所扰。造于秽刹。欲乐非一感土有殊。前与菩萨同修。必多善业故。此明于烦恼。六一颂颂菩萨胜解。七一颂。超颂普贤愿力。以普贤有三。一位前普贤。但发普贤心。即是非今所用。二位中普贤。即等觉位故。此居佛前。三位后普贤。谓得果不舍因行故。长行居后。八有二偈。却颂如来自在。前偈颂果用。后偈颂善流。略不颂法尔。法尔即是法性通故略之。又第七偈依中有依。第八偈正中有依。第九偈融于三世故。三共显融摄无碍。然其无碍通有十种。诸教说土。或谓但是无常。或云心变。理事悬隔。多一不融故。今经宗要辩无碍。一理事无碍。谓全同真性而刹相宛然。经云。华藏世界海。法界无差别。庄严悉清净故。二成坏无碍。谓成即坏坏即成等。三广陜无碍。不坏相而普周故。经云。体相如本无差别。无量国土悉周遍等。四相入无碍。下文云。以一刹种入一切。一切入一亦无余。及此文云。身包一切等。其文非一亦是一多无碍。五相即无碍文云。无量世界即一界故。六微细无碍经云。清净珠玉布若云。炳然显现诸佛影等。七隐显无碍。谓染净异类隐显等殊见不同故。八重现无碍。谓于尘中见一切刹。刹内尘中见刹亦然。重重无尽如帝网故。九主伴无碍。凡一世界必有一切。以为眷属。下经云。毗卢遮那。昔所行种种刹海。皆清净。种种刹即眷属也。十时处无碍。谓或于一刹现三世劫。或于一念现无量刹。如今第九偈文。又下文云。三世所有诸庄严。摩尼果中皆显现。此十无碍同时具足。自在难知散在诸文。可以六相融之。第二段。所依住通染净也。长行释中。十事文并可知。然依异者。由于心乐有差别故。谓一依庄严住者。乐饰好故。二乐无碍故。三乐即质光故。四怖众苦故。五爱离质光故。光作宝色非宝发光。六奉圣教故。七求神护故。八求天护故。九菩萨愿力所任持故。十普安众生故。如何广大世界。依有情等小类而住。此有二义。一外由内感故说依身。此复有二。一宿因力。颂云。业力之所持故。二现在转变力。即世主菩萨神力。任持摄属己故。二由无漏体事。大小无碍得相依住故二颂有二十二文分两别。初一总显一切世界。依佛神力而住故。梵本云。一切依佛神通现。长行不列者。若列则余九非佛神通故。偈以此文该于前十皆佛神力。后二十一偈。别颂前文。分之为九。初一颂依庄严住。举能显所。庄严之具皆宝成故。二半偈颂依空。三半偈颂依宝光明。四一偈。颂佛光。禀佛教光成世界故。五一偈。颂宝色光明住。以严及覆影显依住。六二偈。颂佛音声。谓妙善所感。音声有威神故。七一偈。颂七八二住。兼显说法。八有六偈。颂依菩萨身住。若树若水皆菩萨身菩萨现故。长行但云菩萨。此中兼依佛身。此中虽有愿力。是上宿善所持。非普贤愿。九余八颂。皆颂普贤愿所生住。于中三。初二偈明广大国土。周法界故。前偈明净识所生。心外无体故如影像。后偈难思业起起不离空。次四偈。明微细国土调生自在。然佛力现。此亦普贤愿收故。二段文皆兼佛力。末后二偈。彰刹体性结归有在。初偈明刹依性有。有即非有。次半成坏更起。犹若寻环。后半结归普愿。兼显广业。第三形相亦通染净。长行释中。非圆方者。三维八隅皆非圆方。故云无量差别。山焰形者。如山似焰皆取上尖。对上方圆等故。余并可知。三结颂中。十偈分二。初一总赞劝观。余皆正颂前义。兼举因显果。于中初二颂前十段。后七颂前无量差别。今初。摩尼轮者。即水旋之类。净焰庄严。颂上山焰门闼竞开义兼宫殿。后七中分二。前三彰刹由因异。后四明自在由佛。一毛孔内难思刹者。更有一理。谓修行者。居自报土各各不同。佛摄众生所现国土。以彼报故。重重而现不离一毛。第四刹体。唯约净刹。长行略辩二十种体。然其刹体诸教不同。或以八微为体。或以唯心为体。或法性为体。或一切法为体。今皆具之。谓众宝等即是八微。加之佛音声。即九微也。一念心现是唯识顿变。佛变化者或通果色。或一切法。令三世间亘相作故。又融上诸说为无碍刹体。言日摩尼轮即日轮也。香通质气。佛言为体者。无碍体事故。又依如来说力起故。颂中十偈。初偈颂三谓初二及第六不可坏金刚。次一偈。颂第三第四。三有一偈。颂第五一切庄严光明。四有一偈。颂二种体。愿力生者。颂佛力持。如影像现。颂妙宝相。若兼二事颂佛变化。五有一偈。颂二种体。上半颂日轮。下半颂微细宝。第六偈颂宝焰殊妙之言亦兼香也。第七偈颂宝冠。宝冠亦佛变化。非正颂佛化也。第八偈。颂一念普现境界。第九偈。颂一切宝庄严示现。及颂后三体。摩尼光者。颂菩萨形宝及宝华蕊。佛光明者。颂佛音声。声光成刹故。第十偈结归普贤。第五段刹庄严中。唯明净刹。其中或宝为严。或人或法。或说法修行示现融摄。皆为严刹。以人法为宝故。又由说法因等得庄严果。以果名因为庄严也。十颂分二。初一总显刹严。后九别颂上文。于中初一偈。颂初妙云。次一偈颂第二菩萨功德。及第四菩萨愿海。次一偈。却颂说众生业报。后六偈。如次颂后六事。第六段明刹清净方便者。唯约净也。若约随宜摄物。佛应。统之则净秽皆称佛土。若就行致唯净非秽。然净有二种。一世间净离欲秽故。以六行为方便。上二界为净土。二出世间净。此复二种。一者出世。所谓二乘以缘谛为方便。权教说之无别净土。约实言者。出三界外别有净土。二乘所居。智论有文。二出世间上上净。此谓菩萨即以万行而为方便。以实报七珍无量庄严。而为其土。今此正明菩萨。兼显二乘。然出世上上净中。复有二种。一者真极佛自受用。相累兼亡而为方便。二者未极。等觉已还。故仁王云。三贤十圣住果报。唯佛一人居净土。未极之中复有二种。一八地已上一向清净。以永绝色累照体独立。神无方所故。其净土色相难名。二七地已还。未出三界。无漏观智有间断故。非一向净。若依瑜伽入初地去。方为净土。三贤所居皆秽非净。此分受用变化别故。约此经宗。十信菩萨即有净土故。今此文始自近友终成佛力。皆净方便。故通万行。然净方便即是净因。长行亦可为等流果。如云久近善友。得生有善友之刹中故。即十事皆净相也。然望庄严有同约门别故。望具因缘当知亦尔。又起具因缘通于染净。此则唯净。庄严多约其果。清净多约其因。又前多修善此多治恶。故于世界。此如洗涤彼如粉绘。别释中。一近善友。同善根者。如善财夜神处广说。二智导慈云大弥法界。三法门胜解。皆已净治。约位地前也。四即初地证遍行如故。云观察一切境界。生如来家。故云安住。五修治等者。见道之后修道位故。余虽未满一切皆修。若约圆融亦得称满。六初地胜进遍学十地行法。后后但是依法行故。上三皆初地。七初地发愿顺行。至第八地。一切皆成故名出生一切愿海。而言净者。纯无漏故。八即九地。二乘出要唯止与观。菩萨出要唯无碍辩。令众出故。九一切庄严者。十地二严皆成满故。十净方便力。即是普贤佛功德也。十中前三变化净因。后七受用净因。上欲总收诸土故。依次竖配。若约横修。初心即可圆具其十。颂中。九偈分二。初一总明能所净。前半方便。后半清净。皆上句果下句因。后八别颂前文。于中初四。如次颂上四净。初地慈悲为首。故云为生修行。遍满真如故云广大。第五偈。颂修治净。及超颂第七愿净。以愿通初地八地。此据初地故超颂也。第六偈。颂前第八出要。第七偈。颂第九。及却颂观菩萨地。地义通前后故。第八偈颂方便力。上来且配长行。其间亦兼余义。第七段。佛出差别者十事五对。于海及种有此差别。五中初二随彼类故。次一缘广陜故。次一随机宜故。五熟未熟故。十颂分三。初一颂总标。次五偈别释。如次颂前五对。后四颂总结。既随心总遍故。刹海尘数未足为多。第八段劫住不同。谓刹住经停时分也。随能感因有长短故。长行略列有十大数更有多少不同。如标结中及颂所显。并通诸刹不谓净长。如大地狱其寿更长。人趣却促故。极恶极善受时即多。更约异门亦不可定也。十中唯九者欠不可说不可说也。并如阿僧祇品。偈中十颂。然劫但时分无别义理。故此偈文转势颂之。略分为三。初二总标许说。颂上标也。次有一偈。通颂上列。兼显修短之因。以愿力故。余七颂总结。偈各一义。一明修短通于染净。结以心想。二净劫住久释以因深。三列诸劫名。染净相摄。四佛兴愿异故。入劫不同。五一多互融齐摄双现。六时法相摄普入无边。七结由想心示以方便。一方便者。即了唯心也。一念与劫并由想心。心想不生长短安在。非长非短是谓清净。不坏于相则劫海无边。第九段劫转变故差别者。此有二种。一者但约感成住坏。劫皆名转变。二唯约住劫之中居人善恶。令染净转变。释中具二初一即是前义。故云无量成壤劫转变。言法尔者。法尔随业转也。若尔何异起具因缘。因缘意在于因。转变意彰于果。又因缘通有唯成不坏。如自受用因是也。余九释后义。一遇恶缘故净变为染。下文云。泉池皆枯涸等。二修人天大福。令世界多染少净。故先云染。如下文云。粳米自然生等。三即地前。以未断障故非纯净。以净多故。故先云净。经多云染净与前何别。或译人之失。或传写之误。四即证发心居受用土故。但云纯净。五各各游者。即二地至十地诸菩萨。游戏神通以多庄严而严一刹。或以一严而严多刹。所至染刹则能庄严也。六大庄严者。即普贤位。严于微尘内刹。如上口光召众等。是七庄严灭者。此明失善缘而恶现。谓如来示灭。能事随灭。佛灭百年乳不及水。况今之世。况于减极。稗为上味铁为上严。八如弥勒来也。九以佛神通于何不净。净名足指案地。法华三变净土即其类也。上之十事初总余别。不出业故。又初二属凡。次四菩萨后三属佛。又约佛菩萨。即染令净。约于凡夫即净成染。十颂如次颂前可知。第十无差别者。谓前九辩诸世界。约相不同随业染净。由于众生有差别故。今云无差性无二故。故偈云业性起也。又约权设则种种差别。今约实说则一切无差。如教法中或说三乘。即是差别。说华严时一切无差。又皆是诸佛之所用故。一一融摄等无异故。故前九差别。是此无差之差。今此无差。即是前九差之无差也。故法华云。众生见烧净土不毁。二皆相即。由依此义说净土中十八圆满一一称真皆周遍故二释中十事。一海中包数同。则尽海之尘。一尘一刹。已是含摄之义。二佛示威力同。三道场同同真性故。四众会同常随众故。五光明。六名号。七音声。八法轮方便。上七皆约不动一而普遍无差。九尘含刹海。十尘容佛境。此二约不坏相而广容无差。颂中十颂如次。颂上十义。但第六约身与前名体异耳。而前但约平漫无差。今显尘内重叠融摄无差之义。若云约共同事者。何以不言染同业苦同。岂世界海中都无此耶

    华藏世界品第五(已下入第八经)

初来意者。前品通明诸佛刹海。今此别明本师所严依果。答世界海问。故次来也。二释名者。准梵本。具云华藏庄严严具世界海之遍清净功德海光明品。译者嫌繁。乃成太略。处中应云莲华藏庄严世界海品。谓莲华含子之处。目之曰藏。今刹种及刹。为大莲华之所含藏。故云华藏。其中一一境界。皆有刹海尘数清净功德。故曰庄严。世界深广故名为海。有云。世界依海故。立海名者恐非文意。以下云华藏庄严世界海住在华中故。其梵云严具即是能严。其遍清净功德海光明。即显严之相用。依体有用故致之言。今文举体摄用。但云华藏。约事可尔何因刹海相状如斯。略举二因。一约众生如来藏识即是香海亦法性海。依无住本是谓风轮。亦妄想风。于此海中。有因果相恒沙性德。即是正因之华世出世间未来果法。皆悉含摄故。名为藏。若以法性为海。心即是华。含藏亦尔。然此藏识相分之中。半为外器不执受故。半为内身执为自性。生觉受故。如来藏识何缘如此。法如是故。行业引故。二约诸佛。谓以大愿风持大悲海生无边行华含藏二利。染净果法。重叠无碍故所感刹相状如之。是以出现品中。多将世界以喻佛德。细寻文意。乃由佛德世界如之。三宗趣者。别显本师依报。具三世间。融摄无尽为宗。令诸菩萨发生信解。成就行愿为趣。余如前品。但总别异耳。融摄之相亦见前文。贤首立华藏观。复有十德大同小异。如彼文说。第四释文。一品分三。初明华藏因果自体。二明藏海安布庄严。三明所持刹网差别。三段如次。释华藏庄严世界之名。今初分二。先长行后偈颂。长行亦二。初举果属人显因深广。二彰果体相辩其宽容。今初也。谓指此刹海是我本师修因所净。然因深广有三胜相。一长时修刹海尘劫故。不唯三祇。二于多劫。一一遇多胜缘。不唯胜观释迦等佛。三于多胜缘。一一净多大愿。愿净国等不唯净一无生等。由上三重。故云深广。然瑜伽起信等。约三乘教。一方化宜一类世界。定说三祇。今约一乘该通十方及树形等界。故云刹海尘数。是以宝云经言。我为浅识众生。说三僧祇劫修行。然我实经无量阿僧祇劫修行。又时无别体。依法上立。法既无尽。时亦无穷。况念劫圆融不应克执。第二诸佛子下。彰果体相者。植因既深果必繁奥。然所依刹量诸教不同小乘但一娑婆。三乘有大小之化。或色究竟为实。或他方别有净邦。今一乘十佛之境。大小无碍。净秽相融。且依一相说有边表。实则一重横寻无边。况复重重尘含法界。然准下别显。应有十事。一所依风轮。二风持香海。三海出莲华。四华持刹海。五绕台轮山。六台面宝地。七地有香海。八海间香河。九河间树等。十总结多严。今文之中唯阙一河。文且分四。第一能持风轮。第二所持香海。第三海出莲华。第四华持刹海。然其刹因有其总别。已见上文。为显别义。且明一因成于一果。今初风轮之因。即大愿等亦如前释。于中文三。初总标数。二略列名。三别举最上。列中名平等住者。一遍持诸位故。二称实性故。余文可知。风并在下宝在台面。以力遥持。三举最上者。胜力能持香海。故立其名。第二能持下。所持香海。以摩尼发光。普照一切严海底岸。及宝色香水故立此名。又藏识名海。具德深广故。流注名水刹那性故。又佛性名水。远熏名香闻未证故。涅槃亦云。有人闻香。第三此香水下。所出莲华蕊放异光。又发胜香高出降伏故。立此名。又所发万行。一一觉性故曰光明。皆能普熏即香义也。第四华藏下。所持刹海四方均平。总显形相。清净坚固彰其体性。金刚围等别明所有。即下别显此为其本。一山二地。三海四树。各别区分即总显多严。但阙一河。以下有别显故。此略明下亦略颂。第二偈中。然长行偈颂。有十例五对。谓有无广略离合。先后为八九。或超间十。或颂已重颂。故释颂文不可一例。上下准之。此文略有四例。一宿因现缘。经离颂合。二所成果相。经略颂广。三现缘风轮。经广颂略。四山地海树。经有颂无。十偈分二。初二颂上因相。即辩因招果。余颂果相。于中分四。初一偈半颂风轮。皆上句所持。下句能持。初半偈以果持果。后偈兼明能成之因。前半离障愿令清净故。后半无碍。愿依空住故。二有一偈。颂香海寻此了名。三有三颂半。颂莲华。初一偈半。释种种光明蕊。则显此华以宝为体。次一偈释香义。就法以明宝中出佛。佛出世主如从质发香远熏之义。后一释幢义。演佛是高出义。调生是摧伏义。四有二颂明刹自在。总颂上所持刹海。初偈自在。一一称性故。即同时具足相应门也。心尘准思。宝光现佛者。依正互融故。后偈结归普因。故能含摄。第二别显安布庄严。文分为六。第一四周轮山。二宝地。三香海。四香河。五树林。六总结。各别有偈。今初。轮山则清净戒德。内摄外防之所成也。长行中三。初总举所依。二栴檀下别显体相。三如是下结德无尽。今初山所依处即地面四周。日珠王者。所依处地故。旧经云依莲华日宝王地住。亦有言大华之上别有此莲。为山所依义。似不顺。所以地受此名者。前华名种种光明蕊。偈中云光焰成轮。又云。一切宝中放净光明。知此华以宝为体。是则如日轮之珠王为莲华也。斯即总华之称。二别显中。前取坚利且云金刚今明具德略有十相。前四自体圆满。后六外相庄严。一身为总形。摩尼圆明栴檀芬郁。皆戒之德也。二山峰。谓秀出孤绝威伏诸恶。三山轮。古有二义。一山弯曲之处。二山腹跳出如师子座。半月为轮。准下偈文轮居山下。为山所依四成山之缘。上举三事各别有体。今显金刚内含光焰遍成其体。如世土石杂而成山。金刚遍故得金轮名。余六文显并在山间。应颂有十文分为二。前六明山体相庄严。颂前别显。后四辩山妙用自在。亦显依正无碍。即颂前结文。前中五。初一总颂围山。初句所围。次二句能围。后句出因。言无边者有其二义。一但总相显多故云无边。实有边表。二说有围山外者。是无边之边。不碍理而即事故。今云无边者。是边之无边。不坏相而即理故。二有一颂颂前山轮。三一颂山体四。一颂成山之缘。五六二偈颂前水等诸严及加衣等。后四妙用自在。并显可知。第二台面。宝地即体心性定之所成也。长行文三。初标所在。二一切下。别显体相庄严。三总结。二中十句。初一地体标以金刚。释以坚固不坏。遍华藏地尽是金刚。故上菩提场地彻华藏也。二地相平净。余八皆庄严。谓三饰以宝轮。四畜以宝藏。五间以异宝。六散以宝末。七布以莲华。八分置香摩尼。九充以庄严具。但云诸严严有多少。三世佛国之严。而为严者。显无尽之严具也。十覆以宝网隐映庄严。网有何用普现佛影。此网何相。如天帝网而布列也。又此帝网重现无尽。成上普现如来境界。及上一一境界皆无尽也。偈有十颂分二。前七颂前别显。后三颂总结。前中三。初四颂前八段。而小不次者。显前无优劣故。或重或广者显义无方也。恐繁不配。可以意得。次二颂严具如云。后一偈颂如天帝网。谓一宝既收一切。则彼刹诸尘复摄一切即重重也。后三偈颂总结者。结其所属。初偈结属道场。次属佛力。后结能知之人。第三地面香海者。上之大海既是藏识。今明心华之内摄诸种子。一一种子不离藏识海故。有多香海。然一一具于性德故。皆有庄严。长行分二。初总举数。准下刹种及梵本中。皆有十不可说。今阙十字。或是译人之漏。或是传写之失。下标种处亦然。二一切下。别显庄严。准后总结。应云一一香海各有若干庄严。今文略无。若案文取义。一切之言即一切海。总以妙宝而为其底等。文有二十句。前十明海体状。一底二岸。三网四水。五华六垽。七声八光。九人卫现通。十结广无尽。后十宝下。十句摄异庄严。唯白莲华当于水中。余皆在岸。言十宝者。有云。金银琉璃砗磲码瑙珊瑚琥珀真珠玫瑰瑟瑟为十。十中前七即是七宝。芬陀利者即白莲华。亦是正敷荣时。尸罗幢者应云试罗。此云美玉。若言尸罗此云清净二义俱通。余并可知。以法门合之。可以意得。颂中菩萨持盖。经有颂无。日焰光轮经无颂有。且分为二。初三颂初十句。一颂底。二颂岸及网。缨即网类。三颂余七细寻可见。余七偈。颂后十句而小不次。谓一颂阶陛栏楯。二颂树林。三颂华敷。四颂幢相。五颂城珠。六颂墙阁。缭者缠也。七颂结严属佛。一昔因二现力。第四海间香河。即随一一心。同时相应功德流注也。长行亦三。初举数。二一切下辩严。三若广下结广。严中严事并无差别。故云一切皆以。谓并用宝体宝严圣灵游集。光云相映万象浮辉。十句可知。三结广中。既绕小海之小河。已有刹海尘数之严。弥显诸标。结文非唯约事皆是一多无碍耳。偈中初半偈颂岸体金刚。次一偈半。颂摩尼严岸。三一颂光云言音。次三皆颂漩澓出影。七颂网铎垂覆。及总现诸严。前现事严。此说道行。八颂现佛依正。九颂浪出妙音。十颂水出光云。更有影略可以意得。第五河间华林。长行有三。初总标。次一一下别显。后其香水下总结。别显二事。谓华及树。水陆各一实有多事。然此一段文势少异。不列十事以显无尽。而但举二展转明多。谓初一。白莲后一宝树。于此一树出五业用。一出庄严云。二宝王照耀。三华香盈满。四出音演法。五雨宝遍地。于中文有总别及结。别有八事通三世间。初六现器。次一现正觉。后一现众生世间。初剑叶林等。现恶业报。天意树等即善业报。男女林中朝生暮落。皆业报海。如是等下。且结树之雨宝已有刹海尘数。例上出云等四。一一皆然。一树之中已有多刹海之严矣。次例芬陀利华。亦同于树。其华与树各有四天下尘。一一皆尔。如华树等类。复应有刹海尘数之物。故为无尽之严也。后应颂不次。文分为三。初六颂宝树。次一颂白莲华。后三结严所因。谓由佛等力。明体用无碍现而常如。然此三偈有多意趣。一者初一偈则器世间。次一智正觉。后一众生。欲明一一事中皆现三世间严。影略其文耳。又初明一果能现。次例一切庄严。后明尘尘皆尔。从略至广从粗至细。又初明佛力。次彰愿力后随乐力。又初果后因愿通因果。又初自后他愿通自他。又初明即性无性体本不生。次明即相无相现无来去。后明不坏于相各见不同。方显华藏之严。皆言亡虑绝非可情求也。第六辩总结庄严。上来诸段。虽说庄严犹未能尽。故今总显一一之境。若说不说。皆具刹海尘数功德庄严。是以文云一切境界。长行文二。先标庄严难测。二何以下。征释所由。清净功德文含二义。一谓众多果严。即是清净功德。二谓一一果严。从多清净功德因生。以因望果应成四句。谓多因一果。一因多果等故。随一一事即曰难思。是以颂云。但由如来昔所行神通愿力而出生。斯即因也。若语果严略有五相。一者令多周给一切。二者令常永无乏绝。三者令妙悦可众心。四者称性无生无相。五者自在镕融无碍。偈文具之总斯五义。故曰难思。况因果相即。偈文有十大分为二。前六果严用胜。后四对因辩果。前中分三。初四别明严用。次一结属现缘。后一总结多类。后四对因辩果中。一由行愿神通为因故。获变化如镜像果。二以普行胜智为因。故得一尘净众刹果。三由长时近友为因。故得刹那顿现之果。四彰净国之意使仿而行之。前半智境严即无严。谓自受用土周遍无等。法性之土体性无生。二皆无相。后半悲应无严之严。严遍法界。无住之住常住刹中。上释庄严竟。第三明所持刹网。释品目世界之言。又前明本刹今辩末界。故兼染净。文分三别。第一告众许说。二诸佛子此不可说下。双标二章。三诸佛子彼诸世界种下。广释二章。标二章者。谓种及刹。然刹种依刹海。诸刹依刹种。则宽陜可知。名从何得。欲明世界无边方便显多。故立此名。谓积多世界共在一处。摄诸流类故名为种。如是种类复有众多。深广无边故名为海。如积多鱼以成一种鱼龙龟鳖山泉岛屿。乃有多种并悉摄在一大海中。而言世界无边者海外有海海海无穷也。若尔种无别体揽界以成。何以下文说有形体。虽依种类以立种名。何妨此种别有其体。如多蜂孔共成一窠。岂妨此窠别有其体。上举鱼龙盖分喻耳。即依后义。亦得名为种性。依于此种能生世界。如依一禾有多谷粒。旧经云。性多取此义。恐滥体性故。改为种。言有不可说者。若准下文香海及种。皆有十不可说。梵本亦有今脱十字。多是传写之漏耳。三广释二章中。文分为二。初通明刹种不同。释刹种章。二别明刹种香海。双释二章二段各有长行与偈。今初长行文二。初列十门。后随门广释。今初也。然此十门刹种之异。并悉不离所依华藏。故云于世界海中。所列十事。与成就品都望全异。彼通一切海。此明一海中种故。若别别相望。互有互无。起具因缘。清净佛出劫住转变。彼有此无。方所分齐行列趣入力持等五。彼无此有。依住形体庄严无别。彼此名同。前后互出都有十五。皆显十者俱表无尽。而或异者彰义多端。复有同者恐滥全别。何以起具前有此无。前段总明成立因果。此中正辩何等世界住故。余可思准。然与前同已如前释不同。五事今当说之。各各方所者。若圆满方所周满法界。无处不有。不即三界不离三界。若随宜方所随十方中。向背各别各各趣入者。依门趣入。约法门者谓三解脱。又互相现入而无来去等。各各分齐者。约事随宜广陜异。故约佛分齐则十方无际。各各行列即是道。路约事可知。约法。谓大念慧行以为游路。各各力加持者。即约食能令住。约法广大法味喜乐所持。又此互出显佛净土十八圆满十五摄故。言十八者。显色形色分量方所因果。及主辅翼眷属任持事业摄益无畏住处路乘门及依持。云何摄耶。此具因缘即因圆满。依住即是依持。形状即当形色。体摄二种。一摄显色。七宝光明为体性故。二摄果满。随类之果可知。约佛大圆镜智相应净识之所变故。故上偈云。或一念心普示现。为体庄严摄三。谓一摄住处如来庄严为住处故。二摄辅翼菩萨严故。三摄眷属有余众故。清净摄三。一摄事业。谓作有情之义利故。二摄摄益。谓现证解脱灭彼烦恼及灾横故。三摄无畏。谓内无灾横外无怖畏故。此中佛住摄二圆满。一摄主二摄乘。或说一乘等故方所分齐二名全同。行列即路趣入即门。力持为任持。劫住转变十八中无。义同于果及事业。摄亦可成二十圆满。于理无违。谓劫住。穷未来故。转变即如来神通变化。世界海普清净转变即圆满义。其无差别彼文虽无。即由此故方显圆满。余皆随宜故云各各。无差既同。云何各各所无差事有多种故。若将此十对成就品。十亦得相摄。恐厌繁文。又上诸文。一一段中具多圆满。一一融摄故异余宗。二随门广释。但释其三。谓依住形体。余七虽略义上已说。今初依住中。初列后结文并可知。二形状中。初列二十种后结尘数不同。今初回转形者。襵亵往来之形也。坛墠形者。筑土为坛除地为墠。佉勒迦者。梵音此云竹篅也。三明体中先别后结列中亦二十种。前十色相。后十是声。会释如前。应颂有十分为六段。初一颂依住。次一形状及布列安住。次三体性。次三颂于五事谓初偈初二句。颂所入门。次句方所。第四句庄严。余二偈中。广大刹之本相。即是分齐广陜。此彼相入亦颂趣入。初偈以多入一。后偈一多互入。皆入而无入。入则坏缘起。不入坏性用。又要由不入方能入耳。又约体本空故。无来无入约相不坏故。如本无差以性融相。故得互入。次一颂无差。谓尘容佛海等无差故。后一颂力持。主伴皆是神力任持。普化之言兼于法味

大方广佛华严经疏卷第十一大方广佛华严经疏卷第十二

        唐清凉山大华严寺沙门澄观撰

第二别明种刹香海。双释二章者。谓香海依刹海。刹种依香海。诸刹依刹种。亦有长行偈颂。长行分三。初总举诸海所依。二次第别显海种及刹。第三总略结释。今初也。上来虽复但标刹种及刹二章。而释依住中。皆云依海故列海数。此多香海。并在刹海地面故云所依。言如帝网者。大都分布则似车轮。其有别者。谓帝释殿网贯天珠成。以一大珠当心。次以其次大珠贯穿匝绕。如是展转递绕经百千匝。若上下四面四角。望之皆行伍相当。今此香海。虽在地面分布相似。又有涉入重重之义。故云如也。第二诸佛子此最中下。次第别显诸海种刹。文分为三。初辩中间一海。次辩右旋十海。后明十海所管之海。然十海各管不可说佛刹尘数之海。总显则有十不可说佛刹尘数。次第说者。但有一百一十一海。余皆略指。今初中央一海。文分为二。先明香海出华以持刹种。后有不可说下。明所持世界。前中有三。初香海名。以多华发光故。亦由菩萨行华而为因故。二华名。谓以香摩尼严此华故。又从摩尼底而出生故。约法即万行圆明之所成故。海能有华故受华名。华依于海。取海底称。三种名约事宝光远照故约法。其世界种。正是所含种子。一一皆有大智光明遍照法界义故。性德互严故。第二所持世界中三初总举大数。次其最下方下。别辩二十层大刹。后诸佛子下类结所余。初文可知。第二别辩中。准标及结。皆有不可说刹尘。其别辩中。但列十九佛刹尘数。为二十重。其能绕刹。但有二百一十佛刹尘数。下当会释。二十层即分二十段。最下层中文有七事。一举名。二辩际。谓世界所据之际。如金刚际。三依住。若准此名大同刹种所依莲华。而旧释云。于前无边香海所出华上。更有此华。持此一界者。以例上诸层别有依住故。为此释何妨最下依于总华思之。四形如摩尼者。为摩尼状有于八楞。似方不方似圆不圆。故异下八隅。五上覆。六眷属。七本界。佛名离二障垢。智眼清净照世如灯。然佛德无边。各随一义。二层已去或有八事。谓加去此远近故。或有九事。加纯净言故。准此若无此言即通染净。此上眷属渐加刹数中间。诸事可以准知。五中云普方者。都望即方。而一面之中。亦有多角隅。隅即是角文体容尔。其第十三主刹即此娑婆。言形如虚空者。静法云。大小乘经。并说虚空体无形质。不可见相。今云有形者。回文者误。梵本云。三曼多(周圆)第缚皤嚩曩(天宫)伽伽那(虚空)阿楞迦罗(庄严盖覆)僧塞恒那(形状)回文应以形状置周圆之前。虚空安天宫之上。然后合缀饰云其形周圆以空居天宫庄严之具而覆其上。静法此正深有理致今依经通之。亦有理在。谓空虽无形随俗说故。以俗典指空为天。谓天为圆穹其形如[金*敖]。故说天势围平野。亦如法华云。梵王为众生之父。亦随俗说耳。第十五云形如卍字者。静法云。室离靺瑳本非是字。乃是德者之相。正云吉祥海云。众德深广如海。益物如云。古来三藏。误译洛刹。曩为恶刹攞遂以相为字故为谬耳。今义通此相以为吉祥万德之所集成。因目为万。意在语略而义含。合云万相耳。余并易了。第三类结所余。此中非唯结数。兼总显上文所依住等。文分为四。一总结都数。二各各所依下结形类。三此一一下结眷属。四如是所说下。彰其所在。今初即举本刹种结有若干。此所结刹定是主刹。以下文指此不可说佛刹。更有两重绕故。其直上中间。但有十九佛刹。而结有不可说者。以傍论故。不尔。岂一刹种最下唯一主刹。故知如向所说。主刹横竖共论。有不可说故。下结其所在。云及在香水河中思之。二结形类中初三列十门。既言周匝围绕。则知旁去。二所谓下。广说十门形状有十八事。望前刹种形中。阙须弥山形及严具形。余皆全同。但此约刹为异耳。三如是等下。结归都数。三结眷属中。然有两重主伴。此一一者。指上不可说尘数也。若望前文主刹。直上绕数渐增。今总相说故云一一。各有十刹尘也。又是欲显无尽义故。一一复有如上所说微尘数者。如上之言文含二义。一即总指前能绕所绕之数。绕一世界。不欲繁文。故云如上。二者如上亦用十佛刹为能绕也。依此则似译人文繁理隐。何不言一一复有十佛刹尘数耶。若依前义。则译者之妙。四彰所在。即最中香海既言及在香河明知傍去。(已下入第九经)第二明右旋十海。即绕处中之海。有其十也。各有种刹十海即为十段。今初第一离垢焰藏海。文二。先牒中海以定方。即是所绕从东为首。二次有下。明能绕之海。于中二。先明海华刹种。后此中最下方下。明种所持刹。有二十重。下九海例然。今第一海二十重中。各有七事。一相去远近。二刹名。三形状。四所依。五上覆。六眷属。七佛号。或有说体。或说清净。即或八或九。其第一重无去远近。但有最下方言。然文并可知。有难即释。其第十四重中云。形如四洲者。水中可居曰洲。准俱舍东洲如半月。南洲如车。西洲如满月。北洲畟方。四洲形异。而云如者则全似此界也。此中文无标结大数准例可知耳。第二从诸佛子此离垢焰藏海南下。第二无尽光明轮海。此下九海文皆有二。先牒前海为所依。后有香水海下明能依之海。皆不牒中海为所绕。故云南也。第三海去但言右旋。又不云南者。十海如环。绕于中海故不正南也。如以十叠绕于一盘方所可见。又第二已去。或无莲华者。前总释种中云。或有依莲华住。或有依海故或无也。后能依之海。文亦有二。先明海华刹种。后此中最下方下。所持之刹。二十重中。初一世界文即有七。后一文八加纯净故。中间唯三。谓相去数量刹名佛号。余八海例然。已辩二海。第三金刚宝焰光明海。第四帝青宝庄严海。第五金刚轮庄严底海。第六莲华因陀罗网海。第七积集宝香藏海。第八宝庄严海。第九金刚宝聚海。第十天城宝堞海。文并可知。有欲解释刹中佛名。足可留思(已下入第十经)。第三大段。从第十经去。明十海所管之海。一海各管不可说佛刹尘数。现文但各说十。即为百海。亦有刹种及所持刹。十海即为十段。但记次前十海之名。此文居然易了。十段中一一有二。谓先标能管之海以定方。后次有下。列所管之海次第。于所管中各有三节。初从能管海边。邻次列九。唯第一段。九中阙一。二如是等下。总结一海所管之大数。三其最近下广说最近轮围一海。于中文皆有二。初举海种名体。第二此中最下方下所持之刹。亦皆二十重。于中超间文有四节。一举下层。二超至第十等。金刚幢者。即中央香海。刹种中第十重刹。三更超至第十三者。以等此中央娑婆故。四更至第二十重者。以最上故。言最上者。刹种最上。若云二十重最上。何以得此最上之名。设不欲繁文。何以不加乃至最上耶。然超间者。意存略故。云齐等者恐失次故。又上下横竖皆相当故。又此随所管海有不可说。皆望本能管之海。方面一道布列故。下但云此海之外不言右旋等。第五金刚轮庄严底香海所管。但列九海而结文。及最近轮围之海九行许经。诸梵本中皆同此阙。准前后例。此必定有第十海所管。近轮围海。所持二十重刹内。最初文云。此中最下方有香水海名因陀罗华藏者。从香字至藏字并长。由前已说香水海故。前诸海中无此例故。纵依海无过在文不便。前第一海所管中。九海阙一。今此长者多是梵本脱漏。后人注之。误书相似贝叶耳。余并可知。十海次第。但观次前疏文不俟重举。第三总略结释。文分为五。一总结都数。谓一海各管一不可说。十海即有十不可说一海一种。是以数同。二皆依下结海种所依。谓即是前能持刹海。本大莲华彼名种种光明蕊香幢。今此乃云现菩萨形等者。是此一华随义异名。有此用故。与前最中海底名同以中间海底即此大华之体中受总称故。取大华体。名或是译者之误。三各各下。结种异门。此与前释刹种章。及世界成就中十相参大同。四此一一下。结种中之刹。言成世界网者。一一世界犹如网孔递相接连。如以网持横竖交络。皆悉相当。如天珠网五于华藏下结归华藏即建立之处。上来双释二章长行竟。第二重颂。总有一百一偈。分二。初一明华藏自体。初句标名。次句不坏分量。即同真性。次句具德庄严末句无碍安住。余一百偈颂所持刹网。于中二。初九颂能持刹种。余颂所持诸刹。初中初一颂参而不杂。次一安布行列。次一刹种体严。次二辨形。次一依住。次二方所趣入。后一佛力加持。第二颂种所持刹。九十一偈多颂结文。但一二不同。谓体及形余皆同也。大分十段。第一有二十八颂。明刹异由因缘。即结中各各众生遍充满。下云种种众生居故。及各各佛力所加持。至文当见。第二有二颂显刹微细。即结中各各普趣入。第三十颂明世界体性。结文即无。义见前经。第四五颂。明世界各各庄严具。第五五颂明各各庄严际无间断。此二如结名。第六有十颂。明世界形状。义见上文。第七二颂。明各各劫差别。第八有八偈。明各各佛出现。此二亦如结名。第九有十。颂光明有无即各各放宝光明。及各各光明云覆。第十有十一颂明音声善恶。即各各演法海。今初为二。初半偈标章。种种多端故曰难思。余偈广释难思之相。于中分二。前九偈半喻显。后十八偈法说。前中分三。初三偈半明由染因刹有成坏。初一偈半明种。则长时刹有成坏。次一偈刹种虽一居刹有殊。后偈结归业种。次有三偈明由净因。一净心因。二佛愿通因缘。后一明净业因。后三通结染净因。一随心染净因。二分别起业因。即以正喻依。亦是以因喻缘。心即是因招异熟果。果之粗妙盖由业缘。三一偈双明心业。行即业故。亦喻众生同处异见。后十八偈法说中分三。初六明染净。次四明成坏。后八明苦乐。今初分二。前二显净相不同。后四对因以辩。于中初一唯染由烦恼故。次二通染净心。业通善恶故。属于菩萨及众生故。后一唯净。以属佛故。二有四偈显成坏中。初一粗坏细存。坏由恶业存由二因一约佛二善业者。故法华云。我净土不毁天人常充满。然灭虽不俱而起必同处。虽曰同处而恒相无故难思也。次偈业存处立。次偈世相不同。性无生灭。后偈结归因缘。内由心变则染净万差。外假佛缘于何不净。三八偈明苦乐中三。初三总相。约刹论苦乐。次三约一刹中有三恶趣。后二明人天乐。第二一一毛下。二偈显刹微细。初偈举果。后偈对因以辩。第三十偈明体性中。亦兼余义随释可知。第四五颂。明庄严。第五有五偈。明庄严际中摄三世严故。无间断结归佛故。一尘普见。第六或有众多刹下。十偈明刹形差别。第七二偈。明刹住时分。第八有八偈。明佛出多少。文并可知。第九十偈光明有无。初一无后九有。第十有十一颂刹中音声善恶。初二恶道唯恶。次三人天通善恶。后六佛菩萨善而非恶。正显各各演说法海也

    毗卢遮那品第六(已下入第十一经)

初来意者。前明此因之果。今辩前果之因。答前因问故次来也。因是果因故标果称。又不以人取法知是谁因。前品初言。毗卢遮那旷劫修因之所严净。今方显其事。二释名者。略云光明遍照。广如前释。三宗趣者。明因广大为宗。证成前果为趣。四释文一品分三。初总明本事之时。二有世界下。别显本事之处。三彼胜音世界。最初劫中下。别显时中本事。今初即二佛刹尘数劫也。二辨处中亦三。第一总明刹海。第二此世界海下。别明一刹。略无刹种。刹名胜音者。多佛出世说法音故。次彰其相。后说劫名可知。第三诸佛子彼胜音下的指一方。如今娑婆中。别说一四天下也。于中亦三。初总明感应之处。第二诸佛子此林东下。别明能感居人。第三诸佛子彼大林中下。别显道场严事。今初有三。初明香海者。非持种之海。即如今四洲之海耳。二其海下。海出华山。三于其山下。明山顶之林。先标举后显严。说此林者佛于中现也。说城居人者总举所化也。第二别明能感居人中亦三。初标主伴二城。二释主城。三释伴城。今初虽有天城以佛出故人城为主。二清净下广释主城。于中先显处严。城上守御曰橹。绕城别筑土台曰却敌。优钵罗等。即青赤黄白四色莲华。从此大城下彰其人胜。三其城次南下。略释伴城。于中先辨城名居类。后此一一下。显围绕庄严。世界不同安立少异。不可例此也。第三明道场中。先辨场严。二其道场前下。明莲华香海为佛现故。大文第三别显时中本事。文分为二。先总举劫中多佛。后其第一下。一一别显。正彰本事。经来不尽故无总结。今初将欲说别。先举其总。言最初劫者。即种种庄严劫也。既云最初。即此后更有大劫。于理无违。第二正显本事中历事四佛。即为四别。第一逢一切功德山须弥胜云佛。第二波罗蜜善眼庄严佛。第三最胜功德海佛。第四名称普闻莲华眼幢佛。各有诸佛子言。就初佛中文分为六。第一总标佛号。第二先瑞熟机。第三正显佛兴。第四毫光警召。第五当机云集。第六广演法门。今初也。一切功德山者。福德崇峻不可仰也。复言须弥者。定慧高妙难倾动也。言胜云者。慈覆智润广无边也。第二诸佛子下。先瑞熟机分二。初现瑞熟机。二其世界中下。睹瑞机熟。前中三。初标现时。谓百年前。次此摩尼下。正显瑞相有其十种。于中说前世所行者。示其种子将成熟故。说佛名号令忆念故。说大行愿。使修发故说转法轮。使当听习生法眼故。后现如是下结瑞意也。二机熟可知。第三尔时下。正显佛兴。于中分二。初一处道成。二如于下结通广遍。初中先总。后其身下别。别显胜德略有十相。一示身相。法无不在。本自普周。智与理冥故。等彼真界。能令色相随彼。融通法界尘毛重重全遍。二悲相。不舍因行无所不生。三成相。理行时处为一切道场。身智俱游名为普诣。四色相湛然常住称为妙色。色色无边故云具足。并无质累是谓清净。五胜相色容蔽于大众。威德摄于群魔。力无畏圆。何能映夺。六贵相。无边宝相圆明可贵。超过圣帝故曰分明。七应相不往普现如镜中像。八无碍相。有感斯见无隔山河。九者化相。化从真流源无有异。十吉祥相。身智光照普称世间。此上大同经初。二结通中且结同类一界。余皆略也。第四尔时下毫光警召。文分为五。一放光处显中道故。二王光名。发动宿种生起新善故。善根有三。一者生福及不动业。以施忍智三而为善根。二厌苦求灭以信等为根。三求无上慧。以四等不放逸五法。为根。通说善根。以依圣教发心为性。故云音也。三眷属数无尽法故。四照分齐。充满十方通方教故。五若有下明光胜益。文有十句。一无明重者自觉智开。二烦恼深者息现行惑。三勤修难出裂五盖网。四三障重者摧诸障山。五未解脱者净心垢种。六未信大者发起入住。七阙资粮者生其胜善。八未入地者除五怖畏。九色累功用灭身心苦。十滞无生者见佛趣果。此约差别对治以释。若约横配。生善见理。可以准思第五当机云集中文二。先通显诸王云集致敬。后诸佛子下。别彰诸王云集仪式。于中分二。先广明喜见。后略列诸王。今初即正出本事之缘。文分为六。第一标名辨统。二总辨眷属。三威光得益。四偈赞如来。五父王宣诰。六俱行诣佛。初文可知。第二夫人下总显眷属者。有德曰夫人。有色曰采女。王子别本云。二万五千者。别梵本也。案璎珞本业经上卷。云十住铜轮宝璎珞。百福子为眷属。生一佛土受佛学行。教化二天下。银轮宝璎珞五百子。金轮一千子。初地四天王一万子。二地忉利天王二万子。三地已上乃至净居天王。但云眷属亦如是。故知无过二万子者。若三界王即当等觉。又以一切菩萨为眷属。案喜见所统但以城言。又见佛兴至第三佛。方云去世。五百银轮斯为正也。或约教异理亦可通。上首云大威光者。有大威德圣道光明故。第三尔时下。威光得益文分为二。先举因总标。后何谓下列益明体。皆从胜用标名。一佛德圆满摧障称轮。定中能知故受斯称。二此总持能持诸佛普法。三即空涉有名为方便。斯则权实双行。为不共般若。称体用之广大。四以二严调伏真实慈也。五法云震音能拔苦本。六称理法喜故德无边。自他俱庆心为最胜。七知离名法法亦应舍。如实舍也。八善巧起用平等无思。通从此生。故名为藏。九尽众生界荷负无疲。要令信解为大愿也。十所有辩才皆入佛智。自他俱照是曰光明。此上十法。初三功德法。次四熏修法。后三起化法。多言大者。境界无边称性广大。智契贯达并受证名。第四偈赞如来。文分为二。先说偈之由。后正陈偈颂。十偈分三。初二示佛出现既灭闇。难遇不可失时。次五令观佛德。有德有慈真可归也。后三引例劝归。无远不归固宜往见。第五父王宣诰文分为二。初宣诰所因。以闻赞故。太子道深亲承佛益。王机犹浅转假他闻。二正以偈诰。偈有十一分之为三。初三集众劝观。次七敕令办供。郑注礼云。巾犹衣也。谓以缯彩衣带于车。广雅云。驭驾也。余并可知。后一偈劝赍供佛。第六俱行诣佛。初导从持供。后至而设敬。第二复有妙华下。略列诸王文易可知。第六时彼如来下广演法门文分为五。一佛转法轮。二威光获益。三以偈赞述。四传化众生。五佛加赞励。今初也。佛解脱用主教。宣示刹尘眷属。随机益殊。第二是时大威下。得益中初总后别。总中上说三世佛法。即佛昔所集也。既见佛得益。转受菩萨之名。所谓下别。智即是体光明语用。所照境殊故分十一也。一深定智明。一切法聚。略有三义。一正定等三。二善恶等三。三总收一切。不出有为无为二种法聚。二位相收一味性现。故云平等。定中证此名彼三昧。二大心智明。谓后后因果。皆入初心。略有三义。一后因初得故。言一切悉入。若修涂至在初步。学者禄在其中。二菩提直心正念真如。真如门内摄一切法。三者三德开发初后圆融。初发心时便成正觉故。三大智智明法界者。所照之体大也。普光明者。即相大也。智慧光明遍照法界义故。蕴恒沙性德故名为藏。妄惑本空。故云清净明见。称眼见性肉眼即同佛眼。四大愿智明。知诸佛法愿为本故。五大行智明。无边果德此行入故。六速疾智明。谓趣入无生功用不退。无功大力一行含多。受斯称也。七神通智明。三轮干事出离不能。八大福智明照福严故。九大解智明。谓佛胜解力成庄严海。十佛用智明。普周法界。十一佛德智明。降魔制外。后三佛境故。但了知余可证知。故云得入。第三以偈赞述文分二别。先因后偈。偈中分三。初一标益体用。次八显用所见。于中前七见因后一见果。三一偈发愿思齐。即前品初修治大愿也。第四传化众生文分为三。初明自悟。二为一切下。明转悟他显示十法。与前自得十一有同有异。文并可知。三今如须弥山下。利他之益。第五如来赞励中。偈有十一。初三赞发心得法大果当成。次四对劣显胜进者圆德。次二外加。内智决证无疑。后二举一例余。行者即得。第二遇第二佛文分为二。先结前生后。二正显佛兴。今初。谓将说后佛。故总论劫寿明多小劫者。欲显多佛现故。说人寿佛寿者。由佛寿促而人寿长。故得威光一生历事三佛。二彼佛灭下。正显佛兴。文分为五。一明灭后佛兴。二睹相获益。三赞德劝诣。四眷属同归。五闻经悟入。今初也。此中佛名。谓智导万行皆到彼岸。见性了了故名善眼。果由因饰是曰庄严。二尔时下。威光睹相获益中二。先睹相即获益之由也。二即得下正获益也。先列后结。列有十种。一念佛三昧者。菩萨之父故首明之。乃至十地不离念佛。无边海藏门者。蕴积名藏深广称海。然略有三义。一由此定中见多佛故。下文云。以佛为境界专念而不舍。是人得见佛其量与心等。由念能见所以称门。二一一佛德。是无边海藏。由念能知所以称门。云何无边海。劫海所修有行愿海。成就色身有相好海。成就智身有辩才海。建立念处有名号海。修诸助道有功德海。安立众生有净刹海。如是诸海一一无边。各各出生蕴积名藏。三无边胜德由念佛生故。此一门深广蕴积。何者念法性身则契如理。念功德身成无边德。念相好身证无边相。障无不灭德无不生。一言蔽诸总由念佛。从此通悟所以称门。即此一门说不可尽。二总持大智能达深法。三无缘普应。四等除热恼。五佛深德海蕴积力用。菩萨缘此喜遍身心。六悲则心戚喜便浮动。深契法性则旷若虚空。悲喜两亡。为平等清净。七般若者。觉法实性离分别也。有可离者非真离也。知自性离不复离也。无离之离即真法界。真法界者。本来清净。法界清净即般若清净。般若清净则万法本净。万法净者。无净无不净为真净也。实相般若为万法之体。观照冥此众德攸依。故云身也。八通用智俱故无碍随现。九入法之深离说之垢。十智照佛法净所知障。含藏众德。二如是下。结中明历事增进。故云十千。通达之言释前即得。第三尔时下。赞德劝诣文分为二。初说偈后偈益。偈中分三。初一偈叹希庆遇。二有七偈叹佛胜德。于中三。初三身业。次三语业。后一意业。三有二偈劝众同归。后诸佛子下偈益可知。第四时大威光下。眷属同归。第五其佛下。闻经悟入文分为三。初佛为说经。二当机获益。三如来赞述。今初主经。法界体性大方广也。清净佛也。庄严即华严也。有多眷属者。显此教圆。二彼诸下当机获益。亦有十益。既云大众。或一人得一。或二三四或具十者。威光先证故略不标。大众之言亦已含矣。故下佛赞。然此十事略为二释。一者如次配于十地十度。或取地义或取度义者。达一切法本来清净名清净智。不取净相是名方便。即初地入证之智也。二则二地离破戒垢。是所除障。照诸善品即戒光明。三即忍度。忍为上严一切爱乐。四无刹不入无法不照。无见不净。是为精进增广众行。约地义释。以诸道品。烧无尽惑成无边光。五趣向诸行能入俗也。禅度增故性能离垢。涉俗化物成福德云。不迷实理为光明幢。六般若现前名随入证。照深缘起名法海光。七功用已远将入无功。为深发趣。权实无碍为大庄严。八见法实性。无功而修为极妙见。由此智慧复得灌顶故。仁王经云。后之三地同遣无明。同无功用故。非灌顶地是灌顶智。九显了药病。是功德海相辩才遍应。若月影流光。十智圆离障。方于佛愿而生信解。故曰出生。二者此上十门。随一一事以立其名。未必全将配于地位。或通配诸位。或复不次。以人无量随证不同。普贤巧说故。文含多义。第三时彼下。如来述赞十颂分二。前六赞其已具胜德当成极果。皆前半已获。后半当证。独第四偈三句是因。后四偈行齐佛因当如佛证。皆三句举佛行。后一句齐佛德。然此中述赞望前遇光得益及向大众所得。多有相同义。必述上可以意消息之。遇第三佛文分为六。一如来出时。前佛灭后等时也。二彼摩尼下。正明现世。立斯号者。功德海满无加过也。三时大威光下。威光往供。四时彼如来下。佛为说经。见普法故名为普眼。以慧为性故曰光明。况一眼即十眼。融无障碍。眼外无法方真普眼。以诸缘发见即缘各为根。因没果中缘皆号眼。故全色为眼。恒见色而无缘。全眼为色恒称见而非我矣。五尔时下威光得益。五度皆福定为最。大寂无不照名普光明。得此已下彰其定用。福非福言略有二意。一福即是善非福是罪。二福即是相非福即性。双了性相故。经云。福德即非福德性。此即深也了一切者广也。故有海言。遇于初佛但得十者。自力未胜故。次佛十千者道转深故。今唯一者道已满故。第六时彼佛下。如来记别。十一偈分四。初四显具菩提心。谓初有愿。次偈有悲。四有智光。三兼精进。通策三心故。菩提心圆当成妙智。次四上入佛境。三有一偈示其果相得同诸佛。四有二偈。赞其现能利他住普贤行。遇第四佛文分为四。一佛出入中。二天王就供。三如来说法。四得益还归。今初。约相目类青莲。约德心无所染。相德高显名称外彰。摧邪众归故曰幢也。二是时下。天王就供中二。先明菩萨行进。报处天宫。此城即是品初所列之一。后知佛可归持华往供。三时彼下说经。方便之言略有三种。一无实权施曲巧方便也。二理本无言假言而言。大方便也。三权实无滞。亦大方便。事理皆彰方曰普门。四时天王下。得益还归中。闻上普门正受安住。法喜无尽故名曰藏。由此证达诸实相海。此劫之中。十须弥尘数如来。今但云四。又无结会古今现证得益等者。经来未尽故也。若结会者。应云尔时威光菩萨者毗卢遮那是等。所信因果会竟

    如来名号品第七(此下第二修因契果生解分第二会初从此第十二经尽第十三经菩萨问明品)

将释此品。五门分别。初来意者先明分来。前既举果令生信乐。今明能生因果信解故。次来也。二会来者。生解之中信为其首故。又前举所信之境。今明能信之行。故次来也。三品来者。前品举因显果。成所信之境。今举果辨因。彰能信之行。果中三业身为其总。故先来也。又远答前名号海问故。二释名亦三。初分名修因契果生解分。谓修五位之圆因。成十身之满果。令诸菩萨解此相故。即生修因契果之解。依主释也。二会名。约处名普光明殿会。然有三释。一以殿是宝成光普照故。二佛于其中放普光故。三佛于殿中。说普法门慧光照世。故立其名。依前一义即依主释。后二有财。约法则名信行之会。三品名。如来现相品已释。召体曰名表德为号。名别号通。一切诸佛通具十号。名释迦等则不同故。如来即十之一。品中正说随机就德以立别名。既表德之名。则亦名亦号。如来之名号依主释也。三宗趣亦三。初分宗。谓以修生修显因果为宗。令诸菩萨修行契入为趣。二会宗者。若就总望。信解行德摄位为宗。通成佛果为趣。信能必到如来地故。近望唯信为宗成位为趣。若依长科十分之宗。此下三品以为一分。即果用应机周遍法界。以为其宗。依此起信为趣故。此亦名正报因果。亦是所信。信何法门信佛身名等于众生。则知我名如佛名也。信佛法门随宜而立。知我妄念苦集亦全法门信佛意业光明遍照。则知自心无不知觉故。先古诸德。亦将上三品举果分收。三品宗者。显佛名号周遍为宗。随机调化利益为趣。或上二皆宗生信为趣。第四问答。问五周因果差别平等不同。何以分名合之为一。答通生差别平等解故。离于修生说何修显故。问前会举果本为生信。今何重举名号等三。答凡约境生信有其二义。一标举境法明有所在。二摄以就心令成信行。前会约初义。此会约后义。又前会果广因略。故名举果。此会因广果略故总摄为因。先依后正文影略耳。若约钩锁者。自属正报果故不同第七会说所成果。此中自辩信所依故。问何不入定。以未入位性不定故。若尔十定岂散善耶。然说法之仪通有四句。一定后说如诸会。二说后定如无量义经等。三定中说如第九会。无出言故。四不入说如此信中及第七会。诸文非一。第九表证唯证能说。一得永常不碍起用故。第七为表常在定故。又入为受加。彼不须加故不须入说。后入者说在行故。将起后故。是知动寂唯物圣无常规。故下文中辩十信之用。一方入正定余方起出说。自在无碍也。余会摩顶后说。此会说后摩顶。是知此经体势纵横不可定准。第五释文。若随义约品科十分之中。此下三品。当果用应机普周分。若约随法就会科十分之中。此一会当第二能信成德会。今就四番问答科。从此终第七会。即当第二修因契果生解分。若顺诸会应直分问答。今为顺文一会分三。第一序分。第二请分。第三说分。今先序分具如经初。但加普光以为小异。略分为三。初标主时处。二始成下别显三事。三与十佛下。辅翼圆满。二中分三。初别显说时。二于普光下别显说处。处在菩提场东南可三里许熙连河曲。彼河之龙为佛造此今举总摄别。前标国名以本收末。上举场称故。下不动觉树而遍十方。三妙悟下别显主德。亦即示成正觉之相也。准第八会初及深密经等。皆说佛有二十一种功德。升兜率品当广明之。今文有初十句。亦略释耳。十句之中初总余别。总中妙悟皆满者。妙悟晋经名善觉。论经名正觉。良以。梵音云苏含于妙善及正等故。译者随取悟即觉也。双照真俗故称妙悟。备下诸句异于因人。故复称满。别中一二行永绝者。烦恼所知生死涅槃。皆名二行。俱不现前名为永绝。二达无相法者。清净真如名无相法。达者了也。三如来常住大悲。任运利乐。又常安止圣天梵住。故云住于佛住。四所证。能证。及以化用皆等诸佛。五具能治道解脱障故。六所说教法外道不能转故。七行诸世间违顺魔怨不能碍故。八安立教法超言念故。九于三世境若事若理。了达记别无错谬故。具此九别成初总句。同异成坏准思可知。第三辅翼圆满。文分二别。一标数拣定。二叹其胜德前中菩萨拣非凡小。补处明非下位。他方而来非旧众也。言一生者。释有二义。一约化相。谓如弥勒。此复有三。一人中一生。二天上一生。三下降一生。正取天中二。约实报一生。谓于四种变易生死中。唯有末后一种。名无有生死一位所系。此文多约化相耳。二普善下叹德。德虽无量略叹一。普善观察者能观智也。普有二义。一普众同有此德。二普观十境善有三义。一善知相。二善知无相。三善知此二无碍。众生界下。明其所观。皆具上三义。十中初是总句所化众生。次此生何来。由迷法界起于世界。我当令彼住涅槃界净诸业果故。须识心行之病文义之药。令厌世间欣出世间。不尽有为不住无为。上辨横观十法。今竖达三世观涅槃。知已现当证观诸业已现当造果报。已现当受心行已现当发余可类知。亦以六相融之。第二时诸菩萨下。请分中二。先举人标念。后若世尊下。正显问端。然句虽五十问但四十。以第二十句是说意故。此四十问。望第一会有同有异。后二十句全同。前二十句大同小异。又复前后不同。初十句即前第三十海。前会即总说所观深广。此则别说如来依正。以前会中为总故。此会别显信所依故。故前会皆致海言。此中但云刹等。第二十句前名菩萨十海。此列住等行位。前通诸会总显圆融行布因故。此约当分。欲显差别因之相故。后二十句虽则全同前总此别。又前即所信。今辨所成。欲显所信所成体无异故。文句全同。若唯约义亦可分三。谓初十句。问佛德应机无方大用。辨因所依果。次十句。问菩萨行位即果所成因。后二十句。佛果胜德。显因所成果。是则以佛为缘而起于因。还以此因而成于果。是此分之大意也。故论云。多闻熏习。无不从此法身流。无不还证此法身。即其义也。今取文义俱便。大分为二。初十句直尔疑问。后三十句引例请问。义不异前然。所依所成文应互有。但是影略不欲繁辞故。初会直尔兴问。即此中引例。此中引例即彼直问又前但明一重所信故。合三十句果。今为分二段。故间之以因。今初十句先总显请意。后开示下别列所疑。十句依正间问者。正报应机必依刹故。亦表依正无障碍故。五句依者。一刹类。二庄严。三清净。四体性。五成就。上五即前二海。广如四五二品。其佛住等五句即正报大用。一佛身遍住诸刹。佛心常住大悲。二所具功德。及所证法性。三随机说法。四作用威光。五修行得证现成菩提。然此五即前会七海。一即佛海。二即解脱海。三即演说海。四即变化海。五即名号。及寿量海。波罗蜜海。其众生海但是所化故略不举。含诸海中。此之十句下。有言说及现相答。至下当知。第二如十方下。引例请问。文分为三。初十句标彼说意。明其有悲。后三十句。举彼所说显其有智。末后一句结以正请。彼佛既尔。此亦宜然。初中初句总。谓令诸菩萨行愿成就故。余九为别。一上继佛种。二云何继。以救众生故。三云何救。令离惑故。四如何救。知彼根行故。五以何救说法药故。六成何益。一除集谛染。二决道谛疑。三拔苦希望。四证灭爱处故。又成菩萨行具悲智也。具此悲智何所为耶。令佛种不断。佛种不断有何相耶。谓成三德。救护众生成就恩德。永断烦恼成于断德。了知诸行成于智德。诸行有三。一者心行。二所行行。三所了行。谓一切行无常无相。即所了也。云何救护演说诸法。云何永断净诸杂染。永断烦恼种现双亡。除诸杂染谓唯现惑。云何成智。谓永断疑网。智成何益断诸希望。惑除何益灭诸爱着。一切著者。著有着空着行着果。不着诸法正智现前悲救众生佛种不断。是菩萨之要也。诸佛之本意也。所陈诸问。一一皆有斯益。又释。一切菩萨是所成就。云何成就。不断佛种即自成就。救护众生成就于他。云何救护。谓离二障永断烦恼。无烦恼障。了知一切无所知障。以何方便能断二障。谓说诸法此烦恼障。其相云何。谓爱与见。除诸杂染绝爱烦恼。永断疑网绝见烦恼。此所知障。其相云何。谓于境不了有所希望。法执未忘一切生着。今相无不了何所希望。达法性空当何所著。二障既寂二智现前。成菩提涅槃。谓不断佛种则菩萨成就矣。第二说诸菩萨下。举彼所说。文分为二。初十句问因。后二十句问果。今初文有九句。昔云。欠第九十忍一句。又以十信自不成位是住方便摄在住中。故不别问。故仁王经教化品云伏忍圣胎三十人。十信十止十坚心故。信住不分也。有义云。有四义故信不入位。一进退不定故。二杂修十心。无定阶降故。三未随法界修广大行故。四未得法身。显佛种性故。由斯不开十信。则成此会及第三会俱答十住问也。十行第四会答。十回向第五会答。十藏第四会中答。以藏有二义。一收摄义。谓收摄诸行以用回向。故答在回向之前二出生义。以出生地上证智故。问居回向之后。十地第六会答。十愿初地中答。十定十通第七会答。各有自品。十顶一种答文不显。古有多释。一云。准梵网经。说十忍后有心地法门。即此十顶。理亦可通。但彼经说处乃有十一。初无菩提场会。但云方坐千光王座及妙光堂说十世界海。其二三四。与此三四五会处法全同。他化十地次第亦同。而化乐天说十禅定。初禅说十金刚心。二禅说十愿。三禅说十忍。四禅摩醯首罗宫。说我本源莲华藏世界卢舍那佛所说心地法门。不云重会普光及祇园重阁次第。又别难可会通。又此中问因。后更有果问。故彼佛心地。即后如来地等。非十顶也。有云。僧祇品答以准璎珞等觉。别有顶位以因位穷终。今僧祇中说十大数。数中之极故云十顶。彼问虽十答有多数。对上定通。亦非其类故不可也。有云。寿量品答。彼中十重佛土。皆上为下顶极。至贤首佛刹名为十顶。又佛名第二。名此十一世界为上首故。但举此初后十一。即显过百万阿僧祇世界寿量之数。此为标首。首即顶故。然复彼无别问。似有少理。但标此十界将为问端。对十地等甚不相例。今谓。新旧梵本俱无忍问。答中即有故。知彼忍即此顶也。言十顶者。因位终极。十定十通皆等觉位。十忍居后。又得顶名。问中约位终极。故名为顶。答据法门忍受。以智印定故云忍也。非位终极。不具十忍非有十忍。不极因位。二文更显。故十忍品末云。通达此忍门成就无碍智。超过一切众转于无上轮等。既言超过即是顶义。亦犹四善根中忍顶法门。义相类故。不尔忍无别问。空答何为。设欲成十应脱十信。十信虽未成位。亦随法界修广大行。德用殊胜别一会答应有问故。若将十忍已下四品。共答顶问于理无失。俱是等觉之终极故。第二二十句。问所成果。全同初会。于中亦初十句。明内德成满。后十句体相显著。初中如来神力。前会名佛加持。即神力加持故。神通约外用无壅。神力约内有干能。离世间品各有十事。其相自别。言无碍者。谓如来所作无能障碍也。上文名无能摄取等。义皆同也。后十中辩才是语业。智慧是意业。最胜是身业。准前会中。唯欠佛光明之一句。余如前释。其所答文亦如前引出现不思议相海品说。但前总会故引此文。所引之文正答今问。说者宜重引之。三愿佛下结请。请同彼说故致亦言。请分竟。第三说分。于中通下六会。答此所问。准问长科亦为三分。此初三品答所依果问。二问明已下。答所修因问。三从不思议品下。答所成果问。其平等因果。因乃果中之因。果乃此果之用。故属果收。初中分二。先如来现相答。由其念请故。又如来证穷故。后文殊言说答。伴助主故。假言显故。今初分二。一佛现神通。二众海云集。今初。知其心念者。领念请也。现神通者。示相答也。言随类者。有其三义。一随疑者所宜异故。谓或示色令见。以声令闻冥资令晓。皆是现通。以法界身圆明顿现也。二随疑者流类别故。三随疑者所疑异故。谓若疑十信。即见如来足轮放光周乎法界等。若疑十住。则见如来足指放光百刹尘外菩萨集等。如放光一事既尔。余相皆然。故知初会现相遍于九会。此会现通通于一分。结集随义编之作次耳。故下三会。皆有不起觉树之言。第二现神通下。众海云集即现相。答初十句之问。光现佛刹答佛刹问。刹有金色等是刹庄严。既以金成亦答刹体。彼刹菩萨亦刹庄严。菩萨大宝以为严故。亦刹清净纯净。佛刹唯菩萨故。净修梵行是刹成就净土行故。亦刹清净所修净故。此已上答五句依问。兼答五句正报土。各有佛及见如来坐莲华藏。是答佛住。现通放光是答威德。名不动智等是答法性。见佛转法轮是答说法。佛成正觉是答菩提。文虽在下义皆此具。光明觉现即现此故。十方众集即为十段。一一方内文各有八。一远近。二土名。三佛号。四上首。五眷属。六诣佛。七到已致敬。八化座安坐。去此远近皆十刹尘数者。前会为说所信因果深广。故须远集华藏之外十方刹海。今为说于生解因果渐渐增修。故但集娑婆邻次之刹。信行最劣故。复云十。后后渐增至法界品。还集刹海。初不云一直云十者。表无尽故。要刹尘者。比余胜故。为有所表故。分阶级非初信等。不是通方故。结及证成十方齐说。又随迷名外悟处名来。而实佛土本无远近。土皆名色者。表信粗现故。亦表显然可生信故。佛号同智者。有信无智增无明故。信中之智。本觉起故。主同名首者。梵云室利。一名四实一首二胜。三吉祥四德。是以译者前后不同。今通用之以信为首。摄诸位故。次第行中信最胜故。甚难得故。于生死中创发信心。为吉祥故。信能增长智功德等。一切德故。此十菩萨同表信门故。皆名室利。各随一门达一切法。故复有差。次文当释。亦有传云。梵云室利。此云吉祥。室利云首。亦是一理。眷属皆十刹尘者。表一一行摄无尽德故。皆诣佛者。有归向故。余如前会。又下菩萨名等。皆是表法。菩萨表所行之行。本刹表所证之理。佛名表所得之智。今初东方言金色者。心性无染与缘成器。为自体故。本智如空离觉所觉。湛然不动动即是妄。非曰智故。又纵成佛果不异凡故。即本觉智住心真如。菩萨妙德者。慧达佛境。处处文殊由慧拣择。契于本智故分因果。二觉首者。觉心性也。无性不碍随缘。随缘不碍无性无碍智也。不染而染染而不染。俱难了知为妙色也。三财首者。法财教化即灭闇智。了众生空如莲不着。四宝首者。真俗无违可珍贵故。善知业果不犯威仪。性相无违。唯一乘旨。是为唯嗅瞻卜华矣。五德首。了达如来应现说法之功德故。即是明于法相。又了佛德心明白也。若有此智。如青莲华最为第一。六目首。福田照导如目将身。平等福田。为究竟智。是最可重故云金色。佛为福田以佛为境故。同上文殊依金色界。七精进首。正教甚深必在精进。能策万行为最胜智。圆明可贵故。复云宝。八法首。法门虽多必在正行。于法能行方得自在。得般若之坚利。为金刚色。九智首。佛之助道虽无量门。智为上首能净万行。故云梵智。智净体净犹若玻璃明彻无染。十贤首。前佛后佛一道清净。由自性善故称曰贤。能知此贤是观察力。观察本性常平等故。又十佛相望不动是体。余皆是用。十菩萨相望。文殊为总。余皆是别。以总导别故。九菩萨不离妙德。以前后流例略为此释。惟虚己而求之。不信此理。甚深法门于我何预

大方广佛华严经疏卷第十二大方广佛华严经疏卷第十三

        唐清凉山大华严寺沙门澄观撰

第二尔时文殊下。辨言说答。就文分四。一叹众希奇。二诸佛子下。牒问总叹。三何以故下。征叹总释。四诸佛子如来下。广显难思。今初也。前众疑问。佛令文殊答者。以文殊示居此土生有十征来自他方。体含万德降魔制外通辨难思。化满尘方用周三际。道成先劫已称龙种尊王。现证菩提。复曰摩尼宝积。实为三世佛母。岂独释过之师影响而来。一切咸见故。其说也。何不待请敬同佛故。何不待告承佛神力。佛意许故。众既念请佛方现相。非夫尊极大士。安得理契潜通。故上以光示普贤。此乃冥加妙德。若尔普贤云何定后更请。表说所信甚深细故。何不入定以果从因同于信故。余如上说。何故无加。以无定故。又承佛神力是冥加故。叹众希有者。略有五义。感应悬隔难一遇故。德行内充总称叹故。以名表法甚希有故。创起信行未曾有故。此一众会即是等空法界会故。二牒问中脱于刹体。佛出现者。即前威德也。阿云无也。耨多罗上也。三者正也。藐者等也。又三遍也。菩提觉也。谓道不可加曰无上也。无邪委知为正遍也。三征释中。征上难思言也。下释云。能感之机差别无边。如来普应周于法界。广难思也。下结文具显。又随宜说法意趣难思。又等法界者。举一说法等余多门。门不可尽量等法界。法门难思。第四广显难思文二。先总显多端。二随门别显。今初也。举娑婆为首。略显十种差别多端。准下结通。实通法界。十句不出三业。一身为总相现十法界不同。故云种种。二名以召实。次下广辨。三金银等色不同。三十二相等异。四形有长短三尺丈六。乃至无边。五寿命限量。或无量劫。或不满百年。下至朝现暮寂。六处。谓化处染净等殊。七根。谓眼等随感现异。八生处。有刹利等别。九依语之用随方言音施设非一故。十观察者。周旋顾盻以应群机。又观存亡安危。可不智照诸境示有多端。下结意云。令诸众生各称己分。而自知见得调伏耳。第二诸佛子下。随门别显。文分为三。初终此品辨身名差别。答上佛住之问近广种种身等八句。以色相等皆属身故。二四谛品。辨言教遍周。答佛所说法问。近广种种语业。三光明觉品。明光轮穷照。答上威德法性菩提三问。近广种种观察。其五句依报。但有现相答。广在前会故。今初广上名者。然圣人无名为物立称。若就德以立德无边涯。若随机立名等众生界。虽复多种皆为随宜生善灭恶见理而立。海印顿现不应生着也。文中分四。一娑婆之内自有百亿。二娑婆邻近。即百亿之外。三类通一切。谓尽十方。四释差别所由。由随物故。初中分三。初此四洲。二四洲之邻十界。三总结娑婆。今初亦三。初标处。次列名。后结数。他皆仿此。举四洲者。昔云意取阎浮言总意别。余三天下佛不出故。然虽不出。除北俱卢余容有往。下并准之。一切义成即悉达也。无事不成就故。圆满月者。惑断智圆恩荫清凉故。师子吼者。名决定说。释迦牟尼者。释迦云能。能仁种故。牟尼云寂默。契寂理故。第七仙者。七佛之末故。若取贤劫当第四仙。即喻也无欲染故。毗卢遮那。广如前释。瞿昙氏者。唯约姓也。此云地主。以从劫初代代相承。为转轮王故。然上云释迦。乃是族望。此即姓望故。智论第二云。释迦牟尼姓瞿昙。故佛名经亦然。沙门此云息恶。无恶不息故。复称大。最胜者圣中极故。德无加故。导师者。引导众生离险难故。于生死海示众宝故。然名含多义。略释此十恐文繁博。余但随难解之。二此四天下东下。此洲之邻十界。即为十段。其善护等。皆四洲之通称也。今初东方断言论者。证离言故。无能说过故。南云帝释者。为天人主能称物心故。西云水天者。水善利万物天光净故。北方医罗跋那者。具云医湿弗罗跋那。医湿弗。自在也。罗跋那者。声也。即圆音自在耳。上云盛火者。盛火焚薪不择林木。佛智利物无拣贤愚。问余圣教说。大轮围内平布百亿。上即诸天下安地狱。如何此说上下皆有四洲。答此教所说事随理融。随说法处即是当中。纵极上际旁至大轮围山。亦有十方互为主伴。以融为眷属。本敷非多。十方界融亦准于此。因此略说娑婆融通。改非改相略有其五。一约事常定。如小乘说。二随心见异。若身子梵王。三就佛而言本非净秽。四随法回转如上主伴互为。五潜入微尘。如前会说。若通论余净土更有五义。谓诸刹相入义。相即义。一具一切义。广陜自在义。帝网重叠义。并如前后诸文所说。三诸佛子此娑婆下。总结娑婆。二诸佛子此下。彰娑婆邻近十方。亦为十段。密训唯九者。勘晋经开晓意下阙一闻慧。南方唯二旧经。则具。乃是新本脱漏。准前后例不应独此便略。西北方名有十一者。独此有余不成文体。此中专念法。应即是前所脱闻慧。亦是梵本之漏。注者误安贝叶耳。下方云帝释弓者。如来念定之弓。以明利箭能射业惑阿修罗故。然旧云法命主意。取帝释以法教命为天主故。今云其弓但一事耳。若作宫室字。以处取人大同晋本。第三诸佛子如娑婆下。类通一切。准四谛品。更有举此例余十方亦如娑婆。互为主伴。第四如世尊下。释差别所由。此有二意。一自既由于差别名言等。而得成就。今还仿古以差别熟他。二昔菩萨时随机调物。今时出世称本立名。如昔教众生令空妄境。今成正觉为立超境界名。他皆仿此故而得成熟之言通自他也

    四圣谛品第八

释此一品。五门分别。初来意者。此品广前种种语业。即答前佛说法问。亦远答前会佛演说海之一问故。既知佛可归。次知法可仰。上名随物立。今法逐机差故次来也。二释名中。言四圣谛者。圣者正也。无漏正法得在心故。谛有二义。一者谛实。二者审谛。言谛实者。此约境辨。谓如所说相不舍离故。真实故。决定故。谓世出世二种因果。必无虚妄不可差失。言审谛者。此就智明。圣智观彼审不虚故。凡夫虽有苦集。而不审实不得称谛。无倒圣智审知境故。故名圣谛。故瑜伽九十五云。由二缘故名谛。一法性故。二胜解故。愚夫有初无后圣具二故。偏说圣谛。四谓苦集灭道。总云四圣谛。带数释也。性相云何。逼迫名苦。即有漏色心增长名集。即业烦恼。寂静名灭。谓即涅槃。出离名道。谓止观等。此约相说通大小乘。智论云。小乘三是有相灭是无相。大乘四谛皆是无相。涅槃云。解苦无苦名苦圣谛。谓达四缘生故。空则超筌悟旨成大。又涅槃云。凡夫有苦而无谛。二乘有苦有苦谛。而无真实。菩萨无苦有谛。而有真实。谓若苦即谛。三涂之苦岂即谛也。二乘虽审知之。而不达法空不见真实。又二乘虽知苦相。不知无量相。故大经云。苦有无量相。非诸声闻缘觉所知。瑜伽说苦。有一百一十。然此经中。虽彰名异即表义殊。以名必召实故。是无量四谛义也。约一界一谛即有十千。娑婆四谛有四百亿十千名义。而文义包博言含性相。又究此四。非唯但空便为真实。今了阴入皆如无苦可舍。无明尘劳即是菩提。无集可断。生死即涅槃无灭可证。边邪皆中正。无道可修。无苦无集即无世间。无灭无道即无出世间。不取不舍同一实谛。故斯一品。有作无作有量无量。皆在其中。准下第五地中。复以十重观察。至下当明。三宗趣者。以无边谛海随根随义。立名不同。遍空世界以此为宗。务在益物调生为趣。又上二皆宗发生净信为趣。四解妨难。问既彰佛语业答说法问。佛所说法多门。何以唯陈四谛。答以名虽在小义通大小事理具足。谓苦集二谛是世间因果。所知所断无改易故。灭道二谛出世间因果。所证所修事决定故。知断证修能运众生。到彼岸故。世界有异此独无改。况无量无作何义不收。是故约此以显差别。又为破计引机故。谓演彼声闻四谛局法。令亡所执。引入一乘无边谛海故。约此辨。何以四谛皆带苦言。谓苦灭圣谛等。然谓生苦之集故。云苦集。尽苦之灭名为苦灭。至苦灭之道名苦灭道。不得单言苦道。以道非生苦不同集故。又非灭苦不同灭故。能证苦灭故云苦灭道。五正释文。一品分二。先标告。二诸佛子下正释。于中分四。初娑婆谛名。二邻次十界。三类通一切。四主伴无穷。然此望前品略于单说四洲就初二中。一一方内文各有二。一别列谛名。二结数辨意。然其立名或有因从果称果籍因名。约事约理或总或别。如文当知。初娑婆中列内四谛。即为四别。一苦云罪者摧也。谓摧坏色心故。二逼迫者。不可意境逼迫身心也。此二总显。三变异者。坏苦也。攀缘者。追求苦也。聚者。五盛阴苦也。刺者。从喻立名。如刺未拔。依根者。由苦能生一切恶也。虚诳者。于下苦中能生乐想也。痈疮处者。此喻二苦。有痈疮处性自是苦。此如五阴苦。若加手等。触苦上加苦是苦苦也。愚夫行者。行苦也。愚人所行故。如以睫毛置掌不觉。若置眼内为苦不安。愚夫不觉行苦如掌内之毛。而复以苦反欲舍苦。皆愚夫行也。二集中初二通显。谓有业惑者。系缚三界灭坏善根。次二别显烦恼。余多通业惑。三苦灭中。无诤者。烦恼为诤故。体真实者。非唯惑灭而已。实乃法身常住为灭谛之义故。次云住自性也。谓本来灭故。四苦灭道谛云十藏者。谓信闻等如十藏品说。二结云四百亿十千者。准望前名号。一四洲有十千。今一四天下一谛。亦有十千。四谛历于百亿。故有四百亿个十千。随众生心下。显差别之意也。第二辨十方谛名。一密训即东方界也。苦名分析悉无力者。推之于缘无实物也。形状物者。有形皆苦也。集中病源者。谓有攀缘故。灭云一分者。惑由妄起故。分数尘沙理不可分故称一分。道言上行者。所之在灭。言观方者。谓观四谛也。更有四方如十定品。二最胜世界者。即是南方前名丰溢。丰溢是正翻最胜。乃义译耳。苦名有势力者。生老病死犹四山临。人世虽贤豪力无与竞。集名非己物者。己本性净妄惑何预。灭名义中义者。事善有义灭理尤胜。义中义也。道名烧然。以智慧火烧烦恼故。三西方离垢世界苦名有无数者。三际无涯故。集名增长者。从惑生惑业故。灭名称会者。以事之灭称会理灭故。破印者。世之阴苦若蜡印印泥印坏文成。此阴才灭彼阴续生。今云破印永不生也。道名诸有边者。照实即生死可尽也。故中论云。真法及说者听者难得故。是故则生死非有边无边。谓三事难得故非有边。难得者。容有得义。得则生死有边。受寄全者。业寄于集暂受还亡。业寄于道永不可失。四北方丰溢世界者。丰溢自南方界名。前品此方名为丰乐。梵云微部地(田夷切)丰乐得旨。译者不审二名相参耳。苦名有海分者。二十五有各一分也。数所成者。数体即集集所成故。集名分数者。无一理以贯之则惑业万差矣。攫噬者。攫搏也。噬啮也。集之损害犹恶禽兽也。灭名无所修者。修已极故。道名无量寿者。谓证灭永常。今因标果称。五东北方摄取世界。苦名地狱性者。未入忍来常有堕性。根本空者。约性以说。同净名五受阴洞达空故。集中由妄惑故。爱见罗刹横相执取。妄体本空故。无可取故。中论云虚诳妄取者是中何所取。佛说如是法欲以示空义。灭道俱名离言者。灭性离言。道令言离故。六东南绕益世界苦名如贼者。五盛阴苦劫害我故。集名无力者。于出生死无有力能。善法治之不复相拒故。灭名舍因者。无为无因而体是果菩提之道望此亦因独寂灭涅槃得称果果。故曰舍因。道名一切印无不审决故。印义后说。七西南鲜少世界苦名邪行者。体非正道是行性故。集名广地生大苦树故。宅主即无明也。灭名绝行处者。心路绝故。道名广大路者。先圣后贤游之而不厌故。八西北欢喜界中苦谛阙一者。晋译少出生唐译少失利。集名无底者。烦恼深故。非习道学浮沉而不已。灭名破依止。身与烦恼互为依止。展转无穷唯证灭理方能永破。道名广大性者无不在故。九下方关钥世界。苦名我所成者。我见有故。集名我心即我见爱。灭名觉分者。所觉处故。道名入义者。能入灭谛第一义故。十上方振音世界苦名匿疵。身为惑病所藏处故。傲慢者。慢以生苦为业。果取因名。染着性者。性令染故。如乐受坏苦谁谓苦耶。駃流者。刹那性故即行苦也。不可乐者。苦苦也。覆藏者。藏苦因故。乐藏坏苦故。不苦不乐藏行苦故。速灭者。流转苦也。难调者。谁不欲舍莫之能出。不惮疲苦方能调之。集名至后边者。不断无穷故。门者入苦趣故。灭名不可取取则不灭也。小之则无内不容一物也。大之则无外法界性也。道名难敌对者。有惑必破不为惑破故。犹明能灭闇。故无闇而不灭。闇不灭明何能相敌。第三诸佛子下。类通一切。初举娑婆以类东方。后举东方以类余九。第四如娑婆下。显主伴无尽。文中初举此例彼。谓娑婆为主。有密训等尽空世界皆为伴。后彼一切下以彼类此。则知密训等尽空世界为主。摄伴亦尔。则无尽无尽耳。此犹约娑婆同类世界而说。以结数中同百亿故。余树形等异类世界。彼一一类皆遍空法界。是则重重无尽无尽。非此所说也。如是皆为调伏众生

    光明觉品第九(入第十三经)

解此一品略以五门。初来意中自有其十。一为答前所依果问故。然古德对前二品已答二问。此品正答三问。谓长行放光答佛威德。见成正觉答成菩提。文殊说偈正答佛法性问。今更一解。谓长行但现相答。已如前说。偈中具答三问谓初五答菩提。次一答威德。后四答法性。二为广名号品总标多端故。正广种种观察是意业故。三者即说十信之体性故。如下三会将说正位。皆有偈赞此其类也。四显实遍故。但所说有二。一佛二法。佛有二。一身二名。法亦有二。一权二实。前但佛名遍此显身遍。四谛即实之权遍。此品显即权之实遍故。五现验故。上二云遍众未目睹。今光示遍相故。六显总遍故。前但名谛别遍。今此一会即遍法界。一一皆悉同时同处同众同说同遍故。七显圆遍故。谓前显差别。一切方能遍一切。今显无差别。一切即圆融遍一切故。八与下经为其则故。谓下结经通云。遍一切者。皆如此辨以如来一乘圆教。于须弥山等一类世界。施化分齐皆若此故。九示前神通相故。上云现通。如何现耶。一会不动遍法界故。十为显理事俱无障碍。令舍执从法故。此意虽通在文遍显。有上诸义故此品来也。第二释者名。一开二合。初开者。光明体也。觉者。用也。此二各二。谓光有身智二光。觉有觉知觉悟。又光有能照所照。觉有能觉所觉。如来放身光照事法界。令菩萨觉知见事无碍。文殊演智光双照事理。令众觉悟法之性相。二合者。良以事理俱融唯一无碍境。故得一事即遍无边。而不坏本相。身智无二。唯一无碍光故。涅槃经琉璃光菩萨处云。光明者。名为智慧。知悟不殊。唯一平等觉悟之心。知无事非理故。又此二光不异觉境。此三圆融唯无碍之法界。虽平等绝相不坏光明之觉。品中辨此故以为名。若从开释。光明之觉光明有觉之用。通依主有财。若从合说。光明即觉可持业也。第三宗趣者。以身智二光无碍觉悟为宗。令物生信为趣。又释名并是品宗来意尽为意趣。第四解疑妨。问此足轮光何时放耶。若说名谛意如何。佛刹菩萨众数并同名号。如前已放前何不说。答是前名号品放。但前二品明文殊此会说法不俟光照。今辨百亿刹中。乃至遍法界说故。须光以显示其所来。菩萨即前菩萨。故并全同。次有妨云。光照百亿百亿何不照此释云。此为主故。若彼为主则说彼照。又疑云。下光既穷法界。金色更在何许。当刹当刹有本会处。皆去十刹主伴遍故。第五释文。大分为二。初如来放光。二照此下。光至分齐今初。足下放者。表信四义。一自下而上信最初故。二最卑微故。三为行本故。智度论第九云。足下放光者。身得住处皆由于足。四显信该果海已满足故。轮义亦然。圆无缺故。言百亿光者。以遍法界所照之刹皆百亿故。第二光至分齐者。此中光照大数约其现文。且有二十六节。前九别名。后十七同辨。即为十段。若据实义应有等法界无尽之节。节节有偈。中上本经必应广说。然非多度放光。亦非一度放光。次第照于多节。唯一放光。同时顿照尽空世界。但为言不并彰说有前后。随机心现节节各见。则如来光明节节而照。金色文殊节节而至。乃至法界各见亦尔。在佛文殊节节皆遍。如月普照百川各见。若法界机顿见。前来诸类所见信会既尔。住行等会同遍亦然。十段之中文各有二。皆长行。佛以身光照现事境。令众目睹。偈颂文殊智光赞述事理。令众悟入。十段依答文三。初五答菩提即分为五。初一总显菩提超情。二通显菩提因果。三显八相菩提。四显菩提体性。五体菩提之因。今初长行中二。先照本界染净。二如此处下。现自法会普遍之相。前中三。初总标分齐。二百亿阎浮下。别显所照。三其中下。类结明显。今初言三千大千者。俱舍论云。四大洲日月苏迷卢欲天梵世各一千。名一小千界。此小千千倍说名一中千。此千倍大千。皆同一成坏。梵世谓即初禅。故云同一成坏。以三度积故曰三千。略去小中举其末后。故云大千。长阿含十八。杂阿含十六。正理三十一。及瑜伽智论杂集显扬。亦不殊此。有云然显扬第一明三千世界三灾所坏。故知初禅小千。二禅中千。三禅大千。若金光明直至非想。皆云百亿意在遍诸天。故此经文中。但至色顶约无色无处故。今依二经。二别显所照中。初现人中。二现八相。三现诸天。初中阎浮提者。新云赡部。俱舍云。阿耨达池岸有树名赡部。因以名洲。提者。此云洲也。东弗婆提者。此云胜身。身胜余洲故。西衢耶尼。此云牛货。以牛货易故。北郁单越。此云胜生。以定寿千岁衣食自然故。大海者。即外碱海也。百亿轮围者。一四天下一小铁围故。中者有千。大者唯一。皆云百亿者。此方黄帝算法数有三等。谓上中下。下等数法十十变之。中等百百变之。上等倍倍变之。今此三千。若以小数计有万亿。今约中数。从千已上百百变之。则有百亿。故唐三藏译为百亿俱胝。测公深密记第六云。俱胝相传释有三种。一者十万。二者百万。三者千万。由此三千以俱胝数。或至百数。或至千数。或至百千。唐三藏译是千万也。故至百数。又依俱舍译洛叉为亿。此译俱胝为亿故。下光照一亿十亿等。梵本皆云俱胝。总由俱胝之数不同故也。二现八相中文有五相受生含三。佛成道后始放光明。却现初生及后涅槃者。约微细门融三世故。亦非能照是报所照是化。以放光身在摩竭故。此经报化融故。大菩萨等化处见报。下位之机报处见化。二不并故。能照所照唯是一佛。显佛自在超思议故。三百亿须弥下。现诸天中举须弥者。二天所依故。二现自法会中二。先现本会。此是一会遍一切处。非是多处各别有会。乃至法界亦如是遍。此圆融法非思之境。二悉以佛神力下。现新集众。言佛神力者。亦即是前各随其类现神通也。文有四段谓总显列名。刹号佛名皆同名号品中。但增百亿为异耳。偈文分二。先彰说人后显偈辞。今初。言一切处文殊者。略申三义。一约当节。如初节中。百亿佛前有百亿文殊。为一切也。各各皆说当节之偈。故文皆云各于佛所。二一文殊从一处东来。即从一切处东来。至一法会。即至一切法会故。虽东来而即一切处。以是法界即体之用身故。三约表法。文殊乃是不动智之妙用。触境斯了。六根三业尽是文殊。实相体周万像森罗无非般若。何有一处非文殊哉。下九节中皆有二段。仿此可知。二正显偈辞。然释此偈有通有别。通者此明菩提超情。别谓显前光中所见之事。于中又二。一约境。谓融前所照显理法故。二约观。谓令大众泯绝诸见。于所照事不生执取。然观资理成理由观显故。通而释之。即明菩提超情。大分为二。初一反显余九顺释。今初。反显违理之失。谓菩提体德超绝一切。佛地论明佛非漏非无漏。亦应于世非着非无著。今乃见佛。内离诸漏外不着世。则有漏可离有世不着。取舍未亡此见违理。故非道眼。证道眼者。无分别故。余偈顺显见理之益。皆上三句观相。下句观益。于中九偈各是一义。且分为四。初六观佛。次一趣求。次一观生。后一了法。初中初偈正显佛菩提性本来自空。称此而知则无上失。体谓真性。相谓德相。并性无所有竟何所离。本无有着谁为无著。如是知者。名为正解。修习明了斯为正行。下句观益。言疾作佛者约文殊门情尽理现。即名作佛。约普贤门信终圆收。约行布说则不见此理。成佛未期他皆仿此。次一偈依正等。观佛菩提性依正无二故。亦显光所照处以明离见。谓上半于前所见世界。令离妄动。知真法界不应动故。次句例前八相。佛身亦同。平等不动而了故。成胜智。次偈佛法等观了同体故。二念岂生一亦不存。得难思果。次偈生佛等观言身即众生。以梵本中云佛及我故。我即行人之身称理普周。云平等住。平等则无能所故曰无住。我即法性。更不证入法性无性。复何所入。如是知者旷世难逢故。般若文殊分云。若知我性即知无法。若知无法即无境界。若无境界即无所依。若无所依即无所住也。又本会即住无所住。新集则入无所入。问若皆平等。云何分别有三宝耶。智论答云。平等即是三宝。谓平等即法宝。法宝即是佛以未得法不名佛故。得平等法。分别有须菩提等。次偈会通平等。谓上来主伴依正不离五蕴。五蕴性空即是平等。有相差别总名为数。即同无为故非数法。离数超世成寂静果。次偈拂上出世。谓真出世者。超越入出不碍照知。故成光耀又上第三偈佛即是法。第四偈法即是众。第五偈明是三宝皆无为相。此偈与虚空等。二有一偈。趣求者。以上虽离见而知。犹恐带寂故。上半劝求。次句又观性离。谓了回向心本自不生。是离相回向也。离相求佛得名称果。三次一偈。所见众生亦皆称真。故无生坏知无众生。是无上道故。下经云。无上摩诃萨远离众生想。末后一偈知法。即成前法会周遍所由。上半标门。即十玄门中。一多相容不同门也。次一句释所由。即十种所由中缘起相由门也。并如义分齐中。谓一与多互相生起。且一依多起。则一是所起而无力也。多是能起故有力也。以多有力能摄一。以一无力。入于多。是故此一恒在多中。多依一起准上知之。是则此多恒在一中也。以俱有力及俱无力。各不并故。无彼不相在也。以一有力一无力不相违故。有此恒相在也。缘起法界理数常尔。称斯而见何所畏哉。由此缘起成前平等。由前平等成此缘起。文理昭然不许事事无碍。恐未着深思。第二重光照十方各十佛土者。是娑婆邻次之十刹也十偈通显菩提因果。分三。初偈菩提之因。次五菩提果用。后四令物思齐。今初上半所为。谓无明造业爱能润业。故生死无穷。如泥中刺不觉其伤。如疮中刺为其所毒。下半能为。即从痴有爱。菩萨悲生非大菩提莫之能拔。无此悲智非佛法故。次五菩提果用中。初偈悲智双满。智见诸法悲以转授。普见通于性相故。离二边谓真故无有俗故无无。真故无有则虽无而有。俗故无无则虽有而无。虽有而无则不累于有。虽无而有则不滞于无。不滞于无则断灭见息。不存于有则常着冰消。俱不俱等何由而有。诸边都寂故云皆离。次一美往因行。次一慈力降魔。次一智断致用。后一法鼓警机文相并显。后四令物思齐者。斯即佛因。能如是行得诸佛道。四偈显四种行。一游刹无著。谓不坏其相故能普游。了刹性空故于有无著。二念佛生喜。上半所念法身显故。如空永常。解脱累亡如空清净。下半能念忆持明记。故喜生愿足。三亡苦济物。四护法轻身文并可知。第三重光照百界。偈中显佛八相菩提。十偈分二。初偈标德充满。后九别广调生。今初。谓了俗即真故。如幻本虚真不碍俗。故达诸法相性相无碍。是真通达。无二碍着则转依心净。大悲同体故。调伏众生则三德备矣。故能摄化。后九中即悲愿自在调伏普周。虽数越尘沙略。论其九。皆言或见者。然有多义。一或多机异处各感见。二或同处。各见。三或异时别见。四或同时异见。五或同时异处见。六或同处异时见。七或异时异处见。八或同时同处见。九或一人于同异交互时处。见多人所见。十或一人于同异俱时处。见一切人所见。以是普眼机故。然佛不分身无思普现也。一初生时身如夜月皎镜可观智犹满月清凉照物。故云永作。二行七步时显其具德。三顾眄时观方现笑。四师子吼时说我独尊。五出家时解缚修寂六坐道场时障尽德圆。七转法轮时因悲度物。八显神道时调彼难调。九示入涅槃不妨神用。又下二句亦总结前九。皆是神通并有深意。如第八会。第四重光照千界。颂中显菩提体性。十颂分三。初偈双具悲智为菩提体。次四三德内圆。后五即体悲用。今初上半智深下。半悲济。次四偈中一叹菩提永绝。二我德。谓二我之见必因于身。今观于身若我即阴。我即生灭。若我异阴以何相知。故但妄情曾未暂有。既无有我谁是我所。我我所空身从何有。无身之身显法身德。二显解脱般若德。涅槃二十五云。贪嗔痴心永断灭故心善解脱。于一切法知无障碍。故慧善解脱。涅槃略有一百八句。以显深广。言明行者。即般若德。若作明行足释即禅慧德。瑜伽三十八云。明谓三明。行诸止观二品。涅槃十六又云。明者三明。一菩萨明。二佛明。三无明明。菩萨明者。即是般若波罗蜜。佛明者。即是佛眼。无明明者。即毕竟空。然皆般若因果理智异耳。足有二义一脚足义约因。二圆足义约果。此文略无。无数下。显其离过非有为故。无数超下位故。无等岂是因明能求其过。因明立量依世俗分别定有定无。故曰世间。今体绝有无。故彼莫能过也。如说佛声非定有故。不同外道立常。从法性生离造作故。不同菩萨所立无常。三科皆尔。岂将佛德判属无常。诸因量者。谓诸因诸量。及自他共等三种比量。比量虽有三支。五分因是量主故曰因量。三一偈叹佛超绝三科德。蕴者聚义。谓是有为生死果相。界者种族义。谓是爱着生死因相。处者生门义。谓诸识内外缘相。然不离色心。俱舍论云。愚根乐三故说蕴处界三。蕴等有二。一者有漏是世数法佛非此成。二是无漏则佛非无因。灭无常色等获常色等故。如来妙色常安隐故。四叹佛超离根境德。境智双寂契彼性空。根尘两亡内外解脱。亦常照内外脱于无知。空尚不存妄从何起。又上四偈初一法身故常二无过故乐。三数不能成。故自在称我。四解脱故净。后五即体悲用中。初偈不动普应德。上半不动下半普应。二我永亡称性不动。智周法界何有去来。次偈动寂无二德。三句入寂一句起用。一相是表所谓无相。无二是遮体不可分。又无二者。非对有说无也。观无始终故心不增减。三轮之化云无量神力。次偈。无染了机。次偈度心平等。后偈无生现生智契非有。悲心遍生随机引之。令归常寂。第五重光照十千界。颂中明等菩提因行文有十行。皆三句辨相。一句劝修。虽皆作业而展转深细略分为五初一大悲下。救业不求自利。故云永出人天。次四修智上攀业。一信二乐三念四学。又初一长时修常信不转故。次一殷重修志乐不退故。清凉慧者。无惑热故。次偈无间修不暂断故。后偈无余修常遍学故。三有一偈。内照业观。身实相者。如净名观佛前际不来等。又如法华不颠倒等。中论法品云。诸法实相者。心行言语断无生亦无灭。寂灭如涅槃即上半也。又云。诸佛或说我或说于无我。诸法实相中无我无非我。即下半也。又离我者。超凡夫。离无我者。超二乘故能悲济。然我无我通有四句。一唯有我。二唯无我。三者双辨。即生死无我涅槃有我。四双非上二互形夺故。四一偈等观业。大悲同体所以等观。见真息妄不起分别。妄尽契如名入真实。五后三偈大用业。初偈神足通。后二法智通。于中初一知土。法性土为非色。余皆为色。此二融即皆悉委知。后一知佛。又十展转者。初悲欲救生当云何救。信乐近佛。乐其何法。乐佛功德。佛以功德成其身故。空乐何益。当念念修学。学他不如自观。自观不及物我齐致。入真滞寂当起大用。用何所为当拟。穷十方界入诸佛海。第六重照百千界。即第二答佛威德问。威德约身故。前五法身后五智身。前中分二。初一拣迷。谓以威德则自在炽盛。色相则端严吉祥。种族则名称尊贵。虽是薄伽而见从外来。取相乖于最胜故。为倒见犹眼有病故。见外空华执内为外。谓空为有。后四示悟显最胜法。初偈明如来色相无边故。起情莫测。无边有二。一深故随一一相称真无边。二广故。谓具十莲华藏尘数之相。次偈释上二义。前半释深相。即无相故。后半释广无相之相故。广复有二。一无限因成。二应机普现。谓色无定色。若金刚之合朱紫形无定形。犹光影之任修短相无定相。似明镜之对妍媸故随乐皆见。三一偈明所证超情。以成前义。前半正显。谓欲言其有体相寂灭。欲言其无色相无边。故止言显妙唯智方契故。心虑叵量理圆言偏故。言说莫及。后半重释。谓应缘非不合。住体非和合。又缘起修成非不合。契真相尽非和合。又缘即非缘故非和合。非缘即缘故非不合。合相离故无诸相非合亦离体寂灭也。四有一偈明能证超绝。结归佛身。上来体性寂灭遣有。身相具足遣无。非合不合遣俱有无。而复谓佛是非有非无。还成戏论。中论云。戏论破慧眼是皆不见佛。故次遣之。谓妄惑不生故非蕴聚。起心则生便成戏论。决定见者。不随境相名自在力。有无不能累其神。故无畏也。非言行处为绝言道。后五智身中。初知解脱智。谓外身非业系。内心无取着。为皆解脱。常契等理故云正念。又内脱二障外用无羁。此明自住。下四大用自在展转相释。初一以寂照智利生。意净寂也。光明照也。净故无著。明故智周。故能大作佛事。次一云何利生。谓变化智自在。上半一多无碍。下半随器普现。次偈明一多所从。以无生智随物而感。谓一身多身但由众生分别心起故。无积无从其犹并安千器数步而千月不同。一道澄江万里而一月孤映。情隔则法身成异。心通而玄旨必均。云云自他于佛何预。后偈复拂前迹。谓即前分别之器。亦无所有。妄见之身。岂当可得。此法是佛所知当依此理见佛。此后二句兼通结上。第七重光照十方百万世界。此下四段答法性问。佛以功德为法性故。即分为四。初一总显内外包摄德。二方便干能德。三大悲救摄德。四因果圆遍德。今初。偈中分二。前五叹佛法难思。后五示入方便。今初分三。初三直就佛明。次一对机以辨。后一约法以明。今初。初一句所缘。及一切种智清净。于所缘所知中。无碍智自在转故。次句所依清净。烦恼习气永无余故。三一切种心清净。一切善根皆积集故。四具大悲故。五无忧喜之离染安住舍故。故无所著。六恶想都绝不依止名闻利养故。七八二句。体虽叵量具相好故称叹。九智光遍觉离倒名净。身光可知十永害习气故。十一住正念故。离边常明记故不动。亦是成上智光所观故。结云佛智。又此一偈即四无所畏。光明即正觉。清净即出苦。涤累漏尽及与障道无畏。不动即无畏之义。外难不能倾故。不堕胜负二边故。是无畏智。二一偈对机以辨中。身心离分别者。含于二意。一约佛。以三业随智慧行等故。二约机。即知上功德。而能身心无分别者。则得无疑无滞益。三有一偈约法以显。虽法界遍转。无性寂灭故无所转。假以言宣云方便说。其能转智即十力智。后五示入方便者。上来说佛不离功德菩提。上所说法。不离教义次第令入。初偈令念菩提。初句善决性相。次二句契理绝想。以生分别想即戏论故。具斯二义为念菩提故。大般若云。觉法自性离诸分别同菩提故。又心绝动摇言亡戏论。又瑜伽九十五有六种戏论故名为诸。次偈随教。上二句了法亡言。次句得旨方名随顺。次偈入佛功德。上二句双存一多相别故。次句双泯相形夺故。一因于多有多中应有一。多因于一有。一中应有多。今多中无一一无从矣。一中无多多无从矣。故二俱舍也。而性相融通入一即是入多。名普入也。然一多相依互为本末。通有四义。一相成义。则一多俱立。以互相持有力俱存也。即初二句二相害义。形夺两亡以相依故各无性也。即二俱舍是。三互存义。以此持彼不坏彼而在此。彼持此亦尔。故上文云。一中解无量等是。四互泯义。以此持彼彼相尽而唯此。以彼持此此相尽而唯彼故。下文云。知一即多多复即一是也。诸文各据一义。故不相违矣。复总收之以为十义。一孤标独立。二双现同时。三两相俱亡四自在无碍。五去来不动六无力相持。七彼此无知。八力用交彻。九自性非有。十究竟离言。次偈入佛菩提依正皆寂。故无所依智契于斯。故无分别。后偈知法义上。明生土皆寂不可言异。依正两殊不可云一。第八重光照一亿界。前云百万。今十倍于前。即千万为一亿也。十偈叹佛权实双行方便干能。然方便之言略有三意。一以因中十种加行方便之力。修成佛果自在之德。二但是差别之用皆名方便。其无碍慧无若干故。三即实之权起用自在。故名方便。今文具三。皆三句辨相。一句结名。初偈即礼起用为方便。然有六义。一智超下位。二证法无边。三解脱有海。四具上三义到涅槃岸。五寿兼真应。六身光无涯皆佛功德。二叹寂照方便。初句横照。次句竖穷。次句即寂照而无思。故难思也。三叹佛事理无碍方便。初二句有无无碍。次一句定散无碍。四叹佛修无修方便。初句善穷性相。次句无念勤修乐于解脱。释修涅槃。离不平者。释前正念。以不见生死为杂染。涅槃为清净。此二无差为真寂灭。五叹回向方便。初二句趣如法界。是回向实际。余皆回向菩提。次句回向众生。住如化物故为方便。六证知方便。初句随顺证入。次句知而无障。次句知遍趣行即利生法。即知即证为自在修也。七寂用方便。初句寂。次句用。次句寂用无碍。为无住涅槃。凡小难到。八时数方便可知。九难思方便。初句了生灭。刹那一期皆悉了知。次十一字了相即众生体。不出三界九地。下二界是色。无色界非色。二界八地皆名为想。无想天为非想。有顶非想非非想。悉了知者。能了兼了其性即是无生。此是无边之境故难思也。上二偈但了差别即是方便。十无比方便。初二句知相。上句竖穷下句横摄。次句知性此二不二故。无比即为方便也。第九重光照十亿界。叹佛大悲救生德。十偈多以第四句为结。于中分三。初偈总标行海已圆而能普化。次八别显化类不同。后一总结悲智周遍。初中初句无余修。广谓遍受大谓极苦。次句长时无间。次句功行已圆。极恶难度已能度故。云何能度。谓师子吼。师子吼者。名决定说。定说一切众生皆有佛性。度一阐提。定说无我度诸外道。定说欲苦不净。以度波旬。定说如来常乐我净。度诸声闻。定说大悲以度缘觉。定说如来无碍大智。以度菩萨。故云普化众生次八别中云何普化。初化痴爱众生。前半所救。如人堕海五事难出。一水深。二波迅。三迷闇。四虫执。五忧迫失力。众生欲海流转亦尔。此中爱有二义。一已得无厌深广如海。二于未得处无足如流。痴亦二义。一迷不见过。二妄见有德。结网自缠。五由前痴爱招大忧苦。次句举古佛已行。亡身为物故曰至人。后句立誓当作。二度着欲众生。上半所救。放逸者。着欲缘也。着五欲欲事也。不实分别欲因也。受众苦欲果也。未得已失皆受大苦。正得亦苦横生乐想。况当受三涂故云众苦。次句受教自修。后句立誓转化。三救着我众生。前半所救着我为因受生死果。未证无我浩无边际。次句救方。说二无我唯佛有之。四救恶趣众生。三句所救。谓无善可恃。显唯恶业及惑病因招三恶趣。展转复起三毒之过。因果俱烧末句救方。但净其心因亡果丧。五救邪见众生。前半所救。上句明因迷四真谛。惑现境故。次句起见。邪见翳理即为闇宅。后半能救之方。六救著有众生。前半所救。三有深广总喻于海。漂至人天还溺恶趣。未遇如来多成难处。希求不已故名为忧。未有对治故无涯畔。具上诸失故不可处。后半能救可知。七救无明众生。前半所救。由本住无明故。不见无住之本。迷理惑事狂走于生死之中。后半能救。佛既授法正念即升也。八救险道众生。前半所救。人天报危临堕恶趣。名为险道。能救可知。后一偈总结者。前半结有教证之智。能导无缘之悲。次句结有同体之悲。能遍十方六道。后句结于所救不越群迷。第十重光照十方。总结无尽。长行分二。先明世界数量。略有十七渐穷法界。后明彼诸世界所有皆现。十颂明因果圆遍德。于中分二。前四示佛因果遍说。后六劝物顺行。今初。初一偈因圆果满。彰有说因。初三句三达因圆。后句十力果满。次一偈大用外彰。正明说法周遍可知。后二对因辨果。初一偈遍因初可为因。三句皆果法供养佛故于法顺知。普为众生故。能遍用。斯即等流名相似果。晋经云。正心供养。明是法供养也。后一偈深因故能速证。初二句六度自利。谓供佛是檀意。柔兼戒。从初至末是进策也。次句利他兼方便等。二行既圆则佛果朝夕。故云速成。后六偈观物顺行。佛昔如是行今得说法果令物行之亦得斯果初一偈求法行。二说法行。三听法行。四有三偈破相行今初。初句离过。胜他名利名为异情。次二句显德。一句满福。一句圆智。又无异者。于一切法都无所求。若此之求则见真法身也。二说法行。前半说法益物。义利者。令众生得离恶摄善故。此世他世益故。世出世益故。福德智慧益故。上四对皆先义后利。后半若无说无示同佛说也。三听法行兼显法轮之体。初句教法。次句即教成行。无有一文一法非菩提因。岂止三十七品。次句悟理拣去随文。后句理无废兴。故常见佛果也。后三破相行。初一正明后二转释今初。初三句。反显金容焕目而非形。安可以相取。后句正显法性超乎视听。唯可虚己而求。后二转释云何不见。前偈以妄喻真。众生妄惑尚不可穷。诸佛契真如何见尽。后偈复转释。云虽遍十方不可定取。如刹遍空有其四义。一多刹满空。二体无来去。三不妨成坏。四无别所依。佛身遍空亦具四义。一顿遍多刹。二恒不去来。三应有出没。四体用无依。是故佛身亦不可以遍空而取耳。上来三品。答初十句所依果问竟

大方广佛华严经疏卷第十三大方广佛华严经疏卷第十四

        唐清凉山大华严寺沙门澄观撰

    菩萨问明品第十

释此一品亦有四门。初来意中有通有别。通谓上来三品。已答十句生解所依。此下正答主解因果。故次来也。生解因中先答十住。住揽信成。将答所成。先辨能成。又正答十信故下三品来也。后别者。三品明信有解行德。解为二本此品先来。二释品者。菩萨是人问明是法。遮果表因故云菩萨。问即是难。明即是答。然问有二种。一泛尔相问。梵云必理车。二者难问。谓以理征诘。梵云钵罗室囊。即今品意也。答亦有二。一但依问詶报曰答。二若俱为解释旁兼异义。美言赞述令理显焕曰明。即今品意也。明亦破闇。能除问者之疑闇故。今文殊九首互为明难。递作砧椎。研核教理以悟群生。故以名也。又长行明起于问。偈颂明解于问故曰问明。不云答者。欲以明兼于问故。问有二义故得称明。一问中征责诘难理尽。使答者亡言。此至明之问也。二以问中进退诘理令现使答者易释。故以为明。又明即法明。以十菩萨问出十种法明。故曰问明。虽诸义不同。皆菩萨之问明。依主释也。三宗趣者。亦先通后别通复二义。一通分宗。二通会宗。并如会初。二别明此品。有其二义。一望当品以十甚深为宗。依成观解为趣。二望后二品。则以甚深观解为宗。成后行德为趣。第四释文。此下至菩萨住处。明生解之因。配十句问。如前问中依文次第。且分为六。初此下三品明未信令信。二第三会已信令解。三第四会已解令行。四第五会已行令起愿。五第六会已起愿令证入。六十定品至住处品。已证入令等佛。今初三品即为三别。此品明正解理观。次品明随缘愿行。贤首品明德用该收。就初分二。先问答显理。后示相结通。前中以十菩萨各主一门显十甚深。即为十段。一缘起甚深。二教化甚深。三业果甚深。四说法甚深五福田甚深。六正教甚深。七正行甚深。八正助甚深。九一道甚深。十佛境甚深。此十甚深次第。云何缘起深理。总该诸法观解之要。故首明之。众生迷此故须教化。违化顺化有善恶业。欲知此业由说法成。然说法成善唯佛福田。既说顺田须持圣教。教在勤行。行须正道助道。助必有正殊涂同归。得一道者。当趣佛境故为此次。又此十种亦可配于十信。但不次耳。文殊佛境即当信心。文殊主信故。佛境即所信。故约发心次第信居其初。约所信终极最居其后。亦明十心不必次故。勤首即进心。财首为念心。明四念故。觉首定心。能观心性为上定故。智首则慧心。慧为上首兼己庄严故有十度。法首即不退心。如说修行得不退故。宝首即戒心。三聚无缺如宝珠故。业果甚深戒所招故。德首即护法心。说法甚深是所护故。目首即愿心福田等一由愿异故。目能将身如愿导行故。贤首即回向心以归一道。即回向真如。一身一智等。即是佛果。文云。如本趣菩提。所有回向心等。以是圆融十法故。各兼多义。又亦摄十信之十德。恐繁不叙。且为十甚深解。然有二义。一约行。二约法。言约行者。文殊发问九菩萨答。明妙慧通于众行。九菩萨问文殊为答。明众行成于妙慧。言约法者。初九显差别义。后一显差别同归佛境。此二不二成信中之观解。文中十段。皆先问后答。又先起明问后解问明。今初。问中二。先彰问答之主。问觉首者。彼得此门故。缘起深义不觉则流转故。二佛子心性下。正显问端。略启五门。一问所为。二述问意。三定所问。四会相违。五释本文。初所为者。有二义故。最初问之。一拂异见。二显深理。拂见有三。一令诸菩萨知法从缘异外道见。二知从心现舍二乘见。三但心性起不同权教。二显深理者。令诸菩萨于此实义发深信解。起行证真始终皆实。故问斯义。起信论云。有法能起摩诃衍信根。是故应说。所言法者。谓众生心。依一心法。有真如门及生灭门。彼论依此生净信故。二述问意者。谓明心性是一。云何见有报类种种。若性随事异则失真谛。若事随性一则坏俗谛。设彼救言报类差别自由业等熏识变现不关心性故无相违者。为遮此救故重难云。业不知心等。谓心业五依各无自性。自性向无何能相知。而生诸法。既离真性各无自立。明此皆依心性而起。心性既一事。应不多。事法既多性应非一。此是本末相违难。亦是理事相违。亦一异相违。亦真妄相违。三拣定所问者。准此问意。离如来藏不许八识能所熏等。别有自体能生诸法。唯如来藏是所依生。亦不可言八识无二类。故名心性一以能生种种非相违故。亦非第八而为性一。熏成种种非相违故。心性之言非第八故。答中既言。法性本无生。示现而有生。法性即是真如异名。正与报事相违故成难耳。文殊欲显实教之理。故以心性而为难本。欲令觉首以法性示生决定而答海会同证。楞伽密严皆广说故。四会相违者。问若尔瑜伽等中。异熟赖耶从业惑种办体而生。非如来藏随缘所成。如何会释。答瑜伽等中。对于凡小约就权教随相假说。楞伽密严对大菩萨。依于实教尽理而说。既机有大小法有浅深。教有权实故不相违。故密严云。佛说如来藏以为阿赖耶。恶慧不能知藏即赖耶识。此明守权拒实诃为恶慧。又彼经云。如来清净藏世间阿赖耶。如金与指环展转无差别。楞伽中真识现识。如泥团与微尘非异非不异。金庄严具亦复如是。皆此义也。又彼经云。如来藏为无始恶习所熏。名为藏识。又入楞伽云。如来藏名阿赖耶识。而与无明七识共俱。又起信论云。不生不灭与生灭和合。非一非异名阿赖耶识。又如达磨经颂云。无始时来界为诸法等依。摄论等就初教释云。界者因义。即种子识。宝性论翻此颂云。此性无始时等。彼论就实教释云。性者。谓如来藏性。如圣者胜鬘经说。依如来藏故有生死。依如来藏故有涅槃。以此等文。故知两宗不同。浅深可见。又唯识等。亦说真如是识实性。但后释者。定言不变失于随缘。过归后辈耳。五释文者。文分三别。初心性是一者。立宗案定。二云何下。设相违难。三业不知心下。结成前难。今初。谓心之性故。是如来藏也。又心即性故。是自性清净心也。又妄心之性无性之性。空如来藏也。真心之性实性之性。不空如来藏也。皆平等无二故云一也。第二设难中二。先总显相违。谓心性既一。云何而有五趣诸根总别报殊。故云种种。不同二所谓下。别示相违。有十事五对。一约总报明趣有善恶。善谓人天恶谓三涂。下四对皆约别报。于中二。谓于前善恶趣中。各根有满缺。谓眼等内根。三于满缺中各生有同异。谓四生不同胜劣处异。四于上同异生处。各貌有妍媸。五于上妍媸各受有苦乐。上之五对前前皆具后后。后后必带前前。展转异同成多差别。故云种种不同。心性是一其义安在。第三结成前难中。此文意稍难见。略为二解。一依古德作遮救重难。如前第二问意中辨。二直结成前难。且依此释文。自有三意。由前难意亦有三故。一直问所以故。今结云。非但本性是一。我细推现事各不相知。既有种种何缘不相知。既不相知谁教种种。若谓业令种种业不知心。若谓心令种种心不知业。一一观察未知种种之所由也。二者怀疑故结云既不相知。为是一性为是种种。三作相违难。结云一性随于种种即失真谛。种种随于一性即失俗谛。今见种种又不相知。此二互乖云何并立。已知大意。次正释文。亦有十事五对。略为二解。一通二别。通谓总观前来总别二报。于中初一对。就先业因约能所依以难。然有二意。一约本识。谓业是能依心是所依。离所无能故云业不知心。离能无所故云心不知业。以各无体用不能相成。既各不相知谁生种种。下并准之。二约第六识。业是所造心是能造。并皆速灭起时不言我起。灭时不言我灭。何能有体而得相生成种种耶。第二对约得报果时难能所受。谓受是报因。即名言种为业所引。受所受报。离报无受故云受不知报。离受无报故云报不知受。以并无体故准前应知。三约名言因就能所依难。谓前能受报因。依心无体故无相知。余义同前。四约因缘就亲疏相假难。谓所引名言种为因。能引业为缘。相待相夺各无自性。如不自生等准之。五约境智相对相见虚无难。谓境是心变境不知心。心托境生心不知境。以无境外心能取心外境。是故心境虚妄不相知也。第二别观者。以初二对结趣善恶。趣善恶者。正由业熏。受总报故。二复以第二及第三对。结受生同异初对以名言种对所生处。次对以名言种对能依本识。三复以第三及第四对。结苦乐不同及端正丑陋。初对观现受时。次对观苦乐因及彼妍媸。皆由缘令异。谓损益因成苦乐果。以嗔忍因成妍媸果。四复以第四及第五对。结诸根满缺亦有满业因缘有损他益他之异。故成内六处满缺之果。又由内根有满缺故。于分别位了境不同。并皆无性各不相知既不相知谁令种种。第二时觉首下。答中二。初一偈赞问许说。上半赞问。谓自究深旨。一向为他仁心弘益也。次句许说分齐称性说故。后句劝听。言同意别故令谛受。后十偈正答。答势纵横具答三重问意。且分为二。前五答前释成之中。以何因缘而不相知。用此释成答前难故。首而明之。后五正答前难。令初分二。先一法说。后四喻况。今初意云。特由从缘种种。故不相知也。即此偈上半出因。下半结归本宗。后四即为同喻量。云眼等是有法。定不相知故是宗法。因云从缘无体用故。同喻云如河中水。河水无体用河水不相知。眼等无体用眼等不相知。若以缘起相由门释者初句因缘相假互皆无力。次句果法含虚故无体性。至下喻中别当释之。是故虚妄缘起略有三义。一由互相依各无体用故。不相知。二由依此无知无性。方有缘起。三由此妄法各无所有故。令无性真理恒常显现。现文但有初后二意。言诸法者。非唯举前十事五对。亦该一切有为法也。果从因生果无体性。因由果立因无体性因无体性何有感果之用。果无体性岂有酬因之能。又互相待故无力也。以他为自故无体也。下半结中是故者。是前体用俱无故。故彼一切法。各各不相知也。第二喻况。略有二意。一以此四喻通释诸法不相知言。二别对前文诸不相知。兼通前设难。今初以四大为喻。然各上三句喻况。下句法合。然此四喻各显一义。一依水有流注。二依火焰起灭。三依风有动作。四依地有任持。法中四者。一依真妄相续。二依真妄起灭。三妄用依真起。四妄为真所持。然此法喻一一各有三义。一唯就能依。二依所依。三唯所依。今初喻中。唯就能依者流也。然此流注有十义不相知。而成流注。一前流不自流。由后流排故。流则前流无自性故不知后。二后流虽排前而不到于前流。故亦不相知。三后流不自流。由前流引故。流则后流无自性。故不能知前。四前流虽引后而不至后故亦不相知。五能排与所引无二。故不相知。六能引与所排。无二故不相知。七能排与所排亦无二。故不相知。八能引与所引。亦无二故不相知。九能排与能引不得俱。故不相知。十所排与所引亦不得俱。故不相知。是则前后互不相至。名无自性。只由如此无知无性。方有流注则不流而流也。肇公云。江河竞注而不流。即其义也。然上云前后者。通于二义。一生灭前后。谓前灭后生互相引排。二此彼前后即前波后波。小乘亦说当处生灭。无容从此转至余方。而不知无性缘起之义耳。二依所依者。谓前流后流各皆依水。悉无自体不能相知。然不坏流相故说水流。三唯所依者。流既总无但唯是水。前水后水无二性故。无可相知。是则本无有流而说流也。二法中三义者。一流喻能依妄法。二妄依真立。三妄尽唯真。初中妄缘起法似互相藉。各不能相到。悉无自性故无相知。是则有而非有也。二依所依者。谓此妄法各各自虚。含真方立。何有体用能相知相成。即由此无知无成含真故有。是则非有而为有也。三唯所依者。谓能依妄法迥无体用。唯有真心挺然显现。既无彼此何有相知。正由此义。妄法有即非有。以非有为有。复说真性隐即非隐以非隐为隐。此上三意即三种答。答上三种问思之。何故以水喻真心者。以水有十义同真性故。一水体澄清喻。自性清净心。二得泥成浊。喻净心不染而染。三虽浊不失净性。喻净心染而不染。四若澄泥净现。喻真心惑尽性现。五遇冷成水而有硬用。喻如来藏与无明合成本识用。六虽成硬用而不失软性。喻即事恒真。七暖融成软。喻本识还净。八随风波动不改静性。喻如来藏随无明风波浪起灭。而不变自不生灭性。九随地高下排引流注。而不动自性。喻真心随缘流注。而性常湛然。十随器方圆而不失自性。喻真如性普遍诸有为法。而不失自性。略辨十义少分似真故。多以水为喻。此义见文虽似不具。而大通众经。第二依火焰起灭喻中。三义同前。初唯焰者。谓焰起灭有其二义。一前焰谢灭引起后焰。后焰无体而不能知前焰。前焰已灭复无所知。是故各各皆不相知。二前焰若未灭。亦依前引无体故无能知。后焰未生故无所知。是故彼亦各不相知。妄法亦尔。刹那生灭不能自立。谓已灭未生无物可知。生已则灭无体可知。是故皆无所有也。斯则流金烁石而不热也。二依所依者。谓彼火焰。即由于此无体无用不相知。故而有起灭虚妄之相。是则揽非有而为有也。妄法亦尔。依此无所依之真理方是妄法。是亦非有为有也。三唯所依者。推起灭之焰体用俱无。无焰之理挺然显现。是则无妄法之有。有妄法之无。湛然显现。遂令缘起之相相无不尽。无性之理理无不现。上三义中。亦如次喻答前三问也。下二喻准知。第三依风有动作喻妄用依真起。三义同前。一唯动者。离所动之物。风之动相了不可得。无可相知。妄法亦尔。离所依真体。不可得故无相知。斯则旋岚偃岳而常静也。二依所依者。谓风不能自动。要依物现动。动无自体可以知物。物不自动随风无体。不能知风。法中能依妄法要依真立。无体知真。真随妄隐无相知妄。三唯所依者。谓风鼓于物动唯物动。风相皆尽。无可相知。妄法作用自本性空。唯所依真挺然显现。是故妄法全尽。而不灭真性。全隐而恒露。能所熏等法本自尔。思之可见。第四依地有任持者。喻妄为真所持。三义同前。初地界因依有二种义。一约自类。二约异类。前中从金刚际上至地面。皆上依下下持上。展转因依而得安住。然上能依皆离所无体。而能知下。然下能持皆亦离所无体。可令知上。又上上能依彻至于下。无下可相知。下下能持彻至于上。无上可相知。是故若依若持相无不尽。所现妄法当知亦尔。必粗依细。谓苦报依于业业依无明。造无明依。所造展转无体。无物可相知。斯则厚载万物而不仁也。肇公亦曰。乾坤倒覆无谓不静也。二约异类者。如下文地轮依水轮。水轮依风轮。风轮依虚空。虚空无所依。准此妄境依妄心。妄心依本识。本识依如来藏。如来藏无所依。是故若离如来藏。余诸妄法。各互相依无体能相知。是则妄法无不皆尽。二依所依者。地界正由各无自性。而得存立。向若有体则不相依。不相依故不得有法。是故揽此无性以成彼法。法合可知。三唯所依者。谓揽无性成彼法者。是则彼法无不皆尽。而未曾不灭。唯无性理而独现前。余义同前。上通答释成前难竟。第二别对诸不相知及通前难者。初水流转喻。前二对不相知。答趣善恶难。以善恶趣流转体故。二大火喻。第二三对不相知。答前诸根受生。如火依薪有生灭故。次以长风喻前因缘。答前好丑。遇物鼓扇现诸相故。次以地界亦喻因缘。答前苦乐。展转因依以轻重故。又喻前境智答前诸根。随种所生根等异故。上来总别并答释成中。以何因缘各不相知竟。第二五偈答前设难。文分为三。初三偈正答前难。次一偈释成前义。第三一偈。拂迹入玄。今初先明大意。次正释文。今初前问有三重。今此三偈。一一具答上之三间。谓第一直耳。问云。既有种种何缘得不相知。前五偈答竟。既不相知何缘种种。答有四因。一妄分别故。二诸识熏习故。三由无性不相知故。四真如随缘故。初偈具二三。余二各一义。然此四因但是一致。谓由妄分别为缘。令真如不守自性。随缘成有诸识。熏习展转无穷。若达妄源成净缘起。诸宗各取并不离象。受一非余斯为偏见。上第二疑云。为是种种为是一性。今答云。常种种常一性。第三难云一性随于种种则失真谛。种种随于一性则坏俗谛。今答云。此二互相成立。岂当相乖。性非事外曾何乖乎种种。种种性空。曾何乖乎一性。由无方有。一性能成种种。缘生故空。种种能成一性。是以缘起之法总有四义。一缘生故有。即妄心分别有。及诸识熏习是也。二缘生故空。即上云。诸法无作用亦无有体性。是故彼一切。各各不相知是也。三无性故有。论云以有空义故。一切法得成。经云。从无住本立一切法。即上随缘是也。四无性故空。即一切空无性是也。是以无性缘生故空。则非无见断见之空。为真空也。无性缘生故有。则非常见有见之有。是幻有也。幻有即是不有有。真空即是不空空。不空空故名不真空。不有有故名非实有。非空非有是中道义。又开此空有。各有二义。一真空必尽幻有。以若不尽幻有非真空故。二真空必成幻有。以若碍幻有非真空故。二幻有二义者。一幻有必覆真空。以空隐有现故。二幻有必不碍真空以幻有必自尽令真空彻现故。文殊各以初义致难。觉首各以后义而答。以初二义空有异故。以后二义空有相成故。然此二不二。谓有非有无二。为一幻有。空非空无二为一真空。又非空与有无二为一幻有。空与非有无二为一真空。又幻有与真空无二。为一味法界。即中道义。离相离性无障无碍无分别法门。思以准之。复次性有二义。一者有义。二者空义。复有二义。一者不变。二者随缘。以有义故。说二空所显即法性本无生也。以空义故。说依他无性即是圆成。即各不相知。以有义故说于不变。以空义故说于随缘。此二不二。随缘即是不变。不变故能随缘。若唯不变性何预于法。若但随缘岂称真性。故随其流处有种种异。而其本味停留雪山。又若性离于法则成断灭。法离于性则本无今有。又法若即性性常应常。性若即法法灭应灭。故二相成非常非断。此二相夺故。说非有非空。为中道义。苟得其会不惑百家异说。愿诸学者虚己求宗。次正释文。且第一偈答三问者。初答何因种种。此具二意。一以八识熏习而成故。初句五识次句心。是本识集起义故。意通六七。七谓审思量故。六谓意之识故。了别义故。偈文窄故不立识言。亦诸情摄。此从别义。通则八识皆得心意识名。诸情根者。通于八种。类非一故。五依色根。六依第七。七八互依。又第七识为染污根。第八又为诸识通依。云诸情根。言以此者。以上八识。为能所熏展转为因。而常流转。无别我人故云无能转者。又识外无法亦为无者。二明由不相知方成种种。上半出种种。以此者。以前不相知故。举体性空方成流转。即此八识各无体性故。无实我法而为其主。向若有性不可熏变。安得流转。次遣疑者。以虚妄中有二义故。一虚转。二无转故。常种种常一性也。次答难者。虚转故俗不异真而俗相立。无转故真不异俗而真体存。故互不相违也。第二偈亦答三问。初明真如随缘故成种种者。答所以也。初句印上心性是一是不变义。次句答上云何见有种种。是随缘义。唯心变现全揽真性。生非实生故云示现。下二句印上业不知心等者。以是随缘不失自性义故。是以诸趣种种了不可得。生即无生无能现者。性不动故。无所现者妄法虚故。次遣疑者。常生常无生。上半即无生之生业果宛然。故胜鬘云。不染而染难可了知。下半生即无生真性湛然。故胜鬘云。染而不染难可了知。又法性本无生。不空如来藏也。此中无能现。空如来藏也。答第三难者。此中无能现性非性也。亦无所现物相非相也。又示现而有生。性不违相。亦无所现物。相不违性无二为二。二即无二无碍圆融岂有乖耶。言法性者。法谓差别依正等法。性谓彼法所依体性。即法之性故名为法性。又性以不变为义。即此可轨亦名为法。此则性即法故名为法性。此二义并约不变释也。又即一切法各无性。故名为法性。即随缘之性法即性也。本有二义。一约不变。本谓源本。本来不生随缘故生。二约随缘有此法来本自不生非待灭无。即示现生时本不生故。故下云无能现也。第三偈答三问者。初答所以者。上三句种种即一心性。亦印前文殊不相知等。下句出因。由妄分别故有种种。正答前问。此复二意。一上二句依他起也。次句圆成实也。后句遍计性也。由遍计故能起依他。依他无性即圆成实。故唯识云。依他起自性分别缘所生。圆成实于彼常远离前性。故此与依他非异非不异。二者上二句因缘所生法也。次句我说即是空也。后句亦为是假名。此二不二是中道义。又妄心分别有者。情计谓有。然有即不有故云一切空无性。常有常空。是即万物之自虚。岂待宰割以求通哉。又前偈从本起末。末不异本。此偈摄末归本。本不碍末岂相乖耶。第二一偈释成前义。然有二义。一者云何得知无性。以法眼观称性非倒。成净缘起。当知此理甚为决定。二者前偈诃其见有种种。是妄分别。此不应依。此偈印其观察无性各不相知。斯为法眼固应依止。即依智不依识也。第三一偈拂迹入玄者。谓前法性无生。一切皆空实也。示现有生。眼等差别非实也。妄心分别有妄也。如理观察。非妄也。以妄为缘生世间流转。以如理观成出世间非倒法眼。皆是名言而无真实。何者。如言取故。又欲言其实而复示生。欲言不实体性即空。欲言是妄妄不可得。欲言非妄。能令流转。欲言世间即涅槃相。欲言出世无世可出。则染净两亡。是以物不即名以就实。名不即物而履真。然则实理独静于言教之外。岂文言之能辨哉。故但假说。是以什公云。唯忘言者可与道合。虚怀者可与理通。冥心者可与真一。遗智者可与圣同耳。又后三偈。亦如次明三无性观。又此五偈合前四喻。初以流转合水漂流。次颂合火。火本无生随缘生故。次颂合风风即空无。因见物动妄谓有故。次颂合地。法眼见理无分别故。后一总显令亡言故。又前五偈是印成答。次四出所以答。后一夺令亡言。文殊一问以含多意。觉首纵答体势无方。逆顺研穷以显深致。幸诸学者不咎文繁。第二教化甚深。先问中二。初标告。告财首者。彼得此法财益生门故。二正问中二。初立宗。众生即非众生。彼此同许。亦可蹑前觉首八识皆空。二云何下设难。谓众生既空佛云何化。若佛不见生空则无大智。便成谤佛。若见空而化岂不违空。空有相违进退何据。于中先明十随。辨所化差别。后明三轮显能化不同。今初一随根生熟时。如是时中堪如是化。又此句为总。谓随何寿命时等。下九为别。各有二义谓随其寿命修短而化。又以无命者法而教化之身二义者。谓随其所受何等类身而受化故。又宜以观身空寂等而得度者。以彼化故余准此知。故下答中多说后意。行谓三业善恶。解谓识解差别。言论者。国俗教诲。此六多约未发心前。后四多约发趣已去。心乐者。有所欣求。方便者。随所进趣。思惟者。依法求义。观察者。如说修学。二于如是下能化差别。先牒十随。后现三业。教化调伏通于语意。为以十随化故。众生非空耶。为以众生空故。十随虚设耶。第二财首答中。准诸深经及此偈文。略有四意。一佛见众生本来自空非断空故。不碍随化。偈云。诸法空无我众报随业生故。二佛知众生不能自知真空。故悲以随化。偈云。随解取众相颠倒不如实故。三随化即空。不异众生空故。二不相乖。偈云。此是乐寂灭多闻者境界故。四融上诸义。良以揽空为众生。生与非生唯一味故。不增不减经云。即此法身流转五道。名曰众生。法身即众生。众生即法身。法身众生义一名异。以斯义故。佛见众生举体自尽。本是法身不须更化。大智现前见于法身随缘即众生。故大悲摄化。今以寂灭非无之众生。恒不异真而成立故。是不动真际无化而化。以随缘非有之法身。恒不异事而显现。故不坏假名化即无化。所化既空有不二。能化亦悲智不殊。不碍有而观空。方能入理。不动真而随化方能究竟化他。众生不知此理。故流转无穷。今令众生悟如斯法。是则真实随化。非直十随不违空理。亦由此十方契真空故。净名云。当为众生说如斯法。是即真实慈也。十颂分二。初一举法劝听。上半以人显法。已含答意。上句体深下句用广。即闻之寂则闻无所闻。故无众生。大经亦云。若知如来常不说法。是名具足多闻。即寂多闻则善解药病。不碍随化。下二句许说劝听。后九颂别答前问。文势多舍略为二释。一者一一别答。谓初三答随身。次一随命。三一颂答随观察。四一颂答随行及方便。五一颂答随心乐及解。六一颂答随言论。七一颂答随思惟时通此九。二谓依前五随答后四随。亦时通于九。今依此消文。文分为六。初三颂教。依随何身时。随其心乐修其方便。思惟观察。此四遍于五段。二有一颂依命时。三二颂依行时。四一颂依解时。五一颂依言论时。六一颂教离二取。通结上文。今初三颂。若着我时作界分别观。分别观身皆无我故。若爱染身时作念处观。观于内身及心法故。总相而言即二空观。初一我空。次一法空。后一类通一切。今初。上半即寻思观。观于内身四大五蕴若即若离。寻求主者。不可得故下半观益。如实知于假我则有。计实我无。次偈观身实相法无我观。上半谛了身空。谓揽缘假立来无所从故。本无住处缘尽谢灭。去无所至无停积处。虚假似立实无所住。下半观益。后偈类通以身观身。既明见自身二我皆空。则知万法皆是虚妄。此观亦寂故不起心。若作念处释者。内身拣于外器及他身故。念处有二。一通二别。通则身等皆无我等。别则观法无我。今是通也。复有二种。一小二大。此中是大。观身性相同虚空故。空无二我。谁是我言已兼二我。次偈观受不在内外中间故无方所。后偈观心及法。不得善法及不善法故。云知法虚妄心如幻故。不起分别。又别则身受不同。通则受等皆身。是故三偈皆致身言。前问意云。众生既空。云何如来随其身化。今释意云。以彼不知身本空寂。教如是观故。说如来随众生身而教化也。下皆准之。二一颂令于寿命思惟观察。命谓命根。能令色心连持。故名为命。寿谓寿限即命根体。实谓由业种力。引一期报众同分体。住时分限假立寿命。从业缘起起即无起。业尽便灭灭无所灭。本无主者。况刹那生灭实无自性。喻以火轮。谓旋火速转不见始终。生灭遄流宁知本际。又薪火不续识钝谓轮。命实迁流妄谓相续。又轮资火有命假心明。待他而成固无自体。三二偈令依行时。思惟观察。成四种观。一无常观。二空观。三无我观。四无相观。于中初偈略标其四。一切有者三有也。亦一切有为。然无常等经论异说。今且依辨中边论。以三性释之。初无常三者。约遍计名无性无常。以性常无故。约依他起名生灭无常。有起尽故。约圆成实名垢净无常。位转变故。空亦有三。一无性空。性非有故。二异性空。与妄所执自性异故。三自性空。二空所显为自性故。无我亦三。一无相无我。我相无故。二异相无我。与妄所执我相异故。三自相无我。无我所显为自相故。无相亦三。一相都无故。二相无实故。三无妄相故。然皆融摄则此宗意。而偈正意多约前二性辨。后一偈略显二观。上半明空观。报从业生。如梦从思起不实故空。下半明无常观。由上不实故念念无常。前即过去已灭事显例后现未当灭不殊。四一偈依解令入唯识。量观境即心变。故心为主。然此唯识略有二分。一相二见。今随其见分之解。取其相分之相。心外取故为颠倒也。五一偈依言论时令寻伺名等入如实观。谓了名等唯意言分别。无别名等。意即意识分别。言即名言。名言既唯意之分别。名下之义亦无别体。故所言论以兼名义。既随分别则妄计意流。尚未了唯心安入法性。若能如是自觉通达。是入唯识之方便也。即复此心无相可得。妄想不生便入法性。上约心乖。体非不即。又不入者。妄想体虚无可入故。六一偈通结。亦近结次前二偈。能缘所缘即见相也。又观一切法。唯是意言未能除遣。此境亦为能所也。以此为方便得入唯心。种种法出生者。此相见二分。由无始数习有种种法相似生谓能缘心生。则种种境生所缘境起则种种心起。起法必灭。安得暂停。若了相无相生无有生名了种种。则了唯心。若了无性心境两亡。则住无分别自觉智境。不动法界名入法性。故末后偈结上诸观。令亡观相也。佛如是化应如是知。幻人化幻皆无化化也。第三业果甚深。问中亦二。初标能所问人。以事中显理是可贵。故问宝首也。二一切下。正显问端中三。初举法按定。谓诸众生身但四大。假名四大无主身亦无我。安有我所。彼此同许以为按定。二云何下。正设疑难。能造能受是谓为我。所造所受即是我所。以无我故无能造受。谁令苦乐。无我所故无所造受。何以现见而有苦等十事五对。一苦乐者约粗相说。三涂为苦人天为乐。二就苦中各有妍媸。三于其乐中有内身外境。四通于苦乐受中。若时若事皆有多少。此上皆约生报。前生作故。五现作现受名现报。隔一生去受名为后报。三然法界下结难。谓二无我理即真法界。真法界中。定无善恶。未知苦乐从何而生。此问所以也。为无我故无我所耶。为有所受亦有我耶。此致疑也。以圣言量及正理量违于现量。如何可通结成难也。第二答意云。达体业亡迷真业起。报因业起何须我耶。业报揽缘虚无自体。故无我所。由法无我非断灭故。业果不亡斯乃正理。圣教所明不违现事。法若定有不可造受。便违正理。在文分二。初一法说余九喻况。今初。上半约俗谛缘生。即业报相属。答前现见。次句胜义。即空印其按定。此二不二故不相违。无所有言该上业果。则亦无我所。后句是圣教量。智论第二云。有业亦有果。无作业果者。此第一甚深是诸佛所说。下九喻显。通相而明。喻于业果从缘无性不坏事相。别彰喻意喻各不同。初三颂喻业报无性不坏虚相。次一偈喻无造受者。三一偈喻性一相殊。后四喻体无来处。初中初偈双喻业果皆真心现。虽无实体而相不同。次偈喻能生因缘相虚。后偈喻所生业果无实。今初。若法相宗唯以本识为镜。今依法性宗亦以如来藏性而为明镜。然有二义。一随境界质现业缘影故。合云业性亦如是。二随业缘质现果影像故。前偈云。随其所行业如是果报生。二文影略。共显业果似有无体。合云业者。谓善恶等三性者。通性及相。谓此业体以无性之法。而为其性。不失业果之相。而为其性。由无性故。能成业果。由不坏相方显真空。故中论云。虽空亦不断。虽有而不常。业果亦不失。是名佛所说。不失业果。方显中道。又如镜现秽像。非直不污镜。净亦乃由此。显镜踰净如来藏。现生死业果亦然。非直不损真性平等。亦乃由此知如来藏自性恒净也。此有四位。一能现位。复有二义。一由真净故现染。二由真净故不为污。二所现位亦有二义。一由相虚故不能污。二由相虚故虚相现。三相对位亦有二义。一由分明现染方显性净。二由性本恒净令染妄现。四真净虚染镕融一味无碍圆融。思之。此约染净门。以但有所现即为染故。更约喻中。以一异门释。谓一镜是定一门。二所现染净妍媸。等殊是定异门。染净虽虚不能相摄。故是异也。镜现染处不异现净。故是一也。三像不异镜。是非异义。镜外无像故。镜不异像。是非一义。正现像时去像亦失镜故。上二即非一非异门。四像虽即镜而不坏像。镜虽即像而不碍镜。是亦一亦异门也。二田种生芽。喻能生者田喻业缘也。种子喻于识种因也。此二相待。无性故不相知。由不相知方能生。于后有苦芽。故云自然能出生也。亦本识为田名言为种。三幻师现幻喻。喻所生者。若幻色喻报。则幻师喻业。若幻色喻业。则幻师喻业因。以业亦缘生同报无体。而幻相不亡故。中论内。以化复现化喻业果俱空。若幻唯喻报业则不空。四衢以喻四识住。造业处故。二机关出声。喻无造受者。机关缘造体虚无人。喻业从缘故。无造者。从机出声尤更非实。喻报因业起安有受人。夫无我者。因对我无。既无有我何有非我。着无我者亦是倒故。三出[穀-禾+卵]音别。喻性一相殊者。如鸟在[穀-禾+卵]含声未吐喻业同一性。出[穀-禾+卵]声别。犹感报无差。然鸡子之中终无凤响。业虽无性善恶冥熏。四有四偈。喻体无来处。皆从缘来即无来故。然亦不同。初一喻因含于果故无来处。次偈果酬于因故无所从。此二喻内异熟业果也。次偈转轮王七宝。喻外增上业果也。后偈喻无漏业果无漏智火。焚荡有漏智因漏发故。亦无来业果寂然。方依幻住。第四说法甚深。亦可名应现甚深。问及答中通三业故。以说法化胜故。从此立名。先问中初总标告问。德首者显佛德故。二正显问端中三。初举法按定。谓佛证一味法界彼此共许。二云何下正设疑难。谓证悟既一说现乃多。为一耶多耶。偏取互妨。并立相违。就法即体用相违。约佛是证教相违。下辨十种相违。前九是别后一总结。三而法性下释成前难。谓非唯佛悟于一。我观法界亦不有多。能证所证既并不殊。以何因缘而现多种。将无如来乖法界耶。答有二意。一云。所证虽一随机现多。多在物情佛常无念。二者所悟一法即无碍法界。即事之理全在多中。所现乃即理之事。全居一内。以即多之一是所悟。即一之多是所说。既无障碍何有相违。岂唯不违。亦由得一方能广现。由多现故方令悟一。偈中分二。初一叹问利益。上半叹深。但言一理深而非甚。今即多是一故曰甚深。即一之多尤更难了。不可但以一多知故。下半知益。知此甚深方知爱乐。后九喻答。皆三句喻况。下句法合。喻中皆上二句即体之用。三二两句即用之寂。又初二句以一成多。次句不碍常一故不相违。然此九喻别答九种无量。总显境界无量。初地一持多喻答现无量。刹依住胜劣地无异故。二火一烧多。答化无量众。物从火化不择薪故。三海一波异。答说无量法。义海波涛无穷尽故。四风一吹异。答震无量界。随物轻重动有异故。五云雷普雨。答无量音。圆音普震法雨无差故。六地一芽异。答无量庄严。芽茎华实为藻饰故。七廓日普照。答知无量心。无私普照穷皂白故。八净月遍见。答无量神通。不往而至随器现故。九梵王普应。答现无量身。不分而遍弥法界故

大方广佛华严经疏卷第十四大方广佛华严经疏卷第十五

        唐清凉山大华严寺沙门澄观撰

第五福田甚深。问中初标告。以福田是照导引生。又施为诸度之前导。故问目首也。二显问端分三。初举法按定。佛为生福之田。名为福田。田德无二名为等一。此理共许。二云何下正显疑难。谓田既是一植福应齐。施报有差由何而起。前等此异即缘果相违。别显十事。文并可知。三释成前难云。田虽齐等心有高下。容可有殊。既心无异思报云何异。答有数意。一约众生由器有大小。心有轻重故得报有差。非如来咎。二约佛遍称差别之机。方称平等。即一之多差不乖等。即多之一等不碍差。由心平等无私方能随现多果。终令解脱一味曾何异哉。十颂举十喻喻上诸义。初一总喻印成。后九别显所以。前中初句印等是缘等。彼此共许。次句印异乃因异。答别之由。次句无异思惟诚如所见。下句总合。后九别中皆上半喻。下半合。一水喻。器有大小方圆任器故。二幻喻体外方便贵且悦心。三王喻体内方便终得实乐。上二喻佛巧称物机。四镜喻。约众生。谓随妍媸而影殊。心高下而报别。与前镜喻因缘不同。余义无异。后五皆约佛明。五药喻即多之一。具百味故。普去一切烦恼毒故。六日喻即一之多无幽不烛。大小之闇并除。七月光普照喻佛平等拂上诸迹。虽随机现要且无私。八大风普震喻遍动群机。九大火普烧喻终归寂灭。又此五喻。喻灭惑智二障。至平等智地普动诸有。皆证无为。前四即善巧随机。此五则终令造极。岂不等耶。第六正教甚深。问中初标问人。以破懈怠故问勤首。二正显问端中四。初佛教是一者。举法按定。一有二义。一谓断烦恼集证出离灭。此义不殊彼此共许。二谓多人同见所见不异。二众生下正设疑难难亦有二。一对初义。见教之后何以久而不脱。故云。云何不即断惑出离。二对后义。多人同见何以有脱不脱。故言。云何不悉断惑而出。三然其下释成前难。正释后义。多人苦集皆不殊故。五蕴是正三界通依此苦果也。痴爱发润为集因也。兼显初义。前后苦集亦不殊故。四是则下结成相违。出者有益不出无益。佛教是一其义安在。答意云。修有勤惰障有深浅。机有生熟。缘有具阙。智有明昧功有厚薄。故成有迟速。答初难也。修与不修故见同益异。答后难也。上之别义不出勤惰二门故。十颂分二。初一开章许说。谓上半许称实而说。下半开二章门。余九别释。初一释速解脱。后八释难出离。今初。上半牒疑。下半为释。勤则通策万行。离身心相故能速出。然有五相。一有势力。由被甲精进故。谓于佛法中发大誓愿。二勇捍。谓于广大法中无怯劣精进故。三坚猛。由寒热蚊虻等所不能动精进故。四常不舍善轭。由于无下劣无喜足精进故。五精进由加行精进故。由斯五相发勤精进。速证通慧灭障解脱。下八以喻释难出章。总相翻前皆名懈怠。一火微樵湿喻。喻善根生及三障重。暂一闻教才少修行。而业惑内侵令所闻速失。所行速废故。成懈怠难出离也。二钻火数息喻。喻修有懈退。然此下喻。多通三慧以辨懈怠。此喻约闻。即听习数息。明解不生。约思即决择数息。真智不生。约修即定慧数息。圣道不生。圣道如火能烧惑薪暖顶已前皆名未热。已热而息火尚不生。未热数息虽经年劫终无得理。故遗教对此。明小水长流则能穿石。禅宗六祖共传斯喻。愿诸学者铭心书绅。若直就修行以释。当以智慧钻注于一境。以方便绳善巧回转。心智无住四仪无间。则圣道可生。瞥尔起心暂时亡照。皆名息也。三阙缘求火喻。物者艾等也。教诠圣道。等彼火珠要持向智日。以行承之。则圣道火生。空持文字不能决择。心行乖越道何由生。四闭目求见喻。智微识劣喻彼孩稚。约闻慧者。虽对明师不肯咨决。约思修者。虽对教日心眼不开。责圣道之不生。何其惑矣。五阙缘心广喻。喻愚人无净信手以持定弓。复无戒足以拒惑地。以劣闻慧箭。欲遍射破业惑厚地。空欲难遂。六毛滴大海喻。谓以少闻思欲测法海。妄生希欲懈怠尤深。七少水灭火喻。劫火遍炽喻触境惑增。少分三慧安能都灭。八不动遍空喻。喻虽知性空智未游履。而言遍证。亦增上慢人也。第七正行。甚深。问法首者。以行法故。二显问端中三。初出圣教。受谓心领义理。持谓忆而不忘。二何故下申其所疑。佛言能断。今有不断。即教行相违。先标相违。随贪已下出所不断。势力已下结成不断。谓有持法非唯不灭旧惑。亦乃随解。新增十一种惑。势力所转。前四根本后七随惑。皆言随者。杂集第七说诸烦恼皆随烦恼。有随烦恼而非烦恼。由此即显根本烦恼。亦得名随。随他生故。通释贪等如九地中。今约依法新起者说。即贪求名利嗔所不解。迷其自行恃法自高。覆藏己短论难生忿。结恨拟酬。疾彼胜己悭自所知。不解言解废法逐情。三能受持下结成难也。佛言受法能断烦恼。今受还起其故何耶。答意云。法是法药要在服行。服与不服有断不断。非医咎也。故十行品云。如说能行如行能说。智论云。能行说为正。不行何所说。若说不能行不名为智者。故如说行方得佛法。不以口言而可清净。十颂分二。初一劝赞略说。初句劝听。远离贡高轻慢怯弱三种杂染。方名善听。求悟解故。专一趣心聆音属耳。扫涤其心。摄一切心方名谛听。次句赞问显行称理。故名如实。下半略说。言非但者。要兼修行。独用多闻不能证入。故下诸偈皆云。于法不修行。多闻亦如是。此名不行之失。非毁多闻。若无多闻行无依故。是以不行为失。如调达善星。行之为得。如阿难身子故。自利利他之行并须明达。誓穷法海为种智因。但应善义勿着言说。婆沙四十二云。多闻能知法。多闻能离罪。多闻舍无义。多闻得涅槃。净名云。多闻增智慧以为自觉音。下经推度生之方便。乃至不离善巧多闻。上单显闻。涅槃四事为近因缘。即双美闻行故。智论云。多闻广智美言语。巧说诸法转人心。行法心正无所依。如大云雷霔洪雨。如是教理无量无边。恐繁且止。九颂喻。明皆上半喻况。下半法合。初惧溺渴死喻。喻贪随文义失。谓义门波涛漂荡其心。虑溺溺他无暇修行。自绝慧命故名渴死。二设食自饿喻。喻随说废思失说法施人。多求名利。不思法味损减法身。三医不自救喻。喻善知对治而不自治。四贫数他宝喻。喻说佛菩萨功德。不能求诸身心故无分也。五王子饥寒喻。谓王子违王法教。于内起过故受饥寒。学人亦尔。生在法王教法宫中。行边佛教起恶惑业。故无惭愧忍辱之衣。宁餐法喜禅悦之味。故饥寒也。六聋乐悦彼喻。喻不解自说失。谓夫真说。闻者必忘说闻。逐语而说为自不闻。七盲画示彼喻。喻不见自义失。八船师溺海喻。谓将导众人游佛法海。倚自所解不慎身行。为法所沦。九巧言无德喻。谓亦说修行或谈己德。内无实德但有虚言。独此一偈三句是喻。合文但云不行亦如是。弥显不毁多闻。又此九偈亦可别对随贪等义如理应思。第八助道甚深。问智首者。以显智为正道之体统其助故。二正显问端中三。初举法按定。谓断惑证理导行得果。唯是大智彼此同许。二如来下正设疑难。谓既智为上首。应唯赞智那亦赞余。此是正助相违难。三而终下结成前义。前难云。智为上首已应不合赞余。况非以一法成佛。固当不合偏赞。为要假多。为唯用智。为随一行皆得佛耶。若随一得成亦违智为上首。进退皆妨。下答意中印其初后。释其中间。谓智为上首诚如所言。智如明王为众之御。故大品云。般若如目五度如盲故。印后义云。终无唯以一法。实如来叹三世诸佛皆具说故。以余万行资于智故。释其中间。别赞乃有多意。谓随心令喜故。随时生善故。所治蔽殊故。八门不同故。众生不能尽受故。下当属文。又智论云。般若必具一切行。是故赞一即是赞余。赞余即是赞智。十颂分二。初一叹问许说。余九正答所难。略分为二。先二颂开二章门。后七双释二章。今初。初偈标众行成果章。谓正助相假必万行齐修故。诸佛同说。言无有说一者必具说也。后偈标随机别赞章。文具禅经四随。谓初句即随乐也。将护彼意称悦其心。故性不同者。即随宜也。附先世习令易受行。习以成性故分不同者。即随治也。观病轻重设药多少。谓贪分多者教不净等。随其所应度者。即随义也。道机时熟闻即悟故。下别释中二。初三释随器别赞章。后四释众行成果章。前中二。初两偈半别释随治。后两句结前生后。今初。然六度成其行四等旷其心。四等多约利他。六度多明自利。六度如初会四等如下说。然并通四随略举一治耳。涅槃云。悭者之前不得赞布施者。即随乐意也。二结前生后中。上句结前下句生后。后四偈释众行成果中。各上半喻下半合。然有二意。一仍前渐具之义便得释成智为上首。二正明所用不同。故须兼具。然摄论第九明立六度。通有三意。一为除惑故。二为生起佛法故。三为成熟众生故。前段具初意。此段通具三。谓二二合者对治别故。先基后室等即渐具故。皆为利他即成熟故。文中初偈二度。为治不发行因故。合云行本。谓着财不发施。着家不发戒故。基堵有二义。一基即是堵。即施为进善之首。戒为防恶之初。并称基也。二堵为环墙。即檀为万行首基也。戒防未起非堵也。宫室者解脱也。次偈二度。已发修行心。为治退弱心因故。谓不能忍生死苦事。长时修助善品有疲怠故。今忍城防外恼之敌。进郭长内行之众。通说则此二皆能防外养内。次偈二度治坏失心因故。谓散乱坏静虑邪智坏正解故。今明菩萨定静惑乱慧鉴万法。动寂自在故。菩萨依之以发通慧。赖之以证理果。其由有力之王。澄清四海明鉴万机。故率土戴恩天下仰则。后一偈四等为因。自他安乐招果无尽故。第九一道甚深。亦名一乘。问中标问贤首者。至道柔顺故。又贤犹直善。佛佛皆同一直道故。二显问端中三。初标宗按定。谓佛佛所乘同观心性。万行齐修自始至终。更无异径故云一道。此理共许。二云何下正设疑难。先总后别。前中谓因道既一果应不别。云何现见佛刹等殊。为果异故因非一耶。为因一故无异果耶。若双存者即因果相违。下别辨十事。一界有染净等殊。二居人善恶等异。三诸乘等别广略等殊。四或三学调伏。或强软折伏。五寿有修短。六光明或色相不同。或常放具阙。或照有远近。七随染净土居人异故。现通亦殊。八众会异者。此有三种。一多少。二会数。三凡圣大小。九教仪者。如此土以音声为教。香积以众香教化等。十法住者有久近故。各有差别者通上十位。然若。约一佛。十事各不同者。德首已明。今问诸佛十事互望不同耳。第三无有下结成前难。谓若诸佛于因行法有具不具。可有刹等不同。今皆同具。刹等那别。同具即是一道。第二答中意云。非唯因同果德亦同。而见异者。随机感耳。非佛自位而有差别。何者。诸佛因果具同异故。谓同满行海是同因也。将此同因随所调伏种种回向应机之果是异因也。由此异因感差别果。由上同因。同感真应身土等果。是则约佛即同能随异。约机同处而见异。以生就佛虽异而常同。以佛就生虽同而见异。以佛望佛。能异之必同。其犹锦窠常同常异。瑜伽三十八。诸佛平等唯除四法。一寿量。二名号。三族姓。四身相。意明随机故除此四事。余皆等也。就果同中。自性身土一向体同。自受用者平等无二。相似名同。余二身土亦相似名同。而随机见异故。成唯识云。自性身土。一切如来同所证故。体无差别。自受用身及所依土。虽一切佛各变不同。而皆无边不相障碍。余二身土。随诸如来所化有情。有共不共。所化共者同处同时。诸佛各变为身为土。形状相似不相障碍。展转相杂为增上缘。令所化生自识变现。谓于一土有一佛身。为现神通说法饶益。于不共者唯一佛变。诸有情类属佛异故。偈中义理多含故。文势非一。且分为二。初二偈印其立宗。明真身无二。余偈答其疑难辨应有异同。今初。初句总印。先标文殊者。警其听受。法常尔者。明因果无异法尔常规。余显一相略明四一。初句法一。以法常故。诸佛亦常。次句人一。次句因一。后偈果一。略举其五。一者身一。此有二义。谓若约所证。法界为身则体同为一。若兼能证无挂碍智为身。即相似名一。下既别明心智。则正当初意。然体同义异。二心一。八识心王俱不可知故。三智慧一。四智三智二智一智。皆无别故。四十力一。五无畏一。此五亦略摄诸德。二答疑难中分二。初二偈总明随机见异。于中前偈约佛。后偈约机。前中即随本异因。为物回向各得差别。故云如是。如是即差别之义也。异举十中三事耳。即随所化众生而取佛土。后偈约机者。约佛则刹等皆圆。约机随行见别。如直心为行则见不谄之国。故众生之类。是菩萨佛土。余六偈展转释疑分四。初一偈有疑云。若皆圆满何以不见。答意云。众生不见岂得云无。然有三义。一约他受用。则地前凡小众生不见。二约自受用。则等觉众生亦皆不见。若约即应同真。权教菩萨不见。次偈有疑云。若皆不见何以知。有释云。有见者故亦有三义。初则净意乐地已去。由愿自在力故。见他受用。二净无尘习。普贤愿满方见自受用。三圆解之人则名心净。即应见真。意在初后义兼中间。三有一偈疑云。若应由物见何名佛土。释云。佛威神故。则知生佛共成。既揽同成异亦称体成益。四有三偈。释疑云。上云众生不见净刹。又云佛神力令异。为刹体处别佛有分别耶。故释云。刹实同处佛亦无心。物自见异耳。于中初半显实。云刹无分别。佛无憎爱。分别即差别义。故晋经云。佛刹无异相。如来无憎爱。若顺今经。亦可此二通佛及刹。次半偈明异自在物。次半偈明正见刹异。次半偈彰非佛咎。次三句释佛无憎爱。有感便现非佛有爱。无感不见非佛有憎。末后一句总结。一切诸佛法皆如是。随机隐显真体常存。亦通结一段。第十佛境界甚深。十信观圆便造佛境。于中亦先问后答。问中分二。初标能所问人。大众同问者。摄别归总故。总别无碍六相圆融。问文殊者。佛境甚深。除般若妙德无能达故。始信终智皆托佛境。故无按定结难者。表尊敬故。若人若法难致诘故。二佛子我等下。正申请问。又分为二。初结前标后。加赞妙辩者。敬上首故。二何等下别显问端。句有十一。初总余别。初境界有二。一分齐境界。谓从十地因。后果位之法是佛所有。二所缘境界。谓佛所知之境。并非余测。总为佛境。二谓问佛境以何为因。三请佛境度生仪式。四应机普入世间。五能知之智。六所知之法。七圆音起说。八明知体相。九内证平等。十显现何法。十一量之大小。并非因位作用所及。亦非下位能知。故云佛境。若约能知能度等。即是分齐。约所知等名曰所缘。能所双融异即非异言思道断。是佛境也。答中十颂次第而答唯广一。义独在于初。与总合辨。欲显分量遍于总故。即深而广故。初句总标体深。次句分量广大故。佛地论引经释云。诸佛境界唯除虚空。无能为喻。次句释上广。后句释上深。然有三义。一约一切众生即如来藏。更何所入。翻迷之悟。故云证入。二约理非即非异。故云入无所入三约心境。心冥真境故说为入。若有所入境智未亡。岂得称入。实无所入方名真入。即广之深本起言念。即深之广安测其涯。二答因问。谓此因无限略示三义。一殊胜。以行超绝无等等故。二微妙。以证理深玄尽法源故。三广大。以多劫说少亦不尽故。三答度问。谓随其心器意乐不同。随其智力解悟差别。诱引进修令各获益。以遍法界委悉无谬。差别难知故云佛境。四答入问。谓世间即是众生世间。国土即器世间。一切者遍法界故。入有二义。一以智身潜入蜜益众生故。二以色身现入显益众生。智身难知文中偏显。五答智问。上半权智。横无不知故云自在。竖达三际故无所碍。下半实智故。云慧境平等如空无若干也。虚空之言。亦兼喻上无挂碍也。权实无碍方为佛境。六答法问。法界是理生界是事。揽理成事理彻事表。故云无别。是故事则不待坏而恒真。理则不待隐而恒俗。非直广大无限。亦乃甚深无际究尽了知。故称佛境。又法界是所证。生界是所化。了知是能证能化。究寻其本亦无差别。是难知之佛境也。七答说问。一切言音随性随相。皆悉了知未曾起念。故无分别。以一切差别言音即是如来法轮声摄故。以斯答说。音声实相即法轮故。八知即心体了别即非真知。故非识所识。瞥起亦非真知。故非心境界。心体离念即非有念可无。故云性本清净。众生等有或翳不知。故佛开示皆令悟入。即体之用。故问之以知。即用之体。故答以性净。知之一字众妙之门。若能虚己而会便契佛境。九答证问。即证大涅槃三德圆也。非业系故解脱也。非烦恼者转烦恼即菩提是般若也。无物者虚相尽故。法身显也。无住处者。成上法身无所在也。无照者。成上般若能证相寂也。无所行者。成上解脱无业行之用也。由无用故用弥法界。由无照故无所不知。由无在故无所不在。故结句云。平等行世间也。是谓三德秘藏佛之境也。十答现问。上半所现。初句横尽十方。次句竖穷三际。下半能现。并于如来圆镜智中。无念顿现。故出现品云。菩提普现诸心行。即斯义也。上来辨十甚深。即问答竟。自下第二现事结通。于中二。先现事后结通。今初。因何而现上来十首。法光开晓众生身心故。佛力暂现示相而答。令其目验而欣厌故。所现有十。第一法即所行之法。谓三学等殊。二业谓正行漏无漏等。三集因苦果。四身类不同。五根机差别。六四生非一。七持戒则人天胜劣。八犯戒则三涂重轻。九国土则依处染净。十说法则近报净居。聪明利智速具佛法。此经文阙。晋本具之。又此亦可配十甚深。以是示相答故。一法首正教甚深。二宝首业果。三勤首懈怠难出。四财首观内身等。五德首佛法一味随根异说等。六觉首往善恶趣。七智首六度顺行。通为持戒之果。八目首佛田平等。但犯戒布施得果差别。九贤首随心世界有差别等。十晋经既有说法。即是说佛境界法也。第二如是下。结通广遍。于中二。初结东方。后南西下类余九方。亦现十事。以此处说法则现事通于十方。余处说法亦应类此。总为一法界大会。思之。问明品辨信中解竟

    净行品第十一(入第十四经)

释此一品五门分别。初来意者。夫欲阶妙位必资胜行。有解无行虚费多闻。故前品明解此品辨行。又前明入理观行。今辨随事所行。又前行此愿并义次第。故次来也。次释名者。梵云具折啰。此云所行。波利此云皆也遍也。戍轮律提云清净也。谓三业随事缘历名为所行巧愿防非离过成德。名为清净。又悲智双运名为所行。行越凡小故称清净。以二乘无漏。不能兼利非真净故。得斯意者。举足下足尽文殊心。见闻觉知皆普贤行。文殊心故。心无浊乱。是曰清净。普贤行故。是佛往修诸佛菩萨同所行也。所行即净。持业释也。三宗趣者。以随事巧愿防心不散。增长菩萨悲智大行为宗。成就普贤实德为趣。四解妨者。问文中但辨一百余愿。何有行耶。答文中辨行略有数重。谓就所历事中。始自出家终于卧觉。皆事行也。知家性空理行也。触境不迷善达事理智行也。以愿导智不滞自利大悲行也。上二不二悲智无碍行也。遇违顺境心不驰散止行也。智不沉没观行也。即止观双运行也。又对于事境善了邪正。当愿众生。皆假观也。知身空寂心无染着空观也。见如实理中观也。或先空后中。或先假后空。或一或二或一念顿具。斯为妙达三谛观之行也。又所造成行皆施众生。不起二乘之心。安忍强软两境唯增善品。心不异缘妙达性空。善巧回转。皆愿利物同趣菩提。二乘天魔所不能动。善知药病决断无差。即十度齐修之行也。又皆愿利生皆成佛德。见恶必令其断见善必令其具。即四弘誓愿之行也。故智首总标诸德。以求其因。文殊令善用心顿获众果。但言惟愿岂不感哉。复有问言。夫妙行者。统唯无念。今见善见恶愿离愿成。疲役身心岂当为道。答若斯见者。离念求于无念。尚未得于真无念也。况念无念之无碍耶。又无念但是行之一也。岂成一念顿圆如上所明也。行学之者愿善留心。第五释文中二。先智首问举德征因。后文殊答标德显因。今初。亦先标问答之人。后陈所疑之问。今初。此二菩萨为问答者。历事巧愿必智为导。故事近旨远。唯妙德故。文殊则般若观空。智首则沤和涉事。涉事不迷于理。故虽愿而无取。观空不遗于事。故虽寂而不证。是为权实双游假兹问答。二陈所问中。有二十云何。总十一段。段各十句。成一百一十种德。第一段明三业离过成德。二得堪传法器。三成就众慧。四具道因缘。五于法善巧。六修涅槃因。七满菩萨行。八得十力智。九十王敬护。十能为饶益。十一超胜尊贵。此十一中。若就相显。二四与六此三唯因。八及十一此二唯果。余通因果。或摄为四对因果。初二十句问福因福果。先因后果。次二十句问慧因慧果。先果后因。三二十句问巧解因观行果。四有五段。问众行因成德果。初一为因余四为果。或分为二。初十云何。问净行体。是问因义。后十云何。问行所成。是问果义。以善修七觉等。亦是净行之能。故皆言云何得者。为修何行而得之耶。初十望后故说为因。望历缘巧愿成净行体。即是于果未是圆果而是分果故。上总云举果征因。今分为二。初之一段总问其果。后十别明。今初。十句得此十种三业。成下十果。由无过三业故超胜尊贵。由不恚害故常为饶益。由无余惑不可讥毁。故十王敬护。由恶缘不可坏得佛十力。由修行不退转。满菩萨行。由远离诸相如如不动。成涅槃因。由德行殊胜故于法善巧。由体清净如虚空。故成具道缘。由涉境无染故德堪传法器。由智先导故成就众慧。又由后十能成就此十。以十三业永无失等唯佛不共。分分无失。一通于因。又此十句初一总显无过。次八别显无过。后一总出其因。若以智慧为先导。身语意业常无失故。又于中八。前二离过后六成德。又后九中。不随于嗔故不害。不随于慢故不可毁。不随恶见故不坏败。不随于疑故不退动。恒修胜行不随于贪。故清净无染。不随于痴故智为先导。所作称真。如是等业云何而得。后十段别明中。初一异熟果。次四士用果。次二离系果。次一增上果。后二等流果。今初。即修道之器。以菩萨起修行时要具此十。方成二利之行。瑜伽具释。一常生中国有佛法处。二种族尊贵非下贱等。三生信向三宝修善之家。非外道等家。四形色端严非丑陋等。五具丈夫相诸根不缺。六正念不忘。亦宿念现前。七慧悟高明善解世法。八柔和调善离过修行。九志力坚强故无怯弱。十性自开觉不染世法。又无畏者。依智度论。菩萨有四种无畏。一总持无畏。于法记持不惧忘失。二知根无畏。知根受法不惧差失。三决疑无畏。随问能答不惧不堪。四答难无畏。有难皆通不惧疑滞。今并皆得故云具足。又此十事。若约法者。生在佛家是生处具足等。思之。又具足者。唯佛一人云云。第二十慧下四段。明士用果中。一慧为拣择。二力谓修习。三善巧谓智。四道品助修悉以三业而得成就。今初。言慧者。即道之体。十中一胜世间故。二过二乘故。三拣权教故。四佛果超因故。上四拣劣余六当体。一无分量。二无若干。三超言念。四无等匹。五难比校。六唯证相应。欲言其有无相无形。欲言其无圣以之灵。欲言俱者慧无二体。欲言双非非无诠显。故不可说。第三力者。即具道因缘。皆言力者。此十各有资道之能故。一因力者。即是种性。谓已有习种无倒闻熏与性种合。故名为因。梁摄论云。多闻熏习与阿赖耶识中解性和合。一切圣人以此为因。无性摄论云。此闻熏习。虽是有漏而是出世心种子性。二欲力者。有胜欲乐希大菩提。及起行故。三方便者。谓造修力。依六方便成悲智故。一慈悲顾恋。二了知诸行。三欣佛妙智。四不舍生死。五轮回不染。六炽然精进。摄论广说。四缘力。谓善友劝发。五所缘力。即所观察悲智之境。六根谓信等。七观察者。谓于自他事理药病善拣择故。八奢摩他。此云止也。九毗钵舍那。此云观也。瑜伽起信等论。深密涅槃等经。广辨其相。具如别章。今略显其相。以为十门。一心行称理摄散名止。二止不滞寂不碍观事。三由理事交彻而必俱。遂使止观无碍而双运。四理事形夺而俱尽故。止观两亡而绝寄。五绝理事无碍之境。与泯止观。无碍之心二而不二。故不碍心境而一味。不二而二故。不坏一味而心境。六由即理之事收一切法故。即止之观亦见一切。七由此事即是彼事。故令止观见此心即是彼心。八由前中。六则一多相入而非一。七则一多相是而非异。此二不二同一法界。止观无二之智顿见即八二门同一法界。而无散动。九由事则重重无尽止观。亦普眼齐照。十即此普门之智为主故。顿照普门法界时。必摄一切为伴无尽无尽。是此华严所求止观。十思惟者。筹量应作不应作故。第四于法善巧。皆约流转以明前四流转之体。三界流转之处。三世流转之时。三科之义略如前释。广如别章。缘起六地广明。三界三世如前后释。皆言善巧者。一善知彼法空无所有。二善知不坏假名分别法。相加能摄无尽弥善巧也。第五修涅槃因。七觉三空十地品广说。第六满菩萨行。此下二种明离系果。初六度四等修。即士用。满即离系。治诸蔽故及第七具足十力。并见上文。第八十王敬护是增上果。第九云何得与一切众生为依下二段明等流果。由本愿力为依救等。由本行力为第一等。今初能为饶益。依等十句。如回向初。第十为第一下。超胜尊贵。十地论释。今就佛果略释其相。谓如来功德海满更无所少。故称第一。此亦总句。大者体包法界故。胜者自利圆满故。最胜者利他究竟故。妙者烦恼障尽故。极妙者所知障尽故。上者。望下无及故。无上者望上更无故。无等者望下无俦故。无等等者。望俦皆是无等者故。所以广举诸德者。欲显行之胜故。上来问竟。第二文殊答中。文分为二。第一叹问成益。饶益者利益也。安隐者安乐也。利乐者即上二也。佛地论第七有五重释。利乐之义已见光明觉品。第二佛子下。正酬其问。于中二。先标因成德酬其举德。后指事显因酬其征因。今初。先标其因。谓善用其心。心觉神明之奥心。正则万德攸归。言善用者。即后历缘巧愿触境入玄如上所辨。则获下显所成德。初总后别总谓一切胜妙功德。皆因用心一百一十门。德何足难就。可谓一言蔽诸。胜谓独尊。妙谓离相又德无不备云胜。障无不尽名妙。此之总句。亦即酬上十种三业之总句也。余九别显。句虽有九义亦有十。如次酬上十段之德。一于诸佛法心无所碍者。即初第一堪传法器德。念慧觉悟皆具足故。二住去来今诸佛之道。即上成就众慧。三世诸佛唯以佛慧为所乘故。三随众生住恒不舍离。即上具道因缘。成就种性欲乐方便。常以众生为所缘故。四如诸法相。悉能通达。即十善巧义无惑也。五断一切恶。即七觉三空拣择弃恶。无越此故。六具足众善。即六度四等。七当如普贤色像第一。由此故得十王敬护。八一切行愿。皆得具足。即是前文成就十力。得佛果位方具足故。故晋经无此一句。而有成就如来一切种智。斯为十种智力定无惑也。唯此一段望前不次以内具种智外具色相。此二同在果圆前后无在。或译者不回。九于一切法无不自在故。能与物为依为救为炬为明。十而为众生第二导师。即是上文于众超胜。上求第一唯佛一人。今才发心则道亚至尊。故云第二。然旧经中。亦云而为众生第一尊导。故知第二译者意也。第二佛子云何下。指事显因于中三。初总征次别显。后总结成益。二别显中五门分别。一总明大意文中。总有一百四十一愿。菩萨大愿深广如海。应如回向非止尔也。此盖示于体式余皆仿此。又非无表。一百者。十信圆融一一具十也。四十一者。即四十一位也。明此诸位所有惑障。由此能净所有胜行。由此能行故。二通显文旨。然此诸愿句虽有四事但有三义开为六。言三事者。谓初句愿所依事。次句愿所为境。后二句是愿境成益。开为六者。初事有二。一者内。谓菩萨自身根识等。经云菩萨等故。二者外。谓他身或依正资具等。经云在家等故。次事亦二种。一能发愿者。二所愿众生。经云当愿众生故。后事亦二。一者自益由此诸愿成前诸德故二者益他。由此发愿愿众生故。此后二句。或前句是因后句是果。如云所行无逆成一切智等。或二俱是因。如云巧事师长习行善法等。或二俱佛果。如云永离烦恼究竟寂灭等。或俱通因果。如云以法自娱了妓非实等。或三四二句共成一句。如云演说种种无乖诤法等。亦可后。二句中初句所入法。如云知家性空等。后句所成益免逼迫等以不必具故合为一。三别开义类。然上三事中愿所依事。虽有多类。不出善恶依正内外。随义准之。二愿所为境。其一一愿尽该法界。一切有情不同权小谈有藏无故。又愿即是行。成回向故。一一皆成所行清净善业行故。如云知家性空。则菩萨之心必诣空矣。三愿所为境。成利益中。由愿于他成种种德。自获如前所说功德。然有二义。一通二别。通则随一一愿成上诸德。斯为正意。二别显者。如愿于他得坚固身心无所屈。则自必成十种三业离过成德之德也。二愿于他具足成满一切善法。则自成就堪传法器。三愿于他深入经藏智慧如海。则自成众慧。四愿于他具诸方便得最胜法。则自成就具道因缘。五愿于他语业满足巧能演说。则自成就十善巧德。六愿于他得善意欲洗除惑垢则自成七觉三空。七愿于他所作皆办具诸佛法。则自成满菩萨行德。八愿于他舍众聚法成一切智。则自成就如来十种智力。九愿于他皆如普贤端正严好。则自成就十王敬护。十愿于他统理大众一切无碍。则自成饶益为依救德。十一愿他得第一位入不动法。则自成就超胜第一德。以斯十一配上答中总别十一段。文并可知。通别交络应成四句。谓一切愿成一德。一切愿成一切德等。以因愿一多相即故。成德亦一多镕融。四对辨成例。谓若以初后二事相对辨例。略有十例一会事同理例。如菩萨在家事也。性空理也。二处染翻染例。如若得五欲染也。拔除欲箭翻染也。三相似类同例。如若有所施令一切能舍等。四世同出世例如上升楼阁愿升正法楼等。五以因同果例。如正出家时愿同佛出家等。六舍伪归真例。如着璎珞愿到真实处等。七以人同法例。如见病人愿离乖诤等。八以境成行例。如见涌泉愿善根无尽等。九以妄归真例。如见婆罗门愿离恶等。十以近同远例。如受和尚教愿到无依处等。五正释经文。长分为十。初有十一愿。明在家时愿。二有十五愿。出家受戒时愿。三有七愿。就坐禅观时愿。四有六愿。明将行披挂时愿。五有七愿。澡漱盥洗时愿。六有五十五愿。明乞食道行时愿。七有二十二愿。明到城乞食时愿。八有五愿。明还归洗浴时愿。九有十愿。明习诵旋礼时愿。十有三愿。明寤寐安息时愿。今初。在家有十一愿。初一总举在家。以家是贪爱击缚所故。若了性空。则虽处居家家不能迫。次一在家行孝愿。以是至德行本故。首而明之。大集经云。世若无佛善事父母。事父母者即是事佛。父母于我为先觉故。今翻令事佛者。生长法身故。护养一切者。一切众生皆我子故护之。一切男女皆我父母故养之。生生无不从之受身故。平等敬之法身佛故。次四受家室等愿。然五欲射心犹如箭中。王侯有宫余皆名室。次五在家所作事业等愿。在颈曰璎。在身曰珞。珞以持衣。璎以系冠。一切悉舍亦舍心也。了聚无性成佛智也。第二舍居家下。出家受戒时有十五愿。初一正舍俗家。次三出家方便。僧伽蓝者。此云众园。众有六和法则事理一味。故无诤也。大师谓佛。众所宗故。小谓和尚。亲所教故。若约末世三师为大。七证为小。靡不有初鲜克有终。故希不退。次四正落[髟/柔]出家。袈裟者不正色衣也。亦云染色。表心染于法要。无所染方曰染也。然二乘之染亦非真染。必心染大乘故。云具大仙道为于正法除其结使。方为究竟寂灭。落[髟/柔]披衣之后为正出家。余七受学戒时。初三自归。佛在之日则五受之一。佛灭之后受五八戒。必依三归。归要三者。翻彼外道邪师邪教及邪众故。犹如良医良药及看病人。烦恼病愈故。为与众生为缘念故。三宝之义至下当释。受学戒者即十戒也。亦通五戒。优婆塞戒经云。欲受菩萨戒先应遍受五戒十戒二百五十戒。若尼则受六事及五百戒。受谓受戒。学即随戒。愿中即止作二持。阇梨者此云正行。轨范教授故云具足威仪。和尚此云亲教。亦云力生。道力自彼生故。故翻云入无生智。依之得戒故翻无依。具足戒言义含二种。一则大比丘戒。二则菩萨戒。亦制意地方为具足。第三若入堂下七愿。明就坐禅观时愿。初四为修方便。次二正修止观。后一修行事讫。第四下足住时下。明将行披挂时六愿。下衣盖丑故愿得惭愧。上衣即衫袄之辈。前已辨袈裟故。此直云僧伽梨。僧伽梨者义云和合。新者二种。故者四种。要以重成故云和合。即是三衣中第一衣故。第五手执杨枝下。澡漱盥洗时有七愿。杨枝五利是曰妙法。去秽为净。西域皆朝中嚼杨枝。净秽不相杂。此为常规。凡欲习谓别须用之。盥者澡也。第六手执锡杖下。乞食道行时。总有五十五愿。更分为三。初十二愿游涉道路。次见众会下十九愿。所睹事境。后见严饰下二十四愿。所遇人物。今初。锡者轻也明也。执此杖者轻烦恼故。明佛法故。更有多义具如经辨。今略明二用。一执为行道之仪。二振以乞食故。发相似之愿。无依之道是真道也。向无余法真涅槃也。真净法界心所履也险道有二。一多贼鬼毒兽。二陜径阻绝。初惑业罪苦。凡夫之险道也。后自调滞寂二乘之险道也。皆为难处。不断生死而入涅槃正法界也。二睹事境愿。初睹众会。谓众聚多谈无义故。愿说深法众心易乖故令和合。二大柱者。旧经云大树。梵云萨担婆。(去声轻呼)此云树也。萨担婆(入声重呼)此云柱也。由兹二物呼声相滥。古今译殊。柱有荷重之能。一舍由之而立翻。此愿离我能之诤。忿恨何由而生。三德犹丛林森耸可敬。十一陂泽者。畜水曰陂。不集诸流故愿一味。十二说文曰。穿地通水曰池。沼即池也。取其盈满引法流故。亦可巧思穿凿能有说故。十三汲者取也。辩才演法犹绠汲水。无忧林者处之忘忧故。三见严饰下二十四愿。所遇人物。六云获根本智灭众苦者。若得见道无分别根本智。则断恶道业无明故。三涂苦灭。则三苦八苦亦皆随灭。死及取蕴。直至金刚后根本智。则能永断七愿入真实慧永无病恼者。此有二种。一约入真见道之慧断身病之苦恼及烦恼病。谓一切恶趣诸烦恼品。所有粗重是分别起。亦为身病远因。至欢喜地真见道中。一刹那断。顿证三界四谛真如。身病及惑永不复有。二约金刚心慧顿断一切诸烦恼病及习气随眠。证极圆满真实胜义。诸惑永亡。依上解者。真实慧者即根本智。但约所灭惑苦不同耳。八四大乖违成病。知空则永无所乖。于佛菩萨能知恩德者。诸佛菩萨。始自发心普缘众生。难行苦行不顾自身。垂形六道随逐众生。见其造恶如割支体。迄成正觉隐其胜德。以贫所乐法诱摄拯救。见其憍恣示迹涅槃。留余福教以济危苦。故自顶至足从生至死。皆佛之荫。斯之恩德何可报耶。得人小恩常怀大报。不知恩者。多遭横死。故经云。假使顶戴经尘劫。身为床座遍三千。若不传法利众生。毕竟无能申报者。故唯自利利人如说修行。为报佛恩耳。沙门此云止息。毕竟止息唯大涅槃。世之甲胄随于师旋。进忍甲胄趣于无师。能离五邪方为正命。谓一诈现奇特。二自说功德。三占相吉凶。四高声现威令他敬畏五为他说法行此五事若为利养皆邪命也。第三句通愿离五。第四句但离初一。明断方称长者。守王正法始曰大臣。第七若见城郭下。二十二愿。到城乞食时愿。初三总处王都。则贤达辐辏。林薮则众德攸归。次三入家未入则诸家差别。入已唯一无多。如入佛乘无二三也。次八乞食得不。得愿次七得食正食后一食讫说法。亦为报施主之恩故。其中云藏护诸根者。瑜伽名善守根门。净名云。所见色与盲等。乃至云知诸法如幻相是也。第八从舍出下。还归洗浴时节炎凉。五愿可知。第九讽诵下。习诵旋礼时有十愿。右者顺义故。普耀经第二亦云。菩萨降神趣右胁者。所行无逆故。佛功德者。谓如来十力等。第十若洗足下。寤寐安息时三愿。一切智觉者。非唯三世齐明。抑亦十方洞晓。一日始终既尔。余时类然。第三若诸菩萨下。结叹因所成益。若能如上为善用心。若此用心则内德齐圆。外不能动心游大智故。人天不能动。心冠大悲故。二乘不能动不动有二。一修行时。此等不能惑乱故。二不希彼故

大方广佛华严经疏卷第十五大方广佛华严经疏卷第十六

        唐清凉山大华严寺沙门澄观撰

    贤首品第十二

初来意者。夫行不虚设必有其德。既解行圆妙必胜德难思。收前行愿成信德用。故次来也。又前智首举果征因。文殊广显其因。略标其果。云获一切胜妙功德。故问贤首令广斯言。是以偈初蹑前起后。二释名者。谓体性至顺调善曰贤。吉祥胜德超绝名首。即以此名菩萨演说此法。贤即是首。贤首之品。以当贤位之初摄诸德。故偏举贤名。三宗趣者。于信门中成普贤行德。而自在庄严。无方大用建立众生。通贯始终该摄诸位。以为其宗。令起圆融信行成位德用。而为意趣。四释文者文有三分。初文殊发起。次贤首广说。三十方现证。今初分二。初经家叙述。二正明发起。二段各有结前生后。今初。先结前已说。顺违皆顺客尘不能浊其心。悲智双游万境不能乱其虑。是曰清净行矣。大功德者。即前所成之果。后欲显示下生后。文含始终。约终则显示信满菩提心殊胜功德。广具五位因行尽故。约始但于生死誓证菩提。万德攸依故。今显。示二偈。正发起中前半结前。偈文窄故略无所成之德。后半劝说。令说修行之德。则与长行文有影略。第二时贤首下。贤首广说。于中先总标举。以偈答者此略有二。一少言摄多义故。二美词赞说令净信故。以始德该终散说难尽故。显此胜妙之功德故。第二正显偈词。有三百五十九颂半。大为三分。初四颂谦赞许说分。次三百四十六偈半。正说胜德分。三九偈校量劝持分。初中分二。初偈总明。前半赞问劝修。后半谦己少说。海喻次下当明。后三开章以发心之德。况出修行巧显深广。于中初偈举发心章。次偈况出修行章。初心祈于当证德已叵量。况长时入位遍修故。多佛不能尽说。后偈许说分齐。前半法说。如是者双指发心修行。下文具显故前文双问故。后半喻明。然有二意。一显喻少分。谓发心行德如太空大地。所说者陜如足履一尘。二密喻不异。谓鸟足之空不异太空。微细之尘不殊大地。故此略说义无不周。若广若略皆无边故。出现品云。如鸟飞虚空经于百年。已经过处未经过处。皆不可量。何以故。虚空无边际故等。彼就果行。此就因德。然普贤行德似同佛果。是故皆以虚空为量。上下文中皆同此说。此初发心。与下文十住初发心住。及发心功德品。各何别耶。此中发心该于初后。取其成德乃是信终。取其为本乃在初发。虽如轻毛功归初篑故。十住初发。即是此终成彼初发。此终为能发彼是所发。此正是发起之发。义兼开发彼是开发之发。义兼发起。其发心品。正显十住初心之功德耳。以斯甄别非无有异。故璎珞云。发心住者。是人始从具缚未识三宝。乃至值佛菩萨教。法中起一念信。便发菩提心。既云始从凡夫最初发心。明知此中发心该于初后。问此既是初。何得乃具后诸行位及普贤德耶。古德释此略有二门。一行布次第门。谓从微至着从浅至深。次第相乘以阶彼岸。如璎珞仁王起信瑜伽等说。二圆融通摄门。谓一位即具一切位等。如此经所说亦如大品等中。一行具一切行。此中有二门。一缘起相由门。二法界融摄门。前中普揽一切始终诸位。无边行海同一缘起。为普贤行德。良以诸缘相望略有二义。一约用。由相待故。有有力无力义。是故得相收及相入也。二约体。由相作故。有有体无体义。是故得相即及相入是也。此经之中依斯义故。行位相收总有四说。一或始具终。如此门中。具一切行位。普贤德海者是也。二或终具始。并在十地位。后如下文十定十通等说。三或诸位齐收并在十住等。一一位中各收一切。悉至究竟。如下文十住十行等说。四或诸位皆泯行德显然。如离世间品说。二法界融摄门者。谓此诸位及所修行。皆不离普贤无尽法界。然此法界圆融无限。随在一位即具一切。今在信门收无不尽。下诸位中皆具一切者。并准此释。问下发心功德品。亦说初心具无边德。与此何别。答此据行首信门所具。彼约行本菩提心具。问约法相收是则可尔。约人修行。岂十千劫修信才满。即得如此无边德海。答以法是圆融具德法故。若诸菩萨行此法行。是彼所收。或无量劫或无定限。十千劫言非此所说。如下善财童子。及兜率天子等所行所得。并是其人不同。行布次第教中之所说也。又十千劫。乃是一经。璎珞但言一劫二劫。此经纵有行布亦皆圆融。亦有引此下文证成。此信乃是舍异生性。成就圣性出无明地。生如来家。以有则获灌顶而升位等。非是信故。若尔初地岂得灌顶升位等耶。若云展转进入佛地。何以不得始自于信展转入耶。若许从信展转入者。何以要判此乃舍凡入圣。下文自有十地之会。此中尚隔住行向等。判为入地。乃孟浪之谈。下发心品。亦判为初地发心义。同此会。问下云无量亿劫勤修学。得是无上菩提智。斯则非一生也。亦非十千以为无量。通斯难者应有二义。一此约行布展转义故。二约圆融展促无碍义故。如上所辨故。善财见仙人。执手一一佛所。经无量劫故。修短难思特由于此故。贤首菩萨云。信大乘者犹为易。能信此法倍更难。以初心即具一切功德。故难信也。第二菩萨发意下。正明发心修行胜德。文分为五。初五颂发心行相。二信为道元下略示胜能。三若常信奉下。所具行位。四或有刹土下无方大用。五一切如来下。喻况玄旨。然此五段。初一显正发心。后四发心之德。第三亦兼修行。此及后二皆修行之德。今初发心行相中。初偈总标余文别显瑜伽菩萨地。明发心有五种相。一自性。二行相。三所缘。四功德。五最胜。今文五偈具之。谓发意。即是正愿为发心自性也。希求菩提及下作有情义利。即行相也。菩提三宝有情皆其所缘。能摄一切菩提分法。为其功德。不求五欲等。反显菩萨所求最胜。言因缘者。谓亲能发起求大菩提曰因。假之助发为缘。因即自性住性内熏之力。缘即习所成性。又上二皆因善友及境外熏为缘。瑜伽云。由有四因四缘四力。菩萨发心。四因者。一种性具足。二赖佛菩萨善友摄受。三多起悲心。四长时猛利难行苦行。无所怯畏。四缘者。一见闻佛神变威力。二闻法微妙。三见法欲灭。四见生受惑业苦。四力者。一自力。二他力。三因力。以宿习故。四加行力。谓于现法亲善闻法修善加行故。若具上因缘及初三二力。当知不退。若因二四力心不坚固。今经即初及三也。又起信论智印经。有七因缘如彼应知。下别显中。以三因四缘摄上诸义。三因者。谓信悲智。四缘者。三宝众生也。今文中。后半总以信智因缘三宝境。信谓于实德能深忍乐欲心净为性。故云净信。然实谓一切事理。德谓三宝净德。能谓世出世善有其力能。今法宝中已摄初后。亦三宝中。皆具此三。体实具德。大用救生故。大者智心求大菩提。广者悲心广济含识。翻彼二乘小陜心也。别中初半偈拣去偏伪。谓摄眷属过。所不能染故。文中不求五事求即过故。一若求人天五欲。此能长贪多是鬼因。二求王位长嗔多地狱因。三求富饶长痴是畜生因。实通三涂各从多说。四求自乐是二乘因。五求大名称若胜负心。是修罗因。若我慢心是外道因。又以理求乐是人天因。为王摄属是魔罗因。有二乘心目之为偏。有余心者名之为伪。后三偈半直显真正别释因缘。于中初偈悲因。下救严土供佛。亦为调生故。灭苦是悲。利乐是慈。次一偈半大智上供。上二不二为真正发心。后偈总结成信。兼信因行。其中对上四因四缘。可以意得。又上从不求五欲。下即显信心之德故。璎珞经云。修十信心须具十德。今文并具但不次耳。一遭苦能忍。即前反显。二正显中。初二句即慈悲深厚。三次句及庄严国土。即修习善根。谓利他善及净土因故。四有三字即供养诸佛。五受持一句志求胜法。六证菩提故即求佛智慧。七一句即深心平等。八次二句即亲近善友。九次二句即心常柔和。谓至诚供养柔和善顺于佛法故。十有二句即爱乐大乘。十德备矣。又此十德。即求菩提之意。下经休舍云。欲教化调伏一切众生。尽无余故发菩提心等。又末后偈。初句即自性住佛性。以信心佛众生无差别故。方是真法可谓深信。次句即引出佛性。后句即至得果性。又文有四弘。可以意得。又上云深心信解常清净者。与理相应方曰深心。若昔染今净。净则有始始即必终。非常净也。信烦恼即菩提方为常净。由称本性而发心故。本来是佛。更无所进如在虚空。退至何所。慨众生之迷此。起同体大悲悼昔不知誓期当证。有悲故不为无边所寂。有智故不为有边所动。不动不寂直入中道。是谓真正发菩提心。第二信为道元下。七颂略示胜能。于中初一颂总标。次五颂别释。后一颂总结今初。初句又标道有二义。一果所谓菩提涅槃。二因谓三贤十圣。乘一直道。元亦二义。一本义。菩提本故。其犹滔滔之水始于滥觞。二首义。元者善之长也。即一因之初功德。二义通因及果。母有二义。生长养育。下三句共释初句。长养即母二义。亦道元义。一切善法及第二句。即因功德。第三一句即果功德。无上道者。即大菩提。由信长善得此菩提。由信断疑出爱成涅槃证。不信身心如来知见。岂能开示菩提涅槃。次信无垢浊下。别显中有二十句。一句辨一胜能。一心净为性故。能翻不信浊。二信理普敬故翻憍慢。三十藏之内信即是藏。七圣财中信为第一。四信方受取奉行。五信财如梦故无所吝。六智论云。佛法大海信为能入。七增福智因。八到二严果。九十五根五力各在初故。十一信本无惑方断惑根。十二若向余德不名净信。十三信境本空故无所著。十四正信之人不生八难。十五非不正信。十六正信解脱。十七成不坏本。十八为菩提根。十九增佛胜智。二十究竟见佛。谓信自己心自佛出现。信外诸佛诸佛现前故。下经云。一切诸佛从信心起。三是故下一偈。总结胜能。前法后喻。信乐者信三宝性。已于方便诸度。求欲修行。信乐二字是菩萨正意。由此二故。于诸行有能故名最胜。非佛不信故云难得。喻如意珠。略有五义。一胜义。法宝中王故。二希义。非佛轮王余无有故。三净义。能清不信浊故。四贵义。出位行宝等不可尽故。五蕴义。蕴众德物无障碍故。第三若常信奉下五十颂半。广明信中所具行位。然有二意。一行布。二圆融。古约圆融故名信中所具。于中三。初明所具行。次辨所具位。三结叹功德。今初八。颂半分二。先五颂明信三宝以成诸行。后三颂半。明信展转以成诸行。前中初三颂信佛成行。初二句标章。持戒恶止也。修学处善行也。瑜伽云既发心已。应于七处修学故名学处谓一自利处。二利他处。三真实义处。四威力处。五成熟有情处。六成熟自佛法处。七无上正等菩提处。次一偈半双显二德。若不持戒。尚不能得疥癞野干之身。况于菩提。戒止妄非则性净。菩提开发。因果功德。皆依学处而生。故云地也。后一偈别明成供养行。谓财法供养故云大也。次一信法。后一偈信僧。文并可知。二有三颂半。成展转行。展转依前功归于信。二若为诸佛下。三十九颂明所具诸位。于中成后四位。即为四段。初三颂明十住位。有六句。初句发心住。次句治地修行二住。次句生贵住。次句方便具足住。次句正心住。后句增上是不退住。最胜心是后三住。准下释之。二若得增上下。二颂半明十行位。波罗蜜是十行总名。摩诃衍是异二乘行。初二行收如法供养。是顺理行。次二行摄念佛心不动。及常见佛并是定慧行。故属后六行。释相可知。三若常睹见下。三颂明十回向位。通显三种回向。佛体常住是向菩提。法永不灭是向实际。余向众生。四若得坚固下。三十颂半明十地位。初半颂是初地。谓深法是所证真如。爱乐是极喜异名。二半颂是离垢地。以离犯戒有为过故。三一颂离慢等。是三四二地。以三地于禅不着故无慢又以求法不懈亦名离慢。第四地得出世间道品。故云无放逸。然不舍摄生故云兼利四有一颂。明五地。谓虽得出世而还处生死故无厌。真俗互违难合能合。余地不过故云勇健无能胜。此是难胜之名也五有一颂明第六地。悲智不住般若现前。谓神通摄物是大悲行。知众生行是十二缘生。是大智行。六二颂半明七地。谓初一明有中殊胜行。后一颂半明空中方便智。准释可知。七若具最胜下。三颂明第八地。略辨六义。一道胜。谓无功用道。故云勇猛无上。二力胜。谓智力摧魔。三用胜。谓超四魔境舍分段。故无蕴魔。无舍命故无死魔。惑不现行故超烦恼魔。觉佛十力故超天魔。四位胜。不动地故云不退也。五行胜。谓得无生忍。六因胜。谓此位中当大授记位也。八二颂明第九地作大法师。略辨四义。一诸佛加持名佛现前。二解了诸佛深密之法。三诸佛忆念增其慧力。四佛德自严为众说法。九若以佛德下。十九颂。明第十地位分五。初八颂三业殊胜德。初五颂半身业。于中前三颂明身体德殊胜。后二颂半明身业大用。次演说一颂半。语业胜说法益生。后二颂意业胜智先导故。二若以智慧为先下。四颂明三业广大功。三轮摄生德。初一颂身业。次一语业。后二意业。三若知烦恼下。二颂辨得法结位。四若得十地下。三颂明三昧分大尽分受位分。并显可知。五若蒙下。二颂明大用难测。亦是释名分事也。谓以大法智云含众德水。能蔽如空粗重故。又若蒙下二颂。亦是进入佛地。第三菩萨勤修下。三颂结叹其德。初二法说。后一喻况。前中贤首云。初二句悲愿内满。谓菩萨勤修等者。结前若字下义。无不果者。结前则字下义。以若有彼则有此。非是前后钩锁相因。唯是本位信字。有此则有彼。同时具有而说有前后。是故信门具足一切行位之相。然行虽无量。皆以悲愿为首。故就此结之。次二句。明此悲愿益物不空。次一颂。结前所具行位。初句举人标法。威神即信为能具之由。次句结能证智。眼证如如永常故。次二句结所证道。十善举二地行。等取余地及余位余道。谓教证等胜宝皆现。后一颂喻况。唯喻后偈。初句及威力喻前初句。信体坚固以喻金刚。并居智海之内以信。威力能生。所生众宝即喻前第三句行位。第三句喻前法眼常全。第四或有刹土下。二百三颂明无方大用。分彼能无边大用者。由普贤德遍一切时处法界无限故。略辨十门三昧业用。一圆明海印三昧门。二华严妙行三昧门。三因陀罗网三昧门。四手出广供三昧门。五现诸法门三昧门。六四摄摄生三昧门。七俯同世间三昧门。八毛光照益三昧门。九主伴严丽三昧门。十寂用无涯三昧门。以无不定心故皆云三昧。作用不同略辨十种。又初门依体起用。末后明用不异体。中间并显妙用自在。又十三昧皆具此三。今初六颂明海印三昧。文分为二。前五别明业用周遍。后一总结大用所依。前中三。初三佛事。次一三乘。后一类余。总显十法界之化也。前中初一总明现佛说法。次一体用自在。初句拣非二义。一念无分别。二动无功用。下三句显正二义。谓无念之念。一念遍于十方。无功之功。多门摄于群品。月喻四义准法可知。后一结用所依。海印之义。昔虽略解未尽其源。今以十义释之。以表无尽之用。下经云。如净水中。四兵像。乃至莫不皆于水中现。又云。海有希奇殊特法。能为一切平等印众生宝物及川流。普悉包容无所拒故。大集十四云。如阎浮提一切众生身。及余外色。如是等色海中皆有印像。以是故名大海为印。菩萨亦尔。得大海印三昧。已能分别见一切众生心行。于一切法门皆得慧明。是为菩萨得海印三昧。见一切众生心行所趣。然此经文多同出现。但出现现于四天下像。又约佛菩提。大集唯阎浮约菩萨所得。然皆见心所趣等了根器也。此文所现形类应根器也。二文互举皆是所现。菩萨定心以为能现。言十义者。一无心能现义。经云无有功用无分别故。二现无所现义。经云如光影故。出现品云普现一切众生心念根性欲乐。而无所现故。三能现与所现非一义。四非异义。经云大海能现能所异故非一。水外求像不可得故非异。显此定心与所现法。即性之相能所宛然。即相之性物我无二。五无去来义。水不上取物不下就。而能显现。三昧之心亦尔。现万法于自心。彼亦不来。罗身云于法界。未曾暂去。上之五义与镜喻大同。六广大义。经云遍十方故。普悉包容无所拒故。明三昧心周于法界。则众生色心皆定心中物。用周法界亦不离此心。七普现义。经云一切皆能现故。出现云菩提普印诸心行故。此与广大异者。此约所现不拣巨细。彼约能现其量普周。又此约所现无类不现。彼约能现无行不修。八顿现义。经云一念现故。谓无前后如印顿成。九常现义。非如明镜有现不现时。十非现现义。非如明镜对至方现。经云现于四天下像故。四兵罗空对而可现。四天之像不对而现。故云非现现也。以不待对。是故常现该三际也。具上十义故称海印。诸佛穷究菩萨相似。问仁王三贤。都无八相之文。初地方云。方生百三千一时成正觉。此之八相岂在信门。答即上所引大集亦云。灌顶住菩萨得佛神力。若菩萨成就如是等法。能于无佛世界示现八相。乃至广说。彼说住终。若占察经渐次作佛。略有四种。何等为四。一者信满法故作佛。所谓依种性地。决定信诸法不生不灭清净平等。无可愿求故。二解满作佛。三证满作佛。谓净心地。四一切功德行满作佛。依究竟菩萨地。起信依此说信成就发心。能八相作佛。文据昭然。况圆融门中不依位次。寄终教说信满即能。因果无碍。以因门取常是菩萨以果门取即恒是佛。或双存俱泯自在难思。又此化现非唯一位。依一类界而能具摄一切地位。遍于时处。故云念念遍十方也。第二严净下。华严好行三昧。文有十句。略辨七行。前六句各一行。七八是十度行。九结上自在。十总结所依。万行如华严法身故。余如别说。第三一微尘中下。四颂明因陀罗网三昧门。于中初二句。标定心境。然有二意。一由一多相即故入一定能成多定。由成多定。令一尘内有一切尘。一一尘中现一切刹。二但令一尘现刹一切亦尔。故云成就一切微尘定。次二句明不坏相而普现。故云不增。次二颂明一尘中所现刹相。无碍如焰重现如帝网。次半颂举一例余。亦有二意。一例上一尘之内所具之尘。二例如一尘入定示现。余尘入定示现亦然。后二句结用所因。略辨三门。一三昧力。此同标中。二不思议解脱力。如不思议品云。于一尘中现三世佛刹等。三神通力。谓幻通自在并如下说。第四若欲下十八颂。明手出广供三昧门。初一总标。后一通结。中间别显。欲显胜妙略举一手。为供所依。由于昔时以手持供供佛施人。称周法界。故令真流供具等诸佛之难思。第五菩萨住下。八颂明现诸法门三昧门分四。初一总标多门。二有五颂。别显二十种门供等。即门通入佛果故。三一颂半结多所因。由四悉檀故。初半对治。次半世界。随行差别即当为人。而成就言。谓第一义。四半颂结用难测。第六有妙下。十七颂明四摄摄生三昧门文分为二。初一偈总标名用。余颂别显。于中分四。初四颂布施摄。初一偈半。求受用者恣其所须。次半偈。求自在者施以王位。又此施位即难行施。以是可爱着故。次偈身行法施。后偈妙色悦心。是无畏施。又后二偈。初身行法仪。后服世妙饰。贵悦物心随求即与。次二颂爱语摄。一切爱语。谓慰喻庆悦胜益之言。言种种梵音者。即八种梵音。一最好声。其音清雅。如迦陵鸟。二易了声。言辞辩了。三和调。四柔软。五不误。六不女。七尊慧。八深远。言俱枳罗者。亦云都吒迦。此云众音合和。微妙最胜皆爱语之具。随心说法应在后偈。随世所宜应在前偈。以瑜伽一切爱语略有二种。一随世仪轨语。二顺正法教语。今开示佛说八万法门。即顺正教也。三有二颂明同事摄。物见菩萨俯同其事。知有义利而修行故。于中初颂一切同事。八风等事皆悉同故。后偈谓行同事。忍于诸苦而同事故。四有八颂。明利行摄。谓说趣义利之行。以益有情。于中初二偈。一切利行。此有三种。一于现法利劝导利行。谓令以德业招守财位。以益近故。经文略无。二于后法利行。谓劝舍财位清净出家。即当初偈。三于现法后法利行。谓劝离欲即后偈也。又初一偈。即难行利行。此自有三。一不识出离。即外道异执。二不求解脱。即未种善因。三现舍国财。诱耽财位于此利行。是谓难行。次一句即摄二利行。一即十种清净利行也。二令离十恶。即此世他世乐利行。次三句即善士利行。慈心劝导等故。次二偈即遂求利行。谓众生为八缠所绕开解令离故名遂求。初偈即化无愧缠。以恃寿长不知进修。不知此身但淫欲生。终竟败坏。具诸烦恼故。后偈开解无惭缠众生。余略不具。次二偈即一切种利行。初偈即应摄受者而摄受之。后偈即应调伏者而调伏等。后一偈即一切门利行。谓不信令信故。亦总结诸利行也。瑜伽广说利行居先略明同事居后。此则先略明同事者。以利行中若以行劝修。与爱语相近。若自示行即同事相近。同事即是利行。利行未必同事。此二相近广略互彰耳。又次下三昧。亦同事故。第七雅思下。十七颂俯同世间三昧门。于中三。初六身同世间利益众生。若依若正无不示为。次六示同外道救彼邪党。初五别辨。后一总结。义如别说。三众生迷惑下。五颂明语业大用。初一总明。次三别显。后一总结。别中云或边咒语者。梵云达逻鼻茶曼达逻钵底鞞。言达逻鼻荼者。是南印度中边国名也。此云消融。曼达逻者咒也。钵底鞞者句也。谓其国人禀性纯质。凡所出言皆成神咒。若邻国侵害不用兵仗。但以言破之。彼自丧灭故曰消融咒句也。或云。唯童男童女方得言成咒句。余不得也。又天密语等者。婆沙七十九说。世尊有时为四天王。以圣语说四谛。二王领解二不能解。世尊怜愍故。以南印度边国俗语说四谛。二天王中一解一不解。世尊怜愍故。复以一种篾戾车语。说四圣谛。时四天王皆得领解。善破于他者。以因明比量等。真能破故。非外所动者。真能立故。不为他破。后一偈类结。非唯说四谛。六度万行等皆然。一心说法得语实性。能起随类之用。名三昧力(已下第十五经)第八有胜三昧下。八十九颂半。明毛光照益三昧门。智契解脱之门。慈熏身语意业。故得身同法界大用无涯。毛光触物为益万品。遍于时处缘者会之。是谓菩萨圆建立众生也。文分为五。初一颂标门总辨。二所放光明下别明一毛光明业用。三如一毛下。类显一切毛光业用。四如其本行下。释成分齐。五若有闻下。闻信光益。今初。就所益说故名安乐。就第二段中二。初略辨四十四门光用。后如是等下结略显广。就四十四光中皆有四义。一标光名。二辨光用。三出光因。四结光果。类例相从分为十段五对。初有二光显示三宝。二有四光令发大心。上二即三宝四弘对。三有二光总圆福智。四有二光入理持法。上即二严二持对。五有六光六度行圆。六有七光四等救摄。即六度四等对。七有一光总彰三学。八有八光。杂彰万行供养为先。为三学万行对。九有六光。令六根内净动与理会。十有六光。明六尘外净触境皆道。即根清境净对。今初。二光中。前一显现。于中初句标名以近初标。但云所放不言又放。次三句辨用。后偈辨因中。示三宝令其正归。示正道令其正向。上通一体及别相三宝。亦示佛塔。令其正信义兼住持。后一光照耀用有七句。一偈辨因并显可知。第二四光。令发大心中即四弘愿也。初一令众生无边誓愿度。因中兴有为而毁有为。二一光令烦恼无边誓愿断。因中兴有为而赞禅定。上二皆事理兼修。三上欣佛果。四爱乐三宝穷尽法门。因中四弘之终故。总结云及示发心功德行。第三有二光总圆福智。智因中分别法相。决了真理无亏理事。不减佛法故。得一念悉解多门。第四二光入理持法。初一慧入二空即义持也。后一具四总持于法自在。第五六度光中戒因中。云发大心者。谓若发二乘心。则破净戒。大心导善不在人天。勤策万行慧为上首。各加一偈余可思之。第六有七光。四等救摄中。初一慈光与佛慧真乐见无量佛。此有二义。一见事佛。真乐因故。二见心佛。一一心华有觉性故。次三悲光拔苦。初一厄难苦。次一疾病苦。后一死苦。令见佛者。一舍命不恐。二恶道不畏。又要临终劝者。智论二十八云。临终少时。能胜终身行力。以猛利故。如火如毒。依西域法。有欲舍命者令面向西于前安一立像。亦面向西。以旛头挂像手指。令病人手捉旛脚。口称佛名。作随佛往生净土之意。兼与烧香鸣磬助称佛名。若能行此。非直亡者得生佛前。抑亦终成见佛光也。若神游大方去留无碍者。置之言外。不尔勉旃斯行。次二光令生法喜。初则欣法听说。法喜已充。终则触境无非佛法。成喜之极。后一令成大舍。舍除放逸众惑之根。第七一光总彰万行。三学摄尽故曰普闻。第八八光杂明诸行供养为先。前五供敬由。后三施悲田。第九六光内净六根。第十六光外清六境。文并可知。戈者平头戟也。鋋者小矛也。第二如是等比下。结略显广。一毛之用光。有尘沙。第三如一毛下。类显一切毛光业用。及结用所依。谓三昧力。第四如其下释成分齐。如是等光。今何不见。谓有缘者见如目睹光。无缘不觉盲瞽常闇。于中分二。初偈总明。如其本行牒前往因。所得光者。牒前果用。若有宿缘及曾同行者。则随其所见如是差别。后六偈别显。于中初二法说。后四喻说。前中初偈宿缘。宿有四缘。一昔同业。二爱其行。三能随喜。四但见所作。后偈现因。不必有缘但功行内着。光明爰烛。有三种因。一修广福。二供多佛。三求佛果。即福智二严也。上之七类皆蒙光照。二喻说中。双明见与不见二喻。皆有法合。初日出喻喻光为益因。合中谓法日常明。有智慧者心不住法。如人有目则能得见。有三类人则不能见。一者凡愚。二邪信外道。三劣解二乘。皆无因缘如人无目。后宝严喻。喻光正益。明法宝常存。由福无福有处不处。第五若有下。一颂明闻信光益。谓信仰解了不生疑惑。则成佛果。不以不见疑菩萨之无光。不以极苦莫救谓光明之无益。亦不高推果用谓菩萨不能。故云永断诸疑。第九有胜三昧下。六颂。主伴严丽三昧门。亦是出现三昧文分三别。初一标门显意。次四明一方业用。于中前三法说。后一喻合。既言量等三千。则不坏次第。劣于十地及等觉也。三一颂类显十方。第十有胜三昧名方网下。三十四颂半。明寂用无涯三昧门。约处名为方网。约相是谓寂用。亦总显上来动寂无二故。文分为三。初一标名总辨。十方交络出入纵横。故名为网。二或于下。三十二颂半正显业用。三是名下一颂。总结难思。就业用中分三。初二颂。于十方处交络出入。明于器世间自在。二有五颂。十方佛所入出无碍。明于智正觉世间自在。三于眼根下。二十五颂半。通显于三世间自在。菩萨于三世间自在。略有二义。一以自身作三世间。故得自在。二菩萨于三世间处示现自在。今此三段。初二约后义。后一通二义。文或绮互理实皆具。初二世间略有四重无碍。一约处。谓东处即是西处。是故菩萨常在东恒在西也。二约佛。谓东佛即西佛。是故在东佛恒在西佛。三约菩萨身不分。谓在东之身即是西身。四约定。谓入定即是出定。所以尔者。略显二因。一以所观之法。事随理融相即在故。二能观之心。亦寂用无碍故。然此文中。为显菩萨秘密隐显自在德故。但说后二。若辨前二。则似菩萨无力。三于眼下。通显于三世间自在。文分为四。一明根境相对以辨自在。二童子下。明于他身自在。三鬼神下。明微细自在。四一切尘下。器界事中以辨自在。今初。十二颂六对。一一对中。有十义五对无碍之相。欲辨无碍先须明识定慧。此中云三昧起者观也。入正受者定也。定慧虽多不出二种。一事二理。制之一处无事不办。事定门也。能观心性契理不动。理定门也。明达法相事观也。善了无生理观也。诸经论中或单说事定。或但明理定。二观亦然。或敌体事理止观相对。或以事观对于理定。如起信论。止一切相乃至心不可得为止。而观因缘生灭为观。或以理观对于事定。下经云。一心不动入诸禅。了境无生名般若是也。或俱通二。如下云。禅定持心常一缘。智慧了境同三昧是也。或二俱泯非定非散。或即观之定但名为定。如观心性名上定是也。或即定之观但名为观。如以无分别智观名般若是也。或说双运。谓即寂之照是也。所以局见之者随瞩一文。互相非拨。偏修之者随入一门。皆有克证。然非圆畅。今此经文巧显无碍。言五对者。第一对根境无碍。谓观根入定应从根出。而从境出者。为显根境唯是一心。缘起无二理性融通。是故根入境出耳。境入根出亦然。第二对理事二定无碍。谓分别事相应入事定。而入理定。欲观性空应入理定。而入事定。以契即事之理而不动故。入理即是入事。制心即理之事而一缘故。入事即是入理。而经文但云入正定。不言理事。及乎出观境中。即云分别色相斯事观也。根中即云性空寂者。理观也。亦合将根事对于境理。以辨无碍。第三对事理二观无碍。谓欲分别事相。应从事观起而反从理观起者。以所观之境既真俗双融法界不二故。分别事智即是无生之智。二观唯是一心故。亦应将境事理对根事理。以辨无碍。第四对出入无碍。以起定即是入定故。起定而心不乱。若以事理相望。应成四句。谓事入事起事入理起等。若以根境相望。又成四句。谓根事入境事起等。一一思之皆有所由。第五对二利体用无碍。谓于眼根起定心不乱是体也。自利也。而不碍现于广境是用也。人天不能知利他也。良以体用无二故。自利即是利他。此上十义。同为一聚法界缘起相即自在。菩萨善达作用无碍。思之思之。又经且约根境相对。亦应境境相对。谓色尘入正受。声香三昧起等。此如下童子身中入正定等中明。复应根根相对。谓眼根入正受。耳根三昧起等。一尘入正受多根三昧起等。并略故不说。上来无碍深妙难思。始学之流如何趣入。今当总结。但能知事理无碍根境一如。念虑不生自当趣入。又向云色性难思等。即色等总持。是色陀罗尼自在佛等。亦应云分别眼性难思。有眼陀罗尼自在佛等。又眼中云性空寂灭。即眼之度门。眼等本净。亦应云色等度门色等本净。不唯取相为染无心为净而已也。又以智论三观束之。分别色相等。是假名观也。性空寂灭是空观也。此二不二色性难思。中道观也。三无前后皆是一心。对此三观应辨三止。谓方便随缘止。体真止。离二边分别。止既止观双运。亦名一心三生也。即一而三即三而一。双照三一双遮三一。是无碍也。一一释文准思可见。此是菩萨圆融功德。而自庄严。触目对境常所行用。希心玄趣。幸愿留神。二童子下六颂半。于他身得自在。此有三义。一如前眼根入等。但约见境为出入耳。二菩萨化现彼身。作此转变速疾也。三菩萨以众生身作自身。如下十身相作等。是故于彼身入此身出。而彼不觉知。唯应度者知得度也。三鬼神下二颂半。微细自在。谓毛孔约正报。即佛及众生。毛头约空处。微尘是色相多约器界。并身在中入定出定。为显三昧纯熟隐显自在故。亦通观彼入出定等。即于境无碍也。若唯约身在彼下十定中。亦云无生法中入起。安有处耶。四一切尘下四颂半。器界事中周偏入出。然菩萨身普遍略有四位。一普遍一切十方刹海。二遍彼刹内树等物中。三遍一切尘毛等中。皆圆遍非分遍。是故皆全身显现。四以是法界身故。不异不分恒在此常在彼。无有前后。第三是名下一颂总结。初句以德命人。次句依人显德。后半明说不尽。近结第十定用无尽。远结前十定大用无尽。以是无尽之法门故。第五一切下。喻况玄旨分。亦名举劣显胜分。以上所说普贤行德。穷于佛境。盖是信满之位。既越常规乖于视听。滞情封教取信无由。故举斯近事以镜玄趣。令开悟也。七十九颂分为三段。初二总标喻意。二七十六颂别显喻相。三一颂结说显德。今初先一偈半。明非喻能喻。后半偈借喻通玄。今初举四难思。意在菩萨神力。瑜伽决择分有六种不可思议。谓一者我。二有情。三世间。四有情业果。五诸修静虑者静虑境界。六诸佛世尊诸佛境界。今众生含其前三。加龙变化所以有四。菩萨神力。即静虑者境界。旧经梵本。皆云禅定力用故。然众生业报四因难思。谓处所差别故。事差别故。因差别故。异熟果差别故。诸龙变化不起心念。六天四洲云雨不同等。故难思也。佛自在者有五难思。谓真如甚深故。自在转故。无漏界证得故。无障碍故。成立有情所作事故。菩萨神力由三种相。除佛后二。以今经文分同佛五。以皆超言念故。无可同喻。后半中然取分喻。以小喻大。令闻喻者忘象领意故。褒以智者。二声闻下别辨中。略显二十种大喻。以况菩萨之德。初有三颂半。明声闻现通喻。况菩萨自在益生德。先明喻末偈举劣显胜。不为众生无大悲也。不求菩提无大智也。大饶益者具悲智也。二有二偈日月现影喻。况菩萨普应群机德。三有二颂水现四兵喻。喻菩萨海印现像德。四有二颂善音巧辨喻。喻菩萨总持巧说德。五二颂女授辩才喻。喻授法益生德。六譬如幻师下。二颂幻师巧术喻。喻不思议解脱德。七二颂修罗隐形喻。喻胜通隐显德。八五颂象王随变喻。喻定用自在德。九二颂修罗大身喻。喻法界身云德。同于上文主伴严丽。十有四颂帝释破怨喻。喻降伏众魔德。十一忉利天下六颂。天鼓说法喻。况菩萨以无功用现身说法德。十二有三颂。天鼓安慰喻。况菩萨慈音除恼德。十三有三颂。天王普应喻。喻普应悦机德。十四有二颂。魔系愚夫喻。喻摄生同行德。十五有二颂。梵王殊现喻。况菩萨解脱自在德。十六魔醯下二颂。自在数滴喻。况菩萨一念普知德。十七三颂大风成事喻。喻大愿宿成德。十八二颂众声悦意喻。喻四辩悦机德。十九二颂。大海包含喻。喻禅慧普修德。二十大海龙下。二十四颂半。龙王游戏喻。喻菩萨游戏神变德。文分为二。初二十二颂半。明龙王大用不同。后二颂正明举劣显胜。前中初半偈总标。余颂别显。于中四。初四偈半云色不同。喻菩萨身云各异。次有四颂电光差别。喻菩萨光明等殊。第三偈云宝藏色者。梵云室利揭娑。此云胜藏。胜藏即宝名也。阎浮提中帝青色者。梵云天帝火焰摩尼色。亦珠宝名也。三有三颂半雷声不等。喻菩萨三昧多种。四有十颂所雨不一。喻菩萨说法多门。言曼陀罗者。此云悦意。泽香即涂香也。鸡罗多摩者。鸡罗此云华蕊。多摩此云天上华。谓此香是天华蕊所作故也。婆利师迦者。此云雨时生华。末利香即华名。其色犹黄金。第二如是无量下。二颂正举劣显胜。谓娑竭罗龙。于六欲天等总十五处。现斯作用。而身不动摇心无分别。但由业报之力现斯自在。菩萨亦尔。住无功用不动不思。于十方界应现多种。亦以菩萨功德之力随机见殊。此就喻意显胜可知。第三彼诸下。一颂结说难思。前半非喻能喻。后半结上略说。引诸喻者略有二意。一显菩萨自在不同。二贵令众生起信。且江南之人不信千人[疊*毛]帐。河北之者多疑万斛之舟。皆耳目不暨故耳。所以或举目击或据具缚之人。自在若斯。菩萨之用固当无惑。今犹疑者岂不伤哉。大文第三第一智慧下。九颂校量劝持分。此广大用人皆有分。见而不习诚为自欺。故中人可劝而进也。于中分二。初一颂结前所说。略就六慧结之。第一者上无加故。二广大者。语其分量超二乘故。三真实者。明其体性内证无虚故。四无边者有二义。一量智普知故。二离种种二边故。即中道慧也。五胜者。超地位故。六殊胜者同普贤故。二此法下八颂。明信受难得。于中初一总显余七别明。前中希有者。佛出悬远已难可遇。唯初成顿说故希有也。奇谓初能具后。特谓迥出诸乘。此句赞也。下文劝耳。闻谓遇经。忍可谓信因。信则心净。受谓领文领义。赞乃通言通笔。说唯约言。上皆所作总说皆难。后别明中三。初二偈半明难信。次半偈况出余行。后四偈举事校量。前中初一偈明人天之器信为甚难。若尔今或能信何耶。由二力故。一现修净福称所求故。二昔因闻熏今发种故。今不信者。愿少听闻为毒涂鼓。终成坚种。后一偈半举三乘之信。展转难得况于一乘。明文昭然权实有据。第二半偈。况出余行中信忍尚难。况具余行。难中之难也。真实解者。亦有说行而不信圆融之旨。非真实解也。愿诸学者善择知见。第三四颂举事校量。初三校量难信。初二举二难以况信难。后一举福胜以彰信胜。后一校量余行之难。唯明诵持余略不说。亦显修行。真解非可校量也。此之四事。后后过于前前。巧辩深胜。大段第三时贤首下。显实证成分。于中有四。一动世界大机发故。二蔽魔宫唯佛境故。三息恶道利乐深故。四佛现证契佛心故。于中摩顶赞善随喜。即三业皆证。劝物信行第二会竟

大方广佛华严经疏卷第十六大方广佛华严经疏卷第十七

        唐清凉山大华严寺沙门澄观撰

    升须弥山顶品第十三(已下第十六经)

初来意者。先辨会来。前信此解。义次第故。又答十住问总有二段。前信是住之方便。此明正位故次来也。二品来。前品说信究竟。此品趣后说住。故次来也。二释名。亦先辨会名。约处名忉利天会。约人名法慧菩萨会。约法名十住会。皆依主释。二品名。须弥正云苏迷卢。此云妙高。如来以自在力不起觉树。应机现彼故云升也。表位渐增不处人间。显位清净故居天也。若天表净何独妙高。妙有十义。如于法故。一者体妙谓四宝所成。二者相妙。谓八方四级。三者色妙谓四正色。北金东银南吠琉璃西颇胝迦。一切草木鸟兽等物。随所至处则同其色。自常不变。四者德妙。谓八方猛风不能令动。五眷属妙。谓七金山七重围绕。及七香海海印旋流。六依持妙。唯天依住。得通者居。七作业妙。不离本处而镇四洲。映蔽日月而成昼夜。八生果妙。谓波利质多能益天众。九为首妙。于四洲地最在先成。十坚固妙。于轮围中最在后坏。高者高八万四千由旬。入水亦尔。下据金刚上邻空界。顶上纵广量亦如之。独出九山故称高也。十住之行亦复如是。闻思修解而为妙体。四德八圣以为妙相。四辩为色令物解同。虽同众音自智不变。八法不动而为妙德。七支奉戒金山围绕。七识流转而为海印。第一义天依持而住。可以神会非情能升。不离本处遍应十方。映蔽佛口及菩萨月。而成涅槃生死昼夜。生教行果而为妙树。世界初成菩萨先出。为众生现种种资具。世界将坏菩萨后没。为说上定令免三灾。高者具成八万四千诸度法门。自在障外为众生故。入生死海。亦具八万四千诸度法门。据金刚性邻胜义空。又智入佛慧必穷其底。德超方便迥出群峰。为显十住功德妙高。是故须升妙高山顶。四王处半旁而非正。表住不退异信轻毛。故越彼天居妙高顶。善财童子于妙峰山顶见德云者。亦表斯位弥显有由。然上所释皆圆教意。故下发心品云。应知此人即与三世诸佛同等。与三世佛功德平等。得如来一身无量身。才发心时。即为十方一切诸佛共所称叹。不可同于方便教说。若约观心妙高者。谓三昧须弥寂然不动。无思无心不收不摄。任性而定称本心地。入佛智海湛然不迁。是妙法乐触境自在。合本性净。是四德宝而自庄严。斯则本觉如来。升法须弥之顶。三宗趣者。先约会以十住行德为宗。摄位德果为趣。二品以严处请佛赴感为宗。根缘契合说法为趣。四释文者。此会六品分为二分。初二品方便发起。后四品当会正说。前中初之一品。唯是由致。偈赞一品义有两兼。一是方便。谓前品化主赴机。后品助化赞佛。主伴圆备方演法故。二是所依。谓三天说法各有偈赞。欲显三贤皆依佛智有差别故。离如来智无自体故。独为方便甚抑赞词。行向二会同此科判。今初一品长分十段。一本会齐现。二不离齐升。三各见佛来。四各严殿座。五皆来请佛。六俱时入殿。七乐音并止。八各念昔因。九同赞如来。十殿皆广博严净也。言尔时者。即前二会时。主伴齐遍演前二会之法也。今此明遍。即十重说处中第一重也。何须举此。欲明前会不散成后会故。后必带前。合成法界无碍会故。一一诸会无休息故。后后诸会皆同时故。若散前会即无后故。所以唯约觉树会者。此为本故。得佛处故。理实第二亦同此遍。若同时遍。何有九会前后。若有前后何名同时。应云即用之体同时顿遍。即体之用不坏前后。犹如印文。第二尔时下。明不离觉树各升释天。问动静相违去住悬隔。既云不离何得言升。古有多释。一云。本释迦身不起道树。别起应化以升天上。一云。不起是报升天是化。一云。不起是法身升天是化用。并非文意。以此文中俱是毗卢遮那十身云故。一云。以去即非去故名不起。非去即去是以升天。如不来相而来等。若尔但是升相离故。非是树下别有不起之身。故不可也。有云。此佛神通同体业用。即住是去去即是住。住是体遍去是用应。应是体应。虽升后而不离前。体是应体。虽不离前而升后。若尔何殊第三师。不起是法。又以住释于不起。而言住是体遍。何得独住菩提树耶。升天何得非体遍耶。菩提树下宁非用耶。今显正义。然佛得菩提。智无不周体无不在。无依无住无去无来。然以自在即体之应。应随体遍。缘感前后有住有升。阎浮有感见在道树。天宫有感见升天上。非移觉树之佛。而升天宫故云不离觉树。而升释殿。法慧偈云。佛子汝应观如来自在力。一切阎浮提皆言佛在中。此不离也。我等今见佛住于须弥顶。此而升也。文理有据。更以喻显。譬犹朗月流影遍应。且澄江一月三舟共观。一舟停住。二舟南北。南者见月千里随南。北者见月千里随北。停舟之者见月不移。是为此月不离中流而往南北。设百千共观八方各去。则百千月各随其去。诸有识者晓斯旨焉。古德释此。略有十义。一约处相入门。以一处中有一切处故。是故此天宫等。本在树下。故不须起。然是用彼故说升也。二亦约相入门。以一处入一切处故。树遍天中亦不须起。欲用天宫表法升进。故云升也。三由一切即一故。天在树下。四由一即一切树在天上。不起等准前。五约佛身。谓此树下身。即满法界遍一切处。则本来在彼不待起也。机熟令见故云升也。是故如来以法界身常在此。即是在彼。六约佛自在不思议解脱。谓坐即是行住等。在此即在彼。皆非下位测量故也。七约缘起相由门。八约法性融通门。九约表示显法门。十约成法界大会门。然此十解前五玄门。次四所以。后一总意。欲成十义相参而立。虽似杂乱不违经宗。并可用也。然此中相望有四对。法相即无碍。一此处彼处。二此身彼身。三若去若住。四若一若多。约处此处彼处相即无碍。应如十中前四。约身相即无碍。应如五六及前正显。又十中后四通于身处。约处唯有此彼。约身更加去住。谓此身即是彼身。去身即是住身。若身若处俱通一多。上来诸法同在一时。无前后也。一多相望应成四句。一不离一切树下升一天宫。即如今文。二不离一树升一切天。三不离一切树而升一切天。经云十方世界悉如是故。四不离一树下而升一天。经中欲显一多相即。故举初句。升释天既尔升余天亦然。如后二会升天既尔。往余处亦然。复应树树相望而成二句。谓不离一树下常在一切树。不离一切树而常在一树。复应以不起余处。类不起树下。展转相望皆悉周遍。不坏前后自在难思。又既一处有一切处亦有微细义。所用不同有隐显义。若加前时后时有十世义。唯见说住。及于余法有纯杂义。后后带于前前有帝网义。此天望余成主伴义。十玄具矣。问带前起后事理应齐。何故三贤独有斯旨。答显异义故。谓初二会相邻接故。不假带前。此三人天隔越。故须连带。又此三会同诠贤位。六已入证不假带前。第七即位中普贤居然不假。第八顿彰五位体用已融。第九唯明证入体用一味故。并皆不假。第三时天帝下。明各见佛来。约佛则用从体起。约机境从心现。邻而未即故云遥见。第四即以下。各严殿座。表严根欲之殿为法器故。置师子座。表十住之法门故。文有十句。初总余别。总云普光明藏者。此是解位智。照法空含众德故。从信始入故有置言。别中初句约体。余并显严。皆云十千者。万行因感故。言层级者万行熏成故。金网防护。慈悲帐盖以育以覆。四摄缯绮以为周垂。圆融行愿交络万善。柔忍惭愧以覆法空第一义天。清净梵行绕斯法体。一一智照故日光明。于生死中。遣长夜闇举斯果德。令物行因。下行向中。约位渐增表法无异。第五尔时帝释下。请佛居殿。于中三业崇敬以为请仪。言善来者应机来故。不来相而来故。带法界会来故。三称善者喜之至故。举三号者略叹德故。愿哀处者。希仗胜田生大福故。第六尔时下俱时入殿。谓根缘契合成益不虚。十方如是。通上六段入殿事讫。故一结通。下四段文殿中之事。第七尔时下乐音止息。谓摄散归静得定益故。第八即自下。各念昔因获智益也。散缘既止胜德现前。寂然无思发宿住智。种善根者。即下十佛曾入此殿。闻法供养故。亦表见自心性。同昔佛故。第九迦叶下。同赞如来。然三世诸佛。皆于此处说十住法。独赞十者。表说十住及无尽故。所以赞者义乃有四。一十佛曾处则殿胜可居。二互举一德例赞本师。三叙昔善根庆遇堪受。四昔佛同说表法常恒。文中先明此界后辨结通。今初十颂。各上半标名赞德。上句别下句通。下半以人结处。唯初一句诸佛不同。然佛别名多因德立。赞者取德以释上名。初迦叶者此云饮光。若从姓立示生彼族。若就佛德。一者身光蔽余光故。二者悲光饮蔽邪光故。拘那牟尼旧曰金仙。亦云金寂。寂故无碍。金故明见。迦罗鸠驮者。具云迦罗鸠村驮。此云所应断。已断如金已净。如山不动。亦可见无碍者。是此佛德。如金山者是前佛德。毗舍浮者。亦云毗湿婆部。毗湿婆者。此云遍一切也。部者自在也。亦云遍胜无三垢。故无不自在而超胜也。三垢者。现种及习。尸弃亦云式弃那。此云持髻。亦云有髻。无分别智最为尊上。处心顶也。又髻中明珠即无分别也。毗婆尸者此翻有四。谓净观。胜观。胜见。遍见。如月圆。智满是遍见也。魄尽惑亡是净观也。既圆且净。是胜观胜见也。弗沙亦云勃沙。此云增盛。明达胜义是增盛也。提舍亦云底沙。西域训字底逻那。此云度也。沙是皤沙。此云说也。谓说法度人。或但云说。辩才无碍者即能说也。波头摩者。此云赤莲华。身心如莲华净无尘垢。然灯者。智论云。此佛从初现生。乃至成佛。举身带光如然灯故。身智光明普周称大。然十中后七乃过去劫佛。如何贤劫曾入殿耶。古释有二。一约时劫相即入故。二约其处有粗细故。粗随劫坏。细者常存。如法华天人见烧我土不毁。又梵王见净身子见秽。今此天帝是大菩萨同梵王见。亦佛加故。二如此下结通十方。第十尔时世尊下。殿皆广博。即示如意相广殿。同处以遣局情。亦表廓大慈悲等众生界。又如来入殿。即觉智现前。忽然广博则身心无际。十方已下结无尽。唯结后四前已结故

    须弥顶上偈赞品第十四

初来意者。既明化主赴感。今辨助化赞扬。将演住门先陈体性。性即佛智先赞如来。故品来也。二释名者。须弥约处赞称佛德。依处有赞故立此名。亦顶上之赞拣余处也。三宗趣者。以集众放光偈赞为宗。为成正说为趣。又显佛德为宗。令知住体为趣。第四释文总为三分。第一集众分。第二放光分。第三偈赞分。今初文有十同。义兼三异。谓五六七。一集因同皆佛力故。亦同会前时。二十方下主首同。三一一各下眷属数同。四从百佛下。来处量同。前十此百位已增故。五其名下。表法名同。慧即十解能见法故。菩萨名异至偈释之。六所从来下。世界名同同名华者。位相创开无著感果故。别即次第配于十住。一发心主导世间故。二净治心地如莲开故。三修行圆净故。四水生之贵故。五方便坚誓故。六正心无相如香气故。七不退意悦故。八阿卢那者。此云日出时。红赤之相童真明净故。九那罗陀者。此云人持。以华香妙人皆佩故。王子佩持法王轨度故。十智遍如空故。亦可别明十住胜进十法。思之可知。七各于下。所事佛同。同名月者。表位中。佛果智明闇息恩益清凉。应器周故。别名即十住。自分十法之果。一以十难得法。可谓殊特。二发十大心不可穷尽。三观于空等不可倾动。四了知业行生死涅槃。如风不住。五饶益安乐一切众生。如水普润。六闻十种法。心定不动故得解脱。七闻十不退可谓无上。八三业无失。如星明净。随意受生灿然满空。神足自在若依空运转。九善知烦恼现起习气。故得清净。十观察无数众生根欲智慧心境。余不能知唯自明了。以此十因成兹十佛。上且随要相属以为此释。委明其相如十住文。八是诸已下申礼敬同。九随所来下威仪住同。十如此下结十方同。又上十方从东次第。如名号品问。准此结通。即于十方尽空世界。皆有菩萨而来集会者。且如东方过百刹尘土。外亦有众集。未知彼因陀罗华世界为在何处。余界亦尔。答如名号品。第二尔时下。如来放光分。文义有六。一时。二主。三处。四数。五相。六业处。谓两足指足指拒地得住有力。成位不退而行有恒。数位过前加于千也。相表解显故云妙色。普照十方显佛众会。一光照于一切则一切亦尔。重叠无碍无不互见。为一法界圆明大会。第三尔时法慧下。偈赞分中十菩萨说。即为十段。初一是总余九为别。以法慧是说法主故。总叙此会本末事义。总显佛德。余九叹佛差别之德。总别共显如来无碍之会。此十菩萨名亦表十住。其所说法表位胜进。胜进有二。一趣后位。二趣佛果。今约佛果。今初东方法慧总了佛法故。胜进中云。欲令菩萨于佛法中。心转增广。文中观佛现用。及与往修皆周遍故。十颂分三。初五叙因佛光见多盛事。初一叙此品放光。次一叙前品请赞。余三重叙此品。次二劝观佛力。更发胜心。即前品不起而升。后三举因结果。初一举因后二结果。由因中行愿刹刹齐修故。果位身智遍应遍断。第二南方一切慧者。了一切法真实之性。净心地故。颂意为显于诸众生。增长大悲以称实而观救世者故。十颂分六。初二违理观佛非见佛。次四了法真性真见佛。三有一偈迷性取法不见佛。四一偈。佛即同法为真佛。五一偈引已了法为见佛。六一偈。推功有本了真佛。初中前偈出其妄观。假设长时以况暂见。后偈明其有损。由上不依真实则取相乖真。但见集网系于苦狱。盲无慧眼。冥然不见佛之法身。然此遮取相故。假设长时无有多劫。全不了义。以见如来增智慧故。第二四偈。了法真性真见佛。于中二。前二真观后二真止。前中初二句。空观缘生无性故。次二句假观随俗假名故。次二句中。观由前生灭一切诸法即无性故。相体即是不生灭也。后二句观益。诸法如即是佛如。无生灭佛体本常。观称于如则佛常现。况三观一心则佛之体用。无不现矣。后二真止中。以观观法能所纷动。故须寂之。初句牒前法性。次句泯其能所。法性本空非观之使空。故无所取何有能见。次二句。心冥性佛故止绝思求。又上来空以遣有假以遣空。如则双遣空假。形夺两亡。若谓双非还成戏论故。辨起心皆妄绝念方真。念本自无斯绝亦灭。故中论云。如来寂灭相分别有亦非。如是性空中思惟亦不可。用斯文也。后一显观益。心冥体性惑何由生。亦含三止意也。又亦通结止观。称上而观见惑性空。即同佛性。何能染哉。第三一偈迷性中。上半取法次句迷性。末句结过。第四一偈。佛即同法如。谓同空法故离三世。同假法故相具足。同双遣故无住无著。同如体故遍不动摇。第五一偈。引己中。此亲自证希众无惑。第六一偈推功有本者。非师心也。亦谦己推人异乎凡情。令法钩锁殊涂同致。下八准之。第三西方胜慧。以解佛胜智随空心净。故以为名。颂意。为显欲令菩萨智慧明了。即大智了如及佛性故。十颂分四。初一赞智为迷悟本。次四正显迷悟。次四喻前得失。后一推功有在。今初。由难思故迷难则容有。思者故有悟。次四迷悟中。初二迷后二悟。迷中初一心外取境生想违理。故不能见无相之佛。后偈取蕴内相不了蕴性。故不见心佛。亦是愚法小乘。故名无知者。后二迷中前明倒想。内外俱妄。今有了因内外皆悟。初偈翻前外取。谓了一切法即心自性。性亦非性。情破理现则见舍那。称于法性无内外也。后偈翻前内取。了蕴性相则见自心之佛。与卢舍那。非一非异故难思议。然此一偈文舍多意。一但是蕴缚无有我人。则破前凡夫取我相也。二前后因依相续无性。则破凡小取法相也。此性即第一义空。第一义空即是佛性。又上性无所有正因性也。前解此了。皆了因性。此蕴相续。即是正因。亦名生因。言正因者。是中道义。中道即是佛性。谓现在阴灭中阴阴生。是现在阴终不变。为中阴五阴。故现阴非常如种生牙。种不至牙。虽不至牙而能生牙。此现在阴虽不至后。而能生后。则现阴非断。而中阴五阴亦非自生。不从余来。因现五阴生中阴阴。斯则后阴非无因。故后阴非常。既能续前故后阴非断。非断非常是中道义。正因性也。能生佛果故曰生因。众生佛性有二种因。一者正因。二者缘因。正因者谓诸众生。是故五阴即正因也。缘因者。谓六波罗蜜。非蕴相生名缘因也。今以了因了彼正因。故曰于此性了知。了即般若亦缘因也。第三四偈。喻前得失者。前三喻失后一喻得。前中二。初二喻内取失。于中初一显无缘了不见正因。闇中宝者正因性也。圆满可贵。所以称宝。居于无明五阴室内。如在闇中。灯喻缘了之因。下半法合。无人说者。阙于缘因虽慧莫了。义含二意。一慧即正因。合上宝也。阙于缘因故不能了。二佛法即宝。以阙缘因。虽内有慧不成了因。不见真性。然则缘因即是了因。了因未必是于缘因。有亲疏故。善友是于缘因而必是了。佛性名为了因。未必是缘。此约智慧性故。若以第一义空为佛性者。唯是正因。而非了因。但为了因所了。而非生因所生。若以智慧为佛性者。即是了因。若以五蕴为佛性者。名为正因。亦名生因。然复生必对了正必对缘。今灯一喻双喻缘了。闇中之宝双喻正了。义意包含。具如涅槃二十六七所辨。又上灯喻既是正义。何以涅槃师子吼立。佛不许耶。故师子吼言。一切众生有佛性。性如乳中酪以有性故。要须缘因。何以故。欲明见故。缘因者即是了因。譬如闇中先有诸物。为欲见故以灯照了。若本无者灯何所照。故佛难言。若使乳中定有酪性。即是了因。若是了因复何须了。又善男子。一切众生有佛性者。何须修习无量功德。若言修习是了因者。已同酪坏。结正义云。乳有酪者以定得故。佛性亦尔。众生有者以当见故。然上诸义总有二意。一灯了于宝为正义者。约因性故师子吼立。佛不许者约果性故。二者灯喻正者。约其体性与有不异。佛不许者。约其现惑与无不殊。故知若言定有名为执着。若言定无是则妄语。应言众生佛性亦有亦无。然众生智慧是佛性因。菩提涅槃是佛性果。然则佛性非因非果。今此经宗。宗于法性故。以法性而为佛性。则非内非外随物迷悟强说升沈。佛性要义不可不知。广如别章。及涅槃师子吼品等说。后偈目有翳者。此喻了因。与惑俱故见不清净。以不净故不见佛法。佛法即见佛性。故涅槃云。佛性二种。一者是色二者非色。色者诸佛菩萨。非色者一切众生。色者名为眼见。非色者名为闻见。佛性者非内非外。虽非内外然非失坏。故名众生悉有佛性。二一偈。喻上外取之失。瞽谓全无于目如鼓皮故。则全不见佛。无垢障为明净目。取相是识非智慧眼。故不见也。三一偈。喻前悟中抉去取相之翳。舍于空华之像。绝见契如则见如佛。第四一偈。推功有在准上可知。第四北方功德慧者。生在佛家善解佛德故。此颂意显于三世中心得平等。了知自心穷法空故。十颂分四。初四明凡小妄觉。次四示其真觉。三有一偈佛觉双圆。后一偈。推功有本。今初分二。初一偈。说凡迷缘起之无性。执着相而轮回。后三颂通凡小。初一辨迷执随言作解。可谓小智心外取法为妄分别。余二偈明过失。初二句。曲径趣寂迷一直道。次半有常等倒。长世间恶。有无常等长无明恶。次半不见二空。受二死苦。后半无实谛观。何有法眼。三乘纵有亦不名谛。次四示其真觉中。初偈引己之损劝物成益。次偈教其真见。谓见佛无取即是见如。如即佛所知也。次偈教其了俗。上半蹑前证真。下半方能了俗。后偈拂前二见。以成真见。谓上半取真俗之见忘。方见真俗之正理。下半反释。谓有真俗之可见。不能见真俗之真源。故智论云。若人见般若是则为被缚。下半意也若不见般若是则得解脱。上半意也。若人见般若是则为解脱。即第六七偈意也。若不见般若是则为被缚。即第四偈意也。唯忘言者可究斯旨。第三一偈。显佛二觉双圆。不可觉中而自觉。故是曰奇哉。知无众生而能觉他。大导师也。第四可知。第五东北方精进慧。以勤观真理集无量善。俱无住故。颂意。为显欲令其心转复精进。无所染着。文中由离分别如实见故。十颂分二。前九观法后一推功。前中三。初三所执无相观于中。初一举分别过。后二显无相观。一离所取。上半知于情有。下半知于理无。如迷木见鬼。知鬼是迷有。名如实知鬼。知鬼本无举体是木。名为见木。二离能取以所取空故。上半举失。如若见鬼即不见木。下半显得离于鬼见。方为见木。次三明缘起无生观。一遣所缘。然依他二义。一者幻有从分别生即是上半。二者无性即是下半。二泯能缘。上半牒前生过。有无生见同世非实。下半见等无生名真见者。三辨观益。后三明圆成无性观。一牒前二无。谓能所分别皆不可得者。即圆成性净故。二正显真性。初句体有次句相无。此二融即故无能说。三观成利益。及第二推功。文并可知。第六东南方善慧菩萨。成就般若慧鉴不动。可谓善矣。此颂。为显欲令其心转复增进。得不退转无生法忍。文中离垢解脱无体性故。十颂分四。初二见佛。次三见法。次三观成利益。后二推见有依。今初前偈赞所见。上半标赞。下半释成。智离所知心脱烦恼。兼二利故。二障难除众生难度。自强不息为希有勇健。后偈中。能见谓我如实见。如大菩萨见。次三见法中。约众生说。初偈正显。尽即有为。诸行无常速起灭故。有为之性湛若虚空。便是无为体常遍故。次二偈拂迹入玄。上半拂前无为。谓既如虚空。何有无为之相。次四句拂前有为。谓既约自性论无尽。则不坏于尽。故曰难思。尽即无尽故无众生也。后二句。观成利益见法身也。次三观成中。初偈显法空。由下半了能所见缘成无性故。上半能所之见自亡。次二句显我空。能所之法尚空。谁为能见之者。后二句显实。但除上病不除真法。二空之体及所显圆成。即真佛也。三一偈双结知佛法益。文显可知。四有二偈。推见有依者。谓佛说一道清净。故能遣有。进慧演无量门。复能遣无。想灭理现方知如来。乃住无有无之际也。又智论云。法性为实证实为际。凡夫有实未能证也。第七西南方智慧者。决断不动所以名智。颂意。为显于一切法皆能出离。文中生死涅槃皆善离故。十颂分二。初一引己励众。余偈希众同己。于中亦二。前六示迷后三启悟。前中亦二。初一人执。理实无人横计成险。余皆法执。于中初二执世法。后三双执世出世。今初。初二句明执。谓计蕴为实。不能观身实相。余皆明过。初二句执实乖理不见佛。次二句无慧不见佛。后二句但益流转后三双执中亦分为二。初二执法后一执佛。前中亦二。一立理二起执。初中上半假立。谓待前流转生死。以立涅槃。烦恼名诤。触动善品损害自他故名为诤。此有漏法诤随增。故名为有诤。有彼诤故。故生死者有漏为体。无彼烦恼故称涅槃。下半双非。谓生死涅槃。俱因烦恼假立其名。何有真实。又二互相待故俱空。二互相夺故皆寂。后偈起执。上半执下半损。后一执佛中。亦上半执下半损。执有三义。一佛佛相望。二三身等相望。三心佛相望。后三启悟中亦二。初二顺理之得。后一举佛释成。前中亦二。半偈明顺理而知。余显顺知之益。益中亦二。半偈标一偈释。云何超言。若取知能知寂未免于言。有所缘故。知自知知亦非无缘故。须能所平等等不失照故。无知之知不同木石。故云能见。后偈举佛释者。上云佛然。佛云何然。释云。觉于三世离分别故。种习斯亡为断根也。又亦无心舍于分别。名为断根。第八西北方真实慧菩萨。心不颠倒是真实慧。颂意。为显欲令增进于一切法。皆得善巧文言。于法不颠倒如实觉了。是善巧义十颂分二。前二明依实立名。名能益物。后八显名下之实。辨益所由。今初前颂明损益。受苦闻名速解脱故。受乐不闻反沉沦故。后颂叙昔以成今说。后八中分三。初三觉妄证实。是觉察义。次一双觉二谛。是觉照义。后四非觉而觉是妙觉义。今初也。初偈证实立名。初句拣似比量。无常计常常计无常等。是颠倒法。名似比量。次句证真现量。如眼见故。次句拣似现量。显真现量。谓男女天地等见一合相。名似现量。一合相相不可得故。故名为离。非唯所觉离合。亦无如外之智与如合也。下句结名。次偈例去来。后偈成现观。次一觉照者。真谛名实无和合故。俗谛非实假和合故。互融无杂名究竟解。夫实见者。尚不见实何况非实。见非实者知其即实。故中论云。一切法真实一切法非实。亦实亦非实非实非非实。是名诸佛法。后四非觉而觉者。初偈正显如智。相离名不可觉。寂无遗照故名了此。要不可得方是真修。次二偈展转释成。初偈释无一之义。上半相待而有。通同异体。下半缘生故空。则一多相尽矣。后偈上半。释前偈下半。无能所作故无所依。从业想生故是和合。下半释成上半。云何知无能所。异业想外无我所故。后有一偈结成妙义。上半所住下半能住。由无住故无所不住。谓不住有以即空故。故能住有契有实故。亦不住无无即有故。不住俱有无。无二体故。不住双非不坏二相故。能住例知。既以无住为住。则心绝动摇。方契本觉湛然常住。第九下方无上慧。名如初颂。又从法王教生当绍佛位。故名无上。颂意为显欲令增进心无障碍。文云无著无念不住法故。十颂分三。初一释已名义。次八显佛胜德。后一推功结益。次八中分二。前六内证德。后二外化德。前中亦二。前偈正明证入。后五照境显理。今初即菩提涅槃。以无所得得菩提故。处即涅槃本觉自然。故非造作。悟亦冥符则智无分别。三细已尽六粗居然。又不可以识识故无粗者。不可以智知故无细者。又有能所证名之为粗。无能所证目之为细。皆言语道断故并无之。菩提涅槃绝心行故。后五中。初偈正明照境。境即俗境有能所故。即俗而真故云无数。心同无为故云远离。是佛真法双结能所。后四遣相显理。皆蹑迹遣滞。初偈。双非显中照理灭障。菩提涅槃离有无故。次二偈释前双非。一偈半释非照义。初句是总次句能照无著。故云无念。亦不染此无念。次句所照无著。以无处所为所住故。次句不坏能所。次二句双遣性相。次二句释非无照。称理照故。后偈拂前无二之迹。言无二者但言无有二。非谓有无二。若存无二之见则还成二。以无二必对二故遣之。又遣之以至于无遣。故云三界一切空。空谓第一义空。诸佛同见。后二外化德中。前偈正显令住无住之觉。后偈释成。身即非身故无可悟。悟身见起此见如身。身见两亡真法身也。观身实相观佛亦然。故就佛结。推功可知。第十上方坚固慧者。智力成就不可坏故。颂意。为显欲令增长一切种智。文云得净慧眼了佛境故。十颂分四。初偈总叹为物兴世。智光遍照大悲勇健。次四别示悲相。初偈观机次二反以释成。后一正明兼显僧宝。次三颂半见闻利益。后一颂半结德无尽。此为终极故总举前十

    十住品第十五

初来意者。上由致既彰正宗宜显。故次来也。又前辨所依佛德。今辨能依十住。故次来也。二释名者。慧住于理得位不退。故名为住。本业下卷云。始入空界。住空性位故名为住。然住义多种寄圆说十。总言十住带数释也。下诸品有十准此可知。三宗趣者。以十住行法为宗。摄位得果为趣。四释文者。四品分二。前三当位行德。后一胜进趣后。前会无胜进者。但是趣位。方便未成位故。回向是位无进趣者。三贤位满总为趣地之方便。故亦显趣无分别离趣相故。今初分三。初品辨位。次品辨行。后品明德。初亦名解文分七分。一三昧分。二加分。三起分。四本分。五说分。六证成分。七重颂分。今初。何故入定。略辨六意。一此三昧是法体故。二非证不说故。三显此法非思量境故。四观机审法故。五为受佛加故。六成轨仪故。余如玄说。文有三别。一入定人。法慧入者是众首故。余入则乱不调伏故。显十住法慧能说故二入定依。谓承佛力推功化主表无慢故。三入定名。为拣果定故云菩萨。任性能知观解善巧。故名方便。十住各摄多门善巧。故云无量。心诣于法故云入也。又一切三昧皆有三相。谓入住出。五识对境意从门出。远境护根意识却入。此通权小。今即照之寂故名为入。即寂之照故名为出。入已未起故名为住。余三昧等并如前释。二以三昧下加分。于中三。初总辨因缘。二明加所为。三别显加相。今初又三。一标加所因。二加缘显现。三赞说因缘。今初。谓以三昧力故。论云。所以偏加金刚藏者。得此定故。前由佛力能入。今由定力佛现。互为增上力相。云何谓无作三昧。显自觉智寂不失照。冥同佛心故。感佛现三业加也。二十方下加缘显现。来处佛数皆云千者。望行犹劣故。多佛加者。显于法及法师增敬心故。又显诸佛同说故加。佛同名法慧者。得法不异故。论云。此菩萨闻同己名增踊跃故。但诸佛于此住门中现。皆名法慧。以法力故。法应尔故。普现其前者。不来而至故。三告法慧下。赞说因缘。于中二。一赞有加因能入定故。言汝能者。希越之辞。此定难得汝今乃能入故。举定名者。向来默入。众未知名故举叹之。令众仰故。二善男子十方下。双说加定因缘。于中先别显四因。一伴佛神力。诸佛自说者。令众敬仰故。二主佛宿愿。三主佛现威。四法慧善根。略无大众机感。后入此三昧令汝说法。二句结因所属。谓由上四事前三为缘。第四是因。因缘合故。入此三昧。故前四定因。令汝说法即是加因故。论云。何故加。为说此法故。故十行十向之中。皆云令汝入是三昧。而演说法故。又此令汝说法。亦是后文之总。然十地论。释诸佛遮那皆由先愿故加。则此四段俱是加因。以彼经中诸佛但云加汝威神。遮那则云本愿力故加。古人便将诸佛之加。为得定因。下之三缘转为加因。便令得定无后三因。则又字何用。既结云令汝入是三昧。何得后三不为定因。非唯违经文理亦乃乖论所释。如实义者。此之四因通于二义。一由此四为得定因。如上所辨。二由后三复是加因。诸佛即以愿力而为加因。论主为显斯旨。故云彼佛先作是愿今复自加。问加之与定何先后耶。若先定后加。则不应云汝能入此三昧。此是十方诸佛共加于汝。乃至云及汝善根力故入此三昧。若先加后定则不应在三昧分后方说加分。又十地论云。何故加。为说此法故。不言为入三昧故。又云。唯加金刚藏不加余者以是菩萨得此定故。既俱文证如何会通。古人答云。加定同时。谓若未定而加。则散心不能胜受。若未加而定。则自力不堪入此深定。是故同时。此解亦违教理。现言入三昧竟。诸佛方现身称赞得定。及说加所为竟。方与三业之加。而云同时岂不违文。若言同时为因不成。斯则违理。亦不应引俱有因证。以此二事容相离。故。若正释者。加有二种。若约内外。善根威神愿力冥资。令其得定则在定前。若约与智。赞述摩顶劝说三业显加。则居定后。二文昭著何其惑哉。第二为增长下。辨加所为。且对加因名加所为。然加所为正在说法。此十亦即说法所为。展转相成。文分二别。初十句别明。后一结说。前中文含二意。望加所为即是别说。望于说法即说法之意。谓加为说法。说法为何。为增佛智等。然说法所为即加所为。于十句中初总余别。总谓说十住法。今信解诸菩萨修行。增长性习二性生菩提智故。又此因智即同佛智。亦得言增。增智何用深入法界等故。九句五对。初二证真了俗对。谓入无入相故云深入。了相了性故云善了。次二无障无碍对。由入法界离烦恼碍。由了众生离所知障。次二圆因趣果对。谓巧安真俗无等故因圆。入萨婆若故云果满。次二识法知根对。后一句虽非文对而是义对。谓内持诸法外说利他。所谓下总结所说。谓若说十住。则前所谓皆得成就。第三善男子下。正辨加相分三。先口加劝说以增辨。二意加冥被以益智。三身加摩顶以增威。今初可知。二是时下意加中。先加后释。前中与十种智。初总谓四无碍解智。是说法所依故余皆乐说无碍。一无著者论名不着。辩才于所说法无住着故。即七辩中捷辩。须言即言故无著也。二无断知即无断辩。谓相续连环终无竭故。三无痴者即是迅辩。明于事理心无痴闇。言则迅疾如悬河故。四无异者即应辩也。应时应根无差异故。五无失者即无错谬辩。凡说契理无差失故。六无量者即丰义味辩。名数事理皆无量故。七无胜者。即一切世间最上妙辩。此有五德。一甚深如雷。二清彻远闻。三其声哀雅如迦陵频伽。四能令众生入心敬爱。五其有闻者欢喜无厌。具斯五义故云无胜。上即七辩。八无懈者。通策前七无疲倦故。九无夺者。具前总别。无能制伏令退屈故。后何以故下征释。先征意云。诸佛有力能与有慈能普。何故十智唯与法慧。下释云。法慧得此三昧。法尔如是得诸佛加。三是时下身加。一令增威。二令起故。然三加同时随义为次。承前说便故先语加。为令起定身最居后。准地论。经有诸佛不离本处。则去住无碍。手又不延则延促无碍。同时触顶一多无碍故。是奇特。要摩顶者。楞伽云。若有不为如来二种神力之所建立。而能说法无有是处。一者身面言说神力。即前语加。二者灌顶神力。即智灌心顶手摩身顶。顶受摩者上禀尊力故。右手者。法慧所说顺理机故。诸佛随顺法慧说故。第三法慧菩萨下起分。略由四意。一三昧事讫故。二已得胜力故。三说时至故。四定无言说故。此四后后以释前前

大方广佛华严经疏卷第十七大方广佛华严经疏卷第十八

        唐清凉山大华严寺沙门澄观撰

第四告诸下。本分文分为三。初总显体相。次标以许说。后别陈其名。今初。然十住体略有三种。一约所依。即前三昧。依此说于十住法故。论云三昧即法体故。二者约本。即下所辨。三克性体。若约所缘。即真俗二境。若约能缘即悲智二行。二境既融悲智不别。境智冥契同一法界也。今约本体。若直观经文。则住处二字总示其体。广大已下略显其相。住三世佛家。结示住处。今依地论类例以解。则住处为总余皆是别。总即示体此云住处。十行名行业。十向名愿。十地名愿善决定。皆当位体也。而得名不同者何耶。然三贤十圣。皆以菩提心而为其体。菩提心有三。一者直心。正念真如法故二者深心。乐修一切诸善行故。三者大悲心。救护一切苦众生故。所念真如。亦即本智本觉智故。后二显是恒沙性德。然此三心有一必兼余二。而三贤互有增微。十住直心增故。故名为解。解为行愿本。故首而明之。十行深心增故名为行。依于前解以起行。故十向大悲增故名为愿。回前解行愿诸众生离苦得乐故。十地三心等证故名决定。而大悲为首故举其愿。是以论云愿善决定者。如初地中发菩提心。即此本分中愿。十信通信此三。等觉此三等佛。故知菩提心是诸位通依。今此住位名住处者。若从增胜。则以深般若住于真如。即复由此。而为行愿之所住处。若从通说。俱住上三菩提心家故。住处。梵本名为俱罗。此云家也。家即家族。是以旧译名为种性。即四种性中习种性也。良以此家菩萨所居故。翻名住处。下文还就佛家以结。别中句乃有二。义乃有三。一广大与法界等。是胜住处。然地经总句。是于决定不应学彼。此中广大即是胜义。其法界言含于四义。一正念真如。同理法界深无际限。胜诸凡夫。亦胜二乘偏真理故。二普该菩萨无边行相。大悲深心同事法界无有边量。胜二乘故。三者三心无碍。同无碍法界事理融故。四同圆融法界。一一尘中无不具故。此与第三胜权菩萨。二虚空等者。是因住处。因有二种。一无常爱果因。是因如虚空。依是生色色不尽故。二常果因。今是地前故阙此也。古德又云。一一位中。如空包含无边行海。又如空周遍非至。非不至。又如空无碍故。三住三世诸佛家。准论此名不怯弱住处。谓菩萨所住。即佛所住故名佛家。进住佛家是不怯弱。若直释经文。即结示也。谓向言住处何所住耶。谓住佛家。佛家即是大菩提心。诸佛住此生菩萨故真如悲愿究竟唯佛方能住故。言三世者。是赞胜也。二彼菩萨下。牒以许说可知。三诸佛子菩萨住有十种下。别陈其名。文有三别初标数引证。二依数列名。三总结显胜。今初。谓三世佛果无不由此。十住因成。如大王路法尔常规。故同说也。二何者下。依数列名。初发心住者。璎珞云。是上进分善根人。若一劫二劫。一恒二恒佛所。行十信心信三宝。常住八万四千般若波罗蜜。修一切行一切法门。乃至始入空界。住空性位故名为住。依仁王起信。即十千劫来修信行满。入位不退创起大心。发心即住名发心住。三种发心中即信成就发心也。二治地者。谓常随空心净。八万四千法门清净洁白。故为练治心地。使悲智增明名治地住。三巧观空有增修正行故。四生佛法家种姓尊贵故。五带真随俗习无量善巧。化无住故。六成就般若故闻赞毁。真正其心念不动故。七入于无生毕竟空性。心心常行空无相愿。止观双运缘不能坏故。八心不生倒。不起邪魔破菩提心故。九从法王教生解。当绍佛位故。十从上九住观空得无生。心最为上故。诸佛法水灌心顶故。然住十住得名有三。谓四八九十从喻为名。第七离过受称。余约功德从其所喻。皆持业释。若从能喻或依士释。三是名下。总结可知。若定位者。略有十义。一依唯识等五位之中。即当初位。言五位者。一资粮位。即是三贤。从初发心积习福智。为道资粮为众生故。修解脱分善。二加行位。顺解脱分既圆满已为入见道。复修加行。亦名顺决择分。三通达位。即是见道。谓初入地二种见道。四修习位。始从初地第二住心。乃至金刚无间心位。名为修道。五究竟位。金刚心后解脱道中。尽未来际皆此位摄。二依摄论。第六说有四位。即当初位之初。言四位者。一胜解行位。始从十信终于地前。余三见修究竟。同五中后三。三依瑜伽四十七说十二住。当其第二之初。言十二者。一种性住。谓彼菩萨性自仁贤。性自成就菩萨功德。任持一切佛法种子。性离粗垢。不能现起上烦恼缠。二胜解行住。谓从初发心。乃至未得清净意乐。所有一切菩萨行是。三极喜住。四增上戒。五增上心。六七八三名增上慧。分成三种。谓六觉分相应增上慧住。七诸谛相应增上慧住。八缘起流转止息相应增上慧住。九无相有功用住。十无相无功用住。十一无碍解住。十二最上菩萨住。十三最上如来住。前言十二住就菩萨说。加后如来为十三住。第二即是三贤。第三已去如次十地。四亦依瑜伽及显扬第七。于十三住建立七地。一种性地。二胜解行地。三净胜意乐地。即前三住。四行正行地。谓从第四乃至第九住。五决定地。即第十住。六决定行地。即第十一住。七以后二住为到究竟地。前六唯菩萨。第七菩萨如来杂立为地五依仁王下卷。说十三法师各住一位。即当第一。言十三者。一习种性。二性种性。三道种性。四善觉摩诃衍。五德慧。六明慧。七尔焰。八胜达。九常现真实。十玄达。十一等觉。即八地。十二慧光神变。即当九地。十三观佛菩萨。义当十地及等觉。而佛非十三之数。六依仁王上卷。五忍之中。此当伏忍之下。言五忍者。谓伏忍信忍顺忍无生忍寂灭忍。各有上中下。如次配三贤十地等觉妙觉。七亦依仁王五十二位。当其第二。八依璎珞四十二贤圣位。当于下贤十住。以不立十信。十信摄在十住中故。九依璎珞六种性。亦当第一。言六性者。一习种性。二性种性。三道种性。四圣种性。五等觉性。六妙觉性。若依楞伽等无复地位。十依此经说四十二位。无别资粮加行等名。然所说位依法性。立行布圆融二俱无碍。如玄文辩。十信开合已见贤首品。第五佛子云何为下。说分。即是行相。释此十住即为十段。一一段中皆先征后释。释中皆先明自分后明胜进。又前是住位后是起行。今初发心住。先征可知。释自分中二。先明发心之缘。后正明缘境发心。今初。文列十缘义含四因。谓信悲智及种性也。见佛世尊是初总相。发菩提下。结前生后。中间十句别显不同。一形貌容仪。二显色大相。三具随好故人所乐见。上三观外相也。四时乃一出。出便利益故为难遇。此通内外。五十力无畏降魔制外。此明内德。六神变难思即神足论。此唯外用。于上六中随见一事。发生净信欣心上求。此若可修我定当取。七闻授记。含于二义。一闻授记作佛希预其数。二闻记当事希得此知。皆记心轮。八听教诫。知恶可断善可进修。即教诫轮。上皆信智为因。九见受苦起悲心。未必闻教。以种性内具法尔慈恕。即悲因也。十闻广大法谓佛功德。义兼法灭或传或护。因通悲智种性之因。义通前十。此之十缘。与贤首品所引瑜伽四缘。但开合之异耳。谓前六见佛缘。次二闻法缘。次一见生受苦缘。后即见法灭也。后结前生后者。唯证菩提。方成前事结前也。求一切智。生后。缘难得法而发心也。第二此菩萨下。正明缘境发心。前言求一切智。十种智力即一切智。文有标征列名结数。而义见初品。大同初地。为得十力故等。又此十力于一实智而开为十。化生事足义含悲智。故略举之。非不缘佛余之功德。第二胜进文分为三。初总标次征列。后征释。今初。谓欲求胜位应自劝励亦劝他学。列中有十不出悲智。供佛为总。通财及法。下九为别。行下九事真供养故。一乐住生死大悲为首故。智了其空无所惧故。二住为主道除恶。三即能导理教之法。四示果令欣。即教之所至。五学佛德行以为能至。六成德依缘故生佛前。七寂前上求下化之纷动。八寂必远离生死轮回。九不失悲故常为物依。亦是总结前义。诸所施为皆为众生大悲增上故。问八远离生死初令乐住。此云何通。略有三意。一劝物远离自处无厌。二要自无缚方能摄物。三即智之悲故乐住生死。即悲之智远离轮回。故瑜伽云。菩萨厌离生死。过于二乘百千万倍。非不厌也。斯则不断生死而入涅槃。不动真际常随流转。成不住道。又初既乐住生死。六复云何生诸佛前。亦有三义。一为诱物故。二求摄物之方故。三悲智无碍故。又十藏约实。智契舍闻。诸佛土不愿往生。此约权不坏事故。生诸佛土。三何以下。征释。何须学此。令得通别二种益故。别谓增胜广大。此之别益皆希后位。准下颂文亦令不退转故。有所闻下。诸位通益。以解从内法故不由他。他有三种。一他人。二者心外。三者性外。自解亦三。一者熏习成性故。能自解。二了唯心。三了唯性故。下云知一切法即心自性。若尔云何复言有所闻耶。谓泛尔闻故。或自披寻。闻乃约法开悟约义。必不假人委曲指授故。不由他究竟。则是佛无师智。下诸位中并同此释。有云。从自种生云不由他。但是初意。何足可尚。又引下文。虽知诸法悟不由师。然求善知识无有厌足。亦非此意。彼据双行此约自悟故。第二治地住中亦二。先征可知。二释中。自分内文有四别。一标二征三列四结。下诸自分皆仿此知。列中十心有其二义。一于一一众生各起十心。二为辨差别对八种众生。一于怨众生非直不念加报。亦乃授与利益。二于贫苦众生欲令远离故起悲心。三于危惧无乐众生。令得乐具不尽。四于恶行众生。令安住善行。五于得乐众生。以矜愍心不令放逸。六于外道未发心者。摄令正信发心。七已发心同行者。守令不退。八于一切摄菩提愿众生。取如己身。于此开二。谓于乘大道集进趣者。推之如师。集具足功德者。敬之如佛。此十大同第二地集义中释。以斯十心。治自心地。二胜进亦三。列中十法有通有别。通相可知。别依展转。一总求多闻。为二利行依。二闻已闲静思修。三闻必依友。四于友求请言必和悦。五问不非时。六不怖深法而不能受。不怯行法而不能行。七以思慧力解达深义。非但多闻于义不了。八如说修行。涅槃经。说亲近善知识听闻正法系念思惟如说修行。是大涅槃近因缘故。今展为十。九成行伏惑故离愚迷。十观智照理决定究竟。故安住不动。三征释。所以修者上十多约智。以智导悲令转增也。通益可知。第三修行住。释中先明自分。是护烦恼行。后明胜进是护小乘行。前中。然此十无常大同三地。彼论具释。引中边释已见问明。既文义包含略举一两。论云命行不住总名无常。此总句也。然复有二。一者念念无常。二者一期无常。于何无常依五盛阴。逼迫相故苦也。瑜伽三十四云。由无常行作意。为先趣入苦行。由苦无所得行趣入空行。空故不自在。由不自在趣入无我。此四即苦下。四行相也。五无作者。但缘有故。由念念无常故无造作。由皆苦故。无有乐味但于下苦中横生乐想。即一切世间不可乐想。以彼空故。万法无体物无当名之实。以无我故无有处所。非在色中乃至识中。无分别者。观能取也。无坚实者。观所取也。问涅槃比丘作无常想。佛呵倒惑。云何入住作无常观。答彼但得名不得其义。以无常等该涅槃故。故佛呵之。今但说生死故无有失。又无常者。未会法身故。苦者。未得涅槃故。空者。无善有故。无我者。未得八自在故。则前四句自说生死。次无作等四自说涅槃。常故。无作乐故。无味我故不如名。净故无处所。然二理不偏照与之符。犹悬镜高堂万像斯鉴。又初四句则因缘生灭。是无常义等。次四则不生不灭。是无常义故云无作。五受阴洞达空无所起。是苦义。因起有苦。起即无起故无味也。诸法毕竟无所有。是空义。人法二空空亦空故。故不如名。于我无我而不二。是无我义。诸佛或说我。或说于无我。诸法实相中无我无非我故。无处所。故庵提遮经。说不生不灭是无常义。生灭却是常义等。瑜伽四十六云。云何菩萨观一切行皆是无常。谓观一切行言说自性。于一切时常无所有。如是诸行常不可得。若得斯意则入中道。若依中边论约三性说。则初后二性不生不灭。是无常义。依他起性则生灭。是无常义等。又无作者。非常非无常故。无味者。非苦非乐故。不如名者。非空非不空言不及故。无处所者。非我非无我。不在生死及涅槃故。无分别者。念想无故。无坚实者。实与不实相待有故。后胜进中是护小乘行。小乘不求种智。不欲广知故。十中初三是作佛事处。众生是所度。法界是能度。世界是度处。次四界是起见处。外道计大为诸法本。小乘计大为诸色因。又成身之体。后三界是系缚处云何观耶。一观其相委细而知。二观其性甚深平等。三征意云。但总观无常何用广知。释意云。观空不碍广有知见。性相兼了法智增明故。第四生贵住。自分中有五。谓释名标征列结也。从圣教生者。谓多闻熏习。等流无漏教法生其智故。又下偈云。佛子于法如是观。从佛亲生名佛子。此约能说人也。又偈云。了达诸有无所有。超过彼法生法界。此约理也。上三义皆能生后一义。兼显所生之处。又能说所说能诠所诠。成此三异。从此三生并可尊贵。列中十事同四地。十种法智但有开合耳。既从圣教生成就四智。教化众生。一自住处智。不退转故亦所生也。二同敬智。于佛净信故亦能生也。三真如智。善观察法故。亦所生处也。法即法界。四分别所说智。即余七句。谓了众生空有。佛土权实世界染净。行业善恶果报苦乐。二种生死四种涅槃。具如常释。后十胜进。初三解了通于教理行果。次三修集行法。次三誓当满果。后一别了理法。后征释。意欲进后位真俗平等故。遍观三世不殊方知平等故。第五具足方便住者。自分十心亦是方便也。胜进十心亦具足也。今自分中。即第二住发起此心。今以所修善根正向所为。例前解释文并可见。今别为一势。谓初是总句。救苦护善故。云何护善。一授与乐因如经饶益故。二令得乐果谓安乐故。三哀愍妄乐不令着故。四云何救苦。度一切苦得解脱故。何者是苦。苦有二种。一三灾八难。二二种生死。云何能离。一教生净信。二由净信故授以三学。令诸根烦恼皆得调伏。云何得乐。谓咸证涅槃。究竟灭苦是真常乐。初句九字流至于此。后胜进中。前六义含深广后四唯显甚深。云何广耶。一无涯畔。二无分限。三离算数。四言思莫俦。五色类非一。六非称量尽。所言深者无边。谓非有非无非断非常故。无量者。常一刹那无长短故。无数者。非一非异不堕数故。不思议者。即妄即真。言语道断心行处灭故。无量色者顿现身器故。不可量者。出二量故。后四中。七为总句。人法空故。此云何空。八约能成。非是自他共所作故。九约所成。内外推寻无所有故。十无自性。释成上义。无性故空。无性故谁能作。无性故无所有。非断无也。又七八九是三脱门。三征释意云。双明深广。性相交彻。则转复增胜形夺两亡。皆无染着成般若故。第六正心住。初自分内。由成就般若了法性相故。皆不动名为正心。初四约所敬三宝。由了法平等声如谷响故。于赞毁不生欣戚。又在执应毁就理应赞故。故商主天子经云。无有不毁语言。而能至其解脱中故。次三约所愍众生。有量无量是断常边菩萨不堕。有垢无垢是增减边菩萨远离。易度难度是苦乐边菩萨不住。又有垢者难无垢者易。又亦反此。以不发心不知垢故名之为无。后三约所知法界。有量无量亦是断常。余二增减。已得正心故皆不动。又约众生大悲大愿无限量故。了法界性超量非量故。知法界相缘成世界。说有成坏非成坏故。体有相无体无相有。皆自在故。况并音声性离。何足动哉。后十胜进中。然劝学者。通闻思修。偈云听闻乃一义尔。列中一自性之相不可得故。二缘起想成故。三圆成性净故。四能成非有。五所成无实。六自性本空。七空性亦离。八喻上缘现。九喻上想生。十总离取舍出没想故。此与六地取染净法分别慢对治文多相似。三征释云。此如顺忍欲进后位不退忍故。第七不退。住自分十中初三三宝。次二别显前法。次三别明初佛。后二约佛境智通佛法也。而十皆言不退转者。大同前位。然此位中。已入无生知所闻法毕竟空故。又前位会事入理令心不动。今此事理双现。而心不退。后位从理向事。唯随事行转纯熟故。是故前位于三宝等。但闻赞毁忍之尚易。今闻有无利害转深。成忍则难。故过前位。又前言不动但能正心。今云不退有进趣义。又权实方便皆悉通达。有无等言皆有在故。佛则色相虚无。应机为有。法则离相离性不坏相性。菩萨同佛。次二中约事行为有。入理行为无。出离有二。一约自行。义同前文有垢无垢。亦约事理。二就化他。悲故不出由智故出。次下三句。亦论有无何异初句。初句邪见为无正信言有。此三亦非正见。虽许有佛不遍三世。或言过去入灭。是故非有。未来未成安得为有。现在生界未尽佛愿未满。今有佛者皆应现耳。俱有可知。今知其谬说为无正说为有。后二句中初智后境。佛智有尽等者。一竖约智体。以尽智故名为有尽穷未来故名为无尽。又若入永灭则名为尽。不永灭度是即无尽。约从修生则名为尽。即同无为故名无尽。二横就所知。谓法无尽故智亦无尽。以无尽智称无尽法。则名为尽故。法华云。唯佛与佛乃能究尽诸法实相。智度论云。如函大盖亦大。还将无尽之智知无尽法。是故如来名一切智。今菩萨穷究。知依竖义半了半不了。知依横义二俱是了。又相待说有尽无尽。就理而言并非二相。后一就境约性一相。约相非一。知其随说皆非遍知。后胜进中十事五对。此大同地中乐无作行。对治发起十种殊胜行。由此知其事理无碍。至地则得权实双行。初一多对。总含三义。一约权实。于一佛乘说无量故。虽有众多皆佛因故。二约事理。理能成事说一即多。事能显理说多即一。三约事事无碍有同体异体。义如上说。二文义对。文随于义。转变密意故。即如初句一言随于多义。义随于文。显了直说故。即下三对。但显事理一无碍义。若望下偈云如是一切展转成。则文义亦通事事无碍。三遍计理无情有无二。四依他幻相性空无二。五圆成性空与不空二如不异。又上三中。皆以三性三无性相即准思。三征释中。善能出离者。不沉没于事理。成后位自在也。第八童真住。自分中初三。三业无失。永离习气唯佛得之。任运无功在于八地。此中多同八地。能行无漏故。得无失。无十不善失亦无错谬失。此三自行亦为化体。余皆利他。初一能化身。顿悟菩萨随愿受生。贵在利人不拣净秽。惭悟地前。许受变易意生身故。次四以能化智知所化境。即十力智之四智也。次一化处后一化法正化。后明胜进是不动行。初六于刹自在。后四三业自在。此同八地。若色若土皆自在故。初一总知分齐。次二作用持兼愿力。四十眼智观。五有佛便诣。六游以化生。后四中。一意二身三语四通三业。下征释意。为得善巧入于后位。辩才自在故。第九王子住。初自分十中。一知六趣四生受报差别。又知九种命终心受生差别故。二知现行烦恼。三知种等相续。非如现行有间断故。习气有四如九地说。四知诸行作业所入法门。皆善巧故。上四多同九地十种稠林。彼据入地尤多细密。故名稠林。此但云知。五知法药。是智成就义。六知法师轨仪。七知所化处。八知化时。随根生熟不差失故。后二依二谛说。皆说成就也。后胜进十法皆言法王者。既言王子仿佛之仪。合子法度。而言处者。即是位也。如世王子之于父王。今对辩之。一善巧者。言辞安立。及诸伎艺悦可王心今此菩萨学佛法王说法言辞。安立权实善巧方便。以悦佛心。二轨度轨。谓坐立动中规矩容止可观。度谓升降出入往来进退可度。此明无亏戒行。住佛威仪也。三宫殿者。父王在宫即行子礼。父王处殿即行臣礼。若处涅槃正殿。即令万行归宗。若处慈悲宫室。则子爱含识。四趣入者。趣者。就也。谓泽及万人。入者。收也。谓庭来万国。菩萨则无机不就无德不收。五观察者。入则观父王察其声色。出则观群臣知其贤愚。菩萨入则观佛教理。出则审机可否。六灌顶者。十地有文。出现法喻双辨。七力持者。聚人则以财为力。慎危则以戒为力。降怨则以忍为力。广业则以勤为力。定乱则以静为力。谋安则以智为力。固众则以仁为力。制敌则以众为力。菩萨六度四等。万行总持皆力义也。持财以俭持众以信。持安以不憍持力以不奢。余可类取皆能持也。八无畏者。为上无亢则无忧悔之畏。节俭财色则无病畏。居上不憍则无亡畏。为下不乱则无刑畏。在丑不争则无兵畏。三不备者。永无死畏。菩萨修行。离老病死五种怖畏。得十无畏。九宴寝者。昼无故不内宴。夜无故不外寝。宴于侧室寝于正处。菩萨入定同佛。不过明以耽其味。不昏沉以滞于境。无幽不得其味。正定不易其心。十赞叹者。乐则歌赞苦则哀叹。赞音宜和乐。叹音宜哀思。其情切其辞文。菩萨应仰赞佛德哀叹众生。情诣于理使令欣厌。二征释云。欲令增进得于后位无碍智故。第十灌顶住。文亦分二。先征后释。释中亦二。先自分后胜进。前中二。初有十句所成德用。后有十句赞胜难测。以位终故加此一段。前中前五。了世界无碍智。后五成就众生无碍智。以智度满故。多同大尽分智成就说。后十赞胜。及后胜进皆是神通。有上无上分中义。今赞胜中。前四即业自在不可知。一身二身用三十通四通用。后六心智自在不可知。初三即三达圆明智。四知器世间自在智。五定心所现之境。六大智所知之境。并深广故。下位不知。后胜进中三。初标即学佛一切智。一切种智。以当位满灌顶成佛。以摄诸位皆此中具故。如法界品海幢处说。玄中广明。二征列中。一学佛三达智。此是总句。二佛法智者。觉法自性善出现仪。三事理无碍。四事法横广。五大用周遍。六身智光照。七神力持令不坏。法力持令进善。八穷尽所化。九知化法。十了化主。三征释成十胜智。复更学者。为欲成佛种智位故。然上所释大依十地。第六显实证成分中二。先现瑞显实。后菩萨证成。前中先此界有动地雨供。一万佛刹犹劣行故。后如此下。结通。二又以下。菩萨证成。于中二。初能证现前。二作如是下。发言赞述。于中四。一赞其所说。二我等下。举同显证。此有四同。一能说人。二所说处。三者会主。四所说法。初后与此同。中二但彼同者。法慧表解。不可不同法。若不同岂名为证。中二异此者。表人异道同处殊法一。方表通方之说。成证义也。若亦同此。将谓余异名界佛不同说也。若尔何故同名法云妙法。不多举耶。为有表故。谓所说法该于十地故。非粗浅故。就所说中。众会约人眷属兼法。文句义理主伴皆同也。三佛子下。举因结成。四如于此下。结通广遍。谓非唯来此为汝作证。于余处证亦同证此。弥显所说是通方也。此是彼菩萨结通。不俟经家结通也。问此经何要十方同说。答引摄之教随机不一。诸方有殊圆实之教法尔常规故。十方同说十方如来同一道故。三贤十圣无异路故。问说此经处。何要遍于十方。答能诠如所诠故。所诠义理无不同故。表位优劣证有多少。据其所说无处不该。有云。此上瑞应证成应在偈后。有四因故。一未说偈经犹未了。不应先瑞先证。二瑞证本为证经。既不证偈则偈应非经。三证辞不应。云文句无有增减。四若许瑞征合在颂前。颂中应颂二分。假使梵本如此。译者即合回文。此乃静法佳判。今为一救。理或可通。为欲表说证同时故。然文不累书。编之作次。若全居末。则似说竟方证。若更居初未说复何所证。故置于散说偈文之际。深有以焉。诸会文同皆仿此释。第七重颂分中。总有一百颂分二。初九十一颂正颂前法。后如是十住下。九颂结叹劝修。前中十住即为十段。初住中有四十六颂。文分为四。初三颂颂发心缘。次三十二颂缘境发心。次十颂胜进所学。后一总结。今初。尊重即前众生乐见。第三偈即广大法。二中分二。初十颂缘十力发心。一颂一力。初中谓。以因感果斯为是处。从我心冥性等生。无有是处。余文可见。二二十二颂别显所求。长行结前生后。云求一切智。今偈略显一切智相。此二十二颂。一颂一智。或有阙智了等言者。盖文略耳。今以类例相从摄为十智。初一俗谛智。次一真谛智。三一偈神通智。四五颂解脱智。五过去下。一颂劫刹智。六一颂三乘智。七有七颂三密智。谓二颂身密。三颂语密。二颂意密。八一颂唯心智。九过去下。三颂。一多无碍智。十有一颂权实双行智。三菩萨如是下。十颂。颂胜进十法。一颂一法。皆言令其不退转者。显劝学之意也。不退有三。一位不退。七住已上。二证不退初地已上。三念不退八地已去。今此近希位不退故。若约圆教当位。从信入住得位不退。初发心时成正觉故。四一颂总结亦是引证。第二住五颂。初二颂自分。次二颂胜进。后一颂结说。第三住五颂。前二颂自分。后三颂胜进。第四住六颂。初三自分。次二胜进。后一结叹。第五住五颂。初三颂自分。次一颂胜进。后一结叹。第六住四颂。初三自分。于中后半颂。是显不动之意。二一颂胜进。第七住四颂。初二自分后二胜进。第八住五颂。初三自分后二胜进。第九住五颂。初二自分后三胜进。第十住六颂。初四自分。于中三颂。颂所成德用。一颂颂赞胜难测。后二颂胜进。第二大段结叹劝修。九颂分三。初一颂总叹十住。次六别叹发心住。后二结叹初心。况出修行。十住位竟

大方广佛华严经疏卷第十八大方广佛华严经疏卷第十九

        唐清凉山大华严寺沙门澄观撰

    梵行品第十六(从第十七经尽夜摩宫中偈赞品)

四门之中初来意有六。一前是正位。今辨位中之行。故次来也。二前明诸位别行。今辨诸位通行。三前通道俗。今别显出家所行。四前明随相差别。今显会缘入实。五为显入住之因。谓自他二种梵行净故。则入初住也。六别显初住成佛。则类前诸位。位位成佛不由他悟之相也。具上诸意有此品来。二释名者。梵是西域之音。具云勃嚂摩。此翻为净。拣上净行立梵行名。离染中极故名为梵。即梵为行故名梵行。持业释也。亦有云。真境为梵智契为行。或涅槃为梵修因为行。此二依主释。梵行以何为体。体略有三。一者即戒。戒能防非故得称梵。二者四等。三者是慧。涅槃五行中。梵行即四无量。亦七善知。今此品中具含三义。然此三各二。戒有二者。一随相二离相。今文即相无相。依如来教染衣出家乞食正命。是随相也。于修无所著。则戒相如虚空。即离相也。四等二者。一有缘二无缘。生缘法缘皆名为有。今即缘无缘观察众生。而不舍离是有缘也。了知境界如幻如梦。即无缘也。慧有二者。一有分别二无分别。今即分别是无分别。谓于十法一一推征。是分别也。观无相法了知平等离念契玄。即无分别也。上三中二义。各初义通凡小。后义唯大乘。此二不二为实教梵行。若一行具一切佛法。方是华严之梵行也。梵即是净。但以性净故即行净。行净故则智慧净。智慧净故则心净。心净故一切功德净。乃至成佛功归于行。故云净行。然前信中之净。随事造修悲智兼导。至此纯熟了心自性。悲智无二故。小有不同。三宗趣者。即以悲智无二事理双修观行为宗。疾满一切佛法为趣。第四释文。文分为二。先问后答。今初亦二。先叙问答之人。正念天子问者。天者净也。表所问事理染相绝故。梵依天行而得成故。念与无念二而不二。为正念也。法慧答者。表巧慧穷法。后佛子下。正显问端。于中先举所问境。次云何下。述所问相。问相有二。一问行净所因。谓随相持戒之梵行。云何得离相之清净。故不应言净劣梵也。二从菩萨下。问因所得果。第二法慧下答。答前二问即为二别。先答行净所因。后若诸菩萨下。答因所成果。斯即观成利益也。今初分二。先明自行清净即离相之戒成。后复应修习下。明利他之行净。即无缘之四等二种智慧。通在两文为能净故前中分四。一总示所应。二所谓下。列名略释。三若身是下。广陈修相。四如是观已下。显观成相。今初。作意者。不堕无记故。观察者。以慧推求故。二中初列十法。即列上所缘之境。后应如是观下。释上作意观察所以。唯令观十法者。一为成圆数。二梵行缘体不离此十。谓身口意三是行所依处。三业行因三宝行缘。戒谓行体。问以善三业归于三宝。得受随戒何要观耶。答若不观察。取相坚持同权小故。见戒从缘起心持戒为迷倒故。云何观耶。广在下文。今略释之。意云十中随一。若是余九即非明假众缘。以显无性。况十中各十。一一推征。相尽理现名真梵行。第三广陈修相。即寻伺观也。十法即为十段。前六通染。是故但约染净相违。名非梵行。亦不析破彼法自体。后四唯净顺于梵行故。分析体空何有梵行。十中各先总牒观境。后以十事征显其非。今初身具中。一非善者。身通不善体非顺理。梵行善性体能顺理。二法既殊明身非梵行。梵行何在他。皆仿此。当知梵行之言贯通诸句。二体是无记非可轨法。三饮食资成。四自相臭恶。五自性不净。六种子住处等皆悉可厌。七四蛇违反。八业惑所依故。九是身无知。又要当死究竟不净故。十八万户虫户有九亿。全以虫聚成其身故。今此梵行体是可轨性。能澄净芬馨清洁。贤圣所欣顺法顺教。体无杂染。与智相应众善集成。彼岂当是于十事求梵行叵得。当知梵行离相离性下九准之。二身业者。身之作用名为身业。语意亦然。十中四仪无记。余六通善恶故非梵行。三语具十事。初一语体次五语缘。谓风触七处而出于声。此略无脐轮牙齿。后吐纳等四。是辨语相十事。望业皆是语体。此唯无记故非梵行。四语业十事通善恶故。亦非梵行。安立说者谓假施设。随俗说者。随世名言。余可思准。第五观意十事。觉是寻求观是伺察。觉粗观细是不定法。言分别者。以慧拣择。三分别中是自性分别。七分别中任运分别。种种分别者。三中随念计度故。七中余六。谓有相无相寻求伺察染污不染污故。忆念者。追忆曾习唯缘过去。思惟者。以慧筹度通去来今。并有一多各成二种。上六皆别境摄。种种忆念义兼恶作。幻术通思通念。眠是不定意识亦行。但取境昧略。轻眠有梦。亦通善恶觉之势故。此十是心所。不离心故同名意也。征破准前。第六观意业十事。皆意之用故名为业。约遍行五征之。一思二想次四是触。后四是受。作意一种总遍十段。故前云作意观察。即上四段亦各一蕴。此中思等与意何别。但思等心所有二义故。一扶持心王属前所摄。二依心起用。属此位收故。多从受境以辨。若欲破者。既约遍行通于三性故。非梵行余准前知。第七观佛十事观于三身。若依小乘。初五法身。以无漏戒等及眷属无漏五蕴。为法身故。次二报身。以三祇百劫所修感相好故。次一化身。神通化现故。业行通为三身之因。果报通语三身之果。若依大乘。前八皆是化身。后一报身。业行通语二身之因。涅槃是果离系果故。菩提是报报本愿故。今一一推征。若一是佛余者应非。一一皆佛则有多佛。和合成佛则无自性。故中论云。非阴。不离阴。此彼不相在。如来不有阴。何处有如来。阴合为如来。则无有自性。进退推求佛体寂灭。尚非是有岂当是无。邪见深厚者。则说无如来。诸法性空中思惟亦不可。是知真佛既超心境。依斯成行行岂相耶。第八观法。但有八句者。应梵本脱漏。岂余九皆十此独八耶。若约有所表者。表除九十八使故。加十总观破百八烦恼故。然法有教理行果。今就后三略能诠故。八中初一理法。次一果法。余六通三约理可知。约行者。谓不善不生妄想不起。言语道断智无分别。定无行处如智两冥。此六究竟即是果相。今推征云。若一是法余则应非。一一皆尔。若谓总。是则和合不实。随得一法即应得余。和合而成则无和合。若以无合而为法者。无合之法岂当有耶。又此举法皆举寂灭不生等者。欲明一一自虚。法即非法梵行何从。第九观僧十事。前八约人后二就德。且依小说。言预流者。始超凡地预圣流故。一来者。修惑未尽。一度来生欲界中故。不还者。欲界惑尽。更不还来生欲界故。阿罗汉者。此有三义。一名杀贼。已断一切诸烦恼故。二名不生。三界之生永已尽故。三名为应。应受人天大供养故。有四向者。向于果故。谓断三界见惑有十六心。至第十五道类忍时。名初果向。至第十六即入修道。名须陀洹果。欲界修惑分为九品。断至五二向。断六一来果。断七或八品名第三果向。九品全断尽即得不还果。次断上二界修惑。乃至有顶八品惑尽。名阿罗汉向。三界见修都尽得阿罗汉果。今此欲明梵行。粗陈名目。若广引婆沙俱舍杂集瑜伽则清净梵行有累名数。力有余者付在说时。此中观意。谓僧名和合而有八辈。一若是僧余则应非。又一一别辨则无众义。集此无众岂成众耶。况于入流无所入等。以无为法而有差别。则其体自虚。后二就德。德若是僧何须八辈离法无人离人无法。一一穷究为僧者。谁僧体既虚梵行安寄。第十观戒。戒为行体。亦赖众缘。从缘成戒戒性如空。起心持者。是谓迷倒。无善无威仪不杂二乘心。是名持净戒。此戒乃名真梵行也。其中十事。前八是受后二是随。受中坛场得戒之处。问净教仪并教授师。三说羯磨即得戒法。和尚得戒根本。阿阇黎者。正即二师。义兼七证。剃发着衣是戒外相。随中乞食四依之一。正命。谓离四邪五邪。若依菩萨戒类例上文。具如善戒经。及弥勒菩萨所造。受菩萨戒羯磨所辨。此上十境。正约菩萨傍兼声闻。设依小受修观则为菩萨。即如此方。又善戒经。欲受菩萨戒。皆先具受前之三戒。故所观境通于大小。其能观智唯实教大乘。上来寻伺观竟。第四如是观下。辨观成之相。望前寻伺即为观盖。望后得正觉果。此但如实观成。文分为三。初约所观十境如实观成。二此中何法下。约所成梵行如实观成。三如是观察下。结成梵行清净之相。今初。有十句。初六句明三轮清净观。一不取能持戒众生。言身兼口意也。二不着所修行事。三不住于戒法。亦即是事。亦通不住前法。次三句。以三时门明不住持戒时。兼释上不取等言。三世推求不可得故。已灭未至空理易明。现在多滞偏语空寂。以刹那不住过未分之。故空寂也。次二句明二空观成。作受者。人业报是法。后二句。以不迁理释成因果空义。此世不移动。谓不从今至后。彼世不改变。谓不从后至今。是为因自昔灭无力感果。果不俱因无力酬因。何有报受。以物各性住性本空故。二约所成梵行如实观成者。有十一句。初句总显无名。十已空故。余句为别。一不从十生。二非属身等。皆十已空故。上二句约缘以征。次二句就体以征。初句明离前十外无别无作戒体。十外有体不假前十。次句亦无有作。作之受随前已空故。次句双非显中。无性防非故。次五句约五阴。有二意。一就戒体。有说。无作戒体体即是色。有说。非色非心。五蕴之内。初一是色后四是心。今言为是色者。显非是色。以其所立无表依表生。表色无表色。今明观意。表色尚空。何有无表。为非色者。显非非色也。从色生于戒尚不名为色。从色生于戒岂是非色耶。言为是识者。意显非心。若言是心者。一切皆有心应常有梵行。是知非心也。若言非心木石应梵行。是知非非心也。若言非色非心行蕴摄者。但是行蕴应皆名戒。二就修行梵行不离五蕴。若即蕴者。有蕴皆梵行。若离蕴者。岂是我梵行。故后结云皆不可得。第三结成梵行清净之相。以无得故。文有十一句。初句为总。次九句别显无得。一由上三世皆空故。二由于身无所取。于修无所著故。三言心无障碍者。即前于法无所住故。于风行空无有碍故。四作受二念不现行故。五虽空不碍涉有故。六七涉有不迷于空故。受观无相。受谓忍可于心。观谓起用于境。八结归平等。大般若曼殊室利分云。我不见有一法非佛法者故。无法不等。九一收一切方显具德圆融。末后一句总以结酬。由上义故名净梵行。上辨自利行净竟。第二复应下。明利他行净。文分为二。初深观果智。即利他之方。后慈念众生成无缘四等。是则自利利他上求下化。皆具足也。今初文三。初举法应修谓梵行体也。缘体宛然一心湛寂。梵行用也。不思不造万行沸腾故。不但心观圆明。复应广集佛智。二何者下。征起别列可知。三于如来下。结劝广学。第二闻已下。慈念众生成无缘四等。文有四句。一双起慈悲。如犊母随子。二思惟药病成大法喜。三即行无求以成大舍。四智了诸境导成无缘。此中五喻广如十忍然释有通别。别者如幻似有不实故。似有故假不实故空。此二不二成中道智。如梦者。虚妄见故。如影者。从业缘现故。如响者。属诸因缘故。如变化者。须臾变灭故。若如是了境。即终日化而无化。亦为众生说如斯法。是谓利他梵行清净也。第二大段若诸菩萨下。答因所成果问。文中分二。先牒前因深。初总指前文。不生二解则举其要。即所行无二。二一切下。酬其果满。先标后释。今初。由理观深玄。了性具足。万行齐修故。令大果无边德用现证在。即一切明其果大。疾现语其速证。后初发心下释。先释疾现之言。后释现前之相。今初。上言疾得疾在何时。故云初发心时。何法现前谓无上菩提也。后知一切下。释现前之相。亦是出其所因。何者。夫初心为始正觉为终。何以初心便成正觉。故今释云知一切法即心自性故。觉法自性即名为佛。故下经云。佛心岂有他正觉觉世间。斯良证也。斯则发者。是开发之发非发起之发也。何谓现前之相。夫佛智非深情迷谓远。情亡智现则一体非遥。既言知一切法。即心自性。则知此心即一切法性。今理现自心。即心之性已备无边之德矣。成就慧身者。上观法尽也。正法当兴今诸见亡也。佛智爰起。觉心则理现。理现则智圆。若镜净明生。非前非后非新非故。寂照湛然不由他悟者。成上慧身。即无师自然智也。又不由他悟是自觉也。知一切法是觉他也。成就慧身为觉满也。成就慧身必资理发。见夫心性岂更有他。若见有他安称为悟。既曰心性自亦不存。寂而能知名为正觉。岂唯定之方寸。不取则于人哉。况初后圆融不待言也。梵行品竟

    初发心功德品第十七

初来意者。谓前二品明位及行。今显胜德。举初况后巧显深胜。故次来也。又前品末云初发心时便成正觉。未知此心有何功用。顿得尔耶。今释此义故次来也。二释名者。初有二义。一三种发心之初。二十住之初发。亦二义。一发起上求。二三德开发。能知三世佛智故。永断一切疑网故。得如来一身无量身等故。在于信位久已研穷。至此位中豁然开悟。故得功齐果位摄德无边。受斯称矣。三宗趣者。即以初心摄德为宗。令物穷究发心为趣。然住会发心。定是信成就摄。解行及证自在后文。生如来家。自约解说。不应谓此便是证收。若谓久习无明云何顿成大智者。岂不闻冥室千年之闇一灯倏忽顿除耶。若谓云何能知三世佛法者岂不闻具缚凡夫。能知如来秘密藏耶。余义至文当释。夫机差教别圣旨深玄。并未证真如同居学地。共详圣智诚曰才难。且以浅为深有符理之得。以深为浅有谤法之愆。以远为近则有益于行人。以近为远则法非我分。诸佛说教贵在俯就物机。后辈学人若欲高推圣境。傥失大利岂不伤哉。且夕钓磻溪朝升台辅。岂与夫明经常选。而语其优劣者哉。况才生王宫贵极臣佐。宁同百战夷项备历艰辛。况十千劫之功高。亦非聊尔人耳。是以语其智等虚空而非类。论其德碎尘刹而难量。极念劫之圆融。尽法门之重现。初心契于智海。岂有边涯。犹微滴入于天池齐无终始。故经云。发心毕竟二不别。如是二心先心难。法慧仰推良在此也。如或未喻胜鬘有文。推佛能知。斯言无过余如贤首品。次正释文长分为七。一天王请说分。二叹深难说分。三约喻校量分。四就法略示分。五动地兴供分。六他方证成分。七以偈重颂分。又释于中分二。初长行。后偈颂。前中亦二。初此界后结通。前中亦二。初正说。后证成。前中亦二。先问后答。今依前辨。初中天帝问者。在彼宫故。闻前速成生疑念故。菩提心是万行主故。问法慧者。是会主故。初心具后之德。唯慧境故。下正显问端。虽则正问功德下。法慧答功德之量。便显发心之相。是为菩萨善巧辩才。第二法慧菩萨言下。叹深难说。所以叹者。法体深广去疑令乐故。下寄言显说未尽其源故。于中初句总。言甚深者。谓约时深彻后际。约德深至佛果。约理深同法界。约行深包万行。并深中之极故云甚深。又数广难量理玄叵测。虽深非甚。今即少而多即事而理。初心具后是谓甚深。下十句别由斯十义。故曰甚深。于中初四能所对辨。各前能后所。一离言故难宣示。二无相故超心识。三非自力辩能分别。四非劣慧能信解。后六通能所证。五非有所得及一慧能证。六非起行及一行能行。七次第修慧不能通达。八九思慧不能思惟筹度。十闻慧不能信向趣入。此六后后劣于前前。巧显深也。所以广说难者。非唯成上甚深。正诫今后令信。第三虽然下。约喻校量分于中二。初结前生后。谓约自力则甚深。承力则可说。二佛子下。正显校量中有十一大喻。一利乐众生喻。二速疾步刹喻。三知劫成坏喻。四善知胜解喻。五善知诸根喻。六善知欲乐喻。七善知方便喻。八善知他心喻。九善知业相喻。十善知烦恼喻。十一供佛及生喻。然此十一喻。后后过于前前故皆舍置前前更举后后。巧显深胜。又此诸喻合有通别。通但通合发心德广。谓如初喻中便合云。为悉知一切世界成坏等。此不同于喻也。别谓所合同喻。但喻有分限。法无限耳。如初喻合云。不但为以一切乐具供养十方等。初一具通具别。下十略无通合。此诸喻文皆应有四。一举喻二征问。三领答四校量。初后具四。中九略无中二。又诸喻内一一皆有十重。皆应举喻问答校量。文无者略。今初。喻十重中。初一广说。后九略明。初中有四。一举广事。二征问三答显广。四辨超过。今初有三。先与现世益。文有三广为供具田时。次然后下。与后世乐。后南西下。类余九方。二征问。三答广并可知。四超过中云歌罗者。此云竖析。人身上毛。为百分中之一分也。或曰。十六分中之一分义。译为校量分。优波尼沙陀者。此云近少。谓少许相近比类之分也。百千后即云亿分者。中等数也。后九略说中文四同前。今初并举九事乐具皆同。一切所经劫数渐渐增多。其所教法转转增胜。据初世界亦合渐增。以此十前文标一故。余无者略。若十方共十则界不增。第四校量中三。初辨超过。二何以故者征。征意云前。云功德除佛难知。何以比此犹少非类。三释意有二。一别翻前喻。谓发心无限前有限故。亦是反释。二为令如来种性不断下。通对前十总显具德。亦是顺释。于中有十二句。初三总相对前辨胜。一翻前小果。二翻前限处。三翻前有限众生。下九句即下十喻之本。一即第三知劫成坏喻本。二即第四善知胜解喻本。故下文云。乃至垢解净解等。三却是第二速疾步刹喻本。四即第六及第十本。五即第九本。六即五七本。七八皆第八喻本。九知佛境界平等。即第十一供佛喻本。此中九句即佛。十力智。一知成坏垢净自性。即业报智。心乐即种种解智。知烦恼即漏尽智。生死即天眼智。诸根即根胜劣智。方便即禅解脱三昧智。此及佛境并是一切至处道智。心行即种种界智。三世智即宿命智。其处非处智以是总故。亦是前三总句中摄。然此所知皆约一切无齐限也。下文广释其相。第二佛子复置下。明速疾步刹喻。然次下。九喻文皆分四。初举广喻。二辨超过。三征四释。释中皆先反释后顺释。今初喻中前三可知。四释中先反释彰前不及。后为了知下顺释。辨此过前。于中十一句初句总。所谓下。别知世界相即相入无障碍义。前七正明即入。八一毛端下二对。释上即入所由。略举三门。初以法性融通门释。谓一切世界差别性。与一毛端体性无二故。是故事随性融。此彼相即事揽性起。彼此相入各有同体异体。准上思之。九一世界中出生一切世界者。此约缘起门释。谓诸缘起更互相生。有其二义。一约体有体无体义。是故相即。二约用有力无力义。是故相入。亦有同体异体义。并准上思之。欲知一切世界无体性者。约无自性门。以大非定大故。能即小等。十总结。欲以一念尽知如是广无边际。重重即入无障碍事故。发菩提心。又此言知。偈中亦身往彼。第三佛子下。知劫成坏喻。文亦有四。初明喻广大。举成摄住举坏兼空。二佛子下。对辨超过。三征四释。释中亦二。先反释后顺释。顺中三。初总次所谓下别。三是名下。结能知智别中言平等者。通相即相入。就缘就性唯心等殊。皆无障碍故云平等。一长短者。如娑婆为短安乐为长。递传相望以为长短。二三及四文并可知。五量无量者。如胜莲华界。劫更无有上。名为无量。已下皆有量。六有成坏则有尽。无成坏则无尽。标中但云成坏。从多分说。亦粗尽细不尽。七念劫相望。八劫非劫自有三义。一约未经增灭。纵百千年名为非劫。若经增减成坏名劫。二如胜莲华刹既不可校量。亦无劫数故名非劫。三推妄归真劫入非劫。依真起妄非劫入劫。斯则前七事事无碍。此乃理事无碍。九一念速知兼总包无尽。以斯无限安可比前。三结能知智。即十通中。知尽未来际劫神通也。第四佛子下。善知胜解喻。文四同前。初举广喻。梵云阿地目多。此云胜解。谓于决定境印持为性。不可引转为业。今译存略耳。释中亦先反后顺。顺中初总。后所谓下别。别中总有十三句。初有八句总相以辨。后有五句一一别明。前中又二。初三解。为得方便解智光。此光通因通果。于中一广二深。约理等故。三即能知。后五句。为得佛十力中胜解智力。解一切法。初一约人。谓众生海解故。次一约时及性。三约境明似不似。上皆明所知广。四事事相即显所知深。上皆所知后一能知。即得十力之一也。第二从欲悉知有上。下一一别明。上但云多。未识差别之相。今略示之。于中五句各是一义。初句三对。约佛菩萨相望。一妙觉无上余皆有上。此约竖论。二约横辨尽未尽。故三同位互望为等。高下位相望为不等。第二句有六对。约五乘凡圣相望差别。有依无依。约自性差别。托于根境及称真故。二约浅深差别。甚深般若不共小乘故。三约境差别。佛解无边余未尽故。四约二谛。世谛差别胜义无差故。五巧拙差别。六漏无漏差别。第三句有四解。约佛乘说。一深故。二广故。三无分量故。四契真如正位得果解故。事理无碍故。无二碍故。第四句三对。唯约众生以辨差别。于中初能知方便。不碍空而知假故。后悉知下。明其所知。有三对六解。与惑相应名染。不相应名净。广略者。约境及作意差别。粗细者。约行相差别。委悉不委悉故。第五句三对。多约知圣教解。于中文二。先正明。二一切下。通结前文。初中深密者。开则深约方广一乘。密谓密意。合则深即是密。以秘以妙即事而真故。二方便者。略有三种。一进趣方便。谓见道前方便道是。二施为方便。即第七波罗蜜。依实起权皆善巧故。实无此事假施设有故。三集成方便。诸法同体巧相集成。如六相巧成可名方便。今并能解。言分别者。凡于一法多门决择故。言自然者。法尔本觉内熏发故。随因所起者。过去闻熏之所发故。或于现在正思惟等而能知故。言随缘所起者。谓得善友增上缘力。所开悟故。二一切下总结。广多交络故如网也。为此无限而起大心。岂同前喻。第五知根智。第六知欲乐。欲谓于所乐境希望为性。勤依为业。即胜解智所摄。会释如前。第七知方便者。即禅善巧及至处道智方便三种。如向所辨所望别故。无相滥失。第八知心义兼王所。即他心智。第九知业即业报智。上皆文四。同前可知。辨其名体。具如初会十力章中。广显差别如第九地。第十佛子复置下。明知烦恼差别喻。文亦分四。前三可知。第四释中亦先反后顺。顺中初总后所谓下别。别有六门。各先惑后治。谓非但空知。意在断故。初门总明后一义兼总别。中间四门别举其重。今初门中轻重眠起。通下诸惑故名为总。就中轻重总中之总。以品言之。一切烦恼各有轻重。约起惑者。心有异故。据难易断现行为轻。种子为重。即眠起是。又分别为轻俱生为重。若据破坏三宝焚烧善根。则邪见最重余悉名轻。若据损恼自他障菩萨道。嗔恚最重余悉名轻。若据发润生死流转。无明爱取为重。若依为诸惑根。则三毒为重。若依障初圣道不受圣教。见慢为重。若据远随现行障无学道。我爱慢为重。余可名轻若烦恼当体相望。十大烦恼为重。随惑为轻。随烦恼中大中小随。展转轻重。又正使为重习气为轻。更有异门可略言也。言眠起者。眠即种子眠伏藏识。起即对境发起现行。言一一众生无量烦恼。总结多端。种种差别如后略说。广唯佛知。种种觉观通能所治。有染净故。染为所治。烦恼依故。如欲恚害觉。能生贪等无量烦恼。涅槃加五说有八觉。一欲觉。求可意事。二嗔觉。念欲嗔他。三恼觉。念欲恼他。四亲里觉。忆念亲缘。五国土觉。念世安危。六不死觉。积财资养。七族姓觉。念族高下。八轻侮觉。侮即是慢。念自恃欺人。此等非一故云种种。皆能引起一切烦恼。对上一一众生无量烦恼。亦名引起分别。言净治者。欲以不净观治。嗔以慈治。恼害以悲治。次四以无常观治。后一以无我我所观治。故云种种觉观净治一切杂染。第二依流转门。于所治中即痴爱发润。断一切下明治。由痴爱故。诸趣流转。从痴有爱菩萨病生故。一切众生三有五趣三结要当断尽。一欲界诸爱别名欲结。二上二界爱合名有结。三三界无明名无明结。三结亦名三漏。即上痴爱断已永尽生死流故。第三依病行门。四分分别。分是性义。各据偏多受贪等名。名为不等。三分俱多名为等分。然不出三。此三别名三不善根。故治中云断根本也。第四依通诸识门。明我我所。谓第七识恒执第八为内我故。惑谓为我所染之起慢。故云我慢。通至第六。内执我身外执资具。恃己陵人。又此我者。亦兼法我。若尽此惑则诸惑皆尽。故治中云尽无余也。第五约相生门。以利钝分别先钝后利。故净名推身。以欲贪为本。欲贪以虚妄分别为本。虚妄分别以颠倒想为本。颠倒想以无住为本。今以无住非烦恼故略不言耳。而顺明之。从颠倒虚妄分别生贪等惑。依贪等惑有诸随惑。展转相生。颠倒想者。不净计净等故。利中即身见为本。生六十二见。此有二说。一依三世五蕴。至下当明。二依异道邪见。具如瑜伽八十七说。第六约出家修行门。以障盖分别。盖谓五盖。已见上文。障即二障。此亦总。结前诸惑不离二障。发大悲下。明能治道。谓救有障者。护修行者。此言在末。义兼总结。谓菩萨发心不自为己。但以大悲救护一切。令断上来诸惑之网。断之何。为令本智清净。然能治道。虽复众多不出二种。一通二别。别如上来随分开示。如不能断应宜转治。谓如起贪以不净观治之。不去当起慈悲。缘于前境。应以净法与之。云何出家无慈悲心。反更染污。如是随便种种回转。皆以无得而为方便。所言通者。但当深观第一义谛。谓当观诸惑即是本觉菩提。故无行云。贪欲即是道。恚痴亦复然。如是三法中具一切佛法故。惑性智性皆本净故。但由虚妄分别凡夫不了。如大富盲人动转为宝所伤。二乘热狂。谓为虫蛇惊走远避。权菩萨辈犹谓有之可断。今乘一切智乘以净慧眼。观惑即真。则烦恼自虚智性常净。是为开佛知见。使得清净。不断烦恼而入涅槃。有斯悲智。如是知断发菩提心。岂与夫前喻同年而语哉。第十一明供佛及生喻文三。初举喻校量。二征。三释。今初分二。前广明一人。后略辨九人。初中有四。一举广喻。二问。三答。四校量显胜。初中有二。初广说东方。后南西下略例九方。初中又二。先明佛在供养。后至佛灭下明灭后供养。前中又二。先自行后又劝下化他。前中有四深胜。一供具广妙。二供田广胜。谓无数界悲敬田故。三供心胜恭敬等故。四供时胜。相续无数劫故。此自行已胜。况于教他。况复灭后况于余方。余并可知。后略辨九人中二。先举广喻。二佛子下校量显胜前中九人展转递望。念敌多劫数量复增。此中如第一人一念以无数供。至第二人皆增至无量。乃至第十增至不可说不可说。皆积当位之念。以至当位极时也。后校量可知。二征意云。其第十人供福。已至不可说不可说。全比容许不齐。何以不及少分。第三释中分二。先反显不为齐限。明前不及此。后为供养尽法界下顺释。以无限故辨此过。前略申十种。一时过。谓穷三际念劫重重时故。二处过。谓该十方相即入故。三供过。谓尽法界称理之供故。四田过。谓尽虚空界尘毛等处。诸如来身各充法界故。五心过。谓一一念中。各以无尽供。供无尽佛。经无尽劫心犹不足故。六悲过。自作教他。以此善根唯为众生令先成佛。我亦供养故。七智过。了达三事。随其一一称法界故。如海一滴。则具百川之味。芥子之空已无分限。八善巧过。能以一事为多摄多为一。善巧成就融摄诸位。真实行故。九所求过。唯为菩提不为余趣故。十平等过。谓生佛自他供与不供。皆平等故。束上十义总不出三。一无齐限故。二称法性故。三事事无碍故。无此三意设更重重广喻。亦不及少分。第四发是心已下。就法略示分。前喻显大心因广。此明摄德深胜亦是赞胜劝学文中有二。一发是心已者。牒前诸喻所校量心。二能知下明此大心所摄功德。于中有五。一解行圆满。二妙果当成。三与佛平等。四能作佛事。五大智现前。初中三。一总举所知。现佛正觉但云智慧。过佛示灭故加涅槃。当佛在因云善根也。过现已从缘应可得云知。未来未有但可云信。亦信一切皆当佛也。二彼诸下摄以修证。有为能得无为能知。能证使智身成就法身等佛。古德判此一段。为摄位修成。谓于诸佛功德智慧能信是十信。信成就故。后摄初故。能受是十住。能修是十行。能知是十向。得证是十地。谓本智证后智。得能成就。是结因究竟。能与佛等是果满。平等谓与诸佛能证所证平等无二故。初心即摄诸位。乃至佛果亦是一理。三征释所以。何以初心即满因位。释意云。以等真性所为无齐限故。有十一句。初总余别。文并同前初喻中辨。第二以发心故下。妙果当成分二。初标因得果。二征释所由。今初得于八事。一解契佛心故为忆念。二入正定聚故当得菩提。三真器已成故佛授妙法。妙法者即如来知见也。四知心性故与佛平等。五圆修助道六度四摄。六力等未证亦定无疑。故云成就。七十八不共修习庄严。八得四无碍辨名说法智慧。上七皆言三世明其竖该。今云法界。辨其横摄。前后影略。二征释所由中。初征意云何以发心即得果法。释云。以是发心为因。决定当得佛故。望圆极之果故定当成。约见性成智身。上品云即得故。晋经梵本。此中皆云即是佛故者。当此义也。第三应知下与佛平等者。见性均故。发心毕竟二不别也。文有四句。初总余别。总言等佛何所等耶。有三种等。一所缘境界。及分齐境界等。二大悲大定力无畏等。皆悉平等。三得知身无从。亦无积聚。随物分别见种种身。如是智慧与佛平等。第四才发心时下。能作佛事有十一句。皆是才发即得。言即得者有二意故。一约法圆融。初心摄诸位故。通说诸位相摄。总有三类。一以行摄位。如十信中具一切位。贤首品说。二以位摄位。如十住满即得成佛。如十住品。及法界品海幢比丘处说。其十行十向十地皆尔。各如自品说。三初心摄终。如十住初心即摄诸位。如此品说。并就因位满说。如普贤作用大分同佛。犹未是佛。此中亦尔。二约见性齐故。说与佛等具诸佛法竖。论位次优劣非无。若尔此与历别何异。请以喻显。若彼虚室置之一灯。光周室内。加二加三乃至百千。各各重重遍于室内。虽同周遍不妨后后益。明初心等佛若彼一灯。妙觉等初同第百千。若器中盛灯。虽复百千共置一室。互不相见。历别修行类同此也。依于此义故。初心即云振动光照一切世界。登地已上却说百刹千刹。如理思之。又即由此义废高就下。十住之中即齐地故。第五此初发下明大智现前。此文二意。一别是一段。谓以无著大智求菩提故。二通释上四段。谓由于一切无所著故。称性圆融能成能摄一切功德文中分二。初正明无著。后释其所由。前中初总所谓下别。谓从三世门见佛法僧非佛法僧。同三世摄。于中三位。初八清净次四通染净。后二唯染。后唯求下释不着所由。文含多意。一云。唯为菩提故云求一切智。不余趣向故于法界佛等无著。此虽有理不顺今文。以佛及佛法岂非一切智耶。二云。求之于己不求佛等。求之于己尚未免求。今释有二。一只为求一切智故。求而无著。以有所著非真求故。故净名云。夫求法者。于一切法应无所求。了法无求顺一切智。二者言求者不坏相也。不著者称法性也。性相双鉴。终日求而无所求。经云无所求中吾故求之矣。第五尔时下动地兴供分。全同上文。第六是时十方下。十方证成分。望于上文有同有异。同义可知。异有三种即为三段。一佛现证成异前菩萨。二显益证成前文所无。三结通无尽。前略此广加说因故。今初也。先现身次赞说。后引已同。以初心摄德深广恐难信受。故佛自证。二汝说此法时下显益证成。益通二世。初益现在。后我等悉当护持已下。显及当来。今初清净心者。以闻菩提心见心性故。而经多劫者。然余教说定三僧祇。此宗所明劫数不定。略有四类。一或展则无量。不可说不可说刹尘。如法界品说。二或千不可说。或减或增。如威光太子及此中说。三或一生二生。如善财童子兜率天子。四初心即得如前所说。所乘之法既自在圆融。能乘之人亦迟速不定。念劫融故。故弥勒云。一切菩萨无量劫修。善财一生皆得。起信则以若迟若速。皆为方便。此宗则以楷定为权。并有圣言无烦固执。不以长时而生退怯。不以速证而起轻心。若迟若疾誓要当克。是佛意也。后益末世令信仰故。今之闻者。皆由佛力愿深愧信行。三如此下结通无尽。是证佛结通非经家也。先明说遍。后其说法下示所说同。文中有三。一说人同。二说仪同。谓神力本愿故。三说意同。为欲下是此文大旨。同前十住并显可知。第七尔时下以偈重颂分。先辨偈意有十一句。初一后一是说偈仪。而离开者欲显中九。皆承佛力该十方故。中九正明所谓。初总余别。别中四对。一净业显理。二除惑开信。妄想分别为杂染根。三知病识药。四观果净因。即由利他自业便净。第二正显偈辞。有一百二十一颂。文分三段。初八十二偈。超颂就法略示。二有三十四偈。却颂就喻校量。三有五偈结德劝赞令景慕发心。叹深难说遍于三段。又叹为长行偈颂之本。故略不颂之初中文亦分五。初有十七偈。颂第一解行圆满。二菩萨始发下十七颂。超颂第四能作佛事。三菩萨所住下十八偈。却颂第三得佛平等。四趣向菩提下六偈半。颂第五大智现前。五恒劝众生下。二十三偈半。颂第二妙果当成。文不次者。显德无前后故。又长行明先同果体。后同果用。偈颂明用可在。今果明当得。大智通遍故。前后互明。初中文分为二。初一偈。颂前正明解行圆满。然初句。是总举发心为因。余十六偈颂前征释。于中有七。初一偈颂充遍一切世界。二有二偈。颂为欲度脱一切世界众生。三有一偈。颂知世界成坏。知者意在往化觐佛故四一偈半。颂为悉知一切众生垢净故。及一切世界三有清净。知垢意在令净故。五趣三有名左右耳。五绍隆下两偈半。却颂为不断如来种性故。初半摧邪显正即绍隆义。次句示佛种之体性。次二句即起佛种缘。余是种起之相。化化不绝是报佛恩。心如金刚是种性义。照佛所行修菩提行。则佛种不断也。六五偈。颂知众生心乐烦恼习气下。四种发心。于中初偈。总明所知事。想是妄想即烦恼也。业即习气果即死此生彼。心即心行根性即诸根。次二偈显知之体相。皆即事入玄。次偈非唯知病亦识法药。故如世尊。后偈非唯空知。行愿相符能为实益。七有三偈。颂知一切众生三世智。谓离三世障故。障有十种。一烦恼杂染障。二触境迷倒障。三长时懈怠障。四取着因果障。五邪教邪师引转障。六趣下乘障。七粗相现前障。八于遍趣行无堪能障。九随言生解障。十不亡能所障。如次十句各一对治。末后二句总结通达。第二菩萨始发下有十七偈。颂上能作佛事。总分为十。初二偈。颂即能说法教化调伏一切众生。以悲智相导故。二有一偈颂诸佛赞叹。叹必加故。三有一偈。颂即能振动一切世界。动入互举。四菩萨具足下六偈。颂即能息灭一切诸恶道苦。于中具悲智之德。故能拔因果之苦。而无我人。五有一偈。颂即能光照一切世界。照世意在照诸众生。六一偈。颂即能严净一切国土。毛孔现刹即神通严也。七有一偈半。颂上即令一切众生欢喜。供佛问法但为益物故。八一偈半。颂上即能入一切法界性。初半闻而通达。次半思而兼说。后半修而无著。九有半偈。依修而证。颂即能持一切佛种性也。十有一偈半。颂即能示现成佛。第三菩萨所住下十八偈。颂得佛平等。于中分四。初三偈半颂佛境界平等。初偈分齐境。次偈兼所证所缘境。后一偈半举况显胜。二善知下四偈半。颂功德平等。三有一偈。颂前文得如来一身无量身平等。四于诸下九偈。颂真实智慧。于中有四。初四颂。发离一切妄想广大心。二有二颂。发穷三际广大心。三有二颂。发顺涅槃菩提广大心。四一偈结劝可知。第四趣向菩提下六偈半。颂大智现前。于中初一结前生后。余正颂大智现前。初偈于佛无著。次偈即若众生若众生法。次偈即若佛若佛法。次偈若世间若世间法。次偈若菩萨若菩萨法。二乘文略。后半偈颂上结文。念十方佛即求一切智。无依无取。即于诸法界心无所著。第五有二十三偈半。颂前妙果当成。于中有九。初三偈半颂常为一切诸佛护念。以具德故。二半偈。颂当得无上菩提。三半偈。颂与其妙法。大人法者八大人觉也。四有一偈。颂佛体平等。时处平等即佛体故。五有一偈。颂已修三世诸佛助道之法。六有六偈。颂成就三世诸佛力无所畏。广十力之别名。略无畏之都号。于中五偈半别明十力。后半偈显得分齐。七有五偈。颂已庄严三世诸佛不共佛法。三世间圆融不共权小故。八五偈。颂悉得诸佛说法智慧力。九一偈。结德无尽并属初心。该前诸段大文第二十方国土下。三十四颂。颂前约喻校量。于中分二。先十四颂。正颂前喻可知。后二十偈。通释诸喻不及所由。前虽略释今此广辨。又长行中多随喻别明。今此总辨。亦总相颂前叹深难说。若将别配。则令难证等互有所局。于中分三。初半偈结前生后。次十七偈半正释所由。后二偈结德无尽。就正释中分三。初一偈标章。次十二偈半别释。三四偈显德圆满。今初也。谓标出生无尽体相无限。二章二别释中。初四偈释无齐限。或一句是一义。后一偈半颂六度义。可以意得。后八偈半释出生无尽。于中分三。初二偈半结前生后。以体无限故出生无尽也。次菩提心是下四偈。正显出生为本。出生乃一义耳。后二偈略释为本所由。由修六度为菩萨乘本。由劝正行为人天乘本。由阐妙业通为三乘涅槃之本。三四偈显德圆满。中初偈总显。次二偈别显愿满。后一偈别明智圆。第三二偈结德无尽可知。大文第三欲知下结劝发心于中三。初半偈正劝。次三偈半释劝所由。总举具足一切德故。后一偈结劝速发

大方广佛华严经疏卷第十九大方广佛华严经疏卷第二十

        唐清凉山大华严寺沙门澄观撰

    明法品第十八(入第十八卷经)

初来意者。前明当位所成之德。今辨趣后胜进之行。故次来也。又前明发心之胜德。今辨所具之行相。故次来也。二释名者。准梵本具翻应云法光明品。统有四义。一法慧智慧。于能所诠进趣行法。分明照了故。即明所知法。二明是能诠。以能显行故。法是所诠可轨则故。此则诠旨合目。明有法故法之明故。通二释也。三明是智用法是理行及果。境智合说俱是所诠。法之明明之法依主名也。四所修行法体离无明。亦唯所诠有明之法。法即是明。通有财持业也。三宗趣者。明法不同略有四种。谓教理行果。寻教悟理观理起行行成得果。皆初宗后趣。又此四皆宗。为成后位及成胜德为趣。第四释文文有三分。一请说分。二正说分。三结说分。今初分二。先长行后祇夜。前中亦二。初叙问答之人。胜进趣后非勤不能故精进慧问。二佛子下正申所问。亦分为二。初领前自分胜德。后请说胜进之行。前中先总。后具大庄严下。别别有七句。一领德即领前庄严一切诸佛不共之法。二领乘即上已住究竟一乘道。三领位位不退故。即上已住如来平等性。三世诸佛家中生。此下晋云离生道者。即是领道。圆教初住离生因故。今四五二句成此一句。以舍世间得出世法。入住正位。即上于诸世间不分别等。六去来现在诸佛摄受。领得胜缘。即上佛护佛赞等也。七决定至于菩提。领其当果。即上云当得三世诸佛无上菩提。德虽无量不出于此。故略举耳。此约当住位释。若约摄于上位理无不通。而于求胜进义非惬当。二彼诸菩萨下。请后胜进中亦二。先问所成行体。后问行成德用。以破痴等为德用故。前中先正问后结请。前中十句为三。初五自利兼他。一问云何修习顺佛令喜。其修习言亦总亦别。总遍诸句。别谓策勤。即下答中明不放逸。二问顺法入位。三顺行四顺愿。五顺德积德成藏故。次四利他兼自。束为二对。初常说法而不舍自行。后下念四生上弘三宝。末后一句。总结二利不虚。二佛子下结请可知。第二复次下问行成德用。文亦分二。初正问后结请。前中分二。初问行所成因德。二问结因成果德。今初有十二事。初十一字贯下诸句。一能灭无明。未审修何行法。而能灭耶。诸句皆尔。意在征因。无明有体黑闇为用。非明无之处即名无明。故别有惑体。由无明故事理皆昧。名为黑闇。二问降魔。三问制外。四问究竟断道。心垢即是所知。亦名习气。五善根以何而成。六三恶八难云何可出。七智境何由净治。八地等七种净德云何成就。九依正三业功德。云何庄严满足。十以何观力知佛功德。十一一切智境复云何知。十二何法能成就众生。乃至作大佛事。第二及余下结因成果。于中二。先正结等。谓结所不说及等如来。第二于诸如来下。显等佛之用。护持正法便等佛故。故偏明之。文有十句。初总余别。总谓开示演说教理行果。皆有护义。诸魔下别。一异敌不侵。二摄持修行。三十王外助。四举世同钦。五诸佛灌顶。准梵本云。一切如来共所守护同灌其顶。故应回文。六菩萨爱敬。七得众善根。八能演深法。九摄德自严。若得此九方名护法二。一切下结请可知。第二尔时下偈文分二。初一赞说者。余十颂上文。于中亦二。初一颂领前。余颂请后。于中亦二。前四颂所修行体。后五颂行所成德。于中亦二。前三颂行所成因德。后二颂结因成果德。大文第二正说分中分二。先长行后偈颂。前中亦二。先赞问许说。后正答所问。前中三。初赞所问利益。二佛子下赞能问具德。三谛听下诫听许说。第二正答中二。先答所成行体。后答行成德用。前中答前十问。即为十段今初段中有五十句。前二十句答前修习。后三十句答令佛欢喜。前修习言亦总亦别。今不放逸亦通总别。总则遍下十段。皆由不放逸成。别则属于修习。在文分二。先牒前标后。勤智守心不犯尘境。名不放逸。是修习相。不守根门则名放逸。涅槃云。不放逸根深固难拔。因不放逸。一切善根皆得增长。故首明之。即精进三根。于所断修防非为性。对治放逸。成满一切世出世间善事为业。二别辨中有二十句。前十始修。后十终成。今初有四。一总标。二征数。三别列。四总结。他皆仿此。列中一对治破戒放逸。三聚非一故名为众。即三德三身之因。故首明也。宁舍身命不犯小罪。故名护持。二离痴智显故菩提心净。三四可知。五恐负自心故思本发。六远离恶缘。七修善无住。八离小行大。宁起疥癞野干之心。不起二乘之心。难反复故。九积善无替。十亦爱亦策。不令过分使不相续。若不续者当令相续。故须观察。二终成十中。一行清净由不放逸。得无违教失故名清净。二念智清净。念则明记智则决断。念有智故念即无念。智有念故常得现前。此二相资故名成就。三等持清净不沈不掉。故名为等。然此沉掉乃含多意。如始学者。不昏沉不恶作。亦名为等。未是深定今称性寂然。故能不掉。智照不昧。所以不沈。如此深定非深非浅。四勤闻清净。五思修清净。六等引清净。七妙慧清净称理平等故。八摄受清净。等利益故。如大地者。胜鬘云。譬如大地负四重檐。一者大海。二者诸山。三者草木。四者众生。菩萨大地。荷负四种重任者。谓离善知识无闻非法众生。以人天善根而成熟之。及三乘人随机遍摄。名等作利益。九同行清净。谓如弥伽赞敬善财。十承事清净离杂心故。次答令佛喜。有三十句。初十结前生后。次十正成行相。后十纯熟究竟。今初。此即牒前十种清净。如次配属。前八可知。九摄二句。以菩提心佛法无边誓愿知故。既敬此心及事于师。故能顺了。上九结前第十生后。故令佛喜。次十正成行相者。前明即前修习故令佛喜。今更别明。于中一勤而不退。成上精进。二内不惜身正念方成。三外绝异求故唯有胜进。四加行观空方能不息。五正证入理故无所依。六穷得法印方顺深法。法印多种。或五或四或三或一。但广略之异耳。言五印者。即五非常观。谓无常苦空无我寂静。言四印者。合空入于无我。空即我所故。或名优陀那。菩萨藏经第二中。名法邬陀南。邬陀南者此名标相。涅槃寂静是无为法标。相印即决定义。如说有为决定无常等。善戒第七地持第八。瑜伽四十六。广有分别。言三印者。四中合苦入于无常。或除涅槃寂静。有为印故。今以诸印印于一切。亦无能印故云不着。则入唯一实相印矣。后四依理起行。七愿护小心故增广大。八智护凡见方顺佛法。九自无法爱十无作而修故。入无诤门矣。后十纯熟究竟中。行修成熟故云安住。初二入理行。一加行离逸。二正证舍相。次二救生行。次二随缘行。十度别修诸行总摄。后四愿智行。即十度后四也。亦可。前十如次成此十种。但生熟之异耳思之。第二答入菩萨所住处问。文分为三。初有十法起入地行。次住地观修。后明地要胜。今初列中初三自分行。一具资粮。二成加行。一度具十名大庄严。三智契实相故不随他。后七起胜进行。谓四外近良缘。五内须自策。六能安果用。七不厌修因。八双游定慧深心契寂。利智贯达。以斯二法严于法身。故法华云。佛自住大乘。如其所得法定慧力庄严。以此度众生也。九不住法门。住有二失。一不契地智。二不能进趣。不住反此。十善穷地体。谓依一佛智。方便多门更无异体。二复次下住地观修。有十一句。初一是总。一切法门是成地之法。次九为别。二诸地证智。三修加行因。四摄报等果。五所知分齐及所化境。六进德修业断障力用。七示百身等。八分别诸愿。十善等法。九所证法界。皆言随其者诸地非一故。十悉善下辨成观相。皆自心者。智与心相应故。因由心学果是心成。境由心现力用。是心分位。神通是心现起。分别是心决择。所得是心造诣。并心外无得何所著耶。十一如是下结观成益。三佛子下显地要胜。标征释结文并可知。第三答大行清净问。有二十句。初十是因后十是果。今初行成出障故云清净。虽数名小异大同十行。亦通十度。十行所行即是十度。欲胜进彼故此前修。又下文。由为物说法自增诸度故。复广明。所望处别互有影略。前七可知。八于恶众生修菩萨行。心不倾动。是难得中义。本愿誓化故。九善法行中。与众生为清凉法池。大悲坚固普摄众生为舍为归是广度众生。如桥梁义。有力能故。十真实行中文云。此菩萨入三世诸佛体性。与三世诸佛善根同等。智决体同故。第二菩萨既得下。由行净因得胜法果一他力胜。二自善胜。三深定胜。四同行胜。五助道胜。六真智胜。七意乐胜。八观慧胜。九修行胜。十增进胜。第四答大愿问。有二十句。初十起胜净愿。后十励志令满。今初全同初地十愿。一成熟众生愿。二净佛国土愿。三供养。四护法。五承事。六同善根。七摄法上首。法通至佛名如来门。八三业不空。九具修诸行。十现成正觉。但彼文广。依彼次者。五七一二六八三九四十。为今之次。二佛子菩萨下。令愿成满者。由斯十句。能满前十及余多愿。于中五深心则可久。六悉成则可大。可久则菩萨之德。可大则菩萨之业。余并可知。第五佛子已下。答护菩萨藏问文亦有四。初是结前生后。谓以前行愿蕴积成藏故。唯十句更无成熟等异。文有五对。并显可知。第六菩萨得是下。答随所应化常为说法问。文分为三。初结前生后。谓蕴积福智用以摄生。二佛子下征以标起。三所谓下正解其义。于中分二。前知器授法。二具德成益。初中先知器有四一识习气所作。如金师之子。应教数息等。二知种性因缘。闻法发心为因。随因成性。遇师闻法为缘随缘成种。三知心行之病。谓多贪等。四知希望差别二贪欲下授法文有十句。初二可知。三痴有二种。一迷于事理教观法相。二恶邪推求不信业因。令其观察十二因缘。能离邪执自性等计。上三唯对治。四等分者。等谓相似三观不可并施。若等重者教观胜义。谓淫欲即道等。若等轻者。可以生善为人化之。释此四分具如杂集十三。五求人天乐为乐生死说三苦者。乃至非想行苦所随故。次四可知。十乐事寂者令成理寂。若沈空寂令成事用。菩萨已下总结随宜。二为说法时下明具德成益。有十句十对。一文连义正。二法智无差。即依法不依人。依智不依识。三审定无违即依了义经。不依不了义经。四立法义故能遍断疑。五了物根故入于佛教。六寂契真际照法性源。七断真法爱除人法执。八念佛了音。九亡言巧说。虽无说无示善顺宗因。十令悟随宜终归平等。即说之益。第七菩萨如是下。答恒不舍离诸波罗蜜问。于中二。先结前生后。则正说法时便具十度。设自修此亦为利他。一向大悲了平等故。通至佛果故皆名道。二是时下。正示不舍度相。十度即为十段。皆先辨相。后是则下结名。前四辨相中先辨施等相。后无著等辨波罗蜜相。檀戒可知。三忍中诸恶通于内外。其心下契理平等成波罗蜜。四进中普发众业。是无余修。亦利乐勤常修靡懈。是长时修。恒不退转是无间修。上即加行勤也。勇猛莫制是勇捍修。亦被甲勤。于诸已下是显度相。五禅定中文有十一句。一诃五欲。所以诃者。夫禅定虚凝湛犹渟海。高攀圣境尚曰妄情。驰想五尘岂当为道。云何诃之。色如热金丸执之则烧。声如毒涂鼓闻之必死。香如弊龙气。嗅之则病。味如沸热蜜。舐之则烂伤。触如卧师子近之则啮。此五欲者。得之无厌如火益薪。亡国败家世世为害。过于怨贼。故不应着。况菩萨体此即如。复何所著。二入次第定。谓四禅四空及灭受想。为九次第定。下。十地离世间品具明。即一切门禅。三安住理定寂爱味住。智契不出名正思惟。以见心性故。亦善士相。上二定体即定自性。余六定用。四消灭烦恼通爱见慢等。故云一切即清净相。五出生诸定。如起信云。得此真如三昧。能生无量诸三昧门。上文云。一三昧生尘等定是也。即难行相。六引发神通。谓精义入神以致用也。亦遂求相。七逆顺自在亦难行相。从灭定出入非非想乃至初禅。是名为逆。从初禅出入第二禅乃至灭定。是名为顺。此中逆顺应各有超间。谓超一超二乃至全超。文无者略。此亦名为师子游步三昧。八一多自在摄一切定。应有四句。谓在一入一。在一入一切。在一切入一。在一切入一切。得其源故。九悉知定境。定境有三。一诸定所缘。二诸定分齐。三诸定境用。皆能知之。十者总结体用无违。言三昧者。此云等持。唯扃有心而通散心。三摩钵底此云等至。通于有心及与无心。唯诸位定体。此二功德名为等引。上二句定体通于此三。六句定用即是所引。言智印者即一实相故。智论释百八三昧中。第二名宝印三昧。谓与实相般若相应故。上二是定此一是智。合即双运。今菩萨随在一定。即与一切三昧。此三无违。十一速入智地。亦即定果。以菩萨之定。事穷无边理极无际。故能速至一切智地。亦难行相。亦二世乐相。又上二三四。即现法乐住禅。次五引生功德禅。五亦饶益有情禅。后二通三。又通十种清净。一由世间净离诸爱味故。即第三句。二出世间净亦此句摄。三加行净即是初句。四得根本净即第二句。五根本胜进净即第五句。六入住出自在清净。七舍静虑已复还证入自在清净。上二即第七句。八神通变现自在清净。即第六句。九离一切见趣清净。十一切烦恼所知障清净。此二共是第四句摄。余如瑜伽四十三九大禅说。十行之中当显其相。六般若中句亦有十。前之三句。闻法近友即闻所成慧。初句正明。二近友不倦。是闻慧缘。三乐闻无厌是闻慧因。暂闻则己慧不生故。四即思慧学而后思故。云随所听也。内正作意故云如理。五亦思择慧。又于无烦恼中善决择故。舍烦恼故。六善观下皆是修慧。此句悟入于如。七宿习思量故了无功用道。八周备悟入。一中一切等名为普门。九入二智门。十总结已圆故云休息。后三连环。此中亦有九门之相。恐繁不配。其中虽定慧互有。互相严故而为门不同。若全双运故。起信论合于六度。以为五门。后之方便义亦准此。涉有不迷于空则名方便。不厌有而观空。便称般若。岂令般若不能知有耶。方便若不观空何名方便。非唯此三万行皆尔。况般若能行万行。何法而不用之。寂照尽于理极。不得一行无此君耳。所以开则万行淼然。泯则一不为一。得意则无所不通耳。七方便中亦有十种。一巧智现世为方便。二悲非爱见故化而无厌。即悲智相导为方便。三依体起用。四非舍非受故一切无染。五凡圣双行由双非故。六行无住道。七观察进趣。八现相不着。九遍入诸趣即无生现生。十度脱众生是无化现化。初九拔济余皆回向。依璎珞因果品。后之四度亦各有三。方便三者。一进趣方便。即第七句。二巧会有无除第四句。皆此所摄。三不舍不受即第四句。八愿中亦有十愿。前五后三尽字为初。六身恒住尽劫海。七智尽心海。八穷尽有支。九尽现国土。十穷佛果智。此求菩提前九利乐。若依三愿。二三四五为自行愿。六七为神通。初及八九为外化。十通二利。皆云尽者穷彼源故。九力中十句各二。谓标名释义。一契理。深心是思择力。染则无力。翻此故有也。余可准知。皆修习力。璎珞有三。皆名通力。一报通力。二修通力。三变化通力。观彼似当九十二句耳。十智度中。识病知根顺理授法。名为智度。亦有十句。初四知病轻重。次三知根欲乐。一位二行三心。后三知法乐。一知理法。二知果法。三普觉法界。前七成就有情。后三现法乐住。璎珞三智。一无相智即知法真实。三变化智即如来力。余皆第二一切种智。余义如初会说。第八佛子下。答前所念众生咸令得度问。于中分三。初结前起后。二正明化度。三结如本誓。前中初结前。清净约离障。圆满具事理。不舍谓常相应。住大庄严者。总结十度为严。是大乘体。后随其所念下生后。由且前故。二堕恶道下正明化度。文有十句约为四类。初二令离恶果。三涂除无间皆容发心。如慈童女。二令勤修则脱八难。值佛闻法。次三令离恶因。贪有二种。上偏语色贪教修不净。今通语贪财名等故。但云示无贪法。无贪法者。谓不净观空少欲知足。二嗔亦二种。上偏语能为违害。故令修慈。今通嗔情非情故观同体。不应自嗔。三痴亦二种已如上明。此约邪痴令观缘起。次三令离流转三界循环。皆可厌故。初欲恚害等义见三地。二色界虽定慧似均。然是定地。恐其滞寂故为说观。又无生正观令得无漏。三无色定多故为说妙慧。又示谛观方得永出。后二示以三乘随机为说。又引权归实令知本寂。三如其往昔下结如本誓。故能真度。师子吼者决定度故。第九佛子下。答前绍三宝种使不断绝问。文分为二。初仍前总标。二所以下征释所以。由化众生入三宝海故。能绍前令不断也。文有四番为成十句。前九别明后一总结。就初三番释通总别。然皆后后转深前前。通者通在诸位。别者初在十信。次居三贤后约登地。三番佛种差别云何。初教发心令具因性。未发唯有本住性故。次赞大愿令成因行。令所发心不退转故。言大愿者。谓求菩提愿利乐有情愿。又防恶愿如戒经说。有进善愿如常所明。三下佛种子令成佛智。谓证真如成无漏故。上约别显。通者发菩提心总有三心。谓即大悲大愿大智。初番为总已含大悲。次番是愿。后番是智。谓示妙理令暂见心性。成金刚种。三番法种差别相者。初开法藏令教不断。次说因缘令义不断。后具四种护。令教理行证皆悉不断。复次初虽领教未发真解。次具解行未能证故。三番僧种有何差别。初受法无乖始堕僧数。次修六和敬僧行已成。后统理大众令僧清净。复次初虽奉教解行未具。未是真和。次虽具解行未离众怖。不能控御。言六和者。三业为三及戒见利。谓身和同集口和无诤。意和无违。见和同解。戒和同奉。利和同均。又约菩萨。三业同慈六皆同体。真实和也。一切恭敬令僧久住。后总句者。弘法奉戒三学兼修。则不断三宝化化不绝。第十菩萨如是下。答前善根方便皆悉不空问。先略后广。略中分三。初结前生后。谓由能绍三宝故所行无失。二随有下由不空故。三业无瑕。谓所作回向是不空业。三无瑕玷故下。由无瑕故不空。所作反覆相成。玉之内病曰瑕。瑕谓体破。外病曰玷玷谓色污。以显三业内外无失故。白圭之玷尚可磨也。三业之玷不可为也。初句牒前。次所作下示无瑕相。后皆与下显不空相。方便有慧方便不空。慧有方便慧亦不空。此辨所行不空。回向智智辨趣果不空。第二菩萨如是下广明有二。初明自业不空。后辨利他不空。初中虽明不空。义兼无失。以一切清净离烦恼故。又此无失即自业不空。顺止寂故。文有标征释结。释中皆先标后释。初四依正庄严。次六摄化庄严。言涅槃地者。以涅槃严地也。谓随有成道入涅槃处。当知其地即是金刚。今于一切处成。则无非金刚也。标云涅槃释云成道。文影略耳。四菩萨成就下结文可知。二若有众生下利他不空。于中有法喻合。文则可知。佛与菩萨俱益不空。今不见者不宜见故。见不益者无行力故。亦远益故。上来并答所成之行问竟。第二佛子菩萨摩诃萨住此下。答行所成德问。前文有二。今亦二段。第一答以行成因德。二答以因成果德。今初具答十二问。各有二句。上句答下句。上云修何灭废。今答以智他皆仿此。二用慈降魔。夫欲害人反招自害。苟欲安人则物我俱安。故柔胜刚弱胜强。以慈安一切恶魔。无以施害。慈善根力其功叵量。三福则怖之以威。智则屈之以辩。次四后四文并可知。八以方便智慧出生是答。一切菩萨已下即是所问。准上文中此有七事。今波罗蜜下欠总持句。然方便有二。若加行方便出生地度。若善巧方便。亦生诸度及余五法。智亦有二。若根本智即成内证。若后得智即成业用。是故此二出生此七。言清净者治彼障故。二佛子下答以因成果问。于中亦二。先结因成果。谓但勤修上来诸行。则能次第从因得果。二于无边世界下。正答所成之德。谓护持正法。但当勤修上来以行成因之德。自当成后护持法等诸德。故乘前结因成德明之。答上十句文分九段。第一答初总句。如来法藏守护开演。二佛所护念故。即答众魔外道无能沮坏。以佛护故。三守护受持下。答摄持正法无有穷尽。四于无边下。答于一切世界中。演说法时十王敬护。谓身胜音巧令闻者入智故。五知诸众生下。答举世同钦称机令喜故。六其身端正下。答菩萨爱敬端正有德故。其佛灌顶。在前第二佛护之中。七善知众心下。答得善根力增长白法。于中先总明三业。后得心下别显十种自在。皆是善根。其十自在之能。并是增长白法。八菩萨如是下。答开演如来甚深法藏。九佛子菩萨得如是下。答摄持正法以自庄严。于中初明自严。次征后释。以摄正法故。有十句德。亦即是前所成之德。可思准之。第二重颂分。十颂分二。初六偈颂前十种所成行体。后四偈颂行所成德。前中初二偈颂佛喜。于中初半颂不放逸。余颂佛喜。二有一颂。颂入地及大行大愿。三一颂。颂菩萨藏。及所应化而为说法。四一颂颂不舍自行诸度及所念众生。皆令得度。五半颂颂不断三宝。六半颂颂善根方便皆悉不空。二菩萨所修下颂行所成德。初一颂初行所成因德。后有三偈。颂以因成果德。于中初二颂。通颂前之八段。后一颂。别颂第九答摄持正法以自庄严。以喻而显。一身仪安谛颂前现身。次辨德威猛。颂前以无畏辩。三心定不动颂安其怯弱。四智深如海。颂以深智慧。五法雨灭障。颂前而为说法。第三时法慧下明结说分。谓契理合机故佛喜众奉也。第三会竟

大方广佛华严经疏卷第二十大方广佛华严经疏卷第二十一

        唐清凉山大华严寺沙门澄观撰

    升夜摩天宫品第十九

(第十九经)自下第三中贤十行会。初来意者。酬前十行问故。匪知之艰行之为艰。前解此行。若膏明相赖目足更资。故次来也。次品来者。此会四品分三。初二品当会由致。次一品当会正宗。后一品胜进趣后。于由致中。后品明赞德显体。此品先明感应道交。前会已终将陈后说。故次来也。二释名者。会名有三。一约处名夜摩天宫会。夜摩此云时分。即空居之首表十行。涉有化物宜适其时。时而后言闻者悦伏。时而后动见者敬从。涉有依空即事入玄。托此而说。约人名功德林。约法名十行会。并如后释。三皆依主。次品名者。大同于会。然梵本中。上无升字下有神变。译者以升为神变。升为神变略有四义。一不离前三而升此故。二升一处即升一切处故。三升已广其处故。四前后同时无障碍故。谓佛以圆遍之身。不起而升时分天宫。升属如来夜摩。约处相违释也。前升须弥后升兜率。准此可知。三宗趣者。会品之宗并如名说。意趣可知。四释文者。一品长分为十。第一本会圆遍。谓前会不散而说后会故。初句遍因。十方下遍相。亦有主伴等并如上说。但处加须弥。则而演说法通上三会。第二尔时世尊下。不离而升。第三时夜摩下。天王见佛并如前会。第四即以下。各严殿座。初一句总依空起行。故云化作。无著导行故曰莲华。一行含多所以称藏。余如上说。百万已下别显严相。于中四。初明座体备德严。皆云百万位渐增故。次百万夜摩下。明座旁围绕严。三从百万下法门行德严。文有八句。摄为四对。一因缘。二福智深心契理故。三愿行四体用。无生法体之所起故。四末后一句法教流通严。第五时彼下请佛居殿。第六时佛下如来受请。第七尔时下各念昔因。然晋经亦有乐音止息。今略无者译人之意。谓不如十解会事归理。不云乐音止息。不及回向事理无碍。不云炽然。退可同前进可齐后。故并略之。第八偈赞十佛。此十佛是前会十佛之前。如次十佛明位渐高念昔亦远。理实三世诸佛皆同此说。余如前会。文亦有二。先明此界后辨结通。前中十偈亦各有四。初句标名赞别德。次句通显具吉祥。三忆曾入此殿。四结处成胜极。亦初一句诸颂不同。初二字别名次二字通号。下三字别德。亦皆以下别德释上别名。一以闻十方释成名称。二以世间灯释宝王义。珠有夜光可代灯者。为宝中王。佛有智光照无明夜。故曰宝王。三四五六义并可知。七以世灯释胜天者。身智光照胜于天故。八以论雄释无去者。具勇智辩不可动故。九十可知。又此中殿各举别名。初一严体下皆宝之别德。谓此宝清净。以用庄严殊胜无垢。此宝发香是香必妙。能严之宝无所不见。可谓普眼如是。严者。是善庄严无处不严。名普严也。又善严者善因生故。第九尔时世尊入下。佛同升殿。第十此殿下。处忽宽容并如前会

    夜摩宫中偈赞品第二十

初来意者。助化赞扬故。说行体性故。行所依故。然三天偈赞来意宗趣大旨是同。但解行愿以为异耳。释名宗趣亦不异前。约处约行少有别耳。四释文者。文亦有三。一集众。二放光。三偈赞。初中有十。一明集因。亦即各随其类。为现神通也。二十方下主菩萨。三一一下眷属数。四从十万下来处分量。然显数随位增。信十住百回向是万。此合当千而云十万。或译人之误。或是十百则传写之误。五其名下列菩萨字。同名林者表十行建立故。行类广多故。聚集显发故。深密无间故。扶疏庇映故。此十菩萨。表行之体也。可以意消息之。六此诸菩萨下。来处刹名同名慧者。十解之慧行所依故。七此诸菩萨各于下。明所事诸佛。同名眼者。以智导行了了分明。成有目之足故。斯即十行当位之果佛。于此位显者皆名眼故。宜以当界之佛与当界菩萨。共相属对思而释之。八是诸下至已设敬。九随所下参而不杂。十如此下结通无尽。第二尔时下放光足上。谓跌背行必动故。背依轮指得有用故。表行依信解而成用故。余同前会。第三尔时功德林下。明说偈赞。十菩萨说即为十段。亦以东方为始。上方为终。各有说偈所依。谓承佛力等。今初菩萨。且就能说。积行在躬功德圆满。故名功德。若就所叹。叹佛胜德故云功德林。有十二颂。以是会主总叙此会普遍之事。于中二。初八述赞奇特。后四举德释成。前中四。初一偈叙此品放光。次二叙前品感应。次三叙此品众集。后二明自在普周。后四举德释成中二。前二举因显用。后二辨果用深广。于中一体用自在。上半不去遍至。下半卷舒相尽。谓一身即多。则一相不可得。多即是一则多相不可得。是故恒一恒多恒非一多。由此自在。一尘内身无不周于十方。遍十方身并潜一尘之内。皆悉圆遍非分遍。故难思议也。后一深广相成。上半牒广辨深。下半释深显广。谓不住故无处不至。不去故不离本位。此释深也。尘毛等处无不普入。广无边也。第二上明功德此辨智慧。悟此除冥难遇之慧。故名慧林。偈中叹此十颂分三。初一明佛难遇。次六别释难遇。于中亦三。初二益广难遇。次一因圆难遇。后三果深难遇。三有三偈校量显胜。于中初一长时大行校量。次一长时供佛校量。后一胜物供佛校量。第三胜林悟胜义甚深之法。故偈叹深广无涯之德。十颂分二。初三明佛德广博。后七显法体甚深横竖互显。前中初二喻况。后一法合。喻言孟夏月者取意译也。梵本敌对翻云后热月。西域如来圣教。一岁立为三际。谓热雨寒。西域记云。从正月十六日。至五月十五日为热时。则后热月。言兼得此方孟夏后半余之二际。各有四月准释可知。赫日之言。但取阳光时长难穷其际耳。彼方或为四时。与此名同。但以正月黑半为首耳。不见此文妄为异解。后七中令于依他修三无性观。以余之二性不离依他故。由于二性成依他故。谓圆成是依他体性。遍计但横执依他。又迷真似现故。即依三性说三无性。三性尚一岂有三无。三无但是即有之无。三性但是即无之有。有无不二为一实性。有无形夺性亦非性故。于一依他中具修诸观。文即分三。初三作生无自性性观。次二兼修胜义无自性性观。后二修相无自性性观。今初即分为三。初偈正观无生。初句果空。谓缘生果法非先有体。从世性微尘。及未来藏因缘心识中来。若有来处即先已有。如鸟来栖树何得言生。次句因空既无有果。对何说因。又世性等。亦是妄计因缘有故。次句双遣所从。是因所生是果。又初句不自生。次句不他生。次句不共生。又初句非先有而生。次句非先无而生。次句非半有半无。三义各以末句息妄成观。次偈以无生释无灭。略有三义。一无生可灭故。二无待对故。三例生从缘故。后偈观成利益。经。云无生即是佛。故论云。若见因缘法。则为能见佛。依他因缘即无生故。次二偈约依他。兼修胜义无自性性观中。前偈遣所观。上半辨观。下半明益。各含二义故致兼言。一者成前。谓非唯能相之生。生即无生。所生法体从缘无性。即无所有。此显依他无生是圆成。性益云深者即事而真故。二云无生真性亦无所有。即彼胜义无自性。性益云深者真性不立故。后偈遣能观然有二义。一成前所观。谓以无性故无有能了。如无有人能了龟毛长短大小。知无所了是究竟了。二是正遣能了。既无所了亦无能了。能所两亡为究竟解。后二偈明相无自性性观。中初偈正明后偈总结。前中上半显执。不了国等依他谓为现见。妄计为生故。晋经云。所言有生者。当知由所生。下半明观。若知无性则离遍计故。后偈总。结称于事理之实以观世等。故善说也。第四以信乐力闻深不畏。名无畏林。偈叹信向益深德故。十颂分二。初一所信之境。谓法身体即法界。智身证极法界。致令应用之身不动而遍。后九闻信之益分五。初一闻信离恶。次二辨其难闻。次三明闻信成佛。将过去已成证现未当成。四有一偈明闻必有由。励物起愿。五有二颂显起行益。第五拒妄崇真。拒迷崇智名为惭愧林。偈赞如来大智胜益。十颂分三。初三法说难思。次六以喻并决。后一结德归佛。今初初偈明闻生胜益。令物希闻自在法者即佛智也。次偈佛穷种智故下位难思。后偈显智从生。此文反显。然有二意。一者成前。谓欲生智慧当于佛求佛。无不知故。不应求之于凡凡暗冥故。犹搴芙蓉必于深水。而于木末安可得耶。二者成后智。从熏习自种而生。不从烦恼无智所生。是故下。言二心不同时。属自愚智故故应慎所习也。若尔何以。经言烦恼泥中有佛法矣。此说在缠如来藏故。然此大智从藏德生。非从迷起。若尔烦恼即菩提。复云何通。约体性故。从所迷故。如波与湿。然实义者真妄愚智。若约相成二门峙立。若约相夺二相寂然。双照二门非即非离。若说一者离之令异。如此章中。若云异者合之令同。如后章是善须得意。勿滞于言。若准晋经。云非从智慧生。亦非无智生。了达一切法灭除世间闇。则显智体绝于愚智。不称实了则名无智。此偈双明性相。后喻但显二相不同。二并决中二。先五明二性相违。后一辨功能不等。今初。唯第二偈三句是喻。余偈喻合。各有半偈。一约色非色者。非色谓心缘虑质碍体性不同故。二中有二喻。相无相者理事相反。生死涅槃真妄相反。虽同一体。分别义门不相是故。三成之与坏约相别故。四初心后心时不同故。五诸识身所用别故。缘会不同故眼无耳用。又此眼识不合余根。识身同识尚不相合。愚智。性异安得相生。二功能不等者。非唯二性各别。然智能灭愚愚不灭智。药能去毒毒不去药。亦犹明能灭闇闇不灭明。三一偈结归如来。迥出世表故难值遇。第六勤观理事同无差别。离身心相故名精进。十颂总相显佛此德。前即无差之差。此乃差之无差。二章相接显非即离。亦互相成。十颂分二。初一约法双标。后九就喻双释。今初也。初句标其所知。五类之法皆无有差。余三句对人以显。次句拣非余境。下半唯佛究尽。后九释中前五释所知。后四释能知。前中初四正释。后一遣疑。前中皆上半喻。下半法无差所由。在于末句。然其能喻不离诸法。取其所易喻其所难耳。一体色无别喻。此喻为总。喻虽是一法合有二该横竖故。竖约理事交彻。法者事也非法理也。色即空故。亦可法真法也非法妄法也。取文虽异义旨乃同。谓如金之黄色与金体斤两性无差别。随取互收。合中金是所依喻其真法。色是能依喻妄非法。以妄无体揽真而起。则真无不隐唯妄现也。以真体实妄无不尽唯真现也。是则无体之妄不异体实之真。故云无有异也。亦同密严如金与指环展转无差别。横者异法相望。法者可轨之法也。非法者。不可轨之法也。又法谓有法非法谓无故。中论释法不生非法。云有不生无故。体性无异者。谓同如故。然前义正顺于喻。后义乃顺标中。诸法之言要由初义性相无差。方得显于后义事事无差。若但用后义。未显相全同性。那得显于事事同于一性。第二偈假名不实喻。以真夺俗是故无差。揽缘成众生。即虚非众生。所遣既无能遣安有。故俱无实。以喻诸法皆无实义。并从缘故。若以正报为众生。依报非众生。乃全是所喻非实之相。尚难显了。三三世互无喻。喻无相故无别。谓若未来有过去者。应名过去何名未来。故知定无过现之相。文举一隅应反余二。诸法无相如彼互无。此以差别喻无差别。四四相非实喻。喻无性故无差别。生等四相离所相法。无别自性。一切诸法离所依理。无别自性。此以相无喻于性无。后遣疑者。疑云若都无别。云何见有性相等殊。故此释云。亦如涅槃体离有无百非斯绝。而强立名字曰余无余。诸法亦然。真俗并虚分别成异。若离分别则无一切境界之相。第二四偈。喻能知者皆展转遣疑。初偈疑云。既有分别则有能知。故释云。离所数物无能数数。既所知无性何有能知。无知之知是真了法。次复疑云。若依向喻能数喻能知。能知虽无所知犹有故。复用能数法以喻所知。智慧差别以喻能知。反覆相遣显无差理。谓一上加一名之为二。乃至百千。皆是诸一。由能数智作百千解故。晋译中第三句。云皆悉是本数。今译明一多相待故。无体性喻彼妄想。于无性中计为有无耳。次又疑云。都无能所何名佛智。故释云。能所双亡佛智斯显。故所知妄法如世成坏。能知真智湛若虚空。尚不初成况当有败。如出现品。又权智照俗同世成坏。权即是实如不离空。末偈疑云。佛智既等应用何殊。释云。随心妄取佛无异相。又谓常无常如各取空。佛智双非如空无别。第七智了三种世间。性相诸边不动。故名力林。十颂显佛离相真智。于中分三。初四遍明世间。次五双遣世及出世。后一观成利益。今初略有二观。初二偈摄末归本观。显众生世间空。后二缘生无作观。兼显器世间空。今初也。初二句。推假名众生不出三世。显是无常。次二句推三世众生不出于蕴。显无有我。次句蕴由业生。以明果空显非邪因。次句推业唯心明心外无法。次句体心如幻。不离性空及与中道。如幻无性故。非有非无故。末句以本例末。则上五一如皆展转缘生故。二缘生无作观中。初偈无作故缘成。后偈缘成即无作。今初言不自他作者。通遣诸非。一约外道非自性等作。亦非梵天等他作。但以虚妄无业报故。广如三论破。二约小乘非同类因自作。亦非异熟因他作。以皆相待无自性故。三约因缘相待。如十地论及对法所明。四约以因望果。中论云。自作及他作。共作无因。作如是说。诸苦于果则不然此自他言含于二意。一以果为自以因为他。论云。果法不能自作已体故。二以因为自以缘为他。此明不从因缘。无果待对故。离既不成合亦不成故。论云。若彼此共成应有共作。若彼此尚无作。何况无因。作彼此即自他也。下半二意。一不碍缘成以遣无因。二非但不碍幻有。亦由有空义故能成因果。是则不动真际建立诸法。又非但说于苦四种义不成。一切外万物四义皆不成。成坏之言显兼器界。后偈缘成即无作者。向约幻有。虽言成坏幻有即空故不应说。是则不坏假名而说实相。第二五颂双遣中。初半偈假征。次半标答。次偈出体释成蕴是世间缘成。寂灭即出世间故。净名经云。世间性空即是出世间。一体说二故云假名。次二句征蕴名体。世以蕴为体。蕴以何为体。次二句标答。上句答体下句答名。应名无生五蕴。既云性不可灭。则显前非事灭。次一偈释成空故不灭亦非事在。不灭则知本自不生。是无生义。后一偈例出世间。显智正觉世间。亦应缘无性。又证无性之理为自体故。末后一偈明观益者。佛以实法为其体故。见法则常见佛也。第八照理观佛而起正修。故名行林。十颂观佛体相普周德。于中分二。前七约喻显修。后三见实成益。前中复二。初二地种无性普周喻。喻佛无生遍应德。后五业相无依成事喻。喻佛难思现用德。于中二。三偈喻二偈合。前中初一明业果互依。次偈明相依无性。业不离生故业性空。因业有生故生无来处。后偈双结难思显成真观。若逆推其本。业复有因卒至无住。无住无本故无所见。无见之见方了业空。二颂合中。初偈难思普应。合上业果互依。次二句。以互不相是。合互依无性。身若是佛转轮王等即是如来。佛若是身。正觉之心应同色相。后二句结示真体。唯如唯智。合第三偈难思达本。二有三偈明见实中。初颂见佛即了法。以见佛称性不疑同体故。次偈见法即见佛。了法即性净。知佛不住性相故。后偈明了正修行。照了无相心寂分别。寂照双流故名正念。则从佛法生是法王子故。又上三偈初知离名为法。次知法名为佛。后知无名为僧。穷见三宝之实体也。第九照心本末名为觉林。十颂显于具分唯识。大分为二。前五约喻显法。后五法合成观。前中二。前二约事后三约心。乍观此喻似前喻所作后喻能作。细寻喻意。前喻却亲。故喻真妄依持。后喻心境依持。然依生灭八识。但有心境依持而即如来藏心故。有真妄依持。以会缘入实差别相尽。唯真如门。即前喻所显。摄境从心不坏相故。是生灭门。即后喻所明。存坏不二唯一缘起。二门无碍唯是一心。故下合中但明心造欲分义别。喻显二门。是名具分唯识。今初。二偈真妄依持即真如门。摄一切法也。初偈初句总喻一心。次句喻随缘熏变成依他也。次句不了依他故成遍计。第四句喻依他相尽体即圆成。后偈喻依圆真妄非即离义。上半不即能所异故。大种中无色身所触故。色中无大种眼所见故。又能造无异画色差别故。喻妄依真能所异故。性无差别相不同故。下半不离义。谓所造青等。离能造地等无别体故。假必依实同聚现故。喻妄必依真性相交彻故。然大必能造色。非色能造大。喻妄必依真起真不依妄生。故不云也。然不离于色有大种可得。后三约心者。喻于唯识心生灭门。于中初一亦明心境不即离义。上半不即。心中无彩画。不可见故。彩画中无心。无虑知故。喻能变所变见相别故。下半不离随心安布故。喻离心则无境界相故。要由心变于境。非是境能变心。故云唯识。不言唯境。但云然不离于心有彩画可得。不言然不离于画而有心可得。次一偈喻能所变之行相。明画师巧思不住。变态多端。所画非心谁相知者。法合彼心者。真妄和合心也。恒言遮断。不住遮常。如瀑流故。含一切种故云无量相。甚深细名难思议。次句顿现万境。下句喻所变境。离心无体。又常不住者。无住为本故。无量难思总标深广。下二句释。示现一切广故难思。各不相知深故难思。三一偈。重喻上来不相知义。谓非唯所画之法。自不相知。喻所变之境无有体性。能画之心念念生灭。自不相知故。亦不能知于所画。双喻心境皆无自性。各不相知故。言不能知自心而由心故画。又虽不知画心。而由心能画。喻众生虽迷心现量而心变于境。又由不能知所画。但画于自心故。能成所画。喻众生由迷境唯心方能现妄境。又喻正由无性方成万境。故云诸法性如是。第二五偈合中分四。初一偈合。初二句初句合。最初句心者。即总相之心也。下三句合。第二句诸世间者。即诸彩色此句为总。下出诸相即蕴界处。故云无法不造故。晋译云造种种五蕴。正法念云。心如画师手。画出五彩黑青赤黄白及白白。故上文云。布诸彩色。画手譬心六色。如次喻地狱鬼畜修罗人天。若言种种则十法界。五蕴等法皆心所造。次二颂合前初偈下半。于中二。初一举例以合。由成前诸言。谓如世五蕴从心而造。诸佛五蕴亦然。如佛五蕴。余一切众生亦然。皆从心造。然心是总相悟之名佛。成净缘起。迷作众生。成染缘起。缘起虽有染净心体不殊。佛果契心同真无尽。妄法有极故不言之。若依旧译。云心佛与众生。是三无差别。则三皆无尽。无尽即是无别之相。应云心佛与众生。体性皆无尽。以妄体本真故亦无尽。是以如来不断性恶。亦犹阐提不断性善。又上三各有二义。总心二义者。一染二净。佛二义者。一应机随染。二平等违染。众生二者。一随流背佛。二机熟感佛。各以初义成顺流无差。各以后义为反流无差。则无差之言含尽无尽。又三中二义。各全体相收。此三无差成一缘起。上约横论。若约一人心即总相。佛即本觉。众生即不觉。乃本觉随缘而成此二。为生灭门。下半此二体性无尽。即真如门。随缘不失自真性故。正合前文大种无差。若谓心佛众生三有异者。即是虚妄取异色也。后一偈反势合。谓妄取异色则不知心行。若知心行普造世间。则无虚妄。便了真实。即正合大种无差。兼明观益。三一偈有二义。一双合前真妄心境不即离义。上半合前二三偈之上半。即前互无不即之义。心即能变及心体故。身即所变。谓有根身是识相分及性之相故。下半双合前两偈。下半不离之义。谓虽不相住。而依心现境依体起用。作诸佛事体用不碍。为未曾有。二又将合前第四偈。谓上半合前恒不住义。及各不相知。而能作佛事。合示现一切色。自在未曾有合无量难思议。为兼此义。不以互无言之而言不住。译之妙也。晋经但云心亦非是身。但得前文互无之义。末后一偈结劝即反。合前画师不知心喻。若不知心常画妄境。观唯心造则了真佛。上半有机下半示观。然有二释。一云。若欲了佛者应观法界性。上一切差别皆唯心作。以见法即见佛故。二观法界性是真如门。观唯心造即生灭门。是双结也。又一是真如实观。一是唯心识观。大乘观要不出此二。观此二门唯是一心。皆各总摄一切法尽。二谛双融无碍一味。三世诸佛证此为体故。欲知彼者。应当观此既为妙极。是以暂持能破地狱。第十鉴达诸佛迥超色声。心言路绝故云智林。颂显此德十颂分二。初一标章后九解释。今初。若准晋本。第四句云所思不可思。则四句皆标章。今经则上三句标章。第四句总结。谓标章遮过令不依识。明佛三业非凡境故。第四总结显德示智入门。谓若了唯一真心。言思斯绝则合菩提之体故。梵本第四句。云于不思何思。即是以一真心而成三业。三业不离一真形夺相融。不可以一多思也。又非唯佛之三业同一真心。亦与观者真心非异非一。故难思议。若能离于思议则终日见闻。亦无所见闻矣。后九别释中。即分三别。初二释不可取。次四释不可见。后三释不可闻。今初也。初半偈夺以正释。后一偈半纵以生过。然有量等实通三业。为对下二且就智明。有如理智不可言量。有如量智不可言无。又一智即是一切智故。众智所用不相杂故。后纵中初半。纵其令取必无果利。后一偈显取之失。夫说法者。当如法说法无所得而欲取得。心计有说执石为宝。是谓自欺。理无谓有是为自诳。终不契理。故云。己事不成污他心识故不令众喜。又以量无量取则堕断常。自损损他故皆不可。第二有四偈。叹佛色身深奥释不可见。章文分为二。初一法说后三喻况。今初。非色现色故称为妙。物感斯现是曰无边。又色即空故边即无边。又净识所现空色相融。故身分总别。乃至一毛皆无边量。摄德无尽。具上三义岂可以尽言。次三喻中分二。初一摩尼随映喻。喻佛地实无异色。随感便现故言无色而现色。喻全似法。故但合云。佛亦如是。后二偈净空现色喻。喻佛法身体非是色。能现粗妙一切诸色。初偈喻后偈合。四句对前。但二三前却此是分喻。故委合之。以空但不可眼见。而可心知。佛所现色心行处绝。故为分喻。心眼尚不能见。况肉眼哉。此即见中绝思议也。问二喻。岂不违经上云有无边妙色。今云非色无色耶。亦违诸论佛有妙色为增上缘。古德云。若约初教大乘义。如前说。若实教大乘。佛地无此色声粗相功德。但有大智大悲大定大愿诸功德等。然诸功德等并同证真如。若众生机感。即现色无尽。既无不应机时。故所现色亦无断绝。此以随他为自。更无别他自。约此为有。故云。无边妙色。今约自说。不约随他。故云无色非色也。亦可前喻初教后。喻实教。有云。若尔彼能现体为有无耶。十莲华藏尘数之相。皆示现耶。八地七劝。言佛色声皆无有量。宁不违耶。若执佛果。唯有如如及如如智独存者。无漏蕴界穷未来际。遍因陀罗网皆非实事。亦违涅槃灭无常色而获常色。此义具如智慧庄严经说。然上二解各是一理。并符经论。今当会之。摄末从本唯如如智。自受用色智所现故。摄相从性但有如如。既所现即如。何妨妙色。故有亦无失。然如外无法何要须现。万法即如如即法身。更何所现。故云唯如如。及如如智独存。于理未失。如色相即有无交彻。若定执有无恐伤圣旨。故今二喻前后相成。摩尼现色但云无色。无即但是无他。非无自体。净空现色既云非色。非即非其自体。不独无他。前喻自受用身后喻法身。此二不二为佛真身。故下经云。佛以法为身清净如虚空。所现众色形令入此法中。第三三偈。释所闻不可闻中。初约应声缘感。便应离相离性故。声非如来应不差机。非声之声故云不离。故以声取是行邪道。若离声取未免断无。次颂约体释。湛然不迁。心离分别。尚非心见安可耳闻。犹如天鼓无心出故。此即闻中不思议也。后偈释疑。疑云。为是有法不可闻耶。为是无法无可说耶。上半顺理后句答。次疑云。若尔何以现闻教法。下半释云。但自心变非佛说也。若依权教。此约有影无本。然本影相望通有四句。若依此宗果海离言故无有说。用随机现谓如是说。而此本质亦是自心余如悬谈中说

大方广佛华严经疏卷第二十一大方广佛华严经疏卷第二十二

        唐清凉山大华严寺沙门澄观撰

    十行品第二十一(从第十九经半尽第二十一经)

来意有二。一前序此正故。二前辨所依佛智。此辨能依之行故。二释名者。随缘顺理造修名行。数越尘沙寄圆辨十。仁王名为十止。就三学中定心增故。梵网名。为长养。长道根故。若具梵本。应云功德华聚。菩萨说十行品则兼能说人。今文略耳。宗趣可知。四释文者。此品不同前二。有行德者以行为主。故略无之。又行德已纯熟进趣中收。故唯一品义当行中之解。品有七分。一三昧分。二加分。三起分。四本分。五说分。六现证分。七重颂分。今初三昧分。功德林入者为众首故。表说十行众德建立故。承佛神力是入定因。入菩萨善思惟者。显定别名。拣因异果故名菩萨。巧顺事理拣择无碍。无心成事名善思惟。二入是已下明加分有三。初总辨作加因缘。二辨加所为。三正显加相。初中四。一总标加因。二十方下加缘显现。三告功德林下赞有加因。四善男子下双显加定因缘。于中二。初别显所因。二令汝入下结因所属。今初。亦有四因。一伴佛同加准十住会。即是神力加也。二主佛宿愿。三主佛现威。四大众机感略无助化善根。或是诸字中摄故。余义具于前会。二为增长下辨加所为。有十一句。前十别明。后所谓下一句总结。乃至起分皆同前会。但住行之殊。第三善男子下。正辨加相中三。初语业加。命其说故。二是时诸佛下意业加。与智慧故。有别显征释。别显中初总余别。别中一捷辩。二无断辩。三无师智。前后二会并无此智。即是本觉之智了因自得悟。不由师。假佛缘显故得云与。及无痴智并是迅辩。四应辩五无谬错辩。六丰义味辩。七一切世间最上妙辩。八总策前七九。此七无胜。三尔时下身业加。增威力故。第三时功德林下。起分可知。第四告诸下本分文二。初行体后行相。前中若约所依。即前善思三昧为体。若约所观即二谛双融。若约能观悲智无碍。今从教相。即下四行为体。若约十行别体。即以十波罗蜜为体。义见初会。今就教相中。若直就经文文分为二。初标显。二何以下征释。初中先标行体难思。行即深心所修行海也。与法界下显难思之相。深等法界广齐虚空。故心言罔及也。又超下位名不思议。又即理之事行。同事法界之无量。等虚空之无边。即事之理。行同理法界之寂寥。等虚空之绝相。此二俱非言之表诠心之显诠。故难思议。况二交彻。能令一行摄一切行。一位摄一切位。纯杂无碍故。第十行。云入因陀罗网法界。成就如来无碍解脱。人中雄猛大师子吼。乃至到一切法实相源底故。又若唯遮者则凡圣绝分故。非但遮常心言。亦应融常心言。是则于中思议不可尽也。遮融无二。则思与非思体俱寂灭。方曰真不思议。从征释中。何以因人之行便叵思耶。释云同佛果故佛穷事行之边。极理行之际。断一切障证一切理。因圆果满融无障碍。菩萨同彼宁可思议。若取论势。菩萨行为总句。余皆是别。不可思议即真实行也。彼约地前不见。此约凡愚叵思。亦名真实行布。位中无真如观故。无观相行。二与法界等即是胜行。亦是佛本故。三与虚空等即因行也。是无常因亦未得地智。缺常果因也。四学三世佛而修行者是不怯弱行。未能顺理真实救护。故无大行。余同前会。第二佛子何等下辨行相。文分为三。初总征其名。二佛子下标数显胜。故云三世诸佛同说。三何等下征数列名。先征次列后结。列中。然与本业名虽小异。而义意大同。一施悦自他故名欢喜。约三施说在因皆悦故。下经云。为令众生生欢喜故。若就果说。财获富饶无畏。身心安泰。法施当获法喜皆欢喜义。此约随相。本业云。始入法空不为外道邪论所倒。入正位故名欢喜行。此约离相。二三聚净戒亦益自他。故名饶益。或以后摄前。本业云。得常化一切众生法。皆利众生故。此唯据利他。三忍顺物理名无违逆。彼云得实法忍无我我所名无嗔恨。此约以后摄初。晋云无恚恨。亦是以初摄后。而实二忍顺物法忍顺理。以后遵前。皆顺事理。四勤无怠退名无屈挠。亦通三勤。彼云。常住功德现化众生。故名无尽。谓若有怠退斯则有尽。而摄论三精进中。三名无弱无退无喜足。则是以后摄初。五以慧资定离沉掉故。名无痴乱。彼云。命终之时。无明之鬼不乱不浊住正念。故名离痴乱。此但从一义。故下经云。于死此生彼心无痴乱。六慧能显发三谛之理。般若现前故名善现。彼云。生生常在佛国中生。此但据得报。谓即空照有而能现生。七不滞事理故名无著。彼云。于我无我乃至一切法空故。此即涉有不迷于空。谓于我而无有我也。若于我无我皆不著者。则双不滞也。以有不舍不受方便智故。八大愿可尊故。又成大行愿乃能得故。故名难得。彼云。三世佛法中常敬顺故。名尊重行。彼约修心此约难胜。九善巧说法名善法行。彼经云。说法授人动成物则故。同于九地法师位故。十言行不虚故名真实。又称二谛故。故彼经云。二谛非如非相非非相。故名真实。然上约十度释名。度各有三。并见初会。第五佛子何等为下说分。十行则为十段。一一各三。谓一征名。二释相。三结名。今初。欢喜行即是檀度。初征名中已如前释。第二佛子此菩萨下。释相分二。先略辨体相。后修此行时下。广显名相。今初。瑜伽菩萨地。菩萨六度各有九门。一者自性。谓出行体。二者一切。谓能具行。三者难行。谓就中别显。四者一切门。谓行差别。五者善士。谓作饶益。六者一切种。谓偏摄圣教。七者遂求。谓随所须。八者与二世乐。谓于现在作大饶益。令得未来广大安乐。九者清净。谓胜离相成波罗蜜。今文分三。以摄于九。一总标施主。二其心下离所不应。三但为下彰其意乐。今初。含摄前四及与六七。谓一者施主惠施。显施自性。惠有二义。一惠即是施。二谓巧惠筹量可不。凡所有物悉能施者。摄余五门。谓一若内若外。二若难若易。三财法无畏。四一切种门。五随求与故。二离所不应即清净施。文有五句。以摄十义。心平等者略有四义。一无执取。离妄见故。二不积聚。施观渐与顿皆平等故。三不高举。但行谦下不与他竞。离憍慢故。四无向背。不朋党故。言无有悔吝者。此有三义。一不退弱。施已无悔故。二不下劣。胜物无吝故。三不留滞。速与无吝故。言不望果报者。不求异熟果故。不求名称者。无所依故。不贪利养者。不望报恩故。三彰其意乐中。有十二句摄上二门。谓前十一句明善士施。此有五相。一但为救护者。不损恼故。二摄受者。自手授与故。三饶益者。应其时故。上三下益。次有八句。明其上攀不出二意。一净信故。二恭敬故。八中一创起习学。二忆持不忘。三爱乐不舍。四净治其障。五更修增广。六住持不断。七令不隐没。八演以示人。后令诸众生离苦得乐。结归慈悲。即二世乐。上但为之言流下诸句。又上救护是无畏施。摄受是财饶益是法。第二广显名相中。广前一切施也。亦具诸施恐繁不配。文中二。先现行财施。后愿行法施。财中复二。一随相。二离相。前中亦二。一明施行。二回向行。前中亦二。初愿受胜生行施。二示异类身行施。前中依无著论有六意乐。一方便。二欢喜。三恩德。四广大。五善好。六清净。下并具之。于中文四。一愿具施缘。即方便意乐先作意故。亦即广前为大施主。二假使下难求能求。三尔时菩萨下。明难舍能舍举难况易。即便施者无留滞也。四如是下明一切无违。有三意乐。初即广大意乐。能广行故。二但更下。即欢喜意乐也。三作如是念下。恩德意乐也。我今应下是随顺心。第二又作下。明示异类身而行布施。回现施善未来受身。以悲深故。亦广大心也。第二以此下回向行。初自期大果。亦广大意乐也。后愿施田亦得二果。是善好意乐。第二菩萨如是下。明离相施即清净意乐也。随相离相行必同时。言不并彰故分前后。应将离相别别贯前。如大般若。不欲繁文故。并居一处。前后体势类此可知。文分为三。初人空观。次法空观。后二观之益。即成彼岸智。今初也。如是利益众生者。牒前事行。欲显正利益时。即无我想等故。所无之法略有十句。我谓主宰诸蕴假者也。故智论三十五云。于五蕴中我我所心起故。瑜伽大同此说。此句为总。但是一我随事立下别名。然由迷缘生实性。计有即蕴异蕴之我。既了性空迷想斯寂。故云无也。若别别观无之所以。如十定品第二定辨。二众生者。智论云。五蕴和合中生故。瑜伽名为有情。谓诸贤圣如实了知。唯有此法更无余故。三有想者。智论瑜伽俱名生者。谓计有我人能起众事。如父生子故。有即所起诸趣生也。四命者。谓命根成就故。瑜伽云。寿命和合故活存现。五种种者。智论名为众数。谓阴界入等诸因缘。是众数法故。新译名异生。能受异趣生故。六补特伽罗者。此云数取趣。瑜伽云。计有我人。数数往取诸趣无厌故。此名依一声中呼一人。若依多声中呼多人。即云补特伽罗。七人者。有灵于土木之称。智论云。行人法故。大般若名士夫。瑜伽释云能作一切士夫用故。八摩纳婆。此云儒童。谓计有我人。为少年有学之者。此名依一声中但呼一人。若呼多人多声中呼。应云摩纳婆嚩迦也。九作者者。作诸业故。智论云。手足能有所作故。十受者者。智论云。计后世受罪福果报故。大般若第三四。大品第二及金刚般若中说数有增减。名或小异。大意不殊。回向十定准斯会释。二但观下明法空观。菩萨既了法空。安有我耶。故上云人空非如二乘人空法有。故此直云但观法界空等。法界众生界总举所观法体。不出此二。菩萨了之究竟无差。横则无边。等虚空故。竖则无际。离始终故。空法者此二皆空也。空亦总句。何以知空。但有名字无实所有故。无何所有。一外无自共之相状。二内无有为无为之体性。三无所住之处。所谓不在内外中间有中住故。四无二法之相依。有去不留空故。五无造作之功用故无所有。无所有故空。空故众生界即法界也。第三作是下观益。九句皆云不见者。穷于法性到彼岸故。初三即是三轮。福田者施所生也。业约成因而招当果。克获为果酬因曰报。习因习续于前。习果克获为后。习因习果通名为因。能牵后报此报酬因。此则果通现得又报谓有漏。果谓无漏。同是当果。漏无漏殊。小施小果大施大果。第二愿行法施。文分为二。初观悲境为起愿由。二我当尽学下。起愿利益。不坏法性是坚固因。安隐快乐是坚固果。第二饶益行。释相之中先略后广。皆显三聚含于九戒。今初。略中文三。初明持相。次彰离过。后显持意。今初。初句为总。总该三聚即戒自性。于色声下别释净义。意地无著是真律义。亦为生说。即饶益有情戒也。二不求下彰其离过。亦是于果无依。显清净义。三但坚持下。显持戒意。初句为总。尽寿坚持。作如是下以誓自要成上坚相。谓一切利养恭敬。他论本随烦恼不能伏故。一切恶止得佛正法。是真善行。缠谓八缠。即无惭无愧掉举恶作惛睡悭嫉。初二障戒。正障律仪。次二障止。次二障观。后二障舍。即障善法饶益。于相修中。缠绕身心所以偏说。或说十缠。谓加忿覆。于被举时为重障故。此即随惑。缚谓四缚。即贪欲嗔恚戒取我见。贪利不遂热恼生嗔。梵行命难则生毁谤。谤则戒取我则浊乱。不毁不持方为平等。第二佛子菩萨如是下。广显三聚。即分为三。初摄律仪。二摄众生。三摄善法。今初即坚持不犯。为第一难持。文中亦二。先显难持之境。谓多而且丽加以惑心。日日长时。故为难也。后尔时菩萨下。起观对治。即能持于难持也。言乃至者。大品云。贪着五欲障碍生天。况复菩提胜事皆障故。云乃至。第二唯除下摄众生戒。于中四。初明忘犯济物。如只陀末利唯酒唯戒。唯除教化。即行于非道不舍智心。即通达佛道。二佛子下轻身益物。为第二难持。乃至舍命亦无缺故。三菩萨自得下。彰持分齐。是第三难持。谓恒住正念无误失故。即以难况易以误况故。本性惯习故分齐者。初发心住。了见心性成正觉故。解法无生常见佛故。触境皆佛。岂容佛所生欲想耶。四尔时菩萨下。明深起大悲是善士相。在文分三。初悲物着欲。二生劝持心。三征释所以。今初。七句初二为总。无时不起。是长夜中想念。下别。一想念未得。二趣向可得。三贪着已得。四决谓为净。五耽染无厌。六迷醉沉溺。七随境流转。八欲罢不能。二我今下生劝持心。初劝他持戒。次住净戒下兼赞戒功德。三征释者。大悲益他菩萨家业故。第三作是学已下。明摄善法戒。文分为二。初明自分现摄。后辨胜进当摄。今初。善法虽多不出悲智故。文中略举于中分三。初双标悲智。二然知已下。双释二相。三如是解者已下。双明二果。今初也。先智后悲。智中先明离过。谓离恶行无明。后以智下明其成德。为众生下即是摄悲。二双释二相中。悲智双运文分为二。先以智导悲自成正观。二一切诸法下。通明入法显彼倒因。今初。文有四对。前三二互相望。后一当体以辨。前三对中。前二不离后一不即。即显生之与倒非即离也。众生即能起颠倒之人。乃染分依他。颠倒即所起之妄。是遍计所执。初对明不离者。谓依似执实故。离生无倒。依执似起离倒无生。第二对明不相在。重释前义。言不离者。明因果相待缘成非先有体。二物相在因中无果。故倒内无生。若必有者则应遍计是依他起。果中无因故。生内无倒。若要令有者。则应无有不倒众生。第三对明不即。不坏因果能所遍计之二相故。由前三对则知生倒非一非异非即非离。第四对当体以辨倒心。托境方生故非内法。若是内者无境应有境。由情计故非外法。若是外者。智者于境不应不染。既非内外宁在中间。则知心境。当体自虚。将何对也。以明即离众生亦尔。即蕴求无故非内法。离蕴亦无故非外法。既非内外亦绝中间。本性自空何能起倒。将何对他明非即离。既如是知则自无倒。为物说此倒惑自除。二一切下。通明入法显彼倒因。谓由不达缘成不坚。妄生遍计。故云诳惑愚夫。实则愚夫自诳。若猕猴执月。三如是已下。双明二果。即前悲智所成之果也。亦九戒中二世乐戒也。先总后别。总中由解诸法不实幻化。即是觉了诸行了行相虚。名达生死。知行体寂是了涅槃。了之究竟即得菩提。自得度下别有九对。一度苦。二脱集。以了生死故。三调之以道。四寂之以灭。以了涅槃故。次四即证四谛之德。如次配上。谓由断苦故。得安乐等。九即证佛菩提之乐。第二佛子已下胜进当摄。于中有二十句。前十具胜德。一顺佛二离世。三行胜法。四住等理。五等慈。六明智。七离过。八忘缘。九舍执。十不断烦恼而入涅槃。后十住深智。末句为总即是佛智。余别显深广之义。一上无过。二言不及。三离依着。四无变动。五超数量。六无边畔。七无终尽。八绝色相。由上故深。第三无违逆行。即是忍度。于释相中文分二别。初略辨行相。后对境正修。今初分三。一修忍行。二离忍过。三修忍意今初。常修忍法。即标行所属。谦下等言彰忍之相。文有十句。初总显自性。谦尊而光卑而不可踰。若海之下百川归焉。恭敬崇彼安敢不忍。不自害下九句别明。通有三释。一约三毒。二就三业。三据三忍。初云。前三治嗔行忍。嗔必害故。一无如前境而自刑害。二力及害他。三以死相敌无论先后。及与一时但取两害。次三治贪成忍故。梁摄论云。取是贪爱别名。一自贪名利。二使彼令取。或随喜彼取。三兼行上二。后三治痴修忍。痴故执着一着己德能。云何毁我。二彼人若是云何辱我。三俱染可知。此九皆过菩萨正观。以不不之能治之观下文自辨。二约三业者。害必加身着必由意。自他赞举名为取也。苟心赞他尚为谄媚。况自称举。故并安忍之。三约三忍者。害即怨害。取即不能安受饥寒等苦。妄受取故。着则不见谛理。由见谛理。三忍皆成。故思益云。诸法念念灭。其性常不住。于中无骂辱。亦无有恭敬。若节节解身。其心常不动等。又上三即约违顺中庸之境。故成三毒。余可准思。二亦不下离忍过也。名引中人利诱下士。菩萨上士。故不贪求。三但作下修忍之意也。所以修者。先自忍己后为生说。令修忍行离恶断惑。是内安忍惑亡智现。则住法忍。既去烦恼矿秽。则身心柔和堪任法器。如彼炼金。上来皆是清净忍也。第二佛子下。对境修忍广显行相。文中分二。先明修忍行。后明修忍意。前中有三。初耐冤害。次安受苦。三谛察法。今初分二。先彰难忍之境。后明能忍之行。此亦难行忍也。今初分三。初明口加毁辱故。梁摄论以耐冤害。亦名他毁辱忍。略显十种。一触忌讳故。二恶轨则故。三令忧戚故。四无风雅故。五极庸贱故。六诠邪恶故。七不入人心故。八诠猥杂故。九极鄙恶故。十极粗犷故。以是言下总结所作。多人多口各多恶言。二又此下身加逼害。上二事广。三如是经下总辨长时。是谓难忍之境也。二菩萨遭此下明能忍行。先结前生后。谓遭前极苦。二作是念下正显忍相。以失自要。文有十句。初一假设不忍失念易志故。云动乱。余九明失。一则不调嗔恚。二则不护根门。三迷忍法门。四不修忍行。五随风外转。六动乱内生。七不惜善根。八未忘彼此。上八自损。由此不能利他今能忍故。以不不之。便成八行。自他俱利自他俱调。若说此胜利成善士行。二菩萨尔时下。安受苦忍。虽仍前文义当安受故。引往所受苦以况今苦。而欲安受。所以引者。无始显昔苦时长。诸苦明其事广。虽事广时长而空无二利。今时促苦少能成忍。度自利利他安不忍哉。故练磨颂云。汝已恶道经多劫。无益受苦尚能超。今行少善得菩提大利不应生退屈。由斯重自劝勉诫励。令净而无乱喜不忧戚。调其嗔蔽摄护根门。是自住忍法。令物同忍。第三复更已下谛察法忍。亦仍前起故云复更。斯则一忍之中。便具三忍。表非全异故。一境具明。文分三别。一自成法忍。文有五句。初句总标。无我已下释成空义。以苦空无常无我四行释之。倒为其次。又约大乘故苦乐等双遣。一人我法我两亡。二常与无常非实相待有故。三空有俱寂故云无二四苦乐。皆遣云无所有。二诸法空下令他成忍。众生迷空故应为。说皆清净忍也。三是故下结行应修。然庄严论中。由三思五想则能忍受。一思他毁辱我是我自业。二思彼我俱是行苦。三思声闻自利尚不以苦加人。此三文在安受忍中。思昔诸苦自他调摄故。言五想者。一本亲想。众生无始无非亲属故。二修法想。打骂不可得故。三修无常想。四修苦想。五修摄取想。即此文摄对前可思。第二为慈念下明修忍意。文有十句义兼通别。通则三忍皆为此十在义可知。别则为初五。故修耐冤害。慈念为总。次但欲饶益于他。不惧他不饶益。本欲安人岂当加报。愍彼沦倒宁怀恨心。以忍调行摄诸恚怒。次一安受苦忍。随逐众生无疲苦故。次二句。为觉自他修谛察法。后二通于前三。上一为言下流至此。斯即九中二世乐也。第四无屈挠行。挠者曲也弱也。即牢强精进也。释相中二。先总显其相。后随难别释。前中文三。初正显精进。二性无下明离过失。三但为下辨进所为。此之三段。初即总举次是释。精谓无杂故。三是释进趣所为故。今初正显中。初句标行所属。所谓已下显胜列名。精进多名望业用故。初第一者亦是首义。此义有三。一大故。第一谓为大菩提故。二胜故。第一光明功德故。三殊胜故。第一谓超出故。第二大亦三义。一最胜故。大胜中极故。如世大王。二最妙故。大事理融通故。如世大德。三上故。大行体高上如世尊长第三胜者亦有三义。一无上故。胜不可加故。二无等故。胜不可匹故。三普遍故。胜体周法界无可胜故。二离过中即难行精进。性无间杂最为难故。先离自恼之过。谓本随烦恼任运不起。故曰性无。圆融教中地前得尔。后终不为下明离恼他。三辨精进所为中。有二十句具含三种精进。但为是被甲四弘愿故。而行即是方便加行所为之法。是所摄善。文分为四。初三断惑。次七度生。次四知法。后六求佛。即四弘也。今初。初断现行。次断种子。后断余习。二度众生中为成十力智故。烦恼是漏意令其尽。境界即遍趣行。心行义兼于业生死义。兼宿住处非处力。总故不明。三有四句。知法中初总余别。别中一事法界。若自入法则以净信为根本。若约利他则以慈悲为根本等。二即理法界。云平等性。三事理无碍法界。三世之事。即平等理性也。事随理融义含事事无碍。四有六句。求佛中初二即智。初句教智光明。后句证智。次二知境先真后俗。后二皆权智。前句知机识药。后句四辩宣陈分别演说。即是乐说。说于法义句即是辞上之四弘。初二知苦断集。后二修道证灭。即无作四谛之境也。第二佛子菩萨下。随难别释。于中二。先明被甲精进。后明利乐精进。今初。全同瑜伽之文。但论以被甲为初。约先心自誓故。本业三进之中初名大誓。今居摄善之后。就假设遇缘耳。文有两番问答。初番可知。后设复有下第二番中。更难于前。得大善利者。我本发心愿代物苦。但虑不容相代。今闻苦身能遂顺本悲心。不虑时长。但增喜庆长劫不懈。况尽寿耶。一念不悔即忘身无间。自庆得利即平等通达。有深功德为难行也。第二菩萨以此下。利乐精进。即用前加行摄善。以利众生。令彼涅槃真安乐也。第五离痴乱行。释相中二。先总显无痴乱。后别明无痴乱。今初。句虽有六义乃有十。初总余别。总云成就正念者。然通三义皆名正念。一就奢摩他品名为正念。正念即定。以彼定心离妄念之乱。故名为正。此从业用立名。亦邻近立称故。八正道中正念定摄。起信论云。心若驰散即当摄来令住正念。二就毗钵舍那品。亦名正念。谓不偏鉴达明了于缘。故下经云。正念诸法未曾忘失。三双运道名为正念。次下经云。以正念故善解世间等。谓于缘明了是无痴义。不异所缘名无乱义。即双运也。又下经。云禅定持心常一缘智慧了境同三昧。虽有毗钵舍那及双运道。皆就心一境。辨名禅自性。别中初句复是无乱之总。谓不随境转故无散乱。三障不能坏名为坚固。四缘不能牵故云不动。五超劣显胜故云最上。六异世无染故云清净。上五释无乱也。下四义释无痴。谓七称法界故云广。八趣一切智故云大。九引发难量故云无量。十不舍大悲名无迷惑。上九别句摄为三禅。前六现法乐住。次二引生功德。后一饶益有情。第二以是下。别显无痴乱。如次释前十义。即为十段。亦初一为总释前正念。于中分二。初结前生后。后善解已下显正念之能。文曲分二。先双标后双释。今初也。正念有观故能善解。正念有止所以能持。世言无益但须善解。出世有益偏语忆持。出世不解应不持义。世言不持应无记忆。故文虽影略义必两兼。解事解理故名善解。二所谓下双释分二。先通就诸境明无痴乱。后此菩萨下。别约所持明无痴乱。今初也。据无痴乱文但有九。开初为二句亦有十。谓法义别故。初句即法无碍合蕴成二。谓色与心。非色谓心即余四蕴。二能持建立下义无碍也。义有二种。自性亦二。一事二理。事即质碍为色性等。理即无性为色等性。皆无名相中。施设建立持言及义。即文义二持。今正觉理事离妄分别。名无痴乱。此二释上能持。下八释上善解。义必兼具故痴乱双举。三于五蕴生灭得无痴乱。十地品云。死有二种业。一能坏诸行。二不觉知故相续不绝。今此菩萨。于二事理静无遗照。故无痴乱。四偏语胎生明无痴乱。瑜伽第二说四种入胎。一正知入而不知住出。所谓轮王。二正知入住不正知出。所谓独觉。三俱能正知。所谓菩萨。四俱不正知。谓余有情。前之二人尚有痴乱也。凡夫痴乱相者。谓下者见所生处。在于厕秽中者。见在舍宅。上者见处华林。若男于母生爱。于父生嗔。谓竞母故。女则反上。大集二十七。涅槃十八二十九。俱舍第九。皆具说之。次三及十文并可知。八九各有通别。别谓四魔十魔及业。如离世间品。及如大品魔事品起信论说。若依智论。除诸法实相皆菩萨魔事。起心动念悉是魔业。今以智觉察不随其转。如人觉贼及偷狗故。知魔界如与佛界如。如无二故。既觉其事即不造其业。第二此菩萨下。别约所持法门明无痴乱。文有二别。先正明后征释。前中三。初结前标。后次所谓下正显所持。三菩萨下结无痴乱。二正显中有十五法。一所证理体。大分深义。所谓空故。即事真故。二即体业用之法。三具德相故。四一具一切故云种种。上四即所诠理法。五即能诠教法义。见初卷。六行法以因严果故。七果法。上七通明四法。下八唯约地位。亦果行收。谓八即初地大愿。已证理故名正希望。决定解断二障。故云清净。九即根本智。十即后得。此二通至七地。十一甚广大法。即八地法证深法忍。如法界故。十二九地是法师位。了物机故。十三十地。知世间集共不共等故。苦无常等通色心故。名之为共。色心类殊名为不共。又器世间名共。共业感故。众生世间名不共。自业成故。此二唯约所知。又随他意行名共。随自意行名不共。又静虑无色四等五通。虽共凡小菩萨无漏大悲故名不共。十四等觉智。十五如来智。上竖明诸位。若约横配者。初一唯因后一唯果。中间六智通于因果。而别义相显。三结无痴乱者。不忘不痴不失无乱。心常忆下通结相续。第二何以故下征释。释中。以因深故不乱众生。得无乱果。不坏正法增广大智。得无痴果。不断善根得相续果。因果影响孱然无差。第二复次下别释上九。摄为三禅。初六释前现法乐住。即为六段。今初释前心无散乱文二。初标。二所谓下释。释中又二。前释种种音声。略列七种。言沮坏六根者。非唯引夺耳根。亦令余根不能缘境。故名沮坏根。以见等而为义故。又沮坏者。如治禅病经云。因于外声动六情根。心脉颠倒。五种恶风从心脉入风动心故。或歌或舞作种种变。此即破坏之义。既坏意身余皆随坏。然色可冥目触味合知。香少诠显。为禅定刺唯在于声。故偏语之。明无痴乱。非余四尘不能乱也。故上忍中遇身加害。心无散乱。二此菩萨下释不能惑乱。文亦分二。先总明长时不乱。后所谓下。别显不乱之相。句有十一。初总余别。别为五对。一境审心定。二教达行成。三忆因念缘。四观真起用。五外净他惑自决义门。虽遇恶声此皆无损。上皆一切种禅。谓通名义止观及二利故。第三不作下释前坚固。谓四障不坏。是知正念坚固。亦是出前不乱之因。言法障者。于法不了如彼牛羊。此即所知障也。三障为言摄在烦恼。体即无明故。斯亦清净静虑也。第四佛子如上下。释前不动。谓诸恶缘不能牵故。悉能坏乱众生身心。彰声之过不能坏此菩萨心。对显难思。第五菩萨入下。释前最上。谓超劣显胜故。此下三段亦即出前无痴乱缘。正示现法乐住之相。言超胜者。初标人拣禅。云菩萨入。异凡小故。住于已下举法以拣圣法。即是无漏拣于凡夫。思惟观察拣于二乘。二乘入禅不能缘境故。身子不觉刑害之手。迦叶不闻涅槃之音。善知已下正显胜相。了性相故。相则念念不住。取不可得。性则三相性空固无所得。不得性相违顺何依。第六如是闻已下。释前清净。即清净禅。顺违中境不生三毒。不染善取有定慧故。了相无相故名善取。有斯正念。大地为鼓妙高为椎。岂能乱哉。第七知一切下释广。谓称法界如虚空故。亦近释前文有六句。初总余别。别中无得相空无作人空。无际性空。此三相尽故法界理现。与法界等事如理。故无有差别。理即事故。第八菩萨如是下释前大义。此下二段。释引生功德。今云大者。趣一切智不退转故。即难行禅也。第九善入下。释前无量。谓能引发难量德故。文分为三。初引自利德。文有六句。初标一切门禅。次四别显后一类结多门。则何定不摄。复云门者三昧无量。数如虚空。今一中摄多故名为门。如牵衣一角。如蜂王来。次增长下引利他德。后是时下结不为乱。非唯不乱本定更增。如猪揩金山风炽于火。第十作如是下释无迷惑。谓耽着禅味不起大悲。是为迷惑。今悲以导禅。故无迷也。此即饶益有情禅也。住清净念即现世乐。得智断果即后世乐。是谓与二世乐也。第六善现行。体即般若。瑜伽一切般若。亦有三种。一能于所知真实随觉通达慧。二能于如所说五明处及三聚中。决定善巧慧。三能作一切有情义利慧。摄论以加行根本后得为三。皆六度明义。唯识以生法俱空。本业以照于三谛。皆十度明义。经有十度应依本业今为顺文。且依瑜伽则权实无碍。皆名善现。虽彼依六度。今圆行菩萨则十度齐修。据行布分兼正不同。亦不相滥。就释相中。古人亦依本业三慧分三。初明中道。次念生无性等以为照无。普入已下明其照有。此得次第三谛。失于圆融。又照无经中佛法世法二互不异。亦不杂乱。岂独是无。今约圆融依于瑜伽兼正以辨。各具三谛故。彼论释初慧云。于一切法悟平等性。入大总相究达一切所知边际。远离增益损减二边。顺入中道故。文分二别。先明行相后显成益。前中亦二。先略后广。前中又二。先总标。后能知下解释。今初也。三业清净是能示体。示于三业正是现义。住无得现。现即无得寂用无碍。斯即中道可称善现。若异后有无。而说中者相待中也。二释中能知三业。皆无所有是住无得义。不妄取有离二边缚。是清净义。凡所示现无性无依。释示无得义。以境无定性心无所依。皆不可得也。三业皆示故致凡言。二住如实下广辨行相中三。初如实随觉慧。二佛子此菩萨作如是下。于五明等善巧慧。三菩萨尔时下。能作有情义利慧。今初如实觉。于三业而现三业。于中先别明后总结。前中三业即为三段。今初意业是二本故。首而明之。如实心者用所依也。住者心冥体也。知无量心等者不碍用也。即所示意业。多心多法皆有谛也。境既无相心何所得。即无谛也。有无不二故曰甚深。即中道义也。不可以次第三观而观。故名难入。唯圆机方能入故。何者。若偏观三谛是常是断。是相待故。若总观者。一则坏于三谛。异则迷于一实。故即一而三。即三而一。非三非一。双照三一。在境则三谛圆融。在心则三观俱运。住之与知即是观也。古德以凡所下至于难入。明唯识观非无所以。然且唯识之义不彰。又有释云。心非境外故无得。境非心外故无相。即心是境故甚深。即境是心故难入。亦是一理。二住于正位下释示身业。正位等三即示所依。方便已下依体起用。由非惑业之生故。生灭即无生灭。此中正位即真如异名。非约见道以智契会。故称为住无住。住者即住真如。三住涅槃下释示语业。前之三句示之所依。言语道断。显示而无相即言亡言。是断言道故。晋经云。非有说有言语道断。然上之所住总有七种。体一名异异从义别。一如实心者。即自性清净心。是为总相。次正位等三。即心之体性。正位者法所住故。真如语其自体是实是常法性。约为诸法之本。迷此真如有诸法故。成诸法已不失自性。故名法性。亦即因相。涅槃等三即是果相。住涅槃界即是真如体圆寂故。出二碍故。故智论云。有菩萨发心即观涅槃行道。恐此涅槃滥唯在果。故云住寂静性。谓约真如体无妄动。即是涅槃。如此之性体为有无。故云无性。无性之性即是实性。非谓断无故举多名。方显所住之深奥。依此示现方明所现之为善。二入离下总结三业中。初句结心故无缚着。次句结身即所住真如等。三结前语。即超诸世间等。末句总结三业。皆寂用无碍故名善巧。善现之名从斯而立。第二佛子下辨五明处。三聚中决定善巧慧故。于文中解世间法。于中分三。初以理会事。二菩萨如是下。事理无碍。三永不下顺理起悲。今初。文有六句。一众生缘生故说无性。二法依真起故会归无为。三国是心之相分故。四时依法以假言故。五名无得物之功故。若名在法中见义。应知名故。六物无当名之实故。若法在名中闻名则应识义。召火应当烧口故。二菩萨如是下。明事理无碍。文有七句。初一总显甚深。余句别显深相。然世法与佛法实无二体。假约事理以分其二。故以五句显非一异。一世相即空故云寂静。二佛法平等故无增益。三以理无不事故。佛法不异世法。事无不理。故世法不异佛法。四此全理之事与全事之理。而事理不杂。五各全收尽互无所遗。故云亦无差别。末句了前诸法。同法界体。故得镕融。普入三世横竖该摄。若约漏无漏说为世法佛法。各具事理释者。一生死即涅槃故。云世间寂静。二无有一法非佛法故。更何所增。三二法染净虽殊。同一真性故不相异。四不坏相故。无有杂乱。五皆是即理之事。而各互收无遗。即无差也。六同一法界总显所因。三永不下顺理起悲。谓无缘之悲以导前亡机之智。入假化物。初句为总。谓虽深入智慧不忘本心。非如八地心欲放舍。下三句别。一不舍愿炷。二增大悲油。三兼前智光故。堪为依处。第三菩萨尔时下。作一切有情义利慧。于中二。先建摄生志。二先人后己。今初文有五句。成熟是总。或因成果熟故。或始末劝奖故。余句是别。一折伏。二摄化。三令悟本性成大菩提。四断惑清净得涅槃果。二复作下先人后己。文分为四。一假设自度。二而诸众生下。观物轮回具业惑苦。三菩萨如是下。结所不应有二过故。一违本誓心。二堕悭贪失。此为不可。四我当下决志先拔。第二是菩萨下显行成益。于中三业不空。是为遍益。终至菩提是究竟益(此下入二十经)

大方广佛华严经疏卷第二十二大方广佛华严经疏卷第二十三(此下入二十经)

        唐清凉山大华严寺沙门澄观撰

第七无著行体即方便。依二方便由回向故。不住生死。由拔济故不住涅槃。俱无住故名为无著。本业后四亦各有三方便。三者一进趣向果。二巧会有无。三一切法不舍不受。初即回向。二由巧会故方能拔济。不舍不受相同般若。唯识唯明后得。故不立之。本业约兼正不同不妨此一。三皆善巧故俱无住着。则不二而二之悲智。即二不二之一心。是无著也。有是幻有无是真空。幻有是不有。有故即真空。真空是不空。空故即幻有。此二无碍故名巧会。如是相融故无所著。有能起用空可观察。故皆不舍。若受有同凡夫。受无同趣证。故俱不受。二释相中大分为二。前明自分无著。后明胜进无著。于自分中已含前说。二三方便在文分三。初唯明自行无著。二何以下征释所由。后菩萨如是下。类显万行。前中又二。先明净境无著。后见不净下。染境不嫌。前中三。一明严刹无著。二往诣下于三宝无著。于中初敬事供佛。次如是下显供所为。后于念念下。别示无著之相。义兼三宝及自进修。皆无所著。言念念者显速而且多。三此菩萨下长时无著。二明染境不嫌。唯一句者染易舍故。第二征释中征意云。欣净恶秽人之常情。菩萨如何不嫌不着。释意云。不依佛慧净秽是生顺法而观二相安在。故云如诸佛法而观察故。佛法即法界佛慧也。第三类显万行。若自若他皆无所著。于中初句结前生后。教化已下广列所行。言佛所住者即圣天梵等。余并可知。第二菩萨摩诃萨下。胜进无著。文分为三。初明自行。二得授记已下利他。三菩萨如是观身下。结行成满。今初分二先牒前自分。后于佛法下正显胜进。有十一句。初总余别。总谓了达教理行果之法故。别中一了果法。谓佛菩提。二了理法。谓证法毗尼。毗尼梵音具云毗奈耶。此称为灭。若律藏受名义兼调伏。今云法灭通四种法皆有灭义。谓教诠灭故。行灭惑故。果证灭故。理本寂灭故。今文上下既有余三故。此灭者即理灭也。又与证义相应。圆融教中此容证故。三住佛正教。即了教法如所教住故。四修菩萨行下。皆行法也。三句随相行。行即万行。心谓四等。解脱即诸解脱门。次二句无相行住处。即前教理及果。所行即前万行等。皆无染着也。由此故能净菩萨道。堪受记别。第二大悲利他中二。先增长大悲。后要心拔济。前中又二。先观其所悲后增悲无著。前中又二。先观迷四谛故入于险道。后观迷胜义故入于险道。今初也。初二句标起念时。凡夫已下辨所念境。有十三句。初总余别。总谓迷于四谛。皆曰愚痴。别中前五彰迷后七显过。前中一不知苦谛。二不见集过三不信性本寂灭。四五不能修道。一解二行。后七显过。一不见集过故。顽嚚贪着即痴爱也。二由贪爱故受生死苦。次不求见下四句。释不修道。初三缺道缘。四由不信故迷正道失本解。以邪为正名为错误。后一由前不修故入险失灭。上一向是凡。二不敬下明迷胜义故入于险道。通于凡小。初二句离胜缘。次二句缺胜因。三有生空皆为住处。怖法空者谓断灭故。故大般若诸会之末。善现皆愍众生怖畏法空。而兴问言。云何令诸众生悟诸法空。佛言。非先有法后说为无。既非先有后亦非无。自性常空。勿生惊怖。远离已下覆疏上义。由着处怖空故。远正住邪舍夷入险。由离胜缘故。背佛随魔执有不舍。魔乐生死佛住空故。二菩萨如是下增长悲心。结成无著。第二菩萨尔时下要心拔济。以大悲心长劫随逐。文分二别。先起行。后乃至下显无著。前中亦二。先明心无疲厌。以无著故即大悲坚固。不以难化而厌舍之。后又以下明其心广大。谓一毛量处化多众生。法界皆尔。是为广大。二显无著中三。初举少况多。次于一一下广显无著。后何以下征释所以。所以不著者。后释有二意。一称深无相而兴念故。二广遍虚空起加行故。前中无相难明寄以喻显。然此诸喻通喻诸法。如下本品。今取义便各举其一。则明前所见皆无相也。初句为总观事法界。从缘如幻无实体故。是以不着。余句为别。一佛随机现。如影随质故。又现心水故。二菩萨行想念生故。未大觉故。三缘成之声故。随感有说故。余句经文自释。一切法如实际者总结也。又前明法界如幻。即体从缘。后结一切法如实际。即事而寂。世人皆谓实际不变。而谓诸法无常。以其所知喻所不知。故置如言。理实圆融世间之相。即是常住。然古德以后七喻展转释疑。一疑云。世间幻火不成烧用。佛现益物岂同幻耶。释云如影。亦有应质荫覆等义。岂是实耶。然诸法喻各有三义。一缘成义。二无实义。三有用义。意取无实故不着也。二疑云。若佛如影菩萨何以起行。往求因既不虚果宁非实。释云如梦。梦亦三义。无体现实与觉为缘。谓有梦走而惊觉故。菩萨起行亦尔。证理故空无明未尽故似实。能与佛果为缘勤勇不已。豁然觉悟。如梦渡河。三疑云。若菩萨行如梦者。何以经说此是菩萨行。此是二乘行。释云如响。缘成无本称声。大小圣教亦尔。机感无本随机异闻。四疑云。果行可然世间未悟。此应是实。释云如化。心业神力所持无实有用。五疑云。若皆如化何有差别之身。释云如幻。六疑云身若如幻何有报类不同。释云如心。此二三义如前影说。七总结可知。上来古德之释。既二经小异略加添改。然其所解似过穿凿。亦是一涂。二又作下遍周虚空起加行故。所以不着。初明处广。念念明达彰其解广。正念现前是不着因。第三结行成满中分三。初结自行成。二为化下结利他行成

三何以下征释双结二行成就。利他中三。初总显教化无疲。次无疲厌故下。别示无厌之相。其中施设者。随方仪式异故。和合者善恶缘会故余可知。后不令下结成无著。三征释双结可知。第八难得行体即是愿。就释相中文分二别。前明自分行。后明胜进行。然此二行。各摄上求下化之愿。略无神通。今初分四。初明自行次辨利他。第三双结二行动寂无碍。第四双非二行拂迹入玄。初中分三。一明修成善根。二显善根行相。三行成利益。今初也。斯即起行所依。善谓顺理益物。根谓增上生长。获之在己故名成就。文有十句。初总余别。总具后九受难得名。二此菩萨下显善根行相。亦有十句。如次对前。谓由得最胜解。故受难得名等。亦可。有难得根能有胜解。又亦以后一行成前十善。随前一善具后十行。而别配分明。三是菩萨下行成利益。文中先结前后。于念念下显益。于中初自益。能转生死成大智益。不舍大愿成大悲益。若有已下显能益他。由前自行成此能益。夫正利他。第二此菩萨下辨利他行。文分为三。谓法喻合。今初。谓有大智故了众生非有。则不住生死。有大悲故不舍众生界。则不住涅槃。大悲般若互相辅翼。成无住道。二喻中。初句喻能化人。次三句喻悲智不住之行相。后而能下三句。喻不住之功能。初二句正喻功能。以往返不息一句。结能度所以。三法合中二。先正合后征释。前中具合三段。生死即此岸。涅槃合彼岸。合上中流。亦言生死者。以发心之后成佛之前。十地三贤尚居二死。是以中流即是生死。故云生死中流。非生死涅槃之中间。名生死中也。文旨显然。晋译失旨不应广引。有以烦恼为中流。约其漂溺从因说也。有以圣贤为中流约受生死之人也。有以中道为中流约观行说并不应住。安隐已下涅槃之德。常故安隐。乐故无畏。我故无忧净则无恼。亦不已下广明以智导悲。合前往返无休息义。谓由不住着故。所以往返运济无休。及显法中非有不舍之义。谓非唯悲故不舍。亦由了其非有无可舍故。则终日度而无度也。初句总明。不舍下别有五对十句。初一多对。已化未化俱有舍着二义思之。二增减对。化之成道生界不减。不从化者生界不增。此约多人相望。三约一人。果起不生惑尽非灭。四谓空为尽谓有为长。五一对总结。四对不亡并名为二。今无分别契本不二。第二征释中文有两番。前番正征不着。后番重征前义。今初也。先征意云。现化众生有增有减。而言不着。其故何耶。释意云。以菩萨深观生界。同于法界无增等故。所以不著文中。初二句总。上句是不异义故云如也。下句是相即义故云无二。后无二法中下。别彰无二之相。即属对上文。无取依着释不分别。余文相显。此文昭著。而末学之徒。但谓一分众生不成佛。故名不减生界。深可悲哉。第二番重征意云。何以生界即同法界。释云。一切诸法皆同法界。岂独众生而不同也。第三菩萨如是下。双结二行动寂无碍。亦名无尽心行。有法喻合。法中十句。初二牒前起后。既方便深入故性相无碍。住于下余有八对。正显行相。一约起行之身。二了法药。三识根缘。四游佛刹。五达佛法。六深契离言不舍言说。七无求离欲而万行爰修。前七明即寂之用。八常勤下一对。明即用之寂。亦通显所由由勤修故。涉权入法界故常寂。二喻中。木喻法界火喻所成身智。火事喻悲化。无边本火不灭喻身智常湛。三合可知。第四非究竟下双非二行拂迹入玄者。然初自行。云能转生死而不舍大愿。已有权实双行。而谓多明照体大智。次利他之中。既云无住运济。则悲智相导。而多似起用大悲。次复以导悲之智遣彼着心。复似悲智二心行有前后故。第三段辨动寂双行。则理无不尽。而犹虑物。谓二事不融故。此明形夺两亡权实无寄。岂唯十行菩萨修行善巧。弥显功德林悲济之深。文有五对十句。然其所非之法。即前权实二行。且如究竟即实。不究竟即权。今乃双非者。实即权故非究竟。权即实故非不究竟。又但言非究竟。非谓有不究竟。故亦非之。是则借权以遣实。实去而权亡。借实以破权。权亡实不立。言穷虑绝何实何权。体本寂寥孰非孰是。唯萧然无寄理自玄会。故辨双非非有双非可立。然双非是遮双是为照。即遮而照故双非即是双行。即照而遮双行即为双遣。总前诸段理极于斯。下诸句中皆仿于此。二对所化。能所取寂故非是取。了知心行故非不取。三约化处。不着世界故非是依。依刹现身故非无依。亦约所证智。无分别而善入故四约化法。深达义理故非世法。随世语言故非佛法。五证离欲际故非凡夫。不断菩萨行故非得果。第二菩萨成就下。明胜进行。文分为二。初明慧行。后菩萨如是下辨悲行。今初分二。先牒前自分行。后不说已下正辨胜进行相。皆即事入玄。分四。初总明离相无说。二征释以显双非。释意云。所以不说者。一无法可说故。二菩萨于如是下。明无心说。谓不起念故。三何以故下。转释无念。所以无念者称法界故。故不说声闻法等。四假征以显双运。征意云。既无所著。何以复修二利之行。释意云。性相双非故能双运。文有法喻合。法中诸法无二故无说无著。无不二故不妨起行。二喻可知。三合中皆显性不碍相。于中二。先正明。后普与下辨功成德。立胜进之相故。晋经此初有此菩萨言。第二辨悲行中分三。一牒智显悲。悲假智深所以先牒。二于三恶下正显悲相。三复作是下偏语化恶。显胜进相文中三。初明恶是所悲。次明善非化境。后征释所由。今初所悲中。先明有违教之惑。后贪爱下明总具尘劳。惑病既深方假医救。前中不知恩报者。必无敬养更相酬对则难以诃责。邪见执着则不受正教。迷惑颠倒所领不真。愚痴无智为说不知。无有信心。绝于希向。随逐恶友必远善人。起诸恶慧无由正解。故难化也。二设有下善非化境可知。三征释中。初征次释后转征释。初征意云。菩萨化生理宜平等。偏恶弃善其故何耶。次释意云。菩萨于物无主定于亲疏。就于惑重偏是化境。如母矜病子岂不等耶。又若求名利应化知恩。本为净他理应随恶。若弃恶从善魔摄持故。三转征释。征云。菩萨众生本不相预。何为长劫悲救无求。释意云。诸佛菩萨法尔同遵。不尔不名为明导故。第九善法行体即力度。就文分三。初征名。二释相。三结叹。今初唯识有二。一思择力。二修习力。本业有三。一报通力。二修定通力。三变化通力。唯识约修本业约用互举一边。由前二力为机说法。则成语意二业之善法。有本业三力。则成身意二业之善法。以修定通。即意业故。依梁摄论。由思择力。能伏一切正行等所对治障。令不起故。由修习力。能令一切善行坚固决定。既言一切善行。此则二力通三业善。此位大同九地。是法师位善说法故。释相中二。前自分后胜进。然此二段各具二力。至文当知。亦有三力。谓善知根缘一音普应。成就十身义该三通。初自分中。先总明后别显。前中作清凉法池标也。言含法喻。谓如无热恼池清净无浊。下二句释上句。如池含于德水故。云摄持正法。下句以四辨才出愿智等。饶益众生相续无尽。究竟入于一切智海。名不断佛种。如彼大池流出四河相续入海。二得清净下。别显文分为二。初广摄持正法。二此菩萨大悲下。广不断佛种。今初也。具十总持是摄持义。十持为体十辩为用。初句为总。寂障鉴法名净光明。余九为别。初四即四辩才。四持即池之德水。四辩即池之四口。五即外力加辩。智水灌心故称根令喜。此即得辩之缘。六即内力自证之辩。谓道契内心光明外彻。此乃得辩之因也。七同类音辩此约顺机。八训释辩。此约穷法。前四辩中但明通相文句。此明曲尽其源。义身即当名身。名所诠故。体是名境义即境义。梵云得种种名身故。九总显深广持辩无边。旋有入空旋空入有等故无有边。皆言无尽者称法界故。第二广前不断佛种中。文分三别。初总明三业利生。二假使下假设深胜。三以得一切下总释所以。前二含于四河。今初即大悲河。大悲坚固标其体也。悲绍佛种故首明之。普摄众生正明不断。于三千下示其摄相。二假设深胜于中有三。即为三河。一大会断疑。明问答成就。处多大众顿领顿酬。由具诸度故。即波罗蜜河。二复次下微细断疑。前直明大会异问能答。今乃云于一毛端处有不可说。如前大会。多劫殊问一念能答。不怖大众不怯文义。决断拣择显转超胜。是三昧力。即三昧河故。下经云。菩萨住此三昧。能于自身一一毛孔中。见不可说不可说佛刹。微尘数诸佛如来。亦见彼佛所有国土道场众会听法。乃至云。其诸众生亦无迫隘。何以故。入不思议三昧境界故。彼约听法此约答问。以之为异。余义大同。此约圆教普贤位中。故于地前有斯自在。非三乘中得斯作用。三而作是念下周遍断疑。上举毛端多众犹有量故。今明一切众各具多言。悉能答故。即愿智河。愿智相导悲救无休。故云作念。文中先显多众。后假使下复显多言。第三总释所以者。所以得此四河广利者。略举四因。此之四因。或以一因成前四河。或以四因成其一河。一他佛外加故。二自藏离碍故。三所照法圆故。四能照智具故。或各配属一同体悲加故。二见心性故。三诸度圆故。四二智满故。第二佛子此菩萨下明胜进行。亦即是前四河之相。文分为二。初牒自分行成。二能自下正显胜进。文分为四。一辩四河清净之义。二如于此下辩四河入海无能障义。于多界中化无障故。三佛子下。辩此四河旋绕池义。四菩萨成就下。辨累劫入海无疲厌义。三旋绕中。谓成就随顺身语意业。智为先导。身语意业四方流注入智海故。随顺即是旋绕之义。文中二。先总标。二所谓下列释。皆上句标名下句释相。勒此十身以为五对。一证灭示生对。二不生不灭对。三非实非虚对。四不迁不坏对。五一相无相对。束此五对不出体用。一一对中体用对辨。第一对体用自体。第二对体用之相。第三对体用之力。第四对体用之性。第五对体用之德。今初。理无不证名入无边法界。世无不超名为非趣。下释中。但释非趣者。谓若入法界必灭世间。若灭世间即入法界。标释相成。此即体之自体也。二用无不遍故入无边法界。随类受身。故云诸趣。此言入者应往之入。不同上来证入之入。释文可知。此即用之自体也。第二对。初不生身。即前应用之身生而不生。言住无生平等法者有二义。一依体起用。用不离体故。二体之与用平等无生故。此即用之相也。后不灭身。即前体灭离言说故。一因灭显理理非灭故。二寂灭之理离灭相故。此即体之相也。故上体灭现生之身。即以不生不灭为相。第三对。体有何力得如实理。离世俗之实也。用有何力随应而现。不同尘也。第四对。用以何为性。随流应而不迁。体以何为性。即法界而无坏。第五对。体有何德。过去无始。未来无终。现在非有故。三世言断用有何德。体即无相能照法相故。此十身不离体用。用有聚义体具体依。皆得名身。体外无用用即是体。用外无体体即是用。体即法性用即智应。二既不二理智圆融。唯一无碍法界之身。随相显十以表无尽。一乘圆融地前能尔。更有余义。如十地离世间品明。此略举成就随顺之身言。身兼语意也。四显无疲厌。谓四河入海累劫无疲。菩萨亦尔。以普贤行愿尽未来劫。修菩萨行入如来海。不生疲厌。是以广显与生为归为救等。文中先牒前所成之身。为益他之本。为一切下正显成益。句别有十。在文可见。十地又明。今略其要。俗须委示。故名为灯。真但高明故目为炬。甚深则能所不二。如光合空为照为明。但约入地示德为异。第三佛子已下结叹分二。先结名。后菩萨安住下叹胜。尽法源故。以清凉法池即是行体故。标结皆举。显中是其相。第十真实行文三。同前初征名者。如本分释。体即智度今更略释。若约二智。受用法乐成熟有情。并如行能说如说能行。即是真实。本业有三。一无相智即受用法乐。二一切种智。三变化智。皆成熟有情。下文云。入一切三昧真实相。即受用法乐智。知众生种种想等。即成熟有情。知十力智是一切种。不着一切世间解。众生无际。即无相智。我为善变化及示现如来自在神通。即变化智。就释相中文分三别。第一总显名体。二别显行相。三结住行益。今初。初句总标。后如说下解释。谓言行相符故名诚谛。诚实审谛即真实义。此有二义。一约先誓自他。二利决志具修。今如昔说决能行之。亦如此。行以为他说故。下文云我若先成则违本愿等。二约现修自他二行如所演说。决定能行。非数他宝故。云如说能行。亦如所证宣示于人。不昧所知名如行能说。第二此菩萨学三世下。别显行相。文分二别。先标章后依章别释。今初。文有五句。一称实演法师子吼故。二深住实相契一性故。三二利善根等同佛故。四得如说行同本誓故。五学佛十力智已成故。第二此菩萨成就下。依章别释。从后倒释即分五段。第一释智慧成就。文中三。初显所成十力。言时非时者。垢净之时不同。化不化时别故。次而不舍下得果不舍因。后何以下征释所以。十力化生之智故须得之。令物清净故须不舍因行。第二此菩萨复生下。释得三世诸佛无二语。文中三。初反举违誓自诫不应。次是故下顺释。要当先人后己。后何以下征释所由。征有二意。一云何以违誓。是所不应。二云何以要须先人后己。释此二征即分二别。初释前征云。由先许故不与则违先誓。不请强许今之不与岂是所应。后是故下释第二征。菩萨之道必先人后己。不尔岂得名最胜耶。文有六句。当句自释不俟繁文。第三此菩萨摩诃萨不舍下释同佛善根。本誓智慧皆究竟故。文中二。先标德成满。二于一切下别显同相。一意业智慧同。二念念下身业神通同。第四此菩萨现无量身下。释入佛种性。于中二。一约身明入。入世无依。又身中现刹皆得性融故。二此菩萨知众生下。智入种性。于中二。初入悲种性。知根善化故。二观诸菩萨下。入智种性穷实相故。故结句云住一性无二地。以此智性导前悲性。成无住道。是为如来无二之性。文中初会缘入实。次得义身下依实了相。后智慧最胜下性相无二。文有三句。初句约智则双照性相。次句约定动寂契真。后句释成并由住无二性。第五菩萨摩诃萨以诸下释学三世诸佛真实语。文中二。先牒前起后。众生着二不能悲智双游。菩萨即寂修悲故得不二。后得佛十力下。成果起用显实语相。能师子吼转法轮故。结云知实相源方为实语也。文中大同十地穷佛所得。圆融教中位位果满故。穷法实相。谓如是性相体力等。皆尽源故。余句可知。第三菩萨住此下。结行成益。第三结名并如文显。说分已竟。大文第六尔时已下。显瑞证成分。文分二别。一瑞证二人证前中先此会。后如此下结通。二复以下人证。亦先此界。十住一万此云十万。表位增故。前现瑞中。亦应云十方各有十万。文无者略。余义已见十住之末。后佛子我等下结通。第七重颂分中分二。初说偈仪意。先彰说仪。后欲令下说意。意有九句。初总余别。别中一净治因性。二不退愿性。三行性续愿。四以真性导行。五上摄果性。六开已修性即十行所习。七观所化性。八照当果性。二正说偈辞。总有一百一颂。大分为三。初之一颂总申归敬。次九十六颂正颂前文。三有四颂结叹深广。今初也。将申偈颂再展敬心。初四字申敬。十力下显佛三德。十力智德。次句断德。次句恩德。众生为境故。末句通喻三德。智广惑净悲深远故。第二正颂前文大分为二。初十一偈颂前本分。后八十五偈颂前说分。然十住颂文则举其次第。今没其次第。直云行斯道者。略有四意。一前则约位始终行布而说。今将融会前说令无始终。欲显一位之中具行诸行。一行之中具一切故。二前约别行今约普行。普别无碍二文互显。三前约同教今约别教。同别无碍为一圆教故。四前约不杂辩才。此约任放辩才说不待次。言辞不断故。又前多约因此多就果。或广略绮互体用更陈。总别递明互相影发。显菩萨行深广难思。下文虽依次第既没本名。一同离世间圆融之行也。今初亦可。总叹行深不颂前文。颂亦无失。今颂本分曲分为二。前四颂前学三世佛而修行故。后七颂前行体不可思议。今初分二。初三别明后一总说。各初三句辨德。后句结德。所行下诸文行斯道言。皆仿于此。后七颂行体中。然文旨包含略为二解。一颂行体。二颂加之所为。然所为正为十行。义旨不殊故得同颂。配文少异。分为二解。先配行礼。文分为四。初一颂总显不可思议。故云心无分别。彼无动故。二一颂颂前与法界等。等法界有三义。所有皆明了等事法界。次句等理法界。此二无二等无碍法界。由此等故能破惑成德。三有二偈颂等虚空界。等空五义。初偈显二。谓空无分别而显万像。菩萨亦尔。入实自悟则无分别。不碍分别于诸众生故。结云等空。由入法界故等虚空。二界相成故举入法界。后偈显三义。一等空广大。初二句显示。二等空清净。三等空不可坏。第三句显由等虚空。是胜寂静名曰牟尼。四有三偈。颂前菩萨行。初偈总举自分之行。后二即胜进之行。二以此文颂加所为。虽开合不同依次不乱。初偈颂前为增长佛智。前半所观后半能观。次偈颂深入法界。余如前释。三中初句颂了知众生界。次二句颂所入无碍。四中颂所行无障。往诸国土则身无障。说法清净则自行无障。异论不坏则外无障。第五偈颂得无量方便。以愿行等皆善修故。六中颂摄取一切智性。无边一切地即智地故。十地之智同佛智故。叹胜可知。七中初句颂觉悟一切法。次句知一切诸根。随宜摧伏。次句即持说一切法也。第二远离下颂前说分。十行即为十段。第一六偈颂欢喜行。文分四别。初一财施。财去悭过安隐他故。次二偈无畏施。前偈修因后偈得果。次二偈法施。后一颂总结因圆果满。言百福者。涅槃二十四云。五品心修十善。谓下中上上中上上。各十善成五十。始修终修故成百福。然十善之中。不杀不嗔是无畏施。不盗不贪是财施。离口四过。不淫不痴是法施。故具上三施成百福果。第二智地下颂饶益行。五偈分四。初偈律仪。谓有智能护心不动故。是菩萨律仪。次二摄善。三有一偈饶益有情。举处摄人。后偈总结三聚。第三智慧下无违逆行。四颂中三。初一谛察法忍。次二安受苦忍。一引他励己以策修。二引所成德以进道。后一颂耐怨害忍。遇害无恼但增救心。第四于诸下无屈挠行。五偈分三。初二颂前摄善精进。亦名加行。初半偈。即颂第一精进等十句。次句即颂前离过十句。后偈颂前所为。次一颂被甲精进。为物受苦心无厌等。后二偈颂利乐精进。第五善解下颂离痴乱行。二颂中三初一颂现法乐住。于中前半。颂能持色法言说等。后半通颂前无痴乱等七句。次半偈颂引生功德。禅了一切法无有边际。得一切法真实智慧。故云得究竟也。后半偈颂饶益有情中。我当令一切众生。乃至究竟无余涅槃。即无尽地也。第六功德下二颂。颂善现行。第七四偈颂无著行。对前思之。第八安住下八偈。颂难得行分五。初一偈即自行之愿。次四神通次一外化。次一求菩提。后一成熟有情。若属经文初四偈。颂前于佛法中得最胜解等十句。二无量下三偈。颂自行成益。第三一偈颂前利他不舍一众生着多众生等。第九修习下六颂。颂善法行。初一修习力。次一思择力。次二修定通。次一报得通。后一变化通。若属经文。初偈颂释名前半摄持正法。后半不断佛种亦大悲河。次偈即波罗蜜河。问答成就。次偈即三昧河。前举三昧之用。此约三昧之体。次一即愿智河。次一十身体用。后一即示现如来自在。第十了达下四十三偈。颂真实行。文分为六。第一三偈颂得十力。二善守下三偈。颂得三世诸佛无二语。初偈正明依法修行。即无二语。余二偈颂我为最胜等。三六偈颂同佛善根。四法界下十一偈。颂入佛种性。于中分二。初三偈颂身入。余颂意入。于中初四颂入悲种性。后智眼下四颂。颂入智种性。五成就下十八偈。颂学三世诸佛真实语。得佛十力等。如文思之。六一光下二颂。颂益物不空。第三大段四偈结叹深广。文显可知

大方广佛华严经疏卷第二十三大方广佛华严经疏卷第二十四

        唐清凉山大华严寺沙门澄观撰

    十无尽藏品第二十二(此下当第二十二经)

初来意者。总有五义。一为答前第二会初十藏问故。二前明正位今依位起行故。同梵行品。三前约位别行。今辨始终通行故。四前明成位行。今辨净治彼行故。同十地中信等十行。五前明自分究竟。今辨胜进趣后。同上明法。准问应在十回向后。今此辨者略有二义。一云藏有二义。约蕴摄义在十行后。约出生义在十地前。义通二处问答互显。一云。回向无别自体。但以能回前行为其自体。今十藏既为十行胜进。亦为回向胜进故。回向后无别胜进。此即前后互举显义方备。然明法品及第五回向。皆有十藏随三贤异故不相滥。又前是胜进所成。后是一位之果。今通为胜进故意旨不同。二释名者。藏是出生蕴积之义。谓一藏内体含法界故。摄德出用一一无尽。寄圆显十即带数释也。三宗趣者。十藏为宗。摄前生后得果为趣。四释文中大分四别。第一唱数显同。二征名列异。三依名广释。四总叹胜能。今初三世同说显胜令遵。二何等下征名列异。藏如前解。信等对藏皆持业释。心净名信制止名戒。崇重贤善为惭。轻拒暴恶为愧。餐教广转为闻。辍己惠人为施。决择诸法名慧。令心明记为念。任持所记为持。巧宣所持为辩。各有业用。然念慧及信惭愧等五。皆当体为性。余五行用立名。此约随相。若就融通。皆顺法界之行。良以法界性自清净。离过等故。随义说十。然约随相前九自利。后一利他。通皆具二。信为行本故首明之。依信离过。惭愧庄严戒行光洁。上三离过之行余皆进善。进善之首必藉多闻。如闻而行。唯福与慧念使增明。持令经久辩以利他故。前七即七圣财慧为正导。故终辨之。次二守护。后一积而能散。第三依名广释十藏。即为十段。信中有四。谓征名释相。结名辨益。辨益一种唯初七十。余之七段。文但有三。今初段中初征可知。释中分三。初明信相。次若菩萨下明信力。三此菩萨入佛下总结信成。今初也。十句为四。初三三空。信所执无相。谓情有理无名空。空亦无相。空无相故无所愿求。次三信依他无生。一缘起无作二不实故。无能所分别。三无体故无所依。次三信圆成无性。一广无边量。二胜故无上。三深不可越。后一总信三性无生。如初会辨则十皆无生。并通三性。如一无生观。但信依他无遍计人法自然之生性。则是无性圆成。余例此知。第二明信力中二。先正显业用。后征释所由。今初文有十句。遍从前十前十并成此十。若类例辨。初二于胜上法不怯。次四。广多法不怯。一所化众生。二即化法。三是化处。四化之所归。后四宽远法不怯。若克文取义。以后十句逆配前十。谓由信法无生故。于佛法不怯。佛法以无生为体故。佛难超故。众生无尽故。法界无边故。虚空无依故。涅槃无分别故。过去之因不作果故。未来之法无可愿故。现在之法即无相故。入劫无障碍。以即空故。此十皆深广难思。二征释中。先征意云何。以深广难思。菩萨闻而不怯。释意云。以于深广皆坚信故。文分为二。初总后别。总云一向信者无犹豫故。坚者异说不坏故。所信谓何即佛智慧。智慧何相无边无尽。然通二义。一广无边涯竖不可尽。二无二边之偏同真性之无尽。二十方下别释。初释前意。十方无量是无边义。已现当入是无尽义。言得菩提是自证义。出世入灭是应现义。法无边故佛智无边。一佛之智尚不可尽。况横遍十方竖该三际。菩萨于斯广远坚信不移。宁有怯耶。二彼诸下释第二意。闻深不怯。谓已得今得菩提而不增。当得未得而不减。已出今出而不生。已入今入而不灭。当出而不进当入而不退。现得出入而不近。在于已当而不远。照穷万法而无知。顿寂诸相而不舍。以寂照之体。如如超戏论故。但以世俗文字数故。说有三世。非菩提涅槃有去来今。菩萨既坚信于此。宁闻深而怯耶。此二段释文。具前十句难思之法。如文详之。第三总结信成于中二。初一句总牒信成。谓由明达佛智无边无尽故。称此成信。二得此信下显成信之益。亦是正显成相。有十一句。前七行体坚牢。初句为总。二内心不杂故不退。三外缘不沮故。四不染相故。五有正慧故。无慧之信长无明故。静法云。梵云阿慕罗匿陀。此云不从根生。谓无生之信无根生故。经本云常有根本者。译人不审阿字没在上。句翻无为有于理背也。此或应尔。今以理通二义无违。无根语慧之体。根本约慧之用。亦犹从无住本立一切法故。无本者即是根本。六顺同古圣故。七安住菩提心故。后四摄德无尽。一护已成性。二复长新解。三顺如生善。四不滞有无。三是名下结。四菩萨住此下辨益易知。第二戒藏文三。释相中二。初列十名后随牒释。初中十戒皆通三聚。取其相显。初但饶益有情。后一律仪中八通三。约遮过罪皆菩萨律仪。但为救护等即是饶益。摄善可知。为显此十皆通三聚故。释后一复显三聚。二牒释中十戒为十。皆先牒后释。初饶益者。菩萨本意故首明之。二不受中文有二意。一不受邪戒。谓鸡狗等。二三聚宿成动不踰矩。三中唯为菩提及众生故。非如难陀之类。四中涅槃云。何故持戒。为不悔故。何故不悔。为欢喜故。乃至为得大涅槃故。五中有四。非者违也。一不违制立。不同调达。二不违涅槃。不取相故。三不违律仪。具足持故。四不违利物。不恼他故。六有二意。一非为欲恼众生先须持戒。二非为欲成净戒逼恼众生。如杀马祀等。七中戒正见邪故名为杂。定有定无为断常杂。观缘性离非有非无。则名为持。又无烦恼之杂真出离矣。八中不现异相彰己有德。五邪之一。已见净行。又如十住论说。一者矫异。二者自亲。三者激动。四者抑扬。五者因利求利。大同前引智度论说。今文即矫异也。九中不轻毁者。无行经云。见破戒人。不说其过恶。应念彼人久久亦当得道。问涅槃云。见破戒人应当摈黜诃责举处。当知是人得福无量。岂不违于无行。此经答略有三义。一此经约自行涅槃据摄众。二此经约根未熟。护恐增恶故且摄受。涅槃约根熟者慈心拔济故。应折伏。三彼约慈心此约轻毁故。不同也。十中释内分二。初明律仪。十善众戒之本。故偏明之。广如二地。二菩萨持此下双明二聚。摄菩提善益众生故。第三惭藏。释相中二。先标章。二谓彼下别释。今初然惭愧相别诸说不同。涅槃云。惭者羞天愧者羞人。惭者自不作恶。愧者不教他作。惭者内自羞耻。愧者发露向人。瑜伽四十四亦云。内生羞耻为惭。外生羞耻为愧。大同涅槃后解。成唯识云。依自法力崇重贤善为惭。依世间力轻拒暴恶为愧。俱舍亦同。若无惭愧但翻上惭愧。谓不羞天则是无惭。余可例知。若说羞耻为惭愧者。是二通相。今经多同唯识。而以不相恭敬为二通相。二别释中分二。先释过去作恶即无惭行。二自惟下释而生于惭。前中亦二。初自念无惭。后一切下悲他亦尔。第二正显惭相中。初自念昔非耻佛知见。现修惭相。自惟即是内自羞耻。是故已下决志断证。文言去来现在行无惭者。言总意别。菩萨自惟昔过愍物。三世常行故。专心断除防己伏之。再起为众生说。则物我之兼亡。第四愧藏。释相中三。初自念无愧而修愧行。故云我今不应复行是事。即愧行也。二又作下。伤物无愧不觉苦集。故云无知无见。三于母人下。依顾世间而修愧行。誓益自他。于中初所愧境。有智慧下。顾他生愧。即外羞也。初因人后诸佛。是故已下决志断证。言不净之法者。从淫欲生。即种子不净。母人腹中即住处不净。成垢秽身即自相自性。究竟发白意含究竟不净。又垢秽形。是内污秽不净。处胎受生有苦触不净。从淫欲生下劣不净。若观待涅槃三界并为不净。其五取蕴体是违坏不净。上来烦恼亦是不净。言诳三世佛者。违本四弘誓断惑故。余文易了。第五闻藏。释相中二。初明所知之法。后菩萨摩诃萨下。显多闻之意。今初标称闻藏。释云知者闻为本故。实则多知耳。文亦分二。先标章后牒释。今初句。虽有十义束为七。初之四句但是缘生故。谓一缘生。二有漏五蕴。三无漏五蕴。四有为五无为。六有记七无记。二何等下牒释。即为七段。初缘起中依生引二门。开为四重征释。谓十二支。初二能引。次五所引。次三能生。后二所生。故为四也。然依杂集第四云。十二有支。皆具此有彼有等义故。彼论文释支相云。相者谓无作缘生故。无常缘生故。势用缘生故。此有彼有者。显无作缘生义。唯有缘故果法得有。非缘有实作用能生果法。此生故彼生者。显无常缘生义。非无生法为因故。少有法生而得成立。无明缘行等者显势用缘生义。虽复诸法无作无常。然不随一法为生故。一切果生。以诸法功能差别故。然今经中欲显缘起无性。举前二门。势用一门六地广辨。就二门中。从增胜说前后互举。前七许同因位故。名能引所引。后五要因果相望。云能生所生。由此能所引中但云此有彼有。后文则云此起彼起。起即生也。故集论云。谓于因时有能引所引。于果时有能生所生。然文有染净二观。初于能引中明染观。故云无明有故行有。第二约所引。亦通能所相对以明净观。故云识无故名色无。以识通能引有二种业。一持诸有情所有业缚。谓与行所引习气俱生灭故。二与名色作缘。谓由识入母胎。名色得增长。今言识无者。即不为业熏不持业缚故不入胎。增长名色故。云识无故名色无。第三能生所生相对。以明染观故。云爱起故苦起。苦即当果爱即能生。能生有三。举初摄末。下明净观举末摄初。盖巧辨影略耳。第四亦能所生相对。以明净观。谓因亡果丧耳。后之三门皆能所相望。何以无明与行。唯约能引而相望耶。答欲显十二支皆有无作无常二门故。于初一位相次以明。不尔则谓要四位相望。方得此有彼有故。下之三门。欲显四位不同故。能所相望。又为显能引支中或二或三。故于前二别为一段。盖说者之妙也。第二有漏五蕴。蕴者积聚义。杂集第一云。藏果重担义而标名世间者。世即隐覆义。隐覆胜义故。又可破坏义。三世所迁故。间者堕虚伪中故。隐覆之法即堕虚伪故。世即是间。然色等蕴通于无漏。出世之义。欲诃毁故略举一分。云何知之。应知三种。一知其相。谓色以变碍为相。受以领纳为义。想者取像行谓迁流。识以了别。二知其生灭。谓生无所从来灭无所至。三知其不生不灭。谓法本不生今则无灭。故力林菩萨云。分别此诸蕴。其性本空寂。空故不可灭。此是无生义。况知一切法趣蕴。蕴即法界无碍。方名真实多闻。然诸蕴性。性皆迁流。随胜立名。行之一种。虽标总称即受别名。又摄法多故。第三无漏五蕴。亦名无取五蕴。然无漏蕴亦有二类。一仍本名。亦名色等。不与漏相应。故名为无漏。二从已转立名。即五分法身如今文是。欲显戒等德是可欣故。从极果标以出世。理实亦有世间戒等。戒定慧三上来频释。解脱即是离系。为名解脱知见由离系缚。于境自在观求觉了。智论八十八云。戒众者。摄一切戒和合成众。众即蕴也。余皆准之。然即转前五蕴成此五分。谓转色蕴成于戒身。表无表戒皆色蕴故。转受蕴而成定身。定名正受。入四静虑出四受故。转想成慧。凡所有相皆是虚妄。见相非相见法身故转行为解脱。无贪等行名心解脱。永断无知慧解脱故。又转识成解脱知见。若与邪受妄想相应。谓识依根了别诸境。若与正受智慧相应。即是现量如实知故。仁王观空品云。观色识受想行。得戒忍知见忍定忍慧忍解脱忍。即斯义也。知见与慧此二何别。佛地论第四。总有三说。略举其一。谓无漏净戒。名为戒蕴。无漏定慧名定慧蕴。无学胜解名解脱蕴。无学正见名解脱知见蕴。前三是因后二是果。此五别说四法为性。谓定慧胜解。及无表色。然此五分法身。不覆胜义不为相迁。不堕虚伪故名出世。杂集云。谓能对治三界。无颠倒无戏论。无分别故。是出世间义。问无取五蕴即有为无漏。何以言不为相迁。答约教异故。前是权小所明。若实教定说非为无为。同真性故。但似蕴相现。立以蕴名故。涅槃纯陀云。善覆如来有为之相。应言如来同于无为况一一融摄。若如是知名为多闻。第四有为者。瑜伽一百云。有生灭系属因缘。是名有为。智论云。有所得故。是名有为。二论心境为异。今略举四事。三界即所依处。众生即能依之者。然所依处随心成异。故论云。欲所属界名欲界等。第五无为。为者作也。即前生灭今虚空等。寂寞冲虚湛然常住。无彼造作。故名无为。瑜伽云。无生灭不系属因缘。是名无为。智论云。无所得故名为无为。净名云。不堕数故。然诸论总名大旨无别。然其名数开合不同。小乘多说三种。即此中初及三四。诸大乘中掌珍说四。谓加真如。法相论中或说有六。复加不动及想受灭。谓于择灭中灭惑障。故名为择灭。灭定障故复加后二。或开为八。于真如中开出三性。谓善法真如等。渐欲展此真如遍诸法故。此经说六。于择灭中开出涅槃。二道别故。复加缘起。显无一事不即真故。略无二定未究竟故。言虚空者。离诸障碍无物所显故。二涅槃者古有二释。一云性寂灭故。此即性净涅槃。涅槃三十四。亦同此说。此与择灭显未显殊。一云即性净之果。此即解脱道。后择灭乃在无间道中。然大乘非择灭。既约性净。又下说法性。则后解为正。三数缘灭者。数谓慧数。由慧为缘拣择诸惑。能显灭理故。唐三藏译为择灭。谓择力所得灭名为择灭。然此灭言有其二义。一理性寂灭。此从所显得名。二因灭惑显名理为灭。则从能显得名。四非数缘灭者。非由慧数灭惑所得。但以性净及于缘缺之所显故。五缘起者。有别有通。别谓十二因缘故。分别论者大众。一说鸡胤化地。说出世部。皆立十二缘起。以为无为。彼意以其次第作缘。恒无杂乱故。说为常。有佛无佛此法自尔。名曰无为。故智论三十二云。声闻法中。亦说法性实际。故杂阿含中说。有一比丘。问佛十二因缘为是佛作。为是余人作。佛告比丘。我不作十二因缘。亦非余人作。有佛无佛诸法皆如。法相法位一切常有。所谓是事有故是事有等。涅槃亦说即是无为。远公云。就人论法三世流转。是其有为。废人谈法法相常定。故曰无为。望今经意缘起无性。故曰无为。大品云。菩萨观十二因缘。如虚空不可尽。涅槃云。十二因缘即是佛性。虽举十二因缘。即已摄阴界诸法。六法性住者即真如也。谓非妄倒故名真如。又真实如常拣妄拣事。于一切位恒如其性。而云住者离迁变故。与法为性是随缘义。复云住者是不变义。即妄即真事皆如矣。若准智论。法性法住各是一义(云云)。即为七法。然小乘说三。虚空则就外空。复计三皆实有。若大乘说非唯数增。义亦有异。唯识论中二义建立一唯心变故。二依法性假施设。有谓此诸义但一真如随义假设。一无相义。二所证义。三惑尽义。四性净义。五随缘义。六随缘即不变义。此中法性即是真如。然法性真如亦假施设。遮拨为无故说为有。遮执为有故说为空。勿谓虚幻故说为实。理非妄倒故名真如。为法之性名为法性。非离色心别有实体。今多闻之人。不唯知名而已应如是知。第六有记法者。有释云。谓能招爱非爱果。故名有记。此乃通说。余处辨记即是善恶。今唯举善。应云顺理善法可记录故。下出所记法体。句有十一义摄唯五。四圣谛如前本品已辨。四沙门果如梵行品。四辨如第九地。三十七品如第四地。四无所畏今当略明。谓外难无怯故名无畏。瑜伽云。如来于此谤难。都不见有如实因相。由是因缘能自了知坦然无畏。无畏有四。一一切智无畏。二漏尽无畏。三者障道。四出苦道。此之四段各有难答。初外难云若佛是一切智者。有诸比丘从他方来。何须问言安乐住不。言一切智无所不知。今问于他一何相反。佛自唱言。我是一切智人。但为摄受来者。随顺世间师弟人事故。二有难云。若佛自言漏永尽者。何以爱语罗睺诃骂调达。佛于此难正见无由。安隐无怯。自唱德号我实漏尽。但为随根而调伏故。三有难云。若佛说欲能障道者。何故预流一来。尚有妻子之爱。佛于此难心无怯惧。谓自唱德号。我说欲能障道。但障不还罗汉非初二果。四有难云。若佛说诸圣道能尽苦者。何故罗汉受疮溃蛇螫之苦。佛于此难心无怯惧。自唱德号。我说圣道实能尽苦边际。但说未来非现在故。四中初一离所知障。次离烦恼障。三是出离道障。四即出离之道。初二自利后二利他。所以自叹此四者。初一为菩萨。第二为声闻。后二通为。智论二十八。瑜伽五十对法十四。广辨其相。第七无记中分二。先征名。后谓世间下辨相。今初无记二义。一非善非恶不能招感爱非爱果。名为无记。可释余文。今此正谓虚妄推度非理问难不可记录。故名无记。非对善恶故。俱舍第十九云。诸契经说十四无记。即其义也。亦名置记记即答也。不应答故。所以不答者何。谓此乃无义语也。知之不免生死不知不障涅槃。前说有记则反于此。智论第三云。所以不答十四难者。此事无实故。诸法有常无此理故。言断亦尔。如有人问。[(殼-一)/牛]于牛角得几升乳。岂曰问耶。复次世界无穷犹如车轮。复次无利有失堕恶邪中。覆于四谛诸法实相。复次人不能知。复次称法说故。第十七云。有一比丘。思惟十四难不能解辞。佛不为弟子。佛言我为老病死人。说法济度。此是斗诤法如中毒箭。不应推寻。楞伽亦云。皆是世论非我所说。言十四者。即此中前四四句。其第四四句但合为二。谓身与神一身与神异。然诸经论多说十四难。而相或同异不繁会释。今经委论不出我法二执。文分五段。第一有四四句。就我明无记。第二过去下。就三世横论凡圣数之多少。三何等下。约凡圣竖论初后。四世间从何下征三世间所从。五何者下约生死际畔。以辨无记。今初句虽十六。其过不出断常二见。言世间者。准大品中通三世间。谓众生世间五蕴世间。及器世间。今此文意。正显众生世间。兼明五蕴世间。以众生是总主假者外道计以为我故。有边等诸见。初有边四句约未来世。常等四句约过去世。如来有无依涅槃起。故中论邪见品云。我于过去世为有为是无。世间常等见皆依过去世。我于未来世为作为无作。有边等诸见。皆依未来世。涅槃品云。如来灭后有无等。依涅槃起。我及众生有无四句约现在说。既知起见之本。次随文别释。即为四段。第一四句言有边者。即断见外道。计我于后世更不复作。则与此身俱尽。无边者。谓我于后世更有所作。三俱句者。身尽故有边。我不异故无边。四俱非句者。亦以我存身尽见上有过故立此句。谓身尽故非无边。我存故非有边。既皆邪见故不答之。若欲破者。初之二句。堕无后世过。谓有边则与阴同尽。无边则是今身。故皆无后世。无后世者。修道苦行为何益耶。第三句亦有边无边者。若身尽我存身我为一为异。一则不应有尽不尽。异则离蕴何相知有我耶。若谓舍人生天。人分犹在天分。更增则半天半人故。皆不可。第四句非有边未免于无。非无边未免于有。云何于此强分别耶。二常等四句。约过去者。过去世我即是今我。名之为常。若常即有大过。破坏因果涅槃等故。若谓我今始生名为无常。若尔我是作法。亦堕无因。无因则亦无涅槃等。第三见上二过。便谓我常身无常。离身何处有我。又成上二过。第四谓我不异故非无常。身有异故非常。破同第三句。又中论云。一切法空故。何有边无边及常等见。余义广如彼论。三如来灭后等四句。释有二义。一明如来者非是佛也。如即相似。来谓从前际来。谓一有执云。如从前世来生此间。去向后世亦复如是。故云如来灭后有。谓如前际来时有故。此由计我异阴故。二云。如从前世来此间死后断灭。故云如来灭后无。谓不如来时去故。此计阴我一故。三由计我有粗细故。谓粗我与身俱尽故。云不如去。细我异阴不同灭故。亦如来时而去故。云如来灭后亦有亦无。四云我如虚空体无来去故。晋经云。如来灭后如去不如去等。此则通望三世以辨。若依中论。附涅槃起四句。如来即佛也。顺此经文。亦是外道自立己师。而为如来。有谓如来灭后定有不变。或谓入无余依同于太虚。或谓法有应无。或谓约应非有。约法非无。以其四句皆成戏论。不见如来寂灭相。故亦为邪见。此则权小之徒。未能免也。瑜伽八十七云。依二道理如实随观。俱不可记如来灭后若有若无。所以者何。且依胜义彼不可得。况其灭后或有或无。若依世俗。为于诸行假立如来。为于涅槃若于诸行。如来灭后无有一行流转可得。尔时何处假立如来。既无如来何有无等。若于涅槃。涅槃唯是无行所显。绝诸戏论。自内所证绝戏论故。施设为有不应道理。亦复不应施设非有。勿当损毁施设妙有寂静涅槃。又此涅槃极难知故。最微细故。说名甚深。种种非一。诸行烦恼断所显故。说名广大。现量比量及正教量。所不量故说名无量。四我及众生有无等四句。此并双立众生即是五蕴。非约总主。有即定有定有着常。无即定无定无著断。三远上二过双立有无。即堕相违。四避此相违立俱非句。又成戏论。然此四句。亦有单计我有所无所有我无。亦不离初之二句。又合上成第三。互夺成第四。亦不出初之二句。第二门明三乘凡圣数之多少者。以横无边故不可记也。第三门竖无际故不可记也。有人答问云。有初佛言自然悟引獭祭天。亦为应机宁加置记。若有初佛如来应知。则可说名。言何法者。染净等一切法也。第四门征世间所从有六句。初二句问众生及蕴世间。次四句约器世间。以外道计众生有最初生故。或谓从冥谛中来还至冥故。或谓世界皆微尘成。谓至妙之色常恒不变聚。则为身器。散则成微尘故。此皆邪见之源故不应答。有情世间不言成坏者。瑜伽云。有情望器有五不同。一谓器界生死共因所生。有情生死但由不共故。是因不同。二谓器有除断有情流转不断故。是时不同。三谓三灾坏不坏故。名法不同。四谓器界因无永断有情不尔。名断不同。五谓器则断而复续。有情断已无续。名续不同。以斯义故略无成坏也。第五约生死初后际。唯有二句。问初际无始圣教所明。生死有终岂非正理。答略有三义。一约一人则可云终。通望一切则无终极。二以彼定执长邪见。故亦不应答。谓若许有终必有始故。常法无始亦无终故。三约法性皆不可说故。中论云。大圣之所说本际不可得。生死无有始亦复无有终。若无有始终。中当云何有。是故于此中先后共亦无。既言本际不可得。亦不应定谓无始无终。况有始终之见耶。又有偈云。真法及说者听者难得故。是故则生死非有边无边。上诸邪见多是外道。亦参小乘。菩萨善知则问答无滞。便举破者。令自他造中故也。第二菩萨下显多闻之意。谓悲物无闻长沦生死。故誓持闻藏自证利他。第六施藏文三同前。释相中二第一标列十章。第二佛子下依章牒释。释中十段一一各三。谓标释结。然此十施前六事舍。谓身命财。次三心舍。谓不取着。后一俱舍名为究竟。第一分减施。释中三。初明分减之相。二若自食下明施善巧。外无施境而不舍施心。三复作下对治施障。第二竭尽施者。不顾活命倾竭所有也。然施心须成施行须量。若彼为成大利则身命无吝。若彼但为贪求无厌。或恶心欲行大害。应以方便勿成人恶。如月光王施头。与怨夺万姓之欢。施二人之死。怨王喜死。乞者恨死。虽有贤行未全可准。今言竭尽者。以彰菩萨施心已成。有应施境终无吝也。内施内外准此可知。若不尔者。菩萨能雨七珍充足一切。何不施耶。亦见众生所不宜故。释相中三。初明难施之物。二或时下乞境现前。三菩萨自念下正修施行。下之四施皆有此三。第三内施。谓内身也。茕者单也。玉篇云无兄曰茕。无子曰独。顿者损也冀者望也。第四外施即王位也。窭者无财备礼也。第五内外施者。王位为外兼身作役为内也。第六一切施者。凡所有物也。此与竭尽及内外施异者。竭尽拣异分减。但约资生内外合前二门空。言作役王位。今云一切通前诸门。又是事舍之终故总该收举难摄易。略列数条。广则无边。如第六回向所辨。第七过去施者。然三世之施。通相皆明不着。别则过去不生追恋。未来预止贪求。现在心无染着。今过去释中分二。先明于佛法无著。后又复下于一切法无著。前中初二句总明。次不起分别下别显。先显不着之相。不分别者称法性故。次不贪染不爱味。亦不方便求取以为己德。亦不依此而起修行。次见法下。广上了达释不着所由。次但为下释疑。疑云。既俱无著云何而说。释云为化众生令无著故。二于一切法无著者。以般若智求不可得。触目现境尚了性空。过往法中宁当计有。第八未来施释中分二。先正显后释疑。前中不着修行之因。不愿净土之果。不味其好不厌其事。不回向者释上不味。不自安处求胜乐故。不退已下。释上不厌修彼行故。二但欲下释疑。疑云。既于净不味修行何为。释有二意。一者约悲但为摄物故。二然此下约智。智了非有故。生即非生故。不着不碍事故。非生之生故修行。非有处所者与理冥故。非无处所者事像形故。非内者相分境故。非外者心所净故。非近者十万等殊故。非远者我净土不毁故。此约净国以说。若通论未来法者。可以意知。复作已下。更约性空结成舍义。又目击尚舍况于未形。第九现在施释中有三。初明所舍之境。二闻已下正明舍心。三为令下释通外难。今初先列诸天。后列二乘功德。上二世中举佛菩萨。今举诸天二乘者。文影略耳。天中初六欲界。已如初会。梵天已下明色界天。然色界摄天多少。诸说小异。俱舍正理皆说十七。故颂云。三静虑各三。第四静虑八。长行之中建立十六。以梵王梵辅同一天故。瑜伽云处有十八。谓色究竟外说大自在。不言无想。意在广果中收。今此即文而数有二十二。然四禅初一皆是总标。则初静虑四。二三各三。第四有八还成十八。正理初说有三。今加梵身。晋经梵众名梵眷属。若然身亦众义。则梵身是外所领之众。梵众则为内眷属众。梵辅即大梵前行列侍御大梵。即彼天王获中间定。初生后殁威德等胜。故名为大。次光天下。即二禅三天。一自地天内光明最少故。二光明转胜量难测故。三光音者口出净光故。次净天下即三禅三天。意地受乐总名为净。一于自地中此净最劣。故名少净。二净增难量故。三此净周普故。次广天下明四禅八天。初三是凡离八灾患。皆称福广。于自地中此福犹劣。故名少广。三福难量故。三异生果中此最胜故。无烦已上名五净居。谓离欲诸圣以圣道水濯烦恼垢。故名为净。净身所止故名净居。或此天中无异生杂。纯圣所止故名净居。一无烦者。烦谓繁杂或谓繁广。无繁杂中此最初故。繁广天中此最劣故。此依正理。若顺今经皆作此烦。则无广义。二无热者。已善伏除杂修静虑上中品障。意乐调柔离热恼故。或热者炽盛为义。谓上品修静虑及果。此犹未证故。三善现者。已得上品杂修静虑果德易彰。故名善现。四善见者。杂修定障余品至微见极清彻。故名善见。经本先见后现或恐误也。五色究竟者。更无有处于有色中能过于此故。或此已到众苦所依身最后边故。言乃至二乘功德者。中间越于四空等。故二正明舍心中。闻上世出世境已。不迷为实。不沉没于贪。不聚集其善因。不散动以分别。但观下释其所以可知。三释难者。疑云既言不聚善因。何以说五乘因果。释云。拯三涂之剧苦。示人天以稣息。止劣见之妄情。说二乘以引摄。为物然耳。非自不舍也。第十究竟施文三。同前征名者。略有五义得究竟名。一前六舍财命。次三舍着心。今则兼上二门故。二又发大愿令物无著故。三令物得究竟果故。四不生一念爱着。则微细无著故。五究竟能令物实益故。如无眼等而施之者。如世凡人。岂能将他之目安之于己。今菩萨福力令彼还得。以慈善根力故。如五百群贼。平复如故。故云究竟益。释相中三。初施境现前。二菩萨闻下正明施行。三如我下回向众生。二中分二。初正施无吝。二但自下释成行之由。由入观故。此观即是念处观也。皆言身者观有通别。别观五蕴一一名身故。净名云。是身如泡不得久立等。通观五阴皆无常等故。智论云。五阴即无常无常即苦。苦即无我等。今此不净偏语色身。余之三观皆通五蕴。第一苦观。谓始从入胎皆生苦。摄老等可知。二又观下明无我观。谓无真实主宰故。无有惭愧者。虽假以澡浴衣食。一旦背恩如小儿故。非贤圣物者是世间故。故智论云由无我故令舍世间。三臭秽下明不净观。四复作下明无常观。观危脆故。三回向者拣小乘故。然菩萨修此观时。以无所得而为方便故。同法界故。已不共小况回向耶。第七慧藏中分四。一征名二释相。三结名四叹益。就释相中二。初明慧藏后释无尽。前中三。初明如实知境。次云何下释如实知义。三菩萨成就下总结多门。以彰善巧。今初以四谛慧照十种法。摄十为五类。前五五蕴次二有支。后三三乘故。收此五类不出二门。初二凡境后三圣境。又若后三就果。则初二有作四谛。后一无作四谛。界内界外因果异故。此就所观。若约菩萨能观皆无作也。又初二流转后三还灭。前有灭道。是流转始修之还灭。后有苦集。是还灭未尽之流转。又前是所知之法。后是能知之人。人中有法即是前法。历于四谛是声闻法。所缘有支是缘觉法。五蕴即是三乘共法。皆如实知是菩萨法。皆言如实知者。下经总释今当略辨。一如事实。二如理实。十中前七当相是苦。无明与爱有漏性故。行苦随故。行蕴摄故。缘成是集无性是灭。显灭为道从诠显故。此则总说及就理灭。若别说者。不了无常不净等过。而生爱著名为色集。若灭痴爱名为色灭。唯止与观是色灭道。由止离爱由观离痴。若兼助道。即有戒学及道品等。受想行识例此可知。无明集者。由他言说不如理引。由自妄想不正思惟。灭此名灭。言爱集者。谓无明触为缘所生受故。亦灭此名灭痴爱之道。皆同蕴说。十二支中唯举二者。发业润业唯此二故。能引能生各举初故。从痴有爱病之源故。涅槃三十四云。从无明生爱。当知是爱即是无明。从爱生取当知是取即无明。爱等亦似斯义。又约三际。无明为本爱取为际。此二中间。有识等五及生老死。今悟无明。由迷过去有识等五。现在之爱即是无明。若不断者轮转不息。今思断之。将来无复生死矣。后三约净。声闻是人四谛为法。所行道品为集。所成果为涅槃。十二因缘是缘觉法。无边法界是菩萨法。又知声闻即是知苦。以声闻苦是已知故。但举其位。法即是彼所行之法即是道谛。集即是彼惑。集未尽是为集谛。已有断故法后说之。涅槃即是灭谛。已证灭故改名涅槃。缘觉菩萨准斯可见。前释通因后释就果。若定以前二为分段。后三为变易。则小乘三果已前应受变易。直往七地已下。非此所知故不可也。第二释如实知义。非唯能知行相。亦显所知之相也。先征后释。征意云。为随相知为无相知。若随相知宁异凡小。若无相知。无相无知故言云何知。后释意云。知相知性无有障碍。是菩萨所知。无知之知是菩萨知。文分二别。先约自利明知苦集。后约利他彰知灭道。二文影略应各具四。又二段中含前五类。具显三乘。今初段中知。从业报是五蕴相。业集报苦是二谛相。言诸行因缘之所造作。十二支相诸行因缘。即是集相之所造作。是苦谛相。上辨知相。一切已下显知无相。通于苦集。初有二句共三乘相。非我已下释成上文。拣二别相。由非我故空无有实。但假五阴是声闻相。以非坚固空无有实。但缘成假是缘觉相。若无少法可得空无有实。但虚假幻相是菩萨相。非安立谛无可成故。二欲令已下。次约利他彰知灭道。能知实性是道谛相。法不可坏及所知性。即灭谛相。广为宣说唯菩萨相。文中二。初标说意。二为说下展转征释。总有三重。初征意云。说何等法令知实性。释云。说不可坏此略示其宗。次征云。此不可坏为性为相。此寻说处。释云相即性故。五类等法皆不可坏。依般若中。自色已上种智已还。悉皆遍历。后征云。现见诸法。犹如聚沫泡焰芭蕉幻梦不实。那言不坏下释所由略由三义。一色等性空无可坏故若坏方空非本空故。二由空即真同法性故。若坏方真事在理外故。三由即空不待坏故。坏则断灭。文中十句五对。初无我无造故不可坏。二离能所诠故。三能生不生所生不起故。四因不取果果不与因故。五体无动转用无作相故。第三总结多门以彰善巧者。更有多门。皆以无所得等为少方便。则色空见尽。坏与不坏两亡。不随境转。名不由他悟。第二释无尽义。有标征释结。释亦十事五对。一因缘二教理。三福智四持辨。五智通。福智中云。一味者。百华异色共成一阴。万法虽殊贯之一智。亦如上酥无不入也。三结四叹文可知。第八念藏。释相中有四。一总标念体。二所念差别。三能念胜相。四明念益相。二忆念下所念差别中。唯依宿住以辨明记。略举十事以显无尽。一生二劫。三佛名四授记。五演教六众会。七说义八根性。九所治十能治。文并可知。十二分教今当略说。旧名十二部经。恐滥部帙改名分教。各有二相。唯修多罗或二或三。修多罗者。此云契经广如初卷。言二相者。一是总相。谓涅槃十五云始从如是我闻。终至欢喜奉行皆修多罗。二者别相。杂集十一云。谓长行缀缉。略说所应说义。然更有异名异名有四。一法本二但名经。三直说四圣教。言法本者。远公以五义释之。一教为理本。二经为论本。三总为别本。四初为后本。五略为广本。以彼立三修多罗故。一总相二别相三本相。亦名略相。总不异前。别谓就前总相分出十一。余不收者。还复摄在修多罗中。名为别相用斯别相望祇夜等。为其本故。名初为后本。言本相者。于彼别相十二部中。初略标举名修多罗。后广释者随别名之。如言色者即是根本略相。复云青黄等者是名广相。故云略为广本。然其后二。不违杂集长行缀缉等言。缀缉即是十一所不摄者。如贤首品云。尔时文殊师利说无浊乱清净行大加德已等类。此是结集缀缉。非佛正说。故云十一所不摄者。其略说所应说义。即是略为广本。如欲显示菩提心功德故。即其类也。此第三略相亦顺成实。成实名直说。语言总相而言名为直说。一一语言多义分别。名非直说。斯则通十二分教皆有此一。若十二分中修多罗。并通前三。若三藏修多罗唯局总相。但开杂集别义。以成后二有不晓者妄非先贤。而云修多罗但依总相业用。则违诸论长行缀缉等。言二祇夜者。此云应颂。一与长行相应之颂。由于长行说未尽故。杂集云。不了义经应更颂释。如十住品发心住颂。即其类也。二为后来应更颂故。涅槃云。佛昔为诸比丘说契经竟。尔时复有利根众生。为听法故后至佛所。即便问人。如来向者为说何事。佛时知已。即因本经以偈颂曰。我昔与汝等不识四真谛。是故久流转生死大苦海等。三授记者。梵云和伽罗那。亦云记别。记者录也。别谓分别。一记弟子生死因果。其文非一。二记菩萨当成佛事。如记弥勒。此发心品及出现品。并有其文四伽陀者。此云讽颂。讽即是颂。谓孤起偈。一为易诵持故。二为乐偈者故。三天偈赞皆是其流。五尼陀那此云因缘。一因请方说为重法故。如三家五请等。二因事方说知本末故。如观善财。又杂集云。又有因缘制立学处。即因事制戒。亦第二摄。六优陀那此云自说。一为令知而请法故。如十地本分等。二为令所化生殷重故。念佛慈悲为不请友。如普贤行品等。七本事者。梵云伊帝目多伽。一说佛往事。如说威光太子等。二说弟子往事。如说诸善友因缘等。八本生者。梵云阇陀伽。谓说昔受身。一说如来如说威光数数转身值诸佛等。二说弟子如诸善友等。然其本事。但云其事除所生事。本生要说受身耳。九方广者。梵云毗佛略。一广大利乐故。二正法广陈故。此经一部全受斯称。涅槃云。所谓大乘方等经典。其义广大犹如虚空。杂集开为五义。云方广者。谓菩萨藏相应言说。亦名广破。以能广破一切障故。亦名无比法。无有诸法能比类故。一切有情利益安乐所依处故。宣说广大甚深义故。十未曾有者。梵云阿浮达磨。亦云希法一德业殊异故。如佛。初生即行七步。斯经不起而升四天等。二法体希奇故。谓说佛菩萨不共功德。经文非一。十一譬喻者。梵云阿波陀那。一为深智。说似令解真故。如法华云。诸有智者以譬喻得解。如出现品一一喻明。二为浅识就彼取类诱令信故。如为担人说二蕴等。此经所无。杂集通说。为令本义得明了故。十二论义者。梵云优波提舍。一以理深故。二义不了故。并须循环研核。或佛自说或菩萨相论。如问明品等。此之十二。于大于小为局为通。若皆大者则违涅槃等文。涅槃第三云。护大乘者受持九部。法华第一云。我此九部法随顺众生说。瑜伽等论说声闻藏。无有方广。然诸经论。且约一相故作是说。如实说者。大小皆具。如深密中。菩萨依十二分教修奢摩他。瑜伽二十一云。佛为声闻一一具演十二分教。而涅槃说大但有九者。依三部中之小相故。谓因缘中取因事制戒。于譬喻中依为诱引。于论议中约非了义。法华九部小者。三相大故。于记别中取记作佛。自说之内依不请友。方广之中依广大利乐。其正法广陈通大通小。然契经。望余总相略相则许通。有别相则无。应颂讽颂本事本生。互望并无。本事本生望于记别亦是互无。自说因缘容得互有。如因事说不由请故。除上所除余皆互有。此经之中具足十二。已如上引。十二分教义已略周。有欲广知。如涅槃十五。杂集十一。瑜伽八十一等说。言一三昧种种性者。如一定中。凡小权实多差别故。又一多即入故。三此念下明能念胜相。于中十句。一静虑相应故。二无漏俱转故。三净信俱故。四了了知故。五不取相故。六离分别故。七离所知故。八与慧俱故。九具上诸德故。十离上诸过故。四菩萨住此下明念益相。亦有十句。既世与出世皆念故。能离过成德并显可知。第九持藏。释相中三。初别举文义显长时持。二持一佛下。遍举诸法显能广持。所持即前所念之法。三佛子下辨能持德量。文有十句。一大之无外。二广能虚受。三深难至底。四四边绝相。五外无能制。六体无分量。七用无穷尽。八内含众德。九因彻果源。十余无能究。第十辩藏文有四别。谓征释结叹。释相中四。初总举体用双照事理。二种实相名深智慧。二说一品下显能广演。三或一日下明长时演。二先正明。后征释。以是十藏之终故说具前十藏。近接总持。复举陀罗尼门。四其说法下彰辩之德。亦有正明征释可知。四叹胜中文有十句。义该七辩。一无穷尽是丰义味辩。一一句中出多事理故。二即捷辩。欲言即言无分段故。三无疏谬辩。不以邪错间深理故。四无断辩。相续连环故。五应辩。应时应机无变异故。六迅辩。迅若悬河无隔碍故。已下四句。即一切世间最上妙辩。此辩有五德。一甚深如雷即第八句。二清彻远闻故不退转。即第七句。三其声哀雅。如迦陵频伽故。能普入一切佛法。即第十句。四能令众生入心敬爱。五其有闻者欢喜无厌故。难可得入上二即第九句。上来第三依章别释竟。第四佛子下。总叹十藏胜能分三。初标叹二征释。释有十句摄为五对。一下化上求。二竖穷横遍。三舍相契实。四无变善摄。五外护内明。三是为下结叹。此后应有偈等或是略无。多是经来未尽。第四会竟

大方广佛华严经疏卷第二十四大方广佛华严经疏卷第二十五

        唐清凉山大华严寺沙门澄观撰

    升兜率天宫品第二十三(从二十二经至二十五经一半)

自下第五会。明上贤十向。四门同前。初来意中。先会来者。正为答前回向问故。回前解行以向真证。广益自他令行弥纶。无不周故。菩萨大乘藏经云。以少善根引无量果者谓回向心。以回向心为大利故。故行后明之。又前解行既着。今悲愿弥博。后品来者。前会既终将陈后说。先明说处表法故来。二释名者。先会得名亦有三义。同前二会。二释品名。兜率是处。佛以法界之身不起而应。故名为升。处此说者表位超胜是次第故。又上下放逸。此天知足。表世间行满故。居喜足之天。又以彼有一生补处。表菩提之心功行满故。又积功累勋知阶未足。回勋授子乃知有余。菩萨亦尔。勤苦积行未见有余。回向众生乃知自足。又欲界六天此居其中。表悲智均平处于中故。又生此天而修三福。谓施戒定。自余不具偏多不均故。处此说也。第三宗趣者。会以十向大愿为宗。得地为趣。品以升天赴感为宗。说向为趣。第四释文。此会有三品经。初二当会由致。后一正说。所以无胜进者。由二义故。一以此会是三贤位终。摄前解行总为趣地方便。回向当体自是胜进。是故无也。此经上下其例有四。一约行满入位之际。如贤首品。信满总为入住方便。二约愿满入证之际。如此回向初僧祇满。总为入地方便。三约功用满。入无功用之际。如第八地初。总摄前七地以为方便。此第二僧祇满。四约因位成满之际。如第十地初。摄前九地为入方便。此约三僧祇满处摄也。余同位相接。即别有方便。故非一例二。方欲入地必离进趣相。与无分别为方便故。就初二品。前一化主赴机。后品助化赞佛。今初品中大分十段。一本会齐现。二不离而升。三见佛严处。四迎佛兴供。五睹佛胜德。六请佛处殿。七如来受请。八天王获益。九承力偈赞。十如来就坐。今初也。初言神力即是遍因。未必起神境通。但是修成心自在力。十方已下辨所现相。于中亦有化主助化。望第四会。既加及须弥顶。此亦应云坐于树下及须弥顶夜摩天宫。文无者略。以第二段中带前升。后既全举。前四则影。显前四皆圆遍也。而演说者。亦通四会之所说也。第二尔时下。明不离而升。谓前十方一切处。四会皆俨然不散而升。此说意。明横遍十方竖该九会。佛法界身遍时处故。余义具如第三会初。第三时兜率下。见佛严处中二。初明感应缘会。二即于已下正显严处。于中分二。先明一方严处。后结通十方。今初。初虽标座。下列楼帐等皆兼处严。文分为二。初总显体德。后有百万下别明体用。今初有十一句。初总余别。总中无尽大愿随意出生。悲智必俱生死无染。名摩尼藏。展行弥布故有敷言。别有十种圆满胜相。以斯妙座实德成故。初一自体相以宝成故。次六因相。一深远相。二胜妙相。三广大相。四同体相。五具德相。六坚固相。后三总显殊特即座之德用。一端严故。二离染故。三无极故。二别明体用中。通有三百二种百万亿。广上三段即为三别。初广自体。次有百万亿初发心下广前殊特。三百万亿善根下广前因相。初一多明器世间严。后二显众生世间严。皆智正觉世间之力也。皆言百万亿者。位增十行之百万故。初中长分为十。前九色相严。后一音声严。其一一严事皆即法门。可以意得。第一有十句座体严。于中初句辨座层级。后九覆座之严。虽四面行列执盖亦为覆座。第二楼阁下十句。复于殿内建立楼阁绕座庄严。亦是严处。于中初句总。下九句别显严阁。第三宝铃帐下。十句辨帐严。亦是绕座。前已辨覆故。若重辨者。帐上建楼楼上覆帐重重无尽耳。第四妙宝华下。有十二句辨严座身。其频婆帐应在宝华之前。类例稳便。亦可十二句辨帐。九句严座身。频婆者此云身影质。谓帐庄严具中。现外质之影故。第五因陀罗金刚宝下。有十七句。亦严座四周皆明妙宝以为窗门。及覆亦严座体。以庄严其藏。是莲华藏故。标中表法有异。住行不言莲华。理实应有。或是座身之龛名藏。第六真珠璎珞下十二句。璎珞周垂严。其摩尼身下二句。文似缺略。谓因陀罗妙色宝下无所结属。又非下之香类。不可别为一段。第七黑栴檀下有十六句。以香为严。阿楼那者。此云红赤色。第八雨百万下二十句。雨云为严。第九建百万下四十八句。座外四面严。于中有四。初二十句。杂杂庄严罗列座侧。言楼阁延袤者。静法云。梵云蒲莫迦。此云帐舆。若是楼阁应云微么囊。既不尔者译之误也。此或应尔。前文已有楼阁故。若重辩者亦无大失。宝悉底迦者。具云塞缚悉底迦。此云有乐。若见此相必获安乐。其形如万字具于音义。今宝形似此。二光明宝下九句。光明严。言网覆者。若世之灯。以护夕虫成隐映故。三天宝衣下九句。宝衣敷布严。四天铃幢下十句。宝幢行列严。第十天蠡出妙音下。辨音声严。于中二。初十句乐音严。后悦意音下二十句法音严。前中云牟陀罗者。此云锋鼓。谓天乐初奏。此鼓先作故。后法音严中。初十一句赞叹三宝。后随顺音下九句。说法益物。大文第二广前殊特者。前文略云见者无厌。亦已略明益相。今广显之。即座之德用。恭敬供养复显为严。文分为二。初明获益后申供养。前中有三十九句。曲分为四。初十约位辨益。二得自在下有十二句。杂辨得益。三得檀下十句。约行辨益。四入一切佛刹下七句。约大用辨益。后三并通诸位。或可第二段明回向。第三段明十行。第四段明十地。或唯约十住通别无碍。二诸天恭敬下。明供养文分为五。初十七句。杂明八部人天菩萨三业设敬。其中所作各随类所宜。二天女专心下二十六句。唯明诸天三业敬养。初之三句。即欲界天色究竟。后复言种种天者。或通无色或总上诸类。善思惟天亦通诸类。三菩萨天下有十二句。明菩萨事供养。四诸天子从天宫出下四句。诸天身供养。五思惟菩萨下十句。菩萨修法供养。亦明得益。菩萨多明得益。诸天但说供养者。诸天供养是益因故。诸天得益即菩萨故。第三百万亿善根下。广前因深十句可知。所以此会严事偏多者。一此天多以补处为王故。二贤位已极大悲普周故。所以十住无菩萨严。表凡入位故。夜摩即有已入位故。然亦未广。而此胜相皆是如来海印所现。法界差别自在实德。人法无碍依正混融之严事也。第二如此世界下。结通十方可知。第四尔时下迎佛兴供。于中二。先将迎兴供二尔时如来威神力下。见佛兴供。前中二。初奉迎。二以清净下兴供。于中先诸天兴供。皆从身出者。非唯显诸天福力。亦表身为供具供自心生。后兜率宫下菩萨兴供可知。第二见佛兴供中二先诸天后百千亿那由他先住下明菩萨。前中三。初明承力见佛。一现佛神力。二宿善力。三法门力。二同兴下庆遇奉迎。三各以下正明兴供。于中三。初十句衣盛供以散佛。表修寂灭以趣果故。二百千亿下十句。明起心雨供严空。显所修万行称法性空。空有无碍。是严空义。三百千亿那由他阿僧祇天子下九句。杂申供养。表万行杂修故。调顺寂静无放逸心。应分为二则有十句。第二菩萨兴供中二。先明行成依报供。后其诸菩萨下身出正报供。前中二十七句文分。为三初十句。多因。成多果之供次八句。一因成一果供。后九句一因成多果供。应有四句。由多因成一果。摄在初段。以多因能一一成故。又初段即一切中有一。及一切中有一切。次段即一中一。后段即一中一切也。今初十句。一时并举多因。后通成诸供。出过诸天者。胜故多故余可知。第二一因一果中。皆因果相似。一盖以障尘。若度能除敝。二帐以庇荫。若悲为佛境。华以开敷如觉解清净。三法忍和悦用严法身。四演教网。则震金刚之妙音观教网则不碍文而见理。五香气闻而不可见。见而不可揽。犹幻法见而不可取。取而不可得。知幻无坚以成坚法。六周遍法空。是佛智身所依之境座之义也。七摧懈慢幢树法胜幢故。八诸法如梦。是佛栖托之所也。第三无著下一因多果供。无著无生但是一义。无生约理无著约智。此二契合方成一因。文中九句可知。第二身出正报供中。文有十句。初二明现身德量。谓一一量周法界德齐佛故。次以从下三句。明胜辩之因。次具足下四句显胜辩所依。后以不可下一句。正申辩赞。皆从总持辩藏之所流故。情动于中故形于言。言犹不足敬之至也。第五尔时一切下。睹佛胜德中分二。先明睹佛身云胜德。后尔时如来大悲下。明现胜德意。前中分二。初睹佛胜德。后尔时大众咸见下。见佛光用。前通十眼所见后约天眼所见。今初也。然此经文。次第具显如来二十一种殊胜功德。以文言浩汗致古释同迷。然离世间品虽具二十一句。而此文义兼广。故随便引于诸论。文分为三。初总观如来。次别观德相。三结成观解。今初略举三德以显一雄。一者如来。二言应者即是应供。三正等觉即正遍知。此一应字亦通属下。随应觉故。此即总句。离世间品名妙悟皆满。佛地摄论皆名最清净觉。亲光释云。谓佛世尊。普于一切有为无为所应觉境正开觉故。此释正义拣异邪觉。又于一切所应觉境。净妙圆满正开觉故。此释最清净义。亦明觉满拣异菩萨。又于一切。如所有性尽所有性。正开觉故。此释符今等字。谓双照二谛平等觉故。亦是遍义。故云正遍知。彼经无正等言。此经缺最清净。上妙严品则有最言故云于一切法成最正觉。下离世间中复有妙悟。妙者微妙离觉相故。悟觉及知名异义同。妙正遍最名义俱别所拣异故。若世亲无性不解总句。但以下别德成斯一觉。故清净觉句句皆遍。第二其身下。别观德相。二十一德分二十段。后二合故。然摄论中二十一德通有三节。一先列经二十一句。二无著菩萨。立功德名以为解释。三无性等。但释论名以符经旨。今各句句配属。其佛地论释有同摄论有异摄论。异者引之。今初明不二现行经也。即观察如来一向无障碍转功德。此是无著立名。他皆仿此。无性二释。一云谓佛一向无障碍智。于一切事品类差别无著无疑故。非如声闻等。有处有障有处无障二种。此约离所知障智德满故。非如声闻有处有障者。谓于极远时方无边差别。诸佛法中有无智转。第二释云。或二处现行。此中无有如是所说二种现行。此释二处亦前有障无障。但前释约表为一智转。此释约遮故无彼二。正同下经二行永绝。世亲同于后释。亲光云。凡夫二乘现行二障。世尊无故。凡夫现行生死起诸杂染。二乘现行涅槃弃利乐事。世尊无彼现行二事故。名不二现行。无性生起云。云何而得此最胜觉。故次说此诸声闻等。于所知境有二现行。所谓正智不染无知。佛无此故。文中分二。初广显利乐。明离所知故。不同二乘二住于下结成所住。彰离烦恼不同凡夫。前中三。初明应广顺机令喜。二普遍下。明其遍应定慧庄严生物善根。三示现下彰应用深。虽超语言而无遗曲济。二结成所住者。初句明智住法身。能住所住二俱广大。下句心无烦恼。善根清净色相超伦。具上二义名清净觉。他皆仿此。第二智慧已下。明趣无相法。即观察如来于有无无二相。真如最清净能入功德。无性云。为明断德故次说之。不住生死涅槃相故。即无住涅槃。然无相法即是清净真如。趣谓趣入。谓此真如诸法无性以为相。故非是有相。体即圆成自相有故。非是无相。此二不相离名无二相。诸法中胜故名最胜。远离客尘故名清净。既自能入亦令他入。为最清净。自入则不住生死。他入则不住涅槃。文中先明自入。后明他入。今初先明不住生死智称如境。皆不可尽。无比三昧令智出生。又令真如出二障故。二其身下明不住涅槃。同体大悲遍住物身。心真如性物物遍故。二令无量下辨令他入。一则大悲冥熏。二则大智为说令于身中见如来性。成一切智故。种性不断是入义也。此用常寂名为涅槃。第三住于诸佛究竟已下。明住于佛住。即观察如来无功用佛事。不休息功德。为欲得上无住涅槃故次明之。文中初明所住后彰住益。今初言住佛住者。谓圣天梵等皆佛所住。而于空大悲遍善安住大悲性空即是佛家故。能不住生死涅槃。为究竟住。此即恩德。是以亲光亦名为观。所调化功德常住大悲。昼夜六时观世间故。后令不可下彰住家益。初明由住大悲。故能益物无遗。是不休息义。由住性空自无功用故。能令物住无分别。出过众生。总显胜也。第四获一切下。明逮得一切佛平等性。下云得佛平等。即观察如来。于法身中所依意乐。作事无差别功德。如上佛住为共不共。故次明之。此一切诸佛展转和杂而同住故。一切诸佛三事无差。非如声闻但有所依。文即分三。初明所依无差别。谓一切智。以一切诸佛。皆依真如清净智故。放大光下显智之用。二普使已下明意乐无差。谓同有利乐胜意乐故。普使之言即意乐也。不可坏智即如来藏。普贤菩萨自体遍故。染而不染名不可坏。反源照极故名安住。三遍住下作业无差。一切皆作受用变化利他事故。于中先明作业周遍。次从于下作业所依。即自受用身。一受不失名为不退。谓得法性即念不退。此后亲生佛智。此智生已还住法界。次明了已下正显作业。初观机。后现不可说下。作业受用变化。各有多类名不可说差别之身。能令已下彰业之益。一能益他。二随初下满本所愿。亦令于物能现色身。此上四段明其自利。后十七段明其利他。第五等观众生下。明到无障处。即观察如来修一切障对治功德。利他之中先明化障对治。故次明之。谓已惯习一切烦恼及所知障对治圣道。即一切智及定自在性。故论名为修治。又已到永离一切习气所依趣处。经名到无障处。二文互显。以有治必无障。无障由有治故。文中心无所著。是无烦恼障。住无碍住明无所知障。得佛十力即是种智。是所知障治。心常寂定住一切智。即烦恼障治。第六善能开演下。明不可转法。即观察如来降伏一切外道功德。由有上能治故他不能转利有情事故次明之。谓教证二法。皆不为他所动转故。无有余法胜过此故。文中初明教道。能悉已下证道。出生已下二道之益。第七恒以佛日下。明所行无碍。观察如来生在世间。不为世法所碍功德。显示如来所化之中。无高下碍。故次明之。谓世八风不能拘碍故。亲光名降魔功德。谓色等境不能乱故。文中以佛身日普照法界。则横无碍。常现不没则竖无碍。不以无信生盲等而不现故。正显八风不碍。恒住已下显无碍因。无有变异示无碍相。如摩尼珠不随物变。不着我所于内无碍。世法不染于外无碍。由住出世如莲华故。如有颂云。诸佛常游于世间。利乐一切有情类。八法势风邪分别不能倾动不拘碍。第八于一切下。明其所安立不可思议。即观察如来安立正法功德。由依前方便能作饶益之事。故次明之。谓十二分教名所安立。由深广故不可思议。文中分二。初约所诠以辨深广。后约能诠以明深广。今初。初句总显。建即安立。其智下释超世广大。即是幢义。拔置智地即是建义。所有已下福智相对。明高广义。二以大慈下现身说法。约能诠教以明安立。第九于去来今下。明游于三世平等法性。即观察如来授记功德。以上加行利有情事。三世诸佛皆悉平等。故次明之。谓于三世平等性中。能随解了。过去未来曾当转事。皆如现在而授记故。故下经云。普见三世。文中。初明三世平等之义。故云心常清净自得平等。令物不着使他平等。恒与已下正明授记。授记未来令同过去种性。亦名平等。第十常游十方下。明其身流布一切世间。即观察如来于一切世界。示现受用变化身功德。显上利益一时顿遍非次第作。故次明之。文中初通辨二身。常约竖穷。遍约横广。十方法界。绮互其文。后诸众生心下总显现相德。无不净故不住生死。机无不鉴故普现世间。第十一以智慧月下。明于一切法智无疑滞。即观察如来断疑功德。以于上十方彼彼之处作断疑事。故次明之。谓于诸境善决定故。故下经云。智恒明达一切诸法。文中初自断疑。非不自决能断他疑故。智月普照总明了。境了达无得是了真境。非不证真能了俗故。恒以智下明了俗境。一切皆以心为自性义通二境。摄境为心是世俗胜义。心之自性即是真如。是胜义。胜义如是而住。以无所得而为方便。双照真俗无住住故。菩萨智光月法界以为轮。游于毕竟空世间靡不现。亦可属上现受用身。二随诸已下能断他疑。初明随机现身。如来已下所断疑境。为说缘起是断疑法。深入缘起疑见亡故。知缘起无性故知法无相。无相无异故名一相。智体理成故为其本。后欲令下正明断疑。若离相着开示菩提。疑方断故。第十二为欲救下。明于一切行成就大觉。即观察如来令入种种行功德。由所化生性有差别。故次明之。谓入种种行皆成大觉。下经但云了一切行。文中初约说法令入。开示佛道者令悟入故。后令其下约现身令入。攀缘修习是进善行。除灭已下是离恶行修菩提行。总举万行心不散动。即是入义。既万行齐修则因无不满。果无不成。第十三悉能观察下。明于诸法智无有疑惑。即观察如来当来法生妙智功德。由即于前所化有能无能善巧别知。故次明之。谓圣声闻言此人全无少分善根。如来知彼善法当生。现证过去微少善根种子所随故。故文云悉能观察。下经云。尽一切疑。如求度者远劫采薪兴一善念。佛便知故观已便化故。不坏其清净业报。智慧已下释其所以。以智普入无不知故。故亲光名为能随所应恒正教诲功德。谓于诸法怀疑惑者。无有堪能。随应教诲唯佛能故。名智慧明了。则第十一是自断疑。此断他疑。第十四永离一切下。明凡所现身不可分别。下经但云无能测身。即观察如来。如其胜解示现功德。由上云善巧别知故。此次云。于前所化邪正及俱行中无有分别。文中初二句明无分别义。世虚妄解种现俱亡故云永离。由自无分别故。余不可以分别知故。亲光名为能正摄受无染自体殊胜功德。谓佛身功德。非是杂染分别所起。无烦恼业生之杂染故。不可分别。而无性云随机现身。如摩尼珠无分别者。则顺今文佛无分别。不顺彼经不可之言。次放光明下彰所示现皆无分别。见无厌足而显众生不能分别。如瞿波观佛毛孔。念念无厌不能穷究故。以大功德下辨能现德。出生已下明所现益。诸根已下辨所现相。谓诸根圆满境界自在。作诸佛事总彰现意。作已便没明现时分。既随胜解现则感谢应移。第十五善能开示下。明一切菩萨等所求智。即观察如来无量所依调伏有情加行功德。为欲引发任持不定种性声闻。菩萨唯赞大乘故次明之。言等所求者无不求故。佛地名为正所求智。谓唯菩萨正能求故。文中初明所求即一切智。此所求智即是无量菩萨所依。而言道者通因果也。为诸已下即成所依义。谓由无量菩萨。为欲调伏诸有情故。发起加行。要以佛增上力故。闻法为先获得妙智而为所依。令其发起广大欲乐者。即是调伏有情加行。受持修习者即成智之因。第十六成就一切下。明得佛无二住胜彼岸。即观察如来平等法身波罗蜜多。成满功德。为遮所化。于大师所疑一切智。非一切智故次明之。由满诸度是一切智。言无二者即平等也。平等有二。一法身平等。于法身中满诸度故。二果位诸度无增减。故名为平等。亲光则以住于法身。即是彼岸。不说诸度故云法身无差别相。名为无二。缘彼胜定常住其中。故名为住。即无二住名胜彼岸。佛已穷到故名为得。文中初满诸度故云炽盛。次无边下。以度满故庄严故身。故法华云。微妙净法身具相三十二。以八十种好用庄严法身。以十身圆融不相离故。言一切世间者不隔凡圣。靡不现睹。双睹受用变化之身。永离已下无二碍故和合识破相续心灭故。于一切下显现法身。智纯净故。于功德下诸度满故。第十七为大法王下。明不相间杂如来解脱妙智究竟。即观察如来随其胜解示现差别佛土功德。以外人闻上平等。谓同一性故。次说言不相间杂。谓一切如来十身体用各各别故。犹如冥室千光。但经云如来解脱。无著释云随其胜解。世亲无性皆云。此中胜解名为解脱。又胜解者通机及佛故。无性云。谓观众生胜解差别。现金银等土不相间杂。如来胜解现在前时。随众生乐皆悉显现。无不了知。名如来解脱等。亲光又为一释。即离障解脱故云如来妙智。令众生解脱。名如来解脱妙智。佛于此智已得究竟。观今经中诸论各得一意。复应加佛自得离障及作用解脱。谓文云离诸障翳故。具无边德故。令其入道故。明见善恶是如来胜解。其心所乐即众生胜解。是以不可偏取。下经但云具足如来平等解脱。在文分二。初明变化身土不杂。二明受用身土不杂。无著但云差别佛土。略举一边。亲光则双明身土。合今文意。今初变化中。先身后土。初中先总显化身超胜。次普现者。通十法界身放智慧光。合如日义。欲令已下彰所化意。能为多化。方显佛德无边所以。名不间杂者。以于一切世间普化。一佛既尔余何所化。故知所属不同。重重皆遍是不间杂义。后以无碍下。别化因圆果满之身。初明因圆。为大医下现果满身。二一切世下明现化土。初明非唯能化。亦能遍往。清净慧下明佛观机。即是如来胜解现前。于作不善下随机现土等。随诸众生。应以何国起调伏心。入佛智慧而取佛土。故云善取时宜。无适净秽。故云种种。欲该余化略无土言。义必含有。又对后平等但言不善。亦应合有有漏之善。二若诸众生下。现受用身土。先土后身已证真如。名平等心。睹受用土是平等报。上则心有高下。此则依于佛慧。后随其心乐下现受用身。故亲光云。于净佛土现受用身。亦不相杂。令其已下明现之益。亲光云。大集会中现种种身。与诸菩萨受用法乐。亦不相杂得智心喜等皆法乐也。又心大欢喜。即是初地见诸佛故生欢喜等。以证生信故名深重。以证不退故得永言。第十八一切众生下。明证无中边佛平等地。即观察如来三种佛身方处无分限功德。由疑上如来妙智究竟。非一非异其相云何。故次明此无中边等。常无常等皆二边相。言方处者。谓诸世界。无分限者释无中边。此无中边略有四义。一世界无中边。佛德如彼无有分限。二世界无边。诸佛十身。即于其中称世界量。平等遍满。三此法身等。于佛地中平等遍满。无中无边无有分限。四此法身等遍一切处。为诸众生现作饶益。然非自性无中无边。亲光复名此为真如相殊胜功德。谓真如相无有中边。如此真如。即是佛地平等法性。证此性故遍知一切。于中不染。今此文中总显十身皆无分限。文中分二。先别显四智十身。后无数下总结因果。今初先就觉他翻明自觉。成就法身。于中先明觉他。即妙观察智及成所作智之所利乐。若得见下彰其所益。无依义智即大圆镜。是无中边。佛平等地以无碍智身无所依故。则证真如为佛地性。转昔染依为智所依。即是如如及如如智。既令他证显自己证也。次智慧下二句。即妙观察智。庄严无夺。显圆镜智所现之影。智山清净即平等性智。平等高出所以名山。四惑已亡故云清净。因惑为种生必待时。今能生自在故种受芽称。或现已下。即平等性所现之影。兼显十身不唯此二故。复言或令诸众生至无患地者。即成佛地。以远离微细念故名为无患。后总结中初总明。谓十力四智等庄严法身。业行所成即是报佛现于世间。结他受用及变化身。总上诸义则有十身。一切已下总结异因同归一智。谓智导万行故。能证此佛平等地。若报若化无不清净。第十九常守本愿下。明极于法界。即观察如来穷生死际常现利益安乐一切有情功德。以上言无中边相。云何无相故次云极于法界。谓此法界最清净故。离诸戏论是法界相。能起等流利益之事。极此法界无有尽期。亲光亦名此德为证得果相殊胜功德。谓得穷极清净法界。如是法界修道得故。以斯则极法界言有于二义。一同法界常故。二同法界清净故。文中先明常利乐。二广利乐。今初常守本愿者。谓本发心法界生界。若有尽者我愿乃尽。今生界未穷故常现利乐。作善友者。世之善友略有七事。一遭苦不舍。二贫贱不轻。三密事相告。四递相覆藏。五难作能作。六难与能与。七难忍能忍。如来亦尔。为物随于六趣苦而不舍。贫无法财而不见轻。本性客尘无不相告。善根未熟则以权覆实。堪真实化则以实覆虚着弊垢衣执除粪器。为难作能作。解髻明珠为难与能与。生违佛化。乃至多劫心无退动。为难忍能忍无不究竟方名坚固。次清净已下明同法界清净。虽复常化。离能所相故名第一。次六趣下广多不舍。次若有已下不舍昔缘。次而于下通显不舍。若暂不随则舍本愿。如愿能作名不欺诳。次悉以下彰摄巧益。令同法界清净摧魔惑故。第二十从无碍际下显于二句。谓尽虚空性穷未来际即观察如来无尽等功德。谓上利乐皆无尽故。深密佛地具斯二句。开则别中自有二十一句。下离世间但云等虚空界而无穷未来际欲显圆数故。亲光亦云。次后二句显示世尊无尽功德。初句自利后句利他。故云。谓如虚空。经成坏劫性常无尽。如来一切真实功德亦复如是。如未来际无有尽期。利他功德亦复如是。而无著释但云无尽功德等。不言开合。世亲无性开此等字。为究竟功德故皆云等言。等取究竟功德则以无尽功德释初句。究竟功德释后句。而无性意。后句是究竟无尽。与前无尽异者。前则横论无尽。故云尽一切界遍作有情诸饶益事。后句则竖显无尽。故云显佛功德永无穷尽。所化有情永无尽故。同显无尽故。二句合自他等异。二句则开。今文意合。欲显二利不相离故。穷未来际。通在极于法界及尽虚空故。前段中已显常随不舍。为顺二论文分为两。初唯横论无尽。正明尽虚空性。二为上福田下。双约横竖以显无尽。兼明穷未来际。今初先二句。总言无碍际者。即法身智身如彼虚空。无有障碍。无边无际无尽无减。无生无灭无有变易。名无碍际。而能现前作诸利乐。如彼虚空容受质碍。故云出广大力。次最胜日下别显依空无碍之用。略举一日而有四德。一蕴藏千光。二百川现影。三有目皆睹。四生成万差名种种施。上一段文言含法喻。佛是已下唯就法说。初光明藏。即上日藏身智光明。含摄出生故。诸力已下如日无缺。恒以大下。如日舒光。离诸魔敌降老死怨。如日大明众景夺耀不独合上故。文有影略。二双约横竖论无尽者。但云一切。通于十方及来际故。文中先明为生福智之田。上福田者具前德故。凡所有下释上田义。三义名上。一令清净如无荒秽。二因少果多。如涅槃说纯陀施福。三入无尽智。如田随种随生。如谷展转无尽。成金刚种终不销故。具斯三义称曰上田。次为一切下显为田主。次为一切众生发生下。明体即是田。后智慧下明能为田义。具悲智故。初权实无二总为一智。对下能救。悲智无碍合为一心。则是如来最清净觉。上所引功德之名全依无著。其所解释多依无性。有不同者亦已对决。与世间品小有同异大旨无违。至下品中当更显示。依上所释文旨有据德相可分。若列宿罗空粲然不杂。岂得宽文广申辞句。于佛胜德蔑然略陈。幸诸后学不咎其繁而不要也。第三如是下结成观解。谓前诸德。不出内德及与外相。今初二句总明能观。信解约于仰推。观察通于诸眼。后之八句。就所显德以辨能观。前四内德后四外相。前中谓佛内德无量不出福智。前二福智之体智慧之渊。略语其深。功德之海义兼深广。渊宜趣入海宜游涉。次二句福智之用。智广虚空福无不益。称此而了名普至知。后四外相中。初一句重举能观。拣内外故。言正念者明非散心。了佛德相唯心无性。静而能鉴复云观察。后三句。亦就所观以辨能观。初一句总后二句别。身云普现即是相好。神通自在即前业用。前二十一德中。或一句之内言兼福智。一德之内体用双明。若别配属义成偏近。第二时彼大众下明见佛光用。前虽有用。乃观如来常所具德。今现目睹故不同也。文中三初睹常光。二睹放光。三显光意。今初虽云毛出意取常出。有十一句。初总余别。前三光相后七光益。二尔时下睹放光中。先举体相后以佛下。辨光业用。文有五现。一说法。二现严。此二皆先现后因。三现佛则先现后意。令成教证二甚深故。四现神变。五现宝焰光皆先现后因。第三为显下现光意并显可知。第二尔时如来下。明现胜德之意。文分二别。先牒前现德。悲为能现智为所现者。影略其文。应以依二严体现二严德。二欲令下正明现意。分二。先明下益众生。二开示如来下明上弘佛道。今初分二。先彰现益。后世尊下辨现益之因。今初先举所益。后未信下辨益不同。然此益中文含多势。且依一判先约行布。初五十信。始自初信令心调伏。信位满故。次观下七句皆十住益。谓初二句是住中观慧。次二句下化上求之心。后三句住中证入。知心自性。故曰不违。不退二乘故。不怖实际不由他悟。是证实理。圆教十住许入证故。三满足下三句十行益。初句位中之行。后二句位中之德。四离魔下三句十向益。初句起行一向利他。离二乘等魔回向菩提故入佛境。次句得法随相离相无碍难思。后句行成。五常见诸下尽明十地。初四句皆欢喜地。一见受用身故称曰常。二根本证真。后得证无量法。又证遍行真如亦名无量。三则僧祇积福证理出生。名福藏力。四发欢喜心。是此位名入见道。故名无疑地。离恶清净是第二地。依一切智见法不动。是三四地。得入一切菩萨众会。是五六七地。常生佛家八地已上。念无有间故曰常生。若约圆融。初之五句信中摄位。句各一位如理思之。从观甚深下义通诸位。以圆教中位位摄德故。二辨现因。既积善所成故。为益深大。为欲调伏诸众生故一句。文含二势。一结前谓结因所属。二生后。生后开示亦是为生。第二明上弘佛道中分二。先别彰所为。二自在已下举因结叹。前中有十七句。为欲显前二十一种殊胜功德。初句为总余皆是别。于中前五各摄二德。余句各一。第一照明无碍智慧藏句。显二德者。一显不二现行故云无碍。无二碍故。二显趣无相法故。云照智慧藏。慧为能照藏即所照。无相真如照明趣达眼目殊称。第二句。一显住于佛住。谓住空大悲任运利乐无休息时。名曰炽然。二显逮得一切佛平等住。谓依清净智起利乐意。作二身业皆炽然故。第三句一显到无障处。二显不可转法。谓此二是降魔伏外功德。前由有对治则不为他动。今由有神变乃能转他。第四句。一为显所行无碍。今遍趣现身即是所行有漏。尽通八风不染。又神通力即能遍因。二显其所安立不可思议。谓佛威神所建立故。第五句。初显游于三世平等法性。约记三世事。亦是神通无边际言。即平等性。二显其身流布一切世间。此言甚显。下皆各摄一德。六显于一切法智无疑滞。本愿已满故。七显于一切行成最正觉。名智遍往。八显于诸法智无有疑惑。名于法自在。九显一切菩萨等所求智。十显凡所现身不可分别。十一为显得佛无二住胜彼岸。彼岸已圆十身殊妙故。十二显不相间杂如来解脱妙智。究竟功德。又诸佛平等皆遍而不相杂故。十三显证无中边佛平等地。平等之地即清净藏。十四显极同法界。故云上妙。十五有十力故能尽虚空。见者无厌。十六穷未来际故照三世。第二举因结叹。前举积因后叹无尽。第六尔时兜率下。天王请佛处殿。亦称五号并曰善来。及下文意皆如第三会说。第七尔时世尊下。如来受请分二。先受请入殿。二尔时一切下入已现严。前中先明此界后辨结通。前中初一句明能应之德。次明所为之意。三正受请并显可知。第二现严显是佛力故。出过诸天。第八时兜率宫下。天王获益。文中初得定益。往昔已下是进善益。佛神力言通此二益。十住位劣摄散归静。故乐音止息。此位超胜得动实性故。动寂无二。炽然音乐心不动也。第九尔时下承力偈赞。然忆念昔因亦是益相取文便故为说偈依。文中二。先明此处偈赞。后结通十方。前中先说偈所依。后正陈偈赞。十颂颂各一佛佛名有异。略无别德余同前会。此佛即前会十佛。次前十佛寄位渐深。忆念渐远耳。第十尔时世尊下如来就座。文分四别。一明就座。二法身下显德亦大。同前二十一德。恐厌繁文不能具释。三不可说下。众集即眷属圆满。然后品众集有所表故。但云一万。理实遍集故此但云不可说众。未必但是后品之人。四坐此座下现严。初此界后结通。有云。此升座一段。宜置入殿之后。叹处之前。回文不晓者未必然也。谓初请入殿赞为请坐于理何违

    兜率宫中偈赞品第二十四(已下入第二十三经)

初来意者前明化主赴感。今明助化赞扬。及显位体所依故次来也。二释名者。谓十方菩萨于此宫中赞佛实德故受斯名。通二种释如第三会。三宗趣者。集众放光偈赞为宗。为说回向为趣。四释文亦三。初集众二放光三偈赞。初中二。先明集因谓佛神力。二十方下众集。于中文二。先明此会。后如此世界下结通。今初长分十段。一总举上首。二眷属数。三来处远近。位增数增故各一万。四主菩萨。名同名幢者略有五义。一高出义。表三贤位极故。二建立义大悲大智建立众生及菩提故。三归向义。谓大悲摄生智愿摄善。归向菩提及实际故。四摧殄义。如猛将幢降伏一切诸魔军故。五灭怖畏义。如帝释幢不怖惑业故。异名即表十向行体。至偈当明。五所从来刹皆称妙者。回向之力微善弥于法界故。其别名即表十向所修法门。一救护众生离众生相。最可贵故。二得不坏信常乐因故。三等佛白净故。四如金遍至诸色像故。五出用无尽如摩尼故。六善根坚固如金刚故。七随顺众生不染尘故。八真如之因如水生华最为胜故。九如白栴檀。能去热恼之缚着故。十如彼香气能普周故。故下文慈氏座前烧一丸香弥满法界。即其事也。六本所事佛同名幢。义不异菩萨。别名即表修十向智。亦表当位之果。谓一救护之心不可尽。故成无尽佛。二如空中风不住不坏故。三等佛解脱故。四四威仪中无不至故。五明了功德相故。六常能随顺善根故。七随顺众生善最胜故。八同于真如得自在故。九净无垢染不缚着故。十观察即是入法界故。七其诸已下至已修敬。八以佛神力下。善住威仪。座体云妙宝者。十住以慧光遍照故。以毗卢遮那藏为体。十行以行净离垢故。以摩尼藏为体。今十向大悲处于生死。普该万法不拘乎一故。座体直云妙宝。不限色类。以教行遍周笼摄众生。如以宝网弥覆其上。九其身悉放下放光利物。此位多辨悲智救物故。复辨此于中。初光体。次此无量下辨光因。即圆净回向心。后显示下略示光业。一智敬上业。二悲救下业。十其菩萨众下略赞胜德。有十一句。初总余别。别中十门。一神通门。二入证门。三以智下依智修福。四入于下上入果用。五住于下住善决择。六于诸下四辨无尽。七智开总持。八慧眼见性。九智慧遍知。十究竟离障。结通可知。第二尔时世尊下。放光文分四别。一放光处。言膝轮者位渐高故。又表回因向果等。有屈申进趣之相故。又悲智相导屈申无住故。二放百千下光数。三普照下光照分齐。四彼诸下光所作业。谓令彼此互相见故。于中分三。初正明彼此相见。二如是下释见所由。三如是等下结德所属。二中由二因故见。一宿因同行故。二悉已下现德圆满故。文有二十句。束为十对。一离障成身对。二入刹近佛对。三用速心净对。四外护内证对。五能觉所觉对。谓一切智处是所觉故。六用广证深对。身即智身同住法界及大悲故。七得智生身对。身即应身。八行深解广对。九智极定深对。此位中显名金刚幢对。金刚定即菩提智。十得通立法对。由得通故调化无数。由离数故而能安立。数有二种。一数量数。二色心有为皆名为数。今文具二。谓由不着一多能立一切故。不着于有能安立故。即真俗镕融。谓世俗幻有之相。相本自空胜义真空之理理常自有。有是空有非常有。斯有未曾不空。空是有空非断空。此空何尝不有。有空空有体一名殊。名殊故真俗互乖。迢然不杂。体一故空有相顺。冥然不二。一与不一不即不离。镕融无碍。菩萨智契其源。所以虽迥绝无寄而善修安立。三结德所属。谓无尽德属于此会菩萨。及光中所见也。第三偈赞中。十菩萨即为十段。亦十方如次。皆先标说人及说仪式。今初东方金刚幢者。此是会主名含总别。总显回向不出悲智。金刚者坚利也。即悲之智。二乘实际不能坏坚也。断难断惑利也。故文云智慧到彼岸。即智之悲爱见不能动坚也。无所不救利也。故文中遍刹利生。七十八云。譬如金刚唯从金刚处及金处生。非余宝处生。菩提心金刚亦复如是。唯从大悲救护众生。金刚处一切智智殊胜境界金处而生。非余众生善根处生。故知金刚不独喻智。攻般若者不得此意。但以标名独将金刚喻于般若。不观文中悲济九类而无所度。悲智相导方为真实不共般若。智者应知。别名即是救护众生悲也。离众生相智也。义不殊总。说颂仪式频见上文。正显颂文。十颂叹佛寂用无碍德。大分为二。初八赞佛胜德。后二结劝修行。今初分三。初五偈寂而常用。次一偈用而常寂。后二无碍自在。今初分三。初二偈无生灭而示生灭。于中前偈就法正显。后偈寄对显深。以依体起用体用无碍。故难思议。又心有心相动不能行。故难思议。智无智相名到彼岸。方见佛境。次二偈非色声而现色声。亦前偈就法正显。后偈寄对显深。少智谓权小。久修谓圆机。素习见闻故能了实。后一颂明无来去而示来去。觉处即现不从方来。迷处自无不从此去。以神力故示有来去。然从神力中来即无来矣。二用常寂中。三句用末句寂。三无碍自在中。初偈了事理无碍起用自在。后偈了生法无碍起用自在可知。后二偈结劝中。初偈劝修智进行。后偈劝修福断疑。第二南方坚固者。表不坏回向故。菩提心坚故。观佛无厌故。十颂多明如来为物所依德。于中分二。初三赞佛胜德。后七劝修辨益。前中初颂明佛体离言。次偈无相现相。后偈现相所因。后七中举修有益。即显佛德深玄。文中分三。初偈指德劝依。即结前生后。次三示能入者令物思齐。各先举行后彰行益。后三正劝进修。然夫进修略有五法。谓欲精进念巧慧一心。初偈明欲次偈辨念。后偈巧慧。前二正明后一反显。一心精进摄在志求之中。又慈氏论引醍醐喻经共说九善。谓一切法欲为根本。作意所生触所集起。受所引摄以念为主。定为上首慧为最胜。解脱为坚固出离为后边。有前未必有后。有后定须有前。是故先说欲为其本。下二句。拣非恶欲为胜希望。次偈上半念主下半作意。后偈反释初句慧胜。次句触集及受。次句定及解脱。后句出离。第三西方菩萨。净心智力见佛尽源。等一切佛。故名勇猛。十颂分二。前六明感应道交见佛闻法。后四令舍伪求真。拂见闻相故。此一段总显如来见闻弘益之德。前中前五各上半喻。下半合。通分为二。初二见佛后四闻法。前中初偈双明感应。净心如净眼为见之因。佛力如日为见之缘。如来如色为见之境。如人入闇则无所见。斯则独因不见也。如明净日瞽者莫见。独缘不见也。此辨因缘和合方能见也。后偈偏举于感。以因夺缘。如出现品云。此非如来威神之力等。后闻法中四偈分三。初偈显因能生法。次二显得法之益。前偈得权智能离所知心垢。后偈有根本智。能除烦恼之患。三一偈显缘令闻法故。上文云。佛法无人说虽慧莫能了。后四令舍伪求真中二。前一示伪令舍住相施故。以色见佛行邪道故。后三显真令求。初二偈显真佛。前偈即相非相故非色能见。后偈即寂而应故不可以寂取。末偈显真法。真法无生亦无灭故。第四北方菩萨。以大悲力运智慧光。朗彼重昏无所不至。名光明幢。又以智慧令诸善根无所不至故。此颂中。多显如来即体化用周普之德。十颂分三。初一化用广。亦明化处。次七化用深。亦明化依。后二双结释化依中分四。初四双明能所依。次一拂其能化心。次一拂其所依体。后一双融自在。亦拂能依。今初初偈总明一多无碍。依一总心变多王所。于一实佛应化多端。故无碍也。次一相二无碍。无相现相无二现二。体绝能所故云无二。相依身有是即二也。然相二相对应成四句略举其一。无二现二即于一现多。乃至百千亦名二故。次偈显依性起。起不异性故。如幻无尽。后偈从法身流。举三世佛以显道同。二拂能化心中。谓如摩尼珠无私成事故。三一偈拂所依。谓上无二无相法性法身。即是法界。法界本自无差。亦无定有为化依止由无依无别故为依为别故。下文云。虚空虽无所依能令三千世界而得安住。如空无色而能显现一切诸色。四一偈双融自在。言非非化者。此有二义。一假非化以遣化。非谓是非化则上半约体绝待。下半依体起用。二不碍化故。然真化无二融为一身。不坏体用名依真起。依真起者则报亦依真。非谓三身独一是化。且依真起化略有二门。一开义二融合。初中真应各有二义。真中一不变义。谓虽化而常湛然。初句显之。二随缘义。谓不守自性无不现故。故云亦复非非化。二约化中。一无体即空义。谓揽缘无性故云于无化法中。二从缘幻有义。故云示有变化形。二融合中亦二义。一真化别合。二真化融通。初中由真中随缘即不变故。是故亦真亦非真。非真非不真名真法身。化中体空即幻有故。是故亦化亦非化。非化非不化名为佛化身。二融通者。谓由真不变显化体空。此真不无化不有。以为法身。而不无化用以有化中空义故。又由真随缘显化幻有。此是化不无真不有。以为化身。而不无真理。以有真中随缘义故。又由随缘幻有。不异不变体空故。是故现化纷然。未尝不寂。真性湛然未曾不化。真化镕融为一无碍清净法界宜审思之。第三二偈双结释中。前偈结归于体。谓智冥真境等法界故。深无底等虚空故。广无涯皆绝言道为不可量。后偈举因释成。所以法界无碍者。智行遍故。第五东北方。于佛寂用之境决断无碍故。又智导万行出生无尽故。名智幢故。颂中多叹如来应现出生无尽无碍之德。十颂分二。初一标章劝信。信有修行之益。后九所信胜德。于中分二。初一总余八别。总中上半用而无尽。下半寂而无住。不着应处不住法体。即本末双寂也。通为寂用无碍。别中二。初二明无尽。一一众生前能现无尽身故。众生可知。佛不可数。后六明无碍。于中三。初四一异无碍。亦是本末无碍。一法。二喻。三合。四释。次一偈延促无碍。后一偈性相无碍。第六东南方菩萨。以圆净智照平等理。不碍应现。随顺一切如摩尼宝。故名宝幢。颂中多显平等超世之德。十颂分二。前五总显难思。后五迥超时数。前中初二正明。前一超量现量。后一超处遍处故。出现品云。譬如虚空遍至一切色非色处等。如是难思双结上二。后三展转释成。初云何以难思。若身若处非生灭心行之境故。何以非心境。佛自不起心故。何以不起体无生灭故。若尔何以现见。次偈释云。病眼所睹。取色分齐勿谓为实。次疑云。若尔岂无如来出现世耶。次偈释云自机见耳。上三句以应就感。众生谓出。末句既因物感出即非出。名实不出故。诸法无行经云。如来不出世。亦不度众生。众生强分别作佛度众生。既无有出安有没耶。上三亦初一超心行。次一超内外。后一超出没。后五偈迥超时数而现时数于中初一偈结前标。后国土结前处故。后四别显超时。初偈立宗。上半牒妄情。下半正立菩提是有法。定不系时是宗法。次偈立三因。一智无分别故。二三世不迁故。三体非有为之数故。次偈举同喻。谓日体常明故不合昏夜。后偈合结。上半合下半结。合中语倒。若顺应云一切诸如来不与三世合。又若以超时现时为宗者。则上宗中四句皆宗。应云菩提是有法。定不系日随机说日是宗法。因云。体非三世等。不碍三世等故。同喻云。如日轮不合昏夜。以山映故说有日夜。合云佛无三世。以不应见机之所映。故而说三世。是则上三句皆合。下一句结。第七西南方。勤观如来真应皆同故。能平等随顺一切众生。名精进幢。十颂显此同义。文分为二。初一总标余九别释。前中上半正标。下半略显同相。言身同者。三身十身皆悉同故。义亦然者此含多意。一且约三身体依聚义。无不同故。所觉能觉觉他同故。又义名所以。所以得名佛者。正觉真智力无畏等。无不具故。得名为佛。佛佛皆然故义同也。又应用利乐无不同故。故摄论第十云。诸佛法身。应知恒时能作五业等。二十一种功德之中。名为逮得一切佛平等性。所依意乐作业无差别故。二约十身释义同者。皆通三世间。彼此互望无差别故。种种利乐居然是同。此有三因。一行海齐满。二大愿齐具。三同一法性故。非唯相似。亦一即一切互相融故。余如问明品说下平同相略举应用同。以应即真故。非应之外别明法身是同。然普有二义。一约诸佛。谓无有佛不遍十方故。二约一佛。谓无一方而不现故。后九别释中分二。先四颂正释。后五颂转释。前中初偈。释前普于十力无余二义。一无处不遍故。二一切皆佛身故。诸佛本师二颂影略。次偈释前现义。谓有感方现故。云非内神力能现故云非外。次偈释前随应种种义。一随物类。则十法界等万类殊应。二于一类中。随其先业各见不同。如金色涂灰等。后偈释前身同之义。结成难思。佛身皆同无数量故。唯除大觉者佛佛同证故。后五转释中。从后向前释上四偈。前四兼喻后一唯法。于中初二释第四无能思义。一以我为喻。谓如妄计之我本无所有故。不可思。此以妄计情有理无。非圣智境。以况法身理有情无。非下位测。后偈以刹为喻。喻虽绝相难思而不碍相。次一偈释第三随业异现。所以要随业者。同一切法必假缘故。此以总喻别。次一偈释第二非内外义。如珠现物。虽非内外能满物心。后偈释充满法界义。所以能满者。本愿普周故。第八西北方菩萨。真如体净能成白法。复净世间故名离垢。十颂多叹如来净德。前六净他后四自净。前中前二总明。后四别释。今初前偈智净妄惑既寂。真智不无。开示无我知见性相。故名为法。后偈身净谓拂应显真。后别释中前二释第二偈。后二释初偈。前中初偈。正明欲见诸佛应专佛境。随念随现故名心等。又了心境即佛真性。迷则不知念则便现。次偈转释专念之义。无漏具德故能专念。后二中前偈释普净世间。说法现身而能净故。后偈释开示佛法。示其所悟二无我故。后四自净中初一已净差别之用。后三内净三德。一见性成佛。自开法身称性现应。次偈无得成佛。自开般若。佛法所觉菩提能觉。必能所相因故俱叵得。无所得者则得菩提。后偈离妄成佛。自开解脱。不动无住故。妄倒斯寂名真解脱。第九下方菩萨。解佛遍应法界之身而不离法性。若彼星宿粲然罗空不可缚着。故以为名十颂。显佛此德分为三别。初三总显即体之应。次六别释体应自在。后一拂去自在之迹。前中初偈约处显身之遍。谓法性身则无所住。约自受用则无所不住。名为普住。约他受用及变化身。有感则往故云一切土皆往。若约十身无处非佛。故云一切处咸见。次偈约机显身之多。故云一切。及八相事皆由物感。后偈结叹难思。初句总标。下三句显相。二句约感不能思。思惟约心见通心眼。下句约应难思。云谁能现。次六别释中。初三顺释。后三反释今初。初偈释前谁能现义。谓现即同如无生灭故。次偈释前谁能思义。谓起心而思是妄分别。有依有正。法性之中能所斯寂。后偈释前谁能见义。谓能应随缘体本自无。能感之机竟何所见。后三反释中。谓由无思见等方能思等。则反显前有思见等。不了佛境。于中初偈无思思。要无著无碍故。次偈无现现。神力之现体即虚故。后偈明无见见。蹑前无所有为见。则称实之见非唯见佛。亦得疾成。三一偈拂自在之迹者。上明自在尚假言诠。正觉超言故拂言迹。超言亦假应忘言契之。第十上方菩萨。知真实之法普入法界。则所修行皆无分量。故名法幢。知法名佛故。先赞见佛之益。十颂双显佛法难闻。于中分二。前四赞佛劝人闻见。后六赞法劝物闻求。前中初一正令甘苦近佛。后三释其所以。略举三事。初偈闻名益。次偈发心益。后偈生信益。既受苦得闻成斯胜益。受乐不睹不免长沦故。应甘苦而近佛也。后六中已遇良医复须法药。于中初二由闻实法能成行法。前反后顺。次二由闻理智成于果法。前顺后反。后二以感应释成。前偈佛兴由生迷实。后偈说法示于真实。不动真际建立诸法。则性不可坏。不坏假名而说实相。则相不可坏。斯则天魔外道等皆法印故。无能坏。余如十藏品。上十菩萨之偈应以六相圆融。所以偈后无结通者。为显法界兜率赞德异故。犹彼处处文殊偈偈各别。显佛德无尽故

大方广佛华严经疏卷第二十五大方广佛华严经疏卷第二十六

        唐清凉山大华严寺沙门澄观撰

    十回向品第二十五

初来意者。当会序分已彰。正宗宜显故。又已总示所依佛智。次别显能依行位。故次来也。二释名者。回者转也向者趣也。转自万行趣向三处。故名回向。回向不同有其十种。然十之别名本分当释。回向通称今当重明随境所向义有众多。以义通收不出三处。谓众生菩提及以实际。上二皆随相。实际即离相。开三为十。一回自向他故。初回向云。若有善根。不欲饶益一切众生。不名回向。二回少向多故。下文云。善根虽少普摄众生。以欢喜心广大回向。又云。随一善根普以众生而为所缘。乃名回向。三回自因行向他因行故。第三回向云。菩萨以诸善根回向佛已。复即以此善根。回向一切菩萨。所谓愿未满者。令得愿满。心未净者令得清净。四回因向果。此复二种。一向自果。下文云。修诸善根回向阿耨菩提故。深密瑜伽梁摄论等。大同此说。二回向他果。第三回向云。愿以我今所种善根。令诸佛乐转更增胜故。五回劣向胜。谓随喜凡夫二乘之福。回向无上菩提故。六回比向证经文非一。七回事向理故不坏回向。云与诸法性相应。回向入无作法。成所作回向。第六回向云。永离依处到于彼岸。故名回向。永绝所作至于彼岸。故名回向。八回差别行向圆融行故。如第九回向广说。九回世向出世故。下文云。所有善根皆悉随顺出世间法。教化成熟一切众生。心常回向出世之道。第六回向云。永出诸蕴到于彼岸。故名回向等。十回顺理事行。向理所成事故。广如第八回向所说。前十义中。初三皆回向众生。次三皆回向菩提。次二回向实际。后二义通于果及与实际。若依总云十回向。即带数释。若准梵本晋经皆云金刚幢菩萨十回向品。则人法双举。或人之法法之人。人有法通二释也。三宗趣者。以无边行海。顺无尽大愿为宗。成就普贤法界德用为趣。四释文者文有十分。一三昧分。二加分。三起分。四本分。五说分。六瑞应分。七结通分。八证成分。九偈赞劝修分。十校量功德分。初中金刚幢入者是众首故。表归向高出等义故。不异名说。承佛神力彰入定缘。入菩萨智光三昧者。显所入名拣异果定。故云菩萨智即是体。谓根本智。光有三义。一是证智前相。如明得定等。此约寄位在贤终故。二光即根本智用。对治无明故。如大乘光明定等。三光即后得了所缘故。二智无碍朗照法界。此约刚幢自体释也。第二入是下加分有三。一总显能加。二辨加所为。三正显加相。今初有二。一明佛现。二明赞善。今初有五。一标所因。谓入是三昧已故。十住中云以三昧力。二十方下佛来近远。三有十下佛数多少。上二显位过行故。云十万。四皆同下显佛名同。五而现下正明佛至。余如前说。二咸称赞下明佛赞善。于中初标称善。次别叹得定。后显得定所因。先别显五因。一伴佛神力。二主佛宿愿。三主佛现威。四说者智净。五听者善根。十住无听者善根。十行缺说者自力。此则具二理应遍具。而影略者。表住初自悟。行则舍己利他。今则悲兼自他俱无障碍故也。所以要此五力者。因果主伴皆具足故。谓法因久远愿遂将化故。主伴加威非器不传。明因主自力。非感不应显因伴善根。余之差当如第三会。后令汝下结前生后。第二为令下辨加所为。有二十二句分二。前二十一别明所为。后一结为所属。前中初十标所成。后十一明所作。亦犹十地前十自利后十利他。前中初九内德。后一外加。谓得佛护持信等根故。前中前八横具诸德。后一竖继不断。从前所成明记决断故。前中前七法体。后一大用。佛神力者。非神境通。离世间品。神力神通义有异故。通谓无拥力谓干能。通多就外力多约内。就前七中前六别明。后一总说。谓一门之中具于多门。总摄福智重重无尽。名普门法界故。就前六中前五所具。后一离过。谓所具福智不与二碍有漏相应故。前五中前四智慧后一福德。就智慧中前三自分。后一胜进住佛智故。就自分中前二说教。后一入证。谓入缘起法界相。即自在智故。前中无畏则于缘无惧。辩才常说不断。上来从后襵叠已释所成。二以无量下明其所作。于中初一总谓广说故。后十别。于中初一约法。次三约位。一摄地前。二安地上。三照佛果。次三约修。一令开发十向大愿。二令解实际。三令知回向广大与法界等。后三约人。一称根令喜。二喜故学三世佛回向。三救护一切众生故。不断佛种。后一总结所属者。谓若说十向前益皆成故。加所为即说所为。六相融摄如理应思。然约行布地约说地。此为回向故与下不同。况彼义皆次第。今复反此。第三佛子下正显加相。于中三。初语业劝说以增辩。二意业冥加以益智。三身业摩顶以增威。今初口加承语便故。文有十句。初总余别。总云说此法者有二种力。一者他力。如经得佛护念故。此亦名果力。亦名增上缘力。二者自力。即下八句亦名因位力。亦是因缘力。是故此法要自他因果亲疏融合方得。有说。自力八中。初三明有作净法力。一总谓既住佛家理宜宣法以行家业下二别。一长无漏功德。二入总持智慧故在佛家。次二句无作净法力。一离所净障。谓无二障碍。二得所净智谓事理普照。后三显身净力即三种尽。一二乘不同尽。谓双集悲智离于舍悲入寂过失故。二菩萨尽。谓离心意识。唯依大智法身境故。三者佛尽。无障碍智是佛法故。此是地前有三尽者。一圆教普贤位融摄故。二约金刚幢内德位已极故。又前加所为中。住行但有十句。正口加中唯有一句。今并过前者表位增故。邻于地故。多同地经。二尔时下意加中二。先正明加相。二何以下释偏加所以。前中十句初总余别。然此十句大同地经。唯五六前却余如彼次。后别中。一不着辩才。说法不断无留碍故。二堪辩才。以善净堪智有四种。谓缘法作成故云分别句义。三任放辩才。说不待次言辞不断处处随意有忘名义故。云无碍法光忘不随意则有碍故。四即第五不杂辩才。三种同智常现在前者。慧身平等知三相故。故彼云与遍至一切处智。五即第四能说辩才有净音故。六教出辩才。静鉴双流故。七不畏辩才。智不可坏何有畏哉。或六七前却思之。八即无量辩才。谓一切法智随顺宣说修多罗等六种正见故。九即同化辩才。得一切佛无畏身等。三种教化随所度者。显示殊胜三业神变化故。次释偏加。及尔时下身加。并第三金刚幢下起分。并如前后说。第四告诸菩萨下。本分中分二。先总显体相。后佛子菩萨摩诃萨回向有几下。别示名相。今初。若直就经文应分为三。初句总标愿体难思。希求名愿。即具摄普贤无尽愿海深广难思。二充满下显难思相。谓体充法界故难思议。用普救护故称为大。又约体深不思议。约用广不思议又深广无碍名不思议。又体相用三并充法界。随所遍处无不救护。实难思议。三所谓下释成难思。以行同佛故。然总论品内一一难思。别示其相略申十种。一体深。二用广如上已辨。三摄德无尽。四出生众行。五余不能坏。此三充满法界中摄。六都不自为。七忍苦无倦。八背恩不转。九逆顺多端。十尽穷来际。此五普能救护中摄。此之十句一一超于言念。皆不思议。故收前后有三种体。一所依体即智光三昧。二约克性即上大愿。三约总含通有六法。一定。二智。三愿。四悲。五所依法界。六通慧作用。即不思议解脱以为体性。而圆融无碍为回向体。若取论势。亦初句是总。下三句别。一充满法界即是胜愿。以是一切佛根本故。二普救一切即是大愿。顺作利益故。三所谓学佛回向。是不怯弱愿。决定入佛大愿故。亦未入地故。无观相及真实愿。大悲增故加前行住大愿利益。而住行中有无常爱果因。今此缺者。大悲既增惟愿救护。不欲自求菩提果故。第二别示名相。文分四别。一举名征数。二佛子下标数显胜。诸佛共说故。三何等下征数列名。四佛子是为下。结数引证。三中先征后列。十回向义略以五门分别。一释名。二义相。三体性。四定位。五行法差别。初中先总名已见品初。后别名今当略释。然通相而辨有其二意。一回向二字。皆是能回之愿。救护等名皆是所回之行。故皆依主受名。二救护等名。皆回向之别相。回向二字皆别相之通名。当名相望。救护等即回向。若互相拣是救护之回向。非不坏之回向。则通依主。随其义便不可局定。第一救护等者。大悲广济名为救护一切众生。大智无著故云离众生相。即是广大不颠倒心。回向是行。谓以善根回成救生离相之行故名回向。从所向立名。故下文云。愿此善根。普能饶益一切众生。明知救护非是所回。自以十度为所回向耳。又唯以离众生相为能回者。则回向中无随相也。将坠者护已坠者救。救令脱苦护令息恶。并以善根愿能成此。二于三宝等得不坏信。以此善根用将回向三学三世佛所作回向名等诸佛。四菩萨令其善根至一切处。五由回向故。能成无尽功德之藏。六顺理修善事理无违入于平等。七以善根等心顺益众生。八善根合如以成回向。九不为相缚不于见着。作用自在故名解脱。如不思议解脱等。十称性起用。谓以法界善根回向法界故。至随文中当更开显。第二显义相者。先别后通。别中前七随事行。后三称理行。前中初一悲智不住明行本。次四明行相。于中一者起行心坚。二约佛辨广。三约法显遍。四约德显多。下二行成。一智行成。二悲行成。后三中。一正与理合显体深广。二明依体起无方大用。三显体用无碍圆明自在。二通。论一一中皆有三种回向。谓以善根回向众生菩提实际。此三各有二义故成回向。一以菩萨善根必由众生而成。是众生之分故还向彼。由余二成余二流故。菩提分故。称实除故法尔向彼。二凡是菩萨必为度生不尔同二乘故。必求无上菩提是家法故不尔同凡小故。必证实际背无明故。照二空故。所以要须三者。义乃无边。略申十意。谓依三法故。灭三道故。净三聚戒显三佛性。成三宝会三身。具三德得三菩提。证三涅槃安住三种秘密藏故。一依三法者。谓真性观照及与资成。即起信论体相用也。实际依体。菩提依相。众生依用。二灭三道者。见苦实际方能灭苦。照烦恼空即得菩提。回结缚业为利生业。三净三聚者。谓向实际故律仪离过。向菩提故广摄众善。向众生者即是摄生也。四显三佛性者。实际正因。菩提了因。向众生者即是缘因。五成三宝者。实际成法。菩提成佛。向彼众生成同体僧。六会三身者。谓法报化。七具三德。谓断智恩。八得三菩提。谓实相菩提实智菩提方便菩提。菩提树下示成佛故。九证三涅槃者。谓性净涅槃。圆净涅槃。方便净涅槃。谓薪尽火灭。若依地论。唯有上二者。则真极之成宁殊示灭。菩提亦尔。上四皆如次。配回向实际菩提众生。可以意得。十安住三种秘密藏者。由向实际则住法身。佛以法为身清净如虚空故。由向菩提能成般若。菩提朗鉴居极照故。由向众生能成解脱。自既无累令他解脱。随机应现亦无碍解脱也。以斯十义立三回向。若立三种菩提之心。亦依此十。又此十内。举一为首展转相由。又此三者。成二行故向实自利向生利他。菩提通二。又向实护烦恼。向生护小乘。菩提通二护。又为成悲智。智照理事故有三也。又随举悲智亦具此三。悲中三者。令彼众生知其实际。同证菩提故。智中三者。照生相尽即同实际证菩提故。又此三者其必相资。一即具三方成其一。一为证实际故回向众生。以化众生成其自利。断障证实故。亦向菩提速证菩提。具一切智断于二障。方穷实故。二为救众生故回向实际。速证实际。于惑自在方能化故。故净名云。若自有缚能解彼缚。无有是处。亦向菩提速证菩提方能广利故。地经云。欲度众生不离无障碍解脱智。三为得菩提故回向众生。不化众生不证果故亦向实际。不证实际岂得菩提。故此三事相资成立。非唯三事自互相资。随一一事具摄法界德用。即入无碍方名真实回向三事。第三体性者。有总有别总如前说。谓大愿等别在说分。随位显之。第四定位者。若约资粮等五诸说不同。一云。此回向位。是修大乘顺解脱分资粮位。终从十信来皆资粮故。十回向后别立加行故。庄严论说。行尽一僧祇长养信令增上。增上修达分善根。又成唯识第九云。初无数劫福智资粮顺解脱分既圆满。已为入见道住唯识性。复修加行。杂集十一亦同此说。有云。此十回向是加行位。复有二说。一云。四顺决择分中。是后二摄。谓十解为暖。十行为顶。前九回向为忍。第十回向为世第一法。成唯识云。此四善根亦胜解行摄。此文为证虽不分明。玄奘三藏意存此释。一云。四加行中世第一摄故。真谛翻摄大乘云。如须陀洹道前有四方便。菩萨亦尔。有四方便。谓四十心。若依此释则无五位。地前四十心皆加行故。余约四位十三住等。并如十住品明。上来多是大乘初门。接引二乘拟议彼立四善根故。有说三贤总为趣圣方便。不分资粮加行远近。此据终说。有言。一切行位都不可说。此约顿显真性而说。若依当部。一位之中顿摄诸位不碍前后。而位满处即是因圆。约圆教说然与前教相参应成四句。一唯约相如前诸教。二唯约自体如前顿说。三以体从相。四以性融相。此二即当今文。谓以性随相性不差而位历然以性融相相不坏而常相即故。下一一位中。具一切位。非但融因亦常融果。融果之因方是真因。第五行法差别者。行随位别。亦有圆融及寄法差别。若对前教亦成四句。准位应知。有以十向配于十度。随胜受名。虽位位所回皆具诸度。以名收之亦有理在。四结数引证可知。第五佛子云何下说分。说十回向即为十段。一一段中皆先长行。后明偈颂。长行中各二。初位行后位果。有不具者。至文当知。位行中各三。初牒名征起。二依征广释。三依释结名。文处可见。今初。回向文缺位果。于位行中先牒名者。具如本分。又本业云。常以无相心中。常行六道而入果报。不受而受诸受。回易转化故名救护等。二广释中二。先明所回善根。后修善根时下。正明回向。今初古人名此以为行体。若顺前名救护众生是悲离众生相为智。则以悲智为其行体。以是初行故。将总体以为别体。若以为欲回向故修诸善根。即彼善根亦得称体。古义依此。后正明回向中二。先明随相回向。后我应如日下。明离相回向。前即回向众生及与菩提。释救护众生。后即回向实际释离众生相。前中二先总明令物离苦。至究竟菩提。即双明慈悲及二回向。后菩萨摩诃萨下。别显文分为四。一利乐救护。二佛子菩萨于非亲友下。受恼救护。三佛子菩萨见诸众生下。代苦救护。四佛子菩萨以诸善根正回向下。迥拔救护。初中三。一总标。二我当下别显。三佛子下。总结。今初。晋无菩萨等言。而有复作是念之语。弥显前已回向。别显中文有十句。初离苦果。二离苦因。三通因果。五怖畏中含三道故。上三通于深浅。后七唯约究竟。四得菩提。五得涅槃。六灭烦恼之源。根本不觉若灭此者。如天之大明。七灭所知之闇。故云一切无明。即触事不了者。若灭于此。如人执炬委悉而照。八令得解脱故。涅槃云澄渟清净即真解脱。已脱重昏故云灯也。九令证法身故言真法。十令成般若无二碍智亦是权实无碍之智。三结中以前十句有通浅深故。令究竟得一大事。第二受恼救护中二。先明受恼之相。后佛子菩萨摩诃萨以诸佛法下。明回向之相。前中亦二。先法后喻。法中有标征释可知。后喻中有二喻。先大海不变喻。喻遇恶缘不变本心海。喻菩萨器量大故。众毒喻恶众生。不变喻菩萨不乱。二日轮普照喻。喻遇恶不息利益。于中三

初喻次合后征释喻中略有其二。先日轮具德。后遇缘不息。有十一恶缘合中具合。先合具德举其十德。以合于日影。显于日亦具十德。一福德之轮已圆。二智用深广难测。三正念游空无有高下。四慈风运用不退不疲。五圆福智轮显照空法。六三乘山谷普照无私。七使目睹万像。了真俗之义。八使居自乘业以智成办。九常为利益昼夜无休。十无器生盲亦不语舍。后不以众生下合。非缘不阻于中有四。不以具合十一事。初一不以通合生盲。先正合。后但以下反合。故出现品云。无信无解毁戒毁见等。皆名生盲。若别合者。弊恶合生盲。邪见合干城。令人妄谓为实故。嗔浊合修罗手。日为帝释先锋。彼嗔故覆障。次不知思。合阎浮树崇岩邃谷。次不以凡愚下。合前尘雾烟云。以彼能遍空。犹彼凡愚同一处住。后不以众生数起下。合前时节改变。谓频起过惑乍善乍恶。如彼昼夜阴阳失度等。三何以下征。释中先征。意云何以恶不厌舍。释意云。悲智均故。文中二。初喻后合。合中二初总合。后不但下。别合。于中二。初以大悲合日恶是其境。本为一切岂独拣于恶人。如日普益宁复弃于槁木。二如是已下。以智合日善恶均照故。第二明回向之相中二。先辨回向之心。后佛子下。辨回向之愿。前中依悲智心行回向故。于中二。先缘境广大上等佛心。即以圆觉因果之法为所缘境。圆明可贵所以称宝。后菩萨如是下。悲成利乐下救物心。于中先牒前起。后生二种心。一于上等佛得净信心。二下与众生同。大悲体由依此二。成甚深等十心。一契理故。二自庆庆他故。三离过故。四超二乘故。五定乐相应故。余五可知。普为已下。结其所用。心顺口故名为真实。第二正辨回向之愿。文中二。先愿众生令成法器。二又作下。令得法圆满。于中四。一总举遇缘得法。二于诸佛下。成自分德满。七财者。即十藏前七。三于诸佛所常随下。胜进德圆。四令一切下。明得果满。先标佛乐下。二句释故。第三回向略明十种乐。谓不可思议佛所住乐等。又不思议法品。略明十种无量住。谓常住大悲等。第三代苦救护中。文分为三。初总明代苦回向。二复作是念我所修行下。别明回向之心。三佛子菩萨摩诃萨以诸善根如是回向所谓随宜下。总结成益。今初分二。初明先救重苦。后菩萨尔时作是念言下。念遍救诸苦。今初有二。先见苦兴悲心坚不退。坚有七相。谓不舍所行。不避苦事。不惊忽至。不怖迷倒。不退大悲。多苦不怯。长苦无厌。二何以下。征以释成。征有二意。一云生自造苦何干菩萨。而欲代之。二云剧苦难堪何为不厌。释意云。本愿荷故。逢苦若厌焉能荷负。二念遍救诸苦中二。先救八苦八难等苦故。有诸言。随业流转是业系苦。邪见无智是愚痴苦。我应已下。起救之心二又诸众生下。救迷四谛苦。文中分二。初念苦境。二菩萨见下。正兴悲救。今初。于中先不知集。谓痴爱为本是烦恼道。染着已下。明其业道。为有造行故名染着。随业入苦如彼鸟兽因食爱故入于笼槛。作魔业行明有恶业。福智都尽明无善业。次常怀疑惑。无生道见灭之因。故不见安隐圆寂。不知出离道谛。在于生死苦谛。二兴悲救中起大悲心者。令脱苦集故。大饶益心者。令得清净灭道故。故用善根回向。大回向经者。贤首云。如圆教所说普贤回向故。然藏内有大回向经。此教最初不应指彼。若结集从简于理可然。第二别明代苦回向之心。中有五复念。前三明代苦之心

后二明回向之心。今初。即分为三。初明一向普救无自为心。次众苦备受无懈怠心。三决志保护无虚妄心。初文可知。二中复二。先正明后征释。今初。言大壑者。如尾闾壑。饮缩众生无暂已故。后征释中先征。意云何以独为众生备受众苦。复勤修耶。释云。一身之苦令多解脱故愿自受。显悲之深。问众生之苦自业所招。自心所变。云何菩萨而能代耶。答通论代苦有其七义。一以苦自要增悲念故瑜伽四十九问云。菩萨从胜解行地。随入净胜意乐地时。云何超过诸恶趣等。此问菩萨云何自离恶趣下答文广。意云。谓菩萨于世间清净静虑。已善积资粮于多苦有情修习哀愍。无余思惟。由此修习故。得哀愍意乐及悲意乐。为利恶趣有情誓处恶趣。如己舍宅。设住恶趣能证菩提。亦能忍受。为除物苦愿身代受。令彼恶业永不现行。一切善业常得现行。由此悲愿力故。一切恶趣诸烦恼品所有粗重。于自所依皆得除遣。得入初地。释曰。约此但有悲愿意乐。身不能代。由悲决定自获胜益。二约菩萨本为利生求法苦行。已名为代后能为物为增上缘。亦名代受。三约菩萨留惑同事受有苦身。为生说法令不造苦因。因亡果丧亦名代受。四设有众生欲造无间等业。菩萨化止不从。遂断其命。菩萨自受恶趣苦报。令彼得免无间大苦。名为代受。此依梁摄论第十一说。涅槃仙预国王。亦同此义。非唯意乐而已。五由菩萨初修正愿为生受苦。至究竟位愿成自在。常在恶趣救代众生。如地藏菩萨及现庄严王等。乃至饥世身为大鱼。皆其类也。或以光明照触。或神力冥加其事非一。六由菩萨此愿契同真如。彼众生苦即同如性。以同如之愿。还潜至即真之苦。依此融通亦名代也。七由普贤以法界为身。一切众生皆是法界。即众生受苦常是菩萨。故名为代。上来七义初但意乐。次二但约为增上缘。四五二义实能身代。六七二义理观融通。问若依四五二义。应能普代。何故犹有众生受苦。答此有三义。一有缘无缘故。与菩萨有缘则可代也。二业有定不定故。不定者可代。三若受苦有益菩萨令受。方能究竟得离苦故。如父母教子付严师令治。如是密益非凡小所知。第三决志保护中二。先正明。后征释。征意云。云何不舍何名不虚。释有二意。一异小乘不自为故。二亦不为下。明异凡夫着欲过故。文中三。初正明不求。二征释所以。所以不求者见多过故。文中体即是苦复能生苦。近障天乐况大菩提惑习双亡。今言淫欲即是道者。善须得意。三菩萨如是下。结成前义。第二有二复念明回向之心。即分为二。初念令彼得乐。后念身为保护。今初。乘前欲苦故令得乐。文有十句。初总余别。别中前八涅槃后一菩提。于涅槃中。一住涅槃能建大事。名为利益。二灭心数。三证无为。四无能所。五相不能迁。六广无分量。七生死真性即是涅槃故。无所舍智冥真理是以不退。八一得永常湛然不灭依解节经说有五乐。一出家乐脱家难故。二远离乐。以断欲得初禅故。三寂静乐。二禅为首。觉观息故。四菩提乐。于法如实觉故。五涅槃乐。息化入无余故。彼通人天今唯究竟。会释可知。二保护中初示安隐道。令得菩提名知实义。后又于下。令度生死海得大涅槃。名到彼岸。第三总结成益中。初总标。所谓下别显。别中初句救护余皆成益。第四回拔救护。谓孤标大志普为众生。而无冀望。文中二。先喻后合。喻中有二。一独照喻。二又诸下。成益喻。法合亦二。先合独照。后修习下。合前成益。即正显回向。初之一句通其二势。一成前二标。后所谓下。别显。文有十句。初总余别。照谓照机顾复之义。见于毛诗余文可知。第二大段我应如日普照一切下。离相回向。于中二。先以忘机之智导前大悲令成无缘。后安置下。正明大智离众生相。今初。功高二仪而不仁。明踰日月而弥昏故。于中先正明无私。不求恩故能容受恶。为普照故不以一恶而舍众多。设尽背恩尚无嫌恨。岂况一耶。后善根虽少下。显成广大。大智导悲能普缘故。如声入角小亦远闻。第二正明离相回向。谓向实际。然一一随相皆具。如下诸句离相。说有前后行在一心。文分为二。先正明离相。后菩萨如是下。总结成益。前中义虽总通。且取文便略分为二。先会前回向众生明入实际。后以如是等下。会前回向菩提明入实际。然入实际即事理无碍故。前段亦明不离蕴等。后段亦明离我我所。前中二。先广明离善根回向之相。二解一切下。双结二相。前中有二十一回向分四。初十四句离所取相。次二句离能取想。三一句离能诠名言。四有四句显如如理。由离妄想成正智故。令前名相皆即如如。今初。初总余别。总谓令所向众生契同所向实际。故名安置。实际即法性性自无著。别中二前十入理。后三离过。今初。初句遣所向众生了自性故不着。凝然不动随缘不变。二遣能回悲愿。不依于悲不取愿相。三遣所回善根。四遣所获果报。五六二句双明起行之身及所向众生之相。即真故不着。即俗故不坏。七遣所成业行。八遣所得报相。上四遣体。九总显诸事能成因缘。十总明前事从缘所起。明上回向不出前十。由后二句故无性。无性故即法性。故无所著。后三离过。一不着虚名。二不着报处。三敬养等名虚妄法。二离能取想中。初句对所说能。后句别无三倒。谓于前诸事起心。分别常无常等名为心倒。于常等境取分齐相。名为想倒。于相执实名为见倒。翻背正信立以倒名。翻上名为不起三倒故。大品十七弥勒语须菩提言。新发意菩萨。随喜诸佛及佛弟子善根已。回向菩提。云何不堕想心见倒。须菩提言。于彼善根心不生想。用此心回向菩提。于此回向心亦不生心想。如是回向则非想倒心倒见倒。若取相回向为想心见倒。光明觉品云。若于一切智发生回向心。见心无有生当获大名称。此亦无三倒也。若依大般若第二会随喜回向品意。则上诸事皆尽灭离变。此中何者是诸事耶。若菩萨知此一切乃至菩提。皆无所有而复能行随喜回向。则非想心见倒。以无所得为方便故。然小乘或说想心见三次第而起。或说一时义分前后。心想非倒。由见乱故立以倒名。虽诸说一同皆六识建立。若大乘中亦有多说。一云依七识心义分。三倒谓七识妄心性是乖理。颠倒之法。名为心倒。依是心故便有一切妄境界生。如依梦心有梦境起。即于彼境妄取其相。说为想倒。于所取法执实分明。说为见倒。依此三倒。于为无为境起常无常等八种颠倒。诸宗异说恐厌繁文。三离能诠名。四有四句显如如者。前明妄空一切皆空。此彰实有一切妙有。又即前之空是此之实。二义不二为真法印。是即妄取回向菩萨不有。真实回向菩萨不无。文有四句。初总显实性。次别约众生。三印诸事善。四心绝贪求。第二双结者。一句结所回善根。善根可以独修但云种植。一句结回向行。回向必有能所。故观无二。如此则德本不生惑本不灭。又惑累寂然不生。真德湛然不灭。第二会前回向菩提入实际者。又前明随相次辨离相。欲显此二同时故双非即离。文中三。初结前生后。二非即下。法喻释成。三离我下。结成回向。今初。由前离相所行清净故。顺出世无上菩提。而言二者。善根回向世与出世。若有若无若即若离。皆名为二。今并无之。二释成中先法后喻。法中二对。初以所回善根对能回行愿。辨非即离明因中无二。初句业非回向能所别故。次句不离。离业无可回故。亦同净名布施回向一切智为二布施性。即是回向一切智性。故不离斯为不二。非即故无不二也后对因果相望。初句果不即因。后句离因无果。文影略耳。理应因果各有非即离义。后喻中乘光发影。及水月之影皆缘生无性。非即非离故云清净。初二句。以因对报报通十地故。后二句以报对果。三结成回向者。能回之我所回我所。若随若离并称动乱。今照而常寂故离斯分别。而不坏相故名方便。第二总结成益者。由随离不二故。成无碍离过之益。及第三结名文并可知。第二尔时下。重颂分二。先叙仪意于中初后二句说仪。入深句义者说依。以无量下。亦是说依。依此说故亦说所为。为此说故后正陈偈词。二十八偈分二。前八偈半颂所回善根。前六四等。一慈二悲。一偈半喜。一偈半舍。如地无心故。一偈结其普遍。后二偈半明六度。后如是下。十九偈半。颂回向行分二。前七偈半颂随相。初一偈半颂利乐回向。后六颂代苦回向。余略不颂。未曾下十二偈颂前离相。于中二。前五颂正明离相。后十方下七偈颂前成益。文并可知(自下入第二十四经)第二不坏回向。长行中二。先位行后位果。位行中三。谓牒释结。今初。牒名征起。谓于谛宝等十种胜境。深信坚固得不坏名。然十表无尽。信通事理故。本业云。观一切法但有用但有名。念念不住故名不坏。是知善根回向皆通事事无碍。方真不坏耳。第二佛子下。依征广释中三。初举所回善根。二辨回向之行。三明回向所为。今初分二。先明起不坏信。后佛子下。依信种善。今初。十句不出三宝四信。初句佛宝。次句僧宝。余皆法宝。于中初句是总。兼含理法。余七句别。别中初一教法。次四行法。一大悲行。二恶止善行。行亦摄于戒。三回向行。四近友行。次一果法。后一重举行法。意欲总包其中理法。即信真如。第二依信种善根中二。先种善根。后令菩提下。长菩萨道有十句。初总余别可知。第二菩萨摩诃萨以如是等善根下。明回向行中二。先将善根回向。后将胜报回向。前中即双向众生菩提。文中又二。初正明回向。后菩萨如是积集下结成。今初。先总明回向菩提之果。愿常下。别明回向成得果之因。文有十句。初三行缘。次二行因。后五所成之行。初成利他行即回向众生意。次三自利后一通二利。二结成中九句。前三通显收摄。亦是闻慧。一积一至多。二令至究竟。三随一使增。次四皆思慧。后二修慧起行为修习。相应为安住。二菩萨摩诃萨如是积集诸善根已下。将胜报回向。谓依回向得报。复将回向通向三处。文中二。先明所回善根。二如是修习无量功德下。显回向行。今初又二。先结前生后。后于念念下。正明供佛善根。于中又二。先总标。后以阿僧祇下。广显。今初言如其所应者有二义。一随何所要如应即供。二称佛境界所应之供。谓不以称法界之供。不能供称法界之佛故。二广显中四。一广列供事。二明供佛。三显供意。四结分齐。今初广列供事。有六十七句为六。初二十句杂门。明内外之供。下皆纯门。二座。三经行处。四宫殿。五树严。六严宫殿。亦纯杂无碍可知。二佛子下。明供佛中二。先供现佛。后一一下。明供舍利。三为令一切下。明供意。有十一句可知。四如是供养现在下。结供分齐。谓非唯如上所列。故云不可尽。第二如是修集下。显回向行中三。初回向之心。二回向之相。三回向行成。前中有三。初不离大悲兼回向众生之意。无有执着下。离妄契真即离相之意。后诸佛下。结前生后。二与诸法性下。回向之相。兼显回向菩提。于中有十一句。前六离相后五随相。三佛子下。回向行成。于中三。初随相行成。二以清净下。离相行成。三菩萨如是善巧下。双结二行无碍。今初有三。初牒前由前离相非唯不碍随相。亦能成此随相。次虽随下。正显文有十句。一由前法性相应故。随生死而不变。二以入无作成所作故。求一切智未曾退转。三由舍离想着故。诸有不动。四住多善巧能度众生。五永出诸有故不染有为。六修行不住相故。不失无碍智。七普摄善根故因缘无尽。八普净大愿故世法不动。九发菩提心故具修诸度。十由善根同住故具足十力。如次配上。后菩萨如是下。结前生后。即由前最上信解心生。二明离相行成。由前事不碍理故触境了如。于中初一句总。了一切下别。别中初唯心观成。次知业下。缘生无性观成。次出生下。法眼了真。具菩萨下。妙行无著。亦如次配前。一了心性故。二业无作故。三不起想故。四行善巧故。五诸有缘生故。六行无住故。七普摄无著故。八诸行广大故。九了菩提性无有二。唯一实故。十由与善根同住故。能具菩萨行。十一由最上信解故。于无漏白法无有废舍。若通由前则易可知。三双结二行无碍。以成回向中。初总明不迷理惑事。故名善巧思惟。后不违下。别皆事理无碍可知。第三菩萨摩诃萨以诸善根如是回向下。回向所为。初句总明。后不断下别显。于中前离魔业。通一切恶。后魔事业通一切相。但违法印皆魔事故。故下释。云以平等印普印诸业则离魔也。余句可知。第二位果。亦如十地调柔等果。文中初牒得时。次得见下。正辨果相。后菩萨下。总结所属。第二偈颂。二十五偈分三。初二颂所回善根。及第一节回向。次十八偈颂所成供行。复将回向。后五偈颂回向所为。二中亦二。前八颂所回善根。后十颂回向之行。文中三。初四颂回向之心。次二颂回向之相。后四颂回向行成。所为可知

大方广佛华严经疏卷第二十六大方广佛华严经疏卷第二十七

        唐清凉山大华严寺沙门澄观撰

第三等一切佛回向。长行亦二。先位行后位果。前中亦三。初标名者。若准次文。但等三世诸佛回向之道准下亦等善根。故文云如过去佛所行一切善根。我亦如是故。本业亦。云三世诸佛法一切时行。兼显无间故。下文云。与妻子俱未曾暂舍菩提之心。此从所等立名。即等一切佛之回向。以深入法性行普门善。而为其性。二依征广释中二。先总标举即释名也。后如是下。广释亦二。先显回向。后明成益。前中又二。先等随相后等离相。前中复二。先明对境善根。以将回向。后总摄万善以将回向。前中又二。初所回善根。后佛子下。正显回向。今初。谓学佛修时。于六境违顺成四净心。一于顺违成就行舍。不为境牵名心自在。二异于凡小。以悲智广大净诸惑故。三离忧过故。有喜乐舍无忧苦恼。四禅定轻安故心意柔软。不妄取境故诸根清凉。第二正回向中。回向五乘之境。文分五段。一佛。二菩萨。三有善众生。四二乘。五有恶众生。初中二。先牒前起后。后愿以我下。正显所愿。初总愿乐增。然佛德已圆。今愿增者。尊重荷恩展诚敬故。亦犹献芹于上。香华奉佛非彼须待。所谓下。别文有十句。初句望九亦是总句。具下诸住故。由此名不思议。二即天住谓海印等。三即梵住。四即圣住。谓无边解脱等。五种类俱生无作行通。六十自在乐。或八自在我。七智用无边。八离觉圆寂。九大用恒湛。十二行永亡。二佛子下。回向菩萨亦二。初结前生后。后所谓下。正显有十。前六自行后四利他。前中通有三义。一通相辨随愿行等而满故。二究竟满故。三从次满。初信中随缘之愿。如净行品。二净十住解心故。晋经。云未净直心者。三成十行。四成十向故。菩萨戒名十金刚。五得初地已上证不退故。六得八地已上无功用行。名大精进。任运了一切法。名护菩提门善根。后四利他中。初令证发心离二我故。二遍安诸地。三通得地中之德。四令证佛果。三佛子下。回向有善众生。亦是迷真实义。愚众生有于少善。但为求有处人天乘。今令住佛乘。以成十益。初三令念三宝。次三念己成德。后三由德成益。各如次配佛法僧宝。念佛三昧能发通故。四如为下。回向二乘。然众生于佛法易反复故。先回向之。二乘终竟回心故亦不舍。例前成益。五又愿下。为于有恶。谓不遗阐提。亦是迷异熟愚众生。不见苦果故。初令离苦果成善因。后永不下。令离恶因成当果。上来五段。初一回向菩提。余四回向众生。第二佛子菩萨摩诃萨所有善根下。总摄万善回向中二。先总显其相。后佛子下。历事别陈。今初。所有善根即所发起等也。皆以大愿即能发起等也。别有三句。一未生善根。以大愿方便发起令生故晋经以发起为行。二亦以大愿积集令多。三随已生善一一增胜令充佛地。而皆有重句。云正发起等者。谓随发起积集增进。必向三处不余趣求。离诸过失名之为正。悉令已下。总结成益。由正发等故。令称悲智故名广大。由发起积集故诸善具足。由增长故一一充满法界。等于如来。无善不尔故云悉令。而晋经译正为等。以梵本云。三通正及等。然等有二义。一者等佛。谓以菩萨之行等佛之行。二者等余。谓以一行等余诸行。然古德将为结上。虽穿凿非一并未会下文。若以等为平等与正相近。亦摄义不周。并非今用。第二历事别陈。诸善非一略举一两。以显随缘摄善皆成回向。文中二。初显增长回向。后佛子菩萨尔时下。明积集回向。其发起回向通在二处。前段亦是大悲随顺。后段以明大悲深重。此约善根。若据回向。前明回向菩提。为众生故。后回向众生令得菩提。皆是绮互。欲显一时回向三处耳。今初。增长中分二。先别明。后菩萨如是下总。结前中三。初明随染无污回向。以慈故随染。以智故居清净道念萨婆若。二菩萨摩诃萨下。动与道合回向遍而无间。三为欲下。总显回向之相。正显前文大愿发起增长之义。文中二。先总明。初句标意。安住下。即能发起愿。摄取下。所起所增。善根普救一切即结成正义。二永离下。别显文有十句。一离惑故。二正趣向故。三不取余道故。四正观故。五舍杂染故。六具修因故。七于菩提因舍二障故。八持诵智地。九以智集善。十不染世行受出世法。十皆自德能向菩提。若以上普救一切贯之。则十皆为生令得此善。二总结中。以此文。证释增长义理甚分明。第二明积集回向中二。初别明。后菩萨摩诃萨如是下总结前。中二。初明微细积集。后菩萨初发下。长时积集。前中亦二。先明所积善根。下至一抟一粒。其福至微施与畜生其田至劣。积此微善。亦以大愿令正发起。成回向行。二咸作下。明回向行。先总明离苦得乐。次永度已下。别彰离苦。文有九句。初总显深广。次八别明苦相。受即苦之自性。蕴即苦依。谓五盛阴。苦觉谓苦相。亦摄怨会爱离等觉。聚谓生老病死三苦八苦。行即罪业因即诸惑。本即贪欲处即三涂。乃至变易所依。皆得舍离。通后五句。后菩萨如是下。总结令得菩提。第二长时积集者。从初发心即积集故。文中二。先总标善根回向。后欲令下。明回向意。即是回向之相。以欲令之言是心愿故。文有十三句。前十二为六对。得随相益。后一句入平等理益。前中一离苦果得灭乐。二出集因修正道。三具悲智成上修道。四护善近佛则出烦恼海。余二对共成初对。第二总结中。一抟一粒等即现集也。初发心来即已集也。当集之善。虽则未起愿力逆要。起必任运注向三处。况依此教九世圆融。第二复作是念如过去下。等佛离相回向者。即向实际。统于前二。说有前后行在一心。文中二。初等过去。后佛子下。等于现未前中二先举所等。后如彼下。显于能等。前中三。初标随相即有离相。故末句云而无所著。次所谓下。别显离相之相。三如是深入下。结其无碍。二中先离妄契止。初蕴次处。不住世法即十八界。有根境识是世间故。不依不着即是出世。次知一切下。释前不着所以。不著者。由见实成观故。初句是喻。无所从下。文含法喻。但观所喻能喻可知。皆由从缘无性故无来等。五句展转相释故。上文云。一切法无来。是故无有生等。远离已下。结其成观。心无分别故寂然不动。外缘不转不失于照不坏于止。故与实际相应。实际谓何。即是无相。何名无相体离十相。唯是一相。一相谓何。即是无相。又无相约理本自无故。离相约智离取相故。唯是一相心境冥故。三结无碍者。既称法性修随相故。一摄一切名普门善。悉见诸佛。略辨成益。二显能等中二。先牒所等总显能等。二解如是下。别显等相。初二句愿等佛解证。次二句依之修行。不违已下。显修行相。至究竟地即是修果。第二等现未中分三。初牒所等。即举过去例于现未。次我今下。总显能等。三第一下。别明等相。通能所等。前过去章中已广显离相。今此文内直叹殊胜。义存影略不欲繁文。有十九句。晋经具二十句。谓广大下。有明净回向。今译谓同清净故缺此一。于中初九形对辨胜。初总明首出故名第一。二越凡小故。三超因位故。四独出故。五无加过故。六无与齐故。七唯至极无二者可齐等故。八无匹故。九无敌故。后十约自体显胜。一尊可贵重故。二妙者言思不及故。三称理无差故。四不余趣向故。五摄德故。六周法界故旧云大愿。七离无记故。八离垢染故。九自无恶行故。十不随恶缘故。上来正显回向竟。第二明回向成益。文显可知。第二位果略辨十种胜德。一因修佛业以等佛回向故。回向众生是佛业故。又如离世间品十种佛业。二趣佛果德向菩提故。三智入深理向实际故。余可知。第二偈颂。二十四偈分三。初二十一颂颂前位行。次二位果。后一结叹。前中二。初一颂总标释名。后二十偈颂上广释亦二。先十九颂正明回向。后一颂成益。前中随相离相双颂。文中亦二。初六颂对境所生善根回向。于中初二偈。颂所回善根兼回向佛乐。后四颂回向众生。令得佛安乐。二有十三偈。颂总摄万善回向分三。初四颂增长回向。二有三偈颂积集回向。三六偈却颂上对境善根。回向菩萨。回文前却初四随相。后二离相。于中初偈达法际。二与不二相待皆寂。后偈了妄源以想遣境。境尽想亡非想遣想相待俱寂。寂而常照方名了想。其成益位果结叹可知。第四至一切处回向。长行亦二。先位行后位果。前中亦三。谓牒释结。今初。牒名征起。至是能至善根。及其供具。一切处即所至供境。谓以大愿令此善根供具。遍至一切时处。随所应供供诸福田。本业云以大愿力入一切佛国中。供养一切佛故。然准下文。若因若果皆至一切略举十事。一法身至一切处。如来藏身普周遍故。二法身至故智身至。三智身至故大愿至。四大愿至故。供具善根至。五则见佛听闻至。六则现身开悟至。七则无来无去至。八则不出一毛孔而能至。九则一身一毛等一切身毛至。十则一念等一切劫至。若克陈别体。则以供佛善根。及胜解心为体。通则该于法界。第二依征广释中三。初回向众生菩提。二回向实际。三结叹成益。前中二。初略明后广显。前中三。谓法喻合。法中谓以愿力及善根力。此二相资故。能遍至。次譬如下。喻况中实际者。即一切法真实之际故。无不在一切物者。谓凡是有形故。晋经中名一切有。余并可知。此与如相及法界回向有差别者。此据善根回向。成供具至一切处。第八约善根回向。同如体相业用。第十约所回向行广多无量。故无滥也。第三愿此善下。以法合中。先总后过去下别明。于中二。先举三世合所至处。能事已毕。过云愿满。修因已圆未云具足。现成正化故云国土道场。后愿以信下。明能至供。于中先成供因。因有三种。一以胜解则随心转变。二以大智了无障碍。三以善根回向称愿而成。以如诸下。辨所成供可知。第二佛子菩萨摩诃萨复作是念下广明。于中二。先约十方佛明其遍至。后约常住佛明其遍至。前中分三。初总明供处。二如是一切下。别明供养。三以此善根下。通显回向之心。今初。先约处显多。次种种业所起约因显多。十方已下。约数显多。种种世界约形类显多。义通受用及变化土。二别明供养中二。初供现在佛。后若佛形像下。供住持佛。前中二。先所供田。后佛子下。明能供行。前中二。初实报田。二彼有下。辨权应田。于中三。初现身。次说法。言以至一切处智者。意明今此位菩萨亦能尔也。此即本下迹高。若佛为菩萨。则本高迹下。或俱高俱下因果交彻思之。三法身下释权佛所由。初之三句显与果佛平等。同性起故。一得法性身同遍往故。二等有智身入法界故。三普贤自体如来藏身不生灭故。由上三义故。能善巧普现世间。若尔众生岂无如来藏身。故下三句复释成前义。一证法实故得同法身。二有无碍智力。故普入法界。三佛种中生故得如来藏身之用。谓绝二障权实无碍。是如来见。广大威德。是如来用。菩萨随顺悟入。是生彼种性之中。故出现品云。若得闻此如来无量不思议无障碍智慧法门。闻已俱解随顺悟入。当知此人生如来家。广如彼。说得斯后三因位尚即为果。况应现耶。上亦供行所因。二明供行及供住持佛等。文并可知。三通显回向之心中。初句总牒善根回向。后所谓下。别显行相。谓前以善根回向成供。供诸田时如是用心。文有十句。一不生妄念二专注正境。三不由他悟四于田殷重。五违顺不动。六不住于法。七不依于境。八知我空。九心行安审。十正顺涅槃。第二约常住佛明遍至者。谓三世住寿尽未来际。应亦常也。三身十身融无碍故。不同前文有塔庙等。文中有三。初以善根回向供佛。二愿令一切下。以供佛善回向众生。三譬如下。总愿善根普摄回向。初中二。先所供境。后如是一切下。显能供行。今初。尽空法界明处无不遍。去来现劫时无不穷。诸佛世尊总该真应。得一切下。明真极之成。于种种时下。明应现成成即有始应乃无终故。皆住寿尽未来际。真应无二故。一一各以法界庄严主伴圆通。故道场众会皆周法界。出非在我故曰随时。兴必利生名作佛事。二显能供行中三。初结前生后。二愿以下。所成供具。三以如是下。结成供行。二中三。初以香为盖等二十事。次无量华盖下。以华鬘等九例于前香。各具二十。香等离盖等更无别体。故有二百。后如是一一下。随彼盖幢等中。若总相说皆有楯等九事。成一千八百。并前本门总有二千。是则香等成盖等盖等有楯等。从无数无量如是渐增。且至不可说。理实皆等法界难可称也。然一一诸言定通香等。不全通于盖等。以衣及光明何有门闼楼阁等耶。是则都数未必二千。但通相言一一诸境界也。三结成供行可知。第二以供佛善根回向众生者。正显回向之愿。然前段供。后有不乱等心。今此供后明清净等愿者。文有影略义实相通。文分为二。初总显所为谓令得果惑净智明。后令一切下。别显愿得因圆果满。初明二利因圆。成就已下。智用果满。第三总愿善根普摄回向者。以上来三段别明善根但说成供供佛。今欲显此善根无所不成。故复明此。于中二。初喻谓。二无我理普摄理事无不周故。二我诸下。法合有二十句。前十二句摄成自利德。后八成利他并显可知。第二佛子至以诸善根如下。实际回向中二。初总标。二不于下别显。今初。用无所得为方便者。略有二义。一以无所得导前随相。即涉有不迷于空。为入有之方便。二假无得以入有不存无得。即此无得亦是方便。此为入空之方便也。今文正用前意义兼于后。欲显随相离相无前后故。然略云无得。准大般若。亦以无生无灭无住等。皆为涉有之方便也。二别显中三。初正显观心。二菩萨如是了达下。明观成之相。三菩萨如是观一切下。明观成益。初中十句义有四节。初一会事归理。谓事法既虚相无不尽。理无不现故业果皆空。业空故无体可能招报。况谓因中而有果耶。报空故无体可以酬因。况谓果中而有因耶。若约观心名会用归寂。次五句明理不碍事。约心则寂不碍用。于中初句。理无能所分别。而不碍有能入之智所入法界。次句无作而造作。次句无起而修起。次句无能所信。而能即事入玄。此与初句但事理之异。大般若云。若信一切法。则不信一切法。以不信一切法。名信一切法。此约不信是真信。今约不信不碍信。末句不有能所见。而不碍能所见。三有二句事理双绝。约心即止观两亡。初句正释。作事也。不作理也。待对假言故皆不可得。下句释成。法从缘起不能不生。诸缘离散不能不灭。从缘生灭不能不有。缘生无性不能不空。故诸法性无暂自在。何有性相而可得耶。四有二句明事理无碍。约心即寂照双流。良以事虚揽理无不理之事。理实应缘无不事之理。所以寂而常照照而常寂。故终日知见而无知见也。上四句初则会有归空。有未曾损。次依空立有有未始存。次空有两亡无隐无显。后空有无碍存没同时。四句镕融。方名离相实际观也。二观成之相。然此段文更有二意。一前是即观之止。后明即止之观。前虽云知意明无知。二以后段释成前文。由知因缘等故。不于业中分别报等。虽有此二观成相显。于中分二。初句结前生后。由依如前了达心境故。能成下如是知见。后知一切下。正显其相。文有八句。初总余别。总中由上观故能知因缘。何等因缘。谓一切法若漏无漏为无为等。皆以因缘而为其本。云何为本。谓因缘故有。因缘故空。因缘故不有。因缘故不空。因缘故流转。因缘故还灭。乃至一切皆由因缘故。中论云。未曾有一法不从因缘生。有为缘生无为缘显。因有有为则有无为。又形夺相尽是真无为。下别有七句。释成上义。由观因缘得见佛等。是故因缘为诸法本。一见法身因缘无住。无住之本即是法身。经。云佛以法为身故。论云。若见因缘法则为能见佛。二见法实际。因缘性离为法实故。三无性缘生故如化似有。四理外无事故唯一法。皆如来藏事事皆虚故无二性。尚无有二何况有五。五缘性无碍故。于业境皆得善巧。以业摄报境必对心。则内外因果皆善巧也。六即事显理而不坏事。故云于有为等。七即理成事。而不隐理故云于无为等。若灭坏有为。则失有为本空。若分别无为即坏无为之性。是以若约相即。为即无为无可灭坏。无为即为亦无可分别。若约无碍。则事能显理而非理。理能成事而非事。事理相即性相历然。故为无为体非一异。示谓显示有为界分无为界性。三观成之益。文显可知。第三佛子至称可下。结叹成益。上来近明离相之益。今则通辨一回向益文中二。先明自分。二利益。初句上称佛心。余句自成二利。二佛子下胜进。二利益文兼体用并显可知。第二大段菩萨下。位果中三。初牒得时。二得至下。正显所得。文有十句。初三三业体遍。次三三业用遍。后四显用自在。三佛子下结。第二重颂有十一偈分三。初七颂回向众生及菩提。次三偈半颂回向实际。后半颂成益。前中二。初一偈颂前略明至一切处。但颂法说所修善根。后六颂前广明。于中初半偈通颂前所至处。次一偈半颂前回向众生。后四颂前普摄回向。余可知(自下入第二十五经)

第五无尽功德藏回向。长行中亦二。先明位行中亦三。今初。牒名征起。由缘无尽境行回向故。成无尽善根功德之行。得十无尽藏之果。从能回及果行受名。或无尽功德之藏。或即藏通二释。以回向望行。回向为能藏无尽功德是所藏。以因望果亦然。并有财释。本业云。常以三宝授与前人。故名无尽功德藏。此义亦通所回善根。即以五门善根回向而为其性。第二依征广释中三。初明所回善根。二明回向之行。三结行成德。今初。文有八句。初三可知。四闻法修证属于劝请。以对佛亲请必闻法故。后四皆随喜。然依离垢慧所问礼佛法经总有八重。一供养佛。二赞佛德。三礼佛。余即五悔。或合礼赞。或略供养。或但为五。以发愿回向但总别之异。如十住婆沙。今文依此回向在于下文故此有四或但为三故。智论云。菩萨昼夜三时各行三事。谓忏悔劝请随喜。行此三事功德无量。转近得佛。若依善戒经但有二事。谓忏悔回向皆随时广略。然忏名陈露先罪。悔名改往修来。除恶业障故须忏也。然忏有二种。若犯遮罪先当依教作法悔之。若犯性罪应须起行。此复二种。一事行。如方等经及礼佛名等。二依理观。谓观诸法空如净名说。当直除灭勿扰其心等。若依普贤观及下随好品。皆具事理无碍之忏。至下广明。言礼敬者。除我慢障起信敬善故。勒那三藏说七种礼。今加后三以成圆十。一我慢礼。谓依次位立无敬心故。二唱和礼。高声喧杂故。此二非仪。三恭敬礼。五轮着地捧足殷重故。四无相礼。入深法性离能所故。五起用礼。虽无能所而礼。不可礼之三宝。一一佛前皆影现故。六内观礼。但礼身中法身佛故。七实相礼。无内无外同一实故。八大悲礼。前虽有观未显为生今一一礼普代众生故。九总摄礼。总摄前六为一观故。十无尽礼。入帝网境。若佛若礼重重无尽故。言劝请者。名为祈求。除谤法障起慈善根故。声闻自度但忏己罪。菩萨愍众故须劝请。但劝如来普雨法雨。则自必沾洽。此文略云劝佛说法。智论复加请佛住世。占察经中亦请菩萨速成正觉。次句因闻法故起悟入善。言修习者。瑜伽八十三云。修者。了相作意。习者胜解作意故。又修者。于所知事而发趣故。习者。无间殷重修加行故。言随喜者。为庆悦彼故。除嫉妒障起平等善。然十住智论皆有三位。一诸佛善。二二乘善。三人天善。今文四句。初一总明具于三善。二乘正是所诃故。不别举而含在一切众生之中。后三句别。其第二句别明三善。结一随喜。后一随喜诸佛因果。大品随喜品。明大千海水一毛破为百分滴。取海水可知其数。随喜之福不可知数。法华展转第五十人。尚难校量。况初随喜。此据随喜如来权实功德。其福更多。然佛是除罪胜缘故与忏悔前后无在。既净身器次希法雨。复摄他同己回向三处。不堕三界及与二乘。然礼等五果通得菩提。别则忏得依正具足。礼则尊贵身器具足。劝请得慧。随喜得大眷属并大财福。回向离邪常遇佛世。常能修行。约教不同可以思准。第二菩萨如是下。明回向行中二。先结前善根。后悉以下。正明回向。前中二。初横结上来及不说者。后凡所下。竖结前善。谓随前一善皆有积集等故。具足为圆满学成为成就。证入为获得。了性为觉知。余文并显。二正明回向于中二。先回向菩提。后回向众生前中二。先明随相后明离相。前中亦二。先正起行愿。后结行成益。前中又二。先回向净土。后总摄回向。前中亦二。先明众宝庄严。后明人宝为严。泛论严净有其三种。一处所净。二住处众生净。即前二段。三法门流布净。亦名受用净。遍上二段。又此二段之中。具足十八圆满。今初有二。初总标所成。二如过去下。别显严相。于中亦二。先举三世土严。二愿成彼严。今初亦二。先别明二总。结前中三世即为三。别谓过未现在而为其次。今初分二。先总明后别显。今初先举时辨处。次所谓下。总标世界种者。即方处间列如初会说。无量者。无分量故。无数者。数多故。佛智所知者。净识所现唯佛穷故。菩萨所识者。登地分见故。大心所受者。地前能受故。庄严佛刹者。即正显示。此虽义当形色意是总该。二清净下。别明有二圆满。初辨因圆满。谓出过三界净土。亦有出过之因。然上世界成就品中。起具因缘总有十种。生佛兼说有净秽故。今此唯五。欲同佛净故略众生。初句亦总亦别。总明三土之因。皆无漏业故云清净。自受用土。净行所流万行生故。他受用土及变化土。净业所引随业现故。别则唯约受用。因缘所流增上缘所引故。佛地论云。如来藏识中。无漏善根为因而生。有义。但是增上缘生。以外法故。有义。亦是因缘而生。亲能生故。若不尔者。应无因缘。外法相望非因缘故。意以后义为正。言亦是者。通二缘故。有云。感报净土以四尘种子而为正因。亲感土故。六度万行而为缘因。助成土故。或以自利后得而为缘因。依此经宗。以一切波罗蜜行随其所应。依正二果互为二因互相资辨。以皆是法性相应善根成故。常融常别。余如世界成就品。下四唯别。初二变化土因。初句约为缘义。后句约为因义。次句是自受用因。故云出世净业。后句义兼自他受用土因。登地已上皆修普贤之妙行故。又此妙行即圆融因。融上诸土无障碍故。二一切下事业圆满。自能现作一切有情一切义利故。如来虽即是主意取义利。第二尽未来下。举未来土严文中二。初总标。二尽法界下别。显有九圆满。文分为五。一分量圆满。此通二土。谓约自受用。从初得佛。尽未来际相续无变横周法界。故无边际。约他受用。为于地上随宜而。现胜劣大小改变不定。但地前不测言无边际。登地常见亦无断尽。此文兼明方所圆满。以方所有二。一自受用周遍法界。于三界处不即不离故。二他受用处下文当辨。二皆从如来智慧生者。即果圆满自受用土圆镜智生。他受用土平等智生。三无量下依持圆满故。佛地经云。无量功德众所庄严。大宝华王是为依持。今文中先总标妙宝。所谓下别列。初三事严中有莲华。次二德严。初即无量功德。佛力即是能持。后一即是所持之国。佛地唯据于事但云莲华。今通事理故云佛力功德。庄严亦通事理。四如来所都明主圆满。五不可思下辅翼圆满。复兼四种。文中分二。初总显则兼眷属圆满。眷属谓人天八部。然皆菩萨化作示净土不空故。今但云诸清净众则兼之矣。后未来下别显胜德兼三圆满。初明方所圆满。佛地经云。超过三界所行之处。今云一切诸佛之所成就。通于自他受用非世所睹。即是超过菩萨能见是他受用。受用方所或说净居。或说西方等。是二此诸菩萨具大威下皆门圆满。以三三昧为所入门。此中初句显门之因。知一切下是空门相。行菩萨业是无相门相。善巧方便下是无作门相。入不思议三昧通该前后。三又此净业即摄益圆满。以离烦恼缠垢等为摄益。故名为清净第三现在下举现在严中亦二。初总标类同过未云亦如是。二无量下别显有三圆满。一者形相。即形色圆满。二无量光色。即显色圆满。悉是已下总以因结。三无量香下住处圆满。于中有三。初总明住处。次随顺下别显处因。即他受用因故云示现。后所谓下广显处严。以超过一切菩萨及余住处。名处圆满。第二如是等下。总结三世严具及土。于中二。初总结能所严。后所谓下别显所严。有二十九种随体德用立名不同。亦可并前总标通。结上来十八圆满随胜立土。如理应思。第二如是过去下愿成彼严。于中二。先严一界。后如一世界下。例严普周显严分齐。令法界土皆具三世一切庄严。既一佛土即具无尽庄严。则一严一切严。亦显一圆满即一切圆满。重重无尽。方是华严净土圆满。第二佛子菩萨至复以善根下。人宝为严。同十大愿中第七愿也。亦即是前辅翼圆满。文中三。初总愿所成。二其诸下别显愿相。三愿令如是下结以严刹。二中文二。先愿德高后愿业广。前中亦二。先正显德后结德严土。前中有二十句。初二总明体实智圆。后善能下十八句别显。于中先明智圆。后深入下明体实。今初即路圆满。大念慧行为所游路。路即道之异名。文中初明大慧。分别是权深入是实。此是慧体离痴慧业。成就念下即大念也。七念之中略举前四。七念如离世间品。后法日下即是大行。行即修慧故。后释体实亦是行摄。二结德严土中。初句总。次生如是处指前净土。有如是德即指向文。第二常作佛事下。愿业广中分四。即四圆满。初明事业圆满。上辨佛业今菩萨业。二得大智下即乘圆满。大止妙观以为乘故。三趣萨婆下无畏圆满。内无灾患外无畏故。四随顺三世下即任持圆满。论云。诸佛菩萨后得无漏。能说能受大乘法味。生喜乐故。文中二。前明能受。后知阿僧祇下能说。第三结以严刹中。初总彰人遍。次熏修下结行德深。谓以止以观唯智唯悲。熏修身心无有间断。名极熏修。现惑不生故云纯净。种习不起名极纯净。恬和也宴安也。恬和安寂即照寂之相也。亦一乘也。后于一佛刹下别示遍相。兼显数多。于中三节。一刹中一方有多数量。次以方例刹。后以刹例法界。一方所言义兼大小。准下僧祇品。于一微细毛端处。则有不可说诸普贤也。言如是者如前具德也。第二佛子菩萨摩诃萨以诸善根方便回向下。总摄回向。非唯但向佛净土故。文有十句。初三结前已说后七辨所未明言出要者。小乘出要。唯有四种。谓进念定慧。三十七品不离此故。今亦兼有。大乘出要唯有三科。谓四摄四等及与十度。三乘切要唯止与观。大乘切要唯智与悲故十地皆云大悲为首。智慧增上余并可知。第二佛子菩萨摩诃萨如是回向下。结行成益。总收三种世间。第二佛子至以如是等下。离相回向即向实际。文中二。先明见实智冥实际。后彰离妄德合实际。此之二段反覆相成。今初。初句牒前回向菩提。其心已下正显离相。寂然无涯为入不思议。即事契真故常平等。由此故能遍入。若事若理无碍法界名为一切。二佛子下彰其离妄文有十对。初六遮妄执有。以缘成无性故。皆前回向之法。思所起者谓身语业。余文可知。次一对遮妄执空以即空故。不碍存故不坏假名。说实相故不坏因果。后三对双遮空有。初遮事理。法即理法。互相即故不可定取。次遮生死涅槃。离向背相。通有二义。一约离相。为生死涅槃相待而有。俱空叵得。二约体融。以缘就实生死即涅槃故。无妄分别。以实从缘涅槃即生死故。非真寂静故。中论云。涅槃之实际。及与世间际。如是二际者。无毫厘差别。而晋经。云生死非杂乱涅槃非寂静。言异义同。后对即遮能所证。既二际无差。唯佛能证故复拂之。上句标下句释。亦通二意。一约离相。能证相离不能证于佛境。所证体空故。无少法与能证智。同止相契故。楞伽云。远离觉所觉。二约体融。佛即法界。不应以法界更证法界故。文殊问经云。若以法界证法界。则是诤竞如智一体。如外无少智为能证。智外无少如为所证故。无可同止。次下文云。无有少法为智所入。亦无少智而入于法。影公云。法性不并真。圣贤无异道。即斯意也。上来三节皆约遮边。前来契实已辨双照。则四门备矣。第二佛子下。回向众生中。初总明。谓即前回向菩提时。便以善根回向众生。故云如是回向时也。次决定下别显行相有七句。二句随相。一无放舍心。二无怨亲相。五句离相。一不见众生相。二不取化缘。三不称量根性。四无能度我人末句总结。第三菩萨至如是回向已下。结行成德有四佛子。兼此为五。一成无尽善根德。二成二空智慧德。三成境界清净德。四成福智无尽德。五成福智广大德。就此五中。初一双明。次二离相。后二随相。今初。由随一一行发无尽心故成无尽德。文有十句初总。所谓下别。于中前四随相所成。初二因果。后二依正。次二离相所成显其深广。次二解行。通于随相及与离相。后二通显上来回向同三世故。第二佛子下成二空智慧益。中十句。初四我空。一无众生。离众生垢故。二无寿命。离生死故。三无作者。亦名无我离我垢故。四无数取趣。前后际断故。余如十行说。后六法空文亦可知。第三佛子成境界清净德。一刹净者略有三义。一了秽即空故。二如螺髻等秽处见净故。三虽睹净秽无见相故。三众生净同一空故。同如来藏故无见相故。三法净。对法辨智义便故来。此亦二义。一空无能所故。二同一如故举一全收。智外无如为智所入。如外无智而入于如。法性寂然故名为如。寂而常照故名为智。何有异耶。亦同上来无法同住。后一佛净。为破执有说佛如空。若同空无此见非净。今明二利德圆。非如虚空一向无也。第四佛子福智无尽德。初上摄佛智。谓十力智地。有不可说用故。念念得多福。次具足下自为福田。此菩萨下福智无尽。第五佛子福智超胜德中。初句总显福智之因。次福德下正显胜相。初明福胜。其心已下显智超胜。第二菩萨下辨位果中四。谓标征释结。三中有十句。皆先标名后释义。于中初六自利。初一见佛。约微细门。一毛之义前文频释。今重发挥。谓心性本无大小。悟之成智身。土皆为智影。智净影明故。大小无碍一多即入。次五见法。即相入门。一证理法二持教法。三慧知密意。谓以实覆权等。四义穷意趣。谓四意趣等。亦是穷于性相。五闻藏义兼修证。次三利他。一福满他意。二智灭他惑。三辩教平等。后一摄行成果。此上多有同十藏品。可以意得。四结可知。第二应颂二十五偈分二。初一颂所回善根。文并具含。余二十四偈双颂前回向善根。及结行成益。于中二。先有十一偈颂二段随相。后十三偈颂二段离相。今初分三。初八颂向菩提。于中亦三。初四颂上严刹。次三偈半颂人宝严。后半偈颂总摄回向。二菩萨如是下一偈颂回向众生。三十方下二偈颂结行成德。五段通颂。第二菩萨善观下颂二段离相中三。初七颂前菩提离相。与前见实及离妄。相参而颂。显此二相成故。次二颂众生离相。后四颂结行成德离相。中初二偈。颂境界清净德后二颂二空智慧德。第五回向竟

大方广佛华严经疏卷第二十七大方广佛华严经疏卷第二十八

        唐清凉山大华严寺沙明澄观撰

    十回向品(从二十五经一半尽三十三经)

第六随顺坚固一切善根回向。长行中亦二。谓位行位果。行中亦三。谓牒释结。今初牒名征起。谓所修事善皆悉顺入坚固法性故。下文云。则为随顺真实住。本分名入一切平等善根。入即随顺。平等即坚固。平等之理不可坏故。若顺等理则顺诸善根故。下文云。则为随顺佛住等。又本业云。习行相善无漏善而不二故。名随顺平等一切善根。此则不唯事顺于理。理事相顺受平等名。如此平等方名坚固。此约所回善根。及所向实际。以立斯名。亦可名为坚固之善根。坚固即善根。若以随顺望坚固。善根亦通二义。即以无碍善根而为其性。第二依征广释中二。先明行所依身。二具足下依身起行。前中复二。先明得位。后显具德。今初。菩萨行檀之身。随宜万类故置或言。而偏语王者。一则在家是施位故。二难舍能舍举胜策劣故。三者菩萨多为王故。以菩萨位唯有二种。一者法王。二者人王。法王教化人王摄化。具菩萨戒处处为王故。发号施令无敢违故。具能施物遂所求故。帝者主也。王者王也。临者治也。御亦主领千乘之国。即称为大。下言为转轮王。则以一洲已去可称为大。二威德下显具德中二。先统领自在德。后菩萨下正报殊伦德。今初。有十二句。初二句总。有威则下必畏之。有德则下必怀之。故令名振。次凡诸下十句别。初句释威。祖父之仇曰怨。四夷有土曰敌。由威被故敌归怨顺。次发号下释上有德。依正施令物可则也。执持一盖等兼释临御。一盖有三。一则无私万物故。二等教十善故。下施盖中云。为令众生得自在盖。能持一切诸善法故。三慈悲盖。大光王云。如诸菩萨为高盖。慈心普荫诸众生故。以离垢缯释为帝义。于法自在释为王义。不刑已下双显威德。谓不以刑戮征罚之威。但令感德从化。则威而不猛也。又加苦曰刑。削夺为罚。导之以德义莫敢不服。则庶人无刑。齐之以礼乐。莫敢不敬。则大夫无罚。次以四摄下。显是菩萨拣异世王为转轮王。结成有位。一切周给。结有大财即财位果。二正报殊伦德。初句结前义兼生后。有大眷属下具七种果。一宗族果。二离众过失。不亢不骄发言诚实。见者无厌。有慈有慧人所信顺。即信言果。三福德已下显大色果。四获那罗延坚固之身。显寿命果。五大力成就等显大力果。六得清净业。谓得大念慧成就总持。曾事不忘未萌先觉。由斯有上名振天下。即声誉果。七离诸业障显人性果。有业报障非丈夫故。兼上财位具八异熟。是增上生。如是自在是大势生。第二依身起行中三。一明随相回向。二明离相回向。三释回向名。初即回向菩提。及向众生。次即回向实际。后段通二。又初是广大回向。次甚深回向。后兼深广。今随相中分三。初总相标列善根回向。二佛子菩萨摩诃萨随所施下。依标广显善根回向。三佛子菩萨摩诃萨随诸众生下。总结多门善根回向。今初亦三。一列所施物。二其中下辨所施田。三佛子下显行所依心。今初初句总。或施下别。别中若望下。回向应为六十。若直就文数都八十事。初从饮食至床座。为一十。以床座但通是一床。下文别施座故。次房舍至盖为二十。伞至顶髻为三十。以王位为重。为明外财施竟故。结云乃至王位。下文自有王位。后回向中此次后无故。次眼至足为四十。血至肠为五十。厚皮至救损他形为六十。示佛兴至邑为七十。从聚落至终为八十。救狱囚中虽有妻等四事。但为一救囚之行耳。于中前二十七事是外财施。次救狱囚。一兼于内外代囚命。下二十九事唯明内财。下诸门中或兼内外。或但是外可以意得。又前二十七施无乐者。是为慈行。救囚代命等为大悲行。余或通二行。若通相辨皆兼二行。又代命救残害男形。是无畏施。断杀有二。若望所杀是无畏施。若望能杀。令持五戒是为法施。告示佛兴即是法施。财施可知。又此等既并是法门。俱通三施。二所施田中等皆施与者。不拣贤愚等故。悉令满足者随所求故。三显能施回向之心者。望前是能施之心。故云如是施时发善摄心。望后是能回向心故。云发善摄心。悉以回向。故下诸门回向之内皆以此心贯之。文中二。先总明。后所谓下别显。于中所摄有五。总收上来能施所施。及以施物。言善摄者释随顺义。谓此菩萨若行于施回向之时。于自他五蕴等心无住着。不令驰散故云善摄。如此则与实际相应。便能随顺坚固善根。谓舍住着故随顺施善。无异求故随顺戒善。忍深理故随顺忍善。离色相故随顺进善。不驰散故随顺定善。了无生故随顺慧善。如是乃至一切由顺实际。任运顺于一切称性之善。第二依标广显中。粗相望前略有五异。一伞二顶前有后无。舍宅一种前无后有。即有无异也。二前以法导化。即后禁杀令住五戒。即名字异也。三承事供养前合。后开象马等事。前开。后合。即开合异也。四后文舌居牙齿之后。眷属居妻子之前。骨居肠下。饮于食后。即前后异。五前略后广。其文非一也。余皆大同。然其都门但有六十。由开合故。谓十二段。二二相合。一象马。二幢旛。三宝冠明珠。四耳鼻。五牙齿。六手足。七髓肉。八厚薄皮。九手足指。十僮仆。十一园林。十二妻子。复有二段各五事合。谓一肠肾肝肺四事。及大小肠。合一回向二王位邑聚落宫殿合一回向。故下文。云国土一切诸物。即斯五事都十四门。合二十事。虽缺二事而加二事。谓舍宅及开承事。与供侍别故有六十门。昔光统师。以后都门束前标中。亦唯六十。成一百二十门。皆有十善成千二百。以七施乘之。成八千四百。一一具十回向成八万四千。言七施者。随相有六。谓心有三种。即三时。喜事有三种。即是三轮。入理有一。即照三轮空。又以七圣财乘之。亦得如一施行有八万四千。余一一行皆亦如是。此上且约法门非无有理。若散说者行相无量。如施资具及大会等。不可言一故。次标。云无量无边。后都结。云阿僧祇物。实则皆是法界大缘起门。普贤无碍自在之行故。以一切所有施于一田。一切皆尔。一微尘处即施一切众生。遍法界皆尔。一刹那中顿成此行。尽前后际亦尔。此一菩萨满法界身。备起此行仍有纯杂。若以纯门于一施眼遍上时处。唯见施眼十方无边。初后无际余门如虚空。杂则随一施眼具足诸门。余亦如是。纯杂无碍重重无尽。故知六十八十乃举其大纲耳。文中二。初总标施行。成回向行无量之义。已如上辨。第二所谓下一一别显。六十门内一一皆四。一施行。二回向行。三双结二行。四回向所为。若缺所为则但有三。亦可合后二段为双结所为。此科宜记。下有广略至文当知。若具四段门前多不科判。今第一施食以食为世命。贵贱同依故首明之。文但有三。先明施行。言其心清净者。离施过故。谓不求名利果报为怖畏等而行施故。不贪著者是无贪思。无顾吝者是无悭思。又施时无贪着。施已无顾吝。随所施行与众生共兼于事理。名为具足。此心在初亦贯下诸段。二愿一切下回向行。然其所愿。正为众生令得成佛。即向菩提也。下皆准之。然阿含唯识等说世间食。总有四种。一触。二思。三识。四段。说出世食有其五种。一禅悦。二愿。三念。四解脱。五法喜。今翻四成五。一翻思食成智慧食。即是念食。念慧邻故。二无所贪下。翻于触食以成法喜。触以摄受喜等能为食事故。但愿法喜。其出离食即解脱食。总离四故。三智慧充下。翻于识食以成禅悦。禅则不动故。以法坚住引生功德故。摄取善根能除烦恼故。二身清净并如识食能执持故。四哀愍下。大悲愿力现受段食。今云抟者尚依古译。三是为下双结二行。第二施饮中亦三。初施行。二以此下回向行。于中先牒前起后。后所谓愿一切下别。显愿相下皆仿此。然望食虽异不离五食。望水虽异多同水用。故所愿事。或翻或顺。或敌体相似。或流类以明。不全克定。文中。一如饮无间易得充足。饮法精勤速具大道。余并可知。第三施味文四。加所为故。初施行可知。二以此下回向行中十愿。初愿晋经得上味相。则是三十二相之一。经说佛大牙后有甘露泉。但食入口悉为甘露。约法亦即涅槃。为甘露不死之味。余文并显第四施车乘分三。初施行者。义通马等。以第十六别施车故。回向十愿皆约代步。初一唯果余兼通因。然乘体性通于理智。随义立名。一体性包含。二不可废立。三超劣。四无过。五不历三祇。六十力普运。七兼五度万行。八无漏相应。九发心趣者即名菩萨。第五衣中。瑜伽施衣能感妙色。以衣御寒令颜色润泽故。人新衣成。暂持献佛得无量福。若要期日。数未满而取成取佛物。第六施华文四。初施行中先列施物。后供养下明所施田。下至自身者身为福田。是法器故。依之进道故。故施自身胜施外道无量。回向十愿前七可知。八赤莲华等不遇日光。翳死无疑。菩萨之行必资乎智。涅槃第九云。譬如莲华为日所照无不开敷。九月开青莲华佛智照行。涅槃二十云。譬如月光能令一切优钵罗华开敷鲜明。十约宝华。后二段可知。第七施鬘者。贯华如环而为首饰。或以缨身故。未见则乐见。正见则爱乐。第八施香中。准下涂香十度万行皆香。此偏语戒者翻破戒之秽故。愿有十二。初一总标。次十别显。少同十藏多同智论。随宜不同但案文释。一具持三聚。二不杂外道。三无染心。涅槃经中乃至染环钏声。亦名污菩萨戒。四不犯重故。犯重之人多生悔恨。五设有误犯深惭愧故。如其故犯数犯不生惭愧。深爱着犯见犯是福。名之为缠。六七定共相应故。无惑热常持如初。八九道共相应离断常边。成出世行。十远离二乘。圆修十度。方名不犯菩萨律仪。是智所赞戒。末句结因成果。谓五分之一。第九涂香十度皆有熏发。资长菩提心义。辟除蔽障。俱得称香。第十施床座中初举施行。下第十八别明施座故。晋译此以为床敷深允当也。回向行中十愿。一即第一义天大智证故。二菩提心是贤圣依。三涅槃解脱。四首楞严定名为究竟如。四禅座能发神通。余六可知。十一房舍中。摄取一切诸佛所住。谓圣天梵等。后言不舍佛最上住者。住大寂室余取事类。例可以虚求。十二住处。谓僧坊等。十三施灯。一明施行。于中列其施物。宝灯者如夜光之类。沉水栴檀用和酥油。无量色者。然膏色白。然漆色赤。然油色黄。然檀色绿。如是种种。如是等下明其施意。二以此下回向行。于中先正显回向愿。后辨回向意。前中十愿。然准瑜伽贤首。皆明施灯得净眼报。然灯功德经。烧灯供养大能灭罪生福。令发愿言。当以大海为油。须弥为炷然大灯明。遍佛刹海供养无休。又愿法门之灯大愿为炷等。今文愿中。具身智光并可思准。后菩萨如是下。显回向意三。是为下双结。四如是回向所为。其回向意。诸文应具。大同所为故略不明。十四汤药中三。一施行施药。近果得无病报。如薄俱罗。远得药王树身等。如十大愿中辨。二回向行。言不重发者。经云世医所疗治虽差还复生。如来所治者毕竟不复发。余可知。三菩萨下。双辨二行所为。言金刚围山所不能坏者。如不思议法品。十种大那罗延幢勇健法中。第一说。坚固满足力。亦是彼品中。十力第七名坚固力。不可夺乐者是常乐故。自在坚固身者即金刚身。金刚为内照之实。非唯金色故云自在。十五施器中文四。初施行中三。一所施物。二或施下对田显施圣僧通三乘。三如是下成波罗蜜。二菩萨下明回向行。十愿。一广。二深。三高。四坚。五胜。六净。七果。八悲。九熏闻纳教。十摄法上首。然随施一器即发多愿。未必一器以对一愿。三结四所为可知(从此已下入第二十六经)十六施车中二。先标列财田。后佛子菩萨摩诃萨以如是下。随田别显前中三。一总标所施。二奉施下别举福田。于中先辨类。后此诸人下彰其来意因缘故。来者往昔有缘应受施故。三菩萨是时下。别列所施。以明施行问。瑜伽三十九云。若有众生。来求种种能引戏乐。能引无义所施之物。不应与。今施美色岂不相违。又云。施妻子时。不应施与怨家恶人药叉罗刹凶暴业者。今云种种福田。岂皆施与。答能有二。谓必知能为损恼不施无咎。若不委知。但作利安之心施亦无咎。况菩萨能知无染。又同行之女必不生物染。又女能以法而化彼故。故摄论中。有利有染无利无染有染无利。此三菩萨不行。有利无染菩萨乃行。第二随田别显。约五类田则分为五。一一段中文皆具四。今初。施佛。先施行可知。回向行中有二十愿。初十约所施佛田立愿。后十约所施车立愿。并显可知。但云修安乐行者。法华安乐行品说四安乐行。一毕竟空行。经名行处近处。已入于理而履行之。名为行处故。经云。又复于法无所行。而观诸法如实相等。虽未入理能远诸恶。亲而近之。名亲近处故。经云。不亲近国王及外道等。为远恶也。观一切法空为近理也。二名身口无过失行。三者心无嫉妒行。四大慈悲行。广如彼说。然安乐者略有二意。一涅槃之果名为安乐。此行能趣即安乐之行。二住此四行则身静神定。身静神定则外苦不干。故称安乐。又常见外道因果俱苦。断见外道因乐果苦。析法二乘因苦果乐。唯有菩萨因果俱乐故。涅槃云。定苦行者谓诸凡夫。苦乐行者谓声闻缘觉。定乐行者。谓诸佛菩萨。因果俱乐名安乐行。三结文中。加及佛灭后。所有塔庙。塔安舍利。庙置形像。塔者正云窣堵波。此云高显。亦曰归宗之所。言所有者不局佛塔故。长阿含说四种人应可起塔。一佛。二辟支佛。三阿罗汉。四轮王。十二四缘经云。八种人应起塔。一佛。其露盘八层已上。余七谓菩萨缘觉四果轮王。次第减一层。轮王唯一层。见一层塔不应礼拜。非圣人故。僧祇律说凡僧亦许起塔。然不得安露盘。令在屏处。谓一持律。二法师。三营事。四德望。今造塔者宜审此文。泛论起塔总有六意。一为表人胜。二为令生净信。三令标心有在。四令供养生福。五为报恩行毕。六生福灭罪。若造佛塔近招梵福。远脱生死故。无上依经。供佛舍利如芥子许。悉得究竟脱生死苦。二施菩萨中有二十愿。前十约所施田发相似愿。后十约所施车发相似愿。并显可知。三施僧。初施行中显十施心。一财无不舍田无所拣。二了事可不。受畜不净不应施故。三净三轮故。四顺檀行故。五因佛有僧佛难遇故。六依僧知佛故。七依僧知教故。八应景慕。九不局一僧。十由教说僧故。二回向行中。有二十愿。亦前十约田。后十约车。其十三云。乘虚空身者。当其无有车之用故。四施二乘中亦四。初施行中言如来势力生者。设是独觉亦由曾习佛法。后道成无佛世故。六七翻彼三生百劫故。二以此下回向行中。亦二十愿多翻劣显胜。前十多翻缘觉乐独善寂等故。无诤有二。一人嫌我行。我则长立等。二观缘无性无乖违故。后十翻声闻。一翻彼小乘。非究竟灭罪之法。彼犯律仪容可忏灭。犯四重禁为不可救。大乘至教无所不灭。佛名经说。一闻佛名。灭无量却生死重罪。涅槃第十云。若犯四禁及五逆罪。若为邪鬼毒恶所持。闻是经典所有诸恶悉皆消灭。又云。犯四重禁不还生者。无有是处。如是等文处处皆有由曾所未闻大经力故。二声闻虽从佛闻未悟深理故。三不能广传故。四望于大乘犹是邪故。所以诸处多说九十五种。别有九十五种外道邪论经。今言九十六者。自有二义。一依萨婆多律说外道六师。各有十六种所学法。一法自学余十五种。各教十五弟子。师徒合论有九十六。二者外道有二。一外外道。即佛法外。二内外道。此复三种。一附佛法外道。起自犊子方广。自以聪明读佛经书。而生一见。附佛法起故。得此名犊子。读舍利弗毗昙自别制义。言我在四句。外第五不可说。藏中佛说此人不异外道。诸论皆推不受名外道也。又方广道人自以聪明读佛十喻。自作义云。不生不灭。如幻如化空幻为宗。龙树斥言。此非佛法方广。所作亦邪人法也。二学佛法成外道。谓执佛教门而生烦恼。不得入理故。智论云。若不得般若。意入阿毗昙即坠有中等。三以大斥小故。七卷楞伽第一云。大慧云何为外道恶见。谓不知境界自心分别现。于第一义见有见无而起言说。又第二云。复有说。言见一切法因作者有。此是涅槃。大慧。彼无解脱。以未能见法无我故。此是声闻及外道种性。于未出中生出离相。应勤修习舍此恶见故。诸大乘诃彼二乘同于外道。非夺方便之意。今合后三总为一类。成九十六。依此义故。发愿永离。七中得目见者。非闻见故。余可例知。五施诸田。初施行中有悲境故。加以拜跪等言。以有劣田重举妙物。最下乞人等如来故。言袨服者。大盛玄黄之服也。二以此下回向行。亦二十愿。施田非一故。但就车发相似愿。其中亦兼所施女等。可以意得。六云十出离道者。即是十地以十度行。出十重障离十粗故。七乘四轮乘者。文中自列。然庄严论第六名四种不放逸轮。先辨相者。各具五种因缘。一住好国土轮者。彼名胜土轮。言五缘者。一者易求。谓四事易故。二善护王。如法故。三善地处。调和故。四善伴。同戒见故。五善寂。无喧声故。二依止善人轮。五缘者。一多闻。二见谛。三巧说。四怜愍。不贪利故。五不退。无疲倦故。三集胜福德轮者。彼当第四名先福轮。一可乐。由住胜世为因故。二无难。由值善人为因故。三无病。四三昧。五智慧。此三以自正轮为因。四发大誓愿。彼当第三名自正轮。故成实论名自发正愿轮。一善缘。妙法为缘故。二善聚。具福智故。三善修止观。诸行相应修故。四善说。无求利故。五善出所有。上法恭愿修故。然前二就果立称。后二从因立名。虽俱通因果影略互显。前二外缘后二内因。愿是智因福是福因。此四何因受轮之称。依成实论。以此四轮能摧八难故。谓初住善处能除五难。即三涂北洲。及长寿天。次依善人除佛前后难。三发大誓愿除世智辩聪。四宿植善根除主盲聋哑。前五是恶处。六是恶时。七是恶因。八是恶果。已知四轮。云何总名为乘。瑜伽论说住好国土。谓得人天身出诸难处。以为车体。二由集胜福。诸根完具如车毂轴釭锏。可施脂膏。三发大愿如良牛引重致远。四依善人。谓佛菩萨如善御者。由具此四成大涅槃故。云成满一切清净梵行。因圆必至果也。若依此经。国土即十国土海。善人即十身如来。胜福即性起功德。大愿即普贤愿海。共成无尽大法界缘起车也。余并可知。十七施象马二事。合有十愿。一如性调顺。二如随意所往。三似彼盛壮。四如超步万里。五犹行步平正。六如彼象宝。七似彼如华。八即迅疾如风。九上云调顺通显增于功德。今云具菩萨地名最胜调象马。各有调义故分二愿。十似彼上立金幢。十八施座回向中。言三种世间义如常释。辨法师云。地前为愿乐世间。初地至七地名功用世间。八至等觉名无功用世间。有云。西域相传。众生界中有三世间。一地下世间龙修罗等。二人中世间。三天上世间。若依智论。三世间者。即众生五蕴及器为三。于彼显胜义皆无失。余并可知。十九施盖中。本行经。说编草为盖七宝盖随。况众宝严功报何极。四所为中有十为令二十又欲。皆令众生因圆果满。触理皆盖方显菩萨悲智深妙。可谓随顺一切善根。并可虚求。法门浩大不可具释。二十幢旛二事。合一回向十中初二。幢旛合愿。一建善翻恶。二重法翻慢。次一唯就旛旛书字故。后七皆就幢辨。二十一开藏施宝。回向行中言十六智宝者。辨法师云地前。明得明增印顺无间等四定。地上。光明集。福德王。贤首健行等四定。此八各有自分胜进。依此发智为十六智宝。有云。佛地四智。智各有四。故为十六。以果位自在互融通故。今依贤首即是八忍八智。然此有二。一依观能所取以立十六。一苦法智忍观三界苦真如。正断三界见苦所断分别随眠。二苦法智。谓忍无间观前真如。证前所断烦恼解脱。三苦类智忍。谓智无间无漏慧生。于法忍智各别内证。言后圣法皆是此类。四苦类智。谓此无间无漏智生审定印可苦类智忍。前二观如后二观智。苦下有四三谛亦然。为十六智。二者依观上下谛境别立。谓观欲苦有法忍法智。初即无间道。后即解脱道。次观上二界苦为类忍类智。类同欲故。如苦既然余三亦尔为十六智。广如唯识杂集第九所明。第十愿言无上宝主者。佛为法宝之主故。二十二施庄严具中十愿。初一利他后九自利。于中初三约身次三约语。后三约意。其中言百福相。前文已引涅槃二十四说。依瑜伽五十三。名百福行故论云。复由百行所摄律仪。谓少分。离杀乃至邪见为一十。二多分离杀等。三全分离。四少时离。五多时离。六尽寿离。七自离。八教人离。九以无量门称扬赞述离。十见离杀等深心庆悦。生大欢喜。十门各十。总说为百行所生福量亦尔。此且就同教三十二相化身而说。若依此经十身相海。随一一相无尽因成故。上普兴云幢主水神偈云。清净慈门刹尘数。共生如来一妙相等故。余可知。二十三施宝冠及髻珠二事。合一回向。六智慧明珠等者。体圆德备鉴彻惑亡。为智明珠。极果所宗故名顶上。是秘是妙无能见者。亦以权隐实名在髻中。开权显实故名解髻。文无解义因便故来。若不明解佛有秘藏前后。可知。二十四施妻子等。救狱囚者。上来皆明外施。此下二段明无畏施。初一兼于内外之财。内财为难故。佛本行经说。昔五百长者子。各舍珍宝等施。有一贫人。问求何愿。云欲求佛道。遂自念贫无以蜜涂身。冢间而舍。天帝试之心安不动。知求佛果而称赞云。汝此勇猛过彼五百菩萨所施百千亿倍。当先作佛。彼贫人者即我身是。故知难中之难。施行有三。初睹境兴悲。二如大悲下指同先例大悲即观自在也。以其偏主此门故。下文引例皆准此知。后既救度下施以财法。回向行十愿准思易了。二十五舍身代死囚。一向内财。文四可知(从此已下入第二十七经)二十六连肤顶髻即肉髻也。施行中三。初总标施行。二如宝髻下指物同修。三菩萨是时下正明施行。于中六。一睹乞生欣住种性故。二而语下语意清净。离二障故。三便执下身业正舍。事业胜故。四正念下欣慕上流。意乐胜故。五于诸法下巧安谛理。无相摄故。六是故下决志思齐。依止胜故。此及回向有七最胜成波罗蜜。前后诸施文多略无。二菩萨下回向行中十愿。一无见顶者。纵穷上界亦有余故。言如塔者菩萨敬故。二坚无中断故。五中静法云。准梵本令得二相发谓室利靺蹉塞缚悉底迦相发。义如前说。六云得佛相发。准梵本却是右旋。余可知。回向所为中。总绾诸发成髻圆满故云尔也。二十七施眼。智论十四说。施有三种。饮食为下。珍宝为中。头目五脏为上。广如彼说。文中施行内有四。一标章引例。二菩萨摩诃萨下发起胜心。三为究竟下明行心所为可知。四佛子下彰施仪式。二回向行愿成十眼。与离世间大同小异。二十八施耳鼻中。二事合明施行。别显回向而文但三。今初。施行有二。一标章引例。二布施之时下安住胜心。一具佛种性即安住最胜。二念诸下事业最胜。三常勤下依止最胜。四随顺下清净最胜。五免济下意乐最胜。六生长下巧便最胜。二回向行中。先耳十愿。初及第七俱名无碍者。准梵本初名无著聩者。从生即聋故为耳王者闻与不闻皆自在故。后施鼻回向中有四。初牒起。二正显中有二愿。前一愿得十鼻。言随好者两孔不现故。善相者。相海品云。如来鼻有大人相。名一切神通智慧云故。随顺鼻者。随宜所现故。后一愿得十面。鼻居面中好丑由起。故相从立愿。一切法者正向诸法故。三是为下结。四为令下回向所为有十。以鼻香气所入故。摄受香故。了知故。住于觉故。如眼见色故。合中知故。不坏鼻根故。不邪分别故。香气严洁故。五分法身香故。二十九施牙齿。初施行中。安住坚固。自在位者。登地已上故。智论十四云。象王施牙是法身菩萨事。广如彼及十轮第四。二菩萨下回向行十愿。唯第三单约心说。谓智能调惑趣于彼岸。如牙调食以资法身。余皆约牙齿说。万字成就者。准梵本但云右旋及有乐耳。放无量光者。即如相海品说。三十施舌愿中。初即相海品广长舌相余可知。三十一施头。初施行中三。初标章引证。引迦尸国王者。又本行经说月光王报恩。第五名大光王施头与婆罗门。具说如彼。次为欲下。显施所为为有十种。皆约佛智随义不同。一入理。二导悲。三见事。四离障。五融事理。六为所依。七超劣。八见无初相。九现用自在。十即事而真故不可坏。后佛子下正显施行。亦具最胜可以意得。二菩萨下。回向行等可知。三十二施手足二事合愿。文但有三。初施行亦三。初标章引证。次以信下标因祈果。信为手因果能雨宝行为足因果普游步等。后佛子下净心正施。于中初施手。心愿力已下明施足心。如足住地能持身故。愿住智地能成智身。离心垢故。能显法身。法身湛然故不可坏智。证永续故无有断。二佛子下明回向行。文二。初广辨一用。手能雨宝足能游刹。次又令下略举诸手诸用。三十三坏身出血施。文亦唯三。施行引例。及下施髓并如智论十四中说。三十四施身髓肉中。二事合愿。初施行中三。初标章引证。次于诸趣下正显行相。后佛子下彰施现益。二回向十愿。三云意生身者。七卷楞伽第二云。譬如意去速疾无碍。名意生身。此乃意是举喻。然此身类有其三种。一三昧乐。二觉法自性。三种类俱生无作行。初者楞伽第四云。谓入于三昧离种种心。寂然不动。心海不起转识波浪。了境心现皆无所有。云何觉法自性。谓了法如幻皆无有相。心转所依。依如幻定及余三昧。能现无量自在神通。如华开敷速疾如意。如幻如梦如影如像。非造所造。与造相似。一切色相具足庄严。普入佛刹了诸法性故。云何种类俱生无作行。谓了达诸佛自证法相。释曰。初身从所依定为名。次身从所依智立称。三自证法相。义兼定慧及法性相。故名种类。由此故能随众生愿种种一时现生。任运而成。云无作行。若依地位。初即五地前。次即八地前。后即八地后。若成唯识第八名为意成。随意愿成故。意明但转变成。非新生故。故论又云。亦名变化身。无漏定力转令异本。如变化故。上皆通因。今即十身之一。义取亦通后一。广如别章。四云百福相身。此举三十二相之通因。若别因者。如涅槃师子吼品五云。八十种好者。谓皆殊妙立随好名。具如瑜伽四十九。大般若三百八十一说。余文可知。十云菩提藏身者。如出现品。如来成正觉时。于其身中普见一切众生成正觉等故。三十五施心。初施行。二回向行中先辨意。后显愿有二十心。初云金刚藏者。藏即名坚。其犹树藏金刚亦坚。即佛地智世法莫坏。如不思议品十种勇健法中第一法说。二中外标卍相。表万德吉祥。内智契如名金刚界。界者性也。由契性故坚如金刚不可损坏。由成智故利如金刚坏难坏惑。故十地受职分内。名金刚庄严臆德相。不思议法品及离世间。皆有此心名大同也。第九回向及离世间。又名金刚界根金刚焰根。亦即此名以清净心王。于无分别智有所依增上义。故立以根称。其大勇猛幢取降伏义。言坚固幢。取不为他坏义。被金刚甲是大誓义。余并可知。三十六施肠肾肝肺。四事合一回向。前有大小二肠。今合为一肠言智藏身者。身为智依故余可知。三十七支节诸骨。前云骨髓。髓已前明。而加支节诸骨。若合者但是一事。谓支节之骨。若开支节自是一事。如节节支解等。即前列所无。回向行中言无系界者。即涅槃界。言具那罗延支节大力者。如涅槃校量言普照现身者。如净明镜无不现故余可知。所为中言得智者。智为万德之骨故。三十八施身皮。引例中。清净藏菩萨未见同名。智论十六中。如毒龙受一日戒。被剥五色皮忍而施之云云。言金胁鹿王者。智论及菩萨本缘集经第四说。金胁鹿救于溺者。彼人背恩告王取鹿。大例名同而非施皮。愿中云相好皮者。谓金色等。所为云净佛刹者。皮为外相故。三十九施手足指。回向十愿。纤长者量。佣圆者形。赤铜者色。能摄者力。此以智为指。随好者妙。言十力者随一一指能持一切世界等。齐等者不参差。轮相等者。准梵本云。愿一切众生得十指端。里面皆有千辐轮相。所余节中裹面。皆有本那伽吒及以塞缚悉底迦相。相间庄严准此则圆满之言应云满鉼。右旋之言应云有乐。若准观佛三昧海经。一一指节端有十二轮相现。八中准梵本。愿得大莲华难提迦物多相指。却是右旋。十力业报者。亦十种大那罗延幢勇健法也。相即纤等好即殊妙。有云。卍字旋者约中文也。准三昧海经指端各有万字相。万字点间有千辐轮相。网缦者。经云敛指不现张时即现。如真珠网分明可爱余可知。所为云得清净心者。得指由心故。四十施连肉爪中。言赤铜相者。即是小相。五无比者。事爪则不染尘垢。智爪则不染境相。言善生者善业生故。有云。西域方言。谓善生为端正余可知。所以求法偏语施爪者。一则以引例中有现事故。下入火求法亦准此通。二有所表。以爪能[國*瓜]取顺求义故。下入火求者表难取故。故智论云。般若波罗蜜犹如大火聚。四边不可取。无取亦不取故。四十一求法入火。施行中言七仞者。一仞七尺也。回向行中。初及第九约求法为愿。余约入火为愿。四十二为求法护法受众苦者。如香城粉骨雪岭忘躯。其类非一。四十三求法舍海内所有。即舍王位所统也。回向行中言疑箭者。如涅槃说人中毒箭应速拔之。若妄分别未究而终故。四十四为王断杀等。施行中自住三聚净戒。令他住于五戒。是为法施。五戒杀初故。此偏语。若望所杀是无畏施。四十五救于形残。初施行中具足三施。于中三。初睹境兴悲次菩萨尔时下以法谏喻。后作是语下财法双救。财救所害之现苦。法救能害之当苦。示寂静灭修净业道。灭集因故。俱舍论说。昔有黄门救五百牛毁形之事。善根力故男形具足。二回向行中。修诸梵行未必制心。后离欲心必无身过具男子形。但异女身具大丈夫。必心坏道德。四回向所为中。初令得果。后常勤下令得起行。丈夫行者。涅槃十八云。一切男女若具四法。即名丈夫。一近善知识。二听闻正法。三思惟其义。四如说修行。又四相品具四相故。名为丈夫。又云。虽是女人能信自身有佛性者。即是丈夫故。男子不信即是女人。显示七丈夫道。即丈夫用道字。梵本名为揭底。此云事业。晋本。云丈夫趣与道相近。然七丈夫总有多说。一约世间。瑜伽丈夫有其七义。一长寿久住。二妙色端严。三无病少恼。四非仆非女非半择迦。五智慧猛利。六发言威肃。七有大宗叶。具此七法名为丈夫道。即是彼之因也。即下所列六句小有开合。可以思准。前令具丈夫形即非女等也。二依小乘有七丈夫。即七贤圣。一随信行。二随法行。三信解。四见至。五身证。六慧解脱。七俱解脱。离世间品当说。此应不愿成彼小乘。三依大乘。瑜伽七地即七贤圣。如十住品初说。四依璎珞六位及信即上生贤圣家。复有说言。即七善知。谓知法知义知时知足知自知众知尊卑故。佛丈夫种。所谓大悲成十力等。为佛丈夫。丈夫正教即内三藏及外五明。余文易了(从此已下入第二十八经)

大方广佛华严经疏卷第二十八大方广佛华严经疏卷第二十九

        唐清凉山大华严寺沙门澄观撰

四十六叹佛出世。如上大威光童子偈声是告等。初施行者。即法施行。于中三。一见佛兴世。二以大下法施益生。三尔时下结所成益。二中四。初令闻名离惑益。二复更下见身起行益。三复为下赞希增敬益。四复于下展转增长益。结益可知。二回向可知。四十七施大地中但通相言也。初施行中略列诸田。实通一切。言别人者。有资财人非敬非悲故。菩萨通于一切善知识。要在益我。于中佛塔菩萨知识。父母是恩田亦敬田。众僧二乘是德田亦敬田。贫孤是悲田亦苦田。此等皆能生福如世之田。若敬田有病。则亦敬亦悲。乃成四句。故智论十四云。一怜愍施。谓于贫穷下贱及畜生。二恭敬施。谓于佛及法身菩萨等。三怜愍恭敬施。谓于老病贫穷阿罗汉辟支佛等。总收为二。谓悲与敬。其非敬非悲亦悲田摄。无德可敬故。然此二田以理御心则等无优劣故。净名云。最下乞人犹如如来福田无异。无所分别等于大悲。若直就境论。则敬强悲劣。以恩深德厚故。如校量功德经说。若就于心即悲田为胜。亲引悲故。故敬则田强而悲心弱。悲则田弱而悲心强。各有其美俱为良田。若等是敬田恩则胜德故。校量经云。供百罗汉不及一生身父母阿含中。说供养父母共一生补处功德齐等。若同是恩田。在家人则父母恩胜。出家则师僧恩胜。如舍利弗请问经说。或约生色身及生法身。则优劣可知矣。等是德田别不如普故。梵网经说。别请五百罗汉菩萨僧不如僧次一凡夫僧。又由主财田异。感报胜劣种种不同。恐繁不载。然今此中菩萨施心。悲智齐于虚空。事物穷乎法界。施田凡圣尽于十方故。三事性空深无底。三事殊特胜无比三事广大遍无涯。三事相融俱无碍。二回向行中初一果地。余九因地各相似义。如理应思。四十八施僮仆。少美曰僮以拟瞻侍。执守曰仆以备劳役。然不放之。从良而施与人。还令成仆者。以菩萨行海无善不修。若唯放从良有三义缺。一行海不具。二彼仆本愿不满。三佛果。缺此应机之德余可知。四十九施自身为给侍。二回向行中有二十愿。前十进善后十住持。五十闻法喜悦舍身供佛。初施行者。即财法二供。文中三。初标行体。二欣乐下别显行相。初自利行。后能以如下利他行。三佛子下结行成益。五十一以身普施一切众生。施行中亦具事法二施初总标。后菩萨下别显。若约事则身为日月光明河池井泉。以施于物。以三种世间身得自在故。若约法施。则法灯照耀法日利益等。文中或法或事。而义实两兼。二回向行中。上之施行。以身就生等翻愿众生以身近佛等。随义思之。五十二施身给侍诸佛。初施行亦有身侍心侍。二回向行亦依二侍立愿。五十三施国所有乃至王位。初施行中先明事舍。后于诸下明其心舍自在是总。下十句别现弃万乘。犹如脱屣何系缚哉。余义见十藏品。五十四施王都城可知。五十五施内宫眷属。初施行中二。一女丽具德。二而于下明施心清净。二菩萨尔时下明回向行。文分为二。初回向意。二正显回向。今初以历事将终文势稍展。此一段文贯于前后。然晋经回向二字皆在句初。则是回向菩提意也。今经在于句末。则是回向之意。然回向意与回向所为。大同小异。小异云何。谓有此意故所以回向。今回向者为成此故。又意则多通诸行。所为别约施行。言大同者意为此故。就文又二。初正显回向之意。文有十句。后佛子下重牒前意欲将回向。初句总指上意故。云住如是法。生如来家下从后倒牒。亦有十句。一牒入佛家。二胜因即出世善。次五可知。八善巧者谓不坚易坚。九修习者是得法喜。十常摄善根为令出离。西域文势义多如此。反腾前辞。二菩萨尔时下正明回向。文有十愿。随一一愿具前十意。十愿皆云三昧者。禅定轻安身心柔软犹彼女故。故善财偈云。定女常供侍。三结四所为并可知。五十六施妻子二事合愿。初施行中二。先标章引例。须达拏者此云善爱。或云好爱事。如彼经。现庄严王如大庄严经说。又如菩萨本缘经说。一切持王子施二子等。二菩萨尔时下明能施心。于中初自分所依。后菩萨摩诃萨下胜进所为。初结前生后。次自观下观身不坚。况于妻子。后又以下而修坚固二利之法。二佛子下明回向行。有十一愿。初一依于施心欲令普遍故。次二依妻立愿。次三及后一依子立愿。生自己心。如己骨肉等故。余通依上三立愿。然所施化实应成四句。一乞者是化所施为实。如贤愚经说。毗沙门化作夜叉从王乞子等。此破菩萨执故。二乞者是实所施是化。如摄论说毗荀陀王舍子与婆罗门。是化无恼。以菩萨方便满乞意故。三者俱化旁警众生。四者俱实。复有二种。一始行者。欲将施时再三本问故。瑜伽三十九说。施妻子时先当晓喻令喜。终不强逼令其忧恼。于来乞者。虽以正言晓喻不施怨家等。二根熟者。其所施人。多与菩萨同结志愿。互为主伴。今将为施遂本所祈故。下经。云生生行施处愿常以我施。五十七施宅舍可知。五十八施园林等。施行中二。先标起念。后佛子下离过成德余可知。五十九设大施会。初施行中初总标。次一切下离过成德。择薪而爨滤水而用。不强乞求名不恼众生。今多反此岂成大益。次开置下略显仪式。次发甚难得下显施所依心成波罗蜜。六十施资具者以别说诸门不可尽故。末后总说一切资具。文但有二。一施行。二回向行。以邻后都结故缺后二。今初有四。一施时离过。二善思惟下辨施所依。三随诸众生下正明施行。四行此施下显所成德。二佛子下明回向行中二。先牒前起后。后愿一切下正显显中十愿。资生多种愿亦类别。一施洗涤资具愿。二施扫拭资具愿。余可准思。又资具总明愿亦总发。未必别配。上来依标别显善根回向竟。第三从佛子菩萨摩诃萨随诸众生下。总结多门善根回向。别不可尽故。此总明文分二别。先结善根即前施行。后佛子下结前回向。今初分三。一结施物。谓菩萨所施非止六十。故等以僧祇。二为令下结施所为。三时十方下结能施心。二中文含二意。以初贯后即是所为。若依大悲等而行布施。是施所依。所为即通为自他所依。则自心所住。瑜伽三十九云。又诸菩萨。于诸有怨以慈意乐。而行惠施。于诸有苦以悲意乐。于诸有德以喜意乐。于诸有恩亲善同意以舍意乐。而行惠施。当知。亦名菩萨巧慧而行布施。文中初句总。后大悲下。别显不断之相。谓以四等心而行万行。为相续不断。初悲次慈不断。一切下明其大舍。后段广明大喜。又下离相亦是大舍。三结能施心中四。初对多田生喜离过。二时诸乞下明其田弥多其喜弥广。三假使下校量显广。略举十王所受之乐。不及菩萨喜乐之心。其中色天缺于光音。若依璎珞。十五。轮王则二禅王。当第十三。应言王二千乐。若王三千。即当第十四觉德光相轮。作三界王。当等觉菩萨也。又依十大数不可思后。有不可量。今文缺此。则似梵本脱于二禅。四禅已上虽舍受相应地无报乐。而有定乐。凡是禅定皆有轻安适悦之乐故。又五那含分有解脱乐故。无色界中报非显现。故此不言。若依大丈夫行论中。菩萨喜乐过于世间及二乘涅槃。今但过世间者。净居天中兼二乘乐。四菩萨摩诃萨下结喜广深。何等菩萨见乞生喜。谓施行熟。故施障尽故。言施障者。瑜伽三十九云。又诸菩萨于施障及对治如实了知。施障有四。一先未惯习。二施物鲜缺。三耽着上妙物。四欣乐当来具足财果。云何对治。若现有施物乞者现前。而施心不发。应观此心由往习故。今若不施。后世之中定背施行故。应励力思择而行惠施。二观宿业过。今受饥渴乏少之苦。尚应亡躯。况有少活命而不行施。三应观妄乐能生当苦。四应观当果。是邪果报速灭离散。求大菩提。第二结前回向。回向随义已具上文。今但结其回向所为。则显前来别。别回向不出于此可知。大文第二佛子菩萨摩诃萨。以诸善根如是回向时下。离相回向即向实际。行称涅槃。此彰行深前彰行广。深广同时言不并彰耳。文分为二。先正明离相。后菩萨如是观察下不碍随相。前中三。初略标。二无众生下别显。三何以故下征释。今初三句解脱是总。不着于解不系于缚。是真解脱。二别显中分二。一内绝想念故无缚解。二佛子下。触境离染故无缚解。今初分二。先明绝想。后如是下彰其行成。前中又二。先绝我想。但法上妄执故。具如前释。后无有想下绝其法想。前段以法夺我。今则以我除法。既无有我则无我所故。法我无碍。文有六对。一不于法体起增减想。二于法时离三世想。三于分位离流转想。四于法义离断常想。五于影像离依处想。六于法本遣心非心想。无知所以下经自释。今且略明初对为总。言无有想者。有即空故。二空一味等无差故。言无无想乃有五意。一以事例。无有法触目尚不生想。无法无物安可念耶。二者相无来去故。谓有本自无非有去无来。即以此义则无可无也。故无无想。三者有即非有。不可谓之为有。况得言无。则言思道断。四者假非有。以遣有非谓有于非有。故复遣之。五者以是法无我理非是断无。必不碍有故无无也。故下释。云非有非非有矣。有无既寂俱及俱非。岂当有寄。余对例知。末对总结前有无等想。总名为想。一切都绝是曰无想。假非想以遣想。非有非想故云非非想。余义例知。二显行成文有五对。初对为总。由绝如是我法想故。无有缚解。谓非想故非缚。非非想故非解。下四对别。初对唯语于缚。但因果之异。由无作者及受者故。次对双显缚解。由无有无等想故。即显上来有分别业无分别业。二皆绝故。次对双显二业行俱为思行。后为思已。后对亦双明缚解即思所依。王有心则生死波浪。无心则同乎外道。又以无心为是。则未免于有。故皆非之。第二触境离染。无缚解者文分为三。初明无著次辨不缚。后明不解。心染于境故名为着。由境缠心故名为缚。楞伽云。心缚于境界觉想智随转。此之谓也。离于心境故名为解。今初无著中。初牒前起后。谓内无想念。回向之时。则于诸境心无所著。文有十六句。初十句五对。显界处空故不染着。内谓六入外谓六尘。次对兼前即十八界。能缘是识所缘通于内外。因果一对。即界处为缘所生之法。法与非法总显诸法。通其三义一则有无。二则善恶。三则性相。已如上辨。末后一对别语业体性相。后之六句显不着蕴。大般若中观色等有三。一相二生灭三无生灭。今不着前二。即契无生灭。不着色者即是色相。知色缘成如聚沫故。不着生灭者。生无所来灭无所至故。由此则入无生灭理。后之四蕴但相有异。余二并同。已遣三科则无所遗矣。二佛子下明其不缚。缚着虽异义不出前。三若能下明其不解。若本无缚其谁求解。离缚取解未免于缚故复遣之。遣之又遣以至无遣。傥然无寄理自玄会矣。三征释中。先征意云。设我假立法体不无。今无念着其故何耶。后释意云法性尔故。文分无二。初总显法体离相。后非一下别彰所离。今初先显法体。无生故不可取着。即般若中第三义也。三世求生不可得故。从无而有故名为生。已生已有不可名生。如母已有不名生故。未生未有亦不名生。若未生名生。众生菩提应名为生。诸未生法悉应名生。现在之法刹那不住。恒属已未。离于已未无别现故。为生之理不出三世。三世既无生将安寄。既无有生则亦无灭。无生无灭则无境可取。于何执着。次应问云生是能生之相。可许推无所相。法体岂应非有。故复释云。一切诸法自相如是。离生灭外有为法体不可得故。从缘而生相即无相故。生即无生故。此显相空。次应问云。法从缘生相可触目。云何言无。故复释云。从缘而生无自性故。此显性空。自性相离双结上二。又显法本自离非推之使离。二别彰所离者。上但云离。为离何相谓一二等。文有十对。初二约数。次二约量。外望论大小内望论广陜。次二约理智。浅深约事理静论语识智。次二约教法。处非处者邪正教相对。法非法者善恶相对。后二约体相。初对约体。色心之体不可得故。离色心外非体之法亦叵得故。后对约相。为法之相不出有无。设非有非无。若有此者亦不出有。若无此句亦不出无。但遣有无万法。斯寂由离性相故触法斯非。第二菩萨如是观察下。不碍随相者。凡情封执触言生滞。闻于离相。则谓乖前随相之言失于业果菩提之行故。此略为双会二文。言随相者约随俗说。言离相者约胜义说。诸佛依二谛为众生说法。此之谓也。然俗是真。俗则不坏假名而说实相。故云观察诸法则为非法真是俗真故。不动真际而建立诸法。故云于言语中随世建立非法为法。由建立故。不断诸业道则不坏世间。不舍下不坏出世因果。次了知下。却释观察诸法。则为非法。初了俗即真而不坏俗。谓依他业缘等皆如梦幻。无真实故。俗即为真。由即俗而真故不坏因果。本来自真不假坏故。不妨了业。其用广大。谓业虽如幻一念幻恶长劫沉沦。一念幻善远阶佛果。故云广大。次解一切下。明了俗即真不碍修真。无作真道尚须修行。若不修行不契真故。况不坏俗宁无修证。随相离相准此应知。此二无碍异于凡小。大文第三佛子此菩萨摩诃萨住一切下。释回向名。文分为二。初总释。后以何下别释。今初。住一切智。是自善根由此能成下诸义故。若处已下释平等随顺义。若约对境。处即是善非处为恶。若约自行。处即随相非处离相。处非处殊皆向智性。于一切处悉皆回向。是随顺一切善根义。回向智性是回向义。无有退转是坚固义。又向智性亦坚固义。二别释中三。初假征起释回向义。二佛子下释随顺义。三又佛子。释坚固一切善根义。今初。然随相之名。以坚固心修诸善行。皆愿众生向菩提果。不言自显。而离相受称非释不知。所以偏明。故征起云。离相之中无能所殊。以何义故说名回向。下随顺等例此可知。略显十义。虽一离相得成回向。谓但能离相顺一切智。则自度世等至于彼岸。岂非回向义耶。一过世八法至不动岸。二度我我所至解脱岸。三离寻伺至实际岸。四灭尽诸想至实智岸。五离烦恼本至有余岸。六离苦依身至无余岸。七出一切业至施等岸。八出三界至无住涅槃岸。九尽有漏至法身岸。十出生住灭见至自觉圣智岸。二释随顺。然下二段兼显益相。正为释名。亦应征云实际之内。谁是能随谁是所随。故此释云。但能如是离相回向。自然随顺佛法智等。以佛法等实为体故。三释坚固一切善根。亦合征云。实际非相何名坚固。实际无差何名一切。此释意云。如是离相回向方名坚固。凡是有相可破坏故。但能离相自成诸善。诸善皆以实际而为体故。于中一不了法无相。不名为了故。二佛以法为身。心诣于法为事佛故。三若身承事则有事不事。若事于理则一事一切事。佛无二体故。四如理修行真供养故。五相即无相不须灭坏。六无非无相不可乖违。七八染净皆生无贪无厌。九世间常住故无少灭坏。随缘起灭故不违因缘。十究此根源法力方具。又由无碍故名具足。第三依释结名可知。大文第二菩萨摩诃萨住此回向时下。明位果。随离无二招斯十果。第二应颂。先说因缘。有十二句。初一总辨仪式。后一总明所依。前文屡。释中间十句别显二义。初二仪式。一观所被。二彻事理。上观察言通心及眼。下辨所依。一依教智。本下三句依广大心。初句为总。大悲普覆即上广心。长佛种性即前大心。次二句上依果德。一依说德。二依说身。次二依权智。观乐观宜。后句依体起用。后正显偈。四十一颂长分为三。初五偈颂行所依身。次饮食下三十偈半。颂依身起行。后随顺下有五偈半。颂释名中随顺等义。兼颂位果。二中分两。先十九偈颂随相回向。于中初一颂标。后三颂结。中间皆颂广显。标显二文影略不具。后菩萨观察下十一偈半颂离相回向。文分四别。第一五偈颂内绝想念。于中初句总显观力。次句人空余皆法空。知菩提等者。菩提性净不碍从缘。净法为缘有菩提起。起即无性不违法界。是性起菩提。若业依身有则不由心。若住心中则有心皆业。既许有心无业。则业假缘生其性安有。二菩萨已到下二偈。颂触境离染。由到不可得岸故无所著。三有二偈。颂前征释。四二偈半颂不碍随相余并可知(从此已下入第二十九经)第七等随顺一切众生回向。长行中亦二。先位行后位果。初中亦三。今初牒名征起。谓以善根等心顺益故。等即平等通于能所。所顺众生无相平等。能随顺心智照平等。此从回向受名。等即随顺故。本业云。以观善恶父母无二一相一合相。故名随顺观一切众生回向。名无等字释有等义。有云善恶即怨亲。此二平等俱生法身。皆名父母。应云善父母者方便般若也。恶父母者无明贪爱也。不灭痴爱起于明脱。故无二相。智契无二名一合相。即以无贪等善根而为其性。第二佛子下。依征广释中二。先明回向。后佛子菩萨摩诃萨修行如是回向之时下。辨所成益。初中亦二。先辨所回善根。后佛子菩萨摩诃萨以净志下。摄将回向。前中复二。先正修善根。后佛子菩萨摩诃萨于此善下。因修成德。亦可初是行体。后明行用。前中有三十一句。分为三段。初十一句明善根分齐。次十善所依缘。后十善根体性。然其前十一一遍从中十。中十一一能生后十。后十一一容具前十。前十一一该后二十。思之自显。今初十一句即增数十也。于中初三约分量。如小心施名为小善。为菩提施名之为大。为利他施名之为广。余之九度例此可知。又从佛境所生之施有此小等。从九境生亦有小等。如施既尔余九亦然。此三既尔下八例知。次三约类。谓有多色类。乃至无量种种不同。未至无量但可名多。三五相望亦名种种。余五约数明多。于中后二亦显甚深难思。傍无分量。二佛境下中十句内。前五为缘境。前四智境。后一悲境。后五造修境。初一能修智。次一能修心。次二所观境。后一所修法。因睹此法能起十度等。三勤修下后十中前七可知。八愿心积德。九念力习行辩力说法以为业行。十由智自在故能覆育。二因修成德中二。先牒已修后显成德。初有十句初总余别。一住作意。二加行趣入。三摄行属己。四渐集成多。五假缘资助。六照其事理。七惑障不生。此上自修后二转教。八开显指示。九劝如说行。随修一善则有斯十。后得堪忍下正显成德。文分为二。初成自利德。后为诸众生下成利他德。前中十对皆含因果。一得忍息恶。二摄根具戒。三离倒行正。四上受下资。五佛护善增。六住愿起业。七心等诸佛行诣道场。八内入佛力外相超世。九不乐当报不贪现乐。十不着诸行而修回向。此虽有回向之言。意取所回之善。十中前八成德。后二离过。九离凡。十离小。后利他中先总明。悲智双运为究竟道。于虚妄下别显。又并易知。常勤修下一句总结。第二摄将回向中二。初念修善根本因法应回向。后佛子下正将回向。今初先经叙念时。次此诸下正陈所念。初之五句。总显诸善由菩提心。多闻积集思惟义理。发起修行志乐无厌。唯深唯广。皆为下三句显菩提心。三回向义。种智证于实际即是菩提。三心回向三处也。后作是下结。第二正将回向中。文为三别。初向众生及向菩提。二佛子菩萨摩诃萨如是回向时不着业下。明向实际。三佛子菩萨摩诃萨以此善根普施世间下总结三种回向。今初分二。初回己修善。愿成资具以施众生。二佛子菩萨摩诃萨以所集善根于念念下。复回此施。愿令众生具足财法。今法亦二。先总显要期。二愿令下别彰施行。今初所以偏愿成施行者。一则自具行缘故。云修菩萨行。二则众生现益故。云惠施一切。三则檀为行首。举一例余四。则此一施行具一切行。二别彰中。先愿成外施。后佛子菩萨摩诃萨复作是念下愿成内施。以情非情而为内外。今初分四。一显施广大各僧祇故。二假使下辨施无限。长时多田随求无厌故。三佛子下。明施殊胜离过顺现故。文有十句前五离过。追悔不已则生热恼。后五顺理。前二大智后三大悲。四又佛子结成二行。谓由回向行以成施行。第二内施文四。初对一田显施广大。谓一众生即施多事各僧祇故。二菩萨下。以一例余彰施无限。先举人例人。佛子下举处例处。总收其义有六无限。一物二时。三心四田。五施六处。三大悲下。结成所作该六无限。一处遍法界故普覆。二时尽未来故无息。三田尽生界而加哀。四施随所求而满足。五物该种种行不息。六心住大施而无疲。四佛子下。显施殊胜离过成德。有二十心。初一牒前起后。后所谓下正显一十九心。一不染施行。二不为施缚。三由遮前二故得解脱。四违缘不倾。五诣甚深理。六无相善摄。上六皆巧便殊胜。次五清净殊胜。初句总。总无二执故。下四别。初句无我执。余三无法执。一不取法相故。二了唯心性故。三见性空故。次有三心即安住殊胜。初句为总。菩萨种性万行齐修。皆可贵故。二心为别无瑕而明故。次有二心。即回向殊胜善决诸义。具三回向故。次有一心即意乐殊胜。悲愍一切故。后之二心依止殊胜。依菩提心故。初句因后句果。上显施中广大无限。即事业殊胜。具上七胜檀度行成。第二回上施行。愿令众生具足财法中。文分为三。第一慈悲回向。二又劝众生下劝物回向。三又以诸善如是回向下。究竟回向。今初分三。初正明回向。二佛子菩萨摩诃萨如是回向时发欢喜心下。明回向所为。三佛子菩萨摩诃萨如是悲愍下。结其成益。今初先总标。后所谓下别显十愿。初一丰财以财施故。余皆具法。积善本故。文意总显。第二回向所为中二。先牒前起后。后为令下随义别显。总有一百一十句。文分为二。前七十二句。令成行布修因至果。后三十八句。令成圆融因圆果满。此二无碍为回向意。亦是前自分后胜进。前中六。初二十一句。为令修善趣贤首位之行。然纯明施行。末云摄如来智施行者。照三轮空离诸分别。同菩提故。二为令一切善根下十句。成种性位中修行。三有十句。令成解行位中修行。第十云无量者。四等也。四从成就清净等施心下。令成十地位中修十度行。七云满无边净法界。此通事理故曰无边。是方便度也。八成满神通即是大愿。九住平等方可名力。十入佛境是谓智圆。五有十句。令成等觉位中修行。故皆有普言。六从具诸相好下有十一句。令成佛果位中行。言六十种音者。第十回向有而不具。至文当知。密迹力士经第二具说。庄严论亦引此经。而云百千种法而以庄严者。不思议法品云。如来具足六十种音声。一一音有五百分。一一分有无量百千清净之音。以为严好即其事也。复有处说六十四音。以声有八转。谓体业具为从属於呼。是八转声各具八德。所谓调和声柔软声。谛了声易解声。无错谬声无雌小声。广大声深远声。八八则有六十四种。四云无尽法明者。第八地云。如来法明有无量转等。第十云一庄严者。无二相故。以一庄严严一切故。无量庄严者众多差别故。大庄严者称法界故。若依若正皆具此严。第二悉能往诣下三十八句。明圆融行。因圆果满。明位位中有佛义故。若将此下属前佛果。则令果中有修菩萨行。遇善知识便违正理。文分为四。初十句。令众生于种性位因行圆满。四云行不动业得无碍果者。毁誉不动则触境无碍。有云其因有四。一就机法施。二无障碍愿。三悲心亡己为物受生。四修法性镕融行感三业。皆无功用尽众生界。同时普应无所障碍。二从了达正法下十句。令解行位中因圆果满。二云大力田者。谓于其中种少善根。能坏大惑故。三云坚固第一者。悲智大愿无能坏故。三从悉能具足一切菩萨清净心下八句。令十地位中因行圆满。晋经第一名直心平等。即初证真如。此约离障故云清净。二云见善知识生大欢喜。正顺初地得见多佛。故云咸事。四从令得一切智成等正觉下十句。令成佛果圆满。八云非一非异等者。即十通中。无体性无作神通。以了一切为无为等非一异故。于一切染净自他等境。转变自在相即相作而非一异。业用无碍又非一异应成四句。如十忍品说。然上诸义。望一一位各有所由。恐厌繁文举其大略耳。又行布圆融无碍不可定执。第三结其成益中二。先结前生后。后咸令下别显益相。文有十三句。显二种生摄一切德。初三句显胜妙生。二句为因一句为果。清净者戒受人天身。离悭者。施有大财位。人天财位即胜妙生。有大威德。后之十句显功德生。功德生者即决定胜道。有人天中具大财位。无信解等非功德生。一生大信解。拣异邪小。二永离三毒障。翳即痴浊即是贪。亦兼余障故致诸言。三其心下即离毒之德。初句为总。质直下别。由离嗔故质直柔软。由离贪故无有谄曲。由离痴翳故无有迷惑愚痴。四修真定慧为出离道。五运同体悲为平等心。六入无漏因为白净法。七由离前过不恼众生。自行无失兼能回向。八自他兼利。九灭除恶因。十修行善本。第二劝物回向中二。先令悲智双行而成回向。后为令下明回向意。意通能所。约能菩萨为此故教。约所教其当如是为。文有六句。二中性即体性义。即所以通于理事。第三又以下究竟回向。上来展转回向以随宜故。或通因果世及出世。今回向既终惟愿得成究竟之果。安隐者无障恼故。安乐者唯寂灭故。第二回向实际中。先牒前随相。后不着下正显离相。十句五对。一已业因果。二自己身财。三起行方处。四所化众生。五所回行法。亦通一切。不着一切法者。了法空故。不着无一切者。空亦空故。第三佛子已下。总结三种回向。近仍前起。谓即上离相不碍随相。远结上文。普施世间即向众生。愿生成佛即向菩提。得清净心下即向实际。成就三世佛种即总结三种回向之能。大文第二回向成益即此行所成广大之德。有四佛子即为四段。第一佛子成因位广大德。二一佛子果位清净德。三会违自在德。四相尽平等德。前之二段即随相益。后之二段即离相益。又初一现成德。次一当成德。此二因果一对三。是会相德四。是得实德。此二会违摄法对。今初先牒成益之时。显正修时即成此益。后超出下正显。显有十二句。初二为总。初句显深无能过故。后句显广叹不尽故。后十句别摄为五对。初二所行所见。对行中初行行。后诣刹所见中。初见果后见因。二说法深广对。事理善巧故。法义甚深总持广包。辞辩无断。三为众生下现身严刹对。于严刹中先果后因。四念念令下成就摄生对。初成就。后于彼下摄取。五得无碍下远听速往对。初明远听听必修行。后住无得下。速往往皆无得。不假静虑故曰无依。不起加行故云无作。不染通境故云无著。依此无依故能刹那顿现等。同一见者诣刹虽多道风无异。第二果德清净文分为二。一牒现况当。谓结前因德尚尔无尽。况当成果德。岂可量耶。二一切佛刹下。悬解当相。谓成果之状略举此十。前六果相圆备。后四举因显果。谓此果满由因圆故。皆言清净者。无染不尽。云平等者无理不证。染净皆虚故云平等净符乎理但云清净。此上因果德用。若非圆教诸位相摄。何容地前得斯无碍。第三会违自在德中二。初结前生后。此结有二。一近结上果德。果德无边上言不尽。故云一切功德清净。二通结因果。以随相益。竟欲明得随相益。即有离相故。总结云得一切功德。乃至圆满庄严。由此故有不违等也。二如是回向时下。正显会违之益。有十五对。大分为四。初十一对。法法相望无违。次二对世世无违。次一对世法无违。后一因果无违。即是总结。前中分三。初六对事事无违。次法性下。二对事理无违。三刹平等下三对。理理无违。今初。一依正。二业果。三王所。四心境。五业报。二是引业。此是满业。六正助无违。行前之思方便造业。但名为业。思之所起身口意行。名为业道。以是思之所游履故。晋经名业迹迹即道也。此之事事所以无违者随性融故。缘起相由故。同一缘起义故。亦由后二段令此无违。次二对理事无违者。初对约所相之法。论性相无违。后对约能相四相。辨性相无违。略举一生耳。性不违相者理能成事故。相不违性者。事能显理故。不动真际建立诸法故。不坏假名说实相故。三理理无违。三对。一依正。二人法。三能所。证离欲际即所证理。众生安住即能证智智。冥于理故二无违。然上三段无违。初后二段唯约异类相望。由后段中。以事取理有多平等故。中间事理无违。则有二义。一自类相望。如刹望刹平等。二异类相望。如刹望众生平等。平等即无性之理也。开此则有四句。若细论则有五重四句。第一四句者。一刹二众生。三刹无性理。四众生无性理。此四为本。第二四者。一刹即刹无性。以事不存故。二不即以不坏事故。三刹无性即刹以不守自性故。四不即刹以性不变故。第三四者。众生与无性亦同刹。说上二四句。各初及第三。是第二段性相无违中。自类相望。各二及四。虽非无碍亦不相违义如上说。第四四者。一刹无性即众生无性。以无二故。二不即以无可即故。三刹即众生。以无性是众生。刹既无性即众生故。四刹不即众生。以不碍两存故。此中初二句。是第三段理理无违。以无可即亦无可违故。第三句。是第一段事事无违。第四句虽非无碍亦不相违。第五四句者。一刹即众生无性。二不即。三众生即刹无性。四不即。此中初及第三句是。第二段理事无违中。异类事理相望。二四两句虽不坏性相亦不相违。然为门不同有多差别。理实诸句无不融通。二约世世。三约世法。四约因果文并可知。第四相尽平等德。文分为二。初得平等离相益。二得承事一切佛下。明得不坏诸相益。第三依释结名可知。大文第二辨位果与益异者。成益约于位中得果。就其位满。有二十一句。初一牒前。后一总结。中间十九摄为九果。一断染果降魔冤。谓止恶缘拔欲刺。断恶因也。二入证果。得出离乐正证住无二性证因。三益生果。具大威德即护生之因。四内外超胜果。谓内德外用。五往一切下寂用无碍果。六具一切下行愿广大果。七分别下智通殊胜果。八得无碍下见闻自在果。九于一切境下修行具足果。初成就后无得。第二重颂。二十一偈分三。初十一偈颂回向。次九偈颂成益。后一偈结赞。今初分二。初半偈颂所回善根。余颂摄将回向。于中三。初三偈半。颂回己修善愿成资具。以施众生。次菩萨为度下五偈。颂复回此施愿令众生具足财法。三菩萨言词下二偈。颂回向实际。二知诸世间下颂成益中三。初二颂因德广大。次五颂果德清净。后二颂相尽平等。略不颂会违。上已委具。然颂三段势少异前。前直语益。今兼显回向之因

大方广佛华严经疏卷第二十九大方广佛华严经疏卷第三十(已下入第三十经)

        唐清凉山大华严寺沙门澄观撰

第八真如相回向长行中二。先广明后结示。前中亦二。先明位行后辨位果。前中亦三。今初标名。善根合如以成回向。从所依立名义通能所。故本业云。常照有无二谛。一切法一合相故。若梵本中。具名真如相自性回向。相即德相性即体性。以二非即离。所以双举多说德相。唐本单名。即以法界印为其性。此与前后异者。谓第七明会事向理。故云平等。此明事尽理现故。行等同如。第九明从体起用。第十明用同体。同体而用。余如第四回向会释。第二依征广释中三。初明随相回向。二佛子菩萨摩诃萨以此善根下。离相回向。三佛子此菩萨摩诃萨如是回向时得一切下。回向成益。初中分二。先积善回向。后佛子菩萨摩诃萨若见下。触境回向。前中亦二。先明所回行体。后菩萨尔时慧眼下。摄将回向。前中亦二。先积集资粮。后成就无量下结德成就。今初文有十句。初一为总。谓正念坚明下。九为别文有三节。初三正念菩提。一远离迷惑是明了义。专意修行即为正念。正念是定明了是慧。定慧双运为道之源。二契理不动故曰深心。缘不能沮成不坏业。即自分坚住。三求佛不退即胜进坚住。次四句正念化生。初句为总勇求兼济。为大法故下三句别。一悲智双运为明了。般若为众德之本故。二进善去漏为正念。三悲增智圆为坚住。后三正念三宝。一念佛。二护法。三信增。上有正念下句坚固。影略该摄。二结德成就。文有四句。前三结前。一非止上十故云无量。二三统而收之。不出福智大悲。末句生后回向。第二摄将回向中二。先观察善根本期回向。二以诸善根下正明回向。今初有三。初总标。次其诸善下别显。三如是下总结。于中二先结种类多门有十句。谓随前求缘等有多差别。一通游非一故。如一趣入。为用有门为用空门。乃至无量故。慈行童女云诸佛各以异门令我入此普庄严门。二随其一门缘何为境为佛为法等。三随一境上相貌不同。四相所依事。谓色心等。五随一事上有多分位。六施等万行。七能诠名字。八分别决择。九生多知见。十若定若慧上中下修。后其中下结修本意。本意既然宁不回向。第二正明回向分二。初向菩提。二佛子菩萨摩诃萨如为己身。下回向众生。前中有二十愿分三。初十愿愿成智行。即菩提因果。二得三昧下四。愿周遍利生即化用因果。一化所依。二化时处。三知药治。四识病宜。三得自在下六。愿普严佛刹即净土因果。一神通智严净事土。二入理。智严法性土。亦非严严故。三事理无碍智严帝网土。四以前三严用化众生。上四因圆后二果满。第二回向众生文三。初牒前起后。即从后倒牒前之三段。二所谓下。正显回向文有八句。初二愿离三障。障碍之言义兼烦恼。次四成四智。后二结二果。谓菩提涅槃。菩提不唯四智故云无量。三佛子下总结所为。第二触境回向。大同净行对境发愿。于中五。一列所见境。二见是事下睹境成德。谓增悲智。三以佛善根下总明回向。亦是回向之德。四菩萨尔时下别明回向。五佛子下回向成益。前三可知。四中初句总标。标将说别。上起行中云。以诸善根方便回向。未知回向其相云何。故云尔时如是回向。后所谓下别显。显如是言。三十一愿皆言令得可爱乐者。由见可爱乐境。起可爱乐善故。愿成可爱乐德。释此诸愿通有二意。一横对上境发等流愿。二竖配地位以彰总愿。总者随见一境即发多愿。该因果故。言横对者。初之十愿对上国土。一若见国土当愿众生见法性土。二土之供具。三通受用变化净土。余皆土中之事可以意得。对此一境发十愿者。以一例诸皆应有多。不欲繁文。下渐从略。次得无畏下三愿。对上园林。无漏法林无所畏故。总持三昧为园苑故。次一愿对上草木。善观五乘。三草二木智差别故。次三对华。神通等法如华开敷。处众开演皆华敷故。果之一种留在后明。从发大悲下一愿以对一境。谓大悲熏心以对上香。令根喜悦如彼上服。生如来家得珍宝分。以调伏行为圣财物。无碍辩说为庄严具。可乐世界犹如于村。悟入多门等彼城邑。无碍无本如彼聚落。毕竟无二若国无二王。证离欲际方得自在。无戏论法为离諠杂。后之三句即对前果。二竖配地位者。文分为二前显因圆。后三果满。前中分三。初七未入法者令得入法。即是地前。一最初发心同佛见理。二行法供养。此二十信。三生诸佛前。四解心见法。此二十住。五如说行即是十行。六同善友见。七触境无违。此二十向。二证得下十七愿。已入法者令得入地。初三初地。一证如理。二得教光。三成施行。次一二地行不虑误犯故无所畏。爱语偏多故能说法。次二三地行。习诸禅定求多闻故。次有三愿如次三地。谓焰慧观道品。难胜具神通。现前深般若。次方便下二愿七地行。谓方便偏多故。虽善修空无相。而慈悲不舍众生。故云平等大悲。次二八地行。谓诸佛劝起利他大心。无间现前常悦豫故。得无生忍真生家故。次二九地行。善知稠林能调伏故。四十无碍辩善说法故。次二十地行。得入劫智入微尘世界等。广利乐故。能受如来大法雨故。三有四愿。已入地者成普贤位。一一切境中得无碍见。觉法本源无根本故二得无二住断二障故。三住真实际等如来故。四得寂灭忍无戏论故。第二三愿明果满者。即是三德。亦初金刚智而为能断。次离二碍以为所断。此二为无间道。后一解脱道。证成出现智周法界故。用前二释文旨有据。次第无差。金刚幢之。巧谈非说者之阱凿也。第五回向成益中。先明得时。后得智下正显十句。摄为五对。一以因感缘。由智内明外为友摄。二以缘感因。外蒙慧照内灭痴冥。此除障益。三由勤修入三慧业。此明学益。四上学证智自善普充。此证入益。五尽善福源。入实智海。此成二严益。即为向实际之本。以智穷入故。第二离相回向。即向实际。此与前诸回向小异。前多摄相归性。少有依性起相。今此多显性相无碍。以为如相故。上诸标文。皆蹑前随相之时。今不要对前以成无碍。故无时字。文分为二。初直明回向。后譬如下对如广辩。今初分二。初顺如之行。二于诸佛法下。顺如之益。前中亦二。先约心明则止观双运。不著有无。后虽善下别约行明。则权实双行。不违性相。今初复二。一止寂妄取不违体用。二等观下观达空有信智双圆。前中初二句标。次其心下二句释上句。无所取故。下句离能取故。不舍下明其不违。一不违因。二不违法。三不违果。所以不违者不着无故。观中初观真空。善顺下观其妙有。二权实双行中。初句立宗。以无碍为宗。次句同喻。如幻相有体即虚故。后知一切下合及出所因。一法无性故。二观一切下观无著故。上二顺于空如。三知如实下知一实故。则顺不空如。四知诸法下结成无违。五与诸下结成所作。谓能横入一道竖入一门。二顺如益中十句五对。令四心弥固。一上安深法下净众生。即广大心。二二我不生世见斯绝。即不颠倒心。三于境无染出世勤修。四不依世间。正道唯固。上二即第一心。无住涅槃为第一故。五妄见斯寂。了实体同即常心。常不舍离同体悲故。第二对如广辩如相回向。生此段文略以五门分别。一释名。真谓真实显非虚妄。如谓如常表无变易。此法相宗。若法性宗云不变为真。顺缘曰如。由不变故。与有为法有非一义。由顺缘故。与有为法有非异义。而起信云。无遣曰真无立曰如。唯就遮诠顿彰真理。二明种类。或唯一味无有差别。或分为二。即生空真如法空真如。又安立非安立二。又空不空二。并如常释。或分为三。约三性辨如瑜伽等。或分为七。谓一流转真如。即诸行流转实性。二实相真如。谓思惟诸法无二我性。三唯识真如。即唯识性。四安立。五邪行。六清净。七正行。上四即如次四谛体性。如显扬说。或分为十。十地当明。或有百门十十无尽。如今经辨。则上来所列皆是其中一义。设言通一切法亦一义耳。三辨德用。一成依持用。与一切法而为所依。此能持故。二成观境。谓为贤圣证观境故。亦是百门之一德耳。起信说有三大。一者体大。谓真如平等不增减故。二相大。谓具足无量性功德故。三用大。能生一切世间出世间善因果故。然彼依心说于三大。真如乃是其一。以一统二。二皆属如。然违真名恶契如则灭。顺真为善称如则大。约善顺义故说如为善因。然违顺虽殊离如则无可违故。恶亦以如为体若会此经。百门之内。或体或相或用或兼实。则一一皆通体等。故为百门融通理事。使重重无尽犹如帝网。四约教不同可以思准。五释文者。然此百门古释非一。一英法师十十分之。如次配于十位中如。一贤首位。二十住。三十行。四十向。五净心地。六行迹地。七决定地。八究竟地。九等觉地。十佛地更有诸德各分十门。贤首并皆不许。远公分三。初十配地前。次八十八句配地上。后二句佛地中如。理皆难通。佛地何以无前如德。如第二门真实为性。何以不得通于诸位。若取随位之德以立如名。如十地十如理则可通。然又不出其相。实则百门之德必贯之一如。能如之德岂无异相。异相难见。且从不分分亦无过故。末句云。究竟清净义同于果。今且十十科之。以配十地十如。初遍一切及无相为相等。即遍满真如之义。二中无能测量无有比对。即最胜义。三中于法无碍为众法眼。即胜流义。四中无著无住等。即无摄受义。五中毕竟无尽无有变易。即类无别义。六中无有分别体性无生。即无染净义。七中无所不在住有无法。即法无别义。八中体性清净体性平等。即不增减义。九中遍一切法是佛境界。即智自在义。十中住一切地。成就一切诸佛菩萨等。即业自在义。其中余义。可以类取。随地别显。唯说十如。一具一切十十成百。欲显如德无量无边。地前通修。等觉遍等如来穷证。然异从义别体本常融。但契一如自含众德。非由作意顺差别如。能同回向亦融摄无碍。称如起行体即是如。但人信如德尚迷回向。故以如德喻回向德。若取文义便者。应云真如体相遍一切处善根回向。以同如故。亦遍一切无边际等。又遍一切方得同如。百门之内各有二句。上即所同之如德。下善根下能同回向之德。最初十中初门显在缘中故。无不遍。二明不变故云真实。三明随缘即不变。云恒守本性。四示其性。五示其相。此五一向就如以辨。次二对智以说故为智境。八显真如非境为境。谓要忘境方契如境故。如之本性非安立故。九即安立如。十即如常之义。余可思准。逐难当解。十二。云充满一切者。谓若色若心。若大若小等。极微刹那亦皆圆满。非分满故。如不可分。分则多过。即由此义及下。四十不离诸法故。诸法随如遍一尘中故。下果中得此门故。一毛容纳一切刹等。十四无比对者。法性不并真故。十五六俱是不坏人惑不同。十七寂而常照智即如用故。二十二既以照明为体。何无照瞩之眼。又由见如成法眼故。大般若云。三世诸佛皆以性空而为佛眼。三十云无根本者。前无所依故即无住本故。三十七。云安住者。由无所住安住真实故。四十一毕竟无尽者。虽在诸法诸法尽而体常。又正在法中取不可尽。如芥子之空故。五十一性常觉悟者。能内熏发起厌求故。五十二不可失坏者。在于生死染而不染故。五十三即大智光明遍照法界义故。五十四离言真如。六十一无所不在者。上遍一切即无边际。今随一一法皆全在中。六十二在昼夜乃至尽未来者。一念长劫各各收如各各依如故。得念劫互收互入。七十住有无者。理无惑计。有无常实故。七十二性觉为明离念为洁。八十九非可修者无所得故。非不可修者为圣境故。九十五舍离诸漏者。准梵本云阿那萨攞嚩此云无漏。今言舍者性本舍故。犹心体离念。九十六云无有少法而能坏乱令其少分非觉悟者。如遍非情则有少分非是觉悟。况经云佛性除于瓦石。论云在非情数中名为法性。在有情数中名为佛性。明知。非情非有觉性故。应释言。以性从缘则情非情异为性亦殊。如涅槃等。泯缘从性则非觉不觉。本绝百非言亡四句。若二性互融则无非觉悟。起信云。以色性即智性故。说名智身。以智性即色性故。说名法身遍一切处。论云。菩提菩提断俱名为菩提。说智及智处俱名为般若。亦可证此。既二性相即缘复即性故。无少分非觉悟者。况心为总相。又融摄重重哉。九十七。云过去非始等者。过去初际所以名始。未来为终故称为未。现在似有已未分之。无暂住时故名为异。今明真如。虽遍三世之中。体绝三世初中后相。故并言非。回向亦尔。虽为众生新新起愿。同彼真如遍三世中。而令永离三世生死之相。方名清净。而晋本云。过去非同未来非故现在非异。若以今文会取。非同过去之始。虽在未来非是性本故有。又晋经误将后门三世无分别。同入此门。致令百数缺一纷然异解。繁不叙之。言三世无分别者。前约遮诠不同三世。今约显诠常无分别。意旨相似故。晋本合之耳。又上不同三世总显非故。今无分别亦明非故。而性相互融能新能故。新故双绝矣第三回向成益。及结名并显可知。大文第二菩萨住此下明位果。初牒得因。后证得下正显所得。文有十句。初总余别。皆云无量者同如广大无尽故。皆云得佛者。同佛所证故。作佛事故。大文第二佛子下。总以结示。第二应颂二十九偈分四。初六颂随相。于中先二所回行体。后四回向之行。二有十六偈。颂离相回向。于中先九颂对如广辩。后七却颂约法直明菩萨住是不思议等。宜善思之。三彼诸佛子下六偈颂回向成益。四一偈结回向意并可知(从此已下入第三十一经)第九无著无缚解脱回向。长行中亦先明位行。后显位果。前中亦三。今初牒名征起。谓理智无依。不为能所见着相惑所缚。由此即名解脱。此约行体释之。故本业云。以诸法无二般若无生。二谛平等三世一合相故。又解脱者。亦作用自在如不思议等。此约行用。由摄善根皆用回向普贤三业无边自在德用故。于何无缚着耶。谓心等十以自身有心身口业果。及所作佛事。有世界佛刹众生法智等故。不为何等所缚着耶。略如上说。别有十事五对。一由离凡故不缚生死。以出小乘不着二乘。二离六识取不缚外境。离第七执不着于内。三离现行缚无种子着。四不取有缚不执空着。五无惑障缚无智障着。皆缚粗着细。若约一事由着故缚。义如总中。或缚着一义。此约无碍大用受名。通能所回向。约脱惑障无缚无著。即是解脱。约用解脱。乃无缚着之解脱。若望心等。亦是无缚着之心。即上体用并无其性。第二广释中分三。一明所回善根。二佛子下能回向行。三菩萨摩诃萨如是回向时如三世下。明回向成益。今初先总标尊重。以一毫之善皆佛因故。无非佛所流故。次所谓下别显。后于如是下总结并可知。第二回向行中二。先仍前进修拟将回向。二以诸下正明行愿。今初亦二先总牒前后。究竟下别显修相。文有十句。前五修前即释尊重等言。谓一欣乐故。尊重。二信解故忍可。三自随顺。四令他顺。五总显无著以该上四。后五进修。一积集胜进。二志乐普贤无方德用。三上入佛境。四善根增势。五知见逾明。第二正明愿行中。义有十门文分为二。第一广显其相。二佛子菩萨摩诃萨以彼善根如是回向所谓心无缚下总结多门。前中分二。先明众生及菩提回向。后佛子菩萨摩诃萨以无著无缚解脱心回向不分别下。实际回向。前明广大后显甚深。广大回向。有六十门。甚深之内有二十门。并前尊重进修复二十门。总有百门。显圆融无尽。深广无碍为大回向。就广大六十门。广显普贤自在德用。大分为二。初之四门。总显余皆别明。今初前三成三业。以下诸门不出三业故。后一精进通策万行故。于中无著无缚解脱心。是能回之心。成就普贤身业正是所向。他皆仿此。前诸善根即是所回故。以诸善根之言下流八十门内。此一回向不愿成佛。愿成普贤者。以普贤通于位前及以位后。得道不舍因行穷尽生界。利乐有情故。愿成普贤。兼二回向。下别显中。一一门内。皆摄法界自在德用。或理或行或智或境。或自行或化生。或体或用或因或果。或人或法。皆各总摄一切法故。不可相从。别科略分为二。初二十三门。显普贤自分究竟。即位中普贤。后三十四门。显普贤胜进究竟。即位后普贤。二分无碍是普贤德。前即因圆果满。后即得道。不舍因行故。二段中皆含因果。今初分三。初四成普贤总持德。二有十二愿。成普贤自在力用。三有七愿愿成普贤行。然诸门德多约三业。今初总持亦具三业。初一语业总持。二身业见佛。三意业解了。后一三业用之时处。标名约时辨用就处。文互显耳。第二力用中复二。初九愿。一多摄入自在。文有三业化时处等可知。后三广大自在可知。第三成普贤行中分二。初四愿成神通。二有三愿愿成四辨。初一总具四辩。次二别显法义。初法后义。即显果满究竟。第二始从此生下。明胜进究竟。而言因者乃果中之因。于中分三。初有九门。摄法广大自在德。次有十五门相即相入重重德后有十门。明微细容持甚深德。初中分六。初三愿成智。前一实智后二方便智。初是照行方便。后一照方便之方便。二有二愿成利益不空三业。三有一愿广大三业。广大众生者具大心故。四一愿成清净三业。五一愿诸根三业。别有十四根。皆以胜用增上光显义。故立以根名。初聪利等三根约眼等六。兼五受根聪利者。领览敏疾故。调顺者内无刚强故。自在者。外境不牵故。余约信等五根。初一信根信心无尽故。亦兼命根。次一进次一念。唯念佛平等故。次一定及精进。以不退转是定义故。余七皆慧。金刚界根者义兼定慧。金刚三昧即。是定故。金刚正智即是慧故。界即是性智了心性名上定故。亦即未知当知根。现观位中得不坏故。金刚焰者。焰通事理及能所故。即已知根已成智故。离世间品云。如金刚根证知一切诸法性故。即此界根。又云金刚光焰根。普照一切佛境界故。佛境有二。一所观境通于事理。二分齐境即能观智。亦得称境。次三调化。后二果圆惑净。即具知根也。六一愿神力三业。文虽缺语义亦兼具。第二即入重重德中分六。初三入普贤门。一行门。二智门。三法门。二有三愿成普贤方便。一深心方便。以契理深心故。于一心能现多心。二回向方便。一身悉包一切。但向一身已向一切。故云方便。三大愿方便。以无得心入佛境故。三有二愿入普贤位。初一始入于地故。能入刹无碍。后一终成故得灌顶成智。于中三。初标能所知。次所谓下列所知想。有五十二。其业行界解根等。皆十力智所知。如初会释余亦摄在其内。持谓执持善恶。地谓断证分齐。菩萨成者解行正命。菩萨坏者戒见邪命。余皆可知。后如是等想下结能知德。谓离四过失具五功德。四有四愿成普贤智。一成行智无机不知。以化众生为其行故。二大愿智。无处不知。愿遍化故。三穷业智了因缘故。四知法智知化法故。五有二愿。愿成普贤听说。初耳无不听。次舌无不演。六有一愿成知根德。一摄一切。于中言大行王者。以遍知根于化行自在故。一根知一切根者有二义。一约理融。二约事别。谓如一人有多乘根性。一一乘中有无量品。如声闻中有信行法行等。此二通有退思护住等上中下根。随于一品。复有信等种种善根之异。第三得色甚微细下十门。明愿得普贤微细知法。以所知之事幽微故。能知之智微细。微细有二。一准无性摄论。以难知故。二就经宗。于一法中。有一切法炳然齐现故。如文云众生业报微细等。即约初义。如来在母胎等。通于二义。十门即为十段。第一明世间法微细智。瑜伽。云色微细性有三。一损减微细性。即析至极微。二种类微细性。谓如风等色中有色。三心自在转微细性。即色无色界色。如经说有天住一毛端量地处展转无碍。此三即难知微细也。余之难知类此。各有异义。文中分三。初标得所依。次得色下列所得法。后如是等下。结能知之德。不怖甚深不迷理事。乱谓错谬。散谓不专。浊谓垢染。劣无堪任。今皆反此。上明离过下显成德。一缘谓专注一境。故不散。善寂谓心境两忘。故不乱。即定而知名善分别。故不迷。即照而止名善住。故不怖。此能知之德。以在初门义通下九。皆应尔知。第二知众生趣微细智。住谓住寿余并可知。第三知菩萨行德微细智。列所得中有二十句。前十别类后十同明三昧。第四知菩萨位德大用智于中三。初标所修。次悉知下列所得。有四十一种。初十一事位行成满。后生兜率下。三十事明位满大用。现八相等。其中有菩萨佛名。因果之异。皆是用中之事耳。其微细之事。离世间品。及不思议法品广明。三如是下结能知德。谓成普贤自在行德。德亦名益此德通从诸智而生。亦可别配恐厌繁文。于中云心非心等者。以识缘境名为心地。以智了境名非心地。识所了境通于善恶。善唯有漏。智所了境唯无漏。善漏无漏境心能含之。心即名藏故。晋经云究竟了知思议不思议地诸功德藏。言于非心处示生于心者。即非心量之心量也。由此故能离言语道。安住智等故。晋经云于不思议出生思议。示诸法门离言语道。上经云菩萨住是不思议。于中思议不可尽。入此不可思议处。思与非思俱寂灭。即斯义也。以心与非心生灭真如非即离故。不为此释令人误解。谓使无情有心。设令无情有心。既云示生。于理无失。余文可知。第五知众生界智。其第二知众生趣。即十力中自业智境。此知生界即是性异。十力之中种种界智境故。晋经。云入众生性微细也。文中亦三。初标德所依。次得一切下列所得智。于中十句。初总所谓下别。别言众生界分别等者。亦可言众生分别界等。一分别者。自性强思起邪见等。二言说界者。依邪师教名言熏习等。三谓戒见等。四五可知。六欲求趣天。有求趣静虑邪梵行。求趣无色无想。各谓为涅槃故。七谓诸行界。诸求众生行各异故。随一邪求。有裸形等种种殊故。八多贪嗔等杂染异故。九闻一乘三乘无量乘等。皆清净故。又染净二句通前七句。谓又染分别净分别等。又通有四义故甚深微细。一颠倒即空故。二理有真实故。三缘成离念故。四相入无羁故。三如是下结能知德业。初结德。后广摄下明作业。亦有通别思以配之。第六知世界智。文三。初总标。次所谓下别显。有二十一智。初九直语器界。次九明其受用。其一多相作。亦是菩萨受用。后三正知无取着故。二如是下显能知德。于中亦有通别。别可思之。第七知法界智。此显即理之事法界。故云一切法界即事之理。复云不生等。亦初标所修。次得下辨所得。初句总余十别。后如是下。结能知之德唯就通说。于中初。标二利满足。后不舍下释成满义。普贤行满不出二种。一证道二化道。初离二边显证道满。不舍于义此离空边。不着于法此离有边。故得平等无碍之智。言知无碍本。即是所证。次不住下双照二谛。明化道满可知。第八知入劫智初标。次所谓下列。后如是等下。结能知德亦是益相。先结后益可知。第九知法智。初标。次所谓下列。文有十句义有四重。一法体具德。二一切入一等明法用即入。三入非法等明理事相即。亦有无相即。以非法有三义。一非善法故。二非即是无如兔角等。三非即是理。今是后二。次云无法亦即非法。晋本名非。今译以非进二义。故互明之。依第二义。则法本自无。因缘生诸故云安立。若依第三。则从无住本立一切法。故不相违。四入方便无余。是体用善巧。后如是下结德可知。第十得总知一切尽无余微细智故。晋经十句。皆有无余之言。文中分四。初总标。二所谓下别列。即牒前十门名或小变。次或不等会意皆同。三乃至下结所不说。四生如影下显知之德。亦有通别。通从前生别则次第。对前十句。一外刹是心之影像故。今能知刹则知影像。二众生想现故云如梦。三者果报缘生故如幻。四心性寂然缘感成异故云如响。五说时如化。六即空界。七言语本寂。八即法界。九世间无依。十出世间行即是佛法。第二回向实际。文有十对。初即假实对。二即人法。求菩提故名菩提萨埵。三即体用亦名能所。梁摄论云。于分别依他起性。不见所行行。及能行道。即此义也。谓证智能行则出离故。第九因果。等正觉者。约人契法异前菩提。三中虽有菩萨行意取所行。此约为因故不重也。十法即教法教智相对。余并可知。第二佛子下总结多门。由心无缚。今身等皆无缚着也。第三菩萨下行成利益。初牒后显。显有十句。初总余别。别中一回向者。正起修行。二道者常游法径。三回向教。四平等智。五所缘境。六功行绝修。是佛善根。七了见本源成如来性。八无碍悲智是佛所行。如出现品。九无尽体用是分齐境。第三结名。从初广说故有心言。第二位果。成三种果。一现成果。于中先自利。后为欲。下利他。二在在下成当得果。初自利。后尽未来下兼于自他。三普贤下明终成果。因果无碍。第二应颂。五十一偈分二。先颂位行。后二位果。前中三。初三颂所回善根。二所修下四十四颂。颂回向行。三过去下二颂。颂行成利益。今初。云不为自己等者。照理大智。无私自他同体大悲利益回向。二颂回向中。但颂广大略不颂甚深。以遍在广大中故。文二。初一偈颂普贤自分究竟。余颂胜进究竟。于中前长行有三。一摄法广大德。二即入重重德。三微细容持德。今通颂之但显微细。于中分十。第一有三偈。颂世间微细智二一偈颂众生趣。趣由行别故。三有二偈。超颂第五众生界。界即根性故。四有三偈。颂第三菩萨行德。菩萨亦受众生之称。神通等行名显。三昧等行名隐。余义细详。五十方下二十七偈。颂第四位德大用。于中三。初一总。次二十三别颂因果八相等。后三颂能知之德。六有数下一偈。颂第八知劫智。七一偈颂第六世界智。八二偈颂第七法界智。九一偈颂第九知法智。以法与法界性相互举。前分二门义必相通。偈居一处。十有二偈。颂一切法智成益位果。二段可知(已下入第三十二经)第十等法界无量回向。于长行中。先位行后位果。前中亦三。初牒名征起。次依征广释。后依释结名。今初谓称法界起大用故。然等者入义。故本分中名入法界。法界无量即是所入。何法能入略有其四。一所回行法。谓法施之行称法界施故。二所行行体广大无边故。三能回之智。四所向之德。谓以称法界之大智。回等法界之善根。向同法界之大用。成法界之行体。此则位满至极故。标法界之名。当法受称。等何法界。此通四义。一等理法界故。经云。如法界一性如法界自性清净。善根回向亦复如是。其文非一。二等事法界。经云欲见等法界无量诸佛。调伏等法界无量众生。或愿起等法界无量行。或愿成等法界无量德。或愿得等法界无量果。皆即理之事也。三等理事无碍法界。经云。愿一切众生。作修行无相道法师。以诸妙相而自庄严。则相无相无碍。皆其类也。四等事事无碍法界故。经云一佛刹中现一切佛刹等。然其四事全等四种法界。融而无二故。此能等即是所等。非有二物。而可依之故。上称入入无所入。本业但云法界无等入言。即斯意也。彼释云。觉一切法第一义谛中道无相。一切法皆一相照故。第一中道即是所入。皆一相照即是能入。此二无二即是法界。故不可但以事法界为名。言无量者。亦有二义。一无分量即理法界。二无数量即事法界。前回向明依体起用。此明体用无碍圆极自在。即以法施及诸相。应普贤自在大善巧德。为其位体。第二佛子已下依征广释。文分为三。初明所回善根。二以此善根下摄将回向。三佛子菩萨摩诃萨如是回向时安住下。回向成德。初中二。先明行依身位。第二广行下依位起行。今初。如第十地得离垢三昧。受智职位。内得此定灌心首故。外示表彰白缯系顶。法从喻称名离垢缯。但有此相知得彼定。表位成满方能云雨说法。以益群生。名法师位。然斯位满总有五重。一约信满如贤首品说便得灌顶而升位等。二约解满如灌顶住。及海幢处说三约行满。如第十行入因陀罗网法界等。四善巧愿满。如此位辨。五约证满如十地说。此五重内。随一成处必具理行。内相应故皆名位满。然信解等殊故不相滥。若约圆融。但一位满即因究竟。更不待余。又若得一即得余位。总一法界受职之位。随门差别五位不同。法体融通全摄无碍。不同余教。二依位起行中二。先明起行。后佛子下显其行成。又前即利他。后明自利。又前明自分。后显胜进。今初十一句。初总余别。别谓慈等皆是法施。夫法施者。生解之妙方。起行之根本。入圣道之阶渐。越苦海之津梁。古德云。此经中托人以弘道。多叹法师之胜德。寄行以表法。每引普贤为末篇。故知法施之功。过财施之难喻。于中十句。一慈悲安物于菩提心。二益物无息。上二即广大心。三大心长善拣非余为。四究竟调御御以佛道。上二即第一心。五法日普照。六等劝修善。晋经云。欲使众生修诸善根。上二即常心常爱众生。同于己故名为平等。七心净无碍。即不颠倒心。颠倒有二。一心染能所之化。今不生于化。其化大焉名智自在。二见无能所便趣寂灭。今不舍善业无滞事理。八示果宝渚故云商主。安隐正道俱通因果。果即涅槃菩提。因即八正万行。九导以万行之因。上二即作义利。亦第一心也。十增长不坏为护念也。初令发心终令成就。有始有卒其唯圣人。然广等四心。般若虽当发心住中。位位皆用。第二行成中二。初牒前。晋经。云菩萨行法施等一切善法。后摄受下正显成相。文显可知。第二摄将回向。文小异前。诸段通下总有二十一门。若通将上十句法施善根。共成诸段。理无间然。今且分三。初九门别对十一句善根以明回向。即自分回向。次四门通显回向之意。三有八门。更以异门别明回向。即胜进回向。今初即为九段。第一愿闻法见佛修二利行。对前二句。于中二。初一愿总明余皆别显。今初初句牒前起后。愿得已下正显愿辞。一切境者。文局初段。义总该于二十一段。回向皆一切境。此一切境广大如法界。理事事事皆无障碍。如此之境皆得增长成就。后别显中二。初愿闻法受持。即成上文广行法施之义。二愿念佛修行。成上饶益无休。于中亦二。初正明念佛之行。次又愿下。回念佛善成二利行。于中亦二。先总为一切。遍于时处修菩萨行。后一切诸佛下别。明修行。梵行为万行之本。故偏明之。于中三。初总举所愿。二所谓下列所修之行。三佛子下通难释成。二中有二十梵行。与智论所列十戒多同。所谓不缺不破。不穿不杂。随道无著智所赞。自在随定具足。通用性戒而为根本。今开为二十一。不破在初者。谓持四重十重。若犯此者犹破器无用故。二不缺者。谓持僧残。残如器缺犹可修补。三持方便。若念破戒事。染心共语。闻环钏声皆名为杂。四持波逸提如白圭之玷。虽则可磨亦不为也。五定心相应乃至吉罗。亦不误失。六缘不能坏上三。皆不穿戒。穿如漏器不堪受道。前六皆律仪。七即智所赞。谓事理无违契圣心故。八不依名利果报九不得能持所持。由有此二虽秉御自他。于世间中得自在也。次三皆随道戒。十拣小道。十一显是佛行。十二兼能通达非道。故云无碍。皆随中道也。十三无著即见真成圣。次四即具足戒。谓观中道具事理故。一事理无违。二顺理而行则常不灭。三心能诣理。四对余超胜。无动已下皆随定戒。谓随首楞严定。不起灭定。现诸威仪。虽示十法界像。无戒不行。而寂然不动。顺境不能乱违境而无恚。又安住无比。即住大慈悲。无动无乱即舍心常现。无恚即喜是四等心。亦名梵行。第三通难释成者。有伏难云。菩萨期心先人后己。今先自行岂不相违。故下释云。但自修行便能益物。此亦成上安立众生于菩提心。及以菩提心长养善根。文中分二。初正明二重征释。今初先总明。后令一切下别显。有十二句。总显持犯。前六明有持德。安住者。通住诸戒。开晓者明闲持犯。三善行。四恶止。五心无垢。六智能照。后六明无犯过。一不起心过故无尘染。二不犯身口故无业报障。照明开晓不翳于理。三由不犯则二世清凉。四离无惭及悔缠所缚。五离恶因恶果。六不自恼恼他成波罗蜜。二征释中二。初正征反释。后重征顺释。今初征意云。自他行异。如何自行便是为他。释意云。自身不正其令不从。故上自行便为为物。净名云。若自有缚能解彼缚。无有是处。摄论云。若自住邪行。设欲正他非。是人终不能制止他过失。文有十句。例上可知。二重征意云。石虽不利而能利刀。自虽不行何妨化物。今云不能益者。其故何耶。释意云。若自犯教他便成颠倒。菩萨无倒。必言行相符故。要如说而行方能如行而说。文中先总明后菩萨下别显。初门竟。第二复次愿得法广演以益自他。亦成上文为调御师。示一切智道。文分为三。初牒前起后。次所谓下正明。三是为下总结。二中二愿。初一愿总明得法。文有四节。一得法。二解说。三益机。四摧灭下成自德二。一愿别明演法。释前四段故。晋经异论之下。无愿我之言。文分为五。初总明。二于一一下明得法。三获无所畏下能演。四为欲令下明所为机并可知。五作是念言下。自修成德即为物勤修。自成已德成十种德。初二云遍。遍于事理。余八云等兼等无碍。影略其文。其中云住者即圣天梵等。第三总结中。上成自德亦为摄生故。复重。云为令众生成一切智。第三复次愿得二利行圆。成上作法藏日获智见佛等皆普照故。文中二。先通二利。后又愿下别明二利。即成上文。于诸众生其心平等。初以自等于理。后如我所得下令物等自。第四复次愿行称法界。成上心净无染及智慧自在。以动合法界故无所染。是以末云。永不失坏诸清净行。此章多同理法界也。如智因理发故同法界。余皆准之。即向实际意也。第五复次有十四愿。愿得见佛解法。成上大智商主。初三自成智性是商主德。余为众生是商主事。第六复次愿解法界。即理法界。岂以此文而名随相。然此中云如晋经云解。解契于理故名为如。即是成前安隐正道。文有十句。一不随缘变。二不守自性故为法本。三如亦复如是其自体故。晋经中名为如如。四非是能依。五不暂离如六随缘无性即是如性。七无性。亦无本来寂静。八无二性离能所故。九不随三世。十一味平等。第七复次愿众生成法师。即成上而作导首。导首即是法师。上为他作今令他作。仁王经说十三法师。如来灭后流化不绝。亦名法师。如法华菩萨藏经。各有其品。今此多就极胜而说。于中有二十法师。七云如眼者。现证非闻见故。九无相之相是妙相故。二十唯有说法能安世间。第八复次不取着回向。即向实际。此及第九。成上作不可坏坚固善友。此之一段明坚固缘文显可知。第九离过成德回向。先十七句离过。即离可坏缘。后但为下成德。明其所为。为不可坏坚固善友。今初前十五事护烦恼行。于中初二不耽现境。次一不求当报。余通二世。后一护小乘行。其第十六。若解脱三昧唯小乘因。诸禅三昧通生死因。未得不求已得不着。谁复求死。所谓求生生必死故。求和合者除涅槃乐。皆有合故。沙弥求龙是怀毒回向。愿为魔王即坏善回向。后显成德亦是所求。在文易了。大文第二四门。总显回向之意。故初不云复以善根。但云以彼善根回向时。居然拣别四门即为四别。初一门明应向实际。及向众生。第二门明应向菩提。第三门明应离过。第四门明有成益。初门为二。初明应向实际。后又为令下明应向众生。今初本性即不变性。法性即随缘性。众生是人即无分量。无诤是法理事不乖自性。则起无所起。诸法则横该本寂。三世则竖入无差。以知法性为缘。则生起佛种。依性依用无退失时。照斯实际实智行立。后应向众生中。有二十所为。七云十力轮者。圆满摧伏故。十四云无畏菩提心者。不畏生死长远众生难度。转依难证万行难修。菩提旷远故。第二应向菩提者。有二十二回向。前三无为字欲成二十。故于中前二十回向。明因圆果满。后二明得果不舍因。穷未来际以化物。第三明应离过中有标征释。及第四成益。文并易知。大文第三有八门。更以异门别明回向。即是胜进。文分四别。第一二门回向众生。二有三门回向菩提。三有二门总显所为。四有一门回向实际。今初分二。前门愿得圆音。后门总令具德。今初以法师位故。欲令物同得圆音演法要故。有四十五种音声。即密迹经中六十种音。但数不足。次多不同名或小异。彼第一名吉祥。与此净妙义同名异。二名柔软次第与名全同。三可乐即此第五。四悦意。即此第二十一欢喜音。五清净即此第六。六离垢即此二十三远离痴翳。七显耀。即此第三十一一切法光明照耀音。乃至第六十宣诸德音。即此第二十九能说不可说字句差别智藏音。然彼无天鼓。今此缺彼师子龙鸣。好雨海雷龙王。真陀罗伎哀鸾。鹰畅鹤鸣等。以从喻说。此略不论。又此所明显德广大。如彼但云普入众会音。此则云普至法界无量众会道场等。法有所本不可不知。名言不同无俟全会。中间云音声智者。在心为智宣吐称音。皆应具二影略而说。第八。云不可说功德庄严者。大悲芬陀利经说。以三千界众生功德为一聚。更增十倍不及如来一毛功德。展转乃至无见顶。前一切功德总为一聚。更增百千万亿那由他阿僧祇倍。不及如来胸中。大种所发音声一声功德。彼约总说即此别明。然六十种中不出有二。一约具德如柔软等。二约无失。如不下劣等故。不下劣初。有又以此善根之言。通言音声者。声谓四声为音之依。音谓五音。依五行别。木声壅其音角。火声炽其音征。土声宽其音宫。金声清其音商。水声浊其音羽。若一音之义广在下文。第二总令众生具德中十句。前五果满后五因圆。第二三门回向菩提分三。初一门得正果。次一二果因圆。后一依报果满。今初。然上众生得果有其十句。各应有多。今但广初一身则余可例取。文中三。初明得身。次显身用后总结所成。前中初总相。所谓下别相。身是同相余是异相。成坏可知。然此十身通法通智。一光明者。身光智光无不照故。二体无闇障。能鉴彻故。三体不受染。若彼润玉涅而不缁。四净德内充如玉无瑕翳。五非暂时净拣异下流。上三就体辨。次三对境以明。六不为尘坌对上清净。七极微不着对极清净。八垢秽无污对上不染。若就内德即烦恼障尽。名为离尘。习气亦亡名极离尘。所知不住名离心垢。九具相具德。十形充法界智遍十方。山河事理不能障碍。二于一切下依身起用。前四色身用。前三罗一身于法界。后一收万像于一身。次示诸下五句智身用。后示菩萨行愿下。通二身用。后菩萨下总结所成。第二门愿二果因圆中二。初即理起用行。后入一切下即事入玄行。今初。初成行缘身随住故次众生见下利他不空。后于善知识下兼通二利。后入玄中智契名入。无边法界通身智入(从此已下入第三十三经)第三门愿成依果。文分为二。先总明。后其一一下别显。今初十句初牒前起后。后九正显愿相。一愿清净。二愿庄严。三分量普周。四纯善。五无障碍。六具净光。七有佛现。八融摄。九举一例余。一刹之展量同法界。一刹之卷显现无余。展卷无碍。是一佛刹。如一佛刹刹刹皆然。准上华藏。及后人严尘尘尚然。况复刹刹。第二别显中分二。先显宝严。后如宝庄严下类显余严。今初分三初总标次所谓下别显。三是为菩萨下总结。二中复二。先通显宝严。后佛子下别明人宝严。前中以阿僧祇数。但有九十四数。以晋经皆云无量阿僧祇。初有数事。但云无量则阿僧祇言。非是数中之一。但是无数之言。若定是数便为限局。今就九十四内。宝树之中有无量妙宝。以为华果为一。宫殿中有无量菩萨为二。初段显因之后。有无数宝藏为三。一一璎珞中百千菩萨上妙庄严为四。下宝枝中有不思议鸟为五。宝华中有无量菩萨为六。足满百数。文中分二。初十八事略明显胜。初略明。如是一切下举因显胜。后复有下八十二事广显。于中分五。第一二十四事。唯以外宝为严。其间三两。亦标以事名释以法门。且从多判。二复有阿僧祇宝光明下。有十五事。标以事名释以法门。欲显即事成法门故。三宝修习下三事。唯约法门。显即法可贵非要托事。四宝座下二十二事。约于事宝能成法门。或显依中有正明杂庄严。五宝众生下十八事。显于内身六根三业。皆名为宝。并圆明可贵故。此上诸事。或纯或杂或依正无碍。皆以事事无碍法门因所感故。若将一因各对一事。如以寂忍为因所感宝衣等。恐繁不显观者思之。复将一因成一切果。四句融通义如常说。二人宝严者。法华云。彼国何故名曰大宝庄严。其国中以菩萨为大宝故。所以楚魏之朝。亦不以金玉为珍。而以贤臣为宝。遍法界微尘之处。有多菩萨。可谓大心严刹也。三结成宝严可知。二类显余严。有十一事。一一皆有上之百事。并前一百则一千二百。言次第乃至过此百倍者。若言严事过者。则不应言皆如宝严。若准晋经云衣盖幢旛乃至百事庄严。即以香等为百。过此倍之三字译者不妙。若别理通者。以前宝严但列百事。非止唯百。应过百倍则百百为万。表圆融万行。则应回文云摩尼宝严皆如宝庄严。如是广说。次第乃至过此百倍。理则无违。第三二门回向所为中。初一门应为众生。后门应为菩提。今初有二十三句初之二句文。虽在初义通二处。第三成就众生是为总句。下皆是别。始自信心终成种智。其文并显。二应向菩提中。明因圆果满大用无尽。亦显可知。第四回向实际。有二十九句。皆云法界者。理事无碍法界也。皆云住者。智契即事之理无所住故。住即入义以安住故。法界无二即是等义。初云无量住者。一切善根皆是所住。今以无住之住。便同法界无量。他皆仿此。第三回向成益文有十句。皆言安住者。由上智契故能得安也。身等即差别事法。今即平等清净。平等清净即是法界无尽。法界清净即是所得。智能安住全同法界。由八安住成后二用。一一音普断物疑。二上住佛德。佛德虽多略举其四。谓十力四无畏。十自在六神通名广大德。对上种智为佛二严。是出离法。三佛子下依释结名。大文第二菩萨下位果分三。初标得因。次成满下列其所得。三如是等下结得之相。二中略显三种果满。一因果利益满。二于念念下见佛自在满。初总标。后所谓下别显。皆以体用理量但无障碍。是佛自在。三又得下清净果满。由净惑障见性净故。亦先标。所谓下列文显可知。三结能得之相。平等者离能所知故。余并易了。长行已竟。偈文在下。大文第六从尔时佛神力下。瑞应分于中二。先动地生信。后佛神力故下。兴供表行于中三。一供因。二外事供。三阿僧祇下内事三业供。大文第七如于此世界下。结通十方。以是通方之说故。准上诸会或结瑞应。今此结说故别开章。大文第八尔时复。以佛神力下。证成分。云百万者位过前故。大文第九尔时金刚下偈赞劝修分。于中二先序意。后正说偈。于中亦二。先明第十回向偈后叹胜劝修。前中三十六偈分三。初九偈颂所回善根。次七偈颂回向行。后二十偈颂位果。二中分三。初二偈总颂前文九段回向。次一偈颂回向严刹。后四偈颂二段中回向所为。三菩萨具足下。颂位果中三。初一偈颂见佛自在。由己自在方见佛自在。次十七偈颂得清净中。一念中普入三世一切诸佛众会道场智清净。上云八者必在供养故。此广显。此是力能。不可颂前愿成所为。后过去下二偈总结第十回向。然上且依粗相而分。菩萨纵任辩才体势包摄大旨无异。故不委论第二此是下。叹胜劝修通于十向。于中九偈分二先六偈举人就行以叹胜。谓是菩萨所行如来所说。六度随相等行法界离相。等行故是超胜。后智者所有下。三偈结叹劝修大文第十末。后二偈校量功德。德既无限宜可修行。然此显德。深胜高远者。一圆融教故。二约殊胜愿力故。登地已上寄位阶差故。每结云若以殊胜愿力复过于此不可数知。勿谓此深便言地劣。第五会竟

大方广佛华严经疏卷第三十大方广佛华严经疏卷第三十一

        唐清凉山大华严寺沙门澄观撰

    十地品第二十六(入第三十四经)

初来意者。为答普光十地问故。夫功不虚设。终必有归。前明解导行愿贤位因终。今明智冥真如圣位果立。故有此会来也。前是教道此是证道。教为证因。证即证前三心之教。故无性摄论云。此闻熏习虽是有漏。而是出世心种子性。即斯义也。然会来即是品来。一会之中唯一品故。故释名宗趣亦品会无差。晋经此会有十一品。则名等皆别。次释名者。会名有三。一约人名金刚藏会。二约处名他化自在天会。谓他化作乐具自得受用。表所入地证如无心不碍后得而起用故。事理存泯非即离故。因他受用而有所作。非自事故。自他相作皆自在故。将证离欲之实际故。不处化乐者。表凡圣隔绝故。三约法名十地会。即同品名。所以得此名者。本业云。地名为持。持百万阿僧祇功德。亦名生成一切因果。故名为地。本论云。生成佛智住持故。即斯义也。唯识第九云。与所修行为胜依持令得生故者。但语其因阙生果义。有别行译本名十住经。住是地中一义故。仁王兼明云。入理般若名为住。住生功德称为地。而下经又名集一切智智法门。亦兼因果。复有别译名渐备一切智德经。以后后过前前。故名为渐备。渐备即是集义。若名十地就义约喻以受其名。若云十住。唯就法称。十是一周圆数十十无尽。皆带数释。后之二释皆是依主。一切智智之法门故。渐备一切智之德故。十之别名见于本分。三宗趣者。先总后别。总有二义。一以地智断证寄位修行为宗。以显圆融无碍行相为趣。二前二皆宗。为成佛果为趣。后别者。别于上总略有十义。一约本。唯是果海不可说性。以离能所证故。虽通一部此品正明。二约所证是离垢真如。三者约智。谓根本后得亦通方便。四约所断。谓离二障种现。五约所修。初地修愿行。二地戒行。三禅行。四道品行。五四谛行。六缘生行。七菩提分行。八净土行。九说法行。十受位行。六约修成有四行。谓初地信乐行。二戒行。三定行。四地已上皆慧行。于中四五六地。是寄二乘慧。七地已去是菩萨慧。七约寄位行。十地各寄一度。八者约法有三德。谓证德阿含德及不住道。是十地之德故。九约寄乘法。谓初二三地。寄世间人天乘。四五六七。寄出世三乘。八地已上出出世间。是一乘法故。以诸乘为此地法。十者撮要谓六决定。宗辩此故。于此十中。二三四八十通于圆融行布。初一双非余皆行布。多约寄法显浅深故。若以圆融融彼行布。则无不圆融。故以别从总。皆十地宗。若别中之别则地地别宗。别论其趣。不异总趣。论其体性多不出前。为成十故小有加减。一即离言体。二所证体。梁摄论云。出离真如为地体故。三能证体。无性论云。法无我智分地位故。此论亦名为智地故。其所断约离故非地体。若取离惑所显又即真如。四合能所证以为地体。独不立故。梁摄论云。如如及如如智独存故。五收五六七及其第九为随相体。此等皆为成地法故。六取光明三昧即证入体正相应故。论云三昧是法体故。七就德体即教证不住三道为体。八随要体。谓六决定。九总摄体。成唯识云。总摄一切有为无为功德为自性故。十唯因体取其别相异果海故。收此十体不出三体。一总含体。二克实体。谓智与证。三离言体配属可知。上二即因下一为果。因果非即离。言虑双绝以为地体。

问何为地前显圆融德地上行。布彰浅劣耶。答显一乘故。云何显耶。三乘之位。地前行布地上圆融。今一乘位地前地上俱有行布圆融。若俱双辩则前后不异。若地前行布地上圆融。则全同三乘前浅后深。又似行布圆融各别。教行不知法性。教行非即非离故。于地前但显圆融已过三乘。地上多明行布以显超胜。胜相云何。谓贤位始终已圆融自在。登地已去则甚深甚深。言所不至。若不寄位何以显深。不包三乘何以显广。故虚空鸟迹迹迹合空。大海十德德德皆海。地地之中具摄一切诸地功德。文文之内。皆云若以殊胜愿力复过于此不可数知。故刚藏俟五请而方说。世亲以六相而圆融。意在斯矣。又此一会文唯一品。阙于方便及胜进者。正表斯义。所以阙方便者。有二义故。一表证法无二离方便故。二总摄三贤皆为入地之方便故。阙进趣者亦有二义。一十地如佛更无趣故。二以十定等品即此胜进故。若尔何以别会说耶。含二义故。一开此胜进成等觉故。二胜进趣佛行深远故。若别立方便胜进。即不得包摄前后。显地圆融。十地甚深良在于此。地前乃我地之前。安得云深。异于地上此解尤妙。学者应思。第四释文。一品分二。初长行散说。后偈颂总摄。偈中虽有第十地偈。以后有总摄之偈。前隔结通等文。故从文便科之。中间诸颂摄在当地。初长行中二。先正说十地。后尔时复以下菩萨证成。前中亦二。先显此界所说。后如此世界下。结通十方齐说。前中或总为一十地法门。或为二分。谓初正说。后动地等显实证成。或为三分。为序正流通。然教证不同三分亦异。就教三者。初至起分是其由致。以发起正说故。二本分已去是其正宗。正说地故。三地利益分以为流通。益末代故。二就证三者。序分为序。三昧分为正宗。因入此定显实证故。故论。云三昧是法体故也。加分已去皆是流通。由说自所得。令信行菩萨证入地故。或为四分。于正说中。初法说显地影像分喻显地故。教证准前。或为五分。序为远序。三昧已下是近序故。或为六分。随行德分。初至起分起化之由。为生物信。二本分中略说赞胜。起众乐欲。三请分中彰地超言令生正解。四说分中广明修相。令物起行。五影像分寄喻显德。六利益分。明德成证实。感化斯现。或为七分。从初至请分为六。说分遍通于十地故。问论云。初地所摄八分。第七说分。八校量胜分。明知说分唯说初地。如何得通。答若不许通。何为初地独受说名。故知标于总称。即受初地别名。若以论云初地所摄便定局者。则前六分亦不应通。是知八中前七皆通。后一方局。又下说分。虽言自此已后正说初地。既有初地说分。则有二地乃至十地说分。或为八分。开地利益异正说故。或为九分。影像望前法喻别故。或为十分。即是十地。或于前九加后偈颂。此十次第有其三义。一就化相通为起说。二就化意通为显证。三随宗要教证双辩。初之一义随文释中论自具之。今当略辩。一起说由致故有序分。二显证能说有三昧分。三示说不虚故有加分。四定无言说故有起分。五起先略陈故有本分。六闻名渴仰故有请分。七正为广陈故有说分。上七依论次第。八别说难晓以喻总明。有影像分。九为说既竟显胜劝修有利益分。十散说难知有偈颂分。二显证者。初分为显证由致。余九正显证相。于中前三就相显证。一寄入显证。二因加显证。由得加故显证不虚。三寄出显证。不起无言不能显寂故。次四就说显证。谓本分略说显证。请分拂相显寂说及影像寄修相以表德。但法喻不同。次一分就益显证。后一重述证德。三双辩者。初一为由。后九正显教证之相。于中三昧显证。后八显教。从加已去即有说故。八中次第同初门说。或为四十八分。谓初地十地各摄八分。二地二分。三四与九各摄四分。五六各三。七地五分。八地七分。故四十八。问初地八中前七十地。八中后二义该十地。何为论判属初十耶。答地论科文有其四例。一以后摄前例。以前序等近初地故。判属于初。二以前摄后例。后二近于十地故法云摄。非谓不通。三当相分文例。如中间诸分。四显地该收例。谓显十地是陀罗尼法故。诸地中文虽隐显。义必全收一一地中。皆四十八。如初六分属于初地。许该余九。类显余分无所不通。问初不说戒无彼二净。不说禅枝无起厌等。如何诸分地地皆通。答明言义通那引文局。岂不经说。地地之中。具足一切诸地功德。宁许初地不持戒等。已略料拣。次正释文。若依十地即为十段。初欢喜地文有八分。七如前明。第八名为校量胜分。文之分齐至下明显。今初序分。论经别行具六成就。今摄在大部故阙信闻。但有余四。谓一时二主。三处四众。虽有四事。而论但云时处等。校量显示胜故。此法胜故。在于初时及胜处说。而不言主众胜者。意明主众余经容有故。若以相从主既十身。众不可说亦得名胜故。论有等言。今初尔时者时胜。以是初时得名为胜故。论云。婆伽婆成道未久第二七日故。论经别行故标二七。今经摄在大部。但云尔时。即是初会始成正觉时也。且依论明。若以初表胜。初七最初何故不说。论云。思惟行因缘行故。因者能说之智。缘者所化之机。欲将所得妙法。以逗物机故云思惟行行。故法华云。我所得智慧微妙最第一。思惟因也。众生诸根钝等。思惟缘也。论云。本为利他成道。何故七日思惟不说。显示自乐大法乐故。此问意云。在法身地见机堪化。方应成佛何用更思。今答意云。非是思而后知。自为受法乐故。大法乐者。即所得智慧寂静乐也。论云。何故显己法乐。为令众生于如来所。增长爱敬心故。复舍如是妙乐。悲愍众生为说法故。何故惟行因缘行耶。显示不共法故。谓穷智究竟照机无遗。除佛一人无能及者。名不共法。又因缘亦即所证深理。唯佛穷故。二世尊者主胜义如前释。三在他化下处胜。论云。此处宫殿胜故。宫即自在天宫胜下五天故。殿即摩尼宝藏纯宝所成。胜宝严故。他化天宫。既表地智无心而成化事。摩尼宝殿。亦表慈覆无心出用无尽。若以欲顶为表胜者。色界尤胜何不彼说。论云。此处感果故。谓机感在此故。又色界为长寿天难不能感果。能感胜果必是欲界之身故。密严中明。此处十地菩萨常所游履。大乘同性经云。此处有报佛净土故。于此处说。若唯约机感失所表义。四与大下众胜。文分为五。一拣定众类。二住一切下叹其胜德。三其名下依德列名。四如是下结数难测。五金刚藏下标说法主。今初又三。一拣大异小同菩萨故。二其诸下拣尊异卑。谓八地已上念不退转故。弥勒问经云。自分坚固名不退。胜进不坏名不转。若准论经又云。皆一生得无上菩提。则皆等觉。等觉亦通念不退故。又仁王经。一生正得下寂灭忍。言不退者不复退入无生忍故。显文虽尔本迹难量。多是诸佛之所化故。三悉从下拣新异旧。他方集故。二叹德中有二十句。初二略明后二总结。中间广叹。今初略中。初句自分行满。谓权实无碍智住真俗双融境。境智一如无住住故。后句胜进行满证佛所证。则是如来勤行不息。故名菩萨。二善能下广叹有十六句分二。前十三句广自分。后三广胜进。前中亦二。初三明行修具足。一神用善巧。二调化应时。三行愿遍于时处。余十句德用圆备。四福智益而不竭。五权实知慧虽已究竟。六以无住道不舍修行。七内证定智通明。八外用施为自在。七中若顺三乘法相。禅即四禅定即四无色定。解脱谓八解脱。三昧者此云等持。平等持心趣一境故。即三三昧诸有心定。三摩钵底此云等至。由离沉掉至一境故。局在定地通无心定。谓无想灭定等。神通明智。即通目一切有心无心定地所引功德。今此菩萨皆能善入善引。若就一乘释者。禅定即十禅定。解脱即不思议等三昧。等至各有无量百千通明及智。皆各有十。十十无尽是普贤位菩萨所得。九内获自在干能。十外能一念周遍请法。十一护法。十二供养。十三二利勤修。后三广胜进。即三业广大。及下结文并显可知。三列名中。前三十八同名藏者。表于地法有含摄众德出生果用故。后一名解脱月者。即请法上首脱众疑闇使得清凉。如夜月故。又藏表根本智包含出生。月表后得清凉益物。苏利耶者此云月也。俱苏摩者悦意也。即是华名。余之别名可随义释。四结数可知。五标法主。论云。何故菩萨说此法门。为令增长诸菩萨力故。谓彼同类而能尔故。菩萨众多。何故唯金刚藏说。论答云。一切烦恼难坏此法能破。善根坚实犹如金刚故。不异名说。此释金刚。谓表地智有坚利二义。如金刚故。能坏烦恼即是利义。下释藏义。论先问云。何故名金刚藏。此问意云。为以藏摄金刚名金刚藏。为以金刚而为藏耶。上即有财下即持业。而论双顺二句。顺后句云。藏即名坚其犹树藏。谓如树心坚密能生长枝叶华实。地智亦尔能生因果。此就能藏名藏。次顺上句云。又如怀孕在藏。是故坚如金刚。如金刚藏。此谓子孕在胎藏中。善业所持坚不可坏。而得生长。此就所藏名藏。二喻俱有生长之义。论下广合云。是诸善根一切余善根中其力最上。犹如金刚。亦能生成人天道行。诸余善根所不能坏。故名金刚藏。此之一合通上二喻。是诸善根。谓无漏善。余诸善根即二乘地前。今无漏善于余善中如孕在于胎藏其力最上。双合二喻坚义。亦能生成通合二喻生长之义。其力最上犹如金刚。当体名坚。余不能坏对他名坚。等二尔时下明三昧分。尔时者众已集时。金刚藏菩萨者标入定人。为众首故承佛神力者。辩入所依。显定深玄唯佛穷究故。推功有在无我慢故。菩萨大智慧光明三昧者。显所入定名。三昧通称余皆别名。智慧是体光明就用。照二无我。证如名慧照事名智。此二无碍能破见惑及无明。故名曰光明。大有二义。一拣异凡小。二能断大惑能证大理。成大果故。彰非果定故云菩萨。即照之寂故云三昧。智与理冥故称为入。论经名为大乘光明三昧。则光明即智。此与唯识第九四定初定名同。然其体性不出三种。一定。二慧。三所证如。以具能所证兼寂照故。所以入者。意略有六。论但有二。一谓表深。论云。显示此法非思量境界故。二即以此义显非证不说故。余四如十住品。第三入是下加分有六。一辩加所因。二即时下能加佛现。三作如是下赞其得定。四善男子此是下。双辩加定因缘。五欲今汝下辩加所为。六善男子下别显加相。今初。入是三昧已者。若未入定佛不加故。故下论云。所以偏加金刚藏者。得此三昧故。十住会云。以三昧力故。二能加佛现中有五。一佛现时。谓正入定时。二十方下来处远近。三各有下能加佛数。四同名金刚藏。显名同所加。五而现其前现身生信。上二三中。意明多数胜前位故。若尔何以不言无量世界。而云十亿刹尘界耶。论云。方便显多佛故。谓无量虽多。其言犹漫人不谓多。今假以刹尘。一尘一刹一刹一佛。便谓细而叵测。若尔但趣举刹尘即已显多。何要定言十亿。有二意故。一为说十地故。二此经如是多说十数。显无尽故。即由此义不云无量。无量不得显无尽故。何要显此多佛加耶。论云。显于法及法师增长恭敬心故。又表诸佛皆同说故。何要同名加。论有二意。一云本愿力故。何故如来作如是愿。显示多佛故。此三昧是法体。本行菩萨时皆名金刚藏。同说此法。今成正觉亦名金刚藏。故不异名加。此中论意云。诸佛因中得定名金刚藏。遂发愿言。我成佛时亦同其名。所为同者。为显菩萨所得法体同于多佛。明人异道同故。论意正尔。若以义取亦通遮那本愿。以佛因中得定说法。能加所加同名法尔。亦发斯愿。以显道同故。下经云。亦是毗卢遮那如来本愿力故。第二意论云。又是菩萨闻诸如来同己名已。增勇悦故。前就法理此就化仪。第三同赞得定显有加因。第四双辩加定因缘中。有四因缘。一伴佛同加故。二主佛本愿故。三主佛现威故。四定者智力故。初之一事唯得定因。先由佛加方能入故。故论云。彼佛先作是愿。今复自加。后之三事通于二因。由此能入定由此得加故。非正加相故。论云。后余佛加故。言卢舍那佛本愿力故加。此论意云。后文方显诸佛加相。即由此中本愿力耳。则此是加因。若约得定。由主佛加则此中愿等已显加相。但意冥加故。即前承佛神力耳。是则定因有四加因亦四。虽阙伴佛加因。而有得定一因。故有四也。所以第三会中。后三因初有又是之言。四五两会同云亦是。故不可将前一因为正作加。若此已作加。何用下文正显加相。余如第三会辩。第五明加所为故。论云何故加。然直就经文则应分二。初总明。后所谓下别显。论无所谓二字。故取别中入智地句。入初总句。总别合明但有二十。前十依自利行。后十依利他行。义虽兼通从多分判。欲显二利差别相故。今依论释。初十句中。论以二门解释。一直释经文。二会通本末。初门先释总句。彼经云。又一切菩萨不可思议诸佛法明说。令入智慧地故。既将别句入总。即经论开合不同。论经云明。即今经光明。但广略有异。彼云明说。此云说不思议。彼未回文。即经论方言有异。既知二经同异。次正释文。初欲令汝为者标举章门。总显加意。意为何事。谓一切菩萨说等。此中三义。一一切菩萨是所被机。二不思议诸佛法光明。是所说法。三令入智地是说之益。被何等机。论云。是中一切菩萨者。谓住信行地。此通二类。一谓地前未证真如。但依信心而起行故。无著论中亦同此名。二通地上。如初地加行位中名信行地。即地地加行皆名信行。以摄论中意言无分别观通于四位故。知地上亦有信行。下释所入智地。及别入中皆通十地。明知所被不唯地前。况下请分中。论云。未入地者令得净心。已入地者令得十力。必通被也。二中说何法被。此有二种。一所证法。论云不可思议诸佛法者。是出世间道品。此明十地法体是无漏。故名出世间。生佛果故名道。十位行法类别名品。既是佛因是佛所证。故云佛法。心言路绝名不思议。二说能证。论云。光明者见智得证。此谓后得观事差别名见。根本观理一相名智。见达于事名得。智契于理名证。直语智体故言见智。以智合境故言得证。地法虽多不出此二。见智虽广此释正宜。故解深密第三云。我无量门宣说智见。今当为汝略说其相。若缘总法。修奢摩他毗钵舍那所有妙慧。是名为智。若缘别法。修奢摩他毗钵舍那所有妙慧。是名为见即斯义也。上云说者令分别上来能所证法。三中说此何益。令入智地。论云。入者信乐得证。此中信乐即所被机得证。即上二智契。合入何法耶。所谓智地。论云。智慧地者谓十地智。如本分中说。即上不思议佛法也。上说能所证者。意令菩萨以能证智。入佛所证法。是此总意。已说总句入地之相。次下九句。依本开末显入差别。论云此修多罗中。依根本入有九种入。此九种入寄于四位。初四愿乐位。次一见位。次三修位。后一究竟位。近地方便亦属地故。地后胜进趣究竟故。皆十地摄。言九入者。一者摄入。谓闻慧中摄一切善根故。二者思义入。思慧于一切道品中智方便故。智方便者。即善拣择道品。即是佛法。三法相入。彼彼义中无量种种知故。彼彼即是诸法。种种知即广知。此即所思法成。四教化入。随所思义。名字具足故。能善说此知修慧。修通二利。菩萨利他即是自成佛法故。入自利中收。五证入于一切法中。平等智。见道时中善清净故。言平等者。即无分别。无分别智正证真如。离二取相故云平等。二我分别随眠不生。名善清净。最初照理立见道名。六不放逸。入于修道时中。远离一切烦恼障故。故世法不染。七地地转入。出世间道品无贪等善根净故。此明修道位中。离障证理智行转进。于地地中双断二愚。是无漏善能净所知。以此无漏净三善根。名净烦恼。论云。复有善根能为出世间道品因。此明诸地中加行善根净也。八菩萨尽入。于第十地中。入一切如来秘密智故。即下大尽分中。入如来十种秘密之智是也。如来秘密下地不测。名不思议。若入彼所入是智之境。入彼能入即智是境。得即是入故。叹净名云。诸佛秘藏无不得入。九佛尽入。于一切智入智故。上一切智释一切智入。下智字即智境界。入即得也。上直释竟。自下论文融会本末。初会末归本。谓上九种入。为欲校量地智差别转胜之相。非根本入有此行布。后明本末无碍。欲显前从本起末。则无别之别。次摄末归本。别而无别故。以六相融而无碍。论云。一切所说十句中。皆有六种差别相门者。此标举显通。故云一切皆有此言说解释应知。除事者此显立意。谓此六相为显缘起圆融之法。勿以阴界入等事相执取。言六相者。谓总相别相。同相异相。成相坏相。此标列也。下释云。总者是根本。入者以初一入无不摄故。别者余九入别依止本满彼本故者。谓依一开九。无总别不立故云依止。由别方成总故云满彼。同相者入故者。同名入故。异相者增相故者。九相渐增不相似故。成相者略说故者。揽九缘以成一略言标显故。坏相者广说故者。分一作九九外无一。此九因缘各住自相不相成也。又云。如世界成坏者。犹如世界多缘共成。其中事物一一推征。何者是界名坏。亦如梁等共成一舍。总则一舍别则诸缘。同则互不相违。异则诸缘各别。成则诸缘办果。坏即各住自法。余一切十句皆应随义类知。别章广显。第二又令得下。十句依利他行是增数十。经有十二句。论经合七八二句故唯十一。初句为总余十为别。总中始者内起信欲外近善友听闻。终者忆念任持所闻地法。地地皆尔。故云十地始终。此约教行。复有阿含为始以证为终。则前皆是教。此教证义总有九重。一教行相对。言声为教行德为证。犹下请中字义二藏。二地前地上相对。如下请中叹众。以地前闻思修等为教净。地上行德为证净。三真伪相对。即于地中闻思修慧报生识智缘照之解。名曰阿含。真智出言为证。下论云。闻思修等是则可说。地智离言。四修成相对。一切地中真伪合修为教。舍伪契真为证。犹下所明义说二大。五相实相对。世间中修得彼证相名教。契本实相为证。犹下所说增上妙法光明法门。光明是教增上是证。六体德相对。就彼离相所成行中。显本法性为证。依本成德为教。犹下炼金金体与钏等。七体用相对。前体及德皆证。依体起教智之用为教。下珠放光。光喻于教珠体喻证。八自分胜进相对。自分所成体德及用皆证。进受佛教为教。下叹金刚藏。二力妙智及辩名为证力。坚念教法为阿含。九约诠就实相对。真智之体为证。约言分十为阿含。犹下迹处虚空喻证。空处之迹喻地阿含。下论云。字身住处证智所摄。非无地智名句字身。名句字身即阿含也。今当第四。一经之内频语教证。理须通会勿厌繁文。次依根本始终有十始终。前三地前思修利物。次一见道余六修道。此陜前入。谓初阙闻慧。后无佛尽者理实齐通。以此二并非正。地前已说竟。故此略无。一摄始终。经云。如实说菩萨十地差别相故。谓以思慧智摄持所闻。称思宣说。故云如实。二欲始终。缘念佛法意欲令物证故。此即思慧上品求心。三行始终。以是修慧故名修习。言分别无漏法者。于地上无漏道品。起意言分别观行故。以未证故。但是观分之时带相观心。未觉无相故云分别。四证始终。即见道位。大智者即真见道。根本法无我智过小乘故名大。治无明故云光明。此智亲证真如。平等平等离二取相。名善观察。实断二障分别随眠。名善选择。巧庄严者即相见道。是后得智故论名方便。方便即巧法。真见道种种建立名为庄严。又庄严者即二智成德。由得此二善达法界。于多百门已得自在。故云庄严。故论云。此事中彼时中皆善知故。由相见道复有二种。一观安立谛名此事中。二观非安立谛名彼时中。以法真见道正证如时不可名事。相望前真故名为彼。五修道始终。论云。出世间智智力得入法义故者。以后得了俗由于证真名出世间智。智由证真达俗。故名善入。智能入法即名为门。上寄从二地至七地竟。次下五句有五始终。寄入八地至于佛地。治菩萨于菩提五障。五障在于七地。至于等觉。经文但有能治障在文外。今初二句即能破邪论障。始终不能破邪论障即是所治。随所住处者。即邪论心住着之处。言次第显说者。以宗因喻现比教量。显己正义随病治之。上皆论所据。言无所畏者。即论庄严。后句辩才即是论体。亦论庄严。谓语具圆满顺言敦肃。故名辩才。又上皆论多所作法。所作有三。一善自他宗。二勇猛无畏。三辩才不竭。配文可知。言光明者。性不闇故。即论出离。谓善观察得失等故。由具上诸义故不堕负。由破此障得入八地。二能善答难始终。上明能破此显能立。第九善慧是辩才。地住即证也。三乐着小乘对治始终。不忘菩提上求下化故。四化众生懈怠对治始终。成就不疲故。五无方便对治始终。善达五明为一切处开悟。故能巧化。又上五障。一不能破邪。二虽能破而不能立。三虽能破立情乐小乘。四虽不乐小乘而不勤化他。五虽化不疲而无化方便。治于此五行化略周。第六正显加相。论云。已说何故加。复云何加。加相有三。谓口意身。约别相说。口加以益辩。意加以与智。身加以增威。如实说者。能加则局所加皆通。乘前语便故先口加。得智堪说事须起定。便身触令觉故为此。次此就十方佛辩。若约舍那先意令得定。当有所说。次身光照触增威。后云台说偈令演。亦义次第非有优劣。初口加中有十一句。初总余别。总中令以乐说辩说十地法门。名相差别不违事理。善巧成故。故云汝当辩说等。所谓下十句别中。依根本辩才有二种辩才。一他力辩即是初句。谓承佛力。承何力耶。如来智明故。二自力辩。即后九句。自他因缘方有说故。摄此九力为四种净。以因中有四义故。一有力能作。二无力不作。三具二能引生。四泯摄前三。称理成德故为四净。一净自善根者。有作善法净即是教行。亦约相故名为有作。二普净法界者无作法净。此约证行。亦约体故名为无作。依此性相而有说故。上二皆自利。三普摄众生者教化众生净。即是利他。余六句经皆名身净。摄为三种尽。皆显二利满故成德。成德有二义。一当位显益有菩萨尽。二寄对辩胜有后二尽初菩萨尽者。因位穷终故。摄经三句。初句位满。谓十地胜进破和合识。显现法身。非心意识之所能得。唯如智所依成于智身。菩萨照寂故云深入。后二句成益。一成现报益。得佛灌顶受佛位故。二成后报益。十地摄报。生大自在。云高大身。高大二义。一色形中极量最大故。居有顶故。二约三乘。此成报身位极普周。故云高大。论云。摩醯首罗智处生故者。智处亦二义。一摩醯首罗智自在故。二摄报智满成种智故。二寄对显胜中。一对下彰出有二乘不同尽。摄经二句。一超一切世间道者。度五道故。道即因义。二清净出世善根者。论云。复涅槃道净故。以二乘虽度五道有三余故。不净涅槃。今无三余故云复净也。由具此二故不同二乘。后一望上显同名为佛尽。等觉菩萨同满种智故。自力辩中多义显者。校量后后胜前前故。第二意加中二。初正显。后征释偏加所以。前中十句初总余别。总中身有二种。一与无上胜威德身。如王处众无能映夺。二与辩才无能映夺身。前色身胜后名身胜。后与无碍下别。别开名身成九种身。所加通三故。增其色身。在心名智在口称辩。经云与智论判为名。二文影略显义方备。一与不着辩才。说法不断无滞碍故。谓无偏住着故。不滞事理。云无碍乐说。二与堪辩。分别法相能正说故。名为清净。论云。善净堪智有四种。一者缘。二者法。三者作。四者成。善知此义成不成相故。此言缘者。即因缘生法亦名观待。二法者即法尔之法。三作者。此二作用。四成者。引正理例证成上三。若顺此四名为成相。不顺此四名不成相。菩萨善知故堪能有说名为堪辩。然其此四经论多明。相续解脱经名为四成。相续解脱即解深密经。前后异译。深密第五名为四种道理。然上二经文博义隐。今依杂集十一释之。名次全同深密。彼论云。观待道理者。谓诸行生时要待众缘。如牙生时。要待种子时节水土等。二作用者。谓异相诸法各别作用。如眼等根。为眼等识所依作用。色等境界。为眼识等所缘作用等。三证成者。谓为证成所应成义。宣说诸量不相违语。所应成义者。谓自体差别所摄所应成义。诸量不相违语者。谓现量等不违立宗等言故。四法尔者。谓无始时来。于自相共相所住法中。所有成就法性法尔。如火能烧等有为法无常等。而彼经论次第尔者。谓缘生之法。有此作用以理成证。后结诸法性相常尔。今论义次已如前说。三即任放辩才说不待次。言辞不断。处处随意不忘名义故。云善忆念不忘力。谓随门异说不忘本宗故。四能说辩。随所应度种种譬喻能断疑故。谓应机断疑故名决定。能随所应是谓明了。五不杂辩。三种同智常现前故。三同智者。即自相同相及不二相。自相者色心等殊故。同相者同无常苦无我故。不二相者即一实理。又自相即俗谛。同相即真谛。不二即中道第一义谛。金刚仙等诸论。皆明此三无法不尔。故云遍至一切菩萨所了故云开悟。六教出辩。以十力智自在化物。断惑得果故云自在成道。七不畏辩。于他言说不怯弱故。八无量辩。于一切智。随顺宣说修多罗等法。六种正见故。六正见者。即是法门。金刚仙论云。一真实智正见能知理法。二行正见能知行法。此二教旨。三教正见能知教法。四离二边正见。知前理法不同情取。五不思议正见。知前行法成德出情。六根欲性正见。知前教法说随物心。瑜伽六十四名。六种理门。大旨无异。九同化辩。一切如来同以三轮化故。三业殊胜故曰庄严。上十已辩他力。第二何以故下释偏加所以。以显自力堪加偏就意业释者。意为本故。初征意云。诸佛慈力若随阙者可许偏加。既有力能与有慈能普。何以上十偏加刚藏而不加余。下释十句初总余别。总明得此三昧法合偏加。刚藏得此余不得故。何以得此三昧。下别显中有二因故。一本愿所致故。即初句显示。二善净下。三昧身摄功德故。此复八种净。依自利利他故。谓前四自利后四利他。一善净深心是因净。信乐至极能趣菩萨地。皆尽清净故。故云善净。此一为众行本故名为因。次三明自利行德。谓二即智净。趣菩萨地尽。修道真如观如日轮圆满。普照法界故。此即智德。三身转净。谓生生转胜集助道福德故。四心调伏净善断烦恼习。故云修治。此即断德。上三亦证助不住。后四利他中。五闻摄净。能闻持佛法。故为法器。此利他方便。余三利他行体。即身语意业。六者通净。以胜神通生物信解故。七辩才净。由总持力于一字中摄一切字句。前后无违故无错谬。八离慢净。谓虽化众生。以实智印印之不违法界。故无化慢。上八句中。前四自利因。一精进因。二不忘因。三势力因。四彼不染因。如次配前四句。谓由深心能起行等。后四利他因。谓五是断疑因。由知法故。六是敬重因。以神通力令信入故。七是转法理因。法若坏时。假余尊法诵持故。八教授出离因。论云。如是化者得自利不忘故。此意明。若化时取相。以法界印即自利不忘。便能出离。第三身加增威令起故。言各申者。不离本处而申。即延促无碍。诸佛皆摩故云各申。即一多无碍。即四通中如意通也。余义如前第三会中说。第四摩顶已下起分。所以起者三昧事讫故。云何讫已得胜力故。虽已得力何不且定。说时至故。何不定中说。定无言说故。第五普告下本分略示纲要。为广本故。亦与下请。为其本故。不请而说者。不自说本。众则不知为说不说。又复不知欲说何法故。文分为三。初明六决定。以为地体。次佛子何等下标列十名。以显地相。三佛子我不见下。举十方同说彰地要胜。今初地体已如前辩。文中初句标。告诸佛子下正显。于中初句总明。后无杂下别显。总中言菩萨愿善决定者。标人列法。故云菩萨于大菩提立誓趣求故名为愿。即下初地中发菩提心也。此愿所以名善决定者。以真实智摄故。谓摄导此愿。皆令顺理决择揩定故。真智即善善即决定。持业受名。故论云善决定者。即是善决定。此拣依他受名也。此已入初地是证决定。非是地前信地所摄之愿。受决定名。若通论决定。有其六义。一约行体决定坚固。二望所证决定须证。三定能断惑。四决信不疑。五决圣度生。六决成佛果。后别中此善决定有六种。即经六句。瑜伽地持皆说此六。名次小异大旨不殊。此六行相。前五自分后一胜进。五中前四自利。后一利他。四中前三明行体德。后一显行功能。三中前二行体周圆。后一行德具备。二中初一明行自体。后一显行离过。是故自体离过摄德为因。二利行圆成就佛果。是此行相也。一无杂者。即观相善决定。真如观一味相故。谓正体缘如。境智一味为观之相。则无带相之杂。二不可见者。是真实善决定。非一切世间境界。出世间故。谓此真智超出世间可坏之法。故名真实。真实故非世智所见。三广大如法界者。胜善决定。论总释云。大法界故。一切诸佛根本故。此中上句出所如法界。亦释大义。下句显能如地智。亦释广义。法界所以名界者。一是因义。迷悟根故。二是性义。法本性故。今能如地智为佛根本。故得如之况体合如无所如矣。下开义释。经标广大释以胜善。此云何同。论总释云。大胜高广一体异名。法相义故。言一体者唯一味故。异名者随法相义故。体无不在曰大。而相非情取曰胜。理超数表为高。用无不该为广。上释广大二字。次释法界名。云一切法法尔故。一切法者释法字。法尔者即是界义。性自尔故。下法尔字皆仿此知。此上释所如法界。下辩能如地智。亦受四名。一双释大胜义云。复法界大真如观。胜诸凡夫二乘智等。净法法尔故此云净者。异前所如体该染净故。此即根本智地。当体称如周遍名大。形对凡小超劣名胜。二释广义云。复法界大方便集地。谓说大乘法法尔故者。以证真了俗广集大行。既通二智故曰大乘。三释高义云。大白法界善法法尔故。谓无漏善法出世表故。即二智所成之善故随义立四。不出境智一如。四究竟如虚空尽未来际。是因善决定。此有二种。一成无常爱果因。是因如虚空依是生诸色。色不尽故。二常果因。得涅槃道故。故经云尽未来际。有释云。一为生因。生菩提有为果故。二为了因。了涅槃无为果故。此顺法相不顺经宗。以经宗常与无常非一异故。今更直释论文。明此地智有其二能。一寂而常用故为无常因。用虽亏盈而智无起灭。如所依空非无常故。经明此智究竟如空。二用而常寂故为常果因。虽涅槃永寂而智体不无。不尔将何穷未来际。若会三身者。用为化身。寂为法身。智为报身。非无常矣。设智为了因亦双了菩提涅槃故。论云涅槃道。道亦菩提故。若相融摄固不在言。言无常爱者用适机故。五遍一切佛刹。救护一切众生者。大善决定。随顺作利益他行故。即普覆名大。论又云。次前善决定此愿世间涅槃中非一向住故者。谓由前因善则大智不住生死。由此大善则大悲不住涅槃。前虽有应用。亦智所成故。有云。取前常果因故不住生死。取前无常果因。及此大善。为不住涅槃亦不违理。然约双遮则俱不住。若约双照即二俱住。谓大悲故常处生死等。是故论云非一向住。六为一切下是不怯弱善。上入智地不怯弱故。论经阙于一切诸佛所护一句。但云入智地不怯弱。若准此经由护故入智无怯。言佛护者。智造佛境佛智照故。故佛所护与入智地反覆相成。论下六相圆融类前可见。第二地相中四。一寄问征起。二佛子下举数显同。三何等下征数列名。四佛子此菩萨下结名显胜。初一可知。二中以生成住持故。三世同说。同说之言。文在地相义兼地体。三列名中。为对治十障证十真如成十胜行。说于十地及引诸论。并如下广释中辩。今依本论略释地名。论云。成就无上自利利他行。初证圣处多生欢喜。故名欢喜地。此有二义。一二利创成故。二圣位新得故。遂本期心故生欢喜。二离能起误心犯戒烦恼垢等。清净戒具足故名离垢地。此有三义。一即因离。谓离能起误犯烦恼。二果行离。谓离犯戒恶业故云等也。三对治离。谓清净戒具足。三随闻思修等照法显现。故名明地。此唯一义。谓三慧照当地所闻之法。若准下论更有一义。谓得四地慧光明相故。如明得定等故。下论云。彼无行无生行慧此名光明。依是光明故名明地。然唯识此经皆名发光。谓成就胜定大法总持。能发无边妙慧光故。此则三义。一定为能发。二持为能持。三后地慧光为所发所持。然三慧就初。发光约后。故受名不同。四不忘烦恼薪智火能烧。故名焰地。焰即慧焰故此名焰慧地。此亦兼下二义。今即根本智火能烧前地。闻持不忘恃以成慢之烦恼故。二就后得智起用故。下论云。彼证智法明摩尼宝光中。放阿含光明入无量法门义。光明智处普照示现。以是义故。此地释名为焰。问约初义者。前后诸地岂不烧惑。有二义故此偏受名。一就寄位言。此地寄当出世间无漏故。二以三学此地当慧。初得慧故。五得出世间智方便善巧能度难度故名难胜。此唯一义。谓真俗无违极难胜故。以三地同世未能得出。四地虽出而不能随。多滞二边难以越度。今得出世。又能随俗巧达五明。真俗无违能度偏滞实为难胜。此初得故偏受其名。六般若波罗蜜行有间。大智现前故名现前地。谓妙达缘生。引无分别名般若行。亲如目睹名曰现前。对后彰劣名为有间。以第七地常在观故。七善修无相行功用。究竟能过世间二乘出世间道。故名远行。此或三义。一善修无相到无相边。故名远行。二功用至极故名远行。三望前超过故名远行。合唯一义善修无相行。释行字。功用下皆释远字。然善修有二义。一前地有间不名善修。今常在观故云善修。二舍有之无非善修无。今有无双离。故名善修。云何双离。谓空中方便慧故离有。有中殊胜行故离无。下释远中功用究竟正明远义。如极一界之边故远。何所过望前三地相同世间。过之已远。望四五六相同二乘。今亦超过五地真俗无违。何异此中有无双离。略有三异。一彼犹未能过二乘故。二虽以真入俗犹于双行未自在故。三彼尚未得甚深般若故。于双行非深妙故。八报行纯熟无相无间。故名不动地。此亦三义。一舍三界行生受变易果。故云报行。依此起行任运而成。故功用不动。二得无生忍无相妙慧。则有相不动。三此二无间烦恼不动。合唯一义。谓前地无相已得。无间相及烦恼亦不能动。而为功用所动。无不动名。今由无功用故。令无相观任运无间故。三不能动。下轮王梵王之喻可以证此。九得无碍力说法。成就利他行。故名善慧地。得无碍慧尚未称善。遍说遍益方名为善。十得大法身具足自在。故名法云。此有二义。一得大法身语法云体。具足自在释法云义。谓能云雨说法自在用故。此约能说为名。二得大法身此明法义。是大法器故。具足自在此释云义。能受如来云雨说故。下释名分自当广释。此十得名略有四对。一约法喻。焰慧法云法喻合目。余皆就法。二约体用。欢喜善慧约体为名。余皆就用。三约自他。离垢不动就他受称。余皆自义立名。四约当位相形。虽胜远行形他受称余皆当位受名。此十圆融地地皆具。若约行布。则前前之名应该后后。后。后之称不该前前。如欢喜之名义该十地。法云之称不预前九。今为显别相。各从初得受名。下文重显。四结名显胜可知。第三彰地要胜者。为欲令物生渴仰故。文中二。初明不见不说。反显十方报化皆说。二征释所由。征云。佛国不同化仪亦异。如何十地要皆说耶。释意云。此最胜故。谓万法皆如体如成圣。离斯证智皆是随宜。故为要胜。文有四句。初二句总标显胜。初句证行。谓诸佛证此为因成菩提故。余皆助道故。此最上最胜。次句阿含法门者。名为法体。光明者显照一切余法门故。后二句别显其相。初句释前阿含。云分别说即明前法光明。是教体用。此句是教所照法门故。论云。分别十地事者。显示世间智所知法故。后句显上证道非地前世智所知。名不可思议故。论云。显示出世间智故。说证将默。故呼佛子已说本分

大方广佛华严经疏卷第三十一大方广佛华严经疏卷第三十二

        唐清凉山大华严寺沙门澄观撰

第六尔时金刚藏菩萨说。此下请分中三。初说已默住。二是时下三家五请。三尔时金刚藏观察下。许说分齐。所以默者。将欲演之必固默之。欲令大众渴仰请说故。所以俟请者。略有二意。一增诸菩萨尊敬法故。二前本分中。举地叹胜。为增乐。欲令此请中生正解故。云何生解。谓由请故得说默之由。显地体甚深离于言念。令众先解。后闻说分不随声取。离谬解故。即复由此故。有第三示说分齐。初默可知。第二请中三家请殊。即分三段。谓初解脱月请。二大众请。三如来请。所以要三家者显法深妙。令闻解故。众首显扬当机渴仰。化主加劝事方周故。道大兼亡法应请故。为顺请主。此众堪闻言不虚故。为成请者。如来护念而生信受言有征故。此约因请生请亦是次第。又佛请者即名为加。谓众虽已请要假主佛威光。方堪说故亦名为教。如来教说显刚藏说。传佛教故。又前二家请。显此地法因人修故。后一家请。显此地法佛所证故。前之二请余经容有。后之一请余经所无。法华三请但是一家。良以地法甚深寄位难说故。又三请次第者。初解脱月者彼众上首故。余问则乱。何缘大众不乱问耶。众调伏故。由前二止三请抑扬时众故。次众请以表虔诚。然非争起。依前请仪同声齐请。故亦不乱后。听说理穷故如来劝说。今初众首请中。总有三请。所以三者顺世仪式。少不殷重多则繁乱。正得中故。以止有三。抑扬当时调伏机故。二家助成各唯一请。然依三请应分三段。若兼三止应分为六。以前默住之止。通为五请之本。不可唯属于初故。止请相乘。且为五段。一怪默腾疑请。二法深难受止。三叹众堪闻请。四不堪有损止。谓虽有堪者亦有不堪故。五双叹人法请。谓不堪闻者以法深故。亦得佛护固应为说。于是刚藏理穷更无违请。就初请中分二。初明大众睹默生疑。二解脱月下腾疑为请。今初言何因何缘者。疑怪之辞。为因说者不能说耶。为缘听者不堪闻耶。金刚藏下出所疑事。二腾疑为请中二。初叙请因。谓领众疑故。二以颂正请。文有五偈显说听无过。是以应说。即分为二。初偈说者无过。亦遣大众何因之疑。后四听者无过。亦遣大众何缘之疑。虽似初二征默所由。为拂众疑。后三请说为遂众欲。文彰略耳。非不互通故依前判。今初叹说者净觉无过。偈初二字偈末三字。合为征问之词。谓有中间净觉无过。何故不解释耶。圣德虽多偏叹净觉者。是说因故。觉即觉观。由此得为口加行故。具能所治无思发言故云净觉。净觉之人名净觉人。三字为总。余皆是别。别叹净觉有二胜能。一摄对治。谓念智具。念谓四念智谓如智。二离诸过谓余十字。具字两用。初中由有能治。所治不生。所治有二。一者杂觉。谓凡夫寻伺与四倒相应。即迷事倒。以四念为治。二杂觉因忆想分别。谓随名相转即迷理倒。以真如智为治。前唯凡夫。后通凡小。言离过者离三种过。一由无嗔等功德具故。离悭嫉过。谓无嗔治嫉等取无贪。无贪治悭不等无痴。无痴即前念智摄故。二由前已说上妙地故。无说法懈怠过。三由有乐说辩力无不乐说过。然念智正为治杂觉等。故受治名。而无嗔等本意不为治于嫉等。有此任运自无彼故但名离过。第二叹听者无过中四。偈分三。初二叹同生众。论云。同法决定故。有乐闻故。次一偈叹异生众。论云。复示余者心净故。后一偈双叹。论云。又显此众皆堪闻法故。今初二偈前偈叹根。故云决定。后偈叹欲故云欲闻。若有欲无根虽闻不解。有根无欲设闻不受。故须双叹。今初同法即是同生。拣后异生。决定即是根器。拣后乐欲。初句为总。论云。决定者黠慧明了故。黠慧即根黠能知教。慧能入证故。次二句别。论云。决定有三。一上决定愿大菩提。故云勇猛。二名闻决定。他善敬重故云无怯弱。由内无怯弱外着大名。三摄受决定。谓彼说者善知故。即经说地名由堪摄受方为说耳。下句征默可知。后偈叹欲中。初句所欲之法。次二句正明有欲。后句结请。论云。是中若但有阿含决定。无证决定。但有非现前决定。无现前决定。如是决定法器不满足故。不能听受者。现前是欲现见起故。非现前是根。但冥具故。此中意明。但有根而无欲不堪闻法。今前偈于教决解于理决证。具二决定。为非现前之根。复有今偈现前之欲教证决定。则具足决定故堪受也。其心无怯弱者。论经云。佛子智无畏。无畏即无怯弱。契理之心。即名为智然智有二种一证法。故此属前根。二现受故此属今欲。欲亦须智。故于乐闻心无怯弱。总前二偈根欲。双具诸地妙义。愿为说之。第二一偈叹异生众。但云众会故双叹根欲。初句为总心无浊故。名为清净。三句为别。别离六浊。一不欲浊。谓无心餐采故。离懈怠治之。二威仪浊。不恭肃故。严整治之。三五盖浊。贪名等故。洁净治之。四异想浊。谓贡高杂染轻慢杂染等。皆名异想。今说行坚固不动治之。五不足功德浊。善根微少故。于彼说中心不乐住。具功德治之。六愚痴浊。谓愚闇不了故。智慧治之。第三一偈双叹二众。云一切故。相视为总。论云。迭相共瞻者示无杂染故。余皆是别。咸恭敬等无轻慢杂染。下半喻显敬法转深。何有杂染。论经云。如蜂欲熟蜜。古释云。齐心趣证如蜂熟蜜专意。求教如渴思甘露。今即但。云念蜜则二句皆通教证。然蜂之念蜜渴之思浆。喻希法喜解脱之味更言好蜜复思甘露。显法之妙思渴情深。第二尔时大智下法深难受止。文中二。先叙意。后偈酬前中令众欢喜。是总酬答相。谓说偈本为除前疑恼得心喜故。酬答有二。一堪酬答。自有大智故。二不怯弱酬答。不畏大众之不堪故。论云。此二示现自他无过故。故后偈意明法难说。非己无智而不能说。但言难闻。非斥大众全不堪闻。偈中五偈分四。初二颂明法难说。遣上何因之疑。成上有智。次颂显法难闻。遣上何缘之疑。成前无畏。三一偈喻难说闻。后一偈举难结默。初中分二。前偈显难说之法。后偈彰难说所以。今初偈末难字。即是总相。谓难得故。难得所以后偈明之。此难有二种。一最难。体出名相故。经云第一。二未曾有难在相所无故。经云希有。上二明难相。何者是难法体。即偈初二句。菩萨行者是出世间智。谓即是证道。证心涉境故名为行地。事者谓十地事行即是教道。相差别故。最上者。通说上二胜故。诸佛本者。释上证智得菩萨行名所以行。是因义。觉于佛智所以名佛。今此证智亦觉佛智。故为彼本。本即因也。此之教证于何处成难。谓显示分别说。证道亡心故难显示。教道依证亦难分别。第二释难所以者。彼前菩萨行事所以难者。由住微妙深义故。故论云。彼菩萨行事义住不可如是说。偈中初二句对劣彰深。次句就胜显妙。末句举闻迷惑显成难说。于中难者是总相。云何难。难得难证故。难得有四。一微细难得。显非闻慧境故。二难见难得。亦非思慧心眼见故。三离念难得。亦非世间修慧境故。以地智是于真修故。非地前心数分别缘修之境。四超心地难得。非唯非地前之境。亦非登地已上报生善得修道智境。谓变易所起异熟心识名为报生。生便能知无常等。故名善得修道智。以非照实之智故。亦不测地智。知无常等未忘心境名为心地。以七地已还皆容出观故。又此善得修道智即加行。后得智非根本故。所以拣之。故瑜伽五十五修道位中。有出世断道世出世断道。既通于世故非其境。既非四心之境是谁境耶。即佛智境。何者是智见实义故。出生有二义。一生彼佛智故。二出离于生是无漏故。末句云。所以难说者。闻者随闻取着悉迷惑故。第二一偈显难闻者论云。已辩难说复显难闻。然偈中举具德能闻。反显难闻。兼欲使人学能闻故。于中三句举德。末句结成能闻。初中初句为总。谓持听法心坚如金刚。则能得闻。下二句别。坚有二种。一决定信坚。即第二句。若无此坚于他分法不能入故。二证得坚。即第三句。若无证坚于自分法不能入故。深信之相云何。谓于佛智设心智不及。仰推佛智非我境界。是深信相。即胜鬘三种正智中仰推智也。所信是何。谓佛胜智慧。以此地智上同佛智故。佛智有二。一菩提智。是自行证法称性无边。二化生权智是利他教法。随机隐显种种差别。即是法华诸佛智慧及智慧门。于此二深皆能信故。云何证坚。此亦有二。一知是能证。二心地是所证。言无我者。通能所证。心地即二空真理。所依之事谓唯识相。论云。随心所受三界中报。此即异熟识。又随心所行一切境界。亦名心地。此即前七转识。及通八识相分内外诸境。于此二类。如实了知我法二空。成无我智。下句结成。既知难闻之义。如是具上二坚。方闻上来微细胜智。第三一偈喻难说闻中。上半喻下半法合。此中喻意不单取虚空以无画处空不为喻故。亦不单取画。以壁上画不将喻故。正取空中之画。风喻亦然。于中能依风画以喻阿含。所依之空以喻证智。然空中风画不可言无。谓若依树壁则可见故。亦不可言有依空不住故。非有非无故不可说。文意正尔。论有三段。初释喻相次释合相。后拣喻不同。初中有三。初离释二喻以明非有。次合释二喻以明非无。三双结二喻成不可说。前中画喻有二。一正显喻相云。此偈示现如空中画色如壁者。谓此空中画色不异壁上画色。故云如壁。若尔。何以不见二显其非有。论云。是中不住故不可见。谓壁上之画有壁可住。故可得见。空中之画无可依住故不可见。下风喻亦有二段。一云如空中风如树叶。此正显喻相。二云。是中不住故不可得见。此显非有。谓树叶上风有叶可依故可得见。空中之风无可依住故不可见。二合释二喻以辩非无。云此动作者。非不空中有是二事。此论意。明但无可依故不得见。非风动画作其体全无。三结成不可说义云。是虚空处事不可得说。处者虚空处。是风画所依之空。虚空事是空中风画之相。由前义故不可说有。由后义故不可说无。故此空处及画事风事。皆不可说其处所。第二释合喻中。次第合上三段。而但双合。初论云是画风如说者。此合上喻相。次论云。以非自性不可得见是不住故以其客故者。合上非有。即以非自性合上不住。以其客故者。出名无性不住所以。谓名是实之宾。故无所住无自性也。二合前非无。云非不于中有此言说。三合前结成不可说。云如是佛智言说显示地校量胜分别难见者。佛智即所分别。合上空处。言说显示下。是能分别。合上空中事。以诠从旨故亦难见。合上不可说处。然论佛智即今经牟尼智。牟尼此云寂默。以智相即智性故。此即地智而名佛智者。无二体故。亦是译人见牟尼之言。谓是释迦故耳。第三拣喻不同者。举二喻者喻旨别故。论云。画者喻名字句依相说故。谓画有相状如名句之屈曲。能显地相。风者以喻音声。声无屈曲如风之相。假实既殊故双举之。又假实相依阙一不可。故云。又说者以此二事说。听者以此二事闻。故举二喻双喻说闻。若将二喻喻所诠者。仍有两重。一风画喻地相所以不可见者。以同地智故。如风画合空。二将风画复喻地智。地智所以不可说者。以即同果分。离言说相故。如风画合空。若以果从因则亦可说。以智从相地有差殊。以旨从诠可闻可说。是则无闻说之闻说也。第四一偈举难结默者。若准上义。以二事说以二事闻。则可说可闻。但是难见如何不说。故有此偈。意云。说闻本在证见。难见说之何益。况复加以难信故我默然。初句所证见法。次句难证。难中之难故云最胜。次句难信。非地前证信故曰世间。上三句举难后一句结默。第三解脱月叹众堪闻。请前已叹竟。此复叹者。由闻上言证信难得。示现此众有信有证有堪能故。先长行后偈颂。前中分二。先叙请。后佛子下。发言正请。于中三。初陈众集。二善净下。叹众具德。三善哉下。结请。二中十句初总余别。总谓善净深心离教证过。故名善净。深心有二。一具修一切诸善行故。即下教净。二与理相应故。即下证净。下九别中。前五阿含净。后四证净。谓顺教修行名阿含净。证理起行名为证净。教通地前证唯地上。今初五中。一善洁思念即欲净。随所念阿含得方便念觉净。谓得方便。即不取念相名为善洁。二善修诸行者求。净三业敬顺起求法行故三。善集助道即生得净。愿得益众生处上上胜生。生而便得悲智胜念。以助正道故。四善能等即受持净。亲近多佛意在多闻忆持故。五成就善根即行净。为求地上真证法故。习少欲头陀等离着善根。后证净四中。一舍离痴惑者得净现智。善决定故。谓真见道中得无分别智。非比知故名为现智。相见道中以后得智审观理智故决定无惑。亦可俱通相见道中。亦名现观。真见道中决理无惑。皆破无明故云舍离痴惑。二无有垢染即不行净。修道中一切烦恼不行故。相见道后至金刚无间道中。皆是修道。复数修习无分别智故名修道。灭二粗重皆使不行。对见道中初断所知。故云垢染。成唯识第十云。烦恼障中修所断种。金刚喻定现在前时一切顿断。彼障现起地前渐伏。初地已上能顿伏尽。令永不行。如阿罗汉。由故意力。七地之中虽暂现起而不为失。八地已上毕竟不行等。烦恼即是垢染。不行即是无有。然见道中。非不断惑见理义增。修道位中审虑重观除障义胜。故此偏说。三深心信解即无厌足净。不乐小乘。但于上胜佛德深心希欲。信解决定故。四于佛法下不随他教净。趣菩萨地尽道中自正行故。上叹德竟。第三结请可知。二偈颂中。初偈直举法请不颂前文。上半举法请说。下半彰说有益。后偈颂前请可知。第四尔时下。不堪有损止中二。先长行中亦二。先领前所叹对下有损。所以言虽。后然有下。举损违请。于中二。先举损劣解之人。通凡小等。皆是迷法之器故。多生疑者。正行相违犹豫义故。惑者心迷于理能破坏善法远离善法故。此明现损。于长夜下。明其当损。后我愍下。结默违请。偈中亦二。初偈颂前段。净明有信余皆有证。如山如海双喻教证。后偈颂后段以取相故。但依于识不能依智。第五双叹人法请中。复重请者。示彼疑惑应须断之。岂可避之。避之不说有多过咎。何等过咎不得成就一切佛法。文中先长行。后偈颂。长行中三。初标请。次何以故下。释请。后是故佛子下。结请。释中二。先直征释。后转征释。前中先征意云。何以当得佛护而能信耶。释云。法应得护由得护故必能信受。二转征释中。先征后释征。意云。何以说十地时法应得佛护耶。下释意云。如来说法不离教证。最所要故。文中三。谓法喻合。法中最初所行者。依阿含行故。成就一切诸佛法者。是证智故。此即九种教证中。第四修成相对。二喻中以字母喻于地智。为诸法本。论云。书者是字相。如嘶字师子形相等者。以书记字非正字体。言师子形者。谓[虱-(乏-之+虫)+允]字如蹲踞形。有云。如呼师子为[巢-果+七](词孕)多故。[巢-果+七]字像形似师子头尾者。全不似也。字者论云恶阿等者。即十四音正是字体。字即文也。等余十二。然有十四音。二音不入字母。谓里梨二字。数者名句。此二是数义者。谓有二字多字名。必以多字成句故皆数也。说者是语言。皆以字母为本者。明末依本喻果依因。字母究竟者。明本能摄末。喻因无不摄。上二顺明。无有少分离字母者。反成上二。言字母者。即迦佉等三十四字。以前十二音入此三十四字。则一一字中成十二字。复有二合三合乃至六合。展转相从出一切字。故名为母。论经名为初章者。以梵章之中悉谈字母最在初故。然五天口呼。则轻重有异。书之贝叶字体不殊。梵天之书千古无易。不同此土篆隶随时。故此为母。亦常楷定。三合中初合末依于本。后十地究竟合因无不摄。所以须此二者。若但言为本容非是末。如以百钱为本成多财货等。今明如水为海本。无海非水故。云究竟无有离者。又为本者非但因为果本。亦乃后为前本地前。望证修阿含故。初心即以智观如故。第三结请可知。问若依上义。诸佛有力能令信者。何故今后众生于彼法中亦有谤意。答有二种定。则不可加。一感报定。以先世今世造定业故。二作业定。宿恶熏心猛利缠起难晓喻故。上如释种下如琉璃。颂中初偈颂标请。后偈颂释请。略不颂结。颂释中长行法中无究竟之言。而喻中有。今此反前欲显具有。又法中明本能生末。合中明末依于本。皆影略耳。第二大众同请者。上来众首请说。显众堪闻乐闻。今大众展诚自陈有根有欲。文中先叙请。后正偈请。于中二。前四偈半叹人堪能请。后一偈叹法成益请。今初亦二。前二颂叹说者。余叹听者。前中初五句叹说者。自成教证。后三句叹能令他入。今初。初四句叹证。后一句叹教。自分所成一切行位。通名为证。上受佛教说为阿含。即九种教证中第八门也。今初上者是总。然总有二义。一双为教证之总。二唯显证力辩才。对教名上。此中叹证辩才有三。一真实智为辩所依。即经初句无漏故无垢。过小故云妙。二辩体性即第二句。谓堪能分别无边法义故。三者辩果即下二句。依前起词乐说故名为果。一诠表深旨字义成就。即下一句二滑利胜上字义成就。即宣畅句。二有一句叹阿含。谓念持于教得净慧无疑名清净行。三句叹能令他入者。初句令入证。谓已入地者令得佛十力。未入地者。令得入地。故云集功德。集功德即论经净心。净心即初地。由集德成故。后二句令入阿含辩才分别说者。意令受持十地法故。说主既内具二力。外令他入。何故不说。二有二颂半叹听者中二。初偈叹众有根。后一偈半叹众有欲。今初由有根故堪受教证。初句有治。次二句离所治。下句结请。结请惟愿是总。惟愿有二。一求阿含。二求正证。有二妄想不堪闻教。一我二慢。以我慢故于法法师不生恭敬。以定戒为治。谓若有定则心调伏。故内无我慢。戒则善住威仪外相不彰。有二妄想不堪得证。一邪见颠倒见故。二疑念于不思议处不生信故。有二对治则能得证。一证见善思义故。即经集正。谓积集深思故。二者正心。信心欢喜故。二叹有欲者。显示大众求法转深。于中一偈喻明半偈法合。前有四喻。喻四种义门。示现正受。彼所说义。一受持谓求闻慧。初闻即受随闻受持。如水不嚼随得而饮。二助力。谓求思慧嚼所闻法助成智力。如食咀嚼以资身力。三远离。谓求修慧依闻思行能去惑习。如服良药药行除病。上三三慧。四安乐行。谓求证智即三慧果圣所依处现法受乐行故。如蜜众蜂所依故云贪也。后法合中能求一向是法。所求犹通法喻。以一甘露总合四喻。甘露有四能故。一除渴。二去饥。三愈病。四安乐故。二有一偈叹法利益请。直观经文似当结请。今依论判故云叹法善哉是总。所说法中善具足故。善哉有三。一所依即广大智。说地必依此慧故。二体性即第二句。正说入诸地则地地转胜故。三者地果即后二句。谓具十力无障碍佛菩提故。行亦果行如出现品说。自下第三如来加请前虽二家四请。为显法胜复待佛加。前来为分主伴主佛。唯明意加。今欲具于身口故复重加。又前默与威神令有加请。今加为说不与前同。若尔诸佛前已具于三业何得复加。前但是加未是请故。今以加为请并异于前。上力被下说以为加。因加劝说目之为请。加即是请故云加请。长行则以加为请。偈颂则以请为加。不以常口求请。而以云台发言。不以常身展敬而以光业代者。为不轻尊位故。要复请者为重法故。前加分中不加大众。今此加者。前若即加说主。无由三止。此若不加请主。前言得佛护念便为无验。文中通有八业二身。且分为二。先长行有二身七业。后偈颂但明请业。前中二。先此佛光照十方。后十方佛放光照。此二光互照必互相见。二段皆有二身七业。今初分二。先明光体业用。后作是事已下。正明所作。今初。先明光本。上加于下多用眉间之光。亦表将说中正之道。出清净下。正明体用。于中文有六业。一觉业。即光名体。谓是光照菩萨身。已自觉如来力加故。觉照光用故曰焰明。二百千下。因业。能生眷属义故。三普照下。卷舒业。舒则普照十方。卷则还入常光。今文略无卷业。若兼取下文。如日身中于空中住。义则通有。四三恶下止业。五降伏业。论经云。一切魔宫隐蔽不现。今经阙此。六又照一切下。敬业。显现佛会令物敬故。七又照十方下。示现业。正为令众见说听者。皆得佛加堪说听故。长行受身加之名偏从此立。二正显所作即二身之一。言二身者。一流星身。往他方世界故。论不指经。古德共指卷舒敬示三业当之。以是往来光体如星流故。二如日身。谓如日处空即此所作。于上空中为台是也。故以身业相对。应成四句。一业而非身。谓八中除三。二身而非业。即如日身。三亦身亦业即流星身。四非身非业。此经所无。即论经彼此相见。以身约有体业约有用。三则双具。四则非正所为故。二十方佛放光照此者。正为照此。然其作业亦周十方。七业二身不殊此佛而加。又亦照此娑婆。经文以主佛普照此。不待言伴佛普照。正意为此加被相故。第二偈颂明请业中二。初偈所依望前犹属于身。后正偈请。五偈分二。前四加请所说。后一教说分齐。前中亦二。初二偈举法请。后二偈举益请。前中亦二。初偈正显作加。后偈显加所为。今初。加于彼三字是总。此偈正为加故。其世中上亦总亦别望加于彼是别。以二种加中是具果加故。望四胜义是总。以上即胜义具四种胜。为世中上故。言四胜者。亦如世王。一自在胜。所作无碍故。即经初句言佛无等者。由离二障解脱自在不染如空。十地已还皆无等故。重言等者唯与佛等。欲显佛佛等正觉故。二力胜。即经十力能伏邪智之怨敌故。三眷属胜。即无量胜功德及人间最胜。论经即当无量诸众首。谓具功德堪为众首。故云人间最胜。论云诸众首者。佛于世间最上胜故。四种姓胜。谓家姓胜故。即释师子法。于中又二。一释师子是生家胜。谓应生释姓轮王贵胄故。诸佛同加。偏语释者以现见故。是主佛故。二法之一字是法家胜。谓非但生家胜。诸佛皆同真如法中住故。由上四义故。称法王名世中上。上云二种加者。一具身加依法身故。谓释师子是有法所依之身故。二具果加证佛果故。即是世中上。及别明四胜。异未成佛之色身故。今此具德之人加金刚藏。第二偈加所为者。欲令开现法藏义故。文中初句及下句。以佛威神是说所依。余文正辩所为。开胜藏一句是总。下十字是别。别叹胜藏。有其二种。一义藏成就。二字藏成就。义藏即胜妙行。行者。诸菩萨行。所谓助道法故。妙者。真实智故。即是证道。胜者。神力胜故。是不住道。染净无碍故云神力。如是显示深妙胜上之义。二字藏者。即诸地广智及分别说。谓说十地差别相故。上举法请竟。第二举益请者。显所说法利他有三时益故。二偈分三。初半偈闻时益。若得上加。则法宝入心成闻持故。次半颂修时益。上句修时因圆。下句所修果满。后一偈转生时益。即具坚种人。上半顺明。明有信之益。下半反显举无信之损。论经但有顺明。偈云。虽在于大海及劫尽火中。决定信无碍必得闻此经。今经堪受即决定信义。此中大意云。若有信有机为堪受者。无问恶道善道。难处生皆得闻经。以难不障闻故言虽也。海水劫火即是转生难处。大海即是恶道畜生趣故。故论云。龙世界长寿。亦得闻此经。偈言虽在于大海故。而言长寿者。如有经说。右胁着地未动之间。已经贤劫千佛出世。更一转亦尔。但暂卧息尚尔。况其一生。劫火中者。即是善趣。论云。虽在色界光音天等。亦得闻此经。偈言及劫尽火中故。此即指二禅已上为长寿天难。然论无长寿之言。而前龙趣却有长寿。且三恶为难不必长寿。恐是译人误。将此中长寿入于前文。然二经中文皆巧略。若具应言劫尽火起时在光音天中故。论为此释。以火起时初禅无人。二禅不为其坏于中得闻故。等言等取三禅四禅。免水风灾长寿天难。乃至无色亦皆得闻。今举初摄后。及对水成文故云劫火。案智论等通上二界。除五净居皆长寿难。今不取初禅者。以彼有梵王多好说法。有觉有观闻法障轻。又正已烧故不说之。上顺论释。八难之中善恶二趣各举其一。理实八难皆容得闻。又劫火之言兼佛前后。劫坏之时无佛出故。修罗地狱容在海中则兼数难矣。今经但云劫火。则正在火中亦容得闻。以众生见烧烧处有不烧故。问若依前义。云何堪受法人复生难处。答此约乘戒缓急应成四句。一乘缓戒急。生长寿北洲不闻法要。二者乘急戒缓。生三涂中不碍闻法故。佛会中多列龙鬼等类。三者乘戒俱急。则人天闻法。四乘戒俱缓。则处三涂诸根不具又不闻法。今海水劫火是二三两句。余二无乘故。经论不明。即后半意勉旃学徒。愿留心法要故。涅槃云。于戒缓者不名为缓。于乘缓者乃名为缓。第二一偈教说分齐中。应说诸地者。总劝说也。说地何义。谓应说前字藏之中诸地广智三渐次相故。次修习言即为总相。言渐次者。渐明非顿。次辩不乱。云何为三。一观渐次。二证渐次。三修行渐次。此即十地之中。加行根本后得三智。为地地中初中后相也。胜智道者。即观渐次。道者因也。以加行智为正证胜智之渐次。故名胜智道。谓说此十地若加行观。若加行所依止理。能生诸地实智故。次入住展转者。是证渐次。入者入地心。住即住地心。未转向余地故。展转即出地心。地地转所住处故。即此三心证智自为渐次。第三句即修行渐次。以后得智要由证真修行。方能了俗故。名修行渐次。言法智者。正辩后得智体缘法别。故名为法智。此智从二境生。一由证真故。云从行生故。论云。行者入住展转成就故。二外能了俗故。云从境界生故。论云境界者。此行种种异境界故。谓以正证之行。行于俗境是后得也。利益众生一句。结说之益。亦是后得智境。问地地正证者。如初地中正智亲证真如。则后九地中不应更证以如无二无异故。古德释云。如虽一味。约智明昧有十亲证。此亦顺理故。唯识论云。虽真如性实无差别。而随胜德假立十种。此约所证德异故。有十地亲证。又云。虽初地中已达一切。而能证行犹未圆满。为令圆满。后后建立此。则亦约能证明昧意也。若唯取所证德异。则初地未全证如。亦未能全通如无异难。如人观空小时不远大则渐增。空虽无差眼有明昧。自下第三许说分齐。谓所说不过义说二大。是地分齐。于中二。先叙说仪意。后正显偈辞。今初。观察十方是叙说仪。论云。示无我慢无偏心故。观十方佛将欲承力。故无我慢。观十方机拟将普被故。无偏心故。上下文皆云承佛神力普观十方也。亦可普观物机不慢旁人。普观诸佛不偏一佛。欲令大众增净信者。是叙说意。谓众先有信深渴所闻。今更示说正地二大增益闻者。堪受正义。不如言取名增净信。若准论经更有增喜。彼经云。欲令大众重增踊悦生正信故。以踊悦即是净信故。今略无故。论云踊悦者。心清不浊故。由信以心净为性。则称理而悦。以前说主违请中已令众喜故。今云增如何得此踊悦。论云踊悦有二种。一义大踊悦。为得义故。二说大踊悦。因此说大能得义故。义名所以深广称大。即是当法受名。说名诠表。因于此说得彼义故。依所得义故名为大。大之说故依他受称。闻于二大皆踊悦者。因诠得旨湛净无疑。法喜内充故增踊悦。大意如此。然二大体相古说不同。远公云。此地经中宗要有四。一是言教。二是所说教道之行。三是所显证道之行。四是证道所表地法。就此四中初二为说大。以行依言成。言依行发故合为说。后二合为义大。以证依法成法由证显。故合为义。贤首释云。此经宗要有六。一所依果海如太虚空。二地智所证十重法界。如空中所画之处。三根本智能证法界。如能依画相。四诸地后得随事起行悲智不住。五诸地加行所起行解。为趣地方便。六寄法显成诸地差别。如第二地中十善为正。三地禅支等。于此六中前三合为义大。后三合为说大。然其后解不取能诠者。意云。如偈中七偈亦明义大。岂无能诠。正应用所以甚深故。名之为义。可寄言说故称为说。且依后解。古德因此复辩可说不可说义。然下论自明因果二分说不说义。非无眉目故今叙之于中先就义大。次约说大。后辩双融义中有三。一约果海可以总标举。令人知有。名为可说。不可指斥示人名不可说。二约证处。既此所证离相离名。还云此法不可说闻。以此遣言之言当彼法。故名为可说。有言斯遣名不可说。三约本智。谓以遮诠易解故名可说。直诠不逮故不可说。摄论云。无分别智离五相故。谓睡眠昏醉等。以直诠不到故。约遮诠以示彼法二就说大中亦三。一约后得智。随事行相可以言辞分别。是则可说。是出世间故不可说。二约加行智。谓是意言观故是则可说。观中行相言不至。故名不可说。又诸法自相皆不可说。诸法共相皆是可说。此通一切法。三约所寄法。可以寄此表示令人解十地故名为可说。不可以此即为十地。名不可说。三约双融中。此上六中各说即是无说。无说即说。无二俱融准思可知。又果海离缘故不可说。所证就缘是则可说。二所证非修故不可说。能证修起是则可说。三正证离相故不可说。后得带相是则可说。四后得无分别故不可说。加行有意言。是则可说。五加行观无分别故。不可说。寄法表地是则可说。此上不可说。皆各不异于可说。以真理普遍故。可说不异不可说以缘修无性故。是故下文虽说一分。义亦不少。故论。云如实满足摄取故。意在于此。涅槃亦云生生等皆不可说。有因缘故亦可得说故。说不说不可局执。余至下明。上来叙意竟

大方广佛华严经疏卷第三十二大方广佛华严经疏卷第三十三

        唐清凉山大华严寺沙门澄观撰

第二正显偈词。有十二偈。大分为二。前七显义大。后五明说大。今初分四。初四偈总显地智微妙。二有一偈类地行微。三有一颂寄对。彰微。四有一颂喻显地微。今初分二。初二总显地狱。后二别显微相。今初。正显地智微妙之相。故论云。此偈依何义说依智地故。依者据也。云何知依智地。上来本分请分皆依智地。后说分中亦说智地。即今此中第六偈。云智起佛境界亦依智地。明知此显地智微妙。非别明佛果。于中论经但有六句。初二句即此初偈。彼云微难知圣道非分别离念言微妙者。二偈总相。即前地智超言念故。余皆是别。别中初句是微体。余皆是微所以。于中难可知。总显所以。下六句别显所以。论云。云何微。偈言难知圣道故。此即双指。谓圣道是体难知故微也。故净名云。微妙是菩提诸法难知故。云何难知。此有二义。一说时难知。口欲辩而辞丧故。二证时难知。心将缘而虑息故。上大仙道是所证说。大仙是佛故。言微妙道者。是因修行证智之因。得大仙果故。六句别显微所以中。初句即说时难知。言非念者。非有念虑分别心者之境界故。何以非是念虑境耶。以此地智自体无念故。故云离诸念也。由上二义。如是圣道名为甚微。下之五句明证时甚微。于中复有总别。初句为总。求欲证见难证得故。以无见无得方能证故。下四句别有四甚微。第一观行。第二依止。第三清净。第四功德。初句即功德甚微。不生者。契理出世故。不灭者。非一往灭。不舍利益众生事故。即无住涅槃。寂用无碍功德。次句即清净甚微。性离烦恼非先有染。后时离故名为性净。如此则无不离时故恒寂然。即性净涅槃。言离垢者。即观行甚微。谓观智中离无明垢故。不同世间八禅。为无明杂故。聪慧人下。即依止甚微。聪慧人者。登地已上有智之者。彼人之智能行地智。何智能行。若就总就实。唯一实智见一实谛故。若就别兼权则通三智。一加行智增上善胜解故。二根本智增上善寂灭故。谓灭诸惑证寂理故。三后得智。随闻明了故。云何行处。此之地智是彼证智。自证知故。依彼地智说证智生。故说为行。非正证时有能所行也。上四微中功德异小观行异凡。依止清净拣异外道。自尊之者。以智断异故。前清净微是断德。不同彼有见惑及灭心想。为清净故。依止即是智德。不同彼以六行而伏惑故。上依增胜。若通说者并异凡小。第二两颂别显微相。故论云。此甚微智复有何相。此征体相也。是智有二相。初二句明同相。智体空寂故。后六句不同相。智位差别故。今初同中。上句总下句别。总中此是谁相彼智相故。故言自体。此智自体以何为相。谓本空寂。何以言同。此即性净涅槃。上同诸佛下。同众生一切众生皆有此故。横同诸法诸法如故。此如即是自体空故。一切皆以空为自性。智性色性本无差故。一切皆有安乐性故。下句别者。论经加一有字。云有不二不尽。释云。此智空寂其相云何。谓离三种空摄是真空相。三种空者。即地前空乱意菩萨。一疑空灭色取断灭空。此失空如来藏。则损减也。二疑空异色取色外空。三疑空是物取空为有。今云有者。即初离谤摄。不谓断灭如兔角故。言不二者。即离异摄。不谓异此空智更有异空。言不尽者。离尽灭摄。不谓有彼此自体彼此转灭故。此明非灭有体之智。成有体之空。亦非空有物可转灭也。离此三空。即见自性本空空如来藏。今阙有字如何会通。此有二意。一以不尽摄之。谓有体故不尽。无则异于断灭。若无可尽灭则非有物。义如前说。二者西域之经自有二本故。论云。有二种颂。一有不二不尽。二定。不二不尽。此颂虽异同明实有。若非实有不得言定。此云何定。定能灭除诸烦恼故。意云。定即是有故能灭惑。今经亦无定字。义同定本。谓定是有无不二法故。离前二空。谓无二中兼得空与有不二故非断灭。三种空义。如宝性论第四所明。二有六句明不同相者。即方便净涅槃。断惑平等不同凡小。而能断故不同外境。但是所证有异相。故不同于空。涅槃是果。此云何是约分证故。又是所依果海。如下十山十德不离海故。此当义大不可说故。今明地智应是菩提。那言涅槃。若分相门。则所证为涅槃。今显相融。即智之性为性净涅槃。智出惑障为方便净涅槃。二而不二。难说甚深良在于此。文中解脱是总。余皆是别。总谓净相解脱故异前也。宝性论第四云。清净有二种。一自性清净。谓性解脱即前同相。二离垢清净。谓得解脱即此净相解脱。别中以别显总别有二种。一何处得解脱。即经于诸趣也。此显所脱。谓烦恼为趣缘业为趣。因生为趣果故。三杂染皆诸趣摄。若脱因缘则无生果。二云何解脱。即下五句。此明解脱之体。五句即显五种解脱之相。一等二际是观智相。二断烦恼是离碍相。后三体德圆备。即是涅槃之相。言平等者。谓世间涅槃平等摄取。非如声闻一向背世间故。以世间之性即涅槃故。中观云。世间之实际。即是涅槃际。无毫末差别故。二断惑相者。谓三时无断方说断故。故云非初非中后。释此有二义。一约相翻。二约相续。言相翻者。谓无间道正断惑时。为智先起惑后灭耶。为惑先灭智后生耶。为同时耶。此三惑智各有两失故。如不成断。谓智先起智有自成无漏过。不能灭惑过。烦恼先灭烦恼有自灭过。不障圣道过。智后同时各具四过。如灯不破闇可以喻此。又涅槃云毗钵舍那。不破烦恼若尔云何说断。若依唯识第九明二真见道现在前时。彼二障种必不成就。犹明与闇定不俱生。如秤两头低昂时等。诸相违法理必应然。是故二性无俱成失者。此但举法相一边。亦不违余缘集断义。若望此宗则有所遗。谓秤衡是一低昂无妨。解惑不尔。岂得俱时。明闇之喻。虽则相倾到与不到俱不破闇。同时则相乖异时不相预。故若此宗断结要性相无碍。上明非先后俱为显无性。无性缘成则说断结。由能断无性方为能断。所断本空方成所断。若定有者则堕于常。不可断故。若定无者则堕于断。失圣智故。言相续者不约惑智相对。但就一智自有三时。论依此释就此三时复有二种。一约初心究竟。通分三时。二约无间道中刹那三时。经论并通此二。论云。此智尽漏为初。智断为中为后。答云。非初智断。亦非中后。偈云。非初中后故。此上顺释偈文。兼定三时。唯约智说故。言是智断惑。若尔三时无断云何断耶。论云。如灯焰非唯初中后。前中后取故。此举喻释成谓实教断惑必性相双明。经文正显证智。唯据甚深缘性不可说义。论主兼明断义故性相双辨非初中后。辨因缘无性。是断之不断。前中后取即不怀缘相。是不断之断故。大品云。菩萨非初心得菩提。亦不离初心后心亦尔。而得菩提。譬如然灯非初焰燋炷。亦不离初焰。后焰亦尔而炷实燋故。龙树判云。佛以甚深因缘答。涅槃二十九亦云。众生五阴。虽念念灭而有修道。如灯虽念念灭而有光明。上诸经论。皆显性相无碍。无断之断。又今经论反覆相成。谓若定断者。一念便足何假三心。既并取方成。明知无性。无初中后。无初中后是无性。故方得成于初中后断。此则因缘故无性。无性故因缘也。若云初念则能断。后念方究竟断者。不异毗昙一念有烧始终方尽。若云初念独不能断。积至中后方能断者。不异成实一念不烧相续方然。勿失宗旨。上犹通实教。若依圆宗所断之惑一迷一切迷故。一断一切断。无断无不断若具显诸宗差别如别行章。非言词下三句。明三德者。初句即般若是观行相谓无分别观体绝名言。真智内发。不同声闻依声而悟。前云观智约其决了。此云观行约行契极。次句法身是转依相。谓转无常依。云出过三世故。此微智依常法身论。云非如无常意识智依止无常因缘者。此拣未转依时。今为所转依也。无常意识智是彼能依。无常因缘即是所依。持种本识是无常因。所持染净诸种子等。是无常缘。依此因缘起无常意识。今转无常识成妙观察智。转无常意成平等性智。以为能依。依彼本识如来藏性真如法身。以为所依。论云。如修多罗中决定说者。是了义故。涅槃经说。转无常识获常识故。诸大乘经其文非一。问所依本有可得是常。能依修起宁无生灭。若依唯识。所依常故能依亦说为常。非自性常是有为故。若起信等始觉同本。亦皆是常。胜鬘经云。一切法常住故。三其相如虚空即解脱相。不同声闻犹有智障。二障双亡故。如空无碍。三德之义已见上文。然圆满在佛。圆教十住即许开发。此中约因即言分得。所依果海等佛无差。转依亦尔。从因门中是见修转。就果辨者。究竟广大转也。此不同相。由得前同成斯不同。能显前同。令离障清净无别不同。如融金成像像非金外。论中结后五句云。如是观智如是断烦恼。如是观如。观如如是依止。依止如是解脱得解脱。后三皆重言者。皆上牒前下是结成。谓如是观而观等也。偏此后三有重牒者。以前文后三对妄显真故。须牒真就以结之。第二一偈类地行微。于中上半牒前地智离言。以为能类。下半正举地行以为所类。初中谓彼前地智显二涅槃。皆言不及。寂即同相性净涅槃。自性寂故。灭即不同相方便净涅槃。要智缘灭非约性灭故。此二涅槃是佛所行。故言不及。行者证也。言不及者。说听皆难也。何不直说无言。而云言所不及。若一向无言何由悟解。令寻言求理而知理圆言偏。故但云不及。下半所类者。谓非唯证智如是深玄。而令智眷属行亦难说受。论云地者。境界。观行者。智眷属。智眷属者。谓同行。同行者。谓檀等诸波罗蜜。言境界观者。如为境界照达名观。此即加行。设地是地体。意在举地取行。故云地行。将此地智修行檀等。故名同行。同彼事而行故。斯即后得为证智眷属也。第三一偈寄对彰微者。对闻思等以显微故。初句举法体。智是所起地智。即前五偈所明根本之智。起者即加行后得二皆观如。如即佛境并为能起故。论云。以何观以何同行。能起此智。此即前偈何观者。前境界观。何同行者。前檀等行。皆言何者。随何观行是非一之言。以加行随地不同。后得缘境各别故。次二句明难说。于中初句非心数故难说。非念者非思慧境故。离心道者。非报生识智境故。报生识者。如上违请中辨。后句明不同。三科有色心根境。故不可说。论经。云非阴界入说。论释非说。云离文字故。今经略无说字。门即是说故。法华中以说为智门。下句明不可闻。智知者。唯证智知故。意不及者。如闻取故。即依智不依识也。第四一偈喻显地微。上半喻下半合。此中喻者。不唯取空。余处虚空不为喻故。不唯取迹。砂土上迹不为喻故。正取空中鸟迹。论云。鸟行空中迹处不可说相亦不可见者。总显喻相也。处即迹处之空。相即空处之迹。不可示其长短大小令见不可说为有无等。此中迹处之空。以喻证智。空处之迹以喻阿含故。论合云。如是鸟迹住处名句字身住处也。何以不可说。论云。虚空处鸟迹相不可分别故。意云。鸟足履沙则有迹及处。由履空故处迹难分。名句字身亦尔。菩萨证智所摄故。不可说闻。若说若听心意不能了也。故以证摄教如空摄迹。令名句等非如声性也。以是证智之名等故。上明粗相非有。顺喻不可说闻。后明细相不无。以喻可证。论云。非无虚空行迹故。谓迹处之空异于余空。喻非无地智。空处之迹异于无迹。喻非无名句字身。以有鸟行必有迹故故。论云。非无地智名句字身。即双合也。谓有诸圣亲证如故。证尚不无况于言教。又以空摄迹迹不可示。以迹摄空空亦非无。喻以证摄教教不可示。以教摄证证可寄言。喻意正尔。若欲开鸟异迹。则鸟喻言诠。迹喻差别地相则有三事。而迹处中以迹随于鸟。迹相非无。以迹随于空迹相非有。喻以差别随于诠。差别非无。地相随于证差别非有。若更开迹处之空异太空者。则迹空喻证智。太空喻果海。迹空随于迹地智可说。迹空随太空则地智离言。虽通此义在论无文。若以迹喻证智。如前风画中辨。以斯鸟迹之喻。映下十地之文。则寄位浅深之言。施戒禅支之类。一文一句莫不深玄。岂谓地前为深地上为浅。故论总结云。此中深故示义大踊悦。此中鸟迹亦双喻教证。难说难闻何异请中风画之喻。故论云。云何复说论。答云。汝等不应如声取义。此意云。上喻及法。是显默不说之意。此中喻及难说。诫众舍着许为宣说。意不同也。若以着心随声取义。有五过失。一不正信。以随言解不称实故。二退勇猛。不能忘相趣实理故。三者诳他。以己谬解为人说故。四者谤佛。指己谬解是佛说故。五者轻法。以浅近解解深旨故。谓法如言不殷重故。意令大众自知无此五过所以。明难说闻。今人以地上为浅者。并陷斯五失。故叹难说闻。则翻斯五失以成五德已。说深义令生正信。自下第二复显说大令生正信。五偈分三。初一偈半正显说大三成就义。二有三偈彰己无过诫众除失。三有半偈示说分齐。但是说因。今初言三成就者。一因成就大。谓慈悲愿力为起行本。故名为因。二因渐成就大。谓闻思慧等为出世智因。起之不顿故名为渐。三教说修成就大。谓即修慧真修。契实如于正证。可寄言诠故名教说。教说二字正拣义大。非如果分不可说故。前二不似正证体非玄妙。不假言拣但为出世智因。故并称因。当分获得三皆成就。此三地位为在何所。此有二意。一约初地则前二容在地前。地加行故。后一唯居地上。二约通说。地地之中加行修等慈悲愿力。即是因成。闻思慧等即为因渐。正证后得皆教说修。问慈等闻等说十地中在文易了。正证之相何处是耶。答此有二意。一地体玄妙不可直彰。寄法显示即是其相。谓如十善禅支道品诸谛等。二因满入处即是正证。如初地云。名住菩萨欢喜地。不动相应故。八地云。入一切法如虚空性。成就此忍名入不动地等。即其文也。以真实正证不可说示故。此二类皆是说修。若尔上三渐次。何以诸佛教说证耶。彼从所表义大故名为证。今从可说但得云说故。上论云。因此说大能得彼义故。已知大意。次正释文因成就大。即初二句。慈悲是利他愿通二利。力通上三。以二利熏修不同二乘。故名为力。下句即二利之功。出生地行正是因义。二因渐成就大。即次第二字。论云。说闻思慧等次第。乃至能成出世间智因故。此云等者。通有二义。一者等上以其修慧是第三大。故不等之。二者等修。修有二种。一者缘修。属此门摄。二者真修属第三摄。由等义有含故但云等。不尔何不但言闻思修。而以等替修。三圆满下。明教说修成就大。此有二种。一满足修即初八字。二者观修即后两句。真修位极世虑都寂。能满地智名满足。修真智内发寂照分明。名为观修。初即称性寂然。后即寂而能照。犹莹明镜垢无不净。如满足修鉴无不彻。如彼观修。此二种修望于真证。犹彼等妙。等觉等于妙觉。而但是因圆。妙觉舍行方称果满。此亦然也。二修如于出世。但是因分之终。正证舍修方名果分。诸有智者。请鉴斯旨。文中虑即闻思。智即真修之智。心即真修心体。谓若无闻思缘虑之心。方名真修之心圆满故。唯真修之智所能行耳。若准论经。心是所如出世之心故。论经云。非心境智满如净心。论释云。满足修者。偈言非心境故。非心境者。此句示闻思慧等心境界处。唯是智因能生出世间智。而此不能满彼出世间智者。此明闻思。是心境不能满地智。翻显真修。非心境方能满地智故。次便引偈。云偈言智满如净心故。次牒释云。如净心者。如出世间清净心能满彼地智故。此明函盖相称。谓欲满地智非余心能。要真修虑寂之心。一如出世智心方能满也。其所如出世之心。即是正证地智。此言真直。次观修中是境界者。即真修之境难见者。非闻思能见。可知者。唯真修自心寂照方知。知即见也。故论经云。难说自心。知释云。自心清净可见。既难可见亦难可说。而随修以显说大中收。不同果分但是深义第二彰己无过诫众除失中二。初半偈总明。后二颂半别显。今初由说听者。各有二过。不能得证故。并彰离说二过者。一佛不随喜说。今云佛力开演。则知佛已随喜。二不平等说。今云。汝等应受则情无彼此。听二过者。一见诤过。言我法是彼法非。如是执着种种诸见二于说法者。不生恭敬。今令敬受双离二过。谓敬法故无见诤过。以敬人故无第二过。第二别显中。上虽离四过事但有三。一承力。二开演。三敬受。今三段广之。初一偈广开演。次一偈显敬受。后半偈显承力。今初。上但云开演未知广略。今显略而非广。上半显智入之行深玄广说不尽。言智入行者。地法为所入证智为能入。行此智行则入地法。又智入是证智行是事行。下半今虽略说摄广无遗。真实者。即智入行也。无余者。若事若理无不具故。第二显敬受者。即示恭敬相。初句正明三句出因。恭敬有二。一身正恭敬待。如威仪住堪受说法故。二心正恭敬待。如心决定堪能忆持故。心敬则身必恭故。偈但云心也。下释恭敬所因。谓由善说故令物敬待。初句对人彰己善说。说之一字论经名善说。善说者。对于当机无谄无憍慢故。承佛力者。示己无增上慢。不言齐佛故。次二句对法彰己善说。胜法二字即是所诠。次六字是能诠。其相应二字通能所诠。文虽三节义乃四重。一今之所诠示现何事。所谓胜上地法故云胜法。二复征云。所诠是地能诠多种。或以色香威仪进止皆为能诠。为用何法为能诠耶。故论云以何事。答云。我用八种梵响微妙音声以为能诠。不用香等故。经云。微妙音。三复征云。用此音声复有多种。为直尔用为喻类显。故论。云云何事。答云。非直尔显寄喻类明。故云譬喻。然喻有二种。一是譬事为喻。如下节节引金庄严具。大海珠宝等。二借法相事况出于理。晓喻时听亦名为喻。今通此二。四复征云。虽知喻显喻亦多种。为依世间不善文字而为喻耶。为依出世善字喻耶。故论。云依止何事。答云。依于善字经阙善言。论经具有。云何相应通能所诠。一以妙音声与喻相应。是约能诠。二约善字与理相应。是通所诠。故论云。善字有二种。一随方言音善随顺故。二字句圆满。不增不减与理相应故。又与能诠三事相应。则与理相应也。第三广承力者。论云。前言承佛神力。未说云何力故说此也。无量佛者。略有三类。一是主佛。二是十方金刚藏佛。三是十方一切佛也。第三示说分齐者。但是说因耳。半偈之中下句。论经乃在说大。五偈之初云我但说一分。正是分齐。或是译者回文。或是梵本有异义旨不殊。前后何妨。于中上句牒前所请。兼结上来义说二大为此处也。难宣示义广如上辨。下句许说少分。论上解云。前言十地如是不可得说闻。今言我但说一分。此言有何义。是地所摄有二种。一因分二果分。说者谓解释。一分者。是因分。以于果分为一分故。然因果二分古有多释。全乖文旨者。今所不论。有可通者。正而用之。直望论意即指义大为果分。故不可说。说大为因分是则可说。更以义取略有二种。一唯就十地以明。以证智为果分。方便寄法等并为因分。此复二义。一以修证相对。则方便造修为因分。息修契实为果分。二以诠表相对。则以寄法显地差别为因分。真实证智为果分。如初三地寄同世间。次三寄二乘及禅支道品等。令众因此表解地义。为因所表。证智是此因之果。斯皆证智言所不及。故不可说。如彼鸟迹同于虚空。方便寄法可以言显。故云可说。如空中鸟迹约鸟说异。是以一迹通有二分。即可说不可说也。二约究竟佛果对普贤因。说义通一部。谓即此证智冥同究竟果海为果分。如迹处之空不异太空。地相之因同普贤因。以广说则。有无量差别事殊胜愿力。复过于此故。是则迹处之空随于空处之迹。亦有说义。地智亦可寄言标举故。问上论云。是地所摄有二。如何说为究竟果耶。答岂不向言冥同果海故。上论云。此智是谁证偈言佛所行故。又上加分云不思议佛法。又地影像分云。彼十大山因大海得名大海。亦因十山得名菩萨。十地亦尔。同在一切智。因一切智得名。彼因果相顺故。是知论主亦用究竟之果。为十地摄。有云。彼说十山依海。不说大海即山者。大海十德岂离海耶。宝珠十义岂离珠耶。明知为此难者。不见地智之旨。又且依一相不可指陈等。云不可说及与可说。若有因缘故果可寄言。即事入玄因亦叵说故云说少分也。不可局执。自下大文第七明说分中。三门分别一来意。谓请仪既终已示分齐。彰其地实。地实难明寄显在相。相即因分。从此已下。广明地相。令寻相得实故有此来。又请分生其正解。此后显其行修故次来也。二释名。演畅宣陈十地差别。故名说分。以上请分通请十地。对请辨说理必宜通。为欢喜在初受斯总称故。论云。自此已后正说初地。既有初地说分。即知十地皆有说分。又初地中。皆应名说为分地满异于初住故。十愿下。更与异名名校量胜。又论家科文但举大格。至于血脉殊不介怀。随时起尽不应执定。三释文者。十地即为十段。就初地中七门分别。一来意。二释名。三断障。四证理。五成行。六得果。七释文。初来意者。十地之中。最初断障证理得圣性故。二释名者。此论所释已见本分。当经有释备于下文。今引他部成立正义。唯识第九云。初获圣性具证二空。能益自他生大喜故。此有三义。一得位。二证理。三成行。由此三故名极欢喜。摄大乘论第七云。由此最初得能成办自他。义利胜功德故。此唯依第三成行义说。十住毗婆沙云。始得法味生大欢喜故。此唯约证理义说。瑜伽七十八引深密经云。成就大义。得未曾有出世间心生大欢喜故。此约二义。大义即是二利行成出世间心是得圣位此。同本论本分中释。三所断障者。唯识第九中。异生性障是此所断。谓二障中分别起者。依彼种立异生性故。二乘见道现在前时唯断一种名得圣性。菩萨见道现在前时。具断二种名得圣性。此言异生即是凡夫。梁摄论中名凡夫性。此论本分中。名凡夫我相障。此障障于初地。上来就能起烦恼是根本故说断二障若具说者。亦断恶趣诸业果等。由斯初地说断二愚及彼粗重。一执着我法愚即异生障二恶趣杂染愚。即恶趣诸业果等。此业果等。虽非是愚愚品类故。下九地中愚皆准此。断义如前分齐中说。四所证理者。由断前障证遍行真如。谓此真如二空所显。无有一法而不在故。梁摄论中名为遍满。遍满一切有为行故。意明无有一法非二空故。此地最初偏证遍满。五所成行。略有四种。一约增胜修成施行。二约所成起十大愿。三约修成。谓信等十行。四约实行。谓十度等行无不皆修。余所修行释文自显。六所得果略有四种。一得当地满时调柔等四果。二得檀行成大财果。三依摄论。通达障空得一切障灭果。四通论。得唯识三性三无性理智。及奢摩他毗钵舍那等果。然上诸门多依行布。若约圆融。一断一切断。一证一切证。一行一切行。一得一切得也。第七释文分二。先长行后偈颂。前中若直就经文。应分为二。初明地法。后佛子菩萨住此地多作阎浮提王下。地果。前中先广明。后佛子是名下总结。前中有三。初明入心。次佛子此菩萨以大悲为首下。明住地心。后佛子菩萨住此欢喜地已以大愿力得见多佛下。明其出心。十地之文大体皆尔。故依慈氏论于十地内。皆有三心。仁王上卷。亦云地地上中下三十忍。地地中始生住生终生不可得等。理必然也。而论以出心为调柔果。所以至下当明。今且依论判长行中二。先明初地说分。后佛子菩萨住此下。校量胜分。前中依论总有百句。分为三分。初四十句明住分。二佛子菩萨住欢喜地下。三十句释名分。三佛子此菩萨以大悲下。三十句安住分。若通取校量胜。即为初地四分。初云住者。出世菩提心生。坚守初地。更不退失。故称为住。即始住入心。初虽住地未得名善。更起信等地中善住。故名安住。即地中正住及后一分。并是住心。其释名分十地应齐。但从义。显偏释三地。谓初及八十。余略不论。以初地是得圣之始。八地无功用初。法云菩萨地尽各无数劫满。故偏释也。然十地中既三心齐证。则地地之中。皆摄前之三位此中住分。摄发心住。其释名分摄欢喜行。后之二分摄救护众生离众生相回向。皆文义相顺。如文思之。今初住分文分为二。初别显住法。后菩萨住如是下。结住入位。前中四十句分四。初十依何身。次十为何义。三有十句以何因四有十句有何相。初谓深种善根为所依身。次为得佛果为所缘境义。上二皆发心缘。三以大悲为发心之因。四以过凡得圣。为发心福利之相。瑜伽四十七亦有四相。论依经造故同于此。又此四事即三种菩提心。深种善根是深心。次为求菩提是直心。三即大悲心。具此三心成后入地之相。又此四段各具含三心。可以思准。今初依何身十句。初总余别。总云若有众生者。是具行之人。依地持论是解行人。有如是心则入初地。入已此心常现在前。下诸地中初之十心类此可知。言深种善根者。正是总句。论经名厚集。厚则深也。集即种也。若约圆融则不定时数。若依行布。谓一僧祇已积资粮。故云深种。别有九种集。前六护烦恼行。后三护二乘行。前中即增上三学初戒次定。余四是慧。慧中前三如次是闻思修。后一所成出世之智。后三中初二护二乘心。谓大志护陜心。大解护小心。后一护二乘行。已知其意云何九集。一行集。即经善修诸行。善作眷属持戒故。三聚。非一故。名为诸不净尸罗不生三昧故首明矣。二定集即经善集助道。善作眷属三昧故。即明得等及四静虑。以定亲资慧故名助道。皆云眷属者。慧为主故。三亲近集。即经善供养诸佛。供佛为欲集闻慧故。四聚集。即经善集白净法。聚思慧善思量波罗蜜等诸善法故。谓依闻思彼若名若义自性差别有上下故。成暖顶位治诸蔽漏。故云白净。五护集。即为善知识善摄。由内修行实证。得外教授故修行实证。即如实智。亦分上下立于忍位及世第一。上五皆同加行。下四皆已入地。六净心集。即善清净深心。以得出世间正智。于所缘境无分别智都无所得。不取种种戏论相。故名为善净。智能契理。故曰深心。七广集即立广大志。深心广利故。八信心集。即生广大解。以求一切智智故。九现集。即慈悲现前。谓多行慈悲无时暂舍。故云现前。然小乘无求佛意故。于护小心中明自利心。求一切智。小乘亦有自利三学之行故。今护行之中。但举利他慈悲。于中慈。依苦苦坏苦。以正在苦思愿乐故。悲依行苦拔彼妄乐。不知行苦之所迁故。三界不离三苦。故为慈悲之境。又明与乐即能拔苦故。慈依二苦。拔苦即与真乐故。悲依行苦。已知总别集为同相。戒等异相。略说为成广说为坏。如上具明。第二为何义者。为求佛果。先别显求果之相。后佛子下。总结发心。今初十句初总余别。总云佛智。谓无上智知断证修故。约无作四谛说此四别。修究竟故亦得名修。此智差别有九种业皆悉求之。一力佛智问记为业。以十种力随机答故。二无畏佛智。破邪见业拣异菩萨。复称为大。三平等佛智。得人法无我。教授众生证入之业。四救佛智。以四摄法化众生业。五净佛智。能为救摄因业。慈悲净嗔恚故。六无余智。佛智常以佛眼观世间众生业。十方遍观故云无余。七者染佛智。若顺今经。以无障碍智严其依报。自然应化。令其信乐为业。论经阙于净刹。八觉佛智。一念知三世众生心心数法为业。九转法轮佛智。解脱方便善巧业故。言善巧者。于百亿阎浮提同时转大法轮故。法轮即是能令众生解脱方便。然上九句皆先标智体。后显其业。初三自利后六利他。利他之中四摄是利他之行。慈悲是利他之心。后四利他之智。二总结发心中。言起如是心者。若直望经文。即指前十心。而论云。即是本分中愿善决定者。上求佛智即是愿故。前本分中指此文云。愿善决定者。如初地中发菩提心。即此本分中愿者。即指此文。生心即是生菩提心。以上求佛智故。愿即愿于菩提。二体不殊故得互指。前指于此即摄上之十句佛智。此指于前。即摄前文六决定义。彼是总句中指此。是总结中指总摄别故。又但云生心者。心是总。即摄知断证修。故不云生智。亦摄一切助道法故。不云生余心所。已说为何义。第三以大悲下。明以何因生如是心。意云何因求大菩提。谓以大悲为众生故。如三地中。思惟度生不离佛智。故下总句论经云。是心以大悲为首。是心即指前求佛智心也。十句中初总余别。别有九种大。一增上大。细行苦智慧增上生故。谓若了苦苦坏苦智非增上。论又云。智者因果逆顺染净观故。此约了事名智。论云。慧者自相同相差别观故。此约了二谛通理为慧。复是一门别义。言自相者。因缘之有是法自体故。同相者。二空真如等一味故。念生迷此故起悲心。同六地中大悲增上观其逆顺等。亦如六地广明。二善巧等即摄大四摄曲巧。随宜摄故。三最上下。淳至大淳至即最上义。谓向发大心许尽生界无尽利益。故曰深心。缘此悲增淳厚至到。故云最上。常以此二持此菩萨。四如来力无量者。无量大摄取如来无量神力。生物信故。五善观等即决定大。于上妙法决定信解。名善观分别。于诸众生决定能度为勇猛力。于所治障决能对治为智力。无碍智现前通结上句。六随顺自然智即随顺大。七能受等即受持大。能取大胜法授与众生故。大包一切胜即佛法。授与即教化智慧故能授。八广大如法界即最妙大。摄受胜妙功德故。九究竟下。住尽大。无量爱果因尽涅槃际故。为成十句合于此二。后之二大如本分说。但前云无常爱。此云无量者。胜用非一故。上九大中前七悲体。次一悲德。后一悲能。七中前三自分。一拔苦智。二拔苦行。三拔苦心。后四胜进。第四佛子菩萨下。有何相正显得位福利之相。文有九句。初总余别。总云始发如是心者。指前二段。即得超凡夫地者。以得出世间圣道故。超即过义。二入菩萨位下。别有八种过。论皆先法后喻。此入圣位生如来家。如世王子生王家故。故句句皆有相似法。言一入位过。初成出世间心。如始住胎相似法故。瑜伽住品。名入菩萨正性离生。二生如来家者。即家过。生家相似法。谓如世人虽受胎报。若在凡家不足为胜。要在王家方为显胜。菩萨亦尔。若在外道法中出家。不足为胜。今得佛所证法方为尊胜。梁摄论云。生法王家具足尊胜。下诸句例皆蹑前拣胜。三无能下。种性过。子相似法大乘行生故。谓大行成立。如得王体分堪绍佛种。是子义也。非贱非客故。梁摄论云。以过二乘及世间种姓故。四离世下道过。以非有漏故离世间趣。如非鬼畜等王之体。成无漏故。入出世道如要人王之体分故。梁摄论云。永不作杀生等邪行故。五得菩萨法即法体过。以同体大悲为菩萨体故。以化他事。即是自事。若无大悲法身不具。如拣异残缺。瑜伽云。设有问言。菩萨以何为体。应答以大悲为体。六住菩萨处者。处过。谓不住道是其住处。不同凡小。染世舍世以滞二边。如世王子不处鄙陋。七入三世平等者。业过。谓证平等真如以资慧命。拣无滋味则寿命天促。不任绍继故。是命相似法八于如来下。毕定过。佛种不断显因毕定。得无上道显果毕定。如世王子。虽依正精胜。志气不立所作不成。今志气成立决定绍位。名成就相似法。论云。如是示现凡夫生菩萨生不相似。有烦恼无烦恼故者。显与地前不相似也。第二菩萨住下。结住入位。住如是法者。指上四段。名住欢喜地者。是初住地义。以不动相应故者释成住义。一证真理不复失故。二乘异道不能动故。然不动有五。一种子不坏。名不动。即种性地已上。二起行不退名不动。即此初地已上。地持云。初地已上如明分月日夜增长。善法不退亦复如是。三空有无间不动。即七地。四无功用不动。即八地已上。五究竟不动。即佛地也。大文第二释名分中二。一总标。二成就下别显。于中分二。初正明喜相。后佛子下。出喜所因。然其喜相对依何身。以深种善根得此位故。后喜因中有念。当得喜。对为何义。以所求果定当得故。有念现得喜对有何相。以现离凡得圣故。其第三以何因悲心恻怆喜义不显。故不对之。今初正明喜相中十句。初总余别。总有三喜云多欢喜。一心喜。谓入观之心适悦。二体喜出观喜受相应。三根喜。由前心体欢喜内充外及五根轻安调畅故。此喜者亦名为乐。又内及观心即无喜之喜。不同二禅浮动之喜。故梵本。他经多名极喜。喜之极故。别中九。一敬喜。证三宝体得不坏信增恭敬故。二爱喜。乐观真如法故。上二即喜行之心即是心喜。次三正是喜之体相。三调柔喜。身心遍益皆适悦故。即诸根喜。四庆喜。自觉所证胜地前故。此句论当第三。前觉后悦义甚次第。五踊跃喜。身心遍益增上满足故。增上过前是踊跃义。六勇猛喜。自知堪受菩提去果不遥。故云勇猛。此一喜能。上六皆自行喜。下三化他离于喜障。七无斗诤喜。自心调伏故。论义解脱时。不令自他心扰动故。八无恼喜。化摄众生时。但以慈柔不恼他故。九不嗔恨喜。见不如说行当时不嗔。后无恨故。此句不为他恼。第二彰喜所因中二。先念当得故喜。后念现得故喜。各有十句。今初。初总余别。总云念诸佛者论云。如佛所得。我亦当得故者。文中虽皆念他。并是以他类己。故判为念当得也。以总该别皆属己。当别有九种。一念佛法。二念佛菩萨。三念佛行。四念佛净。五念佛胜。六念佛不坏。七念佛教化。八念佛利益。九念佛入。以总该别皆名佛者。为成佛故。六相融故。若别显义相统收十句。不出因果人法。一佛二法。是果中人法。论云。初二念共者。佛及佛法二事通二乘念。故名为共。则显余八不共二乘。后八皆因。初一是人。谓二地已上。乃至普贤之位。余七是法。于中更有总别。菩萨行为总。别中六句次第显前菩萨行。一以何法为所显。谓波罗蜜净以是行体故。二彼之行体显相云何。谓一地去一垢净一度。即菩萨地殊胜故。三何谓此行全显。谓第十菩萨地尽去障尽故。则行不可坏。上三自利余三利他。皆法云之行。一能受诸佛法明为教化法。二能云雨说法则众生得利益。三受佛智职入大尽等。是一切智行。亦可后三通于诸地。又上十句。初佛次法余皆是僧。僧中有人有德可知第二念现得中二。初正明所念。二何以故下。随难征释。前中十句初总余别。总云。我转离一切世间境界者。转离一切凡夫取着事故。然事有粗细。粗则外六尘境。通是一切凡夫取着境故。细谓现前立少物。谓是唯识性。亦为地前凡夫取着境故。别有九种转离。然此九种。对前有何相中总别九句。文虽不次法体全同。以是念前福利相故。故论二段之中。皆以相似不相似拣。谓与地前不相似故。九中一入转离。经云亲近一切佛以了法如常见佛故。此显事不相似。谓即前生如来家。以佛法为事。不似凡夫六尘事故。二远转离。三近至转离。此二示自身不相似。谓初即过凡夫地识为身故。后即入菩萨位智为身故。四断转离。即行不相似。谓离世间趣行。行出世净行故。五依止转离。即迭相依止不相似。谓得菩萨法。大悲为体依众生起。还与众生为依。不同凡夫不起悲心。不为他依故。六近见转离。是他力不相似。谓以大乘行成种性无过。见佛得助道力。不似凡夫非器不得故。七生转离。即处不相似。谓不住道是佛境界。亦菩萨住处。依之起行名生其中。八平等转离。即生业不相似。谓证三世平等之性。以资慧命而生智业。不同凡夫杂染业也。九舍转离。即成就不相似。谓成就离障毕定胜位。舍约离障成约得位。即前第八毕定过。成就相似法故。由离怖畏决得无上菩提。前就行位此就断位。言怖畏者。论云。不爱疑虑忧想共心相应故。不爱是所畏事。不活等五令心憎恶故。疑虑忧想正是畏体。所畏不定便生疑虑。所畏决定便生忧想。由心畏故相现在身。名毛竖等。然此九句与有何相文同符契皆已义引不得异解。由上诸义不相似。故名为转离。非唯离障名转离也。第二随难征释。由舍转离文义广。故重征释之义。有四重。谓怖畏与离各有因果。而文分五节。一总征。二列名总答。三转征。四举因显相。五菩萨如是下。结酬初征。今初征意云何。以此中说离畏耶。二答意云。以五怖畏是初地障。得初地时法尔离故。又离此即是此地利益翻畏名喜。此相最显故。于释名分中辨之。三转征者。此之一。征文含四意。一云。何以名为不活等畏耶。二云。何因而有此五畏耶。此二是怖畏因果故。论上生起。云何者是怖畏。云何怖畏因。三何以名为得永离耶。四因何令此得永离耶。此二离畏因果。若得离因自然无果故。论上云。远离此因无怖畏故。四举因显相者。谓正举离因显离果相。反显畏因及畏果相故。通有四意酬前四征。如不爱自身何况资财。是离不活因。则反显爱身资财是不活畏因。若不畏不活。即是离畏果。则反显畏于不活。是此畏果余四例然。又此离因即是能治。其怖畏因即是所治。五怖畏果。不活与死二相何别。惧无资缘身不存于朝夕。名不活畏。惧其因尽正舍报时。名为死畏。大怖之极无过死故。又不活通于三业。死唯约身故。论云。第一第二第五依身口意。第三第四依身。死约爱于善道惧舍身故。恶道畏者。憎于恶道。惧得彼身故。但说五者。打缚等畏皆五摄故。此怖畏因略有二种。一邪智妄取想见爱着故。二善根微少故。然此二因通五怖畏。善根少者。亦乏资财惧不活等故。有爱著者。未能忘怀畏大众等故。若取相显。初一为前三畏因。后一为后二畏因。邪智即是分别。身见取我乖理目之为邪。邪心决断名之为智。由有此智妄取于我乃我所想。以成执见而起爱着故。我见为主我所随生。爱着于我则有死畏见有我身惧舍命故。爱着我所有前二畏。但着财利有不活畏着利兼名有恶名。畏但无我我所则三畏因亡。然不活因举我况所。意但取所。后二因者。功德善少畏堕恶道。智慧善少畏于大众。又过去善少今畏大众。现在善少当畏恶道。今具福智兼二世善以为对治故。初三离因即二空智。后二离因即二庄严。五菩萨如是下结酬初征。前云何以能离。今酬由上三段如是义故。所以能离意正如此。而论云怖畏毛竖等事。何故二处说耶。前说身怖畏。后说异身怖畏者。意谓前第十句属念现得。故但云身。今通当报恶道等。故云异身

大方广佛华严经疏卷第三十三大方广佛华严经疏卷第三十四

        唐清凉山大华严寺沙门澄观撰

自下大文第三佛子此菩萨以大悲下。安住地分中三。初总明安住。二所谓下。别显安住。三佛子菩萨以成就下。总结安住。今初。文有三句。一大悲为首是安住因。菩萨所行皆为众生。悲为行本故言为首。二广大志乐无能沮坏。是安住观。论云。烦恼小乘不能坏此观故。谓契理深心为大。故烦恼不能坏。悲化兼物为广。故小乘不能坏也。三转更勤修一切善根而得成就。是安住行。此望初句是智导悲。望第二句是行填愿。此所修善。即下三十句显示。第二别显安住。即显前第三勤修善根。云何勤修。此有三十句。显三种成就。一信心成就。二修行成就。三回向成就。信为行始次依信起行。后回行成德。以为行修次第。今初信心十句。初总余别。总云信增上者。随所有事。谓下所列谛宝等境。深信决定名为增上。别中有九。初六始起信心。后三信增成欲。前中初二自利。后四利他。自利中一敬信增上。谓遍信三宝名多净信。二净信增上。自证真净智解故。上二皆云清净。是信之性。三决定信增上分别。令他证净智故。即利他之行。四悲五慈六无疲厌。此三增上皆利他心慈悲明心大。无厌明心常。后三中七惭愧信增上。是所成行体。谓有惭愧故治悭等蔽。不着世间成檀等度故。八柔和信增上。是得等侣于同法者不恼乱故。九敬法信增上。于所入法益敬信故。第二日夜下。修行成就中九句。初总余别。总云无厌足者。即无间修。别有八集。前七教行后一证行。前中初二摄法方便。一亲近集。近善友意在不忘诸法故。二乐法集。于问答中论义解释心喜乐故。后五句次第修行。于中前三内观顺理之行。一多闻集斯即闻慧。二正观集即是思慧。三不着集即是修慧。于三昧中无依着故。后二随缘离着行。谓六不贪集是知足行。已得不贪故。七不求集是少欲行。未得不求故。八如宝心集即证行圆明。常现前故。又难得无垢势力。庄严殊胜不改证心。同此具六义。故上依论释竟。其第六七集更有一理。谓第六心是远离修。修对治心离三过故。诸说法者有三种过。一着利养求四事故。少欲知足则能治之。二取名闻。为胜他故。正念定慧则能治之。三为他属。过爱敬事故。远离精进则能治之。此中能治即大人觉。其第七句是观过修八种不净。是谓资生。一切不求见不净故此比论释通局有殊。第三求一切智下回向成就。谓求一切智是回向菩提。有十二句。初总余别。总即所求之事名之为家。一切智地是求处故。别即能求之因有十一求。初一显能求之观名为依家。于前家中。分别观察具足十力无畏等故。余十能求之行。并总都有三求。于求行中。又分总别。总名无障求。谓求诸度无著法故。能除蔽障。下九句别。别治诸障故。初二对治檀中二垢。一者离求。治于陷曲。见乞求者诈现方便。一向无心与故。二如说能行求。治不随先言。许而不与。或许多胜与少劣故。又前是谄后则是妄。三者护求。治戒一垢。谓不护实语违本所受。犯已覆藏故。四不污求。治忍一垢。谓恼乱他业。是污如来利益家故。五不舍求。治进一垢。谓菩萨戒法无量不可具持。劫数长远不可常持。戒法精妙难持难行。不可善持生退转心。本不舍菩萨戒具能持之。不舍律仪故。能持难持不舍三聚。能行难行也。进策万行。而偏就戒辨者。有三义故。一戒为三学之首故。二戒具三聚故。三戒通事理难行易败故。寄以策之。六不动求。治禅二垢。一者乱心外攀如山治之。二者不能调伏忆想分别。一切智心治之。下之三句治般若三垢。即三道障。谓七不舍成就求。治障不住道垢。谓无善巧方便一向涅槃。现不舍世间治之。一向世间现成就出世治之。异于凡小成不住道。八者集求。治障助道垢。九者常求。求治障证道垢。于上胜妙证法之中。愿欲心薄故。上来回向成就竟。第三总结者。上三十句广于勤行具足。成就此勤行有四。一信。二欲。三精进。四方便。信谓忍受决定。欲谓希求趣彼行故。初十句中前七是信。后三是欲。次十是精进。对行造修。后十是方便行。成巧求故。是名此地说分中安住。故云成就如是净治地法名为安住。上依论辨更有别理。上多净信。已能永断阐提不信障。发生悲愍尊重教法等。亦能永断凡夫着我障。日夜勤修无有疲倦。又能永断声闻畏苦障。求一切智。乃至常求上上胜道。亦能永断缘觉舍悲心障。故云净治地法。安住地分竟。大文第四校量胜分。谓住此地中胜二乘故。论生既云。住此地中胜者。明知。愿等初住地分已有。但文不累安。故居安住之后。非是地满方有愿也。问经。云初发已为天人师。胜出声闻及缘觉故。沙弥发心罗汉推敬。如何至此方辨胜耶。答然其胜义乃有众多。统而收之不出三种。谓愿行智。此三历位故有众多。略明十位。一初发心胜。通于一切凡夫。如沙弥等。此通三心。二信胜。亦通三心。三解胜。四行胜。五显胜。此三即三贤别历三心。六证入胜。齐证三心双证二空。是为智胜。起十大愿即是愿胜。备修诸行即是行胜。下辨果胜亦三心果。此中行智由愿导故。所以最胜。依行布说。七地已上智方自胜故。下经云。从初地来彼悉超过。但以愿求诸佛法故。非是自智观察之力。今此七地自智力故。一切二乘所不能及。论主立愿为校量胜。凭此明文。虽历诸地戒定道品等。地地超胜。亦不出三心故。七从第七地去名权实自智胜。八无功起行胜。九上等诸佛胜。十究竟胜。所谓诸佛三心果满。今此正明愿行胜也。文分为三。一愿胜。谓标志遐广。二修行胜。依愿造修。三果利益胜。即位行成就。今初二义故胜二乘。一常勤修习无量行故。二与一切众生同行故。同行即是十无尽句。释此愿胜。先以五门分别。一名体。二修证。三行位。四因果。五立意圆融。五各二义则有十门。初中先名后体。名中先总后别。总云愿者。是希求义故。下论云。发诸大愿者。随心求义故。而言大者。下论云。光明善根转胜增广故。谓教证二光。与行愿善根转胜地前。广弥法界故。十愿中皆云广大如法界也。瑜伽四十五云。菩萨所修正愿略有五种。一者发心愿。二受生愿。三所行愿。四者正愿。五者大愿。初求菩提。次摄生处。生三无倒思择诸法。愿于境界修无量等四愿。当来摄受一切菩萨善法。故名正愿。大愿即从正愿所出。此复有十全同今经。今拣异前四故云大愿。兼取所从。即后二愿。别别大相至文当知。后显别名。瑜伽三十五及诸摄论。皆有明文。并如下文当愿自释。今且依梁论略列。一供养愿。二受持愿。三转法轮愿。四修行二利愿。五成熟众生愿。六承事愿。七净土愿。八不离愿。九利益愿。十成正觉愿。后体性者。克性即以欲总解信三为自性。若取所依悲智相导。即后得智。以为愿体。若并眷属。一一皆以一切俱行功德为性。故论云。光明善根者。光明即后得智。善根即信等及行。二修证者。先约修行。初七修始。次二修熟。后一修成得果。后约证者。地前已发今此十愿齐证。三行位者。先约于行。初二自利。次五利他。一以何身。谓摄法上首。而为利他转法之身。二以何心。谓即令他修行之心。三何者众生。四众生住处。五自身。住何处能化众生。上三可知。后三不定。一即八是自利满。九是利他满。十是二利得果。或俱自利。论云。后三显自身故。或俱利他。论云。此三示现如实教化众生故。若约通论十皆二利故。论云校量胜有二。一行无量行即是自利。二与众生同即是利他。后约位者。通则十皆初地所得。别则前七明行。已如上辨。后三明位。下论云。一得地校量胜。初地至九地。二得菩萨地尽校量胜。即第十地。三得一切地尽究竟故。即如来地。四约因果者。若就言显前九求因。后一求果。若约具摄七。亦求果是依果故。十是正果余皆是因。五立意圆融者。先立意。所以但说十者。已摄二严二利因果行位。无不周故。又为表此无尽愿故。故下云。一一皆摄阿僧祇愿。而为眷属。言圆融者以称性故。一愿之中具一切愿。即入重重如常所辨。六相圆融正在此文。已知大意。次正释文。文分为二。初正显十愿彰自勤行。后明十尽句与众生共。今初分四。一总标。二所谓下别列。三佛子菩萨住欢喜地下总结。四以此十愿门为首。下明摄眷属。今初。初句明成愿之位。是欢喜地。次能成就下正明总愿。能成就言该下三句。一始起要期。云如是大誓愿随心求义故。二方便起行。云如是大勇猛。谓成彼一一愿中。所作方便皆勇猛故。三愿遂行成。云如是大作用。谓如供佛愿便能供故。余例此知。论云。菩萨住此地渐次久习起此三行。非一时故。是知此愿亦即是行。称愿行故。非如凡夫空有要期。是以总言能成就也。以总该别十愿皆有此三。二别列中十愿不同。即为十段。一一愿中文各有四。皆初四字总标起愿。次显愿行相。三广大下彰愿德能。四一切劫数下明愿分齐。初后二段文通义局。第二行相文义俱局。第三德能文义俱通。十愿无别故。今初供养愿。准论愿供养胜田师及法主。此则通供。经从胜故但云供佛。文中阙于总标。以近前总如是大愿故。二三两段各有三义。通成六大。显初供养大愿之义。今初行相之中三大义者。一心大。即经生广大清净决定解。谓增上敬重深称佛境。故云广大。回向菩提决定信。故名清净决定解。清净解言信因果故。此上论意局在初愿。若以义求通余九愿。皆为菩提。广大无限无疑净信而起愿故。二以一切供养之具。即供具大。此是行缘。三恭敬下福田大。于中令无有余是总相。无余有三。一一切佛无余。即是行境。二一切供养无余。三一切恭敬无余。此二行体。由上二义成上敬田。上三皆云一切者。佛即三身亦兼十身。供养有三。一衣等利养。二香等敬养。三戒等行供养。恭敬亦三。一给侍恭敬。二迎送恭敬。三修行恭敬。即敬顺佛故。上三各三竖论一切。若横论一切。则佛该十方无尽等。余二准思。二彰愿德能。言三大者。一摄功德大。如经广大如法界。一切余善根中胜故。二因大。即究竟如虚空。无常爱果无量因故。三时大。即尽未来际。此因得涅槃常果故。三明愿分齐。十愿文同所作各异。此应尽未来际行供养故第二受持愿。亦名护法愿。瑜伽双云摄受防护愿。行相之中文有四句。皆通二利。然若约能受等说。受谓受领。摄谓摄属故。胜鬘。云摄受正法。护谓防护持即任持。故胜鬘。云护持正法。若约所受。初教次果。三行。四理。而受等言。文虽互举义实互通。亦初教。次证。三云。护教而判为行者。论经云。一切诸佛所教化法皆悉守护。论云。谓修行法。于修行时有诸障难摄护救济故。即摄护自行救济于他。上约始修愿名受摄等。若约终成名。四成就故。上总云成就如是大誓愿也。一者法轮不断成就。二者证智成就。三修行成就。四入理成就。第三转法轮愿。亦名摄法上首愿。先摄后转故。行相中四。一转法处。即一切世界佛应处故。二从兜率下转法时。谓现八相时。八相之义离世间品广释。三皆悉下摄法方便。于中初集功德方便。后为众上首下集智慧方便。以此二种助菩提法。故云方便四于一切下明转法顿周。第四修行二利愿。若约成益名心增长。论从此义故先标云。第四大愿心得增长。以何等行令心增长。一切菩萨所行教化一切。令其受行心增长故。文中亦四。第二行相中分二。初明能增长行。后明所增长心。前中分四。一明行相论名种种二行体。三行业。四行方便。以此四种教化众生。令其受行。初行相者。世出世间各有多异。故云种种。于中广大无量是世间行。意明俗智之行。广从初地乃至六地。大者七地。无量者八地已上。不坏不杂是出世行。法无我平等观出世间智故。谓不杂世间有漏法故。不坏者冥同真性故。若瑜伽通论云地前名广。虽行一切但得名广。一一行故。非大无量。地上名大。一一各以一切成故。不动已上乃名无量。一切行中具一切故。不坏者。于前六地。各得成一不可破坏。论主意明此地中之愿故。不取地前之行。义不异前。二摄诸波罗蜜。即是行体。广大等相但辨此故。三净治诸地即是行业。以十度行净十地蔽。助真如观净十障故。四总相已下明行方便。然有二种。一自行方便。谓以六相圆融巧相集成。一具一切仍不坏相。故名方便六相之义广如别章。略如前释。二皆如实下即化他方便。不违实道而化物故。二心得增长者。即所增长心。化他受行他心增长。化他成自自心增长。第五成熟众生愿。成熟亦名教化。就行相中文分二别。初明所化众生。教如是等下彰化所为。今初。初句为总。有色下别。别有六种差别。一粗细差别。此明报相。下二界有色为粗。无色界为细。于有色中有想天为粗。无想天为细。就无色中非有想为细。谓第四空非无想为粗。谓下三天此经文略。论经。云非无想非想非非想。谓非无想是粗。余即是细。二卵生下生依止差别。为报之所依托故。余三可依。化生依何依业染生故。然四生摄尽六趣。而通局有异。化生通六趣。胎生不通地狱诸天。湿卵唯局人畜。又以六趣不摄中有化生故。宽陜有异。余如别章。三三界所系名净不净处差别。欲界不净上二界净。就果以明故名为处。就因以说故名为系。四入于六趣是苦乐差别。受种种身故。亦名受生差别。粗相而说。三涂为苦上天为乐。人及修罗兼于苦乐。五一切生处是自业差别。此以因释果。由业异故生处不同。谓于一趣中有多不同。如于人中有中有边。贵贱家异等故。六名色所摄是自体差别。有体唯名谓无色界。彼处有色非业果故。有体唯色。谓无想天。彼所有想不可知故。有体具二。谓除前二。二化所为中初句结前生后。令入已下别明所为。所为有三。一为未信入者。令信入佛法。二已信入者。令其离恶为涅槃因。世间趣者谓业惑苦。三令修菩提道道通因果。第六承事愿。愿往诸佛土常见诸佛。恒敬事听受故。瑜伽。云愿于一切世界中示现。意明化生。今经但云知见者。知生佛住处故。就行相中分二。初明所知后辨能知。前中初句为总。广大下别。别有三种相。一一切相。二真实义相。三无量相。今初。界相不同故云一切。于中又三。初明分量。谓小中大千如次为广大无量。二粗细者明体质粗妙。谓应报等殊。论云细者。随何等世界意识身故。粗者随何等世界。意识色身故者。谓随能依色心粗细。世界粗细。粗者云色。三乱住下安立不同。乱则不依行伍。倒即覆刹。正即仰刹。若入若行若去。论无此文。文含二意。一成前安立。谓前三类世界道路往来。二者顺后。入即摄他入。已去即为他所摄。行即往来不住故。如帝网正喻于此。二如帝网差别即真实义相。土土同体不守自性。互相涉入如彼帝珠。故名真实。论云如业幻作故者。转以喻显。如世幻者。火处见水大处见小等。业所作土亦同于幻故。得涉入重重无尽。三十方下无量相。谓前二相周遍十方。又上说不尽故。结云无量。大菩萨藏经说。虚空中世界重数。多于大千所有微尘。但由业异不相障碍。一处重重尚尔。况复横周。第二智皆明了下辨其能知。若真实义相。唯智能知。余一切相可现眼见。第七净土愿。愿清净自土安立正法。及能修行众生故。于行相中总有七净。一同体净以同法性故。令一多互相即入。二无量佛土普皆清净者。即自在净。如摩尼珠美恶斯现净秽圆通。故云普皆清净。三光明众具以为庄严者。名庄严净。即相净也。四离一切下明受用净。谓受用此土离过成德故。初句成断德。后句成行德。如受用香饭身诸惑灭入正位等。五无量智慧下住处众生净。谓具德人居。今略语智慧。六普入下因净。净因有二。一者生因。谓施戒等。如净名说。二者依因。此复有二。一镜智净识为土所依。二后智通慧为依。如初第十地入佛国土体性三昧现净土等。此二皆是诸佛境界。七随众生下果净。因既有二果亦二种。一所生果。即前相净。二所示现果。即临机示现。今依此义。上七净中。前四当相明土。次一就人显胜。后二举因显果。就前四中初二土体。第三土相。后一土用。就土体中初彰体同。后明体净故有七净净土义周。第八不离愿。愿于一切生处。恒不离佛菩萨得同意行故。亦名心行愿。愿不离一乘故。故论云。第八大愿不念余乘故。行相中有十二句。初总后结中十别明菩萨行。今初。同志一乘同修万行故。次无有怨嫉下别。于中前五修行同。后五德用同。前中初二自分二严。一福善同集。二智观齐均。后常共下三句胜进。于中初一摄法方便。谓聚集解脱论佛法故。后二依法起行。初一利他故。随意现身也。后一自利。谓忘缘照境不由他教。云任自心。智契法身名知佛境。威力外用智慧内明。则兼报化分齐境也。后五德用中。一明通体。如意所成无能退屈。余四通业。于中前三如意通业。一本身往余世界。二现多异身于一切佛会。三示同类生名一切生处。后一法智通业。三修菩萨行一句总结上十。第九利益愿。愿于一切时恒作利益众生事无有空过故。亦名三业不空。瑜伽云。愿所有一切无倒加行。皆不唐捐。行相中二。先总明。谓乘念不退。圆满教轮三业皆益。又三业皆不唐捐。即是不退。摧障圆德所以名轮。后若暂下别显有二不空。一作业必定不空。三业能安乐故。谓见身行行。知佛法真实故云必定闻口说法能生智慧。念意实德诸惑不生。此从增胜故。说三业成益不同。实则互有。二得如大药下利益不空。二喻皆喻拔苦故。一切众生有二种苦。一种种诸苦。谓逼迫等。药树王身以为能治。二贫穷苦。如意宝身以为能拔。种种义兼身心若粗若细。贫穷通于世财法财。论主对前安乐。此为利益。故作此释。实则前喻喻三业舍恶离苦。后喻喻三业进善得乐也。第十成正觉愿。愿与一切众生同时得无上菩提。恒作佛事故。文四同前。而论总显愿相云。第十大愿起大乘行者。是果乘故。虽得佛道不舍菩萨利益。名起大行故。就行相中分为二别。初成菩提体。愿自运已圆。后不离下菩提作业。即运他不息。今初。菩提亦是总相。一切世界即得菩提处。谓遍于十方同类异类一切诸刹。真则称性。应则随机。故无不在。后菩提作业中有七种业。一从不离至入涅槃。是示正觉业。一切毛端是成佛处。上来平漫遍于十方云一切世界。今明遍法界中一一毛端极小量处。皆于其中八相成道。以彼皆有可化众生故。故离世间品云。于一毛端量处有多众生。况于法界。然复不离一毛端处。而于一切毛端处示现。则不动而遍。一多自在。二得佛境界下说实谛业。谓说四真谛令悟实故。初明能说。谓智慧力。力兼二义谓神通力。论经具之。此二力用唯是佛境。后显力用。以神通力念念成佛。以智慧力随乐为说。令得寂灭。是说之益。谓能断集修道。则得苦灭证于灭理。论释成佛。云除诸难处彼彼胜处生者。以佛生处必非五难处。亦无佛前后难故。云除诸难处。三以一三菩提下证教化业。以一极无二之菩提。契差别之性净涅槃。则不复更灭。说此证法令物生信。名教化业。四以一音下种种说法业。一音称机故。五示入下不断佛种业。涅槃常住动寂无二。双林应尽增物恋情。故云示入。既非永灭常作佛事故。佛种不断此亦得果不舍因也。六示大智下明法轮复住业。大智慧地唯一事实。即是佛智能生万物。终归于此。故名为地。示物同归。而智慧门随机万差。名安立一切。前即涅槃能建大事。此即于一佛乘分别说三。对实施权故名复住。七以法智下自在业。于中初显自在所依。所谓三通。法智通者。观一切法无性相故。神足通者。自身现生住灭修短。随心自在故。幻通者。转变外事无不随意。故此后二通。但内外为异。由法智通见理舍相。故不住世间。由后二通有自在事用故。不住涅槃成无住道。又依智论说有四通。前三同前。四以圣自在种种变化通。谓十八变三轮化等取此。则自在下当第四通。上来别显十愿竟。第三佛子下总结十愿。不异前标。第四以此下明摄眷属。若观经文似此十之类有于百万等。依论释云。此十大愿。一一愿中有百千万阿僧祇大愿。以为眷属则此十愿摄无不尽。如成正觉愿。则摄药师十二上愿。如净土愿。则摄弥陀四十八愿等。故此经他经。所有诸愿不出此十。非唯摄愿。亦摄一切菩提分法。如第七地辨。上明十愿彰自勤行竟。第二佛子此大愿下。以十尽句与众生共。谓前十愿皆为众生。由十无尽成前大愿。皆无尽也。文分为二。初总标举。后何等下征以别显。今初。晋经名为不可尽法。下释亦云皆不可尽。今言十尽句者。穷彼无尽皆无有余。故名为尽。斯则尽无尽之众生等也。故下论云尽者。示现不断尽。非念念尽。由此故。今前之十愿得大愿名。故云此大誓愿而得成就。二征显中。先显上十尽。后若众生界下。显前大愿成就。今初。先征。后显。显中十句。初句为总。十愿皆是为众生故。余九句别。别皆集成度生义故。一众生于何处住。所谓世界故。二世界依何。谓尽虚空界故。三说何法化。谓法界故。四随所化生安置何处。谓涅槃故。五涅槃何用。谓佛出现故。六以何方便巧化。如来智故。七此智何知。谓知心所缘故。八此心所缘令随何境。谓佛智所入境故。即是真性。后三转尽。略摄前九义含总别。云何摄九。谓世间转。摄前众生界世界虚空界。其法转摄前法界涅槃界佛出现界。其智转者。摄前如来智。下三界而言转者。世法及智。展转摄前无穷尽故。转亦是无尽义耳。又十中前四。为四种无量界。后六皆调伏方便无量界。十皆云尽者。无断尽故。第二显大愿成就中。先反显。后而众生界下顺明无尽所以。十愿同此十者。前之十愿不出此十。故此十尽句增上力故。诸佛以此力。常为众生作利益事。我愿同然。上来愿校量竟。第二佛子菩萨发如是大愿已下修行胜。即行校量有十种行。就文分三。初明行所依心。二成净信下显所成行相。三佛子菩萨如是下结十名体。今初。由先大愿熏心故。则得利益等十心。为起行依。于后十行起作自在。然有二意。一以十心通为十行之依。随释易了。二以十心别对十行。以治十障。文皆次第。唯信行最初。而不浊居末者。以与释文相接故也。一利益心者。利益拔苦即是悲心所依。治损害障能成悲行。二与乐柔软即是慈心。治嗔恚犷强障。三随顺所求。即是施心。治于身命财生顾恋障。四寂静无求。方能求而无厌故。是无疲厌心。治希求报恩贪着利养不寂静障。五三学调伏是知经论心。以经诠于定论诠于慧。经兼于律复是调伏。治无善巧求加行障。有则调伏故。六虽行世间妄惑不生。故云寂灭。是解世法心。以治性不柔和。不于他心随顺而转不寂灭障。七高崇贤善拒恶不增。故名谦下。是惭愧心。治于放逸之高举障。八能修出离以法润泽。即坚固庄严。治于种种猛利无间无断生死大苦。生怯弱障。九能如说行故心不动。即供养佛行。治于大师所犹豫疑惑障。十不浊心即第一信行。信以心净为性。离不信浊故。此治全未发心全未受持菩萨学处障。由治十障故。经名净治地法。地法通于教证。此所治障。具如瑜伽四十九说。第二别显所成行相。略启七门。一释名先列。后释。列者。一信行。二悲。三慈。四施。五无疲厌。六知经论。七了世法。八惭愧庄严。九坚固力。十供养佛。释名随文可见。二辨体多同十藏。三明得处信位即修故。信进念等大同于此。三贤渐熟故。十藏品有信等藏。初地证得以净治地障故。此偏明下。论云。此信等十行。尽是障地净法故。前将一行以对一障。四约修分别十行分二。前三是行意乐。故名为心。后七加行造修。故名为行。故论云。此十种行显二种胜成就。一深心成就。谓信悲慈。二修行成就。谓余七故。瑜伽地持皆同此说。五约二利。前七别显二利。信及无疲是自利行。余五利他。后三通约二利。摄护前七故。于中前二护前七。谓惭愧治障护令离恶。能令信等成无著行。由坚固力护令住善。能令信等成不可动。后一摄前七。一摄令成行。二摄令得果。思之可知。六明次第者。先自证信因果。既自证信愍伤妄苦。誓与真乐为救他故。舍而无吝求法无倦。便能了知经论筹量世法。止恶惭愧进善坚固。能真供佛。七释文者。十行分九。慈悲合故。今初。信行分二。一摄德成人。二能信下正显信相。有十一句。文分三别。初句总信因果。次九别明因果。后一结略显广。今初。如来是果本行是因。所入通因果。因果皆有证入义故。二信成就下。别明因果中前二句因。初句行体。后句行能。余七是果。句虽有七摄为五胜。合初三故。并结有六。五皆佛德故名为胜。五中前四智德。后一断德。智中一对治胜。即寄对显胜。谓十力降魔无畏制外。不共过小故云对治。而经云不坏者。为对二乘非究竟故。次三当相显胜。二即不思议神通力。上胜所现绝图度故。三不杂染胜。谓证真生智无中边杂。是佛之境故。以即边而中故无有边。二边既无中云何有。四一切种智胜。证真了俗故云随入无量差别。是种智境。五离胜。一切烦恼习常远离故。经但云果。而论判为断德。以前四皆果。今复云果。明是果果故。当涅槃三举要下举略显广。故总信一切因果。智地是证说即是教。力通上二。或谓威力。亦是三轮化益。第二双辨慈悲二行。中二。先明三观为方便。后菩萨见诸众生下明所起之行相。前中三观即为三段。第一远离最上第一义乐观。第二而诸凡夫下具足诸苦观。三然诸众生下彼二颠倒观。但失真乐已为可愍。况加妄苦。况复双迷反本何日。由初观故起慈。由次起悲。由后双起。今初观者。性净深寂名第一义。不动为乐。随妄则离。文中先总标起念。后诸佛下显所离乐。于中九句。初总余别。总云佛法者。唯佛教证所能显故。具下诸义所以甚深。别有九种甚深。今经阙论第九难得。一寂静甚深。谓法体离于妄计实有。故名寂静。自是妄计。于中正取非本不寂中论云。虚诳妄取者。是中何所取。此一约遮诠。二寂灭甚深。此约表诠。论云法义定故。谓一心体寂故云法定。二门亦寂即是义定。次三甚深对治三障。成三脱门观。谓三治妄分别障。四治有相障。五治取真舍妄障。六明离杂染观。谓真方便道。七不可算数思量生善根观故。即是助道。八依自利利他增上智观。故云广大。即不住道。九论云。难得甚深。三僧祇劫证智观故。即是证道。证性净信故。今广大摄之。大称体故。与证义同。前二直就法体。后七约智显深。故皆云观。第二具足诸苦观。约十二缘明之。然十二缘具业惑苦。但云苦观者。业惑苦因故。又二流动当相即苦。动即有苦故。文分为二。先别明缘相。后如是众生下结成妄苦。前中分二。初明前际三支。后于三界田下显中后九支。故论主分前三支。一处解释。后九及结一处解释。欲显前三是因。因是倒惑邪见义同故。识支约种是因义故。亦显前二。前三与次七次八许异世故。约果结苦。苦义显故。今初三支文有十句。初总余别。总云邪见者。前明正法理本无偏。今迷彼实义理外谬取。皆名邪见。通于业惑非独拨无因果。涅槃亦云。一切烦恼邪见摄尽。本在其中。云何言堕。此有二义。一约始起一分。名之为堕。二约迷真随妄义说为堕。非有始也。真虽本有迷亦无初相。依无性故名为真。若定有真真还成妄。若尔真应同妄互相依故。妄必可断真必可显。斯则不同不空之真。非由妄故。但空妄执自见真源。后无明覆翳下。别有九种邪见。初五无明。次三是行。后一识支业及识种亦名邪见者。义如前说。又邪见俱故。邪见引故。所以无明具多句者。一切烦恼谢往过去。总名无明。故今委说。又显一切烦恼皆能发润。而发业位无明力增故名无明。今初五中有二。初三根本迷法义过。后二为末追求时过。今初。前一迷法。后二迷义。故论总云。此三依法义妄计。如是次第。斯则妄计之言。通上法义。亦可妄计别对第三爱念邪见。初一句是蔽意邪见。此依迷法。谓无明住地迷覆法体。所言法者。谓众生心名为蔽意故。此无明迷真之初。妄惑之本。次二迷义者。通四住惑。由前痴故。迷覆因缘无我之义。妄立诸法。所迷诸法有内有外。谓第二憍慢邪见。此依迷内妄立我法。自高陵物故。经云立憍慢高幢。三入渴爱网中即爱念邪见。此依迷外妄谓我所及外境界。而生贪爱。如渴鹿驰焰鱼为网缠。如今爱支。四行谄诳下。二种邪见追求时过。如今之取支故。俱舍云。遍驰求名取。由上内计有我外见我所。以我对所便生三过。一初句于可得处。起谄诳邪见。谄诳屈曲虚而似实。故喻稠林不能自出。二于不可得处。则生忌嫉。三于已得处则生悭吝。上二即第五悭嫉邪见。经云。心与悭嫉相应不舍。由嫉他身故生卑贱中。形貌鄙陋。由悭财故资生不足。故云恒造诸趣受生因缘。次三明行中。初贪恚下集业邪见。由前追求。增长烦恼起业行过。此句。总明由惑造业。故六地。云不正思惟起于妄行。亦是行俱无明正发业故。诸业非一是为横集。日夜增长复显竖集。然集业因。由于三毒。故云贪恚愚痴三毒缘于三受。故论。云受诸受时爱憎彼二。颠倒境界故。谓乐受生爱。苦受生嗔。痴从中容故云彼二。颠倒之言通于上三。皆由无违顺中妄谓有故然愚痴无明行相何别。愚即迟钝多所封着。痴者迷闇不别是非。皆对现境不缘三世。缘三世境而不了达。乃名无明。不见未来发现业故。通义可知。次二别明行支中。初句明吹心识火炽然邪见。即内心思业。为烦恼风动。谓于怨恨时互相追念。名为忿恨。此思之始。欲起报恶业故云炽然不息。此思之终。思通诸恶而杀业在初。故偏云忿恨。下加害亦然。八起业邪见即兼动身口。故云凡所作业。论云。于作恶时迭相加害故。由倒造业业不离倒。故曰相应。三欲流下第九心意识邪见。明所引识支。以其识支通因果故。经欲具明故具显因果。论欲分析故先明识种。心意识三名有通别。已如前释。今此文中义含通别。别谓心是识种。意识通余四种。种子之言拣异现行。谓五果种谁能起此。谓善恶业。无记非因故此不论。善业云何复生苦种。以与欲等四流相应。今施戒等皆是有漏。非无念智无有断期。若尔何不名为起业种子。理实俱通。望苦乐报业为正种。望生心体识为正种。以就本性一切生死皆心起故。如芽肥瘦由于水土。而生芽者正在谷子。故诸经论互说二种。上明前际三支竟。第二明中后九支。然论兼结文。总分三段。初明自相。二有生故下同相。三是中皆空下颠倒相。言自相者。现在名色等支体状别故。言同相者。释有二义。一未来二支亦同现在。有名色等故。二约果相显缘起过患。通遍果位故名为同。犹如色等碍等为自相。苦等为共相。共即同也。是则现在亦有同相。未来非无自相。但隐显耳。此释顺论。论云。二同相。谓生老病死等过故。三颠倒者。缘体是空执有是倒。今初自相。复有三种。一者报相。二不离二字是因相。三此名色下彼果次第相。言报相者。即初受生异熟识。体共名色生故。论云报相者。名色共阿赖耶识生。此含识支一半名色支全故。摄论云。本识有三相。一自相。谓本识自体。二因相。谓种子识。三果相。谓异熟识。此意明为因义边名种子识。即前约因。识支为果义边名异熟识。即此报相名色所依。若不望因果直语自体。名为自相。今论因相。却是彼中果相。立名虽殊并通因果。经云于三界田中者。是所生处。下六地中约因位说。以业为田以识为种。今约果位故。以三界为田生前识种。复生苦芽者。标所生报。前三支因必依苦果而起。今更生苦所以称复。此显展转无穷之义。所谓已下出苦芽体相。论云名色共生者。名色共彼生故。谓名色共彼本识生也。恐人谬取名与色共。故有此言。名谓非色四蕴。色谓羯逻蓝等。此二与识相依而住。如二束芦更互为缘。恒时而转不相舍离。二不离是因相者。即显本识为名色因。谓是名色不离彼本识。依彼本识故。既依此释。定知此段具于二支。谓识及名色。三彼果相者。是彼报相名色之果。由名色增长成余八支。非别有体。初成六处者。名增成意处。色增成余五。次六处增长成触。言于中者。于六处中有根境故。余因缘义广如六地。二同相中生及老死。正显同相。如是已下总结成苦。何处是苦。此有三重。一论将入同相中。则以生老死忧悲苦恼。明于苦聚。文义显故。二近结于果。名色共生此明苦生。余八苦长。三远结十二。前二支半为能生长。后九支半为所生长。三颠倒相中。言是中者。是前十二缘中皆空已下明倒所以。由空谓有所以名倒。此有四重。一缘成无性所以言空。二离我我所释成空义离我人空离所法空。三无知下释无我所以。四以外事释无知觉。三中四句通外及小。初约外道。外道虽众。不出僧佉及与卫世。僧佉说觉以为神相。卫世说知以为神相。今无知觉。成上自体本无有我。作受二句。通于能所。能作能受故。是于我所作所受即是我所。在因名作在果名受。今但缘成故无作受。若约小乘就五蕴说。受蕴名觉三蕴名知。约六根说。身识名觉余五名知。五阴造业故名作者。当阴招报名为受者。今并遣之。现有知觉云何言无。随俗故有约真故无。又心法有四。一事二法。三理四实。谓随境分别见闻觉知。名之为事。论体唯是生灭法数。故名为法。穷之空寂说以为理。论其本性唯是真实如来藏法。故名为实。此四重中说。初即说知觉等名。若就后三即无知等。四如草下以彼外事喻。释无知觉等。以诸众生现见有于动止语言。云何说言无知觉等。故以外物动不动事。示无知觉。草木则动石壁不动。皆无知觉故。内动止岂当有之。净名云。是身无知如草木瓦砾。言亦如影像者。显从缘有似而非真。即双喻二谛。若准论经无影像喻。而有如响。可喻言声而无知觉。第三然诸下彼二颠倒观。妄苦本空得而不觉。真乐本有失而不知。而远乐就苦名彼二颠倒。上来三观为方便竟。第二菩萨见下正起慈悲。初明兴悲。谓见苦应拔。后复作下兴慈。谓无乐应与。既言具苦必知无乐故。第四施行文三初总明施行。二别显施物。三总结行成。今初文有五句。一明施所依。以见有苦无乐故。二以深重下彰其施位。此地檀度得圆满。故契理曰深。不舍悲愿为重。此心住地故能满檀。三于一切下明施体相四求佛大智显施所为。五修行大舍。结施行名。二凡所有下别明施物。偏显上文一切无吝。于中初总。后所谓下别。别显一切略有二种。一者外财二者内财。谓头目等文显可知。三为求下总结行成。初结所为。后是名下正结行成。然初地中应具三施。从增胜说但举于财故。般若论二三地中方行无畏。四地已上乃行法施。第五无疲厌行中分三。初牒前起后。二转更下正显行相。三即得下结其行成。下五行中唯除第十显相。即是结名。余皆具三文处可见。第六得无疲下成经论智。第七获是智下成世智行。言随应者。随机所应宜以何法。随力者。随己智力所能。随他智力所堪。随其所习者。约机现作。论释随宜言如论说者。即瑜伽菩萨地菩提分品也。第八成世智以下明惭愧行。知时已下正显行相。时有三种。一者念时。如是时中宜修定等。刹那不间故。二日夜时昼则存心。初中后夜皆勿废故。三所作得必不断时。此即智量。谓量力所能亦爱亦策。勿令过分后休废故。以此三时。修前八科二利之行。烦恼睡蛇昼夜不杂。为惭愧服而自庄严。第九于此行中下成坚固力。谓此即前惭愧二利行中。欲早求度应当精勤。不退自分不转胜进。第十得坚固下明供养行。利养正行具二供养。第三佛子下结十名体用。先结体用。所谓下结名言体用者。此十即是净诸地法。以治十障故。障如前说。然安住地分有三十句。亦明信慈悲等与此何异。论云前是清净地法。今尽是障地净法者。前句文略。若具应云前是清净。此地法以局初地故。今尽是障地净法者。谓不局初地故云尽是。尽净诸地障故。故经云。净诸地法。瑜伽亦云。此十种法于一切地。能净修治故。下诸地中皆云信等。皆转净等。第三佛子菩萨住此欢喜下。果利益校量胜。有四种果。一调柔果。二发趣果。三摄报果。四愿智果。释此四果略启四门。第二释名。通称果者地中满足故。别言调柔者。谓调炼柔熟。以供养摄化等为能调。炼信等十行为所调。炼由行供等令信等调柔。随意堪用故名调柔。下炼金喻其义甚显。二发谓发进。趣谓趣向。于地满中更求明解。为能发趣。发自此地趣向后后。为所发趣。下商人喻义甚相似。三王位之身酬因名报因成纳果。故名为摄。四内证愿力教智自在。又以愿力助智令业用无边。故称愿智。三明分齐。初二是其行修方便。后二是其报行纯熟。行修唯在地满。报行该于始终。从初住地乃至地满。所受王身说为摄报。所有作用说为愿智。又初二后一此地定有。摄报一果有无不定。容有不作故云多作。而定能作故亦定有。又初二果亦是地法。初行次解。是所修故后之二果唯果非法。初体后用非所修故。是以经于二果之后。便有结文云略说初地法门。不得此意。则似论家谬取法门滥为果称。四辨通局。发趣文局初地。以最在初故。义通十地通解十地故。余三义。局初地报等殊故。文通十地。地地皆有故。第五释文。四果即为四别。今初调柔分三。谓法喻合。法中分四。一见佛为炼行缘。二悉以下所炼行体。三以前二下别地行相。四是菩萨随所下炼行成熟。前中先总明。后所谓下别显。总中以大愿力是见佛　因力兼神力故。瑜伽住品。有二因见佛。一愿二力。论经具二。论云。以胜通力见色身佛。以正愿力见法身佛。瑜伽正愿得生受用土中常得见佛。今云法身即功德法身。别中云。见多百佛等者。论云。方便善巧示现多佛故。此善巧有二。一不直云无量。而巧历百千等数。为方便显多。二言多百者。是多个百。多千等亦然。是为一数之中已摄于多。故名善巧。理实入华藏刹海。见法界身云也。二所炼行体中以行入行。故名为炼。如金入火。然有三种入即分为三。一入功德即供佛行。去薄福垢亦兼供僧。二以此善下入无上果。即回向行。去下劣垢。论当第三。意明通回二行故。三佛子此菩萨下入大悲心。即利生行。去懈怠垢。三别地行相中。先约四摄。然四摄望前。犹是利众生法。望后为别地行相。以因利生之便故。于此明下二地中乃在炼行。成后四摄。虽不足全别十地。为是化生之法故用之耳。爱语是法施。初地檀满故说二增。二约十度。然证相难分寄十度等。以显差别。各说一增。若不尔者。何不二地言二度增。檀度初地先已增故。乃至九地应言九增。九地尚云余非不修随力随分。显寄明矣。是以具论诸地所行。略有五义。一为别地各说一增。如今文是。二辨胜过。前初地檀胜。二地二度胜故。二地文云。远离悭嫉破戒垢故。乃至十地十度皆胜。是则后后皆胜前前。三论其实行地地具修。四证理平等非多非一。五约圆融一具一切。四所炼行成中总收三入。初牒供佛化生。以为能炼。信等净法以为所炼。后举前回向能炼。令信等净也。言转转者。此之信等。于初地中有三节。净谓初住地时。证前缘修。令成真修。已是一净。二行校量中对除障法。复一度净。今此地后更历三修。故云转转。第二喻中。金师喻菩萨。金喻信等火喻供等三行。三行非一名数数入。调柔成就喻炼行成。金性本有从缘始显。信等修生云何同喻。信等有二。一未证真。前但约缘修为对治行。妄识为体。二证真之后。乃知信等非是今有。即如来藏中恒沙佛法。真心为体。真心为体即是理性。信等相殊说为行性。此二不二并可喻金。虽假供等缘修。以成真德。德由真起。后成严具。亦不异金。既了于真真非妄外。故全妄识即是真心。寄相显真。故分能所。第三法合准喻可知。第二发趣果中二。初正明发趣果。后佛子是名下总结地相。前中有四。一法二喻。三合四结。法中亦四。一问二知。三行四到。知是名解正能发趣。然由问故知所以先问。知意在行行必能到今初问中具问诸地。初地已满而更问者。一问胜进非问自分。二者一地之中。具摄一切诸地功德。故问所摄容许。未知于中。云相及得果者。相即随诸地中所有诸障。及对治相故。谓诸地能所观相。皆别十地故。得者即正证出世间智故。果者因证智力。得世间出世间智故。相即方便智。得是根本果即后得。后得缘俗故名世间。无分别故复名出世。又此三者即是三道。初是无间与惑相翻。二是解脱正证无为。三是胜进后智进修。不说加行者。地前加行非地摄故。地上加行胜进收故。言为欲成就此地法者。当地法也。后云彼地法者。后地法也。若准论意。成就地法即是信等。第二是菩萨善知下明知。由问故知。知不异问经展问中。相及得果以为十句。论摄十句为五方便。言方便者行修善巧也。第一观方便。观谓观解摄初二句。一诸地障对治者。以能治观解治十种障。立十地。别本文具之。此约所断明观。二地成坏者。揽行成位集故名成诸行。各住散故名坏此约所知明观。第二得方便。得谓证入摄次三句。曲有三种方便。一相果者。即欲入方便是方便智带相观终故名相果。二得修者已入方便即根本智。显是证修非缘修故。三胜进方便。即后得智。谓信等成地之法。离障清净故。第三增上方便进修后位。故名增上。亦摄三句。一地转转行者。依前起后。地背相舍故。二二执名非处二空为住处。亦是相应不相应也。三以后胜前增长善巧。名殊胜智。第四不退转方便。唯第九句。前三方便无退息故。第五尽至方便即第十句。净治菩萨地尽。转至佛智地故。若以相等摄五方便。初一是相。二具于三。如次三句配相得果。第三唯果

第四总明三事不退。五通明三因穷入果。若摄十句初三为相。第四是得。次四是果。后二具三。第三佛子下行。第四由此下到。并可知。第二喻中初喻前问。有二方便。一不迷方便。道中喻行因。住止喻得地。各有障治故曰安危。二资具方便。具资粮故不迷多约利他资具多明自利。次佛子彼大下喻知。三善以下喻行。四乃至下喻到。行中语略故云乃至。第三合中初合知。然后下合行。安隐下合到。喻中略行。此中略问欲影显耳。第四是故菩萨下结劝可知。第二佛子下总结地相。行修已竟故于此结。前说分齐深故说其一分此。中广故说所不尽

大方广佛华严经疏卷第三十四大方广佛华严经疏卷第三十五

        唐清凉山大华严寺沙门澄观撰

第三摄报果利益胜中分二。先明在家果。后是菩萨若欲下出家果。前中复二。初上胜身显其报胜。后能以大施下。明上胜果显其行胜。今初阎浮王者。即铁轮王。然璎珞仁王。地前四位已配四轮。今在初地方作铁轮。正明皆寄不可定执。常护正法应是行胜。如何论主将属身胜。护法有二。一护国正法。则赏罚以宜。二护佛正法护教理等兴建摈斥。论依初义。二上胜果者。依前王报起于胜行。是身之果。于中二。初行后愿。前中亦二。一大悲利他。谓若施若摄。二如是一切下不失自利。正作利他业时。即不离念佛等故。谓利他事中回向菩提故。成大恭敬事不生分别故。除诸妄想顺理合体。故云不离。所念有十一论分为四。一初三是上念三宝。在已上故不离三轮故。次一是同法念。次三功德念。一自身他身菩萨行。二度行自体。三诸地转胜故。后四求义念佛。以力等是真实究竟义故。已所求故。二复作下明愿有十一句。前七自德。后四摄化。前中此云殊胜。论经名大余名并同。首唯是总。谓大菩提位尊高故。妙等唯别。胜大亦总亦别故。首有二种。一胜首光明功德故。二殊胜首独无二故。胜亦二种。一妙智自在胜故。二微妙。离一切烦恼自在胜故。殊胜亦二。一上无与等故。二无上无能过故。后四中。初一约教。谓导者于阿含中分别法义正说故。余三显证。将者令他得证义。灭诸烦恼故。此约断德。后二约智。前因后果。师者教令入正道故。后句以大菩提而教化故。第二出家果中二。初舍俗出家。后既出家下修行克证。禅定胜业有二。一者三昧胜即胜定体。二三昧所作胜。谓因三昧得见佛等。有十一句。明其二利分为三对。初六句横论二利。初二自利。一见百佛者。十方各十他受用身。瑜伽住品。能于种种国土见百如来。寄位显百。理实如前见多佛也。二知神力。论意取神力所加说法菩萨。于上二处修习智慧。次四利他。初一有信机者动刹现通。次三有悟机者。往刹光照正授以法。次有二句竖论二利。一自摄胜生。瑜伽云。若欲留命能住百劫。二三明穷照示物善恶。后三句。一对明二利速疾。一为增长自智。思惟种种法门。二分身速疾作多利益故。第四愿智果。正愿久积以智内证故。其自在示现难可穷究。则显上来百数彰地阶差非定尔也。今行合法界。是圆融实德故云过此。论后结云。略说诸地各有因体果相者。以此地中相及得果。类后九地也。因即是相体即是得果。名不殊应知。此三通于下九。所以于此结者。显上广说不出此故。第二应颂四十六偈半分为二别。初正颂前后二结说。前中分四。初十一偈颂初住分。于中四。初一颂半依何身。次四颂半为何义。次二颂以何因。后三颂有何相。第二五偈颂释名分。初二偈半颂喜相。余颂喜因。于中先半偈颂念当得。后二颂念现得。第三有六颂。颂安住地分。初五句颂信心成就。次七句颂修行成就。后三偈颂回向成就。第四恒起下二十二偈半。颂校量胜分。于中三。初六颂半颂愿校量。次六颂行校量。后十颂果校量。于中初二调柔果。次二发趣果。次五颂半摄报果。后半偈颂愿智果。结说可知。初地竟(从此已下入第三十五经)第二离垢地。所以来者。论云如是已证正位。依出世间道因清净戒。说第二菩萨离垢地。言正位者。即初地见道是出世间。依此修于三学。戒最在初故先来也。前地虽证真。有戒未能无误。又以十度明义。前施此戒故次明之。下之八地依十度。次以辨来意准此可知。言离垢者。慈氏云。由极远离犯戒垢故。谓性戒成就。非如初地思择护戒。唯识亦云具净尸罗。远离微细毁犯烦恼垢故。十住毗婆沙。虽云行十善道。离诸垢故亦不异戒。瑜伽亦名增上戒住故。此地中断邪行障。证最胜真如。皆约戒明。言邪行障者。谓所知障中俱生一分。及彼所起误犯三业。能障二地。由斯二地说断二愚及彼粗重。一微细误犯愚。即上俱生一分此能起业。二种种业趣愚。即彼所起误犯三业。言最胜者。谓此真如具无边德于一切法最为胜故。此亦由翻破戒之失。为无边德。是以成于戒行。得于最胜无等菩提之果。并寄于戒显地相别。虽经论文异。大旨不殊。次正释文文分三分。初赞请分。二正说分。三重颂分。今初五颂分二。初三庆闻初地。后二请说二地。今初。前二经家叙其三业庆喜。后一发言申赞。然此庆闻亦属前地。以领前请后故。皆判属后。后二中亦初序后请。第二正说分中。先明地相。后彰地果。前中分二。一发起净即是入心。二佛子菩萨住离垢下自体净。即住地心。三聚无误地中正行。名自体净。直心趣彼名发起净。今初发起中三。初结前标后。次何等下征列十名。后菩萨以此下结行入位。今初标云深心者。深契理事故。论经云直心。而下列中总句同名直心。明知深直义一名异。论云十种直心者。依清净戒直心性戒成就。随所应作自然行故。谓发起净中。顺理事持是净戒。直心则令自体净中性戒成就。然性戒有二。一久积成性。二真如性中无破戒垢。今称如持使得性成。故云成就。二征列中。列有十句。初总余别。总云直心者。瑜伽云。于一切师长尊重福田。不行虚诳意乐。此约随相别释。今论主为顺一乘缘起义故。分为总别。别皆成总。则令总中具于别义。故不别释总句。别中初四律仪。次三摄善。后二饶益。一者柔软直心。共喜乐意持戒故。故瑜伽云。于同法菩萨忍辱柔和易可共住。二堪能者。有自在力性善持戒。烦恼魔事不能动转。难持能持故。所以鹅珠草系尽命无违。三守护根门不误犯戒。如良慧马性自调伏。以于诸行深见过故。四寂静者。论云调伏柔软不生高心故。则似不恃。前三所持是事寂静。瑜伽云。于大涅槃深见胜利者。斯即称理寂静。五纯善者。谓纯修妙善菩提分法。能忍诸恼如真金故。六不杂者。论云所得功德不生厌足依清净戒更求胜戒乐寂静故。谓虽得前句妙善。而不厌则不杂懈怠。乐于寂静则不杂事乱。身心俱寂即是胜戒。七诸有势力弃而不顾。不似难陀为欲持戒。八大悲为物不断有愿为广。九大智随有而无染。故能作有情一切义利。第三结行人位。由上十心。成于上品极圆满故。入斯戒住。第二自体净中明三聚净戒。即分为三。初律仪净。论云离净。谓离杀等故。此约随戒亦名正受净。此约初受。二摄善法戒。三摄众生戒。此三聚戒摄前三位。初摄治地住。次摄饶益行。思彼众生堕恶等故。后摄不坏回向。谓有智愿等。于法宝等皆不坏故。律仪。通于止作。摄善唯约善行。前二通于自利。后一唯约益物。又初律仪中。虽有善行而施忍等不行非过故。摄善中无所不行。若尔今经前二同离杀等二相宁分。古释有二义。一同体义分。约离过义边说为律仪。顺理能益判为摄善。二者隐显相成。律仪中有止作。因离果离是其止行。对治离者是其作行。举作助止说为律仪。摄善戒中亦有止作。以止助作说为摄善。今更一释。此中唯约自修正行。下摄善中亦令他修。则摄二利之善。及悲智之善。又此唯己分之善。下摄善中上修佛善。岂得同耶。今初律仪分三。初标所依。谓离垢地戒增上故。二性自已下正显戒相。三佛子至如是下结成增上。二中有十善业道。即为十段。今初离杀分二。初总明。后不畜下别显。今初性自远离。文属杀生义该下九。谓自性成就十善业道。即自性戒。然离有三种。一要期离。谓诸凡夫。二方便离。所谓二乘。三自体离。谓诸菩萨。契穷实性自体无染。然诸菩萨同修自体。而复有四。一离现行。所谓地前。二除种子即是初地。三除误犯。四显性净。此二当于此地。然性净难彰寄除杀等。以显彼净。此通余教。若依此经地体悬绝寄显地胜。岂可地前位位皆深。今居地上方行十善。二别显中有三种离。一因离。谓离杀因缘。二于一切下对治离。谓离杀法。三是菩萨下果行离。即离杀业。今初因离。复有二种。一离受畜因。谓不畜刀杖。此虽是缘从通名因。略举此二。余咒药等皆是此因。二不怀下明离起因。此正是因。因即三毒不怀怨恨明离嗔因。杀父害母亦不加报。次有渐下明离贪因。贪有二种。一为贪财利故造诸恶业。乃至没命心无耻悔。今有惭愧故能离之。二为贪众生捕养笼系。令生苦恼。今有愍伤之仁。恕己为喻便能离之。然起杀之痴必是邪见。邪见难遣非对治不离。是故论主就对治中。明离于痴。此略不说。二对治离中亦有二种。一生利益心。是与众生世出世间二种乐因。二生慈念心。谓念众生得人天涅槃之果。既于如是因果不颠倒求。则离愚痴心。起于杀因杀生祭祠等。此中慈益约能对治即名为离。不同前后杀因杀果而为所离。若尔前有仁恕。故离起贪因。仁恕之心岂非能治。前约本有仁等不起贪等。非是发起仁恕之心。今约于物发生慈益之心。以为能治故不同也。三果行离者。揽因成杀名业为果。今不正杀故名果离。于中亦二。一微细。谓心念害。二粗重谓身行害。今经以细况粗。粗中成杀有五因缘。一身谓于他故。他是所杀之体。故名为身。此拣自身二事。谓众生故。此拣非情。三想谓起众生想拣作瓦木等想。四行谓故以重意。重意是思故名为行。此拣错误。五体谓身行加害断命落究竟。正是杀业。故名为体。则拣前四以为方便。然杂集瑜伽。缘皆有五而合初二为事。复加烦恼。今以烦恼是前起因。故不重明。又境想轻重等非此全要。故略不明。第二离盗亦初句总。非理损财不与而取。故名为盗。别中亦三。一因离。二于他下对治离。三若物下果行离。因中止谓少欲。足谓知足。自之所有尚生止足。故无盗因。然止足有二义。一内心止足。即离起因。若廉贞之士。渴死不饮盗泉。二此地具无尽财。故离受畜因。然杀中杀具畜则为因。淫盗妻财以不足为因。二对治离中。由发起慈心恕己为喻。则于自资财尚舍而安彼。岂侵损他。然他有二。一他人二他世。不盗则不损当来资生。三果行离中亦有粗细。不取草叶为细。余资生为粗。而文通为五缘。一者身。谓若物属他。此拣于自。是他物体故名为身。二事。经阙此句。论经云他所用事。三想。谓起他物想。四行。谓翻终不盗心。五体谓举离本处。乃至下是以细况粗。杀淫于他正报成业。故以身心而分粗细。盗戒虽通依正。但约损财。故唯就外物以论粗细。又杀有多类唯人成重。故就粗中方说具缘。盗易成犯故总明具缘。若粗若细皆成盗体。第三离邪淫。乖礼曰邪染爱曰淫。别中亦三。一因离。谓自妻知足。此亦二意。一内心知足离于起因。二自足妻色。离受畜因故。晋译论经皆云自足妻色。足妻乃由寄报轮王。相同世间故得示有。知足约心亦不妨梵行。二对治离。谓不求他妻。现在梵行净故。不求未来妻色。他人之妻盖不在言。三于他妻下明果行离。亦有粗细。细约起心粗约从事。而文分二。初举邪境。后尚不下以细况粗。初中邪境有三。一不正。二非时。三非处。非处一种在后况中。初不正中他守护女。此为总句。护有二种。一不共护。谓他妻妾唯夫护故。二者共护。谓亲族媒定。亲谓父母族即宗族。谓二亲亡殁六亲所护。夫亡子等所护。媒定谓已受礼聘。二非时者。即为法所护。然法有二。一王法。二佛法。佛法谓修梵行时。此复有二。一分谓八戒。二全谓具足等。然此非时准智论十五。及诸论中广有其相。今之所列意在不起染心。故于自妻不委其事。二以细况粗中有二重况。一以染心况于正道从事。二以染心及正道。以况非道。非道即前非处。亦应以人况于余类。以后后粗鄙于前前故。以其淫境无想疑。故论主于此不约具缘。经文不言作他女想。约邪淫说。亦有想疑。为显此中自妻正境亦定无犯。故不说也。第四离妄语违想背心名之为妄。别中分二。初对治离。后乃至下果行离。今初对治即是因离。不别明因。何者有二义故。一无外事故。谓无刀杖妻财之外事。故无受畜因。二无异因故。谓但用诳他。思心即妄语因。无别贪等以为异因。异因即起因故离彼诳心。即成实语实语即是诳心对治故。对治离即是因离。不同身三故。身三各具三离。口四唯二。意三唯一。文中言实语者。随心想故。谓纵实不见而心谓见。而言见者亦名实语。真语者。审善思量如事真故。谓由心思与事相似。称此而言。若唯称事而不称心。亦名妄语。故加善思量。言时语者。论云知时语不起自身他身衰恼事故。谓心事虽实而回改见时。或令自他而有衰恼。今菩萨朝见言朝。暮见言暮。故曰知时。晋经名随亦顺时义。二果行离中。亦以细况粗。梦中是细故犯是粗。此言覆藏之语者。论经云不起覆见忍见。婆沙云。覆相妄语名为覆见。覆心妄语名为忍见。谓实见事心谓见言不见。此谓覆。己所见事相此翻真语。若实不见心生见想。诳言不见。于事虽实于见有违。名为忍见。忍却己所见故此翻实语。梦中眼见但是智见。第五言不乖离名离两舌。离两舌事成能令离间。别中亦二。初对治离。后未破下果行离。对治离者。即不破坏行。此唯约心。果行离者通心及事。即是差别。今初心者。谓传说者。必于心中忆持恶言。欲将破坏方成离间故。文云无离间心。论经云无破坏心。及为破彼。故等。而论云二种明心受。忆持者谓诈现亲朋。如野干诈亲师子等。又狎密成疏曰离间。亲旧成冤曰恼害。二果行离。差别有三。谓身心业各有二义。身坏二义者。谓已破未破是离间体。故名为身。二不喜下明心坏二义。一随喜他。二自心乐。三不作下业坏二义。谓若细若粗。细则实有恶言。粗则不实虚构。正传离间之言。故名为业。今菩萨并离故皆云不。第六言不粗鄙名离恶口。别中分二。初果行离。后常作下对治离。前后诸业治望果行。非全次第。故先显治。后能离果。今此历别相对先举果行。一时彰离。后说能治次第翻前。文义便故先明果行。今果行中先列所离。后明能离。今初有十七语句。各一义。而其论意展转相释。于中有二。前四一重总显恶言体用。后十三语重显前四。今初四语次第相释。初一总明语体。次云何独害。以粗恶犷戾故。云何粗犷苦他故。如何苦他令他嗔恨故。此之四语义一名异。后重显中。初有四语总释前四。于中初二明其语时。谓前四有对面不对面故。后二明前语体不出二类。一鄙恶谓不逊故。二庸贱常无教训故。后九别释上苦他令嗔为损之相。于中复二。初二明说前粗鄙之言。自违于戒。何以违戒。以能苦他令他嗔故。云何苦他不喜闻故。云何令嗔闻不悦故。余七语明自嗔忿心中发言。令他违戒起嗔生苦。初嗔忿语是自嗔语体。下能令他嗔。他嗔有二无饶益事。一初五语翻喜生嗔。谓闻而不爱如火烧心。忆时不乐故生怨结。热恼者令心胸闭塞。二末后句违乐致苦。谓己有同意乐事自身失坏。令他失坏失坏相知之乐故。后如是下明能离可知。第二对治中有十种语。翻前诸语而小不次。谓润泽翻苦他令嗔二语。柔软翻毒害粗犷。其现前不现前无别体故不翻。悦意语翻上嗔忿。谓和悦意中而发言故。乐闻喜悦翻不乐不悦。上说粗鄙故不悦乐。今说顺人天故生悦乐。又悦意下三语展转相释。善入人心翻如火烧。心热恼怨结。上以忿心发言。故如火烧等。今以言顺涅槃故。令善入人心。风雅典则却翻上鄙恶庸贱。前则街巷陋音。今则言含经史。故爱乐悦乐。翻不可爱乐生三昧故。身心踊悦。翻坏自身他身生亲善故。第七言辞不正故云绮语。其犹绮文总离可知。别中亦二。先对治后果行。前中八语初一为总。故下结云戏笑尚恒思审。是以菩萨常乐。三思而后言。则无散乱矣。下七语别。时之一字亦总亦别。总者上言思审者。谓思合其时语默得中也云何为时。谓彼此无损自他成益时故。论云善知言说时。依彼此语故时语有几。略说有三。一教化时语。谓见非善众生。劝发生信。令舍恶就善即时字别义。次二教授时语。令其忆念实语者。不颠倒故。谓学承有本转相教诲。后二释上云何不倒。以言含于义故称行法故。后三教诫时语。令其修行。地持教诫差别有五。一制二听。三举四折伏。五令喜。今三句摄之。一谓有罪者制无罪者听。为顺道理。二于制听有缺如法举之。数数毁犯折伏与念云巧调伏。三有实德者称扬令喜。故云决定。又此一句总结上四。谓若制若听若举若折。皆须适时。二是菩萨下。果行离中亦以轻况重。第八离贪。此下意三但有对治。以贪等是业有之本。更无所依故非果行。以非果故不可对之更立异因故。但有其一。今初离贪。谓离求欲心。别中有三。一事二体。三差别。于他财物。是事他所摄故。此拣于己。他摄有二。一己现摄用。二己虽不在作摄护想。二他所资用是体。谓所贪物体。然用含二义。一所用事。谓金等。二资用事谓饮食等。三不生贪下明差别。正显能治。一始欲名求。即他物想。二希得属己为愿。即是乐欲。三终起夺想为贪。此即方便及究竟。并前他物。即是五缘故。意三中要具五缘。若阙究竟但名烦恼。今皆性离故。以不不之。第九离于忿怒含毒。故名离嗔。别中有三。一别显能治。二永舍下总显所治。三常思下类通治益。今初为六种众生起六种治。论摄为五。一于冤生慈治于冤者。欲加苦故。二于恶行者生利益心。治当危苦故。三于贫及苦生哀愍欢喜二心。以此二心有通有别。通则可知故论合此。别则贫穷者愍之。忧苦者令其喜乐。四于乐众生生和润心。论名利润。治彼染着无利润故。五于发菩提心人起摄受心。摄令成故。二总离障中亦有六障。通障前六非一一别对。故云总也。于此六中。摄为三对初二己对他用辨冤亲。生怨故嗔。败亲故恨。怨则未生已生令其生长。亲则未生已生令不生长。次二唯约唯已善不善法。以明生长。障善名怨增恶名害。皆有已生未生。后二唯就于他爱不爱事。明其生长。忌胜名热。谓见他爱事苦他名恼。谓见他不爱事。皆有已生未生等。瑜伽云。嗔恚方便究竟者谓于损害事期心决定。正能成业。今并不行故。上云永离。三类通治益者。谓前所说者亦常思慈祐。第十离于乖理推求。不言性离者盖文略耳。别中治七种邪见。一住正道者治异乘见。小乘对大非正道故。二不行占卜。治虚妄分别见即是邪见。夫吉凶悔吝由爱恶生。故云虚妄。三不取恶戒治于戒取。四心见正直治于见取。五无诳者。治覆藏见。六无谄治诈现不实见。七于佛下治非清净见。此所治七见。释有二门。一约行二约人。约行中。初一愿邪愿小乘故。次三解邪。颠倒见故。然邪见恶戒唯是外邪。见取一种通于内邪。谓学大乘者。执语成见故。次二行邪。藏非诈善故。后一信邪。信世间故。又于三宝决不信故。故瑜伽邪见方便究竟者。诽谤决定故。二约人者。初四是邪梵行求众生。于中初一同法小乘。后三外道。次二是欲求。后一有求。今性不求名离邪见。第三佛子下结成增上者。此有三义一遍护十善即不阙义。二常无间即清净义。误犯之垢不起间故。三常无断即常护义。具斯三义得增上戒名。第二复作是念下摄善法戒。谓非唯律仪不阙不断。常摄善法亦无断阙。文中分三。初略观不善起摄善行。次佛子下广观障治起摄善行。三如是方便下总结劝修。今初分二。先明观智。后是故下明起愿行。今初堕恶道者。有三种义。一者乘恶行往故。此即集因。经云皆以十不善业。二者依止自身能生苦恼。此即能堕一切众生。三常堕种种苦相处。斯即所堕恶趣。上二皆苦果。业者因义。道者通到义。既要用不善方堕恶道。则非无因所用。唯是不善。故非邪因。后起愿行者。由念众生恶因果故。便起大悲要心二利。于中先正修二利。后何以下征以反释。第二广观障治明摄善法中。谓观五重善法。于上上清净佛善起增上心。求学修行摄善法戒清净行故。若直就经文亦分二别。先明观智。后是故下要心摄善。今论将后段摄属佛善故。且分为二。先观不善唯是所治。后十善业下观于善法。通能所治。今初具有苦集。此中为明摄善故。略示其恶。既果举三涂。则显因亦三品。如后摄众生戒经文自具。后摄观十善具诸法门。然通相而辨。善皆能治。以顺理益物正反恶故。若随相分人天之善。犹为所治是苦集故。文分五重。今初人天十善。以人天是世间之善故不分之。实则亦具三品。谓人善为下欲天为中。色无色界为上。言三品者。或由三时之心。或约境有胜劣。或心有轻重。或自作教他等。细论其义多品不同。略言三五耳。为不善者反此可知。瑜伽六十广显差别。第二又此下辨声闻善下。三乘中各有三段。初标所修善同。次显所用功异。后结成自乘。今声闻中。以智慧下明所用异。于中初句对前彰胜。以实相智修。不同人天无智善故。通观上来善恶因果。皆是苦集所观境故。次心陜劣下对后显劣。有五种相。一因集由集小因故。心陜劣陜谓修行少善。劣谓但能自利。二畏苦即怖三界故。三舍心即阙大悲。舍众生故。上三唯劣菩萨。下二兼劣缘觉。四依止。即经从他。谓必藉师教故。五观即闻声解了。谓闻人无我法声心通达故。三成声闻乘。结成自乘。然能治十善及与智慧。即是道谛恶因果灭。善因果中使灭名为灭谛。成声闻乘义舍道灭。第三缘觉善所用异中。初句总明。以能修习名修清净。未能圆修不名具足。次不从下别显有三种相。一自觉谓异声闻。不从他闻显依止胜。二大悲下。不能说法大悲不具。无心起说方便不具。力不堪说。若有利物多但现通。此劣菩萨。三悟解已下即观少境界。少有二义。一对前显胜。以是利根。但观苦集。便悟甚深之观。胜于声闻。二对后彰劣。但观人无我法。不同菩萨求佛大智等故。上之二乘。广如瑜伽本地中说。第四菩萨十善所用异中。有四种相。一因集二用。三彼力四地。四中初一行因。次二行相。后一行位。言因集者。宿习善根依之起行。此又三义。一依一切善根起行故。即修治清净具足。具足即一切善义。今经阙此二字。则不能异上辟支。此明自利。二心广者即利他心三无量者即大乘心。是二利行体。二具足悲愍是菩萨用。三方便所摄。即以四摄摄生。是彼悲力。四发生下皆显地义。地虽有十。就三祇满处略举三地。以摄余七。一发生大愿。即净深心初地。二不舍众生。即不退转地。虽得寂灭不舍众生。即八地。三希求佛智等。即受大位地。是第十地。此有三句。一观求行证智度满故。二尽净诸地障故。三尽净诸度蔽故。三成菩萨广大行。结成自乘。第五佛善。上上是总。一切下别有四种义。显上上事。前三属佛。后一菩萨思齐。一者灭。谓不善业道共习气灭故。种智清净。二者舍。谓乃至证十力无畏不共之法。舍二乘故。三者方便。谓于菩萨乘一切佛法。皆善巧成就故。四菩萨求无厌足。故云是故我今等行十善。上虽列五重十善。凡小但将化物。非己所行。菩萨十善先已安住故。唯要心等行佛善。佛善望己是余残未修。一切智中自在纯熟方为具足。亦灭习气故云清净。结劝可知。第三佛子十不善业道下。利益众生戒。文分为二。初广明摄生。后佛子菩萨如是护持于戒下。结成益生之戒。前中显此戒增上有五种义。一者智。二者愿。三行。四集。五集果。今初。谓善知众生苦因果故。文分为三。初总明知因。二于中下别显知果。三佛子下结成苦因。今初。总中果有三涂不同。因有三时阶降。论名时差别。三时复二。一者约心。谓如杀生。欲杀正杀杀已。三时俱重。名为上者。随一时轻为中者。三时俱轻为下者。二约时。谓少时多时尽寿作等。余有三品。如上十善中说。复应于一一涂中各有三品等。然依正法念经。三涂各有边正。正者为重边者为轻。正鬼望边畜。则饿鬼罪重故。杂集等鬼次于狱。若正畜望边鬼。则畜生罪重故。今云下者饿鬼因。二别显知果中。十不善中各有二果差别。一报果差别。所谓三涂异熟。二习气果差别。即人中残报。是正报之余。经中若生人中得二种是。然杂集瑜伽等论。开习气果以之为二。一约内报名等流果。即如经辨。二约外报感增上果。今经阙此。下依彼显异熟报果。十恶攸同。今但解释等流增上。然二等流多是前重后轻。轻即方便等流。重即正恶等流。十恶即分为十。初杀生中。杀令夭折不终天年。故得短命。即正恶等流。二未死受苦故获多病。即方便等流。怖无精光。感外增上资具等物乏少光泽。二盗损彼财故获贫穷。令其不得称意受用故。共财不得自在。感外田苗霜雹损耗。三淫中令其妻不贞故。方便詃诱故。淫之秽污感外臭恶尘坌。四妄语等流。又诽谤约违境。被诳约违心。言无实故。外感农作事业多不谐偶。五两舌中令他离间故。亲友成怨故。由出不平之言。外多险阻。六恶口中。语体恶故语用恶故。言恒有诤违恼他人。外感荆棘砂卤等事。七绮语言无人受。机不领故语不明了。自绮错故。以言绮故。外感果物不应其时。八贪欲中。已得不足故未得欲求故。贪则念念欲多。感外增上日日减少。九嗔恚中二种等流。似前轻后重。见其不可意故求彼长短。二恼害彼故。嗔不顺物之情。外感增上其味辛苦。又多恶兽毒虫。十邪见还生邪见之家。若水之流湿。心见不正故多谄曲。总由不正故。外感上妙华果。悉皆隐没。似净不净似安不安。是以观果知因应当除断。三结成苦因。无边苦聚由此生故。第二是故菩萨下明愿。依智起愿。愿为众生自修善故。但离恶因恶果自亡。愿修善因善果自至。问恶名杀等离即不杀。不杀即善。离恶住善。二相宁分。答此有二意。一离杀。谓离作犯。住善。谓住止持。体则不殊。约持犯分二。作持止犯反此可知。二离恶但是恶止。住善兼于善行。具有止作二持。止如前释。作义云何。前三聚初已略指陈。今当重释。谓非唯不杀。护众生命。如护己命。是第一善。守他财物如自己有。他妻亦然。实语软语和合饶益。是语四善非直无贪。更能惠施。非唯不嗔慈悲和悦。何但无于邪见。乃成就正见。智慧深广斯即作也。第三自住下明行依愿。起行如誓修故。于中初依前愿以起自行后亦劝下。依于自行正摄众生。第四佛子下明集者。依增上悲念众生故。生十种心。此十亦可俱通一切。论就别相为八种众生。一于恶行众生令住善行。故名利益。二为苦众生令得安乐。三于怨憎众生慈不加报。四于贫苦者悲欲拔之。五于乐众生愍其放逸。六于外道摄令正信。七于同行者护令不退。八于摄一切菩提愿众生取如自己。以愿同故。后之二心亦约此类。但后胜于前。九观彼众生乘大乘道。进趣之者敬之如师。十观集具足功德者。敬如大师。第五作是念言下集果。依前悲心起胜上欲。欲拔济故。文中救摄十类众生。皆言又作。文各有二。先观所化。后我当下。与济拔心。前即所治。后即能治。前集之中欲显差别。以其十心对八众生。今十类中。一一生所容有如前十心救拔。十中初一解邪故。论云。依增上颠倒为首。余九行邪。论开为三。初五化欲求众生。求外五欲故。次二化有求众生。求三有中正报之果故。后二化梵行。求众生求出道故。通上为四。然此所化。但摄集中前六而阙后二者。以集者益物之心。起心义宽。乃至缘于具德生师仰故。今此正论救拔故。后二并非所救。纵其同行退转须化。亦无大乘之外别有安处。可云拔出。今第一化颠倒众生中。先所化中邪见为总。谓四颠倒。理外推求故名邪见。次恶慧恶欲此二是别。常乐二倒名为恶慧。专念分别方得行故。我净二倒名为恶欲。不假专念即能行故。以性成故。由计我净便欲名等。如涅槃说。后恶道稠林者。结其邪见为诸过因。恶道者非正道故。显前颠倒为现行烦恼行处。稠林者亦为随眠之因。后结能治中。住于正见。通翻上邪行。于实道翻恶道稠林。第二化欲求众生中。五段分二。初三化现得五欲受用生过。后二化未得五欲迫求时过。前中即分为三。一受不共财。二受无厌足财。三受贮积财。今初已得之物不与他共。于费用时生嗔过也。先明所治。互相破坏以为总句。破坏有二。一斗诤于言中。二对怨于心中。即分别彼我。嗔恨已下结其增长。由嗔恨故思念作报。身心恶行炽然不息。能治之中慈能治嗔。如来之慈乃名无上。二化受无厌财。众生求时无厌以生贪过。初所治中有二。一贪取无厌明内心难满。二唯求财利者。形于身口邪命自活。结上三业。后三业正命以为能治。三化受贮积财。积而不散顺生三毒。增烦恼过。初所治中。染着生贪散用生嗔。若积而能散。何有贪嗔痴迷上二。言种种烦恼因之炽然者。直观经意。因上三毒更生烦恼。若准论意。因贮积财。积财即是烦恼因体。云何炽然。谓宝玩受用。数为烦恼之所烧故。然痴有二过。一迷前二。亦复不知何者是火。云何为失。二无求出意故云不解出要。谓既迷火宅之为乐。宁有出心。后能治中。涅槃清凉烦恼火灭故。上三即起烦恼众生。第二有二愿化。未得五欲追求时过。即造业众生。分二。初一明追求现报。造诸恶行。后一明追求后报。造有漏善业。今初。先所治中有四种过。一愚痴覆心过。于中愚痴是痴体。重闇是痴相。亦是痴过。余皆痴过。一重闇者。迷现在苦不知是苦。二妄见者。于现下苦妄见乐故。如见空华。三厚瞙者。不见未来当受苦报。如眼厚瞙都无所见也。二入阴翳下增恶远善过。初句增恶由迷异熟。愚顺不善行增长结使。名入阴翳稠林。后失智慧光明者。此明远善也。痴为善行障故。三行旷野险道。明受苦报过。生死长广迥无所依。喻之旷野。多难障碍。复名险道。流转称行。四起诸恶见者。即无正对治过。论云。谓多作罪因。于临终时见恶报相。心生悔见者。或悔先所修或起恶见。故名悔见。而不能集正对治。所以名过。后能治中。先得净慧眼是体。此眼有二能。一见如实相。二由见实相即不随他。具斯二义名真慧眼。以此二句总翻前过见。前皆实故。二化追求后报习善行者。随顺险道过。谓以迷出世胜义愚。造福不动业。求未来报。则常在险道。前所治中十句分三。初句自体谓即生死故。二将坠下障碍。谓在之难出故。三随顺下明失。谓住之失于出离善故。今初自体。谓由世间少善为根本故。则人天报危故名险道。二障碍者。皆险道中事。文有八句。迷于苦集道灭。如次各二。一明有苦。谓心虽求出而行顺三涂。如临深渊故云将坠。二入恶见网中。此明迷苦。于苦果中妄生乐想。为恶见网萦。如世险道葛藟交加。三为愚下迷于集因。谓为愚痴所覆。不知烦恼不觉业空。若加深林不见危险。四随逐下明其造集。世寡正道学即随邪。复起邪业为行颠倒行。如险路多岐。动入豺狼之径。虽疲行不已欲进返回。五譬如盲人。显无道体无正慧眼。但得果贪着爱欲所盲。故法华云。着乐痴所盲。即斯义也。如无目涉险茫无所之。六无有导师者。明阙道缘。导师者谓佛菩萨。既离明导有二种失。一当生恶道。二今世后世。虽处人天放逸障见。故佛虽出世有不见闻。如盲无导师。若不陷深坑则坐而不进。七非出要道。谓为出要者。正迷于灭希求涅槃。而趣异处。谓于梵天乃至自在。依正之所以为涅槃。推斯邪解以为正见。如在险道以塞为通。八入魔等者。显有灭障。五种妙欲是魔境界。贪着为入。六尘劫善谓之恶贼被牵为摄。三随顺下二句明失。初句依止怨。故失离恶法。后句远善友。故失进善法。人法俱失。后能治中拔出险道。总离前恶住无畏城。是能离之处。若旷野遇城。众难何畏。近对上文。若无知动念。则顺魔心而远佛意。寂照双运即出险难。而入智城。上来化欲求竟。第三有二段化。有求众生。初一道差别。谓五趣流转。后一界差别。三界系闭。今初先过。后治过中初句为总。入欲下别。总即没在大河过。六道漂溺如彼大河。求有没中所以是过。然总中含下别义。亦是赖耶瀑流七识波浪。别中彼大瀑水波浪有三种相。一自体漂流。谓五趣因果。二身见下为因起难。谓处之多害。三安六处下便成大失。失出离道。今初。自体有五种相。一深。二流。三名。四漂。五广。但有其一。已为难度。况具斯五。漂没何疑。一深者。即具足四流无量水故。为烦恼河。二生死洄澓者流也。上总四流烦恼因深故。此苦果常流无竭。上二即漂溺处。于此生死而漂溺故。三爱河漂转者名也。前明四流。虽无惑不摄爱润生死。由此漂溺偏受河名。如愚堕河爱即难出。四湍驰等者漂也。此有二义。一显河急故云湍驰奔激。谓虽宝爱身欲令长久。而念念不住。是漂溺时。二由急故不能如实知其过失。亦复不见涅槃彼岸。故云不暇观察。是为如此漂溺。五为欲觉等。随逐者广也。谓随欲等觉遍觉五尘。故名为广。依此漂溺。涅槃则以欲等以为毒虫。第二起难有四。一者执。执着我我所窟宅。不能动发。故云身见罗刹。于中执取。言于中者。于阴窟之中。执取之言亦含戒取。二将其下转还。谓先舍欲已得生上界。由身见执还生下界欲念之中。若准涅槃。爱见皆为罗刹。论经云。爱见水中罗刹者。译者回文不尽。三于所贪下。中着。谓于受用时求欲等乐着故。四住我慢原阜者。增慢。谓于受用事时中。我慢大慢憍慢自高轻彼故。慢令心高故喻原阜。上不停法雨下不见性水。广平曰原。原自是高原上。加阜。则慢上过慢。对涅槃岸以水为患。对佛性水则原阜为非。贤首云。四中初一见。次二爱。后一慢。爱中一种子不灭故还来。二现行深着故泥溺。如人在河四事难出。一被执住。二被回流。三为泥溺。四滞枯洲不到彼岸。合喻思之。三明失中有三。一善道无出意失。安六处聚落故此无善因。二恶道无救失。此无救缘。三无能度者异处去失。谓离自善行生诸难处。不值佛故。此双阙因缘通善恶道。后能治中。初起化心。后以诸下成化行。化行有六。一与善因。谓六度万行以为船筏。二作救缘。三令无苦患。四令离集染。五证涅槃寂静。六令得菩提大智。皆翻上三段思之。云何能得此益。论云以如实法。云何如实了生死实性本如。即苦患而证涅槃。见烦恼本源性离。即集染而成大智。如斯教者真与善因。真能救也。第二明界差别。先过后治过中初句为总。三界系缚犹如牢狱。求有处之所以为过。次多诸下别。别明世狱有五过随逐。一苦事二财尽三爱离四有缚五障碍。三界之狱亦然。此五示五种难差别。一无病难。无病是乐病则有苦。与破为难下难义准之。苦谓身诸病苦恼。谓心病愁恼。二常怀爱憎是资生难。爱彼资生求而不得。憎彼贫穷远之强会。三亲难。亲爱别离故生忧怖。四戒难。虽生上界暂离犯戒。不免戒行相违。还为贪械所缚。谓报尽起于欲恶。明上二界非欲永灭故。此贪欲通系三界五见难。虽得世间八禅定智。亦为无明所覆。与正见相违。后能治中。若如实了知三界之相。无有生死非实非虚。则自无障碍果证圆寂。第四有二段化。梵行求众生分二。初段化邪梵行求。令舍邪归正后段化同法小乘。令舍权归实。今初先明过中。初句为总。谓执着于我过。然诸外道执见虽多以我为本。断常等见皆因此生。次于诸蕴下别。别有六句。前三失道故。远第一义乐。后三失灭故具足诸苦。今初。一于诸蕴窟宅不求出离者。无始发方便。谓彼外道众生欲趣涅槃。以有我故。于五阴舍不能动发。二所趣不真内入无我。故名空聚。我想妄计遍于六根。故名为依。三造行不正。既求涅槃应行八正。翻行邪道四颠倒行。以彼计蕴。身受心法为净等故。后三中。一四大乖违苦。谓老病死苦人皆欲远。由计我故四毒常侵。二五阴随逐苦。五蕴具诸结过。常能害人善法故。二怨贼六受无量苦者。上不说者皆在其中。亦总结前五也。后能治中。上由计我处处生着。唯大涅槃是无著处。云何能得谓如实法。如实法者略有三义。一上怨贼等。外道不知计我处之。今菩萨教之观过。了无有人。二假以世喻。喻所不及。则五阴等过于怨等。三知其实性。人法俱空皆是最胜无所著处余如涅槃二十一说。第二化同法小乘。初起过中有三。初不求大因过。利生懈怠为陜。佛法无量退没不证为劣。二不行下不愿大果过。三虽欲下明修行过不定聚众生。实有大乘出离之法。而修行小乘。后能治中广大佛法。即诸度万行。登地已上名为广大。皆佛因法。广大智慧通于因果。翻前陜劣总名广大。上来广明摄众生竟。第二佛子下结成摄生之戒。护持于戒。即前律仪及摄善法。故能增长慈悲之心。即益生戒。第二位果唯无发趣三果同前故。论云有同者。无者亦名果校量胜者。三果皆胜初地故。初调柔中三。一调柔相。二佛子此菩萨下别地行相。三佛子是名下总结地名。初中三。谓法喻合。法中三。初见诸佛为练行缘。二于诸佛下明能练行。于中先供养。后于诸佛下受法更受十善。即学佛善也。是戒地故。三是菩萨下所练净中。对前胜者。以离悭嫉破戒二种垢故。初地菩萨戒未净故。施亦未净。前就初地说檀度满。令更转净。以离二垢说名离垢故。故喻初地。金但火炼以除外垢。今此置矾石中。兼内净体明。云一切净。法合可知。二别地行中。以离语四过。说爱语偏多。二菩萨住此下摄报果。先明在家。后若欲下出家。在家中二。先上胜身即金轮王。后能除下明上胜果。三若以菩萨下愿智果。并如初地。第三重颂中。有十五颂分三。初十颂位行。于中有四。初一颂颂十种直心。二有二颂颂律仪戒。三二颂半颂摄善戒。四有四颂半颂摄众生戒。二有四颂颂位果。三有一颂结叹所说。二地竟

大方广佛华严经疏卷第三十五大方广佛华严经疏卷第三十六

        唐清凉山大华严寺沙门澄观撰

第三发光地所以来者。前戒此定义次第故。又前三地寄同世间施戒修法前二施戒竟。今此显修故。深密云。前位能持微细戒品。未得圆满世间等持等至。及圆满闻法总持。为令得此因说此地。令勤修学。此则具前二意。言发光者。智论四十九名为光地。本论及金光明十住婆沙等。皆名明地。光之与明眼目殊称。皆略无发字。仁王名明慧。慧亦是明义旨皆同。今统收下经及诸经论。总有三义。立发光名。一以初住地十种净心为能发。胜定闻持为所发光。以安住地竟。方始闻法修得定故。故瑜伽四十八云。由闻行正法光明等持。光明之所显示故名发光地。由内心净能发光明。是故说名增上心住。既言由内心净能发明知以十净心为能发也。摄论金光明经意皆同此二以闻持为能发。胜定为所发。以闻法竟。静处修行方发定故。瑜伽亦说等持为光明故。此约地中释之。三以胜定总持。并为能发。彼四地证光明相。以为所发。故下论云。彼无生慧此名光明。依此光明故名明地。此约地满释。唯识亦云。成就胜定大法总持。能发无边妙慧光故。谓由得胜定发修慧光。由得总持教法发闻思光。彼无边慧即是三慧。故上本分论云。随闻思修照法显现。谓就此慧中。四地证法为所照。三慧光明为能照。三慧是彼证智光明之相。余诸经论言虽少异。并不出此故。十净心唯是能发。证光明相唯是所发。胜定一种通能所发。是以此地偏得增上心名。若所离障通约三慧故。本分论云。闇相于闻思修诸法忘障。唯识名闇钝障。谓所知障中俱生一分。令闻思修法忘失彼障三地胜定总持。及彼所发殊胜三慧。入三地时便能永断。由斯三地说断二愚及彼粗重。一欲贪愚。此障胜定及彼修慧。二圆满陀罗尼愚。此障闻思慧。及障彼圆满陀罗尼故。若约所证。唯就总持名证胜流真如。唯识云。谓此真如所流教法。于余教法极为胜故。梁摄论云。从真如流出正体智。正体智流出后得智。后得智流出大悲。大悲流出十二部经。名为胜流法界故。下经中。能舍身命求此善说。其所成行。亦唯禅及求法。其所得果。亦法及禅。梁摄论云。通达胜流法界。得无边法音果。金光明云。三地发心得难动三昧果。下文四无量五神通等。皆定所摄。次正释文总分三分。初赞请分。二正说分。三重颂分。今初六偈分二。前三庆前后三请后。前中初偈集经者序。后二偈发言赞能所说。于中善哉是总。第八句是结。别明能说有二前偈有慈后偈有悲。故云利益。所说亦二。前偈教相故云律仪。后偈证相故云微妙。真实者契理故。无异者千圣同辙故。无差别者理贯事故。后三请。后中二。初二偈大众请。前偈总请三地之法。谓如彼教法相应三智之业。后偈别请十度行法。以地地通有故。慈悲是愿道谓道力。佛清净行即无漏智。末后一偈上首请。第二正说分中。先明地行。后辨地果。前中四分。一起厌行分。二厌行分。三厌分。四厌果分。此地修禅厌伏烦恼。亦厌于禅故名厌地。设忻大法亦为厌故。正住地心住于八禅。故但名厌。初入地心观修彼行。名厌行分。趣地方便起彼厌行。地满心中得无量等。是厌之果。亦可初一是入心。余三是住心。今初分中有三。初结前起后。二何等下征列十心。三菩萨以是下。结行入位。初中标起云十种深心。论经云深念心。则异前二地。单云深心。谓更以十心念前十深心故。瑜伽云。若菩萨先于增上戒住已。得十种清净意乐。复由余十净心意乐作意思惟。成上品故。入增上心住。二征列中十心义分四对。初二一对根本建立。次三一对方便发修。次三一对修已成就。后二一对德用自在。此四对中皆前离过。后明成善。初言净心者离过也。论云依彼净深念心。谓依二地净心。起此趣地净心故。瑜伽云。一者作意思惟。我于十种净心意乐已得清净故。二安住心者。依不舍自乘及前十故。此二依前。故云根本建立。后八依前起后。次第二对方便发修者。论云志求胜法起善方便。三地胜定总持。名为胜法。于中前二句离过。一悬厌当欲。二离于现贪。后一造行进善。若不胜进则名为退。故异第二。若准瑜伽。所修对治不复退失。故下颂云不害。若失对治则有害故。第三对中。初一离过。谓自地烦恼不能坏。故名坚固心。自地即第二。以初十心未增。未入三地故。后二成善。初句体成。依等至八禅出入自在。故云明盛。后句用成。即依前句禅定自在力。虽生下地而不退失。故云勇猛。故下经云。于禅能出能入者。即明盛也。又云不随禅解脱力生者。是勇猛也。地满方成。今此作是思惟。即得入地故。瑜伽。十心。皆有作意思惟之言。第四对中。初句自行离过。依欲界生烦恼不能染故。论名快心。晋经名胜心。皆以有智故不染烦恼。今言广者。兼不乐陜小故。后句利他自在。依利众生不断诸有。故云大心。此广大二心。与前后有异。三结行入地。谓于前十心作意思惟。便入增上心住。第二佛子菩萨摩诃萨住第三下。厌行分中有三。一修行护烦恼行。以观有为可厌患故。二见如是下修行护小乘行。求一切智。深念众生舍陜劣心故。三菩萨如是厌离下。修行方便摄行。欲摄众生。不离无障碍智究竟方便等故。又此三段摄前三位。初及第二一半摄修行住。次护小乘陜心。下摄无恚恨行。以慈悲故。后段摄等一切佛回向。思惟佛智度众生故。今初二十句分二。初十观无常即知有为体性。后十观无救者即人彰过。今初分三。初显观时。谓住地已拣前趣入。次观一切下。总辨所观。言如实相者此有二义。一事实。谓无常等。二理实谓即不生等。今文具二。后所谓下别示其相。文有十句。初总余别。总云无常者。论云是中命行不住故。谓命行二字是所无常法。不住二字是无常义。相续名命迁流名行。命举于内行通内外。故下别中分出依正。别中九句。初五句。云何此无常。即前命行。后四句何者是无常。即前不住。初中有二义。一随事前三内报以显无常。后二外报以显无常。二据义。五句以苦等四观共显无常。初句即苦。论云依身转时力生三种苦故。谓三苦依三受。三受依触生故。依身转方能生苦。即是无常。二即不依饮食力。形色增损故。三不安隐者依不护诸恶力横夭寿等。四败坏者。依世界成。力成必灭故。五不久住者。此句依无我。谓资生依主无有定力。属于五家。非一处住不定。我所反显我无。后四何者是无常。然无常有二种。一者少时无常即刹那生灭。二自性不成实无常。谓三世缘生俱无自性故。不成实体。即下三句。一非从前际生者。过去已灭故。二非向后际去者。现在即灭。无容从现转至未来故。三非于现在住者。念念迁谢求其住相不可得故。约三世迁灭。求生等相皆不可得。即入不生不灭是无常义。此中三世约相续门。如因前身有今身等。若依生灭门。则应从未来藏流入现在。迁至过去。二门不同也。第二又观下明其无救。初句总显。言此法者即前无常。今又观之。不出生老病死。如四方山来无逃避处。无能救者。别有九句约生老病死。初四约死以显无救。此相显故所以先明。一无依者。于无常未至中无所依告救令不至。二与忧者无常既至无能救者。意地惧死所以怀忧。三与悲者。生阴转坏死相现前。于此中间弥增涕泗。四苦恼同住者。正舍寿时四大分散。在于五根苦恼事中。其力虚弱。更以忧悲随逐则忧苦转增。心生热恼。次二约资生事不知是苦。妄生乐想。对治不入故无救也。谓五追求资生境有顺违。故爱憎所系。六于受用时苦多乐少。云愁戚转多。谓受而不散众祸皆集。用而毁损如损身命。故曰苦多。七于身老时。盛年壮色不可救令停积。后二约病。初一病因。谓八于少壮时具乐等三受。故贪等常烧不容法水。炽然难救。九于年衰时众患所缠。如树将朽。日夜增长无能令免。然病通始终。老时多故论偏说老。老即病缘故。论云后三句皆明身患事也。何故不在初说。示身数数患事可卒加故。如幻不实总结前九。第二护小乘行有三十句。前十句护小心。后二十句护陜心。今初先总。后见佛下别。总中初结前。谓先观无常已厌有为。次观无救故倍增厌离。趣佛智慧明其生后正护小心求佛大智故。别中十句分二。前五摄功德大。即求佛菩提。后五清净大。即求涅槃果。菩提是德修成名摄。涅槃本有离障称净。此二无碍。菩提菩提断。俱名菩提。智相智性皆名佛智。今初。一神力摄功德大。智用不测故。二无比德学地无等故。上二妙用自在。三大义德。利他无量故。四无讥嫌德。自行难得故。五不同德外道无杂故。显上二利不同外道。无利勤苦。上三德行圆满。后五中义摄有三。谓离惑苦得涅槃故。一无恼者。即离惑习无明不杂故。二无忧者离苦。苦依根本亡故。忧悲随尽。三得涅槃有二义。一得体。谓无忧畏城。亦是无余涅槃。二得用。谓能建大事。亦无住涅槃。即后二句。不住生死故云不复退还。不住涅槃故能救无量苦难。由俱不住。方是世间涅槃胜事。以斯为业。则翻有为之业矣。第二菩萨如是见如来智下。护陜劣心有二十句。前十悲其沦溺。后十决志慈济。前中二。先牒前标后。谓见佛智胜利。伤物不得有为过患。愍物处之。此是牒前则起悲心是为生后。二何等下正显悲行。文有十句。初总余别。总由孤独无依故生哀愍。少而无父曰孤。老而无子曰独。今众生上远慈尊。又无方便下不利物。又阙善心。故云孤独。既孤且独何所依救。别有九种孤独无依。初二依欲求众生。一已得心无厌足。故贫穷无依。经云知足之人虽贫而富。不知足者虽富而贫。未必无财方曰贫也。二未得他财求无休息故。三毒火然此即多欲。多欲之人多求利故烦恼亦多。初求生贪不遂生嗔。非理为痴。次三依有求众生。一闭苦果狱。二集因覆障。三无观察道。由生八难不闻法故。由上三故安能得灭。后四依梵行求众生行。前三小乘。一行小因不求大因胜善之法。二保执小果不求菩提。为失佛法。当知此辈皆是增上慢人。三不得大般涅槃。长随变易生死。后一外道虽求解脱。以行邪故失于方便。又上总别十句。亦可通为五对。一无亲无财。二有惑有苦。三有障无治。四阙因失缘。五顺流背灭。第二菩萨如是下决志救度中。初结前生后。作是念不正显救心。文有十句。初总余别。别分为三。初三何处救度。谓三道中一脱业结。二净惑染。三度苦果。次五以何行度。谓授三学。初二正授。一着戒善处。二劝住定慧三昧地故。定慧合说。为四地已去方是慧地。此地定增故。慧是定中之慧耳。后三明授法利益。初二戒益。一将受戒者。令除疑生信。众生受佛戒便同大觉。固应欢喜。二已受者令知持犯。见其胜益安固不动。后一定慧益。灭除沉掉故云调伏。后一度果。云何救度成。令得有余无余涅槃故。上皆论意。更有一理授行五句中。初三是戒。初着戒处。次由持戒得心不悔。故云安住。后由不悔得心欢喜。次一授慧故云知见。后一授定故云调伏。然三学对于三道。有通有别。别则戒无业结。慧能断惑定度苦果为别。对前次故先说慧。然犹附论。若直就经文。对前十类生此十心。一救孤独故。二脱贫穷故。三净三毒故。四度有狱故。五着无覆障处露地坐故。六住善观察故。七得善法欲生欢喜故。八知见性相同佛法故。九调伏诸根不随流故。十应令涅槃得解脱方便故。论非无理。未若此顺经文。第三修行方便摄行。谓修摄生方便之行。故下经云。以何方便而能拔济。即知不离佛智等故。佛智等即是摄生之方便也。文分为四。一发起摄行之因。二作是思惟下。思求方便摄行。三便作是念下。思得摄生方便。四菩萨如是下依思修行。今初分二。先牒前二行以为三因。后欲依下。依前三因以明发起。今初。一如是厌离一切有为。是牒护烦恼行为离妄想因。二如是愍念一切众生。是牒护陜心为不舍一切世间因。三知一切智智有胜利益。是牒护小心为发精进因。谓既知佛智胜益。则修行彼道以趣入故。然三因之中初后是智。中一是悲。悲智为因能求方便。后发起者既思三因。欲将有益之智救可愍之众生。故说经者为此发起故。论云此言示现发起方便摄行故。第二思求方便者。亦只思前众生。堕有为惑业苦中。欲令永灭得大涅槃。未知方便故思求之。今经阙一业字。论经具有。问前决志救中。知授三学灭业惑苦。今何故言以何方便。答今但思其能授智慧耳。若尔前护小中。已知如来智慧有大势力。及上因中。云知一切智有胜利益。今何更思。答前知智胜欲令物得。今亦思其令得摄生方便。下乃知之。要自得佛智方令他得。第三思得摄生方便中。方便有五。自古皆将配位。论虽无文于理无失。言有五者。一佛无碍智。二八地如实觉。三四地无行慧。四三地禅定。五亦三地多闻。然此五中从微至着。则后后起于前前。故今观求逆寻其本展转相因。并云不离。此五之中多闻唯能起佛智。唯所起中间三种通能所起。论依此义摄五为三。一佛智穷尽果海。名证毕竟尽。二以中三皆有。下从他起上能起。他渐增至佛。故摄为一。名起上上证毕竟尽。三以闻慧为彼中间起行所依。名彼起依止行。以其闻慧未是证行。不得名起。而忘躯求闻亦得称行。已知大旨。次略释文。一佛智名无障碍解脱者。无二障故是离障解脱。具十智力权实无碍故。是作用解脱。此是究竟摄生方便。二此智要依如实觉者。八地得无生忍。觉一切法如实性故。若觉实性方能尽惑。于事理无碍故。佛智由起。论释一切法云。如来所说一切法者。因音声忍方得无生。寻于能诠悟所诠故。释如实觉云。随顺如实觉者。因于顺忍得无生故。三此觉不离无生慧者。欲觉一切法。一切法不出二种。一者自相。谓色心等殊。是有为法体故名为行。二者同相。色心虽殊同皆生住异灭所迁。举初摄后故。但名生。今四地菩萨了自及同。皆缘生无性成无分别慧。故云无行。无生下一行字是慧行相。以无行无生为慧行相。若如是行。则得八地觉法自性也。四此慧不离禅等者。谓此无生慧非定不发。言禅善巧者。得三地满胜进分禅故。出入自在亦不染禅。故名善巧。决定者。于他四地决能发也。观察智者。论云自智慧观故。谓即三地禅中之智。非前所发四地无生之慧。彼四地之慧。此中名光明。依此光明故名明地。故四地证慧。由三地禅中修慧而发。五此禅不离善巧多闻者。此中修慧由后闻慧方得起故。三节皆慧而慧不同。言善巧多闻者。不取闻相故。然佛智之因乃通十地。而偏举三者。此地闻修近所行故。四地是慧增之首故。八地无功用之初故。第四依思修行。上既逆推本由多闻。今则顺行。先求闻慧而起闻行。文中二。初结前标后。后日夜下正起求行。于中分二。先明求法行。后菩萨如是下明求行因。今初文有十句。闻法者无慢心故。二喜法者无妒心故。三乐法者。无折伏他心问义故。此三约听闻时。四依大乘教自见正取不忘失故。此拣求小不名善故。自见正取者不由他悟故。五随自读诵故。六为他解说故。七顺所闻法静处思义故。此三约已得法自他利时。八到法者。依定修行到究竟故。九住出世间智故。十顺佛解脱行故。上之后三皆约修行。然后二拣不同世间之行。若望后厌分正修此十。皆是闻慧。若望依思而行此十。皆名为行。于中初日夜常闻。以显勤行喜法等九。显正修行。又此十句。若约所受唯教与义。闻约教成修依于义。思通教义。第二求行因中二。初常勤求因。二菩萨如是下正修行因。以前十句有此二故。今初论云彼常勤行以何为因。示现恭敬重法毕竟尽故。于中分六。一总明轻财重法。二是故菩萨下双舍内外。三无有恭敬下内财敬事。谓心则恭敬舍慢。身则承事忘苦。四若闻一句下。况舍外财。五若闻一偈下轻位重法。人天王位终是无常。句偈教义法王为果。一句一偈。约闻教法净菩萨行。约闻义法。六若有人言下甘苦重法。以一句之法能尽苦源。地狱多劫诚可甘也。二正修行因中。初结前。后如其下正显因相。谓静处思惟正观。为修行之因也。然论经但云正观无修行字。故是思慧为修行因。若顺今经。此一段文乃是后文标举耳。大文第三此菩萨得闻法下。明厌分者。前明闻思。今显修慧。即五种方便中。第四禅善巧决定观察智也。论云云何厌分。是菩萨闻诸法已。知如说行乃得佛法入禅。无色无量神通彼非乐处。于中不染必定应作故。谓不乐不染即是厌义。其无量神通是厌之果。皆修行力乘便举来。经文七相。一依何修。二云何修。三何处修。四何故修。五何时修。六何所修。七何为修。束此七相大为三段。初四修行。次二证入后一入意。今初。此菩萨得闻法已。即依何修。以依正法故。即了相作意。次摄心安住。即云何修。摄散住法是修相故。即摄乐作意。次于空闲处。即何处修。空闲通于事理。则无处非修即远离作意。次作是思下即何故修。要必修行方证得故。即胜解作意。然口言者通于说听故。瑜伽云。非但听闻文字音声而得清净也。瑜伽三十三明修行八定皆有七种作意。一了相作意。谓了欣厌相故。二胜解作意。谓正是修行。三远离作意。谓与断道俱。四摄乐作意。谓少分触证喜乐。五观察作意。谓重观试练。六加行究竟作意。谓心得离系。七加行究竟果作意。谓无间证入。上修行中已摄其四。前修行因中有观察作意。后二作意在证入中。七中前五通贯八定。下八定中各有后二故。此总修下亦总发。然皆即妄即真圆融自在。又任运而发不同欣厌故。下论云三昧地故。得不退禅。不退即无漏定也。又释内净云。修无漏不断三昧故。故知一一皆同鸟迹。第二佛子是菩萨下。证入中分二。初结前。即何时修证。谓在三昧地时是修行时。正修行竟是证入时。论经云。住此明地因如说行故。今经阙如说行言。若但云住地。岂初安住即得此禅。但前已有修行之言故今略耳。后即离下即何所修。修何所证谓证八定。八定之义广如别章。略以四门分别。一入意。二释名。三体性。四释文。即当辨相。今初下。经云但随顺法故。行而无所染着。论云。以何义故入禅。无色无量神通为五种众生故。一为禅乐憍慢众生故入诸禅。谓得世禅恃以生慢。二为无色解脱憍慢众生故入无色定。谓外道证此以为涅槃。恃以生慢。菩萨示入八禅。一一过彼故摄伏之。三为苦恼众生入慈悲无量。令安善处永与乐故入慈无量。应解彼苦令不受故入悲无量。四为得解脱众住。故入喜舍无量。谓喜其所得自离动乱故。五为邪归依众生故入胜神通力。令正信故又示入禅定示定寂静。超欲等过令物仿故。善自调练知纯熟故。寄位次第法应尔故。尚不同二乘自为。岂与凡外而同年。然无量神通即是厌果。论主并举者。欲显皆为顺法故。云何顺法。为顺菩萨大悲化生法故。二释名者。先通后别。通中先释四禅。禅那西音此云静虑。静谓寂静虑谓审虑。故瑜伽三十三云。于一所缘系念寂静。而审思虑故名静虑。是以静能断结虑能正观。诸无色定有静无虑。虽能断结不能正观。欲界等持有虑无静。虽能正观不能断结。故唯色界独受斯称。次无色定者。婆沙百四十一云。此四地中。超过一切有色法故。违害一切有色法故。色法于彼无容生故。俱舍云。无色谓无色。若大众部及化地部。亦许有色细故名无。俱舍论中广破有色。次释别名者。初四禅者。一有寻有伺静虑。二无寻无伺静虑。三离喜静虑。四离乐静虑。俱舍定品云。初具伺喜乐。后渐离前支即斯义也。无色别名至文当释。三体性者。婆沙云。四静虑有二种。一修得。俱舍论云是善性摄心一境性。以善等持为自性故。若兼助伴五蕴为性。二生得随地所系。五蕴为性。皆有色者定共戒故。无色体性。但除于色余义同前。故俱舍云无色亦如是。四蕴离下地。大乘宗中亦无异辙。若会相归性。则八定支林一切皆空。若事尽理现皆如来藏。泯绝无寄则定乱两亡。若事理圆融一即一切。第四释文。初明四禅后说四空。四禅之中虽支有多少。论主并勒为四。一离障二对治。三利益四彼二依止三昧。四中后三是支初一非支。虽后后所离是前前支。望于当地并皆非支。然四禅通说有十八支。谓初三各五。二四皆四。为欲恶难除。第二禅喜深难拔故。初三各五。初三不然故二四唯四。其间除重则唯有十。谓一觉二观。此唯初禅。三舍四念。此通后二。五喜局于前两。六乐该于前三。七者一心遍于诸地。八内净唯二。九正知唯三。十舍受唯四。若分二乐则有十一。若内净无别体。则唯有九。此等皆为顺益于禅故。立支名故。瑜伽十一云。诸静虑中。虽有余法然此胜故。于修定者为恩重故。偏立为支。今初初禅一即离欲恶不善法者。此明离障。以一即离贯于下三。然诸论说大同小异。若毗昙离五欲故名为离欲。断十恶故名为离恶。除五盖故名离不善法。若智论八十八云。离欲者。谓离五欲恶不善法。谓离五盖。五盖将人入恶道故名恶。障善法故名不善法。若辨盖欲之相。广如智论十九。及瑜伽十一。杂集第八。断欲恚害恚即是恶害即不善法。瑜伽三十三亦合恶不善法。彼论云。离欲者欲有二种。一烦恼欲。二事欲。离亦有二。一相应离二境界离。言离恶不善法者。烦恼欲因所生种种恶不善法。即身口恶行。此意则总弃欲界诸恶不善。已明离障。二有觉有观者。此有二支。是修行对治。新译名寻伺。皆初粗后细。俱舍云。寻伺心粗细。智论云譬如振铃。粗声喻觉细声喻观。瑜伽十一。以寻求伺察不净慈悲。治欲界欲恚害障。又五盖中。有欲恚害不死亲里国土等觉。今对恶觉起善觉察。又智论四十四云。小乘以欲恚恼觉为粗。亲里国土等觉为细。又唯善觉为细。于摩诃衍准皆粗则觉空为细。三离生喜乐者。是修行利益。庆离欲恶等是故生喜。身心猗息及得解脱之乐。故名为乐。由此名利益支。瑜伽三十三云。离者已得加行究竟作意故。所言生者。由此为因为缘无间生故。已获加行究竟果作意故。喜乐者。谓已获得所希义。故得大轻安。身心调畅有堪能故。四住初禅者。是彼二依止三昧。谓于所缘审正观察。心一境性。为彼对治及利益支之所依止。依止定力寻等转故。其所离障以无行体。非是支故不为彼依。而言初者。欲界上进此最初故。而言住者即安住义。瑜伽云。安住者。谓于后时由所修习多成办故。得随所乐得无艰难。乃至七日七夜能正安住四禅。此句大旨不殊。第二禅中。一灭觉观是所离障。觉观粗动发生三识。乱于二禅。如净水波动则无所见故。初禅能治为此所治。则病尽药亡。二内净一心无觉无观者。是修行对治。言内净者。小乘是信能净心相离外散动定等内流。大乘即揽三禅三支以成故。显扬十九瑜伽六十三。皆云内净。以舍念正知为体。以此三法尚为喜覆。力用未胜但能离外寻伺。故合名内净。言一心者释于内义。唯缘法尘不同初禅有三识故。故身子阿毗昙云。欲界地中心行六处。初禅地中心行四处。谓无鼻舌识。二禅已上心行一处。唯意识身缘法尘故。无觉无观释于净义。不同初禅有觉观故。前灭觉观显于所治。此复言无显能治无故非重也。本论释一心云。修无漏不断三昧行一境故。欲异世间是如实修故。不断者相续一心。行一境者对缘一心。由此即名三昧无漏。三定生喜乐。此二支是修行利益。初禅庆背欲恶故名离生。今庆觉观心息故名定生。如净鉴止水故身心适悦。若智论意。即从初禅定生。欲界无定故。初但云离二禅。虽离初禅烦恼。初禅有定故。又初禅离欲大障故。四住第二禅。即彼二依止三昧。第三禅中。一离喜者是所离障。谓二禅利益支。喜心分别想生动乱。三禅转寂故须除遣。如贫人得宝生喜失则深忧。莫若双绝喜忧。方为快乐。二住舍有念正知三支。是修行对治。一住舍者。即是舍数拣非舍受故。诸经论皆名行舍。行心调停舍彼喜过。故显扬云住舍者。于己生喜不忍可故。平等正直无动安住。二有念者。于喜不行中不忘明记故。三正知者。或时失念喜行。于此分别正知而住。谓住于舍。瑜伽三十三大同于此。上三即前内净渐修转胜。至此别开深细寂静故。能治下地喜踊浮动。三身受乐下是利益支。于中初身受乐。正显支体。正对二禅喜心浮动。是故但言身受于乐。设心受乐亦名身受。故瑜伽云。由舍念正知数修习故。令心踊跃。俱行喜受便得除灭。离喜寂静最极寂静。与喜相违心受生起。彼于尔时色身意身领纳受乐及轻安乐。是故说言有身受乐。又初禅喜乐。如土石山顶而有池水。二禅喜乐如纯土山顶而有池水。三禅之乐。如纯土山在大池。内乐遍身外身在乐中。是故心乐亦名身受。次诸圣所说能舍有念受乐者。释成胜义。谓下诸地。无如是乐及无间舍。上地有舍而复无乐故。诸佛及佛弟子说第三禅。具有能舍及念正知。而复受乐故。诸乐中三禅乐胜。此瑜伽意。不应别解。文中略牒尚阙正知。但有舍念已殊上下。四住第三禅。即彼二依止三昧。第四禅中。一断乐先除苦喜忧灭者。即是离障。三禅胜乐于此为害。如重病人。观妙音乐为障四禅故。须除遣故云断乐。得此定者。即于尔时所有苦乐。皆得超越故。总集说先除苦等。先之一字总贯下三。二禅先除苦受。三禅先灭喜受。初禅先灭忧受。并今断乐则已灭四受。依禅次第应先明忧。为对前乐先言除苦。瑜伽十一云。何故苦根初禅未断。答彼品粗重犹未断故。若尔何不现行。答由其助伴相对忧根所摄诸苦彼已断故。若初静虑已断苦根。是则行者。入初静虑及第二时。受所作住差别应无。由二俱有喜及乐故。此意明不断粗重故。异二禅而无现行。故立乐支。若依小乘。初二禅之乐。但是轻安而非乐受。三是乐受故不同也。二不苦不乐者。是利益支。余禅皆先明治。今此先明益者。乘前总无四受。便举不苦不乐明五受。内唯有于舍。是不动故。若尔前来亦灭忧喜。此何不言不忧不喜。答五受明义无别不忧不喜。三受明义。苦乐摄于忧喜故但对之。又此正断于乐故宜对之。三舍念清净。此二是对治支。三禅舍念与乐受俱。此断乐受故云清净。然其能治大同三禅。但所治喜乐故分二别。喜心浮动常须正知。乐受深细但须舍念。若远显清净者。瑜伽云。从初静虑一切下地灾患已断。谓寻伺喜乐入息出息。是故此中舍念清净鲜白。由是此禅心住无动。此论略举六事。应兼无苦及忧故。俱舍等。明此禅中离八灾患。然四禅虽曰不动。而犹有舍受。未名无受。瑜伽十一云。又无相者。经中说为无相心定。于此定中舍根永灭。若非无相乃至有顶。皆有舍受。四住第四禅。即彼二依止三昧。然入上色定。其身相状如处室中。入下四空如处虚空。第二四空空处等。名同心一境性。有何差别。俱舍定品显此差别。由离下地染故立四名。谓离第四禅。立空无边处。离空无边处立识无边处等。差别既尔。从何得名。彼次颂云。空无边等三名从加行。立非想非非想昧劣故立名。谓修定前起加行位厌坏色故。作胜解想思无边空。加行成时名空无边处。厌空想识厌识想无所有。准此可知。其第四空由想昧劣。谓无下地明慧胜想得非想名。有昧劣想名非非想。故前三无色加行受名。第四无色当体受称。以前三近分加行位中。唯缘空等。入根本位。亦缘余蕴故。从加行受名。第四非想加行根本。同一所缘故。当体受称。瑜伽论中亦同于此。加行等想空识等殊。至文当辨。然此四空亦各有四。谓离障等。而经文中。但各三句义含于四。谓初段离障具对治义。问若有治等为有支不。答准杂集等论。诸无色奢摩他一味相故无有皮分建立。若依璎珞本业。四无色定各有五支。谓想护止观一心。经论相违云何会通。论依相似不同四禅觉观等异。又慧用劣名无支分。经就相似同皆有五。如初空定厌下色相。起于空想。即今对治护彼色相。令不现前。若超色想即名为止。是今离障空无边行。照了分明即是观义。是今利益一心。即是彼二所依故。五支显然。岂得判无违经依论。今初空处。谓观虚空作无边行相。能灭色想。心安空定。名空无边处。文中三句。初句含二义。一明离障。二明对治。言离障者。曲有三句。谓离三有对等色。论云。超一切色想者。过眼识相。此明超可见有对。二灭有对想者。耳鼻舌身识和合想灭故。此灭不可见有对。三不念种种想者。不念意识和合想故。意识分别一切法故说名种种。此灭不可见无对。意识虽缘非色之境。今但取缘色自有种种。皆云想者。小乘以在色欲修起此定。未舍色形故不言灭色。但言灭想想取色相。故偏灭之。大乘之中决唯灭想。若超色相说无色者。后灭空识应无识空。问香味之想初禅已离。色声触想二禅已除。今云何言空定灭耶。远公答云。香味二想虽尽初禅。今云灭者治有四种。一坏对治。谓方便道观下有漏无常等故。二断对治。谓无碍道正断下过。三持对治。谓解脱道为首。及后一切无间解脱持彼无为。不令失坏。四远分对治。谓解脱为首。及后一切无碍解脱。远令前障毕竟不起今此空定据第四治色声触三。云二禅虽灭者。二禅已上乃至四禅。当地虽无得借。初禅三识之心见闻觉触。是故乃至第四犹有此想空定灭之。此上所释约次第修。若于色界顿修空定。则六识行境并皆得灭。故论上言意缘一切法亦无拣故

已明离障云何对治。前三句中不念之言。含于对治。谓不分别色等境故。何以不念见无我故。约菩萨实治故云无我。若依有漏但厌苦粗。以为加行。顺正理云。谓若有法虽与色俱。而其自体不依属色。诸有于色求出离者。必应最初思惟彼法。谓虚空体虽与色俱。而待色无方得显了。外法所摄其相无边。思惟彼时而能离色。此即加行之相也。二入无边虚空者。是修行利益。谓三色想绝。则入空理廓尔无边故。三住虚空无边处者。是彼二依止三昧。瑜伽云。由已超过近分加行究竟作意。入上根本加行究竟果作意定。是故说言空无边处具足安住。准瑜伽意。四义之中离障是超下地对治。是加行究竟作意利益。是胜解作意。彼二依止。是加行究竟果作意。前三为近分后一是根本。后之三定一同于此。又此四义初何所超。次云何能超。三超前何缘。四超何所证。二识无边处。心缘内识作无边行相。故以为名。初超虚空无边处。是明离障。彼何所障外念为粗故。云何对治。见彼外念粗分别过患故。二入无边识。是修行利益。前明舍外今辨缘内。正理云。谓于纯净六识身能了知中。善取相已安住胜解。由假想力。思惟观察无边识想。由此加行。为先得入根本。后依止可知。三无所有处者。即内外皆无也。初超无边识是明离障。何过须超。事念粗故。云何对治。见粗念事分别过患。次入无少所有者。修行利益。前以舍外缘内故为粗。念既无所取能取亦无。故内外俱无。斯为利益。正理云。见前无边行相粗动起此加行。是故此处名最胜舍。以于此中不复乐作无边行相。心于所缘舍诸所有。寂然而住。瑜伽云。从识处上进时离其识。外更求余境都无所得。此意明识既为粗。识外复无故无所有后住无所有处。是彼二依止。四非想中。无下七地明了之想。有昧劣想故以为名。超一切无所有处。是所离障。云何对治。无彼无所有以见粗念分别过患。故为能治。既寂无所有云何名粗。犹有无所有想故经阙一句论经则具。彼云知非有想非无想安隐即修行利益。即入非有想非无想处行。是二依止。瑜伽云。先入无所有处定。超过一切有所有想。今复超过无所有想。故言非想。又言非无想者。非如无想及灭尽定。一切诸想皆悉灭尽。唯有微细想。缘无想境转故。即于此处起胜解。则超近分而入根本。此中所以不出三界者。由缘无相境。即是细想。外道不了谓为涅槃。未能无缘岂离心境。况计此为我复生爱味故。法华喻头上火然。若知此患更求上进。求上进时求上所缘。竟无所得。无所得故灭而不转。则得灭受想定也。若未得此定厌想为先。后想不行即入无想定。然婆沙百四十一。显扬第三及诸论皆明。而文言浩博。上引二论文略义显。今更约第一义修略示四空。谓观色即空心安于空。是空处定。次知空色不出于心。是识处定。次心境两亡为无所有。次亦亡无所有想。缘无想住名非想非非想。若不缘此无想。则诸漏永寂。第三入意但顺化众生法不同凡小有爱味等。如前已释。大文第四佛子此菩萨心随下。明其厌果。即前八定之所等引。故名为果。文分为三。初四无量即行方便果。次五神通即行功用果。三此菩萨于诸禅下总结自在。今初所以先明者。凡夫味定三界轮回。二乘上升多皆趣灭。菩萨因定发生慈悲。广利有情成菩萨性。然入之所以前论已辨。为对生死涅槃分四为二。准瑜伽等。四种无量为四有情。谓缘求乐众生兴慈。有苦兴悲有喜随喜。有惑不染。复应此四通缘一切。以智导之则无所著。此四皆缘无量境。故名四无量。若总相说。皆以定慧而为其体。若别明之。慈即与乐无嗔为体。拔苦不害庆他不嫉。自他舍惑即是善舍。文中二。初别显慈行。后住悲下类显余三。初中有十二句。心随于慈。此句为总。随有二义。一心不趣寂动皆合慈。二以此慈心随逐于物如犊逐母。次十句别。慈之种类总有其三。初有七句八义。众生缘慈。次一法缘后二无缘。缘谓缘念。初缘假者欲与其乐。次缘人空。但有蕴等善恶行法。以用教化。后缘众生体空。欲令悟入。初一通凡次一通小。后一唯大。今初八义曲复有四。初四与乐正显行相。广者与欲界乐。欲境广多故。大者与同喜乐。谓初二禅喜受俱。故高出名大。无量者与不同喜乐。三禅已上离苦离喜故。深故名无量。不二者三乐平等与故。上皆论意更有一理。广则无乐不与。大谓菩提涅槃。无量谓穷来际。不二者无一不与故。次二治障。不爱之冤亦与其乐。故无怨障。是爱之亲亦与其乐。非是偏情故无对碍。中人无爱不爱故非障也。次一清净。谓无身心不调五盖等障。是行清净慈。后一摄界慈定。起于色界正果。慈之余势起欲界习果。皆无苦恼之事。故修慈经说修慈。有十五利。谓卧安觉安。天护人护。眠无恶梦寤常欢喜。水不能漂火不能烧。刀不能伤毒不能害。常生善处镇受快乐。正报梵世残报人王。远果作佛皆慈之果。然此中有多种果。初现报果。常生下后报果正报梵世望上。生报望下正报。残报人王即是习果。又初七用果。水不漂等是增上果。常生下异熟果。残报等流果。作佛是离系果。修一慈心。三报不断五果俱圆。无费一毫而功报无极。幸诸后学思而修之。次遍至一切处即法缘慈。横遍十方竖通三界。彼中所有一切诸法。皆能缘念。然法有二种。一缘圣凡五蕴之法。二者众生所有分别。作业之法。此即所化差别故。涅槃云。缘利众生法名为法缘。后二句无缘者。无缘有二。一自体无缘。竖穷法空云尽法界。二遍至无缘。显空无分齐。横尽虚空。末句。云遍一切世间者。总结上慈成无量义也。类三可知

大方广佛华严经疏卷第三十六大方广佛华严经疏卷第三十七

        唐清凉山大华严寺沙门澄观撰

第二佛子下得五神通。明行功用果。前内怀慈济之心。此外现救生之用。从多分说但为邪归。妙用难测曰神自在无拥曰通。文中有五。一神境。二天耳。三他心。四宿住。五天眼。寄同世间故但得五。外色内身皆神之境。转变多种偏受神名。亦名神足。依欲勤心观之所成。故亦名如意。随意成故余名易了。若语其体。通是慧数别则前四是智。后一是见见亦是智。照了分明顺眼义。故偏立见名。余处天眼居神境。次者显自修者。先成自根胜用。次知他心。后知往业故。今约利他三业故。天眼居末。初一身业到化机所。次二口业。天耳闻佛说法闻众方言。以他心智随种种言音。皆尽知已。将前所闻之法。随其方言之异。复宜用何言之异而授与之后。二意业。宿住知其过去是何界种。天眼见其未来远近成益。随应化之。余如十通品辨。今初身通文二。初总明。后能动下别显。总中云得者总修总得。若准瑜伽三十三。得四静虑竟。各各别修皆有假想。则别修别得。既寄位次第别亦无违。然通依四禅多依第四。后别中得三种自在。一世间自在动大地故。二以一身下身自在。三石壁下作业自在。第二天耳通。初总标其体。谓天耳清净。清净有二义。一离欲界法。得静虑。引生清净大种所造故。二离于障碍审谛闻故。由此故云过于人耳。悉闻下显用释过人义。远细皆知故。第三他心通中三。初总知他心者。通于王所。次所谓下别。后菩萨如是下结。别中二十六心行相各异。然除小等四心。余皆障治间明。善恶对显。总摄为九。一以初六心明随烦恼。谓随缘现起烦恼相应。故名为随。非约小惑名随。言有贪者。于可爱所缘贪缠所缠故离贪者远离如是贪缠故。下四例知。即三不善根及三善根。以为能治。论今但以能治亦因烦恼而来。故皆名随烦恼。下使亦然。二有烦恼等二心。明使即是随眠。三小等四心名生约无记。报心人心。小欲天广色天。大无色二解脱无量。以作空识无边行相故。上二不尔故非无量。而论不明上二空处。意明无所有及昧劣故。或是略非略摄之。四有四心学三昧行。略者谓由止行。于内所缘系缚其心故。非略者。太沉昧故。或不一所缘故。散者太举。于五妙欲境随顺流散故。非散者。于妙所缘明了显现故。前二约定。后二约慧。定等均者则名等持。论经合之为二。名摄不摄。故论以散不散释之。五有二心明得三昧定者。正入根本定故。不定者。未入及起时故。六有二心明得解脱。有缚无缚故。七有二心。余凡夫增上慢即前类之。余以得四禅谓为四果。即粗习行名上无。此即细习行名无上。八有二心妄行正行。论经名求不求。心希求名闻即是杂染。反此非染。九有二心。大乘得失悲智兼济为广。随阙非广。论阙此二。上之九类不出三种。初二烦恼。次一是苦。余皆是业。业有善恶耳。亦即四谛开解脱为灭。善业为道故。皆如实知者。审于事实见理实故。亦非心外见法。亦非无境可知。若自他相绝。则与众生心同一体。故无心外也。不坏能所故能知也。又他心是总余皆是别。六相圆融一乘之实知也。第四宿住智通。初总标谁能念即宿住之智。次所谓下别显。后如是过去下总结。别中初念何等事。谓一生乃至多劫中事。此显念时分。次我曾下云何念。即念相差别也。念彼因中名字不同姓。谓父母家姓如迦叶等种族即刹利等贵贱余可知。第五天眼通。论名生死智通。约根约境异故。初总显能见。谁能见天眼故。清净者审见故。过人者远见故。次见诸下别显所见。初见生死本有之果随业之因。若彼众生下云何见别。见因果不同。如二地摄善戒中辨。菩萨下结。第三此菩萨下总结自在。近结厌果远结前厌。于何自在即前禅等。禅谓四禅。三昧者。四无量慈等三昧故。三摩钵底者。论云五神通。此应译者之误。合云三摩呬多。以此云等引。五通即所引故。三摩钵底此云等至。非神通故。云何自在智能入出。则散动不能缚。即生心时。随心用现在前故。大悲方便不随受生。则定不能缚。若不随禅生当何所生。不拣净秽但能满菩提分。处即生其中。论主从胜及自利说。谓诸佛菩萨共生一处。是能满处。以愿力者非业系生故。第二位果。三果即为三别。初调柔果中三。初调柔行体。二此菩萨于四摄下。别地行相。三佛子是名下结说地相。前中有法喻合。法中三。初练行缘。二悉以下明能练行。三见缚下明所练净。二中先福行。次回向行。后修智行。言观一切法不生不灭者。即法性观。于清净法中不见增故。不生烦恼妄想中不见减故不灭。因缘而有。此有二义。一者。成上由净法从缘生。故无可增。妄法从缘灭故无可减。二约不坏相故虽体不生灭不碍生灭依对治因缘。离烦恼妄想故灭。转胜清净般若现前故生。以一切法不生般若生。故知一切法不灭。妄想灭故。以此该后则见缚等灭。是不灭之灭也。又以此三地世间满故。于禅定中为此实观。生起后地无生行慧。亦即善巧决定观察智也。三所练净中先明断惑。后拣细异粗。前中五缚即五住烦恼。若合色有即是四缚。缚众生故。亦名四流。见缚先灭者。初地见道已断分别惑故。一切欲等者。论云。一切修道中三缚及彼因。同无明习气皆悉微薄。谓烦恼障三缚现行及种。故云彼因。与当地所知障种同灭。故云同无明习气。习气即种义。瑜伽四十八云。舍欲贪故无欲缚。弃舍静虑等持故断有缚。后于无量下拣细异粗。谓是断细。以多劫不积三不善根故。细种渐断善根转净。言多劫者。仁王经说初地经四阿僧祇劫。二地五三地六。细障难断经劫转多。多劫不积故邪贪等断。然但断细习非是断粗。粗障见道初地已断粗障。修者。二地已断故。善根转净即前信等。喻言秤两不减者。厌离世间胜于前地信等。入于厌火故自在不失减也。三合中二。先正合前行净。后此菩萨下别显忍净。此地忍增故偏明之。有十三心。初二句为总。一他加恶辱能忍受故。二善护他心。谓他人陵我以刚强我则骋之。以柔和故。下诸句别释此二。初有二心分别。善护他心。一谐顺心者。以他于菩萨作恶疑菩萨。嗔恨菩萨现同伴侣与之谐和。二悦美者爱语诲诱。次以三心分别。加恶忍受谓身加恶而不嗔。口毁辱而不动心。嫉害而忧恼不能浊。以万顷之陂方其量故。次有三心出上二因。无高下者。过去久离憍慢故。不自高举轻下于彼。由此能柔和护他。后二即加恶不改之因。一不望报恩故。益他被辱而忍受。二受恩常念小恩大报故。众生于我有恩法尔应忍。后三心显上二心。离障虽柔顺护他而非谄。实为利益故。不诳心无隐覆谄佞故无譣诐。譣诐者谄佞也。余皆可知。二菩萨住此下摄报果。此下诸地摄报。文皆分二。初上胜身。后能以下上胜果果中。一自分行。二复作是念下胜进行。第三重颂。十八颂分五。初一颂起厌行分。二有十二颂颂厌行分。于中初二护烦恼行。次三护小乘行。后七方便摄行。三一颂厌分及果四三颂颂位果。五一颂结说三地竟(从此已下入第三十六经)第四焰慧地。所以来者瑜伽七十八引解深密。明四种清净能摄诸地。前三即意乐戒定增上三清净讫。此下第四讫于佛地。明慧增上故次来也。又慧有多种。四地正明觉分相应增上慧住。故次来也。又前地虽得世定总持。而未能得菩提分法。舍于定爱及与法爱。今修证彼行故次来也。若依本论。前三寄世间今此出世。次第故来。若近望前地。因前定闻发此证智。故次来也。故论云。依彼净三昧。闻持如实智净。显示故。言焰慧者。法喻双举。亦有三义。一约初入地释。初入证智。能烧前地解法慢薪故。本分云。不忘烦恼薪智火能烧故。二约地中释。成唯识云。安住最胜菩提分法。烧烦恼薪慧焰增故。由住第四地竟方修菩提分法。明是地中若唯取此而为慧者。未修道品应非焰地。以此地正明菩提分法。中该初后诸论多依此释。摄论云。由诸菩提分法。焚烧一切障故。障即二障。庄严论云。以菩提分慧为焰自性。以惑智二障为薪自性。此地菩萨。能起焰慧烧二障薪。名焰慧地。瑜伽七十八。引深密经大同此说。彼云。所得菩提分法。能烧烦恼智火如焰。金光明经显扬论不殊此意。三约地满。从证智摩尼放阿含光。故名为焰。下论具之。然所烧烦恼即所离微细烦恼现行障。谓所知障中俱生一分。亦摄定爱法爱。菩提分法特违于彼。故能烧之。由斯四地说断二愚及彼粗重。一等至爱愚味八定故。二法爱愚即解法慢。今得无漏定及无漏教。故违于彼。由此证得无摄受真如。谓此真如无所系属。非我执等所依取故。得此真如宁有定法之爱。便能成菩提分行及不住道行精进不退。由达无摄受真如。便得摄生之果。次正释文。文亦三分。一赞请。二正说。三重颂。今初六偈分二。初二偈半集经者序述。地海动者表无明厚地。大爱海水可倾竭故。后三偈半正明赞请。于中初二偈半天王请。后一众首请。第二正说分中二。初明地相。后明地果。前中论为四分。一清净对治修行增长因分。谓清净等。是次二分今趣地方便为彼之因。二佛子菩萨住此焰慧下清净分。是初入地出障行故。三佛子菩萨住此第四下。对治修行增长分。即正住地行道品等行。能有所除故云对治。进习上上名修行增长。四佛子至所有身见下彼果分。此即地满。是中二分之果。又此四分即加行无间解脱胜进四道。又四中初一入心。后三住心。出心在调柔果。住心中三分摄前三位。初清净分即摄生贵住。次摄至一切处回向。后摄无尽行。至文当知。今初因分文三。初结前标后。次何等下征列别名。三菩萨以此下结行入位。今初十法明门者。门即通入之义。故论经名入。明为能入之门。法为所入之处。故论云得证地智光明依彼智明。入如来所说法中。言证地智者。即四地证智也。光明者即三地慧光。谓三地中得此四地证智前相。故并举二处之智。以释于明。亦犹地前明得定也。故前地论云。彼慧此中名光明。即其义也。言所说法者。前求多闻从佛闻说众生法界等。十种之法。便以智光游入数数游入。游入即是修行。修行即下观察。观察增上极圆满故。方得证入四地。二征列中有十种差别。观察此十。略以三重释之。一初句为总。本为众生故。余九为别皆众生事故。二前八为染后二为净。三前五推能依至所依。后五依所依立能依。前中一观众生假名差别。假有三种。一因成假。二相续假。三相待假。假为空诠故先观之因成有二。一五蕴和合假名某甲。则入众生空。二阴亦因缘而有。则入法空。二空所显即是真如。不坏假名。空有不二。即是中道。言相续者。由前阴灭后阴续生。念念相续假而非实。亦入二空真实。言相待者。待非众生以说众生。入实亦然。此一推假入实余九例知。故论但显差别之相。二法界者。论当第三是依正之因。即染法界。此从别义。若净法界通为十依。则十与法界究竟无别。三世界者。彼假名众生所住依报。四依正所依虚空。瑜伽名为平等胜义。即是理空皆无尽故。五染净所依是本识界后五依此所依。立后能依故。此识界前后两向。向前为依正依。向后为染净依初三句。由烦恼使染成染分依他。有三界差别着欲着受及着想故。三界唯心故。后二广大信解成净分依他。论经前是胜心信解依。烦恼不染与声闻同。后大心信解依。不舍众生不同声闻。今经即前云广。则明护陜兼济之心。后是大心。即是护小求大菩提。则二心俱异二乘。前观众生同体大悲。后观众生具佛知见。誓令同得。又皆言界者通事理也。事即曲尽差别。理则一一入实。即净法界故皆为明门。三结行入位。观察圆满与十理冥。则入四地。故瑜伽四十八云。先于增上心住。以求多闻增上力故。已得十法明入。由此十法明入成上品故。极圆满故。入初增上慧住。大文第二清净分。即摄生贵住故前文云。于诸佛圣教中生。云何清净。于如来家转有势力故。文中三。初总明。次何等下征释。三是为十者总结。初中文有三句。末句生家是总相。初句十智为能生因。次句内法为所生家。由以十智观察下。诸行等十法得成熟故。成熟则除灭三地解法智障。摄四地出世胜智。契于法体故云得彼内法。内法者显非外相。此法即如来所说教化之法。名如来家。此地寄出世之首。故名为生。然如来家略有三种。一菩提心家。初住即生。二大教家四住即生。三法界家。初地证故生。今此摄四住。故以智契教法合于法界。具下十义故名为生。若瑜伽但云长如来家。论经亦但云于如来家转有势力。意明初地已生家。二三地起修方便。早有势力。今依三地多闻成出世智。故云转有。此中智契。即无行无生行慧光。二征列中列有十句。论摄为四。初句自住处毕竟智。谓大乘是菩萨自所住处。深心相应为住。毕竟即是不退。二同敬三宝毕竟智。谓证三宝同体成不坏信故。上二约行德差别初自分后胜进故。下有二智约智解差别。初证后教。谓三有二句明真如智。谓见第一义证二无我故。一但有蕴等诸行。而生灭流转故无人我。二即此蕴等诸法本来不生。故无法我。四余六句明分别说智。谓是教智故名为说。知世谛故名为分别。分别染净故。谓初二句是染。后三句是净。第三句具染净。各有因果即是四谛故。谓初二句名随烦恼。染即是苦谛依正二报。随烦恼集因所生故。谓初句依报。次句正报故云有生。同因于业业与烦恼二俱集因。故论与经影略而说。第三句中初观生死。论经名世间即烦恼染。上句以因显果。云因业有生。此句以果显因。故云生死。生死以烦恼为体故。即是集谛。此顺论意。次观涅槃是所有净即是灭谛若直就经文。亦可因业有生是集谛。生死涅槃复双观苦灭耳。后三句随所净即是道谛。随顺前灭故。三中初一利他行。论云。诸佛世界中教化众生。自业成熟故。准此论意译。此初句应言观诸国土化众生业。则不滥前因业有生。后二句自利行。谓观烦恼染及涅槃净。为顺灭之道。初句约事观烦恼无始故为前际。涅槃无终故为后际。后句顺理观烦恼本空无有损减。故无可尽。涅槃性净非新增益。自性尽故皆名无所有尽。烦恼影取生死。涅槃影取菩提。菩提之智亦符理故。然是世谛中观故。与前如智。又后二句即本有今无偈意。亦是观缘起法。无明行为前际。生老死为后际。无明灭行灭。自性灭故名无所有尽。如六地中。自下大文第三对治修行增长分中二。初护烦恼行。后菩萨修行。如是下明护小乘行。前是大智自利异凡。后是大悲利他异小。此二相导成不住道。无所不至。故摄至一切处回向也。今初即修菩提分法。论主别有道品论故此不释。今略为四门。一释名。菩提是觉分是因义。此三十七为诸乘觉因故。亦云道品。品即是类。因为果类故。别名至文自显。二显同异。瑜伽四十四。大乘菩提分乃有多种。三十七品。乃是其中别义。通于大小。涅槃亦说三十七品。为涅槃因。非大涅槃因。无量阿僧祇道品为大涅槃因故。下五地中说无量道品。及离世间品说道及助道。皆名无量。今约寄位故但三十七耳。若准智论。但三十七无所不摄。即无量道品亦在其中。如分别四谛有无量相。但心行大小不同。净名云。道品是道场。是法。身因。大集名菩萨宝炬陀罗尼。涅槃云。若人能观八正道。即见佛性名得醍醐。皆约大说。三明体性。虽三十七品。但以十法而为根本。谓信戒念精进定慧除喜舍思惟。由信二戒三。念开为四。精进定慧此三各八。余四各一。故成三十七品。复束此十以三蕴为体。谓戒是无表色。喜支是受余皆行蕴。五类法中但二为体。谓色及心所。若取助伴则通五蕴。若取所缘通一切法。广显差别如智论二十一二。及五十三。瑜伽二十八九。及四十五。杂集第十。下所解释依此诸论。四正释文。即是行相三十七品。总有七类。一对治颠倒道即四念处。二断诸懈怠道。谓四正勤。三引发神通道。谓四神足。四现观方便道。所谓五根。五亲近现观道即是五力。六现观自体道。谓七觉分。七现观后起道。谓八正道。此七次者。若闻法已先当念持。次即勤修。勤故摄心调柔。调柔故信等成根。根增为力。次七觉分别。八正正行。有时八正在前。则未办名道已办名觉。然上犹寄位。若约行者初心通修。况入地菩萨。今初对治颠倒道。名四念处。四谓身受心法。念谓念慧。身等为其念慧所安住处。故亦名念住。瑜伽云。若于此住即是身等。若由此住即是念慧。体实是慧。以慧观守境由念。得住与念相近邻近名念。杂集云。一切菩提分法。皆由五门而得建立。一所缘。二自体。三助伴。四修习。五修果。文或略无义必须具。今初念处身等是所缘。念慧为自体。循身观等为修习。破四颠倒趣入四谛。身等离系以为其果。此身等四前三即三蕴。而合想行为法念者。为明我所依事我受用事。我自体事我染净事故。要此四者治四倒故。谓观身不净治于净倒。观受是苦观心无常。观法无我治三可知。此次第者。从粗至细教对治故。智论云。此身既尔。不净众生贪者。以其情尘生诸受故。计之为乐。谁受此乐。故次观心念念生灭。后观二蕴皆不自在。破此四倒行四正行。开实相门。若尔说四倒中。何以常乐我净而为其次。此约先重后轻为次第故。然此四处。皆容各起四倒从多计说。各语其一。然观不净等通于大小。瑜伽四十五云。菩萨于声闻道品。如实了知。如声闻地。云何大乘如实了知。谓胜义修及世俗修。世俗修者。即观不净等。然不计实。胜义修者谓离相性。大集般若等。皆性相双观。智论亦尔。乃至不念身受心法。无行经云。观身毕竟空。观受内外空。观心无所有。观法但有名。此约如实。然有二意。一则法性湛然常乐我净。即遣无常等倒。二此入法空俱遣八倒。胜鬘亦说四念能除八倒。既除八倒则成八行。涅槃双树四双八只。四枯四荣正表于此。大品明以一切种修四念处。云何一切种修。应观此身之色法性缘生故。一色一切色缘生即空故。一切色一色。法性中故。非一非一切。双照一一切亦非色非不色。双照色不色身念既尔。余三亦然。云何枯荣表此念处。谓法性之色。实非是净。凡夫计净是名颠倒。实非不净。二乘计不净。是名颠倒。今观色种即空。一切即空。空中无净云何染着。则凡净倒破枯念处成。色种不坏假名。则一切皆假分别名相。不可尽极。假智常净。云何滞空而取灰断。言色不净。是名二乘不净倒。破荣念处成。是以八倒俱破枯荣双立。观色本际非空非假。则一切非空非假。非空故非不净倒。非假故非净倒。既非二边乃名中道。佛会此理。故于中间而般涅槃。余三类此。是则对治法药其数有四。法性观智名之为念。一谛三谛名之为处。一切即空诸倒枯荣。无不空寂。一切即假二边双树。无不成立。一切即中无非法界。只一念心广远若此。故深观念处即坐道场。更不须余。机宜不同故说余品。一科既尔深奥。余六仿此可知。下文之中但略释相。说者有力一一开示。今经但云观身。不言净不净等。从通相说显包含故。文中二。初别观身念。后如是下类显余三。今初观身自有内等三观。此三智论瑜伽广显其相。今略举一两。瑜伽云。内自有情色为内身。外非情色为外身。他有情数为内外身。初即自身我爱爱故。次即资具等我所爱故。后即眷属妻子。彼我我爱我所爱故。智论二十八亦广明此。五十三又云。自身名内他身名外。而不明内外。取下释意但合前二。故云内外。所以有此三者。破三种邪行故。有人着内情多舍妻财。以全身。有着外情多贪财丧驱为妻舍命。有二俱着。破此三邪成三正行。此约三人对治各别。若约一人起观始终。谓先观自身求净等不可得。或当外有。次便观外复不可得。便生疑云。我观内时于外或错。观外之时于内或错。次内外俱观亦不可得。初二是别后一是总。以斯二释明知。但合前二为内外身。今初观内身。初标别所缘。次循身观者总显修相。智论云。寻随观察知其不净等。然循有二义。一寻义。五种不净遍寻求故。二随义。谓虽冥目了见身之影像。随顺本质相似性故。前标内身即是本质。今云循身即是影像。此杂集意。次勤勇念知显修之仪。以贪等世事无始恶习。离之甚难。过于世间慈父离于孝子。故须精进方能除遣。勤即欲勤策励。勇谓勇猛不息。念则明记不忘。知则决断无悔。又心若驰散当念老病死苦。三恶道苦。身命无常佛法欲灭。名为念知。则能鞭心令复本观。便生勤勇。具上诸义则不放逸。次言除世间贪忧者。即观之果有所离故。观身不净本为治贪行者。既离五欲世乐未得定乐。或时生忧。如鱼乐水常求乐事。还念本欲多生此二。故偏遣之。又贪为五盖之首。贪除则五盖尽去。如破竹初节忧。于五受之中。偏能障定。如灭恶贼先除巨害。故偏说之。其不净等广如二论。如实观相已如上说。次观外身及内外身。所观小异观相大同。后例余三念处者。准瑜伽意。依前内等三身生受心法。故受心法随所依生。亦有内等。智论之意大同于此。论问云。于四念中心唯是内。受法唯外。身通内外。云何于四皆有内等。答受有二种。一身二心。心受名内身受名外。又意识相应受名内。五识相应受名外等。心虽是内缘外法故名外。五识一向是外。又定心为内散心为外。法虽是外。缘内法心数法名内。缘外法心数法。及无为心不相应行是外。后三念处。亦合前二以为内外。余如二论。其循历观相如先总说。第二正勤者。四念智火若得勤风。则无所不烧。故次辨之。精进为其自体。故总名勤。拣非九十五种相违之勤。故名为正。虽是一勤随义分四。前二勤断二恶。是止恶行。后二勤修二善。是作善行。二善二恶皆所缘境。前中未生之恶遏令不生。已生之恶断令不续。后二未生善令生。已生令广。亦名四正断。后二是修而言断者。善是断处。正修断者断懈怠故。故瑜伽云。一律仪断二者断断。三修习断。四防护断。然其善恶有通有别。别正取前念处观中懈怠。五盖等。以为不善。其能对治为所生善。约大乘说。勤观法性。除实相之外皆名为恶。就一一勤中文皆有四。今初一未生不善法此举所缘。二为不生故明修观意。三欲生者起希愿心。是修习依止。即增上意乐圆满。四勤精进下正显修习。即加行圆满勤精进者。常自策励发心。正断者。谓策心持心。余三处文例此可知。若二恶不生弃舍二善得生增广。是正勤果。第三四神足者。以勤过散乱智火微弱故。须定制则所欲自在。神即神通足即是定。瑜伽云。如有足者能往能还。腾跃勇健能得能证世间胜法。世殊胜法。说名为神。彼能到此故名神足。此举喻也。由出世法最胜自在。是最胜神。欲等四定能证此。故名为神足。亦名如意足。所欲如心故。神足所缘即种种变事。神足自体即三摩地。欲勤心观皆是助伴。欲谓猛利乐欲。勤谓精进无间。心即是定。谓专心守境观即是慧。由闻教法内自拣择。由欲增上力证心一境性。名为欲定。余三亦然。勤观心性名为上定。皆从加行受名。此四加行。即前正勤中。欲生勤精进发心正断等。以发心中持心能生心定。持太举故。策心能生观定策太沉故。是以随一念处有四正勤。随一正勤有四神足。文中先别明欲定。后修行精进下通显余三。今初言修行欲定者。标举所修助伴自体。断行二字总显修相。亦修之果。云何修相此复二种。一修习欲定。能断现行诸惑缠故。二为欲永害所有随眠。修八断行。谓欲勤信安念正知思及舍。云何亦果。若将断行属下成就。则断行成就。亦神足果。次成就神足。唯是彼果。后依止厌下复显修相。兼辨所缘。准杂集论。五根已下方缘四谛为境。七觉已下方有依止厌等。以为修相。今经神足。即缘四谛而修。谓缘苦修必依厌苦。若缘集修必依离欲。若缘灭修必求证灭。若缘道修必趣灭苦之行。能舍于苦。缘此境时必求修习。故云回向。亦是加行等四道。下文依止厌等并同此释。第四五根现观方便道。增上名根。五根自体即信等五。此五通于生起出世间法。而为增上。前四复能起后得增上名。而信为上首。能起余四。文中先别明信根。后通显余四。二段中各先标举所修。后依止等别显修相。下之三科例此可知。今此所修。即于谛实深忍乐欲。余四即于前所信策勤而行。明记不忘系缘一境。拣择是非。余如前说。然始入佛法即有信心。未有定慧不得名根。今由前三科。则信不可拔。此中念即念处中念。进即正勤定则神足。慧即缘四谛慧。前三至此总得名根。若依位者。在于见道之前。则以速发现观而为其果。今在四地。即应以发后地为果。第五五力。即前五根增长。魔梵惑等不能屈伏故名为力。又能损减不信等障。故复名力。智论云。能破烦恼得无生忍故名为力。第六七觉。觉谓觉了。若依位说。即现观自性如实觉慧。觉法自性。觉支自体即念等。七文中亦二。先别明念觉。后通显余六。然七觉分七皆自体。而差别者觉为自体。余六皆觉之分。谓念是所依支。由系念故。令诸善法皆不忘失。择法是自体支觉自相故。精进是出离支。由此势力能到所到故。喜是利益支。由心勇悦身调适故。猗定舍三是不染污支。猗即轻安。由此不染污故。谓由安故能除粗重。定者依此不染污故。谓依止定得转依故。舍者体是不染污故。谓行舍平等永除贪忧。不染污位为自性故。总收七觉不出三品。念通定慧。次三是慧。后三定摄。虽是前三至此增故。依位所明能断见惑。以为其果。又虽一刹那七法俱起。而随行相各说功能。念除妄念。择除不正知。余除懈怠惛沈粗重散乱掉举。上约通说。大乘七觉不念诸法故。决择不可得故。离进怠相故。绝忧喜故。除安心缘皆叵得故。性定之中无定乱故。亦不见于能所舍故。第七八正。若依位说。即现观后起道。为断修道诸烦恼故。离八邪故名为八正。开通涅槃故名为道。亦云八圣道。圣者道故。八正自体即正见等。文中亦先别明正见。后通显余七。言正见者。是分别支。依前所证真实拣择故。正思惟者。是诲示他支。如其所证方便安立。思惟名义发语言故。次三是令他信支。谓正语者。善依所证问答决择令他信。有见清净故。正业者。身业进止正行具足令他信。有戒清净故。正命者。如法乞求依圣种住。离五邪命令他信。有命清净故。正精进者。是净烦恼障支。由此永断一切结故。正念者。是净随烦恼支。由不忘失正止举相。永不容受沉掉等故。正定者。是能净最胜功德障支。由此引发神通等无量胜功德故。若能如上分别诲示等。即是道支之果。然其八中。语业命三是戒蕴摄。念定是定余三是慧。定慧大同诸品。但增胜耳。戒则前来未有觉支。虽有定共律仪无表相微。此中正行故新建立。此寄位说。若依此经离世间品。八正是菩萨道。一者正见远离邪见。乃至第八正定善巧方便。于一三昧。出生菩萨不可思议法。一切三昧则与前说旨趣悬殊。上之七类总以喻显。法性如大地。念处如种子。正勤为种植。神足如抽芽。五根如生根。五力如茎叶增长。开七觉华结八正果。第二护小乘行中十句。初总余别。总中如是功德指前道品。为不舍众生。正明护义。不同二乘之独善故。别中具有悲智已出于小。况以此导。前九句为四。一始。二益。三希。四行。前三护小心。后一护小行。一始者大愿为起行之本故。二慈悲益物。上二护陜心。三思念种智为希。此护小也。四行中有五句。前四自利。初二求果。一修净土行求佛依报。二修起佛法行。求佛十力等正报之法。后二求因。三求彼地方便无厌足行。谓五六七地故云上上胜道。四修入不退转地行。即八地已上觉法自性顺佛解脱也。后一利他即教化众生行。必须善巧

大方广佛华严经疏卷第三十七大方广佛华严经疏卷第三十八

        唐清凉山大华严寺沙门澄观撰

大文第四彼果分中。即摄无尽行。离障成德穷尽生界。为利乐故。果有二种。一离障果从护烦恼生。二成德果从护小乘生。前中又二。一烦恼染生远离果。此离惑障。二业染生远离果。此离业障。皆言生者。烦恼染等犹如生食。今是寄位出世之首。能离彼生。今初离惑先举所离。后于如是下结成能离。就所离中所起执着出没。是此总相。余皆是别。总中执着是前地中解法慢也。论云。我知大知者。我知谓执我能知。大知谓执所知大法。出没者。是前地中正受慢也。出者三昧起义故。谓修起彼定。没者三昧灭义故。谓定所除。今计我能修此定。此定即我所修故。论云。我修我所修。已释总句别有五种。一本。二起。三行。四护。五过。本即所有身见至蕴界处。于中身见为总。我等为别。别中我人等四为人我慢。蕴界处三是法我慢。而云本者有二义故。一以此我。为解法正受二慢之本。二者身见复为二我。及六十二见之本。有此差别。此中身见。若约实位。准唯识论。此地断第六识中。俱生身见及所起过。由得出世道品治故。以分别起者初地断故。是以瑜伽名为微细萨迦耶见。若约寄位。准仁王经四地名须陀洹位。以寄出世之首故。则亦得断分别身见。二思惟者明起。谓不正思惟而起慢故。三观察者明行。谓心行缘中多观所得。若法若定求觅胜相。令他知故。四治故下三句明护治者。数数观察修治所见我所者。起于我想取彼胜相。属我己故。财物者。如畜财者。受用护持故。以上三事防护自己所得。五着处者明过谓心坚安处法定二事故。五中前三起慢方便后二随助慢心。上总及显相正是所起。后结离中。由得道品正助方便无不离也。第二此菩萨下明离业染。上修道品正离烦恼。烦恼既去业亦随亡。亡不善业而修善业。文中先亡恶后进善。恶有二义故不应作。一佛所不赞者。尊敬佛故不为。二烦恼染者。畏恶名故不作。恶名则违利生道故。进善有二义反此可知。又不作烦恼所染。异凡夫业作。顺菩萨道业则异二乘。第二成德果中有四。一于胜功德生增上心欲果。二彼说法尊中起报恩果。三彼方便行中发勤精进果。四彼增上欲本心界满足果。此之四果。前三从前生后一复从此三果生。前中初二护小心果。后一护小行果。前中初果者。由本欲上求下救。今更为物转转上求。故云增上。文中二初牒前修因。后如是而得下显所得果。今初即牒前护小乘中总句也。随所起方便慧者。牒前不舍一切众生故。不舍众生而修道品。是有方便则道品慧解。修习于道及助道者。即前修习如是功德也。道即四地证智。助道即菩提分法。二显所得果有十句。初总余别。总云润泽者。深欲爱敬故。谓由修二道自有所润。深欲敬上。由为物修润及含生深欲爱。下别中九句释彼润泽。有三种胜。一柔软心者。明乐行胜。谓证法适神故。二调顺者。调和善顺缘中无碍。是三昧自在胜。上二是行体。三利益下七句。明离过对治胜。此是行用。于中初句总利他无过故。利益自利无过故。安乐下六句随过别显。若不寄对难显性净之德。六句即离六过。经中皆是能治。一无杂染心。治为利于食过。及为名妒心过。二治少欲功德过。三治不求胜智过。上三皆自利。四治懈怠不摄众生过。上四皆离于行生过。后二离于教生过。谓五治自见取不遵胜教过。六治舍为首不随说行过。如说修行。于闻思中最为其首。今舍彼首所以为过。又上救生即前悲果。求殊胜智即上求果。第二此菩萨下说法尊中起报恩心果。谓前地中从佛闻法。是说法尊。今起传法修行之心。则为以报诸佛恩也。上希求种智由知佛有恩故。今思报亦上求果。文中先别明。后总结。今初十句。初总余别。总云知恩者。谓若随顺师教行报恩行。方是知恩故。别中彼行有九种。类摄为七。一知报恩者。依尊起报恩心。尊即是佛。此为恩主故偏名报恩。二有二句。依同法起报恩心。此名顺同行善友意。三质直柔软二句。依法起行。谓随顺受教不违师命。故云质直。发修行事逢苦能忍。故云柔软。四无稠林行者。依受用衣食。于施主所自过不覆故。五虽实有德而不高慢。六善受教诲得师言诠。七于教不倒得师意旨。上七品中。初二依人。次三依行。后二依教。所依虽异皆同报恩。二此菩萨如是下总结。谓十句不出此三忍。即心极和善。同住安乐。调柔即质直。柔软寂灭即通结余句。第三如是忍调柔下。发勤精进果。谓行二利行勤无怠故。于前不舍众生护小行中。修勤故名方便行。中正是无尽行相。文中二。先牒其得时。后得不休下正显。于中十句初总余别别有九种不休息义。一不杂染者。彼精进行平等流注故。杂染者。共懈怠共染故。染则着而太过。懈则堕而不及。若琴弦之急缓若不进不怠为平等流。二不退自乘。上二自利三起广念利他之心。四为无边众生作利益愿。起摄取行。上二利他上皆自分。下四胜进。谓五炽然者常志顺行。犹如炽火上进叵灭。论经名光明兼照他地。六修习过余。七魔惑莫坏。上三自利。八摄取众生即是利他上八皆行。后一是解。谓九自断疑惑。决是非故。能伏他言如无畏故。若能具此为正修习。第四是菩萨下。彼增上欲本心界满足果。菩提分心是本心界。正念真如修上道品。故云满足由精进故。故瑜伽四十八蹑前精进。后即云由此因缘。所有意乐增上意乐。胜解界性。皆得圆满。故知此果从前二果生。谓意乐即第一果。增上意乐即第二果。胜解界性即此心界。谓由第三精进令前二果增长。故云满足。文中十句初总余别。别有九种。一深心不失者。彼道品心修行增益故。此一自分下皆胜进。二于五地已上胜上证中。明鉴决断故。三即彼上证因。谓对治善根治行过前。故云增长。四除灭所治烦恼障垢。五断除此地中秘密疑事。即是智障。微细法慢为秘密疑事。由无摄受则能除之。上二除内障。六触境明断。七依胜乐行三昧适神。八上依佛力化众生故。九论云。依现无量。三昧心智障清净故。此除定中智障。若直就经文。总显本愿皆得成就。第二位果中亦三。初调柔中四。一调柔行。二如摩尼下明教智净。三此菩萨下别地行相。四佛子下总结地相。初中三。一练行缘。二皆恭敬下明能练行。三又更下明所练净。二中一供佛福行。二以此下回向大行。三于彼下听法慧行。于中先在家。后复于下出家。然登地已上具十法界身。若出若在何啻不可。然随义隐显有无前却。以前三地寄同世间。还依世法。初二人王故有。三地天王故无。四地已上寄出世之首。故重明有。表心出家。故于调柔行中明之。欲顺天无。出家不于摄报中辩。六地已上表证法平等。无出无在故皆无出家。三所练净中有法喻合。金庄严具者。以三地阿含金。现作此四地证智严具故。余所有金者。即未作严具之金。二教智净者。以此地成就证净。从体起用故偏有此文。前以教成证故。喻金为严具。今从证起教故喻摩尼放光。摩尼宝珠即证智体。无垢名净寂照名光。圆满名轮。具上三义故称证智。言能放光明者。即放阿含光也。谓以此际智。证入无量教法门义故。故能照光明即是证智。所照教法以为智处。证能普照示现于教。得教光明。依证起焰故地名焰慧。非余宝下对前显胜。风等不坏对他彰坚。余并如前第三重颂有十七颂分三。初十二颂颂位行。次四颂位果。后一显名结说。前中四。初一颂增长因分。次二颂清净分。三有四颂颂修行增长分。于中初初颂护烦恼。后二颂护小乘。四有五颂颂修行增长果。余并可知。第五难胜地。所以来者。略有四义。一约寄位。四五六地寄出世间。前寄初果。此寄罗汉义次第故。虽有四果。举于始终以摄中间。此依本论约所观行相。以后六地既观缘起。寄同缘觉故。但二地寄于声闻。仁王下卷。璎珞上卷。约人配位。以七地未离分段故。四五六七寄同声闻。二前明觉分相应慧。今辨诸谛相应慧故。三前得出世未能顺世。今能五明摄化。故次明之。四前得三十七菩提分。今辨方便所摄菩提。故此后三意出于瑜伽。言难胜者。解深密云。即由于彼菩提分法。方便修习最极艰难。名极难胜。此从初说故。初分经云。善修菩提分法故等。摄大乘云。由真谛智与世间智。更互相违。合此难合令相应故。唯识同此。世亲释云。由此地中知真谛智是无分别。知世间工巧等智是有分别此二相违应修令合。能合难合令相应。故名极难胜。此通初中后。瑜伽云。今此地中。显示菩萨于诸圣谛。决定妙智极难可胜。名难胜地。唯约地中。庄严论云。于此五地有二种难。一劝化无恼难。二生不从心无恼难。此地菩萨。能退二难于难得胜。此多约地满。显扬论云。证得极净缘谛所知。诸微妙慧成极难成。不住流转。寂静圣道名极难胜。此大同本分。上诸经论多举难胜之法。未知何等无能胜耶。十住论云。功德力成。一切诸魔不能坏故。此对人显胜。亦兼于惑烦恼魔故。然诸经论言异意同。皆辨真俗无碍。若据实位。约仁王经。初地菩萨四天王即双照二谛平等道。今约寄位。前寄出世此方却入。故云无碍。故此地中断于下乘般涅槃障者。即前四地出世。厌生死苦乐趣涅槃。此障五地。今入真俗无差别道。便能断之。此断欣厌即是二愚。由此证得类无差别真如一约生死涅槃皆平等故。其所成行亦成二种。谓诸谛增上慧行。五明处教化行。此二无碍故得无差别。法身之果皆义旨相顺。次正释文文亦三分。初赞请分中九颂半分二。初八颂半供赞。后一颂请说。前中三。初一菩萨供赞。次一天王众。余皆天女。于中三。初一偈标。次四偈半赞。于中初二偈美感应。皆言久者。佛应由机机难有故。大海动者。动佛智海竭苦海故。后二偈半赞具德。初偈具智断。次半具恩。后一具此三德是故应供。三一偈结赞及请并可知。第二正说分中。先明位行。后辨位果。前中论分为三。初胜慢对治。二佛子菩萨摩诃萨如实知下。不住道行胜。三佛子菩萨摩诃萨住此下明彼果胜。初即加行道。及初住地无间道。次即正住地解脱道。后即地满胜进道。初言胜慢者。慢有二种。一他地慢。谓四地中得出世智。取其胜相名为胜慢。今以十种净心为治。二自地慢。谓于此十心希求胜相。从以为慢。以随顺如道为洎此二通名胜慢故。此一分有其二道。论云。胜慢对治者。谓十平等深净心者。前段能治也。又云。同念不退转心者。后段能治也。言同念者。即后总句。顺如与如同一念故。不退转者。即后段末句略举初后。以该中间前地治解法慢。此治身净分别慢。所治有殊不滥前地。言身净者。得出世智不染身故。文中二。先治他地慢。后佛子菩萨摩诃萨住此下。治自地慢。前中三。初结前举后。二征起正显三结能入地。今初平等有二义。一是如理。二是因果净法。千圣同规名深净心。是此地观解故。论云。于平等中心得清净故。此复何异后地观察十平等法。此有三异。一此地治前于净起慢故。偏明净法平等。后地对此依真入俗。通观染净诸法皆悉平等。二此约举等理以显心净。后地举观察以入等理。三此通理事二等。后地一向约理融二谛故。此皆地地背相舍后渐胜故。二正显中十心分二。初三明诸佛法。论云。谓三世力等者。即果位十力等也。后七明随顺诸佛法二利因行顺成果故。于中前六自利。后一利他。前中合为三学。初戒次定余四慧故。离为七净。一戒净。二定净。三见净。四度疑净。见疑相显。经合一句为成十故。五道非道净。此前五净大小名同小乘。六名行净。七行断净。以彼宗中趣尽灭故。今大乘六名行断。经云修行知见。略无断字。七名思量菩提分法上上净。以依行断起胜求故。若约位者。初二在见道前。以创背凡。过宜以戒防。欲生真慧理须习定。然未合理判属世间。次三在见道。以见道中断身见故。断疑故断戒取故。戒取是非道。知无漏慧是正道。入见道时十使俱断。偏言三者。涅槃经说此三重故。又十使中五见及疑。但障见道。余四通于见修故略不言。就其六中三本三随。偏语其本。边见随身见。邪见随疑。见取随戒取故。断三结三随亦断但立三净。上五大小并同。小乘行净在修道。起断行故。行断在无学道。依行证断故。大乘后二皆在修道。断障成德故有二也。行实同时。若约位分。七地已还为行断。修道断结故。八地已上入法流中顺菩提故。名思量上上余文易了。第二明如道行。又顺经意前明入心。从此已下皆明住心。应分为三。此摄方便具足住。修行十心是方便义。不退转者即是住义。二不住道行胜摄离痴乱行。智清净等无痴乱故。三彼果胜摄无尽功德藏回向摄德无尽故。今且顺论此明如道行。于中三。初标分位为显随如。已入五地。次以善下总显。后愿力下别明。总中四句。皆是正修诸行故总名顺如。谓前二句为所治。即四地修菩提分。以前十心。能善清净得入五地。于此净心希求胜相。即复是慢慢在文外故。以后二句而为能治。初句转求不住道行胜为能治。谓不住净心而起诸行。即治住净慢故。后句虽起诸行。不退失前平等深净之心。则能随顺真如平等。即如故。后别明中显上随如之行。有其八种经有九句。前七各一。后二为一。八中前二是起行心。一自利愿即修菩提心。二利他慈即不疲倦心。后六是行谓三得善根力。四不舍众行。五善巧修行。六无厌足故照明上上。七得他胜力。八自得胜力。此有二句。初句具三慧念。是闻思智即修慧。后句胜进究竟。上六行中前三自分。后三胜进。各有初中后思之。第二不住道行胜有二种观。一所知法中智清净胜。二佛子至得如是诸谛下。利益众生勤方便胜。初即自利护烦恼行故。不住世间。后即利他护小乘行。不住涅槃同时相导。名不住道。今初智胜分二。先明四谛实法分别。后善知俗下。复就此四明十观门化生差别。此乃十种观于四谛。非谓观十四谛也。故瑜伽住品云。此地于四圣谛由十行相。如实了知。今初言实法者。有佛无佛苦集二谛体是妄想杂染因果。灭道二谛体是出世清净因果。此约谛实义释。若约审谛释者。前二无佛不能知此是苦是集。宁有后二灭道因果。余如本品。后十观中略启四门。一制立谓四谛义含法界。菩萨穷照无遗。随智异说难穷。略举十明无尽。然十皆菩萨自智。智相难明故。论约化生以明其异。以此通名所知法中智清净也。二明开合。此十总唯是一化生分别。若随所化大小分二。前九化小后一化大故。若随化所起则分为三。前五生解次四起行。后一令证故。约人不同离以为七。初为根未熟。乃至七为大乘可化故。至文当知。三对实法以明通别。此十望前四谛。前五通观四谛。谓一世俗者。观四谛法相。二观其性空。三通观性相无碍。四观性相各异。五观此四缘起集成。次四别观四谛。谓六七八九如次观苦集灭道。后一但观灭道。菩萨地因证佛智故。远公后五亦通观四谛。谓迷于四谛故为苦集。悟其四谛故成灭道。后一穷四谛缘起实性清净法界。成大乘道。亦有此理。四正释文文分为二。初列十名。后此菩萨下次第解释。于中略为二解。一依瑜伽。二依本论。今初瑜伽十句不显文词。而略所说义阙。其第十知菩萨地而亦有十句。文有三节。初三名为此说。谓是所为故。一依晓悟他故知俗谛。二依自内智知第一义。三依俱处所故知相谛。谓自相是俗共相是真。二体不分故名俱处。次今经两句。彼应有三名。由此说谓由三藏教之所说故。故云依于契经调伏本母名。由此说。经中分位差别应是调伏。知蕴界处义当本母。此中第十义当契经。三有四句名如此说。谓如四谛相各别知故。即依于现在众苦自性故知事谛。依于未来苦生因性。依于因尽彼尽无生性。依于修习彼断方便性。如次可知。二依本论者。摄十为七。初一为根未熟众生。谓未堪入大为说四谛十六行等。名知世谛。即四重二谛中。第三重内俗也。不同瑜伽通于大小及根生熟。二为根熟堪入大故。为说法空第一义谛。三为疑惑众生故知相谛。谓有闻第一义谛。犹豫不决。若是空耶则无因果。若是有耶云何言空。今明即俗自相是空。共相俱处无违。故名相谛。四为谬解迷惑深法众生故知差别。谓前缘二境故名为疑。今闻俱处便谓是一。名为谬解。今明体虽不异性相分位历然差别。五为离正念众生故知成立谛。谓既闻差别。谓皆有体名离正念。今明差别但是缘成无有自性。故云成立。随言显示故。论经名说成谛。六为正见众生知事等四谛。由无前疑执故名正见。可令知苦断集证灭修道。事即苦谛生即集因。无生是灭因亡曰尽。即尽智也。后果不起名为无生。即无生智也。若小乘说。现在惑亡说名为尽。利根之人保彼烦恼。当更不起名曰无生。此尽无生是其灭体。无学之智如是而知。意在取灭故为灭谛道。言无二者。论下重释云一行故。谓称灭而知故云一行。前列实法四谛明其所观。此中四谛明当如是观。七为大乘可化众生故。知菩萨地乃至如来智谛。谓先住大乘化令进故。言正觉一切相者。大乘要须于五明处善巧知故。菩萨地是因。言次第相续者。如从初地入二地。乃至十地入佛地大果也。以信解等者。为释外疑。六地已上乃至佛智。未曾证入彼云何知。故此释云。信解镜像观智力知非成就。智镜像即影像观。未得本质故第二利益众生勤方便胜中二。先总起悲观。二佛子下别起悲观。总中三。初结前。次如实下观过。后菩萨下起悲于观过中。先明非真。后诳惑下对人彰过。今初虚妄二字观内五蕴。谓妄想常等不相似无故虚。此明所取非真理无。不同情有故云不相似无也常作我想慢事故妄。此辨能取不实。非有计有常乐我净。皆名我想。非唯我见。我为本故独云我想也。诈伪二字观外六尘。世法牵取愚夫故诈。此显能取迷真。谓由妄取令彼世法隐虚诈实。使其贪取也。世法尽坏故伪。此明所取不实。世法相似相续似有义利。而实速灭无利故伪。后对人彰过者。上虚伪二境引心。总名为诳。妄诈二心迷境皆名为惑。论云。常等相。无非有似有故。虚事中意正取者。此解虚是诳义。谓令意正取故是诳也。又云。我想慢事正取故。妄事是患。此解妄是惑义。世法利尽故。诳事牵心。此解伪是诳义。世法愚痴凡夫牵取故。诈事相现。此解诈是惑义。愚夫即是依彼正取我慢之人。三起慈悲者怜愍故。悲胜利益故。慈不住道行胜故云转增。皆言大者胜前地故。云光明者。救生方便智成故。转增光明。俱通慈悲。文有影略。转前慈愍分同诸佛。故名为生。第二别起悲观中二。先明化生愿。二如实观下明化他心。今初先牒前得是智力。近牒观有为远牒观诸谛。不舍众生牒前慈悲。后常求佛智正明起愿。愿救众生义故。二化心中二。先明大悲观。后佛子菩萨摩诃萨复作是念。此诸众生下。明大慈观。前中悲有二相。一如实观苦因缘集故。即知苦体性。二佛子至复作是念此诸凡夫下。观深重苦。人而多故即就人彰过。前中四。初总标二际。二知从下顺观二际。三虚妄下逆观二际。四若有下结如实知。今初前即过去后即未来。显无始终流转相故。二顺观中二。先明前际。后如前下类显后际。前中复二。先显缘集苦聚。后无我下显二空无我。今初无明有爱显流转因。能发能润此二为本故。生即是果故。涅槃云生死本际凡有二种。一者无明二者有爱。是二中间有生老死。今菩萨观此而起大悲亦同净名从痴有爱即我病生矣。然生果有三。一欲求众生故流转生死。欲贪即是受身本故。二妄梵行求众生故。于蕴宅不能动出。外道计我常住其中故。三有求众生故增长苦聚。三有皆苦故。后显空无我。及类显后际。并显可知。三逆观中顺即苦集。逆即道灭。虚妄断尽即是灭也。出离是道。四结如实知。即双结二际逆顺有无三义。一约凡夫。但有苦集而无灭道。二约菩萨顺有逆无。三双约凡圣。真灭本有道亦符之。妄苦本空集亦同尔。凡夫迷故不觉不知。菩萨正了名知如实。第二观深重苦者。无始随逐故深。种种苦事故重。文中二。初总标可愍。不知本空故名愚痴。不知厌离故云无智。亦可俱通故为可愍。二有无数下释可愍所由。由迷二苦故初明深苦。不知故为可愍。后如是尽下明重苦不知。故为可愍于中二。初牒前诃后。二转更下正明重苦。于中三。初观生苦。机关苦事即是生苦。言机关者。显无我故。抽之则动息手便无。若造业因生生不息。随生死下明有集爱。于诸蕴下明离灭道。二不知下观老病死四大毒蛇。是不知病苦不能拔下。明具彼集。文有四句。一妄梵行求众生。不能拔出诸慢见箭。外道多起故。二欲求众生受欲者。不能息三毒火。三欲求众生行恶行者。不破无明。以见少利行大恶行。后受大苦故云黑闇。四有求众生。不竭爱欲大海。三有之爱广无边故。观如实中说彼三求。以为苦果。今为集者。三求皆能为集因而受果故。二文互举。次不求十力大圣导师。明远彼灭。不向灭者故。入魔意下明远彼道。顺怨道故。三于生死下总结过患。举生死海总显于苦。觉观波涛总明有集。此中兼显死苦之义。略不明老。第二大慈观中二。初睹境兴慈。后佛子下广愿饶益。前中二。先睹境。后我今下兴慈。今初即睹前众生受深重苦。以为慈境。文中先总。无救下别。总中无父曰孤。明前无所恃。涂尽曰穷明后无所依。任重无替曰困常。受生死故。强力所逼曰迫业惑所陵故。后别中无救无依释上孤义。论云。谓现报已受不可救脱。当报因招无善为依。次无洲无舍释上穷义。溺于觉观波涛。不闻正法智洲为对治故。在于生死旷野不为善友慈舍庇故。次无导无目释上困义。离于寂静正。念思推究竟前导故。离于正见之明目故。既无导无目非困如何。次无明下释上迫义。无明者。无明住地旧烦恼故。黑闇者四住客尘故。常起邪念故。为其覆翳不闻正法。故为彼缠裹。二兴慈中独拔修善。令物得菩提涅槃之乐。第二广愿饶益。亦彰慈所为。文中二。先牒前总明。上来修善皆为救护。即是慈相。后利益下别显救护。有十种相。前二为救未来。后八通于现未。一住不善众生。令住善法利益。二住善法众生令得安乐果。谓成彼善故。三愍贫乏者与资生具。四修行多障者。令其成就。上二救顺缘不足苦。五世间系闭者令得解脱。下有五种令诸外道信解正法。谓六未信摄令正信。七令离无利勤苦。八疑惑众生疑除解净。九已住决定劝修三学。以调三业。十已住三学令得涅槃。上三即解行证。论意皆为外道。理实后三兼通余类。上来不住。道行胜竟。自下大文第三明彼果胜。即不住道行胜之果。有四胜果。一摄巧德胜。二名为无厌足下修行胜。三佛子菩萨摩诃萨如是勤修下。教化众生胜。四佛子菩萨摩诃萨为利益下。起随顺世间智胜。四中初二自利。即所知法中智清净果。初自分后胜进。后二即利他勤方便果。前化他行。后化他智。今初摄功德中十句。初三摄闻胜。然有二义。一即三慧。如次配闻思修。二显二持。念即闻持智。及有趣即是义持。义有多种。略说二种善巧。谓智即法智胜。有趣即义智胜。然二释皆闻在初故。论名摄闻胜。次二摄戒胜。一忍辱柔和胜。即戒因成也。谓内怀惭愧不诳幽明。自护七支不招讥毁。故能持戒。二戒无缺胜即戒体成也。乃至命难不舍戒故。后五摄智胜。一者因缘集智。此知法相智。无因倒因名为非处。正因缘集名之为处。知处治于非处。故名觉者。二者证智知魔事对治。随识分别皆魔事故三知妄说智。异说对治。即知教智。正说为义句。邪说为非义句。邪正交杂拣邪得正。名善分别。四神力起用智。依定起通治邪依故。五化众生智。折伏摄受随世宜故。上五中前三自利。后二利他。第二修行胜。有十一句。前四自分。一增长因行集五度福故。二依止因行慧为所依故。此自利福智对。三化生不疲行。四令物证灭行。此二利他因果对。后七胜进。五起佛法行。六起净土行。此依正一对。七依佛法身起行相好法身故。八依佛所作起行。显三密用故。此二外相内密对。上四皆起菩提。九敬重法行。进依胜己故。上五自利。后二利他。十愿取有行。十一离小乘行。即显是拣非对。第三教化众生胜中二。初正明化生后佛子下。结行成益。今初分二。初总以四摄摄生。后示现色身下。别明四摄。文有八句。一示色身是同事摄。随顺众生应化自众故。二演说法即爱语摄。谛语法语为爱语性。一切种爱语中多约开演。论云为疑惑众生。即一切门中之语也。三开示下。皆利行摄。此句为于菩提无方便众生。示菩萨行。即利行自性。四于大乘疲倦众生。示佛威力。即一切利行未成令成故。五为乐世间众生着财位故。示其过患。明位大忧大财多祸多。六为不信大乘先未行胜。善赞如来智。七为无智外道示以神通。上三即难行利行。八总显一切门一切种利行。故云种种方便。然利行爱语亦可参用。由彼爱语示其所学。即为利行故。次下广明布施故。别中略无四摄。广义如瑜伽四十三辨。第二结行成益中。初结前。心恒下成益。趣佛智者。为化众生更求胜力。余文已作不退。未作增修。第四随顺世智胜者。明染障对治。染即烦恼障即所知。文分为三。初总标多门。二所谓下。别示其相。三及余下总结成益。二中显五明相故。大般若云。五地菩萨学五明故。即分为五。一文字算数。是其声明。通治懦智障。言文字者。名句文身。即声论中法施设建立故。算数即数建立故。又治取与生疑障。二图书至咸通达。即当因明。咸通达者。正是明义种种论者。言论尚论。诤论毁谤论。顺正论教道论等类非一故。地水火风即是诤论中摄。谓诸邪见计不同故。顺世外道。唯地为因。一切皆以微尘成故。水风二仙外道。以风水为因。世界水成故。风轮持故。事火外道以火为因。火成熟故。图书印玺即尚论。随世所闻故。又此图书亦正教量。即治所用事中忘障。论云。取与寄付。即事中障。闻法思义解中障。作不作已作未作应作不应作。皆业中障。印障亦是现量。又治所取物不守护障。玺即玉印。三又善下。即医方明。即四大不调。众生毒相病障对治故。善疗能断皆除断方便。断已不生故名为善癫至蛊毒病相病因。于中颠等内四大。鬼等外众生。蛊毒通二。有草毒蛇等毒故论经说。咒药等即病因死因对治。即善方药摄。四文笔下。工巧明。文笔赞咏即书算计度。数印工业中书所摄故。韵属曰文。对词曰笔显德为赞。寄情曰咏。次歌至谈说即音乐工业。悉善其事通上二文。皆忧恼障对治。国城至其宜。即营造工业。草树华果亦兼营农工业。此即不喜乐障对治。金至示人。即生成工业系闭障对治。日月至无错谬。即占相工业。是所得报分过作恶因障对治。谓皆由前世恶因。感此凶吉等故。日月五星以为七曜及二十八宿并上知天文。地震即下知地理。夜梦至休咎。即中知人情。鸟鸣即察鸟情。亦是人情所感咸善无谬。总究上三才。五持戒下。内明治五种染。一持戒治破戒染。二入禅治贪欲染。三神通治邪归依染。四无量治妄行功德染。谓治杀生祀祠求梵福故。五四无色定。治妄修解脱染。上来所释多依本论及瑜伽十三四五。其中更有别理恐厌繁文。又论与经有不次者。但可以论就经。不可回经从论。第三总结成益者。此起世智具四种相。一异障中无障故。云但于众生不为损恼。事中不知名之为障。损恼生事复是事中异障。今无此捕猎等之异障。二与无过乐即为利益故。谓虽不恼令其染着。亦不为之。三发起清净即咸悉开示。谓能起助道之事。四所用清净。即渐令安住无上佛法。谓用此得净故。第二位果亦有三果。初调柔果亦四。一调柔行。二教智净。三别地行相。四结说地相。前中有法喻合。法中正起行内。又更闻法得陀罗尼者。论云。非得义持者。对胜显劣般若未现前故。所以得闻持者得二难故。一地初十平等心。难得能得故。二地中乐出世间智。现世间智。此不住道难得能得故。此之二难对劣显胜故。得闻持不同三地唯世间闻持。喻中真金砗磲磨莹者证智契如事为真金。教智光明能示现如事。犹彼砗磲。二佛子菩萨住此难胜下。教智净中日月等者论云。依阿含增长智慧光明胜前地智故。谓胜前地珠光。余文如前。第三重颂。二十二颂分三。初十七偈颂地行。次四颂地果。后一结说。初中又三。初五偈三句。颂胜慢对治。于中初四偈颂十平等。余颂如道行。第二了知下。六偈三句颂不住道。于中初两偈一句。颂所知法中智清净。后既观知下四偈半。颂教化众生勤方便。于中初一偈颂总观有为虚伪起慈悲二心。次一偈半颂悲观中观缘集苦。次一颂半颂观深重苦。后半颂大慈观。第三名为下。四偈半颂彼果胜中。初半偈颂摄功德胜。次一颂修行胜。于中如是一切为众生句。兼颂教化众生胜。后三颂起世智胜颂位果。三果可知五地竟

大方广佛华严经疏卷第三十八大方广佛华严经疏卷第三十九(入第三十七经)

        唐清凉山大华严寺沙门澄观撰

第六现前地。所以来者。已说诸谛相应慧。次说缘起流转止息相应慧。寄缘觉地故次来也。又四地出世未能随世。五地能随。而不能破染净之见。此地观察无染净法界。破彼见故。故瑜伽云。前地虽能于生死涅槃弃舍。一向背趣作意。而未能于生死流转如实观察。又由于彼多生厌故。未能多住无相作意。为令此分得圆满。故精勤修习令得圆满。故次来也。名现前者。庄严论云。不住生死涅槃。观慧现前故。此约初住地。以前五地双观故。今得现前。十住论云。降魔事已。菩萨道法皆现在前。亦约初说。瑜伽引深密云。现前观察诸行流转。又于无相多修作意。方得现前者。多修无相此约地初观十平等故。观察流转。此约地中已入地竟。方观缘起故。摄论云。由缘起智。能令般若波罗蜜多现在前故。此释正顺今经约地中说。无性释云。谓此地中住缘起智。由此智力。令无分别智而得现前。悟一切法无染无净。唯识同于摄论。上本分云。有间般若现前者。拣后地故。故所断障亦断染净。唯识名为粗相现行障。谓所知障中俱生一分。执有染净粗相现行。彼障六地无染净道。入六地时便能永断。以观十平等故。由斯六地。说断二愚及彼粗重。一现观察行流转愚。即是此中执有染者。诸行流转染分摄故。二相多现行愚。即是此中执有净相故相观多行。未能多时住无相观。初愚即执苦集。后愚即执灭道。本分名微细烦恼习者。执细染净即是烦恼。形于前地故说为微。唯识形后名为粗相。由断此愚便证无染净真如。谓此真如本性无染。亦不可说后方净故。摄论名为无染净法界。后成般若行。亦得自他相续无染净果。其揆一也。后正释文亦有三分。初赞请分九颂分二。前八颂半赞。后半颂请赞中分二。初一菩萨赞余诸天赞供。于中三。初一天众。次一天王。后五颂半天女。于中初三句集经者叙述。标赞佛果。佛语下正赞。此句赞教。次一偈赞理。次三偈赞行。于中初偈悲智无碍行。后二十度圆修行。本绝诸恶者。见恶可除非真持戒。善达性空即般若度。分别法即方便度。智力即二度。博济兼愿。后半结默。第二正说亦分为二。初地行后地果。前中同于前地亦有三分。一胜慢对治。二佛子至如是观已下。明不住道行胜。三佛子至以如是十种下。明彼果胜。亦初分即入心。后二即住心。住中前即摄正心住。后即摄善现行及随顺善根回向。至文当知。今且依论。然三分虽同而渐超胜。胜相云何。谓第四地说众生我慢解法慢治。第五地中说身净慢治。今第六地说取染净相慢治。所治渐细故曰胜也。所治既细。后二亦过染净慢者。前观四谛。苦集名染灭道为净。又十平等随顺如道。但约净说。染相未亡对染有净。亦名取净。今以十染净平等法而为能治。下观缘起。虽有染净悟空深故。不名取慢。今初胜慢治中分四。一牒前标后。二何等下。征列十心。三菩萨如是下。结其行能。四得明利下。辨行分齐。列中十句。初总余别。总云一切法者。论云。是十二入以三科中蕴不摄。无为处界摄尽。而处次于蕴。又名生门顺无生义。故偏举之。言无相者。论云。自性无相故。谓十二入缘成之相。有来即无。非推之使无。故云自性无也。故瑜伽云。由有胜义自性无相平等性故。亦同净名不念内外行于平等等。别中九句明。九种相皆自性无故论云。相分别对治有九种。谓体生等九。是其所治。无之一字是自性无。以为能治。论以初自性无贯下九句。故但显所治相之差别。一无体故平等者。论经云无想。论云。十二入自相想。谓内六根取外六尘之相。总名为想。即十二入之体故。今经云体想取像为体故。亦自性无故。经云无体故平等。下皆准此。上遣分别心。二生者念展转行相。谓诸入苦果虚妄分别为本故。三成者生展转行相。谓生即苦果从果起因。故云展转。上二遣染分依他。但举缘成已显无生无我义矣。四即遣净相。谓本来自净。非灭惑方净故平等。五遣分别相。谓道能分别拣择灭惑。若有分别则有戏论。今本无戏论故无分别。上二遣净分依他。六遣出没相。谓真如之性。在妄为没离垢为出。今妄体即真故无可舍。真体即空故无可取。七遣染相。即由上义染本寂静。即是真如无别真矣。上二遣圆成。即十二入之真性。八遣我非有相。此有二意。一类前释。谓有执言但我非有不无于事故云如幻等事有亦不实。二者此句遣无。由上以无遣有。恐便执无。故遣云如幻梦等。但无其实非是全无故。不应执我非有相。诸喻虽异大旨无殊。亦可。八喻别对前来总别八句。谓如幻无相故。如梦想现故。果生如影故。因成如响故。本净如水月不可取故。正智但是镜智现故。焰不可揽亦叵舍故。化无心现常寂然故。九遣成坏相。成即是有坏即是无。缘起为成无性为坏。缘成即无性故。有无不二。上之九句。初七以无遣有。次一以喻遣无。后一不二。遣俱则双非入中矣。又此不二则不坏有无。谓说空遣于有执。说有为遣空。迷有是不异空之有。空是不异有之空。无别空有而为二也。是遣俱句。又既不二。亦不坏有无。则不异无之有。是不有之有。不异有之无。是不无之无。则亦遣俱非。斯乃四句百非诸见皆绝。方为般若现前之因。第三结行入地。文有五句。一牒前所观十平等法。二自性清净者。远离前地染净慢垢。三随顺真如十平等法。四以无分别心无违所观。五由前四能得入六地。第四辨行分齐中二句得明利忍。对前显胜。未得无生对后彰劣。仁王经中说有五忍。谓伏信顺无生寂灭。前四各有下中上。地前得伏忍三品。九地如次配。次三忍十地及佛得寂灭忍。若璎珞中开出等觉。则亦有三品。今四五六皆得顺忍。此当上品治于细慢。故云明利。言随顺者。顺后无生忍故。然约实位。初地即得无生。今约寄位。当七八九。寄位何以有此不同。谓若约空无我理为无生者。即初地证如所以名得。今不得者有四义故。一约空理浅深。初地观法虚假破性显空。但名无我。今此地中破相趣寂但名平等。若约证实反望由来常寂。无相可生斯理转深故。七地方得。若约契本常寂斯理最妙故。十地后得。二就行分别。六地已前渐起诸行。谓初愿次戒等故名为生。七地已上念念顿起一切诸行。故云无生。三约空有二法。六地已前空有间起。名之为生。七地已上寂用双行。故名无生。四约修分别。行修未熟名之为生。行修纯熟名曰无生。此则七地已还未得无生故。经就八地方显无生。第二不住道行胜中分三。初总显心境。二作是念下。别明观相。三佛子菩萨至如是十种下。结成观名。今初有二。先如是观已结前。所以结者由前观察随顺。得至不住道故。后复以下正显文有四句。前三辨能观心。后一标所观境。前三皆悲后一是智。由此相导故名不住。故论结云不住生死涅槃故。今初三中为物观缘总称大悲。随观不同故分三别。一首者初义。先起大悲而观缘故。故论云不舍过去现在未来。大悲摄胜故。以虽同一切智观观三世流转。厌离有为而以大悲为先。故胜二乘。二增上者。论云一切法中智清净故。谓以道相智观。不唯但观三世而遍了诸法故。云一切法中以此导前。令悲增上故。下经云大悲转增。三满足者。论云一切种微细因缘集观故。谓以一切种智委照无遗。故名微细。三悲为次后后转深。智转胜故。据论现文。初则双明悲智。俱护烦恼小乘。后但唯语于智义当但护烦恼。既三俱称悲。即下三观则皆双护凡小。俱通二利皆双不住也。后句标所观者。前灭后生染生净灭故。第二别明观相即缘起观。然缘起深义佛教所宗。乘智阶差浅深多种。龙树云因缘有二。一内二外。外即水土谷芽等。内即十二因缘。今正辨内。然外由内变本末相收。即总含法界一大缘起。染净交彻义门非一。下当略示。今经文内略显十重。穷究性相以显无尽。非唯寄位同于二乘。言十重者。一有支相续。二摄归一心。三自业助成。四不相舍离。五三道不断。六三际轮回。七三苦集成。八因缘生灭。九生灭系缚。十随顺无所有尽。各有逆顺即成二十。故下结云。如是逆顺观察。逆即缘灭顺即缘生。此约逆顺生死流注。以为逆顺。若准对法第四。此中逆顺彼名染净。染净之中各有逆顺。则成四十至下当说。今以易故经中略无。但二十重。论。主复以上三悲观门解此十重。则成六十。古人兼取彼果分中。三空观之。则有一百八十重。观于缘起。论三观者。一相谛差别观。二大悲随顺观。三一切相智观。初但观二谛有为无有我故。即大悲为首观也。二悲随物增。即大悲增上观。三即委悉穷究因缘性相诸门观故。即大悲满足观。初一下同二乘一切智也。次一自显菩萨道相智。后即上同诸佛一切种智故。涅槃云。十二因缘下智观故。得声闻菩提。中智观故得缘觉菩提。上智观故得菩萨菩提。上上智观故得佛菩提。初二菩提即初观意。余二各一可知。前约为物三皆称悲。今约观心三皆智观。是知三句各有悲智相导。融此三观唯在一心。甚深般若于是而现。然论三观。虽遍释经而与十门开合不等。初一切智观摄经十门。总为三段。一成答相差别。此摄十中初门。二第一义差别。摄经第二门中之半。三名世谛差别。摄余八门半。所以分三者。初一显妄我非有。后二显真俗非无。真辨缘性俗明缘相。义理周备故。第二大悲随顺观分十为四。一观众生愚痴颠倒。摄十门中第一门。二余处求解脱。摄第二门。三异道求解脱摄次四门。四求异解脱摄后四门。此之四观初一就情彰过。后三就法辨非。于中二。是所依理非对彼正理。名所取我以为余处。三是所依行法。非举其法非明其行失。后一明所求果。非以苦欲舍苦故。第三一切相智观。摄十为九。一染净分别观。摄初半门。二依止观。摄初门后半及第二门。三方便观。四因缘相观。五入谛观。六力无力信入依观。七增上慢非增上慢信入观。上五门如次各摄一门。八无始观摄八九二门。九种种观摄第十门。释相差别至文当知。然其三观俱通二利。若随相分别相谛观即自利次大悲观明其利他。一切相智通于二利。于中分别复各不同。前五自利次二利他。后二二利成熟。前五中初二通染净。一示染净相。二示染净依。后三惟观染。于中初二建立染法。一染法之因。二染法之缘。后一就染观过。次二利他中初一化凡后一化小。后二二利成熟中。初真谛观见法缘集无本性。故名为无始。后俗谛观但顺缘转。故云种种。已知大意。次正释文。依经十段而并以论三观次第释之。更无别理。经之十段。前五佛子次三复次。后二又字以为拣别。唯初门中中间有一佛子。今初有支相续门。先依相谛差别观。三段之中当成答相三字。即分为三。初至则无生处辨定无我。即论明成。谓双举解惑释成无我故。则知缘集但是妄我。二复作是念下。倒惑起缘。即论明答。谓对难释通无我义故。三后佛子迷真起妄缘相次第。即论明相。此三若望十门。皆显妄我非有。三自相望合之为二。前二显起因缘明缘无我。后一起缘次第明缘有相。经依此义中间加一佛子。皆有染净。今初成者将观缘起。先释成无我辨定所宗。一以贯诸则显十门皆成无我。此是正破我执习气。文中二句。初言世间受生皆由着我者。即反举惑情明我非理。但是苦集故。若离此着则无生处者。即顺举解心明理非我。是灭道故。此直顺经文。已无我义成矣。论经言受身处生者。以我执习气。但令自他差别故。论云。五道中所有生死差别。若五道差别自由业招耳。又论主反征。惑情显成无我。初征着我。明凡应同圣过。云若第一义中实有我相者。此按定所执着我之心。即是第一义智。此反以纵立。谓称实我知故。次云不应世间受身处生者。以理正征。谓若我是灭理着心是道。则凡应同圣得于涅槃。何以着我世间受生耶。此中应为立过云。若第一义中实有我者。凡应同圣为立宗。以有能证第一义中实我智故为出因。如诸生尽圣人为同喻。此则凡应同圣。凡既同圣即无凡夫。复成一过。次反征后句。明圣应同凡过云。又复若第一义中实有我相者。若离着我应常生世间。以不称实同于妄执。非第一义智故。此中应为立过云。以理实有我圣应同凡为宗。次圣证无我违理倒惑非圣智故为出因。如诸凡夫为同喻。此则结成圣应同凡过。圣既同凡则无圣人。复是一过。是以经云若离此着则无生处。则反显妄情定是过也。二过既成。则无我理昭然可见。第二倒惑起缘。即论明答。答外伏难故。两难二答。一执情征理难。情乖正理答。二常求下。执相征实难。相不依我答。今初难云。若实无我云何着我。如空中无人岂计有人。既着于我不着无我。明知有我。答云。由无智故于无我处执着于我。非由有我。如翳见空华岂空中有华。第二难云。若实无我。何以贪着于我世间受生为缘次第。明知有我。方得为缘次第生起。答云。正由无我计我痴爱为本。倒惑造业乃至老死何要我耶。答意正尔。就文分三。初明倒惑顺起染缘。二此因缘故下。正智逆观。结酬无我。三菩萨如是下。就人结观。今初。然十二支即为十二别。亦无间然。而诸论中多摄为四。一能引支。谓无明行能引识等五果种故。二所引支。谓识等五是前二支所引发故。三能生支。谓爱取有近生当来生老死故。四所生支。即生老死是爱取有近所生故。此约二世一重因果。明生引别。若依三世两重因果。则生引互通。今经并具。且依十二文分为五。初至有无辨无明支。无智是痴常求有无。即是有爱。然依三世。诸惑谢往总名无明。略举发润有支本故。若约二世。虽诸烦恼皆能发润。而发业位无明力增。故名无明。唯取能发正感后世善恶业者。以为其体。希常为有。于有乐事欲常住故。求断为无。于有苦事愿断灭故。次不正思惟至增长明行支。文有七句。初三行过。次三行体。后一结成。初云不正思惟者。是行俱无明。涅槃说此为无明因。亦无明摄。蹑前起后故因果互举。次句就人彰过。谓起妄行者必是凡夫。无明为因求有造业故。故初地云凡所作业皆颠倒相应。反示菩萨胜义。谓菩萨虽行于有起于善行。以明为因。不求有造不名妄行。下句就法彰过。论云。示于解脱处不正行故。若行涅槃路方为正道。次三句辨行体相。以三业相应思造三行故。谓由迷异熟愚违正信解。起感三涂恶业及人天别报苦业。皆名罪行。然别必兼总。唯感别报非行支故。由迷真实义愚。不知三界皆苦。妄谓为乐。起欲界善业名福行。八禅净业名不动行。后句结成行支。谓作已无悔积集增长。有迁流故。次于诸行下。明识支。谓既发行已由行熏心。令此本识能招当来生老死故。名之为种。若无行熏终不成种故。云于诸行中植心种字。即是所引识等五种。于一刹那为行所集。无有前后。约为异熟六根之种。名六处支。为异熟触受种名触受支。除本识种为识支体。及此三种诸余异熟蕴种。皆名色支故无前后。因位难知。但依当起分位。说五有殊。五不离心但名心种。又隐余四就现说故。然唯识论中。但识等种以为所引。而集论中说此识支。通于能引。正取业种为识支故。识种乃是名色支摄。缘起经说通能所引。业种识种俱名识故。识种但是名色所依。非名色故。不同集论。今经意同缘起经说。通取二故。双举行识论云此中起心种子者。示生老死体性者。谓未来二果。以此识种为亲因故。次有漏有取成上种义。谓行及识等名言种子。皆通无漏。今与三漏相应故名有支。如初地中。以欲等四流起心种故。有漏是爱有取是取。爱取润故能招后有。次复起下。辨名色支。初之二句文含二意。一者成上种义。由起生死心得种名。二者总标后义。现行名等皆生老死故。即同初地。于三界田中复生苦芽。所谓下。别亦有二意。一通约十二自此至生名色芽。是识生名色。二为显前来已具十因。则辨有支生于生死。名色居初次第辨耳。谓由前心等五种。有漏有取爱取润故。复起后有。是标有支生于二果。今别显有支之相故。唯识云。爱取合润能引业种及所引因。转名为有。俱能近有后有果故。瑜伽第十唯说业种名为有者。此能正感异熟果故。如后段说。三十八中复说。唯识等五名为有者。亲生当来识等五故。实则总有八支共立有名。唯除无明通有成九。今经复加无明。则通前十因共招二果。若以十二是前世二果。则一世中具十二。矣。且约有支文有六缘。一业为田。即是行种望所生果。但为增上缘故。二识为种。即是识等五种。为后生死作亲因故。如世种植依田肥瘦。然其菽麦随自种生。论总释云。随顺摄取罪福等行业为地故。此正明随顺。于爱摄前行识之种。而成有支也。三无明闇覆。论主取前经无明故。云前说无智闇障。无明覆蔽故。此则依于等能发起远为助故。亦是举于前世例今世故。准唯识意非前发业无明。即是覆业无明。亦是爱摄。即迷外增上果愚。又诸烦恼皆能润故。以约十因同一世故。四爱水为润。论主指前常求有无之爱。即是举例。亦即是前标中有漏。以前有爱无明摄故。五我慢溉灌者。即是取支。要数溉灌方生有芽。我语等取为我慢故。若悟无我容不生故。六见网增长亦是取支。见取摄故。我见为本诸见生故。令无漏法不能坏故。名之为网。论总释云。如是住如是生心者。总显生名色芽。由无明爱。令上识种安住业地。名色心生故。次却释我慢。彼经云我心溉灌。论云。我是我所我我想是慢者。谓我是我所释我字。以非但执我亦执行业。是我所修故。次我我想是慢者。释彼心字。心即想义。依我起于我想以陵他故。名之为慢。正同今经次释见网云。我生不生。生即是常不生是断。断常为本具足六十二见故。末句云如是种种诸见也。如初地中。始于无明终至识支。皆名邪见。然远公诸德皆云我我所者。受生之时。自见己身名之为我。见父母精血名为我所。又谓父母是我夫妻。当受生时与父母竞色。谓己诤得便起胜想。故名为慢。我生者。我唯此处生。不于余处生。此并通取中有求生之爱。于理无失。然上诸句。皆明能生生名色芽。即是所生当报五果。初结生蕴即是识支。今以前辨识种隐于余四。今辨现行略其总报所依。欲显识与名色次第相生义故。复欲显其通种现故。故有隐显。然名色等必有所依本识故。初地。云于三界田复生苦芽。所谓名色共生。论云共阿赖耶识生故。即此后文云。与识共生。次名色增下。辨六入等八支。如后段明。然此一段意。欲答于受生所以故。具出诸惑隐显等殊不在显相。显相在于后段。二约逆观结酬无我。初二句约生明无我。但由无明等集非由我集。又上句拣无因。下句拣邪因。后二句约灭明无我。刹那性灭无使之然。三就人结观。如是观者。即随顺缘起之理。第三迷真起妄缘相次第者。即论相差别也。论云。若因缘无我以何相住因缘集行。谓当相名住生后为行故。经意云。迷诸谛理起相集耳。然成答相三。通是有支相续。而两重缘相差别云何。略有五异。一前约妄我起缘。即迷我执。此约迷谛起缘即迷真实义。二前约缘起。此约缘次故。前通取十因。一处共起名色。此中一向单说次第。三前通三世二世。以许十因同一世故。义取亦通五世。此唯三世以名色等唯约现故。义取亦通一世。四前文欲明三世并备。于无明中说有爱故。于现在中说无明故。此中三世互有隐显。不许相通。五前为答难此为辨相。如论意故。有斯五异两处辨缘。共明相续总破痴倒故。但束为十门之一。文中亦二。初顺后逆。顺中初无明支。言于第一义不了者。然十二支。皆依真起无有自性故。下偈云观诸因缘实义空也。而无明最初亲迷谛理。而起于行。既横从空起不可复原故。令无明特受迷称。论经云。诸谛第一义者。即四谛也。故对法云。真实义愚者。谓迷四圣谛。所迷即是实义。能迷即愚。别有闇法名为无明。非但遮诠明无而已。二所作业果名。行者行支也。业即罪等三业。是彼无明所起果故。故偈。云所作思业愚痴果。而论云是中无明所作业果者。所谓名色者。此出果体。体谓行体即名色故。远公释论云。行有三业。意业为名身口为色故。婆沙云。名色有二。一方便名色。二报名色。若云名色缘识。即方便名色。若云识缘名色即报名色。今以行为方便名色。三行依止下识支。论云。于中识者彼依止故。彼即是行。此中语倒。应言依彼故。论经云。依行有初心识。谓由行熏心有当果种。乃至现行故。瑜伽云。因识为缘相续果识。前后次第。四与识下。名色支。初一识字即是现行识支。识为种边唯是赖耶。在现行位通于六识。今拣现非种故云共生四蕴识蕴已属所依识故。若言四蕴曰名。羯剌蓝等为色。则所依现行之识。亦唯赖耶。瑜伽云。俱有依根曰色等。无间依根曰名。则通五蕴为体。即四七日来根未满位。论云名色与识共生故者。此言拣滥。恐人误谓名共色生故。又云。识名色递相依故者。释前共义。谓识由名色得起。名色依识得存。如水与尘互相依持。以为泥团。亦如束芦。乃至命终相依而转故。上答文总名苦果。为名色芽五六处支。谓四七日后诸根满位。六处明盛。名增成意处色增成余五。俱舍云。从生眼等根三和前六处。前段为明意根本有。云成五根耳。俱舍第十一五果之中。前三胎内余二胎外。六触谓触对。虽有三和。于三受因尚未了知。但能触对。七受支。分别三受领纳于触名触共生。此前四支唯约现行。八爱支。以三受中乐受缠绵希求。故云染着。即是中下品贪。此虽通缘内外二果。诸论多取缘外境爱增上果生。九取支。虽摄余惑而爱润胜故。说是爱增。然上二支通现及种。十有支。由四取心中所起诸业。故名有漏。此业亲能招当果。故名之为有。此约三世不同前段爱取合润业等名有。此前之业。已隔现行名色等故。十一生支。约增上缘云从业起。始从中有未衰变来。皆名为生。十二老死即诸衰变位名为蕴熟故。上二支体通五蕴。唯是现行欲令生厌。合五成二。以显三苦。老非定有附死立支别离等五。余时虽有死时多故。偏就死说。然此一段有支。亦通一生前后。建立余支可知。唯生一种通。取于前耳思之。后逆观中一结是苦树。谓无明行引识至受为苦芽。爱缘引受至有是守养。生老死为苦树。从芽守养是增长义。又于现法中。无明造业为小苦树。若爱取润则得增长。不润尚灭况更增耶。又初二为根。次二为身。次三为枝次三为华。后二为果。无我我所结成无我。无作无受结成于空。复作是念下。以我况法。结成胜义故。故瑜伽说。由十种相缘起甚深。六义依无常。一义依苦。一义依空。二义依无我。今初一从自种子亦待他缘。二从他亦待自。三俱从无作用。四此二因性非不是有。此四义即前段中。但因缘故集无有集者。五虽无始其相成就。而刹那灭。六虽刹那灭而似停住。此二即前任运而灭。亦无灭者。一义依苦者。一味苦相而似三相故。结云苦树。一义依空者。谓离有情作者受者。然似不离显现。即今无作无受。二义依无我者。一虽实无我似我相现。即今无我我所。二依胜义谛。虽不可说。而言诸法自性可说。即今复作是念已下。经文十义备矣。由前缘相皆是似义故。逆观中直显真实性相无碍。故为甚深缘起之观。正在于此。又无作作者。即显缘生非天人作。若佛出世若不出世。安住法性法住法界故。于此一观已为甚深。况加后二。二约大悲随顺观者。四观之中。此第一门即当第一愚痴颠倒观。论总释云。随所著处愚痴及颠倒。此事观故。谓十二因缘是所著处。痴迷性相倒执我所。下别释意。明痴随所迷立二颠倒。一从初至则无生处。明迷缘性之无我执我成倒。以着我故则世间生。明是颠倒。若离此着则无生处。反显此着必是颠倒。二复作下竟。初一门明愚缘相之缘生疑惑颠倒。谓无智故常求有无。滞断常之二涂故云疑惑。致缘相之相续明是颠倒。令菩萨顺彼众生愚倒之事。起悲观察名为事观。三约一切相智观。九观之中。此门摄第一观全。及第二之半。谓初成答二文名染净分别观。此有二意。一着我为染离我为净。二着我故。缘相生为染。离我故缘相灭为净。后相经文即属第二依止观。谓虽依第一义。以不知故即起诸缘。是为染依。见第一义诸缘则灭便为净依。相谛观中。不知故成缘相。大悲观中不知便为颠倒。然上相续一门。经文无二随义分三。初明倒惑起缘。实无有我成一切智观。次顺痴倒事成道相智观。后委究解惑染净性相。成种智观。又初顺根本次顺后得。后即无碍。虽无我所不坏相故。而起大悲能所本空。悲而无著双穷性相。不滞自他。三观一心成无碍智。甚深般若宁不现前。一门尚然况加余九

大方广佛华严经疏卷第三十九大方广佛华严经疏卷第四十

        唐清凉山大华严寺沙门澄观撰

第二一心所摄门中。然此一门乃含多意。且分二别。一推末归本门。二如来于此下。本末依持门。今初依论三观。初约相谛。即当第二第一义谛观。论生起云。云何第一义差别如是证第一义则得解脱彼观故。此明修观所以。以第一义是缘生之性。若见缘性则脱缘缚。故修彼观。而论经虽云皆一心作意。取能作一心故云第一义观。论云。但是一心者。一切三界唯心转故。此言则总转者。起作义。亦转变义。然此一文诸教同引证成唯心。云何一心而作三界。略有三义。一二乘之人。谓有前境不了唯心。纵闻一心但谓真谛之一。或谓由心转变非皆是心。二异熟赖耶名为一心。拣无外境故说一心。三如来藏性清净一心理无二体。故说一心。此初一心菩萨不为此观。后二一心经意正明通于三观。约清净一心为第一观。通此二心为后二观。后二一心略如问明。广开有十。初之一门假说一心。谓实有外法但由心变动故。下之九门实唯一心。二相见俱存故说一心。此通八识及诸心所。并所变相分本影具足。由有支等熏习力故。变现三界依正等报。如摄大乘及唯识等诸论广说。三摄相归见故说一心。亦通王数。但所变相分无别种生。能见识生带彼影起。如解深密经。二十唯识。观所缘缘论。具说斯义。四摄数归王故说一心。唯通八识以彼心所依王无体亦心变故。如庄严论说。五以末归本故说一心。谓七转识皆是本识差别功能无别体故。楞伽云。藏识海常住境界风所动。种种诸识浪腾跃而转生。又云。譬如巨海浪无有若干相。诸识心如是异亦不可得。既云离水无别有浪。明离本识无别前七。六摄相归性故说一心。谓此八识皆无自体。唯如来藏平等显现余相皆尽。经云。一切众生即涅槃相等。楞伽云。不坏相有八无相亦无相。如是等文诚证非一。七性相俱融故说一心。谓如来藏举体随缘成办诸事。而其自性本不生灭。即此理事浑融无碍。是故一心。二谛皆无障碍。起信云。依一心法有二种门。乃至不相离故。又密严云。佛说如来藏以为阿赖耶及如金与指环喻等。又胜鬘云。自性清净心不染而染。难可了知。染而不染亦难可了知。皆明性净。随染举体成俗即生灭门。染性常净本来真净。即真如门。斯则即净之染不碍真而恒俗。即染之净不破俗而恒真。是故不碍一心双存二谛。深思有味。八融事相入故说一心。谓由心性圆融无碍以性成事。事亦镕融不相障碍。一八一切一中解无量等。一一尘内各见法界。天人修罗不离一尘。其文非一。九令事相即故说一心。谓依性之事事无别事。心性既无彼此之异事。亦一切即一。上文云。一即是多多即一等。十帝网无碍故说一心。谓一中有一切。彼一切中复有一切重重无尽。皆以心识如来藏性圆融无尽故。上之十门初一小教。次三涉权。次三就实。后三约圆中不共。若下同诸乘通十无碍。一部大宗非独此品随一一门成观各异。可以虚求。第二本末依持门。此下终于十门皆是世谛差别。缘相本寂但应观真。何以复观世谛差别。论云。随顺观世谛即入第一义故。俗为真诠了俗无性方见真耳。中论云。若不知世谛不得第一义。故此观有六。一何者。是染染依止观。即双辨能依所依摄此半门。二因观观染因故。摄次二门。三摄过观唯苦集故。四护过观护凡邪见故。五不厌厌观防小慢故。上三次第各摄一门。六深观显因缘之理妙过情取故。此摄后三门。六中初二建立染相。次一就染观过。次二正观防非。后一观行深极。今此半门。即染依止观因缘有分为染。而此染相依止一心故。论云。此是二谛差别。以纯真不生单妄不成一心之真杂染之俗。此二和合有因缘集。经中三。初总谓依一心分别十二。则十二为一心所持。而特言如来说者。一心顿具非佛不知故。谓显如来过去觉缘性已等相续起。展转传说故。次征意云。十二有支三世行列。前后引生。何以今说皆依一心。后释中论无别解。古来诸德。但云离本识心一切不成。而其释相经生越世。此虽不失依持之义未为得旨。今谓说主巧示非唯三世不离真心。今一念心顿具十二。弥显前后不离一心。此同俱舍第九明刹那十二因缘也。是以此一门中含多缘起。一含摄论二种缘起。彼第二云。若略说缘起有二。一分别自性缘起。谓依阿赖耶识诸法生起。即今一心依持。二分别爱非爱缘起。谓十二缘起。于善恶趣能分别爱非爱。种种自体为缘性故。即通今释文及前后九段。二含俱舍第九四种缘起。一者刹那。二者连缚。三者分位。四者远续。后三通余九门。此中正当第一。彼云。云何刹那。谓刹那顷由贪行杀等具有十二。彼广说相与此大同。故今不必依次。意显一心顿具。随事贪欲与心共生者。此则总指所行之事。贪事非一。随取一事于一念中则具十二。谓行此贪事必依心起。复了别前境故。心即识支。事是行者。贪事即是意业之行。若形身口亦是二行。不知贪过。能招于苦名于行迷惑。与无明及心共生是名色者。名色是总。为二所依名与共生故。晋经云。识所依处为名色故。俱舍云。识俱三蕴总称名色。意明。以受蕴自是受支故。名色增长是六处者。不生五识唯名十界。五识依生乃名十处。识依相显即是增长增长之言宜译为开显。俱舍云。住名色根说为六处。谓六根是别。以别依总开成于六。称住名色。贪必对境为触受必领触。贪即是爱名受无厌。爱摄不舍即是欲取。爱取润前六支成有故。但前诸有支生即是有义。有所起者。即前诸法起便是生义。生熟为老者。物生即异故。老坏为死者。刹那灭故。又依大乘当相坏故故经云。初生即有灭。不为愚者说故。此若不断则名连缚。十二支位五蕴皆名分位。即此顺后无始来有。名为远续。大小理通。或六八识异耳。非圣教量孰信斯旨。论主不解殆似疏遗。此文正辨同时异体十二有支。若同时同体亦具十二。谓迷第一义即是无明。有漏有取便名为行。体即是识亦即名色。即是意处对境名触。领境名受染境名爱。着境名取招报为有。体现名生即异灭为老死。以此十二有支约时通说。总有六种。一依五世说十二支。谓过去无明行复从过去。过去烦恼生此则烦恼生惑业。过去二因生现五果。则惑业生苦。若现生未来未来更生未来。则苦复生苦。此依三世推因征果假说有五。非约展转不堕无穷。二依三世。三依二世。四依一世前后建立并如初门中辨。五同时异体。六同时同体。即如此文。二约大悲随顺观中。即当第二余处求解脱。谓是凡夫愚痴颠倒。常应于阿赖耶识及阿陀那识中求解脱。及于余处我我所中。求解脱故。经明唯是一心。则心外无我法。当于一心中求。亦同净名诸佛解脱当于众生心行中求。言阿赖耶此云藏识。能藏一切杂染品法令不失故。我见爱等执藏以为自内我故。此名唯在异生有学。阿陀那者。此云执持。执持种子及色根故。此名通一切位。此二即心之别名。论主意明。心含染净故双举二名。释一心义。求义云何。若有我执成阿赖耶。若我执亡则舍赖耶名。唯阿陀那持无漏种。则妄心斯灭。真心显现故。下偈云。心若灭者。生死尽。即妄灭也。非心体灭。三约一切相智观。即当第二依止观。明此缘集依于二种。一依第一义已如前说。二依心识即是今文。前唯约净。此通染净依义如前。又前即依真起妄。此则显妄依真。第三自业助成中亦三。初约相谛观者。此下二门即当因观。因观有二。一他因观。二自因观。远公云。行望无明异故名为他因。从前无明生后无明。名为自因。他因小通自因有妨。以论云自因观者离前支无后支。经言无明因缘能生诸行故。今谓他因者。全赖前支生后支故。此拣自性故。大悲观中拣于冥性。一切相观名为方便。唯从无明生于行故。名为自因。此拣余因能生于行。亦犹于酪定从乳生。不从石出故。大悲观破于自在等因。一切相智显因缘相故。三观取意小异文旨大同。诸德不寻论文妄为异释。今此一门即他因观。经明各有二业。则一是自业。二是助成。而并云他者。特由无明迷于所缘方为行因。若了所缘宁起妄行。又初明自业显是他义。二明生后显是因义。余十一支仿此思准。然生起之因即增上缘。以缘名因从通义说。于四缘中诸支相望。增上定有故。缘起经及此文中。唯明有一。余之三缘有无不定。故略不明。谓爱望于取有望于生。有因缘义。以爱增为取识增为有故。若说识支是业种者。行望于识。亦作因缘。余支相望无因缘义。而集论说无明望行有因缘者。依无明时业习气说无明俱故。假说无明实是行种。瑜伽论说诸支相望无因缘者。依现爱取唯业有说。上四位相望明有因缘。初二定实。次一不定。后一假说。无明望行爱望于取。生望老死有余二缘。并以现行相望。无间引生故。行等思心可反缘故。有望于生受望于爱。无等无间有所缘缘。以种望现故。所生现行却缘种故。余支相望二俱非有。此中且依邻近顺次。不相杂乱。实缘起说。异此相望为缘不定。以其逆顺各有次第及超间故。为缘既多义不同。经约拣要从定有说。又约因言已含余三。其十二支各初自业。不异前之二门。论主唯解老死二业者。以此难故。举一例诸。然无明无因老死无果故。前十一各与后支为生起因。老死无果与谁为因。经文意显与无明为因。则无明非无因老死非无果故。云不觉知故。相续不绝不觉知者。即无明也。是以十二因缘犹如寻环如汲井轮。无有断绝。反显若能觉知则无复生死。论主总以二业为后生因。故云坏五阴身。能作后生因以不见知故。能作后生因。意明前阴但灭则后阴生故。初为因后意不知。即是无明。无明为因则十二支相续不绝。不见此意徒自云云。二约大悲随顺观。四观之中。此下四段明第三异道求解脱。论云。颠倒因有三种性因。自在因苦行因及无因。此有四因如次四门破之。前三是邪因故并云颠倒。一性即冥性。谓僧佉计此为所知因。谓知此冥性即得解脱故。前云异处求解脱显其理非此中。虽云所知意取行非。二即迦罗鸠驮计自在天。为所求因。谓自在天嗔众生受苦。自在天喜众生受乐。求其喜故。三删阇夜计苦行。为所修因。但修苦行以酬往业。则得解脱故。四无因。即阿耆多计众生不由因得。万法自然。若知此者便得解脱。众生于上邪因无因异道中求经。欲以正折邪故举四门。令于中求。不应于上邪见中求。此门即破冥性。谓因缘有支各二种业。而能生彼因缘事。不由冥性故。断前支缘则后支不续。一生之中便得解脱。汝之冥性纵八万劫知亦无脱期。三约一切相智观即当第三方便观。谓因缘有支各有二业为起后方便。若灭前前即不生后后。是解脱方便。第四不相舍离中。三门同前。初约相谛。即当自因观。自因之义已见上文。又论云。自因观者。无明等自生因观缘事故。谓离前支无后支故。如不离无明有行等。则无明唯是行自因也。以是自故令行不断。以是因故但云助成。若唯不离无明有行。则成太即。不应言无明缘行。若全离无明有行则成太离。无明则非行因故。论云。异则不成不即不离则名自因。亦二义成矣。故论主引中论偈云。众因缘生法是则不即因。亦复不异因。非断亦非常。初句泛举也次句以是所生非能生故。亦复不异因者。从于能生生所生故。非断亦非常者。不即故不常。不异故不断。又不即因故果不断因不常。不异因故果不常因不断。又以不即故因果俱不断。不异故因果俱不常。非无因常故。又亦反此。非相续常故。又以不离是不即故。即不常为不断思之。文中先顺后逆。顺中而论云。无明有二种。一子时。二果时。是中子时者。令行不断。有二种义故。缘事示现者。子是种子果是现行现行之果虽前已谢故不取之。种子续故令行不断。能助成行故取子时。亦可初起无明名之为子。迁至行时名之为果。由前等引之力令行不断。助成行故偏取子时。余十一支皆有二时。例此可了。后逆观。论云。先际后际灭中际亦无。是故不说者。十二因缘不出三际。过未既无中岂得有。是故不说有不断助成义。又不说者。灭则灭前诸义故。不假说子果等殊。二约大悲随顺观破颠倒因中。以自在天为众生因。今以无明等为行等因。尚不从于余支。岂得从乎自在。三约一切相智观。即当第四因缘相观。有支无作故者。既由前前令后后不断。助成后后。则后后无性。何有前前能作后后。即以无作为缘之相。是种智境。第五三道不断。一依论相谛中六观之内名摄过观。谓以三道摄十二支。则显有支但摄于苦因果过患业惑是因。苦即是果亦有顺逆。初顺观中文含二义。一约三世。则过去无明现在爱取名为烦恼。虽同烦恼过去迷于本际与无明名现在牵生后果由于爱取。从其本末隐显互彰。行有是业者。宿业名行。现业名有。虽同是业。过去已定当相名行。未来未有业能有之功能立称。现在五果未来二果。同皆是苦。现报已定当相受名。未来来起从过患立。若约二世前十同世。则烦恼有二能发能润。虽诸烦恼皆能发润。于发业位无明力增。润业受生。爱取力胜各偏受名。以无重发唯一无明数数溉灌。故分爱取。业亦有二。未润已润。未润名行初造作故。已润名有近生当有故。若总取识等种为所润。则亦苦摄故。唯识云。有支一分是业所摄。就苦七中五约种说。二约现行种位难知。依当果位别显为五。果位易了故。唯立二并如前说。三道皆言不断者。谓从三烦恼生于二业。从彼二业复生七苦。七复生三故如轮转。如净意菩萨十二因缘论广明。后前后际下逆观分二。初明对治断。谓断前际无明行及后际爱取有。则七苦不生。后如是。三道下。明自性断。故净意云。一切世间法唯因果无人。但从诸法空还生于空法。是则生灭因果。如二束芦互相依立。不能独成则知无性。二我俱空。二约大悲观中。即当破异道求中苦行因计。谓以业惑而为苦因。欲求脱苦当断业惑反修苦行。是起妄业。计苦行心即是烦恼。如是妄想宁是解脱乐因。三一切相智观中。即第五入谛观。三道苦集谛故。谓业惑皆集故。瑜伽云。生老死现法为苦。识等五当来为苦者。五约种说故。唯识云。十二皆苦谛摄。取蕴性故。五亦集谛业烦恼性故。此则业惑通于二谛。约其逆观即灭道谛。灭分别心亦即道故。又体三道即性净三德涅槃。佛性一实谛故。第六三际轮回。初约相谛名护过观。谓说三际护三过故。三际不同诸教三说。一依唯识合能所引开能所生故。前十现在后二未来。十因二果定不同世。因中前七与爱等三。或同或异。谓生报定同后报便异。若二三七各定同世。如是一重因果足显轮转及离断常。此则但以二世具十二支。不许三世两重因果。若尔云何三际。今之二果乃是前际十因之果。二依智论俱舍。生引俱开。初二过去次八现在。后二未来故成三世。现八之中前五是果。酬于过去。后三是因复招未来。则二重因果各具三道。可得抗行。三依此经意明三世故。开能所引为前中际。为遮前七定同世故。复示众明迷本际故。二属过去合能所生。总为后际。为遮爱等但是润故。示因招果。令厌因故以因从果。五属未来则能所引生。及所发润皆容互有。经无生死者。同许为果。略不明之论经具也。明文昭然。何为唯取二世不受三耶。已知大意。次正释文。文有顺逆顺中有二。先明一往三世。后于是下。明流转三世。今初云无明缘行是观过去者。观有二义。一观现在生是过去二因所作。二则知识等。是彼过去当来之果。因果相属反覆相成。如是方名见过去因义能防三过。言识乃至受是观现在者。亦有二义。一观现在识等由过业得二。复知识等能得未来果报。以不得对治依起爱等故。现在目睹故。分两向明其二义。言爱乃至有是观未来者。此未来因决得来果。一往定故。二流转三世者。谓不得对治复有后世。于后世上转生后世。后后无穷已知三际。云何护过。谓外与内因缘之法。立三种过。一者一切身一时生过。何以故。无异因故。此过从前自因而生。谓既无自在等而为异因。唯无明行为识等因。行有多种。何以不得六道齐生。二者自业无受报过。何以故。无作者故。此过从于无作缘生。作者即我。三者失业过。何以故。未受果报业已谢故。此过从于无常缘生。此上辨过云何护耶。若见三际则能护之。然过去业有三种义故不得报。一未作二作已未润三得对治。今无明缘行则显已作。现识等五则显已润。已受爱取有。三则知未得对治。于已作业既有润未润。殊斯为异因。已润则受生报。未润则受后报。润未润殊。岂得六道一时齐受。此为异因何用自在。既自造异因自招二报。非他身受。何言自业无受报耶。假者自造何用我耶。若已作业不得对治。润则便生知业不失。因虽先灭势力续故。现见得报不可言失。三过度矣。后无明灭下逆观。即得对治义。此灭则彼灭。是观待断。又因观能灭拣自性灭故云观待。然十二缘三世并备。但随化迹隐显分三令知过去因招今苦器。今断爱等当果不生。则愚痴绝命于慧刃。爱水焦干于智火。高罗四开于六趣无生。超逸于八极矣。二约大悲随顺观。治异道求中。无因之见示三际因果。既先际二是中际五因。中际之三是后际二因。若无如是等事。众生亦无。斯因有矣。何得言无。三约一切相智中。当力无力信入依观。论云。先中后际化胜故。谓此三际为因义边皆名有力。为果义边名为无力。若约三世。前际于现五有力。于当二无力。中际爱等于当二有力。于现无力。以斯三际化彼凡夫。令信入依行。化中之胜。如是穷究为种智境。第七三苦聚集。初约相谛。即当六观之中第五不厌厌观。论云。厌种种微苦分别所有受皆是苦故。此约微细行苦。又云。及厌种种粗苦故。此约坏及苦。苦皆凡夫不厌菩萨厌故。又初微苦二乘不厌。菩萨亦厌。二乘虽知舍受。行苦不穷委细。有无量相及变易苦。故云不知。文中亦有顺逆。顺中从相增说以配三苦。前五迁流相显名为行苦。触受二支触对生苦。故云苦苦。余但坏乐故名坏苦。老死坏生亦名坏苦。若准瑜伽唯识。十二支全分皆行苦摄。有漏法故。十二支少分苦苦摄。十二支中各容有苦故。十一少分坏苦所摄。以老死位中多无乐受。依乐立坏所以言无。若约坏生如今经说。若依舍受以立行苦。则除老死。老死位中无容舍故。以此三苦从三受生。谓苦受生苦苦。乐受生坏苦舍受生行苦故。二苦皆言少分者。十二支中具三苦性。若是二苦必是行苦。故言全分。有是行苦而非二苦。又是二苦各不摄二故云少分。逆观可知。二约大悲随顺观。此下四段当第四求异解脱。谓不识真解脱求三界苦等为解脱。故名之求异真解脱者。有四种相。一离一切苦相。二无为相。三远离染相。四出世间相。此四即涅槃乐常净我故。涅槃云。于世间法自在远离名为我故。故下四段经。明其但有四妄而无四德。今此明其有苦无乐故。论云。彼行苦事随逐乃至无色有缚。彼计无色为涅槃者。岂非妄苦耶。三约一切相智。此当第七增上慢非增上慢信入观。不如实知微苦。我慢即增上慢。若知微苦非增上慢。不知令知名为信入。第八因缘生灭。亦名从缘无性。初约一切智观。此下三门皆明深观。谓四句求缘皆无有生。无生而生故曰深观。此门明不自生不他生。第九门明不共生。第十门明不无因生。释此四句略有二意。一破邪。二显理。理外妄计曰邪。邪亡则理显。理显则惑亡反覆相顺。然自他等四是计是依。不之一字是药是理。穷生之理不出自等。自等若无生将安寄。故以不不之则惑亡理显。然其所计略有三类。一者外道。谓冥性为自梵天为他。微尘和合为共。自然为无因。又此四计亦是僧佉卫世。若提子勒沙婆也。二小乘同类因为自。异熟因为他。俱有因为共。计无明支托虚而起。亦曰无因。上计亦通大乘执相之者。三约大乘。果法为自众缘为他。合此为共离此为无因。又赖耶自种为自众缘为他。合此为共离此为无因。又法从真起为自。从妄起为他。合此为共离此为无因。所计虽众但显正理。诸计自妄。显理复二。一约无生以显深观。二约生无生无碍以显深观。先中略为二解。一约展转释法从缘故不自生。既无有自对谁说他。又一切法总为自故。又他望于他。亦是自故。既无有他故不他生。自他不立合谁为共。有因尚不生无因何得生。二约因缘形夺释。故对法云。自种有故不从他。待众缘故非自作。无作用故不共生。有功能故非无因。论解同此。若尔自种有故则是自生。岂曰无生。此乃假自破他非立于自。次句假他遣自。故中论云如诸法自性不在于缘中也。下二句例然。惟审详之。二约无碍者。但因缘生果各有二义。谓全有力全无力缘望于果。若全有力则因全无力。故云因不生缘生故。云不自生。二因望果全有力亦然。故云缘不生。自因生故。故不他生。三二力不俱故不共生。四二无力不俱故不无因。此复二义。一约用则力用交彻。有相入义。谓有力摄无力故。故十忍品云。菩萨善知缘起法。于一法中解众多。众多法中解了一等。二据体有空不空。有相即义。谓非但因力归缘。亦乃因体由缘而显。全摄同缘因如虚空故。上文云。一即是多多即一等。力无力必俱故。常相即入是为无尽。大缘起甚深之观。文中亦有顺逆。初顺观中。经云。无明缘行者牒也。无明因缘能生诸行者释也。论云。有分非他作自因生故。此以不他生释经因字。谓如行支唯从无明。故云自因。即上自因观也。二者非自作缘生故。此以不自生释经缘字。谓行支但假无明为缘。非有行自体。在无明中从自而生。即他因观。但取拣余不亲生故名因。显前非后疏故名缘。非谓四缘之因缘也。余并可知。二约大悲观。即异求中。计非想等以为涅槃。又计妙行为解脱者。非是常德但是生灭。故可悲之。三约一切相智观。此及后门名无始观。此有二意。一若约俗说。因缘为生灭之本。生死无际故因缘无始。二约真说。见法缘集无有本性可依故名无始。即净名云从无住本立一切法故。染净真性皆无始终。显染可除。但云无始余如别说。论云。中际因缘生故后际生。即举此第八门随顺缚故。即第九门。谓但一念从缘生即是不生。故无始也。不言初际生者。意显无初故。今不起妄即不生故。第九生灭系缚者。亦名似有若无。初一切智观中明不共生。文中三。初顺观。经中但明无明为缘缚行。令行系属无明。斯则缘生而为不共者。论云。非二作但随顺生故。无知者故。作时不住故。意谓但行顺无明。缘不得不生。互无知者。故非二作。若尔但随顺生即是共生。何要知者。故末句云。既从缘生则念念不住。谁为共耶。此同对法无作用故。又中论。云和合即无性。云何和合生。次无明灭下逆观。谓灭但灭于系缚。既无共生安有共灭。言有生灭皆是系缚。三类余可知。二约大悲观。谓彼外道异求非想天等。为解脱者。菩萨观之但是染缚。非是涅槃真净之德。三约一切相智观明无始观中。随顺缚故而生非有本也。第十无所有尽观。亦名泯同平等。三观之中。初一切智观。即深观中显非无因。经亦三节。初顺观中由行从无明缘生。缘生即无性故云随顺无所有。次逆观中。灭亦缘灭缘灭无灭。方顺尽灭之理。然论经顺观云。是随顺有者。显无性缘生故。不能不有。二经虽殊同明缘生故非无因。无因何失若无因生。生应常生非不生也。何以故。无定因故。此即纵破。亦可恒不生何以故。无因生故。此即夺其生义故无因生。非佛法所乐。以无因能生大邪见故。二约大悲随顺观。即求异解脱中。外道计非想无所有处等为涅槃。以顺有故。非是出世故。无我德而妄计解脱。故可悲之。三约一切相智观。当第九种种观。此即世谛观。由随顺有故。有欲色无色爱等之殊。故云种种。即真顺有未失顺无。上来别释十门竟。自下第三总结十名。既云逆顺观察。则前二门阙逆观者。乃文略耳。然此逆顺。若对法第四名为染净。染净中各有逆顺。论云。杂染逆顺故。清净逆顺故染中顺者。无明缘行等故。逆者。谓谁老死集乃至无明故。缘起经云。由谁有故而有老死。如是老死复由何缘。初句推因后句审因。清净逆顺者。无明灭则行灭顺也。由谁灭无故老死灭无逆也。今文略无。但约染净为逆顺。耳。言诸缘起者。十二非一曰诸。前前为缘令后后起。又由烦恼系缚。往诸趣中数数生起故名缘起。亦云缘生生即起义。亦约果说。余如瑜伽第九第十三十一九十三。唯识第八。上来多依此诸论解十名可知。然各摄三观体势星罗。今重以十门本意收摄初门。明染净因起。二明缘起本源。三因果有空。四相成无作。五陈其谛理。六力用交参。七穷苦慢除。八形夺无始。九有无无本。十真俗无违。复收十门不出五意。初门迷理成事。次门理事依持。次六成事义门。第九事理双泯。后一事理无碍。故唯四门不出事理。若从事理无碍交彻则涉入重重。若依事理逆顺双融。则真门寂寂。故法性缘起甚深甚深。即此因缘名因佛性观。缘之智即因因性。因因至果成菩提性。因性至果成涅槃性。因果无碍是缘起性。惟虚己而思之。自下大文第三佛子菩萨至以如是下。明彼果胜。亦前摄正心住。故知缘生此下。摄善现行故。三空等现前。依论云果者。有五种相。一得对治行胜及离障胜。二得修行胜。三得三昧胜。四得不坏心胜。五得自在力胜。各有佛子以为拣别。唯第二段有二佛子。初中分二。先明对治胜。后菩萨如是下。明离障胜。今初。即三解脱门。亦名三三昧。三昧即当体受名。解脱依他受称。此三能通涅槃解脱故名为门。文中二。初牒前后正显。今初意通五果。由前十观得此三空等果故。谓以三空观缘。得第一第三果。三悲观缘得第二第四果。三望于初。初是能治三是所成。四望于二。二是能修四是坚固。第五通从二观而生。亦可展转而生。由有治故离障。离障故行胜。有治故三昧胜。三昧胜故心不坏心。不坏故得自在也。二知无我下。正显三空。三空各有别显总结。初空门中别显有三。初三句明众生空。次自性空明法空。此上二句明二我体空。三无作受显二我作用空。由体空故。并不能作因受果。结云现前者。智与境冥故。二无相门中亦三。一者灭障即观诸有支。皆自性灭。谓若入空门不得空。亦不取空相则事已办。若见法先有后说为空。及取空相。非真知空故名为障。故修无相。了自性灭则不取空障。二所以不取者。得对治故。谓知空亦复空。名毕竟解脱。三既有能治治于所治。则念想不行。故云无有少法相生。能所斯寂则无相现前。三无愿门亦有三种相。一依止。谓依前入空无相方得无愿故。二体即无有愿求。不求三界等故。三胜即大悲化生胜二乘故。又上三空通缘诸法实相。观于世间即涅槃相故。亦不同二乘。余如智论二十二说。第二明离障胜中。先牒前修。由修得离故。初离三想是空门所离。次离有无想是无相门所离亦无愿门所离。不见有可求故。已知离障云何为胜。经中三句次第胜五四地。及此地方便故。谓于五地中以十平等深净心。远离四地身净我慢。此用深空灭离二我。故此胜也。二四地中。以道品治三地中正受出没等慢。此用空观以离作受故胜。三此地方便。但用十平等破显有无今此地满用深无相破遣有无。一切荡尽。故此胜也。第二大悲转增下。修行胜中二。先总明。修心悲增心中修故。是利他心为未满。菩提下。兼于自利。亦修所为。言悲增者。前观十平等已起三悲。今十门观缘。弥悲众生缠于妄法。后作是念下别显。于中二。先明修行。后而恒下。明修胜。今初又二。先发勇猛修行。谓励志始修故。后佛子下。明丈夫志修行。果决终成故。又初则悲智勇修。后则穷证性相。今初先智。后悲智中先知后厌。初中上二句明缘有合离。谓业惑相资有为方生。如无明缘行等。后二句明缘有具阙。集即是具。谓业惑随阙必不转生。如虽有行无爱润等。后我如是下厌。既知有为苦过必断和合集因。然为下。修悲益物不尽有为。二丈夫志修中。初厌相。见彼有为多过。是对碍法故厌之。后无有下。证性由了有为自性。同相本无生灭。便能灭于对碍而与理冥。第二修胜者。谓不住胜相现前故。有三种胜。一初二句明般若因胜。以是不住所以蹑前大智而起悲故。二即得下。般若体现胜。般若是通名无障碍智。是别称无碍佛智。虽未成就。今般若能照此智。此智前相名曰光明。光明即门也。三成就如是下。明般若用胜。亦是不住之相。谓上二句涉事不失理。故不住有为。后二句见理不坏事。故不住无为。即有为涅槃平等证故。以菩提下。不住所为智慧助道未满足故。不住有为功德助道未满足故。不住无为又俱未满故。俱不住。广如净名下卷。大品中亦云。菩萨念言。今是行时非证时故。即此所为亦是所以。第三明三昧胜中二。先明空定。后如是十无相下。例显余二。前中复二。先举十上首。后此菩萨下。总结多门。今初十中论分为四。一除第四前五名观。二以第四名不放逸。三以第七名得增上。四以余三名为因事。今初观是观解。前三就相观空。一入空者。是人空。亦是总句。二即法空。三即取前二空为第一义。观之亦空。后二就实观空。谓四观本识空。如来藏包含无外故云大空。五观七转识。不离如来藏和合而起。皆无自体故云合空。楞伽云。七识亦如是心俱和合生。又云。不坏相有八无相亦无相也。二不放逸者。依解起行行修究竟。故名第一。论云。分别善修行故。自分第一也。修行无厌足故。胜进第一也。三得增上者。因修成德功德起故。四因事者。依德起用故。有三种用。初一自利名智障净因事。谓分别是智障。今得如实空能净分别。后二利他。一教化众生因事。依空起悲故不舍离二愿。取有因事由得空故。故离染。随顺有故不离诸有。上依论解已为深妙又此十空。与涅槃经十一空多同少异。更依释之前八证实空。后二起用空。入空即彼内空外空内外十二入故。自性即性空。非今始无故。第一义空名义全同。第一空者。彼名空空。谓前空但空第一义。今明若有若无本来自空故。彼经云。是有是无是名空空。是是非是是是名空空。谓是非亦当体空故。如是空空。乃是二乘所迷没处。十地菩萨通达少分。故名第一。今亦约少分也。大空名同彼名般若波罗蜜。合即内外空也。合无合故起即有为空。八即无为空。如实即无为故。不舍等二名义俱别。若欲会者。九即无始空。无始不离生死而即空故。十即无所有空。谓离与不离皆无所有故。余结等可知。第四不坏心果。此下二段。亦即摄随顺坚固一切善根回向。此为进善后起大行。今初。不坏心者。由障灭行成。若智若悲皆不退坏。文有十句。初总余别。别有九种不坏。一信理决定。二行堪调柔。三不怖甚深。四自乘不退。五胜进无息。六泯绝自他。七利生无边。八上求地智。九巧化众生。亦可对前十三昧心以明不坏。恐厌繁文。九并坚固皆云不坏。十皆具足名悉圆满。第五自在力胜中二。初显其相。后佛子下结其分齐。前中十句。初总。不惧下别。总云此心者。此前十心顺佛菩提者。能深入趣向故。论云。得般若波罗蜜行力胜能深入故。则知此前十心皆是般若现前心也。别中九句。依上十不坏心而得自在趣向。一不惧异论即能伏他力。二上入智地名断疑力。得法空故。三自乘不动力。以离小故。四密处决信力。趣镜智故。此与前二前却者。此二相成故。五诸魔不坏力。以精进故。六治惑坚固力。住智明故。七遍治力。具三空故。处有不染故。八化生力即前第九方便相应。九智障净力。即前上求智。地前智居中导二悲故。此智居后。显悲智相异故。第二结中由般若现前故。顺忍明利。言第三者。三品忍中为最上故。第二位果中三果同前。就调柔中分四。初调柔行。二教智净。三别地行相。四结说地名。前中有法喻合。法中三。初炼行缘。次悉以下能炼行。于中闻已受持下是得义持。三昧慧光是所持义。随顺修行此句示现得义持因。因何事耶。谓因依前三昧胜故。得如实奢摩他等忆持不舍。正显能持。又得已下亦是所持。三经于下明所炼净转更明净者。解脱彼障故。又由前证得彼佛法藏义故。喻中真金喻证。亦喻信等。琉璃喻方便智。由方便智数磨。令出世证智发教智光转胜前也。合中方便慧即上不住道。合前琉璃。随逐观察合数磨莹。转更明净者。般若现前故。转复寂灭者。证智脱彼障故。二譬如月下明教智净。以月光宽大胜于前地。但取月轮为喻也。四种风轮者。出现品有能持等四种风轮。非今四轮。以彼不是坏散风故。有散坏风复无四种。未见经论不可定断。且就义释。即四时之风春曰和风。喻烦恼魔顺爱心故。夏曰炎风。喻于蕴魔多热恼故。秋曰凉风。亦曰金风。喻于死魔果熟收杀故。冬曰寒风。喻于天魔败藏人善故。行四魔行即是魔道。余文可知。摄报中言声闻难问无能屈者。已知二乘缘谛等故。第三重颂。二十二颂分三。初十七偈颂位行。次四颂位果。后一结说。前中三。初二颂一句颂胜慢对治。二有十偈三句。颂不住道行胜。三有四偈颂彼果胜。二中有三。初一句颂总显心境。次九偈一句颂别明观相。即为十段。第一有二偈半颂有支行列。二一偈颂摄归一心。既云心灭则生死尽。故知不可唯约真心。以真妄和合是说依心。即真之妄既灭。即妄之真不无故。起信云。但心相灭非心体灭。三一偈颂自业差别。四半偈颂不相舍离。五半偈颂三道不断。六一偈越颂第七三苦聚集。七一偈却颂第六三际轮环。八半偈越颂第九生灭系缚。九有半偈却颂因缘生灭。十有三句颂无所有尽观。第三十种下五句颂总结十名三如是下颂彼果胜中。初二颂对治胜。次一颂修行胜。次半偈颂三昧胜。后二句通颂后二胜。以义通故。位果等可知

大方广佛华严经疏卷第四十大方广佛华严经疏卷第四十一

        唐清凉山大华严寺沙门澄观撰

第七远行地。所以来者。已说缘起相应慧住。寄于缘觉。次说有加行有功用无相住。寄菩萨地故次来也。瑜伽云。前地虽能多住无相作意。而未能令无相作意无间无缺。多修习住为令满故。次有此来。又前功用未满今令满故。言远行者。通有四义。成唯识云至无相住功用后边。出过世间二乘道故。此有三义。同于本分已如前释。解深密云。能远证入无缺无间无相作意。与清净地共相邻接。故名远行。此有二义。初义即三中无相拣异前地云无间缺。后义由邻后地即能远去故。故下经云。二界中间此能过故。亦是前行后远。摄大乘云。至功用行最后边者。但是一义。世亲释云。虽一切相不能动摇。而于无相犹名有行者。此解功用之言。谓起功用住无相故。金光明经同深密初义。庄严论中同深密后义。虽有四义然通有二义。立远行名。一从前远来至功用边。二此功用行边能远去后位故。十住论云。去三界远近法王位。故名远地。仁王名远达地者。亦通二义。然其能远去行正是无相故。所离障离细相现行障。谓六地执生灭细相现行故。此生灭相即是二愚。一细相现行愚。谓执有缘生流转细生相故。二纯作意求无相愚。即执有细还灭相故。以纯作意于无相勤求。未能空中起有胜行。至此地中方能断之。以常在无相故不执生。更不作意勤求无相。故能证得法无差别真如。以了种种教法。同真无相故。以能空中起有胜行故。成方便度。二行双行乃至亦得无相之果。故知。以纯无相不碍起行。为此地别义。次正释文亦有三分。初赞请中有十二颂。前十赞。后二请。前中分四。初二天众赞说主。次一天主光云供佛。表智契法身故。三有一颂天众庆闻。四有六颂。天女乐音赞佛。于中初一显声因缘。余五正显赞词。于中初四赞寂用无碍。后一明起用所由。即悲智无碍将说双行。故承力赞此。后请可知。第二正说分中二。先行后果。行中有五种相差别。一乐无作行对治差别。二彼障对治差别。三双行胜差别。四前上地胜差别。五彼果差别。五中初一是趣地方便。即当入心。余四为住出心在果。又住中初一即初住地。次一正住地。次一说虽在后义该始终。后一地满。初言乐无作者。乐着般若观空故。即细相现行障。此地随有不着为能对治。二谓向虽能治前地乐空之心。以其有量有功用即复是障故。修无量无功用行。以为对治。三垢障既尽故。止观双行。四明此地功用过前六地。胜后三地。上即后也。五由地满故说双行果。今初分中有四。初结前标后。二何等下征显其相。三菩萨以如是下结行功能。四入已下彰其分齐。今初具足六地行已。即是结前义。含所治无相行故。以般若无相行满。于此生着非增上行故。次欲入下明其标后。十种方便即是能治。谓前乐无作不名方便。不能起增上行。非殊胜道。今以十种不舍众生法无我智。以为能治治前乐心。名方便慧。便能摄取增上行故名起殊胜道。是则即有修空故不住空。是空中方便慧。即空涉有故不住有。是有中殊胜道。道即行也。所行殊胜故名增上。于何增上。谓前所寄世出世中。即空故胜于世间。即能涉有故胜出世间。前六地中。虽亦修悲不住于无。而在寂不能出。空方作故。不得方便殊胜之名。虽行空行有而多着空。但名乐无作治。二征显中。所以胜行得增上无胜者。由下十义故。义各二句皆上句观空。下句涉有。上句得下句。即成空中方便慧。下句得上句。即成有中殊胜行。不滞空有并致虽言。论主摄十为四种功德。谓前三各一后七为一故。一初句即护恶行因事。菩萨恶行有其二种。一不乐利乐。二起爱见。今由上句故无爱见。由下句故能利乐。若二中互阙皆有恶行。今由二句护之。为无爱见之悲因事。二即财及身胜因事。由供佛故。获财及身。由得平等故。二事皆胜。胜财则随物所须。胜身随意取其何类。三护善根因事。善根即勤集福德为菩提资粮。今以即空智而集。是得彼胜因增上。令所集功德法皆成增上波罗蜜行。名之为护。虽有慈悲但是增上意乐故。三皆自利。后七同是利他。合为第四摄众生因事。即为七种。初一随物受生。次二化令离障。后四摄令住善。初中愿力受生。为作众生上首。故须庄严三界。但是愿生非由业惑。故云远离。二说对治故。谓示起烦恼。欲令治断而知性寂。方为第一义治。令见常自寂故。三为灭智障故。障有四种。如五地随世智中说。令随众生心作书论等无量事业。而为能治。四于大法众会集故。为物起严土行。此明依报下。三明正报三轮益物。五即身业无身现身者。令生五福。谓见闻亲近供养修行故。自身无身同佛法身故。下二亦然。六即口业。转法轮故。七即意业。于无长短中随问善释。记三世事起三世行故。第三总结胜能。中论释云。此十种发起殊胜行。共对摄取。对治摄取者。皆上下二句相对。名为共对。由此上下各能对治。皆上句治凡下句治小。随治不同义如前说。由二摄取名殊胜行。对治前障。四彰分齐者。明无相无间故。无相地名从此而立。此亦即摄前不退住。不同前六。前六得住地已舍入地心。以修解入非以行入。此以行入故。常行不舍名不退住。第二佛子菩萨摩诃萨住此第七下。彼障对治。即摄无著行。有量功用皆不着故。言对治者有二种相。一修行无量种。治前有量障。二此菩萨作是念下。修行无功用行治前有功用障。今初有二十句。摄成十对。一一对中。皆上句明境界无量为所知所化。后句明佛德业无量。为能知能化。菩萨入彼佛化以用化生。要则摄十为五。即五无量界。初一对众生无量。论云。随所化何等众生。此对为总。十对皆为利众生故。言何等者。类非一故。释经无量之言。随所者。随多类宜。而以无量化众生业而化故。二有一对。众生住何等处。谓住世界无量。以净土行化故。三有二对。以何等智慧化。初对横穷诸法智。后对竖穷三世智。皆是种智。二对约其所知。皆是法界无量。四有三对。明调伏界无量。初二对明以何等心。于中初对随众生信乐。种种天身菩萨以名色身化故。谓心随其乐同修天行。得天身故。口随其信。以名句身说彼行故。第二对知昔根欲不同。以随类音称根说故。次一对以何等行。谓知现在心行不同。以遍趣行说对治故。五有三对。明调伏方便界。论云。置何等乘。谓置三乘故。初对为声闻说智道。令证灭故。次对为缘觉说深智。令知因缘故。后对为菩萨说地度集成事。称彼方便涉有故。第二修无功用行中二。先加行趣求。后佛子此菩萨下正显修行。今初先牒前无量。为所趣求。我悉下要期以无功无相摄取彼境。无分别者。谓不取性相忘缘等照即无相观也。加以无功无相尤胜。然任放天性不由勤策。自然而行。亡功合道名无功用。八地方证。今要心住彼故云应以。由功用行此已满故。此则修行无功。非如八地任运无功也。二正显中。初牒前观智。次常勤修下是修行相。方便已下是所修法。即前空中方便慧。有中殊胜行。既以无功无相智。修能治功用有相之障。后安住不动显观成相。此即行成不动。非如八地相用不动。第三无有一念下辨双行胜。文分四别。一二行双无间。二常不舍下信胜。三此菩萨于念念。下能作大义。四佛子此十下菩提分差别。四中前三别显。后一总该。三中前一自分。后二胜进。今初无有一念休息废舍者。正显双行无间之义。谓不舍前不动之止观察之观。为止观二行双行。一念不休即无间义。次行住下显无间时。谓四仪睡寤举睡梦者。以昧况审。二信胜者。论云。彼无量智中殊异义庄严相现前。专念故者。专念忍可即是信义。常信前十无量。二严佛境故名为胜。三作大义者。一念顿具十度之行。义利广故念念修起。故名为作。文中二。先总明。后何以下征释。征云。十度行异一念宁圆。释文分二。先明能具所以。由悲智双运故。后所有下显所具之相。檀通悲智忍唯约悲。余皆约智。然此中十相。意令一念十相不同故。三檀等中随取其一。可以意得。理实无所不具故。下菩提分中。云一切皆满前六可知。但释后四。方便涉事云无量智。以是智故。又能出生施等行愿。以摄众生故名方便。愿中由此愿智。能求八地已上上上大波罗蜜。摄取彼胜行故。次力中以是智故。远离布施等障故。不为彼动智中。以是智故。布施等一切种差别如实了知。为化众生故。此四相皆从用立名。通成前六。亦有别成前六等。并如初会中辨。一念具十念念皆然。初心欲修至此方得。四菩提分差别中。有四种相。前二摄善。后二离过。一依大乘行。谓十度自利此即大义。结文为显十度通二义故。论将属后巧用经文。二四摄者。即依教化众生。三四持等。即依烦恼障增上净故。谓依四持为所住处。以三解脱为所依门。修行三十七品则得烦恼障净。任持自分故名为持。亦名四家所住处故。四者一般若家此是能照。二者谛家即是所照。三舍烦恼家。四苦清净家。由初二胜业离此惑苦。若约别说。初一见道前。次三即见修无学。四略说下依智障清净。以无所不具故。离尘沙无明。第四尔时解脱月下。前上地胜差别中二。初明胜前六地。二何以故菩萨从初下明胜后三地。胜即增上义。前中二。先问。问意云。若先已具此何独言若先未具何得成此。后答中三。初标次征后释。释中二。先别显此地胜相。功用行满。即自分满足。得入下胜进趣后。由此二义故能胜前智慧。即八地证智自在。即五通大用十自在等。二佛子下。通示诸地满相。即远释十地皆满足言。近释七地功用满语故。论征云。云何此地中方便行满足。方便即功用也。具十方便故。论自释云。彼余世间出世间中。更起殊胜行。是故此七地中起一切佛法故者。谓前三世间。次三出世。此则更互各一殊胜行。今一切中具起所以名满。初地愿中具。二地戒中具。三地闻中具。而云愿增长者。欲依如来智慧利众生。故余可知。七地一切者。瑜伽论中说佛功德。七地皆得八地。成就九地具足十地。圆满有少余障。未名清净。离已即是清净菩提。二明胜后三地。文中四。一法二喻三合。四因论生论。今初先征后释。征意云。何以前六各一至七。方具一切。释云。从初积集至此成故。此酬前征。由此便能令后三地胜行成就。斯乃胜后胜前。但约能入八地胜后。令后地无功行成。乃至十地。要由积功以至无功之功故。合中有杂染行。合杂染世界。然有二义。一即前六。二通前七有清净行。合纯净界。即后三地中间难过。亦有二义。一若六地为杂。则七地为中间。若七地皆杂。则从七至八即曰中间。难过者。犹娑婆之于极乐。净秽域绝。前六后三难过亦尔。要得此地大愿方便。方能越之。净由此到染由此过故。此一地最为胜要。四因论生论中。先问后答。问意云前后可知。但言中间为何所属。答意明非染非净亦得名为亦染亦净。故名中间。于中二。先通将七地对后彰劣。摄此第七通于染净。则成前七地皆是染净相杂。非纯染行故。论云。从初地来离一切烦恼。示现如是此地名为染净。非染行故。二佛子此第七下。别将此地对前彰胜。显此第七双非染净故。成前第七是中间义。今初通中有法喻合。法中初标离惑业显是净故。次以回向下释上净义。以二因故。后然未下。即由上二显同前染非报行故。次喻中轮王。喻七地随分舍功用道故。梵王喻于八地报得。初禅游千界故。然法中对问。但明前七。喻中举胜显劣故。兼明上地合文准此可知。第二别明此地双非染净。初总明尽超过多贪等者。尽超故胜前。求佛之心为贪。厌世为嗔。取空著有为痴。至此尽超。又初地超贪。檀度满故。二三超嗔。尸忍满故。三亦超痴。得闻持故。四地超慢。道品离我相故。五地超疑。了诸谛故。六地超见。入般若故。此地总超随惑等。常在观故。故云尽超。而云多者显非报行故。则细者未超。次住此下正明形前望后以显双非。后何以下释双非义。常在观故。惑不现行即过前也。有功用行名求未满。即劣后也。功用即是烦恼。以有起动故。第五佛子菩萨住。此第七下彼果分中。论主此中名双行果。此果实通诸分。以双行是正住行。亲生此果故。又以双行该于诸分皆双行故。名双行果。文分四果。一业清净。二得胜三昧。三得过地。四得胜行。远公云。初即彼障对治果。二即双行果。三即前上地胜果。胜行转增故。四即乐无作行对治果。以彼方便及起胜行满足在此故。又初一即自他二行双行。二即定慧双行。三即悲智等双行。四即寂用双行。就初果中复分四种。一者戒清净。于中初约性戒明戒。但三业净。后所有已下约制听明戒。则恶止善行。二世间所有下世间智净。此辨行用。三此菩萨下明得自身胜。此明行体。论云心行二平等无与等者。谓深心及妙行为二。深心即证行犹是前十方便妙行。即教行亦是前起胜行。此二齐起故云平等。不同前地有无间生。四诸禅下明得胜力。谓得禅等现前胜功德力故。上三自分此一胜进。文中二。初明离定障。禅等已见品初。论云。寂灭乐行故。此释三昧是现法乐住禅。次云灭定三摩跋提者。以三摩钵底有其五种。一四无色。二八胜处。三十遍处。四灭尽定。五无想定。前四菩萨多入为化众生。后一不入非圣法故。今于五中正意在于灭定故。论别明下解脱月亦因此言。问何位中能入灭定也。后此地下离智障可知。第二佛子菩萨住此地入菩萨下。明三昧胜分二。初别举十名后入如是下总结多类。今初前五自利。后五利他。又前五起解。后五成行。又前五现法乐住。后五利益众生。前中初二知理。次二知教义。后一知事。一云善观择者。依未观义伏心令观。二依已观义重更思审故。论经。云善思义三昧。三依一名说无量义故云最胜。四依一义说无量名。故云分别。义含于名故称为藏五依通一切五明处。如事实故。后五中初一依烦恼障净。真如观坚固根故。般若云不动法界故。真如观为坚。起信云。真如三昧为诸定之本故。此云根。此一显行深。后四依智障净以显行广。为治四障故。经即能治障在文外。四中初一助道。次二证道。后一不住道。初智通者。治胜功德障。智通即是胜德。下三仿此。以智与通化利钝二类。令入一实故名为门。二治无碍智障双照事理。二法界为业故。三治于深上佛法怯弱障。大悲胜利安住涅槃能建大事。是佛深上故。四治不住行障。种种义藏者。种种善根故。此善能生不住故名为藏。修有为善根故不住涅槃。修无为善根故不住生死。种种善根即无住之门。后结可知。第三是菩萨得此下明过地。于中三。一行修善巧过。二作业广大过。三修行胜入过。今初过法有二。一巧智二深悲。过相亦二。一下过二乘。二上过智地。智慧地即八地无功用智。由此地中双观止观。便至彼处法流水中。任运双流趣佛智海。二佛子菩萨住此下。作业广大过中二。先正显过。后解脱月下彰过分齐。今初中先对下彰出过。言无相者。即前乐无作。对治无量者即前无量对治。入定离相。二乘容有而非无量故。此无量显异二乘。善净之言显过下地。谓修方便行满足故。后得无生法忍光明。对上彰入过。是彼八地无生法忍明相现前故。下地未得故。二彰过分齐中二。先难即执前。同后难。后答即拣后。异前答。有法喻合。法中非自力者。障现行故。喻中王家即如来家。王后即得真法喜。修二利故名为王相。合中大法即法中佛果法。自所行者。即殊胜行。智慧力者即方便智。于此二中常不出观故。是自力能过。此约寄位广如初地中辨。余文可知。三佛子下明行修胜入过。谓非但如前广多无量。而力用难测深无分量。胜而过也。论云。神力亦无量者。神即难测义也。文中言甚深者。即远入无底故。远离者彼前障灭故。无行者无相之行。无所行故。彼前六地不能行故。常行者此无间故。得此三业即当体深入过。勤求下即趣后胜入。故二乘亦有离彼相业。而得少为足。不能上求菩提。求故过也。是故已下结双行过。第四解脱月下明得胜行。于中二。先得寂灭胜行。在定不住故。即方便智也。二佛子此菩萨下得发起胜。即起殊胜行。前中先问后答。答中先明得法分齐。六地入深缘起之实际。未念念入者有出观故。后今住下辨胜过劣。于中有法喻合。法中先正明得而不证。后此菩萨下出不证所以。以得方便。即寂起用故。成不思议三业故。能不起灭定现诸威仪。喻云善巧力者。知行船法。知水相故。准大品经。未善巧前亦有其喻。方便未成入水便败故。合云波罗蜜船。即般若等也。以愿力者。是方便不舍有因。二明发起胜行中。亦是上来已摄无著行。此下摄平等随顺一切众生回向。且依发起胜行文分为二。初牒前标后。由得灭定三昧。不作证智故。成后大方便也。后虽示下正显胜行。经有十句。论为八种共对治摄。谓后三为一故。能治所治二行共俱互相摄故。如示生死为所治。以恒住涅槃为能治。能治摄于所治。则不为生死所染。亦得以涅槃为所治。示现生死为能治。能治摄于所治而不证于涅槃。他皆仿此。八中初一为总。故云生死涅槃。论云。一起功德行。谓入生死为福业事故。净名云。生死畏中当依如来功德之力。不入生死海不得无价宝珠。何有功德。二上首摄余行。谓既示生死必为上首。摄眷属故。三愿取有行。非业所拘故。处而不染。四家不断行。谓虽言不染而示有妻子。名家不断。虽然不烧者。示有常修梵行故。唯此一句。具空中方便慧有中殊胜行。上下皆应仿此。从略故无。五者入行。谓非独化凡。亦转二乘入佛慧故。六资生行。谓虽知五欲即道含摄佛法。而饮食资身睡梦资神皆顺五欲。十军是魔境界。七退行谓示老病死衰。退即四魔等法不行其因名超魔道。八者转行。谓初四化凡。次一化小。次二化魔。今由自行不染故。转凡之惑今绝其因。此有三种。一见贪转。外道着诸见故。如佛示学二仙。今彼转舍诸见着故。二障碍转。如佛示学书算等。三所有下贪转。如佛处于王宫不生染着。第二位果。初调柔中文亦有四。初调柔行体中亦有法喻合。法中亦三。初缘。次于彼下能练行。言护持正法者。由方便行满守护于他故。得于三界为大师所以能护。三利益众生下明所练净。论云。此地释名应知者。即以经文为释名。谓利益众生是有中殊胜行。法忍清净即空中方便智。此二是行。善根转更增胜者明功用究竟。即是远义。喻中金喻证智信等善根。众宝间错者。即一切菩提分法方便行功用满足故。令前善根转胜。第二佛子譬如日光下明教智净。先喻后合。喻中光义如前地。而此日光盛故胜彼月光。以月光清凉如般若故。日光用广如方便故。余并可知。第三重颂。二十一颂分三。初十七颂半颂位行。次二颂半颂位果。后一颂叹胜结说。前中分五。初四颂乐无作行对治。次二颂彼障对治中无量。略不颂无功用行。三有三颂颂双行无间。四有五颂颂前上地胜分。言三诤息者。约忍度故。又得法光明故无有诤。五有三颂半颂双行果(已下入第三十八经)第八不动地。所以来者。瑜伽云。虽于无相作意无缺无间。多修习住。而未能于无相住中。舍离功用。又未能得于相自在。修习得满故次来也。又约寄位。初之三地寄同世间。次有四地寄三乘法。第八已去寄显一乘故。庄严论释第七地云。近一乘故。梁论亦说。八地已上以为一乘。是知从前差别进入一乘。故次来也。言不动者。总有三义。故成唯识云。无分别智任运相续。相用烦恼不能动故。谓任运故功用不能动。相续故相不能动。总由上二烦恼不动。与本分大同。而金光明云。无相正思惟修得自在。诸烦恼行不能令动。但有二义。由相于前已不动故。行即功用。摄论云。由一切相有功用行。不能动故。此则略无烦恼无性。释意云。第七地行动相不动。此中行相俱不动。世亲同此。解深密云。由于无相得无功用。于诸法中不为现前烦恼所动。此但约烦恼不动上二。十住论云。若天魔梵沙门婆罗门。无能动其愿故。此即约人不能动。人亦是相。仁王名等观地者。上皆对他立名。此约当体受称。即无相观。下经自有释名至彼当知。若不动名。诸论虽异并不出前三。故所离障。亦离无相中作加行障。由有加行。未能任运现相及土。此地能断。说断二愚。一于无相作功用愚。二于相自在愚。令于相中不自在故。其所证如名不增减。以住无相不随净染有增减故。即此亦名相土自在所依真如。证此真如现相现土皆自在故。故所成行亦名无生法忍。相土自在。及所得果。即定自在等。皆由无相无功用故。次正释文亦有三分。初赞请中有十二颂分二。前十赞后二请。前中二。初二天王天众供赞。后八天女乐赞。于中二。初二标赞所依。余六正显赞德。总赞如来身土自在。将说身土自在地故。于中毛端约刹论处。毛孔约身。六中前四依正互在。五依正重重。六转变自在。兼结无尽。后请可知。第二正说分中二。先地行后地果。前中有七种差别。一总明方便集作地分。二入一切法本来无生下。得净忍分。三佛子菩萨成就此忍下。得胜行分。四佛子菩萨住此第八地以大下。净佛国土分。五佛子菩萨成就如是身智下。得自在分。六此菩萨如是入已下。大胜分。七佛子此菩萨智地下。释名分。七中初二是趣地方便。一是远方便。总前七地集作此地方便故。二是近方便。前地得忍光明。此修熟令净故。三是初住地行。谓依前净忍发起胜修故。次二即安住地行。谓四是正住之始。依前胜行。更起修净佛土之行。五即正住之终。由净土行成德无碍。六是地满行。此地望前通皆是胜。今复地满。胜中之胜故云大胜。七即辨德彰号通于始终。又前二分即是入心。余是住心。今初分二。先标集德处。谓总前七地非独第七。第七虽亦有下十法而非次第。以是功用行满无功用际故总集之。即四节中当第三也。后善修已下正显所集。有十一句分二。前三同相。诸地通行故。后八别相。诸地异修故。同中三句。一二种无我上上证故。此即证道地地转胜。名上上证。巧证不着经。云方便。二善净诸道者。不住道清净故。悲智双运故名为诸。三善集助道者。彼方便智行所摄。满足助菩提分法故。方便是前证道。行即不住道。悲智等行故。菩提分即是彼二所摄之助。助彼二故。后大愿下别相摄八为七。一初地大愿摄持能至此故。二二地摄善戒中如来力加故。彼经为证十力四无所畏等故。是故我今等行十善等。即上承佛力。三地中因修自证禅定神通。名自善力所持。四常念下。论云。四地中所说法分别智教化智障净胜念通达佛法者。谓前十法明门。是智分别即前观察。依彼智明入如来所说法中。次教化智。即彼经清净分中。以十种智成就法故生如来家。障净胜者。即彼论释谓灭三地智障。摄四地胜智故。上之二段皆念通达佛法故。与此同。五地中有十种平等深净心。故云善净深心。此心即是思觉。六能成下六地中三种大悲故。云成就福德。三皆观因缘集。即成就智慧。七中二句以近此地故。初空中方便智有中殊胜行。皆是大慈大悲不舍众生行。次句即前以无量众生界。故入无量智道。第二净忍分有十五句分三。初十正明无生忍。次四明无生忍净。后一结得忍名。然无生忍略有二种。一约法。二约行。约法则诸无起作之理。皆曰无生。慧心安此故名为忍。即正明中意。约行则报行纯熟智冥于理。无相无功旷若虚空。湛犹渟海。心识妄惑寂然不起。方曰无生。即净忍中意。前一犹通诸地。未得于后不称净忍今初段中言一切法者。总该万有理事之法入即证达。以历事难穷。略陈其十。十中相从为四无生。前七为一名事无生。后三各一。二自性无生。三数差别无生。四作业无生。四中一破相。二破性。三因泯。四果离。即前二破相入如。后二证实舍相。若寄位初加行。二正体。四后得。三通始终。又四中约法性收不出真妄。妄法本空称曰无生。真法离相亦曰无生依佛性等论说三性无生如初会说。事无生中前四不增正显无生。后三不减亦即无灭。法本不生今则无灭。以初摄后皆曰无生。别言七者为治七种实故。实者随相执定故。一净分法中本有实。谓计自性住性为事物有。今为治此故云本来无生。本性离故。先若有生后应灭故。二新新生实。计习所成性为实。治此云无起。从缘起故。三相实。即计前二性所生行相。治此云无相。前二能生无故。四后际实。谓计于佛果后际出缠。治此云无成。真如出缠非新成故。菩萨成佛时烦恼作菩提故。上四初一自性住佛性。次二引出。后一至得果性。又此四展转释疑可知。五先际实。谓对佛果后际。众生烦恼为先。治此云无坏。烦恼即空。无可坏故。菩萨未成佛时菩提作烦恼故。染净和合以为众生。前遣净分。此遣染分。又前即不空藏。此即空藏皆不可得。六论。云尽实诸众生者。谓执众生念念尽故。拣上烦恼故。特云诸众生。故上经云。一切凡夫行莫不速归尽。治此云无尽。其性如虚空故。七论。云杂染实净分中者。谓修行位中转染向净。治此云无转。若定有实不可转故。论经云不行。谓能转之行不可得故。第二无性为性者。即自性无生。此则显诠。论经云非有有性者。明非有彼定执自性。此则遮诠。遮显虽殊义旨不异。无性即是法无我理。此理既以无性为其自性。则自体无性。非是先有今无。亦非全无真体。故云为性。以前观事无生正忍此理故。故论云彼观事故。是此忍不得言无。斯则非有非无以显中道。此二亦不二。又此理亦非所观事外故。论云。所有观法无我理。无二相故。斯则非即非离无二为中道义。第三初中后际皆悉平等者。即数差别无生。于三时中。染净法不增减故。谓先际非染增净减。后际非净增染减。中际亦非半增半减。以知三际皆空无自性故。然准瑜伽。前三句约三世。此中约位以明三际故。论就染净明之。第四无分别下作业差别无生界位。作用名业差别。如智贯之则无差别。无差别即是无生。下如是理如上如是智如。智如于真理故无分别。此智是佛究竟入处。今菩萨证如同佛入处故。论云。于真如中净无分别佛智故。如是四种皆是示现无生忍观。第二离一切下明忍净中。初句离障。后三显治。前言离者。论云示现行远离。谓契实舍妄名行远离。拣非心体离也。所离一切略有二种。一离心者。离报心忆想分别。谓第八异熟识转现遍行。亦不行故。二离意识者。离方便心忆想分别。论云离摄受分别性想故。谓六七识及中心所等。亦不行故。是则心行处灭名离一切想。后无所取下明治。上但明所治非有。今明能治不无故。论云。想者远离障法想。非无治法想者。治即无分别智。所以明此有二义故。一拣异断灭外道无想二乘灭尽故。二拣异如来。尚是照寂。非寂照故。故云。此想于下地有三种胜。一无功自然行故。云无所取着。谓无取果心任性自进故。此显治妙。二遍一切法想故。云犹如虚空。此显治广。三入真如不动自然行故。云入一切法如虚空性。此显治深。此则入于起信离念相者。等虚空界无所不遍。法界一相故。云入一切法如虚空性。然论云。不动自然行者。任性趣故。非谓有彼自然行心故。上离即止。此治即观。无功双运唯证相应。勿滞言也。结名可知

大方广佛华严经疏卷第四十一大方广佛华严经疏卷第四十二

        唐清凉山大华严寺沙门澄观撰

第三得胜行中二。初明深行胜对前彰出。二佛子此地菩萨下。发起胜对后彰入。前中亦是摄童真住。文中二。先结前生后。以入第八地。是结前入位。生后深行为所依故。二为深行下正显深行。先法后喻。法中八句。初一总相。位行玄奥故。余七别相。一难可知者。即难入深。正是对下彰出。二无差别者同行深。与诸无漏净地菩萨同故。如麦在麦聚故难知差别。三离一切下境界深。分齐殊绝故。由所取相离能取相不现前故。复言离一切执著者。护此地一切所治障想故。四无量无边即修行深。自利无分量。利他无边故。五一切等明不退深。二乘不能坏其胜故。前句当相辨大。此句寄对以明。六离诸諠诤即离障深。谓离功用障故。七寂灭现前即对治现前深。以证真如为能治故。一切寂灭。上七别中相从束为三分。能离前地四种恼患。谓初三明此地境分殊绝。离第四微细想行过。谓求如来智犹未息等。次二明正行广大。离前第三化生勤方便过。谓十无量等犹有勤故。后二明离障寂灭。离前二过。一离第二净地勤方便过。即前修无功用日夜常修。及行住坐卧皆起道等。二离第一有行有间发过。此之四过如地持说。瑜伽名四灾患。义次亦同。第二喻中文有三喻。从后次第喻前三段。为顺治障从细至粗故。法中显深故从粗至细。三中各有喻合。今初灭定喻喻前离障。寂灭喻中那含罗汉心解脱人多能入之。九次第定当其第九故云乃至。动心息者。谓所依六七心王已灭。能依心所忆想自亡。合中住不动地合入灭定。即舍已下合动心止息。即舍一切功用行者。过所治故。得无功用法者。明得彼治法故。身口等息者。以得无功用法自然行故。即同前无所取着。离第一有行有间发过。住于报行者。文含二意。一亦成上示现得有功用行相违法。谓得无功用地故。此约教道同前无所取着。二者谓善住阿赖耶识真如法中故。此约证道。同前入一切法如虚空性。即离第二净地勤方便过。不同前地修无功用故云报行。报行者。前地所修报。熟现前故。住真如者。以本识有二分。一妄染分凡夫所住。二真净分。此地所住。由住真如故舍黎耶之名。又佛地单住真如。不云黎耶真如。今为有变易报在。是故双举。则黎耶言约异熟识。如来但名无垢识故。第二梦寤喻。喻前正行广大。论云示此行护彼过想者。离彼化生勤方便过故。有正智想者。非无此地无功智故。如从梦寤虽无梦想非无寤想。但此行寂灭。故云所作皆息。合中勇猛约心精进约行。合上方便并是功用。二行已下出所息障。依内证清净。生死涅槃二心不行。名二行不现。如彼寤时此彼岸无依。外缘境界受用念想不行。故云相行不现。即离化生圣道等想。如彼寤时人船俱无。合中见人堕河喻中身自堕者。众生病即菩萨病故。第三生梵天喻。喻境分殊绝。合中初正合下地。心意识不现。合欲界心不现行也。所以不行者得报行故。此离微细想行过故。论云此说远离胜也。后此菩萨下举胜况劣。谓佛等不顺行世间一分心等尚不行。况顺行世间一分心耶佛心等者。即七地求如来智心也。此中但况世间。亦应以大况小。大尚不行况小乘耶。则若世若出世若人若法若因若果。若智若断皆不行也。第二明发起胜行。此下亦是摄尊重行因。劝起行皆尊重故。胜亦尊重之义。文中四。一说主总叙。二作如是下正显劝辞。三佛子诸佛世尊下显劝所为。四佛子若诸佛下彰劝之益。今初愿即劝因。如第三劝中。论云本愿力住故者。回文未尽。应言住本愿力故。诸佛世尊下总显劝相。诸佛所以与智劝者。转彼深行乐足之心。令入法流门故。法流者。决彼无生止水令起无功用行河任运趣佛智海。即以能趣为门。又法流者即是行海。言与智者有二意故。一现与觉念犹彼意加。二令起修取故名为与。下之七劝皆佛智摄故。但云与智。前地未净此忍故此方与。以得此忍摄德本故。一与之后不复欲沈。二正显劝辞中有二。先赞将欲取之必固与之。后然善男子下劝于中有七。一劝修如来善调御智。二劝悲愍众生。三劝成其本愿。四劝求无碍智。五劝成佛外报。六劝证佛内明无量胜行。七劝总修无遗成遍知道。远公摄七为二。前六举多未作转其住心。后一明其少作能成增其去心。经无此文。论似有意于理无违。今摄为三。前三劝其下化。初一化法。次一正化。后一化愿。次三劝其上求。初一折其所得非胜。后二引其求佛胜果若外若内三最后一劝总结多门。以所作无边别说难尽故。然七皆含转住增去。今初有三。一明多未作以未得修十力等。教授众生法故。二汝应下劝令修习。三勿复下莫舍忍门。然舍有二义。一若以放舍身心。住此忍门。斯则不应故云勿复。是以论云。若不舍此忍行。不得成就一切佛法。此令舍着。二全弃舍则所不应故。论云。依彼有力能作故。故云勿复放舍。此令依之。第二劝中三。初明自所得忍。二然诸下明他无忍起过。在家多有烦恼。出家多起觉观。皆是众生无利益事。三汝当下劝起悲心。悲心依上而转。第三劝中愿有二种。一依广心下化众生。二皆令得下依大心。然有二义。一令他得二令自得。自得佛智。依此智行能广利故。第四劝中有三。初法性真常定其所尚。次诸佛下夺其异佛劝其上求。以有深无碍智大用无涯。方不共二乘故。后一切下抑同二乘令不住忍。三兽渡河同涉理故。功行疲倦趣寂为垢故。应勿住。第五劝中举身相等六。皆是化生事业。若成就此法。则有力化生故。劝修成就。第六劝中有三。初明其所得未广。次善男子下示佛无量胜行。无量入者。所入法门差别故。作是法门业用。转是业用上上不断。后汝应下结劝。第七劝中二。先举三种无量。即净土中三自在行。后悉应下结劝明少作在。既言悉应通达明少分观察。即能成就去佛非遥。此同德生劝于善财。勿以少行而生知足。故云无量。第三显劝所为。令起智业故。第四彰劝益中亦是所为。为是故劝。于中二。先明不劝之损。故不得不劝。后以诸佛下彰劝之益。是故须劝。今初有二。一自损既不与智即入涅槃故。应须与故。论二即入涅槃者。与智慧示现。二者损他不利生故。问始行之流尚修无住。岂深智地取灭。须劝。颇有一人佛不与智。便取灭不。答有四义故。是以须劝。一为引斥定性二乘。明菩萨此地大寂灭处犹有劝起。况彼所得宁为究竟。二为警觉渐悟菩萨乐寂之习。三为发起始行无厌上求。四为显此地甚深玄奥难舍。所以须劝。但有此深奥法流之处。必有诸佛作七劝桥故。无一人便取永寂。又设佛不劝亦无趣寂。为显劝益假以为言。第二劝益中有法喻合。法中三。初牒前与智彰益之因故。论云。彼行中摄功德因胜故。云何胜。诸佛同作教授说故。二于一下起行速疾。三何以下释疾所由。谓先唯一身故长时劣。此一念此地身等无量故。一念顿超有十一句。前十别明。后一总结十中初六依教化众生。次二依自集助道。后二依障清净。十中一多身随现。所以多者。论云。一切菩萨身。信解如自一身故。谓智契同体故。能即一为多。此实报能为不同前诸地变化。此对前一身余音声等。对前起行类亦无量。二圆音随说。三随所知智。四随取何类生。五随应以何国。六随其教化何类众生。七随供养集福德助道。八随入何法门集智慧助道。九随神通障净。十随智慧障净故。能处无量众会随机说法。皆言随者。随宜非一。释无量言故。随时之义其大矣哉。后一结释中。先结。谓起行众多不离三业。后以不动法故者释。由无相无功无有间断故。相用不动任运集成。喻中船喻彼行速疾。论云。应知因胜示现者。释疾所由。船由入海故疾。行入无生故疾。合中初合未至海。即前七地。次到菩萨下合若至海。即第八地无生之智。亦是行故名为行海。又顿能遍起即深而广。亦得名海。无功用智以合上风。一切智境明其趣果。前喻所无。以无生智同佛智海故。喻不分。本有已下合前校量。大文第四净土分者。问经中但云大方便智一切观察皆如实知。广说化生应形作用。瑜伽论中十自在。前起智门。后但云得分身智。何以论主判为净土分耶。答净土有二。一是能净之因。二是所净之果。此有二对。一相净果。谓宝严等。以行业为因。谓直心等。二自在净果。谓三世间圆融等。以德业为因。谓净土三昧等。今约后对。然净土行业始起在凡。满在十地。净土德业始起不动终在如来。文分三别。一器世间自在行。二众生世间自在行。三智正觉世间自在行。初是化处。次是所化。后是能化。具后二净方名净土。然初一多约能净。后二多约所净。文影略耳。就初分二。先总标举。无功用智为能观智。智所行境为所观。方便善巧即无功用因。在于七地修无功用。今得自在。后所谓下别显其相。有五种自在。一随心欲。二随何欲。三随时欲。四随广陜欲。五随心几许欲。今初观世间成坏。论云。随心所欲彼能现及不现故者。谓约能净。论随随自心欲。知即能知故约所净。论随随众生心乐欲见者。则现成现坏。不欲见者则不现。故经云观知。则唯约因。论主欲显义兼于果。故云随现即转变自在。下之四段随现准知。二由此业下明随何欲。谓随物欲知何业。成坏皆能现故。三几时成下明随时欲。谓随时长短即能现故。若约能净即随时智。如此世界成二十劫。初劫成器余成众生。坏亦二十。先坏众生。后一坏器。并称事称理名如实知。四又知地下。随广陜欲彼能现故。文中三。初知四大差别。即是广相。二知微尘下是知陜相。三随何世界所有地水下。知能所成。即双明广陜相。今初中小相者。非定地报识境界。大相者定地境界。乃至四禅缘三千故。无量者如来境界。上三是事分齐。皆以境界智知。差别相者是法分齐故。以相智知。知其自相同相差别故。后类余易了。二知尘中细者透金尘故。论经次云粗相者隙尘故。差别同前。无量差别者。一尘之中含多法故。尘之粗细俱通定散故。不云小大。三知能所成中二。先总知内外。二知地狱下别明六道。斯即楞伽责所不问。意显穷幽。又云无性故。第五又知欲界下明随心几许欲即能现故。文中二。初约智知自在。上即三界互望论大小。今即一界之中自分大小。欲界中人境为小。天境为大。色中觉观为小。无觉观为大。无色界中论。云佛法中凡境为小。声闻菩萨为大者。为拣外道妄取为涅槃故。特云佛法。如来所知一切三界皆名无量相。第二佛子菩萨复起下。约通明自在随物现化。文中三。一随机现化。于中初标能化智。次所谓下明所知机。有三句。一知身类不同故。二知随身宜用方便异故。三生何等界能利生故。后随其下正明随化。虽言现身意在生处故属器界。二此菩萨于一三千下明化分齐。三此菩萨成就下明现自在。谓不动而遍犹月入百川。第二佛子此菩萨随诸众生身心下。明众生世间自在行。谓随感能应调伏众生自在故。于中三。初总明感应。二所谓下别显感应。于中显化生行有二自在。一化同物身。沙门中现沙门形等故。即身自同事。二又应下化应物心。以身不必同其所化。即心自同事故。论云。彼行化众生身心自同事。三佛子菩萨如是下总结感应。如是如是者现类众多故。若身若心无偏顿应故。论结。云自身心等分示现也。第三佛子此菩萨远离下。明智正觉世间自在行。远公云。若就行境应名二谛自在行。今就行体名智正觉。智于二谛正觉无碍。故名自在。今更一释。以所知十身皆是毗卢遮那正觉之体。亦得从境名智正觉。能令相作亦自在故。文中二。初明第一义智。后此菩萨下明世谛智。今初。上句离妄。下句住实。由自身他身不分别故。住于平等。不分别言非唯照同一性。亦乃能所照亡。论云。此不同二乘第一义智示现者。以彼不得法空。不能即俗而真非一异故。二明俗谛智中有三。一总知十身。二此菩萨下。令十身相作显通自在。三此菩萨知众生身下别显知相彰智自在。今初十身。论摄为三。初三染分。次六净分。后一不二分。皆言分者。同一大缘起法界分为十故。即染分依他净分依他。同依一实故。染中三者。初是众生世间。次国土世间。业报身者彼二生因。谓业烦恼。经略烦恼。故论具之。而云报者。业能招报从果立名。若是所招宁异上二。然国土身合通于净。且从一类以判为染。次六总以三乘为净分。于中前四是人菩萨及佛。但因果之异。次一是能证智。后一是所证法故。论云。此三乘随何智随何法。彼净显示。谓因法智殊显三乘别。后虚空身是不一。分者通为二依。非染净故。观下别显。多约事空义兼于理。二诸身相作。皆先明相作所由。由随机故。文中二。一别显相作。略有四翻。云何法智虚空得为自身。入法智中自然应现自己身故。令于虚空忽见自身。故名为作。作余亦尔。二随诸众生下总结例余。上但举四翻。理应具十成一百身。然自身即是菩萨若将自望菩萨别。则有百一十身故云则如是现。所以相作得无碍者。广如悬谈。今文略有三意。一由证即事第一义故。事无理外之事。事随理而融通故。此章初先明胜义。二者缘起相由故。三业用自在故。晋经偈云。菩萨于因缘和合中。自在乃至能随意。为现于佛身。今经略无此偈。论主但释相作之意云。彼自在中所作摄取行种种示现者。谓彼正觉自在中。作摄取众生行故。随心乐种种示现。第三别显知相中。十身为八。以三身合故。然其类例应各具十。文或阙略。且从显说。初众生身有五相。初三业生烦恼妄想染差别。此约总明三界。后二约上二界。即就报开别。若总开三界五趣则具十矣。二国土身具有十相。前八一切相。后二真实义相。前中初三分齐相。即小中大千。次二染净差别。次广即宽陜差别。此略无陜。次二依住差别。真实中一重顿入名为普入。十方交络故云方网。又重重现故。多同初地。三四二段共有四身。皆云假名差别者。但有自相同相差别。假名分别实无我人。余亦假名。偏语此四者。业因尚假苦果可知。圣人尚假况于凡类。又三乘圣人方能知假。佛德超绝不得云假。五知佛身自有十相。余之九身既是佛身。一一有此则已成百。若更相作则重重无尽。菩提身者示成正觉故。二愿生兜率故。三所有佛应化故。拣异猿猴鹿马等化故云应化。即王宫生身。四自身舍利住持故。上四于三身中皆化身摄。五所有实报身。无边相海等拣三十二等。故云实报。即三中报身。六所有光明摄伏众生故云威势。即通报化。七意生身者。论云所有同异世间出世间心得自在解脱故者。同谓同类。异谓异类。世即地前。出世地上。谓若凡若圣若同若异。由得自在解脱故。随意俱生。即种类俱生无作行意生身也。此通变化及他受用。八福德者。所有不共二乘之福。能作广大利益因故。故种少善根必之佛果。九法身者。所有如来无漏界故。斯即所证法体故。离世间品十佛中名法界佛。诸漏永尽非漏随增。性净圆明故名无漏界。是藏义生义含无边德。生世出世诸乐事故。十智身者。所有无障碍智。谓大圆镜智已出障垢证平等性故。次云此智能作一切事者。即成所作智。彼事差别皆悉能知者。即妙观察智。此通四身但两重十身。一一圆融故异诸教。六知智身。有十一相摄为三类。初二约体分别。初通闻思。二即修慧。俱通理教。次果行相即因果分别。行即是因通于三慧。果唯证入。相离前三。余有八智皆约位分别。于中初一是总。世间俗智名之为世。三乘圣智名为出世。又道前名世。见道已去名出世。五三乘者。于出世中大小分别。小乘十智等。中乘七十七智等。大乘权实无量。六七二相于大乘中粗妙分别。甚深般若不共二乘。相似般若是则名共。八九二相通就三乘缚解分别。于新熏性习未习故。后三通于三乘修成分别。七知法身。前能知智。此所知法并通一切。智法不同。前佛法。智唯局如来。文有五相。一平等相即是理法。论云无量法门明等一法身故者。谓法门虽殊同诠平等法身。生佛无二故。拣理异事皆世谛门摄。二不坏相即是行法。论云如闻取故。谓称理起行名如闻取。行符乎理则冥之菩提。名不可坏。三即教法。随所化众生根性相应时说差别故。理本无言假言显理。若权若实皆是随俗假名。四即重显理法。所遍之境此通染净。平等法身遍情非情故。五即果法。唯约于净故。论云。第一相差别。三乘同证第一义故。随智有异三种不同故所显理亦说深浅。若约功德等异如常所辩。八知虚空身文有六相。一无量相。芥子中空亦无分量故。二遍至一切色非色处故。三不可见故。今世人见者。但见空一显色想心谓见。故涅槃经中广破见空。又此含无为空故。亦不可见。四无异相者。无障碍故。谓不同色法。彼此相异有障碍故。五无为相。谓无始终起尽之边故。六能通受色相持所持故。故下经云。譬如虚空宽广非色而能显现一切诸色。既因色分别彼是虚空。则知因空显彼为色。大文第五自在分中分二。初牒前为因修行三种世间自在行故。得十自在。此但约智通说。若依摄论以六度为因。如下别明。二得命下显自在果。命自在者不可说不可说劫命住持故。心则无量阿僧祇三昧入智故。财谓一切世界无量庄严。严饰住持示现故。上三以施为因。如次以一切时一切处一切物施故。业则如现生。后时业报住持示现故。生则一切世界生示现故。上二戒为因。戒调身语。成胜业故。复由戒净随欲生故。愿则随心所欲。佛国土时示成三菩提故。此则由进策勤无懈废故。解则一切世界中佛满示现故。论经名信解摄论名胜解。皆一义耳。用忍为因以修忍时随众生意故。得一切皆随心转。谓变地为金等如意。则一切佛国中。如意作变事示现故。以定为因。智则如来力无畏不共法相好庄严。三菩提示现故。法则无中无边法门明示现故。上二同以般若为因。内照所知得智自在。应根宣说得法自在。于此十中若智若通皆无壅滞。故云自在。论以此十治十怖畏。一死怖畏。二烦恼垢怖畏。三贫穷四恶业。五恶道六求不得七谤法罪业。八追求时缚不活。九法自在。治云何云何疑。十智自在治大众威德。此二如论。次此十亦即初地五畏细故。渐开此中。二四七即是恶名。恶名本故三六属不活。九属第十故。约因此地方得约果。圆满在佛。此约行布。下离世间上贤首品皆有此十。而约普贤位通贯始终。大文第六得此已下。明大胜分于中三。初智大智解殊胜故。二业大行业宽广故。三彼二所住功德大智业所成故。今初文有五句。初句牒前为因。则为下正显显有四智。初一为总。谓不住世间涅槃寂用难测。名不思议。此不思议有三。一修行尽至不思议。谓证涅槃无分量故。二所知不思议广照世境故。三除障不思议令真如出所知障。天魔外道不能坏故。第二此菩萨下业大有三。初二句牒前为因。一入自在。二成就智。次得毕竟下正显业大。三佛子下总结多门。正显中有十二句。初三明三业净当相辨业。后九约修辨业摄为四相。初一句明起。论云能起。能起同时。谓身语意是所起。智慧为能起。此三业起必与能起同时故。经云。随行智为导首故。二般若下四句。智摄不染作利众生行等。谓由般若摄彼大悲故。不染爱见能起方便利众生行。三善起下二句因摄。谓内白大愿为自行他行之因。又外蒙佛摄。得成二因。四后二句作业所持。初句利益众生。后句净佛国土。后总结可知。第三佛子菩萨住此下。彼二所住功德大中三。初标所住分齐。次得善下显所住德。三此菩萨下结成功德。二中十句依七种功德。谓初四为一善住道功德。此是德体以二利行为菩萨道故。初二自利先契理离障。名为深心。后对治坚固名为胜心。后二慈悲利他。后六各一约修辨德。初三三轮化益。修上利他。后三愿行相符外招佛护。修上自利。三结成中近结此段远结前三。得如是智结前智大。以智证理得无憎爱故。次能现下结作业大平等作故。后于诸下结所住功德大。得七功德无过咎故。大文第七释名分。亦摄如相回向。称如不动等故。释名分二。一地释名即约法明位。二智者释名。即约人彰德。今初十句论摄为六。远公复摄六无二。初二自分后四胜进。胜进中复三。初一发修离过。次二因修成德。一成教道德。二成证道德。后一依德成位。亦有斯理。言为六者。一初二句名染对治。一治下地功用行小乘愿诸魔业。故名不动地。二治烦恼习行故名不转。上二即相用烦恼不能动也。二次一句得甚深故可知。三有二句发行清净。上句发净。谓得真无漏。三业无失不破观心。能发趣行。然其八地应对八住合名童真。而论经名王子。似不顺文。下句行净。正行之时离障自在故。四次二句名世间出世间有作净胜。上句悲故随世有作。自无所作。下句出世有作以智善分别。故智障净故皆决定义。五有一句彼二无作净胜。谓于世出世名为彼二愿力变化而不滞寂。故云无作。即无住涅槃。六有二句菩萨地胜。即分位过。前上句胜六地。以六地观空为他有动。今念念发起殊胜行故。下句胜七地。上依论释。今更指文别为一解。谓此诸名对前经立。初二从净忍分受名。得无生忍入不动故。此句为总。此智现前故无退坏。次二约得胜行分受名。一得为深行菩萨不可知故。二离一切相等诸过失故。次三约净土分受名生地。谓器世间自在随乐生故。成地众生世间自在。随物成身自无作故。究竟地智正觉世间。决二谛故。次一约自在分。随愿成就方名自在。次一约大胜分。得深心等十种力持故。后无功用通该始终。依此释者。似若论家阙指明据。第二佛子菩萨成就下。智者释名中三。初牒前为因由得智地故。二入佛下正就人显。三于无量下总结所住。就人显中。以何义故菩萨名为得不动地。有二义故。一一向不动。谓行修上顺故。二一体不动。谓与诸菩萨行体同故。文中先总明。后常为下别显。今初文有四句。皆含二义。论总释云。佛性随顺因故。佛性即初句。以梵云驮都译通界性致译。论经云。得入佛性即是法身果性故。论云佛性者。界满足胜故。究竟见性故云满足。此即分齐境界。菩萨由得地智。能上入之。随顺因者。即下三句由三为因故。能随顺佛境。一摄功德。佛功德照者。善清净义故。谓以无垢慧善照佛德。即是摄义。二者行。谓正行威仪顺同佛故。三者近。即佛境现前近如可睹故。后别明中。先明一向不动。论经十句今经阙一。初一总显佛加。解参玄极上德被己故。既常为佛加故。名一向不动。余句别依五种功德。以显不动。一供养功德即梵释四王。论经王下有奉迎之言。二守护功德。谓金刚等现形卫故。三依止功德。恒不舍三昧故。四国土清净功德。即能现诸身差别。若器若众生皆能随现。故云无量。五于一一下教化众生功德。此复五种。前三自分后二胜进。一愿取诸有多为主导。故云有大势力。二根心使智力。即报得神通穷三际中众生根欲等故。三无量法力。三昧自在转法轮故。四受力。彼经云。能受无量记故。今经阙此。五说力即随有可化示成正觉。真能说故。论经此后更有一句。结云是菩萨如是通达。论云一向不动故。二佛子下明一体不动。文有十句初总余别。总云入大乘会者。谓入同类大乘众数故。入数者不破坏义。和合如一故。别有九种具此九种堪入众数。一智不坏。获法智通故。二说不坏。谓放教智光故。三解脱不坏。谓不住行证入空有等无碍法界业用无碍故。四佛国清净不坏。知世界自在故。五入大乘不坏。智能示现大功德故。六神通不坏。随意自在故。七善能下能解释义不坏。称三际说故。八普伏下坐道场不坏万行。及菩提树下伏魔邪故。九正觉不坏。入如来境同佛觉故。第三总结。所住中行无障碍。不断不转念不退故。第二位果调柔中。先调柔行。法说中受世界差别等。无量法明者。等取众生智正觉故。论名彼因相故者。以所受法为自在因故。喻中真金作阎浮主冠者。喻得清净地身心胜故。以此地中报行纯熟。三世间自在故。特加于王。无与等者。喻善根光明转更明净。三佛子譬如下教智净。梵王普放光明者。胜前日光。一多故。二净故。三广故。第三重颂分中二十二颂分三。初十八偈半颂位行。次二偈半颂位果。后一结说分齐。今初颂上七分即为七段。初一偈半颂集作地分。二一偈半颂净忍分。三有七偈颂得胜行分。于中二。初二颂深行胜。后五颂发起胜。于中云但以甚深无碍智者。长行所无。故知唯念法性。则同二乘事理。事事皆无障碍。是菩萨学故。晋经全有一偈。云但以得无碍甚深微妙智通达三世故。乃得名为佛。又此一句亦可总颂余劝。四有六偈颂净佛国土分。于中三。初二器世间。次三众生世间。后一智正觉世间。五有半偈颂十自在故。晋经。云能得于十种妙大自在智。六一偈颂大胜分。七一偈颂释名分。密迹者。古译为力士余文可知也

大方广佛华严经疏卷第四十二大方广佛华严经疏卷第四十三

        唐清凉山大华严寺沙门澄观撰

第九善慧地。所以来者。瑜伽意云。前虽于无相住中舍离功用。亦能于相自在。而未能于异名众相训词差别。一切品类宣说法中。得大自在。为令此分得圆满。故次有此来。言善慧者。摄大乘云。由得最胜无碍智故。无性释云。谓得最胜四无碍解。无碍解智于诸智中最为殊胜智。即是慧故名善慧。即下文中。十种四无碍是也。庄严论云。于九地中。四无碍慧最为殊胜。云何胜耶。于一刹那。三千世界所有人天异类异音异义。问此菩萨。能以一音普答众问。遍断众疑故。此同下文。金光明云。说法自在无患累故。增长智慧自在无碍者此兼显离障名胜。深密意亦同此。瑜伽住品十住论成唯识等。文辞小异义旨无殊。仁王名为慧光者。言兼法喻。智论名善相。从所了得名。能所虽殊皆明说法之慧。故所离障离利他中不欲行障。有四辩故。四无碍障分成二愚。前三为一。名于无量所说法。无量名句字。后后慧辩陀罗尼自在愚。谓所说法是义。名句字是法。后后慧辩是词陀罗尼。自在愚通于上三。二辩才自在愚。即愚第四无碍故。所证真如名智自在所依。谓若证得此真如已。于无碍解得自在故。便成善达法器自在说法行。梁论云。由通上真如。得应身果。金光明中得智藏三昧皆一义耳。次正释文。三分之内。初赞请中有十三颂分三。初二如来现相显说无功用行。无动之动难思议故。特此现通。次十颂别赞后一颂结请。别赞中亦三初一菩萨供。次一天王供。后八天女供赞。于中二。初一供余七赞。赞中二。初一标赞。后六显词。于中亦二。初二赞菩萨通于八地。及说法主。后四双赞佛及菩萨。三轮化益。此又云菩萨幻智。后结云赞佛已故。文中通赞八九地。如月普现前地有故。此法师位随机说权实故。文中三。初一身无心而普应。次二口随机而演说。后一喻结心常契中。既特云最胜智心示如来法。权实明矣。故璎珞经中说十种善。前九依三乘人各成三乘。第十名佛乘种性。谓初闻佛法即发佛心。唯观如如修佛智慧。终不为悲愿缠心。一向不起二乘作意。第九为悲愿缠心故。此云慈悲乐饶益。明文若斯云何不信。第二正说分。先明地行文有四分。一法师方便成就。谓此地能起辩才说法。名法师地。趣地行立名方便故。二智成就具能知法之智慧故。三入行成就。达所化器之心行故。四说成就称根正授故。四中初一入心余皆住心。亦摄三位至下当知。然第八地中。但净佛土教化众生。此地辩才力故。教化众生成就一切相。能教化故。一切相者具上四分故。初分中三。初牒前起后。前得二谛等智故。次欲更下正显方便。三得入下结行入地。正显中文有十句。不离二利。论云。一一五三句示现者。初句利他次句自利。故云一一。次五利他。后三自利故云五三。示现之言通上四段。初句依无色得解脱想。可化众生利益他故。化其令得大般涅槃。故云转胜论主谓菩萨不求自灭故作此释。然经既云更求寂灭。何妨自求。以七八九地同得无生。八地得忍寂灭现前。依劝起修。此求上品名为转胜。即用而寂真解脱故。若依此义前二自利。亦可十句俱通二利。于理无失。且依论解。二依未得究竟自利益故。复修习如来智慧。三依根熟菩萨化入如来秘密。三密化益故。四依邪念修行可化众生令观察不思议智得正念故。谓观无念见智性故。五依未知法众生转法轮。令得知故。寂净陀罗尼三昧门。皆说法所依故。六依邪归依众生。具广大神通令入正法故。七依信生天众生。令入差别世界佛净土故。上五中一无证二无行三无解。后二无信下三自利中。入依正觉内证智德故修力等。九依转法轮外化恩德。十依无住涅槃断德。第二佛子菩萨住此下智成就。此下二三段摄王子住。知法知根皆法王轨度等故。且依智成文中。初总知三性。谓净染不二。不二即无记。后有漏下展转别开。一于净法开漏无漏。谓施戒等取相心修与漏相应。名为有漏。无漏反此。二于无漏开出见道已前名世。见道已去名出世。三即就上二世出世异名为思议。即世出世名不思议。亦可于出世中约教证二道。四彼有漏思议中定能证入。名之为定。为缘所动名为不定。亦可。佛性定。有余一切法皆悉不定。三聚定等下文自说。五总上诸善开出三乘。谓谛缘度等。皆通上四故。唯佛果一是唯无漏等。而属菩萨乘果。六于三乘法中示有为无为依顺行故。此是善体故后明之。谓灭谛缘性彼岸真理皆名无为。道谛缘智能证修起皆名有为。如来一切皆是无为佛智。有为非极说故。涅槃令覆有为相故。三乘圣人依此起行。依此差别故名顺行。第三此菩萨以如是下。明入行成就。此中三。初总标章门。二此菩萨如实知下。依章广释。三佛子菩萨随顺下总结安住。今初有十一林。一众生心者是总故。论云依共。以通是下十染净共依故。菩萨依此而知故名为依。下依义准之。余十是别。不出三杂染故。论云依烦恼业生生是苦果。今当第九。论释余七云。依共染烦恼染净等。依定不定时。谓次根等四同是业故名共。随眠即烦恼种名染。眠伏藏识令心染污故。受生即生如前已说。余二通三故不出三也。二云何通。谓习气无别体。是染净等气分故。三聚但是约时定不定故。论又别释根信性欲相似之义。云彼复定不定时根等次第。根等相似信等者。由下经文。以根例三故。此重释相似之义。亦须约时故云彼复定不定时。约何论时。亦约根等四事次第也。云何次第。谓根等相似似何等耶。谓信等故。如宿习名根印持名解。依根起解故云次第。解必似根故云相似。习解成性性必似解。依性起欲欲复似性。若相似未熟时即名不定。熟名正定。全无邪定故。时依根等。论经名解为信是信解故。十皆名稠林者多故名林。难知曰稠。论经十林皆有行字。谓不正信义故。名心行等稠林。心行若绝证信圆明。非稠林行。然此十名多如发心品辩。而习气一通于二义。一者残习。二者种子熏习如下当辨。第二依章广释文分九段。以解性欲合一例故。今初心中三。谓总别结。别中略举十门。摄之为八。二三后二合故。一差别相。心意及识六种别故。此八缘境许得齐起。故名杂起。又杂起者必与所俱。极少犹有遍行五故。二速转下二句明行相。四相迁流故。速即是住。住体轻危速就异故。转者是异坏即是灭。不坏是生故。论经但一句。云轻转生不生相。论云住异生灭行故。三无形质者。第一义相观彼心离心故。云何离。谓心身不可得故。身者体。依聚义。即同起信心体离念等。四无边际。即自相顺行无量境界取故。取境不同故名为自。上之四相初一是所相。二是能相。此二并心之相。三是心之空性。性相不同合为心体。四即心用。此四并通染净。后四明净心随缘。由第五随烦恼缘成六七。随业生缘成第八。谓第五清净者。自性不染相。即自觉圣智真妄所依不空性也。染而不染名自性净。次下二句即不染而染。谓六垢无垢者。即同烦恼不同烦恼。相随缘有垢性恒离故。七缚不缚者。同使不同使相义不异。前但种现有别耳。八有二句同名因相。随因受生故。菩萨以幻智愿力生故。余众生随业诸趣生故。第二释烦恼稠林。亦三。别中九句摄为三种事。后七合故。一远入相乃至有顶故。此约四住现行。下至金刚自约种说。久者无始常随故。二无边引起者难知相。言无边者。修习无量善根故。引起者引起惑故。惑与善俱所以难知。即胜鬘中恒河沙等上烦恼也。上明竖深此辨横广。三俱生下七句。合为染相。即三杂染。谓此烦恼亦与业生二俱起故。即分为三。初三句当体明烦恼染。一俱生不离者明随所缚。此句总明能所。所缚即妄心。谓惑与妄心递共同事。故云俱生。生即是事。然离惑不名妄心。离心惑依何住故。迭共相衣名为不舍。二眠起一义者。是以何缚。谓使为能缚使即随眠。起即现行。现行由使不得解脱。以现及种同一惑义故。然下辨使不必与现行俱。此中现行必由于使。如有种子未必有芽。若已有芽必依种子。故云一义。三与心相应不相应者。是所缚事事即真心。若被妄染名与相应。是缚非解心性净故名不相应。示可解脱。二随趣下有二句。约生明烦恼染。论云身事生道界因故者。苦报集起名身事生。上句是道因下句。是界因。三爱见下二句。约业明烦恼染。初句明于三分中业因障解脱故。言三分者。爱是欲求中追求现报受欲行者。见是邪梵行求。痴是欲求中追求现报习恶行者。故论云。无戒众生为现少乐。习众恶行愚痴之甚。慢通上三。而多属见。有求属生染所摄。故此略无。上三俱障解脱过患难拔。如箭入木故。外道得非想定。尚与见慢相应。上即论意。亦可见爱等通七识中烦恼。故云深入。下句明此惑随顺世间身口意业。不断起因故。结中八万四千烦恼随好品自明。贤劫经中亦有其相。第三释业亦三别中。十句为九种差别。后二合故。初一道因差别。谓通说三性为六趣因。引双唯善恶各有三品。二地已说满业通三性。名言熏习亦通三性许为因种故。又俱舍十七以三性因对五种果。无记亦能招果故。论主通以三为道因。或既不招异熟则论主言总意别。二有表示等者自性差别。然论经此句云作未作相。此则并以思为自性故。论云。此有二种。一筹量时。此在意地。唯有审虑一种思故。释未作义。二作业时。释经作字有决定思。若在身语唯发动思。成唯识云。动身之思名为身业。发语之思名为语业。然今既云有表示等。即表无表业各通三业。表则三皆是思。无表则非心非色或说色收义如别说。三与心同生不离者。方便差别心共生。熏心不别生果故。谓此业思与等起意识共生。随其善恶生。已即熏本识成名言等种。种似能熏故云不别生果。即不离义。四因自性等者。尽集果差别谓无始业因以是有为故。自性刹那坏故云尽。此显非常而得持至果。功不败亡故云集果不失。此显非断前念虽灭后念续存。故云次第。亦是因即顿熏果。则次第如识等五也。五有报无者报。论云。已受果未受果差别。过去生报业现在已受。名为有报。后报未受名为无报。非谓全无。更有一理。谓已悔之业则许无报。有报可知。六黑黑等众报者。对差别。谓四业相对成差别故。初二黑白相对。后二漏无漏相对。言黑黑者。即四中初一因果俱恶故。又因果俱与无明相应故。即三涂业。等者。等于余三。谓二名白白业因果俱善故。俱与智明相应故。即色界善业。三黑白业。即欲界善业因中善恶杂故。受报亦爱非爱杂。四非黑非白业。谓诸无漏业无异熟故。对上黑白二业立双非名。言众报相者上三有报故。论云业集成就故。若俱舍意。其黑白业约相续说。以无一业及一异熟是黑亦白五相违故。言相续者。谓或意乐黑方便白。如为诳他行敬事等。或意乐白方便黑。如愍弟子现粗语等。若以义推。正以谄心而行敬事。亦可同时。余广如杂集第八。俱舍十六。七如田无量者因缘差别。谓识种为因业田为缘。随田高下等殊。令种亦多差别故。论经云业田无量相。八凡圣差别者。即已集未集差别。出世未集世已集故。九十二句定不定差别。前句明三种时报定不定。谓现作现得报名现受。现作次来生获报名生受。现作第三生去方得报名后受。于此三中各有定不定。谓前二时定报通定不定。后一时报俱通定不定。第十句明乘非乘定不定。乘即三乘唯修自乘业名定。乍修此乘复修彼乘。名为不定。非乘谓世间无运出义故。定者难度不定易度故。结中亦言八万四千者。惑因既尔所起之业亦然。根等诸门皆成八万。翻此即显波罗蜜门三昧门等。第四释根中二。先别后结。别中十相为九差别。五六合故。一说器差别。谓说法所授之器。信等五根有下中上故。亦是钝中利。谓于教理受有迟速及多少故。二根转差别。过未为先后际。现在已定两望论差。谓前上中下根。于三际中互望转变。若后转为中上。前根则下。后转为下前根则增。是差别义。不转则平是无差别。故论云前后根前根下增平故。三三性差别。谓约菩萨等三乘根性。相形为上中下故不同。第一通于三乘。四烦恼染差别。谓喜乐等五受根。随贪等烦恼得增上故。五六二相明定不定差别。初句乘非乘皆约熟不熟明。大乘中熟者定。不熟者不定。小乘中熟者不定。可转向大乘故。不熟者定。各随自乘而解脱故。若世间非乘熟者不定。可化入道故。不熟者报已定故。且暂舍之。即离世间中待时方化清净舍也。后句淳熟调柔一向是定。六随根网轻转坏者。顺行差别。此知眼等根顺行境界。得增上故。于中有三种顺行。一依身顺行。谓六入展转迭共相缚。如网鱼鸟不得解脱。故云根网。此行内境。二生灭顺行。谓体是有为。生住不久故云轻。易可异灭故云转坏。三观行取相顺行。此行外境。即论经云取相。今文阙此。或根网中收。七声闻净差别。望凡夫二乘行增上故。以二乘根由灭障能成故。烦恼无能坏。八菩萨净差别。此通三种退不退也。九远随等者。示一切根摄差别。谓三无漏根。总摄诸根。三者一始行。即未知当知根。二方便即已知根。正在修道故名方便。三报熟者。即具知根。谓前信等共三无漏根生而随优劣。三位不同。自始至末故名远随。此之三根。于修无学涅槃得增上故。此上九中。初二约信等。三五七入并约三乘。通于诸根。四约五受。六约眼等。九约三无漏根。二十二根已明十九。男女命根不足可辨。余如俱舍根品粗说。即然细分无量故。结云乃至八万四千。第五例三稠林。谓解性欲。此三与根性相顺入举一可反三隅故。皆略例。第六释随眠。先总后别。总中晋及论经皆名为使。论云随顺逐缚义故。如世公使随逐众生得便系缚。即是随眠。眠伏藏识随逐缠绕故。此唯约种不同小宗。别有十二句。论摄为二。前六明何处随逐。后六明以何随逐。今初为五。一合初二句。约心明处。初句于报心随逐。正显眠伏藏识。即久安眠处。而言深者。无始来有微细难知故。下句于非报心随逐。即转识分别。事识不离现事而生。故但云心。即暂回转处。二相应不相应者。约三界明处。唯与当界心相应。不与异界心相应故。故论云。欲色无色。或上中下差别。无色惑微所以名下等。虽则随眠性皆成就。随其现惑亦有不相应义。三久远随行相者。约地明处。论云随顺乃至有顶故。然有顶之言。通有二义。一至金刚之顶。二至三有之顶。今取通大小义。直云有顶。论经但云远入。今云久远亦无始来上至九地顶故。四无始不拔相。此约时明处。处既无边时亦无始。唯智能怖随眠怨贼。既未曾有闻思修智故。不能拔出。五与一切禅定等者。此约行明处。由随眠随逐。令世间禅定等不能灭爱见等心。不能随顺正修行故。名为相违。故下偈云。禅定境排仍退转也。后三界下明以何随逐。即显随逐之相。由此相故。名为随眠。此有六种。一于上三有不断随逐。所以三有不断相似相续者。由有此使作系缚故。如世眠者不能起床。二远时随逐。即于上无始时。令心相续现起无边。如世眠者梦心相续。三开诸处门者。一身生随逐。谓于前一身之上报非报心。明随逐也。如世眠者梦中见闻。于中二义。一令眼等诸根门。集生六种识时。使与同生故云开门。此明外逐方便心。二论云及阿赖耶熏故。此明内熏报心。论经门字下更有集字。即阿赖耶集起之心。然是诸处通依故。今经义含耳。四坚实难治。即不实随逐。谓修禅等时不得真实对治故。不实坚实如世重眠。不得重触大声无由起故。五地处等者微细随逐。此于上有顶处九地中六入处。烦恼身随逐故。然九地有二义。一约三界九地。虽并成就细故不知。成处多少名不成就。如世眠者梦中谓觉。二以善慧为九地。十地犹有故名微细。不成就者。此地中分有断除故。故下偈云。金刚道灭方毕竟故。六离苦随逐。谓唯无分别智。出世间圣道方能拔出。如眠得触。第七释受生稠林中。十句先总后别。论通为八。一身种种。谓形类多故。二业因种种。三住处种种。四四五二句色想上下种种。五同外色因种种。谓田等取外同喻故。六自体种种名色与识俱生。相依不离是报自体故。七本顺生因种种。谓痴爱为本顺生求有。令有续故。八末后二句集苦谛种种。谓三求不同皆是集因。但集苦果故云种种。上句显欲有二求。欲受即欲求。贪爱共取追求不已故。欲生即有求。爱生三有自得胜身。复摄眷属故。言无始乐著者。显上二求之过。下句即邪梵行求。由心取着故。不知三界轮回贪求三界。小大无量之相妄谓涅槃。谓或拍腹为道。或计无想非想为涅槃故。第八释习气中。亦先总后别。总云习气既通二义。不可局于罗汉余习。虽标习气别中皆言熏习。熏谓熏灼。如外香气习。谓习学。唯约有情习。必能熏以成气分故云习气。即赖耶识以为所熏。以恒住一类是无记性。可受熏故。前七转识以为能熏。由有生灭力增盛有增减故。能所共相和合故名熏习。此如摄论及唯识第二。若依起信。真如亦能内熏。佛善友等以为外熏。内外和合以成气分。前中虽闻教等亦因识能领受。故判识为能熏。今并通。此文中既有因熏与果等。定知熏习种成为气分义。别中十种差别。一与果现在非现在差别。谓过去善恶业因。与今现果同起名行。不同起名不行。如人行施。今得人身亦常好施等。此即因习。二随趣熏者。道熏差别。如从天来今犹鲜净。广明道习。如大威灯光仙人所问经。此即果习。上二皆是对过说今。三随众生行者。亲近众生熏差别。此是缘习故。宜远恶近善慎所习也。所以昔王不立厩于寺。而立之于屠。四随业等者。功业烦恼熏差别。功业者。释经业字。谓是起作事业拣非业因。如锻金之子宜教数息等。烦恼习者如人喜眠眠则滋多等。五善不善等者。善业等熏差别。此业即是业因。以是善等三性望来果称业故。如久行施者施心转浓等。上三唯约现世以明习气。六随入后有者。中阴熏差别。中有即是本有后故。如梵行人至中有内。亦无染欲。七次第者。与果次第熏差别。谓修善恶业。于后有位。诸趣之中受果次第。习亦与果次第无差。上二约现望后以说熏习。八不断等者。离世间禅因熏差别。谓诸无漏定名离世间禅修学无漏即是彼因。由未断烦恼。虽修无漏亦为烦恼牵。烦恼随。至无漏名为远行。行亦入义。九实非实者。同法异外道行解脱熏差别。同法释实。即三乘同佛法故。异外道释非实。在佛法外故名为异。行者上二之因。解脱者上二之果。各有熏习好习本法故。曾修小乘今虽学大。先发小习余可准知。此即邪正双明。约修证说。亦含三乘余习之相。十乘熏差别。唯就于正约其见闻故。法华安乐行令不亲近二乘。恐习成种故。上来十种前七约时。三世三有互望明习通于善恶。八明恶随于善。后二约人种种习气。皆能了之。令成如来无习气之习气智故。第九释三聚稠林。亦先总后别。论通为五。总即第一有涅槃法无涅槃法。三乘中一向定差别。无即邪定有即正定。各于自乘定故。离此不定。论略不释。此就种性约位以明。外凡无涅槃。三乘圣人定有。内凡不定。又约一期久远非究竟无。二善行恶行因差别。此约解惑以分三聚。谓正见是善行因。邪见恶行因。二见定起二行名之为定。言二俱不定者。无正慧决择。又不拨无因果。率之则可清升。任之则便鄙替故曰不定。下不定仿此可知。故论皆不释。三恶道善道因差别。此约行业以辨。四外道声闻因差别。此约位以分。翻彼八正名曰八邪。外道邪位定。正性离生圣人位定。已入见道故。前三善根则名不定。五菩萨差别。此约修大乘者得失以分。着邪是失所谓六。蔽圣道为得即六度等。第三总结安住文属入行。论意总结前三。故云前三种事成就。方能安住此地。大文第四住此地已下明说成就。亦摄善法行。辩才饶益多同彼故。文中二。先牒前总显。谓了心行方善说故。后佛子下广显说成有三成就。一智成就。谓知法知器知化仪故。二口业成就能起说故。三法师自在成就。得陀罗尼等成彼德故。各有佛子以为拣别。今初分二。先明随所知之法。二一切下随所依之器。此二何异前文智成入成。前三各别而知。今此总收以法逗器。今初所知法。即三乘一乘解脱差别。各含教证教道。以将化生令器熟故。证道以将度生令得解脱。体正度故。二随所依中文有三节。初总明。次能随下别显。后令生下结益。论主通收为七种器。一说所说法对器。自释云随应度者授对治法故。即总中二句。下句是说所说法。上句即所对之器。别中初能随及后而为说法。即上说所说法中间根等诸林。即是所对之器。于中准论经。众生下有心字。即是心稠林。通为五种器。初众生心根性欲解。明所说法器成。谓十一林之中。此五正显已成信等法器。可随根欲等说故别显之。二所行有异。含其二义。一约能行之行。名种种异行器。即上根等能行。二所行之境。即上根等所行名譬喻器。总喻上五故。如世稼穑具五因缘。彼所种物成就堪用。一有心物。二有根益其生力。三有可生性。四含润欲发。五决定可生。喻上心等故云譬喻。四诸聚差别者。即定不定根转器。亦通上根等。五亦随下随辞辩器。以彼生烦恼业熏难舍。要作同行巧辩方能化故。三结成益。即随乘因能乘出器。以上诸义不出自乘解脱故。第二佛子菩萨住此下。口业成就。曲分为二。先总明具说之德。二以无量下正明口业成就。今初亦是智成就。以具法师行即是智故。而言说者。护如来法藏通于说故。斯则内持于智外口说故。何名具法师行。深妙义中具二十种功德故。一知时二正意。三顿四相续。五渐六次。七句义渐次。八示九喜十劝。十一具德十二不毁。十三不乱十四如法。十五随众十六慈心。十七安隐心。十八怜愍心。十九不著名利。二十不自赞毁他。广释如论。涅槃具七善知名大法师。与此略同。慈氏论说具十德者。名大法师摄义具足。一善知法义。二能广宣说。三处众无畏。四无断辩才。五巧方便说。六法随法行。七威仪具足。八勇猛精进。九身心无倦。十成就忍力。会之亦同。第二正明口业中。先略明。后此菩萨以法下广显。今初先显名体。谓外由菩萨美妙言辞而演法义。名四无碍辩。内由智起名四无碍智。次辩体者。此智即无漏后得为体。故云善巧。即上知法知机智也。义无碍解或通正体。次此菩萨下约位显胜。以初地分得此地任运。故无暂舍。后何等下征列名字。智缘法等无拘碍故法等皆智境界。从境分四。一法者法体。谓法自体有轨持故。即二空所摄。即真之俗境故。论云。远离二边生法所摄。如色碍相等。二义者。法境界体。调于法体上差别境义。即上二空所摄真谛之境故。论云。即彼远离二边生法所摄中。如实智境界故。然得此真智者。由菩萨于生法二执所摄境中。以智安住求彼色等。但是虚妄。即俗而真是彼色等之中别义。上即远公之意。其犹不生不灭。是无常义。亦可。不约二谛。法约自体义约差别。谓十一色等虚妄分别之相。即是别义言如实智者称事实也。三词者正得与众生。谓得彼方言与他说故。故论云。于彼如实智境中。随他所喜言说正知。此释正得随他言说正知而与故。此释与众生。四乐说者。正求与无量门。谓乐说乃辞中别义。七辩剖析名无量门。论云。于彼随他所喜言语正知。无量种种义语随知而与故。二广显中。理实此四通该一切。且约圆数以列十门。各有复次。论云后五是净者。谓三乘行果。则显前五是三乘教理。通于染净。言十者。一依自相。谓知事法体各殊故。二依同相。谓知理法。若性若相各有同理故。三行相。此约时辩法。三世迁流故。上三知义即是所诠四说相。此知教法。上四皆约所知。五智相。此约能知。六无我慢相。此约所离明净。七小乘大乘相。此约所行。上二通辨诸乘行果。后三别约一乘。八菩萨地相此约因行。后二知果。九如来地相约体。十作住持相约用。然上十中法义则别。后二多同。皆词则说于法义。乐说乃词中别义。亦有以词说于法。乐说说义。十中皆四无碍。即四种相。今初自相有四种者。一生法自相。谓知色是变碍相等。二义者差别自相。谓知色有十一处等。上二约总别以分法义。后二同体义分。三想坚固自相想者。起言所依。亦以慧心取彼二种相故。一随自所觉诸法相。二随彼彼所化言词所宜相。以所觉法随彼言词为彼生说。说无错谬名为坚固。论经云。不坏者坏即错也。四彼想差别自相想义同上。但以次第不息。以多异名坚固彼义。令他爱乐名不断尽。此自相一门是总故。论前总中亦依此释。诸经论中亦多依此。第二同相。约性与相分于法义。一一切法同相。谓诸法同以无性为自性故。二有为法同相同生灭故。谓观无常门生灭相得入初句。法无我性故。无我智境得成。是则生灭是常义也。三一切法假名同相。故云安立。所立之法已是假名。更以言诠假名而谈名不断说。四假名假名同相。谓不坏前假名。更能以异异无边假名说故。重言假名。第三行相中。约三世以分法义。一生行相现法缘生故。设知过未亦名现在。以三世皆是当世现在故。故论云。过去未来彼彼世间摄受故。二已生未生行相。设知现在亦名过未。以现是过家未未家过故。是则当世而知名法。逆见过未能知现在。是则名义为菩萨智境。三物假名行相。总说三世之物不谬故。四说事行相。然所说事不出三世。总相物中故云一一世。但曲明异异事法。故云无边法明。第四说相中。约本释以分法义。一修多罗相故但示法。二解释相所以名义。三随顺相。随类言音故。四相似说相。谓随心乐闻何法宜。何譬喻说似彼心故。第五智相。约法类以分法义。一现见智。二比智比即类也。然所知境即是二谛法。比等智是无碍体。从体立称不同前后。又法比等智通于大小。四无碍智唯局大乘。故涅槃说。唯菩萨有。声闻设有少故名无。若就二智所观并通大小。约能观智唯局大乘。于大乘中。依观所取能取以立法类。一法智观如故云现见。谓观差别二谛同如不异故。二比智即观前能观。如实分别之智。类余亦尔。类何等耶。比知如前。差别即如实故。三欲得方便智。谓此是相见道依真假说。后得智摄故云世智。若欲得第一义假说以为方便。四得智。谓虽以世智说。而与第一义相应非颠倒异。方名乐说故。云善巧。可以证得第一义故。余如唯识杂集各第九。瑜伽十六说。上回向品疏已略明。第六无我慢相中。约真俗以分法义。一第一义谛无我。故云一相。言不坏者不坏无我故。若言我知无我我证无我。则坏无我。以有能所故。二世谛无我故云蕴等。迷蕴著积聚。我迷界着异因。我计种族别故。迷处着欲我计为生门。能受入故。迷谛缘起著作。我皆明因果有造作故。并是法我亦通人我。今随顺观察世谛缘生无实。以为对治得入第一义法无我。名善巧方便故。蕴界等是菩萨智境所治之我。三说美妙无我。惬情称美顺理为妙。四说无上无我故云转胜。词中差别故曰无边法名。第七大小乘相中。约权实以分法义。一观相。谓一观不异唯一事实故。二性相。就彼根性有三乘故。三解脱相。会彼三乘同归一实。解脱相中无差别故。论云。依同解脱不惧者。法华云。今我喜无畏但说无上道故。四念相即开方便门。随机念异心行不同。以多法明说诸乘法。然皆为一事。故论云随顺解脱。第八菩萨地相中。约地体相以分法义。一智相。一切菩萨行者总标也。何者是耶。谓所证法行能证智行。何以此二名菩萨行。以智契如故。故经云智随证。论云观智说故。此菩萨行即十地智体。二说相。谓体虽一智相有十地分位故。然此分位由心差别故。论云十地差别者。谓心而名说相者约口言也。以论经云义无量者。说十地别差故。作是释斯则异前义大。三与方便相。谓巧说十地授与众生。不颠倒教授与地证道无有差别故。四入无量门相。入诸地相差别故。第九如来地相。约真应以分法义。谓一法身相。即始本无二之法身。故云一念成正觉。二色身相种种时者。随何劫中种种处者。随何国土依报事。各差别者。随何等佛身正报事。三正觉相。通说正觉十佛差别故。四说相佛德无尽故。说亦无尽。第十作住故相。约诸佛能说德所说声教。以分法义。一觉相。即作住持德觉法性相故。语者随自意语随他意语。随自他意语。此能说法故。十力破魔憍慢。无畏伏外道。不共异二乘慈悲故。常说辩才故。能说方便者随顺物机。转法轮者正说。此上皆一切智智随证。二差别相。知佛随心种性等差别声教故。三说相。用前音声差别说故。四彼无量相异异说故。随信解者。示现菩萨无尽乐说故。以如来智等者。诸佛法身以利生为行。此行合智故。无垢清净不可破坏。故云圆满。此地分得故用之而说。第三佛子菩萨住第九地下。法师自在成就中二。先牒前标后。二得义下正显成就。有四种事。一持成就得不失故。二说成就巧能演故。三问答成就断疑网故。四受持成就更受胜法故。则前三自分。后一胜进。又前一释得妙法藏。后三释作大法师。于此四种皆无缚着即摄第九回向也。今初分二。初列十持。持先已得。后此菩萨得如是下用前十持。持当所得。今初先列十持。并从所起业用立名。初三起意业。次三起身业。后四起口业。一持义二持教法。三持能知智。四善软者慈光摄受。五刚强者善慧降伏种种施为故。六上供诸佛下摄贫穷故名众财。七于大乘中陜劣众生。示教大乘威德胜利令生喜故。八不断辩才智常说故。九无尽乐说深说故。十种种义乐说广说故。后如是下总结。以百万下显持之用。二持当得中闻已不忘。正显持义。为他演说亦持之用。第二此菩萨初见下明说成就。于中三。初显所受法多。二此菩萨得如是下能广开演。三此菩萨处于法座下。明起说自在。第三佛子此菩萨假使下。问答成就。初一界答难。二明一切世界。第四佛子此菩萨复更下受持成就可知。第二佛子菩萨住此下明位果。三果同前。但初调柔见佛缘中。初依内证近佛法身。后依三昧见佛色身。余文可知。第三重颂分中。二十四颂分三。初十九颂地行。次四颂位果。后一结叹。今初具颂上四分。初二颂法师方便。次二颂智成就。次七颂入行成就。四有八偈颂说成就。于中初半偈颂智成就。次二偈颂口业成就。其中诸喻长行所无。后五偈半颂法师自在成就于中初一偈半颂持。次一偈颂说。次一颂问答。后二颂受持兼颂问答

大方广佛华严经疏卷第四十三大方广佛华严经疏卷第四十四(已下入三十九经)

        唐清凉山大华严寺沙门澄观撰

第十法云地。所以来者。瑜伽意云。虽于一切品类宣说法中得大自在。而未能得圆满法身现前证受。今精勤修习。已得圆满故。有此来。论云。于九地中。已作净佛国土及化众生。第十地中修行令智觉满。此是胜故。以八九二地同无功用故。对之显胜有此地来。又一乘中最居极故。次释名下自有释名分。今且略解云者。是喻略有三义。一含水义。二覆空义。三霔雨义。约法就喻则有多义。云有四义。一喻智慧。二喻法身。三喻应身。四喻多闻熏因。空亦四义。一喻真如二喻粗重。三喻法身。四喻梨耶。摄大乘论云。由得总缘一切法智。含藏一切陀罗尼门三摩地门。此喻含水义。总缘一切法契经等智。不离真如如云合空。总持三昧即是水也。又云。譬如大云能覆如空。广大障故。此喻覆空义。即以前智能覆惑智二障。又云。又于法身能圆满故。此有二义。一喻霔雨义。即上之智。出生功德。充满所依法身故。二喻遍满。即前之智自满法身耳。故金光明云。法身如虚空智慧如大云。成唯识中。亦有三义全同摄论。而瑜伽云。粗重之身广如虚空。法身圆满。譬如大云皆能遍覆。此同摄论第二义。而无性释以智覆空。此以法身者智满则法身圆满。起信论云。显现法身智纯净故。本分云。得大法身具足自在。亦以法身喻云。真谛三藏释金光明经云。虚空喻三法身。云喻三道之智。此法喻亦齐似非经意。此喻位极非道前故。庄严论第十三云。于第十地中。由三昧门及陀罗尼门。摄一切闻熏习因。遍满阿梨耶识中。譬如浮云遍满虚空。能以此闻熏习云。于一一刹那于一一相。于一一好于一一毛孔。雨无量无边法雨。充足一切所化众生。由能如云雨法雨故。故名法云。此从法身未及佛。故立赖耶名。十住论云。于无佛世界。能雨法雨故。瑜伽又意云。言大云者。未现等觉。若现等觉。能雨大雨作利益故。是则密云不雨含德而已。然诸释虽众不出三义。谓以智慧含德。遍断诸障遍证法身。故所覆粗重即所离障。谓于诸法中未得自在障。此障十地大法智云及所。含藏所起事业故。斯即二愚障所起业名大神通愚障大智云。即悟入微细秘密愚。断此障故。便能证得业自在等所依真如。谓神通作业总持定门。皆自在故。便成受位等行。具智波罗蜜得化身三昧等果。即是云雨究竟成佛法身。及所证如皆亦所遍虚空。其旨一耳。次正释文。文中三分。先赞请中有十六偈。前十三赞。后三偈请。前中亦二。前三偈但申供养。有三类可知。后十偈天女供赞。于中亦二。初一总标供赞。余九正显赞辞。于中亦二。前八赞佛德能。后一劝修利益。前中亦二。前五赞大用自在。后三显自在所由。前中亦二。前二用益普周。后三随见不等。于中亦二。初一总明后二八相显。所由中亦二。初一智了世幻故。文有喻合后二证穷性相故。于中半偈证体。半偈起用半偈用不离体。半偈体用泯绝。后三请中。初一结默念请。后二上首言请。第二正说论分八分。一方便作满足地分。摄前九地所修。总为方便满此地故。二得三昧分。初住地行行德无量。偏举受职之所依故。三得受位分。正住地行。依前定力摄佛智故。四入大尽分。是地满行。望前诸地行已穷尽。今复地满尽之极故。五释名分。此地学穷辩德显称故。六神通力有上无上分。地满足已妙用自在。形前无上形佛劣故。七地影像分。以喻显法如因影像知形质故。八地利益分。彰说殊胜劝修趣入故。后之二分通该十地。将前摄后云此地有八。若依前长科。后二分通则此地分二。先明地行。后彰位果。地行之中方有六分。如上所列。六中初一是入心。余是住心。出心即调柔果。已如前说。今初分中二。先总明。后善满下别显。今初无量智者。阿含广故。观察觉了者证智深故。宝性论中。地上菩萨起二修行。一约根本智名如实修。即此证智。二约后得智名遍修行。即此广智诸地。具起上二种行。今于上二决择思修。别中十句摄为七相。初三七八二处合故。七中一善修行故。即是同相。谓初三句明证助不住诸地同修故。初句证道无漏白法故。何以得证。由次句助道。何因成助。由后句不住道增福德故。不住无为增智慧故。不住有为。后六别相。谓二广行大悲。即普遍随顺自利利他相。此总前七地合为一相。以七地差别之相。八地之初已辨故。此总举普遍释广随顺。释行大悲利他而成自业。故云自利。三一句令佛土净。即八地相。下三相即九地。以亲证此故多举之。谓四一句教化众生相。即九地自分行。入十一稠林故。五有二句善解相。谓解达真如是佛所行处故。善顺如来能证寂灭行故。六无厌足相。常观察力等欲趣入故。上句解。此句行。并九地胜进故。前地。云昼夜专勤更无余念。唯入佛境界故。七地尽至入相。谓十地证穷故。同前诸地。结行入位已属第十。故云名为得受职位。第二佛子菩萨摩诃萨以如是下明三昧分。于中二。初牒前起后。后即得下正显。于中四。初别举十名。二如是等下结所得数。三菩萨于此下彰入满足。四其最后下显最后名。今初十中初总余别。总云离垢者离烦恼垢故。是障尽地偏受此名。别中九定离八种垢。一入密无垢。谓解入事事法界深密之处。不与惑俱故。二近无垢。万行已圆道场斯近故。如净名说。上来初一解次一行。下三成德。三放光无垢。谓光开心华令其见实。亦能坐种种大宝莲华光无不照故。四陀罗尼无垢。如海包藏五起通无垢。则无心顿现。上五皆起法身之定也。六有二定清净佛土无垢。上句无量则尽法界之疆域。下句正观穷国土之体性。上六自利。七化生无垢。上之二利皆自分行。八正觉无垢。谓胜进上觉将成菩提。时一切诸佛迭共现前而证知故。如下受职处说。以本觉将现故。二结数者亦是眷属。皆现前者。久修成就不加功力自然现故。三彰入满足中能入者。通方便定体入起相。即隐显无方故云善巧。善了所作即知业用。四彰最后名者。将说受位分故。一切智者佛无分别智也。论经重言智者。兼后得智。二智平等名受位也。第三此三昧现在前下。明受位分。于中有四。一法二喻。三合四结。今初有六。一座二身。三眷属四相。五出处六得位。六中前五自分德备。后一上摄佛果。前中初三位体。次一位相。后一位用。前三即依正眷属。今初随何等座。谓大宝华王座故。于中二。先明主华自有十相。一主相即宝莲华。二其华下量相。三以众妙下胜相具德故。四超过下地相生处故。五出世下因相。六知诸下成相。七恒放下第一义相。正观普照法界现事故。如世莲华开敷。菡萏为第一故。八非诸天下功德相。菩萨德招故。九毗琉璃下体相。十其华下庄严相。二十三十下明眷属华。第二尔时下。随何等身殊妙之身称于座故。第三无量下随何眷属。第四佛子此大下。随何等相。周遍作业为其相故。第五佛子此菩萨坐彼下。随何出处。十处出光令恶道出离。菩萨增行故。文分为四。一舒光作业。二众圣咸知。三下类奔风。四同声相应。今初十处放光有三种业。一利益业。二发觉业。三摄伏业。今类例相从且分为四。一前之七光但有益业。前五益凡后二益小。二第八一光有二业半。一者益。益九地已还菩萨故。二者发觉令知故。言一半者。但有摄义摄彼令来故。三第九一光亦二业半。一益等位菩萨故。下文彼光既令此益此光必益于彼故。二发觉令知故。言一半者。魔宫不现是伏业故。四第十顶光但有发觉。文分为三。一显照分齐。二右绕下正显作业。谓兴供成益益。言不退菩提者。论有四义。一于登地证决定故。二入正定聚故。三定离放逸恶故。四定集善事故。三佛子下事讫收光。言足下入者。若约教相。顶光入足显深敬故。若约证实终极之智。从下趣入诸佛境故。故论释后段云平等摄故。显证佛境即自证故。第二尔时下众圣咸知。第三佛子是时下。下位奔风申敬获益。文并可知。第四当尔之时下。同声相应以修平等因行互相资故。表内吉祥深广之德严。心已圆故。外于此相放光相益。又上此照彼。放眉间光表中道已照。今彼照此。乃于胸相者。表心契悬同。德圆魔尽名坏魔怨。第六尔时十方下。明随所得位。于中二。一放光于中十业。初光名即益业。益一切智令成佛故。二眷属光是因业。三示佛是敬业。四开悟业。五振动业。六止恶业。七降魔业。八示现业。九如是下卷舒业。十示现种种即变化业。二现是事已下入顶成益。入顶者。若约化相上收于下也。若约实义照极心源名为智顶。成果在已是为光入。论云。诸如来光明。彼菩萨迭互智平等摄受故。谓菩萨顶光入佛足。则因上进于果也。佛光入菩萨顶果收因也。亦因收果入则无迹。因果双亡名平等也。当尔之时下得益。名为下结位。入佛境者所证同也。具十力者行德同也。堕佛数者。如始出家便堕僧数。第二佛子如转轮下喻。喻上六事文少不次。初喻随何身。二其转轮下喻随何座。三长大下喻随何相。四取四大下喻随所得位。王喻真身手喻应身。瓶喻白毫水喻于光。应有第三随何等眷属。谓文武百寮以为辅弼。五即能下明随何等出处。第三菩萨受职下合。但合随所得位。正意在此故。第四佛子下总结。结斯一分。大文第四佛子菩萨住此法云下。明入大尽分。于中有五种大。一智大。二解脱大。三三昧大。四陀罗尼大。五神通大。此五依五种义。一依正觉实智义离智障故。二依心自在义。离烦恼障故。三依发心即成就一切事义。意定力故。四依一切世间随利益众生义。意能遍持口能遍随故。五依堪能度众生义。身及诸通广能运故。前二自利后三利他。文中三。前二别明。后三合例。今初智大分二。先别明后总结。今初有七种智。一集智大。二应化智大。三加持智大。四入微细智大。五密处智大。六入劫智大。七入道智大。此七展转相生。今初集智。依能断疑力了法缘集故。文中先别明。后举要下总结。前中。有二十集皆明因缘集。然通真妄及与和合故有三分。一染分。二净分。三灭分。在文六重。一唯染。谓初四及众生集。诸见烦恼集。二唯净。谓声闻已下诸集。三唯灭。谓虚空。四净染合说。谓识及有为世界成坏。五净灭合说。谓无为及涅槃。择灭无为为净。非择灭为灭。性净涅槃称灭。余三涅槃为净。六通染净灭谓法界。故论云。随所正不正以法界通善不善及无为故。而论诸句皆有随所言者。随何等差别皆能知故。第二佛子下。明应化智中三。初牒前起后。以依前缘集智身起化用故。故论云依彼身起力。次如实下正显。后如是下总结。别中十句。初三众生世间自在化。化起众生善恶业及利钝使。令众生见似真造作故次一句器世间自在化。次五智正觉世间自在化。三乘正觉故。一法界化。为三乘所说法行。余四化为三乘人及果。后一通三世间。有情有分别器无分别智。正觉通上二也。第三又如实知佛持下加持智。论云依如是如是转行力。谓依彼应化常化不绝。为加持行。其事非一重言如是。有十一句。初三不断三宝是境界持。余八是行持。于中初二逆行。胜热炙身无厌行。虐婆须染欲遍行处邪皆其事也。后六顺行。前四起因行。时谓起因之时。愿等因体。后二得果在时。时谓长劫智即果体。谓一切智智故。第四又如实知诸佛下微细智。谓知佛化用微细自在故。论云。依彼应化加持善集不二作故。谓依前应化等三智合为不二之智。作此微细化用故。随一事即具前三。非但八相。一具余七文并可知。第五又入下密处智。依护根未熟众生。不令惊怖故。现粗隐细而秘密俱成。初三即总显三密。次三别显起化密。一意知化时。二口与其记。谓懈怠者迟记。怯退者速记。或引实行声闻。与应化者记。又昔但记菩萨。则于声闻记为秘密。随机隐显。后摄众生密。论经云摄伏谓摄受折伏。皆通身口。次一教密约实则无三说三。三即为密。但为化菩萨故。约机非一说一。一亦为密。后三约所知明密。知根种种知业万差。知逆顺行。皆得菩提故为密也。第六又知下入劫智。依命行加持舍自在意。谓劫时迁流名为命行。一摄一切名曰加持。一入一切名之为舍。以废己随他故。劫随心转名为自在。亦十世隔法异成门也。以得不思议解脱不见长短。一多大小互相即入等。并如发心品。第七又知如来下入道智。论云依对治意说。谓遍入诸道。若逆若顺皆为对治。无非入道。此约知凡夫道。若约知化凡夫道。即此逆顺等便是佛道。别中有十四句。初句总入所化。谓毛道凡夫随风不定故。论经云入凡夫道。论云依凡夫地。余句别显所化。略有三种。一依我慢行者。令入微尘智观破抟聚。唯尘无我故。二依信求生天者。入净国土过于所信故。余皆依觉观者。于中初句起觉观身。次二句正显觉观心行差别。次句明所觉境。上四即所化之觉观。次四句能化之行。初句总显遍行故。次二随宜若逆若顺。后句若深若浅。后四句化令入三乘果。第二佛子一切下总结。前七皆佛之智菩萨能入。故名智大。第二佛子至住此地下。明解脱大中三。初标得位。次即得下略显有十。初依神通境界。转变自在言念不及故。如净名所得。二能至无量世界。以愿智力无拘碍故。三明离障解脱故云净观。离障有二。并皆知之。一约位则世出世间所离不同。二就出世中学无学别。此学无学并通三乘。上三中前二约通。此一约智共为一对。总相以明约身明通。就人显智。次三一对。一通二智。四约心明通。普照物机随意转变。一时普应如观音普门示现故。次二约法明智。谓五即法陀罗尼。显如来藏中蕴恒沙德故。六即能破他言。随彼言破无碍圆满故。次二一对相入通智。约时明通。由达三世劫随意住持相入故。约因缘集显智。一切种智包藏法界之中故。后二一对约相。即明通智。约身明通。不离一身光明轮而普照故。是解脱光轮约时明智。即一而能知多故。后此十下结广。第三如是乃至下总例余三。大尽分竟。大文第五佛子菩萨摩诃萨通达如是下。释名分中三。一能受如来大法云雨。故名法云。二佛子此地菩萨以自愿下。明能注雨灭惑故名法云。三佛子此地菩萨于一念下。明注雨生善故名法云。然后之二段。从自受名。今此一段从所受立名。论云云法相似以遍覆故。此地中闻法相似犹如虚空身遍覆故。谓佛身云遍覆法界。法雨亦多。唯此能受故名法云。文中二。先总明能受之德。由前七智成就念力能受多法。此智实成多德故云无量菩提。近说受持之义耳。二十方下别显受法之相。于中三。初总显受多。二历数显多。三问答显多。今初有法喻合法中三。一明所受法多。二大法明下所受法妙。故下合云秘密藏也。文有三句。上二句性故谓三慧所知名法自性。大法明是闻思智摄受故。照是修慧所摄受故。下句作故。谓说授众生如云。与他雨法雨故。三于一念下显能受德。一念者。速故既多妙。又速展转显胜。能安者堪能安受文故。受者信受故。上二受文。摄者思惟摄取义故。持者。摄受彼文义成二持。故此但顺说。下喻合中兼反显不能。文并易了。第二佛子譬如大海下历数显多中。先喻后合。海能安者受一切水故。受者不浊故。浊如不信。摄者余水数入失本名故。持者用不可尽故。第三解脱月下问答显多中。先问后答。答中二。先校量显示一佛之所受法广多。后如一佛下类显多佛。言三世法藏者。三世佛法之藏也。而论云。于法界中三种事藏者。意取法明照雨蕴在法界故。以彼经云法界藏故。故为此释。第二注雨灭惑。释名中此中云等如出现品广明。悲云普覆故。法雷惊蛰故。通明无畏。照机速疾令见道故。以福智因成种种身。如云形显多故。法雨正能破四魔故。第三注雨生善。释名八相渐益故可知。大文第六神通力。有上无上分中有六种相。一依内二依外。三自相四作住持相。五令欢喜相。六者大胜。若就经文分二。前四合为一段。正显神通。后二为一断疑显胜。今初分二。先别明后总结。别中三。初明依内。智慧明达者即起通之智。亦陀罗尼。二神通者是通体。三自在即通德。亦摄不思议解脱。及与三昧。具此三事即通无上。第二随其下依外。谓业用依外境而起故。亦是第三依自相。谓转变作用是神通相故。此二经文是一义分为二今依自相释文自有二种。一转变外事。于中三一同类略广转。二垢世界下垢净异事转。三或随心下尘容世界等。是自在转。二或随心念于一毛下。应化自身可知。第三或随心念于一念中示现不可说下。作住持相。谓常用不绝故第二尔时下断疑显胜中二。先断疑。后显胜。今初即论生喜由疑除故于中二。先示自神通力断疑。二说法断疑。今初有二问答。初一问答显神力无上。令众欢喜。后一问答显神力有上。令众欢喜。前中先问后答。问中先大众生疑。举佛疑菩萨。如上之事佛可得。尔菩萨岂然。后上首为请。答中二。一入定现通。二问答决择。今初即事为验故。于中三。一法主入定。国土体性无所不融故。能一身包含无外。二入此下众睹希奇表通自在故。佛号通王。三金刚下摄用增敬。第二尔时解脱月下问答决择中三。初问名字。二又问下业用分齐。三佛子菩萨住下类显广多。于中二。初但结多定已显业用难思。后佛子此法云下结略显广。则余德无尽。此中亦即大尽中事。第二解脱月下显有上中。谓劣于佛故。先问后答。问中即举菩萨疑佛。谓菩萨既实得尔。则佛应不胜。若言胜者其相云何。故问辞则同疑意悬隔。答中三。一总诃问。非显佛德无量。二复次下举所未说显佛德无量。谓向所说乃是十地德之少分。如四天下之少土。全将菩萨之德以比如来。状如四天下土。以比无边大地。况将己说之少分以比如来。则如一块以比无边大地。佛证极故。三佛子我今下。引事类显佛德无量。第二佛子菩萨住如是智慧下。说法断疑者。谓此地菩萨智慧能令众生入一切智。复显上说其德不虚故。疑除生喜。然此下文。当出地心比前诸地。即调柔果而论复将入前分中。欲显义门。多势终似惑人。若准上例。上来地行竟。此下第二明其位果。于中亦有三果。今初调柔果中五。一调柔行。二此地菩萨智慧下教智净。三佛子此菩萨已能安住下。胜过自在。四此菩萨十波罗蜜下别地行相。五佛子是名下总结地名。五中前二合为说法令喜可知。后三及余二果俱名大胜。显义多含故。论连前势为果。已定更不重言。就大胜中初三明神通胜。二摄报中。得十不可说等名算数胜。此二种事胜一切地故名大胜。偏举此二者。以是神通有上无上门中明故。就前三中先明胜过自在。于中三。初牒前。次诸佛下别显。后举要下总结。别中五句为三。初句即能断疑行。谓令通达三世之中所有道义故。二一句速疾神通行。闻说如来秘密法界故。三余三句等作助行。谓以平等三道助通化益故。于中初句作净佛国土平等化。即是助道。次句作法明平等化。谓教智化。后句作正觉平等化。谓慈念令得证知故。故论经云。令一切众生得证法故。余别地结名及算数等并可智。大文第八佛子此菩萨。摩诃萨十地行下。地影像分。于中四喻。谓池山海珠喻四功德前二是阿含德后二证德。前中池喻修行功德。即诸地中起修之行。二山喻上胜功德。即依修成德德位高出故。三海喻难度能度。大果功德即修所成德。能至大果故。谓大海难度十德皆遍。故名能度。大海难成由揽十德能成智海。故云大果。此释法喻兼含矣。四珠喻转尽坚固功德。谓从初地转至法云。障尽证坚故。又十地有三。一是修地因前果后故。初二喻显之。二是成地随分。修成即是佛智故。珠喻显之。三是法地。就佛智法开之为十。故海喻显之。以后一融前二无有障碍又此四喻。皆喻十地与彼佛智。非一非异。无差别之差别。而旨趣各殊。初一喻始异终同。次山喻能所依别。所依之地则一。能依之山不同。此则无差之差。上二喻有能所依。下二喻直喻地智。不立能所。三海喻全一。佛智之体而十德不同。德非别物。又互相遍不同于山。斯乃无差别之参别。差即无差。四珠。喻唯是一珠前后之异。唯一智体前后增明。喻虽无差别不碍差别。又初喻前后体别。前非是后而后包前。次喻前前非后后。后后非前前。而同依一体。海喻前后虽殊而前后相遍。珠喻闻后一体。而前前非后后。后后必具前前。初一即是圆家渐。次喻圆中渐。珠喻即是渐圆。海喻即圆圆也。四喻圆融。上来所解在论虽无理必应尔。若得斯旨。不疑十地差别等相。今初修行德中有法喻合。法中始从欢喜终至法云。名次第行相。次第既具则入智海。譬中四大河者。面各出一故。具如十定品。而言大者。阿含婆沙云出二十河。以四河去池四十里。各分为四。并本四为二十。今就本河所以言大下云增长摄余十六。而胜鬘云八者。以东面五河。人皆具见。余三大河名声普闻。十二小河不闻不见故但言八。合中菩提心合池流出。善根等合四河。依菩提心修四摄行。自善增长故。准十定品说有四河。今文含具。一愿智河即大愿之水。二波罗蜜河。三三昧河即今善根。四大悲河。即以四摄法充满众生故。言无有穷尽等者。合上无尽竭。大愿等皆无尽也。第二山喻上胜功德中有四。初总举于法。次如因下总显于喻。三佛子如雪山下法喻对显。四佛子此十宝下总结法喻。今初言因佛智者。为修平等佛智而起诸行修。既未穷故。随十地之行各一增上。斯乃为修无差而成于差。以本统末非全隔越。第二总显于喻。喻意可智。鞞陀黎者此云种种持。由乾陀此云双持。回文即云持双也。尼民陀罗此云持边。斫迦罗此曰轮围计都末底此云幢慧。第三法喻对显中语其山体。前二土山余八是宝。故论云是中纯净诸宝山喻八种地三地世间云何言净。论云厌地善清净故。谓能修善厌伏烦恼。亦得为净。喻以宝山。若语山中所有。即明各有增上义也。初地圣智法药。二地戒香。三地禅等可贵如宝。四地出世如仙。五地善巧自在如夜叉。六地以五地修四谛因相同声闻未能出彼。六地超彼成果无尽。七方便善巧如彼龙神。超前缘起之因名缘觉果。八地无功用心自在故。此自在众即是密迹诸神。九地善巧摄生大力相故。十地佛德如天已淳净故。论云。前三及六非众生数。余皆众生数。就非众生数中有二种事。一初二及第六是受用事资内报故。第三宝是守护积聚事受用中有二。一药是四大增损对治。二香及果即长养众生。以揵闼婆常食香气故。众生数中复有六种难对治。一五通福田治贫穷难。以供彼仙能生福故。二夜叉治死难。威制眷属不令害人故。三龙治俭难降时雨故。四诸自在众治不调伏难。调伏难调故。五修罗治恶业难。以咒术力制诸眷属。不造诸恶故。六大威德天治修罗怨敌难。以四天王三十三天俱处此山故。论但显喻义含于法。今略合之。初地法药。初破无明故。二地戒。六地无漏慧资法身故。三地禅等可蕴积故。四地道品资助能生福故。五地修无住不永灭故。七地功用满足无所少故。八地三世间化得自在故。九地善知稠林得无碍辩破惑业故。十地如佛降四魔故。皆言集在其中者。如所说事能生一切物故。不可尽者。随顺修行不永断不暂息故。第四总结法喻。即结成本意。本意有二。一既同一智海得差别名。则差非差也。二互相显义。谓彼十大山因海得高胜名。若在余处不足为高故。大海亦因大山得深广名。含斯大义故。十地亦尔因修佛智故得高胜。佛智亦因十地所不能穷。方显深广。故论云因果相显。前言依地即一切智地生长住持故。此言依海。即一切智海由深广故。以山依二处法含二义故。更显之。又地则但依海兼明入故。一一山皆深入大海。一一地智皆入佛智。又一一山下皆有于地。则一一地中皆有佛地。又山在海海则非山。山若依地山即是地。法合是显非一异义思之。又山出海上高下等殊。若入海中量皆齐等。十地教行则优劣悬差。若证如入智量皆平等。第三大海十相明难度能度大果功德。先喻后合皆有总别。合中总云不可移夺者。此有二义。一果海因。十地相不可夺其果海深广之名。二地行因相。由依智海。不可夺其因行之称。以是海家之相故。果家之因故。若夺因相则果亦不成。喻中约果名不可夺。法中举因名不可夺。文影略耳。故论云。因果相顺故。云何相顺。谓十地如大海此总举也。能度难度者。显因顺果也。如海十相方能成海。得大菩提果故果顺因也。如海成时不失十相。离十相而无海。离十地而无佛智故。十地即智海也。别中摄十为八。一易入功德以渐故。二净功德。三平等功德。四护功德护自一味恒不失故。五利益功德利世间故。六六七二句合为不竭功德。以深广故。七住处功德。无功用行是菩萨所住故。经云大身者。以无量身修菩萨行。十身相作故。八末后二句合名护世间功德。九地潮不过限不误伤物。知机授法不差根器。十地若无大海水溺四洲。余不能受必生毁谤。又得此二法用护世间。第四宝珠喻转尽坚固功德者。先喻后合。各有总别。总云过众宝者。论经。云过十宝性虽不列名。论但云过琉璃等。意但取玻璃等。不能出宝者。以况小乘八辈。及缘觉行果。但有净相无利生用。今以出宝乃至放光。则出过众宝故。取之为喻故。论云以出故取亦可以出海故取之。除不出者阙余义故。别中摄十为八。合六七八故。八中一出功德可取者。选择出海故。由初地中如智善观出烦恼海也。二色功德。由治理之则色明净故。三形相。四无垢。五明净并可知。六起行功德。即次下三句。谓智行穿彻方便行摄持自在行高显故。相用不染犹彼琉璃。颂云金刚取不动不坏。上三皆是异相庄严。故合为一。后二句明功用殊胜。谓七神力功德。闻持普照体用微妙故。八不护功德。谓随王雨宝无护惜故。约法则得佛正智受位如王。令一切众生同己善根藏故。如随意雨宝故。合云广作佛事。合文可知。大文第九佛子此集下地利益分。于中三。初显法利益。二如此世界下结通十方。三尔时复以下。他方来证。今初分二。初生信功德。后雨众天下供养功德。今初复二。先明说益生信。谓欲令物生决定信。故说利益。后尔时下动地生信。今初亦二。先总叹难闻。后解脱月下问答显益。答中二。先正显等于佛智。后何以下征以释成。先反后顺。然闻有二义。一者泛尔闻为远益故。二不取闻相。初后圆融真实闻故。闻已等佛何更修也。若更修行等多佛故。第二动地生信中。佛力为缘而动地者。亦为生信故。又法如是者亦是因也。余如初会。第三重颂分。若取长料即当第十。于中二。先说偈仪意。后正显偈辞。今初先说仪。后欲赞下说意。意有九句大旨同前诸会。今约当会以释初句。即显初地。次句即二地。以三聚戒为行境故。三即三四二地厌禅。出世智皆净治行力故。四即五地五明成种智故。五即六地般若能除垢故。六即七地空有无碍。与一切智故。七即八地无功不思议智。庄严三世间故。八即九地十地能说能受诸功德故。九即总结。便指上八句。如是地义以颂说之。云更开显。第二正显偈辞。有四十二颂分三。初一偈总赞劝听。后一偈结说无尽。中间正颂分八。初十三偈颂方便作满足地分。于中初二颂半。总颂前九地同相中善择功德。余颂诸地别义。若依总摄。即次第颂前十地。前八地中唯三地半偈。余各一颂。九地有三颂兼结入位。二有一偈颂三昧分。三有五偈半颂受位分。四有三偈半颂大尽分五有三偈颂释名分。六有二偈颂神通力有上无上分。七有四偈半颂前位果。亦是神通分摄。如长行辨。八有七颂半颂地影像分。于中初三偈半颂山喻。次二颂海喻。后二颂珠喻。池及地利益分。文略不颂。其利益分。亦可结说无尽。颂之十地竟

大方广佛华严经疏卷第四十四大方广佛华严经疏卷第四十五

        唐清凉山大华严寺沙门澄观撰

    十定品第二十七(入第四十经)

初明来意。先辨会来。会来有二。一约圆融。谓前明普门中所具差别正位。故寄历人天。今明位后德用不离普门。是则会别入普有此会来。重会普光意在斯矣。等妙二位。全同如来普光明智故。二约次第。前明十地今显等妙二觉故来。以极果由于始信故重会普光。谓前依本不动智体起差别之位。今位极成果。不离本智之因。后出现因果。因是果中之因。得果不舍因故。果是果中之果。大用无涯故。二品来者。为答第二会中十定问故。第二释名会名有二。约处名重会普光明殿会。由第二会已曾会此。故重意如前。约法明说普法会。二品名者。定谓心一境性。十是数之圆极。以普贤深定妙用无涯。寄十以显无尽。故云十定品。即带数释。若依梵本。具云如来十三昧品。以等觉三昧上同佛故。三世诸佛之所行。故云如来三昧。译家以义通因果。故略如来二字。然三昧为定。虽非敌对由等持心至一境故。义旨相顺从略云定。又别行本。名等目菩萨所问三昧经。皆人法双举。梵本是依主释。别行即依士释。三宗趣者。会以普贤因果德用圆备为宗。令物证入为趣。品以普贤三昧无碍自在无边大用。而为宗趣。次正释文。此会有十一品经。分二。前六明因圆。后五明果满。若依古德前九明生解因果。后二明平等因果。前中亦二。前六品明位后因相。后三品明差别果相。然六品之因。若约次第与前五会俱是差别之因。若约圆融等同果相故。与果同会。果是对因之果。与因同会。平等因果由差别成。亦与此同会。今初此因即是等觉。然文有等觉之义。而无等觉之名者。以此等觉亦即十地之胜进故。是以诸教开合不同。仁王经等合此胜进入于十地。是以不立等觉故教化品中约五忍分位。于寂灭忍唯有上下。下忍中行名为菩萨。即第十地。上忍中行为萨婆若。此谓如来。若依璎珞。开此胜进为无垢地。即是等觉。然等觉照寂。妙觉寂照。又贤圣学观品中说六种性。及六坚六忍等。瑜伽具有二义。七十八引深密经说十一地。第十法云十一说名佛地。唯有二十二愚。得佛地时由断二愚。一于一切所知境极微细着愚。即俱生极微细所知障种。二极微细碍愚即是任运烦恼障种。断此便能证大菩提。更不别说等觉断证。论复有文亦立等觉。又菩萨地云。此菩萨虽已修行功德海。满由未能舍三种法故不名妙觉。一由未舍劣无漏法。二由未舍白净无记法。三由未舍有漏善法。至妙觉位方舍此三。今经欲显开合无碍。故存其义不彰其名。下离世间品智慧助道具中。既云随顺六坚固法。有等觉明矣。文中分二。前三品正答前问。后三品总显深广。今初分二。前二品明业用广大。后一品明智慧深玄。前中亦二。初品就定明用。后品就通明用。前中分五。一序分。二请分。三示说者分。四本分。五说分。初中三。初总显三成就二始成下别显三成就。三与十佛刹下别显众成就。二中分三。初约主显时。二于普光明下约主彰处。三入刹那下就德显主。于中十句。即摄二十一种功德中。二十别句。总句即前始成正觉故。一入刹那际三昧者。即穷法真源。谓时之极促名曰刹那。穷彼刹那时相都寂。无际之际名刹那际。即摄二句。谓二行永绝及达无相法。若有二行则有刹那。二行既绝则刹那无际。由达清净真如本无相故。所以此中特名入刹那际者。为显将说等觉位故。菩萨地尽唯有果累无常。生相未寂犹名识藏。若以无间智觉心初起。心无初相远离微细念故。即无刹那。若入此际即见心性常住。名究竟觉故云诸佛三昧。亦显差别历位。不离最初刹那际故。二以一切智自神通力现如来身者。依通起用。此摄二句。一切智通即住于佛住。谓由一切智无有功用。自神通力常作佛事故。次现如来身即摄得佛平等。谓依上一切智现身利乐有情故。三清净无碍摄三句。谓清净摄二句。一摄到无障处。谓惯习觉慧永断所治。故云清净。二摄不可转法由清净故。他不能转。无碍者即所行无碍。世间八法不能碍故。四无所依止无有攀缘。即立不思议。谓虽立教法不依世间故。非诸世间所能攀缘故。五住奢摩他最极寂静。即普现三世。以见三世平等如理无异。为最寂静。六具大威德。即身恒充满一切世间。现受用变化身大利乐故。七无所染着。即智恒明达一切诸法。谓于诸法善决定故。无有染也。八能令见者悉得开悟。此摄二句。一摄了一切行。谓知有情性行差别随开悟故。二摄除一切疑。谓知彼远劫微少善根。亦令开悟故。九随宜出兴不失于时。亦摄二句。一摄无能测身。谓如其胜解而示现身。如摩尼珠。名随宜出生不失于时。二摄一切菩萨等所求智。谓调伏有情摄受付嘱等。皆不生时故。十恒住一相所谓无相。摄余五句。谓到佛究竟无二彼岸等。随义虽殊皆由一相无相而成。可以意得。余如升兜率品辨。第三别显众成就中五。一举数。二靡不下叹德。三其名下列名。四如是等下结数。五往昔下集意。叹德中十一句。初二句总。位极行圆故。余九为别。前四自分德初二行相。一深二广。后二行体。一定二悲。后五胜进德。前三同佛三业大用。可知。后二同佛无住涅槃。初句释。谓不住涅槃故。入世间不住生死故。心恒寂静。后句结德属人。三列名中一百菩萨。初有三十同名慧者。表纯德故。念庄严下七十菩萨别名者。表杂德故。余二可知。大文第二尔时普眼下。请分中四。一普眼请问。要以普眼方见普法故。二佛言下如来许问。三普眼下举法正问。四佛言善哉下叹问利益。大文第三普眼普贤菩萨下示说者分。以法属普贤故。示其令请。于中有六。一示人令问。二闻名获益。三推求不见。四教起见方。五依教而求。六为现身相。今初分三。一示处。二已能下叹德。三汝应请下教问。第二尔时下闻名获益中。获十种益。文并可知。第三其诸菩萨于普贤下。推求不见中有三推求。皆悉不见。一渴仰推求不见。二重观察不见。三以三昧力推求不见。文各有释。今初先求不见。后此由下释不见所以。威力持者。欲令大众渴仰得显深旨故。二重求中三。一审问重示法本湛然故。初无移动。二是时普眼下推求不见。犹谓可见故。三佛言如是下释不见所由。于中二。初印定征起。后善男子下正释所由。以住处甚深故文有十句。初句总。次八句别。后一句结。别中四对。一广智胜定深。谓智门无边。有边之智焉睹定用。起伏无畏展促自在。唯以出世定求故不可见。次二外用内证深。次二得力成身深。后二多护速证深。由上八深故不能见。第三尔时普眼菩萨闻如来下。以三昧力推求不见。于中分四。一新获三昧。二以三昧下以定推求。三时普眼从三昧起下。自陈不见。四佛言下释不见所由。于中五。一约法总标由住难思解脱。翻上三昧可思入故。二普眼于汝意下以近况远。三何以下征释所由。释中二。初略标深广。翻上三昧尚有数故。后举要下举略显广。文有十句初句总。以金刚慧达差别法界俱空故。余句别由了空故。一世界无住处。二众生无可化。三寂无去来。四竖无断尽。五横泯差别。六体非体故不碍现通。七用非用故无依无作。八不离如如故无动转。九理事圆故穷法界边。四善男子若有下彰见之益。五尔时普眼下归敬弥增。文显可知。第四教起见方中。初令策勤前心。次又应下别示深观。上舍境别求故。未识其体。今令十方齐观知其体周。下依此观是以得见。后誓与下起愿思齐。具上三心则能得见。第五。是时普眼下。依教修行。然普眼位深而犹重。习观修者略有二意。一位未等故。二示深奖物故。第六尔时普贤下为现身相。于中五。一为众现身不见。显深现不碍用故。二是时普眼下众睹喜敬。三是时以佛下。现瑞成益。四尔时普眼下叹德广深。于中十句。无等者下无等故。无过者上无过故。余可知。五佛言如是下如来印述。初印后述。述中十一句。初句总。后所谓下别。别有十德。一二严德。二圆明德。三深广德。四色相德。五慈覆德。六超胜德。七知法德。八绝言德。九同佛德。十赞无尽德。大文第四尔时如来告下。本分有四。一举益令说。二何者下列所说名。三此十大下叹定胜德。四是故普贤下结劝成益。今初分二。初劝说成益。后诸菩萨下引例证劝。以三世诸菩萨若说此定皆成益故。第二列名中皆云大者。因满之定称法界故。一普光者。身心业用周遍全包为普。智照自在名光。二妙光者。身智遍照为光。胜用交映为妙。三十方无余之刹。皆至入定为遍往。往无杂乱不碍时节。历然为次第。即能起用名神通。以智用如理本自遍故。四明达诸法本自清净。离于想念契理深心。依此起用遍供诸佛。请法起说名之为行。五佛出劫刹等事。皆名庄严。过去门中包此无尽为藏。亦名过去清净藏者。入定能入劫一念无缘起。定能受法三轮无著。皆名清净。六未来藏中。包含诸佛及佛法等。名之为藏。智慧彻照称曰光明。七现在诸佛作用。众会身相益物。皆曰庄严。横遍十方故云一切。现可目睹故不云藏。八于差别众生身内外入定起定。皆自在故。虽通三种世间。从多但云众生。前后诸定皆从多说。九于眼等十八界自在入出。又知事法界边际。与理法界无碍自在故。十无碍轮者。三轮摄化皆自在故。又得十无碍满佛果故。无尽大用一一无碍。皆悉圆满能摧伏故。寻初后际不得边故。第三叹定胜德。于中四。一约人以叹。人胜故法胜。二若诸菩萨下约修以叹。于中二。先明修成。后如是下修益。于中亦二。初有十句明上等佛果。后此菩萨普入下明身智周遍。皆言普入者。一一皆穷帝网境故。文显可知。三此是诸菩萨下直就法叹。明此十定该摄诸法体相用等。一一超胜故。十门五对。一境智通悟。二因果游入。三通辨出处。四佛法所从。五严土摄生。罔不由此。四若菩萨入此下约证以叹。前约修叹。望于佛果以显终同。此约证叹直就此定以明业用。亦二十句。前十明胜德无限。文显可知。后得法界智下明智德自在。及第四结劝文并可知。大文第五尔时普贤下说分中三。初承旨总告。二佛子云何下别释十定。三第四十三卷末云。佛子此是下总结十数。二中十定即为十段。各有标释结。就初定释中分五。一智无尽。二心无边。三定自在。四智巧现。五观超绝。各有佛子以为拣别。五中初二定方便。次一定体。后二定用。又前三各有标征释结。今初释中十句五对。初二所事所化。次二化处化法。如影者无实故随现故。次二摄护始终。次二所持能持。后二始心终愿。第二心无边者。前明所知无尽。今辨对境发心。以境无边故心无边。有十一句者增数十也。第三定自在者。由前大智大心故。于三昧自在方处非一。入出不同故云差别文并可知。第四智巧现中有标征释。释中三。初法说。于中先十句别明展转深细。后一句总显离相分明次举喻。后佛子阿修罗下以劣况胜。第五观超绝中有法喻合。合中异前化现故云法身。法性包含故一时顿见。由此义故无能映夺。第二妙光三昧释中二。先法后喻。法中四。一身云展入。二是诸世界种种下身智俱入。三是诸世界亦悉下明其卷入。四然诸下明展卷无碍。二喻中文有二喻。喻前互入无杂乱义。一宝山光影喻。二幻师善巧喻。前中先喻后合。喻中有五。一明日光现影。七宝山者即七金山。如十地末所列其名。但除妙高及雪香二山。山间有七香海。海现日影。山以净金亦能现影。二其宝山上下明两影互现。正喻菩萨自他互入。以彼影明净如今之镜故。能互现。三或说日影下。正辨得名不同。谓水中本影现山上影时。此所现影。从山上出来入山间。若山上本影现水中影时。此所现影。从山间出入七金山上故。正入时即名为出。所喻可知。四但此日影下明重现无尽。喻菩萨帝网身土。五体性下明体离二边故能互现而无杂乱。谓取不可得故非有。影现分明故非无。不住成上非有。不离成上非无。若有定住则不能相入。若其离者则无可相入。故不离不住方能相入。后法合中直明不坏不住故。得互入无乱。初二句明不坏性相。谓若坏性相则无可相入。次二句明若住内外。则不能相入。谓若住世间内。则不能身包世界。若住世界外。则不能遍入世界。由俱无住故能互入。于诸世界下释其所以。由定无分别而不坏相。慧观一相而不坏诸。既事理双游故。不坏不住。若不坏不住。则住真如恒不舍离。既即事不舍故相随性而融通。如无不在故同真如内外互入。后如幻喻中二。初总喻。后如有幻师下别喻。今初先喻。后合喻中三。初总明能幻。二住四衢下明依本时处。现幻时处喻互相入。后不以示现下。本末互不相碍。喻不坏相。后菩萨下合中五。一明一多相容不同。合上现多时处。二菩萨于此下明智鉴不昧。合前能幻之术。三不以彼下。合不坏本末之相。四何以下征释所由。先征意云。何以互入得不坏相。释意有三。一由知人无我故。人我之相已见上文。二菩萨知。一切法本性下。知法无我故。三菩萨勤修下。得同体大悲故。由此故能融通事理。第五佛子菩萨如是下。结成上义。于中三。一结上多入一。二然不舍下。结上不坏性相。后当勤下。结上明鉴。第二别喻中有三逆喻。总中三段。一幻不坏本喻。别喻不坏相。二如是幻者下。幻必依处喻。别喻前依本时处。现多时处。三如彼幻师作诸幻事下。明幻师不迷喻。别喻前能幻今初先喻后合。合中先正合。后菩萨了知下。释其所以。第二幻必依处喻。先喻后合。喻中略无幻必依时。准合应有。合中分二。先合依处。后合依时。前中初总合。以记物现故。空即事空。次何以下征释所以。由理无差故。后住于世下结成自在。二于一念下合于依时。于中先正显。后菩萨摩诃萨得下。释其所由。以得幻智同于佛故。及第三幻师不迷喻。文并可知(已下入第四十一经)第三定中释内有三。谓法喻合。法中五。一明遍刹入定。二或刹那下明入时次第。三若久下。总结多门。四菩萨于彼下心契定体。五虽离此下。不废起通及喻合等。文并可知。第四定中释内分二。先明定内深心行。后明定起深心行。今初分二。先起行。后深心。前中先举内。后于彼一一下起行。于中先明外事供养行。后于彼一一恭敬等三业供养行。二然于诸佛下明深心中二。先法说。后如散动下喻况。于中二喻各有喻合。一妄念无知喻。喻其契实无念。二阳炎似水喻。喻其了妄同真。文并可知。第二佛子此三昧下。明定起深心行中。初法次喻后合。合中上明供养自利行。今明开演利他行。文影略耳。开演深理即深心起行也。第五定释中有五。一对境辨智。二正显智知各有十句。皆是过去藏中之法。三所知时分。有十四重。即释过去之义。四显知相状。不灭现在者不舍也。不缘过去者不取也。谓但约过去门。显非有取舍而缘。上四各一佛子。五明出定获益有三。初举数辨相有十句。初句总位。终成果。名受灌顶法也。余句别。一属己二净障。三究竟。四始入。五正证。六终满。七持令不失。八无知而知。九净三轮。总该前九如约智。辨三轮者。谓无能知所知及正知故。余可思准。二何等下征列其名。初四是四无碍辩。次二自利不畏深法。如言能行。次二利他。为善者依为恶者救后二总明二利胜妙。三佛子下结得速疾。有法喻合。歌罗逻者此云薄酪。余可知也。第六智光明藏三昧释中分二前明定业用。后彰定利益。初中分六。一总知诸佛。二若已说下知多名号。三当出现下知当所作。四彼诸如来修下。明知彼因圆果满。五彼诸如来名姓下。知现所作。六此菩萨于一念下。明知分齐。其中大千即是佛刹。而重言者多是遣脱。应言百佛刹也。余并可知。二以了知下彰定利益。于中四。前二自利。后二利他。谓一令心入持益。即由上知故持之不失。由持不失得持之益。一心中持佛得佛护益。二心入持法。得总持辩才益。余句仿此。有十二者增数十也。师子受生者。不畏生死苦故。示生死实性名开法关钥。了生死本空故。出欲淤泥。智力持者定慧双运也。入无住力持。则大劫不离一念。二佛子至住此三昧下。明得善巧益。有法喻合。然善巧有二。一如事善巧故。法云不可说无量。喻云见种种物。二如理善巧故云日光平等。又由此二无碍方名善巧。故合云无分别而能知。三佛子至如是了知下。明得不空益。四佛子至住此三昧下。十王敬养益。第七三昧释中二。先明定体用。后明定利益。前中亦二。先征后释。所以重征者。前通征一定。此则别征庄严。后佛子菩萨下释中二。先释一切世界。以是现在故但云十方。二皆见诸佛下释其庄严。于中二。先总列十门皆是庄严。其中第八别明庄严者。即功德智慧以严其心。色相光明以严身也。后众会清净下别显严相。以广前二。一广众会。二广庄严。今初有三。初明见他。二见自。三能见。今初亦三。初见众会体相。次亦见众会下明见分量。后亦见诸佛。于彼下见佛作用。二菩萨摩诃萨下明见自可知。三如是见时下明能见。有法喻合。法中明无分别而见。喻中明能所诠。不自云我是能所诠。而不舍能所诠。以喻无分别故而知也。合中先合不舍。后而于下合不分别。二佛子至见佛无量光色下广上庄严中二。先以法说后以喻显。前中二。先标章门。略举四种庄严。皆分明证了。后或见佛身下依章别释。即分为四。一释无量光色。二或见佛身其量下。释无量形相。三佛子菩萨如是见下。释上圆满成就。显前二圆满故。四又见佛下释上平等清净。即兼内二严。二佛子菩萨如是见于佛下。以喻显中三。一空无增减喻。喻法性身无可增减。空之大小在于世界及于芥子。非空体然。如法性之身应器成异。二月无增减喻。喻真常色身体不易故。证有近远随心见殊。前喻但喻佛身。此喻兼喻光色及圆满成就。三随心现境喻。喻上清净。菩萨心净则见佛净。在于如来何净何垢。第二佛子至住此三昧下明定利益。略举七种益。各有佛子以为拣别。第一速成行愿益。有标征释可知。第二法印同佛益。有十句五对。初二福慧同。次二二谛境智同。次二体用同。次二二利同。后二善巧平等同。第三以德成人益可知。第四智德包含益。于中二。先喻后合各有十句。合中总标合初获即得。十句合前十事。唯八九不次。以智虽是一从所知别故。一佛刹合色相。二众生合形体。三变化合示现。四入佛合眷属。以互为主伴如眷属故。五通达佛法为助道资具。六普摄净法则圆音示人。七皆令入法方是神通。八普眼清净超合慧解。九自在却合自在。十住法合智用。第五身威超胜益。有标有释。第六令他圆满益。先牒前起后。后征列名相。第七转作佛事益。亦先牒前起后。后征列名相文并可知(已下入第四十二经)第八一切众生差别身三昧释中分五。一明能入智。二显入出之相。三明入定之益。四明境界自在。五总结究竟。今初由得十种无著。成后出入自在。一切地者佛地菩萨地等。二入出相中。二先征起后释相。于中先法后喻。法中略辨十类。以表无尽。一诸类正报相对明入出。二天中入下六趣依报明入出。三千身入下一多相对。四阎浮提下四洲大海相对。五一切海神下。大种事法相对。其无生法乘四大种生便故来。六一切妙香华下诸方相对。七一切四天下下。众数多少相对。八不可说不可说众生众中入下。染净相对。九眼处下诸界相对。十一微尘下杂明诸类相对。为粗细凡圣念劫真妄等。其入出等义如贤首品。二喻显中有四喻。喻前十类各有法合。一鬼力持人喻。喻第一第四多约身故。第二咒起死尸喻。喻第二及与五六。多约依报境故。第三罗汉现通喻。喻第三第七多约数故。第四地一苗多喻。喻后三门杂明种种故。喻合相映文理自显。第三佛子至住此三昧下。入定益中有三。一得赞同佛果益。皆上句显义下句结名。十力义中云心志圆满者。明力自利义。义利成就显力利他。所作皆办彰力圆满。住无碍智总显力体。分别了知一切诸法通明力用。余文可知。二身智光照益。三业用无作益。皆有佛子文相并显。第四佛子至住此三昧无量境下。明境界自在。先法后喻。今初前第二段但明入起今兼明逆顺有无等。为种种境界。起中入者即用之寂故。入中起者即寂之用故。是知菩萨之定常入常起。常双入出常无入出。方为自在为显自在。寄诸境界交络而明。二喻显中文有六。喻皆自有合。一幻现六境喻。喻前同异。二修罗窜匿喻。喻前粗细小大二对。若约理事相望。则无差别为细差别为粗。理细事粗故。或无差为粗总相入故。差别为细别相入故。无差则大周法界。差则随事成小。若唯约事明大小。并差别所收。三农夫下种喻。喻明上下合辨一多。文影略耳。四受胎生长喻。喻上有身无身。如彼从无之有故。五龙下云上喻。喻有相无相。六梵宫普现喻。喻上入中起起中入。及逆顺相对故合云种种。第五佛子至到神通彼岸下总结究竟。并显可知。第九法界自在三昧释中四。一显定体用。二明定成益。三以喻寄显。四总结双行。今初分三。初总显名体。谓于眼等法界得自在故。二菩萨于自身下彰入定处。谓于毛孔中入眼等定。显互用自在故。三自然下明定功用。于中四。一了三世间。二菩萨于彼下多劫修行。三又于下入出无碍。四以于法界下结成自在。此有二义。一于理法界自在故。能善分别眼等界。二善分别眼等十八界。即是事法界自在。此二无碍及事事无碍。故云如是种种。皆横尽其边竖穷其际。第二菩萨如是下。明定成益中辨十种益。一生多功德益有二十一句。各十千亿。二佛子至复有无数下具无尽德益。随前一事皆至无尽故。于中二十句。前十句所具之多。后十句能具之相。清净者除垢故。莹彻者发本智光故。三佛子至住此三昧下诸佛摄受益。于中三。初明摄受。次彼诸佛下现身说法。后令修下令其修证。四佛子至住此法界下诸佛护念益。摄受摄之属佛护念。即佛力来加。五得十海深广益。六得殊胜超绝益。并可知。七得诸力干能益。于中初列十力。后佛子此十种力下显其超胜。随前一一力。皆具此三十八力。八佛子此菩萨下结能圆满益。九此菩萨功德下自德无边故。他不能说益。十佛子至住此三昧下。三昧无边自无不了益。上十段中前七别明。后三总结。第三喻显中。正显前体用及益。亦明前所未显故。不全似上文。文中二。先总举喻体。后佛子如无热下对喻别合。有十三门各先喻后合。一合流沙入海喻中。先总明喻合。虽举四河意在四口出沙故。下第九别明四河。后如恒伽下别明四辩即喻四口。所说即喻四沙。若开四辩总别为五。则有十七门。二如四大河下合绕池入海喻。于中先喻后合。合中先合绕池。菩提心智名之为池。三业随顺智慧。即为绕义。后佛子下合其四方。三如四大河围绕下。合池见宝华喻。说法有开敷之义。三昧有感果之能。庄严清净皆华上之别义。四合宝树绕池喻。五合大池清净喻。即是池体。六合栴檀香岸喻。十种智宝有二义。一即离世间中十种如宝智。二即他心等十种智也。七合底布金宝喻。妙智合金沙。解脱合摩尼。无碍光明合二种放光。住佛所住入于甚深。合布其底。上四段各以如无热大池为首。八如阿那下合龙王无恼喻。即合池名。名因龙得故。九合四河润泽喻。十合四河无尽喻。十一合入海无障喻。十二合入海无厌喻。上之四喻。各以如四大河而为喻首。上之十喻。皆以菩萨而为合初。十三佛子如日光下。合众宝交影喻。先喻后合。合中二。先正合。后何以下征释涉入所由。第四佛子至虽能于定下。总结双行。谓权实定散无障碍故。于中三。先法。次佛子下喻。后菩萨下合。然法中明即寂而用喻。合乃明即用而寂。文影略耳(已下第四十三经)第十无碍轮三昧。亦初征。次释。后结。释中三。初明入时方便。二佛子菩萨摩诃萨住此三昧已下。明入己智用。三佛子菩萨摩诃萨入普贤所住下。定满成益。今初有二十二句兼显定名。初十一句因用无碍。是无碍义。后普入下有十一句住果圆满。即是轮义。今初段中。即此无碍无所不摧。亦即轮义。初三句三业无碍。次句器世间无碍。次二句众生世间无碍。余句智正觉无碍。后住果中二智通权实。故云普住。三作利乐事。四净二障种。七智契佛境。余七可知。第二入己智用中四。第一摄佛功德。二证入诸法。三普德无尽。四结示劝修。初中即摄如来二十一种殊胜功德。以此位中德等佛故。其间或全同佛相。或有约因相似而次第无差。于中三。初总明妙悟皆满。次别显二十一德。后显德胜能。今初十句。初句标满时。余九显满相。然一切智若对种智即是根本。若直语佛智则通权实。今此显通。于中初三句始观。言观一切智者标也。云何观。观有二种。一总观。谓权实齐观故。二别观。此是实此是权。权中有多差别。皆审照了故。次三句中顺。亦初句标。次云何随顺由前总观故。顿能显示由前别观故。各各攀缘。后三句终契。释同前观。但由前观察。今证见分明耳。二于普贤下别明二十一种功德。分二十段。后二合故。今初第一明二行永绝。即于所知一向无障转功德。然有二义。一谓非如二乘有无智故。二不同凡夫现行生死起诸杂染。不同二乘现行涅槃弃利乐事。世尊无彼今菩萨亦无。文中广显利乐。即不同二乘皆与智俱。即不同凡夫。就文分二。先总明大用常恒。二佛子此菩萨有一莲华下。别显一用。前中二。先法说后喻明。今初法说中二。先正明后征释。今初先明行体。后不断下辨常恒。二征释中。征意云。何以得此智满行常。释意云。愿行善成智慧善巧故。第二喻显中四。初喻二合。三征。四释。今初。摩尼宝置色衣中。即总喻菩萨心智置佛智中。虽同衣色喻前智满十句故。合云观一切智等。不舍自性。喻前行常二十句。二合如喻辨。三征意云。何得已能满智而不断行耶。四释意云。菩萨无障碍愿法应尔故。穷尽生界益无疲故。文中二。先法说可知。后转以喻况。于中三喻皆喻利生无厌。各有法合。一虚空持刹喻。喻大愿法尔故无厌。二涅槃普灭喻。喻为净众生故无厌。上二喻悲。三佛智普成喻。喻能所不二故无厌。此一喻智既非爱见之悲。何有厌乎。第二别显一用中二。初明依果殊胜。后菩萨摩诃萨于此华下。正报自在。前中二。先明相严过前十地故。穷十方际。后此大莲华下辨德严。自内而观量周法界。自外而观许众生见。斯乃即小之大也。二正报中二。初明身量大小。后一切诸佛下明佛加放光。有二十重。后后重中皆倍前前。百万亿那由他不可说佛刹微尘数。倍则数难量矣。第二佛子菩萨至住此三昧下。明达无相法。即同诸如来。于最清净真如能入功德。初结前生后。达无相故不染。后安住下。正显安住即是入义。谓此真如非有非无。故云无边。定有定无即是边故。不可说法即离言真如。其法界实相及无碍际。皆真如异名。而云如来种性者。诸佛以无性真如而为性。故出现品云。皆同一性所谓无性。法华云知法常无性佛种从缘起。无去来等重显真如。即是中道故。深无底现量已下别明能入之义。第三为去来今下。明住于佛住德。谓佛无功用常住圣天梵住故。文中先三世佛赞。文通前后二段。从诸佛力下正显其义。谓入一切佛境。即圣天等所住境也。净眼现证下明能住相。十眼圆明而安住故。文有五眼。余但义含。第四成菩提心下。明得佛平等德。谓佛佛相望有三平等故。文即为三。初明所依平等。诸佛皆依清净智故。文中始发菩提心。终成种智。出生智用皆所依也。次离世生法下明意乐平等。同以调生为意乐故。后神通变化下作业平等。同作受用变化业故。第五功德解欲下明到无障处德。以修一切障对治故。福智皆净。离于二障文中。初二句功德。次二句智慧。各上句障净。下句德满。次二句重显功德。余四句重显智慧。第六所行寂静下。明不可转法德。谓教证二法他不能转。文中初二句略标教证。谓寂静证也。于诸佛法教也恒以下别显教。念力下重显。证既如空无著等。他安能转耶。第七于诸世间下。明所行无碍德。谓虽于世间作利乐事。世间八法不能碍故。文中住菩萨心成坚固力等。即不碍之因也。第八一切诸佛下。明立不思议德。谓安立正法凡愚不能思故。文中初总显一切教法。皆是如来威力之所建立。菩萨能知。反显凡夫不思。入不二下别显安立难思之相。谓依无相而广说故。随欲解之多端。故并难思也。第九法界为身下。明普见三世。以身心等于法界故于三世事记别无差。在文可见。第十开示一切法下。明身恒充满一切国土。谓为开法故。示现受用变化之身。遍诸世界而为利乐。文相亦显。第十一得佛智慧下。明智恒明达一切诸法。谓于境善决能断他疑故。文相亦显。第十二具大威德下。明了一切行。谓具增上意乐。能了有情意乐性行。如其所应而为现身。即有威德。第十三亦为开示下。明除一切疑谓声闻人言其全无少分善根。今能开示。令其知当生如来妙智故。心不障碍。第十四于一切法心无动下。明无能测身。然有二义。一谓其身非虚妄分别所起。无烦恼业生杂染故。不可测。初一行经显之。二其身虽无分别如摩尼珠。然由佛增上及众生胜解力。见金色等。而佛无有分别。即不坏诸有下。经文显之。第十五虽随世俗下。明一切菩萨等所求智。谓菩萨以无量文字调伏有情。要依佛所闻法为先。获得妙智故。诸菩萨等皆求也。文相甚显。第十六了一切法下。明到佛无二究竟彼岸。谓了一切法空法界等。即佛无二法身。依此法身修波罗蜜多等行。而得圆满。为从法界生。第十七犹如虚空下。明具足如来平等解脱。谓一一如来所现身土。皆遍法界犹如虚空。无相无形不相障碍。而不相杂。随其化缘现各别故。故文云。随顺演说于一境门生一切智。谓各顺一一境故。第十八观十力地下。即证无中边佛平等地。谓三种佛身平等遍满。无有中边之异故。至萨婆若。即自受用智。为桥梁。即通变化。见法无碍即是法身。结云善入诸地者。即佛十地也。第十九知种种下。明尽于法界。谓此法界最清净故。能起等流契经等法。极此法界。于当来世作诸有情随应利乐。今文但有所起略无能起。第二十所有大愿靡不成就即等虚空界穷未来际无有尽故方云成就。上来略辨。若广引诸论如升兜率品。第三佛子菩萨摩诃萨以此开示下显德胜能中二。初总明。后虽一切下别显今初先标。谓用此会事之德。开示佛平等性者。同有二十一种功德故。后此是下总叹前德。二别显中余九不言。且广初无碍之义。自有四十一句。初句有不碍无。以有是无之有故。后四十句明无不碍有。以无是有之无故。又前是二而不二。后是不二而二。及寂用相即等。并显可知。第二佛子菩萨入如是下。证入诸法用中四。初明证入。二离证相。三征四释。今初十句。初句明能证之定。三昧智轮尚顺梵语。若正应云智轮三昧。因定最胜名大威德。则能下显所证法。谓证佛果法。初句总。无为果为证。有为果曰得。余句别。趣入释证成就释得。圆满通二积集约因圆。清净谓障尽。定能安住慧能了达。定慧两亡则自性相应为证入也。二而此下明离证相。以无念方证故。尚不念无碍慧境。况所证法有若干耶。三征意有三。一何以证而无念耶。二何以一定得多果耶。三何以因定得果法耶。四释中二。初略别释。后此三昧下广以通释。今初别释三征。一体性离念故。二定体虽一用无边故。三以殊胜故因得果法。后广通释者。谓文广义通。通明上三句。于中二。先总标。境是定之所缘。深入是定证契。威力是定之用。三皆定体皆言种种故。上云无边。具三又多故云殊胜。后所谓下别显有二十八句。句皆有上三义。如初句。入即深入义。不可说等即无边义。智门即境界义。其间或有阙无边义盖文略耳。知智在说说为智门。二入功德智慧不二之庄严。六入不空如来藏。七悲智之境观度无休。余可知。第三佛子此菩萨摩诃萨住普贤下。普德无尽。于中四。一正显无尽。谓非唯上列诸用。又能念念入多三昧。亦不能尽。二征。征意云。既念念入多何以不尽。三释意云。此三昧缘境究竟无尽故。文有十句。初总余别并可知四喻况。于中有三喻。喻前无尽各有喻合。前二合中复加征释。一如意随求喻喻定心随应出法无尽。征意云。何以出法无尽不匮息耶。释意云。了多幻境皆同影像。缘至则生何有尽耶。体无增减何有匮息耶。二生心各别喻。喻缘境无尽可知。三龙王降雨喻。喻入法无尽。于中初喻后合。合中分三。初正明入法合滴如车轴。谓入广大法故初句总智门。下别皆云门者自他游入故。幻网者一切皆幻。互为缘起相交映故。世界性空故无体。随缘染净故有体。又法性土故有体事土从缘故无体。又净刹顺理故有体。染刹妄成故无体。余可知。二于一念下。入法时分合前降雨之时。三如是入时下。明入时相用。合前无边无尽无作境界。于中三。初十句明其相状。次求一切智下明其业用。三征释所由。今初。初二句合云无边雨无尽。不疲下合无作境无作即无功用故。身不疲心不厌。不永断不暂息。未入常入故不退。已入永常故不失。无法非所入门故不住非处。无心不契故。恒正思惟。不沈不举正是入相。二业用者随入一一门。皆有斯业门。门即不可尽。文显可知。三征释中征意有二。一云。菩萨岂无行满成佛。何以业用无际限耶。二云设横显无尽可尔。何以一一门中用即无尽。后释意亦二。一云。菩萨本为众生生无尽故。用亦无尽。二释后意云。生及世界既如虚空故。随一门即用无尽。如芥子中空。由此不但一门成多。一念亦能成多事矣。文中三。初喻明火随薪缘。薪多火在。喻菩萨生界缘广用无有涯。次合可知。后转征释。征意云。菩萨何以起多业用。释意云。为普度生满普愿故。第四是故诸菩萨下。结示劝修中二。初结劝勤修。二佛子至如是修行普贤行下总结显示。今初谓菩萨心穷生界。定用无涯。故应修习。文中二。初举所修之法。后勤加下示劝修相。今初。是故诸菩萨五字该下二段。其所修法有十一句。末后一句举定名体。前之十句。别明无碍轮之业用。于中倒牒前来诸文。初种类者业用非一故。如合龙喻中入法众多。是种类义。二境界者即定所缘。如前妄念缘境喻。三威德者即通显定用。如前宝珠能出生喻。四此上三种皆悉广大。一一无涯。如前不见三昧前际故。五数不可极。如前入不可说智门等即无边故。六并绝心言。如前不作是念有若干菩萨等故。七皆与智俱。如前虽知诸法无作。而能示现一切作业。是权实明照故。八体用齐于佛境。则诸佛现前。如前观十力地至萨婆若故。九如来护念。如前诸佛摄受已。入未来诸佛数故。十非但现用自在。亦成昔善。如前功德解欲悉清净故。第二示修相中二。初略示离过进德。后不依下别示离过进德。于中先离过。后于诸法下进德。文并可知。第二总结。显示者远则通结前来诸段。近则逆结上来进德之文。欲一一配属恐厌繁文。大文第三定满成益。文属此定意兼前九。于中四。一外感佛加益。二内德圆满益。三上摄佛果益。四正同佛果益。初中五。一辨加所依。谓在定时故。二十方下显能加者。三与如来下正显加相。四佛子菩萨下。加以成用。文并可知。五何以下征释所由。征意云。普行既满何须尽未来际行调生行耶。释意云。无障碍愿法应尔故。已成大愿真能调故。第二佛子此菩萨获如是下。内德圆满益中四。初牒前住定之因圆。通牒上文并显可知。二其心恒住下别示所满。十表无尽。三佛子此菩萨摩诃萨已到普贤下。总结究竟。四何以下征释所由。征意云。菩萨何以能满尔所德耶。释意可知。第三佛子至以此三昧下。上摄佛果益中三。初正明。次何以故征。征意云。上是佛德何能摄耶。后菩萨下释意云。住此三昧能所作无余同如来故。于中三。初正显无余之业。故皆云一切。二于此法中下明作业行相。初句总显依前而作。更不作余不足之业。住未足等显其作义。如是已下总结前作。三佛子下逐难重释。谓广前作如是业不作余业。文中三。初略标举其中如作。通身及意。次征。征意云。何以不作余耶。后广释。释意云。若作异前非菩萨故。文有十喻即为十段。各自有合。一金刚不坏喻。喻行体坚牢。二真金妙色喻。喻善业外饰。三日轮光明喻。喻智慧圆明。四须弥四峰喻。喻善根超出。不合四峰。若合可以四菩萨行合也。五大地能持喻。喻大悲荷负六大海含水喻。喻大愿普育。七军将明战喻。喻习定防怨。八轮王护世喻。喻定清物惑。九植种生长喻。喻行增物善。十时雨生种喻。喻法雨普成。先喻后合。合中二。先正合。后征释。前中云乃至者。越初生种直合终成故。由应时而降故。获斯十四种益。一得智果净二障故。二得断果达无相法故。三得恩果住大悲故。四得所依清净。究竟彼岸果。上四自利余皆利他。五了有情行令他欢喜。自离十怖则自欢喜。六得断疑。七成应供。次下诸句由此而成文并可知。后征释中。征意云。菩萨依何行力说法。成斯大益。释意云。由成大智证法界故。尚能净无量行。岂止成众生耶。文中二初标。后所谓下释。释中三。初列所净功德。二佛子下结其广多。以别说难尽故。三于如是等下显能净因。同分善根者。一一善根回向法界成主伴故。超诸世间等者。法性相应所修之福故超于世。法性不并真故无有对。余并易了。第四佛子菩萨摩诃萨住此三昧下。正同佛果益。于中二。初正显同有标征及列。等觉之名由此而立。二尔时普眼下问答料拣。于中先问后答。问中先牒前同佛。后何故下陈己所疑。于中初疑不名为果。后问不舍于因。后尔时普贤下答中二。初赞问牒疑。后佛子此菩萨下正答所问。于中三。一法说。二喻况。三法合。今初十一段。次第答前十一问。在文易了。意犹难见。谓何得已入十力而普行无息耶。今总以喻显。如人习诵虽已得通。而数温习不如久精。下香象喻显相。虽相似而体不同故。璎珞云。等觉照寂妙觉寂照。亦似功用满位。此无功用也。亦显得果不舍因。尽未来际。皆位后普贤故。喻中三。一举象王依正胜严。伊罗钵那此云香叶。常居第一金山之胁。二若天帝下明象王神变自在。言七牙者。准贤首品但有六牙。或是译者类后三七便言七耳。若作表义于何不可。无能分别此象。此天者正意取此以喻菩萨等佛之义。三佛子彼伊罗下。明不坏本而能现。第三法合中分四。一具众行严合前依正。二为欲安处下明因果无碍合前神变自在。三佛子菩萨摩诃萨本身下。结成不坏因而现果。合前不坏本而能现。四何以故下征释重合。初中可知。二中二。一明修无碍行所为。于中先为果。后增长下为因。二不舍普贤下正显无碍行相。于中先总明。以法界因果无障碍故。后现不可说下别显。于中分三。初显因门果行。文有四果。一智果。二说法果。二般若相应果。四断果。次而现受生下显果从因行。及说得时不同随物现故。后复于一切下显果门因行。并可知。第三明不坏因而现果中。本身不坏即因不坏。合在窟无变。一切处变现即能现果。合在天神变。四征释重合中。先征意云。因果相违云何因门现果。果复为因。释意云。调众生法应如是故。文中二。先释果作因意十句可知。后佛子汝应下释因现果意。于中四一法说谓不舍因而现果。二如伊罗下举前喻显。三佛子下重以法合。于中初明不舍因而现果。后虽知诸法平等下。不坏果而现因。四佛子至安住下叹胜。上来释相竟。第三结名可知。上来别释十定竟。最后佛子即大文第三总结十数

大方广佛华严经疏卷第四十五大方广佛华严经疏卷第四十六

        唐清凉山大华严寺沙门澄观撰

    十通品第二十八(已下入第四十四经)

初来意为答第二会中十通问故。以二品明业用广大。前定。此通。义次第故。亦由依定发通。二释名者。通即神通。谓妙用难测曰神。自在无拥曰通。妙用无极寄十显圆。晋经本业俱称十明者。委照无遗故。然通与明经论皆异。故智度论第三云。直知过去宿命之事为通。若知过去因缘行业为明等。今以此经通即委照亦得称明如文广说。故下经云。非诸菩萨通明境界。晋经意存顺义。今译务不违文。三宗趣者。智用自在为宗。为满等觉无方摄化为趣。次正释文。长分为四。一举数标告二。征数列释三。总叹胜能四。结数辨果。今初。言十者。一他心。二天眼。三知过去劫宿住。四尽未来际劫。五无碍清净天耳。六无体性无动作往一切佛刹。七善分别一切言辞。八无数色身。九一切法智。十入一切法灭尽三昧。此十皆言智通者。皆以大智为体性故。若随相说。前八量智。后二理智。据实唯一无碍大智。此十亦是开彼六通。天眼天耳神足漏尽各分二故。天眼约见现未分成二四。天耳约音声言辞。分出五七。亦是约闻圣教及诸类言辞故。神足约业用及色身。分成六八。漏尽约慧定分成九十。一三不分故六为十。然小乘六通智用有分。三乘平遍亦非曲尽。今一乘十通智用重重遍周法界。犹如帝网念刹圆融故。尚越彼明况于通用。为显圆旨开成十通。第二何者下征数列释中。先总征。后佛子下别释十通。即为十段。段各有三。谓标．释．结。今初标。云他心者。智以他心。为所缘故。若直就所缘。应名心差别通。若所若王种类多种皆能知故。并依主受名。然智缘他心诸说不同。安慧论师云。佛智缘他心缘得本质。余皆变影。护法论师则佛亦变影。若缘本质得心外法。坏唯识故。但极似本质有异因人。依唯识宗护法为正。以今经望前亦未失。以摄境从心不坏境故。能所两亡不碍存故。第一义唯心非一非异。正缘他时即是自故。以即佛心之众生心非即众生心之佛心为所缘。以即众生心之佛心非即佛心之众生心为能缘。如是镕融故非一非异。若离佛外别有众生更须变影。却失真唯识义。二知一下释相中二。初知一刹。后如一下以少类多。前中三。初总。次所谓下别。后如是下结。别中有三十类心。阙第三无记。晋经具有。于中前十约相总显。后二十心约人别显。前中初二约性总该诸心。次二约行兼济独善故。次二约报。天大人小故。上四唯善。次二约向背。而顺通三性善惟有漏。背唯是善通漏无漏。约人辨中。初六约乘。前三是果。后三是因。即前背生死心及广狭心。次八部约类。即前顺生死及大小心。地狱等约趣。亦顺生死是不善心。余并可知。第二天眼。标云无碍者见自在故。清净者离障故。天眼即通。二见无量下释中分三。初总明多界相殊。其善恶趣等。后后展开如问明品。次所谓下别明多类非一随一一类有前罪等。三如是种种下委照分明。前但睹其现相。此则照其因缘。十明之目由此而立。于中初能见分明。次随所下所见委悉。言随所者所知非一故。后悉皆下结其无谬。文并可知。第三宿住通。标中谢往之事名宿住。在过去明了记忆为随念。即宿住之随念。宿住随念之通。二能知下释相中二。一知凡事。于中先总。所谓下别。二又忆过去下知佛事。于中亦二。先约界显多。但知其果。后又忆念下约人显多兼知其因皆以菩萨得九世眼如见现在故。若不尔者过去之法若不落谢不名过去。若已落谢无法可知。若但曾经心中。有种影现前故。说忆知者。是则但见自心不见彼法。又曾不经事应不忆知。又但见现在非是过去。何名宿住。余文可知。第四知劫通。亦从境受名。二知不可说下。释相中二。先知凡。后又知下知佛。前中亦二。先明所依劫。但寄多界以显多劫。非有际限名。及后段。皆尽未来。此位所知同于佛故。后一一下显能依事。义如十地中辨。然大乘宗。未来世法体用俱无。今云何知。依方便教但见现在因种。知当果相。非见未来法体。若一乘宗。于九世中。未来中现在体用俱有。今称实而知。然非现在之现在。故称未来。此有若是性有即同小乘。若是缘有缘今未曾。云何言有。若今时看缘性俱无。以是现在未来定非有故。若逐未来时看。以是未来之现在故。还如今有。第五天耳通。初标名。略无智通。若直云天耳。即当体受名。若取无碍清净之天耳。即依有德业受称。二圆满下释相中三。初总显德业自在。二佛子下别示一方业用。三如东方下举一例余。今初九句皆约用辨德。前之标名即是总句。一圆满者能互用故。二遍闻十方及九世故。三一时领览通其源故。四离二障故。五明了所知故。六缘不能碍故。七非如权小闻有分限。不尽重重故。八已证得故。九于一切皆自在故。谓欲闻则细远无逃。欲不闻则近大不挠。故云自在。第二别示一方业用中二。初举多佛欲显闻广。二是诸佛下显闻忆持。于中二。先闻持教法。随释可知。后又于下显持圆满。即能持之相。于中二。先举所持。上文通显佛所说法。今辨所说差别。后于彼下辨能持相。兼明转化。余文可知。第六无体性智通。初标名中有十四名。初一总通。即无体性。余皆别。别中一无功作用。二同理平等。三能普遍。四量难知。五非谓依体起用。六但随念即形。七现有作用。八不动本处。九作必究竟。十用无间歇亦不断佛种。十一他不能坏。十二能生善根。十三随何所诣。于十三中。初二五八是无体性义。余即神通义。此二无碍故受斯名。二此菩萨下释相中三。一明广大。谓闻多刹佛名。即见身在彼多刹故。二彼诸世界下。明无量不起等义。谓又于彼佛重闻佛名。便往敬事受道无著故。三如是经下明不断义。谓于多时体用无碍故。第七善分别言音通中。初标名。从所了得名。即依主立称。若从所发得名。即通持业。二知不可说下释相中二。先知言词有标列及结。后此菩萨下明发言词。谓随乐差别而发言故。有法喻合。文并可知。第八色身庄严智通。依所现得名。即有财立称。二知一切下释相中三。初知无色以色即空故。二菩萨如是下明能现色。以空即色故。三佛子下双明无色现色。所为不碍悲故。今初由了法界无定实色。举体即空非断空故。空中无色不碍色故。存亡隐显皆自在故。方能随乐现种种色故。先明之。于中六句。初一总知色性离相。亦无有法而为空故。余五别明离何等相。一离差别相粗妙长短等。同一无生体故。二种种异相虚故。三无量多相离故。又无大小绝分量故。四但妄分别求叵得故。色空二见皆请取故。即与不即斯见绝故。上通形显。五离显相依形有故。二能现色中。初结前标。后以即空之色为妙色故。又空色不二成上真空。不二而二现斯妙色。色空融即为真法界。缘起无尽即一现多。后所谓下别显不同有一百三种。或从色相立名。或就德用受称。可以意求。然然皆是称法界之色。不同变碍。但随所显以立色名。三双明所为中。初结前后今所化下显其所为。有十句并可知。第九一切法智通。初标名。从所知真俗等法受称。二知一切下释相中二。初明知法。即内证事理。后此菩萨下明演法。即外益众生。亦是前明即事常理。后明即理恒事。用寂寂用无障碍故。今初。又二。初约离言显实。二无我下约二空显实。今初之三句。一向显实。一名无得物之功故。二缘成无性故。三体绝去来故。下有三句相对显实。然此三对释有三义。一唯约显实则相待而空故。异相互无故云不异。遮异言不异。亦无不异可得云非不异。二约双显体则不异相非不异。三约双遮相即性故非异。性即相故。非不异。又相非相故不异。性非性故非不异。故离二边不住中道。下二对例知。二约二空显中。亦初三对一向显实。无比者无有我所与我为比对故。余二可知。无实下亦通三释。准前知之。且约显实以释。一虚实皆缘显故。二法性不并真故一相。一亦不为一故无相。有无皆法待对故。无法与非法但假施设。并就实而求。能治所治无不双寂。余皆仿此。第二演法外益中三。一牒前成智。为起用所依故。二不舍下正明演法。三虽知实相下寂用无碍。于中三。初寂不碍用。次虽有言说下用不碍寂。后于不二下寂用无二。第十灭定智通中三。初标名。云一切法灭尽者。谓五聚之法皆当体寂灭故。斯即理灭不同余宗灭定。但明事灭。唯灭六七心心所法。不灭第八等。但事灭故。不能即定而用。证理灭故。定散无碍。由即事而理故不碍灭。即理而事故不碍用。是以文云。虽念念入而不废菩萨道等。亦非心定而身起用。亦不独明定散双绝。但是事理无碍故。上七地云。虽行实际而不作证。能念念入亦念念起。及净名云。不起灭定现诸威仪。皆斯义也。事理非一故。一切法灭尽之神通非异故。灭尽即神通。通二释也。二于念念下释相中二。先明即定体用自在。后此菩萨住三昧时下。明入定时分自在。前中亦二。先标入定。二亦不退。下明不碍用。于中初二句总。未作不退。现作不舍。正简事灭以显真灭。余句别明。文显可知。第二明入定时分自在中三。初长短随心。二菩萨入此下威仪不忒。三虽于有无下不碍起用。定散双行。于中先法后喻。光影普现寂然无心。随器亏盈体无来去。三是为下结名。大文第三佛子菩萨下。总叹胜能中二。一形劣显胜。劣不测故。二唯除下以胜显胜。谓佛等方测故。大文第四佛子是为下结数辨果。文显可知

    十忍品第二十九

初来意者。为答普光十顶问故。义如前释。前二已明通定用广。今此辨其智慧深奥故次来也。二释名者。忍谓忍解印可。即智照观达。寄圆显十。三宗趣者。智行深奥为宗。为得佛果无碍无尽为趣。然此忍行约位即等觉后心。为断微细无明。若约圆融实通五位。寄终极说。体即是智。不同余宗忍因智果。虽是一智随义别说。二三四五等诸教不同。今此圆教故说十忍。四正释文。文有长行偈颂。前中四。一举数叹胜。二列名显要。三依名广释。四总结其名。今初先举数。后若得下叹胜。到无碍地。即自分因圆。佛法无碍即胜进果满。第二何者为十下列名显要中。初征数。次列名。后显要。名中前三约法。后七就喻。三中初一约教。谓忍于教声从境为名。音声之忍。次一约行。顺诸法故顺即是忍。三无生忍者。若约忍无生理即无生之忍。若约无生之智及烦恼不生。则无生即忍。通二释也。又此三忍。若通相说。前二皆是无生忍之加行。顺向无生。后一方契。若约当位三忍条然。以不应此位方有顺无生忍故。顺但顺理。不是顺忍。若尔何异无生。顺忍通顺事理故。不同无生。经云。法有亦顺知等。又依五忍位当寂灭。今约三忍明义故当无生。如地持说。后七约喻中并是依主。谓如幻之忍等故。光统云。约四喻音声。电化喻顺忍。空喻无生。电即今之影喻。又云幻者。起无起相。焰者境无境相。梦者知无知相。响者闻无闻相。电者住无住相。今既云影。应云现无现相。化者有无有相。空者为无为相。此则能喻局于一相所喻义通多法。在文虽无于理无失。又古德云。观识如幻想如焰。受如梦声如响。行如电色如化。总观一切蕴界处等。毕竟空故。如虚空也。此释顺后会偈文。故今影喻亦喻于行。若依摄论。第五八喻皆喻依他起性。然并为遣疑。所疑不同故。所喻亦异。一以外人闻依他起相。但是妄分别有。非真实义。遂即生疑云。若无实义何有所行境界。故说如幻。谓幻者幻作所缘。六处岂有实耶。二疑云。若无实何有心心法转。故说如焰。飘动非水似水妄有心转。三疑云。若无实何有爱非爱受用。故说如梦。中实无男女而有爱非爱等受用。觉时亦尔。四疑云。若无实何有戏论言说。故说如响。实无有声听者谓有。五疑云。若无实何有善恶业果。故说如影。谓如镜影像故亦非实。六疑云。若无实何以菩萨作利乐事。故说如化。谓变化者。虽知不实而作化事。菩萨亦尔。然彼论无空喻。而影喻是镜像。更有映质光影喻。喻种种识无实。又有水月喻。喻定地境界无实。今经以义类同故。合在影中。至文当知。远公见其无空便以空喻喻无为法。非不有理而违下经。经云众生及诸法皆如空故。若尔云何释空喻耶。谓彼疑情虽遣。犹谓诸法有不实相。故云如空毕竟无物。余义广如摄论及别章说。金刚般若九喻亦皆喻有为。若大品智论十喻。通喻一切。楞伽亦通。今经长行多同前通。而偈所喻亦有局者。显义无方故。已释列名。此十种下显要。要故同说。大文第三佛子云何下。依名广释即为十段。前七皆三。谓征起释义结名。初忍释中十一句。初一总举所闻。谓三无性等法。余显能闻入法。谓闻无相不惊。以解遍计无所有故。闻无生不怖。以解依他必无生故。闻无性不畏。以解真如无性性故。又释。于真空法闻时不惊越。思时不续怖。修时不定畏。又闻有无所有不惊。闻空无所有不怖。闻斯二无所有故不畏。并如诸般若论说。深信者闻慧之始。悟解者闻慧之终。初信久解故。爱乐者思慧之初。爱法乐观故。趣向为终久思向修故。专心忆念者。修慧之初。起加行故。修习为终。正明造修至定根本故。安住者。依定发慧。证理相应故。具如瑜伽菩萨地中。第二顺忍释中。有四重止观。一创修止观。谓止思一境。观观事理。二渐次止观。谓止安事境顺其理故。名平等无违。观达事理名随顺了知。偈云。法有亦顺知。法无亦顺知故。三纯熟止观。谓止惑不生名令心清净。观彻前境为正住修习。四契合止观。寂冥理境名为趣入。智显于心故云成就。上四皆止观俱行。如是方为真实顺忍。第三无生忍释中有二。先总明。后何以下征释。今初。若具皆应征无尽等。此二为总故略标之。释中具有皆此别义。后征释中。征意有二。一云何以得知无生灭耶。二云既称无生法忍。何以复言不见法灭。释中释初征意云。真法本自不生。从缘之法无性故不生。以无生故。何有于灭。此则以缘集释无生。以无生释无灭。此中略无缘集。偈文具有。云何无生释无灭耶。此有二意。一云若先是生。后必可灭。本既不生今则无灭。二云既即缘无性称曰不生。则不待灭竟方无故。次云无灭。此二为总。余可仿之。释第二征意云。夫无生忍非独无生。必诸法都寂。今从初义立无生称故。无灭等成无生义。若从别义亦可得称无灭忍等。是以信力入印度经。明此忍能净初欢喜地云。一谓得无生忍亦令他住。又云。无生忍者。谓证寂灭故。二得无灭忍亦令他住。又云。无灭忍者证无生故。斯文可据。又此诸句各有二义。一以前前释后后。以后后成前前。前前有故后后有。前前无故后后无。二者诸句一一皆在无生句中。正无生时诸义顿足。以是即事之理非断灭故。即理之智无能所故。然文旨包含略为三释。一唯约理。二具理智。三唯约智。今初。云何前前有故则后后有。谓生法既灭灭则终尽。尽则是垢染法。染则前后别异。别则方处不同。有处则能所非寂。不寂则有所欲。有欲则有营作。作则有所愿求。愿则心住愿事。住则有去有来。今由前前无故后后斯寂。故以后后显成无生。此顺长行。二双约理智者。初二是总含于理智。次四显理无生。后六显智无生。故偈云其心无染着等。理智契合名无生忍。三唯约智者。由了从缘无生。则智无有起。故名无生。无生之忍湛然不迁。故云无灭。无灭故用无断尽。次垢念皆离常无差异。傍无方所照而常寂。遇境无染虽为而无作。虽悲而无愿。处世而无住。等法界而无去来。皆以前释后。以后成前。言亡虑绝寂照湛然。名无生忍。若唯约知无生理名无生忍。未足深玄。第四如幻忍释中。先略后广。略中二。先了幻缘相。后此菩萨下成就忍行。今初有三。初指法同喻。次从因缘起者。彰幻所由。由缘生不实故。后于一法下显其幻相。初一切法即是所喻。所喻通局。已见上文此意明通。通为无为。故大品云。设有一法过涅槃者。我亦说言如梦如幻。涅槃虽真从缘显故。遣着心故。广中合云了世如幻。则似有为。然有法世亦通无为。此为有为所隐覆故。所以名世。故后云菩提涅槃亦皆不见者了平等故。就法喻中各开五法。如结一巾幻作一马。一有所依之巾。二幻师术法。三所现幻马。四马生即是马死。五愚小谓有。初巾喻法性。二术喻能起因缘。谓业惑等。三喻依他起法。即众生等。四喻依他无性。即是圆成故。广说皆云非也。五喻取为人法。今菩萨反此。故云解了。今经云从因缘起。能起即第二。所起即第三。以第二为因令悟第三。成第四。遣第五病归第一理。然缘亦从缘故缘果俱幻。中论云。譬如幻化人复作幻化人。即斯意也。然上五义各具有无。一巾性有相无。为马所隐故。二术用有体无。以依巾无体故。三马相有实无。以实无而现故。四生即是无死即是有。以无碍故。五情有理无但妄见故。又五中各有四句。准思可知。然皆具德不同。四谤若以诸门交络成多四句。亦可思准。后显幻相略为二解。一约相类。谓解一无实则知一切皆然。并从缘故。故云一中解多等。二约圆融复有三义。一以理从事故说相。即如马头之巾不异足巾。说头即足故。一即多等。无行经云。贪欲即是道者。贪欲性故。诸法即贪欲者。即贪实故。二以理融事一多相即。如马头无别有。即以巾为头。以巾体圆融故。令头即足。故云一中解多等。三约缘起相由力。则法界同一幻网。令一多相即。如幻师术力令多即一等。贤首品云。或现须臾作百年等。以幻法虚无障碍故。相即既尔。相入亦然。入则一中有多等。异体既尔。同体亦然。一门既尔。余门思准。二成忍行中。由知法幻成二种行。一忍智现前云了平等。二幻用无碍云成通化。云何平等。一理事平等。如巾马无二故。色即空等。二理理平等。如头足俱巾。巾无别故。如贤圣同如。三事事平等。如前一多中说。第二譬如下广中三。一喻。二合。三成忍行。初中二。先明性无。即体空义故。结云非是一切种种之物。所非之事。亦可次第对前情非情境。二种种非幻下明其相有。即相差别义。故云然由幻故示现别事。于中初二句。结前生后。种种非幻者象等非术故。下句反此。法合可知。然由下正显相有。虽互相非。然由因起果。虚而假现。又喻智了平等而起化用。第二菩萨下法合。文有总别。皆言世间者有二义。一可破坏故即喻有为。二隐覆名世。亦通无为则法通五类。趣谓五趣。成坏约器一期说故。运动通情非情。念念移故。造作唯情现营为故。第三菩萨至观一切下成忍行中二。先成真智行。由了体空故。故结云不出平等性。又前法中明即寂之照。云了平等。此明即智之止。故云不见。是知无幻之幻方是幻法。绝见之见方为见幻。二是菩萨下明动寂无二。亦权实不二故。经云。智不得有无而兴大悲。心由了体空不坏幻相差别故。如象生即是象死。此二相对应成四句。谓此二无二故非异。无不二故非一。非一即非异故非非一。非异即非一故非非异。亦绝双照故非亦一亦异。若以巾上二义对象上二义。辨非一异略有十句。一以巾上成象义。对象上差别义。合为一际名不异。此是以本随末就末明不异。经云。法身流转五道名为众生。如来藏受苦乐与因俱。若生若灭等。二以巾上住自位义。与象上体空义合为一际。名不异。此是以末归本就本明不异。经云。一切众生即如。不复更灭等。三以摄末所归之本与摄本所从之末。此二双融无碍不异。此是本末平等为不异。以前二经文不相离故。四以所摄归本之末。亦与所摄随末之本。此二相夺故名不异。此是本末双泯明不异。以真妄平等异不可得故。次下四门明非一。谓五以巾住自位义。与象上相差别义。此二本末相违。相背故名非一。楞伽经云。如来藏不在阿赖耶中。是故七识有生灭。如来藏者不生灭。此之谓也。六巾上成象义与象上体空义。此二本末相反相害故非一。胜鬘经云。七识不流转不受苦乐。非涅槃因。唯如来藏受苦乐等。七以初相背与次相害。此二义别故名非一。谓相背则各相背舍相去悬远。相害则相与敌对。亲相食害。是故近远非一。以前经文不相杂故。八以极相害俱泯而不泯。与极相背俱存而不存。不存不泯义为非一。此是成坏非一。以七识即空而是有故。真如即隐而是显故。九上四非一与四非异。而亦非一以义不杂故。十然亦不异以理遍通故。法无二故。若以不异门取。诸门极相和会。若以非一门取。诸门极相违害。极违而极顺者是无障碍法也。巾象相对既尔。术等相对交络诸句准之。上下诸文非一异义。皆准此释。余文可知。第五如焰忍释中有三。一指法同喻。所喻如前。二譬如下别显喻相。三总以法合。二中若别开义门亦具五义。一空地。二阳气。三气。与空地合而有焰。四焰似水即无水。五令渴鹿谓有。初喻如来藏。二喻无明习气。三喻习气熏动心海起于缘生似法。四喻依他无生。五喻凡小执实。若十喻论法喻各有多义。如彼广说。其有无等义如幻应知。经文有二。初喻体空。后但随下喻其相有三。菩萨下法合中。初明了法。后现证下明成忍行。第六如梦忍释中亦三。一标法同喻。二譬如下正举喻相。然开此梦义亦有五法。一所依。谓悟心以喻本识。二所因。谓睡盖以喻无明习气。三所现。谓梦相差别。以喻缘所起法。四此梦事非有而有。但心变故。非见前法。五令梦者取以为实。文中初明俱非喻法非有。后云而示现有。喻法而有。双辨为俱句。互夺为双非。然此四句皆由以是梦故。谓一以是梦故。有梦事现。于梦者为有。二既言是梦其性必虚。于无实处而见实故。然语有则全摄无而为有。言无则全摄有而为无。以非二相故。非但相有性无而已思之。三以是梦故必具二义。全有之无与全无之有。二门峙立不相是故。非是半有半无。四既言是梦必是双非形夺俱融二相尽故。然此俱非不违双是。以若不夺无令尽。无以为无。若不夺有令尽无以为有。是故存亡不碍俱泯自在。方为如梦自在法门。是故经云。世间恒如梦。智不得有无。此之谓也。第三菩萨下。合喻中十句。初句为总。次无有下别。别中初句近上总句。略无如梦二字。于九句中前八辨梦。后一明觉。就前八中摄为四对。初二明常无常门。体虚无变即是常义。自性无恒是无常义。次二辨真妄门。妄由着生真由性离。次二性相门。性本一如相现多种。后二明一异门。但是一心一而无别。随相分别。异异不同。又唯是一梦相现多种。上之四门各双存互夺。以为四句思之可见。后一句明觉。即止观门。谓要在觉时方知是梦。正梦之时不知是梦。纯昏心故。设知是梦亦未觉故。觉时了梦知实无梦。然由梦方有觉故辨梦觉时。若离于梦梦觉斯绝。观了上之多门。止不取于梦妄。如此方为了梦法门。第七如响忍释中分三。一忍行所因。二知一切下成忍之相。三此菩萨下忍成之益。今初。由闻起观。能成忍故。二中先法。后喻。法中有二。一指法同喻略显其相。通知一切音声如响。无去无来明其体空。如是示现彰其相有。二佛子下了知佛声如响。非独但喻世间声故于中先明即有之无。离机无声故非内。离佛无声故非外。二法相依故非内外。若言内外和合有者。便有二声。内外相依即显无性。后虽了此声下。明即无之有故。牒非三而能巧现。第二譬如下喻显。于中四。一喻。二合。三转喻。四重合。今初。直举从缘所起。明响无性。无性之相已见法中。然有五法。一空谷二有声。此二是缘。三声击空谷便有响应。此明所起。四有而非真。此彰无性。五愚小谓有。亦有有无等义。如上准之。然此一喻通喻三法。一喻上一切声则谷喻喉[壺*桑]。声喻风气。二喻上如来声。则谷喻如来。声喻缘感。三喻一切法。今经略无。晋本具有。大品十喻亦响喻一切。则谷喻如来藏。声喻无明习气。二而与下合。但合佛声以从近故。然初至令诸众生随类各解。言含法喻。谓约法则如来之声。不违法性而能随类。合上能巧示现。约喻则不违本声事法之性。随其呼人类别各解。三如帝释下转以喻显。此有二意。一则喻上佛声一音随类。二则喻下菩萨无心普演。四菩萨下重合。第三此菩萨下忍成之益。于中二。一随机遍说。二虽知声下明权实双行。以同于响性相无碍故。是则由闻如响之教。了如响之声。发如响之音演如响之法也。第八如影忍文分四别。一标。二释。三结。四果。释中有三。谓法。喻。合。今初。法中有十一对分三。初七对双遮显性。以成止行。如影无实故。二非修下二对双照性相以成观行。如影虽虚而现故。性则非修。相乃不舍。真即俗故非实。俗即真故非不实。三虽常下二对。遮照无碍成双运自在行。初对双照真俗。即权实双行。后对双遮真俗即权实双寂。遮照一时为双运。互夺无碍为自在。以此结上二段。同斯无碍为忍相之深玄。二譬如下喻中文具五法。一日等为所依本质。二于油下明能现之处。上二是缘。三而现其影下明缘之所起。四影与油下明有之非有。五然诸下愚小谓有。今初。若约影喻别喻菩萨现身。则日等喻悲智愿等。若约影喻通喻一切法。则日等喻因。其河泉二种。虽通能现且为所现。长河飞泉入镜中故。二能现中亦有通别。别喻机感及应现处。通喻于缘。谓无明等。然此文具摄论三喻。一以油水对上日月。为水月喻。喻于定地所引境界。以水有润滑澄清性故。镜等影像阙此润等。喻非定地。二以于身。对上日月为光影喻。身映日等而有影故。弄影多端故喻于诸识。三以宝镜等对上男子等。为影像喻。喻非定地果报。以镜中影像离于本质别现镜等之中故。喻于果与因处别。前映质之影。虽因日等影乃随身。不于日内而现故。喻诸识虽托境生异。自在我非在于境。三明所起中。亦有通别二果可知。四明有非有中摄多义门。于中一异合离通显影义。各有四句。如幻喻辨。然一异约此影彼影。合离约影对水等。次于川流下。别显影义不通二影。如月映淮流。流水不将月去。光临潭上万仞不见光沈。喻菩萨同世迁流不漂生死。证真寂灭不沈涅槃。后虽现下双结有无。喻性相交彻兼于镜像。五取为有中。由以有无为有无不知即影了不可取。故成执着。于中先取有无为着。后远物下举影正义。显上为执不知此影无远近故。第三菩萨下合中二。先正合前文。于中初举智境合前本质。次而于下合前油等。后各各下合前现影。二如种子下。转以喻合非有之有。于中先喻。后合。有无无碍名为方便等。第三结名可知。第四果中三。初得称性之身。如影不往而至不分而遍故。次然此下结成无碍。以无差是差之无差故。虽不往而遍令物见殊。差是无差之差故。虽遍而不在彼此。后此菩萨下显此身因。其无边身近局果中。亦通前法。第九如化忍文分四别。一标。二释。三结。四果。标云化者无而忽有故。释中有三。谓法喻合。法中二。先总标。标法同喻。具能所知。既知一切世间。不局所化情类。略标世间应具出世。后所谓下别显。先显所知。后显能知。前中十句。前五染化。后五净化。今初。不出惑业苦三。前四是苦。即五蕴相。一识由想起。二行因识生。分别是识故。三受因想起。想取爱憎相故。四色亦行生无记报。色如沫不实。名言熏习即是行故。五即是惑。惑由想行。念即行故。业通二处。初句意业此句分别。皆是业故。此中意等。从缘无性如化不实。本无今有。如化相现故。仁王经云。法本自无因缘生诸。净化二义仿此可悉。后复有下明后五净中。一方便调生。依真智故。二湛然真智。由理成故。故上文云智入三世了法平等。三愿由行满。四慈悲。复依方便立故。五具无畏辩。能转法故。二菩萨如是下。别显能知。于中初二句结前生后。世间结前染。出世结前净。亦结余所不尽。谓乃至一法过于涅槃。亦如化故。或说涅槃不如化者。大品云。为新发意菩萨恐其惊怖。分别生灭。方如化故。余如幻说了知之言即是生后。次现证下。正显能知。上言了知。知有六义。一若事若理非比度故。二傍无遗故。三契中道故。四称俗境故。五真俗无碍故。六归一实谛故。后非虚妄下结上六知处真道而不倾。行非道而不坏。第二譬如下喻。中应开四义。一能化者以喻因缘。二化现事喻所起果。三现用而无实。四愚小谓真故。十喻传云。犹如化事虽空无实。能令众生忧苦嗔恚喜乐痴惑。诸法亦尔。云何无实。如彼化人无生老死。苦乐异余人故。文中有四十句。初句标。次三十七句。一向双非。以显无实。后非有非无有义通二种。一亦是双非。谓无有亦无故。二双融性相。化不实故非有。现化事故非无有。对成四句。及一异等。准前思之。第三菩萨如是下合。中二。先化行。后佛子下化益。前中四。一起化用。以同化相有故。然但云菩萨如是者。以上诸非一一通法故。指上如是为善巧方便。二不着下明化智。以了化不实故。三以本愿下双非显中。四了法下结示化旨。化益及结文。显可知。第四果中先得利他业用之果。后佛子下得依自利立胜名果。第十如空忍中亦四。谓标。释。结。果。标云如空。如空所喻通一切法。佛地喻清净法界。以离差别相故。及中边等论喻圆成实。但是此中一义。然其喻相小异诸喻。诸喻开义多分有三。虽正取所成幻等以喻于法。而亦取缘等以显无性。此中喻相不开别法。直指于空。具含多义。以喻于法。又此诸喻。若约能喻前五多取似有以破实有。化喻以不有之有破于似有。此喻以性相俱绝破于一切。又前六遣有会空多。依空立有少。此一遣有入空少。依空立有多。又上所喻则通一切。此中能喻则具多义。所喻各随别义。喻一类法。然龙树十喻。以四复次释如空义。一近无远有。谓如虚空非可见法。以远视故。眼光回转则见缥色。一切诸法亦复如是。空无所有。以凡夫人远无漏慧弃舍实相。则见彼我男女等物。而实此物竟无所有。二约性净不染。三约无初中后。四约体实无物。及佛地论有十复次。上八地中空有十义。皆是略明。然别义有此不同。若约同义诸喻无别故。睿公云。十喻以喻空。空必待此喻。借言以会意。意尽无会处。若得出长罗住此无所住。若能映斯照万象无来去。余无碍义如前后说。第二释中二。先忍解之相。后忍行成益。今初。先别明。以空九义喻九种法。随义虽别。然其总意。亦以缘成无性故空。然九句各初标法同喻后出所以。一标事法界。如空下出所以者以无相故。谓从缘无性其相自虚。即事是理法界故。此句为总。二世界共业所起故。三轨仪教法一味法界所流故。及余六句并准初句。后菩萨如是下总结。第二佛子下忍行成益中三。初总明得如空三业业具。二譬如下别显德齐虚空。于中初二句。一向喻实。无依为依已下皆显性相无碍。从缘有故。无性空故。又此二相即故便成四句。一缘生故空。缘生故有。二无性故空。无性故有。三缘生故有。无性故空。四即反此。余一异等。并例此知。无法出空故皆现其前。空不可见故不现法前。余并文显。三何以下征释得益之由。所以得者。释意云。空观成故。于中二。先智证齐空故。一体者真如平等故。一味者解脱不殊故。一种分量者。大小皆称性故。后严净下。德用满空故结名可知。果中得二十种身。前十与十行及离世间。大分相似。然通相多从德用立名。可以意得。大文第四佛子至是名下。总结十忍。第二祇夜一百七颂。大分为二。百偈颂前。七偈结叹。前中但颂广释。即为十段。段各十偈。初有十颂。颂音声忍。于中先二偈颂所闻佛说。余颂能闻入法。于中一偈颂不惊怖畏。一偈深信。一偈悟解。二偈爱乐。一偈修习安住。后二偈颂趣向专心忆念。二有十偈颂顺忍。于中初一偈三句颂思惟。次二偈一句。颂随顺了知令心清净。次一却颂观察平等无违。余颂正住修习。三有十偈颂无生忍。初三颂标。以前三忍皆是法说故。偈初各加其喻。次四颂释。后三结叹。第四颂如幻忍。初六颂略说。于中前四颂指法同喻。及显缘相。后二颂成就忍行。后四颂广。于中初二颂喻。次一颂合。后一颂忍行成。第五如是下颂如焰忍。初一摄前生后以明观意。次三颂指法同喻。次一颂喻。后三颂合。第六菩萨了下颂如梦忍中。正颂前合兼颂标喻。十颂颂前九句。一颂无变异。二一颂颂自性。上二兼颂标法。三颂执着翻则解脱。兼颂前喻。四颂性离。五超颂所现。六却颂本性。七八二颂颂无差别。九颂想分别。十颂觉时思之可了。第七修行下颂如响忍。初一偈颂忍行所因。文云。修行如是行。似结前喻。既言知诸法性。义同忍行。次二偈颂闻一切声如响。次二颂知如来声如响。余颂忍成之益。其喻遍诸偈中。第八为欲下颂如影忍。颂法说十对。喻合含在其中。初二偈颂非世生没。谓了寂故不生。饶益故不没。次偈颂非在内外。不住故不内。不离故不外。次偈颂非行不行。了无染故非行。化世故非不行。次偈颂非同非异。知自性故非同。了无二故非异。次偈颂非往不往。第二句不往。余三句非不往。次六句颂非住非不住。于中初二句兼别颂喻。故云非内外。次亦不在内外二句。颂非是世间非出世间。次入此一偈。颂非修菩萨行非舍于大愿。次一偈颂虽常行一切佛法。而能办一切世间事。其实不实及不住世流法流。义通结上。故略不颂。第九观察下颂如化忍。初三偈颂总知一切世间如化。次一颂染法化。次二颂净法化。言度脱亦如化者为释疑故。谓观察众生如化。何用化之。故此答云。化若有实可招来难。度既如化化之何妨。余颂法合。第十颂如空忍。初一偈颂忍解之相。余颂忍行成益。于中初五偈颂别。显德齐虚空。次三偈颂征释得忍之由。后一偈。却颂上总明得如空三业。末后七偈结叹中二。前三二利行圆。言超过一切正显十顶之义。后四显深难测上智所知

大方广佛华严经疏卷第四十六大方广佛华严经疏卷第四十七

        唐清凉山大华严寺沙门澄观撰

    阿僧祇品第三十

初来意有二。一通。谓前三品别答前问。此下三品总明等觉深奥故。二别。谓前既智圆证极。此品校量行德难思。故次来也。又难思佛德菩萨尽穷。故亦为远答变化海故。故下偈中广显变化大用。又通显一部之数量故。二释名者。阿之言无。僧祇曰数。全带数名。若晋本云心王菩萨问阿僧祇品。兼能问人。即人法双举。及菩萨所问之算数。梵本同此。然僧祇是十大数之创首。经论多用故以标名。又显此数即离数故。寄无数标名。三宗趣者。寄数显德分齐为宗。令知普贤诸佛离数重重无尽为趣。四正释文。此下三品总显深奥。即为三别。此品明胜德无数。次品明尽一切时。后品明遍一切处。然此三品。初一通明佛菩萨德。次品正显佛德兼明菩萨。后品唯明菩萨。所以尔者。亦是等觉亦名佛故。位后普贤是佛菩萨故。今初一品。先问后答。问中二。先牒佛所说。后世尊下正明咨问。今初。所以心王问者。表数不离心数与非数皆自在故。又显此数统收前后辨超胜故。所以偏问十者。举后摄初。显无尽故。前后文中多用此故。故文云如来演说。但问本数已摄诸转。第二佛告下答。中四。一赞问成益。令入佛所知数者。以是圆教所明深广无涯。唯佛方测。不同凡小所知。如黄帝算法但有二十三数。始从一二终至正载。已说天地不容。小乘六十已至无数。此有百二十四。倍倍变之故非余测。故数之终寄不可说。况复偈初更积不可说。历诸尘刹。以显无尽。所以佛自答者。正表难思故。又明此品统语因位终德。故佛说之。二善男子下诫听许说。三时心王下敬受尊命。四佛言下正答所疑。于中二。先长行明能数之数广多。后偈颂显所数之德无尽。今初。问乃举后难知。答则始终具说。初言一百洛叉为一俱胝者。是中等数。洛叉是万。俱胝是亿。故光明觉品云过一亿。梵本皆云俱胝故。若依俱舍以洛叉为亿。则俱胝当兆也。若兼取一十百千万等下数法。则通有百三十七数。由前易故略不说之。俱胝已下并是上等数法倍倍变故。余如光明觉品说。其中多存梵音。但是数名。更无别理。末后云此又不可说不可说者。若类前具牒。便有四个不可说字故。译家云此又。二字替一不可说不可说。为译之巧。第二偈颂。百二十偈大分为二。前六明普贤德广说不可尽。余偈明佛德深广普贤穷究。前中分二。前四偈半明能数多。后一偈半显所数广。今初。积数自有十重。以显无尽。是知。上至不可说转。尚约顺机。据佛所知。实无尽故。言十重者。一初句积不可说至不可说。然此应积最后不可说不可说转。而但积不可说者有二义故。一取言易故。下偈多用故。二表言所不及之数故。二次三句将上所积充满一切不可说中。于中初句标。后二句释。谓何者是一切不可说。释云。不可说劫中说不尽者。三半偈将上诸不可说。一一是一刹皆碎为尘。四半偈。即前一一尘有不可说刹。五半偈。将前诸尘中刹一念遍碎为尘。六半偈。念念碎尘复尽多劫。七有一句明前所碎尘复有多刹。八一句即此多刹复碎为尘。九半偈。以多算数经于多劫。数上诸尘云如是数。十以上诸尘数劫。一尘有十万个不可说劫。如是重重无尽无尽。第二显所数广中略举三重。一将上诸劫赞一普贤之德不尽。二况一尘中有多普贤。三况遍法界尘皆有多矣。是知德无尽故。若不以称性之心思之。心惑狂乱。第二一毛端下。一百一十四偈。明佛德深广普贤穷究。即广显变化之相。于中二。前九十一颂。明果德无碍因位善穷。后不可言说诸如来下。明果德深广因能趣入。前中亦二。先明果法无碍。后菩萨悉能下。明因位善穷。前中亦二。先三偈明依报自在。后于彼一一毛端处演不可说。下明依正融摄即入自在。于中五。初二偈半依中现正。二于彼一一光明下。十一偈半正中现依。于中二。初现莲华光明。后彼如须弥下净土之用。三光中现佛下五偈。依中现正说法。四或复下一偈明现时常住。五其心无碍下十偈半。明自在调生。第二因位善穷中二。先半偈结前生后。余偈正显因德。于中有十。初八偈明帝网身土是起行处。又前文明其展遍。此明包容。文影略耳。言毛孔悉能受诸刹等者。称法性之一毛故。受多刹而无外。不坏相之多刹。安[稫-禾+彳]悟者之一毛。内外缘起非即离故。二意根明了下五偈。三业勤勇行。三一切众生下应器摄生行。四普现其身下五偈半。明游方供佛行。五修行于施下。广修十度行。六诸佛刹海下二偈半。游刹自在行。七了知众生下。明调伏众生行。八一一毛孔不可说下七偈半。三业深净行。九彼诸菩萨下。愿智自在行。十不可言说一切劫下。一偈结德无尽。第二明果德深广因能趣入中。先果后因。前中三。初六偈总叹佛德。二一微尘中能悉有下别明依报。三一一刹中有如来下三偈别明正报。第二种种数量下明因德趣入。于中二。先自分行。后能于一时证菩提下胜进行。且从相显略科。然上诸德。德德圆融无尽无尽。唯忘怀体之

    寿量品第三十一

初来意者。夫玄鉴虚朗。出乎数域之表。岂有殊形万状修短之寿哉。然应物随机。能无不形。而无不寿故。上品彰其实德。此品以辨随机。虽积少至多显时无不遍。即前多德之一。故粗广之。亦为远答寿量海故。所以来也。二释名者。寿谓报命。量即分限。染净土之报寿。随机见之分限。以显无尽之命无限之量。寿之量故。寿有斯量。通二释也。别行经名无边佛土。经即以处显人。三宗趣者。应物修短为宗。显穷来际无限为趣。以就同教。且积劣之胜。若就别教。则修短圆融故。次正释文。初集经者叙。而心王说者以领旨故。佛寿自在故。二佛子下正说。于中三。初别举十刹相望。次佛子如是下举略显广。三最后世界下举其玄极。且如以劫为日。未历十重。则劫不可说。沈百万僧祇则最后之刹。已邻刹海平等故。举普贤等充满。明极位所居。由此名为兼显菩萨

    诸菩萨住处品第三十二初

初来意者。上约化益尽一切时。今明菩萨遍一切处。故次来也。故僧祇中。明法界毛端之处。皆有多多普贤。此则据实而谈。今约机缘所宜。指有方所。使物欣厌翘心有归。若知能住菩萨毛含刹海。所住之处尘纳无边。则未有一方非菩萨住。亦远答前寿量海问。菩萨随机住寿异故。昔将此品。远答第二会初问意十句。非唯义意不同。抑亦文不相次。二释名。曰菩萨大悲随机住处能住非一。故名曰诸。诸菩萨之住处故以为名。三宗趣者。随机应感方所为宗。使物归凭及悟无方为趣。次正释文。文中二。先集经者叙。亦心王说者。随所统王皆自在故。亦表心随智住无障碍故。二佛子下正说住处。有二十二处。前十依八方山海。以上下非凡至故不明之。山海包藏仁智栖止。表大智高深故。能止能照故。后十二处。城邑杂居。曲尽物机。表大悲无遗故。则知菩萨无不在矣。今初。第六是海中之山。第十海中之窟。余皆是山。一仙人山者。相传是东海蓬莱山。若尔则亦兼海。二胜峰。即德云所住。晋本名楼阁山。即婆施罗所居。三金刚焰。在西海之滨。四香积山。昔云应是雪北之香山。五清凉山。即代州雁门郡五台山也。于中现有清凉寺。以岁积坚冰夏仍飞雪。曾无炎暑故曰清凉。五峰耸出顶无林木。有如垒土之台故曰五台。表我大圣五智已圆。五眼已净。总五部之真秘。洞五阴之真源。故首戴五佛之冠。顶分五方之髻。运五乘之要。清五浊之灾矣。然但云东北方者。其言犹漫。案宝藏陀罗尼经云。我灭度后。于赡部洲东北方有国名大振那。其国中间有山。号为五顶。文殊师利童子游行居住。为诸菩萨众于中说法。及与无量无数药叉罗刹紧那罗摩睺罗伽人非人等。围绕供养恭敬。斯言审矣。其山灵迹备诸传记。余幼寻兹典。每至斯文皆掩卷长叹。遂不远万里委命栖托圣境。相诱十载于兹。其感应昭著盈于耳目。及夫夏景胜事尤多。历历龙宫夜开千月。纤纤细草朝间百华。或万圣罗空。或五云凝岫。圆光映乎山翠。瑞鸟翥于烟霄。唯闻大圣之名。无复人间之虑。入圣境者接武。革凡心者架肩。相视互谓非凡。触目皆为佛事。其山势寺宇难以尽言。自大师晦迹于西天。妙德扬辉于东夏。虽法身长在。而鸡山空掩于荒榛。应现有方。鹫岭得名于兹土。神僧显彰于灵境。宣公上禀于诸天。汉明肇启于崇基。魏帝中孚于至化。北齐数州以倾俸。有唐九帝之回光。五天殉命以奔风。八表亡躯而竞托。其有居神州而一生不到。亦奚异舍卫三亿之徒哉。愿皆修敬。六金刚山。谓东海近东有山名为金刚。虽非全体是金。而上下四周。乃至山间流水砂中。皆悉有金。远望即谓全体是金。又海东人自古相传。此山往往有圣人出现。然晋本此处当其第九。以与第十庄严窟俱在海中故。而今居此者。意是八方之内。东北方摄故。若不然者。何以正说八方忽然语海。又晋本海中有二住处。一名枳怛那。现有菩萨名昙无竭。有万二千菩萨眷属。言枳怛者。具云昵枳多。此云涌出。金刚语体涌出语状。昙无竭者此云法生。亦云法勇。亦云法尚。今言法起。与生勇义同。即常啼之友也。菩萨眷属十倍今经。或前译之误。七支提山者。此云生净信之所。有舍利者为塔。无舍利曰支提。或山形似塔。或彼有支提故以为名。昔云既指清凉为东北。则东南影响吴越。然吴越灵山虽众。取其形似者。天台之南赤城山也。直耸云际赩若霞起。岩树相映分成数重。其间有白道猷之遗踪。或即当之矣。然剑川有三学山。中有欢喜王菩萨。屡持灯而出。名虽不同。而天竺望之即是东南。亦有见其持宝冠者。则密示其名也。希后贤以审之。八光明山。昔云。应是与补怛洛迦山相连。以晋译观音住山为光明。今文非观音住处。而云光明故言连也。九香风山。疑是香山西畔。十庄严窟者。对上第六海中故云复有。晋本云。二名功德庄严窟。后城邑十二处中。一毗舍离者即毗耶离。此云广严城。亦曰广博。即是中印度净名所居之城。言南者。案西域记第七云。此城南十四五里有塔。是七百贤圣重结集处。更南八九十里有僧伽蓝。其侧有过去四佛座。及经行遗迹之处。应是其所。晋本第二更有一处。名巴连弗邑。有处名金灯僧伽蓝。昔云。具言波吒补怛啰。此云黄华子。即黄华女之子创居此处。亦中天摩伽陀国。具如西域记第八。今经阙此一处。二云摩度罗者。亦曰摩偷罗。此云孔雀。亦云密盖。并是古世因事。亦中印度。言满足窟者。彼国有舍利弗等塔。及文殊师利塔。于王城东五六里有山寺。是乌波鞠多所造寺。北有岩中间有石窟。是鞠多度人安筹之所。具如西域记第四说。安筹虽是后事多是安圣窟中。三俱珍那者。具云俱陈那耶。俱珍姓也。此云大盆。那耶法律也。谓池形如大盆。往昔有仙于侧修法律。后人以此为姓因为城名。四清净彼岸城。是南印度。目真此云解脱。即龙之名。邻陀云处。即龙所居处。五摩兰陀国未详所在。晋经无国。但云风地。谓有风孔处即龙所居。六甘菩遮国。正云绀蒲。即是果名。其果赤白圆满。乍似此方林檎。而腹三约横文。此国多端正女人。而似绀蒲。三约文成。以女名国。出生慈者。大集经中但名慈窟。七震旦国。即此大唐。亦云真丹。或云支那皆梵音楚夏。此云多思惟。以情虑多端故。前为成八方故。清凉直云东北。今在诸国之类。故举国名。那罗延者。此云坚牢。昔云。即青州界有东牢山。现有古佛圣迹。此应是也。然牢山乃是登州。亦青州分野。其山灵迹亦多。然今之到此山在蔚州东。灵迹显著不减清凉。时称普贤所居。往往有睹。彼亦有五台。南台有窟难究其底。时称那罗延窟。或即是此。八疏勒国。具云佉路数怛勒。是彼国山名。因山立号。或翻为恶性。因国人以立名。然牛头山在今于阗国。此云地乳。佛灭百年方立此国。具如西域记。以集经之时未开。尚属疏勒故耳。晋本但云边国。故或指江表牛头。今译既明。定非此也。九迦湿弥罗。晋译为罽宾。此翻为阿谁入。即末田乞地之所。略如音义。广出西域记第三。十增长欢喜城。古释云。即南印度。尊者窟者。即上座部所居之所。十一庵浮梨摩。此云无垢。即是果名。此国丰而且胜故以为名。在中印度境。十二乾陀罗国。此云持地国。多得道果者护持。不为他国侵害故。或云香遍。遍国香草先发故。苫婆罗者是香华树名。与初品苫末罗。梵言轻重耳。遍窟侧近多生此故。相传云。是佛留影之所。具如西域记及大集月藏分第十。此文之终都无结束。或是经来不尽。阎浮既尔。余方余界异类界等可以仿之。法界身云则无在不在矣

    佛不思议法品第三十三(已上入第四十六经)

初明来意。先通后别。通则此下五品。为答第二会初如来地等二十句问故。古德但有三品答前。谓前明修生之因。今辨修生之果。因圆果满故次来也。若答前问。何以重请。由因果隔绝念法希闻。因德尚深。果必玄妙。故念请耳。别明此品。则前品因终。此品果始。故次来也。二释名者。如来果法迥超言虑。故以为名。斯即佛之不思议法也。三宗趣者。先总后别。总明说佛果德体用。心言罔及为宗。令总忘言绝想速满为趣。别就宗中三门分别。一通辨佛德。若说百四十不共佛法通于权小。若五法摄大觉性。犹通于权。若言唯一味实德者。约理顿说。若言具无尽德。是此所明故。后文中初标十问。答具多门。类通十方。一一无尽。二别显义相。诸佛功德不出二种。一者修生。二者本有。初谓信等本无今有。后谓真如具性功德。此二无碍应成四句。一唯修生。二唯本有。以性相躯分故。三本有修生。谓如来藏待彼了因。本隐今显故。四修生本有。无分别智冥符理故。若权教所明二德不杂。法报四句亦有差殊。依此经宗。虽有四义而无四事。本有如真金。修生如严具。然由严具方显金德。严具无体全揽金成故。唯金不碍严具。唯法身而不碍报化。唯严具亦然。既互全收故。十身无碍。八相该于法界。丈六遍于十方。诸根毛孔各无限量。亦不碍量。量与无量无有障碍。三显不思议之义。泛明有四。一理妙难测。二事广难知。三行深越世。四果用超情。今文通四正辨后一。就后一中复开为四。一何者不思议。略辨十种。一智超世表。二悲越常情。三无思成事。四同染恒净。五所作秘密。六业用广大。七多少即入。八分圆自在。九依正无碍。十理事一味。文并具之。恐繁不引。二于何不思议。此有四位。一过世间。二越权小。三超因位。四显法自体。三云何不思议。亦有四种。谓非闻思修及报智境故。四何用不思议。亦有四种。谓令信向故。起行求故。随分证故。圆满得故。前并是宗。唯何用为趣。即此宗趣可以释名。次正释文五品分二。初品总明佛德。后四别显佛德。古德后二为平等因果。此但三品果法。有将此三配体相用。后二可然。初品有妨。有相用故。今依贤首。初品总显佛德体用。次品别显胜德之相。后品别明胜德用益。又初品明德。次品明相。后品明好。今初分四。一请分。二加分。三证分。四说分。初中二。先明请人。后诸佛下正显所念十法。皆云不思议。即前果用超情。离于说相故。此十句义并多含。皆通真应。不得一向。就应而辨。然此十问摄前普光后二十句所成果问。谓身摄六根。智摄佛境佛地及最胜三问。自在摄五。一神力。二神通。三十力。四无畏五。三昧。此并前开此合。前境界中开出国土。所化所依之境故。前所行中开出出现本愿种性。种性即悲智之行。本愿就因辨行故。出现是佛普贤行故。出现与行互有宽陜。下出现品行是其一故。前之无碍此开解脱。作用无碍名解脱故。所以开合者。显义无方故。名多同者显不异故。音声即辩。虽无开合名有宽陜。义旨大同。此十义相第二会中已释。至下说分重明。第二尔时世尊下加分中三。初加因。神知机故。次则以下显加相。三业加故。初句总。余句别。谓意语身以光即教光故。后令青莲华下加所为。为具说德故。文有八句。一外制无畏。二内证深寂。此意业胜。三威德内充。四神用外彻。此身业胜。五具四无碍是语业胜。六遍观机教为广大。七智性无差为次第。八授记善巧为方便。皆说德也。所以加青莲华藏者。果德离言藉因显故。因果同时故。性德无染最超胜故。一德具含一切德故。第三尔时青莲华下证分。十句初四自利。次三利他。上皆自分。后于一念下三句胜进。并显可知。第四承佛下说分分二。先承力总告。告莲华藏者。非同佛心。无以受佛德故。亦名莲华。不言青者。不碍能说为最胜故。后佛子诸佛下。正显佛德。略有二义。一总下五品。共答十问。此品答佛种性。佛以功德为种性故。次二品答身。次一品答本愿。后一品答出现。其国土问初会已广。余或经来未尽。或前后摄之。二者此品具答十问。谓佛德无量略显三十二门。门皆具十有三百二十德。以显无尽。昔以初十标宗略答。具答十问。所余唯有别答。而超次答前十问。今谓三十二门如次答前十问。而门门皆含答十。欲显佛德一具一切故。亦显所问能包含故。而其标门之名。多不同前者。为显佛德无边量故。文分为十。初二门答国土问。第二念念出生下二门答本愿问。第三不思议境下二门答种性问。第四普入下二门答出现问。第五离过清净下五门答身问。第六演说下二门答音声问。第七最胜下三门答智慧问。第八自在下八门答自在问。第九决定下三门答无碍问。第十一切智住下三门答解脱问。以身及自在含前普光诸问多故。用门亦多。而文多有三。谓标。释。结。义相至文当显。今初二门答国土者。国土即是所依所住。初门明其常住法门。后门明其遍住法界不唯国土。不在方所为真土也。今初文二。初标。后释。释中九句显于如来应机说法。含答十问则十问皆成住处。下皆仿之。一起应之心答种性问。悲为种性故。二演法之身答身问。三转法之意答本愿问。本愿平等利一切故。四能转之辩答音声问。音出辩故。五所转之法答自在。自在不思议故。六转音周遍答国土。国土是音所至故。七所显之理答智慧。智慧能住法界故。八能化之通答神通问。九演法之益答无碍问。文唯九句脱于出现。或通前诸句。出现皆能作前九故。答此十问既尔。答初二会类例可知。二普遍法界者明其遍住。谓六根三业皆遍法界土故。标中无量是事法界。无边是理。此二无碍。及事事无碍法界。并为所遍。列中则显前十皆遍。一无边身含答三问。一正答身。其普遍诸趣是有悲性及出现义。次六是身别相。亦是于身兼答普光眼等六问。出妙音声答音声问。第八答三问。谓无碍答第九。解脱答第十。神通力。答自在。第九别答国土。第十答本愿及智慧问。第二念念出生智下二门答本愿问。此门明乘愿现其八相。后门明愿不失时。今初。然愿以后得智为体。从其愿智生八相等非生智也。别中一乘愿下生。二受生种族。三学解脱道。四明其出现。五音声。六化生严国。七现佛身。八自在。相严福严严如来藏故。九是无碍。十即智慧。正遍知故。二不失时者。行止在缘根熟化现。未熟便舍。非愿不周。若机熟失时便违本愿。别中一出现。二成本愿有缘。三知种性与记。四自在。五现身。六智住于舍。七六根无碍。八净国摄信。九强音调恶。十即不思议解脱。第三不思议境界下二门。答种性问。此门双明报应种性。皆真正故。后门唯明法身种性。今初。体相超言念故云不思议。下位不及故云无比。别中一身。二音。三乘愿放光。如其本愿所得光故。四出现。五国土。六智慧。七自在。八威德种族。九无杂之碍。十解脱体同。上之五段皆略指陈。兼答十问。已下恐繁不显。说者随宜。二出生智者明法身。为种性也。从无性中出其智慧。非答智慧故。别中十各二句。皆上句知性。即无性之性为能生。后句出生智用。第四普入下二门。答出现问。此门明遍现。常现非有出没方为真现故。别中云普现三世诸佛。况自身耶。又一现即一切现。以三世佛无二体故。如文殊般若中辨。别中云三种自在者。即三业化也。二十种广大法者。明出现之相。谓大用无涯故云广大。凡小莫测故难信受。文显可知。第五离过清净下五门答身问。即分为五。一此门总显无过。如来三业随智慧行故。三业等事不出于身故。别中十句。多同出现品身之十相思之。二究竟清净明过不生。拣异因净故云究竟。惑障诸垢永不起故。别中前五功德身净。次二色身。次一法身。次一智身。后一意生等身净也。三十种作佛事。即明身之业用。别中亦多同出现品身相。四无尽智海法者。即如来六根三业。皆智慧深广相应故。亦别广智身可知。五十种常法者。明身中意业恒常。用无断故。第六演说无量下二门。答音声问。此门明以音声辩说。兼答普光辩问。后门十种作佛事。明种种说法。谓六尘四大举动施为。皆能显法。成益无非佛事。非独音声如净名说。别中初身。二音。三四皆智受。为成彼檀故。不受令彼仿佛行少欲故。又以无所受受诸受故。余可知。第七最胜法下三门。答智慧问。初此一门总明权实因果之智。兼答普光最胜之问。智慧最胜故。结云住十力地。兼答佛地之问。别中四。即三念处行。余可思之。二无障碍住。明智慧离障。以智慧所作无碍故。一切无碍。三十种无上庄严即智慧成益。由内具智严故。外具诸严。标中超下位故最胜。上无加故云无上。别中十义结名自显。一相好身。二圆满音。三以功德严意。四放光。五微笑授记。其缘甚众。离世间品亦明。六法身中真如出缠。故云清净无碍。即法性法身本智返照故。于一切法究竟通达。即智慧法身智契法界。俱无边际。虽在已下应化法身。了世已下功德法身。严理智故。了世实性成上不杂生下出世。行出世法则功德备矣。言语道断即虚空法身。亦实相法身。体绝百非。言亡四句。唯证相应故。超蕴界处显是无为。翻有漏蕴成五分法身。若翻界处则外六尘。亦国土身则十身圆融。成真法身矣。七即常光。八金等妙色。九中具真应种。三世佛种即真如无性故。应种可知。十中起必智俱故无渴爱。动与道合故。身行永息心善解脱。成上无爱。见者无厌成上行息。此皆功德。亦无爱见成下大悲。既为第一田故。受施之中更无过上。第八十自在法下八门。答自在问。即为八段。初一总明自在。兼摄加持。初总可知。别中全同八地之中十种自在。但深广不次耳。一法自在。论经云无中边。法门示现故。二心自在。无量阿僧祇劫三昧入智故。由在三昧观机故化不失时。三胜解自在。大小净秽随解转变故。四财自在。一切世界无量庄严。严饰住持故。五命自在。不可说劫命住持故。六如意自在。一切国土中如意变化故。七智自在。如来力无畏不共法相好庄严三菩提示现故。文中生界无边机熟相续故。念念应成。而真成在昔故。佛于三世。非是新觉。亦非不觉住在学地。又显虽念念觉离觉相故。非三世觉。亦离不觉故不住学地。又云而悉通达无量智等。即十力等。八业自在。六根互用广大佛事。是佛业故。然非改转。一根不变本来具故。九生自在。一切世界生示现故。十愿自在。随心所欲佛国土时示成三菩提故。上来唯三与八取意而释。余并论经之文。其第十自在文有四节。一一念现多佛。于一类界成佛。二如于众妙下类显余界。三如于一念下类显余念。四一念一切现下总结深广。一切现者。一念便现法界诸形诸时诸神力故。一念无量住者常无现故。而不动如来少许方便。故云自在。第二不思议圆满佛法者。明圆满自在。谓前十自在八地容有故。显如来十种圆满。又无一法不自在故。方云圆满。别中二即证成菩提。十方等云一切佛法。九即具有法轮教法。三通福智故曰善根。四唯是福但云功德。余可思准。第三善巧方便。即于法自在。皆权实等无碍故。别中一知实离言绝动摇之戏论而起权。开示善根故为自在。二证实无能所见而不碍于法。真实知见无缚无解。而至大自在。三无相知相无性入性。亦能示现依正调生。四证冥三际之理。而演三际益生。五三业湛然而包含示现。六知非一异而见一切法。七知时融入故。不住不舍而不坏年劫。演法无休。八恒住法界。则寂无所住。而成就无量无畏。十辩演法。十辩者。一多故。二非心测故。三随说一事穷劫不尽故。四任放辩才无有间故。五触类成辩故。六下位所无故。七无能难屈故。八皆契事理故。九无一句义不能显故。十无有一法不能演故。初中后善下明说之德。具七善故。或开为十。瑜伽八十五云。一初善。听闻时生欢喜故。二中善。修行时无有艰苦。远离二边依中道行故。三后善。谓究竟离垢等故。今文云皆悉究竟。诸经论中更有多释。恐厌繁文。余七经文略无。九离说而说故无想着。十了寂起用。于中先知本寂。后而能下不废起用。前中亦二。先正显。后然亦下释成。谓色等性无。非遣之使无故不坏诸法。即空无业等。后起用可知(已下入第四十七经)第四十种广大佛事。明神通自在。即答前二会神通问。先总标中。谓八相等中皆有大用。微细相容故。以此摄物故名佛事。于中先标名。无量下显胜。列中先征。后释。释中一明上生佛事。于中四。一别明能摄。二摄取下所摄广多。三大慈下能摄殊胜。四或令下所摄成益。二降神处胎。佛事中先明智德内圆。后受最后下明神通外用。于中先一处一时作佛事。后佛子如来尔时下。总摄时处作佛事。此中多处准下瞿波。乃至十重。此略举五。皆后后广前前。一一切方者。即娑婆与能绕十三刹尘数十方无间住故。二彼上诸刹复有眷属刹等。围绕交络成网故。三绕中间海十右旋海故。四尽华藏刹海诸刹种故。五一切世界者。尽法界故。三现生处宫佛事分二。初无生现生是诞生相。后一切佛于诸色下。无染处染是处王宫相。于中四。一三学自圆。无染是定故。二观诸下四心愍物。三具佛下具德摄益。四虽处下摄益广深。四出家佛事中二。先明出家意。后当出家时下明出家相。三业二利故。五成道佛事中三。初明真觉旧圆。次菩提树下应身今满。后其菩提下演法益生。此顿演华严。六转法轮佛事中义通权实。先列。后结。列中一唯菩萨乘通四不退。二通五乘。世咸了故。三开权显实。令悟知见决定有故。四通三藏。三藏除痴及三障故。五唯顿法。事理双绝故。六中道法。不着二边故。七世谛法。净所知故。八唯佛法。智遍知故。九唯圆法。无异味故。后一切诸佛下总结。即无量乘。唯第十轮。随机演故。十皆圆融为不思议。七威仪佛事。于中四。一别举入城益物。二一切诸佛色身下。通显威仪益物。三一切诸佛昔于下。言谈示现益物。其昔字晋本所无。即是现益。若言昔者乃是举因显果。必是普字。四一切诸佛以如是下。总结深广。八起行佛事中四。一身心安住行。兰若唯山林寂静通城邑。空闲在无物。二或以天身下。起应上求行。三或时说法下。说默下化行。四或住一日下。时分进修行。九起用佛事中二。初显起用所依。以是能生功德藏故。二或现涅槃下正明起用。十涅槃佛事。别显用中之一。于中三。初明涅槃悲恋益。次复为化度下。舍利流布益。后佛子下总结益满。若配十问。一本愿。二即种性及国土。三是无碍。四十皆解脱。五出现。六音声。七身。八智慧。九自在。三结可知。第五无二行。自在法者明无畏自在。兼答普光无畏之问。于事明审决定无疑故云无二。不畏他难名为自在。别中初四可知。次三通二义。一以理融相。二事事即入。次二唯理。后一有三义。一同性修故。二互回向故。三互主伴故。第六明住。一切法者。明三昧自在。兼答普光三昧问。如来所住无非三昧故。遍住一切。文显可知。第七知一切法尽无有余者。明十力自在。兼答普光十力之问。十力智慧照境无遗故。亦显可知。第八广大力者。明神力自在。亦答普光十力之问。文中亦三。初标。次何者下征释。三结。今初。十力是别名。大那罗延等是总称故。下列中但依总名。是则标中十力。一一遍下别中。十门一一具前标中十力。则成百门。古德将标中十力。次第配下十勇健法。谓初为广大力等。则令别中一门不摄前十。不成百门。亦令余门无广大义。初门无最上等。设欲从胜配者。应逆次配之。十中。一广大者。周法界故。二最上者。无加过故。三无分量故。四可敬畏故。五唯佛得故。六作无屈故。七当体坚故。八缘不坏故。九超言念故。十不可摇故。次征释中。第一身命不可坏力。今逆次配此。即不可动力。乃至一毛不摇动故。文中二。先正明不可动坏。谓情非情境俱不能坏。后若有众生下举况显胜。如令耆婆入火取子入狱问罪等。第二毛孔容持力。即是不可思。而诸众生不觉知故。第三毛持大山力。即当不坏。以虽持多大山身心无劳损。故。文中速行广步。多劫行刹为一山之量。此山已无边矣。况有多山。在于一毛。况复多毛。穷劫持住实难思之境矣。第四定用自在力。即是坚固定力安住故。第五常遍演法力。此即不退言音无变无断尽故。文中二。初明一身转。后如一佛下明多身转。前中三。初显所说多。次如是演说下明所说常。后所谓下示所说体。后多身可知。是则常恒之说。前后无涯。生盲之徒对而莫睹随所感见说有始终。第六德相降魔力。即当难获。然十皆难获。世多魔惑偏立难获之名。第七圆音遍彻力。即是威德闻。皆调伏故。第八心无障碍力。即无量力。离量非量故。初无尘惑障碍。后于不可说下起用无障碍。心善解脱者。由三种相。一于诸行遍了知故。二于彼相应诸烦恼断得作证故。三烦恼断已。于一切处离爱住故。第九法身微密力。即是最上此总收前八后一。更无加故。文列二十五身。或即应之真。即真之应。即性之相。即理之智。十身圆融同一法界之身。不可配于报化。故云最上微密。第十具足行智力。即是广大力。因行如海果智普周。五无边界大用无涯故。文中四。一万行圆净。二住佛所住下智用圆周。三虽已证下动寂自在。四佛子一切诸佛下。用无涯畔。上之十力不出三业。可以思准。第三佛子此一切下。总结可知。第九决定法下三门答无碍问。一明所作决定无能为碍。此约一类世界。故云决定于异类界。未必定然。又约佛。定能为故云决定耳。二速疾法者。明令他无碍。如如意宝见速获益。而薄福不睹。十句五对。一离恶趣圆胜德。二成善因感乐果。三除疑惑满大心。四始入位终清净。五净二碍具四辩。三应忆念清净者。举佛无二碍劝物念持。第十一切智住下三门答解脱问。初门明智障解脱。智安事理故名为住。由离障故一切能知。二无量不思议三昧者。明定障解脱。由离障故。用广为无量。体深不可思议故。十种之中各先明在定。后一念遍用。三无碍解脱者。明业用解脱智。论云。菩萨有不思议解脱。诸佛有无碍解脱。所作无障。脱拘碍故。故各于一尘顿为微细作用。若别答十问者。一答出现。二音声。三本愿。愿化尽故。四国土。五即智慧能授菩萨之记。六佛身。七即种性。云世界种入世化物之种。应非世界海中之种。以前有国土竟故。八自在。九是无碍。利生无碍故。十即解脱。无不为故。既随一门皆答十问。则包含该摄。是以名不思议。然文少结束似经来未尽。或显佛德无尽故。相海等犹答前问故

大方广佛华严经疏卷第四十七大方广佛华严经疏卷第四十八

        唐清凉山大华严寺沙门澄观撰

    如来十身相海品第三十四(已下入第四十八经)

初来意者。前品总明果法。此品别显相德。近答前品身问。远答普光眼等六根。非唯眼等遍于法界。而各具多相用难思议故。二释名者。如来十身标人显德。言相海者。依人显相。如来十身并如前释。福报奇状炳著名相。相德深广故称为海。故文云有十莲华藏微尘数相。相体广矣。一一用遍。相用广矣。一一难思。互相融入。体用深矣。若此之相唯属圆教。标以十身。故观佛三昧海经。辩相有三类。一略中略说。有三十二相。二略说八万四千相。三广说有无量相。如杂华经中。为普贤贤首等说。杂华即此经异名。三中初通权小示同于人。端正不乱故。次唯大乘菩萨。修八万四千波罗蜜故。后唯一乘。一乘修无尽行故。又初化次报。后属十身。十身之相海依主释也。又初凡圣同见。次唯地上。后唯圆机。然通五位。若语其体初以形色。次即定慧。后以无尽法界。若语其因后通纯杂。如初会说。故一一相果皆周法界。前二相因如瑜伽智度等论。涅槃大集等经。广如章说。三宗趣者。显无尽相海为宗。令修无尽之行。显成为趣。后正释文。文有三别。第一诫听许说。二正陈相状。三结略显广。今初。所以普贤说者。相海普周故。令行普行获普相故。普贤本是会主。前说已穷。此便说故。或前品末经来未尽。更应别答国土等问故。第二佛子如来顶上下正陈相状。略举九十七相。文通有五。一依处。二列名。三体严。四业用。五结数。或略不具。至文当知。或加成益业用中摄。然名依体用以立。皆以体用释名。或单从体用。或双从二。随文思之。或名与体用。义不相似者。则是文略义含耳。细论一相各依一处。则为九十七段。经自标次。今以类例相从。依十九处即为十九段。始自于顶终至于足。斯即顺观相海。今初。依顶中三。初约处总标次。其中下别列名相。后佛子下总结为严。今初。宝庄严者通显体严。事宝则云皆摩尼等为庄严故。亦显智宝。圆净严故。一一相中。皆有事理二严随宜解释。大人相者大人之相故。二别列中三十二相。文各唯四。以依处一种已总标故。此处独有三十二者。理实应多为显圆融。一即一切故。一顶中便具权教三十二数。若尔余何不然。显顶尊胜故。善生经云。一切世间福。不及如来一毛功德。一切毛功德不及一好功德。一切好功德不及一相。一切相不及白毫。白毫复不及无见顶相。故知胜也。此约相好相对明之。若约人具有好为胜故。相伏于人好胜诸天。故余处说好为微细。第一相中四者。一列名。名从用立。二一切妙宝下体严。三一一下业用。四是为一者结数。他皆仿此。二中以摩尼下体严。即释光明义。其光下业用释佛眼义。佛眼无不照故。余并准思。毫相放光如现相品说。云义亦如初会。八中严内摩尼名意故不同如意。十一中。如是皆从下辨业用因。亦业用摄。十四用中。云四菩萨行者。瑜伽菩萨地云。一切菩萨略有四行。一波罗蜜行。二菩提分法行。三神通行。四成熟有情行。十九云具足千轮者。梵本云具千辐轮也。二十一。示身智二光。俱显智慧。二十六中庄严云如来净眼为庄严者。此通十眼。光照下显业用。亦通身智二光。净眼及光释前普照。现于严具是上轮义。即法轮故。从二十七至三十一。并略无庄严。亦由名中已含有故。三十二。先名。次最处下体严。此居顶极特显别处。故云处中。则知所余皆绕此相。略不明耳。渐次隆起者。正显其相。智论第五云。如来顶有骨髻如拳。观佛三昧经云如合拳。即隆起之相也。第二眉间有一相。自下并有依处故。文皆有五。初依处。二显名。三摩尼下体严。谓此相若收。则右旋如覆琉璃碗。若展则具十楞。有大光明。严唯一宝光具多色。中表皆空即是洞彻。四其光下业用。复出已下即是法光。故此光名从用而立。五结数可知。第三眼。第四鼻。各有一相。第五舌有四相。初一即舌广长相。于体严中。宿善成者。此举因严。偏此说因者。令赞演一乘故。其舌长广即语其体。福德人至鼻。权佛至发际。余大乘中明现神足。方至梵世。或覆三千。今直语体便覆一切。后如来下辨其业用。演法释音声。现佛释影像。二舌掌之相。掌谓近根。其光下显业用。光照诸刹令应度者无俟观破。搏聚自晓。但合尘成。何性之有。后二同在舌端。或居左右。或在上下。观文业用。但有展卷不同。前则卷佛海于舌端。后则展诸佛于法界。第六上齶一相。上齶既有。下亦宜然。或是梵本脱漏。第七牙有四相。谓左右上下。四大牙故。故佛涅槃四牙不碎。辅颊也。亦云颊车骨也。二右辅上牙名弥虑者。显妙高故。四中有法乳等三。同一演法约资法身名乳。照了万境称灯。令其圆净为实。即演三德涅槃之法。亦成三德涅槃之益也。第八齿有一相。第九唇有一相。上二各应分出上下。放阎浮下体严。以唇色赤好。如日初出红莲叶故。后照于下业用。第十颈有一相。第十一肩有五相。右二左三或亦脱也。第十二胸有十一相。初一当中。左右各五。今初卍字正翻为吉祥海云。以依形立名故。先标形相。应回安名下以属体摄无违。前后左右可知。第十三手有十三相分三。初九直语手相。右五左四者。或左脱一。或表右常用故。而前肩则右二左三相通正等。右中六十六。云成变化网者。光化为网也。左中七十二。云因陀罗网为严者。即是网鞔之相。互涉入故。次二左右指可知。后二左右掌。皆有千轮者。轮毂辐辋三事具足。自然成就不待人功。第十四阴藏一相。犹如马王。第十五坐处二相。第十六髀有二相。左云随顺安住者。髀多行动故。须多宝随顺而严。第十七腨有三相。第三膊毛通于二腨。若准晋经直云毛端。则通身一切毛也。义应如昔。则处成十九。第十八足有十三相。通分为七。初足下一相略无左右。而晋经足趺之后。别有足下千辐轮相。此必合有故。后品明足下轮相。名普照王。今经千轮之言。乃在指间。或以常明易知指间有异故举之耳。名安住者。以足下安平一切着地不容针故。二足上三足指间。四足跟五足趺。六足四周。因陀罗尼罗者。此云帝青。七足指端。上六各左右为二。文显可知。上来略列九十七相。次第数名译者安置。既不说尽。岂不盈百。足下阙一唇齶不开。设合此二六根皆辨耳。何独阙如。若加两耳及足下一。则圆百数以显无尽。岂不妙哉。况此中所列。于三十二尚有未尽。岂普贤力不及百耶。晋经有遗但九十四。亦无次第之数故。知九十七数不在生情配属诸法。第三佛子下结略显广。别说难周故须结略。非略能尽故须显广。一华藏尘相已无边。况十华藏则无尽无尽。非普眼者。安能睹欤。既三十二相权实不同。互有互无故不会释

    如来随好光明功德品第三十五

初来意者。前品明相。此品辨好。相好虽殊。俱用严身。以答前身及眼等兼自在问。好依相有。德劣于相故次明之。劣德之用用成顿益。翻显大相德难思矣。二释名者。如来标人表德。随好等显德依人。随好是体随逐大相。益姿好故。光明者用。功德者德。谓从好发光。光能益物。显好之德故以为名。如来之随好等。亦如来有随好等。通二释也。三宗趣者。明好胜德为宗。令物敬修为趣。次释文中二。先略。后广。略中二。先标果好。二佛子我为下举因对显。今初。佛自说者。有二意故。一僧祇因终。此品果极故。二皆佛说。二好用劣相而用难思。恐物不信故佛自说。告宝手者。亦有二义。一说手随好。彼主此门故。二令当宝重起信手故。有随好者总相举也。即足下好与后名同故。德用周备故云圆满。摄益自在最胜名王。光名炽盛者。如日具德。由此复能摄诸眷属。百万等显多。复云七者。净七支修七觉。照七地故第二举因对显者。为显胜故。此有数重。一以相德深广言不能备。故置之说好。二好德复多。以三十二相既有八十随好。十莲华藏之相好弥多矣。且举其一。三一中置胜但说劣者故明足下。四足下一好。复有多光但说一光。五果位一光亦不可说。故寄因显因光成益。三重顿圆。况果一光。如是展转。况于诸相。况复总说如来诸德。果海绝言亦斯义矣。文中二。先光照分齐。即前圆满好中放光故。不别标放处。而非前光好具多光故。后彼世界下光所成益。于中二。先令离苦净宿善益。后从彼命下转报生天得闻法益。于中初示宿因。谓昔近善友必闻普法。成金刚种。心不放逸显曾修行。种诸善根通见闻等。次毗卢下显其现缘。后于彼下结因属果。文从略故结属生天。理实息苦及净眼等。皆由此因缘也。是知佛光等照。不种善因无斯胜益。何以一光顿成斯益。无尽功德之所显故。纯尽法界之所流故。非如权教八十随好。但严于形生信而已。此中略无堕狱之因。谓虽修乘戒行宽故。第二佛子菩萨足下广辨。但广于因果难说故。文中亦二。先广净宿善益。后既生天下广闻法益。今初。摧下恶趣之苦。放足下轮光。四十光者。表四十位无不照故。中有一者置广说略。能照已下分齐过前。随诸已下净惑成德故。前光受清净等名。以重况轻举阿毗耳。第二广闻法中长分为六。一略标劝诲。二尔时诸天子下闻已生疑。三是时天鼓下总示所因。四诸天子如说下正明劝教。五时诸天子闻是音下依劝诣佛。六说是法时下见闻益深。前三可知。四中有四。一以己喻佛无我无来。二诸天子譬如汝下。以他喻己显来即无来。文有三喻。并显可知。然恶业善根是来因缘。因缘无性故来即无来。非先有法在十方中从彼来也。故因缘者即是智慧。智慧之法本非因缘。云何念言有何因缘。三诸天子譬如亿那由下。以己况佛难思之境。合中举手随好者。别举显胜。上救下趣故举足光。今约现通故说手也。四诸天子汝当下。正劝往诣诫不应留。于中二。先总诫劝。后着五欲下广释。于中亦二。先释前诫。有法喻合。后诸天子下释劝。于中。有六。一顺释。为报恩故。二诸天子其有下反释。三诸天子汝等下示其恩相。四汝等今者下劝往增善。五诸天子如我天鼓非男非女下。示法令修。谓说二空。非男女喻以显人空。不生灭喻以显法空。六汝等若能下劝修成益。言无依印者。既解悟无生。则能所双绝。傥然靡据故曰无依。以斯智印印定万法。不收不摄任心自安。故称三昧。第五依劝诣佛中分五。一献供不遇。二时有下闻其所在。三时诸天下观见下生。四诸天子众下发心欲往。五时天鼓中出声告下。教见佛仪。于中二。先教识受生令舍曲见。后教发心悔过令其必见。今初由前不遇。后睹下生不离有无。情存彼此故示体用。显无生现生。文中有法喻合。法中先诫其曲见。后但以下示其正见。是知佛化所生非殁生也。二诸天子如我下喻。三菩萨下合。于中先明法身无生遍而叵见。后而能下应无不生。即处处皆有。有感此中亦见。何须更下阎浮。离分别下显应生之德。拂其诸见以无分别智而生。非谓有选生处。虽处王宫而无憍慢。诸天围绕而无染着。第二诸天子汝等应发下。教发心悔过中三。先标教悔。次征问其方。后如法正教。夫欲悔过须识逆顺十心。谓先识十种顺生死心。以为所治。一妄计人我起于身见。二内具烦恼外遇恶缘。我心隆盛。三内外既具灭善心事。不喜他善。四纵恣三业无恶不为。五事虽不广恶心遍布。六恶心相续昼夜不断。七覆讳过失不欲人知。八虏扈抵突不畏恶道。九无惭无愧不惧凡圣。十拨无因果作一阐提。次起十种逆生死心。从后翻破。一明信因果。二自愧克责。三怖畏恶道。四不覆瑕疵。五断相续心。六发菩提心。七修功补过。八随喜他善。九念十方佛。十观罪性空。今此三段文皆具有。而为次不同。向以起心之次第。此以胜劣言故。今初标教诲中。文有四节。治其六失。一发菩提心为忏所依。以是行本摄众德故。首而明之。翻昔恶心遍布自妄危人。今悲覆法界广利有情。二净治下令净三业为能忏体。净治其意是意止行。住善威仪义通止作。谓当发露不覆瑕疵。及断相续心。翻前六七。三悔除一切下令忏四障。即所灭之非谓惑业苦。业报二障约因果分异。既忏报障则怖畏恶道。以翻不畏。天子新从彼来故不广明。于烦恼中利钝分二。邪见断善最可畏故。别明见障。又障所知。亦见障故。余如别说。四以尽法下。运心普遍令无不尽。由昔起过既遍诸境。今悔昔非故普运三业等众生界。一一佛前及众生前。皆发露忏悔。既人天凡圣皆对忏悔。则自愧克责翻无惭愧。由意遍运令身口遍。头即顶礼兼身为总。五轮着地。此言遍者为以何遍故。下次言善三业遍此即修功补过。翻纵恣三业。第二时诸天子下征问其方。上言犹略。余义未尽故次征之。第三尔时天鼓下如法正教。正教观罪性空。兼显妄计我人拨无因果。外遇恶缘。而文分二。先明发声之因。后诸天子下正说教诲。于中分五。一别观业空。二总观四障。三别观见惑。四对业观报。五总结忏益。今初。业为报因。三障首故。非先有体从十方来。正显空义。但从颠倒生。释空所以。由业障海从妄想生故无自性。令此空慧与心相应。则决定无疑。能如是知即名菩萨。第二诸天子如我天鼓下总观四障。即天鼓说法。无说喻。以喻俗有真无。先喻中初举所治。谓业报二障。后说行等五。即是能治。谓行善止恶。喜他安他住定。后诸佛下合。于中先随俗说有。言我我所者即是见障。说贪恚痴即烦恼障。后而实下胜义实无。有无二文三障影略。既无我所翻破第一妄计人我。第三譬如我声下别破见惑。见惑深险故广破之。文有三喻。一鼓无生灭随闻喻。喻业虽无生随修感报。谓向观业空为遣执有。若谓为空诸佛不化故。今显非断无。翻破拨无因果。二声无去来喻。喻归中道。定有即常定无则断。俱亦是二故。双破二见显离断常。文中先喻。诸天子若有下合。若有可来即常。去而不来则断故。虽空不断。虽有不常。三鼓声随心喻。喻佛由心见。遣其心外定执。忏主令其真念十方诸佛。翻破外遇恶缘。第四如玻璃下对业观报。文有二喻。一镜像体虚喻。喻虽有而无。谓镜像依镜现。像非去来。报从业生。何有来去。二幻师惑眼喻。喻业招报虽无而有。又业亦如幻。又幻非又无。即中道矣。第五若如是下。总结忏益可知。第六见闻益深。中二。先明余众益。以三昧力声普闻故。后尔时下正辨当机益。于中二。先一重益。后其诸香云下展转益。前中亦二。先得法益。后以众生下见佛益。今初。皆有故字。义似牒前为因则见佛为益。而前来未有得十地等处。为何所牒。是以晋经皆无故字。应言闻说普贤广大回向。故便得十地获诸力庄严三昧。上句得位。下句成行。分得十力为庄严故。二明见佛益中三。一明见因。二即见下正明见佛。三尔时下敬心兴供。言以上者。上来持华诣佛。犹未散故。毛孔出华者。已得地位故。华在最初。故略举之。上所持中有香盖等故。下见香见盖并皆成益。第二展转益中二。一闻香益。二见盖益。并依前供成。今初。有法喻合。法中由脱障故。得解脱乐故。喻四禅无八灾患。若有下合。由灭障故得净善根。是为益相。文中先显所灭。即八万四千。古有二释。一云众生烦恼根本有十。然一惑力复各有十。即为一百。计应分为九品。今但上品重故开为三品。中下轻故各为一品。合为五百。复于内外境起。谓自五尘为内。以他五尘为外。一一各五百。即为五千。别迷四谛则成二万。并本一千则有二万一千。依三毒等分成八万四千。经文自具二。有云。以十恶为本。展转相成。一一各十故成一百。迷自他五尘。为一千。正迷十谛法门。谓四谛三谛。二谛一谛。或迷说成谛等十谛。或迷十善故成一万。然迷十谛空有不同。分成二万。或迷十善二谛。亦分二万。并本一千。余如经辨。然二皆有理任情去取。更有异释。如贤劫经等非今经意。后了知下能灭。谓了惑本虚居然不生故。晋经云。此诸烦恼皆悉除灭。除灭故清净。惑亡智显。即自在光明善根成就。言香幢云者。即九地善根至下当明。第二若有众生见其盖下。明见盖益。于中二。先正明得益。二佛子菩萨住此下。明摄化转益。今初。准晋经云。种一恒河沙转轮圣王所植善根。所谓白净宝网轮王等。是则多个轮王。非一轮王之多善也。梵本亦然。而言清净金网者。准璎珞上卷。金轮在十回向。初地已上皆是琉璃轮。而增宝数为别。是知旧译为宝网者。胜金网也。故彼经云。欢喜地百宝璎珞七宝相轮。四天王一万子为眷属。百法身为百佛国土中。化十方天下。已后略无化之分齐。宝数一一增至第七地。十三宝相轮。八地但云大应宝相轮。九地云白云宝相轮。十地云百万神通宝光璎珞无畏珠宝相轮。若顺晋经。白净之言。则是九地。即前香幢云自在光明。若然彼但是所等。则金网无失。若取十地为清净金网。正当十地以无畏珠为清净义。又摄化分齐。与上第十地摄报果同。则证十地明矣。故下此王放光遇者。亦登十地。言一恒沙者。谓从九地已还乃至十住铜轮。以此十地所化分齐。比前如恒沙矣。故晋经云宝网轮王等。等取前也。第二摄化转益中二。先明得位益。后佛子如得初禅下成德益。今初。有法喻合。法中直明摄化分齐。已如前释。喻中初化无间断。喻上法中教化众生。后若有闻名必生其国。喻下合中遇斯光明获十地位。后合中。初句总合。准晋经亦复如是下。欠放曼陀罗自在光明之言。今经影在后喻合中。若直云得遇斯光。前文无放光处。为何遇耶。言得十地者。此品总有三重。皆得十地故名展转益。一诸天子闻鼓说法得十地。二此天子毛孔出华盖云。见者得轮王位。即是十地。三轮王放光。遇者复得十地。此三位皆齐等同时顿成。各尘数多类。总是一随好中一光之力。余光好等弥更难说。言以先修行善根力者。显顿益之因。因闻普法修普善故。第二成德益中先喻。后菩萨下合。喻意云。欲界修得色定。以欲界眼见色界境。喻菩萨顿证未转凡身见十地境。以法力故。是则三祇可一念而届者。明一摄一切故。尘劫不穷一位者。明一切摄一故。如是迟速自在。是此圆教非余宗也。二合中初正明得益。后佛子假使下显境分齐。今初。言得菩萨第十地者。犹是牒前合中。以德依地成所以重牒。不然则成两度放光各得十地。言成就如是清净肉眼者。谓上诸德十眼。皆依凡身肉眼而成故就结之。后显境分齐者。即显肉眼境界广大。肉眼尚尔。余眼玄妙不可说也。文中三。初假设譬喻。以显境多。次正明能见。后结德有归。今初分三。初明一重广大。二宝手于汝意下问答显广。三宝手设复下。复积前数重显广大。第二如是一切下正明能见。先见前广刹之尘。肉眼能见已是超胜。况一念耶。次亦见下明见多佛。后如玻璃下明见之相。无心无来去故。第三宝手如是下。结德有归归轮王善。差别因果竟。此品之末。经来未尽

    普贤行品第三十六(已下入第四十九经)

初来意者。先通后别。通谓二品明出现因果。故次来也。亦名平等因果。谓会前差别因。成此普贤之圆因。会差别果。成性起出现之果。又前约修生。此约修显故。若尔何以更无别问。复何以差别果终。而无瑞证。平等因竟便有瑞耶。即以此义显是会前。若更别问便有隔绝。欲会前故不以瑞隔。普法希奇因果各瑞。又前应有瑞。经来未尽。故所以无耳。别谓此品先因后果。义次第故。亦远答前第二会初所行问。及不思议品念请本愿问故。前虽已答。下二深妙故重明之。亦犹相海随好。而妙中之妙。古德别为一段因果。二释名者。初通显二品义名。依性起修依性起用。差别相尽因果体均。故云平等因果。又因是果因。量周法界。果是果果。境界如空。因果俱尽未来利乐含识故名出现。别则品名普贤。即标人显法。明此行法非次第法。行者显法非人。品明所行非说人体。德周法界为普。至顺调善曰贤。依性造修曰行。然普贤行。诸经多有其名。品中虽广。今略显十义以表无尽。一所求普。谓要求证一切如来平等所证故。二所化普。一毛端处有多众生皆化尽故。三所断普。无有一惑而不断故。四所行事行普。无有一行而不行故。五所行理行普。即上事行。皆彻理源性具足故。六无碍行普。上二交彻故。七融通行普。随一一行融摄无尽故。八所起用普。用无不能无不周故。九所行处普。上之八门。遍帝网刹而修行故。十所行时普。穷三际时念劫圆融。无竟期故。上之十行参而不杂。涉入重重故。善财入普贤一毛。所得法门。过诸善友不可说倍。又上十行通收为二。若位后普贤。则得果不舍因。彻穷来际为普贤行。以人彰法则普贤之行。若位前位中普贤。则以德成人。但修普行即曰普贤。亦则普贤即行。但从行名故。若独位后普贤。则普贤之行无施下位。广释普贤如初会辨。三宗趣者。亦先通后别。通以二品明平等因果为宗。会前差别为趣。别以此品明平等圆因为宗。成平等果无二为趣。释文中二。此品辨因。后品明果。前中亦二。先长行直明。后以偈重显。前中又二。先正说。后瑞证。今初亦二。先明说因。后佛子我不见下正陈今义。前中亦二。先标前少说。后征释所由。今初。普贤说者。以人表法故。言如向者。一近指向前随好一品。为于障重地狱众生。略说随好少分用故。广说难思。二通指前所说之果为少分境。果海绝言故。三远通差别因果。虽有圆融之义。以五位渐次因果殊分。逐机就病未尽法源故名少分。则显下平等因果。逐法性说。因果圆融。名广大说。二征释中。征意云。何以前名少说。释文二意。一者成上。诸佛世尊所以出世者。以众生有无明等十过。未宜广说故。先明差别等。二者生后。谓众生既过滋多障累无尽。则一治一切治。一现一切现。众生无尽。因果亦穷未来际。前之所随由未尽故。言十过者。一者无明。二作恶行。晋经名诸缠。则亦是惑。此二为总。次六皆无明。三计我我所。四着身见故。六地云世间受身皆由着我。五三倒四倒等不能决断。六乖僻正理。七遍计分别。八结缚常随。九随生死流义通业苦。因流果流故。十远如来道行邪径故。此结成其失。结缚等名如常所辨。第二正陈普贤行中二。先明所治广多。后是故诸菩萨下能治深妙。今初。既一惑成百万障。则一障一切障义则惑惑皆然。今从重说文中三。初标次征释后结成。今初。总标嗔最重。除嗔之外。更遍推求无有一恶如嗔之重故。晋经云。起一嗔心一切恶中无过此恶。决定毗尼经云。菩萨宁起百千贪心。不起一嗔。以违害大悲莫过此故。菩萨善戒亦同此说。言于他菩萨者。若于菩萨起嗔其过尤重。以令菩萨废大行故。是以大般若中。天魔见诸菩萨互相是非过常大喜。二何以下征释。释中二。一总显。二何等下征列。标虽百万略列百门。古人寄位分五。初障十信行。二不乐佛法下障十住行。三不得菩萨诸根下。障十行之行。四乐诽谤一切下障十向行。五不乐与菩萨同住下障十地行。言口如哑羊障者。此是耳根障。以生边地不闻法。是故口无所说。舌根之障。次下自明。昔结云。菩萨万行不过此五。起一嗔心一切顿障。此释非不有理。如贼心求法。岂独障于地耶。是知通障一切信尚不起况后位耶。又所障法界如帝网重重。能障同所亦皆无尽。故知百万犹是略明。三佛子若菩萨下结成可知。第二能治深妙中二。先正显。后结劝。今初。文有六位。位各十行。初一始修。后五成益故。后五段展转依初。是为初即摄后。一治一切治也。说有前后得即一时。今初分二。先标举劝修。后何等下征列及结。于中十法摄为五对。辨五种修。初二约人明谦敬修。敬上爱下故。次二约法明真正修。顺教知事故。次二约心行明广大修。乐大行坚大心故。次二约智明增胜修。内入果智外起胜辨故。后二约悲愿明长时修。众生无尽悲化不疲。世界无边愿住不着故。第二清净者。依前正修行。时成离染故。文中二。初蹑前起后。后征数列名。下皆仿此。例中十句次第。从前十句而成。一由不舍众生故达深法净。以众生皆有佛性即妄而真。为深法故。二由敬上故能近。三由不谤故能护。四由知无尽故了如空。五由菩萨行不离法界故深入。六知菩提心等虚空故无边。七观察菩萨皆同此观能入佛力。故名为根。八精修不懈故不着劫数。九由化无厌故。观三世众生化未化等。十由愿住世界能修一切佛法。第三广大智者。垢染既拂本智自明。称性相知故云广大。亦从前十及次十而成。然有开合恐烦不配。说者随宜。第四普入者。事隋理融本来即入。智了法尔无境不通故。身心皆入。亦从前三生可以意得。非根者。境识及理皆非根也。第五胜妙心者。由前知法本融。则事理无碍。应机成益名胜妙心。从前四生亦可意得。第六善巧智者。由上事理无碍。今则权实决断名善巧智。有十一句。后二合一余皆如次。从前十成。一即言亡言为甚深。二无依故广大。三如依空生色故能说种种。四住无二边故证平等。五了种智深密故了差别。六无差全同。七若无疑惑则佛法庄严。八以平等成一方便。九三世法约差别门为无量方便。十由住佛力得知佛无边自力不退。从前十既尔。从前四段亦然。如是展转不离始修故。随一法具一切矣。第二佛子菩萨下结劝。一行能具一切行故疾得菩提。大文第二尔时佛下。证成中二。一现瑞证。于中先此界。后如此下结通。二尔时至十方下。诸菩萨证。亦先此土。后如此下。结通。言授记深法者。少用功力疾得菩提故。同名普贤者。皆有此行故。普胜界者。依此普法最为胜故。普幢自在者。此行成果高出无碍故。第二以偈重显中二。先叙述。后正颂。今初亦二。先说仪。后欲开下说意。此有十偈中并具文显可知。第二正颂中。百二十一颂分二。前二十四颂显说分齐。余皆正辨普贤行相。此是伽陀与前长行。绮互共显普贤之行。前是略明十法展转相生。此则广显诸门略无展转。又前多显体此多辨用。前中二。初一诫听许说。余正示分齐。于中二。前九颂许说过去菩萨行。后于一贤劫下。许说三世佛菩萨行。于中二。前三偈举说时处。前二时后一处。后十一偈明所说行。于中前四诸佛出世行。即普贤行故名因果圆融。后七菩萨三轮愿智行即普贤行。第二于一微尘下。正显普贤行九十七颂分二。初六十七明即悲大智行。后未安者下。三十颂。即智大悲行。今初。有十种行。一初五颂明善入帝网行。二十七颂深入时处微细行。三世界及如来下。三颂。明了佛心秘密行。前一偈半摄前起后。后一偈半正显难了能了。四十偈了三世佛摄化行。五出生下。二偈六根无碍行。六有三偈如化无方行。七诸佛甚深下。十颂。三世间自在行。此中玄妙宜审思之。八六颂别明智正觉世间自在行。九如来法身藏下。五颂。非身示身行。法身藏者。即前藏身普贤菩萨自体。遍言亦同此也。十有六颂非量示量行。第二即智之悲行中。亦有十行。一初四偈无住摄化行。二有四偈非身现身行。三一颂分布舍利行。四二颂知佛大心行。五三颂法轮深入行。六无量无边下。五颂了知根器行。七三颂了世业惑行。八五颂了达根境无碍行。九一颂知四种说法行。而刹说等者略有三义。一约通力。二约融通。一说一切说故。三约显理。是说菩萨触境皆了知故。则触类成教如香饭等。十末后二颂三世摄化行。平等因竟

大方广佛华严经疏卷第四十八大方广佛华严经疏卷第四十九

        唐清凉山大华严寺沙门澄观撰

    如来出现品第三十七(已下入第五十经)

初来意者。前品明称果之因。此品辨如因之果。体虽平等不坏二相。先因后果义次第故。亦为答前不思议品出现念故。答第二会所行问故。会释如前。二释名者。如来是有法之人。即三身十身之通称。出现是依人之法。果用化用之总名。如来虽见上文。对出现故重辨十身皆有出现。且寄三身以明。然来即出现。为分人法晓喻分明。故重辨之。若依法身如来者。即诸法如义如理。常现名为出现。故文云。普现一切而无所现。又云体性平等不增减等。若依报身。乘如实道来成正觉。故曰如来。本性功德一时顿显。名为出现故。文云。如来成正觉时。于一切义无所疑惑。普见一切众生成正觉等。若依化身则乘萨婆若乘来化众生。故曰如来。则应机大用一时出现。文云。以本愿力现佛身。令见如来大神变。又云。随其所能随其势力。于菩提树下。以种种身成正觉等。今以新佛旧成曾无二体。新成旧佛法报似分。无不应时故即真而应。应随性起故即应而真。三佛圆融十身无碍故。辨应现即显真成。是以晋经名性起。性字虽是义加未爽通理。以应虽从缘不违性故。无不从此法界流故。以净夺染性即起故。若离于缘性叵说故。下加性起菩萨表所说故。妄虽即真不顺性故。今以起义多含直云出现。从性从因从真从感。皆出现故。若唯辨应身出现。非唯失前二义。亦未足显深。何能融前差别之果若以来为现义。则如来即出现。持业释也。若分人法。三皆如来之出现。拣余出故。第三宗趣者。平等出现为宗。融差别果为趣。四正释文。文为七分。一加分。二本分。三请分。四说分。五显名受持分。六表瑞证成分。七偈颂总摄分。今初有二。先毫光加请主。后口光加说主。前中三。初光次加后益。光中有十分三。一光出处。眉间者。表证中道。离有无二边故。表无住道离真应二边故。白毫者。表所出现性无垢故。能诠出现诸教本故。二放大下。辨光名。体如所说故。三无量下八段。皆是光业。初眷属光即是因业。总摄诸法皆此生故。四其光下舒业。五显现下敬业。六觉悟下觉业。七除灭下止业。八映蔽下降伏业。九显示下示现业。十作是下卷业。二入如来下正明加相。所以加此菩萨者。如名所显故。性有二义。一种性义。因所起故。二法性义。若真若应皆此生故。亦有释云。此之妙德即是文殊说此法门加性起称。此释无违大理。以文殊大智为能显。普贤法界为所显。共成毗卢遮那之出现故。亦是解行满故。佛出现也。从顶入者。是加持相妙智之极方能显故。第三时此道场下。加益中二。先大众同欣。知法将被故。二尔时下。妙德领旨。知令求说主故。于中二。先长行。身心致敬。跽者跪也后偈颂赞请。十偈分二。前五赞后五请。前中初一总赞申敬。余四别赞。放光中有赞因赞果赞用等。文并可知。后五中。初一自叙得益。即是领旨。次偈领众意请。次偈叹众堪闻。次偈叙佛令请。后偈正求说主。已领佛意故不请佛。第二口光加说主者。示所请故。文中三。初光次加后益。今初亦十。一出处口放者。表教道传通故。二光明令得无碍辩。不畏大众及深理故。余如前辨。二入普下。加中入口者。教以口传故。如佛说故。加普贤者。是普贤行之果故。所证法界由理显故。三其光入下。明益中。唯除如来拣师资故。第二尔时下。本分中三。初征事而问。次引例以答。答即是本后说。是语下。表瑞证成显说希奇。才闻其名已有征故。大地动者。大法将显大惑将倾故。出问法光者。冥加智慧助发请故。第三时性起下。请分中有长行与偈。前中四。一总举法请。二佛子此诸下。叹众堪闻。三佛子汝已下。叹说主具德。四善哉下。标章别请。前二可知。三中别叹十事。一供多佛必曾闻故。二成妙行曾已修故。三定自在有所依故。四亲证入故。五知教道故。六除他疑故。七上力加故。八审根器故。九能随说故。十顺智到彼岸得意深故。有如是下总结。既有说德堪宜说故。第四标章别请中。初句赞善蹑前三段。后列十事以显无尽。一如来出现之法。此是总相。总集多缘成出现法。法含持轨。余九是别。初三即三业秘密。四境即智之所缘。亦分齐境。五依境修行通因通果。六成菩提道。七成必转法轮。八应必示涅槃。九若存若亡见闻皆益。备斯九事一化始终。有云。初一所依之法。余九能依之德亦有斯理。如是下结请。第二尔时下偈请。十偈分三。初一赞德标请。颂前第三段。次四举法别请。颂前第四段。三有五偈叹德劝请。通颂后三段。于中初偈总赞请。次二偈劝说之方。以法深难领故请说因喻。次一偈半叹众堪闻。末后半偈结请。所说净心显说无过。具演文义周圆。第四说分大分为二。初别答十问。后佛子如来以一切譬下。总以结酬。今初。十段答前十问。各有长行偈喻。一一具十。今初。答出现之法。长行中二。初标告叹深。二所谓下。随义别显。于中三。初法说深广酬前因缘。二佛子譬如下。喻明深广双酬因喻。后佛子至知如来出现下。总结成益。结上十喻。初中分三。谓标释结。今初。总标多因成出现果。二何以下释于中二。先征以总释。后何等为下。征数别明。今初。先反释缘。约能成之缘事。即所成因体。后以十下顺释。向言无量乃是总相。今明有十个无量。以显无尽。理实则有百千阿僧祇数无量。此十无量皆遍十喻。言百千者。占人云。以十无量入中十喻成百。以后结中十句。一一结前百门为千。其中更有别义。方成无量。今以下列十中门门皆云无量。则不俟相入。是知百千之言。但是数之总称耳。二征数别明中。一始发大心誓期出现故。此心何相。二明上求胜志。三明下化慈悲。四行以续愿。此行谓何。五明不出福智。六别显福严。七别明智严八净前功德。九严前智慧。所谓方便道。教道证道无住道。正道助通。一道二道等。皆庄严故。十穷究法源真实智故。三佛子如是下。结中既皆过去积因多法圆满。令二利果一时出现故。出现言通真通应。第二喻明深广中。十喻各三。谓喻合结。喻酬譬喻合酬因缘。故文云非以一缘一事而得出现。又前法说多约往因。此中合文多约现缘。十中一大千兴造喻。此喻为总总喻众缘。以成出现故。云以无量缘等。下说云雨皆此所霔。初喻中四。一总辨多缘。二别显缘相。三显被因起。四性相结成。今初。先反后顺。缘即因缘。如众生业及风雨等。事即事相。谓如所持水及宫殿等。二所谓下。别显中。先云雨上霔。后风轮下持。一能持者。若无此轮雨无停处。二水若不减碍起天宫。三水虽已减假此成立。谓减一节水起一重天。如严冬急流重重水结。四虽起总处。无别庄严故。须第四。三如是皆由下。显彼因起。谓上云等。略由二因。一众生外增上业。言共业者。谓多有情应生此界共业同变。于中有四句。谓共中共等。二菩萨善根。此有二意。一约同居。谓地前菩萨。二约能化。谓随诸众生。应以何国起菩萨根等。便修彼因以取彼国故。有众生类即菩萨佛国。令于其中下显受用果。谓先成器界。后起众生依之而住。如俱舍婆沙等辨。各随所宜者。谓水族众生得水受用等。又人罗刹宫殿无碍。菩萨众生净秽同居。第四佛子如是下。性相结成中。先结前生后。后法性如是下正结。此句为总。此法性言通于性相。无有生下别显性空亦遮其妄计。谓非冥性微尘等生。非自在梵王等作。无神我能知。上三显能作空。无有成者显所作空。虽能所俱空不碍相有。故云而得成就。如是无碍为法性如是。次合中略不合第三显彼所因。以次下二喻自别合故。合四轮中。前三是因。后一二利果满。因圆果满佛出现故。一品之内多以依喻正者。非唯义类相似。实则外由内变故。令外器全似于内。是以上云菩萨善根所起。众生共业所生等。华藏品中已略开显。第二洪霔大千喻。此之云雨即前喻中兴云降雨。正喻出现法门。广大难知周十方故。言心相续力者。若约信受但是圆机。坚种相续能受深旨。若约具受。则八地已上得无尽陀罗尼力。方能受持乃至十地。方受如来云雨说法。是以文言除大菩萨。由初义故但拣二乘。第三云雨无从喻。菩萨善根。如生共业感彼出现。法云法雨机感而现。非先有一方所从彼而来。机谢而去。亦非归至旧所故。体无生灭。第四大雨难知喻。喻深非心境故。古云。教广行大因深果远。故非预二乘。亦不乖理。但是大机即世间主无能所行。即能知之。第五大雨成败喻。况佛灭惑成德喻中。初一即坏界之时。三即以水止水合中。初二灭惑成智福。次一灭障成智。即止观双运。后一权智照机。又无二同二乘。无三同外道。无四增无明无五非种智。此即分上总中法雨令差。第六一雨随别喻。喻佛一味随器。随器即合前差别。第七胜处先成喻。喻佛胜缘。先济德文中先正明。后佛子譬如下。牒以释疑。先成由业力。法异由机殊不乖第六一味。第八事别由因喻。喻佛成办大事德。亦是德殊由智喻。喻中分三。初莲华表佛。总中略无名出现者。表佛现故。而言大者。准五卷大悲经第三云。有千叶故光照十方者。金色光也。言尔所佛者。有千枚华表千佛故。故劫名贤贤善多故。余多同此。二佛子尔时下。风轮起处者。即有力遥持广前建立风轮。三佛子大云下。结因有属。二合中亦三。先合莲华表佛喻。于中一切善根功德合上大水遍满。放于下。合生莲华。谓不断种性如华表佛故。普照十方合上光照十方。与诸菩萨下。合知佛当出。第二佛子下。合风轮起处喻。此十智光次第合前。所成唯果德。能成通因果。又能成即实之权。所成唯差别之德。故下结云同一体等。第三佛子如来下合。结因有属于中三。一结因即能成之智。合上一味之水风轮不同。此轮由一节水减。一重轮生。如澄水垽。今推能成由一味大悲。二佛子一切下结果。即所成之大智。从一实之智随权而生。合上风轮差别。故世界差别。三佛子汝等下结缘。即由众生异。合上以众生善根不同。兼释外疑。于中又三。初牒前正理。一解脱味即能成之水。水具二义。悲及解脱二文影略。种种功德通能所二智。二众生念言举外疑情。然感应之道略有三义。一互相成。二互相夺。三缘成性空。今众生以缘夺因。纯推佛力失因缘义。三佛子此非下。如来为释。于中初以因夺缘。一向言非。次但以下。为说正义初句因缘相成后而佛下。有二义。一成上因缘。虽随众生心无分别。二成第三义了性空故。缘成故无成。无成故无坏。所成既空何有能成作者及作法耶。第九四轮相依喻。况佛体用依持德。亦广建立风之别义。喻中二。先明能持之风。有四者。一一时持水名安住。二多时不动名常住。三与劫齐量。四体性坚密。是以俱舍云。假使有一大诺健那。以金刚轮奋威悬击。金刚有碎风轮无损。其量广无数。厚十六洛叉。彼但有一与此不同。二此四下四轮相依。准俱舍论。次上水轮厚八洛叉。洛叉亿也。次上更有金轮。厚三亿二万由旬。然其世界。或说三轮成。谓风水金。或说五轮。谓下加虚空上加大地。今欲称法合成四轮。则地中含金金亦地故。二合中先合能持四风。有配四摄义。则少似既合。以如来出现则成大局。今谓一未信入者。以四摄普摄示以正理。二已信受者建立教法。三已入法者令其成行。四已成行者令其得果。二佛子下。合四轮相依。一慈悲合地能厚载故。二方便合水曲随器故。出现合风力能持故。无碍合空如空无碍故。故净名云。其无碍慧无若干故。文意虽但取展转相依。不妨有似其事。若准偈中。慈悲之前有一切佛法。以况树林则五重相依。第十大千饶益喻。况佛利世德。别显总中一切众生各随所宜。而得受用。合中次第合前四益。见佛生喜如鱼得润故。戒如平地万善由生故。定如宫室得安息故。慧如虚空不可坏故。于中二句。初不坏事。后不坏理。第三总结成益中有十一句。各别结上十门。以九十二句结第九门。故有十一。一多因出现故。二广故难受。三无生故无从。四非心识故思必发狂。五如空故惑见双亡。六平等无我故一味。七由无尽故诸乘遍化。八后际无断故佛种不断。九无对即无碍慧。十为无为平等。即摄三轮归无碍慧。十一本为众生故今利益满足。若将一一通前十门。未为得意。第二偈颂。三十七颂分三。初十四颂叹深许说。次二十二颂。颂上十喻。后一颂结说无尽。不颂上文。今初分二。前十一颂叹深难量。后三颂诫听许说。今初亦二。初偈总叹。颂前标告不思议言。后十别叹。即次第颂前总结十一句。亦第九偈颂九十二句结。既结喻。今此亦即通颂前喻。喻则性相双明。此中多就性说。古称性起弥复有由。一无边量即无量义。二一毛叵量即广大义。三空际叵得即无生义。然唯此第三偈。似颂第五如空。第六偈似颂第三无生灭。然取义不同故。皆案次。四不能知者离心识故。五遍于一切非一切者。即如空义。六体性平等即平等无我义。七前遍诸刹。此遍三世文绮互耳。八无变易故尽后际。九离言说故无二无对。十本愿现身故能成益。第二诫听许说中分二。初一诫听劝修净意如空。总以喻显。下二句别显。一离妄取。如彼净空无云翳故。斯即真止。二触境无滞。如彼净空无障碍故。斯即真观。此观不作意以照境。则所照无涯。此止体性离。而息妄故诸取皆寂。若斯则不拂不莹而自净矣。无净之净则闇蹈佛境矣。此为心要。谓后学思行。后二偈许说分齐。于中初半偈。结前生后。后偈半正示分齐。牒举十门。略无行者三业摄故。阙正觉者导师中摄。或复略无。第二颂前十喻。即为十段。初喻四颂以是总故。余九各二。今初文二。前二颂总显多缘。后二颂别显缘相。其第九喻。合云方便依智者。智即颂前出现。然初无碍慧。是佛实智中二皆权。于中智即知事方便随机。合上即权实无碍对初即悲智双游。第二别答出现九门。先明身业。后八依故。长行中二。先标举。后佛子诸菩萨下释相。于中三。初就法总明。次约喻别显。后就法总结。然总中五遍通喻中十身。结中十句别结十喻。亦同前出现。今初分四。一总教广见。二何以故征其所由。三诸菩萨下。反释所以。四应遍一切下。顺以结酬。就反释中总举五法。法是所知法界。及调伏法事。是调伏众生行事故。晋经名行。身即是正国土是依。生是所化。四顺结中应翻上五成五无量界。身为能遍四为所遍。一遍法界。二遍调伏界。三遍调伏加行界。四遍世界。五遍众生界。唯有五界非是略也。第二佛子譬如下。约喻别显中。明如来出现有十种身。一周遍十方身。二无著无碍身。三普入城益身。四平等随应身。五无生潜益身。六圆回等住身。七无心普应身。八穷尽后际身。九严刹益生身。十严好满愿身。此即八地十身而为次不同。一法身。二智身。三威势。四菩提。五庄严。六意生。七化。八力持。九福德。十愿。四是菩提者。初成先照故。偈云日照出现故。五庄严者。一一毛孔随好光明。以庄严故。余文并显。显此十身举十喻况。一一喻中文各有三。谓喻合结。今初虚空周遍喻。况周遍十方身故。下结。云以其心无量遍十方故。喻中先直示后征释。征云。至不至别。何得俱耶。以一无身释上二义。由无身故无可得至。亦以无故无所不至。如色中空。空若有身身即质聚。便碍于色。如铁入水水不入铁。今由无身故遍入色中。法准喻知。此以事空以况理空。理空即是法身故。经偈云。佛以法为身。清净如虚空故。为众生下此释外疑。第二空无分别喻。况无著无碍身故。经结云所行无碍如虚空故。空无分别不碍显色。智无分别不碍利生。第三日光饶益喻。喻普入成益身。普入法界故。喻合皆有总别释成。合中别内有十种益。合前八句。初二合初句世出世异故。三拔四流之苦与出世之乐。拯二乘沉定水之苦。与菩提乐。皆变湿令燥之义。四道品通长三乘草木。五信有二义。一成上义。信能增长一切法故。二合成熟信。能必到如来地故。六七二句合廓彻虚空。一得见闻四谛因果智。二得三明十力智如空有日廓净照彻故。八有二义。令心无碍成上彻空。不坏善根成下莲华。如赤莲华不遇日光翳死无疑。三乘善根若遇智日则便不坏。九正合开华。上已开不坏。今未开今开。十合后二句。发菩提心即见大道。成就本行是办家业。第四日光等照喻。喻平等随应身。由住真际故无私平等。文中二。先正喻。后重举释疑。前中黑山喻缘觉者。无法空之光故。不出功德故。不同菩萨十大山王表十地故。高原喻声闻者。不生佛法莲华故。大地一种通含三聚。取决定能生处喻正定聚。得缘方生喻不定聚。砂卤等地喻邪定聚。然亦不舍故皆等照。后释疑云。日光是一佛智万殊岂为同喻。释云岂不向说但随山地有高下耶。故知但随众生智慧不同。佛无私智无若干也。未违前喻。又既约机说异。则照高未能兼下。照下而犹照高。又若舍化先舍于小次舍于中。唯菩萨高山尽日蒙照。思之。第五日益生盲喻。喻佛无生潜益身。有目者睹。非是独为生盲不见。亦未曾灭。以潜益故。合中二先略后广。略中五事皆盲。而无信为总。故云无信眼故。此即涅槃阐提三罪。无信断善即一阐提。无解毁见则谤方等。毁戒邪命。即犯四重禁作五逆罪。此四至恶犹有佛性。亦为饶益令离苦集。后佛子如来下。广显中二。先能益光后所益众。今初二。先列十光。后结分齐。今初。十中初三成二庄严慧中二句。一普照事。一照净理。次三成三慧。初二成闻慧。后一成思修。后四成四智。大圆镜智。无住普照故。平等性智。绝戏论故。妙观察智。随应演故。成所作智。严土化生故。佛子下结数分齐。以日有千光故。结云千实乃无数。五百照下者。五位自分行。五百照上者。五位胜进行。二其菩萨下。所益中有四。初益菩萨。二益二乘。三益生盲。四益恶趣。菩萨有二种益。一益圆机顿证佛境。二益权机令熟权趣实。诸处谓五眼等诸地。谓种性地等。二乘生盲可知。四地狱下。光益恶趣文有六段。一拔苦与乐。二佛子下。因起邪见。二是时下。慈音示正。四彼诸下。回邪报恩。五如来下。佛与授记。六佛子下。结光利益。此中诸益多同随好。第六月光奇特喻。喻佛圆回等住身。谓等住三世无增减故。合中四法者。一圆智映二乘。二常身示延促。三由器见有四无所见无向背。初及后二皆圆回义。菩提器者。堪受菩提之人。睹意生身。若心海澄清妄念都寂。则真见佛矣。第七梵王普现喻。喻佛无心普应。身不分而遍故。第八医王延寿喻。喻佛穷尽后际身。喻中二先彰现德。后彼大下。咒力持身。合中亦二。初合现德。于中初合用药无不尽。次修学下。合咒力为方便。后善能下。合见者病愈二及住下。合咒力持身。用前咒药持住多劫。故略不重明药咒能持。第九摩尼利物喻喻佛严刹益生身。雨宝利贫即严刹故。各有体用可知。第十宝王满愿喻。喻佛相严满愿身。合中先正合。后佛子佛身下释疑。于中初虽合喻。已是释疑。谓有疑云。若念皆见今何不见。故云少福不见。次疑云。亦有贫下薄福何以得见。释云除可调者。第三以其心无量下。就法总结。十句次第结前十身。其有难者前已会释。第二颂中有二十偈。次第颂喻。喻各二偈(已下入第五十一经)第三出现语业。长行有标释结释中三。初就法略说。二约喻广说。三以法通结。昔人亦以初十入于中十为百。后十通前十为千。此亦可通。今更一解。后结则容通结中十。中十则别喻初十。但小不次耳。今初圆音之义。略启四门。一叙昔二辨违。三会通四正释。前三非要广在别章。但正释文自含众妙。文有十音以显无尽。各上句标下句释。一普遍者。即随类音。然有二义。一约体。广无声不至。故云普遍无量音声。斯则人天等异万类齐闻。上云众生随类各得解。二者随前一一之音。皆能独遍。如目连不究其边。二随乐欲音。谓趣举一一类音。能随乐欲说种种法。上经云。如来于一语言中演说无边契经海。又云。佛以一妙音周闻十方国。众音悉具足法雨皆充遍。通证前之二义。三随根解音。谓即上说中。随说一法大小各闻。故云随其信解。宝积云。佛以一音演说法。众生各各随所解。四随时音。谓即上大小之法。令闻不闻皆自在故。云不失时。亦兼随闻一法欣忧不同。宝积云。或有恐畏或欢喜。上四多约即体之用。是圆音义。后六多约即用之体。显一音义。谓五外随缘叩我无生灭。六内集缘成何有主宰。七甚深者。欲言其一则万类殊应。欲言其异一体无生。又欲言其一。随一音中能具多音故。上云一切众生语言法。一言演说尽无余。欲言其异。即上多音唯令闻一故。下喻云。譬如天鼓发种种声。懈怠诸天唯闻无常觉悟之音。故甚深也。八纯称法界。九横入无断。十竖归一极。此十圆融一味。是如来圆音。是知或谓无声随叩发响。或谓唯一直声无宫商等异。皆大地之一尘耳。第二佛子菩萨下。约喻广说中三。初结前生后。次征后释。今初收上十声要不出三。约相则广无量。约体则无主宰。约用则有显示。今并双非以显中道。谓莫穷其边故非量。随机随时有闻不闻。故非无量。多缘集故非有主。纯一法界生故非无主。当体无生故无能示。巧显义理故非无示。更以四句明体用无碍。谓一以用从体。由体无不在故。能令上十类皆遍一切。非唯遍声。亦遍一切时处。众生如来法界等。虽复于色等皆遍。恒不杂乱。若不等遍则音非圆。若由等遍失其音曲。则圆非音。今不坏曲而等遍。不动遍而差韵方成圆音。二以体从用。其一一音皆具含真性。三用即体故。上十类声皆不可得。唯第一义永离所执故。法螺恒震妙音常寂。名寂静音。如空谷响有而即虚。若不即虚。非但失于一音亦不得圆融自在。四体即用故寂而恒宣。若天鼓无心而应一切。长风随窍万吹不同。若不遍同非但失于能圆。亦非真一梵音随缘自在。名为如来圆音妙音。非是心识思量境界。第二征意云。前言无量等。今何双非。第三举喻广释。其大意云。性相无碍体用相即。故约法难显寄喻以明。十喻即为十段。段各有三。谓喻合结。今第一劫尽唱声喻。喻前第六无主喻中。言法尔者。俱舍第二云。生无色界有二种因。一因力。谓近习及数习故。二业力。谓上界后报业果欲至故。若生色界则有三因。谓加法尔力。但器坏时法尔有声故。然四种音非是一时。初二火劫将坏欲界及初禅时。三即水灾坏二禅时。四即风灾欲坏三禅时。四声各别故非无生。但从缘生故非有主。合中明佛欲坏生死世间。亦有四声说五乘法。第二响声随缘喻。喻上第五无生。第三天鼓开觉喻。喻第九无断绝声。遍入法界化无断故。喻合各三。一能开觉。二开觉益。三结用归体。二当知下。合中三者。初合能开觉别有十一声。义分四节。而有二意。一初二通五乘。次六通三乘。次一通第一第二乘。后二唯大乘。二者初一节人天。余三节配三乘。次无数下合开觉益。后而如来下合结归体。由不住方等故。上能普遍。是以庄严论云。若佛音声是有法非非法者。不能遍至十方。反此故能。第四天女妙声喻。喻第三随信解声。多音随乐故。第五梵声及众喻。喻化不失时熟者必闻。即以根熟为众。第六众水一味喻。喻无邪曲声从法界生。一体性故。第七降雨滋荣喻。喻欢喜声称根增长故。离佛无声不从外来。离机无声不从内出。第八渐降成熟喻。喻无变声以皆至究竟故。上先照高山以显顿圆。此先小后大即是渐圆。将降法雨者。思欲说一也。未便即降者。恐破法堕恶道故。先兴法云是说方便。方便含实如云含水。第九降霔难思喻。喻上甚深声。虽多差别。皆于甚深法界之所流故。第十遍降种种喻。喻普遍声。非唯普遍四洲。亦遍出多雷音。喻中有总别结。从四天下别中有五。一云二电三雷四风五雨。此与贤首品文有影略。思之。后虽彼下结。合中亦有总别结。别中亦有五。前四各有佛子。一以身合云有覆阴等故。即菩提等。十身中有四身名异义同。一即愿身愿生兜率故。第四即意生身。随意所生同世色故。八即菩提身。具佛十力成菩提故。九即威势。具四无畏能伏外故。亦可。十力降魔为威势。无畏为正觉。有正觉义故。余六名义俱同。第二合电光。不出通明无畏。第三以三昧合雷声者。略有三义。一若秋之雷蛰虫藏匿。若入三昧诸恶不行。二若春之雷则发蛰开萌。犹彼三昧发生功德。三雷是雨之先相。三昧是说之先兆。十名思而释之。第四以大智合风者。以后得智观机警觉。加被令成法器故。第五此相现已下。以说法合雨。于中初结前标后。所谓下。别有十法者。一将成正觉念相欲尽闻斯法雨便细念都忘。得见心性等虚空界。法界一相始本无二。契同诸佛平等法身。故云说法界无差别。二出胎已后坐道场。前后更无身故。名最后法雨。名游戏等者。此有二义。一开为二。谓游戏是神通大用。秘教即心智所契。二合为一。令于秘教出没自在。故云游戏。言秘教者。即诠如来三德涅槃故。涅槃经名秘密藏。安住于此能建大事。神通作用故名游戏。在法华经以体从用。名如来知见。深固幽远名为秘密。虽初心同禀而穷究在斯故。亦为说三。一生所系者。谓如弥勒更一下生故。所以更一生者。由微细无明能障所知故。今为说令净彼细惑成种智普照。上三皆等觉位。四灌顶菩萨。即十地受职位。十方诸佛法水灌顶。堕在佛数。能受如来大法云雨。令具佛功德智慧。广作佛事为庄严故。五得忍菩萨。若取忍净。八地已上。将止此忍劝满福智。不断悲故。若取初得。有说初地即得。为说信等功德。后后圆净十地。地智一一开发不断二利故。六住向行三即三贤位。令其入证真如现前。依此变化为甚深门。而胜进不息。七初发心者。通信初发心及信满发心。既发上求下化之心。令依愿行故。上皆已得本位故。并为说胜进上位之法。此下二门通有二意。一约初求显说说其自乘。二约已住密说。密授大乘。如缘觉中。约自乘。说则因谢非常。果续非断。逆观非有顺观非无。为离二边。虽离二边而不坏自乘之果。约密十二因缘即是中道。中道者名为佛性故曰甚深缘起。是为上上智观。故。得不坏佛解脱果故。九声闻中二者。一约显说。由彼厌患苦集故。说人空智剑断之。二约密说。应以法空断一切惑。故名大剑。十为二聚众生故。云集善根者。其邪定聚未堪法雨。未定令得名为成熟。已定令增种种法门。三佛子诸佛下合上结中有二佛子。初合结数。后合心等以释外疑。第三复次佛子应知下。通结十喻皆无分量。文显可知。第二偈颂。颂上十喻喻各二偈。第四出现意业。先身次语后意义次第故。长行中二。先征起后正释。释中三。初约法总辨。二寄喻别显。三总结劝知。今初。言如来心意识俱不可得者。约体遮诠也。但应以智无量故。知如来心者寄用表诠。然此一文古有多说。一云识等有二。一染二净。佛地无彼有漏染心心所。而有净分心及心所。果位之中智强识劣故。于王上以显染无。约彼智所以明无量。若必无王所依何立。故成唯识第三。引如来功德庄严经云。如来无垢识。是净无漏界解脱一切障。圆镜智相应则有王明矣。言转识者。智依识转非转识体。一云以无积集思量等义故。说心等叵得。就无分别智以显无量。非无心体故。摄论第八云。无分别智所依非心非思义故。亦非非心为所依止。心种类故。以心为因。数习势力引得此位名心种类。上之二解俱明心意识有。一云。佛果实无心意意识及余心法。云不可得。唯有大智故言智无量故知如来心。故金光明经及梁摄论。皆云唯如如及如如智。独存佛地。论中五法摄大觉性。唯一真法界及四智菩提。不言更有余法。上之二宗遍取皆妨。若依前有未免增益。亦不能通不可得言。又此净分此何不说。彼无垢识而得说耶。经何不言染不可得。若依后义未免损减。亦不能通知佛心言。既云以智无量知如来心。不言无心。可知明非无心矣。又心既是无智何独立。非唯违上二论。亦违涅槃灭无常识获常识义。若二义双取未免相违。若互泯双非宁逃戏论。若尔何以指南。今释此义先会前二宗。后消经意。今初。若后宗言唯如智者。以心即同真性故曰唯如。照用不失故曰如智。岂离心外而别有。如是则唯如。不乖于有。前宗以纯如之体。故有净心。心既是如有之何失。是知即真之有。与即有之真。二义相成有无无碍。后消经意者。言不可得者。以心义深玄言不及。故寄遮显深。言但以智知如来心者。托以心所寄表显深故。晋经云。但知如来智无量。故知心无量。云何深玄。欲言其有同如绝相。欲言其无幽灵不竭。欲言其染万累斯亡。欲言其净不断性恶。欲言其一包含无外。欲言其异一味难分。欲谓有情无殊色性。欲谓无情无幽不彻。口欲辩而辞丧。心将缘而虑亡。亦犹果分不可说故。是知佛心即有即无。即事即理即王即数。即一即多。心中非有意亦非不有意。意中非有心亦非不有心。王中非有数亦非不有数。数非依于王。亦非不依王。一一皆尔。圆融无碍。则令上诸义各随一理不爽玄宗。言寄表显深者。既心不可以智知。且托智以称叹。智是心所尚以十喻明玄。则所依之心玄又玄矣。故十喻之末皆结为心之相。然佛尚不说凡何敢思。有因缘故。辄凭教理以示玄宗。望无咎其繁而不要也。第二譬如下寄喻别显。举十大喻。以喻如来十种大智。十智体用非一非异。亦文各有三。谓喻合结。今初。虚空无依为依喻。喻佛无依成事智。合中谓诸乘之智依佛智生。如十地云此十地智。皆因佛智而有差别。离佛智外无所依学。而佛智果满更不依他。岂不依心及依理耶。岂不向言王所无二耶。良以。佛智照极。无有智外如为智所依。故智体全如。若有所依不名如智。亦犹净名云法随于如无所随故。文殊般若云。若无境界则无所依。况佛智外无法可得。以一切法即佛智故。第二法界湛然喻。喻佛体无增减智即转释前依。依者依此出生故。虽出诸智亦不减少。菩萨解脱成佛智时。亦不增足以同体均故。如上海中板喻。第三大海潜益喻。喻佛体均益生智。即双释前依及出生义。谓与众生心同体。故义曰潜流。穿凿自心得智慧时。即是见他佛智。是曰依之出生。又由体同。令外佛加持资其念力。亦是流入。第四大宝出生喻。喻佛用兴体密智。释上能生。以何义故而能生耶。具四宝故。喻中有三。初总明出处体用。次征列宝名。后结其深胜。合三同喻。列名中。衍英诸公皆云。初证道智断惑障。二助道智断智障。三不住道智舍于报障。上三自利。四利益众生智。即利他行。此释亦无大过。果地具此三道。能令学者入菩萨地。故今更一解。若直就文。文自明显。今以法相收之。即四智菩提。一大圆镜智。以离诸分别名无染着。所缘行相微细难知。不忘不愚一切境相。名巧方便。二即平等性智。观一切法。若为无为。自他平等名善分别。三即妙观察智。此智善观诸法自相共相。无碍而转故。说无量法而不坏法性。无量法者。即摄观无量总持定门等。而言说者。雨大法雨断一切疑故。四即成所作智。知机知时作所应作故。三若诸如来下。合前深胜。于中先明用胜体深。此中用胜喻在总中。此中体深。同法华髻中明珠。不妄与人。然约下智不及故称密藏。不全同喻故。涅槃中明有密语而无密藏。后此四智宝平均下。明体胜用深。平均正直即平等性智。大慈悲等共相应故。故曰平均。一味相续名为正直。二端洁即大圆镜智。端者。纯净圆德现种依持故。洁者。性相清净离诸杂染故。三妙好即妙观察智。四普能利益即成所作智。此约别配。今以四智圆融故。四德亦该四宝。况四智乃十中之一。则永异余宗。第五珠消海水喻。喻佛灭惑成德智由有前智无智不生。由有此智无惑不断。又前则横具四智。此则竖具四智。皆是释前为依之义。喻中二。先总明体用。后佛子此日藏下。别显用相。此为极教了说。而起世婆沙等。说阿毗地狱在下火气上吞销铄海水。盖是少分方便之说。而俗典云。以沃焦石消海水者。或测度而知。或见宝不辨谓之石耳。又云注于尾庐壑者。但见其消以名之耳。合中亦二。先合总明体用。后佛子诸菩萨修习下。合别显用相。然此四智。古德有配四种三昧。初是大乘光明三昧智。二是集福德王。三是贤护。四是首楞严。此释配定理则可尔。案次乖理。以第三名智光普照故。若将初为三以三为初。乃顺文理。今更一解。标其所成即是四定。约能成智应别立名。又若将此竖配诸位。尤异昔解。谓一佛以即事而真智。治于地前。成初四地令得贤守定。以此三昧能守世出世间贤善法故。前三地为世四地为出世。既了即事而真则即散而定。二以即体之用智治四地。未能起用。令得五地入俗成集福德王定。三以平等无相智治五地虽能随俗未得平等。令得六七地般若大光功用后边成光明定。四以平等无功用智治七地功用。令入八地。乃至佛果得首楞严定。所作究竟故果既具四。因亦通修。且约相显为此竖配。不可遍局。第六虚空含受喻。喻佛依持无碍智。亦释前依义。上但云依。犹通外依他力。今明体遍普容。是则五乘等智。皆是如来大智中物。肇公亦云。夫圣人虚心冥照。理无不统。怀六合于胸中。而灵鉴有余。镜万有于方寸。而其神常虚。即斯义也。第七药王生长喻。喻佛穷劫利乐智。喻中四。初总显体用。二彼药王下。别显用相。三此药王下。得名所由。四佛子下。拣其非处。先拣后收。收者亦不厌故。故晋经云不舍生性。合亦四段。而文不次。初合总显体用有六。一以悲愿菩提合根。此为诸佛之本深难拔故。文有四弘。二依实智所生方便为茎。能干事故。菩提体故。三依前二智分为诸度。旁阴为枝。四戒定息热别受业名。五辩才道品等。亲生菩提开发为华。六果可知。上六亦可竖配地位。而下别。显用相。既云一切菩萨故。但从通释二。一佛子越次合得名所由。穷未来际故云究竟无休。得果不舍因。故云不断菩萨行。由此故得因果交彻展转相生。三一佛子却合前别显用相。深心乐修善行。即前方便净戒亦能息热。相好如华为严。文多影略者。为分能所成故。四一佛子合拣非器。亦先拣后收无为正位。一堕难出故喻深坑。又无悲水取灰断故。如彼地狱。邪见拨无贪爱浸烂。皆喻于水。不容善根又阙土缘。非生处故。后收言无厌舍者。上据现恶阙缘。令生厌怖直进一乘故。除二处而同有佛性。久久当成故不厌舍。是知现恶明无则无恶必有。故涅槃云。一阐提人虽复断善犹有佛性。若能发心非阐提也。法华云决了声闻法。余诸声闻众亦当复如是。结云根善安住者。常住大悲故。有引向所拣证无佛性及定性义。不观次后不舍之言。况第十喻平等共有。减损佛性恐毁谤一乘。愿诸后学当诫慎之莫滞权说。第八劫火烧尽喻。喻佛知无不尽智。由此佛智更无所依。第九劫风持坏喻。喻佛巧令留惑智。非但能断亦复能留。谓佛有斯巧。授与根未熟未具万行菩萨。令留润生之惑。由此留惑惑方至尽得一切智。不同二乘不为菩提心期速出。广明留惑润生。具如别章。第十尘含经卷喻。喻佛性通平等智。文中四。谓法喻合结。今初。所以知佛智遍者。无一众生不有本觉。与一切佛体无殊故。以上言潜流。则似佛智遍他众生。今显众生自有。故云遍耳。此有三意。一明无一众生不有。则知无性者非众生数。谓草木等已过五性之见。二者众生在缠之因。已具出缠之果法。故云有如来智慧。非但有性后方当成。亦非理先智后。是知涅槃对昔方便。且说有性。后学尚谓谈有藏无。况闻等有果智谁当信者。三彼因中之果智。即他佛之果智。以圆教宗自他因果无二体故。不尔。此说众生有果。何名说佛智耶。斯则玄又玄矣。非华严宗无有斯理。次但以下释疑。疑云。涅槃云。佛性者名为智慧。有智慧时则无烦恼。今有佛智那作众生。释中先顺答前义。谓倒故不证岂得言无。如壮士迷于额珠。岂谓肤中无宝。后若离下。反以理成。谓若先无离倒宁有。既离倒则现明本不无。如贫得珠非今授与。是以涅槃恐不修行。故云。言定有者则为执着。恐不信有故云。若言定无则为妄语。乍可执着不可妄语。自然智者。自觉圣智也。无碍智者。始本无二绝二碍也。第二喻中二。先明大经潜尘。以喻上文妄缠佛智。大经卷者。佛智无涯性德圆满也。书各称境者。智如理故。潜一尘者。略有三义。一妄覆真故。二小含大故。三一具多故。一切尘者。无一众生不具佛智故。后时有一人下。出经益物。喻上离妄现前。第三合中亦二。先合大经潜尘。无量无碍普能利益。合上书写多事。众生身及妄想俱合土尘。后尔时如来下。合出经益物。如来合上一人。智眼合上天眼。是知不信众生等有佛智。智眼未开复何可怪。然如来藏等经说有九种喻。喻如来藏。为如青莲华在泥水中。未出泥水人无贵者。又如贫女而怀圣胎。如大价宝垢衣所缠。如摩尼珠落在深厕。如真金像弊衣所覆。如庵罗树华实未成。亦如稻米在糠糩中。如金在矿如像在模。皆是尘中有佛身义。与此大同也。大文第三总结。上来十喻。初总明无依为依。二能出生。三能潜遍。四横具四智。五竖具四能。六体广包含。七用无终竟。八知无不尽。九巧能摄持。十处处具足。前九直语佛智。后一乃融自他。此十圆融略显佛智之相。寄显如来之心未尽佛心一毫。故应更以无量无碍等知也。第二偈颂。二十二偈分二。初两句约法总显。余颂上喻。于中初喻一偈半。后一四偈。余八各二偈。并显可知

大方广佛华严经疏卷第四十九大方广佛华严经疏卷第五十

        唐清凉山大华严寺沙门澄观撰

(已下入第五十二经)第五明出现境界。正显分齐之境。兼辨所缘之境。依初义者。前约智以显心。此正明智用分齐。依后义者。前明能知今辨所缘。由所缘无边故。显分齐难思。分齐难思故方穷所缘之境。二义相成如函盖相称。文中长行分三。谓标释结。释中二。先法后喻。法中亦二。先广取所缘显分齐境。后近取诸心以况佛境。前中又二。先列所缘无边。后显分齐无量。今初。先令以无障碍智为能知者。非此不能量佛境故。后正显所缘文有十句。一通举所化。二化时。三化处。四化法。五所化人。六七八三皆明所证。于中真如语其体。常一味故云无差别。法界生法所依。故云无碍实际。是穷事至实故云无边。九化处分齐。后一遍通。若约二谛境。前五为俗次三为真。九通真俗。事空理空俱是空故。后一双非。显前九境即同无故。若约三谛空即是真三真为中道。若以五界摄之。初三是世界无量。四即调伏及调伏加行界。五即众生次三即法界。余二双非。二佛子如一切下。显分齐无量中。先约十境以显分齐。境智相称故皆无量。后约无境显其非有。乃至真如皆不可得故。是以诸境云兴而常寂也。如无既尔。如真如等无变易等亦然。第二佛子至应知心下。近取诸心以况佛境。于中二。先正明后征释。今初。无量无边语其相用广大。无缚无脱。明其体性深寂。次征意云。何以将心况于佛境。释意云。菩萨自心。随思即显故无分量。佛境亦尔。随机显现。若身若智何有量耶。智假思显则性无缚脱。不为相缚后无脱故。第二佛子如大龙下喻显。文有三喻。前二喻无缚无脱。后一喻无量无边。无量无边通前二段。今初。前明降雨无从喻。正喻无缚脱。既无来处有何缚脱耶。后明海水从心喻。喻无缚脱所因。水从心力为因。非定内外。智从昔愿。缘起故来即无来。第二海水宏深喻。喻无量无边中三。先标章诫听。二佛子此阎浮下喻显。三佛子于汝意下。法合喻中三。初别显水多文有四节。一四洲水。二龙王雨水。三宫殿出水。四娑竭龙王兼雨兼出。皆后后倍前以显深广。二其所出下。通显水相。涌出故潮上速。为宝消故潮下。此为极说。三佛子如是大海下。通显无量兼水有四。第三合中二。先合水无量。佛智一念即无穷尽。况尽三际周乎十方。重重重重安可喻显。二佛子至应知如来下。合通显无量。非唯智为佛境。菩提分等皆分齐境也。智海合水余合宝等。并显可知。大文第三总结。即结云知意。不知佛境。安能利生。第二偈颂。五偈分二。初一颂法说。余颂前喻亦二。初二合颂前二喻。同喻无缚脱。后二颂大海宏深喻。但颂通显无量。余文略无。第六出现之行。前明分齐境智无边。今彰运用则悲智无尽。虽智海已满悲无息故。长行中二。先标举后释相。释相中三。初双标二行。次双释二行。后双结二行。今初。义有多含。一无碍行者。即理之事行。真如行者。即事之理行。前即行相后即行体。又前是即智之悲。后是即悲之智。前即真之俗。后即俗之真融而无碍。为如来行。第二佛子如真如下。双释中二。先释真如行。后释无碍行。今初。真如之名言含法喻。文中有三。初牒名以解。明体绝三际故同真如。契如成行行即如也。过未非缘故不生不动。现在离缘故非起也。二复举法界无形。明双非契中。是知实相等皆如来行。三举鸟飞虚空喻。释非量义。非量有二。一行广无量故。云如来行无边际故。二即事同真便无分量故。以空喻。既无有量何有无量若谓无量即是量故。双非永寂为如来行故。心弥虚行弥旷。终日行而未曾行。故涅槃云。复有一行是如来行。所谓大乘大般涅槃。第二佛子如来应正等下。释无碍行。文中二。先约法总明。后以喻别显。今初。智无所住悲示所行。即悲智无碍自无二碍。令他无碍皆无碍行也。二别以喻显中二喻。初金翅辟海喻。喻即智之悲。后日月无思喻。喻悲不失智。第三佛子至应以如是下。双结二行。性结真如。相结无碍。第二偈颂有五。前三颂真如后。二颂无碍。第七出现菩提圆行之果。故对缘造修必有成正觉。故文中三。谓征起释相总结。征言正觉略显五门。一释名。晋名菩提存其梵语。此翻为觉。正拣二乘成异菩萨。初会已显。又单语菩提。但是所觉之道。今云成者。即理智契合之名。二明体性。摄论云。二智二断为菩提体。智论云。菩提菩提断俱名为菩提。若依此经通一切法。如文具之。三辨种类。或说唯一如智契合无二相故。净名云。夫如者不二不异故。或开为二。大品明有性净菩提及修成故。亦名性净方便净也。或分为三。约三乘故。如十地论或开为四。涅槃云。下智观者。得声闻菩提。乃至上上智观得佛菩提。又四智菩提亦是四义。或分为五。如大品智论说发心等故。或具明十。如离世间品。唯十为圆是此所辨。三除前二。四除前三。五除前四。余皆兼通。同教一乘之所摄故。若业用所现。则无所不收。四明业用文有十门。而体用参显各随别义立目。今统收之。谓缘二谛断二障。证二空起二智。印群机现万像。具十身遍十方。周于毛端微尘等处。通因及果业用无边。具如文显。五者辨相。即当释文略辨十门。一总明体相。二即现万机。三体相甚深。四三轮平等。五因果交彻。六体离亏盈。七相无增减。八用该动寂。九周于法界。十普遍诸心。十门之中亦可当门别释。今且以初为总余九为别。别虽九门而释十义。初释第一。二释第十。谓举初该后。三从第二次第解释。第十一门释八九二义。至文当知。释文显然不应异解。今初。总明具有十门。皆含体相用三。一寂照为菩提体。故云于一切义无所观察。一切义者。真俗境也。观极于无观故。净名云。不观是菩提离诸缘故。如海无心而能顿鉴。非无所了故。晋经云解一切义。二经合明义方圆。妙解即是观观即无观。既观念斯寂无惑习种。无观是体照断为用。合之为相。二等同万法为菩提体。谓智与理冥同一圆觉。故云于法平等。而不失照。决断分明云无疑惑。既无所疑即所知永寂。上二已摄摄论之体。三一成一切成。不见生佛有异故云无二。以知一切众生即菩提相故。亦是能所不二净名云。不二是菩提离意法故。四总指前三体相寂灭。寂灭是菩提灭诸相故。五即心行处灭湛然不迁。亦是不行。是菩提无忆念故。六虽觉而常定不住定故。七有二义。一横遍十方广无量故。二体无生灭绝分量故。八亦二义。一竖念念成无际畔故。二一得永常无后际故。心无初相冥符于理。无前际故。九离边契中。晋经此前有无缚无脱。并含在二边之内。谓若染若净若缚若脱。有无一异等。斯边皆离不偏住着。故曰离边。非见有边边即中故。无中无边方住中道。十总显离言。上九寄言显深。未尽菩提之奥。故收归性离。令亡言契之。第二知一切众生下。印现万机。即海印三昧。文中三。初法。一念知三世名一切智。次喻即举海印以喻菩提无心顿现。三合。言无所现者。有三义。一无心现故如海。二所现空故如像。三无别体故。如水与像不可分异。自体显现故名为觉。起信论云。诸佛如来离于见想无所不遍。心真实故。即是诸法之性自体。显照一切妄法。有大智用斯即无思。显照同体之境为菩提相用。故上文云于一切义无所观察。第三佛子诸佛菩提下。性相甚深。性离言故。理圆言偏故。第四佛子如来应正等下。三轮平等。释上于法平等。等诸法故意轮等故。何所疑哉。文中二。先别举身等。后类结显多。今初。有十三身。前六等事。次三等理。次一等事理。事事无碍。后三等因果。略举十三故结云无量。皆言量者。是所等之分量。皆言等者。即能等之三轮等有二义。一者等彼事理之量。二者等彼事理之体。所以等者。彼诸理事即我所证。能所冥合彼尚即我。等之何难。是以圣人空洞无像物无非我。会万物以成己也。后佛子如所得下。类结可知。第五佛子如来成正觉下。明因果交彻。释上无二同一性故。文中三。初标次皆同下释。三知一切下结。今初。八相之中。略举其二故云乃至。此文正同净名云若弥勒得菩提者。一切众生皆亦应得。一切众生即菩提相。弥勒示迷此旨。但谓理诘之言。不知真得菩提。实如所诘。又前章以我等彼故。遍同彼量。今明以彼等我故全现我中。是知一性平等。反覆相成。此中之成为理为事。若是事成。何以释云同一性故。若是理成。何以此云成正觉耶。入涅槃耶。此是华严大节圆宗之义。不对诸宗难以取解。然诸众生。若于人天位中。观之具足人法二我。小乘唯是五蕴实法。大乘或说但心所现。或说幻有即空。人法俱遣。或说唯如来藏具恒沙性德故。众生即在缠法身。法身众生义一名异。犹据理说。更有说言。相本自尽性本自现。不可说言即佛不即佛等。若依此宗。旧来成竟亦涅槃竟。非约同体此成。即是彼成。若尔何以现有众生非即佛耶。若就众生位看者。尚不见唯心即空。安见圆教中事。如迷东谓西。正执西故若诸情顿破。则法界圆现。无不已成。犹彼人悟西处全东。若尔诸佛何以更化众生。不如是知所以须化。如是化者。是究竟化。如是化者。无不化时。故下结云。大悲相续救度众生。随门不同种种有异。约成佛门一切成也。又此众生乃是像上之模。令其去模则。自见己佛。亦见他成。如第十段。二释中先总释。同一无性故得现成。妄性本虚生元是佛真性叵得非今始成。故皆成也

次转征所无无何等性同菩提性故。后释所无。有十二句。前四通生及佛。次四约众生。后四唯约佛。非独妄空真有。亦非妄有真空。以性融相法界圆现。故由此无说成正觉。又摄十二总为六对。一能相所相对。谓染相净相相待有故。念念之尽缘所尽故。烦恼永尽本自尽故。二生灭对。约凡则本自不生。即涅槃相。不复更灭故。约佛菩提非始生故。何有灭耶。三我非我对有缘无主故。我尚不可得。非我何可得。诸法实相中。无我无非我故。四缘非缘对。揽缘生故。缘尚不可得故。五能所证对。能证菩提因所证故。所证法界由智显故。六合不合对。虚空非合因有显故。所以性无。成觉是合。理智契合即为缘起。故非有也。三结中。物物无性故成种智。证斯同体而起大悲。一得永常故云相续。又只由不知无性。故教化不绝。第六佛子譬如虚空下。明体离亏盈。释上无相虚空无生。故体无增减。菩提无相成不宁殊。第七佛子假使下。明相无增减释上无行。湛然不异行岂能迁。文中三。初举喻问答。以化现无形喻成不莫异。化多心者。喻修多因。化成多佛喻证多果。次普贤下。赞善以合。三佛子下。结此生后。第八如来成正觉时下。用该动寂释上无止。不滞定故。文中四。初举所依三昧。觉不滞寂故名善觉。觉彼一相故用为方便。二入已下。显一身之用。既以一相为方便则物皆一相故。一则现多。三如一下。类显余身。如来成正觉时。布身云于法界。一一皆是广大之身。并如一身之现。四佛子下。总结多门。谓上来所现一定为门余定亦尔。定门既然。悲智总持等门亦尔。故有无量界矣。是谓高而无上广不可极。第九佛子至应知如来下。明周于法界。释上无量无量有二。一广多无量。一毛含多遍法界故。二无分量皆不生故。文中三。初明一毛含多。释以不生故。此与前段分。有分异。又此唯现佛。即同类相望。前通多类即异类相入。又前则住体遍应。此则如理而含。亦如理而遍。二如一毛下。类显多毛。但容毛处即是毛孔。次征意云。身契无生。可许能含法界。虚空无有能契。何能亦含。释云。无处不至则无非佛身矣。是谓大包天地。细入无间。三随其下释疑。疑云。若尔何以要就觉树。释云。随机所能受耳。是知坐菩提树多身顿成。尚曰随宜。有顶鹿园岂为真极。第十佛子至应知自心下。明普遍诸心释前二门。即分为二。初正明普遍。释上无际。念念常成无际畔故。后广大下。总结双非。释上远离二边住于中道。今初亦二。先指一心。后如自心下。例一切心。前中先标。次征后释。释云不离者。有二义。一众生身心即佛所证故。二全即佛菩提性故。此即他果在我之因。非约因人自有佛性。此文正显佛菩提故。后总结双非。不离不断释有二意。一不离。结上无处不有。不断生下无有休息。二不离者。生佛非异故。不断者。生佛非一。不同众生可断坏故。是名入不思议方便法门。是以不得意者。作众生思故是不可。设作佛思。是亦不可。即亦不可。非即亦不可。当净智眼无取诸情。第三总结。即最后佛子。今依此知映前十门。无幽不尽。离此何有真菩提耶。后偈有六颂前十门。初二次第颂初二门。次三如次颂六七八。后一通颂四五九十。以同是普现无量义故。其第三门。但显离言故略不颂。第八明出现转法轮。得大菩提理必转授。长行中三。初标征次释相。后总结。就释相中二。先显体用。后显所因。今初分三。初法次喻后结劝。今初。文有九句。减数十也。皆先标后释。前五显体性寂寥。后四辨相用深广。前中一能转心。二所转体。三所得果。四能诠教。五所显理。夫转法轮不过此五。今皆即事契真。一能转心者。由知法无起故。正转法时不起心念。言我转授前人名心自在。如是方为真能转也。二所转体者。即示劝证名为三转。此三名轮者。摧障恼故。言离边者。若有惑可摧未离于常。无惑可摧宁免于断。今永离断常等边。方为真能断所应断。知与证修亦然。三所得果者。由断惑故得离欲际。由证性空本无可离。斯际亦遣。四能诠教者。理假言诠。今了本寂灭不可说故。则终日言而未曾言也。五所显理。谓即寂灭。今了性净涅槃。法本不然今则无灭。方为究竟之灭。是知。其轮本来常清净也。后四相用深广中。一触言皆轮广也。二即用而寂深也。下二亦深亦广。三一即多而无主。四即横竖而恒虚。谓横则无遗。无所不转故。竖则无尽穷未来故。而不着内外。则深广无涯矣。第二佛子譬如下。喻中文有二喻。一文字无尽喻。喻第九无尽。二遍入无住喻。喻六七八用而常寂故。于中有法喻合。合中二。先合普入一切。以上法中。但云入一切言故。今明入余法则触类皆法轮。岂同三乘但用佛声为轮等耶。二一切众生种种下。正合前文入一切语。前五易故略不喻之。第三佛子下。结劝可知。第二复次下。显法轮所因。于中三。先辨轮所起因。因机差故。若离物机佛无说故。次佛子如来下。明因所起轮。物既为力不同。教须适宜差别。于中说法所依之定名者。无碍辩才无所怯畏。得究竟者唯佛有故。后能如是知下。结其得失。及第三总结文并可知。偈有五颂分二。初二偈颂法轮体用。后三偈颂法轮所因。第九出现涅槃。转化既周安住秘藏。为物示灭故次明之。然大涅槃盖众圣归宗冥会之所。寂寥无为而广大悉备。形名绝眹识智难思。今以无名强名亦为五别。一释名。涅槃正名为灭。取其义类乃有多方。总以义翻称为圆寂。以义充法界德备尘沙曰圆。体穷真性妙绝相累为寂。而言大者。横无不包竖无初际。此约三德涅槃。若约义开略明三义。一者体大。自性清净故。二者相大。方便修净累亡德备故。三者用大。化用无尽故。般者入义。性入真入示现入故。若圆融无碍即大涅槃。二出体性。涅槃既妙绝常数。恬怕希夷。虽迥出百非。而靡所不在。今以义求不出三法。即摩诃般若解脱法身以为其体。所以三者。翻三杂染故。成智恩断故。成法门法性应化身故。能证大智冥所证理累永寂故。然此三种。不离一如德用分异。即寂之照为般若。即照之寂为解脱。寂照之体为法身。如一明净圆珠。明即般若净即解脱。圆体法身。约用不同体不相离故。此三法不纵不横不并不别。如天之目如世之伊。名秘密藏为大涅槃。三显种类。虽理无不统义类尘沙。今自陜之宽略分一两。或唯说一即大涅槃。或说有二。自有三门。一余无余。二性净方便净。三真与应。或分为三。此有二种。一约三乘。二即自性真应。或分为四。一自性清净涅槃。二有余依。三无余依。四无住处。有余无余义通大小。今唯说大。于三种内不明二乘。余皆具论融而无碍。为大涅槃。如文具之非独应灭。四彰业用。囊括终古导达群方。靡不度生靡不成就。故涅槃云。能建大事则出现法门。皆斯用也。然诸门广义备于别章。略在文具。第五释文中二。先征起后正显。正显中十。一体性真常。二德用圆备。三出没常湛。四亏盈不迁。五示灭妙存六随缘起尽。七存亡互现。八大用无涯。九体离二边。十结归无住。然斯十段。随义虽殊皆含体用。互相交彻显大涅槃。今初分三。初举法劝知。二如真如下。指理同事。三何以下。释显同相。今初。根本自性者。即下所列真如等十。为真应涅槃之根本故。体即自性清净涅槃。以出二碍名方便净。为真涅槃。大悲应物亦自此流故名为本。以是本故。但了真如即了涅槃。二指理同事中。皆云如者如即同义。能同涅槃通真及应。所同如等。即自性涅槃故。上句皆有涅槃之称。应真无本应非不生。何出现之为妙。故以本该末以体显用令皆圆寂为大涅槃。所以列十名者。欲明究竟妙道。穷理尽性无不同故。德无尽故。十名已如前释。于中后二加际言者。穷真于无真。为真如际等故。三释显同相者。向言亦如是者。云何如耶。故云如真如等不生灭故。何以不生。以但了因所显非生因所生故。既无有生亦非出障。始既无生则永常不灭。是知玄道存于妙悟。妙悟在于即真。即真则生灭齐观。齐观则彼此莫二所以真如与我同根。法性与我一体。真既不灭应灭宁真。是知涅槃名灭者。乃在于无灭者矣。第二佛子如来不为下。明德用圆备者。如来之身色相圆备。常现大机前故。文中先标举。后征释。标中约人显实。云不为菩萨。明说永灭是为二乘。迹尽双树并为凡小。据此亦名拣异灰断。后征释中文有二重。初释之中自有二义。一令称实见受用身。即同法身常住其前。涅槃云。涅槃不空者。谓有善色常乐我净故。因灭无常获此常故。二于一念下。令见三际应用。亦即是常。故云皆如现在。涅槃云。吾今此身即是常身。法身下。开栴檀座佛塔。见三世佛无涅槃者。楞伽亦云。无有佛涅槃。无有涅槃佛。亦不起二不二想者。远离觉所觉故。谓既知幽灵不竭妙色湛然。三际大均。何生灭之动静。故不起二也。亦不取此一常。故无不二也。下重征释。征意云。菩萨何以能不起想。释云。菩萨由了法空本无想着故。既无心于动静。终不谓佛常与非常。第三佛子诸佛如来下。出没常湛。谓涅槃无为而无所不为。无不为故能建大事。不碍出没。以无为故住净法界。体常湛然不碍出没故。显迹为生即是有余。息迹为灭即是无余。故余无余乃应物之假号耳。体性常湛。故存不为有亡不为无。是知寂然不动未尝无为。应迹无方未尝有为。岂可随于见闻。以滞殊应之迹。第四佛子譬如日出下。亏盈不迁。先喻后合。然法身无像故。无器而不形。圣智无心故。无感而不应。像非我有。自彼器之亏盈。心非我生岂普现之前后。故摄论第十颂云。众生罪不见如月于破器。遍满诸世间。由法光如日。是以经言非日咎也。持戒器破定水无依。菩提器破智水宁止。无信清珠故。心水浑浊何由见佛耶。然此中虽明现身。即是三德涅槃所流大用。亦涅槃摄。若尔宁殊出现之身。出现身以法身为门而论真应。非无般若解脱二德。智慧日身无不照。故永离戏论。即解脱故。医王之喻即示灭故。此有般若宁异菩提。若分相说。菩提为能证智。唯是修生。涅槃是所证理。唯约修显故。涅槃中说菩提。必从生因所生。涅槃必从了因所显。若摄相说。菩提是即理之智。涅槃是即智之理。即智之理。不碍摩诃般若。即理之智不碍寂灭菩提智性本有。亦是性净涅槃。修显亦方便净。随一为门则皆放尽即大涅槃真菩提也。今以涅槃收之。非唯菩提及身。前后诸门皆从三德所流。能建大事。第五佛子若有众生下。示灭妙存。既为物示灭即体无灭。第六佛子譬如火大下。随缘起尽有喻合结。合中以机喻薪。以涅槃喻火。众生善根未熟。可熟者成正觉。以熟之如为火事。若所应度者皆已度竟。则现般涅槃。寂无所为如火息灭。故法华云佛此夜灭度如薪尽火灭。然现灭现生。皆是涅槃大用。故摄论第十名涅槃如火。既起灭在缘。则益不可盈。损不可亏云云。自彼非佛然也。第七复次佛子譬如幻师下。存亡亘现由顺机故。此灭彼存。非如来身不能长久。前喻约见灭见成。此喻约常见不见。第八复次下。大用无涯。谓正宗涅槃。而便分身无边。穷于来际不动三昧者。究竟寂灭也。由寂无动故。无所不动耳。涅槃受纯陀供处大同于此。而佛数少顺机不同故。第九佛子如来身者下。体离二边。身若是实有不可灭。身若是虚何能起灭。若有方所此现彼无。由非实故起灭无恒。由非虚故能无不现。无方所故感处即形。本愿力故化周法界。随堪度故见则不同。第十佛子如来住于下。结归无住。上来九门。初门多显其体。余八皆体用双明。今此分二。初至实际。通结九门之体。后为诸众生下。通结八门之用。随时示现正显于用。本愿力故显用所因。无有休息皆穷来际。不舍已下。明用分齐。谁独非涅槃而欲舍之耶。是则初住实际故不住生死。后不舍众生故不住涅槃。由双住故能俱不住。前即大智后即大悲。大悲般若常所辅翼。为无住涅槃。自性涅槃众生等有。二乘无学容有前三。唯佛世尊独言具四。故就无住总以结之。即安住涅槃建大事也。偈文有六。初偈颂第四次偈颂第六。次偈颂第七。次二偈颂第八。后偈颂第十。初句无生之生。次句无灭之灭。次句结归涅槃无名。后句结其大用无尽。此二无碍是无住义。余不颂者。含在此中。第十明出现见闻亲近所生善根。前九门出现一期始终。今明于上见闻功深益远奖物进修。文中三。初征起次正显。后结示。就正显中分二。先明见闻信向益。后见闻不信益。前中先法后喻。法中先总后别。今初。见等如后喻合中。后出生下。别即示不虚之相。有十一句不出智断恩德思之。第二喻中三喻。喻其三德。初少服金刚喻。喻于智德。智慧破惑如金刚故。以有智慧者。必无烦恼故不共住。第二少火烧多喻。喻断德。性究竟者。了惑本寂故。第三药王遍益喻。喻恩德。种种利生故。文中先喻后合。合中二。先明为六根境界益。合上药王遍益。六根皆通在世灭后。灭后亦有见故。况忆念等。宝性论中。亦明如来与菩萨。为六根境界。大同于此。后若有众生供养如来所经土地下。明遗迹之益。合上取彼地土。所经土地犹通现灭。其塔庙者。唯约灭后。亦同法华乃至举一手等。皆已成佛道。第二佛子我今告下。明不信益者。此明益深。如来秘密藏经明。骂药服之得力。骂沈烧已还香。骂佛犹胜敬诸外道。若尔岂无骂罪骂罪非无。今语远益故。法华云。跋陀婆罗等。骂常不轻千劫于阿毗地狱受大苦恼毕。是罪已。还遇常不轻菩萨教化。涅槃喻以毒涂之鼓。欲闻不闻无不死者。故菩萨之名。起自闻谤之日。谤尚远益况深信耶。况解行耶。况证悟耶。弘持之者。勉思此文。第三佛子至应如是下。结示可知。第二佛子如来下。总以结酬拣喻异法。上来性起请说因喻。普贤依请明十出现。皆借象取譬。意显佛旨深玄。深玄之旨尚不可以智知。岂言象之能及。故令外亡言象内绝思求。则庶几于出现之旨。大文第五佛子此法门下。显名受持分。于中分二。先长行后偈颂。今初。准晋经。此前有诸菩萨。发二种问。谓何名此经。云何奉持。今但有答。即分为二。先显名后佛子此法门下。明受持令知总名。寻名求旨识受持法。依之修持故。今初。有十名分为五对。一内深外绝对。谓内证三德秘密藏故。外则凡小不能测故。二证寂开智对。三现果成因对。谓性净万德即是佛种。今十门出现即是现义。四越世顺佛对。世尚不知安能破坏。此十通是佛分齐境。五净机演实对。知生佛同源则能净故。随缘不变之性诸佛本故。而性相无碍因果圆融为不思议。过此更无为究竟法。前九别义后一总该。第二明受持中二。先辨定法器后是故菩萨下。举益劝修。今初。有法喻合。法中二。先标器非器。非器不为。所谓权小乘可思议乘。历次修故名余众生。是器则为所谓圆机。不拣凡圣趣向大乘。拣于小乘。不思议乘拣于权乘。一运一切运。十信满心即摄诸位。圆融无碍名不思议乘。后此法门下。明受非受。释上为不为。有圆信手能受众行故。上为之。权小于斯不尽能受。是故不为。法集经云。是经虽行阎浮提。于能信深法者常住如是。众生心手中行亦有以信解行证皆有手义。以后后破前前亦是一理。第二喻可知。第三合中以经合七宝者。若无此法非真佛故。生如来家。合第一夫人所生太子。如来相者。初心顿行佛行故。散灭有二义。一不能信受则教不行故。二不能修行则行不行故。般若论云。法欲灭时者。修行灭故。下释散灭所由可知。第二举益劝修中三。初略标释。二佛子设有下。广释所由。三佛子至成就如是功德下。总结成益。就广释中二。先反显后顺释。今初。若不依此教。纵多劫修行尚非真实。况能疾得菩提。此中设有之言。似当假设。望慈氏赞善财言。余诸菩萨于百千万亿那由他劫。乃能满足菩萨愿行。今善财一生则能净佛刹等。斯则举权显实非假设也。若实有此不信人者。为在何位。文无定判义当三贤。以入证圣必信圆故。若约教道三祇亦未入玄。所以凡夫顿能信者。宿因闻熏为种别故。今更不信当来岂闻。第二若得闻下。顺释中二。先明闻信生家益。后佛子至闻此法已则能下。信闻成行益。今初。先明闻信。后当知下成益。生如来家为总余句为别。别中一以如境为家。无性论云。生如来家者。谓佛法界于此证会故。名为生家。二以行法为家具家法故。三以俗境为家。世亲释云。由此能令诸佛种性不断绝故。四远离非家。五以佛行为家。十住毗婆沙第一云。今此菩萨行如来道相续不断故。广如彼释。六菩萨法性为家亦是佛种性故。亦同如来一如境故。七净当佛家。八住本佛家。九总明因果事理无碍家。前六自分家。后三胜进家。前来初住见心性故。故名生家。四地寄出世故。生道品家。八地无功用故。生无生法忍家。今此通三。兼显凡夫解心亦名生家。因果无碍故。第二信闻成行益。十句分为五对无碍。一即观不碍于止。二见佛不碍入法。三智行法界不碍起福。四智不染世不碍悲入。五体绝三世不碍用而回向。不入而入释上入义。不于已下。复释不入而入。智体即如。如外无法而可攀缘故。无可入心行处灭。寂然无入不失照用故。恒以一如而观诸法故名而入。此二无碍方为真入。又一即是如。便于一中已见一切。第三总结可知。第二偈颂即属第十见闻之益。不颂显名受持。显名受持后文自颂。此颂应在拣法异喻之前。以前长行钩锁显名。亦是见闻益故。若回此偈于现瑞后。与后偈相续。文理甚顺。四偈分二。初一颂法说。后三如次颂前三喻。大文第六现瑞证成。于中二。先现瑞后证成。今初先此界。后类通。动刹等数皆广多者。法难思故。二是时十方下证成中二。先果人证。后因人证。所以具二者法玄妙故。因果交彻之法故。因圆果满之法故。前来诸会唯菩萨者。唯因行故。发心品中唯果证者。果之本故初心成佛难信受故。随义各别。所以互无唯斯具二。今初分四。一现身。二而作下赞说。三佛子我等下引说证成。兼明结通所说。一说一切说故。四今此会下举益证成。于中四一得因位果满益。一生得菩提故。神通三昧即十通十定故。二佛刹微尘下得发心益。与远记者不期速成故。又前明一生即多之一。此辨多劫即一之多。既一多圆融何定劫数。妄生多劫智日不迁。苟执短长未期成佛。同号佛殊胜境者。缘佛出现境故。三我等下护持久远益。四如此下结益广遍。第二尔时十方下因人证。于中四。一明集因。前果人证承前现瑞之因。故略不叙。今此显因果别故。广出集因文显可知。二十方各过下明现身。虽来自十方而周遍法界。则来即无来矣。三示现菩萨下辨其德用。十句文显。四以佛神力下发言诚证皆同普者普法同故。界佛名异者。不失主伴故。普光明者。常寂光土无不遍故。佛名普幢自在者。本智高出无所不摧。事理无碍故。兼亦结通所说。大文第七尔时普贤下。以偈总摄。文中二。先叙意后正颂。前中二。先说仪。后欲重下辨意。欲重显前十门出现故。文有十句。句各一门。而约利生为次不等。一成正觉。二即法轮。三是见闻生善。此三正显益故。四即出现之法。是前总门。五即是心约智显故。六即圆音。七即境界。境界无量生光亦多。八即涅槃动寂自在。大般涅槃为佛庄严故。九即是身约本说一故。十即是行果中说因故。后正颂中四颂。初一颂说分中结酬。以此总包十段意故。后三颂显名受持。初句显名。余皆劝持。且分为三。初偈叹深难闻。次一偈明文由多善。后偈举胜劝持。然此一品文旨宏奥。能顿能圆。究众生之本源。罄诸佛之渊海。根本法轮之内更处其心生在金轮种中。复为嫡子。妙中之妙玄中之玄。并居凡类之心。少功而能速证。安得自欺不受。长沦生死之中。今闻解能欣尤须自庆昔善。出现品竟

大方广佛华严经疏卷第五十大方广佛华严经疏卷第五十一

        唐清凉山大华严寺沙门澄观撰

    离世间品第三十八(已上入第五十三经)

初明来意。来意有三一分来。前明修因契果生解分。则于法起解。今明托法进修成行分。则依解起行义次第故。二会来者。前会因圆果满生解之终。此会正行处世无染。通于始终故次来也。三品来者。前品出现之果殊胜。今明依彼起行圆融。故次来也虽一分一会一品是同。所对既殊。来意亦别。第二释名。亦有三别。一分名者。没彼位名但彰行法。欲显行位无碍。前后圆融。故以名也。二会名者。约法不异分名。约处名三会普光明殿之会。第七重会会终归始故。虽越四天同为生解之会。今复重会通对彼分始终。依解成行故会普光。而前分生解差别故。寄历处以显浅深。今分起行圆融故。一会并收因果。亦表成行。不离普光明智故。此中不隔余处。何有重会之义若约次第。前时后时即是重义。若约圆融。就义名重故。不动前二而升四天。二七相望亦何所隔。明知。约义亦犹灯光涉入无碍。亦似灯炷重发重明。约人名普慧普贤问答之会。三品名有二。一得名。二释名今初又二。一异名。下文十义至彼当辨。有别行本名度世经。度即离义。又有别行。名普贤菩萨答难二千经。此就能离人法受称。二正辨本称。总由超绝世染。故受其名。别有三义。一约法。二约行。三约位。约法之中先世后离世。有三类。一约事相有二世间谓器及有情。此约依正分之。二约粗细亦二。一有为世间。二无为世间。此约分段变易分之。以变易非三有摄。名之无为。故胜鬘云。有为生死无为生死。然粗细虽殊体不出二。三约染净有三。于初二中。加智正觉示同世间。不同世故。如地论辨。二明离者。离有二义。一性离。世间性空即是出世间故。二明事离行成无染故。力林颂云。三世五蕴法说名为世间。彼灭非世间。如是但假名。灭通二义。于事离中。有似离真离分离全离。次下当辨。二约行者略为四句。一随二离三俱四泯。言随者。凡夫沉溺世蕴非离非随。二乘无悲不能随世。虽离非真。菩萨能随方为真离。故以随释离。二离者。有大智故了世性离。处而不染亦异凡小。三俱者。悲故常行世间智故不染世法。既以世与性离无二。为其境故。以悲智无二为其行。境行融通有其三句。一悲无不智则世无不离。是以常在世间。未曾不出。二智无不悲故。离无不世。是以恒越世表无不游世。三双融故动静无二。唯是一念所谓无念。无念等故世与出世无有障碍。四俱泯者。谓境既世与性离形夺两亡。故令悲智俱融二念双绝。又由境行相由形夺齐离。则绝待离言。融前四句皆无障碍。方为真离世间也。三约位者。凡夫染而非离。二乘分离非真。谓果离分段因唯事离。非今所明。菩萨具上真行可得名离。而非究竟。唯佛为离故。经云。佛常在世间而不染世法。然今文中。备六位之行即是行离。行所依位即是位离。故若事若理若因若果。皆名离也。二释名者。约法事离无他受称。离非世间即相违释。若约性离。通持业释。约行四句。前三句俱通持业相违二。事理离故。泯句并非六释。亦可持业泯即离故。第三宗趣。顿彰六位理事二离为宗。令体性离顿成真离究竟为趣。第四释文。长科十分。一序分。二三昧分。三发起分。四起分。五请分。六说分。七结劝分。八现瑞分。九证成分。十重颂分。今初有三。一器世间圆满义如前释。二妙悟下智正觉世间圆满。与三不可说下众生世间圆满。二中明佛二十一种殊胜功德。广引诸论已见升兜率品。今但略明。初句为总具下二十一种功德。故云妙悟皆满。后二行下别。于中前四自利余皆利他。前中一智德。二断德。三恩德。四作用平等德。今初二行永绝即于所知一向无障转功德。佛地经名不二现行。不字此宜言无。即永绝义。谓佛智德离所知障。非如声闻极远时处等有不知。故有知不知即是二行。今无不知故云永绝。二达无相法。则于有无无二相。真如最胜清净能入功德。彼经名趣无相法。趣谓趣入即此达义。然无相法体即真如。无彼有无二相故名无相。诸法中最净无客尘。令自他入胜于二乘。名最胜清净。三住于佛住者。即无功用佛事不休息功德。世亲释云。谓住佛所住无所住处。此即释经于此住中常作佛事无有休息。此即解论。四得佛平等即于法身中。所依意乐作事无差别功德。谓诸佛有三事无差。一所依智同。二益生意乐同。三报化作业同。故云平等。五到无障处。则修一切障对治功德。世亲释云。谓一切时常修觉慧对治一切障。故此明觉慧为能治。一切障即二障为所治。六不可转法。即降伏一切外道功德。谓教证二道他不能动故。七所行无碍。即生在世间不为世法所碍功德。谓利衰等。八法不能拘故。八立不思议。即安立正法功德。谓安立十二分教。余不能思故。九普见三世即授记功德。谓记别过未皆如现在故。十身恒充满一切国土。即一切世界示现受用变化身功德。谓二种身遍二种国。故十一智恒明达一切诸法。即断疑功德。谓自于一切境善决定。故能决他疑。十二了一切行。即令入种种行功德。二释摄论易故不解。意云遍了一切有情性行。随根令入故。十三尽一切疑。即当来法生妙智功德。谓声闻言其全无善根。如来知其久远微善。后当生故。十四无能测身。即如其胜解示现功德。谓随诸有情种种胜解。现金色等身。虽现此身而无分别。如末尼等故无能测。十五一切菩萨等所求智。即无量所依调伏有情加行功德。谓由无量菩萨所依为欲调伏诸有情故。发起加行。佛增上力闻法为先获得妙智。异类菩萨摄受付嘱。展转传来相续无间而转。由此证得一切菩萨等所求智。意云。佛智为一切菩萨等所求故。十六到佛无二究竟彼岸。即平等法身波罗蜜多成满功德。平等即无二义。无二法身为波罗蜜多所依。十七具足如来平等解脱。即随其胜解。示现差别佛土功德。此中解脱即是胜解。随物胜解所宜。如来胜解能现金银等土。佛佛皆然故云平等。十八证无中边佛平等地。即三种佛身方处无分限功德。世亲云。谓佛法身不可分限尔所方处受用变化。亦不可说尔所世界。十九尽于法界即穷生死际。常现利乐一切有情功德。二十等虚空界即无尽功德。谓佛实智如空无尽故。今经缺最后穷未来际。总别合有二十一句义如前说。然佛地摄论约受用身。此约十身。所以知者。处摩竭提国是变化土。而叹受用功德。明知二身二国本相融故。不要地前地上。则五位通见故。第三众生世间圆满中二。先举数叹德。后其名下列名叹德。前则多人具德。后则胜人具德。前中二先举数拣定。二悉具菩萨下叹具胜德分三。初总标。二所谓下别显。后成就下总结。别中十九句皆不出方便智慧。分二。前十叹自分德。后于一念下九句胜进德。今初前八皆有智慧方便。依体起用故。前五以善能为句首。六知空不坏业果。七知根器别明识病。八持法化之后二明有方便慧。皆即事归实。后胜进中。初句总明速成果智。余皆果智之用。及后总结文并可知。第二列名叹德中二。初列名结数。二皆悉下叹德。文有十句。初总余别。别中一契理愿圆普眼满故。二摄法上首为普化故。三受持正法有普慧故。四不断佛种普见有性故。五知佛化仪光普彻故。六示现成佛观见无故。七净染机照其源故。八摧他障有智幢故。九证法界觉法性故。上之九句别明。则初句为愿余八为行。通说则皆普贤愿。宿誓今满故。如十大愿。并普贤行现缘所作故。故总句云成就行愿。又此十句十人通具。文云皆悉成故。亦句显一人之德当释名故。故总句为普贤。余九如次前已配释。大文第二尔时普贤。下三昧分。普贤入者是会主故。说普行故。佛华严者。万行披敷严法身故。即以法界行门心海为体。持无限故。说法成行发起为用。依此能故。大文第三入此三昧时下明发起分。先明地动警群机故。后显出声令闻法故。前皆有加而无发起。此有发起而无加分者。前表解可从他故。有他加此表行由已立故。自力发起。又表行依解起无别法故不加。摄解成行亦须入定。圣旨多端不可一准。大文第四然后从下。起分三义如前。大文第五尔时普慧下请分分三。初总标问意。二佛子下正显问端。三善哉佛子下结请愿说。今初当机众集说法时至此为问意。何以前来诸会先问后定。今乃翻此此有二意。一说仪无定。前表重法感而后应。此明悲深观机欲说。众既已集故先入定令知说主。二约所表则前明从相入实。以成正解。此中依体起用以成正行。故不同也。普慧问者。称法界慧能发行故。一人问者行独已成非如解故。第二正显问端中有二百句。其别行。度世经别作六番问答。番番之中皆先问次答。后动地现瑞。显益证成。古来诸德皆依彼文用科此经以为六段。初二十句问十信行。二从发普贤心下二十句。问十住行。三从力持下三十句问十行之行。四从如宝住下二十九句。问十回向行。五从身业下五十句。问十地行。六从观察下五十一句。问因圆果满行。其第四段中。句虽三十以无碍用一句是总标虚句故。此有五十一句。此经总三遍说六位。此当第二约行说也。以普贤行该六位故。故度世经初请云。唯愿解说诸菩萨行。从始至终令无疑故。彼经虽不配于信等。既云从始至终。末后复明成佛。则知决是六位之行。此经所以不问答相间者。意取位中之行不取位故。如下圆融。若克定约位。何殊差别因果。此经上下及本业经等。判于六位。皆以信未入位十住为首。谓三贤十圣等妙觉故。今何以不开等觉而取信耶。此有深意。彼及此前意在于位。取位成说。今此意明于行。故十信之行正居行始。等觉之位有其三义。或摄属前十地胜进。或摄属后即名佛故。或别开位无垢地故。今为说行摄属因圆之中故。五十一句唯后四句属妙觉位。余皆等觉。若尔此中依言依菩提心等。岂非发心住耶。此难尤非。第二段初发普贤心岂非发心住耶。十信之初岂无发心耶。故贤首云。菩萨发意求菩提。非是无因无有缘。等正是发心所依。不究斯旨空张援据。大文第六尔时普贤菩萨告下。说分中二。先总告。二佛子下正答。答前门二百问。问一答十以显无尽。成其二千。普贤胜行故。英公云。云兴二百问瓶泻二千酬。释此二千略为五门。一约因果。二分行位。三显普别。四明统收。五辨行相。前问例此。今初有四。一约大位前五为因。后一为果。或后四门为果余皆是因。二约细辨。一一皆彻佛果故诸文末皆结得佛。是则二千并通因果。三或总属因普贤位行示成佛故。四或皆属果。下文多云虽得成佛不断菩萨行故。二分行位者亦有四义。一束行成位分。成六分故。二总属位收。以行并是位中行故。三总属行。普贤行体不依位故。四一行遍六位。位位通修故。如此无碍方为普贤行。然文正显后二以揽行成位位虚行实故。故问答并举。不分六番意在此也。三普别者。谓一行相必遍一切。然恒不杂。不杂故别义殊分。必遍故普义该摄。犹如锦文众色成文。常普常别缕缕交彻非如绣。成行法亦尔。即普是别即别成普皆无障碍。若尔此则普别具足。何以独名普贤行耶。非谓守普而不能别。亦非作别而失于普。实谓能别而不坏普。故名普贤行也。又普必有别但语一别。未必有普。如一缕非锦非是锦中缕故。四统收摄者。复有四重。一以位收位。六位各各收一切位故。一位即具二千。为万二千行也。上云一地之中具足一切诸地功德。二以门收门即二百门。一一各收一切门。即成二百。二百为四万行。三以行收行一行具一切行。则有二千个。二千行成四兆行。四以略摄广。此二千行下颂结云。如大地一尘。以此一尘之略说不离十方之广地。是故摄广亦无不尽。此乃等无极之法界。越无际之虚空。下颂云。虚空可度量菩萨德无尽。斯之谓矣。五辨行相。即随文释。释寄相别即分六段。今初二百句。答前信行二十句问。文分三别。初九门明自分行满。二入诸菩萨下八门胜进行圆。三差别智下三门。明二行究竟。今初一门一类即为九段。首明依者。起行所依故。谓依托菩提心等成万行故。贤首品云。菩萨发意求菩提。非是无因无有缘等。然二百门多分五别。一总标二征数。三列释四结数。五显修胜益。或缺后二。或缺第五至文当知。今此依中文具有五。初二可知。就列释中十句各先标名。后释义。一依菩提心者。十皆名依。已为众行之首。而菩提心复是十中之初。以是万行之本故。贯二千之首。释云不忘失者。忘失菩提心修诸善根。则是魔业故。依斯不忘能成万行。此句为总。二上虽内有胜心。若外不依善友。行亦无成故。大圣谓善财言。求善知识是无上菩提最初因缘。释云如一者。若不心行符契岂为我友。三若不增修善根遇友何益。四随所修善须到彼岸。五非独十度触境皆通。上四自利。六愿七行并通自他。上皆依法后三依人。八胜侣智同。九十唯佛究竟为所依处故。净心供养以成福德。长禀慈训以成智严。又前五自分后五胜进。六广菩提心。七广二四五。后三广第二四结可知。五显修胜益者。由依上十成佛大智。为一切所依斯为胜益。岂得不修故亦名劝修。第二奇特想者。前依因缘以成诸行。今依胜想以摄善根。翻妄想源次所依故。并出常想受奇特名。即上文中常欲利乐诸众生等利益之想也。十中一以他善同己者。随喜于他情无彼此故。互为主伴相资益故。同体性故。即我所行故。自他相即故。四六愿行亦然。二一毫微善皆是佛因故。法华中举手低头皆已成佛。三下至阐提皆有佛性故。五思益云。知离名为法故。七诸性相法佛所证故。文殊云。我不见一法非佛法者。皆不可得故。诸轨仪法皆佛所流。涅槃云。外道之法。亦如来正法之余故。八因言契理。而理非言故名言道。九佛以觉他圆满故为慈父。十如来即诸法如义故无有二。益中无想之想名善巧想。第三十种行。依胜想之解造修大行。想唯在心行通三业。空想不行亦无成办。即上文中修学处也。释中唯九者。准晋本此脱第三善学一切戒。具十为五对。一下化上求。二止恶进善。三妙止深观。四修因严刹。五敬友事师。第四善知识者。行起必依善友故。次明之。未知善令知。未识恶令识故。凡所顺益皆我善友故。十皆益也。上云。即得亲近善知识。是第五精进者。行友既具必须策勤。于此十事离身心相。而进修不杂故。上云勤修佛功德。第六心得安隐。进成二利故获心安。自利故智心安。利他故悲心安。即上文增上最胜心。十中初一行本。次二离过。一无诤三昧离一切诤。二越凡小。凡谓凡夫愚即愚法小乘。次二进善次三证入。一入位二入法。三入益。谓谤有二义。一粗言。此非佛说等其过弥大。二细谓说不契实其过则微。若无细谤证实方能。后二因圆果满。得益中究竟安隐。谓菩提涅槃。第七成就众生者。上通明二利心安。今别明利物成就故。上云则能慈愍度众生。然有二义。一以此十通用成就一切众生。二各成一类众生。谓一成就悭贪贫穷众生。二成恃形色憍慢众生。三疑法。四佷戾。五贪爱。六乐二乘。七不乐严刹。八不欣佛果。九邪归依。十邪智狡猾。以经中十法如次成就。第八戒者。欲成就众生须自止恶行善。十中若忘菩提心。乃至诸根犯境皆名破菩萨戒。故上云坚固大悲心则不破也。此十三聚如应思之。第九受记法者。既离过德成。自验已行必招当果故。自知受记故。上云若得无生深法忍。则为诸佛所授记。即此中一义。一见理深悲即发心。殊胜得果无疑。若因他厌苦则非殊胜。未定得记。二无厌修。三长时修。四无余修。五契理修。余五可知。于此十中随有其一。即自知得记此辨得记之行。非显受记相殊。如瑜伽等。又此约十信横具。余约竖位不同。上来自分行竟。第二八门明胜进行中。既自分行成故。胜进入诸所入之处等。即为八段。今初入菩萨。入有二义。一证得义。二观达义。入因则通证。通达入果唯达未证。此下五门皆是智入。四五二入亦通身入。今此即是入因。所以入者。即彼所修是我所修。互相资益为同行故。故度世经名不相求短。即上文中神通深密用等十句可知。第二入诸如来是入果。所以入者必当证入故。上云则以佛德自庄严。第三入众生行。前二入能化。此明入所化心行等。上云悉能调伏诸众生等。问中脱于行字。行有多种如文可知。十时非时。谓熟未熟等。不知时者非大法师。第四入世界。对佛是依报。对生是化处。上云普随诸趣而现身。结云普入者。不离此十故一时顿入。非前后故。第五入劫者。即是化时。此下三门皆是成上一念悉知无有余也。十中前五直入。后五约相即入。此相即入有二意。一彼劫相即智入彼故。二由彼劫相摄相入故。但入能摄即入彼所摄等。余如前发心品。第六说三世者。前劫此世长短有异通皆时分。并是十世隔法异成。十中前九别。后一总。别中三世各三故成九世。未来是续起法故。未来未来名为无尽。过去已起故。过去过去不名无尽。现在现在即事可见。例过未之现在故云平等。过未之现在非可见故。但对前后立现在名。然此三世何以成九。古人释云。义说为九宝唯有五。意云。如五日相望。前三为过去三世。从后取三为未来三世。处中取三为现在三世。若依此释。进无九世之体。退过三世之数。云何一念得具九耶。今谓若不令九缘起相由但以三世缘起相由。即九世成矣。谓过去因现未。则过去之中有现未。现未各因二世亦然。是以三世各三故。中观云。若法所因出是法不异因。中论破执则一中有三为过。此明离过之用。则一中有三为德。以病成药。岂不良哉。总云一念者。前之九世相望以立。今摄末归本不离一念。即此一念现在。是过去未来。是未来过去。自具三世。三世相由九十具矣。故以一融九虽九而常一。以九融一虽一而常九。九一无碍。没果绝言假十圆融为入门矣。况积念成世念外无世耶。又无念等故。又法性同故。此有四义。后三通于余宗。第七知三世者。前之二段明法上之时。此辨时中之法。即化生之法。随彼安立而化故。是上所知之法故。晋经名三世间。度世经名入于三处。皆意取其中事也。十中初七知安立谛。次一通二。成上安立事无有尽。生下非安立性无可尽。后二知非安立。第八无疲厌心。既所化无边。求法化之而无厌怠。由上即知烦恼无所起故。十中初四上求。次四下化。后二通二谓游刹近佛化生故。思惟二利行法故。上八门胜进行竟。第三有三门。明前二行究竟。今初一门明所持差别智究竟。上云则以智慧辩才力。随众生心而化诱也。第二陀罗尼即能持究竟。上云修行诸度胜解脱等。十中初一闻持。次四义持。次四广闻持之用。后一收上义持。又初四如次持教行理果。次二重显持行。即定慧故。次一持理不思议故。次二重显教。后一重显果。第三说十种佛。上能持所持皆是佛法。今知法主究竟。上云则得灌顶而升位等。十信满心便得佛故。然此十佛与下十种见佛名义全同。与前十身名有同异。而义亦无殊。一示成正觉故。即前菩提身。二愿生兜率故。与前全同。三万行因感故。即前相好庄严身。四自身舍利住持故。即力持身。五涅槃佛化必示灭故。即前化身。六法界佛真无漏界故。即前法身。七依唯心故。即威势身。虽光明亦能摄伏。心伏最胜如慈心降魔等。八常在定故即福德身。定为福之最故。九了本性故即前智身。大圆镜智平等性智皆本有故。故下云明了见十随所欲乐无不现故。即意生身故。晋经云如意佛然佛就内觉身多就相故。立名不同余广如别章。略如八地。大文第二发普贤心下有二十门。答前二十句问。明十住行法。古德同分为四。初六门别明发心住义。二十种波罗蜜下六门。明余九住中所成内德行。三从十种说法下三门。明诸住中外化行。四从十种自在下有五门。明无碍殊胜行非不有理。今取顺十住。经文二十门如次明十住行。但与前行互有广略影显。解中之行。广无尽故。若依圆融行行遍通。若不坏相不妨次第。初四门明初住行。二三各有二门。四五各一。后五皆二门。今初四门明发心住。初一总明。后三别显。今初总发名普贤心。前十住中自分之内。即缘佛十力发心。但广发心之境。今发普贤心则广发心之相。影略明故。普贤心者即菩提心。菩提心就果以明普贤心。约相用说。横周法界竖穷未来故。十中初三悲护众生心。次六约起愿心。于中一求果智。即前缘佛十力。二求因行。三竖。四广。四皆上求愿。忍施下化愿。后一智心即三心菩提也。又前七护小乘。于中初三护陜心。后四护小心。余三护烦恼心故。异凡小是菩提心。又初三众生无边誓愿度。度生无吝故一切施也。次一佛道无上誓愿成。次三法门无尽誓愿学。后三烦恼无边誓愿断。即四弘誓愿观理发心。二有十种普贤行法下。别明菩提心。此门即大愿心。亦即是前胜进行。所谓勤供养佛乐住生死等。文相多同恐繁不会。三有十种大悲。即别明悲心。初一总谓外无善友可依。内无自德可怙故。余九别。初五欲求众生。但纵目前之情故。次一有求众生故。没生死海。后三邪梵行求众生。无明邪见之所病故。但欲邪法故。四有十种菩提心。因缘别显智心观境。推理发心别故。此与前自分行中发心因缘。亦互影略。十中前五以萨埵为缘初句总余四别。别中一令灭妄苦。二得真灭。三断痴集。四证真道。即推无作四谛理发菩提心。后五以菩提心为缘。初二福智因。后三希福智果。然上二段文含二意。一成上发心住中行。二成下治地住中行。谓十种大悲。即广彼自分中十心之一。菩提因缘前五。即彼自分中初之五心。一利益二大悲。三安乐四怜愍五安住。后五即彼此互缺。第二近善知识下二门。正明治地住中行。此门明胜进中。近善知识文中标内兼是显意。列中前六事友。后四同修无异。求者不求名闻利养及过失故。二十种清净即胜进近友之果。故云起如是心即得。此十即是前文了达。于义如法修行。远离愚迷安住不动。梵云波利戍提。此有二义。一遍清净即此十种。二极清净即下第六十四段。列中初六三业净。前三体净后三用净。次二主伴果报净。后二愿行净。第三波罗蜜下有二门。明修行住中行。此门即自分行。彼开一慧为十观察。今总显修具修十度。十度皆总相而释。一一多含故。施云一切皆舍等。智即方便。进趣佛力权智立以智名。神通即力度。晋名神力法即是智。从所知名法。二十种智随觉。由前行成无倒了达随事随理善觉知故。即前胜进十法观察众生界等。亦有影略恐繁不会。第四证知一门。明生贵住中行。即彼自分行由前了达故。能证知证故。于圣教中生。十中初三总知一切法。次五广前知众生。九菩萨行愿即前业行中摄。后一即知涅槃对生死故。其胜进但了佛法。无别行相故。略不明。第五十种力。即具足方便住中行。准梵本此名积集。即方便具足之义。下第九十五即是十力。前十住中但云所修诸行皆为众生。不知修何。今显所修之行。又入即了达。兼其胜进解众生等。于中前六解法力。余四上求力。第六十种平等下二门。明正心住。此门即自分行。由了平等故闻赞毁心定不动。然平等之言通有三义。一事等。谓十类各各相望。如说众生等有佛性。乃至诸佛同一法身。一心一智等。二者理等。谓此十类等一真故。三心等。由了前二即之于心故。于十境不生高下。十中一于众生等谓无怨亲故。二于善恶不生分别故。三见染见净无高下故。四同一真道而出离故。五无一善根不为佛故。六于诸同行如自己故。七一一大愿彻来际故。八不谓般若胜檀等故。九随一一行彻事理故。十不谓此佛此最胜故。二十种佛法实义句者。即彼胜进中行。与前虽少前却而义多同。于中初一约遍计都无实故。次四约依他。后五约圆成。一无名相中假名说故。余四各一义可知。第七说十种法下有二门。明不退住中行。于中初一自分。后一胜进。前中由能说深广法故闻说心不退转。十中说业性等。成如来力。随义演说令菩萨不退。涅槃二十八中广明退不退相。余文可知。二十种持。持谓受持奉行。非但宣之于口。十句可知。第八十种辩才下二门。明童真住中行。此门即自分行。由三业无失故。有无著辩。由知众生欲解故辩令他喜。后门即彼胜进。现变化自在身等。皆自在义。第九十种无著下二门明王子住中行。此门由无著故。能善知十法。后门由平等故。胜进学法王处法。第十十种出生智下二门。明灌顶位中行。此门明成就十智学佛十智。后十种变化故。能动刹等。然此变化即实。如化非要化作。上来数段文相并显。虽有深旨类前可知

大方广佛华严经疏卷第五十一大方广佛华严经疏卷第五十二(已下入五十三经)

        唐清凉山大华严寺沙门澄观撰

大文第三十种力持下有三十门。答前十行三十句问。古德分三。初六门明大志旷远行。二从十种不思议下九门。明定慧业用行。三从十种园林。下十五门。明德备成满行。然约圆融此意非无。今不坏次。亦次第显十行中行。第一行有三门二三行各一。第四行二门。第五行六门。次四行各二门。第十行有九门。至文当知。所以用门多少者。檀在初故具三。戒忍通世间故唯一。定慧尊胜故有多门。智中既多故。般若中略余次胜故但用二门。又此十行虽约十度。而义多含故。文中或就十度明义。或就行名以释。今初三门明欢喜行中之行。三中初明力持。此含总别。总者以是十行之首。依此十事加持建立。能起诸行故。度世经名十建立。别即欢喜行中凡所布施。皆为修习诸佛本所修行等故。是建立行意。十中初三三宝。即境界持。众生即僧宝。菩萨之僧即众生世间故。余七行持悲所作业故。正起行故。愿持行故。有悲智境行方成故。时即起行之时。后二福智。然第十地大尽分中有十一持。第四加烦恼持故。论判行持中。初二逆行彼约应化不断所以加之。今但约为行本故无烦恼。彼有供养持及劫持。无境界持及善力持。此以时中摄劫。彼以行摄善力依境起供。故并无异。余名并同具如彼释。既数名不同案名以释。此无僧宝有教化众生。亦未爽通理。上辨陀罗尼即总持文义。次云受持即领纳受行。今云力持即加持任持。故不相滥(已下入第五十四经)第二大欣慰。正辨欢喜行义。彼但见乞者来倍复欢喜。今则知由施故见佛供佛等。心大欢喜。初行多同欢喜地故。十中略为五对。一事佛供佛对。二闻法亲善对。三二利行成对。四严土化生对。五难见能见难成能成对。文相甚显。三十种深入者。上明预欣当成。此辨现能证了。即前法施之行故。彼云。我当尽学诸佛所学。证一切智知一切法。为众生说。十中前六有入字。后四以知为初。证入了知二文彰显。于中初四入器世间。前三别入三世。后一总明。别中现在内数谓多少。行谓刹因。说谓彼彼果中说法。清净谓刹体。此是通体。后总句云种种性。即染净等殊。斯即别体。次二入众生世间。后四入智正觉世间。于中前三入三世佛。后一入法。法中初知差别五乘。后虽知下。明权实双行。以性不坏相故。虽无分别而说种种。此中分别即是差别故。晋经云虽诸法无一无异。而说一异次言悉入法界无所入故者。释成上义。谓悉入法界故无差别无所入故。而说种种。何者若别有一入处。则入时失本相不得说种种。以当法自虚名入法界。无别可入则不坏种种矣。言如其下此上辨知。此下明说。夫说法者当如法说。法既权实双融。说亦即说无著。第二十种依止。明饶益位中行。上明证入今托良缘。遍依此十方能饶益。非但依戒。况戒有摄善何所不具第三十种无畏。即无违逆位中行。由依菩萨止善。则于十难作能作。难忍能忍。为发无畏心。一障碍难灭。二遗法难护。三恶魔难降。四身命难舍。五外道难摧。六物心难称。七大众难喜。八八部难调。九下乘难离。十上行难修。于此十难皆无所畏。岂畏众生相恼害耶。第四发无疑心下二门。明无屈挠位中行。于中此门由前于难无惧故。于十所作决志无疑。即被甲精进中行。后门摄善之行。利乐遍在二门。今初十中一十度摄生。二事佛供佛。三光明严刹。四长时调熟。五具一切智。六作世明灯。七说法开悟。八灭障成佛。九离妄自觉十决成菩提。于此十事发誓要期故名被甲。二十种不思议。即所摄之善由决志无疑故所为难测。十中初三单约善根。愿智称性名不思议。余七权实双运故不思议。于中前四约行。后三约智。智约内明行就外相。前中四涉有而一道清净。五悟空而万行沸腾。六修因而八相果成。七现果而大用不舍。皆难思也。后三中八二谛相。即九三事融而不融。十权实即而不即。八中十句五对。一境二心三通一切。四约修起五即名言。亦即五法。一相二妄想。三如如四正智五名。然各有二意。一直就法体无相是真相。即是俗常互相即。下四例然。二约迷悟。五对大同小异。谓一迷如无相以成于相。悟相无相即是如如。二迷于正智无分别。即成妄想分别。悟妄分别即正智无分别。三了如非有真有如如。若执有如则非如有。四智若无作是作。正智若有所作非作正智。五知名非说是真说名。谓名有说非是说名。九中初融三事。后亦不下显离融相。名为不融。三事即心佛众生。皆无差别。如觉林偈。十中三句初明尽而不尽。此约断时以明体用。二无而不无。此将法性对断以明体用。二句虽殊俱是权实双行。三虽知佛法下。明即而不即。于中初正明。后一切诸法下释成上义。悉入法界故说相即。无所入故。不应世中分别佛法等。谓以当法自虚故名相即。非世间中佛法可得。下重释云。知一切法皆无二故不得二中互求无变易故亦非世法作彼佛法思之。第五十种巧密语下六门。明无痴乱中行。于中三。初二门即无痴之行。次二门明无乱之行。后二门双明二门引生功德。虽痴乱有通今从别说。又此三段即是三禅。初即饶益有情禅。二即正法乐住禅。三即引生功德禅。今初二门中。初门不愚巧密之言。后门不愚善巧之智。今初前既明内行今辨外言。彼行文云以正念故。善解世间一切言说。能持出世诸法言说等。皆言密语者。泛明有五。一说深密法故。如出现品。名如来密藏等。二一言说一切法故。上云。如来于一语言中等。亦如仙陀四实九义瞿声等。三近而不闻。如身子在座远而无隔。如目连寻声等。四言近意远。如说三乘为究竟等。言远意近如说寒时得火名。涅槃等此意。亦名隐实说权。五以异言说异法如觉不坚为坚等文中十句。初一具五以是总故一切教故。次二含二意谓示而谓实故即第四意。此二皆是深密之法即第一意。余通前二。或并兼五可以意得。二十种巧分别智。外言既密内智又巧故。于利生无有痴闇故。彼文云。菩萨于善知识所听闻正法。所谓甚深法等。文义多同十句可知。第二二门明无乱行。皆是定体。于中初门明入三昧。显处等不同。后明遍入则触类皆遍。今初故。彼文云。善入一切诸禅定门。此中明十皆通一切。十中通辨缘斯十境。入定不同。别则十门各异而前五一重之事。余五涉入圆融可知。九十皆即一而多故。彼行云。一念中得无数三昧。但从多分对前后说。判为定体耳。非此无用二十遍入。亦犹小乘说十遍处。即令三昧渐更增广。前明一切如众生身。谓童子身等。虽能一切身入而不必一时。今此随入一类皆遍一切。如海慧初来一时皆水等。十句可知。第三十解脱下二门。明引生功德禅中。此门明作用无碍故称解脱。后门于境无拥故曰神通。今初解脱即亦思议解脱。梵云毗木叉此云胜解脱。谓殊胜作用不由依禅成八解脱。十句可知。二十种神通。如依四禅引六通用。此十若以六摄前四可如。次五神境。后一漏尽成菩提故。约位不同与十通小异。第六十种明下二门。明善现位中行。此门正显行体即是般若。故曰智明。后门明离智障故称解脱。今初然皆权实无碍之智。故称善巧。非如十度唯约根本。但约增微分成五行。十中前七单约一智。后三双行。前中初三约所化。次三约能化。各初事次理。后即事归理。七离能所想会归般若。念想观除不受境界。为入理善巧故。后三双行中。八明无说之说无成之成善巧智明。谓双非照寂离言而能差别。照事有说非相遣相非无遣无一性遣多。无性遣有即性相俱寂。住于下。无成之成法界之体。实无所成。照斯法界即说成佛。九明无生起生智明。文中三。初正明。次何以下征释。三是名下结名。今初明无缘之缘。兼显无化之化。于中二。先明无缘。谓众生真心称理不可得故。若无缘即无所化。而知下明真心随缘不坏缘起。则亦有所化。于中二。先知所化。后结成双行。前中文有三节。初有八句别知缘相。因谓无明等。缘谓业行。事即识名色等。境界即触受尘境。行即现在爱取。有生即生支。灭即老死。知言说者。总是随俗缘生不离三世故。二知迷下十二句六对。通知染净迷悟。迷理则倒惑杂染。悟皆反此。随俗则俱可得。第一义中二俱叵得。得非得约理。着非着约智。三知住下明知心行。住谓本性动谓客尘。随客尘则去而莫归。见本性则还源反本。有还有去。皆是起心还住两亡寂然不起。起则诸善失坏。不起则出离盖缠触境寂知。是为成熟。上通物我后兼知机。约自根谓六根不为境牵。即是调伏。后随其下结双行中。谓智随曲化不失无行。二征释中所以尔者。为物发心故。结名可知。十平等教化智明中三。初明实不碍权。二知种种下权不碍实。三于生死下结名并可知。二十种解脱脱二障故。梵云毗木底此云解脱。与前不同。十中初四脱凡三障取增为业故。后六脱智障。初一拣劣余皆显胜。第七园林下二门。明无著位中行。于中此门明游处纵情。后门明栖止适悦。皆通二利。权实方便而无所著。今初可知。二宫殿十中四梵住者。即四无量亦色因故。故度世云修四梵行慈悲喜舍余可知。第八所乐下二门。明难得位中行。于中此门内心愿乐。愿即行体。既处宫殿则情欣胜乐故。二十庄严即外德庄严具。以众德庄严愿故。文并可知。第九不动心下二门。明善法位中行。此门明外缘不动。后门明内心不舍。又此明心坚。后明深入皆是力义。今初十中二。及第九是思择力。余皆修习力。八中有十。一信一生佛果故。二不杂不信浊故。三净无烦恼故。四无细念故。五离所知垢故。六彻事源故。七向果位故。八自分坚故。九德无尽故。十缘不动故。十一证真如故。余并相显。二不舍深大心者。由不动故能穷理事。理深事广故云深大。十句可知。第十智慧观察下九门。明真实位中行。即分为九。一观察智。二说法智。三离障智。四审决智。五照彻智。六无等智。七无劣智。八高出智。九深广智。今初。亦由不舍深大故能观察。前问但言观察者。脱智慧言十句准思。二说法智由能内观故能外说。十中初二说俗。后八说真。一无二可诤。二体德兼广。三相深远。四体坚利。五如如不动。六体绝百非。七在缠不染。八体相一味。第三十种清净即离障智。此离智障晋名无垢故。虽同清净所净不同。十中与七净有开合不同。在文易了。七净如五地初辨。第四十种印者。即审决智。以清净智决定印可一切法故。故晋本中名为智印。后所结益亦是智印。亦犹三法印等。十中一于安受苦境忍智不动。二他不饶益忍行决定。三于佛法深信忍决定。即谛察法忍。四决定成佛度生。五决定知佛智无边。六决欲佛果不退。七决不顾身命以亲人法。八决度已入大乘者。九决平等度。十决同佛体因圆果满。第五智光照即照彻智由印定故照。彻无碍十句易知。第六无等住即无等智由前照彻故不偏住着。双住事理名无与等故。列十中皆权实双行。或即寂之用即用之寂等。并显可知(已下入第五十五经)第七无下劣心。即无劣智。上既望下无等。今望上无劣。于十胜事皆决作。故名无下劣。所以晋经名无怯弱。十句五对。一降魔制外对。二喜他自满对。三积福成智对。四下化上成对。上四单辨。五悲智究竟对。即是双行。于中九是即智之悲。而悲智双行。虽悲而不求果报。十是即悲之智而权实双行。于中四。一列所知。二如是下辨能知。谓知苦觉妄见理证灭修道断集。三然于下拂彼知相能知。无分别故无功德。所知无种种故无境界。四非有下会归中道。广辨双行。于中初二句总辨中道。次以不二下境智对。明皆以实智知权。显双行无碍。于中异约竖论变异差别。约横辨不同。后以究竟法界下。即体起用以辨双行。第八如山增上心。辨高出智。由无下劣故。万行迥出难仰其高。于胜决作故直趣菩提。不可倾动。十中一勤修能证智。二常观所证理。三内修无漏。四外近善人为名利为异求。从他闻言已解为盗法。观佛三昧经说此人堕地狱如箭射顷。后学诫之。五大忍度生弘誓更增者。若薪炽于火。六决超魔境。由成胜德而不着。唯法乐以自资。则魔境皆为佛境。七勤勇修行。摄论云愚修虽少时怠心疑己久。佛于无量劫。勤勇谓须臾。八不舍恶人。九孤标等佛。十权实双行文中四。一正辨双行。二何以下征释。征有二意。一云修须称理。理既无得愿何不舍。既不舍愿何用观无。进退有妨。二释亦二意。一云若有所得不得菩提。以无得故。出生菩提故。虽不舍愿须观无得。二云无得之法非在得外。要求一切法。方尽无得之源故。欲证无得须不舍菩提之愿。三是故已下结成双行。四不作是下显其离过为不怖空而不求故。第九如海智即深广智。非但求升耸峻。抑亦智体包含故。十中前四即四无量界。后六并佛界。无量开出。谓五入三世佛善根。六七八入三世佛界。九供多佛。十求多法并显可知。由此因海得入果海。上来十行位竟。大文第四如宝住下二十九门。答二十九句问。回向位中行。若并无碍总句有三十门。古德分三。初十一门明回向位中行体坚固。二从十自在下一十二门。明行用自在。三从十种游戏下七门。明行德圆备。今亦随次配十回向。于中初有四门明初回向。二三回向各有二门。四五六七各唯一门。第八回向即十无碍。九有三门十有四门。至文当知今初四门明救护众生离众生相回向位中之行。即分为四。一明所回善根。二即大愿救护。三即回向所为。四显所作成满。今初所住善根可贵圆满故。十中一供事多佛。二闻法受持。三自在受生。四说本末法。于中初说从本起末法。如无量义从一法生。其一法者所谓无相。次以一切下摄末归本。释成上义。五知断自在资粮道。厌息加行道。防护无间道。断除而不取解脱道。证入为异二乘留惑不断。方能究竟断证故。云何不证。方便巧学无边佛法满昔弘愿故。如箭射空筈筈相拄故。六悲智双行。七知性相无碍。八无得之得。九观空满愿。十受行无厌。于中先正显。后知如来下释成。第二十种如金刚心。即大愿救护虽回向皆愿此在初故。谓于当作事及现作行皆无齐限。要心坚固穷其际故。十中一法门无尽誓愿知。二众生无边誓愿度。三严刹。四回向。五供佛。上三愿成佛果。上五皆约当成并横论无畔。次二约其现作皆竖深无际。谓六见闻无著。七安忍不乱斩首为级。上二暂断烦恼。后三亦约当成。谓八遍于时处修行二利。九以心要成无际大行。十即寂起用。于中三。一悟寂。二而亦下起用。三何以下释成。于中有三重征释。初番意云。所以即寂而用者。由本愿智不舍悲故。次番云。所以智不舍悲者。智亦为物故。后番征意云。何以要此双行者释有二义。一诸佛皆尔故。二又我下我先愿然故。第三十种发起。即是回向所为。发起令现前故。十中前六自分。初三福业大。次三化业大。严土亦为摄生故。后四胜进。七八胜进摄福。后二胜进起化。谓九证体。十起用。第四究竟大事即所作成满。十句可知。第二不坏信下二门。明不坏回向中行。此门正明不坏十句义如前说。二十种受记即回向行。成十中一解会佛心。二具解脱分善。三大行已修此。三多约三贤四五约对面不对面。法华云其不在此会。汝当为宣说等。六初地证如。七八地成忍。八九地具调化方。九十地三大劫满。十等觉已入重玄故云自在。如记慈氏等。若约行布。此位但有前五因便余来。若约圆融并通斯十。第三十种善根回向下二门。明等一切佛回向中行。此门正明等佛佛为真善知识。同即等义。十中心即悲智为心平等契理。余各一义。皆云同者同一体故。不见二相故。标云由此。能以一切善根皆悉回向。二得智慧亦回向行成故。彼文云。住此三昧。入深清净智慧境界等故。第四十种广大心。明至一切处回向中行。无量无边故无不至境。既无量无边心如境而广大。第五十种伏藏。即无尽功德藏回向中行。于一切法蕴斯十义故。名为藏。即法而观惑者不见故名为伏。一切各十是无尽功德矣。第六十种律仪。即随顺坚固。一切善根回向中行。彼约行首故。广就施以明善根。今约行本略辨律仪。善根皆顺平等之理实通一切故。第八云一切善根皆令究竟。究竟即顺坚固义。通明十句摄善饶益无所不具。通一切善居然可知。第七十自在。即平等随顺一切众生回向中行。具十自在能随顺故。十自在如八地辨(已下入第五十六经)第八十无碍用。即真如相回向中行。如于真如无障碍故。故彼位果云。住于此位得一切刹平等等。平等即是无碍之因。亦无碍之义。又云。得佛无量圆满之身。一身充满一切世界等。即正显无碍之义。文中四。先总标十章。二佛子云何下总征十章。三佛子菩萨下依章别释。四佛子如是下总结成益。今初亦三。谓标征列名。无碍者前明自在。即作用任运。今明无碍显作用无拘。又无碍有二。一智二事。十中有通有局。然法智无碍多唯约智。如身刹等。多唯约事如众生等。通于事智。然事无碍必通于智。智无碍境未必通事。二皆即体之用故。并云无碍用也。然十皆通二利。且约化说。初一所化二是化处。余皆能化。谓化法化身等可以意得。第三依章别释中即为十段。文皆有四。谓标征释结。今初所化众生无碍用十句中。前三约智辨无碍。一了性空故。二唯心现故。此二实智。三知时说法即是权智。余七约事无碍。四能现众生故五近收一毛。六远示他刹。余四示上首之身。第二刹无碍十中。知刹无尽通智通事故。晋经云。于一切刹深入无尽方便。度世云。一切佛界所入无尽。皆通事也。余九唯事无碍。深即微细刹。余并可知。第三法无碍。谓皆约智于性相无碍之法。能知说自在故。一一多即入而不坏本。二实智出权。三无文示文。四一说多相。五无说之说。六一言圆备。轮字之义弥伽处释。七门门互收。八以真收俗。九横知无边十竖穷其际。第四身无碍用。第五愿无碍用文并可知。第六境界无碍。谓于此十种胜劣相违境中于胜现劣回转无碍。是为菩萨分齐之境。文亦可知。第七智无碍。前来虽亦有智各从本类摄之。今则一向辨其智用。然智无若千因法显别。以法从智。前法无碍以智从法。十中初二能化智。次三知所化智。六上入佛智。前六皆权智。七八权实无碍智。后二事事无碍智。第八神通无碍。一无数色身通。二天耳三他心。四分别言辞五宿住通故。度世经名见前世。六往一切佛刹通。庄严乃是其中别义。七未来劫通。前已明过去故。通举三世。八即一切法智通。故度世云。一切诸佛菩萨所建立行。演法光明而照耀之。即是法光照佛法也。九即天眼。度世云。知见一切等故。谓见有所作而守护之。十准晋本云。佛子略说菩萨平等观一切诸法通自在。此即一切法灭尽三昧通平等寂灭故。故度世云。菩萨平等寂诸音响。则以平夷等御众生。今文脱。此文中略举故不曲尽。大旨不异如十通品辨。第九神力无碍。神通多约外用无壅。神力多约内有干能故。其十中多约一毛含摄等。此即身力。后是智力。若以通摄力。十种神力但是一神足通耳。既分通力两殊故。十通中少说神境。第十力无碍用。悲智之力皆无碍故。亦有事用无碍从多说之。第四总结成益中。欲成不成。已得无碍得果不舍因尤显无碍。第九游戏下三门。明无缚无著解脱回向中行。彼有百门。广显以无缚着解脱。成就普贤自在智用。今略其三。此门任志行成游赏自在。次门明境界难量。后门明智用干能。皆由无缚无著故。今初十中摄为五对。一依正染净相作而皆不坏本相。正显游戏之义。如世纵情游戏无损动故。他皆仿此。二大小乘互现。三因果互现。四生死涅槃互现。五定散自在。谓初即定中起用而常定。后即用中入定而常用。第二境界难量通二种境。一即游戏所行之境故。晋经名为胜行。二即分齐之境。谓出没无碍唯菩萨能故。十中前三通所行境。后七皆分齐境。第三十力智能。十中前七自分力。后三胜进力。前中初三自利一一向深求故。释以不杂。二深求佛法佛法即是增上。三所作究竟者。由有善巧。次二利他。后二通二利余可知。第十十无畏下四门。明法界无量回向中行。分之为三。初门明所回善根。次门明法界行体。后二门明所成之德。今初即是法施善根无畏。即说法之德故。十中一闻持无畏。二辩才无畏。上二不畏不能答难。三二空无畏。了达二空不畏妄念。四威仪无缺无畏。五三业无过无畏。上二不畏外讥。六外护无畏。不畏众魔外道。七正念无畏不畏遗忘。八方便无畏。不畏生死如善治船不惧海难。九一切智心无畏不畏二乘。十具行无畏不畏不能化生。第二不共法。正明法界行体。以称法界起行故。不共凡小。又悟不由他亦非他共。十中一自利行。二化他行。三上求行。四善巧行。于中五。一巧离二乘。二善能下巧修三昧。三往来下巧顺世间。四虽现下巧住诸乘。五虽念念下巧穷因果。五双行不共行。有标释结可知。六三业随智慧行行。七悲代他苦行。八大慈摄物行。九坚净自他行。涅槃春池可于中说。十位满常修行。第三十种业下二门。明所成之德中。先明业用十句可知。后门十身显得其体。然若身若业皆同法界无量。略举十耳。此中十身与第九行十身。大同小异。谓此不来不去即彼不生不灭。不实不虚即彼不实不妄。不尽坚固即彼不迁不坏。不迁则横无迁变。不尽则竖说无穷。此中不动即彼一相故。文殊般若云。不动法界法界即一相。由得一相魔不能动。此具相身即彼入一切世界。诸趣身无相名同普至身。即彼入一切世界非趣身。余如十行中辨。上来回向位竟。大文第五十种身业下有五十门。答五十问。明十地位中行相。古德分四。初十二门明十地中三业殊胜行。寄在初地。二从十种勤修下。九门明造修离障行。寄二三地。三从十种离生道下九门。明造修纯熟行寄在四地已上位。四从十种足下二十门。报相圆满行寄八地已上位。此释犹稍近。文亦未尽理。今亦依次分配十地。初地十门。次八渐略文势尔故。谓二地六门三四各五门。五二六一七八各三。九地二门十地十三门。至文当知。今初十门明欢喜地中行。若粗相分总为三段。初二约身。次四辨语。后四明意。总显彼地三业殊胜。若顺彼文且分为二。初九明初住地中行。后一明安住地中行。前中分四。初六门明依何身。次心一门辨以何因。三发心门明为何义。四周遍门显有何相。今初分二。前二约身辨身。后四就语遍身。语属身故。皆是深种善根之所摄故。今初分二。此门约色身业用明身。十句可知。后十种身约法门自体明身。故但云身。十中度摄福智等。即前深种善根集助道等。互有影略。二就语辨身中。四门皆是所种善根。是知彼文虽无义已含有。若全异彼岂为彼行若全同彼何须重说。故彼文节节皆云。若广说者不可穷尽。小异何疑。四门即分为四。初十种语明语体用。若约遮释十中。初一离恶口。二离两舌。次二离妄语。一粗二细。余六离绮语。若约表释。十种各显一德。二十种净修语显语净因。初二摄法次二离过。次二摄善次二法施。后二求法行。由此十事能令语净。三十王守护即净语之果。发其言善幽冥应之。况其人乎。然地经中。善知识善护意通由诸善。不独由语故。度世经亦不蹑前。四十种大事案经。即内善外护故。能成所作。然即地经善集白法善净深心等。余句中义亦不独蹑于语。然皆蹑者以语例余。于理无爽。十句并通二利文相亦显。第二十种心者。明以何因。以大悲为首荷负一切等故。十中一荷负心。心如大地荷四重任故。二深广心包含无外故。三胜心四净心。五利六坚七无染。八希有九智慧十无边。并语心体也。第三十种发心者。明为何义。为上求下化故。发起胜用十句可知。第四十种周遍心。明有何相。以过凡夫地入真如法中故。十中一总明悲广智大。旷若虚空。二智契深极余皆可知。第二十种根即安住地中。行由前初住之行。令此胜用增上皆光显。故名之为根。十中分三。初一信成就。次六修行成就。于中初句乐欲根即近安乐法。多闻能正观故。二不退者。即不著名利。于三昧中亦无爱着及贪求故。三安住者。万行念念现前故。四五悲智不断上皆教道。六即证道之修。后三即回向成就。一总求一切地智故。即金刚智照彻法性故。二别求法身。三求功德身。谓十力等。第二十种深心下六门。明第二地中行。于中二。初二门明发起净十种深心。后四门自体净。今初前门自分直明深心。后门胜进加以增上。今初晋经及论。皆名直心者。然深心有二义。一于法殷重名深。即乐修善行。二契理名深深入理故。若语直心但有后义。正念真如法故。今文具二。初由契理。二由修行。次七广上契理。后一显前修行。二增上深心即胜进。上求增殷重故。十句亦四。初门乐修善行。二标契理。次三成上离疑。一出所因。二彰所入。三成德自在。后五成上积集善根。第二十种勤修下四门。明自体净中行。彼约别地之行但明于戒。而有三聚。今文分二。初一门通修十度。即摄善法戒律仪亦在其中。以地相望是修位之首。故特名勤修。晋经名方便。方便修起故。二决定解下三门。明饶益有情戒中行。此门总显智。于诸善决起胜解。地经约戒但解十善。晋经名乐修由有决解故乐修习。二解世界。三解众生文相并显

大方广佛华严经疏卷第五十二大方广佛华严经疏卷第五十三(已下入第五十七经)

        唐清凉山大华严寺沙门澄观撰

第三十种习气下五门。明三地中行分二。前二门明能起厌行。后三门即所起厌行。前中二。此门明熏习成气。后门增盛摄取。今初由此地厌伏烦恼故。于诸行积集熏成气分。方能究竟断伏烦恼。故名习气。十中一行本气。二成行气。三下化。四上见。五受生。六大行。七十愿。八十度。九理智。十量智。二十种取者。明增盛摄取故。晋经名炽然。由前积习爱乐得增长故。第二十种修下三门。明所起厌行。即分为三。此门正显修行。前八修因。后二修果。第二成就佛法明修成胜缘。依托此十能成就故。第三十种退失明修行离过。别举十过总令远离。文并可知。第四离生道下五门。明四地中行分三。初此门明清净对治修行增长因。次门明其清净。后三门明对治修行增长。今初前三地寄同世间。有见等惑。犹如生食在腹。四地寄同出世。对治清净能离彼生。谓离有为行故得无生故。显行纯熟离生涩故。广如婆沙。今是彼清净对治之因。故名为道。地经有十法明门。初是观察众生。今但广斯一句余略不具。结云不杂二乘者。以于十句双行而修故。不同二乘见道离生矣。第二决定法者。明其清净。上明能离今显所得。以得出世决定法故。故彼文云。得彼内法生如来家。十中前五自分。后五胜进。第三出生佛法下三门。明对治修行增长。于中分二。先二门明修行增长。后一门明修行对治。今初亦二。此门正明增长。后门显立胜名。今初从缘出生即增长义。亦犹出息增长其多。十中初二顺人信法。次二愿智不虚。次二时处广长。次二无间普遍。后二胜行摄生。二丈夫名号即立胜名。由德行内增故嘉名外立。十中前四从境立名。五六约当体受名。上皆自利七八利他。九通显胜具二利故。上皆自分因名。后一胜进果。称上皆随德假名故。瑜伽四十六。明菩萨随德假名有十六种。初名菩提萨埵。十六名为法师。显扬第八庄严论十二。皆同此说。又商主天子经五义立名。恐繁不会。第二有十种道明修行对治。地经寄位广明三十七品。今约实位故。增数显十皆为对治。并是正道。十中前二后一名义皆不共。三道则名义俱共。四道至九名共小乘。义唯实教前三可知。言义唯实者故。四行云。善巧回向无休息。故五根定根知三昧入出。六通天眼见死此生彼。七六念成七加念众生为大悲故。亦是广七觉中一念觉故。余例此知。八正思惟顺一切智。九次第定皆寂用双行。初禅离欲恚害而逆化众生。亦用欲等言说。故云一切语业。二禅虽无觉观不坏净觉。以为说因。三禅离喜而生法喜。四禅离乐而受解脱道乐。从此不下。明四无色定。但总相显胜。虽住灭下即灭尽定。此定虽尽灭诸不恒行心心所法。及灭恒行染污一分。而以厌患想受为先故。名灭想受定。由非想地犹有细想。是舍受故。今实教明即受等性灭故。不息菩萨行。是以七地云能念念入。亦念念起等。余如三地及七地中辨。十力中六遍一切下。是一切至处道智。八是天眼。九是宿命。今三世悉知。况乎宿命。余如初会中辨。第五无量道下二门。明五地中行分二。此门明胜慢对治中行。后门明后二分中行。今初分二。先总标四门。以此四门同显道义。义皆无量类例相从。故总标之。约义须分故。后二属后。二从佛子下别明初门。谓十平等心及随如道行。皆是菩萨正道所游路故。以触境皆如道无不在。况虚空等十。一一无量道岂有涯。十中前四各一无量。后四皆佛界无量。语言亦属众生。亦是调伏界。无量劫数即竖论无量。余七横论无量。虚空亦横亦竖。法界非横非竖。虚空法界约无分量。余八广多无量兼无分量。二无量助道即不住道行胜。及彼果胜中行。以智契如是谓正道。万行资缘皆为助道。此二合行名不住道。今以圆融之修无不契如。并为正道。皆互相资并为助道。故举虚空等十不异前章。然正道不随事转同称无量。助道随事故。随所等事名无边无尽等。第六无量修道一门。明六地中行。般若现前为真修故。无去来等即十平等等故。十中前四即胜慢对治中行。摄十平等。后六即彼果胜中行。不住道行胜。十种观缘彼已广故。此略不明。四中前三约法。后一约喻。法中彼从别义开成前八。今总明之。一不起心。二称本性。三遣修相。亦可配三性三无性。如理思之。四举七喻通显无著。后六中五虽证三空。而集福德。六不着教法不可说者。理圆言偏言不能诠故。无言说者性无言故。离言说者忘言方会故。七不坏事法界。八不坏真如理。九总明权实之智故力无尽。上皆自分修。十即胜进修。第七庄严道下三门。明七地中行分三。初门明权实双行。次门明念念进趣。后门取授自在。今初即彼地中。乐无作行对治十种方便智。及双行果发起胜行中行。以权实交饰故曰庄严。列中前五自行无染。次四随有摄化。一无染而化。二处正入邪。三持犯权实。四人法权实。十总显因果权实。于中三。初因圆示缺示现受生。是因未满故。次与三世下。同果境界而不舍因。因有十句行通二利。法即教法业谓利他。道谓正智仪谓制听。取即愿求巧谓权实。上皆所作事。总语因体。生成用者即因成大用。住持力者长用不绝。后何以下征释可知。二十足明念念进趣行。即彼障对治中修行无量种。及双行分中菩提分差别等。十中初二约行。一戒二进。次二约通。一总二别。次二约心。一愿二誓。次二约法。一顺二持。后二约德。一演二伏。三十种手明取授自在行。即双行分中能作大义。十中初一约取。谓念念中修习一切佛法向佛智故。余九约授。于中前五明四摄。一布施二爱语。三四皆利行。五即同事共一手。作而拔出故。后四即四家一苦清净故。二示诸谛故。三般若力故。四舍烦恼故。第八十腹下三门。明第八地中行。以内证无生故。皆约内事明内德圆满。即分为三。初门明含容清净德。即彼集地分中无住道清净等故。及净忍分中得无生故。亦是得胜行分中离一切贪着等故。世人之腹多含秽恶。今此十中。前六后一明恶无不离。七八九三明善无不积。若能如是凡即佛腹。二有十藏前总举其腹。今别明五藏。由得胜行诸佛劝起。一念出生含摄成熟无量德故。十中初三出生三宝。次三成熟三聚。邪定亦有佛性为未来因故。起悲为缘。涅槃云。一阐提人虽复断善。由佛性力未来善根还得生长。即其义也。后四摄授佛果。最后即一切智也。三有十心。即五藏之一最为胜故。五藏主故。即此地能成诸善无功用心。前初地中明心。梵云质多即虑知心。对身口故。今此梵云缬唎陀耶。此云肉团心对余藏故。十中前六自利。于中初二摄善。一勤二策。次二破恶。一破缘二破因。次二成行。一坚二净。次二摄生心。一智令悟。二慈拯救。大梵住即四无量。后二成德。一深。二固。第九被甲下二门明九地行法师入有。备外严故。初门明入地十心。如被甲防内将趣入故。十句可知。二十器仗。器仗破外。以住地心穷十稠外无不破故。十中前五顺仗破障。次三违仗破障。如令贼破贼故。次一非顺非违仗。如以良谋不用兵仗无不破故。后一切成立德仗。第十十种首下十三门。明十地行十地德圆故。寄六根四仪业用明之。且分为三。初一总标德首。次六六根胜德。后六四仪成规。今初居受职位首出众圣故。十中初三果首。次三标之以因释之以果。后四直明行首。第二十眼下六门明六根。即分为六。初明十眼者。即大尽分中。如实知见一切法故。十中前五名同诸教。而体用不同诸宗。肉眼见障内色故。智论三十七。说肉眼见近不见远。见前不见后等。天眼方见远等仍有分齐。今肉眼见一切色。已过二眼故。四十四自指云。不思议经应见远。此中不说。然天眼是假和合不见实相。今明见心即似同于彼。然心通性相则亦不同。此中慧眼似彼法眼。此中法眼似彼慧眼。所以互者。以彼慧眼。不能见众生尽灭一异。不能度生。今显实过权反此明能。彼中法眼虽知于法。不能遍知众生方便道。今反此故明知一切。意欲异权故耳。彼佛眼细无不知。今举胜况劣。又十力无不该故。后五中智眼见事。即法眼开出。光明眼通身智光。义兼法慧。出生死眼者。然涅槃不可见。绝见方见见圆寂故。无碍眼者。总见诸眼境皆无障故。此即一眼具多为不坏相故。须列十眠。一切智眼即是普眼。非但见法界重重。亦乃法界即眼故。为普门故。知十眼全以无碍法界而为其体。若辨次第。以肉眼见生受苦。次以天眼了知其心。次别知根境。次引入如实。次令得佛力。次寻光而见。次同归寂灭。后等同法界余如别章。二十耳者。然眼等六根由得解脱神通无上。见闻嗅触等。皆自在故。总就行辨。此门亦即释名分中。闻持如来大法雨故。初二离顺离违。次二弃小欣大。次二愍苦厌乐。次二满果圆因。后二了俗同真。悲智俱运。三有十鼻嗅行香故。于中初四闻香体。俱舍有四。总名为香。一好香谓沈坛等。二恶香谓葱韭等。三等香。四不等香。谓于前二增益依身。名为等香。损减依身名不等香故。亦不离好恶。今此中俱闻闻其上二。更无别体。非香非臭对前成三。谓如柴炭等。次三闻香表用。瑜伽等中上二界既无鼻舌二识。亦无香味二尘。语其无粗。此闻有顶香者明其闻细。菩萨力故。又有顶言。余处多明是色究竟。准晋经中闻非想香。则有顶言亦是三有之顶。既有通果之色。亦有通果之香。后三闻出世人法。四有十舌演法味故。下三为成六根非显三业。三业前已有故。十中前五约辩显德。后五约用。十降四魔。魔即天子魔。生即蕴魔故。五有十身随行成身故。六有十意。初一总余九别。文并可知。第三六门明四仪动止行。一行者动游行法故。于中令转还者。转有漏定还无漏故。不断生死者。若断非真涅槃故余可知。二十种住者。止息散动故。前七自分住。后三胜进住。三坐者多时安处故。初四世坐以摄物。后六法坐以成德。四十卧者。放舍身心合法体故。十中初三显定。一加行调身心。二习修。三得定。余七定益亦兼余善。然其十事各同卧之一义。初三后二可知。四独已卧故。五离尸伏故。六离依倚故。七思明相故。互警觉故。八右胁卧故。五住处者。智有栖止之所故。前明能住此辨所住。十句可知。六所行处。前辨能行此明所行。于中初四自行。一依四念。阿难四问佛令依住。今辨依行余可思准。十地行竟。大文第六十观察下。五十一门答上因圆果满。若克实而论。成如来力下四门方明果满。前皆因圆。以八相前五犹属因故。为明八相皆示现故。通入果中即分为二。初三十二门明因圆究竟。即等觉位。后十种住兜率下。一十九门明现果圆满行。即妙觉位。前中分三。初一十四门明因行体性。二十种义下八门。明方便造修。三十种魔下十门明因行除障。初中二。初四门起行方便。二十种施下十度行体。前中三。初二门意业观察。次一门身业自在。后一门语业宣畅。前中初观察者解方便故。达通塞故。于中初二观所化。次四观能化法。谓理果教行。后三观位。一超劣。二得位。三同果用。二普观察者审虑周遍故。前六以六度治六蔽众生。后四双明二利。谓顺人证法下化上成。二身业自在中。谓实德内充威德外溢。如师子王奋迅威势。更有异释如法界品辨。于中前五寄喻。次四约法。上皆自分后一胜进。三师子吼者。既勇健无畏则能决定宣唱。二中令物度苦脱集安道证灭故。余并可知(已下五十八经)第二十种施下十门。明其行体。于中先明六度。后显四等十度之义。已如前释。皆言清净者离蔽障故。不同世间施戒等故。然皆寄十表圆。各为一义。与九三施等开合不同。若具会释恐厌繁文。故随显直释。今初十施者。一无向背施。即清净施中别义。二遂求施。三二世乐施。梵本中名应时及济难。不失益故。余七皆一切施。四即观其可不。有损不宜等。极贫下者应先施等。五不希异熟亦清净施。六亦难行施。所爱重物无恋着故。七内外财等无不舍故。八九与十皆巧慧施。此回向巧治二过故。一观诸行性不坚牢。治于当果有为见胜功德。二由具大悲治于二乘趣证无为。故行不住道而向菩提。九益生施。常以财法施之故。名不舍。十忘相成度。然其十度皆有三轮而义有小异。如瑜伽说。此上十施皆通三施。二十戒者。前三律仪七十摄生。余皆摄善。又四即广博戒。五回向戒。上二皆一切种戒。六持微细故。即难行戒。七令他悔除即善士戒。八轨则具足所摄受戒。一切恶止善行故。九永出离戒。上二即清净戒。十令他得二世乐戒。三十忍者初三耐怨害忍。忍他三业恼害故。次三安受苦忍。初后忍不称情中。一忍身苦以济物。后二谛察法忍。七八通后二忍。又四难行忍。于下能忍恕不逮故。五亡身济难。六忍己顺他皆遂求忍。余如前判。四十精进中二。与第十是饶益有情。五是被甲余皆摄善。又初三三业即精进自体四离染法五引白法。上二一切门精进。六无所弃舍及无所退减。七无下劣。八无颠倒及勤勇加行。上三即善士精进。九平等相应。即一切种精进。上皆自分十即胜进回向菩提清净精进。五十禅中初五方便。次一正定坚成。次二发慧断惑。上八现法乐住禅。九利益众生禅。十引生功德禅。又五六奢摩他品。七毗钵舍那品。上三一切种禅。八无爱味及慈悲俱行故。不舍欲界并善士禅。九虽发通明而利众生。十能速入佛境皆难行禅。六有十慧初三解法即加行慧。次四摄生即后得慧。后三证理即正体慧。又前五于所知。如实通达慧。六于五明处及三聚中决定善巧慧。七知能引义利慧。谓同佛差别智故。非凡小所知。上皆一切慧。八难行慧。达深无我于境无碍故。九具教具行慧。十具证智慧。上二即善士慧。余义如十行品所引。第二四门明四等者。六度多明自利。四等多约利他。然四等于境有别。已见十地。今文从通但约于乐等。以为显别。今初明慈。前八众生缘九十文显然。瑜伽四十四三缘之中。初共外道。次共二乘。后方不共。此中三缘皆不共凡小。如文思之二有十悲前七众生缘。次一法缘后二无缘。于中初伤其真隐故。为显后念彼不知故令悟。三有十喜初四众生缘次三法缘。后三无缘。四有十舍文列十一。晋本初二但合为一。于中初四众生缘。次六法缘后一无缘。上明行体竟。第二十义下八门。明造修方便行。于中前五门明自分行。后三门明胜进行。前中初二明法义。次二说福智。后一显圆足。今初以彼法义成行故。若以能诠为法。则以所诠为义。今此不取能诠为法。然法约自体义。是所以法总义别余如九地。四无碍中辨。今初十义。一以修行为多闻之义。意在于修不在闻故。净名亦云多闻是道场。如闻行故。二思为法家之义余仿此。知法即事法余八理法。理法所以在于证入。二有十法法有二义。一持自性。二轨生物解。今此前七通二。八九唯自性。后一唯轨生。乌波提者此云有苦。即二乘涅槃。佛性论第二说二乘无余尚有三余。一无明住地惑。二无漏业。三变易苦故非真无余。今以涅槃为安乐义。略举有苦故应舍之。轨令众生不应修此。第二二门明福智者。福智即道成福智缘名助道具。如云三宝不断。是福劝众生发为缘等。又具二庄严方为正道。偏语皆助斯则福智。即助道具。又以正道福智相绝故。故文中说法布施。皆即是福非福缘故。今初福德中二顺回向因。七不杂小善。回向于果余可知。二智慧具中。一外近善缘。二内调法器。三念慧安处。六念自持。六和众法并见上文。六坚顺位。本业上卷。以三贤十圣等妙二觉为六。谓信坚法坚修坚德坚项坚觉坚。亦名六忍。谓信法修正无垢一切智。复名六慧。谓闻思修无相照寂寂照。复名六观。谓住行向地无相一切种智。即亦六性。谓习种性等。一切诸佛无不入此故。常随顺十种智者。谓法智比智他心智世智四谛智尽智无生智。若开如实异前。则有十一智。今以如实贯上故但说十。如智论二十六辨。由念成智故为方便。四法乐怡神。五真实修行。六自他双净。言三觉者欲恚害也。七遍观法性界。如毒蛇者。净名涅槃。皆以四大为毒蛇性违害故。今居蕴入之中义当十八界。以四大即内界故俱舍云。大种谓四界。今取总中别义。亦可。十八界皆不可执取。处如空聚者中无人故。并如涅槃二十三说。八深解二空无心已下。明其法空。九止观双游。于中先总修止观。后心意下双释二门先释止。欲取我相为我想。正计为我业。正损法身为疮疣。余过未灭为瘢[病-丙+(一/艮)]。能所忍寂故无来去。后观一切下释观。说虽先后运在一时。十修集种智谓见法从缘。则知国由心现。国由心现故有而即空。空为法性万法由生。见法性源是真智慧。皆离妄垢并云清净。五重积集一切智圆。第三明足者。总显圆足惑闇斯亡。智解斯显故称为明。足有二义。一智圆备故。二有进趣故。其犹脚足。斯即十号明行足义。果称圆足因为脚足。又准涅槃十八以明为果。所谓菩提以行为足。谓戒定等广如彼说。此居等觉义通二足。望脚足义。此门亦得名为胜进。十中前七约行。后三别举。三明自分行竟。第二有十种求法下三门。明胜进行。一更求法要。二得已明了。三如说修行。今初依此成行故。一始心唯直。二中后无懈。三内不顾身。四外亡名利。五双圆二利。六得意亡言。七果不近求。八因酬所为。九普决疑惑。十唯满佛乘。离此十求皆邪求也。二明了法者。得不照达求之何用。总以普贤胜智。了知三乘凡圣差别。一是凡夫。若童稚蒙昧未能出世故。随世俗长四善根。二谓钝根随信他言而行道故。名随信行。三是利根由自披阅契经等法而行道。故名随法行。然今既云觉法自性等。即知十中前九亦兼含大。是以智论明有三乘共十地法。此上二人约根分异。四第八人者。即初果向。又俱舍贤圣品中疏云。第八人者。谓苦法忍。八忍之中从后数之为第八故。又智论中有八人地。若约超断容具二三果向。谓具修道惑及断。一至五皆初果向断。次三向二断九乃至八地惑尽至苦法忍。即为第三向也。五初果法断众结者。谓三正三随已如十地亦可。见所断惑八十八使。名为众结由见谛理断无明漏。无明是生死根本。名生死漏。六一来果。观欲味过患已断六品。虽三品惑能润一生故。一往来而知无往来也。七不还果断九品尽故。不还欲界。乃至八地惑皆断故。总云不乐三界。八无学果。八解脱者。一内有色观外色解脱。二内无色观外色解脱。三净解脱。初二如次依初二禅。三依四禅。次四无色为四解脱。八即灭受想解脱。余义已见上文。广如诸论。九十可知。三修行法者。如说修行方得佛法故。常为诸天者为字去声故。晋经云觉悟诸天余并可知。上来造修行竟第三有十魔下十门。明离障行分二。前五门明离障成行。后五门明离障加持。前中分三。初二门明所离障体。次一门明离障方便。后二门显见佛成行。前中初显魔体后辨魔因。今初十魔能障道故。一蕴魔者。身为道器体与佛同。岂即是魔蕴。魔之名特由取着。下九例尔。皆以下句释成魔义。是知以心分别万法皆魔。何但此十。故举菩提法智以胜况劣。不以心分别。一切皆佛岂舍魔界求佛界耶。然四魔直就体明。十魔多约执取。十表无尽故。与四不同。若欲摄者。除三同外皆烦恼。摄法即所证智是能证。能所冥合故名菩提。若不舍于分别菩提之见。即是魔矣。余文自显。二有十魔业者行此十事。皆能讹善亦招天魔。故为其业。十中一由忘行本。令所修善感生死果。不至菩提。故是其业。二于蔽度不平等故。于中初二蔽俱行度。后四嫌弃有蔽之人。文影略耳。夫真道者。不施不悭不戒不犯。不忍不恚不进不怠。不定不乱不智不愚。嫌他不忍忍度岂成。他皆仿此。又悲化恶故。况恶为善资不爱其资。是大迷也。余八易知。然观此文难免魔业。愿诸后学审此省躬。第二舍魔业即离障方便。对障修治故云舍离。然此十句敌对反前。但略而不次耳。一反第五二反第二。三反第七四反第一。五反第四六反第八。七反第三八反第九救护彼故。九反第十。若得佛加蔽恶息故。十反第六。同一善根岂求恶故。然复欲显随其一善。总反前十或以多善共反前一。令不定执故不次耳。第三二门显见佛成行由障离故。果现行成。于中先见佛。后成行。今初即是果现。此中所见即前十佛。亦是八地十身。十身与此名小不同。已如前会。然此中明见。皆称彼佛而见。如云无著。自属正觉。非谓菩萨于彼不着。若菩萨于此不着。下九岂当着耶。是知皆就所见明见亦不得。半就所见半约能见。一无著者。安住世间故。不着涅槃成正觉故。不着生死乘无住道。示成正觉故名无著。称此而见是见正觉。他皆准此。又无邪慧而不离。故云无著。无正德而不圆故云正觉。则佛见影略。此即总句。下九皆此别义。二乘愿出生故。上文云佛愿力故无不现。又乘此愿能生一切德故。三报即相好庄严身业。即万行之因而深信为首。云深信见故。下善财云。一切诸佛从信心起。亦能令见者信故。四随顺众生住持舍利等故。又随顺众生以圆音周遍三世持佛法故。五涅槃即是化身。化身示灭故名涅槃。深入见者。深入涅槃故能示灭。深入生死故示灭非真。六法身充满于法界故。法界为佛体故。七湛然安住真唯识性。是佛心故。八寂然无依。心言路绝即三昧义。触类皆然。故三昧无量。九平等性智了本性故。本觉真性性本了故。十随自他意无身不受故。依上十见则真见佛。既知十佛总别六相圆融。则亦十见无有障碍。又此十种摄为五对。一所出能出对。二正报任持对。三真常普遍对。四内住外寂对。五体深用广对。如文思之。上十佛十身类此成对。又此十见各有十种。并如不思议法等品。二有十种佛业即是成行。前见佛体今辨佛因。又行顺佛行故名佛业。佛以利生为事业故。十中初总余别。又总别合为五对。一觉导梦化对。二开缠净戒对。犯戒疑悔故为彼缠。令其忏除故名出离戒。有多种出离。亦多总相言之不过二种。一事二理。事随轻重篇聚悔除。理观性空是真奉律。若具二者罪无不离。又如瑜伽九十九有五恶作。即是悔缠。一谓作是思惟后定自责。二诸天呵责。三大师同行责。四恶名流布。五死堕恶趣。亦有五相能除此恶作。谓佛许还净故。由无知等我已灭故。当来无犯意我已生故。已于同梵行悔故。佛说悔除为善哉。恶作相续以为盖故。余如净名第一及随好品辨。三现相说法对。于现相中由如来相从六度生故。除六蔽见此殊胜不希二乘。睹慈善根决知尊胜。住心佛境自失威光故无害等。四降魔护小对。五悲摄双行对。双行中有十一句。初一总明无作四谛。不惊怖者。妄惑本无今有故应惊。妄苦逼害身心故应怖。今皆了本寂即同灭理。故不惊怖。虽了本寂而修福智为能治道。余十一句别中初一约苦。次一约集次八约道。后一约灭文并可知。第二有十慢下五门。明离障加持行中二。初二门内成离障行。后三门外得加持行。前中初门举障。后门显治。今初慢者。恃己于他高举为性。能障不慢生苦为业。然经论中说多差别。且明七慢。俱舍论十九云。一慢。二过慢。三慢过慢。四我慢。五增上慢。六卑慢。七邪慢。今文开十。四五与九具有其名。余七但有其义。前三即慢但约有高心故。故彼论云。一慢者。谓于他劣谓己胜。于他等谓己等。虽能称境以心高举。说名为慢。初一轻人次二慢法。四中自高陵物。是于他等谓己胜。即当过慢过前慢故。五即慢过慢。今言过过者过前慢故。有德应赞。即于他胜见赞不喜。是谓己胜应合赞我故。六即邪慢。谓于无德谓己有德故名邪慢。成就恶行名为无德。恃恶高举名之为慢。自起诽谤即恶行故。七即卑慢。耆旧有德即是彼多分胜。不应执事。即谓己小劣何得事他。八亦邪慢起恶行故。九即我慢我慢所吞故。十即增上慢。新善未起即是未得。不应诤而诤。即是谓得故。其但以曾发下。准梵本应回安于百千劫前深坑之下。彼梵本从消灭。下云不应说而说。言多斗诤发起怨嫌。数行此法应堕大坑。然以曾集菩提心。力得受豪贵自在之力于百千劫尚不见佛。何况闻法。晋及度世大意皆同梵本若但依今释。当堕深坑。语其慢过。终自醒悟。明非长没。若约八慢前三皆是憍慢。亦名傲慢。皆于尊境不肯礼敬。故余如别说。二若诸菩萨下有十种智业。显对治行。谓既识障惑。不令增长。制情从理敬重法行。故名智业。文中初结前生后。文通两段。后何等下。正显并是智之作用故名为业。第二魔摄持下。三门辨外加持行分。二此门所离障。后二门能治行。今初即怨障加持。由内行乖理外魔得便。名为摄持。又行乖理即是魔摄。初二心怠志陜。次二行少解滞。次二舍愿趣断。次二成小舍大。后二舍悲谤法。第二佛所摄下二门。明能治行。由离于邪自然合正。于中先佛后法。今初先结前生后。后何等下正说文显可知。二法摄中前四即四法印。次二总别缘生。次二大小。后二智断。上辨因圆究竟讫。第二住兜率下十九门。明果用圆满行。多约八相显果用者。明是普贤大用之果。不就净土实报处说。又显实报不可说故。又显八相通因果故。长分为十。初一门住天。次一门示没。三一门入胎。四一门住胎。五三门初生。六二门在家。七二门出家。八五门成道。九二门转法轮。十有一门入涅槃。初之二门合属第三。即是八相。今初欲说下生。先明在天所作。一化欲天。二化色天。三化大千。四同类共谈。五为同类说。六善巧降魔。七乐音说法。八诣佛闻法。九供养多佛。十多身益生。第二时至云没名将下生。大乘方便经下卷云。菩萨如其本愿。处兜率天宫。能得菩提转于法轮。非为不能。菩萨思惟。阎浮提人。不能至此兜率天上听受法教。兜率天人能下阎浮。是故下生。一广拔众苦。二遍警有缘。三严刹拣非。四觉诸导从。五密召侍卫。六先告当机。七令辅翼知。八净所生处。九长延天寿。十广现难思(已下入第五十九经)第三正明入胎十事。如有问言。于四生中化生为上。佛为最胜何故胎生。诸经论中。多用初缘以通此问。今明具十以表无尽。一化劣解此通凡小。二摄眷属化生。设有父母等恩养少故。三三时无乱出时无乱。在后初生故。俱舍世品明。轮王唯入无乱。缘觉兼住唯佛三时无乱。以福智俱胜故。瑜伽同此。上之三缘小教亦说。次下四事兼于权大。四演法益物。五乘愿化生。六破胎生慢。谁能于佛恃种族耶七胎障不隔故。令大心同睹。后之三缘唯实教有。八同类共集说智慧藏。为胎藏故。九定力现严。以离垢藏为胎藏故。十兴供闻法。以法界藏为胎藏故。此一是总。八九即法界别义。法界寂然是离垢义。寂而常照是智慧义。又前二是能证。后一所证。能所冥合诸佛生故。又前二不坏小而广容。后一不动此而普遍。如是自在是佛生故。第四微细趣即明住胎十事。初一通现地位。次八明现七相。以处胎为能现故。童子属处宫相故。后一总结多门。并一相中同时齐现。深密难知故名微细。第五十种生下三门明初生相。今初正辨即右胁生时。初一即出时无乱。后一动刹益生中八可知。二现微笑在行七步时故。瑞应经云。菩萨示生即行七步。一手指天一手指地。天上天下唯我为尊。即自誓也。初三自庆。次六庆能遍益群品。谓四无智自憍我能摧故。五昔善今退我能续故。六能为众生良福田故。七见生闻教益不虚故。八伤诸同行不成佛故。九愍诸同会滞凡地故。后一得佛加故。三行七步。谓初生在地十方各行七步。显自在希奇故。七数过三名过三界。随所履地皆现金刚。余并可知。第六童子地下二门明在家同俗行。并处王宫相。童子已在王宫。但此门明幼怀德艺显是超绝。后门贵极无染。以彰德高。今初八云令乐法者。幼而梵行德业殊伦。后见道成必乐其法。余九可知。二正明处宫十中。一化同行。同行处宫故如瞿波。四浊世欣贵故。余八可知。第七出家下二门。明舍家期道行。初明出家后显修行。今初虽能深宫入道而出家者。示斯十意。初二令厌舍苦果。次二欣扬胜道。次二令离利钝集。着常见者。贵常为贵故不出家。着断见者身灭无余。何须出家。既非常断明可修进。云离二边。又非苦乐等。次二显界家系灭。后二显得果同因。二示苦行者。行有苦乐。而遍苦者有斯十意。一为小乘要。谓勤苦方得道故。二示同异道摧邪见故。谓六年自饿无道。后受乳糜方得显饿非真。三一言骂佛六载受饥故。缘如大乘方便经。第二四五浊众生皆有重罪。忧恼覆心不能得道。令彼念言谤佛尚得解脱。况我等耶。即悔除故。亦如彼说。五策懈怠众生故。六令知为法忘饥故。七示着乐非道故。八始末精勤故。九准晋经云。欲令未来众生发精进故。今精进之言合在前句。缺斯一句。十苦行待机者显悲深故。第八诣道场下五门道成证入行。即分为五。一明进趣所安。即从苦行所向于道树。显舍邪趣正故。因圆趣果故。行行后边故。十句可知。二正坐道场明自力安处。初四严处。次三三业现相。观师子座者知将说故。晋经云。观一切佛师子之吼。后三成德。一满自能证明智显惑亡。二受佛所处将契同法界。三大悲同体故能遍加。三有十奇特者。明外感希奇大果先兆故。四降魔者。正觉将显先摧邪故。皆言示者久已降故。魔王多是大菩萨故。无有恶魔能恼佛故。亦如野干。岂能于师子前以振威势。大乘方便经下卷云。若非佛力召来彼等恶魔岂得近佛。魔为欲界尊胜。胜降伏余故。十中一示以德诤。二破魔佛谁愈。三波旬兵众满三十六由旬围菩提树。欲作留难。菩萨住慈悲智慧以手指地。一切散坏。八万四千八部大众皆发大菩提心。故云教化调伏广。如方便经及本行集说。六未免魔者勿懈怠故。七一被降伏。乃至末世翻护法故。余五可知。五有十种成如来力。即正觉现前。前之二门当无间道。此当解脱道。更前二门即方便道。今此十中初一障无不寂。次二因无不圆。次二果无不满。次三德无不普。后二佛无不同故。结名如来也。第九转大法轮下二门明转法轮。道成机熟开甘露门故。于中初门所转法轮体用。后门明转法轮因缘。前中流演圆通目之为轮。自我之彼名之为转。小乘以眼智明觉四行。系于四谛。今显无尽十行。应系十谛以成百行。余如法轮章说。十中初二能转备圆。次二所转深妙。次二生信拔苦。次二因深量广。后二时远益高。二种白净法十事即法轮因。白净法者即所转轮体。谓佛无漏清净法界转入众生心中。成闻熏种子故名为种说应时机言不虚发。还生无漏圣智故。无空过故。摄论中多闻熏习从最清净法界等流生无漏现行。是此义也。亦即前章无碍解脱。所以能种此种者有十事故。初一宿因余皆现因。于中前六德具。后三用胜。前中二三悲具。一内持。二外摄。次四智具即四悉檀。一为人所乐不同故。二第一义应时令悟故。三对治随病所宜故。四世界了世而顺故。第十涅槃谓应尽还源。有斯十意。初二明生死过患。一无常故二无乐故。云非安隐。三明涅槃是乐翻上无乐。以涅槃寂灭为真乐故。四翻色身无常法身为常故。故晋经云。令求常住净法身故。今缺常字。以法身是三德之一性出。自古体无变异偏语其常。今已出缠故名为净。次三句明生死无我不自在故。一一期无常不自在。故云不可转。二别明念念无常不自在。此通变易生死。三即分段不能坚住。亦非自在。八明涅槃是坚即自在我。亦兼常义。九翻有为以明净德。不净者即有为法故。言聚散净者。诸佛菩萨正法名无生起。然是性净涅槃。随缘生死即相之性。方为正法。然涅槃第二翻破凡小四德。通诸佛法故。以如来为我此正显涅槃故。亦就涅槃明我。余并相顺。然常等四德。虽遍通佛法。从其别义各显不同。上以四荣翻枯具遣八倒。十明法尔诸佛常规。上来说分竟。大文第七从佛子此法门下。结劝修学分。于中二。一结义劝修。二佛子此一切菩萨下结名劝学。前中亦二。初举名结义。后佛子若有下劝信修行。二结名劝学中。先显十名。初一约能诠依此生行故名为处。前约所诠行体但云清净行。余九约所诠功能立称。二决彼行义定能感果故。三证所证故。四能证分明故。五有智超胜故。六悲兴万行故。七一一圆融故。八轨则具足故。九即理涉事故。十即事而真故。后应尊重下劝学可知。大文第八从说此下现瑞分可知。大文第九尔时十方下证成分。于中二。先赞法证。后佛子汝已下叹人证。大文第十尔时普贤下偈颂分。总有二百一十五颂半分三。初有八偈七言叹德深广。明说分齐。二其心下百三十一颂半。总示行德略显深广。上二并是伽陀。三从依于佛智下七十六偈。颂前长行方是祇夜。今初分四。初四许说广深。次二举德诫听。次一重总许说。后一示说分齐。第二总示行德中分三。初二颂略标法喻。二五十五颂半托事表法。以明深广。三从菩萨等于佛下。听十四颂即法明行。以彰广大。初标可知。二托事表法中总五十喻。难以区分。今类例相从且分为十。初四偈半二喻明悦物覆荫行。二师子下十偈。摧邪导迷行。师子吼义。法界初说。三有十一偈明高深坚密行。四迦楼罗下六偈。观机照益行。五有六偈自在统御行。六智慧心下二偈包含无染行。七二偈周遍成益行。八如珍宝下六偈。检束修身行。九二偈调御运载行。十优昙华下六偈。外用游处行。第三即法明行中二。初十偈总明深广。许说诫听。后一身能示现下六十四颂。别明深广以酬前许。前中三。初三上同佛觉。次三下超群品。后四许说诫听。第二别明深广中。束为十行。初六偈三业深广行。二菩萨身下五颂。二严无碍行。三有三颂逆顺成满行。四或现行成满下。十颂普门示现行。五四颂时处圆融行。六菩萨知下六颂。知根说法行。七四颂寂用迅疾行。八譬如工幻下十偈。悲不失智行。九有十四偈智不失悲行。谓末后二句不失悲。前皆智德圆满。十有二偈结德无尽行。第三颂长行中二。初有三十九偈颂前说分。后虽令下三十七偈颂结劝修学分。今初颂前六位即为六段。初四偈颂十信位中行。二有四偈颂十住行。三有六偈颂十行。四有五偈颂回向行。五九颂半颂十地行。六有十颂半颂因圆果满行。其初所行二字义属前段。第二颂结劝修学中。然小异前势。分之为四。初一偈结前所说为少。二有三十偈别显德用广深。三有四偈总结深广。四有二偈结劝修行。二中分二。前二十一颂半结约法显行。后八颂半结托事显法。今初分五。初五于刹自在行。二有六颂三业自在行。三过去下三颂明三世间自在行。四有五颂明身智自在行。五有二偈半总结难测。后结托事显法中。或前来所无。或事同义异并可意得。第三总结深广中前二结前已说。后二结末说难穷。四结劝修行可知。离世间品竟

大方广佛华严经疏卷第五十三大方广佛华严经疏卷第五十四

        唐清凉山大华严寺沙门澄观撰

    入法界品第三十九(已下入第六十经)

初来意者。先辨分来。夫行因证立证藉行深。前分托法行成故。此依人入证。亦为远答解脱海故。会品于意不异分来。无别会品故。二释名有三。初分名者。谓依佛菩萨诸胜善友。深证法界故名依人入证。证法在己谓之成德。二会名。约处名逝多林园重阁会。林名战胜。以表依人。园名给孤用表悲厚。重阁之义以显二智互严。悲智并为能证。亦为重义。若兼取城名闻物亦表依人。约法如品名释。三品名者。入通能所。谓悟解证得之名。法界是所入之法。谓理事等别。然法含持轨界有多义。梁论十五云。欲显法身含法界五义故。转名法界。一性义。以无二我为性。一切众生不过此性故。二因义。一切圣人四念处等法。缘此生故。三藏义。一切虚妄法所隐覆故。非凡夫二乘所能缘故。四真实义。过世间法。以世间法或自然坏或对治坏。离此二坏故。五甚深义。若与此相应自性成净善故。若外不相应自性成壳故。上之五义皆理法界。复有持义族义及分齐义。然持曲有三。一持自体相。二持诸法差别。三持自种类不相杂乱。与法义同。族者种族即十八界。上二并通事理。分齐者。缘起事法不相杂故。于中性通依主持业。因唯依主。后六唯持业。心境合目名入法界。始则相违终则持业。入即法界故。三明宗趣者。分会品同既入法界为目。即以为宗。于中三门分别。一约义。二约类。三约位。初中有二。先明所入。总唯一真无碍法界。语其性相不出事理。随义别显略有五门。一有为法界。二无为法界。三俱是。四俱非。五无障碍。然五各二门。初有为二者。一本识能持诸法种子。名为法界。唯识云。无始时来界等。此约因义。而其界体不约法身。二三世之法差别边际名为法界。不思议品云。一切诸佛知过去一切法界。悉无有余等。此即分齐之义。二无为法界。二者一性净门。在凡位中性恒净故。真空一味无差别故。二离垢门。谓由对治方显净故。随行浅深分十种故。三亦有为亦无为法界有二者。一随相门。谓受想行蕴及五种色。并八无为。此十六法。唯意所知十八界中名为法界。二无碍门。谓一心法界具含二门。一心真如门。二心生灭门。虽此二门皆各总摄一切诸法。然其二位恒不相杂。其犹摄水之波非静。摄波之水非动故。第四回向云。于有为界示无为法。而不灭坏有为之相。于无为界示有为法。而不分别无为之性。此明事理无碍。四非有为非无为法界二门者。一形夺门。谓缘无不理之缘。故非有为。理无不缘之理。故非无为。法体平等形夺双泯。大品三十九中。须菩提白佛言。是法平等。为是有为为是无为。佛言。非有为法非无为法。何以故。离有为法。无为法不可得。离无为法有为法不可得。须菩提。是有为性无为性。是二法不合不散。此之谓也。二无寄门。谓此法界离相离性。故非此二。又非二谛故。又非二名言所能至故。是故俱非。解深密第一云。一切法者略有二种。所谓有为无为。是中有为。非有为非无为。无为非无为非有为等。五无障碍法界二门者。一普摄门。谓于上四门。随一即摄余一切故。是故善财。或睹山海。或见堂字。皆名入法界。二圆融门。谓以理融事故。令事无分齐。微尘非小能容十刹。刹海非大潜入一尘也。以事显理故令理非无分。谓一多无碍。或云一法界。或云诸法界。然由一非一故即诸。诸非诸故即一。乃至重重无尽。是以善财暂时执手遂经多劫。才入楼阁普见无边。皆此类也。上来五门十义。总明所入法界。皆应以六相融之。二明能入亦有五门。一净信。二正解。三修行。四证得。五圆满。此五于前所入法界。有其二门。一随一能入通五所入。随一所入遍五能入。二此五能入如其次第。各入一门。此上心境二义十门。六相圆融。总为一聚无障碍法界。第二法界类别亦有五门。谓一所入。二能入。三无二。四俱泯。五存亡无碍。初所入中亦有五重。一法法界。二人法界。三俱融。四俱泯。五无障碍。初中有十一事法界。谓十重居宅等。二理法界。谓一味湛然等。三境法界。谓所知分齐等。四行法界。谓悲智广深等。五体法界谓寂灭无生等。六用法界。谓胜通自在等。七顺法界。谓六度正行等。八逆法界。谓五热无厌等。九教法界。谓所闻言说等。十义法界。谓所诠旨趣等。此十法界同一缘起无碍镕融。一具一切。二人法界亦有十门。谓人天男女在家出家。外道诸神菩萨及佛。此并缘起相分参而不杂。善财见已便入法界。故名人法界。三人法俱融法界者。谓前十人十法同一缘起。随义相分融摄无二。四人法俱泯法界者。谓平等果海离于言数。缘起性相俱不可说。五无障碍法界者。谓合前四句。于彼人法一异无障。存亡不碍自在圆融。如理思之。二明能入亦有五重。一身。二智。三俱。四泯。五圆。谓入楼观而还合身证也。鉴无边之理事智证也。同普贤而普遍俱证也。身智相即而两亡俱泯也。一异存亡而无碍自在圆融也。余可准知。三能所浑融无二际限不分。就义开殊理仍不杂。此五能所如次。及通可以意得。四能所圆融形夺俱泯。五一异存亡无碍具足。如理思之。上来约类辨竟。第三约位明入法界者。准下文中。所入法界大位有二。即因与果。于前人法。无不皆是佛果所收。即如来师子嚬申三昧所现法界自在是也。又于前人法。无不皆属因位所摄。即文殊普贤所现法界法门是也。因中曲有信等五位法界不同。二明能入准文亦二。对前果位。明诸菩萨顿入法界。对前因位。寄显善财渐入法界因果。既其无碍渐顿。亦乃圆融。但以布教成诠寄斯位别耳。次正释文。一品大分为二。初明本会。二尔时文殊师利从善住楼阁出下明末会。亦前明果法界。后明因法界。又前顿入法界。后明渐入法界。又前总后别。总别圆融本末无碍。又前即亡修顿证。是正宗之极。后是寄人修入。以辨流通。通正圆融中后无碍。就本会中长科十分。一序分。二请分。三三昧现相分。四远集新众分。五举失显得分。六偈颂赞德分。七普贤开发分。八毫光示益分。九文殊述德分。十无涯大用分。今初。虽义贯末会。以从处别独判在初。文分为三。初智正觉世间圆满。二在室罗下器世间圆满。三与菩萨下众生世间圆满。今初。言世尊者。梵云薄伽梵。包含六义。如佛地论。一自在义。永不系属诸烦恼故。二炽盛义。猛焰智光所烧炼故。三端严义。三十二相所庄严故。四名称义。一切殊胜功德圆满。无不知故。五吉祥义。一切世间亲近供养。咸称赞故。六尊贵义。具一切功德。常起方便利益世间。安乐一切无懈废故。今举后该初。亦是标人取法。具无尽德故曰世尊。二器世间圆满中有三。一国城。此云闻者。西域记云。昔有古老仙人住于此处。后有少仙名为闻者。于彼禀学老仙。没后少仙于此建立城郭。故取其名。亦云闻物。以此城多出聪敏博达。名闻人物故。即中印度境。二逝多下明林园。逝多者梵音华言战胜。即太子之名。给孤独者梵云须达多。正言赈济无依义云给孤独也。即长者之称。长者仁而聪敏。积而能散。拯乏济贫哀孤恤老。时美其德故立斯称。长者侧金买地。太子施树同成功业。二人式崇共立伽蓝之号。三明重阁即说法之所。表所证法界。体无不周曰大。德无不备曰严。依体起用为重阁。第三众生世间。即辅翼圆满。于中三。一菩萨。二声闻。三世主。初中亦三。一举数。二列名。三叹德。今初。此会菩萨标名乃少。列名乃多者。有所表故。数中欲显五位同证入故。位各十度。一一相融成五百故。第六妙觉是所入故。又表解行者多证者稀故。二普贤下列名分三。初标上首。二列别名。三总结数。今初以二大圣是助化主故。又有所表故。至下当明。二其名。曰下别列中。有十四位。位各有十。其间亦有增减。成百四十一人。名各一义皆有深旨。今且寄表大分为二。前四十一人通表住等四位。后天冠下十位百人。别表十地十度。今初十幢表向行德高出故。二有九威力者。表行能进修故。三十藏表地义如前释。四有十二眼者。表解能照法故。所以不次者。欲表圆融之位无前后故。后十位中如次。别表行布十地十度。一十冠者。初地冠于诸地之首。檀冠众行之先故。又一一位中各具十者。一地之中。具足一切诸地功德故。一度之中具足十度。为庄严故。二十髻者。持戒无垢检束尊高故。三十光者。发闻持光照法忍故。四十又名幢者。焰慧精进超世高出故。又道品伏惑精进伏慢故。五十音者。禅定发生难胜悦机故。六十上者。般若现前最尊上故。七十胜者。远行方便有中殊胜行故。八有十一自在王者。相用不动大愿无碍故。九十又名音者。善慧演法自力生故。十有九人同名觉者。法云受职堕佛数故。智觉诸法无所遗故。然其幢等亦有通义。类释可知。三如是下结数。第三此诸下。叹德有十一句。初句为总。上名以随宜别显。各以一德立名。今德以据实内通。故言皆悉成就普贤行愿。余十句别。于中前六明智用普周。后四明智用离障通为五对。一境遍身多对。穷依近正故。二见用诣实对。十眼离障不往而见。一念契实身心普周。三内照外演对。四智净色随对。五悲深智广对。以即智之悲故于生无翳。无外之智故照同虚空。前对虚空自取净义。今取广义。第二及与下辨声闻众文二。初标数类。后悉觉下叹德文有十句。然此声闻皆是菩萨。欲显深法托为声闻故。所叹德言含本迹。今释为二门。一就迹约小十句。皆声闻德。一得现观。于四真谛善觉了故。二入正性离生。无方便慧已作证故。三所学已穷故云深入。法华云。我等同入法性。即三兽渡河。理无二故。古人亦将上三如次配见修无学。四生分已尽由缺大悲。故自永出。五有为无为之德依佛成故。即逮得己利。六已尽有结。谓九结十使现行离故。七无烦恼碍种子亡故。八心善解脱故。寂如虚空。九慧善解脱故于佛无惑。十明非定性。皆可回心故。信入佛智。二约本门。就菩萨叹故。如来不思议境界经云。复有无量百千亿菩萨。现声闻形。亦来会坐。其名曰舍利弗大目揵连等。广如彼说。明皆是权故。下身子令海觉等观文殊德十中。一觉第一义。二方便已具善能入于无际际故。三二空真理穷其源故。四具足大悲能入不染。方永出故。五依十力等离小见故。六不断不俱方能离故。七已净所知无二碍故。八处乱恒寂了本空故。九佛不共德。虽未证得亦无疑故。十一切种智证信入故。第三及与无量下诸世主众亦先标数类。后悉曾下叹德十中。初一叹福。次四叹悲。于中初句总余三句别。一无缘普应。二护念初心。三誓不舍恶。次二句叹智德。一智入权门。二行护理教。正法兼理护兼行故。上七皆行。八即是愿愿行具故。第九入位。上九自分十即胜进。上序分竟。大文第二。时诸菩萨下请分。众集本为闻经故。文分为二。初标众念请。二如来境下显所请法。今初声闻下如聋盲。此能念者释有二义。一约本迹。就本能念就迹不知。二唯就迹说。意法师云。理处不隔故得同疑。未积大心故不厕其次。此亦有理。犹叶公好龙真龙难视。同居法会同仰法门。所现超伦故如聋瞽。二所念中有六十句。初后三十句是所请法。中三十句但是请仪。其三十请法多同初会四十句法以初会为总。此说将终会同本故。就文分二。前三十句念德难思。后唯愿下三十句。请随机演。以初十句明自体圆着。寄显果海绝言。最后十句明化用普周。令寄言显果。由斯文有影略。理实兼皆请示如初会辨。今初念德中。初十句。正明所念果法。次十明玄妙难思。后十明缘会可了。今初十中。前八摄初会。最初十句。即内行成满德。以如来自在摄彼神通及无能摄取故。一境界者。即所缘分齐故。如出现等品辨。二智行者。悲智无碍无功用行。亦如出现品辨。三加持者。谓胜力任持令有所作。如不思议法品辨。四谓十力等。五即四种十种无畏等。六即师子奋迅等。七所住者即初会佛地。佛所住地故。若别释者。即常住大悲等如不思议品。八谓十自在等。及摄二句如向所辨。广引诸文释义并如初会。后二句即摄初会。次十句体相显著。德前有六根三业。今身合六根及于二业。智即意业心意俱不可知。但以智知故。所以合者。欲显身兼十身故。合六根三业智导故但云智。二一切下十句。明玄妙难思人天莫测。于中初二句总明解行不及。谓智慧不能通畅。心行不能诣证。次五句明三慧莫测故不能成自利。谓初三句闻慧莫测。一妙故不能印持于境。二深故不能晓了于心。三广故不能忍可包纳。次句玄故。修慧不能观察委照。后句融故。思慧不能拣其优劣故。晋本拣择名思惟。在观察上。后三句四辩莫宣。故不能成利他。谓法义不能大开曲示。词辩不能宣明。乐说不能令他解了。三唯除下十句缘会可了中。前四佛力上加为缘。后六自根堪受为因。具此可知。前中初三现缘。后一宿愿。后六中初一宿善。余五现德。于上十句分有分知全有全知。又此十句通有二意。一成上显深。二起后请说。第二请随机演中二。初十一句请随机宜。后显示下二十句请所说法。今初。前云缘会可知。今请以缘随器。于中初三约内心器殊。次一约外类音异。上四通于凡圣。后七多约菩萨。一财等有殊。二地位优劣。三依根除障。四作业差异。五缘境不同。六曾依何德而修。七曾听何法为种。又六宜依何德以化。七宜何广略而说种种不同。皆请随顺。第二请所说法中二。先列所请后如是等下结请。今初分二。前十句请说往因。后十句请今果用。今初此十句中。七与初会名义全同。诸道即彼助道海。此中方便即前智海。即名异义同。彼有乘海无此本事。则名义俱异。以彼通请一切菩萨故。显乘乘不同。今约本师为问故。加本事则乘通诸句。为成十故略之。或本事即是乘海。昔所乘故。余如初会。后及成下十句。请果用中。此十望初会第三十句义即多同而文多。异欲显果用无边。故影略其文。一因圆果成即佛。海二成必演法即演说海。三法诠净国即世界海。四皆为调生即名号海。五双开菩提涅槃之果城。即涅槃防非止恶故。即解脱海。六示生行业为至果之因。即众生海。七遍入机处随机立寿。即寿量海。八为众生田令得常命。即波罗蜜海。檀为最初故。九说诸度为安立世界海之法式故。十三轮变化犹水月镜像即变化海。结请可知。大文第三尔时世尊下三昧现相分。酬前念请示相答故。于中二。先明三昧为能现。二入此三昧下明所现净土。今初无方大用依体起故。故先入定。即以此义先明入定。后集众海。前来诸会为明从相入实。前集后定与此不同。佛自入者表证法界唯佛穷故。不言答者表证离言故。又令目击而自证故。文分为三。初入定缘领前念故。二大悲下明入定因。三入师子下正明入定。就入因中有四种悲。以为入定益物之本。各有二义。一身二义者。一是入定所依之身悲所熏故。二身者体义依义。欲入深定。全依大悲而为体故。二门二义者。一佛有大智大定大悲等门。今欲益生唯依悲门。令物入故。二者定为所入。悲为能入故。三首二义者。一者初义。凡所益物。皆以大悲为先导故。二者胜上义。谓非不用智定之门。此增胜故。四方便二义者。一悲智相导互为方便。今以悲为入定益物之方便故。二者以是即智定之悲不滞爱见。故名方便。方能令物普入法界。又此四悲。亦是从佛向机之渐次矣。此上四悲皆遍虚空。亦有二义。一广周故。二无缘故。第三正明入定者。以定业用从喻为名。言嚬申者。有人云。梵音讹略。具正应云毗实廪多。此翻为自在无畏。如师子王群兽之中自在无畏故。然旧经翻为师子奋迅。且嚬毗二言小有相滥。奋迅之语殊不似于毗实廪多。涅槃二十五中。既云嚬申欠呿。明知嚬申奋迅俱是此言下婆须蜜女。亦云见我嚬申。但敌对而翻为自在无畏。从义而译以为嚬申。曾何讹略故依古德。用此方言释之。嚬申奋迅。俱是展舒四体通畅之状。总相释者。即用之体寂而造极。则差别万殊无非法界。即体之用不为而周故。小大相参。缘起无尽。名曰嚬申自在之义。若别解者。涅槃师子吼品明师子王自知身力牙齿锋铓。乃至晨朝出穴而吼。为十一事故广有喻合。又离世间品显菩萨师子王。白净法为身等。合首足等。与涅槃复异。此文以大悲为身。故知但取义似。未必揩定。今会取诸文。先以十义合彼师子。后依涅槃为十一事。今初谓以同体大悲为身。以增上大悲为首。以即智大慈为眼。纯以智慧为牙爪。大悲方便为振尾。悲为方便居其末故。方便振动义故。总取四悲为足。依此立故。以法界三昧为窟所入证故。以无缘大悲为窟门。入出由此故。以体用无碍为嚬申。舒展自在故。以演法界法门为哮吼。决定宣说一切众生。本与如来同法界故。如此师子随一一毛皆称法界。次言为十一事而嚬申者。一摧破魔军诈师子故。二示众神力十力等力为十力故。三净法界土佛住处故。四为邪见凡夫知归处故。五安抚生死怖群党故。六觉悟无明眠众生故。七为行恶法兽舍放逸故。八令诸菩萨及邪见诸兽。来归附故。九调诸外道及二乘香象。令如聋盲舍憍慢故。十教诸菩萨子息令顿证故。十一庄严正见。四部眷属俱增威势。不怖一切邪党。一切邪党皆怖畏故。又野干随逐师子百年。不能作师子吼。二乘安处法会如聋如盲。五十七中十奋迅义。亦应此说。第二所现净土者。总相而言。即前十一事中净所住处。别相而论具前多义。然此现相云何詶前诸问。令其目击可现证故。云何目击。此净土分具答三十句问。且从相显。此中答初果体十问。所现境界答境界问。四种大悲为众生现。即答智行问。令众证见即答加持问。知是如来威力答佛力问。三昧之用答无畏问。正入三昧答三昧问。净法界土答住处问。令大小融摄答自在问。见如来身遍于法界答佛身问。则见如来大悲方便答智慧问。余二十句集众中答众集。亦是三昧力故。是知能现所现种种境事。无非教体。又二圣开显中广明无尽之用。亦显答相至文当知。就文分三。初结前标后。二于时下严此园林。三如于此下结通法界。二中有二。先正显严即器世间严。后何以故下出严所因。显智正觉世间严。今初有三。一严重阁。二严园林。三严虚空从略之广说。有此三表三缘起。谓严阁显自体缘起严。林表有为缘起。严空表无为缘起。今初分二。先明广处。谓破情显法即事会真故。自内而观广博无际。然不坏事故。自外而观阁外有园。园外有空庄严各异。斯即事理交彻。十方三际无不圆融。林空例然。二金刚为地下。正显庄严。表缘起万德无不备故。其间表法以意消息。第二尔时复以下。明园林严。第三尔时逝多林。上虚空下明虚空严。并显可知。第二出因中先征后释。释即智正觉严。是前为众示其身力佛力。上加文有十句。一慈善根力。二无漏智力。以上二力而加众故。三福威德力。余皆自在神通力。于中一展二卷。三横包四竖摄。五一切即一。六一即一切。七成坏相即余义准思。第三结通法界中二。先结前标后。二所谓下正显严相。言见如来身住逝多林者。住彼彼十方界中之林。此明一会遍一切处如光明觉品。非是彼界遥见此佛。住于园林下诸严事皆尔。现相分竟。大文第四尔时东方下。明集新众分。即远集同证。亦三昧中。令诸菩萨皆来归附。文中三。初别集十方。二通赞德行。三总结集因。今初十方即为十段。段各有十。今初东方。一来处远近。然皆远集者。表证入甚深故。唯初会及此皆远集者。初为所信此为证入。证入于初一合相故。中间随位深浅不同。义似金刚矣。二有世界下。明世界名别。可以义思。三本事佛号胜德王者。福德有于光明遍照。所以为胜。二严无碍自在称王。四主菩萨名愿光明者。于遍照光中主此愿光故。上皆带此佛号者。显是此佛胜德愿力故。五眷属俱来者。对上成主伴故。六广兴云供表因严果故。皆云天者自然成故。七诣佛作礼表因趣果故。八化座本方。本方者表参而不杂故。座表法空阁表空有重显。九冠网严身。以显胜德严法身故。有髻珠者。表一乘圆旨居心顶故。十眷属同坐表主伴同证故。余方十段仿此可知。其间刹佛菩萨之名。本意难定。但可说者随宜。初二及六无珠冠者。盖文略耳。又此等供具非唯表法。并是以人同法。依正因果无碍法界自在之德耳。二南方中供具皆云持者。表修持故。三西方皆言须弥山云者。四德妙高清凉利物故。四北方皆言衣者寂忍惭愧严法身故。五东北方云楼阁者。悲智二利相因显故。六东南方云圆满光者。权实二智无缺行故。七西南方云焰者。以净智慧烧惑薪故。亦表皆想所持不可取故。上之七方兴供表法。通答菩萨神通。下之三段。兼亦别答前来问中后二十句。八西北方十句。皆答前最后为一切众生现诸佛影像。若约表者。为显缘有似非真故。九下方毛孔中十句。答前九问十句。皆言方便海。则通答往昔成就方便。初一句通显所随众生言音。次五句答因中五问。谓二答诸行。此句应显趣求一切智心。以第五明行圆满。此为行初故。三答所起菩萨大愿。四答所净诸波罗蜜。五正答圆满诸菩萨行。六别答所作神通。然问就如来因中。此通一切菩萨。通别之异耳。其助道及出离问。亦是通答。以诸句中皆是助道。并即出离故。余四句答果用中五问。谓七答第一正觉问。八答转法轮。九答调伏众生。其国土一种现净土分通答。十答开示一切智法城。及示一切众生道。以能证是道所证是智故。而皆言音声者。表无言之法假言显故。十上方相好等中十句。通答因问中第十本事因缘。兼答波罗蜜及所入诸地。以十度即是别地所行故。别约初句。答入一切众生所住处。及受一切众生所施。并为一切众生说布施功德。如文思之。其答问中或不次者。以十方齐来诸供齐现。文不累书随方异说。以问次往收无不次矣。又皆言本事者。表三世之法体常住故。由得体用非一异智。以用随体无不存故。德相业用皆自在故。蜜严第三云。金刚藏菩萨。现种种形说种种法。乃至云净所依止入于佛地。如来蕴界常无变异故。若理事别修则不得尔故。不同余处现法体用俱有。过未体用皆无。况于小乘三世有耶。以彼过未有体无用故。第二如是十方下通赞德行中三。初总。次以净智下别。后如是等下结。就别赞中三十四句分三。初五句明上近诸佛德。二于一尘中下十四句。下摄众生德。三一切菩萨神通下十五句。大用自在德。亦名三种三业。今初一净眼见佛即是意业。二闻如来法即净修语业。余三句并显身业自在。第二下摄众生德中三。初微细化生。二知一切众生下七句。明摄众生之智故。末句结云十力无畏。前六别明。一缘集非真故。二随机本质映光有胜劣故。三诸趣思所起故。四随照映质有妍媸故。五想所持故。六无而忽有暂有还无故。三勇猛下五句明摄生语业。于中初句总显决定。下四倒明四辩。第三大用自在德中。初句总明所得。余别明通用。于中三。一三业摧邪勇进通三故。二恒以智下六句。明意业自在。皆权实双行故。一智了三世事慧达三世空。二知法如空空无可诤。而不坏有故不着空。三进无进相故曰无来。四即有而空。五即空而有故云方便。六智入性土。三以自在力下七句。身业自在可知。第三如是等下总结集因。大文第五于时上首下。举失显得分。亦名举劣显胜明不共故。于中三。初明不见之人。二皆悉下明所不见境。三何以下释不见所由。今初。舍利此云鹙鹭。其母目睛明利似彼鸟故。弗者子也。从母立称故标子言。目揵连此云采菽氏。上古仙人山居豆食。尊者母是彼种。从外氏立名。有大神通拣余此姓。故复云大。摩诃迦叶此云大饮光。本族仙人及尊者身。并有光明饮蔽日月。头陀第一拣余迦叶。故云大也。离波多此云室星。祀之而生故。或云所供养。或云假和合。即智论二鬼食人之事须菩提此云善现。生而室空现善相故。阿[少/(兔-、)]楼驮此云无灭。一食之施九十一反天上人间。不没恶趣故。难陀此云欢喜。性极聪敏音声绝伦故。劫宾那此云黄头。黄头仙人之族故。迦旃延此云翦剃种。富楼那此云满愿。具云满慈子。其母甚慈亦从母称。而言等者等取五百。广辨古今译殊。德行缘起如智论及音义中说。第二明所不见境中三。初不见果有十句。初总余别。多同念请果中。初之十句。重阁同空等即是神变。不坏本相即是游戏。余可准思。次亦复下明不见因。即诸菩萨初总明即分齐境界。次菩萨大会下别显会通新旧。入谓身遍刹尘。智入诸法等。普至即新来普诣即此往。皆言普者一横竖遍故。二一即一切故。余句准上诸来菩萨作用中辨。及上离世间品十十所明。后如是等下总结不见。第三不见所由者。然皆废本从迹。以显一乘因果不共深玄。笃诸后学令习因种。文中二。先征后释。征意云。身厕祇园自对尊会。而莫睹神变。其故何耶后释意云。彼境殊胜宿因现缘皆皆缺故。其犹日月丽天盲者不睹。雷霆震地聋者不闻。道契则邻不在身近故。菩萨自远而至。声闻在会不知。文自广释分为三别。初法次喻后征以结成。今初分二。先明缺宿因故。后复次下明缺现缘故。今初分四。初一总标大小善差。二本不修下举劣异胜。三如是皆是下举胜拣劣。四以是因缘下结不见闻。今初有小善根得厕嘉会。大小善异不睹希奇。二举劣中有十八句。前十二句释不见佛果之因。后六句释不见菩萨之因。前中初句总余句别。由不赞等。即是不集见佛自在善根于中二。初二句不赞果故。后九句不修因故。于中亦二。前五句缺自分行。后四句缺胜进行。亦是前明陜心。后显劣心故不能见。二本不得菩萨眼下。释不见菩萨所因。一不见十眼所见无碍法界。二缺无障碍智之因。若但修真常离念。即共二乘菩提之善。法华游戏神通。即闻而不乐。此中乐而不闻余可思之。既本因中不修不见。愿诸后学修见佛因。勿滞冥寂。第三举胜拣劣。言如是等者。指前佛神通等所不见法。普贤智境即是举胜。不共二乘名为拣劣。第四以是因缘下结不见闻。以前缺因。境胜因缘故不能见。于中初后总明。中十别显。谓眼不见心不知耳不闻。本有不证新成不获。无方便不能念观。无后得不能筹量浅深思惟旨趣。分别事理。第二明缺现缘故不见中三初明无胜德行故不见。次何以故下。明住自乘解脱故不见。后是故虽在下结成不见。今初分二。先十句明无胜德行。即是前所不见境。亦即是前宿因不修胜进。四句不修故无。无故不见。初总余别。势力即是加持。余皆同前。后是故于此下。十句显不能见。入有二义前文约证。今约了达余可知。第二明住自乘故不见中。先征后释。以此二段反覆相成故。征以释之。谓何以无如是善根等。由住自乘作证故。亦应征云。何以作证。由无上善根故。所无在前故略不明耳。此段亦同法华。自释心不喜乐。云何以故。世尊令我等出于三界得涅槃证故。释文亦二。先明住自乘作证。后于彼智慧下结成所无。今初十句初总余别。别中一道者。以见修等道断感集故。不同菩萨无住道等。二三行果可知。四观谛智别。谓我空法有。不能我有法空。名无有谛。以证现观名决定智故。无菩萨中道第一义三谛之理。亦如涅槃声闻有谛而无真实。五已证理故。六舍事故。下三句成上声闻行。一内无悲。二外舍物。三但自调。又上十句总为四失。一初句出粗而不出细。但出分段故。次四句得权失实。次三句滞寂失悲。后二句舍生自度。二结成所无即由住自乘故。无前智等亦有十句。但于前一智有十不能。余三昧等例此可知。第二佛子如恒河下喻显。文有十喻。自古诸德。皆将配前所迷佛果十句。唯第九二天一喻。喻上第二如来严好。余皆如次。此亦有理。今解有二。一者随一一喻总喻不见因果等境。以合文中亦言不见菩萨众故。又不喻菩萨之德义不尽故。又合文中多从总合。但言不见如来神变。明通诸句。二者别喻诸德。若全不别何俟多喻。然虽别喻亦通因果。而前九约胜境为喻。谓恒河须弥等喻佛德故。后一就劣法为喻。入灭尽定喻二乘故。于前九中。配所迷菩萨之德。其义则次配所迷如来之德。义少不次。所喻义别至文当知。又第一五十单喻声闻不见。第二三四七。双喻菩萨声闻见不见别。余三佛对声闻论见不见。有此三类者。文影略耳。又唯约声闻说者。十喻皆喻彼无德故。就中初一兼喻有障故。后一兼喻住自乘故。且就前九约胜境为喻。显九种胜德。其后一种总明不共显十无尽。前九德中。一一皆具通别二意。今初鬼对恒河喻。其恒河清流。通喻佛及菩萨润益甚深德。别喻佛神力及菩萨境界德。以此二句为初总故。鬼喻二乘有所知障故不见亦喻不得诸法喜故。言饿鬼等者。生分已尽为鬼。未得无生忍衣为裸形。不得法界行食为饥。不得真解脱味为渴。由此故称为饿。此上并无真道。即是业余行苦所迁。为举体燋然。即是苦余空见为乌鹫。有见为豺狼。于斯作决定解为搏撮。内含大机有真脱分。名为渴所逼欲求水饮身在法会名住河边。不睹神变名不见河。虽睹世尊但见丈六。为见枯竭。无明翳瞙名为业障。即烦恼。余后彼大下合中先合业障。不曾已下合裸形等。第二觉梦相对喻。梦游天宫。通喻佛及菩萨高显广大德。别喻如来游戏神变。二句及菩萨大会已下十一句。喻甚相似。然此下八喻约二乘喻。明其无德亦有通别。通则于一一德不了。皆由前缺因缘故。别则各喻无德不同。此一喻无如是神通故。又不知菩萨如梦故。然合文中。明无如是智眼故者。从通相合故。下数段皆合无眼。文中先喻。后一切菩萨下合。合中二先合梦者自见。后一切声闻下合大会不见。并可思也。第三愚对雪山喻。雪山良药通喻幽邃难见德。别喻亦喻佛境界所悲境故。喻菩萨所住处。悲救众生为所住故。其捕猎等。喻声闻无大悲救众生病亦是无如是境界故。第四伏藏难知喻藏。则通喻秘密难知德。别喻如来尊胜可宝重故。喻菩萨所入三昧。及观察嚬申勇猛供养。如喻思之。薄福喻声闻无如是威德故。第五盲不见宝喻。宝洲通喻迥绝难测德。别喻如来妙行积行圆妙故。喻菩萨受记成熟勇猛可知。盲喻二乘无如是善根故。第六净眼无障喻。通喻智照难量德。别喻如来威德。菩萨法身已下五句不睹威仪喻二乘无如是自在故。第七遍处定境喻。通喻周遍难思德。别喻如来净刹菩萨常光。众色庄严菩萨放大光明网。不见定境喻声闻无如是三昧故。喻中言遍处者于一切处周遍观察无有间隙故名遍处。然喻伽智度俱舍等论。皆说有十今有十二。前八同彼。彼中九名空遍处。十名识遍处。先观青等普遍。次观青等为何所依。知由地等。次思所观由何广大。知由于空。次思能观知由依识。前八依第四静虑。观欲可见色。后二依无色定。瑜伽十二云。何故遍处唯说色触二处建立。由此二种共自他身。遍有色界常相续故。眼等根色唯属自身。香味二尘不遍一切。声尘有间是故不说。无色界中空遍一切处。识所行境亦遍一切。故立此二。今以宗别合空识二。为天遍处。前论所拣。皆容假想称性周遍。加于三事。十名种种众生。身遍处者即前所拣眼等。根色十一。语言音声即前声尘。十二一切所缘即六尘境。则收前香味及法尘境。例此天遍处言。亦可通于诸天。次如来所现下合文可知。第八妙药翳形喻。通喻隐显超世德。别喻如来住持。喻菩萨起变化云德。不睹者。喻声闻无如是解脱故。第九二天随人喻。通喻微妙难坏德。别喻如来严好。菩萨身遍十方。诸行圆满德。不睹二天喻二乘无如是势力故。亦喻无悲舍众生故。第十灭定不行喻。唯喻声闻。安住自乘证实际故。亦总喻无德。又上十喻。从后逆次配前缺因。后之十句谓一喻无法喜。二喻不知菩萨如梦。三喻不从如来加被之所生等。如理思之。其前十句。但通为不见之因。第三何以故下征以结成。文有十句结前十喻。唯第七八为顺前合故有前却。余皆如次。上来法喻广显声闻不见闻等问。般若经明声闻若智若断。皆是菩萨无生法忍。若是其忍。何以上文。皆言无菩萨德耶。又文殊巡行经中。五百声闻闻而不信。法华不轻亦令其闻。何得此中不令闻耶。答为显不共故。故智论明般若有共不共。指此不思议经。不共二乘说故。又大圣化仪其类不等。或令闻不信以为远种。如上所引或以威力令其出会。如法华中五千拂席。或令在会使其不闻。即如今经。然法华渐教之终将收败种故。加令其去笃励在会。使其信受。此经顿教之始为显深胜。留使不闻。令诸后学修见闻种。又复大乘该于小乘。则其智断皆是菩萨法忍小智不知大智故。此云于有无谛作决定解不见不闻。又若已开显即权为实渐。故法华云。汝等所行是菩萨道。若权实相对。则如聋盲非其器故。其犹黎庶以对于王。贵贱悬隔以王收人。则率土之内莫非王人。是以若约普收。即一切众生无不具有如来智慧。况于二乘无漏因果。若校优劣。则权教久行菩萨尚不信闻。况于二乘。二乘上首尚如聋盲。况凡夫外道。既非其分本不合列。为显法胜大权菩萨示为聋盲。是知聋盲于胜有力。能显胜故。胜劣相望力用交彻。成大缘起方是深玄

大方广佛华严经疏卷第五十四大方广佛华严经疏卷第五十五

        唐清凉山大华严寺沙门澄观撰

大文第六尔时下偈颂赞德分。既至咏德显所证故。文中十方菩萨。即为十段。初二赞道场三昧等用。余八通赞佛德。今初。东方总赞一会。十颂分二。初总余别。别中亦二。前四叹佛。于中初二叹内德。一广二深。次一叹内外无碍。后一结成今用。后五叹菩萨。一总显云集。二愿行深。三超下位。四智地高。五定用广。第二南方唯叹菩萨。然既结归佛力。亦为叹佛。十颂分五。初二令观内德。于中初偈二严究竟。后偈定智广深。次二示其集处。次三明寂用无碍。初一偈半即寂。后一偈半起用。次一结归佛力。后二结其德广同诸佛故。第三西方下唯叹佛德。然虽通诸德随多显名。今此叹智用应时德。十颂分二。初三法说。一内德。二外用。三总结离言。后七喻显。一喻前广大。二喻圆满。三四喻现通。一长时。二无碍。五喻演法。六喻摧邪。七总喻前德诸佛同依。第四北方十偈。九喻叹三德深广。于中二。前五偈四喻喻内德。一恩二断。次三喻喻智。前一高远。次二深广。后五喻大用。一巧示。二随欲。三照机。四合理。五结益。第五东北方法界。愿月王十颂。叹普益众生德分四。初偈总喻见无不益。次三别明益菩萨。初一净二障。后二成妙力。三有五颂明益周遍。一成道遍。二神通遍。三示行遍。四了法遍。五转法遍。四有一偈结益周普。第六东南方十颂。叹大用难思德分三。初三明凡小难思。次四出难思之法。后三显能知之人。第七西南方十颂叹智身难思德分四。初一总显难思。次一举因显果。次三别示难思之相。于中三。初三智照净障。次一示现深广。后二念智圆融。四有二颂结劝。谓从不思议生佛智身。令绝思议之念。是思佛矣。第八西北方十颂。叹佛成就菩萨德分二。初总标观成决定。余九展转成益。于中前七偈各一行。后二总结深广。第九下方菩萨叹佛难见闻德分二。初一标名难闻近必断疑。余别显益物之相。于中初一生福益。次二向菩提益。次二成智益。余四就人结益。第十上方菩萨叹佛恩深重德分四。初二总举佛德意在于恩。次一恩深难报。次四发荷恩之心。后四释成荷恩之意(已下入第六十一经)大文第七尔时普贤下普贤开发分。现土显于法界普贤主此方能开故。于中长行与偈前中。三初明开发意。二能开方便。三正明开显。今初观众会者。上佛入定现相。令众睹亲证。今假言开显使寻言契实。二以等法界下明能开方便。有十一句。初句总以含事理深广故。句初以字贯下十句。谓嚬申三昧业用深广。要以此十无分齐之方便。方能开显。况十复表无尽。余句别。虚空明其广无际限。余八显其多无分齐。光影一种兼显深义。如光影清净故。又映光之影随机别故。拣异水镜似本质故。三为诸菩萨下正明开显分三。初总标。次征释。后总结。今初。以十法句者。此法望前方便。即是所用。望三昧境界即是能开。二何等下征释。释中一一法句。皆用前来十种方便。一一方便皆能演斯十句。然此十句所开即前所现。亦念请中果用十句。文少开合不次而义无缺。初二即净佛国土。一依正净。二法流布净刹成坏即土。佛于中兴明是佛土。前念欲知佛土之相。今明一切佛刹尘中皆有佛土。土无边矣。皆佛所净下诸句例然。皆一毛一尘。即含摄无尽故。次三即成等正觉。一主一伴。五即为一切众生现诸佛影像。六即入一切众生所住处。七八二句通显能现神通即开智城。而境粗尘细为别。九即含前调伏众生等四句。十即转法轮。三佛子下总结。第二尔时普贤下偈颂中二。先说仪意有十句。初四句说仪。后六观其所说。然多同前念请果德难思。余如前辨。二正偈中。颂十法句而开合不次。初偈颂初句。二颂第三。三颂第二。四颂第四。五颂第五。其六七二颂同颂第六。八颂第九句。九却合颂第七八句。十颂第十文并可知。大文第八尔时世尊下。毫光示益分。令寻智光为能证故。文中四。初毫光普示。二时逝多林下依光见法。三其有见者下显见证因缘。四是故皆得下明其得益。今初有四。一标光意。二从眉间下主光体用。表即法界中道无漏正智。方能证前所现之法界故。三世是相相即法界。法界体用互为其门。又通皆为门。若见法界之性相。即入三昧之体用故。三以不可下光摄眷属。差别之智皆入法界故。四普照下明光分齐第二依光见法中二。先明此众普见。后如此会下类通十方。前中亦二。先能见人通新旧众。后悉见下明见法亦二。先见此会遍。法界之尘刹。后或见于不可说下。多类摄化遍周法界。于中分三。初明广大会遍。二或见在天宫下。明遍处不同。并在前尘刹之内。三现种种姓下别彰所现。亦通答前诸所念请。故云种种。第二类显十方。则十方众会同见。于中二。先举此显彼。后如是尽下以彼类此。于中亦二。先举能见分齐。谓彼十方微细大会。并同此会之见。后皆亦如是下。明其所见自在。谓虽广现而不坏本相故。第三明见证因缘。谓顿尔证见非无宿因。然成前为见因。顺下为证因。皆是如来所摄受故。可知。第四明其得益中二。初明因见得法。二尔时诸菩萨下。荷恩兴供前中二。先略明后广显。前中三。一明所入初句为总。言是故者。是前宿因之故。或入下别列十门以显无尽。二彼诸菩萨下。显前能入亦列十门。一解者鉴达分明种种不同。如发心品。二道谓一道。二道乃至无量正道。三门谓无常门梦境界门等。四入谓所证差别。五理趣谓意旨不同。六机法万差并皆随顺。余四可知。即此能入亦是所益。三入如是等下结其所入。谓用前解等入前法身等。前略列十。实有不可说尘数等。二云何下广明得法。先广能入。后其诸菩萨皆悉下广其所入。前中但广三昧一门例余九句。文中三。初句征起。次所谓下别列一百二门。皆从业用受名。并以法性真如为三昧本。随一一事。皆能契实正受现前故。于中前百一门别别业用。后一总相同果。初言普庄严法界三昧者。入此三昧。能令法界普妙严饰故。斯即嚬申现净土之一义。下诸三昧。皆是嚬申大用别义故。以多别入佛之总。诸门别义说者随宜。后师子嚬申者。若不总相分同。无以能究佛境故。三菩萨如是下总结能所。上略列百门。如前之例有多尘数。方能入佛神变之海。三昧既尔。解等九门亦然。文略不结。二广所入中二。先别列。后其诸菩萨具如是下总结。前中有其十德。广前十门别句。而小不次。总句即前三昧结中。一智位高深德。即前诸地。二为诸众生下调生无染德。即三轮严净。三智慧解脱下成满诸度德。四以不颠倒下智力无畏德。虽有四辩意在于智。五善巧下成就昔行德。六普见诸佛下。法身圆满德。七已得自在下色身自在德。八决了下辩才自在德。九得佛境界下三昧神变德。十一一尘中下成等正觉德。第二总结可知。第二荷恩兴供中三。初总。次所谓下别。后是诸菩萨下结。结其所因。由得前十种德故。大文第九尔时文殊下。文殊述德分。文殊主智故光后述德。光本令证三昧。智本为显法界。寻智得理故。述叹林中。又前普贤门以行显理。此则以解显理。解行无二方能入故通明。即以文殊权实无二之大智。普贤体用之理。行此二无二。共显如来三昧之果德。文中二。先述意。二正颂。颂中十三偈。通赞一会三种世间自在之用。分之为六。初二总叹。初一普遍。后一广容。次一偈赞众生世间。即通前诸来及向得益菩萨兴供之事。次二偈赞依正互在。初偈依中有正。后偈正中有正。四三偈述上林空。五有三偈述于正觉依正无尽。六末后二偈总显普收。大文第十尔时彼诸下无涯大用分。开必得益。益必利生。于中二。先总显用因。谓由佛三昧得前三昧。成此悲门故能有用。后于其身下依体起用中。二初别明毛孔世主化。后佛子此逝多林下。通显分身多类化。今初分二。一总明。二或现下别显。于中四。一明能化法。二以如是等下所化处。三以平等大悲下能化心。四或有见已下明所化益。今初。总有二十五门分二。初八门杂明欣厌等门化。余门明十度门化。于中前六门各一度可知。次三门明方便度。次降魔一门是力度。余七门皆智度。前欣厌中已明于愿故此略无。第二化处中二。先结前生后。后所谓下别明及第三化心。第四化益。文并可知。第二通显多类化中二。先明住处化异。结不离逝多林者。明不动而普遍繁兴而恒静。末不离本故。下文殊游行。亦不离于本会。本末事理非即离故。二佛子此诸下明现身化异。于中五。一能化身异。有十二种。初二总余十别。此中多同善财所见。故知善财诸友。即此会之菩萨。二往诣下化处异。三随其下化类异。四或说下化法异。五教化下总结末不离本。上来本会竟。大文第二末会。亦即一部流通略启十门。一总显会意。二会数开合。三会主多少。四定会名义。五二位统收。六五相分别。七圆摄始终。八会主类别。九法界事义。十随文解释。今初。夫圆满教海摄法无遗。渐顿该罗本末交映。人法融会贵在弘通。故非顿无以显圆。非渐无以阶进。非本无以垂末。非末无以显本。非人无以证法。非法无以成人。故前明不异渐之顿。多门而众人同契。此明不异顿之渐。一人而历位圆修。前则不异末之本。虽卷而恒舒。此即不异本之末。虽舒而恒卷。本末无碍同入法界。今托人进修以轨后徒。使大教弘通即斯本意。二会数开合者。若约所摄之机唯有三会。一比丘。二诸乘人。三善财会。若约能所通辨。有五十五会。善财自有五十三故。虽人有五十四。文殊一人四会说故。德生有德同一问答。遍友无答不成会故。若以遍友承前指后。得名会者。善财则有五十四会。是以唯就能化不足定会。若约主伴。成百一十会。至下当辨。若约散说。则佛刹尘数会。尚顺三乘。若约普贤德则无尽会。如普贤结通处说。三会主多少。若以人克定唯五十四。若以会显人则五十七。文殊分四故。或刹尘数。或无尽无尽思之。四定会名义者。此下诸会虽无佛说。以本收末亦得名经。谓文殊滥觞出此会故。诸友皆本会得益。菩萨不离而周故。若尔下文善财应收归重阁。何乃见在菩提场耶。以菩提为诸会本故。所为既终摄末归本。况诸众会不动觉场。五二位统收者。此中诸会不出文殊普贤。略有二门。一相对明表。二互融显圆。今初。略明三对。一以能所相对。普贤表所依法界。即在缠如来藏故。理趣般若云。一切众生皆如来藏。普贤菩萨自体遍故。初会即入藏身三昧故。文殊表能信之心。故佛名经说。一切诸佛皆因文殊而发心故。善财始见发大心故。二以解行相对。普贤表所起万行。上下诸经皆说普贤行故。文殊表能起之解。通解理事故。慈氏云。汝见善友皆文殊力等故。三以理智相对。普贤即所证法界。善财入身故。又云。得究竟三世平等身故。普贤身相如虚空故。文殊即能证大智。本所事佛名不动智故。见后文殊方见普贤故。又理开体用智分因果。二互融显圆者亦二。先以二门各自圆融。谓解由前信方离邪见。信解真正成极智故。依体起行行必称体。由行证理理行不殊。故随一证即一切证。二以二圣法门互融。谓始信必信于理故。能所不二称解起行。行解不二智与理冥。则理智无二。是以文殊三事融通隐隐。即是普贤三事涉入重重。由此故能入遮那嚬申之境故。前本会明二圣开显。序分之中标为上首。余如别说。六分五相者。若意法师及台山论。但随文散释更无别配。光统等师皆配地位。二皆有理。谓随一一位具多法门。岂容凡心不得习求善友之法。故不配有理。然无次位中不碍次位。显位是常规配亦无失。横竖无碍。且依古德配为五相。谓初四十一人名寄位修行相。寄四十一人依人求解显修行故。二从摩耶下九会。十一人明会缘入实相。即会前住等。成普别两行契证法界故。初得幻智后得幻住。该于中间如幻之缘。入一实故。三慈氏一人名摄德成因相。会前二门之德。并为证入之因故。故法门名三世不忘念。则摄法无遗。四后文殊名智照无二相。谓行圆究竟朗悟在怀。照前行等唯一圆智。更无前后明昧等殊故。五普贤一人名显因广大相。始觉同本圆觉现前。称周法界无不包含故。其后四相亦得称为寄位。前三义同等觉故。摩耶慈氏并入重玄门。文殊表菩萨地尽心无初相。普贤义同妙觉。才见普贤便等佛故。今从别义目为五相。此五亦是菩萨五种行相。一高行。二大行。三胜行。四深行。五广行。七圆摄始终者。上寄法显异布之前后。据实圆融一位即一切位。乃至无尽故。所历差别并一中之多。一多同时无有障碍。八法界人类。于中有二。先明类别。谓知识虽多不出二十类。一菩萨。二比丘。三尼。四优婆塞。五优婆夷。六童男。七童女。八天。九天女。十外道。十一婆罗门。十二长者。十三先生。十四医人。十五船师。十六国王。十七仙人。十八佛母。十九佛妃。二十诸神。二显义相有四。一约果摄化。并是如来海印所现。二约因成行。皆是菩萨随力现形。三约义显法。总是缘起法界之人法。四约相辨异。不出菩萨五生所收。一息苦生。如良医等。二随类生。如外道等。三胜生。如善见比丘等。四增上生。如无厌足王等。五最后生。如慈氏等。通即前四。各具五生可知。于中菩萨有六。三处现身。一初文殊信位劣故。唯显一人。二中间渐进现于二人。谓大悲正趣。三位后成满显于三人。谓弥勒等。九法界事义者。通下诸位总有十门。一正报法界。二依报法界。三现相。四表义。五言说。六义理。七业用。八说往因。九结自分。十推胜进。此十门法界同一缘起互融无碍。十随文释。依五相中。今当第一寄位修行相分五。初文殊一人寄十信。信未成位故但一人。余四十人寄十住等位。各有十。谓二从德云至慈行寄十住位。三善见至遍行寄十行。四鬻香长者至安住地神寄十向。五婆珊夜神至瞿波寄十地。今初。信中分二。先明能化发起。二尔时尊者舍利弗下成彼化事。前中分三。初标主出阁。二与无量下别明伴从。三文殊下总显出仪。今初。文殊菩萨本是童子。而前列菩萨。此彰童子者。表创入佛法故。亦显非童真行不能入。故。权实相依悲智无住。名善住阁。从此利生为出非离此矣。二伴从中初一同生。余皆异生。并约通称表法之名以明般若导万行故。随一一类各有众多。故云诸足行等。或缺诸言盖文略耳。余如初会。三总显出仪中。前约无住化生名善住阁出。今约依自利而利他。云出自住处。又前依佛法界流。此依自所证出。二文影略。第二成彼化事中。通有三会。一比丘会。显回小入大故。二诸乘人会。显通收诸权入一实故。三善财会。显纯一乘机一生成辨故。又前二会表居信未久尚不定故。善财信终可入证故。今初有二。一明助化摄大。二正明化益。今初。小乘之智亦助大故。文中亦二。先明睹缘兴念。二时尊者下摄众同游。于中亦二。先总辨摄仪。舍小趣大为出自住处向文殊所。后此六千下别明所化。于中三。初指数辨位。比丘义如常。六千者。表六根性净可入法界故。自所同住者。同居权小故。同住法界故。出家未久者。未证实际易可回故。信心尚微须诱化故。二所谓下列名。三悉曾下叹德。文有十句。初二叹宿因。次七明现德。后一结德属缘。既皆约大乘以叹。明本大器。托迹比丘显收诸类非小乘矣。结属文殊今成其善。非无因矣。第二尔时尊者舍利下正明化益。于中二。先以身仪摄益。则令根熟起欲。二尔时文殊告诸下。语业摄益正授法门。前中四。一示胜境。二得胜益。三诣胜人。四蒙胜摄。今初有三。初标告。二海觉汝可下正教观察。有十胜德。一身相胜。二常光胜。三放光胜。四众会胜。五行路胜。表常依八正故。六住处胜。举足下足无非道场随心转故。七福严胜。常观空有二边。心地之下具如来藏恒沙万德。无心忘照任运寂知而显现故。八林树胜。树立万行严法体故。九自在胜。于我无我得不二解自在。主中为最尊故。十上摄胜。此有二意。一约事心常上摄诸佛法故。二约表。诸佛显扬皆依般若究竟至于一切智。故三尔时下结略显广可知。二彼诸比丘下得胜益。中上既劝观义兼修观益。相可知三即白尊者下明诣胜人可知。四尔时文殊下蒙胜摄于中二。先示摄相。以回观法器故。如象王回者。身首俱转无轻举故。后时诸比丘下。设敬兴愿为后正说之由。第二语业摄益中二。先受自分法。后尔时文殊下受胜进法。前中亦二。先受法。后时诸比丘下得益。前中三。初举益标告。二何者下别示行法。皆言无疲厌者。法门无尽众生无边。取相而修多生疲厌。厌则退堕二乘。若无爱见而修则无疲矣。无疲则佛果非远。况我身耶。十句摄为五对。一内因外缘。二求法成行。三深定妙智。智入三世故四严刹调生。五长时广大。广大亦胜进修也。三比丘若善男子下举益劝修中。亦为五对。一长善离生。二超凡越小。三生家具业。四习果修因。五摧邪入证。第二得益中二。先别明一定。后又即成下通显多门。前中亦二。先明所得定体。言无碍者。略有三义。一能见离障故。二所见无拥故。故云见一切佛境。三一具多用故。虽具此能而无见相。故名三昧。二得此三昧下别明定用。有四。一正明天眼用。二及亦闻下天耳用。三亦能观下他心用。四亦能忆下宿住用。一眼具斯四用故称无碍。二通显多门者。上一定之用既尔。多门无尽例然。此显圆教摄机创立大心。乃得十地之后十通之用。以始摄终故。如发心功德品等辨。第二受胜进法中亦二。先教劝。上但明大心无疲。今令广住行愿进趣普修。后以成就下明展转获益。上来初会竟(已上入第六十二经)第二尔时文殊师利菩萨劝诸下。诸乘人会中四。一结前所作。二渐次下明至化处。三时文殊下显所说法。四说此经下明所益众。就化处中。其城居人多有福德故曰福城。城表防非。东为群方之首。亦启明之初。表顺福分善入道初故。又表福智入位本故。娑罗林者。此云高远。以林木森耸故。表当起万行庄严摧伏故。大塔庙者。即归宗之所。日照三藏云。此城在南天竺。城东大塔是古佛之塔。佛在世时已有此塔。三藏亲到其所。其塔极大。东面鼓乐供养。西面不闻于今现在此处居人多唱善财歌辞。此城内入并有解脱分善根。堪为道器。此表所依法界本觉真性。诸佛同依。故云往昔诸佛曾所止住等。三显所说法。名普照等者。智用宏舒。故云普照。所照深广称为法界。即入法界经也。四所益众中有二类别。初明诸龙。得主教意故云正求佛道。即住海水中堪受得闻。后复有下。摄三乘机得眷属教意故。但云复有众生调伏。不别演说故非别会。自此第三时福城人下摄善财会。亦为十门。一趣求有异。二修入众殊。三示方不同。四见处差别。五遣不遣别。六叹不叹别。七推不推别。八结不结别。九去不去别。十正释本文。今初。有三句。初文殊自往福城。以机尚微故。未发心故。大悲深故。二德云已去善财往求机渐胜故。已发心故。显重法故。三末后普贤知识不就。善财不往。显法界位满无来去故。二修入众殊。唯初信内有三会。四众诸类不同。显创修故。表通收故。住位已去善财一身行别。在已入位希故。三示方不同大位有三。初地前知识多在南方。地内无方。地后兼二。然南者古有五义。初一约事。谓举一例诸。一方善友已自无量。况于余方。余四约表。二者。明义表舍闇向智故。南方之明万物相见。圣人南面听政。盖取于此三中义。离邪僻东西二边。契中正之实道故四生义。南主其阳发生万物。表善财增长行故。北主其阴。显是灭义故。世尊涅槃今棺北首。五随顺义。背左向右右即顺义。以西域土风城邑园宅皆悉东向故。自东之南顺日月转。显于善财随顺教理故。此五义中。初一则通。次一后二地前表之。契中道义地后表之。亦通地前正证离相。地中不以南表。地后显于业用不同地中。后文殊有示无方。表般若加行。有行正证无二故。普贤无方无示表法界普周故。有人唯取随顺一义。非前诸释。谓正明之义出此方故。宁知西域南非明等。况通方之说言旨多含。四见处差别者。三贤未证散在诸处。地上证真生在佛家多居佛会。地后起用亦散随缘。普贤因圆克果还居佛所。五遣不遣者。初之文殊以在最初。表内重起信。前更无遣见。后文殊则般若照极自见普贤法界故亦无遣。中间诸友显缘起万行相资圆满。故皆教遣以指后人。亦显诸友不独己善离摄属故。六叹不叹者。初文殊中。未发心前所以不叹。劝发心已方乃叹之。后二不叹表位满故。离心相故。中间诸友皆应有叹。其不叹者略有二缘。一正在定故。如海幢等。二行非道故。如胜热无厌婆须蜜等。叹违逆化故。无此二缘不叹者略。七推不推者。诸位知识。皆有谦己知一推胜知多。唯初一后三缺斯二事。为显人尊德已备故。而有遣者。令增修无厌法门别故。普贤不推佛者。显果海离修故。佛属本会故。八结不结者。唯普贤有结通十方尘刹。显位满证理周故。余皆反此。九去不去者。末后二位无有辞去。以文殊无身显离相故。普贤位极收尽法界故。余皆辞去。学无常师。成胜进故。十释文者。于摄善财十信行中。文别有四。一四部云奔。二三业调化。三上根随逐。四大圣重教。今初分二。先总明。后时有下别显。别有四众。一优婆塞。此云近事男。谓亲近比丘而承事故。别名云婆须达多者。此云善施。或云财施。余可思准。二优婆夷。此云近事女。亲近比丘尼而承事故。上二并由受五戒。故立近事名。三童男四童女。并可知。而数皆五百者。表五位证入并通此故。第二尔时文殊下。三业调化中二。一身意调机。二尔时文殊师利菩萨如是观下。当机授法。前中亦二。先总调大众为授法方便。故云将说。后复于下。别观善财知其不群。特回圣眷。善财会名因此而立。偏所为故。于中二。先总标。二知此下别显。别中二。先观外缘。后观内因。前中亦二。先别明。后以此事下总结。财多属依善通依正财现是其善相。称曰善财。亦犹善现立称。二又知此下观内因者。此亦称善对上为财。又解心顺理曰善。积德无尽曰财。文有十句。初一唯宿因。信解已去皆通过现。第二当机授法中三。初结前标后。二所谓下别举法门。三尔时文殊师利。童子为善财下结说劝进。就别举中十句。初二约佛因。一积集万行。二念念不断。次七约佛果。于中前三妙用摄生。后四体用圆备。第十句通因通果通理通事。三结说劝进中。结前所说普及无偏。指前因法劝令进修。令发大心求前佛果。令忆宿善使不自轻。余非此机随宜更演。第三尔时善财下。上根随逐同餐妙旨。独颖众流重法随师。说偈求度。文中二。先总序说因。二正陈偈颂。今初。由已发心故。此菩提心为当何位。善财童子为圣为凡。有古多释。一云即地上菩萨。言发心者。证发心也。一云是地前宝报凡夫。但有宿善信根现熟。有云。古不足依。自引安住地神处。众神相谓云。此人已生法王种中。斯文可定。然自为二解。一谓智契法性生在佛家。名法王种。即已入地。二谓据多闻熏习胜解真性成就佛种。名生法王种中。即三贤内种性菩萨。然此师解依于前义。不异初师。依于后义未殊次解。何足异焉。又以此文为证者。则慈氏云。一生净菩萨行。见普贤处等诸佛等。复云何通。无执一文自相矛盾。贤首云。应是善趣信行中人。依圆教宗有其三位。一见闻位。即是善财次前生身。见闻如是普贤法故。成解脱分善根。如前叹德中辨。二是解行位。顿修如此五位行法。如善财此生所成。至普贤位是。三证入生。即因位穷终没同果海。善财来生是也。若尔定是何位。谓以在信是信位。在住是住位。一身历五位随在即彼收。以遍一切故。如普贤位。此之一解甚顺经宗。但更有一理。谓历位而修得见普贤一时顿具。地狱天子尚三重顿圆。何以善财克定初地等。又定初地。言为是未见文殊前耶。为是已见普贤竟耶。一生有增进耶。始末定耶。无得管见以害经宗。二正陈偈辞。三十四颂分二。初四颂。伤己沉溺自勉不能。后三十颂。仰德依人请垂拔济。前中亦二。前二明依果起因。长迷不出故。喻之以城。后二明依因趣果。生死无穷故。喻乘恶乘。又初二迷于苦集。后二失于灭道。今初文也。三有悦情即起惑之处。愚迷三世即起惑之因。魔王即起惑之缘。童蒙乃起惑之者。余皆所起之惑。然三界受生皆由着我起。依我起高而难踰故。六趣门中出入不息。余可思准。后二中初偈失正行邪道。后偈入苦无涅槃。徽者束也。缠者索也。又三股曰徽。四股为缠。盈者缓也懈也。第二请拔济中分三。初十三偈赞人求法。次十五偈赞法求乘。后二偈双结人法。前中二。初六偈对前苦集希垂拔济。后七偈对失灭道冀成行果。皆上三句赞文殊德。偈各一德。后一句正求运济。就后七中初一总求其道。次二求涅槃道。次二求菩提道。后二求见道缘。第二愿轮下叹法求乘中。亦对前恶乘以求胜乘。尚异二乘。况驰骤三界。于中分四。初四求悲智定摄利他乘。次三求十度自行乘。次四求二利灭障乘。后四求运载广大乘。上四即同三贤十圣皆文义多含。可以意得。后二偈双结中。初偈结法愿见。后偈结人请摄。第四尔时文殊师利菩萨如象王下。大圣重教成其胜进之行。文分四别。一略赞略教。二广问广答。三指示后友。四念恩辞退。今初先赞。一赞发心。发心在前长行之中。二赞近友。问行在前偈内。后善男子亲近下。教往近友。云何近友是种智初因。法无人弘虽慧莫了。故下德生中广显其相。涅槃二十云。一切众生得阿耨菩提近因缘者。莫先善友。乃至广说。以为全分等。靡不有初鲜克有终。历事多时故宜勿懈。第二善财白言下。广问广答中先问后答。今初。有十一句。望前偈中文有二势。一前别此总。谓于前悲智等别行总修学故。二前横此竖。悲智等行。位位同修趣入圆满等。从始至终故。就此诸句初二为总故。下诸友中多但举此。谓若学解学行始修终修皆名修学。唯因圆无学果满无修故。又学摄于解修摄于行。二句已收解行尽故。余九句别。一始趣向。二即事造修。三治障离过。四达证分明。五具足获得。六随顺人法。七长时无间。八无余修习。九究竟圆满。若竖配者。谓十住解能趣故。十行正行故。十向普贤悲愿能净障故。初地始入如故。二三四地世出世行皆成就故。五六七地能随世故。八地无功无念无间断故。九地知诸稠林广利益故。十地等觉方圆满故。横竖无碍是则问意。二尔时文殊下答。于中二。先以偈颂别赞别教。后长行内总赞总教。今初。十偈分五。初二偈赞其发心。于中初二句总赞。次三句指其发心之体。即三种心。谓悲以下救智以上求。大愿为主故。慈氏云。菩提心灯大悲为油。大愿为炷光照法界。后三句显发心意乐。谓不求五欲及王位等。但为众生故。二有一偈略教。谓若厌苦趣寂。则大道不具魔小所坏。若能了生死之实息爱见之疲。则摄众魔为侍。不溺实际之海故。一切莫坏三有一偈重赞其发心之德。以为物发心福之胜故。有智之福为福光。凡小不坏之福为威力。能生众福为福处。离障深广为净海。四有五偈广教具答十一句问。初偈答二总句。谓若见多佛闻法则能受学。于解持而修行。次偈答次三句。谓若趣向见佛。成就大愿则能具行。具则行净。次二句答入与成就。谓证入真空而不碍涉有。了达妙有而不迷于空。是入方便。若如是入即住菩提。何行不成。次二句答随顺问。若顺佛学是真随顺。自然顺于一切智法。次一偈答忆念。谓刹尘诸劫相续修行。斯为忆念。后一偈答后二句。谓多时处修则增广圆满。大圣此中总教诸法。显十信中总相信故。下诸善友各别教示。显入位后别修证故。五有一偈结益。第二长行总赞总教中。先赞。但言发心已含前别义后善男子若欲下。教谓但能求友离过则前诸问皆圆。于中先按定上令求友不得犹豫。言善知识者。谓能令于未知善法令知。未识恶法令识。或二字并通。识约明解知约决了。真为拣似。然知识有五。一知识世间善恶因果。而令修断。二厌世乐而欣涅槃。三有悲心相心修度。四以无相慧令物修行。五令无障碍修满普贤行。此五前前非真真唯第五人能行。此是人善友。若约法友。教理行果皆善友也。后善男子求善知识下诫劝。随顺是劝。余皆为诫。设有实过尚取法亡非。况权实多端生熟难测

大方广佛华严经疏卷第五十五大方广佛华严经疏卷第五十六

        唐清凉山大华严寺沙门澄观撰

第三善男子于此下指示后友。于中二。初举友依正。后汝可往下劝往教问。今初。国名胜乐者。次下知识寄当初住。胜过前位是信所乐故。山名妙峰者。山有二义。一寂静不动义。二高出周览义。以况初住。解心创立依定发慧。寂然不动。智鉴无遗彻见果原。下观万类山以表之。登此心顶便成正觉。故曰妙峰。友名德云者。具德如云云有四义。一普遍。二润泽。三阴覆。四注雨。以四种德如次配之。一定二福。三悲。四智。然此德义。就事就表通皆具之。而创出外凡。故以比丘为表。教问可知。第四尔时善财下念恩辞退。庆闻后友故喜跃。怅辞德音故悲泪。下诸善友仿此可知。然后二段。义虽属后文属前会。问大圣有智能演。善财有机堪受。何不顿为宣示。而别指他人历事诸友明此深旨略申十义。一总相而明。为于后学作轨范故。谓善财求法不懈。善友说法无吝故。二显行缘胜故谓真善友是全梵行。如阇王之遇耆域。犹净藏之化妙严等。三破愚执故。谓令不师愚心虚己遍求故。四破见慢故。谓令不观种性不耻下问。遍敬事故。五破遍空执故。谓不唯无求。无求之中吾故求之。六令即事即行宁可少闻便能证入。不在多闻而不证故。七为破说法者摄属之心。我徒我资彼此见故。八为显寄位渐修入故。若不推后。则位位中住无胜进故。九为显佛法甚深广故。善友尚皆谦推。凡流岂当臆断。十显善财与友成缘起故。谓能入所入无二相故。无善友之外善财。则一即一切明善财历位也。无善财之外善友故。一切即一多位成就。皆在善财。由见卷舒自在无碍。上之十义初一通于师资。次五多约资说。第七约师后三约教。思之可知。大文第二向胜乐国下有十善友。寄于十住即为十段。然下诸善友古德科判。从一至十虽皆有理。今略存一二。谓一依辩法师。科为三分。一闻名求觅是加行位。二受其所说是正证法界三仰推胜进是后得位。或分为五分。一举法劝修。二依教趣入。三见已请敬。四正示法界。五仰推胜进。上二并约位科故。取前段指示后友。以属后段方便以后友名属后位故。约义甚善而文小不便。今依意公及五台论。约会科之分为六分。而名小异。一依教趣求。二见敬咨问。三称赞授法。四谦己推胜。五指示后友六恋德礼辞。而诸文多具其有增减。至文科判。今初发心住文具斯六

初依教趣求中见心陟位。故曰登山。智鉴位行为十方观察。情怀得旨为欲见德云　七觉。助道为经七日。忘所住位方为得旨故。见在别山。见则定慧双游为经行徐步。徐即是止。不住乱想故。行即为观。不住静心故。若约事说。即正修习般舟三昧故。二见已往诣下即见敬咨问。于中四。一设敬仪。重人法故。二作如是下。申己发心明有法器故。三而未知下正陈所问。彰己未知请随机说故。问中于前十一句举初略后是经家略。若善财略友云何领。四我闻圣者下叹德请说。有智善能有悲无吝。故应为说。诱谓诱喻。即是教授。以成前解。诲谓诲示。即是教诫。以成前行。下皆仿此。前问但问因圆。此中结期果满。即发心所为。第三时德云下称赞授法。即正入法界。于中二。先赞器希有。后正示法界。今初。先标二难。所以赞者。令自宝固欣闻法故。后所谓下别牒前问。有十一句。初句牒总余十牒别。文小开合而皆案次。一境界即前趣菩萨行。趣通能所境约所趣。二即前行。行则出故。三即前净。四即前入。入即不滞空有广大心故。五即成就六七及八。皆前随顺。其解脱门是能随顺。示所作业即事业随顺顺众生心即逐机随顺。此第八句亦是忆念。念众生故。九即增广。谓不住涅槃是生死门。不住生死即涅槃门。以不住道即能增广。十即速满普贤行。若了为无为非一非异。而无著者则速满矣。亦即为满矣。第二善男子我得下。正示法界即念佛三昧。于中二。先示体相。后普观下明其胜用。今初。先标名。后信眼下释相。今初。自在有二义。一观境自在。二作用自在。决定亦二义。一智决断。二信无犹豫。解即胜解亦有二义。一约为信因于境忍可。二为作用因于境印持。近处为远等。信智相资他境不动。故名为力。即三昧义。二释相中信眼清净。释上解义。谓欲修念佛三昧先当正信次以智决了。今由胜解于境忍可故。于实德能证信心净了见分明。故称为眼。次智光照耀释上决定。谓决断名智。智故决定故。文殊般若明一行念佛三昧先明不动法界。知真法界不应动摇。即是此中决定解义。然约寄位正是发心住体。以本解性闻熏之力。今开发故是决定解。二明胜用中亦是展转释成。于中二。先约内用。后往诣下明其外用。今初。普观境界即信眼用。亦释眼义。以如为佛则无境非佛。故云普观。又若报若化一时观故。次离一切障释清净义。若沈若浮诸盖诸取皆三昧障故。次善巧观察释智光照耀谓于无色相而观色相。为善巧观。后普眼下结成上义。谓信眼普观境界名为普眼。穷如法界名曰明彻。如是离障见如。是谓具足清净一行三昧。一行者一法界行故。二明外用者。以前即用之体。则以无心之觉契唯如之境。不动法界穷乎寂照之原故。能即体之用用无不穷。亦由前胜解于境印持。随心去住。于中三。初明不动而往。二常念下不念而持三常见下明不往而见。于中三。初标次。所谓下别显所见数多。于中三千即一佛刹。而重言佛刹微尘数者。准梵本中脱十字故。应言十佛刹也。后一一方下明所见事别。第四善男子我唯下谦己推胜。于中先谦己知。即结其自分。后岂能了下推胜知多。即增其胜进。今初。一切诸佛境界者。结其所观。横通十力。竖该三世。故云一切。即上普观境界一行三昧。观其法身十方诸佛亦通报化。种种色相兼相海故。次智慧光明者。结其能观。即上智光照耀。次普见法门即总收前二。以结其名。即前普眼明彻。最初善友先明念佛法门者。以是众行之先故。故智论云。菩萨以般若波罗蜜为母。般舟三昧为父故。依佛方成余胜行故。又初住中缘佛发心乐供养故。二推胜中三。先总。次所谓下别。后而我下结。今初。无边智慧即下诸门。及所不说能观之智缘无边境故。清净行者。即下诸门离障之心。而言门者。随其一一入佛境故。二别中有二十一门。各先标名。后释相。并从业用以受其名。准晋经一一皆云念佛三昧门。今略无三昧字。理实应有。古德判此。前十念佛胜德圆备。后十一念佛妙用自在。亦是一理。克实细论。一一皆念体用无碍之佛。又此诸门当文标释已自可了。细穷其旨义乃多含。然其念佛三昧总相则一。别即三身十身。修观各别。且寄三身释者。即总分为三谓念法报化。为观各别于三身中各有依正。便成六观。谓念法性身土为法身依正。念报身华藏等刹为依。十身相海等为正。念余净土水鸟树林为化身依。三十二相等为化身正。又后二正中各分为二。谓念内功德及外相好十力无畏等。为化身德。如不思讥法品为报身德。三十二等为化相好。十莲华藏等为报相好。则成八门。而初法身二门为后六门之体。若体相无碍成第九门。若融前诸门为一致故。于一细处见佛无尽。如是重重成帝网之境。则入普贤念佛三昧之门。今此二十一门。通是后一而随相异。故有多门。与前十门互有开合。一智光普照门。即通法身报化依正。以此门为总故。一切诸佛通于横竖通诸佛国。故云种种严净。如无量寿观经。先观莹彻琉璃之地琼林宝树。及作华藏观者。一一境界无尽庄严。无土之土方为真净等。二即观色相身令见得净故。而标名中念佛门三字。既是通名。令一切众生之言。未知令作何事故。准晋经。应云令一切众生远离颠倒。念佛门义方圆备。三念内德。四亦内德无倒说。授菩萨见佛本为得法故。五通三身依正内德外相。以十方诸如来同共一法身故。一心一智慧力无畏亦然。故皆能随本誓愿化众生故。余等可思。即此亦是一行三昧。随念一佛等一切故。六即第九事理无碍观。以理融事故。随一细境见多神通。唯智眼境名不可见。七八皆约时并通诸身土。而七约所念佛事无断。八约能念时分无间。九双念依正。亦通报化。十念即应而真。过去诸佛安住不涅槃际。未来诸佛亦已现成故。文殊般若云。今佛住世。则一切诸佛皆住。以同一不思议故。又约随相门。即欲念何佛。佛便为现。十一亦即体之用。由了无非佛境故。境境佛现。十二念应。十三亦念应。然上十一境中见佛。或谓诸佛住于境中。今明知诸佛无住故。远离时处之想。则见一日念念而去。十四念报身相好眼耳等。皆遍法界故。十五中念即体之用。前第六微细。显依中有正。此约正中有正故不滥前。十六念劫圆融故。上二皆即体之用。十七念内德。十八十九皆念色相。二十念依。二十一通内外真应等一切身云。如上出现品及上下文然。上就所念辨异。成其十门。若与经文互开合者为门非一。二十一者。盖略说耳。然约能念心不出五种。一缘境念佛门。念真念应若正若依。设但称名亦是境故。故上诸门多是此门。二摄境唯心念佛门。即十八十九二门。十八即总相唯心。是心是佛是心作佛故十九虽随我心。心业多种见佛优劣故。三心境俱泯门。即前远离念佛门。及不可见门之一分。及如虚空门。四心境无碍门。即如初门。双照事理存泯无碍。故云普照。五重重无尽门。即称前第十门而观察故。如微细等门。亦是此门中总意。若约十身各以二门而为一身。后一总显。谓愿智法力持意生化威势菩提。及福德相好庄严身。以念佛之门诸教攸赞。理致深远世多共行故。略解释无厌繁说。三结可知。第五善男子南方下指示后友于中二。初正示善友。后叹友胜德。今初。即治地住善友。海门国者。彼国正当南海口故。表观心海深广。为治心地之门故。比丘海云者。观海为法门。以普眼法云润一切故。表治地中观生起十种心。深广悲云故。后海云比丘下。叹友胜德。于中十句。先一总叹。后善男子下九句。别就益当机叹。句各一义。即预指后说。初一即见竟得益。二即闻化宿因。三即叹发心处。四即闻彼受持处。五六及七皆普眼法门所证。八闻依正庄严。九即显发心之相。至文自见。第六尔时善财下。恋德礼。辞生难遭想故。恋喜见后友故辞。第二海云比丘。寄治地住善友文亦有六。第一依教趣求中二。初依教正观。此明温故。后渐次下趣求后友。意欲知新。又前即学而能思。后即思而能学。然思前犹属前文。谓上来近友。次闻正法。今辨正念思惟及如说修行。即涅槃四近因缘。今以前义属后进趣。后义属前指来。互为钩锁显主伴交参。且从会判属于后耳。下皆准此。今念前中有十一句。初总余别。别中皆云正念观察者。不沈不举寂照变流故。十中一即是前观境自在。二即前作用解脱。三即一行三昧体。及推胜中诸三昧门。四念前种种众会。五即前见佛。六即前十方。七即寿命神通等。八即通观佛遍。九即种种成正觉。十即随种种众生心乐。后趣求可知。第二向海云下见敬咨问。于中三。初设敬。次自陈发心可知。后而未知下咨问法要。于中言愿轮者。愿穷三际无有终始。故对生死以立轮名。余文自显。第三时海云下赞示法界。于中二。先赞法器。后正授法。前中三。先本问。以发心者难故若不发心不堪授法。非法器故。次善财下答。非虚妄故。后海云言善男子若诸下正赞。于中二。先赞因缘难具故。发者为希。后发菩提心者下。显发心相胜故。发者难得。今初。先友赞。后要得下顺赞。事友为缘余皆是因。通有十句。初句为总。即宿植普贤法门成种性故。二具真下别。初得真如三昧智光。名具真实道。此即了心寂照生佛德故。余可知。二显发心相中有十一句。前五即大慈悲心。初二总余三别。次四深心修行大愿尽空界故。后二直心不违法性证果智故。又此十心多同治地自分十心。恐繁不会。第二善男子我住下正授法要。谓观法海睹佛闻法。次前念佛而明此者。显闻法弘传次为要故。于中二。先明修观。后善男子我作是下观成利益。前中二。先托事显诠。二善男子我思惟下欲忘诠求旨。今初。先总标。言十二年者。一纪已周。表过十千劫已入第二住故。亦表总观菩萨十二住十二入故。后所谓下别显皆托事表法。智海十义如十地说。今是悲海。二忘诠求旨为见佛亲因。可知。第二观成利益中二。先明见佛。后得闻法。今初。即见法界无碍依正。于中先见依后见正。前中三。一总标体相。以深观心海法海。则心华行华自然敷荣。无漏性德无不备故。二百万阿修罗下外相为严。三此大莲华下举因显胜。第二我时见彼下明见正报。谓心行既敷。则本觉如来忽然现故。于中先明德相圆备。后又念下因圆用广可知。第二时此如来下明得闻法。所以海中说者。表从悲智海之所流故。于中三初演说。次受持。后转授。今初先总标。普眼者诠普法故。普诠诸法故。得此法者。一法之中见一切故。后开示下别显所诠可知。二我从于彼下明受持。于中二。先总显所持法多。以是一多相即无尽法门故。后善男子下别显持多之相。于中先标长时。千二百岁表义同十二年。后于日日下别显能持所持有十种持。初一闻持余皆义持。二契本寂智方能入故。三于一义中旋转无量故能普入。四地地义殊。故能分别。五威力者普摄在怀故。若约所诠明摄。即以威力摄诸众生。同九地中威德陀罗尼说。六如华开引果。今开发于教引于果故。又华开见实以为庄严。今开发言教见其旨故。七可知。八如空无相而包含一切。显明妙理示法相故。九以多智光聚于一法。则义理增广故。十若海含十德各辨析故。诸持经者应仿此文。第三若有众生下明其转授可知。第四善男子我唯下谦己推胜。谦己结前推胜进后。我唯一海岂得与彼同年者哉。第五善男子从此下指示后友。六十由旬者。修六度行净六根故。聚落名海岸者。是往楞伽山之道。次南海北岸故。然楞伽梵言。此云难往。又含四义。一种种宝性所成庄严殊妙故。二有大光明映日月故。三高显宽广故。四伽王等居。佛复于此开化群生。作胜益事故。然体即是宝具斯四义。名无上宝存以梵音。此山居海之中四面无门。非得通者莫往。故云难往。表修行之住。是入智海绝四句。离分别之道故。比丘善住者身住虚空故。表此住中观一切法如虚空无处所故。亦比丘者。入道未久宜依僧故。又初念佛次闻法今依僧。修三宝吉祥为所依故。第六时善财下恋德礼辞。第三善住比丘寄修行住。文亦具六。一依教趣求中二。先念前友教有十句。初一通念示教人法。次三念前闻佛说法事。次三思入海观事。后三证理治障摄法观修。二渐次下趣求后位可知。第二见此比丘下明见敬咨问。于中三。初见。次时善财童子下敬。三作如是言下咨问。于中二。先自陈发心。后而未知下正陈请问。于中二十句问。文分为三。初十句总问。于法起行故。佛法言通一切行法。于中净治者对治净故。深净者契理遍净故。余可知。二我闻下结前请后。欲显后问异前问故。三菩萨云何不舍见佛下。十句别问行起胜用故。十句中所行各别。于中初三句明不离三宝行。次二句不舍二利行。次二句摄佛依正行。次一句悲智无住行。后二句摄法证入行。皆言不舍者。无暂舍离故。第三时善住下称赞授法。于中二。先赞后授。前中佛法是总。一切智法约智。然唯局果。自然者法约性通果及因。后善男子我已下。授法中二。先总标所得二若来若去下别示其相。今初。无碍有二义。一智慧于境无碍。以证无障碍法界故。二神通于作用无碍由内证故。所以次前明此法者。闻法受持。意令于境无障碍故。显此住中善观众生等十种界故。二别示其相中二。先明修习得法。由一切威仪顺法思修。故能获得。言究竟无碍者。若事若理无少碍故。后得此智下显法功用。于中三。初通明智用无碍。次何以下总相征释。三善男子我以下别明通用。今初。有十二句。初一他心。次四兼三明。谓现未劫事含漏尽故。次四三业化物。次二知时。一知时分。二知流转。案俱舍论。时之极少名一刹那。百二十刹那名一怛刹那。六十怛刹那名一腊缚。腊缚即是罗婆。三十罗婆为一牟呼栗多。牟呼栗多即是须臾。三十须臾为一昼夜。言时分者。西域记第二云。五牟呼栗多为一时。六时合成一日一夜。亦有处说。昼夜初分时等。又黑分白分六时四时等。又准仁王经。九百生灭为一刹那。九十刹那为一念。此则刹那非时极促。以刹那之中生灭唯佛智知故。小乘中略而不说。后一即神足通。二总相征释。以不住不作故无碍也。三别明通用多显神足通十八变相。且分为三。初于空现变。二或一念下十方遍供。三如是一切下现形益物。并可知。言十八变者。一于空行住等即所作自在。二或隐。三或显。四或现一身即卷。五或现多身即舒。六穿度下往来。七入地下转变。八遍身下炽然。九或时下振动。十或时以手下。即众像入身。以高大故。十一或现烧下放大光明。皆悉广大弥覆十方。成上放光起下遍满。十二或一念下遍满。十三一一佛下显示。十四一一如来所有宣说下。施他辩才。由能受持故。十五如是一切下施他安乐。菩提为真乐故。十六彼诸世界下所往同类。十七若有众生亲近下。施他忆念。十八由总具无作通力。故能伏他神通。三段之中具矣。第四善男子下谦己推胜。于中先谦己知一一念遍往故云速疾。现形益物为成就众生。后如诸菩萨下仰推胜进。而皆明戒者。意显上得无碍解脱。皆由持别解脱戒为依地故。非戒不能修治心故。有二十句。初十一句明具胜德戒。一本为益生故。二自行胜故。三具二利故。上三异小。四道共故。五无能令不持故。六定共故。七不失行本故。八顺法不谤故。毗卢遮那经第六云。有四根本罪。乃至活命。亦不应犯。谓一谤法。二舍菩提心。三悭吝。四恼害众生。今此七八不犯初二。无损无浊不犯后二。九缘果智故。十称法性故。十一般若相应故不住三界。次六句明离过戒。一无过失。谓不自贡高言我能持戒。见破戒人亦不轻毁。令愧耻故。二不损恼。谓不因于戒学咒术等损众生。故。三无缺犯。谓具足受持十善业道及威仪故。四无杂秽。不着边见故。五无悭贪浊不现异相彰有德故。六无悔恨。谓不作重罪不行谄诈故。后三显清净戒。一忘能所持究竟净故。二不染六尘故。三无心垢故。第五善男子从此下。指示后友。即生贵住善友。国名达里鼻茶。此云消融。谓从圣教生消谬解故。城名自在。于三世佛法了知修习得圆满故。言有人者。晋经云。彼有良医名弥伽者。此翻为云。演轮字门含润雨法故。以三世圣教法云雨一切故。第六礼辞可知(已下六十三经)第四弥伽寄生贵住。亦具六分。第一依教趣求中二。先念前友教。十句初总。即前所得法门。深信已下皆别起观修。文显可知。后渐次下趣求后友。第二乃见其人下。见敬咨问中三。初见次敬。后而作下咨问。于中二。先自陈发心。后而我下正问。有十二句。初二句总。余十句别。释通横竖。横释可知。竖配十地。一证发心故不退。二不误犯故。三得禅定故。四精进故。五入俗故须总持。六般若现故。七权实双行为甚深义。得观察智慧地故。具足辩才。八无功用方为正念。九力增上故。十智增上故。第三尔时弥伽下。称赞授法中二。先称赞法器。后授己法门。前中二。初审定。二弥伽遽即下敬赞。于中二。先敬。后然后起立下赞。今初。所以师礼资者。以菩提心是佛因故。能广出生诸功德故。故法界无差别论云。敬礼菩提心者。如人礼白分初月不礼满月。以希现故。满月由此故。又发心毕竟二不别。如是二心先心难。是故我礼初发心人。况未说法未定为师。后授己法方升本座。不乖重法。前诸知识而不尔者。为僧敬俗事不便故。后赞中二。先赞发心。后善男子应知菩萨下。赞其求友。前中二。初总赞。二善男子若有下别赞。于中三。初有十句因德深广。斯德终成功归初发。而汝能发是谓希奇。其相多同初发心品。此中亦具深直悲心。可以意得。次则为一切下十王敬护。后则今一切众生界下。外益众生。第二赞求友中。以菩萨难遇而能求能遇。故知善财是深法器。亦预诫求友之心故。解脱处历十二年。不生疲厌。于中二。初总赞机应难得。二菩萨为下别赞善友。于中二。先法后喻。有十三喻。初二喻恃怙。次四喻拯济。次君喻依处。余喻救护。第二弥伽如是赞叹下。授己法门中二。先现通益物。令其目睹。后弥伽于是还升下。升座说授令其听闻。今初。言轮字品庄严法门者。贤首引日照三藏解云。轮有多义。一约字相。楞伽中云。字轮圆满犹如象迹等。二约所诠。尽理圆备如轮满足。三约用。谓妙音陀罗尼有转授义灭惑义。如法轮等。即轮字教法诠示庄严。此释已佳。今更依毗卢遮那经第五。别有字轮品。彼经云。是遍一切处法门。谓菩萨若住此字轮法门。始从初发妙菩提心。乃至成佛。于是中间。所有一切自利利他种种事业。皆得成就。如是初阿(上)字。即是菩提之心。若观此字而与相应。即同毗卢遮那法身之体。谓此阿(上)字轮。犹如孔雀尾轮。光明围绕行者而住其中。即是住于佛位。又阿(平声长呼)娑嚩三字总摄三部。阿字如来部。娑字莲华部。嚩字金刚部随一部中皆有五字。所谓字轮者。从此轮转而生诸字轮。是生义。如从阿菩提字即转生四字。谓一阿字(上声长呼)是修行轮。既已发心必修诸行。二闇字是成菩提轮。既修行已必证菩提。三恶字是大寂灭涅槃轮。即菩提所至。四恶字(长呼)是方便轮。而阿字当中四字绕之。从下次第右旋亦如轮相。举一为例。余字准之。若行者如是了达。则能入陀罗尼门。旋转无碍故名字轮品。种种布列员位故名庄严。余如彼释。其字下深义。至众艺中当广分别。所以次前而辨斯者。前无碍解脱即无相智光。今将入俗兼存有无。寄字表义。又为总持令不失故。既为医人亦以字轮消伏障故。圣教中生宜持字故。第二升座说授。妙音陀罗尼者标名。能分别下显用。此妙音持即前轮字法门。然字即四十二字。音即十四音。谓哀阿亿伊等。以十四音遍入诸字故。出字无尽。若于音穷妙。则善万类之言究声明之论耳。二处互举理实相成。第四善男子我唯下。谦己推胜中二。先谦己结前。言光明者智鉴妙音故。后如诸下仰推胜进。别有十四句。前四可知。五诠深密故。六无余说故。七法融时法故。八胜故。九胜中胜故。次三可知。十三十四即前所得。而言际者穷理尽性故。第五善男子从此下指示后友。住林者方便具足住。众德建立故。年耆德艾事长于人。故称长者。于其身内现无边佛境。定用自在故名解脱。表此住位所修善根。皆为度脱一切众生。乃至今证大涅槃故。第五解脱长者。寄具足方便住分六。初依教趣求中二。先思念前教于中亦二。初十一句思修前法。初总余别。后誓愿坚固下显修之益。二渐次下趣求后友。十二年者。昔云自分胜进。各修六度故。亦显遍观十二住故。亦表不住十二缘故。故云游行。若不住缘则得解脱故。下云得见。第二既得见已下见敬咨问中三。初明见敬。而自庆者。希望多年故。二圣者我已下自陈发心中。先总。后为欲下别陈发心之相。于中三。初欲上穷佛境。二为欲闻一切下。欲罄尽法源。三为欲与一切下。欲齐菩萨行。亦僧宝境。文并可知。三圣者我今下方陈请问。于中亦三。初结前生后。谓结前发心之相。便为请问之端故云以如是心至圣者所。二我闻圣者下赞能诱诲。三唯愿圣者下。请说所疑。第三时解脱下。正示法界分二。初入定默示。后出定言答。前中所以此中入定示者。亦显此位定增上故。文中三。初彰入定因缘。宿善为因表自修故。后二为缘主佛威力表本觉故。文殊念力显信智故。已彰善财因文殊故。二即入下举定名体。谓普摄诸刹在于身中。由唯心之智称性总持。令如体用旋转无碍。故以为名。三入此三昧下明定业用。即普摄等义。于中三。初总明普摄。次种种形下别彰广多。三彼诸如来所有言下。令善财闻见。第二尔时解脱下。出定言告中四。一明起定二告善财下示定名体。名如来无碍庄严者。总有五义。一一切如来各具一切无碍庄严。二一一如来互遍无碍。三一切如来庄严。悉入长者之身。四长者彻见十方佛海。五长者智持不以为碍故。无碍言兼得旋持。不违上文经家所序。三善男子我入出下明定业用。四善男子我见如是下彰定体相。即无来去唯心观故。所以次前显此定者。唯心之观亦其要故。亦显此位知众生界无量无边皆心现故。于中二。一结前所见体无来往。二我若欲见下广显随心见佛体相。于中四。一明随心念佛诸佛现前。二然彼如来下。正显唯心念佛观体。三善男子当知下。以唯心观遍该万法。四是故善男子下结劝修学令证唯心。初中既了境唯心。了心即佛故。随所念无非佛矣。何难见哉。二观体中。初总明相无来往。知一切下释其所由。所以上言普见诸佛又无来去。其故何耶。了彼相虚唯心现故。于中前别显。后结成。别中文有四对。意含通别。谓通显唯心。喻无来往。别喻唯心。兼明不出入等。一如梦对。般舟三昧经云。如梦见七宝亲属欢乐。觉已追念不知在何处。如是念佛。此喻唯心所作。即有而空。故无来去。又云。如舍卫国有女。名曰须门。闻之心喜夜梦从事。觉已念之。彼不来我不往。而乐事宛然。当如是念佛。此正喻体无来往。但随心变。二水影对中。若月满秋空随水而现澄潭。皎净则月影圆明。水浊波腾则光昏影散。有水月现曾何入来。无水影空未曾出去。虽水中见月谁能执持。心之定散准喻思择。三如幻对。如幻非实则心佛两亡。而不无幻相则不坏心佛。正喻空有无碍故。即无来去不妨普见。见即无见常契中道。四如响对。以心为缘而佛响应。佛无分别以佛为缘。而心见佛心何去来。此但总喻缘成之义。后结成唯心故。无量寿观经云。是心是佛是心作佛。诸佛正遍知海从心想生。般舟三昧经结云。自念佛从何所来。我亦无所至。我所念即见。心作佛心。自见心是佛心。是我心见佛。上方摄境归心。下又拂云。心不自知心。心不自见心。心有想为痴。无想即泥洹。是法无可示者。皆念所为。设有念亦了无所有空耳。此即喻中意已具矣。第三心该万法。谓非但一念佛。观由于自心。菩萨万行佛果体用。亦不离心。如有偈云。诸佛从心得解脱。心者无漏名清净。五道鲜洁不受色有。称此者成大道。第四结劝修学中。既万法不离自心。但修自心万法行备。亦遣愚人妄解之失。谓有计云。万法皆心任之是佛。驱驰万法岂不唐劳。故今广明心。虽即佛久翳尘劳。故以万行增修。令其莹彻。又但说万行由心。不说不修为是。又万法即心修何碍心。文有十句。一如彼病人非杖不起。烦恼病重假善相资。二若无法水法芽不生。三对境忘心。即六尘不染。四旧善不杂新善进修。可谓坚固。五违顺不干则坦然宽廓。六寂照内证皎然无瑕。七触境了如无不鉴达。八六自在王性同于佛。开尘发用知见分明。九与佛同如体周法界。十以调生十力察获疏遗。如是修心则圆前佛法。第四善男子我唯下谦己推胜。不住涅槃际生下。当知余文相显。第五从此下指示后友。阎浮提畔者。此洲南际表将邻不退。故亦云所得。般若六度后边故。摩利伽罗。晋经译为庄严。比丘海幢者。业用深广而高出故。正心不动如海最高胜故。第六海幢寄正心住。文但有五。初念教趣求文显可知。第二乃见其人下。见敬咨问中二。先见敬。后善财童子赞言下咨问。今初。小异前来。谓便见其入定体用。即同前文正示法界下诸夜神类多如是。文中有五。一见入定相。二睹定胜用。三瞻敬证入。四所经时分。五睹从定起。今初。此通二定。一即灭受想定。谓无别思觉。七转已息唯第八识持身定。前加行誓愿力故。令于定身起诸业用。若圆教中融摄法界。自在无碍故。业用无方未曾起念。是以六地能入灭定。而起通用住似地故。净名云。不起灭定而现诸威义。正当此也。二者即第四禅。以起用多依彼故。四禅无出入息。亦无觉观。内净喜乐诸思觉故。通表此位心定不动故。又经行地侧。是动之所。而灭思觉者。表即动而寂故。而言侧者不住行故。二从其足下见定业用中二。先别明身分作用处别。后海幢比丘又于其身下。总显毛孔光明业用。今初。总十四处作用不同。总相而明。从下至上渐渐增胜。别则各表不同。一足出长者等者。足有二义。一最初故。多显施行万行首故。二行住义长者行之长故。居士得安处故。婆罗门净行故。成就菩提是利行故。二膝出刹帝利等者。土田帝主屈申自在故。行由于膝故出净行。次前二摄故。说爱语同事。三腰出仙人者。腰谓脐轮之下。气海之间是吐故纳新。出仙之所故。梵本云那髀曼陀罗。此云脐轮。四胁出龙者是旁生故。五于胸德相出修罗者。胸是能生能灭憍慢幻术之所故。又明德相能降魔故。六背出二乘者。背大乘故。七肩出夜叉等者。肩是可畏勇力之所故。又是荷负之所故。为守护业。八腹出紧那罗等者。鼓腹弦歌音乐之所故。九面门出轮王者。布十善令向佛法故。十目出日轮目。等日照故。十一眉间出帝释者。于地居中最尊胜故。中道般若化众生故。令离五欲得净法故。十二额出梵王者。梵王超欲故。次于眉上。又是稽颡请法之所故。十三头出菩萨者最上首故。说十度行并显可知。十四顶出佛者。尊极无上故。文中三。初总显所出身语之相。次所谓下别彰法雨不同。后如是下一句总结。就别彰法雨中。总有三十二种。前十二法雨为菩萨。余为杂类。今初。一普知平等法雨者。略有三等。一始觉同本。无始本之异故。二等诸佛故。三生佛一性故。得此三等则转成妙觉。二普门法雨者下。十法雨即十住者。圆教位中十住位满。便成佛故。此前更无别位。此约以位摄位非一乘宗。余无此说。然此十法皆是劝学。十法已住自分劝胜进故。普门即三世等。十种智慧劝佛灌顶。令其进修。下皆仿此。三令普学法王善巧等为庄严故。四令学知刹动刹等。皆无能坏最高出故。五令学说一即多说多即一等。十种广大深法故名海藏。六令学一切法无相无体等。既一切皆然名普境界。七知众生无边。乃至知众生无自性。皆是自性门。以无边等亦入自性故。八了知圆满三世佛法。皆是随顺世间故。九遍观察众生界等为悲愍故。十诵习多闻虚闲寂静。近善知识等皆为积集包藏于法行故。创治心地故名新学。十一令其勤供养佛。主导世间为摄众生。若作十地等释类可思准。十二即十信菩萨。令普缘如来及普贤无尽境界。而生信心。分明现前进入位故。后为色界下。二十法雨。普为人天杂类。一总为色界众生舍外住内。令得心境无碍故曰普门。二偏语初禅。以宿习多慈而偏己眷属。今令慈普含福无穷。三即他化自在天转世自在。生十力自在。四就他化中分出魔众。魔好摧他自高。今令得慈心法幢摧其邪慢。五随念化乐但污自心故。转令净念。六虽于世乐知足宜生出世之意。七世乐时时称快。不及法喜之欢。八地居之极羡空居为胜。不及福智严法性空。九夜叉性多暴害。故令欢喜于含生。此约对治明喜。前夜摩天约随便宜。十以彼善奏乐音。上德声闻亦为摧坏。今令得金刚智。无所不摧无不圆满。十一彼恃大身而生憍慢。令见法身称法界境。十二彼以净眼观海。意欲吞龙。令以慈眼智光遍照机感。十三随彼善歌。令得即空涉有殊胜世智。十四人王着乐故偏对治。十五龙多恚毒故为说喜。有热沙等怖。说法幢能摧。十六蟒多毒害。又为虫唼食无休故。说内休毒心外苦休息。十七地狱众生身受无边苦。心念无边恶。若以正念三宝为严。则顿脱众苦。十八畜生多痴故。十九焰魔鬼卒互相怖畏。乃至王身。亦有热铁镕铜等怖故。二十诸难者。所谓八难及在人间狱囚系闭等。而多不安故普安慰悉令得入贤圣众会。翻彼难处。后结周遍称性用故。二总显毛孔光明业用可知。上来见定相用竟。第三尔时善财童子一心下。瞻敬证入中十句。初句思人证人法界。余句思法证法法界于中初一句总。谓三昧是体解脱是用。体用合明。二别思彼体。次二句别思彼用。一益生广多。二无思普遍即用而寂故。次二句思前体用所因。一内智净故。二外缘加故。后三句思其胜进。依前体用进益后三故。第四如是住下所经时分。六月六日者。第六住中满第六度故。以法味资神故。身心都忘不觉时久。第五过此已下。明出定者所作讫故。第二正明咨问中二。先赞后问。今初分二。初标赞深胜。后以能除灭下出赞所因。由具此下诸因故。上云甚深广大等。其中云能令增长有为乐者。不舍有为故。出有乐者不染有故。又上句为凡夫。次句为二乘。下云引发菩提。即为大器。第二圣者此三昧者下。正问有二问答。先问名后问用。初中先问后答。今初。上既修入何更问名。其犹世人得大王膳。虽餐胜味何必知名。答有三名者。初一从智立。次一双就境智。后一双融境智立名。普眼舍得者。般若之智照一切法故名普眼。皆无所得故云舍得。若有所得。不能即寂而用。以无所得即无所不得。菩萨无得心无挂碍。诸佛无得则得菩提。昔云障无不寂曰舍。理无不证曰得。非无此理而未造玄。二合称中般若清净故。境界清净。清净之境皆般若境故。三双融立称者。般若了境无境非般若。何所不严。故智论云。说智及智处俱名为般若。是则若般若清净若境清净。无二无二分无别无断故。故一庄严一切庄严。名普庄严。及摄眷属可知。二善财童子言圣者下向境界中。先问后答。问云唯如是者。上所目睹颇已修入视听之外。更希异闻。后答中皆示上来之所不及。于中三。初明于器世间无碍。次见一切佛下于智正觉世间无碍。后大悲摄受下于众生世间无碍。其中见佛亦为摄生故。文并可知。第三谦己推胜中。初谦己知一。后如诸下推胜中二。先举彼所知。后而我下显不能测。第四指示后友中。处名海潮者。但言有处。则犹是前国显方便行不离般若故。言海潮者。谓潮所至处。显方便就机不过限故。亦将入生死海以济物故。能知三世佛法海故。故上法门名为海藏。园名普庄严者。约相广有众严故。约表以生死为园苑。万行为庄严故。又文义相随等庄严总持无漏法故。友名休舍者。此云意乐。亦云希望。亦云满愿。谓随众生意乐希望。得圆满故。亦能圆满性相法故。前般若了真故寄比丘。此以慈心方便入俗故。寄优婆夷矣(已下六十四经)第七休舍优婆夷寄不退住文中具六。第一依教趣求中二。先念前友教文有十句。前五集经者序。后五正陈所念可知。二渐次下趣求后友亦可知。第二见普庄严下。见敬咨问中三。初见次敬后咨。问前中二。先见依报殊胜。有十事庄严。一宝墙围绕。二一切宝树下林树行列。三其地下堂阁崇丽。四一万浴池下浴沼清华。五其中复有百万陂下。映带池流。六园中复有广大下。严敷殿座。即别明善友所坐。先殿后座可知。七园中复有下罗以帐网先帐后网。八有百万大光下耀以光明。九常雨下雨散杂严。十百万天子下凡圣欣敬。二时休舍下明见正报端严。于中四。一正报殊常。二百千亿下十方云仰。三其有见此下业用难测。四尔时善财入下正见身仪。二往诣其所下设敬。三白言圣者下咨问法要。文并可知。第三休舍告言善男子下。称赞授法。略无称赞。但有正示法界。于中四。一举法门体用。二穷因浅深。三显果久近。四彰法名字。今初分二。先总举体用名。下当显用约不空。二善男子若有下别明胜用。于中三。一明益物不空用。先反后顺。见皆不退者。显若得方便至不退住故。二善男子东方下。诸佛被益用。以与三宝同住故。与我住皆悉不空。三善男子我此下引证不空。现与同住皆不退故。亦表方便入俗。则八万尘劳皆成波罗蜜故。二穷因浅深中。先问后答。答中二。先约因缘答。婆楼那者。此云水也。总三十六恒者。近佛既多发心已久。而要言三十六者。显已过前六位。位位具修六度。六六三十六。皆是恒沙性德故云尔耳。涅槃亦有此数。后善男子菩萨初发心下。约心量答。意显发心称法界故。亦等众生。众生亦无初际。从痴有爱。而菩萨发心痴爱无初。心亦无终故。三显果久近中。亦先问后答。答中明无齐限故。不应作久近之问。文中三。初反释无齐限。于中先别明二十四句。初八化生。次六供佛。次四严刹。后六持法。后如是略说下总显。二欲教化调伏一切众生下。顺释无齐限。亦有别有总可知。三善男子菩萨行普入下。总结无尽此同初地十无尽句。众生无尽故。成佛无期。若尔岂都无成耶。因此略辨成不成义。勒为四句。一以向约因缘厚薄。对今无尽则有始而无成。此约悲门得果不舍因故。二以称法界发心故。不见初相方为真成。则无始而有终。此约智说。三悲智合明不坏相故不妨始终。前后诸文其例非一。四约称性之谈。则无终无始故。天女云。但以世俗文字数故说有三世。非谓菩提有去来今。故下大愿精进夜神云。不可以生死中长短劫数。分别菩萨智轮等。喻斯四句无有障碍。欲成即念念成。常成常不成无有障碍。四彰法名字先问后答。答云离忧安隐幢者。此有二义。一以大悲高显所以称幢。其有见者。离业惑苦不退菩提。是谓离忧安隐。二者即智之悲涉苦安隐。即悲之智多劫无忧。双摧生死涅槃。特出凡小之外故名幢矣。第四谦己推胜可知。第五指示后友中。言海潮之处者。但约大悲摄物无失。受童真名故。不异前处国名那罗素者。此云不懒惰。动刹持刹观刹诣刹。无休息故。仙人名毗目瞿沙者。梵言犹略。若具应云毗目多罗涅惧沙。此翻名最上无恐怖声。亦云毗沙摩。此云无怖畏。乌多罗此云上。涅瞿婆此云出声。二译大同。谓常出增上无怖畏声。安众生故。彼住文云出广大遍满音。以童真清洁无漏故。寄仙人表之。第八毗目仙人寄童真住。六段初依教趣求中。初念前友教。有十二句。前二总明顺前解行。后十依前增进胜心。前四约福。后六约智。第二见一大下。见敬咨问中三。先见次敬后咨问。今初分二。先见依报。树名波吒罗者。正如此方楸树。尼拘律者。如此方柳树子以枇杷。余如音义。后时善财童子见彼下见正报。领徒一万者。表万行故。二善财见已下设敬称赞。于中三。先身敬。次言赞。见夷险者。涅槃为夷平。生死为险难。又二皆为险。不住为夷。余可知。后作是语已下重明身敬。将欲问故。三白言圣者下咨问法要。第三时毗目下。称赞授法中二。先称赞法器。后正授法要。今初中四。一总赞发心。示徒众者令敬学故。次善男子此童子下。别赞发心之相。三时诸仙众下眷属敬赞。言险易者。易亦平也。四时毗目下述赞结果。第二时毗目瞿沙告善财下。正授法要。文中有六。初示法名体。童真净智变化自在。高出功用之表所以名幢。相惑不动故云无胜。即此摧惑亦名幢义。二善财白言下征其境界。三时毗目下授令证知。摩顶显加持之相。执手表授与之义。相摄有力故。所见可知。四尔时善财童子为菩萨无胜下。得解脱益文有十句五对。谓为五法照得五种益。能照皆是无胜幢之别名。然初对为总余四为别。展转相生。且初总对。由见彼真智作用。即知是法界体。上寂而遍照故云三昧光明。二即上所得三昧光明。乃是能照之智作用。无尽之寂照故。得所照十方智。总持之明鉴无遗。三即上总持以智为体。坚利圆满由得此故。能令自心障净智明。为寂照之光。四得上净智般若。则无行不严无德不备为庄严藏。此光照心能照如来法性空中包含圆满。正受现前。五上虚空藏轮。即一切佛法圆满寂照。以此照心。则智穷三世无尽法源。此约展转释。若约能照皆是总中别义。则不相蹑义不异前。而其所得即三时中事。五时彼仙人放善财下。明舍加持所作托故。还在本处者。不移本处而遍十方处。既还本时亦多劫。未逾一日故。近远无碍念劫圆融。皆圆教善友法门之力。是以善财一生能办多劫之行。普贤位内或经不可说劫。非但三祇。皆法力加持。不应以时以处定斯玄旨。六时彼仙人告下。明言承领可知。第四仙人言下谦己推胜。第五善男子于此下。指示后友。伊沙那者。此云长直。谓里巷径永。表善知三际故长。善知胜义故直。婆罗门胜热者。于五热中成胜行故。表体烦恼热。成胜德故。不染烦恼成净行故

大方广佛华严经疏卷第五十六大方广佛华严经疏卷第五十七

        唐清凉山大华严寺沙门澄观撰

第九胜热善友寄王子住。义如前释。文亦有六。一依教趣入中二。初证前。后趣后。前中二。初显证所因。后住诸佛下正明证益。于中二。先得自分益。后求一切智下得胜进益。及于趣后文并可知。第二见彼胜热下。见敬咨问中三。先见苦行。四面火聚者。更加头上有日。即五热炙身。今但云四者。四句般若皆烧惑薪故。中有刀山者。无分别智最居中道。无不割故。高而无上难可登故。故智论云。般若波罗蜜犹如大火聚。四边不可取远离于四句。四句即四边。取则烧人离则成智。又火有四义。一烧烦恼薪。二破无明闇。三成熟善根。四照现证理。投身入火者。从无分别智遍入四句。皆无滞故。又释刀是断德无不割故。火是智德无不照故。投身下者障尽证理故。即刀山为能证。火聚为所证故。此火等即是法门。不须别表现所用故。称性事故。此为甚深难解不可轻尔。二敬三问文并可知。第三婆罗门言下。正示法界有六。一示法劝修。二疑惮不受。三胜缘劝引。四疑尽悔愆。五诫劝见容。六依教修证。今初。然刀山不可执。火聚不可取。若能不住无分别智遍入四句。则远离四谤不滞空有何行不成。所以要令入者破其见心。令解菩萨深密法故。顺相易解逆相难知故。此中示于邪见。无厌足王示嗔。婆须蜜女示贪。显三毒相并有正法故。然有五义。一当相即空空故是道。非谓此三即是佛法。诸部般若其文非一。二约幻用摄生。亦非即是如净名云。行于非道先以欲钩牵后令入佛智等。三在惑用心如俗流辈。此在观心为道亦非即道。四留惑润生长菩萨道。亦非即是。如净名云。不入生死大海则不能得一切智宝等。五当相即道。不同前四不思议故。无行经云。淫欲即是道。恚痴亦复然。如是三法中具一切佛法。亦斯义矣。二时善财童子作如是下。疑惮不受非惜身命恐失道缘。示智未深故生此念。文中先明道缘难具。于中离诸难者。非佛前后等。得无难者。非生聋等。具诸根者。谓信进等。后此将非下正疑魔坏。三作是念时下。胜缘劝引中有十三众。各述曾为胜热化益。故劝勿疑。初一即色界梵天多是初禅。文中有三。一总劝莫疑。二今此下彰其本意。智慧坚利犹如金刚。烧诸惑薪发诸智焰。烧而常寂为三昧光。三善男子下自述蒙益。梵王最初。生此余众念而后生。故生邪见。次五欲天。次六杂类。各有复有以为拣别。十三欲界诸天众。然此欲界即是一类。从地狱出者。义通六天及前夜摩四天王。前所不列皆在其中。第四尔时善财闻如是下。疑尽悔愆。第五时婆罗下诫劝见容。上疑为拣其真伪。此劝为显其实德。魔亦能为现劝。何故闻即疑除。以此善友前友指来。况劝中正说非魔能作。善财亦得超魔之眼故。若尔何以生疑。以显法故。如第八地中佛之七劝。纵佛不劝岂容趣寂。又为后代之轨令审察故。第六尔时善财下。依教修证。于中二。初正修证。未至得善住三昧者。上不依山下不依火。正处于空即显般若。离于二边无所住故。名为善住寂静乐。神通三昧者。亲证般若实体。即性净涅槃故。云寂静乐。而大用无涯故云神通。触者。亲证也。故净名云。受诸触如智证。二善财白言下。自陈所得显后得起说。第四谦己推胜。谦己中云无尽轮者。有二义。一智轮摧惑。照其本源无可尽故。二反常智用用周法界无有尽故。圆转不已所以名轮。推胜可知。第五指示后友。师子奋迅者。师子幢王所居。表振动照耀住持世界自在无畏故。慈行童女者。知众生根令其调伏。慈为行故。智中生悲便能处世无染。是谓童女。以学如来十种智故(已下六十五经)第十慈行童女寄灌顶住。文六同前。初依教趣求中二。先修入前教。于中初二句重友解生。次二句念乘思佛。次观法下智证实际。初句能观智。现决定下所证穷极。后于一切佛下离障自在。二渐次下趣求后友。于中初至处。次闻名五百为侍者。以一期位满总摄五位十十法门。互相涉入之法。而相应故。第二善财闻已下。见敬咨问中亦三。初见中先明远见。表得门未证故。后善财入已下。亲睹依正等。二敬三问并可知。第三时慈行童女下。正示法界中二。一令观亲证。并依中见正。小大念劫皆无碍等。十住位终故约报显。二尔时善财下。以言显发于中二。先显法名因。后彰法胜用。前中初善财默请。后童女言答。答中初示名。名般若普庄严者。有二义。一由般若照一切法。依中有正一中有多故。所得依无所不现。般若中云。了色是般若一切法趣色。即其义矣。二由能证般若已具诸度庄严故。所证所成亦庄严无尽。次下显因云。彼诸如来各以异门令我入。此即其义也。总摄三十六恒沙之别。归于普门。则一严一切严故名普严。言三十六恒沙者。住位既满。则六度之中一一具六。故为三十六。皆恒沙性德本觉中来。故云佛所求得。二善财白言下显法胜用。先问后答。答中先总。后所谓下别。总中初明修习契证相应。后得普门下。总明所得业用陀罗尼。以智为体。由得般若普严故能总持万法。一持一切持故云普门。以圆融十住。亦同十地所得无量百千阿僧祇陀罗尼门。又彼总此别。但举一持余三昧等。略而不说。二别显中有百一十八门。略分十位。初八总知依正理事持。二福德下九门明愿行持。三业下九门明业持。四三昧下六门明正受体用持。五心海下五门染净诸心持。六知众生下十门知所化持。七普见十方下十七门知能化持。八世界成下十七门明知刹海自在持。于中言世界转者。晋经云回转世界。九见诸佛下二十五门知佛海自在持。十菩提心下十二门明菩提因果持。自心清净即性净菩提。总摄诸门不出于此。第四谦己推胜可知。第五指示后友。国名三眼者。施为行首复开导自他。如目导余根故名为眼。财施无著成于慧眼。无畏之施成于慈眼。法施开于法眼故复云三。用上三眼见无不善。又施行内成胜报外现。见者皆善故出住之行。故以出家表之。又行本令物得出离故。上明十住竟。大文第三善见已下有十善友。寄十行位。位各一人。初善见比丘寄欢喜行。文亦具六。初依教趣求中亦二。先念前友教中有十三句。初总余别。别分为三。初二约菩萨论深。一所证法界即事而真故。二入菩萨地智唯证相应故。次有七句。约众生辨深。一报类难知故。二妄想为因。即无性故。三染分行业。唯佛知故。四感异熟识。若种若现恒转如流不可知故。五所变影像若内若外缘无性故。六名无得物之功。而不失所名之物故。七文字言说皆解脱故。后三句合辨前文。一染净二分。皆严法界而无严故。二上二分业不相知故。三各自庄饰净染世间果报无失。即同真故。总上二分。皆是般若波罗蜜普庄严故。所以思之。二趣求后友于市肆等处处求者。显随缘造修无不在故。第二见在林中下。见敬咨问中。先见次敬。后问。见中三。先见身胜相。见在林者。行之初故。同佛相者。如说修行顺佛果故。于中七处平满者。两手两足两肩及项。言其身殊妙如净居天者。准晋经即师子上身相矣。上下端直如尼拘陀树者。准晋经。云其身圆满如尼俱陀树。此则但是一相。言诸相随好者。上但列十四故总结之。目视不瞬圆光一寻。复是二相。都列十六耳。余至瞿波处释。二智慧下明其心相。即止观双运。止过则沈。智过则举。不沈不举则正受现前。不智不愚则双契中道。起念止观皆成动转。双非再遣未离戏论。虽止观双运而无心寂照。则一切皆息。为践如来所行之道。随所履道即是法门。三无量下明诸侍从不无表法。恐繁不说。敬问可知。第三善见答下正示法界中二。初示依缘得法。后又善男子下显法业用。今初分三。初总序。初入行位故云年少。创离十住之家。名为出家。又近言我此生者。略有二义。一念劫圆融故。如毗目处说。二显入解行生。非见闻生故。供三十八恒沙者。过前位故。次或有下明所修时分。后听闻下所作成益。于中初自修愿智行。次见果用。后知佛修因。二显法业用中有十二句。各先辨业用。后出所由。然不出愿智行如文思之。总云一念者。以得无依无念智故。无法不现。第四谦己推胜中。谦己结前。名随顺灯者。用无念之真智。顺法顺机无不照故。后如诸下推胜中。初句为总。亦别显家族胜。上但云灯照未必常。故今推之。明金刚智灯亲证真如为真正。生则常照矣。不同解行生也。二报命胜。由所证常故。即金刚义。三内智胜。如于所证无尽灭故。即是灯义。四报体胜。法性成身相不迁故。亦金刚义。五现于下明业用胜。即对上随顺义。以是即体之用故。皆不可坏余并可知。指示后友次文当说。第二自在主寄饶益行。初依教趣求。国曰名闻者。能持净戒现世果故。河渚中者。若持净戒。生死爱河不漂溺故。又无量福河常流注故。童子自在主者。三业无非六根离过故得自在。则戒为主矣。戒净无染故云童子。第二尔时善财下。见敬咨问。中见聚沙者。恒沙功德由戒积集故。第三自在主言下。正示法界。于中二。初举法门名体。二善男子我因下明业用。今初文殊所学者。有智能护戒故。书者。能诠止作分明故。数者。表四重十重乃至三千威仪八万细行故。算者。一一之因感几何果故。印者。持犯善恶感果决定故。等者。等余医方成五明故。上明所学下辨所悟。工巧神通皆智所为故。亦表修戒发定慧故。二明业用中三。初总明。次亦能疗下杂辨诸明。三善男子下广显知算。于中初辨能算之数。后善男子我以此下。算彼所算余三段可知。第三具足优婆夷。寄无违逆行。城名海住者。近海而住故。安住于忍。如海包含故。友名具足者。一器之中无不具故。忍器遍容一切德故。忍辱柔和故寄女人。文中初依教趣求可知。第二善财闻已下见敬咨问。初见中四。一见外依报。二见友正报。端正可喜者。忍之报故。素服等者。忍华饰故。三于其宅下见内依报。四复有下明其眷属。万行皆顺忍故。二敬三问并可知。第三彼即下正示法界。于中二。初举法门名体。器中出物兴福无尽故。称法界福之所招故。后能于如是下辨业用中三。初正显业用。次令见同益。三使其目验。前中三。初益众生。次益二乘。后益菩萨。今初亦三初总明。以是称性之具。即一小器融同法界。无尽缘起故。用无不应应无不益。而其法界体无增减。又表忍必自卑故小。法忍同如一味为一。内空外假为器。忍能包含无外。故随出无尽。次出生下别明出味。后如饮食下举一倒余。二又善男子假使下明益二乘。二乘虽不立忍名。亦忍尽无生理方成果故。三又善男子东方下益菩萨。约事如受于乳糜。约法谓餐上品寂灭之忍。得菩提故。净名香积与此大同。二善男子汝见下令见同益。三且待下令其目验。及后三段文并可知。第四明智居士寄无屈挠行。初依教趣求中。初依前修治。后渐次下趣求后友。城名大兴者。起大精进故。友名明智者。进足必假智目导故。第二尔时善财下见敬咨问中。先见于市四衢者。表处喧不挠无不通故。敬问可知。第三长者告下。称赞授法中三。初叹发心胜能。二善男子汝见下。示己所化发心眷属。生如来家者。同四住中生也。三善男子我得下正示法界。于中二。先举名。财法无尽蕴在虚空。随意给施故。名随意出生福德藏。亦表见空无不备故。后凡有下显业用。于中二。一略举。二善男子且待下。举事现验。于中先见众集。后尔时居士下。广施财法。先施财。后然后下施法。于施一食令成八行。初二约施。余六约食。食有五果。一得如诸法即是慧命。二得喜悦即常安乐。三具相好即是常色。四六即常力。五即常辨。言上味相者。牙有甘露泉故。余可准思。第四尔时居士下。谦己推胜可知。第五善男子下指示后友城名师子宫者。禅定无乱如彼深宫处之。则所说决定。作用无畏故以为名。友名法宝髻者。绾摄诸乱居心顶故。定含明智加以宝名。以喻显法名法宝髻(已下六十六经)第五法宝髻寄无痴乱行。六中初文可知。第二见此长者下见敬咨问。市中见者。表处闹忘怀乱中常定故。第三尔时长者下。授己法界。于中四。一执手将引。即授法方便。显加行智归正证故。二作如是下示其所住。即正授法界。三尔时善财见其下正证法界。四尔时善财见是下。问答因缘即后得智。初二可知。三中二。先总。后善财入已下别。今初。十层八门者。如八角塔形。层门各有三义。层别中解。门三义者。一通约所修之道。以八正为门。八正通入于诸位故。二约所依之道。即以八识为门。于眼根中入正定故。根若能入境则可知。三约教显理。即四句入法。教理各四故有八门。谓若失意有空俱泯。便成四谤。得意通入并称为门。寻教得解即教四门。于理得解即理四门。别中十层三者。一表十地。一施食。显初地行檀。二地持戒。以惭愧为衣服。三地忍行。以为严具。四地。道品为内眷属。精进可珍。五地。文显。六地。般若现前故。文中三。初总。次所谓下别显十五门。一照体即寂而无不包。二即寂之照无机不鉴。三外缘不转。四内照无求。五惑境不摧。六遍摧诸惑。七包含胜德而甚深。八普见法界而无碍。九一即无尽。十巧化无边。十一内证世间。十二外演胜辨。十三曲随物欲。十四事理交罗。十五观缘授法。后说如是下总结。七地有殊胜行。知种种教法故。云得如响忍。八层之中含于二位。一八地无功用之神通。三种世间自在。二即九地法师。一音能演。九层亦二位。十地等觉俱可为一生故。十层即如来地。二表十行。以十行即十度故。前七文显。八大愿所成神通等故。九一生所系力最上故。十唯至如来智方满故。此即当位自摄诸位。向摄十地。即摄后诸位故。以十层双表二义。还如海幢。当位摄尽十位才竟说成佛故。前寄第六位摄。此寄第五位摄。前约正报摄。此约依报摄者。皆显位胜前故。三者总不表位。但此菩萨以行就机。现居胜报渐次增胜。十显无尽。初四以物施。后后渐难。次二集法施。前浅后深。次二得法。初陜后广。后二现胜德先因后果。总上三义因果行位等法。以为长者之宅。四问答因缘中。先问后答回向三处者。谓离贫穷招前四层之报。二三两果即后六重。一九之微因愿力故报胜。又表万行混融发起向佛。则随一行无不具矣。何果不阶。第四善男子下谦己推胜。谦己云菩萨等者。世宝三宝蕴积十重之中。故云宝藏。常用无尽是为无量福德。后推胜中当法显胜故。功德宝藏皆不思议。即是总句。入无分别下别明。由无分别而具诸法。故不思议。后二可知。第六普眼长者寄善现行。国名藤根者。夫藤根深入于地上发华苗。表善现行般若证深能生后得。后得随物而转。故取类于藤。城名普门者。实相般若无所不通故。长者名普眼者。观照般若无不见故。第一依教趣求中。言深入诸佛无量知见者。无量有二义。一多故即权智境。二无分量故即实慧境。境无量故智亦无量。知见亦二义。一别。谓知即是智。见即是慧。即照二境之智慧。二通者。谓知见二字俱是如来能证。如实知彼义故。即无障碍智。若尔何假重言。为拣比知所以言见。为拣肉眼见所以云知。此如世亲般若论释。悉知悉见。入谓证达余句易了。第二然后乃得下见敬咨问中。先见依正。百千聚落周匝围绕者。眷属般若也。雉堞崇峻者。般若防非高而无上也。五板为堵。五堵为雉。堞即女墙。衢路宽平者。般若诸佛常行非权迳。故荡然无涯。第三长者告下称赞授法。先赞。后善男子下授己法界。于中二。先能疗病。即下化众生。后善男子我又下。明能合香上供诸佛。今初有二。先除身病。后治心病。前中亦二。先治无不能。后善男子十方下。来者皆治。兼与身乐。二然后合为下治心病。亦二。先明除惑义通大小。后为欲令其下令其成益。此唯大乘有十六句。初五通显大心行愿。次十别明十度之因。感十身之果。施满他心故。相好悦物。戒遍止恶故。净身遍至。忍兼忍理故不思议。进策万行故无能胜。禅唯一心故无与等。般若照理故显法身。方便显用色身可睹。愿穷来际住劫无穷。力不可摇悉过一切。智穷事法故随物成身。后一句总离诸恶。故究竟净妙。二上供佛行中二。初知香体。辛头者。即信度河也。波罗是岸。即彼河岸之香。阿卢那跋底。此云赤色极。乌洛迦者。西域蛇名。其蛇有毒绕此檀树故。和合者。戒定慧等融无碍故。次兴供起愿。后能成大供文处并显。第四谦己推胜中。谦己知一中。谓身心病除成二世乐。故皆欢喜以香普供。得佛十身。则何佛不见。余并可知。第七无厌足王寄无著行。第一依教趣求中。先念教成益。后渐次下趣求后友。既入其国必闻其政。言多罗者。此云明净。幢者。建立表无著行依般若净明立胜行故。王名无厌足者。如幻方便化无所著故。无疲厌心。第二遥见下见敬咨问中。先见有四。一见胜依正。二其前后有下睹其逆化。三善财见已下不了生疑。四作是念时下空天晓谕。于中二。先令忆前教真实使不生疑。后善男子菩萨善巧下。辨后行深玄令其信入。然善财虽常忆教而生疑者。逆行难知故。贪益此世不疑婆须。嗔痴现损故。胜热此王并生疑怪。言深玄者通达非道故。梁摄论戒学中。明菩萨逆行杀等生无量福得无上菩提。要大菩萨方堪此事。此有二种。一实行。二变化。实行者。了知前人必定作无间业。无别方便令离此恶。唯可断命使其不作。又知前人若舍命已。必生善道。又菩萨自念。我行杀已必堕地狱。为彼受苦。彼虽现受轻苦必得乐果。瑜伽菩萨地戒品之中。亦同此说。言变化者。即当此文。下王自说。二时善财下敬问可知。第三时阿那罗下。授己法界中二。初授法方便。执手同坐示无间之仪。表摄彼加行令趣真故。二告言下正示法界。令证相应。于中四。一举果令入。二时阿那罗王告善财下以实显权。三善男子我得下示其所得。于中初名如幻者。了生如幻故。以幻化幻。次我此国下明法门业用。后我以如是下明法门胜益。四善男子我身语下。直显实德慈念之深。然诸位至七皆方便故。休舍观自在开敷树华。多约慈悲。第四谦己推胜。推胜云无生忍者。由了如幻方证此忍故。又后位中当此忍故。第八大光王寄难得行。第一依教趣求中。先念前。后渐次下趣后。于中初推求得知。城名妙光者。前位悲增。今得无住妙慧运众生故王名大光者。慈定之智无不该故。广大愿中皆彻照故。后时善财童子下自庆当益。第二作是念已下见敬咨问。初见中三。初见依报中二。先所见殊胜。云十由旬者。欲明圆满。既有十亿衢道道各无量众生。岂世间十小由旬之所能受。故此中事物皆应圆融。表法如理思之。后尔时善财下能见无染。二渐次下见王正报。处四衢道者。以四无量用四摄法摄众生故。二十八相者。因未满故。三于王座前下主伴摄生。于中亦三。先列所施通情非情。六十四能义如别说。次一一道下明能施人。即是助伴。后为欲普摄下明其施意。二三敬问可知。第三时王告下。授己法界中三。一总示法门。谓大慈首出离染圆满故。二善男子我于下明得法因缘。问难是闻慧。以三种慧庄严此慈。三我以此下明其业用。于中五。一以法摄化。二我国土中下以无畏摄。三若有众生下以财宝摄。四此妙光城下随机遍摄。五善男子此国土中下以三昧摄。于中二。先以言告。后时大光王下。正以定示显定业用情与非情咸成胜益者。谓同体大慈物我无二故。如世间王德合乾坤。则麟凤来仪宝璧呈瑞。况于出世慈力。不令草木屈膝耶。第四时大光王从三昧下谦己推胜。先谦己知一。慈本为物名顺世间。高出众行故名为首。即是幢义余并可知。第九不动优婆夷寄善法行。自发心来于一切法无不得定。烦恼二乘不能动故。亦令众生心不动故。以智修慈故。示以女居安住王都者。王子位故。智契实法不为缘坏名为安住。第一依教趣求中二。先依教。后趣求。前中有五。一思修前法。二生欢喜下因修得益。无浊约无他。清净约自体。三如是思惟下推功归友。至此偏悲者修悲将满故。四又作是念下广叹友能。五善财童子如是悲哀下。胜缘印劝。于中先印。天字两用。故晋本云。如来使天随菩萨天。随菩萨天是已业行之神。如来使天是佛力摄生神。但修行位已着。皆有二天常随其人。后汝可诣下劝诣后友。二时善财童子从彼下。趣求后友可知。第二入其宅内下。见敬咨。问见中分二。先见依获益。后善财童子前诣下见正超伦。二尔时善财曲躬下。敬问可知。第三时不动下称赞授法。于中先赞。后善男子我得下正授法界。于中二。先示法门名体。后善财童子言下征业用之境界。今初。不同前例而举五法者。亦同九地当法师位。须广知故。五中初二所持内德。一智慧无羁偏名解脱。有智则烦恼不可坏。取着无能胜故云难摧伏。此智包容故名为藏。二受持坚固偏得行名。谓遇恶众生而能堪忍。遍生诸趣而心不迷。故云坚固。三即能持深入法门。得法性地则无不持矣。四即外化由正思佛法明照差别。故得辩才。能转法轮称众生欲。五即上求。一心求法故云三昧。近佛无厌受法无足故。二征业用之境界。中四。一征问二显难。三重请四广答。答中二。先明得法因缘以彰深远。释上难知。二善男子我得菩萨求一切下。显其业用以酬初问。今初分六。一举往见佛为发心缘。二便从楼下内兴观念为发心因。先观后念。念福智等即前五法之因。神通自在是行坚固。三善男子尔时下佛劝发心。能成前五有十种心。初二成智慧。次一成总持。次二成神通。次二成三昧。后三成辩才故。上来取斯十句释五法门。四善男子我于彼下。正明发心坚固。五我发是心已来下。经久无违。六我从是来下彰发心胜益。即前五因之果。二显其业用中四。一许现。即举五法中二。二申请三正现。入一万三昧者。于一求法无厌三昧即入一万。明知。余解脱等亦摄多门。四出定即述并可知。第四优婆夷言下谦己推胜。第五指示后友中。都萨罗者。此云喜出生。谓此城中出生无量欢喜之事故。以智度圆满则能无所不生。友名遍行。巧智随机无不行。故名真实行。示外道者。能行非道故。非道不染故曰出家。余可知(已下六十七经)第十遍行外道寄真实行。第一依教趣求。第二城东有山下见敬咨问。见中中夜见者。智入生死故。善财将入此位故。上云日没入城。于山顶者。表位极故。光明照者。以智慧光破于生死及二边闇故。第三遍行答言下称赞授法。先赞发心。后善男子下正授法界。于中二。先彰名体有四者。智遍知故。四义虽别而得相成。一化境。普周遍行之名亦从此立。二入定观机。三由无作神通故。能遍至前处。四由普门般若故。能在定普观。若约别者。无作无依用而无住。普门般若无法不穷。二善男子我普于下显四业用。即分为四。一明至一切处用。二或住诸见下普观世间用。观其所宜随宜说故。三又善男子此部萨罗下。明无作无依用故。云不知从何而至。四善男子阎浮提内下。普门般若用。九十六种皆能穷故。上来随胜别配。实则义通。大文第四有十善友寄十回向。今初。青莲华长者。寄救护众生离众生相回向。在广大国者。创入回向故。回向众生故广。回向菩提故大。回向实际义通广大。言鬻香者。鬻者卖也。香质虽小。发气弥布。善根虽微回向普周。又若卖若买二俱得香。自他善根俱可回向。青莲华者。莲华处淤泥而不染。犹护众生而离相。青莲华为水中之最。救护为入生死之尊。文亦分六。第一依教趣求中。先依教兴愿。以是回向大愿之首故。后渐次下趣求后位。第二诣长者下见敬咨问。第三长者告言下称赞授法。先赞后授。授中二。先总标所得。后所谓下别显业用。今初知世诸香以表法香。谓以戒定慧慈悲等香。熏修生善灭恶习气故。善知一切香者。差别行也。亦知调合者。融通行也。以金刚杵碎之。实相般若波罗蜜调和。令纯杂无碍。悲智圆融成回向故。二别显业用中二。先总相显知。后指事别显。前中四。一知香体异。二又善了下约类辨异。三又善别下知力用异前。二约世此兼出世。四如是等下明委穷本末。上四各有事理思之。二人间有下。指事别显中有十种香。初象藏香具前本末十事。一但语香名必有形相。二龙斗为生起。三兴云为出现。四雨雨为成就。五金色为清净。六喜乐为安隐。七无病等为方便。八慈心等为境界。九意净为威德。其业用一种义通前七。十我知下是根本。本为菩提心故。若就菩提心显十义者。以菩提心香似如来藏。因善恶相攻而生。若一发心兴慈云注法雨。心所及者令归真净。得法喜乐离惑业苦。展转兴慈志愿纯净。余之九香皆应具法喻之十。略故或二或三。摩罗耶者国名。国多此香故。此即忍香嗔火不烧。三即进香魔军退散。次五如次是五分法身香。九即称法界香。先陀婆一名四实。此宜用盐香似此故。十忘能所香故名夺意。余三可知。第二船师婆施罗寄不坏回向。婆施罗者。此云自在。谓于佛法海。已善通达于生死海。能善运度。于一切法深信不坏。故名自在。在楼阁城者。由此回向令菩提心转更增长。悲智相依而胜出故。文中第一依教趣求中。先依教观道。于回向道初得不坏故。佛道为高余皆是卑。生死涅槃为夷险。障无障为净秽。二乘为曲菩萨为直等。后渐次下趣求后位而兴胜念。谓菩萨道因人得故。即于菩萨法师得不坏信。于中先正明。后征释可知。第二既至彼下见敬咨问。见在海岸者。若佛法海以生死为此岸。不舍生死故。若生死海。以大悲修因而为此岸。住大慈悲令离因故。第三船师告言下。称赞授法分二。先赞问。赞其发心。后能问法文有十句。前五能问果因。后五能问因因。故云道因。三昧旋者。旋谓深澓沈而不流。二乘沉寂动八万劫故。能远离是菩萨道。二善男子我在此下授己法界中二。先标名体。谓大悲超出为物所归故。后我观阎浮下。辨其业用中二。先明于陆化生令知有海。后我知海中下善知海相。于海化生于中二。初明善知。后彰化成益。今初此宝洲等。生死法海义皆有之。且约生死海释文中。略举知五种事。一知宝。宝即是智故。不入生死大海。则不能得一切智宝。于中有十二句。一生死海中湛寂不动。谓之宝洲。二空不空如来藏为宝处。三恒沙功德皆宝类。四佛性为宝种。此上皆约本有。次四约修成。以净戒头陀等为能净以缘起智为能钻。以发一切智心为出因。听闻为能作。后四为宝用。谓三乘等器智慧有殊。照理断惑所用各别。所缘境界万品阶差。破愚显明各各不等。二我知一切龙下。即生死中嗔贪痴之三毒。部多此云自生。亦如夜叉。但不从父母生故喻多痴。三亦善别知旋澓下。即知心识相色无色等依识心定。劫数浅深。七识波浪染习远近。随善恶缘心水色异。四亦善别知日月等者。即能知时。谓机之生熟。如是时中宜修定慧等。五亦知其船。即知万行不同。有方便为坚无方便为脆。曾修为滑不曾则涩。水之大小者。谓生死有边与无边。风之逆顺者。八风四顺四逆。又谓修行有住与无住故。若开第三第五。各有三事。则总具十二。我以成就下彰化成益。既列十海则知前海。准此应思。前四自利后六利他。后三文显。第三无上胜长者。寄等一切佛回向。以得胜通无过上故。等于诸佛。更无胜故。在可乐国者。由等佛回向不见美恶。皆得清净欢喜悦乐故。文中第一可知。第二见无上胜下见敬咨问。初见。在城东者。启明佛日故。处无忧林者。同佛回向无爱憎故。商人等围绕者。佛为商主菩萨为商人。法财外益功归己故。次尔时善财下设敬。后白言下咨问称名者。声名久闻。表重法之器。冀有闻故。第三时彼长者下。称赞授法。授法中先标名体。由无作无依故能遍至。遍至是用广。无依是体胜。无依者。不依他故。无作者。离加行故。二善男子云何下征释业用。释中明至一切处广说法故。文中先举三千。后如于此三千下类显十方。第四谦己推胜中。加清净法门者。遍至本为说法故。即前所说。后二可知。第四至一切处回向。善友名师子嚬申者。舒展自在无不至故。比丘尼者。纯净之慈合善遍故。国名输那者。此云勇猛。勇猛之力。能使善根无不至故。又以十度明义。义当进故。城名迦陵迦林者。以义翻。为相斗战时。谓因斗胜而立城故。表此回向愿。以信解大威力故。广大智慧无障碍故。令修善根无所不至义同战时。文中第一依教趣求。言胜光王舍施日光园者。准律。尼之头陀多在王园。藉外护故。表因实际胜光。令其善根遍法界之园苑故。并皆即智故有光名。第二时善财童子即诣下。见敬咨问中三。先见次敬后问。前中二。初见依。后见正。今初有六。一无漏林树无漏法行而建立故。文中有八。各有所表思之。二园中复有下明八解泉流。八功德者。谓轻冷濡美净而不臭。调适无患。三无量宝树下敷法空座。而随法严异。于中有标列及结可知。四此大园下杂明诸严。万行非一故。五尔时善财下出其所因。六三千下明果用自在。二尔时善财见师子下。明见正报中四。初总明遍坐胜德显彰。二别明所遍。演法各异。三总结多类闻法发心。四通显所因释成自在。今初婆楼那者此云水也。此天能满人愿故。二或见处座下别明所遍中有三十处分三。初十六为八部人非人等。次二为二乘。后十二为菩萨。今初中先有七处为天。一为净居天。说无尽者。治彼那含求尽身智故。二梵王。普应。但于己众广及三千。为说普门则无不应。梵音清妙但是世间。为说法界胜流方为净妙。三他化天。令得出世净心超世自在故。四化乐。乐具庄严不及善故。五旋归如来藏心。则真喜足故。六遍严法界方尽时分之乐。七释天。耽欲甚故。次一为龙。龙能通变耀电雨庄严故。三夜叉。性好飞空害物故四乾闼婆众。能奏乐喜乐故。上三亦四王众意存八部。故阙南西。五修罗。善幻为庄严故。六迦楼罗。动海怖龙故。七紧那罗。是歌神。以佛行光明破其着故。又头有一角亦云疑神。令同佛觉离疑光明故。八摩睺罗伽。多嗔毒故。上来八部。除第一第七及夜叉众摩睺罗伽。约对治说。余皆约随便宜。随其世能转入出世故。紧那罗众通其二义。第十五一座为人。人多行不善行。设行仁义亦非胜故。故令起出世胜行。十六一座为罗刹。则是非人。亦治多残害故。次二为二乘者。声闻智劣故。缘觉修福止百劫故。缘起智光未能亡缘故。后十二为菩萨分三。初一为地前。说定慧之光。次十为地上。初发心者。证发心也。发十大愿故。五地妙华藏者。华谓十种平等净心故。晋经云净心华藏。华藏者。以真俗双修。于难得胜为因含藏故。余八可知。后一义当等觉说金刚喻定坏散尘习故。既为等觉而说明此位非小。言回向者。约寄位耳。他皆仿此。第三善财童子见如是下总结多类闻法发心可知。第四何以故下总显所因。释成自在有二。一由能化具般若故。二此日光下由彼所化根已熟故。二时善财童子下设敬。于中三。初睹胜发心。次放光摄受。后正申敬仪。三白言下问法。第三比丘尼言下。授己法界中三。初标名。一切智者同佛智故二善财言下征释其体。一念普照故。三善财白言下辨其业用。先问后答。答中二。先明通用。后明智用。前中亦二。先辨用所依。谓由一切智能入王三昧故。王三昧者。智论第八云。一切三昧皆入中故。体即如如。如体本寂真智契此。故名三昧。以一切智言有其二义。一遍知三世一切事故。二对于种智名根本智。知一切事皆一实故。以即权之实智。契即事之实理故。一切三昧皆入其中。又由王三昧体无不遍故。意生身随类能成。二往十方下辨能依业用可知。二善男子我见下明其智用。又前即差别智用。今即无分别智用故。触境无取(已下六十八经)第五无尽功德藏回向。善友名婆须蜜多者。此云世友。亦云天友。随世人天方便化故。国名险难者。逆行非道下位不能行故。城名宝庄严者。逆随世行能生无尽功德藏故。第一依教趣求中二。先依教成益。谓由闻一切智光故。思修趣入得二种益。一得见实法性益。由前实智故。二得了知下得权智益。由前穷。三世差别智故。二渐次下趣求后位。于中四。一专心寻觅。二城中下浅识致疑。逆行难知故。不自疑者。贪顺于悲。障行劣故不同前二。又于前二已调伏故。此中不疑。三其中有人先知下深智赞教。先赞。后善男子婆须下教示所在。市者喧杂。北主于灭。自宅即毕竟空寂。谓在欲行禅。处喧常寂故。在市廛之北等。四时善财下依教往诣。第二见其下见敬咨问。见中先见依报。毕竟空中无德不具故。广显其严。后尔时下见正报具有主伴德用。二尔时善财前诣下。敬问下知。第三彼即告下授已法界。于中三。先标名。离贪欲际者。凡夫染欲二乘见欲可离。菩萨不断贪欲而得解脱。智了性空欲即道故。如是染而不染。方为究竟离欲之际。二随其下显业用。于中先身同类现。后若有众生下。以法益生中有十种三昧。皆随受欲便宜。得斯甚深三昧。思之。三善财白言下得法因缘。先问后答。一宝钱施者有二义。一宝而能舍故得离贪。二一钱虽微。以菩提心故。成斯自在。第六入一切平等善根回向。善友名鞞瑟胝罗者。此云缠裹。义当包摄。塔中包摄一切佛故。或云摄入。摄诸善根入平等故。城名善度者。无一善根不度到究竟故。常供佛塔者。善根中最故。未详何缘偏供此塔。有云。以塔中空有栴檀之座。为欲普供无尽佛故。亦是一理。文中第一依教趣求。阙无念法第二诣居士下见敬咨问。第三居士告下正授法界。于中四。一标名。不般涅槃际者。般者入也。穷诸如来不入涅槃之实际故。故出现品云。如实际涅槃如来涅槃亦如是。二善男子我不生心下显体。谓心契实际知佛常住。三唯除下释疑。并如出现品辨。楞伽亦云。无有佛涅槃。无有涅槃佛。四我开下显其业用。于中二。先辨用所依。亦是证前不涅槃义。举现见故。佛种无尽者。佛种从缘起。佛缘理生。见理湛然故见佛无灭。以佛化身即是常身法身故。后善财白下问答境界。第四谦己推胜推胜中长者。虽知三世不灭。未能一念而知及能所平等。第五于此南下。指示后友中。先长行后偈颂。以大悲菩萨众尊重故。偏加于颂。言海上有山者。大悲随顺入生死海而住涅槃山故。即南印度之南。第七等随顺一切众生回向。善友名观自在者。三业归向必六通赴缘。摄利难思名观自在。由此能遍随顺众生。在补怛落迦山者。此云小白华树。山多此树香气远闻闻见。必欣是随顺义。又观自在者。或云观世音。梵云婆卢枳底。观也。湿伐罗。此云自在。若云摄伐多。此云音。然梵本之中自有二种不同。故译者随异。而法华观音品中云。观其音声皆得解脱。即观世音也。若具三业摄化即观自在故。彼中初语业称名除七灾二身业礼拜满二愿。三意业存念净三毒。而今多念观音者。以语业用多故。又人多称故。今取义圆故云自在。然观即能观。通一切观。世是所观通一切世。若云音者。亦通所观。即所救一切机。若云自在。乃属能化之用。文中但有五段。阙第六礼辞。第一依教趣求。第二见其西面下见敬咨问。先见有三。初见胜依正。在西面者。西方主杀显悲救故。又令归向本所事故。二善财见已下彰见之益。以得胜念熏心故。善知识者。则是如来者。引至究竟同于佛故。三尔时观自在下。友垂赞摄大悲深厚。随顺摄受故。二尔时善财下敬问可知。第三菩萨告言下称赞授法。先赞后授授中三。初标名。二我以此下总显体相。亦是释名。平等教化即是大悲。以同体悲故云平等。相续不断即是行门。又门即普门。普门示现曲济无遗故。三善男子我住此下广显业用。于中二先约普门以显业用。后约大悲。前中先总明。以上同如来妙觉真心故。常在一切诸如来所下。与众生同大悲体故。普现一切众生之前。普现即普门示现。然大圣久成正觉号正法明。示为菩萨。义言等佛耳。后或以布施下。别明普现之义。有十一句。方法华经三十五应。乍观似少义取乃多。彼三十五应。但是此中或现色身及说法耳。二善男子我修行下约大悲行以显业用。救诸怖畏故。于中三。初离世怖有十八种。初三约烦恼即是因怖。余皆约果。缚杀贪三不活开出。黑闇已下皆五怖中事。上约所离。二复作下即能离因。念即是意。三业皆益故。三我以此下。今进大心方能究竟。离二死怖。第四我唯下谦己推胜。久成正觉尚不失谦。第五尔时东方下指示后友。于中二。初后友入会。从东来者。后位如相智明方证故。名正趣者。正法遍趣化众生故。以智正趣真如相故。从空来者。智体无依方契如故。智轮围上者。如依妄惑显故。足动界者。以定慧足除杂恶故。同前会者。不离随顺众生得如相故。又以智会悲成无住故。后时观自在下。前友指示以在此会故阙礼辞。第八正趣菩萨寄真如相回向。善友文中具六。初二可知。第三正趣菩萨言下授己法界分二。先标名体。十方无际故名普门。一念超多故云速疾。二善财言下显其业用。于中四。一申问。虽有三问意在速疾。二告言下显深。三善财下承力请说。四正趣菩萨言下正答前问。于中五。初答得法处。谓从自本智如来藏界。普生万善本觉而来故。行能速遍知一切法。不离心性万行顿成。二从彼发下答时久近。三一一念中下答处近远。以多时发多步则知远矣。即是速疾。四一一佛刹下显其成益。五如从东下类显十力。后三可知。第九无缚无著解脱回向。善友名大天者。现大身故。无缚无著智净自在。故名为天。称理普应故名为大。妙用难测故名为神。在堕罗钵底城者。此云有门。谓有此无缚等微妙法门。为法师故。初二可知。第三尔时大天下。授己法界中二。先授法方便。后正授所得。今初现相。赞友难遇令欣入故。长舒等者。约事则发心难遇。净目而观散华而供故。约表谓展四无碍解手。取所证胜流相应法门。先当自净以洗身心。后因利他故云华散。亦表四摄远展摄取四众故。二我已成下。正授法界中二。先名体。谓以六度大悲。如云覆润如网罗摄故。后善财下问答业用。四摄摄生故。先问后答。答中二。先现宝令施教以檀摄。后如我为汝下类余通教。及利行摄。如是等言亦兼爱语同事。后三段易知。第十入法界无量回向。善友名安住地神者。地为万法所依。即所入法界。安住即入义。在菩提场者。所入法界即得菩提之处故。菩提是本。前南有所表。从本之南。今摄末归本之法界故。不云南矣。又地上证如亦同本故。今回向终故摄归此。文亦有六。第一依教趣。求第二百万地下见敬请。法于中五。初友见称赞。既云友见则已含见友。二时安住下。严处摄生以显胜德。三时安住告下。许示昔善引其问端。四尔时下设敬陈请。五以足按下正示昔因。第三善男子我得下示己法界。于中四。一标名体用。谓一念之智冥乎法界。则不可坏。此中则无所不生故名为藏。由贤位既满。总会三贤。为入地之因故。显善财之福常随地神之智不坏。是则昔因不失能入证矣。常以此下略明其用。二善男子我忆下别显业用。由智不坏故常忆等。三乃往古世下显得法时处。四我于此下总结纯熟。后三段可知。十回向竟

大方广佛华严经疏卷第五十七大方广佛华严经疏卷第五十八

        唐清凉山大华严寺沙门澄观撰

    入法界品(入六十八经)

自下大文第五有十善友。寄十地位。即分十段。第一婆珊婆演底夜神寄欢喜地。城名迦毗罗者。此云黄色。往昔黄头仙人依此处故。黄是中色表契中道故。又此是佛生之城。表初地生佛家故。婆珊者。此云春也。婆演底者。此云主当。以于春时主当苗稼故。谓显初入地能生长万行。护众生故。地上多见夜神者。证智玄妙杂相破闇故。下九天神准梵本。皆是女神。瞿波亦女者。地上证于同体慈悲女之状故。第一依教趣求中。先依前修证。后渐次下趣求后友。于中先至时处从东门入者。开明之初。显入证之始故。见日没者。是夜神故。表分别见日皆已亡故。后心念下生渴仰心。第二作是念时下。明见敬咨问。于中二。初见友依正。于空见者。城表教道空表证道。宗说兼通。如日处空故服朱衣者。证智明显故。法门星像。不离一身如体。化生作用。不离一毛之性。二善财童子见闻下设敬咨问。第三时彼夜神下称赞授法中二。初称赞。后善男子我得下授己法界。于中三。一标名体。二显业用。三得法久近。今初。一切众生痴暗者。即所破二愚。法光明者。即是能破二无我智。又破众生闇为悲。法光明是智。悲智具故。二我于恶慧下明业用中二。先长行后偈颂。前中二。先兴救物之心。二我于夜闇下。正明对缘救摄。于中十门。初一总明。为海难下别显。今初有四种。一夜等为救时。二海等为救处。三遭盗等为所救。四种种方便为能救。后九门别显中。文皆有二。先救世苦令得世乐。后以回向大愿。令其究竟离苦得乐。九中一救海难众生。二为在陆地下救处陆众生。三一切众生下救求不得及行山险众生。四救乐国土众生。五救着聚落众生。六救闇夜众生。七是诸众生无有智下。救惑业众生。八或病所缠下救八苦众生。九入见稠林下救恶见众生。文并可知。二偈颂中二十一颂分四。初一颂法门名体。二有四颂举因劝修。即四无量。三有十颂显果令入。即六处殊胜。四有六颂明业用广大。三得法久近中。先兴二问后还两答。答中有二。先答发心时节。后答得法久近。今初有六。初总显本事因缘。二时彼城东下明初佛兴世。三莲华城内下善友劝发。四令王夫人下正发大心。五时王夫人下结会古今。六我于彼佛下发心成益。二过此劫已下答得法久近。于中二。初总显得法因缘。后我才见佛下正明得法。于中三。初得方便三昧。谓上见诸佛下化众生。次以闻法故下得此解脱。后得此解脱已下广显业用。第四谦推可知。第五指示后友。云菩提场内者。得无误犯。由契理故。理即菩提场。友名普德者。最胜法界无德不具故。净光者。正智证入离误犯之垢故。即前净月。故云本从发心。第六尔时善财下恋德礼辞。于中二。先以偈赞表恋德之深。于中十偈分四。初四赞身心超胜。次三明大用无涯。次二益物不虚。后一结德无尽。二时善财下作礼辞退(已下六十九经)第二普德净光夜神。寄离垢地。善友义如前说。文则具六。且分为四。第一依教趣求。第二见敬咨问。第三称赞授法。第四恋德礼辞。今初。先念前法有十一句。初一念发心余十念得法。第二顶礼下见敬咨问。第三夜神答下称赞授法。先赞后授。授中二。先长行后偈颂。长行中三。第一正授法门。第二谦己推胜。第三指示后友。初中二。先总答所问。后别示己法。今初。有标征释结。释中有十句。初总余别。别中三。是智法光明。四放光利益。五常光发焰余可知。二善男子我得下别示己法。于中二。先标名体。谓契理无著为寂静。止观双运为禅定。正法乐住为乐。大用无涯为普游步。后普见三世下广显业用。于中四。初明攀缘如实禅。同如来清净禅。即寂静业用。次现法乐住禅即定业用。三明引生功德禅。四饶益有情禅。此二即普游步业用。今初。文中有标征释。标以见佛无著故寂静。释云所以无著者。穷了如来之体性故。文有十非。大同中论八不。谓不去不来不生不灭为四。其非实非妄即是不常。非迁非坏即是不断。一相即非异。无相亦非一。二善男子我如是了下明现法乐住禅。先牒前起后。后思惟下正显四禅。初禅中。思惟观察即是寻伺。当对治支。坚固庄严犹是寻伺之相。次不起一切妄想分别。即所离障。然世禅但离欲恶不善。今一乘深妙故。离一切妄想。次大悲救护一切众生。即利益支。谓离自忧念众生忧故生喜乐。后一心下即所依支。谓彼二依止二禅中息一切意业。即灭觉观。次摄一切众生。是一心智力勇猛。是内净无觉无观。次喜心悦豫是定生喜乐。修第二禅即彼二。依止下三四禅准此

三禅中初思惟一切众生自性。即舍念二支。谓舍离前摄生之喜。于此舍中不失念故。厌离生死即慧乐二支。谓正知生死不可喜故。厌离即得真寂之乐。四禅中二句通具三支。谓苦喜忧乐皆是众苦热恼。于下苦中横生乐故。四受俱亡故。云悉能息灭即舍念清净。既无苦乐即是中受。三增长圆满下引生功德禅。游戏神通即普游步义。上来皆约一乘。异于三地寄法故。乃至云普入法界。四善男子我修此下明饶益有情禅。种种方便无不饶益。亦普游步义。文中三。初令修四念处等观。次若有众生下明作道因缘。后复次下令修四正断。第二我唯下谦己推胜。第三去此不远下指示后友。去此不远者。同寄世间故。菩提场右者。依理发光义便易故。喜目观察者忍恶视物故云喜目。发闻持光故云观察。后偈颂十三偈分三。初十偈颂正授法门。次二颂谦己推胜。后一颂指示后友。前中颂前十法。文小不次。初四如次颂前四法。五超颂第七。六颂第六。七却颂第五。八颂第十。九颂第八。十颂第九。第四礼辞可知第三喜目观察众生夜神寄发光地。文具六段。第一依教趣求中二。初依前友教。念友成益。后作是念已下趣求后友。得友加持于中四。一欲趣后友。二时喜目神下得友加持。谓加令知近友之益。三时善财童子遽发下加所成益。谓依前能加而起念故。如次以此十句对前十句四。尔时善财下正明趣后。第二见彼下见敬咨问中。但略明见已含敬请。第三入普喜幢下示己法界。谓悬为示相义当答问。于中三。初标名体。次显业用。后出所因。今初。无不摄伏为大势力。遍称群机故云普喜。摧伏高显所以名幢。第二于其身上下明业用。于中三。初显无涯之用。次尔时善财见闻下睹用获益。后尔时善财得此下庆益称赞。初中谓毛孔身云无有尽故。于中二。先出通说修行身。后复于一一诸毛孔下出演说本行身。前中三。初总标亦是释名。次所谓下别显十度。如次十度各有又出。以为拣别。其间深旨如理思之。后如说菩萨诸波罗蜜下类通余法。种种行法者。神通度生菩提分等。二出演说本行身中四。一出能说之身。二于彼一切众生下明演法之声。三以如是等声下显所说之法。四如是说时下彰说之益。前二后一可知。三所说法中二。先说本行十度行法。后又说下类通所余行法。今初忍中。恶作属身恶说属口。禅中有六句。一名体。二资缘。三造修。四获得。五治障。六起用。下之五度句虽多少。例此可知。般若中日约破闇云。约演法。藏显包含。方便中体性通事理。理趣谓意趣。后类通余行中。具四菩萨行思之。二睹用获益。即证入法界。于中三。初显证因缘。次则得下正明证入。后何以下征释所由。三庆益称赞中十偈分四。初一偈现说之因。次一现说之意。次六现说体相。皆即寂之用。后二总结现说无碍。第三尔时善财下明出所因。于中先兴二问。后具二答。于中先以偈答。后会古今。前中总九十一颂分二。前七十九颂答发心久近。后十二颂答得法时节。前中有十。复次初寂静音劫。正是发心之时。有三十一颂分六。初一偈总标。二有八偈显其本生三有十偈明发心本事。四一偈正显发心。五六偈明发后之德。六有五偈转值余佛。未得慧眼者。未得十解正慧明故。二天胜劫中有四偈半。无而计为有者。未解即心自性故。余之八劫偈数可知。三梵光明劫中。未能明了法者。未了十行真实行法故。四功德月劫。未得善巧回向深智趣佛智海故。五寂静慧劫。未得地上二空真如清净法故。六善出现劫。未净修道之障故。七集坚固王劫。未得六地缘生深顺之忍。八妙胜主劫。修最胜道者。六地般若为胜道故。九千功德劫。未得八地净无生忍故。十无著庄严劫。四颂半。但言供养者。下明得法故。又前次第皆言未得。后后则已得前前思之。亦可。初劫已得初地未得第二乃至第九未得第十地第十劫中方得圆满故。其劫名亦顺地义。如文思之。第二次有佛出现名为功德幢下。答得法时节中。即前无著劫得此法也。于中二。初四偈得无功用之三地。谓八地无依大愿。九地灭定总持。十地成如来力。后八结成普贤行位。于中三。初四偈半牒举大心之始。次二偈半明成德之终。后一偈总结圆满。因果圆融初后该彻故。入普贤道。二结会第四谦己推胜并可知。第五指示后友。同在证位。故云于此会中。起精进行为普救众生。智焰吉祥称为妙德(已下第七十经)第四普救众生妙德夜神。寄焰慧地。文但有五。二三合故。第一依教趣求中。先修入前法。后一心愿得下趣求后友。第二时彼二神下。闻见法界即合二三。谓约善财则是见敬。若约夜神所现即是解脱业用。便为默授法界。若约二文开辨则先明见敬咨问。后答因缘。方为正授法界。今依合科总分为四。一现光加持。二蒙光获益。三三业敬赞。四问答因缘。今初调伏众生解脱即光所依。是己法门名体可知。第二善财尔时下蒙光获益谓得三昧见大用故。于中二。先得定。谓三业六根皆离障故。云究竟清净。即净智圆满。摧障为轮故所见无碍。后得此下明见大用。于中二。先见用所依处。后一一尘中下明所见事。于中三。一所化处。二能化益。三所化意。前中二。一总明处类。二又见下别明尘中之刹。趣杂秽等者。转变向染净故。杂染清净者染多故。下句反此。一向净者对上二故。初之二句乃是总明。二如是等下明能化益亦二。先总明。后令地狱下别显。于中先化五道。后又见一切众生下明化九类。三为成就下明化意中。为成诸法通能所化。第三时善财童子见此下。三业敬赞中三。初身心敬重。二时彼夜神下显友自在。三尔时下口以偈赞。二十偈半分二。初偈总余偈别。别中二。初九偈半明光用无涯。后我承下述前蒙光获益。于中三。初半偈推功归本。次二偈半述得三昧。余述见大用。第四问答因缘中二。先问后答。问中有三。一问名前来标名集经者言故。此方问。二问得法久近。欲显久修德远故。三问修因净治。求入路故。后夜神言下答中二。先叹深难说。后我承下承力为说。今初。深相云何。若约得时时久远故。非久近故。若约修因因行广故。若通上二契理深故。若约名说名如体用故。名者实宾。难穷实故。文有标及征释可知。后承力为说中。先长行后偈颂。前中先标许。后善男子下正说。于中二。先通答三问。后别答修行治净问。今初分三。一答得法久近。二明发心之始。三结会古今。今初十段。一总举劫刹佛兴已略。酬其久近。二其佛世界下通显刹相。三此界东际下别显生处。四有转轮王下明本生父母。五其有一女下明本生身。六尔时众生下。众生起恶为佛现因。七时彼城北下佛兴益物。八时普贤下明善友引导。九时转轮王女下。明德女修因。十普智宝焰下闻经得益。前六可知。就第七佛兴益物中三。一明得道之场。二须弥山下总显佛数。三其第一下别明初佛。于中七。一总明成道。二其彼如来下成道前相。谓放光调机有十一重。一一重中。各有光明业用成益。以益对名可以思准。若约表法。则前十为次第十度光。后一为圆融十度光。以此照心则自智出现。三满七日已下动刹集众。四尔时彼世界中下现相显德。五善男子此普照下明成道依正。六善男子彼普智宝焰下始成正觉。一成一切成故。七随众生心下转正法轮。于中三。初总标转法。二于一一下显其成益。于中初益凡夫。次益二乘。后益菩萨。菩萨中先成行。后发菩提心下成位。菩提心是住位。菩萨道是行位。净波罗蜜是回向位。以大愿海净治前度故。后二句是等觉位。三善男子彼普智下结无间断。第八善友引导中六。一知机起恶。二化现妙身下现身超胜。三时诸众生下物机惊怪。四尔时普贤下告语佛兴。五时圣王女下女发大心。亦是入法之因。六善男子时转轮王下父王诣佛。于中四。一身处虚空。二以偈赞引。于中十偈初一总劝。次五偈释劝。后四偈结劝胜故应往。三尔时下广兴供云。四到已下至彼修敬。第九德女修因。于中三。一严具奉佛表修万行。向佛果故。二时庄严下见佛现变。表因小果大故。三既见是已下睹变获益。第十闻经得益中三。一佛为说经从总相为名。二时彼女人下正明闻益。于中亦三。初得三昧益。文有总别。次得如是等下得大心益。即悲智等心。后一心思惟下成夫愿益上之三益。即调伏众生。解脱三事皆调伏之法故。三时彼如来复为下显发昔因。第二善男子复于此前下。明发心之始。于此前者。即得法劫之前也。显前得法非无因也。第三善男子于意云何下结会古今。于中三。初结会得法时身。次我于彼时下结发心之始。后次复引导下正结得法。此方酬其名即前三益。第二善男子过彼毗卢下。别答修行净治。前有闻法修行。是得法之前。此是得法之后。于中二。一别举大光劫。二善男子此世界中下。总显诸劫。今初分三。初总明。次其最初佛下别显。其中经名说者当演。后善男子如是下显其最后。二总显诸劫中三初总标。次彼诸如来下得法修行。后善男子我依下见佛行成。第二偈颂四十一偈分三。初二偈举法诫听。次三十八偈颂前正说。后一偈举因劝修。今初即颂前标许。就颂正说中。通颂得法久近及修行清净。于中二。先三十六偈颂最初一劫。广前长行。有百一十佛。表十地等觉。各以初佛为主余九为伴。思之。后二偈颂前总显诸劫。亦表智满行圆无非佛故。第四去此不远下指示后友。亦以证同。又禅依进发。故云不远。禅故寂静入俗演法化物深广。故云音海。然此神即普救之母。表真精进却从定生。起心动念是妄非进故。余可知(已下入第七十一经)。第五寂静音海夜神。寄难胜地。文中具六。第一依教趣求。第二顶礼其足下见敬咨问。第三时彼夜神下称赞授法。于中先赞。后善男子我得下正授法界。于中二先略标名体。准下有二意。一化生遂志故。生喜即福德庄严。二观佛菩萨胜用故。欢喜即智慧庄严。观化既无间断故。喜亦念念出生。后善财言下广显其相。于中三。初显解说业用。次明解脱所因后彰发心久近各有问答。今初先问有四。一问所起业用。二问所行之境。三问能起方便成上所起。四问能观之观成上所行。后答中即分为四。初答起何方便。以悲智双运等心。为能起之方便。二发是心已下答为何事业。正以化生为事业故。三复次善男子我常观察下。答作何观察。谓观察菩萨如来。四又善男子此解脱无边下。答行何境界。以无边无尽甚深广大能所不二为所行境。问中欲显能所别故。先问所成后问能成。答中欲显能所相成故。隔句相属。又由能起所故先辨能。又观察中虽有所观意在能观。所行境中虽是所行而义兼能所故。四问全别。是以晋经行何境界名何境界。云何此则兼通分齐之境。非但所观。今初能起方便中有二十心。前十起上求大智心。后我发起令一切众生超过下十心。下化大悲心。第二答所作事业中。有标释结。初标可知。二所谓下别释。有三十七门分三。初十五门随其便宜。以十度化治其十蔽。于中初五门双明舍戒。以舍一切着则戒净故。后十心明余八度。而般若及愿各有二门。次色相不具下有十二门。化无功德众生。令得佛因果功德见第一义。后贪行多者下十门。但以对治门破其惑障。三善男子我以此等下总结化意。见物成益故大欢喜此即释名中初意。第三答观察问中二。先观菩萨境界。后善男子我观察此道场下。观佛胜用。于中三。初结前生后。知佛神力下义当生后故。次我观毗卢下正显有其十门。后我见是已于念念下总结。近结前之十门。亦远结前观菩萨境。以所观境皆称性故。于中先标喜成益。后何以下征释益由。以能观之大智称法界之体相故。所生信等等一切智。第四答所行境界问。通二种境。如言入法界门即所观境。发一切智性心即分齐境。余可准思。文中分三。初十门法说。次犹如影下二十二门喻说。以深广相难可知故。后我今为汝下一句总结劝修。第二尔时善财童子下。明得解脱因中。先问后答。答即十度为因可知。第三善财童子言圣者下。明发心久近。欲显道根深故。先问后答。答中二。先长行中三。初于余刹海中发心修行。二然后命终下。于娑婆界中修行得法。三善男子汝问于我下结酬其问。今初分二。先于第一刹尘劫修。后于第二刹尘劫修。前中分五。初总显刹海。二此世界中下别彰时处。三有佛名不退下。显于初佛发心得定。此即正酬发心之问。自此已去皆显修行得法。是知先问。亦含问其得法久近。神名具足等者。亦表五地入俗福智高胜故。四此道场中次有如来下。略举次前九佛。五善男子清净光下。结略显广。此举一劫之中刹尘数佛。皆悉供事。二从此命终还即下。于第二刹尘劫修行。界不异前故云还即。劫时有异言历刹尘。前虽数数命终。今语前劫之末。是知前普光明幢劫。即是大劫。其中已含有刹尘数小劫。此中但明尘数小劫。略无大劫之名。二文影略故下结云。于二佛刹微尘数劫中。修菩萨行。是则前段一如来兴义当一劫。若以普光明劫为刹尘之一。此命终之下结成刹尘之劫。则阙二字。故晋经言于彼世界。经二佛刹微尘数劫。方顺下文二劫之言。一劫已有刹尘之佛。则佛弥多矣。第二于娑婆世界修行得法中二。先举此前三佛。后次值毗卢下显遇本师得今解脱。则前所得望此皆因。于中二。先名体。后得此解脱已下明业用。此中业用。非独事业。良以前之四问皆业用故。故此通包。于中二。初标所入海数。后见彼一切下明海中所见。展转深细略为四重。一刹海中尘。二尘中之刹。三刹中之佛。四又亦见彼下佛毛变化。于中二。先通力演法。后我得下明夜神悟入。于中有二。一总显能所悟。二一一法门下明重重微细。于中二。先总显十重。后一一智光下。别显智光之用。今初有十重一切。显无尽法门。十中前五约所悟。一法门者。如般若一门中有多契经。二随一契经诠多深广之法。谓含诸度等。三随一深法有多品类。四随一类中有多事法。其一一法含旨如云。五随一根本法云。流出众多支派后五约能悟可知。二别显智光之用者。是第十一重但广最后一重。功用无边则类前重重不可尽也。于中初句总该横竖后知无量如来下。别显横竖之中所知于中五。一知如来因地之行。二知往昔超菩萨地下。知佛因地之位。三知为菩萨时常见下。知因地作用。上三知因。四知无量如来放大光下知果用。五彼诸如来下总知因果。第三结酬其问中三。初结此前。次及此劫中下。类显未来及于余界。后善男子下结劝修学。第二偈颂有十偈分三。初一诫听劝修。次八正明昔行。于中前四智行上供。后四悲心下救。后一结行分齐。第四谦己推胜。第五指示后友。般若为得佛之所持。言菩提场。般若若现则善守心城及一切智城。万行由生为增威力。第六恋德礼辞中。初以心观。次以偈赞。后以身礼。偈中十偈分四。初一明因友得见。次二寄对显胜。次六当相显胜。后一总结圆融。第六守护一切城夜神。寄现前地。第二见彼夜神下。见敬咨问可知。第三时彼夜神下。称赞授法。先赞发心之相。后善男子我得下。正授法界。于中三。初标名体。二显业用。三辩法根深。今初即事契理。故曰甚深权实无碍蕴摄妙辩。称为自在。依此演法普应群机。是为妙音。二为大法师下显其业用。于中三。初总明次别显。后结益。初中二。先十句彰法施之德。后佛子我以此等下显法施之意。第二善男子我以如是净法下。别显业用。于中三。初释甚深。次释自在后释妙音。初中三。初总标。次何者下征列。列法界中十种别义。约十种行显之。以行必称理理由行显故。谓一无分量。二无边际。三无齐限。四无涯畔。五竖无断绝。余可知。后善男子我作下结前观益。二又善男子我如是正念下。释自在义谓总持权实故。各就所持立名可知。三善男子我或为众生下。释妙音义。于中二。先别明后总结。今初有二十三。向初三约三慧。后二十句为十对。约广略辨。略言一者通理通事。理一有者二十五。昔理无二故。事一有者。同一有为故。余可思准。后我以如是等下总结。第三善男子我入下结益中二。先别结甚深益。由入无差别故住劫而不疲。后我成就下。通结妙音自在总持故。增长解脱。妙音故充满法界。第三时善财童子下辨法根深。先问后答。答中二。先辨初劫修行。后后是已来下类显多劫成益。今初分二。一总举刹劫。言世界转者。谓世界为尘一尘一刹。复末为尘故。亦犹无量无量为一无量转等。若取回转形。世界尘者。何以偏取此形。二善男子彼世界下别彰遇佛。于中四。初总举佛数兴处。二其最初下。别明于初佛得法。三次有佛兴下。略举次前百佛。四善男子如是等下。结略显广。二中分六。一标佛现。二彼佛出时下父王出家。三法欲灭下恶世过兴。四时王比丘下灭过弘阐。五时有比丘尼下。王女见闻发心得法。即正答得法久近也。六于汝意云何下。结会古今成益。三略举。四结广及类显成益。文并可知。第四我唯知下。谦己推胜中先显己知一。略显四种业用。若约妙音释。则不绮不离间不妄不恶口如次配之。若约甚深释者。不与理合皆名戏论。理外发言即是二语。既与理乖则非真非净。反此可知。后如诸下推胜知多。第五指示后友分三。初指后位。次颂前法。后善财得益。今初开敷树华者。约事在香树阁内故。约位七地是有行。有开发无相住故。二颂中颂前法者。临去殷勤属令修学故。十一偈分二。初二偈颂前体用。余颂显法根深。于中亦二。初颂初劫。后一偈颂类显多劫。前中三。初三通颂初后。次四别颂于初佛得法。后一颂中间百佛。及后结文。三善财得益。虽通由前。文亦近由此。于中先长行叙益。后观察下偈颂庆赞。十偈分四。初一赞福智超绝。次四叹悲智甚深。念念攀缘一切境。不碍分别事故。心心永断诸分别。常契理故。又上句约观下句约止。即止观双运了达无性。成无分别而起大悲。成上攀缘。攀缘即分别耳。不唯属妄。次四总显德圆离障摄益。后一成行入位(已下入第七十二经)第七开敷一切树华夜神。寄远行地。初二可知。第三夜神言下授已法界。于中四。一显法行。二立法名。三明业用。四辨根深。今初亦是法门所作业用。对先问行故。总示其行未举法门之名。于中二。先明安乐众生行。后善男子若有下利益众生行。令物断恶修善故。于中先总。后为悭吝下别显十度。治十蔽障。第二善男子我已成下立法名。此有二意。一望前称已益物悲智之心。故生大喜。二者望后照佛摄生广大悲智故生大喜。第三善财言下明业用中。先问后答。问中以是业用分齐。故云境界。答中三。初总标。谓知佛摄生之智为业用分齐。二云何普摄下。略显普摄之相。谓一切物乐皆由佛得。故知佛摄。三云何知然下。广显巧方便智。先征可知。后释意云。我见如来从因至果。大悲巧摄故。知乐由佛生。于中二。先总明。后善男子世尊往昔下别显。于中亦二。先发善巧普摄之心。后起善巧普摄之行。前中亦二。先见发心之境沈苦集故。后见如是下正发救心。令得灭道。于中先并起慈悲后起观察下双运悲智。二起如是心已下。起普摄行中亦二。先别明利益众生行。后善男子毗卢遮那下。杂明种种行。前中三。初举摄生行体。次以是方便下明摄生本意。后菩萨如是念念下辨摄生周遍。即广大义。二杂明种种行中二。先明观机彰苦集无涯。后起大悲心下显修行无量。于中三。初总明化益。次为说种种下别明化法。后令诸众生下总结化意。第四善财童子言下辨法根深。先问后答。答中二。先叹深许说。二乃往下承力正酬。前中二。先长行亦二。先叹深难知。后承力许说。前中四。一标难知。非唯久远难知。抑亦当时发心。已得深法满佛境故。况无久近相非常见闻故。难信非闻慧境故。难知非思修故。难解难入上皆心缘处灭故。难说者言语道断故。二一切下显不知人三唯除下拣去能知即善财之类。四何以故下征释所以。以是佛境故。权教菩萨尚不能知。况前劣耶。二然我今下承力许说。后尔时下偈颂。二十一偈分二。初十九偈颂叹深难说。后二偈颂承力为说。前中四。初一偈颂标深难说二有三偈颂不知人。三有一偈超颂前释。以是佛境故。惑者不知。四有十四偈总颂拣去能知。次第颂前佛力所护等。恐繁不配。说者随宜。第二承力正酬中二。先长行亦二。先正说后结会古今。前中四。初总显发心时处佛兴。二善男子彼普光明下。别举本生时处。三其中有王下。明发心胜缘。四时此会中有童女下。正显发心本事。初二可知。三中有四。初明大王治化。即铁轮王故云阎浮。二时彼世界下。五浊为因感三灾果。寿命短促即命浊。资财下众生浊。不修下烦恼浊。任情下见浊。劫浊则通三。咸来共绕下悲境现前。四尔时大王下正明起行。于中二。先深起大悲。后作是语已下广行大施。于中八。一施令弥布。二其坚固下施会大敷。三时彼大王下施主超伦。四尔时阎浮下施田云集。五时王见彼下施心殷重。六善男子其王尔时下施愿广深。七已能深入下施慧玄微。八不拣方下施时均普。第四正显发心本事中六。一发心身德。二时宝光明女下。正发大心同王心故。三尔时大王下王发摄言。四时宝光明下女赞王德。五时彼大王下大王述赞。六王赞女已下施行摄持。六中前三可知。四女赞中三。初标心净。次发口言。后展身礼口言。偈中五十二偈分二。初二十五偈总显王德。后王父下二十七偈。显王本生。前中有四。初六偈明王未兴时损。次二偈明王兴世之益。三有十偈翻损成德即翻十恶。四有七偈明依正难思。后显王本生中四。初四偈明先王世末。次八偈明王兴先相。三有七偈正显诞生。四有八偈生后之益。身礼及王赞述等可知。第二善男子尔时一切下。结会古今。第二尔时下偈颂。但是总相显已能知。于中先九明能知。后一结劝(已下入第七十三经)第八大愿精进力夜神。寄不动地。无功用道任大愿风普救护故。第一依教趣求略无念法。亦表无功离念故。第二见彼夜神下见敬咨问。然亦含二意。若约显说则自此。尽偈皆第二段。至夜神答言下。方属第三授已法界。若约密授则此现胜用已。为授已法界。善财发同善友心。便已得益。义虽通二为欲顺文。且依前判就文分三。初见胜用。次时善财童子下设敬证入。后尔时善财说此偈已下。咨问法要。今初先总见所依。后现日月下别显身相。有二十四身。初十即应机摄化身次现一切佛所下。六身是应法成行身。余是离障契理身。多随内德显身差别。见身了心。二设敬证入中四。第一设敬陈礼。第二于善知下发增胜心。第三发是心已下深证悬同。第四既获此已下以偈庆赞。初二可知。三中有标释结。今初由前起同己等十心故。得同善友等行。通论同有四义。一人法无二。与一切法界同。二因果无二与一切诸佛同。三自他无二。与一切菩萨同。四染净无二与一切众生同。今云得彼夜神与诸菩萨同菩萨行则正是第三。义兼余三。由见初。故则不殊余二。方为究竟之同。良以八地证无生理。自他相作皆无碍故。偏此明同。故下列中有无生忍。二所谓下列释。八十四同。各有标名释义。文相自显。三时善财童子观察下总结第四以偈庆赞。十偈分三。初八颂前发增胜心。次第颂前十句。初六偈各颂一句。第七偈上三句。颂第七。下句颂第八。第八偈上半颂第九。下半颂第十。二有一偈颂前深证悬同。三一偈颂荷恩深重。第三咨问法要。前已睹解脱之用故。不问云何修行。直征名而已。文有三问。第三夜神告言下授已法界。前即默授。今方言授于中二。初答名问后答发心久近。所以不答第三成菩提者有二意故。一显悲增如休舍说。二显久成示居因位故。下所救千佛尚已久成。况能救耶。前中二。先标名。谓现身广化。令生诸善究竟得佛。故名为根。后我以成就下。显其业用。谓契理之用故用而无涯。动寂无二。于中三。初明内契理事。二而恒下明大用无涯。略显九十八种色身。并初后标结即为百身。起信等论。明八地当色自在地故。此广辨色身种种。约其类别非一。约一类而多余可思准。三念念中现下总结深广。于中四。一结所作之业。二善男子当知下结能现所因。三善男子我入下双结寂用无碍。四一一身下结成深广。第二善男子如汝所问下。答发心久近中二。初叹深许说。后正答所问。前中三。初牒问许说二善男子菩萨智轮下叹法甚深三佛子菩萨智轮虽复下。结承力说。二中先法说后喻明。今初先标后释。释中先正释本性约理。离分别约智。超障约所断后随所应下释妨。既无长短。今说长短者为利生故。欲长则长显法根深。欲短便短显法超胜。后喻显有五。一皎日随时喻。谓日体恒明映山出没。智无三世心障见殊。二日轮现影喻。谓白日无来随处隐显。智轮常寂机见短长。三虚舟运物喻。喻菩萨无住摄生。四太虚无碍喻。喻于菩萨无功益物。五幻化无真喻。喻即用而寂。然上诸夜神叹深。皆仿斯法喻。三结承力为说可知。二佛子乃往下正答所问。先长行后偈颂。前中三。初善光劫中行因得法。次日光劫内供佛修行。后总结时处。初中二。先明最初佛所修证。后转生值佛修行。前中三。初古佛出兴。二是时国王下先王治化。囹圄者周之狱名。三王有太子下夜神修因。于中有三。初明在家本事。二结会古今。三出家得法。今初有十一悲救罪人。正答发心之始。榜笞捶击也。膑谓刖足之流。二臣议非理。三请代囚命。四臣执令诛。言宝祚者祚位也。易云圣人之大宝曰位。五王后哀祈。六王夺子志。七太子确救。八母请修因。九正设施场。十经半月下如来亲救于中六。一就戮时临。二时法轮下如来降德。三尔时太子下敬申礼请。四以佛神下就座谈经。言普照因轮者。谓令知善恶各自有因。罪人恶因所招。太子善因当满故。五时彼会下广益当机。六善伏下太子得法。二善男子尔时太子下。结会古今分四。初结自身正酬发心之问。二结大臣。三结狱囚。四结王属。并文处可知。萨遮有也尼干不系也。裸形自饿不系衣食故。三佛子我于尔时下。明出家得法。各言百万。义当彼时已得四地。二佛子我于尔时命终下。明转生值佛修行。略列八佛通结一万。第二次复有劫下。明日光劫中。值佛修行。中三。初总标举。次最初下别列十佛。后于彼劫下总结得法。第三如于此劫下。总结时处修行得法。第二偈颂中有三十四颂分四。初一颂承力许说。次二颂古佛出兴。次一偈半先王治化。余颂夜神修因。于中四。初九偈半颂在家本事。次一偈颂出家得法。三有二偈颂一万佛。四次于佛刹下有十七偈。颂总结时处得法。于中三。初一略标。次三总会古今。后十三偈。重颂末后得法深广。四谦己推胜。第五指示后友岚毗尼林此云乐胜圆光。昔有天女下生此处。因以为名。表九地总持光明无不照故。友名妙德圆满者。善慧无缺故。然此园在迦毗罗城东二十里。是摩耶生佛之处。又从九地当得受职。是故今问生如来家(已下入第七十四经)

大方广佛华严经疏卷第五十八大方广佛华严经疏卷第五十九

        唐清凉山大华严寺沙门澄观撰

第九岚毗尼林神寄善慧地。初二可知。第三彼神答下授已法界。于中四。一显法义。二立法名。三明业用。四辨根本。初中二。先长行后偈颂。前中四。一标数叹胜。二征数列名。三依名释义。四结叹胜益。初中生如来家。即正酬其问。第二何等为十下征数列名。此十通于六位。一当十信。二即十住。三通行向。四是初地。五从二至七。以是功用边故。六七皆八地。然六即自分。七即胜进得劝之后。八即九地。九当十地。十即等觉入如来地。然依行布竖配定。然若约圆融。初后通用故云成就。此法则生如来家。若定须具十方得生家。何以文中。第二第六皆有生家。第十复言于三世佛所已受灌顶。故知须竖约证分异。若定竖者。则违具十则生之言。是知须横约圆融修观。第三善男子云何名下依名释义。一中即信发心故。贤首品云。常欲利乐诸群生。庄严国土供养佛故。故文云始集善根。二中初住发心。文具三心。生如来家亦初住生家。三中十句。一观法门海标十行。二向一切智标回向。以行愿相资故合为一。余八通行向。四中契理断障名深净心。即净心地已证理故。坚如金刚已得离生道故。舍诸有趣已破二障碍山故。为物依处。五中证如起行为平等光明。戒忍进等为次五地。得无碍下即是七地。七地得无生忍光明故。入一切真实法六中以得无生忍契同法性。为生佛家。愿度增上善根一体。惑等不动为白净法。七中因佛劝起能顿修行。名佛力光明。无功用修故无疲厌等。八中从第八地入第九地。故云住童真位。观一切智智门。即法师之德故。于三性等皆如实知即事知理之如实故。于有差别境入无差别定。即理穷事之如实故。于无差别法现有差别智。余可准思。九中以佛庄严而庄严。故名普庄严。已得离垢等诸三昧故。虽复常用而常在三昧。十中约其自分为此菩萨。约其胜进名入佛地。已受职位云受灌顶。智齐佛境云知一切。如十定品辨。第四佛子若菩萨下。结叹胜益可知。二重颂中十偈如次颂前十法。第二善男子菩萨具此下。立法名中先牒前所明。后我从无量下指前立目。机感便现无所拥碍名自在受生。通能所现。第三善财白言下明法门业用。于中先问后答。答中知见此境即是业用。于中二。先明依愿受生。后经于百年下如昔愿睹。于中四。初睹降神瑞相。二善男子摩耶下见出城现光。三摩耶夫人于毕洛叉下。睹将生神变。于中二。先标征。毕洛叉者此云高显。后别显十变。一集众息苦。二卷舒无碍。三毛现佛因。四现佛本事。五现行所依身。六遍现舍行。七现古佛受生园林。八现今佛所处宫殿。九出菩萨同类。十地现莲华将承至圣。四善男子岚毗尼下正睹诞生。于中三。初睹外相有四种相。释通事理。约事谓一回耀挺特故。二高显邕容故。三威光赫奕故。四分明可睹故。约理则一依性空无住现故。二依涅槃山无心出故。三大慈云中现无住之化身故。四为破众生生死无明之大闇故。二菩萨尔时下了其内德。三当我见佛下。结其周遍。则横竖无穷。第四时善财童子白彼神下。显法根源。先问后答。答中先长行中六。一古世佛兴。二其四天下显昔父母。三其喜光下攀树诞生。四时有下观佛得法。五善男子下结会古今。不结父母者。意明即净饭摩耶。佛即今佛故。六我从是下显用周遍。后偈颂中二十三颂分四。初一诫听许说。次九最初修证。次十二偈历事增修。末偈结叹无尽。第五指示后友中。言瞿波者。此云守护大地。在家为父母守护太子。储备守护国地。既为其妃依主得名。表十地既圆故无地不护。然太子有三夫人。一名瞿波。次名耶输陀罗。三名摩奴舍。今因位之极故取。其第一法喜已满故。寄之昔妃。此位亲能得佛。故在生佛之城矣(已下入第七十五经)第十释女瞿波寄法云地。第一依教趣求中。二初依前修证。后渐次下趣求后友。于中四。一趣求诣处。二其中有神下伴友迎赞。三善财童子言下善财印述。四尔时善财下神敬增深。二中四。一赞行究竟。二我观仁者修诸下。赞精进得果。三我观仁者勇猛下。赞精进得法。四何以下以理释成。三善财印述中二。初印受所说。后圣者我愿下述自所作。于中二。先明四等摄生。后明万德益物。前中有四。谓法喻合释。法有慈悲合中兼喜。释中不贪兼明有舍。于中先征后释。释中先总明。后不贪生死下别显。于中先明不自为。后但见众生下明其所为。二圣者菩萨摩诃萨下。明万德益物。于中二。初有十六句。别约喻显为物归趣。后圣者菩萨如是下结成益物。四神敬增深者。以闻上法故。文中三。初长行申供。次以偈赞德。十偈分二。初三叹下益众生行。后七叹上求无碍行。后尔时下以身随逐爱重情深故。第二尔时善财童子下。见敬咨问。先见次敬后问。前中二。先入堂推求已见依报。此文亦可属前。二见在堂内下见其正报。初见主。后八万下见伴。广叹伴从胜德主德。固已绝言。二尔时善财下设敬。三作如是言下咨问。于中先自陈发心。后而未知下正问。有十一句。问悲智逆顺权实寂用无碍。双行之行。前十句摄为五对。一过凡越小对。二离果超因对。三现生示色对。四极相穷说对。五下化上供对。十一总显诸善真俗双行。第三时瞿波女下示已法界。于中四。一法义二法名。三法用四法根。前中先长行。后偈颂前中亦二。先赞诫许说后善男子下正显法义。于中二。先明帝网智光行。谓依此十则照重重无尽法故。有标释结可知。后佛子若菩萨下承事善友行。前明依法此辨依人。法假人弘故。由得此出无尽法。亦是广前初一。亦有标释结。后偈颂中有十二偈分二。前十偈如次颂前十帝网行。然前长行但名帝网光明行。则十法通称。今偈中初二取前总名。后之八行。各别立称。则知十名一一通其十行。重重无碍方受帝网之名。叉须得斯偈意方了前名。后二偈颂前事友十法后二。以后二相隐故。余略不颂第二时释迦下立法名。谓一切菩萨普贤三昧深广如海。如法界。故深如众生名故广。以殊妙智念念观察故立此名。第三善财言大圣下。明法门业用中。先问后答。答中二。先显广知。后释知所以。前中三。初知娑婆世界。次类知刹海。后别显毗卢因果。前中二。先知刹尘劫事。后善男子此娑婆下。类尽未来前中亦二。一知世间善恶因果。不善根所摄善根者。如嗔心持戒等。下句类知。二又彼劫下知出世因果。于中亦二。先知佛因果。后亦知彼佛众下知佛众会。于中有三。初知声闻。二知缘觉三知菩萨。及后类尽未来。文并可知。第二如知娑婆下。类知刹海于中二。先通显知多。后别显所知相状。今初有六重类知后后广于前前。初二皆全刹摄多刹。而初但摄同类刹故云尘数。二即异类刹故云一切。一切种类故。三即尘中摄刹故。细于前。四即十三佛刹尘数围绕界。及广大眷属世界。故云娑婆世界外等。五即普照十方炽然宝光明刹种所摄刹。通二十重。六即全莲华藏世界海。后所谓下别显所知相状有十种。一广博即所依种。二安立即因缘或所依住。三即轮围。四即其中场地。五体类各殊。六转者有二义。一如轮侧转形故。故世界成就品云。或有世界随轮转。二即劫转变故七所依莲华。八即其中须弥九随缘立称。十即结果属因谓华藏世界海。是佛本愿所严故云由力。第三亦念如来下别显毗卢因果。于中二。先明因。然有二义。一者成上上。但总云本愿力故。今别显成刹之因。二者顺从亦通正报之因。后得于如来下显果可知。第二何以故下释知所以。第四善财白言下显法根源。先问后答。问中虽但问得法久近。而义已含修行久近。得此法门故。答中分四。一明最初佛所发心修行。二于中间多佛修行。三正明得法之时。四多劫修莹此法。初中分二。初正显本缘。二结会古今。前中分十。一王都时处。二太子超伦。于中先具相后游观。三宝女求归。于中分四。一具德端严。二见其下白母求事。三彼香牙下梦睹佛兴。四时妙德下自陈心。总有十偈。前三自述德堪。后七赞彼求纳。四太子审问。有十二偈分三。初二问其属缘。次三审其内过。后七邀其进善五女母代答。明有德无过。亦不属缘故应纳受。三十一颂分六。初十一偈总显报胜。次三偈别赞端严。三有三偈明其绝伦。四有五偈伎能内满。五有八偈离非具德。末后一偈结赞所宜。六太子重邀。谓若不障道当随汝意。于中先长行分二。初自述行深。后当于尔下恐其为障。后偈颂十偈分三。初六偈颂其行深。次二颂半邀其莫障后一偈半结令审思七女敬顺从。有十四偈分三。初三忘苦眷德。次六希同胜行。即正是发菩提心。后五劝诣如来。八太子摄受由敬佛心欢故。九母陈庆遂故。重赞女德。十偈分四。初一标其遂志。次二德行悬同次四身语超伦。后三内心蕴德。十正共修行。亦分十段一诣佛供养。二时佛下闻经得法。三时彼太子下辞归白父。四尔时大王下王审庆闻。五作是念下禅位往观。六尔时下闻经得法。七其众会人下兼益时会。八时佛下佛重现通。九时彼父王下。父王出家修证法门。十尔时太子下。太子绍位弘通大化。第二佛子于汝意下。结会古今。第二彼佛灭后下。见中间多佛略列四十。第三其最后佛下。正明得法之时。最后者。即六十亿那由他之后耳。第四佛子我得此下。明多劫修莹于中二。一于一刹尘劫修行。于中亦二。先多劫修行。未穷菩萨之境。后佛子若有下。明菩萨难遇见者不空。二佛子我见下于百刹尘劫修行。于中亦二。初多劫修证未知菩萨解脱。后何以下释不知所由释中亦二。先总显深广。谓所以不知者。以称事理之无边等诸佛之境界故。斯则等觉菩萨解脱。十地不知故名普贤解脱。后佛子我于佛刹下。别显深广难知之相。谓一毛即不可穷。况多毛多身广大之用。以是无尽无边之法门故。于中五。一毛中见器世间。二见智正觉世间。三见众生世间。四见菩萨修行。五佛子我于下总结不穷深广。第五指示后友分二。先指后位。如后当释。后颂前法临行再述故。三十一偈分三。初一总显菩萨益生。超颂前见者不空。生下女人染心之益。次十五偈明远劫前事。长行所无。长行语真净发心。但论德女。今则收其杂善故叙远缘以粗况妙。后十五偈正颂长行德女因缘。第六礼辞可知。上寄位修行相竟(已下入第七十六经)自下大文第二从摩耶下。有十一人。明会缘入实相。谓会前诸位差别之缘。令归一实法界生于佛果。如摩耶生佛故次明之。然人虽十一约法唯九。约会为十。初一为总余九为别故。摩耶得智幻法门。末后亦得幻住。始终相会该于中间。总别圆融归实无二。故摩耶既会缘入实。何得更须十人。岂不向言总别相会。非别无以成总故。又显是所会之缘。语十表其无尽。无尽之缘。皆成摩耶之实德故。又此一相义当等觉。等觉方能亲生佛故。等觉却入重玄门中故。有十人多明入俗。初天主光且须正念无失。次可为世师。遍穷众艺字智之门。无依无尽无著清净。清净则净智发光。发光则智相无尽。无尽则诚愿不违。方能还归幻住故。虽十一不失入实之言。始末皆幻方知诸缘体虚即实。今初总中文亦具六。第一依教趣求中二。初将诣观成。后胜缘引导。前中三。初标将诣观成。次作如是下别明观念。后如是之人下思欲亲承。今初摩耶昔云天后。天后能生佛故。权教中说生佛七日命终生天。而晋经指在迦毗罗城。则显常不灭矣。又上云此世界者。亦表即佛境界故。得观佛境智。然说摩耶或云是实非化。或云是化非实。或云亦化亦实。或云非化非实皆带方便。约此宗说。即法界实德人法圆融。二别明观念中。初总念胜德已能闇合愿智幻门。后随意生下。别念一十七身唯普眼见。冥契下文天后所现。三思欲亲承可知。二作是念已下胜缘引导中三。初城神显教修心。次身众神密加授法。三法堂罗刹教求友之方。初中有三。初以华散。二作如是下。正以言教城神令护心城。是知无有一事非法门矣。心名城者。中有正觉法王万德所聚故。有三十门分三。初有十二门明十度行。初后合二。中八各一次扶助成十一句。即初地净治地法十种胜行。文少不次而数全足。一信二慈。三坚固四悲。五舍六七皆惭愧。谓不容恶故。八无疲厌九如说行。十知诸经论。十一即成就世智故。能普晓众生。后住持下七句福智圆满。初二是福。后五是智。智中前三权。后二实。三佛子菩萨下结赞征释。第二身众神密加授法中三。初赞友令欣。次从其耳下放光加被。后善财即得下善财获益所谓十眼言不思议身者。十身无碍故。佛平等者佛佛同故。故异于前。但明法身余可思之。第三时有守护下教求友之方。于中三。初教次问后答。初中二。先教十法增其智。后示三昧息其乱。各有标释结。今初释中有十一心。一直二悲。三智四进。五信六深。七慈八净。九益十巧。十一常。后示三昧释中。于境不舍离等者。凡夫染境二乘舍境。权教纵观空有互陈并为缺减。若圆修者触目对境穷尽法源。不取不舍故。央掘经云。摩诃衍者。所谓彼眼根于诸如来常了了分明。见具足无减修等。又云所谓眼入处。于诸如来。常明见来入门具足无减修等。余可知。结中处处遇友者。既定慧双游无境不契。并为道品。则真友悬通能如是行。为护正法堂也二说是语时下问。三罗刹下答有四法。一以友无不在故。二以法为体故。三身同友遍故。四智与境合故。如梦如影。又前三即离境界相。四则离心缘相。求善友者幸思此言。第二尔时善财受行下见敬咨问。先见次敬后问。初中先睹依后见正。今初先受行其教蹑前起后。近蹑罗刹之言。远通前三胜友。以前二神并未有答故。即由前三位调练故。得睹斯胜报。后即时下正明所见。于中三。初明莲华所证法界。自性无染故曰莲华。无明既开不离心内如从地涌。亦表性净万行之四从法性地而出现故。此即十定中普贤之华也。二于其台下明台上楼观。谓能证权实二智。依于所证而重现故。智包无外云普纳十方。总摄五位自分胜进。故云千柱行列。其一一事皆有所表。恐厌繁文。三其楼观下。明楼中宝座即智体自空。故云楼中有座。空具性德故广显庄严。二尔时善财下见友正报。于中二先结前标后。前但明主座。今双结主伴。后所谓下别显身云。于中亦二。先明身相。后显身业。前中亦二。先明万类难思身。后明一类超胜身。前中亦二。先显别相。后明通体。今初有四十身。于中或唯约事。如普遍色身。或唯约理。如十二十三不生不灭身。以本无生起灭亦不为灭故。或事理交彻。如第三十二三十五无生不生色身。以事显理故。于中无生。则约自愿所成。无别有生。不生则随他而现。生即不生。余可思准。后如是身者下明其通体。谓离有取蕴故。二尔时善财下。明一类超胜身。约唯女故。二现如是等下明身业中二。初总标。后行于平等下别显亦二。先明十度行。唯精进在于忍前。余皆如次。谓初明檀。次出生下戒。戒能生长故。三修习下进。四观察下忍。五具众下定。六恒转下般若。七见诸如来下方便。八成就大愿下愿。九心恒遍入下力。十得佛智光下智。后修习一切如来下明二严行。未为佛母者是其本行故。第二尔时善财下。设敬自道已深故。现身等彼。上二并是住体遍应。第三白言大圣下咨问所以。叙文殊等者。若约等觉则因位极故。若约会缘。从初发心一一善友皆是所会之缘。同入比故。第三答言佛子下示已法界。于中三。初明体二业用三根源。今初大有二义。一愿大。愿为一切诸佛母故。二智大。智亦二义。一权智即能起大愿。能成幻事。二实智即是般若。生佛真身。幻亦二义。一愿智体虚当相名幻故。上文云。幻智即是菩萨。菩萨即是幻智故。能无不为。二者即智所作生佛之义。谓于己身不坏小而广容。若于佛身无生起而现起。又愿收普贤智收文殊。皆入大幻同为般若。亦名佛母。二是故常为下业用中二。先总。后佛子如我下别。于中有四。一为现在遮那母。二善男子如今下。为过去诸佛母。三如此世界下为贤劫千佛母。义通三世。四如于此三千下。结通横竖无穷。初中二。先标为刹海舍那母。后又善男子下别显生佛之相。于中四。第一毛光为先相。于中五。一光入身。二光现变。三见八相。四现因果。五令身难思。谓不大而容十方故。第二尔时菩萨下。正明自在入胎。于中亦五。一眷属翼从。二菩萨现通。三光明息苦。四现变入胎。五入已游步。第三又念念中下腹包众海难思。第四善男子如此下。举此类于百亿。本来无二者称一性故。非一处住者体周遍故。非多处住者不如事故。又上句不坏多故。下句不坏一故。又上句理如事故。下句事如理故。又一与多相即入故。此并释中智幻之义下。二三四段文并可知。第三尔时善财下辨法根源。先问后答。答中六。一轮王久远。言非后身菩萨所知者。显唯佛知非但久远。亦显时无时相佛智契故。二彼王城下有佛魔来。三圣帝助降。表智王助体本觉现故。此时已得菩萨神通。明今始成非实始也。四场神兴愿智假慈兴故。神生子想。五结会古今。六为母普周前来为生时之母。即是愿母。此明为成道时母即智母矣。脐中放光者。生长同气之所表。佛佛皆从无二理生故。后三段可知。第二遂往天宫下十友别明会缘。然位德已极托迹凡流。深悲接生不标神异。但以法利人。又显求者道深。或但示法门之名。则悬领旨趣。第一天主光即幻智念力。善友言天主光者。谓悲智胜用光净自在。破闇义故。父名正念者。此由定发。故故法门名无碍清净念初一句即依教趣求。第二见彼下。见敬咨问。第三天女答。下示已法门于中二。先标名。谓以一念无碍智普观三世。无不明现而无去来今。为无碍念不杂异念。为清净念。念佛功德有益悲智。故曰庄严。后善男子下明业用。于中三。一念最初一劫。二又忆下中间诸劫。三善男子如是忆下总结多劫。非唯忆念。亦于彼多劫多佛闻持此门。余并可知。下诸善友六段之文。多有不具皆可思准。第二童子师遍友幻智师范。善知识谓为童蒙师。遍与众生为善友故。居迦毗罗黄色城者。中道轨物故。不得法者略有四义。一与众艺法门同故。二法有所付显流通故。三表一切法门体无二故。四表无所得方为得故。第三善知众艺幻智字母善知识中。初二可知第三时彼童子下。授已法门中二。初标名体。谓以无碍智穷世间之伎艺故。二我怛下显其业用。字母为众艺之胜书说之本。故偏明之。有标列结。列有四十二门。皆言般若波罗蜜门者。从字入于无相智故。字义为门故。毗卢遮那经中皆言不可得。智无所得即般若故。又文殊五字经云。受持此陀罗尼。即入一切法平等。速得成就摩诃般若。才诵一遍如持一切八万四千修多罗藏。然初五字若准阿目佉三藏。即全是文殊真言。若准今本。而第二一字不同。今依彼经释之。一阿者是无生义。以无生之理。统该万法故。经云。无差别境而菩萨得此无生。则能达诸法空断一切障。故云威力。二多者。彼经第二当啰字。是清净无染离尘垢义。今云多者。毗卢遮那经。释多云如如解脱。金刚顶。云如如不可得故。谓如即无边差别故。如不可得。此顺多字义。应是译人之误。啰多二字字形相近。声相滥故。若顺无尘垢释。以无边之门。方净尘垢。三波者。五字经云。亦无第一义谛。诸法平等。谓真俗双亡是真法界。诸法皆等即是普照。四者者。诸法无有诸行。谓诸行既空故。遍摧差别。五那者。诸法无有性相。言说文字皆不可得。谓性相双亡故无所依。能所诠亡是谓无上。又云。以那字无性相故。者字无有诸行。者字无有诸行故。跛字无第一义。跛字无第一义故啰字无尘垢义。以啰字无尘垢义故。阿字法本不生。以阿字法本不生。故。那字无有性相。汝知是要。当观是心本来清净无染无著。离我我所分别之相。遮那经中字义与此无殊。下多依彼经。及阿目佉所译。而梵音轻重有殊释义无别。六逻字悟一切法离世间故。爱支因缘永不现故。离世故无依。爱不现故无垢。七拖字。悟一切法调伏寂静。真如平等无分别故。方为不退转方便。八婆字悟一切法离缚解故。方入金刚场。九茶字。悟一切法离热矫秽得清凉故。是普摧义。十沙字。悟一切法无挂碍故。如海含像。嚩字悟一切法言语道断故。能遍安住。哆字。悟一切法真不动故。不动则圆满发光。也字。悟如实不生故。则诸乘差别积聚皆不可得。瑟吒字。悟一切法制伏任持相不可得故。普光明即能制伏。任持烦恼即所制伏。息即伏义。迦字。悟作者不可得则作业如云。皆无差别。娑上字即时平等性。么字。即我所执性。我慢高举若众峰齐峙。我慢则生死长流湍驰奔激。伽字即一切法行取性。他字。即是处所性。社字即能所生起。锁字即安隐性。拖字。即能持界性。奢字即寂静性。佉字即如虚空性。叉字即尽性。娑多字即任持处非处令不动性。惑障为非处。开净光明为其处。坏字即能所知性。曷攞多字即执着义性。执着为生死境。义即智慧轮。婆字即可破坏性。圆满之言。不空译为道场。然此婆字宜蒲饿反。诸本多云蒲我。则与第八不殊。车字即欲乐覆性。娑么字即可忆念性。诃婆字即可呼召性。无缘召令有缘故。縒字即勇健性。伽字即厚平等性。吒字即积集性。拏字即离诸諠诤。无往无来行住坐卧。谓以常观字轮故。娑颇字即遍满果报。娑迦字即积聚蕴性。也娑字即衰老性相。室者字。即聚集足迹。谓聚集即一切众生。法雷即是足迹。侘字即相驱迫性。谓无我晓之。即为驱迫。陀字即究竟处。所谓此究竟处含藏一切法轮。然新译乃是茶字。去声引之。上来从娑上字来。皆上有悟一切法。下有不可得言。今并略之。若具皆如瑟吒字耳。其中难者已释。余以经疏相对文并可知。更有对会及修观仪所得功德。并别章具也。结云四十二门者。谓表四十二位故。故智论中诸位圆融。明初阿具后诸字。第四谦推中。推胜即就其所知众艺。寄胜推之不舍世俗。皆与实相不相违背。会同般若之门。五指后中。婆怛那者此云增益。以无尽三昧能出生故。友名贤胜者。贤犹直善。无依道场直善之最故。第四贤胜优婆夷。幻智无依善友。初二可知。三贤胜答下授已法门中二。初得解脱。后得三昧。今初直就经文。内外无依即是道场。贤首云。梵名那阿赖耶曼茶罗。那者。此云无也不也。阿赖耶云依处也依止也。曼茶罗云道场也。圆场也。谓无阿赖耶染分依处。而有净分圆场。出生胜德不可穷尽。即转依究竟显德无尽故也。下二句即二利之用。后得三昧先名。后非彼下用即为释名。于中初拣滥。后以能下显是。谓体则双超尽及无尽。但从用出生说无尽耳。然则二门相成无依道场。即空如来藏。无尽三昧即是不空。要心无依契于本空方见不空具性功德故云出生。智性眼等息妄显出故曰出生。出非本无犹称智性。指后云沃田者。是南天竺近水沃润故。显无念定水能滋长故。长者名坚固解脱者。无著清净惑不能坏。即解脱故。第五坚固长者。幻智无著善友。示法门中先显名。无著约境。离所知故。无念约心。心体离念故无烦恼。二障永尽是曰清净。净则能严法身。后我自得下彰用。既二障不生则无爱见故。无求求法无厌无休。第六妙月长者。幻智智光善友。真智廓妄名为净智。后智照法名为智光。能净能光若秋空满月。故名妙月。第七无胜军长者。幻智无尽相善友。法门之名。即所成德相无穷尽故。我以证下以用释名。得无尽藏谓闻诸妙法。又诸心境无非佛法故。若佛若法皆无有尽。既见佛得法无尽故。无能胜众德所聚。从喻如军。亦能普胜诸魔军故。皆从体出故。城名出生。第八最寂静婆罗门幻智诚愿语善友。授法中先标名。有二义故。一始终无妄故。如从初发心立弘誓言。必如言行不乖先语故。二者随行不虚故。如忍辱仙人言我不嗔令身还复。后过去下以用释名。即如次释前二义。虚诳言息故云寂静。寂静即为净行。言行君子之枢机。苟能诚实斯则可法。故城名为法。指后云妙意华门者。妙意华者即苏满那华。其城门侧有之故。亦在南天当受其训。得求友之妙意胜因之华故。童子表于净智。智则万德由生。童女表于净悲。悲为众德之本。以悲智相导故。二人同会。会缘之终此二满故。将见慈氏绍佛位故(已下入第七十七经)。第九德生有德幻智归幻门善友。第一依教趣求。第二见德生下见敬咨问。第三时童子下示己法门。于中二初标名后业用。今初谓能所境智染净之法。皆从缘起无定性故。如幻而住。二得此解脱下明业用中二。初别明后结叹今初有十种幻。皆上句标幻。下句以缘生释成。十中初一为总。缘生世界并通染净。刹海亦名世界故。余九为别。初五约染分依他。如幻缘生故。一约有情苦果。从业惑集生。二约十二因缘顺观即世间故。次第相由故云展转。三就五类法中但除无为。故云一切。以无为无有起。非幻缘生故。异熟识等。从无始恶习内执为我。四惑相应故云我见等。及外取妄境。云种种幻缘故。感心等悉皆如幻。四五二句别明不相应行。四即是时。谓依行相续不断分位。建立为时。所依行空时何所立。妄计有体是颠倒智。五即无常生老等。谓依生已坏灭分位。建立无常等皆妄分别有。次一切国土义通染净众生。染土多从三倒所生。以不了唯心妄取境界故。上云一切国土但想所持。既有妄想故心见皆倒。言无明所现亦通净刹。谓登地已上无明未尽。所见国土种种不同。既云无明则拣非佛土。后三种但约净分依他。从缘如幻可以意得后善男子下结叹。言自性不思议者。幻法非有体不实故。非无相非无故。非一性相异故。非异无二体故。空有相即一异两亡。既离二边亦忘中道。由斯交彻故。能一中现多多皆即一。重重无碍为不思议。故推胜云善入无边诸事幻网。第四善男子我等下谦己推胜。第五时童子下指示后友。于中二。初以力冥加。后而告下以言显示。于中三。初指处。二示人。三教问。今初国名海岸者。南海北岸。一生菩萨临智海故。园名大庄严。因圆万行而严果故。又生死园苑以万行树林严自果故。广大楼阁等者。约事则其中广博同虚空故。有多光明能遍照故。阿僧祇等宝所严故。蕴多楼阁包多事故。约法则二智相依缘起相由。故云楼阁。智即法界是为广大。名毗卢等顺成上义。二智光明遍照事理故。智能包含万德。即庄严藏。华严万行不离此故。上约其果。从菩萨下出因。善根果报约其宿因。是彼善根之果报故。念力愿力等约其现缘。后住不思议下现依所为。二弥勒菩萨下示人。先正示。后为欲下显住因。弥勒梵音具云迷帝隶。此云慈。是其姓也。然有三缘。一由本愿。过去值大慈如来因立大愿。愿得斯号故。二由此得慈心三昧故。三由母怀时有慈心故。如满慈子名阿逸多。此云无胜。以生具相好胜德无过故。今以姓而呼但云慈氏。慈依智住故曰处中。悲智双游皆为利物。故云为欲等。三汝诣彼下教问中二。先正教。兴十问者。表无尽故。后何以下释广问所由。先征后释。征意云。何以要须广问释有二意。一所求德广能具说故。后善男子汝不应下。能求大心。法应尔故。前中二。初通显弥勒德圆位满。后善男子彼善知识下别显是其真善友故。设若德满非已有缘亦难求故。二明能求大心法应尔故者。即广诫劝。于中二。先诫劝求法。后诫劝事友。前中二。先标不应。诫其去劣。后何以下。释所应作令其广修。文中先征后释。释中亦二。先别明应修。后善男子举要下。结略显广。前中有九十八门。分为十段。一上求菩提行。二应化下下救众生行。三应断下自断惑障行。四应令无量众生下。劝物出离行五。应消灭下净自根欲行。除三不善根。则成三善根等故。六应生净信下。力用自在行。七应分别下摄法治惑行。八应严办下供佛摄生行。九应修总持下。悲愿深广行。十应入差别心下证入圆满行。二结略显广者。谓别陈难具故。第二善男子汝求下。诫劝事友中三。初诫次劝。后双结二门。今初分二。先正诫其离过。后何以故下举益释成今初。言见随烦恼行勿嫌怪者善友有二。一实二权。权能行于非道。内外生熟善巧难知。故不应嫌。实中复二。一行二解。今但求解不应观行故。如智论五十说。亦如有目跛人犹能示道。二举益释成中有二。初明善友能示行故。二明善友为外护故。今初先征意云。但起广心足成大道。何以要令事友诫离过耶。释云。法假人弘。不因善友何能闻诸妙行。于中有三十五句。句各一行。二善男子菩萨由下。明善友能为外护。前即能生此能养育。于中二。前正明能为摄护。后何以下举因释成。于中初征意云。善恶在己。善友何能令我不堕恶趣等耶。释意云。由友令离恶因故。因亡果丧。岂非友力。以此四十句。释上正明十五句。有通有别。通则后诸恶因。通对前果。别则各各配属。如由除诸难不退大乘。由止诸恶不犯净戒。由破无明不随恶友。下诸句或有二三对上一句。可以意得。恐繁不配

大方广佛华严经疏卷第五十九大方广佛华严经疏卷第六十

        唐清凉山大华严寺沙门澄观撰

第二善男子善知识者。如慈母下教劝。谓教其事友之方。文有四段。皆约喻显。一教念友胜德。于中先叹胜。后常当如是下结劝。二复次汝承事下。教起事友心行。有二十一句。文显。三复次汝应于自身下。身友对辨文有十句。句各四事可知。四善男子汝应发如是心下结劝成益。于中二。初正劝。后何以下举益释成。于中亦二。先正释事友之益。后复次下。重赞友为能益故宜承事。第三善男子举要下。双结诫劝二门。谓别说难穷故结广从略。于中亦二。先寄数结多。后我复略说下总收结多。既通一切何但百千。明知前云十不可说意显无尽耳。第六时善财下恋德礼辞。自下大文第三慈氏一人明摄德成因相。前既会缘入实。定堪成佛故。办一生补处成因之义。文唯五段。以补处位极显彰阙谦推故。第一依教趣求中二。初标念前趣后二自忆下。别生胜念悔往修来。于中四。一观昔非以行对治。二复观此身下。观其现苦策进当善。诸修行者愿审此仿之。三作是念时下。明观念之益。益其胜观。四如是一切下结益所属。第二善财童子以如是下见敬咨问。于中二初见敬后咨问。前中亦二。先见依后见正。各有申敬。前中二。先入定申敬。后出定敬赞。前中三。初结前标后。二别显定用。三总结成益。今初。位念者标定。思察者定加行。信愿者是定因。入遍下辨定名相。二普现下别显定用。即双运定慧。于中二。一明即智定之妙用。于中先罗身云于法界。后等虚空下契法性之真源。二又决定知下明称法界之深观。于中三。初了法从缘。次离于断下智契无性。三知一切法如种生芽下会归中道。此三无碍即三观一心。今初报酬善恶故云业起。果自种生云从因起。自修成佛信为道源。感他化身敬心便现二契无性。中离颠倒见者。通三四倒。四倒谓常计无常是名颠倒。见于实理则无斯倒。若以无常为常亦非。见如实理以坏相故。自在见者。谓自在天能生万物。故知由自业故不由他。离自他见者。单执自他则乖缘起。边执见者。坚执生死等有其始末故。离有无者。从无之有名生。自有还无称灭。体无生灭何得有无。知空无生约理遣法。知不自在约缘遣法。知愿力生约因遣法。三会归中道者。然随一句皆离上诸过。今且通说。如种生芽者。从水土等缘生故非无。此如初段。缘生则无性故非有。如第二段。非有非无即是中道。如是离断常等可以思准。种芽横喻万法。如印生文即竖喻诸法。涅槃云。此阴亦灭彼阴续生。如蜡印印泥印坏文成等。自下诸句通于横竖。了世心现亦唯心观。以心为缘现而无性。即中道观。余并可知。三善财童子下总结成益。第二从地而起下出定敬赞。于中三。初以身敬绕。次作是念言下以心敬念。后偈颂中以言敬赞。二中举能住者德叹所住楼阁。初句具显故。此大楼阁之言贯通诸句。于中分十。初约境显胜。二是入一切甚深下约德显妙。三是以一劫下。约用显自在。四是于一切众生前下约行显胜。五是能住难知法下约观显深。六是住大慈悲下约对治显胜。七是虽住四禅下约止观明自在。八是虽于一切业烦恼下。约利他行显胜。九是虽行九次第定下。约护小乘行明自在。十此大楼阁下结德所住。于前九中除初二及五。余皆约权实事理双行。第三偈以言赞中。五十五偈分二。前三十四偈七言举德叹处。后二十一偈五言指处明德。前中二。初二总叹。一约行位。一约名德。余偈别约德行。于中四。初有七偈。约自利。行胜。二有十偈。叹利他行胜。三有八偈。叹功德胜。四有七偈。叹方便胜。后五言指处明德中。虽复语依意在叹正。于中六。初二下化。次二上观。三有五偈。明三昧自在。四有七偈。明智慧广深。五有一偈。显其平等。六有四偈。结德申敬求哀请加。第二尔时下见正报中二。一见二敬。见中二。先翘心愿睹。后乃见下正睹慈尊。言别处来者。摄化就机故。还来归本故。亦显慈氏应念而至。不着处故。第二善财见已下明设敬仪。于中五。一身心敬礼。二时弥勒下赞德记别。三尔时弥勒下重申敬仪。四时弥勒下再赞再记。五时善财下庆遇念恩。二中有二。先长行。指示者令众同睹仿而行故。后偈正赞有百一十三颂分三。初一指众总叹。末后一偈略示后友。中间诸偈别叹胜德。于中三。初二十二偈直对善财叹。于中亦三。初九赞德善来。次二明来因缘。以外由善友内具德行故。后十一偈明来所为。二汝等观下二十六偈。对众令劝赞。于中五。初四总赞。次四赞其即智之悲。次七叹即悲之智。尔焰者此云所知。入大乘论云。尔焰地者。是第十地。此约尽断十种所知障故。次六偈总叹诸德。后五偈赞妙果当成。三汝行下重对善财赞。于中分五。初二十六偈叹其当果德。初二总余皆别。二汝于下七偈双叹当现德。三诸根下八偈赞其遇友德四有五偈叹速成位行德。五有十七偈。总明诸德结叹令欣。第三重申敬仪中三。初辨敬因闻赞德故。次善财闻下身心悲敬。后以文殊下华供展诚。言文殊心念力者。表由信智故。华因德立璎珞行成。云盈手者。信智满故。散弥勒者。摄成因故。办当果故。第四再赞再记。第五庆遇念恩。文并可知(已下入第七十八经)第二尔时善财童子合掌下。咨问中二。先自陈发心。后而我未知下正问法要。于中三。初标所问次大圣一切如来下。叹慈氏有能答之德。即以此德亦为问端。初总后别。别有五十句。皆因圆果满德。三大圣菩萨下结问请说。兼显问意。第三尔时弥勒菩萨下。称叹授法。于中二。先称叹。后授法前中二。先为大众赞叹善财。即是叹人。后为善财赞菩提心。即是赞法。前中亦二。先指人示众。后诸仁者此长者子下正赞其德。于中四。一明求友精勤。二明所乘广大。三明具德无缺。四明速证超权。初中二。先总显精勤。后诸仁者下别示精勤之相。谓一时之勤犹未可叹。自始暨末一念无懈。故为可称。言一百一十善知识者。古有多释。一云理应具有。但文脱漏贤首云。前后诸友总五十四位。分出德生有德为二。则五十五人。各有自分胜进故有一百一十。若依此解则违此已言。既云经百一十已方至弥勒。弥勒等三。非百一十之数明矣。有云。减数十耳。实唯一百八人。谓此前除遍友。但五十一人。各具主伴成百二人遍友指示众艺。虽非主友而是伴友。为一百三。更加无厌足王处。空天瞿波处。无忧德神摩耶处。莲华法德身众神。及妙华光明神。守护法堂善眼罗刹。合前总有百八。以空天等相问答故。得在友数。非前主友称名指示故。非主友但名伴友。若尔则违下余城之言下自释云。前至童子童女。已经一百一十。今更后文殊所故云余也。谓若此为百八。加于慈氏尚始百九。并后文殊方正一十。何有余耶。若会通者三释皆得一种。取前更加不动处觉悟菩萨如来使天。足成一百一十。则余义亦成。以彼二圣亦教善财。故得为伴友其余己之言。但是译者之意故。晋经无有已字则通取前后。于义无妨然下复云百一十城。又云过百一十由旬。皆言百一十者。有所表故。谓除佛位取其证入十地等觉为百一十。一中具十故。亦显位位十十相融。设有三贤亦唯具十。若合等觉属十地胜进。则开十信为一故。进退行布及与圆融。皆顺百一十言。何必克定前后。第二诸仁者此长者子甚为难有下。明所乘广大。于中三。初总叹希奇。二如是之人下别明难遇。于中二。先标举。后何以下征释。释意云。悲济深广故。即开前总中救护众生。于中二。先明总护一切。后为被四流下约类别明。汨者流急之貌。言界城者。即十八界。一一根境识中别别解脱故。言界地者。即地等四界六处空聚痴闇无人。不以智光引之。必为尘贼所劫。三诸仁者此长者子恒以下。总结所作。第三诸仁者若有众生下。明具德无缺。有十三句。有一在已已为希有。况有二三乃至全具。故云展转难有。又复后后难于前前。故云展转。第四诸仁者余诸下。明速证超权。以依实教修行故。谓即凡身一生亦解行生故。千年之鸟不及朝生之凤。普贤生位互融摄故。依实修者。悉皆能尔。胡不勉旃。文有十句。初二总明具诸位行。三入十住。四五入十行。六入回向。又上四句亦皆十地行。又上四义义含通别。下四句通诸地位。第二尔时弥勒下为善财叹菩提心。文分二别。初结前生后。后告善财下正叹。于中四。初标叹发心。二汝获善利下叹其发心之器成益。三何以下广举菩提心德释成四善男子菩提心者成就如是下。结释所属前二可知。三中先征意云。所以叹善哉获善利者何耶。释意云。菩提心具德故。文有二百二十一句皆通三种发心。顿具诸位功德。且分为二。初一百一十八句明菩提心。遍该诸地。后得无畏药下一百三句。明菩提心顿具诸位功德。又前多明信成就。及解行发心。后段多明证位发心。故文多云得。又前段明菩提心殊胜功德。高齐佛果。后段喻菩提心自在功德。广多无量今初段中分二。先别明。后总结前中文通横竖。横则一一发心。皆具诸句之德。竖则别配诸位发心。以从菩萨种性至于究竟。不出三种发心故。光统配十二住。初三句即种性住。故云如种如田地。皆是种生之义。二如净水下六句。明胜解行住中之益。三净目下十六句。极喜增上住。皆初地中义故。四如大海下七句戒增上住。五调慧象下十句。增上心住。六善见药下十句。觉分相应增上慧住。中云毗笈摩者。此云普去。七如意珠下十句。诸谛相应增上住。八利刀下十句。明缘起流转止息相应增上住。九卧具下十句。明无相有功用住。十命根下十句。明无相无功用住。十一好种性下十句。明无碍解住。言寿行者。梵本云则为磁石。不吸声闻解脱果故。十二净琉璃下十六句。明最上菩萨住。梵本云因陀罗网。网取烦恼阿修罗故婆楼那风此云迅猛风也。其中文义皆与彼位相应。恐繁不属故。始于种子终于惑习。明竖义彰矣。然断习等推功归本。由初发心。则横具诸德于理明矣。二善男子下总结。即功成由于始篑故。初心具于诸德。况复初后圆融。第二善男子譬如下。一百三句明菩提心自在功德。文中各有喻合。说听之人所见深远故。所引喻多非凡境。亦显不共菩提心故。虽通横竖且竖分五段。初有七句摄十住德。觉心自性离恶觉等故。二无生根下十喻摄十行德三。帝释着摩尼下九句。摄十回向德。四有宝名净光明下。六十喻摄十地德。即分为十。初四摄初地德。二如自在王下三喻摄二地德。持戒头陀等净功德故。三善调龙法下四喻摄三地德。入诸禅定离惑热等故。四须弥山下四喻摄四地德。同一切智焰得无漏故。五椰子树下四喻摄五地德。利人不染俗故。六一灯下六喻摄六地德。般若现前顿破闇故。七迦陵频伽下五句摄七地德善入方便得自在故。八如人学射下十四喻摄八地德。无功发心能灭相惑等故。九服延龄药下十喻摄九地德。延寿益生等故。十譬如有药为咒所持下六喻摄十地德。深除惑习成一切佛法故。五金刚非劣恶器下十七喻摄等觉位功德。以金刚智终成菩提故。其间梵语具如音义。第四善男子菩提心者下。结释所属谓上来多德。释获善利之言故。第二善男子如汝所问下正授法界。于中四。一授法体。二显法名。三穷严因之本源。四核正报之性相故。初中四。一摄入方便。二加令证入。三见所证境。四事讫起定。初中先牒问劝证(已下入第七十九经)后尔时善财下求证方便。第二尔时弥勒下加令证入先约缘加。令其就法亡言会旨。则佛法门开故云前诣等。即开理智门。示令其悟入也。后善财心喜下。约因自证悟佛知见。则入法界。从迷之悟加行趣入。有门理之殊。证已契合能所两亡。即妄而真更无入处。故云还闭。第三见其楼阁下明见所证境。于中二。先别明所见。后总显见相。前中六一见依报。二见正报。三见伴菩萨。四见诸佛。五见阁中主阁。六总见严具作用。然此六皆是悲智之中所有。今初先见。后益前中三。一直见一重庄严。有标列结。同虚空者称法性故。次又见其中下依中有依。一中见多即微细门。亦主伴门。后善财童子下一处见多即相在门。二尔时下明得益。第二才始稽首下。见正报中二。先总标。所谓下别显。于中五。一见初发心时。二或见初得慈心下。见其修行得法时。三或见弥勒为转轮下。随类摄生时。四或复见为护世下。见处会说法。于中先明所处会殊。后或见赞说初地下。显所说之法。五或见弥勒于百千下。总见行用。第三或见诸菩萨下。明见伴菩萨身云演法。即前与无量眷属。第四或复于中见诸如来下。明见诸佛摄化之德。第五又复于彼下。见阁中主阁。别明慈氏一生当作。于中先见。后尔时下得益可知。第六复闻一切下见闻严具作用。于中十段。一闻网等演法。于中三。一近闻。次又闻某处下远闻。后善财下得益。二见宝镜作用。三见宝柱放光。四见宝像威仪。五见璎珞等出生。六莲华重现。七宝地现像。八树现半身。兜沙罗者。此云霜冰。九半月现光。十壁现本事。于中初见慈氏修行随类摄生。后又见下睹所事友劝喻善财。二尔时善财下。总显见相。先法后喻。今初。谓何力能见。以何眼见将何智见。依何位见。于何处见。如经属之。及结前来所不说境。后譬如下喻显见相。所以有十喻者所喻别故。然有二意。一喻能见因缘不同故。二喻所见境相别故。具初意者。十中初一总喻能见所见皆如梦事。大小无碍等。如喻合文寻之。余九皆别。二喻自因力随自业故。凡命将终故。三四并喻缘力龙鬼所持故。然鬼持自他不同。龙持自他同体。五喻友依报力。六是定力。七喻性空力。八喻法界自在力。九喻智定无二力。大智海印之三昧故。十幻智自在力。二约所喻境相别者。亦初总余别。别中一临终现业喻。喻所见冥应。二非人所持喻。喻所见能说。三龙宫淹久喻。喻念劫圆融。四梵宫广现喻。喻一多无碍。五遍处定境喻。喻所见明了。六干城依空喻。喻事理无碍。七同处异见喻。喻隐显自在。八海现三千喻。喻顿现远近。九幻现众多喻。喻所见纯杂无碍。第四尔时弥勒下事讫起定。于中四。一警觉令起。亦弹指者前来得旨。所谓忘言。此中得旨令不滞寂。二法性下略示体相。初句标。此是下释所见之相。从法智缘生。缘生故无自性。故云如是自性如幻梦等。悉不成就者。结成上义。从缘无性故事不成就。无性从缘故。理不成就。由不守自性故能从缘。成上之法。虽成不离法性故。即事得云法性如是。亦是性自具故。三尔时下得旨而起。四弥勒告下问答所见。约问亲证推之在因。云住不思议。答中谦敬推之在缘。云善反力。师资互推反常情也。第二圣者下显法名。先问后答。答中先明主门。后善男子下眷属。前中三世一切境界者。即此所入所见之境。不忘念智者。即能入能现之智。良以三世。一如故念劫圆融。随一世中现三际之境。智入三世了法空寂与如冥契故。一念之中无所不见。庄严藏者有二义。一以法性严故。一庄严中包含出生无尽严具。如一阁中见多阁等。二以无碍智契圆融境。严如来藏则本具诸法故。上云法性如是。非是新成故。此门中具不可说解脱。第三善财问言下穷严因之本源。于中有二问答。初番穷其所归由上睹希奇摄力之后。忽然而失。故问其去处。答中以从本流末故来。摄末归本故。去去不异来故引之于来。一时并答。后番彰其本起。于中先问。虽蒙引归来处既不究。终归宁知本起。故复寻之。答中先法后喻。法中先相后性。谓智力缘作故来。智力缘加故住。既从缘来则无来去。故此严事非在阁中而住。亦非别处持来。从缘而来故非集。缘谢则灭故非常。若先定有来处则堕常过。先有今无则为断灭。既离断常何有生灭一异等相。故云远离一切。后喻有二。先龙王降雨喻。偏喻无来之来。合中不住内者。菩萨力故不住外者自善力故。以内外因缘互夺。则内外两亡。后幻师现幻喻。双喻来去则无来去。第四善财童子言大圣下。核正报之性相。于中二。先问从来。后问生处。前中先问。后答问中。上见慈氏从余处来。遽即设敬问法。未遑咨问所从。故此因前严事之来。便问来处。答中有三来处。一约体实法身。即无来之来来即无来文有十对思之。二善男子菩萨从大悲下。约相实报从万行中来。亦犹净名从万行道场来矣。三汝问我下。约用化现。随机熟处而来。此三即法报化身。亦体相用。亦理行事。又初唯理。后唯事中一具理事。摩罗提者。具云摩罗耶提数。摩罗耶者。此云鬘施。即山名也。提数云中。谓其山在此国中故。或国中近此山故。瞿者地也波罗云守护。即守护土地及心地故。第二善财下问答生处。问中由前云从生处来故。今穷之。答中二。先通明诸菩萨生处。后别显慈氏生处。前中三。初正答生处。次明生缘眷属。后校量显胜。今初有十。皆上句为能生之行。下句为所生之家。谓若发菩提心。则是菩萨名为生家。若有深心则见善友。若得诸地则满诸度。教化众生即是觉他有智慧故了法无生。有方便故不取无生之相。不滞二乘之寂。故生无生忍家。余可思准。又上句亦通所生思之。二善男子下明生缘眷属有二十句。般若为母方便为父者。略有三义。一实知虚凝与阴俱静。权智流动与阳齐波故。二亲生法身。实由般若。若无方便多共二乘。成菩萨种乃由方便故。三者内解外济如父母故。次檀以福资尸以防护。余可思耳。三善男子菩萨如是下。校量显胜于中二。先总辨生家胜。后生于如是尊胜家下。别彰智胜。第二善男子我身下。别显慈氏生处。于中二。先彰实报等周法界。文有十句。初句总次八别。后一结。二我为化下显为顺机当现生殊。于中先明现生。拘吒者此云楼阁。此聚落中多楼阁故或慈氏阁在此中故。后我为随顺下明当生。于中先正显当生所为。如莲华者有三义。一释迦下种彼华开故。二昔因含果如华未开。因亡果现故如莲华开。三闻熏含实如莲未开。见实亡言故云开悟。智论云。菩萨善根不遇如来智慧日光。翳死无疑通证前义。后我愿满下结会三圣。言俱见我者亦有三意。一俱助化故。二善财表行。文殊信智。成正觉时俱证此故。三者文殊古佛善财当佛。慈氏现佛。三世圆融浩然大均。故云俱见。第四善男子汝当下。指示后友中三。初劝往教问。次何以下释劝所由。三是故善男子下结劝重释。初中令往文殊者。因位将极令反照心源故。二中先征意云。文殊已见何为劝往释意云。彼德深广宿缘重故。于中二。先明行广。后显缘深。今初。出生菩萨功德者。主信法门长养一切善。故为佛母者。主般若门住甚深智见法实故。为菩萨师者。具善巧智通达解脱究竟普贤行故。后是汝善知识下。显其缘深已多成益。三结劝重释中三。初结劝具上二义应往勿疲。次征释。先征意云。何以的知具前二义。后释意。云已所成益皆是彼力。故知德深缘重。若当见者获益尤增。后文殊下结德究竟。前见为信之首。后见为智之终。故云一切究竟。第五尔时善财下恋德礼辞(已下第八十经)。自下大文第四明智照无二相。显前因法生果体无分别。绝境智等诸二相故。又善财障尽惑除未始动念。是故反照唯是初心。更无异也。即信智无二文但有三。第一依教趣求。第二见闻证入。第三转遇胜缘。今初言经游百一十余城已者。百一十义已见上文。然此游城复有二义。一但从弥勒至于文殊。自经百一十城。非连取前。二者加前百一十友。故云余城。即通取前友。普收诸法归一照故。若尔前友此城岂得同耶。亦有二义。一者友必依城。则一城一友。二者或于一城值于多友或求一友历于多城而。要具一百一十以。顺表法故到。苏摩那者此云悦意。即华名也。谓智照一性悦本心故。即德生城。有本云至普门国。显摄诸差别归无二相。即普门故。言住其门所者。显解心已极将入般若无二之门故。第二是时文殊下见闻证入此。下即是所漏脱文义。如前说然。以极照无二心境两亡故。略无敬问。信解双绝故。不见现身而反照。未移信心故申右手。又不见乃为真见。但了自心空般若故。文中三。一摩顶摄受。过百一十由旬者。彻过前位故。始信该于极果。故曰遥申。随顺行成故曰右手。然过城约超封域。由旬明超数量。又前越诸位断德。后越诸位智地。按顶表于摄受。亦以普法置心顶故。信至极故。二作如是言下诲示法门。即举失显得。谓若离信根等不了法性等。反显善财有信根等。能了法性等。于中先列所阙行法。文有九句前七阙因。一阙行本故。二求小故。心劣处生死而忧悔。三横不具。四竖不进。五滞一善。六不广求。七不起无住行愿。后二阙缘后不能了下。不能成益中有十五句。前六约所知理事。后九约能知分齐。例前诸文思之。又前九中。初一信根是所阙因。余皆不能成益。约法功归于信。约人前友之法皆由文殊。三是时文殊下结益归本。于中十句。前九结益甚深。初一总余八别。前智光明即般若方便。后无边智即智波罗蜜。普贤行道场者。举足下足皆与普贤行相应故。自所住处者。即是法界。是文殊大智无住住故。又普贤道场即法界理。自所住处即文殊智。此亦义同。示于后友普贤之境。后一句摄用归本。所作竟故信穷智境。信相便亡故云不现。第三于是善财下。转遇胜缘修行敬事。然此诸友及后普贤皆无指授者。表证法界离此彼相故。此三千友乃有多义。一者成前尚是文殊之益。二者顺后为入理方便。又通论诸友更分三分。初文殊一人为信心之始。次至后文殊为智满之终。故此总见三千等友。后之普贤理智无二。又前诸友一一各逢即是纯门。此中诸友一时顿见。即显杂门。后普贤一人具前诸友。即纯杂无碍。又此诸友所得法门受行各别。文所不具结广从略。故总云三千耳。大文第五增长趣求下。显因广大相。以前照理无二显其甚深。方堪成佛广大之因。以随一一因皆称法性故。文殊般若即摄相归体。普贤法界即秘密重重。若以二圣相对。则文殊为能证。若以二圣对善财。则文殊亦为所证。未得般若今证得故。文中分三。初依教趣求。二闻睹前相。三见闻证入。今初有二十六句。初一标求佛果。后一总观圆因中间诸句义通前后。皆是趣佛之因。并是普贤解脱境故。就中间摄为十对。初四四等普周寂静即舍故。次二福智无外缘境是智故。次二入正增助次二修因知果。次三入法现生。次二证愿修行。次二照上增下。次二得实照权。次二智周身遍。后三摧障入理。其入无碍法向上成无二碍。向下即成无碍法界。其住平等地即前文殊自所住处。后总句观普贤境。即前普贤行道场。以是显因广大相故。文殊通指善财普观。不同前文一友指于一友。良以普观方见普贤故。第二即闻普贤下闻睹前相。于中先闻后睹。今初有十三句。初一闻人名。后十二闻行位。即闻二字贯下诸句。此中闻者。非从一人多人闻之。即称法界而闻耳。诸地者。普贤位中自行依地。及圆融所摄地也。此句总下八别。一地方便者即加行也。二即入心。三出心四住心。五即修施戒等。六即遍行真如等为所证境。亦是所得分齐之境。七即神通作用。摧邪摄生等。八即同依佛智而住。二渴仰欲见下明睹。于中二。先仰德修观。后睹见希奇。今初。初闻前人法故生渴仰次。即于下修观。菩提场者是所观处。金刚藏者约表。即于本所信自心佛果菩提体中金刚智内。起一切因陀罗网普贤心观。约事即前其地金刚。而蕴德具严故名为藏。然此经体势应具十会。以顺无尽。又始起觉场义应归本故。今且依文。对前本末二会。即是摄末归本之义。是以善财不假别指。便于初会始成之处如来座前。而起观求。后起等下正显观心。有十一句皆称普贤境。而起于心故后得见。二善财下睹见希奇。于中二。先结前生后。兼显见因。后见十种下正睹希奇。于中二。一见瑞相十句五对。各先所依净土。后住处众生。二睹光明前瑞。则直见一重净刹。此明重见。又前粗此细。前体相此业用。然皆是普贤依报之刹。第三时善财下见闻证入。于中三。初结前生后。由睹前相生必见心。二于时善财普摄下起观增修。初摄散住定。次策勤无退。次观其体遍以法界为身故。次悲智横广。次愿行竖穷。后得果圆因。此乃总摄诸观。行人欲见当仿此修。离此观心见亦非胜。三时善财下正明见闻证入。于中二。先正见闻证入。后闻佛德难思。前中亦二。先显得益圆因。后位满齐佛。前中分四。一见身得益。二摩顶得益。三显因深广。四观用无涯。初中二。先见胜身。后得深益。前中四。一总见胜德身相。二别见毛孔出生。三重观体内包含。四结通周遍。今初由前于菩提场师子座前起胜想故。二见普贤身下。别见毛孔出生广遍法界。实则重重无尽。略显二十重。亦对前善财渴仰所起十一心故。其初等虚空广大等五心。遍此诸句。余之六心别生诸句。且除初一句。次之五句。由前观道场明了心故。出云等皆严道场。次叹菩提心下三句。由前入佛法海心。次一句及最初一句。由化众生界心。次四由前净一切国土心。亦兼化众生心。后六句由前住一切劫。及趣如来十力究竟心。并如文思之。是知各由自心所见分齐。三尔时善财下。重观体内包含。于中二。初结前生后。后重观下正显。于中亦二。先见三千。后如见此下类通十方三际。四如于此毗卢下结通周遍。文有四重。举类未结。尘中普贤。是知前则身中包含法界广无边故。显其普义。今则全此含法界身。潜入尘中调柔无碍。明其贤义内外周遍。限量斯尽故名普贤。二善财童子见下明得深益。既得智度已彰地满。况十表无尽耶。第二善财童子既得下。明摩顶得益。于中三。初摩顶。次既摩下得益。前向外观故得智度。此摩顶亲证故得三昧。后如此娑婆下结通。良以善财等普贤故。第三尔时普贤下明因深广。因深则果厚故。文分为三。初问答审见。二显因深远。三结因成果。二中三。一别明求菩提行。于中二。先顺显所行。后善男子我于下结离过成德。二我庄严下通明悲智行。三我法海中下。别明求法行。于中先反显无不能舍。一文尚无所不舍。况全部耶。以一文即。一切之一。如海一滴故。后我所求法下。显求所为结说无尽。第三是故善男子。我以如是下。结因成果。于中先结因。以有成果之功故云力也。文有十句。初四缘因。次二了因。后四通于缘了。后得此下成果。谓由了因故得法身果。由缘因故得色身果。第四善男子汝且观下观用无涯。于中三。初举益劝观。次观见奇特。后校量显胜。今初有标释结。初标可知。二我此下释中二。一明难见闻。二若有众生下明见闻皆益。于中三。初明不退菩提益。次或有众生下善根成熟益。后我以如是下总结多门。皆不退成熟。于中先多门皆不退。后若有众生见闻下。种种皆成熟。净刹可生身云何生。此有二义。一约法性身刹。则与刹为体名清净刹。与身为体名清净身。从能依有殊。欲显所依体一。故言生身。二约相用净刹是所依之刹。净身则身内之刹。欲显身土互融故言生净身耳。后汝应观下总结。第二尔时善财下观见奇特。于中三。初见毛内含三世间。次又见普贤下。见普贤身遍诸刹中出生大用。后时善财童子下。自见己身等普贤化。第三又善财下校量显胜。于中三。初校量善根。二从初发心下。校量所入刹海。三善财童子于普贤下。双显上二超胜之相。于中二。先别明横竖深广。于中有三世间。一器世间。一步超过显横广。尽未来劫明竖穷。犹不能知显深远。藏约包含。普入约广遍。余可知。后善财童子于下。总结平等周遍。不于此没彼现者。以没现相如法性故。以此彼相相即故也。第二当是之时下明位满齐佛。于中初句明自得。余皆等上。初一等因圆。次一等果满。一身下别显等相。此即义当等觉。因位既满更无所修。故但说等不辨更求。此则一生顿成。行布亦足。非唯但约理观初后圆融。上明见闻证入竟。第二从尔时下明闻佛胜德难思。前长行但显因圆。此偈方陈果用。非颂前文。然有二意。一对普贤。普贤意云。上见我难思。尚是因位。今示汝果尤更甚深。二对善财。善财等佛但是因圆。以果海离言故不说成佛。今寄现佛之德。以显善财果相故。长行偈文因果绮互。文中三。初偈颂标德。诫听许说。二尔时下长行举众渴仰欲闻。三尔时普贤下。广陈德相令众求满。于中二。先长行重诫许说分齐。后偈颂广显佛德难思。九十五偈分二。先九十三偈别叹佛德。后二偈结德无尽。劝信勿疑。前中前八十偈法说。后十三偈喻明。然通赞毗卢遮那十身圆满二十一种殊胜功德。即分二十一段。初有二偈。即于所知一向无障转功德。谓佛无障碍智。于一切事品类差别。无著无碍故。二有一偈。明于有无无二相真如最清净能入功德。谓了真如无二故无动念。三有三偈。即无功用佛事不休息功德。谓住佛无住处作佛事不休息。故云或见等。四有十五偈。即于法身中。所依意乐作事无差别功德。谓由诸佛所依智同。益生意乐同。报化作用同故。前经云得佛平等。亦同摄论四种意趣中平等意趣故。此广列诸佛皆互相遍。此释已妙。今更以文理证。此诸佛皆遮那之身谓此文言。此三十界阿閦在中。阿閦本在东方。今云在此明不异此。又无量寿佛月觉如来。皆遍十方岂容隔此。又皆言或见。则知一佛随见不同。若言别赞余佛。直言阿閦在此。何成赞德。况华藏刹海皆遮那化境。无量寿等未出刹种之中。岂非是此佛耶。法华央掘并说十方分身。故知法藏别缘十六王子皆方便说。以理推之。皆是如来海印所现。何缘不说自所现佛而说他耶。故知贤首佛等。皆本师矣。然此段文。亦兼显第十七随其胜解。示现差别佛土功德。文中三。初八主伴严土摄生同。次四微细含容转法同。后三总摄多门结前生后。五或见释迦下三偈。即修一切障对治功德。谓一切时常修觉慧。治六蔽等故。既云已经多劫。则不定始成。六有三偈即降伏一切外道功德。于中初二即教证二道。后一现所摧同类之身。七或现兜率下十六偈。即生在世间。不为世法所碍功德。于中初五八相现世无碍。次三处天宫殿无碍。次六随世巧化无碍。后二结无碍智之能遍随机。八如来住下有十八偈。明安立正法功德。于中初四偈。立三乘法轮兼显业用。次三明立六度道品对治法。次七明一音随类闻法不同。乃至无量。后四明平等语业而应一切。九具足下三偈明授记功德。谓记别过未如现在。故云悉明见。十有四偈。明示现受用变化身功德。十一或持下二偈。明断一切疑功德。谓于一切境善决定故。能断他疑。十二有九偈。令入种种行功德。谓遍了一切有情性行。随根令入故。十三如来无碍智。一偈即当来生妙智功德。谓佛知久远故。十四有五偈。随其胜解示现功德。谓随解现身故。十五有三偈。即无量所依调伏有情加行功德。意云。佛智为无量菩萨调伏众生加行之所依故。十六如来清净下二偈。明平等法身波罗蜜多成满功德。然同摄论法身具五种相。初句白法为相。以是极果圆满自在故。次二句不思议相。次一是无二相。次一无依相。次句常住相。次句二喻者空画喻无依。梦喻非有无二相。余不可喻。或略不喻。十七有一偈。明随胜解示现差别佛土功德。既随解而现故不可喻。此偈亦总拂前喻。如山等必不依空。有等必不能喻佛。十八一偈。明三种佛身方处无分限功德。十九一偈。摄三种功德。同法性等。即穷生死际常现利乐一切有情功德等。虚空即无尽功德等。实际等即究竟功德。以如实际之际穷未来际故。后二偈结德无尽。亦是别显无尽功德。虽是总结即当别文。于中前偈结德后偈劝信。古德亦有将此二偈为一部流通。已如前说

  法性深广难思议　　我已随分略开解
  愿斯功德同实际　　普令含识证菩提

大方广佛华严经疏卷第六十


大方广佛华严经搜玄分齐通智方轨

    No. 1732 [cf. No. 278]

大方广佛华严经搜玄分齐通智方轨卷第一(之上)

        终南山至相寺沙门智俨述

此经本外国凡有十万偈。昔晋道人支法领。从于阗国得此三万六千偈。以晋义熙十四年岁次鹑火三月十日。于杨州谢司空寺。天竺禅师佛度跋陀罗手执梵文。译胡音为晋。沙门释法业亲从笔授。时吴郡内史孟顗。右卫将军褚叔度为檀越。至元熙二年六月十日出讫胡本。至太宋永初二年辛酉之岁十二月二十八日校毕

今分判文义以五门分别。一叹圣临机德量由致。二明藏摄分齐。三辨教下所诠宗趣及能诠教体。四释经题目。五分文解释

初叹圣临机德量由致者。夫如来大圣。自创悟玄踪发轸于无住。融神妙寂志崇于菩提。故能殖道种于先际。积善业于无我。晕正智于金刚。朗如如于尔焰是以妄想弗剪而霄翔累表。灵鉴弗莹而圆明等觉。澄深我净至寂所不隐。凝迹常乐无所而不施。生死涅槃夷齐同观。德备圆通大智无障碍。解脱方便妙极然矣

第二明藏摄分齐者。斯之玄寂岂容言哉。但以大悲垂训道无私隐故。致随缘之说法门非一。教别尘沙。宁容限目。如约以辨。一化始终教门有三。一曰渐教。二曰顿教。三曰圆教。初门渐内所诠三故。教则为三。约所为二故。教则为二。言其三者。一曰修多罗。此云线亦名经。以线能贯华经能持纬义用相似。但以此方重于经名不贵线称。是以翻译逐其所重。故废线名存于经目。譬圣言教能贯穿法相使不差失令法久住。经与线相似。此从譬立名。即诠定教也。二毗那耶此云灭。以身口意恶焚烧行者义同火然戒能灭之故称灭。此从功能彰目。教从所诠亦名为灭。即诠戒教也。三者阿毗达摩。此云无比法。亦名对法。能破烦恼及分别法相。无分别慧最为殊胜。更无有法能比此者。故曰无比法。此从无他得名。教从所诠亦名无比法。此即诠慧教也。名对法者。即阿毗是能对智。达摩是所对境法。即境用立名。此后二藏并从所诠得名也。问若然者。何故摄论云。为说三种修学别立修多罗。为成依戒依心学故立毗那耶。以此文验。即经诠三行。戒诠二行。慧诠一行。答有二义。一克性门。二兼正门。克性如前说。兼正门有二义。一本末义经为本教。余二次第末也。二者兼正门。经中定为正。戒慧兼也。律论亦尔。准可知耳。此经即修多罗藏摄也。所为二故。教即为二者。根有利钝。法有浅深。故约声闻钝根就分别性立于三藏。成声闻行法故也。为菩萨利根。约无分别等三无性。义立三藏。为成菩萨行法故也。问经云为诸缘觉说因缘观法。即缘觉亦有教。何故不立藏。答依普曜经。三乘教即立三藏。今依摄论及地持等。但假教即入声闻藏。故不立也。此以二义明之。一声闻声闻。是人本来求声闻道乐观四谛。今遇佛说四谛法得道。先有种性。今复闻声故曰声闻声闻。如经中说。求声闻者如来为说四真谛法。据此为言。二缘觉声闻者。先求缘觉道。今遇佛说因缘教法。如经中说。求缘觉者如来为说十二缘法。就此为论。初义总相知法。后义别相知法。利钝虽殊。同期小果。总为一藏也。若上利根出无佛世。自悟因缘。而得道果。有行无教。据斯废也。依普曜经。望理教别也。就声闻中有其二种。谓初执性教及顺破性等诸部执教。破性教者。分知法空。同依四谛趣于小果故同入声闻藏也。二菩萨藏内有二。一者先习大法。后退入小。今还进大故。经说言。除先修习学小乘者。我今亦令入是法中名渐入也。二者久习大乘今始见佛。则能入顿。故经说言。或有众生世世已来常受我化。始见我身闻我所说。即皆信受入如来慧也。此经即入大乘教摄也。第二顿教摄者。故下经云。若众生下劣其心厌没者。示以声闻道令出于众苦。复有众生。诸根少明利。乐于因缘法为说辟支佛。若人根明利。饶益于众生有大慈悲心。为说菩萨道。若有无上心决定乐大事。为示于佛身说无量佛法。以此文证知有一乘及顿教三乘差别。又依真谛摄论。一者一乘。二者三乘。三者小乘也。问顿悟与一乘何别。答此亦不定。或不别。或约智与教别。又一浅一深也。一乘藏即下十藏也。相摄准之。第三言圆教者。为于上达分阶佛境者。说于解脱究竟法门。满足佛事故名圆也。此经即顿及圆二教摄。所以知有圆教者如下文云。如因大海有十宝山等准之。问此经何故上来通三乘分别及摄者。答为此经宗通有同别二教三乘境见闻及修等故也。如法华经三界之中三车引诸子出宅。露地别授大牛之车。仍此二教同在三界为见闻境。又声闻等为穷子。是其所引。故知小乘之外别有三乘。互得相引主伴成宗也。藏摄分齐讫

三释教下所诠宗趣者有其二种。一总。二别。总谓因果缘起理实为宗趣。别有四门。一教义相对以辨宗趣。二境行。三理事。四因果。教为宗义为趣。境为宗行为趣。事为宗理为趣。因为宗果为趣。次能诠教体者有其五种。第一义者实音声名味句。第二义者可似音声名味句。第三义者不可似音声名味句。第四义者唯识音声名味句。第五义者真如音声名味句。故经云一切法皆如也

四释经题目者。大方广佛华严经世间净眼品者。大谓体相用莫过故也。谓平等不增减体。具足性功德相。生世出世善因果用故。方者理正非耶。广者法门理数具德尽其边也。佛者觉也。此通十佛及三身佛。华有二种。一集果华不与果俱。如生死为道具等乃至因位善根等也。二庄果华与果同时。如七净华等及满果位诸德。修生本有互严可知。严者庄饰也。又言大者标以胜极之都目。故论云。大胜高广一体。而异名乘旨道富。参罗无外。谓之大本。非局然矣。言方者圆通之致。处无不善。触缘斯顺。不择物而施。故曰方。言广者。冲而幽微而远渊而且博。谓之广也。言佛者中国正音云佛陀。此方称觉者。以其朗达穷源。尘习永亡。怀明独曜。晖光大夜。启导群惑。自觉觉人故曰佛陀。言华严者。此况法身行德之美故。体非真无以彰其妙。功非极无以显其胜。互相莹发义并超殊。可谓自体圆通胜妙之极然矣。其犹众彩奇珍纤饰金颜。特甚瑰丽世之无比。故就斯喻标名。故曰华严。经者真净之教。训议常则。文诠理纬。显用行心。故曰经也。世间净眼者。谓时中器等三世间也。及能况之相。又体用差别。故现世。无碍无染况净眼。亦可如来未出世。无善导故如盲。佛今出世。现自他净喻明眼耳。言世间净眼者。此应名序。但今之时会并是胜流入佛众海数。德居净域尘所不染。出自天真。信非有为。故托以显至极圆道缘起之妙。不舍生死而无沾污。是以就事为目故曰世间净眼。难测。非喻莫晓。故设以拟状。若于眼内外俱净中表清彻。色像参罗并属于一运。无小无大无远无近不相妨碍。故可准况标之如眼。故下偈叹。世间清净犹如眼。义显圣说然矣。品者语言理均。挌类相从。称之为品。此经有三十四品。此品贯之在首。故称第一。经之都目宗要之况旨明于此。故言道大方广佛华严经

第五随文解释者。初总料简教之分齐。次别释文分齐。有二。一对耶显正明其分齐。二约所诠义明其分齐。初对耶者有其四门。一约缘辨耶。如八时不应语等。二约业辨耶。如求其名利。自是非他。乐世有等。三约惑明耶。闻作闻解不得不闻。乃至依法不依人等。四约始终辨耶。如经云八大善人等当成不善故。二约就所诠明分齐者略有十门。一同时具足相应门。于中有十。一教义具足。二理事具足。三解行具足。四因果具足。五人法具足。六分齐境位具足。七师弟法智具足。八主伴依正具足。九逆顺体用自在具足。十随生根欲示现具足。此等十门相应无有前后也。二因陀罗网境界门。此中具前十门。但义从喻异耳。余可准上。三秘密隐显俱成门。此亦具前十门。但义从缘异耳。余可准上。四微细相容安立门。此亦具前十门。但义从相异耳。余可准之。五十世隔法异成门。此亦具前十门。但义从世异耳。余可准之。六诸藏纯杂具德门。此亦具前十门。但义从世异耳。余可准之。七一多相容不同门。此亦具前十门。但义从理异耳。余可准之。八诸法相即自在门。此亦具前十门。但义从用异耳。余可准之。亦可依性。九唯心回转善成门。此亦具前十门。但义从心异耳。余可准之。十托事显法生解门。此亦具前十门。但义从智异耳。余可准之。上之十门玄并皆别异。若教义分齐与此相应者。即是一乘圆教及顿教法门。若诸教义分与此相应而不具足者。即是三乘渐教所摄。余义依下天王等法门。准之可解也。随文解释者。初略举八种教明互相成。及约三教相明其次第。次随文释。其八教者。一一乘三乘分齐。二真应。三回三入一。四空有。五凡圣相由。六常无常。七三乘同行。八辨法邪正。此之八义上下皆通。广说略说相从成就本末二相。宜可准思。约三教相成者。谓始于道树。为诸大行。一往直陈宗本之致。方广法轮其趣渊玄。更无由藉以之为顿。所言渐者。为于始习施设方便。开发三乘引接之化。初微后着。从浅至深。次第相乘以阶彼岸故。称为渐。所言圆教者。为于上达分阶佛境者。说于如来解脱法门。究竟穷宗至极果行。满足佛事。故曰为圆。如穷之以实。趣齐莫二。等同一味究竟无余。何殊之有。但以对治功用不等故。随根器别其浅深。言分有三。其次第者就于一乘了义实说。约对治方便行门差殊。要约有三以明次第。一者据方便修相对治缘起自类因行以明三教。渐即在初。顿中圆后。三义从渐说也。初渐以生信。次顿以成行。次圆以成体用耳。若约实际缘起自体因行以明时。顿初渐次圆后。初示顿以令修。次示渐彰为物。后示圆果德备故也。若约穷实法界不增不减无障碍缘起自体甚深秘密果道时。即初圆次顿后渐也。所以尔者。正以冲宗不遗于玄想。圆道不拣于始门。是以事虽近而至远。相虽着而至密。浅至极深方穷故。初示圆令见闻。次彰顿令随喜。后辨渐阶位。显德起信行也。此即约圆以明三耳。然教乃可尔。论其旨也。正明如来法身无上菩提至极圆道。契穷实相德盈海奥。义兴真本显明后际。语果彰之于无得。论因显之于无发。故无相之相。其趣幽微凝同太虚。旨绝名相。可谓至道无言而玄籍弥布。真容无像而妙相备严。入于佛慧具佛所行。德显殊美踰越于世。故经首贯以佛华严之称者。当以旨南之说。宗要在兹。随文释者。此一部教大分有三。谓序正流通。若竖料简。随其八会有十义别。余准可识。此经一部凡有七处八会。人中三。天上四名七处也。重会普光名八会也。此为阶法故有七八耳。此七八文相有无不同。略以十门分别。就八会内所以初明佛者。佛是化主。今摄物必以化主为先故。初明也。二大圣说法有所栖托。次辨处也。三摄化有所。次明菩萨。四器虽具足。请若不满。则不为说故。次生疑。五法润无崖。次辨集新众。六微法不审不可即说。次辨入定。七欲辨法胜故明佛加。八显法始终分齐。次明出不出异。九胜法既宣。次明法益。故辨动地雨华等也。十然功用既彰。化不偏屈。十方齐转契合不虚故。次辨结会平等显证述成。此十若离雨华等乃有十五。散华烧香放光作乐雨宝。摄五为一也。今并摄在十耳。二对会释有无者。七处佛三身中是何。此解有二。一局一通。局者八会俱非小见。故是报身。问既报非化。何以处与下同。答此为先化流于末世。故寄世处以辨也。又问若寄世者何故经云阿迦尼吒天成。答此有二义。一寄化显报。即八会是。二寄报显化。即色究竟是。为彰欲界是化故约相是化。今论教意耳。通者三身具有。一一互成。又普贤文云。在我身内无障碍。又辨华藏世界海又寄道树等。故知也。此约三乘辨。若约一乘即下十佛并皆通有也。分文三者序正流通也。序者方便相。正者说体相。流通津用相。此净眼品是序。卢舍那下辨正宗。经不来尽故无流通。所以知。大论云。不思议经有十万偈。此唯有三万六千偈。故知也。亦可有流通。众生心微尘已下文是。但为龙树菩萨会事等处十万。准省之故不足耳。若从文义以分。至文别辨耳。序文分二。初明证信。二天王设供等已下明其发起序。证信序文有二义。初二句四字局此证信。二一时下义有通。此约一义耳。又亦可二句义通一部而文局。初一时已下文通而义局也。约此义即有六句。一如是。二我闻。三一时。四佛。五住处。六同闻众。初释如是者。众圣理教文义相应故也。亦可我传文义如佛所说也。是圣教义也。又信顺辞耳。我闻可知。一时者根授相应时也。时有三义。一平等时谓无沉浮颠倒。二和合时谓令闻能闻正闻。三转法轮时谓正说正受。佛者可知。处者谓摩竭提寂灭道场。此是大圣所托。以一在释一切在。国通场局。此云无害国。寂灭表离障圆果净寂德也。始成者有二义。一得道始。初七日时。二现世始。说法第二七日时也。由令他知成道始故。此文有二。初二句总开依正立宗。二别辨。别内分二。初释依报。二如来处此下辨正报也。初即器世间也。文有三。初辨道场地二其菩提树下辨其道树。三不可思议下明师子座。此立意者。地为住行之本。树为众德建立。座为摄益之用。初场中有三子句。一辨道场体庄严具足。二佛神力下明果德资成。三无量善根下出其因行。初体文复有三。一总辨体。二众杂宝华下六句辨自利德。三雨无尽宝下二利自他德也。自利六句中。初一句微妙圆净。次一具德净。次一色相净。次一高显净。次一眷属净。次一隐映净。利他二句内。初明津用净。次一覆润净。此二句通自他。次佛神力下第二子句中有三句。初明变净土令地广博。二光明普照下德用也。三一切奇特妙宝积等者体摄众德。就道树文二子句。一有九句辨树体庄严。二佛神力下辨果德资成。初文分三。初明树体高胜能阴覆也。二清净琉璃下五句正辨庄严。三树光普照下三句明利他用。此中有三业。初意次身次口。坐文分五。初明座体出过情量。二众妙宝华下正辨庄严。三流光如云下辨利他用。亦有三业。初身次意后口。四如来光明踰等下。上果下加。有五句。一阴覆胜。二感化胜。三无碍胜。四疾遍胜。五具德胜。五无量众宝下总结成也。第二辨正报文有二。初如来处等总释。二了三世下别辨。第二别释文有三。初明法身。二其身遍坐一切道场下明报身。三悉能普现一切众会下明其化身。此约三乘判文。若依一乘此中即具十佛体德用。准以思摄。初法身文有三句。初辨身业德有二句。二妙音遍至下二句明口业德。三平等法相下三句辨意业德。二报身文分三。初身用有四句。一座分齐。二知根行。三除惑染。四生德也。二普放三世智海光明下三句辨口业。三力无畏下一句明其意业。三辨化身文。初身业有三句。二了达一切下二句意业。三一切光明下二句口业。就口业文分二。初辨放光能普现诸义。次诸佛世界下辨益分齐。第六同闻众。即众生世间文明大众圆集。此作二门辨。一明诸会有无不同。二依文释。有无分二。一大小。二杂类。大小者七会皆大。第八通小。所以者前为显顿教大乘体。第八为入法界。普摄小乘令入大。显人力故。二杂类者唯前一后一。列杂类神王名。余略不列。所以者。前为表仰修信如称法界人信解万行相。后为表称法界摄法界人修入德满相也。问若尔何故涅槃经摄众类多。此少也。答彼望熟故远说。此约始近论也。所以可知。又亦可始约初位为分齐故不通小下。余如下辨。第二释文分三。初别如来法身净土摄三十四众。二尔时于佛师子座下复以法身净土方便之力摄起一众。始末合有三十五众。初略列众名。二列名叹德。初文分二。一辨菩萨等明无为缘集众。二诸神等明有为缘集众。下列名叹德准可知。初菩萨众中分三。一举数。二列菩萨名。此有三。初辨。次结。三叹德。与俱者有二。一佛与俱与之俱说。二传法俱与之俱闻。普者德满法界曰普。至顺调柔曰贤。所以此中明菩萨名杂者有二意。一为显下粗细等杂世界故。二为此众通下八会序显多类法故也。余者可知。三叹德文有四。初总叹。二诸波罗蜜下别叹自分德。三无上智愿下别辨能入他分德。四悉得诸佛下辨普贤行愿自在摄化。总文分二。一皆是善友者显人胜。卢舍那者此云广博严净。二辨自分文有三子句。一明自利行。二辨才大海下利他行。三住于一地下明以行成位。辨所摄分齐。云住于一地普摄一切诸地等者。就行相次第终至穷实自体以论。略要有四。一者以于始故能生于后。终竟满足。故名摄也。二者虽足初始。然皆能行于诸地所行。诸法无殊。故言摄也。而所成之行但在于自分之位。上下忧劣但以明昧为异也。三者但是初始即摄一切诸地功德。故名摄也。四者非谓以初后故名摄。但是初始。即正是终故名摄也。就自利分三。谓总正助也。利他文有三。初一辨口业。次一身业。次三善知下意业。此中初知根。二知理法。三知事法。他分文有四句。一明自利五句。一得愿。二得教。三得果法。四得位德。五得定也。二于众生海下利他二句。初立次释也。三善入下二句善入法身。初立次释也。四遍游下二句为物出生净土。初世界海。次国土海也。第四普贤愿行文有四。一得诸佛三世方便。二辨供养。三得普贤愿。四摄生成智德。亦可对物摄胜。就有为缘集文有三十三众。从下向上列名所以者。为表进行增微故。问此诸众住何土中。答此众一身住土四土之中三土化土中之一分。此可思之。何故下赞佛文从上向下列者。为彰尊位次第也。初力士众分三。一举数。二列名。三叹德。叹德文有三。初总。次五句别。一具愿门。二具德门。三具定门。四具神力门。五具解脱门。即自利德也。三处一切众生下二句利他。余众列名叹德可知。迦楼罗者金翅鸟也。紧那罗此云疑神。作乐也。摩睺罗伽此云莽神也。夜摩者此云时天。亦名妙善。兜率者此云知足。大梵者此由新离欲染也。摩醯首罗此云大自在天。文有三。前二可知。就叹德文有四子段。一总叹。二于一切众生下别叹利他。三无量妙色下叹自利。第四睹佛姿颜乃至所以者何下。因事辨成二用所以。第三自利文分三。初明法身身业。次于十力中下明意业。处一切众下口业。此文有五句。展转可知。第四所以文有二初明所依。二辨所以。所以中初问次答。答文有三。初辨所依缘。二于诸如来下明依缘成行。三各随下结别所成。推功在佛。第二文中有六子句。一在信位为佛摄生善根。二为佛引入解位。三为佛摄入证位已上。四从逮得无量功德下明得八地已上无功用势力。五皆悉成就下辨十地已上普贤愿行。六菩萨所行下结别所成。第三结功在佛文中分四。一结。二正推如来智光普照。三得成因乘解脱力入佛果海。亲辨所由。四于法门得自在成述已行满。亦可四句展转辨成。次就叹佛文十八众内。此但略上隐显。故明十八。大分为二。一善海等各于一法门得自在。二第十八普贤菩萨于一切法门得自在。此中约缘起楼观显同生异生德门分齐。宜可思之。亦可前十七异生。后第十八普贤菩萨是其同生。就异生文有十七。初善海内有二。一举法门自在即意业行供养。王身现在即身业供养。二说偈下辨口业供养。偈赞文总为叹如来三业满法界用。就中初六偈总叹佛三业在世胜。二有一切世间众生下六三业在世起殊胜德用。次如来妙色身下二偈别叹身业。次如来音声无碍下二别叹口业。次一切十方无边佛下二辨佛意业。次二偈举因释成。二乐业光天偈叹佛寂用双行德。文分三。初一总叹。次十六偈别举。三无数无量劫下二举因结成。三禅有七天。净智有二十二偈。总叹如来身业功能。初六叹法身。次六叹报身。次六叹化身。次四总叹如来慈悲德。二禅十天。二十偈总叹佛大方便行及所证法。初六偈总叹佛方便行。次六叹以法门摄化。次六叹八相成道化。次二举因结成。初禅有十天。颂内十六叹佛寂用无碍自在德。初四叹佛身业。次四叹佛口业无碍。次四叹佛意业。次四总叹三业无边。他化十天诵文有二十偈。叹佛后得智用。初四法身普益生善灭恶。次四佛口业用。次二意业用。次六总叹佛能灭恶生善。次四叹佛应机自在而无高心。化乐天有二十偈。中叹佛三身德。初六叹法身德用自在。次十四叹报身。十四中有四。初二辨佛口业。次六身业。次四叹佛本因。次二叹佛摄生自在。兜率有八天。颂中十六偈总叹佛周遍法界说法自在。初六总叹佛用无碍。次六叹佛除生三障德。次二叹佛能成众生行益不空。次二叹众圆集显圣摄力耳。夜摩十天。颂十六总叹佛三业功德。初八意业。次二口业。次六身业。忉利有十天。颂有二十偈。总叹三世佛权实菩提智门。初四辨念佛者得遇圣缘。次八辨佛方便被物。次六叹佛成胜智身令修入者成胜利益。次二结劝念佛灭三障也。即惑业报耳。日天有十。颂中二十二总叹佛智日功。初十二叹佛众德庄严。次八叹佛胜智善巧。次二叹法深广。月天有十。颂中十六总叹佛于痴闇中放智教光成其观行也。初十辨佛智光益生成证心不倾动。次六明放光智转相教示成其正观。次下乾闼婆等四众即四天王是也。从所领为名故作此说。若从主名者。大论云。东方天名提头赖吒。此云治国。领二部鬼神。一名乾闼婆。二名毗舍阇。南方天名毗楼勒叉。此云增长。领二部鬼神。一名鸠槃荼。二名辟荔多。西方天名毗楼博叉。此云杂语。领二部鬼神。一诸龙。二富多那。北方天名毗沙门。此云多闻。领二部鬼神。一夜叉。二罗刹。此所领即是经中八部鬼神。此即二十八天中一天。东方天有十。谓持国等。颂中有二十。总辨慈悲方便示法事净土成利他益也。初六叹佛摄生令见法身。次有八偈叹佛在净土化生得果。次有六偈叹佛随处益物。南方天有十。颂有二十偈。叹佛慈悲法门。初六叹佛大悲忍苦调伏众生。次十四明佛悲德周遍十方用无相也。于中有二。初十二辨慈悲相。次二辨用离相。西方天有十。颂中有二十。叹佛悲益故令生得法喜。初六偈辨佛悲力救生。次四叹佛在生死者令入法海。次四令在苦者得其净土。次六偈叹佛在净土中说妙法海成法供养。如须弥藏经说。龙报有五种形。一善住龙为象形。二难陀龙为蛇形。三阿那婆达龙为马形。四婆楼那龙为鱼形。五摩那苏婆帝龙亦名摩那斯。为虾蟆形。变形如律说。各领所形龙。北方天夜叉者轻捷。颂中有十六。叹佛为拔苦故在世间。初八偈叹佛平等慈德。次六辨佛智身法身摄生趣正道。次二举因结成。上三十三众中名此为鬼王者。八部中唯紧那罗龙毗舍阇是畜生。但夜叉罗刹力大故与鬼名。此中五皆鬼也。金刚力士有十。颂中有二十。辨佛法身三业难坏。初六叹佛身业自在。次六辨佛口业。次八叹佛意业。此上诸类并像现劣而体是胜故。大集云。诸佛诸菩萨言。汝欲往释迦佛所者当现作梵王等。故知也。又此华藏界岂有此实类也。意如摄论。次解第十八菩萨众说偈叹佛。此唯列普贤不列余名者。此形居道位。德标普门。彰一即一切一切即一故也。此文有二。初列名叹德。次偈颂表三业供养可知。上下二众长行叹德。是经家列非当时文就长行有二。初总。次所谓下别总文分二。初自分德。二能入如来下入他分德。别文分二。前八法门广前自分。后二法门广前他分。又此五对十句。二二自他利颂中二十偈。义分有六。初二叹佛住处及眷属净。次二叹佛土主净。次二半叹利益圆净。次有七偈半化用圆净。次二叹佛果位胜出圆净。后四体用净。就七偈内初三半佛身业净。次二偈口业净。次一切三世下二偈辨佛意业净。后四偈文分二。初一辨法身体净。次三用净即三业用也。即为三耳。此中释普贤分齐以八门明因陀罗。可以知之。一理。二土。三身。四教。五法。六行。七时。八事。事即尘等也。凡论大意。约文有二。一但有使习烦恼染业及报并入凡境。自外入圣境圣中有二。谓理量二法。此二各有二法。因陀罗网境界即理中量也。及量中之一分耳。此可思准之。次下大段第二不动而集众。此上诸众未必有动。但欲显同体摄。故有此耳。又显果位具因法故也。就中有八子段。一明出处。谓师子坐楼观侧。二举数。三列十名。所以列杂名者。欲显说增微多类法故。四设诸供养下列供具。五皆大欢下正供佛。六随方而坐。七彼菩萨等下叹德。八说偈叹佛。前地总。此楼观别住也。供具有五。散华烧香放光作乐雨宝。就叹德有十句。一自分因行门。二胜进证时。他分无碍。三真佛境中无尽辨才。四得佛意业成不思之用。五得普门境佛身业普现。六总说悉能入三世智地。七总叹常无常二涅槃因力具足。八方便净涅槃。九自净常果因。十总结成法供养行。颂赞有十九偈分为四。叹佛三业及坐道树自在德。初三偈叹佛意业用。次十偈辨身在树王自在。次二偈口业自在。次四叹座庄严大用自在。次下第三诸王兴供养行亦可。第二发起序。就中分三。初佛神力动地等。所言动者一方动。遍动者四方同时动。等遍动者八方动。此解十八动出大论。吼觉震是声。余者色也。下文有六种动。即东涌西没等是也。诸经有异动。不出此二。准以思摄。二明兴供养。三此世界中佛坐道场下结所得业。第二文分四。一总。二别。三结。四等余方。诸王德业文有二。一正叹此王。二等余世界。就正叹文有六句。前三自利。次一利他。次二自他行成满入胜分。初一总说各随乐所入法及能入方便法门。二依证出观心生欢喜法门。三别说方便对治法。四通达诸方勇猛利他法门。五如来位境胜分已入。六诸佛所证无量法海皆已得度。结文二意可知。释净眼品已。总有四种生解法。以起下文。除立破四答善巧翻依等。一次第门。相形取解故。二总别门。如六相等。从相入实故。三摄取门。如依言摄义故也。四例声门。七种例声例文取义故

    卢舍那佛品第二

自此已下正明正宗。文有四门分别。一辨名。二来意。三明宗趣。四释文

一释名者。卢舍那此云广博严净。问此品辨依报。何故从主名者。此土与主为所依。正报强故举人显土

二来意者。何故此品来。既众集已。次明所显法故也

三辨宗趣者有二。一人。二法。人有二。谓能加及所加。各有体相用。下诸会并一约处会分异耳。能加体者以内证法智为体。七日思惟庆喜以显德相。加说为用。所加助化人体者入定为体。蒙加为相。起说为用。余会升沉优劣准之可解耳。法者四种净土为此会宗。又亦可法界及世界海为宗也。其法用真如为体。别德为相。益物为用

第四分文释者有二。一对会。二随品。此卢舍那品果广而因略。故属果德。二名号下因广而果略。故判因行。更有别判。如第二会初释。二就品分者有三。初至光觉等来举果劝乐生信分。二明难下明修因契果生解分。三离世间下辨依缘修行成德分。所以须尔者。为众生薄少善根信心难发故。此品内佛加普贤说净土依果。第二会内文殊承力说佛三业明其正报。以此胜依正以起信心。既起信心已。次须为说法令其起解故。明难品下广辨行相劝依。已见法明白。次须劝依起行归有所得故。离世间下明依缘成德分。亦可依会分文定耳。余义可知。又依璎珞经云。第一会明世界及法界海。第二会明净土。此依经判。大妙。文有此意。甚须思简。至文当知。次第二引证者。如维摩经佛国品在先。如是非一可知。此品大分二。一总通释。二别约文辨。初总有三。一能诠教。二所诠法。其法义不定。广如四十无碍辨才等中释。二别约文辨有二。初大众生念陈疑。二尔时世尊知诸菩萨心下明其答相。因初请问料简八会。诸问不同。即十门中第四也。此略有三。一辨有无。二明法门广略前后。三辨问人多少不等。初有无者。初二会后三会初有问也。所以者初为通问因果二法故。第二所以者复问行法初故。后三所以问修行中同异故。余对文辨。次依文释疑问中分二。初长行。后偈颂。长行有三。初举能问人兴念。二何等下正请。三唯愿下结请。请中有二十三句问。又佛作头成十四句分二。初二十一句问得果法。次一切菩萨下问因法就果文。准下五海十智答文有五子段。初十二句明三身果体差别。又若依一乘即体德用也。余准之。次世界海一句辨净土依果。三众生海一句辨所化生。四法界方便一句辨化生法药。五佛海下六句辨果德摄化作用之义。初十二文分三。初四辨法身德。二佛力下五句辨报佛德。三佛眼下三句明化身德。此约三乘定文耳。佛地者果位出生众德故。佛境界者分局也。佛持者法身持众德也。佛行者行业也。化身文眼耳等辨身业。佛光明等辨口业。佛智海辨意业。就佛海下六句化用文中。初三辨报佛化用。后三辨化佛作用。就因问分二。初一切菩萨所修行海者总也。次别。别文分二。初大乘心等辨地前信乐等种为因也。二出生诸度下辨地上行。即摄十度。波罗蜜即六波罗蜜。愿即愿方便。智即力智也。颂文有二。初长行。次偈颂。偈有十八。偈准地论此名口业也。就中分三。初六偈总赞请。次十一偈半颂上请文。次半颂上结。请前六文内分三。初一自利德圆。次三利他满。后二根器乐闻。就十一句巧略故不可周尽。初八颂三身十二句。次一颂世界海下三句。次二颂上佛海等六句及因行等二句。次第二明答相。文分七。初辨放光集众明其序分。二尔时普贤即入净藏定下三昧分。三普贤入定已下辨加分。四大众同声下请分。五尔时普贤菩萨承佛神力已下明本分。六尔时普贤从定下辨起分。七尔时普贤菩萨欲令众欢喜下明其说分。文分二。初广集说仪。二如此四天下已下结通平等。初文有四。初放光。二集众。三示众令知说法者。四于彼有莲华生下显说仪则。次放光有二意一。现相表实。二起其信心。此文二意通下会耳。因此放初光即明。诸会放光集众偈颂三义不同。此即十中第五番也。集众说偈对文辨。诸会序内显解行法及德位浅深不同。但第六七八三会无放光集众。所以第六不放者。凡放光表往来众集等。地前世间故有往还。地上证体无漏尽其性。处无可摄聚在异处也。但可共加显深方说也。七八不放者起光本显为集众彰法。后二法已先显。今依修行。故不假也。然彼第八会正说中放光者。为明果德摄益分齐不为集众也。又第七会证行境界法唯相应。辨信非言事能证成。故无光及众集耳。又初会光为集众证经。二光觉品显所依法浅深。通下为则。三第三会已去三会光为显当位得理分齐。又问第六会放光集众俱无者。欲显无漏德位不可以事彰故也。放光文分二。初面门是身业。二光中起声说偈是口业。莲华藏海因人非及故。须光加方可见也。所以面门放者表正向教道旷被说故。言面门者面之正容非别口也。所以一一齿者表能对资成功立也。就放光文中有五。初辨所依。次总列十门。三如是等下出光眷属行。四后一一光下辨用。五显光摄益。光十门分三。初六法身正报相。次二明净土依相。次二明摄化相颂文十九偈有三。初十叹佛德行善能开觉。次七劝诣导师兴其供养。往佛所也。次二重叹佛德用内证谛海生物胜欲。就第二集新众文中。先明诸会有无。二次分文有无四。一有无。二来处远近。三本处佛号及菩萨名不等。四供养多少有无者。唯他化天说十地。及重会此二无新众。有四意众集。一为表所摄机。二为证法。三为兴供养。四明众圆集如是等所以可知。其第八会定后集者。表知识方便善巧令自他入于法界。不为显法。亦可为显摄他用非证自义。仍是众集为证法耳。二辨来众远近者十百千等如文。余义对文释。集众有四相。一处名彰法相。二佛名显解。三菩萨名明位始终。四座名辨摄法利用。此但局新众。余即通也。就十方新众文有五。一圆众来此。二如是等下总结。三菩萨次第坐下各显已所得法门显有化德。四念念中于一一世界下明缘起力用自在化物。五明说偈。初文十中各有七分。一处海。二佛刹。三佛名。四彼菩萨名为某佛开觉。五与侍俱来。六兴供具供佛。七各据本方坐。第二结文十亿佛刹等有十亿菩萨来者。此是国土海体同不别。此众生土名字不同者。为表果德普通摄益现法差别不同故也。第三有六。一坐已。二毛孔出光。三光中出菩萨。四菩萨方便周遍诸尘。五一一尘中有佛刹。六一一刹中有佛现。此是实事非化权也。次第四文有三。初辨所化生。二以梦自在法门下辨能化之法。初辨次结。三于一念顷下辨化成益。就成益文有六句。一益人天。二益内凡。三益成十果向。四益令成十回向已还。五益令得七地已还。六益成八地已上。五颂文有二。初十偈颂前十方菩萨久修胜行赴此。后十偈颂前次第坐下及益生文。前十中分三。初二偈辨菩萨自德。次有五偈辨能拔生离苦。次有三偈由德成故。能遍游十方佛所显其殊能。后十偈通颂上坐已下所得法门化德等文也。余相可知。第三佛示普贤使知说法者令众敬请文有四。一辨放光益意。次正放光此有五句可知。三光所照处正示。四从足下入摄用归本。显因果二融。第四出莲华及菩萨。显说仪中有三。初于场处华出。亦可相轮。此有七句。此显摄化分齐。二从佛眉间出一大菩萨。约人显教。三说偈赞叹明教分齐。就第二出菩萨中有七。初辨处。二明所出人。三列名。四眷属。五出已敬绕坐。六退坐有二。七成就下叹所出人德。此有四句。第三偈有二。初胜音说六偈。叹佛化身应器自在。及显法分齐。即显教声德。二师子焰光奋迅说十七偈。总叹卢舍那及普贤能同诸佛。及辨转法轮相也。即显教威耳。初颂分三。初二明化身充满法界现生前意。次二现用说法亦教分齐。次二威德难思。第二奋迅音菩萨偈内。初三辨卢舍那自在转法轮。次十四偈明三业转。即缘具也。此明约缘显三种法轮。初文有四。初半总显。二半辨轮体。三一行明所应方处随转。四一行明义相耳。法轮有四种。一教。二行。三理。四事也。问此转法轮与三乘三转十二行轮何别。答此但一转成其十行。所谓一转无尽转。广如下说。又佛本行经云。佛于箕宿月初十五日内十二日昃过半人影难胜时。北面坐。于鬼宿及房宿时。转梵法轮也。就第二中。初六偈明意业化。次四偈辨身业化。次四偈辨口业化。又释有七。初二总辨因果起化分量。二有二辨身业。三有二明其口业。四有二明意业。次二重辨身分齐。次二重口。次二重意。二明三昧分法体。即敬承佛力。受加以发起。于内有二。一约诸会料简。二释文。料简分四。即第六番也。一有无者入定为表法深。唯第二会所对机浅。法不可深故。又是住方便无自位体。故不入定。法对机位故也。二重入不重入者。初会义重。余会无也。亦可不重为此本分定中说故。所以下别释耳。三因果体别者第一第七及八明。是佛定。三四五六并菩萨定。何为者。初为无垢如藏是净体故入净藏定。第七会自利果行成熟故入佛华严定。此语望化主。若就行者修因华严果故。为修从始故重普光。第八法界解脱利他果满。故佛自入师子奋迅定。此亦约化主。若就修行表因人操境建志立身故。又此三会所显法并通因果。故入果定耳。中间四会入因定。对文方释。四能入人异者。七处入定中前六会明菩萨入。为彰分契理故。亦明踊悦因人。第八佛自入定者明法界解脱究竟果体唯佛能穷故。亦可举佛显法际故。又对佛显诸人所知分齐故。余意在下辨。次依文释分三。初辨普贤入净藏定二照诸佛无碍。此中智断分二也。三于此已下辨等诸佛所得定也。亦可结通也。第三入是三昧下明佛加分文二。一因是料简诸会加被差别。即第七番也。二释文。料简有二。一辨有无二辨诸佛远近及多少名字有异。有无者二七八会不明诸佛加何为。凡加被为果摄益令下位下智得力堪说上法及胜进起行。第二辨机初不定防其进退故不入定。以表法决深故。又人不入定审见法故不加也。第七会有二。一即此会行所依法与前不异故。二明行者起修粗细不定故也。第八会辨佛自入三昧。法界解脱之果大周圆极。故不假加。次佛名不同者显德差别也。次依文释分三。初口加与辨及加所为。二尔时一切诸佛与下明意加与智。三尔时十方下明身加摩顶与其无畏。又此文分二。初辨入定故加。二所谓下辨加所为。即是加相。初文有三。一为加故诸佛现身。二彼诸如来下赞入深定有力能说。三是皆下明加赞所由也。口加文中分三。一总。次二句辨自他行体。次七句明利他行用。意加分三。初一总。次别辨十智。三何以故下释成。初十智文。前三自利。后七利他。此与下十智多同。何故既说果德。佛不自说者此为表胜果下因堪克故。又普贤得定故。长子故。众首故。尽卢舍那佛愿底故。本愿故也。又自善根力故。准下于此应有摩顶已即出。今略无出。下始明出。及益意可知耳。因此明诸会出定说法不同。即第八番也。先辨起定不同。诸会说法对文方辨。第八有入无出。表入法界无返故。第二会出入俱无。初会文不定也。亦可真俗双观。或文家交错。余会具出入耳。第四段菩萨同声重请普贤。即请分。文分二。初少长行怪不说意生后请文。普贤为先唯自众请未新旧共请请不满故不说耳。颂请二十偈分二。初叹德请。二下二偈结请。前文有五。初二辨普贤久诸佛所修诸愿行应依大愿为众即说。次四辨普贤常见诸佛在尘道中应同示说故今应说。次六辨普贤久成定力遍知器海能广为说应同于彼愿为众说。次四辨普贤三业。能云雨利他。何故不说。次二正举性报二土是十力修得。劝应机为说。下二结请。所以唯十地内具加请者为成因证行法。余即不尔也

大方广佛华严经搜玄分齐通智方轨卷第一(之上)二十四

          乙巳岁分司大藏都监开板大方广佛华严经搜玄分齐通智方轨卷第一(之下)

        终南山至相寺沙门智俨述

第五正本宗答文。大分为二。初观五海等明其本分。二明十智。即五海之智。初文有二。一明承佛神力显不自力能入。二正观五海审察其法。今此通说兴教所为有十义。一成佛本愿故名诸佛本愿经。以此准之。二成菩萨本愿可知。三利益时机可知。四末代见闻益可知。五欲显本有理及明修成因果二行。六辨因果二位增微不同。如因中果果中因者是。及明初粗次细等。七明行位相对辨通局。此望同时可知。八因果行位前后通局不同。九辨修德相成之相。十欲显阿含教轮圆净。及约时事显真应二行相。此可思之。依寻下文八会通有十义。至下会文可亦准之。若横取文相显可知。世界海者答上世界海。为净土行成众生住处。众生海者所化生也。答上众生海。法界业海者业用也。成下法身耳欲乐诸根海者通答上因行二句。三世诸佛海者辨佛化用广周。答上三身十二句及化用中六句。亦可此六句属上诸根海。但心境界异以相显根耳。亦可相即入业用海。二十智者分五。一告。二列名。三结难思。四许说。五明说意耳。即上佛所与十智。今叹能显深法故也。亦少有不同者对根别拟。故异耳。佛子者有五义如论。十智者。一世界成败清净智。答上果问中佛世界一问。二众生界起智。答上果问中所化众生海一句。三法界智。答上能化法药一句。四如来自在下答上三身德十二句。此一句即答上法身中佛地佛持等三句。次净转法轮智答上佛行一句。次力无畏不共法智答上报佛中佛力佛胜法示现菩提等三句。次光明赞叹音声智答上佛光明一句。次三种教化智答上佛眼耳佛智海等三轮化佛德。次三昧法门不坏智答上报佛三昧。以果德体故别答之。次如来自在智答上化用德中佛海等六句。下广文随相准释上五海。初世界海十智中世界成坏智。亦可通说下广答也。此之十智即三世间智。一器世间。二众生世间。第三第四智正觉。次愿转法轮智说前三世间行。六力无畏不共智依法成治。行力治魔。无畏治外道。不共治二乘。七光明音声智以佛事善成赞扬三宝。第八三种教化智兴隆三宝使不断绝。第九三昧法门不坏智明证智。十如来种种自在智即后得智。又此说前一海。即具十智耳。以智法正助各相成故。为五海依下三世间转成十身。法相似故。如是下三结叹难说闻。四我当下显承力方许说。五欲令下明说意。又义言观佛五海十智说自十智。又通观因地五海十智说自十智。为起说方便智与本法施设不同故。又亦可下别辨文中论土者是知习境也。此可思准之。亦可唯佛地耳。又亦可地前人说是智习境。地上菩萨及果人说是证非习也。第六起分文分二。初辨起益。二毛孔赞叹。初文分二。一正起主伴定有二句。初起定。二不坏本体。二一切三世三昧下辨起定益用有二。初内益。二动地下外事益有三。动地及二益也。初用文二。一此众益。二如此下他方益。此众益有四。一得定。二得内方便。三得外用辨智。四得大悲愿行。第二毛孔偈赞普贤德。文十四偈即是加赞光也。分二。初八明普贤菩萨自在尽佛源底。次六偈明普贤应化及土普应众生自在成义。前八中初三身业自在。次一口业自在。次一行意业自在。次三总叹三业自在尽佛境界。第七菩萨令众增喜敬。文即说分有二。初令众喜即授说方便。二正与法。初文分二。初长行明重欲说意。二正说偈令喜也。偈文分五。初十约佛叹德用深广。二普贤菩萨下四明普贤善入能广利物。三无量下二推功在佛。四一切刹土下二释普贤益其功在佛意。五有二结德劝听。许说在当。初文分四。初二总叹。次二叹佛功用。次四举众生界及法难思。复能遍摄促入。次二举法利益。第二文有二。初二普贤善入。次二明普贤利物胜能。普眼者具五眼自在智故普也。又具十眼也。理量等知故云普耳。次第二正说广文。诸会能说人异者。唯阿僧祇小相二品佛自说。余品别人说也。依大论说有五。一佛。二弟子。三神仙。四诸天。五变化。此据出声名句味。若望授与即通情与非情。又有五种说。如下文也。就文分二。初广出世界体相即答上果德二十一问。二乃往过去下答上二问因法。初文分三。一总明世界因缘等庄严十种事义。二尔时普贤菩萨欲分别下明此世界海集起因缘之状相。三法界不可坏下以偈颂上二段文。问何故本分观海说智。此说分废智说海而不具明。但论世界海者何也。答此为立文者但成信解智而未尽海源。又世界由智成。说海即是智。复此略明显互为诠相故也。又此说由是方便相故。即是智也。此须思之。初文分二。一列十名。二别解总列十名庄严文分四。初举数并引证。二列十名。三结体。四引余世界尘等庄严具成。二别十中后一初一列名不释。何故尔。由说通余九。今约不明。欲成莲华世界略不明坏。亦可成即坏也。凡依三乘净土有四种。一性。二报。三事。四化可知。若依此部一乘但有二种。谓世界海及国土海。或十种如下瞿夷说。今将此十名。对摄论十八相圆净对辨同异。彼文摄佛别住处合有十九也。佛别住大宝重阁上已明故。此中略无。即是彼论别住处也。今此起具因缘。是彼因圆净亦通第一色相净及三量圆净。故偈云众宝成及无边际故知。文中分二。初长行。次偈颂。诸偈皆尔。长行分四。可知。三别中有八。一佛神力即胜进力。摄成即佛后智也。二缘起理然。三是因得。四行业果感。五普行摄成。六共因所得为生取土摄成故。七是佛依果。八普愿所感。偈有二十文有三。初一总次十八以广显略。三后一偈结之。第二住中三十半偈。初八明土相。二二十偈广显事安住义。三有二行半五字偈显因陀罗安住相。第三形偈中有三。初三行广显形。二四字偈下六颂土因。三一切业海下八半辨因陀罗住持。第四体内十偈以广显略可知第五庄严中二十偈亦以广显略可知。第六清净十八偈中亦以广显略可知。第七佛出世二十偈中有二。初四辨佛出世。次第二广明利益可知。第八劫文略无颂耳。次第二广开示成立世界海因缘状相。文中有四。一辨普贤重分别意。二明净土因有三。谓时缘行等也。三辨相成。四常说法处结处属人也。此中事状广说。余理行教等略说。可思之。第三文有三。初明风轮上香水海辨本末相成。二香水海上已下复持世界性显重成义。三彼众香水中下复持向上十二佛国等七世界性明分齐义。就初中有七子段。一风等地通是本。二宝王地。三有斫迦罗下明有宝王映现受用如意。四大地处下明地上有小香水海等。五明香河绕香海广作利益。六明河中有宝树庄严。七有少长行。一一境界有尘数庄严。亦可结分齐耳。诸文并有二。初长行次偈颂。第一风本末中五。一风。二水。三华。四世界金刚。五金刚山风文有三。谓一总二别三结等。二别中有十重风耳。偈文有二十。但明用相略不辨持。文有五。一有七辨因住持严。亦颂前文。次五佛德圆周十方。次一明此土穷因陀罗网体。次六明佛事随心自在大用。次一辨具普贤智行得见闻此土。次金刚地文有五。初宝地。二地上海。三众宝。四金刚地出生宝。五光明颂中十七。初九颂上五句。由佛力故。次八法轮及佛充遍十方。即地用也。九中初三颂上圆珠地。次一颂金刚地。次一颂宝庄严。次二颂海。次二颂光明。斫迦罗此云轮也。八中分二。初四身业体。次四辨用。三摩尼宝王映中有五句。颂中二十偈。初三就地以明映净。次五颂华。四颂云。次二颂刹庄严。次四明此世界十方菩萨常来不绝。下明修普贤行得入无边佛刹。四明地上香海中。初总中有十四句。别颂二十颂上妙宝香等广作佛事。五河中有二。初长行次偈颂。长行有四可知。颂有二十。初十二颂河体及光明。次八广佛圆极自在。六宝树文有五可知。颂有四偈有二。初二明果行自在。次二明因行自在。七当知下明世界清净庄严及结也。第二风所持香海上别持不可说佛刹世界性住。此中有二。初长行次偈颂。初文分三。初总明佛刹。二或有下别明住。三或须弥下明世界形。颂有二十。颂前长行中第二文。初一颂净土性相。次三略颂住。次五颂形相庄严。次二明约业浅深显土优劣。次三总显优劣。作入深方便。次二辨成。次四明能成方便功力。三明向上持世界文有四子句。初牒上香海河等并列名。二明所出莲华。三明华所持十二佛国海七世界性。四如是下结等余方。此有二可知。若依下瞿夷文内。除三千界外有十世界。一性。二海。三轮。四圆满。五分别。六旋。七转。八莲华。九须弥。十相。又义言此十界互为首。余九庄严成一百句。今此世界。或是莲华。或是海。余者共严也。可准思之。世界成相虽有众多。义由难解。所以知耶。依此经文更有刹名。不知是何。今依一义。此刹非是如上诸相。由说佛刹无上诸相高下别故。依佛取处名刹名土。即无别异高下。若约众生取土。即有诸相高下。文言常转法轮处者约众生说也。若依此解文少可寻。又大论中第五十卷内。复次三千大千世界名一世界。一时起一时灭。如是等十方如恒河沙等世界是一佛世界。如是一佛世界数如恒河沙等世界是一佛世界海。如是佛世界海数如十方恒河沙世界是佛世界种。如是世界种十方无量是名一佛世界。于一切世界中取如是分是名一佛所度之分(此约三乘说)。又大经本中十种世界。一世界性。是同类义。二世界海。色类多义。复深广义。三世界轮。齐用义故。四世界圆满。具德义故。五世界分别。是不杂义。六世界旋。是正旋义。七世界转。侧转义。八世界莲华。敷发义。九世界须弥。是胜妙义。十世界相。是形貌义。何故说十。欲显无量故。问何故一中具见一切土答为修行者居自报土各各不同。佛摄众生所现世界及佛土等似彼报土引诸众生。仍摄佛境尽故使然也。又问何故大论明世界海。与此经不同。答彼为三乘人方便渐释故不同也。第三颂上二大段文有七十偈。大分为九。初二十颂上成坏世界海次二颂上庄严及住世界。次十八颂清净世界。次五颂体世界。次五颂起具因缘世界。次六颂形世界。次二颂劫世界。次五颂佛出世界。余七颂说世界。就初二十句内。初十一法说。次九喻说。又此结对染器世界交络结之。所以者。为欲引下信心显入上法方便。故此准之。次第二文辨得果之因缘答前二十三问中一切菩萨所修行两问。论土因者如经可知。文中分四。一举往世佛及土是起因缘。二佛子彼焰光城中下辨因人即童子也。三明见佛得定。即为自分正因。四彼佛灭后下明复见佛得定。有二可知。即为胜进因。此文具彰因门理教行事因果三世自他主伴人法因缘本生记别普贤法门等具成。可准前取之。又此等何以无重颂偈者。答凡颂有二。一少摄多义。二异时为后来者。此等若颂即无上二义。此可思之。初文分四。一明久远劫数。二尔时有世界下明土处。三时彼林中下明有道场华座。四过百岁下明佛出世。第三见佛得定有四。一时彼童子明得定有二可知。二时普庄严童子下以定力说偈。三尔时善慧王下明王闻偈喜复更说偈。四尔时善慧王下明与劝大众往佛所。童子偈文有三。初生起。二正颂。三明音分齐。偈中初四赞佛难闻。次三颂佛慈光益世。次一劝众诣佛供养。王九偈中。初生起。二正颂偈。初一总劝众诣佛。次七教令严供具。次一教令与眷属俱供见佛。四往诣佛所文分四。一往佛所有二可知。二尔时如来下佛为说经。三尔时童子下明获益。即自分中胜进也。四尔时功德下辨佛寿命起后说文。三闻经得定获益文分四。一明得定。二童子偈赞令众得益。三说是偈时下正明益相。四佛说偈印成令发心者心坚固。就童子十偈初二赞佛法身。次七明佛久修愿行今令众见。后一举佛德劝菩萨修行。佛偈文分四。初三叹童子有勇猛力。次四叹普庄严大精进力。次一授记。由供佛故成佛。次一引证。劝令勇猛遍诸世界。此中因得定其位者。童子第一见佛当十信满心自分。第二闻法当十信满心胜进。第三见佛当解位初心自分。第四闻法当解位初心增上也。所以知者。以童子所得三昧用比上下诸位经文。是以得知耳。此略无颂。何以竟会不明得益者有二意。一此经佛初成道总显法轮体。但表佛有法益在后时未即利也。二如日初出光照高原。此八会次第益菩萨令其胜进。即是益也。由无中下根故不别辨益相耳。初会竟讫

    第二会普光堂如来名号品第三

有四。一释名。二来意。三宗趣。四分文释

释名者有二。一处名。普者德普。光者智光。亦可光普。二品名者。名即通名。号者别号

二来意者此有二意。一会来意。二品来意。何故会来。前举净土为所信境。次辨能信心故也。二品来意者。前辨所依土。次土中化主人名故也

三宗体者分别有二。一约人。二约法。人者化主及助化各有体相用。如文应知。但局此会。二约法出体者。谓十信行法。后当分别。名号品以化悲德自在相为宗。亦可是佛国海为宗

四释文者。依大光律师云。前会普贤承力说净土依果。此下明因行。此意从会判故也。此为前会果广而因略。此会因广而果略故尔也。问何故因与果同会者。答计行应别。今但为显法依人弘故。同一会不分别也。就前三品正报中。初名号明佛身业。二四谛品是佛口业。三光明觉辨佛意业。又亦可名号品显土以生信。二四谛品彰法是宝。三光觉品显法增微成下轨则也。就名号大分有二。初辨此会序。二是时文殊师利下明其正说。序文分四。初明住处及佛德。二与十佛国土下辨所被机及其助化。三诸菩萨作是念下明欲请。四尔时世尊下辨集余方新众以发起。今约长分为定。何者长分为八。一举处及化主并叹佛德明显法因缘。二明所被机。三明陈所疑事。四辨集新众。五文殊叹曰快哉下叹化事甚深成土难测。六四谛品下教法甚深谛言设则。七光觉品下许说方便显法渐次彰其浅深。八明难品下正陈行仪辨法浅深之状相也。何意树堂并说者。为此堂在树南同处。诸鬼神龙为佛作故尔也。就初叹德文有二。初辨证性明自利。二至无碍趣下辨利他德。自利有五句可知。利他有五可知。二列所被众。此中有四。一简大异小。二简始异终。三简新异旧。四叹德。就叹德文有十分二。初举二章门。二有八句。四句对前一门也。二二自他利。三时众请文有四十四句。问所以此会通问上位及果德者。此会是起行初并复对化主。文次故尔也。亦可此问佛土。非世界海可思之。问内分三。初十问辨法身三轮果即生信之境。即先际佛法即此会答之。次开示下有二十问辨中际佛法。至菩萨住处品已来答之。次佛无上下有十四问辨后际佛法。讫小相品已来答之。大光师但作三十三问。即合随喜等十句总为一问。此最好也。先际内初五问名号品答。次二四谛答。次一光觉答。次随佛刹起等者明难等三品等答。示成正觉亦光觉答之。贤首品亦有答相。亦可并尽性起品来答之。中际内初三及第五问位法。第四十藏十愿下有五。问行法位法可知。十愿十自在等从升忉利天品尽十地品答之。次十定等十四句从十明品讫菩萨住处品答之。后际十三问佛不思议品讫小相品答之。十愿十明品答。十自在下十无尽藏品答之。十顶不见别答。十忍品答此十定。定即忍也。此由品分故尔。若通即对文当知。第四集新众文有二。初明能集。此句文局而义通下会也。二辨所集。即如其像者。一如器像。二如器所对境像。像者缘集似故。影现故也。即如其像现神通力者。正以果德圆极体融至顺冥津无外缘无不在故。能随其行别位殊故。显会相应也。所以放光下觉品重明者。此为一事表二法故。分文二处也。一为集众。二为寄法浅深三辨所集。土同色者表功德显外也。佛同智者内解元也。菩萨同首也进行始也。座同莲华将成果初也。所以集众等先从东方。为显开明之初生长之始故也。第二正说文。若长分此即第五叹化主甚深。所以此会不入定者。明法体不住随器不同。若对胜器法深故须审。今十信解劣不表法深。加劝等准此可知。所以文殊说三品为平等妙慧智住胜境方显法故。所以文殊说此品为妙慧善达佛国海故。此文有四。初叹众希有二句可知。二诸佛子下略牒所问法明不思议。三何以故下列名广释。四是皆如来下结叹摄化益。第二有十句可知。第三文内初总次别。总内分四。初责。二答。三重问。四重答。此中初一总。余十六别可知。诸四天下列十六句。所化机相不同。证成名号各异。此等名是别非通。此中正举诠显其净土也。二何以故广文中分二。初责。次答。答文分三。一明此三千大千界名号不同。二有密训下明余三千界。三如是东方下广解尽界名号也。此既明一佛土名。何以取上下者。此为上下亦无方傍亦无际以显教圆也。此意如文耳

    四谛品第四

四门同前

一辨名四者。数谛者有作无作圣谛实故也

二来意。何故来者。前叹化主。此叹所说教法。何故独此会明。答此起化初故。总叹人法深胜故

三辨宗。此叹教法谛实甚深为宗

四分文释。此文分三。初略列此方三千谛名。二列十方三千四谛。三佛子如此娑婆下广辨无边界者。凡四谛有二。有作。无作。此中文通意唯无作。真实不虚。问何故不依一谛而依四谛设则者。为通与下三乘人作见闻境成后起信入道缘故。又亦可此通有作无作。为是一乘共教故。一乘有作即空。一乘无作不空。此可思之也。所以文殊说者妙慧善达虚实故。四谛义讫

    光明觉品第五

四门同前

一辨名者。如来即化主。光者智体。明者用。觉者开晓于缘耳。又觉诸菩萨

二来意。何故来者。将欲说故。集有缘众并显法分齐也

三宗为集同法众亦显法增微。人法体相用准之

四分文释者。此上三品并通下第六会已来。增微有异文局义通。可思准之。此文有十。初文分六。初佛两足放光。二明光所照处。谓此三千世出因果所有法各有二文也。三结分齐。四由佛神力故见诸菩萨来集有二。初总次别。别有菩萨土佛三文也。五文殊说偈叹佛一乘。三乘小乘法是一乘信法方便也。六如此处下结类余方。余九同然。略无结文。因此料简诸会放光隐伏同异者。第一会放光有十意如文。即为证法始。名号品初神力集众显其位相。光觉品初相轮光显信位所依法分齐。次佛神力集众显当位中所成德。此经中云神力。未必放光。次菩萨说偈者即明当会所解理事法分齐。此法依位成耳。问此处显位集众。何故别品明。下四会不尔。欲显摄化所依佛土及显教谛实入其当位并与下为则故尔。佛足相轮放光示十信是行足圆备故也。此中放光分齐有二十五重。初九别列。余者总结。文相如经。第二文辨光照现可知。第四文内所以文殊在前贤首在后为表智先福后故。又明前智行后位故也。文殊者此云妙德。妙慧行也。又此中光觉在于一时。而能别见远近。又诸方运集只是一人而令众异见。未必有多。又诸方往来者唯见当处集。未必见余方交往者。又诸方光及现十方所有者并见当中。未见偏处者。此为以报法摄化土所有故也。又亦前机自变当处自心为本。所以诸事随心为正化者无此别相也。此可思之。第五偈颂文言出文殊。意表余十菩萨。所以文殊说者示法从慧出故。偈云总明般若所证。真性相同初地行。又亦可并渐渐增多故。不可偏表其十地及十菩萨颂也。又亦十名显数圆。渐多远者显法渐深耳。大分有三。初一辨取相不应真法。二有八偈辨离取应实法。次一叹解者有胜能也。八中初三辨分别无性。次三辨依他不生。次二真实离相也。亦可八行俱依一境观。又今辨增相者。约因果各二种。一竖。二横。因竖约法明净。横即知法宽狭。果者竖即自分非他分。横则得处多少也。又下诸集众叹德并叹当位分齐。所成知见下可准之。第二觉首偈文。此下九偈倍为异耳。总明知善恶等慈化物益。相同二地戒行。文分为二。初六明佛觉他令离二边。二有四明菩萨利益同佛。第三财首偈总辨平等法财资成益物。相同三地。后智教流益物。文中初一明佛德性能无碍利生。次九辨幻现八相正说法身。第四宝首偈相同四地无摄义。此虽未得但解见也。偈文中三。初五明佛成其无摄。次四如自所解利众生。次一喻以显净。第五德首偈相同五地中相续不异义。明不住道慈悲益物。偈文中三。初五辨菩萨慈悲不住道。次一正观相续不异义。次四辨令他成真实净境。文又得十平等净。一行为一义可知。第六目首偈相同六地无染净义。偈文中有十七。为四。初二辨执取不见真佛。即辨失。次四成如量智者得见报佛。此即德耳。次六辨得正体智者见法身。次五明法深微显解分齐。又此中上下有二文同异。一者一中多一数中见十故。多中一者十数中见一故。又一即多者一数即多而不见一故。多即一者多数即一而不见多也。此可准之。又即事辨一多。二异事辨一多。可思之。第七进首偈相同七地中种种法无别异义。偈文中三。初六辨空中方便智有中殊胜行。即叹德也。次十劝观实性显解方仪。次四明于理量二境入得胜法也。第八法首偈相同八地无增减法界义。文中初二明佛成理智故能灭障。次六叹佛深法益。次十二劝摄果性三世用力也。于二为一对。初一辨智入法。次一结成智用。又长分为十耳。外即净土摄生。内则成其自实也。第九智首法门相同九地明大悲利他自在智。偈文中初二辨意业。次十六明口业。次二辨得法无碍故大用无碍。又初二总。次广叹用相也。第十贤首偈相同十地业自在后智用也。偈文初十四正辨业自在。次六喻说十四中。初五明观实性得依果因。次九明观业自在故得正果因。初五文中。二行体。三行用。九文内分四。初三明顺真如观故得菩提果。次二修事观故得法身果。次二修慈悲故得化身果。次二从佛闻法故得报身果也。此品答上第八佛功德势力及第十示成正觉二问。问何故约增光觉集众。答为表法有浅深行有增微故也。此文与后为则。今略开诸位为二十二门。六道因果即为六门。声闻辟支二人因果。通说复为二门。声闻辟支所依之佛。为彼二机说四谛教及十二因缘教。即分佛通因及果复为二门。声闻缘觉回心入大乘。于初教处。通因及果复为二门。直进初心菩萨通因及果复为一门。直进熟教及回心熟教通因及果复为二门。顿教因果复为一门。从愚法声闻总摄诸位干慧地已上菩萨及佛复为一门。普贤位中从信已上乃至十地。皆通因果菩萨及佛复为五门。此依普贤阿含说

    明难品第六

五门分别

一释品名及来意。明难者有二。一约法。明十义深微故也

二约辞。论难显义情故也。明者教。难者十义。又明者智。难者论道也。来意者何故来。众集已。为说信法成解故来也。余义可知。二出所治。一嗔障百法明门之障。此下生解断障凡有四义。一约生信。即初地断使种。二约位。即解位使习种俱断

三约行。即十信满心使习种等俱断

四约实。即本来不须断。自体净也可准思之。又问断惑相云何。答非初非中后。前中后取故。云何断。如虚空。此是三乘共学义也。三明所得。得百法明门。若约行门即得华严三昧。四辨所成成其信。谓十信心。一信心。二念心。三精进心。四慧心。五定心。六不退心。七回向心。八护心。九戒心。十愿心。如经初发心住未土住前。有此十心名字增修是心。一劫二劫三劫乃得入初住位中增修百法明门。十心之中心心有十故成百法。常发有行无行大愿。得入习种性中修行一切愿。依此下文有一百四十事上行愿。依璎珞经。有二十四行中成愿。即此品宗。此约别相语。通义如论应知。宗者有二义。若约品即以十深义为宗。若约会即用十信位法为宗也

五辨文者。正宗文中上辨举果劝乐生信分。自下第二修因契果生解分即所学法也。亦可是第八显其解行义。或辨法浅深之状相也。文中分二。初讫小相已来明方便对治修成因果。二普贤菩萨品下讫性起品明自体因果。释意可知。初为修成者依闻熏修起故。所以名性起修显者本性今成故。又圆明因果实觉发中故。约三际辨者。此明难品讫贤首明始起于先际。二忉利天下善修于中际。三不思议法品讫小相终显于后际也。次约四成就者。初辨未信令信。二忉利天下明已信成解行。三十地品下已入者成就。四不思议下已成就者令解脱。余准可知。又约修成分亦好。又从此下并是序分。第六一会是其正宗。前是阿含。后名义证故。又为第六会中广出本有修成体相等故知也。此可思准。初信文分三。初一品明依法生解。二净行品依解成行。三贤首品明依行彰德以成位耳。初文中分二。初明问答显十种深义。二尔时娑婆界下显解行入法界圆通无碍。即明法益耳。初文有二。一文殊问众人答。明妙慧导众行。二众人问文殊答。明以众行成妙慧。文有十义。一缘起甚深。二教化甚深。三业果甚深。四佛说法甚深。五福田甚深。六正教甚深。七正行甚深。八助道甚深。九一乘甚深。十佛境界甚深。所以初缘起者由菩萨初学应先观诸法如实因缘故也。缘起者黎耶共善等三性及无为集起故也。文中问答即为二耳。问内有四。初总告。次立正义。三申问。四起后难有二意如文。共成一缘起相违难。问意云何心以无分别为一性。云何能成种种事也。若能成者不应无分别耳。二既诸法并无知者。所作云何仍有真俗事也。又解但是一问。后文是结耳。问文十事可知。答意但为无分别不住故能成众事。若知分别不可成也。问既不分别。云何成因果。答作无主故。反示可见耳。偈文分三。初一赞请劝听以许说。二有七偈法说譬况以显理。次有三对彼前法明观行也。第二文分二。初五举法答上问。次二遣伏执。初有二。初法次喻。所以得知不住故作。偈云诸法不自在故。云何知作时不知。偈云求实不可得故。余可知耳。次喻有四。初约缘成相续经时喻。次一约缘起有为生灭喻。次一约因缘腾击动成喻。次一约缘起体相互依喻。伏疑云既不分别云何流转。偈云由眼耳故。复云既也无自。云何有现相。偈云示现转故。文言不相知者非谓情知。今言有力性作也。二自不对故云不相知。用自性为知法之始也。观文分三。初牒前理。对法辨观。成分别无相观。二一依他无生观。三一偈真实无性也。所以觉首说者知觉法始故。第二教化甚深中分二。初问后答。何意来。前摄心入理。此后智度生。财是法财。问有二。初总告。次别。别中有三。初一总。次十一别。三一结问也。第二文有十一句相生。问文可知。问意云何如上说。若众生无性。云何教化。若随教化。云何心住无性。答文有二。初生起。二偈答。义意但以知境无性。虽在缘即离取非也。但为无生故化反示可知。偈文分二。初赞问者许说劝听。二示正义。正义文分三。初三偈总示正义。次四约观门显示。次有二偈示伏疑。初文分三。初一总示。次一正明约内身示观行。次一以内类外辨化生无取。第二约观门辨者有四。一举因缘无始明所观法。次一劝观。次一明诸法是无。即约观释相。次一正约唯识门以遣。三伏疑有二。一既世法本然无性。众生何故不知。偈云悉虚妄故。二若法无者何以种种现。偈云从缘起无异相故。所以财首说者能以正法财施众生故。第三业果甚深有问答二文。问有五。初告。次立义。三问。四结。五生后。第三问文有五对十句可知。问意既性无我所。云何受苦乐。若受苦乐云何仍说无性。此是理事相违难。问与前缘起难何别。答前是二事相违故别也。答意为苦乐即性无别体。为是不违耳。偈文分二。初法。次喻。喻文有九。一辨依他离性喻。二缘起成有喻。三因缘现果喻。四缘果离性喻。此望能熏。五因体无杂喻。六受生离作喻。七果报无本喻。八胜事无根喻。此望用耳。亦可互彰。九有无同性喻。此并不坏世间说第一义也。所以宝首说者能事中显理。初得可贵故。第四说法甚深。初问次答。问文总别二文。别中分四。初辨所得法。二十句正陈问。三而法下结。四生后难文有十种相违。问意法若非一可随言并实。法若不应言教便是妄。此是教义相违难。答意所言一者法唯一不住义也。亦可一善巧是故能贯。众教仍一义成也。偈文分二。初赞问者。二约喻显示。喻中有九。第一明法能荷负万机喻。二缘灭众惑喻。三入器无变喻。此望德用。四拂动诸根喻。五应欲随润喻。六缘生众德喻。七拣染赴净喻。八应物无往喻。九应缘住体喻。所以德首说者为初显法多能故。第五福田甚深。文相准前可知。问中有二。初告举正义。二成难。难中有四。初总告。次别。三结。四生后。别有十句。问答相可解。此是因缘相违难也。偈文有十。一缘能现果喻。二对机随解喻。三权巧令喜喻。四应感令喜喻。五物感现形喻。六缘灭众惑喻。七对治诸惑喻。亦可起缘分齐。八悲情普被喻。九动拂诸有喻。十毒灭三有喻。所以目首说者初见法明白故。第六正教甚深。文有二。初问次答。问中有四。初总告。二正问。三结。四生后。问文约所知十法为问。问意云何若教能断。即不须更后知因果方得断也。若要须知因果方断者立教有何益也。答意有二。一进二退。退者自无益。进者教。即有胜用上难是教力相违难也。偈答文分三。一劝听开二门立宗。次一劝精进以彰教力。即对初门。次八辨懈怠失对上第二门。此文初一多闻懈怠喻。二无力懈怠喻三遍修懈怠喻。四倒修懈怠喻。五过求懈怠喻。六少力懈怠喻。七少治懈怠喻。八无有出意喻也。又执我慢高喻。所以进首说者初进能显成胜德故。第七正行甚深。有问答二文。问文有二。初告。次问。问中有四可知。第三所陈句有八可知。问意云何圣说云闻说法有能断烦恼。云何有闻法不断惑而惑依心心无所行反能断惑也。此名圣说行教相违难。答意教不无力。但取不得方故也。答文分二。初总敕听略说。二以喻况成。喻文有九。此但举失以显德也。一不如说行喻。二随说废思喻。三计文迷行喻。四自谓非分喻。五恶业障碍喻。六不解自说喻。七辨聪持说喻。八废正成助喻。九隐非现是喻。所以法首说者能初显法可轨非邪故。第八助道甚深。偏执此圣说正助相违。问文有五。初告。二立正义。三正问。四结。五生后。答文分二。初赞问者许说。此赞者通能所。二正答。答文分三。初一总答。次四会偏赞意。三有四偈明正助相成不可废意。会佛说文有二。初总。次别。文相可知。正助相成文有四可知。所以智首说者能初善用正助故。第九一乘甚深有问答二文。问文有二。初告。二问。问中有四。初立正义。二问。三结。四生后可知。此是因果体用相违难。答意我佛因果体用皆同一法。谓法性一法。亦可一大慈方便法。但众生见异耳。偈文分六。初二举因果俱一以答上问。次二明自业各异见。次一成佛本一无别精粗。次一明善行者得见。次一明佛自在业随物应机。次三释伏意。意有三可知。亦可唯一耳。所以贤首说者善开圣法顺理得中故。上来辨一人问多人。次下明多人问一人。即是第十佛境界甚深。有问答二文。问文有五。一告。二结已说。三叹所问者辨德以进问。四正问。五生后偈颂。今所问有十一相。何故先文殊覆却难。今但直问者。为彰长位故也。十一问内文分四重。初三自利德。次四利他德。次三所利众。又此三通能所也。后一总明所问广大。一佛所证知分量境界。二能证境因。三问所入处。四佛境界内度几许众生。五随顺境界智。六随众生所说法。七如量智分别知。八佛境为分别识。所不识。九于何境界中能令众生决定知佛境。十智照何等众生心为境。十一如境中说何等广大义。所以文殊说者妙慧达佛境界为始故。答文有十偈。初一答上佛证境界。次一答上佛境因。次一答上所入境处。次一答上佛所度。次一答上何等随佛境智。次一答上佛境法随众生说。次一答上何等是佛所知境能分别智知。次半答上识佛境。下半答前何等能决定知佛境。次一答前佛境界广。次一答前境界照。亦可依问次第答。次第二大文明既得信解平等无碍现莫二之相义也。文中有二。初明承力见此刹无碍。二如是下类通余方齐见获益。此文有二。可知。初此方利益文中。又云初总次别三结。别中如所行法者如上第八智首所辨六度行法。如所行业者如上第三宝首所辨随所行业受报亦然等也。如世间行者如上第六进首所辨精进速出懈怠难脱。亦如第七法首所辨修行出离多闻不得。随身行者如上第二财首所辨随身随行见为教化名随身行。随根行者如上第四德首所辨佛法虽一随根分多。亦如第五目首所辨佛田虽一随行分多。随其行分多随其行报所生之处。持戒毁禁者如上第一觉首所辨心性虽一随行不同受报各异善恶等别。说法果报者如上第九贤首所辨随众生欲诸业及果各令见实名说果报。又如向前文殊所辨佛境界法亦得名为说果报矣。又此显现有二。一表法顺理是法皆真成圣方便。二表法体应理功能明净一切皆见。

    净行品第七

四门同前

一辨名。此中广菩萨修行胜妙净行之相故名净行品也。亦可净者德无垢故。行者体。又净者愿。行者所净耳

二来意。所以来。依解起行故也。亦可前行次愿故也

三以诸愿为宗

四释文者。此文有二。初智首问次文殊答。所以智首问文殊答者。初愿相微非智不受。随相发愿非妙慧而不明。问中义类相从有十一事。总分有二。前七云何问自分因相。二得是处智下明问胜分果相。就初文内。前一福因行。次一福果行。次一智因行。次一智果行。次一法智因行。次一证智果行。次一修满成诸度。初问有九。初三种离三毒。次一坚固不退。此不同凡夫。次一自利成。次一利他胜妙。此异二乘。次三离信位前假名菩萨见。又解初三断对治。次三体。后三性治也。思即知之耳。第二问事有十也。第三问亦有九事。第四问中有八。余文可知。第二果内问中。胜进果文有四。一入果分故堪受物养。二为天神等敬护。三辨大悲行德。四辨位德也。就第二文殊答答尽。思之可知。举一愿答前多问无余耳。文有三。初长行略答。二偈诵广答。三长行结也。初文有二。初赞问者晓喻其怀有二可知。二佛子下正答。答文有三。初辨自利。次去来今下利他。三明达实相下明胜进果行。文有二可知。第二尊导者佛为一。能请故为二也。又对普贤因人望果故。又自利道满为初。今利他德圆为次耳。二偈文。初牒次偈释答。愿有二种。一行前。二行后。此是行后。亦可同时由即行故。此总有二意。一即转其见心即成行体。二转求异事成彼愿事也。此愿有十种势。一会事入理。如菩萨在家等。二以因同果。如若在聚会等。三以自同他。如见无惭愧等。四以人同法。如见疾病人等。五以染同净。如见背恩人等。六以世同出世。如在房舍等。七以境成心。如若入僧房等。八以体随用。如见苦行人等。九相似类成。如布施所珍等。十以实同虚。如若在伎乐等。如是准之。偈有一百四十大分为二。初十一明在家菩萨法不舍世间行。余文明出家行。是不住有为行。出家文有五。初十五明出家受戒法。二若入房舍下二十辨住处进以威仪行法。三手执锡杖下五十七明道路行法。四入里乞食下二十明入城邑聚落乞食行法。五若入水时下十七明出离修道行法。愿有三种。一要期誓愿。二行愿。三自体无障碍愿。初未成欲成。二正成行。三成已是真愿。即六决定及性起等一切诸愿皆有三文。初一句自分境。次一句及众生。次二句摄同胜事也。又问何故璎珞经对入理处愿多。此经对事愿多者。答此经顺一乘教在事益大。璎珞经顺三乘教在理益即多也。可准思之

    贤首品第八

四门同前

一辨名者。十信已满位是贤圣之初。为凡顶菩萨中初故曰贤首品

二明来意。何故来。行既成立。次须广叹德用成位故来也

三宗为叹德

四释文。此品有七百一十五偈半。文中有三。初文殊问。二有七百七偈半贤首正答。三贤首说。此品竟时下有六偈。经家所显诸佛证成。问文二。初长行。经家总显文殊问意之相也。次有二偈。牒前净行成是信因。以正请问。初一结前。次一起后。所以文殊问贤首答者十信位中圆通之德非妙慧不受。深义净德唯贤始得。明第二答中。文有四。初十三偈总明信位发心行相。二深心下五百一十九偈半广明信位德体殊能。三一切诸佛皆共说下一百五十四偈明所说旨深群情莫晓以喻为况。四如我所说诸譬喻下二十一偈校量劝发。初总文有三。初半敕听许说。次六偈半举广义以显略文。次六偈正说发心功德行相。二举广显略文。初有三偈半明说分齐。次二显广是深。次一成初略说。三总赞德文内有三。初半举因缘二门总叹德。次一半略辨发心缘及因通辨上二。次四表发心意有二。初一明所离。次三辨所成。此三偈中初一开二门。次二释前二也。第二五百一十九半中有三。初一百三十二偈辨自分因中集菩提具。次施戒忍辱精进禅下三百五胜进果中集菩提具。三神力于此得自在下八十一偈自他无碍成就功德。初文分二。初一百一十九辨自利差别相。二或有刹土无有佛下有十四利他行事。初文有十。初十八明十信初位相明四不坏信。二若信恭敬一切佛下有十。是第二位同二地相。三若信坚固不可动下七偈明第三位同三地相。四若为一切佛所护下有八。明第四位同四地相。五若能具足摩诃衍下九偈明第五位同五地相。六若得大悲心坚固下有八。明第六位同六地大悲为首观等。七若解一切众生行下八偈明第七位同七地相。八若能超出四魔道下十九偈辨第八位同八地行相。九若说微妙甚深法下十三偈明第九位同九地说法相。十若身功德智慧具下十八偈辨第十位同十地相。初位文有二。初十六偈辨初位德。二是故下二偈通叹十位次第德。初文有二。初四辨所信境。二有十二偈广叹信德生善灭障义也。初境文有二。初二三宝。次二三种佛性。若信不可坏者。何故论云善根薄喜舍等也。解有二。一此明一乘顿入人。二明此种子非上心行位也。亦可此信满心一向不退。此语住信满心行十解能成行也。故诸经异说准之思摄。二是故下结有二。初一法说。次一喻况。二二自分因行文。第二利他中有四。初八明清净方便八相成道化。次二无染方便化。次一明大用体。次三结叹自在。二施戒忍辱精进禅下辨胜进。文有二。初九十偈明自利行满足佛事。二说法教诫及神足下有二百一十五明利他行。自利文有三。初七十偈身业不空。二柔软美声如哀鸾下四偈口业。三众生苦乐利无利下十六偈意业。声有八种者如梵摩喻经说。一最好声其声清雅如迦陵等。二易了声言辞辨了。三调和声其声朗雄。四柔软声。五不误声。六不女声。七尊慧声言无惮怯如尊重人如胜慧人言无所畏。八深远声脐轮发声犹如雷振。初七十偈文有三。初十出身业用。体谓定。次若欲供养一切佛下三十四偈正明身业。次欲安一切下二十六偈明现诸法门化。亦即所作事也。二胜进利他文有三。即三轮也。初二十八明神足化。二若见世间无正见下九偈说法轮。三安隐众生下一百七十八宿住轮化。即忆念化。此约本因说。若望现缘即是记心轮也。忆念文有三。初总。次别。三如是等比下结。别中合有四十四事。各有三。一列名及体。二光有本用。三说本因。文中有十种非法语者依下论用经本十七种语为十非法语。谓侵恼语。粗犷语。苦他语。令他嗔恨语。上四语为一。现前语。不现前语。鄙恶语。不断语。上四语为四。不喜闻语闻不悦语。此二语为二。嗔恼语为一。心火能烧语。心热恼语。不爱语。不乐语。上四语为一。不善自坏身。亦坏他人语。此二语为一。此十非法语生他事惑障其定也。又依燃灯经十种非法语。一妄语。二痛心语。三粗语。四苦恶语。五不喜语。六不乐语。七不爱语。八不入心语。九恼他语。十结怨语也。结文有四。初四举法体。二六辨益。三有七喻。四有三。结劝可知。次第三有八十一。明自他无碍成就功德有三。初神力于此得自在下十七明于器世间自在。二东方世界无有余下十偈明于智正觉自在。三于眼根中入正受下五十四偈明于众生世间自在。众生世间文有五。初有二十四明自身入定。二童子身入正受下十四于他身入定。三一毛孔入下四偈明自他入出自在。四一微尘入下十偈于外四大入定。五是名下结叹无尽。自身文十二入即为二十四耳。此上三世间且约一相说。理有二义。一菩萨自身作三世间。二菩萨于三世间处示现自在。上文即是第二门也。第三有一百五十四明法旨深群情莫晓。引喻类答。上来正答创基建立。善根行德义显于此。而位次言之。盖是外凡始起发心之行。然经文所辨。乃云十地终于入佛境界无上菩提满足佛事。言状矛盾。其故何也。如究其实。当是一乘通宗行要。义兴真本而不舍于世。鉴彻玄源旷周法界。妙绝情卑功显无外。体无不融行无不在。先后莫二旨在一味。故果无异因之果。因无异果之因。而因果之称寄显于缘。其缘乃差殊流同轶亏盈自彼。于我无为。是以据其所学以彰发轸之迹。功成有在。而法通行局。事显常仪。或有鉴真。故须明简。圆宗之致镜曜玄真胜出言表非思量境界。然矣而浅识情滞。旨玄难测。反于视听。封教守诠益增情惑。自非假况以拟导达其心。无由取信。故举近事以镜玄趣耳。文有二。初二总举龙神佛等不思议事。次今说下广示喻说有二十事喻。一德行深广相形喻。二实德离非喻。三持法明了喻。四辨才令喜喻。五善用令喜喻。六缩大增小喻。七定用自在喻。八变化自在喻。九胜德仇怨喻。十利生广大喻。十一安生除怖喻。十二随机应现喻。十三摄行自在喻。十四解脱自在喻。十五知法速疾喻。十六无碍成事喻。十七顺法令喜喻。十八明了增机喻。十九举下成上喻。二十穷源自在喻。如我说诸譬喻者第四劝发修行文有二。初四辨能说难。次七明信者难。次十借喻况难有五事结叹胜妙。而所说既玄。其真趣义兴成感应之圣心故。次第三六偈明于瑞相赞说摩顶等成说善也

大方广佛华严经搜玄分齐通智方轨卷第一(之下)

          乙巳岁分司大藏都监开板大方广佛华严经搜玄分齐通智方轨卷第二(之上)

        终南山至相寺沙门智俨述

    第三会佛升须弥顶品第九

四门同前

一释名者。佛者化主。升者上进。须弥者妙高山。顶者居胜尊上也。问何故此下四会在天说者。答德行位成。除障净胜故在天说耳。此答前十住位问也

二来意。何故来者信故解也。此初辨会来意。又何故会来。既报体成已。次须起化赴机故来也。因此略料简教兴所表。今诸会但不舍离本处。即表起行成报体坚固不移也。而往诸会即表起用随机。此释约修行体。若望生解起信门即显行位增微耳。又解文中约佛起用赴机以解者即善知识力也。若约分位等解者即约自修行解也。可思准之。又此会已下四会并位相增。与前信行少别。于三乘一乘法义亦须交络。思准之。余会并同此意。品来者前说信法已。次辨赴后说所依处耳

三宗者。约会分别有二。一约人。二约法。人有化主及助化。各有体德用。但局此会。二约法者。谓十解法。后当辨耳。约品宗者。若依利他时现处及供养。即显法缘。若约自利时此即机感相应。机缘体用成也

四辨文。此会有六品分三。初二品明方便发起。次二品明正位相。次二品明后成满足行相。初二品分二。初起用随物。二帝释遥见下辨机感相应。前文有二。初辨依正二融。即显前体净。二复显后用净。自在无碍成事之本也。诸会有文。并同此释耳。但进胜异也。问此文何故不在初会后。乃在后会前。答若初会后。即但显说法利益义明。与后化用体义不显。故在后会前辨耳。余会同此。何故不在第一会后。料简为前会兼余义意在彼释。后第六七八会亦显别有余义意耳。体中身口意三也。二尔时世尊下彰用应物。即用净也。余相可知。第二相应文有五序。一住处序以动静无碍无处不至。为此说法德也。二请佛序。三集众序。四放光序。五赞叹序。若通下住品即八序。谓入定加劝及起定也。又约品分文亦好也。初住处序及请序有六。一见佛来用从实起。即发心缘。二即于妙胜殿下明天主严供养故请佛。具显从解成法供养行。即成根也。三世尊即受赴感施化。释音寂然表息乱应真也。五说偈下表从定发慧。六佛升坐下正明化用事成相。严具文分二。初严具即成根也。二请即成欲也。初严中有三。初总。次严坐具。三结。二尔时帝释下明其请佛。即表欲也。偈文有三。一忆本行。二偈赞。三结通十方。六化成中有三。初处坐。二辨用相。三等通余方也

    菩萨云集品第十

四门同上

一释名。菩萨者是人。云者润益故。又龂齶貌也。集者聚集。妙胜等者别处也

二来意者。何故来。辨处已次明集众

三集众叹德顺法为宗

四辨文者。此文有三序。一集众。二放光。三叹佛。今此下三会集众何故不在初品。复何故一一方各有十。又放光下何以不渐集众。答前会位相未成。但显行圆故在初品说。今此行位具成。同彰行位利润益故共在此品也。所以一一方具十者欲显解相分明圆融数等一方即一切方也。所以此放光下不渐集众者。欲显行位圆成无有增减之相故也。于中别有增减。义用上准成即得也。上下应可准思之。上第一会释集众光者亦是准义。初为后则耳。初集众序内有二。初指方辨数。此中一一方者。或通上会。或不通上。信行又不成位相。为此不通。下三会位显。故通义也。二其世下列名耳名有三。初明十方佛土菩萨。三种世间即为二也。二此诸佛神力下明集诸菩萨有三。净行云集依方坐可知。三如此世界下结类十方成法界会。佛同名月者依月起光故。清凉故。解法准之。菩萨同名慧者解之始故。足指放光者表立解位不退故有二可知。三赞叹序文有十菩萨。相生次第叹。解相明白耳可知。一法慧偈有二。初长行生起。二正偈颂下并准之。此文有二。初七牒众明是佛力所成。即结前品中六段义。次三明胜行者得见佛余莫知者。即通赞前难思。下诸人偈并约理成也。二一切慧偈有六。初三明谓见之徒不见真佛。次三显解无生法身常现。次一明取著者失。次一明慧解者益。次一明解佛因缘成即离痴惑。次一推功在本。三胜慧偈有六。初三明妄取者失。次一明有解者德。次一约法辨观益。次三推功在佛。次一能净慧者见法身。次一推功在本。四功德慧偈有五。初四明迷者失。次一示胜方便。次三明得法性益。次一叹佛利生方便。次一推功在本。五精进慧偈有三。初一彰失。次一辨德。次八广辨观式获益相。八文内前四无相生。后四真实性也。六善慧偈有四。初二明有解能度自他。次五明无生故应真性。次一半叹解胜能。次一半推功在本。七智慧偈有三。初一明因教成正解。次六明迷教理者失。次三重成解德。八真实慧偈有五。初二挍量胜劣得失。次二辨所观境。次一举益劝学。次一释知者名。次四示其观仪。九无上慧偈有四。初一释人名。次六叹自利。次二叹利他德。次一推功在本。十坚固慧偈有四。初四叹佛是真归。次二举德劝依。次二引自劝物令入。次二举胜人显德无尽以劝依也

    十住品第十一

分别有五

一释十住名。即辨来意。十者数。住者不退位也。何故来正说故

二明所治。是前百障应位断故。若三乘熟教所断外道我执

三所得光增定及顶善根

四所成即十解成。即是三乘熟教说。即此品宗

五释文。自下第三品分为正宗。此中二品即为二。初通道俗。二梵行品是出家别行法。初品若义分文。此初有三序。光师云有八序为三。初品二合名住处序。次品三合名集众序。此品三合起说序。又依地品此下三会各有六分。初名三昧分。二加分。三起分。四本分。五说分。六利益分。分齐至文应知。又此文有二。初明三昧序。次告众菩萨言下正宗。三昧序加意上已辨。定名无量方便定。方便是智。定成胜智知法故。所以法慧菩萨入定及说者如下论应知。二加序有三。初辨同加。此有三。一明现身及显同名即为二也。二同赞亦有二可知。三释得所以有四可知。二欲令汝广说下明加所为有十一句。一总。九别。后一结成位也。第二九句内。初五自分。次四胜进耳。三善男子下辨加相。谓三业也。加相文有三。初善男子下辨口加。二如来即与下明意加。三各申下身业加。云何意加。与法同缘资故也。意加文有二。初列十智。次何以故下释所以也。问何故与智者为智解法故也。起有四意。一定事讫。二得胜力。三说时至。四定无言说故也。第二正说文有四。初叹种性深胜。并列十名。即本分。二何者下广解住相。三尔时佛神力故下明地动。显实证成。四以偈重颂。初文有二。初总叹种性义。即性习二种性体也。二菩萨十住下列十解相。明佛同说也。即性习二种性相也。此约克性为语。若就分位时即有六种性。一习种性当十解位。二性种性当十行。三道种性当十回向。四圣种性当十地。五等觉性当十地终心。六妙觉性当佛地。复名六坚。亦名坚信。亦名坚法。亦名坚修。亦名坚德。亦名坚顶。亦名坚觉。亦名六忍。信忍法忍修忍正忍无垢忍一切智忍。复名六慧。闻慧思慧修慧无相慧照慧寂照慧。亦名六观。住观行观向观地观无相观一切种智观。此约三乘寄位语耳。此中十解十行中。六决定内但无大善决定。十回向但有观相善大善及不怯弱余三并无。所以有大善及无余三者。为回向是方便事中显成故大善显也。余三无者为义隐故不说。观相等可知。十解行等何故无大善。解行自行义显。故无也。余者思之可知。初体文有二。初总告。二别明六决定也。第二解相文有三。初举数引证立宗。二别列有二可知。三引证结也。十解名者。一发心上期。二治地灭惑生自他利。三修行定成前二耳。四生贵行成生佛家。五方便具足自他行满。六正心住得缘起正解。七不退理量止观双行。八童真无生妙解以立身。如童无染。九法王子善施佛教故。十灌顶位满受职相应故也。此即是下诸位行相也。第二广辨文一一住皆四段。一问列名。二辨解相有三。初总次释三结。三明仰修胜进助行亦三。立释结。下并同此。亦可当位所习。四何以故下释学意。唯初及十有六句。一牒寄问。二辨发心缘有六句。三辨行体此有三句。一体发心有四缘四因四力。四缘者。一见闻佛菩萨神通大事。二闻法。三末世护法。四见苦众生故发心。四因者。一种性因缘。二佛等为善友。三起大悲心。四不畏众难。四力者。自力他力因力方便力。如地持说也。二所起。三不退此有二义。若约一乘通教。入十住位即四退等皆无。二若依三乘。十地已来有念退。地前有行退位退。不进退亦退。十信已前有实退。已后有示现退也。此约位语。四明所得。五明学。六辨前学意。又此下诸文并有三。一问。二答。三辨成行胜能也。此文有三。初责。次辨意。三明所成德也。诸位并同此。亦可通释耳。即自开解者通因果其义有三。一不由他小教等解。二不由他教境成。三不由他性外别集也。后文所为各同异。思之可知耳。二治地内。初十同二地十种集。后十同集果中令诸众生舍倒住正见等。三修行内。前十同三地护烦恼行。后十同护小乘。四生贵内。初十相同四地十种法智。后十同修道品等。五具足方便内。初十同五地大慈等观。后十同大悲观深重苦。六正心内。初十同六地十平等中第十句。后十同前九平等也。七不退内。初十同七地十种乐无作对治。后十同彼障对治亦同双行分。退有四种。一位。二行。三念。四应得不得。此中无四退等。八童真内。初十同八地胜行分何等身乃至供养佛等。后十同彼三世间自在。九法王子。初十同九地智成就入行等。后十同彼口业法师成就等文。十灌顶有五。初列名。二广释。三显胜。四进学。五除伏疑。初十同十地三昧分。次十同彼受位分。三十句同彼大尽分即入住出也。上来依一乘生信为言。若约三乘寄位别观时。如经初住中厚。集一切善根成四弘誓。未度苦令度。未解集令解。未安道令安。未得灭令得灭。第二住中修习无量善行。谓四念观身受心法此四皆空。第三住中善集佛道法。谓观十一切入四大四色空处识处皆如实相故。第四住中。一切佛前受法而行八胜处观。内实五阴中。广相略相二胜处。外假众生法中。广相略相二胜处。四大法广略。四胜处。如是观一切法空无相故。第五住中修诸清白法。谓八大人觉。少欲。知足。寂静。精进。正念。正定。正慧。不诤论。顺一切法故。第六住中为诸佛所护。八解脱观闻慧得。内假外假二相不可得故。一解脱思慧。内五法外一切法不可得故。二解脱修慧。六观具足。色界五阴空。三解脱四空五阴及灭定观皆不可得故。五解脱如相故。第七住中广正法。谓六和敬。三业。同戒。同见。同行。入此法和必竟空故。住不退位。第八住中信喜大法。所谓三处一切因故无作。一切果故无相。因空果空。空复空故空空。如是法如虚空故。第九住中住四等法。谓化众生教四谛法。三界非乐为苦。无明习因受生无穷。三空道品。无为寂灭。四谛无二。一合相故。即是众生缘法缘无缘也。第十住中好求佛功德。谓六念佛法僧戒舍天得一切佛功德念念入。不约三昧。常前修故。此约三乘寄位观也。第三显实证成文有二。初动地显实。二复云佛神力下菩萨证成。前文有三。一动地。二雨华。三等余十方世界等。第二文有二。初菩萨证成。二结会平等广周法界。前文有四句可知。二结会中有二可知。第四重诵文有二百三偈有二。初一百八十五颂十解相。二如是十住诸菩萨下有十八。总颂十住结叹劝修。初正颂文有十。初九十颂初住。次第二治地下颂第二住。余并可知。初文有三。初对三十五事广成发心体。二菩萨如是发心已下辨初住用。三是说菩萨下结也。治地内初四颂解。后八颂所学行。修行前四颂解。后六所学行。生贵前六解。后六行。方便具足前六解。后三行。正心前八解。后二行。不退前四解。后四行。童真前六解。后四行。法王子前四解。后二行。灌顶前十德体。次二诵住位相。下四颂后方便行。第二结叹文有二。初十四总颂十住难知。次四结说无尽也

    梵行品第十二

四门同上

一释名者。行中上净故名梵行也。要论梵有二。谓报及方便。始修为净。成就为梵。若据报者。欲天为净。色天为梵。若约自利利他。自利为净。利他为梵。故涅槃经云。三学为胜圣行。四无量为梵也

二明来意。何以来。其进道多方从相分二。谓一缁。一素。素从利他无方利物。故不住分齐行。缁从自利故。不可轻坏出世容仪故。唯成内观也。故地品辨出家人唯成三昧。问前诸会何不亦说此品。答有二意。一此中行劣。二以始通终故也。何不十信明此品。答此正宗为彰以法成人。不以人成法。何名人成法者。法无高下。随人器物。显法精粗故。十信法解未明。不可以法成人。十信解劣故但随信根定法。若语形局即诸见更增不成正信也。问梵行发心明法何故不通下三会。答理有。以此类彼耳

三辨宗者。无念理观当是自体果涅槃圆寂行也。即为此品宗。又问此中始明十住初发心因。何故乃言是果行也。答此明自体真发心故。契于后际体包无外也。又是自体发中果。无戏论行耳。故品下结云。初发心时便成正觉。具足慧身不由他悟

四释文者此文有二。初问后答。所以正念天子问者表定显理故。又正念不妄净报堪受也。问文有四。初总问。次牒事。三自分成出家行。四速成下胜进明他分。又佛境界。又问上净行品何故在家出家合明。此即不尔者。上为信根弱故。始约缘修相易处双明。此中已去会法明出家相者。欲明自体缘起性离非断故离也。此如维摩经说

答文有三。一答前自分。二又复修习增上十法下答前他分问。三菩萨如是观者下结梵行成益耳。初文有三。初辨寻思。二正念下辨正观。三是名下结。初文有二。初辨寻思。二又知过去下明如实。初复分三。初举十法明所观。此有二。初总。次别。次应如是下正明观。三当如是下结。何者梵行体。理实自体发中正智是也。何故法慧菩萨说者。圆通性德非顺法之慧不明也。十中前六是行及行缘。四所信境故偏说也。余相可知。如实文有二。初辨观行。二此梵行法下反验。第二菩萨正念无障碍者辨正观。文有三。初辨无相。二如是观者下辨依他无生。三一切佛下辨真实无性法。喻可知。第二胜进文有三。一自利有四句。谓立问答结可知。二如是观察下明利他有句。三如幻下喻说。前二无体如幻。现实如梦。起用如电。缘聚如响。成事如化也。第三结利自他文。亦可答上速成问也有二。初牒次结益。益文有二。初结前少行多能有二可知。二初发心时下成疾所以有二可知。言即菩提者有二。一约位即十解菩提。二约解觉正理也。余信行证等准以知之。又即普贤证得自体圆明究竟因果。此解约一乘耳

    发心功德品第十三

此下辨此住胜进德。四门同上

一释名。发心牒行体。功德行所成功德也。就二义得名

二来意。所以来。前行已成。今辨叹德相故

三功德分量为此品宗

四辨文。此文有四。初问。次答。三证成。四偈颂。所以帝问者在天故。亦即功德自在也。又净解自在方堪受德耳。所以法慧菩萨说者称法之慧方穷功德。二答文有二。初略。此中有三。初总。次别。三许分齐。教量难知。义深难信。思惟难解。应教难说。欲证难通。数极故难分别也。次假使下广答。广文有二。初辨十二喻。次发是心已下合喻。初文有四。初喻。次征。三答。四校量。余文不定。十二喻中有五。初五戒二十善等。此二取所益为况。第三身通即所利生处。四知成坏知法时也。下根悕望等七喻明所利根器厚薄。下一明诸行德广入胜位也。第二合文长分为七。初总辨德能。二何以故下责初非劣成等胜义。三答所由。四何故下重责始同终。五此初发心下以终摄始。六悉与三世诸如来等下广辨。七彼初发心下结因胜缘由耳。又得证者行证也。身证者位证也。又得证智相应。身证者身相应也。此中并是普贤实德也。又问何故诸世界等善顺菩萨心转者何也。答为菩萨得诸因缘和合自在心是诸法因缘故随转也。此可思准。又上文十欲等者。随有一善欲即具上十德也。余可准之。又所以身证通三世者。为下文菩萨常不离三世佛前故也。第三动地成证等文有五。初动地雨华等。二诸佛同证有二可知。三利生获益有三耳。四别佛同说证成前义。有二可知。五辨成所由有十耳。问何故佛证。答为胜进举果摄成。又恐不信。又表因与果同一性故。余事可知。第四重颂有二。初长行生起。次偈颂。初文有八可知。偈文有二百四十一半分四。初广叹发心现成功德。二十方世界中下重举前十二喻述德难思。三三世人中尊下辨能成当果。四菩萨初发心下结。此中不得细科。若细即失旨也。又住位已去所有解行理事教义等法门并皆常行无间应知。又从信位成已去普贤行。乃八相与佛已来并无差别。此可思之。余三乘行义等并别不疑也

    明法品第十四

四门同上

一辨名。言明法者有二。一约教。阿含法照理现故名明。法即义也。二约行。由行增胜后位相现故。即用前位法义解行等为明。用后位教义等为法也

二来意。所以兴者。用前行德更修。与后地为方便故也

三即行教法义等为此品宗

四辨文者。所以精进问者。若不精进行不能受此胜进法也。所以法慧菩萨答者称法之慧能申此教故。文有三。初问。次答。三末后少长行略结流通也。问文有二。初问。次重颂。初文有三。初先牒前住位中行德为生后次第。次彼菩萨云何修习下正问胜进中先际行德。初牒文有六句可知。次问胜进先际文有十一句分四。初六自利。次随其下三利他行。次兴隆下一住持建立。次一成事不虚。第三胜进中后际利他分法有二。初总次别。别文有三。初明成熟德。此文有二。初自利成熟行德。二具足佛刹下利他成熟众生行法。初自利分有四句。一离障。二成体。三成德。四成用也。二利他中有三。谓体德用。体有十二事。准此可解耳。第二天王下明眷属行法有四可知。三得善根力下辨自他德满成就不虚义有四句也。第二重诵文有二。初生起。次偈颂。偈有二十二偈。初四颂前牒前初发心菩萨前住位中所进德文。次云何下七颂第二彼菩萨下正问胜进中先际正行。次人雄下十一颂善哉下后际果德利他文。就第二云何下先际自分中。初有三偈颂上自利六句。次二颂利他行中三句。次一颂建立文。次一颂果行成就不虚。第二答中有二。先长行。后偈颂。初文有三。初叹所问今时多益。有三可知。二敕听许说。三佛子此菩萨下正答。答文有二。初答胜进中先际自分正行。二菩萨摩诃萨若得成就下答上胜进中后际果行。初文有一百七十句。亦可百八十句耳有四。初一百一十答上十一句中初六句自利行。次四十答利他行三句。次十答住持建立。次十答成事不虚。答自利文中。初一百答前五行。后十答第六行。答前五文中。一一皆二十句答之。二十内前十自行相应法。次十胜进修行法。云具足净慧等者。牒前自利行生起后利他。令势相连也。诸十文各有四。初生起。次问。三答。四结。亦有不定者。可准思之。利他前问有三。此答中有四十。亦可五十句。此初二十答三中初句。次不舍诸波罗蜜十句答前第二句。次佛子下十答前第三句。前二十句亦可三十句也。初五知器所宜。次十应诸病授药。次十五应器与法。言能如是行者则兴隆三宝者有十答第十句内住持建立。此中有二。初总次别。此别文中分四。前三别。第四总。前三文初依教道。次依证道。后依不住道。六和敬者。身口意业及见戒施同也。菩萨如是不断三宝下有十句。答上自分行第十一句行成事不虚有三。初十辨行成事不虚。次第答前五句。二有十以德自严。即答前不虚句。三有十以自严故能摄化不虚。亦同答一句。于中法喻合三文。次若得成就下第二答后际果德行中有三。初菩萨摩诃萨下答前灭除痴闇果熟德行法。此文有二。初辨自成熟行。二次第方便下明利生行耳。二于大众中下辨眷属行。三成就如是胜妙法下辨行成不虚。唯除如来者以下过上也。第三行不虚文有三。初立。次责。三答。答中有十一句。前六因。后果行。第二重颂有二。初长行生起。二正颂偈。胜进中有二十偈有二。初十三颂先际缘起。次七颂上答中胜分果德自分行法。前中初六半颂自利行。次三半颂利他。次一颂住持建立。下二颂成事不虚。后七中初一半自利果及利他果。次三半颂眷属行。下二颂行成不虚也

    第四会佛升夜摩天自在品第十五

四门同上

一释名。佛者化主升者上进夜摩者时天亦云戏乐。天者明故。自在者游空无碍也。约行准之可知。即答上十行问

二来意者。所以来依解起行也有二意。一会来意。二品来意。并如第三会说准之

三宗者有二。约人约法同上。准思之可知也。此品宗为明处及兴供养

四辨文者。此文四品分三。初二辨序。次一明行体。次一明胜进方便也。此初序文一同前会。但增胜转上寄法不同耳。尔时如来威神力故。十方一切诸佛世界诸四天下一一阎浮提。乃至无不显现等者。若约三乘教辨时。阎浮苦空秽恶。厌苦情敏。忻上志猛。故在阎浮成道佛身非出世。若约一乘三乘共教时。欲显阎浮是实即空。是似成假为事缠绵圣恒悲愍。佛以本愿力悲愍众生。应于世处成道佛身。现佛故身即出世也。若约一乘时。此阎浮处即一心法界境界。若佛若处俱显处染无秽之最佛故。显在此方成道也。但诸应化事义并皆准此别之。第二供养成机中有四。初文有二。初明兴供养即根也。二合掌下明请佛即欲也。初供养行中有二。初严。次结。初有二十三事。初辨事严。次善根下行严。三如来下佛德加严供养。显因同果。余可知也。问何故十解赞偈别列佛。此即不者何也。答解相别知。行即通成故也

    菩萨说偈品第十六

四门同上

初释名。自体妙因。行集文班。教则显彰。故言菩萨说偈也。余义可知

来意及宗并同上准也。又问若义次第相生。意同但所显别者。何故名目不与上同。答此但欲交络显义意故尔也。但增胜及托法为异者可知

四释文者。此内第一集众序中世界同慧者。用前解慧即为行所轨故。佛同眼者行心见法明白故。菩萨同名林者但以此行益物炽燃俱兴显备集之相故也。第二段中足指放光与前会何别。答况足指有行住二力。前彰住。此显行。故况别也。第三说偈序内十人即各以自已得缘起真如。法因叹佛。即归行相也。初功德林偈有二。初长行生起。第二说偈下并准之。此文叹法身自在功德有十一偈。初六牒前升天云集自在之相。次五法身自在甚深。二慧林偈文有二。初二辨佛具德难遇。次八释前具德难遇。八中分三。初二明上具德门。二如来无与等下四释上难遇。三不可思议劫下二校量劝修。三胜林偈有四。初二喻说微深。次一法合。次二辨深所以。次五叹其胜用。四无畏林内有三。初二举体胜。次五举用胜。次三劝学。初体用二文各有二。初举法深。二叹胜。五惭愧林偈有五。初一总叹佛法胜益。次一叹胜用相。次六反成胜用所以。此中初一总。次五别。次一重顺成人德用。五结人难见也。反成文内。初一愚智性别喻。次一同成虚妄喻。三二性乖违喻。四愚智缘隔喻。五用无相感喻也。六精进林有三。一总叹人胜。次八广举法成人。次一明人法深故难见。八中一法体无异喻。二法体空无喻。三法体无实喻。四法体离相喻。五法体成真喻。六一成多用喻。七起用依缘喻。八体坚难坏喻。准初说之。七力成就林有三。初四依他缘起观。次五分别无相。次一约心叹用也。初文分二。初二法。次二观。八坚固林有二。初七辨佛性相二身难议。次三叹胜。前有二。初二喻辨性身。次有五。喻合并叹应化也。九如来林偈有二。初九法喻双显。次一劝学。前文有二。初五喻展转答五玄疑。一疑法是实。初行答之。二见生异解疑法离因。三疑分别实法离心有之四疑既是心作何为非有。五谓心作法有知。此可思准。次四法合。造如来者谓无作佛也。所以者乘前来意不得为有作佛故。十智林有二。前八叹法身甚深。次二结叹劝学。初文有二。初三叹体。次五叹用也

    功德华聚菩萨十行品第十七

分别有五。一释十行名及来意。二所治一乘如前解。三乘终教者声闻畏苦障。三所得通行定及忍善根。四所成即十行位。即此品宗。五释文

一释名者。功德者行体。华聚者喻名也。叹行胜妙能与果为依众行集故也。众德聚集能严无上菩提果。是因故安菩萨也。十行者数行之本相故。文云譬如数法十增一至无量皆悉是本数。智慧故差别。从五义得名耳。前众既集。次须彰说故次来也

四此品以所修行体及位为宗

五辨文者。此文有七分。初三昧分。二加分。三起分。四本分。五说分。六利益分。七偈诵。善伏定者行力也。加劝序者。明此行法其旨甚深分在非已。自非诸佛加持道力说之莫由故次明也。此内有二。初总辨加所为。二佛子当承佛下明加相差别。初文有三。初明佛加赞。二十方下明加所以。三欲令汝广下辨加所为。初文有三。同上会。所以中有四句可知。所为中有十句。初一欲令等者总也。次八句广。次一句结差别。二加相差别三业可知。问何故意加与法。答法是正行之本也。故与法也。又问前会何以不与法乃与智者。答法从智生故亲能成行。智境即通。故前会但与智也。此约地前。非证位故作此解耳。二意加中有三可知。四告诸菩萨言下即本分。文有二。初叹十行宗本广大即体也。二列十名即相也。六决定同前解。但行异耳。问何故前观相约性。今此约行业者。答前解相非胜故约性。此行相即胜。故约相也。此可思准。所以并无常果因者为显在有流因位耳。第二就本分相中有五。初问。次略答。三重问。四答。五结也。第四答中。一释欢喜者施成自他喜。二饶益者持戒摄益故。三无恚恨者忍息自他恨。四无尽者精进获无穷德。五离痴乱者得定故也。六善现者智现缘起法。七无著即方便度故。八尊重即成愿。九善法者力智善说。十真实者得智顺理善说。五说分中有十可知。佛子何等者此初文有三。初牒问。次释。三结释。文有三。初辨布施行相有二。初释次结。行相有十七句可知。二菩萨修欢喜行时下明行熟广摄令他喜也。此文有四。一修施仪。二离过。三设方便。四明所为。此文三句。谓自因果及为生。第三句有二可知。三离诸我相下明离三轮成檀度也。此有二句。自利利他也。二饶益相文有三。初问。次答。三结。第二文有三。初明性成。二戒体有八句。二菩萨如是持戒时下对缘辨持相。此有四。初持戒仪。二辨方便。三离过。此有五句。初句分二可知。四明所成。此有二句可知。三何以故是我业下举行离相成戒度也。此中有二。初问次答。答文有三。初明观有五句。二未度者下明意。三我当下明所起。无恚文有三。初问。次答。三结。答文有二。初辨忍行体有八句。二菩萨成就如是净慧忍下对缘辨忍相。相文有三。一他不饶益忍。此能所分二。能中口身分二也。二菩萨作是思惟下安忍有三。谓立责答可知。三复更思惟下辨法忍。此中初法。次是故下所为有三句。三佛所行法下辨疑也。无尽相文有三。谓问答结。答文有三。初辨精进体。即勤勇进有十一句。二菩萨复作是念下加行进有二。初明所离。二辨所趣。三菩萨成就如是下辨难坏无足等也。此有二。初有二问答辨难坏。二释分齐可知。离痴相文有三。初问。次答。三结。答文有三。初辨入理安乐住定。二是菩萨成就寂静引通定。三菩萨闻此能坏下随利他定。此初内有三。初辨定体无失。二菩萨成就如是等下辨定业用。此中有四。初总辨。二何以故下释所以。三此菩萨下别辨有二。初辨。次对因明也。四如是等下以广显略也。三菩萨于三昧中下辨观行成前自在耳。此中相性成治分三。余文可知也。善现文有三。初问。次答。三结。答文有三。初辨加行般若。二无所依无所住下正证智。三分别一切世间法下后智般若。初文有二。初明智体。二无所有下释成前义。正证文有十八句有四。初七辨智与理相应。二离业报下六辨正证离诸相。三无所依住下二句辨所住分量。四入离虚妄下三句明观成分入无性问也。后智文有三。初辨如量智中如理即显所知法。二安住三世平等下辨如量智中如量即对所化生。三是菩萨住此行时下德用自在。余文思之可知。七无著文有三。初问。次答。三结。答文有三。初辨自利方便。二初得受记下辨利他方便。三菩萨如是观察下二自他利善巧满足有二。初辨二行。二所以者何下辨所以可知也。自分文有二。初自分位中修。二不舍菩萨心下辨胜分位修。有二可知。自分位有三初于净法中修无著行。有二可知。二见不净刹下于染行中见不净修。三何以故下辨前无著所以有三。初问答总辨。二广辨。三对生明离过。二利他文分三。初辨大悲方便观。观二不着身等下正明不着行。此中有十句。三何以故下明不着所以。初大悲观有三。初辨大悲深重。二尔时菩萨见彼生下明增上。三尔时菩萨作如是念下明为首耳。尊重文有三。初问。次答。三结。答文有六。初辨所遵法。二此菩萨行时下辨所趣。此有二。初趣。二益。益有三益。一成愿。二成生。三显理理中有二。初法喻合即立宗。二有二责可知。三菩萨如是下辨所成用有法喻合三文。初法中初行行离非。二得法为人。三成功入法界。四而菩萨摩诃萨下明行自在。五如是菩萨成就下辨用无二。此文有四义。第四义答中法喻合三。文可知。六此菩萨下明行成就有二。初自利。二利他。他文有二。初教。二申己意以去疑。有二。初申意。二有二责可知也。九善法文有四。初问。次答。三结。四利益。答文有三。初举善法以为佛种。二清净陀罗尼下释成行体。三菩萨摩诃萨安住善法行下约修辨成。第二释成行体文有二。初辨行体有二可知。二尔时菩萨下明行作用。作用有二可知。三约修辨成文有二。初总。次别。别文有三。初总。次佛子下别有二可知。三成就如是十种身下结成行用。十真实文有二。初问次答。答文有七。一言行相应故真实。二此菩萨下行相应此即释名。三菩萨成就众生下辨行体。此有二。初立。次是故下结胜。前文有二。各有立责答。四不舍下辨行用。谓身口意即为三也。五菩萨摩诃萨住大悲下辨即位以因成果。六是名下结。七此菩萨安住下成利益也。上来约一乘信行相。若约三乘寄位别观时如经。初行之中为自得一切种智故起四精进。勤修二善。勤断二恶。为求佛果故。第二行中为得自身有大力故为四如意足。念守境。精进驰求。定舍摄。慧照境。得法无生自在故。第三行中愿无畏具足故。谓五根信进念定慧皆无相故。第四行中求具足三宝故。谓五分法身戒除形非。定无心乱。慧悟相虚。解脱无累。知见一切众生无缚知见解脱故。诸法虚空无二故。第五行中为化一切众生故。谓八正道从师生慧名正知见。得法生思名正思惟。出家受道得三道分名正语正业正命。入法性空名正定正觉。于无生无二观一合相故。第六行中大悲故起七观。择法念法精进法观法喜法定法慧法入一相故。第七行中为得四无碍故。谓五善根正观暖观顶观忍观三界空第一观能生十地无相大明慧。圣人胎未变第一空平等故。第八行中一切佛国中行行故。谓四化法。法辨义辨语辨乐说辨。此四名慧。性照一切法无生。第一义谛中行故。第九行中于一念中照一切法。谓三世十二因缘皆假合会以成性。实不可得故。第十行中为自在转大法轮故。谓菩萨三宝。智觉中道一切法无生佛宝。则用为法宝。常行六道与物相应名僧宝。转一切众生流入佛海故。此约三乘寄位语也。六尔时佛神力故者证成所说。此文有四。初动地雨华等。二如是四天下结会平等。三尔时各过下明十方菩萨证成。以此十方菩萨证成文即知。诸会后但此处同名佛菩萨并为证义故来。会初十方同名集者。但是影响标位分齐未是证法。余可准之。四结通十方。七重诵文有二。初长行辨说偈意。问此中佛种性菩萨种性何别。答因位菩萨由佛而成即是佛性。由菩萨自成即菩萨性也。此等可思准耳。二说偈有一百一十二偈。此中有三。初七字偈总叹。二别叹。三后有四行总结大情。思之。又此众德上十行一一位中皆具有也

大方广佛华严经搜玄分齐通智方轨卷第二(之上)大方广佛华严经搜玄分齐通智方轨卷第二(之下)

        终南山至相寺沙门智俨述

    菩萨十无尽藏品第十八

四门同上

菩萨者人。十者本数。无尽分齐也。藏者蕴积也。良以体非数分。行无穷竭。而生灭所不易故云无尽。一摄一切统含无外。故曰藏也。余可准知

二来意者。所以来。正位自分已成。次明进胜入后位故来也。所以前问在回向后今答在前者欲显行通故也。亦可回向属助方便。藏从行本故在初前耳

三品以能所甚深功德蕴积诸义为宗

四辨文者。此文有三。初举数引证。略叹列名。二何等为菩萨下辨相。三此藏有十下结叹也。初文有二可知。十名者一信即十地第一。及摄论中书持。二戒即地中慈悲。及论中第六教他得。三惭。四愧即地中行。及论中第九独处空闲等。五闻即地中知诸经论。及论中第四恭敬听受。六施即地名舍。及论中名施他。七慧即地第十如法修。即论中第十修相入意。八正念即地中不疲惓。及论中自读。九持即地中坚固力。即论中第七如所说一心习也。十辩即地中六善解世法即四辨也。即论第八为他如理广释。地论及摄论皆有供养。此中何故无者。此中分惭愧为二故也。亦可此藏与彼一向义别也

二广辨文有二。一释相。二是为下结叹行用能成大果。初信藏文有四。初列名。二辨相。三结。四重叹行用。二辨相有三。初自性住佛性。二佛如是知下约至得果性。三此菩萨成就如是下约引出性。初自性文有三。初入理。次辨信坚固。三何以故下决疑也。第二至得果文初辨信境。次菩萨成就下明信解成相。第三引出文有三。初牒前。次不退下即明信境界分齐。次护持下辨信行成。戒藏有三。初列名。次别释。三是为下结。已下诸文三段准此可知。二别释文有三。初牒十名。次何等下辨相。三此菩萨持如是等下大悲利物用。就不诤戒中不非先制。不更造立者随顺实际体非集起。心常随顺向涅槃者一切诸事即涅槃相不复更灭也。惭文有三同前。第二辨相内有四。初知已过。二一切下识生有罪。三自惟下上圣知见。四是故下离过显惭心。愧文有三同前。第二辨相内有四。初知已过。二复作下知生有罪。三上圣见知。四我当下离过显愧耳。多闻第二辨相内。初列所闻十种事。二辨十相。三菩萨作如是念下利他。十二因缘是无为者。婆沙一师云。有为不自立因无为故也。此中文有六无为。又解一空约事相辨。二涅槃约位论。三数灭约性散。四非数灭就事散。五缘生约理从事。六法界理不对事耳。对情即有为所以。及余意思之可解也。此等义并是自体缘起。参而不杂。不可以事相论也。是以大乘教相。若论方便解入时。一切教相要况诠中取也。若论正解时。要是秘密教诠。方得显大乘义相也。甚须得意。勿惑其声。无记有六十也。施第二辨相。夫言施者以舍济资益为义。故文言乃至自受资用无非是施。若就事相中明时。如文所列。若据诠表以明。但使解远穷宗。莫问玄想之以正智。一开情已乃至三业起动进参随缘所作。无不随顺如实与无尽藏相应。故能建立无上菩提根本种子。文有二。初列名。后广辨。前施法中有三种施法准可知。余文相显可知。慧第二辨相内有五。初七句所知境。前四各有二义。一色苦是报色。二色集是业色。三色灭是分别性色。四色道是道共善色。第二色苦者色无常。二色集生后。三色灭即如。四色道谓成道具也。余准之。声闻菩萨等者初知人。次知所轨法。三知道因。杂烦恼习故得集名。四知灭果也。体相如下说。次云何知下辨加行观诸法。即自利有问答二文。答中有六句可知。三广为说下利他有五句。初总。二问答明义分齐。三问答显说仪。四责。五答所由有四句耳。四菩萨成就下辨利自他行成相。有二可知。五此智慧藏有十种下辨慧摄无尽。有四可知。念藏第二辨相文有三。初辨所念净法。云念佛者随顺实觉也。云授记者实觉妙轨显此心怀也。云念持修多罗者。圆觉等满相彰于外。妙轨备时以为世则故也。次菩萨作如是念下辨十念体。三此菩萨住是下明念坚强也。言妙者妙过余人。净念者所记分明。不浊者不杂闇障。遍净念者于法悉明。离尘念者于所念事不生贪染。离种种尘念者不生余结。离垢念者不计我能。光曜念者广照无极。言乐念乐修不息。无障碍者发意即知。不得思量等也。持文有四。初问。二辨相。三结。四叹德耳。辨相文有三。初辨持人。次佛明所闻缘处。三闻持一品下辨所闻法。辩释相有四。初牒。次辨。三结。四叹德。第二广辨文有五。初明后智辨体。二广为下明辩功能。三何故下释成。四成就此藏故下广明辨德所成之事。五此菩萨成就百万下成辩无尽之用事也。此文有二。初释。次问答去疑。云佛子是为下第二结德用能成大果无尽。次此藏有十种下第三结叹辩藏深奥生德无尽。有四可知也

    第五会佛升兜率天宫一切宝殿品第十九

此即答上回向门。四门同上

一释名者。知足天约行准之。又前第三会但说其殿。第四会但论庄严。第五会云一切宝庄严。第六会摩尼宝等者欲显慈悲德相随物转增故也

二来意者。所以来者。若不回向进行莫由故也。一会来意。二品来意。同前准之可知

第三会宗者分别有二。约人法。同有体相用。准上可知。又因此会宗体更举上下诸会别。宗有二义。一举普贤性起实德随差别缘以起信心故说。即初会明世界海。第二会十信。第三会十解。第四会十行。第五会方便回向。第六会明修成本有无漏因果二行法等。第七会依法成因果行德。第八会依人成位差别德也。此并是一乘三乘共学法。第二摄差别缘以从本实。即初会观圆明五海十智以起说。第二会位信位成就本实因果分量德。第三会解位显证性德普贤因果第四会行位显证本性普贤因果。第五会方便回向位显证法界如相普贤因果。第六会证位显证性普贤因果。第七会依法以显通教普贤因果行德分齐。第八会依人显证普贤因果缘起理事德。位分量差别义也

四释文者。此文三品分二。初二前方便序。后一正宗。此初品有二。初体用。二融体。融内有三。谓身口意又因果相应为后方便也。上皆同此耳。第二时彼天王下赴缘摄化。此文有六。一时彼天王下从体起用为摄化缘。二即于下辨王修供养具即成就根。三尔时世尊。以佛庄严下明佛受请升座明机感相。四尔时佛神力为天王故下明胜力加被息乱住静。五尔时天王下明从静定发智偈叹也。六尔时世尊升一切宝殿下辨佛法身平等摄益成事不虚。第二文有二。初成根。二尔时天王为如来敷坐竟下天王出迎世尊辨敬仪也。即根熟成欲。初严供具。文有三。初总严立宗。二所谓下别广辨修入方仪。三如是四天下结叹同等显机应法。初文有二。初总明严座。二过去修习下辨因缘。因缘有十三。初一总。余别。次第除疑可知也。就第二所谓下广说在殿修供养行成方仪中。大文有三。初辨器世间庄严自在行。二百万亿诸天神王下明众生世间庄严自在行。此能供养人。第三百万亿诸大菩萨下智正觉庄严自在行。此分证理故。有异解云。此中有五十八众可知。初器文有二。初外尘庄严具。二百万亿神力自在下明内法庄严。智正觉中初十三辨人。次二十句行德。诸大菩萨者入道场会人。华手等信解位也。第二迎佛文有三。初出迎辨敬仪有二。谓初结前。二生后也。二设供养。三正申请。二设供文分三。初明自分行供养有二。初外。二内可知。二佛神力故下明胜进分行供养。三尔时一切诸天众下辨二行入佛界也。二胜分德中有三。初总。二别庄严虚空。三出华供养如来也。三尔时一切诸天众下明入佛界中有三。初辨利他。二时诸天见如来身一一毛孔下自利德。三尔时如来下辨自他平等圆极自在。就前段中初知利他德。二如是正念下十句结观解益。初知中有二。初人雄等报身德。二顺众生根为现佛身下化身德。报身中初身业德。次住一切智下辨口业德。三佛智慧月下明意业。二化佛中。初身业。二常以法施下明口业。三皆由从心起下辨意业。此等上远佛境。即是回向因人用事。可准之。二自利德中有六句。初辨放光相。二自然下辨光说偈。三显现阿僧祇下明庄严相。四显现不可思下出化身说法。五又佛身中下出宝光明显其因行。六又睹自在神力下明说法教化。三自他平等圆极文有四。初牒前慈悲德。二欲令无量下随机摄益。三成就如来下入佛界德成。四如来显现下结叹难尽。第三赴缘摄化文有三。初正赴。二等余方。三辨益可知。第五智文有三。初长行忆念。即是智体。二说偈明智相。何意叹一佛德者。为彰回向多方便归一慈悲善巧也。三等通余方。第六摄化成事文有四。初辨赴机。二正摄化。三成益文有二。初二句顺理。次顺事。所以但辨具德不广殿如来处者为显方便别庄严也。四等通十方也

    兜率天宫菩萨云集赞佛品第二十

四门同上

一释名者有四义。一处。二人。三身仪。四口业。或六句可知

二来意同前。但所为别耳

三宗亦同前准之。但回入此品叹方便佛行为异耳

四释文者。此品三序。初文集众序内。先举佛神力显分齐。次辨所集众。后如此下结所集众。第二内三世间可知。众生世间中有五句。初列名。次依本修行。三俱来。四依方而坐。五叹德。叹德有三。初明自利行。二一切众生观无厌足下利他行。三此诸菩萨下辨自他德用自在。第二放光序中有三。初辨光出处。二明所照处。三彼诸菩萨下光所摄益即叹德也。两膝放胜光者法身行中入佛境界增长胜妙相也。膝者表进方便相也。叹德中有三。初总。次别。三结。别中有三。初自利。二教化成就下一句利他。三胜进可知耳。赞佛序中。金刚者因行坚也。幢者行成高出也。亦有摄伏义耳。又十菩萨中。初名金刚幢者明自体真实能消殄相累。超世之道标别胜负故名金刚幢也。余相可知。此中诸偈并约回向方便显其佛德。即以此教为诠善巧相也。余准思之。诸偈文若有二。初长行生起。第二正说偈。初偈有三。初五自利德。次三利他。次二劝修也。坚固偈有三。初三叹佛自利坚固。次四叹利他坚固。次三劝修也。勇猛偈有三。初二辨法界海深。次五辨利用广大。次三结体用圆极也。夜光偈有二。初四叹法身自在。次六叹化用自在。智偈有二。初一叹即位德。次九辨所见胜。所见文有二。初一总。次八别。别文有三。初二叹佛德。次四明佛离数相。次二辨离世相耳。宝偈有三。初一化身。次二法身。次七报身。又问何故科此经文。多依三乘者何也。答所为人三乘者多。故尔也。一乘义文准之可知。精进偈有二。初六通三身自在。次四约四喻辨成。离垢偈有三。初七叹智身。次二叹法身。次一总释。真实偈有五。初二叹化身自在。次二法性身自在。次四重成前化。次一辨趣方仪。次一结成身离相。法偈有四。初二辨明策修者意。次三总举损益释成。次四广辨损益相以叹德。次一显德相也。又亦可此十菩萨德叹不须别科。一一句义即一方便法也。此约一乘意取文也

    金刚幢菩萨回向品第二十一

分别五门。一释十回向名及来意。二辨所治。一乘如前准三乘除独觉舍大悲障。三所得无间定及世间第一善根。四所成十回向行位即宗体也。五释文

一释名者。回向者回前行向菩提。亦可通众生及法性。金刚等是人。回向等是法。就二义得名也。来意同前耳。但法体异前耳。今此论所治及成得等并约三乘说之。若约一乘别教辨者。即或治或不治等可准思摄

四宗者总相可知。广在下文

五释文者。此文有七分。初入定三昧分。二加分。三出定分。四本分。五说分。六利益分。七偈诵

初云入定者显法体非思境也。明智定者显行无惑照明故也。亦可方便净智依止能成净智。加序有三。初总明赞加因缘相。此文有三。初总诸佛现身及同名证法有二可知。二时彼下正赞述。三善男子下得入现定。所以加入定有五因缘。一诸佛力加。二卢舍耶本愿力。三卢舍那今神力。四金刚幢自智净力。五余菩萨善根力也。二欲令下辨加所为中有二十二句。初十二自分德。次十胜进。今此二十二句内所有诸文。及上下意加内所有文相。不可一一具解。但准下地品初加分内论主所判。约分此文意即可知。仍此中文相或通果及因。或初总后别。或自他利异。或同异成坏。如是一切及上会诸文。并准地论初六相取之无不明了。余相可知。三善男子汝当下辨三业加相差别。就中初口内有十句可知。意加亦十句。初一总。次别。问何故此意加与杂法者。为方便事不定心境及理事非一法故也。准之可知。本分正说文有二。初总辨体。二列名辨相。初文有二。初总叹。二辨方便体。即六决定于中但有观相大善及不怯弱。所由上已辨也。二相文有五。一问。二举数及引证。三重问。四列名。五结及证成。不思议大愿者是地上愿因。亦即十回向愿也。四列十名者。一救护一切众生。离众生相回向化事离二我也。回向有三。一回向众生与物同成故。二回向菩提舍诸世有故。三回向实际用归极体故。此三相成。所以知有此三。下弥勒令善财见菩萨修三种回向也。般若经中亦说此也。下并通此意。二不坏者自行坚固也。三等一切佛者自他等入佛境。亦可量等。四至一切处者分得佛力故。五无尽功德藏者修用出生不穷尽故。六随顺平等善根者亦名坚固德用无尽获得。三坚固随顺涅槃也。七随顺等观一切众生者得大涅槃而不舍世间故。八如相者行依如修故。九无著解脱者。理等离缚脱无脱相故。十法界无量者称性用也。此十相成共有二。一以十门摄诸行回向。约此门即是行。二以行依十门明回向也。回向有三。所谓实际菩提及众生回向。实际有二种。一现修诸行即是真如。二为显真如故修诸行也。众生亦二种。一为度生故修菩萨行。即是众生道具。二菩萨所成即众生所与。菩提亦二。一所修诸行为成大果。二菩萨众生诸行即是菩提芽果。一一回向并有此门。具述总意。准以思之。第一中有四。初问列名。二辨相。三是为下结。四以偈重颂。二辨相内有四。初明行体。二摩诃萨复作是念发菩提心宝下回向众生及菩提。三菩萨复作是念如日天子等下回向实际。四以如是等善根回向下结叹胜妙德用自在。初辨体内有三。初以六度四摄等为济众生法。二修善根下明救护众生。三此菩萨为怨亲故下明托依起行。此中有二意。一为离众生相故得成三回向。二由离众生故是三回也。此可思之。二正救众生文有二。初令生不堕地狱等。二复作是念下得法身乐。于中因果分二也。三托依起行文有二。初以善回向众生不拣怨亲有三。初立。次问答释疑。三常以爱眼下对缘成行。展转有四辨疑。第四疑文有三。初立次责三答可知。二菩萨不为一众生下显意广大。有二可知。第二回向众生及菩提有五。一行等诸佛及起心究竟即为二也。此二子段中复各为二可知。二菩萨以诸善根回向时下令生得清净趣。三复作是念以此善根下为生得见佛获益。七财净满足者谓信戒闻施智慧惭愧。四此菩萨复作是念下代受一切苦。此文有四。初对物生心。次何故下除疑。三以大下明善巧有二可知。四复作是念我悉当为下正明为生受苦。此中有三。初代受苦。二除疑此文有三。第二文中有四。第三文有三可知。三是故不以下结可知。三复作是念我当以下辨所成也。有二可知。五菩萨以是无量下令生得具助道因缘有三。初起意。二喻况。三合可知也。第三回向实际文有二。初简择前二回向。二令一切不着等下正回向实际。此文有三。初辨分别无相。二不起虚妄因缘下依他不生。三观察一切众生平等下真实无性。彼不生诸法不灭诸法以如是等善根回向者。即第四总结文有三。初总。次修行下别。后菩萨下结叹。别中初修行对治法等结初行体。次观一切结回众生及菩提。后于彼善根不作二相下结实际。余相可知。重颂有二。初长行辨意。次偈颂有五十六偈有三。初十二总结。次别。此别有三。初十一结行体。次十三结回众生及菩提文。次十五结实际。第三后六总结之。可准取解。二不坏者有五。此中初问。次答。三结。四叹德。五偈颂。答文中有五。一辨行体。二欲令一切众下回向众生。三诸佛成就无量德下回向菩提。四菩萨如是舍离痴下回向实际。五如是菩萨成善根下结叹德用。体文有五。一对缘成信有二。初立宗。二何故下除疑二如是安住下依信成行因。三菩萨如是等善下辨行所成果。四菩萨如是精勤下结兴行益。五菩萨善根回向已下辨依行成愿事。此有二意。一为不坏故得成三回。二为不坏故是三回也。此可思准。二回众生等文可知。实际文有三。初简前二回向。二观察平等下正回实际。三常为诸佛下功感圣念。四结叹内有五。初结行体。次摩诃萨如是下结众生。次究竟清净下结回菩提。次得平等下结实际文。次菩萨行如是下通结胜妙。偈文有二。初长行。次偈颂有五十有五。初二十一颂行体。次二颂众生。次二颂菩提。次十颂实际文。次十四颂结叹文等。三等一切佛者有五。初问。次答。三结。四叹德。五偈颂。答文有五。初辨行体有二可知。此回向有二意。一为等故成回三种。二为先应三回故得等也。可准之。二此菩萨得如是乐时下回佛菩萨及众生。此文有四。初向佛。二回菩萨。三回众生。四菩萨摄取行等行下明仪式也。菩萨文有二可知。第三回众生文中有三。初回仪式此有二可知。二灭恶。三生善。三菩萨若在家时下辨起心分齐。此文有二。初释。次如是菩萨今集下结。初文有二。初在家摄生回向。二菩萨作是念乃至小大下大悲深重。初文有四。初起心。二对缘辨摄有二可知。三明成行无间即显智坚固。四结。第二深重文有二。初离苦。二得乐可知。四复作是念如彼下回向实际。文有三。初牒前。二回向。二而无所著下正回实际。三摩诃萨下结同佛回。正回实际有二。初约入观智回。二常乐习行普门下出观智以回向。第五总结中。初牒前行体。次第一回向下通结偈有二。初长行。次偈有四十八。初二颂体。次三十四颂回佛众生等文。次四颂实际。次八颂结叹。四一切处者有五。初问。次答。三结。四叹德。五偈颂。答文分四。初辨体。二如是庄严下回向菩提及众生。三菩萨如是善根回向了无所下回向实际。四菩萨如是善根回向下结叹德用。初体中分二。初明行体有四。一法。二喻。三合。四辨所成。此有三句。法喻合喻如诸天者第一义天。余相可知也。此有二意。一为顺一切故得回三。二为顺三故得至一切处也。二菩萨复作是念下广明行相。此文有二。初明所依方土及佛。二菩萨于诸如来下广明行相。此中有二。初对境兴心即为二也。前对境明心。次辨心德。二复作是念下对境成行。则复为二耳。如是庄严下回众生文有二。初开理事二门立宗。二令一切等下别辨得成至一切处所以。有法喻合。三文可知。三实际文有三。初牒前行。体及二回向。次了无所有下正回向。三如是菩萨乐观下结回成益。正实际有二。初约入观智。次如是菩萨圆满下出观智辩也。一切法众因缘地者依因缘解证一切法故。四总结叹中初结行体。得佛自在下结菩提。次教化众生结众生。次菩萨如是下结实际。偈文有二。初长行。次颂偈文二十二。初八颂行体。次六颂菩提及众生。次六颂实际。次二颂结叹文

五无尽功德藏者此有三义。一出生无尽。二所成。三自体。以此三准之。初问。次答。三结。四辨德。五偈颂。答文有四。初辨行体。二菩萨诸善根皆悉下回向菩提及众生。三菩萨以如是等下回向实际。四菩萨如是善根下结叹胜用。此初行体文有二。初辨行体有四。一忏。二劝请。三随喜。四回向也。随喜有四。一成佛。二说法。三涅槃。四流通等文有二。初悔过。第二劝请随喜回向也。此三义由是有为德义分相交故。同处合说。此文有二。初总举。二别辨。别中依随喜四义即为四段耳。此有二意。一为行顺三回故得成无尽藏。二为成无尽故回三处也。此可准之。二菩萨作如是念下辨行相有二。初严土。二严成人。严土有四。初成世界土。二菩萨修胜善根下庄严佛国土。三彼诸世界中下三世庄严。四如一世界下结成究竟。二菩萨复如是下严人有二。初辨次结。辨中有四。一人。二此诸菩萨下略具显德。三成就下别显德。有二可知。四成就等下结有三可知。二如一佛刹下以结略显广可知。回向菩提众生文有二。初以法界方便回向二处。二如是菩萨善下辨方便分齐。实际文有二。初牒总回向趣向萨婆若际。二菩萨行如是下别回实际。此文有二。初入观智以回向。此有二可知。二菩萨如是起下出观智回。生死非杂乱涅槃非寂静者此有二解。一就破相。生死体空故非杂乱。涅槃体如故非寂静。二寂用解生死体寂故非杂乱。何者是体。近说空是。深则不空如来藏是。大涅槃能建大义。妙用繁兴无所不为。故非寂静。今依后释。此二佛境佛所行道名境界道。无别生死故非他作。生死涅槃体无定相。故曰无法。诸圣同依名为同止。如义同先解。第四结叹文有二。初牒结前文。次菩萨初发下总结。初文有四。初牒前行体结成回向菩提及众生。二以如是等下牒前回众生结成实际。三菩萨如是回向眼终下结所得益。四菩萨如是回向时下行德胜妙。第四叹德用文有三。初举数。二释。三结可知。偈内有二。初长行生起。次偈偈有五十偈。初十八颂行体。次六颂回向众生及菩提。次十四颂实际。次十二颂结叹文也。第六随顺一切坚固善根回向者有五。初问。次答。后是名下结。四叹德用。五说偈。第二答有四。一施门中辨行体。二菩萨善根回向令一切众生下回众生及菩提。三菩萨摩诃萨以此善根回向时下回实际。四菩萨以一切善根如是回向下结叹德用。初文有二。初举轮王位舍叹成行德体有二可知。二若施饮食下辨行相。此文有四。一略列所施诸物名。二作如是念下辨修行意。三若施饮时下广辨施仪则。于中或四五六不定。四者。一人。二所有事。三回向。四结前。五者第三增田。六者第三增叹事德。又有成施心。四此菩萨以如是等无量下结利益也。初列所施名文有三。初列六十章门中所施财。二心不贪着下辨施心无染。三若诸众生下辨所施田。第二意文有二。初辨施回向意。二菩萨如是回向已下明回所成。三广文虽有一百二十事无不皆在六十门摄也。此有二意。一为顺三回向故得顺坚固。二为顺坚固故得三回。此可准之。又今此所舍并通三义。一是分段依正。二变化依正。三是变易依正。可准思摄也。地前具五生身故。四轮乘者运度八难也。一住正国。此度三恶道北单越及长寿天。二正士度佛前后。三本功德度诸根不具。四平等愿度世智辩聪。又正国轮者真如法性土也。依正士轮者般若正观也。本功德轮者施等五波罗蜜也。平等愿轮者菩萨十种无尽大愿也。菩萨净行由斯满足。又字肆者恣也。第四结叹中有二。初叹益。二菩萨尔时下庆得成益。此二文各有二。初释。次结成究竟也。二实际文有二。初牒前行体。二于身口意业无缚着下正回实际。于此正向中有五。初约入观智辨行成。二菩萨如是回向时不着内下明所离。三菩萨若于此法中下辨利益。四何以故下释成。五菩萨如是见法下结说是非。此文有九句相生可知。前文言禅头者。众生有形有体名禅头。今无此想也。四结叹中有四。初菩萨等总释体用。二回向者何义下结回向名义。三菩萨若能以此下叹行回向德。四菩萨如是回向已下结益。偈有二。初长行。次偈偈有八十二。初四十八颂行体及二种回向。次菩萨观下三十二颂实际文。后二颂结叹文。了达菩提从缘起于法真性无所坏者用不违体也

七等心随顺一切众生。初问。次答。三结。四叹德用。五偈颂。第二答文有四。初辨行体。二菩萨离垢清净下回向众生及菩提。三菩萨修行如是善根下回实际。四菩萨行如是下结叹胜用。初体文有三。初辨行体。二菩萨行如是等下辨行用有二。初离恶。二生德也。三不求生天下辨修意。此有二意。一随他众生所作善根不逆善令进故。二菩萨自善根随众生根性三品授与故。此可思准之。二众生及菩提文有二。初辨修行。二菩萨以此善根下正明回向。初文有二。初自分。二修习平等下增上修也。初文有五。初辨所依之缘谓善根也。二菩萨复作是念下明依缘起心。于中分三可知。三菩萨如是下显心具德。四辨时分。五复次菩萨下广辨所施之物。第二增上施中有二。初辨施心。二菩萨复作是念下明心具德。二正回向中有二。初正回向。二如是菩萨下结德自在。此有二。初自分。二以如是等下胜进可知也。实际文有二。初牒前利益。二菩萨如是等下正明实际。初文有五。初离垢。二明所得。三明无等。四对果校量。此有二。初总。次别。五结成具德也。二正回法界。文相显可知。四结叹文可知。偈有二。初长行。次偈颂。偈有四十二。初二颂体。次十七颂众生及菩提。次七颂实际。次十六颂结叹文

八如相者有五。初问。次答。三结。四辨利益。五偈颂。第二答中有四。初行体。二菩萨以此下回向众生及菩提。三菩萨善根如是下回实际。四菩萨如是回向时下结叹胜用。初体文有三。初集善根体。二菩萨如是下摄助成正行。亦可摄因助果也。此中有二。初摄次辨观相。二菩萨以如是等下成三业大用自在也。此大用内有二。初明心所趣即略也。三业即为三也。初一句身。次一句口。次下并意耳。二一佛世界下结略显广也。此有二意。一此善根是如家相故回三处。二以相等体无碍故回向三也。二回众生及菩提文有五。初总明回向。二菩萨如是回向修下辨行广究竟。三复次菩萨下对事辨成行仪。此有二可知。四菩萨善根如是下辨修意也。五如是菩萨长养下回向功力所成。三实际文。此中回与上下何异者。诸回摄相从体。此中摄相从相。此可思准之有三。初明回向体用。二善解回向下成胜所以。三如如下约法广辨。初门有三。初辨体。二顺如来道下明用。三观察寂灭下结前二。第二胜用所以中。初举意。次如是菩萨下释。三如法门下约法辨成。第三广辨中有一百句文。初一句所轨则下诸句依回耳。又广辨文中三种言说。初取无著。第二取施设法。第三正取言说教事。文中三种时者初唯法耳。二拣时论法。三时法双论耳。此等依文次第舍之。即知所由。过去非同者非同一灭也。未来非故者非现后故也。现在非异者非异前后二世及自同类法也。此亦反外人见。思之可知。四结叹中。初三句结叹回众生及菩提。次等观诸佛无有二下结叹实际德用。第四成益文分二。初辨德。二结可知。第五重颂有二。初长行。次偈颂。偈有二十九。初二颂行体。次四颂生及菩提。次九颂实际。次十四颂结叹利用。九无缚无著解脱心。初问。次答。三结。四辨德。五偈颂。初答文有四。初辨行体。二摩诃萨以无缚着下回众生及菩提。三摩诃萨以如此无缚下回实际。四摩诃萨如是回向时下结叹胜用。初体文有二。初总辨不轻众善。二菩萨常乐摄受下由不轻顿故。于行摄成自在。此有二意。一为善根无缚着故回三处。二以善根顺三处故无著也。二回众生及菩提中有二。初辨普贤三业。二从此生尽未来际生下广约别事显成自在。初文有四。初总。次身。三口。四意可知。二广显内有三十二。一得因果位。二得方便。三得身业。四得口业。五得意业。六成根。七得神力。八于佛刹自在。九得家。十得因陀罗智。十一得时自在。十二身容受。十三入果位自在。十四入世界自在。十五知想。十六知心。此等中各有二文。初知。二叹知德。十七知处。十八知业。十九知法。二十知声。二十一说自在。二十二知根自在。二十三智方便知微细。此文等有二。如前可知。二十四行方便知微细。二十五知入解位菩萨微细。二十六知初地微细。二十七知生性微细。二十八知世界微细。二十九知法界智微细。三十知劫智微细。三十一知法智微细。三十二知出生杂法微细也。上知微细中。何故知智而不知法者。为智能显成法也。三实际文有二。初入观。二约出观可知耳。四结叹胜用文。满足等者满因果行也。约位如此。若约行即通一切耳。偈文有二。初长行生起。二正颂偈有一百二。初六颂行体。次七十颂众生及菩提。次如是一切诸法王下十八颂实际。次八颂结叹文。十法界无量者。此文有六。初问。次答。三结。四叹胜用。五证成。六偈颂。亦可此二段从会初科。第二答文有四。初所成行体。二复次菩萨以法施下回众生及菩提。三复次菩萨安住法界下回向实际。四菩萨如是回向时下结叹胜利。问此第十回向与前八九何别。答第八趣理。第九约修成。第十二俱通含及所作事也。初体有三。初总除障显德。此文有二。初受记辨位。次明益用也。次菩萨行法施下修行所趣。三菩萨于彼善根下辨行广大。所成自在福智庄严也。此有二意。一以行体回依法界至于三处。二所有行体即是法界故可回至三处也。此广大文有四。初总明行智庄严。二诸佛菩萨所赞下别辨庄严行。三何以故下辨成自行所以。四复何以故下释自成能得利物所由也。第二回向众生等。文中有二。初明恭敬无间。三业恒行故也。二菩萨以此法施下三业起用不空。初文有三。初意业随智慧行。二令一切众生皆悉具足下口业不空。三令一切众生得净法身下身业不空。初意业中有十门。知法等可知。一令自他得佛无尽法门。此文有五。初立宗。二以此下总辨其德用。三悉得下得佛法。四于一一下述自能。于中有二。初总开十门。于此文中其十海者。一名生法立义相。二引证相。三方言语则。四施名于义。五文教成轨。六说则。七所依门。八能入智。九境智资成相。十义住立不动也。五菩萨善根如是下明所成也。次广辨文可知耳。第二复次菩萨下明自回向所成德。三菩萨复作是念下令同己等得。四复次菩萨以此等下缘成性德。五复次菩萨以此善根下行成得佛随喜。六菩萨以此善根如是下辨回向所依。此文有二。谓佛及法界可知。七复次菩萨下辨所趣意。八菩萨摩诃萨下得用自在也。九菩萨以此善根如是回向下以行成位有二。初明所离。二明辨所得可知。十菩萨如是平等心下位依成胜进行用。此文有四。初辨回行体。二令一切众生下明回意。此有二文。一自分。二胜进可知。三菩萨善根如是下明所离。此文有三。初立。次责。三答可知。四菩萨如是回向时下明起行益也。第二口业可知。第三就身业文分三。初辨身体。二明身德。三辨身用。此有三。初总。次别。三结。二三业起用不空。文有二。初复次菩萨修善下具辨三业。第二如是菩萨下不空行成。初具明三业。文有二。初辨宝庄严。二广说香华等下类辨十门庄严。初文有四。初辨所供境。谓佛等。二彼一一刹下供养具。三菩萨复作是念下以略示广。四是为菩萨等下结。初供境中。初总次别。别中依正分二。二供养具有四。初明百句别宝供养。二宝身庄严下八句明三业行。三宝眼下六根妙用。四宝身业下后以三句成三业智用。二三业不空行成中有二。初令生成自分行。二菩萨复作是念下令成胜分行。此上各有二段应知。三复次菩萨安住法界下回实际可知也。四利用文有二。初牒前诸行也。二安住法界等无量净身下依行成胜三业。大段第三是为下结文可知。四叹德文有二。初明已成就普贤广大众德。二于念念中下明别叹已分成自他胜用一切行事也。上来依经。是一乘法通而非局。次明三乘寄位法者如经。初向心内。一二谛正直所谓学习第一义谛。观一切法相如不可得故。以慈悲喜舍教授六天人。剃头被三宝衣。出家菩萨共一切僧。佛法无二。第一清净故。第二向内第一义智。五神通是慧性差别用。即以六通为观境也。第三向中。于无生慧内四不坏净。于佛法僧戒中信不可坏故。于第四向中量同佛力所谓。三相诸法本无。故假名生。已有还无假名灭。不空有法假名住。是故一切通达空而不二名世谛相。空空一谛相故。第五向中善计量众生力所谓五阴。色者异空。色集成大色分。故色相空。刹那刹那成心。故心相空。受想行无集无散。一相无相故。第六向中佛教化力。所谓十二入。外六境内六根为识所入处。故名为入。其慧观者。不在外。不在内。不在中间。一切法无自他故。第七向中趣无碍智为十八不共法。六境六根六识。一合相一切法亦尔。第八向中随顺自然智所谓因果。善恶名因。苦乐名果。所由为因。所起为果。因果二空无生无灭。皆一合相也。第九向中受佛法僧故。谓二谛空因缘集故。谓之有。非曰有是有。因缘散故谓之无。非曰无是无。故有无无二相也。第十向中以自在慧化一切众生。所谓中道第一义谛。般若处中而达一切法而无二相。转增入圣地名相似第一义谛观。非真谛观。初地已上是真观。此是三乘寄位说。所以知者为经中明已前三十心并凡夫法非圣位故也。初地已上经本无通三乘。立其教义文相多同故。不须料简也。尔时佛神力故动地等下第五明证实显成。此文有二。初动地雨华等证成。次云十方菩萨悉云集者第二明诸圣证成劝信流通也。于二文各有二。谓辨相及结通余方也。偈初意后颂。颂文有九十四。初十四颂行体。云无相妙智观法真相者末用依体也。世行穷故最妙。次菩萨法施下六十八颂众生及菩提。次譬如如下二颂实际。次如是殊妙下十颂结叹。就菩提众生内。初八颂三业随智行。次十方一切下二十颂身业不空。次恭敬下二十二颂口业。次众生数等下十八颂意业等也。此会答上回向问耳

大方广佛华严经搜玄分齐通智方轨卷第二(之下)大方广佛华严经搜玄分齐通智方轨卷第三(之上)

        终南山至相寺沙门智俨述

    第六他化天会十地品二十二

此会初四门分别同前

一辨名者。他化自在天会从处得名也。十地品者数义以彰名也

二来意者有二。初会来意。前是阿含。次入证故来也。二品来意者。前方便回行向于菩提。今行相增明转入十地。义次第故也

第三宗者有二。一会。二品。会者有四。一明所治。谓正使烦恼业报及性三障上心种子。二能治。谓正无分别智及普贤性起智。三所成德。谓有二。所谓人法。人有二种。谓正化及助化。各有体相用并通性起等。法者谓理教行果。并通性起及修生等也。准以思摄可知。四明所成位。谓十地位及普贤性起无漏法门等也。若论品宗四义。准上唯取修生为异耳。又此品以不说为说义即证普贤德位。以说为三乘宗

第四释文者。问此会共上二三四五会何异者。答且有四异。一漏无漏别。二本末别。三共不共别。十地人天声闻等共采故。地论云。亦能生成人天道行余则不然。可准之。四位别如是一切。问何故此会独不显别处及彼体用二融放光往来集众严具者何也。答欲显此会是证了法无二。体用远近并无别异故。不须表显别处等也。又此会等是证法不可以事别标玄趣。但得总相显耳。准上思之。此会有十一品大分有二。初有九品辨缘成德用。次有二品明性起体用。以为诸会所学法也。初九品内大分有二。初有六品辨因行满足。次不思议品下有三品经辨因成所得果。问何故果不别处说。答此经上下显法尽理。推高佛地不可说为正也。此中说者为彰同证。略为举果显因故说也。就初六品内有二。初一辨行位体。次五品辨德用。就体门有三。或复为六。或分为九。或判为十。或复离为四十八。又此中所辨通解论中难文。所以然者为此释共论合成一疏故也。三者所谓序正流通。就此三中所辨之法要唯证教。证教既殊三分亦异。就教三者。初至起分是其由序。以此起发正说故也。本文已去是其正宗。于中虽复有广有略。同说地法判为正宗。地利益下劝信传持。津及末代判为流通。亦可分四。后分重颂偈。就证三者。初一序分判为由序。入三昧是证正宗。因入三昧正显实证故。地论言此三昧是法体也。流通之义释有二种。一以已德流被信地说为流通。若从是义加分已去皆是流通。以说自得令信菩萨证入地故。二流末代名曰流通。若从是义地利益分名曰流通。言为六者随所行以分。初至起分起化之由。为生物信。第二本分略说地法。叹其殊胜起众乐欲。第三请分彰地出言令生正解。第四说分广明修相令物起行。第五影像分寄喻显德。第六地利益明德既成契证地法故。地论言以得法力大地动等。言为九者。始从序分乃至请分则以为六。说分已去判为第七。地影像分说为第八。地利益分是其第九。亦可分十。增其重颂。就此十中所辨有三。一就化相通为起说。二就化意通为显证。三随宗要证教双辨。言起说者。如来将说。先托时处。现相集众。发起所说。以之为序。由序既兴。将为众说。时金刚藏默入三昧显己自证能为众说。又为受加故。次第二明三昧分。由入三昧。十方诸佛赞叹与力故。次第三明其加分。既得圣力欲为众说。但定无言宜从寂起故。次第四明其起分。从定起已。略宣地相起后广说故。次第五明其本分。然彼本中略说地名不广分别。大众渴仰闻名欲义。相与稽请故。次第六明其请分。众既请已。正为广陈故。次第七明其说分。乃至十地通亦是说法难解。宜以喻显故。次第八明地影像分。为说既竟。宜显胜益劝信传通故。次第九明地利益分。显其法已。宜以偈述故。次第十偈赞结前。言显证者为化之意。宗为显证。于中初分显证由序。后九正显。九中前三就相显证。次有四分。就说显证。次有一分。就所摄化显证利益。次有一分。重述证德。前三之中。初三昧分寄入显证。第二加分因加以显得证之相。故地论言。以何故加。由得大乘光明法故。第三起分寄出显寂。说必宜起。即显所入寂灭离言故。地论云。定无言说。是故宜起。次四之中初本分者略说显证。第二请分拂相显寂。说及影像寄相表德。说分之中寄修表德。地影像分借喻显德。地利益分就所摄化显地利益。故下文言以得法力动地雨华。偈颂同前。此等差别同为显证。言随宗要证教双辨者此品之要无出证教。九中初一是其由序。后八正显证教之相。八中初一入三昧分显示正证。后七次第明起言教。言次第义如初门。所言十者随地不同分为十也。已上三会并同此。准可用思摄也。言四十八者。初地八分。二地两分乃至十地八分差别。一品合有四十八分也。此经文与地论经本多有增减。就不同文中以四法简之。后至文当知。一诸文内漏少者当增。左相安竖画。脚中点少句数记之。诸文背而意顺者。句中第一字间点之。诸十句中与论前后者。当句左相齐等点数记之。诸句多增者。左相上下相拘之。此并约论取定耳。若论不辨者诸亦不论。又论中增者依此知之。又此四十八段文者但一地即成四十八。余地类然。如是准之。所以知者其论主自分诸地前后隐没废兴不同。以义推之理合俱有也。就初序分四。一明说时。二辨化主。三明说法所栖托处。四辨同闻就住处有二。一明通处。二摩尼宝殿下明其别处。四明同闻中有六。一简定其人。二此诸菩萨下叹其人德。三其名曰下列德者之名。四无量下辨名者之数。五明来处。六标列上首。经脱第五句。前中有四。一简大异小。二于阿耨下简终异始。三简住异退。四从他方下简新异旧。前中先定所列之人。次明诸经辨人之意。人者泛释有二。一圣化所被当机之众如论所说信地人等。二圣化所对影响之人如此所列诸菩萨等。辨人意者。诸经列人凡有四意。一彰化所益。如涅槃经辨列无常诸学人辈。二为对人显说决定故。经说言虽于空地多有所说。不得名为真师子吼。今于如是大智人中有所宣说。方得名为真师子吼。三为寄人彰别其法。如说十信广对诸首等。四举同闻证成可信。今此列众义兼后三也。简住异退者。泛论退有三。一者得退。谓先所得后还退失。二未得退。谓于胜进退住不入。三习行退。先习多行同成在已。后一现时余则不现。所不现处名之为退。今以此三准约地位。非无斯义。解行已前分未坚固。随其所得容可退失。具有三退。初地已上尽于六地次第修道不能顿起。故有习行及未得退。七地已上位分未穷。有未得退。退相如是。随所离处即是不退。然彼三退广分为五。就初得退随义分三。一是灭退。谓外凡夫所有善根为彼邪见所断灭故。二是失退善趣之人信未成者容可退失起二乘心。如舍利弗等。虽不退灭作一阐提。而菩提心不复能显。三是废退。种性已上或时暂起烦恼业迹。废其所习不令现前。名为废退。以此三种通余二退。合说为五。此之五种外凡具有。善趣信位唯无灭退得有余四。以不断善作阐提故。种性已上无灭无失。得有余三。初地已上无前三种。得有余二。七地已上唯有未得。余四悉无。第十地中。克就因位五退悉无。若望佛果由有未得。退相如是。不退可知也。又若依此经。信行及解位已去但有未得退。余者并无也。此约一相也。若约普贤自体并无诸退。准上思摄。地法深密。非粗智知。所以然者。为地教法托彼诸乘及世间善事。以显阿含法义分齐。虽托显一乘理。仍三乘小乘当宗自住不失自宗。如盐成羹盐自住性而羹义得成。下之文义应准此知之。菩提有三种。一入性地名得菩提。二初地。三佛地。故涅盘中说须陀洹八万劫到。乃至辟支佛十千劫到。谓到性地。问阿耨菩提在果何故通因。答此亦不定故。大品经说五菩提。所谓发心伏心与明出到无上菩提也。一乘有十菩提。如下离世间说。生者五种。一法性生。六入殊胜无始法尔。二实报生。谓从先来修善所得。三者生灭变易法身。所谓缘照无漏所得。四分段身。谓彼凡时三界业所得。五应化身。随物现受。此等并约三乘解非一乘也。何故此会首多约三乘明者。为地品通三乘信向故。就叹德文有二。一别。二总。菩萨功德不可顿彰故。先别叹。非别能尽故须总结。别中复二。一者略叹。二善能化下随德广叹。菩萨广德非可顿彰故。先略叹。非略能具故须广叹。略中有二。一叹自分。二诸佛如来下叹其胜进。二广叹文有二十句。前十二句广上自分。二有八句广前胜进。广自分中摄以为二。初六明其行修具足。次有六句明德用圆备。行修具中。初三利他。后三自利。前文初句是总。后二是别。依经二中脱一句。二自利文中有三。初愿。次修。后明成行。第二圆备文中有六句。前三利他。后三自利。利他之中。初明身业。次明意业。后彰口业。第二自利中三。一行修殊胜。二诸德圆备。三诸所下妙用自在。第二广前胜进文句别有八。前四明其殊胜三业摄修所行。后四明其广大三业备具诸德。前中初三明胜三业。后一明其摄修所行。后四亦尔。初三明其广大三业。后一彰其备具诸德。初殊胜三业之中。初明身业。次口。后意。就后四句文。初有三句明广三业。其身普现是广身业。其音遍闻是广口业。其心通达是广意业。第四一句备具诸德。此处感果者。感是根。果是欲也。又下地人果决能成耳。余如论辨。又明不共者。一外道不共。二二乘不共也。又二法喻金刚中。法前是能破。后是坚也。喻即前树取心坚。孕子取子能破也。三昧分中承力入定有三。一为推化在于如来故现承力。二虽自得对佛胜人不得自在。必须仰承。三于此定虽分得证。穷满在佛。今此欲为佛之胜化故。须承力。科文可知

就加分中有三。一入三昧故诸佛同加。二欲宣一切下明加所为。三金刚藏汝当说下示现加相。初文有三。一诸佛为欲加赞同皆现身。二同声赞下诸佛同赞。应前入定显证能说。三如是十方下佛彰已加。应前入定为受佛力。又释得加所以。又显示多佛故者多佛同证此法也。余文如论应知。二所为文。一对地法明加所为。二所谓入智慧下对所化人明加所为。又见智得证者。前二观解。后二行解。见始智终。得始证终也。又信乐得证者亦同前。但为未得向得故安信乐名。对人明所为中有二十句。前之十入是自利行。后十始终是利他行。何故自利名之为入。利他之行说为始终。答但入始终义一无别。语入其必从始至终。论其始终必有所入。为分两行各随一义。就入及始终二十句内。各初一总余句别。第七中复有善根能为出世间因者地中加行善根等也。又始终内经脱第二句。又论言阿含者有九种。一行教相对。音声言教名为阿含。一切功德说以为证。犹下说中字义两藏是也。二位地相对。解行已前依教修行名为阿含。初地已上说之为证。犹下解脱第二请中叹众是也。地前所起闻思修等名阿含净。初地已上一切行德通名证净。三修成相对。一切地中闻思修慧报生识智。此等四心缘照之解名曰阿含。真智出言说以为证。故下论言。闻思修等是则可说。以可说故名为阿含。地智离文。名之为证。四真伪相对。一切地真伪合修名曰阿含。舍伪契实名之为证。犹下所明义说二大。说大阿含方便修也。义大是证行成就也。五相实相对。世间修中得彼证相名阿含。契本实相名之为证。犹下所说增上妙法光明法门。增上是证。光明是教也。六体德相对。就彼离相所成行中。无始法性本隐今显。名之为证。依本所成方便行德。依教修生名为阿含。犹下文中炼金所况。金体喻证。环钏严具喻于阿含。七体用相对。前体及德相从为证。依此所起。随顺世间教智之用名为阿含。犹下文中珠光明等所况法是。珠轮等净喻于证体。光焰等喻于阿含。八自分胜进相对。自分所成体德及用皆名为证。能受佛教称曰阿含。犹下文中叹金刚藏二力是也。妙智及辩名为证力。于佛教法念坚净慧名阿含力。九约诠就实相对。真智之体说以为证。即此证体约言分十。名为阿含。犹下文中虚空迹处所况法是。虚空平等喻地证智。故下论言。字身住处证智所摄。空中之迹喻地阿含。故下论言。非无地智名句字身。名句字身是阿含法也。此之阿含及证通上及下。可准思摄。余相知之。第三加相文内。谓口意身。口则劝说以增力。意则冥被以加威。身则摩顶而令觉。何故先口次意后身。乘前诸佛显加所为。因则劝说。故先明口身摩则起。理宜在后。意无此义。据中而说。口加中有二。初总次别。又身净中经脱佛尽一句。第二意加文有二十句。初之十句正明意加。后十解释偏加所以。何故就意解释偏加余不如是。意是加本故就释之。又前口加有其自他二力辩才。意加亦尔。前十正加明其他力。后十释加显其自力。故此释之。就前文内。初无畏身亦总亦别。通摄十句为无畏身。所以通是总别。于中别分。初之一句显色身胜。是故名别。余之九句一向是别。又此中论法成者依相续解脱经中有四种成。一以有成。因缘名相言说诸法得成。二所作成。一切所作各有成辩三者法成。一切诸法性相成立。四者助成以智言说助成诸法。今言缘者是彼以有成也。以有因缘诸法得成。故名为缘。法者即是彼中法。成作者是彼所作成也。成者即是彼中助成也。又三种同相智者释不一种。依金刚仙论知一切法皆无常苦及与无我也。依别翻论知一切法自相同相不二相。谓世谛真谛一实谛也。又知空无相愿也。又六正见者是能知智。依金刚仙论。一真实义正见。能知理法。二行正见。能知行法。此二教旨。三教正见。能知教法。四离二边正见。知前理法不同情取。五不思议正见。知前行法成德出情。六根欲性正见。知前教法说随物心也。第二释所为中。初何以故责。次答文有二。初一总。后九别。又佛法欲坏时假余尊法诵持者。随坏时何尊教也。第三身加文有四句。一不离本。二以神力。三申右手。四摩顶。经阙初二句。就释本分文内有二。初告次述。第二文有三。初明愿善以为地体。二列十名显其地相。三举佛同赞显地要胜。此三之中皆各有二。初地体内。初一句总。二无有过下别。余如论辨。第二相中文别有二者。初问。次答文有三。初立有二。次列有二。三结。第三段文别二者。初我不见者举佛同叹显地要胜。二何以故下彰地要胜释显诸佛同叹所由。此文有二。初问次答。答文有四句。初句举此证行释佛同叹。第二句非但是彼出世所证。亦是世间方便所行。三所谓一句显前第二光明法门。四诸佛子下显前第一增上妙法。此约论中经本科也。余文可知。又论云决定者。依地持有三种。一种性决定为定佛种。二解行决定定发心。三证决定定得法故。此即第三也。又善决定者。初辨善。决定随来。次决定者辨决定义。善字随来。就善释决定义也。三胜善决定中依论合有四义释。初一总。后三别。三中谓证助不住也。又解初理。次智。第三位及教法。四约相即无漏亦即助道。准思摄也。依大品经论有三乘十地名。一干慧地。二性地。三八人地。四见地。五薄地。六离欲地。七已作地。八辟支佛地。九菩萨地。十佛地。此十地是一乘所用。是三乘所入也。此中本分依自义阿含说也。就请分文中大判有二。一金刚藏说已默住。菩萨及佛咸皆共请。二观察下示说分齐令众正知。前中随人分请为三。一解脱月请。二大众请。三佛加请。就此三中。初解脱月请内文别三对。皆初说者默违不说。后明启请。第一对中。初金刚藏说已默住。后解脱月知众心疑为之问请。仁者堪说。大众能闻。何故不说。第二对中。初金刚藏乘前请问显已默意以为酬答。以法难说证信难得故我不说。解脱乘此叹众重请。我谓仁者更有何意。乃云证信难得不说。今此菩萨善净众集有证有信。仁者宜说。此第二对。上来两对叹人以请。第三对中。初金刚藏乘前请言举损以违。虽此众净余乐小者闻生疑惑长受衰恼。有斯两损故我不说。解脱月乘此叹法重请。仁者但说。莫虑众疑。诸佛护念令人易解。有说多益。勿惧衰恼。然解脱月请义有余。彼金刚藏违请。理尽于斯绝言。但为重法默待余请。初对经中初金刚藏说已默住。是时一切已下明众心疑解脱为请。前中两句。初金刚藏说地名已。牒前起后。二默不说正待后请。下众对此生欲生疑。就下请中。初明大众闻名欲义睹默生疑。时大菩萨下明解脱月知疑为请。复就前中。初对说名闻已欲义。各作是念下对不分别睹默生疑。何因者对彼说人以生疑念。言何缘者对其听众以生疑念。第二解脱知疑请中句别有三。一标请主解脱菩萨。二知众疑为之启请。三举请辞。请辞偈中文分有五。两门分别。征请分别。征者征默拂遣众疑。请者请说遂众心欲。偈中初二征问默意。第三一偈请其宣说。后之两偈略无征请。理应齐有。二就所叹说听分别。初偈叹彼说者堪说。为遣大众何因之疑。后之四偈叹众堪闻。为遣大众何缘之疑。就听者四偈中。初之两偈叹同法众。次有一偈叹异法众。后之一偈总叹二众。然此亦名同生异生。又论云。有非现前决定无现前等者。证教二决定非现欲决定也。又第一行慧字当论中觉也。第四行中瑕字即论不欲也。秽字即论中威仪浊也。实者即除论中异想也。余准可知耳。就第二请内有二。初金刚藏乘前启请显已默意。后解脱月乘言重请。前文有二。初长行生后说意。第二偈释。偈有六偈。初之二偈明法难说。次有二偈彰法难闻。次有一偈喻难说闻。后之一偈举难结默。又喻中文意者。空喻证地体。风画喻字句言说。风画住处喻所说差别十地。问此与下喻何别。答下取鸟迹处为喻。况之以证。此中宣说动笔之画飘忽之风以为喻故。况之以说。有此左右耳。又此画及鸟足并下悉昙章喻。及下普贤品总为一类。是言显证十地下鸟迹处等以不言显证十地为己许说十地名故。此亦可准解之。所以故十地总名。亦可是三乘熟教名故。前二偈中法有四重。一总举法难。二第一等显其难相。三菩萨行出难法体。四微难见下彰难所以。此依论经。可准取思摄也。第二解脱乘请文中有二。初长行次偈颂。长行有三。一解脱月闻违重请。二是大菩萨众直心清净下广叹众净。三是故下结请令说。二广叹众净文中。初总次别。阿含净内别经文中第二句在论第四句。经中第五句在论第二句。亦可依文定仍须思准。二重颂文内有二。初长行生起。第二偈颂。偈中初一颂上结请。次有一偈颂上请文。第三请内。初金刚藏举损以违。后解脱月叹益重请。初文分二。初长行。次偈颂。初文有二。初领前所叹举得兼失。二其余乐小下简所不叹举损以违。此文有三。一败善之损。二是人下长受衰恼失乐之损。三我愍下结默所以。二重颂文。初明说意。二正颂。此文有二。初一行半结牒前文。次一偈半结上彰失。第二解脱请中。初长行次偈颂。长行有三。一自宣己心彰欲重请。二愿承佛力下正请令说。三是故下结请令说。就初段中可知。二正请文有二。初立宗请说不思议法。二佛所护念下辨诸佛法应护念。此文有四。初护然有三可知。二何以故下辨要胜。三譬如下喻况。四如是佛子下法合。第二重颂文有五。初一半明颂请说文。二一偈颂前第一护。次一颂第二要胜。次半颂喻。次半颂第四合喻。第二大众请文。上来解脱为众先请。请虽言众堪未知虚实。大众宜须自彰己能成前请辞。又为起说显法尊重故。下共请。请文有二。初同声生起。二正偈诸偈文有五行半。初四行半叹人以请。后一叹法。就初段中。初二叹其说者。后二半叹众堪闻。初有五句叹金刚藏自成证力及阿含力。下之三句叹金刚藏能令听者入证及阿含。初文有二。一有四句叹成证力。次有一句叹成阿含。就叹听者中。初一偈半大众自叹具智断德及先有根。次有一偈叹堪思持。第三佛加请内。上来虽复菩萨众请。率感由微显法未极。故次佛请。又菩萨请显法未胜故须佛加请。此文有二。初明身加。后明口加。身加经中有五。一释迦放光普照十方。二十方佛放光照此。三此大众寻光见彼。四彼大众寻光见此。五光台说偈。光台说偈应属口加。何故在此。然所出声口加所摄。今此正取能发声业判属身矣。若依经本无此见彼及彼见此。二俱无。又经脱第五降伏业也。又此光为显佛力分齐及加说者。不为集众等。余文如论。就第二口加文有二。初长行生起。第二偈颂。偈中有七偈半。于中有二。一教请分别。前六偈是其请说。后之一偈半是其教说。请彰法胜令人重敬。教显说真使众深信。二加请分别。就此偈前六偈内有三。初一偈半正加。二有一偈加所为。三有三偈半彰得益此文三。初一闻益。次半修时益。次二转生益。又此转生文中偈迮难解。文意趣者。其经法胜力加其闻者。乃至若火劫尽时由得闻经。论言等者等余二灾并得闻也。问彼云何闻。答彼天先从佛闻。今为说也。此在极为言。非局此时也。龙中先有经。故引之耳。又三渐次者即加行正体后得三智也。此可准思摄之。亦可教证不住耳。第二尔时金刚藏菩萨下示说分齐令众正知。就此经中初集经者明金刚藏将说之相并显说意。后正明其所说偈辞。就前文中初示说相。观察表说。内心照察名之为观。亦可目眄说之为观。显已无偏。故观十方。下明说意可知。金刚藏有二意故说偈。一自显有智堪说。拂遣大众何因之疑。二彰已不畏大众不堪听闻。拂去大众何缘之疑。问众有何益。答有二义故益。一义大益。彰实出言唯深是乐所以获益。二说教大得闻在今。是以欢悦深生正信。就偈文内有十三偈半。初七偈半明其义大。后有六偈明其说大。就义大文中文分为二。初三偈半显其佛法。次四行偈举彼佛法显地出言。今为明地。何须显彼佛法微妙。以地在因辨深义隐。佛法在果彰深义显。故明佛法显地深微。因之与果高下天殊。云何相显。然此虽复随人高下。法体不别。其犹虚空约尺分异异即是空。地法像此。就初文内初一偈半直彰法微。后之两偈出微体相。谓二涅槃初文有二。初总辨微。二唯智者下释相也。初文有四。一者是微。二难知之道。三非思量论名非分别。四名无垢浊。经无此句。下三句有。又无垢浊下有四义亦可。难得属上无垢向下。又二向并属。可思准之。初观解清净。二智者下行证契真。三自性等下体性清净。四不灭等下德用自在。此依论辨。经亦同然也。又有世间智慧随闻明了知。下举世智随文显真智不随闻也。又论结云观解甚微结不浊。二依止结智者等。理与智为依耳。三清净。甚微结自性灭等。功德等结不灭不生等。又第一出世故不同世间定也。第二实成故不同外道。第三本净故不同始净尊者。第四即静恒用故不同声闻等也。余义可知。就下两偈出微体相文分有二。初有两句是其同相。后一偈半是不同相。不同相有二。一何处脱。谓离诸趣。二有五句是云何脱。五句即分为五。一观解入如。所谓等同涅槃相也。二对治离障。三明体德圆备。四是其法身常故出矣。五有一句是其解脱自体无碍。又论云非唯初中后前中后取故者此约智义。非约智事。义言智起惑次灭耶。又智生惑灭耶。同时耶。此名中耳。又惑灭次智成耶。此悉不可。并有恒生恒不生恒灭恒不灭等过故。初中后如缘起性取也。又如是观智等者次第结前不同相方便坏涅槃。五义可知也。二举前佛法显地离言内。于中有四偈。初一偈半举前二种涅槃以类地法。次一偈半正明地体难说难闻。次有一偈喻难说闻。前中三句牒前佛法寂灭出言。下有三句显地难说又复难闻。又论云地者境界观者。或名分齐或是所缘耳。第二说大文中有六行偈。义分有五。初之一偈三句彰说分齐。次之三句彰已无过劝众除失。次一偈半显其说相略而非广。次有一偈劝众敬听彰已善说生众敬爱。次有一偈显已得力结说分齐。又论云但说一分者谓因分也。地有二分。一因二果。因谓世间方便行修。即加行智分齐也。果谓出生离相真证。即正证分齐。真证出言。因相可论。今唯说因故说一分。又亦可约位也。因渐成者谓闻思等非顿渐成故云也。又约资成之义。此有二义。一资成其因。二资成其证。教说修中有二者。一真心究竟成德满足故云也。二者观修者真心离妄内照法界故名也。此二与后得正说相应故名教说也。不相应义属义大耳。余文可知。就说分文内六门分别。一释名。二明所除障。三辩所显理。四明所成行。五所得果。六释文诸地同此。一释名者。初名欢喜。成就无上自利利他行。初证圣处多生欢喜。故名欢喜地。二所除障者。依地论名凡夫我相障。依摄论名凡夫性无明。又分二障。一法我分别。二恶道业。又治二种业及一种报。谓方便生死也。云何治。如虚空等。广如论释。三明所显者。谓显法界遍满义。四明所成者成檀度及十愿等。五明所得果者。若局取果唯通达障空义得一切障灭果及地位等。若通判果则得唯识三无性理。及得奢摩他毗钵舍那等。六释文者有二。初长行后偈颂。长行有二。初结前生后。二若众生下辨地体相。此文相二。初辨说分。二菩萨如是安住下校量胜分说分文有一百句。初四十句名为住分。次三十句名释名分。后三十句说为安住。前四十句如论应知。又初十句中经脱净心集。就释名三十句中。初十多喜。此中经脱庆喜文。依论中云心喜者。心体非喜摄喜从心也。体喜亦如是。根喜者以体成后为根。非喜根也。次十念当得。后十念现得。就念现中。有二第一正明所念现得。二何以故下广释远离五种怖畏。亦可就第十中分之。就释怖畏文内有二。初责。次答。答内有三。初明所离果。二何以故下释成离相。三如是菩萨下总以结之。又论云前说身畏后异身畏者。前总明后别辨。故云异身也。非身外耳。就安住分文有三。一总明安住。二所谓信心下有三十句。别明安住。三菩萨成就如是下总结安住。就广辨三十句中。初十信。次十修行。次十回向。余文如论。第二愿校量文有三。一愿校量胜。二行校量胜。三果校量胜。言十愿者。一供养佛愿。二护正法愿。三摄法上首愿。四知众生心。五名化众生。六名知世界七是净土。八同心行。九三业不空。十成菩提。依摄论有十愿。一供养愿愿供养胜缘福田师法主。二受持愿愿受持胜妙正法。三转法轮愿愿于大集中转未曾有法轮。四修行愿愿如说修行一切菩萨正行。五成就愿愿成就此器世界众生三乘善根。六承事愿愿往诸佛土常见诸佛恒得敬事听受正法。七净土愿愿清净自土安住正法及能修行众生。八不离愿愿于一切生处恒不离一切诸佛菩萨得同意行。九利益愿愿于一切时恒作利益众生事无有空过。十正觉愿愿与一切众生同得无上菩提恒作佛事。又此十愿与前十愿义同不别也

就经文内有四。初结前生后。二正明愿体。又初愿脱二句。第九愿中脱如意宝身也。三诸佛子乃至大愿等明修愿方便。四以十不可下总以结之。若依论本别明十无尽成前大愿。若依经本即是第四结愿无尽。就此文中有四。初举法及愿立宗。二何等为十下列十尽法。有二可知。三若众生尽下将法对愿逆显成尽。四而众生下顺结无尽又第六愿中论云辨粗细中。并云随何意识身色心粗细故土亦粗细也。余相如论。又三种三转者。就十尽句别中众生界世界空界及心缘界等四是世间转。法界涅槃界佛智入界此三名法转。佛出世界如来智界此二为智转。就第二行校量胜文有三。初牒前起后。二正释行体。三诸佛子悉知已下总以结之。二释行文内有三。一大愿薰心成利安等益。二如是则成下人成信者。三乐以信分别下广明信相。此文十行即为十段。初信文有三。一总立宗。次别释。三举要言之下总以结之。第二释慈悲文有二。初举三门为所观。二对起慈。前文有三。如论应知。又论云辨远离第一义乐中三空离三障者。谓分别相取舍等即三性障也。余行如论可解。第三果校量胜文有四果。如论应知。初调柔果内。初法次喻后合。法中有四。一见多佛起行之缘。二心大欢喜下明能练行。三多以二摄下乘前练行明别地德。四是菩萨下明所练净。二发趣果内文分为二。初释后结。前文有四。一法。二喻。三合。四结。法喻合中皆有四句。一问地法。二是菩萨善知下明知解法。三诸佛子下明能行行。四得诸地智下明其能到。喻合四句同此。三摄报果文有二。一在家果。二出家果。在家有二。一上胜果。二能以大施下谓依王报起胜行也。愿智果如论应知。第二偈颂中四十五半。初二十二颂上说分。次菩萨如是下二十一半颂校量胜分。次二总结叹。初文之内。初十一偈颂地方便及住地文。次是菩萨下五行偈半颂彼释名及五怖畏。次常行下五行偈半颂安住文。次二十一半偈文内初五偈半颂十愿结及无尽文。次六行偈颂信等十行文。次智者于日夜下十行偈颂果校量。于中初一颂调柔果。次三颂发趣。次五偈半颂摄报果。次若以愿力半行偈颂愿智果。第二地内六门同前。言释名者。离能起误心犯戒烦恼垢等。清净戒具足故名离垢地。二明所离者。依地论邪行于众生身等障。依摄论依身业等于诸众生起邪行。无明又治二障。一微细犯过。二种种相业行。又治二业障及一报方便生死。三所显者显最胜义。四所成者成戒度。五所得果者。若通达法界最胜功德得于一切众生最胜无等菩提果。通果同初地。六释文者有三。初偈生起。二长行正释。三偈颂结前。初偈有二。初三偈文大众获益。三业供养即为三也。次有二偈解脱月请生后地文。第二正释文内有二段经。一发起净。二自体净。发起者趣地。方便生后地中三聚净戒名发起净。三聚净戒地中正行故名自体净。就初文内有三。初金刚菩萨结前生后。二何等为十下正释发起。三菩萨以是下结成利益。二自体文大分有二。一明行体。二辨地果。初行体文有三。先解律仪。次释摄善。后辨摄生。此十地内科文不定。初及第十同分为八。此地为二。三四九地为四。五六同三。第七地为五。八地为七。各随一法耳。此为地法甚深故方便影显。非唯一地有斯一门也。就律仪中大判有二。第一明其性戒成就顿离诸过。第二菩萨如是下毕竟护持。就初文内复分有二。初明自性成就。二远离一切下顿离诸过。又论云此二种朋者。忆二家语往其二家诈为亲朋也。又经云此闻不向彼说此坏故等者此辨持意。恐彼此相坏故不说也。又第十邪见中七种邪见异相者。一异乘邪见依别出世行。次二依似法起。仍记无记分二也。次一依无中妄计。次二依隐伏法生。仍一用内一用外分二也。次一依世间法生也。经脱第一第三句等文。又决定深信是异乘。罪福因缘是覆藏见。如文应知。宜须思准也。余文如论。第二摄善法戒文。文别有五。义别有四。要摄为二。言文五者如下文中。五处举经论别解释。义别四者。一智。二愿。三观。四行。初思众生。随一切恶皆由十不善道。是其智也。我当自住等是其愿也。此文有三可知也。又深思惟下乃至如来是其观也。是故我应下是其行也。要为二者。初二一对智为方便后起正愿。后二一对观为方便后起正行。余文如论。第三摄众生戒文大分有二。一广明摄生。二诸佛子是菩萨如是下总结摄生。余义如论。又问杀生等得二种人中果何也。答此之习者非是气习。此名残习。顺人道业者在人中别报受。正报随断等者仍是人中不定报也。宜可准之。若以名言求之二报亦有忧劣。有无不定。此可思之。迳历三道义亦不定。广如大论说也。又二倒恶意专念行者伺缘名意。常乐二倒缘中现起故名意也。违理名恶。是起烦恼作意而生名专念行。二倒恶心非专念者。根本集起是其心义。我净二倒望前常乐。根本集起故说为心。我是常本。净是乐原。此二性成。非作意生名非专念也。又追后报中经脱障中第八句共中第一句也。又界差别内。第二别句内经中第一句是论中第三句也。第二地果文内三果同前。调柔中有三。一调柔相。二菩萨尔时下别地行相。三佛子是名下结说果相。前中有三。初法次喻后合。法中有三。一见诸佛起行之缘。二能练行。三所练净行。能中有三。初明供养。次明回向。后受十善法行。依经略无回向。摄报同初地。依摄论中二地已去有八种清净。此见多佛即彼见佛净。此中衣被乃至恭敬心即彼信净。此中净戒即彼波罗蜜。此中作王即彼第六成熟众生。此中念佛即彼心净。此中为首等即彼慈悲。此住千劫等即彼生净。此动地等即彼威德。余地准此。三重颂文有二。初明说意。第二正颂。颂有二十六文分有四。初二颂发起。次十六偈颂自体净。次有七偈颂果利益。次一结叹。自体文中初有四偈颂离戒净。次有四偈颂摄善法。次有八偈颂摄利生。利生文内初有三偈颂愿行集等。次有五偈颂集果文。果利益中初二颂调柔。次四诵摄报。次一颂愿智

第三地内六门曰前。一释名者。随闻思修等照法显现。故名明地。二所离者。依地论闇相于闻思修等诸法忘障。依摄论心迟苦无明。闻思修忘失无明。复有二无明。一欲爱无明。二具足闻持陀罗尼无明。有二业障及一报方便生死。三明所显者显胜流义。四明所成即成忍行及四定也。五明所得果。通达法界胜流文句功德得无边法音。及能满一切众生意欲果及三地位。通果如初地。六释文者有三。一偈颂发起。第二正明住地体。三偈重颂。初偈文中有二。初有六偈。大众三业敬赞前说。此中有三。初一喜。次一雨华。次四叹德。二四偈生起后请。此中初三偈是大众请。次一解脱月请。就第二地体文差别有四。一起厌行分。二厌行分。三明厌分。四厌果分。初文有三。一结前生后劝修起入。二何等为十下正辨起厌。三菩萨以是下结行能入。就厌行中有三。一修行护烦恼。二修行护小乘。三修行方便摄行。初文有二。初十辨无常。次十无救者。就护小乘中有三十句。初有十句明求佛智护彼小心。后二十句念益众生护彼狭心。前文有二。初总次别。二护狭心中。初十起悲。后十救度。度是悲益。亦可初十是其悲心。后十是慈心。于前中初总次别。于后救度十心中。初牒前起后总明度心

第二别明度心。别中九句。初三度处。次二度行。次三辨前。后一度果。三方便摄中此内有五。一起观方便。牒上三心起后观求。二即时欲具下标趣方便。标其佛慧彰其所趣。三作是思惟下观求方便。观察推求度众生法。四即时知住下正知方便。五菩萨如是知已下转修方便。修闻法行摄取正法

第四正知方便者。前念众生堕在烦恼业苦之中。以何方便而拔济之。令得涅槃毕竟之乐。即知不离无障碍智者是如来智。智由何生。即知不离八地已上如实觉起。觉由何生。即知不离四地已上无生行慧。慧由何得。即知不离三地禅定。定由何生。不离闻法。是故菩萨先求正法。既闻法已。静处思惟。思已修习入禅无色。依此禅定观法无生起出世慧。依无生慧如实觉。依彼实觉得无碍智。既得智已便来救生。知相如是。第五摄生方便文中有二。初明求法生难遭想能舍外财。此文有二。初生难想。二但于说法者下重人轻宝中有五句。此即为一句。为求法故是第二句。为法舍施。又为求法下为法走使为第三句。破除憍慢无苦不受为第四句。于上不恭为憍慢。于下执我名为我慢。于等自大名为大慢。若得一句已下得胜财心即为第五句。此中入校量总成有三句。此初成一句。得闻一偈下第二校量。是菩萨若有人来下是第三校量。余文可知。第二又如所闻下随文能行。释厌分中文分有三。一牒前闻法静处思量以起后说。二明厌体。三明入意。为顺法行而不乐着。第二文内。初禅中即离欲恶不善法者是离障也。释有四种。一总相释除欲界恶不善故名离欲恶不善法也。二依龙树远离五欲名为离欲。断除五盖名离不善。故龙树云趣向初禅远离五法断五法矣。三依毗昙五欲离故名为离欲。断十恶故名为离恶。除五盖故名为离不盖。四依成实断贪欲心名为离欲。亦舍杀等名为离恶不善法也。有觉有观者是对治也。粗思名觉。细思名观。故龙树言。譬如振铃。粗声喻觉。细声喻观。离生喜乐是其利益庆背欲恶。是故生喜离过倚息。故名为乐。入禅行者是其定体一心支也。何故独此名为禅行。一心禅体故名禅行。就二禅中灭觉观者是其灭障。灭障之中觉观有三。一即定心。二出定时。三识身中粗动觉。此二并是动乱之心。二禅胜静同皆灭之。言内净者是对治支。若有觉观浊乱不静。此禅胜静离彼外乱故云内净。言一处者彰其治相。彼内净心住于一境。更不余缘。故云一处。故彼舍利阿毗昙言。欲界地中心行六处。以六识身取六尘故。初禅地中心行四境。以四识身行四境故。以初禅上无鼻舌识故。但云四耳。二禅已上心行一处。唯意识身缘法尘故。又复相续无间不断亦名一处。下论释中具此两义。无觉观者显其能治。能治觉观。前灭觉观直彰离过。如说灭谛以为无漏。今就能治彰无觉观。如说道谛以为无漏。定生喜乐是其利益。前初禅中创背欲恶。庆离故喜。今此禅中法从内生。庆得故喜。乐同前释。入二禅行是禅体一心支也。就三禅中。言离喜者是灭障也。二禅喜心分别想生动乱多过。此禅定心转寂故灭。行舍念慧是其对治。言行舍者是其舍支。行心调停舍彼喜过。故名为舍。此是舍数简异舍受。故彰行也。言忆念者是其念支。念前喜过守心一境。故称为念。念与忆俱通伴而说。故云忆念。忆能发悟助念力强。所以通举。亦可即说念以为忆。如四念处体性是慧而名为念。此亦同然。言安慧者是安慧支。分别喜过说慧。慧静名安。身受乐者是利益也。释悦名乐。言身受者。受有二种。谓身与心分别有二。一约根分别。五识中受依色根生。故名身受。意识中受从意根生。故名心受。二约所益分别身心。下品之受释畅在心名为心。受上品之受释遍身心。就所遍处从末为名。故曰身受。今从后义。乐处心法。此处增上遍满身心。故说身受。显乐增上乐是心法。心中受之义不待言论。言诸贤圣能说舍者此乐深胜唯有贤圣。能说为过。堪能舍离。非凡所能。彰此乐深。言念受乐入三禅者是其禅体一心支也。谓念自地受乐之过以入一心。就四禅中断苦断乐灭忧喜者是灭障也。革绝四受明禅不动。言断苦者苦实在于二禅中灭。为欲禅彰此是不动免绝四受故此说断。亦可指彼三禅之乐以为苦故。断三禅乐即名断苦。何故如是。彼三禅乐望粗心人说之为乐。望后静心即是大苦。如似世间指手打木于彼寤者说之为乐。睡眠之人用为大苦。此亦如是。故说断乐。断乐者断三禅乐。彼乐粗动。故此断之。先灭忧者初禅灭也。先灭喜者三禅灭也。并在前灭。是故言先。既非此灭。何故论之。亦为显此不动禅故。若使忧喜前地断故彰先灭者苦亦先灭。何不说先。释言彰先。理亦无伤。但此为明苦虽先断对苦之乐此中断故。对乐之苦不得言先。若当说言先断苦者。人谓彼乐亦是先断。故不彰先。忧之与喜能对所对。并是先断。故云先灭。不苦乐者是其利益。余禅之中皆先明治。今此何故先说利益。乘前所明断苦断乐。对之即明不苦不乐。彰益义便。故先论之。行实在后。此乃舍受不同苦乐。是故名为不苦不乐。何故不名不忧不喜。释有三义。一以此禅正断乐受而复无苦翻对彼二。是故名为不苦不乐。二前文中先断苦乐故。此偏对之明不苦乐。三五受中忧喜名别。三受分别。忧喜二名摄入苦乐。苦乐宽故。舍受对之名不苦不乐。舍念净者是其对治。舍是舍支。念是念支。前三禅中有乐故舍念不净。今此无故舍念净也。入四禅行是其禅体一心支也。四空定义广如别章。此应论之。四空定文如论分别。顺法行者。为依禅定顺起无量神通等故入诸禅定。非爱着也。余文如论。释厌果中分文有三。一明无量。二明神通。三总结自在。余义如论应知。又四无量中经脱不二又清净并无念中二句也。又身通中经脱第六注水句。他心中经脱第七妄行正行句。就释地果文分有三。三果同前。调柔果中大判有四。一调柔行。二忍辱行德。三明别地行。四结说相。前中初法次喻后合。法中有四。初见多佛起行之缘。二供养下明能练行。三于百千劫下明垢障薄。四不复积集下明所练净。余文如论。第三重颂文有二。初生起。第二正颂。颂有三十五偈。初二颂十深心。次二十四颂厌行文。次二颂厌分及以果分。次六颂调柔三果经文。次一总结就厌二十四。初四颂护恼。次六颂护小。次十四偈颂方便摄也。第四地中六门同前。言释名者。不忘烦恼薪智火能烧故名焰地。二所离者。依地论离解法慢障。依摄论微细烦恼行。共生身见等无明复有二种。一三摩跋提爱。二行法爱又灭二业障及一种方便生死。三所显者显无摄义。四明所成者成精进行及道品等。五所得果者。若通达法界无摄功德得如所应一切众生利益事果及四地位。通果同初地。六释文者文内有三。初偈颂生后。二正辨地体。三以偈结前。初有八偈。一有两偈菩萨供养。次天女供养。次三天王庆遇以兴供养。次一大众请。次一解脱请。所以此有王及女请彰此地正体智及外用俱成故也。就体文中大判有四。一清净对治修行增长因分。二清净分。三对治修行增长分。四彼果分。初文有三。初牒前生后劝修趣入。二明行体。三菩萨以此下结行利益。又论云处顺行者。地前方便思量正地而未证得。正在地中名曰已证。此二处行同依所说故名顺行也。余文如论。清净分有三。初总次别后结。总中有三。一明佛家转有势力。二得内法。三谓十智教化成就。又论云如来自身所有诸法以是诸法显示如来者。人法互显佛证得法还以胜法显示如来也。修行增长文有二。一护烦恼是自利行。二护小乘是利他行。此二各有初总次别。又护烦恼中就身念中。先观内身。次观外身。后二合观。何者内身而复云外。若当就彼十二入中分内外者。若自若他六根为内。六尘为外。今四念中自身名内。他身为外。何故初别而后总乎。释有两义。一破病不同。有人着内情多。着外情少。如人为身弃行妻子及诸财物。着内多故须教观内。有人着外情多着内情少。如人为欲财丧身为欲没命。着外多故须教观外。有人内外俱着故须合观。二随观始终行者本来于自身中取有净相。故先观内。内求不得谓外有。之故须观外。向者观内不及其外。观外之时复不及内。是故第三内外合观观内身者标别所观。循身观者明其观相。循犹顺矣。其身相审悉观察名循身观。精勤一心明其观仪。行者今欲破坏身相。非勤不辨。故须精勤。故龙树云。离别常人易。离别知识难。离别知识易。离别亲戚难。离别亲戚易。离别自身难。行者今欲离别己身必须精勤。勤由专意。故云一心。除世贪忧彰观所离。何故此中偏离贪忧。如龙树说。行者此中多生贪忧。故偏除之。云何多生。始弃五欲念本所爱。是故生贪。未得道法。所以生忧。是故但言除世贪忧。又复贪者凡夫多起。着境难舍。受生之本三毒之初故。烦恼中偏说除贪。忧心一向贪欲者起。障定最重。禅中先离。故五受中偏说除忧。若说除贪结余法随之。若说除忧诸受随遣。譬如破竹。初节为难。若破初节余节皆随。贪忧亦尔。下观外身及观内外类亦同然。就受念中。亦初观内。次外。后合。十二入中。受唯在其外法入摄。故今四念中自受为内。他受为外。又复意相应之受说以为内。五识相应名之为外。亦得定受说之为内散受为外。于此内初别后总。就心念中。亦初观内。次外。后总。十二中心唯是内。意根摄故。今四念中自心名内。他心名外。又复意识名内。五识名外又得定心说以为内散心为外。就法念中亦初观内。次外。后总。内谓心法。外谓非色非心不相应行及三无为。第二正勤义者。初二断除恶法。后二摄善。前离恶中。先断未生。后断已生。斯乃说时非是行体。亦可已生是其先成无明住地。细故后断未生是其四住现起。粗故先断。未生恶者举其所断。为不生者勤之所为。欲生进者勤方便心。发心断者正明勤体。已生之中类此可知。已生谢往云何可除此。乃断于已生种类在未来者令不相续。非谓断于起已灭者。后生善中。先起未生后广已生。善非本有习之方起。是以要须先起未生后广已生。未生善者举所修也。为生故者勤之所为。欲生勤者勤方便心。发心行者正明勤体。已生同前。已起谢往。云何可策。此必策彼已生种类在未来者令其续起。非谓策彼起已灭者。第三如意义。就此文中。初总标举。后别释。言欲定者直举行体。欲能生定因从果称。故名欲定。亦可定心由欲而生。举因名果故云欲定。断行成者辨其功能。以此定行能断众结名断行成。亦可名彼涅槃名断。断家行成名断行成。修如意者就前欲定明其修也。依止厌下明向第二断行成也。于诸烦恼初方便道观过厌背。名之为厌。无碍正断。说之为离。解脱证除说之为灭。趣向涅槃名为向舍。若随位分。见道已前说名为厌。除见谛惑说以为离。断修道结说以为灭。得涅槃果名之为舍。此乃诸行治结次第。不须别对念处行等。余行类尔。何故念勤不明此者。得定成就方有此能故前不说。精进可解。心定者余经论中为念定。系意住缘。故称为念。专心守境。故说为心。思惟定者余经论中名为慧定。慧心筹虑故曰思惟。余广如论耳。二护小中五行内经脱第三句。彼果胜中。初明行果。次别地果。行果有六。始从离恼尽第六本心界满。经中略无第二业染。余义可知。又离恼中文虽背异意亦得足耳又论中业染者有二义。不作一敬佛故佛所呵即不作。二畏恶名失利他。生烦恼失自利。故不作也。增上欲中第三离过别句内脱第一句。发勤精进中经论似有不次。但依论文次第消息。意亦无失也。本心界中亦如是。地果文内三果同前。调柔果中文分有四。一调柔行。二摩尼珠下明教智净。以此地成就净证从体起用。故有教智不同前地。三四摄下明别地行。经本略无此句。四是名下总结说相。前中初法次喻后合。法中有三。一见诸佛为起行缘。二恭敬下辨能练行。三是菩萨乐心下明所练净。余义如论应知。第三重颂中。初辨说意。次正偈颂有二十九。初二颂增长因。次三清净分。次七颂对治修行增长分。次九增长果。次七颂调柔摄报等三果。次一总结叹也

大方广佛华严经搜玄分齐通智方轨卷第三(之上)大方广佛华严经搜玄分齐通智方轨卷第三(之下)

        终南山至相寺沙门智俨述

第五地内六门同前

一释名者。得出世间智方便善巧能度难度故名难胜地

二所离者。若依地论离身净我慢障。若依摄论下乘般涅槃无明又有二障。一生死涅槃一向背取思惟。二方便所摄修习道品。又治二业障及一报因缘生死

三明所显。相续不异义

四明所成。禅波罗蜜及学四谛

五明所得果通达法界相续不异功德得与三世诸佛无差别法身果。及成五地位。通果同前

六释文中大判有三。初偈颂生后。二释地体。三偈结前。初十五偈。一有二偈菩萨顺修供养三业庆喜。次二天王赞佛菩萨无染功德。次十天女赞因及果大慈悲用二位圆备。次一解脱请显入后证。就天女文初七叹因。次二赞果。次一显行成因证矣。地体有三。一胜慢对治。二不住道行胜。三彼果胜。前文有二。约慢二种。一自地慢。二他地慢。他地者前四地中得出世智。取彼胜相名之为慢。下以十种净心为治。二自地慢于此十中悕求胜相。复以为慢。下以随顺如道为治。此二文中通名胜慢。慢治同故。初文有三。初牒前生后劝修趣入。二辨十心。三菩萨以是下结成利益。又同念不退转心者。方便净心与不退证心同缘正理不异也。又文中七净者。一戒。二定。三见。四度疑。五道非道。此五大小名同。后二名异小乘。后二者一行净。二名行断。以彼宗趣灭故。大乘名者一名行断。二名思量菩提分法上上净。以此宗依行断起胜求故。行虽有七文有六句。第三句中有二种净。谓见行净及度疑净。余相可知。位者若依小乘戒及定见道前。次三见道。次一修道。次一无学道。大乘三位论之。行断及行在修道中。余悉同前。所由如大疏也。二随如道行有三。一举前起后总显如行。二得大愿下别明随顺如道行相。三生定不退下总以结之。就初总中法体有三。句别有四。法体三者。一是四地所修道品。二此地前十种净心。三此地中顺如道行文四可知。不住道中经文有二。初列四谛实法分别。是护烦恼自利行也。第二化众生分别。是护小乘利他行也。前经有二。初列四谛实法分别。后就此四明十观门。即化生分别。此文有二。初列十名。二次第解文。四谛门中义含法界。菩萨于中穷照无遗。随智异论旷别难穷。今此且就一数之圆略为十门。然此十门菩萨自知。知相难明。故寄化生以显其异。斯乃约化显自知耳。以此通名所知法中智清净故。言开合者此之十门总唯是一化生分别。若随所化大小分二。前九化小。后一化大。随化所起分以为三。前五化生令其生解。次四化生令其起行。后一化生令其入证。约人不同离以为七。初谛化于根未熟者。第二化于根已熟者。第三化于疑深法者。第四化于谬解法者。第五化于离正念者。第六第七第八第九化正见者。第十化于大乘可化随法不同分以为十。若广分别数别无量。言对实法辨通别者。此之十门望前四谛一一皆通。初世谛者通观四谛法相差别。第一义者通观四谛体性空寂。言相谛者通观四谛非有非无。言差别者通观四谛有无各异。说成谛者通观四谛缘起集成相状事也。言事谛者通观迷四谛成苦等事也。言生谛者通迷四谛起作集也。尽无生者通解四谛得证灭也。言入道者通解四谛得成道也。菩萨如来地成谛者通穷四谛缘起实性清净界成大乘道之因果也。又此谛者前四谛直明法界体性无非四谛也。下事等四谛是有非四谛也。中间五谛是方便修相解观次第。后之一谛明正称周法界自体因圆通妙道无障碍德备也。若约教缘法相差别时。初四谛直明法体。次世谛第一义谛明于相。次相谛者明一实谛相。次差别者明法界法相。成谛者明如此法界相以凡夫迷倒故菩提为烦恼。三界繁兴炽然于世众相集成也。次明事四谛显正修对治方便行也。然此有非四谛。乃是菩萨正修方便法。而但以法通无局故。二乘亦得于中修进。下至人天善业亦于中行也。今但此菩萨正修对治方便道满故。能显发称周法界自体圆极无障碍道故。欲明于菩萨地次第入如来智谛故也。此观意如论。信解智非无尽智知者释前如来谛文。谓因智知非果无尽智知也。又可说文字阿含。信智知非不可说义无尽智知也。此文约解简耳。下离世间品中重更简文者约行简也。释云镜像智者。三乘见道前依定成事。如镜中像成事自在也。其位不定。或见前暖等四善心。或光得等四定。或地前四十心。或十行十回向等。或世间修慧。乃至得定已去即是其位也。二护小乘勤方便文分有二。一观有为虚妄诳诈恼于众生起悲慈念。二得如是智慧下别明悲慈。此文有二。初明化他愿。二如实观一切有为下明化他心。此文有二。先悲。后如是苦恼等下辨慈。悲文有二。初起悲方便。二知众生下正明悲观。于中有二。一观如实苦知苦体性。二又作是念下观深重苦。就人显过明其可悲。就深重苦内经文有二。一观众生怪生受苦不知厌离。二无明痴故下明诸众生可怪所以。于中有二。初明深苦。二如是生死下明其重苦。二释慈文中大判有二。一为众生修习善法。二如是思惟下随其所修发愿饶益。初文有二。一于众生念恶无始。此经文脱第三句第五句第六也。二唯我一人为集善法。二发愿饶益中。初一总后九别。此中经文亦有不次。依次消文义亦无失。释果分文大判有四。一摄功德胜。二修行胜。三教化众生胜。四起随顺世间智胜。前二自行。是上所知智清净果。摄功德者自分所成。修行胜者胜进所成。后二利他。是前利生勤方便果。化生胜者化他之行。随顺世智者化他之智。余文可知。四随世智中。初总辨意。二知世所有下别释化智。别中有十。一知书等。二知石性等。三治病方。四作论等。五日月等。六持戒等。七不恼生事。八安乐生事。九怜愍故出。十渐令信入无上佛法。经第三中阙二句。第四义中无一句。余文如论。又论中难解。吉凶入等随时变相。遍身相者是报定相。随时变相有八。日一月二星三。星谓五星。东方岁星。南方莹。或西方太白。北方辰星中有镇星。以为五星。四宿者二十八宿。谓角亢等五星。于中止宿故名为宿也。地动为五。梦六。想七。吉凶为八。狐鸣等并吉凶摄也。又七曜者日月五星是也。入者顺也。过去世八相之业又顺未来八相所表之果也。又遍身诸相者定报爱非爱果相也。又五行对五染者。持戒治破戒。四禅治贪欲。神通治邪归。四无量治妄行杀生祭祠求福等。四空治妄修解脱外道邪修等。就地果文中三果同前。调柔分四。一调柔相。二又如日月下明教智净。三别地行。四结说相。经阙第三句。初文法说次喻后合。初明见佛为起行缘。次能练行。后所练净。能练行中。初供养。次修回向。后受法行。经多不足。又四五地中出家果在调柔中。所以者四地已去得出世无漏行。出家义显故。余义如论应知。三重颂文。初辨说意。次明偈辞有三十九。初十一偈颂胜慢文次十三偈颂不住道胜。次有七偈颂不住果。次七颂调柔等三文。后一结之。初胜慢内。初二颂平等。次九颂顺如道行。不住道内。初四颂智净。次九颂勤方便利生文。第六地内六门同前。一释名者。般若波罗蜜行有间大智现前。故名现前地。二所离者。依地论本微烦恼习障。若依摄论微细相行无明。此文寄在七地。复有二障。一证诸法生起相续。即迷俗也。二相想数起。即迷真也。又治二业障及一报因缘生死。三所显无染净义。四辨所成成般若波罗蜜及解得缘起。五所得果者。通达十二缘生真如无染净功德。得相续清净及能清净一切众生染浊果及六地位。通果同前。六释文者此文有三。初偈颂生后。二辨地体。三偈颂结前。初有十八偈。前有二偈。菩萨赞叹。次二诸天三业供养。次二天王及以眷属赞叹地义。次有十一天女赞地体及诸别行。次一解脱请入后证。女文分三。初一伎乐供养。次九正叹果德及因。后一默然观佛。就前九文中。初四叹果。次五叹因。因文有三。初一大悲行。次三六度行。次一结成德用。地体文中大判有三。一胜慢对治。二不住道行胜。三明彼果胜。初文有三。一牒前生后劝修趣入。二辨相。三结行成。初明胜慢对治者。明十平等法有二种意。一解境。二行境。言解境者即此十门为所轨法。不住道下明所依行观门方便。言行境者即十平等是观解初不住道下明观成相。又依论别定其文亦好也。就十平等释相有二。初一总。次九别。九内有三。初七以无破有。次一以有破无。次一有无双破。初文有三。初一空解脱门即无相观。次五无相解脱门即无生观。次一无愿解脱门即无性观。行次第者此举解成行外。疑云若诸法无云何住持久立决定为答此疑。故经云无性故。言无性者无实性也。又云若诸法无云何现见实有。为破此疑故。经云一切法无相平等。又疑云若法无相者有处法生有处法灭。取心随见不由自意。云何无相。为破此疑故。经云一切诸法无生平等。此下自体空不如无相等故异前也。言无生者一切诸法并从念生无有自立。云何云有。如论念展转故。又云若法从念生即因缘非一。念等诸缘我尽不见。唯见所成安立之法念等不见。自可是无。所成之法应说是有。为破此疑故。经言无成故。言无成者既法从他生汝不见彼从缘而发。既许法从他生汝不见此相。当知所见即是自谓不得实境。妄见所成。故论云无成平等。此二迷苦谛。又云若诸法从他生无自生性。我许非有。能成之因既得成他此有力能。应说是有。为答此疑故。经云一切离故一切法平等。依经在第八句。言离者但所执境情谓是实。论彼所见即无所从。一非先有。二无实理。所以知若从缘生即似非实。故知所见即相非有故。论云染相故。此即计集谛。问若是集谛即心聚摄。解既在境。云何应集。答论能取体乃应缘似。烦恼业用计谓境中。境即是无。义归取相。故说是集。又云诸法因缘寻彼本末俱不可取。究其此意。染法依实迷真而生。染可说无。所迷真俗灭道二谛顺理应有。答汝谓真俗顺理是实。此义不然。灭道真俗乃是梵行正智境界。云何乃云如谓是实。为破此疑故。经云本净平等。若如谓是实。即杂染心生。不可言本净。故论云净相故。此迷灭道二谛。又云若法不如所见是实有者。即不应起世间言说。现有名种种不同即验所目之义非无。答如言所执名非一者。是世谓施设非先实有。所以知。但见世间得义不得名得名不得义。故知诸名不定从义。汝谓义实起名等。此即戏论非实有也。为破此疑故。经云无戏论故。名不实有赖义而生。义不自彰依名而显。此即验。是戏论因缘。又观义因不见名果。又观名果不见义因。此似戏论亦无故。论云分别相故。所以唯说分别者为显即相空也。此迷四谛名上已无生观说。又云我已知相是无了生非有。即验如实决定可趣。答汝谓自见为妄非有。别见离念为可取者。还是分别故。经云无取舍故。无取舍者本为情谓。是取所见。并皆不真。今还见离念为所趣。即同前妄。故论云出没相故。所以唯言出没为出没即空。上来以无遣有。又云我寻相生是无。又知离念非有。当知染净真俗等法并无其体不可进趣。答汝见染净不可进趣谓无法者此义不然。为破此疑故。经云如幻梦等。若法并无者云何有处梦有处不梦。验此即知。一切诸法不定是无。故论云我非有相。所以为破我无唯言无我者。此为离我不住无我故。缘成幻事此不同上见。此即以有破无。又云所以前起八种见为不尽理以无破有。复起一见。又不尽理已有破无。我今体寻不可偏有无取。今具成二义。此可当理。答如外所见由不越情。所以知如所见境无义非有义。有义非无义。据其理也。即无是有。有无是一。为破此疑故。经云有无不二。言不二者法不自住。应缘成起。复不是缘故成果法。寻其诸法不越自他。自他不住。即事辨空。若如见有无此由不越自他两际。故论云成坏故。所以但言成坏者。谓成坏即空故不别求。当知不二平等之法非除灭有无说为不二。此即如实即验。所谓有无名为戏论。亦非有无二法之中别立一法以为不二。不俱取同上以因缘法有无同体各非自性。说彼无法以为有故。有即非有。还即说彼有法为无。无则非无。有非有故。无外更无别有为二。无非无故。有外更无无法为二。故曰有无不二。又复说彼有无之法为不二故。亦无不二自性可取。此破有无双计。第三结文有二可知。义相如论耳。上约十二入明所轨法。下约十二缘生辨所依观门。问上明法唯约十二入。下诸观门何为偏在缘生。答摄法取宽故。约十二入以通依正。今约观门摄外。从内故局缘生。此文有二。一就初住以明不住。即总立宗。二作是念下约彼正住以开观门。即别释也。前地劣故正住地中方名不住。此地胜故初住地中即名不住。初文有二。一观法相等牒前起后。言法相者牒前文中十平等法。随顺牒前得入六地。此依论经可准之。二复以胜大悲下正显不住。于中通下六句分别。一释其名。对前观故说此为复。大悲首者念众生心。拔苦为悲。悲增曰大。大悲增者求心愍至称曰增上。亦可求于增上果故名为增上。为求佛智利众生故名曰大悲。言满足者。离有为心厌有为故观察缘起。观之穷尽名为满足。此即经论二处不同。若依论文为有四句。即以第四生灭一句依前三门以成行相。若依经本第三即生灭。即用生灭为满足观。据经论二处。即有二意释生灭门。一依论者。所谓众生菩提因缘并是有为。今以智知故云观生灭。二依经者。因缘之法顺生逆灭。本为救生故云大悲。又若依经成四句亦得可知也。二明三心次第之义。乘前观空法便念众生虚妄所缠。故先起悲。以悲念故求佛智慧欲以利益。故起第二。佛智必由离过所成故起第三。三就自利利他分别。前一利他。后二自利。四护烦恼护小分别。前二护小。后一护烦恼。五就因果。初后摄因。第二求果。六不住分别。初一利他不住涅槃。后二自利不住世间。二就正住别辨观门。初通经论科简观门。第二释义。初门有三。一就经科。二就论科。三将经论相对分文。就经科中。初别明十观。二重结之。十观是何。一因缘分次第。二三界虚妄下明一心所摄。三无明有二种。下明自业助成。四无明令行不断下不相舍离。五无明爱取下三道行。六无明行是过去下明观先后际。七无明行乃至六入下明三苦集。八无明因缘行生下辨因缘起。九无明因缘是生缚下辨因缘生灭缚。十无明因缘是随顺有下是随顺无所有尽观。于中并各有顺逆观。即为二也。经文如此。二次就论科。论家就此十番观中三门分别。一就厌离有为心中观十二因缘。此即是前满足生灭门。二就深念众生心中观十二缘。下说为悲随顺观。言随顺者此即起悲随顺缘生。即是前悲为首。三求佛心观十二缘。论文名为一切相智分别观。此即是前悲增上观。问前初住先明悲首。次说增上。后彰悲满。今此何故先满次悲后说增上。前初住中生心次第故。先悲首后论悲满。今此是其正行次第故。先悲满后说增上。是义云何。前初住中乘上十法观法空寂。便念众生妄有为法之所缠故。故先起悲悲。欲拔苦须得佛智。次起增上。佛必由离有而成。故明满足生灭等观。今正行中离过为始。先厌有为。因自离过。便念众生处之不出。次辨随顺。前二摄因。理必在前。一切相智是求果行。理须在后。此三门中各有十种观因缘集即为三十。一一门中各有逆顺即成六十。上来分别但依住地明六十番。对下果分有一百八十因缘观门。所以知然。寻果分文以三空门分别缘集。据此门下各摄不同故。经云依空解脱得十空三昧。无生无愿亦复如是。据此三空便有三义。若以空三昧观十二缘即十二缘皆空。所以知已论主将分别无相配空三昧。若以无相门观十二缘十二即似。若以无愿门观十二缘缘生即实。论中又说无相观门为真实性。由真实离相。故以配之。以无愿配无生。为依他无生无所愿求故用配之。此等因缘同异法门。准下十空三昧思之可解。第三以论对经。文分齐者更有别意前依经本十番即成厌离有为因缘等观。故据前后经本十番成一百八十门。又问若依经论无有六十门观相。云何得成一百八十门。答由经初开三观门。后论主仍许经本二十番。而更别辨三门四门九门等。今以前开三观门验。后经中观体。即知定有六十门也。今以论对经摄十门为三番。意从一观厌离有为。此意下更分别。然论摄经分齐者。就厌离有为观中。摄彼经内十番观门以之为三十中初门。即以为一。名成答相。次有半门复以为一。名第一义。后八门半合之为一。名世谛差别。第二大悲随顺观中摄十为四。初门为一名观众生愚痴颠倒。次一为一名余处求解脱。次三为一名异道求解脱。后四为一名求异解脱。一切相智分别观中摄十为九。初有半门说之为一名染净观。次一门半复以为一名染依止观。次有五门各别为一。次有两门复合为一名无始观。次一为一名种种观。通前为九。此三门中文之前却后当分释。二释义者。依大经本。法界缘起乃有众多。今以要门略摄为二。一约凡夫染法以辨缘起。二约菩提净分以明缘起。约净门者要摄为四。一本有。二本有修生。三名修生。第四修生本有。言本有者。缘起本实体离谓情。法界显然三世不动故。性起云众生心中有微尘经卷。有菩提大树。众圣共证。人证前后不同。其树不分别异。故知本有。又此缘生文十二因缘即第一义。言本有修生者。然诸净品本无异性。今约诸缘发生新善。据彼诸缘乃是妄法所发真智乃合普贤。性体本无分别。修智亦无分别。故智顺理不顺诸缘。故知修生即从本有。同性而发。故性品云名菩提心为性起故。问本有修生既是新发义。非是旧。云何乃说从其本性。答此品为是新生之义说是修生。与本义亲。故从性起。如今谷不别劫初。顺本谷亲。对今缘疏故。不说新得。此思可解。三修生者。信等善根先未现前。今对净教。赖缘始发。故说新生。故论云彼无无分别智故。四修生本有者。其如来藏性隐在诸缠。凡夫即迷处而不觉。若对迷时不名为有故。无相论云若有应见。又依摄论云有得不得见不见等故也。今得无分别智始显法身在缠成净。先无有力同彼无法。今得成用。异本先无。故不可说名为本有说为修净。问若说始显为修起者名曰修生。云何说显。答只为是显修生门中义成本有。先在迷心不说体用。今时始说有彼法身。故知与彼新生是亲。先有义疏。如论云。离不离无常。既言无常。不可从本有。上来四义于此缘生理实通有。若对经分文。此十番缘生唯有二门。一修生。二修生本有。余二在性起品。第二染法分别缘生者有二义。一缘起一心门。二依持一心门。缘起门者大分有三。初真妄缘集门。二摄本从末门。三摄末从本门。言缘集者。总相论十二因缘一本识作无真妄别。如论说。依一心法有二种门。以此二门不相离故。又此经云唯心转故。又如论说。真妄和合名阿梨耶。唯真不生单妄不成。真妄和合方有所为。如梦中事知与睡合方得集起。此是真妄缘集之门。二摄本从末者。唯妄心作故。论云名种子识及果报识。对治道时本识都尽。法身流转五道名为众生。随其流处成其别味。法种众苦如此非一。故知摄本从其末也。问当随染时为即染也。为由是净。答体是净本复是净不可名随。故知染时不可为净。若尔者不应说言依如来藏有生灭心。应但是单生灭。今言相依。如此说者是有智人染净双证。故作是说。非局染门。三摄末从本者。十二因缘唯真心作。如波水作。亦如梦事唯报心作。以真性故。经云五阴十二因缘无明等法悉是佛性。又此经云三界虚妄唯一心作。论释云第一义谛故也。问摄末从本应是净品。云何乃在染门分别。答此摄末从本理在净品缘生。今为对染显染如幻故在染门。问义若如此一切净法并对染显妄。云何独辨摄末从本在染缘生。答凡论净品缘起有其二种。一为对染以显妄法故。经云不如实知诸谛第一义故也。二但显净品缘起。即是显理之门。即如普贤性起品等是也。余义准此可解。此摄末从本即是不空如来之藏。此中亦有空义。为自体空。后当分别。二依持一心门者。六七等识依梨耶成。故论云十二缘生依梨耶识。以梨耶识为通因故。问与上缘起一心云何取别。答上缘起一心染净即体不分别异。此依持门能所不同故分二也。问如上诸义并一一门别。云何得成一证境界。答上来所辨并约缘别显。即是证境方便道缘。欲乐既别即今所依观门非一。若寻证境如上十平等说。上来第二释义门讫。次对文释观门别相。就经本十观内。初明顺观。次辨逆观。余皆同此。其逆观相后当释。初因缘分次第者三种分别。一明所治障。二辨观体。三释经文。余皆同此。言治障者治我见执。谓言十二分是我作也。即是身见邪见遍通。若分文别但治人见。此惑通彼三空所治。治相云何。实无有人相。见实人相即空门所治。缘起似我生。不如所取生。计为似相。即无生所治。所以得知有彼似我。故论云自他差别识从我见薰习生。故得知也。成似生及实法相即无愿门。通治前二执。亦可治彼无我空及成八自在见相。所以得知。故论云自体空者有故。此成无性性也。即治惑门。二观体者即显因缘理次第生义。以空及似实等三性为顺观体。逆即成一缘起空无性性观。即用缘起次第理为此观体。即依经辨也。若依论辨但准以思摄。三释文者。就因缘分者即因分也。次第者渐次也。观者照达义。就此以题章也。此文有四。相从为三。要则为二。总摄为一。门别四者。一举彼解惑显成无我门。二依论愚痴下。依经一切凡夫下。责情显理门。三依论无智下。依经常随邪念下。辨相显实门。四不知诸谛第一义谛下依实辨相门。相从三者。四门中初一名成。释成无我中二名答。答显无我。后一名相。谓依二谛立因缘相。要摄二者前之三门宗显无我。即因缘性。后一总显因缘之相。总为一者总为第一因缘分次第。就第三辨相显实中。只由痴爱起诸业行。乃至老死非由于我。于中初顺。次逆。后结。顺中初言无智有无。经云常随邪念。是无明支。无智是痴。求是爱。求常名有。求断曰无也。过去唯痴。实即过去备诸烦恼。痴爱力强。所以偏举。恒随下是行。行有六句。前三行过。后三行体。依经行过三句亦是无明支。以阙论中无明支故。以是行下是其识支。初以是行起心种子。乘前起后。由行熏心令心生后。故说为种。心者是梨耶。二有漏下对后生死显前种义。有漏是爱。取想是见。依经取心心即通想。所谓业为地下复生后有。是名色支。生名色等有七句。一业为地。二识为种。三无明覆。四爱水润。五我心溉灌。六种种见纲。七名色牙生。问如熏习义应业为种识为依地。云何今识为种子。答凡论业种分别有二。一熏习成种时。二引生感果时。若熏习成种时。业为种子以识为地。为识未被熏时未辨有种。今为熏习始说种生。即与上心能熏义亲。与识义疏。故识为地。种为能依。即属业也。二引生感果者。以识为种。用业为地。今言业者是临生。时中阴求生业心为正业种。犹在本识未发。今此上心求生中阴。是种子用相。此用相既非业体。但能引业感得识支。如地引种令得成果。说业为地。种在识内。与彼本识同无记性。先造业识上心已谢。今种现与本识俱成。与识义亲。与能薰疏。故判从识合为种子。此有二义。一是即体。二是异体。此义如上料简中说。问业力无明及诸见等。现今求生用识为依。应从识为种。云何别分为所依地。答理同依识。但有别义不如种子。以种现同识无记性。一体。二相。俱一不分。求生无明虽与识同现变成其色心等别。不如本识体相二义。不可从识为种子也。余文可知。二依止一心观者。即十二缘等能依也。心者即梨耶心。就此以题章。以梨耶缘起为此观体。三门同上。初所治者治彼外境自性执。谓一切境。别治但以惑自性差别积聚等三。通治可知。二能治所依观体者还以三空空似实无生性相为此顺观。故论云阿梨耶识为大空故。无生似实无愿如论思之应知。逆成一观同初门。唯识者有二种。一梨耶识持生诸法。离识即无。二明意识唯识。生死涅槃染净等法现在意地离识即无。梨耶唯识始是解境非行所依。意识唯识此终即是正解所依。心终意始。反前可知。观相云何。如行心见法为境。若无观心觉境。染净等法纵任现前。今知意言所作取谓之心不起。知识作时名用依他遣分别境。问依他与识云何取别。答依他约相。所以知。分别体空相能起识。其识随缘不守自性。此应成空乃现似相。故知约相。二唯识约体。三界唯心。颠倒分别即空。故得知也。识望无性即似非实。体相相成。故通说耳。问如境依心即是果法。似而非无。云何对识辨境即空。答但从心生非分别境。属能缘心依他性摄。所以知。当见境时但见实故。故论主以二谛等文作一依止观也。问后知唯识还是所知。与前谓境有何义别。仍判后境属依他性。答前见境时。不知缘集说唯识作。作义非性见识作。时分杂谓染。缘集作理违分别性。故知别也。遣实境灭时即得一分空无相性。无相现故。唯识想境并则不生名得无性性。此是行门唯识观法。若约生解则三性后辨无性性。问唯识想灭为知无相境遣唯识想。为识想自灭。答更无别知无相观心。但唯识想兼知无性。取想则自不现在前。又亦依前势而得后心不生也。今此文内通二唯识。三界唯心作即本识唯识。如经下偈但从贪心有即意识唯识。此是顺观。此依经辨。三释文者。经本有四。初句立宗。二十二缘分下引圣教证。三所以者何下责。四随事生欲心下答。随者众多义。事者上心作业。生欲心者心是梨耶心。问既言欲心。即是意识。云何言本心。答欲心有二义。一识现起作用分别。二即此识因缘发起作用义边即属其事。能见取边即属意识。因缘发起即属梨耶。为起时同处不可分别。如行诳心名为无明。欲心取境即是不了。岂可欲心之后别辨不了。故知即欲名为不了。但成文故语有前后。事是行者上心分别事即是业行。行诳心名无明者其行现成分别实相。今梨耶识变成不了名为意识。取其实事故名无明。余文可知。此依论辨。问此与经本何别。答经通论局也

三自因观者。自者拣他异之名。唯拣邪因不拣正因。今此观内摄四种因。因缘增上缘缘缘次第缘。以四缘理为此观体。自此已下至因缘观。并用三性相为顺观体。用三空门为逆观体。但义别分有此诸观。于分别性内拣异妄计。三门同上。言所治者治异计因绿执。如修道贪嗔痴实非发业。计具因缘能发生业即戒取见。如自性非因为因及心烦恼。分同此治。二所依观门者明此自因具四缘等能生诸法。此具因缘亲疏二理名俗谛观。妄计不生成一分真也。此经文辨之。三释文者。今言无明有二种作等者。一亲因缘。二是疏缘。一缘中痴是亲因也。二与行作因。即疏缘也。此中摄三缘。余文类可知。又但取疏因。此约论辨。第四不相舍离观者三门同上。不相舍离者无他别时相离生也。三性分同上自因观。初明所治者因果异时计。谓因灭果后生。此即因不生果失。更有余失。思之可解。是戒取见。二所依观门者。以同时生果理为此观体。此亲疏二因俱同时。此约经文辨。观相云何。无明有二种。一子时。二果时。彼二种时非是前后。依子取时名曰子时。依果取时名曰果时其义云何。子者令行不断。果者此子时中所成行果。依此取时名曰果时。问果因同时即别体过。若前后生因不生果过。答我立因果异彼二失。由是同时异第二失。为是因果异第一失。此非逆观。去情说也。但显俗谛理非第一义。所以知同时。故论云有二种义故缘事示现。云何二义。一是因义。二是果义。缘事示现者。依缘二种义示现二种时。如是余因缘分自生因二种义缘事应知。又论引中论偈。云众缘所生法是即不即因。亦复不异因。非断亦非常者。明因果两义各非断常行是无明果不即无明因。由是果故不异无明因。因义反前可知。非断亦非常。行由是果非断。是果无方非常。即此时中无明是因非断。是果因故非常。此义论主削去外情作逆观说。非顺缘生俗谛门。所以得知。论主后自属当经云。自生因缘观义如前说。故知也。此约论辨。五三道观者。三者数。道者通生义。以烦恼业报及通生义为此观体。三门同上。初所治者。对治因缘废事计理执。谓计诸法通因缘理。即废事执理失。故论云若因缘生者一切法俱生。故得知也。问如论文此语属后三际。云何从前以为所治答论主别有异意。科后八门半观。以为俗谛明执是过。故从后说。论主用三道为摄过观。即体是过不可别有所治。今依经本。三道是德故有所治。将在前论。所以知论主别有异意。如前依止一心观分为两门。岂是十番意也。亦有解者。作外人与论主成失若作此释。义转难解。所以得知。疑云若因缘生者一切法俱生。论答云。过去业有二种。一未作业。二已作业。只可未作者非一切生。已作者应一切生。为如是故。今成论主与外成失属前治也。又一因生诸法如计宿作及自性等。分同此治。是戒取耳。二所依观门者对三性分。同上。自因观因缘之道通生诸有。依烦恼道生诸有故。同在有流也。依业生诸有六道不同。善恶有异。依报生诸法相续不断。故得三有成其事业诸相不同。此理事相应理故法齐生。由事隔故不互相生。若但因缘理不藉事生者即三有不成。此依经本辨。三释文可知。依论辨之可知。第六三际观者。三者数。际者显无始分齐。即以三时因果理事为此观体。三门同上。一所治者。治无因执即常见也。谓执诸法不从因生复言未来无生老死即断见也。二能治所依观门者。无明行等是过去世。治现在世执身常见。爱取有等是未来世。对治外执断见过也。此依经辨。三释文者。于是有三世转者谓展转生诸后有也。此明过患耳。余文可知。此依论辨。七三苦观者。三者数。苦是义。三门同上。初所治者谓乐净执。是因缘身具有三苦。迷者不了谓有乐净。即见取摄分有戒见。二明所依观门者。三性同上。理实通论诸因缘。分通三苦。今约相分。无明行等以为行苦。触受二支名为苦苦。爱取有等以为坏苦。行苦渐增治身常住计有乐净。苦苦治身自在有乐净执。坏苦治身究竟计有乐净。此名顺俗观。但以三苦及知苦智为此观体。此苦何得通三性。答如经说不生不灭是无常义等。又云是苦是谛是实。又广如中边论。准之思之可解。此依经文辨。释文者。所以五支名为行者。诸分渐增未对苦具。但行相增。所以触受为苦苦者为此二支对外苦具增。所以爱等名坏苦者是未来世生因缘故违现在身。显其现在非久住世。爱取有体非是坏相。显他坏增名为坏苦。余文可知。此依论辨。八因缘观者三门同上。初所治者谓计单因有力生果。如执自性因能生二十五谛。此身等因缘生。迷者不了谓自性作。即戒取见。二所依观门者三性同上。因缘生理。因有决定用。缘有发果能方得法生。若但因力无缘发果能者。其因六义不现在前。何者为六义。一念念灭。此灭是空。有力不待外缘所以有力不待缘。为因体未对缘事自迁动故。二俱有是空有力待缘。所以者为得外缘唯显体空俱成力用也。三随逐至治际是有无力待缘。所以知为随他故不可无不能违缘。故无力也。四决定是有有力不待缘。所以知外缘未至性不改自成故。五观因缘。是空无力待缘。所以知者为待外缘唯显亲因非有无力能生果也。六如引显自果。是有有力待缘。所以知得外缘时唯显自因。得自果故。问此因缘六义分齐云何。答今言赖缘者。但取因事之外增上等三缘不取自因六义互相发。所以者。其六义者同是理法对因事显。废生因事六义不能自互发成。但外三缘各有理事故。得对显因果之义。若尔六义不应总别相成。答六义六相共成者。六相有二义。一顺理。二顺事。此二义中。顺理义显。顺事义微。其四缘事二义同上。但顺事义增。顺理义微。所以知。因缘生果法起迷义显。为此论主别将六相照令入理。故知四缘顺事增也。所以知总别顺理义增者。为辨六相令见心入理。问何以得知但总别六义得顺理增不取于事。答论主简事不具六相。唯约义辨。故知也。上二微义思之可解。今因缘内各有六义。故说别有胜用能感于果。问如论说。非他作自因生。非自作缘生故。既言非他。云何但取胜力生果。答此举不生形取胜力。若不形夺胜力不成。令此夺中偏取一边胜力属上论主自因观。今此通取二力。不能生义分在其中。准上六义思之可解。有一别空。入后观门至当分别。此即治前独因感果执。业藉缘造后感果时。不赖缘发。此执何失。答若废于缘自因胜力并皆不成。此即俗谛观。即以缘生理事及智为观体。此依经辨。三释文者。因即通亲疏四种缘也。故云因缘能生行。故知也。释名可解。此依论辨。又依小乘六因四缘若依三乘即十因二十因等。若依一乘即随法辨因。为一一因缘理事各别与法界等。今六因义唯一乘能穷。此约别教说也。第九因缘生灭缚观者。因缘牒成俗谛所依。生者所生果法。灭者即离因缘生力。缚者即顺缚。从俗谛依经本阙无。因缘二字三门同上。初所治者。此下二观但治心惑。通义可解。谓因缘共力能感果执。又言因缘法。各有少力。共成一果。其缘起理通有诸义。若见因缘有力共生。即名迷理事分别执。即法我所见。二所依观门者。此用三空门为顺观体。逆成一生缚无分别观。余意下更分别。诸缘生法成俗谛相。不属一缘。但诸已生法随去。一缘果不得立。不简亲疏故。论云。无知者故。作时不住故。若因缘能生不可不住。问若因缘不生而有法者。先因未集亦应生果。又此缚果法因缘生果。二相何别。答因缘生内有二种义。一无自生义故空。二因缘有力故生得果法。此缘缚内亦有二义。一是俗谛缘起。二离缘生力故空。因缘生法。若无生力。果即不成。此缘缚观。若无空义。果即不成。云何是空相。答因内求疏不可得。又求生力不可得。前因缘生果生义。是增空义。是微为因缘法顺生迷增故。今缘缚法空义。是增生力义微为缘起法顺生无分别智故。故下经云。缘起之法离有无也此虽无生力以空力成故。离自性生。经云。无住为本故。问若缘生顺迷增者。此义可尔。缘缚顺空增。应当真谛摄。答空有二种。一为空故得有俗成。二为空成无分别。今取成俗空故不入真谛。问若观生缚当见法时。为有能缚因力以不。答无能缚者。若有能缚即是他义。缚义不成。此义思之可解。今以俗谛无分别理事为此观体。此生缚观不分因果。此依经文辨。三释文者。无明因缘诸行生以生缚说者。无明因缘牒俗所依。以生缚说者。正斥观体。生缚同前释。所以言说者。为欲依言得平等俗故。何者以此缚字通目生不生为缚故。非亲生为缚故。非无俗谛不可以二相取此二义故。以一说缚字印定其义。若废其说恐别取二义故。观依说以取义也。理在说中。余文可解。又经通取空力多有力少。论即不说因也。此依论辨。十无所有尽观依论名。随顺有尽观三门同上。初所治者。此局心惑。亦可通诸使。俗谛通摄故。为执因缘。但有应俗相。自体空义。不现在前故是障也。何者但因缘生法。即自体空理不自住。顺成俗谛。成俗谛果时。仍以不同因缘。以此义求有不偏增。若迷谓唯有俗者故是过失。即法我我所见。二所依观门者。三义同上。生缚意趣有异。后自分别。诸缘生法。不起即已起即双现。如彼渴鹿见阳焰水干湿并彰。又如镜像染净双现。此是正理。问其所现空。为是真谛。为是俗谛。又此观法与前缘生及以生缚。云何取别。答因缘及缚唯成顺有。今第十观空有俱顺。又此空有并是俗谛。泛明真俗此有多义。一体相相对。二空有相对。如此分真俗。其义非一。若空有分真俗。有则为俗。空即为真。即证智所知。若体相相对。空有可以相论故。若约此义。俗谛通空有。此空是自体空。非事空也。故论云。是心真如相。能示摩诃衍体。故知虽是真如得名。俗相不是体也。此即空有同为一相。以缘顺性。理事为此观体故。上文云。十二缘生是无为也。此依经辨。三释文者。随顺即空。随顺于有尽者为空随顺。即有尽灭也。此顺论主后释。不顺经文。若依经无所有尽观者。无所有者所顺。尽者能顺。俗相即空顺于灭理。以俗相求法。即尽其性。此是周尽之尽。亦有解者。以尽字为逆观。此不应经文。为文中别有逆相。又若此尽即是逆者。诸观并应置其尽字。文云。无明因缘诸行生是随顺无所有尽观者。因缘无性即相辨空。空故随顺无所有理尽其性也。十观亦有相生次第。为知诸虚妄过故。故有第一。既识妄已未知妄法依何得生。故有第二。识知所依未知有何理。故有第三。已知生理未知依何时。故有第四。识知时已未知约何义。故明第五。知其义已有何本末。故有第六。知本末已未知有何过。故有第七。知其过已云何对事成。故有第八。知成已未知有何相。故有第九。知相已疑谓乖理。故有第十。依经十番讫。二依论分别者有三。一厌离有为。二大悲随顺。三一切相智。初厌离有为者。解则为顺。行则为逆解中以三空相为顺。大分为三。一成答相。二第一义谛。三世谛差别为知。世无人成。世有为过。故须第一。既知过已。未知趣何理。故有第二。虽知所入法。未知依何而得故。举俗谛辨所依观门。故论云。随顺观世谛即入第一义。初释文如前。问此相即俗谛。何须第三。更明俗谛。答此辨俗谛为取过失。二第一义谛释得脱所以。就彼因缘观第一义得脱因缘。此取依止观中上半门也。世谛观者。世即时也。谛者时中法实。此合经中后八门半为六门观。初半为一取二为一。次三各一。后三为一。初□是染染依止观。染者能依也。依止者所依也。此六门中。初一门明染依止。次二建立染相。次一就染彰过。次二正观防非。后一辨观分齐。又云何染故明染相。染何所依依第一义。何故说依妄法依真。为欲就之求真故也。二言因观者。观染所因问论主合本二观为一因观。经本初为自因。论主云他因。经本不相舍离。论主云自因。此义云何。答经主言自简异外道。论言他者。就四缘内。简取增上缘。成十二因缘义准论主意。消彼经文。即举亲别疏。取其疏缘不取亲者。为不顺十二因缘故也。云何不顺。十二支中但行有二支。报因义显。余者略而不具。又别取增上缘故。简之所以名疏缘。作他因者为增上缘。对亲因为疏。望增上自果为亲。今对亲因说彼增上故。说他因亦可。反之取其他也。经名不相舍离。如前观释。亦通亲疏。论言自因者。增上缘中取亲因缘。即互为因。等由互为因通诸支故。三摄过观者。摄十二缘以为三道观察。唯是苦集过也。四护过者。护彼凡夫邪见过也。五不厌厌者。防离二乘慢心过也。微细之苦。二乘不厌。菩萨能厌。名不厌厌。六深观者。观行穷深。因缘之理妙过情趣。故名为深观。相云何。论主分本三观。以为四法趣其深理。一非他作自因生故。即成自因。具有胜力。离无因计。二非自作缘生故。即显疏缘。具有胜力。即离单因生果不藉缘失。此二种义离自性执。由顺俗谛见心不息。问何故不言各有少力共成多力。答若少多则不成。三非二作但随顺生。此则去前见。因缘相随顺生者。有无不可取为随有故。不可无随顺有故。非自有复随顺有。非定从因生故。离有无不可取也。四非无因作随顺有故。即离意地。谓无分别。其法如上十平等摄。此即深观之妙趣也。问此观为是逆观。为是顺观。答此通逆顺。随顺观世谛即顺也。即入第一义谛故逆也。此观通治诸惑。不别明所治。以一缘起无生唯识为此观体。问如上诸义并是顺观。逆观云何。答真俗二谛非分别知。但对见情故分二相。欲知逆顺者。唯越见情。即逆顺相应。云何作方便。如诸观门。互相形夺。即体其理。得灭诸见。余义可知。二大悲随顺者。大悲随顺因缘。亦可因缘随顺大悲。论主合十为四。一以第一为愚痴颠倒。二以一门为余处求解脱。三以四门为异道求解脱。四以四门为求异解脱。第一辨过为所离。第二所求理。三为所依道。四为所求果。此四门中一一对番。邪为所治。正为能治。初愚痴颠倒者。随所著处愚痴及颠倒。此事观故。以着我故。一切处受生远离我故。即无有生。即以颠倒治法我相用。知过心治执我心。余处求解脱者。凡夫愚痴颠倒。常应于梨耶识中及陀那识中求解脱。乃于余处我我所中求解脱。此义云何。应于梨耶缘起法中求。及于妄我境中求解脱。即用识境以治我境。以唯识智治我智矣。云何异道求解脱。于颠倒因中求解脱。此义云何。应因缘理中求道所依。及于妄因自性等中求解脱。道则以自因理治。自性为因生。二十五谛理法为自性因。不平等故须治也。何者为二十五谛。五知根即眼等五根。五作根即手脚及口大便小便根。并心平等根为十一根。五大即地水火风空。五唯量即色声香味触。加前十一为二十一。忧喜闇亦名染。粗黑即是贪嗔痴合名染。心谛为二十二。慢谛亦名我。心为二十三。觉亦名智为二十四。自性为二十五。人欲死时。不能作业故。先五作根坏变为五知根。肉眼坏变为火大。耳变为空。鼻变为地。舌变为水。身根坏变为风。五大坏变五唯量。地变为香。水变为味。火变为色。空变为声。风变为触。唯量变为忧喜闇。忧喜变为慢。慢变为智。智变成自性。今坏者非灭坏。但无现用。还归于本故名坏也。成反前可知。不相舍离。以治梵作为梵天与众生相离故。三道治苦行因。为苦行非乐因故。三际治无因。前中后际因生故。用四智心治邪智。此有二义。一以缘起为正道体。以修成智为助道体。自因等为正道体。二以无分别智为正道。诸道品为助道。即举法取能观智为道体也。求异解脱者。泛释解脱有三种。一显缘起。第二生智。第三灭惑。今于我我所中求解脱。妄计常乐我净。三义即俱不成。论以四义显之。一用三苦治彼乐倒。显缘起理真实乐德。行苦等迁动无故。二用因缘治彼我倒。即显我德。有为不自在故。三用生缚观治彼净倒。即显净德。缚非自在净故。四用随顺有治彼常倒。即显常德。为随顺三有不常未出故。又用常乐等次第配之。余义如论。三一切相智观者。一切即所观境。智者能观心。一取有分观内半门为染净分别观。染者我慢烦恼染。净者无我慢净。分别者差别而知。仍依止观取十番内一门半观为依止观。前次第半门真俗二法与迷心为依。后一心观与俗谛为依。二依义齐故通一依止一心依止。通生依止及境界依。前半门内唯境界依。三以一门为方便观。方便者。因缘二力方便发果。四以一门为缘相观。缘相者。因缘生果之状相义也。亦可增上缘状相义也。问此一门与上方便何别。答前取因缘力。后取成事状相。又前位后欲明有支无作。唯有缘相义也。五以一门为入谛观。入者观心。谛者所知苦集谛也。六以一门为力无力信入观者。如无明行生识等果名为有力。识等不感后果名为无力。以此因果分齐。令人信入故名信入观。七以一门为增上慢等者。声闻人未断行苦。谓为究竟。故名增上。已断粗惑名非增上。举此深苦令人信入。八以二门为无始观。言无始者。无彼无始也为成因生故非缘作。为成缘生故非因作。此二处求无作者。始复求二作。非自成故无自性。始名无始观。所以二观为无始者。答因缘相形不可说始。以生缚观表法有终。若法无终。不可但说言无始观。问缚云何终。答若缚是果不可说有终为缚。不定果一相故说终。九种种观者。但俗随顺因缘非一故云种种。此九观门是种智境。治无智障。能观法体。即为能治。非理观智境。亦有逆顺。逆者烦恼灭。顺者得法体。三彼果胜者。文分有五。一对治灭障胜者。是前胜慢对治家果。前修十法而为对治。此地满中。更以甚深三脱为治。名对治胜。前治五地染净慢障。今此更治微细我心及有无等。名灭障胜。此中文亦有背向。消息无违也。二修行胜者。是前不住道行家果。依前不住更起胜修。名修行胜。三三昧胜者。望前治胜以说果也。前修三脱而为对治。彼治转增名三昧胜。此中文用论比之可解耳。四不坏心者。望前灭障以说果也。以灭障故。三昧之心不可破坏。五自在力者。望前修行以说果也。依前修行。上进无碍名自在力。余文如论。二修行胜中。初明修行之心。二菩萨作如是念下明修行胜。此文有二。初明修行。二即得无障碍下明修行胜。余文可知。就三昧有二。初辨空门。二无相下等余二空。余义如论。后二果中。各初一总。后句是别。就地果文内。三果如前。调柔分四。一调柔行相。二月光喻下明教智净。三别地行。四结说相。前中。初法次喻后合。就法说中。多见诸佛为起行缘。次能练行。后所练净。余文如论。三重颂有二。初明颂意。次正偈颂。偈有三十九。初三一句颂十平等。次十九三句颂不住道行。三次六偈颂不住果。次有九偈颂调柔三果。次一叹显说分齐。不住有二。初十七一句颂十种观。次二半颂结文。不住果文中。初三颂三脱。次一半颂修行。次半颂三昧。次半颂不坏心。次半颂自在力

大方广佛华严经搜玄分齐通智方轨卷第三(之下)

              巳岁大藏都监开板大方广佛华严经搜玄分齐通智方轨卷第四(之上)

        终南山至相寺沙门智俨述

第七地者。六门同上

一释名者。善修无相行。功用究竟。能过世间二乘出世间道故名远行地

二所治者。依地论文。细相习障。若依摄论。粗相行无明。此文在六地。又有两无明。一微细相行起无明。即迷俗也。二一向无相思惟方便。即迷真也。及二业障有一报障因缘生死

三所显者。种种法无别义

四所成者。成方便波罗蜜

五所得果者。达种种法无别功德。得一切相灭。恒住无相果

六释文者。经文有三。初偈赞生后。二明地体。三偈颂结前。初有十四偈。初十三大众三业供养。次一解脱请。初文有二。初十二正赞请。次一结供养摄行入上位。初文分二。初三偈诸天总修三业供养。身口意三请也。次九偈是别。别中有三。初一当处天王供养。次有一半明余天王欲闻法益。次六偈半明天女等承力叹佛三业胜用。二偈半身也。次一口。次三意也。二辨地体中。大判为五。一乐无作行对治差别。治前地乐空心。二彼障对治差别。治此地有相心。三双行差别行成相也。四前上地胜差别校量也。五彼果差别纯熟也。乐无作中经有三。初总生起。二正释。三结利益。第二文有二十句。摄为十对。一一对中。皆初明其境界无量。后句明佛无量德业。亦可初句为空中方便智。后句为有中殊胜行也。又论文云。有四障如五地说者。取彼不恼生事安乐生事。怜愍故出渐令入法。对四化行说四障也。又书论等四障如论耳。余文如论。就彼障对治修行胜文。经中有二。一明菩萨观解方便。此方便中论有六问。初问所益生。二问所依世界。三问何慧者。其法界法中两句难可别问。故就能知智慧以问。四以何心者。问根心也。五以何行者。问起行心也。至下解中合举。辨之有通二义故耳。六问所乘也。二菩萨如是下正明修行也。有五句。初所标。二辨意。三明分齐。四出体。五成对治义也。双行文中有四。一二行双无间。二信胜。三能作大义。此文有四。初立。二责。三略答。四广辨。四菩提分差别。此中经文脱四家一句。余文如论。彼前上胜文有二。一胜前六地。二何以故下明胜上胜上三地。前中先略辨相成解脱月问。二金刚藏答。答中初先通对诸地彰此为胜。二何以故下别对诸地显此为胜。此别答有二。初问次答。答中分二。一总次别。二释胜上中有二。一明此地胜过于后。二解脱月下因前所论乘明诸地染净之相。初中分二。初责次答。答内分三。初法次喻后合。余文可知。二乘明染净中有二。初问次答。答中有二。一通辨。二约七地别明分齐。初通中有三。谓法喻合。三文可知。二别辨文有三。立责答也就彼果胜文中。初一业胜文有三。初总次别三结。此经结文中脱一句。别文有四如论。二三昧胜中。初总次别三总结之。经脱总句。余如论也。三过地胜中。分文有三。一行修善巧故过。二作业广大故过。三行修胜入故过。初中分二。初牒前起后。二别解义。第二过中。初正辨过义。二解脱月下显过分齐。此有二。初问次答。答有三。法喻合也。余文可知。得胜行文有二。初明三昧胜。次发起胜。初文有二。初问次答。答文有法喻合三文。发起胜中。初结前生后。次正明发起胜行。又此论文中总为八句。初一自利行。现身世间是殊胜行。深心涅槃是方便智。下利他中。初三顺凡。次一转小。次二随魔。后一转凡。眷属围绕是殊胜行。心常远离是方便智。诸句例然。愿取有者。为首之化必由愿也。家不断者。示有爱染之事也。远离使者。离使性也。入行者。能转二乘上入佛知。资生行者。示有饮食睡眠等也。退行者。示老病等也。言转行者。转诸凡大烦恼心也。见贪转者。转其见惑也。障碍转者。无明不了名障碍。今转灭也。五明智治之耳。贪转者。转贪结也。菩萨现受胜五欲处而不着。令诸天等舍自所欲故也。地果文中。三果如上。调柔果中文还有四。一调柔行相。二教智净。三别地德。四结地相。调柔行中还初法说次喻后合。法中初多见诸佛。次能练行。后所练净。余文可知。三重颂有二。初明说意。次正偈颂。偈有四十二。分文有七。初九颂无作行。次三彼障对治。次六颂双行。次十一颂前上地胜。次八双行果。次四颂调柔等。次一结叹也。第八地者。此下名出出世善法。因此料简上下诸地一乘三乘人天起信生解渐次同异法门。初地中十愿。是一乘三乘共行法。信等十法。是三乘别行法及人天所依。二地戒行。是三乘小乘人天所依。三地禅定。是三乘小乘人天所习。四地道品等。是三乘小乘所得。五地四谛。是一乘三乘小乘共行法。六地缘生。是一乘三乘小乘共行法。第七地方便双行等。是大乘所行法。八地九地十地。是一乘大乘所习法。此等若望见闻修证通说。即等无别。若约相别论。则有此殊分。又诸地调柔果是行门发趣果是解门。摄报果是报门。愿智果是德用门。亦是一乘三乘共行法。以此准之。十地善巧圆通广摄故得藏名。故崔光云。十地经者。盖是神觉之玄苑。灵慧之妙宅。亿善之基舆。万度之纲统理包群藏之秘。义冠众典之奥。积渐心行。穷忍学之源。崇广住德。极道慧之府故也。今此地中六门同上。初释名者。报行纯熟无相无间故名不动地。二所治者。依地论文。于无相有行障。依摄论文。于无相作功用心。无明又有二无明。一于无相作功用。二于相行自在有二业障及一报障有有生死。三所显者。由不增减义。四所成者。成愿波罗蜜。五所得果者。若通达不增减功德。得共诸佛平等威德智慧业果及得法身果。六释文者。大判有三。初偈颂生起二明地体。三以偈结。初有十五偈。初十四诸天菩萨赞请供养。次一解脱请。初十四内初二天王诸天菩萨庆法雨花供佛大众。次十二天女歌叹佛德。此文有三。初一乐供养。次十偈颂赞佛德。次一供已入理观察。第二十偈中有二。初一天女赞佛。次九佛力令菩萨等供具出声赞佛功德及三世间自在。初三偈器世间。次一偈众生世间。次四偈智正觉。次一偈结叹无尽。智正觉文中。初一叹佛口业。次二身业。次一意业。地体有七。一总明方便作集地分。为远方便有二。初总告次释可知。二得净忍行分。近方便。此二俱为趣地前方便。三得胜行分。初入地行。四净佛国土分。五得自在分。此二安住地分。六大胜。七释名分。此二地中满足。余文可知。第二净忍分有十五句有三。初有十句明无生忍。次后四句明其忍净。后一总结。依经不足脱自性无生句及遍一切法相句也。余文如论。胜行分中有二。初胜行。次发起行。初有二。初总后别。别中先法后以喻。法中七句相从为三。初三明此地中境分殊绝。次二正行广大。经中脱修行深一句。次二离障寂灭。喻中从后向前次第喻之。发起胜行内。于中有二。一明此本愿故住诸佛劝发若不与下明劝利益。初明本愿力住。又诸佛下由住劝发。此文有二。一总明诸佛法水中与起智门。二善哉下别明与相依劝能成。第二别中。先叹所得无生忍门。后彰未得劝之修习。此文有七。摄以为二前有六劝举多未作转其住心。后一明其少作能成增其去心。复前六中分为三对。自利利他。前初对之中。前一明其自德未成。后一显其所化未出。此中经脱一句。第二对中。前一明其化愿未满。后一彰其自德未胜。第三对中。初一明其化业未广。后一彰其自己所得法门未穷。此中经脱一句。余文如论。二明劝利益文有三。初法次喻后合。法中有三。一明诸佛与起智门。二于一念下明由劝故起行速疾。三所以者下问答解释。余文如论。国土分中有三。一器世间自在行。二众生世间。三智正觉。初文有二。初总标举。二知世界生下别显之。此文有二。初知法分齐有二。初知次结。初文有五。初知世界生者明随心欲。二知以何业下明随何欲。三经脱随时欲。四是菩萨下明随阔狭欲。五是菩萨入如是下随心几许欲。二善分别下明自在仪式。此文有四。法喻合结也。余文如论。释众生世间中有四。一总明自在。二若于沙门下别明自在。三辨现意。四所有不可说下总结自在。亦可二别辨中及意内。初化同物身。二以声闻下化同物心。智正觉文。初明第一义智。所以明此者。为成世智法相由所以也。二是菩萨善知下是世谛智。此中随所化摄有十身。通已有十一身有三。初举数。二辨相作。三出体释义可知。问何故明器世间乃辨三世间者何也。答为三法相参难识欲别故须明也。此中多漏诸句。比论取之。大胜中有三。初明智大。二业大。三彼二住功德大。余文如论。释名中有二。一地释名。二智者释名。余文可知。智者大分有二。初正明不动。二以不转相故下总以结之。前中合有二十五句。初十五一向不动。二是菩萨入下十句一体不动。地果文中三果如前。调柔有四。一调柔行。二教智净。三别地行。四结地相。前中初法次喻后合。初明多见佛起行缘。次起能练行。后所练净。教智中亦初法次喻后合。余文如论。三偈颂中文分有二。初说偈意。二正偈颂。此文有四十四偈。初三颂方便集。次三颂净忍。次十五颂得胜行。次十二颂净土。次一颂自在。次二颂大胜。次二颂释名。次五颂调柔等。次一举略显广以结前义。胜行中。初五颂胜行体。次六颂七劝不颂第五第六劝。次四颂举劝彰行胜。利益净土中。初四颂器世间。次五众生世间。次三智正觉也。第九地中六门同上。一释名者。无碍力说法成就利他行故名善慧地。二所治者。若依地论。不能善利益众生障。依摄论。于众生利益事不由功用。又有二无明。一无量正说法无量名句味难答。巧言自在陀罗尼障。自利二依四无碍解决疑生解障。利他。有二业障并一报障有有生死。三所显者。由定自在依止。由土自在依止。由智自在依止。义应知法界。四所成者。成力波罗蜜。五所得果者。若通达土及智自在依止得应身果。通果同前地。六释文者。大判有三。一偈颂生后。二明地体。三以偈结前。初有十九偈初二明说前地利益也。次有十七辨四众赞请。初一菩萨供养。次一梵王设供赞叹。次有十四天女赞请。后一解脱请。天女中三。初一半偈总叹佛德。次十一半叹菩萨等具白他德。就此第二文有二。初三半总叹自因殊胜。次有八偈别叹利他果用。次第三摄乱从寂。就别八偈内。初一身业。次六口业。次一意业。就口业中有二。初总叹说自在。二约根辨相。次一约身喻显。此文有四。声闻缘觉渐顿等分四。亦可一乘三乘分四也。第二地体中有四差别。一法师方便成就。二智成就。三入行成就。四说成就。初文有三。初牒前起后。二正辨释。三结入地相。余文如论。第二智成就中。初牒前起后总辨。二有漏下偏广善法。第三入行文中有三。初总十一门。二别辨。三总结之。余文如论。初总门中。论主云。依共者。心稠林是众法共止故也。名共依者依此而知耳。次复共者根欲性深心等。四类同故名共也。经文使难内何处文脱第四句。生难中经脱第二句。习气难经脱第九句。余相可知。就说成中有二段。经初总明说成。二是菩萨化众生下别。别辨中义三。经文有四义。三者一智成就。二口业成就。三法师成就。经文四者。依论分文。又第二法师深妙义一段。经文亦入智。亦入口业。思之可智。口业文有四初立宗。二是菩萨下明辞坚固。三列名。四历法别释。余文如论应知耳。法师成就有四事示现。一持成就有四。一立宗。二释。三结。四以广显略。二是菩萨于一佛所下说成就。此有十句可知。三是菩萨三千下问答成就。有四句可知。四于是中生不受持成就。此有一句也。问此受持与前持何别。答前持是临说时。后持是初受时耳。二地果文中。二果如上。调柔分四同前。一调柔行。二教智净。三别地德。四结说相。前中初法次喻后合。初中见佛即起行缘。二能练行。三所练净。余文可知。三重颂者。初明说意。二正偈颂。颂中四十二半。初四颂法师方便。次四智成就。次十二入行文。次十四半颂说成就。次七三果。次一结叹说成就内。初一智成就。次四口业成就。次九半法师成就。此内初二持成就。次一说成就。次一问答。次五半受持成就也。第十地者。六门同上。一释名者。得大法身具足自在故名法云地。二所治者。依地论。于诸法中不得自在障。依摄论同地论。又有二障。一六神通慧。二入微细秘密。佛法有二业障及一报障有有生死。此在初及住心中。复有二障。一于一切应知境微细着。二于一切应知境微细碍有二业障及一报障无有生死。此在地终心。三所显者。由业自在依止陀罗尼门三摩提门自在依止应知法界。四所成者。成智波罗蜜。五所得果者。通达业依止得化身果。通果同前。六释文者。大判有三。初偈颂生起。二明地体。三以偈结。初二十五偈内有五。初二首陀会天兴供赞叹。为此地行满故色究竟叹也。次一菩萨叹及供养。次二诸天天王共叹及供养。次十八天女叹及供养。后二解脱请天女有五。初二总举乐音供养。次五叹报佛。次六叹化佛。次三叹法身体。次二劝行。初一劝入体观。次一结益归本。二体文中大分有八。一方便作满足地分。二得三昧分。三得受位分。四入大尽分。五地释名分。六神通力无上有上分。七地影像分。八地利益分。初文有三。初总次别三结。三昧分有三。初牒前起后。二正义。三结所成。受位中有六。初座有三。谓主眷属及结。身有二。眷属有三。相有六。座初文中。十德内经脱第八功德一句。及脱第三结文。出处中顶光文有八段可知。六受位文有三。初释觉。第二辨相。第三结。结文有三可知。第二文有三。谓法喻合也。法中有三。一九地菩萨供养有二可知。二同位加威有二可知。三佛正受职。此文有三。谓释光。第二等余佛。三结。初文有三。第一放光。二归处有二句。三辨益。初光有八业可知。光入顶有三。一约事入事顶。二约行入行顶。三约实当果现入行心也。可准之如论应知。大尽分中如论应知。又此大尽已后。一乘顿教三乘小乘等成佛果分齐。可准义消息之。于中诸经句亦有增减。以论准之。释名分中。大分有三。一能受佛云雨说法名法云地。二佛子乃至自从愿力起慈悲下。能注法雨灭诸众生烦恼尘焰名法云地。此文初释次结可知。三复次佛子乃至菩萨住法云地从兜率下。能同果德。大注法雨生物善根与云相似名法云地。初文有二。一总明念力能持佛法。二能于一念至十方无量佛所下。别明受法。别中有三。一于佛所听受多法。二譬如大海下。于多佛所听受正法。此有喻合结三文。三解脱月言乃至于一念中能堪受几所下问答明前二种分齐。前中初法次喻后合。第三问答二种分齐中。文相有二。初问次答。答中有四。初立义。二假说问答。举略显广。第三显其实义。四结可知。神通力无上有上分中有六。一依内。二者依外。三者自相。四作住持。五令欢喜。六名大胜。就此六中。初之一门义贯前四。此处文无。次有一段贯通下四。所以尔者。论主善知文含多义。欲交络显法故作此科也。余之四门文义俱有。余文如论。第四住持中。外内分二。此二内各有二可知耳。第五令喜文有六。初问。此有二。谓念请分二也。次举定事答。三明定业用有二可知。四摄业依本。五结赞有二可知。六问答显定分齐。此文有二。初因后果。各有问答。初因内。初问次结有二可知。初有名用。二问答果。答内有四可知。大胜分如上地。调柔等三果释可知。广如论辨。地影像中。如论应知。上来依一乘圆通佛法约教分齐记。今更约三乘显其两位如经。一名等觉位。二名妙觉位。等觉者。于第十地金刚无碍道中入法界心。谓勇伏定法光三昧。依此定中修行十法。一学佛不思议变通二集菩萨眷属。三重修先所行法门。四顺一切佛国问讯一切佛。五与无明父母别。六入重玄门。七现同如佛现一切形相。八二种法身具足。九无有二习。十蹬中道第一义谛山顶。此位在第三禅说。若约外相当补处菩萨。亦示成微细八相。经百勘万劫变化如佛。菩萨见佛。佛知是菩萨。由得金刚三昧故变现自在。唯生灭为异。广如璎珞经。妙觉位者。经指第四禅说。义相多同故不料简。问此经何故不说等觉妙觉二位者。答若约三乘别行义门。由约分位取相为正故。等觉妙觉相形分成两相。若据此经。圆通自在不以相形定法为正故。摄在因果二义之中。地利益中文分有五。一正显地益。二如此世界四天已下彰地广益。三以佛力十方菩萨下明诸菩萨云集作证显成可信。四金刚藏说如来喜下明其所说。上顺圣心如来随喜下惬下四颂第四功德也。余文可知

    十明品第二十三

四门同上

一辨名者。十者数。明者用。从二义得名

月此下五品。为明地德胜用分齐故次来也。此即第二明来意

三宗者。此通释五品次第及宗体。所以先明者前既得体。次明依体起用自在故次明也。明用不自起。何以成为证。理法故。次辨十忍即理用也。大果因行非十数测量故。次明阿僧祇以数行法也。既广德已成。非小时而得迁动故。次明寿量品。既德无方随缘依现故。次明菩萨住处耳。初十明者德用相也。即答上十自在一问。亦可地中答也。此通答上问耳。次十忍者即答上卜定一问。十愿在初地答。次十顶及随喜心等十句。僧祇后三品总答之。亦可通前二品答也。问此下五品属前十地。何以不刚藏说。答若德体难明。须托人寄事以说。下五相寄别义显也。所以明忍普贤说。为表胜德大用广高也

四释文者。初十明文有四。初总开数。次第二寄问。三辨德用。四安住已下总明结叹。第三文分六通以为十明。问明与通何别。体一义异无壅。日通识根由日明也。十中第一他心通。第二第四天眼。即现未等分之。第三宿命通。第五第七天耳。亦可第七意法尘摄也。第六第八神足即身通。第九第十普是漏尽智。所以知为此二并达性故知也。第七声与第八色可见不见分也。又第十是灭尽定。又辨六通三明是三乘教。十明十通是一乘教。不可相摄。深浅分齐不同故。初他心内有三。初问。次辨相。三是名下结名。余九皆尔耳。第二文有二。初明知此界。二如是等下摄通余方。初明中分群机大众同欣五佛在下总以结之。此依论辨。依经有三。初总叹。第二说是品时下约事显地胜。第三以佛神力下菩萨为证。初文有三。初总叹。第二有二问答显胜义。第三结胜义。第二事文中有五。初动地。二显所由。三雨花等。四大音赞地德。五等通余方。第三菩萨证成文有六。初菩萨来此。二叹地德。三显同为证。第四举多说为证。第五推证所由。第六等同也。依论初文有二。初法益。二事益法文有三。初反显。二顺辨。三结。顺文有四。谓问答责释可知。经文略而不具。第三重颂中。初明颂意及现颂相生起后文。二正彰偈颂。此前有二。初观法。二显意。此文有二。初为利生。二示不思议下为欲显理。初文有三。初叹人德。次示菩萨下与自利益。三随众生下与利他智断用。二显理文有三。一总显示。二示相。三辨说意。二正颂中有九十偈。初六十九正颂法云等地。次为得佛智下二十一偈颂影像分。余略不颂。初中文有二十九颂方便集地。亦可前二十六通颂前九地。次三颂满足地分文也。次二颂三昧分。次十颂受位分。次七颂大尽分。次六颂释名分。次十三偈总颂无上有上等文。次二金刚藏总结。亦可此等文通颂十地准思。科释可知。方便集地内。初二颂集起功德知慧行相修行佛道等文。次二十七颂同相及别相文。此文初别后同也。别中初六三句颂初地相。次一偈一句颂二地。次一颂三地。次二颂四地。次二颂五地。次二颂六地。次二颂七地。次三颂八地。次三颂九地。次第一妙下三颂同相。三道亦好。影像中。初十九颂影分。后二结地德无尽。初中十一颂第二胜功德。次四颂第三功德二。初直知心知法差别有二可知。二声闻心下约凡圣报类辨智用殊能。此文有二。初随行方便次天心下辨随类方便智。二天眼中。初释次结。初文有二。初明随报别不同知。次菩萨以无障碍明下知造业成仪境界。三宿命有二。初释次结。初文有二。初知自他下位境有二。初总次别。次别又忆过去下知佛上位境也。四未来智明有二。初释次结。初文有二。初知善恶下位人法有二。初总次别。二知未来无量下知佛上位行法。五天耳有三。初立次释三结。第二文中有二。初辨天耳闻持德。此有四句。二十方远近下明天耳用事。此中有三。初总。次于东方下别。三如东方下类九方也。第二东方别辨中分三。初佛。次辨法体。三善解无量下对人说法。第二法体中出理行二教所说等辨理教。二所制下行教也。法略有十句。一教体相。二起信相。三示义宗相。四解释相。五制学相。六受学相。七举事劝进相。八闻轨。九思轨。十修轨耳。次第三对人中有三。初理法机。次所得功德下行法机。三广说下教机。此文意难得。思之可解。此并叹天耳明德也。六身通内有三。初立名义。次释。三结。第二文有三。初身业体。二若闻十方下辨业体用有二可知。三悉自了知下结业分齐耳。又此通约威力。第八约现色也。七分别言音知明有二。初释次结。初有二。初知声。二菩萨随其等下辨知所以。初文有□。初辨知众生报音声。初总。次别。三结知。次善分别知下知二谛教法及根器也。八出色身庄严智明有二。初释次结。初文有三。初达色性。二菩萨入深法界住持下辨缘集成色即明用也。三佛子菩萨入无色法界下辨通成用相所以耳。第二现色文有三。初明自行色体胜。二大慈色下明利他故现净色。三出生如来下辨因果色相大用成就。普贤色总别有一百一十句。此色有体用。凡愚二十五色即空故也。九真实智明中有二。初释次结。初文有二。初约所知理显智明体。二菩萨知如是下辨智巧用。即明其相。前文有二。初约无相境。二知一切法别异下约无生境也。二用文于中有二。初牒前所知二不着下辨智巧用也。用中有三。初明用自在无著。二不舍一切下释顺寂成用相三观察诸法下明用自在。十一切法三昧正受智明中有二。初释次结。初文内有三。初辨住寂名体有二可知。二亦不舍下即寂常用。三菩萨于一切法灭尽正受文下辨分齐。第二结文有三。初结。次叹定行德用深广。三仰推知者。大段第四。结文有一。初结。次明德量可知也

    十忍品二十四

四门同上

十者数。忍者境与神会情谛可也

余二意前已辨

四释文。此文有三。初总列名。二释。三偈重颂。初文有六。初总告。二叹成忍因果胜相。因果即为二也。三问。四列名。五是名下结。六引诸佛同说证成。第二释文有二。初辨次结。此十忍前二加行摄。次无生忍正体摄。后七后知摄。约位即顺音声三地已还顺忍即四五六地。无生忍即七地已上。后七忍九地已上。若通时即齐等也。此忍前三心境得名。后七从喻受称。别释初忍有三。初举次释三结也。二顺忍三句同前。三无生有三亦同前。就第二释中有三。初立次问三答也。后七忍相生次第如论。此义云何。疑者云。若法无云何现经如幻也。疑云幻法不生取识。世法不尔。云何同也。故经如焰亦生渴心。疑云其焰不得受用。世法不尔。云何同。答如梦。疑云梦则觉者不闻彼声。世法圣凡共得。此云何同。答如响虽共而非实也。疑云响即前得无益。世法不尔。此何也。答如电光无有作者而触照有用。疑云电若有用即是实法。答如化益生岂是实也。疑云若一切是无谁能作化。答如空成诸色。岂是有也。四幻文有三。初问次答三结。答文有二。初辨所观法。此文有三。初总举。二菩萨等下辨观相。三譬如幻化下广辨幻相。此有譬合二文。第二菩萨观察下辨忍行。此文有二。初加行忍。二出生下后得忍也。五如焰忍有三。初问次答三结。答文有法喻合及辨观相。四文可知。六梦忍文同焰忍可知。七响忍有三。初问次答三结。答文有二喻。各有法喻合三文。前是自利后是利他也。八电忍有三。初问次答三结。第二文有四。初法。次不行菩萨下喻。三是名下结。四若菩萨下辨益胜用。第二喻有二喻。初向理体。第二向事用。各有法喻合三文可知。九化忍有二。初问次答。答有五。初一法说。次喻。三如是菩萨处于下合。四是为下结。五佛子菩萨成就此忍下明用利益耳。初法文有二。初明行体所知。二佛子是为下结所知起用自在。合中有三。初总合。二不着世间下辨相。亦可约法譬显行仪耳。譬如化下法喻双结胜用益也。十虚空忍中有二。初问次答。答文有五。初十句明忍体。一一句皆有法喻。二佛子如是菩萨下七句结成忍行。三譬如虚空下复以喻况行体。以合喻成前忍德也。四是名下结。五若菩萨成就无来身下辨忍行用利益。初十句中。一总九别可知。第三广喻况忍行文有二。初十一句明行成。二何以故下释成忍行也。此答文有二。此意难解思之。何者疑云。若法如空者此有二疑。一空体是无。物法亦可如是。二如世事空别。物依现法。亦如是别有异空也。答相可知。第三重颂文有一百二十九偈。初十颂音声忍。次十颂顺忍。次十颂无生忍。次十颂幻忍。次十颂焰忍。次十五颂梦忍。次十七颂响忍。次七言二十行颂电忍。次十颂化忍。次十颂虚空。次七总颂结叹文。彰忍利益也

    阿僧祇品第二十五

四门同上

僧祇者十数之始名也。此品从三义得名

二来意

三宗上已辨

四释文者。所以心王问佛自说者。上来由是大果之因。非果人莫能辨其际故佛自说。法依心成故心王起问也。又为因果互显耳。亦可数法是知事通果故佛自说耳。故文云如来等正觉佛智之义也。此品有二。初问后答。问意菩萨行德尽其数极。未知菩萨数法云何。亦可问云圣境既宽菩萨尽了。未知以何数法得穷其分量。以示下人也。答中总举一百二十数以答。大数有十一阿僧祇。二下名无量。此云不可量。三无分齐。四无周遍。五下名无数。此云不可数。六云不可称。七名不可量。此脱不可字。八名不可思议。如下在第七。九名不可说。十名不可说不可说。此问。文有三可知。就佛答中有四。初叹心王问。二劝听。三忍可。四佛告下正答所问。就此文有二。初长行。后偈颂。长行即能数数法。偈颂即数所数也。此即交络显数义德用耳。长行中有百二十番数法门。初一百成僧祇。二僧祇下次第成十数以答前问。又一百二十数分齐者。从初拘黎句为因。次不变已下别有一百句为满数。次有二十句者从受等十句为因。从僧祇等十句为满数句也第二偈中。唯取上第九数法以校量德行不颂上文。此中有二百四十五偈。此中诸偈总长约有二种意。一总二别。总者。或事或理或行或境或因或果或文或义等。乃至显发释等文相自彰也。此可思之。二别者有二。一约境有三。一智正觉。二众生世间。三国土世间。二约心谓正助也。此文有三。初十四行明能数。于中有十重积数法即为十文。二对事辨所数。此对事所数中有二。初用第九数量法。二摄取不可言说转已下转取第十数因用以量法。所以尔者。但欲明增数之法非只如此。三后一行总结。问所以不用第十数者。第十数属佛故。文中虽明佛果法。欲取能回善根因位法也。所以尔者。为果相通因二处显故。此可思之。此即数于无数耳

    寿命品第二十六

四门同上

辨名者。寿者命根。亦可命寿无二。依大乘即阴相续。依小乘别有不相应性

二来意。三宗。上已辨

四辨文者。此下二品。心王自说者。为命处不定随心成故也。亦可唯因位有种种义自在也。即寿于无寿也。此中何故举果土。此为举处。取能修行人故。下云。普贤充满其中也。此文有三。初总告。二举所依土。三普贤下辨能修入因行也。第二文中。初略十土。二广校量耳

    菩萨住处品第二十七

四门同上

一释名者。人义及所依三义得名可知

二来意。三宗。上已辨

四释文者。约相同下位故辨处也。此即住于无住耳。又虽同人而无生为生无住为住。此文有二。初不住有故。明十方清净八住处。二辨不尽有为故。寄四海十五染处也

    佛不思议法品第二十八

此下答第二会中三十二问。后十三果德问耳。然问答辨义者。为明圆宗秘教。显于时听修相方便彰在心目致使。说法被益者无隐宗趣。发心崇远者不翳习求。是故经言。于正说中置随语义。于正义中置随义语。随语之义义非别体之义。随义之语语非别诠之语。此是语者之正则不可执。名诠以定法体。是以此经正宗中。因果相从。问答连照。不隐失一意。此即大圣巧也。方便修成因果中。上来答因行讫。次下三品答果。初不思议即法身德。次相海即报身德。次小相即化身德。此依三乘。若依一乘时。初品是体。次品是相。第三品是用也

四门同上

一辨名者。佛不思议法者。此由果故标佛为初果。非下地测量也。法者因人所轨也。亦可自体也。就三义得名

二何故品来。由因行满已。次行成得果耳

三宗。此品三身内以法身为宗。若体相用以分。即果德自体为宗。亦可初体次相后用。约三身通此三耳

四释文者。所以青莲花说者。果不自彰。寔由因花显也。青莲花胜也。所以告莲花藏者。非因净藏无由摄受胜果也。此文有二。初序。二尔时青莲华承佛下明正说。序文有三。初会众疑念。此文有二。初总生念。二出所疑法。二尔时世尊下加威与力。三尔时青莲华即入下明入定审法。亦可不入定所以者。由是果法已自深微。更入定显。退信解故。为以法深故但审法界。下二品从此耳。因此料简上下文中。法界者是何观境。答依此经文及地论有二义。一若依地论判。即是第一义谛理观境。此约三乘判。二若依经上下文。即通理事二观境。其法大通非局。仍位在无为耳。初问中略念十法为是果法。非思量境故。皆不思也。此十句义有五。初一辨依果。次二问因行。次一问正报果德。次三问佛法身音声智慧三业德相。下三句问神力自在。第三审法中十句内。初五自利。下五利他也。二尔时青莲华下正说。此品远答上十句。法身德。次相海答不动一句。报身德。小相答上佛六根佛智二句。化身果。此告青莲花藏者。深奥之胜器也。答文中分二。初十句总亦则是别。从此句下别。别中略举三百二十种功德法门以示也。有五。初五十句答上刹土一问。二十种出生住持下五十句答上净愿及种性二问。三有十种佛事下六十句答上佛出世一问。四一切诸佛有无碍住下九十句答佛三业相三问。五十种最胜力下七十句答上神力作用三问。初五十句中。初十辨行德所依妙住。次十实性随缘以成十种行德。次十以称法起行成十方便智。次十巧用随缘自他德备不失时。次十不思境明境界巧用应机无失故超果独绝。初十句中。初二辨自分相应行德。次七利他摄化行。次一自他契实平等无二。第二十句中有三。初七明法身功德六根作用。次二明依正二法神通自在。次一明佛因圆等诸佛所证也。第三十句可知。第四十句有二。初二自利。后八利他。第五十句可知第二五十句中。初三十答上净愿。后离恶下二十句答种性。初十从正智出。后得住持愿智之用。此有二。初三自利。后七利他。第二十以外用依内成即内德法也。于中初三三业德备。次七三业摄化功德。第三十由前内德成实用外彰。独胜莫加故也。于中初二自利行。次二利他方便。次一自利德满。次六利他德备第四十德彰故净也。初六自行无染。次四利他处无著。第五十净决定故究竟也。初六因行满净。次四三身果满净。四中初一化。一法二报

第三六十句。初十明化德。后五十报身德皆此法身德也。佛事者能兴大用。化身摄益相也。初五利他方便。次五利他正益。后五十中。初十一无尽智用如海。初一明所依法身。次十能依德用。初四自利行。后六利他行体。第三十常法。初四自觉行满。次六觉他行备。第四十无量说佛法可知。第五十常作佛事。初四明于净土三业施化摄益。次三现色等住持。次二现宝等庄严。次一入定益诸菩萨。亦可但默非定也。第六十坚固。初五自分德圆。次二胜进行回向。次三修成化益。第四文九十句有三。初三十答上法身一问。次三十答上音声等口业。下有三十答佛智意业。初十无碍住。初三自行无碍。次七利他无碍。第二十最胜庄严。初三三业体严。次六三业用。次一利他德行满。第三十自在正法可知。言非不先觉诸佛正法亦不住学地而成正觉者。此有二意。一简文中义。此中佛者非同小乘佛。为是共教因大佛也。二者将普贤义简异生信别门。其佛假使前后现成并同先觉。并同在究竟离其学地及以不觉。为普贤法摄三世自在故也。此意思之。第四十一不思议成正觉。初四因圆。次三利他行成。次四三身具德满成佛也。十巧妙方便。初四自行。后六利他。十佛事可知。十法王。初七自利德。次二利他行。次二自他。二果相摄无别耳。十住法。初四利他德。次六起悲等用无尽。十悉无有余。初三知法界等无余。次二知染器世间。次六知出世因法等也。第五文有七十句。初十答上神力一问。次五十答上无碍住。次十答上解脱。初十胜力。初列次释。初四自行成。次六他行备。第十中四住义。佛所住即最胜我是佛住。次无碍即真空定即圣住。次无碍心即天住。次大悲即梵住也。十定可知。十法。初五得世间善满。次五出世行成。十清净法。初六入因行。后四入佛。三身境界。十一切智住离障相应不动也。初二知器性。次一总。三轮化下七别别中。初三神通轮。次一正教轮。次三记心轮化。十不可思议三昧。初二利他方便。次三自利方便。次一利他纯熟。次一自利行熟。次三寂用解脱自在究竟。十无碍解脱。初五于一尘中现诸佛转法轮教化。次五于现在摄三世佛。于一门中现也。又大乘同性经中佛有十种地。善丈夫佛地有十。一切菩萨及声闻辟支佛等所不能行。何者为十。一名甚深难知广明智德地。二名清净身分威严不思议明德地。三名善明月幢宝相海藏地。四名精妙金光功德神通福德地。五名轮威藏明德地。六名虚空内清净无垢焰光开相地。七名广胜法界藏明界地。八名最净善觉智藏能净无垢无边无碍智通地。九名无边亿庄严回向能照明地。十名毗卢遮那智海藏地。善丈夫此是如来十地名号。诸佛智慧不可具说。善丈夫佛初地者。一切微细习气除故。复一切法得自在故。第二地者转法轮故。说深法故。第三地者说诸声闻法式故。又复显说三乘故。第四地者说八万四千法门故。又复降伏四种魔故第五地者如法降伏诸外道故。又复降伏敖慢及众数故。第六地者教示无量众生六通中故。又复显现六种大神通故。谓现无边清净佛刹功德庄严。显无边菩萨大众围绕显现无边广大佛刹显现无边佛刹自体显现无边诸佛刹中从兜率天下托胎乃至法灭。示现无边种种神通。第七地者为诸菩萨如实说七菩提分。无所有故。复无所著故。第八地者受一切菩萨阿耨多罗三藐三菩提四种记故。第九地者为诸菩萨善方便故。第十地者为诸菩萨说一切诸法无所有故。复告令知一切诸法本来寂灭大涅槃故。此应三乘耳

    如来相海品第二十九

四门同上

一释名者。佛相无穷故如海也。今寄同人说三十二耳。胜诸天故说八十好也。亦可应神耳。此约三乘解。今此文是一乘相。故如海也。所以普贤说寄德无边故也。问上不思议法品别告一人。今何故不也。答上法是体显胜故别告耳

二来意者。前体后相故来也

三宗者。依三乘用三十二等诸大相为宗。亦可增广不同三十二相也。即如文辨相德为体耳

四释文者此文有二。初诫听许说。二广辨。此文有二。初略辨九十三种大人相。次下总明十莲华藏世界大人相也。前文初七顶上相。次名圆满下二十二严顶相。次三眉间相。眼鼻各一相。舌有四相。龂齶一相。大牙有四相。齿有一相。肩有五相胸有一。胁有一。腹有七。下分有二。手有十二。马藏有三。髀有二。[跳-兆+專]有二。毛端有一。足有十三。一一相文有四初列名。二出体。三光。四光照被益。于缘分齐也

大方广佛华严经搜玄分齐通智方轨卷第四(之上)大方广佛华严经搜玄分齐通智方轨卷第四(之下)

        终南山至相寺沙门智俨述

    佛小相光明功德品第三十

四门同上。次第等上已说

小相者相形别德也。所以佛自说者。化身之用唯佛方穷故。亦可化身随物劣令生信。有实德故。佛自说也。此文有二。初总举形好被益。次如来足下有千辐下广辨随功摄益。初文有四。一列名二明用相。三辨眷属。四举往因辨用益。影成如来小相德用难尽。此有四文思之。二广中有六。初辨形好摄益。二汝等应当下教往报恩及识因果。三诸天子闻是音声下兴供养行。四是故诸天子下教发心悔过。五说是法时下辨获益转更回向。六尔时诸天子下得益故传通不绝也初文有二。初辨相轮光照摄益。此有二可知。二生天上已下劝成胜行。劝中有二。初正举下况劝。二诸天子卢舍那下举胜利以示。初文有三。初正劝。二天子赞美。三重示。重示有二。初总举德劝。二如我下引喻以示。有六喻中各二文可知。第一法性无我喻。二无有来者喻。三无方住处喻。四离作成善喻。五法无方面喻。六法无诸过喻。第二教往中有四。初举益以教劝。二天子其有下举损示劝。三汝昔下举恩以示。四诸天子下示法以劝也。第三兴供养文有六。一兴供具。二往。三不见。四天重示。五重生敬念。六尔时天妙音下重敬也。于其内外各有五百烦恼者。十使十恶自相乘即成一百。于内五尘迷生五百。于外五尘迷生五百也。二万一千等者可解也第四教发心中有三。初教发心及悔过。天子得益略有三句。二时诸天子下重问有二句。三尔时天声下答。答文有四。初示悔仪有五句。二譬如明净下喻况有三句。三譬如幻师下释伏疑。四若如是下结教诲义。第五获益文有二。初明得益有二句。二犹未能见下结答分齐。六尔时天子下展转修行教轨不绝有四。初以香华等修供养行。二尔时彼香云下自行熟已。复教摄余人有四句。三摩诃萨安住如是下行益成故复转益。四左手持下举喻以况成观境界也。文中有四。初举喻广大。彰法难信有三句。二佛告宝手菩萨如是下法合成其德用深广。三佛告宝手菩萨譬如千亿下广增喻况。四佛告宝手菩萨譬如定光下举喻分齐结法深广。此文难。须思之。且释迦佛为菩萨时。有一相益于一生益一众生。其一众生展转利益一切众生。并一生至离垢三昧。如是一切众生复利一切众生。如是尽穷后际。下至遍傍。化作如意珠亦利益尽穷后际。菩萨一相既如是用。当知佛相德用不可说。佛一小相德既如是。佛大相海准之可识。文意如此。余相可知

    普贤菩萨行品第三十一

四门同上

一释名者。行周法界云普。体顺调善称贤。菩萨是人。行者明因。行体从二义得名

二来意者。何故来。有二。一疑者云向前因果以何为体。依何以成。为决此疑也此即第二自体因果。此品是因性起是果。此因果与上修成云何取别。若约缘分齐取。即属上。离性泯始终。即属此。问上地中广明离性。此云何也。答前欲摄别行为趣体方便故也。此中所明正是顺理之行性也。而无二体。义不相是耳。以缘尽缘。以性即并性也。问性起绝言离相。云何有因果。有二意。一为经内因中辨性起果中明性起故二也。二性由不住故起。起时离相顺法故有因果也。问起时离与缘修何别。答缘修离缘则不成。性起无缘即不损故别也。其普贤行亦如性起分顺修生也。何故下文云多法所成出现于世也。答此望解知。非约性体也。故下数云若如是知也。问若不知云何辨起。答余观异见故。缘修即不尔也。第二又解。摄前别行成其普德。以发性起故来也。若作此解由属修生。性起已下文入本有也。问普贤行何位成。答实即不依位。就彼解位已去成。为上经文在解已上说故。余准思摄

三宗者二门分别。约人约法。人体德用修生离始。广大异前耳。二法是普贤行法。亦有体相用。具有理教行果等也。但义异耳。问此二品无定及加集众。云何有体相。答此二品体表在玄。为彰法体极深广故。加集众等如地品初释也。法寄人显。故此人说也

四释文者。此文有四。初序。次正说。三结会证成。四偈诵。序文有三。初举略显广辨说分齐。二何以故下啧。三答。答文意前对缘故局少也。此体通缘非缘故宽也。亦可前缘修举体从相故局。此起依相入体故宽也。有此品摄本有修生修生本有。又前对一品二品机。此即普也。此总约五义。一位。二根。三事。四病。五行等也。文有四。初总辨上说少意。二愚痴众生下别辨随说意。三为如是下结。四佛子若菩萨下略出迷惑过失。此广文意者前教既大。云何局无一机。答为烦恼功力其大。小成大损。上虽非小所治不轻故。若望普贤法界不名为广也。此约嗔惑功能辨失。若约一切惑体时。唯是皮肉心三惑也。此中有六。一总辨失。二啧。三略答。四广释。五结。六重广。显广有三可知。百障约位有六。初十信。二不乐佛法下十住障三离菩萨行下十行障。四诽谤佛法下障十回向。五不乐菩萨住下初地已上障。六不顺三世佛即佛障。此在十地终也。理并通耳。二正说中有三可知

第二文有六十句。初五十因行。次十因中果。前中初十十信。二十十解已上。三十初地已上。次二十九地十地也。理即通耳。初十中前七自利法中修信。次三利他中修信也。第二十初六自行。次三利他行净。次第十因位净。第三十智次第配十地也。第四十巧随顺可知。第五十直心前七九地相。于中初二知根。次二知药。次二知顺正证方便。次一除障。后三十地相可知。第六十巧便初四法身果。次四报身果。次二化身果。次是故下结劝修行。有三可知。三证成可知有四。初动地雨华此有二可知。二等通余方。三十方同证。四复总结也。第四颂中有二。初长行举说意以生起。第二正偈诵。偈文有一百二十二行。初二总颂因行所说分齐。次广叹普贤行德。非诵前文。又亦一行一句即是一德不须更科也。此可思之。文云与诸如来等者。因果俱无相。因缘作及无作二发果力等故也。过去即未来二世等者。因此集果义。但三世一相故。十信即诸位也。如是一切但世相入者。即一一世法入现世。不证位成比也。此约三乘别行成。又亦九世自在摄受皆证也。此约普贤自在故尔。因果等法并然。准之。若临时变化相入等不在此限。宜可思之

    宝王如来性起品第三十二

四门同上

一辨名。宝王者摄德自在为王。可贵名宝也。如来者如实道来成正觉。性者体。起者现在心地耳。此即会其起相入实也

二来意者。前普贤明能起之缘。次辨所起也

三辨宗体者分别有二。约人约法。人但本有异前。法者如文耳。问性起分齐云何。答此有二义。一始终相对。二阔狭相对明分齐。初始发心至佛性起。终至大菩提大涅槃流通舍利也。阔狭顿悟及三乘始终。出世至声闻缘觉。世间下至地狱等诸位也仍起在大解大行大见闻心中。文义俱在下辨。至当指释。问若声闻等有性起者。何故文云于二处不生根。答言不生者不生菩提心性起芽。不言无果叶。若无者微尘中不应有经卷。准喻可知。若细分别地狱无果叶有体。声闻有体及果叶也

四释文者。所以性起问普贤说者。显器善胜法旷周也。此文有三。初序。二尔时普贤菩萨答下正说。三尔时十方下结说证成。序文有五。初眉间放光发起有二可知。二尔时一切大众下疑念生起。三尔时如来性起下明对佛欲请。四时如来口中下口中出光。以示说者亦通加耳。五尔时如来性起问下正问发起。初放光中有八业。一请业。二因业三敬业。四觉业。五止业。六降伏业。七示现业。八卷舒业。有一流星身也。第三欲请中有三。初长行示现请仪。二偈陈己意。三结偈有五。初六偈叹佛德。三善学下陈己所谓。三大众皆净下叹根胜妙。四叹所说法。五正觉下成所欲意。第四光示文有三。初辨光同前。二明所归。三尔时普下明益相也。第二正说文有三。初示名总答。即本分也。二尔时如来性起问下重请。即请分耳。三尔时普贤菩萨告下即说分也。初本中有三。初举先事。二结说。三辨益。二请中初长行。次偈请。长行中有四。初总请。二叹众器熟。三仁者下叹说者堪能。四善哉下结请。叹器熟中有三。初举众集。二叹德。三结。集德中初自利德。二大悲下利他德。三说者堪能德中有二。初自利。二于诸佛法下利他德。二偈文有二。初长行生起。二正偈颂偈文有三。初二总叹说听者德以请。二有十三半正别请。三十方下四叹众会希有请。别请中有二。初十半问果。次三问因。果中初七半陈事。次三叹德耳。三说分有三。初总叹。二所以下啧。三非少因缘下广答。答中有二。初由多因成。故不思议总叹。二以十种无量下辨相有二。初酬因问。二佛子云何知见如来身下答上果问。此初即答上因问。此文有二。初总明十门。二别解。初分有四可知。二别解文有二意。一释上十门。二上十门中一门即有二。初长行次偈颂长行有二。初辨因体。二佛子菩萨又复应知下辨性起德用。此或在知人或法也。初辨体中有十幡。初有二。初释次结。释有二。初喻后合。余皆同此。初明众缘共起喻。二大机堪受喻。三缘成离作喻。四胜智善达喻五大用现前喻六机感随现喻。七有二喻。初名胜缘先济喻。二随欲所成喻。此释疑耳。八成自大事喻。九体用相依喻。十成益非虚喻。此十中前二第四依缘辨缘。余七约自体辨缘。第二重颂中有二。初长行生后。次偈颂。偈中分九。初二总叹性起无上。次八别叹校量性功德。次十举法以况也。次二结成体用自在。次二示教知者。次二劝听辨说分齐。次二举事许说。次三十五正说。次二教劝也。正说中初五结颂初喻。二四颂第二。次四颂第三。次三颂第四。次三颂第五。次三颂第六。次二颂第七中第二喻。次四颂第七中第一喻。次二颂第八。次二颂第九。次三颂第十耳第二辨身。此次第答上果问有二。初寄起发。二此菩萨知见无量下答。答中初长行。次偈颂。长行有四。一总答。二啧。三略答。四譬如下广释。略中二可知。广内有二。初辨法体。二菩萨具足成就下辨德用。此用或属知人。或摄在法也。余十文相同前。一密身普摄喻。二在缘离无住喻。三辨事利生喻。四中有二。一胜缘先济喻。二机感随现喻。五潜用资成喻。合中有三。一正合前喻。二引光证成。三辨光利益。六随根殊现喻。七一身多感喻。八无思成事喻。九大宝摄德喻。十摄治从愿喻

第二偈颂。初生起。次正颂偈有四十二。初四颂第一喻。次四颂第二。次四颂第三。次五颂第四。次四颂第五。次四颂第六。次四颂第七。次五颂第八。次四颂第九。次四颂第十。问上来所辨。多与初同义云何也。答由能德显即属初因。今此举能取所依止也。三音声有二。初寄问。二答。答文有二。初总。次别。别中有二。初长行。次偈颂。长行有二。初辨法体。二菩萨知见音声十种无量下明德用。亦二通谓能所也。法体有十。初文有五。初法。次如呼响下喻。三知见下合。四譬如世界下重喻示。五如来妙音亦尔下合。前喻无性故顺理。后喻无性故具德。第三合内初叹知见胜。次对法成解以合上喻耳。此名声无本性喻。二声无自质喻。三有用益生喻。四随根开解喻。五随机感见喻。六依缘异现喻。七用无所依喻。亦可大用遍资喻。八审根受药喻。九大音具德喻。十随益非虚喻。第二偈颂有二。初生起。次颂颂有四十偈。四行颂一喻可知。四菩提性起心有二。初寄问。二答。答内初法次喻。问心意识非即佛者何也。此通二故。故文云智无量故心亦无量凡即可知。喻中分二。初长行。次偈颂。长行中分二。初辨十心法。二菩萨如是下结知利益。此初喻名智无所依喻。此何故约智辨。答有二意。一为一心体通染净故不约之。二今论性起智即是心约净辨故也。故文云智无依止也。一智无所依喻。二性无增减喻。三兴用益生喻。四智宝摄德喻。五智用殄非喻。六智堪含受喻。问详其文相似言独佛是性起何也。答须知大意。但菩萨从他受教。即是其果佛及菩萨能授他教。所有行德即属其芽也。此思准之。七坚固随益喻。问树生芽时诸树生芽。所况义云何。答此不异。何者但在一心中本有新生异耳。若尔与前众生不了而有性起。异义相违。答此各别门。所以知。为前义中声闻凡夫不知本性亦是性起。今此不知即非性起。得知别是异门。此约性起芽说。故异前耳。又问二处相违。因何不成矛盾。答一切善根有邪有正。但顺菩提者无问人天善根等。并是性起。不顺菩提者即非性起。此约果处分粗细。是以不违耳。八智用遍资喻。九巧不尽有喻。亦可巧便留惑喻。十性通平等喻。此文有三。初法次喻后合。余文可知。第二偈中有二。初长行生后。次颂偈有三十七有二。初一总示识佛心。余结十喻。初三结第一。次三颂第二。次四颂第三。次四颂第四。次三颂第五。次三颂第六。次五颂第七。次三颂第八。次四颂第九。次四颂第十。五境界有二。初寄问。二答。答文有二。初长行次偈颂。初文有二。初辨境体。二饶益众生下辨利益用。初文有三。初法次喻后合。初法说有四。初总举佛境。二非境界下辨佛境分齐。三佛子一切众生无量下辨境深广。四佛子菩萨知心下约法定体以明深义。二喻有三。初佛境分齐喻。第二境起因缘喻。第三境界深广喻也。境界有二。一所缘境。二分齐境。此通二也。第二偈文有二。初生起。次正颂。偈有十分四。初二颂前法说。次三颂初喻。次一颂第二喻次四颂第三喻也。六佛行有二。初寄问。二答。答中初长行次偈颂。长行有三。初法说。次譬如法界下譬况。三佛子菩萨如是等下结德业用。喻中有五。各有譬合。初一至绝三际喻。二业性无碍喻。三用穷法界喻。四起业济生喻。五无功成事喻。第二颂中有二。初生起。次偈颂。偈有十分五。二偈颂一喻可知。七菩提文有二。初寄问。二答。答文有二。初长行次偈颂。长行有三。初法。次喻。后佛子菩萨以如是下结其业用。初法说有二。初辨体。二知处等下辨用。亦可初自利次利他。二就喻中有二。各有喻合。初名现机定器喻。二至寂离性喻。初合喻文有四。一正合上喻。二佛子一切佛下辨菩提离言。三佛子成菩提时下辨离言相。四佛子如来身中下释离言用事。三辨相文有三。初释相。二佛子随如来下类以成法。三如来具足下结成。四用事中有三。一辨用事。二皆悉一性下释所以耳。三如是下结。第二合喻有二。初辨法。二复次佛子于一毛道下辨依法成解。初文有二。初辨法体。二佛子如来成正觉已下成身业用。此文有二。初辨次结。初法体文有二。初辨次结。初文有二。初正合上喻。二佛子设有下有二。初问答假设类成。二成解文有二。初建万像通体。二复次佛子下解自他无咎有。三结可知。二颂文有二。初长行生后。次偈颂。偈有十二分六。初二结法说。次二颂初喻。次二颂第二喻。次二颂假设类文。次二颂成身用。次二总叹德用也。八转法轮有二。初寄问。二答。答文有二。初长行次偈颂。长行有二。初释次结。释文有三。初总辨体。二譬如下譬况广辨。三佛子若如是下结定损益。初总辨中有六。初辨体。二辨分齐。三明所离。四譬况。五释成。六类释。广辨中有二。初约体辨。二复次佛子下约用辨成。初有二譬各有譬合。初大音无尽喻。二大响遍周喻。第二合文有三。初立。二啧。三答可知。二约用辨成有五可知。二颂文有二。初生后。次颂偈有十分五。初一颂总辨文。次一颂第一喻。次二半颂第二喻。次三半颂约用辨成文。次二总叹也。九涅槃有二。初寄问。二答。答文有二。初长行次偈。长行有二。初辨法体。二复次菩萨如是知涅槃下结知业用。初文有二。初法总辨。次喻广释。初文有四。初总约法劝知。二出涅槃体有三可知。三佛子如来下明不说本涅槃体但辨性起。文有五可知。四佛子但如来下明说事相涅槃。文有三可知。二广辨中有二。初约喻以辨。二如来示现涅槃时下显事用随缘分齐相也。文有二。释结可知。前喻有三。各有譬合结三文。初现局体通喻。二化穷尽灭喻。三赴用随机喻。第二偈文有二。初生后。次偈颂。偈有十二分五。初二颂第一喻。次二颂第二喻。次二颂第三喻。次四颂用随缘文。次二总叹耳。十见闻得益文有二。初寄问。二答。答文有二。初长行次偈颂。长行有二。初辨现未见闻流通益。二尔时诸菩萨下问经得名。辨经文义持利仪式。初文有二。初释。次佛子是为下结。前文有三。初总法说。次譬况广说。三于如来下辨见闻功行广大难说。此有三。初立。次责。三答。初法说中有四。初总辨成益不虚。有二句可知。二辨有中殊胜行。三成空中方便智。四明穷其果位具足胜德。譬况广文有二。初辨现在体益。二若有得经下未来住持用也。此有二可知。初现在益文有三喻。初二喻譬所得福慧坚固行德。后一喻性德胜用。前二喻者。初喻行穷坚实难坏喻。二名小智能焚大惑喻。此等各有譬合也。三者性起善巧资成喻。二问经名义及仪式等中有二。初问次答。答文有五。初示经名并经义用。二如是经典下明所为分齐。三是故菩萨下举益劝持。四佛子菩萨虽无量亿下显经要胜。此文有二。初辨损。次明益可知。五佛子菩萨闻此经已下明教修益方仪。二所为分齐中。初法次喻后合。颂中有二。初生起。次颂偈有八分四。初二总。次二颂第一喻。次二颂第二喻。次二颂第三喻。第三尔时十方下结说证成有二。初长行。次偈颂。亦可此偈是广说中第二重颂耳。初文有五。初动地并雨华有二。初辨次结通。二佛现身。亦二可知。三成行益。亦有二可知。四明得力所以。五菩萨云集为证。亦二可知。二偈颂有二。初长行明说意。二正颂。颂文有七分三。初二总辨法深难以喻显。次三叹闻法利益。次二举益劝持有三可知也

    离世间品第三十三

解行法相动静无碍此会成也。四门同上

一释名者。离者行体净义也。世间者所离之法。世者时。闻者中。但在时中者名世间也

二来意者有二。一辨教兴会来由。此下第三依缘修行成德分。所以来者。上既得法。次须依法就缘使修成行德故也。故下二品文中皆有劝辞。故知二品来者。前圣性现前。欲得不与凡共分齐故次来也

三宗者分别有二。一约人。人有正助。二人各有体相用。问此人与下知识人何异。答此是能宣教人。下知识是教所诠法人也准取之。二约法。法谓行法。即一乘道品也。三乘及小乘名数虽同三十七而意异也。广如诸经。一乘之行学亦有始。若依定学明始分齐者。若约回心人即用非至定及初禅定等为学始。若据直进人。即用光得意言定为初学始。若约一乘不共教。据行即寂静胜三昧为初学始。若约行解即华严定为初学始。若约行位即十行位定为初学始。若约人知识轨则用师子奋迅定为初学始。若约解信等即用净藏定等为初学始。若约正解用性起法门为初学始。若约解位即十解位定为初学始。此等约归向本实为言。顿悟人意言无分别定为初也。余可准知耳

四释文者此下有二分。初品明托法进修分。二入法界下明依人入证分。问何故对法不明入证。下约人方始入证。答法是所依。善巧由智。若不依善达机仪胜人。虽自有法未可得证也。故经云知识全梵行也。问上来法及此成行并无声闻。下法界知识即通辨声闻何也。答上法是顿。此行亦顿。为此无声闻。下法界中有二意。一为人有胜巧。引小成大。为明人德故说小也。二显法界发心始通二回故。此二品何故分二处说。答只桓重阁摄化之始。普光堂起行之初故也。故上来明菩萨起行发于普光。下明文殊教化起于重阁也。所以知。此重会别本云乃能重启斯义问故知也。此文有七。初序。次入定。三起。四请。五尔时普贤告下正说。六品末证成。七偈颂。初文有四。初时。二佛。三处。四同闻众。处中有二。初辨处。二依处成佛德。何故于此叹德。以因果淳熟功归化主故也。又行相可责故。德文有三。初总辨。二自分行。三能与一切下利他行。四同闻有二。初总列数叹德此初文有四。初举俱。二略叹德有二。初练始异终。二练新异旧。三具足成就下别叹德。四具足如是下结。三别叹德中有二。初自分德。二于一念中下他分德。自分中初自利。二善摄众生下利他。第二列名叹德中有二。初列名。此略列。所以此文菩萨名同普者。为行体顺理成无异相故也。次叹德中有四初总。二随诸世下摄法为首行。三悉能受持下护持正法行。四随诸下示成大事行。二入定中有三。初入定。二列名。三明定力。所以此名华严定。表行严果故。三明起定同前可知。四请问中所以独普慧为法先问。彰今但以慧导行也。复显机广大故。但慧发于体。故普慧略问二百句。巧行随缘故。普贤广答二千句也。此中已下有十意。故行教兴。一由为与胜人同行故。二佛护念故。三成就不可思议诸善根故。四具足菩萨根故。五生佛家故。六得善知识力故。七一切诸佛神力持故。八卢舍那佛本愿力故。九善根熟故。十堪受普贤菩萨行故也。此文正在善知识义通此品耳。此可思准之。问中有三。初总告。二正问。三善哉下总结请也。所以普贤答表行广故。此文有六。即六位也。初二十句十信位。次何等发普贤心下二十句十住位。三何等为持下三十句十行位。四何等宝住下二十九句十回向位。五何等身业下五十句十地位。六何等观察下五十一句问果位差别。故别本云。愿解说菩萨行。从始至终令无疑也。就尔时普贤告下第五说分广答上六位也。初十信位中有三。初九十句自分行满。二十种入下八十句胜分行。三十不可坏智下三十句利他行。初九十中。初五十自利行。二正希望下二十利他行。三十戒下二十当位因成果满。初依果者泛有四种。一国土等依果。二习气依前果生。三习因习果。四因体相依因果。此中不说前二也。亦可说同第一。此可思准。此文有二。初八自分。后二胜进可知。此等文中十十皆有四。一举数。二列名释。三结。四举利劝学唯除佛地及共法行。更无异果等法学故。因果既立能解非胜。智不成故明十奇特想。此中初八自分。次二他分也。既有大解须起大行。次明十行。修行之来必须依善友。故明十知识。初一安固菩提心。次三依道心成自利行。次四依心成利他行。次一依心成普贤行。次一依大行入法界。若不策勤无由进道。次明十精进。欲明精进合理明十悕望。前八自分。后二胜进。离偏名正耳。依正悕有力故辨十种成就众生。初一布施摄。次二爱语。次二同事。次五利行。由利生故恶无不离。善无不积。故明十戒。既前德成。故明十授记。二有八十。胜分行有三。初二十自行。次四十入利他行。次二十入利他因果中。既自行成次入胜境也。行胜故入十如来境也。初一示成菩提。次八三业利物。次一入涅槃。八中初四口。次二身。次二意。用既入胜用须识器性。故明十入众生心行。既识根次明所安处。故明十入世界。既得依处须识时修短。故辨十入劫。虽时自在。说示不明理亦难可。故辨十说三世。既识时次明时中法。故次辨三世间。文言入世间者。一知三法现时中故。二入语法通义力故。又有施设通情曰道故。三入语义体性故。四入语义随方施设故。五入知识语义想故。六入语言因故。七知语言分齐故。八入言义互转无尽故。九知时中离染。言义亦如是故。十知时中性净故。言义亦如是。既达时中法得法解益故。第八十舍离忧恼。心无厌悔。初四自利。次五利他行。次一自他俱行。第三利他内。初成作事无悔其心坚固。次明十利他智不可坏。初二利他。次八自利。既有智故能持法。次十陀罗尼。前九持因法。次一持果法。以持成就分解果法故。次第三辨说十佛化被于他。初三报佛。次三化。次四法佛。此但一相解耳。若依此经即并通摄也。第二普贤心下答十解位问有三。初五十句明解方便。二十清净下七十句解位正修对治行。三十说法下八十句利他行。初中大心为本故发普贤心。初三护众生心。次三趣果智心。次四厌离有为心。既大心成。次成大行。第二十普贤行。初九自分行法。次一胜进行法。大行既备次辨悲济物。第三十大悲。悲心既具次依悲明发心之具。第四十发菩提心因缘。既大心成已次须依善友令增。第五近善知识。前八起因行。次二起果行。解位第二有七十句为三。初二十明方便修。二随顺觉下三十明解成就。三十明所知法门差别。以近善友故能远诸惑。第一十清净。既离障故。高升彼岸。第二十波罗蜜。既行体成。于所知中随顺觉达。第三十随顺觉知。既随知已。成知精立。第四十决定知。既决定多有堪能。第五十力。既智力堪能。第六辨十平等。既得理观须起智用。第七辨十方便佛法句。就第三利他八十句复为三。初四十正对缘说法。显辨才德备。次十无著下三十辨无著智成。次十句辨化德备足。初既解已。须起言说。第一辨十说法。既说法已。次须受持故。第二十受持方法。前七持因行。次三持果法。既受持已讽诵。须第三十才由才无滞。德相殊出。第四辨十胜法。前八方便修胜。次二自在用胜。正以德起胜能。于境缘无执。第五辨十无著。以无著故成平等证。第六辨十平等心。前八自分行中平等。次二胜分行中平等。心既得平等。依证起后得智。第七辨十出生智。从后智起用。第八辨十变化。第三十持下三百句答上十行问有三。初六十句胜入佛境障尽清净。二十不思议下九十句辨对治道成行德清净。三十园林下一百五十句当位修成满足也。初中有三。初十辨行体。次二十入佛境界。下三十句行成除障。初持有四。一因持果。如种性持。二果持因。如地持加持等。三住持力益。四心境相持如论。此中通也。既种性持成。于法悕望不厌。第二辨十正悕望。正以悕法智成。心彻无碍。第三辨十深入佛法。初四约器世间明佛法。次二众生世间。次三智正觉。次一总法界为佛法。既入佛法。缘无不实。皆是起行所依。第四辨十依止。既有所凭。于缘无惧故。第五辨十无畏心。正以于缘无惧。自知得决定故。第六辨十无疑心。初三自行。次四利他。次三自他俱成。第二子段九十句。治行成中有三。初三十方便对治行。次十正受三昧下三十行体等无碍。次神通下三十行成作用。正以无疑于深法中智能解达。故辨十不思议。又亦可无疑入深法。故不思议也。既得深智解巧隋生。故第二辨十巧方便能说微密语。既得密语复巧知所入。故第三辨十巧方便分别智。初二约器世间明智。次六众生世间。次二智正觉。即常寂静故。第四辨十正受三昧。从定起通慧。无所不达故。第五辨十一切处。正以处无不在。体遍无碍故。第六辨十法门。起用自在故。第七辨十神通。正以神通自在缘无不达故。第八辨十明。以明智起无明缚尽故。第九十解脱。园林下第三行德具足。一百五十句有三。初四十明报相具足。二十不动心下四十辨实解为行本。三十无垢下七十句大用成满。初行用所依。智游境界。故辨十园林。前七方便行。次三果德。既外游已。复须内安故。第二辨十宫殿。以胜妙能出生道利。为物忻乐故。第三辨十乐。乐心成已。德发法身故。第四辨十庄严。前八方便行严。次二淳熟行严。第二四十句中德严身已。行德坚固故。第一明不动心。以行体坚。于胜理中心能穷达故。第二辨十不舍深心。既深至难坏善能得理故。第三明智慧观察。既达无遗。于法善能拣别故。第四辨十分别法。第三七十中有二。初三十明离障净。次四十行德成就。初辨十无垢智故。智行揩定。故第二辨十智印。问文云知如来法是文字智印者约何义说。答菩萨及佛各知法无边。若用二圣相对时菩萨即不及佛。佛即过菩萨。所以者。为法性体上二门具足法尔故。此约一乘解也。既行不坏照用无碍。故第三辨十智光明。智光无碍旨无不契。故第四辨十不可称量住。以行体难胜勇猛无间故。第五明十发无懈怠心。以策成大心决定正向故。第六辨十须弥山王心正直心。以正心于内决定不动于世间中。利他果成。故第七辨十深入大海智慧成三菩提。前八自行。后二利他也。第四十宝住下二百九十句答上十回向有三。初一百一十明十回向行体成就离障。二十自在下一百二十辨行相自在无碍。三十游神通下七十辨行用究竟。初有二。初四十句行成高栖彼岸。二十信下七十对治道成。离障清净。初行称理成。无住名宝住。既行与理合德位坚固。故第二辨十发金刚心。大乘显彰果位圆备。故第三辨十发大事。初三自利。次三利他。次四菩提果满。正以佛事满足众行圆备故。第四辨十究竟大事。但前明发行。后辨究竟。有此异也。前八自分行成。次二他分行熟耳。第二七十句中。初三十明回向行体。次四十能生出世间行。初十不坏信初三三宝所不坏信。次二同行人所。次一众生所。次四于法成不坏。以信成就生在佛家故。第二辨十授记。既道种成就向果必然。故第三辨十善根。初四回向菩提。次四等诸菩萨回向众生。次二回向菩提。回向位成智用自在。故第四辨十智慧。初四自分行自在。次六他分行自在耳。以智用照明旷周法界故。第五辨十无量广心。前七自分因行。次三胜分行。智用普周体包无外。德穷海奥。故第六辨十藏。前七自分行。后三胜分行。既积德备满。刚[麩-夫+廣]斯尽。故第七辨十调顺。初四胜分境中调。次六自分行中顺。第二十自在下一百二十句辨行相自在。于中初十总辨自在。二有一百一十句别辨自在。初中初五自分行。后五胜进行。此自在六位通有。但约生信胜劣为异耳。下一百一十中初别立十章门。二依章释。门初中有五。初二就依正以辨自在。次二约人法。次二约境智。第四约智用。第五对力用以显。二别辨释中。初释次结。初一众生。二刹。三法。四身。五愿。六境界。七智。八通。九神力。此唯约色耳。十力自在第三七十句中。初二十行周殊胜下无畏不共等五十明行德究竟。初十游戏神通明善巧转变无碍。以智用游化即体殊妙故。第二辨十胜行。其德殊胜智力有余。故第三辨十力。前七因行。后三果满。智力功强外无所惧。故第四辨十无畏。智断具足二乘不同。故第五辨十不共法。不共异小能与净土为因。故第六辨十业。由德行坚固。第七辨十身。第五十身业下五百句答上十地因位所问相有四。初一百二十句辨正修行体。寄在初地。二十方便下九十句辨造修离障。二地已上。三十离生下九十句辨修淳熟德。四地已上。四十足下二百句辨报相具足。八地已上。初文有三。初二十句辨身业。次四十句辨口业。下六十句辨意业。初身二十句中。初十体。次十别用相。第二口业中。初十辨体。次十辨口业因行。初四自利。次六利他。口业善故得诸神加护。次十守护由护成内德。能外化故。第四辨十大事。第三意业六十句中。初十意业体。下五十辨意业作用。初体中初三利他。次七自利行。既得体已须顺理造修。故第二辨十发心。发心行成终于法界。故第三辨十满心。由正智能生后得信等根。故第四辨十根。既行体立解心当理。故第五辨十直心。既理观开明契穷实际。第六辨十深心。前九自行。次一利他。第二九十句中初三十句明自行。二十入众生下三二十利他后十趣下三十辨自他行成。初因行巧修。故明十方便。以善巧方便而能忻求诸行。故第二辨十乐修。由乐修故障累斯亡。道味渐现故第三辨十解脱。由解脱故深知物性。故第四辨十入性由深入性道味渐细故第五辨十习气。道味渐增成其大用。故第六辨十炽然。即炽盛修也。不动胜进无所不至。皆合圣趣。故第七辨十趣。既依正趣德行外彰。故第八十事具足佛法。既得佛法须识退过。故第九辨十退失佛法。初四利他行不成。次六自利行不成。第三九十句中有三。初三十句明因行体。次十名号下二十句辨行用差别。三十无量道下四十句因德成就。初十离生者方便生死障尽也。以顺无生行成坚固故。第二辨十决定法。初五自分。后五胜分行。以自体坚固故。第三辨十出生佛法。以行成故德彰于时。故第四辨十号。以圆德显彰壅滞斯尽自体虚通故。第五辨十道。此即约增数以明道体。前道自体辨道境无量。故第六辨十无量道。即明分齐。正以所观道境界无量故。能观道法亦无量更无别法。亦可道之数也。道法既成次明能成之因。即第七也。第八十修道者一圆数故也。即辨策修方便。第九十庄严道者由别策修显德故也。又言无量道具者起道因缘。又摄在己能资于道。故名具也。无量修道者摄法在己堪能进达。故名修道。无量庄严道者众行互相庄严故也。此等始末真如所流缘起共成。故一处举。次第明之。此等若从所见则道法之道。若摄在己即道行之道故也。十足下第四二百句中有四。初二十辨八地已上根行淳熟外方便用。二十腹下六十句辨报体差别。三十眼下六十句辨报相差别。四十行已下六十句辨报用差别。八地已上同佛身业等故也。初十足者运报根本。进发之初。造用方便授受自他故。第二辨十手。第二报体六十中。初十腹者总能容摄故。复能蕴积。故第二辨十藏。行用缘起斯从本实而立。故第三辨十心。以德业成就互相严饰营发法身故。第四辨十庄严。行德自严防殄诸过。故第五辨十器仗。降诸魔等也。众行集起德成最胜。故第六辨十头。次十眼下六十句辨报相差别。初行德净胜照了缘起。故名十眼也。初五即五眼。后五作用得名。大论云无常肉眼畏风大故不见他方。此常肉眼自在见他方色也。二天眼见二世法。三慧眼见信等根。四法眼见一切法真实相。五佛眼见十力。此等诸经亦不定。次五可知。既有照用。复能摄诸声教。故第二辨十耳。十德备故行受戒香。故第三辨十鼻。众德聚成能宣示轨。故第四辨十舌。行坚自在形无不现。故第五辨十身。既色相外彰。明心内发。故第六辨十意。前九因行。次一果行。第四报用六十句中。以法身成立德用殊能威仪具足故明四威仪行也。造修方便须进发不住。故第一辨十行法。方便进修则有自分成立。故第二辨十住行。既立安固不动。故第三辨十座。初四自行德。次六利他德进行平等众相永夷。故第四辨十卧。众行既备必有相应之境。故第五辨十住。前能住此明所住法。有所依法其行无不。故第六辨十行法。前行始修。故约闻等此约终成故念等为行也。又名行也。次第六观察下五百一十句答上第六问因圆果满行德圆备义有二。初三百二十句辨因行究竟障尽清净。二十住兜率天下有一百九十句辨果德究竟。此中等觉及妙觉合明也。初文有三。初一百四十明因行成就。二十义下八十句辨方便修顺胜进义。三十魔下一百句辨因行成障尽清净。初一百四十句有三。初四十辨行方便。二六十句六度自利行体。次十慈下四十句辨四等利他行体。初十观察者凡辨行相必须善达通塞故也。初四自分行。次六他分行法。一往不尽。故第二辨十周遍观察。所观周悉行无不建。威宿勇健。故第三辨十奋迅。勇健无畏能决定说。故第四辨十师子吼。既能宣说。若自无德无由利物故。次辨十施下六度自行体次第如摄论。一施。二戒。三忍。四精进有三。初四是勤勇。第五是加行。下五不下难坏无足精进。五定。六慧。次十慈下四十句利他行体初十慈与乐意先故。初二平等普摄。次三令离障。后五令行成。次第二十悲。第三十喜。第四十舍。次十义下。第二八十句辨方便胜进有二。初四十自分行成。次四十句胜进修成。初十以义成行也。前七自分。次三胜进。如来义者顺如而来也。第二十法以法成行也。第三十功德具者辨行因缘。后明成智慧因缘故。第四十辨智慧具。次四十句者初十明足解心游履诸法门。既有进趣方便。必于三乘等法无厌。故第二辨十求法行。得法在己善解明达。故第三辨十明了。善法行成趣无上道。故第四辨十回向法。第三辨因行障尽。文有二。初五十句辨见佛行成入佛境也。二十慢下五十句入佛境界为佛加护。初五十中有三。初二十明道障现前。次十对治除障。次二十障尽见佛。初十魔者于道有障故。次第二十魔业。前是体。今此是力用有十一句。前七自行不成。次三利他不立。次一果德不满。然道障交竞。不除而自灭。故第三辨十舍离魔业。前七自分行成。后三胜进行立。体碍既尽。行入佛境。故第四辨十见佛。前信始但解。今行成故见也。既得体相应大用无方。故第五辨十佛业。后五十句佛加被中有三。初二十句对治胜分障方便行成。次三十后障复起摄行在障。三有二十句果德加入佛境界。初慢业者轨道相迷于胜分。故在初也。识障不起敬理重法。故第二辨十智业。若不识道相即随有为。不免羁缚故。第三辨魔所摄持。以正达道相即正觉开明故。第四辨十佛所摄持。以契如实即法被于己故。第五辨十法摄持。次第二佛住兜率天等一百九十句辨果德满足中有四。初四十辨因行胜进与般若法门相应。二十生下五十句明胜行自严建立自在。三十出家下六十句胜治行成障尽清净。四十觉如来力下四十句明果德满足佛事究竟。初住兜率十事业者。自他俱利。后边行满耳。自他行满已。将欲处缘摄化。若不舍无有生死。大果无由得达。故第二辨临命终十示现事。示现已。次十事下降神母胎。就中初五句利他后五句摄因果相应。所现难测旨趣精深。故第四辨十微细趣。无生为生。故第五辨十生。自下五十句第二从母出生现世也。就初十种生中初六自分。次四胜进。德相外彰。故第二辨十庄严。众德备集道超世表。其行旷周功无不建。故第三辨十游行七步。其道始立清净无染。故第四辨十现童子。身若不在染何能显其清高。故第五辨十现中宫。处世不着。缘所非碍。故第六辨十出家。此下六十句明对治行相。以性离相违缘不碍。洮练身心炽然不懈。故第二辨十苦行。舍离二边随顺中道。故第三辨十往诣道场。随顺中道摄果相应。故第四辨十坐道场。摄果在己超升独绝。故第五辨十奇特。善觉三昧等是后如来力中。令将此欲超群惑显智用圆明力。故第六辨十降魔。有为生灭不断而自息。大智真用不拂而自明。故第四段辨十如来力。下四十句明之。此即解脱道中顿得十力也。此善觉三昧即奇特中九也。真相内。显次正轨彰时故。第二明十转法轮。以教被机无缘不益故。第三辨十白法入众生心。同化既毕。息影归真。故第四辨十涅槃。即初十文耳。亦可涅槃是常。依缘现没。故次明也。即后十句耳。佛子是为大妙法门下第六结证述成有二。初总。次别。别文有三。初结劝修行。二佛子此经出生下辨经名叹经德用。有三可知也。经名有四义。一行。二解。三所离。四利他。如文应知耳。三说此出生下明雨华等证成。初文有三初结法叹德。二佛子若众生下辨修行益。有三可知。三佛子是故下明劝修。三说此出一切下证成有三。初牒经名。二动地。三十方佛同叹。有三可知。同名佛对示普贤者明大行不虚也。第七重颂中有二初长行生后。次偈颂颂。文有二百三十一偈有二。初二总举诫听。第二下广辨广文有三。初一百四十九半总颂普贤二千答意。二常依如来智下四十三正颂二千答。三菩萨修诸行下三十八半颂结叹文。初有三。初有十四叹德深广非言可尽。二持众生下六十七菩萨德深。故广举事况。三一身无边际下六十六偈半正叹因果行相德用自在。二事况中有三。初五十六半举三十余事喻因行差别二菩萨等如来下六偈况讫。总明行相。三菩萨悉成就下四半结德劝听。一身无边际下第三六十半为二。初三十六偈半叹因行摄益。二菩萨一念中下三十叹果德摄益自在。前叹因行有二。初十一半叹自分因行入佛境界。二示现种种下二十五辨因行利用。就二十五偈中。初十八明他行自在。如是众生下七明应机授法。菩萨一念下果摄益三十文有三。初十四自他果德摄化。二观色如聚沫下十一辨菩萨道善达真性。三广入下五结成功行利益。其旨深奥宁可悉宣。聊以一尘之说以况玄趣耳。次半常依如来下第二有四十三。颂上二千答有六。初四颂上十信位。次四颂上十住。次六颂上十行。次六颂上十回向。次清净身业下十颂上十地因位。次观察下十三颂上因圆果满佛事究竟。次菩萨修诸行下第三有三十八半。颂上结文有二。初三十二半结因果德自在。下六偈举以劝修。初文中初六半略结叹行用自在。下二十六广辨行用自在。二十六中初十六叹因行自在。二净身等虚空下十叹果行自在。因行中初二叹意业。次四半叹口业。下十叹身业。果行中初二正叹果德三业成就。次八喻果自在。第二劝修中初二总举因果行德。次喻况难尽。下二劝修同会莫二也

大方广佛华严经搜玄分齐通智方轨卷第四(之下)大方广佛华严经搜玄分齐通智方轨卷第五(之上)

        终南山至相寺沙门智俨述

    入法界品第三十四

此是第八会在只桓重阁说。所以在只桓摄化始故。所以在重阁表悲心在正智上重生故。此即第二依人入证分四门同上

一辨名者。何义故名入法界。答其法有三种。谓意所知法。自性及轨则也。此中通三也。界者是一切法通性。亦因。亦分齐也。入者得此法门

二来意者。何故来。上虽得行解法。若不依知识加持无由进会故来也

三宗体者分别有二。约人及约法。初人者正化及助化各有体相用。准思摄之。二法者人法也有二。谓约人。二约法。人者谓因人及果人。各成师及伴知识。并有同生及异生。亦有五生之身。此可思准。二约法者有十。一因。二果。三约行。四理。五教。六义。七事。八人。九法。十解。前人是弘教人。后人是所依法人也。此可思准之。入法界分齐云何。答有二义。一始从初发心。终即不定。若依经文但至金刚心已还。若义求即通果德耳。依文为定。果位不可说故。又望机即不通果。约知识自行则通因果。为用通果因。又果位无求相。此约三乘说。若约一乘时亦通果。如离世间品说。所以准之可识也。二阔狭者唯在大乘心。小菩萨声闻凡夫不说入法界。问性起即通。此品局者何也。答性起宗欲明约法辨分齐故通。此明约入心辨分齐故局耳。性起约法。假使不证不名不起。余义对文分释

四释文者此文有二。初发起序。二尔时世尊欲令诸菩萨下辨正宗。此宗明何义意。明知识力也。已前诸会并先放光令余方知显说法浅深集众增微。复以音声为正说。此会不然。但如来放光显现三世间。令大众入即为正说也。更不别有言下诸知识通耳。今约初明意。知识有四力。近善知识。听闻正法。系念思惟。如法修行。下文具有此意耳。复有四能。如摄论说。初序文有九。一说时。二化主。三住处。四同闻。五大众疑念。六佛入三昧。七十方新众集。八说偈赞叹。九普贤重开发三昧德用也。前诸会并集新众已。然后入定。此何在前。答前即入来趣化主。说有别人。人欲说时方始入定。今此不然。佛自授机佛若不入定诸人来即无由。故先入定显相。后方新众集也。即是因人果人设则不同。又为下文二重显法至第二重方始下趣人入知见故也。此何佛自入。答今为成行人法。若不果人自入显法是真。无由引彼因人令成大果故也。何故入师子奋迅定。欲令菩萨得故。复显表勇健授教令使修者伏妄显真故也。四同闻众有三初菩萨。次声闻。三天王等。何故菩萨在先。答诸经从相取亲教。以通渐故。此经约理以辨。由是顿教故也所以此众独有声闻。此有二意。一为显法界摄相应故。二为回小入大行。故菩萨众有三。一举数。二列一百四十名。有十五位各显别法。可思之。三叹德。德文初总。次别。别有二。初七自利行。后三句利他行。二声闻中有三。初举数。二列名。三叹德。五疑念请中。初请。次结。初有六十句有三。初三十句辨所请法。二有十句叹众堪闻。三二十句叹佛堪说。法中有三。初正辨所请果法。二十句辨因人未穷。三有十推功在佛。初所疑法中有三。一辨疑人。二辨念。三明所念法。三叹佛堪说中。初十句明因圆。二有十叹果满。六入定中有二。初入定。二入三昧已已下明显净土相。即定力也。初文有三。初辨方便。二正入。三欲令下明入意所为。此何故唯依大悲。为前说通解行此唯存行令其去危得乐故也。第二入定力显净土中有五。初庄严重阁。二严园林。三严虚空。四何以故下释成。五如此祇树下结通十方。初文有二。初总次别。别中有十种庄严可知。下诸园空十句可知。五结中有四。初结。次佛集。三菩萨集。四重严空。亦可大文分三。初庄重阁等即器世间。二如来集即智正觉。三菩萨集即众生世间耳。所以因果俱集。显因果实成故也。七集众文有三。初辨十方众集。二是诸菩萨下叹德。三尔时诸大声闻下辨不共相。初文十方皆有八。初远过尘数界海即从量也。二列世界名。三辨佛名。四列上首菩萨名。五辨眷属。六供养具。七来诣佛所。八各化阁而坐。余同尔耳。所以菩萨名王证法界行用自在故也。第二叹德文有二。初叹。二皆是如来下推功。初文有三。初总叹。二成就下别叹德。三此诸菩萨下结叹集也。别中有二。初自分德。二于大众中即师子吼下他分德。初中有三。初辨自利行。二能于一切如来下利他行。三具足十力下辨俱成。自他分德满也。第三辨声闻不共即显法界是深。文中有二。初正不见。二譬如饿鬼下譬况。初文有三。初明不见佛真常行德。二何以故释成不见所以。三是故虽与下结。初文有三。初列名。二如是等诸大下不见法界果德。此即与上十句所问法大同也。文有三可知。三亦复不见下不见圆通大众因行。第三不见因行境界中有三。初总举。二正辨。三如是等下结。第二释成中有二。初责次答。答有二。初总。二本不修习能见如来下别辨不见意。此中二。初明不修大行故不见。二亦无三昧清净智眼下正辨不见相。初文有三。初由不修故不见。二是诸功德下不共故不见。有三可知。三是故诸大弟子下结。初不修文有二。初不修果德。二不求菩萨下不求因行。第二正辨不见有二。初明不见。二何以故辨所以。初文有二。初总次别。别中有二。初无自大果失。亦不乐说下二无他恩德失。余者可知耳。第二喻况中有十喻。初名惑障胜境喻。二不穷源底喻。三求下失上喻。四无所摄取喻。五临光失眼喻。六修得异果喻。七同居异见喻。八不行同一行喻。九深浅相形喻。十住位息求喻。第八叹德中有十人说偈。初人有三。初五叹土体。二有四叹众集。次有一结叹。二精进势王有十分五。初二总叹依正。二有二叹众会胜。三有二明来者神力。四有二叹佛德。五有二辨觉分齐。三普妙德王有十分二。初三法明佛德。次七喻。四无碍妙德藏王有十。次第叹佛可知。五善化月王有十。初四示报身令菩萨同入法界。次四显净土令修入者成就观智。次二辨佛转法轮利物。六法义慧焰王有十分有四。初三总叹下人非及。次二叹德广大。次二显其德相难知。次三显德是胜人境界。七一切众魔智幢有十中有三。初五叹法身。次二叹应身。次三叹化身。八净愿智幢王有十分二。初九叹修因行。次一明果成满。余相可知。九智慧势王有十分四。初二总叹二业利益。次二别叹身业益。次四叹口业益。次二叹意业益。十智通王有十一分三。初一总叹见佛益。次七叹佛慈悲德。次三辨见闻得益。慈悲中有三。初一明出世意。次五正叹慈悲相。次一辨所以耳。第九重辨定德用有二。初长行。次偈颂。初文有六。一明重意。二辨定三昧德用方便分齐法。三略列十一门方便所况事。初一总。余十别事耳。四为诸菩萨下明所为机器对法相拟耳。五何等十下辨三昧所成事用。则正照明。六佛子此师子下结略显广。此第五段中依一方便说十种法。十一方便即有一百一十法。十法何差别。一明佛兴次第。二明常说义分齐。三辨成佛。此上摄入智正觉。四明眷属。即众生世间。五明化身无碍。六辨住持自在。七辨功德所依。八明神力作用清净。九辨愿音声。十具明三世间转法轮义。后六名德用。又于中初三从所依。意一。身一。口一。又初身。次用。三位地。余意依文。准之可知。第二颂文有二。初十句辨颂意。二正颂。于中有十半。总颂上十法门。于中有三。初六正结前义。次三半明信入分齐。次一结成利益所以。前中有六偈。初一眷属净。次一说法净。次一显行净。次一云集净。次一显理净。次一照明净。第二文有三。初一总。次一半释。次一辨所以可知。问所以普贤重照明。答果人入定显法是真。若因人不证。同修者不进故。普贤因人。照明引初修者趣入耳。此约体入。若约用时。则重举用以显体也。第二正说中有二。初明如来大悲摄化令修行者入其法界。即正说体。二尔时文殊师利童子下广约善友。明入仪则也。问何故加入法界。不依位得何也。答理实须自他二力。今且约一相耳。自力依位。他力佛加持也。亦可初辨依三昧得自利德。二彼诸菩萨下成利他德。三尔时文殊童子下辨利他行相也。初文有二。初明佛入定。摄人入法界故。有四可知也。二尔时祇林大众下明诸菩萨因光入法。此文有六。初牒入人。二悉见一切下蒙光摄益。三如此间如来下结会平等。有二可知。四而不坏三世下辨所见益用。有六句可知。五其有众生下辨得益所以有五句。六逮得如来下广明其益相。二摄益中有三。初辨显器世间摄益。二诸大菩萨现坐下智正觉自在摄益。三或见在天下众生世间摄益。此文有二。初辨处。二显种种下明显身相。亦可但是智正觉十身也。若依下结文。但是国土世间及众生世间也。六广益相文有二。初得自利行。二时彼诸菩萨下明利他德。初文有二。初举德。二尔时文殊下说偈赞叹。初文有三。初举身座体。二显大自在下明座及身德用。三尔时彼诸菩萨深入下既有内资外显益相。随分利他也。初文有二。初举德成身。二彼师子座下明叹德显座。初文有四。初总出三昧德体。二次列十门以为德用。即上十门也。此文有二可知。三所谓种种下辨德所依。四得深入菩萨三昧门下广辨上三昧门耳。亦即所成也。亦可上十一门并是总功德门。此有三。初总。次别。三以广显略也。第二别中略明一百句三昧门。第三中有二。初结成广说。二入如来海下结观分齐。证行圆满也。此文有二可知。此中定三昧法门者并通一部为起法所依。所有解行分齐并皆准此思摄也。二座中有二可知。第二明座身德益有二。初辨相。次如是等下结成德相叹不可尽。初文有三。初十三句德自利行。二安住庄严下五十七利他行。三决了如来下二十自他行满可知。第三外益于文有三。初立。次释。三结。第二文殊偈赞祇林显证真实。所以文殊说彰净慧证也。所以不在利他。后说彰利他。起后说便故也。就十三半偈中。初十二别叹佛及祇林即果也。二普贤等佛子下总结庄严普集。即因也。第二利他德中有三。初辨果德被益。二彼诸菩萨下利他行体。三随其所应下辨对缘摄化。此第三对缘摄化中有四。初辨机器。亦可机缘相拟。二明同生益。三现不可说下辨现法门被益。四或现天宫下明现三世间摄化。三现法门中有三。初现无常等忻厌门。二为一切众生下辨十度行门。三以如是下结。第二十度中。初六可知。后四中为一一身方便度。悉能供养下愿度。悉能显现下力度。知一切下智度。下结法界非一耳。第四三世间有四。初现器世间。二或名号下现智正觉。三或现声闻下现众生世间。四或现种种色身下对三世间起用方便。余文可知也。尔时文殊童子下第二依其善友辨修入仪则。此望机辨所轨。若望知识自行即前依果人得法。今对机器起用也。今略取此经上下有五相不同。持是五相以科此文。何者五相。一显位修行相二会缘入实相。三摄德成因相。四智照无二相。五显因广大相也。今此中意以德彰人。以人引修行者入于法界故。广验诸教有二知识。一人。二法。分齐者有三。一初人者。教为言诠处。为方便门。人为旨。问等彰德。二若法者。言为教诠。总别同异等为观门。智眼所得者为旨。通明等为德。三人法合明即观教为诠。见处及人为方便。得法为旨见。说往因及仰推等为德也。广如别章。约时位等别。人有其四中五。文殊重也。今寄显法相。故有若干。若约正助即一百一十。若约实行即三千大千微尘等也。所以实约三千微尘等者。欲明附引三乘别机故也。若依一乘不只若干耳(云云)。此文分有五。初四十一人显位修行相。次摩耶一人会缘入实相。三弥勒一人摄德成因相。由行会理成正因故。四重会文殊一人寄智照无二相。五普贤一人寄显因广大相。后二人述因胜也。今约此意。若别位位皆差。若通行行皆有也。位即为相。通即为体耳。初四十一中。初一寄十信。次十寄十住。次十寄十行。次十寄十回向。次十寄十地。所以文殊初智光导故也。今以五门料简。一明缁素等别。若约行相并别不同。若总约相有十六种。一菩萨。二比丘。三比丘尼。四长者。五优婆夷。六童男。七童女。八天。九外道。十药师。十一船师。十二婆罗门。十三王。十四仙人。十五母。十六妇。二明修入徒众。唯初文殊所具诸众。次下唯一人。三辨往不往异者。初文殊往善财所。欲明初机不请自往。余四十二明善财往彼。为机胜也。次有摩耶及普贤二人。不去不来。摩耶会相故。普贤广大故。四叹发心不叹异。初文殊后普贤。文殊此不叹发心。意可知。亦可此亦不定诸知识中有不叹者。五结会有无者。余四十四无结会。显化未穷故。普贤有结会。明化位满故也。所以不现佛位化者。为表至果离相故也。此约所成自行。若望缘境如前可知耳此初知识菩萨字文殊入菩提心法门。初文殊文有三。初明文殊及眷属辞退南行以为化缘。所以辞从佛往为明果悲下被故。二尔时尊者舍利弗下对缘摄化。三尔时文殊知善财下明自位满足进入胜境。初文有四可知。二摄化文有三。初化引声闻即回小入大也。二尔时文殊菩萨建立下摄诸龙众。三时觉城人闻下摄化人众。初文有四。初舍利弗表从化之智。二此六千比丘下表所摄机器。三尔时尊者舍利弗下明睹相回心。四时诸比丘白尊者下求胜进入也。初文有二可知。二机器文有五可知。三睹相发心中有三。初觉察大众。二示其事相。三尔时尊者赞说下明从化得益。二示相文有二。初示自功德力。二海智乃至一切如来下辨上人加持也。四求胜进入中有五。初明见胜求进。有二可知。二文殊现象王回下胜进中缘器相应。有三可知。三尔时文殊告诸比丘下明对机授十信行法。四彼诸比丘下闻法获益。五尔时文殊劝诸比丘等示教大解行有二。初总令得普贤行及位。二彼诸下别辨可知。三授法文有三。初举益开十数立宗。二何等下别释。三若善男子下举益劝修耳。四获益文有三。初总得三昧门。二悉见下依定所现事。三得此三昧下广辨利益。二定所现事中有三。初见佛依正。二见佛转法轮。三又能知彼下知见三世果德差别事。此等由文迮。不得依次。可知之。二摄龙趣。就中有四。初结前生后。二明处胜。三说法。四赴机摄化可知。三摄善财文有三。初觉城人闻赴化。二列人数。四众即为四也。三尔时文殊知众集下明对机授药。此文有二。初总令生信。二观察善财下别属胜机。此文有二。初叹德。二文殊菩萨下为说胜进佛法。文有二可知。初文有二。初问次答。答文有二。初叹显德。二此善财者下叹过去行德。第三进求胜境文有三。初文殊南行引生胜欲。二善财随从文殊下明愿欲求进。三尔时文殊如象王回下赴欲赞教令入胜位。此犹在十信内也

二愿欲求进文有二。初少长行牒前生后。二正偈颂。颂文有三十四偈有二。初四明自无始迷轮。二有三十偈请求垂顾。初文有二。初二辨惑体。次二明过失。后三十偈中即为三十事。于中各二。初三句叹德。下一句请导。三赴欲赞教中有二。初长行。次偈颂。初文有二。初赞。次是故下教。初文有三。第二文有二可知。二偈颂中有二。初长行生起。二偈颂。颂有十偈分五。初二正叹善财能有大心。次一举余菩萨显成。次一重总叹善财。次五举五义叹善财德。次一举益以叹也。此下进入十住位。总作三门料简。一方所有顺因果通局。初文殊有东有南次功德云等二十七及第二十九大天乃至弥勒二十九人并云南方。第八回向云东方。第十回向及十地不云南方。各别有所。摩耶后文殊有示无方。普贤无示无方。所以然者南以表正。东表发觉。前文殊初信觉理故有东。胜进顺正故有南。次功德云等二十八表未证理故远有相应故云南。次十一得理及应行相故表随缘现。次一会相入实故不云方。等对方便相故示也。次一表结因位顺果故示南也。次一表胜智境故示。离取故无方。次一大故不可示。遍故不可局方也

二辨教问遣辞得舍修明进升之相。不遣者利益义微。复彰己独善。有此失也。善财不辞即失异闻进升之美。初文殊自往故。无人教问。亦无辞向。普贤中亦无辞向。意可知。三辨分量深浅推不推异。前四十一皆有结有推。后弥勒等无结无推。意可知也。就一一知识中显法多门不定。对文当知今此初功德云比丘当发心住位。入普贤光明观察正念诸佛三昧有三。初劝教胜进。即闻慧也。二时善财下依教趣入。即思慧也。三时彼比丘下得其法故名证法界。即修慧也。此中处及人名等并从当位义相得名。至文宜随义消息之。初文有四。初南方等处。二有一比丘下人名。三汝诣彼问下教得。四彼比丘下叹德。此出离始故现比丘形。二依教趣入文有六。初辞往。二正趣胜境。三于彼山中下依教简择。四见彼下依教见理得比境。五驰诣下依求趣入辨敬仪。六请问。三正入法界此文上下有四种证。一阿含约位证。二教解证。三正证。四上果下加证。复有十种证入。如离世间品说。思之可解。文中有三。初总叹能问。二我于解脱力下为说自分所得法门。三岂能了下仰推胜分。初文有二。初总。次如是事下别叹能问。别中有九句。此初句即上教问第三句。此第二即上第二句。此第三即上第五句。此第四句即上第六句。此中第五句即上第十句。此中第六句即上第四句。此中第七句即上第八句。此中第八句即上第九。此中第九句即上第七句。此九通叹上总耳。二说自分中有三。初辨法门体。二或见东方下辨法门用相。有四可知。三我唯下结自分齐。初文有四。初总辨体。二逮得下明有所成。三普照下辨益相。第四一切佛化下成前起后也。三仰推文有三。初总辞。二诸大菩萨下别辨胜相。三得虚空界下结。别中二十句念佛三时也。问仰推有何义。答有二义。一明他位德高。二约他显自德分齐深广耳。第二知识即治地住菩萨比丘名海云。入普贤法门。初教劝胜入。二时善财下依教趣入。三尔时海云下证法界。初有四。初示处。二人名。三教问。四叹德。二依教趣入中有八。初辞退。二南行下依入。三念持所得。四海门国所依处。五诣下见相。六头面礼下敬相。七白言下说已所得。八而未知下请问。问中初七自分行。次五句利他行。三告下正证法界中有三。初叹能问。二我住此下说自分行相。三岂能下仰推胜德。初文有二。初总叹有三可知。三得普门下别叹善财德有二。初自利。二大悲救护一切下利他。余相可知。二自分法门中有四。初明得法因缘。二时彼如来下为果德摄益。三其有十方下明利他德。四结法名字。初文有五。初正寻思有三可知。第二句中一句总十句别。此别即回事海为十地相也。二作是念已即见下见缘起法门。三百万阿修罗下外护行。四宝华佛下因行集起。五见彼华上下见其胜相。外护中有二十句。人宝二耳。见胜相中有二十句。二果摄中。初正加摄。二得益有三。初叹经德。二受持。三假使下校量功德耳。仰推文。初总。次责。三别广辨可知。第三知识修行住菩萨比丘名善住。入菩萨无碍法门。劝教等三同前。初文有三。初示处。二示人名。三教问。二依教趣入中有七。初辞。次念所得法。三进入方便。四依教简择。五见知义相。六尔时善财下敬仪。七问及叹有二可知。三证入中有三。初叹发心。二我已成下说已所得自分法。三云何能说下推胜说自分中有四。初辨法体。二我得此神通变下辨其作用。有三可知。三若有众生明摄化行。四我唯知此下结分齐。初法门中有三。初辨体。二我已修习乃至得慧光下辨德。三何以故下辨成。推胜分中初二十辨上德。二菩萨有如是等下以略现广。第四生贵住菩萨良医名弥伽。入所言不虚法门。即初教劝。二时善财下依教趣入。三良医下谓正入证。初文有三。无其叹德。二依教趣入中有七。初辞进。二尔时一心下念前法门令其成满。三渐至下进向胜分。四入祝药城下依教简择。五见相。六敬仪。七请问。有二可知。三正入中有三。初叹发心。二尔时良医称扬下说自分法。三云何能说仰推胜分。初文有五。一审发心。二明答。三礼供养。四敬重下叹发心功德。五当知菩萨下通叹菩萨化德。四广叹发心内有四。初总叹。第二善男子若有下通叹发心功能。三佛菩萨加护天等供养。四彼为安慰下辨护念意。第二说自分法中有四。初明口放光集众。二时彼良医下广辨智慧法门。三所应作已下摄仪归本有三。初归。次说法门名。三明德用。第四结仰推中有二。初总。次彼诸下别也。第五方便具足住菩萨长者名解脱。入如来一切无碍庄严法门有三。初劝教趣入。二时善财下依教进入。三时解脱长者下辨正证法界。初有三。初示处。二示名。三劝教问。二进入中有八。初信德而辞往。二念前法门。三如是念下进向方便。四周遍下依教简择。五见相。六敬。七念也。八白言下请问。问中有三。初明已所欲。二白言我闻大圣下叹德。三唯愿以下正请。初文有三。初十五句求果法。次欲与一切下十四求因法。三欲满下自分所修行法。三正证中有二。初说自所得法。二何能下仰推。初文有三。初明得法门。二得此法门下辨法门所现事。三我唯下结解分齐。初文有三。初辨入定及因缘。二入已已下明定功德。三从起下辨法门名字。二法门所现事中有二。初约自他相对。二知一切佛及与下心境相对。前文有二。初略。次广。各有三可知。二心境内有二。初约真。次善男子当知下约俗。亦各有二。初立。次劝可知也。仰推中初总。次别可知第六正心住位菩萨比丘名海幢。入普眼舍得法门。亦名清净光明般若波罗蜜境界。有三。初劝教趣入。二时善财下依教进入。三三昧正受。初文有三。初示处。二示人名。三教问。二趣入中有五。初敬仪念德。二念前法门。有二可知也。三渐趣下进向胜分。四见得方便。五周遍下依教简择。三正证中有二。初明自分法。二云何能说下仰推胜分。初文有五。初举法门体。二善财叹未曾有下叹功德。三此定名何等下问法门名。有问答二文。答中有名义因果二文。四唯有此下辨功作用。有二可知。五我唯下结。初文有四。初辨法门体。二从其足已下明现身摄。身光有十五处化。彼诸如来者顶上佛耳。三善财一心下辨摄法相应。四舍从定起。第二叹三昧功德中初十一句叹定德。二大圣乃至入此三昧下叹其作用。仰推中。初总次别三结。问菩萨既有具德何须仰推。答此有二意。一寄位不相。是故须推也。二寄三昧门别。发生胜欲故也。第七不退住菩萨优婆夷名休舍。入离忧安隐幢法门。初劝教进入。二时善财下依教趣入。三答言下正入。初文有三。初示住处。二示人名。三教问。二趣入信量中有八。初获益辞退。二念前法门。三渐渐下进向胜位。四得方便相。五见普庄严园下见相。此有三。初见依粗相。二尔时休舍下见正细相。三其有下叹德。六尔时善财下审法有二句。七往诣下辨敬相。八白言下请问。园中有十二事。垣树等。三正证入中有二。初明自分法门。二诸大菩萨其心如海下仰推胜分。初文有四。初辨法门作用。二发心为久如下问因缘久近。三此法名何等下问得名有二句。四结。初文有四。初我唯成一句明证分齐。二若见闻下明功能益用有三句。三东方下辨佛果德物被益。有二可知。四我此大众下辨眷属行成。有二可知。二因缘久近中有二。初问答得法因缘。二久如当成下问答成佛久近。久近答中有三。初明不依时节修。二欲化一切下称法界修。三结。初中十四句皆是分局也。称法界修中有十三句。仰推中初总举。次别。三结可知。第八童真住菩萨仙人名毗目多罗。入菩萨无坏幢智慧法门有三。初劝教进入。二时善财下依教进入。三时彼仙人下辨现量证。初文有四。初示处。二示人名。三善能下叹德。四汝诣下教问。二依教趣入中有八。初辨敬辞退。二念前法门有义教。分二可知。三渐渐下辨方便进向。四周遍下依教简择。五见园林依报粗相。六尔时见彼仙人下见正报细相。七往诣下敬仪。有三可知。八白言下申请问。三正证入中有三。初叹发心。二明自分法门。三仰推胜分。初时彼仙人等叹发心功能。此中文有三。初十句叹善财利他德。二大众各持下大众散华供养赞叹善财。三告大众下结叹发心功能。第二自分文有四。初辨法门体。二善财白言下明法门自在用分齐。有问答二文。三放善财手下归住自分有二。初放。次问答审法。四我唯下结法门名。二法门自在分齐。答中有三。初知识手加见在十方佛所。闻法修行。有二可知。二或自见下修行时节不同。三善财为无坏下明为十法照得十三昧。仰推中有三。初总。次别。三我岂能下结。第九法王子住菩萨位婆罗门名方便命。入菩萨无尽法门有三。初劝教趣入。二时善财下依教进入。三答言下正入证。初文有三。说处人名教问等。二进入中有六。初辞进。二明念得前法门。三明所到处。四周遍下依教简择。五敬礼。有二可知。六申请问。三入证中有二。初明自分法门。二明净法王下仰推。初文有六。初举自分现法门劝修。二善财作是念下明对法生疑。三作是念时下诸佛菩萨等加劝除疑。四童子闻奇特下闻法欢喜悔过除疑。五登刀山下如说修行有二句可知。六我唯成此等结法门名字。第二生疑中有二。初十二句于自分法中生疑。二将非魔下胜分法中生疑。第三菩萨等加劝中有三。初现色界天劝。二现欲界六天等劝。三现龙等八部劝。初劝有三。初总止莫疑。二此是大圣下叹德。三时诸天下举他益以劝。天者初禅天。自在者色究竟天。四悔过文有三。初于婆罗门起善知识心。二头面下明悔过。三婆罗门说偈。为其受忏悔开导。偈中初一偈劝顺教除障。次一劝令成行。又此诸知识内。三人是反道行。一方便命现痴相。婆须蜜现贪相。满足王现嗔相。问何故此处倍增劝法。答行相局无记故。余二即二通。又在初前故也。又所以登刀山投火聚者。约何相顺也。答约实是法。并悉广通。若局非不有别。何者刀体相续增成其断法之用。由有破能故。火体不续增成其显常之用。由有照能故。此依何理。如有无二名。说有能令离断。成解妙常之用。说无能令离有无成其证会妙无绝相之能。火即用无理。会妄照玄之用。刀即用有理。破无成信实德之解也。故有破义增成义微。由成解显故。无即成义增。由显证理故。此如起信论说也。又今定宗唯取诠相。由约事故也。又准所得三昧名其义亦可解耳。又问何故刀山须舍后得法。火即得时获益何也。答由有教舍而方顺无教相。即非违故也。仰推中有三。初总。次别辨。三总结。第十灌顶住菩萨位女名弥多罗。入般若波罗蜜普庄严法门。初教往。二时善财下依教趣入。三答言下正证。初文有三。初示处人名。教问等。二进入胜分中有八。初辞进。二念前法门之用。三到其处。四周遍下寻求有三可知。五善财即入下见依粗相。六见彼女下见正细相。七见已已下辨敬仪。八白言下请问。三证入中有二。初自分法门。二诸大菩萨下仰推胜分。自分中有四。初辨得法门体。二童子正念下问法门名有三可知。三境界云何下问作用分齐。四我唯知此下结。初文有三。初劝观。二见一一下定所现事。三皆是下推起因缘第三作用分齐中。先问。次答。答中合有一百一十六门。此等法门并通一部为轨。为此是解穷故也。仰推中有三。初总。次别。三结。次下十知识当十行位。此初即欢喜行菩萨比丘名善现。入随顺菩萨证明法门有三。初明劝教往诣。次时善财下依教趣入。三答言下正入法界。初文有三。示处人名教问等可知。二依教进入有七。初辞进。次念前法。念法中有十三句。三进入。四于城墎下依教寻求简择。五见胜相。六往诣亲近礼敬。七白言下请问发心。三正入法界中有二。初明自分法门。二金刚菩萨下仰推胜分。初文有三。初辨法门体。二不离此下明法门作用。三我唯知此下结名。初文有二。初得法因缘。二彼诸佛所下辨所成体。仰推有二。初别辨。二总结。第十二饶益行菩萨童子名释天主。入巧术智慧法门有三。初劝教趣入。二时善财下依教进入。三答言下正入法界。初文有三。示处人名教问等即教量也。二信量有八。初成前法门。二念人辞退。三与天龙下明所到处。四周遍下依教简择。五时空中天龙下方便知识示导。即助道耳。六见释天主下见其相。七即诣下亲近礼敬。八白言下自说发心请问。三正入法界中有二。初说自分法门。二诸大菩萨下仰推胜分。初文有三。初辨所住法门因缘。二我因下辨法门德用。三唯知此下结自分所知。第二德用文有二。初总明相黡子算印功能德用有二。初总次别。二我亦了知下别辨算数德用有三。谓一直算。二乘除。三功能可知。推胜中。初辨相。二结。第十三无恚恨行菩萨优婆夷名自在。入无尽功德藏庄严法门有三。初劝教趣入。二时善财下依教趣入。三答言下正入法界。初教量中三如前。二依教趣入中有八。初念法获益辞退。二尔时善财于善知识下叹德摄益有二可知。三渐渐下明所至处。四周遍下依教简择有二可知。五寻求进位。六进入下正见胜相。七辨敬仪。八白言自说发心。六正见相中有三。初正。第二依。三眷属。第三正入法界中有二。初自分。后仰推胜进。初一句明自分法门。二一器下辨法门大用。三结名。第二法门大用中有二。初为说大用法门有二。初施。二辨益可知。一汝见我此下摄令同益。此文有二。初令见内眷属。二此诸下于外作业。初文有三。此第二有五可知。仰推中。初释次结。第十四无尽行菩萨位长者名甘露顶。入如意功德宝藏法门。初劝教。二时善财下依教进入。三答言下正入法界。初文有三同前。二依教趣入中信量有七。初辞。二念。三到。四寻求。五见甘露下见相。六敬仪。七申意请问。三正入中有三。初叹发心能问。二汝见我下说自分法门。三诸大菩萨下仰推胜分。自分中有四。初约眷属以显法门。有三可知。二我成就下明法门体。三随其所须下明法门大用。四我唯知此结法名。大用中有四。初众宝等明财法二摄。二且待下明所化众生。三仰视下显虚空器出无尽财摄。四满意归本。仰推有三。总别结也。第十五离痴乱行菩萨位长者名法宝周罗。入满足大愿法门。初劝教。二时善财下进入。三执善财手下正入。初文有三同前。三依教进入中有七。初念德敬辞。二念法令增。三至处。四寻求。五于道遇见。六礼敬七自说发心请问法门。三正入中有二。初说自分法门。二诸大宝下仰推。自分中文有三。初以自分法门摄益。二尔时善财乃至白言下问得法因缘有三。初叹。次问。三答可知。三我唯下结成自分。初文有二。初叹以手引入家。观方便耳。二正观。观中初依报摄益有二可知。后正报摄益。正中有十重。第八重中。初神通等三世间八地德。次诣一切佛受持等明九地德。第十重如来满中等此即因中具果法门也。仰推中。初别次结可知。第十六善现行菩萨长者名普眼妙香。入令一切众生欢喜普门法门。初劝教进入。二时善财下依教趣入。三答言下正得法界。初文有三。示处人名教请等也。二进入中有七。初礼辞。二思前法门。三渐至处。四起胜进行。五见普门下见相。依正分有二可知。六辨敬仪。七白言下请问。三正入中有三。初叹发心。二我知一切下说自分法门。三诸大药王下仰推胜分。自分中有二。初辨摄益。二我唯下结名。初文有四。初治事中报障有二可知。二然后下除其定障。三称扬下教发心除其细障令诸行成。此有二可知。四善男子我又下明有异巧便也。有二可知。仰推中。初别辨次结也。第十七无著行菩萨位王名满足。入幻化法门。初劝教进入。次时善财下依教进入。三时满足王下正入法界。初文有三如前。二依教进入中有八。一辞。二念。念中有二。初总。次十六句别也。三至处四起方便导之。有问答二文。五见下见相有三。初见依正。二见治国法。三睹生疑可知。六作是念下诸菩萨等导诫除疑。有四可知。七闻天已下敬仪。八白言自说请问也。三正入中。初辨自分。二诸大下仰推也。初文有四。初方便摄受。二见我此报示其行相审之。三我成就下明法门体用有三。初体。次用。三反以显成耳。四我唯下结分齐。仰推中有二。初广次结也。第十八尊重行菩萨王名大光。入菩萨大慈幢行法门。有三义同前。劝教中有三如前。二依教进入中有八。一谓辞。二念前法门。三至处。四兴念自知必见胜法。初问。次答。三作念生欲。五入善光下见依粗相。六尔时善财于此下见正报相。七五体下敬礼。八请问。依报中有十。谓堑墙巷人众楼阁宝帐盖幢幡王住处楼阁。第六善财观生无著等正报中有三。初成前起后。二见王身。三彼殿前下申其利物相也。二十八相者显因行未圆故。三正入中有二。初说自分法门。二诸大下仰推胜分。初文有四。初举法门名及得因缘即为二也。二我住此下明利益用。三此城众生下举三昧功能以证现事。四我唯等结自分所知。二利益用文有五。一总辨摄益。二令诸下明摄成。三善男子下正辨摄用。四各见下明所感各异。五以正下明会属往因也。三三昧功能证现事中有三。初说入定时除他障。二且待下正显入定功能证成前事。有二可知。三从定起。仰推中有三。初总。次喻显。三结也。第十九善法行菩萨位优婆夷名曰不动。入菩萨无坏法门。三义同前。初教劝有三如前。二时善财下明依教进入中有七。初辞。二念。念前法门中有四段明义。初寻思法门令得增胜。二复作是念辨知识功能。三悲心念时下入定。如来使者方便教示令更进趣。四尔时善财定讫出定。三渐至。四推问下辨寻求。五善财欢喜下见依报净用。六前诣其所下恭敬观身作用。七自说发心请问。敬观中有五。初形色胜获益。有三可知。二宫殿等体胜。三眷属胜。四其有见者下除障胜。五见彼女人下牒前胜德偈赞耳。即为二耶。三正入中有三。初叹发心。二我成就下说自分所得。三诸大下推胜分也。自分中有四。初辨法门体。二白言得法因缘。三我入此下引现定用成行胜相。四我唯下结自所知。得法因缘中。初问修行胜行及问德用。下答中因缘德用合释。答中有三。初略答。次重问。三广辨中有六。初见佛身相发心念求。二时彼如来下更教发十心。三我于尔时下问法求果智。四我发是心已下行成离障。五于尔所劫若有众生下辨利他德用。六我初发心来下总结也。三引现定用文有五。初叹德二审定。三答。四成事。五出定仰推中。初举六喻明行深广。二结。第二十真实行菩萨位。得至一切处行法门知识外道名随顺一切众生。三文同前。初教劝中有三如前。二依教进入中有八。一辞退。二念前法门。三渐到。四周遍下寻求。五于中夜下见依相。六尔时善财下见正报相。七往诣下敬仪。八请问法门。三正入中答言下有三。初叹发心。二知已安住下说自分所得。三诸大下仰推胜分。自中有四。初辨法门。二以平等般若下明法门体用摄化。三复次善男子下以亲近利益用证前行。有三可知。四我唯知此下结。第二体用摄化有三。初举智光。二观察下观其机器。有三可知。三以妙智下说法被益。仰推中。初别明下结。此下十知识当十回向位。初即第一救护众生离众生相回向菩萨位。长者名青莲华香。入香法门。初劝教。二时善财下依教进入。三答言下正入。初教中有三如前。二进入中有六。初辞。二尔时乃至不惜下念修前法获益。有二可知。三渐渐下至其处。四诣青莲华下随进得实。五头面下礼敬。六自说发心请问未闻。三正入中有三。初叹发心。二我能下明自分法门。三诸大下仰推胜分。自分有二。初辨所知。二结。初文有三。初知香法。二彼香下知香起因有十种因。初一立。二所为。三法成。四诸分具五无过。六德成不动。七善巧相发。八分齐。九成前事。十来处也。三人中有香下辨胜力。仰推中。初辨次结。第二十二不坏回向菩萨位海师名自在。入大悲幢净行法门。明教劝等三义同前可知。初教劝中有三。如前海师名自在。二依教进入中有七。初辞。二念有二。第二中有三。立责答也。三渐至。四寻求。五见胜相。六诣彼礼敬。七自说发心请问。三正入中有三。初叹发心能问。二我成就下自分法门。三诸大下仰推胜分。自分有三。初一句辨法门。二在此海边下辨化用利益有四。谓一解脱法有二可知。二知世事法。三回世成出世。四结成大用可知。三我唯下结自所知。仰推中。初别次结也。第二十三等一切佛回向菩萨也。长者名无上胜。入至一切趣菩萨净行庄严法门。初明劝教。二时善财下依教进入。三长者告下正入。初教中有三如前。二进入有八。一辞退。二念修增广。三渐至处。四周遍下寻求五城东下见胜妙相。六时彼长者下彼眷属相。七尔时善财下敬礼。八白言下斥己请问耳。三正入中有三。初叹发心。二我成就至一切下说自分法。三诸大下仰推胜分。自分中有三。初总举法体相。二何等下广辨义用相。三我唯下结自分所知。第二广辨中有二。初问次答。此文有二。初约此方。二等类余土。此有二可知初文中有二。初身业至趣。二于中说法下口业说法。于此二文中知法合药及诸佛自觉圣趣即意业也。仰推中。初身业胜。二逮得下口业胜。三分别下意业胜。四我当下总结。第二十四至一切处回向菩萨也。尼名师子奋迅入菩萨一切智底法门。初劝教。二时善财下依教进入。三善男子下正入法界。教中三如前。二趣入中有七。初辞进。三渐至略无念前法门。三周遍下寻求有二可知。四诣彼下见依报相有三。初辨果体。二明因。三辨自在。此有三可知。五见比丘尼下见正报相。六五体投地下辨敬仪。七白言下请问。正报中有三。见身遍在众座。二见处一座下为众说法。三善财见下结所见奇特。为说法中有六。初为八部等天王说法。二声闻下为众说法。三初发心下为十地人也。四金刚力士等说。五见处如是下广类结益。六何以故下释所由也。初净居天等总有二十九门见正报。第三文结中。园林等结上树等。经行坐等结上遍坐等。大众眷属结上大众等。诸妙功德下结上说法等。诸奇特事者总结殊胜。又闻下结叹上说法熏资令身心柔软等。三正入法界有二。初自分法门。二诸大下仰推胜分。自分中有四。初说法门名。二大圣如此下明自分法体。初问次答。三大圣此智光下明法门大用分齐。初问次答。答文有四可知。四我唯下结自分所知。仰推中。初别明。次结可知。第二十五无尽藏回向菩萨位女名婆须蜜多。入离欲实际法门。初明劝教。二时善财下依教进入。三答言下正证。教中三义同前。二进入中有八。一辞退。二念前法门。三渐至如前。四明寻求有四可知。五善财闻此下见依报相。六善财见彼下见正报相有四。初身。次口。三意。四庄严可知。七礼敬。八自说发心请问。三正入中有二。初自说法门。二诸大下仰推胜分。自分中有四。一句辨法门名体。二若天见我下明法大用有四。初总同生。次现胜。三对生获益。四结。阿黎宜者此方名本欲。阿众鞞者此名正欲。三昔何所下得法因缘。初问次答。答中有二。初胜缘。次发心。四我唯下结自所知。仰推有二可知。第二十六随顺坚固善根回向菩萨位长者名安住。入不灭度际菩萨法门。三义同前。教劝中有三同前。二进入中但有四。初辞。二往。三至。四自说发心及请问耳。三正入有二。初自说所得。二仰推胜分。自分中有三。初辨法门体。二自言下明法门德用有三。谓问释结通等也可知。三我唯下结自所知。初文有二。初列名。二住此下明见佛行相有二。初佛次法也。各有二句。仰推中。初释后结。第二十七随顺等观一切众生回向菩萨位也。菩萨名观世音。入大悲法门。初明劝教趣入有三同前。二时善财下依教进入。三答言下正入。二依教进入中有九。一辞进。二念前法门。三渐至。四寻求。五见观世音依正相。六善财发念谛观以兴念。七时观世音下赞叹善财。八诣所礼拜。九自说发心及问法门。三正入中有三。初叹彼发心。二我已成就下自分法门。三诸大下仰推胜分。自分中有三。初明法门体相。二我行大悲下明作益用。三我唯下结所知。初文有二。初辨名体。二辨功能。第二益用中有二。初辨令离十八障。二复次下教令发心。仰推中。初总次别三结。第二十八如相回向菩萨名正趣。入普门速行法门。初辨劝教。二时善财下进入。三我已下明正入。初文有四。初示来方。二叹德。三审见可不有问答二也。四汝诣下教请问。何故此一知识言东不道南何也。答此第八回向如相离分齐故。拣前耳。但有证见觉初。故说东也。问所以住金刚山上及至观世音者何也。答由地前位是未证真如流至比境难坏故。复下赴利生悲际故也。二依入中有五。初礼敬谛观。二念前法门。三往亲近。四礼拜。五自说发心请问法门。三正入中有二。初说自分所知。二诸大下仰推胜分。初文有三。初辨法门名。二问答辨得法因缘等。此有三问。三我唯下结所知。答因缘中有三。初举难知。二唯愿下重请。三正答因行。正答中有七。一刹。二佛名。三从得法门。四发求远近。五辨速疾。六供养行。七悉能了知下应机授法。通答上三问。亦可别也。仰推有三可知。第二十九无缚无著解脱回向菩萨位天名大天。入云网法门。初辨教进。二时善财下依教进入。三尔时大天下正入。劝教三义如前。二依进中有八。一敬辞。二念前法门。三渐至。四寻求有二可知。五往。六礼敬。七自说发心。八请问。三正入有三。初以水洗面。散以金华。及叹其知识难遇。二我已下自说所得自分法门。三诸大下仰推胜分。第二自分中有三。初辨法门体。二白言下显法德用境界。三我唯下结已所知。德用中有二。初问次答。答中有二。初教财施。二复次下教法施。初财施有五。初积宝。二积香。三现女。四教善财。五及他人。第二法施中有四可知。仰推中。初举五喻即合。次结耳。第三十法界无量回向菩萨也。神名安住。入菩萨不可坏藏法门。初劝教二时善财下依入。三安住地神告下正入。初劝教中有三如前。道场神名安住。何以此下不辨南为。世间淳熟离诸相故也。二依入中有七。初辞。次趣摩竭也。三依入略无念前法门。四一万地神下叹善财德。此文有四。初叹德。二净界。三应法。四审问可知。五尔时善财下敬礼。六申意。七地天显净土果报令同见益有二。初果。次因及劝取可知。三正入有二。初辨自分法门名体因由。二诸大菩萨下仰推也。自分中有四。初出法门名体。二我于燃灯下明修行差别大用境界。三乃往已下明得法因缘。四我唯下结自分所知。仰推中。初释后结可知

大方广佛华严经搜玄分齐通智方轨卷第五(之上)大方广佛华严经搜玄分齐通智方轨卷第五(之下)

        终南山至相寺沙门智俨述

自此已下有十知识。此一欢喜地菩萨也。天名婆娑婆陀。入光明普照诸法坏散众生愚痴法门。初辨劝教。二时善财下依入。三尔时夜天告下明入法界。劝教中三如前。加毗罗城国名舍夷。是佛生处。表初地生如来家也。所以此后皆是夜天。欲彰此下得理自在辉光大夜处深闇化故也。余前已明。二依入中有七。一辞往。二念前法门。三至处。四从东门下渐趣寻求有二可知。五见彼下见相有二。初见。二观德。六见闻此已下明喜礼拜。七自说发心请问。此有三句可知。东门者开明之初也。三告言下正入中大文有三。初叹发心顺知识教。二我已成下说自分法门。三诸大下仰推胜分。自分中有四。初辨法名体。次我于善恶下辨用。三白言下明得法因缘。四我唯下结自所知。用中有三。初于众生起慈悲方便。二我常如是下依前方便对缘化也。三说偈劝修。二对化中有十七文。初总救。二救海难。三陆难。四为依。五救山难。六救旷野难。七救苦难。八救着国土。九救着五阴。十救着聚落。十一救着六入。十二救迷惑。十三救恶业。十四救厄难。十五救苦等三障。十六救邪三业。十七普贤行摄也。三偈中有二。初长行生后。次偈颂。偈有二十一偈。初一颂前法门。次四颂初入地四无量行劝令究竟。次十三偈六入胜用劝修究竟。次三偈总叹所得法门胜用。前十三偈中。法身等宿命通。我心等二他心。我以神等二身通。清净广智一偈漏尽通。第三得法因缘中。初问次答。问中初问发心时劫。二问得法门久近。答上二问各有结会。二文可知。仰推中。初广次结也。第二夜天名甚深妙德离垢光明。即二地菩萨位也。入菩萨寂灭定乐精进法门。初劝教有三可知。二尔时善财下依入。三答言下正入。二依入中有七。初十偈叹前知识德。十偈中初六叹报身德。次一叹本因行在身中现也。次三叹利用难尽。二辞往。三念。念中有二可知。四渐至。五到。六礼敬。七自说发心请问。三正入中大文有三。初叹发心。二菩萨成就十法下明自分法门。三诸大下仰推。二自分中有三。初辨法体相有二。初辨体相。此文有四可知。就此第三十门内。初四自利。次六利他也。二我已下结名。二悉见下明大用。此文有四。初总辨用相。二亦不着下对用成行体有四。谓立责答结答可知。三分别了知下明二用双行。四我如是常下广辨用相。余相可知。第三我唯下结可知。仰推中。初别释。后总结。第三夜天名喜目者即三地菩萨也。入离垢喜幢法门。初明劝教。二时善财下依教进入。三见彼夜天下正入。教中有四。初示处。二示其人。三教诣问。四尔时甚深下以偈颂劝诣。偈中初十二总颂前十法。次一教劝善财诣后知识。前中初二颂初四法。次十颂后六法。二依入中有四。初辞往。次念前人法用耳。三时喜目天加被善财令往为赞知识有二。初赞。次得法门。初文有二可知。四善财往下正往。第三正入中有二。初说自分法门。二诸大下仰推。前文有四。初明法体。二一切毛孔下辨法门大用。三白言下得法因缘。四我唯下结自分名也。大用中有二。初现德。二尔时善财皆得见闻下获益。初文有三。辨现十度行德有二。略释。次结类广可知。二喜目下明过去世行德有三。谓总释结。三身云下现身摄益。此文有四。一现身有三。谓总释结也。二为一切众生下辨所显德。三如是等下辨能诠言教音声。四彼一一身云说是法时下辨说获益耳。又即初身。次意。三口业也。初十度身云中一一皆有四义。谓一所依。二身。三所作事。四利益可知。二过去行中。方便波罗蜜有五句。初行体。二善巧随方现依正。三所知作用。四自在无碍。五方便所依事。愿有五句。准方便可知。力有四句。初行体。二成诸法因缘德。三成法善巧海。四所依事智中三十句。初体。二显现相即立教义。三智依止。四智辨才相。五分齐。六种类相摄。七智胜能。八所依事。九差别。十所穷源底。十一执取随用。十二不违可轨。十三智因。十四所依刹土。十五知依报时。十六知正报时。十七果人显现。十八知果人智。十九知因人。二十知因人智。二十一智知因人位。二十二因人功德。二十三因人转易。二十四能扶行愿。二十五授行分齐。二十六知说分齐。二十七法因陀罗。二十八同法。二十九知法契道。三十知所趣。二善财获益文有二。初获益。二偈赞叹。初文有四可知也。就十偈中。初七叹知识身业化用。次一叹意业化用。次一叹口业化用。下一总叹化用广大。三得法因缘中有三。初结前起后问。二夜天以八十九偈半答。三结会古今。答中初二十五答发心久近。次从是后下六十四半答得法因缘也。仰推中。初别释次结耳。第四夜天名妙德救护众生。即四地菩萨位也。入教化众生菩萨法门。初劝教。二时善财下依教趣入。三尔时夜天下证也。初劝教中三同前。二依入中有三。辞念前法往见。略无礼问耳。三正入有二。初说自分。二诸大菩萨下仰推。初自分中有四。初天为现法门令善财得自分法体。二即得此三昧下明三昧力用。三白言下明得法因缘。四我唯下结自分所知。初中有四。初辨所依菩萨法门。二现身光。三辨所趣。四得益。二三昧力用文中有三。初明所化众生处中自在。此中有四。一依二处三知四益。此文中有四。一六道。二四生。三约相。四满足大愿下释成化意。二善财见彼下善财得益起敬。三即舍相好下化穷息用引动行心令善财偈赞也。长行及偈二也。此偈文有二十偈半有三。初十半略叹夜天化用自在。二喜目下三偈叹得见因由。次七广叹夜天化诸众生成其胜行。三得法因缘中有二。初善财略叹法门即作三问。二善男子下天神广答。答中初叹法深。二谛听下正答得法因缘及时劫久近。名在第四结中答也。初文有三。初总叹。二一切人天下非小心境界。三何以故下释成有二可知。正答有二。初长行。次偈颂。长行有二。初诫众听。二辨。辨中有二。初值一佛得闻正法。二其后劫已下有五百佛出世。作种种形而往供养。此文有二。初释次结利益也。初值一佛文有八。初时劫中佛出。二时彼城下明所属王。三彼有女下明本身修行。四时彼城北下明佛施化。五时女即解下明受化获益初缘。六尔时妙德乃至于大众中下正明得益。此有四。初佛说经。二女得定。三得胜心。四获胜法门。七复于是前下转释往昔缘起。八尔时明净妙王等下结会古今。有四句可知。四施化文中有二。初明佛普化说法。二尔时普贤菩萨下别为当机。初文内有四文。初辨菩提树庄严。二最初佛成道放十二种光养众生根器。即十二住也。三满七日下知受道时动地出声。及随所应器为转法轮。即为三也。四何以故下释成也。转法轮中有二十句。初二利外凡夫等。次一利小乘。次十利十信。四立无量下利十解。五立无量住菩萨下利十行。六无量清净下利回向令回向入初地。七乃至九地入十地。八立无量众生已下使十地人入安住分究竟处。九成普贤行位也。二当机文有三。初普贤察机。二王人等知说偈正告。三兴供养具也。圣王十偈赞佛中有二。初长行次偈。偈中初一叹佛劝众往诣。次六叹难值遇。次二示光令喜。次一劝人速往。二天重颂中有二。初长行生起。次偈。偈文有三十八半有四。初二敕听许说。次三十三半略明百一十佛。总颂上尘等诸佛。次二依佛得法门。下一劝发善财应速修满。仰推中初释次结。第五夜天名寂静音。即五地菩萨位也。入无量欢喜庄严法门。初劝教。二时善财下依教趣入。三夜天告下正入法界。教中三同前。二依入中但有四。初辞退。二往。三礼。四举行地而问。三正入中有三。初叹发心。二我成就已下说自分法门。三诸大菩萨下仰推胜分。自分中有四。初辨法门体。二白言下明法门德用。二白言天神下得法因缘。四我唯等结自分所知。德用中。初问次答。问有四句。初问摄化德用。二问法门境界体相差别分齐。三问造修方便行。四正行也。答中还四可知。答初文有三。初明观修。二我为下正明摄化。三善男子下总结。初文有九心可知。二正摄化中有五。初总为苦众生令离苦。二若见在家下以十度门等化。三无色界下化着正报者。四为园观下化着依报者。五为贪欲下以五度门摄修胜行。三结中。初结上初句总告。次句结着依正者。次一句结十度等门。又亦可但有三意而通结上文也。文有二。初总次别。二答上境界文有四。初辨因行所观境。二又善男子下明果德所观境。三起非下泯相入实有三可知。四佛子此菩萨下结。三答上方便造修文有三。初一总。次别。三结可知。别中三十一句可知。四答正行中有二。初问次答。答有五可知也。三明发心久近中。初问后答。答中初长行次偈颂。长行中有六。初佛得法。二彼道场上下以法力故常见诸佛。三经佛刹下复以法力见贤劫四佛。四以此法界下复重得无量法门。五汝所问我下结会广大真实无增减相。六是故下劝修行。第二偈颂中有二。初长行生起。二正颂有十分三。初一敕听劝修。次四颂上所得法门因缘。下五颂上行成利益众生义。仰推文初别次结也。第六夜天名妙德守护诸城。即六地菩萨位也。入甚深妙德自在音声法门。初劝教进入。二尔时善财下依教趣入。三夜天告下正入法界。初文有三同前。二依入中有七。初善财将辞。先以偈赞报恩。十偈中有二。初生起。次偈颂。颂中初三叹由教故离诸取着得见法身。次二叹菩萨离三障故得解脱自在。次三叹菩萨摄益。下二令时众离取着也。二正礼辞。三念前法门。四往趣。五见胜相。六敬礼。七问。三正入中有三。初叹发心能问。二我已下说自分所得。三诸大下仰推胜分。自分中有四。初辨法门体。二是故佛子我为下明法用。三白言夜天下得法久近因缘。四我唯等结当分所知。二法门用中有四。初二十三句明观修摄化方便有三。初一句立。次于一切法下释。三佛子我等下结。第二文有四。一依法。二依世界。三等心下依众生。四佛子我常下成心德用。二复次佛子下以十种行观察法界行称法成。有四可知。三我如是念下二十三句正明对缘利他摄化。四我已成就下结。三就对缘利他文有二。初辨利他方便。二我深入下结用广大。初文有二。初辨能持德。举数释结三文也。二明所摄持法此有二。初释次结耳。得法久近中初问次答。答中有四。初说往世得法因缘。二佛子下会古今。三佛子次有下复值无量佛得诸法门。四复次佛子下复更值无量诸佛获胜益也。仰推有二。略广。后述己非分可知。第七夜天名开敷树华。即七地菩萨位也。入无量欢喜智足光明法门。文中三义同前。初劝教中示处人名教问偈重颂等四也。夜天重颂中有三。初长行生后。二偈颂。三结。第二文有十四偈。初二叹法门深妙。次十半颂劫中值佛得法门。下一半颂后值佛出世获益转胜。二依入中有八。初善财得法深入大用。二偈赞报恩之行。善财十四偈中。初三叹自利证德。次三叹利他。下八通明自他二用。三礼辞。四重修前法门。五往。六见相。七礼。八述问。三正入中有二。初明自分法门。二诸大下仰推胜分。自分中有五。初总明法门德用有三。初令得世间乐。二令得出世离苦行。三令成善法行。二我已成下正明法门名体。三善财白言下明法门大用。四白言天神下明发心得法久近因缘。五我唯下结也。三大用中有三。初问。次答。三结。第二答中有五。初辨相。二推功在佛。三寻往因。四依起胜行。五举佛为证可知。四发心久近中有二。初问次答。答有二。初明深远难知。二佛子乃往下正答。此二各有偈及长行。初长行五文可知。初偈有二。初长行生。二正颂。颂有二十一半有五。初一叹法门深胜。次四颂上非凡小乘等知。次十四半颂唯大心菩萨能知。即通颂上业行也。次一劝善财勤修。下一推功在佛。许说生后也。二长行正明往因行中有二。初长行。次偈颂。初有六。初明往昔佛世因缘。二佛子彼世下明往世起化因缘。有四可知。三时彼会中下叹王化德。有二可知。四时彼女人下说偈显王大行成就。五王赞女言下赞女及眷属福智德成。六善男子下结会古今。第四女偈叹王德中有五十二偈有三。初生起。次偈赞。三显敬仪。第二偈有二。初二十五偈叹王化德。二王父名净光下二十七偈叹王眷属胜。初文有三。初六明王未生时具有诸恶。次十二叹王出世丰乐断恶修善。次七偈叹王说法利物。第二叹眷属中。初三出王父母所正法治世。次九叹王出世丰乐。次三叹王游池园观。次十二偈池华中童子出现为世归依。第二重颂中十偈有三。初五以五通自在知诸佛出世事。次四以漏尽智通知出世法。下一劝修。仰推文有二可知。第八夜天名愿勇光明。即八地菩萨位也。入随应化觉悟众生长养善根法门。三义同前。初教中有三句可知。二时善财下依教趣入有四。初辞退。二诣。三见相。故下文云。向所显现者即指此相也。四敬礼。三正入中有二。初说自分法门。二诸大下仰推耳。自分中有四。初得十种心下于知识十种心等即法体。亦可十种心由属前第二依教趣入第五文。即当请问也。但为显八地无相故不言请。共法已下始是法门体。宜可思摄耳。二偏袒右肩下说偈赞叹。三白言下请问法门名及久近成道因缘。四我唯下结。初文有二。初得十心。次得应共菩萨法。十法有三。举释结数虽有十列唯八句。句别先举次释可知。二共法中总有四。初总。次所谓下别有一百句。三得如是下结。四辨益。共有三义。一师与弟子共。二位中摄法共。三缘他共法故得共行也。上来善财行穷至此无功用地故。广辨获益。二偈文有二。初长行明说偈意。次正叹偈中有十行。初一于知识起自己心摄也。次六明由知识得法请为广说。下三念德难报。三辨答久近。文有二。初问有三问可知。次答。答文有三。初答法门名。二我入此下明法大用。三如汝所问下明答发心久近。又亦可发心久近答第二问。大用者答第三成佛问。即因广大随机上下故。未定作佛也。第二答大用中有五。初总说入此法门得平等离染着。即理智也。二解一切色后智了色性也。三于念念中现如是下总结自在神力。四或见等下广显行相品类等也。五我住此下结叹佛事广大利益。三答前发心得法久近中。初牒问次答。答中有二。初一句总。次别。别中有六。初辨法深。此文有二。初法有五句。后以五喻次第合之。即随结也。一智门圆满究竟喻。二智体本净无惑喻。三智门离障益生喻。四智用随机难坏喻。五自在遍周无害喻。二菩萨智下以世间言说其久近。初许次说。二文可知。三结会古今。四佛子我于尔时下转报见多佛也。五次有劫名日光下转劫值见六十亿佛劝发修行。此文有二可知。六偈颂此文有二。初长行生起。二正偈颂。偈文有三十六偈文有六段。初一颂上法深承佛力说。次十三颂过去太子代受狱囚救生等文。次五颂初佛闻法发心出家等。次六偈颂从是已后值诸佛修法门等。次八明法门大用。次三叹法门德备胜妙难思也。余文可解。第九天名妙德圆满。即九地菩萨位也。入无量境界受生自在法门。流弥尼者生太子处也。三门同上。初教进三义同前。二时善财下依教趣入中有七。一辞。二念增前法。三渐至处。四周遍下寻求。五见相。六敬礼。七申问。三答言下正入法界中有二。初说自分法门。二诸大下仰推胜分。自分中有四。初辨法门名体。二善财白言天神下明法大用。三善财白下得法久近。四唯我下结自所知。法门名体有二。初辨方便。二出行名体。初文有三。初长行。次偈颂。三结益。长行中有三。初举十名叹德。二何等下叹别释。三住是下结。此有十句。初文有三。初举十数。二叹德。三何等为十下列十名。有二可知。第二别释中十门各有三。初列名。二释也。三结。重颂十偈。次第颂前十受生法可知。二法门大用中有三。初问。二答。三我一念中悉知下结知自在耳。此有二可知。二答文内有五。初天得具足受生法门生此林。有四句也。二时此林下现十瑞相。初立宗。次问。三释。四结。五明初利益也。三佛子摩耶乃至生太子时下因行智光以相显体。有三句可知。四毕利叉树下大用自在摄德无碍有三句也。五生菩萨时如空下显清净无染。文有三。初为益现身。二顺法成似。三成而无作。初有四喻。朗曜挺特如空中日。即现群机喻若电光。布慈渐益如山起云。像现除迷若闇中灯。三得法因缘中。初问次答。答中初长行次偈颂。长行中有四。初时劫佛现。二彼世界乃至王都下明受身因缘。三于意云何下结会古今。四我从是来下辨修行广大。颂中有二。初长行生起。二颂偈文有三十三半有四。初一敕听许说。二有八颂前初所得法门。次十三半颂上经诸佛修使增广。次一结难思也。仰推有二可知。第十瞿夷此方名明女。即十地菩萨位。太子有三夫人。此是第三夫人。耶输陀罗第一夫人。第二夫人名摩奴陀罗。此名意持。此佛宫中但闻名不见其形也。此明女表慈悲行究竟也。入分别观察一切菩萨三昧海法门。三义同前。初教往三义同前可知。二依入中有八。初辞退。二念增前法。三往。四至菩萨会堂下明至所。即总集地分。五尔时彼天下显方便行胜克位自然。即眷属行胜。六尔时离忧坏下彰其行具入胜境界。即三昧分。七敬礼谛观。八自说发心请问。五具方便行胜。文有六。初眷属行集。二白言下叹善财自分中具自他行。三我观仁者下叹善财胜分行中具自他利行。四复我观人者下胜进中通三世法。此文有三可知。五善财答下述同利他佛事有二。初总次别显。此文有三。初缘违顺二境调心。此文有四。初法。次喻。三合。四广成。此文有三也。二若菩萨如是行者下述成业用也。三天神下结也。六善财将升法堂下明一行一切行俱现显胜妙相。此文有三。初将升即趣向正位。二彼离忧等下显熏资义。三偈颂显善财勤求示成佛义也。所以往天所为此。已下知识位胜故。表藉多方便成也。偈有二。初生起。二偈颂。颂文有十行分三。初三自利行。次六利他行。次一叹能近善友得见诸佛。六入胜境中有四。初总辨胜境。有二可知。二寻求。三见胜相。四悉于下明德行清净。三尔时瞿夷作是言下正入中有三。初叹能问许说。二若菩萨下自分法门。三诸大下仰推胜分。初文有三可知。自分中有五。初举业自在修观方便。二善男子下明法门名体。三此法门下辨法门大用。四大圣发心下明发心久近因缘。五唯我等结当分所知。初文有三。初明十法界行五句也。二佛子十值知识中若诸菩萨下明十值知识方便行有六句也。三以偈颂有二。初长行生起。二偈颂中有十三偈。初二颂上一句。次七颂中间七。次四颂下二句。又亦可合通赞前人法方便也。三大用文有二。初问次答。答有四。初明此界用。二如此娑婆下遍余十方十世界也。三卢舍那本愿下明前教意异有所因。四我悉深入乃至何以故等已下释知宽广所以。此有四句可知。初文有二用。初知有漏因果。二彼诸劫下知无漏因果有三。初知佛。二知小乘。三知大乘也。四得法发心因缘中。初问次答。答中有六。初辨本身及始得法门。二彼佛灭后转得胜法门。有三可知。三佛子我得此下辨修分齐。四佛子我若下明修行本意。此中有二。初辨。次释所以可知也。五我于下修增诸行。六犹未能知下辨行增微彼诸本身及始得。文有十一段。一明本身感佛化导。二时彼女人闻是下化同众生故往太子共为眷属。三尔时太子下为犯邪行故。问彼女依正法有二文也。四时彼女母白言下叹德劝受。五太子答言下共其立要有三。初立要。二偈颂明有所期。三女随受。六尔时太子闻彼下以衣施。报恩显德。七时彼女母即为下叹女自庆起随喜心行。八彼太子与女俱下见佛得道。九诣父王所下劝父王见佛。令彼大王知见于佛得圣道耳。此文有五。初诣告王。二王审问。三王喜舍位。四佛为说法。五王出家得道可知。十尔时太子月十五日下太子作王广成摄化。十一尔时太子下结会古今也。六行增微内此文有三。初总辨。次责。三答。答中有四。初立。次释。三广辨。四结分齐。第三广文有三。初立。次责。三答。答文智正觉众生世间分二也。又问若取上下诸文。普贤法行似从十信解位已去即得究竟。今约此文时。其普贤行势似难成。位到十地方始可得者何也。答其普贤行体实不可依位得之。何以故。为附性起法故。今约三乘起信位论。从初信解位乃至十地皆非究竟。何以故。依位相取故。仍于此中间念念刹那尽普法也。何以故。为得性起故。佛即可知耳。摩耶夫人者此方云清净妙。此下第二会缘入实相。所以将夫人。表此为性实能成究竟觉故相即如。实大幻不住智悲故。入大愿智幻法门有三。一劝胜进等。三同前。初劝教中有四。初示处。二示人教名。三教问。四瞿夷重颂。颂中有三十三偈。初十八偈长行中脱无。大论引此。具有亦可过颂前事未是脱也。此文有三。初一总明摄修行人。次十七广述多劫修行因缘。三下十五总颂上文。此中初三颂上日光佛所发心。次七颂上逢后佛发心。次四总颂上得菩萨自他胜法。下一总颂上修行增微也。二依教趣入中但有七。一辞略无念前法及所至处。无意可知。二作是念我当云何下明善财念后方便。三善财随顺其教下明见依报相。四见夫人下见正报相。五见摩耶有如是下善财同彼即表行修入实。六敬仪。七述本因由请问法门。第二方便文有三。初善财念求。二时有城下有三。知识开导。三答罗刹言下明显求知识法。此有二。初领恩问。次答。答中有四句。一信。二思。三精进。四会理也。初文有三。初总。次叹摩耶身德。三结。此文有三。初辨分齐。二仰推。三仰求方便。二有三知识其意云何。初表所知法。次表能知智。三表方便相。又初约性起辨义。二约智辨诠。三约方便辨资成。余意可知。初知识内有四。初供养善财即方便资成相。二作如是下教其行法。三菩萨若如是知下结观成益。有三可知。四佛子下明得法者见一切真知识。显法有可成名善巧也。教行法中有二十四句。摩耶者此名幻化。方便智教唯心观。即正知识。是正唯心幻化不疑。此即以实显相故也。第二知识有四。初天神叹夫人。二光照诸佛依正。三智光入善财顶。四善财获益。第三知识有三。初罗刹华散善财。二语善财下教行法。此文有二。初亲近。次见。此二文并各有四。文可知。三若有菩萨下结。能亲近知识十法中前八可知。善对治下第九句。顺善知识下第十句。三见依报有四。初见华台。二见楼观。三见宝坐。四明眷属行相。四见正报有三。初见身体。二尔时善财乃至随应众生下辨化用。三善财见如是下广辨见利益相。初文有四。谓为益现色。二顺法成似。三相实说空。四胜二乘故现色。初文合有五十句可知。五善财行修入实文有五。初见夫人牒前所见身相。二即变下正同此正会相入实。三敬礼下胜分相应。四获益得定即行体也。五从三昧起。三答言下正入法界。文中有二。初说自分法门二诸大下仰推自分中有四。初辨法门名。二得此法门下辨法用。三白言下明法因缘久近。四我唯下结也。第二法门用中有三。初局文分有四。初得大幻法故。生太子时能现不思神力。有二句也。二善男子下菩萨退生时光触故。得受生法门自在有四。初光触。二得受生庄严。三见现未事。四见过去事也。三又善男子下明容受自在有七。初光触。二身宽有二可知。三容依报。四受等行菩萨。五受异生。六容下位菩萨。七受作用。四念念中下明化用容受自在。二于此下通十方有五。初明分量。二决疑。三决一疑。四责。五答可知。三善男子我为卢舍那下与千佛等为母也。此文有二。初辨次结也。三得法久近中有三。初问次答。此文有三。初本身获益有二。释结也。二彼道场神下结会古今。三善男子我从下广明修法门德用。三复次善男子下举广显略也。仰推三可知。此世界忉利天上下明第三摄德成因相。为弥勒是因故也。人名弥勒。入三世智正念思惟庄严法门。有三。初教劝进胜。二尔时善财闻如是等赞下依教趣入。三尔时弥勒观察大众下明证法界。初文有五。初示方便知识。二又作是言下示正知识住处。三彼园中有菩萨下辨知识名德。四汝诣下教问。五何以故下叹德以劝求。初文有二。初示天以表净女以表内智慈悲显妙法身。此文有三可知。二明二童子等表见化用修成方便资成依止。即寄福慧也。亦可前摩耶示以实应实。此童子等以相应相也。有说此中失次。此意未详。且作此释。又作是言者是摩耶言。案此即以理成事不虚。若尔前正念天及女寄是妙法智身云何。答正念即体相成。此寄依体成相耳。二示依报住处文有四。一示方。二示国。三示园林。四示楼观并因也。所以云南为事。因位顺正果故。三示知识名中。初名。次辨德。四教问中有十句。初五问修方便相。次五问正修行相。五叹弥勒能说德有二。初叹能说德。次汝不应于下广叹劝求。初文有二十句分二。谓问答二可知。答中初知识自成德。二彼菩萨能成善财胜行。二广劝求中有五。初一百七句劝修诸相行。此初文有三。初十句总劝教。二何以故下释成求法相。三善男子略说下九句结略显广。初释劝修诸相中有二。初释。次结。初释文有三。初四十二句自利行有三。初劝。二责。三广辨。二照无量法下利他行。三诣诸佛刹下四十一句胜分行。二是故善男子下正劝求知识。三复次乃至则为慈母下引十喻叹知识。释结二也。四发大地心下辨求知识益。此文有二。初明转受法药仪。二辨药病相拟法耳。此文有三可知。五善男子诣善知识下结行成益。此文有三。初辨自分。二明胜进有二。初责次答可知。三善男子下推功在友耳。此文有三。初总显德。二以略显广。三摄德属人也。第二正劝求中有七十四句有三。初正劝进。二何以故下四十辨成须求。三复何以故下辨知识有力之意。尔时善财问如是等下第二依教趣入中有八。初闻叹知识心生信。二正念思惟下念前法门。三渐进也。四以过去际下为见胜境故起大方便。五善财如是下得大慧眼观大法境无辞退文。第六五体礼敬下见依报相。七尔时善财赞叹楼观下见正报相。此即是证相。以人成德。此则是证。以德成人。此从后说。八头面敬礼白言下明礼敬请问。第六文有五。初见楼观敬礼。二作如是念深察贤圣住处。三未起间下敬法转深。四合掌谛观下广叹依正。五以偈颂。第二文有三。初见土相即恩敬缘。二又复下泯相入实即缘实观。三深心信解下以实成相。五重颂中有五十五偈有三。初七颂上楼观住处。二有四十四颂上第四具德圣所住处。次四结德叹穷。亦可分五。初一叹弥勒。次三十四举人德以叹室。此有三十三事。三有十八叹住室利益。四有一恭敬住室人。五有一请求摄授也。第三文有二。初一叹在室人。次十七正辨利益有十一事。前长行举室成人。此偈叹人成室耳。七见正报相中有五。初起方便求见法身。三遥见下邻而未即也。三与无量天龙下辨其眷属。四从外而来显众行缘集也。五威德特尊下叹德也。三尔时弥勒观察大众下辨入法界。文有四。初广叹发心德。二汝先所问下正入自体法门。三大圣此行下辨法门名。四白言下穷缘显实也。初文有五。初叹具功德者。二告善财汝可往诣下会位从实。三善财五体敬礼下摄其胜德也。四重指大众。由善财具德故偈赞善财。五告善财善哉下领问叹德耳。初文有七。初示大众总叹善财德。有问叹二文。二此童子下叹成希有有四句也。三何以故下辨成。四诸善男子下广叹劝学有四。一谓发心。二能进。三修行。四劝学故也。五此童子下重成德用。六善财汝今下广叹值遇善友益有六。初总通法见。二推叹文殊力。三成其证行。四叹行力增上。五劝学六晓喻其坏有二句。七善财当知下劝知行分齐有三句。余相可知耳。频陀伽罗城者觉城也。经由一百一十知识者通正助也。上四十二等寄位故来耳。叹善财云。无量菩萨广劫所修。善财一生得者。教法中得也。故离世品云于文字教法等故。此约三乘教释。若约一乘时。亦可普贤行证。证彼普行及别行也。此即非教得。亦可上果下加得。问何故此处广叹功德及发心等。答此为位穷行满足处故也。余准可知耳。二会位从实文有六。初教问。二悲泣显成位难。因此辨诸知识内数有悲泣者。但诸位中胜进玄越而今得者荷恩。难离慕恋悲耳。三文殊授璎珞即表福智严德之位。四善财得已供散弥勒正辨福德庄严会成其位也。五弥勒摩顶赞叹根行相应。六善财偈叹。此等表意可知。此有二。初长行次偈颂。偈中初一庆见弥勒。次一愿见文殊本师。三重请弥勒。即举德成位。亦即摄胜德也。中有四。初敬礼。二自说发心请问。三大圣下叹德。四唯愿下结请。四偈叹善财。文有三。初长行总示大众能发心人。二偈叹善财德。三长行结偈有六十八行有四。初十一叹其善来。次十八叹其自利得。次二十二叹成利他德。下十七叹自他德满。五领问广叹发心。文有四。初总叹。二善男子汝得善利下叹能见知识德。三何以故下有二百一十八句。广叹菩提心令修趣入。四是故下结。第三文有二。初一百一十五叹菩提心能生万德德等诸佛。二譬如自在药下一百三叹能成大用得彼大果及不舍世间也。初文有二。初辨次结。结有三可知。第二有二。初释次结。结有三可知。二自体法门文有三。初牒前方便摄入楼观现量境。此文有三。牒劝趣入。二生其胜欲。三显方便可知。二善财即入下正入三昧。三弥勒摄神力下明出定也。二正入定文有三。初入。二见净土。三汝见不下审其见解。第二文有五。初见严相即信境。二尔时善财下获益礼敬三礼已下现自身。即当法机器有二可知。四又见下现因果法相。即修行者所依法此文有二。初因。次或于楼观下现果法耳。五尔时善财诸下明差别异现。即显一果互彰立教仪则。此文有二。初现果八相有二可知。二铃中等现因中差别事也。前即初因后果。即修行次第。此文初果后因。生信成解次第耳。铃下有六。初铃现音声法门有二可知。二镜现形相法门。三柱现住持法门。四珠璎现庄严法门。五树现建立法门。六半月现住位起行法门也。三审见闻有三。初问。次答。三譬况叹见无碍。叹文有七。初超出妄境喻。二回观胜法喻。三善识诸相喻。四延时谓短喻。五真德善现喻。六境现随心喻。七观法无碍喻。此有三喻。一见色无碍。二现色无碍。三随作无碍也。出定文有四。初大圣摄用归本。二复以身口加令出。三正出。四出已弥勒重问观中事。审观虚实。有问答二文也。第三答法门名体有三。初正辨定体。有问答二文。二一生菩萨下明摄一切法门。三大圣此诸奇特下问答显处。以彰实耳。答中有二。初开二法门。二以二喻现及合也。初喻成就菩萨起事喻。第二起学菩萨愿成喻。第四辨法门大用。即名穷缘显实耳。有二问答。即为二。一问从来所趣处。二白言下问生所。初第一答中有三。初举实无来。二但为教化下约缘集有处。三汝所问我下为引物故现所出方。二问生处中有二。初辨因行体生处。二我于此阎浮提下明化身现来生处。初文有五。初辨生处。二以般若为母下十九句别明眷属行。三超凡夫地下校量优劣。四生如是家下十句辨位胜。五我净法身下十句辨报体相应。即体胜也。二化身生处中三处即分为三。谓一人中。二天上。三下生人中。并是最后生也。第四智照无二相人名文殊师利。入普见顺知识教法门。亦云菩萨寂静法门。文有三。初善男子汝往文殊等辨劝胜进。二时善财下依教拣择即趣入也。三尔时善财下正入法界。初文有三。初示人名。二示教问。三何以故下叹德。此中略无处。下文云到普门国也。叹德有六。初责。次答。即叹德。三善男子下重示以劝。四是故下结劝也。五重责。六答耳。依教趣入中。初敬礼。次辞退。三经百一十城渐至处。四拣择也。普门国是文殊一暂化处也。亦可智所依普法耳。第三正证入中有二。初见。二获益。所以不云说法证无言说故。所以此中普见为表见大智普照不二故。所以不言见文殊显普照离见相故。不违其教者通诸知识顺忍故。二增长等者证益在己。此中有四。初成利他。次安住下成自分行。三入佛甚深下随顺胜分。四现入诸趣下明自他德成入普贤行也。此下第五显因广大相人名普贤。入十不坏智慧法门有三。初善财闻普贤名者教劝胜进。二一心欲见普贤下依教趣入。三善财即见普贤下正证法界。初文有二。初闻普贤名即示名也。二行愿下即叹德也。此无示处辞等。意可知耳。言闻普贤名者上闻四普。一教量中文殊分具普贤行。二趣入中至普门国。三现证中普见诸知识。四证后智修普贤行也。故言闻也。叹德文有十一句。初行愿诸地者总。次具下十句别。总中初显地前愿乐行。次叹地上所依位功德也。别中地具者成地因行也。地法者十法界。是地体故。地得者摄之在己证得也。次第者地地始终也。地修者四五修等也。住者当地修满也。地境界者三性三无性。亦可分局也。是地所缘境也。持者境持观心也。亦可因持果。共者信悲慈舍等十行等通成诸地也。正道者根本智也。二趣入中有二。初一句起正希望。二虚空界等下辨趣入方便。此文有二。初善财总念净土法身。二起是心时下瑞相应现。此文有三。初辨见之因缘。二即见下正见相也。三结前生后。现相文有二。初十净土相。次十法身相。又亦可初十显净国土及净众生世间。次十显净因陀罗网境界成智觉分齐。欲明普贤分齐耳。三证入中有五。初明普贤德用摄化。二我于过去下重述普贤本因劝修胜行。三善财经由亲近下校量显胜。四善财能自究竟下叹善财行胜。五说偈叹佛结终于后。初文有四。初总见胜妙等诸如来。二善财见普贤下见法界行用。三普贤即申手下加令得三昧。四普贤告下审问定事有三。初问次答三叹德也。初文胜妙有九义等诸如来。亦十也。二见行用中有四。初明外用化。二重观普贤下内用摄化。三十方下结会平等有五句。四善财见普贤下明善财得十不坏智门益。初文有二。初释十九出生用。次结。二内中有二。初释次结。四善财得益文有二。初总牒十门。二别辨。三摩顶加得三昧中有三。初摩。二得益。三如此下结会。二摩顶益中有六可知。劝修本胜行中有七。初由久修菩提心故得上自在德用。二我所修下明德难穷。三我得如是下引已所得劝修行也。四汝且观下劝观现事。文有三句可知。五若有众生闻我名下显德深广有五句。六闻修习下明大心大行行应同得生有二句。七汝复观我下劝观三身大用。前第六中生净世界者生报土也。生我清净身中者生法身中耳。文云普贤身相犹若虚空。依于如如不依佛国耳。第七中有二。初劝。次观。具见因果。第三校量行德有三。初正明校。二何以故释成。有三可知。三不此世界没下叹善财自在难思显其胜义。第四叹善财行胜。文有二。初因圆。次不久下果满。果中初总。次别可知。五偈颂叹佛。所以叹佛者。明普贤菩萨在座前承加摄化。其行究竟成功在佛故叹也。亦可约果叹因位力。即是述前。偈中有二。初长行生起。次颂偈有九十九偈半有三。初八略举如来菩萨功德敕听许说。次八十九半别叹如来三身化用。三有二结劝修行。初文有三。初半敕听。次四半略叹如来三身德。三有三叹普贤功德。所说不虚劝物生信也。前三身中初一半叹法身灭德。次一报身智德。次二化身恩德也。二广叹中有三。初二十半叹报身德。二或见释迦下六十三叹化身德。三如来净法身下六偈叹法身德。问何故重结乃叹佛德者何也。答此是显发释。举果显因分齐故。余可准之。报身中有五。初三叹理量二智善巧。二或见如来坐下四明德普周唯大心境界非小智所缘。三或见卢舍那下七明诸佛德等具法身净土及胜眷属。四或见一毛孔下五半辨无方大用。五如是下结说难尽。化身中有三。初二十半叹佛身业大用。次安住无上道下有二十二叹佛口业教化。三诸佛尊导师下二十半叹佛意业巧摄益。初身中有四。初一释迦身化。次七示种种因行八相成道化。次五现余佛升天等化。次七半能现授记等种种随缘益。口中有三。初五明所说法有大威力。次十二明一音随机赴感。次五辨成德用所以。前十二中初四明一音随闻各异。次八结教差别。意中有二。初十二叹用善巧。次譬如下八半喻显。喻别有五。一随益应成喻。二在物心现喻。三随顺像现喻。四为生护持喻。五为物生德喻。此五是摄化大网。余文可知。法身六偈中有三。初一半叹法身具五相。次譬如梦所见下通约喻显。三有二偈法合。喻文有二。初一半约理辨成。二一约事彰法耳。初文五相者。初一句白净相。次二句不可思议相。三性离有为无为为相。第四句无染相。第六不去而遍至者。即第五常住为相。下二结劝中。初举四喻况德难穷。四者一觉心无限喻。二事法难穷喻。三数深广大喻。四虚空无际喻。通即可知。反成佛德深远耳。次一举益劝修也。此即流通分也。此经本有十万偈。此释但有三万六千偈。说余意可知耳

大方广佛华严经搜玄分齐通智方轨卷第五(之下)


大方广佛华严经随疏演义

    No. 1736 [cf. Nos. 279, 1735]

    大方广佛华严经随疏演义序

        唐清凉山大华严寺沙门澄观述

至圣垂诰。镜一心之玄极。大士弘阐。烛微言之幽致。虽忘怀于诠旨之域。而浩瀚于文义之海。盖欲寄象系之迹。穷无尽之趣矣。斯经文理。不可得而称也。晋译幽秘。贤首颇得其门。唐翻灵编。后哲未窥其奥。澄观。不揆肤受。辄阐玄微。偶溢九州。遐飞四海。讲者盈百。咸扣余曰。大教趣深。疏文致远。亲承旨训。仿佛近宗。垂范千古。虑惑高悟。希垂再剖。得睹光辉。顺斯雅怀。再此条理。名为随疏演义。昔人云。人在则易。人亡则难。今为解释。冀遐方终古。得若面会。然繁则倦于章句。简则昧其源流。顾此才难。有惭折中。意夫后学。其辞不枝矣

大方广佛华严经随疏演义钞卷第一

将释此疏大分为四。一总序名意。二归命下。归敬请加。三将释下。开章释文。四疏末一偈谦赞回向。为顺经文有四分故。若顺序正流通判者。则合前二为序分。开章为正宗。谦赞为流通。为疏三分。今初。总序名意。即是疏序。亦名教迹。粗分为四。细科为十。言有四者。一通序法界。为佛法大宗。二剖裂下。别叙此经。以申旨趣。三是以菩萨搜秘下。庆遇由致。激物发心。四题称大方广下。略释名题。令知纲要。亦为顺经四分故。言细科为十者。顺无尽故。一标举宗体。二剖裂下。别叹能诠。三故我下说主难思。四湛智下。说仪周普。五虽空空下。言该本末。六其为下。旨趣玄微。七若夫下。成益顿超。八真可下结叹宏远。九顾惟下。感庆逢遇。十题称下。略释名题。今初。往复无际至其唯法界欤。文有五句。言意多含。略为四意。一约三大释。二约本末释。三明法界类别。四总彰立意。今初。约三大释者。意明法界具三大故。初句明用。次句明体。次句明相。次句融拂。末句结属。今初。即往复无际是也。往者。去也。起也。动也。复者。来也。灭也。静也。无际有二。一约广多无有际畔。此就事用。二约绝于边际。据即事同真。何法往复。略有三义。一双约迷悟说。二唯就妄说。三返本还源说。今初。谓迷法界而往六趣。去也。动也。悟法界而复一心。来也。静也。皆法界用也。迷则妄生。悟则妄灭。然真有二义。一约随缘。迷则真随于妄。则真灭妄生。悟则妄灭归真。则真生妄灭。二约不变。迷悟生灭来往纷然。真界湛若虚空。体无始故即无初际。悟绝始终。即无后际。二唯约妄说。复有二义。一竖论去来。过去无始。未来无终。无初后际。二约横说。妄念攀缘浩无边际。上二皆约广多无际。若约绝际。妄无妄源。竖无初际。既无有始。岂得有终。故绝后际。中论云。大圣之所说。本际不可得。生死无有始。亦复无有终。若无有始终。中当云何有。是故于此中。先后共亦无。横寻妄心。不在内外故亦无际。是以远公云。本端竟何从。起灭有无际。一毫涉动境。成此隤山势。惑相既相承。触理自生滞。因缘虽无主。开途非一致。即其义也。三约返本还源说。对其初义。初义是总。第二约妄惟往非来。今此唯复。复本源故。斯即静义。故周易复卦云。复其见天地之心乎。然往必复。易泰卦云。无往不复。天地际也。就此一义。自有往复。故文殊师利所说不思议佛境界经中。善胜天子问文殊师利言。云何修菩萨道。文殊初说双行之行。次云。复次天子。有往有复名修菩萨道。云何名为有往有复。观诸众生心所乐欲。名之为往。随其所应而为说法。名之为复自入三昧名之为往。令诸众生得于三昧。名之为复。自行圣道名之为往。而能教化一切凡夫。名之为复。如是自得无生法忍为往。令诸众生得无生忍为复。自以方便出于生死为往。令诸众生出离生死为复。心乐寂静为往。常在生死教化众生为复。自勤观察往复之行为往。为诸众生而说斯法为复。自修空无相无愿为往。为令众生断于三种觉观心故而为说法为复。坚发誓愿为往。随其誓愿拯济众生为复。发菩提心愿坐道场。名之为往。具修菩萨所行之行。名之为复。是为菩萨往复之道。释曰。上来十对。皆上句自利为往。往涅槃故。下句利他为复。复于生死化众生故。虽有往复。总为返本还源复本心矣。此中无际。亦有二义。一菩萨行海广多无际也。二一一称理深无边际也。然上三义。皆法界用矣。二动静一源者。法界体也。对上三义约迷悟者。动即往也。静即复也。动静迷悟虽有二门。所迷真性一源莫二。莫二之源即是体也。二对唯妄者。动即往复。有去来故。静即体虚。相待寂故。不释动以求静。必求静于诸动。必求静于诸动故。虽动而常静。则动静名殊。其源莫二。莫二之源。即一体也。三对返本还源说。自利静也。利他动也。二利相导化而无化。则不失一源。为法界体也。若对上二种无际者。广多无际动也。际即无际静也。动寂无碍为一源也。际与无际当体寂也。三含众妙而有余者。法界相大也。谓杳冥之内众妙存焉。清净法界杳杳冥冥。以为能含恒沙性德。微妙相大。以为所含。相依乎性。性无不包。故称为含。性体无外。相德有名。有名之数不能遍无外之体。故云有余。则恢恢焉犹有余地矣。故阿僧祇品云于一微细毛孔中。不可说刹次第入。毛孔能受彼诸刹。诸刹不能遍毛孔。即斯义也。以手约称性。刹约不坏相。是故广相不能遍小性也。然此相大略有二义。一约不空具恒沙性德故。此是同教意。二约事事无碍。十玄之相。本自具足。即是别教之意也。然众妙两字。亦老子意。彼道经云。道可道非常道。名可名非常名。无名天地之始。有名万物之母。常无欲以观其妙。常有欲以观其徼。此两者。同出而异名。同谓之玄。玄之又玄。众妙之门。释曰。然彼意以虚无自然。以为玄妙。复拂其迹。故云又玄。此则无欲于无欲。万法由生故。云众妙之门。今借其言而不取其义。意以一真法界为玄妙体。即体之相为众妙矣。四超言思而迥出者。融拂上三也。融则三一互收。拂则三一双寂。云何超耶。谓理圆言偏。言生理丧。法无相想思则乱生。并皆超之。故云迥出。故肇公云。口欲谈而词丧。心将缘而虑亡。则迥出于言象之表矣。何者。欲言相用即同体寂。欲谓体寂相用纷然。即一而三相不同。即三而一体无二。三一无碍互夺双亡。存泯莫羁。岂言象之能至。故云迥出。又借斯亡绝以遣言思。非有无言可为栖托。故下经云。虽复不依言语道。亦复不着无言说。况言相本寂亡绝亦亡。斯则言与亡言相待亦寂故。假迥出之称。以拂言与亡言之迹矣。五其唯法界欤者。结法所属属法界也。谓具上诸德独在于法界矣。第二约本末释者。此上五句。初句从本起末。即不动真际建立诸法。次句摄末归本。即不坏假名而说实相。第三句本末无碍。则性相历然。第四句本末双寂。则言思无寄。末句结属通四义焉。第三明法界类别者。略有三意。一者约三法界。初句事法界。次句理法界。第三句无障碍法界。第四句融拂上三。第五句结属上三法界也。二者约四法界。往复无际事也。动静一源具三义也。动即是事。静即是理。动静一源。即事理无碍法界也。含众妙而有余事事无碍法界也。超言思而迥出。融拂四法界。其唯法界欤。亦结属四法界也。三者约五法界。往复与动。皆有为也。静即无为。一源有二。若互夺双亡为一源。则非有为。非无为法界。若互融双照为一源。则亦有为亦无为法界。含众妙而有余。即无障碍法界。超言思而迥出。总融五法界。其唯法界欤。结属五法界。第四总彰立意者。所以最初叙法界者。应有问言。诸家章疏多先叙如来为物应生先小后大。或无像现像。无言示言。今何最初便叙法界。故今答云。以是此经之所宗故。又是诸经之通体故。又是诸法之通依故。一切众生迷悟本故。一切诸佛所证穷故。诸菩萨行自此生故。初成顿说故。不同余经有渐次故。然最后一意正答初问。而前诸意共成后意耳。第二剖裂玄微昭廓心境。下别叹能诠意。明此经诠于法界故。难思议。文有七句。于中分四。初二句总明能诠。次二句别显深广。三有二句结叹深广。后一句结法所属。今初言玄微者。即指前法界多义也。谓幽玄微妙之旨。剖判分裂在乎此经。谓于无障碍法界。剖为心境二门。故下句云昭廓心境。云何剖裂。谓一真法界。本无内外。不属一多。佛自证穷知物等有。欲令物悟义分心境。境为所证。心为能证。故下引裕公云。心则诸佛证之以为法身。境则诸佛证之以为净土。则二皆所证。智为能证。所证之境即大方广。能证之心则佛华严也。文中广说故云剖裂。言昭廓心境者。心境即上所开。昭廓即是此经。昭者。明也。照也。廓者。空也。张小使大也。云何明心境耶。谓此经中。昭明显著。若凡若圣若因若果。能观之心所观之境。无不毕备故。如出现品说佛境界。即佛境也。说如来心即佛心也。诸位心境例此可知。云何照心境耶。谓此经中教人观察若心若境。如云欲知诸佛心。当观佛智慧。佛智无依处。如空无所依。此令观佛心也。云何空廓心境耶。如云法性本空寂无取亦无见。性空即是佛。不可得思量。即空心境也。无取即无境。无见即无心。又云。若有欲知佛境界。当净其意如虚空。远离妄想及诸取。令心所向皆无碍。亦空心境也。又云。若有欲得如来智。应离一切妄分别。有无通达皆平等。疾作人天大导师。亦空心境义也。云何张小使大。谓若张于心则无心外之境。张境则无境外之心。以随举其一摄法无遗。即无涯故。故下经云。无有智外如为智所入。亦无如外智能证于如。上句张心。下句张境也。真心真境。本自无涯。即妄同真。则张小使大矣。经云。如来深境界。其量等虚空。佛境大也。又云。佛智广大同虚空。真心大也。知妄本自真。见佛则清净。如心佛亦尔。如佛众生然。心佛与众生。是三无差别。皆张妄心。即无涯也。因果万法心境普收。随一一事皆可张廓疏穷理尽性彻果该因者。二有二句。别叹深广也。理谓理趣。道理广也。性为法性。心性深也。若穷其理趣。则尽其体性。今此经中。意趣体性皆穷究也。此借周易说卦之言。彼云。穷理尽性以至于命。昔者圣人之作易。将以顺性命之理。注云。命者生之极。穷理则尽其极也。即以极字解性。性者极也。若穷其理数。尽其性能。则顺于天命。故次云。以顺性命之理。今借语用之。取意则别。言彻果该因者。兼于深广。彻究五周之果。该罗六位之因。则广也。故广说地位因果。莫踰此经。若云因该果海果彻因源。二互交彻则显深也。初发心时便成正觉。因该果也。虽得佛道不舍因门。果彻因也。上约广义。彻果属果。该因属因。即明能诠之教该彻彼因果也。今约深释彻果属因。以因彻彼果故。该因属果。以果彻彼因故。即因果自相。该彻唯属所诠。而其能诠。具明斯义。然因该果海。果。彻因源。是古人之言。今欲具含深广之义。云彻果该因耳

疏。汪洋冲融广大悉备者。三有二句结叹深广也。上句明深广之相。下句出深广之由。汪汪深貌也。洋洋广貌也。冲亦深也。亦云中也。亦曰冲和。故老子云。道冲而用之。或似不盈。融者。融通兼深广也。故肇公云。汪哉洋哉何莫由之哉。八师经中梵志阇旬云。吾闻佛道厥义弘深。汪洋无涯。无不成就靡不度生等。即深广义也。亦如冲和之气。生成万物而不盈满。融通万法令无障碍。言广大悉备者。即出深广之由。以无不备故。此言亦出周易系辞。彼云。易之为书也。广大悉备。有天道焉。有人道焉。有地道焉。兼三才而两之故六。六者非他也。三才之道也。今若取意就经。亦可喻三世间。天道智正觉也。人道有情也。地道器世间也。此经广说三世间故。亦可天道深理也。地道事相也。人道诸佛菩萨修行者也。此虽配之。本意但取包含而已。谓此根本法轮之内。何法而不备。未有一事一理而不极。一因一果而不备。五周因果。则五十二位之昭彰。九会玄文。则难思教海而可睹。说真妄则凡圣昭昭而交彻。语法界则事理历历而相收。法华佛知见一偈必开示而无遗。大涅槃。涅槃一章必尽其体用。六百卷般若。不出三天偈文。一大藏经文并摄于七字之内。是谓罄诸佛之智海。竭性相之洪源。故云广大悉备矣

疏。其唯大方广佛华严经焉者。四结法所属也。上之胜事唯我华严。第三故我世尊下说主难思文有六句。义分为四。初二句标果满。二一句语因深。三一句明体玄。四二句彰德备。初云故我世尊十身初满者。总标十身。该下两段。正明难思。以是十身无碍。佛说非三身故。而言故我者。由上能所诠。深广玄妙为诸教本。故我世尊始成正觉。顿说此经。言十身者。次下当列。言初满者。成正觉时。身方满故。故经云。尔时世尊处于此座。于一切法成最正觉。智入三世悉皆平等。其身充满一切世间。其音普顺十方国土等。是初满也。正觉始成者。别语菩提之身。以是总故始觉同本觉。无复始本之异。故曰始成。下当广释

疏。乘愿行以弥纶者。二有一句语因深也。乘因有二一乘愿因。经云。毗卢遮那佛愿力周法界。二乘行因。主山神偈云。往修胜行。无有边等。乘昔愿因弥纶果用。即是愿身。言弥纶者。周遍包罗之义。亦出周易。系辞云。易与天地准故。能弥纶天地之道。释曰。圣人既准天地而作易。易中所说与天地理同。故能弥纶天地之道。以况如来本起愿行意欲周遍。利物今得如其愿行之力故。周遍法界是曰弥纶

疏。混虚空为体性者。三有一句明体玄也。然有二义。一约世尊身上自具十身。即法身也。以法性身为法身故。故下经云。性空即是佛。不可得思量。又云。佛以法为身清净如虚空。二者约外虚空。以融三世间而为佛身。则外虚空是虚空身故。故云混虚空为体性。混融无碍故

疏。富有万德荡无纤尘者。四有二句彰德备也。上句德无不备。下句障无不寂。万者总相之大数也。实具无尽之德。故下经云。刹尘心念可数知。大海中水可饮尽。虚空可量风可系。无能尽说佛功德。无尽之德。总名万德。尘沙无明。种现习气。总皆断尽。故云荡无纤尘。总即二障。二障有三。一现行。二种子。三习气。习气微细况之纤尘。细中之细尚无。况余粗中之细等。若总配三德。万德含于智恩。下句即是断德。又混虚空为体。即法身德。万德即般若德。无尘即解脱德。万德之句为总。上下诸句皆是别德。上之二句。并福德身。十身之中已具四矣。余之六身在后段中。第四湛智海之澄波。虚含万象。下说仪周普。文有七对。即为七义。一明所依定。二明能说身。三说经处。四说经时。五所被众。六说经本。七别示说仪。今初。说经所依三昧者。如说法华依无量义处三昧。说般若经依等持王三昧。说涅槃经依不动三昧。故说诸经多依三昧。今说此经依何三昧。即海印三昧。海印是喻。从喻受名。贤首品疏。当广说之。今略示其相。谓香海澄渟湛然不动。四天下中。色身形象。皆于其中而有印文。如印印物。亦犹澄波万顷晴天无云。列宿星月炳然齐现。无来无去。非有非无。不一不异。如来智海识浪不生。澄渟清净至明至静。无心顿现一切众生心念根欲。心念根欲并在智中。如海含象。故下经云。如海普现众生身。以此说名为大海。菩提普印诸心行。是故正觉名无量。非唯智现物心。亦依此智。顿现万象普应诸类。贤首品云。或现童男童女形。天龙及以阿修罗。乃至摩睺罗伽等。随其所乐悉令见众生形相。各不同行业。音声亦无量。如是一切皆能现。海印三昧威神力。然此文中言含法喻。智即是法。海即是喻。识浪既停云湛智海。无心顿现。故曰虚含。能应所应皆为万象

疏。皎性空之满月。顿落百川者。第二对明能应之身。此之两句。惟性字是法。余皆是喻。以性该之。皆含法喻。谓若秋空朗月皎净无瑕。万器百川不分而遍。性空即所依法体。满月即实报智圆。百川即喻物机。影落便为变化。故佛之智月全依性空。惑尽德圆无心顿应。故出现品云。譬如净月在虚空。能蔽众星示盈缺。一切水中皆现影。诸有观瞻悉对前。如来身月亦复然。能蔽余乘示修短。普现天人净心水。一切皆谓对其前。智幢菩萨偈云。譬如净满月普现一切水。影象虽无量。本月未曾二。如来无碍智。成就等正觉。普现一切刹。佛体亦无二。此则水亦喻刹。若准离世间品云。亦喻菩提。偈云。譬如净月轮。皎镜在虚空。影现于众水。不为水所杂。菩提净法轮。当知亦如是。现世间心水。不为世所杂。则亦以月喻所说法。上皆空月不同。若以相归性。则空亦名佛。故一切慧菩萨云。法性本空寂。无取亦无见。性空即是佛。不可得思量。则空色照水影落晴天。天犹空也

疏。不起树王。罗七处于法界者。第三明说经之处。意取七处故。言树王者即菩提树。谓毕钵罗树。此树高耸独出众树。故称为王。言不起者。谓不起菩提树。而升忉利天等。故下经云。尔时世尊不离一切菩提树下。而上升须弥向帝释殿。法慧菩萨偈云。佛子汝应观如来自在力。一切阎浮提。皆言佛在中。我等今见佛住于须弥顶。十方悉亦然。如来自在力。三天皆有不起而升之言。故彼成四句。一不起一切菩提树而升一天。如前经文。二不起一处而升一切处。三不起一处而升一处。四不起一切处而升一切处。二四两句取其结例之文。谓十方悉亦然。取前一切阎浮提对忉利亦然。则是第四句。但取一阎浮对一切忉利是第二句。其第三句易故文无。义必合有。是则不起法界菩提树。遍升法界七处。今言罗七处于法界者。略有二意。一令遍法界中皆有七处。二令一一处皆遍法界。且初义者。若约自狭之宽说遍应。如下说处中。十重之内遍于中八。以初一是能遍七处。十是例余佛故。然下十重是约佛遍于处。今明处遍于处。自有二义耳。所依之处既遍法界。能依之身居然遍也。今直就遍法界言。略有五重。一遍法界同类刹中。皆有七处。二遍法界异类刹中有七处。三遍法界微尘中刹亦有七处。四遍法界虚空容尘之处亦有七处。五遍法界帝网刹中。亦有七处。二令一一处遍者。如菩提场遍法界。则普光明中亦有菩提场。忉利天中亦有菩提场。夜摩兜率等七处。一一皆有菩提场。如遍七处。亦遍非七处之处。如化乐四王色界十八等非说经处。今菩提场亦遍于彼。如菩提场处遍其七处。一一皆遍七处乃至法界。此亦有五。一者一遍同类刹。二遍异类刹。三遍法界尘。四遍虚空容尘之处。五遍法界帝网刹。更细而论。非但一一处遍。随一一尘。皆遍法界五重之处。是则一处中有一切处。上二重释遍皆遍五类。五类之中前三约事法界。次一通事理。理空事空故。后一事事无碍法界。由事即理事理无碍故。以理融事遍于重重。皆是如来说经之处

疏。无违后际。畅九会于初成者。四明说经时。即始成正觉时。然有两说。各是一师之义。以无违两字会通。谓菩提流支。则以前五会。是初成即说。以经初云始成正觉故。三天皆云不起而升故。第六会已下是第二七日后说。以别行十地经初云婆伽婆成道未久第二七日故。例此则第九一会在后时说。以有身子祇树等故。贤首则以初成顿说九会之文。今会取贤首。既指归云。常恒之说前后际而无涯。则在后时无过。故云无违后际。后际即通第九会。在后时说故不妨后际。而宣畅九会在于初成。上来分于三时约所表故。初成顿演约圆融故。又分三时者。以法就机故。能顿说者约佛德能。能顿演故。以初后相即故。故云无违后际。不妨初成顿彰九会。经云。一念即无量劫。无量劫即一念。故晋经十住品云。过去无量劫。安置未来今。未来无量劫。回置过去世。非长亦非短。解脱人所行。多劫不乖刹那。初成岂妨后际。上之二段。广如教缘中辨

疏。尽宏廓之幽宗。被难思之海会者。五明所被众也。然上句略明经义。以为能被义。在旨趣之中。今为成所被故。略举能耳。宏者大也。廓者空也。幽者深也。下句所被。云被难思之海会者。以深广故。谓普贤等众行德齐佛。数广刹尘故称为海。深超情表。是不可思。数广难量。亦不可思。即深而广不可作深思。即广而深不可为广思。真应权实类例多端。又不可思。该彻果海尤不可思。故初会云。有十佛刹微尘数菩萨所共围绕。略列四十二众。皆以刹尘无量而为其量。况口光所召。一一菩萨各领世界海微尘数菩萨以为眷属来至此会。毛光重现周入刹尘。依正作用该摄三际。诸大菩萨尚不能思。岂况凡情测其涯际。故云难思之海会

疏。圆音落落。该十刹而顿周者。六明说经本也。本即圆音。落落者。疏远声也。十刹者。谓树形等异类之刹。经列二十结有十佛刹尘。举十以彰无尽故。故十刹圆音之义。下当广说。略而言之。一音之中具一切音。名曰圆音。一切音声即是一音。亦名一音。一多无碍总曰圆音。经云。佛以一妙音。周闻十方国。众音悉具足。法雨皆充遍。一切言辞海。一切随类音。一切国土中。恒转无上轮。皆圆音义也。十刹齐闻无有前后。故名为顿。法界十刹无所不闻。故名曰周

疏。主伴重重。极十方而齐唱者。七别示说仪也。谓是通方之说。举一为主。十方为伴。诸佛菩萨皆有主伴。递互相望尽于十方。随一为主。十方为伴。邻次相压。故曰重重。然相犹难明。今复略示。言诸佛菩萨皆有主伴者。略有三句。一果主果伴。谓遮那为主。十方佛为伴。十方佛为主。遮那为伴。二因主因伴。谓此方法慧菩萨为主。十方法慧菩萨为伴。十方菩萨为主。此方菩萨为伴。三果主因伴。谓如来为主。普贤等为伴。此一亦名辅翼。亦得称伴。彼佛为主。此方菩萨为伴。如法慧说法十方佛证。但名证法诸佛。不名因主果伴。设尔为伴自望本佛而为主。故言邻次相压故曰重重者。略有二义。一此彼互望。如遮那为主十方诸佛为伴。此界之东阿閦如来为主。此土遮那与十方诸佛为伴。次东第二佛为主。遮那与东第一佛及十方佛为伴。则随一佛有法界诸佛重数。如十人为主伴。递互相望。便为十重主伴。如一佛既尔。佛主菩萨伴亦然。因主既尔因伴亦然。此一义中自有三义。二者遮那一佛为主。十方菩萨为伴。主佛既遍。伴亦随遍。谓遮那处普光堂。东方十佛刹尘数界外。有金色世界文殊而来为伴。十方菩萨皆去十刹而来。若此主佛向东一界坐莲华座。金色文殊来亦不相近。还去十佛刹尘数外。如长空明月列宿围绕万器百川星月炳现。月如主佛。列宿如伴。一一水中远近皆现。义当金色近东一界。其西莲华色世界财首菩萨。亦移近东一界。余之八方皆移近东一界。如是主佛。至东十佛刹尘数界外。坐莲华藏师子之座。正当本金色界处。由主佛至彼其金色界。近东亦十佛刹尘数界外。其西方莲华色界。则正当娑婆之处。如是主佛极于东方。金色等伴刹亦极东方。终不见文殊从西向东来近主佛。如是主佛极于西方。亦不见有西方菩萨从东过西来近主佛。十方皆尔。如人以十钱布地。钱心为主。钱缘为伴。第一钱当中。以第二钱压第一钱上。近东一缘之地。则开元通宝等。皆亦近东一缘之地。如是钱钱重重相压皆渐近东。如近东既尔。更十钱近西亦然。说一十信。则已重重周于十方。如是第三会说十住时。亦如说信重重遍于十方。行向地等皆然。则九会为九重重。如第一会重重遍法界。第二会重重。还在第一会重重之上。则九会自为九个重重。若四十八会。为四十八重重。若无尽会。有无尽重重。此一佛为主。余菩萨为伴。重重如是。十方佛为主。十方菩萨为伴。重重亦然。如是诸佛重重复互相遍故。云主伴重重极十方而齐唱。余义至教起因缘中辩。然上七对有其六身。初所依海印三昧。即是智身。湛智海故。二说法之身为化身。谓如水分千月故。三说经处是意生身。随意遍于法界处故。四说经时。即力持身。持令永久故。五被难思海会。即威势身。菩萨众中威光赫奕故。六圆音。七主伴。皆相好庄严身。圆音即一相。主伴即坐莲华藏师子之座。具相好故。此段有六。前说主难思。已有四身则十身具矣。意云。十身初满即说此经。然疏本意正示说仪等异。含具十身故。有三两身名全不昭著。第五虽空空绝迹。而义天之星象灿然。下言该本末也。文有两重本末。一理事相望而论本末。二诸教相望而论本末。今初也。亦是遮于伏难。恐有难言。夫大象无形。大音无声。希微绝眹。乃是难思之境。岂有形言者哉。则心绝动摇。言忘戏论。自入真趣。何用广陈言相。翻欲扰人故。今释云。非言何以知乎无言。非相何以显乎无相。十忍经云。了法不在言。善入无言际。而能示言说如响遍世间。斯则以言显无言也。又云。佛以法为身。清净如虚空。所现众色形。令入此法中。斯即以相显无相也。又云。色身非是佛。音声亦复然。亦不离色声。见佛神通力。具上二也。法华亦云。诸法寂灭相。不可以言宣。以方便力故。为五比丘说。斯亦以言显无言也。金刚经云。若见诸相非相即见如来。此亦以相显无相也。净名云。夫说法者。无说无示不言不说。故云。当如法说。又云。无离文字说解脱也。又云。虽知诸法不生不灭。而以相好庄严其身。虽知诸佛国及以众生空。而常修净土教化诸群生等。皆是言与无言。相与无相。不相离也。十住品云。欲以寂静一妙音。普应十方随类演。如是皆令净明了。菩萨以此初发心。一切众生语言法。一言演说无不尽。悉欲了知其自性。菩萨以此初发心。世间言音靡不作。悉令其解证寂灭。欲得如是妙舌根。菩萨以此初发心。皆即言无言其文非一。今疏文中。但略明其无碍之义。文有二对初对无相不碍相。后对无言不碍言。今初对也。虽空空绝迹。诸法性本空。空无诸相。缘生之法。无性故空。复有何相。借空遣有。有去空亡。故曰空空。净名云。唯有空病。空病亦空。中论云。诸佛说空法。为除于有见。若复见有空。诸佛所不化。故知非有非无也。非有即空。非无即空空也。经云。无中无有二。无二亦复无。三界一切空。是则诸佛见。此即空空也。次云。凡夫无觉解。佛令住正法。诸法无所住。悟此见日身。则空亦无所住矣。又上无中无有二空也。无二亦复无空空也。三界一切空成真空也。又回向品云。法性本无二。无二亦复无。皆空空也。言绝迹者。空有斯绝。心行处灭。行处灭故。迹不可寻。谓若有有可有。则有无可无。今无有可有。亦无无可无。以无遣有。无即是迹。以空遣空空亦是迹。以有遣故遣之。又遣之。以至于无遣。若以无遣无无遣亦是迹。有所得故如鸟履砂。若无所得当句即绝。故出现品云。了知诸法性寂灭。如鸟飞空无有迹。故云空空绝迹。以空空不碍于相。故致虽言。虽字生下义天之星象灿然也。谓依于晴空不碍星象灿烂。晴空即是义天。依第一义天不碍法门星象。又以不碍星象。方知是空。不碍法门。为真第一义空矣。上即以空为本。法门为末也

疏。湛湛亡言。而教海之波烂浩瀚者。二约无言不碍言也。则以无言为本。言即为末。湛湛者。即是海水澄凝之相。意明动依于静。无言不碍于言。故下经云。虽复不依言语道。亦复不着无言说。若碍于言则身子被呵。不碍于言。则文殊攸赞。况文字性离即言亡言。故虽无言而教海之中波澜浩瀚。大波曰澜。是以佛证离言。流八音于听表。法本非说。演大藏于龙宫。故知至趣非远。心行得之则甚深。言象非近。虚怀体之而目击。言绝之理而非绝。繁兴玄籍而非兴。故即言亡言也融常心言无所遣矣

疏。若乃千门潜注。与众典为洪源。下诸教相对而论本末。即以华严为根本法轮。文有二对。上对为开渐之本。谓千门异义潜注众经。如海潜流四天下地。有穿凿者无不得水。则知众流依海水故。海为众水之源。华严为诸教之本源矣。下对为摄末归本。则万德交归。若百川归海。海能普收即为本故。昔人云。九流于是乎交归。众圣于是乎冥会。彼约会归涅槃。此约会归法界。故地论云。无不从此法界流。无不还证此法界故。故法华云。于一佛乘分别说三。一乘即三乘之本。一佛乘者即华严也。会三归一即摄末归本故。第五经云。始见我身闻我所说。即皆信受入如来慧。即指华严为根本也。除先修习学小乘者即所流也。我今亦令得闻是经入于佛慧即摄末归本也。是经即是法华。法华摄于余经。归华严矣。是则法华亦指华严为根本矣。其义分明余如下说。第六其为旨也下。旨趣玄微。此句标举疏。后冥真体下。正显旨趣。于中有二。先明理事无碍。后显事事无碍。虽此经中广说于事及说于理。而皆无碍故。以无障碍法界而为旨趣。此门即义分齐中意。就初理事无碍中亦二。先示三大。后融真妄前中问曰。初往复无际等。已明三大。今何重说。答有三义。与前不同。一前直就法界宗上。约义以明三大。今约能诠经中。具说三大。故不同也。二前辩三大之相。今明三大所在。谓体在何处。所谓万化等。三者前明三大融拂。为成己宗。此明三大互在为遮异释。辩不相舍离为无碍义。如昔人云。其为体也。则不生不灭无去无来。以不灭为无生。以不生为无灭等。其为相也。则同异类之殊体。则微细容持。同异类之别质。则展转重现。微细之理难见况之以芥瓶。重现之相易观喻之以帝网等。其为用也。不分而遍。不去而臻。一多大小而互为延促静乱。而相在等斯则别显三大之相。今但明其不离。则是深玄。名理事无碍。初句明体。体在万化之中。非事外也。故云冥真体于万化之域。冥为冥契。亦是冥寂。万化乃事法之总名。故晓公起信疏序云。原夫大乘之为体也。翛然空寂。湛尔冲玄。玄之又玄。岂出万象之表。寂之又寂。犹在百家之谈。非象表也。五目不能睹其容。在言里也。四辩莫能谈其状。释曰。此明真体与一切法。非一非异。今疏但云无碍。则与诸法非一异矣。故肇公云。道远乎哉。触事而真。亦体即万化矣

疏。显德相于重玄之门明相不碍体也。重玄即是理体。明德相只在体上。若离体有相。相非玄妙。胜德之相名为德相。言重玄者。亦即空空。语借老子。老子云。玄之又玄众妙之门。彼以有名无名同谓之玄。河上公云。玄者天也。天中复有天。庄子云。天即自然。则自然亦自然也。依此而生万物。故云众妙之门。今以空空之中无德不备耳

疏。用繁兴以恒如者。明用不离于体也。繁多兴起而常。即如。上体相用三。不相舍离。皆是所证所观

疏。智周鉴而常静者。即能证能观。若当句明即止观无碍。周鉴观也。理事遍观。常静止也。惑相皆寂。亦权实无碍。周鉴权也。常静实也。对上三句。为境智无碍由所观境既体用无碍故。能观智亦寂照双流。若别对三大。则各具体用。皆有止观。如体上冥真体。体也止也。万化之域。用也观也。显德相。观也。重玄门。止也。用繁兴观也。以恒如止也。若作三观释者。以智鉴体空空观也。鉴用假观也。鉴相中观也。三谛齐观。故云周鉴。对此三观。常静之止。亦有其三。一体真故静。二方便随缘无取故静。三离二边分别故静。三止三观融为一心。契同三谛无碍之理。则心境融即。而常历然

疏。真妄交彻。即凡心而见佛心下。融真妄也。文有二对。初对正明双融。后对不碍双现。今初。真谓理也。佛也。妄谓惑也。生也。亦生死涅槃。言交彻者。谓真该妄末。妄彻真源。故云交彻。如波与湿。无有不湿之波。无有离波之湿。若论交彻亦合言。即圣心而见凡心。如湿中见波。故如来不断性恶。又佛心中有众生等。若依此义。合云真妄交彻。凡圣互收。今不尔者。若约理融实。即真妄互有。今约有不坏相。但明凡即同圣。以即真故。而圣不同凡。无烦恼故。如波即湿而湿未必即波。有净水故。故净水说波有动之性。无动之事。如波中说湿。动湿俱有。又说凡即是佛。于凡有益。佛即是凡。令人妄解。是故但云即凡心而见佛心耳。然其真妄所以交彻者。真妄二法同一心故。妄揽真成。无别妄故。真随妄显。无别真故。真妄名异。无二体故。真外有妄。理不遍故。妄外有真。事无依故。然或说妄空真有。或说妄有真空。俱空俱有。双非双是。虽有多端并皆交彻。此义云何。且说何法为真。何法为妄。真妄自有二义。一约三性说。圆成是真。遍计为妄。依他起性通真通妄。净分同真染分为妄。二约二谛说。真谛为真。俗谛为妄。二谛多门。下当广说。今且约理事二门理为真谛为真。事为俗谛为妄。设净分之事。妄未尽故。问真妄二法。孰空孰有。如唯识论。约遍计为妄。则妄空真有。若染分为妄。则真妄俱有。若涅槃说空者所谓生死。不空者谓大涅槃。则依他染分为空。净分圆成皆有。若依三论。以世谛故有。真谛故空。若以妄为俗谛。以真为真谛。则妄有真空。若约随俗说二谛。则真妄俱通空有。若约触物皆中。则真妄俱非空有。问真妄交彻行相如何。言并皆交彻者。约相宗以明。唯识等宗不得交彻。今就华严。则前诸义皆得交彻。以具前即一心等义故。如约遍计为妄者。情有即是理无。妄彻真也。理无即是情有。真彻妄也。若染分依他为妄者。缘生无性。妄彻真也。无性缘成真彻妄也。若约生死涅槃说者。生死即涅槃。妄彻真也。涅槃即生死。真彻妄也。故中论云。生死之实际。即是涅槃际。涅槃之实际。即是生死际。如是二际者。无毫厘差别。即交彻也。此下经云。有诤说生死。无诤说涅槃。生死及涅槃。二俱不可得。亦俱空俱有。交彻义也。若依二谛。以妄为俗谛。以真为真谛。言交彻者。即俗而真。即真而俗故。故影公云。然统其要归。则会通二谛。以真谛故无有。以俗谛故无无。真故无有。则虽无而有。俗故无无。则虽有而无。虽有而无则不累于有。虽无而有则不滞于无。寂此诸边故名中道。即真妄交彻也。真故无有则虽无而有则。真彻妄也俗故无无。则虽有而无则。妄彻真也。余可思准。若约随俗说真妄。本虚居然交彻。真妄皆真。则本末一味。居然交彻。若触物皆中。居然交彻。次明交彻所以。问真妄相乖。其犹水火。何得交彻答此有多义。一真妄二法同一心故。以一贯之故得交彻。故起信云。依一心法有二种门。一心真如门。二心生灭门。然此二门。皆各总摄一切法尽。以此二门不相离故。故云。不离一心。故得交彻。二妄揽真成无别妄故。亦是起信胜鬘等意。真如随缘成一切法。故真彻妄也。言真随妄显无别真故者。妄彻真也。若无有妄。对何说真。如无缘生则无无性故。三真妄名异体无二故者。如向所引。有诤说生死。无诤说涅槃等。俱不可得。则体无二也。故下经云。若逐假名字。取着此二法。颠倒非实义。不能见正觉。明以无二为实也。岂非交彻。四真外有妄理不遍故下。反成二义。此句真彻妄也。五妄外有真妄无依故。即妄彻真也。此亦法性宗义。一切法皆如。岂妄外有真。真如遍一切。岂真外有妄。是知。真妄常交彻。亦不坏真妄之相。则该妄之真。真非真而湛寂。彻真之妄。妄非妄而云兴

疏。事理双修依本智而求佛智者。二不碍两存。上来交彻不碍之义。恐人误执。谓泯二相故举此言。亦由惑者执禅。则依本性无作无修。镜本自明不拂不莹。执法之者须起事行当求如来。依他胜缘。以成己德并为偏执故。此双行。依本智者约理而说。无漏智性本具足故。而求佛智者。约事而论。无所求中。吾故求之。心镜本净。久翳尘劳故。恒沙性德。并埋尘沙烦恼中故。以顺法性无悭贪等。修檀施等故。诸佛已证。我未证故。又理不碍事。不妨求故。事不碍理。求即无求故。若此之修。名为无修。无修之修。修即无修。为真修矣

疏。理随事变则一多缘起之无边下。第二明事事无碍法界。为经旨趣。义分齐中当广分别。今但略明。亦分为二。初一对明无碍所由。所以事事不同而得无碍者。以理融事故。于中初句。明依理成事。故一与多互为缘起。此犹是事理无碍。蹑前起后。故举之耳。由事理无碍。方得事事无碍。若事不即理。事非理成。则互相碍。今由即理故得无碍。下句以理融事。故云事得理融。则千差涉入而无碍。此正辩事事无碍。所以由上事揽理成则无事非理故。以理融事。理既融通。事亦随尔。故得千差涉入而无碍。由即事故。故有千差。为理融故。重重涉入。即当十玄所以之中。理性融通门也。余至下明

疏。故得十身历然而相作下。正显无碍之相。具十玄门。以随文语便故。小不次。如下次第者。一同时具足相应门。二广狭自在无碍门。三一多相容不同门。四诸法相即自在门。五秘密隐显俱成门。六微细相容安立门。七因陀罗网境界门。八托事显法生解门。九十世隔法异成门。十主伴圆明具德门。今文之次。在文可知。唯主伴一门。前说仪中。文理已具。故不重出。诸藏纯杂。今古多异。今文重出。故亦有十门。今初。即诸法相即自在门。文有两句。上句总明三世间相成故。故得十身历然而相作。言故得者。由前事得理融之故。便得具下十种玄门。故得二字文虽在初。义贯下十。言十身者。即八地云。此菩萨远离一切身相分别住于平等。此菩萨知众生身国土身业报身声闻身独觉身菩萨身如来身智身法身虚空身。言相作者。次经云。此菩萨知诸众生心之所乐。能以众生身作自身。亦作国土身业报身乃至虚空身。又知众生心之所乐。能以国土身作自身。亦作众生身业报身乃至虚空身。又知诸众生心之所乐。能以业报身作自身。亦作众生身国土身乃至虚空身。又知众生心之所乐。能以自身作众生身国土身乃至虚空身。随诸众生所乐不同。则于此身现如是形等。释曰。上之四类别显。末后结例。即十身相作也。言历然者。不坏相故。坏相而作。非不思议。其由芥纳须弥。须弥本相如故。故下七十七经云。是以一刹入一切刹。而不坏其相者之所住处。又云。是以一佛入一切佛。而不坏其相者之所住处等。五十六经云。所谓以众生身作刹身。而不坏众生身。是菩萨游戏。以刹身作众生身。而不坏于刹身。是菩萨游戏。如是佛身与二乘相作。菩萨行身与成正觉身相作。于涅槃示生死等。皆不坏其相。故云历然而相作。言六位不乱而更收者。六位即三贤十圣等妙二觉则因果。皆悉相摄。如初发心便成正觉。不坏初心之相。若无初心何名初心便成正觉。故十信摄于诸位。诸位十信历然。十住摄于诸位。诸位十住不乱。不乱则行布。更收即圆融。如下说因中辩此句亦是相入门。下有相入故。故此一句但为相即。如乳投水废己同他。故名相即

大方广佛华严经随疏演义钞卷第一大方广佛华严经随疏演义钞卷第二

        唐清凉山大华严寺沙门澄观述

疏。广大即入于无间尘毛包纳而无外者。第二广狭自在无碍门。上句大能入小。下句小能容大。虽有即入意取广狭。无间谓小。小之则无内。以无内故无有中间。无外谓大。大之则无外。无外即是广大之身刹。即入无内之尘毛。故名广狭无碍。若即若入。皆得广狭无碍。经云。金刚围山数无量。悉能安置一毛端。欲知至大有小相。菩萨以是初发心。至大有小相。即广狭无碍也。又云。能以小世界作大世界。大世界作小世界等

疏。炳然齐现犹彼芥瓶者。即第三微细相容安立门。一能含多即曰相容。一多不杂故云安立。炳者明也。微细有三。一所含微细。如琉璃瓶盛多芥子。炳然齐现。不相妨碍非前非后。此即如来不思议境界经说。然有两本。一本云白芥子。一本即但云芥子。今依此本。谓一法称性。含容皆尽故。一切法随所含理。现在一中亦是缘起。实德无碍自在。致使相容。非天人所作。乃得安立。如八相中一一相内即具八相。名为微细。二约能含微细。三约难知微细

疏。具足同时方之海滴者。第四同时具足相应门。如大海一滴。即具百川之味十种之德。故随一法摄无尽法。及下九门以此一门为其总故。同时明无先后。具足所摄无遗。言十德者。十地经云。一次第渐深。二不宿死尸。三余水入中皆失本名。四普同一味。五具无量珍宝。六深难得底。七广大无量。八大身所居。九潮不过限。十普受大雨。涅槃经云。如人入大海。浴则为己用诸河之水。称此而修。一行之内德不可尽

疏。一多无碍等虚室之千灯者。第五一多相容不同门。由一与多互为缘起。力用交彻故。得互相涉入。是曰相容。不坏其相故云不同。如一室内千灯并照。灯随盏异。一一不同。灯随光遍。光光涉入。常别常入。经云。一中解无量。无量中解一。了彼互生起。当成无所畏。此之灯喻亦可喻于相即。直就光看。不见别相唯一光故

疏。隐显俱成似秋空之片月者。第六秘密隐显俱成门。如八九夜月半隐半显。正显即隐。正隐即显。不同晦月隐时无显。不同望月显时无隐。以一摄多。则一显多隐。以多摄一。则多显一隐。一毛摄法界。则余毛法界皆隐。余一一毛互相摄入。隐显亦然。然其半月。非但明与暗俱。而亦明下有暗。暗下有明。如东方入正定。为一半明。西方从定起。为一半暗。而东方入处。即于东起。如明下有暗。西方起处即于西入。如暗下有明。故称秘密隐显俱成门

疏。重重交映若帝网之垂珠者。第七因陀罗网。境界门。如天帝殿珠网覆上。一明珠内万像。俱现诸珠尽。然又互相现。影影复现。影重重无尽故。千光万色虽重重交映。而历历区分。亦如两镜互照。重重涉入。传曜相写。递出无穷

疏。念念圆融类夕梦之经世者。第八十世隔法异成门。即离世间品。菩萨有十种说三世。谓过去说过去。过去说现在。过去说未来。现在说过去现在说平等。现在说未来。未来说过去。未来说现在。未来说无尽。三世说一念。前九为别。一念为总。故名十世。以三世相因互相摄故。一念具十。以显无尽故。一念即无量劫。无量劫即一念。普贤行品云。无量无数劫。解之即一念。知念亦无念。如是见世间。如一夕之梦经于数世。摄论云。处梦谓经年。觉乃须臾顷。故时虽无量。摄在一刹那。离世间品云。如人睡梦中。造作种种事。虽经亿千岁。一夜未终尽。故庄生梦蝴蝶假寐百年。事类广矣

疏。法门重叠若云起长空者。第九托事显法生解门。言重叠者。意显一多不相碍故。随一一事有多法门。以随一事即是无尽法界。法界无尽故事亦无尽。回向品云。此华即从无生法忍之所生起等。意明一切因生一果。一果即具一切因故。非是托此别有所表也

疏。万行纷披比华开锦上者。第十诸藏纯杂具德门。至相十玄中。有此名也。然有二意。故贤首改为广狭自在无碍门。一者若以契理为纯。万行为杂即是事理无碍。非事事无碍。设如菩萨大悲为纯。尽未来际唯见行悲。余行如虚空。若约杂门即万行俱修者此二门异。亦不成事事无碍。二者。如一施门。一切万法皆悉名施。所以名纯。而此施门。即具诸度之行。故名为杂。如是纯之与杂不相障碍故名具德。则事事无碍义成。而复一中具诸度。诸度存即名相入门。若诸度泯。复似相即门。故不存之。改为广狭。今以至相但约行为小异。此段略无主伴故。复出之以成十义耳。言比华开锦上者。意取五彩之线。华色虽异一一之线。皆悉通过。通喻于纯。异喻于杂。故常通常异。名为无碍。不同绣画但异。不通上之十玄略陈大格。广如向下义分齐中

疏。若夫高不可仰。则积行菩萨曝鳃鳞于龙门下。第七成益顿超。文有十义。初有二义。总显高深。明权小莫测。后八正明成益顿圆。又前二高深。反显成益。明权小不测。由昔无因反劝众生令信仰故。后八顺显成益。谓能顿能圆令必受故。今初即第一明高远。若泰华倚天岷峨拂汉。难仰其顶故。论语云。仰之弥高。钻之弥坚。积行菩萨者。出现品云。设有菩萨。于无量百千亿那由他劫。修行六波罗蜜。修习种种菩提分法。若未闻此如来不思议大威德法门。或时闻已不信不解不顺不入。不得名为真实菩萨。以不能生如来家故。若得闻此如来无量不思议无障无碍智慧法门。闻已信解随顺悟入。当知此人生如来家等。如鱼登龙门。若得登者即化为龙。如入华严之机也。若登不过者。曝鳃鳞于龙门之下。如假名菩萨。即权教次第修者

疏。深不可窥则上德声闻杜视听于嘉会者。第二彰深妙也即法界品。初舍利弗等五百声闻。彼叹德云。悉觉真谛皆证实际。深入法性永出有海。依佛功德离结使缚。住无碍处。其心寂静犹如虚空。于诸佛所永断疑惑。于佛智海深信趣入。释曰即上德也。在逝多林如来嘉会而不见闻。名杜视听。杜犹塞也。在目曰视。在耳曰听。虽在会下如聋如盲。故云杜视听也。故经云。尔时上首诸大声闻舍利弗。大目犍连。摩诃迦叶。离波多。须菩提。阿[少/兔]楼驮。难陀。劫宾那。迦旃延。富楼那等。诸大声闻在逝多林。皆悉不见如来神力。如来严好。如来境界。如来游戏。如来神变。如来尊胜。如来妙行。如来威德。如来住持。如来净刹。亦复不见不可思议菩萨境界。菩萨大会。菩萨普入。菩萨普至。菩萨普诣。菩萨神变。菩萨游戏。菩萨眷属。菩萨方所。菩萨庄严师子之座。菩萨宫殿。菩萨住处。菩萨所入三昧自在。菩萨观察。菩萨频申。菩萨勇猛。菩萨供养。菩萨受记。菩萨成熟。菩萨勇健。菩萨法身清净。菩萨智身圆满。菩萨愿身示现。菩萨色身成就。菩萨诸相具足清净。菩萨常光众色庄严。菩萨放大光明宝网。菩萨起变化云。菩萨身遍十方。菩萨诸行圆满。如是等事悉皆不见。何以故善根不同故。本不修习见佛自在诸善根故。本不赞说十方世界一切佛刹清净功德故。本不称叹诸佛世尊种种神变故。本不于生死流转之中发阿耨多罗三藐三菩提心故。本不令他住菩提心故。本不能令如来种性不断绝故等。上来先列人。即是上德声闻。次明不见等。即杜视听也。何以故下。释不见因劣者。不见犹未为深。上德不知方为玄妙

疏。见闻为种八难超十地之阶下。文有八段。正显成益圆遍之相。此第一段明见闻益。亦名为种益。即随好品。地狱天子三重顿圆及初地云。虽住海水劫火中。堪受此法必得闻。其有生疑不信者。永不得闻如是义。不信不闻翻显信。闻则成利益。海水是龙。畜生趣摄。劫火是天。火灾及初禅生在二禅光音等天。长寿天难。于此得闻。兼上地狱天子。已有三难。佛会神鬼亦闻三涂足矣。火灾之时兼佛前佛后。人天道异已兼办聪。亦不拣北州聋者目视。盲者耳闻故。八难具矣。皆容闻经为种之义。超十地之阶。正在地狱天子。举重摄轻。阿鼻地狱尚得顿圆。忝在人伦岂不留听。故随好光明功德品。佛告宝手菩萨言。佛子。菩萨足下有千辐轮相。名光明普照王。此有随好。名圆满王。常放四十种光明。中有一光。名清净功德。能照亿那由他佛刹微尘数世界。随诸众生种种业行欲乐皆令成熟。阿鼻地狱极苦众生遇斯光者。皆悉命终生兜率天。既生天已天鼓发声。广为说法。乃至云。尔时诸天子闻说普贤广大回向得十地故。获诸力庄严三昧故。以众生数等清净三业。悔除一切诸重障故。即见百千亿那由他佛刹微尘数七宝莲华。一一华上。皆有菩萨。结跏趺坐。放大光明等。乃至以华散菩萨上。又云。其诸香云普雨无量佛刹微尘数世界。若有众生身蒙香者。其身安乐乃至云灭八万四千诸烦恼。结云。如是知已成就香幢云自在光明清净善根。释曰。此即一重得十地。次云。若有众生见其盖者。种清净金辋转轮王一恒河沙善根。释曰。此即第二重得十地也。后文云。是菩萨摩诃萨住清净金辋转轮王位。放摩尼髻清净光明。若有众生遇斯光者。皆得菩萨第十地位。成就无量智慧光明。得十种清净眼乃至十种清净意。具足无量甚深三昧。释曰。此即第三重得十地也

疏。解行在躬一生圆旷劫之果者。第二解行益。七十八经。慈氏赞善财云。余诸菩萨于无量百千万亿那由他劫。乃能满足菩萨愿行。乃能亲近诸佛菩萨。此长者子。于一生内则能净佛刹。则能化众生。则能以智慧深入法界。则能成就诸波罗蜜。则能增广一切诸行。则能圆满一切大愿。则能超出一切魔业。则能承事一切善友。则能清净诸菩萨道。则能具足普贤诸行。及大威光太子。亦是一生圆多劫之果。上二皆明证速。又此经宗。明三生圆满。一见闻生。二解行生。即上二句。三证入生。即下二句

疏。师子奋迅众海顿证于林中者。第三顿证益也。第六十经初云。尔时世尊知诸菩萨心之所念。大悲为身。大悲为门。大悲为首。以大悲法而为方便。充遍虚空。入师子频申三昧。旧经云奋迅。奋迅之义。就师子说。其义便故。至第六十一经。初普贤开发后。如来眉间放光照故。时逝多林菩萨大众。悉见一切尽法界虚空界一切佛刹。一一微尘中各有一切佛刹微尘数诸佛国土。种种名。种种色。种种清净。种种住处。种种形相。如是一切诸国土中。皆有大菩萨。坐于道场师子座上成等正觉。菩萨大众前后围绕。诸世间主而为供养等。乃至云。是故皆得入于如来不可思议甚深三昧。尽法界虚空界大神通力。或入法身。或入色身。或入往昔所成就行。或入圆满诸波罗蜜。或入庄严清净行轮。或入菩萨诸地。或入成正觉力。或入佛所住三昧无差别大神变。或入如来力无畏智。或入佛无碍辩才海。即顿证林中。广说以十能入入此所入

疏。象王回旋六千道成于言下。即第四超权益。即六十一经。末会之初。六千比丘会。身子令六千比丘观文殊十德。六千请往欲见文殊。身子令见。尔时文殊师利童子。无量自在菩萨围绕。并其大众。如象王回观诸比丘。故云象王回旋。言六千道成于言下者。比丘兴愿。文殊令发十种无疲厌心。时诸比丘闻此法已。则得三昧。名无碍眼见一切佛境界。得此三昧故。悉见十方无量无边一切世界诸佛如来及其所有道场众会。皆悉见彼十方世界一切诸趣所有众生。亦悉见彼十方世界种种差别。亦悉见彼一切世界所有微尘。亦悉见彼诸世界中一切众生。所住宫殿以种种宝而为庄严。及亦闻彼诸佛如来种种言音演说诸法。文词训释悉皆解了。亦能观察彼世界中一切众生诸根心欲。亦能忆念彼世界中一切众生前后十生。亦能忆念彼世界中过去未来各十劫事。亦悉见彼诸佛如来十本生事。十成正觉。十转法轮。十种神通。十种说法。十种教诫。十种辩才。又即成就十千菩提心。十千三昧。十千波罗蜜。悉皆清净。得大智慧圆满光明。得菩萨十种神通柔软微妙。住菩提心坚固不动。尔时文殊师利菩萨。劝诸比丘住普贤行。住普贤行已入大愿海。入大愿海。已成就大愿海。以成就大愿海。故心清净。心清净故身清净。身清净故身轻利。身轻利故得大神通无有退转。得此神通故不离文殊足下。普于十方一切佛所悉现其身。具足成就一切佛法。释曰。此即道成也。一三昧中有十通用。皆圆益也

疏。启明东庙智满不异于初心者。第五成智益。启明东庙者。即第六十二经云。尔时文殊师利菩萨劝诸比丘发阿耨多罗三藐三菩提心已。渐次南行经历人间至福城东。住庄严幢娑罗林中。往昔诸佛教化众生大塔庙处。释曰。此即东庙。时福城人闻文殊师利童子在庄严幢娑罗林中大塔庙处。无量大众从其城出来诣其所。下别列中。有五百优婆塞。五百优婆夷。五百童男。五百童女。善财是一。下文殊师利独观善财。既观察已安慰开喻。而为演说一切佛法。乃至云说此法已。殷勤劝喻增长势力。令其欢喜发阿耨多罗三藐三菩提心。又令忆念过去善根。作是事已。复于其处为诸众生随宜说法。然后而去。尔时善财童子。从文殊师利所闻佛如是种种功德。一心勤求阿耨多罗三藐三菩提。随文殊师利而说偈言等。即启明东庙也。言智满不异于初心者。即第八十经初。智照无二相。经云。是时文殊师利。遥申右手。过一百一十由旬。按善财顶。作如是言。善哉善哉。善男子。若离信根心劣忧悔。功行不具退失精勤。于一善根心生住着。于少功德便已为足。不能善巧发起行愿。不为善知识之所摄护。不为如来之所忆念。不能了知如是法性。如是理趣。如是法门。如是所行。如是境界。若周遍知。若种种知。若尽源底。若解了。若趣入。若解说。若分别。若证知。若获得。皆悉不能。释曰。了知法性下。即是智满。若离信心则不能得。反显前义由信心故。则得不离初发之心。则信智无二。若约不动智为初。即前后二智无二也

疏。寄位南求因圆不踰于毛孔者。第六成位益。谓其善财初见文殊。寄十信位。德云至瞿波寄三贤十圣位。摩耶已下并寄等觉。后见普贤便得因圆不踰毛孔。文云。时善财童子。又见自身在普贤身内。十方一切诸世界中教化众生。又云。是善财童子。从初发心乃至得见普贤菩萨。于其中间所入一切诸佛刹海。今于普贤一毛孔中一念所入诸佛刹海。过前不可说不可说佛刹微尘数倍。如一毛孔一切毛孔悉亦如是。又云。善财童子。于普贤菩萨毛孔刹中。或于一刹经于一劫。如是而行。乃至或经不可说不可说佛刹微尘数劫。如是而行。亦不于此刹殁于彼刹现。念念周遍无边刹海。教化众生令向阿耨多罗三藐三菩提。当是之时善财童子。则次第得普贤菩萨诸行愿海。与普贤等。与诸佛等。一身充满一切世界刹等。行等。正觉等。神通等。法轮等。言辞等。音声等。力无畏等。佛所住等。大慈悲等。不可思议解脱自在悉皆同等。释曰。此即毛孔中因圆也

疏。剖微尘之经卷则念念果成者。第七显因成果益。即出现品大经潜尘喻。经偈云。如有大经卷。量等三千界。在于一尘内。一切尘亦然。有一聪慧人。净眼悉明见。破尘出经卷。普饶益众生。佛智亦如是。遍在众生心。妄想之所缠。不觉亦不知。诸佛大慈悲。令其除妄想。如是乃出现。饶益诸菩萨。又经云。应知自心念念常有佛成正觉。何以故。诸佛如来不离此心成正觉故。念念相应则念念成矣

疏。尽众生之愿门则尘尘行满者。第八成就行愿益。谓菩萨发心化尽生界。生界若尽大愿方终。生界无穷大愿无尽。故十地品云。若众生界尽我愿乃尽。而众生界不可尽故。我此大愿善根无有穷尽。今众生界虽无有尽。而等有经卷故。普贤开之。要令尽无尽之众生为大愿矣。言尘尘行满者。菩萨大悲不可尽故心量难思。为一众生于一尘中经无量劫。修行万行心不疲倦。尘尘皆尔。生生尽然。方显愿行无穷尽也。文殊菩萨赞善财云。汝遍一切刹微尘等诸劫。修行普贤行成就菩提道

疏。第八真可谓常恒之妙说下。结叹宏远。于中分二。先当相显胜。后对他显胜。今初四句。初句。佛说明常恒之说。前后际而无涯故。二通方之洪规者。明其普遍。无有一国不说此法故。明是通方不同随宜之教有说不说。三称性之极谈者。显其深也。一一称理故。一文一句不可尽故。普贤大士语善财云。我法海中未有一文一句非是舍施无量转轮王位而求得者。四一乘之要轨者。明其要妙。谓于一乘之中是别教一乘。不共之旨。圆因之门。成佛之妙故

疏。寻斯玄旨却览余经下。二对他显胜。先法后喻。初法可知。后喻之中文有二喻。初其犹之日丽天夺众景之曜者。即智明映夺喻。初升谓日。谓之杲日。丽者着也。此经犹如杲日。杲日既升。众景夺曜。景犹明也。即大明流空。繁星夺曜。斯经大阐。众典无辉。后须弥横海落群峰之高者。即高胜难齐喻。须弥即是此经。群峰即是余经。设七金铁围。方余高广比妙高之出海。并落其高。以俯望群峰如培塿故

疏。第九是以菩萨搜秘于龙宫下。感庆逢遇。于中二。一明弘阐源由。二正明感遇。今初。谓龙树菩萨五百年外。方入龙宫搜求得斯玄奥之典。事如别传及纂灵记。言大贤阐扬于东夏者。正取觉贤兼余大德。谓智严。法业。日照。实叉等。阐扬斯典。言于东夏者。谓葱岭之东。地方数千里。谓之神州大夏。而上云是以者。由上深妙故。搜以阐之。故龙树入于龙宫广见。无数偏诵此经者。以玄妙故。故智论詺。为大不思议经。而诸大德皆见此经。一文一句竭海墨而莫书。一偈一光破地狱之剧苦。是以诸师尽命弘传耳

疏。顾唯正法之代尚匿清辉幸哉像季之时偶斯玄化等者。二正明感遇。于中亦二。先对昔自庆。后对今自庆。今即初也。谓五百年前即当正法。斯经清辉。隐匿龙宫之内。时人不闻。何幸像法垂末之年。遇斯玄微之化。生居像末应合悲伤。反顾前不闻经。未惭正法之代。故自庆也。此依不灭正法一千年故。今为像末。以今去大师涅槃一千八百六十年故。又按。大集月藏分。第一五百年解脱牢固。第二五百年禅定牢固。第三五百年多闻牢固。第四五百年塔寺牢固。第五五百年斗诤牢固。今居塔寺之末。将邻斗诤之时。翻闻难思之经。碎身莫酬其庆

疏。况逢圣主得在灵山竭思幽宗岂无庆跃者。第二对今自庆。此庆有三。一庆时。二庆处。三庆所修。初即况逢圣主。谓明时难遇。今值圣明天子。敷陈五教高阐一乘。列刹相望钟梵交响。故得闲居学肆探赜玄门。斯一幸也。二得在灵山者。庆处也。清凉灵山三千之最。文殊大圣诸佛祖师。金色虽在东方。住处即为金色。大圣虽周法界。摄机长在此山。感应普周。若百川影落。清凉长在。犹素月澄空。万圣幽赞于五峰。百只传庆于千古。况大孚灵鹫标乎圣寺之名。一介微僧得在居人之数。此之庆幸爰愧多生。斯再幸也。三竭思幽宗者。庆所修也。大方广佛华严经。即毗卢遮那之渊府。普贤菩萨之心髓。一切诸佛之所证。一切菩萨之所持。包性相之无遗。圆理智而特出。不入余人之手。何幸捧而持之。积行菩萨犹迷。何幸探乎幽邃。亡躯得其死。所竭思有其所归。幸之三也。岂无庆跃结上三也。其犹溺巨海而遇芳舟。坠长空而乘灵鹤。庆跃之至手舞何阶。是故感之庆之。唯圣贤之知我也

疏。第十题称大方广佛华严经者。即无尽修多罗之总名。下略释名题。以下第九门中广释。故此云略。于中有三。先双标经品二目。二双释二目。后双结上二。今初。先标经目。谓若从略至广。展演无穷。难思教海不离七字。故云无尽修多罗之总名。标经题也。后世主妙严品第一者。即众篇义类之别目者。标品目也。众篇即三十九品。品者。义类不同。今当其一故云别目

疏。大以旷兼下。二双释二目。先释总题。后释品目。今初。下有十门。释其七字。字各十义。今但略举。当字释之。然此七字略有六对一经字是教。上六字是义。即教义一对。二严字是总。上五是别。即总别一对。三华为能严。上四皆所严。即能所一对。四佛是所严所成之人。上三皆所严之法。即人法一对。五广者是用。上二皆体。即体用一对。六方者是相。大者是性。即性相一对。故此七字即七大性。大者体大。方者相大。广者用大。佛者果大。华者因大。严者智大。经者教大。则七字皆大。七字皆相等。今各以二义释之。大以旷兼无际者。旷兼明其包含。约广遍释大故。涅槃云。所言大者。其性广博犹如虚空。故下经云法性遍在一切处。一切众生及国土。三世悉在无有余。亦无形相而可得也。二无际者。约其竖论则常故名大。涅槃云。所言大者。名之为常。故下经云法性无作无变易。犹如虚空本清净。诸佛境界亦如是。体性非性离有无。然渊府不可以拟其深妙故。寄大以目之。实则言思斯绝。故下经云。法性不在于言论。无说离说恒寂灭。诸佛境界不可量。为悟众生今略说

疏。方以正法自持亦二义者。一方者正也。二方者法也。并持自性。通上二义。谓恒沙性德即是相大。并无偏伪。故称为正。皆可轨持。目之为法。故下经云。凡夫无觉解。佛令住正法。诸法无所住。悟此见自身

疏。广则称体而周者。此即用大。用如体故无不周遍。然亦二义。由体有二义故。一者能包。二者能遍。犹如虚空包含万象遍至一切处今用称体之包。则一尘受世界之无边。二称体之遍。则刹那弥法界而无尽。上之三字。即体相用无有障碍。为所证之法界也

疏。佛谓觉斯玄妙者。亦有二义。一者能觉。佛陀梵言。此云觉者故。二者所觉。即上大方广。斯为玄妙之境故。云觉斯玄妙。斯即此也。即此上大方广耳。若别说者。觉上用者。觉世谛也。觉上体者。觉真谛也。觉上相者。觉中道也。三谛相融三觉无碍。为妙觉也

疏。华喻功德万行者。此亦二义。一感果华。喻万行。因成佛果故。或与果俱。或不与俱。俱如莲华表因果交彻故。不俱如姚李。不坏先因后果故。二严身华喻诸位功德。必与位位果俱故。故下经云。若见华开。当愿众生神通等法如华开敷。若见树华。当愿众生众相如华具三十二

疏。严谓饰法成人者。严亦二义。一以万行饰其本体。即严上大方广。如莹明镜。镜虽本净非莹不明。二以万行功德。成佛果之人。若琢玉成器。又饰本体。似铸金成像。以行成人。如巧匠成像

疏。经乃注无竭之涌泉下。唯经举四义。然亦唯二。谓贯与摄。涌泉即是所摄义味。常乃通于上三。一注无竭之涌泉者。此言犹通诸教。二贯玄凝之妙义。以总就别。别贯华严玄妙义故。凝谓凝湛。严整之貌也。三摄无边之海会者。即是摄义。无边海会局此经众。拣余众故。四作终古之常规者。即是常义。余处释云。常乃道轨百王。今亦以通就别。别属此经。法眼常全无缺减故。常恒之说非随宜故。终古无忒可得称常。释题竟

疏。佛及诸王并称世主下。释品名。此释世主。世谓世间。即三世间。一谓众生世间。二器世间。三智正觉世间。主谓君主。即佛及诸王。地神水神林神山神。即器世间主。天王龙王夜叉王等。即众生世间主。如来即智正觉世间主。亦总化上二。遍统前三。故云并称世主

疏。法门依正俱曰妙严者。此严亦说三种世间法门为能严。唯局于主。依正所严通三世间。众生及佛俱通正故。谓诸世间主。各得法门自严己众。即众生世间严并用。严佛亦智正觉严。佛成正觉是自法门。是故能令其身充满一切世间。其音普顺十方国土菩萨众中。威光赫奕等。即智正觉世间严。其地坚固金刚所成。上妙宝轮及众妙华。清净摩尼以为严饰等。即器世间严。器世间严通二法门。一佛力令严。是佛自严。二能感者观见。即是众海法门严。是故总云法门依正俱曰妙严。三世间严并胜余教。故标妙严以为品目。后斯经下。双结二目。上文明不释。已上用当同诸经之序分。余如下说

自下第二。归敬三宝。请威加护。有十六句。大分为三。初有八句。正归敬三宝。次有六句。请威加护。后有二句。回施众生。初中分二。初句总明。余皆别显。今初。归命二字。显能归相。三业普周。归向依托无尽三宝。但云命者。以人所宝重莫过身命。今将仰投。十方已下所归分齐。十方横遍。三际竖穷。极通横竖。就别显中三宝即为三别。初三句归佛。次二句归法。后二句归僧。初中又二。前之二句总归诸佛。后之一句别归本师。初中尘刹有其二义。一所依处。谓一一尘中诸刹土故。佛所严刹等尘数故。又尘约微细。刹通粗细。二即尘数如来。圆谓圆寂。明谓智明。即菩提涅槃。亦无德不圆。无法不照故。上二字自利。调御师者。通利自他。十号之一。巧摄有情号。法界亦二义。一成上依处。上云尘刹。似当约事。今云法界义兼事理。佛身充满于法界故。又充满法界无穷尽故。二者该后称。法界之功德大悲云故。功德者。亦圆明中别义。即十力无畏十八不共。百四十种无尽之德。大悲普覆。无心含润。故喻于云。毗卢一句别归本师。乘恩重故。四字标名。三字赞德。上云功德。总该无尽。今云大智。别语最胜。顺于光明遍照义故。大智深广故喻于海。又诸佛举悲。本师语智。影略以明。悲智深广故。悲亦称海。大悲深广故。智亦如云。含润法雨故。又前云功德。此云大智。成二严故。无尽功德不出二故。所住下二句归法。言所住者。蹑前起后。所以蹑者。显同体故。但归别相不会理故。然三宝有三相。一同相。二别相。三住持相。今通依之。初同相者。此有三义。一约以事就义门。则别相之上。各有三宝。一佛体之上。有觉照义。名为佛宝。轨则义边。名为法宝。违诤过尽。是名僧宝。即以无漏法界功德为体。二法上有三者。法有觉性即是佛宝。轨持即是法宝。法体无违即是僧宝。三僧上三者。观智为觉为佛宝。轨则为法宝。在众无违。无违众生故名为僧。今举佛所住以明法者。即约佛上论同体也。理是佛所住。教从佛所流。两重相依。二约会事从理门。三宝皆依真故。今举佛法皆归真性。略不言僧。三约以理融现门。心性本觉。即是佛宝。恒沙性德。皆可轨持。即是法宝。此恒沙性德。性相不二。和合名僧宝。由此一门故。令如来住真法性。若无此者何所住也。三门虽异并称同体。故净名云。佛即是法。法即是众。是名三宝。皆无为相与虚空等。是故若就觉义并称佛宝。轨则而言无非法宝。冥符和合莫不皆僧。义说有三。不可为一。然无别体。岂为异耶。故云同相。二别相者。即如前科。佛则横该一切竖彻十身。法则通四。略举理教。上句是理。下句是教。僧虽该摄偏语大乘。是故但举文殊普贤。三住持三宝者。十身之中有力持身即住持佛。其修多罗即住持法。住持之僧含菩萨中。然三三宝。通于诸乘有其胜劣。以义料拣。归胜非劣。一理统之。三三无异。故并皆归敬。显敬无遗。三一一。下二句归僧。初句明处。一一微尘中。有一切诸佛。菩萨众围绕故。况一一佛所难思。普贤住普贤位。莫不皆尔。下句举人。偏举二者。以是海会之上首故。表理智故。诸言不一则无所不该。第二我今下。请威加护。六句分三。初二句请归之意。意欲释经故。然通显归意。乃有众多总相而言者。三宝吉祥。一切众生最胜良缘。有归依者。能办大事。生诸善根。离生死苦。得涅槃乐故。又一切经。初有六成就。令物信故。佛灭度后。凡诸弟子所有著述。皆归三宝示学有宗。不自专己。离过失故。请威加护令契合故。上句自谦智劣。等彼一毛。下句赞法广深。同真法界。一毛度空。乍可知量。凡智测法何能穷尽也。次愿承下。二句愿加护相。上句明加。下句明益。今初。未能深入三昧。外感佛加。但请同体之慈。希沾胜益。下句益中句句冥符。愿始末无违。而言冥者。亦谦辞也。末得显加。且希冥契。使凡心凡笔暗合圣心。三俾令下。二句著述所为。使令法眼圆满化尽含生故。贤首品云。彼诸大士威神力。法眼常全。无缺减也。第九回向不愿成佛。唯愿等于普贤者。良以普贤该因彻果。佛前佛后皆悉有故。普贤即是诸佛根本故。法界体故。故金刚顶经。十方诸佛礼普贤者。亦斯义矣。然著述所为。但愿大法弘通众生利乐。即悲智大意。曲论别为。乃有多缘。以斯经乃诸佛所证。根本法轮。诸教标准。此方西域无不仰遵。而圣后所翻文词富博。贤首将解。大愿不终。方至第十九经。奄然归寂。苑公言续于前疏。亦刊削之。笔格文词不继先古。致令后学轻夫大经。使遮那心源道流莫挹。普贤行海后进望涯。将欲弘扬。遂发慨然之叹。若有过不说。是非浑和。岂唯掩传者之明。实乃拥学人之路。若指其瑕类出彼乖差。岂唯益是非之情。实乃黩心智之境。余故抚心五顶。仰托三尊。不获已而为之也。以斯别意略有十焉。一圣旨深远。各申见解故。二显乎心观。不俟参禅故。三扶昔大义。不欲掩人故。四剪截浮词。直论至理故。五善自他宗。不妄破斥故。六辨析今古。新旧义殊故。七明示法相。显经包含故。八广演玄言。令悟心要故。九泯绝是非。不妄破斥故。十均融始末。首尾可观故。初一为总意。后九为别意。指昔瑕疵。疏中欲掩是非。传者须知得失。诸徒诚请。难以违之。长时弘宣。不繁数述。恐迷宗滞迹。竞作是非耳

第一圣旨深远各申见解者。此为总意。谓佛法冲深。随人智慧有深浅故。斯亦为遮外难。恐有难言。世路以多岐亡羊。学者以多途丧志。纯源莫二。枝派转多。旧疏新章。益汨真性。何以屋上枷屋。床上安床。昔已有之何要改作。故下十意皆通此疑。今之初意正答斯难。特由圣旨深远随见不同。各呈其能以光法施。昔可尚也。安更有词。故五百比丘各说身因。佛许无非正说。三十二菩萨共谈不二。异见同归。故下经云。无边海会。各入解脱之门。境界万差。同趣如来智海。故海慧菩萨云。如来境界无有边。各随解脱能观见。是以西域东。夏释论解经。经有多家论文。论有诸师解释。如析金杖。金体不殊总收百川。溟渤弥大。故或登地菩萨。或加行贤人。或当代时英。或如来悬记。皆思拔群伍。智出众情。而所见不同。并传于世。各申其美。共赞大猷。依之修行无不获益。今亦仰攀胜德。以尽专精。握管窥天。滴流足海。复何怪焉

第二显示心观不俟参禅者。以经虽通诠三学。正诠于定。皆是如来定心所演。故经云。汝所说者。文语非义。我所说者。义语非文。况华严性海不离觉场。说佛所证海印三昧亲所发挥。诸大菩萨定心所受。昔人不详至理。不参善友。但尚寻文。不贵宗通。唯攻言说。不能以圣教为明镜。照见自心。不能以自心为智灯。照经幽旨。玄言理说。并谓雷同。虚己求宗。詺为臆断。不知万行令了自心。一生驱驱。但数他宝。或年事衰迈。方欲废教求禅。岂唯抑乎佛心。实乃翻误后学。今皆反此。故制兹疏。使造解成观即事即行。口谈其言。心诣其理。用以心传心之旨。开示诸佛所证之门。会南北二宗之禅门。撮台衡三观之玄趣。使教合亡言之旨。心同诸佛之心。无违教理之规。暗蹈忘心之域。不假更看他面。谓别有忘机之门。使彰乎大理之言。疏文悬解。更无所隐。难可具陈

大方广佛华严经随疏演义钞卷第二大方广佛华严经随疏演义钞卷第三

        唐清凉山大华严寺沙门澄观述

第三扶昔大义不欲掩人者。谓晋译微言。幽旨包博。玄义全盛。贤首方周。故讲得五云凝空六种震地。而刊定记主师承在兹。虽入先生之门。不晓亡羊之路。徒过善友之舍。犹迷衣内之珠。故大义屡乖。微言将隐。破五教而立四教。杂以邪宗。使权实不分。渐顿安辨。析十玄之妙旨。分成两重。徒益繁多。别无异辙。使德相而无相即相入即用之体。不成德相不通染门交彻之旨宁就。出玄门之所以。但就如明。却令相用二门无由成异。以缘起相由之玄旨。同理性融通之一门。遂令法界大缘起之法门一多交彻而微隐。如斯等类其途实繁。非是重古轻今。不欲欺诬亡殁。今申上古之义。新疏翻多。有同刊定之文。皆是古义今同用耳

第四剪截浮词直论至理者。且文华尚犹翳理。繁言岂不乱心。科文过碎已杂尘飞。重叠经句但盈纸墨。等闲会于梵语。无益经文。次第数于经文。更无理观。如烟郁火云翳长空。今并剪而削之。若长风卷雾。然经多十句。若过半已上。难者则具而释之。难则曲尽而非繁。易则略陈而不阙。若五六句已下难者。则摘句而释之。易则不释。若文义全易者。大科而已。若文易意难者。总相收束。文难意易者。但细消文。若文义俱难者。先出意而后释。使质而不野。简而必诣。是本心也

第五善自他宗不妄破斥者。谓昔人所引经论及破他义。无问性相多不穷于始末。辄引辄破。或多用法相。而复尽呼为权。引权释实。又不分通局。疑误后学。或以昔正为非。或复以权为实。今亦反此。若破若引。先示彼义。使性相无亏。尽其意态。后申此理。对决分明。使学者不滞迹迷宗。不谬非古义。亦无劳周览。更复傍求

第六辨析今古新旧义殊者。谓探玄本记但释晋经。大旨虽同在言有异。但引彼疏须观所释。如发心品晋经云。以是发心即得佛故。唐经云。以是发心当得佛故。即当既别。岂得将昔之即。释今之当。其类皆尔。然昔人十行已前。多依贤首新修略疏。回向已下并用探玄。三地已下多唯古录。二经小异舛互相参。文亦非一

第七明示法相显经包含者。然性之与相。若天之日月易之乾坤。东夏西方。分宗开教。学兼两辙。方曰通人。是以释经。事须明示。然此经法相。名义兼广。或有名无义。或有义无名。昔人苟见一名。广引论释。随名解义。义乃无穷。如释净行品百四十一愿。以诸门料拣。释梵行品四果。广引婆沙。问明品。贪嗔全抄唯识。十行品三倒广据诸宗。虽则皆是法门。而甚深观行翳于名相。今皆略陈而已。古人若有义无名。则莫知所以。今则引诸经论。以名管之。使经中法相昭彰于众论。至如兜率品二十一种功德。则有义无名。离世间品初则有名无义。今于兜率品。广引经论而释之。至离世间品略陈而已。又如离世间品具舍诸位。一一位内摄义无遗。或名异义同。或前后广略。然于四十二位次第无差。今并具引六会经文。对前释之昭然可见。使七卷之经句句有据。翻验昔解臆说尤多。然性相二宗。法相有同有异。如五眼十眼六通十通等。并各示之使无余惑。如初卷叹德。释以十身。则法性宗之法相也。释智入三世广引四智。即法相宗之法相也。以众海解脱之门。释众海之名目。法性宗之法相也。以九门之六度释经十度。即法相宗之法相也。如十通十忍会六通五忍。十身十智融三身三智。十门涅槃。以会通四种涅槃。十种佛智。而一智融于四智。即性相二宗无违之法相也。触类非一。又诸经疏所明法相。多是傍来。如法华经。但云如来知见力无所畏禅定解脱三昧深入无际。斯乃通赞佛智深远。逢力一字立十力章。无所畏字立四无畏章。禅立四禅。定立八定。解脱三昧并立章门。若此之流千章万章。释一卷经亦不得尽。若为成种智之境。应须更学多门。取法华玄宗。但示众生等有知见。先所出内是子所知。非是十章五章能尽斯妙。若华严经有异于此。如十度十力。一经数十处明故。须总撮一章顿晓玄旨。如十地品内以法相为观门不了三聚。岂知离垢之名。不晓八禅宁知发光之行。四地道品。成无生之慧光。五地诸谛。穷真俗以化物。六地般若要观缘生。星罗十门月满三观。研穷性相般若现前。七地穷一切菩提分法。权实双行。八地七劝该罗。方见无功之道。九地居法师之位。药病须知。不得四十辩才。何以广能化物。得第十地方尽种智之深玄。四十二位之昭彰并称观行。九会五周之因果。佛道方圆故。若相。若性。若因。若果。无不成观。无不契真。依经修行并是圣意。若不了法相。岂唯不知圣旨。亦非弘阐之人。寻文自知

第八广演玄言令悟心要者。谓经多有玄言妙旨。昔不广明。或指在别章。或略陈不具。今应具者毕在疏文。文易意深。广申体势。如始成正觉。以诸宗始成而会之。智入三世。以二智三智四智而释之。如幻喻中引兔章以尽之。如影之喻。分三影以别之。第七回向刹平等出诸句以拣之。第八回向历境起愿。以横竖位次而彰之。三天偈赞离相回向。以般若等深经中百等论玄妙而通之。九会五周皆以性相而广之。普贤三昧。穷妙中之妙。出现一品尽玄中之玄。至如法界华藏之深观旨归关脉之妙章。尽关键之幽微。穷义理之分齐。如关中系表三玄格言。有美斯经必尽其奥。亦有指别章者。皆非正要。知与不知无乖弘赞耳

第九泯绝是非不妄破斥者。昔人胜负气高是非情厚。上古妙义用而不言。先贤小瑕广申破斥。如娑婆形如虚空。便云良由译人不闲经论。谬预译场。误累圣教。一朝至此。先师在其译内。斧凿太深。纤芥在于珠中。何须击破。又如十行品内释不住中流。广申异释。晋经失旨致古释枝辞今文分明何须叙昔。若斯之类。其事颇多。终日是非。岂合大道。凡破义者。其犹毒蛇螫手不得不斩。毒树生庭不得不伐。若邪解乱辙。事须决之。若易知其非。略而不述。若似正不正。则并决分明。如欲识真金须明鋀石。盖不获已情忘是非。设有破斥须存礼乐。不得自尊己德。下视先贤。须知草创者难。因循者易。纵有举非显是。不是自炫自媒。故今疏文是非全少

第十均融始末首尾可观者。然造疏大体。皆初重后轻。若更广开门庭。消文疏略。至于弘阐。圣旨多沈。今以大经九会始末深玄。逢义即明不拣初后。但初已释。后不重明。故义科章门落落星布。使初中后善始末可观也。略述制疏有斯十意。故忘躯灵境。仰述玄猷。本意皆为众生得同普贤诸佛耳。第三二句回向众生者。前之二句作疏所为。为于众生。此段通回归依之益。及所成德。制疏之功。傥一句冥合圣心。尽为众生得大觉圆明涅槃常乐也。将释下。第三开章释文。十门之内。前八义门。后二正释以经题目即是文故亦可。九门皆义。题目通于一部文故。十门生起。如是次第者。夫圣人设教。言不虚发。动必有由。非大因缘莫宣斯典。故受之以教起因缘。二者。因缘既兴有所起教。佛教虽广不出三藏十二分教。未委此经三藏教中何藏教摄。故举藏教之总名。含摄华严之别教。故受之以藏教所摄。三已知此经修多罗摄。具十二分。然其藏教皆通权实。拣权取实唯圆教收。未知圆义浅深宽狭。故受之以义理分齐。四既知圆教包博冲深。未审此经被何根器。故受之以教所被机。五知甚深义理正被圆机。未知其诠何为体性。故受之以教体浅深。六能所文义已知该罗。未审所宗尊崇何义。故受之以宗趣通局。七既知旨趣冲深。未委能诠文言广狭。故受之以部类品会。八既知部类广则无尽略乃百千。未知传译何年有何感应。使宗承有绪。知胜益可归。故受之以传译感通。九大旨既陈随文解释。先明总目包尽难思。故受之以总释名题。十总意虽知在文难晓。使沉隐之义彰乎翰墨。宗通之理见乎百千。故受之以别解文义

疏。因缘者下。疏文有二。一生起大意。二先因后缘下。开章别释。前中有三。一正释。二引证。三解妨。今初。先法。次若须弥下喻。后今摇如来下合。如来合山。智慧合海。此文意出智论。今转势用之。智论中问曰。佛以何因缘说般若波罗蜜经。诸佛不以无事及小事因缘而自发言。譬如须弥山王。不以无事及小事因缘故动。今以何等大因缘故。说般若波罗蜜经。此中论意。即以说般若为动须弥。今开须弥。约能说人。智海通能所说。动能说之佛智。说如来之智海。并即不共般若。又于经中广说佛身及与佛智。故佛身及智并通所说。疏故下经下。二引证也。疏。出现本为下。三解妨也。有伏难云。非一缘等。乃明出现之缘。今将证说。岂为惬当。故今通云。出现本为一大事因缘。一大事因缘。即华严佛智。明知出现之缘。即华严缘也

疏。先因后缘各开十义者。此下第二开章别释。于中二。初双标。二双释。双标可知

疏。因十义下双释先因中亦三。初列。次释后因。上十义下。结属会释

疏。言法尔者下释也。即为十段。今初。法尔。疏文分四。一正释。二引证。三结释。四解妨。初文可知

疏。故不思下。引证。此即第四十七经。第五大那罗延幢勇健法云。佛子一切诸佛能于一身等。乃至已下中间。应云法界众生靡不皆闻一一音声演尔所修多罗藏。一一修多罗演尔所法。一一法有尔所文字句义。如是演说尽尔所劫。尽是劫已复更演说尽尔所劫。如是次第乃至尽于一切世界微尘数劫。尽一切众生心念数量。未来际劫犹可穷尽。如来化身所转法轮无有穷尽。所谓智慧演说法轮。断诸疑惑法轮。照一切法法轮。开无碍藏法轮。令无量众生欢喜调伏法轮。开示一切诸菩萨行法轮。高升圆满大智慧日法轮。普然照世智慧明灯法轮。辩才无畏种种庄严法轮。如一佛身以神通力转如是等差别法轮。一切世法无能为喻。如是尽虚空界。一一毛端分量之处。有不可说不可说佛刹微尘数世界。一一世界中念念现不可说不可说佛刹微尘数化身。一一化身皆亦如是。所说音声文字句义。一一充满一切法界。其中众生皆得解了。而佛言音无变无改无有穷尽。是为第五大那罗延幢勇健法。今疏略引耳。上钞中尔所字。经中皆是不可说不可说佛刹微尘数字

疏。斯则处以毛端下。三结释也。结释经文。成初正说。于中初二句正结。后处则下。覆释。法界齐起为顿。如月入百川。非从东向西等。故长时不断曰常。无间断故。既常既遍故不待别因

疏。但随见闻下。四解妨。有伏难云。既横竖该罗。说穷时处。何有初成之始九会之终。故为此通。于中二。先正解妨可知。后令寻于此下。重通再难。难云。略本至少。安穷无尽之理。故为此通。以见理圆融故。少见能穷无尽。有法喻合。以一处下。释成上义。时处既一多相即法。岂一不含多

疏。二酬宿因等者。疏文分五。一标举章门二何以下。蹑前起后。三夫根深下。摽因深广。四深大云何下。释成深广。五宿因虽多下。开章别释。于中先标章。后别释可知

疏。三顺机感者。文中分六。一标章。二蹑前起后。三其犹下。约喻显相。四故兜率下。引经证成。五广显下。指略在广。六然此下。拣定于机。言今之闻者是未来机者。望说经时是未来故。故发菩提心品中。十方法慧同白佛言。我等悉当护持此法。令未来世一切菩萨未曾闻者皆悉得闻。亦是未来机也

疏。四为教本者。文三。初标章。次总彰大意。然后亦有二下。开章别释。大意中。初二句立理。故出现品云。譬如大海潜流四天下地。有穿凿者无不得水。彼喻佛智普入一切众生身中。今借用之。斯即喻也。非本无以垂末者。法说。如无海本不能流末。无其本月。则无月影入于百川。无有法身。岂能垂于应化。故无有根本之法。何有随宜之谈。后将欲下。两句正释。为本之义。故天台指为乳教。乳是酪等诸味本故

疏。出现品云。如日初出先照高山者。彼文云。譬如日出先照须弥山等诸大山王。次照黑山次照高原。然后普照一切大地。日不作念我先照此后照于彼。但以山地有高下故。照有先后。如来应正等觉亦复如是。成就无边法界智轮。常放无碍大智光明。先照菩萨摩诃萨等诸大山王。次照缘觉次照声闻。次照决定善根众生。随其心器示广大智。然后普照一切众生。乃至邪定亦皆普及。为作未来利益因缘。令成熟故。而彼如来大智日光。不作是念。我当先照菩萨大行。乃至后照邪定众生。但放光明平等普照。无碍无障。无所分别。释曰。始成便说华严。是照菩萨山王。此明是先大后小

疏。二为摄末之本者。于中二。初标名也。为华严未有未之可摄。以法华摄末归本归华严故。故为本也。疏。如日没时还照高山故者。二义取出现经意以证。而无此文。即是法华所明。先小后大及三时五时之教。后后胜于前前。法华涅槃唯闻一极。为照菩萨

疏。无不从此法界流下。二双证上二。先引摄论。后引法华。初引摄论。无不从法界流。即证开渐之本。无不还归此法界故。即证摄末之本。此乃义证教。谓论所明。报化身等。皆从法身生。还归于法身。法身等即义。今以法身类于华严故。云以义证教也

疏。法华亦云下引法华证。故下。吉藏引此立三种法轮。第一名根本法轮。第二名枝末法轮。第三名摄末归本法轮。文中便引便释。三节具也。疏。斯则法华亦指此经以为本矣者。结成本义。若自立为本。恐义未明。法华指此为本。本义方显。始见我身入于佛慧。即华严。亦令得闻法华入于佛慧。岂非指初为本。又法华第一云。于一佛乘分别说三。亦是从本流末。即指华严为一乘。分别说昔之三。三即鹿野四谛等。若也。不指华严为本。鹿野之前。以何为一乘耶

疏。五显果德者。疏文分二。初总明大意。有法喻合可知。后然果德有二下。开章别释。于中亦二。先正释可知。后然依正无碍下。融通于中三。初约用互在。以明六句。次约体相即。以明四句。后随举一门下。双结体用

疏。然依正无碍。通有六句。至其文非一者。初二指事令晓。余但列名。然相即相入相在之义。义分齐中即当广明。而相入各有分圆。若约圆说。应言刹中有刹。今欲显胜。举尘毛之分。以摄刹身之总也。言其文非一者。谓第六经。法界普明慧菩萨偈云。佛刹微尘数。如是诸刹土。能于一念中。一一尘中现。第一句也。成就品云。一一尘中难思刹。随众生心普现前。一切刹海靡不周。如是方便无差别。亦第一句也。现相品云。如来一一毛孔中。一切刹尘诸佛坐。菩萨众会共围绕。演说普贤之胜行。回向品云。一毛孔中悉明。见不思议数无量佛。一切毛孔皆如是。普礼一切世间灯。僧祇品云。于一微细毛端处。有不可说诸普贤。如一毛端。一切尔。如是乃至遍法界。皆第二句也。又云。于一微细毛孔中。不可说刹次第入。毛孔能受彼诸刹。诸刹不能遍毛孔。现相品云。如来安坐菩提座。一毛示现多刹海。一一毛现悉亦然。如是普周于法界。亦第三句也。普贤偈云。如于此会见佛坐。一切尘中亦复然。佛身无去亦无来。所有国土皆明现。现相品云。一切刹土微尘数。常现身云悉充满。普为众生放大光。各雨法雨称其心。亦第四句也。又云。一一尘中无量身。复现种种庄严刹。一念殁生普令见。获无碍意庄严者。即第五依内现依正也。僧祇品云。一微尘中悉能有不可言说莲华界。一一莲华世界中。贤首如来不可说。亦第五句也。世界成就品云。一毛孔内难思刹。等微尘数种种住。一一皆有遍照尊。在众会中宣妙法。即第六正中现正依。现相品云。一切诸佛土。一一诸菩萨。普入于佛身。无边亦无量。成就品云。一切刹土入我身。所住诸佛亦复然。汝应观我诸毛孔。我今示汝佛境界。皆第六句也

疏。又有四句等者。第二约体相。相即明四句也。相即互亡。故无有二。一佛即刹者。佛体即是法性土故。废己从他。佛体虚故土外无佛。法性无二故。二刹即佛身者。刹体即是法性身故。废他从己。刹体虚故佛外无刹。法性无二故。由性无二故。以性融相故。身刹相即三俱者。谓有身有土不坏相故。若无身无土无可相即故。四泯者。谓佛即刹故非佛。刹即佛故非刹。以互夺故

疏。随举一门即摄一切者。三双结体用。以即入二门无二体故。体外无用。唯相即故。用外无体。唯相入故。无有镜外之明明外之镜故。言并如下说者。即指义分齐中

疏。六章地位者。疏文二。初总彰大意。后开章别释。前中二。先顺明来意。后夫圣人下。立理反成。圣人之大宝曰位者。即周易下系辞云。夫天地之大德因生。圣人之大宝曰位。注曰。夫无用则无所宝。有用则有所宝也。无用而常足者莫妙乎道。有用而弘道者莫大乎位。故曰圣人之大宝曰位也。疏。若无此位行无成者。即反成须位也

疏。此亦二种下。二开章别释也。于中三。一正释。二会融。三引证。初中先释行布。言行布者。行位分布。阶降浅深。如第二会明信。三明住。四明行。五明向。六明地。七明等妙。前非是后。后非是前。故言行布。后释圆融。言圆融者。圆满融通。疏释有二。初正释。二引证。前中自有二义。一者疏云。一位即摄一切位故者。此总辩相摄。谓四十二位之中。随举一位。即摄一切。如初发心住即摄余九住及摄行向地等。二者疏云。一一位满即至佛故者。此别明五位互摄。如初住摄于初行初回向初地。第二住摄第二行第二回向第二地等故。第十住满。则十行满十向满十地满故。十住满称灌顶位。第十地满时。亦称灌顶。而成佛故。十行智度圆。十地智度满。海幢比丘顶出诸佛说法。灌顶住后。即明佛者。即其事也。前唯约理行圆融。此兼明行证相似

疏。初地云下。二引证也。文即为三。一云。一地之中具摄一切诸地功德者。此约当地之中。自互相摄。一地摄十地。以一例诸位位皆然。上正引文。二云。信该果海者。此明五位互摄。贤首品中。乃至则得灌顶而升位等。此即义引为证。三初发心时便成正觉者。正明以初摄后。通于二义。若住满成佛。即是当位。以初摄后。若究竟成佛。即异位相望。以初摄后。如四十二字门。初阿字门具后荼字也。上来总有三义。一举一位。总摄五十二位。二举一位摄五位。三举初摄后。复应有后摄初。初后摄中。中摄初后。一摄一切。一切摄一。一摄一。一切摄一切。如理思之。上云初发心时便成正觉。即是正引经文。梵行品云。若诸菩萨能与如是观行相应。于诸法中不生二解。一切佛法疾得现前。初发心时。即得阿耨多罗三藐三菩提。知一切法即心自性。成就慧身不由他悟。今略引耳

疏。然此二无碍下。会融也。于中二。初辩定其相。二正明会融。前中有二对。行布圆融。以教对理。以相对性。下正圆融。但融相性。初对。谓约能诠教道。则行布不同。约所诠之理。则圆融无碍。第二对。就所诠中。约相则深浅不同。约性则融通无二。言德用者。即德相业用也

疏。相是性之相故下。正明融会。文有三番。第一番。直明无碍。第二番。则互相成。谓无量本是约相行布。圆融本是一理平等。今圆融既不碍行布。故成无量之德。下句反此可知。第三番。从无量为一故。融通隐隐下。明相成而不失本相。无量为一故。融通而不失本相故。隐隐然似有二。一为无量故能重重。不失一相故能涉入

疏。故世亲。以六相圆融下。第三引证。此引论证。即总别同异成坏。由此故得举一全收。至下广明。次云上下之文非一者。双引经疏。若望经则唯是下文。若望疏文。通指一经上下耳

疏。七说胜行者。疏文亦二。先明大意。后开章解释。前中初二句依教正释。后二句引外事证。即论语第二。彼下二句云。不患莫己知求为可知也。包氏注曰。求善道而学行之则人知己。今引证此。求为可知。及所能立。皆是行也。上两句行成得位。下两句行成得名。今为证位故。但引前耳

疏。行亦二种下。开章释也。先释后融。前中明顿成中。先正明。后引证。言一断一切断等者。等取一障一切障一修一切修一证一切证故。普贤行品。初说十句。若成此十。则顿成五十二种胜行。一念嗔心起。百万障门开。故偈中云。不可说诸劫。即是须臾顷。莫见修与短。究竟刹那法。皆以圆融也。故妙严品云。一法门中无量门。无量千劫如是说。所演法门广大义。普运光天之所了

疏。二遍成诸行下。释行布从始迄终。故云乃至。则五位所行。皆此摄也。菩提心为始。体即三心。谓一直心。正念真如法故。即是大智无所执着。二深心。乐修一切诸善行故即是大愿。谓四弘等。三大悲心。救护一切苦众生故。七十八云。菩提心灯。大悲为油。大愿为炷。光照法界。光即直心。炷即深心。油即大悲心。多以三心为体。上求下化。照理起行。不出此故。言相者。即无相为相。同法界相。无分量相。无齐限相也。言功德者。无德不收故。发心品十种大喻。百门较量。亦不及少分。七十八卷。广以喻叹。亦不能尽。贤首品云。若有菩萨初发心。誓求当证佛菩提。彼诸功德无边际。不可称量。无与等。发心品云。发心功德不可量。众智共说无能尽。又云。菩萨发心功德量。亿劫称扬不可尽。以出一切诸如来。独觉声闻安乐故等。皆发心功德也。又云。欲见十方一切佛。欲施无量功德藏。欲灭众生诸苦恼。宜应速发菩提心。此上三事。皆是发菩提心。为万行之本。故首明之。即此发心。便名为行

疏。此二无碍下。第二融通可知

疏。八示真故下。文亦有二。先总明。后别释。文含多义。不异分齐中教因总该故。此略举义深理要。故别为一门

疏。九开因性者。文亦先总后别。总中先蹑前起后。良以下。总相解释。于中有三。初明因义。本有恒沙性德。本觉佛智无二体故。以此为因。二但相变下。覆彼因义。是以须开。所以相变体殊者。迷真如以成名相故。情生智隔者。失正智而成妄想故。上对约境。下对约心。五法具矣。三今令下。正明开义。知心空寂。则名相泯而真体合。达本无住。则妄想亡而正智生。真本不可以功成。要亡功而本就。深源不可以行得。必行尽而源成。若寂照双流。则因性开矣。性即知见。知见性相并皆显现。故谈已下结成开义

疏。亦有二下。别释。以言显示令其知有者。唯明示义。如示贫女宅中宝藏。未见未得。二使其修行者。义通开示。不知令知。名之为悟。未证能证。称之为入。显现之言。对于开义。如下破尘下。引经证成。经云。如有大经卷。量等三千界。在于一尘内。一切尘亦然。有一聪慧人。净眼悉明见。破尘出经卷。广饶益众生。佛智亦如是。遍在众生心。妄想之所缠。不觉亦不知。诸佛大慈悲。令其除妄想。如是乃出现。饶益诸菩萨等。即其义也。疏。唯以一大事因缘故者。即引他经。大乘法师。但云事物体事事义。道理随应皆得。今略释之。无二无三故名为一。佛因佛果故称为大。因果干能。令物解脱。并称为事。言因缘者。如来因此缘此。故出现耳。又因缘者。属于大事。正因佛性为因。缘因佛性为缘。了因所了为因。生因所生为缘。斯则大事。通因通果。因缘但语于因。因即种性之义故。彼经云。佛种从缘起。万行为缘起。斯佛种成菩提故。疏。所谓开示下。义引彼经。具云舍利弗。云何名诸佛世尊。唯以一大事因缘故出现于世。诸佛世尊欲令众生开(无上义)佛知见使得清净故。出现于世。欲示(同义)众生佛之知见故出现于世。欲令众生悟(不知义)佛知见故出现于世。欲令众生入(因义)佛知见道故。出现于世。广释如别。略释如下。疏。众生等有故言唯一者。随难而解。唯解一字耳

疏。十利今后者。文中亦二。先蹑前总辩。后此亦下。开章别明。又分为三。初约时分二。可知。次此益复二下。约行分二。后又此利益下。对前成异。二中。疏云。终竟不销等者。等取余句。余句云。要穿其身出在于外。何以故。金刚不与肉身杂秽而同住故。于如来所。种少善根。亦复如是。要穿一切有为诸行烦恼身。过到于无为究竟智处。何以故。此少善根。不与有为诸行烦恼而共住故

疏。二令起行成证入故下文二初证释后。良以有作下。释成。今初。疏云。乃至深入如来等者。中间经云。随顺一切如来境界。具足一切诸菩萨法。安住一切种智境界。远离一切诸世间法。出生一切如来所行。通达一切菩萨法性。于佛自在心无疑惑。住无师法。深入如来无量境界。故云乃至

疏。又此利益下。先对前辩异。所以辩异者。亦为拣滥故。利今后义似顺机感。机感亦有二世机故。故上文明约行分二。已是异。前但约时故。又顺机多约于所。利益多约于能。又顺机但是别义。利益通于十义。即总别之异故。对前九别。成斯十益也。于中二。先别对前。后亦可已下。通申本义。今初。文中。此十种益出于指归。但次第不同耳。彼次第云。一见闻益。二发心益。三起行益。四摄位益。五速证益。六灭障益。七转利益。八造修益。九顿得益。十称性益。此依从浅至深。自利利他等。而为其次。今疏顺前九门。展转相生。后能成前。以为次第耳。然见闻等。实通十因。欲显别义。随便逐胜。以别配耳。一以法尔常说遍说。便能触目对境。一切时中常如法见。所引经文如前总中。又出现品云。佛子。譬如雪山有药王树名曰善见。若有见者眼得清净。若有闻者耳得清净等。佛子。如来应正等觉无上药王亦复如是。能作一切饶益众生。若有得见如来色身。眼得清净。若有得闻如来音声。耳得清净等。又云佛子。我今告汝。设有众生。见闻于佛。业障缠覆不生信乐。亦种善根。无空过者。乃至究竟。入于涅槃。上虽明见佛。佛是华严佛。故舌根尝法味。故贤首品云。此法希有。甚奇特。若人闻已能忍可。能信能受能赞说。如是所作甚为难等。兜率偈赞品云。设于念念中。供养无量佛。未知真实法。不名为供养。若闻如是法。诸佛从此生。虽经无量苦。不舍菩提行。一闻大智慧诸佛所入法。普于法界中。成三世导师。明知。见闻其益深矣。疏。发心益者。若不闻此。不能发心。设有发心不得尊胜。以初发心时便成正觉等故。义如前引。疏。造修益者。谓闻此普法。便能造修一行一切行故。如前引出现品云。多劫修行。不闻此法非真修故

疏。顿得益者。如下六千比丘。言下获于十眼。善财童子一生便能顿圆诸位。法界品初。菩萨顿证等。并如教迹中引。疏。灭障益者。即一断一切断。如随好品天鼓教云。汝等应发阿耨多罗三藐三菩提心。以等法界三业悔过。结云。若如是知。是真实忏悔。一切罪恶悉得清净。说此法时。百千亿那由他佛刹微尘数世界中。兜率陀天诸天子。得无生法忍。又诸天子以香华等供佛而成大益。又云。其诸香云。普雨无量佛刹微尘数世界。若有众生。身蒙香者。其身安乐。譬如比丘入第四禅。一切业障皆得销灭。若有闻者。彼诸众生于色声香味触。其内具有五百烦恼。其外亦有五百烦恼。贪行多者二万一千。嗔痴等分亦然。了知如是悉是虚妄。如是知已。成就香幢云自在光明清净善根等。皆灭障益也。疏。摄位益者。如前位中具明。疏。起行益者。如普贤行品云。菩萨摩诃萨。得闻此法少作方便。疾得阿耨多罗三藐三菩提。以一行一切行故。如前行中具引。疏。称性益者。谓依此普法。一切众生无不皆悉称其本性。佛果海中旧来益竟。故出现品云。如来成正觉时。于其身中普见一切众生成正觉。乃至普见一切众生入涅槃。皆同一性。所谓无性。若不称性。岂得然也。疏。转利益者。如第一重地狱天子得益竟。展转成三重之益。后二即转利益也。如上灭障即第二重。亦是转利益。所望处别。故为灭障。第三重云。若有众生见其盖者。种清净金辋转轮王位一恒河沙善根。佛子菩萨住此转轮王位。于百千亿那由他佛刹微尘数世界中教化众生。乃至云。若有暂得遇斯光明。必获菩萨第十地位。以先修行善根力故。皆转利益。疏。速证益者。如前教迹中辩。一生圆旷劫之果中说。疏。故前九因皆为今益者。结也

疏。亦可一一门皆成十益者。此第二意却是正意。上但随宜耳

疏。因上十义故。此教兴下。第三结属。会释也。此上结属。下会释经文。彼经具云其说法者。同名法慧。悉以佛神力故。世尊本愿力故。为欲显示佛法故。为以智光普照故。为欲开阐奥义故。为令证得法性故。为令众会悉欢喜故。为欲开示佛法因故。为得一切佛平等故。为了法界无有二故。说如是法。十因举二。故有等言。疏。因缘相参者。神力是缘。余皆是因。故。云相参。今略举二。即有因缘。以疏对彼。因缘易知。故云可以意得

疏。第二明说经缘等者。疏文分二。先引例总明。后今有十缘下。开章别释。前中谓六成就中。信闻二种属于阿难。在佛灭后结集时安。不为经缘。余四成就。为经缘起。说必依时。要有方处。人通说听。即佛及众四义足矣。问智论云。说时方人令生信故。何以今言为缘起耶。答六中初二。唯属证信。后四义有两兼。阿难引之为生物信。当时无此教不得兴。故为缘起。今十缘中具有此四

疏。今有十缘下。开章解释中。先列后释

疏。今初。依时依文分四。一大意。二开释。三融会。四广如旨归。一句出法源。今初二。先拂迹显实。后就德显圆。前中疏。夫心冥至道。则浑一古今者。此约人显实。心与理冥契。则无今古之相。故肇公云。古今通始终。同穷本极末。浩然大均。生公法华疏云。古亦今也。今亦古矣

疏。法界无生等者。就法显实也。有生则属三世。便即有时。无生则无三世刹那。安有时分。故出现品云。真如离妄恒寂静。无生无灭。普周遍等

疏。下经偈云。下引经证。略举人证耳。即兜率宝幢偈也。彼具云。众生如是说。某日佛成道。如来得菩提。实不计于日。法界品云。菩萨智慧妙法轮。远离一切分别网。超越一切障碍山。不可以生死长短。染净劫数显示等。其文非一

疏。况无涯之说等者。二就德显圆。无涯之说。竖约长时。故旨归云。常恒之说。前后际而无涯。念劫圆融者。约一念即不可尽。一念即无量劫。无量劫即一念等。故云尔也。念即多劫。何定时之长短哉

疏。今以无时之时。略显十重时别者。此下第二开章解释也。就中三。初上二句标。次初唯下释。后于下结。二释中初唯一念者。谓于一刹那顷。遍无尽之处说无边法。二尽七日者。谓初成道一七日中。自受大法乐。大法乐者。所谓智慧寂静乐。第二七日。顿说此经。何以初成便说此经。此经胜故。若以初成表胜。初七最初何故不说。论云。思惟行因缘行故。因者能说之智。缘者所化之机。将欲说所得妙法以逗物机。故云思惟行行。疏。三遍三际者。谓尽前后际各无边劫。常恒周遍。演说此经。初无暂息上三易故

疏。但列名而已。疏。四摄同类劫下。以义稍隐故并加字。旨归但云。四摄同类。五收异类劫。六以念摄劫。七劫念重收。八异类界时。九彼此相入。十以本收末。今加一字。义则易见。故并不释。唯释第十耳。言摄同类者。于前无边劫各摄同类。如长劫唯摄长劫。短劫唯摄短劫等。疏。五收异类劫者。谓长劫摄短劫等。疏。六以念摄劫者。于一念中即摄无边同异类劫。念念皆尔。疏。七劫念重收者。此上念所摄劫中。各以念成劫。一一念亦各摄诸劫。是则念念既其不尽。劫劫亦复不穷。如因陀罗网重重无尽也。疏。八异类界时者。上之七重。且约一类世界。如今娑婆一类。今辩树形江河形等。无边异类之刹。刹既同处。而有不同时亦同时。而各别分齐。尽彼时分常说此经。疏。九彼此相入者。即彼异类界。所有时劫。亦各别相收。或同异类界时。互相摄入。若念。若劫。重重无尽。同前四五六七。于彼诸时。常说此经。疏。谓以非劫为劫者。第十难见故。以此句释之。以非劫为本。劫即为末。言非劫者。离分限故。如华藏世界。以非劫为劫。劫即非劫。念等亦尔。以时无长短离分限故。以离时分说彼劫故。以时无别体依法上立。法既融通时亦随尔故。离世间品云。菩萨摩诃萨知一切劫即是非劫。而真实说一切劫数。是为第六无碍住。故云非劫为劫。于前无量时劫。常说华严

疏。又此十种随一圆收者。此下。第三融会也。于中三。初此上二句。正融会。二依此说时则无始终下。通妨难。此上牒疑情。既无始终。何有初成之始九会之终。亦随见闻下。会释也。故疏指前通。又此一部。即是无边法海。以下皆结通无分齐故。一部即是一切说故

疏。若依此时下。三显胜能。于中又三。初拣他显胜。次而余教下。会他显胜故。或说下。再通妨难。难云。彼有三七六七等殊。云何不出于此。故今通云。皆是此经之时。随见闻故

大方广佛华严经随疏演义钞卷第三大方广佛华严经随疏演义钞卷第四

        唐清凉山大华严寺沙门澄观述

第二说经处文有四。第一总彰大意。第二叙昔顺违。第三句数圆融。第四别明处异。初中有三。初拂迹显实。二融通显圆。三依义建立。今初。至而非国土。即拂迹显实中。谓既亡能所。何有能依之佛所依之处。普贤三昧品云。普贤身相如虚空。依真而住。非国土。犹是假说。以真无能所无可依故

疏。况刹尘即入下。第二融通显圆。无能所依。尚通实顿二教。实教顿教尚离处所。况于圆教耶。刹尘即入即下。通局交彻。二种四句。染净参融。即下染净无碍。二种四句圆满。教下总结难思

疏。然真非下。第三依义建立。不坏相故不妨立时。然旨归约处。先已有处。依此说经。后辩其时。疏家顺六成就之次第故。先明时耳

疏。然有言下。第二叙昔顺违。于中先正叙。后上之下决断。前中第一师云。既七处九会。人三天四。并居娑婆欲界之中。明是秽也。第二师云。说此经时。华藏世界六种震动。又言。其地坚固金刚所成。娑婆乃是土石诸山。岂得将此而为秽也。第三师云。但合上二无碍。谓感娑婆者。对华藏而见娑婆。感华藏者。对娑婆。而见华藏。亦如螺髻所见如自在天宫。身子所见丘陵坑坎。华藏品云。譬如见导师种种色差别。随众生心行。见诸刹亦然。后决断。言后一近宗者。且知刹该净秽。即二四句中之一句。未穷玄妙故云近宗

疏。然说此经处下。第三句数圆融。于中有三。一双标。二双释。三以粗例细。初标可知

疏。初净秽中下双释。先释染净二种四句。前一四句。以本刹末刹相望成四句。华藏为本刹。世尊修因所严净故。刹种所持世界为末刹。应众生有故。然末刹即狭。本刹则宽。末通净秽。本刹唯净。若宽狭相望。自属通局。今论净秽故。但取末中染刹。前二句可知。第三句。双明本末故。得称俱者。不同前二说华藏即不言娑婆。说娑婆即不论华藏。今要明华藏之内娑婆。如一庄严城中举一小室耳。上三皆。约事明。第四句唯约理说。若理事相望。则前三句皆末。第四句复为其本故。华藏品云。华藏世界海。法界等无别。庄严极清净。安住于虚空等

疏。又或唯染下。第二四句。随取一刹即有四句。不论本末染净。今正约娑婆染刹上。论四句也。即前三约净秽亏盈。后一约相尽理现。若约机说者。染就劣机见故。净就胜机见故。俱约二人同见故。刹体自在故。俱非约顿机故。亦唯约体故

疏。次明通局。二四句等者。先标后释。释中前四句。约一重平漫以论。后四句。约重重相摄以说。又前四约以人望处论通局。后四唯约说处论通局。前中初二句。唯约相说。一谓此界七处说经。二谓十方诸刹齐说。三以相随性故。即一能遍。如光明觉品。彼云。如于此处见佛世尊。坐莲华藏师子之座。十方一切诸世界中。各有百亿阎浮提。百亿如来。亦如是坐。此明一会即遍一切。非是彼处各别有佛。四即归理平等。后四句中。初一约广容门。事含于理事理无碍故。令一界即理能摄一切。二约普遍门。事如理遍。令此一界随所依理入一切刹。三广容即普遍故。正摄之时便能入。彼以此二门无异体故。四泯同平等门。法界之中。俱不可得故

疏。又以一尘例刹。亦有四句者。三以粗例细也。引文如前依正融通中说

疏。若从狭至宽略显十处下。第四别明处异中。文分为六。一标数。二初此下。列释。三然上下。总结。四然说十住下。释妨。五十余佛同者下。随难重标。六又上十处下。总融十义。二中。然其十名与旨归小有不同。旨归云。初此阎浮二。周百亿。三尽十方。四遍尘道。五通异界。六该刹尘。七归华藏。八重摄刹。九犹帝网。十余佛同。今疏所以不同彼者。以归华藏。即前染净无碍故。不立之故。旨归文云。事尽理现。染相尽故。其该刹尘。与遍尘道。并皆是尘故。第七中摄。八重摄刹者。亦名华藏中尘一一摄余刹海。亦不异于第六该诸刹尘故。并略之而加四五六。以成十义。此亦贤首略疏之中。光明觉品中意。参而用之耳。疏。如升须弥品者。此文为证七处而周法界之言。文云。尔时世尊不离一切菩提树下。而上升须弥向帝释殿下。云十方世界悉亦如是。法慧偈云。一切阎浮提。皆言佛在中。我等今见佛住于须弥顶。十方悉亦然。如来自在力。皆遍法界之文也。七处皆尔。文中但三贤三天。言不起而遍。义如下疏。疏。如光明觉品者。此证百亿遍法界。皆有同类一界。言同类者。同有须弥大海铁围四洲二十八天。各有百亿故名同也。彼经云。如是无数无量无边无等。不可数不可称不可思不可量不可说尽。法界虚空界。所有世界。南西北方。四维上下。亦复如是。彼一一世界中。皆有百亿阎浮提。乃至百亿色究竟天。其中所有悉皆明现。彼一一阎浮提中。悉见如来坐莲华藏师子之座。十佛刹微尘数菩萨所共围绕。拣唯阎浮。故云百亿。拣下异类。故云同类一界。疏。三遍异类树形等刹者。上二皆略释。下八唯列名目而已。而言等者。等取江河回转形等。经列二十形。结有不可说不可说佛刹微尘数异类。一一流类皆遍十方虚空法界。与前须弥界等互不相碍。各于其中转斯法轮。疏。四遍刹种者。向明异类。且举百亿中异类故。今方明刹种。然异类言虽通华藏。言总意别。言遍刹种者。即取最中无边妙华光。香水海中普照十方。炽然宝光明世界种。其中摄二十重佛刹微尘数世界。结有不可说佛刹微尘数世界。于中布列。今遮那亦遍其中。疏。五遍华藏者。谓遍华藏一界。有前十不可说佛刹微尘数世界种。既皆如来修因之所严净故。常处其中而演说法。疏。六遍余刹海若种若刹者。即华藏之外十方无间。穷尽法界之刹海。例如华藏也。如第六现相品说。华藏世界海东。有世界海名清净光莲华庄严。南方名一切宝月光明庄严藏。西名可爱乐宝光明。北名毗琉璃莲华光圆满藏。东北名阎浮檀金颇梨色幢。东南名金庄严璃琉光普照。西南名日光遍照。西北名宝光照曜。下方名莲华香妙德藏。上方名摩尼宝照曜庄严。结云十亿佛刹微尘数等是也。疏。七遍前六类刹尘者。前之六段。各是一类。此上诸刹皆以尘成。一一尘中。皆有佛刹。如来于彼尘内刹中说经故。华藏品云。华藏世界所有尘。一一尘中见法界。法界尚见。何况刹耶。又云。一一尘内难思刹。随众生心各别住。又云。如于此会见佛座。一切尘中亦复然。其文非一。疏。八尽虚空界容一一毛端之处。各有无边刹海者。此不论成刹之尘。但取容尘之处。兼于空矣。如二界中间空无有物。亦是容尘之处。今取遍法界虚空界。有刹无刹有尘无尘。但可容尘之处。即有无边同类异类一切刹等。如来于此常转法轮。阿僧祇颂云。一毛端处所有刹。其数无量不可说。尽虚空量诸毛端。一一处刹悉如是。又云。彼毛端处诸国土。无量种类差别住。有不可说异类刹。有不可说同类刹。不可言说毛端处。皆有净刹不可说。种种庄严不可说。种种奇妙不可说。如是等文。成证非一。而言于中说法者。彼次颂云。于彼一一毛端处。演不可说诸佛名。出妙音声不可说。转正法轮不可说。于彼一一法轮中。演修多罗不可说。于彼一一修多罗。分别法门不可说。于彼一一法门中。又说诸法不可说。于彼一一诸法中。调伏众生不可说等。疏。九犹常网者。彼一一微尘。既各摄无边刹海。即此刹等复有微尘。彼诸尘内复有刹海。是则尘尘不尽。刹刹无穷。如帝释殿网重重。重重不可说其分量。而毗卢遮那亦重重无尽常演说法。疏。十余佛同下。文自释

疏。然上十类一一各遍法界等者。第三总结也。由上十门。初二。有遍法界之言。从三至十。皆略此言故。今总结皆遍

疏。然说十住下。第四释妨。谓有问言。若忉利天说十住法。既遍虚空周于毛道。未知夜摩天等亦说十住不。设尔何失。二俱有过。若彼不说。则说处不遍。若彼亦说处。则杂乱。何以经中唯云忉利说十住法。夜摩天处说十行等耶。故为此通。于中三。初总答前问。次重通再难。后一一品下。以一例余。初中即隐显门。谓一门显时。余门则隐。如以十住为门。唯言十住遍。十行为门。唯明十行遍等。故云为门不同。亦无杂乱

疏。若约十住至彼此互有同遍法界者。即第二重通再难。谓更有问云。若约为门不同。为互相见不互相见。若相见者。还成杂乱。若不相见。何以知遍。今答此问。明有见不见。谓若约相即。即不相见。若约相入。则许互见。言若约十住与十行等。全位相摄。则彼此互无。各遍法界者。是相即门。谓若以十住摄于余位。则唯有十住。余位如虚空。以余位废已同十住故。余位亦尔。十住遍时。非十行等遍。是故互无各遍法界。言若约诸位相资。则彼此互有同遍法界。者。是相入门。若以约力用更资不坏自他。如两镜相照故。东镜动时西镜中之影亦动故。得同遍法界。而有主伴故非杂乱。如十住为门。带十行等。同遍法界时。但名十住遍。不名十行遍。若十行等为门亦然。则有力能摄者为主。无力被摄者为伴。前相即门中。正十住遍时不妨余遍。但隐显不同耳。十住遍时十行等即隐。十行遍时余隐亦然。依相即门亦名纯门。遍周法界尘毛。唯有十住等故。依相入门亦名杂门。以诸位一时相资遍故。则十住中有十行等。余义至义理分齐中广辩

疏。十余佛同者下。第五随难。重释中二。先正显同遍。后然主主下。释通妨难。前中以竖穷三际横遍十方。佛佛德用说法皆同故。故经云。三世诸佛已说。今说。当说。疏中引经我等诸佛亦如是说。即横论也。即证法佛言也。十地经云。我不见有诸佛世界彼诸如来不说此法。即金刚藏证法菩萨言也

疏。然主主下。二通妨中。谓有问言。余佛说处与遮那佛。为相见不相见。设尔何失。二俱有过。谓若相见。即乖相遍。若不相见。即乖主伴。故为此通。谓见与不见。二义俱成。二互相见。主伴义成。见与不见。遍义皆成。但各遍同遍。以为异耳。文具四句。言主主不相见者。遮那为主时。十方余佛但得为伴。不得为主。若余佛为主。遮那亦即为伴。不得为主。故云主主不相见。二伴伴不相见者。如诸佛为遮那伴时。遮那更不得为伴。故云伴伴不相见。非谓彼诸伴佛自不相见。疏。主伴伴主则互相见者。即第三第四句也。三主伴得相见。如遮那为主见余伴佛。伴佛亦见遮那故。四伴主相见者。如遮那为伴余佛为主。则得相见。然三四二句。义则不异。但约一人。互通主伴。故成四耳。言无杂乱者。结为门别故。言亦无障碍者。约常融摄故

疏。又上十处下第六。总融十义。于中分三。初正显十义融通。次而随下。对时显处。后此犹约下。三进显甚深。谓上十重。但是器世间耳。未说佛毛孔及众生毛孔中事。一一皆悉重重无尽。言普贤众生一一皆尔者。普贤若望如来。亦名众生世间。若望众生。亦名智正觉世间。又举普贤。则摄一切菩萨也

第三依主。疏文分五。一总彰大意。二今说此经下。假难征起。三故说此经下。总相会通。四今先明下。开章别释。五是知或说下。会通余教。今初。谓如来唯一无障碍身。随机教异耳

疏。夫真身寥廓与法界合其体者。若以法界为身。法界即身。不言合体。今以无障碍智与如冥一。故言合体。故金光明云。唯如如及如如智。独存则以如智共为真身。既智合如。则令色相功德无不合如。疏。包罗无外与万化齐其用者。体既合如。如无不在。如无不包故。令佛身亦无不包矣。万化云云。即是法身大用。而言齐者。以如来得一切法量等身故。假言齐耳。上二义明佛身体用同法界体用。故浑万化。即真会精粗一致。圆融无碍也。故次疏云。穷源莫二。谓若据本以适末。则一源有万派。若寻流以讨源。则千途无异辙。若三江之浩淼。并源出于岷山也。执迹多端者。即据本适末。不知多端是应迹耳。疏。一身多身经论异说者。出执迹之由也。由经论中一多异说故。经随物异。论逐经通。人随教执。若识其源。一多无碍。故光明觉品云。一身为无量。无量复为一。了知诸世间。现形遍一切。此身无所从。亦无所积聚。众生分别故。见佛种种身。即其义也。言异说者。或说唯一。即如此经云。十方诸如来。同共一法身。一心一智慧。力无畏亦然等。或说二身。佛地论说。一生身二法身。谓法身实报。皆名法身。实功德法故。他报化身。俱名生身。为物生故。智度论中意亦同此。又般若论说有二佛。一真佛。二非真佛。初是法身。后即报化。下经之中。亦多说二。文云。诸佛真身本无二。应物分形满世间。又云。佛以法为身。清净如虚空。所现众色形。令入此法中等。或分为三。即法报化。亦言法报应。应即化也。或说四种。楞伽经说。一应化佛。二功德佛。三智慧佛。四如如佛。初是化身。中二是报身。后一是法身。金光明经又说四种。一化身非应佛。谓为物所现龙鬼等形。不为佛身。名化非应。二应身非化。谓地前菩萨。所见佛身。依定而现。非五趣摄。名应非化。即四善根所见。一大千界一应身也。三亦应亦化。谓诸声闻所见佛身。见相修成。故名为应。人见同类。故名为化。四非应非化。谓佛真身。前三并是化身。后一法报二身。佛地论中亦说有四。一受用非变化。谓自受用身。二变化身非受用。谓变化身。化地前类。三亦受用亦变化。谓他受用身。化十地菩萨。四非受用非变化。所谓法身。是则前金光明。约三身上论四。合法报而开化身。今约三身谓四。三身俱开。复重开于报故。虽有四义理不乖三。或说五身。如大通经说。然睿公维摩疏释云。所谓一法性生身。二亦言功德法身。三变化法身。四虚空法身。五实相法身。详而辩之。即一法身也。何者言其生。则本之法性。故曰法性生身。二推其因。则是功德所成故。是功德法身。三就其应。则无感不形。是则变化法身。四称其大。则弥纶虚空。所谓虚空法身。五语其妙。则无相无为。故曰实相法身。五所以能妙极无相。四大包虚空。三遍应万化。无感不形者。就机而明。何者三有之形。随业而化。故有精粗大小万殊之差。二如来法身。是妙功德果。功德无边。果亦无边。功德无相。果亦无相。功德方便。果亦方便。无边故量齐虚空。无相故妙同实相。方便故无感不形。是为如来真妙法身。阴界不摄非有非无。一以有此身。为万化之本。故得于中无感不应。如冥室曦光随孔而照。光虽万殊之本之者一。所谓真法身也。若直指功德实相名为法身。此乃以法深理假名为身。非色像之谓也。上皆五身义。若以三身摄之。初二是报。次一是化。后二是法。又有义说有于九身。以三身各三故。法身三者。一真法界以为法身。本有三大故。故为三耳。修成为报身。同体大悲。名为化身。报身三者。真智所证故名法身。智德圆满即是报身。为十地所现故曰化身。应身三者。化必有体即是法身。故经云。吾今此身即是常身法身。三十二相八十种好等。修因所成即是报身。感而必形即是化身。或说有十。自有二义。一约十地所得十身。如胜天王经说。一平等身。二清净身。三无尽身。四善修身。五法性身。六离寻伺身。七不思议身。八寂静身。九虚空身。十妙智身。二约佛身之上。自具十身。即如下明。故疏云。一身多身经论异说。略示异义无厌繁文

疏。今说此经佛。为真为应为一为多。下第二假问征起。于中二。先问起后。若言真者下。征难。今初。但有两对。已含前后诸义。征难中先难真应。后难一多。初中有三。一约名。二约处。三约机。言为一为多者。二难一多。言多处别现者。如光明觉品云。如于此处见佛世尊。坐莲华藏师子之座。十佛刹微尘数菩萨。所共围绕。彼一一世界中。皆有百亿阎浮提。百亿如来百亿佛刹。亦如是坐等文是也。又云。如于此处见佛坐。一切尘中亦如是。佛身无去亦无来。所有国土皆明现等。疏。何以复言。而不分身者。出现品云。譬如梵王住自宫普现三千诸梵处。一切人天咸得见。实不分身向于彼。诸佛现身亦如是。一切十方无不遍。其身无数不可称。亦不分身不分别

疏。故说此经佛并非前说下。三总相会通也。于中二。上即遮非。后即是法界无尽身云下。显正。于中三。初总相显相。次对难会融。后结成难思

疏。真应相融一多无碍下。第二对难会融。于中分二先二句双标。后即卢遮那是释迦故下。双释。亦二。先释真应。后释一多。前中二。先此两句。唯释真应。通前约名为难。谓余教遮那是真。释迦是应。故经云。清净法身毗卢遮那佛。千百亿化身释迦牟尼佛。今既相即。明是真应相融故。名号品云。或云毗卢遮那。或名释迦牟尼。但名异耳。又华藏品中明。第十三重有世界。名娑婆。其佛即是毗卢遮那。故知融也。疏。常在此处亦兼通前。约处为难。谓常在此处。即他处故。远在他方。恒住此故者。二有二对。正明真应。兼显一多。而含有身土对。前约处为难。初作真应释者。以约应故在此。约真故周遍法界。故经云。佛身充满于法界。普现一切众生前。随缘赴感靡不周。而恒处此菩提座。初句即真。余三皆应。第四句常在此处。余三句即他处也。言兼显一多者。在此处即一。在他处即多。如不起一处遍一切处。处此菩提座一也。普现众生前多也。言含土者。此处即娑婆。他处即兼华藏

疏。身不分异亦非一故下。二释一多也。身不分异故非多。多不碍一也。亦非一故虽一。一不碍多也。上唯释一多。疏。同时异处一身圆满。皆全现故者。正释一多兼该真应。言一多者。以一身全现故。非一非多也。一身现多故。一不碍多。多现而常一故。多不碍一。如上已引。一身为无量。无量复为一。了知诸世间。现形遍一切等。又云。唯一坚密身。一切尘中现等。出现品云。如来于一成正觉身。普现一切众生数等身。成正觉等。而言同时异处者。若异时异处。容许一身次第遍游。今明同时异处决是多身。而是一身全现故非多矣。其犹一月一刹那中百川齐现。皆即一即多。又普现故非一。一月故非多故。智幢菩萨偈云。譬如净满月。普现一切水。影像虽无量。本月未曾二是也。故下光明觉品疏中。明有同时同处见。异时异处见。同时异处见。异时同处见。同异时处一人顿见等。言兼真应者。一身圆满即是真身。皆全现故。即是应身。又言全现者。非分现也。言分现者。如一身中现多头。头中有佛。腰现仙人等。即分现也。今言全现者。即此佛身。即一切身。即诸类身。全菩萨身。是佛身等

疏。一切菩萨不能思故者。结成难思也。兼对前约人为难。菩萨尚不能思。况人天能见耶。以离心缘相故。二十一种功德中。有无能测身。第八十经云。如来清净妙法身。一切三界无伦匹。以出世间言语道。其性非有非无故。虽无所依无不住。虽无不至而不去。如空中画梦所见。当于佛体如是观。由非真非应非一非多故。不可作真应一多等思也。故光明觉品云。佛身无生超戏论。非是蕴聚差别法。故难思也。又云无染无所著。无相无依止。体性不可量。见者咸称叹。其文非一。既云菩萨不能思。明唯佛境

疏。今先明十身。后彰无碍。下第四开章解释也。于中三。初上二句标。次言十下释。后以此身云下。总结周遍

疏。广显其相如第八地及离世间品辩者。如第八地中明。前十身各有十相。第二十身。即是前十之中第七。如来身之十相。又明前十身相作。谓随众生心之所乐。能以众生身。作自身。国土身。业报身。声闻身。缘觉身。菩萨身。如来身。智身。法身。虚空身。如上教迹中引。及一一释相。并在下文。言离世间品者。彼五十三中有十佛。即前第二十身。而名小异。彼亦会释。言十佛者。所谓成正觉佛。愿佛。业报佛。住持佛。涅槃佛。法界佛。心佛。三昧佛。本性佛。随乐物。第五十八中。又明十种见佛。即见前十佛文云。所谓安住世间成正觉佛。无著见愿佛。出生见业报佛。深信见住持佛。随顺见涅槃佛。深入见法界佛。普至见心佛。安住见三昧佛。无量无依见本性佛。明了见随乐佛。普受见。然无著等。复有十义。并至下当明

疏。一切尘中亦如是等。其文非一者。等取下半云佛身无去亦无来。所有国土皆明现。此即第五经普贤菩萨偈也。言其文非一者。遍于一经。如第六经云。毗卢遮那佛。愿力周法界。一切国土中。恒转无上轮。又云。一一微尘中。能证一切法。如是无所碍。周行十方国。又云。佛演一妙音。周闻十方国。众音悉具足。法雨皆充遍等。如是等用。无量无边。谓或现摄生。或现威仪。或现八相。或现三乘形。或现五趣形。或现六尘境。差别名号。业用多端。不可称说。法界微细。无不皆遍。故云周遍也

疏。二相遍无碍。谓上差别用中。各摄一切业用者。如上所明。摄生威仪行住坐卧。如不思议品云。如来一坐食已。结跏不动。遍于十方经一切劫。今明即此坐中便具行住及卧也。又如前现八相相遍者。岚毗尼林神。说如来受生云。善男子。当知我见佛于此四天下。阎浮提内岚。毗尼林园中。示现初生种种神变时。亦见如来于三千大千世界百亿四天下。阎浮提内。岚毗尼园中。示现初生种种神变。亦见三千大千世界。一一尘中无量佛刹。亦见百佛世界。千佛世界。乃至十方一切世界。一一尘中无量佛刹。如是一切诸佛刹中。皆有如来。示现受生种种神变。如是念念常无间断者。但是一重之遍。今此明一一相中皆具八相。如三十一经云。菩萨在母胎中。自在示现一切法界道场众会甚微细。菩萨在母胎中。示现一切佛神力甚微细。又离世间品云。佛子。菩萨摩诃萨。有十种甚微细趣。何等为十。所谓在母胎中。示现初发菩提心。乃至灌顶地。二在母胎中。示现住兜率天。三在母胎中示现初生。四在母胎中示现童子地。五在母胎中示现处王宫。六在母胎中示现出家。七在母胎中示现苦行。往诣道场成等正觉。八在母胎中示现转法轮。九在母胎中示现般涅槃。十在母胎中示现大微细。谓一切菩萨行。一切如来自在神力。无量差别门。佛子。是为菩萨摩诃萨。在母胎中十种微细趣。释曰。母胎一相之中。八相皆具。万德斯圆。故云相遍也。又上示三乘。今一乘具三。上示五道。今一道具五。例可知也

疏。三寂用无碍无私成故者。若取义显。应作思惟之思。今用无私之私。则表不偏为故。亦以无心于物故。谓常在三昧为寂。无方利物为用。即定即用故云无碍。如摩尼天鼓无心雨宝及出声。故不思议品云。一切诸佛于一念中。悉能示现一切三世诸佛。教化一切众生。而不舍离诸佛寂灭三昧。是为诸佛不可思议境界。又第一经云。身遍十方而无来往。第三经云。如来境界不可量。寂而能演遍十方。第四经云。广大寂静三摩地。不生不灭无来去。严净国土示众生。此树华神之解脱等

疏。四依起无碍无心顿现海印力故者。谓虽寂用无心不妨皆依海印之力。又正依定即起用故。贤首品云。或现童男童女形。天龙及以阿修罗。乃至摩睺罗伽等。随其所乐。悉令见众生形相各不同。行业音声亦无量。如是一切皆能现。海印三昧威神力等

疏。五真应无碍应即同法一味平等故者。释迦遮那无二佛故。吾今此身即法身故。第五经。云真如平等无相身。离垢光明净法身。智慧寂静身无量。普应十方而演法。又云。如来真身本无二。应物分形满世间。光明觉品云。如来非以相为体。但是无相寂灭法。身相威仪悉具足。世间随乐皆得见等

疏。六分圆无碍者。支分不碍全身。全身不碍支分。谓遮那一一身分。手足眼耳乃至一毛。皆有舍那全身。法界品云。如来一一毛孔中。一切刹尘诸佛坐。妙严品云。佛身一切相。悉现无量佛。普入十方界一一微尘中。以一毛之性不异全身故。故出现品云。佛子。菩萨摩诃萨。应知如来一毛孔中。有一切众生数等诸佛身。何以故。如来成正觉身。究竟无生灭故。如一毛孔遍法界。一切毛孔悉亦如是等。又如来眼等。皆遍法界。若分与圆异。分既有多。应有多个法界。合成一身。以分圆无碍故。一遍一切遍也。又法界品中。普贤毛孔支节亦然

疏。七因果无碍不碍现因故者。谓一一毛孔。现自遮那往昔本生行菩萨行。所受之身及所成事。亦现十方一切菩萨身云。及下经中眉间出胜音等尘数菩萨。又第一经云三世诸佛所有神变。于光明中靡不咸睹。第五经云。佛以本愿现神通。一切十方无不照。如佛往昔修治行。光明网中皆演说。第六经云。一一佛身中。亿劫不思议。修习波罗蜜。及严净国土。如是等文。其处甚多

疏。八依正无碍者。如上说因中释。又此身云即作一切器世间故。故经云。或作日月游虚空。或作河池井泉水。又或时作地水。或复作风火。相入相即六句。并如前释

疏。九潜入无碍等者。文中二。先标章。后入众生界下。释释。释有二义。一明佛入众生。二又亦摄下。明众生入佛。皆众生不知。故云潜入。今初有三。初一句正释。次如来藏下引喻。后故出现下。引证。喻中。众生真心名如来藏。随无明等缘作诸众生流转三界。而此真心自性不失。故胜鬘经云。不染而染难可了知。染而不染亦难可了知。若转以喻显者。如大海水因风成波。而不失湿性。佛亦如是。随众生感现万类殊形。而如来身不失自性。此以众生自法身作自众生。喻如来真身入一切众生

疏。故出现品下。引证。引其二文。初佛智潜入者。此以智身通证佛身。佛身随化文处盖多。今取潜入之义。故引出现耳。彼经云。譬如大海其水潜流四天下地及八十亿诸小洲中。有穿凿者无不得水。而彼大海不作分别我出于水。合佛智海水亦复如是。流入一切众生心中。若诸众生观察境界修习法门。则得智慧清净明了。而如来智平等无二无有分别。但随众生心行异故。所得智慧各各不同。今所引者。正取潜入之义耳。疏。又云众生心中等者。亦是彼品前文已引

疏。又亦摄下。上辩潜入。佛入生身生不知故。今明摄他。正摄他时不碍入他。故称无碍

疏。十圆通无碍等者。文中二。先别明。后总结。今初。以遮那佛融大法界。而为其身故。无不即。不待现身方名即事等。以法界之体无不包故。无不即故。令身亦然。若指相别说者。佛身色相即事也。全同法身即理也。即一即多乃有二义。一法身为一。应化为多。真应既融。故相即也。二此一处应即多处。应亦以体融。又即此一应为多应故。故光明觉品云。一身为无量。无量复为一。了知诸世间。现形遍一切。此身无所从。亦无所积聚。众生分别故。见佛种种身等。即依即正者。亦有二义。一以法性身土融无二故。二者有国土身故。即依。有智正觉等身故。即正。即人者。证法成人故。即法者。佛以法为身故。即此即彼者。不离菩提树而遍一切处故。既亦不离一切处而坐菩提树。可言即彼即此也。二义小异。彼此相即是同。又即此佛是他佛故。他亦是此。即情者。异木石故。即非情者。同色性作河池等故。非情即佛体故。蕴界入等若虚空故。即深即广者。无形绝相故。深量无不包故广。又量同空故广。离空相故深。故问明品云。如来深境界。其量等虚空。一切众生入。而实无所入。出现品云。譬如虚空遍至一切色非色处。一切如来亦复如是等广也。非至非不至深也。又如虚空宽广非色。而能显现一切诸色等。皆深广也。又妙严品云佛身普遍诸大会。充满法界无穷尽广也。寂灭无性不可取深也。为救世间而出现。具深广也。即因即果者。因无异果之因。果无异因之果故。十身之中。有如来身有菩萨身故。即三身即十身者。若以佛身上十身者。菩提身。愿身。化身。力持身。意生身。即三身中化身摄也。相好身。威势身。福德身。义通报化。法身即法身。智身义通三身。局唯报身故。即三是十。即十是三。若约融三世间十身。即三身者。如来身通三身。智身亦通三身。法身虚空身即法身。余六通法化。法身体故。随物应国土等故

疏。同一无碍法界身云。二总结成也。即以无障碍法界为体。含四法界何所不具。故无不即耳。则未有一法非佛身也

疏。以此身云遍前时处常说华严者。第三总结周遍也。上来第四开章释竟

疏。是知或说报身在色究竟约摄报说等者。第五会释余教也。文中三。初别会。二总非。三拣滥。今初。略会五文。一会起信唯识等文。起信论云。又是菩萨功德成满。于色究竟处。示一切世间最高大身。谓以一念相应慧。无明顿尽。名一切种智。自然而有不思议业。能现十方利益众生。藏和尚疏。引地论释云。一者现报利益。受佛位也。二者后报利益。摩醯首罗智处生故。自问云。何故他受用报身在此天耶。一义云。以寄报十王显别十地。然第十地寄当此天王。即于彼身示成菩提。故在彼天。余义如别说。天宫钞释余义云。二即四智圆满。唯识即实报成佛。此示高大身。即他受用。唯识为引摄二乘。令知菩提树下非是报身。且指彼为实报也

疏。今亦据二文之意及十地经文通之。故云约摄报果说

疏。或说报身在余净土约引摄者。即第二通涅槃央掘等经也。涅槃二十四。高贵德王菩萨品。明十功德中。第四功德。高贵德王难云。若有菩萨修大涅槃。悉作如是十事功德。如来何故唯修九事不修净土。佛答具修。末云。善男子。西方去此娑婆世界。度四十二恒河沙等诸佛国土。彼有世界。名曰无胜。彼土何故名曰无胜。其土所有庄严之事。悉皆平等无有差别。犹如西方安乐世界。亦如东方满月世界。我于彼土出现于世。为化众生故。于此界阎浮提中现转法轮。非但我身独于此中现转法轮。一切诸佛亦于此中而转法轮。以是义故。诸佛世尊。非不修行如是十事。善男子。慈氏菩萨以誓愿故。当来之世。令此世界清净庄严。以是义故。一切诸佛。所有世界。无不严净。释曰。既言为化众生居此阎浮提。无胜国土。是我严净。明指报身在余净土。言央掘经者。经文稍广。今略义引。谓佛答央掘云。我住无生际而汝不觉知等。央掘难云。若住无生际。何以生于此土。佛答云。东方有佛。汝往问之。当为汝说。央掘与文殊同往问佛。彼佛答言。彼释迦者即是我身。大意明余净土中佛。是证无生际者。今生娑婆是化现耳。故云在余净土。而疏言约引摄说者。不言严净华藏及周法界帝网之刹。不言此身周满法界。而言在于东方等。明是随宜引摄娑婆杂恶众生。令修净土之行耳

疏。或说舍那坐千叶华摄二地说者。第三通梵网等经。彼云。我今卢舍那。方坐莲华台。周匝千华上。复现千释迦。一华百亿国。一国一释迦等者。即以莲华台上。为本源卢舍那。千叶释迦复是大化。一释迦更有百亿。方为小化者。亦不言其身充满一切世间。普贤莲华。有不可说叶。量周法界。十地菩萨之华。尚量等百万三千大千世界。况如来耶。明知亦是他受用身。摄二地耳。以二地戒度圆满故为说戒以初地化百佛刹。则有百叶之华。二地化千佛刹故。华有千叶。若至三地应见万叶。四地亿叶。五地千亿。六地百千亿。七地万亿那由他。八地百万三千大千世界微尘数。九地百千万亿阿僧祇国土微尘数。十地不可说百千亿那由他佛刹微尘数。据上十地。百万三千尚犹略说。故知非显真极之身

疏。或说登地方见约胜机说者。即四通他受用身。登地之机为胜机耳。前别约二地。今通约十地也

疏。或分三异约体相用说者。第五通会三身也。若直说者。法身约体。报身约相。化身约用。然起信立义分云。所言义者则有三种。一者体大。谓一切法真如平等不增减故。二者相大。谓如来藏具足无量性功德故。三者用大。能生一切世间出世间善因果故。藏和尚释相大云。二种藏中。唯取不空如来藏也。用大者。谓随胜业约自体大用。报化二身约粗细之用。令诸众生始成世善。终成出世善也。释曰。依此解者。体相二大俱名法身。以性功德本自有故。用即报化。亦是约三大说。若各配者。一以不空之藏修成方显。为真报故用大中报。他受用故。显胜名报。若应约登地之机。亦是化故

疏。俱非此经真实之义。第二总非也。以十身圆融为实义故

疏。设分三十第三。拣滥也。云何拣耶。粗相约教而说。三身为权。十身为实。若不知三身即是十身。为不融前。权外立实故失经宗

第四依三昧。疏文分二。先立理正明。后对文略释。今初。先别显。后结成。初中下十住

疏。明入定意总有六义。一此三昧是法体故。即十地论意。二非证不说故。若不证而说。则是生灭心行说实相法。三总显法体非思量境故。明要忘心方契上义。前约显实。此约遮过。然上三义后后释于前前。大同小异。四观机审法故。须药病相当。方可说故。五为受佛加故。上四内因。此一外缘。因缘和合方能说故。六成轨仪故。即一向为生。上五自利。此一利他。今疏含具。初之二句。总相立理。非唯入定为物。出定亦然。宜见出者则出。宜见入者便入。故云唯物。圣无定乱故。云圣岂然乎。故净名云。不定不乱

疏。示轨后徒下。别显意也。此即第六意。疏。明将有说必须净鉴前理者。含前四意。静者离思量也。鉴者证法体也。静鉴前理者。观机审法也。前字兼机故。佛加可知。从定起而发言下。亦明非证不说。亦总显前六之胜用也

疏。故于诸会下。总结成也。九会说经。八会入三昧。第二不入故名为多。第一会普贤菩萨。入毗卢遮那如来藏身三昧。第三会法慧菩萨。入菩萨无量方便三昧。第四会功德林菩萨。入菩萨善思惟三昧。第五会金刚幢菩萨。入智光三昧。第六会金刚藏菩萨。入菩萨大智慧光明三昧。第七会如来自住刹那际三昧。第八会普贤菩萨。入佛华严三昧。第九会如来。自入师子频申三昧。第二不入者。未入位故。有云盖文漏耳。说世间法。尚须入定。况十信耶。若约所表前义无失

疏。有不入下。第二对文略释。不入之义。已如向说。其所入下。显胜超劣。寄位优劣所入不同。人法俱胜故。一一三昧皆尽法源。非如入初禅时。不入二三等故。以尽法源故。并感诸佛三业加等

大方广佛华严经随疏演义钞卷第四大方广佛华严经随疏演义钞卷第五

        唐清凉山大华严寺沙门澄观述

第五依现相。疏文分四。一总明大意。二显相不同。三别明放光。四料拣同异。今初。应有四句。一者随相。二者无相。三者无相不碍相。四者相即无相。法性寂寥。即第二句。无相之相。即三四句。下别明中有初一句。故应莫执无相。以斥诸相也。故下经云。如来非以相为体。但是无相寂灭法。身相威仪悉具足。世间随乐皆得见。十地经云。佛住甚深真法性。寂灭无相同虚空。而于第一实义中。示现种种所行事。所作利益众生事。皆依法性而得有。相与无相。无差别。入于究竟皆无相等。即其义也

疏。起教多端下。第二显相不同也。由所起教异故。能起相殊。如说法华。以放光动地雨华为相。将说涅槃。以声光遍照普告为相。如说般若。以散金华为相。今经具有诸相。华藏世界六种震动。雨于华云香云盖云鬘云璎珞云等。皆其相也。又现相品。现五种相等

疏。故诸会下。第三别明放光。于中文三。初总明。次然有二下。别显后随处放异总有十光各有所表至文当知者。重释随相。三中言十光者。第一会放于二光。谓现相品初。于如来众齿之间放种种光。二亦于此品放眉间光。第二会放足轮光。第三会足指放光。第四会足上放光。第五会膝轮放光。第六会亦眉间放光。第七会初不放光。而出现品放二种光。谓放眉间光加于妙德。放于口光加于普贤。第八会总。不放光。第九会亦放眉间白毫光明。初会七会各二光。八会不放故。故九会共有十也。言各有所表者。初面门众齿放者。表教道遐舒。金口所流。从佛口生。真佛子故。以是义故。于总处放也。又表咀嚼法味滋法身故等。眉间放者。通表一乘中正之道。足轮最下表信四义。一自下而上。信最初故。二最卑微故。三为行本故。四信该果海已满足故。第三会足指安住故。四足上依行故。五膝轮屈伸可回向故。六十地眉间。表所证十如具足中道故。七出现眉间。表出现中道。不住生死涅槃之二边故。又口放光。表佛口生真长子故。第八会不放。行依解发依解光故。或略无故。第九眉间。表证穷法界之中道故。广如下疏。故云至文当知

疏。其动地等下。第四料拣同异。庆前起后。二义不同。故取起后。不取庆前言如十地等者。九地初云。说此菩萨八地时。如来现大神通力。振动十方诸国土无量无数难思议等。既牒八地。明是庆前赞竟。便请第九地故。义兼起后

第六依说人。疏文分二。先总显来意。后开章别释。今初。先立理。然法有四种。教理行果。理法湛然无兴废。龙宫教海亦多长在。修行克果。则在于人。故般若论云。法欲灭者。修行灭故。然弘有二义。一者自行。二者转化。今取转化。下文云下。引证也。即第十六卷胜慧菩萨偈。具云。譬如暗中宝无灯不可见。佛法无人说。虽慧莫能了。故说者如灯。能照众生心宝故

疏。今此能说通三世间下。开章别释。于中三。初总明说人。次指文显说。后说仪不同。今初。总有四种。一明有三。二开三为五。三开五为十。四开十为无量

疏。开即为五者。开三世间中智正觉一。为三乘故。众生世间及器世间。仍旧不开。故为五也

疏。更开为十等者。以三世为三。微尘说为四。毛孔说为五。疏。器及有情各有分圆下。出为十所以。直语世界说。是器家之圆。若言微尘说。即器家之分。但言有情说。是有情家圆。若云毛孔说。即有情家分。言有情者。即含前佛菩萨声闻众生也。疏。此上诸说通三世者。上之七说。并通三世也。谓过去佛说。现在佛说。未来佛说等。疏。故普贤下。引证。言如是说等者。等取下句种种悉了知也。亦等余文

疏。广则无量法界品中类非一故者。法界品中。略明五类法界。皆有说义。五类之内一一复多。故云无量。言五类者一法法界。二人法界。三俱融。四俱泯。五无障碍。初中有十门。一事法界。二理法界。三境。四行。五体。六用。七顺。八逆。九教。十义。二人法界亦有十门。一人二天三男四女五在家六出家七外道八诸神九菩萨十佛。又事有多事。天有多天。神有多神。百一十城。三千知识等。故云类非一也

疏。如僧祇下。指文显说。言菩提树等。即器世界说。至文当知者。经云。其菩提树恒出妙音。说种种法无有尽极。而言等者。等取余文师子座说等。又等取尘毛之文。如善慧地云。或时心欲放大光明演说法门。或时心欲于其身上一一毛孔皆演法音。或时心欲乃至三千大千世界。所有一切形无形物。皆悉演出妙法言音。乃至云。或时心欲令不可说无量世界。地水火风四大聚中。所有微尘一一尘中。皆悉演出不可说法门。如是所念一切随心无不得者。上之所引。即器界尘毛等说也

疏。其能说下。三明说仪不同。指下文耳

第七依听人。疏文有二。先明大意。后即下诸众下。略指类别。疏。子期云丧者。列子云。伯牙善鼓琴。钟子期善听。伯牙鼓琴志在高山。子期曰。善哉。峨峨兮若泰山。志想流水。钟子期云。善哉。洋洋兮若江汉。伯牙所念钟子期必得之。伯牙游于泰山。又遇天阴卒逢暴雨止于岩下。心悲乃援琴而鼓之。初为霖雨之操。更造崩山之音。音曲每奏。钟子期辄穷其趣。伯牙乃舍琴而叹曰。善哉。子之善听。夫志想像犹吾心也。吾于何处以逃声哉。庄子加云。钟子期死。伯牙终身不复鼓琴。文选云。士为知己者用。女为悦己者容。明人之道术在遇知音。知音即听者

第八依德。本文三。初明大意。次略。有二类下别释。后若感者下拣滥。初中疏。川有珠下喻。内无得下合。后然唯约说者。拣定

第九依请人者。文二。先举无显有。后然有二下。别示请仪

第十依能加者。亦二。先总明大意。后然若佛下。别释所以。今初先立理。后指陈。前中借尚书意故。彼第四云。民罔常怀。怀之有仁。鬼神无常享。享于克诚。心冥至极下。指陈也。以入定契理故佛加耳。故下文中。以三昧力故。感十方诸佛现前等。别释中四。一总彰有无。二所以加者下。出加所以。三若尔僧祇随好下。释通妨难。四加有下。就类彰别。二中先征后释。释有三意。疏。欲显诸佛同加即同说故者。即第一意。若佛自说即不可言加。即但名自说耳。今由同加皆与智劝说。则显同说也。疏。一说一切说故者。第二意也。上显通方之法。此显圆融之教。然一经中。总具四句。今但举一以顺同加义。故言四句者。一者一说如僧祇等。二者一说一切说。如向所明。三者一切说是一说。如一切处文殊遍周法界同声说偈。显法无异故。四者一切说是一切说。如十方来证皆自叙云。我等诸佛所亦如是说。余三不顺同加故。疏不明耳。疏。亦显果海下。第三意也。佛表果海。菩萨表因故。故十地经云。此处难宣示。我今说少分。论经云一分。论释云果分不可说。但说因分。因分于果分为一分耳

疏。若尔僧祇下。三释通妨难。于中三。初设难。二释难。三遮难。今初也

疏。表微细下。二释难也。略举二意对前三意。言微细难知者。对前同说及一切说。前菩萨说。以受加故表佛同说。今以僧祇数量重重微细。唯佛能知。随好光明功德。一好一光能破地狱。三重顿圆故亦难知。唯佛能了。故佛自说。疏。超出因果故者。对前果海不可说也。前难中意云。若以菩萨表因。今佛自说应可。表果可说故。今答云。对果说因言因可说。因无果外之因。没同果海故。因亦叵说。如鸟迹同空迹亦叵说。因既非因。果亦非果。欲拂前因果之相。故佛自说

疏。然施设不同不应一准者。三遮难也。恐有难言。若今佛说。即表微细。余应是粗。此言超出前应系着故。此遮云。圣教施设。千差万别。各取一表不应克定。受加表于同说。亦非粗非着。佛说表细显超。亦不碍于同说。约表小异大旨全同。何不亡言触途生滞。故云不应一准

疏。加有二种下。第四就类彰别。于中二。先显别。后指文。前中显有三业者。口业劝说以益辩。意业冥加以益智。身业摩顶以增威。然意与智虽则是冥。以与身语同时。此二显彰以少从多故。三皆称显。冥唯与智故有不同

疏。普光法界下。后指文也。普光摄三会。谓二七八也。法界即是第九会故。此四会并唯有冥。由二七两会不入定故。故无显加。而文殊师利普贤菩萨。皆言承佛神力故是冥加。第八会普贤虽入三昧无有加分。但有作用发起故无显加。亦云承佛神力故有冥加。法界品。如来自入三昧不可有加。下普贤文殊有说无定故阙显加。皆承佛力故。能说能证故有冥加。疏。余皆具二者。即余五会。显必有冥者。释具所以。冥即未必有显。显即必有于冥。以如来有力有慈常冥加故。未定缘阙。不容有显故唯有冥。显加之时冥常不舍。又有意加故言必有。疏。余至下明者。谓冥显加相有多义门。随文具显也

第二藏教所摄。疏文分二。先总。后别。总中亦二。先总科后。今初下。牒释总名。引世亲摄论者。然摄大乘论。本论即无著菩萨所造。释有多家。此方有二本。即世亲无性。二菩萨也。大唐三藏俱译二本。各有十卷。梁朝真谛译。世亲释论。有十五卷。今称梁摄论。是释义大同小异。疏家随便引之。恐滥三本故。各以异名拣之。然依古德多引梁论。若今自取多引无性世亲。疏。谓摄一切所应知义者。即彼论自释摄义。所应知者。然论无别释。下广显论所明。即十胜相。谓一应知依止胜相。二应知相胜相。三应知入胜相等。十相皆言应知。即理事等法皆应知也

疏。摄即包含者。疏家转将摄义复释于舍。以前标云以舍摄故。故牒释也。疏言三藏下。第二别释分二。先三藏。后二藏。前中三。初总列。次初中下。别释。后然此三藏下。总显所诠。二中三藏即为三别。皆先标。后释。疏。今初亦名下释也。于中四。一会梵音。二叙古释。三叙古破。四会顺违。今初。言梵音素怛缆者。唐三藏译云。是中天之语。什公多译为修多罗。亦云修妒路。多通诸天什公是龟兹人近于东天。实叉三藏于阗国人多近东北。然什公亦游五天。随时所受小有轻重。语其大旨理则无乖。然前后三藏。多云修多罗也。梵音楚夏者。秦洛谓之中华。亦名华夏。亦云中夏。淮南楚地。非是中方。楚洛言音呼召轻重。今西域梵语有似于斯。中天如中夏。余四如楚蜀。西来三藏。或有南天。或有北天。或有中天。东西各异

疏。古译为契经下。第二叙古释也。于中五。一标名。二智论下。引证。三契谓契理下。会义。四即契理合机之经下。会六释以契对经。即名依主。以契经对藏。便名持业。五复云下。会傍正。疏有云。按五印度至斥于古德。经非敌对者。第三叙古破。此古即是静法寺苑公刊定记中义也。但言有云。即是刊定记主。若云古德。多是藏和尚。亦有此前诸德。此中总举先古诸德。又此中疏撮略刊定之意耳。刊定记叙古义竟。便云。今详诸论及以梵本。良恐不尔。所以者何。此中通辩。有三失故。一敌对翻名失。二以义为名失。三总别不分失。今疏所明即第一失。谓修多罗一名既含四实。线既敌对。经何得非。经亦是敌对。言非敌对。故云敌对翻名失。故今疏云斥于古德经非敌对。二以义为名失者。意云。经字是名。契字是义。以经有契理合机之义故。借契义。以助经名。而呼契经两字全作名者。即是以义为名失也。若是全名者。应云欲底修多罗。欲底之言。有其三义。一者契义。二顺古所行。三依正道理。今取契义。既无欲底之言。明知名无契字也。又举例云。如质多名心。集起为义。讵翻集起亦作名耶。意云。集起既非心名。契理岂是经目也。三总别不分失者。彼云。但藏部立名。各有两重总别。一谓三藏十二部为总名。修多罗等为别称。二谓修多罗为总号。毗奈耶应颂等为别目。古来相传。唯辩前门不论于后。今修多罗依藏部中总相业用。而立其名。余藏部名依藏部中别相业用。所以者何。修多罗业能贯摄故。余藏余部所诠所化。由此贯摄彼方成故。故涅槃十五云。始从如是我闻。终至欢喜奉行。一切皆名修多罗故。释曰。刊定记文犹似难见。今更为释。言各有两重总别者。如三藏中两重者。一云三藏是总。经律论为别。二修多罗是总称。调伏对法为别称故。三藏中修多罗即是总名。虽标总称即受别名。故云今修多罗依三藏中总相业用。古人不知此从总相得名。但谓为别。故云总别不分失也。又如十二部亦有两重总别者。一云。十二部经是总名也。谓修多罗祇夜等。即为别称。二云。修多罗是总名。祇夜等十一为别称。不取修多罗。以修多罗为总故。亦虽标总称。即受别名。是则三藏中修多罗。通于二藏。十二分中修多罗。通余十一故。若不通者。修多罗既称契理合机。余无此名应不契理合机。既俱契理合机。明知修多罗是从总相立名耳。三藏十二部。皆有两重总别。故云各有也。刊定之意亦有理在。今谓若十二部中修多罗。则通十一及于三藏。若三藏中修多罗名。唯通十二不通二藏。二藏之中有契合者。自属十二分中修多罗耳。思之以非苦要故

疏。略不叙。唯明初一。恐欲知根本故钞具叙耳。彼复破于远公三修多罗。至十藏品当说

疏。今更详之者。第四会顺违也。于中三。初全纵。次半夺。后出古意。今初。言古如所破者。经线俱为敌对而言线是经非故如所破

疏。若兼顺义下。二半夺也。纵其经是敌对。夺其不名圣教。是故一名含于多实。应须顺义立名。如仙陀婆一名四实。若译经中五味之处。应译为盐。若译经中王之所乘。仙陀婆者。应译为马。不可言水言器。今译佛经云修多罗。合名圣教也。言线言索非全惬当。故云经自属于席。经敌对应名圣教。梁摄已下。引文为证。即第一论。然此所引上两句全是论文。为成圣教下。乃取义释。以彼本论云摄大乘论即阿毗达磨教及修多罗。释论云。此言大乘者。欲拣小乘阿毗达磨。何不但说阿毗达磨名。复说于修多罗名。有阿毗达磨非是圣教故。此中意云。若但言阿毗达磨。拣滥不尽故。加修多罗言。拣异凡夫所造之论。明是圣教之论故。今引意者。本论牒修多罗。释论之中乃云圣教。明是译修多罗为圣教也

疏。古德见此方儒墨皆称为经。下出古意也。席经不顺本义。是故借耳。儒即儒教。夫子为主。墨即墨教。墨翟为主。亡身益物。是其所宗。如夏禹之勤用斯意也。儒有九经五经等。皆称为经。经者。常也。典也。圣人之言方得称经。此方既以圣人之言为经故。译圣教亦名经也。言双含二义者。即圣教及经纬义也。俱顺两方者。顺此方夫子等经。顺西域经纬圣教之经也。恐滥席经故。加契字以拣之耳。古人既以敌对为线。明知亦未了契经。半从义耳。故为允当

疏。二显相下。此中大意。取其一名四实。以会杂心五义。便是显修多罗之相。文中三。初总举包含。二故杂心下。正会五义。三总上五义下以义贯通。二中即杂心。第八修多罗品云。修多罗者。凡有五义。一曰出生。出生诸义故。二曰涌泉。义味无尽故。三曰显示。显示诸义故。四曰绳墨。辨诸邪正故。五曰结鬘。贯穿诸法故。如是五义。是修多罗义。今疏引初二义不次者。依古疏引。取义便耳

疏。总上五义不出贯摄。于中二。先总释贯摄。后彰所贯摄。前中有三。初标义。二引证。三释所引。疏。故佛地论第一者。二引证也。全引论文。更无所少。而次下对所诠云。应知此中宣说佛地。饶益有情。依所诠义。名佛地经。如缘起经。如集宝论。意云皆从所诠也

疏。此或贯摄通所说所化下。三释所引论也。释有二义。一通。二局。上即通也。言二义通所说者。谓贯穿所说之法。摄令不散故。故下疏引瑜伽。云摄取圣语。言二义通所化者。贯穿所化众生心行。摄取不舍故。局义可知

疏。又世亲摄论下。第二彰所贯摄之法。于中二。初引摄论正释。后例同指余。前中即彼论第一。文中亦二。先引论总标。后依者下。引论别释。释标四义则分为四。初释依中。举其三事。一于是处者。即说经处。如佛在摩竭提国等。二由此者。即说经因缘。即所被机等。如十地经。由十方佛加。解脱月请等。三为此者。即说经意。如发心品云。为欲显示佛法故。为以智光普照故。为欲开阐实义故等。故梁论云。是处是人是用。疏。相者。谓世俗谛相。胜义谛相者。谓世尊说法。有何相貌。诸佛唯依二谛为众生说。更无余相。疏。法者。谓蕴界处等者。即所诠法门轨持之法。一一皆通二谛。蕴即五蕴。界即十八界。处即十二处。缘起即十二因缘。谛即四谛。食即四食。如世亲论第十初说。静虑即四静虑。无量即四无量。无色即四无色。解脱即八解脱。胜处即八胜处。遍处即十遍处。菩提分即三十七品等。无碍解即四辩才。无诤即无诤三昧。等者。等余法数。并下经文广有其相。疏。义者随顺密意说等者。义名所以。世尊说法。或显了说。或密意说。如说一切皆空。此就第一义说。凡夫不解谓无俗谛等。亦如四意趣四随等。梁论释义云。义者所作事故名义。生道灭惑是事。此意云。佛所说经。但令众生生道灭惑。以为其义耳。亦佛之意趣也

疏。瑜伽二十五。显扬二十等者。二例同指余。先例同。谓彼二论皆云素怛缆者。谓佛世尊于彼方所。为彼有情。依彼所有诸行差别。演说无量蕴相应语。乃至广说。结集法者。摄取圣语为法久住。以美妙言次第结集。贯穿缝缀。能引义利。能引梵行真妙实义。是素怛缆。疏。余义至十二分中当明者。下有异名有四。一依仁王二谛品名为法本。二依梁论名为圣教。三依成论名直说语言。四依智论第二。但名为经。四中疏文已有二四。初三二名在十藏品。又三局十二分中修多罗。故此不释。又远公立三修多罗。一总相。二别相。三略相。刊定记。破于后二。并在十藏品中。故云余义等。第二毗奈耶藏

疏。文分二。初总科。后前中下。别释。于释名中二。先正释。后辩异名。今初

疏。此翻为调伏者。准刊定记云。义翻为调伏。若敌对翻。正称为律。若素律师疏云。梵曰毗尼。或云鞞泥迦。毗那耶。鼻那夜。此等皆由梵音轻重不同。传有讹略不得正名。正曰毗奈耶。此云调伏

疏。毗尼或翻为灭下。二辩异名。于中有四。今初。名灭者东塔。又云毗腻多。此云已调伏。当其灭义故。母论第一云。灭诸恶法。故名毗尼。释曰。若依此释。则毗尼但是毗腻多之言略耳。则与毗奈耶。调伏之义有乖。而上又云。毗尼。鞞泥迦等皆梵音轻重。则毗尼亦是毗奈耶略称。含其调伏与灭二义耳。故疏云。毗尼或翻为灭。疏。灭有三义等者。释义。一灭业非者。不杀盗等故。律中有犯毗尼。有诤毗尼。二灭烦恼者。是发业之本故。律云为调伏贪嗔等令尽。是故世尊制增戒学。三得灭果者。即无为果故。戒经云。戒净有智慧。便得第一道。疏。或名尸罗等者。第二名也。即双从因果得名

疏。亦名波罗提木叉等者。第三名也。言拣异定道者。非是定共道共二戒。是远离羁缚业缘。名为解脱。疏。亦翻为随顺解脱者。即第三名中别义也。故遗教经云。戒是正顺解脱之本。故名波罗提木叉。又相续解脱经云。五分法身。名为解脱。梵云。毗木叉。若涅槃解脱。梵云木叉。依此亦可双从因果得名。随顺是因故。又刊定记云。离过无障。名无木叉。业用无碍名毗木叉。又云。复有异名。名优波罗叉。此西域外道律名。又名刺阇尔地(地字音提)此西域王法律名

疏。后显相者下。显相文二。先指前总说。谓制伏过非及灭恶等。即行止行调练三业。性善守信等。通于止作。毗尼以止恶作善为宗。律宗其唯持犯故。以止作总为显相

疏。若别说者下。二论别释。言广如彼论者。论云犯罪者。谓五众罪。等起者。为无知故。放逸故。烦恼盛故。不尊敬故。而犯诸罪。还净者。谓由意乐不由治罚。如受律仪。出离者有七种。一各各相对说悔所犯。二誓受治罚。谓受学等。三等有妨害。为先制学处。后由异门。还复开许。四别立止息。谓僧和合还舍所制。五转根。谓苾刍苾刍尼转男女形故。舍不共罪。六由真实观。谓作殊胜法嗢拖南等。诸行相观。七由法尔得。谓由见谛法尔而得谓无小随小罪。应知毗奈耶。复有四义。一补特伽罗故。世尊依彼制所学处。二制立故。谓告白彼补特伽罗所犯过已。大师集僧制所学处。三分别故。谓制学处已。更广解释先所略说。四决择故。谓于此中决判所犯。云何有罪。云何无罪。然明了论。释无小随小罪。自有二说。一云小谓第二篇罪。随小谓二种方便罪。一云小谓性罪。随小谓诸戒中制罪。问今明大乘。那引小教有。答云。理实三藏大小不同。今且就引接教说。古来同此。今更一解。谓持心虽异名意大同。故得引小。又上所引论名。分明易晓故。又上云如受律仪者。梁论云。如本受持对治。第三阿毗达磨藏文中二。先标。后释。释中三。初辩名。二显相。后异名。初中二。先得名。后释名。前中先释法。后释对。前中即取俱舍意释。故论云。能持自性故名为法。若胜义法唯是涅槃。若法相法通四圣谛。是善是常故名为胜。即释彼论也。相者性也状也。二俱名相者。亦释彼论也。以四圣谛中灭谛是理。而皆云相者。灭谛之相。即体相也。余三约相即相状也

疏。法既有二下。释对。亦取论意。彼论云。此能对向。或能对观故。为此属之

疏。其能对者下。出对法体。亦取论意。故论颂云。净慧随行名对法。论曰。慧谓择法。净谓无漏。净慧眷属名曰随行。如是总说。无漏五蕴名为对法。疏。由对果对境分二对名等者。释疑。疑云唯一净慧。何有二对之名。故为此通。疏。慧但是对而非是法。非所对故者。拣滥。此是古德解释。意云为分能所故。言慧但是对。若据法能持自性。慧何非法。故今拣云非所对故

疏。言对法者下。二释名也。即会六释。法之对者。依主释也。疏。故对法藏特名慧论者。若据所对所依。应名法论。慧依于法。慧为其主。故名慧论。故所诠中诠于慧学。疏。旧译已下出其异名。兼成上慧义

疏。世亲摄论云下。第二辩相。于中二。先总。后对。义同前下。别释数者。数字通去入二声。此取去声。数数宣说者。数即入声。自相者。如色变碍为相。受以领纳为相等。共相者。共有无常苦空等。广如十地疏明。疏。论处所等者。即瑜伽论说。论有七例。颂云。论体论处所。论据论庄严。论负论出离。论多所作法。亦如初地中辩。言能胜伏他论者。胜约能立。伏约能破。故梁论云。伏者此法能伏诸说。立破二能。由正说依正等方便故。云通者梁论名解。由阿毗达磨。通修多罗义。易解了故。亦名已下。三辩异名。文处可知。问曰。三藏前二。是佛所说。后一论藏。是菩萨说。是则如来不说三藏耶。答婆沙最初即有此问。问曰。谁造此论。答佛世尊。谁问谁答。或云舍利弗问。或云诸天问。乃至或云化比丘问。佛答。若尔何以云迦多演尼子造。答。造彼讽诵耳。有云。亦是彼说。是则论藏。有是佛说。有是菩萨说。取经中义广以释之。以本统末。亦佛说三藏耳

疏。然此三藏约其所诠下。第三总显所诠也。疏。如摄论说者。亦是世亲摄论第一。论云。又能说三学故。立素怛缆藏。能成办增上戒增上心学故。立毗奈耶藏。谓具尸罗。即无悔等。渐次能得三摩地故。能成办增上慧故。立阿毗达磨藏。谓能决择无倒义故。梁论亦同。疏。兼各通三者。经中戒慧其文非一。毗尼增三文云。云何增戒学。所谓增心学增慧学。是名增戒学等

疏。第二明二藏等。疏文有四。一标二即。由前三下。释三故。庄严下引证。四此就二乘下。出所以。于中分三。初正出为二所以。次若约教行别故下。出三乘三藏不同。后又由缘觉下。重成二藏之义。疏。即大小半满不同者。诸经论中多以大小相对故。分大小经律论。别大乘之中有大乘经律论。小乘之中有小乘经律论。别华严般若等为大乘经。菩萨戒善戒经等为律。瑜伽智度等为论。小乘四阿含等为经。五部律为戒。婆沙等为论。故大小三藏迢然不同。言半满者。即出涅槃。北经第四。如来性品文云。善男子。譬如长者唯有一子。心常忆念怜爱不已。将诣师所欲令受学。惧不速成寻便将还。以爱念故。昼夜殷勤教其半字。而不教诲毗伽罗论。何以故。以其幼稚力未堪故等。下合云。所言一子者。谓一切众生。如来视于一切众生犹如一子。教一子者。谓声闻弟子。半字者谓九部经典。毗伽罗论者。所谓方等大乘经典。以诸声闻无有慧力。是故如来为说半字九部经典。而不为说毗伽罗论。方等大乘。善男子。如彼长者子年既长大。堪任读学。若不为说毗伽罗论何名为藏。乃至云。今我亦尔。为诸弟子说于半字九部经已。次为演说毗伽罗论。所谓如来常存不变。上即经文。半满是喻。大小是法。余义可知。又西方三藏之外加一杂藏。谓陀罗尼五明论等为四藏。大小俱有则有八藏。若六波罗蜜经说有五藏。小乘三藏及杂藏为一藏。大乘为一藏。故为五藏。若大开为三即有七藏。三乘各三便是九藏。加一杂藏便为十藏。三乘各四应十二藏。疏中。第二明所摄下。文中有二。初明彼摄此经。后若约下。明此摄彼藏。文并可知。上来藏摄竟

第二明教摄中

疏。二者诸宗立教等者。由前经藏有权实等。故有此门。于中三。一标举将说。二总辩深玄。三开章别解。今初可知

疏。夫教海冲深下。二总辩深玄。有标释结。今初。教海总含深广。文略语深。法云智光略明深广。下经云。一切诸佛云雨说法。唯十地菩萨。能安能受能摄能持。佛刹微尘法门海故。云雨说法故。夜摩偈赞品。胜林菩萨云。譬如孟夏月。空净无云翳。赫日扬光辉。十方靡不充。其光无限量。无有能测知。有目斯尚然。何况盲冥者。诸佛亦如是。功德无边际。不可思议劫。莫能分别知。故云智光无际。妙辩叵穷者。法华云。诸法寂灭相。不可以言宣。是法不可示。言词相寂灭。故四辩八音。不能谈其状也。普贤行愿云。如来功德。假使十方一切诸佛。经不可说不可说佛刹微尘劫。相续演说不可穷尽

疏。以无言之言至无穷之机者。二释即出叵穷所以。全依体上起大用故。非是无言非在言故。然能说之妙。谓无言之言。所说之深。谓言绝之理。故经云。了法不在言。善入无言际。而能示言说。如响遍世间。法华云。以方便力故。为五比丘说等。以无变之变者。能说多端故。下经云。一法门中无量门。无量千劫如是说。所演法门广大义。普运光天之所了等。应无穷之机者。所感非一故。故九地云。如是乃至不可说世界所有众生。一刹那间。一一皆以无量言音而兴问难。一一问难。各各不同。菩萨于一念顷悉能领受。亦以一音普为解说。各随心乐。令得欢喜等。菩萨尚尔。何况如来。出现品云。如来音声亦复如是。普入一切处。一切众生。一切法。一切业。一切报中。而无所住者。即无变之变也。又云。佛子。如来随一切众生心行欲乐。无量差别出若干音声。而转法轮者。即应无穷之机也。广如下说。是知如来教法。能深能广能高能远。其犹大海周天虽涉而难越。孤峰四绝可仰而叵升也

疏。极位所承凡情难揖者。三结成难思。揖由测也。九地已下。皆测量不及。唯十地菩萨位极能承故。十地经云。譬如娑竭罗龙王所霔大雨。唯除大海余一切处。皆不能安。不能受。不能摄。不能持。如来秘藏大法明大法照大法雨。亦复如是。唯除第十地菩萨能安能受能摄能持。余一切众生声闻独觉。乃至第九地菩萨。皆不能安不能受。不能摄不能持。第五经云。佛子众会广无限。欲共测量诸佛智。诸佛法门无有边。能悉了知甚为难。喜目云。诸佛法海无有边。我悉一时能普饮等。证上可知

大方广佛华严经随疏演义钞卷第五大方广佛华严经随疏演义钞卷第六

        唐清凉山大华严寺沙门澄观述

疏。今承理教之力略启四门。下第三。开章别释也。于中先标。后释。今初也。应有难云。既极位方知。何以凡情辄窥大教。故此云耳依凭教理。圣教许故。故涅槃云。具缚凡夫。能知如来秘密之藏。毗卢遮那品云。如因日光照。还见于日轮。我以佛智光。见佛所行道。即因佛教能了教也。即仰推之智。信解而知耳

疏。今初西域下。释第一门。于中三。初双标开合。次且不分下。双释开合。后以斯多义下。双结开合。今初也。西域开合者。如龙树之释大品。无著之解金刚等。皆合而不分也。而智光戒贤。各分三时。皆开而不合也。东夏开不开者。如僧肇之解净名。僧睿之释思益等。皆合而不分也。生公之立四轮。智者之立四教等。皆开而不合也。故诸德见开有失则合。见合有失则开。不应局执也

疏。殊途同归者。周易云。天下殊途而同归。百虑而一致。谓若千迳九逵王城不二。九流百氏大道宁差。今疏借用。乃通三义。一约教。始随机异故殊途。终归显实故一致。二约机则异。就理常一。三体外无权。权即是实故。殊途同致也。疏二。一音普应一雨普滋者。一音即是净名。一雨即法华药草喻品。谓三草二木不同。同承一雨之润。五性三乘不一。法雨一味无差故。彼经云。如来知是一相一味之法。所谓解脱相。离相。灭相。究竟涅槃。常寂灭相。终归于空等。疏。三原圣本意为一事故者。亦是法华中意。故彼经云。过去诸佛以无量无数方便。种种因缘譬喻言词。而为众生演说诸法。是法皆为一佛乘故。一佛乘者即华严矣。又云。我此九部法。随顺众生说。入大乘为本。以故说是经。皆为一事也。疏。四随一一文众解不同者。此通明诸经。如经说一无常。或有解者以生灭代谢故云无常。或云无彼常故名为无常。或云。不生不灭名为无常。或即无法可常也。或云。真如一法随染净缘。转变不常故名无常。或闻无常便知对常。以说无常。非常非无常。以为中道等。明知随人解不同也。又苦集灭道四名。则同随机解殊。乃有四种。又涅槃云。十二因缘下。智观者。得声闻菩提。中智观者。得缘觉菩提。上智观者。得菩萨菩提。上上智观者。得佛菩提。又如一乘五教机解不同三谛差别。中论偈云因缘所生法。我说即是空。亦名为假名。亦是中道义。即有多人解不同也。或云。既言因缘所生。那得即空。要须析因缘尽。方乃会空。呼十方空为即空。亦名为假名者。有为虚弱。势不独立。假众缘成。从缘故假。非施权之假。亦是中道义者。离断常故名为中道。非佛性中道。若作此解者。虽三句皆空。尚不成即空。况即假即中。此生灭四谛中义也。或云。因缘所生法。不须破灭。体即是空。而不得即假即中。设作假中。皆顺入空。何者诸法皆即空。无主宰故。假亦即空。假施设故。中亦即空。离断常二边故。此三番语异。俱顺入空。退非二乘析法。进非别圆。乃是三兽度河之意耳。或谓即空即假即中。三种逦迤。各各有异。三种皆空者。无主故空。虚设故空。无边故空。三种皆假者。同有名字故假。三种皆中者。中真中机中实故。谓空名中者。约真谛故。假名中者。就机设化。不住化不。化故。中名中者。约一实谛之中道故。此得别失圆。或谓即空即假即中。虽三而一。虽一而三。不相妨碍。三种皆空者。言思道断故。三种皆假者。但有名字故。三种皆中者。即是实相故。但以空为名。即具假中。悟空即悟假中。余亦如是。是知随闻一法起种种解。圆机受教无教不圆。偏机受教圆亦偏矣。既随一文异解。何须分判不同。疏。五多种说法成枝流者。上义亦傍该诸经。今正引当经立理。法界品云。法欲灭时有千部异千种说法等。何不寻条以得根。便欲派本而为末。浑纯源之一味。成浇薄之枝流

疏。以斯五义下。三总结也。夫子云。攻乎异端斯害也矣。何得执异迷同是非竞作

疏。其分教者下。释分教中乃有十意。前五对前五义。后五显过于前。疏。一理虽一味等者。谓今欲分教非欲分理。迷于权实。宁契佛心。二中一音但是教本。非即是教。教乃在机。随机不同。今分彼教故。净名云。佛以一音演说法。众生各各随所解。今分随所解耳。其犹长风是一。百窍异吹。岂以一风不殊。便谓百窍齐响。一雨亦就佛说。三草即就机殊。今分三草教殊。非析一雨令异故。经云。虽一地所生一雨所润。而诸草木各有差别。以一音一雨义相不异故。但说一音。三中本意未申者。如佛本。为一大事出现于世。四十余年。未显真实。今分一代时教。岂妨判有浅深。言随他意语者。佛有三语。一随自意语。说自所证一实等故。二随他意语。一向方便引众生故。三随自他意语。半称自证。半随机故。今分后之二语。不分初一随自意也。四中言有通别者。如前所引。此通随闻异解有不通者。就此分之。如说人空法有。斯即小乘。不可名大。若说二空。此可名大。不得名小。说有五性非是一性。说一性处非是说五。如是等文。无容异解故须分之。五中有二义故。虽分权实不成枝派。一善会佛意。所说权教乃是随宜。所说实者称理究竟。二有开显者。说彼权教是方便门。说于实教是真实相。不谓方便为真实。则方便门开知实理之普周。则真实相显故。法华经云。此经开方便门示真实相。今能开显故。不滞枝派。约佛施张故。须分权实

疏。又王之密语所为别故下。有五意。显过于前不分。此一初也。涅槃第九。说先陀婆一名四实。一者盐。二者器。三者水。四者马。释中。一水二盐三器四马故。彼文云。如是四法皆同此名。有智之臣善知此名。若王洗时索先陀婆。即便奉水。若王食时索先陀婆。即便奉盐。若王食已将欲饮浆索先陀婆。即便奉器。若王欲游索先陀婆。即便奉马。如是智臣善解大王四种密语。是大乘经亦复如是。有四无常大乘智臣应当善知。若佛出世为众生说如来涅槃。智臣当知。此是如来为计常者说无常相。欲令比丘修无常想。或复说言。正法当灭。智臣应知。此是如来为计乐者。说于苦相。欲令比丘多修苦想。又复说言。我今病苦。众僧破坏。智臣当知。此是如来为计我者。说无我相。欲令比丘修无我想。或复说言。所谓空者是正解脱。智臣当知。此是如来说正解脱无二十五有。欲令比丘修学空想。以是义故是正解脱。则名为空。亦名不动。谓不动者。是解脱中无有苦故。是故不动。是正解脱亦为无相。谓无相者。无有色声香味触等。故名无相。是正解脱常不变易。是解脱中无有无常热恼变易。是故解脱名曰常住不变清凉。或复说言。一切众生有如来性。智臣当知。此是如来说于常法。欲令比丘修正常法。是诸比丘。若能如是随顺学者。当知是人真我弟子。然彼经疏。不释不次所以但案次配释而已。前四彰权隐实。后一彰实隐权。今谓前别喻中。即无常苦空无我。而为其次。以水方圆任器。是无常故。盐是苦故。器当其空。有器之用故。马由人策。不自在故。合中无常苦无我。是三修法。属生死故。四合空者。是正解脱。而解脱中空无我苦不净及无常。即是常故。故一空中明有四义。并以器喻。而最后佛性彰其妙有。即合前马。然空中四义。遮无常等。佛性一义。显是真常。亦应具说我乐净等。含在正解脱中。不动是乐。无相是净。无变热恼即是常义。马又我义。是则此中具彰八行。由于生死无常等中。密显常等故为密语。又初标中盐在初者。亦是苦空无常无我。而为其次。如常所明。故此释不同古师之义。然引此文意。令随所说言。须善得意。岂可浑然不分权实。疏。不识权实以深为浅等者。第二意也。如言初发心时便成正觉。而谓但是如来方便说者。是以深为浅也。不能正修。高推圣境。即不能速证无上菩提。故云失于大利。离世间品云。修此法者。少作功力疾得菩提等。言以浅为深虚其功者。犹如世尊为止乱想。令数息看心。为厌苦者令出三界。众生不了耽味为真。勤苦不已。多用功力所获至微。不得涅槃一日之价。故云虚其功故。即虚废功力也。疏。庄严圣教令深广故者。第三意也。谓分析权实空有。取舍偏圆迟速。方知佛法微妙深玄。无不包摄。譬犹不泛大海岂识边涯。不识土石安知真宝。故智论释法施云。依随经论广作义理。为立名字皆名法施。又若不分权实。则谓三教大同。今明大乘尚有权实。何况小耶。小乘比大。由若萤光方于日照。小是佛教尚被斥诃。况于儒道比之佛法。则天地悬隔矣。以此重重拣之。方知佛法深奥。疏。诸圣教中自有分故者。第四意也。如解深密。立三时不同解节。金光明立三轮之异。涅槃自分半满。又约五味之差。皆佛自分也。疏。诸大菩萨亦开教故者。第五意也。若无著之扶五性及与三时。龙树之判四门共与不共。皆拣权实有取舍也

疏。以斯多义下。第三双结离合。而舍合从离。第二古今违顺中。先叙此方。后明西域。前中先总标。后别释。一一师中多分为二。先叙昔义。后辩顺违。一音中疏上之下辩顺违。先出彼意。言各得圆音一义者。言含纵夺。纵之则顺下出现品。明如来圆音有其十义。十义之后。复六句融通。今但得十义中之一耳。初师则顺善口天女一声之中。与百千种乐而共相应。则佛一音之中有多音也。后师则顺如水一味随器成异。则如来本无多音。故云各得一义耳。又此二义。若不会释。敌体相违。互不相许。则齐楚俱失。并应夺之。若取各自所宗故。各得一义而与之耳。然并为教本下。又都夺耳。疏。二立二种教。隋远法师亦同此立者。彼涅槃疏。初云。圣教虽众。略有二种。一声闻藏。二菩萨藏是也

疏。斯则文下。二辩顺违。先明其顺。顺于至教。涅槃半满。前已广引。疏。盖是对小下。辩违。上云顺者。但顺通相之意。未知佛之深旨。半满之言。显在小大密意而说。复有以权为半以实为满。则大乘中有半满矣。亦犹缘觉声闻开之有异。则成二乘。合之有同。总称为小。权实亦尔。开之有异。权可称半。合之大同。故并称满。是则实教唯满。小教唯半。权大乘者。亦半亦满也

疏。此虽约机下。辩顺违。直出其立意不离半满。半满顺违。即此顺违也。言不出半满者。顿即前满。渐具半满。以具有三乘。二乘是半。大乘是满。故以机就教有直有曲。故分渐顿耳

疏。三唐初印法师下。第三师先叙昔义。中有三。初总标。二屈曲下。正立。三又此下。拣异

疏。此约化仪以判下。辩顺违。先顺后违。顺中三。初一句总出立意。第二遮破释成。第三结成昔义。今初。第一半满。约所说法立。第二渐顿约机以立。今此一师约化仪立。谓佛以法化生。有曲直故。即化法仪式不同耳

疏。然华严下。第二遮破释成。谓刊定记不许此师立义。先破总名。后破四异。今为昔通。则遮其破耳。文即分二。先救总名。后救四异。今初。至故云屈曲。是救其破于总名。彼疏破中。先牒义竟云。若尔涅槃法华维摩楞伽密严胜鬘佛藏经等。皆释迦说。应不明于如来藏性实相法界等(此破屈曲以有平道故)华严梵网。既舍那说。何故华严说于四谛。普贤行等品中。皆云随诸众生所应调伏。作如是说。又问。明净行梵行三贤十地。离世间入法界等。诸品之中。不应皆说对治行法等(此破平道以有屈曲故也)今疏云虽有随诸众生各别调伏者。此牒其破平道教中屈曲之文。疏。皆是称性一时顿演者。释成是其平道之义以称性之巧。无边差别皆是平道。又一时顿演不同屈曲说权之时不说实。说实之时不说权。说四谛唯为小乘。说六度唯被菩萨。故一切并陈尤显平道。又说随众生者。说于世尊余处随机。非此经中是随机说。疏。涅槃等虽说一极者。此牒其破屈曲教中有平道之文。疏。或对权实下。释成是屈曲之义。言屈曲者。非是有真如法性。即非屈曲。但取随机隐显为屈曲耳。此上二句是约法华。明是屈曲。昔权今实。破三显一。明权则未说实。说实必废于权。不同华严权实齐彰一时顿用。故名屈曲。疏。或会异归同下。约涅槃经以明屈曲。涅槃会昔有余之义同归一味涅槃。先异后同。亦成屈曲。不同华严若同若异。空不空等一时顿演。又云一切如来或说不说者。古德共云。日月灯明佛。晨旦说法华。中夜便灭度。则法华之外。非是别时更说涅槃。谓人根利故闻法华竟。不复须说涅槃。则涅槃或说不说。谓或有国土。唯说三乘究竟不破。或有国土唯说一乘无三可破。则知法华亦有说不说。不同华严云我不见有一佛国土。其中如来不说此法。明是平道

疏。约释迦为主下。第二救破四异。彼疏破云。又四异中。众处两异皆违经说。七处并是娑婆界故(上破处异)又云。出现品云。十方诸佛赞普贤言。能说此法。今此会中有佛刹微尘众生。发菩提心故。发心品中云。亦同此说。准此故知有地前器。(此上破众异)是故此师所立。多违教理。甚难依也(此结破也)。彼破二异。今疏通二异。后一是救刊定破处异。初一是遮有余师破其主异。谓恐有破云下。经既云。或名释迦牟尼。或名毗卢遮那。明知二主不异。何言主异。故今通云。释迦为主。但是三身中化身。遮那为主。则十身具显。化身乃是十身之一。故云必具释迦。是则总别异也。何言不异

疏。娑婆之处未融华藏。华藏之处必融娑婆者。此通刊定破处异也。余处王城舍卫。未言即是华藏娑婆。今云七处自有二义。故同华藏一。约本末分岐故。七处亦是华藏界中。第十三重之内。二约净秽该彻。则摩竭提国其地金刚。说初品时。华藏世界六种震动。彼疏序云。刹该净秽。娑婆震而华藏动。岂不华藏之处融耶。故知破其处异。自违己说也。所以不救破众异者。由刊定破最不当故。彼众异中但云。释迦经中通被三乘。遮那经中唯被菩萨。则通局之殊而破彼义。乃引凡夫发心。岂非菩萨之器。况此经发心。又甚深故。其说异一种。他人不破故此不救

疏。略云四异下第三结成昔义。言异实有多者。更举十条。一教门仪式异。于中复有多义。谓全依海印曾无出入。一时顿演与前后次第不同。放光集众一多通局。请答言念现相等殊。道场庄严胜劣不等。故云教门仪式异也。二所诠理致异。圆融历别多义不同。十十法门有多差别。如义分齐中。三成佛迟速异。谓或唯一念或无量劫。念劫圆融长短自在。不局三祇及应化故。四见佛通局异。无论凡圣。许见十身。不局地前地上之别故。五说教时分异。始成即说时有十重。念劫圆融不局三七等故。六见境宽狭异。地狱天子。六千比丘。肉眼远彻周法界见。不局三千有分限故。七因果行位异。具足圆融行布。性相交彻故。八立乘多少异。或说一乘或无量乘。不局三乘五乘定故。九利益胜劣异。地狱天子三重顿圆。尘尘刹刹无尽利益故。十流通付嘱异。尽未来际长流不断。诸佛亲护非小乘故。历别细求过此更有。故云异实有多。诚如所判者。结成昔义也

疏。但以下。第二辩违。既不判屈曲之浅深。便令多法浑同无别。不能令人善识权实故不依之

疏。四齐朝隐士等者。于正立中。约于化仪及时。以立渐说顿说。即是化仪顿。在始成。渐有五时即约时说

疏。然此经下。二辩顺违。先顺后违。顺中由依化仪故成顺理。便引当经为其证成。所引二喻并出现品文。前来已引。疏。然渐约下。辩违也。以约时局教有诸妨难故成违理。指在后破。第三立三种教中先总标。后一南中下。别说三师。初即诸师同立。于叙昔中二。先总明。后别明渐义。前中分三。初正立。次由渐中先小下。立三之意。后谓别有下。出不定相。言偏方者。谓大体而言。渐中先小后大。而不妨说小之时亦有说大。如人十年弘律不妨私房时说大乘。故曰偏方不定。指经云如胜鬘金光明者。胜鬘经初云。波斯匿王末利夫人。信法未久。既言未久明是初说。金光明经既非第一顿教。又非第二渐教。末后而明常住。明是不定。言佛性常住者。胜鬘经说二种如来藏。即佛性也。又叹佛三身。即今梵音之文云。一切法常住。是故我归依。即常住义也。金光明经三身品中。广说法身常住故

疏。渐中开合下。第二别明渐义。开渐成别自有四种。从二至五。于分三中。初自有三师。初有师正立。后二师指同。即唐三藏及真谛三藏。初云武丘。即苏州山寺。于第三师中二先指同初师。后而时节下。指异别立。疏文稍略。彼云。谓佛二月八日成道。四月八日于波罗柰国鹿野苑中。为声闻众转四谛法轮。后于成道第七年中在舍卫国。去祇园五里智慧河边。为诸菩萨及二乘众说般若等经。此时具二。谓转照法轮。又于成道三十年后。未涅槃前。在毗舍离国鬼王法堂中。为真常菩萨说解节等经。此时具有转照及持三种法轮也

疏。即宋朝岌法师下。第三分四于中文二。初双标。后双显。疏家不欲繁文故。但于前师之外。加其异名应具列之

疏。道场慧观者。即上元道场寺僧。言五教者。一有相教。二无相教。三抑扬教。四同归教。五常住教。言抑扬者。谓抑挫声闻褒扬菩萨故。刘公五者。一人天教。二有相教。三无相教。四同归教。五常住教

疏。上来诸师下。第二辩顺违。于中三。第一总明顺违。第二别破违理。第三结成违顺。初中以上来诸师从二至五。皆先小后大故。不加不定。招初有大乘之难。虽加不定犹有妨者。加不定免初有大乘之难。而于所立名义之中。皆有难也。言略显五时之妨者。从后破之。既破五时。四三二时皆已破竟。故云余可例知

疏。初明十二年等者。第二别破。别破二家五时。即为二别。今初破道场五时。即分为五。疏。成实论云。我今正明三藏中实义。实义即空者。破第一时。引其三文。此即第一引小乘论。以成实论意云我今成立小乘中实义。故云成实。以三藏即小乘教故。既言实义即空。明小乘已说空竟。何言见有得道。不可不见实义而得道也

疏。又阿含中云下。第二引小乘经。然经文相续云无是老死无谁老死。此即明十二因缘人法空义。是老死者。指老死法体。谁者即人也。故无是老死。即老死法空。无谁老死。即我人空也。然诸经论多明小乘。但有人空未明法空者。有二义故。一从少分说小乘。多分但明人空。二从显了不显了说。虽说法空未全显了。故言不说法空耳。若从不显了说及少分说。则亦明法空。今从此义

疏。三藏中明法空为大空者。第三引大乘论。彼释十八空。拣二宗大空之异。今但取三藏明法空之言。三藏亦即小乘教耳。皆显已下。四结上三文

疏。若云第二时中下。破第二时。于中三。一破说空。二破不相常住。三结立正义。初中又二。第一引制戒。明十二年后说有。故戒经云。善护于口言。自净其志意。身莫作诸恶。此三业道净。能得如是行。是大仙人道。此是释迦如来于十二年中。为无事僧说是戒经。从是已后广分别说。明知十二年后。始制广戒。广戒即是明有

疏。又智论云。从得道夜下。第二引论通说般若。明十二年前已说于空。非局十二年后。般若明性空之智故

疏。若云第二时中未显常住者下。第二破不明常住。于中四。初反质破。实相即常住故

疏。涅槃亦说佛性亦名般若者。第二显正破。上即现量。此即圣言量。般若既即佛性。佛性是常。般若常矣

疏。是知实相般若下。第三会义破。谓会释二经。使第二时同第五时。以义同故。谓二种般若。即二佛性。在名则异。在义不殊。言实相为正因者。即第一义空。名为佛性。第一义空。即实相异名。观照为了因。如灯了物

疏。又般若离四句下。第四纵夺破。先夺则拂迹入玄理绝百非。言亡四句。若但以空为般若者。非真般若也。故经云。般若非有相非无相。亦非有无相。亦非非有无相。离一切诸相何得存空。故智论云。诸佛说空法。为离于有见。若复见有空。诸佛所不化。疏。般若不坏四句岂无妙有者。此即纵也。纵其是空。亦须是有空。尚是四句。何况有耶。故般若经云。般若不坏色。不坏受想行识。即不坏有也。余文可知。故智论云。一切实。非实。亦实亦非实。非实非非实。是名诸佛法。则四句皆实。又因缘所生法。即空即假即中。有遮有表。即下二句。是知失意则四句便成四谤。得旨则四句便成四德。下说正义。蹑此而起

疏。是知小大各有四门下。第三结立正义也。此则纵而夺之。纵其初有次空。则各得一门之意。夺其不识四门之意。则初有次空之旨全乖。言四门者。小乘以阿毗昙为有门。毗昙即今俱舍。遵一切有部故。成实即是空门。实义是空故。以昆勒论即亦有亦空门。其非有非空门。未见论文。即是恶性车匿见此入道。有云。犊子部亦计我非有非无。恐未指定。大乘四门者。如涅槃云。一切众生皆有佛性。如乳有酪性等。斯即有门也。又云。石无金性。乳无酪性。众生佛性犹若虚空。迦毗罗城空。大涅槃空。即空门也。又云。众生佛性亦有亦无。何以为有。一切众生悉同有故。何以为无。为从善方便而得见故。即亦有亦无门。又云。众生佛性即是中道。非有如虚空。非无如兔角。百非斯遣。此即非有非无门也。若取经论。唯识多明有门。掌珍多辩空门。辩中边论多辩亦有亦空门。中百论多辩非有非空门

疏。若云第三时中但名抑扬等者。破第三时。文二。先双标。后净名云下双破。先破第三时中不明常义可知。后般若亦云下。破独得抑扬之名。以第二时中亦抑扬故。二乘萤光抑也。菩萨如日扬也

疏。若云第四时下。第四时但破不明常住。不破同归之义

疏。五以涅槃为常下。破第五时。许其涅槃是常住义。责其涅槃无有小乘。以至涅槃皆有大小故。阿含说如来涅槃之相者。彼说如来于纯陀家乞食。因食栴檀木耳羹。得患背痛。于拘尸那城娑罗双树间。逆顺出入。超越三昧。于第四禅中入火光三昧。烧身灭度。唯留舍利为人天福田。身智俱灭。入无余涅槃是也

疏。若以人天为初下破第二家。即刘公之义。言提胃虽说戒善等者。彼说如来在树王下成道。于七日中。无人知佛得阿耨多罗三藐三菩提。唯提胃波利此二居士。明究阴阳知佛成道。名为树神。提胃献糗。四天王奉钵。如来受已。始为提胃说世间因果。此约小乘相不妨为大。谓彼经又云。五百贾人得受五戒。先自忏悔五逆十恶谤法等罪。得四大本净。五蕴本净。六尘本净。五根本净。提胃长者得不起法忍。三百贾人得柔顺忍。二百贾人得须陀洹果。四天王得柔顺忍。三百龙王得不起法忍。自余天等无量众生。发无上菩提心。又普曜经云。第二七日。提胃等五百贾人。施佛糗蜜。佛与授记。汝于来世当得作佛。皆同一字名曰齐成。明非独人天也。然提胃塔现在土火罗国。上所引经。皆明初时已说大也。疏又违密迹经中第二七日说三乘故者。既第二七日。已说三乘。那言最初唯人天之教。此经即大宝积密迹力士。第三会卷当第八。是初竺法护译

疏。然上五时等。皆以约时克定。则有所乖等者。第三结成违顺也。上结前违而言等者。等取四三二时。疏。拣去不定从多分说。亦有理在者。结成顺也。有二义故。故得顺理。一拣去不定。则无克定之失。不违密迹等经。二从多分说。不违自所立义。故有理在

疏。二后魏光统等者。第二师先正立中二。先明所承。后显立义。今初。言承习佛陀三藏者。佛陀是西域人。同学五人。四人皆得道。其欲亡身求之。友曰。道须缘会。不可强也。汝与东土有缘。彼有二弟子。汝若度得必当得道。佛陀初至于此。当后魏孝文。始在云州投之见重。初至一康家供养。夜见火光满室。及孝文移都洛阳。佛陀亦随之。彼为立少林寺。知后为则天所取。遂指水令西山透陇而流。其二弟子。一是稠禅师得道。二是光统。故云。稠公解虎于东谷。佛陀指水而西流

疏。亦立三教下。显立义也。于中渐约不具。顿约具说。不同远公大小相望成渐顿也。言具说者。即如涅槃说。空者所谓生死。不空者所谓大涅槃等。又云。若空不空若常无常等。皆令广闻。即时顿也。三圆教者即是华严

疏。此亦约化仪说有前后下。辩顺违。此师所立义。多顺理故不辩违。于中先出立义。后解妨难。今初。是约化仪说。有前后者。顿中化法无异渐中。别说空不空。即名为渐。同时说空不空。即名为顿。故是化仪。其第三亦约化法。拣异前二。从多分说。故云此亦约化仪

疏。意明今时下。二解妨难。中谓刊定记主。有其二难。一合难渐顿。二别难于圆。第一难云。若渐根生熟俱渐。顿根生熟俱顿。则渐顿可分。既云未熟名渐。已熟名顿。此则于一渐根。但生熟为异。无别顿义。或应彼一有渐顿二根。生必至熟。熟必从生故。或应一切时皆是渐根。无有不从生至熟故。释曰。此第一难其渐顿自有三难。第一渐顿不分难。第二一根具二难。第三无有顿根难。初一是总。后二是别。今初。为此一通。三难皆遣。如第一难。刊定以根定于渐。顿则有此难。今不以根定于渐顿。何有此难。谓为其根生。渐说法门。名之为渐。为于根熟。顿说法门。则以为顿耳。何得以生熟俱顿难耶。则第一难遣矣。既不约根。何得以生必至熟熟必从生等难耶。则第二第三难遣矣。又为此难遣下自所立教。彼立四教云。第三教当初心菩萨。第四教义当终心识如来藏者。又自通云。初心者约机胜劣。名其初终。非约修行初终时位。汝既以根胜劣为初终。何妨此师亦以根胜劣为生熟耶。故为此难。失古意也。疏。上达之言义兼地前等者。通彼第二难于圆教。彼难云。既云分阶佛境。则地前无有堪闻此经。则违出现品佛刹微尘数众生发菩提心。释曰。彼以上达分阶佛境。合为一义故为此难。今为此通。则上达为地前。分阶佛境为地上。故不违出现品文。亦不失于大理。况初发心时便成正觉。岂非分阶佛境之人。疏。隋末唐初下。第三师先正立中。皆依法华经第五。即从地涌出品。以彼中涌出菩萨问讯云世尊少病少恼安乐行不。所应度者受化易不。不令世尊生疲劳耶。故佛答云。如是如是。诸善男子。如来安乐少病少恼。诸众生等易可化度。无有疲劳。所以者何。是诸众生世世已来。常受我化。亦于过去诸佛。供养尊重。种诸善根。此诸众生。始见我身闻我所说。即皆信受入如来慧。除先修习学小乘者。如是之人。我今亦令得闻是经入于佛慧。今疏引经。便以义隔成于三轮。此师以根本法轮。是华严经。始成正觉顿宣说故。其枝末法轮。是以根本化之不得。便于一佛乘分别说三。为枝末者。即指华严已后法华已前。并为枝末。三即法华。以为摄末

疏。此判全约化仪等者。第二辩顺违。于中此句。出彼立教所依。依化仪立。非是约法及约根等。而言全者。对前光统。光统三教。一约化仪。二约化法。三约对根。今此师立唯约化仪。疏。据法但有大小下。正辩顺违。唯有大小则无殊半满。亦摄义不周。疏。然法华为于一类开显本末者。此段通经意。以释妨难。恐有难言。依于法华立义。乃是一极之说。如何不依。故今释云。自是立教之人。不得法华之意。法华别为一类滞小之人。故为此说。谓执三疑一。执小疑大故。为开方便门显真实相。真实相者。唯是佛慧。执小乘者。是方便门。非欲会通一代圣教。若以法华之前。皆为枝末法轮。则般若净名胜鬘等经。皆在法华之前。前为枝末则抑诸大乘。又经但云除先修习学小乘者。明知经意。不指般若等为枝末也

疏。又无量义下。上引法华破之。今引他经破之。既云一切时中皆有大小。则先后非独大乘。中间非独小乘也。此皆直破。而不收之者下。开宗立教之中收于此义。故此略无。又前出经意。已是收竟。第四立四教有四。第一光宅中二。先叙昔。后顺违。前中三。初正立。二出所以。三结成。初中四衢即四谛。余可知

疏。以临门牛车下。二出所以。有三所以。故三乘是权。而义势连环。一亦同。羊鹿俱不得故者。羊鹿是虚指。出门不上车。牛车若是实。出门合上车。又并羊鹿是虚指。出门不上车。牛车亦虚指。同彼羊鹿。不上车。上明三皆虚指。约法说者。昔指三乘三界门外。二乘出三界。无有真实证。菩萨出三界。岂有真实证。俱无实证。名不上车。明知三乘皆是权设。二并无体者。既不得车。明皆无体。以无可得故。长者虚指。三车实无。界外三乘。明是方便尽无生智是二乘车体。丈六浅智。是牛车体。二乘之智既非真实。丈六浅智岂有实耶。然上不得约人就法。今明无体直就法明。三诸子皆索故者。复成上义。向若有体。即不合索。诸子皆索。明皆无体。不见羊鹿故索羊鹿。今索牛车。明无牛可见。故彼经云。尔时诸子各白父言。父先所许玩好之具。羊车鹿车大牛之车。愿时赐与。既索牛车。明同无体。故牒索耳。索车是喻。约法云何。古有多释。略要有二。一者机索。二者口索。言机索者。三乘之人。以佛教门出三界苦。谓为究竟不解索三乘。已被淘练。一乘机熟。冥机叩圣。义言索耳。佛知机熟。灵山集会。为说法华一极之旨。即是各赐诸子等一大车。二口索者。已集灵山。三乘三根皆悉启言。求法求记。即是索车。为说与记令其修证。即是等赐。弥勒序品陈四众疑。征佛定因。已是索义。文殊云。诸求三乘人。若有疑悔者。佛当为除断令尽无有余。已许等赐。方便品初云。告诸声闻众。及求缘觉乘。我令脱苦缚。逮得涅槃者。佛以方便力。示以三乘教。众生处处着。引之令得出。已是开权。又云。舍利弗当知。诸佛语无异。于佛所说法。当生大信力。世尊法久后。要当说真实。即是显实。开权显实。已是等赐。亦是许与。身子三请法说。索车。譬喻品初腾疑白佛。说诸喻车。踊出品中弥勒陈疑。请说果车。开示知见。说佛寿量等。即是等赐。三根求记即是索车。佛皆与记即是等赐。菩萨闻是法。疑网皆已除。即时大欢喜。千二百罗汉。悉亦当作佛。皆是赐义。故合喻云。令诸子等日夜劫数常得游戏。与诸菩萨及声闻众。乘是宝乘直至道场。由是故知。三乘皆索。三乘皆赐

疏。是知三皆虚指以为方便者。三结成上义也。由上三段展转相成。以证三乘皆是方便无有实体。故古人云。虚指三车而群子竞驰。火难既夷。乃无有二。岂合有三实以为一。又非殊途而异获哉。故经云。如彼长者初以三车诱引诸子。然后但与大车。宝物庄严安隐第一。然彼长者无虚妄之咎。如来亦复如是。无有虚妄。初说三乘引导众生。然后但与大乘而度脱之。何以故。如来有无量智慧力无畏等诸法之藏。能与一切众生大乘之法。但不尽能受。以是因缘。当知诸佛方便力故。于一佛乘分别说三明。三皆虚指也。由皆虚指即无体故。后得大车。并非本望。若昔大是实。今得牛车何非望耶

疏。此则前三是三乘下。辩顺违。于中有四。一总辩顺理。二明其有违。三会通教旨。显违顺之由。四结成昔义。四乘无失。今初可知

疏。若唯说法华下。第二明其有违。所以违者。以抑昔大乘了义之经皆成权故

疏。是知下。会通教旨。于中又三。一明会不会之意。二明会二会三之意。三明取昔废昔之意。上三段展转通难。谓初有难云。既许昔三皆权。何言抑诸圣教。故今释云。非不许其四乘但昔大不分权实故。成抑诸实教耳

疏。若约会权下。第二会二会三之意。谓有问言。若尔为是会三。为是会二。设尔何失。二俱有过。若会三归一。昔应无实。若会二归一。昔应无权。无权则四乘之义不成。无实乃不抑昔时圣教。此是光宅之意。若作北宗难者。应云昔既有实。会二归一义则明矣。故为释云。会二会三。二俱有理。昔之权实二义亦存。故云尔耶

疏。若开权显实下。第三明取昔废昔之意。谓有问言。若会三归一者。为会昔三而为一耶。为会昔三归今一耶。故今释云。明俱上二义。先明会三为一。则会取昔三。后明会于昔三归今之一。以废昔三立今之一故。约会取则昔小亦取。况昔大耶。以其理不可分行是佛因故。若约废昔。则昔大亦废。况于小耶。以其约教虚设。果亦虚指。故并废也。然开废等言。有通有局。若约局者。约教则废三立一。三教虚设故。约理则开三显一。言有三理覆于一极。开元无三理一极自彰。约行则会三为一。三乘之行皆佛因故。约果则会三归一。三乘之因同归一果故。三乘之果非究竟故。若约通者。唯废一种。则约于教。开会等言并通四种。今疏。从此言约开三显一。则三即是一者。若约理者。昔说三理谓各别证。今会法身是同更无异味。昔言有三是方便门。则闭于一实。今云无三。则一理自显。故云。此经开方便门示真实相。若约行者。昔说三乘之行。行各不同。谛缘度等随修各异。今并得为佛因。谓三行别。则方便之门闭于一实。今会为一。则方便门开。一实显矣。故云。汝等所行是菩萨道。若约果者。昔说三果不同。是方便门闭于一实。今云三果虚设。唯有极果无上菩提。心生欢喜自知作佛。则实相显矣。今疏。先明会三为一。于中二。先正明。后故彼经云下。引证。引二文证。一引药草喻品。证小行即是佛因。二引信解品。证大行是其所有。良以小乘昔有二种下劣之心。一谓自行不成佛。故法华云。我等同入法性。云何如来以小乘法而见济度。又云。金色三十二。十力诸解脱。同共一法中。而不得此事。皆名小行不得佛也。故今引药草以会之。二谓大行非己分故。故净名云。一切菩萨闻此法者应大欣庆。一切声闻皆应号泣声振三千。又云。我等何为永绝其根。于此大乘已如败种皆明大行非己分也。故今引信解以示之。今初。引药草喻中文云。迦叶当知。以诸因缘种种譬喻开示佛道。是我方便。诸佛亦然。今为汝等说最实事。诸声闻众皆非灭度。汝等所行是菩萨道。渐渐修学悉当成佛。释曰。诸声闻等皆非灭度者。是废小果。渐渐修学悉当成佛。是归实义。今但引汝等所行是菩萨道会行之言者。欲明三即是一之义。若约果者。三果皆成佛因。而非佛果。不得云三即是一。又皆非灭度。是下废权之意耳

疏。先所出内是子所知者。即第二引信解品文。文云。复于少时父知子意渐已通泰。成就大志自鄙先心。临欲终时而命其子。并会亲族国王大臣刹利居士。皆悉已集。即自宣言。诸君当知此是我子。我之所生。于某城中舍吾逃走。伶俜辛苦五十余年。其本字某。我名某甲。昔在本城怀忧推觅。忽于此间遇会得之。此实我子。我实其父。今我所有一切财物皆是子有。先所出内是子所知。释曰。此上即委付家业。当说法华经也。一切财物。即万行万德。先所出内者。指于前文。我今多有金银珍宝仓库盈溢。其中多少所应取与汝悉知之。此即是喻慧命须菩提说般若。取与即是出内。以法外化。名之为出。化功归己故称为内。即自利利他之行。皆如般若等中。今法华中。但示如来知见是其所有不广诸行。今疏。欲会三因同为一因。故引二文皆明会行。余略不引

疏。若废权立实义说为四下。第二明会于昔三归今之一。于中二。先会昔成今。二彰今异昔。前中有法喻合。法云。义说为四者。以但废昔三教。言三是权。一实便显。三外无别一实之法。云义说为四。但三为别。一为总耳。如揽三点下喻。斯借涅槃第二三点成伊。彼喻三德。以成涅槃。阙一不可故。彼经云摩诃般若亦非涅槃。解脱之法亦非涅槃。如来法身亦非涅槃。三法若异亦非涅槃。如世伊字。此喻至出现品。当广分别。今借其喻不取其法。谓以三点喻于三乘。以成一伊喻为一乘。别说三乘三皆是权。合三为一故得称实。非三点外更有一点。合云。昔三既别。实不兼权。此合上点别非伊。纵昔日有实实亦不兼于权。今一全兼者。合上伊具三点。成四无爽者结成正义。三别有三。总合为一。故成四也。岂差通途三虚既废故成一实。故经云。唯此一事实。余二则非真。十方佛土中。唯有一乘法。无二亦无三。除佛方便说。又云。吾从成佛已来。种种因缘种种譬喻。广演言教无数方便。引导众生令离诸着。明昔皆方便也

疏。若依昔未显说下。第二彰今异昔。前但合三为一。一无别法。已成四乘。今辩一乘别有法门。则四义昭著。是为昔所未说。而今说之。闻所未闻未曾有法也。谓昔日虽有大乘亦说如来藏性涅槃法身真常之理。未曾显说一切众生皆悉具有如来知见。唯为一事出现于世不为于余。则一乘三乘。昔权今实。于理昭著。故睿公云。至如般若诸经。深无不极。故道者以之而归。大无不包。故乘者以之而运。然其大略皆以适化为本。应劝之门不得不以善权为用。权之为化悟物虽弘。于实体不足。皆属法华固其宜矣。疏。根败之种今并说成者。引净名经证。大迦叶自责云。譬如根败之士。其于五欲不能复利。如是声闻诸结断者。于佛法中无所复益。斯则二乘自知不成佛也。岂非不兼权耶。又云。我等何为永绝其根。于此大乘已如败种。此显烦恼已断不能生也。佛名经云。我等今者犹如败种。虽逢春阳无希秋实。并是声闻不作佛义。今法华三根声闻。皆与受记。一切声闻不在此会。令转宣说。一切众生皆是吾子。则唯实非权。故言今并说成。明今昔有异。上云根败之种。乃有二意。一即根败两字。收净名根败之士。二即败种二字。双收净名及佛名二经败种之义

疏。于文有据下。第四结归昔义也

大方广佛华严经随疏演义钞卷第六大方广佛华严经随疏演义钞卷第七

        唐清凉山大华严寺沙门澄观述

疏。二陈隋下。天台四教中二。先叙昔。后顺违。前中亦二。先师宗。后立教。师宗言陈隋者。故天台传云。陈隋二代。三帝门师。谓陈朝一帝。即是后主。隋有二帝。即文帝炀帝。炀帝为晋王时。即请为菩萨戒师。终于炀帝之时。故云陈隋二代。天台山名。举处辩人。僧名智顗。而言智者。帝为立号。美其德也。承南岳者。故韦虚舟传云。自佛教东流。秘密斯阐。思大师之所证。智者大师之所弘。故思大师一见。便云。昔日灵山同听法华。宿缘所追今复来矣。又入道场澄心云。非汝不证。非我不知。师资传芳。故并序耳

疏。立四教云下。正立中二。先正立四教。后通相料拣。前中四教。即为四别。每教皆有三节。一立名。二所证。三所被。其四教所诠。即四种四谛。一生灭四谛。二无生四谛。三无量四谛。四无作四谛。广如四谛品。今初。一三藏教者立名。至下当释

疏。此教明因缘下。辩所诠理。其因缘之言。通于四教。因缘故生灭。因缘故即空。因缘故假名。因缘故中道。因缘为主故。四教皆带之。言生灭四真谛理者。苦以逼迫为义。集以增长生死为事。道以除患为功。灭以累尽为名。有苦可知。有集可断。有灭可证。有道可修。迷则苦集生。而真道灭。悟则苦集灭。而正道生。有可生灭。故云生灭四谛。苦定是苦等。故得名真

疏。正教下明所被。鹿苑初转法轮。俱邻五人见谛成道等。但有小乘得道。未有大乘得道。故言傍化为菩萨。智度论云。佛于阿含中虽为弥勒授记。亦不说种种菩萨行。故菩萨为傍也

疏。二者通教等者。文分为三。初正立。二引证三解妨。初中亦有三段。初名即以同释通。故法华云。我等同入法性。肇公云。三乘同观性空而得道也。即三兽度河。一水无二耳

疏。此教下。辩所诠。从缘生法。无性即空。非色败空。不要析破。故云即空。若约中论偈明四句。初教即因缘所生法。此教即我说即是空。第三亦名为假名。第四亦是中道义。故此云因缘即空。言无生四真谛者。第二种四谛也。谓解苦无苦。名为苦谛。解集无和合。名为集谛。解灭无灭。解道无道。四谛性空本无生灭。不同初教有可生灭。疏。是摩诃衍初门者。拣非深极。言初门者。以空遣有。未彰妙有中道义故

疏。正为菩萨下。所被机。双明二空。故云正为菩萨。言傍为二乘者。初以空门遣荡小乘执心。令渐通泰。故云傍通。疏大品下。二引证。此双正名及所被机。既三乘当学故。是通教三同禀也。二乘既学即傍为也。云何欲得三乘。当学般若。如云了法无生名般若者。当声闻学无生。便云一切诸法皆悉空寂。无生无灭。无大无小。无漏无为。如是思惟。便于严土利他不生喜乐。但欲趣寂故成声闻乘。若闻无生。知从缘生故无生。从缘灭故无灭。无生无灭因缘之理。如是学者成缘觉乘。若闻无生。便知一切诸法。本自不生今则无灭。即生灭而无生灭故。不碍于生灭。灭恶生善。悲智兼济。成菩萨乘。同学一无生而成三乘故。若欲成自乘。当学无生般若。又如无所得是般若。罗汉得之。实无有法名阿罗汉。缘觉得之不得缘相。菩萨得之心无挂碍。以无所得能得菩提。故言三乘同禀般若。以此义推。则二乘人同学二空也。而云等者。具云欲得缘觉乘。当学般若波罗蜜。欲得菩萨乘。当学般若波罗蜜。此明般若能成一切道果也

疏。然教理智断下。解妨难。谓有难云。此通别教名。皆智论中。共般若不共般若。以立。何不二名共教。三名不共教。而云通别耶。故今释云。通则上通别圆。下通二乘。远近俱通。共但共小。得近无远。故名通耳。别有二义。不名不共。次下当释。又言皆通者。上之八字。字各一义。一教通。二理通等。一教通者。三乘同禀因缘即空之教。二理通者。同见偏真之理。三智通者。同得巧度一切智。四断通者。菩萨界内惑断见思同也。五行通者见修无漏行同也。六位通者。从干慧地乃至辟支佛地。位法同也。七因通者。九无间同也。八果通者。九解脱二种涅槃界同也。通义虽八。因教方知。故名通教。余教例知。疏三别教者下。文中分二。先正释。后不名下。通妨难。初中亦三。立名可知。此教下。二明所诠。因缘假名当中论第三句。无量四真谛理。即第三四谛。言无量者。苦有无量相。非诸声闻缘觉所知。集灭道各有无量相等

疏。的化菩萨下。三明所被机。即华严法界品意

疏。不名不共下。二通妨难。初牒疑情。谓有难言。既言别即不共。便是智论不共般若。何不名为不共教耶。疏。兼欲下。解释以别有二义。一不共二乘义。如上说。二历别不融。故名为别。若云不共不兼后义。故云兼欲拣非圆故。疏。以一因下。出非圆之相。一因迥出者。对他显别。不同通教。三乘通修。今一道出离。迥超二乘。亦离二边。以显中道故。一果不融下。当法明别。一果不融者。果别谓三德。三身各不融故。不能一德一切德等故。历别而修者。当体以明因别。修布施时。非戒等故。初地不知二地功德等故。疏。不德因果圆融者。因果互望不融。不能因该果海果彻因源故

疏。四圆教下。文中亦二。先正立。后对前结成。前中又二。先释义。后引证。前中亦三节。释名可知

疏。此教下辩所诠。略无无作四谛之言。言不思议因缘二谛中道者。即论第四句。亦是中道义。而言不思议者。佛性中道故。又因缘即空故。不可作因缘思。即假故不可作空思即中道故不可作二思。即一而三。即三而一。为不思议。因缘二谛。即真俗二谛。中道即第一义谛。三谛义也。又融二谛即是中道。不似通教多约真谛。别教多约俗谛。言事理具足者。通多约理。别多约事。圆中举事乃是即理之事。举理乃是即事之理。无理不明无事不具。言不偏不别者。不偏。谓非偏真。不滞一边故。不别者。谓不历别。必须融摄故。余如大意合离中辩

疏。但化下。三所被根也。最上利根。即圆融之机也

疏。华严经云下。引证。即晋经。今当七十三。经云。佛为说修多罗。名圆满因轮。偈中云。彼佛知众根将熟。而来此会化群生。显现神变大庄严靡不亲近而恭敬。佛以一音方便说法灯普照修多罗。无量众生意柔软。悉蒙与授菩提记。义则大同。名有小异耳

疏。别则教理等下。对前结成。谓别圆各有教等八事。别教八者。一教别。谓恒沙佛法。别教菩萨不通二乘。二理别者。藏识有恒沙俗谛之理也。三智别者。道种智也。四断别者。尘沙无知界外见修无明断也。五行别者。历劫修诸波罗蜜。自行化他之行也。六位别者。谓三十心伏无明。是贤位。十地发真断无明。是圣位。是谓别也。七因别者。无碍金刚之因别也。八果别者。解脱涅槃四德。异二乘也。圆教八义者。一教圆。正说中道。言教不偏也。二理圆。中道即一切佛法也。三智圆。一切种智也。四断圆。不断而断。无明惑断也。五行圆。一行一切行也。六位圆。从初住一地具足诸地功德也。七因圆。双照二谛。自然流入也。八果圆。妙觉不思议三德之果。不纵不横不并不别也。故云圆则教等皆圆

疏。又此四教下。第二通相料拣。于中三段。一立教所因。然依中论三观之偈。而用此偈。有三重不同。一则一教之中各成三观。如前大意合离中辩。二四句各配一教。如向立教中明三离合。用之。以成四教。如今文是。如云从假入空。义同因缘所生法。我说即是空。从空入假者。义同亦为是假名。以连第二空句故。从假入中者。义同亦是中道义。以连上假名句故。今合初二句。成初二教。通用四句。为别圆两教。从假入空析体异者。谓观因缘假有之法皆悉空寂。云何知空。若云色者唯五根五境及无表色。此十一色合成色蕴。色蕴故空。又于此中一一推征。谓一眼色。从八微生。假合成色。析至极微。都无实色。故曰色空。此名析法成藏教也。若云因缘所生。即无自性。举体即空。不须析破。如净名云。色性自空。非色灭空。体达此色。有来即空。故云体法明空通教起也。从空入假等者。即三观逦迤故成别教。谓先观真谛本来空寂。出观入俗涉有化生。净佛国土等。故云从空入假。由入俗。故又多流散。次观中道动寂无二。远离空有动寂二边。三观不在一时。故名别教。三观一心等者。即空即假即中。即一而三。则三而一。非先非后。非一非三。亦如前大意合离中第四义辩

疏。又此四教下。第二辩其所释。拣异余师。余师或云。般若是空教。法华是中道教。涅槃是常住教。此是圆教。此是偏教。局定一经。今则不尔。故云一部之中容有多故。而言容有者。不必具多。或一或二或三或四。故彼师云。三藏但。谓明小故。方等对。谓呼净名等为方等教。对小说大。般若带。谓带小说大。华严兼。兼别说圆。法华无复兼但对带。唯说圆教。但者唯一教。对则具四。如净名云。诸仁者。是身无常无强无力无坚。速朽之法不可信也等。即藏教也。迦延章云。不生不灭是无常义等。即通教也。富楼章云。无以秽食置于宝器。无以琉璃同彼水精。大非小分。即别教也。如须菩提章云。不断淫怒痴亦不与俱。不坏于身而起一相。不灭痴爱起于明脱等。皆即圆教。故具四也。般若部中唯有三教。无前藏教。已被诃破。不为彼故。华严兼者。以寄位修行。行布罗列。兼斯一分故。法华唯此一事实故更无余教。而涅槃十仙果证罗汉者。具于四教。若尔宁异方等。虽有四教而皆知常住。故得异前。垂入涅槃。意欲普收。故得具四。如文有之

疏。又更以四种下。第三用四仪式。复成八教。谓一顿教。二渐教。三不定教。四秘密教。初即华严经。初成顿说故。二即始从鹿苑终至鹤林三乘一乘。并称为渐。若约化法顿教摄二。谓圆及别。渐教具四。谓藏通别圆。然此二教。本是刘蚪初立。以南中诸师加于不定。三教渐中初开有三。即是岌公。故云渐顿如岌公。后二即于不定教中开出。而与前不定不同。谓从一音异解中分成此二。净名云。佛以一音演说法。众生各各随所解。普得受行获其利。斯则神力不共法。释曰。各闻不同。即所说不定。谓闻大者知彼闻小。闻小者知彼闻大。即名不定。故云若互相知名为不定。若闻小乘。不知彼人闻大。闻大乘者。不知此人闻小。即名秘密。故云互不相知。谓闻大不知彼闻小。小即于闻大者为秘密。闻小不知彼闻大。大即于闻小者为秘密。此之二教所说化法。俱通藏通别圆故。顿中唯二化法。余三具四教法。是故以化仪取法。华严之圆。是顿中之圆。法华之圆。是渐中之圆。渐顿之仪。二经则异。圆教化法。二经不殊。大师本意判教如是。又詺圆教亦名为顿。故云圆顿止观。由此。亦谓华严名为顿顿。法华名为渐顿。以是顿仪中圆顿渐仪中圆顿故

疏。此师立义下。第二辩顺违。复二。初聪明顺违。初顺。后但三藏教下。辩违。以名滥故。故静法与作四种过。一滥涉大乘失。以大乘亦有三藏。应名三藏教故。二大无三藏失。以彼不名三藏故。三特违至教失。彼云不得亲近小乘三藏学者。有小乘言拣异大乘故。明知三藏不唯属小。四有不定失。以小乘诸部有不立三故。如经量部。但立经律二藏故。有立五藏。成实三外立于杂藏及菩萨藏故。以有此四失故。总许其破。云名似小滥。正许初失。然下皆为通

疏。所以尔者下。别为会释。于中三段。初别释藏教难。文有四节。以通五难。谓上四失之外。第五云何不立小乘。难言四节者。一出三藏名之所据。通违至教之失。及滥涉大乘失。谓大小乘论同立此名故。滥涉之失不在于己。若有难言。智论之内小乘之名随自宗语。三藏之称随他宗言。非共名也。故今释云。智论是随他名。成论小乘。云何亦名三藏。岂随他宗耶。即由上义不违至教。以罗什译经多依智论。小乘三藏为欲成文。二言双举。小乘之过不在三藏。但责其心小耳。故诃小乘。不责所诠三藏

疏。初对旧医者。第二明立三藏所以。四教之初。敌对旧医之三故。须特立三藏。三又条然不同故。无滥涉大乘。所以偏从立号。亦犹五尘皆色。而色独得总名。故三藏虽通标总名。便为小乘别称。言旧医者。即涅槃第二。新旧二医之喻。旧医即喻外道。戒定慧者。然各有二。一邪。二正。旧邪戒者。谓鸡狗等。正戒者。谓十善道。旧邪定者。九十五种所说鬼神之法。或能知世吉凶现神变相也。正者。即四禅四无量四无色发五通是也旧邪慧者。因身边见。发诸邪智拨无因果。食粪裸形等也。正者。即因身边见发诸世智。说有因果诸善法也。今佛说三藏教。所明戒定慧。即是新医从远方来。晓八种术。如来所说。一戒者。即五种得戒。发一切律仪无作有作。如五部毗尼是也。二定者。即依八背舍入九次第定等。发六神通是也。三慧者。即是生灭四谛。破身边二见六十二见。发真无漏。成十一智三无漏根是也。此戒定慧。一切外道尚不闻名。况有其分。故云初对旧医等。言三事条然不同者。上对旧医下对通别圆教。由不同故立三藏名。即由此义诸部多明三藏。从多立名。非不定失

疏。通教融三故下。第三明后三不称三藏所以。即正通大无三藏失。谓大乘虽有三藏。各有融拂等义。故不立名。非无其体。言通教意融三者。融至空寂故。故法句经云。若说诸持戒。无善无威仪。戒相如虚空。持者欲迷倒。若学诸三昧。是动非坐禅。心随境界流。云何名为定。无智无得方。名真智般若。无知如智双寂等。皆是意融三也

疏。别教依一法性而显三者。以一法性统之。亦不得迢然有别。一一法门不离法性。故云。以知法性离五欲过故。随顺修行尸波罗蜜。以知法性无乱想故随顺修行禅波罗蜜。以知法性本有智慧光明无痴暗故。随顺修行般若波罗蜜等。疏。圆教三一无障碍者。即三而一。即一而三。非唯一体统之。一学之中摄三。皆尽。一行尚具一切。何况三耶

疏。所以不名小乘下。第四明不名小乘所以。通第五难。谓有难言。何以不名小乘。强立三藏而招多失。故今通云。以有大乘故。不得名小。彼教之中亦有菩萨。谓是大乘。大乘之中望之。皆称三藏小教。言六度菩萨者。谓三僧祇耶别修六度。各有满时。皆是有漏未入见道。以无常狼伏贪爱羊。令烦恼脂消功德身肥。直至菩提树下。三十四心一时断结。以见谛十六心八忍八智。及非想一地修惑分为九品。各有九无间九解脱。成其十八。故有三十四耳。广如俱舍涅槃等说。言成真佛者。大乘说此断惑成佛。乃是八相化身。小乘谓为实成故。属小教。故涅槃中詺此执实。以为二乘曲见

疏。故藏通别圆之义下。第二总释四教难。谓有难言。三藏教亦有通别圆义。乃至圆教亦有藏通别义。何以不得互名而局定耶。故今答云。四教虽皆四义互有余三义。傍不成本义。如三学大德禅师。虽有戒定慧但成禅义。以禅长故余但兼故。不尽妙故不名律法。余二亦然。言互有者。三藏教中亦通有无。常三乘同禀。亦别为菩萨说四弘六度。亦为菩萨说一切种智故。故藏教有三矣。通教有三者。亦说三藏故。应名三藏。亦说道种智故。应名别教。亦说一切种智。应名为圆教别教具三者。亦说三藏故。亦说无生空理故。亦说中道一切种智故。圆教亦说三藏故。亦说真空之理故。亦说历劫阶位修行故。亦应得有余三名。故总答云。虽则四教各傍兼有。核定不成。云何不成。初藏教通等不成者。虽有同禀无常。二乘一生得发真断结。菩萨三祇不证。故通义不成。虽为菩萨别说四弘六度。不诠别理不断别惑。由约生灭四谛而起于见。岂得称别。虽说一切种智者。菩萨因中不得即具种智。又此种智唯照二谛。不照中道。岂得称圆。是则核后三义不成。但成当教三藏义耳。通教三不成者。虽说三藏。一相无相故。又云。已得故虽说道种智。秖照界内俗。非如来藏恒沙功德故。虽说一切种智。秖照二谛。非照中道不思议二谛故。故核三教之义不成。但成通教义耳。别教三不成者。虽说三藏恒沙佛法。无量戒定慧。异生灭三故。虽说无生空理。是不可得空。非但是空二乘同见故。虽说中道一切种智。非初住发心即具一切种智故。故藏通圆三义皆不成。但成别义耳。圆教三不成者。虽说三藏。皆约真如实相佛性涅槃故。虽有真空之理。即佛性真空。二乘不知。何况得入。虽说历别阶位法门。无不与实相相应。一摄一切故。是则藏通别三义皆不成。但圆教义耳。故云核其定实。余三不成。但成当教中义耳

疏。但判华严下。第三重通圆别二教。定其去取。以彼判诸经。云华严兼。谓兼别教。是则迷其行布。谓为别教。但取圆融。以为圆教。离成二教各失一边。合而融通方成了义。顺华严宗。由行布圆融二互相摄故。如前行位中辩。若与之者。则名异义同。故无大过。若夺之者。则失华严本意。故今不取。是故此段名定其去取。余义广在四教。要略已备

疏。三唐初海东中。先正立。后顺违。前中二。先正立。然后三乘共学下。解释。是则未明法空成别。非四谛十二因缘等别。具明二空为通不取三乘共学故。前二依天台而有小异。以不共释一乘。非合三为一

疏。然此下。辩顺违。先出义本。自言下。正辩顺违。良以自谦非摄一切故得无失。若有别理推在摄不尽中故

疏。四贤首弟子下。亦二。先正立。后顺违前中五。一总以标举。二论云下。引论为据。三言四教下。正明所立。四初教谓下。别示其相。五广如下。结广从略。彼疏又明。此所立教。依所诠法性。以显能诠。初教法性全隐。次一法性分显。三即分隐。四即全显。法性虽一显有不同。故成四耳。若约乘收其第二教即是小乘。三即三乘中大乘。四即一乘。此亦多同光宅四乘

疏。然今下辩顺违中。先别破。后结非。前中又二。先破初一。后破后三。今初。有邪正混杂过。若对教主下。遮救。恐有救言。若不识邪。安能知正。邪正对辩。则是皂白分明。故今遮云。若欲尔者。应总分邪正。然后于邪正中。方可分其大小等耳。故为立式如此。方先分三教。于儒教中方辩九流七经。于道教中方论道德之别。于佛教中方论大小权实。则无混滥。不然即如西域先分内外。外中方分六师或十宗等。等者。等取内教之中分大小等。言六师者。净名云。一富单那(名也)迦叶(姓也)。二末伽梨(名也)俱奢梨(母名也)子。三删阇夜(名也)毗罗胝(母名)子。四阿蓍多(名也)翅舍钦婆罗(弊衣也)。五迦罗鸠驮(名也)迦旃延(姓也)。六尼揵陀(名也)若提(母也)子。此六各起一见。一起断见言。一切法空。无君臣父子忠孝之道。二末迦梨俱舍梨子。起常见言。一切苦乐不由行业。性自有之。三起自然见。执道不须修。八万劫苦尽。即自然解脱。如转缕丸于高山顶。旋尽自止。立解脱因。谓解脱为因。非因计因。是邪因也。拨道不须修。是邪见也。四即苦行外道。自拔头发。五热炙身。即得解脱。非道计道。亦戒取也。五起边见。执一切法亦有亦无。不同佛法因缘故有无性故无。由执有即定性之有。即是常见。执无即定性之无。即是断见。断常乖中。合成边见也。六谓一切苦乐果报。皆由过业不藉现缘。前世业尽即苦尽。纵现修道亦不能断。此人信有前世业为因。非邪见拨无现缘。即是少分邪见。道能尽苦拨无不能。道计非道。亦是邪见。六师之计。具如涅槃。此六各起一见。如第六地引

疏。又依涅槃为半满下。破后三教。然彼师之意。以真如有二分。具说二分为具分。唯说不变为一分。但明生空为半。具显二空为满。今难半满乃有二义。一若约第二义已称为满。不合唯得一分。若满中有一分义者。涅槃满字亦唯一分。则亦未满故云不应复有一分之言。一分之言。意在第三教也。二有救言。涅槃但约二空论半满。不约真如等者。则违涅槃。涅槃既云空者。所谓生死。不空者。所谓大般涅槃。何得言唯约二空。而论半满。是知二空。犹是涅槃半字。双照空不空。方为满耳。故彼经云。声闻之人但见于空。不见不空。菩萨见空及与不空。故疏云。岂彼不说妙有而诃空耶。故其所立下。总非也

疏。一波颇三藏者。据般若灯论序云。中天竺三藏。波颇蜜多。唐言朋友。学兼半满。博综群诠。丧我怡。神搜玄养性。游方在念。利物为怀。故能附杙传身。举烟召侣。冒冰霜而越葱岭。犯风雪而渡沙河。时积五年。途经四万。以大唐贞观元年岁次娶嘴。十一月二十日。顶戴梵文至于京辇。昔秦征童寿苦用兵戈。汉请摩腾远劳蕃使。讵可方兹感应道契冥符。家国休祥德人爰降。有司奏见殊悦帝心。其年有敕。安置大兴善寺。仍请译出宝星陀罗尼经。般若灯论庄严论等。疏。阿含具云阿爰摩。此云教也

疏。此释名局下。辩顺违。以上立义各指一经。一经之中。皆有四谛观行等。诸如华严涅槃皆有四圣谛品。广显其相。大乘等经非无观行等故

疏。二贤首所立等者。以下文依之。故今略指。然昔来更有耆阇法师。立六种教。一因缘宗教。二假名宗教。三不真宗教。谓说诸法如幻化理。四真宗教。谓说诸法真空理故。五常宗教。说真理恒沙功德常恒等故。六圆宗教。如诸师今不序者。前四名即衍公四宗义。在立宗之初。第五同第五时。第六同诸师圆教。故略不引。又真宗说真空理。常宗说真理恒沙功德常恒。既真宗真理非常宗。应同无常。又三与四。但法喻之别。故并不引。上来此方立教竟

第二序西域中。文分为二。先正序。后顺违。前中贤首起信论疏。初义理分齐中序之。于中二。一总序源由。二双释所立。今初。然真谛笈多波颇三藏。皆是西域。而躬亲在斯分教。故属此方所收。下二大德。本是西方分教。故云西域耳。那烂陀者。此云施无厌。然案唐三藏传。似智光乃戒贤弟子。而今云同时者。或恐名同人异。或是师资。不妨立义所宗复异。又准无行禅师书亦云。西方有二宗并行。一宗无著天亲。一宗龙树提婆。龙树之宗。玄标才举。则无著牵羊。翎羽暂腾。则陈那乱辙。则同时定有二宗。又案西域记。唐三藏初遇龙树宗师。欲从学法。师令服药求得长生。方能穷究。三藏自思本欲求经。恐仙术不成辜我夙愿。遂不学此宗。乃学法相之宗。若藏和上义分齐云。法藏于文明年中。幸遇中天竺国三藏法师地婆诃罗。唐言日照。于西太原寺翻译经论。躬亲问之。故有凭矣

疏。戒贤远承下。第二双释所立。即为二别。二中文皆有五。一师资相承。二所凭经论。三正显所立。四彰了不了。五结成所凭。今初。戒贤中初。师资相承中。弥勒位极此为上古。无著初地此为中古。护法难陀未有得圣之文。但是当时英彦。化世未久故云近踵

疏。依深密等者。二所凭经论。等取佛地等经瑜伽。等取对法显扬等法相之论。余并可知

疏。立三种教下。三正显所立。于中先总后别。总中以法相大乘为了。则显法性为不了。唐三藏师宗者。具如西域记及三藏传广说

疏。谓佛初下。别显三教。即为三别一一教中各有三定。一时定。谓有初时等故。二法定。谓有空等故。三经定。谓指阿含等故。三性等义至下当辩

疏。具说三性三无性等者。此有两重。一约三性。则初时约依他说有。二约遍计说空。三具说三性。则遍计是空。依圆是有。以为中道。二者约三性皆有。约三无性皆空。第一时中说三性皆有。第二时中总说诸法皆悉无性者。约三无性密意说耳。故唯识云。即依此三性。立彼三无性。初则相无性。次无自然性。后由远离前所执我法性故。佛密意说一切法无性。谓若显了说。则双明三性三无性方是中道。故为尽理

疏。是故于彼下。第四明了不了。然二宗义别。下说十种。且就深密。略有四义。一约三性三无性。二约心境空有。三约一乘三乘。四约成佛不成佛。即五性一性义。此中且约三性空有。论了不了。前第三时合约三性三无性论。余二门义略不明之。下别会中。隐显而出疏。此依深密下。第五结成所凭

疏。二智光下。疏文亦五。同前标列。初师宗中文殊对弥勒。龙树对无著。青目清辩对护法难陀。护法难陀注唯识论。青目注中论。清辩亦注中论。造掌珍论

疏。依般若等下。二所凭经论。般若等经等取涅槃法华等经。中观等论等取门论百论智论

疏。亦立三下。三正立可知。疏。又初渐下。第四明了不了。上约心境空有。以立三时之教。今约三性空有。以明了不了义。盖影略耳。言以彼怖畏此真空者。小乘闻空。谓无物为空。如空泽之空。则毕竟都无。恐成断灭。若必无者。何有因果生死涅槃。徒事勤苦修有何益。故经云。宁起有见如须弥。不起空见如芥子许。故生惊怖。今存假名。但除其病而不除法。故存依他之假有。以接小心之劣机

疏。后时下。第三时教缘生即空者。缘生即依他。依他即空。不存依他空遍计也平等一味者。空有一味。非空外说有。有外说空。空有相即故无异味。见空即是见有。见有即是见空。空有二体既同。何要偏留依他但空遍计

疏。此三次第下。五结成所凭。般若灯论本颂。即中论五百偈。题云分别明菩萨释曰。分别即智。明即是光。人译异耳。释论称为般若灯者。照了般若。般若无此不可见故。又体即般若。照物如灯。大乘妙智经。未见经本。但依贤首引耳。或云即般若经。般若是智。摩诃是大。亦可妙故。又波罗蜜亦同妙义

疏。然此二三时下。第二辩顺违。然藏和尚起信疏。问云。此二三时可和会不。自答云。无会无不会。无会者。各各为人悉檀。悉檀者。智论云义宗也。诸佛说故。并是圣教。随缘益物。何须会之。故云无会。言无不会者。即可会也。今会此义有其二门。一约摄生宽狭。言教具阙。以明了不了。二约益物渐次。显理增微。以明了不了。初中二。一约摄生宽狭者。深密宗中。初唯为小。次唯为大。此二时中狭故非了。第三时中普为发趣一切乘者。宽故为了。二约言教具阙者。初唯说小。次唯说大。各有所阙故非了义。于第三时具说三乘。具故为了。第二门内亦有二意。初约益物渐次者。谓妙智经意。初唯益小故非了义。次虽通益大小。不能令趣寂二乘得大菩提故。非了义。第三时中普得大益。方为了义。二显理增微者。初说缘生实有。次说假有故非了义。第三时中显理至空。会缘相尽故。为了义。依此会释二宗。各有了不了义。此贤首意。谓约初门。则法相宗为了。法性宗非了。若约后门。则法性宗为了。法相宗非了。既皆二义了。二义不了。于理则齐。今观贤首之意。多明法性。何者。有二义故。一以摄生宽狭。对益物渐次。则摄生宽为了。不及益物唯大为了。以言教具阙。对显理增微。则言教具为了。不及显理相尽为了。思之可知。二者言中虽云各有二了有二不了。深密宗中二种了义。亦成不了。何者。如摄生中。以第二时唯摄大为不了。第三时具摄为了者。则得纯金。何如杂铁。纯菩萨众。何如凡小同居。法华唯为菩萨。何如昔日被三。是故应云唯摄大机为了。总摄三根为不了。又如言教具阙中。以第二时不具为不了。第三具说三乘为了者。言皆阙典。应为不了。杂以无稽。应当是了。纯卖真金。应为贫士。瓦木杂货。应为富商。法华唯说一乘。何如昔开三异。是故应云唯说一极方为了义。杂说三乘即为不了。上二本是法相宗为了。今皆成不了。后二又或法性是了。则四不了皆属前宗。四种了义皆在法性。恐法相者。是非心生故。疏不引之。乃别谓和会耳。疏文分二。先总明顺违。后各别会释。今初分三。初总非前立。谓既俱圣教。不可受一非余。二互相违。不可二文双取。故云不能。二深密经意下。会释二经。恐有问言。若并不许。其如二经。有文如何会释。故今为显二经之意。各有所为。不可偏执。偏执则互相违。三得斯意下。结成和会。若得经意二家俱得。受一非余则二家俱非故。离之则两伤。合之则双美

疏。然欲会二宗下。第二各别会释。于中三。初标列章门。次广会初二。后通略会释。今初十对。句各一对。皆先明法性。后辩法相。如云一乘三乘对。则一乘是法性。三乘是法相。余九例知。初二次下。广明。后八义分齐中具显

疏。且初二义下。第二广会初二也。于中二。先双标二义。后别显二相。所以双明者。以初二义互相成故。谓若立五性为了。则三乘为了之义自彰。以有声闻缘觉二定性故。则成二乘。有菩萨性成菩萨乘。不定性人通成三乘。无种性人三所不摄。则人天乘收。则五乘亦具。若以一性为了。则一乘义成。等有佛性。故名一乘无不成佛。故涅槃云。佛性者名为一乘

疏。如法相下。第二别显二相者。先法相宗中二。先标所宗。后故深密三时教下。引文成立。总为二段。一明三乘为了。一乘为不了。后明五性为了。成前三乘。前中引其二经。初引深密。虽明有性无性意成三乘。言初皆不成者。小乘中说独佛一人有大觉性。余不说有故皆不成佛。次一向成者。是第二时中唯说一乘。一切众生皆得成佛。为一向成。尽成则太过。尽不成则不及。故皆方便并为不了。以初未堪闻大一向抑故。第二时中劝令欣佛。一向扬故。第三时中依理正说。有性皆成非不及也。无性不成非太过也。故称实为了。上明三乘是了之证。又初二卷下。证一乘是权。后引胜鬘。亦但证一乘是权耳

疏。大般若下。第二明五性为了。成前三乘。则显一性一乘皆非了。也。于中总五段。引经而三论附出。即分为五。一引般若说有五性。虽无第五。前四既有。无性必然。前三可知。第四云虽未已入正性离生者。谓不定性人未入见道。则容不定。若入见道。则名正定聚。不容不定。如入声闻见道。终无回心作菩萨人。言离生者。见惑过患。如生食在腹。若入见道。能离彼生。故云离生。至下更释

疏。深密第二下。引深密经。于中二。初指同前文。后又云一切趣寂下。证有趣寂。若有趣寂。则五性义成

疏。又十轮下。第三引十论。明定有三乘。以成五性。若无五性无三乘故

疏。故楞伽下。第四正明五性。庄严瑜伽二论例同

疏。善戒下。第五引善戒地持。立有二性以成前无性。故彼论云。种性有二。一有种性。二无种性。彼论释云。种性者。无始法尔六处殊胜。展转相续等。而言亦云者。全同楞伽。以前不引彼经所释故。今例释。不欲繁文耳

疏。若法性宗下。疏文亦二。先标所宗。后法华下。引证成立。长分十段。一引法华。双明一乘一性。二引涅槃。明乘性相成。三重引法华。明无趣寂。四引涅槃第九。明无无性。五引经释论。结成正义。六广引诸经。遮救定性。七引涅槃。遮救无性。八引法华。遮救趣寂。九释胜鬘。会一乘方便。十以法华。结成破立。今初分二。先正立一乘。后立一性释成一乘。今初。十方佛土中等者。即第一方便品偈。上三句正立第四句释疑。言无二亦无三者。古有多说。大乘法师云。二即第二。三即第三。以菩萨乘胜故为第一。此即生公意。而未尽其旨。生公云。二者第二乘。三者第三乘。亦应无第一。第一不乖所以大故不无之。既无二三。一亦去矣。意云。今日一乘深有玄致。所以称大。所以大者。义理深也。昔三乘中大乘既未融。余二则立为权。若约悲智。万行不乖今日之一。故云不乖所以大故不无之。言既无二三一亦去者。昔说有三。二既不立。大岂独存。以不收二乘故。又权指故。亦同羊鹿。俱不得故。如光宅四乘中说。若天台等意无二者。无有声闻缘觉之二乘。无三者。总无昔日三乘。以皆非实故。宗说不同。任情去取。若望经意。但立一实为真趣。举二三皆悉不许。不论大小。如说世间此人独立。更无与比。非要别指张王二人。下句释疑。疑云。若唯有一。昔何说三。又华严经云。或有国土说一乘。或二或三或四五。如是乃至无有量。故今释云。若以如来方便。则多少皆得。十方国土及昔说有三。是方便耳。非真实也。又次下经云。但以假名字。引导于众生。疏。又云初以三乘等者。此引第二经。重成三皆是权。若具引者。经云。如彼长者初以三车诱引诸子。然后但与大车宝物庄严安隐第一。然彼长者无虚妄之咎。如来亦复如是。无有虚妄。初说三乘引导众生。然后但以大乘而度脱之。释曰。此文皆明先三是权。后一为实。纵饶会二归一。亦是三为方便。唯一为实耳

疏。以性唯一下。引其二文。明唯一性证成一乘。此句总以一性成一乘。若有多性容有多乘。既唯一性并同作佛故。唯一乘耳。疏。故云诸佛两足尊下。引证。初引第一未来佛章。故彼偈云。未来世诸佛。虽说百千亿。无数诸法门。其实为一乘。诸佛两足尊。知法常无性佛种从缘起。是故说一乘。是法住法位。世间相常住。于道场知已。导师方便说。今但引两句。显诸法无性。成一性义耳。然上三偈。诸释不同。今直解经文。初一偈明当佛开权终归一实。故云其实为一乘。次偈释说一乘所以。以唯一性故。谓若有二性容有二乘。既唯一性故说一乘耳。知法常无性者。知即能证知。法谓所证知。法即色心等一切法也。常无性者。所证理也。即是真如无性之理。觉诸法故。云何常无性。谓色心等。从本已来性相空寂。非自非他。非即非离。湛然常寂。故曰无性。而言常者。谓本来即无。非推之使无。故曰常无性耳。佛种从缘起者。然有二义。一约因种。因种即正因佛性。故涅槃云。佛性者。即是无上菩提中道种子。此种即前常无性理。故涅槃云。佛性者。即是第一义空。无性即空义也。缘即六度万行。是缘因佛性。起彼正因。令得成佛。是故说一乘者。唯以佛性起于佛性。更无余性故说一乘。称理说也。体同曰性。相似名种。故关中云。如稻自生稻不生余谷。此属性也。萌干花粒其类无差。此属种也。二果种性。关中云。佛报唯佛其理不差。即性义也。说法度人类。皆相似此种义也。果之种性。缘真理生。故云从缘。故释此偈云。佛缘理生。理既无二。是故说一乘耳。意云。证理成佛。称理说一。此中知法常无性偈。全同出现。出现品云。如来成正觉时。于其身中普见一切众生成正觉。乃至普见一切众生入涅槃。皆同一性所谓无性。乃至云知一切法皆无性故。得一切智大悲相续救度众生。谓知无性。佛性同故。准于下经。以知无性。尚得一成一切皆成。况无不说一乘而度脱之。后偈又云。是法住法位等者。重释前偈。言是法者。即前所知之法。所以常无性者。由住真如正位故。由缘无性。缘起即真。由即真故。故上云无性。言法位者。即真如正位。故智论说。法性法界法住法位。皆真如异名。世法即如故。皆常住。谓因乖常理。成三界无常。若解无常之实即无常而成常矣。则常与无常二理不偏。故涅槃经况之二鸟。今于道场证知一切世间无常即真常理。犹悬镜高堂万像斯鉴。二而不二不可言宣。以方便力假以言说。一尚假说况有二三。故知前偈即一性之文。疏中略要但引一句耳。疏。又第三下。此引药草喻品证一性义。故彼经云。众生住于种种之地。唯有如来如实见之明了无碍。如彼卉木丛林诸药草等。而不自知上中下性。如来知是一相一味之法。所谓解脱相离相灭相。究竟涅槃常寂灭相。终归于空。今但略引二句。以此证知。则明三乘之人不知差别即一。唯佛究之无三无二。言解脱者。真解脱也。故第二经偈云。为灭谛故修行于道。离诸苦缚名得解脱。是人于何而得解脱。但离虚妄名为解脱。其实未得一切解脱。释曰。一切解脱即真解脱。真解脱者即一解脱味。故无二味安有三乘。故又云。常寂灭相。即性净涅槃。是上世间相常住也。故皆一性

疏。涅槃亦云下。第二引涅槃明乘性相成。非但唯一性。故说一乘。经明一性即一乘也。即第二十七经云。善男子。毕竟有二种。一者庄严毕竟。二者究竟毕竟。一者世间毕竟。二者出世间毕竟。庄严毕竟者。六波罗蜜。究竟毕竟者。一切众生所得一乘。一乘者。名为佛性。以是义故。我说一切众生悉有佛性。一切众生实有一乘。以无明覆故不能自见。释曰。以皆有佛性故唯一乘。又佛性者。即是第一义空之理。理能运载。即是乘义耳。疏。师子吼者名决定说者。亦即第二十七经。师子吼品。释曰。若不宣说一切众生皆有佛性。则是野干鸣。设千万年在于佛法。终不能作师子吼也。疏。三十三又云下。引证佛性即是一乘。非但因同果亦同也。亦师子吼品。彼明海有八德。下具合之。此合第三一味之义。经中但加标云三者一味。释如疏文。一甘露者。正显一味。甘露以喻涅槃

大方广佛华严经随疏演义钞卷第七大方广佛华严经随疏演义钞卷第八

        唐清凉山大华严寺沙门澄观述

疏。又法华第三云下。第三明无趣寂。既无趣寂。则无定性二乘。一乘之义亦已显矣

疏。引三文。谓法华智论及法华论。今初。即化城喻品。结会世尊所化弟子。经云。尔时所化无量恒河沙等众生者。汝等。诸比丘及我灭度后未来世中声闻弟子是也。我灭度后下

疏。全同。言余国者。有云。随举娑婆之外一国。即是若天台云。余国者。方便有余土也。彼立四土。一凡圣同居土。即法相中变化土也。二方便有余土。三实报无障碍土。即是法相中报土。通自他受用。四常寂光土。即法性土。方便一土。法相所无。天台依凭智论而立。智论即下所引。九十五文。论曰。阿罗汉先世因缘。所受分段身。必应当灭。住在何处。而具足佛道。答。得阿罗汉更不生三界。有净佛土出三界外。乃无烦恼之名。于是国土佛所闻法华经具足佛道。如法华经说。有阿罗汉我于余国等。引文全同前疏。又云。若尔罗汉受法性身。应疾得菩提。何以稽留。答云。以舍众生及舍佛道。又复虚言得道。虽不受生死。于菩提根钝。不能疾得。不如直往菩萨。释曰。智论之文昭然。与法华符会。定知虽出三界不趣寂也。故疏结云决定回心

疏。法华论中四声闻内等者。引论成上无趣寂义。先引后释。今初。然论云。言声闻受记者。声闻有四种。一者决定声闻。二者增上慢声闻。三者退菩萨心声闻。四者应化声闻二种声闻如来与记。谓应化声闻退已还发菩提心者。若决定者。增上慢者。二种声闻根未熟故。如来不与记。菩萨与授记。菩萨授记者。方便令发菩提心故。疏文略引耳。言退菩萨心得记者。即如身子二万亿佛所。已曾受化。又次下云。我今还欲令汝忆念本愿所行道故。则非独身子。又四大声闻。自陈舍父逃逝。则已先化。第三周中引大通智胜佛所曾已广化。皆是退菩提心。言应化者。如富楼那内秘菩萨行外现是声闻。又言。是故诸菩萨作声闻缘觉。又阿难自忆本愿。偈云。方便为侍者。罗睺罗偈云。罗睺罗密行。唯我能知之。现为我长子。皆应化声闻也。故知夫能对扬圣教。影向其迹。靡不是权。而独言富楼那是应化者。亦抑法华诸罗汉耳。言菩萨与记者。论主次前自云。如下不轻品中应知。礼拜赞叹作如是言。我不敢轻于汝等。汝等皆当作佛者。示诸众生所有佛性故。此上皆论。而安国法师不许此义。云何有昔时菩萨。预记今日会上声闻。即诸弘法菩萨。谓药王等当与记也。释曰。既是论主自言菩萨与记。亦论自释。何得不依

疏。既云未熟下。释上所引论文。若决定声闻定不成佛。则应言余二声闻根不熟。故佛不与记。既言未熟。非永不熟也。若大乘法师云。合言不熟。译者之误。言未熟耳。故疏结弹云。不可不顺己宗。定有趣寂。便判论文为错耶。又上言方便令发心者。彼论次前。有问云。彼声闻等。为实成佛故与授记。为不成佛与授记耶。若实成佛者。菩萨何故于无量劫修习无量无边种种功德。若不成佛者。云何与之虚妄授记。答曰。彼声闻授记者。得决定心非谓声闻成就法性故。如来依三平等说一乘法故。以如来法身与彼声闻法身平等无异。故与授记。非即具修功德行。故菩萨之人功德具足声闻之人功德未具足。释曰。由此论文是故上云方便令发心耳。言三平等者。一乘平等。无二乘故。二生死涅槃平等。三法身平等。今即第三平等

疏。入楞伽下。亦成无越寂义。言入楞伽者。即后魏菩提留支所译。文有十卷。世尊入楞伽王城。故云入也。同引三卷经文。皆说无实涅槃。明知定无趣寂。若尔何以言得涅槃。望其当分。谓是无余涅槃。以大乘望之。但是深入三昧。沈空多时假言涅槃。以引劣器耳。疏法华论中意亦同此故。同无实涅槃也。论释七譬喻中第四。为有定性人。说化城喻。论云四者实无。而有增上慢人。以有世间有漏三昧三摩跋提。实无涅槃而生涅槃想。如是颠倒取。对治此故。为说化城譬喻应知。释曰。既言无实涅槃。明知是假说耳。故与前同。又法华云。我虽先说汝等灭度。但尽生死而实不灭。次引胜鬘。亦成上来涅槃不实耳

疏。又无上依经。宝性佛性二论。皆说入灭二乘等者。无上依第一说云。阿难。一切阿罗汉辟支佛。未自在位菩萨。为由四种障。不得如来法身四德。一者生缘惑。二者生因惑。三者有有。四者无有。何者是生缘惑。即是无明住地。生一切行。如无明生业。何者是生因惑。是无明住地所生诸行。譬如无明所生诸业何者有有。缘无明住地。因无明住地。所起无漏行。起三种意生身。譬如四取为缘。三有漏业为因。起三种有。何者无有。缘三种意生身。不可觉知微细堕灭。喻如缘三有中生念念老死。由无明住地一切烦恼。是其依处未断除故。诸罗汉辟支佛。未自在位菩萨。不得至见烦恼垢浊。习气臭秽。究竟灭尽大净波罗蜜。又因无明住地轻相惑有虚妄行。未灭除故。不得至见无作无行极寂大我波罗蜜。缘无明住地。因微细虚妄。起无漏业。意生诸阴未除尽故。不得至见极灭远离大乐波罗蜜。若未得一切烦恼诸业生难。永尽无余。是诸如来为甘露界。则变易生死断续流灭无量。不得至见极无变异大常波罗蜜。阿难。于三界中有四种难。一者烦恼难。二者业难。三者生报难。四者过失难。无明住地所起方便生死。如三界内烦恼难。无明住地所起因缘生死。如三界内业难。无明住地所起有有生死。如三界内生报难。无明住地所起无有生死。如三界内过失难。应如是知。阿难。四种生死未除灭故。三种意生身。无有常乐我净波罗蜜果。唯佛法身是常是乐是我是净波罗蜜。汝应知之。释曰。据上经文。明于二乘及未自在菩萨皆受变易。三界之外有业惑苦甚为昭著。如何断言永灭无余。下疏明于四种生死。可检于此论。下文中。又广说常乐我净之相。亦可知之。所归下。言宝性佛性二论者。大意同无上依经。宝性论当第四。佛性论当第二。此卷亦广论四种生死

疏。如是经论下。结成无定性声闻也

疏。涅槃第九下。第四明无有无性。彼经广说阐提无善根竟。即云。复次善男子。譬如莲华为日所照无不开敷。一切众生亦复如是。若得见闻大涅槃日。未发心者皆悉发心。为菩提因。是故我说大涅槃光所入毛孔必为妙因。彼一阐提虽有佛性。而为无量罪垢所缠。不能得出。如蚕处茧。以是业缘不能生于菩提妙因。流转生死无有穷。已上皆经文。今疏。但取中间。意在虽有佛性之言。既言虽有。则非无也。但未得其用耳。故疏结云。此则有而非无。疏又云。或有佛性一阐提有等者。即涅槃第三十六。南经三十二。皆迦叶菩萨品。具有四句。今但引第一句者。是证阐提有性。经云。善男子。或有佛性一阐提有。善根人无。或有佛性善根人有。一阐提无。或有佛性二人俱有。或有佛性二人俱无。善男子。我诸弟子若解如是四句义者。不应难云一阐提人定有佛性。定无佛性。若言众生悉有佛性。是名如来随自意语。如来如是随自意语。众生云何一向作解。此一段经近远皆释。大同小异。今依荐福故。彼疏云。今准经明佛性略有五种。谓善不善无记及理果等。今言一阐提有善根人无者。此是不善佛性也。然善根人有其二种。一是离欲善根人。离欲断一切不善故。二是五性。五住已上无不善性故。此之二人俱无不善性也。善根人有。阐提人无者。此是善佛性也。阐提断一切善。故云无也。二人俱有者。理及无记性也。二人俱无者。俱无果性。此中有者。是现有。非当有也。然有人执此经文。谓一分善根人。及一分阐提。无有佛性。以经说有善根人及一阐提无故。善根人无者。是无性不断善人。阐提人无者。是断善无性。二人俱有者。俱是有性。二人俱无者。俱是无性。此释违经故。涅槃上文云。如来佛性则有二种。一有二无。有者。所谓三十二相。乃至无量三昧。是名为有。无者。所谓如来过去诸善不善无记。业因果报。烦恼五阴十二因缘。是名为无。乃至阐提佛性亦尔。是则上从乎佛下至阐提。皆有有无二性。无全无性。由善根人与一阐提有无二性异故。得有四句。此中明佛性多种有无不同。不明众生多种有性无性。所以得知者。经言。或有佛性。善根人有阐提人无等。故不言或有善根人有佛性。阐提人无佛性。故谈文尚不识颠倒。尚能解义。今此善不善因果理性。无一众生悉具一切。无一众生悉无一切。始末以明一切众生具一切也。佛与阐提亦有四句。佛有非阐提者。谓果性。阐提有非佛者。谓无明诸结性。二人俱有者。是理性。二人俱无者。善因性。故阐提决有佛性。又上经云。若言众生中别有佛性。是义不然。何以故。众生即佛性。佛性即众生。直以时异有净不净。解曰。生之与性既二互相即。明有众生即有佛性矣

疏。况前引楞伽五性。自迷其文等者。破其所引不晓经意。彼之所引证无性义。今释其所引。还成有性。非无性也。何者以彼经言非焚烧一切善根者。常不入涅槃。则有入义也。疏。此意则明下。疏释经意。疏。况经自下。引经结成。疏。庄严论下。引论重成。同前楞伽。非毕竟无性

疏。是知前来下。第五释所引经论。结成正义。于中二。初释般若深密经意。意明长时定性。长时无性。多劫之外。定性回心。多劫之外无性说有。故云非永定永无。非永定者。结上声闻。非永无者。结阐提也

疏。诸论随佛下。二通妨难。谓有难言。诸大菩萨造论释经。言永定永无。岂是菩萨不了佛意。故今释云。菩萨能知随教弘阐耳。故世亲造于小乘论。则无预大乘。说般若宗。则性空寂灭。建立唯识。则性相历然。及释法华一乘昭著。解十地论。则六相圆融。余诸菩萨例此可了。佛随众生机缘立教。菩萨随佛亦显浅深。故次下。引宝性佛性。即符一性

疏。若谓法华是第二时下。第六引诸经论。遮救定性。于中二。先正牒破。后结成前非。今初又二。先牒救词。后何以下。难破。今初。言是第二时者。彼不立为第二时教。由谓一乘是密意说。义当深密第二时教。又以法华盛破三乘说于一乘故。当第二时耳。言为引不定者。彼引摄论第十偈云。为引摄一类。及任持所余。由不定种性。诸佛说一乘等者。彼有十意。此偈有二。一为引摄一类不定性声闻故。二为任持不定性菩萨恐退精进故。今但取初意。故云为引不定性故。一切悉成。即一乘义。既未说定性不成故是密意。若作此说者

疏。何以自判法华为第三时者。难破也。彼法华疏引经。云我等今日得未曾有。非先所望而今自得。第三时教也。又下结云。为显第三时真实之教故说此经。据上二文。则判法华为第三时。约明一乘是密意说。则成法华复为第二。一宗自立义语相违。疏。谁敢判于法华为不了耶者。即遮救也。恐彼救言。设依密意为不了者。复有何过。故便难云。谁敢判为不了。以判不了即是谤经。恐招苦报。但由不信皆当作佛。即是谤经。岂要不信文字经卷故谤不轻。但由不信汝等皆当作佛言耳

疏。妙智经等者。此双引经论。妙智经者。即上西域三时教中。第二时中明于三乘。第三时中即明一乘。故言一乘居三乘后。次引梁摄论成立正法中者。即第八卷末论曰。佛说正法善成立。释论释曰。一切三世诸佛共说此法。所说理同不相违背。故名正法。又欲显说者胜。故言佛说。由所说道理胜。及所得果胜。故名正法。如来成立正法有三种。一立小乘。二立大乘。三立一乘。于此三中。第三最胜。故名善成立。释曰。既彼论亦云第三最胜居三乘后。则三非了矣。疏。真谛三藏部异执记者。即宗论之异名耳。疏。故经云临欲终时者。即引法华第二信解品文。经云。复经少时。父知子意渐以通泰。成就大志自鄙先心。临欲终时而命其子。并会亲族国王大臣刹利居士。皆悉已集。即自宣言。诸君。当知此实我子我实其父。今我所有一切财物。皆是子有。先所出内。是子所知。斯即会无性定性之父子意。明法华会中。明一切声闻皆佛真子。临欲终时者。喻临涅槃时也。第三经末亦云。若如来自知涅槃时到等。明皆临涅槃时也

疏。若不信下。又遮其救。恐彼救言虽言临终说于法华。临终言宽。容后更说其余经故。若作此救。且致法华。涅槃即云二月十五日临涅槃时。晨朝唱灭中夜涅槃。斯为最后。居然可信。此后必定不说别经。而涅槃经亦说一乘。以破三乘。一性破五性。则一乘一性亦居最后矣。那言居第二时为不了耶

疏。若以般若为第二时下。复重遮救。恐其救云。我对般若为第二时。故立法华为第三时。以般若但明于空。法华显中道故。若作此救。且纵可尔。以从多分一义说故。即自违于深密三时。深密三时三乘为了。破第二时说皆成不了故。今说法华以一破三。岂得同于第三时教

疏。明知深密下。第二结成前非。欲将深密三时。定断一切佛法。理不尽故。以未居最后故者。以约时判未是穷终之极唱故。如世后敕破于前敕。涅槃法华居于最后故。能决了有余义耳。若尔不信深密。岂不谤于深密经耶。故下释云。深密别为一类之机故非无理。以诸余经虽未终极各随一类。皆不相违。义如前说者。如前叙西域中。最后会通也

疏。若谓佛性有二下。第七遮救无性。于中二。光牒救辞。后辩差当。今初。彼法华疏云。然性有二种。一者理性。胜鬘所说。如来藏是。二者行性。楞伽所说。如来藏是。前性皆有。后性或无。故今许云。斯言可尔。故涅槃云下。引经为证

疏。然涅槃依于理性下。第二辩其差当。涅槃明有心作佛。有心未必有行。既皆作佛。明约理性。何以趣寂。趣寂定不成佛。有心定当作佛。岂得相成

疏。是知下。结示正义。谓阐提实不作佛。今言阐提作佛者。以发心之后方能作佛。从其未发大心前名阐提耳。故云以作佛非阐提故。亦如女身不得成佛。今言龙女作佛者。当作佛时。忽然之间变成男子。岂是女身作佛耶。阐提成佛亦复如是。此约成佛。若约佛性。理本有之。疏。乃抑扬当时言阐提无者。扬则令其发心。抑挫令其莫作。若言阐提有佛性者。显扬理性令不自欺。若已作阐提令速回心。若速发心。得佛无异。是故言有。未必总有果行二性。言无未必总无理等。故生公云。扬当时诱物之妙。岂可守文哉。以法显三藏翻六卷泥洹经云除一阐提皆有佛性。生公云。夫禀质二仪。皆是涅槃正因。阐提含生之类。何得独无佛性。盖是此经来未尽耳。由唱此言。被摈武丘。后大经既至。圣行品已下。果云一阐提人虽复断善犹有佛性。于是诸公轻舟迎接请唱斯经。每至阐提有佛性之文。诸德莫不扼腕。何以至今犹存无义

疏。若谓法华入灭下。第八遮救趣寂。于中先牒救辞。谓彼救云。上法华第三云。我于余国作佛更有异名。是人虽生灭度之想入于涅槃。而于彼土求佛智慧。得闻是经入于佛慧者。是应化声闻。非定性入灭声闻也

疏。权必化实下。次正破也。于中又二。先总夺云。化有无用之失。如有定性声闻。故菩萨化为声闻诱令回心。此则化而有益。今汝宗中定性决不回心。何用化于定性而受一乘耶。故无所化之机。能化便成无用

疏。又岂不误下。纵其有化。化翻成损。言岂不误。一类怯弱等者。谓一类人厌生死苦。又闻佛道长远。心生怯弱。常欲且趣寂灭界中。若知一灭永沈。彼则不敢趣寂。今见变化之者从灭得起。此怯弱人便谓有真趣灭得起。便即趣灭希后得起。汝宗一灭。决定不起。便成误彼令其永沈。故云尔也

疏。是知趣寂下。三结成正义。法华已前有二意。故说有趣寂。一为好灭之者。且顺其心。谓彼念言。大患莫若于有身。故灭身以归无。劳勤莫先于有智。故绝智以沦虚。然则智以形倦。形以智劳。轮转修途。疲劳莫返。不如寂灭诸患永亡。故顺彼机。言有永寂二者。为恐怖不定小乘怯弱菩萨。倦于广利且欲息心。便闻永寂声闻。一沉涅槃永不复起。便生怖畏惧见小乘。由此策心还行大道。有斯二益权说有之。不晓随宜执为究竟。故法华之会广破昔非。三根声闻皆与记别。不在此会亦为宣陈。若实是声闻。必信一乘之说。若不信者增上慢人。第一周中。犹云除佛灭后现前无佛。以佛灭后解一乘义者难得其人。故许不信及第三周。即言余国决定受化。明文若此。何用偏执。故言皆是法华前意耳

疏。又胜鬘经云下。第九会一乘方便之言。意云若随欲说。不是方便。是真实者。即定有三乘。既随欲说。是方便说非真实者。则明唯有一乘。故云即是一乘。则随彼所欲而方便说。便为一句。此是一乘所以下云。即是一乘无有二乘。此意正显一乘之义。诸公错读。乃云而方便说即是一乘。故谓一乘而为方便。斯定误矣。若以名中一乘大方便者。此是巧化摄物运济方便。非是真实假设方便。故生公云。理本无言。假言而言。即是方便。疏。又彼经中更引胜鬘余文。证成一乘真实可知。疏。设有方便之言者。复纵破之。莫论胜鬘无一乘方便之言。设纵有一乘是方便之言者。亦是法华之前方便说耳。及至法华。亦复破三归一也。况复经无此言。何须强执

疏。法华云。此经难信难解下。第十结成破立。意云以四十余年皆说三乘。唯至法华独说一乘故难信解。此即法师品文。文云。佛告药王。我所说经典无量千万亿。已说今说当说。而于其中此法华经。最为难信难解。药王此经是诸佛秘要之藏。不可分布妄授与人。诸佛世尊之所守护。从昔已来未曾显说。而此经者如来现在。犹多怨嫉。况灭度后。今疏。略引言已说者。法华之前谓般若等。言今说者。即无量义经。言当说者。即涅槃等。所以方知诸经不及法华。难信解者。以法华是会三之始归一之初。信解者难耳。昔经虽妙犹带三乘。曾未明言说唯一实。涅槃之中虽明一极。法华在前已破三乘。后说一极。便易信受。法华犹如先锋。涅槃如于大军。先锋已破于贼。后军用力不多耳。又破三显一。法华如收获。涅槃如拾穗。故涅槃三十六云。昔于灵山说法华。八千声闻得受记别。如秋收冬藏。更无所为。即其义耳。若依难信之义。设将已说该着华严。若比法华亦为易信。始成正觉便说一极。上根所受。不对昔权。故比法华诚易信耳。疏。诚哉斯言者。结定前经。若保执下。结成破立。三乘五性即是所破。一乘一性以为所立。疏。百喻经下。更引他经证成一义。彼经第二云。昔有一聚落。去王城五由旬。村中有好美水。王敕村人。常使日日进其美水。村人疲苦。悉欲远移避此村去。时彼村主语诸人言。汝等莫去。我当为汝白王。改五由旬作三由旬。使汝得近往来不疲。即往白王。王为改之作三由旬。众人闻已便大欢喜。有人语言。今三由旬。与彼本来五由旬量。更无有异。虽闻此言。信王语故。终不肯舍。世间之人亦复如是。修行正法。超度五道向涅槃城。心生疲倦便欲舍离。顿驾生死不能复进。如来法王有大方便。于一乘法分别说三。小乘之人闻之欢喜以为易行。修善进德求度生死。后闻人说无有三乘但是一道。以信佛语终不肯舍。当知彼人亦复如是。此经即是金口良断。权实显然。可息诸说耳

疏。上约二宗。下第三通会二宗令不相违。然此会者。恐于后学各计是非。以生过患故复会通。虽复会通权实不失。于中有三。先总标。后谓就机下。正会。言约法则一者非佛化法。化法亦有权说三乘。故今言法者。佛之知见一乘可轨之法耳。疏。新熏则五本有无二者。然准法相。立新熏者。亦说有五。立本有者。亦说有五。今借其言不依其义。谓众生遇缘熏习三乘种性及不定无性。故有五耳。何者唯习近声闻。成声闻定性。唯习近缘觉。成缘觉定性。故法华安乐行中。不许亲近声闻者。恐被熏习成其性故。若唯习近菩萨则成菩萨定性。若俱习近三乘。则成不定性人。亦如今人偏习禅戒慧等。即成定性。三学俱习成不定性。不定偏执故。若都不习近三乘者。则成无性。卒难教化。故知熏习成五种性者。依其长时故说各别。言本有无二者。本有佛性理不容差。故说有心定当成佛。非是本有五种性也。疏。若入理等者。真理寂寥不属诸数。借一以遣三。三亡则一遣。言穷虑绝何实何权。体本寂寥孰三孰一。故法句经云。森罗及万像。一法之所印。此以一遣多也。又云。一亦不为一。为欲破诸数。浅智着诸法。计一以为一。此以非一遣一也。故须三一两亡。疏。若约佛化仪。则能三能一者。随物机宜则说三乘。淘练已久。则便说一。故下经云。或有国土说一乘。或二或三或四五。如是乃至无有量。释曰。尚有无量况三一耶

疏。是故下。令物除执。常说权实亦莫执之。此即求那跋摩遗文偈也。谓有偈云。诸论各异宗。修行理无二。竞执有是非。达者无违诤。亦如胁尊者。对迦腻色迦王云。如析金杖。况以争衣。争衣则衣终不别。析金则金体不殊。是故依之修行。无不获益耳。疏。大集五部虽异者。谓五部僧。故涅槃三十三。亦云五部互生是非。长没三恶道。疏。涅槃各说身因者。即第三十五经云。善男子。如来所说十二部经。或随自意说。或随他意说或随自他意说。云何名为随自意说。如五百比丘问舍利弗云。大德。佛说身因。何者是耶。舍利弗言。诸大德。汝等亦各得正解脱。自应识之。何缘方作如是问耶。有比丘言。大德。我未获得正解脱时。意谓无明即是身因。作是观时得阿罗汉果。复有说言。大德。我未获得正解脱时。谓爱无明即是身因。作是观时得阿罗汉果。或有说言。行识名色六入触受爱取有生饮食五欲。即是身因。尔时五百比丘各各自说己所解已。共往佛所稽首佛足。右绕三匝礼拜毕已。却坐一面。各以如上己所解义。向佛说之。时舍利弗白佛言。世尊。如是诸人谁是正说。谁非正说。佛告舍利弗。善哉善哉。一一比丘无非正说。舍利弗言。世尊。佛意云何。佛言。舍利弗。我为欲界众生说言。父母即是身因。如是等经。名随自意说(云云)释曰。意取各随自说者。为随自意。今疏所引。不取随自意义。但取皆正说言。五百虽异皆为正说。二宗小别并合佛教。故不应是非。故海东晓公云。如言而取所说皆非。得意而谈。所说皆是则贵在得意亡言耳。余可知

第三立教开宗中。疏文分二。先标章。后今初下。别释分教。于中三。初总辩源由。次言五教下。正立五教。后若约所说下。约诠辩异。二中先列名。后初即天台下。解释。初小乘教易故不释。以见天台立名招难故。改名小乘。所摄法门不异于彼。故指同也

疏。二始教等者。文二。先正立。后释名。今初。言二乘不成佛者。其言犹略。应云阐提二乘皆不成佛故。下终教有二乘阐提悉皆成佛言。以趣寂难成。故偏举耳

疏。此既未尽下。二释名也。谓何名初教。复称分耶。由合二三两时。皆未尽理故。言未尽者。第二时中但明于空。空即初门。第三时中定有三乘隐于一极。故初教名并从深密二时以得。云何空为初门。法鼓经中以空门为始。以不空门为终。故彼经云。迦叶白义言。世尊。诸摩诃衍经多说空义。佛告迦叶。一切空经是有余说。唯有此经是无上说。非有余说故。若尔彼第三时既不明空。何得名初。以未显一极故。特由此义加分教名。故云有不成佛。故名为分

疏。三终教等者。疏文有三。初立名。次第。性二乘下立理释名。后上二下。结前生后。二中亦对第二教二义。由前定性二乘及一阐提皆不成佛。故名为分。亦名为始。今既尽理所以名终。立实教名双对前二。非唯说空复说中道妙有。故称实理。既非分成亦名称实

疏。四顿教等者。初正立。次释名。后解妨。今初。言一念不生即是佛者。即心本是佛体。妄起故为众生。一念妄心不生。何为不得名佛。故达摩碑云。心有也旷劫而滞凡夫。心无也刹那而登正觉。下经云。法性本空寂。无取亦无见。性空即是佛。不可得思量

疏。不依地位下。二释名。先正释。下引二经。思益经文文显易了。楞伽经语略而未周彼经第四先长行云。大慧。于第一义无次第相续。说无所有妄想寂灭法。颂中有七偈。后二偈。明不立地位。十地则为初。初则为八地。第九则为七。七亦复为八。第二为第三。第四为第五。第三为第六。无所有何次。解曰。初之七句以义配同。最后一句据理都泯。十地则为初者。同证如矣。初则为八地者。初地不为烦恼所动。同不动矣。第九为第七者。第九同第七无生忍矣。七亦复为八者。纯无相观与八同矣。第二为第三者。同信忍矣。第四为第五者。同顺忍矣。第三为第六者。第三地中获三慧光。第六地中得胜般若。同慧义矣。无所有何次者。结上经文。于第一义无次第相续等。今疏上句略举约义同中一句之要。下句即据理都泯。义已略周。正意在于下句。而言等者。等余经文

疏。不同前渐下。上约当法立名。此下对他受称。不同二三之渐教。不同第五之圆教。故立此名。则圆顿义异。不同天台圆即是顿

疏。顿诠此理下。解妨难。此有二难。一者刊定记难和尚云。上所引经。当知此并亡诠显理。复何将此立为能诠。若此是教。更何是理。今为通此。故云顿诠此理。故名顿教。谓所诠是理。今顿说理。岂非能诠。夫能诠教。皆从所诠以立。若诠三乘即是渐教。若诠事事无碍即是圆教。岂以所诠是理。不许能诠为教耶。何得难言更何是理。迷之甚矣又复难言。若言以教离言故与理不别者。终圆二教岂不离言。若许离言总应名顿。何有五教。若谓虽说离言不碍言说者。终圆二教亦应名顿。以皆离言不碍言故。今疏不救者。以贤首不如此立。何用救耶。但用一句之言。诸难皆破。故知形虽入室。智未升堂。亦由曾不参禅。致使全迷顿旨。疏。天台所以不立下。通第二难。谓有问言。此之五教摸榻天台。初即藏教。二即通教。三即别教。第五名同天台既不立顿。何用此中别立。故今释云。若全同天台何以别立。有少异故所以加之。天台四教皆有绝言。四教分之故不立顿。贤首意云。天台四教绝言。并令亡筌会旨。今欲顿诠言绝之理。别为一类之机。不有此门。逗机不足。即顺禅宗者。达磨以心传心。正是斯教。若不指一言以直说即心是佛何由可传。故寄无言以言。直诠绝言之理。教亦明矣。故南北宗禅。不出顿教也

疏。五圆教下。文中有二。先正立。后指经。既是当经。义理分齐。一门广说。故不释耳。又亦大同诸师圆教故

大方广佛华严经随疏演义钞卷第八大方广佛华严经随疏演义钞卷第九

        唐清凉山大华严寺沙门澄观述

疏。若约所说法相者下。第三约所诠辩异。然贤首义分齐内。第二卷广明。今但略说。于中上一句标。下皆别释。初小乘中四。一约法数多少。二约二空差别。三约所依根本。四结成有余。今初。言七十五者。谓五类法中有多少故。谓一色法十一。俱舍颂云。色者唯五根五境及无表。二心法一。即是意识。三心所有法。有四十六。谓遍大地有十。俱舍颂云。受想思触欲。慧念与作意。胜解三摩地。遍于一切心。大善地有十。颂云。信及不放逸。轻安舍惭愧。二根及不害。勤唯遍善心。大烦恼有六。痴逸怠不信。昏掉恒唯染。大不善有二。谓无惭及无愧。小烦恼有十。颂云。忿覆悭嫉恼。害恨谄诳娇。如是类名为小烦恼地法。不定有八。谓悔眠寻伺贪嗔慢疑。上之六类有四十六。四者。不相应行法。有十四种。一得。二非得。三同分。四无想异熟。五无想定。六灭尽定。七命根。八生。九住。十异。十一灭。十二名。十三句。十四文。故颂云。得非得同分。无想二定命。及生住异灭。并名句文身。五者无为法有三。一择灭。二非择灭。三虚空。总上五类之法。合七十五法。比于大乘欠二十五。次下当明

疏。但说人空下。明二空差别。以其根劣未堪闻说二空真理故。智度论四十一云。小乘弟子钝根故。为说众生空。起信云。计我见者。依二乘根钝。如来但为说人无我等。纵说二空少未明显

疏。但依六识三毒下。明所依根本。然小乘计生死根本。虽有多义。略举其三。一计识心。如顺正理论第八说。经部师计以现在色心等。为染净因。意云如大乘中第八为所熏故。二者三毒为因。义如大乘能熏故。今引阿含但证三毒耳。而云等者。谓以三毒为因缘故。起于三业。三业因缘故起于三界。是故有一切法。中论十二因缘品颂云。众生痴所覆。为后起三行。以有此行故。识受六道身等。即其义也。三者合取上二义。同有能所熏方流转故。若尔焉异大乘。然似参经意而不同者。但六识非第八为所熏。纵说赖耶但有名字。能熏又非七识。故全不同

疏。未尽法源下。第四结成不了。可知

疏。二始教中下

疏。文分三。初总。次别。后结。今初分二。先对后彰劣。后对前显胜。前中以相多性少故。言法相宗。言所说法性即法相数者。说真如法性。乃是百法之中六无为数。后说有百法下。对前彰胜。言百法者。谓心法有八。心所有五十一。色有十一。不相应行有二十四。无为。有六。故成百数。于前七十五中。加二十五。谓心法加七。小乘唯一意识故。心所加五。不相应行加十。无为加三。并如彼说

疏。说有八识下。第二别明。文有九节。即前会二宗。中十对之内。法相宗中十义。而皆如次对前。唯第一当第三。第二当第一。及第二者。以第三唯心真妄为对。六识三毒为所依故。今初。第一云何对前说。有八识为所依故说八过前教。唯是生灭明其劣后。依生灭识。建立生死及涅槃因者。不同前教以明三毒六识为因。不同终教不生灭与生灭和合。故摄论第一云。无始时来界。一切法等依。由此有诸趣。及涅槃证得。界即因义。谓种子识等。下文广说

疏。法尔种子下。即第二对一性五性别中。五性之义。含前第一对。一乘三乘别中。三乘之义以乘性相成故。但明五性。则有三乘。而三乘但是化法。非所诠中别义。故略不明含在五性之中。言法尔者。此明本有拣异新熏。故瑜伽云。种性略有二种。一本性住。二习所成。本性住者。谓诸菩萨六处殊胜。有如是相。从无始世展转传来。法尔所得等。习所成者。谓先惯习善根所得。显扬论云。云何种性差别。五种道理。一切界差别可得故。五中前四为有。后一为无。故云有无永别

疏。既所立识唯业惑生等者。第三明真如随缘凝然。别中凝然义。上一句蹑前生灭识起。言业惑者。以现行第八名异熟识。由过去烦恼及业熏习成种。招此识果酬引业故。其前六识酬满业者。从异熟起名异熟生。不名异熟有间断故。故其八识皆业惑生。故所立真如下。正明不变之义。若识从真如如来藏起则有随缘之义。识既从于业惑辨生。明知真如不变。故唯识释真如名云。真谓真实。表无虚妄。如谓如常。表无变易。若随缘变。岂得称如

疏。依他起性下。第四三性空有即离别中。不即之义。言三性者。一遍计所执性。二依他起性。三圆成实性。故唯识论第八云。由彼彼遍计。遍计种种物。此遍计所执。自性无所有。依他起自性。分别缘所生。圆成实于彼。常远离前性。此中二颂。初一释遍计。次二句辩依他。后二句明圆成。初中一偈有多师义。今从护法。初句能遍计。次句所遍计。后二句明所执。其能遍计正义。唯六七二识所计有多。故云彼彼。其所遍计正唯依他。为亲所缘依展转说。亦通圆成为疏缘故。此非凡境故非亲缘其所执性。若安慧师。三界心及心所。由无始来虚妄熏习。虽各体一而似二性。谓见相分即能所取。如是二分情有理无。此相说为遍计所执。其所依体实托缘。生此性非无。名依他起。若护法师。一切心及心所。由熏习力所变。二分从缘生故。亦依他起遍计。依斯妄执定实有无一异俱不俱等。此二方名遍计所执。二句依他起性者。众缘所生心心所体。及相见分有漏无漏。皆依他起。依他众缘而得起。故颂言分别缘所生者。应知且说染分依他。净分依他亦圆成故。或诸染净心心所法。皆名分别。能缘虑故。是则一切染净依他。皆是此中依他起摄。二句圆成者。二空所显圆满成就诸法实性。名圆成实。显此遍常体非虚谬。拣自共相虚空我等。释曰。遍释圆满。常释成就。体非虚谬。释实性义。此一体言贯通三处。遍拣自相。常拣共相。非虚谬言。拣于空我。若尔净分依他体非常遍。如何亦是圆成实耶。故次论云。无漏有为。离倒究竟。胜用周遍亦得此名。然今颂中说初非后。释曰。此中离倒名实。究竟为成。胜用周遍以释圆义。是则圆成。有其二种。一约理说。二约果德。故论拣云。今此颂中说初非后。以约三性。通一切故。上来论文方释圆成实言。次释余文云。此即于彼依他起上。常远离前遍计所执。二空所显真如为性。说于彼言。显圆成实与依他起不即不离。常远离言显妄所执能所取性理非恒有。前言为显不空依他。性显二空非圆成实。真如离有离无义故。上来所释。一依唯释。今疏语意。拣法性宗。法性宗中依他。无性即是圆成。即依他无性。无性即空。空即圆成。今言似有不无。非即空也。语则但释依他。影出圆成名耳。说经空义。但约所执者。三性之中遍计所执。此一则空。二性不空。故云但约所执

疏。既言三性下。第五生佛不增不减别中。不减之义。此但义别而言全同。不同前后一乘三乘。但取三乘之义等。谓五性之中无种性人。决不成佛故。有此众生守众生界如何可减

疏。真俗二谛迢然不同下。即第六对二谛空有即离。别中离义。于中含有二义。一但明二谛别。二兼明中道别。言二谛别者。依唯识第九。有四种胜义。一世间胜义。谓蕴处界等。二道理胜义。谓苦等四谛。三证得胜义。谓二空真如。四胜义胜义。谓一真法界。依瑜伽论六十四。有四世俗。一世间世俗。谓军林等。二道理世俗。谓蕴处界等。三证得世俗。谓预流等。四安立世俗。即安立真如。以四世俗。对前唯识四种胜义。则有四重二谛。一世俗二谛。谓军林为世俗。蕴等为胜义。二事理二谛。谓蕴等为世俗。苦等为胜义。三胜义二谛。苦等为世俗。安立真如为胜义。四安立非安立二谛。谓安立真如为世俗。非安立真如为胜义。又真俗各四。便成八谛。一世俗四者。一名假名无实谛。二名随事差别谛。三名方便安立谛。四名假名非安立谛。谓二空理依诠而说。但有假名不得体故。胜义四者。一体用显现谛。二因果差别谛。三依门显实谛。四废诠谈旨谛。然上八谛名则小异。义不殊前。又四重中初一世俗唯局世俗。后一胜义唯局胜义。中间六谛各通世俗胜义二谛。如第一胜义。望前为胜义。望第二为世俗故。既四重二谛一一差别。故云迢然不同。不同法性二谛相即。疏。非断非常果生因灭者。于二谛门中曲开此义。此则于俗谛中明非断常。不同法性二谛互融明非断常。言果生因灭者。因灭故不常。果生故不断。故唯识第三云。此阿赖耶识恒。转如瀑流。释云。恒言遮断转表非常等。意云。若因不灭迁至于果。则名为常。若果不续因无所生。则堕断灭。今常相续故无断常。广如唯识

疏。同时四相灭表后无者。即第七四相一时前后别中。前后义也。成唯识第二云。然有为法因缘力故。本无今有。暂有还无。表异无为。假立四相(标也)本无今有。有位名生。生位暂停。即说名住。住别前后。复立异名。暂有还无。无时名灭。(别明相也)前三有。故同在现在。后一是无故在过去(拣异小乘生在未来余三现在)如何无法与有为相(难也)表此后无为相何失(总答也)生表有法先非有灭表有法后是无。异表此法非凝然。住表此法暂有用(别释表义)故此四相。于有为法虽俱名表。而表有异。此依刹那假立四相(结也)。今疏但举灭者。唯此一句异于法性。不许同时故

疏。根本后得下。第八能所断证即离别中。不即义也。因明断证。复说缘境。根本缘真。后得缘俗。义说双观者。亦言了俗由于证真。二智双观真俗。以其宗中二智不融。二境不即故。正双观时而常别照。言断惑别者。根本智断迷理随眠。后得智断迷事随眠。护法云。不亲证故无力能断迷理随眠。而于安立相。无倒证故。亦能永断迷事随眠。故瑜伽说。于修道位中有出世断道世出世断道。相传释云。正体能断迷理迷事二种随眠。后得但断迷事随眠。断迷理时即观理境。断迷事时即观事境。故不即也。既言根本有双断义故说双观。后得既不断于迷理还成别照。不同法性一断一切断也。此中疏文影略而说。若约断惑。应云义说双断而实别断。言以有为智证无为理者。唯约根本断惑而说。上明断惑。此辩证理。前缘境断惑。但就所观以论不即。今此证理。就能所证。心境相对。明不即义。能证之智。则是有为。所证之理。即是无为。故不即也

疏。既出世智依生灭识下。第九明佛身无为有为别中。有为义也。佛地论第三云。大觉地中无边功德。略有二种。一者有为。二者无为。无为功德净法界摄。净法界者。即是真如。无为功德皆是真如体相差别。有为功德四智所摄。无漏位中智用强故。以智名显一切种心心所有法及余品类。若就实义具摄一切功德。若就粗相摄妙观察等。明知四智皆有为也。唯识第十云。四所转得。此复有二种。一所显得。谓大涅槃。二所生得。谓大菩提。此虽本来有能生种。而所知障碍故不得生。由圣道力断彼障故。令从种起名得菩提。起已相续穷未来际。此即四智相应心品乃至云。故此四智总摄佛地一切有为功德皆尽。以斯二论明皆有为。今疏。初两句出有为所以。以从种生。生则有为。况能生识。体是生灭。所生之智。安非有为。既是修生有为必有有为之相。谓生住异灭。故云为相所迁。四智摄于三身。大圆镜智成自受用。故说报身有为无漏

疏。如是义类下结也

疏。三终教中少说法相等者

疏。亦有三。初总。次别。后结。今初。对前始教互有少多可知。言所说法相亦会归性者。如说五蕴。五蕴即空。空即法性。下文云。三世五蕴法。说名为世间。彼灭非世间。如是但假名。又云。有诤说生死。无诤说涅槃。生死及涅槃。二俱不可得等。又如说心。心即离念。法界一相。华藏世界海。法界无差别等。其文非一。故此宗中非不有相。宗意显性以为玄妙。令物达此速证菩提。故光明觉云。如来所转等

疏。所立八识下。别明文亦九段。如次对前成十段义。亦第三当其第一。以对前次故。今初。即唯心真妄别中。明具分唯识真心成故。然法性宗十义。即此经同教中义。至下广引本文释之。今且略引他经释耳。通如来藏者。如来藏即不生灭。拣异前教唯生灭识故。楞伽第一云。譬如巨海浪。由斯猛风起。洪波鼓溟壑。无有断绝期。藏识海常住。境界风所动。种种诸识浪。腾跃而转生。既言体即常住。明非唯生灭。常住即如来藏。言不生不灭与生灭和合者。即起信论文。具云不生不灭与生灭和合。非一非异名阿赖耶识。既二和合名为阿赖耶。则知赖耶非独生灭。谓唯真不生。纯妄不成。真妄和合方成藏识。广如问明品辩

疏。一切众生平等一性者。即第二明一性五性别中一性义。兼一乘义。对前五性三乘。广如前说

疏。但是真如随缘成立者。第三真如随缘不变。别中通随缘义也。楞伽经云。如来藏为无始恶习所熏。名为藏识。又云。如来藏受苦乐。与因俱若生若灭。皆明随缘成一切法也。起信亦云。自性清净心。因无明风动。成其染心等。而疏云但是者。蹑上而起。谓上众生但是真如随缘成也。由此成立不失一性。对上始教但说凝然。故云随缘。非谓此宗无不变义。由不变故始能随缘。由随缘故方能不变。何者。谓若变自体。将何随缘。如无湿性。将何随风。而成波浪。即由此我经中说言真如随缘。若不能随缘。体则不遍缘中。缘中既无。何成不变。是以二义及覆相成。故胜鬘经云。不染而染。难可了知。染而不染。难可了知。此经二对。上对即不变随缘。下对即随缘不失自性也

疏。依他无性即是圆成者。第四明三性空有。即离别中。相即之义也。谓依他是因缘所生之法。缘生无性。无性故空。空即圆成。更无二体。此中无性。即无遍计妄执之性。法相宗中无于遍计。无即是空故。但空遍计。法性宗中。则依他性上无遍计性。故依他即空。空即无性之理。无性之理即是实性。故密严经云。名为遍计性相是依他起。名相二俱遣。是为第一义。中论云。因缘所生法。我说即是空。亦名为假名。亦名中道义。一因缘上。三义具足。无前无后。故即有即空不相拾离。若释三性之名。大意不殊前教。但融不融故分性相之二宗耳

疏。一理齐平故说生界不增不减者。第五生佛不增不减别。此但义异。名乃不殊。谓法性既同。设令一切众生一时成佛。生界不减。佛界不增。以生佛界既是法性。不可以法性增法性。喻如东方虚空是众生。西方虚空是佛。不可以东方虚空。添西方虚空。令东减西增。故不增不减。大般若等经。皆约一性平等而说

疏。第一义空下。第六明二谛空有即离别中。相即义也。虽有不即不离。对前成即。故仁王二谛品云。波斯匿王言。第一义谛中有世谛不。若言无者。智不应二。若言有者。智不应一。一二之义其事云何。佛言。汝今无听。我今无说。无听无说是即名为一义二义。即说偈云。无相第一义。无自无他作。因缘本自有。无自无他作。法性本无性。第一义空如。诸有本有法。二假集假有。有无本自二。譬如牛二角。照解见无二。二谛常不即。于解常自一。于谛常自二。通达此无二。真入第一义。涅槃十三云。文殊师利白佛言。世尊。所说世谛第一义谛。其义云何。世尊。第一义谛中有世谛不。世谛之中有第一义不。如其有者。即应一谛。如其无者。将非如来虚妄说耶。佛言。善男子。世谛者。即第一义谛。世尊。若尔则无二谛。佛言。有善方便随顺众生说有二谛。善男子。若随言说则有二种。一者世法。二者出世法。善男子。如出世人之所知者。名第一义谛。世人知者。名为世谛。善男子。五阴和合称言某甲。凡夫众生随其所称。是名世谛。解阴无有某甲名字。离阴亦无某甲名字。出世之人如其性相而能知之。名第一义谛。以上二经对前二论。二宗有殊。前教则八谛区分。初一唯世俗。后一唯胜义。中间六谛上下相望。各通二义而皆约事。令第八谛独居事外。今此二经。仁王则虽有二谛。智照无二。涅槃则本唯一谛。解惑分二。斯则二而不二。不二而二。一二自在为真二谛。故昔人云。二谛并非双。恒乖未曾各即其义也。生公云。是非相待故。有真俗名。生一谛为真。二言成权矣。即涅槃经意也。梁论亦云。智障甚盲瞑。谓真俗别执。然法相务欲分析。法性务在融通。各据一门。勿生偏滞。然疏云。第一义空该通真妄者。真妄俱空非独真空。妄有妄空真有也。而言第一义空者。非无物为空。乃即妙有之空也。真非俗外者。明不异也。影取俗非真外。即俗而真者。明相即也。影取即真而俗。而不云俗非真外即真而俗者。一则影取如上所明。二则以妄必是其真。亦有真非妄故。如波即湿。有湿非波。即静水故。即佛已证故。但言随顺观察世谛。即入第一义谛。无有随顺观察第一义。即入世俗故。故上涅槃中。文殊双征。如来但云世谛即第一义。疏。虽空不断等者。由上二谛既融。令不断不常。中道妙旨不唯约事。此即中论及智论文。且约空为真谛。有为俗谛者。空是即有之空故。虽空不断。斯乃即俗之真也。不同始教如龟毛兔角。方说名空。虽有不常者。有是即空之有故。此有非常。斯乃即真之俗也。若执有定是有。便堕常见。故中论云。定有则着常。定无则着断。是故有智者。不应著有无。非断非常即是中道。若灭故不常。续故不断。但俗中一义耳。上则不坏有无。而离有无。有之与无。非一非异。故成中道。若其一者。有无之义俱坏。若其异者。便堕断常。何者若法定有有相。则终无无相。如说三世有者。未来中有。迁至现在。转入过去。不舍本相。是则为常。又定有者。应不从缘。不从缘者堕无因常。若法定无。先有今无是则为断。若不融三谛明空有者。决不能祛断常之见

疏。四相同时体性即灭者。第七四相一时前后别中。一时义也。以性灭为灭故得同时。故楞伽云。初生则有灭。不为愚者说。一切法不生。我说刹那义。净名云。汝今即时亦生亦老亦灭故。又云。过去已灭。未来未至。现在无住。三世皆空故体性即灭。乃会相归性也。故起信论云。若得无念者。则知心相生住异灭。以无念等故。而实无有始觉之异。以四相同时而有。皆无自立。本来平等同一觉故。前教假立四相故不同时。此教以所相法体随法性而融通。故能相之相。亦生灭而无碍

疏。缘境断惑下。第八能所断证即离别中。相即之义故。十地经云。非初非中后。论释义云。是断结相。此智尽漏为初智断。为中。为后。非初智断。亦非中后。偈言。非初非中后。故云何断耶。如灯之焰非唯初中后。前中后取故。谓唯取一时。则不能断。三时总取方说能断假三时。断则无定性。何者初若能断。不假中后。后若能断。不假初中。既假三时故知无性。一一推征。三皆不断。是故经言非初非中后。由三时无断方能断结。是故论云前中后取。故论主总取三时。方显三时无断。经论言反。意乃相成。经则约性。论则约相。性相无碍。方能断结。大意如此。而疏有二节。初总明无断之断。后别明内证之相。今初。文亦影略。若约缘境。不二而二有能所照。二而不二即智证如。若约断惑不二而二。有能所断。以能断是智。所断是惑。惑体智体无二体故。故名不二。故涅槃云。明与无明其性无二。愚者谓二。智者了达知其无二。无二之性即是实性不坏相故。有能所断即名为二。二而不二。说为内证。证者以能合所故。惑即如故。疏。照惑无本下。别明内证之相。谓智有二能。一能断惑。二能证理。上说断惑。今明证理。照惑无本即是智体者。寻此妄惑。都无根本。非内非外亦非中间。三世推求都不可得。从无住本颠倒妄生。既以无住而为其本。则无本矣。无住之本即实相异名。故此惑本便是智体。智体惑体无二体也。照体无自。即是证如者。即此智体。本唯无念。不能自立。因惑说智。智不自名。智无自性。即是如体。无心存智。是曰证如。若以智合如。非证如矣。疏。非智外如为智所证下。反成上义。智即是如。如即是智。法界寂然曰如。寂而常照曰智。岂离寂外别有智耶。上二句举智收如。智外更无如矣。下二句举如收智。如外岂有智耶。若智外有如。智则收法不尽。若如外有智。真如则不遍智中。举一全收。不容相并。此即回向经文。更有文云。无有少法与法同住。则显法性无容并真。二既不存。一亦奚立。如斯断证唯实教宗。不同前宗决有断证

疏。世出世智依如来藏下。第九佛身。无为有为别中。无为义也。文中有二。先出所以。若法相宗从生灭识生则是有为。今依如来藏。所依常故。能依亦常。始谓始觉。本谓本觉。本觉理有众许是常。始觉修生。义同无常。今以始觉同于本觉。无复始本之异。岂无常耶。若是无常。何得而言无有始本之异。以一常一无常故。今言不异。明即是常。疏。则有为无为非一非异者。以约修生义同有为。全同藏性故。即无为本觉义同无为。始觉即是有为。今说始本。明其不一。始本无二。明其非异。化身已下。正显无为。化身最劣。尚是常住。报身更胜。安得无常。化身即常。此义乃是涅槃经文。故彼经云。吾今此身。即是常身法身。恐人谓言但是不断之常。非凝然常。凝然常者。即是法身。今云即是常身法身。明知化身即法身。凝然常也。不堕诸数。即净名经弟子品云。佛身无为不堕诸数。以诃阿难谓佛化身有小疾故。上举二经明化身常。下况于报体。即体之智者。若体外有智体常。智无常即体之智。体既四相不迁。智亦无能迁矣。智若可迁。体亦可迁。以相即故。故涅槃第二云。若有善男子欲护正法。勿说如来同于诸行。不同诸行。唯当自责。我今愚痴未有慧眼。如来正法不可思议。是故不应宣说如来定是有为。定是无为。若正见者。应说如来定是无为。何以故。能令众生生善法故。生怜愍故。如有女人在于恒河。为爱念子而舍身命。善男子。护法菩萨亦应如是。宁舍身命不说如来同于有为。当言如来同于无为。以说如来同无为故。得阿耨多罗三藐三菩提。如彼女人得生梵天。何以故。以护法故。云何护法。所谓说言如来同于无为。善男子。如是之人虽不求解脱。解脱自至。如彼女人不求梵天。梵天自至。乃至(云云)文殊师利。外道邪见可说如来同于有为。持戒比丘不应如是于如来所生有为想。若言如来是有为者。即是妄语。当知是人死入地狱。如人自处于己舍宅。文殊师利。如来真实是无为法。不应复说是有为也。如是等文诸经皆有。涅槃中意。初则为与无为。二俱双遣。后于此二中宁说无为。不应宣说是有为也。今明三身既得相即。为与无为本融。如此解于如来。是为真实观佛。余义至下当明

疏。如是义类下。结广从略。兼示法源。令知有据

疏。四类教中总不说法相。唯辩真性等者。意云但诸经中。一向辩真性之处。即属顿教。疏。亦无八识差别之相等者。八识心王尚无差别。况心所变岂当有耶。心生即种种法生。心灭即种种法灭。故起信论云。一切诸法唯依妄念而有差别。若离心念则无一切境界之相。是故一切诸法从本已来。离言说相离名字相离心缘相。毕竟平等无有变异。唯是一心故名真如。以一切言说假名无实。但随妄念不可得故。故疏云。一切所有唯是妄想。疏。一切法界唯是绝言者。又拂前真性。辩离言真如。故起信论次文即云。言真如者。亦无有相。谓言说之极。因言遣言。此真如体无有可遣。以一切法悉皆真故。亦无可立。以一切法皆同如故。当知一切诸法。不可言说不可思念。故名真如。故疏云。皆是绝言也。言一切法界者。界者性义。以一切法性皆离言故。亦通四种法界。皆不可说故。名无得物之功。物无当名之实故。理本无言故。事理交彻。不可作事理说故。事事相即。不可作一多等说故。名名不尽。不可以一名詺故。理圆。言偏。言不及故。无有一法非实相故。疏。五法至双遣者。即如楞伽。虽明五法。名相妄想正智如如五皆空寂。何者谓迷真如以成名相。妄想是生。悟名相之本如。妄便称智。则无名相妄想。唯如如智矣。智因如立。智体亦空。如假智明。本来常寂。故并空矣。况八识约事。皆缘生性空。因有我法。说二无我。我尚叵得。无我宁存。故中论云。诸佛或说我。或说于无我。诸法实相中。无我无非我。故双遣也。诃教者。谓以心传心不在文字故。劝离者。乃有二义。一令离教。成上诃教。二令离法。法虽无量不出色心。离心心如。离色色如。故今皆离。则契心体离妄念矣。毁相约境。凡所有相皆是虚妄故。泯心约智。了境相空。假称为智。相既不有。智岂有真。心境两亡则皆泯绝。心无心相即是真心。故说生心即妄。不生即佛。言生心者。非但生于余心。纵生菩提涅槃观心见性。亦曰生心。并为妄想。念想都寂。方曰不生。寂照现前。岂不名佛。故达磨碑云。心有也旷劫而滞凡夫。心无也刹那而登正觉。言心无者。虽了心空。不生于了耳。故下经云。一切法不生。一切法不灭。若能如是解。诸佛常现前。言如是解者。如不生解而无解相。非谓空解于不生耳。疏。亦无佛无不佛。无生无不生者。重拂前迹。为迷众生。言即心即佛。既无众生。何曾有佛。故经云。平等真法界。无佛无众生。执佛言无佛。非谓是无佛。故云无不佛矣。则遣之又遣之。若少有所得。皆是妄想。故佛藏经第一云。舍利弗。乃至于法少有所得者。则与佛诤。与佛诤者。皆入邪道。非我弟子。是吾法贼。又只詺无佛以为真佛。故言无不佛矣。故下经云。性空即是佛。不可得思量。若有生心。生心是妄。故说不生。佛尚不有。何有无生。作无生解。还被无生之所缠缚。故云无不生矣。又一切法不生。则般若生故。云无不生则生与不生。反覆相遣。亦反覆相成。唯亡言者可与道合。虚怀者可与理通。冥心者可与真一。遣智者可与圣同。故引净名默住。以显不二是也。然净名第二入不二法门品。前有三十二菩萨。各说不二法门。后问文殊师利云。何等是入不二法门。文殊师利曰。如我意者。于一切法无言无说。无示无识离诸问答。是为入不二法门。于是文殊师利。问维摩诘言。我等各自说已。仁者当说。何等是入不二法门。时维摩诘默然无言。文殊师利叹曰。善哉善哉。乃至无有文字语言。是真入不二法门。然此经意。前后相成。共显深旨。若辩优劣。或三重四重。言三重者。一诸菩萨以无二遣二。则是以言显法。似有不二可说。便是对二明不二。非绝待也。二文殊以言遣言。明无不二可说。令亡言会旨。三维摩诘以无言显理。谓本自无言。不须更遣。故为三也。而言四者。文殊师利以言印彼。又明言即无言。非要离耳。若欲合者。然后三段反覆相成。但为一义。初文殊以言显无言。次净名以无言印言。后文殊以言印无言。三段二人共显绝言之理。故前三十二菩萨以无二遣二。后二大士以无言遣言。则但有二节。若更合者。若无诸菩萨以言遣二。空有绝言何由显理。是则前诸菩萨假言显理。后二大士以无言显理。言与不言双亡。皆真不二矣。故虽三节一致无违。今取最后。故云如净名默住也

疏。五圆教等者。义广理深。非略可尽。故彰其宏奥。别立一门。然在立教之终。故须略举。言十十法门者。一一法门。一一法中。多明十故。十身十忍十眼十通十种玄门。出十所以表义无尽。彰异余宗。故文文之中多皆十句。一一十句。六相圆融方显教圆。广如下辩。如经宗辩者。即是第六宗趣门也。第四总相会通中。文多易了。随难则释。疏。三者三四二教下。虽则泯二异前者。三即终教。四即顿教。此之二教俱明一乘。故云泯二。则异前始教存三乘也。而言虽者。虽明一乘。由是对三显故同前二教。亦入屈曲之数。则前四教皆屈曲收。后之一教方是平道。故顺印公

疏。此三亦顺四乘者。初一小乘。次一三乘。此二皆是三乘教。摄以初小乘。即三乘中之小乘故。后三是一乘故。为四乘也。又梁论下。证成三一之义。前会三乘一乘文中已引。及妙智经部异执记。并如前引

疏。一中间三教存三泯二别者。始终顿三名为中间。以初有小乘。后有圆教。故名中间。而始教存三故。别为一教。终顿二教泯二是同故为一乘。即合终顿二教也

疏。二约历位无位别者。始终二教皆悉历位。顿教不历。故合始终以为渐教。余皆如名者。一小乘教。二渐教。三顿教。四圆教。则渐是新加余三如本名也

疏。然取多分下。遮外难也。恐有难云。既破昔人不许指于一经以为一教。如何前立教中。亦云如法华等。故今通云。从多分说所以略指。实不局判一经以为一教故。下出所以云。以一经中容具多故。上来开合遍收。理无不尽。依此亦可总判教言。若唯为一难见浅深。非判教也。若欲判者。当渐开之。且分为二。一方便教。二真实教。故法华云。开方便门示真实相。亦即半满。又方便即随他意语。真实即随自意语。又方便是三乘。真实是一乘。然诸经中对小显大。即以二乘为方便。大乘为真实。若对权显实。则以三乘为方便。一乘为真实。则于方便之中更分为二。一小乘。二大乘。就真实中亦分为二。一行布。二圆融。行布即始终之教。圆融即是圆教。又小乘居然是别。大乘之中有多差别。一直显一乘。如华严。二开权显实。如法华。三会权归实。如涅槃。四斥权赞实。如净名思益。五权实双明。如诸般若。六带权说实。亦如般若。七带实明权。亦如般若。胜鬘小似法华。央掘小似涅槃。于上七中有似其类之经。各以类摄。若就大乘分宗。亦可有四。一法相差别宗。多说相故。二相想俱绝宗。多约性故。三性相无碍宗。事理相即故。四圆融具德宗。以理融事故。故如来圣教意趣无边。不可局执。今且依于古势。如疏明耳

疏。本末同时始终一类者。本是一乘。末即小乘。三乘然非前后。从初得道。迄至涅槃。此三类教。同时并行。故云本末同时。言始终一类者。若小始终俱小。若三则始终俱三。若一则始终俱一。故云始终一类。各无异说。然有三位下。别出其故

疏。然此三类依于此世下。拣滥。恐有执言。小乘始终定者。岂非定性声闻。故云谓非一人多世同闻一类。以容转根器故。亦非通取不定性人。要约一世一类定者

疏。如出现品日照下。文甚分明。此应广引

疏。约机各是一类之机者。拣滥也。非是一人先大。后小故。若一人身则明先小后大。乃摄末归本门中有之。故摄末归本门有二类人。一者一人备历小大。如四大声闻等。二者先禀小人。未必后时禀大。以小性定故。而闻后时说大故。异前始终俱小。后禀大人未必要从小来。以有顿悟机故。而知先来说小故。非始终俱大

疏。法华亦云初转四谛者。即第二经诸天说偈云。昔于波罗奈转四谛法轮。分别说诸法五众之生灭。今复转最妙无上大法轮。是法甚深奥。少有能信者等

疏。上之四门者。通结上也。所以此中结者。前之四门义已略周。藏和尚立但有前四。今疏顺彼且将略毕故。此结之下之六门复傍收异义。以显玄奥

疏。更有一类机下。上来牒列前之四门。生起第五。明第五门非前四摄也。疏六显密同时者。是天台八教中。秘密不定之二教也

疏。七一时顿演者。如来于一语言中。演说无边契经海。无论小大三一显密。一刹那中皆具演耳

疏。八从初得道等者。即寂寞无言门。谓涅槃楞伽等经皆有此说。涅槃二十六云。若知如来常不说法。是人名为具足多闻。大般若四百二十五云。我从成佛已来不说一字。汝亦不闻。五百六十七云。众生各各谓佛独为说法。而佛本来无说无示。净名第一云。其说法者。无说无示。其听法者。无闻无得。佛藏经第一念佛品云。佛告舍利弗。不能通达一切法者。皆为言说所覆。是故如来知诸语言皆为是邪。乃至少有语言不得真实。上所引经。但明不说。未出不说所以。若楞伽经兼出所以。故第三云。大慧复白佛言。如世尊所说。我从某夜得最正觉。乃至某夜入般涅槃。于其中间不说一字。亦不已说当说。当知不说是为佛说。大慧白佛言。世尊。如来应正等觉。何因缘故。说言不说是为佛说。佛告大慧。我因二法故作是说。云何二法。谓缘自得法。及本住法。是名二法。因此二法故。我作如是说。云何缘自得法。若彼如来所得我亦得之。无增无减。缘自得法。究竟境界。离言说妄想。离文字二趣。云何本住法。谓古先圣道如金银等性。法界常住。若如来出世。若不出世。法界常住。如趣彼城道。譬如士夫行旷野中。见向古城平坦正道。即随入城受如意乐。彼有偈云。我某夜得道。至某夜涅槃。于此二中间。我都无所说。缘自本住故。我作如是说。彼佛及与我。悉无有差别。有云佛无色声。总有五义。一遮过显德。二真俗二谛。三传古非作。四悲愿所成。五本质影像。初者为遮过患。故云不说。约显实德故说非无。如十卷楞伽第八云。如来不说堕文字法。若人言如来说堕文字法者。此即妄语。佛性论第二云。如来无有色声粗相功德可得。兜率偈云。色身非是佛。音声亦复然。亦不离色声。见佛神通力。此上皆显有过失之色声。则佛非有。无过失之色声。则佛非无。二真俗二谛者。真谛离相故明无说。俗谛随机故非无说。仁王观空品云。若有修习说听。即无说听。如虚空故。法同法性。一切皆如也。三传古非作者。谓佛所说。但是传述古佛之教。非自制作。般若论云。须菩提言。如来无所说。此义云何。无有一法唯独如来说。余佛不说故。四悲愿所成者。谓佛所有无尽三业。应众生者。皆是旷劫悲愿。为因顺众生感。非自所有故。说佛果无有色声。然则以他为自故亦有说。下经文云。如来不出世。亦无有涅槃以本大愿力。显现自在法。亦此意也。五本质影像者。谓佛三业平等普应。无彼差别影像色声。故说非有。然即与彼差别闻见为增上缘。因质有影故说非无。下经云。诸佛无有法。佛于何所说。但随其自心。谓说如是法。由上五义会诸圣教。说默无碍。皆悉有理。然上五义刊定记有而引文杂乱。今上所引颇为改易。所以疏不引者。以不出楞伽二因故。谓初一即缘自得法。自所得法即是证道。证法在己。离过显德。次三即缘本住法。本住即古先圣道。二即所证。三四即教道。传古非作。即古先圣道。悲愿所成即兼因果耳。其本质影像但通相说。本质无者顺自所证故。影像有者顺古圣人。即体妙用故。故云宗通。自修行说通示未悟。不说之义小有异相。故今叙之。上虽说所默之由皆兼有说之意。故思益第三云。如佛所说。汝等集会当行二事。若圣说法若圣默然。何谓说法。何谓默然。答言。若说法。不违佛不违法不违僧。是名说法。若知法即是佛。离相即是法。无违即是僧。是名圣默然。又善男子。因四念处而有所说。名圣说法。于一切法无所忆念。名圣默然。斯皆正说之时。心契法理即不说耳。明非缄口名不说耳。余可知。藏教所摄竟

大方广佛华严经随疏演义钞卷第九大方广佛华严经随疏演义钞卷第十

        唐清凉山大华严寺沙门澄观述

第三义理分齐中。疏文分二。先总明大意。后今显别教下。开章别释。前中分三。初结前生后。二总显深广。三结属所摄。今初两句。前句结前。谓前教摄中不别明摄者。以五教中第五圆教。指于此经义当已摄。况诸师立教。皆以华严为圆故知圆摄。后未知下。一句生后

疏。然此教海下。第二总明深广。有法喻合。令初至方显深广。法说也。初二句总标。宏大也。即是广义。色空交映德用重重。释深义也。然上二句言含法喻。如海傍无边涯连天一色。空彻海底。海映空天。即下四门之二。总摄归真。并皆空净。理事无碍。即色空交映。色不碍空。空不碍色也。德用重重。即唯明深义。具十玄门。重重无尽。即事事无碍。如海十德互相周遍

疏。语其横收下。释上广也。如下二地中。说人天十善等。即其文也。总无下。双结深广。疏。其犹下。喻明可知

疏。前之四教下。法合。以四教合于百川。圆教合于大海。于中先正合。后解妨。今初。言尚非三四况初二者。合前故随一滴迥异百川。即举胜显劣。三即终教。四即顿教。初二即小乘及与始教。虽有戒善。是圆教戒善。尚不同终顿之胜。以彼不能事事无碍故。况初二之劣。以彼尚不得二空。及事理无碍等故。其犹大海尚异江河。况于沟洫

疏。斯则有其所通。无其所局者。二释妨也。谓有难言。先则总收。后则总拣。二义天隔何以会通。故为此释。总收者。约其所通。如圆教中有小乘戒善之法四谛因缘。有始教中十地十如八识四智。有终教中事理无碍。有顿教中言思斯绝等。如海有百川之水。水义同也。后总拣者。约无其所局。如小乘唯人空自利。始教五性三乘。终教不说德用该收。顿教一向事理双绝等。如彼百川不同碱味。不具十德。海则具之。一次二不宿三余水入中四普同五无六深七广八大身九潮十普受大雨

疏。故此圆教下。结属所摄。于中三。初总显深广。次一乘有二下。别释深义。后通妨。二中言同教者。谓终顿二教。虽说一性一相无二无三。不辩圆融具德。事事无碍故非别教。而别教中有一性一相事理无碍。言思斯绝。同彼二教

疏。以别该同下。三通妨难。谓有难言。既同顿同实。何异顿实。故此通云。即此同中必有别义。如事理无碍。必有事事无碍耳。犹彼江水入海亦碱

疏。今显别教下。第二开章别释中二。先标章。后初中下。依章别释。释初章中三。初具列。次略释。后结广从略。疏教即能诠下二略释也。但释教义理事．二对。言乃至光香等者。谓诸法显义体。但能诠理并为教体。如下教体中明。有以光明而为佛事等是也。义即所诠。即五教等一切义理者。如前立教中约所诠。差别七十五法八识等义。十对法等皆是义也。疏。理即生空等者。具五教理。生空所显。是小乘教理。二空所显。是始教理。无性真如。是终教理。而言等者。等余二教之理。谓顿教理亦即无性真如。体绝安立。如性双遣。亦不离如。圆教之理。总融诸理。无有障碍耳

疏。事即色心等者。等取其余事类。如身广有多义。谓六道四圣等。若事门中无不此摄

疏。余可思者。即余八门。谓三境智者。即五教所观之境。能观之智。总收不出二谛二智。别即初小乘四谛涅槃为境。无漏净慧为智。及他心等十智。始教亦通四谛二谛等为境。加行根本后得等智。终教则是三谛等境。权实无碍等智。顿教则无境为境。绝智为智。圆教则无尽之境。无尽之智。四行位者。五教。修行不同得位差别。位通因通果。五因果自互不通。如七方便等为因。须陀洹等为果。等觉已下皆因妙觉为果等。六依即国土。正即佛身等。七体则法报。用则应化等。八人则觉者等。法则菩提等。九逆则婆须无厌等。顺则观音正趣等。十应即赴感。佛及菩萨等。感即当机。菩萨众生等。各随五教以辩差别。诸教具有故云可思。又此十对初一为总。后后渐略。若辩次第者。如来说能诠之教。所诠之理。则无法不尽。法有教理行果。行果并在所诠理中故。二就所诠理。虽复众多不出事之与理。即性及相无法不摄。三理该下八。且置而勿论。就其事中不出境智。四智观于境。便有造修之行。所成之位。五行位。未极总属因收。极则为果。六果中多法不出依正。因亦有之。七随依正中皆有体用。如正中体者法报。用者应化。依中体者法性等刹。用者应物随现。交入无碍因门例然。八正中自有人法不同。以法成人。以人弘法。九于人中逆化顺化。十人之逆顺必有感应。宜逆化感之。则婆须等应之。宜顺化感之。则文殊等应之。若依后后开一成二。则法弥多矣。谓如果分依正为二。因亦如之。则有四矣。正有体用。依亦如之。则成八矣。如是相望展转成多。不必全尔。是故疏中不为此释耳。又此十对。就其正意总相该收。以为十玄所依体事。若以义取。随一事中即有十对。如下胜音莲华处说。故下但约一尘即具十对

疏。第二摄归真实者。疏文有三。初标章。次真空绝相者。即指法之本后。后经云下。引文证成。二中。然杜顺和尚法界观中。总有三观。一真空绝相观。二事理无碍观。三周遍含容观。即是今疏四门之中。后之三门。初摄归真实。即真空绝相观也。于中自有四句十门。一会色归空观。二明空即色观。三空色无碍观。四泯绝无寄观。此为四句。前二各四。故为十门。初句四门者。前三同言色不即空。以即空故。释则不同。一色即空。明不即断空。以即真空故。二色不空。明青黄等不即真空。以青黄无体故。即是真空。三色不即空。空中无色可即。故云不即空。以会色归空。无有体故。即是真空。上三以法拣情。四色即是空。以无性故。如色既然。万法皆尔。第二明空即色观亦四门。前之三门。准前释言同释别。但翻云空不即色。以即色故。亦有三义。一空不即色。断空不即色。以真空必不异色故。二空不即色。以空理非青黄故非色。青黄之真。必不异青黄。故云即色。三空不即色。空是所依故不即色。必与能依为所依。故云即色也。上三拣情。四空即是色。凡是真空。必不异色故。第三空色无碍观者。谓色举体是真空故。色不尽而空现。空举体不异色故。空即色而空不隐。是故二法无碍一味。第四泯绝无寄观者。谓此真空不可言即色不即色即空不即空。一切法皆不可。不可亦不可。此语亦不受。迥绝无寄。言解不及。以生心动念乖法体故。以前八门拣情显理。第三门解终趣行。第四门正成行体。由解成行。行起解绝。上皆法界观义。所以疏中。不广引者。以第三色空无碍。滥于第二事理无碍观故。彼所以立者。以第四泯绝无寄。泯前三故。故名真空绝相。今但取一门总意。亦即泯绝无寄。又欲令四门成四种法界故。初门即事。次门即理。三即事理无碍。四即事事无碍。故第三事理无碍观中。疏文分三。初总标。二一理遍于事下。别释。三上之十事下。总结。今初。言十对皆无碍者。谓一教义无碍。二事理无碍。三行位无碍。乃至十应感无碍。今且约事理者。事理是所诠法中之总故。又诸处多明理事无碍故。为成四法界故

疏。一理遍于事下。第二别释十门即为十别。一一门中多先正释。后会前义。即前性相。不同中十对之义。或一门会一义。或二门同会一义。或一门以会多义。至文当知。又十对中唯会法性。以是同教一乘义理分齐故。如前云三乘一乘别。今但会一乘五性一性别。今但会一性。十对皆然。今初。第一门不会。至第二门。一时会故。疏中三。初标门。次谓无分限下。正释。谓理不可分故无分限。事随缘别故。分位历然。而不相杂。故得相遍。今明理不异事故遍事中。后故一一纤尘下。结成遍义。若不全遍则理可分。事不全摄亦不即理。如一纤尘。事事皆尔。正遍此时。不妨遍余。故亦非余处无理。全此全彼。亦非二理

疏。二事遍于理门者。文中二。先正明。后会前。前中所以要全同者。以事无别体。还如理故。若不全同。则不如理。色不异空义不极成。然相遍二门超情难见。何者。谓事既有分。理即无分。如何得遍。若尘遍法界。尘应非小。理遍同事。应如小尘。今明由事与理。有非一非异义故。以非异故全同。以非一故不坏。分别则事理两分。如海之波。一波全遍大海。以同海故。大海全在小波。以海无二故。全在一波。亦全在诸波。同一海故

疏。由上二义下。二会前义。于中二。先会一性。后会一乘。前中三。初明一性五性。二明成佛不成佛。三明无性即佛性。初中先正明。后引证。前中谓事有分限。理无分限。五性约事。一性约理。今理遍事。则一性之理。全在五性之中。事遍于理。五性即是一性。故云互该彻故皆同一性

疏。故出现下。二引证。此文释通二义。一正是事事无碍义。以众生及佛皆是事故。今取释文皆同一性之义故。证事理无碍。由理遍事故众生随理而在佛中

疏。理遍事故一成一切成下。第二明成佛不成佛义。谓理无二实。故该多事而皆成也。理如虚空故事同理而无成矣。经云。譬如虚空下。引证。亦出现品成正觉中义引之耳。文云。佛子。譬如虚空一切世界若成若坏。常无增减。何以故。虚空无生故。诸佛菩提亦复如是。若成正觉不成正觉亦无增减。何以故。菩提无相无非相。无一无种种故。即无所成义由上二义。欲成则念念常成。欲不成则十方三际无成佛者。故成与不成自在无碍

疏。一性无性即是佛性者。第三会佛性义。先正会。后故涅槃下。引证。以第一义空即佛性故。大意秖尔。欲穷法源。故复略引。然此经二十七。师子吼品。问于佛性。总有六问。一问云何为佛性(一问体性)二以何义故。名说佛性(二问性名义)三何故复名常乐我净(三问性德)四若一切众生有佛性者。何故不见一切众生所有佛性(四问众生不见所以)五十住菩萨住何等法。不得了了见于佛性。佛住何等法而了了见(五问住法差别)六十住菩萨以何等眼不了了见。佛何眼而了了见(六问用眼不同)答中答第一问经云。佛性者。名第一义空。第一义空名为智慧。所言空者。不见空与不空。智者见空及与不空。常与无常。苦之与乐。我与无我。空者。一切生死。不空者。谓大涅槃。乃至云。无我者。即是生死。我者。谓大涅槃。见一切空。不见不空。不名中道。乃至云。见一切无我。不见我者。不名中道。中道者。名为佛性。以是义故佛性常恒无有变异。无明覆故。令诸众生不能得见。荐福释云。然佛性有二。一性得。二修得。佛性名第一义空。第一义空名为智慧。智慧者。即性得中道智慧觉性。如密严云。如来清净藏。亦名无垢智。常住无始终。离四句言说。亦如下经云无相智无碍智。具足在于众生身中等。非是从缘智慧。名智慧也有自性遍照法界光明义。故名智慧也。从所言空下。明修得性。修得觉性。观第一义空。不见空与不空。离有无相故。从智者见空下。明见中道之人。智者即佛及菩萨也。从空者下。明空有等法也。空即遍计依他。不空即圆成实性。下文云。一切诸法皆是虚假。随其灭处。即是第一义空等。故知第一义空。是不空如来藏。非空如来藏。诸佛菩萨真俗双观。有无齐照。故名中道。又准下文云。佛性云何为空。第一义空故。云何非空。以其常故。云何非空非非空。能与善法作种子故。准此经文。第一义空。不是空如来藏。上即荐福意。亦有深理。今正释者。与上少异。初云佛性者。名第一义空。第一义空。名为智慧者。即双标空智。以第一义空该通心境故。明即是智慧。拣异瓦砾非情。从所言空者下。经自双释二义。所言空者。即是牒上第一义空。以空有双绝。方名第一义空。故云不见空与不空。智者见空及与不空下。释上智慧。经文稍略。若具应云所言智慧者。能见于空及与不空。故此中者字。非是人也。秖是牒词。此中言见。非约修见。但明性见。本有智性。能了空义及不空故。若无本智。谁知空不空耶。我无我等亦尔。约修见者。自在下经。佛答第五六问中。及无明覆下。方论见不见耳。今以即智明空。故名第一义空。即空之智。方是常恒智性。不生故常。不灭故恒。古德引下经空等二门。证成第一义空。非空如来藏。今观所引。正证是空如来藏义。云何非空已下。方证名为智慧之义。空智相成方为真佛性义。则知。二藏亦不相离。以其佛性妄法不染。故名为空。具恒沙妙德。故名不空。要空诸妄方显不空之德。故不相离思之。又言第一义空者。第一义谛上论空故。明知空性智性无二性也。故初言即是第一义空。又云。见一切空。不见不空。不名中道。中道者名为佛性。若尔双见。方有佛性。不双见时。应无佛性。故知一切空不空等言含于能所。约其所见空与不空。即是中道佛性。约其能见即是智慧。若不双见不识佛性。若见中道名见佛性。余如彼经及疏

疏。又出现云。无一众生下。第二会一乘无不有者。释成一乘之义。若有一人无智慧性。即有二乘三乘耳。三依理成事门中二。先总释。后会前。前中言要因理成者。以诸缘起皆无自性故。由无性理事方成故。故中论云。以有空义故。一切法得成。又离真心无别体故。疏于中有二下。第二会上二义。由前离真心外无别体故。成初具分唯识。由前无性理成。故成真如随缘之义。今初。言具分者。以不生灭与生灭。和合非一非异名阿赖耶识。即是具分。以具有生灭不生灭故。不生灭即如来藏。即会前唯心真妄别中即通真心也。若不全依真心。事不依理故。唯约生灭。便非具分。有云。影外有质为半头唯识。质影俱彰为具分者。此乃唯识宗中之具分耳。次引证言觉林偈。即夜摩宫中偈赞品。先有喻云。譬如工画师。分布诸彩色。虚妄取异色。大种无差别等。疏所引偈。即合上半。初句合譬如工画师。下三句皆合分布诸彩色。次引证具分偈亦合分布诸彩色。并如夜摩偈赞品释

疏。二明真如随缘成故者。即会前真如随缘凝然别中随缘义也。缘从真起。故依理成。离如来藏一切诸法不可得故。如问明品释

疏。四事能显理门中分二。先正明。后引证。前中谓由事揽理成者。蹑前第三门也。故事虚而理实者。由揽理成事。离理无事故。事即虚理则实也。以事虚故能显实理。事若有实。实理则隐。以事虚故。全事中之理。挺然露现。如波相虚令水现也。以波揽水成。故波虚而水实。是故波能显水。若离波说水。即事外明空。疏。依他无性等者。释成上义。即是会前依他空有即离别中即义。既云无性即是圆成。明非但无遍计妄性。别有圆成。是所显理。后夜摩下。引证。总引三文。初夜摩偈。即力林菩萨偈。三偈连绵。二引十忍品。即如向忍。三引须弥偈。即胜慧菩萨偈。下半云。如是解法性。即见卢舍那。此前有一偈。反释云。迷惑无知者。妄取五蕴相。不了彼真性。是人不见佛。其中深旨如随经疏文

疏。五以理夺事门等者。于中分二。先正释。后会前。今初。言事既全理即事尽无遗者。以离真理外无片事可得故。斯则水存。已坏波矣

疏。故说生佛不增不减下。二会前也。于中三。初正会。次引证。后非约一分众生下。拣异权宗

疏。出现品云下。引证。略引二经。初引出现云。乃至云设一切等者。其乃至中合云。菩提无相无非相。无一无种种故。佛子。假使有人能化作恒河沙等心。一一心复化作恒河沙等佛。皆无色无形无相。如是尽恒河沙劫无有休息。佛子。于汝意云何。此人化心化作如来。凡有几何如来性起。妙德菩萨言。如我解于仁所说义。化与不化等无有异。云何问言凡有几何。普贤菩萨言。善哉佛子。如汝所说。设一切众生下同疏。末后云皆以无相平等故者。义引合云等无有异。何以故。菩提无相故。若无有相则无增减

疏。不增不减经下。二引他经。言虽小异而文义多同

疏。六事能隐理门。即随缘之中别义。以随缘成事。此事遍于真理故。事显理隐也

疏。故法身下。引证。即法身经。疏。财首偈云者。即问明品。未曾有一法得入于法性。释曰。妄想体虚无可入故。七真理即事门者。以事必依理虚无体故。是故此理举体皆事。方为真理。如水即波。无动而非湿。故水即波也

疏。法性不违法相等故者。等字。等于余文。具云法性不违相。法相不违性。生不违法性。法性不违生。此两对明事理无违相。不违性。生不违性。自属事能显理。及第八事法即理门故。但略引性不违相一句。即第二十九经

疏。上之二门下。并合七八二门。会前五义。一会二谛空有即离别中相即义也。湿喻真谛。波喻俗谛。夜摩偈者。即精进林菩萨偈。彼初偈云。诸法无差别。无有能知者。唯佛与佛知。智慧究竟故。次文即云。如金与金色。其性无差别。法非法亦然。体性无有异。然法非法。有其二义。一善法为法。恶法为非法。此顺标中诸法无差别。二者法相为法。法性为非法。即金喻法性。色喻法相。今文正用后意。故证事法即理。二谛相即

疏。此亦喻于如来之藏。与阿赖耶展转无别者。二重会前唯心真妄别中通真心义。即金喻如来藏。色喻生死等。故密严云。如来清净藏。世间阿赖耶。如金与指环。展转无差别。由前第三门中已会故。致亦言

疏。又由事即理下。会不断常亦是二谛门中开出

疏。又由理事相即故。起灭同时者。会四相时一前后别中一时之义。事全同理。故事即灭也。以事虚无体故引偈。即善慧菩萨

疏。亦令究竟下。会能所断证。即离别中相即义也。然引十地断惑经文。但初一句是断惑相。三时无断方说断故。后之一句是般若相。今以般若亦为能断故。因便引之。故论释此句云。即是观行相。谓无分别智体绝名言。真智内发。不同声闻依声而悟。故既为真智。故可断惑。疏。回向品云无有智外如者。亦证断惑能所不二。义如前说。上所引经。皆至下本文自当晓了

疏。九真理非事门者。谓即事之理而非是事。以真妄异故。实非虚故。所依非能依故。如即波之水非波。以湿非动故。是则不异有之真空。空存也

疏。十事法非理门者。谓全理之事。而恒非理。以性相异故。能依非所依故。是故举体全理。而事相宛然。如全水之波。波恒非水。以动非湿故。是则不异空之幻事。事存也疏。上七八二门下。用前四门会前佛身无为。有为别中无为义也。然大品亦云。须菩提白佛言世尊。若是法平等无有高下。为是有为为是无为。佛言。非有为法。非无为法。何以故。离有为法。无为法不可得。离无为法。有为法不可得。须菩提。有为无为不合不散。皆其义也

疏。上之十事下。第三总结。即结释十门。于中二。先总标。后约理望事下。别束十门以成八字。理望于事有成有坏有即有离者。一有成者。即第三依理成事门。二有坏者。即第五以理夺事门。既夺彼事事则坏也。三有即者。即第七真理即事门。四有离者。即第九真理非事门。疏。事望于理有显有隐有一有异者。亦有四门。一有显者。即第四事能显理门。二有隐者。即第六事能隐理门。三有一者。即第八事法即理门。四有异者。即第十事法非理门。此上言成坏等者。就功能说如有成者。是理成事。非理自成。则一一门。皆有事理无碍。故云约理望事。约事望理。余可思之。上来相参。故有四对八义。而初相遍二门。今不会者。以相遍之义。义皆相似。非如一成一坏等故。故不显之。又相遍者。即后八门之所以。故谓由相遍方有成坏等耳。若欲摄者。即事理相即二义所。收后之不即二门。即不坏能所方有相遍。有相遍故。方论不即。疏。逆顺自在等者。事理相望。各四义中。皆二义逆。二义顺。谓依理成事。真理即事顺也。以理夺事。真理非事逆也。事能显理。事法即理顺也。事能隐理。事法非理逆也。欲成即成。欲坏即坏。故云自在。成不碍坏。坏不碍成。显不碍隐。隐不碍显。故云无碍。正当成时即是坏等。故得同时。四对皆无前后。故云顿起。又上四对。何以约理望事。但云成等。不云显等。约事望理。但云显等。不云成等。深有所以。何者事从理生。可许云成。理非新有。但可言显。事成必灭。故得云坏。真理常住。故但云隐。其即之与一。离之与异。大旨即同。细明亦异。理无形相。但可即事。而事有万差。故可言与理冥一。理绝诸相。故云离事。事有差异。异云异理。上约义别。有此不同。若统收者。应成五对无碍之义。一相遍对。二相成对。三相害对。四相即对。五不即对。五中前四。明事理不离。后一明事理不即。又五对中共有三义。成显二义一对。是事理相作义。夺隐及不即二对。是事理相违义。相遍及相即二对。是事理不相碍义。又由第二相作故。有第四相即。由相即故。所以相遍。由有第三相害故。有第五不即。又若无不即。无可相遍。故说真空妙有。各有四义。约理望事。即真空四义。一废己成他义。即依理成事门。二泯他显己义。即真理夺事门。三自他俱存义。即真理非事门。四自他俱泯义。即真理即事门。由其即故。而互泯也。又初及三。即理遍于事。门以自存故举体成他。故遍他也。后约事望理。即妙有四义。一显他自尽义。即事能显理门。二自显隐他义。即事能隐理门。三自他俱存义。即事法非理门。四自他俱泯义。即事法即理门。又初及三。即事遍于理门。以自存故而能显他。故遍他也。故说约法存亡无碍真空隐显自在。第四周遍含容观。于中二。先标举章门。后依章别释。今初。然此观名。即法界观中之名。以当事事无碍。以理有普遍广容二义。融于诸事。皆能周遍含容。众多义门。皆悉由此二义而有。然法界观立十观名。与十玄不同。故今疏云。且依古德显十玄门。即依藏和尚也。至相已有而小有不同。于中文二下。开章。疏今初一同时下。二依章别释。释其二章。即为二别。今释初章。疏文有三。初列名总显。二指事别明。三结例成益。今初十名全依贤首。是故上云。且依古德就列名中。其第二广狭自在门。同法界观中广容普遍之义。而名小异此门。贤首新立以替至相十玄。诸藏纯杂具德门。意云一行为纯。万行为杂等。即事事无碍义。若一理为纯。万行为杂。即事理无碍。恐滥事理无碍。所以改之。主伴一门至相所无。而有唯心回转善成门。今为玄门所以。故不立之。而列名次。亦异于彼。彼云。一同时具足相应门。二因陀罗网境界门。三秘密隐显俱成门。四微细相容安立门。五十世隔法异成门。六诸藏纯杂具德门。七一多相容不同门。八诸法相即自在门。九唯心回转善成门。十托事显法生解门。今此十门不依至相者。以贤首所立有次第故。一同时具足相应门。以是总故。冠于九门之初。二广狭门别中先辩此者。是别门之由。由上事理无碍中。事理相遍故。生下诸门。且约事如理遍故广。不坏事相故狭。故为事事无碍之始。三由广狭无碍故。所遍有多。以一望多故。有一多相容。相容则二体俱存。但力用交彻耳。四由此容彼。彼便即此。由此遍彼。此便即彼等故。有相即门。五由互相摄。则互有隐显。谓摄他时。他可见故。有相入门。又摄他时。他无体故。有相即门。摄他他虽存。而不可见故。有隐显门。以为门别故。故此三门皆由相摄而有。相入则如二镜互照。相即则如波水相收。隐显则如片月相映。六由此摄他。一切齐摄。彼摄亦然。故有微细相容安立门。七由互摄重重故。有帝网无尽。八由既如帝网。随一即是一切无尽故。有托事显法生解门。九由上八皆是所依。所依之法既融。次辩能依。能依之时亦尔。十由法法皆然故。随举其一。则便为主。连带缘起。便有主伴。广如下释。然刊定记。则分德相业用。各有十玄。德相十者。一同时具足相应德。二相即德。三相在德。四隐显德。五主伴德。六同体成即德。七具足无尽德。八纯杂德。九微细德。十因陀罗网德。二业用十者。一同时具足相应用。二相即用。三相在用。四相入用。五相作用。六纯杂用。七隐显用。八主伴用。九微细用。十因陀罗网用。其德相门中。无业用门中四五二门。业用门中无德相六七二门。彼师意云。业用是应机施设故。有相入相作。以本不入今见入故。本来众生非佛。今生佛相作故。故是业用。德相不尔。故无相作相入。其德相本具故。有同体即一切法德。及具足无尽德。业用不尔。故无此二。此四互出故各有十。历门备举。便成二十。今明德相业用虽异。不妨同一十玄。无不该摄。德相。亦有相入相作故。故彼相在。即相入也。彼相作者。乃相即也。名异义同今见出入。即业用门。常相涉入如镜互照。即德相门。以众生为佛。生即佛也。以佛作众生。佛即生也。故知相作即是相即。若约对机而作。名业用门。本来相即。是名德相门。依此而分。非无小异。统其体事。更无别也。是知相即相作。二名虽异。而无两门。入在小殊始终一致。又德相不能入作。真如则阙此德。不应有普摄诸法之德。及遍一切法德亦应无有能安立德及能持世间。成就一切诸佛菩萨之德。故常作入于理无违。如有颂言。诸佛犹如净明镜。我身一似摩尼珠。诸佛常来入我体。我身遍入诸佛躯。即常入也。又真如随缘成一切法。何无作耶。若随情见作入。则但有业用义也。其同体成即德乃是。此中托事显法生解门。但名异耳。故彼自释云。一一即是一切诸法也。故与下释托事义同。其具足无尽德。即帝网门。亦微细门摄。并如下会。又彼不存广狭而存纯杂。亦如下会。而彼无十世隔法异成门。彼以时为所依体事故。故彼体事。亦有十种。谓色心时处身方教义行位。则摄法无遗。斯亦有理。今明时无别体故。不为所依。但依法立故入玄门耳。亦如下会

疏。今且于前十中下。第二指事别明。分二。先总辩所依。即于前彰无碍中一事法。后如下文中。一莲华叶下。别显十门。即为十别。初即同时具足相应门。以近初列故不标次。文中先正明。后引证。前中又二。初明当门中具。后明具余九门。疏。则具教等十对。同时相应具足圆满者。初当门中具也。此中正意。则明具前教义。理事境智行位因果等十对之法。前十对法无法不包故。此顿具则无所不具。所以具者。广有十因。略而言之。法界融故。然古德就一华之上义有此十。探玄记云。此一莲华。表令生解为能诠教。则是所诠乃名为义。如下胜音菩萨莲华处说。二华相为事。华体为理。三华是所观。亦即是能观。以此经中可以内行为外事故。四行事之华。结成位故。如净行品。五因事之华。揽成果故。六华台所依亦入正故。如国土身等。七华体同真。用应机故。八全揽为人。恒是法故。九逆同五热。顺同十度故。十应赴群机。亦能感故。如一华事既尔。余一切事准以知之。如事法既尔。余教义等一切皆然。准思可见。如具自十对既尔。彼一华叶具十门亦。然。释曰若依古德。此义则一事华上。已有此十义。前十对上。复各有十。令一事华顿具十十。亦有斯理。今此疏意。但令顿具前十。已无不收耳

疏。亦具后之九门及彼门中所具教等。以是总故者。此第二明具余九门。亦释成总义。若唯具当门。不成总故。而言所具教等者。下九门各有教义理事境智等故。今能具门既全在初门。门门所具。居然在此。然九门具教等虽同。于义各别。谓如广狭门。则十皆广狭。谓教广狭。义广狭。理广狭。事广狭等。若相入门。则十皆相入。下七例然

疏。故下文云下。第二引证。于中有二。先引妙严品。即普智眼广果天王偈。彼偈下半云。如是法性佛所说。智眼能明此方便。此明一门中具无尽法。则无不具足也。后引华藏偈下半云。宝光现佛如云集。此是如来刹自在。今但引于尘含法界。便是总义以教义理事境智。及广狭相入等即法界故。问但言法界。宁知非是理法界耶。答曰。以下半云宝光现佛如云集。此是如来刹自在。明知是含事法界耳。疏。一尘尚具况一叶者。举细况粗。释成玄妙耳。又妙严品。喻佛身云。譬如虚空具含众像。此举佛身具足诸法也。人晋经性起品云。三世一切劫佛刹及诸法。诸根心心所。一切虚妄法。于一佛身中。此法皆悉现。是故说菩提无量无有边。亦约佛身心具也。又普贤三昧品云。能令一切国土所有微尘。悉能容受无边法界。据能令之言。但以业用。总由德相。本自具足。即是德相。令物见之。即为业用。下业用准之。第十行云。此菩萨于其身中。现一切刹。一切众生。一切诸佛。八十云。善财见普贤一一身分。一一毛孔。皆有十方一切世界。三千界中地水等轮。诸山河海人天宫殿。种种时劫。诸佛菩萨。如见现在世界。如是前际后际。一切世界中悉亦明见。乃至十方刹尘中。现三世一切境界。一切佛刹。一切众生。一切佛出兴一切菩萨。及闻佛菩萨众会言音。斯并同时具足相应门也

疏。二即彼华叶普周法界而不坏本位下。二广狭自在无碍门。于中二。先正明广狭。后会通纯杂。前中有三。初正明。次引证。后句数。今初。上二句出广狭相。言以分即无分无分即分者。出其所以。由华是事分限历然。而即同真性。故无分限。便广无际。以事如理故。无分即分者。明广即狭。以不坏相故

疏。十定品下。二引证。即第十无碍轮三昧之文。当四十三。有一莲华尽十方际。即是经文。然其犹略。具云佛子。菩萨摩诃萨有一莲华。其华广大尽十方际。以不可说叶不可说宝不可说香。而为庄严等。次云而不妨外有可见者。乃是义引。彼经具云。众生见者无不礼敬。故知亦有外相可见也。七十七经。善财叹楼阁云。不动本处而能普诣一切佛刹者之所住处。七十六经。摩耶夫人云。又善男子。彼妙光明入我身时。我身形量虽不踰本。然其实已超过世间。所以者何。我身尔时量同虚空。悉能容受十方菩萨受生庄严诸宫殿故。如是等文。皆广狭自在也

疏。是故或唯广下。三句数分别。初事如理故广。二不坏本相故狭。三此二同时。故有即广即狭。四同时互夺。故有俱泯。五具前四一时照了。故云解境行起解绝。故有第六。总绝前五。谁复以广狭存泯当其方寸

疏。然此广狭亦名纯杂下。二会纯杂门。以古十玄有此名故。贤首意云。万行纯杂。有通事理无碍。及单约事说故废之耳。谓同一法界故纯。不坏事相故杂。此即事理无碍也。一行长行故纯。不妨余行故杂。此但约事也。故昔废之而立广狭。今欲会取即事同理而遍故纯。不坏一多故杂。则亦有事事无碍义耳。如以入门取之。则一切皆入故纯。入中有多法门。故名为杂。如妙严品说。诸众海各各唯得一解脱门纯也。普贤菩萨得不思议解脱门杂也。六十五经慈行童女云。我于三十六恒河沙佛所。修得此法。彼诸如来各以异门。令我入是般若波罗蜜普庄严门。即纯杂无碍也。又善财童子所求诸善知识各言。我唯知此一法门故。又云多劫唯修此一门者。即纯门也。诸善知识皆推进云。如诸菩萨种种知见。种种修行。种种证得者。此杂门也。自言知一推他有多。自他虽异然属一义。此亦纯杂无碍门也。又善财普获诸善知识解行德证。亦杂门也。然上所引数处经文。多皆约行。一行多行为纯杂故并通。及单约事明。然通德相。若准无著无缚解脱回向云。以无著无缚解脱心。于一门中示现。经不可说不可说劫无有穷尽。令一切众生皆得悟入。以无著无缚解脱心。成就普贤自在力。于种种门示现。经不可说不可说劫无有穷尽。令一切众生皆得悟入。其身普现一切佛前者。即约用纯杂也

疏。万行例然者。即约行说纯杂。通于事理事事无碍。及单约事行也。约事事无碍者。如一施行一切皆施名纯。施中具于诸行名杂。第三一多相容不同门。于中有三。初正明。次引证。后重料拣。初中有二。先正释。即如理之遍。如理之包。后舒摄同时下。句数料拣。例上广狭。故云思之。若具作者。一或唯入。以一入一切故。二或唯摄。以一摄一切故。三即入即摄。同时无碍故。四非入非摄。以入即摄故非入。摄即入故非摄。五或具前四。以是解境故。六或绝前五。以是行境行起解绝故。疏下云。以一佛土满十方。十方入一亦无余者。引证。即德相之文其下半云。世界本相亦不坏。无比功德故能尔。上即晋经依贤首引。即当华藏偈云。以一刹种入一切。一切入一亦无余。体相如本无差别。无等无量悉周遍。第八回向云。此菩萨于一毛孔中。普能容纳一切国土。第九回向云。于一身中悉能包纳。尽法界不可说不可说身。而众生界无增无减。如一身乃至遍法界一切身。悉亦如是。十定品第二定云。三千大千世界微尘数三千大千世界。悉入是菩萨身。是菩萨身亦入是诸世界。第七定云。菩萨自见其身往彼众会。亦见自身普入诸地。普贤行品。有十种普入。谓一切世界入一毛道。一毛道入一切世界等。上来经文。并通德相业用。离世间品十种无碍用中。亦说。众生一多相入。六十经云。上方菩萨以自在力。令一切世界展转相入。六十一经云。此诸菩萨入一切无诤境界。乃至能令大小相入。以一切方普入一方等。十行品云。能于一一三昧中。普入无数诸三昧。无量无边诸国土。悉令共入一微尘。如是等文。多约业用。明相入义。或通德用。或各局一。可以意得

疏。若一与一切对辩下。三重料拣。谓上来约一华叶望余。但有一入一摄。多入多摄之义。故今更对余一多等。皆有摄入。于中有二。先明相入。后辩相摄。初中言一入一切者。如前初句。第二一切入一者。即以多法来入此一华。第三一入一者。即以一华随对一法。如一华叶入一佛身。第四一切入一切者。独用一华此句不成。即将多华及诸佛诸菩萨等。别入余华诸佛等也

疏。互摄亦然者。后例辩相摄也。上之四句。但明入义。今摄亦四。第一句一摄一切者。谓以一华普摄一切诸法。第二句一切摄一者。谓以余一切华。摄此一华等。第三句一摄一者。即以一华但摄一佛等。第四句一切摄一切者。即以多华多佛等。摄余多华多佛等也。此二种四句相隐。故疏说之。随一四句中。复应更有具四绝五。皆以成六句。例前可思。故略不显。然相入门。刊定记主。德相不立。谓业用则有。德相之中即有相在。此公意谓。相入相在二相别故。今明入即在义。如一镜影在多镜中。岂非入耶。若常相入。即属德相。今见相入。即是业用。曾何大殊

大方广佛华严经随疏演义钞卷第十大方广佛华严经随疏演义钞卷第十一

        唐清凉山大华严寺沙门澄观述

第四相即门。于中有三。初正释。次句数。后引证。初中言废己同他者。是相即义。以上相入。则此彼互存。如两镜相照。但约力用交彻明耳。今此约有体无体。故言废己。废己。即无己体也。同他。他有体也。亦如事理无碍文中。废波同湿等。摄他同己。即他无体己有体也

疏。一多相即混无障碍。解行境别六句同前者。二句数料拣也。于中初句结前。含于四句。应云一者一即多。二者多即一。三者亦一即多。亦多即一。合上二故。故三句皆是一多相即。四非一即多。非多即一。亦由一多相即互相夺故。谓由一即多故非多即一。由多即一故非一即多。成俱泯句。五或具前四。以是解境并明照故。六或绝前五。以是行境言亡虑绝故。疏云解行境别。即下二句。然约同一类。法即有一多相望。如一华叶望诸叶等。若约异类。谓华望刹等。例此可知。复应例前亦有四句。谓一者一即一。二者一即一切。三一切即一。四一切即一切。以今但约一华故。略不言。故下结例。该一切法明具四也。或应有六。此四句后有解行境故。复或有六。谓前四句。后加一即多。一多即一多故。复应成八。加多一即一。多一即多。以并不出前四句故。故不例耳。多一既尔。大小长短等。一一相即例知。然刊定记。将相即门拣异同体成即德故云相即。据此彼相望同体相即。约此体即是一切法故。若尔则是托事显法门。今疏正意。但以相即门。摄同体成即。同体成。但是一即多耳。疏下云下。三引证。即十住品长行文。若偈云。一即是多多即一。文随于义义随文。如是一切展转成。此不退人应为说。既言展转成者。即异体异类相望也。不思议法品云。诸佛知一切佛语。即一佛语。此同类相即也。初发心品云。以发心故。即与三世一切诸佛体性平等。乃至云真实智慧等者。此显位上下相即也。七十八经云。弥勒告大众言。诸仁者。余诸菩萨经无量百千亿那由他劫。乃能满足菩萨行愿。乃能亲近诸佛菩萨。此长者子。于一生内则能净佛刹。则能化众生。则能以智慧深入法界。则能成就诸波罗蜜。则能增广一切诸行。则能圆满一切大愿。则能超出一切魔业。则能承事一切善友。则能清净诸菩萨道。则能具足普贤诸行。此则行位。皆相即也。又如菩萨曾不分身。即遍一切。亦一即多也

第五秘密隐显俱成门中。疏文分四。一正释。二句数。三引证。四喻显。初中华能摄彼等者。亦蹑前起。由上言摄他同己故。若摄他他现。即相入门。若摄他他尽。乃相即门。若摄他他不尽不现。即隐显门。如前列名中已会。故至相十玄云。犹如十钱一摄十时。一即名显。二三至十即名为隐。亦如见此不见彼。彼名隐此名显。亦如一人身上六亲。互望虽各不同。然各全得亦不杂乱。由此隐显体无前后。不相妨碍。名秘密俱成。疏。显显不俱等者。以显俱则无隐。隐俱则无显故不得具。然隐显同时。故得俱成。隐显无碍。故云秘密

疏。全摄俱泯存亡俱成者。二句数料拣。全摄即初二句。此全摄彼。即此显彼隐为一句。彼全摄此即彼显此隐。为第二句。俱成者第三句。谓此正摄彼时。不妨彼摄此故。则亦隐亦显。泯者。即第四句。此摄彼为显时。即是彼摄此故非显。则显泯也。彼摄此为隐时。即是此摄彼故非隐。则隐泯也。故是非隐非显存者。四句皆成。是解境。亡者。五句并绝。即是行境。言俱成者。总结上六句也。疏下云东方入正定下。引证。东方入正受为显。西方从定起为隐。以此但见入定不见起故。古十玄亦云。于眼根中入正定即是显。于色尘中三味起即是隐。例上可知。疏如八日月等者。四以喻明。即取明处为显。暗处为隐。而必同时故云俱成。不同十五日唯显月晦日唯隐。又暗处非无明。明处非无暗。但明显处暗隐。暗显处明隐。亦得云隐显俱成。亦如夜摩偈云。十方一切处。皆谓佛在此。或见在人间。或见在天宫。则见处为显。不见处为隐。非佛不遍。十定品云。或见佛身其量七肘。或见佛身其量八肘。或见佛身其量九肘。乃至见佛身不可说。不可说佛刹。微尘数世界量。则见七肘时七肘显。余量皆隐也。余显例然。故彼喻云譬如月轮阎浮提人见其形小。而亦不减。月中住者。见其形大而亦不增。释曰。见大则大显小隐。见小则小显大隐。而不增减。则是秘密俱成。余一切法。类可知也。摩耶夫人云。于此一处。为菩萨母三千世界。为母亦然。然我此身。非一处住。非多处住。亦隐显义。此处为母。此显彼隐等。非一处住。即是一隐。例有多显。非多处住。即是多隐。例有一显。亦是双夺俱泯之句。非隐非显秘密之义。然若约智幻。即业用门。约极位成。即德相门

第六微细相容安立门。于中分二。先正明。后引证。前中炳然齐现者。炳然者明也。如琉璃瓶盛多芥子隔瓶顿见。然微细言。总有三义。一约所含微细。犹如芥瓶。以毛孔能受彼诸刹。诸刹不能遍毛孔故。以毛据称性。即如琉璃之瓶。刹约存相。故如芥子在内。二约能含微细。以一毛一尘。即能含故。如下引证。三约难知微细。微尘不大。刹亦不小。而能广容。即难知义。一能含多即曰相容。又法法皆尔。故云相容。一多不坏。故云安立。疏下云。于一尘中下。引证。略引二文。初即晋经。又于一毛端处有不可说诸如来者。第十回向云。一毛孔中悉明见不思议数无量佛。一切毛孔皆如是。普礼一切世间灯。即其文也。然此二文。正唯德相。六十八云。一一毛孔内。各现无数刹等。即业用门。又德云比丘云。住微细念佛门。于一毛端处。有不可说如来出现。悉至其所而承事。故通于德相业用。第九回向云。彼菩萨于一念中。现一切众生各不可说念心。即业用门。十微细趣中。通于德相业用。然刊定记。开此微细以成二门。第三名相在德。第九名微细德。而自拣云。此不同前相在之义。彼约别体别德。相望相在。此但当法即具一切。炳然齐着。若尔此中一切法。为是法界中有法耶。为一法中别自有耶。若是法界中法。则同相在。若是别有。为示为真。示则复是业用门收。以彼立业用德相别故。德相之中则无微细。若是真者。何异同时具足相应门耶。故彼自释微细门云。此门亦可名为普门。七十一中寂静音海夜神。谓善财言。此解脱者。即是普门。于一事中普见一切诸神变故。既言普门。即同同时具足相应门也。若言唯摄同类一切法者。如十微细中八相之中。一一各具余之七相。岂要同类。况一尘中一切诸法旷然安住。明知相在。即是微细。是故古德有相容言。设此不摄。即是相入门中所收。如前已会。故知新立多有相滥。设有小异。皆本门收之。十门即足

第七因陀罗网境界门。疏文分四。一正释其相。二以喻释名。三引文证成。四重以喻显。今初。一华一尘以称性故。能摄一切。余尘余法亦皆称性。何有一法而不摄耶。应以尘对余尘。以辩重重欲令易见。且以一尘望余尘说。谓一尘之内所含诸刹。彼所含刹亦揽尘成。此能成尘亦须称性。尘既称性亦须含刹。第二重内所含诸刹亦揽尘成。尘复称性亦须含刹。第三重尘含第四重刹。第四重尘含第五重刹。重重尘成重重称性。无穷无尽犹如镜灯。故下疏文。重举镜灯以喻帝网。令于常情见近知远。疏如天帝下。以喻释名。十门唯此从喻受名。若就法立。应名重现无尽门。一珠之内顿现万象。如一尘内顿现诸法。但是一重一珠现于多珠。方成重重之义。珠皆明净如尘称性。一珠现于多珠。犹如一尘现多刹尘。所现珠影复能现影。如尘内刹尘。复现刹。重重影明。重重互现。故至无尽。疏下文云。如因陀罗网世界者。三引证。即是初地承事愿中文云。又发大愿。愿一切世界广大无量。粗细乱住。倒住正住。若入若行。若来若去。如帝网差别。十方无量种种不同。智皆明了。现前知见。论释云。如帝网差别者。即真实义相。意明常称实理。故不可尽。又阿僧祇品云。一尘中刹不可说。如一一切皆如是。此不可说诸佛刹。一念碎尘不可说。念念碎尘悉亦然。尽不可说劫恒尔。此尘有刹不可说。此刹为尘说更难等。不思议法品云。诸佛有十种知。一切法尽无有余。第十云。诸佛知一切法界中如因陀罗网差别。尽无有余等。此约德相。若约业用。普贤三昧品云。佛身所现一切国土。及此国土所有微尘。一一尘中有世界海微尘数佛刹。一一刹中有世界海微尘数诸佛。一一佛前有世界海微尘数普贤菩萨。此亦重重义。然刊定记。于此开出第七具足无尽德。谓一一自体皆无穷尽。如水中纹。此不同帝网互在重重。但就当体即具无尽耳。又亦不同微细。微细约一中多法齐现。此约一一即无穷尽。妙严品云。佛身普遍诸大会。充满法界无穷尽。又云。其菩提树恒出妙音。说种种法无有尽极。十住颂云。欲具演说一句法。阿僧祇劫无有尽。而令文义各不同。菩萨以此初发心。六十五说。具足优婆夷。于一小器之中。出一切资具饮食等。毕竟无尽然不减少。彼自释云。此明体德自在。非约解脱等业用。古德所以不开者。一重无尽。与重重互望无尽。同无尽故。若微细顿现。现于法界。法界无尽故微细亦无尽。纵出生无尽亦不出法界。若细分别非无小异。统其大意。但取无尽。故依古德不分为二。疏亦如下。四重以喻显。以重现之理深远难测。帝网之喻世不见形。故以近事。以况远旨

第八托事显法生解门。疏文有三。初正释次拣滥。三引证。今初。既言即是无尽法界。明知即是事事无碍。古立第七具足无尽。不异于此

疏。非是托此别有所表者。二拣滥。谓拣余教以事表义。但是一事以表一法。如衣表忍辱。室表慈悲等。今明一事。即法即人。即依即正。具无尽德。从无尽因之所生故

疏。下文云。此华盖等者。三引证也。即升兜率天宫品中。彼有三段。文含四义。谓初一段。文有十句。明于多因以成多果。谓并列多因复说多果。故经云。百千亿那由他不可说。先住兜率宫诸菩萨众。以从超过三界法所生。离诸烦恼行所生。周遍无碍心所生。甚深方便法所生。无量广大智所生。坚固清净信所生。增长不思议善根所生起。阿僧祇善巧变化所成就。供养佛心之所现。无作法门之所印。释曰。此上并出因也。下云。出过诸天诸供养具。供养于佛者。即说多果也。次八句一因成一果。经云。以从波罗蜜所生。一切宝盖。于一切佛境界清净解。所生一切华帐。无生法忍所生一切衣。乃至解诸法如梦。欢喜心所生。佛所住一切宝宫殿。既以无生忍唯生于衣等。故云。一因唯生一果。后有九句。一因成多果。谓但举无生为因。总生诸果故。经云。无著善根无生善根所生。一切宝莲华云。一切坚固香云。一切无边色华云等九云故。应有多因成一果。摄在初段。谓以多因一一成故。谓共成一盖。共成一衣等。今约多因成一果时。则随一衣则是盖等。以其多因别别所成。并在一衣上故。故随一事即是无尽法界。况此一事皆是称性故。皆即是无尽法界。但随一义。以名目之如显可重圆明之义。即名为宝。若云自在即称为王。若为润益即名云等。故金色世界即是本性弥勒楼阁即是法门。胜热婆罗门。火聚刀山。即是般若无分别智等。皆其事也。故一一事即具无尽之法故。故立具足无尽之德。不出于此

第九十世隔法异成门。疏中三。初正释。次引证。后拣滥。今初。三世区分。名为隔法。而互相在即是异成。而疏文中。但作十世言三世各三等者。取意以立。即离世间品意。文云。菩萨有十种说三世。何等为十。所谓过去说过去。过去说现在。过去说未来。现在说过去。现在说平等。现在说未来。未来说过去。未来说现在。未来说无尽。又三世一念。总成十世。上言无尽即是未来未来。欲彰无穷故云无尽。现在平等即现在现在。以可目睹。例同过未。故云平等。不言一念。亦名九世。摄归一念。故云十世。然若依旧解。如以五日而为九世。初一二三为过去三世。中二三四为现在三世。后三四五为未来三世。义当正在第三日。前望取二。后望取二。故有五日。成三三世义。似进无九世之体退过三世之数。今但用三世互为缘起。便成九世。不离一念故为十世。谓如因过未而有现在。则现在中已有过未。法从因出不异因故。余二因二例此可知。即中论时品。破于执时立无穷过。今无所执。故以其过成称性缘起。广如离世间品。疏文释之

疏。以时无别体下。出十世融通所以。如见华开知是芳春。茂盛结果知是朱夏。凋落为秋收藏为冬。皆因于物知四时也

疏。晋经下引证。引晋经不释者。以文显故等者。等取次半云。非长亦非短。解脱人所行。即当今经普贤行品。如下所引

疏。普贤行云。过去中未来。未来中现在等者。等取下半云三世互相见。一一皆明了。即同向引晋经偈也。此偈前文复有偈云。无量无数劫。解之即一念。知念亦无念。如是见世间

疏。无量劫即一念。一念即无量劫。即晋经初发心功德品。今经云。不可说劫与一念平等。一念与不可说劫平等。而言等者。等取余经。若此之类皆可引证。如十地品第十地云。菩萨知种种入劫智。所谓一切入多劫。多劫入一劫。乃至云。长劫入短劫。短劫入长劫等

疏。时无别体故不别立。以为所依者。三拣滥也。以刊定记不取十世以为玄门。意云。以时是所依体事十中之一。若长劫入短劫等。即相入门耳。若云长劫即短劫。即相即门。故知十世非别玄门。斯亦有理。古意以余十对有体可得。得为所依。时依法有。无别自体。何能与他为所依耶。又缘外道计时为常故不存之以为体事。是故依古别立玄门

第十主伴圆明具德门

疏。文分三。初正明。二引证。三重以例释。今初。理无孤起者。即主伴所由。疏下云此华即有下。二引证。即十地受位处文。文云。其最后三昧名受一切智胜职位。此三昧现在前时。有大宝莲华。忽然出现。其华广大。量等百万三千大千世界。下广叹德竟云。有十三千大千世界微尘数莲华。以为眷属。即华眷属。又现相品中。佛眉间出胜音菩萨。与无量诸眷属俱时而出。即入眷属。佛放眉间光明。无量百千亿光明以为眷属。即光明眷属。又法界修多罗以佛刹微尘数修多罗。而为眷属。即法眷属。故随一一皆有眷属。若以余经望此。但为眷属。不为主伴。今言眷属者。约当经中事以为眷属。眷属即伴。故证主伴。疏。又如一方为主下。亦是义。引经文约方。明主伴如此方法慧菩萨说十住时。余方菩萨皆悉来证言。我等佛所亦说此法。文句义理与此无别。即主伴义

疏。是故主主伴伴下。三重以例释。谓此方法慧为主之时。不得为伴。十方法慧为伴之时。不得为主。故此为主时。不得与彼为主相见。彼为主时。此须为伴。故亦不得见此为主。故云。主主伴伴各不相见。言主伴伴主则得相见者。此方为主。与彼方为伴相见。此方为伴。即与彼方为主相见。若主伴义成。则圆明具德。余如教迹钞说

疏。举华既尔下。第三结例成益。于中二。先举一例。余后结劝修益。前中文有四节。初以华例事。二以事例余所依。三以所依例能依门。四结成重重以至无尽。今初又二。先正明。以华事例于余事。故云举华既尔。一尘等事亦然。后如此事华既带同时下。类结成门。谓上广说十门唯约事说。谓华事上说。一切事同时具足。事广狭无碍。事一多相容。事一多相即乃至主伴。故云此事华既带同时具足等十义。后而此事等具余教等十门者。谓事上有教义同时具足。教义广狭。教义一多。教义相即。乃至教义主伴。复为二十也。一境智同时具足。广狭相容乃至主伴。复为三十也。三行位同时具足。广狭乃至主伴。复为四十。四因果同时具足相应等。复为五十。五依正。六体用。七人法。八逆顺。九感应。各有同时等。添为百门。故云而此事等具余教等十门。则为百门

疏。事法既尔下。第二以事所依。例余所依教等九。谓事法既有百门。二教义为百门。三境智为百门。乃至感应皆具百门。故有千门

疏。如教义等有此千门下。第三以所依法。例能依玄门。亦成千门。谓前以所依体事为首。今以能依玄门为首。谓同时门中。具同时教义。同时事理。同时境智。乃至同时感应。故有十门。同时门中具广狭等。其广狭等。有广狭教义等。故成百门。二广狭具百例同时耳。三相容门具百。四相即门具百。乃至第十主伴门具百。故成千门。然其后千不异前千。但互举为首而成异耳。又前分总别。则同时门中具下九门。下之九门不具同时。今约不相离说。故得九门例前同时。亦具九门。成二千门

疏。若重重取之亦至无尽者。四结成无尽。言重重取者。谓如初一门中具十。十中取一。此一亦须具十具百具千。以不相离故。如一既尔。千门各十义类亦然。则具十千。十千之中随取其一。亦具十千。如一千钱共为缘起。一钱为首。则具一千。余亦如是。则有千千。千千之中。随取其一。亦具千千。故至无尽。又重重者。一事之中有多事故。一境之中亦有多境。一智之中复有多智等。更相涉入亦无尽也

疏。于此十门下。第二结劝修益。以是德相无尽法门。唯普眼境界上智能入。故当勤修必成大益

第二德用所因。疏文分三。初问答总明。二初唯心下。随门别释。三由上十因下。总结所属。初中有四。一标举章门。二问有何因缘下。假问生起。三答因广难陈下列数总答。四十中随一下。总相会通。于中有三。初总标功能。次十中前六下。料拣差别。谓前十玄门则通德相业用。今出所以。则有通局耳。三从前十门下。会通德用。遮其异释。谓由刊定记。别立德相业用二种十玄故。今通之。明但一重自含德用不须分二。于中有二。先别明。后结成。前中亦二。先以互通释非两别。后通染净辨二双融。今初。先两句标。后约佛下。释。谓佛体上之用。即德相故。如有音声词辩之用。即是德者相故。若令众生见于即入无有障碍。故相名用

疏。即用之相下。第二会通染净辩二双融。亦由刊定立二别云。德相纯净。业用通染。即令众生作佛身等。故通染也。今明在佛德相。染净二相皆尽。而现染用。举用同体故。师子座中顿现众生居处屋宅。德相岂不能现染众生耶。相若不现。何有微细门也。微细顿现一切染净。但现而常虚。如镜中像。故云双融耳。又相作相入。彼德相所无。今明法尔常入。常能作故。如十定品山间山上日影喻中。虽能互照或说日影出七山间。或说日影入七山间。如此出入。即湛然不动常入出矣。岂要对机方有入耶。相作即是相即之义。义如前会

疏。故相及用不分两别下。第二结成也。非是德用二义不分。但不别立二种十玄。唯一十玄通德用耳

疏。如大海水举体成波者。心能变境。境须似心。心既无碍。境亦无碍。况真心所现。拣异妄心。真法具德故。能即入重重无碍。言举体者。全真成妄也

疏。法无定性等者。文中有三。初约大小正释。次引证。三例释余法。今初也。疏。有何难哉者。以小尘有大却如太虚。广刹有小。却如小尘。广大之尘含于小刹。故无难也

疏。旧经十住品者。二引证也。所以引旧经者。以文显故。今经云。无量无数轮围山。欲悉令入毛孔中。如其大小皆得知。菩萨以是初发心。若依当经则无定性之理义非显著。岂如晋经欲知至大有小相耶

疏。一非定一下。三例释余法。言中边者。乃有二义。一边方中土。此则事事无碍。如名号品极轮围边。有四天下亦有十方则知边非边矣。递相围绕故。中亦是边。明是事事无碍也。若云中道者。二行不同中边相即。亦是事事无碍。亦通事理无碍耳。延促者。一念为促。长劫为延。即念劫圆融也。静乱者。入定出定二行别故。由无定相亦得相即。亦如东方入正定。西方从定起。尤是事事无碍也

疏。三缘起相由者。疏文有三。初总。次别。后结。今初又三。初总彰多门。谓大缘起者。拣于内外染净一事缘起也。如外水土人工时节为缘。则有芽起。内无明行等为缘。有识等起。今则不然。总收法界为一缘起。故云大也。又即一缘起具多义门。全同法界。即大缘起。不同三乘但明因缘生法无性而已。疏。约就圆宗下。二标举章门。疏。谓缘起法下。三彰十所以

疏。一诸缘各异义下。第二别释也。十门之中。初三是本。后七从生。谓四五六从初门生。七八及九从第二生。其第十门从第三生。第三但合前二门。故唯生一门。就初三门。初一是异体门。二即同体门。三即同异合明。所以有同异体者。以诸缘起门内有二义故。一不相由义。谓自具德故。如因中不待缘是。二相由义。如待缘等是也。初即异体门。后即同体门。若尔何以初异体门中云诸缘各别不相杂乱。第二同体门中。云互相遍应方成缘起。释曰。谓要由各异。方得待缘。要由遍应。方自具德耳。所以前之二门各生三者。有三义故。一互相依持。有力无力故。二互相形夺。有体无体故。三体用双融。无前后故。已知大意。次正释文。第一门即异体门。于中有四。初正释。次若杂乱下。反成。三此则诸缘下。结示。四文云下。引证。即光明觉品。更下半云。如是二俱舍。普入佛功德。上半即相成并立义。下半形夺两亡义。今非下半形夺之义。故不引之。然由相成方各有体

疏。二互遍相资义。即同体门文中亦四。初正释。言则具多个一者。如十钱为缘。一钱当体自是本一。应二之时乃詺初一。以为二一。应三为三一。乃至应十为十一。故有多一

疏。若此一缘不具多一。则资应不遍不成缘起者。第二反成也。若无十一。本一不能应余九故

疏。此则一一各具一切者。第三例余也。一既有十。二三四等亦各有十。故云。一一各具一切。如十钱为喻。其法界差别无尽法中。各各遍应故。随一一各具法界差别法也

疏。文云下。第四引证。即忉利宫中偈赞品。真实慧菩萨偈文下半云。诸法无所依。但从和合起。此证第三门义故。今但引上半

疏。三俱存无碍义等者。双融同异也。文中亦四。一正释。二是故唯一多一自在下。句数料拣。于中有二。先总明。欲多常多。欲一常一。故云自在。二一或举体全住下。别释。初二句可知。三或俱存者。俱存住自及遍应也。亦俱存唯一及多一也。四双泯者。即第四句由俱存。则相即夺故住一。即遍应非住一也。遍应即住一。非遍应也。五或总合者。合前四句为解境故。六或全离者。全离前五成行境故。三文云诸法下。引证。如前已引。意取和合起义。四此上下。总结三门大旨

疏。四异体相入义等者。疏文有五。一总释。二引证。三反成。四结成正义。五别示其相。今初。递相依持者。以是缘起一多等。非定性一多等故

疏。如论云因不生缘生故等者。二引证也。然论有二意。一显无生之义。则上句以缘破自。中论云。如诸法自性。不在于缘中。以若有自性。不合假众缘。既假众缘。则自性应在缘中。缘中求自性。不可得故。无自性生下句。以自破缘。故云缘不生。自因生故。谓若他生则但有缘即应能生。不合假于自因。今假于因。明非他生也。上来显无生之义耳。二者显缘起义。因不生者因全无力。缘生故者缘全有力。下句例知。今正用此意。证成上义

疏。若各唯下三反成上义。亦是解妨。谓有问言。因缘各自不生。和合共力有生。复有何过。斯即立共生义。故先通云。若尔则有多果过。释云。一一各生故。如谷子为因。水土人工时节是缘。应生五果。谓谷芽水芽土芽等。故云多果。次有问言。若尔总皆无力。合而能生。复有何过。此亦立共生义。故复通云。有无果过。谓金石火等于芽无力。不能生芽。水土谷等。于芽无力。安能生芽。故同火等非缘。不能生果。云无果过也

疏。是故缘起下。四结成正义。谓既全有力全无力。缘起不成。要一有力一无力。缘起方成。疏。如阙一缘下。指事别明也。如无一即无二三等。亦如无柱即无梁无椽等。以阙一事。余皆不成舍等缘故。言余亦如是者。若无二亦无一无三等。若无三亦无一二等。乃至若无十亦无一二等。若无梁亦无柱等。随举一法阙缘不成。今法界中随阙一事。一切法界不成缘起也

疏。是故一能持多下。第五别示其相。于中有三。初明以一望多。二例多望一。三结成句数。初中复二。先明一持多依。后例多持一依。今初又二。先正明依持之义。后由一有力必不与多下。释成。亦通妨难。恐有难云。一之与多俱有有力无力二义。云何一能摄多。故此通云。由二有力与二无力。必不俱故。以能为缘边。即是有力。要对所起是无力故思之

疏。如一持多依下。二例多持一依也。多是能起。能为缘故。一是所起。是所成故

疏。如一望多有依有持下。第二例多望一也。于中有二。先结前。即是举于能例。二多望下生后。即是正释。问既前门之中。先明一持多依。后例多持一依。义已圆足。何得更有此多望一耶。答此有深旨。谓前一望多中。一为持。边一能摄多。一为依。边一能入多。虽复多上有持。但取一为能入。是故并属一望于多。所以疏文。欲释后段多望于一。先结前段云。如一望多有依有持等。有依者。即前多持故成一依也。有持者。即前一有力为多依故。言全力者。成上一持。言无力者。成上一依。言常含多在已中者。一有力为持。能摄多故。言潜入已在多中者。一无力为依。便入多故。故此二句皆属一望多也

疏。多望于一当知亦尔者。二生后。正释也。若总释者。但改前一字为多字多字为一字。则义自现。如恐不晓。更为具作应云多能持一。多是有力。能持于一。一依于多。一是无力。潜入多内。由多有力。必不与一有力俱。是故无有多而不摄一也。由一无力。必不与多无力俱。是故无有一而不入多也。如多持一依既尔。一持多依亦然。反上思之。是则能摄亦是多。能入亦是多。虽多摄一即是一入多。然名多持多摄耳。虽多入一即是一摄多。而名多入耳。则前之二门摄入皆属一。后之二门摄入皆属多。则二义天隔。非繁重也

疏。俱存双泯下。三结成句数。谓上一摄多是第一句。多摄一是第二句。俱存即第三句。谓一摄一入时。即多摄多入故。双泯者即第四句。谓一摄一入。即多摄多入故。便一摄一入泯。多摄多入。即一摄一入故。则多摄多入泯。故云双泯。对前别明二句。则有四句亦可成六。五俱照前四。成解境故。六顿绝前五。成行境故

疏。五异体相即义者。此中但即。与前入异。文势大同。五段之文。唯阙引证耳。于中有四。一立理略明。二反显前理。三结成正义。四别示其相。今初。为能起边即是有体。为所起边即是无体。如云从缘生法是法即空。意取所生空也。空即无体义。言形夺者。以能起之缘。形对所起。夺彼所起。令无体也

疏。若阙一缘余不成起。故缘义则坏者。二反显前理。成有体义也。如无一缘。二三四等皆不成故。则知一有体也

疏。得此一缘下。三结成正义。既然一切全由于一。故一有体也

疏。是故一缘是能起下。四别示其相。于中有三。初明一望多。次则多望一。后结成句数。今初亦二。先明一有体。后例多有体。前中文二。先正明可知。后由一有体不得与多有体俱下。释成。亦是解妨。谓有难言。一之与多。俱有有体无体二义。云何独言一有体耶。故今通云。由有无二义不得并故。今一为能起。边多为所起故。若不尔者。能所不成缘起亦坏。言是故无有不多之一者。此一即是多故。无有不一之多者。此多即是一故。问。一不即多有何过耶。答。有二过故。一不成多过。谓一既不成多。余亦不成多。故如一不成十。二三四等亦不成十。故无十过。二多不成一过。谓若一不成十。此十即不成一。由十不成故。一义亦不成。以无于十是谁一故。一不即多成过既尔。多不即一成过亦然。又若不相即。缘起门中空有二义。即不成立。便有自性断灭等过故

疏。一多既尔多一亦然。反上可知者。反上一有体却为一无体。多无体却为多有体。更无别义

疏。如一望多下。第二例多望一也。于中亦二。先结前。即是举于能例。大意全同前相入门也。但即入别耳。言有体无体者。有体即前一。是能起故有体也。无体者。即前举例中多一亦然。明一无体也。故能摄他同己者。成上一有体摄他多也。即前无有不一之多耳。废己同他者。成前一无体也。故废己一同他多也。即前无有不多之一耳。虽有有体无体二义。皆属一望于多。故云摄他同己。废己同他

疏。多望于一下。二生后正例。全同前门但改一为多。改多为一耳。若结应云。摄他一同多己。废多己同一他耳。前一望于多。摄之与废。皆是一也。此中多望于一。摄废皆是多。则二义悬隔矣。余如相入门思之

疏。俱存双泯者。第三结成句数。俱存谓正一摄他同己。废己同他时。即是多摄一同己。废己同一也。双泯者。以一望于多二义。即是多。望于一二义故。则一望于多二义泯矣。多望于一二义。即是一望于多二义故。则多望于一。二义泯也。旨不异前故令思之

疏。六体用双融义等者。文中有三。初立理略释。次是故圆通下。开章别释。成六句故。初一以体就用。二以用就体。三体用双存。四体用双泯。以体用交彻形夺两亡即入同源故。圆融一味。五成解境。六成行境。并显。可知。疏。此上三门等者。后结所属也

疏。七同体相入义等者。释中有三。初别释同体义。二双释即入所以。三正解此门。今初。言谓前一缘者。即指前第二门。以第二是此门本同体门。故如一本自是一则为本一。应二为二一。应三为三一等。只是一个。一对他成多。亦如一人望父名子。望子名父。望兄为弟。望弟为兄等。同一人体。而有多名。今本一如一人。多一如诸名也

疏。又由此一缘下。二双释即入二义所以。谓同体即入由异体成。异体相入故。令同体相入。异体相即故。令同体相即。此有二义。一若直说者。如异体二即是本一。其同体二。岂非即本一耶。异体三即本一。则同体上三亦本一矣。正是今意。二者本一自与多一互为缘起。例同异体相由故耳。次疏具之

疏。先明相入者。三正释此门也。此亦有二。初明一望于多。后余义下。例多望于一。前中亦二。先明一有力多无力。言一能摄多多便入一者。多即余九。一即本一也

疏。一入多摄。反上应知者。二例多一有力本一无力也。以由我多一。方詺本一。为本一故。故多一有力便摄本一。本一入多一也

疏。余义余句下。二例多望于一也。亦全同前异体相入门中。言余义者。谓上明本一望多一。有持有依全力无力故。能常含多一。在己一中。潜入本一。在多一中。无有障碍。今明多一望于本一。亦有全力无力故。能常含本一。在多一中。潜入多一。在本一内。亦无障碍。故云余义也。言余句者。即俱存双泯四句六句。例前异体故不繁说

疏。八同体相即义等者。疏文亦二。先明以一望多。后余义下。例多望一。前中亦二。先明本一有体。后例多一有体。今初又二。先言亦有有体无体之义者。总出所以。亦同异体门。能成有体。所成无体也。后以多一无体下。正释本一有体。在文可思

疏。如一有多空既尔下。二例多一有体也。由有多一方詺本一。为本一故。多一有体。本一无体也。多一有体故。能摄本一。本一无体。潜入多一也

疏。余义下。第二例多一望本一也。谓上本一有有体无体故。能摄多一同己。废本一同他。同时无碍。今多一望本一。亦有有体无体。能摄本一同己。废多一同他。同时无碍。全例前异体中文。故云余义也。余句者。亦即俱存双泯。四句六句耳

疏。九俱融无碍等者。疏文亦二。先正释本门。后此上下。结前三门所出。前中言亦同前者。同前异体门也。即前第六门也。寻前第六于义分明。但有同体与前别耳。恐不晓者。今当具说。谓同体缘起法中。力用交涉。全体融合。方成缘起。是故圆融亦有六句。一以体无不用故。举体全用。则唯有同体相入。无相即义。二以用无不体故。举用全体。则唯同体相即。无相入义。三归体之用不碍用。全用之体不失体。是则无碍双存。亦即亦入。自在俱现。四全用之体体泯。全体之用用亡。非即非入。圆融一味。五合前四句。同一同体。缘起无碍俱存。六泯前五句。绝待离言。冥同性海。故云准前应知

疏。十同异圆满等者。疏文有三。此上一句标名。次谓以前下别释。后此第十下。结属引证。今初。谓前来异体四门。同体四门。及第三同异俱存。并不出同异。今合一处不偏一门。故云圆满。二别释中具足十玄。今初。从以前九至具足也。即同时具足相应门。言多种义门者。有本有末。有同有异。有入有即。四句六句等。合前九门为同时门也。以是总故。随阙一义缘起不成。故下之九门。各先释义。后结属矣

疏。由住一遍应故。有广狭自在门者。即前本门第二门也。住一故狭。遍应故广。言就体就用者。就体故相即。就用故相入。并通同体异体二门

疏。由异体相容者。即别取前第四异体相入门中一半之义。然入通能入所入。多就能说。容亦有能容所容。亦就能说。然所入即是能容。所容即是能入。今微细门。但取容义。不取入义。故云一半。疏。异体相即具隐显门等者。释此隐显。疏有三重。此即初也。若尔相即应同隐显耶。答。上来九门。但有即入同异四义。用斯四义。以成十玄故。一义中容有多义。此中由此即彼故。此隐彼显。由彼即此故。彼隐而此显。由相即故。成隐显义。成门已竟。义则不同。谓相即要此彼合一。隐显则彼此皆存。如东方入定。定身在东。西方定起。起身在西故二不泯。况具下二义。尤异相即也。疏。又就用下。第二番释隐显也。谓正论入门。即义如虚空故。谓若更存即。则入义不成。谓即则泯一。入则存二。义不坏故。正即无入。例上可知

疏。又由异门下。第三番释隐显义。由同异二体义乖。故二门不得并立。事须隐显可知。疏。又由异体相入。带同体相入故具帝网门者。同体相入。一中已含于多。而更入于异体。故有重重之义。同体相入。如一镜已含多影。更入异体。如含影之镜更入余镜。故有重重无尽义也。余门可知

疏。此第十下。三结属引证。先结属。后引证。今初。由第三本门之中融同异故。今则近融前六门。则异体中三门。与同体三门相成。无异体同体不成。无同体异体不成故。六门相成。后之七门。从前三生。前三融故。后七必融。故十门一揆也。例前第三。融通亦有六句。一或举体全异。具入即俱。二或举体全同。亦具入即俱。三或具同异。双现无二体故。四或双非同异。以相夺俱尽故。谓同即异故非同。异即同故非异。五或具四为解境故。六或绝前五。成行境故。故约智显理。诸门不同。废智忘筌。一切叵说。说与不说无碍难思。没同果海。唯言亡遣照。庶几玄趣耳

疏。故下文云下。引证。略引二文。一即十忍品。二又云下。光明觉品。然所引文。乃是总意。由第十门义是总故

疏。上来缘起下。第三总结

大方广佛华严经随疏演义钞卷第十一大方广佛华严经随疏演义钞卷第十二

        唐清凉山大华严寺沙门澄观述

第四法性融通门者。谓真如既具过恒沙德。如所起事亦具德无尽。以真法性融通诸事故无碍也。文中二。先总。后别。总中二。一拣非中。谓理事抗行。不得事事无碍故。是知有言。须弥元不有芥子。旧来空。将空纳不有。何处不相容者。斯言未当耳

疏。今则理事下。第二显正。于中亦二。先标举。后谓不异理之一事下。别示其相。于中四。一顺明。以一切诸法皆依于理。无离理者。今一事全摄于理故。带一切事。入一事中。二若一中。摄理不尽下。反立。谓若摄理不尽。则真理可分。则有一理二理乃至多理之失。今真理湛然。故不可分。一味平等。故无二理。若遮此过。云摄理尽。而其多事不入一事者。则不入之事。在于理外。便令理离于事。而自入一事之中。事离于理。不来一事之内。然离理有事。事成定性。离事有理。理同断灭。过尤深矣。三今既一事之中下。三结成正义。既离可分之过。故全摄理尽。又无事理相离之过故。事随理而顿现一事之中。四华藏下。引证。可知

疏。斯即总意别亦具十玄门者。第二别明也。于中二。先结前生后。后一既真理与一切法下。正显别相。十门之义。皆依真如别德而立下。第八回向。明真如具百门之德。今略举十四种德。成十玄门。一譬如真如与一切法而共相应。不相舍离。德成第一同时具足相应门。二譬如真如性常平等故广。及譬如真如普摄诸法故狭。二德成广狭门。三无所不在。德成相入门。四譬如真如不离诸法。及与一切法同其体性。二德成相即门。五譬如真如无有分限。及恒守本性。二德成隐显门。六譬如真如普摄诸法德。成微细门。七毕竟无尽德成帝网门。八譬如真如与一切法同其体性德成托事门。九遍在昼夜及遍在年劫二德成十世门。十性常随顺及与一切法恒共相应二德成主伴门。疏中密用经意。以经文对疏。一无差失。设有不具经文。意亦有之。文中先别明十门。后一理融通。十门具矣者。结也。文并可知。五如幻梦中二。先幻。后梦。前中先喻。后合。前中先正释。后经云下。引证。此晋经贤首品等取下句云。幻力自在悦世间。今经云。譬如幻师知幻法。能现种种无量事。须臾示作日月岁。城邑丰饶大安乐等。普贤行品云。譬如工幻师示现种种事。其来无所从。去亦无所至。幻性非有量。亦复非无量。于彼大众中。示现量无量等。四十二云。佛子。譬如幻师持咒得成能现种种差别形相。咒与幻别而能作幻。咒唯是声而能幻作眼识所知种种诸色等。十忍品云。譬如幻非象非马。非车非步。非男非女。非童男非童女。乃至云非一非异。非广非狭。非多非少。非量非无量。非粗非细。非是一切种种众物。种种非幻。幻非种种。然由幻故。示现种种差别之事。如是等文其处非一。疏一切诸法业幻所作故。一异无碍者。合也。华藏品云。如幻师咒术。能现种种事。众生业力故。国土不思议。明知业即喻幻师。又如中论偈云。譬如幻化人复作幻化人。如初幻化人。是则名为业。幻化人所作。是名为业果等。又十忍品云。佛子。此菩萨摩诃萨。知一切法皆悉如幻。从因缘起。于一法中解多法。于多法中解一法等。偈中云。众生及国土。种种业所造。入于如幻际。于彼无依着。又偈云。诸业从心生。故说心如幻。若离此分别。普灭诸有趣。斯则显业自如幻矣。又云。度脱诸众生。令知法如幻。众生不异幻。了幻无众生等。其文非一。疏言如梦等者。疏文分二。先喻。后引论证。便当于合初中言。所见广大未离枕上者。六十经。梦游天宫喻云。譬如有人于大会中昏睡安寝。忽然城乃梦。见须弥山顶帝释所住善见大。至云。其人自见着天衣服。普于其处住止周旋。其大会中一切诸人。虽同一处不知不见。何以故。梦中所见。非彼大众所能见故。释曰。天宫广大岂离枕上。余类此知。昔人云。枕上片时春梦中。行尽江南数千里等。亦时非离须臾也。普贤行品云。了达诸世间。假名无有实。众生及世间。如梦如光影。于诸世间法。不生分别见。若离分别者。亦不见分别。无量无数劫。解之即一念。知念亦无念。如是见世间。无量诸国土。一念悉超越。经于无量劫。不离于本处等。如是自在皆由如梦。故十忍品。譬如梦中见种种诸异相。世间亦如是。与梦无差别。又云。譬如梦中见长短等诸色。如是等文。其处非一。皆以如梦长短。即无长短故。不碍长短也

疏。故论云。处梦谓经年。觉乃须臾顷等者。二引证。便当合文。即无性摄论第六所引。但言如有颂云。斯即引经耳。案西域传云。昔有隐士结庐并迹。博习伎术。究极神理。能使瓦砾为宝。人畜易形。但未能御风云陪仙驾。阅图考古更求仙术。闻其方曰。夫神仙者。长生之术也。将欲求学。先定其志。筑建坛场。命一烈士。执长刃立坛隅。屏息绝言。自昏达曙。求者中坛而坐。手按长剑。口诵神咒。收视反听。达明登仙。是人既得仙方。而访烈士。营求旷岁未谐心愿。后得烈士先与人佣力。艰辛五年。一旦违失遂被笞挞。又无所得悲号巡路。隐士既见。命以同游。来至茅庐。以术力故化具肴膳。已而令入池浴服以新衣。又以五百金钱遗之曰。尽当来求幸勿外也。自时厥后数加重赂。潜行阴德感激其心。烈士嘱求效命以报知己。隐士曰。我求烈士弥历岁时幸而会遇。奇貌应图非有他故。愿一夕不声耳。烈士曰。死尚不辞。岂徒屏息。于是设坛场受仙法方行其事。坐待日昏。昏暮之后各司其务。隐士诵神咒。烈士案铦刃。始将晓矣。忽发声大叫。是时空中火下烟焰云蒸。隐士疾行引此人。入池避难已。而问曰。戒子无声。何以惊叫。烈士曰。受命后至夜分惛然若梦。变事更起。见昔事主人躬来慰谢。感荷厚恩忍不报语。彼人震怒遂见杀害。更受中阴身。自顾叹息犹愿历世不言以报厚德。遂见托生南印度大婆罗门家。乃至受胎备经苦厄。荷恩荷德忍而不言。暨乎受业冠婚丧亲生子。每念前恩忍而不语。家中亲戚眷属咸见怪异。年过六十而有一男。妻谓曰。汝可言矣。若不语者。当杀汝子。我时惟念。已隔生世自顾衰老。唯此稚子。因止其妻令无杀害。遂发叫耳。隐士曰。我之过也。此魔娆耳。烈士感叹。悲事不成。愤恚而死。此即未经半宵。已历二生。况年月耶。此类甚多。故知时处等皆如梦自在

疏。亦如影像等者。文亦有二。先正释。后引证。前中然约镜像喻。镜不是像。像不是镜。故无镜之能。此但取像。以况性空虚无之义。今取即入自在。故明一切具于镜像二义。故疏结云。如镜互照。则一一法上有镜有像也。疏下经云下。即十忍品。彼云。然诸众生知于此处有是影现。亦知彼处无如是影。远物近物虽皆影现。影不随物而有远近。菩萨摩诃萨亦复如是。能知自身及以他身。一切皆是智之境界。不作二解。谓自他身别。而于自国土于他国土。各各差别一时普现。释曰。若不如影何得诸处一时顿现。故引远近之言。意取自在。偈中譬如水中影非内亦非外。菩萨求菩提。了世非世间。不于世住出。如影现世间。入此甚深义。离垢者明彻。不舍本誓心。普照智慧灯。世间无边际。智入悉齐等。普化诸群生。令其舍众着。释曰。不了如影。安能普入无边之世。七因无限者。谓因多德远。因果相称故。但修一缘起之因。则果中尚如缘起无碍。况有无限之因无边行海皆备修耶。况一一行自复无尽。如一慈门即有佛刹尘数。况于余门。疏。无性等观者。一近等上四。谓唯心所现观。法性融通观。如幻梦观。如影像观。兼能等缘起无性观。故总收前六。菩萨因中皆为此观。观法唯心。乃至观法如影像。故用此六观该一切法。谓若染若净。若依若正。若因若果。同类异类。是法所摄。皆用六观贯之。故令成果。如于六观自在无碍。二者等余诸因齐佛所知。普贤所行。十方三世无尽。无尽所有因门皆此门摄。故云及余无量殊胜因耳。其大愿回向称法界修。亦该通法界诸因。今如所起果者。如于昔因所得果故。八佛证穷者。文中二。先正释。但得成佛法尔能尔。经云下。引证。无比功德。即佛德也。普贤行品云。世间及如来。种种诸名号。经于无量劫。说之不可尽。何况最胜智三世诸佛法。从于法界生。充满如来地。明佛地德用不可说也。又下偈云。其中人师子。修佛种种行。成于等正觉。示现诸自在。此亦明因圆果满。故有大用耳。前即德相。此即业用。九深定用中。先正释。言海印定等者。如下第六十一经。略说一百门三昧及智论五百三昧等。贤首品下。引证。而云等者。有二义。一只等此偈余文。文云。于一普现难思刹。彼一尘内众多刹。或有有佛或无佛。或有杂染或清净。或有广大或狭小等。即是三昧所现自在也。二等余经。即彼次前偈云。众生形相各不同。行业音声亦无量。如是一切皆能现。海印三昧威神力。如是等文。其处非一。疏由上十因下第三总结所属。正结周遍含容。以是事事无碍故。该取前三。故皆别教一乘分齐。第四教所被机中二。先总后别。前中。初蹑前起后。后若明下。约法拣定

疏。今直彰下。第二别也。于中先标二门。后前中下。别释其相

疏。随声取义有五过失者。即十地论释示说分齐中文。论云。一不正信。随言生解。不称实故。二退勇猛。不能亡相趣实理故。三者诳他。以己谬解为人说故。四者谤佛。指己谬解是佛说故。五者轻法。以浅近解解深旨故。下文具释。疏下经云。设有菩萨等者。即出现品。如前已引。地狱天子即随好品。大海劫火即十地品。故彼偈云。虽住海水劫火中。堪受此法必得闻。是也。疏。约未悟入故名为兼者。通外难也。恐有难云。既有顿超之益。即是当机。何名兼为。通意可知

疏。权教极果无实事故者。如有五教唯圆教中因果俱有实事。前四因中则有。至果皆无。由修权因。若入地后即入实故。犹如百川浩荡千里。亦无究竟归处。究竟归处即是海故

疏。或在法会而聋盲等者。释其示相。略有二类。上即五百在本会中或示在道。下即末会初。六千比丘也

第五远为中。疏文有四。一立理正明。二出现品下。引证。三初三非器下。会释。四又彼品下。明恶是所为。初一可知。二即彼品见闻利益中文。疏云。前三非器者下。三会释也。一不信。二违真。三乖实。然初一正是邪见。二三非是邪见。而皆配入邪见中者。然邪见有二。一轻二重。初一深重邪见。二三即浅近邪见。谓但违真乖实皆邪见故。又以经中但拣二处。欲配前非器令尽。故合入邪见之中。第四非器。即前狭劣二乘。今四及五者。即所为中。四是权为。五即远为。此二即曾无厌舍

疏。又彼品中下。第四明恶是所为。于中二。初正明为恶。后况出圆融。前中亦二。先引二经。明其为恶。后引二经。明等有性。前中初云彼品。即当第十见闻利益中文。经云。佛子。我今告汝。设有众生见闻于佛业障缠覆。不生信乐亦种善根无空过者。乃至究竟入于涅槃。疏。谓谤虽堕恶下。释成上义。谤既有益。应可谤耶。释云。为远益故。非无罪也。故地狱天子。或由谤故。堕于地狱。法华谤常不轻菩萨。千劫于阿鼻地狱受大苦恼。毕是罪已。方受常不轻教化故。愿诸后学勿见谤益便生诽谤。又大般若中。广说谤法之罪。谓此方堕阿鼻地狱。此方劫坏罪犹未毕。移置他方阿鼻地狱中。他方劫坏罪亦未尽。复移他方。如是巡历十方阿鼻。各经劫尽。还生此土阿鼻狱中。千佛出世救之犹难。若欲说其所受之身。闻者当吐血而死。故善现请说所受之身。佛竟不说。是知谤方等大经。非可轻也。又入大乘论第一偈云。诽谤大乘法。决定趣恶道。此人受业报。实智之所说。生堕地狱中。大火炽然身。焚烧甚苦痛。业报罪令尔。炽然大铁犁。具满五百数。而耕其舌上。遍碎身苦恼。故疏云。谤虽堕恶道。疏由闻历耳者。谓恶道罪毕。由昔谤时经目历耳。熏成其种故得益耳。言终自醒悟者。即五十八经云。但以曾发菩提心故。终自醒悟。疏。又云。如日亦与等者。出现身业中长行文广。今当引偈。偈云。譬如生盲不见日。日光亦为作饶益。令知时节受饮食。永离众患身安隐。无信众生不见佛。而佛亦为兴义利。闻名及以触光明。因此乃至证菩提是也

疏。又如大海水潜流下。引二经明性等有。初明具有。后明皆见。二经皆是出现意业之中。前亦已引

疏。此皆明有自性住性等者。二正立理显被。圆融相。举况以释。然有二意。一举前况后。明其普度。谓但依生等有佛性。尚皆普为。况事事无碍。何有非所被耶。二者举后况前。谓约圆融一即一切。则无情之境亦是所被。况前等有佛性。而拣之耶。言被非情者。以所被情即非情故。一即一切无情。岂非情耶。况色性智性本无二体。无有情外之非情故思之

第五教体浅深中。疏文分三。初总。次别。后结。总中亦三。初摽举。言浅深者。十体之中前前浅。后后深。故下释云。从浅至深。虽有浅深。融通并为无尽教体。二一音声下。列名。至文自显

疏。十中前五下。三料拣。总有四重。一体性料拣。相举于外。性主于内。体者性相之通称故。若言体者通其事理。若云性者唯约于理。由后五中摄境唯心。若约真心即通性故。七所入实体即是性故。八中理是性故。九中必有理融事故。十中无不具故。是则约性。亦体亦性。约事但可称体。二又前四下。大小乘料拣可知。三前七下。三乘一乘料拣。以会缘入实归一实理。即一乘故。下三皆是一乘。于义可知。四前八约同教下同教别教。相对料拣。谓七八虽是一乘。第七多明顿教中义。第八乃是终教中义。故属同教。前八皆同于义可知。同教皆有故。事事无碍。海印炳现。若非别教一乘无此义也。于后三重料拣。则前前无后后。后后兼前前可知

疏。就前三中下。第二别释。于中二。先合释前三。后别释后七。今初。以大小共同故合释之。于中三。初双摽。次双释。后双会

疏。小乘三者下。第二双释。先释小乘中二。先总征。疏一云下。后别释三释。即为三别。今初。语业为体。是标语即声也。谓佛语言下。别显其相。谓唱号言词评量论说言语音者。谓如宫商角徵羽等。亦如西方十四音。即阿上声也。阿去声等也。言语路者。言所行处。瑜伽九十三云。有情增语。即是语路。然瑜伽释增语。有二义。一云增语是名。名能诠表。增胜于语。二云有说。意识名为增语。今小乘不取于名。正用意识。是语行处。亦是唇舌等。言语业者。即有业用。如恶言既为恶业用。佛之善言即善业用。故梵行品云。若语是梵行者。梵行则是音声风息。唇舌喉吻吐纳。抑纵高低清浊。此即语音语路。又云。若语业是梵行者。当知梵行。则是起居问讯。略说广说。喻说直说。赞说毁说。随俗说。安立说。显了说。斯即语业。言语表者。表亦是业。然业有表无表别。故今但云表者。婆沙一百二十六。亦云。但言语表而非无表者。令他生正解故。耳识所取故。又二识所取。无表唯一故。又三无数劫求此表故。疏。是谓佛教者。结也。正出其意。今知教体而云佛教者。一依根本故。二依相似故。三依随顺故。佛依如是名句文身四法而说。今亦随之故

疏。其名句下。拣法。亦通妨难。故彼论中自有难云。若尔如次所说。当云何通。谓如说佛教名为何法。谓名句文身次第行列。次第安布。次第连合等。为答此难故。论有此通。此难但牒后段之文。故疏略耳

疏。二名等为体等者。此句摽。谓名身下。列名。次第下。释相。次第释上三名。谓行列于名。安布成句。文为二所依故云连合。名等别相次下当释

疏。声但下。拣法。亦通妨难。谓论有问言。若尔此文所说当云何通。如说佛教云何答。谓佛语。言唱词评论。语音语路。语业语表。是谓佛教。为答此难故。论有此通。尔亦以此难但牒前文故

疏。略耳声但依于展转因故下。论有喻云。如世子孙展转生法。意云。从父生子。言是某父之子。虽语父名意在子体。又子生孙。孙是某孙。虽举其翁。意在孙子。孙如于义。子如于名。父如于声。则有三重。中是教体故。下合云谓语起名。名能诠义。是即名为展转因也

疏。评家意取语业为体者。评论家释云。如是说者。语业为体。佛音所说。他所闻故。言评家者。婆沙。是诸罗汉同集。而有四大罗汉为评家正义。一世友。二妙音。三法救。四觉天

疏。杂心论同俱舍者。以彼论第一有此偈。而文小异耳。论偈云。广说诸法蕴。其数有八万。戒等及余蕴。悉是五蕴摄。长行释云。八万法阴。皆色阴摄。以佛语是语业性故。有说。名性者行阴摄故。又戒阴色阴摄。定慧等行阴摄。故与俱舍同也。疏。俱舍论云下。引俱舍文。何以当于名等教中而引此证。以其俱舍情无去取。二义随用故。于此处引双证前二。既许俱通故。下第三取为四法之体。在文易了

疏。正理论中意符名等者。正成第二义也。故彼论第三。释前颂竟者。以正理论总释俱舍六百行颂文。但义顺婆沙正理故。立顺正理名。然正释上颂无异俱舍。俱舍则情无去取。正理则断属于名。此中疏略。彼有问曰。语教异名。教容是语。名教别体。教何是名。注中释问意云。教是言教。语为教体。则异汝名别有其体。若以名为体。名是不相应行。非言教体。何得以名等为教体耶。论自答云。彼作是释。要由于名。乃说为教。是故佛教体即是名。所以者何。诠义如实。故名佛教。下与疏全同。此答意云。虽名声教。若无名等诠其自性差别。独用于声。岂成于教。故定用名等。疏家存略。但申正意。足显论旨

疏。故正理十四破彼师云。汝不应立。名句文身即声为体者。引此为成上来经部立声为体。论文繁广。今当略引令知其源。论云。此中经主作如是言。岂不此三语为性。故用声为体。色自性摄。如何乃说。为心不相应行。此责非理。所以者何。由教及理知别有故。教谓经言语身文身。若文即语。别说何为。又说应持正法文句。又言依义不依于文。释曰下。广引教证。大意则同。故论结云。由此等教证知别有能诠诸义名句文身。犹如语声实而非假。理为现见有时得声而不得字。有时得字而不得声。故知体别。有时得声不得字者。谓虽闻声而不了义。现见有人粗闻他语。而复审问汝何所言。此闻语声不了义者。都由未达所发文故。如何乃执文不异声。有时得字不得声者。谓不闻声而得了义。现见有人不闻他语。睹唇等动知其所说。此不闻声得了义者。都由已达所发文故。由斯理证文必异声(下文广说大意同也)论下又云。随思发语。因语发字。字复发名。名方显义。由依如是展转理门。说语发名名能显义。如斯安立。其理必然。又次下云。或如树等大造合成。非不缘斯别生于影。影由假发。而体非假。如是诸文。亦应总集别生名句。而彼名句。虽由假发。而体非假。此为善说。理极成故。又下结云。故知离声别有名等。又下云。故不应立名句文身。即声为体。是故于我所说离声有名等三。能显义理。今疏但引后结文。已显正义耳

疏。大乘有三下。疏文分三。初标。次释。后以余下。料拣。疏一云摄假从实以声为体下。第二释也。大乘通意以声为实。名句文但声上假立。经部师义。参预大乘故。亦谓名等依声假立。疏。一契经等者。此引稍略。具引应云。佛告曼殊室利菩萨曰。善男子。如来言音略有三种。一者契经。二者调伏。三者本母。下广释其相。今疏所引。但意在言音两字耳。疏。杂集论云。成所引声谓诸圣所说者。亦证唯声为教体也。既言圣说是声。明非名等为教体也。即彼论第一释外六界声尘界云。声者四大种所造。耳根所取义。若可意。若不可意。若俱相违。若因执受大种。若因不执受大种。若因俱大种。若世所共成。若成所引。若遍计所执。若圣言所摄。若非圣言所摄。如是十一种声。由五种因之所建立。谓相故。损益故。因差别故。说差别故。言差别故。相者。谓耳根所取义。说差别者。谓世所共成等三。余如其所应。因执受大种者。谓语等声。因不执受大种者。谓树等声。因俱者。谓手鼓等余声。世所共成者。谓世俗语。所摄成所引者。谓诸圣所说。遍计所执者。谓外道所说。圣言非圣言所摄者。谓依见等八种言说。今疏。但引成所引声。以证声为教体。然上五因摄十一者。初一是总。余四是别。损益摄初三。可意是益。不可意是损。俱相违通二。因差别摄次三。说差别摄次三。言差别摄后二。思之可知。言八种言说者。即八种圣语。一见言见。二不见言不见。三闻言闻。四不闻言不闻。五觉言觉。六不觉言不觉。七知言知。八不知言不知。斯即为圣言所摄。若见言不见等。则非圣言。疏二云。以体从用名等为体者。义引论文。然唯识第二。破于小乘名等实有。故彼论云。复如何知异色心等。有实诠表名句文身(论主问也)契经说故。如契经说佛得希有名句文身(外人答也)此经不说异色心等有实名等。为证不成(论主总非)下广破竟。便结云。语不异能诠。人天共了。执能诠异语天受非余。下申正义云。然依语声分位差别。而假建立名句文身。名诠自性。句诠差别。文即是字。为二所依。此三离声虽无别体。而假实异。亦不即声。由此法词二无碍解。境有差别。声与名等。蕴界处摄。亦各有异。上即论文。准彼论疏。萨婆多虽有名由声显生二义。论主取生破显。正理师救云。声上屈曲。是名句文。体异于声。而定实有故。上论文广破异声实有名等。故彼疏破竟。结云。故知但由无始惯习。前前诸声分位力故。后生解时。谓闻名等其实。耳等但能取得声之自性刹那便谢。意识于中诠解。究竟名为名等。非别实有。是故汝等。宁知异语别有能诠。次假外问云。既声体即是能诠。何有名等三种差别。故论下申正义云。然依语声分位差别等。于中有四。一从初至假建立名句文身。显假差别。此论主解。依声建立名句文身。如梵音斫刍。此翻为眼。若但言斫。或唯言刍。未有所目。说为字分位。若二连合能诠法体。诠于眼体。说为名分位。然未有句位。更添言阿萨刹缚。名为眼有漏。说为句分位。故依分位。以立名等。依一切位。非自在故。外人难言。分位差别何者是也。论从名诠自性至为二所依。述曰。二显二用殊。名诠诸法自性。句诠诸法差别。文即是字。为名句之所依。不能诠自性及差别故。文者彰义。与二为依。彰表二故。又名为显。与二为依。能显义故。而体非显。字者。无改转义。是其字体。文是功能。功能即体。故言文即是字等。或字为初首。即多刹那声。集成一字。集多字为所依。次能成名诠诸法体。多名已后方成句身。诠法差别。即杂集。云自性差别。及此二言。如是三法总摄一切。此二言者。即是字也。字即语故。说之为言。名句二种。所依止之言也。瑜伽论云。名于自性施设。句于差别施设。名句所依止性。说之为字。又显扬言。句必有名。名不必有句。名必有字。字不必有名。如枢要说。此下广论自共相义。略不录之。疏无性论下。可知

疏。成唯识下至法词无碍境应无别者。述曰外人问言。若名等即声。法词二无碍解。境有何别。答曰。即缘此故。二境有异。法无碍解。缘假名等。词无碍解。缘实声等。故说境差别非二俱。缘实虽二自性互不相离。法对所诠。故但取名。词多对机。故但说声。耳闻声已。意了义故。以所对不同。说二有异。非体有异也。又此二境及名等三。与声别者。蕴处界摄亦有异故。色蕴行蕴。声处法处。声界法界。如其次第。摄声名句。问曰。声上屈曲假即言不相应。色上屈曲假应非色处摄。答声上为有教名等不相应。色上为无教。故是色处摄。问曰。声上有屈曲。即得以为教。色上有屈曲。即亦应得为教。故论复云。且依此土说名句文依声假立。非谓一切。诸余佛土。亦依光明妙香味等假立三故。述曰。四会相违释义可知。所引即净名经。而言等者。等取触思数等。皆得假立名等三种。亦是不相应。摄此三法故。以众生机欲对待故假。又梵云便善那。此有四义。一者扇。二相好。三根形。四味。此即是盐。能显诸物中味故。味即是文。如言文义巧妙等。目之为便善那。此中四义总是一显义故。古德说名为味。对法云。此文名显。能显彼义。故为名句所依。能显义故。恶刹那是字。无改转义。如对法说。钵陀是迹。如寻象迹以觅象等。此名为句。理应名迹。义之迹故。寻此知义也。顺古所翻。称之为句。今疏总略。以疏对论。于义分明。疏唯识论云。此三离声至亦不即声。述曰。三明不即声不离声。论主答难谓。先有问言。上来虽言名等即声。若名等是不相应行者。色上屈曲。非不相应。声何故尔耶。故此答曰。此三离声虽无别体。名等是假。声是实有。假实异故。故名等三非即是声。非声所摄。但是差别之声。义说名等。以诠义故。是不相应无别种子生。故言不即声。疏深密第四至而能说故者。彼无故字。其说字下云。是故我依般若波罗蜜多。能取诸法无自性性。意云。由文字般若。能显实相般若。既双牒言说文字。明知通用四法。下引净名。亦是第三香积品文。十地论中音声即声。音字即名句文。故下引风画二喻。风喻音声。画喻名句文。义如下释。疏以余之意下。第三料拣双会。于中二。先双会大小四法。后会大小不同。今初分二。初直出正意。意在双取。二若就下。会通前二。于中五。一正明去取。二良以下。出所以。三书虽是色下遮妨难。恐有难云。疏不善相书之竹帛。非名句文。名句文身。是不相应。翰墨简牍。但是色法。何得为体。故此救云。色与名等亦为所依。何异声为名等所依。声是色蕴所摄。书字之色。岂非色摄耶。故前唯识之中例于余方。亦依色等有名句文。亦同诸法显义之体。显无方理故。不取常规。四前净名下。会通前文。但言所用者。用此四法。何必要四。问曰。若四中随取但取名等。岂不违于唯识之文离声别有非正义耶。答。彼不离声假实合说。今不离色假实亦存。未爽通理。疏仁王云下。五引证成立。既然但言名句味。不云音声。明唯取名等。此即仁王观空品。而文少略。具云大王。是经名句味。百佛千佛百千万佛。说名句味。于恒河沙三千大千国中。盛无量七宝。施三千大千国土中众生。皆得涅槃四果。不如于此经起一念净信。何况解一句者。句非句非非句故。今但意在有名句味。无声之言。故不全引

疏。然大小诸宗下。第二会通四法。大小不同。或四皆非实者。即初教义名等假有。声是心变故。或四法皆如空者。然有二意。一空为初门。即属初教。二顿寂诸相。即属顿教。今正当顿。而引三经。皆成顿义。初引净名。即弟子品须菩提章。以其被呵便置钵欲出其舍。维摩诘言。唯须菩提。取钵勿惧。于意云何。如来所作化人。若以是事诘。宁有惧不。我言不也。维摩诘言。一切诸法如幻化相。汝今不应有所惧也。所以者何。一切言说不离是相。至于智者不著文字。故。无所惧。何以故。文字性离。无有文字。是则解脱。解脱相者。即诸法也。此明即言亡言。通圆顿意。二引十地经论。以风画合空皆不可取。以此言教皆与证智而相应故。不同风在树叶画存于壁。但就教道则可见闻。三引佛藏经。亦证顿义。即彼经第一念佛品中。取意引耳。经云。舍利弗。诸法若有决定体性。如析毛发。百分中一分者。是则诸佛不出于世。亦终不说诸法性空。舍利弗。诸法实空。无性一相。所谓无相。如来悉知见。如来以是说有念处。舍利弗。念处名为无处非处。无念无念业。无想无分别。无意无意业。无思无思业。无法无法相。皆无合散。是故贤圣名无分别者。是名念处。上显无念承便故来。下又云诸法毕竟空等者。亦是取意。引彼经云。何以名为诸法实相。所谓诸法毕竟空无所有。以是毕竟空无所有法念佛。复次如是法中。乃至少念。尚不可得。是名念佛。即其义也。疏有说。四皆事理无碍。即终教意。下即圆教意。第四通摄所诠体

疏。依于六文以显十义者。瑜伽云。六文者。谓一名二句三字四语五行相六机请。十义者。一地义二相三作意四依处五过患六胜劣七所对八能治九略十广可知。上证辩通所诠。疏此门下。出通所诠所以。疏又瑜伽下。后又通收能所。则有三重能所。一以佛为能说人。则声等皆所说。二唯语为能说。则名等为所说。以依语显屈曲故。三四法皆能诠。则前义为所诠。故皆通取。下对前拣别。此中有二义。第一通所诠则向下取。第二通说者则向上取。故说皆通不同前义。克取名等。故云所说。疏第五诸法显义体中三。初标。二引证。三结释。今初。摽举略释。声名能显义。声名皆为教体。六尘能显义。六尘皆教体

疏。净名第三下。二引证。略引二经。净名即第三卷菩萨行品。因阿难闻香。自昔未有。便问世尊。世尊为说。是净名取于香积佛饭。因问久如当销。佛为广说。乃至灭除一切诸烦恼毒。然后乃销。因即致问。阿难白佛言。未曾有也。世尊。如此香饭。能作佛事。佛言。如是如是。阿难。或有佛土。以佛光明而作佛事。有以诸菩萨而作佛事。有以佛所化人而作佛事。有以菩提树而作佛事。有以佛衣服卧具而作佛事。有以饮食而作佛事。有以园林台观而作佛事。有以三十二相。八十随形好。而作佛事。有以佛身而作佛事。有以虚空而作佛事。众生应以此缘得入律行。有以梦幻影响。镜中像。水中月。热时炎。如是等喻。而作佛事。有以音声语言文字而作佛事。或有清净佛土寂寞无言无说。无示无识。无作无为。而作佛事。如是阿难。诸佛威仪进止诸所施为。无非佛事。阿难。有此四魔八万四千诸烦恼门。而诸众生为之疲劳。诸佛即以此法而作佛事。是名入一切诸佛法门。菩萨入此门者。若见一切净好佛土。不以为喜。不贪不高。若见一切不净佛土。不以为忧。不碍不没。今疏。但撮略引耳。然生公云。若投药失所。则药反为毒矣。苟得其会毒为药也。是以大圣为心病之医王。触事皆是法之良药也。苟达其会。众事皆毕矣。菩萨既入此门。便知佛土本是就应之义。好恶在彼。于我岂有异哉。所贵唯应但欲应生之寄耳

疏。又十卷楞伽者。文言稍博。大意无殊四卷中义。若四卷经。当其第二大慧白佛言。世尊。非言说有性。有一切法耶。世尊。若无性者。言说不生。世尊。是故言说。有性有一切法。佛告大慧。无性而作言说。谓兔角龟毛等。世间现言说。又云大慧。非一切刹土有言说。言说者。是化故耳。或有佛刹瞻视听法。或有作相。或有扬眉。或有动睛或嘘或吹。或謦咳。或念刹土。或动摇。大慧。如瞻视及香积世界。普贤如来国土。但以瞻视。令诸菩萨得无生法忍及诸胜三昧。是故非言说有性有一切法。大慧。见此世界故蚊蚋虫蚁。是等众生无有言说。而各办自事。释曰。以上所引证知皆教。然楞伽意。兼又遣言及遣诸法。思之可知。十卷经中大同于此。疏又香积下。第三结释大意。于中有三。初引例总收。次结成说听。后况出此经。今初。含有内外典据。香积世界餐香饭。而三昧显者。亦是净名经意。而是香积品中。又与前文影略。前说色触等。今辩香之与味欲。令六尘皆作佛事。故经云。尔时维摩诘问香积菩萨。彼土如来以何说法。彼菩萨曰。我土如来无文字说。但以众香。令诸天人得入律行。菩萨各各坐香树下。闻斯妙香。即获一切德藏三昧。得三昧者。菩萨所有功德皆悉具足。释曰。此即以香显三昧也。又前文云。与诸菩萨方共坐食。有诸天子皆号香严。悉发阿耨多罗三藐三菩提心。即食味之益也。又下菩萨品中。明饭久如当消云。未入正位食此饭者。得入正位然后乃消。又云。已发大乘意食此饭者。得无生忍然后乃消。释曰。此即味为佛事故。疏统收经意。含于二处经文也。疏。极乐国土听风柯而正念成者。即弥陀经云。舍利弗极乐国土。微风吹动诸宝行树。及宝罗网出微妙音。譬如百千种乐同时俱作。闻是音者。自然皆生念佛念法念僧之心。舍利弗。极乐国土成就如是功德庄严。以经对疏。文义可知。疏。丝竹可以传心者。即史记中事。含其多事。谓漏月传意于秦主。果脱荆轲之手。相如寄声于卓氏。终获文君之随。帝释有法乐之臣。马鸣有和罗之伎。皆丝竹传心也。疏。目击以之存道者。即庄子中事。夫子欲见温伯雪子。久而不见。及见寂无一言。及出子路怪而问曰。夫子欲见温伯雪子久矣。何以相见。寂无一言。夫子曰。若斯人者。目击而道存。亦不可以容声者矣

疏。既语默下。第二结成说听。语默视瞬皆说。结前文也。见闻觉知尽听。显后义也。觉收鼻舌身之三根。上既六尘皆说。今则六根皆听。疏苟能下。释其听义。上则但能显法为说。此则但能得法为听也

疏。况华严下。第三况出一乘。上通三乘内外二教。皆有此理。况复华严一乘圆宗。何法非教。于中四节。一明事物说法。云台宝网者。即十地经。尔时世尊从眉间出清净光明。乃至云。又亦照此娑婆世界佛。及大众并金刚藏菩萨身师子座已。于上虚空中成大光明云网台。时光明台中以诸佛威神力故。而说颂言。佛无等等如虚空。十力无量胜功德。人间最胜世中上。释师子法加于彼等。即其文也。又宝网者。即第一经云。其师子座。摩尼为台。莲华为网。下云。复以诸佛威力所持。演说如来广大境界。亦其文也。又言云者。第六经。初于一切供养具云中。自然出声说法等

疏。毛孔光明皆能说法者。即上十地经亦光明说。又第九地云。或时心欲放大光明演说法门。或时心欲于其身上一一毛孔皆演法音。又现相品云。尔时诸菩萨光明中。同时发声说此颂言。诸光明中出妙音。普遍十方一切国。演说佛子诸功德。能入菩提之妙道等。又法界品初。诸来菩萨下方菩萨。名破一切障勇猛智幢王。与世界海微尘数菩萨俱来诣佛所。于一切毛孔中。出说一切众生语言海音声云。出说一切三世菩萨修行方便海音声云等。其文非一

疏。华香云树即法界之法门者。第二明即事是法更何论说。以有托事显法生解门故

疏。刹土众生本十身之正体者。第三明即事是能说人何但显法。刹土即国土身。众生即众生身。十身略举其二。以二是劣尚即十身。况余胜者。于何非教者。正结成也。尚即能说。况非教体

大方广佛华严经随疏演义钞卷第十二大方广佛华严经随疏演义钞卷第十三

        唐清凉山大华严寺沙门澄观述

疏下云第四引证。初引普贤行品。如前教缘中辩

疏。第六摄境唯心体等者。疏文分二。先总明。后然有下。开章别释。前中亦二。先正明。后引证。今初。前之五体皆心所变。心外无法如声是色。即心所现影。况依声上假立名等。其教所诠。及诸法显义。并离心无体

疏。唯识等云下。第二引证。此引三文含于四教。初引唯识。即是初教。故彼论云唯遮外境。识表内心。离识之外更无别法。彼引多教。成立唯识。亦引华严。广如彼论。而言等者。等有二意。一等余论。二等余经。今初。谓瑜伽杂集摄大乘等。故无性摄论第四论曰。其中有未得真智觉者。于唯识中云何比知。由教及理应可比知。此中教者。如十地经。薄伽梵说。如是言三界皆唯有心。又薄伽梵解深密经。亦如是说。释论中云。十地经者。于彼经中宣说菩萨十种地义。此即安立十地行相名句文身。识所变现。聚集为体。谓彼圣者。金刚藏主。净识之上所变影像。为增上缘。闻者。识上现影似彼法门。如是展转传来于今。说名为教。故诸论中皆引华严。成立唯识。所引之经。即是第六地中一心所摄门。经云。佛子。三界所有唯是一心。如来于此分别演说十二有支。皆依一心如是而立。今由诸论皆已引之。故下疏但引梵行。二又此等者。取楞伽等经顿教中义。八识虽空而说唯识。疏。起信亦云下。即终教中证。此即彼论解释分中。显示正义之文。然其立义分中云。摩诃衍者。总说有二种。云何为二。一者法。二者义。所言法者。谓众生心是。心即摄一切世间出世间法。依于此心显示摩诃衍义。此即已明唯心义讫。今取解释分中。显心性相真妄交彻。知是终教。案彼论贤首疏云。一心者。即如来藏心。含于二义。一约体绝诸相即真如门。二随缘起灭即生灭门。此义至问明品。当广分别。今但略证教体是唯心耳

疏。梵行品下。即引当经。以证圆教唯心之义。知一切法即心自性。非但相宗心变而已

疏。然有下。开章别释中。先开章。后别释。释中先释本影。中四句为四。第二句中分二。先正明俱有。后说聚集显现。前中亦二。先引佛地论。各别成立。后引二十唯识。双证前义。前中初即如来实有说法。故名本质。文通六文。义通十义。皆是已下显文义本。因位说听由于意识故。果位中亦唯意识。故云妙观察智相应净识。以果位中智强识劣故。说此识与智相应。此智能于大集会中雨大法雨。故能说法。智所依王即是第六。故云净识之所显现。而言净者。纯无漏故。唯识疏云。既无漏心现。即真无漏文义为体。是故世尊实有说法。言不说者。是密意说。疏佛地论第一云。有义下。引证可知

疏。若闻者识上下。明影像教托佛本质。自心变故。有漏心变。则名等有漏。佛地论下。引证有影。亦是前卷以佛为缘。自心影像文义为果。疏。此文义相下。解释。亦通妨难。恐有难云。若尔是自心变。何名佛说。故牒释云。自善为因。佛力为缘。影像为果。今从于缘名佛说耳

疏。故二十唯识下。第二引论双证前二。则本质影像。二教齐有。谓若闻者。为增上缘。则佛心上文义相生。若佛为增上缘。则闻者心上文义相生。故云展转增上力。如来之识及闻者识。名为二识。决定成立本影之教。疏。护法论师等者。唯识诸师。皆同此立故。大乘法师疏云。然此论主无不说法。故取此解

疏。然云文义相生复说五心集现等者。第二明聚集显现。于中二。先总明聚集之相后然西方下。别释五心多少。言然西方多释者。相传略有四解。今疏。即是第一。唯识疏中。亦唯此解。斯乃总意。故疏存之。疏。余如别章下。有三师释。一云初说诸字时。率尔耳识。同时意识。但缘其声。是现量故。寻求心中唯寻耳识所缘境故。亦但缘声不缘字名。此之三心所变。声上虽有字名。如生等相而不缘之。至决定心缘声字名。有三相现。二说行字时。率尔耳识。同时意识。及寻求心。亦但缘声。至决定心缘声字名。有六相现。为前之二字。各有声字名故。三说无字时。率尔耳识。同时意识。及寻求心。亦但缘声。至决定心缘声字名。有九相现。为前之三字。各有声字名故。四说常字时。率尔耳识。同时意识。及寻求心。亦但缘声。至决定心缘声字名。经十二心有十四相。谓四声四字四名并句及义。名为聚集。若不散乱。则起染净等心及等流心。若散乱时生心不定。一云率尔耳识。同时意识。但缘于声是现量故。寻求心中缘声字名。非现量故。由此极少经十二心。有三六九十四相现。名为聚集。若不散乱。决定心生。若散乱时。生心不定。一云率尔耳识。但缘于声。同时意识缘声字名。若不尔者。寻求意识寻何等名。此中曲有二解。一云四率尔耳识但缘其声。四同时意识缘声字名。是其现量。以缘常声时。不缘诸等声及字名故。五识同时意识随声等。皆现量故。下四寻求心方得圆满。经十二心有三六九十四相现。名为聚集。一云同时意识容非现量。得缘过去缘于八心。谓四率尔耳识。四同时意识。有三六九十四相现。名为聚集。问同时意识既是现量。何得缘字名耶。答。现量亦缘名等自相。如理门论说。不缘者。不缘名义相系属故。上约诸行无常四说之。以辩五心名字多少。疏文是其总义。于相可知。但云由前字力。展转熏习连后字生者。然呼诸字时。行等三字皆在未来。呼行字时。无常二字亦在未来。其诸一字虽谢过去现无本质。由熏习力唯识变力。仍于此念说行字时。心上显现。下言连带。准此可知。然此聚集。依法苑中约诸恶者莫作五字。一句则有一百五相。谓唱诸字时。有其二相。谓一字一名。次唱恶字时。有其七相。谓二字二名。并一个一字身为五。取上二相故有七相。次言者字时。有十六相。三字三名。并两个一字身。一个二字身。此有九相。并取上七故有十六。次唱莫字时。有三十相。谓四字四名。有三个一字身。两个二字身。一个三字身。有十四相。并上十六故有三十。后唱作字时。有五十相。谓五字五名。四个一字身。三个二字身。两个三字身。一个四字身。总此二十相。并上三十故有五十相。五位总数。有一百五相。此上一百五相。但约字名二事。上言十四相者。兼声句义。又但当字故。言四字四名。今约连带成一百五相。若约四字但有五十五相。然十二心不约连带。然此五心初后通六识。中三唯意识。又前三是无记。后二通善恶。又率尔五识。后必有寻求心。后或散或不散。散即复起率尔耳识。不散即起第三决定。乃至等流。又意识率尔。自有二种。一五识同时率尔意识。缘现在境。二独头率尔意识。唯缘过去。此中且说同时。余义广如别章。然此皆约未自在位。以显五心聚集显现。若自在位。于一念中具足显现。如理思之

疏。三唯影无本者。唯识论疏。指无性论。作如是说。不取为正

疏。龙树等宗多立此义者。等取顿教般若。言多立者。不必全尔。有三观故。此但明空之一义故

疏。此前四说下。融为一味方顺圆宗。若约摄生则浅深有异

疏。第二说听全收等者。文中有三。初标。次释。后结融通。今初标中所以成二四句者。以真心融二。则似事理无碍。故复分之。初同教中初二句。但以生佛同一真心故互相收。三即互不相碍故得双存。四乃互相即故。所以相泯。并易可知

疏。二约别教等者。别教四句。则唯约事事无碍。由生佛两相宛然互相在故亦可。前是相即门。后是相入门。以相即门中含于理事无碍故。且名同教耳。疏一众生全在佛中等者。第一句有二。先正立。后引证。今初。此以佛果称性故。摄法无遗。无有一法出法性故。全性为佛故无法不摄

疏。故出现下。后引证也。初引当经。如前已解。至下本文重明。后又佛性下。引论证成。然此品中说如来藏。乃有三义。今是其一。言三义者。论云。复次如来藏义有三种应知。何者为三。一所摄藏。二隐覆藏。三能摄藏。此中疏引。即第一所摄藏也。以为如来之所摄故。名如来藏。故彼论云。一所摄名藏者。佛说约住自性如如。一切众生是如来藏。言如如者。有二义。一如如智。二如如境。并不倒故。名曰如如。言来者。约从自性来至得果。是名如来性。虽是一因名应得果名至得。其体不二。但由清浊有异。在因位时违二空理故。起无明而为烦恼。所杂乱。故名为染浊。虽未即显必当可现故名应得。若至果时与二空合。无复惑累。烦恼不染。说名为清。果已显现故名至得。譬如水性体非清浊。但由秽不秽故有清浊名。应得至得二义亦尔。云云所言藏者。一切众生等。与疏全同。次下论即云。复次藏有三种。一显正境无比。离如如境。无别一境出此境故。二显正行无比。离此智外。无别胜智过此智故。三为现正果无比。无别一果过此果故。故曰无比。由此果能摄藏一切众生故。说众生为如来藏。今疏中所引。但取佛含众生之义故。略引其初后耳。下更略引次之二藏。二隐覆为藏者。道前犹为烦恼所覆众生不见故。三能摄为藏。果地之中一切功德应得。性时摄之已尽。故今取果摄。故亦不引后之二藏。疏。又下出现下。三又引当经况出摄听。诸法皆摄。何独听法众生。于中又二重举况。一明一身顿摄众生。二明智广同空。一切情器本居智内。何由用摄耶。然第一文。即出现偈云。如三世劫刹众生。所有心念及根欲。如是等身皆现显。是故正觉名无量。今疏上二句。但略如及二字耳。言尚皆一身顿现者。即长行中意。经云。如来成正觉时。以一方便入善觉智三昧。入三昧已。于一成正觉广大身。现一切众生数等身住。其身中。如一成正觉身。一切成正觉广大身。悉亦如是。然彼经长行。以身摄身。偈颂之中明其总摄。今但取长行之一身。对偈中之广摄。以显难思耳。故言尚皆一身顿现者。此一尚字。即是举况。一听法人下况佛智。更彰广大。即第八十经普贤。普贤赞佛偈初。经云。佛智广大同虚空。普遍一切众生心。悉了世间诸妄想。不起种种异分别。今疏引者。意通前半。正取大智以况一身。故但引初一句而已

疏。二佛在众生等者。众生即因。因称法界。法界摄法无遗。故众生亦摄无遗矣。次故出现下。引证。后此明佛证下。解释。谓如来何以不离生心。释云。众生心中真如。是佛所证故。若尔但是平等之理。何足为玄。故复次云。本觉无异故。谓佛本觉与众生本觉无有二体。同一觉故。本觉即法身故。法身同故。以始下。若尔法身体同众生未证。佛证法身复何相预。故次云。以始同本。总在众生心中。谓起信既言始觉同本觉。无复始本之异。生佛本觉既同。今佛始觉同本时。全同众生本觉。是故全在众生心中矣。复有问云。约体虽同相用自别。岂得全同。故次云。从体起用。用不异体。体既众生之体。用岂离于众生。故依体起用。即是众生心中真如用大。更无别佛。若尔起信论中已有此义。何以独名华严为别教耶。故次释云。起信虽明始本不二。三大攸同。而是自心各各修证。不言生佛二互全收。是则用起信之文。成华严之义妙之至也。疏文可思

疏。三由前生佛互相在下。但合前二并实非虚。成此句耳。谓初佛摄生时即全摄。无前无后故实非虚。生摄非虚。教在生心。佛摄非虚。教在佛心耳

疏。故众生心中佛下。显双存相。谓虽互相摄。不妨说听宛然。在文似隐。义极分明。请以喻况。略举二喻一者如一明镜。师弟同对说听。以师取之。即是师镜。弟子取之。是弟子镜。镜喻一心。师弟喻于生佛。是谓弟子镜中和尚。为和尚镜中弟子。说法和尚镜中弟子听弟子镜中和尚说法。诸有智者。请详斯喻。虽设此喻。犹恐未晓。又如水乳和同一处。而互为能和。所和且顺说听。以能和为说。所和为听。且将水喻于佛。乳喻众生。应言乳中之水。和水中之乳。乳之与水虽同一味。能所宛然。虽能所宛然。而互相在。相遍相摄。思以准之。更消疏文。众生心中佛者。此明众生称性普周。而佛不坏相。在众生心内。言为佛心中众生说法者。此明佛心称性普周。而众生不坏相在佛心内也。但明能说之佛。即是众生心中佛。但语听法众生。即是佛心中众生。下对反上。更无别理。但说听之异耳

疏。四由生全在等者。此句双泯。义更易了。于中先正明。是以贤首下。引证。即第十五经。但证第四双非之义。因缘所生无有生。生泯也。诸佛法身非是身。佛泯也。下半云。法性常住如虚空。以说其义光如是。正要前二句。故不引此耳。又偈赞品亦证双非。大般若文。前已释章

疏。是故此四下。总结融通。随举一句。即须具四。故随一文一句。若大若小必具此四。摄理周圆

疏。第七会缘入实体等者。疏文分二。初总明。后亦有下。开释

疏。摄论中名为真如所流十二分教下。引证。此引无性摄论第七。梁摄论第十。次引唯识第十。彼论释十真如中第三地。如彼疏释云。由此地中得于三慧。照大乘法观此法教根本真如。名胜流真如。或证此如说法胜故

疏。彼宗虽不立下。释妨。谓有问言。彼宗真如凝然。何有流义。故疏通云。而说佛证体等。此中逆顺总有四法。展转相依。若逆推者。此之教法从何而立。答。从佛后得智立。此后得智。复依何生。由根本智。故论云。了俗由证真故。说为后得。此根本智。从何而立。由冥真如故名真如。最为根本。若顺说者。梁论第十释云。真如于一切法中最胜。由缘真如起无分别智。无分别智。是真如所流。此智于诸智中最胜。由此智流出后得智。后得智所生大悲。此大悲于一切定中最胜。因此大悲如来欲安立正法救济众生。说大乘十二部经。此法是大悲所流。此法于一切法中最胜。菩萨为得此法。一切难行能行。难忍能忍。由观此法得入三地。在文可知

疏。二会相显性者。上说如为教本。而教非即如。今说教即是如。则摄十二分教之相。即如之性也

疏。如来言说下。重释教即如义。上明教从缘生无有自性。故教即如。今明说主称如是故言教皆如。金刚三昧。证成此义。言义语者。皆契如故。下引仁王证成前义。言乃至者。文中略故。若具经云。波斯匿王白佛言。云何十方诸如来一切菩萨。不离文字而行诸法相。大王。法轮者。法本如。重颂如。授记如。不诵偈如。无问而自说如。戒经如。譬喻如。法界如。本事如。方广如。未曾有如。论义如。是名味句音声果。文字记句一切皆如。若取文字者。不行空也。大王。如如文字。修诸佛智母。上即经文。其中云。戒经者。即因缘经。因事制戒。故乃因缘经中一义。又言法界如者。即本生经。界即因义。故余可知。十二分名义。十藏品说

疏。此经明教即是如下。复辨通局。谓但言十二分教即如。此如局在十二分中。若云如即佛教。则一切法皆如也。则一切皆佛教。斯义则通。故次疏云。若取诸法显义体。即明一切皆教。既一切皆如。如皆佛教也

疏。第八理事无碍体等者。在文可见

疏。第九事事无碍下。疏文分三。初双标。次正显文。后例释义。今初双标文义。拣义取文耳。次文即下。正显文圆。文即名句文。而言圆音者。有二义故。一例上名等离声无体。今圆音体文亦依之。二者既言圆音。则文句皆足方称圆耳。若一直声。昔义非正下。引诸经成斯教体具十玄门。疏。佛以一妙音等者。经文略有三节。初则一音周闻。但彰其遍。次言众音悉具。则即前一音顿具多音。谓万类殊音。如善口天女。三法雨皆遍者。则随一一音。具说一切大小权实无尽法门。又一一法皆充法界。三节以含四义。三则展一普遍。二则一收一切。展卷无碍。皆悉同时。何音何法而不具足。彼经次下云。一切言辞海。一切随类音。一切国土中。恒转无上轮等。则重数更多。今但引其一偈。足显同时具足。疏。譬如书字等者。即如来转法轮中取意。略引故有等言。若具引者。经云。佛子。如来法轮悉入一切语言文字。而无所住。譬如书字。普入一切事一切语一切算数。一切世间出世间处。而无所住。如来音声亦复如是。普入一切处一切众生一切法一切业一切报中。而无所住。一切众生种种语言。皆悉不离如来法轮。何以故。言音实相。即法论故。佛子。菩萨摩诃萨应如是知。如来转法轮。即此经文法喻之中。亦自影略故。疏取意略引耳。疏。此亦相入即相容也者。据所引文即相入义。即此相入。是一多相容不同门。能入名入。所入名容。能容即所入。所容即能入。随义名异。容入一义耳。疏。道场皆闻不出众外者。即出现音声中。梵王及众喻。若具引者。经云。复次佛子。譬如大梵天王住于梵宫出梵音声。一切梵众靡不皆闻。而彼音声不出众外。诸梵天众咸生是念。大梵天王独与我语。如来妙音亦复如是。道场众会靡不皆闻。而其音声不出众外。何以故。根未熟者不应闻故。其闻音者。皆作是念。如来世尊独与我语。佛子。如来音声无出无住。而能成就一切事业。是为如来音声第五相。释曰。众会闻者。即以根熟为众内。未熟为众外耳。余并可知。应闻者得闻。此即显也。不应闻不闻。斯即隐也。疏。各各随解者。闻中复有差别。若闻大乘。大乘则显。不闻二乘。二乘即隐。若闻小乘。大隐小显等。可知。疏。又云如来言音等。即彼次下。第六相也。经云。佛子。譬如众水皆同一味。随器异故。水有差别。水无念虑亦无分别。如来言音亦复如是。唯是一味谓解脱味。随诸众生心器异故无量差别。而无念虑亦无分别。然此一文证其两义。若取诸器各受互不相知。即是隐显。若取一味随器即是纯杂。善口天女亦即彼品。经云。复次佛子。譬如自在天王有天采女。名曰善口。于其口中出一音声。其声则与百千种乐而共相应。一一乐中复有百千差别音声。佛子。彼善口女从口一声。出于如是无量音声。当知如来亦复如是。于一音中出无量声。随诸众生心乐差别。皆悉遍至悉令得解。即第四相一中顿具。即微细也。疏。阿僧祇品至不可说等者。等余经文。经云。一一佛法不可说。种种清净不可说。出妙音声不可说。转正法轮不可说。于彼一一法轮中。演修多罗不可说。于彼一一修多罗。分别法门不可说。于彼一一法门中。又说诸法不可说。于彼一一诸法中。调伏众生不可说。此上经文已有数重。而但说一法。法法皆尔。互入重重故成无尽。又彼中云。清净实相不可说。说修多罗不可说。于彼一一修多罗。演说法门不可说。于彼一一法门中。又说诸法不可说。于彼一一诸法中。所有决定不可说。于彼一一决定中。调伏众生不可说。不可言说同类法。不可言说同类心。不可言说异类法。不可言说异类心。不可言说异类根。不可言说异类语。念念于诸所行处。调伏众生不可说等。亦是其类也。疏。一念顿演者。一念顿演无量劫法。何有十世不互相融。第五经云。树下诸神尘刹数。悉共依于此道场。各各如来道树前。念念宣扬解脱门等

疏。此且约下。例文释义。初句结前。余皆释后

疏。以上十门下。第三总结。可知教体竟

第六宗趣通别中。疏文分二。先释名标章。后前中下。依章别释。前中宗者。崇也。故云所尚。亦云尊也主也多也

疏。前中通论下。第二依章别释。于中二。先释通宗。后释别宗。前中三。初总标大意。二叙昔辩违。三申今正解。今初。言诸部异计。即二十部。言十八本二者。十八部名。次下当列。本二者。即上座部及大众部。故文殊问经云。十八及本二。皆从大乘出。无是亦无非。我说未来起。以义相从者。合二十部兼诸大乘为十宗故

疏。然隋朝下。第二叙昔辨违。于中二。先叙昔。后辨顺违。前中又二。先正立。后异名。前中各从所立得名。四中各有二句。上句立义。下句指教。疏。又此四宗下辨异名。不出性相而前三从所破。后一就所显疏。初二小乘下。辨顺违。于中文二。先顺释明顺理。后约局明违文。今初。言各初浅后深者。以初显正因缘。立有因果之性。故为浅也。二破于定性但从缘有。故为深也。万法从缘故无定实。如铁之坚。遇火则镕。如水之湿。遇寒则坚。明知从缘则无定性。假名而已。故为小乘深。早已参涉大乘。故云经部三是大乘之浅。望其第二亦是次深。以二但破性而有其相。如会指成拳。虽无定性非无拳相。今复破之。明性相俱空为法空矣。而言浅者。但除妄计以显空义。未彰妙有不空真性。故名为浅。第四方显妙有真性。故四为深。言此亦有理者。自浅之深。先小后大。一代佛教大意尔故。又第一宗。是因缘所生法。第二宗。我说即是空。第三宗。亦为是假名。第四宗。亦是中道义。故无大违。疏。但收义不尽下。第二约局明违。言但判二者。唯明有部及经部。故除本二部。故云十八部中

疏。今总收一代时教。以为十宗者。第三申今正解。于中三。初总摽。二别释。三料拣。疏。第一我法俱有宗等者。第二别释也。释第一宗中。先立理。后谓犊子部等者。等取余四部。谓此计中总有五全或一少分。言五部全者。一犊子部。二法上。三贤胄。四正量。五密林山。故总为五部同计。泰法师云。更等取经部中根本经部。不等末经部。以本经部亦执有胜义。我非即非离即。计菩提出离生死。故名胜义

疏。二法有我无等者。疏文有二。先正立。后显功能。今初。言等者。等取余二部半。谓此计都有三全。一少分。谓一一切有部。二雪山部。此即上座部。宗轮论云多同说一切有故。亦等取也。三多闻部。宗轮叙多闻部云。余义多同一切有部。并不立我计法有实故。言一少分者。化地部末计彼云。过去未来并皆实有。亦于中有一切法所知所识故。名法有我无

疏。又于有为下。第二辨教功能。于中有五。一总显功能。二广显所破。三举正折邪。四指广从略。五结功超胜。今初因缘能破无因。正因以破邪因

疏。然西域邪见下。二广显所破。于中三。初叙西域。二叙此方。三双就结过。初中亦三。初束九十五种为十一宗。二束十一以成四计。三结诸计以归二因。今初。九十五种。如第六回向引。然至妙虚通目之曰道。心游道外即称外道。故唯佛正道余悉名外。故此总非。所以成十一者。以约现有教文传习西域故。疏。或计二十五谛从冥性生等者。即十一中之一计也。此即数论师计。案金七十论中。谓有外道名劫毗罗。此云黄赤色。髭发面色并黄赤。故时世号为黄赤色仙人。其人计从冥而生自然四德。一法二智三离欲四自在。得此智已依大悲说。先为阿修和仙人说。次阿修和传般尸诃。般尸诃传与褐伽。褐伽传与优楼佉。优楼佉传与跋婆和。跋婆和传与自在黑。般尸诃广说此智。有六十千偈。其自在黑姓拘式。见大论难受。略抄七十偈。此婆罗门初入金耳国。以铁鐷鐷腹。头戴火盆。声王论鼓。求僧论义。因诤世界初有后无。谤僧不如。遂后造此七十论。申数论宗。王意朋彼。以金七十斤赐之。外道欲彰己令誉。遂以金七十摽名。唯识疏云。其后弟子之中上首。如十八部中之部主名伐理沙。此翻为雨。雨时生故。即以为名。徒党名雨众者。即义当自在黑所受跋婆和。梵音不同耳。梵云僧佉。此翻为数。数即慧。数数度诸法根本立名。从数起论名为数论。论能生数。亦名数论。其造数论。及学数论者皆名数论师。本源即是迦毗罗造。金七十论。即自在黑造偈。长行即天亲菩萨解释。言二十五谛者。准百论云。从冥生觉。从觉生我心。从我心生五微尘。从五微尘生五大。从五大生十一根。神我为主。常觉相处中。不坏不散摄受诸根。斯则五大亦为能生。今依金七十论释之。二十五谛总略为三。处中为四。广为二十五。言略为三者。谓一自性。二我知。三变异自性。是第一谛古称冥性。亦名胜性。未生大等。但住自分名为自性。若生大等便名胜性。用增胜故。智论云。谓外道通力观至八万劫。八万劫外冥然不知。谓为冥谛。从此觉知初立故名冥谛。二言我知者。即第二十五谛。即神我也。三变异者。中间二十三谛自性所作。名为变异。故有三位。言处中为四者。彼论云。外问曰。云何分别本性变异及知者。答曰。性本无变异。大等亦本变十六。但变异知者非本变。谓本性能生大等故名为本。不从他生故非变异。二大我慢五尘。此七亦本亦变异。大从本性生。是故变异。能生我慢故得为本。慢生五唯。五唯生五大及五知根。故皆亦变亦本。三五大五知五作业及心平等根。但从他生故唯变异。不能生他故不名本。四知者。即我知为体故。不从他生。亦不生他故。非本非变异。若准百论五大生十一根。则五大亦本亦变异。唯变异中则唯十一根变。言广有二十五者。如上引百论。然都有九位。就其中二十三谛。自有七位。一大。二我心。三五唯量。四五大。五五知根。六五作业根。七心平等根。兼其初后故二十五。问曰。自性不可见云何知有。答。有法体故。有微细相故不可见。如热气散空。岂得言无。若不见云何知有。答。因大等事。从自性生有三德故。问自性云何能与诸法为生因。答。三德合故。其三德在冥性中眠伏不起。若在大等二十三位。便有觉悟故。二十三一一皆以三德合成。言三德者。梵云萨埵剌闇答摩。萨埵此云有情。亦云勇猛。今取勇义。剌闇此云微。牛毛尘等皆名剌闇。亦名尘坌。今取尘义。答摩此云闇。即闇钝之闇。三德应名勇尘闇。若傍义翻。旧云染粗黑。新云黄赤黑。旧名喜忧闇。新云贪嗔痴。旧名苦乐痴。新云苦乐舍。敌体而言。即是三毒能生三受名苦乐舍。黄赤黑者。是其色德。贪多轻光故色黄。嗔多动躁故色赤。痴则重覆故其色黑。由此自性合三德故。能生诸法故。自性是作者。我非作者。若非作者何用我为。答为证义故。义之言境。证于境故。谓二十四谛。是我所知故。我是见者而非作者。余不能知。问自性是作。我非作者。何用和合。偈答云。我求见三德。自性为独存。如跛盲人合。由义生世间。谓我有如此意。我合当见三德自性故。或与自性合。自性为独存者我是困苦人。唯有能见知。今当为彼令得独存。以是义故。自性与我合。如人与王合。亦如盲为跛合。则以我为跛。不能作故。自性为盲。不能见故。此二合故。能生世间与我受用。盲跛达其所在。各得分位。我见自性时。即得解脱令我独存。问曰。已说和合能生。是生次第云何。答曰。自性次第生大我慢十六。十六内有五。从此生五大。谓自性先生大。大者增长之义。自性相增故。或名觉。或名想。或名遍满。或名智。或名慧。大即是智故。大得智名。大次生我执。我执者。自性起用观察于我知。我须境故亦名我慢。亦名五大初。或名转异。或名炎炽。次慢生十六者。即五唯量。五知根。五作业根。及心平等根。此十六内意总明皆从慢生。就十六中应先生五唯。五唯生十六故。云十六内有五。从此生五大。即百论中从我心生五微尘。从五微尘生五大。从五大生十一根。初生五唯量者。一声二触三色四味五香。五各有体。有能缘量故。唯亦定义。唯定用此成五大故。五唯无差别。以微细寂静故。从此生五大。大尘有差别。五唯无差别。即是大尘。大无忧痴。唯以喜乐故。五大具三毒故差别。从声唯生空大。慈恩疏云。别有一物名之为空。非空无为。触唯生风大。色唯生火大。味唯生水大。香唯生地大。金七十论但各一生。有说。藉尘有多少。从声一尘成空大。声触二尘生风大。色声触三生火大。色声触味生水大。总用五尘生地大。藉尘多者力弱。藉尘少者力强。故四轮成世间。空轮最居下。次五大生十一根者。先生五知根。次生五作业根。后生心平等根。云何五大生五知根。谓声唯生空大。空大成耳根。是故耳根还闻于声。触唯生风大。风大成身根。是故身根还受于触。色唯生火大。火大成眼根。是故眼根还见于色。味唯生水大。水大成舌根。是故舌根还知于味。香唯生地大。地大成鼻根。是故鼻根还嗅于香。而金七十论。但云耳根唯从声生。唯与空大同类。是故能取声。若优楼迦仙人。则计遍造义。谓五大造眼根。而火大偏多。色是火家求那故。眼根唯能见色。余四例知。皆用五大成。各一偏多耳。次生五作业根者。金七十论即总用五大成。谓一语具二手三足四小便处五大便处。此中语具。谓口舌等。手足即分皮根少分。彼谓身根为皮根。又男女大小遗等。各有用故。故偈云。唯见色等尘。是五知根事。言执步戏除。是五业根事。言心平等根者。金七十论分别为体。故论云。分别为心相。即心事亦具五唯成。通缘诸境故。又论云。大我慢心事。三自相为事。心能遍取差别境故。有说。以肉团心为体。二十五我知者。以思为体。唯识因明。皆云数论。执思为我。若金七十云。云何知有我。颂曰。聚集为他故。异三德依故。食者独离故。五因立有我。一如人聚床席等。必为于人。如是大等聚集。即知有我。二异三德者。前二十四皆有三德故。三依故者。如人依身。身则有用故。四食者。如人见味。知有别味。人见大等所知。必知有能知。五独离故者。离身有我。若唯有身。圣人所说解脱则无有用。故知有我。我有何相。然金七十论。将自性望变异。有九不似。有六相似。我翻似不似。言九不似者。一无因。二常。三多人共一。四遍一切。五无事。六不没。七无分。八不依他。九不属他。自性有此九德不似变异。变异则有因等。我有八义。同于自性不似变异。但多人共一。义不同自性。谓人人各有我故。自性有六义。似变异者。谓一同有三德。二不相离。谓三德不可分。三皆为我所受用之尘。四平等俱。为一切我受用。如一婢多主使。五无知者。本末同无知。唯我知故。六能生。自性能生。大等亦能生故。而我知亦无此六相似故。总云我翻似不似。谓亦无三德。不能生等故。我有八不似变异乃成八德。无六似于变异。但成二德。谓一无三德。二是我知者。余之四似是自性变异之德。非我之德。余义可知。有云。由三德是生死因。由所转变扰乱我故。不得解脱。若能去。彼二十三谛转变无常。生厌修道。自性隐迹不生诸谛。我便解脱。金七十云。人无缚无脱。无轮转生死。以无三德故。无变异故。无作者故。若尔谁得解脱。答。轮转及系缚。解脱唯自性。由自性变异故缚。若得正遍知即得解脱。意明知二十五谛为正遍知。明缚与脱不由于我。言我解脱者。约自然脱耳。论总结云。此秘密智。应施设五德婆罗门。一生好地。二好族姓。三净行。四有能。五离欲。上依金七十论。略叙其计。其间不同。兼智论意并已具释。若广破者。如唯识中百等论下。疏略总破耳。疏或计六句者。即卫世师计。新云吠世史迦萨多罗。此云胜论。吠世亦云鞞世。吠世为正。立六句义最为胜故。或是胜人所造论故。其能造人即成劫之未。人寿无量。外道出世名嗢露迦。此云鸺鹠。昼避声色匿迹山薮。夜绝视听方行乞食。时人以为似鸺鹠鸟。故名鸺鹠仙人。即百论中优楼佉也。或名羯拏仆。羯拏此云米脐。仆翻为食。先为夜游。惊他稚妇。乃不夜乞。遂收碾场糠秕之中米脐而食。故时号为食米脐仙人。多年修道遂获五通。谓证菩提。便欣入灭。但嗟所悟未有传人。愍世有情痴无慧目。乃观七德授法令传。一生中国。二父母俱是婆罗门性。三有般涅槃性。四身相具足。五聪明辩捷。六性行柔和。七有大悲心。经无量时无具七德。后经多劫。波罗痆斯国有婆罗门。名摩纳嚩迦。此云儒童。其儒童有子名般遮尸弃。此云五顶。顶发五旋。头有五角。其人七德虽具。根熟稍迟。既染妻奴卒难化道。经无量岁伺其根熟。后经三千岁因入园游。与其妻室竞华相忿。鸺鹠因此乘通化之。五顶不从仙人具返。又三千岁化之不得。更三千年两竞尤甚。相厌既切。仰念空仙。仙人应时神力化引腾空。迎往所住山中。与说所悟六句义法。一实二德三业四大有五同异六和合。实者。诸法体。实德业所依。名之为实。德业。不依有性等故。德者道德。业者作用。动作义也。一实有九种。一地二水三火四风五空六时七方八我九意。二德有二十四。一色二香三味四触五数六量七别性八合九。离十彼性十一此性十二觉十三乐十四苦十五欲十六嗔十七勤勇十八重性十九液性二十润二十一行二十二法二十三非法二十四声。三业有五种。一取二舍三屈四申五行。四大有唯一。实德业三同一有故。离实德业外。别有一法为体。由此大有有实等故。五同异亦一。如地望地有其同义。望于水等即有异义。地之同异是地非水。水等亦然。亦离实等有别体实。六和合句者。谓法和合聚。由和合句。如鸟飞空忽至树枝住而不去。由和合句故令有住等。上已略叙。广出体相。及广破斥并如唯识及疏。并百论等疏。或谓自在梵天等生者。此有三计。一即涂灰外道。并诸婆罗门。共计自在天是万物之因故。唯识第一云。有执有一大自在天。体实遍常能生诸法。谓彼计此天有其四德。一体实二遍三常。四能生诸法。又计有三身。一者法身。体常周遍。量同虚空。能生万物。二受用身。在色天之上。三变化身。随形六道教化众生。复计彼天有二住处。一在雪山。二在南海末剌耶山。昔摩竭国有兄弟二人事自在天。同往雪山求见彼天。至山忽见一婆罗门云。大自在天。是汝国释迦牟尼佛。何不礼事。兄弟报云。我先承习但事天神。时婆罗门变为天形。面上三目。复现四臂或现八臂。告兄弟曰。汝可还国。菩提树东造释迦降魔之像。菩提树后可穿一池济渴乏者。彼宗因此计二住处。以为不谬。瑜伽第七云。彼作是思。世间诸物。必应别有作者生者及变化者。为彼物父谓自在天。或复其余如论广破。显扬第十亦同此说。十二门论亦广破之。二。言梵天等生者。即第四围陀论师计。及第五安荼论师。围陀明。此师计那罗延天能生四姓。此计梵天能生万物。提婆菩萨破外道小乘涅槃论云。从那罗延天脐中生大莲华。莲华之上有梵天祖公谓梵天为万物之祖。彼梵天作一切命无命物。从梵天口生婆罗门。两臂生刹帝利。两髀生毗舍。两脚生首陀。故瑜伽第七云。婆罗门是最胜种类。刹帝利等是下种类。婆罗门是白净色类。余种是黑色类。婆罗门种独得清净。非余种类。婆罗门是梵王之子。从大梵腹口所生。梵所变化梵王体胤。广破如彼。显扬亦同。故上等言等取那罗延天。以那罗生梵。梵为物祖故。正云梵王生。等取那罗延。又等梵王。是第五计安茶论师计本际也。言本际者。即过去之初首谓计世间最初。唯有大水。时有大安茶出生。形如鸡卵。颜如金色。后为两段。上则为天。下则为地。中生一梵天。能作一切有命无命物。是故梵天是万物因。以四五两计。一计那罗延为始。一计安茶为始。并次生梵王。梵王生万物。故疏云。梵天等生。则等取安茶及罗那也。其安茶计。亦似此方有计天地之初。形如鸡子混沌未分。即从此生天地万物。疏或谓时方微尘虚空宿作等。而为世间及涅槃本者。此有六计。一时者。即时散外道。执一切物皆从时生。是故时是常。是一。是万物因。是涅槃因。广百论云。复次或有执时是真实常。以见种植等众缘和合。有时生果。有时不生。时有作用或舒或卷。令彼条等随其荣悴。此所说因。其有离合。由是决定知实有时。广破如彼。百论亦云。如是时虽微细不可见。以节气华实等故知有时。此则明其见果知因。次言方者。即第七方论师。计从方生人。人生天地。灭后还入于方。故方是常。是一。是万物因。是涅槃因。故百论云。外曰。实有方常相有。故曰合处是方相等。言微尘者。即第八路迦耶论师。计色心等法皆极微所作。路迦耶此云顺世外道。计一切色心等法。皆用四大极微为因。然四大中最精灵者。能有缘虑即为心法。如色虽皆是大。而灯发光。余则不尔。故四大中有能缘虑。其必无夫。故唯识云。有外道。执地水火风。极微实常。能生粗色。不越因量。虽是无常而体实有。释曰。谓从四大生。后还归四大。言粗色者即是子微。不越因量者。因者父母。微最初极微名为父母。聚生诸色故。所生者名曰子微。子微虽是无常。不越父母故是实有。亦广如彼破。但是随情虚妄计度。显扬第九云。又计极微是常住者。以依世间静虑起如是见。由不实知缘起法故计有为先有果集起。离散为先。有果坏灭。由此因缘。彼谓从众微性粗物果生。渐析粗物乃至极微。是故粗物无常。极微常住。瑜伽同此。言虚空者。即第九因力论师。谓彼虚空为万物因。别有一法是实是常。是一。是一切万物因。从空生风。从风生火。火生暖。暖生水。水生冻。冻坚作地。地生五谷。五谷生命。命殁还归空。是故虚空能为一切万物因是涅槃因。百论亦云。外曰。定有虚空。法亦常亦遍亦无分。一切处一切时信有故等。广如彼破。言宿作者。即第十宿作论师。计一切众生受苦乐报。皆随往日本业因缘。是故若有持戒精进。受身心苦能坏本业。本业既尽。众苦亦灭。众苦尽灭。即得涅槃果。是故宿作为一切因。瑜伽论云。何因缘故。彼之外道作如是见。立如是论。答彼见世间虽具正方便而招于苦。虽具邪方便而招于乐。彼如是思。若由现法士夫作用。为彼因者彼应颠倒。由彼所见非颠倒故。是彼诸法皆以宿作为因。由此理故。起如是见。立如是论。涅槃三十五。广破此见。而疏云。等者。等取第十一无因论师。计一切万物无因无缘。自然而生自然而灭。故此自然是常。是万物因。是涅槃因。此计一切无染净因。如棘刺自纤。乌色非染。鹤色自白。大乘法师云。别有一法是实是常。号曰自然能生万物。与下此方计有同义。瑜伽第七云。何因缘故。彼诸外道。起如是见立如是法。答谓见世间无有因缘。或时欻尔大风卒起。或时一日寂然止息。或时忽尔暴沙弥漫于一时间。顿即空竭。或时郁尔果木敷荣或一时间。飒然衰悴。由如是故。起无因见立无因论。显扬亦同此。则无因为自然。非别有物。若广分别上诸异计。如瑜伽六七。显扬九十。婆沙十一二。及金七十。广百论等

大方广佛华严经随疏演义钞卷第十三大方广佛华严经随疏演义钞卷第十四

        唐清凉山大华严寺沙门澄观述

疏。统收所计不出四见下。第二统收十一为四计。即百论意。于中二。先正明计。后若计一下。对因果明。皆广如百论

疏。虽多不同下。第三结归二因。即收上十一宗计。乃至九十五种。皆不出二因。无而忽有。是曰无因。所计处谬。是曰邪因。如乳生酪。乳曰正因。令乳生席。即曰邪因。从无明行而生此身。是曰正因。从冥性等生。皆曰邪因。一切诸法缘会而生。缘离则灭。未有一法不从因生。情非情境并从因生。而言无因。乃成大过。谓不应生物则合常生。石女则应生儿。龟毛亦应生物。不修万行应得涅槃。则世出世法。一时俱坏。故无因过。过莫大焉。配属可见。离佛法外。非唯九十五种。设千般异说。皆不出于邪因无因故。说一正因缘。无计不破

疏。此方儒道下。第二叙此方。疏文分二。初指同二因。后如庄老下。略出诸计。然此方儒道玄妙不越三玄。周易为真玄。老子为虚玄。庄子为谈玄。今疏有二。先合引庄老。后别引周易。前中亦二。先引文。后断义。今初。正引老子。及引庄子。故云皆计自然。此句标也。故庄子云。不知所以然而然故曰自然。谓人法地下。即老子道经。有物混成章。此先有言云。有物混成先天地生。寂兮寥兮。独立而不改。周行而不殆。可以为天地母。吾不知其名。字之曰道。强为之名曰大。大曰逝。逝曰远。远曰返。故道大天大地大王亦大。注云。因所大而明之。得一者天地王也。天大能覆。地大能载。王大能法地则天行道。故云亦大。又云。域中有四大。王居其一焉。注云。正者人灵之主。万物系其兴亡。将欲申其鉴戒。故云而王居一。欲警王令有所法也。次文云。人法地。地法天。天法道。道法自然。注云。人谓王也。为王者。先当法地安静。既尔又当法天运用生成。既生成已。又当法道清净。无为令物自化。人君能尔者。即合道法自然之性也。又上释道大云。以通生表其德字之曰道。以包含目其体。强名曰大。此文相蹑故委引之意在道法自然耳。德经又云。道生一。一生二。二生三。三生万物。前则逆推。此则顺辩。注云。一者冲气也。言道动出冲和妙气。于生物之理未足又生阳气。阳气不能独生。又生阴气。积冲气之一。故云一生二积阳气之二。故云二生三。阴阳合孕。冲气调和。然后万物阜成。故云三生万物。次下又云。万物负阴而抱阳。冲气以为和。上来皆明万物自然生也。即老子言。若引庄子者。庄子太宗师篇云。夫道有情有信。无为无形。注云。有无情之情。故无为也。有常无之信。故无形也。又云。可传而不可受。注云。古今传而宅之。莫能受而有之也。又云。可得而不可见。注云。咸得自容。而莫见其状也。又云。自本自根。未有天地自古以固存。注云。明无不待有而无也。又云。神鬼神帝。生天生地。注云。夫无也岂能生神哉。不神鬼帝而鬼帝自神。斯乃不神之神也。不生天地。而天地自生。斯乃不生之生也。故夫神之果不足以神。而不神则神矣。功何足有。事何足恃哉。又云。在太极之先。而不为高。在六合之下而不为深。先天地生而不为久。长于上古而不为老。注云。言道之无所不在也。故在高为无高。在深为无深。在久为无久。在老为无老。无所不在。而所在皆无也。又云。狶韦氏得之。以挈天地。伏羲得之。以袭气母。维斗得之。终古不忒。日月得之。终古不息。堪坏得之。以袭昆仑。冯夷得之。以游大川。肩吾得之。以处大山。黄帝得之。以登云天等。注云。道无能也。此言得之于道。乃所以明其自得耳。又云。知天之所为。知人之所为者至矣。注云。知天人之所为者。皆自然也。则内放其身。而外冥于物。与众玄同任之。而无不至也。意云。但有知有为。皆不为而为。故自然也。疏若以自然为因等者。断义也。通其两势。初即老子意。由道生一。道是自然。故以道为其因。是邪因也。疏。若谓万物自然而生下。出庄子意。则万物自然无使之然。故云自然。即无因也。疏。如乌之黑等者。即庄子文亦涅槃经意

疏。周易云下二引周易等者。文中亦二。先引文。后断义。今初。即系辞也。系者系属也。亦纲系也。此上应加是故二字。注云。夫有必始于无。故太极生两仪也。太极者无称之称。不可得而名。取其有之所极。况之太极者也。孔云。太极天地未分之前混而为一。即是太初太一也。老子云。道生一。即此太极之谓。混元既分。即有天地。故云太极生两仪。即老子一生二也。不言天地者。指其物体。下与四象相对。故云两仪。谓两体容仪也。释曰。若准列子。有太易太初太始太素。太易者。未见气也。太初者。气之始也。太始者。形之始也。太素者。质之始也。彼注云。质性也。又释太易指周易太极。此则太初非太易便成。太极在初。若准易钩命诀说有五运。前四同列子。第五名太极。则太极非初。释与列子大同。运则运数。易谓改易。元气始散。谓之太初。气形之端。谓之太始。形变有质。谓之太素。质形已具。谓之太极。虽小异同。皆是元气生天地耳。疏。两仪生四象等者。孔云。谓木金水火禀天地而有。故云两仪生四象。土则分王四时。又地之别故唯四象。四象生八卦者。谓震木离火兑金坎水。各主一时。又巽同震木。干同兑金。加之以坤艮之土为八卦也。八卦定吉凶者。八卦既立。爻象而相推。有吉凶故吉凶生。大业者。万事各有吉凶广大悉备故。能生天下大事业也

疏。太极为因等者。二断义也。谓若用太极为因。故是计无为有。亦是邪因。疏。若谓一阴下。通显邪因无因。易云。一阴一阳之谓道。阴阳不测之谓神。一阴一阳谓之道者。注云。道者何无之称也。无不通无不由也。况之曰道。寂然无体不可为象。必有之用极而无之功显。故至乎神无方而易。无体而道可见矣。故穷变以尽神。因神以明道。阴阳虽殊无一以待之。在阴为无阴。阴以之生。在阳为无阳。阳以之成。故曰一阴一阳之谓道。孔疏云。孔疏非孔子。乃孔颖达也。一谓无也。无阴无阳乃谓之道。一得为无者。无是虚无。虚无是太极。不可分别。唯一而已。故以一为无也。若有境则有彼此相形。有二有三不得为一。故在阴之时。而不见为阴之功。在阳之时。而不见为阳之力。自然而有阴阳。自然无所营为。此则道之谓也。故言之谓道。以数言之。谓之一。以体言之。谓之无。以物得开通。谓之道。以微妙不测。谓之神。以应机变化。谓之易。总而言之。皆虚无之谓也。圣人以人事名之。随其义理以立称号。释曰。若以阴阳变易能生万物。即是邪因。而注及疏。皆云一者无也。故是无因。故云若计一为虚无。自然则亦无因也。以虚无亦通邪因。故致亦言

疏。然无因邪因下。第三双就结过。言生应常生者。人自然生应常生。人不待父母等。众生菩提亦自然生。则一切果报不由修得。此正无因之过。若以虚无为因。亦邪因过。随计各异。略不言之。上来广破异计竟

疏。以不知三界由乎我心下。第三举正折邪。于中三。初总明迷倒因缘。次况出深旨。后拣滥显邪。初中三界由乎我心。即唯大乘下十地有文。唯识等论皆引成立。谓心法刹那。自类相续。无始时界展转流来。不断不常。凭缘凭对。非气非禀。唯识唯心。岂同儒道气变为神。神由气就。气非缘就。出于自然。自然而成其性自化。非由修习耶。岂况心外别有冥性微尘等耶。况梵天等为能生耶。疏。从痴有爱流转无极者。即净名经。义通大小。大乘有二义。一无明发业爱能润业。二过去无明现在爱取。小乘则唯有后义。虽由三毒。此二胜故。涅槃亦说生死本际凡有二种。一者无明。二者有爱。此二中间。即有生老病死。其文非一。小乘立三毒为生死根本者。中论染染者品云。经说贪欲嗔恚愚痴是世间根本。乃至云三毒因缘起于三业。三业因缘起于三行。是故有一切法。十二因缘品云。众生痴所覆。为后造三行。以有此行故。识受六道身。皆是三毒为根本义。然外道虽立三德。不知是己心之所有故。又计从冥而起用故。故为邪见

疏。迷正因缘等者。唯心痴爱。即正因缘。若大乘说唯心为因。痴爱为缘。小乘亦以痴爱为因。业等为缘。大乘亦以业种为缘故

疏。安知因缘性空等者。第二况出深旨。因缘有相浅义尚迷。性空真理安测涯分。性空通于初顿终教。妙有即是实教。若通于空有二文交彻。具德即是圆教

疏。言有滥同下。三拣滥显邪。谓易云。寂然不动。感而遂通天下之故。礼云。人生而静天之性也。感物而动性之欲也。老子云。杳兮。冥兮。其中有精。其精甚真。庄子云。有真君存焉。如是等文。后儒皆以言词小同。不观前后。本所建立。致欲混和三教。现如今时成英尊师作庄老疏。广引释教以参彼典。但见言有小同。岂知义有大异。后来浅识弥复惑焉

疏。同于涅槃盗牛之喻者。即涅槃第三答迦叶问。经云。尔时迦叶菩萨白佛。言。世尊。出世之法与世间法。有何差别。如佛言曰。佛是常法不变易法。世间亦说梵天是常。自在天常无有变易。我常性常微尘亦常。若言如来是常法者。如来何故不常现耶。若不常现有何差别。何以故。梵天乃至微尘世性。亦不现故。佛告迦叶。譬如长者多有诸牛。色虽种种同共一群。付放牧人令逐水草。但为醍醐不求乳酪。彼牧牛者构已自食。长者命终。所有诸牛悉为群贼之所抄掠。贼得牛已无有妇女。即自构捋得已而食。尔时群贼各相谓言。彼大长者畜养此牛。不期乳酪但为醍醐。我等今者。当设何方而得之耶。夫醍醐者。名为世间第一上味。我等无器。设使得乳无安置处。复共相谓。唯有皮囊。可以盛之。虽有盛处不知钻摇。浆犹难得况复生酥。尔时诸贼以醍醐故加之以水。以水多故。乳酪醍醐一切俱失。凡夫亦尔。虽有善法。皆是如来正法之余。何以故。如来世尊入涅槃后。窃盗如来遗余善法若戒定慧。如彼诸贼劫掠群牛。诸凡夫人虽复得是戒定智慧。无有方便不能解说。以是义故。不能获得常戒常定常慧解脱。如彼群贼不知方便丧失醍醐。如彼群贼为醍醐故加之以水。凡夫亦尔。为解脱故。说我人众生寿者士夫凡天自在天微尘世性。戒定智慧及与解脱。非想非非想天即是涅槃。实亦不得解脱涅槃。如彼群贼不得醍醐。是诸凡夫有少梵行。供养父母。以是因缘得生天上受少安乐。如彼群贼加水之乳。而是凡夫实不知因修少梵行供养父母得生天上。又不能知戒定智慧归依三宝。以不知故说常乐我净。虽复说之而实不知。是故如来出世之后。乃为演说常乐我净。如转轮王出现于世。福德力故群贼退散牛无损命。尔时转轮王即以诸牛付一牧人多巧便者。是人方便即得醍醐。以醍醐故一切众生无有患苦。法轮圣王出现世时。诸凡夫人不能演说戒定慧者。即便退散如贼退散。尔时如来善说世法及出世法。为众生故令诸菩萨随而演说。菩萨摩诃萨既得醍醐。复令无量无边众生获得无上甘露法味。所谓如来常乐我净。以是义故。善男子。如来是常不变易法。非如世间凡夫愚人。谓梵天等是常法也。此常法称。要是如来。非是余法。迦叶。应当如是知如来身。释曰。以法对喻。文相可了。是知儒道言同。皆佛法出。疏。况抨驴乳下。即智论第三文。意谓佛教如牛乳。修得解脱。如抨得酪生熟酥等。不解修行尚不得酪。况外道教犹彼驴乳。佛喻于牛。外道如驴。驴乳本非出酪之物。外道之教无解脱味。故抨驴乳但成屎尿。依外道教行。但招苦果无所成益

疏。广明异计下。第四指广从略。恐繁故略。欲知源故指所出耳

疏。今但说下。第五结功超胜。言佛法之浅浅者。以其十宗前前浅于后后。后后深于前前。前二望第十。有八重之深。已能总破一切外道况第三宗。况第四宗。乃至第十展转深妙。然上所引皆是外宗甚深玄妙。今以第二并能超之。故云佛法之浅浅。已胜外道之深深。然西方外道。明说三世多信因果。知厌生死欣求涅槃。但真源小差。致去道悬远。况此方儒道善止一身。纵有终身之丧。而无他世之虑。虽齐生死强一枯荣。但以生死自天。枯荣任分。天乃自然之理。分乃禀之虚无。聚散气为生死。归无物为至道。方之释氏不合同年。略辨释道之殊。以举十条之异。一始无始异。谓释立生灭因缘。无定初始。儒道有太初太始。为物之先。太初为万物之先。物自造化。因缘为万法之本。兴灭由人。二气非气异。释以心为法本万行凭缘。道以气变为神。无为自化。自化则无修无习。弃智绝圣。凭缘则必假修成。万行会本。三三世无三世异。释以禀质色心灵契相续。随缘起灭。三世迁流。儒道以聚气为生散气为死。死则归夫天地。不续不存。既止一身宁知三世。四习非习异。释以善恶由业。愚智习生故。积劫熏修灵识玄妙。儒道以善恶由分愚智自天。禀纯和则至圣至神。禀浑浊则为愚为暗。纵言慎习止在一身。岂说积功能资他世。五禀缘禀气异。释以参罗万象并由缘生。儒道以富贵吉凶皆由气命。禀气者不可改易。禀缘者则可增可修。六内非内异。释以天地万物。内识变生。儒道以人物蠕飞。皆由天地所变。在我则可变染令净。所变在天任彼高底。七缘非缘异。释以四相迁流。浮虚变灭。皆由缘力非曰自然。儒道以日化月移趣新更故。力皆自尔。非由我心。八天非天异。儒道以祸福吉凶派流为二。一者天。二者地。地而所为可得闭绝。故谋未兆而散脆微。天之所为不可遁避。故受而喜之。忘而复之。是以安乎天者弃于人。绝于圣者从乎道。斯老氏之旨。释以果报因缘。宗源斯二。一者苦集。二者灭道。灭道者。不住不染离断离常。高出空有之颠。迥超生死之外。苦集者。因心回转逐业高低。往来六趣之中。留连三有之内。是以厌乎苦者断于集。忻乎灭者修于道。此释氏之旨也。二家之理皎若掌中。户则千门殊归异贯。较之于一其可得乎。九染非染异。老以仁毁于道。绝仁而道自停。不在于为也。欲害于性。去欲而性自得。不在于修也。利累于生。屏利而生自成。不在于益也。礼出于乱。弃礼而乱自除。不在于作也。理由于道。有道而理自至。不在于圣也。得在于时。时来而位自成。不在于争也。是以不求而自得。不为而自成。为之者必败。求之者必失。此老君之教也。释以善为福道之本。修善而受福人天。不善为恶道之根。积不善而沉沦三恶。慈为无害之径。欲为生死之源。绝欲而生死必除。行慈而寿命长远。是以为善者必得。为不善者必失。离欲者必超欲。不离欲者必陷欲。此释迦之教也。教方既辩。异乃条然。譬彼寒温理难并合。十归非归异。释以生死苦也。从妄想而形。贪爱垢也。因无明而起。因无明而起。则可剪可除。从妄想而生。则可搴可拔。搴拔缘乎性假。除剪由乎体妄。知体妄者。息妄而证涅槃。达性假者。弃假而归寂灭。于是控御一乘。浮航六度。越生死苦海。出火宅烦笼。迥登般若之台。妙入涅槃之苑。湛然常乐与虚空而并存。嶷尔圆明混境智而双寂。此乃释教之所归也。老以生与死命也。悉是道之所为。圣与不肖性也。但是天之所与。天与不可逃。道为不可捍。知天道不可迷捍者。则能安处生死。而守全性情。性情全而天不坏。死生处而道不亏。道不亏则悦恶之虑消。天不坏则喜怒之心灭。于是出嚣尘之域。游道德之乡。理孤劭于寰中。神独凝于方外。澹然玄寂。而累害不能千。怕尔无为而邪气不能袭。可以长生。可以尽年。此老教之所归也。所归既异。发轸复殊。相去渺然千里非远。此上十异。即冀审思慎之深衷。多以小乘因缘以破外宗玄妙。况乎真空妙有事理圆融。染净该罗一多无碍。重重交映念念圆融哉。无得求一时之小名。浑三教之一致。习邪见之毒种。为地狱之深因。开无明之源流。遏种智之玄路。诫之诫之。传授之人善须拣择

疏。三法无去来宗。谓大众部等者。先标宗。说有现在下释而云等者。等取七全一少分。谓都八全一少分。同有此计。一大众部。二雪山转部。三鸡胤部。四制多山部。五西山住部。六北山住部。七法藏部。八饮光部。宗轮论序制多西山北山云。余义多同大众。叙法藏亦然。叙饮光云。余义多同法藏故。上八部类同此计。言一少分者。取根本化地部。彼云。过去未来世无。现在无为是有。叙雪山转云。余义多同说一切有部。亦无去来也。北京素公云。以前义故。四分律法藏部义。及四阿含僧祇律大众部义。并是第三法无去来宗也

疏。四现通假实宗等者。一全一少分。一全者。即说假部。一少分即末经部。以根本经部是第一宗摄故。其成实论。先是数论弟子。以所造为能造。后出家入佛法时经部摄。故三藏云。经部细实而粗假。实义同故现通假实摄。此说假与一说。说出世别。此谓真谛中有假实。蕴门明义是实者。实积聚故。界处门明义是假者。假积聚故。今疏云。其成实论。即是少分末经部也

疏。五俗妄真实宗等者。以世俗是假。假故妄也。出世为真。真非是假故。是实也。少似中论一半向前

疏。六诸法但名宗者。则显出世亦假名耳。故云。一切我法亦如中论。若有世间则有出世间。既无世间何有出世间等

疏。七三性空有宗者。即是大乘法师所立。应理圆实宗

疏。八真空绝相宗。即是大乘法师胜义。俱空宗

疏。九空有无碍宗等者。谓互融故。有是即空之有。空是即有之空。语空必摄有。言有必摄空。故曰互融。双绝者。有即空故有绝。空即有故空绝。言不碍两存者。不坏相故。有即空而有不泯。空即有而空不亡。真如随缘者。上言空有容滥但空故。说真如即空空即真如。又异但凝然。故云随缘。非无不变。具恒沙德者。唯法性宗非唯空寂而已。上皆实教中义。如前立教中辨

疏。十圆融具德宗。广如义分齐

疏。然此十宗后后深于前前下。第三料拣。于中二。先通料拣十宗。后会通妨难。前中有五。一通明浅深故后后深于前前。然此十宗前六全同大乘法师。大乘则有八宗。七名胜义俱空。八名应理圆实。即以法相为应理圆实。法性为胜义俱空。今回七为第八。八为第七。如前西域中。二宗不同。今符法性。又加后二以显甚深。疏。前四唯小。五六通大小。下二大小乘料拣。然五六立在小乘。义通大乘。故云五六通大小。疏。七即法相下三。权实料拣。疏。又七即始教下。四以五教料拣。但举四教。前六小乘。即当第一小乘藏教。以前已有大小料拣故略不言。疏。又第七亦名二谛俱有宗者下。五二谛料拣。亦是随难别释。唯料拣三宗。以含异义故重释之。初宗二谛俱有可知。疏。如掌珍颂者。即清辩菩萨所造一论唯释此偈。此中有两重比量。前半有为法比量。谓立云有为是有法。定空无性。是宗法因。云从缘生故。同喻云。如幻法。幻法从缘生。幻法空无性。有为从缘生。有为空无性。此中因喻前却。或回文不尽。而言真性者。即有为性。亦合言有为真性空。二无为比量。云无为是有法。定无实故。是宗法因。云不起故。同喻云。如空华。空华无有起。空华无有实。无为无有起。无为亦无实。故中论云。若有有为法。则有无为法。既无有有为。何得有无为。广如彼论

疏。即般若三论中一分之义者。以三论中四谛品前以空遣有。四谛品中以空立有。故偈云。以有空义故。一切法得成。若无空义者。一切则不成。又标名以中论意。显不滞空有。非但明空。又偈云。因缘所生法。我说即是空。亦名为假名。亦名中道义。则三观齐驱。三谛无碍。岂独空耶。故有言学龙猛宗堕恶趣空。斯言可怖。故云一分之义。即三观中一空观义疏。九二谛无碍宗者。即真不碍俗。俗不碍真于谛常自二。于解常自一。通达此无二。真入第一义。二谛并非双。恒乖未曾各。亦其义耳。今略其旨。故指前文。所以不会第十宗者。第十亦可名二谛无尽宗。然必融于前。故不别立耳。又上三宗诸师各立。故今叙之。其第十宗非彼所竞。故不言耳

疏。然十宗五教下。第二释通妨难。谓有难云。十宗何异五教。而重辩耶。故为此通。然有二义。一则通局不同。二乃体式有异今初。先双标。后教则下。双释。显明二通。影出二局。上句。言教则一经容具多教者。显明教通也。如一维摩则具五教。涅槃般若等亦具五教。故而影出宗局。维摩但是事理无碍宗。不通三性空有等宗故。言宗则。宗容具多经者。显明宗通。以一事理无碍宗内该法华维摩涅槃等故。而影出教局也。如一经中具有五教。不相通故

疏。又夫立教必须断证等者。二明体式有异也。亦重通妨难。难云。若各有通局。何以不得以宗为教。以教为宗。故为此通。教有断证阶位等殊故。但有五宗。约所尚各别故有十宗。故前六所尚不同。而成六宗而断证等齐。但为小教。则教宗无违也

疏。第二显别宗下。二释别宗。疏中分二。先总明立意。二开章别释。今初又二。先正立诸经。各自有宗故。此别明斯经宗也。如法华以一乘为宗。涅槃以佛性常住等为宗。故云各自有宗。虽互有兼通。就其偏重故。标为别宗

疏。然楞伽下解妨。妨云。楞伽第二云。大慧。一切法不生。不应立是宗。故今通云。斯言遣滞耳。若一向不立宗者。何以彼立宗通说通。故经云。宗通自修行。说通示未悟。昔人云。宗通说不通。如日被云曚。宗通说亦通。如日处虚空。既有二通。则非无宗矣。是为无宗之宗。立而无立。为宗说兼畅。是日处空耳

疏。略以二门分别下。第二开章别释。于中亦二。先标章。后前中下。依章别释

疏。初品中无尽平等等者。即是晋经第二。善光海大自在天王偈。下半云。无取无起亦寂灭。为一切归故出世。即今经妙焰海天王偈云。佛身普遍诸大会。充满法界无穷尽等。疏。缘起相即入故者。即缘起相由门意

疏。十贤首以前下。就此一师。疏文有二。先出意总立。后谓前之二师下。为其解释。即释互阙之言。出其新立之意。于中又二。先出互阙。后故贤首意下。彰其立由。虽依光统师而更添之。于中三。初总标。二由光统师下。出光师意。不安缘起法界之由。三贤首下。出贤首加之所以。于中有二。先总明所以。以彼得别而阙总故。以法界下。二出总别之相。法界有四。理实是一。故云别也。缘起是总而有二义。一本有缘起。如大方广。方广是业用。周遍是本有故。佛华严是因果即修成缘起。又缘起是义。因果是位故

疏。二申今解下。疏文有二。先总明建立。后今释前义下。开章别解。前中五。一总相标立。二显其包含。三彰加所以。四释通妨难。五重显异门。今初意云。略则第十师其言则多。既光统别不摄总。应言法界缘起。总则摄别。不应复存因果理实之言。若取广说。又阙不思议。故云若取前义。应言因果缘起。理实法界不思议为宗。若取次第。应言法界理实缘起。因果不思议为宗

疏。此则摄一总题下。第二显其包含。方字两用。向上则大方。大方无隅即法界故。向下方广。业用是缘起法界故。故云法界总该前二

疏。而法界等言下。第三彰加不思议之所以。拣异余经。故兼引文证

疏。净名但明下。第四释通妨难。即蹑迹为难。谓若加不思议。欲异余经。尚同净名。曾何成异。故为此通彼得业用。不得德相故。故彼经云。有解脱名不思议。菩萨住是解脱。能以须弥之高广。内芥子中等。曾不说言真如具无尽德。佛身不分而遍尘毛之德不可尽等。故彼而为一分。故龙树呼此经为大不可思议经。则显彼为小不思议。不思议虽无大小教中彰之有广狭故

疏。若就题中下。第五重显异门。上来所辩。但明题中已具经宗。若准天台智者释法华经。于一题中有体宗用。今取例释故有三也

疏。互用皆通者。谓不坏性相。则理法界性义名界。若事法界分义名界。若性相交彻。相既即性。分即名性。性即相故。无分即分。故言互通

疏。二显义中曲有四门等者。此门有三。初总标。二别释。三总结。初标可知。别释四章即为四别

疏。第一别开法界等者。此一段疏文有四别。一标章略明。二于中十事下。开章别释。三而此因果互为宗趣者。会通宗趣。然有二意。一者五周。皆以因果为其宗趣。若以修因为宗。得果为趣。举果为宗。令修因为趣。二者所信因果为宗。令得差别因果为趣。举差别为宗。成所信为趣。举差别为宗。令得平等为趣。举平等为宗。融差别为趣。举平等为宗。令成行为趣。举顿成诸行为宗。令信平等为趣。举成行为宗。令证入为趣。举证入为宗。令忘证修行为趣。故言互为。疏。一经始终下。第四结成因果。收前五六七八四师之义。彼皆不出因果故。故此因果不违法界。以是法界成因果故

疏。第二会融因果以同法界下。疏亦有四。一标章。二法界门中下。开章解释。三五对别明下。会通六释。谓不坏因果。及交彻故。四上五周因果下。结归法界。收前衍裕二师。就结归法界中有二意。一归事理法界。谓第五因果即前因果。又前之四对。皆通因果。因果皆有境智等故。又第三对中一种是理。余之九事皆是事摄。故五周因果不出此十。二况因果无性下。会上归于理法界也

疏。第三法界因果分明显示。文亦有四。一总标。二亦有十义下。别释。三此上五对下。会宗趣。如举在缠法界为宗。令得出缠清净为趣。余四例知。四又上五中下。结示法界因果之相。收前光统师。唯初一对。是法界理实。余皆缘起因果

疏。第四法界因果双融下。此门但二。一先标。二别释。今初。由双融故俱离。由双融故混然。离不碍存故云无碍。能存能离故云自在。法界虽通事理。今取理实。故法界为性。因果为相

疏。一由离相下。别释中初二一对但明俱离。三四一对不碍两存。然性则叵坏。但云不泯。相则可坏。故言不坏。五即合其初二。六即合其四三。皆由性相相即故。二对皆不相异。七复合其五六。谓六是于存。五是于泯。正存即泯。故复不异。八即融前因果令同法界。九由同法界因果互摄。十令因果差别之法。一一别摄。已知大意。次随难释。疏。此即相为宗等者。举相意欲令亡。不在相故。后对合上离相。并为其宗。令亡因果者。前离于相。明因果之相本离。今亡因果。令离取相之心。言下九准思者。二中应云举性为宗。令离性为趣。离性为宗。令亡法界为趣。三即离性为宗。不泯性为趣。以性本自离不待泯故。又离性不泯性为宗。令亡法界不碍法界为趣。四以离相为宗。不坏相为趣。相本自离不待坏故。又离相不坏相为宗。令亡因果不坏因果为趣。五离相为宗。不异离性为趣。由性相不异故。若异离性。非真离相故。又离相不异离性为宗。令双融性相俱泯为趣。六不坏相为宗。不异不泯性为趣。若离不泯有不坏者。是定有故。又不坏不异不泯为宗。令俱存现前为趣。七双存为宗。不异双泯为趣。以即泯而存方是存故。又双存不异双泯为宗。令超视听绝思议。不碍见闻言念为趣。然超视听之妙法。则约相说。绝思议之深义。则约性说。八法界性融不可分为宗。令因果各摄法界为趣。九因果各全摄法界为宗。令因果互在为趣。十二位差别皆摄法界为宗。一一行位无尽为趣

疏。上之四门下。第三总结。于中有四。初以体用收之。体即前性。用即前相。二又初即因果下。以宗中十一字收之。三既以第四融前。则四门一揆者。总融四门。四故即照下。会归心观。在法为离。在心为遮。在法不坏。在心为照。遮即初之二门。照即三四二门。然初遮是即照之遮。次照是即遮之照。五即双遮。六即双照。七即正双遮。而正双照。八即四门一揆。圆明一观。九十随一句中。具摄前四。亦同一观。又十门齐鉴曰照。无心于十曰遮。双照照前照遮。双遮遮前遮照。言亡虑绝。了了分明。故上十门圆明一观。方契十门之旨。合上四门之宗。希领文系之表也

大方广佛华严经随疏演义钞卷第十四大方广佛华严经随疏演义钞卷第十五

        唐清凉山大华严寺沙门澄观述

疏。第七部类品会下。此章有二。先辩来意。后于中四下。开章解释

疏。摩诃衍藏是文殊等者。即结集法藏经说。有三阿难。一阿难。此云庆喜。持声闻藏。二阿难跋陀。此云喜贤。持独觉藏。三阿难伽罗。此云喜海。持菩萨藏。但是一人随德名别。由此阿难多闻。闻持其闻。积集三慧。齐备文义。并持于三藏教总持自在。于铁围山间者。纂灵记说。然此记本是藏和尚制。后经修饰。其间经论所无。皆问日照三藏。乃西域相传耳。而纂灵记及刊定记。皆言智度论说。未见其文。金刚仙论亦同此说。云佛记铁围山外二界中间。召集阿罗汉八十亿那由他。菩萨无量无边恒河沙等结集。疏。龙树菩萨往龙宫。见此大不思议经。有其三本等者。纂灵记引真谛三藏西域记说。龙树别传亦说入龙宫见经之缘。广如别说。然龙树案七卷楞伽经。如来记云。大慧。汝应知善逝涅槃后。未来世当有持于我法者。南天竺国中大名德比丘。厥号为龙树。能破有无宗。世间中显我无上大乘法。得初欢喜地。往生安乐国。唐三藏西域记。亦广说其行迹。疏。遮拘槃国有其具本者。案隋开皇三宝录。其于阗东南二千余里。有遮拘槃国。彼国王历叶相传。敬重大乘。诸国名僧入其境者。并皆试练。若小乘学者即遣而不留。摩诃衍人请留供养。王宫内有华严摩诃般若大云等经。凡一十一部并十万偈。王躬受持亲执户钥。香华供养种种庄严。悬诸彩旛。间以时果。诱诸王子使入神拜令其回向。又此国东南可二十里有山。其内置华严大集。方等宝积。楞伽方广。舍利弗陀罗尼。华聚陀罗尼。都萨罗藏。摩诃般若。大云等经。凡一十一部皆十万偈。国法相承传宝守护。初东晋有沙门支法领。志乐大乘。捐躯求法。裹粮抗策。以至遮拘槃国。竭诚请祷。遂得华严前分三万六千偈。赍来至此。即东晋朝所译是也。然而龙树具本以从上升。法领半珠遂行东土。圣凡证异。华梵音隔。修途阻绝。妙旨沦湑。落简遗编。仅传兼半。又案今于阗所进。盖逾四万偈。其晋经第一会所说。华藏世界文多阙略。取悟无由。至八十卷烂然可见。虽十万之偈未全。已四万之文多具。即上略本也

疏。即海云所持者。是善财第三善友。如六十二经

疏。不思议法品者。教起因缘法尔因中已引

疏。色与非色言与非言等者。色与非色对声名等。谓为体中。以声为体。即色蕴摄。名等为体。即非色蕴故。今并不可定之。言非言等。兼对诸法显义体。声名句文并属于言。诸法显义功即非言等。今异界类别故不可定之

疏。七十三名圆满因轮者。晋经。但名圆满修多罗。此是大愿精进力夜神叙昔为善伏太子救于狱囚。半月行施就戮时临。如来入会为说此经。第二品会差别中二。初总明。后今经九会下。别辩。于中先明会别。后今有三十九品。下彰品不同。今初言九会者。下随文释。中具列。今当略示。谓初三会各有六品。四有四品。五有三品。六有一品。七有十一品。八与九各唯一品。故三十九。言九会者。第一菩提场会(从第一经至第十一)第二普光法堂会(从第十二至第十五)第三忉利天宫会(从第十六至第十八)第四夜摩天宫会(从第十九至二十一)第五兜率天宫会(从第二十二至三十三)第六他化自在天会(从第三十四至三十九)第七重会普光法堂会(从第四十至五十二)第八三会普光明堂(从第五十三至五十九)第九逝多园林会(从第六十尽第八十)其九会名至下疏辩。疏。言三十九品者。以会会之。中各有序正等故。次第云何。第一会有六品者。一世主妙严品。二现相品。三普贤三昧品。四世界成就品。五华藏世界品。六毗卢遮那品。第二会六品者。第七名号品。八四谛品。九光明觉品。十菩萨问明品。十一净行品。十二贤首品。第三会六品者。第十三升须弥山顶品。十四须弥顶上偈赞品。十五十住品。十六梵行品。十七初发心功德品。十八明法品。第四会四品者。第十九升夜摩天宫品。二十夜摩宫中偈赞品。二十一十行品。二十二十无尽藏品。第五会三品者。第二十三升兜率天宫品。二十四兜率宫中偈赞品。二十五十回向品。第六会一品者。即第二十六十地品。第七会十一品者。第二十七十定品。二十八十通品。二十九十忍品。三十阿僧祇品。三十一如来寿量品。三十二诸菩萨住处品。三十三佛不思议法品。三十四如来十身相海品。三十五随好光明功德品。三十六普贤行品。三十七如来出现品。第八会一品者。即第三十八离世间品。第九会一品者。即第三十九入法界品。所以前后次第尔者。夫圣人设教。必有其渐。将欲命乎微言。先说三种世间严事。为九会之都序。起大法之原由。故受之以世主妙严品。同诸经之序分。二由致既彰。将陈正说。众海兴念。举其问端。如来将酬。先现瑞相。口光远召菩萨来仪。毫光普烛示说法主。震动刹网。以警群机。佛前现华。表说依果。白毫出众彰教从佛流。总为说法之端倪。故受之以如来现相品。三现相既着。法主将宣。如来长子。即普贤菩萨。毫光既示。悬解圣心。欲显难思。先明入定。内观事理外鉴根宜。上感佛加下为物轨。故受之以普贤三昧品。四既入至定。诸佛赞扬。定起发言。言必真当。先陈如来依报。总说刹海源由。故受之以世界成就品。五成就乃总明刹海。次别彰本师昔所严净。安布成立。无尽庄严。量等虚空。尘含法界。故受之以华藏世界品。六依报殊胜必有所因。其犹源远。流长根深果茂。故说昔为太子历事难思。备修胜因。严净刹海。即举人显法。故受之以毗卢遮那品。上之六品。总明所信因果。为第一会。亦名举果劝乐生信分也。次第二会有六品者。七由上所信方举依果。欲起深信复须识正。故先明如来三业正报。谓身语意。身是其总故先明之。应物成身随宜立号。故受之以如来名号品。八言随物欲广说法轮。展四谛之法门。名周法界。一一世界各有四百亿十千之名。故受之以四圣谛品。九身语既彰。意业将显。意玄叵测仍带身明。故足轮放光照事警物。文殊普遍说智光明。双照事理警令悟入。身智二照合为一光。令二觉齐圆。故受之以光明觉品。十上之三品。复为所信正报之果。次当正说十信法门有解行德。先明解穷玄智。谓十甚深十首菩萨。互相激扬。故受之以菩萨问明品。十一既有正解。复须正行历境造修。悲智双运无障不寂。故受之以净行品。十二解行既圆。便成胜德住于圆位。以圆功德而自庄严。以圆力用建立众生。贤首说此。故受之以贤首品。上之三品。明十信法。第三会六品者。第十三由上十信已周。将说十住。故不动觉树而升释天。体用无方赴于物欲。其犹澄江一月三舟共观。一舟停住二舟南北。南者见月千里随南。北者见月千里随北。停舟之者见月不移。是为此月不离中流而往南北。如来应现类此可知。即体之用无不普周。去住在缘佛无动静。不动而遍。以赴彼机。故受之以升须弥山顶品。十四既至彼天。菩萨云集赞扬佛德。显住体深玄。故受之以须弥顶上偈赞品。十五感应已交。正陈所说。明信满入位得正定心。以深般若住于真理。故受之以十住品。第十六十住。是位别行不同。若欲通修。皆须净行。故观十种境入甚深观。观法尽也。正法当兴。惑智亡也。真智方起。修佛十力。起四等心悲智双流。初发心时便成正觉。故受之以梵行品。十七行位既具。次彰胜德。十住之德后后过前。但明初住以况于后。初发心住德已难量。由无分齐等虚空界。举斯胜德劝物发心。故受之以初发心功德品。十八自分已圆。将趣十行。说于明门。以为胜进。故受之以明法品。第四会四品者。第十九上之六品十住已圆。将欲说行。亦须赴感。故受之以升夜摩天宫品。二十佛既赴感助化赞扬。显十行体。皆依佛智故受之。以夜摩宫中偈赞品。二十一由致既彰。正说中贤十行之位。故受之以十行品。二十二自分已终欲阶后位。蕴积众行。拟将回向。故受之以十无尽藏品。第五会三品者。二十三前第四会行德既具。将说回向说主赴感。故受之以升兜率天宫品。二十四十方云集助化赞扬。显回向愿。皆依佛智。故受之以兜率宫中偈赞品。二十五由致既彰。正说上贤十向之行。谓回向三处而无障碍。大悲普覆故回向众生。大智上求故回向菩提。入理双寂故回向实际。三无前后大愿普周。故受之以十回向品。上之三品已周。上贤离进趣相更无胜进。第六会一品者。即第二十六十地一品。谓上之三会三贤既具。解行愿周。亲证真如。有十重胜德。如地普载生成万物。若四河入海同趣佛智。宝珠十德渐渐增修。大地十山嶷然高出。大海十德。德德该通。为诸如来微妙智业。故受之以十地品。第七会十一品者。第二十七十定品。谓十地既满将成正觉。十地胜进立等觉名。等觉法门量同法界。略申数义以显深玄。先明十定穷尽法源。能为通用智慧之本。故受之以十定品。二十八依定之用量周法界。故受之以十通品。二十九定通难量特由智极。故终明智慧玄奥宏广。故受之以十忍品。忍即智也。三十定通智用一一难量。若欲校量非数能数。故须历数至不可说。积不可说以至十重。校量等觉功德难知。以况妙觉位德微细。阿僧祇为大数之首。故受之以阿僧祇品。三十一僧祇所说微细难知。念劫圆融刹那莫穷其际。尘刹该摄一尘。有无尽普贤。今略陈指事。明穷一切时。故受之以如来寿量品。以劫为日。后后倍前。刹劫难穷。佛寿亦尔。故云寿量品。三十二复明遍一切处。上就实。说尘尘皆是诸佛菩萨所居。今指事就粗。令归心有在。故受之以诸菩萨住处品。三十三佛不思议法品者。上之六品辩等觉法门。等觉义周。终明妙觉。妙觉之果略有二义。一名不可说。二可寄言。寄言之中复有二义。一差别说。二平等说。差别说者。即次下三品酬前诸因。因果别故。初总明佛德迥超言念。故受之以佛不思议法品。三十四次辩身相普周。总有十莲华藏世界海微尘数相。一一相用遍周法界深广难测。故受之以如来十身相海品。三十五大相既尔。随好更多。一一好中有多光明。一一光明用周法界。破地狱苦生兜率天。三重顿圆十地速满。彰其功用。故受之以随好光明功德品。三十六上皆差别因果。次有二品明平等因果。谓因无异果之因。果无异因之果。因果交彻。平等不二。不二而二。因果历然。因即普贤行门。故受之以普贤行品。三十七明果。即十门出现性起圆融。故受之以如来出现品。上之六会。总辩修因契果。生解分竟。第八一会。唯一品者。即离世间品。由上差别平等因果生解既终。今摄解成行。六位顿修辩二千行门一时齐起。而处世无染。故受之以离世间品。第九会唯一品。即入法界品。近望上文。大行既具。则证法界。远取诸会。信解行愿本在于证。依人证入。故次辩之。如来自入师子频申三昧。即果法界。令诸大众顿证法界。善财历位渐证法界。渐顿该罗。本末融会。皆证法界。故受之以入法界品。是知无尽教海。唯证相应。无尽法门自此略毕。故末偈云。刹尘心念可数知。大海中水可饮尽。虚空可量。风可系。无能尽说佛功德。此则言思道断矣。故三十九品条贯真诠。令无尽法门宛如在目。故云今经有三十九品。疏。初会六品彼经唯三十四下。辩晋经有阙开合可知

疏。第三明支类等者。支即支流。支者分也。亦如树枝从一树身分出枝分。本即华严故。此中言流。如从一池流出诸泒。大部如池别行如泒故。类即流类。此中言流。取相似流类之义。谓余别行经。不从大部分出。义势相似。即今经流类故

疏。小十住经者。以古德译十地亦云十住。或云十住地。今言小者。即地前十住。今言大者。即十地经。非以卷少为小等。疏。渐备一切智德者。一切智即佛智。十地即佛智中十德。如海十德。以十地之法。后后深于前前。故云渐备。故地影像中。明十地行相。次第现前能趣入一切智。智即渐备义。又如阿耨达池。流出四河。复更增长乃至入海。又如宝珠十德后后过前。皆渐备义。疏。无边功德经者。以前刹之劫。为后刹之日。后后胜前前。明功德无边矣。疏。罗摩伽即入法界之梵语。罗者此云离垢染。摩者转义。伽者一合义。谓离垢染转。即净法界。一合即入义

疏。二明流类等。疏文有二。先正明是类非本部之支泒。后或是别行彰有支义。古德见今经所无。将为流类。本部来既未尽。是此别行复何可定。多闻阙疑。故云未敢详定

疏。三北齐刘谦之等者。及与灵辩并如纂灵记。下当重出。但今云行道一载。即是传文。若准论序不言年数。又但云于悬瓮山嵩岩寺。顶戴华严经。勇猛行道足破血流。膝步殷勤。精微感悟。不言清凉。多是随方之人欲美其处。故取太原当处明之。传既云在清凉。必托胜境。况传中所明。经历数处方终百轴。第八传译感通

疏。佛度跋陀罗。此云觉贤等者。案纂灵记。本姓释氏。迦维罗卫国人。甘露饭王之苗裔。觉贤三岁而孤。八岁丧母。为外氏所鞠。从祖鸠摩利闻其聪敏。乃度为沙弥。同学一月诵习。贤乃一日当之及受具戒。博览群经多所综达。少以禅律驰名。尝与同学僧伽达多游处积年。知其已证不还果。常愿游方以弘至化。会秦沙门智严至罽宾国。问彼国僧谁可流化东土。咸云贤可。贤本受禅业于佛大仙。佛大仙时亦在罽宾国。智严求人东化亦谓严曰。可以振维僧徒宣授正法。即贤其人也。严即披诚至请。贤遂默而许焉。于是辞师东迈。涉路三载。寒暑备经艰危罄受。或层岩四合鸟道跻云。或连冰千里。风行雪卧。每清晖启曙即潜伏幽林。皓月良霄乃奔波永路。飞梯架迥扪索凭虚。危惧日寻。资粮时绝。至于交阯渐达夷途。附舶海行。备经危险。方达青州东莱郡。闻罗什在长安。欣然而诣。后游东晋。至安帝义熙十四年。吴郡内史孟顗。右卫将军褚叔度。请译此经别造净室。其年三月十日起首。贤乃手执梵文。共沙门法业慧严等百有余人。于道场寺诠译。指文会理通言适妙。故道场寺犹有华严堂焉。永嘉六年卒。时春秋七十有一。手屈三指明得阿那含果。余广如传。业公未详氏族。风格秀整。学无常师。遍阅群教。每以为未能探微照极。常怏然不足。后遇觉贤请译华严筹咨义理。数岁之后廓然有所通悟。因顾其友人曰。圣教司南于是乎在。遂敷弘幽旨郁为宗首。着旨归两卷。见行于世。今不见本者。以希声初启未遑曲尽。时月淹久故多废替。慧严慧观。即什公八俊之二。笔格高简经论深博。备于僧史

疏。谢司空寺者。即道场寺。从檀越呼之。严观二德并此寺僧。疏。今润州兴严寺者。晋时称南扬州。其境广阔。今分出为润州耳

疏。日照三藏者。住摩诃菩提及那烂陀寺。风仪温雅。神机朗逸。负笈研精。琢玉成器。属玄奘三藏传教东归占风圣代。以永隆初至自京师。高宗弘显教门。诏会龙象。道成律师薄尘法师等十大德于魏国西寺。翻译经论。时有贤首法师。先以华严为业。每叹大教阙而未圆。往就问之。果云赍第八会文来至此。贤首遂与三藏对校。果获善财求善知识。天主光等十善友文。乃请译补阙。复译密严等经十有余部合二十四卷。垂拱年中。右胁而卧。无疾而终。门人等建塔于龙门山伊水之右。后梁王武三思奏请置伽蓝。制以香山为名。月殿陵烟。波涵倒景。珠旛散迥。影入飞云。工不日成。乃回天眷。法门盛事。今古莫俦

疏。三证圣元年于阗三藏实叉难陀等者。具如开元释教录第九。证义译文僧。总一十三人。俗官五人。弘景禅师有表。案经序中。本于大遍空寺亲受笔削。故表云。陛下亲临法座焕发序文。自运仙毫首题名品。七曜垂象。景丽于三明。八体成文。光敷于五义。法宝分行而错落。净华入贯而昭彰。九会真诠。词中悉现。百城奥旨字下皆明

疏。其文之要至下当辩者。八十卷初。疏中具明。意云。第七十七末。善财自云。我以文殊故。见诸难见者。彼大功德尊。愿速还瞻近。七十九末。弥勒广示后友。赞文殊德。令往问文殊。又云善男子。汝当往诣文殊师利善知识所。而问之言。菩萨云何学菩萨行。云何入普贤行门。云何成就。云何广大。云何随顺。云何清净。云何圆满。善男子。彼当为汝分别演说。何以故。文殊师利所有大愿。非余无量百千亿那由他菩萨之所能有等。广赞竟。次结云。善男子。汝应往诣文殊之所莫生疲厌。今既无彼文殊。案顶十五行经。则令弥勒记言为虚。善财。不依弥勒之教。先来拟往。复违昔心。又阙智照无二相文。则令后见普贤亦无因起。故今有之。诸过皆离。故云其文之要。文续义连

疏。二明传通感应下。此段疏文分三。初正辩感应。二出感应所以。三感庆逢遇。初中有六。一翻译。二造论。三书写。四读诵。五观行。六讲说。今初。晋译微言双童现瑞者。谓初于道场寺译经。堂前池内。每日有二青衣童子。从池中出捧香散华。举众皆见。又以此经久在龙宫。龙王庆此传通故。令龙子给侍。亦有善神护诸左右。故下云冥卫昭然。疏。唐翻至教甘露呈祥。则天梦。普天降甘露。故经序云。甘露流津。预梦庚申之夕。膏雨洒润。后覃壬戌之辰。以其十四日辛酉初译。前后各有一日感微。疏。冥卫昭然下。成上二译。此句成上晋译。如上已引亦有善神执戟卫护左右故。言亲纡御笔者。即成上唐译。然事即因讲。以则天序云初译之日。梦甘露以呈祥。又是讲新译华严经。故入译经之中。传云。新经初译之后。佛授记寺诸大德。请藏和尚讲。敕令十月十五日开讲便即入文。至十二月十二日晚上讲。讲至华藏世界海震动之文。其讲堂内及寺院中。忽然震动。于时道俗数千共睹。叹未曾有。三藏法师实叉难陀。及当寺大德明诠律师德感法师。述兹灵应具以奏闻。都维那慧表署状为首奏闻则天。以圣历三年腊月十九日。则天后亲运御笔批云。省状具云。昨因敷演微言。弘扬秘赜。初译之日。梦甘露以呈祥。开讲之辰。感地动而标异。斯乃如来降迹。用符九会之文。岂朕庸虚。敢当六种之应。披览来状。欣畅盈怀。宜付所司颁示天下。此批及状具如别录。故云亲纡御笔

疏。论成西域等者。即世亲菩萨西域记云。世亲菩萨是无著之昆弟也。性与聪敏良缘未具。遂以小乘为业。三端妙耸峻若霜峰。四辩横分。利如星剑。无著知小乘权教接引下机。慰疲俗而置化城。诱穷子而持粪器。遂设方便托病在床。令唤世亲示将去世。世亲闻已。不日至焉。无著见之。广说病源。因开大教云。及吾未死之间读吾所习经典。世亲即读华严。乃见毗卢法界普贤行海。如日光而总照。若帝网之相含。因生信悟叹曰。可取利剑断吾舌根。用明裨赞小乘之失。兄止之曰。如人因地而倒。亦因地而起。昔日以舌毁于大乘。今可将舌以赞大乘。遂入山披览大乘。造十地论。论成之日大地遍震光明洞然。国主自谒曰。得阿罗汉等果耶。答曰未得。既未得圣果。何以地动。答曰。贫道小年不信大乘。今者良为造大乘论。而得地动。故云地震光流

疏。志彻清凉感通玄悟者。此有二人。一刘谦之。二灵辩法师。初中传云。北齐太和年中。第三王子。于清凉山。求文殊师利菩萨。烧身供养。其王子下有阉官刘谦之。自叹形余。又睹王子焚躯之事。乃奏乞入山修道。既谐所欲。遂赍此经一部。昼夜精勤礼忏读诵。心祈妙德以希冥祐。绝粒饮水垂三七日。形气虽微而丹恳弥着。忽感髭鬓尽生复丈夫相。神彩通悟。洞晓幽旨。覃思精修。爰造斯经之论。始终纶综。凡六百卷。遂以奏闻。高祖敬信有倍常日。华严一教。于斯转盛。言灵辩法师者。传云。后魏沙门灵辩。太原晋阳人。宿殖胜善常读大乘。及见车严偏加钻仰。乃顶戴此经。入清凉山寺求文殊师利潜护。凡历一岁足破血流。肉尽骨穿。忽闻空中谓之曰。汝止汝止。但思惟此经。于是披卷豁然玄悟。后熙平元年岁次大梁正月内于清凉寺。敬造华严论。演义释文一百卷。穷微洞奥。至二年初。徙居悬瓮山嵩岩寺造毕。余具如传。若准论序。但云在悬瓮感通。今据传文故。亦清凉感通玄悟也

疏。其书写则经辉五色者。后魏安丰郡王延明。中山王元熙。并以宗室英灵博通归一。虔心无上稽首圆宗。以香和墨。写华严经一百部。金字华严一部。皆五香为藏。七宝为函。静夜良辰清斋行道。即放神光五色照曜堂宇。众所咸睹因而发心。不可胜纪。疏。楮香四达者。即僧德圆。不知氏族。天水人也。常以华严为业。读诵受持妙统宗极。遂修一净园种诸谷楮。并种以香草杂以鲜华。每一入园必加洗濯。身着净衣溉以香水。楮生三载香气四达。后别立净室书写此经。才书数行。每字光发照明院宇。又神人执戟现形警卫。又有青衣梵童无何而至。手执天华亦申供养。余如传说。疏。冬葵发艳者。即邓元爽。华阴人。证圣年中。爽有亲故暴死。经七日却苏。说冥中欲追爽。爽甚危惧蒙彼使命令写华严。写竟。爽母坟侧先种蜀葵。至冬已悴。一朝华发璨然荣茂。乡闾异之。乃为闻奏。则天皇帝为立孝门。疏。瑞鸟衔华者。僧法诚隐居蓝谷。后于南岭造华严堂。藻洁中外庄严既毕。乃图画七处九会之像。乃屈弘文馆书生张静敬写之。诚亦亲执香炉专精供养。后感瑞鸟。形色非常衔华入室。旋绕供养再三往复。经成之后精心转读者。多蒙感祐

疏。读诵则眇然履空者。隋禅定寺僧慧悟。京兆人。常与一僧同在终南栖隐。慧悟受持华严。一持涅槃。木食岩栖各专其业。忽有一人。无因而至。拜跪问讯。问讯既讫云。请一师就宅赴斋。二人相推。彼曰。请华严。法师悟因随往。乃是山神。请千罗汉皆推之于上。食讫皆飞空而去。神呼一童令侍。乃入师口中。因便得通还归取经。辞其友僧眇然而去。广如传说。疏。焕若临镜者。即僧辩才。不知何许人。幼事裕法师。以华严为业。久而不悟。乃护净造香函盛经。顶戴行道。凡经三载。遂梦普贤指授玄义。因忽成诵焕如临镜。疏。每舍舍利者。即樊玄智。安定人。弱岁修道于京城。南投杜顺和尚。顺令诵华严为业。劝依此经修普贤行。每诵经时。口中频获舍利。前后数百粒。疏。适会神僧。即苑律师。京兆延兴寺僧。以贞观初。途经[溧-木+(革*月)]桥舍于逆旅。日既将夕。因而寓宿。俄有异僧仪服粗弊同至。主人别房而止。遂命醇醪良肉快意饮啖。律师持洁。勃然秽之。其僧食已乃嗽以灰水。闭户而诵华严。俄终一轴。苑乃束身抱愧侧听玄音。未至五更便终六帙。苑深自悔责。悲泣交怀。入房礼忏。因而分袂。不告名字。莫知所之。疏。踊地现金色之身者。即慧祐法师。京崇福寺僧。戒行精苦。事俨和尚。专以华严为业。每清景良宵焚香专诵出现一品。后时忽见十余菩萨从地踊出。现金色身皆放光明坐莲华座。合掌敛念听诵此品经。经了便隐。疏。升天止修罗之阵者。即般若弥伽。于阗国沙弥也。甚有戒行每诵华严为业。忽有一人合掌窃谓曰。诸天令弟子奉请法师。请师闭目。遂至天上。天王跪而请曰。诸天今与修罗斗战。屡被摧衄。今屈法师。诵华严经。希望法力加护。弥伽如其所请。乘天宝辂。执天幢旛。心念华严。以诸天众对彼勍敌。修罗见之。忽然溃散。须臾送归。身染天香。终身不灭

疏。观行则无生入证偈赞排空者。即解脱和尚。姓邢氏。岱州五台县人。七岁出家志业弘远。初从介山抱腹岩慧超禅师处。询求定舍。超有知人之鉴。识其才器。告众曰。解脱调习融明。非尔辈所邻。未几而大启悟。后于五台西南佛光寺立精舍。读华严。复依经作佛光观。屡往中台东南华园北古大孚寺。求文殊师利亲承言诲。菩萨告曰。汝今何须亲礼于我。可自悔责必当大悟。后因自求。乃悟无生。兼得法喜。遂慨兹独善思惟广济。祈诚大觉请证此心。乃感诸佛现身说偈曰。诸佛寂灭甚深法。旷劫修行今乃得。若能开晓此法眼。一切诸佛皆随喜。解脱更问空中寂灭之法。若为可说得教人耶。诸佛即隐但有声告曰。方便智为灯。照见心境界。欲究真实法。一切无所见。又尝本州都督请传香授戒。法事既毕。将俟东归。都督及众送至城东。日云暮矣。思欲焚香。乃闻城上空中声曰。合掌以为华。身为供养具。善心真实香。赞叹香烟布。诸佛闻此香。寻声求救度。众等勤精进。终不相疑误。故云。偈赞排空。余广如传。然或即大圣化身事难详究。德广化博未之有也。疏。海神听而时雨滂沱者。即僧道英。姓陈氏蒲州人。年二十二亲为之婚娶。五载同居。誓不相触。后于并州炬法师筵下。听华严经。便落[髟/米]入太行山柏梯寺。修行止观。曾属亢旱。讲华严经以祈甘泽。有二老翁各二童侍。常来在座英每异之。后因问由绪。答云。弟子并是海神。爱此经故共来听受。英曰。今为檀越讲经请下微雨。神乃敕二童。童便从窗孔中出。须臾滂霈。远近咸赖焉。二翁拜谢。倏然而灭。故云海神听而时雨滂沱。其行迹绝多。亦广如传说。疏。天童迎而大水弥漫者。即隋朝僧灵干。姓李氏狄道人。依衍法师出家。年十八能讲华严。住兴善寺为译经证义沙门。后遇疾而死。数日乃苏云。住兜率天见休远二法师。并坐华台光晖绝世。谓干曰。与我报诸弟子。后皆生此。干志奉华严。常依经作华严观及弥勒天宫观。至于疾甚目睛上视。若有所见。沙门童真问之。答曰。向见青衣童子。引至兜牵天宫。而天乐非久终堕轮回。莲华藏。是所图也。言终气绝。须臾复苏。真问何所见耶。干曰。见大水遍满华如车轮而坐其上。所愿足矣。言绝而逝。故云尔也

疏。讲说则华梵通韵者。即宋朝求那跋陀罗。唐言功德贤。中天竺人。初学五明诸论。靡不该通。后崇佛法深入三藏进学大乘。大乘师试令探取经匣。即得华严。师喜之。令其讲说。元嘉十二年至广州。刺史车朗奏闻。太祖遣使迎接。南谯王义宣等。并师事之。集义学沙门七百余众。谯王欲请讲华严经。以华言未通有怀愧叹。即朝夕礼忏。虔请观音以求冥应。遂梦有人执剑持一人首。来至其前曰。汝何忧乎。于是具陈上事。即刎却陀首。便置新头语令回转得无痛耶。答曰。不痛。豁然便觉。备悟华言。遂讲华严至数十遍。余如传说。疏。人天共遵者。即魏勒那摩提。此言宝意。中天竺人。博闻赡学通诵一亿偈经。尤明禅性。以正始初。至洛阳译十地等论二十四卷。意神理摽峻。慧悟绝伦。领受华音。妙穷清切。帝每令讲华严经。精义频发。尝处高座。忽有持笏。执名者。形如大官云。天帝令来请法师讲华严。意云。法事所资独不能逮。都讲焚香。维那梵呗。咸亦须之。讲席众僧悉皆同见。意熙怡微笑告众辞诀。奄然卒于法座。都讲等僧亦同时殒。故云人天共遵。疏。洪水断流者。即僧法顺。俗姓杜氏。京兆杜陵人也。操行高洁。学无常师。以华严为业。尝居山日将欲种葵。地多虫蚁。乃巡疆定封。虫便外徙。尽力耕垦。一无所损。三原县人自生聋哑。顺乃召之与语。应言便愈。因诣南山属黄渠泛溢。止之断流徐步而过。将终之日。普会有缘声色不渝。言终而逝。葬在樊川北原。今全身塔。在长安南华严寺。事迹颇多。别传云。是文殊化身。疏。神光入宇者。即藏和尚。僧法藏字贤首。俗姓康氏。康居国人。初贤首母梦异光而孕此。为一光。及生而志慕无上。年十七辞亲。求法于太白山。后慈亲不愈归奉庭闱。绵历岁时能竭其力。时俨法师于云华寺讲华严经。贤首至中夜忽见神光来烛庭宇。贤首叹曰。当有异人发弘大教。及明乃遇俨和尚。自是伏膺深入无尽。此为二度神光入宇。又后于云华寺讲。有光明现从口出。须臾成盖众所知见。又是神光正取言同。即第二节神光入宇。取其讲时即第三节。语其生瑞兼第一节。故云神光入宇。余如别传

疏。良以一文之妙摄义无遗下。第二明感应所以。于中四句。初上一句正辩所以。以一文一偈摄义无遗。极圆妙故。故普贤菩萨告善财言。我此法海中无有一文。无有一句。非是舍施转轮王位而求得者。非是舍施一切所有而求得者。释曰。以一是一切之一故。称性之一也。疏。故一偈之功下三句。辩其功能。亦是感通之事初一偈之功能破地狱者。纂灵记云。京兆人。姓王名明干。本无戒行。曾不修善因患致死。被二人引至地狱。地狱门前见一僧云。是地藏菩萨。乃教诵偈云。若人欲了知三世一切佛。应当如是观。心造诸如来。菩萨授经已。谓之曰。诵得此偈。能排汝地狱苦。其人诵已遂入见王。王问。此人有何功德。答云。唯受持一四句偈。具如上说。王遂放免。当诵此偈。时声所至处。受苦之人皆得解脱。后三日方苏。忆持此偈。向诸道俗说之。参验偈文。方知是华严经。夜摩天宫无量菩萨云集所说。即觉林菩萨偈也。今经偈云。若人欲了知三世一切佛。应观法界性一切唯心造。大意是同。意明地狱皆由心造。了心造佛地狱自空耳。既一偈之功能破地狱。何况一卷一品一部之玄微。愿思此言勉夫传诵。疏。盥掌之水尚拯生灵者。即长耳婆罗门。僧弥伽多罗者。师子国第三果人也。麟德年初来仪震旦。高宗大帝甚加尊重。处于禁中岁余供养。多罗请寻圣迹。遂往清凉山礼敬文殊师利。因出至西太原寺。时属诸僧转华严经。乃问曰此是何经。答是华严。多罗肃然改容曰。不知此处亦有是经耶。合掌欢喜赞叹久之。言曰。此大方广功德难思。西国相传。有人读此经以水盥掌。所沾虫蚁而舍命者。皆得生天。何况受持读诵观察思惟者欤。故云尔也。疏。读诵思修功齐种智者。上辩盥掌之水。今明读诵思修功至齐佛。即十地经。解脱月先问也。初金刚藏云。佛子。此集一切种一切智功德菩萨行法门品。若诸众生不种善根不可得闻。解脱月菩萨言。闻此法门得几所福。金刚藏菩萨言。如一切智所集福德。闻此法门福德如是。何以故。非不闻此功德法门。而能信解受持读诵。何况精进如说修行。是故当知要得闻此集一切智功德法门。乃能信解受持修习。然后至于一切智地。释曰。闻尚齐于种智。何况读诵思修不可量也。经虽举闻为显胜故。意通思修故。疏云。读诵思修功齐种智耳

疏。宿生何幸下。第三感庆逢遇可知。余诸感通具于传记者。上来所引。粗举数条耳

大方广佛华严经随疏演义钞卷第十五大方广佛华严经随疏演义钞卷第十六

        唐清凉山大华严寺沙门澄观述

第九总释名题中。初总标章

疏。今初总题下。别释。于中二。先释总题中三。初标举。二一通显下列章名。三今初诸经下别释。于初章中有二。先总举诸经体式。二别明今经得名。前中疏或以人为目。或以法为名者。总说也。以人为名。约明法之所由。以法为目。乃举经之本体

疏。人有请说等殊下。别释人中举其二类等取所为。所说言请者。一从请人得名。如思益梵天所问经贤护经等。二就能说人。如无尽意菩萨经等。三依所为人。如须达拏忧填王经等。四依所说人。如金色童子经等

疏。法有法喻等者。所言等者。等取法中有多义故。法之多义次下当辩。喻者如大云经宝积经等

疏。或体或用或果或因者。即法中别义也。体者如般若经等。用者如神足经等果者如涅槃经等。因复多义。一者因行。如正恭敬经等。二者因位。如十住经等

疏。乍复乍单者。复中略有四义。一法喻双题。如妙法莲华经等。二人法双举。如胜天王般若经等。三体用双明。如十住断结经等。四因果双举。如渐备一切智德经等。言或乍单者。通上诸义。谓法单喻单体单用单因单果单。言其类繁广者。即上所明已是繁广。更有从所说时为名。如时非时等经。或从所说处为名。如密严经等。上收余义。故云其类繁广。并非正要故疏略言

疏。今经受称下。第二别明今经得名。于中复二。先举异名。后彰今称前中四义。一数二喻三法四义。用并可知。言梁摄论十胜相者。论曰。谓依大乘诸佛世尊有十相殊胜殊胜语。一者所知依殊胜殊胜语。二者所知相殊胜殊胜语。三者入所知相殊胜殊胜语。四者彼人因果殊胜殊胜语。五者彼因果修差别殊胜殊胜语。六者即于如来修差别中增上戒殊胜殊胜语。七者即于此中增上心殊胜殊胜语。八者即于此中增上慧殊胜殊胜语。九者彼果断殊胜殊胜语。十者彼果智殊胜殊胜语。由此所说诸佛契经诸句。显于大乘真是佛语。今当第十相中

疏。如下离世间及出现品。各有十名者。离世间品十名。经云。佛子此名一切菩萨功德行处(一)决定义华(二)普入一切法(三)普生一切智(四)超诸世间(五)离二乘道(六)不与一切诸众生共(七)悉能照了一切法门(八)增长众生出世善根(九)离世间法门品(十)应尊重听受。应诵持。应思惟。应愿乐。应修行。若能如是。当知是人疾得阿耨多罗三藐三菩提。言出现品十名者。经云。佛子。此法门名为如来秘密之处。名一切世间所不能知。名入如来。印名开大智门。名示现如来种性。名成就一切菩萨。名一切世间所不能坏。名一向随顺如来境界。名能净一切诸众生界。名演说如来根本实性不思议究竟法。即十名也

疏。依今梵本下。第二章。今目也。于中三。初正释今名。二拣前说。三结成今义。疏中一时并举梵言。一时译就此语。若别对者。摩诃言大。毗佛略云方广。勃陀云觉者。即是佛字。佛字略存梵音故。健拏云杂华。骠诃云严饰。修多罗云经

疏。前三异名下。二拣前说。言二品十目多从别义者。不得总该。不可具举故。又局当品者出现十名局于出现。离世间十名局离世间。岂得通为一部总称

疏。故今译者下。结成今义。明其具足。前通辩类中即是复义。而具前四对之复。故理尽义圆也

疏。大方是体。大方无隅故者。大方广三字。总有三义。一三字别释配体相用。如下广说。二方广两字属之为用。对上大字为体。三者大方为体。方字属大。便成无方。言大方无隅者。语出老子德经云。上德若谷。大白若辱。广德若不足。建德若偷。质真若渝。大方无隅。大器晚成。大音希声。大象无形。道隐无名。夫唯道善贷且成。意云。小则有其圭角。大即绝其方隅。隅即角也。借其言用。今大方即法界。等于虚空。何有隅角

疏。若合以华严。则亦喻上之四字者。即是上文二就义中。法喻一对。以严通能所。华为能严。大方广即所严。佛是严成之果。又以因望果。佛亦所严。故华严两字。通喻大方广佛之四字也。言至下当明者。即释严中疏。一体大下别释十大。初体大中二。先总后别。以二义释大而。云即是大字者。古人亦各十义释其七字。不知以七字更互相释。今明大义。则七字皆大。方则七字皆方。广则七字皆广。佛则七字皆佛等。故以体大配于大字。若总举七字。大者体也。方者相也。广者用也。佛者果也。华者因也。严者智也。经者教也

疏。涅槃云所言大者。下证上二义。先证常义。即涅槃第三。名字功德品云。佛告迦叶。是经名为大般涅槃。初语亦善中语亦善下语亦善。义味深远其文亦善。纯备具足清净梵行。金刚宝藏满足无缺。汝今善听。我今当说。善男子。所言大者。名之为常。如八大河悉归大海。此经如是降伏一切诸结烦恼及诸魔性。然后要于大般涅槃放舍身命。是故名曰大般涅槃。释曰。彼经具释大般涅槃。今但取其大字。约体不变故名为常。以性出自古非造成故。故生公序云。夫真理自然。悟亦冥符。真则无差。悟岂容易。不易之体湛然常照。但从迷乖之事未在我。苟能涉求。便返迷归极。归极得本而似始起始。则必终。常以之昧。若寻其趣乃是我始。会之非照今有。照不在今。即是莫先为大。既云大矣。所以称常。常必灭累。复曰般泥洹也。正顺今意。涅槃第二十五。亦云所言。大者。大名不可思议。以体绝常境故。言如人最长者谓无一法先法界故。故老子云。有物混成先天地生。寂兮寥兮独立而不改。可以为天下母。吾不知其名。字之曰道。强为之名曰大。释曰。彼以虚无为道。理异释门。言可证此。疏又云大者。其性广博下。二证上遍义。即涅槃第五。如来性品。南经四相品文云。佛告迦叶。所言大者。其性广博。犹如有人寿命无量名大丈夫。是人若能安住正法。名人中胜故。远公分此一文成二种大。一广故名大。二胜故名大。今但取广遍之义。义便引来彼更有多故名大。如藏多珍宝。复有高故名大。如大高山难至其顶。复有深故名大。犹如大海。即上不思议义。今以多即约用。高即约果。故但用常遍二义。于常义中已含深胜。如人最长即是胜故。又言犹如虚空。复是别文二十三云。又无不遍者。譬如虚空。解脱亦尔。彼虚空者。喻真解脱。真解脱者。即是涅槃

疏。二相大等者。有二意。恒沙性德与起信同。互相即入下。即显圆教事事无碍亦性具矣。然远公释涅槃。亦明体相用。体约性净涅槃。相约方便净涅槃。用约应化涅槃。此通因果。今明所证法中有三。故不同彼

疏。三用大等者。文中三。初正释用大。二涅槃又云下。引证。亦是第五经。南经四相品。以迦叶复问。如佛言曰。我已久度烦恼大海。若佛已度烦恼海者。何缘复纳。耶输陀罗。生罗睺罗。以是因缘当知。如来未度烦恼诸结大海。唯愿如来说其因缘。佛告迦叶。汝不应言如来久度烦恼大海。何缘复纳耶输陀罗。生罗睺罗。以是因缘。如来未度烦恼大海善男子。是大涅槃能建大义。汝等今当至心谛听。广为人说莫生惊疑。若有菩萨摩诃萨住大涅槃。须弥山王如是高广。悉能取令入于芥子。其诸众生依须弥住者。亦不迫迮无往来相如本无异。唯应度者见是菩萨。以须弥山内芥子中。复还安置本所住处下广说作用竟。结云善男子。是菩萨摩诃萨住大涅槃。即能示现种种无量神通变化。是故名曰大般涅槃。是菩萨摩诃萨所可示现。如是无量神通变化。一切众生无能测量。汝今云何能知如来。习近爱欲生罗睺罗。善男子。我已久住是大涅槃。种种示现神通变化。彼经即约果用。今意。明是即体之用。本有之用下佛果有相用者。皆由本自有故

疏。良以涅槃无广。广与大同。下释妨谓有问言。涅槃此义本释大字。何得以广配之。故今通云。涅槃但言大般涅槃。无有广字。以大字含广故。以能建大义。即广家之义。以释大字。今经大字对体。广字对用。故字别释因便。便通方广之经。谓十二分教中有方广经无有大字。而用大字释方广言。即如下合释方广云。宣说广大甚深法故。能生无量广大果故。皆以大释广也

疏。五因大等者。谓发菩提心即十信发心。起解即十住。行即十行。愿即十向。证即十地。精勤匪懈通策于前。以成诸位。所以广说因中差别者。欲收摄论七大性故。次文当知

疏。如摄大乘等。七种大性不离于此者。结会他文。而言等者。等取杂集瑜伽般若。大同小异。摄大乘第一。释大乘云。若广释者。七种大性共相应故。不广说之。瑜伽四十六云。一法大性。二发心大性。三胜解大性。四增上意乐大性五资粮大性。六时大性。七圆证大性杂集十一。说七大性者。一者境大性。二者行大性。三智。四精进。五方便善巧。六证得。七业。彼论云。何等名为七种大性。一者境大性。以菩萨道缘百千等无量诸经广大教法。为境界故。二行大性。正行一切自利利他广大行故。三智大性。了知广大补特伽罗法无我故。四精进大性。于三大阿僧企耶劫。方便勤修无量百千难行行故。五方便善巧大性。不住生死及涅槃故。六证得大性。证得如来十力无畏不共佛法等。无量无数大功德故。七业大性。穷生死际示现一切成菩提等。建立广大诸佛事故。若般若无著论七大性者。一法二心三信解四净心五资粮六时七果。此与瑜伽大同。若与对法会者。一法。即杂集境大性。缘大教法而为境故。二心。即是行大性。即由净心行二利行故。三信解。即智大性。信解与智。于境印持。于境决断。大意同故。四净心。即精进。由精进练磨令心净故。五资粮。即是方便善巧。由大悲般若而为方便。与无住涅槃为资粮故。六时。即杂集第七业大性。穷生死际尽未来时。建立佛事而为业用故。七果。即杂集第六证得大性。谓证佛功德而为果故。杂集据依体起用得果。不舍行因证居其先般若论中约时通因果。故果居时后。余之次第。二论意同。谓依教起行达甚深理。精进长时不滞二边证大胜果。穷生死际建立佛事。故名为大杂集。即是对法瑜伽大同般若。今疏总会上十大义。为七种大性摄。一体大。即第三智。大之中所知无我之理。二相大。亦所知摄。亦法大性即境摄故。三用大。即方便大。而是即体之用。亦境摄故。四果大。全同五因大。摄其五大性。一发菩提心。即是心大。二起解者。摄胜解大。三行愿证。并是行大。是十地因证非果证故。四精勤匪懈。即净心精进大。五成就诸位。即摄资粮大。六智大。全同而义小异。通了性相因果等故。七教大。即是境法大性。八义通前六。但除教故。九名同杂集初一。而义同时大及与方便善巧。十同第六。而具含二论时业二名。为对题中七字摄十故有开合。及次第不同。而义无违。故云七种大性不离于此。或相大一种二论略无理。亦无失。又通约十大。教旨小殊。不妨有异

疏。谓体法相等者。等取下八谓用法果法因法智法教法义法境法业法等。法是轨。持能持自性。故十皆法

疏。三广十义等者。疏文有二。先离释广字。后合释。顺诸经论。释方广经。于中二。先正释十义。后此之十义下结示本源。言前四即杂集第十一中四义。者。彼论云方广者。谓菩萨藏相应言说。如名方广亦名广破亦名无比。为何义故名为方广。一切有情利益安乐所依处故。宣说广大甚深法故。为何义故名为广破。以能广破一切障故。为何义故名为无比。无有诸法能比类故。此方广等。皆是大乘义差别名。释曰。此论标以三名。释成四义。以方广中有二义故。对疏前四次第无差。疏后六即入大乘论。第一中六义者。彼论云。毗佛略者。是摩诃衍。何以故。名毗佛略经。为诸众生说对治法。名毗佛略。亦有众多乘故。名毗佛略。亦以多庄严具故。名毗佛略。亦能出生无量大果报故。名毗佛略。非是称量所能知故。名毗佛略。断除一切诸邪见故。名毗佛略。释曰。次第与疏全同。但以毗佛略隔之。以成六义。然其第一说对治法。似杂集。第三广破。杂集约所破。此约能破。故亦不同。五非是称量。似于集论第四无比。集论约法不可比类。此约心不能知。故并不同。而刊定记云。集以对治。与入破障是同。乃除入论第一加集论菩萨藏相应言说为五者。殊失论意。以菩萨藏相应言说。是总拣小故。总拣已竟。方标三名。释成四义耳。若欲以集论之四。摄入论之六者。一即第二广说义。二即三四广德广生。皆深法故。三即一六对治破见。皆破义故。四即第五广超广绝。大意同故。今取小异。并开为十。则二论不同。谓集论一约言教。入论二约所摄。集论二约通辩甚深。入论别开三约二严通因。四约能生唯果。集论三约合明对治。入论别分一。治烦恼。六破智障。杂集第四似入论第五。已如前会故成十义。然为顺二论之次。故不依题之次。若欲配者。一广绝是大。体绝众相不思议故。二广超是方。妙法无类故。三广摄是广。摄无边故。四广知是佛。具种智故。五广破。六广治。七广生。三皆华字。并是因故。八广德是严。具二严故。九广依是经。依言教故。十广说是义。甚深法是所说故。即总上六字亦可通七

疏。四解佛十义等者。文有三解。初依本经。言如八地及离世间品辩者。上教缘中已广其义。今更略明八地。明十身即离世间品十佛。八地云。知如来身有菩提身。愿身。化身。力持身相好庄严身。威势身。意生身。福德身。法身。智身。离世间品五十三中说十种佛。所谓成正觉佛。愿佛。业报佛。住持佛。涅槃佛。法界佛。心佛。三昧佛。本性佛。随乐佛。十佛即是十身。若欲会者。正觉佛。是菩提身。愿佛即愿身。业报佛即相好庄严身。住持佛即力持身。涅槃佛即化身。法界佛即法身。心佛即威势身。三昧佛即福德身。本性佛即智身。随乐佛即意生身。今疏为顺经题故。不依彼二经之次。言大即法界佛者。大即法界体故。方即是本性佛者。即是本有智性故。广即涅槃佛者。化周遍故。亦随乐佛者。随自他意无不生故。佛即成正觉。佛者佛是梵音。此云觉者故。自觉觉他觉行圆满故。华即愿佛。及三昧佛者。并是因故。严即业报佛者。谓万行之因严成相好庄严身故。经即住持佛者。教法住持法不坠故。总不离心。七字皆是心佛者。是威势身心伏胜故

疏。又佛地论第一下。第二引佛地论者。论无别释。今当略辩。摄此十句。以为五对。一能证智。二所断障。三所证理。四所成益。五显觉相。前四法说。后一喻明。然此五对一一相属。一能证智者。即具一切智是根本智。一切种智是后得智。二所断障中。以一切智断烦恼障。一切种智断所知障。种类而知故。三所证理中一切法者。即真谛法也。一切种相者。俗谛法也。以一切智总相。观法之性。以一切种智别相观法之相。由证法性除烦恼障。由达法相断所知障。四所成益者。一则自利。二者利他。上之三对。俱通二利。若取别义。以一切智自证法性。便是自觉。以一切种智觉法之相。故能觉他。五显觉相者。如睡梦觉者。以一切智觉诸法之性。顿破无明烦恼睡眠故。如莲华开者。以于种智觉法之相。开悟法门。如于华开得见莲故。前即觉察。后即觉悟。此五无缺方称觉满。名曰妙觉。离觉所觉而尽觉故。上之解释未见经论。理必应然

疏。又真谛引真实论。亦有十义恐繁不引者。即真谛三藏七事记中引言十义者。谓觉胜天鼓(一)不由他悟(二)离二无知(三)已过眠梦(四)譬如莲华(五)性净无染(六)具足三义(七)具足三德(八)具三宝性(九)自知令他知(十)初言觉胜天鼓者。天鼓有四德。今并过之。一能觉悟诸天。贼来云来。贼去云去。佛即不尔。能令众生觉三烦恼。若生知生。若灭知灭。二天鼓能护天众。能破修罗。佛即不尔。能救三苦。能破四魔。三天鼓能令诸天受五欲乐。佛即不尔。能令众生受出世乐。四天鼓能令诸天生贪着心。佛即不尔。能令众生生出世心。具此四过。故云觉胜天鼓。二不由他悟者。无师自然智故。三离二无知者。即是烦恼无知。所知无知。四已过眠梦者。凡夫眠而不梦。唯烦恼故。二乘亦眠亦梦。以有无明及妄解故。佛不眠不梦。无有无明舍妄解故。五犹如莲华者。日光照触莲华即开。十地行成佛智自发。六性净无染者。因时虽有烦恼。五义不染。一佛无相故。譬如烟雾不能染空。二是对治故。譬如镕铁不停蚊蚋。三非处所故。譬如大石不能住空。四无转异者。譬如白玉涅而不缁。五妄不染真。譬如幻刀不能斫石。因时有惑尚不能染。果时惑尽岂当有染。七具足三义者。即是三佛。一假名佛。谓六神通。二寂静佛。谓惑不生。三真实佛。谓即真如。八具足三德者。谓摩诃般若解脱法身。九具三宝性者。谓同体三宝。十自知令他知者。即是二利。谓佛智慧力照真如境。名曰自知。复以慈悲力。说十二部经。令他知也。释曰。以此十义有同佛地故恐繁文

疏。五释华十义下。疏文有二。第一别释十华。第二总相料拣。前中即如次配于十佛。如一含十义。表法界佛。含性德故。为对十佛故。为此次亦可配于十度之因。而不依次为顺题故。一即般若。二即智度。三即方便。四即尸罗。五即忍辱。六即是愿。七即禅定。八即是檀。九即是力。十即精进。此意如下普眼长者。以十度因成十身果。故彼经云。为欲令其具佛相好。称扬赞叹檀波罗蜜故。即成相好庄严身。二云。为欲令其得佛净身。悉能遍至一切处故。称扬赞叹尸波罗蜜。即意生身。三为欲令其得佛清净不思议身。称扬赞叹忍波罗蜜。即菩提身。四为欲令其获于如来无能胜身。称扬赞叹精进波罗蜜。即威势身。五为欲令其得于清净无与等身。称扬赞叹禅波罗蜜。即福德身。六为欲令其现于如来清净法身。称扬赞叹般若波罗蜜。即是法身。七为欲令其现佛世尊清净色身。称扬赞叹方便波罗蜜。即是化身。八为欲令其为诸众生住一切劫。称扬赞叹愿波罗蜜。即愿身。九为欲令其现清净身。悉过一切诸佛刹土。称扬赞叹力波罗蜜。即力时身。十为欲令其现清净身。随众生心悉使欢喜。称扬赞叹智波罗蜜。即是智身。末云。为欲令其获于究竟净妙之身。称扬赞叹永离一切诸不善法。即圆净十度八万四千波罗蜜门。万行顿具该上十华。是故梵本名为杂华。上约相显。别配十度。若约圆融。一一行门皆具十义。可以意得

疏。然华有二种下。第二总相料拣。其引果华。亦喻生因。其严身华。亦喻了因。此二无碍。言或与果俱者。如莲华等。因该果海。果彻因源。圆融行故。或不与俱者。杏柰等华。因果区分行布行位不相杂故。此二无碍。是此中华

疏。神通众相等者。净行品云。若见华开。当愿众生。神通等法。如华开敷。若见树华。当愿众生。众相如华具三十二。神通等相。果上用故云与果俱。然神通虽乃通因。且就金玉之华与身俱说

疏。六释严者下。疏文。有三十八义。且为三节。初十总释。次十别释。后十八句互严。今初言为严不同者。如以十宝严一金佛。一真珠严二珊瑚。严等一佛十严。历于十佛。便成百严。约圆融修故

疏。又上十华如次严于十佛者。第二别释义。同一度成一佛。故总别无碍者。总融上二。行布圆融二无碍故。疏更有十义下。第三约互严说。于中有二。一别约十义五对。以互相严。二收成四句。以显互严。今初十义。在文可知。然亦是于别释得名。又释名中。释名之义。若约圆融。皆持业释。若约当相。皆依主释也。如第一用因严果。是华严之佛故。二即佛之华严故。三即佛华严之大方广。四即大方广之佛华严。五即大之方广。六即方广之大。七即大之方。八即方之大。九即大方广佛华严之经。十即诸因互严乃含多义。谓。施之戒戒之施。定之慧。慧之定等。前四成对。后一非对。但可以大等严经。不可以经严大等。故不成对。又为欲显诸因互严故

疏。禅非智无以穷其寂等者。举一为式。余可类取。谓禅无智。但是事定。若得智慧观于心性。为上定故。智不得禅乃为散善。分别慧故。慧若有定。如密室灯寂而能照。离动分别成实慧故。所言等者。等余万行。如施不得戒。非是真施。破戒行檀。非真福故。戒不得施。亦非真戒。悭贪不息。非真戒故。不舍财法。正犯戒故。余并可知

疏。又上来互严下。第二收成四句。于中二。先总标。后初相资四句下。别释

疏。无不从此法界流者。即从本起末证行从理发。无不还证此法身者。摄末归本证理由修显

疏。三理行俱融不二而二下。此句有三节。一此上正释以互融故不二。不坏两相故而二

疏。非真流之行下。第二反成上义。上句反上成行融理。次非起行之真。不从行显者。反上成理融行

疏。良以体融行下。三正成前义。言体融行而因圆者。行即是因。以体融行故因行圆满。行该真而果满者。正成上行融理也。行不该真。何由行得果耶

疏。四理行俱泯。此句易了。然上互融。行融理而行在。理融行而理存。故不二而二。今理行相夺。故云二而不二疏。相即四句下。但例前释。若力用交彻。即说相资。有体无体。即言相即。若具作者。一者唯理。无不真故。二者唯行。理废己故。三者俱融。即行即理。为一味故。四者俱泯。理即行故非理。行即理故非行。故双绝也。言法喻交映者。如人以华严像为喻。喻以因行严佛故

疏。七释经十义。言杂心五义。已见上文者。即藏摄中。谓一出生。二显示。三涌泉。四绳墨。五结鬘。余可知

疏。第四别释得名等者。此中得名。各取前七字别义例。皆二义释之。类前可知。此中释名。即前对辩开合中。五对之中。但除法喻一对。用余四对。以法喻一对华之一字已属因门。故略无之。四对之中望前有二异。一前则从宽至狭故。先明教义。今从狭至宽故。先明体用。又前从下释上故。先明教义。今从上释下故。后明教义。而前五对中。后明人中因果者。以因是华字。借喻中华故在后明。前从宽至狭义已尽故

疏。四教义相对亦通二释者。以易知故不出。若具释者。应云大方广佛华严之经。拣非涅槃等经。故经之大方广佛华严。拣非论中之所明故。而四对皆具二释者。约行布则依主。约圆融则持业

疏。教望于义下。谓四对之中。后二对中通于三释。谓经中有大方广佛华严故。如对法藏论。全取他名以目经故。佛华严有大方广故。故云可思

疏。第五展演无穷等者。然此下四门。皆关中意。然此门中彼有二义。一展一为多。二类结成本。类结成本。不异前第七部类品会中本部故。故此不明。又此展中并皆略示。而有十重。一展法界为理智二门。理即大方广。是所证法界为涅槃。智即佛华严为能证即菩提。虽有六字但是二法。二又展理智为题目。即大是体性包含。方广是业用周遍。故云理开体用。佛即是果。华严是因。故云智开因果。三又展此目为初会。于中自有二重。一但世界成就品。初牒问许说中。已具题目。二通就一会以示品目

疏。十海之中含于体用者。即初会也。十海者。一一切世界海。二一切众生海。三一切诸佛海。四一切法界海。五一切众生业海。六一切众生根海。七一切诸佛法轮海。八一切三世海。九一切如来愿力海。十一切如来神变海。七九与十。此三是用。余皆是体。此十本具皆是所证。故名为理。十之相差是事法界。十之真性是理法界。理事相融。并为所证之理。故云十海是理

疏。智分因果者。上言十智者。知上十海即是十智。而名小开合。经云。佛子。诸佛世尊知一切世界海成坏。清净智不可思议(一)知一切众生业海智不可思议(二)知一切法界安立海智(三)说一切无边佛海智(四)入一切欲解根海智(五)一念普知三世海智(六)显示一切如来无量愿海智(七)示现一切佛神变海智(八)转法轮海智(九)建立演说海智(十)此上皆有不可思议之言。唯愿海是因。余皆是果。若约所知。一三四八九十皆果。余三为因。三世通因果

疏。又华藏世界下。二通就一会。以示品目。则题目该于一会。言遮那遍中者。非唯遍于华藏。亦遍法界。以世界成就品。亦说毗卢遍严净故。彼偈云。所说无边众刹海。毗卢遮那悉严净。世尊境界不思议。智慧神通亦如是。况第六经云。毗卢遮那佛愿力。周法界一切国土中。恒转无上轮。第五经云。佛所庄严广大刹。等于一切微尘数。清净佛子悉满中。雨不思议最妙法。又华藏品云。华藏世界海。法界无差别。又云。一一尘中见法界皆普遍义。故遮那遍中之言。亦已摄于世界成就品矣

疏。彼二所证所观。即大方广者。果证法界大方广。因观法界大方广

疏。又展此会以成后八者。即第四节。展成一部

疏。又展九会周遍十方者。即第五节。言如第二会光明觉品者。举一会文以为体式。谓光明觉品。总有二十六箭放光。最后遍周法界虚空界。皆云彼一一世界。皆有百亿阎浮提。乃至百亿色究竟天。其中所有悉皆明现彼一一阎浮提中。悉见如来坐莲华藏师子之座。十佛刹微尘数菩萨所共围绕。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹微尘数诸菩萨。俱来诣佛所等。释曰。此即遍十方文。既周百亿阎浮等。故是一类世界。言余会亦尔者。下之七会及第一会。皆遍十方。如第二会。故诸会末多结周遍

疏。又展此诸会各有主伴者。即第六节也。上来但明主经之遍。今辩伴经之遍。而引第三会文。则前遍法界之会。各有重重主伴者。此言例上遍法界之九会也

疏。乃至遍于尘刹者。即第七节也。上但遍国。今则遍尘

疏。异类界等者。即第八第九节也。上来七节。但遍同类。八遍异类树形刹等。而疏言等者。等取第九节异类刹尘。谓异类之刹亦以尘成尘。亦有刹。于中说经尤更多矣

疏。无尽时会者。即第十节。谓上同类异类若刹若尘。皆悉重重犹如帝网。时会与法。皆无尽也

疏。皆不出大方广佛华严。举题总收也清净法界。举本总收也。明从一法界无名无相中。展成无尽

疏。第六卷摄相尽者。相字去声呼。乃至无字法界之相亦不存故。然但解上展。则解此卷。故云从后渐卷。言乃至不出九会者。乃至二字略后五重。不出九会。是第四节耳。若具应云。一卷无尽时处。归异类界尘。二卷异类界尘。归异类界。三卷异类界。不出同类界尘。四卷同类界尘。不出同类刹主伴经。五卷主伴不出主经。结遍十方。六卷遍十方不出九会。七归初会。八归总题。九归理智。十归清净法界

疏。非理不智下。是第十节。卷理智归法界。而有二意。一者理智之中随举其一。即摄于二。但成一味。二者以智为用。以理为体。但摄智归理。不摄理归智。初摄二为一。唯一理字。理体性离。一亦不存。故云无字。又准前展。亦合云总题。不出体用因果。因果虽殊。不出一智。体用虽异。不出一理。然后方融理智。但不异前故略示耳。若从七字倒收者。摄教从义。但有大方广佛华严。摄人从法。但有大方广。摄用归体。不离于大。古人云。一言无不略尽。殊说更无异盈又大体性离言。言思斯绝。唯证相应耳

疏。第七展卷无碍者。谓说有前后实在一时。随门不同。故有三门耳

疏。无量无边法门海。即展时也。一言演说尽无余。即卷时也。如来于一语言中。即卷时也。演说无边契经海。即展时也

疏。第八以义圆收者。疏文有二。先以法摄后以人摄前。中又二。先指前不出总题。后或以教义下。重释摄义。疏文略举。若具说者。应增数明。谓或于无字中一字摄尽。谓或教或义。或性或心。或二字摄尽。疏有三节。亦更应言。或法界字摄尽。或三字摄尽。疏又有一义。顺于后段表三圣。故亦应云入法界摄尽理行果摄尽。从所诠故。或四字摄尽。谓教理行果。教即经字。理即大方广。行即华严。果即佛也。或教义成处摄尽。谓文虽浩瀚。唯一教字。即题中经字。观虽无量。但一缘起。义摄题中大方广三字。成谓行解因果德相用等。虽各缘起不同。据其成立。唯一成字摄尽。即题中佛华严也。处谓一切重重无尽同类异类。重重尘刹唯一处字故总卷之。义唯一性。教唯一文。成唯一念。处唯一尘。此一即是一切之一故。或信解行证摄尽。经有四分。初会是信。次六明解。八约成行。九唯证故。如下当知。或五字摄尽。谓加理字。成信解行证。理是所信所解所行所证故。或六字摄尽。即题中除经上之六字。是所诠故。或理信解行愿证。理即所信等。解行愿三即是三贤。证通地上及极果故。或七字摄尽。即全取一题。一题通目无尽法故。或八字摄尽。即法界缘起理实因果故。或九字摄尽。谓无障碍法界缘起因果故。或十字摄尽。谓体相智用因果教义及境业故

疏。或唯普贤文殊下。第二以人摄也。然有二重。前约人法对辩二圣。后于人法中。各有二圣。佛字当中。两重总收可思。第九摄归一心者。于中二。先指前总明。谓上八门已是一心上说。故云上来诸门不离一心。而诸禅流皆欲弃文而修观行。故复接之以辩此门

疏。心体即大下。后正约观心以释。谓心体离念。离念相者。等虚空界。岂非大耶。心之本智。即方广者。上大是即智之寂。方广乃即寂之智。故云寂照。运无涯之照即心。体相用三。融为所观也。观心起行即华严者。观体照而即寂。止也。观用寂而常照。观也。一心六度万行。皆起觉心性相。即是佛者。一念相应觉也。故经云。佛心岂有他正觉。觉世间。觉性无觉。即根本智。觉相历然。即后得智。此二不二。是无障碍智

疏。觉非外来全同所觉下。上明安立六字。今明卷摄相空。此上融成一味。此下互夺双亡。则一不为一。如斯观行未曾一念不契华严

疏。第十泯同平等者。此门总融前九。八是法师所知。九即禅师所尚。故今会之。于中三。初法说。二余曾莹两面镜下喻明。即借帝网之喻。以喻心境。三见夫心境互照下。合喻。意唯一而文有四节。初取两镜及灯合之。一镜喻境一镜喻心。灯喻本智。但取明了之义。言本智双入者。智性色性本无二故。智知一切法。即心自性故。故此智性入心入境。言心境重重者。合两面镜互照。智照斯在。即合一灯双入。是则以本智为能照。心境二法皆为所照。由斯本智令心境互融

疏。又即心了境界之佛下。第二取两镜及一尊容。以合尊容喻真佛。故今学人。只解即心即佛是心作佛。不知即境即佛是境作佛。今明以如为佛。心境皆如。心如即佛。境如焉非。又心有心性。心能作佛。境有心性。安不作佛。以心收境。则心中见佛是境界之佛。以境收心。则境中见佛是唯心如来。心佛重重者。即两镜之重重。而本觉性一者。即尊容之双入。疏皆取之不可得下。第三双融前二。以成止观心境。两亡即止。理智交彻即观

疏。心境既尔下。第四结例一切。境有多境心有多心。各自相对一一互相融也。万化皆然即总结例。唯证相应。则泯同果海也

疏。第二释品名。疏文有四。一会梵音。二释义理。三立名所以。四会释晋经。今初。疏中一时总对。若别对者。萨婆一切也。噜鸡世间也。印拏徕主也。骠诃庄严也。柰耶法门也。钵攞叵婆威德也。[言*那]忙名也。钵里勿多品也

疏。世者时也下。第二释义理也。于中二。先释世主。后妙谓下。释妙严于中三。初正明三世间严。次众生不严下。出立严所以。后复由佛严下。明二严相成

疏。诸经无此下。第三显立名所以。彰异余宗不名序品

疏。旧云世间净眼品下。第四会释晋经。所得法眼。即今法门威德也。自下第十。别解文义。中二。先释经序。后释经文。今初序之题目。备如音义。直解序文。然此一序。大分为六。一明佛日未兴群生沉溺。二明如来出世德用难思。三自庆逢遇。得闻声教。四别彰此典旨趣玄微。五传译古今。感庆逢遇。六总彰序意。赞理自谦。初中三。一明化法域中。二能化浅近。三所化迷沦。今初有二对。前对明混元之初。后对明三才已着。今初。即盖闻造化权舆之首。天道未分是也。盖闻者。发语之端也。造化者。造作变化。易系辞云。刚柔相推而生变化。又云变化者。进退之象也。权舆者。尔雅云。初哉首基肇祖元胎俶落权舆始也。二皆是始言天道未分者。谓元气混沌未分天地。下云人文始着。即有三才。始分天道。今云未分。即五运之时也。故易钩命决云。天地未分之前。谓之一气。于中则有太易太初太始太素太极。为五运也。运即运数。谓时改易。取易义也。元气未分谓之太易。元气始散谓之太初。气形之端谓之太始。形变有质谓之太素。质形已具谓之太极。转变五气故称五运。皆是天道未分也

疏。宗趣中已明言天道者。易系辞云。易之为书也。广大悉备。有天道焉。有人道焉。有地道焉。说卦云。昔者圣人之作易也。将以顺性命之理。是以立天之道曰阴与阳。立地之道曰柔与刚。立人之道曰仁与义。兼三才而两之。故易六画而成卦。又云。在天成象。在地成形。变化见矣。注曰。象况日月星辰。形况山川草木。又易云。易与天地准故。能弥纶天地之道。仰以观于天文。俯以察于地理。是故知幽明之故。原始反终。故知死生之说。注云。幽明者。有形无形之象。死生者。始终之数也。疏云。天有悬象。而成天文也。地有山川原隰各有条理。故云地理。此上皆是已分之相。因释天道故便举之。此对正在未分之前耳。序曰。龟龙系象之初。人文始著者。第二对明三才已着之相。略如向说。易系辞云。是故天生神物。圣人则之。天地变化。圣人效之。天垂象见吉凶。圣人象之。河出图洛出书。圣人则之。孔疏云。如郑康成之义。则依春秋纬云。河以通干出天苞。洛以流坤吐地符。河龙图发。洛龟书感。河图有九篇也。洛书有六篇也。孔安国云。以为河图则八卦是也。洛书则九畴是也。音义云。尧有神龟负图而出舜感黄龙负图而现。言人文始著者。系辞云。古者庖牺氏之王天下也。仰则观象于天。俯则观法于地。观鸟兽之文与地之宜。孔疏云。此下明圣人法自然之理而作易象。次易又云。近取诸身。远取诸物。于是始作八卦以通神明之德。以类万物之情。释曰。上云图出八卦。今云观乎天地者。或见龟复象天地等。于理无违。音义云。观乎天文以察时变观乎人文以化成天下。此非正意。后人用之耳。君臣父子尊卑上下。谓之人文。龟龙举三皇之时。斯为上古。系象举于夫子。即为下古。然其文王为中古。既有卦爻之辞。已有象矣。则总该三古。又上。云天道即言未分。今云人文则言始着。则二言影略。则初分之时亦皆未着。直至系象已具。方曰着明。故先有者即易。有太极是生两仪。两仪生四象。四象生八卦。八卦定吉凶。吉凶生大业。即三才具矣。上明法化竟。序曰。虽万八千岁。至无边之义。第二明能化浅近也。按帝王甲子记云。天皇氏治万八千年。地皇氏治九千年。人皇氏治四千五百年。有本云。三皇皆治一万八千年。故云万八千岁也。言同临有截之区者。毛诗注云。有截者。齐整也。区者域也。谓四海域内率服齐整。言七十二君。讵识无边之义者。司马相如封禅书云。继昭穆受谥号。略可道者。七十有二君。故管子云。昔者封太山。禅梁父者。有七十二家。梁父即太山下。小山名也。讵者何也。明上七十二家。贤明之君。何能识于称性玄理无边之义。序曰。由是人迷四忍至三途之下。第三明所化迷沦也。言由是者。上明化主及法二皆浅近。盖是域中一身之化。不能令所化免沈苦海。于中上对迷理轮回六趣。下对缠妄没溺三途。言四忍者。即思益经第一四法品中。佛言梵天。菩萨有四法。善出毁禁之罪。何等为四。一者得无生法忍。以诸法无来故。二者得无灭忍。以诸法无去故。三者得因缘忍。知诸法因缘生故。四者得无住忍。无异心相续故。是为四忍。言人迷者。人人皆迷故。但迷四忍容漂人天。故云轮回于六趣之中。家缠五盖。则溺三途矣。五盖者。一贪欲二嗔恚。三惛沈。四掉举。五疑也。言家缠者。家家缠也。上三皆明佛未兴世。群生沉溺竟。序曰。及夫鹫岩下。第二明如来出世德用难思。于中四。一总叹化主高深。二明能化时处长广。三别叹如来胜德。四结德归于如来。初中四句分二。前二句总序佛教兴流后二句寄对显胜。今初。上句明主出西天。故云鹫岩西峙。峙者立也。此约处叹人。后句即化法东被也。故云象驾东驱。言象驾者。略有二义。一一千年后像法之时。佛教方被故。二者象驮经故。初虽白马来仪。本用象故。为对鹫岩故用象驾。宋公题安国寺诗云。为龙太子去。驾象法王归。序曰。慧日法王下。第二寄对显胜。初句出域。后句超因。今初。慧日法王超四大而高视者。出域中也。则异前化在域中。慧日者。以佛为日。略有四义。一破闇如慧。二照现如智。三轮净如解脱。四上三不相离。如同法界。于法自在故称法王言超四大而高视者。即老子道经云。道大天大地大王亦大。域中有四大。而王居其一焉。人法地地法天。天法道。道法自然。释曰。然其说道。乃是清净虚通。故云道法自然。自然者。不知其所以然而然故。即世界始成。域中近事不达业因。故曰自然。今佛出现。善证真常妙穷二谛。天地造化。乃俗谛业因。域中之事耳。后句超因。言中天调御。越十地以居尊者。十地菩萨时经三祇。已断十障已证十如。成十胜行化周十方。今比世尊。犹一块土以方大地。况于四大何足越哉。序曰。包括铁围延促沙劫者。第二明时处长广。初句约处。略举三千大铁围内以为化境。岂同上说有截之区。后句约时。多劫促为一念。一念延为多劫。岂同上说万八千岁。序曰。其为体也则不生不灭下。第三别叹如来胜德中。即双明化主化法。略就三大叹之。上二句明体大也。经云。佛身无生超戏论。非是蕴聚差别法。又云。佛以法为身。清净如虚空。故又云。一切法无生。一切法无灭。若能如是解。斯人见如来。序曰。其为相也无去无来者。第二叹相大也。经云。如来。非以相为体。但是无相寂灭法。身相威仪悉具足。世间随乐皆得见。既无相为相故湛无去来。又德周法界。亦无来去。序曰。念处至多绪。即第三叹用大也。于中二。一约化法为用。二约化体明用。今初。化法玄妙。异前化法域中。即行唯造品。心唯四等。方便多门圆应难测。并如经说。言圆对者。身则圆回普应。若月落百川。音则称物普闻。若风吹万籁。意则刹那顿觉。若海印炳然。故云多绪。序曰。混大空而为量下。二约化体明用。谓大之则无外。细之则无内。经云。譬如虚空。遍至一切色非色处。亦如虚空具含众象。刹尘为量不可数知。故云岂算数之能穷。后句入纤芥之微区。匪名言之可述者。经云。如于此会见佛坐。一切尘中亦如是。尘中有刹。刹复有尘。尘复有刹。重重无尘。非是心识思量之境。故绝名言之表。表义名言难述。即言语道断显境名言不知。即心行处灭。亦是前句明化处普周法界。后句细无不入。经云。一一毛端。悉能容受无边世界而无障碍。示现调伏无量众生。序曰。无德而称者。其唯大觉欤。即第四结德归于如来也。谓上之三段皆属如来。则叹不可尽。论语云。泰伯其可谓至德矣。三以天下让。民无德而称焉。故经云。刹尘心念可数知。大海中水可饮尽。虚空可量风可系。无能尽说佛功德。即其事也。序曰。朕曩劫植因叨承佛记下。第三自庆逢时得闻声教。于中三。一蒙佛记。二荷太平。三万国朝宗重译来贡。今初。久远种因。故得大觉亲记。叨者忝也。从金山下别明记相。初明大云经或有疑伪。后玉扆下明宝雨经。郑氏注周礼云。扆屏风也。天子屏风以玉为饰。宝雨经有十卷。入开元正录。第一卷中云。尔时东方有一天子。名日月净光。乘五色云来诣佛所。右绕三匝顶礼佛足。退坐一面。佛告天子曰。汝之光明甚为希有。天子。汝于过去无量佛所。曾以种种香华珍宝。严身之物。衣服卧具。饮食汤药。恭敬供养种诸善根。天子。由汝夙种无量善根因缘。今得如是光明显曜。天子。以是因缘故。我涅槃后第□五百年法欲灭时。汝于此赡部洲东北方。摩诃支那国。位居阿鞞跋致。实是菩萨。故现女身为自在主。经于多岁正法治化。养育众生犹如赤子令修十善。能于我法广大住持建立塔寺。又以衣服饮食卧具汤药供养沙门。于一切持常修梵行。又一切女人犹有五障。此天子不为二障所障。一者轮王。二者不退菩萨。余如彼经。释曰。此时更无女主弘建若是。斯言不虚。序曰。加以积善余庆下。二荷太平也。易云。积善之家必有余庆。积不善之家必有余殃。今由积善故。得地平天成河清海晏。晏犹安也。序曰。殊祯绝瑞下。第三万国朝宗重译来贡也。于中二。初两对标。后两对释。前中谓万。方仰德殊异祯祥。奇绝瑞应日日而至。月月而书。书史册也。贝牒灵文亦时臻而岁洽。岁岁沾洽。二踰海下。两对释成。初成上祯祥而至。后架险下。成上贝牒臻洽。踰海航深。皆水行也。越漠架险。皆陆路也

大方广佛华严经随疏演义钞卷第十六大方广佛华严经随疏演义钞卷第十七

        唐清凉山大华严寺沙门澄观述

序曰。大方广下。第四别叹此典旨趣玄微。于中二。先总叹。后别叹。今初。先二句标其深广。后视之者下。成上二句。既为秘藏故视之不见。称为性海。安测边涯。挹者。珠丛云。以器斟酌于水也。故文选头陀寺碑云。盖闻挹朝夕之池者。无以测其浅深。仰苍苍之色者。难以知其远近。故今测量者。以管窥天用蠡酌海也。序曰。有学无学志绝窥觎下。第二别叹。于中三。初约人叹。二约法叹。三约处叹。初中二。先对劣显胜。后当体显胜。前中初句通三乘。后句别说。然二乘在座如聋如盲。三乘菩萨积行多劫。不能测故。窥者。左传云。谓举足而视觎者。珠丛云。谓有所冀望。后最胜种智下。当体显胜。上句约果满。以满二严成种智也。下句云普贤文殊等者。纳因圆。普贤之行文殊之愿。二皆圆也。亦得行愿通上二圣。序曰。一句之内下。第二约法叹。于中上句约能诠深广故。一句之义竭海墨而不尽。后一豪之中下约所诠。事事无碍故。一豪之中置刹土而非隘。序曰。摩竭提国下。三约处叹。举摩竭者。九会本故。不起觉场而周遍故。举普光者。近菩提场。又说信门该于果海。故云爰敷寂灭之理。序曰。缅惟奥义下。第五传译古今感庆逢遇。于中二。先明前译多阙。后明今译多具。今初。缅者远也。惟者思也。六代。即晋宋齐梁陈隋也。言惟启半珠未窥全宝者。即涅槃圣行品。雪山童子闻化罗刹。云诸行无常是生灭法。惊而愿视。唯见罗刹。问罗刹云。大士。汝于何处得是过去离怖畏者。所说半偈。大士。汝于何处而得如是半如意珠。释曰。欠下半偈义未全故。若得闻下生灭灭已寂灭为乐。即全宝也。今明先译既多阙略。为半宝也。序曰。朕闻其梵本下。第二明今译多具。即全宝也。文中有六。一邀迎。二正译。三感征。四事毕。五赞益。六庆遇。今初。事如玄谈。序曰。粤以证圣元年下。第二证译也。月旅姑洗者。正当三月。言亲受笔削者。则天躬自刊削。言笔削者。汉书卫青传云。削则削。笔则笔。削谓删去。笔谓增益。有云理书勘受削而注之。良以古人书竹木简。以刀削故序曰。遂得甘露流津下。三感征也。十四日是辛酉。庚申即十三日。壬戍即十五日。前后一日各有感征。谓则天于十三日夜梦。见遍天之内皆降甘露。十四日覃开译经。十五日天降甘雨。覃者。尔雅云。及延也。郭璞注云。谓蔓延相被及也。式开下成上征祥。此二句亦可通上二瑞。皆一味之泽。亦可式开实相成上甘露。不死之药况实相之常住故。一味之泽成上膏雨。一云一雨无异味故。式者用也。序曰。以圣历二年下。第四事毕己亥取于乙未丙申丁酉戊戌己亥首。涉五年缮写方毕。缮者。说文云补也。珠丛云。治故造新。皆谓之缮。序曰。添性海之波澜下。第五赞益。于中二。先明益教理。大波曰澜。玄言曰。廓者张小使大。郑玄注。礼云。疆者界也。说文云。域者封也。谓玄言既加。添足性海。开廓法界矣。后大乘顿教下。二辩益物机。序曰。岂谓后五百岁下。第六庆遇也。于中先庆遇。后发愿。今初。前句约恶时得闻。是一幸也。后一句约恶处得闻。此二幸也。初言后五百者。如来灭后有五五百年。第一五百年解脱坚固等。今当第四五百年。故云后也。在三五之后故。故金刚经中。于后五百岁信受者难得。言俄启珠函之秘者。即智论第六十四云。般若是如意珠。舍利如函箧。舍利之中虽无般若。而为般若所熏故。得一兴供养千反生天。今用此事。则如来如函。华严经是如意珠也。序曰。所冀阐扬沙界下。二发愿。于中二。先雨句横遍沙界。粗相遍也。尘区者。明微细遍。遍微尘中之区域故。后并两曜而长悬下。二句明竖穷长悬永布故。两曜即日月。喻如来根本后得智也。序曰。一窥宝偈下。第六总彰序意。赞理自谦。于中三。先两句正制序由。以披寻玩味庆喜深故。毛诗注云。复谓反复。珠丛云。复谓重审察。即是南容三复白圭。疏中已引二虽则无说无示下。赞理离言要假言显。无说无示。则净名目连章之文。不二之门。即净名不二法门品。亦如疏说。因言而显言者。若无文殊赞默之言。安知无言之为妙。故寂灭之相假以言诠。言大千之义者。即出现品。尘含经卷喻。疏中已引。故大千经卷潜尘无益。聪慧者开便能益物。今假言显义。当开尘示于经卷有成益也。三辄申下。谦己结成。上己略释序竟。其中有与理相应者。随时取舍耳

疏。第十别释文义者。疏文分二。先总科。后释经。前中三。谓标彰。列名。解释

疏。初本部三分者下。解释十重三。初分中分二。先明序正。后流通。有无下。别释流通。于中三。一序昔说。二序昔义。三申今解

疏。此上七解下。二会昔义也。复会前七师融成四句。一即第七师。三即前六师。二四义加。二唯正宗者。意取悟入显理。为正宗故。故河西道郎云。若因初分以得悟。则初分为正。若因后分以得悟。则后分非傍即斯义也

疏。今依具三下。第三申今正解。谓上显义理包含。纵成四句。依文释义三分可依。若无流通。序正安立。若唯有正起尽不明。若约无言如何解释。就疏文四。一立取源由。二所以三者下。辩三之相。三非唯一部下。例成前义。谓会品之文尚须三分。何况一部不立三耶。四虽六解皆通下。辩定流通。于中三。先取正义。次辩前顺违。后结正释

疏。初之一解下。二辩前顺违。出前不取五释所以

疏。令正宗中阙证入者。此即光统以法界品为流通。法界是证入因果众海大问。新众远集。佛自入定。众海顿证。判为流通。已抑经文。况正宗中但有信解行三而无证入

疏。第三但属善财一相者。此即裕公以法界后偈为流通。但是善财五相之中。显因广大相之一半。故非一部流通

疏。后二偈下。但言有云。即刊定记主意用此义。言但结偈中佛德者。以普贤向赞如来。言不能尽。故总结云。刹尘心念可数知。大海中水可饮尽。虚空可量风可系。无能尽说佛功德。若将此结叹佛德。判为流通。则一部之中无菩萨德

疏。十行等末类有此偈者。上以义破。此以文破。彼非经终而有此偈。故今此偈。非是一部用为流通。但当会当品流通意耳。言十行末偈者。偈云。菩萨功德无有边。一切修行皆具足。假使无量无边佛。于无量劫说不尽。何况世间天及人。一切声闻及缘觉。能于无量无边劫。赞叹称扬得究竟。释曰。法界偈末。结佛德无尽。此结十行菩萨之德不可尽耳。而言十行等者。等取十向十地。十向末云。一切众生由可数。三世心量亦可知。如是普贤诸佛子。功德边际无能测。一毛度空可得边。众刹为尘可知数。如是大仙诸佛子。所住行愿无能量。此结回向行愿无尽。十地末云。十方国土碎为尘。可于一念知其数。豪末度空可知量。亿劫说此不可尽。而言此者。明此上十地德无尽耳。是知位位品品德德之末。皆结无尽。故非一部之流通也

疏。经来未尽未必在后者。破第五师言未必者。容许后有但不必定耳。如毗卢遮那品末。或随好品末等。既不必有。故难取定

疏。眷属流通但约义故者。即第六师以约义理。于一佛乘分别说三。根本法轮摄彼眷属故云摄群经为眷属。何必将彼为此流通。此中有序不用彼序。何独用彼为此流通

疏。故依远公。三结归正义

疏。古云此九会中大位问答总有五番者。疏意存四故举古释。以第五无大位问答故。于中二。先叙昔。后古德以善财下。密示今意。意有其二。故但为四。一五无大位问故。二第五属流通故。故云今既判入流通。则前唯四。第四应名依人证入成德分

疏。兼取流通以为五分者。顺于古义。第一分中既摄一部序分。不于正宗之内分为五分。故取流通为第五分。理亦无违。但无大位之问。故疏合为四耳

疏。三以文从义科谓据现文但有其四。四位大问故。就第二分中。有差别平等二义。故分为五周因果

疏。初五位明因。后八相明果者。且依一相。以八相是应现故。故属果摄。若克实而言。成如来力下四门。方是其果。前一百九十六门。皆属因摄。若以八相为果。果有一十九门。余皆属因。言名出世因果者。品名离世间故。言亦名成行因果者。废于位名意在行故

疏。四前后襵叠科者。虽有十重总为二分。从后倒襵节节。除后就前分二故

疏。初位前十信行者。以四十二位明义。十信未成位。但为住因。故仁王詺十住为十信。故取能成信詺所成住故

疏。五前后钩锁科者。即是新意。文中二。初总标。二正释

疏。一第一会为依报因果下。第二正释也。然文有十节。谓一经初五品。二毗卢遮那品。三名号下三品。四问明至住处。有二十三品为一节。五不思议至随好三品为一节。六普贤行品为一节。七如来出现品为一节。八离世间品为一节。九入法界品为一节。初后不重用。但合有八重因果。以第九离世间及第十法界。各自为一重因果。故得为十

疏。五取不思议品下。此一因果。疏文有四。初正明。二解妨。三引证。四结成。初文可知

疏。以不思议等与前为果下。二解妨。谓有问言。差别圆融二义非一。如何前差别果。得为圆融果耶。故通意云。虽不思议等经文是一。所望异故。果别于因。成差别因果。果自圆融。得成圆融之果。言圆融者。以一一德周法界故。三十六门。门门之中。含十句故。所说之相难测量故。品名标为不思议故

疏。然有六义下。三引证。证成不思议等三品。为普贤行之果。普贤行品。是不思议等因

疏。一因果相属科中多先果后因者。五周因果。所信证入二果居先。差别因前。亦先有果。故云多先果也。今亦先果后因。为例同也。而言因果相属科者。即前第三以文从义科也。谓从因果相属之义。科成五故

疏。二四十八后未有证成等者。若不思议至随好。唯属差别果。因果既终。合有现瑞证成。今却无证。普贤行品既唯属出现之因。既未说果。何得有证。明知普贤行竟有证结属前来不思议等故

疏。三普贤品初无别发起者。若不属前此品之初。应合别有发起。既无发起明是属前

疏。四以义等者。果德难思。不可但为差别果故

疏。五前虽有问等者。即第二会初之问。而复问者。欲显不思议下难思。是圆融因果之初故

疏。六第二会初已有三业等者。前若无果。要用不思议等为差别果。前既已有此不思议等全属于后。前段差别因果亦足

疏。由斯六义下第四结也。三通释中

疏。成佛涅槃亦因现故者。此遮外难。恐有难云。离世间品自有因果。那得总为出现家因。故为此通

疏。由离世间下释为出现因义

疏。八离世间等者。当会自成因果。九全合两会为一因果。十以入法界当会自成因果。然第八会虽不钩前。前出现品已曾钩此第十因果不钩第八会。第八会已曾钩第九。故并得名钩锁因果

疏。其善财已下等者。善财历事为因。普贤说佛德为果故

疏。六随品长分科者。不约会分总为直科。三十九品以为十分耳

疏。二现相品下。明佛果无涯大用分者。现相品大用在义可知。普贤三昧言大用者。同加普贤不来而至。一多延促皆无碍故。毛光赞德无不周故。成就华藏。皆说如来遍净法界遍应刹海。令依正相入尘含法界。皆无涯大用也

疏。十善财下善友教证分者。若据标云随其本会科。会各一分。只成九分。欲显圆十故开后一。据实合有十会表圆。或经来未尽。且案文释耳

疏。若开诸龙及三乘会等者。前为百二十分。则诸龙三乘。皆属善财会。以初至福城本为善财故。故不别开诸乘等会。今约虽至福城。城中善财等二千四众尚未出城。先说普照法界修多罗。利益诸龙及三乘人故别乘之。余可知

疏。上来十例各显一理。然亦无尽者。第二正释经文。于中三。初总结前义二依三分。三依四分消经

疏。若依常用下。二依三分略科。于中二。先总科三分。后序中就文分二下。别释二序。于中三。初总科。二结通者。文在第五卷末。彼文有三。初结此界。次结华藏内。后结华藏外。次然此二序下。总指在余。三初证信者。下文分为三。初立序原由。二立序所以。三略释序文。今初。文略言阿难请问等者。智论第二云。佛涅槃时。于拘尸那国娑罗双树间。北首而卧一心欲入涅槃。阿难亲属爱心。未除未离欲心。心没忧海不能自出。尔时长老阿泥楼豆语阿难言。汝是守佛法藏人。不应如凡夫自没忧海。一切有为法是无常相。汝莫忧愁。又佛首付汝法。汝今愁闷失所付事。汝当问佛。佛涅槃后。我等云何行道。一谁当作师。二恶性车匿云何共住。三佛经初首作何等语。四如是种种未来要事应当问佛。阿难闻是事已。心闷小醒得念道力助。于佛末后所卧床边。以是事问佛。佛告阿难。若今现在若我过去。复自依止念处。莫依止余。乃至广说身受心法。以除世间贪爱。又云。从今日后解脱戒律经。是汝大师。如解脱戒经说。身口意业应如是行。又车匿比丘如梵天法治。若心软后应教迦旃延经。即可得道。复次是我三阿僧祇劫所集法宝藏。是藏初首。应作如是说言。如是我闻。一时佛在某方某国土。某处树林中。是我法门初首。应作如是说。何以故。三世诸佛法经首皆称是语。今我经初。亦应称此如是我闻一时佛在等语。故云如智度论

疏。及大悲经说者。案大悲经第五云。佛告阿难。我今以是正法宝藏付嘱于汝。勿令毁灭。阿难白佛言。我今云何修行法眼。乃至复云云何结集法眼。佛告阿难。我灭度后。有诸大德比丘僧众。集法毗尼时。彼诸大德摩诃迦叶最为上首。阿难。彼诸大德诸比丘众。应如是问。世尊何处说大阿波陀那。何处说摩诃尼陀那。乃至云何处说声闻藏缘觉藏菩萨藏。阿难。时诸比丘如是问已。汝应答言。如是我闻。一时佛在摩伽陀国菩提树下。初成正觉。如是我闻。一时佛在伽耶城。如是乃至云。如是我闻。一时佛在拘尸那城力士生地。阿利罗跋提河边。娑罗双树间。乃至云佛说经已。一切大众皆大欢喜顶戴奉行。阿难。汝应如是结集法眼。余可例知。上皆原由。即出其原本事由

疏。若核其所以意有六焉者。第二立序所以也

疏。今废我从闻下。上智论文。此下生公意成上论义

疏。若准佛地论下。第三略释序文。于中二。先引二论开合不同。后然信闻二事下。料拣通局。谓如是我闻。唯经初有而义通九会。为如是法义我皆得闻。时主俱通者。会会之初。皆云尔时世尊等。处众俱局者。摩竭非忉利天等处局。十佛刹菩萨列名异故。新旧菩萨亦不同故

疏。随相则尔等者。一会即一切会。何有众等而不通耶

疏。上来略依三分。下第三用四分科以释文。疏文有二。先总明。后就第一下别释于中二。第一序昔

疏。若以义从文且分为三下。第二辩今。已闻中

疏。如是一部经义等者。疏文有二。先序昔解。二明去取。前中又二。先合释信闻。后离释信闻。前中二。先总明。后如是等言依四义转下。别释其相。一言依譬喻者。如有说言。富贵如毗沙门。如是所传所闻之法。如佛所说。此则以佛所说如毗沙门。我今所传如富贵人。则以佛说为喻也。亦有说言。如是文句如我昔闻。此则以昔闻喻今闻也。故云譬喻。故有释如是云。两法相似谓之如。一法无非谓之是。相似即譬喻耳

疏。二依教诲者。谓如是当听我昔所闻。此即传法者之教诲也。亦有云即佛教诲。谓如是是我佛说。应当谛听。如有人言汝当如是读诵经论

疏。三依问答者。谓众问言。汝当所说昔定闻耶。故此答言。如是我闻

疏。四依许可者。谓结集时诸菩萨众咸共请言。如汝所闻当如是说。传法菩萨便许可言。如是当说。如我所闻如是说言。我当为汝。如是而思。如是而作。如是而说等。又许可者或信可言是事如是。谓如是法。我昔所闻。此事如是。齐此当说。定无有异。由四义故。经初皆置如是我闻。然上总意遍此四义。非别义也

疏。余更有释意不殊前者。刊定记。别开有九意。一以总释为一义。次用上四别。如次成五义。六以许可中第二释云又许可者或信可言为第六意。此是大乘法师。重释第四许可。非别义也。设有异释大同许可。又引功德施论。为第七释云。如是我闻者。显示此经是佛世尊现觉而演非自所作。此亦同佛地总意耳。八引长耳三藏依三宝释。若大乘法师用之乃是离释如是。下文当引。九引梁朝云法师。云如是我闻者。将传所闻之法。先当标举一部。谓如是经教。我于佛所闻者。此亦全同佛地总意。故云更有异释。意不殊前

疏。若离释者下。第二离释信闻。于中有二。先依智论合如是二字通释。是信顺之辞。然论具云。佛法大海信为能入。智为能度。如是者即是净信也。若人心中有清净信。是人能入佛法。若无净信。当知是人不入佛法。不信者言是事不如是。是不信相。信者言是事如是。是信相

疏。故肇公云者。此下肇公释。但是用智论意。非是别理。是以疏言故肇公云也。复有人于肇上加云。信为入法之初基。智为究竟之玄术。信则所言之理顺。顺则师资之道成。由信故所说之法皆可顺从。由顺从故说听二途师资建立。此亦后人傍于智论肇公。复后加言。则虽多亦非异理故

疏。收其异义。立为别释。意同言异并略不存。后人不知重重因循。皆列为异解

疏。有云圣人说法下。此下自狭之宽以释。此第一最局唯取如故。即刘虬洼无量义经释

疏。若云如斯之言。此下即梁武帝释。此约能诠而通诠事理

疏。有云如者当理之言者。通能所诠含于事理。理者道理非唯真如。即生公释法华经

疏。此明说事如事下。此即于生公解释中。傍出远公约法以释。意明生公即远公意。然彼具云。一约法解。阿难道彼如来所说。如于诸法故名为如。说理如理说事如事。说因如因说果如果。如法之言是当道理。故曰如是。良以乖法名为非故。如法之言得称为是。其言虽多但是道理之言耳。故不异生公

疏。融云如是者。感应之端也。谓以如字为佛应。是字为机感故渐宽前。从经以感应下。通妨难。恐有难云如即是应。是即为感。何不名为感应我闻。故为此通。有引此为注法华释者。注是刘公用融公义耳

疏。上来诸释下。第二申今去取。于中二。先且总许。后正申去取。前中言更有诸释。言异意同者。谓长耳三藏。就三宝释云。一就佛。三世诸佛共说不异。故名为如。以同说故称之为是。此大同梁帝。二约法。云诸法实相今古不异。故名为如。如来为说故称为是。此同刘公。圣人说法但为显如。三约僧。释云以阿难闻望佛所教所传不异。故名为如。永离过非故名为是。此同佛地总意。故云言异意同。又宝公约离五谤释云。第一句如是。此经离执有增益谤。故云如是。第二句如是。此经离第二执无损减谤。第三句如是。此经离第三执亦有亦无相违谤。第四句如是。此经离第四执非有非无愚痴谤。第五句如是。此经离第五执非非有非非无戏论谤。此上五谤。当理之言即皆摄尽。又真谛三藏约二谛释。既离有无。则离俱及俱非等。故亦不异前释。故云言异意同。略序数条更有多释。亦言有异意则大同。恐繁不序

疏。若依生物之信下。第二正申去取。于中文二。先总取三义。后以宗拣定。中文并可知。言敌对外道阿优者。百论云。外道立阿优为吉。智论云。梵王昔有七十二字。以训于世教化众生。后时众生福德转薄。梵王因兹吞啖却七十字。在口两角。各留一字。是其阿优。亦云阿呕。梵语轻重耳。余可知

疏。若华严宗下。第二以宗拣定。即约教以释。上通诸教。今先举圆宗。后应随教门下。依五教以释。既如是为当理之言。明于二谛。则小乘人法为俗。生空为真。始教之中四重真俗抗行。终教事理真俗二相交彻。如真谛所解。四顿教则真俗两亡。亡言绝虑方称当理。如无常经。应以生老病死定可厌等。称为当理之言。异此所明不得称是等。余教可知

疏。二我闻者释闻成就等者

疏。文有三。初总明立意。次我即阿难下。略释。后云何称我下。解妨重释。于中有二。先征释我闻。后释所闻。前中先征释我。诸蕴假者通于诸教。后此用何闻下。征闻重释。通于我闻。于中先征。后若依大小乘下。约教别释。于中三。初法相二无相三法性。初法相中含于小乘及与始教。于中二。先王释。后解妨。今初言小乘三者。萨婆多宗自有三义。一法救论师。耳闻非识。谓虽自分识依根方闻。然闻体是根非是于识。如闻既尔。见等亦然。故杂心云。自分眼见色。非彼眼识见。非慧非和合。不见障外色故。二妙音师。识闻非耳根无觉故。三成实师。和合能闻。上三并如俱舍界品。及婆沙第十三说。言大乘三者。一耳闻非识。如杂集第二云。耳界有何相。谓能闻声。瑜伽三十五云。数数于声。作意至能闻故。二识闻非耳。梁摄论云。闻有三义。一闻体谓耳识。二闻资粮谓音声。三闻果谓即闻慧。唯此耳识以为正闻。三和合能闻。佛地论云。闻谓耳根发识领受声尘。瑜伽论云。闻谓听闻即是耳根。发生耳识闻受教故

疏。然或具四缘八缘者。通释大小乘和合闻义。上言和合。但合根识。今取具缘。故云四八。然其四八是生识缘。若取能闻兼所发识。则或五或九故

疏。云等言或四者。即是小乘。一空二根三境四作意。故智论云。尔时耳根不坏。声在可闻处。作意欲闻。情尘意合即耳识生。随耳识生即意识生。方能分别种种因缘。方得闻声。释曰。声在可闻处即空。二即作意情即是根故。中论内詺六根品。为六情品。古云。根含识义目之为情。尘即是境。意即意根加此为五发生耳识。言随耳识生即意识生。即同时意识分别。非是缘也。若约分别声尘。则同时意识。亦是缘也。种种因缘得闻。总结上也。言八缘者。于前四上复加于四。谓一空二根三境四作意。五根本依第八识。六染净依第七识。七分别依第六识。八种子。种子为因缘依诸有为法皆托此依。离此因缘必不生故。分别依者即第六识。染净依者即第七识。根本依者即第八识。根即同境依故。唯识第四云。由此五识俱有所依。定有四种。谓五色根六七八识。随阙一种必不转故。同境分别染净根本所依别故。如有偈云。眼识九缘生。耳识唯从八。鼻舌身三七。后三五三四。若加等无间。于前各加一。释曰。眼九缘者。复加于明。闇中无见故。耳已除明。七更除空。此三合中知故。后三即六七八。六识五缘。更除染净及与分别。分别即所发识。染净即所依根。第七识或三或四。四谓除染净。染净即所发识故。前六识中约为根故除。此第七中约为识故。复除第八。第八即总故。或三者更除于境。境即根故。言三者即第八。但有种子作意及根。或四即更加境。此上诸释因便故来

疏。虽因耳处下。第二解妨。此有二妨。一有问言。现是耳闻。云何言我闻。故为此通。明我为总。总该眼耳等诸根故。即佛地论文。二有问言。一切佛教诠于无我。阿难已是入理圣人。那同凡夫而称我闻。故此通云法虽无我是牒问意。后言语便易下。即是通释。于中先显正。后非邪慢下拣非。此中通是二论之意。谓智论第一有三复次。以释无我说我。一云复次世间法中说我。非第一义中说。以是之故。诸法空无我。世间法故虽说于我。无实体故。二云复次世间语言有三根本。一邪二慢三名字。前二不净。后一是净。一切凡夫具三种语。见道学人具二种语。谓慢名字。诸圣人具一种语。谓名字。内心不计实法。随世间人共传是语。诸佛弟子顺俗故说我无咎。三云复次若人着无我相。诸法是实余皆妄语。是人应难。此一切法实相无我。云何言如是我闻。今诸佛弟子。知一切法空无所有。是中心不着。亦不着诸法实相。何况无我中心有所著。以是义故。不应难言何以说我。释曰。上三复次。一随世间故。三破邪见故。三不着无我故。二者依瑜伽论第六云。略由四义故称我闻。一为世间语便易故。二为随顺世间故。三为断除决定无我怖畏故。四谓宣说自他得失。令生决定信解心故。显扬第九。杂集十三。皆同此说。释曰。此与智论大同。瑜伽第一智论略无易故不出。二即智论第一。三即智论第三。谓着无我。即无我怖者。谓若定无我为谁修学。若不说无我。着即令怖不着。故不说无我。此怖自除。四即第二。谓随世流布。即能令他生决定信解之心。已知二论言异意同故。今疏明含于二论。取其言同。言语便易。即瑜伽第一意。随顺世间。即瑜伽第二智论第一。非邪慢心而有所说。即智论第二意中。所拣二语。然大乘法师傍智论意。立三种我。一妄执我。即此邪我。二者假施设我。谓大涅槃乐净常我。除二乘倒。强施设故。此亦即是智论名字中收。而智论于世间假名。此依出世法假名。三世流布我。正同智论三语之中名字我耳。然此中更有问言。为佛说法而言我闻。为不说法而言我闻。即本质影像之义。已见教体中。故疏不问

疏。若依无相下。第二无相宗含于三教。谓始教顿教实教。谓若但云我既无我闻亦无闻。即大乘初门为始教意。若云能所双寂无闻不闻。亦无我不我。离念顿显即顿教意。其从缘空故。向上成前二教无我所以。二者向下成不坏假名。即不闻之闻。为实教意。谓事理无碍故。闻即不闻无二义故。故智论云。闻者云何闻。用耳根闻耶。用耳识闻耶。用意识闻耶。若耳根闻耳根无觉知。故不应闻。若耳识闻。耳识一念不能分别。故不应闻。若意识闻。意识亦不能闻。何以故。先五识识五尘。然后意识识。意识不能识现在五尘。唯识过去未来五尘。若意识能识现在五尘者。盲聋人亦应识色声。何以故。意识不破故。答曰。非耳根能闻。亦非耳识亦非意识。是闻声事。从多因缘和合故得闻声。不得言一法能闻声。何以故。耳根无觉故不应闻声。识亦无色无对无处。故亦不应闻声。声无觉亦无根。故不能知声。释曰。此上皆明相离不能闻。下云尔时耳根不坏等。即辩和合能闻。已如前法相宗中引。今明和合而闻。闻即无闻。皆实教意。若刘公注法华云。阴入非主为我。听受非情曰闻。深照缘起悟解法空。若斯人也顾命之所因。然后传而无执。物我同致。释曰。此初亦始教意。从深照缘起下。即实教意。然皆属无相宗摄。又言不闻闻者。即涅槃十九。十地品中当引大意。但明事不碍理故不闻。约理不碍事故为闻

疏。若约法性下。第三约法性宗辩而但明圆教中意。言以我无我不二之真我者。含两经意。一者净名云。于我无我而不二。是无我义。二者涅槃云。无我法中有真我。是故敬礼无上尊。正当今意。即口顺世间。心造真境。真自在我

疏。根境非一异之妙耳者。以根与境共为缘起。因根说境因境说根。互相融即故曰非异。两相历然故曰非一。斯为妙耳。何所不闻

疏。然阿难所不闻经下第二释不闻难。谓有问言。阿难是佛得道夜生。年满二十方始出家。年至三十如来方命以为侍者。自三十年前如来所说。阿难不闻。何以经初皆言我闻。故为此答。答有四意。大为两节。前三带权。后一显实。一或云展转闻者。自有数说。一报恩第六云。阿难所不闻经。从诸比丘边闻。或有诸天向阿难说。二依涅槃四十云。我涅槃后。阿难比丘所未闻者。弘广菩萨当广流布。阿难所闻自能宣通。三智论第二云。迦叶阿难于王舍城结集三藏。是时长老大迦叶谓阿难言。佛嘱累汝令持法藏。汝应报佛恩。佛在何处最初说法。佛诸大弟子能守护法藏者。皆已灭度。唯汝一人在。汝今应随佛心怜愍众生故。集佛法藏。是时阿难礼众僧已坐师子床时大迦叶说此偈言

  佛圣师子王　　阿难是佛子
  师子座处坐　　观众无有佛
  如是大德众　　无佛失威神
  如夜无月时　　虚空不清净
  如大智人说　　汝佛子当演
  何处最初说　　今汝当布现

是时长老阿难。一心合掌向佛涅槃方。如是说言。佛初说法时。尔时我不见。如是展转闻。佛在波罗柰。佛为五比丘。初开甘露门。说四圣谛法。苦集灭道谛。阿若憍陈如。最初得见道。及八万诸天。闻是得见道。以是等文明是传闻。故云或展转传闻

疏。或如来重说者。报恩经第六明阿难佛命为侍者。阿难从佛请求三愿。一者不受佛故衣。二者不受佛别请。三者所未闻法更请重说。如来将入涅槃前。更为阿难重说

疏。或得深三昧自然通达者。金刚华经云。阿难得法性觉自在王三昧故。如来前所说经。皆能忆持。与亲闻无异涅槃亦云。阿难多闻士。若在若不在。自然能解了常与无常义。法华得受记竟云。世尊甚希有。令我念过去。无量诸佛法。如今日所闻。我今无复疑。安住于佛道。方便为侍者。护持诸佛法。既云得记竟。方悟亦带方便。据方便为侍者。即密显实矣

疏。上皆就迹而说下。显实。于中上一句是结前。此下正显实义。言如不思议境界经斯良证者。彼经云。尔时复有千亿菩萨现声闻形。亦来会坐。其名曰舍利弗目犍连。乃至云阿难提婆达多跋难陀等。而为上首。皆已久修六波罗蜜。近佛菩提。为化众生于杂染土现声闻形。释曰。是大菩萨方便显本。故为实说。如法华五百弟子品云。诸比丘谛听。佛子所行道。善学方便故。不可得思议。知众乐小法。而畏于大智。是故诸菩萨。作声闻缘觉。即其文也。又阿难章中云。方便为侍者。护持诸佛法。即大权明矣。后去取中

疏。但随机教别者。此亦含多义。一成上诸说。但随机教故。二者即约三种阿难受持三藏。故云随机教别见闻不同。三种阿难。即大乘集法经说玄中。已引金刚仙论。及真谛般若疏。引阇王忏悔经等。并同此说

疏。第二标主时处下。释一时中文二。先唯就一时说。后感应合说。今初。言亦随世假立者。谓佛法中时不可得。中论云。因物故有时。离物何有时。物尚无所有。何况当有时。今随世俗说有一时。智论意同。言拣异余时者。谓趣举一时耳。疏即法王启运嘉会之时者。即肇公语意亦可知。启者开也。嘉者善也。易云。元者善之长也。享者嘉之会也。谓佛开大运演说真乘。即嘉善之会也

疏。亦可机教一时下。二感应合释。即生公意可知

疏。佛者主成就下。疏文有二。先略释。后义见下指广。前中若言菩提但称为觉。若云佛陀此云觉者。然觉有三。一自觉。谓双觉事理。如睡梦觉。如莲华开。此拣凡夫。二者觉他。拣异二乘。三者觉满。拣异菩萨。故云自他觉满之者。若禅观说。亦云离心名自觉。离色名觉他。色心俱离为觉满。以依起信心体离念。名为本觉故。题中总有此义释之

疏。真身无在而无不在故次辩之者。总显大意。言无在者。体相寂寥离能所故。无不在者。体圆遍故。故下经云。譬如虚空遍至一切色非色处。非至非不至。何以故。虚空无身故如来亦尔。遍一切法。遍一切众生。遍一切国土。非至非不至。何以故。如来身无身故。为众生故示现其身。又无在即体。无不在即用。体用无碍故为真身。此亦净名身子答天女意。女身色相无在无不在也

疏。为表所说下。释处所。以表自心中所证。非是随宜故不移证处

疏。第三别明时分中分二。先蹑前生起。谓说法时及成佛时。双标二时。后此教胜下。双释二时。于中二。先明说时。后释成佛。前中三。初释其所以。次初言尚总下。二假问征起此有二征。一征初近远。二征初通局

疏。略为三解下。第三解释。此上总标三义。即为三别。三解之中初之一解征初远近。近在一念。答初通局。局初五会。第二解初在二七之后而通九会。第三解取前师。即一念之初。取后第二师通于九会。就初解中三。初正明时分。二遮伏难三会论文。初中明九会。分为三时。非总初也

疏。以祇园身子皆后时故者。出后时所以。祇园在后者。佛成道后在王舍城。因长者为子娶妻。至于此城。闻佛发心方造精舍。故知在后。身子等在后者。案报恩经初度五人。次度耶舍门徒五十人。次度优楼频螺门徒五百。次度伽耶门人三百。次度那提门人二百。次度鹙子门徒一百。次度目连门徒一百。合有一千二百五十五人。十二游经初成道第一年度五比丘。第二年化迦叶兄弟三人。第五年度身子目连。五人者。一抲邻。二頞湿鞞。亦云马星跋提。三摩诃男。四十力迦叶。五拘利太子。二是母亲。三是父亲。释曰。既身子等在后。今第九会有此等五百。及祇园则在后矣

疏。常恒之说下。第二遮伏难。总有四难。一云华严教旨时处圆融。要历三时。岂通玄趣。故此释云。常恒之说。说无息时。后时不谈。岂名常说。二有难云如来圆音。顿演何要。三节方尽幽微。故此通云。虽能顿演表法浅深故须三节。三有难云。若表三节。三七日中一七一节。足得成表。何要后时。故此答云。三七未有声闻。不得显于不共之教。故须后时。故疏云亦显二乘绝见闻故。四有难云。处历秽土时不相融。岂顺华严圆融之旨。故此答云。正为融于异时及与秽土。即一刹那即是净故。故疏。云虽异处别时亦不相离等

疏。若尔世亲下。第三会论文。言思惟行因缘行者。因谓自所得法。缘谓所化之器。欲将已所证法为众生说。名为行因缘行。故法华经云。我所得智慧。微妙最第一。众生诸根钝。着乐痴所盲。如斯之等类。云何而可度等。是也。彼思不得一乘机。今思即得一乘机为异耳。余文可知

疏。二顺论释可知

疏。三约实圆融。即贤首国师意。于中四。初正释。二应机出现下。立理。谓若机熟不应便为失人。未熟而应虚心有待。二俱失时

疏。祇园身子下。三通妨难。谓有问言。若初成顿说。初成未度身子等众。何处得有五百罗汉。故今答云。九世相收。次有难云。祇园身子等纵许九世相融。一念一时何有重会。前时后时方有重故。故今通云。重会之言。亦犹灯光涉入如点灯盏。似有前后光。无前后而相涉入。今重会义但似灯光。一时之中不妨两会。法则有重。时不重也

疏。故法界放光下。第四引文为证。于中有三。初引法界品文。证是初成。法界品内见坐道场初成正觉。明知法界同初会时。二故此经十地下。引十地经。证无二七故。三故诸经论下。后会诸教时。明二七言非为楷定并随机故。密迹三乘玄中已说。普曜说十二因缘。而三乘俱益。十二因缘通三乘故。三乘既益明通说三

疏。法华过三七日方云说小者。经云。我始坐道场。观树亦经行。于三七日中。思惟如是事等。初欲说一而无一机。次念说权诸佛皆赞。乃至云舍利弗当知。我闻圣师子。深净微妙音。称南无诸佛。复作如是念。我出浊恶世。如诸佛所说。我亦随顺行。思惟是事已。即趣波罗柰。诸法寂灭相。不可以言宣。以方便力故。为五比丘说。是名转法轮。便有涅槃音等

疏。时既不定下。结成随宜

疏。约佛就机下。会于权实。劝令善知

疏。上显时分下。第二释成佛义。于中二。初结前总标。二小乘已下。别明五教。一小乘三十四心者。如婆沙八十二说。俱舍根品云。传说菩萨三十四心便成佛故。言三十四心者。见道一十六心。谓八忍八智离有顶贪有十八念。谓断有顶惑。有九无间九解脱道。如是十八足前十六。成三十四。一切菩萨决定。先于无所有处。已得离贪。方入见道。不复须断下地烦恼。唯断有顶一地之惑。但三十四心一坐成佛

疏。五分法身初圆者。即戒定慧解脱解脱知见。如十藏品。是实非化。拣异大乘

疏。大乘之中下。第二始教

疏。据实即古今情亡下。第三终教。古今情亡即观行意。但当无念为始成故。心无初相。即起信论云。菩萨地尽觉心初起心无初相。以其远离微细念故。得见心性。心即常住名竟究觉。今疏杂其语用

疏。无念而照名之曰正者。若唯无念寂而失照。若但照体照而失寂。并称不正。正在双行

疏。见心常住称之曰觉。即上所引起信论文。得见心性心即常住名究竟觉

疏。始本无二目之为成者。起信云。谓始觉同本觉。无复始本之异。名究竟觉即是成义

疏。约法身下。第四顿教意。言无成无不成者。经云譬如世界有成坏。而其虚空不增减。一切诸佛成菩提。成与不成无差别。既无有成何有不成。又体湛寂故曰无成。不碍随缘故无不成。即成终教意

疏。若依此经下。第五圆教。言以十佛法界之身云者。即成正觉等。十佛义并如前。言念念初初为物而现者。即体之应。应无尽时生感即成。念念机感念念成矣。成既不已故曰初初。一成一切成者。事事无碍故。故出现品云。如来成正觉时。于其身中普见一切众生成正觉。故如来成。即众生成矣。况佛佛平等一切成佛。又于一处成即一切处成。故十地中第十愿云。愿于一切世界成阿耨多罗三藐三菩提。不离一毛端处。于一切毛端处。皆悉示现等。又云。如于此处见佛坐。一切尘中亦如是。佛身无去亦无来。所有国土皆明现等。无成不成义不异前疏。一觉一切觉者。若觉一法一法之中一切具足。无觉者远离觉所觉故。无不觉者。朗鉴在怀亦不存于不觉相故。余可知

大方广佛华严经随疏演义钞卷第十七大方广佛华严经随疏演义钞卷第十八

        唐清凉山大华严寺沙门澄观述

疏。第四别显处严中。文亦有二。一通释前后。二别释器界。前中疏。即如来依正者。别显处。严是依教主。难思是正众。海云集是众。而言辅翼不空者。菩萨即十八圆满中辅翼。圆满不空。即眷属圆满。谓净土中无有四趣。龙鬼等众是佛现有。欲示净土不空故

疏。今初器界下。第二别释器界。文中五。初总科。二然此诸严下。示释仪式。谓各三故。三然或一因下。通妨难。谓有问言。因果圆融。何以就因各别所表。故今释云。实具四句为约所表。故别属因耳。然通别无碍。四然各摄无尽下。总科四事

疏。今初心地十句下。第五释本文。言彻华藏者。以华藏世界。海大莲华地面。金刚所成故。此依本经。若依观佛三昧海经第二。亦异常说而未尽源。彼云尔时菩提场地化以金刚。满八十里其色正白不可具见。此相现时菩萨眉间白毫相光。端洁正直矗然东向。长一丈五尺有十楞现。释曰。既有里数。又言化以故非极说。四因中

疏。或于树中现者。以上别中第四宝树行列故。言或诸严具及地中现者。以是叹地尊胜故。二树严疏长耸等者。谓长耸为高。迥露释显。圆妙释殊胜。故独出为特。然案西域记。长一百尺。即毕钵罗树

疏。表神通等法者。即净行品云。若见华开。当愿众生神通等。法如华开敷

疏。下经云。菩萨妙法树等者。等取下文。云信种慈悲根。智慧以为身。方便为枝干。五度为繁密。定叶神通华。一切智为果。最上力为鸟。垂阴覆三界。释曰。此五十九经所以引者。意明表法。皆有文据。非是臆说

疏。菩提智放教智光者。菩提即是证智。教谓差别之用。乃至言教即教证二道。十地广明

疏。无心成行等者。陶隐居云。云无心而出岫。鸟倦飞以知还。凡举云义虽有多种。多明无心

疏。即明涅槃众圣冥会者。无有一圣不证涅槃。犹如百川皆归大海。故肇公云。恬然而夷。怕然而泰。九流于是乎交归。众圣于是乎冥会矣

疏。染违性净等者。即通外难。谓有问言。涅槃既无不包染净同在其内。何以果用即言出生。居处屋宅不言出生。故今释云。染净之法涅槃实包。净则顺体染则违体。证会涅槃方有大用。故曰出生。染既违净。非此出矣。而体不离故云依现耳

疏。然上充遍等下。上直消经文。此下会成无碍

疏。十种宫殿此应说之者。亦约表法之宫殿耳。亦同上文妙法树矣。即五十四经。经云佛子。菩萨有十种宫殿。何等为十。所谓菩提心是菩萨宫殿。恒不忘失故。十善业道福德智慧是菩萨宫殿。教化欲界众生故。四梵住是(云云)教化色界众生故。生净居天是(云云)一切烦恼不能染故。生无色界是(云云)今诸众生离难处故。生杂染世界是(云云)今诸众生断烦恼故。现处内宫妻子眷属是(云云)成就往昔同行众生故。现居轮王护世释梵是(云云)为调伏自在心众生故。一切菩萨行游戏神通。皆得自在是(云云)善游戏诸禅定解脱三昧智慧故。一切佛所授无上自在。一切智王灌顶记是(云云)住十力庄严作一切法自在故。是为十。若诸菩萨安住其中。则得灌顶一切世间神力自在。释曰。从第三是下。皆有菩萨宫殿之言

疏。空乃高而无上等者。疏有三义。释师子座。今唯约表法释高广妙好。事则可知。下多就表

疏。诸觉诸通者。净名。云觉意净妙华。净行品云。神通等法如华开敷

疏。即菩萨妙法树随化分枝者。释宝树枝果周回间列。菩萨妙法树。即前文所引。前云方便为枝干。今以权实为枝。随树不同分枝差别。随枝有华各各成果。随因有异感果不同。并依无相不离法空之座

疏。一一智中知一切法等者。如一实智知遍法界理。如一权智穷事法界之边。则二智圆明无不知也。言一一法体显一切智者。如于一尘能显实智权智中道智。证智教智无边智门

疏。智论云轮王宝珠等者。即第十二论说。宝有三种。人宝天宝菩萨宝。人宝力少。唯有清净光色。除毒除鬼除闇。亦除饥渴寒热种种苦事。天宝亦大亦胜。常随逐天身可天使今。亦可共语轻而不重。菩萨之宝胜于天宝。兼能有人天宝用。又能令一切众生知死此生彼因缘本末。譬如明镜见其面像

疏。如文殊师利冠中毗楞伽宝者。即文殊般泥洹经说。文殊身如紫金山等。其文殊冠毗楞伽宝之所严饰。有五百种色。一一色中日月星辰诸天龙宫。世间众生所希见事皆于中现是也

疏。用此严座者下。出严所以。言寂照照寂皆莹净照烛者。准璎珞经妙觉方称寂照等觉照寂。今菩萨宝义同照寂。如来宝珠即当寂照

疏。佛境如空故云广大者。即问明品云。如来深境界。其量等虚空。一切众生入。而实无所入

疏。显教皆从法空下。上就事说。此下约表。无有一法不从法界流。无有一法不归于法界。故从座流还周法界。第五教主难思

疏前但云佛下。疏文有二。先彰大意。后文分下。开章。前中二。先蹑前征起。对前二文。一对标主。二对别明时分。后谓具十种深广下。总答。初答前佛。后遍于法界成正觉者。答其成相

疏。今初总辩即菩提身下。疏文有三。初当相以辩。即菩提身总示所属具无尽下释世尊。次座相现时下释尔时。次于一切下牒释余文。于中二解。先当相解。后寄对明。言开悟称觉者。二谛中道理本湛然。妄惑所翳久迷不见。今二障既寂。若云卷长空故名为开。了了分明若晴天廓彻故称为悟。悟即觉悟如睡梦觉。开即开发如莲华开矣

疏。若拣别者下。第二寄对以释。仍含二意。一对凡名觉。对小名正。对因名最。对位极名成。二者对凡名觉。对邪名正。对小名最。对因名成。一时双牒如文思之

疏。但悟我空未知我有等者。谓敌体与菩萨相反。二乘知我空法有。菩萨知法空我有。然二乘所空之我菩萨亦空。谓是我执。若无我法中有真我。菩萨知有二乘不知。若但约二空了我空与菩萨同。不了法空与菩萨异

疏。有厌生死空该涅槃者。此出上空有之过。由谓法有故厌生死。不如菩萨了生死之本空无可厌故。故净名善意菩萨曰。生死涅槃为二。若见生死性。则无生死无缚无解不生不灭。如是解者。是为入不二法门。又宝印子菩萨曰。乐涅槃不乐世间为二。若不乐涅槃不厌世间。则无有二。所以者何。若有缚则有解。若本无缚其谁求解。无缚无解则无乐厌。是为入不二法门。二乘不能如是解故。故厌生死。言空该涅槃者。即涅槃经意。涅槃云空者。所谓生死。不空者谓大涅槃。今二乘谓生死却为不空。以涅槃无余永寂却是于空。故云空该涅槃

疏。颠倒未除者。倒有八种。外道谓世间为常乐我净。为四颠倒。二乘永寂计为涅槃。则无常乐我净为四颠倒。若谓世间无常乐我净。涅槃乃有常乐我净。则名八行皆非颠倒。是则二乘但有无常乐我净之四倒。此约与之。若夺二乘。二乘既不能知涅槃常乐我净。则于无常乐我净亦不如实知以其漫该。如虫食木偶成字故。况不了生死实性即是涅槃。安离八倒。故云颠倒未除岂得称正。余如涅槃四倒品说

疏。设许称正亦未名最者。此对邪名正。对小名最。以上与之。能知我空异乎外道。故得名正。不能双觉二空及不空义。故不名最

疏。菩萨虽正下。亦有二意。初对二乘不名正义。今对菩萨方得名正。有上者。上有佛故。有修者。未绝学故

疏。设位极下。对上二乘得名正义。则菩萨许得最名。但未成故佛方成耳

疏。我佛独能下。第三结归就佛。具有成最正觉四字之义。谓如量如理下。对上所觉境中。以释觉义。如量觉俗。如理觉真。三谛中道亦如理摄。亦是合上二智觉于中道。了了究竟。拣异菩萨。故涅槃云。十住菩萨见不了了。唯佛世尊名为了了。故阇王云。了了见佛性犹如文殊等

疏。已出微细下。释上了了究竟之言。二障有三种。一现行。二种子。三习气。习气种子名为微细。佛已尽故。然二障习气。通障菩提及大涅槃。若就别说。断烦恼障显于涅槃。今成正觉略言所知耳。后别中

疏。一三业普周等者。十中后五。全十身名。前五无有身言而义具之。一即菩提身。前总中已示。二即威势身。三福德身。四意生身。五相好庄严身

疏。今初意业下。疏文有二。先总标。后前云于一切下。别释。于中复二。先略释。后智即二智下。广释。于中亦二。先标能入之智。后二智者下。别明智入之相。即为四段。一释二智。二释三智。三释无障碍智。四释四智。以无障碍智约义即圆故列在后。因三谛成故释居四前

疏。一以如量智达俗等者。然入有二义。一达二证。故以达入俗。以证入真。然二智相者。摄论云。如人初开目。是名加行智。如人正闭目。是无分别智。即彼复开眼。后得智亦尔。应知如虚空。是无分别智。于中现色像。后得智亦尔

疏。如其胜义觉诸法故者。证第二义。上则二智别觉二境。则三世为俗。平等为真。今觉俗即真。是故三世即是平等。胜义是真。诸法是俗。今以真智而觉于俗故。令诸法即真胜义。以其性相非一异故

疏。一真俗互泯双遮辩中者。俗即真故非俗。真即俗故非真。非真非俗即是中道。则三世即平等故非三世。平等即三世故非平等。为两亡也

疏。真俗虽即而不坏相者。谓即有之空方是真空。即空之有方为妙有。空有不二两相历然。如波即水而恒动。水即波而恒湿。故云双照疏。此二觉三谛之境者。结成也。在境为一谛而三谛。在心为一观而三观。在果为一智而三智。如一圆珠。珠相喻有。珠净喻空。圆明喻中。三无前后。此喻一谛而三谛。若以明镜照之。珠上三义一时顿现。即喻一观而三观。若就镜中观珠。珠之与镜非一非异。则喻心境二而不二为真觉也

疏。境既双泯而双现下。第三仍前三智释无障碍智。谓合前二种中道为无障碍。然前三智圆融已为无碍。而未明遮照无碍故。复双融明无障碍。然双泯即前双遮。双现即前双照。若境双泯。则无心于真俗为寂也。若境双现。则心权实双鉴为照。故云智亦寂照而双流。二种中道既无障碍。二种二谛居然相融

疏。谓无障碍智下。结成疏。言四智者下。第四释四智。疏文有三。初总标。二会释经文。三通妨难

疏。通缘三世下。第二会释经文。然四智广义次下。喻中广引论释。今此但取其中同义。言通缘三世者。四智皆缘三世之境。果位八识相应之智皆缘三世。故云并入三世。下释平等。言镜智离分别故依持平等者。论云。此智心品离诸分别。所缘行相微细难知。故云离诸分别。又云。不忘不愚一切境相。性相清净离诸杂染。纯净圆德现种依持。故云依持平等。意云。虽言现行功德之依种子功德之持。由无分别故得平等

疏。平等性智证平等性者。论云。谓此心品观一切法自他有情皆悉平等。大慈悲等恒共相应。随诸众生所乐。示现受用身土影像差别。既云自他有情皆悉平等。即是所观平等故。云证平等性

疏。妙观察智观察平等者。论云。谓此心品善观诸法自相共相无碍而转。摄观无量总持定门。及所发生功德珍宝。能现无边作用差别。皆得自在雨大法雨。断一切疑令诸有情皆获利乐。既云善观诸法自相共相无碍而转。此即明平等能遍观一切诸法。故云观察平等

疏。成所作智普利平等者。论云。谓此心品为欲利乐诸有情故。普于十方示现种种变化三业。此即普利之义。不拣怨亲岂非平等

疏。四智圆融一句摄尽者。叹胜也。下身语皆四智之现者。明此中用四智之意。以观下文佛德。与唯识论释四智同。故云皆是四智之显现。所以总中宜用四智释也

疏。四智圆融无二性故下。第三通妨。谓有难云。四智菩提有为无漏。非我经宗何得参杂释此玄旨。故今通云。四智菩提性相二宗皆具有之。但义小异耳。用之无爽。谓圆融无二是其一义故。彼宗说四不得相杂。今明一智便具四智故。下出现以四宝珠喻其四智。经云。复次佛子。譬如大海有四宝珠具无量德。能生海内一切珍宝。若大海中无此宝珠。乃至一宝亦不可得。何等为四。一名积集宝。二名无尽藏。三名远离炽然。四名具足庄严。佛子。此四宝珠。一切凡夫诸天龙神等悉不得见。何以故。娑竭罗龙王以此宝珠端严。方正置于宫中深密处故。佛子。如来应正等觉大智慧海亦复如是。于中有四大智宝珠。具足无量福智功德。由此能生一切众生声闻独觉学无学位。及诸菩萨智慧之宝。何等为四。所谓无染着巧方便。大智慧宝(一大圆镜智离诸分别名无染着所缘行相微细难知不忘不愚一切境相巧方便故)。善分别有为无为法。大智慧宝(二平等性智观一切法有为无为自他境相名巧方便利他平等名善分别)分别说无量法而不坏法性。大智慧宝(三妙观察智此智善观察诸法自相共相无碍而转故说无量法而不坏法性无量法者即摄观无尽总持定门而言说者雨大法雨断一切疑)知时非时未曾误失。大智慧宝(四成所作智知机知时作所应作故若诸如来大智海中无此四宝有一众生得入大乘终无是处此曰智宝薄福众生所不能见何以故置于如来深密藏故)其一一智。皆云平均正直端洁妙好。即具四智之德故。况同一性居然融通。言修生本有非一异故者。第二意不同彼宗。彼宗四智修生涅槃本有。今即四智是本觉智。修生之四非别有体。如金成像金像不殊故

疏。然上能觉下。第三总结。所以结者。欲明一菩提身已具法报二身。况具下九

疏。二其身下身业等者。疏文有二。先总明。后法身普周下。别释。于中二。先随相各别遍。二圆融总摄遍。今初。且寄三身以明下。明摄十以为三故。今明法身本体遍。智身修成如体而遍。色身即体之用遍。法身如虚空遍。智身如日光遍。色身如日影遍

疏。并是圆遍下。别示遍相。三身皆如下说。故云并是。言并是圆遍者。若大若小皆圆满故。非分遍者。非是分析散布令遍。谓一切下示圆遍相。纤尘亦圆粗则可了。总看亦现者。遍法界内唯是一佛。佛身充满于法界故。言别看亦现者。则向一一国土一一尘中。皆见全身。故下经云。如于此处见佛坐。一切尘中亦如是。佛身无去亦无来。所有国土皆明现。是也。又总别看者。总则一身处处皆有。别则支分眼耳鼻等各遍法界。故现相品云。佛眼云何无有量。耳鼻舌身亦复然等

疏。又国土等即是我身下。二圆融总摄遍。谓前明能遍三身非所遍土。今明能遍即是所遍。能所互融故。又明一一身相融和杂遍故。又上约佛身上十身。谓菩提愿化力庄严等。今明三世间无碍之十身。谓国土众生等故。十身相作于何不融。故云犹如灯光。经云。譬如冥室百千灯。一一灯光遍室内。诸佛身智亦复然

疏。譬如下喻显下。疏文中二。先总明大意。后开章别释。今初。言佛三业非喻能喻者。八十卷末云。三界有无一切法。不能与佛为譬喻。譬如山林鸟兽等。无有依空而住者。虚空真如及实际。涅槃法性寂灭等。唯有如是真实法。可以显示于如来。即其文也。又佛地论第四云。如契经言。乃至所有施设譬喻。喻诸如来所有功德。一切皆是谤诸如来。唯除一喻。所谓虚空。可喻如来。戒等无量功德同虚空故

疏。然虚空为喻有同不同等者。上两句标。下释二相。先释不同。即第五回向之文。此明佛有自利之德。不同虚空不能自利。而言等者。等取次下经文。云于一切处令诸众生积集善根悉充足故。此明如来有利他之德不同虚空

疏。今分取同下。二释同义。但是分同。言同义多种如下十忍品者。即第十如空忍经云。佛子。此菩萨摩诃萨了一切法界犹如虚空。以无相故。一切世界犹如虚空。以无起故。一切法犹如虚空。以无二故。一切众生行犹如虚空。无所行故。一切佛犹如虚空。无分别故。一切佛力犹如虚空。无差别故。一切禅定犹如虚空。三际平等故。所说一切法犹如虚空。不可言说故。一切佛身犹如虚空。无著无碍故。释曰。上所引文。若取总通。无相无起等。皆是虚空多义。若取别相。唯取无分别无差别无著无碍。以喻于佛佛力佛身故。又彼忍下文云。譬如虚空一切法依不生不没。又云不可破坏。又云一切世间之所依止。而无所依。又云无生无灭。能持一切世间生灭。又云无方无隅。而能显现一切方隅。又云非行非住。而能示现种种威仪。又云非色非非色。而能示现种种诸色。又云非久非近。而能久住现一切物。又云非净非秽不离净秽。又云一切世间皆现其前。非现一切世间之前。又云普入一切而无边际等。皆喻菩提经具有合。今略不引。例喻于佛亦具上诸义。以十忍位是等觉故。故可同佛。疏今有二喻下。第二开章别释。于中有三。一总显喻相。二喻其所喻。三结示有归。今初可知

疏。以此四喻喻意业下。喻其所喻。别喻三业。即为三段。古人唯将前喻。喻于意业。后喻身语。普遍喻身。随入喻语。今并喻三业。但引文证居然可知。今初喻意业。中文分为二。初引经总释。后随相别明。今初。言佛智广大同虚空者。通于二智四智。然下三句云。普遍一切众生心。悉了世间诸妄想。不起种种异分别。了世妄想即是量智。不起分别即是理智。而今但取广大同空。则二四皆广。故云总也

疏。量智包含而普遍下。第二随相别明。于中二。先喻二智。后喻四智。前中取前喻中包含之义。及后喻中普遍之义。以斯二义并喻量智。量智知差别故似包含义。无法不知是普遍义。言理智无分别而证入者。取前喻无分别义。后喻平等随入义。总取二义以喻理智。理智即无分别智。方能证入真如故

疏。又大圆镜智下。第二以喻喻四智。于中二。先以初喻。喻于圆镜及平等智。后以后喻。喻后二智。前中复二。先别释喻相。后总结喻意。前中复二。先喻镜智。后喻平等。前中又二。先引唯识。证包含义。后引当经。双证二义。今初唯识第十云。一大圆镜智相应心品。谓此心品离诸分别。所缘行相微细难知。不忘不愚一切境相。性相清净离诸杂染。纯净圆德现种依持。能现能生身土智影。无间无断穷未来际。如大圆镜现众色像。释曰。纯者无杂。净者离染。圆者满义。现种依持者。现行功德之依。种子功德之持。能现能生身土三智之影。余文可知

疏。下经云菩提智普现下。第二引当经双证二义。一经云。譬如大海普能印现四天下中一切众生色身形像。是故共说以为大海。诸佛菩提亦复如是。普现下同疏

疏。无所现言无有分别者。上现心欲等。即证含摄义。今证无分别义。然唯识镜智。亦有无分别义。前疏总中已引用故。故今略之。然无所现有其二义。一所现即空。二无心而现。今取后义

疏。平等性智等者。疏文亦二。先引唯识。后引当经。今初。论云。二平等性智相应心品。谓此心品观一切法。自他有情皆悉平等。大慈悲等恒共相应。随诸有情所乐。示现受用身土形像差别。妙观察智不共所依。无住涅槃之所建立。一味相续穷未来际。释曰。由昔因中执有我故。自他差别。今我执既无故皆平等。随十地有情所乐。中无住涅槃所立。此识恒共悲智相应一味无漏

疏。亦无分别者。然唯识论平等智中。无有无分别言。今言亦无分别乃有二意。一依唯识。四智通缘真如境。故是无分别。二者约境无差。名无分别。今初论云。大圆镜智缘真如故。是无分别。缘余境故后得智摄。其体是一随用分二。了俗由证真故说为后得。余三分二。准此应知。释曰。准此论文四智各通二智。并通缘真俗。今且约于增胜。而说增胜二喻。各配二智

疏。无分别言显无差别者。即此第二意。然所观二境无分别故。能观之智亦无分别。故无分别言显无差别。此显平等性智无分别义与镜智不同。镜智无分别。若明镜之无心。平等性智无分别。如日合空空无异相。名无差别。谓不分别差别相故。故摄论第八云。应知一切法本性无分别。所分别无故。能分别亦无

疏。故下经云。于一切义无所观察等者。二引当经。即出现品菩提相中。经云佛子。如来成正觉时。于一切义无所观察。而言等者。等取余经。云于法平等无有疑惑。无二无相无行无止无量无际。远离二边住于中道。出过一切文字言说。释曰。无所观察证大圆镜无分别义。于法平等下证平等性无分别义。余义兼具

疏。是以太虚下。第二总结喻意。在文可了

疏。二普遍喻下。第二以第二喻。喻妙观察及成所作智。疏文有四。一引唯识。二引当经。三结成喻意。四总结难思。今初。言妙观察者。论云。三妙观察智相应心品。谓此心品善观诸法自相共相。无碍而转。摄观无量总持定门。及所发生功德珍宝。于大众会能现无边作用差别。皆得自在雨大法雨断一切疑。令诸有情皆获利乐。释曰。神用无方称之曰妙。缘自共相。名为观察。自即色心等别。共即同无常等。又摄论云。圆成实性为共相。依他起性为自相。言摄观者。摄即藏义。观即观察。六度道品为功德宝。诸神通等为作用差别。既观有情自相共相等。明无不遍知也

疏。成所作智曲成无遗。即随入义者。论云。四成所作智相应心品。谓此心品为欲利乐诸有情故。普于十方示现种种变化三业。成本愿力所应作事。释曰。既云种种三业。成所作事岂非委曲。成就于物无所遗漏。此言即周易系辞云。范围天地之化而不过。曲成万物而不遗。注云。范围者。拟范天地而周备其理也。曲成者。乘变以应物。不系一方者也。则物宜得所矣。此说易之德。今借况佛之德耳。唯识结云。如是四智相应心品。虽各定有二十二法。能变所变种现俱生。而智用增以智名显。故此四品。总摄佛地一切有为功德皆尽。会二宗义已如上说

疏。下经云佛智广大下。第二引当经释。于中二。先释普遍。后释随入。前中有四种遍。一约智体遍。二约智用遍。此二即第八十经。已如前引。三约契证通。心与境冥。即出现品菩提章文。四约理遍者。即义引起信论云。问曰。若诸佛法身离于色相者。云何能现色相。答即此法身是色体故能现于色。所谓从本已来色心不二。以色性即智性故。色体无形说名智身。以智性即色性故。说名法身遍一切处。所现之色无有分齐。随心能示十方世界无量菩萨无量报身无量庄严各各差别。皆无分齐而不相妨。此非心识分别能知。以真如自在用义故。释曰。此文亦可证下身遍。今但取其二性不异之义。以明智性之遍。上言智体以智为体。今是理性与前悬隔

疏。云何遍入下。二释随入之言。今先正释。言不坏能所者。由前普遍之言。有其二义。一有能所遍。谓约体遍。众生却是智中物故。二无能所。若约理遍。所遍全是能遍体故。则能所不二故。今此义不坏能所。所证能证二相容差

疏。故下经下引证。即问明品。佛境甚深中答佛境入文。然彼中意入有二义。一者色身入。二者智身入。今取智入。身入可见。智入唯智。智能知故。故云非彼所能见

疏。由随于如下释平等。入言此乃义。引净名目连章云。法随于如无所随故。谓若有所随。所随则在能随之外。能随之法乃在所随。如外所随之如。不遍能随。由无所随当体如矣。若约观行。随如之心不生真顺如矣。下问明亦云。如来深境界。其量等虚空。一切众生入。而实无所入。即其义也

疏。是以虚空遍入国土下。第三结成喻意。于中先结喻。后法合。前中先结遍入。后虚空之于国土下。结平等随入义

疏。虚空可喻佛智下。二法合。于中复二。先合遍入。后合随入。今初。言三世有处。佛智必在其中者。佛智通达染净无碍。一念普观无量劫故。则知佛智无不遍知。如来定慧无边际故。前观无始。后无终故。言佛智知处三世或无其体者。谓真如实际涅槃法性。是佛智证。彼无三世故

疏。佛智之于三世下。二释随入之言可知

疏。此犹约不二而二说等者。第四总结难思也。于中三。初就随入义结。次例普遍。后总结二喻。今初。由上随入之言。约不坏能所。故云不二而二说耳。则喻中虚空为能入。国土为所入。法中佛智为能入。三世为所入。所入不得为能入。今皆互相入。则国土亦入虚空。三世亦入佛智。故云举一全收。疏普遍亦然者。二例普遍也。上但佛智遍三世。今三世亦遍佛智也

疏。三世间圆融等者。兼结上来包含之义及无分别。皆悉圆融故云不可思议。疏故名下。总结二喻

疏。次以二喻喻身业。即第二段亦具四义。初义引经文举况。以释含摄之义。故云一毛尚容法界全分必含众像。世界成就品云。一毛孔内难思刹。等微尘数种种住。一一皆有遍照尊。在众会中宣妙法。出现品云。如人持尺量虚空。复有随行计其数。虚空边际乍可得。佛一毛孔无涯限。次下文云。一一毛端悉能含受一切世界而无障碍。皆即一毛含法界义也

疏。出现身业第二下。引此一喻。证前含摄兼无分别。但合文未具。具云如来身亦复如是。以智光明普照明故。令一切众生世出世间诸善根业皆得成就。而如来身无有分别亦无戏论。何以故。从本已来一切执着一切戏论。皆永断故。对文可知

疏。佛身充满于法界者。即现相品。下三句云。普现一切众生前随缘赴感靡不周。而恒处此菩提座。此四句皆普遍义。今但用初句足已为证

疏。又云譬如虚空遍至一切等者。引此一文亦证二义。诸普遍随入二喻。喻中次释经云。何以故。虚空无身故。合中略引。具云如来身亦复如是。遍一切处。遍一切众生。遍一切国土。非至非不至。何以故。如来身无身故。为众生故示现其身。今但略引足证遍义。亦非至非不至。是平等随入者。谓无身故非至非至。即平等非不至。即不碍至是随入义

疏。次以四义喻语业等者。即第三段如次证四义。言如来于一语言中。具一切语言故者。即证含摄义。亦是义引。即出现语业中。第四善口天女喻合云。当知如来亦复如是。于一音中出无量声。随诸众生心乐差别。皆悉遍至悉令得解。释曰。据其末句。可证遍至。今但取前。即含摄义。又妙严品云。如来于一语言中。演说无边契经海。亦即含摄义也

疏。舍支天鼓无心出故者。即证第二无分别义。此有二喻。一舍支者。即十忍品如响忍云。如帝释夫人阿修罗女。名曰舍支。于一音中出百千种音。亦不心念令如是出。菩萨摩诃萨亦复如是。入无分别界成就善巧随类之音。于无边世界中恒转法轮。天鼓即出现语业第三。天鼓觉悟喻。结云佛子。彼天鼓音无主无作无起无灭。而能利益无量众生。下法合竟结云。而如来音不住方所无有言说。即无心出义。又如随好品天鼓为诸地狱天子说法云。诸天子。如我说我而不着我不着我所。一切诸佛亦复如是。自说是佛。不着于我不着我所。即无心义故。诸论皆云。佛身如摩尼珠无心现色。佛口如天鼓无心出声。皆无分别义

疏。如来音声无不至故。亦出现语业第一相云。应知如来音声遍至普遍无量诸音声故。此证第三普遍义

疏。应知如来音声无断绝普入法界故。此全证平等随入之义。以普入故法界平等故

疏。又云如来音声无邪曲下。引于二文。别证平等随入二义。彼文具云。应知如来音声无邪曲。法界所生故。言随其信解令欢喜者。具云应知如来音声。随其心乐皆令欢喜。说法明了故。上来四文皆出现语业

疏。以空下喻下。第三结示有归谓既明文具有故。应不可唯以初喻喻意业。及将后喻喻身语也

疏。第二身恒下。此段疏文有三。初标章。二谓随诸下。引论总释。后言一切道场下。牒文别释二中即唯识论平等性智之用以四身明义。此当他受用身故。虽语于土。意正取身。唯识第十云。一他受用身。谓诸如来由平等智。示现微妙净功德身。居纯净土为住十地诸菩萨众。现大神通转正法轮。决众疑网令彼受用广大法乐。释曰。彼唯据净土。今十身圆融染净交彻。与彼小异耳。疏言一切道场下。牒经别释。上就别义配受用身。为顺法相。此中据实故说十身皆坐道场。而言此四义便故来者。为顺十身别故。若将十身配十道场。初二可知。三即福德身愿身相好庄严身。以福德云三世所行众福大海。是万行故。愿是众行之本。以行填愿方能遍周故。相好庄严由行成故。故十佛中名业报佛。由万行事业报得相好故。如云不可思议大劫海供养一切诸如来。普以功德施群生。是故端严最无比等。皆约因成相好也。然法门之言。是天台依智论立名。即功德法身。四幻化身。即化身意生身及力持身。此三皆属化身摄故。菩提身为总。亦此化身摄。此四具九。兼后威势则十身具矣。上约别说。既十身圆融。随举一身即十身具故。坐一道场即坐十类。今就相显。故说不同耳。已知十身所坐之处。次当别释遍坐之义

疏。智身遍坐法性道场者。法性是所证。以能证智安处理故

疏。法身非坐而坐道场者。法身既无能所。故曰非坐。非坐之坐湛然安住。名坐道场

疏。三法门身等者。即净名经光严童子章云。佛告光严童子。汝行诣维摩诘问疾。光严白佛言。世尊。我不堪任诣彼问疾。所以者何。忆念我昔出毗耶离大城。时维摩诘方入城。我即为作礼而问言。居士从何所来。答我言。吾从道场来。我问道场者何所是。答曰。直心是道场。无虚假故。发行是道场。能办事故。深心是道场。增益功德故。菩提心是道场。无错谬故。布施是道场。不望报故。持戒是道场。得愿具故。忍辱是道场。于诸众生心无碍故。精进是道场。不懈退故。禅定是道场。心调柔故。智慧是道场。现见诸法故。广说乃至云。一念知一切法是道场。成就一切智故。如是善男子。菩萨若应诸波罗蜜教化众生。诸有所作举足下足。当知皆从道场来住于佛法矣。释曰。光严谓事道场故。问道场何者是。净名以法表示故。万行为得道之处即是道场。故曰法门身坐万行道场耳

疏。四幻化身安坐水月道场者。涅槃云。吾今此身是幻身矣。则所得道之处。如水中月。故昔人云。修习空华万行。安坐水月道场。降伏镜像天魔。证成梦中佛果。意云。若因若果皆从缘生。如幻梦故。二引疏若正约威势下。别辩十身之一。坐六类道场。但自狭之宽。威势既通变化他受用身故。约诸刹渐宽周遍法界。乃至重重

疏。言如名号品等说者。等取四圣谛。光明觉品。及升忉利天宫品。谓遍法界虚空界。皆有百亿四天下等。一类相似佛皆遍故。已如前引其名号四谛。皆先列百亿。后结周遍。皆有百亿十千名等。故知皆是同类界也。下之五类至下当见

疏。菩萨众中等者。即以此文显是威势身也。映蔽菩萨。疏映山出没等者。谓映山出没如化身坐道场。无隐显者。即法身坐道场。处处全现下。即报身坐道场。以即应即真故。随处即全皆无异体

疏。大明流空下。正释威势。大明即日。余辉谓星月等。日喻如来。月喻菩萨。星等以喻余众生。正取映夺。是威势义。兼菩萨不测。亦威势义。言赫日之照难究其涯者。即夜摩会胜林菩萨偈云。譬如孟夏月。空净无云翳。赫日场光辉。十方靡不充。其光无限量。无有能测知。有目斯尚然。何况盲冥者。诸佛亦如是。功德无边际。不可思议劫。莫能分别知可见

疏。既云照世下通妨。谓有问言。既十身圆融则普应一切。何为唯处菩萨众耶。故义取喻中如日轮出之言。则无所不益。故云终益生盲及照高山。皆是出现品。并如前引。疏今三际已断者。此下释清净义。若有三世相福非清净。称法界修故无三际。谓不从前际来。非向后际去。不于现在住。法身已净为断三际。福岂可量。万行之上垢习斯亡。故云清净。谓恒沙等烦恼皆已尽故

疏。第四而恒下随意受生者。即意生身。然意生有二义。一者是喻。犹如意去速疾无碍故。二者是法。自有二义。一随自意。二随他意。总谓随意速疾而成故。余义至回向品辩

疏。谓慈悲般若恒共相应等者。此即唯识平等性智之用此下配属于化身。略举一相。实则此身亦通他受用。随十地菩萨意所生故。又悲智相导通化用故。化身即是无住涅槃之大用故。疏感而遂通者。即周易系辞云。夫易无思也。无为也。寂然不动感而遂通天下之故。非天下之至神。其孰能与于此。注曰。至神者。寂然而无不应。斯盖功用之母象数之。所由生。意明亡象方能制象。遗数方能极数。非动方能应动。彼取易之虚无。无动故能无不动。今借此言。以况如来内体圆寂外应群生。蹑上众福已净之体寂。便言而恒示生。故云寂然不动感而遂通。即法身无生。无所不生耳

疏。即愿身演法等者。此文有三。一标示。谓雨大法雨断一切疑。即引唯识妙观察智之文。释成此义。二故下经云引文证成。疏三然经二句下。牒经委释。三中总有五意。一云喻法身。雨喻说法。法喻影略者。然出现语业第十。娑竭罗龙王降雨喻中。广说诸处云色不同。雨亦各别。合中云。佛子。如来应正等觉无上法王。亦复如是。欲以正法教化众生。先布身云弥覆法界。随其所欲为现不同。所谓或为众生现意生身云。或为众生现化身云。或现力持身云。色身云。相好身云。福德身云。智慧身云。诸力不可坏身云。无畏身云。法界身云。皆有或为众生现言。次复云此相现已。一切众生身之与心皆得清凉。然后从如来大法身云。大慈悲云。大不思议云。雨不思议广大法雨。令一切众生身心清净。所谓为坐菩提场菩萨。雨大法雨。名法界无差别等。故知云为现身。雨为说法。言法喻影略者。法中但有法说。喻中但有兴云故。若具应云广现化身演一切法。如布大云雨大法雨

疏。又先兴慈云后注法雨者。亦即上出现所引之文

疏。一云一雨所润不同者。即法华药草喻品云。一云所雨称其种性而得生长。华果敷实虽一地所生一雨所润。而诸草木各有差别。喻也。合云迦叶当知。如来亦复如是。出现于世如大云起。以大音声普遍世界天人阿修罗。如彼大云普覆三千大千世界。释曰。上即合云。次云。如来于时观是众生诸根利钝精进懈怠。随其所堪而为说法种种无量。皆令欢喜快得善利。释曰。上即合雨。何以知是一耶。次云。如来知是一相一味之法。所谓解脱相离相灭相。究竟至于一切种智。即一云一雨之义也。偈云。其云所出。一味之水。草木丛林。随分受润亦一云一雨所润不同下云。为大众说甘露净法。其法一味解脱涅槃。以一妙音演畅斯义。乃至云正见邪见利根钝根。等雨法雨而无懈倦。一切众生闻我法者。随力所受住于诸地。或处人天转轮圣王释梵诸王。是小药草等。皆一云一雨所润不同也

疏。亦随物机宜云雨各异者。亦出现意。上引法华云雨则一所润不同。喻佛身说法曾无有差异。在于物。今明佛能具异。谓现十种差别身云降十法雨。如娑竭罗龙王兴云。或现阎浮檀金光明色。或毗琉璃光明色。或白银光明色。或玻璃光明色等。即云不同也。次云。所谓于大海中雨清净水。名无断绝。于他化自在天雨箫笛等种种乐音。名为美妙等。即雨不同也。故云云雨各异

疏。掩尘蔽日普覆无心者。即十地经。及法华意。法云地云。佛子。此地菩萨以自愿力。起大悲云震大法雷。通明无畏以为电光。福德智慧而为密云。现种种身周旅往返。于一念顷普遍十方百千亿那由他世界微尘数国土。演说大法摧伏魔怨。复过此数于无量百千亿那由他世界微尘数国土。随诸众生心之所乐。霔甘露雨灭除一切众惑尘焰。是故此地名为法云。释曰。此即掩尘及普覆义。无心之义乃是通说。即出现云。复次佛子。譬如海中有大龙王名大庄严。于大海中降雨之时。或降十种庄严雨。或百或千或百千种庄严雨。佛子。水无分别。但以龙王不思议力令其庄严。乃至百千无量差别。如来应正等觉亦复如是。为诸众生说法之时。或以十种差别音说。或百或千或以百千或以八万四千音声。说八万四千种行。乃至或以无量百千亿那由他音声各别说法。令其闻者皆生欢喜。如来音声无所分别。但以诸佛甚深法界圆满清净。能随众生根之所宜。出种种言音皆令欢喜等。即无心义。即娑竭兴云喻中亦云。虽彼龙王其心平等无有彼此。但以众生善根异故而有差别。亦是无心之义。法华亦云。我无贪着亦无限碍。又云等雨法雨而无懈倦。皆无心义

疏。谓于大众会下。即引唯识妙观察智之用。释成化身

疏。先明广容者。然法界如空有二义。一广容。二普遍。今一尘如法界之包含故。即是广容

疏。以广容不碍普遍下。出毛内调生所以。谓广容。则收法界入于一毛。普遍则展一毛遍于法界。今毛正容无边刹时。即普遍故。便遍所容刹内

疏。若广遍十方示现下。二举况以释。谓尚遍毛内何况外耶。疏文即是成所作智之妙用也

疏。法身弥纶者。标章。弥纶即周遍包罗之义。以法为身等者。先明法性法身遍无来往。后依法现色下。约应化法身明无来往所以。用此释者。由下以三身收之。以此属化身故

疏。力持等者。疏文有二。先正。释力持此经分二

疏。上约十身下。第二以三身收束也。于中五。一正以三身四身收之。二出收所以。三拣权实。四融国土等身。五结叹难思。今初。然则十身望三有通有局。菩提为总。亦是化身。余九身中愿化力持。此唯化身。意生威势通他受用及与变化。福智相好通于二报及变化身。法局法性。今且取顺次故为此配。所以前菩提身复明真身。向来法身复明色身。欲顺今次第配故耳。二中疏。以诸教中三身等者。二出收所以。谓有问言。何用更以三身收束十身。故今释云。以诸教三四迢然不同。今明圆融一身具三。则权实有别。言三身成异者。法身无成。但出障为成。报身四智创圆为成。化身八相菩提树下为成。三身说异者。法身无说。报身佛佛相见亦无有说。化身有说。若摄末归本应化非真佛。亦非说法者。即报身说。报同所证是法身说。言四身成说异者。于报身中开自他受用。自受用遍法界成。则无所说。他受用为十地成。为十地说。若依楞伽。四佛皆说而说不同。言四佛者。一化佛。二报生佛。三如如佛。四智慧佛。初化次报后二皆法。如如及如如智为法身佛。亦可智亦是报。自受用故。言说异者。化身说施戒等因缘法。报佛说三性法。谓为地上菩萨。说令成佛故。法佛唯说离心自性。则以无念会于法界。是故法佛唯说法性。智佛说者。依净法界了相智觉。如说而解故名为说

疏。十身为正下。三拣权实

疏。又毛内调生下。第四融国土等十身。毛内调生。则有众生身声闻身缘觉身菩萨身及业报身。光中持刹是国土身。如空普遍是虚空身。上菩萨众中亦菩萨身。如来居然可见。言三世间圆融岂报化之云别者。十身中众生业报。即众生世间。国土虚空。即器世间。余是智正觉世间。此三情非情异。染非染异。尚得为一。岂一如来身上。而分报化之殊。明知权说隔历难可比此圆融

大方广佛华严经随疏演义钞卷第十八大方广佛华严经随疏演义钞卷第十九

        唐清凉山大华严寺沙门澄观述

疏。是知略以下。第五结叹难思。可知。第六众海云集中

疏。一为影响为主伴故者。此集意中十意。皆闇取下经。此初意引。即诸大菩萨及下。证法如来皆互为主伴。若影之随形响之应声故

疏。二为作辅翼等者。亦是义引

疏。三为守护等者。经云。皆于往昔无量劫中。恒发大愿。愿常亲近供养诸佛。又下经云。一切诸佛化形所在。皆随化往一切如来所住之处。常勤守护

疏。常为严净佛宫殿故者。此即主城神德下经云。皆于无量不思议劫。严净如来所居宫殿。所以标道场神。及释却引主城神者。此中等字。等城神故。然道场神合严道场。以道场神所叹德中。但云皆于过去值无量佛。成就愿力广兴供养。释曰。由无严饰之文故。等取城神之文耳。五为供养等者。以义繁重重故。总相引。偈赞下妙严品。其华幢等。即第二十二经升兜率天宫品

疏。六为发起即解脱月等。七亦总引八九十并显可知。疏第二集因亦十等者。因谓因由。疏一曾与毗卢等者。即菩萨德中。云。此诸菩萨往昔皆与毗卢遮那如来。共集善根修菩萨行。二蒙佛四摄曾摄受者。即第二经初。总叹众集文云。如是皆以毗卢遮那如来往昔之时。于劫海中修菩萨行。以四摄事而曾摄受。三即义引入法界品。诸声闻等往在生死不曾闻此故不见闻。反显菩萨昔曾闻故。四即夜叉王德云。皆勤守护一切众生。此亦义引。如海云言发哀愍心有怖畏者。咸守护故等。即其文也。五即身众神德文云。皆于往昔成就大愿。供养承事一切诸佛。六即是足行神德文云。皆于过去无量劫中。亲近如来随逐不舍不舍即无厌足。七即乾闼婆王德文云。皆于大法深生信解。欢喜爱重勤修不倦。八即主风神德文云。皆勤散灭我慢之心。亦阿修罗德文云。悉已精勤摧伏我慢及诸烦恼。九即菩萨德文云。一切如来功德大海咸入其身。一切诸佛所在国土皆随愿往。亦通就义说。具二严者。方能周遍至诸佛所。十亦菩萨德文云。皆从如来善根海生

疏。中有集因亦通集意者。谓即五六七八。五约往愿。承愿而来。即是集意由愿得来。即是集因。六约随逐。心乐随逐即是集意。由乐随逐故得来集。即是集因。七约乐闻大法而来。即是集意。由乐得来即是集因。八约散我。为叹散我。即是集意。由散我故方得在会。即是集因。初四后二但是其因由。同集善等故得在道场。但为集因非为别来。为同集善等故非集意

疏。及随诸众各有别因者。即下经文。随名叹德。然上所引即是其文。然经随便宜叹德不同。如风神云散灭我慢之心。语其大意。总此十因遍通多众故。此别说随众别因

疏。第四定数者。疏文分三。初随相别明。次然此诸众下会释。后此犹约相别下融通

疏。第五权实等者。疏文分二。先通辩权实。后对前十类下。对前别辩。云互为主伴非权非实者。然权实有其二类。一本高迹下。如佛为菩萨。二本下迹高。如菩萨为佛。今既是佛则非迹下实是如来。又非本下则是实非权。既无权可对故。亦非实同果海故。疏昔为释迦等者。此有二经。一即放钵经。但云昔为释迦之师。二正是菩萨处胎经。第四经云。计我成佛身。此刹为最小。座中有疑故。于胎现变化。我身如微尘。今在他国土。三十二相明。在在无不现昔为能仁师。今为佛弟子。佛道极广大。清净无增减。我欲现佛身。二尊不并立此界现受教。我刹见佛身。下取意引。佛刹名无碍。佛名升仙尊。结云我身濡首是。又云。刹土名究竟。佛名大智慧。亦结属已云我身濡首是

疏。当机唯实者。上至等觉下至地前。俱有听义。并皆称实。余八通权实。可以意得

疏。将此对前权实等者。此第八门疏文分二。先正明。此下对前料拣。初对第五门料拣。若对前十类。即对第三门料拣

疏。第七前后等者。谓约列众。余经或从胜。先列菩萨。后列声闻。或从微至着。或先列声闻。后列菩萨。今此众海何者为先

疏。文分三。一正明。二解妨。三结成表法。今初。列与赞德前后不同。然以菩萨为本。杂类为末。下赞德中。先三卷明杂类赞。后第五卷方明菩萨赞。故云寻末归本

疏。又从本流末下。通妨。谓有难言。就先列中。既菩萨为本。杂类为末。先本后末。即合诸天之内。从自在天次明广果。次列三禅等。何以先明欲界。后列初禅二禅等耶。是则先小后大矣。故今答云。菩萨为本犹如一乘。杂类为末如流三乘。三乘之中初于鹿苑转于四谛。渐次归大故。先列欲界。后列色界。如次而上。故云先小后大故自在为末。末即末后耳。摄末归本者。又有难言。赞德之中表寻末归本。后明菩萨者。则合先明日月天赞。末后方明自在天赞。何以杂类之中。先明自在赞耶。故今答。云摄末归本。必从深至浅。谓菩萨是所归之本。杂类是所摄之末。摄末必须从胜。是故先摄大乘权教。如海摄百川。必先摄江次摄大河。次摄小河。次摄沟洫。故摄归一乘先摄权大。次摄缘觉。次摄声闻。次摄人天。一毫之善无不皆摄。故先明自在天赞。表是所摄之中先摄胜也。后明日月天等。表所摄之中后收劣也

疏。然皆显法界下。第三结成表法。又二。一结成自在。二又表四十二位下。结成交彻

疏。第八有无等者。文中二。先别明。此中分三。初通明前三。次别辩第四。后合解余六。后上十且随相下圆融

疏。四约乘无二乘不共教故等者。此段有四。一正明。二下为显法下。通妨。谓有难言。若无二乘。第九会中何得有耶。答云。为显法耳。次又难云。若为显法则有二乘。答云。亦不见闻与无同故。三智论云下。引证云。明无小乘是不共义。四或大乘经下。四重通妨难。正通智论。兼通正义。谓有问。言现有唯列小而是大乘如金刚经。那言前列小但是小乘经耶。答云。为引摄故。智论就其大略故唯列小乘。是小乘经。如金刚经等别是一理耳。言或唯列大亦非一乘。谓主伴不具者。即如楞伽等是也

疏。第九闻不等者。于中三。初正明。次纵不起前下。通妨。谓有问。言若约实众不互闻者。如来说法既不起前而趣于后。如何听众不得互闻。故今答云。约佛前后圆融。约根互不知觉。故法慧云。一切阎浮提皆言佛在中。我等今见佛住于须弥顶。则知各不相知也

疏。上之九门下。三总结义门。十中。疏云。余释云云不符论意者。谓有释云。声闻为同。菩萨为异。谓小乘断惑同故。有云。出家菩萨声闻为同。余并为异。此约形相同。故上之二解俱非论意。以经八会无声闻故。论释地经。经亦无故。初成正觉无出家故。或云登地为同。同证真故。余皆是异。是以地前名异生性故。有云。八地以上为同。同无漏相故。上之二解亦违论文。论主但云解脱月是同生众。本不曾言约地位。故又论明大众请云有同生众请。有地前故。所以知有者。由金刚藏云。有行未久解未得。随识而行不随智。闻此生疑堕恶道。我愍是等故不说。大众承此便请。明大众之中有行未久。即地前故。复有释云。杂类为同。以受彼彼同类身故。菩萨为异。不约同彼众生类故。此亦违论解脱月为同。故又有释云。菩萨杂类俱为同。法界无二故。余俱为异。法界义差别故。此约实义。岂得为释同异之殊。明知上来并非正解。故疏。云余释云云不符论意

疏。云何名为下。上出同异生体。今释同异生义。然其二释。前约事相。后约表法。又有将此四十众以配地位。同生众中开之为二。谓十普菩萨即是圆因。对前菩萨以为所信。从海月光下及执金刚为十住。复将一一位中十名。如次配于十度。海月光等十菩萨配初发心住。此住位本即是檀。其十菩萨复配檀。中具十则令十住自有百波罗蜜。历于五位有五百波罗蜜。以等觉位亦有十位故。主稼神下十众配十行。修罗已下配十向。三十三天下配十地。前十普菩萨是等觉地。作此配者则似生情。然文势多端。配亦无失。但不俟如此不次。谓四十众以配三贤十圣。下师子座众以配等觉。眉间出众以配妙觉。则四十二众配四十二位。于理甚直

疏。今初夫圣人无名等者。此先总彰大意。于中有三。初总标。无名立名故。庄子云。至人无己。神人无功。圣人无名。今约利生而于无名强立名耳。次虽得名千差下。总辩立名所以。此下辩立名别因。言多依行德者。亦有因姓。因父母等故。后行德皆具下。通妨。谓有难云。既依行德。而诸菩萨德行皆具。何以成别。故云随宜别标。随便宜故。谓如有偈云。弟子坚固菩提心。从师以受灌顶位。妙修定慧恒观察。深入业用善巧门。即普贤菩萨。又云。导诸有情胜菩提。以四摄法而摄取。即金刚王菩萨。无厌大悲未曾舍。即金刚爱菩萨。见行小善便称美。即金刚善哉菩萨。无住檀施等虚空。即金刚宝菩萨。亦虚空藏菩萨别名。能以慧光破愚冥。即金刚日菩萨。亦云金刚光。有所乐求恒不逆。即金刚幢菩萨。发言先笑令心喜。即金刚笑菩萨。能于妙法无染中。即金刚法菩萨。善用般若断诸使。即金刚利菩萨。亦即文殊师利是。无上法轮恒不退。即金刚因菩萨。亦云金刚转法轮菩萨。四辩演说无所畏。即金刚语言菩萨。诸佛众生事业中。即金刚业菩萨。恒被坚誓慈悲甲。即金刚护菩萨。亦云金刚甲胄菩萨。摧破魔罗胜军众。即金刚药叉菩萨。亦云金刚牙菩萨。坚持诸佛所秘门。即金刚拳菩萨。又如乘声济物。即曰观音手中雨华便名华手菩萨等。皆随德随宜也

疏。今初十名之普是别之总者。应有难云。前云十普既显法界总相之德。何得更有普德普光等殊故为此通

疏。此是古今下。明先列所以可知。然其释名。皆取下文所得法门以成会释。由得解脱。各随所得以立其名。所以前云依德行立。此若不了。但寻下经自当分明。疏又毗者种种下。第二释毗卢名。以梵语多含故有此释。于中二。先总明。后故普贤观经下。引经别解。然彼经由普贤令行者忏悔。行人问云。我于何所忏悔。故有此教。今以疏间经。当总引经云。释迦牟尼名毗卢遮那遍一切处。其佛住处名常寂光。常波罗蜜所摄成处。我波罗蜜所安立处。净波罗蜜灭有相处。乐波罗蜜不得身心相处。不见有无诸法相处。如寂解脱乃至般若波罗蜜。是色常住法故。但观经文自分经疏

疏。主伴有三者。一回向主伴。所修善根互相回向故。今成佛递为主伴。二同行者。同修禅戒等行。三二俱称性居然相收

疏。谓佛德无边等者。释为海义。即金光明意。彼经偈云。佛德无边如大海。无限妙宝积其中。智慧德水镇恒盈。百千胜定咸充满。即同海故

疏。从自佛善根海生者。由普贤等自圆十身。十身之中有如来身。依于佛身起菩萨用。云从彼生

疏。以夫大士必崇德下。先彰叹意。先两句标。崇德广业者。周易上系云。子曰。易其至矣乎。夫易圣人所以崇德而广业也。注云。穷理入神。其德崇也。兼济万物。其业广也。次复云。智崇礼卑。崇效天。卑法地。注云。智以崇为贵。礼以卑为用。又云。盛德大业至矣哉。富有之谓大业。日新之谓盛德。虚心外身者。即老子意。彼云。虚其心实其腹。弱其志强其骨。又云。后其身而身先。外其身而身存。今借其言。谓菩萨虚旷其心智绝能所。亡身为物一向利他。故下经云。菩萨所修功德行。不为自己及他人。但以最上智慧心利益众生故回向。即斯意也

疏。崇德故下。第二释上四事可知

疏。五眼之中慧眼观理者。五谓一肉眼二天眼三慧眼四法眼五佛眼。释相如离世间品。今唯取慧眼。十眼者前五眼外更加五眼。而业用多异。文云。所谓肉眼见一切色故。天眼见一切众生心故。慧眼见一切众生诸根境界故。法眼见一切法如实相故。佛眼见如来十力故。智眼知见诸法故。光明眼见佛光明故。出生死眼见涅槃故。无碍眼所见无障故。一切智眼见普门法界故。释曰。见诸根境界即是见事。即五眼中法眼见同。则明彻之言。明配十眼中智。彻配五眼中慧

疏。竖则深入无际者。故法华云。禅定智慧解脱三昧深入无际

疏。即应摄受者下。即胜鬘经文。由此具行入正法故者。即取意结之。彼云。折伏摄受令正法久住。多分折伏刚强摄受柔弱

疏。依佛性论说有五藏者。即彼论第二卷辩相分。第四自体相品。第一中有二义。第一自体相。牒释云。自体相者有二种。一者别相。二者通相。别相有三种。何者为三。一者如意功德。二者无异性。三者润滑性。言如意功德相者。谓如来藏有其五种。何等为五。一如来藏。自性是其藏义。一切诸法不出如来自性。无我为相故。故说一切诸法为如来藏。二者正法藏。因是其藏义。以一切圣人四念处等正法。皆取此性作境。未生得生。已生得满。是故说名为正法藏。三者法身藏。至得是其藏义。此一切圣人信乐正性信乐愿闻。由此信心故。令诸圣人得于四德乃至过恒沙数等一切如来功德。故说此性名法身藏。四者出世藏。真实是其藏义。世有三失。一者对治可灭尽。故名为世。此法则无对治。故名出世。二不净住故名为世。由虚妄心果报念念生灭不住故。此法不尔故名出世。三由有倒见故。心在世间则恒倒见。如人在三界心中决不得苦法忍等。以其虚妄故名为世。此法能出世间故名真实。为出世藏。五者自性清净藏。以秘密是其藏义。若一切法随顺此性。则名为内。是正非邪则为清净。若诸法违逆此理。则名为外。是邪非正名为染浊。故言自性清净藏。故胜鬘经云。世尊。佛性者。是如来藏。是正法藏。是法身藏。是出世藏。是自性清净藏。由说此五藏义故。如意功德而得显现。为显此义故说如意宝喻。譬如有人以宿业故。感得如意宝珠。得此珠已能随其意。有所乐事自然得成。佛性亦尔。由事善知识修诸福慧。感得此性。便随修行者意。各各自得三乘之果。故如意功德是其前相。释曰。然疏引五藏。即贤首疏其第五藏。即论第二正法藏。是名则小异。大旨则同。取其最后。顺经法界藏义。故当第五复名法界藏耳。然论正法藏。云因是其义。今疏云通因果者。谓能与因果诸位功德为因故。论云一切圣人四念处等而为因故

疏。所证之藏平等要无分别方契下。释智无差别。于中分二。先正释。后解妨。前中然有三释。连成一义。第一智自无差。如以圆盖称于圆函。今但论盖圆耳。谓所证平等故。须无差别智方证于理。若差别智即不能证此。二即由上义下。是第二义。能所不殊云智无差。如鱼符相合。三又此能证下。明一味无差。如水和乳。言此复有二者。前即真空一味。后即妙有一味。前即无相。后即法性

疏。若皆一味下。第二解妨难。于中先问。后古德下答。答中二。先举昔答。后申今意。于中三。初正释。谓智相尽故不有。则同如一味。能令智相尽故不无。则智有功能反照智空。不取于智斯为真智。故不无智。二不尔下。反释。反成不有一味之义。三是故于境不碍真而恒俗下。结成。于中二意。先以寂照对真俗二境。辩非一异。后境则空有下。结成无差

疏。上来所释下。二申令意。于中有三。初成昔解。次未尽下。辩顺违。后今正下。申义。今初。成昔解者。明有文据。出于起信。为出论意。则令昔解未尽其源。谓前结成之中。于境不碍真而恒俗。智则不碍寂而恒照。虽明不碍。若别对者。意以心寂对于境真。心照对于境俗。以照对俗。则心境非一。以寂对真。则心境非异。明是唯照对俗唯寂对真。次虽双融空有二境。寂照二心终不得言。境则不碍俗而恒真。心则不碍照而恒寂。则心境非异。明知本意相对别也。故今疏取其意。示论意。云真理寂寥与止寂相顺。俗谛流动与观照相顺。言起信等中且为此释者。出其所据也。等取瑜伽及别经论。言起信中者。即彼修行信心分中云。云何修行止观门。所言止者。谓止息一切境界相。随顺奢摩他观义故。所言观者。谓分别因缘生灭相。随顺毗钵舍那观义故。云何随顺。以此二义渐渐修习不相舍离。双现前故。若修止者。住于静处端坐正意。不依气息。不依形色。不依于空。不依地水火风。乃至不依见闻觉知。一切诸想随念皆除亦遣除想。以一切法本来无想。念念不生念念不灭。亦不得随心外念境界。后以心除心。心若驰散即当摄来住于正念。是正念者。当知唯心无外境界。即复此心亦无自相。念念不可得。若从座起去来进止有所施作。于一切时常念方便。随顺观察久习淳熟。其心得住。以心住故渐渐猛利。随顺得入真如三昧。释曰。上皆论文。止中则知无相不生不灭。观中常念方便及分别因缘生灭。明是止顺于理观顺于事。又论下文云。复次若人唯修于止。则心沉没。或起懈怠不乐众善远离大悲。是故修观。修习观者当观一切世间有为之法。无得久停须臾变坏。一切心行念念生灭。以是故苦等。释曰。上亦多就事明观。又下论云。唯除坐时专念于止。若余一切。悉当观察应作不应作止观俱行。所谓虽念诸法自性不生。而复即念因缘和合善恶之业苦乐等报。不失不坏。虽念因缘善恶业报。而亦即念性不可得。释曰。此之双行。亦明念自性不生是止。念因缘和合是观。故疏出论意云真理寂寥。与止寂相顺。俗谛流动。与观照相顺。而上云等。等取瑜伽七十七中。亦说禅定有于三品。一奢摩他品。二毗钵舍那品。三双运品。大旨与起信多同。故致等言

疏。未尽其源下。辩顺违。文虽顺论。不知诸论。且约一相。便将寂照敌对真俗故。是有乖疏。以令照真不得名照。照俗之时不得即寂故者。出其有乖所以。由以寂对真故。单照真时无照。以照对俗故。单观俗时无寂。故统收经论中意。或以理观对于事止。谓契理止妄是也。或事观对于理寂。谓无念知境是也。或事观对于事寂。谓观于一境心不动摇是也。或理观对于理寂。忘心照极是也。略举其四。广如贤首品。此由约单观。若约双融事理。如下疏文。若依古释。则全无事止。亦无理观。云何更得三观一心三止齐运。若云约真则境智无二。约俗则境智非一。斯则有理。而其结云境则空有无二智则寂照双融。明知。还融前照事之观契理之寂耳。更请细详

疏。今正释者下。第三申今正义。于中四。初约证理。以释境智非一异义。二约照俗以明。三双融事理以释。四约三观圆融以释。今初。即肇公般若无知论中之意而便以疏间而释之。彼论先有难云。圣智之无。感智之无。俱无生灭。何以异之耶。答曰。圣智之无者无知。惑智之无者知无。其无虽同。所以无者异也。何者夫圣心虚寂无知可无。可曰无知。非谓知无。惑智有知故有知可无。可谓知无。非曰无知也。无知即般若之无也。知无则真谛之无也。是以般若之与真谛。言用则同而异。言寂则异而同。同故无心于彼此异故不失于照功。是以辩同者同于异。辩异者异于同。斯则不可得而异。不可得而同也。何者内有独鉴之明。外有万法之实。万法虽实。然非照不得。内外相与以成其照功。此则圣所不能同用也。内虽照而无知。外虽实而无相。内外寂然相与俱无。此则圣所不能异寂也。是以经云诸法不异者。岂曰续凫截鹤。夷岳盈壑。然后无异哉。诚以不异于异故。虽异而不异耳。故经云。甚奇世尊于无异法中而说诸法异。又云。般若与诸法亦不一相亦不异相。信矣。释曰。但观上来所引论文。则疏之中自分主客。但观疏文中间释论。则论旨趣居然可知

疏。若约照俗下。二约照事可知

疏。若约融真俗下。三约双融。所以辩此者。自有二意。一者古德自科入法界藏云。一证理法故。于止义唯就理明。今此别明事理无碍。二者即所证理。是即事之理。不遮双融。但上双融。唯取权智对于真止故为非耳。故今不要以止对真。而智自有权实双融。对真俗双融。以与昔别。况云而不失止。则二智之上自有二止。权智之上有随缘止。实智之上有体真止。二止亦融对上二智。即止观双融。若融智境方为一味

疏。若约三观下。第四约三观说。谓空观假观中道观。在心则空假中一心。对境无谛有谛中道第一义谛。三谛之境三观自有三止。空观有体真止假观有随缘止。中观有离二边分别止。三止三观六法。一时以契一谛。三谛之境。境智一味。则有九法皆成一味。更有异门等并如下说

疏。总有十种广如彼说者。即第四十七经末云。佛子。诸佛世尊有十种无碍解脱。何等为十。所谓一切诸佛能于一尘现不可说不可说诸佛出兴于世。二一切诸佛能于一尘现不可说不可说诸佛转净法轮。三众生受化调伏。四诸佛国土。五菩萨受记。六现去来今一切诸佛。七现去来今一切世界种。八现去来今一切神通。九现去来今一切众生。十现去来今一切佛事。十句之首皆有一切诸佛。能于一尘等言。前五句下。皆有不可说不可说言。同初二门也

疏。然有引梵本下。因释此句。便弹古人有无益之文。意云。如不获已须引梵文。若无异辙何要繁引。因示体式。言译梵为唐诚乃不易者。案道安法师云。译梵为秦有五失本三种不易。即睿公摩诃般若经序所明。言五失本者。一梵语尽倒而使从秦。一失本也。二梵经尚质。此方好文。传可众心非文不合。二失本也。三梵经委悉至于叹咏叮咛反覆。或三或四不嫌其繁。而今裁斥。三失本也。四梵有义说正似乱辞。寻说向语。文无以异。或千或百刈而不存。四失本也。五事已全成将更傍及。反誊前辞已。乃复今说。而悉除之。此五失本也。又三种不易。何者。然般若迳三达之心。覆面所演。圣必因时。时俗有险易。而删古雅以适今时。一不易也。愚智天隔圣人叵阶。乃欲以千载之上微言传合百王之下末俗。二不易也。阿难出经去佛未久。尊者大迦叶令五百六通迭察迭书。今虽千年而以近意裁量。彼阿罗汉乃竞竞若此。此生死人而平平若此。岂将不知法者勇乎斯。三不易也。涉兹五失本逮三不易译梵为秦讵可不慎乎。今用此意。故云诚乃不易

疏。苟文小左右下。示译方轨。先二句总令取意。即什公意。睿公摩诃般若波罗蜜经序云。执笔之次。三惟亡师五失三不易之诲。惕焉若厉。忧惧盈怀。虽复履薄临深未足喻也。辛冀宗匠通鉴。文虽左右而旨不违中。遂谨受案译敢当此任。故会意译经秦朝罗什为最。若敌对翻译。大唐三藏称能

疏。若理不可通下。别示方轨。如下万字非字虚空无形。引梵以正斯引得矣。译人意近则会之以晋经者。如今经云。以是发心当得佛故。引晋经云。以是发心即是佛故。译人意谓即佛。恐滥果佛。故云当得。若尔上云初发心时便成正觉。何异即佛。况下复云即得如来一身无量身等。岂唯当成为是。是知即佛。约圆融门。当成但是行布之意。今以行布释于圆融。故言意近。须引晋经以成正理。又如出现品菩提章云。于一切义无所观察。但得寂义。故引晋经。解一切义。则止观具矣。如是等文其类多矣。许可引斥。今此文中广引梵本。言异意同故成繁长

疏。大乘同性经说等者。经云。一甚深难知广明地。二清净身分威严不思议明德地。三善明月幢实相海藏地。四精妙金光功德神通智德地。五火轮威藏明德地。六虚空内清净无垢焰光开相地。七广胜法界藏明界地。八最胜普觉智藏能净无垢遍无碍智通地。九无边亿庄严回向照明地。十毗卢遮那藏海智地。释曰。此上十地同是佛地。约用成别。广有其相。具如彼经

疏。转不退法轮。不退有四等者。此有两种四不退义。前义即十地论。一向约利他大用而说。后四不退如常所辩信谓十信。已满十千劫故。亦是第六不退心也。位即十住。第七不退住。不退堕声闻辟支佛地。故名位不退。证谓初地。已证真如已得不退念。即八地已上。念念入法流。心心趣寂灭。故得不退

疏。无德而称也菩萨之德焉者。此借论语泰伯篇言。子曰。泰伯其可谓至德也已矣。三以天下让民无德而称焉。意云。德既至深。故不能称叹也。谓泰伯即武王伯祖。文王之伯。弟名季历。即文王之父。合当泰伯长子承嫡。知弟季历必生圣子让而不受。托采药于吴故为至德。第二异生众

疏。一那罗延者。此云坚固。见佛妙色等者。取下得法以释此名。下经云。妙色那罗延执金刚神。得见如来示现无边色相身解脱门。偈云。汝应观法王。法王法如是。色相无有边。普现于世间

疏。二见佛身毛犹如日轮等者。故下经云。日轮速疾幢执金刚神。得佛身一一毛孔。如日轮现种种光明云解脱门。偈云。佛身一一毛。光网不思议。譬如净日轮。普照十方国。举此为例。下皆准之。欲具释者。但看下经名义俱了。余三十八众例此可知

疏。众即同生同名者。谓左右肩童子

疏。第十一主河神。即河伯之流者。外典说为河伯故。庄子秋水篇云。秋水时至百川灌河。泾流之大。雨涘渚涯之间。不辩牛马言其广也。于是焉河伯欣然自喜。以天下之美为尽在己。顺流而东行至于北海。东面而视不见水端。于是焉河伯始旋其面目。望洋向若而叹曰。野语之曰。闻道百谓万分之一。以为莫己若者。我之谓也。释曰。向若者。即海神名也。如下引之。皆此章具今但取名河伯亦名冯夷。故洛神赋。云冯夷鸣鼓如娲清歌

疏。即东方青帝等类者。此主五方有五帝。东方甲乙木。其色青故。东方为青帝。南方丙丁火。其色赤为赤帝。西方庚辛金。其色白为白帝。北方壬癸水。其色黑为黑帝。中央戊已土。其色黄为黄帝。若十二神。即一方有三故。故成十二。大集经说十二兽。皆是大菩萨示迹为之。广如彼说

疏。阿毗昙亦鬼趣摄者。若依杂心第八修多罗品。亦畜生趣摄。有言阿修罗与天同趣。是故说言汝先是天。问若然何不见天帝耶。答谄曲所覆故。有说是大力饿鬼。天趣不摄故。问若尔。释天云何与相习近耶。答天贪色故。胜负多故。鸠槃茶勒叉亦饿鬼趣摄。紧那罗毗舍遮醯鲁娑迦阇罗颇来罗。皆畜生趣摄。上皆论文。因便引来。疏化食四生者。化最胜故。则湿生鸟。食湿胎卵三生龙。胎生鸟食胎卵二生龙。卵生鸟唯食卵生龙。然劣不能食胜。若有食者其鸟即死。而可食者。日食一龙王五百小龙。绕四天下周而复始。次第取食。其鸟命将尽时至海取龙。为龙吐毒复不能食。饥火所绕耸翅入海。直下至风轮际。为风所吹还复却上。如是七返无处停足。逐至金刚山顶命终。以食龙故其身毒气发火自烧。难陀龙王恐烧宝山。降雨灭火滴如车轴。其身肉消散唯有心在。大如人髀绀琉璃色。轮王得之用为珠宝。帝释得之为髻中珠。疏略不言

疏。亦表菩萨摄生下。约表以释。引文云乃至者。彼经具。云菩萨迦楼罗。如意为坚足。方便勇猛翅。慈悲明净眼。住一切智树。观三有。大海。搏撮天人龙。安置涅槃岸

疏。而龙受三归者。菩萨处胎经。佛自说。昔为金翅鸟七宝宫殿等。时乃入海求龙为食。时彼海中有化生龙龙子。八日十四日十五日受如来斋八禁戒法。时鸟衔得龙出海。金翅鸟法。若食龙时先从尾吞。求尾不得已经日夜。明日龙出尾示金翅鸟云。化生龙者我身是也。我若不持八关斋法者。汝可食我。我奉齐戒。汝屈灭我。故金翅闻已。悔过自责云。佛之威神甚深难量。请龙入宫龙即随入。乃请龙受八戒

疏。又出现云。取善根熟众生等者。即彼如来行中金翅辟海喻。喻如来无碍行。经云佛子。譬如金翅鸟王飞行虚空回翔不去。以清净眼观察海内诸龙宫殿。奋勇猛力以左右两翅。鼓扬海水悉令两辟。知龙男女命将尽者。而抟取之。如来应正等觉金翅鸟王。亦复如是。住无碍行以净佛眼。观察法界诸宫殿中。一切众生若曾种善根已成熟者。如来奋勇猛十力。以止观两翅。鼓扬生死大爱海水。使其两辟而撮取之。置佛法中令断一切妄想戏论。安住如来无分别无碍行。释曰。观前经文。自知广略。下释救摄。引出现品亦是此文

疏。亦云歌神。即唐三藏译

疏。亦令爱见罗刹不害法身慧命者。涅槃十一。浮囊喻中罗刹乞浮囊。合以爱见罗刹。谓一切众生或因贪爱烦恼破戒。如有人明信因果正见在怀。但为惑缠遂破禁戒。名爱罗刹。二者以见不正。拨无因果起诸邪见断常等见。便破禁戒。谓破无罪名见罗刹。但彼令破戒。此害慧命。以之为异罗刹义同

疏。须弥藏经等者。有两卷。此即下卷。功德天自叙云。我与世尊往昔于因陀罗幢相王佛所。同时发誓愿。今愿悉满心意满足。是故如来出现于世。我今得住功德之处。我今虽复住功德处。犹未圆满昔本誓愿。何以故。此处多有象龙。下即义引。谓诸恶龙恼害众生请佛除灭。佛告须弥藏龙仙菩萨云。汝于往昔然灯佛所。为化诸龙起大勇猛。今四生龙。有于恶毒气毒见毒触毒啮毒贪嗔痴毒。云何当令如法除灭。彼菩萨答我。入其窟入深三昧。彼当降伏。广说竟云。我从阿僧祇劫勇猛精进。故能教化一切众生。此诸龙王于大乘法精进修行。谓此善住龙王为一切象形龙主。此难陀龙王为一切蛇形龙主。此阿耨达龙王为一切马形龙主。此婆楼那龙王为一切鱼形龙主。此摩那苏婆帝龙王为一切虾蟆形龙主。如是等诸大龙王。能与众生作诸衰恼。自余诸龙。自力不堪作上衰患。此五大龙安住大乘有大威德。是大龙王各各佛前率诸眷属。不令起作如上灾祸。于佛法僧三宝种性。久住于世不令速灭

疏。德中云行雨施者。语出周易乾卦。彖曰。大哉乾元万物资始乃统天。云行雨施品物流形。大明终始六位时成。时乘六龙以御天。乾道变化各正性命。保合大和乃利贞。首出庶物万国咸宁。释曰。干为龙也。六爻皆龙。今释于龙宜取乾德。况云行雨施

疏。余如音义者。前后不多引音义。以鸠槃茶此译为阴囊。其状稍隈故。指在音义耳。旧云冬苽鬼。亦以状翻

疏。然诸天寿之长短等者。俱舍世界品云。人间五十年。下天一昼夜。乘斯寿五百。上五倍倍增。色无昼夜殊。劫数等身量。无色初二万。后后二二增。言身量者。颂云。欲天俱卢舍。四分一一增。色天踰[跳-兆+善]那。初四增半半。此上增倍倍。唯无云减三。释曰。俱卢舍即二里。踰[跳-兆+善]那即十六里。以八俱卢舍为一踰[跳-兆+善]那故。则四天王天身长半里。至第六天身长三里。以半里半里增故。有引三法度经云忉利天身长一由旬。衣二由旬。广一由旬者。以彼误译里为由旬。不知彼失故妄引耳。四天王天半里。忉利天则一里。余可例知。上云劫数等身量者。色界梵众天身长半由旬。则人寿半劫。余可例知。云初四增半半者。二梵辅天则一由旬。三大梵则一由旬半。四少光则二由旬。此上诸天皆倍倍增。唯无云天减三由旬。所以减者。略出一意。唯无量光天四由旬。光音则八。少净十六。无量净三十二。遍净六十四。至无云天合有一百二十八。减却三由旬。有一百二十五。此上七天倍倍增之。至色究竟天欲成一万六千劫。故则身长一万六千由旬。又云。少光上下天。大全半为劫。谓少光已上大全为劫。谓八十中劫为一劫也。自下诸天大半为劫。即四十中劫为一劫也。言中劫者。即一增一减劫也。言衣服轻重者。四天王衣十二铢。忉利六铢。夜摩三铢。兜率一铢半。化乐一铢。他化半铢。上皆减半也。言宫殿等殊者。月天。长阿含云。其城正方一千九百六十里。高下亦尔。有分为二。一分真金。一分琉璃。王座二十里。遥看似圆。而实正方。日天同此。但量加半由旬。三十三天中宫名善现。周万踰[跳-兆+善]那。高一半。金城杂饰。其地柔软。中有殊胜殿。周千踰[跳-兆+善]那。此上诸天皆倍倍胜。可以意得。今但略消名意。故指广在余

疏。又日以阳德月以阴灵。即文选月赋中言

疏。更有异释如音义者。彼云释迦。正云铄迦罗。此云帝也。因陀罗。此云主也。古来释同佛释种族。望之称谬之深矣。又楞伽大云疏云。天帝名有一百八。今略举三。一因陀罗。此云尊重。三十三天共尊重故。二云释迦。此云勇猛。威德勇猛胜诸天故。三名不兰陀。此云降伏。以能降伏阿修罗故

疏。犹惧修罗之敌者。修罗嫉天有甘露味。诸天求修罗之女色。因起诤竞。广有因缘

疏。若修善者。即下正法念经说。帝释知修罗欲求。遽遣天使。令观阎浮之人。为修善多为作恶多。若修善多知战必胜。故生欢喜。若为恶者多。不孝父母不敬三宝。则生忧悴知战不胜。今言减少者。兼辩余时。为恶必堕三涂故。人天减少

疏。况受佛付嘱者。则净名大品等。皆属天帝。疏大权应为者。小乘中说是须陀洹。若准此经。例是大权菩萨疏。至如下。引事证成。坚常啼之心。大品般若施雪山之偈。即涅槃十三。成尸毗大行。即方便报恩经。破卢志巨悭。即卢志长者经。谈般若等者。大品广说。扬大教等者。净名大品等。其类非一。恐厌文系。不能具出

大方广佛华严经随疏演义钞卷第十九大方广佛华严经随疏演义钞卷第二十

        唐清凉山大华严寺沙门澄观述

第七称扬赞德分。初标章有二。一对十分之名。称扬赞咏本师功德。二云亦是发起序者。对三分科经。谓序正流通。一品是序。常途分二。一证信。二发起。今以前六分。皆为证信。此下四分。总为发起。赞扬发起佛德。出众显于佛用。正发起大经不同。古德但用天地祯祥为发起也

疏。第二总显德行因缘。疏文有二。先总彰大意。后科判解释。今初正释科文。何名总显德行因缘。先释总显自有二义。一望前为总。前四十众各随所宜以显胜德。所显则局。如显海神云。佛功德海充满其身等。今总显四十众德。二望后为总。下四十众得法各异。今总显具德。从前同生下。蹑迹成难。谓有难云。前显同生。云皆与毗卢遮那共集善根。岂非总耶。故今答云。前局同生。今该同异。四十众德方得名总。又前明共集。下重通所难。非唯总别不等。实亦文意有殊。前云共集。与佛德齐故为主伴。今曾摄受。唯为佛摄故为眷属。为分二义。前略摄受此略共集。可互影取。故云影略其文

疏。此文多势下。二科判也。言多势者。或可分三。或可分二。二中立名。亦可有异。于中三。初科为三。二初后是因下科拣。三又初段下对前且字。今为二故久摄。今见下亦是科拣。上三分中二即是缘。初后是因者。约自行为因。佛摄为缘。今得见佛由昔曾摄。摄即亲因。因缘既着为感。昔既曾摄故应

疏。言一切者。谓分别俱生若种若现者。谓二障各二。一者分别。谓因邪师邪教及邪思惟。此见道断。入初地时便永断尽。二者俱生。不由上二生而便有。此修道断。地地断之。此又二种。一者现行。二者种子。若所知现行地地断之。若烦恼现行亦地地断烦恼种子直至金刚定。断疏。二障气分粗重。粗重者。二障气分。即熏习所成。拣异现障故云习气。然习气有二。谓因与果。于现起障能为因者。亦名种子。此因习气根本智断。断此因已现不起故。不起现因。但粗重者。唯名习气。此果习气后得智断。断现粗重知现无故。言粗重者。违细轻故。然粗重有三。一现起粗重。贪嗔痴等令行者心无堪任故。二种子粗重。烦恼种子障诸智故。三粗重粗重。实非烦恼。似烦恼故。如身子嗔习毕陵慢习等。今即第三。以经言余习故。又位极故。前二即是一切中摄。故疏释。云若种若现。上言已断。即有能断之道。拣异伏道故云已断。断道有二。谓一根本无分别智。亲证二空所显真理。无境相故。能断二障种子现行。二后得无分别智。虽不亲证。无力能断迷理随眠。而于安立非安立相。明了现前无倒证故。亦能永断彼修所断迷事随眠。上来皆是唯识论意。更有释者。所知障中亦有二种。一于所知境而能为障。即是不染污。无知而非法执。如于五明处有所未解。但是无知。何曾有执。然唯识云。由我法执二障俱生。若证二空彼障随断者。据见道分别障说。以证空理而断障故。言是障而非执者。据修道断俱生障说。以遍知有成种智故。上来所知之障。二所知即障名所知障。此体即是善心心所。以彼空有二相未除。带相观心有所得故。前据了俗。此据证真。说名智障。此障对治亦有二种。一者解有。二者达空。空有俱明名遍知故。然唯识正义。唯所知之障。今就理通故亦用之。问永断习气唯是如来。云何此亦皆云已断。答此有二释。一约法相。全分离尽唯是如来。若据分离亦通菩萨。以经中说三种粗重。三位断故。解深密经说三粗重。一者在皮。初地即断。二者在肤。八地方断。三者在骨。唯佛地断。虽则余位亦断粗重。而三位显。是故偏说初地。舍凡入圣位故。八地无漏常相续故。佛地果满顿得舍故。又此即是八地菩萨故云断也。二约圆融。如疏文显

疏。布施是摄缘等者。略示四摄之相。然瑜伽说各有九门。至贤首品当略明之

疏。已超七地殊胜善根者。以七地有空中方便慧。有中殊胜行功用行满。故云无量

疏。一道无量道者。一道者。一切无碍人一道出生死故。离世间品说。一道是菩萨道。不舍独一菩提心故。二道是菩萨道。谓方便智慧故。三道四道乃至十道。又云。菩萨有无量道无量助道无量修道无量庄严道。各略列十句。则万行触目皆菩萨道

疏。尘毛刹海下。上是通相般若之意。此是华严一乘玄旨

疏。此一段文望前是别下。总显文意。以总具德中文有三节。第三德行圆备中自有七句。今但是二故云别也。既言得于诸佛解脱之门。则是四百余门之总标也。义虽两向科且属前

疏。初乘因入果者。以胜解力即是乘因。入于如来功德大海。即是入果。冲者。和也深也虚也高也升也。今正是升义兼虚高

疏。亦是胜解印持果德者。前则印言即比知二严。与慈悲皆教道也。今云印果。则心冥果海为证道也。疏言解脱门者。先总释。后圆融。前中三释。初解脱门三字。皆属于佛。二解脱属果。门属众海。三三字皆属众海。于中有二。一就因中自分能所。二将已解脱望果为门

疏。然总别下。二圆融。融上三义。总别圆融。融第一义。因果交彻。融后二义。重重无碍。通上三义。且如总具于别。别亦具总。则一解脱门中。有一切解脱门等思之。疏约观心者。疏中初正释。次若以门下拂迹。先返成。后正入下。顺结能所双寂故曰双亡。门理历然称为正入。正入则理无不契。双亡则过无不寂

疏。及空有称真之理者。此空是外空。若以理空对外空。外空离法是断灭空。理空即事名为真空。若以外空亦心所现。亦由对色灭色方显。则此断空从缘无性。即性空也。故十八空明大空者。谓十方空。即十方虚空。亦是性空矣。是故疏云空有称真之理。即有之空皆性空也

疏。一明前大用。用无用相等者。此二义中。一用同体寂。二用同体遍。言方便二者。一由忘寂故不碍用。二由依寂故能起用

疏。三自相解脱者。以一切法各各不同色非心等。故名自相。今皆不生故名解脱。此明无彼生相。则法体不生。故名自相。若直遣生住灭相。亦共相耳。疏文有四。一略科释。二然不生下。开章门。三别释下。随门别释。四斯为正法下。结劝。三中有三释。一别释。二通释。三展转释。今初文二。先释不生灭。后释不来去。今初。自有五重者。前三别据三性文同。四即合前三而义别。五即融四句而无碍。就别约三性中各三释者。初一通就当性说。二约当性二义说。三对三无性说。唯圆成二义小异。云何三性各二义耶。遍计二者。一情有。二理无。依他二者。一缘生。二无性。圆成二者。一性有。二相无

疏。一就遍计下。遍计三义也。一遍计无体如绳上蛇。故无可生灭。二约二义者。情有合是生。理无体是灭。今此情有即是理无。何有生耶。正理无处。方是情有故。非灭也。下例可知。三对无性者。由无遍计。方显无相故。唯识云。即依此三性。说彼三无性。是知若无遍计。安知无相。下亦例然

疏。二就缘起性者。一通说因缘之法依他而起。因缘所生无有生故。故经云。一切法无来。是故无有生。以生无有故。灭亦不可得。二明二义中又缘起无性故者。缘生即无性也。无性缘起者。无性即缘性也。前句即因缘故空。此句即无性故有故。引中论以有空义故一切法得成。唯证后句也。三显无性中。若无因缘不知无性。故论四句推之。诸法不自生。亦不从他生。不共不无因。是故知无生。若不推此安知无生。无生即是生。无自性性也

疏。三约圆成。初义可知。二约二义中小异前二耳。谓二三皆约二义。二即法相宗二义。于此二义显无性义。谓非妄心境故。即相无义。圣智所证故。即性有义。而非妄心境故。远离我法所执。便能显得胜义无自性性。三云又体非迁变下。即约不变随缘。法性宗中二义。既不变故不生。由此不变方能随缘。则不生是不灭义。既以随缘为不灭。由随缘不失自性。方知不变则不灭。是不生义。故云为一物也

疏。四通就三性等者。即合前三而义全别。理实具合。三性三无性。以成四句。如一念心刹那瞥起。即具六义。谓一念之心。是缘起法。是依他起情计有实。即遍计所执。体本空寂。即是圆成。三性备矣。既即依三性说三无性。故六义具矣。今于三性成其三句。三无性上共成一句谓一念之上既理本无故。遍计为不生。本无之理。即是圆成故不灭。依他即无性故亦不生。而不坏相故亦不灭。三句备矣。言就三无性非不生非不灭者。上约遍计故不生。今遍计即无性故。无彼不生为非不生也。上约圆成故不灭。今圆成即是胜义。无自性性。故非不灭。上约依他亦不生亦不灭。今依他即生无自性性故。何有亦不生亦不灭。故上三性不出不生不灭。今翻彼三性。以成三无性。故双非也。五中融四句而无碍。以一念心上一微尘上即有六义故总融合。言合四句者。非第四门中四句。合前总别二种四句耳

疏。一不来不去下。有三义释。初唯约体。二依体起用。三摄用归体。初中背舍。是去而云不去者。智照妄空无可舍故。照惑无本即智体故。向证真理合是来义。如如来故。而云不来者。真不可得故。照体无自。即真理故。故经云。如来者。无所从来

疏。又依体起用等者。第二双约体用说也。依体起用故是去。以即体之用故不去。应机现前合是来。以应不离体如月之影故不来

疏。又往应群机而不去等者。第三唯约用说也。往应合是去。应无应相故不去。恒归寂灭合是来。灭不可得故不来。又即体之用往而不去。用即体故归而不来。然前对于佛上明去机上明来。此对于机上明去佛上明来。又前对机见佛来。此对佛见机来。然三义虽殊。皆显不来即不去也。疏由此下。释无功用。摩尼约身。天鼓约口无思约意。文意可知也。疏二通释者。然既言不生灭约行。不来去约境。此亦是局。何名为通。已上是贤首意。不生灭局境而不通行。不来去。局行而不通境。今翻其不通令通。则四义俱通境行。故名为通。于中先总。后谓妄念下别。亦约三性以成观行。初即遍计。契同无相何有生灭。二又虽起大用下。约依他起观。三又常称真下。约圆成观。此约行释下结属。约境释不来下。亦约三性。初即遍计。二又缘会下约依他。三又诸法即如下。约圆成。而并从拣略各出一义。例前不生亦可具五。亦应前三。别说四五融通。如遍计上。亦应云情有即是理无故不来。理无即是情有故不去等。但改生灭二字。为来去二字。余准前思

疏。三展转释。所以为此释者有三意。一则上来但当句释。今显互相释。故如经云一切法无来。是故无有生等。即此亦名相因释也。二又既无来无去则非一异者。次正是展转释。欲明不生灭等四含义无尽。故略举八不。即中论宗。论云。不生亦不灭。不常亦不断。不一亦不异。不来亦不去。而青目释之。有展转相因释。今取此势故为此释云何不来不去。则得非一非异耶。谓若有来去则有能所。能所为异。对此为一。今无来去故无一异。云何不生不灭。则得不常不断。谓若许有生。生即是有定有则常。若许有灭灭则是无。定无则断。今无生灭。何有断常。故中论问云。不生不灭已总破一切法。何故复说此六事耶。答为成不生不灭故。谓有人不信不生不灭。而信不常不断。若深求不常不断。即是不生不灭。故知二义相成。从智契下释无功用。三是则不生之生下。生与不生展转相成。上来诸不相成。总显不生之理。今则性相相成。以此不生不同断灭故。不碍于生。若碍于生。非真不生故。不碍生成不生也是则缘生故无性。无性故缘生。二义相成。真不生也。余可例知

疏。尚不造善等者。然邪说空。谓豁达无物。或言无碍不妨造恶。若真知空。善顺于理恐生动乱。尚不起心恶背于理。以顺妄情岂当更造。若云无碍不碍造恶。何不无碍不碍。修习善行而断恶耶。厌修善法恐有着心。恣情造恶何不惧着。明大邪见恶众生也

疏。尚不依佛者。意同前义入理观佛。恐怀观心。更造业思。特违至理

疏。此离二取相者。唯识第八有四二取。一相见。二名色。三王所。四本末。本即第八异熟。末即前六识异熟。今当相见。所觉是相。能觉是见。远离觉所觉。名自觉圣智。故楞伽云。一切无涅槃。无有涅槃佛。无有佛涅槃。远离觉所觉。即斯义也。上是第一经。第二又云。佛告大慧。前圣所知转相传授。妄想无性。菩萨摩诃萨独一静处。自觉观察不由于他。离见妄想上上胜进。入如来地。是名自觉圣智之相

疏。十地论中承佛力等者。论但云示无我慢无偏心故。昔人或将通配二句。疏意以别配为正故便配之

疏。结集取此者。以昔人皆云颂长行故

疏。然此中长行下。相对料拣者。示说偈仪式。然上举四种明偈体式。次明八义。即立偈之由。然通重颂及与孤起。华藏品亦有十例五对。唯约祇夜。今此料拣。唯局此文。虽是孤起而经家广列。故须会释。总有六对。一因果者。如第十偈云。佛于无边大劫海。为众生故求菩提。此举因故。长行即。云自所悟处。此显果也。第二体用者。第二偈。云能然照世妙法灯。用也。长行云普观一切悉自在。体也。第三影略者。长行云知一切法不生不灭不来不去。偈中但。云了相无有。即偈中略也。第四偈。云永灭众生痴暗心。长行但有现见一切法。即长行略也。第四难易者。如初天王。长行但云得法界虚空界。寂静方便力解脱。不见偈文难为解释。第五法喻不同者。长行第二但。云观一切法。偈云能然照世妙法灯。是也。第六能所递举者。初天王但。云法界虚空界是所遍处。偈中则云佛身普遍诸大会。则长行阙能遍。且就初段具有六对。况下诸段显文甚多。言传授之者善消息之者。易丰卦云。天地盈虚与时消息。释云。消者尽也。息者生也。谓可加则加。可减则减。可出则出。可没则没。故言消息

疏。二文相映者。长行不了则观偈文。偈文若难见。则观长行则易了也

疏。一出现无尽等者。然还源观说有三遍。一一尘普周法界遍。即经充满法界无穷尽。二一尘出生无尽遍。即疏前意。三一尘含容空有遍。即疏后意

疏。不可取为一异俱不俱等者。普遍诸会此应有异。充满法界此应唯一今性相俱寂故皆叵得。若有一异则合此为俱。一异既亡俱从何。有若有俱句遣此双非。俱句已无双非宁立。故四句皆遣百非俱亡。寂乎唯寂而言等者。亦不可说有无等四。真应等殊。唯证相应耳

疏。因灭无明则得炽然三菩提明者。即涅槃二十一。南经十九。高贵德王菩萨品。因琉璃光菩萨欲来放光。佛问文殊。文殊初入第一义。答云世尊。如是光明名为智慧。智慧者即是常住。常住之法无有因缘。云何佛问何因缘故有是光明。广说无因缘竟。末后云。世尊亦有因缘。因灭无明。则得炽然阿耨多罗三藐三菩提灯。今略义引耳。第二四禅

疏。只由真空能立因果下。答上疑念。此句明其以有空义故一切法得成。若无有空义因果定有。便堕于常。言因果立故乃是真空者。即因缘故空义。若离因果以明空者。是断空故。第三三禅

疏。光影之言略有二者。贤首更有一义。今不存之故云略也。彼释云。谓如明净物得日光曜。于屋壁上有光影现。如来应机现身亦尔。然有多义。一缘集义。谓大智明净悲愿日照。于众生阴室之内。现于佛影。二速疾义。无远不至故。三无碍义。不可执持故。四有用义。能破暗故。五无生义。无所有故。广如十忍品说。此义似有穿凿。故略不存。今疏所明二影者。然摄论影略有三。一映质影。二水月影。三镜像影。广如十忍品。今是前二今云光影故略镜像。正是初义。所日喻如来身。树等形质以喻众生。日无异体。质有万差。树侧影斜形端影正。影不现于日内。但在质边。弄影多端随心万品。二水月影。以月有光亦名光影。影多似月者。如月圆缺故。少似水者。随动静故

疏。或折或摄等者。胜鬘云。应摄受者而摄受之。应折伏者而折伏之。摄受折伏则正法久住

疏。谓众生界等者。瑜伽有五无量界。此前例四。后言以方便界者。即调伏方便界故五具矣

疏。爱见罗刹甚可怖畏者。即涅槃第十一。罗刹乞浮囊喻。因贪等造恶。即爱罗刹。若拨无因果成破戒事。即见罗刹。乞浮囊也。己如前引。第四二禅中

疏。经论共说乐有五种等者。论即瑜伽等经。即善戒经第二。自利利他品。释真实义中快乐义。经云。云何名快乐。快乐义者。有五种。何等为五。一者因乐。二者受乐。三者断受乐。四者远离乐。五者菩提乐。云何因乐。因内外触。因触因缘故有受乐。是名因乐。因行善法得他世乐。是名因乐。云何受乐。从因因缘身得增长心得安隐。是名受乐。受乐者。有二种。何等为二。一者有漏。二者无漏。无漏有二。一者学地。二者无学。有漏有三。欲界色界无色界。三有有内外入故有六触。六触有二。一者身乐。二者心乐。五识共行名为身乐。意识共行名为心乐。修习圣道断诸受故。道得增长无有诸受。名断受乐。永断烦恼身心无患。名远离乐。受常乐故名菩提乐。或有说言无想定者名为断乐。是义不然。何以故。不断受乐故。远离乐者。有四种。一者出家乐。二者寂静乐。三者断乐。四者菩提乐。世间之人多有忧苦。永断是苦名出家乐。断欲界贪名寂静乐永断烦恼名为断乐。受常乐故名菩提乐。菩萨常能施众生乐。名菩提乐。菩萨摩诃萨自受常乐转施众生。名菩提乐。何故名为因乐。是乐因故名为因乐。不名受乐。受乐者。不名因乐名为性乐。断乐者。不名因乐不名受乐。以断多乐故名为断乐。远离乐者。不名因乐。不名受乐。不名断乐。以观生死众过患故。名智慧乐。菩提乐者。不名因乐。不名受乐。不名断乐。不名远离乐。无边常故名菩提乐。名无胜乐。名无边乐。名无上乐。亦名常乐。名寂静乐。菩萨摩诃萨能以如是五种之乐施于众生。是名因乐义。今疏望彼经数名不同。若欲会者果及苦对除。即是受乐开出无恼害者。即远离乐。及菩提乐。经中远离有四。今云出家远离乐。含其二种出家即第一远离。兼得第三断乐。复开菩提为菩提涅槃二乐。若瑜伽九十六。说乐有二种。一者欲乐。二者远离。远离复有三种。一劣谓无所有已下。二中谓第一有。三胜谓灭受定。然世尊依第一义。说有三种最寂静乐。谓等解脱故总摄为三。一应远离。二应修习。即前三上中下远离。名有上远离。三最极究竟解脱无上住乐。即前贪等解。五初禅中

疏。以一言说尽故者。释此一偈。疏文有二。一正释。二解妨。前中自有二意。一佛法对说。前句一言说尽。显佛胜德。后句劫说不明法无尽穷。约能包下。总就佛说。是叹佛故。前二句能包。后一句能久。疏然一言但说刹尘下。通妨。谓有问云。前言说尽。后云不穷。岂不相违。答有二意。一顺文通。二约理通。今初经。云佛刹微尘法门海。一言演说尽无余。刹尘法外更有无尽之法。何妨劫海演说不穷。故反成之。设欲一言尽者。则二三两句相违。初明前违于后。后更有所演下。后违于前。从若欲通者下。约理会通。则前二句直是说尽一切诸法。后之一句不妨无穷。若一言不尽者。佛非不思议故。故总说则尽。成于前句。隐映无尽。成于后句。兼以喻显。皆遗忘集意。第二欲界

疏。芥子之空投刃之地者。芥子之空即十定品。四十一经云。佛子。譬如虚空于虫所食芥子孔中亦不减小。于无数世界中亦不增广。其诸佛身亦复如是。见大之时亦无所增。见小之时亦无所减。今但取能喻。投刃之地者。即庄子中。庖丁为文惠君解牛十九年。而刀刃若新发于硎。君问其故。答云。臣始见牛为全牛也。今见非全牛。彼节者有间。而刀刃者无厚。以无厚之刃。入有间之节。恢恢乎其于游刃。必有余地矣。故文选云。投刃皆虚。目牛无全。今借其骨间小空。以对上小空。为真俗之况耳

疏。余皆威力自在者。大集经云。孩子以啼为力女人以嗔为力。外道以见为力。波旬以生死为力。菩萨以慈悲为力。佛以智慧为力。故以说法皆为威力

疏。攀取缘虑是惑病之本者。即净名问疾品意。经云。何谓病本。谓有攀缘。从有攀缘则为病本。何所攀缘。谓之三界。云何断攀缘。以无所得。若无所得则无攀缘。何谓无所得。谓离二见。何谓二见。谓内见外见。是无所得故。今疏。云心境无得则舍攀缘

疏。涅槃经中有闻赞佛等者。即三十八经。南经三十五。诸婆罗门欲与佛捔力。尔时复有一婆罗门。作如是言。诸仁者。瞿昙沙门。成就具足无量功德。是故汝等不应与诤。大众答言。痴人云何说。言沙门瞿昙具大功德。其生七日母便命终。是何得名福德相耶。婆罗门言。骂时不嗔打时不报。当知即是大福德相。其身具足三十二相八十种好无量神通。是故当知是福德相。心无憍慢先意问讯。言语柔软初无粗犷。年志俱盛心不卒暴。王国多财无所爱恋。舍之出家如弃涕唾。是故我说沙门瞿昙。成就具足无量功德。大众答言。善哉仁者。瞿昙沙门实如所说。成就无量神通变化。我不与彼捔试是事。释曰。文甚昭著。今但义引。略不引相好者。前已有故非功德类言。然与前义相成者。第二义慈为相因。此义慈即是相果。果由因致。复相显因故云相成

疏。以开摄示等者。此有二释。前即嘉祥意。四句虽殊不出能所。开示约能化。悟入约所化。全彼疏文。彼更释云。能化有大开之与曲示。所化有始悟之与终入。意云。但说有性名为大开。言此是凡夫性。此是圣人性。因果理行即名曲示。豁然了知即为始悟。修行契证目为终入。则始浅终深。下引论意则初深终浅。以入约因故。彼论云下。即第二释。彼论先释如来知见云。佛知见者。如来能证如实知彼义故。疏意云。如实即法性所证也。知彼义即能证大智也。能所知见皆名知见。正同今经开示正觉境界。正觉即能证。境界即所证。今疏但出开等四句。开者无上义。此即标名也。谓除一切智智更无余事者。释所开即一切智智。一切智是根本智。重言智者。是后得智。根本名知。后得名见。除此二事更无有余。能胜过此故名无上。即双开菩提涅槃者。释所开一切智智也。谓以知见之性下。释双开义。众生本有下。疏释开义。大乘法师释开云开者。出生显证之义。谓出生菩提显证涅槃故。即法相宗意。故下释悟云。令悟知见性相。本有种子以成报身。今疏意不然。知见性相并皆本有。本有大智光明遍照法界义。故涅槃云。佛性名第一义空。知见性也。第一义空名为智慧。知见相也。在因为性相。在果为菩提涅槃。故云众生本有障翳不现耳。智障菩提惑障涅槃。二障俱无。菩提涅槃一时俱显。故云佛为开除则本智显现

疏。示者同义别。示知见之性以成涅槃悟者。不知义别示知见之相以成菩提。言不知唯一实事者。经云。唯此一事实余二则非真。一实事即是知见。上三皆果。断德智德以总别故而成三句。入即因义。未知何可能证。故示与无量智业。无量智者。即果中一切智智体用。而言业者。是彼因也。所以要举初地已上为因者。登地证如为涅槃因。能证地智为菩提因。故十地论。释经究竟如虚空尽未来际云。即因善决定。究竟如虚空。即菩提因。如依空生色。色不尽故。尽未来际为涅槃因。常果无穷故。二果即智性相也。又开者即般若。故论云除一切智智。更无余事。示即法身。悟即解脱。三德涅槃即是三句。入是三德之因。上有三意。一约佛性释。二约菩提涅槃释。三约三德涅槃释。会之并同佛性有果。有果果即菩提涅槃故。三德涅槃摄菩提故。亦佛性故。余如前后释。禅宗之解如问明品

疏。五求不得等者。即中论观如来品偈云。非阴不离阴。此彼不相在如来不有阴。何处有如来。即五求也。由诸外道妄计有我。我为如来。计有五故。五者。一谓即阴是如来。二谓离阴有如来。三谓如来中有阴。四谓阴中有如来。五谓阴能有如来。今并非之若阴即如来。阴生灭故佛应生灭。故云非阴。二若谓离阴有如来者。以何相知又如来堕常过。离阴生灭故故云不离。三若谓如来中有阴。如器中有果。则亦是异如来亦堕常故。四若阴中有如来。如床上有人。亦有别异过。故云此彼不相在。五若如来能有五阴。阴属如来者。则如人有子。亦有别异过。异则如来堕常等故。然后四句皆成异过。初即是一。总合但是一异过耳。故观法品破我。但云。若我是五阴。我即为生灭。若我异。五阴即非五阴相。今细推寻故有五求皆不可得。上之五求但能破有。今四句并非故。言谓佛有耶常见为惑。谓佛无耶邪见深厚。此且双破有无。而有过则微。无过则重故云深厚。彼论偈云。邪见深厚者。则说无如来。如来寂灭相。分别有亦非。如是性空中。思惟亦不可者。亦遣有无。然则四句百非所不能加故无所有者。结归经文准中论中。略说三种四句。皆不能加。初偈云。空则不可说。非空不可说。共不共叵说。但以假名。说此一四句。共即俱句。不共则双遮。若别说者。一空。二非空。三亦空亦非空。四非空非非空。此皆双遮辩中。以第二四句云。寂灭相中无常无常等四。第三四句云。寂灭相中无边无边等四。今并拂之。非唯此四。泛尔随相皆悉非之。然百非有二义一约十恶说。如下当明。二约通相说。谓离一切分别之相耳。故论结。云如来过戏论。而人生戏论。戏论破慧眼。是皆不见佛。谓起心动念并为戏论。非观如来。应如净名观阿閦品。故疏结。云真则无缘佛尚应舍。何况余境。即借用金刚。法尚应舍何况非法。疏相好者。经云尽人中福等者。等取善生经云一切世间福不及如来一毛功德。一切毛功德不及一好。一切好功德不及一相。故名福相。云不及如来一相等。等取瑜伽四十九。亦如是说

疏。毛孔过空。疏有三段。说二种过。一如来灵智能证真理虚空不能证。二如来称真理空。超过事空。事空即断灭空故。三无限理智下。双结上二皆不可分。理无分限智契于理。亦无分限。智结灵智。理结真理。既不可分一毛。称真则重重融摄。此处之空。岂不能摄于余处之空

疏。寻影之月月体不分者。此中法喻影略。若具更云。以月随影万流异见。寻用之体体本寂然。为寂静光也

疏。慢是根本等者六。根本中之一也。憍逸随惑者。二十随烦恼中之二也。憍是小随。放逸是大随。并如初发心品。今略释之。以经有意故从。慢谓下释三惑相。以顺经文故。唯识云。慢谓恃己夌他高举为性。能障不慢生苦为业。谓若有慢。于彼有德心不谦下。由此生死轮转无穷受诸苦故。故疏。云慢能长沦生死。论云。云何为憍。于自盛事深生染着醉傲为性。能障不憍染依为业。故疏。云憍为染法所依论云。云何放逸。谓于染净品不能防修纵荡为性。障不放逸增恶损善所依为业。故疏。云放逸即是纵荡。余可思准

疏。十魔并离者。即五十八经。一蕴魔。二烦恼魔。三业。四心。五死。六天。七善根。八三昧。九善知识魔。十菩提法智魔。下广有释

疏。疑自疑他等者。然疑略有二。一通相说。于诸谛理犹豫为性。能障不疑善品为业。二者五盖中疑。略有三种。一疑自。谓己不能入理。二疑师为彼不能善教。三疑法。谓于所学为令出离为不出离。如有病人疑自疑医疑药病终不愈。今言疑自疑他疑理疑事。即五盖中之三种也。合其事理皆所疑法。通相说也。从如闻空疑断者。略示疑理事之相。亦通一切疑也。此疏有二势。一当句生疑。谓闻空疑断等。不了真空将谓断灭等。二又闻空疑有者。即空有互疑。而云等者。等取闻双是则疑双非。闻双非则疑两是。今开之可思。更略示其义。谓闻空莫疑断。是即事之空非断灭故。闻有莫疑常非定性有。从缘有故。闻双是莫疑两分。但双照二谛无二体故。闻双非莫疑无据。以但遮过令不着故。又闻空莫疑于有。是即有之空故。闻有莫疑于空。是即空之有故。闻双是莫疑双非。是即非有无为有无故。闻双非莫疑双是。是即有无方是非有无故

疏。又但以世俗下。即净名第二。唯改菩提为如来耳

疏。经云藏识海常住等者。此疏义引。具云。譬如巨海浪。斯由猛风起。洪波鼓溟壑。无有断绝期。藏识海常住等。同此义。至下问明品。当广分别

疏。又言此二不二者。融上性相二空也。云何融耶。谓若不达者。性相二空俱非了义。何者。谓法若性空相不空故。若云相空性又不空。以性相异故。犹如画火无有热性。而似火相。如木中火不见其相而有其性。如角峰垂[古*頁]即是牛相。负重致远。是其性故。性主于内。相据于外。若一空者。彼一不空。若得意者。此二相成。谓由从缘无性名为性空。故令体相无不空寂。即相空也。此以性空成于相空。由诸相荡尽是故空中无色无受想行识。方显法性本自空耳。此以相空成性空故。二空相成云不二也。又说性空总有三义。一法无定性名空。则相未空。二法之真性本空。则相亦未空。三若说从缘无性故名为空。则一切法性自空矣。非推之使空。则悟真如成正智火者此中具五法三自性。三性文显。五法相者。谓遍计无物。故亡名也。妄计无相。故绝妄想也。起缘无相。故绝相也。悟真如即圆成。成正智火。五法具矣

疏。若以生灭八识。即彼第八亦名为转者。以起信中则生灭与不生灭和合故。有藏识海常住之言。如长行辩今取唯识宗八识。唯是业惑辨体生故皆生灭。言以恒转故者。即引证也。论释第一能变即阿赖耶。于中因果法喻间之恒转。如瀑流。论有问。云阿赖耶识。为断为常。论答云。非断非常。以恒转故。恒谓此识无始时来一类相续常无间断。是界趣生施设本故。性坚持种令不失故。转谓此识无始时来念念生灭前后变异。因灭果生非常一故。可为转识熏成种故。恒言遮断转表非常犹如瀑流因果法尔。疏云念念殊者。即以论恒转之言。会同经文。新新已下。义引上论。从念念殊故下。会法性宗与如来藏非一非异故。起信云。谓不生不灭与生灭和合。非一非异。名阿赖耶识。由念念殊是生灭故与藏非一。即此生灭心恒沙性德本来具足。故名不离不即不离即不一不异。言如彼瀑流者。即向所引唯识后文云。如瀑流水非断非常。相续长时有所漂溺。此识亦尔。从无始时来生灭相续非常非断。漂溺有情令不出离。又如瀑流虽因风等击起诸波。而流不断此识亦尔。虽遇众缘起眼等识。而恒相续。又如瀑流漂水上下。鱼草等物随流不舍。此识亦尔。与内习气外触等法。恒相续转。释曰。但观上引于疏自明。而疏文中二宗合释。如瀑流水即唯识文。离水无流。通二宗义。若成法相。离第八识无眼等识。若依法性。离如来藏无有八识。广如问明。又如海波涛。即起信论云。如大海水因风波动。水相风相不相舍离。海即藏识。如长行说。恒常住故是如来藏。此即成上离水无流。亦乃生下有所漂溺。即唯识上生人天犹如漂草。下沉三涂犹如溺鱼。多畜养故。又兼法性。此中具有恒沙性德。一切至宝自此而生。若取法相阿陀那识甚微细。一切种子如瀑流。我于凡愚不开演。恐彼分别执为我。亦多畜养义。义兼二宗言法合思之已如上说玄文。又明至问明品当广分别二宗之异

疏。谓此识微细。即如向引偈文。即唯识第三。引解深密偈

疏。次句示心海性即是佛智者。上句佛智为能了。故八十经。云佛智广大如虚空。悉了世间诸妄想。故今此即出现品。云一切众生无不具有如来智慧。如大海水潜流四天下地。故云即是佛智。不令外求者。即净名云。诸佛解脱当于众生心行中求。称彼圆机故生欢喜

疏。圣智涅槃本有今无者。约法相说。涅槃本有圣智本无。故无菩提觉法之乐。今约法性。涅槃圣智皆有。性净即法性门。是则真乐本有。失而不知云无有耳。故初地云。诸佛正法如是甚深。而诸凡夫心堕邪见。既失真乐妄苦本空。得而不觉是故沉迷。若觉本性不沉迷故。故第三句。示其性有。令其觉性了彼苦性。真寂静乐。云乐非苦外。是以长行名不思议

疏。见性得乐性即是门者。若约解。苦无苦苦。为见性之门。今约见性成佛故。性为圣乐之门

疏。依光有影等者。疏开影像二字。以为两喻。影谓光影喻像谓镜像喻。然此二喻有通一切。今取别义。光影之喻。喻佛现多端。故云有动静。质动影动。质静影静。镜像喻现身胜劣。如丈六三尺三十二相等随机见故(第二经终)

大方广佛华严经随疏演义钞卷第二十大方广佛华严经随疏演义钞卷第二十一

        唐清凉山大华严寺沙门澄观述

自下第二八部众

疏。然则世之忧喜生乎利害下。上显释经文。此下密取经意。举世忧喜。况出世乐。即周易系辞之文。而倒用之。先具出易文。易云。刚柔杂居而吉凶可见矣。变动以利言。注云。变而通之以尽利也。易云。吉凶以情迁。注云。吉凶无定。唯人所动。情顺乘理以之吉。情逆违道以蹈凶。故曰吉凶以情迁也。易云。是故爱恶相攻。而吉凶生焉。即今疏。云吉凶存乎爱恶。则爱恶是吉凶之因也。易云。远近相取而悔吝生。情伪相感而利害生。即今疏。云忧喜存乎利害利害存乎情伪。是则情伪为利害因。故注云。情以感物则得利。伪以感物则致害。则有忧喜。故利害是忧喜之因。故上易。云远近相取而悔吝生。意云。相取相资也。顺之则喜。逆之则忧。顺则利也。逆则害也。又次易云。凡易之情近而不相得则凶。或害之。悔且吝。今为顺逆之次第。不顺疏次。但晓易文疏文自了。爱恶尽下。彰灭吉凶忧喜所以。易虽无文乃易本意。即知无忧无喜方为大喜。无苦无乐为真乐耳

疏。慈云普阴材与不材皆凉等者。上句依庄子。下句依法华。材者可为栋梁成器之木也。不材无所堪也。庄子行于山中。见木枝叶盛茂。伐木者止其傍而不取也。问其故。曰无所可用。庄子曰。此木以不材。得终其天年。庄子出于山。舍于故人之家。故人喜命竖子杀雁而烹之。竖子请曰。其一能鸣。其一不能鸣。请奚杀。主人曰。杀不能鸣者。明日弟子问庄子曰。昨日山中之木。以不材得终其天年。今日主人之雁。以不材致死。先生将何处焉。庄子笑对曰。将处夫材与不材之间。然材不材之言。虽在庄子。意亦法华第三云。我观一切普皆平等。无有彼此爱憎之心。我无贪着亦无限碍。恒为一切平等说法。乃至云。贵贱上下持戒毁戒。威仪具足及不具足。正见邪见利根钝根。等雨法雨而无懈倦。即材与不材皆凉也。言三草者。小草中草上草。二木者。小树大树。以人天乘为小草。经云。或处人天转轮圣王释梵诸王。是小药草。二乘为中草。经云。知无漏法能得涅槃。起六神通及得三明。独处山林常行禅定得缘觉证。是中药草。菩萨为上草。经云。求世尊处我当作佛行精进定。是上药草。此通说大乘。为上以大乘登地已上慈阴义广。复加二树。七地已前为小树。经云。又诸佛子专心佛道常行慈悲。自知作佛决定无疑。是名小树。八地已上为大树。经云。安住神通转不退轮。度无量亿百千众生。如是菩萨名为大树。而言咸益者。经云。佛平等说如一味雨。随众生性所受不同。如彼草木所禀各异等

疏。足履影覆至若在下。苦七日之中身心安乐者。涅槃二十六说。如有怖鸽至身子影中犹自战惧。至佛影中坦然安乐。世尊履地去地四指。然当足下虫皆得生天。于如来所种少善根。如食金刚必至涅槃

疏。又总取偈意等者。上别配三句竟。今总取三句释因果。次第成言。乃有五对因果。一取初句上四字为因。第三句初二字是果。由佛身净令众生解脱故。二以第三句初解脱字为因。第二句为果。此是如来作用解脱。令众生得乐故。上为一对。三世无尽乐下。以第二句为因。第三句初解脱字为果。以世乐为因出世解脱乐为果故。四以第三句初解脱字为因。第一句初四字为果。佛证离障解脱。方能起于大用而现身故。上即第二对。五又佛身清净下。唯就初句自分因果。上四字为因。下三字为果。由佛身清净令物乐见无有厌足。六又以初句下三字为因。上四字为果。由物乐见自感净身。又众生若乐见则净身有果。若不乐见则净身无有果。即以利他为果故。上即第三对。七众生乐见下。以初句下三字为因。第二句为果。由乐见佛。天上人间常受安乐。八以第二句为因。初句下三字为果。乐见若得乐。乐见即有果。乐见若无乐。乐见便无果。上即第四对。九无尽安乐下。以第二句全为因。以初句上四字为果。由得无尽世乐故。终得清净之身。此举世尊因中修行之果。劝物亦然。十能现净业是无尽果者。即以第二句中下三字为因。第一句上四字为果。谓无尽乐即涅槃乐。安住涅槃能建大事。方便现净身。是故净身。是无尽乐果故。上释云。终获涅槃为无尽乐。则无尽乐言有其二种。一则出世如上所明。二连取一句。即世无尽乐。如纯陀施佛。果报无尽应不成佛。故约世乐说无尽耳。结云如是展转者。递互相成也

疏。欲为苦本者。法华云。诸苦所因贪欲为本

疏。次句明等电光者。下经云。通明无畏以为电光。谓十通十明十无畏等。皆称电光故云方便

疏。圆音之雷可以思准者。谓雷震百里。今周法界。二发生。云何为发。耽着禅味起大功用。是蛰虫发动。云何为生。令诸众生善根萌芽。未生令生

疏。自然朝宗者。谓百川趣海。如万国归朝。礼云。春见曰朝。夏见曰宗

疏。诸龙皆有四种热恼者。经论不同。然谤佛经说。如阿那婆达多龙王。三种过患皆悉远离。一者热沙不堕其头。二者不以蛇身行欲。三者无有迦褛罗鸟之畏。彼喻发菩提心离三界恶。然会之亦同。疏云。无鳞甲细虫而有风吹者。由有细虫故[馬*展]热沙。此二则同共风吹宝衣露身。即现复本身之耻。所以互有开合

疏。第四夜叉王下。前之十段长行偈颂委释。第十一段去。即摘难释。此下多不释偈。偈有难者。悬引释于长行之中。讲者自对会之

疏。住正道者则不分别是邪是正者。即净名入不二法门品中。珠顶王菩萨之言

疏。善者善之等。即借用老子云。善者吾亦善之。不善者吾亦善之。即德经也

疏。闻深不怖等者。即大分深义。所谓空也。闻说于空谓同断灭。故令人怖。故大品云。既非先有亦非后无。自性常空勿生惊怖。闻浅不疑者。浅谓涉事方便多门。则令疑惑。今知随宜何所疑耶。闻非深非浅。疑无所据。使身心茫然。今知非深为妙有。非浅为真空。离身心相方为勇猛。可造斯境。又此三句亦即三观。初空次假后中道。三句齐闻。一念皆会

疏。七城有三义。疏文有二意。先解长行城义。后有斯已下。会颂文。前中有三。初立城三义。二今言法城下。出城之体。三从各有三义下。别释教理行果。皆有防外敌等三。而四法为三。以理行合释。非理不显行。非行不显理。故初若了心城之性空。则众惑不入。是防外敌义。性空是理。谓自性净心不与妄合即理防外敌了空即行。众惑不入即行为城。名防外敌也

疏。见恒沙性德。则万行爰增。即是第二养人众义。恒沙性德是不空藏。是理所养。见即行体。万行爰增即行养人众义。以知法性本寂。有定慧等

疏。道无不通则自他引摄者。第三开门引摄义。道无不通言含二意。一理即是道。无不通故。即开门引摄。二行契于道则无所不通。故能引摄二利之行

疏。便能下。第二约果城说三义。果由理行成故云便能。即契果位三德。为涅槃城之三义矣

疏。方显教城下。第三由上三城皆因能诠故方显教功。三义可思

疏。有斯多义下。二会释偈文。重重四门者。且第一重即是四句。谓一有门。二空门。三亦空亦有门。四非空非有门。天台以斯历于四教。则有四个四门。略如前玄谈中辩。今且于一重四句中。更有四重四门。然执着成见取。成四谤得意为门。今取门义。言四重者。一即单四句。如向所说二复四句。谓一有有有无。二无有无无。三亦有有有无。亦无有无无。四非有有有无。非无有无无。而言复者。四句之中皆说有无故。第三具足四句者。四句之中皆具四故。第一有句具四者。谓一有有。二有无。三有亦有亦无。四有非有非无。第二无句中四者。一无有。二无无。三无亦有亦无。四无非有非无。第三亦有亦无具四者。一亦有亦无有。二亦有亦无无。三亦有亦无有亦有亦无无。四亦非有非无有亦非无非无无。第四非有非无具四者。一非有非无有。二非有非无无。三亦非有非无有亦非有非无无。四非非有非无有非非有非无无。上四四一十六句为具足四句。第四绝言四句者。一单四句外一绝言。二复四句外一绝言。三具足四句外一绝言有三绝言。若为见释。上诸四见。一一皆有八十八使相应。是见即外道见故。若约佛法历四教。四门各生四见。又一种四句。各一绝言。如是一一亦各有八十八使。六十二见。百八等惑。若破诸见一一见破。一一成门故云重重四门。又重重者。如一有无门具诸四句。则历常无常我与无我等。亦有多四句。谓一有无常。二无无常。三亦有亦无无常。四非有非无无常等。又历万行。谓若布施等。如云一有布施。二无布施。三亦有亦无布施。四非有非无布施等

疏。复有一行是如来行。即涅槃第十一。至下当引

疏。如尸毗救鸽等。即智论第五。及报恩经等。皆本师本行。如常所知。自下第三诸神

疏。智了物心如空入色者。取下偈意。偈中如空。是喻光明之言。舍于法喻。余皆是法。法喻相对。略有三入。一以初句佛智为能入。第三句众生心行为所入。入者了达义。故八十经云。佛智广大同虚空。普遍一切众生心。悉了世间诸妄想。不起种种异分别。此即智了物心而云如空入色者。出现品云。譬如虚空遍至一切色非色处故。二言光照身器如日合空者。即以第二句光明为能入。第四句为所入。一切世间即众生世间及器世间。故云光照身器。即取上空喻为所入。取光明上法喻皆为能入。光通二种。身光照事。智光双照事理。三身遍器中如像在镜者。即唯取第四句。自有能所。则无不入言通三种入。一光入。二智入。如上已说。三身入。但言无不入。不拣身故。而言如像在镜者。将上如空普遍喻此亦齐。今傍出一喻以喻身入。质来对镜镜中见像。像是执像。机感对刹。刹中见佛。佛是心佛。从世间主力下。上是佛德。今摄归就神。故云能摄此身。从此身之性等世间故者。彰入所以。智身色身皆等世间。论云。智性色性皆相即故。皆入观机。彰入之意。并释普字结归长行。所入之处下。结归神名。以难见故。所以偏结。疏随缘非有之法身等。至第五经当释

疏。十有觉德行者。即毛诗注云。觉大也

疏。石室留影毒龙革心者。革变也。即观佛三昧海经。彼事极长。今当略意。即第七经佛告阿难云。如来到那干诃罗国古仙所止檐匐华林有毒龙池青莲华泉北罗刹石穴阿那斯山南。尔时彼穴有五罗刹。化作龙女与毒龙通。龙复降雹。罗刹乱行。饥馑疾疫已历四年。时王惊惧祷祀神祇。于事无益。下取意引。有一梵志赞佛功德。彼王焚香遥请如来。如来受那干诃罗王弗巴浮提请。广现神变。罗刹毒龙既受化已。尔时龙王长跪合掌劝请世尊。唯愿如来。常住此间。佛若不在我发恶心。无由得成无上菩提。世尊不离龙窟复受王请入城教化。游行往昔行菩萨道处。诸龙皆从闻佛欲还。复啼哭雨泪白佛言。世尊。请佛常住。云何舍我。我不见佛。当作恶事坠堕恶道。尔时世尊安慰龙王。我受汝请坐汝窟中千五百岁。释迦文佛踊身入石。犹如明镜人见面像。诸龙皆见佛在石内影现于外。尔时诸龙合掌欢喜不出其池。常见佛日。尔时世尊结跏趺坐在石壁内。众生见时远望则见。近则不现。诸天百千供养佛影。影亦说法。时梵天王合掌恭敬以偈颂曰如来处石窟。踊身入石里。如日无障碍。金光相具足。我今头面礼。牟尼救世尊。经文甚广。复令众生观于佛座。见丈六像坐于草座。作一石窟高一丈八尺。深二十四步。青白石想。又想此窟成七宝窟。见佛形像踊入石壁等。广弘明集。说远公有此石影赞。说处所与经全同云。在西域那伽诃罗国南山古仙石室中。度流沙迳道去此。一万五千八百五十里。感世之应备于别传。西域记第八亦说远公序云。昔遇西域沙门。辄餐游方之说。知有佛影。而传者尚未晓。然及在此山。值罽宾禅师南国律学道士。与昔闻既同。并是其人游历所经。因详其间。乃图之为铭曰。廓矣大像。理玄无名。体神入化。落影离形。回辉层岩。凝映虚亭。在阴不昧。处暗逾明。婉出蝉蜕。朝宗百灵。应不同方。迹绝杳冥(其一)。茫茫荒宇。靡劝靡奖。淡虚写容。拂空傅像。相具体微。神姿自朗。白毫吐曜。昏夜中爽。感诚乃应。扣机发响。留音停岫。津悟冥赏。抚之有会。功弗由囊(其二)。余如广弘明集。罽宾禅师即耶舍三藏疏。世人靡不有初等者。本即毛诗王注周易亦用此言。靡无也。鲜少也。克能也

疏。世人以人随欲者。书云。小人以人从欲。君子以欲从人。言不能兼亡者。亡无也。然两字相连。即庄子意。而亡字有心。则自他想忘。不恃己功也。今云兼于无道之人耳

疏。空有四义含于五法者。四义即无生等。五法即名等。今当先释五法。后消疏文。五法诸经论皆具。且依楞伽列次者。即名相妄想正智如如。以为其次。若瑜伽七十二云一相。二名。三分别。四真如。五正智。分别妄想异名。相谓言谈安足事处。名即于相所有。增语分别。谓三界行中所有心心所。真如谓无为法。无我所显圣智所行。非一切言谈安足事处。正智略有二种。一唯出世间正智。二世间出世间正智。释曰。上即根本。下即后得。此之五法为假为实。然相通假实。亦具假实二有。名唯假有。分别同相。以有三界心心所实法。故是实有。若虚妄计度故是假有。真如唯实有。二智俱实有。此五二谛何谛所摄。前三世俗有。真如胜义有。根本智胜义有。后得智通二有。五从何生。名从欲生。相与分别俱。从想分别生。真如无生智。从听闻正法如理作意生。此之五法为一为异。今且将相望余四法。论异不异者。一相与名异。若言其异。名应实有。若言不异。取相应得名。二相与分别若异。则分别应非相。若不异分别外相。应以分别为性。三相与真如若异。则相之胜义。应非是如。观者应舍相求如。正觉真如应不觉相。若言不异。真如无差别。相亦无差别。得相之时。应得真如。又得真如时。亦应得相。应不清净。四相与正智。如相与分别说。应知名与分别及正智。及分别于正智。皆当言异。余略可知。已知五法名相差别。今当消疏文。疏中。先以五法属文。后迷如下。辩因起融摄。言迷如以成名相则妄想是生者。此显迷时唯有三法。一名。二相。三妄想。故此五法通该一切。而不必同时。谓妄想正智。此必不并故。今有妄想决无正智。其如如名相。则有隐显。此中迷故。如如则隐。名相则显。次云悟名相之本如执翻成智者。此显悟时但有其二。一正智。二如如。既有正智决无妄想。了得如如。名相即隐。虽不坏相。举体即空。理夺于事无不荡尽。是故空中无色等法。故楞伽云。谓了名相及与妄想体本不可得。名为正智。如如即是名相。妄想本自不生。释曰。名相不生则境如矣。妄想不生则心如矣。了心境如是为正智。故唯正智。及如如存。次云。如外无智。智体即如者。复融上二。以为一味。如外无智。即以如摄智。智体即如。是以智摄如。合为一味。故下经云。无有智外如为智所入。亦无如外智能证于如。即斯义也。故疏结云。此二犹空寂照无碍。寂即是如。照即是智。如日合空。虽有二事一相难分

疏。十力降魔十军皆殄者。智论第六云。欲为汝初军。忧愁军第二。饥渴军第三。渴爱军第四。睡眠军第五。怖畏军第六。疑军为第七。含毒军第八。利养军第九。着虚妄名闻。自高军第十。轻慢于他人。汝等军如是。一切世间人。及诸一切天。无能破之者。我以智慧箭。修定智为弓。摧破汝魔军。如坏瓶投水。今以爱欲为水故偏语之。疏百窍异吹者。义则可知。事出庄子第四

经疏。日光合空等者。疏文有三。初总释。二开彰别释。三总结称叹。今初。先举喻。智符已下合。以智合日。以实相合空。符者。分而合也。实相体上本有智光。无始迷之今方朗悟。即我始会之。非照今有。故与实相分而合也。实相无边智亦无边。如空无际光亦无际。虽从旷劫修成全同本有者。以偈文会义也。偈云。亿劫修成不可思。求其边际莫能知。义乃修成。智无际耳。何得分而合也。故今答云。虽则修成。全同本有。是以经云。演法实相令欢喜。故疏结云。穷灵极数。即是修成。妙尽难思。即符本有。亦犹始觉同本觉。无复始本之异。为究竟觉。然穷灵极数之言。即肇论。刘遗民所难。般若无知论语。具云。但今谈者所疑。于高论之旨。欲求圣心之异。为谓穷灵极数妙尽冥符耶。谓将心体自然灵怕独感耶。若穷灵极数妙尽冥符。则寂照之名故。是定慧之体耳。若心体自然灵怕独感。则群数之应。固已几乎息矣。此公意云。若穷灵极数妙尽冥符。则是修极于无修。穷灵为照。妙尽为寂。亦是我之定慧。何用别立无知。若心体自然灵怕独感。则是体本无知。固合无乎应用。何以言般若无知。对缘而照故。结云。疑者当以抚会。应机睹变之知。不可谓之不有。论主答云。意谓妙尽冥符。不可以定慧为名。灵怕独感。不可称群数已息。两言虽异妙用常一。迹我而乖。在圣不殊也。释曰。观肇公答上句云。既冥符心体。何可以定慧为名。若以定慧为名。则未符心体答下句意云灵怕独感。与穷灵极数。二义相合。何得息于群数之应。故云两言虽异在圣不殊也。今疏总不用彼难答本意。借其问中一句。谓穷其灵鉴极其数运。妙无不尽。则合心体。今略申故难思耳。十义以辩难思。第二开彰别释。于中二。先别举十门之喻。后以智慧日照心性空下。总以法合。凭喻解法故云准思

疏。寂然不动以观机者。此言即周易系辞。具云。夫易无思也。无为也。寂然不动。感而遂通天下之故。今借此言也

疏。第一偈前半辩一相因果等者。疏文有二。先消经文。辩十身相。后引经论辩三身相。今初。言纯杂无碍因果相融者。然如来相亦具四句。一一因一相。二一因一切相。此皆纯门。三一切因一相。四一切因一切相。皆是杂门。正纯恒杂杂而常纯。故云无碍。由因相无碍。果相亦无碍。故得圆成非分成耳。以一切纯杂无碍之行。成一相故。故此一相即同法界。况因果交彻。因中有无尽之果。果中有难思之因

疏。若三十二相下。第二引经及论。说三身相。唯语化身。而总指在余。智论当三十二。瑜伽当四十九。涅槃当二十九。经云。善男子。若菩萨摩诃萨。持戒不动施心不移。安住实语如须弥山。以是业缘得足下平满如奁底相。若菩萨摩诃萨。于父母所和尚师长乃至畜生。以如法财供养供给。以是业缘得成足下千辐轮相。若菩萨摩诃萨。不杀不盗。于父母师长常生欢喜。以是业缘得成三相。一者手指纤长。二足跟修长。三其身方直。如是三相同一业缘。若菩萨摩诃萨。修四摄法摄取众生。以是业缘。得网缦指如白鹅王。若菩萨摩诃萨。父母师长若病苦时。以手洗拭捉持案摩。以是业缘得手足软嫰。若菩萨摩诃萨。持戒闻法慧施无厌。以是业缘得节踝佣满身毛上靡。若菩萨摩诃萨。以专心听法演说正教。以是业缘得鹿王腨。若菩萨摩诃萨。于诸众生不生害心。饮食知足常乐惠施。瞻病施药。以是业缘。其身圆满如尼拘陀树。立手过膝顶有肉髻无见顶相。若菩萨摩诃萨。见怖畏者为作救护。见裸露者施与衣服。以是业缘得阴藏相。若菩萨摩诃萨。亲近智者远离愚人。善喜问答扫饰行路。以是业缘。得皮肤细滑身毛右旋。若菩萨摩诃萨。常以饮食衣服卧具医药香华灯明施人。以是业缘得身金色常光照耀。若菩萨摩诃萨行施之时。所施之物能舍不吝。不观福田及非福田。以是业缘得七处平满相。若菩萨摩诃萨。布施之时心不生疑。以是业缘得柔软声相。若菩萨摩诃萨。如法求财以用布施。以是业缘。得缺骨充满师子上身臂肘佣纤。若菩萨摩诃萨。远离两舌恶口恚心。以是业缘。得四十齿白净齐密。若菩萨摩诃萨。于诸众生常修大慈悲。以是业缘得二互相。若菩萨摩诃萨。常作是愿。有来求者随意给与。以是业缘得师子颊。若菩萨摩诃萨。随诸众生所须之食悉皆与之。以是业缘得味中上味。若菩萨摩诃萨。自修十善遍以化人。以是业缘得广长舌。若菩萨摩诃萨。不讼彼短不谤正法。以是业缘得梵音声。若菩萨摩诃萨。见诸怨憎生于喜心。以是业缘得目睫绀色。若菩萨摩诃萨。不隐他德称扬其善。以是业缘得白毫相。善男子。若菩萨摩诃萨。修习如是三十二相业因缘时。则得不退菩提之心

疏。正因令显如出金藏。即涅槃经。如贫女家中宝藏之喻

疏。了如不取则心绝动摇者。金刚经云。不取于相如如不动

疏。须弥可倾魔岂能娆者。即高僧传中慧嵬禅师之事。云林修定有一恶鬼而现其前。有身无首令禅师惧。公安然不惧。而慰之言。喜汝无头痛之患。次现无腹之鬼。复云。喜汝无五脏之忧。如是随来随遣。竟不能惑。魔又化为天女云。天帝令我以备扫洒。公曰。我心如地难可倾动。无以革囊来相见试。天女乃腾空而去。赞曰。大海可竭须弥可倾。彼上人者执志坚贞。今用一句。义意全同

疏。以慈善根力放月爱光者。慈善根。即涅槃第十五经云。复次善男子。菩萨四无量心。能为一切诸善根本。下广说慈心行施。发起大愿竟云。善男子。一切声闻缘觉菩萨诸佛如来。所有善根慈为根本。善男子。菩萨摩诃萨修习慈心。能生如是无量善根。谓不净观等。皆从此生。结云如是等法。慈为根本。善男子。以是义故。慈是真实非虚妄也。若有人。问谁是一切诸善根本。当言慈是。以是义故实非虚妄。善男子。能为善慈者。名实思惟。实思惟者。即名为慈。慈即如来。慈即大乘。大乘即慈。慈即如来。善男子。慈即菩提道。菩提道即如来。如来即慈。次广说慈德是一切善法。下广说慈德。如提婆达多欲害如来。令阿阇世王放护财醉象。我即入慈定举手示之。即于指端出五师子。即便怖畏。举身投地敬礼我足。善男子。我时手指实无师子。乃是修慈善根力故。令彼调伏。广说缘起。皆悉结归慈善根力。次放月爱三昧光。即涅槃二十经。尔时世尊在双树间。见阿阇世王闷绝躄地。尔时世尊大慈道师。为阿阇世王入月爱三昧。入三昧已放大光明。其光清凉往照王身。王身疾愈郁蒸除灭。乃至王问耆婆。何等名为月爱三昧。耆婆答言。有六义似。一譬如月光能令一切优钵罗华开敷鲜明。月爱三昧亦复如是。能令众生善心开敷。是故名为月爱三昧。二如月能令行路欢喜。此三昧能令修习涅槃道者欢喜。三一日至十五日光色渐明。此则能令善根增长。四十六日至三十日形色渐减。此则能令渐灭烦恼。五能除郁蒸。此则能除贪嗔恼热。六如月众星中王。甘露一味人所爱乐。月爱三昧亦复如是。诸善中王甘露一味。一切众生之所爱乐。是故复名月爱三昧

疏。佛以正法金錍者。即涅槃第八。迦叶菩萨白佛言。世尊。佛性者。云何甚深难见难入。佛言。善男子。如百盲人为治目故造诣良医。是时良医。即以金錍抉其眼瞙。以一指示问言见不。盲人答言。我犹未见。复以二指三指示之。乃言少见。善男子。是大涅槃微妙经典。如来未说亦复如是。无量菩萨虽已具足行诸波罗蜜乃至十住。犹未能得见于佛性。如来既说即便少见。是菩萨摩诃萨既得见已。咸作是言。甚奇世尊。我等流转无量生死。常为无我之所惑乱。善男子。如是菩萨位阶十地。尚不了了知见佛性。何况声闻缘觉之人能得见耶。泽州苑公。及延法师。广有配释。今并不用。且泽州释云。十地菩萨各修十度。名为百人涅槃为金錍。经初一说名一指示。中间重说名二指示。经末后说名三指示。下合中未见佛性。并如前盲人。若俱经教则錍指不殊。若以涅槃为所诠者。又不顺喻。所以不依。延公云金錍喻教。抉瞙者。教能生解。喻破无明。即今疏意。故名正法金錍。而言三指者。喻三僧祇乃至十地。未了分明故言少见。若准泽州则涅槃为錍。三说为三指者。若俱约教。则錍指不殊。若以涅槃为所诠者。又不顺喻。宁取延公。约以三僧祇为三指者。亦顺前示及与后示。亦顺十住少见之言。今不取者。遂令佛说一时之中不具三指。又以时喻指。以未全同故

疏。自释以三谛为三指。指为旨趣。义甚分明。一时横观皆观三谛。竖至十地亦证三谛。第一指者。即示俗谛。言凡是有心定当作佛皆有佛性。二者示真谛为第二指。云佛性者。名第一义空。三示中道为三指。经云。佛性即是无上菩提。中道种子故。非有如虚空。非无如兔角。故知三谛喻于三指

疏。悟如日照等者。楞伽经中有四渐四顿。今唯用一。彼经大慧白佛言。世尊。云何净除自心现流。为顿为渐。答中先明四渐。后说四顿。渐。经云。佛告大慧。渐净非顿。一如庵罗果渐熟非顿。如来渐除众生自心现流。亦复如是。渐净非顿(此喻十信)二如陶家作器。渐成非顿(十住)三如大地渐生非顿(十行)四如习艺渐就非顿(十向)上之四渐。约于修行未证理故。下之四顿。约已证理故。一明镜顿现喻。经云。譬如明镜顿现一切无相色像。如来净除一切众生自心现流。亦复如是。顿现无相无所有清净法界(喻初地至七地)二日月顿照喻云。如日月轮顿照。显示一切色像。如来为离自心现流习气过患众生。亦复如是。顿为显示不思议胜智境界(喻八地已上)三藏识顿知喻云。譬如藏识顿分别知自心现流及身安立受用境界。彼诸依持佛亦复如是。顿熟众生所处境界。以修行者安处于彼色究竟天(此喻报佛)四佛光顿照喻云。譬如诸佛所化依佛光明照耀。自觉圣趣亦复如是。被于法相有性无性恶见妄想。照令除灭(亦喻法报前喻顿成此喻顿照)今疏唯取顿中一日光顿照喻。虽举镜喻非是明镜顿照。自取拂镜之喻。正同大通时时勤拂拭莫遣惹尘埃。而复自融通。又上四渐四顿多依地位。古今同为此释。亦顺经文。今释通于横竖。则位位之中皆有顿义。然约横论。顿复有多义。一顿悟渐修。如见九层之台。则可顿见。要须蹑阶而后得升。今亦如是顿了心性。即心即佛无法不具。而须积功遍修万行。此约解悟。二者顿修渐悟。即如磨镜一时遍磨明净有渐。万行顿修悟则渐胜。此约证悟。三顿修顿悟。如利剑斩丝。千茎齐斩一时齐断。亦如染千丝。一时齐染一时成色。故万行齐修一时朗悟。四渐修渐悟。犹如斩竹节节不同。此今非用。今言悟如日照。即解悟证悟皆悉顿也。即顿修顿悟。功如拂镜。亦非顿悟渐修。是顿修渐悟义。言明是本明渐为圆渐者。此融上二。恐人谓拂镜非顿。明镜本来净。何用拂尘埃。故为会之。此是六祖直显本性。破其渐修。今为顺经。明其渐证修随渐明皆本明矣。故云明是本明。即无念体上自有真知。非别有知知心体也。言渐为圆渐者。即天台智者意。彼有言云。渐渐非圆。圆非渐圆。谓渐家亦有圆渐。圆家亦有圆渐。渐家渐者。如江出岷山始于滥觞。渐家圆者。如大江千里。圆家渐者如初入海虽则渐深。一滴之水已过大江。况滥觞耶。圆家圆者。如穷海无涯底。故今云渐是圆家渐。尚过渐家之圆。况渐家之渐

疏。众生谄佞自不修德者。诗云。内有进贤之志。而无譣诐之心。苍颉篇曰。诐谓谄佞也

疏。如大璎珞经说。过去有佛凡欲说法令大众眠

疏。涅槃亦云。其人梦中见罗刹像。即第九如来性品。迦叶菩萨白佛言。世尊。云何未发菩提心者。得菩提因。佛告迦叶。若有闻是大涅槃经。言我不用发菩提心。诽谤正法。是人即于梦中见罗刹像心中怖惧。罗刹语言。咄善男子。汝今若不发菩提心。当断汝命。是人惶怖寤已。即发菩提之心。是人命终若在三趣及在人天。续复忆念菩提之心。当知是人是大菩萨摩诃萨也

疏。修慈护法故得金刚之体。亦涅槃意。彼第二问云。云何得长寿金刚不坏身。故以长寿品答长寿问。由不杀及施僧之食为因。金刚身品答金刚不坏身问。因于护法故。经初明金刚身义云。尔时世尊复告迦叶。善男子。如来身者。是常住身。不可坏身。金刚之身。非杂食身。即是法身下。迦叶难。次如来广答金刚身相。后迦叶征因云。唯然世尊。如来法身金刚不坏。而未能知所因云何。佛告迦叶。以能护持正法因缘故。得成就是金刚身迦叶。我于往昔护法因缘。今得成就是金刚身常住不坏。善男子。护持正法者。不受五戒不修威仪。应持刀剑弓箭[矛*牟]。槊守护持戒清净比丘。此后广说护法之相。便引往昔此拘尸城有欢喜增益如来。末法之中觉德比丘能师子吼。为破戒比丘刀杖所逼。时有国王名为有德。与破戒比丘共战。时王被枪举身周遍。觉德赞王。王闻法已即便命终。生阿閦佛国。为彼如来第一弟子。觉德比丘却后寿终。亦生彼国为第二弟子。故知能护功高所护。生公释金刚身云。长寿之与金刚。皆共谈丈六。但内外之异。长寿为外应之迹。金刚为内照之实。实照体圆故无方也。然则长寿金刚。并义通内外。而金色示灭故。以实照为常。实则至妙之色。亦常不变矣。然长寿对于凡夫之夭促。金刚对凡身之危脆。故无长无短方为长寿。非实非虚始曰金刚。而推其因由护法者。护法令法久住。获法身矣。今疏文中言修慈护法者。护法即涅槃文。修慈即今偈意

疏。教理行果皆有护也者。有毁谤教。不惜身命折伏护持。为护教也。得旨契理便为护理。修行无缺即为护行。此三若护正觉果圆。即为护果

疏。本迷无始犹若生盲。虽闻譬喻竟不识乳者。即涅槃经。然涅槃总有二文。一即二十八经。明八喻云。善男子。凡所引喻不必尽取。或取少分。或取多分。或复全取。如言如来面如满月。是名少分。善男子。譬如盲人初不见乳。转问他人言。乳为何类。彼人答言。如水蜜贝。水则湿相。蜜则甜相。贝则色相。虽引三喻。未得乳实。二者涅槃第十四经。南本十三。喻诸外道不识常乐我净。以四种喻。谓贝稻米末雪鹤。经云。如生盲人不识乳色。便问他言。乳色何似。他人答言。色白如贝。盲人复问。是乳色者如贝声耶。答言不也。复问。贝色为何似耶。答言。如稻米末。盲人复问。贝色柔软。如稻米末耶。稻米末者复何似。答言如雪。盲人复问言。彼稻米末。冷如雪耶。雪复何似。答言。犹如白鹤。是生盲人虽闻如是四种譬喻。竟不能识得乳真色。释曰。贝可喻常。米末可喻乐。雪可喻净。鹤可喻我。然经中前三。各从领解。而鹤一种略无领悟。应言如鹤动耶。然其四喻。皆是眼境。彼但身触。何能眼境知耶。非唯外道不知四德。智眼未开。空欲暗证。犹彼盲人触四境也。言唯佛出世方能晓之者。示其出世常乐我净。开其智眼了见分明耳

疏。梦是神游。汉武故事说。昔汉武帝欲试善元梦者。乃诈为梦云。朕梦见殿上两瓦化为鸳鸯飞空而去。是何征也。元梦者曰。宫中必有相杀暴死之者。帝曰。戏之耳。言未毕。监司奏云。宫人相杀。帝曰。朕实不梦而有征者何耶。对曰。梦是神游。陛下欲言。即梦也

疏。亦见闻之气分者。即智论五梦之中。见闻多故梦也。言五梦者。一热气多故梦火。二冷气多梦水。三风气多故梦飞空。四见闻多入梦。五天神与并。如下如梦忍

疏。如迦旃延为弟子现梦者。庄严论说。迦旃延有一弟子眉希罗王。舍王位出家。于山林中修道。有一邻国王名阿槃地。游猎至山。其王安寝。宫人诣王比丘所。比丘为其说法。王觉谓诱我宫人。遂鞭挞比丘。比丘痛苦心生怨恨。我不相犯非理见辱。遂欲还家为王伐彼国。师劝不止。便言且留一宿。明当任去。即留一宿。夜中迦旃延示之以梦。梦见还国。国人迎之却立为王。与大臣商议。征兵伐怨。而战败失道。遂被擒去。将欲刑戮。忽遇本师。本师告言曰。前苦相劝何为不从。此王梦中号诉师言。大师救命。失声便觉。悲涕白师。不复还家。是为迦旃延之善巧。觉化不得梦化便遂疏。空非独虚者。意云。非为无物处是虚空。出现品云。譬如虚空遍至一切色非色处故。住非分住一尘亦周者。如来纵在一尘之中。亦全法界之广大。身皆具在故。举芥子空证。已如前引

疏。果获五常者。疏文具列。即涅槃第二纯陀施食处说。下回向施食中当广明之

疏。受报无尽者。亦纯陀事。即三十一经。师子吼菩萨白佛言。世尊。如佛先告纯陀云。汝今已得见于佛性。得大涅槃阿耨多罗三藐三菩提。是义云何。世尊。如佛所说。施畜生者得百倍报。乃至。云施不退菩萨及最后身诸大菩萨。如来世尊所得福报无量无边。不可称计此不可思议。纯陀大士。若受如是无量报者。是报无尽。何时当得阿耨多罗三藐三菩提。此下广说施相。下佛答意云。如向难言。纯陀报无尽者。谓世间报体。然业有多种不必定受。随人所造愚智等殊。今纯陀大智。将此施业唯为菩提及利众生。云何今受人天之报。不得菩提。况所造业及受果报。皆是垂迹。若善若恶非现生后受是业报。下广说业有定不定愚智轻重。一切圣人为坏定业得轻报故。不定之业无果报等则报无尽者。是约世间。今疏为顺悉离贫穷故。引世间受报无尽耳。非取彼经师子吼菩萨之难意

疏。真妄相循难穷初后故者。若言先妄后真。真则有始。若谓先真后妄。妄由何生。若妄依真起。真亦非真。若妄体即真。则妄亦无始。为破始起立无始言。始既不存终从何立。无终无始岂有中间。故中论云。大圣之所说。本际不可得。生死无有始。亦复无有终。若无有始终。中当云何有。是故于此中。先后共亦无。真妄两亡方说真妄。真妄交彻无定始终

疏。闻空谓空则沈于漩澓者。大分深义。所谓空也。以空为空。虽深而沈矣。余三句亦然。不取空相则无所沈。何以故。空相不可得故。若复见有空。诸佛所不化。故空即有故。有等亦然

大方广佛华严经随疏演义钞卷第二十一大方广佛华严经随疏演义钞卷第二十二

        唐清凉山大华严寺沙门澄观述

第五经自下。第二同生众。疏谓不动真而成事者。即事理无碍为方便。如涉有不迷于空次。巧以因门契果者。即事事无碍之方便。因果交彻故

疏。竖通四上等者。并如世界成就品。略言竖者。即于一处有四上故。以法性之土为三土体。故本遍常自受用土。量周法界。一如法性。他受用土。及变化土。不离上二。犹如物影不离空及日光。而地受用及变化土。随心异见亦如两影互相涉入。故一尘中则有四土。横遍法界。即十方一切差别国土。横竖相融者。以竖融横。则一尘之中有十方国土。以横融竖。则一尘四土常遍十方。结成可知

疏。前半颂明总遍别中者。然则能遍所遍不离依正。依正各二。一总二别。全佛身为正之总。一毛孔等为正之别。一佛国土为依之总。一微尘等为依之别。今以前半佛遍尘中。故云总遍别中。言体用无碍者。上句是体。无去来故。下句是用。现诸土故。亦是总遍。总者身遍国故。余可思之

疏。如不入海安能得宝。即净名观佛道品。譬如不下巨海。则不能得无价宝珠。如是不入烦恼大海则不能得一切智宝

疏。经云。水银和真金。能涂诸色像等者。金如法身。水银如般若。以般若照机真身随感故。天台智者亦用此义。以释法华寿量应用

疏。若结跏趺坐身安入三昧等者。等取余偈云。威德人敬仰。如日照天下。除睡懒覆心。身轻不疲倚。觉悟亦轻便。安坐如龙蟠。见画跏趺坐。魔王亦惊怖。何况入道人。安坐不倾动。即第八论

疏。然三世平等下。重释善住三世平等智地。文中三。初指前标举。二且依下。别明义相。三依此释者下。结释善住智地之言。二中即正释三世平等。于中三。初唯约佛。如问明品十方诸如来同共一法身等。二唯约生。六道虽差皆三杂染。三若生佛相望下。生佛对说平等之义。于中二。先异时平等。后同时平等。前中先总言等。后此约三世下。别示义相。便引涅槃四出偈释。今先叙彼经。后方释疏。疏言四出偈者。四处出故。亦名四住。一即第十经中出。二即十七经。三即二十七经。四即二十八经。初段即如来性品。南经第九菩萨品。文殊师利白佛言。世尊。今此纯陀者。犹有疑心。佛征文殊。文殊师利言。纯陀心疑如来常住。以得知见佛性力故。若见佛性而为常者。本未见时应是无常。若本无常后亦应尔。何以故。如世间物本无今有。已有还无。如是等物悉是无常。以是义故。诸佛菩萨声闻缘觉无有差别。尔时世尊即说偈言。本有今无。本无今有。三世有法。无有是处。善男子。以是义故。诸佛菩萨声闻缘觉。亦有差别亦无差别。文殊师利赞言。善哉诚如圣教。我今始解诸佛菩萨声闻缘觉。亦有差别亦无差别。佛更不说。迦叶便请佛说。如来便为引长者[穀-禾+牛]牛之喻。以况佛性。乳色皆一如性无异。上第一出竟。第二出即第十七经梵行品。南经十五因为迦叶说无所得竟。迦叶领解。更欲请问无所得义。举佛先说本有今无偈。问如来。为答云。本有者。我昔本有无量烦恼故。以烦恼故。现在无有大般涅槃。言本无者。本无般若波罗蜜。以无般若波罗蜜故。现在具有诸烦恼结。此释上半。若有沙门婆罗门。若天若魔若梵若人。说言如来去来。现在有烦恼者。无有是处。此释下半。下略经意有二。一明本有父母之身。无金刚身。本无三十二相。具有四百四病。二云本有无常无我等。今无无上菩提。本无见佛性。今有无常等。总有八段。大意多同。皆明本有有世间妄因。今无无出世真德。本无无出世因。今有有世间妄法结云。我或知言不知。有相言无相。随宜化物耳。上即第二出竟。第三出。即二十七经。南经二十五。师子吼品。因说一切众生定得菩提。是故我说一切众生定有佛性。一切众生真实未有三十二相八十种好。以是义故。我说偈云。本有今无等。善男子。凡有有三种。一未来有。二现在有。三过去有。一切众生未来当有无上菩提。是名佛性。一切众生现在悉有烦恼。是故现在无有三十二相八十种好。一切众生过去之世有断烦恼。是故现在得见佛性。以是义故。我常宣说。一切众生乃至一阐提亦有佛性。未来有故。如有乳者问言有酥上。即第三出竟。第四出。即二十八经。南经二十六。因明食为命因。非即食为命。故说此偈本有今无等。五叙古人不得论意。释曰。上四处经偈意。大同而用小异。诸公多于第十经中。广释其相。远公引十七经意。释云。上二句自立道理。下二句破他定义。释上二句。一同第十七经。释下二句云。此文语略。亦合云三世无法。亦无是处。意云。于佛烦恼昔有今已断竟。故三世有法无有是处。涅槃昔无今已证竟。言三世无法。亦无是处。于众生反此可知。故无一法三世定有。三世定无。此意明必互有互无。次通难意云。佛今现证有异二乘。故非无差。彼亦当得。则亦无差别。此答文殊疑。又云。佛今已证。何得难言。后亦无常。释曰。此通纯陀疑。诸公大同此意。则成此偈。但是三世有无之法。如何能通纯陀之难。难意正云。由见佛性而为常者。见既有始。后必当终。如世间物有已还无。今明证见。何能通此。若超悟法师说答疑意。意则善成。是生公意。但是我始会之。非照今有。而其释偈亦多同远公。将偈答难。亦不顺理。荐福即用本有今无。论意出二种疑。释偈下半。亦同远公。不得论意故非尽理。六正会论意。今先出论意。后出经中四出别意。今初。先定本有今无之法。谓烦恼业若是生得名本。解脱圣性是修得是今。释曰。今此正顺十七经本有烦恼。今无涅槃等。故论云。为二乘说。不谤大乘。若为大乘说。是谤大乘。意云。此是随相之法。是三世有法。迷悟之殊是无常法。可化二乘。非是大乘涅槃真性。上定本今之法。次正说偈意。论云。此偈有二意。一破邪义。二立正义。破邪义者。依语言说。立正义者。依于义说。不依语言。然邪复有二。一者外道。二者小乘。上三句。是邪小所立之法。第四句。总非云无有是处。初外道者。谓本有。同僧佉因中有果。本无。同卫世因中无果。三世有。同勒沙婆因中亦有果亦无果。皆有多过故。云无有是处。二破小乘者。如向所说。为小乘说烦恼本有。为大乘者说过三种义。谓若烦恼本有。为真谛有为俗谛有。若真谛有。前后无异烦恼不可断。若俗谛有。俗谛无本何名本有。言本无今有者。若本无者后不应有。若本无法而得有者。空应生华。诸本无法皆应当生。若三世共有。居然不成。三世相违故。故下结云。无有是处。则破小乘说三世有法无有是处。已破邪义。所言立正义者。本有今有过于三世。是名正义。本有今有者。从初发心至得涅槃。一味无异。不依生因。不依灭因。有则清净。凡夫法不能染污。圣人法不能清净。乃至过一切语言道及一切思惟。不可说不可思惟。摄受因果非因非果。如来一体最极摄受一切妙宝。是大涅槃超过三世。为说涅槃功德乃至常乐我净。复次有二种义。若本有今有。则是常见。若过三世则是断见。若二义相待。成离断常。是中道义。如是俗谛真谛相待故有十二因缘真实。何以故离二边是真十二因缘。若能善解。则见如来现在于世。释曰。此后一段。复融性相令其无碍。余广如论。已知论意。今将论释经之疑。论云。纯陀有二因缘故疑。一纯陀见同相。不见异相故生疑。二文殊见异相。不见同相故生疑。皆是权为物疑。然若别配。初疑即经中纯陀疑。后疑即文殊疑。然此二疑文即影略。实即二人俱有此疑。故云纯陀有二种疑。今初。云何见同。谓纯陀将本无今有疑。同本有今无疑云。佛本不见佛性。后见佛性而得常住。岂非本无今有。本无今有。即是生法。生法必灭。故是无常。即与世同。故云见同。云何不见异。不见如来契无三世异于凡小。故今举异答云。约缘始会。以本无今有。菩提之性不属三世。智契此性。同性是常。何得难言。有始必有终是无常耶。纯陀疑心。自兹遣矣。若通文殊疑者。文殊见异。不见同故疑。谓见三乘迷悟差别。今同二乘无常尽灭即无差别。此名见异生疑。云何不见同。不见同无三世故。今答云。契无三世。一得永常。何得同于二乘无常。无三世性则无差别。会与不会则有差别。上根一闻二疑顿遣。中下未悟。迦叶起悲。梵行品中因无得问。佛举八段。八段之中皆悉结云。三世有者无有是处。斯无得矣。二十七经。因说一切众生定得菩提。是当有义。是故说言有三种有。一未来有。二过去有。三现在有。明此三有。亦约迷悟。佛性菩提岂属三世。二十八经。食为命因。非即是命如佛性为因非即是佛。亦是三世因缘之法。随相而说。若随相取亦无是处。释曰。上来判释四出之偈。理无不尽。次当解释今疏用意。按十七经本有今有。皆约于妄。故本无今无并约于真故。故云我本有烦恼。今无涅槃。本无般若。今有烦恼。所以尔者。约佛昔因故。及二十七经。则云众生过去有断烦恼因缘。今见佛性。则是真法本无今有。故纯陀生疑。正约世尊。因见佛性本无今有为难。是知若真若妄。皆通本有今无本无今有。故疏取经意及彼论意。故约生佛相望真妄并说。又十七经约佛昔说故。即以佛昔时为本。亦以昔时为今。例于众生。则以今时为本。亦以今时为今。如佛昔有烦恼无异。皆是影略。后释疏。今疏。取意。则以昔为本。现在为今。言烦恼。佛则本有今无者。以佛昔为凡夫则有烦恼。今成正觉故无烦恼。言众生则本无今有者。约性净故本无烦恼。约客尘故今有烦恼

疏。菩提则众生本有今无者。亦约性净菩提本有。今为客尘之所覆故。迷真起妄无有证得圆净菩提。故云今无耳。言诸佛则本无今有者。约圆净菩提。昔未修成故云本无今已修得故云今有。上来已显彼偈上半

疏。约迷悟异下。释偈下半。然准论意三句皆相。第四一句拂去上三。方为真性。今疏以第三句总牒三世。第四句遣之。故云下半显性。取文小异。全是论意。云何约迷悟异等。谓迷时有妄。非是无。真悟时见性。性非今有。故生公云。但是我始会之。非照今有。照不在今。即是莫先为大。既云大矣。所以称常。是知迷悟虽异。涅槃之性三世不迁。湛然常住会即符契。同彼性常如始觉同本。无复始本之异。何得难言有始必终。则纯陀之难遣矣。疏若以性净下。第二约同时平等。正是前偈下半之意。以离三世性故现今平等。而不妨迷悟之殊者。即是论主末后融其性相。令离断常。若相外有性。性为断灭。相是定常故。离迷悟无别真性。因乖常故。有三界无常。因解无常之实性故。成常智二理。不偏照与之符。犹悬镜高堂万像斯鉴。经引二鸟意在此也。是故三乘亦有差别亦无差别。即是涅槃。文殊领解性无二故。故无差别。迷悟浅深故有差别。则文殊之疑遗矣。文殊之疑既遣。迦叶之疑亦亡。余如上论。众生寂灭即是法身下。示于亦有差别亦无差别之相。言众生寂灭即是法身者。生不异佛。法身随缘名曰众生者。佛不异生则无差别矣。次言寂灭非无之众生恒不异真而成立下。一对。明无差不碍差。寂灭故无差。非无众生故不碍差。恒不异真成上寂灭。而成立言。成上非无之众生。随缘非有之法身。恒不异事而显现者。随缘故佛不异生。非有之法身。则不碍异生。恒不异事成上随缘。而显现言成上非有之法身。从是故染净下。总以融结。疏况称性互收者下上但事理无碍。已是难思余经容有。此则事事无碍。唯华严意。如是下结释可知。此上一义乃似傍来。涅槃玄旨于是乎见也。疏九会五周之文等者。指此上一经。一化随宜。则始从鹿苑终至双林。一乘三乘场地顿演。何况如来言说之耶。第七金焰菩萨中十力章

疏。下诸经文屡明十力下

疏。文分三。初立章所由。二然大般若下。广指他释。三今略以下。开章释文。今初。即七门中初门。恐言当宗贵其名相故。总出斯意。文有五意。一经文多故。解斯一节。余处例然。二是不共德。三佛佛等有。此二是瑜伽二门。四菩萨缘此发心。即十住品。则不识十力。如何发心。五梵行令观。不了十力非真梵行

疏。今初立意者。疏文有四。一总显立意。智论即二十七。二如来唯一下。成十所以。三由时下。成多所以。四度人因缘下。说十之由。三中即瑜伽中分别门。然瑜伽亦说七门。与此小异。一自性。二分别。三不共。四平等。五作业。六次第。七差别。前有二门。今有分别。云何分别。瑜伽云。由三分别。当知无量。一由时分别。谓堕三世一切所知。随悟入故。二由品类分别。一切有为自相共相。一切行相随悟入故。三由相续分别。谓诸有情各各差别。一切相续一切事义随悟入故。四说十之由可思。二释名中瑜伽即四十九。自性中五十七。即决择分。五次第中分四。一通列诸文之次。二且依下。依论明次。三瑜伽多门下。指广在余。四上来下。会经之次。三中言多门者。论云。如来初成正觉。即顿证得十种智力。后方次第逐一现前。谓初起处非处力。观察诸法。建立一切无倒因果。既观察已。次起自业智力。谓有希求欲界胜果。方便为说。令离不善故。若有希求世间离欲之道。教授令趣禅定功德。故起定力。若诸有情希求出世离欲法者。为说出世之道。谓于此中先起根力。观根胜劣。次观彼根。为先所有意乐。次观意乐。为先所有随眠。既知根欲及随眠已。次令于所缘中而得趣入。次由于所缘趣入门。加行摄住心已。净修行已。为说中道令离断常。谓宿命除常。天眼除断。次令永断一切烦恼及诸习气起漏尽力。更有异门次第。恐繁不引

疏。七释文中。疏文有三。初总辩宗意。二第一偈下。正释。三然上十力下。重以诸门料拣。二中一一文内。皆分为二。先名义。后释文。名义中或二或三。至文当知。今第一力中有三。一释名。即因果相当名之为处。若不相当名为非处。二其作业者下。即作业。第二偈业力中。初释名。二与初何别下。次辩差别也。初力约所造。自业约能造。此犹未了。云何能所。谓以人望业已杀等竟。此杀等业必招于果。名为所造。此人若行于杀必堕地狱。此名能造。即上自业。各随善恶而感果故。即是作业。第三偈根力中。先释名。及能于彼下。二明作业。其于此正知。向上释智力字。向下释能作业下皆准之。第四胜解智中。初释名。二令舍下。作业。三此与前下。三辩差别。此有二解。一约宿现起别。故智论云。以二种欲作上下根因缘故。十地论中别叹根欲。如有根无欲。能解不乐。有欲无根。虽闻不解。二论云下。二即瑜伽拣依根起乐即是根力。正分别欲乐即名解力。第五界力中。先释名体。二性即种子下。辩差别。于中二。先正释。后解妨。今初。先引智论。于义可知。后引瑜伽。应有问言。胜解力中亦知彼解当成此种与此界性有何别耶。故疏答云。照解起种即是解力。但照种子即是界力。然智度论。即明种现内外之殊。瑜伽即解兼种现性唯种子

疏。若习欲成性下。二解妨。此对智论若依性起欲义如前说。若习欲成性。则欲前性后。复云何别。故以宽狭通之。则欲狭性宽。言欲唯大地一数者。此即俱舍颂。通大地十法云。受想思触欲。慧念与作意。胜解三摩地。遍于一切心。今即十中第五欲也。言性通诸数者。既有贪等八万四千心所。则广数即心所。次引智论。帖成正义疏。若性即种子下。对根辩异。于中有二。先约宽狭正通。后以信等望果下。通于前伏难。难云。性既宽通。何不名根。答云。特由宽故不得名根。以信等望果。三乘圣道有胜用增上。可得名根。性无此能安得名根。上正显竟。后三善根下。举况以成。三善根是善。尚不得名根。性兼贪嗔等。何可得名根。言三善根者。但是翻三不善根。立三善根名不同信等。体相昭著故不立为根。且依一义。若根通二十二根。则所望不同耳。根约胜用增上。性约不改

疏。谓非唯佛智如空等者。此有二种。超胜之相。寻常界力。但以佛智能知能所不同。今云佛智平等如虚空。则众生之界。皆是如来智中之物。此为一胜二者智能包纳。犹是智类。今毛孔顿现。则细色能收。良以色性智性融无碍故。以性融相。为华严宗之界力也。第六至一切处道力中。先释名体。若出离行不出离行者。标也如行有漏下。别显。瑜伽又云。如贪行者修不净观等。名遍趣行。又趣一切五趣之门。或诸外道沙门婆罗门。各各异见品类诸行。或此世他世无罪趣行。名遍趣行。名下之事即为作业。二若知如是下。次辩差别。先对界辩异。意云从性起行。即属性摄。但观其行即属趣行。次初力下。对初力辩异有二义可知。然对他辩自。自亦作业。第七偈禅定力。初释名。瑜伽名为净虑解脱等持等至智力。佛善知下。结成智力。即为作业。二此与下。二辩差别。此中有问云。自业有三。一罪二福三不动。不动业即是禅定。与此何别。亦应答言。业通定散。今唯约定。居然不同今疏所通是瑜伽意。若唯知定体。即是自业。知定体用便是禅力。第八偈宿住力中。初名兼显作业。二瑜伽下。辩差别也。谓有问言宿住智中知彼修因。则与遍趣何异。答中有三。初依瑜伽正答。谓唯知因是遍趣行。兼能知果。即宿住摄。言名姓苦乐等事者。瑜伽知过去所有自体。有八言说句。一如是名。二生类。三种姓。四饮食。五受苦乐。六长时。七久住。八寿量边际。今但列三。等取余五。二此与智论下。引智论难。三故应通云下。疏家为答。瑜伽为对下。出瑜伽宿住无有因。意。若以等字收之。于理可也。第九偈天眼力。初释名。亦即作业。二知前际下。辩差别可知。文中五眼十眼。并如离世间品。第十偈漏尽力中。初释名。即为作业。二文中下。释文。以漏尽无滥故不辩差别。余习有四。谓贪嗔痴慢。贪习如迦留陀夷。嗔习如身子。痴习如周利槃特。慢习如毕陵伽婆蹉。曾无有教说见疑习气。见有习气不见理故。通说或有耳

疏。然上十力下。第三重以诸门料拣。于中二。先会六释。后显功能。前中先总名中。但云智力。即持业释。若云十力。即带数释。二此中宿住下会别名。宿住名邻近者智近于念故。言宿住亦依主者。宿住境之随念故。二然此十力下。辩功能可知。十力略义亦已释周。更欲广引。恐翳玄理

疏。佛威神力者。略有三种者。即当瑜伽四十七中。彼有二类。初列三种云。一圣威力。二法威力。三俱生威力。次又云。复有五种。一神通威力。二法威力。三俱生威力。四者共声闻威力。五不共二乘威力彼广释相。今疏引三而不依彼次。及至释文二处参用。风不动衣等。即五中俱生。俱生有多。谓佛菩萨常右胁卧。如师子王。虽现安处草叶等蓐一胁而卧。会无动乱。一切如来应正等觉。虽现睡眠而不转侧。大风卒起不动身衣。行如牛王步如师子等。今但云风不动衣等。等取余事。五中望三。神道即圣威力共与不共。但显超胜。疏中皆含二处法威力。疏中云。谓波罗蜜圆满法力。即是语因。从令五根中下。辩其果相。彼法威力中。诸度各有四相。一断所对治。二资粮成就。三饶益自他。第四辩果果各不同。施得大财宝朋党眷属。戒生人天。忍临终之时心无忧悔生于天界。进得爱乐殊胜士夫功业。定得神通生静虑天。慧果能离烦恼所知二种重障。上瑜伽中多是近果。又是别明。今是究竟之果。又是总明。无诸非净即离系果。百节有力是施等果。坚因不坏是戒度果。故普眼长者。以十度因成十身果。言遍十方下。疏以经文会上果义。余义广如论文

疏。二有十颂别显下。疏文分二。先总释经文。后十度之义下。立章广释。此中立章。多依唯识第九

疏。安住菩萨种性者。若依五性则拣余四性。唯取菩萨种性。今法性宗。约习以成性。非约本有本有平等故。故摄论中。但有六种最胜。无初安住。或云菩提心摄。则知唯约习所成者。然无性引颂。亦似证有安住种性。颂云。鳞角喻无有六波罗蜜多。唯我最胜尊。上品到彼岸。此最胜尊义似初一。然依此释。亦是习成非约本有。五疏谓要无相智者。即三轮空也。故离世间品云。三轮清净施。施者受者及以施物。正念观察如虚空故。疏六回向最胜。问既言回向菩提。何异依止。释曰。彼有道心未必一切回向菩提。此乃回向。又依止者。即行前心。今回向者。乃行后愿

疏。七清净最胜者。谓要不为二障。间杂者。约分说耳。通说清净为离二障。行于六度耳。言谓三时无悔者。此乃大乘法师释论意也。悔即烦恼由不了故。即是所知。又即此悔心障于真智。亦所知也

疏。四句分别者。有三四句。一者一一自望种类而有四句。施中四者。一是施非度。不与七胜相应施故。二是度非施。随喜他施具七胜故。三亦施亦度。具七胜施故。四非施非度。随喜他施。不与七胜共相应故。二者不约种类次第修者。以明四句。唯施一种。但有二句。未成余度。阙二句故。谓是度非施。及非施非度。余戒等五。得有四句。前有施度。得为是度非戒等故。谓一是戒非度。谓不与七胜共相应故。二是度非戒。即前施度具七胜故。三亦戒亦度。具七最胜而持戒故。四非戒非度。谓前布施不具七故。忍度望戒。进度望忍。次第如戒。三非次第修者。诸度各得具于四句。如施得望戒忍等度。得有是度非施等句故。可以思准。此上释度。即彼论疏明相门也。谓显波罗蜜多相故。故此论初云。此十相者要七最胜等

疏。四建立等者。即彼第四无增减门。疏文有三。一明十无增减。即建立十度之所以也。二立六所以。三重显十义。初中为治十障者。即异生性等十无明也。至下十地具明。今略列名。一异生性障。二邪行障。三暗钝障。四微细烦恼现行障。五于下乘般涅槃障。六粗相现行障。七细相现行障。八无相中作加行障。九利他中不欲行障。十于诸法中未得自在障。若准对法十二云。所知障等。皆度所治。故云为治障故

疏。为对六蔽下。第二立六度所以。于中总有六门。一对治六蔽门。即上一句。言六蔽者。一悭吝蔽。二犯戒蔽。三嗔恚蔽。四懈怠蔽。五散乱蔽。六恶慧蔽。亦有师言。离恶慧为五成十度障。大乘法师不许此义。上来十度及与六度。皆是第四无增减门

疏。渐修佛法者。即第二渐修佛法门。故唯识云。渐次修行诸佛法故。诸佛法者。谓十力等。摄论云。前之四度不散动因。第五一种不散动成就。第六依是如实觉知

疏。渐熟有情者。即第三渐熟有情门也。唯识云。渐次成熟诸有情故。摄论云。由施能摄受。由戒能不害。由忍虽遭苦能受。由勤助彼所作。由定心未定者令定。由慧已定者。令得解脱

疏。六中前三增上生道下。第四二道之因门。施感大财。谓多饶财宝。戒感大体。谓尊贵身。忍感眷属。有情归附。由富胜形及多眷属。趣中增上。名增上生道。道亦即因。言能伏烦恼者。谓修善方便故定熟有情者。依此发通故。慧成佛法者。佛法由慧故。有此三德名决定胜。诸菩萨道唯有此三。若阙一种道不成故

疏。又前三种饶益。有情等者。第五利生断惑门。故瑜伽论七十八解深密等说。由二因缘。是故六度不增不减。即其义也。施财摄彼。戒不恼害。忍受彼恼。此三皆通有饶益故。后三言勤修加行者。瑜伽云。由精进故。虽未永断烦恼。永害随眠而能勇猛修诸善品。彼诸烦恼不能倾动。善品加行。故唯识云。虽未伏灭。而能勤修治善法加行。由静虑故永伏烦恼。由般若故永断随眠。是故疏云永伏永灭。对法十一亦有此解

疏。又由前三者故不住涅槃等者。第六为无住涅槃因故。以前三是大悲饶益有情故。后三是大智断灭诸惑故。故为无住涅槃因也。翻彼凡小之双住也。又复三学摄于六度故不增减。瑜伽四十九说。前四是戒。后二是定慧二学故。由上七义故立六度。此第七义疏略不明

疏。后唯四者下。第三重显十义。谓有问言。六度既尔。后四云何。此答意云。四属六摄。义随六异。于中分二。先总明。后方便助前三下。别显。大论七十八云。由前三种。所摄有情以诸摄事。方便善巧而摄受故。意云。巧用施等以摄物也

疏。愿助精进者。大论云。由正愿故能破羸劣意乐。烦恼微薄起精进修。言力助静虑者。深密云。若诸菩萨亲近善士。听闻正法如理作意。为因缘故。转劣意乐成胜意乐。亦得上界胜解。名力波罗蜜多。由此力故于内心住有所堪能故。说力度助于定也。言智助般若者。彼经云。若诸菩萨已能闻法因缘善修习故。能发静虑如是名智。由此智故。性能引发出世间慧。故说智为慧助。是以后四助于前六。令前六度修习圆满。前六不能助于后四。第五次第门。此曲有四。一引发门。二摄持门。三粗细门。四难易门。兼通结上。今初。疏云。谓由前前引发后后者。即初引发门。谓由行施引发持戒。由持戒故引发于忍等。及由后下。二摄持门者。布施本欲益他。持戒不恼于彼弥令施净等。故云。及由后后持净前前。三又前前下。粗细门者。布施则粗。持戒则细。戒望于忍。戒则为粗。忍则为细等。故云前前粗后后细。前九并为前前。从戒至智并名后后。一一相望故致重言。初一唯前。后一唯后。中间八度递为前后。四易难修习下即难易门。亦结通上三也。上之四门。并如瑜伽对法所辩

疏。六相摄门等者。疏文有二。先总明十互相摄。后明六十相摄。前中文三。初总明。次般若论下。引证。三会今意。二中先引般若。后引智论。前中言资生无畏法等者。等取下半云此中一二三是名修行住。谓施有三种。一财。二无畏。三者法施。财即资生。正是檀度。故云此中一也。无畏摄二谓尸不恼彼。忍受彼恼。皆无畏相。故云二也。法施摄三。谓进定及慧。决定胜道渐熟佛法。是法施相。故云三也。即十八住中。修行住也。三今此经文下。会释今意。是圆教故。非唯要约相顺相类。以理融故。法尔一摄一切行也

疏。若但说六下。第二明六十相摄。若六度摄十度。第六摄后四。若十度摄六度。第六但摄第六。少分有所未尽。不摄后得加行智故。故兼后四。方摄第六。是故疏云若开为十。第六唯摄无分别智。第七修证中五位通修者。谓此一门亦名为位。今云修者。以五位通修故名为修。佛方究竟故名为证。故二十一种功德之中。有波罗蜜多成满功德。然唯识云。五位皆具。修习位中其相最显。通漏无漏。广修行故。故十地中各一圆满。疏十约因位下。即分位分别。显于三劫得名不同。初但名波罗蜜多者。以一行中修一行故。二名近者。一行之中修一切行故。近菩提故。三广大者。一切行中修一切行故。体包博故。然未入劫同于第一。已成佛竟同于第三

疏。八约教可思者。谓小乘不成波罗蜜多。无七最胜故。始教要是菩萨种性人方有故。又各有体性。或说俱空。终教一一皆从真如性功德起。顿教一一皆不可说。谓不施不悭。不戒不犯。不忍不恚。不进不怠。不定不乱。不智不愚等一切皆绝。若十若六皆悉亡言。圆教如文

疏。九观心可以意得者。谓一念相应心舍则具十度。舍而不取为施。不为取所污即戒。忍可非有为忍。离身心相为进。寂然不动。为定。决了无生为慧。虽空不碍智相为方便。希齐佛果是愿。思择不动为力。决断分明为智。一念方等十度顿圆。纵七最胜亦在一念。可以思准。欲令行者即之于心。是故结云何以意得

疏。十释文中一一偈。疏多皆有四。一释名二出体。二辩相。四释文。唯识并在一处出体。云谓施以无贪及所起三业为性。戒以受菩萨戒时三业为性。忍以无嗔精进审慧。及彼所起三业为性。精进以勤所及起三业为性。静虑但以等持为性。后五皆以择法为性。为有说是根本后得智故。辩相亦并居一处。今随文配属。以义相映易了知耳。今初施度。初名可知。二即以下出体。无贪即善十一中一法。要由无贪相应思。于自身财方能慧舍故。然三施体大意多同。疏二戒中初名防其未起非。止已起恶故。二即受学下。次出体。大论律义。以七众别解脱戒在家出家戒为体。即唯二业。谓表无表。下说语故。若摄善法戒者。谓诸菩萨受律仪后。一切所作为大菩提。由身语意积集诸善。以为其体。今疏通三聚及与受随。故云三业。摄众生戒。居然通三。戒有三种下。三释文也。即当辩相。律者法律。仪者仪式。于不善法而能远离及防护故。故摄论名为依持戒。依是能有集诸佛法无罪益生故。疏三忍者。初名二。即以下出体。无嗔精进。即善十一中二。审慧即别境五中慧。所以有此三者。大论云。自无愤勃不报他怨。亦不随眠流注相续。是名菩萨耐怨害忍。即以无嗔及三业为性。若安受苦忍。即精进三业为性。若谛察法忍。即审慧三业为性。故三业通于三忍。余三各配其一。故有三耳。三忍亦有三下辩相。四偈言下。释文。然无性云。初忍是诸有情成熟转因。二是成佛因。寒热等法皆堪忍故。三是前二之所依处。堪任甚深广大法故今言色相圆满是前二忍果者。由忍他辱生端正故得依色相。言皆圆满者。究竟成佛具诸相故。故此四字是二忍故。光通智光故是第三

疏。精进中名。二以勤下。出体。通三精进。即善十一中之一数也。三亦有下。辩相。被甲即大誓愿。摄善即方便进趣。利乐即勤化众生。四初句下。释文。言通前二者。勤修二字故是摄善。多劫海言。即是被甲。被甲相隐故引论释

疏。五禅中初释名。静拣散心。虑无慧。止观均故。二即以下出体。三摩地虽是别境心所之一。今约定说。不通散心故。不说三业。对法论云。所起三业自在用时。所有一切种常安住。即通三业以约用故。三亦有三种下辩相。言安住者。安住现法乐住故。无性云。离见慢等得清净故。言引发者。引神通故。言办事者。成办利有情事故。四既引发下释文。取上辩相以释经文

疏。第六般若中。初释名。二此及下出体。以后五体同故。故唯识云。后五皆以择法为体。说是根本后得智故。意云。以根本智为第六体。后之四体皆后得故。此依胜说。若对法及瑜伽四十三。同以出世间加行正智后得为体。唯识下文亦云。十度皆通漏无漏故。依此实义。三亦有三种下。辩相。总有三说。唯识依十度。唯取根本。摄论三智约六度说。缨络三观亦约十度。约兼正说故。有照空照有照中道。是以疏云三观之义至下当明。谓十行当会。四慧导万行下。释文。谓万行不得般若照。体空寂不成彼岸故。因如有目者。智论云。五度如盲人。般若如有眼。故能明见夷途开道万行。御心中道至一切智城。即其义也

疏。七方便中。初释名。二下四下。辩相。先总显下四。此依唯识。若约本业亦各有三。至十行品说。后今初下。别明此度。谓由大智故。回前六度向大菩提。由大悲故。回前六度拔济有情。故无性云。不舍生死而求菩提。三文云下释文可知

疏。八愿中初释名二。有义下出体。前虽总出。此一有异故。复别用此三为性。三法正是愿之性故。谓愿者希求。希求即欲。要于前境正信印持。方希求故。其后得智但是所依。依此起愿耳。欲及胜解。别境中二也。三内初下。释文。疏九力者。初名。二亦有下。辩相。三今言下。释文。初即无性释论之言。故摄论下。本论之语

疏。十智度初名。二亦有下。辩相此相难见故引论释。但引释论。本论但云。谓由前六成立妙智。受用法乐成熟有情。若天亲云。由般若波罗蜜无分别智故。故成立后得智。复由此智成立前六波罗蜜多。由此自为与同法者。受用法乐成熟有情。大意亦同。瑜伽四十九云。于一切法如实安立清净妙智。名智波罗蜜多。当知能取胜义名慧。能取安立名智。又三十九云。谓无量智。当知方便波罗蜜多。希求后后殊胜性名愿。一切魔怨不能坏名力。如实觉了所知境名智。大意皆同。然上辩体。约克实性体。若兼助伴。一一皆以一切俱行功德为性。三经云下。释文可知。若广分别如唯识疏第十及瑜伽四十二

疏。恐厌繁文者。谓仁王下卷奉持品中说。伏忍下中上。下忍初贤一僧祇。中忍次贤两僧祇。上忍亚圣三僧祇。初地四僧祇。乃至七地有十。八地千。九地万阿僧祇。十地百万阿僧祇。故地前已经三阿僧祇。经中多说三阿僧祇成佛者。以下中忍位菩萨相隐。上贤之位菩萨相显。所以特言经三僧祇。地前菩萨二乘圣者。见初入地皆谓究竟故。说三祇成等正觉。亦佛随宜故。宝云经云。实经无量阿僧祇劫。华藏品初当广会释

疏。得妙观察平等性智故者。由破分别我执。第七不与四惑相应。成平等性已证真如。于多百门已得自在。成妙观察。未舍异熟识体。不得大圆镜智。异熟既存。眼等五根是异熟生故。亦未得成所作智。此二直至佛果方得

疏。世间中极者。前三地寄同世间故

疏。离身见者。寄出世间初。同须陀洹故。又初地断分别身见。四地断俱生身见

疏。十平等心故曰等门者。三十六经。入五地有十心。一过去佛法平等清净心。二未来。三现在。四戒。五心。六除见疑悔。七道非道智。八修行智见。九于一切菩提分法上上观察。十教化一切众生。皆有平等清净心。言疏谛法俗境者。良以十重观四谛故。四地出世。五地却入。云观俗境

疏。得十空三昧者。即六地末云。佛子。菩萨住此现前地。得入空三昧。自性空三昧。第一义空三昧。第一空三昧。大空。合空。起空。如实不分别空。不舍离空。离不离空。句句皆有三昧之言。结云。得如是等十空三昧门为首。百千空三昧门皆悉现前

疏。今自狭之宽者。娑婆为狭。华藏为宽也

疏。诸天重重下。通妨难。难云。既言华藏地动。华藏之地乃在大莲华地面。今娑婆界当第十三重。曾何是地。设若是地是娑婆地。即非华藏故。今通云。乃有二意。一以本该末。谓通举华藏总该利网故。二十重皆华藏内。况第十三下。岂非地耶。二又染净融故下。染净交彻。通摩竭之地便是金刚。染净既融。是故一动一切动也

疏。余如别章者。即教义分齐中明。谓智论引长阿含第二云。有八因缘。一大水动时动。二尊神试力时动。三如来入胎时动。四出胎。五成道。六转法轮。七分教。八涅槃时。九依增一二十八。更加大神足。比丘心得自在。乃至观地无相故令地动。十智论云。授菩萨记。当于此界作佛之时。地神喜故。所以动也

疏。地论有四非当今文者。第十二论云。器世间中依四种众生聚。一依不善众生。二依信种种天众生。三依我慢众生。四依咒术众生。为此众生。下中上次第差别故动。乃至吼如十八句。异义应知。如是生信功德。今言非当今文者。始成正觉便演一乘。皆是海会何有不善等。据别行经顺别机故。论为此释

大方广佛华严经随疏演义钞卷第二十二大方广佛华严经随疏演义钞卷第二十三

        唐清凉山大华严寺沙门澄观述

    现相品第二

疏。四分之中已明教起者。四分即举果劝乐生信等分四。以四分科。第一会名举果劝乐生信分。六品分三。初品明教起因缘分。次二品明说法仪式分。后三品正陈法海分。初分已竟。次有说法仪式。二品经来。此是四分科中。第一分内。三分之中第二分来。举其大科。故云四分之中。对前序正流通三故

疏。以从多说者。此通妨难然有二妨。一云以文从义科中。名所信因果。经中复有遮那品。因何以问答相属科中。但名举果劝乐生信分。随其本会科中。但名说佛依果会耶。故此答云。以多说果以因少故。如河少水亦名无水。如乳有水但名为乳。劝物信乐宜举果故。第二妨云。上云举佛依正二果劝物信乐。何故随会。但言说佛依果会耶。故此答云。多说依果少说正故。亦以本意在于依果。正报之果第二会去。方始说故

疏。二品名者下。疏文分三。初总明。二然如来现相各有五义下。别释。三如是等下。总结。二中先释如来。后释现相

疏。涅槃三十二亦同此说者。即是北经。是树提伽长者父之亲友。赞佛功德。复问佛。云何名如来。佛云长者。如来世尊。于一切法知见无碍故。名为佛。发言无二故名如来。断烦恼故名阿罗诃。世尊所说终无有二。释曰。无二即无虚妄也

疏。转法轮论云。第一义谛名如等者。即第二论

疏。此与成实大同者。成实云。乘如实道来成正觉。故曰如来。乘如实道。即第一义来。成正觉即正觉名来。以如实道亦通万行。故言大同

疏。若理若智等者。若理即第一释。若智即第二释。若开即双明前二。若合者第三释。其第四释义通理智。亦兼开合。谓例大品云。诸法如即是佛。诸法如则无来无去。此则唯约理释。二云心无动摇。智绝真妄。则约智说无有来去。三若以心无来去。方契如如体无来去。则通合说故。但判为离相释耳。以离一切相名诸佛故

疏。现相五者下。二释现相。然五各二句。一句辩相。一句辩意。如一云现面门光相者。辩现相也。召十方众者。即彰所以。下四例然

疏。即以佛果无边刹海。具三世间无尽自在者。然华藏品。犹似有边有金刚轮山。莲华刹故。此外更有别刹海故。而彼文云。法界无差别已无边矣。况世界成就品云。十方刹海叵思议。佛无量劫皆严净。为化众生使成熟。出兴一切诸国土。又偈中云。所说无边众刹海。毗卢遮那悉严净。世尊境界不思议。智慧神通力如是。则刹无边矣。言具三世间者。无边刹海即器世间。毗卢遮那遍兴。即智正觉。刹网所持如来所化。即众生世间。言自在者。三种世间互相即入。隐显重重皆无碍故。故华藏偈云。华藏世界所有尘。一一尘中见法界。宝光现佛如云集。此是如来刹自在。故无尽之义。即是无边。况三皆称性。所以无尽

疏。初会标果起因者。举果即是标果。劝乐生信即是起因

疏。第二会等者。次第修因。即是寻因契果。即为至果

疏。果无差别者。第七当会答者。当字去声而有二义。一对上六会不同。今但第七一会中答。由第七会六品是因。不言一会答也。二者不对前六。但第七会中六品因圆。五品果满。与因同会故云当会。当因圆中即明果满。故云当会。此中应有问云。若果无差别。何不别一会答。故今答云。欲显因圆便得果满。故当会答。若更别会。便与因圆不相摄故。故前六品。望前是因。望后是果

疏。然诸会更有问者下。通妨。为有问言。九会之中皆有问答。何判唯四。如第二会中十首相问。第三会中正念天子及天帝释俱问法慧。第四会中精进林问。功德林答。第六会中解脱月问。金刚藏答。第七会中大众念问如来功德。岂非问耶。唯第五会中无别问答耳。何得独判唯四会问。故今答云。并当会别义耳。言以总收别者。第二会问。但十信收。第三会问。即十住收。第四会问即十行十藏所收等。故云以总收之。或重明于前者。如不思议法品十问。但重举第二会初后十问耳。谓已答因竟。将欲答果。因果悬绝故。于果初重复念请。亦表果德是所重故

疏。第八会明因果纯熟者。初会已信。次七已解。故云纯熟

疏。行修无碍下。彰当会答由。由二义故当会答之。一行修无碍故。谓取前六位所修之行。诸位通修不随位局。故云无碍。既没位名则无优劣。故当会答。二者六位顿成设尔有位。一时顿成异乎约解。差别因果故。一会答。此云当会者。当会问答

疏。第九会明称性因果者。谓既证法界。则异前八。前八但明于信及解行故

疏。四处都有下。结成问数

疏。初两会果广因略为成信解故者。初会四十句问。初二十句问果。次十句通问因果。唯后十句问因。故云因略。第二会四十问。唯第二十句问因。余三十句皆是问果。故云果广。初会为成于信。举果令信故。第二会为成于解。果相难知故广举之

疏。第九会问全同初会。而因举主佛之因者。此中十因。皆云一切菩萨。即通余也。法界中十因。但云显示如来往昔趣求一切智心。往昔所起菩萨大愿等。故是主佛之因。言明因是果因等者。释成第九举主佛因义。谓因是得佛竟。因非是菩萨正修之因因果皆证入故

疏。交络相望应成九句者。一言请言答。二言请示相答。三念请言答。四念请云相答。五言请言及示相答。六念请言及示相答。七言念请言答。八言念请示相答。九言念请言说及示相答。初四以单望单。次二以单问对复答。次二以复问对单答。后一复问复答。今会正当第九。第二会即第六句。第八会即第一句。第九会即第四句

疏。第五疑之权实。疏文分三。初征起。次有云下。序昔说。后然此经中下。申正义。非斥权实为不当理。但成缘起有异昔人。言此事旧尔者。法界之中法尔有此疑与答故。言海印顿现者。疑之与答。皆佛现故。由上二义故。疑答皆常。其犹像模者。假以喻显。以模喻疑。以像喻答。像因模有。答假疑成

疏。皆希佛境等者。总收上三。皆希佛境。即上实疑。并欲利生。即是权疑。成缘起门即是正义。故入大乘论第一偈云。薄福之人不能生疑能生疑者必破诸有。疏二云何下。正显问端。疏文有二。先科判。后准义二文下。料拣。而有二重。光明影略。后辩因果。前中亦二。先正明。后故下偈中下。以义成立。引二文证故一引偈文。直尔问中。已具列故。二引后会。彼中引例。同此直请。彼中直请。同此引例。二文相对。则直尔引例。皆合四十。其义明矣。言正欲显于下。结成上义。既引例直问。皆具四十。明是道同佛道。既同知文影略所以。要此二势问者。直请以尊主佛。引例为显道同故

疏。又四十句中。初二十句问果。下二因果料拣。于中三。初正明。二前是所求下。示为三意。三分是举果下。通妨。此有二妨。一对上言因是所行。理合在前故。今答云。分是举果故先问果。二据斯下。对科文难。既义有二节。何不分三。以义从文。故分为二。二段之中皆有结故

疏。故此三事合则可一等者。可一故没。可三故出。此文无能摄取中。摄于自在及与神通。法界品中。复以自在。摄于神通及无能摄取。亦合有于神通摄无能摄取及与自在。问中略无。余经则有

疏。言佛地者下。疏文有四。初出体。二辩类。三释名。四结示。今初。言即智德者。正是出体。非断德故。言分位者。便彰地义

疏。然此经宗下。二辩类。自宽之狭总有五重。一无量法界融故。二略有十者显无尽故。三然体不出。五者克实体故言具。如佛地经等者。即五法摄大觉性。谓一真法界。四智菩提。又论第一释佛地名云。地谓所依所行所摄。即当所说清净法界。大圆镜智。平等性智。妙观察智。成所作智。受用和合一味等事。是佛所依所行所摄。故名佛地

疏。然要唯有二下。第四摄五为二。五法之中四是智故。金光明云。唯有如如及如如智。独存名法身故

疏。融而无二者。第五摄二为一。谓无有智外如。为智所证。亦无如外智。能证于如故。融无二。又融无二者。总融五节。为无障碍如来地矣

疏。并有生成住持功能故名为地者。三释名此有三义。一能生万德。二成熟自他。二任持万德。万德依住故。如下十地中明

疏。此句为总下。四结示。结示是总。总持诸德及示答文

疏。二佛境界下。诸句皆别明佛智之德者。疏文分三。初对总彰别。二言境界下。牒名辩体。三广亦无量下。约类开合。亦有五意。一广无量。无有一境非佛境故。二略有十种下。寄圆说十。于中二。先正说三种十。然后出现多明体遍等者。拣三处不同。谓出现品。即五十二云。佛子。菩萨以无障无碍智慧。知一切世间境界。是如来境界。知一切三世境界。一切刹境界。一切法境界。一切众生境界。真如无差别境界。法界无障碍境界。实际无边际境界。虚空无分量境界。无境界境界。是如来境界。佛子。如一切世间境界无量。如来境界亦无量。如一切三世境界无量。如来境界亦无量。乃至如无境界境界无量。如来境界亦无量。如无境界境界一切处无有。如来境界亦如是。一切处无有等。释曰。此即明体遍义也。言多明者。一切处无有。亦显深义也。言不思议品以辩超胜者。即四十六经。所谓一一切诸佛一加趺坐。遍满十方无量世界。二一切诸佛说一义句。悉能开示一切佛法。三放一光明悉能遍照一切世界。四于一身中悉能示现一切诸身。五于一处中悉能示现一切世界。六于一智中悉能决了一切诸法。无所挂碍。七于一念中悉能遍往十方世界。八于一念中悉现如来无量威德。九于一念中普缘三世佛及众生。心无杂乱。十于一念中与去来今一切诸佛体同无二。是为十。上八句。初皆有一切诸佛之言。释曰。既一念能为无尽之事。故云超胜。问明该其因果者。即十三经问有十一。谓一何等是佛境界。二何等是佛境界因。三度四入五智六法七说八知九证十现。十一广。上九皆有何等是佛境界之言。初一是总。二即是因。智证知广。四句皆体。余五皆用。偈中答云。如来深境界。其量等虚空。一切众生入而实无所入。此双答总及广二句。又云。如来深境界。所有胜妙因。亿劫常宣说。亦复不能尽。此即答因。余如彼文。上三虽同佛境。说意小殊。故云小有不同。谓佛即境者。分齐谓如来所成。一切功德智慧等是佛所有。如一国境属于当国之王。而菩萨不测。唯佛得故言佛之境者。真如实相真俗二谛等。是智所缘境故。云所观众生。国土等是佛悲所化境故。云所观化等。略有十种者。此含二段。一即四十六经。十种为众生作佛事。何等为十。所谓一一切诸佛示现色身。为众生作佛事。二出生妙音声。三有所受。四无所受。五以地水火风。六神力自在示现一切所缘境界。七种种名号。八以佛刹境界。九严净佛刹。十寂寞无言。皆上一切诸佛下。有为众生作佛事之言。故下开为三类中。三加非情作佛事等。二即四十七。十种大那罗延幢勇健法故。疏结云。今此加持即是神力及法云地者。即十种持。经云。又如实知佛持法持僧持业持烦恼持时持愿持供养持行持劫持智持。如是等皆如实知。离世间品者。即五十八经云。所谓初始能发菩提之心。佛所摄持。二于生生中持菩提心令不忘失。佛所摄持。三觉诸魔事悉能远离。四闻诸波罗蜜如说修行。五知生死苦而不厌恶。六观甚深法得无量果。七为诸众生说二乘法。而不证取彼乘解脱。八乐观无为法而不住其中。于有为无为不生二想。九至无生处而现受生。十虽证得一切智。而起菩萨行。不断菩萨种。皆有佛所摄持之言。一如加持者。如此类甚多。谓化现多身随所乐见碎身舍利。一兴供养千返生天。全身舍利如多宝佛。即是如来力持身也。如出现品医王留身喻等。二如加耆婆者。即涅槃第三十。南经二十八经云。我于尔时往瞻婆城。时彼城中有大长者。无有继嗣。供事六师以求子息。于后不久其妇怀妊。长者知已。往六师所欢喜而言。我妇怀妊。男耶女耶。六师答言。必是其女。长者闻已。心生愁恼。复有知识来谓长者。何故愁恼乃至是耶。长者答言。我妇怀妊未知男女。故问六师。六师见语。如我相法生必是女。我闻是语。自惟年老财富无量。如其非男无所付嘱。是故我愁。知识复言。汝无智慧下取意意引广赞佛德。令问世尊。长者即至佛所。问佛言世尊。我妇怀妊。六师相。言生必是女。是事云何。佛言长者。汝妇怀妊是男无疑。其儿生已福德无比。六师闻已心生嫉妒。乃以庵罗果和合毒药。授其长者。令其妻服语云。若服此药儿则端正。产者无患。服已便死。送至城外以火焚之。如来知之。便往冢间。长者难言。所言无二可名世尊。母已终亡。云何生子。我言长者。汝于尔时都不见问母命长短。但问所怀为是男女。诸佛如来发言无二。是故当知。定必得子。是时死尸火焚。腹裂子从中出。端坐火中。犹如鸳鸯处莲华池。我于尔时寻告耆婆。汝往火中抱是儿来。六师止之。耆婆言。如来使我入阿鼻地狱猛火炽然。尚不能烧。况世间火。尔时耆婆前入火聚。犹入清凉大河水中。抱持是儿还诣我所。授儿与我。我授儿已。告长者言。一切众生寿命不定。如水上泡。众生若有重业果报。火不能烧毒不能害。是儿业报非我所作。长者请佛立字。佛言。是儿生于猛火之中。火名树提。应名树提。尔时会中见我神化。无量众生发阿耨多罗三藐三菩提心。故云如加耆婆入火。则入火之言。兼于二事。一如向所说。二如耆婆所言。佛令入阿鼻地狱猛火不烧。复有一缘。即令入地狱问提婆达多事也

疏。四佛所行。疏文有三。初正释名。次辩类。三拣滥。疏或说十种下。二辩类。于中初约行化释。后约所行释。今初。十种化不失时者。即第四十六经云。佛子。诸佛世尊有十种化不失时。何等为十。所谓一切诸佛成等正觉不失时。二成熟有缘。三授菩提记。四随众生心示现神力。五随众生解示现佛身。六住于大舍。七入诸聚落。八摄诸净信。九调恶众生。十现不思议诸佛神通。皆上有一切诸佛。下有不失时言

疏。亦是所行之行等者。二约所行释。于中又二。先引文二。或大悲摄生下。类释。今初。谓无碍行是如来行等者。即五十二经云。佛子。菩萨摩诃萨。应云何知如来应正等觉行。佛子。菩萨摩诃萨。应知无碍行是如来行。应知真如行是如来行。佛子。如真如前际不生。后际不动现在不起。如来行亦如是。不生不动不起。下举鸟飞虚空前后无际。况真如行。金翅辟海喻无碍行。广如下辩

疏。或大悲摄生下。二例释亦成上义。大悲摄生即无碍行。大智造缘即真如行。无思成事成上二义。亦该通所缘

疏。约人望行下。第三拣滥。以经云如来所行滥于境界。是悲智所行故。于中初正拣后引证。谓佛是能行故。悲智之行是所行。非如于境悲智是能行。真如众生是所行也。故云约人望行摽云所行

疏。况所望不同者。上行通能所。境唯局所。已是不同。设同取悲智行。约所行以用悲智境。约能行以用悲智。如人望子名父望父名。子一人二用。岂相滥耶

疏。若准瑜伽下。第二引证。以释二相不相同。经当第五。五界全同瑜伽。然瑜伽全写深密为论。今引瑜伽引经者。欲双引经论故

疏。谓广大力等如不思议法品者。即四十七云。佛子。诸佛世尊有十种。广大力。最上力。无量力。大威德力。难获力。不退力。坚固力。不可坏力。一切世间不思议力。一切众生无能动力。大那罗延幢勇健法。何等为十。所谓一切诸佛身不可坏等为一。此上十力遍于十种勇健法。广如彼文。今略举其名。一身命不可坏力。二毛孔容持力。三毛持大山力。四定用自在力。五常遍演法力。六德相降魔力。七圆音遍彻力。八心无障碍力。九法身微密力。十具足行智力。一一力中有多义。理具于下文

疏。离世间品说。有十种无畏者。即第五十六云。佛子。菩萨摩诃萨有十种无畏。何等为十。经文浩博。今当义引。谓一闻持无畏。二辩才无畏。上二。不畏不能答难。三二空无畏。此不畏妄念。四威仪无缺无畏。五三业无过无畏。上二不畏外讥。六外护无畏。此不畏天魔外道。七正念无畏。不畏遗忘。八方便无畏。不畏生死。九一切智无畏。不畏二乘。十具行无畏。不畏不能化生

疏。或说四种者。即十藏品辩。谓一一切智无畏。二漏尽无畏。三出障道。四出苦道

疏。未必全尔者。非不许昔解。但显义包含耳

疏。如师子频申等者。下六十一经。略列百门。初名普庄严法界三昧。二名普照一切三世无碍境界三昧。最后。云师子频申三昧。结云。以如是等不可说佛刹微尘数三昧。入毗卢遮那如来念念充满一切法界三昧大神变海

疏。略说十种如不思议品。说佛有无量不思议三昧者。即四十七经云。所谓一切诸佛恒在正定。于一念中遍一切处。普为一切众生广说妙法。二普为众生说无我际。三普入三世。四普入十方广大佛刹。五普现无量种种佛身。六随诸众生种种心解现身语意。七说一切法离欲真际。八演说一切缘起自性。九示现无量世出世间广大庄严。令诸众生常得见佛。十令诸众生悉得通达一切佛法无量解脱。究竟到于无上彼岸。每句皆有一切诸佛恒在三昧。于一念中遍一切处之言。一如初句

疏。或说有十如十通品者。一他心智通。二天眼智通。三知过去劫宿住智通。四尽未来际劫智通。五无碍清净天耳智通。六无体性无动作。往一切佛刹智通。七分别一切言辞智通。八无数色身智通。九一切法智通。十入一切灭尽三昧智通。广如经文。疏不思议品云。一切诸佛有无边际。无碍解脱示现无量大神通力。义引经文。无碍解脱一句牒经。示现无量大神通力。显此解脱是神通解脱。如净名不思议解脱。能以须弥内芥子等。故经云。何等为十。所谓一切诸佛能于一尘。现不可说不可说诸佛出兴于世。二转净法轮。三众生受化调伏。四诸佛国土。五菩萨受记。上五皆有一切诸佛。能于一尘。现不可说不可说言。一如初句。下五句但无不可说不可说言。余同上有。谓六现去来今一切诸佛。七现去来今诸世界种。八现去来今一切神通。九现去来今一切众生。十现去来今一切佛事。释曰。既皆一尘顿现。明是大神通力

疏。十通唯局菩萨者。欲生下六通。通二乘故。六谓天眼天耳他心宿住神境漏尽

疏。广有无量者。历事别明故。疏或说百种者。即五十六经。初列十门云。佛子。菩萨摩诃萨有十种无碍用。何等为十。所谓众生无碍用。二国土无碍用。三法四身五愿六境界七智八神通九神力十力。皆有无碍用言。下九释。一一各有十门。故成百也

疏。略有十种。谓命自在等者。即五十五经末云。佛子。菩萨摩诃萨有十种自在。何等为十。所谓命自在。不可说劫住寿命故。心自在。智慧能入阿僧祇诸三昧故。资具自在。能以无量庄严。庄严一切世界故。业自在。随时受报故。受生自在。于一切世界示现受生故。解自在。于一切世界见佛充满故。愿自在。随欲随时于诸刹中成等正觉故。神力自在。示现一切大神变故。法自在。示现无边诸法门故。智自在。于念念中示现如来十力无畏成正觉故。是为十。若诸菩萨安住此法。则得圆满一切诸佛诸波罗蜜。智慧神力菩提自在

疏。不思议品亦说有十等者。即第四十六云。何等为十。所谓一切诸佛于一切法悉得自在。明达种种句身味身。演说诸法辩才无碍。是为诸佛第一自在法。下略取意。上即法自在。二心自在。三胜解自在。四财自在。五命自在。六如意自在。七智自在。八业自在。九受生自在。十愿自在。然上二经与八地全同

疏。十无能摄取。疏文二。先释名。二略有十下。辩类。于中二。先依晋经佛最胜法释

疏。如不思议品诸佛有十种最胜法者。即四十六经。此顺晋经佛最胜法言。故引此文。经云。所谓一切诸佛大愿坚固不可沮坏。所言必作言无有二。二为欲圆满一切功德。尽未来劫修菩萨行不生懈倦。三为欲调伏一切众生故。往不可说不可说世界。如是而为一切众生而无断绝。四于信于毁二种众生。大悲普观平等无异。五从初发心乃至成佛。终不退失菩提之心。六积集无量诸善功德。皆以回向一切智性。于诸世间终无染着。七于诸佛所修学三业。唯行佛行非二乘行。皆为回向一切智性。成于无上正等菩提。八放大光明。其光平等照一切处。及照一切诸佛之法。令诸菩萨心得清净满一切智。九舍离世乐不贪不染。而普愿世间离苦得乐无诸戏论。十愍诸众生受种种苦。守护佛种行佛境界。出离生死逮十力地。是为十。每句之中。上皆有一切诸佛之言。一同初句

疏。若取无能坏义等者。二依今经释大勇健法。前文已引。则义有两兼

疏。多在不思议法品者。亦有离世间等故致多言

疏。不思议法品。诸佛世尊有十种法。普遍无量无边法界者。即四十六经云。何等为十。所谓一切诸佛有无边际身色相清净。普入诸趣而无染着。二无障碍眼。于一切法悉皆明见。三无障碍耳。悉能解了一切音声。四鼻能到诸佛自在彼岸。五有广长舌。出妙音声周遍法界。六身应众生咸令得见。七意住于无碍平等法身。八无碍解脱示现无尽大神通力。九清净世界随众生乐现众佛土。具足无量种种庄严。而于其中不生染着十菩萨行愿得圆满智。游戏自在悉能通达一切佛法。佛子。是为如来应正等觉普遍无边际十种佛法。其一一句上。皆有一切诸佛有无边际言。一如初句但第五舌无无边际言。以广长替故

疏。离世间品各以十门辩释者。即第五十七经。谓十眼十耳等。十眼者。一肉眼。二天眼。三慧四法五佛六智。七光明。八出生死。九无碍。十一切智眼。其十耳十鼻等。广如彼文辩。然彼是菩萨眼等。而下结皆云则得佛眼等。故通因果。可释佛眼等

疏。出现品三业各十义者。身在五十经。语意在五十一。各有十义。并以十喻喻之

疏。常妙光明不可说等者。即四十六经。十种庄严中。第七庄严文云。一切诸佛皆有无量常妙光明。不可说不可说种种色相以为严好。为光明藏出生无量圆满光明。普照十方无有障碍。是为诸佛第七最胜无上常妙光明庄严

疏。然放光下。通伏难。恐有难言。若常光一寻。与放光异。今常光周于法界。何异放光。故为此通。疏而分别者下。亦通妨难。谓上通放光异常光者。则放光有时不放。今引相海常放。如何取别。故为此通

疏。佛智者广即无量等。随事无边故略说有十者。即如出现品。第五十一经明意业中。如来心意识俱不可知。但以智无量故知如来心。说有十智十喻是也

疏。体不出五者。即摄论佛地论。皆言五法摄大觉性。谓一真法界。四智菩提。则一是理而非是智。今清净智。即一真法界。清净智即本来智性。金刚顶瑜伽说有五智。初法界清净智。即一真法界故

疏。通明法界所安立海等。此有三释。初即疏意。而言通明者。谓世界海。唯约果说。法界安立海。通因通果。由起具因缘能安立法界故。二若因缘者。贤首云。所化生法也。复是一义。唯取化生之法。三亦是前二下。是第三义。安立众生世界。故前二即世界海及众生海。于中先正明。后安立。然安立言下。引梵文证。此是贤首引证。后二义法式。即化生法也。安立即第三义故。结云即安立法式。四佛海指不思议等品者。等取相海随好。皆佛德相用故。是妙觉故。五佛波罗蜜指离世间品者。以二千行法。一一皆到彼岸故。六如法界品者。佛亲证入离障解脱。及大作用皆解脱故。七指僧祇者。僧祇偈颂。广显佛德重重无尽广大用故。等即等于一经上下变化之文

疏。因德深广下。疏文有二。先正释经。后然此十句下。料拣。于中三。初标。二释。三结

疏。别则初二下释别。先以竖释别。诸位浅深故。言此约横论。一切菩萨者。结上别义。约所行位。信住等异。即是竖论。约能行人。一一位中摄多菩萨。故云横论一切菩萨

疏。若约通说下。二释通。约所行法。位位同修。即是通义。随约一人遍历诸位。皆修此十。即是竖论一切菩萨

疏。故此十句文通行位者。三双结也。别说寄位。通说约行。故疏四十句答文下。对问辩答。于中二。先标征。后通即诸会下。释相。先释通。后释别。通中二。先通相释。后总别释。前中文四。一正明通。谓九会通答故。二谓前众海下。立理。此有三理。一众海常随既通九会故。问答合通。二岂复下。众海智深能问尽故。三故知初会为总下。合总问故。以此三理问答合通。三而为分下释妨。谓前问言。若言众海问尽九会。九会同答。何以下文。复有三位。大问故为此通

疏。则显分分之中。皆通因果者。谓问虽互有广略。因果皆足。则是重问耳。四则从此尽光明下。正示答文疏。又就四十问下。二约总别释。十海为总。余三十句别。皆十海摄故。总答十海。已答余三十问。于中二。先正以九会答于十海。后问中为次下。以答对问。辩次不同。问中言。先有世界众生者。即标中本有三海。世界即世界海。及摄安立海故。次则有佛出修因得果等者。即标中修成。即自行意。言余四皆大用临机等。即标中化他也

疏。答中先人后己下。先利他故。大用四海。即先利他。言四海者。一名号海。二四谛海。三变化海。四寿量海。言自利二海居后者。即波罗蜜海为因。佛解脱海为果。八九两会答故居后。此中唯会六海。不会四海者。以世界海及安立海。依问在前故。佛及众生本居中故

疏。又众生一海下更以异门释众生海。上欲具收十问故。以答因属众生海。今以众生为总。即前答因属演说海。说诸位故。上来通竟

疏。若约局言下。第二释局答问。经来未尽者。遮那品后无结束故。若来应具答尽。二答二兼余者。谓正答安立及世界。兼余三十八问故

疏。亦表身为供养具者。即解脱和尚叹佛说偈云。合掌以为华。身为供养具。善心诚实香。赞叹香烟布。诸佛闻此香。寻声来相度。众等勤精进。终不相疑误疏。若别明者。如文思之者。若此之类显义无方。类例相似即可引证耳

疏。面门即口者。以昔有解云。面门即面之正容。非其口也。又云鼻下口上。以梵音呼面及口并门。并云目佉。是故译者解人。取文非一。今以众齿之间则口。为定解。表四十问者。有四十齿故。教道遐舒。即教智光。故口生真子。唯取口义故。法华云。从佛口生从法化生。得佛法分。故下出现。加于普贤光明入口。咀法味下。约齿明义。言总处者。口为说法处。一切法门总从此演故

疏。通举十号者。疏成正遍知者。理无偏邪目之为正。无法不照名曰遍知。即实智穷源号。言是明行足者。明是证行。行是教行。二行圆满名明行足。即修行满足号。言世间解者。明解世间故。即权智圆明号。言可谓善逝者。善者好也。逝者去也。谓不向余三界二乘去。唯向大菩提去。即直往菩提号。言即佛义焉者。佛者觉也。自觉觉他觉行圆满。名之为佛。由此天上人间共所尊重。故曰世尊。即无师自觉号。言谓无上士。夫士谓士夫。遍于众圣。于众圣中更无过上。名无上士。即位超诸圣号。言调御丈夫者。调谓调练。御谓控御。故云调御。则乃摄有情号。言天人师者。师谓轨范。说五乘教。利益众生故。即导轨众生号。言是应供者。谓堪受人天广大供养故。即堪为福田号。言结云如来者。乘如实道来成正觉。故曰如来。即仿同先迹。号佛德无边。十号略尽故。法华第三云。我是如来应供正遍知明行足善逝世间解无上士调御丈夫天人师佛世尊。未度者令度。未解者令解。未安者令安。未涅槃者令得涅槃。今世后世如实知之。我是一切知者。一切见者。汝等天人阿修罗众。皆应到此为听法故。斯即举十号以昭然。初但云如来亦复如是。出现于世如大云起遍覆三千大千世界。则通局有异。又下众集。但云天人阿修罗等。胜劣小异耳。今取彼意故。以十号释经十号之义。法界品方辩

疏。已至会中故阙初海等三事者。一土海。二世界海。三佛名。非别从彼来。故此不说

大方广佛华严经随疏演义钞卷第二十三大方广佛华严经随疏演义钞卷第二十四

        唐清凉山大华严寺沙门澄观述

疏。三别释者。前之二释。一则一一别对。二则互相总对。今不对前。则七八两段义不相关。七约法开悟。八约身成益。身法不同故不相对。上言对前为三者。前二相由故名为对。今与前别亦是对前

疏。此上菩萨法化始终下。上约顺释。今乃逆收。以彰深妙耳。细寻易了

疏。初悲智相导度众生而不疲者。悲无大智。即成爱见。爱见悲者。则于生死有疲厌心。今劫海修行而无疲厌。明有智导矣。智若无悲。则多趣寂名为下劣。今脱苦众生。心无下劣。即有悲导矣。悲故能度。智故无疲

疏。次偈空有双观等者。空有双观即是前半。空无分量。有无边际。入法门而常寂。即是后半。内前观有入一切法门。由前观空而恒寂灭

疏。后偈等者。三世二利是愿皆修。斯则名为物我无滞便成。后半化他自净

疏。言与前影略者。前有入尘。此中即无。此有住一毛端遍动诸刹。尘尘多身刹那顿现等。彼皆略无

疏。分与无分皆无碍故。乃至然各四句者。总相而言。分即是事。无分是理。理事既融故无障碍。言各有二四句者。事理皆四故。理四句者。一无分限。以遍一切故。二非无分。以一法中无不具故。三具分无分。谓分无分一味。以全体在一法而一切处恒满故。如观一尘中见一切处法界。四俱非分无分。以自体绝待故。圆融故。二义一相非二门故。事四句者。一有分。以随自事相有分齐故。二无分。以全体即理故。大品云。如色前际不可得。后际不可得。此即无分也。三俱以前二义无碍。是故具此二义。方是事故。四俱非。以二义融故。平等故。二相绝故

疏。身等不唯分故等者。谓由上诸义理性不唯无分。故在一切处而全体。在于一内不唯分故。常在一中而全在一切处。而事法不唯分故。常在此处恒在他方。不唯无分。故遍一切处而不移本位。又由理性不唯无分故。不在一事外。不唯分故。不在一事内。事法不唯分故。常在此处而无在。不唯无分故。常在他处而无不在。是故无在无不在。而在此在彼。无有障碍也。然此中有两对事理。各有二四句。乃成八句。疏中但出二句。谓上云证理不唯无分故。即初对约理一句。其一切法皆尔者。举例耳。今云身等不唯分者。即是后对中约事一句。以身等即事也。余之六句略而不出。故上总言各二四句。意中含取

疏。于体不计有无二边者。一切诸法体。不出于有与无故。于义不着常等者。就一有上。自有常无常之义。谓生灭。是无常义。不生灭。是常义。又不生灭。是无常义等。只要一有法上。即有常无常。我无我。苦之与乐。净非净等。故云诸法相遍。于行不习苦乐者。断见计乐行。常见计苦行等。住正道者。则不分别。是邪是正。因果交彻故。世间性空。即是出世间故。随顺观察世谛。即入第一义故。于谛常自二。于解常自一。故未堪实化。权为说三。大根既熟便为说实。权是即实之权。实是即权之实故

疏。照初二藏令菩萨证者。一如来藏在缠含果法故。二自性清净藏。在缠不染故。此二本有故令其证

疏。照次二藏令菩萨成者。一法身藏。谓果位为功德所依故。二出世间上上藏。谓出缠超过二乘菩萨故。并已出缠故致成言

疏。照第五藏令化令净者。以第五法界藏。通因通果。外持一切染净有为。名为法界。内含一切恒沙功德。故复名藏。以有因故化之。以有染故净之。余如前说

疏。三中后二如下业中者。即藏有三义。中后二义下动刹网。一一尘中现无数佛。即第二义。三雨法雨。即第三义。妙法轮云。即如来藏故。便是所证。二出离云。即令化令净。三大愿云。令得令成义

疏。谓色如灯云者。相海品云。如来眉间有大人相。名遍法界光明云。摩尼宝华以为庄严。放大光明具众宝色。犹如日月洞彻清净。其光普照十方国土。于中显现一切佛身。复出妙音宣扬诸法

疏。亦具同时具足等十门及教义等者。十门可思。但法是所依体。事中一华事。由此华事为理所融故。具十对令同时等。而康藏和尚约义分齐释成云。一教义。谓见此莲华能生解故。二事理华。即是事举体同真故。三境智华。是所观同智性故。四行位。是万行华。随位别故。五因果。因事之华。览因成果故。六依正。全是所修亦能依故。七体用。体同真性。用应机故。八人法。恒览于人。摄为法故。九逆顺。逆同五热。顺十度故。十感应。遍应一切。亦能感故

疏。而其本意正表义耳者。以十玄十对。凡举一事必具十玄。凡一玄门必收十对。泛明一法。一一圆收故。若作教者但是傍来。然其本意唯表义耳

疏。忽然现者。随难牒释。准观佛三昧海经第二。明地金刚白毫相光云。此相现时。佛菩提树白毫力故。根下自然化生宝华。纵广正等四十由旬。其华金色金刚为台。佛眉间光照此华台。其光直下至金刚际等。与此大同

疏。亦如涅槃从牛出乳者。即第十四经。南本十三云。尔时众中有一菩萨。名住无垢藏王。有大威德成就神通得大总持三昧具足。得无所畏。即从座起偏袒右肩右膝着地。长跪合掌白佛言。世尊。如佛所说诸佛菩萨所可成就功德智慧。无量无边百千万亿。实不可说。我意犹谓故不如是大乘经典。何以故。因是大乘方等经力故。能出生诸佛世尊阿耨多罗三藐三菩提。时佛赞言。善哉善哉。善男子。如是如是。如汝所说。是诸大乘方等经典。虽复成就无量功德。欲比是经不可为喻。百倍千倍百千万亿。乃至算数譬喻所不能及。善男子。譬如从牛出乳。从乳出酪。从酪出生酥。从生酥出熟酥。从熟酥出醍醐。醐醐最上。若有服者众病皆除。所有诸药悉入其中。善男子。佛亦如是。从佛流出十二部经。从十二部经出修多罗。从修多罗出方等经。从方等经出般若波罗蜜。从般若波罗蜜出大涅槃。犹如醍醐。言醍醐者。喻于佛性。佛性者。即是如来。善男子。以是义故。说言如来所有功德。无量无边不可称计。释曰。彼约赞法胜。能从微至着。今但取从佛出教。以况眉间出众耳。然此段经文诸说不同。若泽州先于菩萨申已解中。有一问云。此经是其言教。阿耨多罗三藐三菩提。是其果证。教浅证深。何故菩提不及是经。释言。此中偏名宣说佛性之诠。法身之教。以之为经。所证即是性净因果。所生菩提是其方便。因果性净为本。方便为末。末不如本故。佛菩提功德不及准后。佛答其义如是。次下释佛答。合中云。以佛合牛。约应身佛。十二部经合乳。说小乘经。修多罗合酥。名大乘教。藉小开大故名为出。后四俱大乘。诠事之教名修多罗。谓施戒等事。方等合生酥。即大乘中破相空教。因事显理故名为出。以般若合熟酥。究竟离相证实之慧。名为般若。依理起慧。是故名出。约行辩教。亦得名出。般若经云。然此般若即是向前菩提体也。以醍醐合涅槃。般若了因。了彼无始法性涅槃。是故名出。约实辩教。亦得名出。涅槃经言。佛性即是如来者。是法身如来。非报身如来。报身功德不及此经。故不即之。上皆远公之意。若望经意未必如是。谓此公坚将大小事理。以配五味。乃成屈曲。如何不说大乘十二部等耶。今谓无垢藏意。推功归本。果从教生。如来述成。成其推功之义。醍醐最上功本由乳。如来至极功归于教。故涅槃即是如来。如大即是菩提。诚谓。滔滔之水本于滥觞。合抱之树生于毫末。故说教为佛本。何用强分大小法报别耶。然佛自拣此经。异于小乘。今牛出乳。是大教耳。若尔何成五味。谓十二部经辩所说教。出修多罗者。十二分教出生契理合机之义故。修多罗出方等者。由契理故显出真理。正理广陈为方等故。从方等出般若者。依理生智等。般若出涅槃者。以智契理成极果故。故云涅槃犹如醍醐。醍醐喻于佛性。佛性即是如来。文理昭然。何须屈曲。亦有说。言从佛出十二部经是本质教。从十二部出修多罗是影像教者。亦是妄推度耳。都无本影之意

疏。故此十句摄为五对者。重收前释。谓一如理如量对。二法身报身对。三身毛心念对。四外感内安对。五竖见横圆对

疏。既现既至者。疏于释文之前。总彰赞意。于中有二。先正释。后总科。今初。既现即胜音赞。既至即十方菩萨赞。罔极者。即无极之情。故诗序云。情动于中。而形于言。言之不足则咏歌之。咏歌之不足则不知手之舞之足之蹈。之故生公用此意释说偈意云。以罔极之心咏歌舞蹈耳

疏。初一眉间菩萨赞下。科释。先总科。二新众才集下。明赞次第。于中亦二。先正明。后结弹。今初。亦是通妨。谓有问言。若以后十为十方菩萨赞者。十方先来。何以后赞。故今通云。现瑞与赞。二皆同时。则胜音与十方赞亦同时。自是结集。集赞一处耳。又应问言。既是结集排次居然。合排十方在前。何以向后。故释云。承前赞胜音德次。是故先举胜音赞耳

疏。昔人不晓下。二结弹古德。于中又三。初正辩非。次何者且眉间出众下。立理。三况法界品引例合叹

疏。亦含诸问思之者。文含四十句。且收十海。初偈即佛海。次偈演说海。三一偈变化海。一毛示现故。四一偈众生海。五一偈世界海。六一偈法界安立海。七一偈波罗蜜海。八一偈佛寿量海。已证佛地必有寿故。九一偈解脱海。普贤开觉已离障故。已获神通作用解脱故。十一偈名号海。身云普遍。随物立名故。十海既尔。摄余问例然。故令思之

疏。则十身圆融遍四法界者。以但言佛身故通十身。但云法界故通四界。以体即理。以用即事。体用无碍即事理无碍。即一即遍。即事事无碍。又初句体遍。次句明用。第三句明用遍第四句不动本也。本有二种。一真身为本。本体自遍。以用如体故。不动本而能普遍。二应用之中自有本末。菩提座身即本。周十方即末故。下不起树王而升四天。正明不动本而周遍。今明虽遍法界而处此座。明不坏末而归本。此二不相离故

疏。以不动本而周遍。释不坏末而归本耳

疏。上则事如理故等者。菩提座身是事。以如理故周遍。言此则事含理者。一毛是事无不包故。由理有二义。一无处不遍。二无法不包。犹如虚空具包遍义。今事如理故具上二义。即事事无碍中。事理融通门也

疏。又一毛表解脱门者。约观心释。一毛外有内空能容受故

疏。初二总身总相遍等者。然有四句。谓一总遍总中。二总遍别中。三别遍别中。四别遍总中。然所遍通依正。且约能遍为正。所遍为依。依正各有总别。正总即全身。别即眼耳乃至一毛。依总即全一国土。别即若树若石。乃至一尘。初但言刹中安坐故。是总身总相遍。后明身遍尘中之土。总遍别中。疏言众中者。即大众海中为拣昔解。以为胜音眷属赞故。则是胜音众中菩萨故。今明是新旧二种大众海中

疏。又句各一智者。上约二智。此约四智。四智之相已见第一经。今但取其与今经文相应之处。而引之耳

疏。力无畏等皆无异故者。即问明品文。经云文殊法常尔。法王唯一法。一切无碍人。一道出生死。一切诸佛身。同共一法身。一心一智慧。力无畏亦然。言相同者。即相似名同。非谓共也

疏。此即无碍慧身不依一切者。上以无住本释无依。无依是理故无住。即实相之异名。今以智慧释无依故。出现品云。一切佛法依慈悲。慈悲复依方便立。方便依智智依慧。无碍慧身无所依。故疏离诸分别。是无差别者。上释无差别。约理无二。今释无差。但心无分别耳。故无差别与无分别。有通有局。局则无差别是理。无分别约智。通则理亦得名无分别。故问明品云。佛刹无分别。无憎亦无爱。智亦得名无有差别。谓无差智为能证故。今用通义。以无分别释无差别

疏。能现能生身土。智影皆无二故者。即唯识释大圆镜智之能。亦如上引

疏。即法身无色应物现形者。引证此语。正是肇论。论云。法身无色应物现形。般若无知对缘而照。若取其本据。即是经云。佛真法身犹若虚空应物现形如水中月。下经亦云。佛以法为身。清净如虚空。所现众色形。令入此法中也

疏。以智契如下。会上二身令无障碍。是真法身。引金光明。已如上引。即三身品

疏。望前应身即重化者。应身对法报。应身是化身。今于应身上起化。故云重化。如释迦是应身如涅槃受供。于其毛端现多化佛。即重化也

疏。先一偈显真佛者。此约法报无碍之身。为真佛也。第一义常者。本有常也。智符于理。湛然常照者。即是修成。合本有也。若依法相。后常是相续常。今依法性宗。冥符于理。同理常也。故生公涅槃疏云夫真理自然悟。亦冥符真。则同无差悟。岂容易不易之体。为湛然常照。即其义也。显者离二障者。亦有二意。若别说者。离烦恼障故法身显。离所知障故智身成。合则二障俱障二身。离于二障俱显二身。智性本有非照今有故

疏。诸根相好一一无边者。即自受用身果。无限福智所庄严故者。即自受用因。故唯识云。二受用身。此有二种。一自受用。谓诸如来三无数劫修习无量福慧资粮。所起无边真实功德。及极圆净常遍色身。相续湛然尽未来际。恒自受用广大法乐。释曰。以论对疏。居然可知

疏。初一普随物乐下。三义皆通他受用身及变化身。故唯识云。二他受用。谓诸如来由平等智。示现微妙净功德身居纯净土。为住十地诸菩萨众。现大神通转正法轮。决众疑网。令彼受用大乘法乐故

疏。无生为佛法体故者。诸经论中皆诠无生之理故。净名不二发始明之。楞伽经说。一切不生中论不生。为论宗体。傅大士亦云。佛法以无生为体。无著为宗。忘想为因。涅槃为果。诸文非一

疏。无住处者。拂约性云。法性如虚空。诸佛于中住。似有住处。今谓法性如空。则无所住。况体无生。安有能住不住。诸法方住法性故。上文云。诸佛于中住故。金刚经云。应无所住而生其心。若心有住则为非住。大品云。若住一切法。不住般若波罗蜜。不住一切法。方住般若波罗蜜。故大般若会会之初。皆先明无住。净名亦说无住为本

疏。无尽相言兼真身故者。一应用无尽。若镜对万形。二真体无尽。此复二种。一十莲华藏之色相故。二一一色相体无穷尽。湛然不变故。经云。如来妙色常安隐。不为时节劫数迁。大圣旷劫行慈悲。获得金刚不坏体。胜鬘云。如来色无尽。智慧亦复然。故疏言。十化者。即佛地经说。佛身有十化。初依身轮起三种化。一受生化。谓受最后身。二神通化。谓现诸变等。三业果化。谓受金锵等。又依语轮起三种化。一辩扬化。谓转法轮。断疑答难。二赞励化。谓赞胜劝学。三庆慰化。谓有进修。或能断证随喜庆慰。意化有四。一领受意化。谓领问受取等。二决择意化。谓观有情心行差别。拣择诸法性相不同。三发起意化。谓能发起宿世善根。及令二乘发大行等。四造作意化。谓能建立诸法事义。是故当知依实起用。即是化身。故说化身无别心色。释曰。上即论文疏文具用。欲会释经少有添减。但观向引。自分疏中主客之言

疏。离一切诸相即名诸佛者。复有文云。若见诸相非相。即见如来

疏。慈氏论云。但离四相等者。此释上离一切言故。四加行位菩萨。但观此四。四者。一名。二义。三名义自性。四名义差别。名即能诠。义为所诠。名中有句。名诠自性句诠差别。则名中有自性差别。义中亦有自性差别。能诠所诠此二异相故。二别观。若名义自性。名义差别。二二相同故合观察。谓观于名必诠自性。若观于句必诠差别。故自性名与自性义此二相同。名义差别相同亦尔

疏。亦是释疑为物现相不乖如空者。疑云。既以法为佛身。清净如虚空。何缘现金色等。云何令人悟于虚空。答有三意。一体虽无相为物现相。物宜见故随他意耳。二者若不现相。云何令人悟于无相。如不因言岂显无言之理。上二意即为物现相句中通之。三如虚空言。取其清净。无相非离相求。相即无相故不乖空。故下经云。佛住甚深真法性。寂灭无相同虚空。而于第一实义中。示现种种所行事。所作利益众生事。皆依法性而得。有相与无相无差别。入于究竟皆无相。故相不乖无相。相即无相耳

疏。地地三心者。即入住出。下当广说

疏。一梵音故者。唯取五天梵音意在一故。二即此一梵音称性故遍。三此一梵音中即具一切音故

疏。释云事理融故。一梵音是事事为理融故一具一切。四多法雨者。随前一音。即说四谛十二因缘六波罗蜜因果等法。五随说一法具多文辞。如四谛品说四谛法。遍周法界主伴无尽。六随前一音一法。各同一切众生之音。如百道风各吹多窍。竞发异响。前第三一音具多。是佛音自具。今一具多。是随一音外同物类。七德一类音各遍一切处。多类皆尔。八唯宣称性融差别故。九能令万类皆得见闻上之性净。十随闻大小益皆究竟。言文处可见者。上之八义句各一义。唯第九义具于三句。十亦一句。故十二句而有十义。疏言影像者。显无方所者。此句标。下别释之。离其影像以为二喻。影取光影喻。故云光东影西等。然光影喻自有二意。一以若身若树等。以喻物机。日月之光以喻佛智。所见之影喻佛色形。如瞿师罗之短质。佛智对之为三尺之影。无边身之长质。佛智对之为穷上界。而有余之影。今不取此义。二质喻法身。无二相故。光前机感。随其东西所感异故。影喻色形。随机感光而东西故。今取此义云无方所。二以像一种为镜像喻。故云质对像生。无从无去即无方所故此影像下。双结二喻无方所言意明空耳。疏言如空者。不可取等故者。等于四义。谓此偈中五义如空。一不可取。无物可取智览无性故。二无生。非从无之有故。三无起作。非新成故。四应物现前。无有一物不对空故。随器大小孔隙之异故。五平等。十方虚空皆不可量。三际虚空同一相故。如来五义者。一离相故。二真常故。三湛寂故。上三寂然不动。四即感而遂通。五体相用等。佛佛相望平等无二

疏。故虽现形犹如水月者。经云。佛真法身犹若虚空。应物现形如水中月。此义佛佛平等。故结云平等如虚空

疏。既以结通菩萨云集尤显上叹。是彼十方者。谓若是胜音眷属。何以叹后结云如此四天下道场中。以佛神力。十方各有一亿世界海微尘数诸菩萨等。而来集会耶。明知。上是十方菩萨叹佛德耳。现相品竟

    普贤三昧品第三

疏。二释名。疏文有二。一正释。二解妨。前中有三释。第一释普贤是人。第二释普贤是法。第三依梵本义通人法

疏。纵佛加下品。二解妨难。有二种难。一义广名局难。难云。文中具有佛加光赞。何以偏名三昧。一法释意可知

疏。余会入定下。通第二违例开品难。难云。诸会中皆入定等在于本品。今何开耶。故疏牒此以答。答文有二。一释余不开所由。二今此开下。释今开所以。而文有四。一正答前问。二从四五二种下。展转生难。难云。光赞众请十地亦有。何名六异。彼何不开今此则开。答意可知。三以此果下。出广所由。七八九下。通蹑迹难。难云。若说果法。别立此品。七八九会。此三亦说果法。何不立耶。答意云。彼唯有一而无二义故

疏。二此三昧下。彰定名字。疏文有三。一解文。二彰入所以。三叙昔异同。今初。先指前。后复有下。正释。文有二释。一约广大生息释。二约光明遍照释。前中先总后别。今毗者。广大也。卢遮生也。那者。息也。即安国意也。疏诸佛有者。慈悲无边下。二广释也。先明修成。言生相尽者。即起信意故。彼有三细。谓业转现。总名生相。在赖耶识。今言尽者。论云。菩萨地尽。觉心初起。心无初相。以远离微细念故。得见心性。心即常住。名究竟觉。释曰。远离细念。即生相尽也。故次引涅槃经离有常住。即第四经。离有即生相息也。常住之义。同上起信

疏。言本性者下。释本性。言本觉现量者。本觉即是所证本性唯真。现量方能证故。与佛等者。起信论云。所言觉者。谓心体离念。离念相者。等虚空界无所不遍。即是如来平等法身。说名本觉故。以等佛而释大也。言新新生者。上约本净。今约随缘。言染净苦乐所不能动者。上约随缘。此明不变。又约上生灭。此约真如故。约生灭随缘常生。约真如不变常息

疏。即上法身在缠下别释藏字。谓空不空标二藏名。起信云。复次真如依言说分别。有二种义。云何为二。一者如实空。以能究竟显实故。二者如实不空。以有自体具足无漏性功德故。释曰。上即双标

疏。空为能藏藏不空者。即次下论中意。论云。所言空者。从本已来一切染法不相应故。谓离一切法差别之相。以无虚妄心念故。当知真如自性。非有相非无相。非非有相。非非无相。非有无俱相。非一相。非异相。非非一相。非非异相。非一异俱相。乃至总说。一切众生以有妄心。念念分别皆不相应。故说为空。若离妄心实无可空故。所言藏不空者。以显法体空无妄故。即是真心常恒不变。清净满足。则名不空。亦无有相可取。以离念境界唯证相应故。释曰。上引论文。即双释二藏。而疏引意释于空藏藏不空。意犹似难见。谓标论中本意。自性清净心不与妄合。则名为空。性具万德即名不空。及至释文乃云。若离妄心实无可空。即显空藏同妄而显。不空之藏要由翻染方显不空。如本有檀德今为悭贪。本有尸德今随五欲。本有寂定今为乱想。本有大智今为愚痴。是则悭藏于施。乃至痴藏于慧。故论云。以知法性无悭贪故。随顺修行檀波罗蜜等。万行例然。故下论释本有真实识知义故。故云。若心有动非真识知。明妄心之动藏其真知。是以即妄之空。藏不空之万德。故下经云。知妄本自真。见佛则清净。故上论云。以能究竟显实故名为空。故知空藏能藏不空。能藏既空。则不空之藏本来具矣

疏。若以光明下。二约光明遍照释。犹有二意。前以毗卢遮那为能证。又毗卢下。以毗卢等以为所证。则以如来而为能证。言本有真实识知义者。即起信生灭相中之文。论云。若心起见。则有不见之相。以心性离见。即是遍照法界义。故若心有动非真实识知。意云。若无动念即真识知。既云即是遍照。则毗卢遮那亦本有矣

疏。显于依正下。第二彰入所以。可知。疏贤首云下。第三叙昔异同。意以身包刹海得藏身名。但是下文用中。一义。摄义不同不为正释。顺经宗意。故存而不论。疏普入下。明体相用。文有三。初总科。二言六对下。随文别释。三言四节者。结束称赞

疏。初二句下释初对中。先双摽。谓以因因性下。双释。先释正入一切佛平等性言因因等者。即涅槃二十七。师子吼菩萨品云。佛性有因。有因因。有果。有果果。因者。十二因缘。因因者。即是智慧发心已去。果者。即阿耨多罗三藐三菩提。果果者。无上大涅槃。今疏文意。因因即观缘之智通发心已去。果即所证之理。能证至果。为大菩提为大菩提。所证至果名大涅槃。前二是因。后二是果。而有重因果言者。谓十二因缘。是正因性。虽有此性若无观智不能成果。今由观智令彼成果。即与因作因。故名因因。菩提对前已名为果。而大涅槃由菩提显故。此涅槃即是菩提果家之果故。彼经喻云。如无明为因。诸行为果。行缘识果。则无明亦因亦因因。识亦果亦果果。举此无明为因因则在行前。行如十二因缘。无明如观智。则观智。在于十二因缘前。而远公云。十二因缘近起观智。远为涅槃正因。故名为因。方依前因以起观智。依因起因故名因因者。则因因在于十二缘后。理则可矣。而不顺喻。无明因因在于行前耳。然上四句之后经中。复有四句云。一是因非果。如佛性。二是果非因。如大涅槃。三是因是果。如十二因缘所生之法。四非因非果。名为佛性。此之四句。三即是前二三两句。智慧菩提皆依十二因缘生故。初及第四。皆前中初一。以十二缘约相是因。若约缘性即非因非果。是中道正性法身理也。二即第四。而菩提望前是果。望后是因故。言亦因亦果。涅槃之后更无所显故唯是果。又第四句非前四句。总为四句之体。就缘成四。与此为因名为因性。与此为果名为果性。犹如真如出烦恼障名为涅槃。出所知障名为菩提。而体无二随出得名。佛性亦尔。因等四句皆望缘取。而佛性体。体绝四句。俱非因果。四句已亡。思之可见。若总合上二种四句。成五佛性。复成四句。一或有佛性。阐提人有。善根人无。是前因性之中一分之义。以未成佛时。善恶无记皆名佛性。亦取其恶故。云一分阐提有也。二或有佛性。善根人有。阐提人无。即因因性。三或有佛性二人俱有。即是因性中通十二缘。亦非因非果之性。四或有佛性二人俱无。即彼果性及果果性。对前两重四句。可以意得。十二因缘名佛性者。一当体净故是法身性。二能知名义成反流故名报身性。又前灭后生非断非常显中道故。又三杂染即三德故。翻烦恼杂染。以成般若。翻业杂染以成解脱。翻苦杂染以成法身。当相即是性净三德。观之则是观行三德。证之则是圆满三德。又初因性。即染净缘起。二因因性。即内熏发心。第三果性。即始觉已圆。四果果性。即本觉已显。又初随缘隐显。二微起净用。三染尽净圆。四还源显实。又初与四俱是理性。但染净分二。二之与三俱是行性。但因果有殊。又初染而非净。二净而非染。三亦净亦染。四非染非净。又初自性住性。二是引出佛性。三四皆是至得果性。又初二因中理智。后二果中理智。因果虽异。理智不殊。理智似分。冥契无二。唯一心转。绝相离言无不包融。故名佛性。由此名为佛性契合门也

疏。如是佛性即有七义者。即涅槃三十五经云。善男子。如来十力四无所畏。乃至如是等法是佛佛性。如是佛性则具七事。一常二乐三我四净五真六实七善。今但义引故小不次。泽州云。不迁名常(四)自在名我(六)安隐名乐(五)无染名净(七)离妄是真(一)不空显实(二)体顺成善(三)后明菩萨性有六种。于前七中略无我乐。加少分见。以其未得八自在我故无我德。未得大涅槃无真实乐德。未见自身佛性故加少分见

疏。生佛之性下释平等义。言佛平等性。即如来藏下。会别归总。此为第一下。结十门之一。疏言胜用下。即释经能于法界示众影像。是第二门。言能现能生身土智影者。即唯识论释大圆镜智之文。谓三身三土三智之影。皆是镜智之所现故。如第一经说。前抄已引

疏。谓若自相等者。谓观色等六尘入正定。故名为自相。若观无常空等八定。则名共相。并皆不离如来藏性。性即真如故。起信论云。真如三昧是诸三昧根本。上释出生一切诸三昧法

疏。后摄受下。即释普能包纳十方法界。终归此者。约事法界。法界体性。约理法界。疏四有二句。前句即三世诸佛智光明海。皆从此生。言不体此理。非佛智故。体谓体达。若能证入藏身之性。即名佛智正用。起信始觉同本。名究竟觉故。生公立体理成照义。云理不待照而自了智。必资理而成照。故知理无废兴。弘之由人。智虽人用。不在人出矣。故人有照分。功由理发。失理则失照故。要见此理方成佛耳

疏。后示现诸境门者。释经十方所有诸安立海悉能示现。上摄受法界。即言终归此。故此能现者。文影略耳。皆自此生者。皆归此故。故知万物依地而生。终归于地

疏。五有二句即依正含容者。二句共成一门。一门便成一对。内含因果智力。释经含藏一切佛力解脱诸菩萨智。从外令尘下。释经能令一切国土微尘。悉能容受无边法界。释云。由尘全依法界藏现。即是事尘顿现万境故。言同真性者。约理法界

疏。六有三句下。三句成一门。一门分二。一对前二句即成人。经云。成就一切佛功德海。二显示如来诸大愿海。是故疏云初成果人功德大愿。即二句也。疏后持法轮。即是持法。释经一切诸佛所有法轮。流通护持使无断绝。言由斯玄理法眼长全者。法眼长全无缺减。即第十四经。由真理湛然故悟亦冥符。理既无亏法眼常矣

疏。言四节下。第三结束称赞。言次四句者。即出生一切下。言二句者。即含藏下。言后三句者。即成一切下。及下三义。皆是结束此三。圆融称赞也

疏。此第十句有二义者。昔人唯有后义。则是佛身所现国土中尘有诸佛刹。遂令普贤不遍如来身外之刹也

疏。及此国者。指前十处之国者。即前第十句中初义。谓及尽法界国土中。尽虚空国土。尽三世国土等。其第十义身中国土。以文近故。疏中不指

疏。于上诸处下。总结能遍。上之四重但所遍故。于中三。初正结遍身。二此处入定下。类通。三故约主定下。后解妨难。谓有难云。别明入定。佛前唯一普贤。今此结通。何以一一佛前各有多耶。疏中含有二义。一正约主伴。二遍明即入。初主伴中。谓为主须一为伴必多。难云。此中普贤应不为伴。故应答云。若为伴时。亦得有多。二者即由上义故。此一者是即多之一故

疏。云一切之一故。彼类通中多是全一之多故。疏云一一切故。前是举一结多。此是即一即多。前是通辩缘起相由。今明力用交彻。一有一切等故。普贤身不可思议。略有三类。一随类身。随人天等见不同故。二渐胜身。乘六牙象等相庄严故。三穷尽法界身。帝网重重无有尽故。今当第三。含有前二

疏。得定所由所由有三等。疏文有三。初当句释。二又上三下。展转释。谓由自有行愿。方得主佛愿加。由主佛愿方得伴佛同加。故云前前由于后后。三余岂无下。通妨。难言。一切菩萨皆修行愿。何故不加。法门主下。疏答。答中二意。一约教相。二表诸下约表法说。如金刚藏表地智等

疏。余九即是十海者。就十海名二处具出。影带钩锁文该五处。言二处者。一现相品。众海问中十海。二成就品。初标章答中十海。然文小异开合不次。问中十者。一世界海。二众生海。三长行阙一偈中即有。谓世界安立海。四诸佛海。五波罗蜜海。六解脱海。七变化海。八佛演说海。九佛名号海。十佛寿量海。三世界成就品。初答中十者。一世界海。二众生海。三一切诸佛海。四一切法界海。五一切众生业海。六一切根欲海。七一切佛转法轮海。八一切三世海。九一切如来愿力海。十一切如来神变海。若将此十对现相品者。此中一二名次俱同。此中三即问中第四。此四即彼三。此中五六皆带第二众生海中。开出亦可。第六根海通下诸海。须知根。故至成就品当更会之。此七是前第八演说。及第五波罗蜜海。是所演故。此八即第六解脱。此九即前九十二海。谓名号寿量。皆由愿力而得成故。此十即前七。上言此者。此成就品。言文该五处者。二处如前。三即此所为中。是为十海故。四者即下意加与智。即十海智故。五世界成就品答中。称叹十智。即是知此中十海之智。正是此中诸佛所与十智也。此上五处三处。是海。二处是智。其所为中虽无海言。而是海义。然其五处决定相承。谓由问十海故。加所为中。为于十海佛与十智令知十海。普贤得智将欲说之故。观察十海。智海难思。唯佛智能知故。称赞十智。亦是赞所得之智。方能遂佛所为。答前问也。而其五处开合广略者。显义无方故。亦似译人不相对会。故今疏文并为会释。使前后无违。下成就品更委会释。今此所为中十句。正对问中十海有三。两海兼下答名。以文同故。谓一即问中第三安立海。二即问中第二海。言业者问中所无。即兼下名。答中开出。然有众生必有于业。以此经中有净治杂染得清净言故。疏加之及业海也。三同问中第一。四同问中第四。五中摄前四海。谓九名号海。十寿量海。六解脱海。七变化海。以其上四皆佛随机之大用故。故云一切佛功德也。六即问中第五。七九二海皆是问中第八。答中但有转法轮海。而无演说。问中但有演说。而无法轮。今此所为及与叹智。并开成二。八亦问中第二众生开出。然上九句。七九合成。问中一演说海。八复合归第二故。此九句唯有于七。而第五佛功德中。独有其四。兼七中余六故。十海具矣

疏。与下十智令知此十者。上来正释经文。今对后生起。如前已说

大方广佛华严经随疏演义钞卷第二十四大方广佛华严经随疏演义钞卷第二十五

        唐清凉山大华严寺沙门澄观述

疏。余九为别。即是成就品中十智等者。疏文有三。一总相会通。二一即第三下。别别对释。三又菩萨根下。随难重释。二释中欲对下智。须知十智名字次第。彼云诸佛子。诸佛世尊知一切世界海成坏清净智不可思议。知一切众生业海智不可思议。下皆略去不可思议而加次第。三知一切法界安立海智。四知说一切无边佛海智。五入一切欲解根海智。六一念普知一切三世智。七显示一切如来无量愿海智。八示现一切佛神变海智。九转法轮智。十建立演说海不可思议。经脱智字。然疏中则易知。但对名字次第难知。已为会释。并可知也。身加中

疏。谓佣纤直等故云相好者。佣纤之言。言兼相好。案大般若三十二相中。第九双臂修直佣圆。如象王鼻。斯则佣直是相。手连臂故纤者。三十二中云。五世尊手足所有诸指。圆满纤长甚可爱乐。言兼好者。八十好中手足指为二十。以一指为一好。谓十指端皆圆纤可喜故。而言等者。即妙网光舒。此言显故。三十二中云。四世尊手足二指中间。犹如鹅王咸有网鞔。金色交络文同绮画。即是相也。略举此二。广如十身相海品说

疏。亘十方等者。一切诸佛种种。即亘十方也。过现未来即三世也。菩萨因也。诸佛果也。上二皆人。法轮即法也。顿具为深。横该为广。相好即体。出生等用。皆悉圆融名无边自在。谓即横即竖即人即法等

疏。初总谓一起一切起等者。此上正释。由此妙下。出其所以。所以有三。初总摄故。二终归此故。三彼全同下。通妨难。难云。若取归此如百川归海。何以能归亦受海名。故今通云。约随机别用。故曰终归。实则体同。更无异味。即是总中之别义耳。如于海中说百川味

疏。二即所知尘境者。此有二义。一尘即微细之尘。知其相虚。又能容纳故。及为物因。如八地中知微尘差别智。二即六尘境故。亦名微尘境故。安国云。谓色等五尘界。是现量境。五识亲证都无尘相。如来藏中顿现身器。而无尘相。六七妄想。谓有我法想所现相。是分别变。分别变相。但可为境而无实用。如日发焰带微尘而共红。非实红也。如水澄清含轻云而俱绿。非实绿也。如观本质知画像而非真。若了藏性悟尘境而为妄。故经云。非不证真如而能了诸行皆如幻事等。似有而非真故。法界微尘以为三昧。释曰。此义易了。亦非经宗故。疏含有而释之。似巧故抄引之

疏。楞伽经云。如来藏性顿现一切身器及诸受用者。上即第一经文。然彼明顿义。此第三藏识顿知喻。喻于报身顿成。经云。譬如藏识顿分别。知自心现及身安立受用境界。喻也。经云。彼诸依正亦复如是。顿熟众生所处境界。以修行者安处于彼色究竟天。释曰。今疏不取所喻。但取能喻。藏识顿变之文。从器即广刹下。以楞伽经配属今经。上引楞伽双证三四二句。广刹即第三句。从现三世一切佛刹三昧门起。舍宅即第四句故

疏。以受用二字配之。彼经但云受用境界。受用有二。一共业所感外诸器界。即如来藏识顿变。其宅舍即是共中不共。皆属受用。其器一字。乃是义引。欲配二句故

疏。微尘中佛复有一义。即观心释。广如出现品

疏。九从知一切法理趣下。疏文有三。一对前总显。二大般若下。引教成立。三上来九句下。总结一段。二中总引三经一论。初大般若。即第十理趣分。经当第五百七十八。彼经叙云。此经并乃核诸会之旨归。绾积篇之宗绪。明是六百卷理趣也。佛在他化自在天。为八十亿大菩萨说。今疏义引两节经文。初至不可愿求。自为一节。经云。尔时世尊复依一切无戏论法。说如来之相。为诸菩萨宣说般若甚深理趣轮字法门。谓一切法空。无自性故。一切法无相。离众相故。一切法无愿。无所愿求故。一切法寂静。永寂灭故。一切法无常。无常性故。一切法无乐。非可乐故。一切法无我。不自在故。一切法无净。离净相故。一切法不可得。推寻其相不可得故等。释曰。此上显性空理趣。从然第一义湛然常住。当知即是此如来藏者义引。彼经显真实理而为理趣。若唯用前。非真趣故。故彼经云。尔时世尊。复依一切住持藏法如来之相。为诸菩萨宣说般若一切有情住持遍满甚深理趣胜藏法门。谓一切有情皆如来藏。普贤菩萨自体遍故。一切众生皆金刚藏。以金刚藏所灌洒故。一切众生皆正法藏。一切皆依正语转故。一切众生皆妙业藏。一切事业加行依故。释曰。前明有法非有。后明无法不无。非有非无是中道理趣故。疏结云当知。即是此如来藏。亦空不空二种之藏。又摄别从总。即藏身三昧之所有也

疏。思益经下。即彼经第一。时有五百比丘。闻说法空从座起去等。网明令思益梵天为作方便(云云)。梵天言。善男子。纵使令去至恒河沙劫。不能得出如是法门。譬如痴人畏如虚空舍空而走。在所至处不离虚空。此诸比丘亦复如是。虽复远去不出空相。不出无相相。不出无作相。又如一人求索虚空。东西驰走言。我欲得空。我欲得空。是人但说虚空名字而不得空。于空中行而不见空。此诸比丘亦复如是。欲求涅槃行涅槃中。而不得涅槃。所以者何。涅槃者。但有名字。犹如虚空但有名字不可得取。涅槃亦尔。但有名字而不可得。尔时五百比丘闻说是经。不受诸法漏尽意解。心得解脱得阿罗汉道。作如是言。世尊。若人于诸法毕竟灭相中求涅槃者。则于其人佛不出世。释曰。上经有二意。一不离空。以有遣空。求空不得。以空遣空。二者不离空。显空体妙有。求空不得。显空离相。非有非空。亦非空非不空。而诸比丘但得初意。故成罗汉令毕竟无求。今疏通用二意。皆为理趣。略引初喻。以彰体周为真意趣

疏。深密经中意趣有六者。即第五经。如来所作事品。为文殊说其第六事。亦名意趣。亦名理趣。即今所引而但列名。不别解释。今疏已略释。疏中有二。先引经正释。六理趣义在文可知。后彼真义者。即此藏身下。会释经文。而但释二者。由前六中前三为本。后三解释。则以此三摄前三也。今以真义摄于第四。即以前摄后。以不思议摄其第二。即以后摄前。以真义直举藏身之体。不思议正同三昧之相故。十地论释云。所以金刚藏入三昧者。显此法非思量境故。其第三与六。即是他利益。后普贤说法。是此二趣。今言出定故略不言

疏。无著菩萨说四意趣者。但指摄论。而杂集第二。庄严论第十三。皆同说四。谓一平等意趣。谓如佛说。我昔曾于彼时之中。名毗婆尸。即名胜观正等觉者。无性释云。谓一切佛由资粮等。互相似故。说彼即我非昔毗婆尸即今释迦。楞伽经中约四义释。一字等。二语等。三身等。四法等。故说即彼而实非彼。二别时意趣。谓如说言。若但颂多宝如来名者。便于无上正等菩提已得决定。又由唯发愿便得往生极乐世界。无性释云。谓观懈怠不能于法精勤学者。故作是言。此意长养先时善根。如世间说。但由一钱而得于千。解云。以后别时而得千也。以一钱为千钱因。念佛为菩提因。发愿为安乐因也。三别义意趣。谓如说言。若已逢事尔所殑伽沙佛。于大乘法方能解义。无性释曰。意约证相大乘。不就教相大乘。故作是说。四补特伽罗意趣者。谓如如来先为一人赞叹布施后还毁者。谓随此人得成何心故。若人于财物有悭吝心。为除此心。先为赞施。若乐行施。施是下善。欲令渴仰余胜行故。所以毁之。不达言违。皆佛别意趣耳。余行例然。今明普贤亦善穷究

疏。普贤出定余人益者下。上释文。此下问答显理。先问后感应道交下释。释有法喻合。合中云。冥显双资者。谓宿善为冥资。以暗成故。现业为显资事昭著故。今当俱句。亦有冥而非显。但有宿善故。复有显而非冥。现身精勤宿无善故。其非冥非显。此非机感。设欲成机。乃是大悲通相所被耳。此上四句但约于机。对机说应亦有四句。一冥应。令所得功德不自觉知。二显应。现形说法光照现相等。三俱。四俱非。俱非不名为应。若取大圣无心即应。无应亦得名应。以机对应乃成九句。谓一冥机显应。二显机冥应。三冥机冥应。四显机显应。上单四句。二单复相对。复成四句。一冥机冥显应。二显机冥显应。三冥显机冥应。四冥显机显应。三以复对复而成一句。谓冥显二机冥显二应。今此乃成第九句也。谓宿善冥着精心显彰。是谓冥显机也。入定冥资起用显益。即冥显应也。今举冥显之机。成前得益所以。故云冥显双资于何不可

疏。身相如空法性身也者。疏文有二。先略释经文。后问答广显。今初。具四身土。前半即一法性身土。具如疏释。后半有二身土。谓受用字即他受用。化字即是变化。顺经示现故。其自受用含在前半。以身如虚空自受用相。良以经有非国土言。故但属法性身土耳

疏。法性身土为别不别下。问答广释。于中先问后答。答中三。初双标二章。二双释二章。三别示五重土相

疏。一依佛地下。第二双释二章。然净土之义。次二品广明。问明贤首。第五回向等。复当广说法身之义。玄文已具一经。往往显甚深旨。此中亦即一段。寄如来身。显普贤身。今十中第一文中有四。初依论正立。二论自解妨。三为论引证。四会释经文

疏。性虽一味下。二解妨。即正答前问也。谓与身为性名法性身。与土为性名法性土。即三土三身之真性也。未失一味

疏。智论云下。三为论引证。共答前问。亦犹外典。天地万物同禀阴阳之元气也。佛者是觉人有灵知之觉。今第一义空与之为性故名佛性。非情无觉。但持自体得称为法。今真性与之为性故名法性。是故结云。假说能所而实无差。次引唯识亦为证前。即第十论云。又自性身依法性土。虽此身土体无差别。而属佛法。性相异故。此佛身土俱非色摄。虽不可说形量大小。然随事相其量无边。譬如虚空遍一切处。释曰。此文兼证后段如空。论文易了。谓法性属佛下。是疏释论。然准彼疏云。佛是相义为功德法所依止故。众德聚故。二身自体故。法是性义。功德自性故。能持自性故。诸法自性故。体为土义。相为身义。此公意云。属佛是相。属法是性。直语所依名土故。云体为土义。以能依亦所依。为法性身故。云相义为身。今疏意小异。谓佛有觉义故名属佛。土无觉义。但持自性故名为法性。言性随相异者。身土约相则有二差。随所依性则无差别。今以无差之性。随有差之相。故云性随相之异也

疏。今言如虚空下。四会释经文。言然随事相其量无边者。以变化等三身三土事。既无边与之为性。岂有边耶。既如虚空则遍至一切色非色处

疏。结云故如虚空。言通喻身土者。按于经文。但言身相如虚空。按唯识云此之身土皆喻如空。则显虚空喻兼下句

疏。下经亦云解如来身非如虚空者。即第五回向第一经

疏。已引下更一句云。于一切处。令诸众生积集善根悉充足故。前明自利。此明利他

疏。我此土净而汝不见。即净名第一众生见烧净土不毁。即法华第五。并如下引。色即是如。相即非相。即义。引大品等经。身土事理互交彻故。结前生后。然结前者。结前三文成上三义。谓引净名成第三。当相即是功德。身土则具妙庄严。通自他受用。二引法华成智法身土。亦通性相。智所现身者。若大圆镜智现自受用身。平等性智现他受用身。成所作智现变化身。此三身既融。则三土亦融。变化则毁。自他受用皆悉不毁。我此土安隐。即自受用。天人常充满。即他受用。三义引大品。色即是如。成第一义。相即如故。如即法性土。相通诸土。即法性身与色相身。无碍依土。亦性相无碍。是故结云皆事理交互。言生后者。生后四句。文有两重四句。初四唯单相对。其色相言。通于报化自受用报他受用报皆色相故。二又以单对复。成五句。唯出其一。今准思之。以成于五上即第一。二法性身。依色相法性土。三法性色相身。依色相土。四法性色相身。依法性土。第五有一俱句。谓法性色相身。依法性色相土。则是性相无碍之身。依性相无碍之土

疏。此上犹通诸大乘教者。结前生后。生后唯属一乘华严之宗。结前不出法性色相之身土。及四身四土之义故。谓一及第四唯法性。二三唯法性及如智。五六具上诸义。亦不出如智。七八方具事理无碍故。上八门不出事理无碍实教之宗故。通诸大乘。即同教一乘义也。故此下二。方是事事无碍法界。华严别教一乘宗也

疏。九通摄三种世间等者。如八地中十身。即三世间故。谓众生身国土身等已见玄文。言即如空身。而示普身于何不具者。会释经文。谓经文但云身相如空等。何有十身之义。故今释云如虚空言。即十身中虚空身也。八地之中十身相作。今云示现普身。则两重十身皆悉具矣。如下经云。虚空身作众生身。作国土身。作业报身。作声闻身。作缘觉身。作菩萨身。作如来身。是为虚空示余九身。其如来身上既具。菩提身愿身化身法身智身等。则有百身千身一一类身。复各摄多故。云示现普身等一切也。又如虚空言。含法身智身。即如真身。即真而现何不具矣

疏。十土分权实等者。为拣浅深。以分权实故。前八非实。若不摄权。亦非真实。如说海水异于百川。不摄百川非海水矣。随义布列有十不同。得意而谈一一融摄

疏。上言土有五重下。三别示土相。谓前三如智有离合之殊。故分三身。其所依土唯一法性。余可思准

疏。重重皆遍下。通其妨难。难云。如上所说。则无一处无有普贤。今何不见。释有三意。一约机不见。是盲者过。二不见是见。见虚空身。谓以虚空不可见故。若不见者。真见虚空。三亦遍不见处故者。以见则不遍。何者以可见不可见。皆是普贤身。要令可见为身。则普贤身不周万有。如智不可见。岂非智身耶。明知由有不见之处。方知身遍耳。此第三身何人能见。慧眼方能见。非肉眼所见。慧眼无见。无不见故见矣

疏。一因修法生义通缘了者。然准涅槃。缘因对于正因。了因对于生因。而缘亦名了。如酵暖等为酪。缘因即疏家义。通缘了。缘即缘因。了即了因。能了彼乳中之酪令得成酪。而今开异。义小殊耳。故了谓照了。不通于生。缘谓众缘。义通生了。今从别义。又对正因。是真如故。云通缘了。如不可生故但名了。偈云出生者。出于二障。故曰出生。非生真如。诸佛法言。通教理行果。通于二因义如上说

疏。真如即是不空者。此言不空。自有二义。一空者。所谓生死。不空者。是谓大涅槃。二对下空藏。是不空藏。妙有之中含性德故

疏。平等与藏通此二义者。藏通真如是不空如来藏。藏通虚空是空如来藏。平等通二者。一真如体性平等。二虚空无相平等。此二不二是真平等。悟法性空是真如故。经云。汝已严净此法身者。对上真如。即是法身出障名净。因华行满是已庄严。易故不释

疏。细处有多众生者。即离世间品。五十五经。十种如金刚大乘誓愿心中。第二心云。菩萨摩诃萨又作是念。于一毛端处有无量无边众生。何况一切法界。我当尽以无上涅槃而灭度之。是为第二如金刚大乘誓愿心。今云法界微尘无不入。与一毛端处大意同也

疏。二有三颂说法果者。此有二意。一说法即果。对上说因。詺为说果。二称根令喜。是说法果。今具二意。谓具功德光明广大胜力等。即说法因。今能遍说。即是说果。是初意也。二由上遍说胜法。能度众生。即是后义。以称根故

疏。一能说力胜具二严故者。即是说因。功德是福德庄严。光明名为智慧庄严。此以前半力殊胜言。释此无等。下释易知

疏。又前问总该诸会等者。此有二意。唯问于三。一以要摄广故。二明总别不同故。总即广问。别故唯三

    世界成就品第四

疏。初来意者。疏文有二。一明分来。对前二品以为说缘。生下三品。为正所说。二总明果相下。别明品来。此句对下华藏为别。别明本师之所严净故。指此品以为总明诸佛果相。是古德意。下句指前答安立问。二问不同故。二品别答。后品自答世界海问。此是疏意。然答问虽异。总别无违故。双存二义

疏。二释名者。疏文有四。一释世界。二释成就。三会六释。四会梵文。今初二释。一以破坏释世。二以隐覆释世。若唯前解。令华藏刹是可破坏。今为此释。令华藏刹从无为起。同于真极不可破坏。是故感娑婆下。双出不离隐覆之义。疏成或下。释成就字。能成之缘通因及果。起具因缘是因体性。依住等事皆是果故。总具十门世界成立

疏。能所合目下。会六释

疏。准梵本下。会梵文

疏。会一海字。若具梵云。噜迦驮都(世界也)三慕达罗(海也)湿第奢(演说也)匿缚怛囊(观察亦云照曜)三牟陀(十方也)俭摩(合集也)娜[女*亡](名也)钵里勿多(品也)。若依回文。总云观察十方世界海演说合集名品。今经译家存略太甚。余言可略。海字切要。故疏会取意云。佛果下。出下无海字。所以刹海庄严是佛修起。直语世界。众生业成无始有故。但云世界。虽为译家出理。实则海言切要

疏。三宗趣者。先宗后趣。趣中有六。一总明。二云一令诸菩萨下。别显。别显之中总有六意。唯初有一字。余皆略无次第。但以故字而为拣别。三亦为下。结成来意。四故下颂下。引文证成。双成来意宗趣。五若不闻下。反以成立。六故普贤下。引普贤结经文具之

疏。又此品明成刹之缘等者。前释对二种来意中前义。此释对后义。此品成刹之缘。具果具因故。后品唯果

疏。但观于十下通难。难云问有四十。何唯观十。故答意云。十海为总。已含所余三十别问。言佛海之中。具身等者。是佛必有六根三业为体相。显著之十。必有德用圆备。谓佛地等故具二十。大愿海中已摄因中发趣等十。故四十无遗

疏。观乃观海叹乃叹智者。下释妨难。即心口相违难。此难因前而生。于中四。一问。二智之与海下答。三若尔下重难。即叹说不同难。此难望后说分而生。四智离海境下。辩答。答中二。先约教相。谓智之异相因所知故。二又表以下。约证相。海是所证故

疏。十智望海下。正释经文。于中二。先总后别。总中十海之名。总有五节已如前品。今对三文并此即为四。四言望海者。即前所观。言与问者。即第六经。此唯三下对二。别释中兼对与智。即是前品意加之中

疏。谓一中下别释。钩锁相连令义无遗。今当具出。问中十海。与智中十智。观海中十海。叹智中十智。一世界海。一能入一切智性力智。一一切世界海。一知一切世界海成坏智。二众生海。二入法界无边量智。二一切众生海。二知一切众生业海智。三法界安立海。三成就一切佛境智。三一切诸佛海。三知一切法界安立海智。四诸佛海。四知一切世界海成坏智。四一切法界海。四说一切无边佛海智。五佛波罗蜜海。五知一切众生界广大智。五一切众生业海。五入一切欲解根海智。六佛解脱海。六住诸佛甚深解脱无差别诸三昧智。六一切众生根欲海。六一念普知一切三世智。七佛变化海。七入一切菩萨诸根海智。七一切诸佛法轮海。七显示一切如来无量愿海智。八佛演说海。八智一切众生语言海转法轮辞辩智。八一切三世海。八示现一切佛神变海智。九佛名号海。九普入法界一切世界海身智。九一切如来愿力海。九转法轮智。十佛寿量海。十得一切佛音声智。十一切如来神变海。十建立演说海智。其所为中十法亦是十海。已如上会。文无海言。今略不出。今对会四文。即分为四。第一以叹智对观海。辩次第者。第一智观第一海。第二智观第二海及第五海。第三观第四。第四观第三。第五观第六。第六观第八。第七观第九。第八观第十。第九第十并观第七。但看前列次第可知。疏中所会。正是此对。第二若将叹智对与智。次第者。所叹第一即与智第四。世界成坏。二即是五。业海智也。三即是二。入法界无量。四即是三。五即是七。六即是六。七即是九。八即是六。九即是八。十即彼十。彼有总句故。彼六中含此六八。第三若将叹智。对问十海。多同第一对观海辩。若具说者。前四如次对四海。第五通遍后五。六即彼六。七即九十。八即第七。此九与十。皆是彼八。第四若将十种观海。对问十海者。此观第一。即问第一。二即彼二。三即彼四。四即彼三。五亦彼二。六遍后五。亦可是二。七即彼八。八即彼六。九即彼九及与第十。此第十海。即彼第七海也。复应将观海对问十海。如前问中以对更应将与智对问十海。前与智中已对。若更将十海。对加所为中十法。已如前品所为中明。故今略出四门而已。余义疏中具会。细寻易了

疏。以总收别但广身光等者。以三业之总摄六根之别。言但广身光等者。等取前光明及音声智慧。二光为身音声属口。智慧是意。今文并具。故致等言。即开三业而为十耳

疏。若言具说何以下文。唯说安立及世界海耶。此下问答料拣。此上问也。答有二意。一经。来未尽。约显现答。遮那品末。无有结束故。若经具来。应更答余三十八问。二又虽说二下答。二兼余。于中先标。后谓界必有生下。出所兼相。略出三海。谓一众生。二佛。三行业及能兼二。已有五海。言余可意求者。即余五海等。谓有生必有根欲为一。有佛必由愿力为二。必有神变。普周为三。必转法益生为四。有作用解脱为五。则具十海矣。具海既尔。具余例然。此依别答四十问说。若约十海为总。此但答二。下别答八。已如现相品明。则十海之中兼余三十

疏。此十亦对前十海十智者。初一为令即具十智。故云为令众生入佛智慧海故。余九即十海。一即佛海及神变海。二即世界海。三即三世海。四即法界海。五即转法轮海。六即众生根海。七八皆众生海。九即愿海十海备矣。对海既尔。对智可知。如对海故。四赞胜诫听

疏。然通此十下。重释偈文。结云欲委配释恐厌繁文。今当配之。初偈即牒智慧地。及无畏功德。兼含体相显著等十句。以言普现十方光明遍照等故。第二偈即世界海及出现也。第三偈牒佛境。第四偈牒佛加持。第五偈即业海及乐欲海。并调伏海。第六偈前半波罗蜜海。亦兼佛地。次句法界海。末句所行。第七偈即神变海。第八偈前半众生海。后半演说海。第九偈即佛解脱海。及三自在。第十偈即大愿海。余皆兼含。可以意得。非益观智。疏略不言。明欲委释寻文。故抄重出。第二广陈本义

疏。智犹难测下。分三。初总难。二然上十事下。料拣。三释文。二中三。初以十对刹。二以十对种。三以十对海。初中四。一正对。二有云下。叙昔。即刊定意。三则违下。辩违。四若依下。结过。谓尽世界海皆作无差别故。刹海中无差别事。余可知

疏。言有世界海尘数下。三释文。于中四。一正释经意。二牒昔总非。三彰非所以。四逆遮昔救

疏。有云下。第二牒昔总非。云孟浪之甚者。浪谓流浪。孟亦猛也。庄子齐物篇云。瞿鹊子。问于长梧子曰。吾闻诸夫子。圣人不从事于务。不就利不违害。不喜求不缘道。无谓有谓。有谓无谓。而游乎尘垢之外。夫子以为孟浪之言。而我以为妙道之行也。吾子以为奚若。释曰。今不取其事。但取孟浪所出耳。孟浪者。率略之言也。明其无当。向秀云。澜漫无所趣舍之谓。二字要连用

疏。何者下。三彰非所以。寻意可知。而犹恐难见。请以喻明。如一槃中盛于十楪。十楪之中各盛十弹子。一槃如刹海。一楪如刹种。弹子如一刹。若言一槃之中。有一槃弹子。尘数无差。岂得以一槃之内弹子无差以充其数。一槃弹子。但有一百。一弹子之尘已难知数。况一百弹子。尽抹为尘。则数不可量。便将一百之数。以充一槃弹子之尘数故。为孟浪也。得斯喻意。寻数易了

疏。亦不得言通一切世界海说者。第四逆遮昔救。恐有救云。一刹海中刹。不充一刹海之尘。今取一切刹海中刹。以充一刹海中尘数。岂不得耶。亦如一槃弹子之多。不充一槃之尘。若多槃弹子。岂不充一槃之尘耶。故今遮云。若依此义。义则粗通。奈何违下文。下文云一世界海中。即有世界海尘数。不可言一切世界海。共为一世界海尘数。岂得将此而为救耶。亦犹一槃弹子。即有一槃弹子尘数。不言多槃有一槃之尘也

疏。然佛土之义下

疏。文有三。一辩类。二融摄。三释文。今初。说三土。二开三为四。三合四为二。四融二为一。前二则唯识第十意。然初说三者。依三身故。报有自他故为四身。四身还依四土。论云。又自性身依法性土。虽此身土体无差别。而属佛法性相异故。此佛身土俱非色摄。虽不可说形量大小。然随事相其量无边。譬如虚空遍一切处。释曰。此义前品已引。为下文用之故。重委引论云。自受用身。还依自受用土。谓大圆镜智相应净识。由昔所修自利无漏纯净佛土因缘成熟。从初成佛尽未来际相续。变为纯净佛土。周圆无际。众宝庄严。自受用身常依而住。如净土量身量亦尔。诸根相好一一无边。无限善根所引生故。功德智慧既非色法。虽不可说形量大小。而依所证及所依身。亦可说言遍一切处。释曰。功德随所依身。智慧随所证如。余并可知。论云。他受用身亦依自土。谓平等性智大慈悲力。由昔所修利他无漏纯净佛土因缘成熟。随住十地菩萨所宜变为净土。或小或大。或劣或胜。前后改转。他受用身依之而住。能依身量亦无定限。若变化身依变化土。谓成事智大慈悲力。由昔所修利他无漏净秽佛土因缘成熟。随未登地有情所宜。化为佛土。或净或秽。或大或小。前后改转。佛变化身依之而住。能依身量亦无定限。释曰。上皆论文。文并易了。下疏用之。须知所在

疏。统唯二种谓净与秽性与相者。三摄四为二也。诸经论中。皆有于此二种之二。先摄上四为净秽者。乃有多义。四中有净有秽。则三类半为净。半类为秽。二前三为净。以他受用断分别障已证真如。故名为净。变化皆秽。设有七珍。秽众生住。故亦非净。三后二皆秽。仁王经云。三贤十圣住果报。唯佛一人居净土。而生公说有形皆秽无形为净。则唯法性为净。若尔自受用土岂称秽耶。此以冥同真性。不可说其形量大小。则同净摄。二摄前四为性相者。略有二门。一法性为性。余三皆相。二自受用土冥同真性。亦可名性。余二唯相。第四融而为一。则净秽性相。三土四土。无不圆融。即此经意。故云有异余宗

疏。又此净土一质不成下。第二融摄。因上第四义故。略为此融。然东安庄公。本有三句。无有质不成。今加此句。以成二对。谓净秽域绝。不可言一。理唯一味。不可言异。冥同性空。不可言有。随缘成立。不可言无。然一为遣异。无相遣有。然其释中一亦约理。实则一义。有其二种。一约理一。二约事一。如自受用。十方如来同有净土。不可言无。而得称一。故疏成四句。二对不同。又上略举四句。一向遮过。实则即异即同。即有即无。若互相形夺。则一异两亡。有无双寂。若圆融无碍。则即一即多。即有即无。有是无家之有。无是有家之无。多是即一之多。一是即多之一。有无即事理无碍。一多兼事事无碍。由此重重故。华藏刹一一尘中。皆见法界。余如玄中

大方广佛华严经随疏演义钞卷第二十五大方广佛华严经随疏演义钞卷第二十六

        唐清凉山大华严寺沙门澄观述

疏。土既不同下。第二释文于中四。一蹑前生起。二正释经文。三料拣解妨。四次第钩锁

疏。初三者下。第二正释经文释第一句

疏。文有二。一正释。二解妨。今初。言一切净秽者。此通三土唯除法性。以言通慧力所成故。此即偈文智慧神通力如是也。言为物而取拟将普应者。除自受用皆为物故

疏。佛应统之下解妨。此有二妨。一皆名佛土妨。谓土有净秽秽岂佛土。故今答云。秽亦佛土。三界朽宅属于一人。娑婆杂恶居华藏内是我佛土。二然就佛言之。故无国而不净者。通于秽土称为净妨。此由净名经中。宝积愿闻得佛国土清净。而佛答云。众生之类是则不拣净秽秽亦净土。故生疑云秽名佛土。就佛统之秽名净土。复据何理故有此答。然佛土皆净。所以身子见丘陵坑坎。佛言我此土净。而汝不见。言既即秽而净故。不思议者。即以上义会下偈文。偈云。世尊境界不思议故

疏。若是法性即本识等者。约如来藏随缘成立净秽诸土。如三昧品引楞伽说。此从通相不局众生。亦不局佛。若云法尔者。即法尔道理如十地说故

疏。会二文于理可见

疏。业有善恶下。先总释。后净名下。后引证。引三经四文。净名有二皆佛国品。初云以万行为因者。经云。宝积。当知直心是菩萨净土。菩萨成佛时不谄众生来生其国。深心是菩萨净土。菩萨成佛时具足功德众生来生其国。菩提心是菩萨净土。菩萨成佛时大乘众生来生其国。次列六度等。故云万行为因。二又云众生之类。是菩萨佛土等者。亦是此文。次云为法性虽一下。双释上二。疏文有三。初随业成异。释上万行为因。此是土因。二佛随异类取土摄生释上文。又云众生之类是菩萨佛土。此是土缘。三涅槃下。别引他经成其初义。就第二中亦具引文。佛国品宝积献盖。佛为现变化净土相。便求其因故。初问云。愿闻得佛国土清净举果也。唯愿世尊说诸菩萨净土之行(征因也)佛答云。众生之类是菩萨佛土(标也下征释文)所以者何。菩萨随所化众生。而取佛土。随所调伏众生。而取佛土。释曰。上二句总明取土一向为物。经云。随诸众生应以何国入佛智慧。而取佛土。随诸众生应以何国起菩萨根。而取佛土。释曰此明土异之由。下经征释云。所以者何。菩萨取于净国。皆为饶益诸众生故。释经意云。菩萨修因取土皆缘众生。若无众生取土何用。此皆他受用土。及变化土缘故。唯识中二土皆以利他行成。明为物取故。彼经举喻。欲造宫室须依空地。若无虚空终不能成。欲修净土必缘众生。若无众生无修土处

疏。涅槃微善者下。别引他经成其初义。即二十一经高贵德王菩萨品。琉璃光菩萨从不动世界而来。无畏菩萨问佛。此土众生当造何业。而得生彼不动世界。佛以偈答广列十善。一一皆生。言微善者。彼有偈云。若于佛法僧供养一香灯。乃至献一华。则生不动国。若为怖畏故。利养及福德书是经一偈。则生不动国。又云造像若佛塔。犹如大拇指。常生欢喜心。即生不动国是也

疏。观经三心者。有三种。三心第一佛为韦提希现净土竟。韦提希愿生求因。佛言欲生彼国当修三福。一者孝养父母。奉事师长。慈心不杀修十善业。二者受持三归具足众戒。不犯威仪。三者发菩提心深信因果。读诵大乘劝进行者。如是三事名为净业。佛告阿难及韦提希。汝今知不。此三种业。过去未来现在。三世诸佛净业正因。释曰。若具此三何净不致。然以生就佛总名为生。如上引直心是菩萨佛土。菩萨成佛时不谄众生来生其国。第二上品上生文中云。若有众生愿生彼国。发三种心即便往生。何等为三。一者至诚心。二者深心。三者回向发愿心。具足三心者。必生彼国。第三云。复有三种众生当得往生。何等为三。一者慈心不杀。具诸戒行。二者读诵大乘方等经典。三者修行六念。回向发愿愿生彼国。具此功德。一日乃至七日。即得往生。释曰。第三三心多同初三句。而合初二开其后一。此上诸心。非但得生彼国而为生因。亦能成彼净国得为修因故。观经云。三世诸佛净业正因故。今引为佛国因也

疏。上三初一因二缘三因者。然因略有二。一变化因。即第一如来通慧。二感净刹因。即是第三。缘亦有二。一约境利物众生为缘。二摄境从心皆自识变。此中第二义而是真心随缘变耳

疏。次四别明有因有缘者。如镜智所成是缘变化土因。通因通缘。佛以生为缘生以佛为缘

疏。众生菩萨共构一缘者。上已总明即是直心是菩萨净土等。若菩萨自修直心。众生谄曲何由得生。是故劝物同修直心。故菩萨以直心之因。取直心之土。以应直心众生为同构一缘来生其国。万行皆然故云随其行业。言凡圣同居者。即变化土。若他受用唯圣所居。变化之土凡圣同居有二意。一就机化故。二于凡身中初证圣果。尚亦为居之

疏。三四二种他受用土因者。略如上引唯识论文。唯识一向就佛说因。今通菩萨。谓佛因中修此二因。成他受用。即是佛因。二住地菩萨修此二因得他受用。约菩萨因。初地八地地经广说

疏。胜解印持随心转变者。胜解以于境印持为性。印持万境随心转变

疏。一善根所流因中者。即圆融修行自他二利无障碍行。故得尔也

疏。其法性土下。第三料拣妨难。问上之十句含于四土。何以特明三土因耶。故为此释。次复问云。四土之外别说圆融应有五土。故今答云故。其后三但融他四即是我宗。非别有体。其圆融之因亦如上说。又说净土总有二义。一者行净业为因感净相果。二以德业为因感自在净果。行业始自凡夫终至十地。德业始起不动。终至如来故。第二别明是行业净。第三融摄。是自在净。第一总明具斯二净故。疏为三

疏。又此十事下。生钩锁偈中

疏。成唯识下。此下之文前已总引。今当略释大圆镜智相应净识。即果位第八此是依因。依此顿变故。由昔所修下。此是行因。从初成佛下。辩其果相。初明竖长。后周圆下。明其横广

疏。论云。谓平等性智等者。上已具引。先智后行俱是缘因。亦以行为因以智为缘。故云因缘。亦上二皆因。随十地菩萨为缘。如上随所化众生等变化为净土。即是果相。初地见刹等百三千。故名为小。二地即千三地万等。后后大于前前。前前即劣后后渐胜。下所引地义并如本品

疏。又第七偈依中有依下。以义料拣成无碍行门。此即贤首华藏观意。彼有五门。一成立因缘。正当此门起具因缘。二相状布列。即华藏品风轮香海等。三具德圆满。四依正融摄。五摄成观智。今疏有二。先牒经略明即彼第四。二从然其无碍通有十种下。即彼第三但解此二自成观智。略无第五。然彼具德指一香树。亦明十义。一此香树即佛智身德。二即转法轮。三事理无碍。四悲智德。五难思德。六体用无碍。七定乱无碍。八微细德。九佛境界德。十缘起无碍德。而内外相参以成十门。亦不引证。今为顺经加减废立皆引文证。而具事理事事无碍。疏中有四。初总摽。二诸教说土下立意。或是无常者。通大小乘。或云心变。唯是大乘理事悬隔明非实教。三一事理无碍下。开门别释。一中引经即第十经偈末句云。安住于空虚今但取庄严为事法界为理无差别言即是无碍。二成坏中不引文者。义易了故。亦是此偈故云一一。刹种中劫烧不思议所现虽败恶其处常清净。三中经云。体相如本等者。即第八经释刹种章偈。及后四相入中所引。即前偈前半具云以一刹种入一切。一切入一亦无余体相。如本无差别无等无量普周遍。五相即无碍证文即第七经。六清净珠玉等即第八香水河偈。具云清净珠玉布若云一切香河悉弥覆其珠。等佛眉间相炳然显现诸佛影。今但取初后二句。是显微细之义。七隐显中略不引经。以义多故。即此中偈。随心造业不思议一切刹土斯成立。即其义也。以同处异见故不可思议。又形状偈云。一切尘中所现刹皆是本愿神通力。随其心乐种种殊于虚空中悉能作。释曰。既一尘随乐种种皆作则隐显自在也。然疏文中略出二种隐显。一染净隐显。如感娑婆者。对华藏而见娑婆。则净隐染显。感华藏者。对娑婆而见华藏。则染隐净显故。摩竭提国其地金刚等。二明异类隐显。如须弥山形世界。一类显时江河等形即皆隐也。长刹显时短刹则隐。余可例知。八重现无碍亦不引文。以华藏世界所有尘一一尘中见法界已频引故。若更引者。依住偈云。或有国土周法界清净离垢从心现如影如幻广无边。如因陀罗各差别等。九所引即第八经释小海中偈十中。又下文云。即第八经河间树林偈

疏。此十无碍下。四结释六相之义。略如前说广如十地别章

疏。如何广大下。随难别释。释第八九有二义释。前通诸教。后由无漏下。即事事无碍宗故。上普贤云。一切刹土入我身所住诸佛亦复然。汝应观我诸毛孔。我今示汝佛境界等

疏。所现国土似彼报故重重而现。不离一毛者。如十盏灯共照一毛。则一毛之上有千重光也。准喻思法

疏。第四刹体中诸教不同下。即五教出体释有二意。一则别配八微是小乘。唯心是始教。法性是终顿二教。或一切法是圆教。二则通明圆教具于四义。顿教唯法性小乘唯八微。始终二教通于前三。若三各别即二是始教。若三无碍性相圆融即是终教故。法相宗出体之别。一法性土。以真如为体。二实报土。力无畏等。一切功德无漏五蕴以为体性。若摄相归性亦真如为体。三色相土。摄境从心自利后得智为体故。佛地论云。最极自在净识为相。相即体相。若约相别即四尘为体。四他受用土。摄境从心利他后得智为体。摄相归性亦以真如为体。若约相别亦是四尘。五变化土同前他受用体。是知始教具用三法。圆教则以性融相相无碍故通一切法。则事事无碍而为其体。是故疏云。今皆具之。次引经具收。后融无碍

疏。第五段刹庄严中至或宝为严等者。然庄严有三。即名三净。一处所净。即众宝为严。二住处众生净。即人宝为严。三法门流布净。即以法为严。对文可知

疏。第六段明刹清净。疏文有四。一总摽大意。二别显其相。三对教拣定。四对文拣滥。今初。言唯约净者。以言清净故不同形等。通于染净。言行致者。即生公意。彼净名注云。行致净土非造之也。造于土者。众生之类矣。十四科中释致义云。问云何致而非得耶。答夫称致者。体为物假虽获非己。释曰。谓因他而得故名为致。谓佛修万行直趣真极不取色相。他受用等因他众生。遂以大悲为物取土。故云行致。既因万行而致于土必招净也

疏。然净有二下。第二别显其相。展转开之乃成四重。皆以方便为因清净为果。第一对中言以六行为方便者。谓厌下苦粗障。欣上净妙离故。以色无色界而为净土

疏。此复二种下。第二对二乘净土玄中已明

疏。然出世上上净中下。第三对言仁王经等者。即菩萨行品。波斯匿王赞佛。此前一偈半云。正觉无相遍法界。无生忍尽智圆明。寂照无碍真解脱。大悲应现无与等。湛然不动常安隐。光明遍照无所照。三贤十圣住果报。唯佛一人居净土。在文易知。若璎珞经亦云。佛子有土名一切贤圣所居之处。是故一切众生一切圣贤。各有自居果报之土。若凡夫众生住五阴中。为正报之土。山林大地名为依报之土。初地圣人亦有二土。一实智土。前智为住后智为土。二变化净秽经多劫数量应现之土乃至无垢地土亦如是。一切众生乃至无垢地。尽非净土住果报故。唯佛独居中道第一法性之土。是故我昔在普光堂。广为一切众生说净土门。以上二经唯佛为净

疏。未极之中下。第四对也。言永绝色累者。即生公十四科净土义云。夫未免形累者。八地已前在生空观。即净土出即居秽土。八地已上长在生空。即长在净土。故须托土以自居之。八地已上永绝色累。照体独立神无方所。土复何为。意云。八地净无生忍得色自在。舍于分段故云永绝色累。一切世间出世间心悉不现前。故云照体独立。称性普周故云神无方所。神即心神。易云。神者。妙万物而为言者也。故神无方而易无体。既无色累。故其土相难以名目

疏。七地已还等者。未出三界者。依直往者。未舍分段故。无漏观智有间断者。即六地已下若至七地观无有间。依十地经六地已下为染。八地已上为净。七地亦名中间。亦可名染亦得名净。或非染非净。今取染义故非纯净

疏。若依瑜伽下。第三对教拣定可知

疏。然净方便下。第四对文拣滥。于中有二。先对此文。上来四对。皆约清净为果方便为因。今以义通方便亦果。亲近善友即是方便。今得人宝为严则兼于果故。极乐等土诸上善人俱会一处。是等流果也

疏。然望庄严下。第二对前文拣也。如庄严中云。或以说一切菩萨功德庄严与此增长广大功德云遍法界故文同。又彼偈中多举因显果。与此长行同。此云慈悲广大遍众生。以此庄严诸刹海。与庄严同起具因缘。诸净刹因与此长行修净因同故。为此拣

疏。文有二。一明门别。谓所用虽一用处不同。犹如说法在布施门名为法施。在智慧门名为方便等

疏。又起具下。更以别理拣于二门。则具缘是通此处则局故。前疏。云唯约净也。对于庄严则多少不同。如多药和合从疆得名。定中有慧但资于定。慧中有定但名般若等。故云彼多约果。此多约因。从前多修善者亦从多少。前则以因对果论其多少。此则唯就因中自有多少。前云菩萨无边功德海。及普贤行愿。诸佛子等众生劫勤修习此多修善也。今乃文。云净修广大诸胜解成就方便清净力。即治恶多。文显可知

疏。如善财夜神处说。即七十三经大愿精进力夜神善财初见。起于善知识同已等十心。便得佛刹微尘数行。所谓同念心常忆念十方三世佛故。同慧心分别决定一切法故等。广如彼说。此下数段皆如十地经文

疏。前半方便。后半清净者。以各下句有方便清净言故。言皆上句果下句因者。从多分说。则方便为因清净为果。若从通说俱通因果。方便约因。善巧出生于土。方便约果。依正业用是净土相清净。约因离诸障盖。清净约果无有三恶八难等故

疏。初二随彼类者。如佛出娑婆但可丈六。若生极乐无量由旬。不可以无量由旬之如来。以化三尺身众生。丈六之佛化万丈之人寿。亦然矣。居于此刹不满百年。弥陀人民寿皆无量。然此一对亦通化机多少。次一缘广狭者。缘广则刹广如文殊普贤之邦。缘狭则刹狭如迦叶光德之国。四宜闻三则秘一乘之妙宝。宜闻一则废羊鹿之小车。五根熟者。化多如释迦之化。未熟则化少如须扇多如来亦是因中缘广狭故

疏。一念与劫下。释唯心方便之义。然一念与劫。并由想心。此有二意。一者由有想念。即有刹那。积此刹那终竟成劫。心想若灭生死长绝。此顺经文。二者一切境界皆依妄念。而有差别。若离心念则无一切境界之相。此顺经意。成唯心观是故。疏云。心想不生长短安在。无长无短即心体清净。是以经言以一方便皆清净也。此约真性故。第三句是不坏相义。相性无碍刹海义也

疏。二唯约住劫之中居人善恶。复有二义。一约众生引因所得。二约菩萨居中作用。心纯善故染净交彻耳

疏。一遇恶缘故净变为染。即是劫中染污众生住故。七十二经云。往昔此城邑大王未出时。一切不可乐犹如饥鬼处。众生相杀害。窃盗纵淫佚。两舌不实语无义粗恶言。贪爱他财物嗔恚怀毒心。邪见不善行。命终堕恶道。以是诸众生愚痴所覆蔽。住于颠倒见上恶缘也。天旱不降泽以时无雨故。百谷悉不生草木皆枯槁。泉流亦干竭。大王未兴世河池悉枯涸。园苑多骸骨望之如旷野即劫变也

疏。粳米自然生等。即是上经次文云。大王升宝位广济诸群生。油云被八方普雨皆充洽。乃翻十恶成十善也。其中翻偷盗云。往昔诸众生贫穷少衣服。以草自遮蔽饥羸如饿鬼。大王既兴世粳米自然生。树中生妙衣男女皆严饰。即其事也

疏。三即地前者。信解是地前通称。亦名胜解行住。未证真如但依解力而修行故

疏。或以多庄严而严一刹者。如第五回向即愿。普摄十方三世所有佛刹一切庄严。而严一一刹一切亦然。至登地竟能如愿成。如八地十地中说言。或以一严而严多刹者。第二回向云。以一庄严严一切。亦不于法生分别。如是开悟诸众生。一切无性无所观。如上口光召众者。即第六经。其诸菩萨既至会中现自在用。如是坐已。其诸菩萨身毛孔中。一一各现十世界海微尘数一切宝种种色光明。一一光中现十世界海微尘数诸菩萨。皆坐莲华藏师子之座。此诸菩萨悉能遍往一切法界。诸安立海所有微尘。彼一一尘中皆有十佛世界微尘数诸广大刹。一一刹中皆有三世诸佛世尊。此诸菩萨悉能遍往亲近供养等。即严微尘中刹也

疏。佛灭度百年乳不及水者。育王经说。育王常供养诸圣僧。上座食乳稍多。育王白言。乳若多食恐生疾患。上座云。此乳有何力。不及世尊在世时水。今佛灭度一切精淳皆沈地下。育王愿见佛在时水。上座展手地下取水。育王尝之实过于乳。明知福人灭矣。能事随灭。百年上尔。况今去圣将二千年。尤更淡薄况于减极。铁为上严稗为上味。如起世等经说

疏。八如弥勒来者。即弥勒下生经说。佛告舍利弗云。四大海水以渐减少三千由旬。是时阎浮提地长十千由旬。广八千由旬。平坦如镜名华软草。遍覆其地。种种树木华果茂盛。其树悉皆高三十里。城邑次比鸡飞相及。人寿八万岁。智慧威德色力具足安隐快乐。有一大城名翅头末底。长十二由旬广七由旬。其城七宝上有楼阁户牖轩窗。皆是众宝真珠网覆。堑广十二里。街巷道陌处处皆有明珠之柱。处处皆有金银之聚。便利不净地裂受之。受已还合。亦无衰恼水火力兵及诸饥馑毒害之事。园林池沼八功德水众华异香皆悉盈满。不生草秽。一种七获味甚香美。增色力身等广如彼说

疏。净名足指案地者。即佛国品说。随其心净则佛土净。尔时舍利弗承佛威神作是念言。若菩萨心净则佛土净者。我世尊本为菩萨道时。意岂不净。而是佛土不净若此。佛即答云。我此土净而汝不见。尔时世尊即以足指案地。即时三千大千世界。若干百千众宝庄严土。一切大众叹未曾有。而皆自见坐宝莲华等是也

疏。法华三变净土者。即宝塔品大乐说请开塔户。佛言。须集分身。大乐说请集分身佛。世尊放光远召。为欲受分身佛故。一变娑婆。二于八方各更变二百万亿那由他国土皆令清净。坐佛不足。第三更变二百万亿那由他国土。皆令清净。故云三变

疏。谓前九辩诸世界约相不同至皆周遍故皆释标名。于中有三。一约性相相对。相则有差性则无差。二又约权设下约权实相对。实则无差。三又皆是诸佛之所用故下。收差与无差皆归果用。前之二对性相权实二不相即。今则融即。言无差之差者。是圆融上之行布也。差之无差者。是行布上之圆融也。若离圆融则无可差别也。若离差别无可圆融。如揽别成总。非离别外而有此总。引法华经但明二不相离。由依此义下。显十八圆满由此而成

疏。尽海之尘一尘一刹已是含摄之义者。以经云一一世界海中有世界海微尘数世界无差别。谓一个世界海。还有世界海微尘数世界。则义当一尘是一世界竟。唯就此一句已显融摄释。无差别义善成矣。若界界相望论无差者。无差全少。今十句中句句各有世界海尘。则一海之中已有十世界海尘数无差故。须融摄思之

疏。而前但约平漫无差者。即长行云。一一世界海中所有佛威力无差别。今乃皆云一一尘中无量光等。即是重叠无差别也

疏。若云约共同事下。结弹古人。谓经举十事皆约融摄。若依昔义。何以不言一一世界海中染净无差别。一一世界海由众生受苦无差别。以世界海中皆有染有苦故。故疏结云。岂世界海中都无此耶。今经不言。明知约融摄无差别耳。世界成就品竟

    华藏世界品第五(尽第二会初如来名号品)

疏。梵本具云等者梵云拘苏磨(华也)多罗(藏也)骠诃(庄严也)阿楞伽(严具也)噜迦驮都(世界也)三牟达啰(海也)钵履输陀(云遍清净也)惧曩(功德也)三牟达啰(海也)阿罗婆(上)娑(光明也)钵履勿多(品也)此云华藏庄严严具世界海遍清净功德海光明品。然疏文有四。一举梵名。二译者嫌繁下申其义释。三其梵本云下释前梵本。四约事可尔下。核其本源。不为此释岂委刹海之兴由。三宗趣言有十德者。前品已引四文也。疏初明华藏因果自体者。然第二安布庄严亦是果相故。应对果分因。总为二段。谓先明刹因。后彰果相。以第一段中长行具有因果。偈中双明因果。故合于因。属自体中。疏谓指此刹海。是我本师下疏文二。先通释经文。后随难别释。今初疏不唯胜观释迦等者。俱舍论第十八说。于三无数劫各供养七万。又如次供养五六七千佛。三无数劫满逆次逢胜观然灯宝髻佛。初释迦牟尼。释曰。此三偈中初偈明供养佛。数谓初无数劫供养七万五千佛。第二无数劫供养七万六千佛。第三无数劫供养七万七千佛。后颂意明供养何佛。言逆次者。从第三无数劫向前以明。谓第三无数劫满逢胜观佛。第二无数劫满逢然灯佛。第一无数劫满逢宝髻佛。最初发心逢释迦牟尼佛。发誓愿言。愿我当作佛一如今世尊。彼佛世尊末劫出世时法住千年。今我如来一一同彼。故今疏云。不唯胜观者。举第三阿僧祇劫满佛。言释迦者。举初发心之佛。而言等者乃有三义。一等然灯宝髻。二等所供佛数。三等余教所明。设言供养三十六恒三十八恒佛等。皆未足为多也

疏。不唯净一无生等者。如智论说。五华供养然灯得无生法忍。故金刚经云。若有少法可得。然灯佛则不与我授记等。无法可得是无生相。而言等者等余法门。俱舍颂云。但由悲普施被折心无忿。赞叹底沙佛。次无上菩提六波罗蜜多。于如是四位一二又一二如次修圆满。释曰。初之四句即是四位。初位一满。谓普施成檀。次位二满。谓尸及忍。被折不报故能满尸。由内无忿故成于忍。第三位中但一度满。谓精进度。第四位中定慧双满。故云一二复一二等。言底沙者。此云圆满。赞佛偈云。天地此界多闻室。逝宫天处十方无。丈夫牛王大沙门。寻地山林遍无等。七日七夜忘下一足叹底沙。故超于弥勒九劫先成佛。智论之中亦同此说。故六度满前后不多。今经一一佛所净修世界海微尘数大愿。况于多佛况多劫耶。故结云由上三重故云深广。疏然瑜伽起信下。第二随难别释。即重释三祇。约三乘一乘以通。言该通十方者。对上一方化仪言。及树形等界者。对上一类世界。且如娑婆一劫方知安养得为一日。则安养世界乃经三无数日耳。更方袈裟幢刹未经岁月。况于后后以劫为日之刹耶。是则不可以此一方一类定于成佛时劫之数。二异类刹者。即于一界即具诸界互不相见。时劫亦殊安知修短。故朝菌不知晦朔。况识春秋耶。况于大椿之岁耶。言宝云经者。经云。善男子。菩萨不能思议如来境界。如来境界不可思议。但为浅近众生说三僧祇修习所得菩提。而实发心已来不可计数。贤首释云。不可计者不可计数阿僧祇也。义分齐云。始教三祇不同小乘十十数之。此即倍倍数之。仍说百劫修相好等。智度论破此别修相好。不许三祇之外别修。即是实教之意。然实教之意。自有二义。一定。三僧祇一方化仪故。又是实佛故。起信云。或示超地速成正觉。以为怯弱众生故。或说我于无量阿僧祇劫当成佛道。以为懈慢众生故。能示如是无量方便不可思议。而实菩萨种性根等。发心则等所证亦等。无有超过之法。以一切菩萨皆经于三阿僧祇劫故。斯则定也。二者不定。复有二意。一为通余类世界故。如胜天王说。即前树形等刹是。二据佛实德无限故。如宝云经。若瑜伽说有二种无数劫。一者日夜月半月等方便显时无量故。二者如常说。若依初义经无量劫。若依后义但三僧祇。然依此释不同宝云。宝云不言为浅近众生说于大劫。为于深胜说日月劫。明知意殊。是则瑜伽亦是一方所宜说耳

疏。又时无别体下。别教一乘融摄以说。如毗目仙人执善财手时经多劫。处历无边故不可以长短思也。若显超胜一生顿圆。若约甚深多劫莫究。故云不可定执贵在入玄

疏。第二诸佛子下彰果体相。疏文有四。一总相生起。二彰其分量。三科释经文。四用义通局

疏。然所依刹量下。第二彰其分量。言大小之化者。如梵网经周匝千华上复现千释迦。即大化也。一华百亿国。一国一释迦。即小化也。小化唯一四洲。大化总该百亿。且依一相等者。且依一种义相。不坏边表。有莲华外别佛刹海等实则称性横不可寻。故云法界无差别。若以性融相则一尘中法界无量。疏然准下别显。下第三科释经文。言应有十事者。以文广释十事故。此中长行略标列故。是以古德一品之中。先分土因。就果相中即分十段。今不依者。以下六事各有长行偈颂。而前四事同一长行。故科十段于文不便。先科为三。于第一华藏自体中长行之内。方为四耳。疏然其刹因下。第四明用义通局。已见上文者。即起具因缘中通义易知故。示别相。列中疏风力遥持者。古有二释。一云一重风轮持一重物。疏以出现品中。有十风轮持欲色等。皆是遥持故。今案定。疏所持香海下。疏有二释。一约事释。二又藏识下约表。于中又二。一约众生。二又佛性名水下。约通生佛。佛性即是真法性故。故此品初海表三义。今举其二略不说悲。涅槃亦云。有人闻香即第七经。至问明品当具引之。疏又所发万行下。上约事释。此约表法。但通相表行。若别说者。略示十德表于十度。一开敷鲜荣以表施度。二自性无染以表戒度。三香气芬馥。四宝茎坚固。五宝叶扶疏。六宝蕊光幢。七相巧成就。八含藏莲子。九宝台坚住。十普放光明。下八如次显于八度。疏宿因现缘经离颂合等者。此中詺长行为经。以取长行缀葺略说所应说义。别相修多罗故。言经离颂合者。宿因即前显因深广。现缘即前风持香海等。此二离明言颂合者。初偈颂总。前半宿因。后半现缘。第二偈三句宿因。第四句是现缘故。疏所成果相。经略颂广者。长行云。华藏世界海住在其中者。即所成果相此文则略。以十偈之内皆有果相故云颂广。疏三现缘风轮经广颂略者。经列十种风轮。偈中但云风力所持无动摇耳。疏四山地海树经有颂无者。长行云。金刚轮山周匝围绕。地海众树各有区别。此经有也。颂无可知。上言有四者。但有四例唯广略一种。乃成一对离合有无。但成一例耳。若成对者。应须经合颂离经无颂有方成三对耳。余四例二对。此中则无下颂则有。疏是无边之边不碍理而即事等者。意明理无分限总曰无边。事有分限故名有边。若理成事理性全隐。则无边即边。若会事归理事相全尽。则边即无边。今则不尔。不失理而事现。云无边之边。不坏事而理显。云边之无边。此是事理无碍义不是相即。相作之义思之。疏但云诸严下。此句稍长故。牒释云。即从诸庄严具下是第九句。摩尼妙宝下皆第十句

疏。准下刹种及梵本皆有十者。以中一海管十海。而此十海一道布列。结有不可说佛刹微尘数香水海。十道皆然。一海一种故。有十不可说也。言下摽种处亦然者。摽云。诸佛子此不可说佛刹微尘数香水海中。有不可说佛刹微尘数世界种。释曰。此即摽种处无十字亦例合有

疏。芬陀利即白莲华者。即唐三藏等诸师所翻而言。亦是正敷荣时者。即付公意故。睿公法华序云。华有三时之异。华而未敷名屈摩罗。凋而将落名迦摩罗。处中盛时名芬陀利。生公亦云。器像之妙莫踰莲华。莲华之美荣在始敷。始敷之盛则子盈于内色香味足。诸之芬陀利。意亦同也。今存二译各是一义。梵语多含故两存耳。疏即随一一心同时相应功德流注者。大海既喻藏识。小海复表种子。二皆心王故。河表同时心。所谓善十一遍行别境二。千福河流注心地也

疏。严中严事下。释第二辩严也

疏。中先略释。后结十句可知。今先示十句后示别释。十句者。一岸体金刚。二净光下摩尼严岸。三常现下现佛光色。四及诸下出同类音。五其河下旋澓出影。六摩尼下网铎垂覆。七诸世界下总显多严。八摩尼宝云下宝云覆上。九复出妙音下浪出妙音。十其香水下水涌光云以文易知。故长行不出。但偈中具示。今示略释者

疏。云宝体是初句。宝严是第二句。圣灵游集即三四五句。光云相映即六八。与十万像浮辉即七九二句。疏如剑叶林者。其林树叶犹如刀剑下即伤人。言如天意树者。涅槃四十二问中。当第二十四问云。云何观三宝犹如天意树。言天意树者。随天意转故。至第九经方始答之云。复次善男子。如庵罗树及阎浮树。一年三变。有时生华光色敷荣。有时生叶滋茂蓊郁。有时凋落状如枯死。善男子。于意云何。是树实为枯死不耶。不也世尊。善男子。如来亦耳。于三界中示三种身。有时初生有时长大有时涅槃。而如来身实非无常。释曰。意明三宝随物转变而实常存。如天意树随天意转而实不死。随天之意明是善业矣。言男女林者。即楞伽第一百六问。云何男女林。一百七问。云何诃梨勒阿摩勒。解曰谓令观世间如男女林等。依立世阿毗昙论第一云。阎浮提林外有二林。一名诃梨勒。二名阿摩勒。此二林南复有七林中有人林。是人林中果形如人。如阎浮提圣人王种。若男子十六岁如女十五岁庄严具足状如行嫁。是人林果可爱如是。其子蔕形如人头髻未离欲者。见此果子便生爱心。诸外道等有离欲人。若见此果即失禅定欲心还生。其子熟时唯鸟竞食。鸟食之余残落于地。如尸陀林甚可厌恶。诸退禅定者。见是相已。深生厌离还得本定。意表世间男女如林所见荣饰悉皆如幻与此无别。遍计所执妄谓之实。菩萨观之都无所有。故楞伽云。观诸众生如死尸无知。以妄想故见有往来。若离妄想如彼死尸无鬼入中云为自在故。有经说菩萨所见世间资生无非实相。此之谓矣

疏。后三结严所因。疏文有三。初总明。二然此三偈下别释。三显华严下结叹。二中示难思相。总有六重。六重之中皆通一偈而各取一句中言。又此四句各是一义。如第一偈初句所现之境。二能现之处。三所现相。四能现之因下二例。然其第一重料拣初句所现不同。三偈各一世间。而初偈是初句。次偈是第二句。后偈是第二三两句。言影略其文者。谓随一能现。能现三世间。今各举其一故云影略。非但此义六重皆影略

疏。又初明一果。能现下第二重约现处明矣。初偈是第二句。后二偈皆第一句

疏。又初明佛力下。第三重约能现因差各显一因。皆第四句

疏。又初果后因愿通因果者。是第四重亦约现因明异。重释第四句而约因果不同

疏。又初自下第五亦约能现因。句亦第四约二利不同

疏。初明即性无性下。第六重约所现性相明差。三偈皆第三句。以各见不同同体无来等故。此之一义更须解释。谓若顺上释既从佛力等因故。所现之体即无生等。二者此句亦是能现。由体无生故。现而叵取。称性而来故无来去。随机隐显各见不同

疏。应成四句者。文出二句。三一因一果释文已用。四多因多果随修一行无德不招。广如问明及升兜率品四句相融故。一一难思

疏。一者令多等者。第四偈一切刹海咸周遍。是令周给他也。第二偈中靡暂停。第三偈中恒闻见是令常也。第三偈中其音美妙是令妙也。第十偈中无等无生无有相是称性也。第八偈能于一切微尘中。普现其身净众刹。及第九偈一刹那中悉能。现皆自在也

疏。后半悲应即他受用及变化净。一偈之中四土具矣

疏。摽二章者谓种及刹下疏文有三。一总释征名。二欲明世界下双显名相。三而言世界下对难释通。于中二。初通世界无边难。后若尔下释种无体难。虽依种类下释通。于中先正释。二结成。今初。前为成海故取种类略无别体。今别喻蜂窠以彰有体。蜂孔如刹一窠如种。则显鱼龙乃成分喻

疏。即依后义下二结成也。先会同晋经成种性义。种有二义。一类二性。以禾喻种以粒喻刹。禾能生谷故有性义。二恐滥下显今经意亦是通难。难云。若有种生之义何不依昔为世界性故。为此通则种兼二义。今经存之。疏今初也。然此十门刹种之异下

疏。文分四。一显种所依。二对前会释。三随文别解。四别示义门

疏。所列十事下二对前会释。于中亦四。一总显不同。二若别别相望下。互出同异。三皆显十下彰互所以。四何以起具。前有此无下。牒问释成圣即问也。问意云。一种起具等五此无前有。方所等五此有前无。从前段总明下答也。答中对上牒起具问。而下结云余可思准者。即是结例余四但用何等世界住言总通五难。劫住即是果起具是因。此通易了余四犹难。谓清净佛出劫住转变正是果相正辩果住何得全无。今云无者。清净方便亦是约因。又不通染今则通染。又不语因佛住约人今此辩刹故亦无之。劫住转变此二竖明。今语现住。亦非此要故略不说

疏。然与前同下第三随文别释。但解五句。言若圆满方所等者。释此五句皆是十八圆满中意。次下当明。此中每句各二义。方所二者。圆满方所即自受用。方所如上引唯识明自受用土相。随宜方所者。即他受用及变化净。然依佛地十八圆满。唯约他受用说。今约圆通故进入自受用下该变化

疏。依门趣入等者。彼有事门即如向说。二约法为门。今但出此。又互相现入者。是约此宗以辩门义。并如下说分齐分二。随宜即他受用等。约佛即自受用土。行列与下第十加持。各约事法分为二问。圆满方所云无处不有。圆满分齐十方无际二相何别。答若识随宜方所分齐。即知圆满二相不同。谓随宜方所者。此之净土十方之内为在何方。如极乐在西妙喜在东等。言分齐者。此之净土广狭云何。或等一娑婆。或等百千是分齐也。是则圆满方所明无处不有者。即遍在一切处也。分齐云十方无际者。量周法界也

大方广佛华严经随疏演义钞卷第二十六大方广佛华严经随疏演义钞卷第二十七

        唐清凉山大华严寺沙门澄观述

疏。又此互出显佛净土十八圆满十五摄故下。第四别示义门。于中三。初摄十八圆满。二摄世界成就。三拣定所宗。初中四。一总标。二列名。三正摄。四同异。今初总将二品之文。共摄十八圆满。疏言十八下第二列名文无次第及圆满言。而十八具足。一显色圆满。二形色圆满。三分量圆满。四方所圆满。五因圆满。六果圆满。七主。八辅翼。九眷属。十任持。十一事业。十二摄益。十三无畏。十四住处。十五路。十六乘。十七门。十八依持圆满。疏云何摄耶下。第三正明相摄先征。此具下释。释中文意皆是佛地论中之意。细寻可知。十八名相第五回向更当广释。此但举于此十五名摄彼十八。其有难者引经会释

疏。劫住转变十八中无下。第四明同异通有四种同异。此有二门。一立名同异。如上别对中明二开合同异。亦如上说。然上体及佛住。各摄于二清净庄严各摄于三则四门摄十。余之八门各摄其一。则十二门以摄十八。即开合异也。三有无异。即是劫住及劫转变释无所以。略有二意。一以彼摄此。谓果摄劫住有刹之果。必有劫住之时分故。事业圆满摄此转变。菩萨神通如来作用皆转变故。二者不用彼摄何必定须十八圆满。加于此二以成二十数正圆满故。如以六通为十通等。谓劫住穷未来故下示于二种圆满之相。四从其无差别下明通局同异。彼十八事各各不同。今无差别通该十八。由无差别约融摄说。故令十八得圆满名。则此十四皆约随宜由此无差别故名圆满无差。既同下蹑迹生难。上云余十四事皆是随宜。故称各各。其无差别称实而说。令余圆满则无差别。非各各义。何以经云各各无差。今答此云所无差别事有多种故者。上经中明尘尘刹刹佛佛生生皆悉融摄事事相望。即云一一各各融摄。即是无差

疏。若将此十对成就品下第二摄成就品摄前十八。共以二品皆为能摄。今此对前自分能所而得互摄

疏。恐责繁不能具出。抄须尽理一一示之。此华藏品摄成就品者。此中趣入摄彼起具因缘及清净二事。以趣入即三解脱门可为刹因令刹净故。此中力持摄余三事。谓佛出劫住及劫转变以力持即是广大法喜。无佛从何得法喜耶。况有佛持。若佛不出但以食持。若佛出世即有法持。若以食持住时即少。若用法持住劫则长。二种力持皆通转变。法持则染变为净。食持则净变为染故。俱舍说三灾起时有二种因。一耽着美味。二者懒堕故。以食持净变为染。上以此二摄于彼五。五事全同故十具矣。若以成就摄华藏者。上以此二门摄于彼五。则以彼五摄于此二。此余三事谓方所分齐。并及行列彼何摄耶。即五同中依住形状二事所摄。以但有依住则有方所及行列故。但有形状则有分齐。则以彼七摄此五事。五事全同则十亦具故。于二处各举十事无所不收。巧显多端故互隐显。理实互出为显十八

疏。又上诸文下第三拣定所宗可知

疏。此彼相入亦颂趣入者故。上疏中释趣入义。以为此解。于中有二。先略属偈文。后皆入而无入下通释二偈入无入言。唯前偈中有义通后偈故致皆言。总有三意。初一反释通缘起相由及法性融通二门。约缘起门者。凡缘起法要有三义。一诸缘各异义。二互遍相资义。三俱存无碍义。今云入则坏缘起者。反释不入入则失缘则无诸缘各异之义。言不入则坏性用者。反释入义则不得不入。不入则不得力用交彻故。无互遍相资之义则坏用也。若具入不入则俱存无碍。成缘起门。言法性融通门者。即性之一字。凡法性融通要不坏相而即真性。入则坏缘起者无可相入。不入则坏性者。则性不遍一切法故。由不坏相而能普遍方是法性融通义也。二又要由不入方能入耳者。即顺释也。亦通二门唯就相说。若约缘起门要由诸缘历然不入方能相资遍相入耳。若约法性融通门者。要由事相历然方随理融入一切法故。说若唯约理无可即入。三又约体空下。亦顺明而双约性相。上第一义相即不入性即能入。今此一义独相独性俱不能入。要二相融方能入故。言若约体空则无来无入者。是若唯约性无可即入义。言约相不坏如本无差者。即若唯约事不能即入。上二皆是不入之义。言以性融相故得互入者。即释入义是显正义。谓不异理之一事全摄法性时。令彼不异理之多事随所依理。皆于一中同时现等。一事摄理既尔。多事摄理亦然。则一事随所依理。皆于多中同时顿现故得互入。是为法性融通门。如义分齐。疏海能有华故受华名者。以海名无边妙华光故。如莲华池池受华名华依于海取海底称者。海以摩尼王幢为底故。华名摩尼王庄严。如泥中华华受泥称。疏但有二百一十者。第一层一佛刹尘数世界。第二层二佛刹一上加二为三。第三层加三为六。第四层加四为十。第五层加五成十五。第六层加六成二十一。第七层加七成二十八。第八层加八成三十六。第九层加九成四十五。第十增加十为五十五。下十增有五十五。上十层一一渐加算数亦有五十五。而各有十。谓十一十二十三十四等。上十层更有一百。都有一百五十五。并下层五十五故。有二百一十矣。问既有二十层。何以但云十九佛刹为主刹耶。答以最下一层。但云一世界非一佛刹尘数世界。故云从此一界去。云此上过一佛刹微尘数世界至第二层故。二层共有一佛刹尘数刹耳。如竖二千钱为二十百。最下取一钱。如最下一刹此上过一百钱为第二层。方共一百。尔此上过一百至第三层。方是二百。至二十层方有一千九百文耳。故二十层成十九佛刹思之。疏下当会释者。即第三会能绕所绕类结之耳

疏。六眷属者。即经中云种种安布种种庄严。是辩眷属刹相状耳

疏。天为圆穹者。外典说天或谓有形。故云天形穹隆其形如[金*敖]故。天圆地方。若庄子云天者自然也。则无形质

疏。亦如法华云。梵王为众生之父者。即第六经药王本事品中云。譬如大梵天王。为一切众生之父。此经亦复如是。为一切众生之父。以梵王劫初时生。后有诸天下降梵王。凡夫皆悉妄计梵王为父。诸经论皆破为非。是外道计。今法华经如来自引以譬。法华岂佛不知是父为妄。故是世尊随俗说耳。今亦随俗说天有形于理何违。然今疏非不许静法之见。但己着在经小有可通。即为会释。不欲使人轻毁圣教耳

疏。误译洛刹曩者。洛刹曩。此云相也。恶刹攞。此云字也。声势相近故使有误。梵本是室利跊蹉洛刹曩。合云吉祥海云相也

疏。然此相以为下疏出古德。以吉祥海云为万。合云万相者。即结成静法正义。纵汝吉祥海云为万合言万相。不合云万字。疏此所结刹定是主刹者。以昔人云经言此一一世界者。此上二百一十佛刹尘数之刹耳。非此上不可说佛刹尘数之刹也。以二百一十尘数刹为所绕。两重绕竟方有不可说耳。故立理云。若不将此以会大数。一即此刹种中非唯有不可说刹尘数广大世界。二即三处说数相违。释曰。此上意云。若所绕已有不可说佛刹尘数。更加两重绕刹。则有众多不可说佛刹尘数刹也。言三处说数相违者。一是标中有不可说。二中间说但有二百一十三。是结文两重。能绕初则有不可说。后则有无量不可说。中间则不满不可说故相违也。此释亦似有理。而经此一一言远承于前二百一十殊已隔越文中既云如是有可不说佛刹微尘数佛刹。即云此一一世界各有十佛刹微尘数广大世界周匝围绕。明知合绕前不可说也。又以二百一十为所绕者。前中间说刹但超间。明有二百一十。望其文意直上十九佛刹尘数之刹。一一各有众多佛刹围绕。应有不可说不可说也。何者。且如最下一刹已有一佛刹微尘数佛刹围绕。向上过一佛刹微尘数世界。方至第二层一刹有二佛刹微尘数世界围绕。此第一层向上至第二层中间诸刹。何以无绕刹。若无绕则刹网不成。故知。直上一佛刹尘数之刹。一一皆应有绕不能具说故。有超过举二十重耳。既最下层一刹有一佛刹尘数刹绕。此上次第二刹更加一刹为能绕。第三亦加一刹。如是渐上至百加百至千加千至万加万至满佛刹尘数。到第二层还加一佛刹微尘数刹为能绕故。有二佛刹尘数刹绕。如是乃至第二十层亦复如是一一渐增故。但直上至一佛刹尘数世界并其能绕。已有众多佛刹尘数个佛刹微尘数世界不可知数。且就一期之数云不可说耳。明知所绕定是主刹。若尔云何不与标文相违标文。但云一刹种有不可说佛刹微尘数世界故。既加两重能绕有多多故。答此有二意。一言不可说者就主标耳。二者其两重能绕并不出不可说刹尘刹中。何者。观其文意但是诸刹互为主伴为相绕耳。如百人共聚一人为主则九十九人绕之。余九十九人一一为主时。皆得九十九人绕之。若不尔者。最下一刹已有一佛刹尘数世界围绕。此能绕刹更有两重能绕。已有不可说不可说刹尘数刹也。思之。明知互为主伴则本数不增。而疏言傍去者。经中现说下狭上阔如倒立浮图。仰安雁齿亦合更说上尖下广如正浮图。俯安雁齿则上下栉比皆悉周满。间无空处方为刹网。上下四周皆悉相当。经欲拣别诸重不能备举故。且增数说绕刹殊。又欲令斜望相当故为此说。所以梵网经云。世界不同犹如网孔。若但取二百一十以为所绕殊非得意疏。依此则似译人文繁理隐者。若言十佛刹但有三字。今云如上所说则有四字故为文繁。但云如上所说。言不分明即是理隐

疏。若依前义则译者之妙。能绕所绕其数既多。但云如上则言省略故云妙耳。虽有二释。疏意存第二释。但用十佛刹尘数而为能绕。为顺经宗明无尽故。前后体势类皆然故。余如疏文细寻可见

疏。俱舍云者。略其义耳。具足颂云。东毗提诃洲。其形如半月。三边如赡部。南边三百半。南赡部如车。三边各二千。南边三百半。西瞿陀尼洲。其相圆无缺。迳二千五百。周围此三倍。北俱卢畟方。面各二千等。东则北阔南狭。余可知。故结。云四洲相殊从今云如者。上举论为问。今为会释言全似此界者。此四洲安布是一佛居。今此世界同此四洲之界耳

疏。此中文无标结大数等者。例中间海。如第八经末。第十经即以正喻依者。以众生身喻种种刹故。亦是以因喻缘者故。下六地云。业为田识为种。谓心即名言种为亲因缘名之为因。业如增上缘名之为缘。余如疏释。疏三一偈双明心业者标也。行即是业故释也。以心显故不释。谓随其心净则佛土净。是由心异见刹不同。若行十善则见命不中夭。生于大富梵行之国是随业异见刹不同。此即双举因缘。亦双明王所。言亦喻众生同处异见者。佛本无二见银见金。刹本是一见净见秽。故螺髻所见如第六天宫。身子所见丘陵坑坎。疏初一粗坏细存等者。所现虽败恶即粗坏也。是变化土其处常坚固细存也。即自他受用上略属经文下出所以。坏由恶业者。法华云。是诸罪众生。以恶业因缘。过阿僧祇劫。不闻三宝名。言存由二因者标也。一约佛者。即自受用土。二善业者即他受用。兼变化净以业不同同处见异。故法华云。诸有修功德。柔和质直者。则皆见我身。在此而说法

疏。故法华下引证。我净土不毁。证自受用成上约佛。天人常充满。证他受用等成上善业。如次证上故。义引经文。若具引者。经云。众生见劫尽。大火所烧时。我此土安隐。天人常充满。园林诸堂阁。种种宝庄严。宝树多华果。众生所游乐。诸天击天鼓。常作众伎乐。雨曼陀罗华。散佛及大众。我净土不毁。而众见烧尽。忧怖诸苦恼。如是悉充满。即云是诸罪众生等。次云诸有修功德等

疏。然灭虽不俱下释成上义。结归难思。即睿公意。一灭一存故曰不俱。不离灭处有存故曰起必同处。如人于饿鬼火处见水。饿鬼于人水处见火。虽曰同处而恒相无者。灭中无存存中无灭。亦如罗刹宫殿与人宫殿同在一处亘不相见。他受用土亦复如是。若自受用故是遍周。不即三界不离三界。故法华云。不如三界见于三界。若法性土又起灭常如疏故难思者。结释经文劫烧不思议。谓不可作存灭染净而思矣。疏世相不同等者。以法性土对他受用及变化土也

    毗卢遮那品第六

疏。此后更有大劫于理无违者。此遮救也。谓静法云。准下文大劫有恒河沙数小劫。人寿二小劫初。佛寿五十亿岁。威光历事三佛转报生天。今云最初劫中有十须弥山尘数佛者。为彼刹中更有多个大劫。此初大耶。为诸小劫中取小初耶。释曰。上引文案定双开二关。次云若就小劫初。不应威光一报之中但遇三佛。若就大劫。一刹之中宁有多大。释曰。双释二关。谓人寿二小劫。一小劫中有须弥山尘数佛故。不应一报但遇三佛。言宁有多大者。如一贤劫则无多大。次云。故知此文最初劫之三字。应回云劫最初。仍移此三字。于后行出兴于世其字之下。即无过也。释曰。此立理具足回文。合云彼胜音世界中。有十须弥山微尘数如来出兴于世。其劫最初第一佛号一切功德山须弥胜云也。此正甚善。今不欲繁举出经之过。强以理通最初劫言耳。云更有大者义当中劫。顺静法意言有大耳。如贤劫有二十增减为中劫。第十五劫有九百九十四佛出。则一劫中容多佛矣。但彼净劫时长故。一劫中有十须弥山尘数佛矣。然不欲斥经不急修行故。存略理通。非斥净法正不当也

疏。略明有十相者。下结文云。大同经初。即教主难思十身相也。初一即法身经。以身智无碍而为法身

疏。更融色相等为一法身。以初身为总故。法无不在本自普周。即释经其身周普是法性身。次云智与理冥故等彼真界者。释经等真法界。此是报身亦如智也。故金光明云。唯如如及如如智独存为法身故。能令色相下。以真身周故令应用亦周。吾今此身即是常身法身故也。则以三身圆融为一真法身矣。下九别说二者悲相。即意生身。三成相。即菩提身。理行时处为道场。并如经初。四色相。即福德身故。上经云。三世所行众福大海。悉以清净。是故妙色为福之果。上经又云。不可思议大劫海。供养一切诸如来。普以功德施群生。是故端严最无比。五胜相。即威势身。六贵相。即相好庄严身。且顺三乘云过圣帝。俱舍颂云。相不正圆明。故与佛非等。此释轮王相。今是世尊。故云分明。实具十莲华藏微尘数相也。七应相。即力持身。如为龙留影力持不灭。八无碍相。即愿身。上经云。毗卢遮那佛愿力周法界。一切国土中常转无上轮故咸目睹。九化相。即化身。十吉祥相。即智身。正在智光傍兼身光耳。是知此经引昔因缘。亦皆圆妙

疏。一者生福及不动业。以施忍智三而为善根者。业有三种。一恶业即三不善根所生。今所不明

疏。列三业即三善根所生。三善根者。即无贪无嗔无痴。今非但不著有境兼能惠施成无贪根。非唯于苦无恚兼行忍辱。故成无嗔根。非唯于境明了增修慧解是无痴根。有此三根唯出生欲色无色故。为福不动根。然其三根依唯识论。各别有性。善十一摄无贪。以于有有具无著为性。无嗔以于苦苦具无恚为性。无痴以于诸理事明解为性。通唯善惠各别有性。今依集论第一。以惠为无痴性。唯识意会以惠为无痴之果。故施忍二亦从果名。由无贪嗔故成施忍。所以疏云以施忍惠以为其根。二信等根下当广说。疏三求无上慧。以四等不放逸五法为根者。涅槃经云。皆叹慈悲为菩萨根本。有慈悲心必须喜舍不放逸者。是精进无贪等。三于所断修防非为性假立为一故。涅槃说不放逸根根深难拔由不放逸。策前四等得一切智故为根也。四通说善根下。即上三类之通性也

疏。一无明重者。自觉智开下。疏文有二。先别明后结释。前中初四离障。五令解脱通益三乘。六未信令信。七令入三贤。八令得初地。九令二地已上得于八地。十已在八地已证无生。诸佛劝起令得九十二地

疏。此约差别下第二结释也。差别结上。明是竖释对治。结上非三悉檀。若约横配下更结异门。横对前竖位位通用此十句。故生善见理对上对治生善。即是为人悉檀。谓发大信解生胜善根。起见佛心皆生善也。见理即第一义悉檀。如自觉智开趣一切智。皆见理也。亦应合有随俗令喜。世界悉檀。以益近故。故此中不说横竖无碍。是此中意四悉檀义。问明当辩

疏。按缨络本业经下引经释成。五百为正。二万五千为非。于中分二。先夺破。后约教下纵成前中。言上卷者即第三贤圣观品。彼中敬首菩萨问。云何菩萨学观名字义相。及心所行法。复当云何。佛先答名字。即列三贤十圣等妙之名。次答心所行法。云佛子汝先言云何心所行法者。所谓十心。一发心住等广释三贤十圣等妙之相。次敬首菩萨复问世尊。从初地至后一地。有果报神变二种法身。一法性法身。二应化法身。为何色相。为何心相。佛答云。先答出世间果报者。从初地至佛地各有二种法身。于第一义谛法流水中。从实性生故。实智为法身法名自体。集藏为身等兼说净土。次云。佛子世间果报者。所谓十住铜宝璎珞铜轮王百福子为眷属。生一佛土受佛学行。教化二天下。银宝璎珞银轮王五百福子为眷属。生二佛国土中受佛教行。化三天下。金刚宝璎珞金轮王千福子为眷属。入十方佛国土中。化一切众生。处四天下欢喜地。百宝璎珞七宝相轮四天王万子为眷属。现百法身为百佛国土中。教十方天子。千宝璎珞八宝相轮忉利王二万子为眷属。万宝相璎珞九宝相轮炎摩天王眷属亦然。不可称数。亿宝璎珞十宝相轮兜率陀天王眷属亦然。不可称数。天光宝璎珞十一宝相轮化乐天王眷属亦然。摩尼宝光璎珞十二宝相轮他化天王眷属亦然。千色龙宝光慧璎珞十三宝相轮梵天王眷属亦然。梵师子宝光璎珞大应宝相轮光光天王眷属亦然。不可思议宝光璎珞白云宝相轮净天王眷属亦然。百万神通宝光璎珞无畏珠宝相轮净居天王眷属亦然。千万天色宝光璎珞觉德宝光相轮三界王。一切菩萨为眷属。无量功德藏宝光璎珞千福相轮法界王。一生补处菩萨为眷属。佛子是上璎珞相轮一切佛。及菩萨动止俱游常随其身。亦化一切众生故。有如是果报之数法。释曰。已上具引经文。于疏易了。明知无过二万子者。疏按喜见下以二义证。唯合五百。一所统于城不统四天下。故非金轮。二既遇三佛。佛出减劫。轮王出增劫。故知非也。疏知离名法者。即思益经。第一思益梵天问言。世尊。云何名为菩萨遍行。佛言能净身口意业。尔时世尊而说偈云。若身净无恶。口净常实语。心净常行慈。是菩萨遍行。行慈不贪着。观不净无恚。行舍而不痴。是菩萨遍行。在聚落空野。及与处大众威仪常不转。是菩萨遍行。知法名为佛。知离名为法。知无名为僧。是菩萨遍行。释曰。此当第四偈因便故来。欲释此偈令知起尽故。以此一偈人多解释。今观经意。三个知字皆是观行之人。若能如是知是菩萨遍行。知法名为佛者。即是真佛法身如来。佛即是法法即是佛。亦犹如来者。即诸法如义。次应问言。法即是佛。于义已解。何者是法。故次句云知离即是法。以一切法本性离故。心体离念即是觉故。次应问云。法本自离则无所修。何等有僧。故次解云。知无为名为僧。无为即法。法本自离。由知无为故得成僧。故大品云。由知诸法空分别有须菩提等。金刚经云。一切圣贤皆以无为法而有差别。谓俱学无为有浅有深。乃成差别。非无为法而有差别也。今疏正取知离名法。若不舍法非知离也。故云法亦应舍。即金刚意。法尚应舍何况非法因法得悟如筏渡人。若不舍法如住舟内。要舍于舟方至彼岸。要忘所舍方为如实觉悟诸法为真舍也。故大般若云。般若甚深。知一切法本性离故。又文殊释云。如佛世尊堪受供养。以于一切法觉实性故。是故经云如实觉一切法大舍

疏。智即是体者智体如日用如日光。日体虽一能放千光。智体不殊能照万境。又日光无二所照物殊。智光无差随境分照

疏。一正定等者。谓等取邪定不定聚故。善恶等者。等取无记。三总收为二。四二位下融而为一

疏。谓后后因果皆入初心者总释也。六位相望故。成后后五位为因妙觉为果。又位位之中亦有因果。如十地中调柔果等

疏。若修途至于初步者。即肇公不迁论。论云。是以如来功流万古而常存。道通百劫而弥固。成山假就于始篑。修途托至于初步者。果以功业不可朽故也。彼论意云。物各性住故无往来。今虽引文用意少别。此云本出庄子。千里之途在于足下。其犹滔滔之水本于滥觞。合抱之木生自毫末。后由初得故曰在初。学者禄在其中矣。意亦同于上。即论语子张学干禄。子曰。多闻阙疑。慎言其余则寡尤。多见阙殆。慎行其余则寡悔。言寡尤行寡悔禄在其中矣。注曰。干求也。禄位也。虽未得禄得禄之道也。故得禄在后。由学而能得故居学中。此上一义通诸经论。疏菩提直心等者。即起信论法性宗中实教之意。然菩提心总有三心。今但直心中摄。以直心正念真如。真如即起信生灭真如二门之一。故云真如门内。然此二门者各总摄一切法尽唯取真如谓一切法。及后后诸德皆依真如。真如无二通为诸法之体。今菩提心正念真如。故能摄也

疏。三者三德开显前后圆融者。即别教一乘圆融义也。不同余义。言三德开者。即发心功德品。初发心时得如来一身无量身。则法身开显得究竟智慧。得一切智慧光明则般若开显。不于诸法少有所得。即以心离妄取寂照双流故。解脱开显故。此心中无德不摄。因该果海并在初心。从初发心时便成正觉。即梵行品文。言初后圆融者。以初是即后之初。后是即初之后。以缘起法离初无后离后无初故。举初摄后。若约法性融通。一切因果不离心性。契同心性无德不收。以一切法随所依性。皆于初心顿圆满故。故梵行品云。若诸菩萨能与如是观行相应。于诸法中不生二解。一切佛法疾得现前。初发心时即得阿耨多罗三藐三菩提。知一切法即心自性。成就慧身不由他悟。如玄文已明。下当更说

疏。三大智智明者。经中清净眼是总相。此眼何见见心三大。疏中嘱经。唯配二大略无用大。用即智摄故。从智慧光明遍照法界义故者。即暗引起信证普光明。为相大义。即起信释生灭门中。所显义大双明体相之文。论云。复次真如自体相者。一切凡夫声闻缘觉菩萨诸佛无有差别。非前际生非后际灭。毕竟常住。释曰。上释体大。今不引之。以法界为体义易知故。论云。从本已来性自满足一切功德。所谓自体有大智光明义故。遍照法界义故。真实识知义故。自性清净心义故。常乐我净义故。清凉不变自在义故。释曰。上之六句皆是相大。一本觉智明义。二本觉显照诸法义。三照时无倒义。四体离惑染义。五性德圆备义。六性德无迁义。今不引后四。而引前二有智遍照。证以普光明为相大义。恐人以法界为所照。普光明为能照。故引此文。相大本有则皆所照。以净眼智明为能照耳。从蕴恒沙下释经藏字。具二藏义。蕴恒沙德即不空藏。妄惑本空即是空藏。故清净言向上属所观之藏。向下属能见之眼。无障盖故言见性。肉眼即名佛眼者。即涅槃第六经云。善男子。声闻之人。虽有天眼故名肉眼。学大乘者虽有肉眼。乃名佛眼。何以故。是大乘经名为佛乘。如此佛乘最上最胜。诸佛见性故

疏。无功大力一行含多者。由八地得无功用如乘船入海故。云大力速疾。言一行含多者。先以一身起行。至此八地以无量身起行。一一行中起一切行故

疏。余可证知故云得。云入者。智论三十一云。通彻名入。入亦证也。得者获之在己也

疏。菩萨之父故首明之者。即智论文。论云。菩萨以般若波罗蜜为母。般舟三昧为父。般舟即念佛。此翻为佛立三昧。良以念佛即真涉事。与方便同故得称父。又念佛成佛是亲种故。言乃至十地不离念佛者。十地之中皆云一切所作不离念佛念法念僧等。上辩先明所以。后无边海藏下牒释别名。于中先牒经略释。后然略有三下。别示其相。三义中。一定见多佛。二佛有多德。此二并就所念名无边藏。三无边胜德下约能念名藏。于中三。初聪明。次何者下征释略举三身。后障无不灭下经叹。故贤护结中广列诸德。以征其因。佛答皆从念佛而生。一言蔽诸者。即论语。子曰。诗三百一言以蔽诸。曰思无邪。谓归于正也。念一佛号亦名一言。直取一言只一佛字故。自四祖唯称佛言

疏。七般若者。觉法自性离诸分别也。此总释一门亦当别释自性离垢之言。即大般若曼殊室利分中。慈氏菩萨云。若诸菩萨闻是甚深般若。心不沉没。已近无上正等菩提。何以故是诸菩萨现觉法性。离一切分别如大菩提故。今此般若亦觉法自性。名自性离。离字两向。向上属自性离。向下属离垢。即离分别之垢也。从有可离下。别释经文。成上总释。有可离者非真离也反释。初句成上性离。知自性离不复离也者顺释。初句成上离分别言。不知性离谓有可离。即是分别。今知性离知相即寂。故无分别。从无离之离即真法界者。即蹑上释下法界言也。正同起信。所言觉者。谓心体离念。离念相者等虚空界。无所不遍。法界一相即是如来平等法身。法身即真法界。本来清净者。蹑上法界释清净言。既自性离是真法界。则本自净非观令净非去垢净。是故经云法界清净。彼法界清净即般若清净者。即以上义成此般若得清净名。此有二意。一由体清净方成般若故。此般若受法界清净之名。二者性无二故。故大般若难信解分云。复次。善现般若波罗蜜多清净故色清净。色清净故一切智智清净。何以故。若般若波罗蜜多清净。若色清净。若一切智智清净。无二无二分无别无断故。名无二性。从般若清净则万法本净者。亦有二义。一以般若照一切法知本净故。二者亦是性无二故。义同上引般若清净。则色清净遍历诸法。略举八十余科。谓五蕴十二入十八界四谛十二缘六波罗蜜。乃至菩提涅槃皆如色说故。万法本净。从万法净者。则无净无不净者。拂其净相。夫言净者。悬法本无生性。寂诸相故名为净。岂待荡荡无物方称净耶。非但事无而为真净。见真本净事为非净。亦是相待能所未忘。安得称净。故真善知识令看净门。云性本清净净无净相。方见我心即斯义矣。故净名云。垢净为二。见垢实性则无净相。离于见相是为入不二法门也。下经云。若有见正觉解脱离诸漏。不着一切世。彼非证道眼。若有知如来体相无所有。修习得明了。是人疾作佛。疏实相般若下。释经身字。身有三义。谓体依聚义。今实相般若则法身之体。观照般若同报身之依。化身名聚。浅故不说则眷属般若。亦得名身同聚义故

疏。故仁王经云后之三地等者。即教化品中第八名等观菩萨。偈云。等观菩萨二禅王变化法身无量光等。九地云。慧光开士三禅王。十地云灌顶菩萨四禅王。后都颂上三地。云等慧灌顶三品士。除前除习无明缘。无明习相故。烦恼二谛理穷一切尽。释曰。既总牒三地除无明习。是故疏云同遣无明。言非灌顶地。下义释彼经。彼经灌顶地也。自当第十故云非灌顶地。然十地亦用尽无明习无功用智而得灌顶。故云是灌顶智也

疏。见普法故名为普眼者。此释经名而有三义。一约所见称普。言普法者。一具一切一一称性。同时具足等。斯即十眼之内一眼之能。经云一切智眼见普门法界故。二况一眼即十眼。融无障碍约能见称普。如五眼中佛眼。四眼入佛眼皆名佛眼。如四河入海无复河名。而具海味故。金刚经云。如来有肉眼不。如是世尊。如来有肉眼。乃至云。如来有佛眼不。如是世尊。如来有佛眼。今十眼亦耳。随一具十。而诸教说唯佛眼具五。余四则无。今因果之人皆许一眼。即具十眼。不唯后胜具于前劣。若一不具十则非普眼。言十眼者。离世间品说。谓一肉眼。二天眼。三慧眼。四法。五佛。六智。七光明。八出生死。九无碍。十一切智。其融无碍则有二义。一者成上十眼无碍。二者成下即能所无碍。三眼外无法方真普眼。下约心境互收方称普眼。此上标也。以诸缘发见下别释所以。如大乘法师。以九缘发识。眼根名眼余不名眼。今则例之。眼根能发识。眼根得名眼。空明能发识。亦得同名眼。余六例然。以缘起之法各有有力无力相成立故。次云因没果中缘皆号眼者。九缘不见色。不见不名眼。九缘皆见色没果同名眼。以皆全有力故。言全色为眼恒见色而无缘者。色是所缘之境。眼是能缘之根。今即是眼故无缘也。言全眼为色恒称见而非我者。眼是我能见。今全为色。正见之时即非我也。此即贤首之意。下更有言。云非我离于情想无缘绝于贪求。收万像于目前。全十方于眼际。是以缘义无尽。随见见而不穷。物性叵思。应法法而难准。法普即眼普。义通乃见通。体之自隐隐。照之遂重重。然后穷十方于眼际。镜空有而皎明。收万像以成身。显事理而通彻也

疏。五度皆福定为最大者。然六波罗蜜摄成二严总有两意。一前五为福。后一为智。二者前三唯福。后一唯智。进定通二。成前为福成后属智。今以经中云得三昧名大福德故。用前门

疏。福即是善非福是罪者。即百论相摄罪福品意。故论引金刚。福尚应舍何况非福。以善舍恶以无相智舍福。则善恶两忘。今云了者。一了其相。二了体空。三了无碍。二福即是相下。即以世谛说福。谛一义中福亦不存故。引金刚如来说福德相随俗说也。即非福德相当体空寂也。是名福德相。结正义也。若福即非福方名真福。若以福为福非真福也。有人以第三句亦约俗谛。非得经意

疏。一无实权施者。如说临门三车即是权教三乘。本无三乘说有三乘。虚指三车出门不获是也。二理本无言者。亦法华云。诸法寂灭相。不可以言宣。以方便力故。为五比丘说是也。三权实无滞者。即涉有未始迷空。观空不遗于事。即如来方便知见波罗蜜。皆已具足。毗卢遮那品竟

大方广佛华严经随疏演义钞卷第二十七大方广佛华严经随疏演义钞卷第二十八

        唐清凉山大华严寺沙门澄观述

    如来名号品第七(入第二会)

疏。二会来意者。于中有二。一对后辩来。以一分六会。今是初故。又前举下对前辩来

疏。又远答名号海问者。自是十海为总意耳

疏。佛于其中说普法者。就此普法自有四义。一境智合说。真俗双照曰普。妙智照达名光。二单约境说。体周曰普。用彻为光。三唯约智说准境可知。四约融摄说。若事若理皆无障碍。一尘一行犹如帝网曰普。圆明显焕为光。余如十玄

疏。表德为号。亦有释云。表德为字。响颁人天曰号。今以即字是号。犹如十号皆约德故。言名别号通者。总相说耳。品中正说下。拣定通局可知

疏。修生修显因果为宗者。修生约差别因果。修显约平等因果故

疏。二会宗下疏文有二。先约四分科经。以明宗趣。二约别科辩宗。今初又二。初若就总望等者。亦名为远望。为成佛果故为远具解行德故为总。解即问明。行即净行。德即贤首。二近望十住故为近。亦合名别将前摄位。为总故。摄位者。十信满心顿摄诸位。今此唯成十住故。仁王不开十信。摄在十住。信为能成住为所成故

疏。若依长科下。第二约别科辩宗。略有三义。一随品长分科总为十段。今当第四前后摄叠故。二故此亦名正报因果者。即前后钩锁科。亦当第二毗卢遮那是因。此三品为果故。三亦是所信者。贤首向前亦将此三属所信因果。正报果故。如下疏指。亦属四分之第一分故。而言亦者有二意。一对金科属第二分故。二对随其本会科。名能信成德会。今为所信故云亦也。疏前会举果。此通繁重难。先问后答。答中二。先约义通。为意别故。所以重举可知。后又前会果广下。约文以答。以少从多故。前会果多名举果分。此下因广分名修因。虽举此会正酬向来约分名难。故云因广。然取当会因果。皆各三品因果似齐。而因文亦广

疏。若约钩锁者。此当第三依起因果。是所依果故不同。第七说所成者。所成自属第四差别因果故。疏以未入位性不定故下答。此上问文有五段。一者正答犹如轻毛未能得入正定聚故。二若尔下蹑迹生难。三然说法下以义释通。四第九会下出四所以五是知下结其深玄。二中说后定如无量义经者。即法华中经云。为诸菩萨说大乘经。名无量义教菩萨法佛所护念。说是经已结跏趺坐。入于无量义处三昧。身心不动是也。若出其意。无量义者是出生义。故彼经云。无量者从一法生。其一法者所谓无相。法华即是收入之义。故彼经云。究竟至于一切智地。世尊法久后。要当说真实。今欲收入先辩出生。若知三乘万化从实相生。究竟还归一实相故。欲为法华序故说无量义。便入此定

疏。第九表证唯证能说者。即第四出四句所以。其第一定后说。诸会广说故不释之。但解后三。初解第三二第七。为表下解第四。第四有二会不入定。第二不入前已解竟。唯解第七。三说后入下通第二义。入即修行。上引无量义经。乃是别意而有等言。等取此经通意。通诸经意今显通意耳。疏是知下第五结其深玄。故下文中示十信相。既所说信定散自在。明知。能说入出难思。余会摩顶下更示异门。令无局执

疏。若顺诸会应直分问答者。以六会共答此中问故。第一序分。唯属此会为加序分名为顺文

疏。处在菩提下西域记说。贤首亦云。相传说云。以龙见如来初成正觉树下露坐。故为佛造。若西域记说。菩提树南门外有大龙池。帝释献方石在此池中。池东林内有目真邻陀龙王池。其水清黑其味甘美。龙池西岸有小精舍中作佛像。往昔如来初成正觉。于此宴坐入定七日。时此龙王警卫如来。即以其身绕佛七匝。化出多头俯垂为盖。故池东岸有其室焉。释曰。若取龙造正当于此。虽不言造堂。龙既警卫不妨后造。当向即东南。又云菩提树东有精舍。高六百七十尺。下基面阔二十余步。叠以青塼涂以石灰。层龛之中皆有金像。四壁之间镂作奇制。或连珠相或天像焉。上置金刚阿摩勒迦果宝瓶。东面接为重阁。檐宇特起三层。榱柱栋梁户扉窗牖。金银雕镂以饰之珠玉厕错以填之奥室邃宇洞户三重。外门左右各有龛室。左则观自在菩萨像。右则慈氏菩萨像。白银铸成高十余尺。精舍故地昔无忧王建小精舍。后有婆罗门建大精舍。即雪山见大自在天天令置也。释曰。此义亦当。若取普光堂义。却当树西。西域记云。菩提树西不远。大精舍中有鋀石佛像。饰以奇珍东面而立。前有青石奇纹异彩。是昔如来初成正觉。梵王建七宝堂。帝释建七宝座。佛于其上七日思惟。放异光明照菩提树。去圣逾远宝变为石。释曰。此为普光法堂定矣。但从古传云是东耳。若东西二三里。即是盲龙之室。非是龙造。去圣时遥传记讹异。故且略出三处。冀更审之

疏。双照真俗故称为悟者。准下无著不释总句。具下诸别以成总句。亲光则更别释总句。今依亲光别释总句妙悟。取无著意将别释满

疏。烦恼所知生死涅槃。皆称二行者。准无著名所知。一向无障转功德。但离所知。二乘之人于极远时处不能知见。有知不知故名二行。今无不知故云永绝。若亲光云。凡夫二乘现行二障。世尊无故。凡夫现行生死起诸杂染。即烦恼障。二乘现行涅槃弃利乐事。世尊无彼二事。故云永绝。今具含二释故双释之。下诸功德皆是下文广释中意。如或未晓但寻兜率会疏及论文。居然易了

疏。圣天梵住者。即智论第三云。圣谓三乘圣人。天谓六欲天。梵即色无色。复次三三昧是名圣住。布施持戒善心三事名天住。四无量是梵住。释曰。此虽二文义乃是一。前举果住后出因住。或为四住。谓加佛住。如来常住首楞严诸三昧故。虽遍住四住。智海已满大悲深故特言大悲。大悲即梵住所摄

疏。四种变易生死者。第一疏钞已。引摄论无上依经。今更依佛性论第二。略示其相。一方便生死。谓生死缘即无明住地惑。能生新无漏业。譬如界内无明生行。以惑生智非同类故。名为方便。二因缘生死。谓生死因。即上无明所生无漏有分别业。譬如无明所生行业。但感同类故名因缘。三有有生死。即由前因缘感得变易。异熟有果。如三界内以有漏业感六趣身。言有有者未来生有。更有一生故。如上流般阿那含第二生般涅槃故。亦云。有此有果故名有有。四无有生死即改变易脱。譬如生为缘有老死等过患。一期报谢更无有有故名无有。故今疏云唯有第四无有生死。一生者。此生之后便成佛故。如那含人当涅槃故

疏。后若世尊下正显问端。疏文有二。先对前辩异。后若唯约义下科判经文。于中分三。先科有三。初就义为三。以所问法有三类故。二是则以佛下辩三段次第。三今取文义俱便下。后分二释文。两段皆结故是文便。直问引例表人异道同。故是义便。疏一刹类者。即形状长短等。言即前二海广如四五二品者。第四成就品。答世界安立海。第五华藏世界品答世界海故

疏。初句总下。释此十句总有三势。皆有总别。第一行愿俱起释。初总余别。别中展转相释文势可知

疏。又成菩萨具悲智也下。第二悲智双流释。于中三。初一总句菩萨即悲智也。二具此悲智下。一句明双流所为。三佛种不断有何相耶下。八句皆释不断之相。于中四。初三正释不断。谓成就三德是不断相。二云何救护下覆成上义。如次三句。三智成何益下。显三德益。经但二句含于三义。初明智德益。后惑除何益下。以灭爱着处句双成二益。若着诸法正智不生。若着于空不能悲救。今空有无滞故能灭惑成智起悲不断佛种。四所陈下结属本意

疏。又释一切菩萨下。第三约二利齐运释于中初句总余句别。别中疏皆假征起。以经为答。于中初二双明二利。二云何救护下别释利他。经有六句疏文分四。初二正离二障。二以何方便下。一句出离障因三此烦恼下三句。出二障之相。四二障既寂下。从后倒收结归。总句二障既寂通后七句。即二障除能成二智。除烦恼障根本智现。除所知障后得智现。即此二智亦为能寂。菩提涅槃即是所成。烦恼障断成于涅槃。所知障断成菩提故。此结利他意则不断佛种。结归自利菩萨成矣。结归总句

疏。今初文有九句下。疏文分二。先通释九句。后别解顶问。前中一向序昔于中有五。一正立脱忍。二又以十信下。出其所以。若不开十信则不合问信。下有忍品故知脱忍。三故仁王下引教证成。四有义云下。以理证成。五由斯下结成配属。可知

疏。十顶一种下。二别明顶问。于中二。先叙昔后申今。前中有三说。一依梵网经。疏文有三。初正叙昔。二理亦可通者以理纵成。三但彼经下以文夺破。言二三四与此三四五会处法全同者。此是第三会在忉利。四在夜摩。五在兜率。彼第二即在忉利故。彼说十世界海竟。即云次于忉利天宫说十住法。次至夜摩说十行法。次至兜率天宫说十回向。斯则处法全同次第不同。彼二此三。彼三此四。彼四此五。以前加菩提场故。言他化十地次第亦同者。亦是第六在他化自在天说十地故。由彼不越第五化乐天故。说地亦第六故。彼文云。次至化乐天宫说十禅定。次至他化自在天宫说十地法。次至初禅说十金刚心。次至二禅宣说十愿。次至三禅说十忍法。次至第四禅摩醯首罗宫。说我本原莲华藏世界卢舍那佛所说心地法门。故总收之四例不同。一菩提普光二会不分则开合不同。二则次第不同。三即有无不同。此经四禅无说彼皆有说。四此有重会彼无重会。彼经一处说一法门。此则四六兼二。七兼于三。以斯四义故难会通。从又此中问下。纵成一破。设汝欲将心地法门例同此者。此中说果应为心地。何得用顶上。一师义竟。疏有云僧祇下。第二师义。于中二。先叙昔。二彼问虽十下破可知

疏。有云寿量品答第三师义。于中二。先立后破。前中四。一正立。二又佛名下引证。三但举此初下。彼师遮难恐有难云。今经百万阿僧祇重。何以证成十界之义故为此通。四此为标首下。释成顶义

疏。然复下第二难破。于中先纵立。后但标此下夺破

疏。今谓新旧下申今正义。于中二。先以十忍答顶。后通以四品答顶。前中七。一正将十忍答顶问。二言十顶者下会释二名。三故十忍下引文为证。四亦犹下引例成立。五不尔下反以释成。六设欲下释无十难。难云。若开顶问十句即圆。若以忍答顶句则唯九。故今答云脱于十信十句成矣。七十信虽未成下会通上难。难云。我先用二义不开十信。一文证二理证。今欲开信双乖文理故。今通之乃有数意。一对前立理。前明阙于四义不立信位。今明不必成位四义无遗。二德用殊胜下。上以文证今亦文答。上引但明信位不开。今明何必要开而不妨有问。何者。十愿十藏非是别位得为问端。信不成位何妨有问。又藏愿等寄他会。答尚有别问。十信法门别一会答。解行德能三品宏深。岂合无问。疏若将下。第二会通。以四品答于顶问。以信住行等皆有多品。总将四品共答顶问。于理无违。若尔古以僧祇寿量而答顶问。应不乖理彼以局取又不收忍。今总收四与昔全乖。顶乃通名忍等别称。故不同也。此解最妙亦能傍通一难。难云。引四善根忍顶不同。今何将忍以酬顶问。故为总释。则以等觉因位之极通称为顶。不全同四故。上引之义相类故

疏。其平等因果下。通妨难。难云。若依问为三。第三段唯合明果。今有普贤行为因出现品为果。自是一段平等因果。今何得皆将答果问耶。故为此通。既因是得果不舍之因。即果中因亦是果摄。故属第三所成果也。又古人以文从义。出此因果。若疏本意全属果也。至下重明。疏言随类者。有其三义者

疏。文有二。先释三义后结通局。前中一随疑者所宜异者。即用法不同。随一类人所乐不同。随宜适化。故经云。彼彼诸病人良医随处方。即应病与药也。言或示色令见。是现相答。以声令闻是言说答。上皆显应。冥资令晓即是冥应。总合上三一时顿应。以法界圆明顿现也

疏。二随疑者流类别故者。上之三义。随一类中即容此三。今明万类。谓人天鬼畜音辞差别等。然准疑人约有所表。但明菩萨据其实义万类皆通。又菩萨者。但语大心众生。不妨本类亦有差别。谓天为菩萨。人为菩萨等。疏三随疑者。所疑异者。此约所疑之法。是则初是义无碍境。二是辞无碍境。此是法无碍境。然其所疑即十住等。其能疑人未必疑于十信。许互疑故。十信亦疑住行等故

疏。谓若疑十信下。出随疑现通之相。于中有二。初疑十信。即是此文及第十三经光明觉品。言周乎法界等者。等取十方。各过十佛刹微尘数世界菩萨云集故。下经云。悉以佛神力故。十方各有一大菩萨。一一各与十佛刹微尘数诸菩萨俱等。若疑十住者。即第三会十住品。初言云集等者。此一等字等取行向地等。谓十行则足趺放光。十向则膝轮放光。十地则眉间放光等。十行千刹十向十千等。此一等字者。等于一分放光中事

疏。如放光下。例于余相。谓动刹雨华香云等事。皆随宜不同也

疏。故知初会下。第二辩通局。此会望初则局一分。彼通九会。谓佛前现华。通表一部所诠华严。眉间胜音通表九会能诠教故。结集编次非现前后

疏。故下三会下引文为证。即不起前二而升四天。明正当此处现通四天齐现耳

疏。名不动智等是答法性者。不动智等等余九智。智虽是一十智不同。不同之德即是法性。则以佛德为法性故

疏。文虽在下等者。释通妨难。谓有难云。适所引文皆光明觉品。此中现相言答十问。乃引下经岂成此答。释云六会现通尚在一时。况光明觉义不在此。故光明觉说说此所现。是以此中别列十方佛刹菩萨一一各说。光明觉品一时总牒。明是说此所现相耳。疏去此远近皆十刹下。上总科十方皆八下。别释八段。前六释初远近自有三段。一正释。二为有所表下通难。难云。华严即是通方之教。未有一土不说此经今举十刹则十外不收。今说百刹应百外不摄。岂为通方释意可知。三又随迷下约观心解。疏今通用之者以梵语多含。三藏各取今以义收。故皆通用而暗引下经以成四义。初释首义。以信为首。摄诸位故。是通意明信该果海故。二释胜义。云次第行中信最胜故。经云。是故依行说次第。信乐最胜甚难得。三于生死中下释吉祥义。经即通取下经之意。四信能增长智功德故。释德义。亦全是贤首品经文。文云。彼诸大士威神力法眼常全无缺减。十善妙行等诸道无上胜宝皆令现。即吉祥义也。疏亦有传云者。即兴善三藏译。余亲问三藏有同此说。令欲会意故前收四说。疏今初东方下。别释十方。八段之中皆释三事。一刹名。二佛名。三主菩萨名。唯初东方。案经之次。下之九方从后倒释。以十首菩萨表十甚深。是助化主故先举之。余二因此故在后释。细寻可知

疏。处处文殊下文当释。从由慧拣择下通难。难云佛名不动智文殊表慧。二相宁分。答中然智慧二字乃有多门。今此正用分别名慧。决断名智。故以慧为因以智为果。疏不染而染等者。此释妙色义。语出胜鬘。下当广释。又释十段皆暗取十甚深义。一云。慧达佛境即佛境甚深故。二觉首缘起甚深心性是一故。三财首教化甚深。四宝首业果甚深。五德首说法。六目首福田。七进首正教。八法首正行。九智首助道。十贤首一道故。并可思

疏。又十佛相望下。总以六相圆融。文殊为总者。若以法门为总。文殊主般若统收万行。九首之德皆是般若。随缘别相同明佛德。即是同相缘起。教化互不相收。即是异相。统十甚深为成佛境。即是成相。各住一甚深即是坏相。余如下说。若约人为总别。文殊为上首。故曰是总。余九为伴是别相故。同则同名为首。异即贤智等殊。共成十首。表信之人坏各住自

疏。以前后例下。三结释劝修。如前现华表义现众表教。后如十慧说十住。十林说行。十幢说向。十藏说地。离世间品菩萨万行寄表甚深。斯为观心。非是臆断。不信此理一向外求。如数他宝。故非我分。二文殊言答中。疏以文殊示居此土生有十征等者。释文殊说意。上明是主菩萨。庐山远公但云。文殊师利是游方大士。唯见一经但睹一迹耳。今具出之。是主是客亦果亦因。具难思也。言示生此土者。即文殊般泥洹经云。佛告跋陀婆罗。此文殊师利有大慈悲。生此国土多罗聚落。梵德婆罗门家其生之时。家内屋宅化作莲华。从母右胁而生。身紫金色堕地能言。如天童子。有七宝盖随覆其上。释曰。言此国者。即舍卫国。佛正在此说故。即此经复云。文殊师利具三十二相八十种好。则相好同佛。复有经说。生有十桢无非吉祥。一光明满室。二甘露垂庭。三地踊七珍。四神开伏藏。五鸡生凤子。六猪诞龙豚。七马产麒麟。八牛生白泽。九仓变金粟。十象具六牙。由是得立妙吉祥号

疏。来自他方体含万德者。即今经文。从东方金色世界中来。节节皆。言所住世界谓金色等。既周法界不动而遍。各领十佛刹尘数菩萨。说佛功德明万德斯备矣。上二对标其主客。下略说胜德

疏。降魔制外通辩难思者。然此二句有通有别。通则通用通辩。降伏魔怨制诸外道。别明以神通怖之。以威故言降。用四辩屈之。以辩故言制。然其事类颇多。略举一二。如幻三昧经十卷云。时有善住天子。启白文殊。欲同往见佛。文殊现变三十二部交络重阁。有诸菩萨先至佛所。身子睹变具陈问佛。佛答是文殊令诸菩萨集会。又问。何以不见文殊。佛答文殊住降毁诸魔三昧正受。蔽魔宫殿兴大威变。诣如来所。于是文殊住降毁诸魔三昧。应时三千大千世界百亿魔宫一时皆蔽。不乐其处各各怀惧。时魔波旬自见老耄。羸毁少气拄杖而行。所有宫人及彩女等亦复羸老。又见宫殿而复崩坏。暗暗冥冥不知东西。时魔波旬即怀恐惧身毛为竖。心自念言。此何变怪。令吾宫殿萎顿乃尔。将死罪至归命终尽天地遇灾劫被烧耶。时魔波旬弃除贡高。舍恶思想。时文殊师利所化百亿天子在交络者。住诸魔前。谓魔波旬。莫怀恐惧。汝等之身终无患难。有不退转菩萨大士。名文殊师利。威德殊绝总摄十方。德过须弥智超江海。慧越虚空。于今以是入降毁魔场三昧正受。是其威神。下取意说。时魔恐惧魔宫震动。求化菩萨救。菩萨答言。勿惧勿惧。可诣释迦如来之所。有无尽慈悲令无所畏。言讫不现。魔即俱来诣佛。请救我等。闻文殊之名即怀恐惧。不能自安畏亡身命。佛赞文殊已。魔请归依愿脱斯苦。佛令且待须曳。文殊当来即脱汝此难。后文殊至。佛问三昧。彼广说竟。令舍诸魔。文殊问曰。汝秽恶此身耶。魔答曰。尔若能当厌贪欲之事。不住三界等耶。魔敬从命。即令诸魔皆复本形。五体如故等。此即降魔也。制外者。即文殊般泥洹经。佛说。文殊初诣诸仙人求出家法。诸婆罗门九十五种诸论议师无能酬对。唯于我所出家学道。余文广博不可具引。至如圣智怖心。闻声扬而躃地。寂顺思睹入隐身而立空。故得帝释心喜。雨天华而至膝。蔽魔愁忧行拄杖而垂泪。劫火烧刹。蹈水之上而经行。霖雨绝供。化钵饭而无尽。示多身以抗迦叶。放一钵而发本源。皆是通辩降魔制外也。又如度二十亿佛现说法者。持地犹存。化百千诸龙立登正觉者。娑竭王女是一。是以礼妙慧而不忘敬本。劝善财而增长发心。无言于不二法门。悉力于安乐行品。教龙吉祥之分卫。下位莫知。答琉璃光之光明。正觉称妙。谈般若之玄致。屡质本师。说权实之双行。频惊小圣。皆辩才也

疏。化满尘方用周三际者。辩得用横竖深广也。谓十方微尘刹土。皆是文殊化处。故菩萨处胎经云。我身如微尘。今在他国土。三十二相明。在在无不现。余如众海云集中引。又般泥洹经云。住首楞严三昧。以三昧力。于十方国或现初生出家灭度入般涅槃分布舍利饶益众生。又宝藏陀罗尼经广说。至下菩萨住处品。当更明之。即今文中。一切处一时说偈。即横周法界

疏。道成先劫已称龙种尊王等者。此下别明竖穷略示一二也。先劫即过去。名龙种上尊王。智度论十二具引首楞严三昧经说。名龙种上尊王。经文但名龙种上尊王佛。即译人广略耳。五十三佛名中。亦名龙种上尊王。其首楞严三昧经有三卷。即当下卷。因文殊广说首楞严三昧境界竟。尔时长老摩诃迦叶白佛言。世尊。我谓文殊法王子。曾于先世已作佛事。现坐道场转于法轮。示诸众生入大涅槃。佛言如是。如汝所说。迦叶过去久远无量无边不可思议阿僧祇劫。尔时有佛。号龙种上尊王如来应供正遍知(云云)于此世界南方。过于千佛国土。国名平等。无有山河沙砾瓦石丘陵坑坎堆阜。地平如掌生柔软草。如迦陵伽。龙种上佛于彼世界。得阿耨多罗三藐三菩提。初转法轮。教化成就七十亿数诸菩萨众(云云)佛寿四百四千万岁。下取意引。涅槃后起三十六亿塔。法住十万岁。记智明菩萨次当作佛。下结会云。尔时平等世界龙种上佛。岂异人乎。即文殊法王子是。次言现证菩提。复曰摩尼宝积者。即央掘摩罗经。此经有四卷。事出第四。初卷中明。舍卫城北有村名萨那。有一贫穷婆罗门女。名跋陀罗女。生一子名一切世间现。少失其父。年将十二。聪明辩慧。有异村名颇罗诃私。有一旧住婆罗门师。名摩尼跋陀罗。下取意引。世间现从其受学。师乃受王请留其守舍。师妇年少染心逼之。世间现不受。其师少妇自惭毁害。师归。乃言世间现强逼。师言汝已为恶当杀千人。可灭汝罪。即杀千人还归见师。师怪其存。又令杀千人各取一指作鬘冠首。唯欠一人。母为送食便欲害母。世尊现前舍母。趣佛为佛所降。广显深妙。第四末。波斯匿王严四兵至。欲罚央掘来至佛所。佛示央掘。后发其迹云。大王南方去此。过六十二恒河沙刹。有国名一切宝庄严。佛名一切世间乐见上大精进。下取意引。寿命无量国土严净。纯说一乘即央掘是。由前文殊广与对扬。后显文殊之迹云。大王北方去此。过四十二恒河沙刹。有国名常欢喜。佛名欢喜藏摩尼宝积。纯一大乘无余乘名。即文殊师利是。故云现证菩提。复云摩尼宝积盖言略耳。下说师及师妇央掘之母。三人皆是如来化现耳。上略举过现不说未来成佛者。未来成佛现即是因。非殊胜故。疏略不显。若欲说者。即大宝积文殊会中说。于未来成佛。号普见如来。以恒河沙界庄严。为一佛国。以安养世界庄严比之。析毛滴海不可为喻。其中众生三十二相。天眼无碍镜照十方。不闻生老病死苦等。但出佛法僧声。若人欲见应念便睹。不待解释疑网皆除。闻名得最上善利。聆记为面见诸佛等

疏。寔为三世佛母。岂独释迦之师者。结其实德。故七十九经云。文殊师利所有大愿。非余无量百千亿那由他菩萨之所能有。善哉文殊师利其行广大。其愿无边。出生一切菩萨功德无有休息。善哉文殊师利。常为无量百千亿那由他诸佛母。常为无量百千亿那由他诸菩萨师。教化成就一切众生等。佛名经说。过去无量恒河沙佛。皆是文殊教令发心。然犹带数故今显实。实为一切佛母。不可穷其始末。岂独释迦之师者。即前所引处胎经云。昔为能仁师。今为佛弟子。二尊不并化。故我为菩萨。即法华九世祖师。亦带方便住首楞严三昧。亦是迹中故。弛张乎权实之场。莹彻乎真如之际。住诸佛不思议之境。岂可语其始终。无言强言为三世之佛母耳。疏影响而来故其说也者结也。影响显非实因也。疏何不入定者。问意中云何明已后信未入位许不入定。今此三品说佛三业。何不入定。故为此通。以果从因因即十信。十信不入果亦不入。是十信中取说果故。疏下结文具显者。即品末。云世尊昔为菩萨时。以种种谈论种种语言。种种音声种种业。种种报种种处。种种方便种种根。种种信解种种地位。而得成就。亦令众生如是知见。而为说法。即其文也

疏。又随宜说法意趣难思者。上指品末广故难思。今明意趣深故难思。亦如法华方便品说。谓称体大用。或随自意。或随他意。或随自他意故。从又等法界下多门难思

疏。三金银等色者。如观佛三昧海经第三广说。今当义引。佛为父王说观诸相竟。佛白父王。乃敕阿难。吾今为汝悉现具足微妙身相。说是语已。佛从坐起。令众俱起令观如来。从顶顺观至足轮相。复从足相逆观至顶。一一身分分明了了。如人执镜自见面像。若生垢恶不善心者。若有曾毁如来禁戒者。见像纯黑犹如炭人。五百释子但见炭人。有千比丘见赤土色。优婆塞辈十六人见黑象脚色。优婆夷辈二十四人。见如聚墨。比丘尼见色如白银。优婆塞优婆夷有见如蓝染青色。四众悲泪释子拔发。碎身毁形自述所见。父王安慰竟。释子即起白阿难言。我宿罪故不见佛身。佛为说因。过去毗婆尸佛时。有一长者。名曰日月德。有五百子。聪慧无双不信父之正法。子临终时。父云。汝等邪见。不信正法。今无常刀割汝身心。眼何所怙。令称毗婆尸佛名。未及法僧而终。生四王天。后邪见因故堕大地狱。铁叉刺眼。忆父所教得生人中。六佛出现闻名而不得见。以其得闻六佛名故。与我同生。如来令称诸佛名号礼拜忏悔。还见相好身。即得初果求佛出家得阿罗汉果。千比丘见赤土色者。过去然灯佛时。像法之中有千弟子。心疑于师。师见其临终。令其称念然灯佛名。生忉利天。以疑师罪下堕饿鬼中。洋洞灌咽。以称佛名今得值佛。佛示胸前万字。令读于此字中。说八万四千功德之行。即便忏悔。罪障消灭得记作佛。比丘尼见白银色者。过去释迦文佛时。五百童女在山泽中。忽遇比丘。皆脱银环散上发愿。愿此比丘成佛之时。愿我见之如所散银环。此后生生作银山神。今见银色。从是已来恒值诸佛。优婆塞见黑象脚者。此等昔时皆作国王。受邪沙门说于邪法。其说法人堕阿鼻狱。汝等随顺恶友教故。堕黑暗地狱。由前闻法善心力故。今得遇我得受五戒。令其忏悔。佛放眉间白毫光照。便得初果。求佛出家成阿罗汉果。优婆夷见聚墨色者。佛说。昔时一宝盖灯王佛像法之中。有一比丘巡行乞食。至淫女家。其女见之。盛满钵饭戏弄比丘言。汝颜色可恶犹如聚墨。身所著衣状如乞人。比丘掷钵腾空飞去。诸女惭愧忏悔发愿。愿此施食所有功德。未来得如比丘自在。以施食故。千二百劫常不饥渴。恶骂因故。六十小劫堕黑暗地狱。由前发善心。今得值我受其五戒。乃是供养阿罗汉故。见舍利弗不见我身。佛为脐中出大莲华。化成光台。有百千声闻。身子目连作十八变。诸女消二十亿劫烦恼之结。得须陀恒果。后见佛身相好端严。而不见白毫相。佛告大王。戏弄恶口乃至得道。见佛不明。余广如经更不会说。如蓝之缘准例可知。下十定品见色多种

疏。三尺等者。三尺之身即瞿师罗长者所见。丈六应身无边。即无边身菩萨穷上界而有余。准十定品。或见如来一由旬量。百千由旬乃至不可说不可说佛刹微尘数世界量。略等去中间。故云乃至无边

疏。五寿命等者。或无量劫如阿弥陀佛。或不满百年如今世尊。故涅槃云。我闻诸天寿命极长。云何如来是天中天。寿命短促不满百年。下至朝现暮寂者。如月面佛寿一日一夜故。佛名经第六云。妙声佛寿命。六十百千岁。智自在佛寿命十二千岁。威德自在佛寿七十六千岁。摩醯首罗佛寿一亿岁。梵声佛寿十亿岁。大众自在佛寿六十千岁。胜声佛寿百亿岁。月面佛寿一日一夜。日面佛寿一千八百岁。梵面佛寿二十三千岁。又第二中云。诸佛寿命长短差别。有十阿僧祇百千万亿。毗卢遮那品云。一切功德须弥胜云佛寿五十亿岁。下经之中。说诸佛寿长短多门。疏七根谓眼等随感现异者。佛眼等六根通相而言。三十二相广长舌等。既有八万四千等异。则六根之相随宜亦殊。故高幢普照主山神。得观察一切众生心所乐严净诸根解脱门。雨华妙眼道场神。得能雨一切难舍众宝庄严具解脱门。偈云。昔行施行无量劫。能舍难舍眼如海。如是舍行为众生。此妙眼神能悟悦。谓于一眼有无量行故。所得眼无量差别。复有诸根美妙执金刚神。又上经云。佛眼云何无有量等

疏。然圣人无名下。欲显多名先且立理。于中有二。先双标。谓本无言相故。下经云。已出世间言语道。其性非有非无故。凡有言象皆是随俗利众生耳。二若就德下就无名立名。不出此二。就德通于真应。随机唯约利他

疏。虽复多种下二以义统收。不出四悉檀义。一世界悉檀。但令欢喜如来立名少从于此多约后三。今言随宜此为总句。然四悉檀皆是随物宜故。此一句亦摄世界悉檀。二生善者。即是为人。三灭恶者即对治。四见理者。即第一义。又四悉檀亦名四随。问明品中更当广说。言海印顿现者。无尽之名皆我本师海印顿现。即摄十方三世佛号。皆属一佛随宜之号。非约多佛

疏。一切义成者。梵名悉达多。太子时号。果收因名恐人不知故将梵言以释唐语

疏。惑断等者。暗尽明圆清凉益物。如三德也

疏。然上释迦乃是族望者。姓望如崔卢等。族望如博陵。以是能仁之瞿昙故

疏。无能说过者。即大萨遮尼干子所说经第四卷。有严炽王请萨遮入宫供养。因问云。颇有人于众生界中聪明大智利根黠慧有罪过不。答言有。下有十重问答。大意皆同。一问是谁。一云能雨婆罗门聪明大智。常多淫欲喜侵他妻。二颇罗堕婆罗门多睡。三黑王子多嫉妒。四胜仙王子多杀生。五无畏王子慈心太过。六力过王子饮酒太过。七婆薮天王子行事太过。八大仙王子贪心太过。九大天王子轻躁戏笑放逸太过。十波斯匿王食啖太过。第十一问还更有不。答云。王亦有过。谓太暴恶急卒。王闻大怒令杀尼干。尼干惊怖乞容一言云。我亦有过实语太过。大王黠慧之人。不应于一切时常行实语。观其可不。我于暴卒人前出其实语。故为太过。王悟悔过。更问之曰。颇有聪明大智利根无有过不。答言有。问谁是。答云。沙门瞿昙。此一无过。我四围陀经中说。释种沙门无有过失。所谓生在大富家不可讥嫌。何以故。是转轮王种故。种姓豪贵不可讥嫌。以甘蔗种姓家生故。福德庄严不可讥嫌三十二相八十种好庄严身故。下广说如来具大慈悲无碍辩才十力无畏诸不共德。广说三十二相八十种好一切功德。云唯此一人无有过失。则显余皆不免。故今疏云无能说过。王闻发心

疏。问余圣教说下问答料拣。初问答中有三。初正释此文。二因此下类显义理。即五教意。二通始终。三即顿教。四五皆圆。三若通论下该通诸刹。以上五义但语娑婆。今该横竖一切诸刹。此五亦即成就品中。十无碍义。欲对上五显其无尽。故复重明。又前约五教以法随机。此五约理直语融即一相入义。即一多相容不同门。二相即义。即诸法相即自在门。三一具一切。即同时具足相应门。四即应即狭。是广狭自在无碍门。五即因陀罗网境界门。又兼上五潜入微尘。即微细义。随法回转即主伴门义。随心见异即隐显义。就佛而言本非净秽托事表法。十门不同即托事义。显于时中即十世义十玄具矣。上之十义直约处明立名如是。若小乘中尽三千界唯一释迦。若三乘说。亦百亿内有百亿释迦。余十方刹自是别佛。今约一乘。皆是遮那海印顿现。余十方佛刹亦犹如灯光互相重遍。然于一乘不可说体建立多名故。今此名一一融摄。名号品竟

    四圣谛品第八

疏。此品广于下。疏文有三。一对问辩来。二既知佛下约义辩次。三上名随下辩义相不同

疏。二释名者。疏文有二。先正释名。后出体相。今初。经论广明其文略具五地。复释。今当略辩。先得名后释名。前中文有三节。一双标二义。二言谛实下双释二义。谛通二义。圣之一字唯属审谛。三瑜伽下引证二义。法性是谛实。胜解是审谛

疏。四谓苦下释名先列。后总云下释名

疏。性相云何下第二辩体相。谓正出体性即说行相。故名体相。于中亦二。先辩性相。二属经结示。今初。通有天台四四谛意。四四谛者。玄文已具。今略列名。一生灭四谛。二无生四谛。三无量四谛。四无作四谛。依常所释但有其二。或名有作无作。或名有量无量。有作有量即是小乘。无作无量即是大乘。今以义开故成四四。初则生灭四谛。文有三。初正明。然句皆二义。如逼迫名苦则释别名。亦当辩相。一逼迫身心是苦行相。二即有漏色心者正出体也。色心即五蕴。心是四故。五盛阴苦苦故。不摄无为故。增长名集。是释名相。积集增长故。即业烦恼者出体。下二谛例知。而道云等者。等取八正道等。二此约相说。通大小乘者。结属生灭四谛也。然四谛有相有性。上所辩性是相性也。下说无相是真性也。三智论云下。引证通大小乘。亦是结前生后。结前是生灭四谛。大乘四谛皆无相下。生后无生四真谛也

疏。涅槃云下。即无生四谛。然疏有三。初引经正明。即十三经略示一苦。若具应云解集无和合名集圣谛。解灭无灭解道无道等。影在次文。二谓达四下以义释经。云何言无生四谛。从缘无性即是空。故名之为无非断无也。灭虽无为因灭惑显。亦曰从缘。言超筌悟旨成大者。苦集灭道以为空筌。其犹筌[(ㄇ@人)/弟]以求鱼兔。无相空理即为鱼兔。得鱼亡筌。是悟空方便得成大乘。非离四外别有大也。如非离筌而得鱼矣。三又涅槃云下。以引经证成大小别义。双证生灭及无生也。经云。善男子。以是义故。诸凡夫人有苦无谛。声闻缘觉有苦有苦谛。而无真实。诸菩萨等解苦无苦。是故无苦而有真谛。诸凡夫人有集无谛。声闻缘觉有集有集谛。而无真实。诸菩萨等解集无集。是故无集而有真谛。声闻缘觉有灭非真。菩萨摩诃萨有灭有真实。声闻缘觉有道非真。菩萨摩诃萨有道有真谛。故引此经文。兼释解苦无苦下之三句。言谓若苦即谛下。释经凡夫无谛之言。涅槃四谛品云。佛复告迦叶。所言苦者不名苦圣谛。何以故。若苦是苦圣谛者。一切畜生及地狱众生应有圣谛。亦即思益经文。此无谛言约审谛说。不约谛实。若约谛实。三涂实苦。言二乘虽审知之下。释二乘有谛无实之言。有审谛故如实知苦。不同凡夫妄计为乐。无实可知

疏。又二乘虽知苦相下。第三无量四谛。疏文有三。初蹑上立理。前不见法空苦性故无真实。此不知无量不见相故。亦非见实前即理智故。但见生空不及菩萨。此即量智故。但知粗相不及菩萨。二故大经云下。引文证成。迦叶白佛言。世尊。昔佛一时在恒河岸尸首林中。尔时如来取少树叶。告诸比丘。我今手中所捉叶多。一切因地草木叶多。诸比丘言。世尊。一切因地草木叶多。不可称计。如来所捉少不足言。诸比丘。我所觉了一切诸法。如因大地生草木等。为诸众生所宣说者。如手中叶。迦叶难言。如来所了无量诸法。若入四谛则为已说。若不入者。应有五谛。佛赞迦叶。善哉善哉。汝今所问。则能利益安隐快乐无量众生。善男子。如是诸法。悉已摄在四谛法中。迦叶复白佛言。如是等法若在四谛。如来何故唱言不说。佛言。善男子。虽复入中犹名不说。何以故。善男子知圣谛有二种智。一者中。二者上。中者声闻缘觉。上者诸佛菩萨。善男子知阴为苦名为中智。分别诸阴有无量相。悉是诸苦。非是声闻缘觉所知。是名上智。善男子如是等义。我于彼经竟不说之。次历入界皆如阴说。又别历色等五阴。一一皆言有无量相。此是无量四谛意也

疏。瑜伽论说苦有一百一十者。一百即四十四论。增数明之。初云。谓有一苦无差别流转之苦。一切有情无不皆有流转苦故。复有二苦。一欲为根本苦。谓可爱事若变若坏所生之苦。二痴异熟生苦。谓若猛利体受所触。即于自体执我我所。愚痴迷闷生极怨嗟。由是因缘受二箭受。谓身箭受及心箭受。复有三苦。一苦苦。二行苦。三坏苦。次云复有四苦。五有五苦。六有六苦。七有七苦。八有八苦。九有九苦。十有十苦。共成五十五苦。次论云。当知复有九种苦。一一切苦。二广大苦。三一切门苦。四邪行苦。五流转苦。六不随欲苦。七违害苦。八随逐苦。九一切种苦。其第一一切苦开为二苦。一宿因所生苦。二现缘所生苦。其第二广大苦开为四苦。第三一切门苦。亦开四苦。第四邪行苦开五。五流转苦开六。六不随欲苦开七。七违害苦开八。八随逐苦开九。九一切种苦开十。复成五十五故。两段合一百一十苦也

疏。三然此经中下。会今经文正同无量

大方广佛华严经随疏演义钞卷第二十八大方广佛华严经随疏演义钞卷第二十九

        唐清凉山大华严寺沙门澄观述

疏。又究此四下。第四无作四谛。文中亦三。初总明。言非唯但空者。拣上无生但显空义。便为真实正是所宗。二今了下别示四相。阴入皆如者。前云即空。今云即如理已别矣。又言无苦可舍非是空故。无有可舍今体即如。如外无苦何所舍耶。此句言如如尚似空。集言无明尘劳。皆即菩提。岂同前空苦。菩提体外无别可断。不同无生空无可断。前则空中无华云何可摘。今则波即是水不得除波。下二谛例然。生死即涅槃。非是体空无生灭也。边邪皆中正者。非离边外别有中道。非离邪外别有正道。亦非无边无邪无可修也。细寻可见。勿滥无生。故涅槃四谛品云。若知如来常住名修习苦。若知法常是名修集。若修灭者。若多修空名为不善。何以故。灭坏一切法故。坏于如来真法藏故同于外道。若有说言。有如来藏虽不可见。若灭烦恼乃能得入。若发此心一念因缘。于证得中而得自在。结云以如来秘密藏者。即是灭谛。道圣谛者所谓佛法僧宝。及正解脱。若能一念发心见如来常住无变。法僧解脱亦复如是。名修习道。上皆无作四谛意也

疏。无苦无集下第三束归一谛。一实谛义亦是涅槃十三文。文殊问佛。世尊第一义中有世谛不。世谛之中有第一义不。如其有者即是一谛。如其无者。将非如来虚妄说耶。善男子世谛即第一义谛。世尊若尔则无二谛。善男子有善方便。随顺众生。说于二谛等皆一谛义。亦下文殊问言。所言实谛其义云何。答云实谛名为真法。若法非真不名实谛。又名无颠倒。又无有虚妄名曰大乘。是佛所说非魔所说。又言善男子实谛者。一道清净无有二也。善男子有常有乐有我有净。是则名为实谛之义

疏。故斯一品下第二会经结示。上第三段中。言此经正同无量四谛。且从一义耳。今则具结通具四种也。故上疏云而文义包博言含性相。相即生灭及与无量性即无生。及与无作。相以广狭成二四谛。性以空实成二四谛。经宗必融举一收四方是经旨。以四种四谛义出诸师故。疏闇用使合经文不标名目。恐惊常听。结归二对顺常经论。或名有作无作。或名有量无量。今之结意有作即生灭。有量同无生。于有量上说无生耳。余二名同五地十重。至文自见。今略示名。一善知俗谛。二善知第一义谛。三相谛。四差别谛。五成立谛。六事谛。七生谛。八尽无生谛。九入道智谛。十善知一切菩萨地。次第成就谛。乃至善知如来智成就谛

疏。答以名虽在小等者。通此一问有二意。一四谛包含故。二开权显实故。今初名虽在小者。经中多言为求声闻者说四谛故。义通大小。即生灭无生等。言事理具足者。如十二缘但事而无理。今灭谛是理十二因缘名广事略。事亦不具。但有苦集而无道故。六波罗蜜但显此出世间无世间故。但有道灭无苦集故。谓苦集二谛下出具足相。言世界有异。此独无改者。十方诸佛出世教化皆令舍于世问证涅槃故。三世同然。故涅槃云。我昔与汝等不识四真谛。是故久流转生死大苦海。况无量无作下收后二重。但用前二性相具足大小包含。况加此二一实之旨。于是乎在

疏。又为破计下。第二开权显实故。以诸经等多说四谛为小。今开此局名周法界。亡所执相即入无生。引入一乘则会真实。况六度等而不周耶。五正释文

疏。如睫毛者全是俱舍颂云。如以一睫毛置掌人不觉。若置眼睛上为苦极不安。凡夫如手掌不觉行苦睫。智者如眼睛。缘极生厌怖。从而复以苦等者。即法华经第一云。不求大势佛及与断苦法。深入诸邪见以苦欲舍苦。为是众生故而起大悲心

疏。有业惑者。系缚三界者。然三杂染业惑为集。别有多门总不出二

疏。烦恼名诤即俱舍论云。烦恼名诤触动善品故。今灭烦恼故名无诤

疏。非唯灭惑而已者。如成实等亦说灭者。譬如灯灭则膏明俱竭。无复别有一实尽处也。肇公亦用此言。实则灭惑所显法身常住有实体也。故涅槃第四迦叶问言。如佛所言如灯灭已无有方所。如来亦尔。既灭度已亦无方所。佛告迦叶。善男子如人然灯之时。灯器大小。悉满中油。随其油在其明犹存。若油尽已。明亦俱尽。其明灭者喻烦恼灭。明虽灭尽灯器犹存。如来亦尔。烦恼虽灭法身常存。下文又云。如灯灭者是罗汉涅槃。又四谛品云。若言修习空法。是名不善。灭坏一切如来真法藏故。同于外道。故知灭体法是真实故。次云自性住者。证成上文体真实义。则体真实拣非虚妄及非空无。自性住言即是法住法正位也。本来寂灭即成上文自性住义

疏。集中病源者。谓有攀缘者。即净名第二云何谓病本。谓有攀缘从有攀缘即为病本。下文云何断攀缘以无所得。若无所得则无攀缘。释曰。正引病本无得因便

疏。惑由妄起故。分数尘沙等者。即大般若中般若波罗蜜多清净若色清净。若一切智智清净无二无二分无别无断故。故无二分是一分耳。是以生公云。万善理同而相兼亡异而域绝。善因伏惑成别故。有八万行名。行虽参差俱果菩提。总由一理以统之故。何有二分。理不可分如虚空故

疏。所之在灭者。灭为最上之者适也。道能证灭故为上行。此言在于周易。故谦卦云。地道卑而上行。噬嗑卦彖辞云。柔得中而上行。注云。上行谓所之在进也。凡言上行所之在贵也。今借此文势

疏。言观方谓观四谛也者。即涅槃三十六迦叶品中云。如恒河边有七种众生。一者沉没。二者没已还出。出已复没。三者没已却出出已不没。四者出已观方。五者观方已去。六者出去浅处则住。七者到彼岸广有合文。今但取第四观方一义。经云。是名第四遍观四方。四方者即是四谛。释曰。能观四谛即是道谛故。道名观方

疏。更有四方如十定品者。即第四十二阿耨达池喻中合池四方云。佛子何者名为菩萨四方。所谓见一切佛而得开悟(一)闻一切法受持不忘(二)圆满一切波罗蜜行(三)大悲说法满足众生(四)释曰。若观此四。为菩萨道也

疏。生老病死犹四山。临人等者。涅槃二十九中释八喻。非喻云。云何非喻。如我昔告波斯匿王云。大王有亲信人。从四方来各作是言。大王有四大山。从四方来欲害人民。王若闻者当设何计。王言世尊。设有此来无逃避处。唯当专心持戒布施。我即赞言善哉大王。我说四山即是众生生老病死。生老病死常来害人。云何大王不修施戒。即其事也。故贤与不肖。豪强羸弱同为四迁。一无脱者。梵王帝释贫穷下贱。尧舜桀纣三苗四凶。并归灰坏皆为苦依

疏。从惑生惑业者。即俱舍颂具云。从惑生惑业。从业生于事。从事事惑生。有支理唯此。此偈六地当释。今但要此句从惑生惑者。谓从爱生取也。言从惑生业者。即从取生有及无明生行。事即是苦。今但说集唯举惑业

疏。蜡印印泥者。涅槃二十九下当广释。次下疏文即彼经文。今当略引。经云。善男子如日垂没山陵堆阜。影现东移理无西逝。众生果报亦复如是。此阴灭时彼阴续生。如灯生暗灭灯灭暗生。善男子如蜡印印泥。印与泥合印灭文成。而是蜡印不变在泥。文非泥出不余处来。以印因缘而生是文。现在阴灭中阴阴生。是现在阴终不变。为中阴五阴。中阴五阴亦非自生。不从余来因现阴故生中阴阴。如蜡印印泥印坏文成。名虽无差而时节有异。释曰义至下释。今意在破印耳。阴即是苦。若证灭理。现在之阴不为后因。后阴不生即破印也

疏。照实则生死可尽者。此正立理故。中论下引证。先举偈文即邪见品。先有偈云。若世间有边云何无后世。若世间无边。云何有后世。上反释之。次云。五阴常相续犹如灯火焰。以是于世间不应边无边。释曰。以缘生性空故。不属边无边。复次如中百观说真法及说者等。此约相说。不遇因缘则生死无边。遇则有边。此有三事。一真法如良药。二说者如良医。三听者如可治之病。若具此三烦恼病愈。生死可尽。尽即是有边。不具此三烦恼浩然生死无畔。斯则无边。故结云非有边非无边也

疏。谓三事难得故下。疏释上偈。即影公意。彼疏云难得故非有边。难得故非无边。言犹难见故。取意释。夫言难得非全不得。若全不得一向无边。今有得者得则有边。以难得故则无边耳。此亦约一人而说。若总望一切难有其边。疏业寄于集者。设修善业。有漏心修。是寄于集谛因尽报谢。故云还亡。无漏心修是寄于道。道符于理直趣菩提故。疏二十五有各一分者。颂云。四洲四恶趣。梵王六欲天。无想五那含。四空并四禅。广如涅槃十四

疏。数体即集者。有为之法总名为数。亦心数也。今总中取别云即集也

疏。无一理以贯之则业惑万差者。生公云。凡顺理生心名善。乖背为恶。万善理同而相兼亡。异而域绝。即斯义矣。疏未入忍来常有堕性者。俱舍云。暖必至涅槃。顶终不断善。忍不堕恶趣。第一入离生。四善根中第三善根方免地狱。故知苦依之身地狱性矣

疏。同净名五受阴洞达空者。即迦旃延章。谓不生不灭是无常义。五受阴洞达空无所起是苦义。诸法毕竟无所有是空义。于我无我而不二。是无我义。法本不生。然今则无灭是寂灭义。今唯要第一句。至第三会当广分别。生公云。夫苦之为事会所成者。岂得有哉。是以言五受阴空是苦义也。五受阴苦之宗也。无常推生及灭事不在一。又通有漏无漏故言诸法苦。以即体是无义起于内。又得无漏者。不以失受致苦。故唯受阴而已也。洞达者苦以空为其体故。洞达无所起者。假会之法宜配起也

疏。爱见等者。爱见罗刹前已释竟。二地经云。身见罗刹于中执取。将其永入爱欲稠林。言妄体本空故。无可取者由二义。一段前名执取后名无所取义似相违故

疏。牒释下引中论释无所取。即是行品。行即是阴。谓小乘人为菩萨立过云。若一切法空。何以佛说虚诳妄取。若有妄取法则不空故。偈云。如佛经所说。虚诳妄取相。诸法妄取故。是名为虚诳。故论主举偈以答。即如今疏所引偈。是此答意云。由不了空。无所取中。而生取着。故云妄取。若有可取不名妄取。明知。说于妄取正为说空。如责翳人妄取空华。正为显华是非有故

疏。灭性离言者。诸法寂灭相不可以言宣故。道令言离者。亡心体极离言契灭故

疏。无为无因而体是果者。即涅槃师子吼品云。涅槃无因而体是果。若涅槃有因。不得名为般涅槃也。谓涅槃之体毕竟无因。如无我我所故。亦如俱舍无为无因果。谓六因无五但有能作故名舍因而体是果。则离系果菩提之道。望此亦因者要得菩提证涅槃故。此菩提亦名为因。是果中因故。灭理涅槃亦是因家之果。又是菩提果家之果故

疏。非习道学浮沉而不已者。亦涅槃三十二师子吼品。恒河七人之意。习道是法学。浮是喻。经中因师子吼问。若一切众生乃至阐提定有佛性。即当定得无上菩提。何以一切众生不得涅槃。若有佛性力故何须修习八正道等。佛便赞叹。谓举此喻。佛言善哉善哉善男子。如恒河边有七种人。若为洗浴恐怖贼寇。或为采华则入河中。第一人者。入水则没。何以故羸无力故。不习浮故。第二人者。虽没还出出已复没。何以故。身力大故则能还出。不习浮故出已还没。第三人者。没已即出出便不没。何以故。身重故没力大故出。又习浮故出已即住。第四人者。入已便没。没已还出。出已即住遍观四方。何以故。重故则没。力大故还出。习浮即住。不知出处故观四方。第五人者。入已即没没已还出。出已即住住已观方。观方已即去。何以故为怖畏故。第六人者。入已即去浅处即住。何以故。观贼远近故。第七人者。既至彼岸登上大山。无复恐怖离诸怨贼。受大快乐。善男子生死大河亦复如是。有七种人。畏烦恼贼故发意欲度。此下则义引经文。第一者。谓出家披衣。随逐恶友听受邪法。拨无因果即一阐提。没生死河不能得出是第一人。第二人者。欲度生死断善根故没。亲近善友得信心故出。又遇恶友复断善根。故复没也。第三人者。断善根故没。近善友得信心故出。信如来常住修习净戒。读诵书写十二部经。坚住施慧故名不没。修戒施慧即是习浮。第四人者。出没与住皆同第三。但合观方。云观四方者。四沙门果。第五人者。余义同前。但即去者。心无退转是住无退转已即便前进。前进者谓辟支佛。第六人者。前喻之中但云入已即去。及至合中亦同第五。皆有没出住去。去至浅处则住者。谓诸菩萨欲为度脱诸众生。故住观烦恼。经云第七人者。发意欲度生死大河。断善根故于中沉没。亲近善友获得信心。得信心已是名为出。以信心故。受持读诵书写解说十二部经。为众生故广宣流布。乐于慧施修习智慧以利根故。坚住信慧心无退转。无退转已即便前进。既前进已得到彼岸。登大高山。离诸恐怖。多受安乐。善男子彼岸山者。喻于如来。受安乐者唯佛常住。大高山者。喻大涅槃。善男子是恒河边如是诸人。悉具手足而不能度。一切众生亦复如是。实有佛宝法宝僧宝。如来常说诸法要义。谓八圣道大般涅槃。而诸众生悉不能得。此非我咎。亦非圣道众生等过。当知悉是烦恼过恶。以是义故。一切众生不得涅槃。释曰。是知众生虽有佛性要须修道。方至彼岸

疏。身与烦恼互为依止展转无穷。即涅槃四十纳衣梵志问言。如瞿昙说。无量世中作善不善。未来还得善不善身。是义不然。何以故。如瞿昙说。因烦恼故获得是身。若因烦恼获得身者。身为在先烦恼在先。若烦恼在先谁之所作。住在何处。若身在先云何说言因烦恼得。是故若言烦恼在先。是则不可。若身在先是亦不可。若言一时是亦不可。先后一时义俱不可。是故我说一切诸法。皆有自性不从因缘。下经答云。善男子汝言身为在先烦恼在先者。是义不然。何以故。若我当说身在先者。汝可难言。汝亦同我身不在先。何因缘故而作是难。善男子一切众生身及烦恼俱无先后。一时而有。虽一时而有。要因烦恼而得有身。终不因身有烦恼也。释曰。上有三关先后一时。佛舍前后而用一时。恐难一时故。自遮云。汝意若谓如人二眼一时而得。不相因待。左不因右右不因左。烦恼及身亦如是者。是义不然。何以故。世间眼见炷之与明。虽复一时。明要因炷。终不因明而有炷也。释曰。此佛一答。一时因缘二义并成。故今疏云。身与烦恼互为依止。互为依止言即俱时义。非为因身有烦恼也。谓因烦恼而得有身。能生烦恼。复依身住亦不应难。未有身时烦恼依何。故云互依。二互因依展转无际。若证灭理因惑不生。惑既不生身从何得。非唯身灭证于不生。展转之见亦皆寂灭

疏。道名广大性者。无不在者。然道无不在亦是庄子。东郭子问于庄子曰。道何所在。答曰。道在瓦壁。曰何下耶。庄子曰。道在屎尿。曰何愈下耶。曰道无不在。彼以虚无自然为道。无法不是虚无自然故无不在。今以类取。则真如寂灭无所不在。道符于灭何所不在

疏。则知密训等虚空世界为主摄伴亦然者。此有两重。一即释迦在此为主。摄密训等为伴。则在密训为主。摄娑婆等为伴亦然。方是一佛之谛。二如此佛谛名。既主伴无尽。则密训等他佛为主。谛名亦然

    光明觉品第九

疏。前但名谛别遍等者。如名号品如来于此名悉达等。在密训等名则不同。十方例然。谛名亦耳。此是一重别遍。二者名遍而非是谛遍。谛遍而不是名遍。故云名谛别遍。言今此一会即遍法界者。经云。如于此处见佛世尊。坐莲华藏师子之座。彼尽虚空遍法界一切世界阎浮提中。亦如是座。此是总遍相也。对上二别亦有二总。一总遍诸处。二主伴时处等总皆遍也。言同时者无前后也。言同处者。此有二处。一者约主。同在普光明殿。二者约伴同居金色世界等。言同众者亦有二众。一约主佛。十刹尘数菩萨围绕。二约伴众。谓文殊等诸来菩萨。亦各领十佛刹尘故。言同说者。一切处文殊同时发声。而说颂故。法界皆同说十信故。言同遍者。结上诸同。谓主伴时处皆悉遍也

疏。七圆遍故者。问此与第六有何异耶。第六亦名谛别遍。今亦云差别方能遍。第六云一会即遍。今此亦。云无差别一切遍。二相难分。答曰。细寻方别。前是总别对。此是圆别对。二处别则大同。而圆总则异前。言总别者。别则此界他界各各不同。总则处处皆同此一今圆别者。别则要有差别方能遍故。若不差别不能遍也。圆则不要差别而能周遍。能周遍之法一一圆融。故云无差别。一别一切别即圆融遍一切。上一切字是主伴处众。是能遍之一切。下一切字。但是所遍一切处耳。而言圆融者。一会即是彼一切会。亦非此会处处到也。即此即彼即一即多。故云圆融。又第六约所遍处以论总别。东名非西名所遍别也。此会即彼会所遍处总也。七约能遍以论圆别。要将差别之法方能普遍。是身名别也。今是圆融无差别之法。即能遍故名为圆也。前之别如列宿遍九天。此之别如一月落百川。故前云别则二处大同。大同者有小异故。前之总如一云之满宇宙。此之圆如和香之遍一室。故云总圆诚有异也

疏。第二释名。疏中先得名后若从开下释名。前中先开者。正有三重义含四对。一二光。二二觉。三能所。能所中义分为二。一上二光能所。二下二觉能所。从如来放身光下。二别示上来四对之相。谓分二光各属文殊及佛二觉。别配身智二光。而二光中各有两重能所。谓如来放身光能照也。照事法界即所照也。令菩萨觉知即能觉也。见事无碍是所觉也。所觉即照所成益。上即长行中事。二文殊以智光即能照也。双照事理即所照也。令众觉悟即能觉也。法之性相即所觉也。所觉即照所成益。即偈颂中意

疏。二合中下。合上四对。义有五重。文有六节。一合二境。即前所照。若事理不融余皆不合。故先明之。言故得一事。即遍无边而不坏本相者。即前所觉见事无碍。二身智无二者。二合二光也。引涅槃证者。琉璃光菩萨放身光明。文殊乃云。光明者名为智慧。则知二光不别。即第二十一经。三知悟不殊下。合二觉也。谓前身光照文殊等觉知如来光照我刹。然文殊等知是无知之知。故名悟心之知。知事即理二觉合也。不同凡小取事理相。四又此二光不异觉境者。即合能所也。二种能所一时双合。则能照所照能觉所觉。皆性融故举一全收。五此三圆融唯无碍之法界者。总融上三也。上虽四对体唯有三。谓能觉之光所照之境。所成之觉。三对六法举一全收为一法界。此上五重合竟。六虽平等绝相下。结成品名。上开多约相。合多约性。即开即合不坏性相。故云光明觉也

疏。又释名并是品宗等者。立名从所宗故。来意辩意趣故。故贤首以此释名。为其品宗。以此来意为其意趣

疏。第四解疑难者。文有三重。初一具疑难。光何时放滞二途故。从若说名谛下。蹑迹申难。答中初指前决其所疑。从但前二品下。二为其解难。谓前二品未要放光。故前不明。此中始要故此方说。此中菩萨即是牒前。故前十方一一别说。此则并牒。二光照百亿下。唯难无疑。三又疑云下。光明既穷法界。唯疑不难。但疑金色等何所在。故是不决耳。疑意云。此界放光而金色等。去于此界各十佛刹。今若主佛至东十佛刹处放光。则是文殊所从之刹。若更至东十刹。金色乃在放光之西。九方例然。故云金色更在何所。举初为例九色例然。后当刹下答。答意云。主刹向东放光。余之十刹一时向东。主刹如车毂。十方金色等。则如辐辋。车毂若移辐辋皆移。故下经云。尽法界虚空界。一切世界皆有百亿阎浮提一切如来。亦如是坐。悉以佛神力故。十方各有一大菩萨。所从来刹谓金色世界等。如向东既尔。遍余九方亦然。故主与伴一时俱遍。既遍法界总是娑婆。亦遍法界。皆是金色遍法界。皆是妙色十色皆遍。且依此会余会遍等。已如玄中。第五释文

疏。智论云。足下放者。身得住处故云于足。即第九论释经。从足下千辐轮相中。放六百万亿光明。表说六度故。义有两意。此是初意。第二意云。复次一身中。虽头贵而足贱。佛不自贵光不为利养。是故于贱处放光。彼约教相故作是释。今文约表故不正用。即是第二最卑微故摄之

疏。第二光至分齐。疏文有三。初明光至节数。二然非多下。拣非三唯一。下显正于中三。初正明一光顿照。二随机心现。下次通难。难云。既一时顿照。何以有二十六节等耶。释云。随机见故。三在佛文殊下拣滥。云何滥耶。上释妨中文有三节。一权机节节见。二光节节照。三文殊节节至。如第一百亿内机。则非百世界中机。百世界中机。则非千世界中机。则应第一节中文殊如来。非第二节中文殊如来故。今释云。唯第一机节节。互非下二节节皆遍。如第一三千佛光。即是第二乃至遍法界光。文殊亦尔。正遍第一节。文殊即遍法界。而节节见者。但由机感故云百川各见。机复有差。若未入法界节节不同。已入法界皆如文殊诸节顿见

疏。俱舍云四大洲日月等者。此文易了。总以喻显。一小千界如一千钱。一中千界如千贯钱。大千世界如千个千贯。而但取于初禅为数。已上不说。若举二禅已上则不同一成坏火灾所坏唯初禅故。故正理三十一云。小光等天非小千界摄。积小千为中千。积中千为大千。亦不摄彼。疏长阿含十八下。二例同余文。下引二经四论。并同俱舍。俱舍是十一。瑜伽第二。智论第十一。杂集第六。显扬第一

疏。然显扬第一明三千世界三灾所坏者。即刊定记意。上即论文。故如论释三千。意云如是三千三灾所坏。谓水火风。故知初禅已下即刊定取意解释。谓火灾坏初禅。水灾坏二禅。风灾坏三禅。明知说小千。但数初禅若数中千即数二禅以二禅量等中千故。若数大千即数三禅。三禅量等大千故。是知有百亿初禅。有百万二禅。一千三禅。唯一四禅。然若语量即是向说。所引文证义则不成。以言三千皆许三灾坏故。若中千数于二禅。二禅即火灾不坏等思之。正义如前引俱舍正理已释

疏。金光明经直至非想者。经云。是诸人王手擎香炉供养经时。其香遍布。于一念顷。遍至三千大千世界。百亿日月。乃至百亿非非想天。言今依二经者。即金光明。及此经文。约有处所。但至色顶约该地法遍于四空。四空无处。随处得果。如在欲界得无色定。即于欲界而受果报故。无别处摄在二界。然皆通于二十八天。若尔与诸经论云何会释。意云。且如二禅直语其量。等小千界。一三禅量。等中千量。一四禅量。等大千量。三千如次上为下盖。譬如夏云普覆九洲。若以洲取则有九云。若以郡取则四百余云。若以悬取千数未多。或言一云普覆万国。或言万国各有夏云思之可知

疏。俱舍云。阿耨达池岸者。即第十一论释无热池。意云。于此池侧有赡部林。其形高大其果甘美。依此林故名赡部洲。或依此果以立洲号。论更不释。有云。以此洲南狭北阔树叶头大后小。似此洲故。未见有释。若立世阿毗昙云。树在此洲之南。瞿耶尼亦云瞿陀尼。瞿即牛也。陀尼货也。北洲新云俱卢。余可知

疏。若以小数计有万亿者。小数即下等十十变也。谓十小千为万。百小千为亿。千小千为中千。已有十亿。更千中千为一大千。一千中千即有千个十亿。故为万亿。疏今约中数者。谓从千已上方百百变之。谓百小千方为一万。千个小千为中千。方是十万。十个中千始为百万。方是一亿。既十中千为一亿。今有千个中千。故有百亿耳。故唐三藏下二引证。既译百亿为百俱胝。俱胝存其梵言。亿是此语故。二义同。次引测公三种俱胝。证百亿为百俱胝。言或至百数者。即三千有百亿是也。以千万为俱胝故。或至千数者。以百万为俱胝。谓小数数之。中千有百万个小千方是一亿。今大千有千中千。故为千亿。或至百千者。即以十万为一俱胝。故中千已有百俱胝。千个中千方为大千。大千则有百千俱胝也。故疏云。唐三藏译。是千万为俱胝。故三千有百俱胝。俱胝即亿。疏又依俱舍下。三会释俱胝不同。言俱舍译洛叉为亿者。亦是十一论释水轮云。次上水轮深十一亿二万。下八洛叉水。余凝结成金。初以唐言云十一亿二万由旬。下句梵语云下八洛叉水。则八亿由旬为水。三亿二万由旬为金。故知洛叉为亿也。下阿僧祇品云。一百洛叉为一俱胝。则俱胝义当于兆。良以。俱胝有三等故。则俱舍洛叉云亿。当十万云亿。下云一百洛叉为一俱胝。则当千万云亿也

疏。约微细门融三世者。一中顿具一切诸法。炳然齐现名微细门故。说一相之中具余七相。如在母胎即具余七。今在成正觉相中具余七相也。故言融三世者。亦即十世隔法异成门。受生是过去。涅槃是未来故

疏。亦非能照是报者。拣滥释也。可知。言二不并故者。报处见化。见化不见报非谓报化并现故也。疏非是多处各有会者。亦是拣滥。恐人误解若多处有会。似如十人为会十会在一室中。一灯照了。令人顿见十会百人今不尔也。一会遍一切处者。如于一室悬百面镜。中有十人共为一会。则百镜中有百会也。思之。疏一切处文殊。略申三义者。第一约文即是以应就机。令百川中一时见月。言各各皆说当节之偈者。如百亿内。同说若有见正觉偈。第二节内。同说众生无智慧偈。然有四句。一一切处文殊同说一偈。是一切即一。二但一文殊十节说偈。是一即一切。三各于佛所即一唯是一。四诸处文殊各偈不同。即是一切中一切。疏二一文殊从一处东来下。第二释约义。复语其实德。如前溪之月即是后溪。及千江百川之月。全入前溪。所以尔者。一切处月不离本月故。本月落溪。则千处俱落。第三约表者。文殊主般若门。若约观照般若。智了万境无非般若。若白日丽天无物不照矣。若实相般若无法非实相体故。无非般若。犹水全遍波无波非水。即大般若云。般若波罗蜜多清净故色清净。色清净故一切智智清净。何以故。若般若波罗蜜多清净。若色清净若一切智智清净。无二无二分无别无断故。通于观照及实相也。二正显偈。疏然观资理成等者。以贤首有上二意。各别科文。初约境显理中。十偈为三。初一法超情表。次八会事归理。后一事如理融。成前一会。即一切会等事无障碍也。二约心令泯绝诸见。依此释经十偈为六。初之二颂颂于放光佛。令离见。次一颂会前光所照处。以明离见。三有三颂会前所现本法会等。以明离见。四有二颂别会诸菩萨大众。以明离见。五有一颂会前所照众生。六末后一颂明前法会周遍所由。今疏意明不为两般合成一释。显理离见二义相成。故总出所以。云观资理成。若不见理不成观照故。理由观显者。不得观照安能会理。理无废兴弘之由人。故观成契理。诸见自亡故合为一释。皆带显理破见之义。一一具于逼别二意故。初偈反显明违理起见为过失生。后九顺。明会理则理显而见息也

疏。本无有着谁为无著者。如黐胶粘人则有着不着之者虚空不粘。谁为不着空中胶者

疏。情尽理现即名作佛者。此顺禅宗即事理无碍门也。约普贤门。正是华严即事事无碍门也。约行布说。此为千里之初步也

疏。亦显光所照处以明离见者。上约通明。今约别说。令离妄动即是破见。知真法界不应动故。即是显理。此句全是大般若曼殊室利分。经云。若菩萨不动法界。知真法界不应动摇。不可思议。不可戏论。如是能入一切相也。言不动而了故成胜智者。此句观益。诸偈虽同皆是。佛果差别之德。而皆与于观相相顺故。称不动而知。以释当成胜智

疏。我即法性更不证入下。释上平等即无能所。故曰无住。然有二意。一上二句明一性不分。故无能所。犹如一指不能自触。二法性无性复何所入者。明性空故无能所入。亦如虚空不住虚空。此亦大般若曼殊室利分意。彼经云。佛告文殊。汝于佛法岂不趣求。文殊言。世尊我今不见有法非佛法者。何所趣求。释曰。此即一性意也。次佛问云。汝于佛法已成就耶。文殊答言。我都不见法可名佛法。何所成就。释曰。即性空意也。次佛又言。汝岂不得无著性耶。文殊答云。我即无著。岂无著性复得无著。释曰。即今疏云。我即法性更不证入

疏。故般若文殊分云下引证。前即闇用二意。今即显证无住。是彼次后经文

疏。智论答云。平等即是三宝者。即八十五论。亦是经文。须菩提问佛。若无差别云何有三宝。佛答。即今疏文

疏。又上第三偈下。收上四偈成一不二法门。即净名经寂根菩萨曰。佛法众为二。佛即是法法即是众。是三宝皆无为相。与虚空等。一切法亦尔。能随此行者。是为入不二法门。疏下经云。无上摩诃萨远离众生想者。即第十六经。无上慧菩萨偈下半云。无有能过者。故号为无上。今无生可坏即离众生想。疏谓一与多下。上标举二门。今正将缘起相由所以。释一多相容之门。此中大意凡所知所起即无有力。若能知能起即是有力。广如玄文。疏由此缘起下。结破静法。彼云。此偈了一多平等。谓解多由一起。解一由多生。无一不成多无多亦无一。了彼一多相由生起。一多之念息。一多相平等。此会差别归平等性。理事无碍非事事无碍。应审思其文。勿谬解也。释曰。今疏即贤首意。此公破师言。是谬解故。今结示即符昔大义中之一也。此公意云。是理事无碍者。以例前诸偈。多约会事归理。一切平等拂诸见故。不合是事事无碍故。今先出此偈本意。言由此缘起成前平等者。上云本会则住无所住。新集则入无所入等。皆平等义。何以得此皆平等耶。特由缘起互相由故。且如本会。与彼十方新集之会。共成缘起由因。本会有十方故。十是所起。所起无体即是本会由因。十方说本会故。本是所起。所起无力故入十方故。由缘起成前一切皆悉平等。言由前平等成此缘起者。谓一有定性不由于多。多有定性不由于一。今由一无定性。假多而起。多无定性。由一而生。故由无性平等之义。方成缘起。若有一可一此是自性一。若有多可多此是定性多。若是定性多。多不因于一。若是定性一。一不因于多。今由多故一。此一不自一今由一故多。此多不自多。多不自多。此多则无力。此一不自一。此一则无力。无力随有力。一多互相收。故随一佛会即一切佛会。法界一切会即是一法会故。此一法会不动而常遍。不分而常多。前后互相成如何不信。故贤首云。缘起法界理数常。尔。应细深思自当见耳。观此疏文。似此弟子当听之时。早已不受特令深思故

疏。结云不信事事无碍恐未着深思也

大方广佛华严经随疏演义钞卷第二十九大方广佛华严经随疏演义钞卷第三十

        唐清凉山大华严寺沙门澄观述

第二节疏。如泥中刺不觉其伤者。爱欲所覆犹如溺泥不知其伤。言如疮中刺者。即是肉刺故。涅槃中名为息肉故。彼十三经云。深观此爱凡有九种。一如债有余。二如罗刹妇女。三如妙莲华茎下有毒蛇。四如恶食性。所不便而强食之。五如淫女。六如摩楼迦子。七如疮中息肉。八如暴风。九如彗星。初一即声闻缘觉余习。二生子便食后食其夫。爱食善子后食众生。令入三恶道。三五欲华下有爱毒蛇。令其命终。四强食患下堕三恶道。五与爱交通夺其善法。被驱逐堕三恶道。六缠绕凡夫善法令死。七如人久患疮中生息肉。其人要当勤心疗治。莫生舍心若生舍心息肉增长。虫疽复生。以是因缘。即便命终。凡夫愚人五阴疮痍。亦复如是。爱于其中而为息肉。应当勤心治爱息肉。若不治者。命终即堕三恶道中。唯除菩萨是名疮中息肉。八暴风能偃山夷岳拔树深根。爱于父母所而生恶心。拔菩提根。九爱之彗星能断一切善根。令凡夫人孤穷饥馑。今正用疮中息肉一义耳

疏。普见通于性相故离二边者。此上总释一偈。此下别解上半。上半。云普见于诸法二边皆舍离。今应问云普见诸法。如何即能离得二边故。今答云。通性相故。唯见相者即是有边。唯见性者即堕无边。性相无碍故离二边。中论云。虽空而不断。虽有而不常。即由空有相即离二边也。从谓真故无有下。引影公中论序以释之。真即是性。俗即是相。依二谛融故离二边。然二谛之义玄中已明欲释此疏略申四义。谓或说妄空真有。如涅槃云。空者所谓生死。不空者。所谓大般涅槃。二者妄有真空。即是今文。三俱空相待无性故。四俱有性相不坏故。于谛常自二故。今此正当第二俗有真空义。而有四对。初对定有无所在。我约真谛上。说空是无性空。不同无物空也。我就俗谛明其有。此是缘有非定性之有也。二真故无有则虽无而有下一对。彰有无体相。是不坏有之无。不碍无之有故成中道。三虽有而无则不累于有下。彰有无之德。若是定性之有。此有则唯是有。不得即无。若是定性之无。此无则唯是无。不得即有。今二互相即故不偏滞。四不滞于无下一对。彰有无离过滞空则断累有则常。既不滞不累故无断常。又释。初对双离有无。故云无有无无。此成空观。第二对不坏有无。故云虽有而无。虽无而有。此成假观。第三对明二谛相即故。不偏滞有无故。不为有边所动无边所寂。成中道观。肇公亦云。涉有未始迷虚。故常处有而不染。此不累有也。不厌有而观虚。故观虚。而不证。此不滞于无也。第四离过。准前有释。初对中初句云真故无有。无彼定性之有是真空义。次句俗故无无。无彼断灭之无故。是妙有义。第二对亦有亦无义。第三对非有非无义。第四对离过则成具德四句也。又初对双离二过。一离有二离无。第二对离非有非无。第三对。离亦有亦无。第四对总明离过故。起信云。真如非有相非无相。非非有相非非无相。非有无俱相即斯义也。是以结云。俱不俱等何由而有。谓第四对正离断常。第三对不偏滞。故离于俱句。第二句不坏二故。离于双非故俱寂也。又若有二可得名俱。今有即无故。则有外无无。可与有俱。今无即有故。则无外无有可与无俱故。亦有亦无相违不立。言不俱不立者若定有定无。遮彼有无有俱非句。今有即无何有非无。今无即有何有非有。故双非亦寂。既无有无亦无一异断常来去。靡不皆如。故云都寂。是以经言二边皆舍离。皆舍离者。一切二边非局有无。又言离者性自离故。不取着故了真性故。非有诸边可舍离也

疏。次一慈力降魔者。大乘方便经说。波旬兵众满三十六由旬。围菩提树欲作留难。菩萨住慈悲智慧。以手指地。八万四千八部大众。皆发大菩提心。故云慈力降魔。经云。导师降众魔慈悲故如是。观佛三昧海经第二。说观白毫功德中。说慈悲降魔。今取意引波旬。召诸八部及旷野鬼神十八地狱阎罗王神。其阿鼻等诸大地狱。全至佛所。及有无边诸怖畏事。一时逼迫菩萨。菩萨。尔时徐举右臂。申眉间毫下向用拟阿鼻地狱。令诸罪人见白毫中流出众水。澍如车轴。火灭苦息心得清凉。狱卒见铁叉头如白银山。龛室千万有白师子。蟠身为坐。于其座上生白莲华。有妙菩萨入胜意慈心三昧。狱主发心。众多罪人诸苦休息。称南无佛。皆得解脱。无边恶事无由近佛。魔王憔悴懊恼却卧床上。有三魔女。又怀惑乱菩萨。亦以白毫拟之。诸女皆见三十六物九孔不净。背负老母抱死小儿。皆九孔流溢匍匐而去。魔王奋剑向前。世尊又以白毫拟之。令魔眷属身心安乐。如第三禅。饿鬼见毫端皆有百千万亿诸大菩萨。入胜意慈心三昧。皆是慈力降魔。经云。光中演妙义者。即眉间光。谓时魔波旬既不能坏佛。忽然还宫。白毫随顺直至六天。于其中间无数天子天女。见白毫孔。筒中皆空团圆可爱。如梵王幢。于其空间有百千万恒河沙微尘数诸宝莲华。一一莲华无量无边。诸妙白毫以为其台。台上有化佛菩萨。放于白毫。大人相光亦复如是。诸菩萨顶有妙莲华。其华金色。过去七佛在于华上。是诸化佛自说名字与修多罗等无差别。即光中演妙义也。然是慈心三昧之力。是故总云慈力降魔。疏次一智断致用者。初句智次句断。此即精义入神故。能一念顿现一切。是致用也易系辞云。尺蠖之屈以求信也。龙蛇之蛰以存身也。精义入神以致用也。注云。精义物理之微者也。神寂然不动。感而遂通者也。故能乘天下之微。会而通其用也。今借此言。以智断冥契。为精义入神耳。第三节。疏性相无碍。是真通达者

疏。释通达无碍。有其二义。一所达之法性相无碍。二能了之智无有二碍。二碍即二障了相故无智障。了性故无惑障。故次句云。无二碍着。则转依心净者谓转无常杂染之依唯以功德依常法身。故云心净离众着。通达是智。无碍是断。调生是恩。云三德备

疏。皆言或见者此九别中有九或见在义易了。而人尚迷。今寄清凉五台求见文殊。以况法界。见佛差别总有十义。一或多机异处各感见。一者如有五人名为多机。各在一台名为异处。一人南台见菩萨。一人西台见师子。一人中台见万圣。一人东台见化佛。一人北台见圣僧。是各感见一也。二或同处各见者。五人同在中台故云同处。一见菩萨一见师子等。故云各见。三或异时别见者。一人朝见菩萨。暮见化佛等。四或同时异见者。上异时别见不局一人多人今此要是多人。谓二人同于晨朝一见化佛。一见菩萨。五或同时异处见者。亦约多人同于晨旦。一于东台见。一于北台见。所见之境。或同或异。或同见菩萨。亦是同时异处见。或则一见菩萨一见化佛。亦同时异处。六或同处异时见。同于中台朝见暮亦见。而能见亦通一人多人。所见亦通一境异境。但取处同时异耳。七或异时异处见。时则朝暮不同。处即东西台别。而能见亦通一人多大。谓或一人朝于中台见菩萨。暮于北台见菩萨。异人可知。然约一人其所见境亦通同异者。同见菩萨如上已明。或一人朝于中台见菩萨暮于北台见师子。然多分且约一境。八或同时同处见。亦约多人同在中台。同于中时见菩萨。所见亦通同异。且约同说。九或一人于同异交互时处见多人所见者。言同异交互时处者。谓同时异处异时同处。名交互时处。然同时异处即是第五。而要是多人异时同处。即是第六通一人多人。今唯一人顿见前多人。所以见此机亦是不思议人。能于同时异处见故。谓有一人于晨朝时在于中台。见中台多人所见。亦在西台见多人所见又于中台。于朝于暮皆见多人所见也。十或一人于同异俱时处见一切人所见者。谓同时同处异时异处。名同异俱时处。既是一人时该多时处遍诸处。见通诸境。故是普眼机也

疏。然佛不分身下。不分而遍。无思普现顿应前十也。疏如第八会者。即五十九经各有十意。说者应引。第四节疏。今观于身若我即阴等者。即中论法品中意。论云。若我即五阴我即为生灭。若我异五阴即非五阴相。若无有我者。何得有我所。内外我我所尽灭无有故。诸受即为灭。受灭即身灭。业烦恼灭。故名之为解脱。业烦恼非实入空戏论灭。释曰。上中论意。正观于身五阴之法。而如来品五蕴上求如来。亦能就于我及我所说。即如自观身实相。观佛亦然。若了二我本自空寂。则见法身堪然常住

疏。中初二句即论。初两句明即阴无我。阴是有为生灭之法。我即是阴故同生灭。次两句是论第二两句。异阴无我。而论主但云则非五阴相。今云以何相知者。是长行释语。谓凡一切法。皆以相知有离阴有我。即不以五阴为相为用。何相知有我耶。故但妄情结成论意。妄情计有我性实无。故云我性未曾有

疏。既无有我下。以我破所。释经我所亦空寂。即论云。若无有我者。何得有我所

疏。我我所空身从何有。以无我遣身。释经下半云何诸如来而得有其身。即论内外我我所下。一偈半文

疏。无身之身下。结归疏意。三德内圆法身为一耳。故经云。佛以法为身清净如虚空矣

疏。二显解脱般若德者。即三德之二也。先释解脱德。引于涅槃。略有二种。即二十五经。高贵德王菩萨品第八功德中一义。经云。云何菩萨心善解脱。贪嗔痴心永断灭故。是名菩萨心善解脱。若瑜伽八十五云。由三种相。当知心善解脱。一于诸行遍了知故。二于彼相应烦恼断德作证故。三烦恼断已于一切处离爱住故。经云。云何菩萨慧善解脱。菩萨摩诃萨。于一切法知无障碍。是名菩萨慧善解脱。因慧解脱昔所不闻而今得闻。昔所不见而今得见。昔所不至而今得至。释曰。心善解脱即灭定障。慧善解脱即脱智障。二障既除翛然无系。故名解脱。涅槃下经重复问起以显前义。谓心定有贪等则不可脱。定无贪等即不须脱。欲明相有性无。此二无碍方名解脱。言涅槃略有一百八句以显深广者。即第五经广释二德中。解解脱之德。迦叶问言。世尊何等名为涅槃。善男子涅槃者。名为解脱。先示其体。亦色非色下。迦叶重请明解脱相。尔时迦叶菩萨。复白佛言。世尊唯愿哀愍重垂。广说大般涅槃解脱之义。佛赞迦叶。善哉善哉善男子。真解脱者。名曰远离一切系缚。若真解脱离诸系缚。则无有生亦无和合。譬如父母和合生子。真解脱者则不如是。是故解脱名曰不生。迦叶譬如醍醐其性清净如来亦尔。非因父母和合而生。其性清净。所以示现有父母者。为欲化度诸众生故。真解脱者。即是如来如来解脱无二无别。譬如春时。下诸种子得暖润气寻便出生。真解脱者则不如是。此是一句余如彼经。然依远公云以义相从有九十四句。随别细分有一百九句。第二十二无逼切中别有七句。第二十三无动义中有四句。第二十四希有义中有其二句。第二十五虚寂义中。亦有两句。第四十甚深义中有其二句。第五十一平等义中亦有两句。第六十七无窄狭中有其三句。余各有一。是故分为一百九句。今言一百八者。即于二十二无逼切中。但有六句以远公见有七喻。故分为七。而第三句云。云何逼切无逼切耶。譬如凡夫我慢自高。而捉蛇虎毒虫。是名逼切。不逼切者。如转轮王所有神珠。能伏毒虫名不逼切。六句皆是无逼切义。唯此一句兼明逼切。以显无逼。看似两句实是一句。表除百八烦恼。亦同楞伽百八句问

疏。言明行者。即般若德。朗照万法故称明行者。即如来具三德人

疏。若作明行足释者。重释明行二字。即十号之一。先引瑜伽。由有止观云禅慧德。彼后更有极善圆满。以释足义。约满足义无脚足义故

疏。不引

疏。涅槃十六下。此经十八先释明后释行。前中先引经。彼有四释。今当第四。就行修证入释明。即证入之体。后然皆般若因果理智异耳者。是疏释经。菩萨明者因中证智。佛明者果中证智。上二皆智。无明明者是所证理。智即观照。理即实相。智度论云。说智及智处。俱名为般若。即斯义也

疏。足有二义者。即释行字。此中略无足字行字所摄。然经四释不出二义。第一释云明者。名得无量善果。行名脚足。善果者名无上菩提。脚足者名为戒慧乘。戒慧足得大菩提。名明行足。释曰。此则据果寻因。释以明为果以行为足。行即是足脚足义也。行足不分是今经意。二者经云。又复明者名咒。行者名吉。足者名果。善男子是世间义。咒者名为解脱。吉者名无上菩提。果者名大涅槃。释曰。此偏就果德释然以世间况于出世。此以涅槃为足。是满足义。亦智断总别耳。三者经云。又复明者名光。行者名业。足者名果。善男子是名世间义。光者名不放逸。业者名六波罗蜜。果者名无上菩提。释曰。此即从因释果。释谓明行皆因以足为果。前释三皆是果。此独菩提是果耳。今疏所引。即当第四。但引释明。彼释行足云。行者于无量劫为众生故修诸善业。足者明见佛性。释曰。此亦满足释足。以足为果以行为因行足义开。今经无足故取初释。行足合义不引此文

疏。无数下显其离过。即下三句于中四。一总明。二因明立量下。释世间义。三如说佛声下。指事以明求过。不得定有则常。今非定有不同外常。因缘造作即是无常。今从法性故离造作。不同无常何可求过。四诸因量者下。随难牒释。言诸因者。谓即生因了因。言诸量者。谓现量比量。及圣言量。所言因者。所由所以顺益待籍之义相也。为由有此所由所以顺益待籍。宗果方明。故说此等名为因也。此即要是宗之所由。亦是宗之所以等。由此即显与所立宗。一向一味能建立宗。故名因也。又因有三相。一遍是宗法性。二同品定有性。三异品遍无性。如立声是无常瓶等。为同品。虚空等为异品。于同品定有异品遍无。是无常等因。同喻异喻皆名喻也。言自他共等三种比量者。因明。第二疏中广说。今略示之。如萨婆多立无表色自立量云。我无表色定是实色。许色性故。如许色声等此即自比量。谓自立义。令他解了。二他比量者。于他立中出宗因过。如大乘破萨婆多云。汝无表色非定实色。许无对故。如心心所三共比量者。于他立中。出比量过

疏。因为量主者。此即彼中三支有阙妨问。夫论立量三支圆满。果明不举独唱因明。答有二解。一云。对敌申量即能立。三支具足。敌者起智所由并得称因所生敌。智即号为明。理智合举故说因明。二云。就比量中有许未许为成未许必有能成。即能成是因。所成是宗。宗由因显。义得分明。此即因果双彰理无违妨。上之二义。正以后义因为量主。又经中云世间诸因量者。亦可世间相违求过不得也

疏。蕴者聚义等者。俱舍界品云。彼论。问云。蕴处界等别义云何。颂曰。聚生门种族。是蕴处界义。释曰。初句释义。次句结成。聚谓积聚即是蕴义。诸有为色。若过去若未来若现在。若内若外若粗若细。若劣若胜若近若远。如是一切略为一聚。说名为色蕴。言粗细者。可见有对为粗。余二为细。又不可见有对。望上为细。望不可见无对为粗。三唯是细染污名劣。不染污名胜。现在名近过未名远。余蕴例然。但粗细一门有异。谓意识相应四蕴为细。五识相应五蕴为粗。依五根故。或约九地下地为粗。上地为细。言生门者。处义谓六根六境是心心所生长门处。言种族者。界义论有两释。一族者谓种族也。是生本义。谓十八界为同类因。各生自类等流果故。是法生本。二族类义。十八种法种类自性各别不同也

疏。俱舍论云。愚根乐三下。此之半偈。论明教起不同。谓愚有三。一愚心所为我。二愚色。三双愚心色。如次配三。言根有三者。谓上根闻略得悟故。说五蕴。中根闻中说十二处。下根闻广方了说十八界。言乐三者。谓乐略说蕴。乐中说处。乐广说界

疏。因灭无常色即涅槃三十八如下当引。疏如来妙色常安隐故。但要此句具有一偈。偈云。不为时节劫数迁。大圣旷劫行慈悲。获得金刚不坏体

疏。四叹佛超绝根境德者。即其性本空寂。偈初句何法不寂独叹如来故。疏答。云境智双寂契彼性空。故为佛德。所以无心于物境则未亡摄境归心。心又未寂。今佛双亡寂照方契性空。此以第二句成上第一句。次言根尘两亡内外解脱。即上句释下句。由契性空故亡根尘。心所知法一切皆空。故亡尘也。能知之心亦不可得。故亡根也。由内亡故根不能系。由外亡故境岂能牵。真解脱也。斯乃解脱惑障。次云亦常照内外脱于无知者。此智障解脱。上寂此照寂照无二。真佛心也。次空上不存者。举况释第三句。空为所契尚不当心。妄念空华岂当佛意。第五节

疏。次四修智上攀业者下

疏。释有二意。前意各别一行。后意通修诸行。文虽局一义乃兼通。如长时修。谓长时信长时乐。长时念长时学。下三亦然。若约所信。念等皆佛功德

疏。如净名观佛前际不来等者。即见阿閦佛品。佛问维摩诘。汝欲见如来。为以何等观如来乎。维摩诘言。如自观身实相。观佛亦然。我观佛如来前际不来。后际不去今则不住。不观色不观色如。不观色性。不观受想行识。不观受想行识如。不观受想行识性非四大起同于虚空。六入无积。眼耳鼻舌身心已过。不在三界三垢已离顺三脱门。三明与无明等。不一相不异相。不自相不他相。非无相非取相。不此岸不彼岸不中流。而化众生观于寂灭而不永灭等。彼以观身实相用观如来。今但自观为小异耳。真实观同

疏。又法华不颠倒等者。即安乐行品第二亲近处经云。文殊师利。又菩萨摩诃萨观一切法空。如实相不颠倒。不动不退不转。如虚空无所有性。一切语言道断。不生不出不起。无名无相实无所有。无量无边无碍无障。但以因缘有从颠倒生。故说常乐。观如是法相是名菩萨摩诃萨第二亲近处。释曰。上经皆观实相。即理实相也。云皆寂灭疏中论法品下。引论全释一偈。然顺今经。引论乃倒。今先具引论文。然后释义。论云诸佛或说我。或说于无我。诸法实相中无我无非我。诸法实相者。心行言语断无生亦无灭。寂灭如涅槃。一切实非实。亦实亦非实。非实非非实。是名诸佛法。自知不随他。寂灭无戏论。无异无分别。是则名实相。若法从缘生。不即不异因。是故名实相。不断亦不常。不一亦不异。不常亦不断。是名诸世尊教化甘露味。释曰。此有六偈。大分为四。初三明实相之体。次一智契实相。三有一偈。名实相之由。四有一偈。明实相之教。初三中。初一明实相双非。次一明其深寂。后一语其体圆。又三是横广。三是竖深。初一非深非广。又初一对我说实相。二约性显实相。三该通性相明实相。以实是性非实是相故。略知大旨。今之所用。但用二偈。初以竖深释经上半。以心绝动摇言亡四句。故云心行言语断。理圆言偏理与言绝。故云言语道断以欲言其有无状无形。欲言其无圣以之灵。故口欲辩而辞丧。心以取相为行。实相无相故绝心行之处。是则心将缘而虑息。以起心动念不会理而。故体无生。既法本不生。今何有灭。无生无灭即是寂灭。言如涅槃者。举喻以显。然实相之体即性净涅槃。而人知涅槃寂灭不生。不知实相寂灭。故以涅槃为喻。若了实相即是涅槃。涅槃之相亦叵得也。次以双非实相。释经下半。离我无我着。实相无我不可着。从亦无无我。亦不着无我。若着二无我理未免于着。从又离我者下。上来直就体明。此下对人以显不着无我。则不趣证故能悲济。从然我无我下。复以四句会融释此四句。略有三意。一对人以显成前对人。谓唯我即凡夫。无我即二乘。双辩对小说大涅槃。云无我者所谓生死。我者谓大涅槃。二乘之人但见无我。不见于我。双非即泯绝大小。二者直就大乘性相。亦有此四。初句唯一真我迥然独立。次句对病显实我法皆空。双辩句。真妄双观不坏性相。双非句。性相融即故互夺两亡。三者但约观照。第一句。知诸众生妄执有我。二称理而观离于二我。三亦双照性相。四即真妄形夺。与第二释异者。此初句有我此是妄我。第二初我乃无我法中有真我耳。第六节

疏。初一拣迷此下。以经初句下五字为三节摄。佛地论叹佛偈。偈云。自性炽盛与端严名称吉祥及尊贵。如是六种义差别。应知总名薄伽梵。今文具用此翻六义。以显真佛最胜之法。初以自在炽盛二德。释威德字。论云自在者。永不系属诸烦恼故。炽盛者。猛焰智光所烧炼。故此内威。德由内具此智断二德。外摄群魔制诸外道。二以端严吉祥释于色字。色即色相。论云。端严者三十二相所庄严故。吉祥者。一切世间亲近供养咸称叹故。三以名称尊贵释种族字。论云。名称者。一切殊胜功德圆满无不知故。尊贵者。具一切功德。常起方便利益世间。安乐一切无懈废故。此上二德前是功德。后是大悲。悲智功德为佛种族。谓佛以功德为种性故。佛以大悲为根本故。为出生故。即内种族故。能悲现刹帝利种

疏。虽是薄伽下释后半。蹑上而释。谓上之六义号为薄伽。依此而取未免颠倒。见从外来即不了唯心。是起信文云。见从外来取色分齐。取相二字向上成心外取相。若就当句。设取心佛亦为取相。不了真佛无相相故。言颠倒者。颠者顶也。顶合在上向下即倒。如是合无为有。合内为外。皆名颠倒。故举空华喻。通二义思之。疏一无限因成者。此中无文。含在随乐见中。上普兴云幢主水神偈云。清净慈门刹尘数。共生如来一妙相。一一诸相莫不然。是故见者无厌足此慈一门已无量矣。况于诸门。出现宝光主海神云。不可思议大劫海。供养一切诸如来。普以功德施群生。是故端严最无比。即施门无量也。普发迅流主河神云。如来往昔为众生。修治法海无边行。即无限因也。如是等或一切因共成一相。或一切因成一切相等故云无限

疏。二应机普现者下。举三喻。别喻色形诸相

疏。后半重释等者。前半云。难可量则心行处灭。言说莫及则言语道断。今重释者。何以寂灭诸相心言罔及耶。释意云。寂灭是不和合义随乐皆见是和合义。今亦不可作合与不合。而知而说故。重释云。于中寄三身说。初约法身住体遍应释。则前无相寂灭。即是住体随乐皆见。即是遍应故。今以二义相夺。故非合不合。其住体遍应犹如虚空。随其窍隙方圆大小。二缘起修成下。约报身修成契实说。如铸金成像像全同金。亦互夺叵说。三又缘即非缘下。约化身应缘说。犹如影像有而即虚。亦二相夺不可得说。已释上句。从合相离故下。释下句可知

疏。中论云。戏论破慧眼等者。即如来品。此前更有一偈半云。如是性空中思惟不可得。如来灭度后分别于有无。青目释云。诸法实相性空故。不应于如来灭后思惟。若有若无若有无俱。如来从本已来毕竟空。何况灭后。释曰。此偈总遣三句。次偈云如来过戏论。而人生戏论。戏论破慧眼。是皆不见佛。此偈二意。一者仍前破第三。此破第四非有非无戏论谤句。即今疏文二者。总遣四句百非谓起心动念皆成戏论。非局第四故。次疏云。妄惑不生故非蕴聚起心则生便成戏论。彼青目释云。戏论名忆念取相分别此彼。言佛灭不灭等。是人为戏论。覆慧眼故。不能见如来法身

疏。决定见者下。释下半。谓决定见者。则见法身。如来法身其相云何。论云。如来所有性即是世间性。如来无有性世间亦无性。真妄无性即佛法身。如是见者。不随相转。若随相转则不自在。不随相转即决定见。见同无性能所双寂。何有有无能累其神。则不畏有无等也

疏。初知解脱。智者摽也。此偈第四句结叹

疏。总不别释。四句交络相合而释。谓初句身字。合次句外字。初句心字合次句内字。应云外身内心。平等二字是身心理。解脱二字通上身心内外。而解脱不同外身。脱业系苦相。即以解脱字上取外身。下取第四句中无所系字。内心脱执取等相。即以解脱字上取内心。下取第四句中无著二字。心无取着即为能证。契上平等名为正念。是第三句四句圆矣。从又内脱二障。更为异解。上解脱字别配身心。皆离障解脱。今释内解脱者。离障解脱。外解脱者。作用解脱。如净名有解脱名不可思议等

疏。谓即前分别之器亦无所有者。上云月之一多由器有异。佛之一多由感不同。今云心分别世间是心无所有。则分别之器亦忘也。其犹梦中见器中之月。岂唯月之不实。实亦器本自无。能现之器既无。所现之月安有。约法可思。疏此法是佛下。释下半。依此见佛则如佛见。第七节疏。今初一句所缘及一切种清净者。契经诸论皆说如来一百四十不共功德。今依瑜伽四十九说。论云。依如来住及依如来到究竟地。诸佛世尊有百四十不共佛法。谓诸如来三十二大人相。八十种随形好。四一切种清净。十力四无所畏。三念住三不护。大悲无忘失法。永害习气及一切种妙智。今经略具。初三句中。具四一切种清净言四种者。一一切种所依清净。谓烦恼粗重并诸习气。于自所依无余永灭故又于自体如自所欲取。住舍中自在而转。二一切种所缘清净。谓于种种若化若变。若所显现一切所缘。皆自在转故。三一切种心清净。谓如前说。一切心粗重永灭离故。又于心中一切种善根皆积集故。四一切种智清净。谓如前所说。一切无明品粗重永灭离故。又遍一切所知境中。知无障碍智自在转故。上四中除第二。皆有二释。今疏之中皆具四净。而文少略。取顺经耳。初如来最自在句。有二清净。所缘是第二一切种智。是第四。于所缘中无碍转。释第二所缘清净。于所知中无碍智自在转。即是第四一切智清净。彼论二释今取后释耳。此二皆是最自在义。次句所依清净者。即经超世无所依。是第一净可知。三一切种心清净者。即经具一切功德。是第三心清净。亦二释中。后释对论易知。疏五无忧喜之离染安住舍故者。即无染无所著。是三念住。谓一者一心听法不忧。二者一心听法不喜。三者常住舍心。谓有忧喜即染不住舍即着。今无染无著故具三念住

疏。六恶想都绝下。即经无想无依止。是三不护。三不护者。一恶想都绝。二不依止名闻。三不依止利养。今无想。成初一。无依止成后二

疏。九智光遍觉即一切种妙智十可知。十一即无忘失法故。常明记

疏。又此一偈即四无所畏者。谓光明遍清净偈无畏有四。一一切智无畏。二漏尽无畏。三出障道无畏。四出苦道无畏。至十藏品当释。唯十力智在第三。约法以显中。即百四十功德具矣

疏。故大般若云觉法自在性下。即文殊分中如前已引。又心绝动摇。亦是此经次后那伽室利分。那伽云龙。即龙吉祥菩萨。妙吉祥菩萨欲入城乞食。龙吉祥问云。我欲入城为有情故巡行乞食。妙吉祥云。随汝意往。然于行时勿得举足。勿得下足。勿屈勿伸。勿起于心勿兴戏论。勿生路想城邑想大小男女想。所以者何。菩提远离诸所有想。无高无下无卷无舒。心绝动摇言忘戏论。无有数量。今唯用后一对耳

疏。又瑜伽九十五有六种戏论者。一颠倒戏论。二唐捐戏论。三诤竞戏论。四于他分别胜劣戏论。五分别工巧养命戏论。六耽着世间财食戏论动摇尚无斯六岂有之

疏。次偈入佛功德等者。文有三段。初略释经文。二然一多相依下。束成四义以顺经文。三复总收之下。融成十门。疏下文云知一即多者。十住经文

疏。一孤标独立者。即前多中无一性。一亦无有多。二法互无故得独立。亦一即多而唯多。多即一而唯一。废己同他故云独立。二双现同时。即下经云知以一故众。知以众故一。无一即无多。无多即无一故。故二双现更无前后。如牛二角。三两相俱忘者。即前二俱舍也。四自在无碍者。欲一即一不坏相故。欲多即多一即多故。一既如此多亦准之。常一常多常即常离。故云自在。五去来不动者。一入多而一在多。入一而多存。若两镜相入而不动本相。相即亦然。六无力相持者。因一有多多无力而持一。因多有一一无力而持多。七彼此无知者。二互相依皆无体用故。不相知故。觉首云。诸法无作用。亦无有体性。是故彼一切各各不相知。八力用交彻者。即前一中解无量。无量中解一。九自性非有者。互为因起举体性空。十究竟离言者。不可言一不可言非一。不可言亦一亦非一不可言非一非非一。不可言相即。以相入故。不可言相入。以相即故。不可言即入。不坏相故。不可言不即不入互交彻故。口欲辩而辞丧。心将缘而虑亡。唯证方知同果海故。一多既尔。染净等法无不皆然。第八节疏。今文具三者。具上三方便也。然其十偈皆具此三。取其相显。八九两偈但有第二故。下疏云上之二偈但了差别即是方便。余之八偈即是即实之权。约其因修。总是加行方便之力。如第四偈善巧通达一切法。差别用也。正念勤修涅槃道。加行方便也。上二皆权。乐于解脱离不平等。即是称实。对上故为即实之权也。余可意得

疏。初二句有无无碍者。无即是理有即是事。次句定散无碍者。恒住禅寂定也。由契心性理也。禅不系心。不碍散地即涉事也

疏。初二句趣如法界者。二句之中唯取四字。是向实际。初句及一切智。皆回向菩提

疏。二界八地皆名为想者。以欲色二界有于五地。皆全有想。其无想天在第四禅。不摄一地全故。八地有想。其有顶天是第九地。不属于想及与无想故。令无色一界四地不全属有无。故云二界。其无色界下之三地。由是有想故。举八地而以摄之。第九节疏。初句无余修者。此有四修。一无余修以皆修故。次句有二修。一长时修。二无间修。日夜不息。即是长时精勤无怠。故无有问。难度能度勇猛修也。此偈是总。总示度相。师子吼者。名决定说。即涅槃二十七师子吼品下。说法度类略有其六。亦摄下偈文有四节。初偈即说佛性。度一阐提。阐提佛性无明所覆迷真起妄如堕大河。二有一偈无我化外。三有六偈。皆说欲苦度于波旬。波旬为主诸类皆摄故。四有一偈济度三乘。声闻法执不了性空。缘觉无悲不随六道故。悲智双流普教群生。即化菩萨

疏。五事难出。一水深即爱欲海。二即流转。三即无明。四即网覆义。兼虫执罗不得出五即大忧迫。次众生下约法。释五而四释虫执。云妄见有德结网自缠。余可知。第十节疏。初三句三达因圆者。三达即达三世。于中初句了相无量。劫言通过及未。次句了性。过去心不可得。故云无去。未未心不可得故云无未来。现在心不可得故云无住。故净名云。若过去过去心已灭。若未来未来心未至。若现在现在心无住。现在是住亦生即灭故云无住。第三句结知佛如是。知云何如是。非唯知无去等。亦知其相。又性相无碍。又一念能知为如是了

疏。兼方便等者。劝物涉有故是方便。劝生发心即是大愿。众生无边誓愿度。佛道无上誓愿成故。即修习力为智决断。言佛果朝夕者。此有二意。一明果速。匪朝即夕故。一念相应功圆旷劫。此为正意结云速成。二朝夕是海。文选云。挹朝夕之池者。无以测其浅深。谓此是佛果大海以深广故。与此相应亦得速成。于一切法都无所求。即净名经身子念座因有此耳

疏。上四义皆先义后利者。即佛地论

疏。若无说无示同佛说也。亦净名目连章经云。夫说法者。无说无示其听法者无闻无得。说约教道示约证道。无闻则不如言取。故为真闻。无得则心无所得。方真证得无闻无得。则后偈听法行中。今此说法。但无说示。亦同宝积叹佛偈云。善能分别诸法相。于第一义而不动。故言同佛也

疏。次句悟理。拣去随文者。不随文故无闻。悟理故无得

大方广佛华严经随疏演义钞卷第三十大方广佛华严经随疏演义钞卷第三十一

        唐清凉山大华严寺沙门澄观述

疏。初来意等者。疏文有二。先标。后通。谓下释。通中二。一分来意直尽第七会来。二生解因中。下唯明下三品来意。于中二意。一依古德信住合明。二又正答十信下。即疏意别明唯答十信。以第二会。初十问之中脱十信问故。今三品答之不答住也。然贤首意。始教别开信位。如梁摄论云。如须陀洹见道前四位。谓燸顶忍世第一。菩萨道前四位亦尔。谓十信十住十行十回向。又彼论及佛性论。皆云地前修四种行。谓十信修信乐大乘行。十解修般若行。十行修三昧行。十回向修大悲行。如其次第即是四位故。又为除四类障正使故。即此四位。谓初除阐提不信障。二除外道我执障。三除声闻畏苦障。四除独觉舍大悲障。又信成净德因种。解成我德因种。行成乐德因种。回向成常德因种。又仁王经寄四轮王。谓铁铜银金。以上教义。故知十信亦成位也。若终教。十信但是十住。方便自无别位。谓仁王释三贤云十信十止十坚心。十信即住故。今疏不论成位不成位。皆以三品别答信问。别一会答合有问故。已如前说。疏二释名疏文二。先得名。后虽诸下释名。前中先总释。后然问有二下别释。于中三一。约论通。二分宾主。三约法理。今初问即是难。明即是答。今对彼难问故答称明。此明局在答者。而有二义。一显理为明。此明属自。二明亦已下。破闇为明。此约答他。令他明故。疏又长行下。第二约宾主问。唯属问明通问答。言使答者亡言者。如缘起甚深中问云。心性是一何以种种。若云缘令种种。何以复不相知逆遮其救使其亡言。言使答者易释者。谓问意言。既是一性何以种种。欲言种种复不相知故。答意云。由不相知能成种种。种种无性即不相知故不乖一性。即答者易释也。疏又明即法明下。第三约法理释。亦是约教义说。谓问即是教。释有往复。故明即法。明是义所摄。谓十甚深为十种法明。就此法明。又约心境。法即是境。明即是心。以智慧明照二谛法。故云法明。第四释文。疏前中以十菩萨各主一门下。疏文有三。初约十甚深。次示别理。后正释文。前中二。先列十名。然此十甚深。即迁禅师所立。今古同遵。后此十甚深下。明次第。言缘起深理总该诸法者。若染若净。染净交彻无不摄。故摄论中云。菩萨初学应先观诸法如实因缘。以成正信及正解故

疏。又此十种下。第二示别理。于中有二。一配十信。二配信德。前中亦二。先正配释。然十信心。谓一信。二进。三念。四定。五慧。六不退。七戒。八护法。九愿。十回向。配文可知。后以是圆融下。通妨难。谓有难云。信进等相释处易知。今十甚深文义兼广。何得而是十信等耶。故为此答。疏又亦摄十信之德者。信有十德。一亲近善友。二供养诸佛。三修习善根。四志求胜法。五心常柔和。六遭苦能忍。七慈悲深厚。八身心平等。九爱乐大乘。十求佛智慧。配十甚深者。一则正教甚深。近佛善友闻教法故。二即福田甚深。三即业果甚深。四即缘起甚深五即正行。六即助道。七即教化。八即一道。九即说法。十即佛境。通说佛智为所信故。既有多含故文义兼广。疏且为十甚深下。第三释文。疏妙慧通于众行者。文殊为妙慧。九首为众行。各主一门故。而问为能成。答为所成。故妙慧众行互为能所。疏。此二不二。成信中之观解者。融上二也。谓行与法不二。了法成行。行契法故。又衍法师云。一人问多。表一中解无量故。多人问一。表无量中解一故。又文殊是主。余九是伴故。文殊是总。余九是别。不是全要故略不出

疏。二显深理者

疏。文分二。先正明令始涉者便悟心性超乎大方。故云始终皆实。故起信论云下。第二引证。于中四。初至应说。是论初标文。二从所言法者谓众生心即立义分。又论云。次说立义分。摩诃衍者总说有二种。一者法。二者义。所言法者谓众生心。是心即摄一切世间法。出世间法。依于此心。显示摩诃衍义。何以故。是心真如相。即是摩诃衍体故。是心生灭因缘相。能示摩诃衍自体相用故。释曰。法通轨持。亦能显下义。故称为法。该于染净大位在因。故言谓众生心。为染净依。故摄世出世。何以故下。出摄所以。以有三大故。三大即义大位在果。今取通为缘起之本。故但引法以证真心随缘。三从依一心法有真如门及生灭门即义引解释分显示正义中文。以释前法。论云。显示正义者。依一心法有二种门。一者心真如门。二者心生灭门。是二种门皆各总摄一切法尽。是义云何。以是二门不相离故。心真如门者。即是一法界大总相法门体。所谓心性不生不灭等。次下释心生灭云。心生灭者。依如来藏有生灭心。所谓不生不灭与生灭。和合非一非异名阿赖耶识等。广如彼释。今以真如证心性一。随缘生灭而成种种。为此深理故。四从彼论依此生净信故。即结示为实。马鸣依此造论。令物生信何不信耶。疏二述问意。于中三。初正释前难二设彼救下释。业不知下。经文先出伏难。后为遮此救下。举经通释。三既离真性各无自立下。结成本难。于中二。先出所以。后方正结。今初。言各无自立者。起信云。若得无念者。则知心相生住异灭。以无念等故。而实无有始觉之异。以四相俱时而有皆无自立。本来平等同一觉故

疏。心性既一下。二正结。先以本难末。后事法既多下。以末难本。故初结云本末相违。此结有四。一本末相违约能所生。二事理直语体性。三一异唯语其相。然一有事有理。今是理一。四真妄唯语其体。然真亦通事。如佛真智等。今亦约理为真。以含义不同。故有四结。大同小异

疏。三拣定所问者。意云。此是假名法相师问。欲显法性义。非是法性师问。显法相义。故云拣定。于中三。一正拣。二遮救。三结成

疏。亦不可言下。二遮救也。即法相师救。此法性师难法相义。心性是一者。八识心王同是心故名为性一。破云生于种种即眼耳鼻舌等故非相违。亦非第八下。遮其转救。救云。若八识非一。第八赖耶此是一义故。今破云。汝第八正是一所熏心体。含多种子熏一成种种。亦非相违。心性之言下。以理正折第八。但是心相生灭非唯识性。答中既云法性示生。不言第八。无生示生明是真如随缘义耳

疏。文殊下。三结成也

疏。四会相违者。此门蹑前而起。谓若依上如来藏随缘成立。则违瑜伽等文。故今会之。先叙所违。玄谈已释后答。瑜伽等下。后为会通。于中亦二。先会法相宗意。后楞伽密严下。申法性宗意。于中三。初正释。二引证。三结成。疏故密严下。第二引证。总引二经三论以成此义。初引密严自有二文。俱是第三卷阿赖耶微密品末两颂。相续中间有释。故着又言。此前更有一偈云。如来清净藏亦名无垢智。常住始终离四句言说。次即云佛说如来藏等。彼疏释云。上半定赖耶体。谓是如来藏与妄染合。名阿赖耶。更无别体。此是实教所说故引佛说。下半明会权教。谓彼守权教者。不能了如来藏作赖耶者。当知彼是恶慧之人。此是诃守权之人令归实说。次颂即如来清净藏等。彼疏释云。此颂释成前义上半法说。牒举二位下。约喻释成。谓如以金作于指环。环相虚无金体露现。故云无差别。如来藏作赖耶。赖耶相虚藏性理现。故云即是也。亦可众生迷故成阿赖耶。如来悟故成如来藏。体无有二故云无差

疏。楞伽中真识现识如泥团等者。若具彼文亦复如是下云。大慧若泥团微尘异者非彼所成。而实彼成是故不异。若不异者。泥团微尘应无差别。如是转识藏识真相。若异者藏识非因。若不异者。转识灭藏识亦应灭。而自真相实不可灭。是故非自真相灭。但业相灭耳。贤首解云。此中真相是如来藏。转识是七识。藏识是梨耶。此解甚当。但喻有二法。谓泥团微尘。而合有三意少难见。此即第一经初先明识三相。次明三识。初云诸识有三种相。谓转相业相真相。释曰。此三种相通于八识。谓起心名转。八俱起故。皆有生灭故名转相。动则是业。如三细中初业相故。八识皆动尽名业相。八之真性尽名真相。是故经云诸识有三种相。则知三相通八识矣。次经辨三识云。大慧略说有三种识。广说有八种相。何等为三。谓真识现识分别事识。释曰。约不与妄合如来藏心为真识。现即第八。故下经云。譬如明镜现众色像。现识处现亦复如是明是第八。余七皆名分别事识。是则三识别为三类。现唯第八。分别唯前七。真相约佛是八出缠。约凡在第八中亦兼在余七。然泥团经文。含前二段。意明三识。而参三相之名。转识即转相之名。意是分别事识故。唯识中名七转识。藏识即是现识。此则可知真相即是真识。上二取识类别故牒识名。真相但取通八识之真。故牒相名。上经文言若异者藏识非因者。谓三若异藏识。即应不同真相及转识为因。既以转识熏故。真识随缘而成藏识则知不异。非以藏识为二识因思之。故下重案定云非自真相灭但业相灭。斯则三事备矣。谓喻中有三。一尘。二水。三泥。以水和尘泥团方立。以业熏真相。藏识便生业。以合水但水灭而尘在故。业亡而真存。经云若自真相灭者藏识则灭者。反显藏识以真妄和合而成。但其妄灭而真体不无。故下以水喻如来藏。波喻七识。合成动。海即为藏识。但波相灭。湿性不坏即斯义也。不异之义易知。言皆此义者。皆是如来藏随缘成识义也。然云自真相者。十卷但云自相。晓公释云。本觉之心不藉妄缘。性自神解名自真相。约不一义说。又随无明风作生灭时。神解之性与本不异。亦名自真相。是依不异义说。疏又彼经云。如来藏识。为无始恶习所熏。名为识藏者。上辨与七和合为藏识。今明无始无明为因。故论下文中无明为因生三细。境界为缘生六粗。此中正取无明为因生于三细。三细既属赖耶。已成识藏。即第四经文具云。大慧如来藏是善不善因。能遍兴造一切趣生。譬如伎儿变现诸趣。离我我所。不觉彼故三缘和合方便而生。外道不觉。计著作者。为无始虚伪恶习所熏名为识藏。生无明住地与七识俱。如海浪生常生不断。离无常生过。离于我论等。疏又入楞伽云下。前引楞伽与七识俱。次引楞伽为恶习熏。今则双具故复引之。大意无异。言而与无明七识共俱者。与无明俱即前第二意。与七识俱即第一意。疏又起信论云下。引于三论。初直引起信。后双引二论。今初。即二门之中生灭门初。具云心生灭者依如来藏故有生灭心。所谓不生不灭与生灭和合。非一非异名阿赖耶识。释曰。初二句标。所谓不生灭下。辩相。不生灭者。是如来藏自性清净心。因无明风动。举体随缘作生灭心。不相舍离故云和合。非谓别有生灭来与真合。此心所以生灭者。因无明生。此生灭心原从本觉而起。故有二义而无二体。故下论云。如大海水因风波动。水相风相不相舍离。乃至广说。此中动是风相。湿是水相。以水举体动故。水不离于风相。无动而非湿故。动不离于水相。心亦如是。不生灭心举体动故心不离生灭相。生灭之相无非真故。生灭不离于心相。如是名为和合。此是不生灭心与生灭合。以是随缘门故。非是生灭与不生灭合。以此不是向本真如门故。言非一非异者。真如全体动故心与生灭非异。而恒不变真性故与生灭不一。此约三细以为生灭。则第八中已含动静。若楞伽经云。七识染法为生灭。以如来藏净法。为不生灭。以此二和合为阿赖耶识。以和合故非一非异者。就粗显说。然非一非异义广如十忍品如幻忍明。又如来藏名初品已释。言不生灭等者。旦公云。性该始终体非起尽。体遍迷悟性非解惑。故云不生不灭。若不觉知能令生死不断名生。始觉能灭生死故名为灭

疏。又如达磨经颂下。双引二论。于中二。先举经偈。而云达磨经颂者。摄论第二释所知依中云。此中最初且说所知依即阿赖耶。世尊何处说阿赖耶识名阿赖耶。谓薄伽梵于阿毗达磨大乘经中说。释曰此乃通指大乘经为对法经耳。文中但举上半。下半云。由此有诸趣及涅槃证得

疏。摄论等下。第二引二论释。初即法相宗论等者。等取瑜伽杂集等。彼论释云。无始者初际无故。界者因义即种子也。是识因种。谓一切法此唯杂染非是清净。彼一切法等所依者。能任持故非因性义。所依能依性各异故。若不尔者。界声已了无假依言。故第三论云。此中闻熏习为是阿赖耶识自性。为非阿赖耶识自性。下论答云。此闻熏习随在一种所依转处。寄在异熟识中与彼和合俱转。犹如水乳。然非阿赖耶自性是彼赖耶。对治无分别智种子性故。下二句易了。明知赖耶但是生灭非真性成

疏。宝性论翻下。即法性宗论。疏中一句但是义。引彼论具足云。无始时来性。作诸法依止。依性有诸道及证涅槃果。即第四论。彼论释云。此偈明何义。无始时来性者。如经说言。诸佛如来依如来藏。说诸众生无始本际不可得知故。所言性者。如圣者胜鬘经言。世尊。如来说如来藏者。是法界藏。出世间法身藏。出世间上上藏。自性清净法身藏。自性清净如来藏故。作诸法依止者。如圣者胜鬘经言。是故如来藏。是依。是持。是住持。是建立等。次论云依性有诸道者。如圣者胜鬘经言。世尊生死者。依如来藏。世尊。有如来藏故说生死。是名善说故。及证涅槃果者。如圣者胜鬘经言。世尊。依如来藏故有生死。依如来藏故证涅槃。世尊。若无如来藏者。不得厌苦乐求涅槃。不欲涅槃不愿涅槃故。此明何义。明如来藏究竟如来法身不差别。真如体相毕竟云佛性体。于一切时。一切众生身中。皆无余尽应知。疏以此等文下。第三双结二宗。于中先正结。以上诸教皆如来藏为识体故。知心体性即如来藏。此外无法故为深也。又唯识下。引唯识文结同法性。故论云。此诸法胜义。亦即是真如。常如其性故。即唯识实性。释曰。既用真如为识实性。明知天亲亦用如来藏而成识体。但后释论之人。唯立不变。故云过归后辈。况世亲造佛性论。广用胜鬘疏。又妄心之性等者。此下一对成上二义。然有二意。一如次成上。谓妄心之性成心之性。以性相不同故。真心之性成上即性。真心即性故。二者通成。谓此之二性别名二藏。前之二性皆具二藏。但为妄覆名如来藏。直语藏体。即自性心故。此自性清净真心。不与妄合名为空藏。具恒沙德名不空藏。前明即离。此明空有故重出也。言皆平等无二者。上二即离不同。由心之性故不即。由心即性故不离。不即不离为心之性。后二即空之实为不空。即实之空为空藏。空有不二为心之性。然空有无二之性。即是不即不离之性。故但云一也

疏。五趣诸根总别报殊者。如持五戒招得人身。是总报业由于因中有嗔忍等。于人总报而有妍蚩。名别报业。唯识亦名为引满业能招第八。引异熟果。故名引业。能招第六满异熟果。名为满业。俱舍亦云。一业引一生。多业能圆满。犹如缋像。先图形状。后填众彩等。然其引业能造之思。要是第六意识所起。若其满业能造之思从五识起

疏。展转异同成多差别者。都有六十二句。谓初对是善恶为二。第二对开二成四。兼前二成六。第三对。开四成八。配前六成十四。第四对开八成十六。兼前十四成三十。第五对开十六成三十二。配前三十成六十二。此约以后添前故成六十二。克实而言但有三十二。以后开前前更无体故。如开善恶趣。各成满缺。但有其四耳。谓一善趣根满。二善趣根缺。三恶趣根满。四恶趣根缺。此四之外更无有别善恶趣故。又但若二二开之唯成三十二。若更展其四生则复成多句。谓第三对先以四生乘上四句。四四成十六句。更有胜劣乘十六。已有三十二。配六已成三十八。后后开之句数更多。第四对开成六十四。第五对开成一百二十八。若从初善恶开为六趣。则句数更多。并可思准。故云后后必带前前。展转异同成多差别。疏第三结成前。于中文二。先总显文意。后已知大意下。释文。今初。准下。诸菩萨问。皆有三段。其第三段多是直结故。次释文中

疏。一约本识者。业是心所故依于心。心是第八为根本依。从离所无能下。释不相知义。以相待门释。言离所无能者。既无所依心王。亦无能依之业。今依心有业。业从缘生故。无自性不能知心。离能无所者。离能依业则心非所依。今由业成所依。所依无性故不能知业。以各下结。谓各从缘成性。空无体相。依无力故云无用。觉首亦云无体用故。故不相知

疏。二约第六识。业是所造。心是能造者。即以第六识名心。从于积集。通相说故。谓第六识人执无明。迷真实义异熟理故。以善不善相应思造罪等三行。熏阿赖耶。能感五趣爱非爱等种种报相。但云六者。谓五识无执不能发润故。非迷理无推度故不能造业。虽造满业亦非自能。但由意引方能作故。后并皆速灭者下。明不相知。通相而言皆约无体用故。别相而言。用门不同。此用二门。一无常门故。言并皆速灭。净名弟子品云。优波离。一切法生灭不住。如幻如电。诸法不相待。乃至一念不住。诸法皆妄见故。心业皆空。下经云。众报随业生。如梦不真实。念念常灭坏。如前后亦尔。故由无常不能相知。从起时不言我起下。即无我门。约法无我明不相知。故净名问疾品云。又此病所起皆由着我。是故于我不应生着。既知病本。即除我想及众生想。当起法想。应作是念。但以众法合成此身起。唯法起。灭唯法灭。释曰。上以法遣我。次经云。又此法者各不相知。起时不言我起。灭时不言我灭。释曰。此总显我空明不相知。次经云。彼有疾菩萨为灭法想。当作是念。此法想者亦是颠倒。颠倒者。即是大患我。应离之。云何为离。谓离我我所。云何离我我所。谓离二法。云何离二法。谓不念内外诸法行于平等。云何平等。谓我等涅槃等。所以者何。我及涅槃此二皆空。以何为空。但以名字故空。如此二法无决定性。释曰。此破法显空。今但取我法不相知义。故略用二句。次下经云。得是平等无有余病。唯有空病。空病亦空。释曰。此以空空破空非今所要。因便引来成一段义毕耳

疏。第二对约得报果时难能所受等者。此释受不知报报不知受。受是能受之因。报是所受之报。此上总明。从谓受是报因下。别释。言即名言种者。唯识第八云。复次。生死相续由诸习气。然诸习气总有三种。一名言习气。二我执习气。三有支习气。名言习气者。谓有为法各别亲种。名言有二。一表义名言。即能诠义音声差别。二显境名言。即能了境心心所法。随二名言所熏成种。作有为法各别因缘。释曰。言各别亲种者。三性种异故。能诠义音声者。拣无诠声彼非名故。名是声上屈曲唯无记性。不能熏成色心等种。然因名起种。名名言种。二显境名言。即七识见分等心。非相分心。相分心者。不能显境故。此见分等实非名言。如言说名显所诠义。此心心所法能显所了境。如似彼名能诠义故。随二名言皆熏成种。二我执习气。三有支习气。并如六地。有支即是今文为业所引。能引之业故。唯识云。三有支习气。谓招三界异熟业种。有支有二。一有漏善。即是能招可爱果业。二诸不善。即是能招非爱果业。随二有支所熏成种。令异熟果善恶趣别故。论颂云。由诸业习气二取习气俱。前异熟既尽。复生余异熟。此能引业即诸业习气。此名言种即二取习气。言为业所引者即彼俱义。亲办果体即由名言。若无业种不招苦乐。如种无田终不生芽。故此名言由业引起。方受当来异熟之果苦乐之报。故六地云。业为田识为种也

疏。离报无受下。释不相知亦约相待空故

疏。三约名言因就能所依难等者。标也。即将第二对中能受名言之因。对第一对中所依本识。前以业依识难。今以种依现行难。从谓前能受报因下。释不相知义。但释受不知心。不解心不知受。故结云余义同前。若具应云所依心体。若离能依亦无所依。无所依故不能相知。疏四约因缘等者。取前第二对中所引名言及能引业。相对以明。于中初标也。次所谓下出体。后相待相夺下。释不相知。言相待者。业无识种不亲办体。识无业种不招苦乐。既互相待则各无自性。言相夺者。以业夺因。唯由业招故。因如虚空。以因夺缘则唯心为体。故业如虚空。互夺独立亦不能相知。互夺两亡无可相知。次言如不自生等者。引例以释。以缘夺因故不自生。以因夺缘故不他生。因缘合辨相待无性故不共生。互夺双亡无因岂生。以此不生类于不知居然易了。即以因为自以缘为他。合此为共离此为无因。互有尚不相知。互无岂能相知

疏。五约境智相对相见虚无难者。相即相分。见即见分。诸心心所略有二分。广说有四。如下当辨。从谓境是心变下。明不相知义。于中先约唯识能所变释。后以无境外下。约于当经互融以说。故下经云。无有智外如为智所入。亦无如外智能证于如无有少法与法同住。以举心摄境则无心外之境。举境摄心则无境外之心。以性无二相即性故。相随性融随一皆摄。上约真心。后心境虚妄。下约其妄心。真则互融。妄俱无体故。下答中云能缘所缘力种种法出生。速灭不暂停念念悉如是。即显妄无性故不相知也。然上五对初及第四唯约因中。第二一对因果对辨。第三一对心含因果。第五一对义通因果。修因二取即名言等故。唯识论释二取中。总有四义。一者相见。二者名色。三者王所。四者本末。末即六识异熟。本即第八异熟。四种二取皆能熏发。亲能生彼本识上功能。名二取习气。所变心境即通因果也。又能变之心是因。所变之境是果。心托境生。俱通因果

疏。第二别观者。上云通观。五对之中一一通前善恶趣等五对本难。今即以斯五对。别对前五而前后钩锁。但有四重细寻可见

疏。以初二对结趣善恶者标也。次云趣善恶者。正由业熏是第一对。业不知心心不知业此对为因。次云受总报故即第二对。受不知报报不知受。初。对为因受第二对报。总报即是趣善恶故。疏二复以第二及第三对结受生同异者。钩取前二对中第二对。即重明受不知报报不知受。受即名言种故云初对。以名言种对所生处。谓亦由识种往所生处故。初地云。于三界田中复生苦芽。次对以名言种对能依本识者。即心不知受受不知心。受即名言种。心即能依本识者。依名言种招现行识故。识为能依则此心言通因及果。上约因中本识故为所依。今约果中故为能依。疏三复以第三及第四对。结苦乐不同及端正丑陋者。即通以此二对。双结前二对。言初对观现受时者。即心不知受受不知心对。谓亦由受因受苦乐体及妍媸故。若无识种本识。此二亦无所依。次对观苦乐因及彼妍媸。皆由缘令异者。即因不知缘缘不知因。谓损益下。别示二对之相。由损他业感于苦报。由益他业感于乐报。以嗔恚业感于丑陋。由忍辱业感于端正。此中言因詺缘为因。此中言果是别报果。疏四复以第四及第五对。结诸根满缺者。此上总明。从亦由满业下。别说其相。满业即第四对。因不知缘缘不知因。缘即是业。唯取满业。由损他眼耳成盲聋等。由益他六根等成六处满足。次云又由内根有满缺故。于分别位了境不同者。即第五对。智不知境境不知智。谓智于境有信进念定慧之满足。则受果中亦具五根明利胜上。若智于境信等随阙。或非深厚则得果时五根随缺。或成下品。疏并皆无性下。上别释中。但出能对所对二种法体。今则总明不相知义。在文易了。意云并各相依从缘无性。何有能所熏等而能相知。既不相知。谁令种种。此但约第一直问意结。亦应带疑云。为是种种为是一性。结成难云。一性随于种种则失真谛。种种随于一性则失俗谛。一性即不相知。亦应结云种种随不相知则失俗谛。不相知随于种种则失真谛等。第二觉首答。疏今初。意云。特由从缘种种故不相知下。疏文有三。初总显偈意。二即此偈上半下别示义理。三言诸法下。委释经文。二中亦三。初以因明立量示。二以缘起相由示。三结示缘起深旨。今初。悬指后四。以为同喻。则此偈中但有宗因可知

疏。若以缘起相由门下释者。第二缘起相由示。然缘起相由。具力无力。及有体无体。今显不相知理。但明无力无体。又因中亦有无体义。今取义便。因缘相假但明无力。谓因假缘故因无力。缘假因。故缘无力。果上亦有无力义。今取义显。但明无体。谓全揽因成缘成无性。故云含虚无体。下四喻中皆有无体用义。故指下明

疏。是故虚妄缘起下。第三结示缘起深旨。然此正结缘起相由明。兼结上因明立量。以立量中亦说不相知为宗故。即三义中初义。言现文但有初后二意者。全取一偈即是初。意唯取不相知言。即是后意其第二意。至后五偈答本难。中方用斯义。疏言诸法者下。第三委释经文。言果从因生等者。上取义便。但因无力说果无体。今欲尽理故具举之。则上句诸法通于因果。于中先以因缘门。明因果俱无体。从因无性故何有感果之用。下以上无体释成因果无用。体尚不立用安得存。从又互相待下。以相待门明无体用。先明因果无用故云无力。后以他为自。下明因果无体。既全揽他故无自体。疏今初喻中下。疏文有四。一释喻。二释法。三对问会通。四傍显水义。初中三重。即为三别。初唯流中文有六段。一标章。二别示不相知相。三结示正理。四引他证成。五别释前后二字。六简定不相知理。今初可知。然此偈文晋经。云譬如驶水流水流无绝已。二俱不相知。诸法亦如是。今文小异。义旨无违

疏。然此流注下。第二别示不相知相。谓欲显不相知理。故寄前后流异。成其十门。若不说前后之流。将何不相知耶。一河之水不出前后。则千里九曲皆悉无性不相知矣。然虽十义本唯二流。成两重能所。前流望引为能。望排为所。后流望排为能。望引为所。以斯四义相参成十。初及第三以为所故无性无知。二四两门约不相到。五六二门约无二体。以后流是能排即所引故。前流是所排即能引故。七八约缘成故无二。谓七中能排是后。所排是前。言亦无二者。要有所排方有能排。此二相成故亦无二。八约能引亦然。九十约不俱故无知者。然其能排是后。能引是前。而言不得俱者。后为能排。前须为所排。不得即此名为能引。义门别故名为不俱。第十句例此。前流为所排时。后流须为能排。不得为所引故云不俱

疏。是则前后下。第三结示正理

疏。肇公下。第四引他证成。则物不迁论。然其相连总有四句。论云。既无往返之微眹有何物而可动乎。然则旋岚偃岳而常静。江河竞注而不流。野马飘鼓而不动。日月历天而不周。复何怪哉。今四喻中但用水风彼无火地

疏。然上云前后下。第五别释前后二字。一生灭前后者。此即竖说。如壮与老。谓此流水刹那生。前刹那灭后刹那生。二此彼前后者。犹如二人同行狭径。后人排前前人引后。此即横说。分分之水皆有前后。乃至毫滴亦有前毫后毫。故聚众多皆成流注则无性矣

疏。小乘亦说下。第六拣定不相知理。文中二。先举小乘。后而不知下。举大异小。小乘即俱舍论业品中。释身表许别形。非行动为体。以诸有为法有刹那尽故。论文初句论主标有宗义。下三句破正量部。以正量部谓以动身为身表体。故论破之。然正量部心心所法则有刹那。此之动色无有刹那。今论主明诸有为法皆有刹那。何以知有后有尽故。既后有尽知前有灭。故论云。若此处生即此处灭。无容从此转至余方。释曰。此生此灭不至余方同不迁义。而有法体是生是灭故非大乘。大乘之法。缘生无性。生即不生。灭即不灭。故迁即不迁。则其理悬隔。然肇公论则含二意。显文所明多同前义。故云。伤夫人情之惑久矣。目对真而莫觉。既知往物而不来。而谓今物而可往。往物既不来。今物何所往。何则求向物于向。于向未尝无。责向物于今。于今未尝有。于今未尝有。以明物不来。于向未尝无。故知物不去。覆而求今。今亦不往。是谓昔物自在昔。不从今以至昔。今物自在今。不从昔以至今。故仲尼曰。回也。见新交臂非故。如此则物不相往来明矣。既无往返之微眹。有何物而可动乎。即云然则旋岚等。下文又云。若古不至今。今亦不至古。事各性住于一世。有何物而可去来。释曰。观肇公意既以物各性住而为不迁。则滥小乘无容从此转至余方。下论云。故谈真有不迁之称。导物有流动之说。此则以真谛为不迁。而不显真谛之相。若但用于物各性住为真谛相。宁非性空无可迁也。不真空义。方显性空义。约俗谛为不迁耳

疏。二法中下。第二释法。文中三。初总。次初中下别。后正由此义下结。妄法有即非有。是初义。隐即非隐。是第二义。以正为事隐之时。而有所依故。以非隐为隐即第三义。理常现故

疏。此上三意下。第三对问会通。言思之者以易见故。若具说者。第一妄法有而非有。答前直问既有种种。何缘不相知。谓种种是妄。有体即非有故不相知。二答怀疑为是种种为不相知。故今答云能依妄法依所依真。妄常种种。真常无知故。三答结成难者。即妄即真故。种种不乖不相知也

疏。何故以水喻真心下。第四傍显水义可知

疏。第二依火中者。下之三喻文势稍略。随其三义便以法合。今初。唯焰喻中二义。一明后不知前。二明前不知后。二妄法亦尔下。法合于中先总。后谓已灭下别。然法喻俱用生灭门释。而有小异。喻中用前念灭后念生释。今法。合中亦用前灭后生。正合前焰后焰兼三时门。今初已灭者。前念也。未生者。后念也。故此二念一向无物。生已则灭者。前后二念皆即生即灭。并皆缘生故言无体。体无实故。言兼三时门者。谓一念之上即有三时。已灭为已生。未生为未生。生已即灭是生时。故净名云。若过去生过去生已灭。若未来生未来生未至。若现在生现在生无住。经云。比丘汝今即时亦生亦老亦灭。故三时无体无可相知也

疏。斯则流金烁石而不热者。即庄子中意说。于至人大水稽天而不溺。大旱金石流火山燋而不热。然其本意。非是水不能溺火不能烧。意云。乘时处顺不以水火而为患也。亦不横为其所烧溺也。正同今意烧而不烧。但彼约顺时。此约无性。理悬隔矣

疏。二依所依者。亦先喻。后合。然与水喻释有影略。水喻以水为所依。今以焰无体用而为所依。若例前流依于水者。应以火为所依。火是热性身所触故。焰是色动有形显故。若依此释应云前焰后焰皆依于火。以无性故无相知。是则依水依火。明二空所显不空真理以为所依。若无体用为所依者。则显依他无性即是圆成。二空真理以为所依。显义无方故有影略。下唯所依亦准斯释。又若例后风喻。风依物动。则火依薪有。薪为可然。火是能然。故以然因可然。则然无体。可然因然。则可然无体。则以无性可然而为所依

疏。是则无妄法之有下。结上三义也。然有无有二。一定性有无。二真空妙有。今无妄法之有。则无定性之有。则非断无矣。有妄法之无是真空之无。便为妙有。是故若举妄取真则妄有真空。如三论说。若真妄对辨则妄空真有。如涅槃明。遂令缘起之相下。覆成上义。上句成无妄法之有。下句成有妄法之无。相无不尽是初门。理无不现是第三门。合上二句为第二门

疏。上三义中。下第三对问会通。唯焰无性故不相知。答直问也。能依种种所依无二。答怀疑也。即事同真故不相违。答设难也。在义易了故云准知。若贤首意。问者据其初义。答者用其后二亦是一理。是则初义。两家共用下当重明

疏。第三依风有动作喻。有标释结而无对问。即以水树等而为所依。余大同前。但云斯则旋岚偃岳而常静者。即肇公言。亦云随岚。皆梵音轻重。即兴云之风北方风也。亦是坏劫时风。是故妄法下结。文有两对。具上三门。妄法全尽而不灭者。单取妄法全尽是初门。将上而不灭对下真性全隐为第二门。以不灭为能依。全隐为所依故。下句中而恒露现即第三门

疏。第四依地有任持者。有标释结。二中三义。初义立名与前小异。前云一唯流唯焰唯动。今初云地界因依。即喻势小异。言一约自类者。犹如累墼。余并可知。言斯则厚载万物而不仁者。不恃仁德也。老子云。天地不仁以万物为刍狗。经云。譬如大地荷四重任。而无疲厌也。次肇公下。亦不迁论。末总结云。然则乾坤倒覆无谓不静。洪流滔天无谓其动。苟能契神于即物。斯不远而可知矣。坤即是地故得引之

疏。二约异类者。即出现品四轮相依喻。然其合文与此不同。今但借其四轮用耳

疏。余义同前者。第三总结例也。然余义有二。一者结前三门应云一。妄无不尽是初门。理无不现是第三。合二为第二。二三合在第三。唯所依中故。故云余义。二者对上三问以为余义

疏。第二别对诸不相知等者。上之四喻通喻五对不相知义。今则别对。言及别通前难者。即往善趣等五对难也

疏。初水流喻前二对者。即业不知心。心不知业。受不知报。报不知受。答趣善恶者。上云心性是一。云何见往善趣恶趣。答云善趣恶趣。即是总报。由业熏心受所受报。如水漂流。言流转体者。体即赖耶。故唯识云。恒转如瀑流。释论云。如瀑流水非断非常。相续长时有所漂溺。此识亦尔。从无始来。刹那刹那果生因灭。果生故非断。因灭故非常。漂溺有情令不出离。亦如起信云。如大海水因风波动。楞伽云。藏识海常住境界风所动等。二地经云。一切众生为大瀑水波浪所没等。其文非一

疏。二大火喻。第二三对者。此亦钩锁。第二对前已用竟。今复喻之。谓受不知报。报不知受。及心不知受。受不知心。答前诸根受生者。答前二难。由前问云心性是一何以见有诸根满缺及受生同异故。今答云。诸根满缺受生同异皆由识种。受所受报亦依于心。如火依薪

疏。此以长风等者。唯喻一对。谓因不知缘。缘不知因。答前好丑者。谓前问云心性是一云何见有端正丑陋。故今答云。今所受报有妍媸者。皆由业缘异令报好丑。如风东西令物偃仰。相各不同

疏。答苦乐者。喻不相知则同于风。答前苦乐则不同风。谓上问言心性是一云何见有受苦受乐。故今答云善因乐果。恶业苦报。苦乐多种。如地轻重。言又喻前境智者。前以风地二喻。同喻因缘一不相知。今一地喻喻二不相知。答前诸根者。以诸根有二义。一约眼等诸根。则火喻已答二信等诸根。今地喻已答地虽是一随种生芽。心性虽一随根成异故。故信进等各各不同。第二五偈答前设难

疏。今初。前问有三下。即先明大意。于中二。第一总彰偈意。第二通明缘起之义。前中疏然此四因下。上别明。此下融会。言诸宗者。上四因中。初一通性相二宗。二即法相宗。三即无相宗。四即法性宗。据其实义。四因不缺。方成缘起甚深之趣。随情执见则乖圣旨。如盲摸象不全见象然不离象。盲不识乳则一向夺之。今盲摸象则乃是分夺。取其不离并顺圣教。此喻即涅槃第三十二。南经三十。答师子吼。众生若有佛性。不须修道自得菩提。答意云。众生有者定当得故。后举此喻云。善男子。譬如有王告一大臣。汝牵一象以示众盲。尔时大臣受王敕已。多集众盲以象示之。时彼众盲各以手触。大臣即还而白王言。臣已示竟。尔时大王即呼众盲各各问言。汝见象耶。众盲各言。我已得见。王言象为何类。其触牙者即言。象形如芦菔根。其触耳者言。象如箕。其触头者言。象如石。其触鼻者言。象如杵。其触脚者言。象如木臼。其触脊者言。象如床其触腹者言。象如瓮。其触尾者言。象如蛇。善男子。彼众盲不说象体。亦非不说。若是众相悉非象者。离是之外更无有象。善男子。王喻如来正遍知也。臣喻方等大涅槃经。象喻佛性。盲喻一切无明众生。是诸众生闻佛说已。或作是言。色是佛性等。释曰。彼经喻意。明一切众生虽有佛性见不明了互执不同。然非全离。所执之法皆佛性故。而非全见。今借此喻以况圣教深旨。总喻于象。诸宗异见如盲所触。并合圣理故云不离。然非圆了故云非是说象。故胁尊者云。依之修行无不获益。言受一非余斯为偏见者。言象如箕不信如臼。斯为大迷。但信诸识不信无性。真如随缘故为偏见。离世间品云。受一非余魔所摄持

大方广佛华严经随疏演义钞卷第三十一大方广佛华严经随疏演义钞卷第三十二

        唐清凉山大华严寺沙门澄观述

疏。由无方有下。上辩不相乖。今明相成。然事理相望略有三义。一相违义。二不相碍义。三相作义。今用后二。其第一义是问家所用

疏。是以缘起之法下。第二通明缘起之义。于中四。一总明。二开义。三融合。四别释性义。初中二。先立义配经。后是以无性缘生故空下。会归中道。今初。就四义中二义是空有之义。谓缘生故有是有义。无性故空是空义。二义是空有所以。谓无性故有是有所以。缘生故空是空所以。所以即是因缘。谓何以无性得成空义。释云。由从缘生所以无性。是故缘生无性是空之所以也。何以缘生得为有义。释云。特由无定性故方始从缘而成幻有。是故无性是有所以。故中论四谛品云。若人不知空。不知空因缘及不知空义。是故自生恼。如不善咒术。不善捉毒蛇。若将四句总望空有则皆名所以。故云缘生故名有。缘生故名空。无性故名有。无性故名空。良以诸法起必从缘。从缘有故必无自性。由无性故所以从缘。缘有性无更无二法。而约幻有万类差殊故名俗谛。无性一味故名真谛。又所以四句唯第三句引证成者。无性故有。理难显故。若具证者。一缘生故有者。法华云。但以因缘有。从颠倒生故说。净名云。以因缘故诸法生。中论云。未曾有一法不从因缘生等。皆因缘故有义也。二缘生故空者。经云。因缘所生无有生。论云。若法从缘生是则无自性。若无自性者。云何有是法。三中。言以有空义故一切法得成者。亦四谛品文。由前诸品以空遣有。小乘便为菩萨立过云。若一切法空无生无灭者。如是则无有四圣谛之法。菩萨反答云。若一切不空无生无灭者。如是则无有四圣谛之法。谓小乘以空故无四谛。菩萨以不空故则无四谛。若有空义四谛方成故。有偈云。以有空义故。一切法得成。若无空义者。一切则不成。即无性故有也

疏。经云从无住本立一切法者。前已引竟。今当重引。即净名第二。推善不善之本。故经云。善不善孰为本。答曰。身为本。又问身孰为本。答曰。欲贪为本。又问欲贪孰为本。答曰。虚妄分别为本。又问虚妄分别孰为本。答曰。颠倒想为本。又问颠倒想孰为本。答曰。无住为本。又问无住孰为本。答曰。无住则无本。文殊师利从无住本立一切法。睿公释云。无住则实相异名。实相即是性空异名。故从无性有一切法。余如别说。四中应引净名云。以何为空。但以名字故空。如是二法无决定性。经云。法性本空寂。无取亦无见。又云。一切法无性是则佛真体。八地云。无性为性。中论始末皆明无性以显真空

疏。是以无性缘生故空下。第二会中道意。明此中空有皆是中道。文中三。初拣非显正。二立中道义。三结成中道。初中无性缘生故空者。双牒前四句中两种空也。此二种空并离断见之无。断见之无定无。定无则着断。今缘生故空非是定无。无性故空亦非定无。定无者一向无物。如龟毛兔角。今但从缘无性故非定无。此上拣非为真空也。二显是。言无性缘生故有者。亦双牒前之二有。并非常见之有。常见之有是定性有。今从缘有非定性有。况由无性有。岂定有耶。亦是上拣非是幻有也。显是幻有者。从缘无性如幻化人。非无幻化人幻化人非真。故云幻有。亦名妙有。以非有为有故名妙有。然断常见既由有无。则有无见即断常见

疏。何重牒。此有深意。断常二见多是邪宗。即五利使。边见所摄。其有无见通涉正法取空有相未能契理为有无见。此有无见究竟远离唯大菩萨。故净名云。说法不有亦不无。以因缘故诸法生。有无二边无复余习。下经善友历事诸佛已证法门。尚云犹于诸法中无而计为有等

疏。幻有即是不有有下。第二立中道义。此中有三中道。一幻有上自为中道。谓有与不有此二无碍故为中道。故云有是不有有。言不有者。举体全空无所有故。重言有者。亦名非不有。谓不待破差别相故。故大品云。诸法无所有如是有故。非有非不有名为中道。是幻有义。二言真空是不空空者。即真空上以明中道。谓不空与空无障碍故。言不空者。以空无空相故。重言空者。亦名非不空。谓余一切相无不尽故。是故非空非不空名为中道。是真空义。经云。空不空不可说名为真空。中论云。无性法亦无。一切法空故。重言不空。空故名不真空。不有有故名非实有者。傍会异义意不殊前。即通会肇公不真空论。康公云万法不真故空。不得肇意。达公云。不迁当俗。俗则不生。不真为真。真但名说。却得肇意。此中真空非是前文对妙有之真空。此中真空是所破病人。谓真谛一向无物为真空义。是故肇公以不不之云不一向是无物。故云不真空。谓即万有之无性名为真谛。何曾一向是空。故云不真空也。此不真空即前真空。不有有故名非实有者。对上不真空故为此拣。真空实有并是二边。不真非实即为正理

疏。非空非有是中道义者。即第三结成中道。然其正意。合前真空二义总名非空。合前幻有二义皆名非有。空有不二故为中道。又以幻有为非空。以真空为非有皆中道义。实则上空有之上有二中道。兼此为三。下融会中更当广说。上来即第一门总名竟

疏。又开此空有下。第二开义别释。于中有二。先正开。二文殊各以下。结示问答。今初。一真空必尽幻有是相害义。亦法界观中真理夺事门。以事揽理成。遂令事相无不皆尽。唯一真理平等显现。以离真理外无片事可得故。如水夺波波无不尽。般若中云。是故空中无色无受想行识等。二真空必成幻有者。是相作义及无碍义。亦法界观中依理成事门。谓事无别体要因真理而得成立。以诸缘起皆无自性故。由无性理事方成故。如波揽水而成立故。亦是依如来藏得有诸法。故大品云。若诸法不空则无道无果。中论云。以有空义故一切法得成

疏。一幻有必覆真空者。即相违义。亦法界观中事能隐理门。谓真理随缘成诸事法。然此事法既违于理。遂令事显理不现也。以离事外无有理故。如波夺水水无不隐。是则色中无空相也。二幻有必不碍真空。是不相碍义。亦相作义。亦法界观中事能显理门。谓由事揽理故。则事虚而理实。以事虚故全事中之理挺然露现。由如波相虚令水体露现。故论云。若法从缘生是则无自性。然上真空二义。第二义中以相作摄无碍义。今幻有第二义中。乃以不相碍摄相作。其故何耶。理实空有。第二义中皆含相作及无碍义。而影略者。事依理成故前有相作。理非事造故今无相作。而上三义中言空有相作者。但约事法能显理故名作理耳。然此四义亦即是前缘生故空等四义也。一真空必尽幻有。是无性故空义。二必成幻有。是无性故有义。三幻有必覆真空。是缘生故有义。四必不碍真空。是缘生故空义。前四总明空有所以。今四正说空有之相

疏。然此二不二下。第三融合。于中二。先正明。后结叹。前中即合前四义。须知四义两处名异。上真空必尽幻有是真空上空义。二必成幻有是真空上不空义。三幻有必覆真空是幻有上有义。四必不碍真空是幻有上非有义。又须知有非有空非空各有二义。一有上二义者。一是不坏有相义。二是遮断灭义。则詺有为非不有。二非有上二义者。一离有相义。二即是空义。三空上二义者。一不坏性义。二遮定有义。故铭空为非不空。四非空上二义者。一离空相义。二即是有义。已知名义。今疏融合乃有五重。为五种中道。一云。谓有非有无二。为一幻有者。此是有上二义自合。然取有上不坏相义。非有上离有相义。故合为一幻有。是俗谛中道

疏。空非空无二为一真空者。则空上二义自合。然取空上不坏性义。非空上离空相义。故合为一真空。为真谛中道。前一为即相无相之中道。此一为即性无性之中道。亦存泯无二义

疏。又非空与有无二为一幻有者。上一对空有自合。此下一对空有四义交络而合。今此第三。即取真空上非空义。及幻有上有义。二义相顺明其不二。然是非空上取即是有义。有上取遮断灭义。故得共成幻有。为非空非不有。存泯无碍之中道

疏。空与非有无二为一真空者。即第四取真空上空义。幻有上非有义。二义相顺明其不二。然是空上遮定有义。非有上即是空义。故二相顺得成真空。为非有非不空存泯无碍之中道。三是存俗泯真。此是存真泯俗。又三是空彻于有。今是有彻于空。皆二谛交彻

疏。又幻有与真空无二。为一味法界者。即第五总合前四令其不二。然上各合交彻。并不出于真空幻有。故今合之为一味法界。为二谛俱融之中道。然三四虽融二谛。而空有别融。今此即空有无碍。即是非空非有无碍。举一全收。若以真同俗唯一幻有。融俗同真唯一真空。空有无二为双照之中道。非空非有无二为双遮之中道。遮照一时存泯无碍故

疏。第二结叹。云离相离性无障无碍无分别法门者。以幻有为相。真空为性。又空有皆相。非空非有为性。又别显为相总融为性。今互夺双融。并皆离也。无分别法。但约智说。唯无分别智方究其源矣。其无障无碍通于境智。谓上之五重多约境说。心智契合即为五观。五境既融。五观亦融。以俱融之智契无碍之境。则心境无碍。心中有无尽之境。境上有无碍之心。故要亡言方合斯理。总为缘起甚深之相。余义如玄中已明

疏。复次性有二义下。第四别释性义。于中有四。一顺释。二反成。三结归中道。四结劝修学。今初。文有四节。一双标二门。二以有义故。说二空所显下。释空有义。三以有义故说于不变下。即将初门释变不变。四此二不二下。双融不变随缘二门。就第三释变不变中。云何以有义说于不变。既以二空所显真如。则湛然常存体无变易。云何以空义故说于随缘。由依他无性即是空义。要在缘中方显空理。故知随缘四中。上来旦随一义以收二宗。以法相宗唯不变故。无相宗中唯性空故。故。须第四双融二门具足无碍。方顺圆融。法性宗意。二义既即空即有。亦即随缘。即是不变故。空性即有性不变故。能随缘则有性即是空性。若非实有将何随缘而成诸法。如本无水将何随风而成波浪

疏。若唯不变下。第二反成。若唯不变性何预法者。即性如虚空。法如星象。虚空不为星象之性。真如何得为诸法之性。则性与法异何相干耶。若但随缘岂称真性者。缘有生灭则非真故。疏。随其流处下。借涅槃经以成二义。随流有异是随缘义。本味停留是不变义。即第七经。南经第八。如来性品答迦叶问显性是常。经云复次善男子。譬如雪山有一味药。名曰药味。其味极甜。在深丛下人无能见。有人闻香即知其地当有是药。过去往世有转轮王。于彼雪山为此药故。在在处处造作木筒以接是药。是药熟时从地流出。集木筒中。其味真正。王既没已其后是药。或酢或碱。或甜或苦。或辛或淡。如是一味随其流处有种种异。是药真味停留在山。犹如满月。凡人薄福虽以掘凿加功苦至而不能得。复有圣王出现于世。以福因缘即得是药真正之味。善男子。如来秘藏其味亦尔。为诸烦恼丛林所覆。无明众生不能得见一味药者。譬如佛性。以烦恼故出种种味。所谓地狱畜生饿鬼天人。男女非男非女。刹利婆罗门毗舍首陀。佛性雄猛难可毁坏。是故无有能杀害者。若有杀者则断佛性。如是佛性终不可断。若可断者无有是处。如我性者。则是如来秘密之藏。如是秘藏一切无能毁坏烧灭。虽不可坏然不可见。若得成就阿耨多罗三藐三菩提。尔乃证知。以是因缘无能杀者。释曰。以法对喻。文亦易见。然彼如来秘藏佛性。以合一味。即是此中如来藏性不变随缘二义分明。但雪山喻经。其过去王喻过去佛。复有圣王即是合中。若得菩提。余并可知

疏。又若性离于法下。覆成上义。上云性何预法。即是离义即成断灭者。性离于法非即法空故性成断。言法离于性本无今有者。性出自古此为本有。法既离性故本无今有。本无今有有何过耶。则虚空中本无众生常出众生。若尔法即于性应非本无今有。何以论云从无之有曰生。自有还无称灭。释曰。缘会事显则是本无今有。无始众生不可得。言本无今有。况涅槃云本无今有本有今无三世有法无有是处。上半约相。下半约性。既相与性不得相离。则本无之法非全本无。今有之法非全新有。是故下云三世有法无有是处。此偈广义已见初品

疏。又法若即性性常应常者。然常无常非即非离。此以不即难其大即。性若即法法灭应灭者。谓水若即波波灭水灭。今但波灭而水不灭。则法若灭时而性不灭。即非全即也。故大品中。佛问须菩提。心若生时为即性不。答言即性。此心灭不。答云生法必灭。佛言真性灭不。答云不灭。佛言此处可思议不。答云不可思议。即斯义矣

疏。故二相成下。第三结归中道。略有三重。上非即非离为中道。由此故成非断非常非有非无。亦应言非变非不变也

疏。苟得会下。第四结劝修学。使无偏执。上已明大意。次正释文。疏。初答何因种种此有二意者标也。谓此一偈具四因中。第二八识熏习。第三由无定性

疏。一以八识下。别识第二因

疏。次句心是本识集起义故等者。成唯识第五云。云何应知此第七八识。离眼等识别有体耶。述曰。以小乘谓此但是第六入过去故。故为此问。论云。圣教正理为定量故。谓薄伽梵处处经中说心意识三种别义。集起名心。思量名意。了别名识。是三别义。述曰。此上总解。谓小乘。谓未来名心。过去名意。现在是识等。种种分别。然无别体。今显经证论。如是三义虽通八识。而随胜显第八名心。集诸法种起诸法故。第七名意。缘藏识等。恒审思量为我等故。余六名识。于六别境粗动间断了别转故。释曰。谓为一切现行所熏。是集诸法种。现法为依。种子为因。能生一切法故云起诸法。言缘藏识等者。因中有漏唯缘我境。因中无漏缘于第八及缘真如。果上许缘一切法故论云等也。言粗动等者。易了名粗。转易名动。不续名间。各有所缘故得别名。论如入楞伽第九伽陀中说。藏识说名心。思量性名意。能了诸境相是说名为识

疏。此从别义下。显通别之义。瑜伽六十三亦但有别名大同唯识。已下更无别释。通则八识下。通出八识皆得三名之相。说者应云。若以集起以解心第八独名心。若积集以解心八识皆名心。若思量以解意第七独名意。若以等无间以解意。八识皆名意。若以了别别境以解识。前六独名识。谓了差别六尘境故。若以了别以解识八识皆名识。即别识之义其义善成。唯识第一等者。云了别别境及粗显境唯前六故。对此六尘说六识故即斯义也。通别之名。居然易了

疏。诸情根者。通于八识类非一故者。八识皆有根义已成非一。况就八中复有二类。前五依色后三依心。三依心中复有单双互依之异。若具说者复有多少不同。故唯识第四云。诸心心所皆有三依。一因缘依。谓自种子诸有为法皆托此依。离自因缘必不生故。二增上缘依。谓内六处诸心心所。皆托此依离俱有根必不转故。三等无间依。谓缘前灭意。诸心心所皆托此依。离开导根必不起故。释曰。根识同时名俱有也。前灭识等犹能开避导引后生名开导也。然此三依。言生转起别相云何。生约依种办体而生。转约随顺与力令转。起约由前开路令后得起。然其八识说俱有依四师不同。今但用第四护法。护法广破前义。故唯识结云。由此五识俱有所依定有四种。谓五色根六七八识。随阙一种必不转故。同境分别染净根本所依别故。释曰。同境即五色根根识共同缘一境故。分别是第六。分别差别故。染净是第七。依此能起染净识等故。根本是第八。若离第八余不立故。论曰。圣教唯说依五根者以不共故。又必同境近相顺故。释曰。此会违也。谓对法第一但言眼识依色根。会云不共者。眼根但为眼识依故非余识依。余四亦然。六七八识通余识依。又必同境者。根必与识同缘境故。又近相顺者。六七等识即是远。是故五识定有四依。论曰。第六意识俱有所依唯有二种。谓七八识。随阙一种必不转故。虽五识俱取境明了。而不定有故非所依。圣教唯说依第七者。染净依故。同转识摄。近相顺故。释曰。论中有三。初正明。次虽五识下通外问。谓有问云。意识得五缘境明了。何不亦用五识为依。故答云不定有故。意识不得五识之时。能独缘故。后圣教唯说依第七下。会通余教亦是对法。通亦有三。初明是彼染净根故。二者六七同是转识故。三多引意识起染污执故名相顺。论第七意识俱有所依但有一种。谓第八识藏识。若无定不转。故如伽陀说。阿赖耶为依故有末那转。依止心及意余转识得生。阿赖耶识俱有所依亦唯一种。谓第七识依识若无定不转故。论说藏识恒与末那俱时转故。又说藏识恒依染污。此即末那。释曰。上引伽陀即楞伽经。上引论即瑜伽论。然上所引唯识说识差别不同。故今疏云种类非一。而顺诸圣教。从多而说。故于五中取不共依。六取染污故各举其一。余义含在类非一中。及次疏文重明七八二识中摄。既七为染污根则与前六为染净依。八为通依。即与前七为根本依矣。言染污根者。第四论云。此意任运恒缘藏识。与四根本烦恼相应。其四者何。谓我痴我见并我慢我爱。是名四种。我痴者。谓即无明。愚于我相迷无我理故名我痴。我见者。谓我执。于非我法妄计为我。故名我见。我慢者。谓踞傲。恃所执我令心高举。故名我慢。我爱者。谓我贪。于所执我深生耽着。故名我爱。并我慢爱有见慢俱。遮余部师不相应义。彼疏释云。余部即萨婆多。见爱慢三不得俱起故。论云此四常起扰浊内心。令外转识恒成杂染。有情由此生死轮回。不能出离故名烦恼。释曰。即由四惑常俱等故名染污根。下论文中往往皆詺为染污意

疏。第八又为诸识通依者。即根本依也。言诸识者。识不一故。唯七识心所等法皆依此故。直就第七名染污根。若为六依则通染净故云为染净依

疏。以上八识为能所熏展转为因常流转等者。释第三句也。前七为能熏第八为所熏。故通云八识为能所熏。七熏八种七是八因。八含七种八是七因。故云展转。又依种起现现复持种故展转无穷。然此能熏所熏通性相宗。先依法相宗说。唯识第二广显其义。论云依何等义立熏习名(问也)所熏能熏各有四义。令种生长故名熏习(此总答也)何等名为所熏四义(别征)一坚住性。若法始终一类相续。能持习气乃是所熏。此遮转识及风声寻。性不坚住故非所熏。释曰。转识谓七转识。兼含心所。若许七识能持种者。初地已破四惑应失一切有漏种子。已转七识成平等性。犹有有漏种者。明是八识能持。言风声等者。此拣根尘。以间断相显故偏语之。理实等字等取根尘及法处所摄色等。一切皆拣。至无色界即无色故。入灭定等心亦无故名不坚住。论云。二无记性若法平等无所违逆。能容习气乃是所熏。此遮善染势力强盛无所容纳故非所熏。由此如来第八净识唯带旧种非新受熏。释曰。善染如沉麝韭蒜等故不受熏。无记如素帛故能受熏。佛第八识以极善故亦非所熏。唯于因中曾所熏故带彼旧种。论曰。三可熏性。若法自在性非坚密能受习气乃是所熏。此遮心所及无为法。依他坚密故非所熏。释曰。第八心王得自在故。自在故可是所熏。第八同时五种心所体非自在故非所熏。无为之法体。又坚密如金石等。故非所熏。论曰。四与能熏共和合性。若与能熏同时同处。不即不离乃是所熏。此遮他身刹那前后无和合义故非所熏。释曰。他身即上同处。无有。以他身识为我所熏故。刹那前后即上同时。拣于经部前念之识熏后念。故论唯异熟识具斯四义。可是所熏非心所等。释曰。此总结也。非心所者。即第八同时心所。等取所余。如上所拣。论曰。何等名为能熏四义。释曰征也。论曰。一有生灭。若法非常。能有作用生长习气乃是能熏。此遮无为前后不变无生长用故非能熏。二有胜用。若有生灭势力增盛。能引习气乃是能熏。此遮异熟心心所等。势力羸劣故非能熏。释曰。胜用有二。一能缘胜用。即拣诸色为相分熏非能缘熏。二强盛胜用。谓不任运起。即拣别类异熟心等有缘虑用无强盛用。为相分熏非能缘熏。由斯色等有强盛用无能缘用。异熟心等有能缘用无盛强用。诸不相应法二用俱无。皆非能熏。论曰。三有增减。若有胜用可增可减。摄植习气乃是能熏。此遮佛果圆满善法无增无减故非能熏。彼若能熏便非圆满。前后佛果应有胜劣。释曰。有增减者第七末那。至无漏位亦有增减。唯除佛果。言有胜劣者。前佛应胜以熏无漏种子多故。论曰四与所熏和合而转。若与所熏同时同处不即不离乃是能熏。此遮他身刹那前后无和合义故非能熏。释曰。此第四义大同所熏。上二皆云共和合者。和合即是相应异名。论曰。唯七转识及彼心所有胜势用。而有增减者具此四义。可是能熏。释曰。上结能熏。论云。如是能熏与所熏识。俱生俱灭熏习义成。令所熏中种子生长。如熏苣胜容名熏习。上来皆是法相宗意。下经数数有熏习义。莫厌文繁。第二法性宗者。上法相宗所熏第三能熏第一。正拣真如受熏之义。今法性宗亦七识等而为能熏八为所熏。其第八中以如来藏随缘成立。含有生灭不生灭义。故熏第八即熏真如。故起信论云。复次有四种法熏习义故。染法净法起不断绝。云何为四。一者净法。名为真如。二者一切染因。名为无明。三者妄心。名为业识。四者妄境界。所谓六尘。熏习义者。如世间衣服实无于香。若人以香而熏习故则有香气。此亦如是。真如净法实无于染。但以无明而熏习故则有染相。无明染法实无净业。但以真如而熏习故则有净用。云何熏习起染法不断。所谓以依真如法故有于无明。以有无明染法因故即熏习真如。以熏习故则有妄心。以有妄心故则熏习无明。不了真如法故不觉念起现妄境界。以有妄境界染法缘故即熏习妄心。令其念着造种种业受于一切身心等苦。广如彼论。是则真如亦为能熏。亦能受熏。故楞伽云。不思议熏不思议变是现识因。谓不可熏而熏故名不思议熏。真如不变而随缘成立名不思议变。亦即不染而染也。藏和尚云。妄心通业识及事识。今据其本言业识耳。言熏习故有染相者。真如本无相。随熏现相。又显妄法无体故但云相。此释经中如来藏为恶习所熏等。上即生灭门中。真如言有净用者。此是生灭门中本觉真如故有熏义。真如门中则无此义。由此本觉内熏不觉令成厌求反流。顺真故云用也。此释经中由如来藏故能厌生死苦乐求涅槃也。涅槃经云。阐提之人。佛性力故还生善根。彼言佛性力者。即此本觉内熏之力耳。良以一识含此二义。更互相熏遍生染净也。此中佛者是觉性者。是本故名本觉。余如彼说

疏。无别我人下。释第四句。然有二意。一破我执者。即人也。二又识外下。破于法执。即以此者。言通一切法

疏。二明由不相知方成种种者。即第三段明前四因中第三因也。但由偈中以此二字取义不同故。一偈文通于二义取文全别。前熏习义则以此二宇。全指上半为流转因。今显无性则上半偈为流转果。故疏释上半云出种种。则以此二字指前五偈法喻所明不相知义。为流转因

疏。即此八识下。释第四句。既所流无性。何有能转者。即其主者通于人法

疏。向若有性下。上来顺释。此下反释。由如金石各有坚性不可令易。今此无性犹如于水遇冷成冰逢火便燸故中论云。集若有定性先来所不断。于今云何断。道若有定性先来所不修。于今云何修等。故知若有定性一切诸法皆悉不成。若无定性一切皆成。故中论云。以有空义故一切法得成。若无空义者一切即不成。无性即空义也

疏。次遣疑下即释第二番怀疑问也。由前问云。为是一性为是种种。故今答云常一常多。一虚转者。无性故有也。二无转者。无性故空也。虚转故常种种。无转故常一性勿滞二途也

疏。次答难下。即答第三番设难也。谓前难云一性随于种种则失真谛。种种随于一性则失俗谛故。今意明不相违也。虚转等者。转故是俗。虚故不异真。既言虚转则俗相立也

疏。无转等者无转即真也。以即转言无故不异俗。即转是空故真体存。俗法离真而无别体故云相立。真不可见但云体存。上句俗不违真。下句真不违俗。故疏结云互不相违也

疏。唯心变现全揽真性者。正释真如随缘之义。谓即依前诸识熏习之缘。所熏真如随缘成法。故云全揽真成。以离如来藏无有实体为能所熏故。云全揽真成。正拣法相真如之外有能所熏。真性即如来藏性。如来藏性即生灭门中真如。生非实生。正释示现字。亦仍上起。谓既揽真生生相即虚故云示现

疏。以是随缘不失自性者。如水遇风缘而成波浪湿性不失。如来藏性虽成种种而不失自清净性。此中随缘即是前经见有种种。此中不失自性。即前业不知心等。对上问中故云诸趣种种了不可得。对今经文故云生即无生。生即诸趣。无生即不相知。蹑上示生之句。经云此中即下八字是不失自性

疏。无能现者。性不动也。真如随缘成一切法即能现也。不失自性名性不动。何有能现。妄揽真成故自虚无体。疏上半即无生之生者。由上疑云为是种种为是一性故。今答云。无生之生即常种种。生即无生故云一性。本末染净既相交彻。安可凡情而了知耶

疏。又法性本无生不空如来藏等者。上约不变随缘。今约二空。即以能随缘者。为不空藏故有种种即上半也。随缘不失自性名为空藏。以妄法不染故。即是下半。又约二藏体。即是一性不碍随缘故有种种。不空即是一性空藏。即不相知

疏。答第三难者。谓上难云。一性随于种种则失真谛。种种随于一性则失俗谛。亦性相相违。今答意明性相无违。然疏有二意。一明性相双绝。故无可相违。即下半意

疏。又示现而有生下。第二明性相相成故不相违。即是上半。即无生之性不违示生之相。言亦无所现物相。不违性者虽牒第四句连取第二句。正示现生即无所现故不违性

疏。无二为二者结也。一体而分能现所现。云无二而二。性相无违。为二即无二故云圆融。岂得种种乖于一心心性乖于种种

疏。言法性者下。随难别释。先解法性。后解本字。今初有三。前之二义虽有依主持业不同。然皆与法不得相即。以不变之性非妄法故。第三随缘与法不离。不即不离方为真性

疏。本有二义者。释本无生。由于法性有其不变随缘义故。令本亦二。本即是性。末即是相。前不变本与末不即。后随缘本与末不离。不即不离融无障碍为真本也

疏。此复二意下。上来总明。此下别释。会性相宗。初三性释通有二宗。疏文有三。初直属经文。是法性意。依他无性为圆成故。二由遍计下。正释偈意。由妄分别有上眼等。既从缘生故体即空。空即圆成。三故唯识下。引文证成。二宗三性已见玄文。今此略引依圆二性。初之二句是依他性。故彼释云妄分别缘即是遍计。然妄分别是能遍计。眼等依他是所遍计。计为实故成遍计性。由此能生染分依他。故此遍计能起依他是彼依故

疏。圆成实于彼下。释圆成性。一偈分二。上半正释。下半明与依他起性非一异义。彼论释云谓圆满成就诸法实性。显此常遍体非虚谬。拣自共相虚空我等。此即于彼依他起上。常远离前遍计所执。二空所显真如为性。说于彼言显圆成实与依他起不即不离。常远离言。显妄所执能所取性理恒非有。前言为显不空依他。性言显二空非圆成实。真如离有离无义。故。释曰。玄文已释。但释论意。分前性宇二义不同远离前言已空遍计。故是离有而言性者自属真如故能离无。是以结云真如离有离无相故。若依此释即空无性妄分别有皆是遍计。前偈法性方是圆成。今顺法性依他无性即是圆成故。一偈中三性具足。设顺彼宗离有离无。远离前性。离遍计有。又此偈云此诸法胜义亦即是真如常如其性。故即唯识实性。此即离无。未失彼宗。何须伤巧离前性字。若会二宗。依他起上无遍计性即是圆成。此无性理是真如故。已离有无故。八地云无性为性。疏。故此与依他非异非不异者。释非一异。谓由圆成于依他起远前性故成非一异。故云故此彼。论释云由前理故此圆成实与彼依他非异不异。异应真如非彼所依。不异此性应是无常。彼此俱应净非净境。则本后智用应无别。释曰。圆成唯净智境。依他通净非净。岂得全同

疏。二者上二句因缘所生法等者。即会法性宗中三观义也。欲显包舍。取文小异耳。中论偈云。因缘所生法我说即是空。亦为是假名。亦是中道义。配经可知。然中道言经文所无。但含下半空有为中。若取别显。亦在前偈法性无生。即前偈中亦具三观。初句中道。次句假名。下半即空。由前已配。真如随缘故不显耳。又真如随缘亦不殊三观。思之可知。玄谈抄中已广三观。贤首品等疏文。更释。上别出二宗。取文小异。若以义会二宗不违。因缘所生法。即总举三性所依之法。我说即是空。遍计性也。亦为是假名。依他起也。亦是中道义圆成实也。但三性迢然即法相宗。今皆言即是法性宗。但即不即小有不同便成天隔。然法相宗亦非即离多成不即。法性宗中亦非即离多成非异。法相宗由不即宗。遍计是空但是空无。法性宗则明由无遍计令依他空。便成天隔。后人随计二互相乖。虚己而求大旨无别。显经包摄备举二文。又经旨无差。二宗随取耳。疏又妄心分别有者情计谓有下。第二答怀疑问也。谓上问言为是一性为是种种故。今答云。常空故常一性。常有故常种种也。是即万物之自虚下。肇公不真空论意也。意云万物自虚则常一常多矣。故彼论云寻夫不有不无者。岂谓涤除万物。杜塞视听。寂寥虚豁。然后为真谛者乎。诚以即物顺通故。物莫之逆。即伪即真故。性莫之易。性莫之易故虽无而有。物莫之逆故虽有而无。虽有而无所谓非有。虽无而有所谓非无。如此则非无物也。物非真物也。物非真物故。于何物而可物。经云。色性自空。非色败空。以明夫圣人之于物也。即万物之自虚。岂待宰割以求通哉。释曰。此明体法即空非析法明空也

疏。又前偈从本起末下。释第三重结成难也。谓前偈法性为本示生为末。此偈以空无性为本。眼等为末。摄末归本种种不乖一性。非本无末一性岂乖种种。欲显起末相摄逆顺具足故。引前偈。非独此偈不能答难。若独此偈答者。谓眼耳等即无性故。种种不乖一性无性。要依眼等故。一性不乖种种。又从本起末。即不动真际建立诸法。摄末归本即不坏假名而说实相。义理无妨

疏。第三一偈拂迹入玄者。疏文有二。先正释偈。后又后三偈下。摄叠收束重释诸偈。前中又二。一顺释偈文。二征释所以。今初。然实不实约事理说。妄非妄者约情智说。上即如如及相下。即妄想正智。并属于名五法具矣。而其疏文双牒前二偈文。细寻可知

疏。何者如言取故下。二征释。释中有三。初句略标。亦约智说。故晓公云。如言而取所说皆非。得意而谈所说皆是。十地论云。如言取义有五过失。若不取着实非实等并皆契理。故中论云。一切法真实。一切法非实。亦实亦非实。非实非非实。是名诸佛法。则真妄等一一例然。无非当也

疏。又欲言其实下。一别释。亦约理释。以理圆言偏言不及故。以实非实等相即相夺。一一圆融理致包含故

疏。是以物不即名下。第三结成。于中又二。初正结。后引证。今初。此亦肇公不真空论意也。在文可知。然此言因破大公本无论。后结成言也。彼论具云。本无者情尚于无。多触言而宾无。故非有有即无也。非无无即无也。寻夫立言之本旨。直以非有非真有。非无非真无。何必非有无此有。非无无彼无。此直好无之谈。岂谓顺通事实即物之情哉。夫以物物于物则所物而可物。以物物非物故。虽物而非物。是以物不即名。而就实名不即物而履真。然则真谛独静于名教之外。岂文言之能辩者哉。今但引其结文。两对耳。言物不即名以就实者。物体虚无无当名之实也。名不即物而履真者。名但假立无得物之功也。若名即物召火即应烧口。若物即名见物即应知名。今不尔者。明俱非实故不相得也

疏。是以什公下。第二引证。即悟玄序。其前文云。夫玄道不可以设功得。圣智不可以有心知。真谛不可以存我会。至功不可以营事为。今疏即次下之言。此上二对反显难思。疏文所引即顺明难思。忘言者。舍筌蹄也。虚坏者。离取着也。冥心者。不已见也。遗智者。泥能证也。道理真圣大同小异。然上三即法。后一约人道者虚通即前玄道理拣于事。即前至功所契真拣于俗。即前真谛。圣拣于凡。即前圣智。故有心不契。遗智方知。若有契合复应拂迹。故彼次云虽云道合无心于合。合者合焉。虽云圣同不求于同。同者同焉。无心于合则无合无散。不求于同则无同无异。超非于百非之外。非所不能非焉。忘是于万是之内。是所不能是焉。非所不能非则无非矣。是所不能是则无是矣。无异无同故怨亲无二。无是无非则毁誉常一。夫然则几于道矣。今略引二对足令得意

大方广佛华严经随疏演义钞卷第三十二大方广佛华严经随疏演义钞卷第三十三

        唐清凉山大华严寺沙门澄观述

疏。又后三偈下。第二襵叠重释。上之十偈从后渐收。于中有二。先正收后结叹。前中自有三重。第一收后三偈。为三无性观者。唯识论云。即依此三性。立彼三无性。初则相无性。次无自然性。后由远离前。所执我法性。释曰。谓依遍计所执性。说相无自性性。由彼体相毕竟非有。犹如空中华绳上蛇故。故今偈云一切空无性妄心分别有。次依依他起性。立生无自性性。此如幻事托众缘生。无始妄执自然性故。故今偈云如理而观察一切皆无性。后依圆成实性。立胜义无自性性。谓即胜义。由远离前遍计所执我法性故。故今偈云若实非实。若妄非妄。皆是假说。实即圆成。非妄即契圆成之智。圆成之智成于出世。并是假名。实尚不存何况非实。举况总结。故云其非实妄及世间。一时总遣

疏。又此五偈下。第二合前四喻。由依此义十偈正答。亦可分四。初诸法无体性一偈法说宗因。次四偈举四同喻。三有四偈别合前喻。四者末后一偈结成前义。则五分具矣

疏。又前五偈下。第三重总结。十偈可知

疏。文殊一问下。第二结叹。以缘起深理幽玄该博故。问答包含。今释竭愚发扬玄旨。勿以经少责疏文繁。第二财首菩萨

疏。余准此知者。上三各显二义。下七不欲繁文。故令例知。若具说者。行二义者。一随修何行时。二以何行化之。其能化行与所行行未必全同。如行施行时。或以施行化。或以禅慧行化故。解二义者。一随有深浅之解。二说诸佛菩萨之解化故。言论二者。一随何国俗言说。二宜用何等言辞化故。心乐二者。一随希求何法。二称根为说诸愿乐故。方便二者。一随何进趣时。二随用何善巧等化故。思惟二者。一随思求何义。二宜说云何思化故。观察二者。一如说修学时。二称宜为说观察相故

疏。准诸深经及此偈文略有四意者标也。下别释四中。前三别明。后一总摄。就前三中。一佛见下。初一空不碍化答。二佛知下。智不碍悲答。三随化下。化不违空答

疏。四融上诸义等者。即总摄上三共为一致也。然前三中。初后即性相交彻。中一乃悲智双运。故今融成悲智性相皆无障碍。就文更三。初明所化性相无碍。即前第一意。二从以斯义故下。蹑前初意以辨能化。即前第二意。悲智无碍。悲对前事。智对前理。三今以寂灭非无下。更融前能所。兼具前第三意方成一味。于中二。先正明。后结释。前中亦三。初融所化性相无碍以成能化。无化而化。即前第一意。二以通缘非有下。即融其能化。以成前第三化不失空。三所化既空有无二下。对于所化。成前第二能化悲智无碍之义

疏。不碍有而观空下。第二结释。于中有五。一既云不碍有而观空方能入理。结成问意。则前以空难。随化非得意也。二不动下。既云不动真而随化。结成答意。三从众生不知此理下。结成化意。四从非直下。正结无违。非但无违。兼能相成。五故净名下引证。但证为众生说如斯法。即观众生品。维摩诘问文殊师利菩萨云。云何观于众生。文殊师利答言。我观众生如第五大。如第六阴。如第七情。如第十三入等。意明毕竟空。故次净名问云。若尔云何行慈。答曰。当为众生说如斯法。是即名为真实慈也。然上云寂灭非无之众生者。体虽寂灭不无众生之相。由寂灭故恒不异真。由非无故而恒成立。是故不动真际等者。即智论意。谓不动真际而建立诸法。不坏假名而说实相。细寻可见

疏。大经亦云若知如来常不说法即二十六经。教体中已辩

疏。今初。三颂若着我下。疏文有二。先总标二观。后总相而言下释经文于中先依二空观释。后依念处观释。今初。即二空观者。谓界分别及四念处。皆明二空故。故便以二空科判经文

疏。初一我空下。即界分别观。谓十八界等中。求我不得故。言上半寻思观者。斯为方便。即显下半是如实观

疏。谓揽缘假立者。此释初句。次来无所从下。释次句。虚假似立下。双结二句

疏。以身观身者。即借老子之言。彼云以身观身。以家观家。以国观国。以天下观天下。彼意令近取诸身远取诸物。如观一叶落知天下秋。虽不知空寂例知同也

疏。此观亦寂故不起心者。此释不起心分别。然此句有二意。一既物我皆虚故。不分别物我之异。此意即浅故略不出。今明知空之心。即是此观二我既寂。观何由生。若观不忘非见空矣。则空病亦空能所双寂矣

疏。内身拣于外器及他身者。释初偈内身二字以念处。然四地中有于三身。然智论瑜伽各有解释。今即瑜伽意。一以自身为内身。二以器物瓶衣车乘等为外身。三以外有情妻子男女等为内外身。故今拣于后二

疏。念处有二下。释第二此中谁是我句。谓有问言。准念处观观身不净。观受是苦。观心无常。观法无我。今何观身为无我耶。故今答云。有通有别。上以别难。今约通说。故于观身得作无我及苦无常不净之观。今但举无我耳

疏。复有二种一小二大下。通释一偈。以为通妨。谓有问言下。既别观受及心法。法应无我何无不净苦等观耶。故今答云。约大乘说故。然大乘中具有二观。谓约世谛则观身等为不净等。约第一义则观身等同虚空等。今约大小对辩观身不净等唯属小乘。观身性相同虚空等唯属于大

疏。谁是我言已兼二我者。上约界分别观释谁是我。但遣人我。次第二偈方遣法我。今约大乘念处故兼二我。谓于四大五蕴求其主宰了不可得。但蕴等合即无人我。观蕴等相缘成故。空则无法我

疏。又别则身受不同等者。此亦通妨。谓有问言。大小二观皆观身受心法。今何三偈皆有身言。故为此通。以身受心法但合五蕴。五蕴皆身故。亦犹净名方便品云。是身如聚沫不可撮磨。是身如泡不得久立。是身如焰从渴爱生。是身如芭蕉。中无有坚。是身如幻。从颠倒起。此则如次喻于五蕴皆名是身。若别说者。应言是色如聚沫。受如水上泡。想如热时焰。诸行如芭蕉。诸识犹如幻。今皆言身明知四处皆得称身。故云通则受等皆身

疏。前问意下。结成前问

疏。命谓命根等者。疏文有二。先释上半。于中又二。先释寿命二字。后总释两句。今初。先依小乘。即俱舍根品偈云。命根体即寿。能持燸及识。论引对法云。云何命根。谓三界寿。谓有别法能持燸识说名命根。此有三法。寿为能持故名为体。疏云色心色即是燸。燸必依色故

疏。实谓由业种力下。约大乘释。即唯识第一广破小乘离色心外别有命根竟。示正义云。然依亲生此识种子。由业所引功能差别住时。决定假立命根。而疏云。引一期报众同分体者。通大小乘。大乘是假。小乘是实。故俱舍云。依同分及命令心等相续。又云。同分有情等。同谓身形等同互相似故。分者因义。谓由此分能令有情身形等同。言有情者。同分所依拣非情也。等者。拣于不等。正显能依同分义也。论云。别有实物名为同分。彼言众同分者。众多同分故。广如彼说。唯识广破竟示正义云。然依有情身心相似分位差别假立同分。即大乘义具如疏文

疏。从业缘起下。二通显上半。先以因缘门释。后况刹那下。以生灭门释

疏。喻以火轮下。释偈下半

疏。有三意。初二皆喻上生灭门。而初就所知。二就能知。第三意喻上因缘门。然上法说因果对明。今合喻中能所对说。命为能依。心为所依。依心假立故。是因缘故。生公云。如杖薪之火。旋之成轮。轮必资火而成照。情亦如之必资心而成用也。以彼情依于心。类此命依于心

疏。然无常等经论异说。净名涅槃诸经皆说。下第三住当广示之。今依中边盖是一义耳。即第二论。彼论具有无常苦空无我。论云。无常三者。一无性无常。谓遍计所执。此常无故。二生灭无常。谓依他起。有起尽故。三垢净无常。谓圆成实。位转变故。苦三种者。一所取苦。谓遍计所执。是补特伽罗我执所取故。二事相苦。谓依他起。三苦相故。三和合苦。谓圆成实。苦相合故。空有三者。一无性空。谓遍计所执。此无理趣可说为有。由此非有说为空故。二异性空。谓依他起。以妄所执不如实有。非一切种性全无故。三自性空。谓圆成实。二空所显为自性故。无我三者。一无相无我。谓遍计所执。此相本无故名无相。即此无相说为无我。二异相无我。谓依他起。此相虽有而不如彼遍计所执。故名异相。即此异相说为无我。三自相无我。谓圆成实。无我所显以为自相。即此自相说为无我。彼论结云。如是所说。无常苦空无我四种。如其次第。依根本真实各分三种。释曰。根本真实者。上论云。谓三自性所以名真实者。偈云。许于三自性。唯一常非有。一有而非真。一有无真实。释曰。彼论具释如其次第。一常非有即是遍计。一有非真即是依他。一有无真实即是圆成。释此句云。唯圆成实亦有非有。唯有非有。于此性中许为真实。释曰。论意云。具有具无。有此非有。故为真实。其无字属上。非是无真实也。意明二性皆依于此真实上立。今经无苦而有无相故。疏依三无我开三无相。故彼论释无我之中皆有无相。又亦依此三种无相对于三苦。以论对疏广略可知。疏然皆融摄下。通妨。可知

疏。然此唯识略有二分者。以唯识第二四师不同。谓安慧唯立一。自证分。二难陀立二。谓相见二分。三陈那立三。加自证分。四护法立四。于前三上加证自证分。依彼论宗。即以四分而为正义。故今疏。云略有二分。以诸经论及彼论文多说二故谓离二取相等故。而论文有三。初明立二。二明立三。三明立四。而安慧一分于二分中破之。傍出初立二分。论云。然有漏识自体生时。皆似所缘能缘相现。彼相应法应知亦尔。似所缘相说名相分。似能缘相说名见分。释曰。谓依他二分似遍计所执二分。又以小乘相分名行相。能取所缘故。见分名事。是心心所自体相故。今似其心外之境名似所缘。是心外法此中无故。所变相分为所缘耳。若明相分未是颠倒。向心外取方为倒耳。又言见者。是能缘境义通心心所。非推求义。推求义者。唯慧能。故次破安慧唯立自证分。论云。若心心所无所缘相。应不能缘自所缘境。释曰。谓缘色之心应不能缘色。论或应一一能缘一切。释曰。谓随一识等能缘一切境。以眼识无所缘。而能缘于色。余识无色缘。亦应能缘色。既余不能缘一切。明知无所缘者。是义不然。此中正义缘自境时。心上必有带境之相。如镜面上似面相生。次破无能缘。论云。若心心所。无能缘相。应不能缘。如虚空等。释曰。同于虚空不能缘故。论云。或虚空等亦是能缘。释曰。此反难云。谓心心所法无能缘而能缘所缘。此虚空等无能缘。亦应缘所缘。论云。故心心所必有二相。如契经说。一切唯有觉所觉义皆无。能觉所觉分各自然而转。释曰。此即厚严经。上半明无外境。下半明有见相二分。各各自从因缘所生名自然而转。下结正义。论云。达无离识所缘境者。则所变相分是所缘。见分名自行相。相见所依自体名事。即自证分。释曰。此中虽是立二分家义。已有三故。次论云。若无此者。应不自忆心心所法。如不曾更境必不能忆故。释曰。此明有自证分。意云。相离于见无别自体。但二功能故。应别有一所依体。若无自证应不自忆心心所法。如不曾更境必不能忆。谓如见分不更相分之境则不能忆。要曾更之方能忆之。若无自证已灭心心所则不能忆。以曾不为自证缘故。则如见分不曾更境则不能忆。今能忆之。明先有自证已曾缘故。如于见分忆曾更境故。次下立三分。论云。然心心所一一生时。以理推征各有三分。所量能量量果别故。相见必有所依体故。释曰。所量是相分。能量是见分。量果是自证分。自证分与相见为所依故。如集量论伽陀中说。似境相所量。一能取相。二自证。三即能量及果。此三体无别。释曰。所量如绢。能量如尺。量果如解。数智果是何义。成满因义。言无别体者。同一识故。则离心无境。次立四分。论云。又心心所若细分别应有四分。三分如前。第四证自证分。此若无者谁证第三。心分既同。应皆证故。释曰。见分是心分。须有自证分自证是心分。应有第四证。论云。又自证分应无有果。诸能量者皆有果故。释曰。见分是能量。须有自证果。自证量见分。须有第四果。恐彼救云。却用见分为第三果故。次论云。不应见分是第三果。见分或时非量摄故。由此见分不证第三。证自体者。必现量故。释曰。意明见分通于三量。三量者。谓现量比量非量。即明见缘相时。或量非量不可非量法为现量果。或见缘相。是于比量及缘自证。复是现量故。自证是心体。得与比量非量而为果。见分非心体不得与自证而为其量果。故不得见分证于第三。证自体者。必现量故。第三四分既是现量。故得相证。无无穷失矣。意云若以见分为能量。但用三分亦得足矣。若以见分为所量。必须第四为量果。若通作喻者。绢如所量。尺如能量。智为量果。即自证分。若尺为所使智为能使。何物用智。即是于人如证自证分。人能用智。智能使人。故能更证。亦如明镜。镜像为相。镜明为见。镜面如自证。镜背如证自证。面依于背。背复依面。故得互证。亦可以铜为证自证。镜依于铜。铜依于镜。此上四分即护法之后方有此义。论如是四分或摄为三。第四摄入自证分故。果体一故。论或摄为二。后三俱是能缘性故。摄论为二。亦摄入见故。论或摄为一。体无别故。如入楞伽伽陀中说。由自心执着。心似外境转。彼所见非有。是故说唯心。如是处处说唯一心。此一心言亦摄心所故。识行相即是了别。了别即是识之见分。释曰。此上论文释偈了字。虽开合不同。今但略举相见二分。故彼论初便立二分。处处多说相及见。故若了相分唯心所变此非颠倒。谓相为外心外取故是名颠倒。故上释云依他二分似于遍计相见二分。今约遍计故成颠倒。上之四分文则似横法相之要。故以引耳

疏。令寻伺名等者。入如实观者。此借加行位中。四寻伺观。四如实观。以解经文。四寻伺者。一名。二义。三自性四差别。今云名等等取下三

疏。谓了名等下。即以意言释寻伺观相。于中有三。今初总释。二意即意识下。即引摄论第七。释意言相。论云。意谓意识。觉观思惟。但缘名言分别。无别有义可缘。又必依名分别诸法。故云意言分别。三名言既唯下。会论释经。显四寻伺相。名诠自性。句诠差别。名句皆名自性。差别皆义故但云名义

疏。既随分别下。二别释下半。未曾有一法得入于法性。然此句牒上摄论及经一切是分别言。故云既随分别则妄计意流者。即引楞伽释成。彼经第三。因说破外道所说皆是世论。末后婆罗门问言。痴爱业因故有三有耶。为无因耶。我时报言。此二者亦是世论。彼复问言。一切法皆入自相共相耶。我复报言。此二亦是世论。婆罗门云。乃至意流妄计外尘皆是世论故云妄计意流

疏。尚未了唯心者。上蹑前分别之义。为不入法性之由。此下举况释不入义然其要观略有二种。一唯心识观。二真如实观。唯心观浅尚未能了。真如观妙彼安能入。法性即是真如异名

疏。若能如是自觉通达下。上来顺释经文不入之义。今此反显能入之义。即如实观。于中先入唯心识观。言自觉者。对上楞伽。楞伽云。彼婆罗门又问。颇有非世论不。佛答。云有。外道不能知。以于外性不实妄想虚伪计着故。谓妄想不生觉了有无。自心现量妄想不生。不受外尘妄想永息是名非世论。此是我法非汝有也。今言自觉略其大意。令觉自心耳。其通达之言即摄论意。通达唯是意言分别无有实法。即为入唯识方便。不取外相即入唯心。疏即复此心下。引起信论成真如实观。故彼论云。心若驰散即当摄来令住正念。其正念者。当知唯心无外境界。释曰。此即唯心识观。次云即复此心亦无自相。念念不可得。释曰。此即真如实观。言妄想不生。亦楞伽经。已如前引。便入法性结成上义

疏。上约心乖体非不即者。通难重释。谓有难言。如净名等一切皆如文字性离即是解脱。下经亦云。一切法皆如。诸佛境亦然。三毒四倒皆亦清净。如何言说不入法性。今通有二。一约修行人心不入理。非约法体。不即法性。二约所观。亦无可入故。下文云。如来深境界其量等虚空。一切众生入而实无所入

疏。六一偈通结者。通结五段。令离能所言。亦可近结前二偈者。能所相显故。初明前偈。又观一切下明后偈。以意言观纵成如实。亦有能所云未除遣。加行偈云现前立少物。谓是唯识性。以有所得故。非实住唯识故。但为唯识方便。得通达位方入唯心

疏。此相见二分由无始数习有种种似相似生者。即唯识意。而言似者。显其无真但似二相。若执有实便成遍计

疏。起法必灭下。释下半。然蹑上半起。上既心境相藉即皆从缘生。生法必灭一向绝故。刹那不住故云安得暂停

疏。若了相无相下。正显偈意。上顺释偈文明二取之失。今令了之。则令离二取。是经之意是则反释经文。而顺经意则了唯心成唯心识观。若了无性下。成真如实观。心境两亡则住无分别。如上所引。通达位偈云若时于所缘智都无所得。尔时住唯识离二取相故。自觉智境即楞伽意。不动法界即大般若意。文殊室利分云。系缘法界。一念法界。不动法界。知真法界。不应动摇。谓若言我入法界已动法界。能所两亡入相斯寂。故不动法界是入法性

疏。故末后偈结上诸观下。总出此偈意明通结前

疏。佛如是化下。总显答意。第三业果甚深

疏。四大无主等者。即净名第二云。四大合故假名为身。四大无主。身亦无我。又此病起皆由着我。是故于我不应生着。今取彼文以释今经

疏。能造能受是谓为我者。我在因中即为能造。业为所造。我在果中即为能受。报为所受。此中且顺我我所言。故净名云。无我无造无受者。若僧伽师能造但是冥性。我是受者。而非造者。若卫世师我为能造亦为能受

疏。此问所以也者。此中取前缘起甚深三重问意以释今文

疏。业报揽缘下。上以业遣我。此下以缘遣于我所

疏。由法无我下。上明二我俱空。此下明不坏业果之相。空有无碍二谛双存。是正理量圣教所明即圣言量。故净名云。说法不有亦不无。以因缘故诸法生。无我无造无受者。善恶之业亦不亡。中论云。虽空而不断。虽有而不常。罪福亦不失。是名佛所说。言不违现事者。即是现量。以现见苦乐等报。举体即空不坏事故

疏。法若定有下。反以释成。故中论云。若无空义者。一切则不成等

疏。无所有言该上业果者。案文但云作者无所有。以偈文窄故。实乃作者所作皆无所有

疏。今依法性宗亦以如来藏性为镜者。疏中分二。第一释文。第二显义。前中亦三。初辨定镜体。二显喻相。三出业性。今初。言亦以者。非拣本识。识亦喻于镜故。楞伽云。譬如明镜现众色像现识处现亦复如是。但法相宗不用如来藏为镜。今双用二义故致亦言。言如来藏为镜者。起信论释本觉内体相合明中云。复次觉体相者。有四种大义与虚空等。犹如净镜。云何为四。一者如实空镜。远离一切心境界相。无法可现。非觉照义故。二者因熏习镜。谓如实不空一切世间境界悉于中现。不出不入不失不坏常住一心。以一切法即真实性故。又一切染法所不能染。智体不动。具足无漏。熏众生故。三者法出离镜。谓不空法出烦恼。碍智碍。离和合相。淳净明故。四者缘熏习镜。谓依法出离故遍照众生之心。令修善根随念示现故。释曰。四镜之名者。一空镜。谓离一切外物之体。二不空镜。谓镜体不无。能现万像故。三净镜。谓已磨治离尘垢故。四受用镜。谓置之高台须者受用。四中前二自性净。后二离垢净。又初二就因隐时说。后二就果显时说。又前二约空不空为二。后二约体用为二。又前二体。后二相故。云觉体相者。今约众生。即前二镜合而用之。以第二为能现。以第一显本净故。后之二镜既在果位。约佛为境。故于福田甚深中用

疏。然有二义下。第二显喻相有三事。一镜。二本质。三影像。以喻就法镜则无二。质影各二。谓一是因影。境界为质故。合云业性。二是果影。业缘为质故。法说云果报生也。净名云。是身如影从业缘现。是故结云二文影略下。引中论重化之义。正显因果俱从缘空

疏。合云业者。谓善恶等三下。第三出业体。等取无记。及等不动各成三类。言不失业果之相而为其性者。上是理性此即事性。如火热性等

疏。由无性故下。第二显义。于中有二。先显中道。后明染净。今初。即融上理事二性。交彻无碍以成中道

疏。又如。镜现秽像下。第二约染净。上及此段俱证。由不坏相方显真空。此段亦中道义相。于中二。先略明。后此有四位下。开章广释。于中亦二。先正显染净。后兼明一异。今初。然但知。以镜喻如来藏。影喻生死业果。则法喻昭然。一由真净故能现者。即四镜中第二镜义。二由真净故不为污。即第一镜义。亦前即不染而染二即染而不染。又前即能随缘。二即体不变。然二皆是能现之德。如玉之性虽染不污。若第三相对方显正在泥中染而不染也

疏。二所现二义者。一依他无性义。二无性缘成义

疏。三相对二义者。一即真如随缘。能成万法方是真如。二即真如不变。方能现染。若变性净不能现染。若不现染无随缘德

疏。四真净虚染镕融一味者。以如来藏。举体成生死。如来藏外无生死故。生死即空是如来藏。离生死外无如来藏故。如波与水一味无差

疏。此约染净下。结成上义。谓如真如现依他时。设有净分亦名为染。如镜现像不拣净秽。皆非镜体故。唯能现得名为净所现皆染

疏。更约喻中下。二约一异门言镜是定一者。谓如来藏唯一味故。所现定异者。生死缘差故

疏。染净虽虚下。通难释成。先通异难。谓有问言。染净皆虚岂非一耶。此约喻难。生死涅槃二俱虚寂岂非一耶。此约法难故。此释云不相摄故。此通法喻。如所现像男不摄女故。生死不能摄涅槃故。以相就性故说生死及与涅槃二俱空寂一际无差。以性就相有染有净。以有诤故说于生死。以无诤故说于涅槃。有烦恼时非无烦恼故。就虚相而说异耳。欲令一者。要如来藏而以统之。是第三义

疏。镜现染处下。二通一难。谓有问言。镜能现染。复能现净。岂非异耶。如来藏能成生死。复能成涅槃。岂非异耶。故今答云。现染净处无异体故。生死涅槃一性现故

疏。三像不异镜是非异者。谓像本是异。镜本是一。今像同镜故非异也。故释云镜外无像故。同镜一异相便无。生死本异。如来藏本一。今生死即如来藏。故生死非异。以如来藏外无生死故。疏。镜不异像是非一义者。镜本是一。像本非一。今镜同像故非一也。正现像时去像亦失镜者。释成上义。谓去像失镜明镜同像。言同像者。同像非一。非是约镜与像一也。思之。如来藏本是一。生死非一。今如来藏全体为生死故。同生死之万差。正成生死时。若去生死即无如来藏。此明如来藏同生死之差。非约与生死一故是非一义也。第四亦一亦异门者。但约不坏性相。则一异历然耳。四门一揆。则一异无碍。染净相融。方为事事无碍之镜像也

疏。田喻业缘也者。即六地经云。业为田。识为种。无明所覆。爱水为润。见网增长我慢溉灌。生名色芽。谓若不造业识不成种。如谷不入田终不生故。疏亦本识为田名言为种者。上约因缘合辨。故以业为田。今但约本识含于种子能起现行故。以本识为田。若初地中。亦云于三界田中复生苦芽。则约当果生处亦得名田。显义无方也。成不相知类前可解

疏。三幻师现幻喻。喻所生者。所生通因果。从若幻色喻报下别释。先明果为所生。后若幻色喻业下。辨业为所生。业亦缘生者。如人受五戒为人业。必假戒师言教。三业之具方成业。故业亦缘生

疏。故中论中下。义引论文证业果俱空。彼论偈云。譬如幻化人复作幻化人。如初幻化人是则名为业。幻化人所作则名为业果。既业果皆幻故知并空

疏。若幻唯喻报下。反成上义

疏。四衢喻四识住者。瑜伽八十四云。谓色受想行此之四蕴是识蕴所住

疏。如鸟在壳者。壳为鸟卵。为母所附者。言含声未吐者。庾信云。团团竹上禽。白玉里黄金。里有思晨鸟。含声未吐音。借其言用

疏。轮王七宝喻。增上业果者。非在身内故。言无来处者。轮王登位从空忽来。言七宝者。一轮宝。大如一由旬。或云四俱卢舍。三轮各减一俱卢舍。二珠宝。其状八楞。大如人脾三象宝。即金胁山中八千象中之最下者。四马宝。即帝释厩中者。五兵宝。即是夜叉。六主藏臣宝。即地神。七女宝上即帝释赐。下者人间或乾闼婆女轮。即北方天王令四夜叉持之。归则在门之上一由旬住。帝释所赐。若依此说则有来处。多是约教有殊。故小乘中说轮王殁后收在铁围山间。又有相似七宝。谓一剑宝。二皮宝。三殿宝。四床宝。五林宝。六衣宝。七履宝。如智论及萨遮尼干经第三说。第四说法甚深

疏。为一耶多耶。此亦有三重问意。此上即直问所以。二云偏取互乖者。是第二带疑问。由滞一多二途不知何据。三云并立相违者。即第三成难问也。证一乖于说多。说多违于证一故

疏。能证所证既并不殊者。能证即前案定。所证即释成中法性

疏。二者所悟一法即无碍法界等者。上之一意以法就机。许其有一有多。出多所以。是答直耳问意也。此下唯就法。体常一常多。遣其第二怀疑及第三难。上疑意云。为是一耶为是多耶。今云亦一亦多。上第三难云并立相违。今云相即故不相违。又不坏相故有一多。岂唯不违下。重成第三答难之意尚能相成。岂相违耶

疏。然此九喻等下。上总显偈意。此下别释偈文。古但直释。今将配问。言总答境界无量者。下之九事。皆佛分齐之境故。境界为总句故

疏。不分而遍弥法界故者。即出现品意。彼身业中云。譬如梵王住自宫普现三千诸梵处。一切天人咸得见。实不分身向于彼。诸佛现身亦如是。一切十方无不遍。其身无数不可称。亦不分身不分别。略引一文。余可例取故。将颂文别对前问文理分明。第五福田甚深

疏。一约众生。由器有大别心有轻重故者。俱舍等。说由主财田异故施果差财。前难约田。今答约财主。然第一意正约主异含于心异。谓多财重心少财轻心等故。然器约观解浅深。假之轻重复通深浅。约佛可知

疏。体外方便者。无而别设。如无三说三等。体外方便者即佛权智鉴事差余。即体上大用为体内方便

疏。与前镜喻因缘不同也。义无别者前业果中喻如来藏。约其自心故是因外。今将喻佛是喻缘。故起信云。真如内熏为因。善友习熏为缘。约四镜中即后二镜已出缠故。正取缘熏小镜义兼法出离镜。以法出离是缘熏习镜之体故。义如前引。言余义无别者。亦有一异染净等义。则以佛为净。以生为染。自他相望而论一异。谓心佛众生三无差别等

疏。普去一切烦恼故者。阿伽陀。此云普去故

疏。又此五喻下。覆疏重释。于中有二。先正释五偈。后前四即善巧下。二总彰答意。今初阿伽陀喻灭惑障。日破闇喻。喻灭智障。月光普照喻。喻至平等智地。平等智地即法华意。故彼经云究竟至于一切智地。风喻普动诸有。火喻皆证无为至智地。即是菩提是灭智障果。证无为是证涅槃。是灭惑障果。二因无碍二果亦融动诸有者。即所化生。普令众生灭二障之病证菩提涅槃之果。是此意也。前四已下总彰答意。第六正教甚深

疏。一对初义者。谓约一人竖论。教能断惑亦见即合断惑。何以久而不断。二对后义。后义约多人横说。同见断惑佛教是一。何以一断一不断耶。悉者俱合断故

疏。修有勤惰等者。先答初意。总有六对。略收下喻。勤惰是总意。障有浅深是樵湿喻。机有生熟亦是上喻及钻火喻。未热数息是机生故。缘有具阙即阙缘求火下三喻。功有厚薄即毛滴下三喻

疏。修与不修下对后难意。虽多人同见不修不益。修则有益

疏。然有五相等者。即瑜伽论八十五说。彼云。又有五相发勤精进速证通慧。谓有势力者。由被甲精进故。有精进者。由加行精进故。有勇捍者。由广大法中无怯劣精进故。有坚猛者。由寒热蚊虻等所不能动精进故。有不舍善轭者。由于无下劣无喜足精进故。今但次不同耳

疏。此喻约闻下。别释此喻。于中四。一通明三慧释。二约修消经。三结劝。四示不息相

疏。圣道如火等者。二约修消经。即俱舍论文。谓圣道如火能烧惑薪。道火前相故名为燸

疏。燸顶已前者。谓七方便中前三方便。即五停心观。别相念观。总相念观也。以燸法为热故。燸顶忍世第一法。此四方便为四善根。是加行位。然大小乘释小有不同。大乘之义至初地广释。言已熟而息者。谓燸必至涅槃。顶终不断善。忍不堕恶趣。第一入离生。至于燸位犹尚断善。故云已热而息。未入见道为火向不生。未热数息即前三方便。更加懈怠何由造证

疏。故遗教经对此明小水长流者。即是彼经八大人觉中释精进相。经云。汝等比丘。若勤精进则事无难者。是故汝等当勤精进。譬如小水常流即能穿石。若行者之心数数懈废。譬如钻火未热而息。虽欲得火火难可得。是名精进。释曰。彼以钻火数息以况懈怠。小水长流以比精进故。云对此名小水长流

疏。禅宗六祖共传斯喻下。三结劝。初引内教结劝。自达磨教可即用此喻展转相承。但云六者后分南北。多纷竞故。疏。愿诸学者铭心书绅者。二引外典结劝。言铭心者。犹如刻铭长记不灭。言书绅者。即论语第七。子张问行。子曰。言忠信行笃敬虽蛮貊之邦行矣。言不忠信行不笃敬。虽州里行乎哉。立则见其参于前也。舆则见其倚于衡也。夫然后行。子张书诸绅。注孔曰。绅大带也。疏若直就下。四示不息相。以智慧钻注于一境等者。心一境性名之为定。一境之言通于事理。故遗教经云制之一处无事不办。下经云禅定持心常一缘等。如了法无生名为般若。无生即境。此理一境。了即智慧。无住住故。名注一境。则能入理。言方便绳者。带空涉有。照事照理。喻之以绳。有动用故。善巧回转者。若了无生而入理者。或观生法求生不得。或忘能了入无念门。或起大悲方能入理。如是种种若事若理名巧回转。言心智无住者。亦通事理。且约理者。若以心知如是心住境。若以智了心是智住心。若内若外皆名为住。若住无住亦名为住。故经云若心有住则为非住。应无所住而生其心。谓生无所住心。则非有无住可生。不生于心则无住心生。即此契理亦名方便。故大品云。以无所得而为方便若不住事理生死涅槃。则事理无碍之方便也。四仪无间者。设尔有断亦须知断。若不断时亦知无断常。无念知则无间矣。瞥然起心即失止也。又违北宗。暂时忘照即失观也。亦违南宗。寂照双流即无斯过

大方广佛华严经随疏演义钞卷第三十三大方广佛华严经随疏演义钞卷第三十四

        唐清凉山大华严寺沙门澄观述

第七正行甚深。疏二何故下。疏文有二。先总彰大意。二前四下别释经文

疏。杂集第七说诸烦恼等者。解妨。问既分根本随惑。云何皆名为随。故为此通。故彼论云。随烦恼者。谓所有诸烦恼皆是随烦恼。有随烦恼非是烦恼。释曰。非烦恼者。所谓忿等。但随本惑名随烦恼。而非根本名非烦恼。而贪嗔痴名随烦恼者。心法由此随烦恼故。随恼于心令不离染。令不解脱。令不断障。故名随烦恼。如世尊说。汝等长夜为贪嗔痴。随所恼乱心恒染污。释曰。论意云。一切烦恼根本随惑随逐众生。令心心所随顺染污。故皆名随。是以疏云随他生故。他即众生。由惑随生故生随惑。正是经意。谓诸行人心随贪等

疏。通释贪等如九地中者。指广在余。然九地中释其别相。若随名释如唯识第六云。云何为贪。谓于有有具染着为性。能障无贪。生苦为业。谓由爱力取蕴生故。释曰。有谓后有三有异熟之果。有具谓彼惑业中有及器世间。论云。云何为嗔。于苦苦具增恚为性。能障无嗔。不安隐性恶行所依为业。谓嗔必令身心热恼起诸恶业。不善性故。释曰。苦谓三苦。苦具谓一切有漏。无漏但能生苦者。谓邪见等谤无漏故亦能生苦。论云。云何为痴。于诸理事迷暗为性。能障无痴。一切杂染所依为业。谓由无明起疑邪定贪等烦恼随烦恼业。能招后生杂染法故。释曰。独头无明多迷谛理。相应无明亦迷事相。谓于谛等生犹豫故。论云。云何为慢。恃己于他高举为性。能障不慢。生苦为业。谓若有慢于彼有德心不谦下。由此生死轮转无穷受诸苦故。然根本有六。疑及恶见。此中不说者。以解教人多无于疑及恶见故。后七随惑中。然唯识随惑总有二十。颂云。随烦恼谓忿。恨覆恼嫉悭。诳谄与害憍。无惭及无愧。掉举与昏沉。不信并懈怠。放逸及失念。散乱不正知。此二十中有其三品。谓初忿等十各别起故。名为小随烦恼。无惭等二遍不善故。名为中随烦恼。掉举等八遍染心故。名大随烦恼。今唯小随为成十故但举其七。略无恼害及憍三事。亦憍属慢摄。恼害嗔收故。而言覆者。谓于自作罪恐失利誉隐藏为性。能障不覆悔恼为业。谓覆罪者后必悔恼不安隐故。忿谓依对现前不饶益境愤发为性。能障不忿执取为业。谓怀忿者。多发暴恶身表业故。恨谓由忿为先怀恶不舍结怨为性。能障不恨。热恼为业。谓结恨者。不能贪忍恒热恼故。嫉谓徇自名利不耐他荣。妒忌为性。能障不嫉忧戚为业。谓嫉妒者。闻见他荣深怀忧戚不安隐故。悭谓耽着财法不能惠舍。秘吝为性。能障不悭。鄙畜为业。论悭吝者。心多鄙涩畜积财法不能舍故。诳谓为获利誉矫现有德诡诈为性。能障不诳。邪命为业。谓矫诳者心怀异谋。多现不实邪命事故。谄谓为网冒他故。矫设异仪。险曲为性。能障不谄教诲为业。谓谄曲者谓网冒他。曲顺时宜矫设方便为取他意。或藏己失。不任师友正教诲故。然谄诳并以贪痴一分为体。悭唯贪一分。嫉恨忿三以嗔一分。覆以贪痴一分为体。恐失利誉。是贪。不惧当苦是痴。余可例知。疏法是法药要在服行者。净名云。应病与药令得服行。服与不服非医咎者。即遗教经八大人觉复云汝等比丘于诸功德。常当一心舍诸放逸如离怨贼。大悲世尊所欲利益皆已究竟。汝等但当勤而行之。若于山间。若空泽中。若在树下闲处静室。念所受法勿令忘失。常当自勉精进修之。无为空死后致有悔。我如良医如病说药。服与不服非医咎也。又如善导导人善道。闻之不行非导过也。此皆劝行

疏。十行品云。如说能行等即第十真实行

疏。智论云。能行说为正等者。即第六论文。故疏如说修行方得佛法者。即第三地经

疏。远离贡高轻慢等者。即瑜伽论三十八云。听法由六种相。远离贡高杂染。由四种相远离轻慢杂染。由一相远离怯弱杂染。言六相者。一应时听。二殷重听。三恭敬听。四不为损害。五不为随顺。六不求过失。言四相者。一恭敬正法。二恭敬说人。三不轻正法。四不轻说人。言一相者。不自轻蔑。具上诸义方名善听

疏。求悟解等者。论云。由五相故无散乱心。一求悟解心。二专一趣心。三聆音嘱耳。四扫涤其心。五摄一切心。疏文具足。具此五心方名审谛

疏。言非但者。要兼修行此下。牒经广释。一句显一章大意。于中二。先立理。后引证。前中亦二。先正释。后此明不行为失下拣滥。以人多言此章毁于多闻。令人守愚不习教理故为此拣。于中有三。初正拣非毁多闻。但责闻而不行。不令行而不闻。次若无多闻行无依故者。返立。无闻无解依何而行。后是以不行为失下结成上义。多闻不行调达等是。是经所诃。多闻而行身子等。是经所不责。善星是佛之子。调达是佛之弟。并解十二部经。不依修行生身陷入阿鼻地狱。阿难身子多闻行故亲得授记

疏。故自利利他下。结要多闻。但应下通伏难。谓有难言。一切经论皆说无言。商主天子经云。无有不毁语言而得道者。涅槃二十六云。若知如来常不说法。是名具足多闻者。又涅槃二十云。宁愿少闻多解义理。不愿多闻于义不了。故为此通。涅槃但令解义不毁多闻。商主等经但令莫着。岂当不许众生闻教。疏婆沙四十二云下。第二引证。总引二论三经。而文分二。先引一论二经。证须多闻。净名即第二答普现色身菩萨之偈下。经即第三地经。前文已引。疏上单显闻下。二双引闻行。先引涅槃即第二十五高贵德王菩萨品第七。功德云善男子菩萨摩诃萨。修大涅槃微妙经典。作是思惟。何法能为大般涅槃。而作近因。菩萨即知有四种法。为大涅槃而作近因。若言勤修一切苦行是大涅槃近因缘者。是义不然。所以者何。若离四法得涅槃者无有是处。何等为四。一者亲近善友。二者专心听法。三者系念思惟。四者如法修行。善男子。譬如有人身遇众病。若冷若热虚劳下疟众邪鬼毒到良医所。良医即为随病说药。是人至心善受医教随教合药。如法服之服已病愈身得安乐有病之人喻诸菩萨。大良医者喻善知识。良医所说喻方等经。善受医教喻善思惟方等经义。随教合药喻于如法修行三十七助道之法。病除愈者。喻灭烦恼。得安乐者喻得涅槃常乐我净。故云涅槃四事双美闻行故。疏。智论云。多闻广智等者。然彼论第六总有四偈。此第一偈。次偈云。多闻辩慧巧言语。美说诸法转人心。自不如法行不正。譬如云雷而不雨。博学多闻有智慧。讷口拙言无巧便。不能显发法宝藏。譬如有云无雷雨。不广学问无智慧。不能说法无好行。是弊法师无惭愧。譬如不云无雷雨。此上以行为雨。以辩为雷。以闻智为云。初偈总具故今引之。次一阙行。次偈阙辩行。后偈三俱阙故。云弊法师

疏。恐繁且止者。即智论次前云。有智无多闻。是不知实相。譬如暗夜中有目无所见。多闻无智慧。亦不知实相。譬如大明中有灯而无目。多闻利智慧是所说应受。无闻无智慧是名人中牛。及余诸经其文甚广

疏。又此九偈亦可别对随贪等义者。一溺水喻随贪。爱水故。二喻随悭。不自食故。三喻随嫉。是内病故。四喻随谄。数他德故。五喻随嗔及忿。违王之法受饥寒故。六喻随覆。若掩耳偷铃欲人不闻故。七喻随痴。盲无见故。八喻随慢。恃己惯故。九喻随诳。无德说德故。第八助道甚深

疏。谓断惑证理等者。谓以智慧剑杀烦恼贼故。无分别智方证如故。言导行者。智论云。五度如盲人般若为有目故。能明见夷途开道万行。御心中道至一切智城故。余行得智皆成彼岸。般若究竟成菩提果

疏。结成前难者。此下亦有三重问意。初言前难云智为上首。及今非唯一法成佛。不合偏赞。今有偏赞其故何耶。此直问所以也。二为要假多下。带疑问也。三若随一得成者。结成相违难也

疏。谓智为上首下。上摽答意。此下委释初。释印初。二终无唯以下。释印后。三从释其中间下。释中间。总有五意。前四即四随。后一统摄。今初。随心令喜。即下随乐。亦世界悉檀。二随时生善即下随宜。亦为人悉檀。三所治蔽殊故。即下随治亦名对治悉檀。四入门不同即下随义。亦名第一义悉檀。悉檀此云义宗。即智论中意。诸佛说法不离此四故

疏。又智论云。般若必具一切行下。即第五意。般若统摄诸行。今赞一般若即是赞余。余是般若中余故。但赞余已赞般若

疏。称悦其心者。谓前人乐行布施即劝布施。乐行持戒即劝持戒等。随顺世界顺意乐故。言附先世习者。心未必乐但夙世曾作。劝则易成。如昔曾坐禅今劝坐禅即易得定。乐约现欲。宜约有根。亦犹锻金之子。宜令数息等。随治可知。随义谓随以何法得入第一义故。有人因禅悟道。有人因慧悟道。六度万行皆为入理之门户故

疏。然并通四随略举一治者。会经文也。摽章具四释。但有一者盖是略耳。故引涅槃以证有四之义。谓如一布施有乐施者。劝之即随乐也。昔曾修行能生度善即随宜也。因施见理解财如梦。心事俱舍即随义也

疏。涅槃悭者之前不赞布施者。即三十四经。迦叶菩萨品。佛告迦叶。我于余经中说五种众生。不应还为说五种法。为不信者不赞正信。为毁禁者不赞持戒。为悭贪者不赞布施。为懈怠者不赞多闻。为愚痴者不赞智慧。何以故。智者若为是五种人说是五事。当知说者不得名为具足知诸根力。不得名为怜愍众生。何以故。是五种人闻是事已生不信心恶心嗔心。以是因缘于无量劫受苦果报。今疏引之以成今文。应具四义。言是随乐者。彼不乐故。亦是不宜赞故

疏。仍前渐具等者。即前如是次第修渐具诸佛法。由仍此言。显智得为上首

疏。二正明所用不同者。行本防护与乐别故。故须兼具前意释印初义。此意释印后义

疏。然摄论第九下。引论成经通于前后

疏。通说则此二皆能防外养内者。谛察法理养内德也。进防懈怠众魔不入防外敌也

疏。澄清四海喻上定也。明鉴万机喻上慧也。戴恩仰则喻依赖也

疏。招果无极。如慈一定得十五果。三地当明。第九一道甚深

疏。同观心性者。即正道之一。是唯一之一法性不并真故。万行齐修者。义兼正助。千佛同辙今古不易之一道也。即明流类相同为一。非一二三四数之一也

疏。谓因道既一等者。疏中有二。先释文。后拣滥。今初。先释总句。亦有三重问意。一直问所以故云云何现见。二为果异故下带疑。三若双存下辨相违难

疏。下别辨十事下释所谓下经文。在文易见。今当略示异相言一界有染净等者。略有十义。等字等于余九。二大小。三所依。四形状。五体性。六庄严。七清净。八佛出。九劫住。十劫转变。此即世界成就品十门中八。不取起具因缘。以将因同难果异故。不等无差别门。今难差别门也。为欲满十故加染净及与大小。大小即分量故。亦形状开出染净。即对清净开出。通余八门如娑婆为染安乐为净等。小如娑婆一三千界。大如法华富楼那国。如一恒河沙三千界量等。下之九门。多如世界成就品。二居人善恶等异者。等取或唯地上。或唯地前。或通此二。或三乘一乘等也

疏。三诸乘等别。或有国土说一乘。或二或三或四五。如是乃至无有量。或广略者。如释迦如来广制戒学。迦叶即略。乃至有佛梦中说法。四或三学调摄。即用前乘教等调摄众生。或戒调练。或定以柔伏。或慧以摄御。言强软者。即胜鬘意。已如上引。净名亦云。此土众生刚强难化故。佛为说刚强之语以调伏之言。是地狱。是畜生。是饿鬼。是愚人行处。是身邪行。是身邪行报等。譬如象马[怡-台+龍]戾不调。加诸楚毒乃至彻骨然后调伏

疏。或寿有修短者。如佛名第七说梵声佛寿十亿岁。月面佛寿一日一夜。智度论说须扇多佛朝现暮寂。阿弥陀佛寿命无量无边阿僧祇劫。释迦寿量不满百年等

疏。光明或色相不同者。如十定品。或见如来放黄金色光。或见如来放白银色光等。言或常放具阙者。释迦则具。谓常光一寻放眉间光照万八千佛土等。若普明佛常放光明无前后别。以常光故

疏。随染净土居人异故现通亦殊者。谓随见胜劣多少不同故。如普现如来国土。其中众生皆悉成就自然神足等。则佛为彼现必异此方

疏。一多少者。或菩萨多声闻少。或反此。或俱多俱少。故上世界成就品明佛出云。或化多众生。或调伏少众生等。佛名经说弥留胜王佛初会声闻八十亿百千那由他等斯即多也。言二会数者。如佛名经第七云。弥留胜王佛四会说法。华胜佛一会说法。声德佛三会说法。放焰佛十会说法。或一经多会说。如华严般若。或一会说多经。如无量义法华。弥勒世尊。龙华三会。七佛说法会数不同。三凡圣大小。或唯集声闻等。或唯集菩萨。或三乘同会等。九化仪如教体中。而言等者有二。一瞪视等。二化仪前后。或先小后大。先大后小。或显密不同。顿渐等异。并如教摄中说

疏。十法住久近者。如法华说华光佛正法住世三十二小劫。像法住世亦三十二小劫。若光明佛正法像法各住二十小劫。山海慧自在通王佛寿无量千万亿阿僧祇劫。正法住世亦倍寿命。像法住世复倍正法。则正法二无量千万亿阿僧祇劫。像法亦尔

疏。若约一佛十事下。二拣滥也。恐人误谓一佛一因而有多果。故为此拣。明此是多佛同修一因。何以见果种种差别耳。一佛证一而果异者。如前已明。谓文殊问德首云。如来所悟唯是一法。云何乃说无量诸法现无量刹化无量众生等。故云德首已明

疏。第二答中下。疏文有二。一略叙答意。二广征释。前中印其因同释其果异。异自在物。同是佛同

疏。何者诸佛因果俱同异下。第二广征释也。于中有二。一摽。二释。今初。文殊向以因同用难于果异。今明果亦有同。何以不知。因亦有异故。互为不说。故云俱有同异。是则以佛就机因果俱异。废机说佛因果俱同。然果同因异相隐。因同果异相显。故文殊以显难其所隐。使物齐明成乎一道

疏。谓同满行海下。二释相也。于中有四。初通释四义。二结成同异。三引证同异。四别彰果同。今初。一同满行海者。二利行也。二将此同因下。辨异因相。亦用上来二利行也。然法相宗。自受用身及受用土自利行成。若他受用变化身土利他行招。然则利他亦能随机而取异果。诸佛皆尔。亦得言同。若法性宗。二利皆成同因异因。利他不圆安得真报。自利不足岂能利他。故随二行并成自果俱能利他。但随所宜化类差别故取异果耳

疏。是则约佛即同能随异下。第二结成同异。上直指因果同异之相。今此融通会释。然有五句。此句唯约佛。既将同因回成异因故即同。果能为异果。二约机同处而见异者。唯约生说。心自异故。三以生就佛者。犹如四心同观一境。一境不差成本同义。四以佛就生者。如虽一境令四心见殊。成能异义。五以佛望佛者。佛佛皆能随机见异。即是同义。结云犹如锦窠常同常异者。融上五句不离同异无碍

疏。瑜伽三十八下。三引证同异。除意明随机故一句。是疏释论。余皆论文

疏。就果同中下。第四别释果同。以难见故。于中二。先正释。后故成唯识下引证。即第十论。于中四种身土文分为三。初释证自性身土。既同所证明是体同。如一室之空。二自受用如千灯光同照室内。三余二身土。即他受用及变化者。正证于前亦相似名同。而随机见异。疏文有二。先摽。后释。今初。就随机见异中。有共不共者。共为异故名共。非是同义。不共随化别故上二皆异。然共不共亦相似名同。令其各见共不共差即随机见异

疏。所化共者下。第二释也。于中三。初释共义。二释不共。三双结。今初。言佛各变者。如今释迦化身。若一类众生。昔与阿閦弥陀药师宝集。皆悉有缘。应受其化。所化之者身不可分。在贤劫时阎浮之处。则阿閦如来化一佛身为释迦文。阿弥陀佛亦化一身为释迦文。药师琉璃光亦化一身为释迦文。宝集如来亦化一身为释迦文。同在迦毗菩提树下一时成佛。令诸众生但谓是一释迦文佛。如五盏灯同照一物共发一影。实有多光各发一影。而相杂故谓之为一。如其一人属于五佛。如上所明。若百千人同属五佛。亦如是见五佛为一

疏。于不共者唯一佛变者。第二释不共。设见十方百千化佛。亦是一佛化现诸身耳

疏。诸有情类属佛异故者。第三双结释。释成就上来共不共义。上来皆是论文。唯属佛异故一句义引彼论具云。诸有情类无始时来。种性法尔更相系属。或多属一。或一属多。故所化生有共不共。不尔多佛久住世间。各事劬劳实为无益。一佛能益一切生故。释曰。不尔已下即彼论文弹余师义。然应更有或多属多。或一属一。文无者略。又彼论云无始时来种性法尔。今虽取彼共不共义。但约结缘不必法尔。然摄论中有三师义。一云皆共。一一皆度一切等故。二云不共。以类本来相属别故。如慈氏释迦同事底沙佛。佛见释迦所化先熟为之入定。令其七日忘下一足。说偈赞佛超于弥勒。九劫先成。岂非别耶。三云有共不共。若一向共。何用多佛。若一向不共。不应历事多佛。愿度一切。不应以己所化众生付嘱后佛。今唯识论。即第三正义。略弹共家不弹不共。偈中

疏。略明四一者。上以因一难于果异。今此具明因果一相

疏。然体同义异者。通妨。恐有难云既取初义体同为一。则一佛证时一切皆证。若约出现实如所难。佛见众生皆以证竟。今约现事故为此通。以体就能有证未证。千灯一室所照同空。以灯就空空体无二。以空就灯有照未照。随灯各取各属本灯。佛义亦尔。疏八识心王等俱不可知者。以非佛无心但深妙玄奥难知相耳。故出现品云。如来心意识俱不可得。但以智无量故知如来心耳。既云知如来心则非无心矣。彼有十相。一一皆云是为如来心第一相等。诸菩萨摩诃萨。应如是知。今取佛佛之心皆不可知故名一耳

疏。前中即随本异因等者。如众生宜以直心土化。菩萨即将直心因取直心土等。即随诸众生。应以何国起菩萨根。而取佛土等。故云得如是佛土。谓染净等土相不一故

疏。答意云。众生不见岂得云无者。即同净名经云。尔时舍利弗承佛威神作是念。若菩萨心净则佛土净者。我世尊本行菩萨道时。意岂不净而是佛土不净若是。佛知其意。即告舍利弗。日月岂不净耶。而盲者不见。对曰。不也世尊。是盲者过。非日月咎。舍利弗。众生罪故。不见如来佛国严净。非如来咎。舍利弗。我此土净。而汝不见。即其义也

疏。亦有三义初则净意乐地者。此中三义对前三义。由初他受用身地前不见。此辨登地则见下。二例知

疏。既揽同成异亦称体成益者。既是如来将其同因以取异果故。令圆机即应见真故。云称体成益

疏。若顺今经亦可此二通佛及刹者。上取晋经意。无分别是无差别。故但属刹。无憎爱约心。故但属佛。今直案文。佛具无分别无憎爱。以无分别智心平等故。刹亦无分别无憎爱。以境但无心即无分别。何有憎爱。是则佛字两用。佛无分别佛刹无分别等

疏。次半偈明异自在物者。此明见异之因。因心及业故。下半正明见异。第十佛境界甚深

疏。十信观圆便造佛境者。此明来意。亦辨在后之义

疏。始信终智皆托佛境者。文殊主二法门。一主信故。善财初见便发信心。二主智故。善财后见便见普贤。始入之信亦信佛境。能度之智亦证佛境耳。故文殊说

疏。并非因位作用所及者。结也。此结分齐境。亦非下位所知者。通结二境

疏。然有三义者。正释第四句而实无所入言。仍取第三句释之。故皆有证入之言。此三别者。初一以理对悟说。二以理对事说。谓生是事与理非即故有入言。与理非异故无所入。三正约心境契合说。谓正冥境时不作入解故

疏。即广之深下。总结一偈意

疏。一殊胜等者三义并在偈中

疏。无若干者。即净名第三。其无碍慧无若干也

疏。六答法问。疏有二释。前释但融二境。后释境智双融。前中揽理成事者。是依理成事门。理彻事表者。是真理即事门。但用此二即显无别。此影略明耳。亦应云理依事显。即事能显理门。事彻理源。即事法即理门

疏。是故事则不待坏而恒真等者。成上二句。此成前句。以事全揽理。非色灭空。色性自空故。下句成下理彻事表故。不待隐而恒俗也

疏。非直广大下。结。谓生生称真则一一广大。理非事外是谓甚深。又理遍于生故云广大。即生即理故曰甚深。此即结归。初总偈中深广义

疏。又法界是所证下。第二释融境智也。则究竟无差别言有其两向。向上融二界。通向下融能所了。故云究寻其本亦无差别。即能所契合同一法界

疏。以一切差别下。通妨。谓有问云。上问说法。今答智了。岂得同耶。故今答云。所了之声是佛法轮声摄故。随其类音为说法故。出现品云音声实相即法轮故。贤首品亦云能令三界所有声。闻者皆是如来音故。上疏云随性随相皆悉了知。了相差别。随宜用之。了性体融。一摄一切

疏。八知即心体者。此句标示。上智即对所证之法明能证之智。今直语灵知真心异乎木石者。通能所证也

疏。了别则非真知下。双会南北宗禅以通经意。此句即遣南宗病也。谓识以了别为义。了见心性亦非真知。净名云。依智不依识。谓分别名识。无分别名智。今有了别之识故非真知。真知唯无念方见

疏。瞥起亦非真知者。此释第二句。遣北宗之病也。北宗以不起心为玄妙故。以集起名心。起心看心是即妄想。故非真知。是以真知必忘心遗照言思道断矣。故胜天王般若。问云。云何菩萨修学甚深般若通达法界。佛告胜天王言。大王即是如实。世尊。云何如实。大王。即不变异。世尊。云何不变异。大王。所谓如如。世尊。云何如如。大王。此可智知非言能说。离相无相远离思量过觉观境。是谓菩萨修行甚深般若了达甚深法界。释曰。但以无念心称此而知。即同佛知见。经云如实即无念。是用无念心见闻觉知觉知一切事法。心常寂静即如来藏

疏。心体离念非有念可无者。双会二宗释第三句。以北宗宗于离念。南宗破云。离念则有念可离。无念即本自无之。离念如拂镜。无念如本净。今为会之。起信既云心体离念。亦本自离。非有念可离。亦同无念可无。即性净也。非看竟方净。若无看之看。亦犹无念念者则念真如也

疏。众生等有惑翳不知下。释第四句。即用法华开示悟入佛知见意。谓开除惑障显示真理。令悟体空证入心体也。大意然矣。此有多释。已如前引。今更略举禅门释之。北宗云。智用是知。慧用是见。见心不起名智。智能知。五根不动名慧。慧能见。是佛知见。心不动是开。开者开方便门。色不动是示。示者示真实相。悟即妄念不生。入即万境常寂。南宗云。众生佛智妄隔不见。但得无念即本来自性寂静为开。寂静体上自有本智以本智能见本来自性寂静名示。既得指示即见本性佛与众生本来无异为悟。悟后于一切有为无为有佛无佛常见本性。自知妄想无性。自觉圣智故是菩萨。前圣所知转相传授。即是入义。上二各是一理。前之略释是疏本意。余如别说

疏。即体之用。故问之以知下。会违。谓前问问知。今答性净都无知言。何以会通。故为此会故。水南善知识云。即体之用名知。即用之体为寂。如即灯之时即是光。即光之时即是灯。灯为体光为用。无二而二也。知之一字众妙之门。亦是水南之言也。若能虚已下劝修。即可以神会。难可以事求也。能如是会非唯空识而已。于我有分也

疏。九答证问。疏文有三。初标举。二释相。三结示

疏。非业系故下释相。于中有三。初经中七字。示三德体。二无住处下八字拂三德相。三以第四句辩三德功能

疏。由无用故下释第四句。合上体相不二故。功用普周也。三是谓三德下。结示三德。广义已见玄中。下出现品复当重解释。此但撮略对文耳

疏。因何而现下。疏文有三。初来意可知。二所现有十下。释文。三又此亦可下。重会前文。二中持戒即人天胜劣等者。如第二地

疏。说法即近报净居。聪明利智等者。皆智论文。论第十三引育王经云。育王常供养众僧。有一比丘。口内馨香。育王怀疑试而验之。方知本有。问其所因。比丘答云。迦叶佛时说法之果。复闻说法果唯尔耶。答。此是华报。问云。果报云何。因说偈云。大名闻端正。得乐及恭敬。威光如日月。为一切所爱。辩才有大名。能尽一切结。苦灭得涅槃。如是名为十。此即说法之果也

疏。又此十亦可配十甚深者。重会前文不为此释则现事无由。理必合耳。但文影略故致亦可之言。初来意有三。初一通对前后辨来。谓欲成妙位是后十住故。前品明解即是对前。二又前明入理下。此及第三俱是对前二。即以行对行。但理事不同。三即以愿对行。则二品全别故。前品具解行二义。此品具行愿二义故

疏。次释名中二。先正释。后得斯意下。辨行功能

疏。文殊心故下。覆成上二。然即贤首品初生起之意寻文可知。疏四解妨中。有二。一唯愿无行妨。二辨所行非真妨。前中二。先问后答。于中又二。先列。后结。前中略有六重。一事理无碍行。二以愿导智下。悲智无碍行。三遇违顺境下。止观双流行。四又对于事境下。三观一心行。五又所造成行下。十度齐修行。六皆愿利生下。四弘誓愿行。六中前三各有三义。初中三者。一历缘造修事行也。二触境不迷理行也。三双达事理。即事理无碍行也。第二行中含三行者。一大悲行。二初对悲行。总为智行。三悲智双运行。四中有五别。明空假中为三。四三观不次第为一行。五三观一心为一行。三五六者并文处可知。三观如前后说

疏。沤和涉事者。沤和俱舍罗此云方便善巧。即肇公宗本论文。论云。沤和般若者大慧之称也。诸法实相谓之般若。能不形证沤和功也。适化众生谓之沤和。不染尘累般若力也。然则般若之门观空。沤和之门涉有。涉有未始迷虚。故常处有而不染。不厌有而观空。故观空而不证。是为一念之力权慧具矣。一念之力权慧具矣。好思历然可解

疏。二陈所问中。文二。先总科。二此十一中下。料拣。自有三意可知。三中以善修七觉下。解妨。谓有问云。其初意中二四与六此三明因。如何今十皆得名果。故为此通。以约相显望菩提涅槃此三为因。是初十成故得称果。皆言下。释云何得言。从初十望后下。重通复难。问。初十既因。何以前科云智首举德征因。答意可知。则智首总问因果之德。文殊总举历缘巧愿。则皆成矣

疏。今十句下。疏文分三。初依总别科释。二先果后因释。三当句对惑释。今初。则十一段皆是所成之果。兼含料拣中第三意。初十为能成。下十为所成。从后倒牒十果。案次释文。谓第一无过失三业。得第十一超胜尊贵果。第二不害三业。得第十能为饶益果。三成第九。四成第八。五成第七。六成第六。七成第五。八成第四。九成第二。十成第三。唯后二前却耳。亦可如次犹涉境无染故成众慧。智为先导成就法器。其中加字已当释文。如云无恚害以恚释害。以涉境释于无染。约体释于清净等。细寻历然

疏。又由后十下。二先果后因释。以初十句为果。后之十段百句为因。故云永无失等唯佛不共。永无失等者。等下九句不害业等。言不共者。即十八不共法。谓一身业无误失。二无卒暴音。三无种种想。四无不定心。五无忘失念。六无不择舍。七欲无退。八念无退。九精进无退。十定无减。十一智慧无减。十二解脱无减。十三身业智为先导随智而转。十四语业智为先导随智而转。十五意业智为先导随智而转。十六知过去无著无碍。十七知未来无著无碍。十八知现在无著无碍。广如别章。今以十句通摄十八。谓初二即初三。一由三业无过害故。次二即次三。由有念定慧故。不可毁坏故。三皆云无。五六即七八九。七即定慧解脱。三种无减故称殊胜。八九即后三。三世无著无碍故云清净无染。十即十三十四十五。智为先导随智而转。故疏云永无失等唯佛不共。今约分分故为后因

疏。又后十句下。三当句对惑释。以破六根本惑成斯十句。疑摄三句。贪摄于二。余四各一故。六摄九

疏。初一异熟果者。俱舍显相颂云。异熟无记法。有情有记生(二)等流似自因(三)离系由慧尽(四)若因彼力生是果名士用(五)除前有为法有为增上果。释曰。初二句异熟果相。但是无覆无记。不通非情。从善恶感名有记生。次句等流果相。似于同类遍行自因。次句离系果相。由慧尽者。慧则择也。尽则灭也。谓此择灭离系所显故。将择灭释离系果。次二句士用果相。若法因彼势力所生。如因下地加行心力上地有漏无漏定生。及因清净静虑心力生得变化无记心等离系。名为不生士用。为因道力证得亦得士用果名。后二句增上果相。有为法生余法不障是增上果故。唯有为除前已生有为之法。谓果望因或俱或后必无前果后因故云除也。除此前外余诸有为为增上果。论云。增上之果。问。士用增上二果何殊。答。士用果名唯对作者。增上果称通对所余。如匠所成对能成匠。俱得士用增上果名。对余非匠。唯增上果。非匠不造故非士用。瑜伽三十八云。习不善故乐住不善等为等流果。或似先业后果随转。释曰。此有二义。释于等流。后义果似于因。即俱舍意。如杀生因等得短寿果。前义即于后果之上行因似因。如前世杀生今亦好杀等。瑜伽又云。以道灭惑名离系果。四人工等事由此成办稼穑财利等果为士用果。若眼识等是眼根等增上果。身分不坏是命根增上果。二十二根各起自增上果。当知一切名增上果。余例可知。然上所引俱舍即是根品。彼论以六种因成斯五果非今所要

疏。瑜伽具释者。第六回向初当广释之。即有八种异熟。今开成十句。今生处具足总明义当财位果。二即种族果。三亦财位。四即大色果。五人种性果。非不男等。六信言果。意由念具故。七名誉果。八义当寿命。离过修行无夭逝故。九大力果。十亦大力。智力觉悟故

疏。无畏下随难重释

疏。又此十事下。约法。言生在佛家者。菩提心家故。等者等于余句。谓二种族即具佛种性。谓自性住性习所成等。三明家即真如为家。亦四家故。四家如七地。四明见佛性。如见色故。故涅槃云。佛性有二。一色。二非色。如来所见为色故。五相谓有悲智等为菩萨相故。余之五句经自约法可知

疏。又具足下。重释具足之言。上约横具为具足。今约竖说之

疏。即是种性者。谓种性位。由于习种合于性种方名种性也。性种即自性住性为正因。性即是涅槃第一义空性也。习即新熏修成之性。决于佛因称为种性。引证可知。言无性摄论者。即第八论释因缘云。诸菩萨因缘。即有言闻熏习。是无分别智及如理作意。释论中云。因即能作因缘义。有言者。大乘言音。闻谓听闻。由此引功能差别说名熏习。以此为因。所生意言顺理清净。名如理作意

疏。摄论广说者。即第七论。瑜伽四十五。明内外各有六方便此即内六

疏。瑜伽起信等论者。前第一经疏中已引起信。今略引瑜伽。即七十七菩萨地品中。彼论亦引深密。慈氏问世尊。如来说四种所缘境事。一有分别影像所缘境事。二无分别影像所缘境事。三事边际所缘境事。四所作成办所缘境事。几奢摩他所缘境事。几毗钵舍那所缘境事。世尊答云。初一毗钵舍那所缘境事。次一奢摩他所缘境事。后二是俱所缘境事。释曰。初一即事。二即是理。故无分别智缘三四通事理故用二为能缘。则是以事对观义也。故前第一经疏中已为出意。但不顺无分别智证如中义耳。广如彼说。今取一义故不言是非。以明十重。从粗至细。自浅暨深故。初二止观别行。一即瑜伽奢摩他品。二即毗钵舍那品。下八皆双运品。而三正是双运。对第四双遮。此为双照。若取别义双照皆观。双遮皆止。上四以理事为能成。止观为所成。五融于心境即合前三四二门。以初二事理即三四所融故。绝事理即第四门中境。无碍即第三门中境。泯止观即第四门止观。无碍止观即第三门止观。合上二重止观与二重之境明非一异。不坏二相故不一。二体无异故不二。故虽融心境方是事理无碍之门。但言相融不说。何者。是止是观者此通三意。一但融上二重止观即是此门止观。二者照斯二而不二不二而二。即是于观不取诸相即名为止。三者不碍心境而一味成即观上止。不坏一味而心境成即止之观。后五即事事无碍门中止观。六是一多相容不同门。七是诸法相即自在门。八即合前即入义。当同时具足门。九即因陀罗网境界门。十即主伴圆明具德门。欲显后后深于前前故合即入耳。余可思准。此亦一处明示止观。兼广演玄言

疏。皆约流转以明者。由善巧义通还灭故。总释善巧乃有三义。一知理。二知事。三云加能摄无尽。正是事事无碍兼于事理无碍。故大品云。一切法趣色。色尚不可得。云何当得有趣非趣。一切同归于空。诸法之空不异色。空故即事理无碍意。今取一摄一切。即事事无碍。善巧开此为二便有四义。瑜伽五十六七广说。三科善巧。多约相说。即第二义

疏。第八十王敬护是增上果者。即有力增上。由己具德令彼护故

疏。由本愿力为依救等。即瑜伽。前意行以昔修故。言由本行力为第一等者。即第二意果似昔因。既为第一故是行果

疏。佛地论第七有五重者。一修善因得乐果故。二离恶摄善故。三此世他世益故。四世出世益故。五福德智慧益故。上之五重各先义后利

疏。一言蔽诸者。即论语云。诗三百一言以蔽诸。曰思无邪。包曰蔽犹当也。谓归于正诸之也

疏。四十一位者。此约行修有障等。第四十二即妙觉位。是所求故。无障非行故

疏。不同权小谈有藏无者。小乘谓唯佛一人有大觉性。权即五性。谈其有者。藏其无者。在有佛性中故。又云。通别类异。通即皆有。别则有有佛性有无佛性

疏。以是至德行本者。即外典意。故孝经。夫子语曾子。曰。先王有至德要道。民用和睦上下无怨。汝知之乎。注云。至德者孝悌也。要道者体乐也。故上至天子下至庶人。皆当行孝无始终也。言行本者。俗典以孝为百行之本。下引佛教证。菩萨戒亦云。孝养师僧父母孝名为戒。亦名制止

疏。然二乘之染非真染等者。即涅槃第二南经哀叹品。佛诃三修比丘云。汝诸比丘。勿以下心而生知足。汝等今者虽得出家。于此大乘不生贪慕。汝诸比丘。身虽得服袈裟染衣。其心犹未得染大乘清净之法。汝诸比丘。虽得行乞身经历多处。初未曾求大乘法食。汝诸比丘。虽除须发。未为正法除诸结使。汝诸比丘。今当真实教敕汝等。我今现在大众和合。如来法性真实不倒。是故汝等。应当精进摄心勇猛摧诸结使。释曰。此以小乘。方大尚未能除所知无明。染法空法常住妙法故云尔也。疏。五受之一者。一善来。二上法。三三归。四八敬。五羯磨。多释不同。多依此五

疏。归要三者前归敬序中已广说竟。言至下当明者。即明法品。前是抄广故此指下

疏。和尚此云亲教者。是昔时梵语。即龟兹已来梵言。正云邬波陀耶。此云亲教

疏。戒有二种等者。依比丘戒则五戒十戒八戒皆为方便。五众之最为最胜法。若菩萨戒为具足。则比丘戒亦为方便。超二乘上为最胜法。愿所成者明是佛果

疏。杨枝五利者。一明目。二除痰。三除口气。四辨味。五消食。新经有十义

疏。朝中嚼杨枝。净秽不相杂。此两句语全是无行禅师。于西域寄归之书。南海寄归传亦广说之

疏。三苦八苦亦皆除灭者。由三涂苦灭故生老病苦亦灭。由断此惑不造十恶业故。无怨憎会苦。由断分别欲贪故。无求不得苦及爱别离苦。从此唯有死及取蕴。至金刚无间道根本智断彼二苦。虽有漏善法此时犹在行苦所随。由被胜智照同法性。于解脱道不待择灭。任运弃舍功归无间。上约法相说。取正体无分别智名为根本。以望加行得名。虽通诸位而见道金刚二处最显故略举之。又有约法性以本觉为根本智。以与始觉为根本故。此唯约解脱道。证理时与根本冥合乃名获得本觉根本。从此永无死及取蕴。虽断惑证理立二道名然。同一刹那获智亦尔。是故无间道断见修二障种时。即是解脱道时断也

疏。一约入真见道之慧等者。亦有二义。例同断苦。断身病之苦牒前所断。及烦恼病是此所断。谓一切下。出所断体。粗重即是种子。分别拣于俱生。亦为身病远因者。非近因故。如房色过度是身病近因。由贪故尔即为远因。言一刹那中顿断者。至初地中广释。顿证三界四谛真如。至十回向中释

疏。二约金刚心顿断一切诸烦恼病者。即俱生也。此上所转舍。依上解下结成前二

大方广佛华严经随疏演义钞卷第三十四大方广佛华严经随疏演义钞卷第三十五

        唐清凉山大华严寺沙门澄观述

疏。诸佛菩萨始自发心下。文中有三。初列十恩。二结成恩重。三者引证。初十恩者。一发心普被恩。二难行苦行恩。犹如慈母咽苦吐甘。舍头目髓脑国城妻子。剜身千灯。投形饿虎。香城粉骨。雪岭亡躯。如是等事皆为众生。三不顾自身者。一向为他恩。曾无一念自为于己。犹如慈母但令子乐自杀不辞。经云。菩萨所修功德行。不为自己及他人。但以最上智慧心。利益众生故回向。四垂形六道恩。谓已证灭道应受无为寂灭之乐。而垂形六道遍入三涂。长劫救物入于地狱。以身救赎一切众生。五随逐众生恩。上辩横遍六道。今约长劫不舍。如子见父视父而已无出离心。如来随之。如犊逐母。备将万行随逐救摄。如须弥音遍净天王。得随诸众生永流转生死海解脱门。六见其造恶如割支体。即大悲深重恩。故善财童子谓无忧德神云。圣者。譬如有人唯有一子。爱念情至忽见被人割截支体。其心痛切不能自安。菩萨摩诃萨。亦复如是。见诸众生造烦恼业。堕三恶趣受种种苦。心大忧恼。若见众生起身语意三种善业。生人天趣受身心乐。菩萨尔时生大欢喜。今略举悲深。喜亦深故。七迄成正觉隐其胜德者。即隐胜彰劣恩。十莲华藏尘数之相海滴难称。无尽之德并隐不彰。但云百劫修成三十二相。三十四心断见修惑。五分法身觉树初圆。如老比丘同五罗汉。故法华中。脱珍御服。着弊垢衣。执除粪器往到子所。八以贫所乐法诱摄拯救。即隐实施权恩。圆顿一乘隐而不说。乃以三乘人天小法教化众生。此上二句。即净名经第三香积品中。彼诸菩萨问维摩诘。今世尊释迦牟尼以何说法。维摩诘言。此土众生刚强难化故。佛为说刚强之语。以调伏之言。是地狱。是畜生。是饿鬼。是诸难处。是愚人生处。是身邪行。是身邪行报等。乃至云。如是刚强难化众生故。以一切苦切之言乃可入律。彼诸菩萨闻说是已。皆曰未曾有也。如世尊释迦牟尼佛。隐其无量自在之力。乃以贫所乐法度脱众生。斯诸菩萨亦能劳谦。以无量大悲生是佛土。九见其憍恣示迹涅槃者。示灭生善恩。故法华云。若佛久住于世。薄福之人不种善根。贫穷下贱贪着五欲。入于忆想妄见网中。若见如来常在不灭。便起憍恣而怀厌怠。不能生难遭之想恭敬之心。是故如来以方便说。比丘当知。诸佛出世难可值遇。乃至云。斯众生等闻如是语。必当生于难遭之想。心怀恋慕渴仰于佛便种善根。四十七经有涅槃佛事。与此大同。十留余福教以济危苦者。即悲念无尽恩。谓世尊同人中寿应寿百年。留二十年福以庇末法弟子。大集月藏分第十卷云。悲愍众生故舍寿。第三分令我法海满洗浴诸天人。假使毁禁戒。悉住不退地。若有挝打彼。即为打我身。若有骂辱者。则为毁辱我。又云。留白毫之福以覆弟子言留教者。即三藏八藏广益众生。依之修行皆得成佛。形像塔庙乃至舍利。一兴供养千返生天等

疏。故自顶至足下结成恩重

疏。得人下。引经证成。初即涅槃第二十八。不知恩者多遭横死。即此经四十八随好品。故经云下。三引他经(月藏分)先一偈具足经文。唯自利下取意引。彼亦一偈云。唯有传持正法藏。宣扬教理施群生。修习一念契真如。即是真报如来者。会意可知

疏。能离五邪者。即智论二十二。其第五。名称说所得供养以动人心。前四全同。疏瑜伽名善守根门者。即第二十三论云。云何根律仪。谓如有一能善安住密护根门防守正念。乃至广说。云何名为密护根门。谓防守正念常委正念。乃至防护意根。及正修行意根律仪等。疏净名云。所见色等者。即迦叶章。令迦叶以空聚想入于聚落。所见色于盲等。所闻声与响等。所嗅香与风等。所食味不分别。受诸触如智证。知诸法如幻相。无自性无他性。本自不然。今则无灭等。是故藏护诸根则不犯尘境。成六自在王。岂为六贼所劫夺耶

    贤首品第十二

疏。夫行不虚设等者。此有二来意。初对前行以成今德。后又前智首下。广前所成之德故次来

疏。令起圆融信行等者。天台智者。依此一品立圆顿止观。止观第一云。此菩萨闻圆法。起圆信。立圆行。住圆位。以圆功德而自庄严。以圆力用建立众生。今宗即圆法。意趣有五。一信。即起圆信。二行。三位。四德。五用。皆以上圆融贯之。彼释闻法云。谓闻生死即法身。烦恼即般若。结业即解脱。虽有三名而无三体虽是一体而立三名。是三即一相。其实无有异。法身究竟般若解脱亦究竟。般若清净余亦清净。解脱自在余亦自在。闻一切法亦复如是。是名闻圆法。云何起圆信。信一切法即空即假即中。无一二三而一二三。无一二三是遮一二三。而一二三是照一二三。无遮无照直入中道。皆究竟清净自在。闻深不怖。闻广不疑。闻非深非广意而有勇。是名圆信。云何行圆行。一向专求无上菩提。不余趣向。三谛圆修。不为无边所寂。不为有边所动。不动不寂直入中道。是名圆行。其位德用之圆。全引今经。若自取当经闻圆。即闻上同时具足等十种玄门。及依正无碍等。依此起信即是圆信。其圆行等。并广如前说。今此一品多广圆德用耳

疏。则与长行文有影略者。长行起后但起发心。偈中起后但起修行。故二处起后互为影略。就结前中长行有大功德无佛往修。偈有往修复阙功德。亦是影略

疏。一少言摄多义等者。上一意诸赞叹者多义偈者是也。第二意以偈有美妙文辞故

疏。后三开章下。此段有二。先正释经文。后此初发心下。问答料拣。于中有二问答。第一问发心浅深。第二问圆摄所以。前中

疏。以此甄别非无有异者。此中异下二处之文

疏。故缨络云发心住者。是人等者。证成发心通始义也。彼经第二初释经义品云。佛子。发心住者。是人始从具缚凡夫未识三宝圣人。未识好恶因之与果。一切不识不解不知。佛子从不知始。于凡夫地。值佛菩萨教法之中。起一念信。便发菩萨心。是人尔时信前名信相菩萨。亦名假名菩萨。亦名名字菩萨。其人略行十心。所谓信心。进心。念心。定心。慧心。戒心。回向心。护法心。舍心。愿心。又云。佛子。发心住是上进分善根人。若一劫二劫。乃至一恒二恒佛所。行十信心信三宝常住等

疏。明知此中发心。该于初后者。具缚未识初发为始。而一劫二劫修行方得初住。住前但名信相菩萨。居然通始终也

疏。问此既是初下。第二问答。显圆摄所以。于中先问。后古德下答。于中三。初正释本义。二傍序异释。三引妨会宗。初中二。先明行布。后二圆融通摄门下圆融。于中亦二。先正辨圆融。后此中有二门下。出圆融所以。于中三。初双标二门。二双释二门。三问答料拣

疏。前中普揽下。双疏二门。即分为二。就初门中又二。一正明缘相。广如玄中

疏。此经之中依斯义故下。二会释经文。言如下文十定不通等说者。定通二品。义该始终故。等者等取十忍。下经十忍之中。有音声顺忍等。谓约五忍明义。七八九地得于无生已过信顺。况于等觉。今明等觉有音声等故是摄初

疏。十住十行等说者。谓位位满处皆成佛故。一住若不收诸住。云何说得位满成佛。故十住后有灌顶住。海幢灌顶之后便说佛故

疏。如离世间品说者。离世间品具二千行法。如次配于住行。而不存其位名。但有与位相应之行故

疏。二法界融摄门等者。在文可知

疏。问下发心功德品下。第三问答料拣。有三问答。一会前后经文。二问约法相收是则可尔下。以法疑人。先问。后答。答言十千劫乃是一经。是即仁王经

疏。此经纵有行布下。三通伏难。谓有难言。如上所说既有行布。此与诸经复云何异。故今答云。行布乃是圆融之行布耳

疏。亦有引此下文下。第二傍序异说。即安国法师。于中有三。初正立。二引文证成。三辨顺违。初中意明。此中发心是初地证。发心非信成就发心。以其作用殊胜。非地前故

疏。以有则获灌顶而升位等。非是信故者。二引文证成。而言等者。彼有十义。以证此中非信成就。谓一以说断除疑网出爱流。便得坚固不坏心故。以若未入圣何。以度疑。若是凡夫何能不坏。入见谛者乃能度疑。信不坏故。二若未入地不应得有常持戒故。三不应云生如来家故。四凡夫不得身语意业常无失故。五不应则获功德法性身故。六不应云则获十地十自在故。七不应则获灌顶而升位故。八不应云则身充遍于虚空故。九何以菩萨具智慧故。十信大乘者。犹为易。能信此法倍更难故。岂有凡法难于圣法。故知此品正教舍凡展转乃至进入佛地。今疏文中略引彼证故。致等言是其一意

疏。若尔初地岂得灌顶下。辨非。文有五段。初正以其所引难其所立。但难其一余九例知。谓既十地中方得灌顶。纵是初地岂得灌顶。二若云展转下。假设彼救反以成立。三若许从信下。假纵彼救结破彼立。四下文自有下。广引文证。显彼立非。孟浪者出庄子。已见华藏品。五下发心品下。例破。后文所立非理。以彼下文亦判彼品为初地发心故。此既不立。彼居然非

疏。门下云无量亿劫勤修学下。第三引妨会宗。于中有二。先问后通。前中即此品文。安国坚执属证发心经多劫故。非是初心一生故也。亦非十千以为无量。遮救自义。况有救云无量即十千故

疏。通斯难者下通。通意可知

疏。第三亦兼修行者。以所具行位行即修行故。位即亦是修行之德。故云此及后二皆修行之德

疏。瑜伽菩萨地明等者。疏文有二。先释科文。行相之言便引瑜伽明具五义。而行相为总故为科目

疏。后因缘者下。牒经别释因缘之义。于中二。先以义略释。二后瑜伽云下。引文释。于中三。初引瑜伽。次引起信。后会当经。初中因缘之外更加四力。缘谓见闻境界。因谓内心发起。力谓有所干能。然即前四因正望发心以明力用。自力即从种性因发。他力即是善友所摄。因力即是自起悲心。加行力即长时苦行。又四力成就即名为因。亲能发故

疏。今经即初及三者。文中无人劝故。不言因加行故

疏。起信论智印经有七因缘者。论云信成就发心者。依何等人修何等行得信成就堪能发心。所谓依不定聚众生已有熏习善根力故。信业果报能起十善厌生死苦。欲求无上菩提。得值诸佛亲承供养。修行信心经一万劫。信心成就故。诸佛菩萨教令发心(一)或以大悲故能自发心(二)或因正法欲灭。以护法因缘故能自发心(三)如是信心成就得发心者。入正定聚。毕竟不退。名住如来种中正因相应。若有众生善根微少等。未经一万劫。于中遇缘亦有发心。所谓见佛色相而发其心(一)或因供养众僧而发其心(二)或因二乘之人教令发心(三)或学他发心(上有四缘)如是等发心悉皆不定。遇恶因缘。或便退失堕二乘地。智印同此

疏。信谓于实德能。深忍乐欲心净为性者。唯识第六云。云何为信。于实德能深忍乐欲。心净为性。对治不信乐善为业(此总明体业)。然信差别略有三种。一信有实。谓于诸法实事理中深信忍故。二信有德。谓于三宝真净德中深信乐故。三信有能。谓于一切世出世善深信有力能得能成起希望故。释曰。实德能三即信依处。忍乐欲三如次配之。言能得能成者。信己及他。今得后成。又无为得有为成故。论云。由斯对治彼不信心。爱乐证修世出世善。释曰。上释信业。下欲拣别。故又问答。论云忍谓胜解。此即信因。乐欲谓欲。即是信果。确陈此信。自相是何问也。岂不适言。心净为性。此犹未了彼心净言。若净言即心应非心所。若令心净惭等何别。心俱净法为难亦然。释曰。此中三难。初持业释。次依主释。后邻近释。言为难亦然者。同前惭等何别。亦是心王俱时法故。论曰。此性澄清能净心等。以心胜故立心净名。如水清珠能清浊水。惭等虽善非净为相。此净为相无滥彼失。又诸染法各别有相。虽有不信自相浑浊。复能混浊余心心所。如极秽物自秽秽他。信正翻彼故净为相也(正义竟)。有说。信者爱乐为相。应通三性。体应即欲。又应苦集非信所缘(此破小乘上座部)有执。信者随顺为相。应通三性。即胜解欲。若印顺者。即胜解故。若乐顺者。即是欲故。离彼二体无顺相故(此破大乘异师也)由此应知。心净是信结也。然今疏文略引标释义已周备。今法宝下以论配经。复有二意。一者别配。谓法有事理。即是初实也。法有理行即出世善等故。是后能故。云今法宝中已摄初后。后亦三宝中皆具此三者。义以前三通于三宝。如文可知。次大者下。释下句也

疏。别中下。上释总偈竟

疏。初半偈拣去偏伪者。即天台止观中意。然有二文。一当第五卷明十法成乘。中有真正发菩提心。故云拣去偏伪。故下疏云。有二乘心者。名之为偏等。二者第一卷中明有五略。谓发大心。修大行。感大果。列大网。归大处。今即第一发大心中文。然彼复分为三。初方言。次拣非。后显是。方言易了。今将不求一行当彼拣非也。余文即当显是。今初。彼文云。道亦有通有别。今亦拣之略为其十。若心念念。专贪嗔痴。摄之不还拔之不出。日增月甚起上品十恶。如五扇提罗者。此发地狱心行火途道(一)若其心念念。欲多眷属。如海吞流如火焚薪。起中品十恶。如调达诱众者。此发畜生心行血涂道(二)若其心念念。欲得名闻四远八方称扬叹咏。内无实德虚比贤圣。起下品十恶。如摩揵提者此发鬼心行刀涂道(三)若其心念念。欲胜于彼。不耐下人轻他珍己。如鸱高飞下视人物。而外扬仁义礼智信。起下品善心。行阿修罗道(四)若其心念念。欣世间乐。安其臭身悦其痴心。此起中品善心行于人道(五)若其心念念。知三恶苦多。人间苦乐相间。天上纯乐。为天上乐。闭六根不出。六尘不入。此上品善心行于天道(六)若其心念念。欲大威势身口意业。才有所作一切弭从。此发欲界主心行魔罗道(七)若其心念念。欲得利智辩聪。高才勇哲。鉴达六合。十方颙颙。此发胜智心行尼揵道(八)若其心念念。五尘六欲外乐盖微。三禅之乐由如石泉其乐内熏。此发梵心行色无色道(九)若其心念念。知善恶轮环凡夫耽湎贤圣所诃。破恶由净慧。净慧由净禅。净禅由净戒。尚此三法如饥如渴。此发无漏心行二乘道(十)若心若道其非甚多。略举十耳(结)今疏欲具此十非故。于经文。委曲而取耳。于疏文中分二。先总明。即瑜伽意。后文中不求五事下。正释经文配成十非。然不必全尔故致多言。以随一烦恼有三涂因故。又但取意略明。但寻上引疏文。居然易了。但人天因含其三界也。一人。二欲天。三上二界。余文可知。有二乘下结成。即前九为伪。后一为偏也

疏。其中对上四因四缘可以意得者。深心信解。及深信诸佛及佛法。即第一种性具足因。恭敬尊重一切佛。即第二赖佛菩萨摄受因。以恭敬故。但为永灭众生苦。即第三多起悲心也。常欲利乐诸众生庄严国土供养佛。即第四长时猛利难行苦行也。四因具矣。言四缘者。恭敬尊重一切佛者。以见闻神变威力故。即第一缘。受持正法修诸智者。以闻法微妙故。即第二缘。又受持正法者。见法欲灭故。即第三缘。但为永灭众生苦者。即见生受惑业苦。是第四缘也。见苦即缘。长悲即因。故虽一文因缘具足。此中四力不具故不会之

疏。又上从不求五欲下。重解经文以上来所解参古德意。此下一向新意不干旧解。文自有五。一约信德。二约菩提意。三约佛性。四约四弘。五结归真正。今初。则经文五偈应分为二。初一偈标信发心。后四偈彰信之德

疏。今文并具但不次耳者。彼经次云。一亲近善友。二供养诸佛。三修习善根。四者志求胜法。五心常柔和。六遭苦能忍。七慈悲深厚。八深心平等。九爱乐大乘。十求佛智慧

疏。四有三字者。以供养佛字全同故

疏。又此十德即求菩提之意者。第二明菩提意。而云发菩提心等者。彼广有文。略举十四广结无边。今但举一以等十三。谓二欲承事供养一切诸佛。悉无余故发菩提心。其悉无余下八字一一皆有。三欲严净一切诸佛国土。四欲护持一切诸佛正教。五欲成满一切如来誓愿。六欲往一切诸佛国土。七欲入一切诸佛众会。八欲知一切世界中诸劫次第。九欲知一切众生心海。十欲知一切众生根海。十一欲知一切众生业海。十二欲知一切众生行海。十三欲灭一切众生烦恼海。十四欲拔一切众生烦恼习气海。悉无余故发菩提心。善男子。以要言之。菩萨以如是等百万阿僧祇方便行故发菩提心。善男子。菩萨行普入一切法皆证得故。普入一切刹悉严净故。是故善男子。严净一切世界。尽我愿乃尽。拔一切众生烦恼习气。尽我愿乃满。释曰。上皆菩提心所为也。对今经文可以意得

疏。末后偈初句下。三。约佛性。即随难重显种性具足三佛性义。即佛性论第二卷第三显体分三因品。论云。复次佛性体有三种三性所摄义。应知三种者。所谓三因。三种佛性三因者。一应得因。二加行因。三圆满因。初即二空所显真如。由此应得菩提心。乃至道后法身故。二加行因者。谓菩提心。由此心故。得三十七品。十度十地。乃至道后法身。三圆满因者。即加行因。由此故得一切圆满。三种佛性者。应得因中具有三性。一住自性性。二引出性。三至得果性。释曰。住自性者。谓道前凡夫位。引出性者。从发心已上穷有学圣位。至得果性者。无学圣位

疏。又文有四弘可以意得者。四约四弘也。文中不求五欲等。即显烦恼无边誓愿断。但为永灭众生苦。即众生无边誓愿度。受持正法修诸智。即法门无尽誓愿学。证菩提故。即佛道无上誓愿成。故四具矣

疏。又上云深心信解常清净下。第五结归真正。于中二。先显真正菩提心体。后正结归。前中意有其三意。初约三心菩提。二约三观。三约四弘。今初。初明大智心。次慨众生迷此下。大悲心后悼昔不知下。大愿心即菩提心。灯大悲为油。大愿为炷。大智为光。光照法界故。上如次即直心。大悲心。深心也。二约三观者。悲愿是假观。前大智心中直明本性清净。即是空观。烦恼即菩提本来是佛。即中道观。三约四弘者。初通立理以是圆教四弘故。称性明之。从信烦恼即菩提下。别显四弘。初即烦恼无边誓愿断。二由称本性而发心故下。即佛道无上誓愿成。三慨众生迷此下。众生无边誓愿度。四悼昔不知下。法门无尽誓愿学。此明四弘通指上四弘。上但指文。今将深心之言会通此四令圆妙耳

疏。有悲故不为无边所寂下。正结归。谓上虽多义不出悲智故今结之。即结上疏文及经耳。故止观第五明十法成乘中。第二真正发菩提心云。既深识不思议境一苦一切苦。自悲昔苦起惑耽湎。乃至云思惟彼我鲠痛自他。即起大悲兴两誓愿。众生无边誓愿度。烦恼无边誓愿断。众生虽如虚空誓度如空之众生。虽知烦恼无所有。誓断无所由之烦恼(上二即空观)虽知众生甚多。而度多多之众生。虽知烦恼无边底。而断无边底之烦恼(假观)虽知众生如佛。而度如佛之众生。虽知烦恼如实相。而断如实相之烦恼(中观)何者。若但拔苦因拔苦果此誓杂毒故须观空。若偏观空则不见众生可度。是名著空者。诸佛所不化。若偏见众生可度则堕爱见大悲非解脱道。今则非毒非伪故名为真。非空边非有边故名为正。如鸟飞空终不住空。虽不住空迹不可寻。虽空而度。虽度而空。是故誓与虚空共斗故。名真正发菩提心。释曰。此上释须三观所以。又云又识不思识心一乐心一切乐心。我及众生昔虽求乐因不知乐因。如执瓦砾谓如意珠。妄指萤光呼为日月。今方始解故起大悲兴两誓愿。谓法门无尽誓愿知。无上佛道誓愿成。虽知法门永寂如空。誓愿修行永寂。虽知菩提无所有。无所有中吾故求之(上即空观也)虽知法门如空无所有。而有誓愿画绘庄严虚空。虽知佛道非成所成。如空中种树使得华果(名假观也)虽知法门及佛果非修非不修。非证得非不证得。以无所证而证而得(中观也)是名非伪非毒。名之为真。非空非爱见。名之为正。如是慈悲誓愿。与不思议境智。非前非后同时俱起。慈悲即智慧。智慧即慈悲。无缘无念普覆一切。任运拔苦自然与乐。不同毒害。不同但空。不同爱见。是名真正发菩提心。释曰。但观上所引之文。疏文居然易了。即撮其大意而为此疏显经深玄。然此经上下菩提心义。文理渊博。见其撮略故。取而用之。引而证之

疏。第二信为道元下。此段多易。但云一本义菩提本故者。意以本义为果德元。首义为因德元耳。言元者善之长也。即周易乾卦文言。释乾元亨利贞四德云。元者善之长也。亨者嘉之会也。利者义之和也。贞者事之干也。君子体仁足以长仁。嘉会足以合礼。利物足以和义。贞固足以干事。君子行此四德者。故曰乾元亨利贞。今但用其一字义耳

疏。不信身心下。反成上义。知见相为菩提。知见性为涅槃。故法华论释开佛知见。为无上义。谓双开菩提涅槃疏。如意珠略有五义者取与信相应义耳。若准宝性论。宝有六义。颂云真实(一)世希有(二)明净(三)及势力(四)能庄严世间(五)最上不变等(六)。今此胜义摄真实最上二义。余四则同。四即势力。五即庄严。或无庄严加此蕴义。然疏五义皆言含法喻。思之可知

疏。尚不得疥癞野干等者。即萨遮尼揵子经第四

疏。初三颂明十住等者下。明诸位。皆含义理。并如本品。但言增上是不退住者。由前正心但闻赞毁不动。今闻无有利害更深而心不退故为增上。余如下文寻之。然皆隐位名存其中行。或合或开。或略或广。不全次第者。意明圆融信门即顿具故。亦犹离世间品。六位顿具故。亦顿成二千行。位位顿修故。若一向次第者。但得行布一分义耳

疏。以若有彼则有此者。拣滥。明此是圆融义。才得一位即得一切位。如十味香才烧一丸。如小芥子十气齐发。若有闻香十味齐闻。若得沈气时。则得檀气。若得酥合则得龙脑等。十味丸药服者齐得。亦准此知。非如钩锁由得于前方能得后。非如涉路若行一里即得二里。若行二里则进三里。故此位中不在位名。或开或合。正在于此。思之思之

疏。略辨十门三昧业用者。然还源观。立一体二用三遍四德五止六观。亦不出此。言一体者。即自性清净圆明体。即通为十定之体。言二用者。一海印森罗常住用。即此第一三昧。二法界圆明目在用。即华严三昧。言三遍者。一者一尘普周法界遍。二一尘出生无尽遍。三一尘含容空有遍。此三并是因陀罗网三昧门。言四德者。一随缘妙用无方德。二威仪住持有则德。三柔和质直摄生德。四普代众生受苦德。即次下第六三昧门。言五止者。一照法清虚离缘止。二观人寂怕绝欲止。三性起繁兴法尔止。四锭光显现无念止。五事理玄通非相止。言六观者。一摄境归心真空观。二从心现境妙有观。三心境秘密圆融观。四智身影现众缘观。五多身入一镜像观。六主伴互现帝网观。上之止观并是寂用无涯三昧门。故此十门无不收矣。广释一体六观等具如还源观辨

疏。海印之义下。疏文分四。一标章。二总明。三别示义类。四总结料拣。初一可知

疏。下经云。如净水中四兵像下。第二总明也。即引当经及于他经。以示能现所现海印之相。言乃至莫不皆于水中现者。其中间云。各各别异无交杂。剑戟弧矢类甚多。铠胄车舆非一种。随其所有相差别。莫不皆于水中现。而水本自无分别。菩萨三昧亦如是。即第十五经

疏。又云海有希奇等者。即此卷中下合云。无尽禅定解脱者。为平等印亦如是。福德智慧诸妙行。一切普修无厌足

疏。大集十四云下。引他经文。疏文分二。先正引。后解释。前中即虚空藏菩萨品头。有一善男子言。此中亦尔。经云亦复如是余皆全同

疏。然此经文下。解释。此即此上大集。言出现四天下像等者。文云。佛子。譬如大海普能印现四天下中一切众生色身形像。是故共说以为大海。诸佛菩提亦复如是。普现一切众生心念根性欲乐而无所现是故说名诸佛菩提。下偈文云。如海印现众生心。以此说名为大海。菩提普印诸心行。是故说名为正觉

疏。言十义下。第三别显义类也

疏。经云遍十方故者。即是今经。于一念顷遍十方也。言普悉包含无所拒者。即指上引。十义所引皆上总中。所引之经。及出现品。文多易了。但第十云以不待对是故常现者。此以第十释成第九即为拣异。由十成九故云释成。而九竖论。十是横说。故为拣也

疏。具上十义下第四总结。于中先正结。后问仁王三贤下。问答料拣。先问。后答。问即上卷菩萨教化品。经云。若菩萨住百佛国土中。作阎浮提王王四天下。修百法明门。二谛平等心化一切众生。下偈云。善觉菩萨四天下双照二谛平等道。权化众生游百国。始登一乘无相道。释曰。此前更无成佛之文

疏。答即上所引大集下。第二答中有三。初指前引答。二别引文答。三况出圆融。今初。谓上引大集灌顶即第十住。故云彼说住终。则初贤已得八相。何得偏引仁王三贤无文

疏。若占察经下。次引别文答。谓占察经作佛有四。初是信满。正与今文相当。余三因便故来耳。二解满作佛即同前大集灌顶受位。三证满者。初证名证满故。云净心地即初地故。四究竟菩萨地。即第十地后故。起信云。菩萨地尽觉心初起心无初相。以远离微细念故得见心性。心即常住名究竟觉是也

疏。起信依此下。上正引经。此方引论。用信成就发心即第一信满位。论云。菩萨发是心故。则得少分见于法身。以见法身故随其愿力能现八种利益众生。所谓从兜率天退。入胎。住胎。出胎。出家。成道。转法轮。入涅槃。即八相之文也

疏。况圆融门中不依次位者。三况出圆义也。则上所引尚是行布。以四位成佛深浅不同故。今初即具后故是圆融。今约信满犹寄终教说耳

疏。因果无碍下。通伏难。谓有难云。若初即后应坏因果故。故为此通明其无碍。正在因时即有果。果中有因。随门不同名因名果。体无前后故得圆融。双存则亦因亦果。俱泯则果海离言

疏。又此化现非唯一位依一类界者。重拣前文以圆融。非唯一位则显具一切地位。非依一类界则显遍于时处也。第二华严三昧

疏。万行如华严法身故余如别说者。遗忘集说。略有十观。一摄相归真观。二相尽证实观三相实无碍观。四随相摄生观。五缘起相收观。六微细容摄观。七一多相即观。八帝网重重观。九主伴圆融观。十果海平等观。然此十观融四法界。初二理法界。始终不异。三即事理无碍法界。四即随事法界。次五即事事无碍法界。五即一多相容不同门。六即微细相容安立门。七即诸法相即自在门。八即因陀罗网境界门。九即主伴圆融具德门。其第十观果海绝言。通为前四之极。则四法界十种玄门皆约因分。然此十观略收万类不异玄中故指在余。又释题中广显华严义竟。又还源观释云。广修万行称实成德。普周法界而证菩提。如华有结实之用。行有感果之能。今则托事表彰。所以举华为喻。严者。行成克果。契理称真。性相两亡。能所俱绝。显焕炳着故名严也。良以非真流之行无以契真。何有饰真之行。不从真起此。则真该妄末行无不修。妄彻真源相无不寂。故曰。法界自在圆明无碍用为华严三昧也。若更总释。总以万行严于法界。成于法身为华严也。行有行布圆融。成佛亦有十身总别。别如普眼长者以十波罗蜜严成十身。融如八地一念之中十度圆修。成佛之时十身无碍。故曰华严。余如题中。第三因陀罗网三昧中

疏。次半颂举一例余。亦有二意者。前意对前第一意。既一尘之中有多尘向来。方说一尘摄刹。今方说尘内所具余尘摄刹。后意对前第二意。此所例尘非前尘内。是前尘外遍法界中尘也

疏。由于昔时以手持供供佛施人称周法界者。此出因也。供佛施人约其施行。称周法界约其施心。入深观故

疏。故令真流供具等诸佛之难思者。显今果也。真流供具显出供时心以称法界。手出供具故。等诸佛之难思者。称因境也。因虽尊胜。心不称境非真供养。由称真之因感称真之果。能供真佛之境

疏。初半对治等者。对治文显。随心所乐为世界者。顺心令喜故。随行差别即当为人者。心行不同生善异故。如心寂静应教禅定。若心明利为说智慧。悉以善巧而成就文。则连上属于为人。第一义者。谓要见理。见理方得名成就耳。又成就言通于上三。前三悉檀皆为见理故

疏。第六四摄摄生三昧。布施摄中。前二偈有两重释。先约财施。所须王位皆属外财故。王位兼于身命。亦属内财

疏。又此施位下。第二重释次半偈。可爱着物即三种难行之一。次法及无畏兼前财。三为一切施。又将后二属于遂求。然准瑜伽六度四摄各有九门。颂云。自性一切难。一切门善士。一切种遂求。二世乐清净。自性皆一。一切或二或三。难行皆三。一切门皆四。善士皆五。一切种皆六。遂求皆七皆八。二世乐皆九。清净皆十。四摄即当三十三卷。至十行品更说其相。今疏言即难行者。以难行有三。一物少自在施。二可爱着物施。三极大艰难获财施。今当第二难也

疏。又后二偈至随求即与者。是遂求施。遂求有八。一匮乏饮食而求乞者施以饮食。二匮乏车乘而求乞者施以车乘。三乏衣服。四严具五资生什物。六种种涂饰香鬘。七舍宅。八光明。皆如初二句会文可知

疏。一切爱语等者下所列。即三爱语。一慰喻爱语。二庆悦爱语。三胜益爱语

疏。言种种梵音者。即八种梵音等者。文中具列初二。疏释后六但标。若释应云。三调和谓大小得中。四柔软者。言无粗犷。五不误者。言无错误。六不女者。其声雄朗。七尊慧者。言无战惧。八深远者。脐轮发声

疏。随心说法应在后偈者。以后偈说八万法门。是顺正法教语故。应合云随心为说。前偈种种梵音故。是随世仪轨。合言随世所宜而化诱

疏。初颂一切同事者。瑜伽同事不举别相。但同上利行即名同事。故利行居先则示同。利衰等为一切也。等取毁誉称讥苦乐。忍于诸苦而同事故者。难行有三。亦无别相。即同三利行为三难行同事。谓一诸未行胜善根因。诸有情所行利行。二现在耽着广大财位众具圆满。诸有情所行利行。三于外道异执邪见邪行。所行利行。同事例耳。今于上三同事皆须忍苦

疏。一即十种清净利行者。谓一依外清净有五。二依内清净有五。依外五者。一无罪利行。二不转利行。三渐次。四遍行。五如应。论广释其相。依内清净有五者。一谓诸菩萨。于诸有情起广大悲。意乐现前而行利行。二诸菩萨。于诸有情起所作义利。虽受一切大苦。劬劳而心无倦。深生欢喜。为诸有情而行利行。三安处最胜第一财位。而自谦下如子如仆。及离憍慢而行利行。四心无爱染无有虚伪。真实哀愍而行利行。五起毕竟无复退转。慈愍之心。而行利行

疏。次三句即善士利行者。善士有五。一于真实义劝导有情。二于应时劝导。三于能行摄胜妙义劝导。四于有情柔软劝导。五于有情慈心劝导。此之五相。皆是大人之法。慈心劝导举后等初

疏。次二偈即遂求利行者。论云。此略有八。谓诸菩萨见诸有情于应惭处。为无惭缠之所缠绕。方便开解令离彼缠如无惭缠。二无愧。三昏沉。四睡眠。五掉举。六恶作。七嫉。八悭。皆如无惭缠说

疏。次二偈即一切种利行者。彼说或六或七总有十三。六者。一应摄受者正摄受之。二应调伏者正调伏之。三憎背圣教者除其恚恼。四处中住者令入圣教。五于三乘中令其成熟。六已成熟者令得解脱。云何七种。谓诸菩萨安处一分所化有情。于善资粮。守护长养。所谓一依下乘出离。二依大乘出离。三于远离。四于心一境性。五于清净诸障。六于二乘而正安处。七于无上正等菩提而得安处

疏。后一偈即一切门利行。谓不信令信故者。此略有四。一不信令信。二犯戒有情令戒圆满。三恶慧有情令慧圆满。四悭吝有情于舍圆满。今疏文中略举其一

疏。瑜伽广说利行居先等者。会二前后。可知

疏。婆沙七十九等者。彼云。毗奈耶说。世尊有时为四天王。以南印度边国俗语说四圣谛。谓医泥迷泥瑜部达[甲*葉]剌蔑戾车语。说四圣谛。谓摩奢都奢僧摄摩萨缚怛啰毗剌达。论引净名圆音为难。下释有七。一云。有作是说。佛以圣语说四圣谛。能令一切所化有情皆得领解。何以作此等语说。答为满彼意故。彼天欲闻故。下并取意引之。二复次世尊欲显于诸言音皆能善解故。谓有疑。佛不能余语等。三复次有所化者。依佛不变形言而得受化。有所化者。依佛转变形言而受化者。四复有说者。佛以一音说四圣谛。不能令一切所化有情皆得领解。世尊虽有自在神力。而于境界不能改越。如不能令耳见诸色等。通圆音云。答不须通。非三藏故。诸赞佛颂言多过实。如常在定不睡眠等皆过实也。五复次如来言音遍诸声境。随所欲语皆能作之故。复伽陀作如是说。六复次佛语轻利速疾转故。故云佛以一音演说法。众生各各随所解。七复次如来言音虽有多种。而同有益故说一音。释曰。然上七解。前三可通。后四浅近。即彼小乘三藏说故

疏。篾戾车者。三藏云恶中恶。亦云奴中奴。皆义翻耳。

大方广佛华严经随疏演义钞卷第三十五大方广佛华严经随疏演义钞卷第三十六

        唐清凉山大华严寺沙门澄观述

疏。第八毛光照益三昧中。言智契解脱之门等者。总出光明之因具悲智故。先此上一句约智。亦是约表释。谓毛孔表解脱门。光明表于智慧故。二正明智慧故。云智契解脱之门

疏。慈熏身语意业者。约悲智释。以菩萨旷劫慈悲熏修三业故

疏。后具一四总持者。一法持。二义持。三咒持。四无生忍持。如七地中广说。四持并具。何不自在

疏。不以不见疑菩萨之无光等者。此下别释绝疑之义。绝于三疑。一以不见疑无光明。二不救剧苦谓光无益。经文以如盲不见日等双释二疑。三亦不高推果用下。又遣一疑。谓此作用是佛果用非十信故

疏。既言量等三千。则不坏次第等者。此亦遮其不信十信八相成道。谓十地方能故云不坏次第。谓十地菩萨受职。有大莲华量等百万三千大千世界。十定品辨等觉菩萨有一莲华量周法界。周法界唯大。百万亿中但言三千故劣后二。今疏十二颂六对。一一对中有十义五对等者。疏文分六。初总标。二欲辨无碍下。总辨定慧。三言五对下。正明无碍。四上来无碍下。总示入门。五又向云色性下。彰其含摄。六此是菩萨下。总结劝修。初文可知。就第二总辨定慧之中三。初总指当文定慧之相。二定慧虽多下。彰其类别。后所以局见之者下。总示得失。二中又二。先总辨为二。二者用二不同。今初

疏。制之一处无事不办者即遗教经文。然亦可通理。以其先后类例多约事故。即是彼经八大人觉中第二明精进初云。汝等比丘。已能住戒。当制五根勿令放逸。乃至云。此五根者心为其主。是故汝等当好制心。心之可畏甚于毒蛇恶兽怨贼。大火越逸未足踰也。喻如有人手执蜜器。动转轻躁。但观于蜜不见深坑。譬如狂象无钩猿猴得树。腾跃跳掷难可禁制。当急挫之。无令放逸。纵此心者丧人善事。制之一处无事不办。是故比丘当勤精进折伏汝心

疏。能观心性契理不动者。上句即涅槃经意。彼第二十七师子吼品云。以彼立三品定故。经云。善男子。一切众生具三种定。谓上中下。上者谓佛性也。以是故言一切众生悉有佛性。中者。一切众生具足初禅等。下者。十大地中心数定也。今但义引耳。从契理不动即义说也。观其心性即是观门。而云定者心性是理观。即契理与理相应。湛然不动故名为定

疏。明达法相事观者。如起信等

疏。善了无生者。即七地经云。了法无生名般若是也

疏。诸经论中或单说事定等者。即第二用二不同也

疏。如起信论止一切相乃至等者。论云。云何修行止观门。所言止者。谓止一切境界相。随顺奢摩他观义故。所言观者。谓分别因缘生灭相。随顺毗钵舍那观义故。云何随顺。以此二义渐渐修习不相舍离。双现前故。次论云。若行若住若卧若起。皆应止观俱行。所谓虽念诸法自性不生。而复即念因缘和合。善恶之业苦乐等报不失不坏。虽念因缘善恶业报。而亦即念性不可得。释曰。此中先止不碍观。后观不碍止。皆止约入理。观约观事。第一经中已广引文。兼辩大意。以疏对论文相可知

疏。或以理观对于事定言下。经一心不动等者。即七地偈文。然今经云。于道不动即修禅。忍受无生名般若。盖其义引小有不同

疏。禅定持心常一缘等者。即第三十三经。彼具明十度云。如其回向行布施。亦复坚持于禁戒。精进长时无退怯。忍辱柔和心不动禅定下同。今此但取明定慧文耳

疏。言五对者下。第三正明无碍。于中先别明。后总结。前中五对即为五别。然其五对皆约经文。取文不同。第一对取根境。如初偈将上于眼根中对下于色尘中作义。于中有三。初明根入境出。二为显下。出所以。所以无碍者。略有三义。一唯心现故。二缘起相由故。三法性融通故。广如玄中。以是最初故。具出所以。下多总略。三境入根出亦然。即例释后偈

疏。第二对者。即于入正定中作义。于中文四。一正明

疏。分别事相等者。缘从色尘中出。明知眼根中入是其理定

疏。欲观性空等者。缘于眼起等是理起。明知色尘中入是事入。二以契即事之理下。出所以。唯约事理无碍明所以。于中二。先成上分别事相应入事定而入理定。后制心即理之事下。成上欲观性空。应入理定而入事定。三而经中但云下。出二定得名所以。显上入正定所对之文。由对观故。四亦合将根事对于境理以辨无碍者结例。谓合有二偈云。于眼根中入正定于色起定。心不乱。了色无生无有起。性空寂灭无所作。于色尘中入正定。于眼根中三昧起。分别眼性不思议。诸天世人莫能知

疏。第三对理事无碍等者。即约经文从定起。对于后半以作义。疏文有三。初正明。次以所观下出所以。三亦应下反例。初中疏文但作初偈不作后偈。若具应云欲了真理。应从理观起。而反从事观起。谓前偈示现色性。是事则色尘中三昧起。义当理观也。后偈说眼无生无有起。是理性则前眼根起定心不乱义当事观。出所以可知。疏亦应将境事理对根理事。以辨无碍者。三反例此意稍隐。先应问言。上辨二定但云亦合将根事对于境理。今何双言将境事理对根理事故。应答言。以上二定不能自别。要因起观方知事理。如眼入定未知何定。以见尘上了色差别。是其事观欲令无碍故。说根中入定是其理定境入根起既了根性空故。说境中入于事定。则经文中。已辨根理对于境事。故但合例以将根事定对于境理。今此二观不因定别。根上境上各有二观。谓根入定即于境上从理观起而分别事。于色入定即于根上从事观起分别于理。经文已有此二未于境上从事观起。分别于理。及与根上从理观起。分别于事。若作偈者。应云于眼根中入正定于色尘中事观起。说色无生无有起。性空寂灭无所作。及于色尘中入正定。于眼根中理观起。分别一切上妙眼。诸天世人莫能知。斯则境上事起观理。以对根上理起观事故。云亦应以境事理对根理事以辨无碍也

疏。第四对出入无碍者。即于经入正定对从定起言及起定不乱。作义于中二先正明。后若以事理相望下。句数料拣。事理四句但出其二。等取余二。谓三理入事起。四理入理起。上且单说有其四句。若单复相望应成九句。于前四上更加五句。谓事入事理起。理入事理起。事理入事起。事理入理起。事理入事理起。故为九句。疏又成四句。即根境出入成四。但举其一。若具应云二境事入根事起。三根理入境理起。四境理入根理起。若更交络乃成十句。五谓根事入境理起。六境事入根理起七根理入境事起。八境理入根事起。九根事理入境事理起。十境事理入根事理起。以其事理相望。属前事理四句故但云四耳

疏。第五对二利体用无碍者。此有两重无碍。一体用无碍。二二利无碍。下双牒释。言心不乱是体者。全用根起三句。以对境起中后二句。作义则根起三句为体亦为自利。谓于眼起定心不乱说眼无生无有起。性空寂灭无所作。而言不碍现于广境者即取前示现色性不思议。诸天世人莫能知为广境。亦全用此二句为利他。疏良以下。以体用无二。释二利无碍。然上疏但约眼色根境以为体。例后五根境可知

疏。此上十义同为一聚下二总结十对也。于中又二先正结。后又经且约根境下。例显若境境相对即下于自他身自在中摄故。此不明根根相对等。但略无耳。例亦合有。若具说者。应云于眼根中入正定于耳根中从定起。示现耳性不思议诸天世人莫能知。于耳根中入正定从眼起定心不乱。说眼无生无有起。性空寂灭无所作等。成六根互用。疏一尘入正受多根从定起等者。亦略无耳。若具应云于色尘中入正定。于六根中从定起。示现六根不思议。诸天世人莫能知。于六根中入正定。于色起定心不乱。说色无生无有起。性空寂灭无所作等。复应有一根入多尘起故云等也。等字等于两重。一等多根入一尘起。二等一根入多尘起。若具应云于眼根中入正定于六尘中三昧起。分别六境不思议。诸天世人莫能知。于六境中入正定眼根起定心不乱。说眼无生无有起。性空寂灭无所作。余根对尘亦然故云并略不说

疏。上来无碍深妙难思下。第四总示入门。先问。后今当下。正示知事理无碍根境亦如总观也。念虑不生总止也。即禅门大意

疏。又向云色性难思下。第五彰其含摄。于中又二。先收总持等。会佛名经。后约三观会通智论。前中然十二入。约其含摄并称总持。约其性空究竟并称波罗蜜。约其性本清净皆解脱门。约其觉性圆明并得称佛。故佛名经云眼陀罗尼自在佛。乃至意陀罗尼自在佛。色陀罗尼自在佛。乃至法陀罗尼自在佛等

疏。不唯取相为染无心为净而已者。结弹北宗禅门但得一分之义。谓彼云眼见色意同知染法界。意不同知净法界。意同知即眼陀罗尼自在佛。眼等总持度门等者。今谓亦是一义。但得不起心之义耳。不同上来十重五对无碍自在等

疏。又以智论三观下。第二以三观会智论。于中有三。初明三观。次辨三止。后双结上二。初中先明次第三观。后三无前后即一心三观。言此二不二色性难思中道观也。此有二种中道。一但合上二以为中道。此之中道大乘初门。二色性难思即佛性中道。斯为圆妙欲辨包含故双出耳

疏。对此三观下。辨三止。一方便随缘止。即假观家止。谓方便涉有随一一缘住一境故。二体真止。即空观家止。体达真理与理冥故。三离二边分别止。即中道家止。不取有无等二相也。以上对经文之次故。以假观为初。今对上观亦以方便居首。若准智论中。先空次假后中义如前辨

疏。既止观双运下。三双结上二。于中又二。先结止观。诸处多明一心三观。既有双运则亦合言一心三止。若具亦可言一心三止观也

疏。即一而三。下二结三一通于止观。即一而三体随相用故。即三而一相用即体故。双照三一体用显然。双遮三一互夺双泯。谓即体同用故。非一即用同体故非三也

疏。一一释文准思可见者。今将三观以对经文三观。以遮照等亦然。谓色相难思是假观。眼定即是随缘止。性空寂灭是空观。色定即是体真止。色性难思是中观。眼根即是离二边分别止。以色性有三义。若以变碍为性即假观摄。若以真实难思为性即中道摄。故二观皆用双运即是根境对辨。二俱宛然即是双照。二俱无碍互夺双亡即是双遮

疏。此是菩萨圆融功德等者。第六总结劝修可知第五喻况玄旨中

疏。众生含其前三者。以业报二字是第四故则初一含四

疏。菩萨神力由三种相除佛后二者以无障碍约二障尽故。成立有情未周遍故。疏然取分喻者。由上云无可同喻今何喻耶。故云分喻。无可喻者下经云。三界有无一切法不能与佛为譬喻故。言分喻者。喻有八种。一顺二逆三现四非五先六后七者先后八者遍喻。如涅槃说前文已引则有遍喻。今对遍喻但取少分。如言佛面犹如满月。但取圆无缺义故。今喻亦然。以小喻大者。若易中射隼于高墉。以况天下等其事甚多。疏令闻喻者。忘象领意故褒以智者。周易略例云。夫象者出意者也。言者明象者也。尽意莫若象。尽象莫若言。言生于象故可寻言以观象。象生于意故可寻象以观意。意以象尽。象以言着。故言者所以明象。得象而忘言象者所以存意。得意而忘象。犹罤者所以在兔。得兔而忘罤。筌者所以在鱼。得鱼而忘筌也。然则言者象之罤也。象者意之筌也。是故存言者非得象者也。存象者非得意者也。象生于意而存象焉。则所存者乃非其象也。言生于象而存言焉。则所存者乃非其言也。然则忘象者乃得意者也。忘言者乃得象者也。得意在忘象。得象在忘言。故立象以尽意。而象可忘也。重画以尽情而画可忘也。是故触类可为其象。合义可为其征。今疏用此文故令忘象领意。谓如水现四兵。是喻是象但知菩萨无心顿现。则水印可忘矣。诸喻皆然。若能忘象得意斯为智者。执象失意乃成愚滞故。法华云。诸有智者以譬喻得解。疏江南之人。不信千人之毡帐者。即颜之推。字介文。家训归心篇中之语也

疏。为毒涂鼓者。即涅槃第九如来性品云。复次善男子。譬如有人以杂毒药用涂大鼓。于众人中击之发声虽无心欲闻闻之皆死。唯除一人不横死者。鼓合涅槃。死喻灭惑。不横死者。喻一阐提。终成坚种者。即下出现品如上频引

    第三会升须弥山顶品第十三

疏。信前此解者即疏本意。疏以前信会答第二会。初所脱信问故。次住有二段。即古德意

疏。二品名须弥下。疏文有二。先正释。后表位下约表法释于中四。一正约表。二若天表净下。假问征起。三妙有十义下。通释上问。四若约观心下。约观心释。前三可知三中分四。一约能表。二十住之行下合所表。三显十住功德下结所释。四然上所释下拣权实。初中二。先释妙。后释高。前中疏。谓七金山七重围绕者。俱舍世间品偈云。苏迷卢处中(苏即妙也迷卢高也)次踰健达罗(此云持双以山顶有二道脊山能持此故以为名)伊沙驮罗山(此云持轴山峰上耸犹如车轴山顶持故)竭地洛迦山(俱舍疏云此即西方树名大疏但依状翻不出其名颂疏云此方亦有名檐木山山上宝树形似彼故)苏达梨舍那(此云善见见者称善)頞湿缚竭拏(此云马耳山形似彼故)毗那怛迦山(此云象鼻山形似故)尼民达罗山(俱舍疏云鱼名其鱼觜尖山形似故华严音义释此云云持边山也)于大洲等外有铁轮围山。前七金所成。苏迷卢四宝。入水皆八万。妙高出亦然。余八半半减。广皆等高量。释曰。上来所引正证七金余因便来。下疏方要疏及七香海海印旋流者。俱舍颂云。山间有八海前七名为内。最初广八万。四边各三倍。余六半半狭。第八名为外。三洛叉二万二千踰[跳-兆+善]那。释曰。前七名为内七金内故。第八名为外七金外故。外在铁围之内亦名山间。最初八万即持双之内海也。七金内海皆八功德水。故云香水旋流。外海铁围因便故来耳

疏。唯天依住者。俱舍颂云。妙高层有四相去各十千。傍出十六千。八四二千量。坚手及持鬘。恒憍天王众如次居四级。亦住余七山。释曰。谓始从水际尽第一层相去十千。傍出十六千。上三层级向上相去数同。傍出渐减一半。第二层八千。三即四千。四即二千。向上渐狭。此四层级直上方尽妙高下半四万踰[跳-兆+善]那。第一级有药叉神名为坚首。乃至第四是四天王余皆四王管故。云唯天依住。妙高顶八方复三十三天居故。皆天住。疏。波利质多罗能益天众者。波利此云遍也。亦曰周匝。质多罗。此云间错庄严。言此树众杂色华周匝庄严。或云圆妙庄严。即俱舍园生树也。故俱舍云东北园生树。西南善法堂。论释云。其园生树槃根深广五十踰[跳-兆+善]那。耸干上升枝条傍布。高广量等百踰[跳-兆+善]那。挺叶开华妙香芬馥。顺风熏满百踰[跳-兆+善]那。若逆风熏犹遍五十。是诸天众游乐之所。余文可知

疏。为显十住功德妙高下。第三总结释也。于中三。初正结释。次四王处半下通伏难。谓有难言。若以妙高为表四王亦处妙高。复为次第何不处此。故为此通。后善财童子下。引例为证

疏。偈赞一品义有两兼者。前是古意。后是新意可知。十段科中皆有皆俱齐遍等言者。以约结通周法界故

疏。今此明遍即十重说处中第一重也。即第一疏说经缘中初此阎浮是也。疏文分三。一总释文意。二何须举此下。释举二会所以。三所以唯约觉树下。通妨难。此通二难。一有难云。既不散前应举二会。何以唯言不起觉树。故此通云。初会为本。又第二会近初会故。二若同时下。复通一妨。文中先举难。后应云即用下。通释可知。疏动静相违去住悬隔下。疏文有五。一假问征起。二序昔顺违。三申今正解。四会通古义。五问答会违。疏古有多释下。次序昔顺违。昔有五义。而文三节。初并序三师。二序第四。三序第五。以初三师并约三身义类大同。欲并破故先序于昔可知。疏并非文意下。二辨违。通有二违。一违现文去。住皆是遮那佛故。二违经宗。十身非三身故(彼即是后二会此即今文也)疏一云以去即非去等者。二序第四师以不分三身。但就一身论性相故。即是事理无碍。宗中之意。不违本体。不顺今文。于中先序昔。后辨违。前中光正释。后如不来相而来等。即是古人引例证成。此是净名经问疾品中净名之言。经云。时维摩诘言。善来文殊师利。不来相而来。不见相而见。文殊师利言。如是居士。若来已更不来。若去已更不去。所以者何。来者无所从来。去者无所至。所可见者更不可见。今但引净名之言。余略不引。睿公释云。文殊心栖实相。形贯法身。内外冥寂都无来相。都无来相能以之来。此明心冥至理体绝去来。应物随缘不坏来去。而下文殊答者。即得意相领印成其言。则以三时门领其不来相而来。以合不合门成其不见相而见。前中三时略举其一以相显故。言三时者。即中论去来品偈云。已去无有去。未去亦无去。去时亦无去。翻此则云。已来无有来。未来亦无来。来时亦无来。谓已来已灭不可言来。未来未有何得言来。来时不住已未分之故亦无来。无去亦然。故下经云。若过去生。过去生已灭。若未来生。未来生未至。若现在生。现在生无住。而净名所见。文殊自庵园而来。庵园众会谓文殊为去。故文殊言非唯居士见我不来而来。从庵园见我为去。我亦不去而去也。所以者何。下文殊自征释上义。谓若先有法从彼而来。既非先有缘会而来。故于三时无有来矣。无去亦然。来必有从。去必有至。故三句释别。又有来去不出三时。今三时无来故。来无所从。三时无去故。去无所至。言所可见者。更不可见者。即以合不合门成上不见相而见。谓见必有三。谓能见所见及以见者方成于见。所见因于二成故无所见。所见无故余二宁有。故中论云。见及所见者。是三各异方。如是三法异终无有合时。异法不可合。非异无可合。又论云。见不能有见。非见亦不见。若已破于见则为破见者故。正见时即无见矣。因他所引略示纲宗。疏若尔但是下。二辨违但是升即非升。似去即非去。何有树下不动之身。若庵园有文殊。毗耶更见妙德。可以证此。彼此义异何得援引

疏。有云此佛神通同体等者。三别序第五师。即刊定记主。亦先序昔。后辨顺违。前中以体遍为不动。以用应而犹升。疏若尔何殊第三师不起是法者。即第二辨违也。此有二破。一指同前义破前义不立。此义自破。二又以住释于不起下。直就所立破。唯住觉树非有体遍。遍于去处何得去非体遍。然觉树亦用独言是体。升天有体但言是用故。有所违。非责本立同体业用。故下正义亦是即体业用

疏。今显正义下。第三申今正解。有法喻结。文显可知。疏古德释此略有十义下。第四会取古释。于中二。先正序。后然此十解前五玄门下。为其会通。于中又二。先总会。意明古德所立。文则杂乱。义则无违

疏。然此中相望有四对法下。二别会通。于中又二。先通明义类。后一多相望应成四句下。别释前法类中一多之义。于中三。初正说四句。次类释余会。后例释余义。今初。经中欲显一多相即故等者。显经中不尽之由。若云不离一树而升一天难思之相不显。若言不起一树而升一切忉利天者。则不能显本会圆遍。若言不离一切树。而升一切天。则无一多无碍之相。故唯出初句。下法慧例云十方悉亦然。方有升一切句即俱多句。疏升释天既尔下。二类释余会

疏。复应树树相望等者。三类释余义。于中二。先例经。后又既一处有一切处下。例释十玄。以古德玄文与意相参但有四玄。前五但二九为托事。十为同时。故今加六十玄具矣

疏。问带前起后下。问答会通可知

疏。第九迦叶下。同赞如来者。此中疏以别德释其别名。于中数名状若疏家。以文就义观下二会义更昭然

    须弥山顶偈赞品第十四

疏。先陈体性者。即第二来意如前品明。疏别即次第配于十住等者。下之所释闇引经文。如以主导世间释因陀罗者。因陀罗此云帝也。主也。即下发心住劝学十法中云。所谓勤供养佛。乐住生死。主导世间令除恶业。乃至为苦众生作归依处皆为主义。从二已下但取名上之义不引经文。疏亦可别明十住胜进十法思之者。初之一住已引经文。余九思者。二以治地胜进云习诵多闻虚闲寂静近善知识了达于义等。皆如莲华开敷义故。三谓观察众生法界等。谓智宝故。四为了知三世佛法等为最胜故。五知众生无边无量无数不可思议等。为大乘如金刚誓愿心故。六学一切法无相无体不可修等如香气故。七说一即多说多即一。文随于义义随于文等。可悦意故。八知刹持刹观刹诣刹。领受佛法为明净故。九善学法王善巧轨度等为可持故。十学十种智。如空遍故。疏智明闇息恩益清凉应器周故者。月有四德合佛三法。明是智德。闇息断德。清凉是恩德。应器周故亦是恩德。又具上三德故。能遍应。疏别名即十住自分之果者。前刹配胜进故。此配自分具如下文。疏以此十因下结成。上且随下令其寻本。疏如名号品者。不欲繁文故令寻彼。但远近小异义理全同。若刹若人皆遍法界重重无尽。疏次二劝观佛力更发胜心者。前品成于四句亦从此生。谓前一偈半即指上文。是不起一切处而升一处。后十方悉亦然。单取十方须弥顶亦然。即是不离一切处而升一切处。取上一阎浮提对此。则是不离一处而升一切处。取上一阎浮对我等今见佛住于须弥顶。即不离一处而升一处。如来自在力通于四句。第二南方疏了一切法真实之性者。约偈文释。言净心地者。约表治地住释

疏。颂意为显于诸众生增长大悲者。约彼住中胜进行释。以称实而观救世者故。约当偈释

疏。初二句空观。缘生无性故等者。约三观释。皆初牒经摽观。后句取经意释成中观疏。释成中有二义释。次二句中道观。一云由观前生灭一切诸法即无性故者。一切法故非无。即无性故非有。由前但观无性是空。但观假名是假。今二相即故非空非假。是中道义。此约即缘生法以明中道。二云相体即是不生灭也者。约三性义以辨中道。然无生多义。略有二种。一事无生缘生之相即无生故。二理无生。圆成实体本不生故。今既经言该一切法。不拣相性则相体皆无生矣。则遍计无生是空观。缘生假有是假观。缘生无生。及圆成无生皆中道观。则性相二宗三观皆具。然此二偈亦可但为性空之观。则初二句正辨性空故。言自性无所有。次假观二句通妨。谓有难言。现见生灭那言无生。故释云。随世假说耳。次二句中观正示不生之理。依此释者极顺常解三论中意。而未得于龙树玄旨故

疏。取论三观释之

疏。法性本空非观之使空故无所取者。此以性空门显无所取。次云何有能见者。即以相待门遣其能见。此中语略。合云若有所取则有能取。既无所取故无能取能因于所而得立故。亦曰相因门。然取与见皆通能所。今所取之中则存于所取略无能取。于能见中略无所见。所见即所取故

疏。又上来以空遣有等者。此别为二释不分止观。四偈相蹑总为遣病。则四偈中。初二句以空遣有。次二句以假遣空。次二句以如不生灭双遣空假。次二句且结观益。第三偈即双遣非

疏。从若谓双非下。正释第三偈。以上来疏重举前文生此偈故。故此正释。于中初举所破。次故辨起心皆妄下。以偈正破。起心皆妄绝念方真。释其上半。念本自无斯绝亦灭。释其下半。以性空无念亦不可思故

疏。故中论云下。引证即如来品初广破有如来竟。末后结云若于一异中如来不可得。五种求亦无。云何受中有。又所受五阴不从自性有。若无有自性云何有他性。以如是义故受空受者空。云何当以空而说空如来。次破于空四句皆拂。颂云。空则不可说。非空不可说。共不共叵说。但以假名说。何以故。寂灭相中无无常等四。寂灭相中无无边等四。次问云。若如是破应无如来。次偈答云。邪见深厚者。则说无如来。如来寂灭相。分别有亦非。如是性空中。思惟亦不可。如来灭度后。分别于有无。次总拂偈云。如来过戏论。而人生戏论。戏论破慧眼。是皆不见佛。长行释云。戏论名忆念。分别有此彼。又云。此如来品初中后。思惟如来定性不可得。是故偈说如来所有性即是世间性。如来无有性世间亦无性。此上诸偈文义相连

疏。家但引同今经偈。言用此文者。明是龙树取此经意而为论偈

疏。亦含三止意者。上云心冥性佛即停止止。心安正理故。止绝思求即止息止。今偈疏文即心冥体性停止止也。惑何由生止息止也。直就经文体性皆如。即是对不止止也。谓法性非止非不止。而铭法性为止故。云对不止止

疏。又亦通结止观者。即以第四偈结上三偈也。而止。已先明故。此疏文但结上观。疏第六偈推功下。此有四意。一明义意相承有本。二亦谦己下拣异凡情。三令法下辨法相承。四殊途下彰法体连合次八菩萨例有此四。第三西方胜慧解佛胜智。偈此偈明随空心净即表位中义故。彼文云。所谓观一切法无常。一切法苦。一切法空等故。云随空心静下七菩萨初释名中。皆有二意。细寻准此

疏。谓了一切法即心自性。性亦非性者。即心自性此是表诠。由一切法无性故。即我心之实性。言性亦非性者。此是遮诠。即上真性以无性为性也。即心自性如圆成性。性亦非性。如胜义无自性性。以偈但云了知一切法自性无所有故。故复遣性

疏。翻前内取等者。疏文。有二。一总释文意。二然此一。偈下。显义包含。略为二解。初云但是蕴缚。即涅槃二十九。师子吼难云。如佛所说一切诸法有二种因。一者正因。二者缘因以是二因应无缚解是五阴者念念生灭。如其生灭谁缚谁解。世尊因此五阴生后五阴。此阴自灭不至彼阴。虽不至彼能生彼阴。如因子生芽子不至芽。虽不至芽而能生芽。众生亦尔。云何缚解下佛牒以为答。引蜡印印埿印坏文成。喻意云。生时诸根有具不具。具者见色则生于贪。生于贪则名为爱。狂故生贪。是名无明。贪爱无明二因缘故。所见境界皆悉颠倒。无常见常。无我见我。无乐见乐。无净见净。以四倒故作善恶行。烦恼作业业作烦恼。是名系缚。以是义故名五阴生。此中意云。虽复生灭不妨系缚故。今用云但是蕴缚无有我人

疏。二前后因依相续无性下。是第二意上辨人空。此明法空。于中又二。先正明法空。后此性即是第一。义空下。会通佛性。然案显文但辨二空理已玄矣。观其法喻。包涅槃经佛性深义故复显之。此中文势连环。先总示佛性。即师子品初。如前玄中已广引竟

疏。又上性无所有下。别示诸因先指经以明。性无所有者。即前偈自性无所有。内外虽异皆是第一义空。故指前偈亦即此偈于此性也。既以第一义空为正因佛性故。性无所有即正因也

疏。前解此了者。前偈云如是解法性故云前解。此偈云于此性了知故云此了。并是了因。明知。一切众生虽有第一义空智慧之性。若无般若等为了因者终不成佛。上通二偈以出正了

疏。此蕴相续即是正因。亦名生因者。唯约此偈以显二因此双标也

疏。言正因者下。即双释也。然欲解诸因先须知彼经文。二十八云。善男子因有二种。一者生因。二者了因。能生法者是名生因。灯能照物名为了因。烦恼诸结是名生因。众生父母名为了因。谷子名生。水土名了。六度阿耨多罗三藐三菩提名为生因。佛性阿耨多罗三藐三菩提名为了因。复有了因。谓六波罗蜜佛性。复有生因。谓首楞严三昧阿耨多罗三藐三菩提。复有了因。谓八正阿耨多罗三藐三菩提。复有生因。谓信心六度。又云。善男子。因有二种。一者正因。二者缘因。正因者如乳生酪。缘因者如酵暖等。又云。正因者名为佛性。缘因者发菩提心。又云。正因者。谓诸众生。善男子。僧名和合。和合者名十二因缘。十二因缘中亦有佛性。十二因缘常。佛性亦常。是故我说僧有佛性。故下疏云。然复生必对了。正必对缘。已引经文次当释疏。言正因者是中道义。中道即是佛性者总示其体故。二十七云。佛性即是无上菩提中道种子

疏。谓现在阴灭下。出中道相。即今因前五阴故。偈是中道义。其下所用涅槃经文。即前二十九答师子吼阴缚难文。上引难文则具。引答则略。今当具引佛答之文。经云。善男子。谛听谛听。我当为汝分别解说。善男子。如人舍命受大苦时。宗亲围绕号哭懊恼。其人惶怖莫知依救。虽有五情无所觉知。肢节战动不能自持。身体虚冷暖气欲尽。见先所修善恶报相。善男子。如日垂没山陵堆阜。影现东移理无西逝。众生业报亦复如是。此阴灭时彼阴续生。如灯生闇灭灯灭闇生。善男子。如蜡印印埿印与埿合印灭文成。而是蜡印不变在埿。文非埿出不余处来。以印因缘而生是文。现在阴灭中阴阴生。是现在阴终不变为中阴五阴。中阴五阴亦非自生不从余来。因现阴故生中阴中。阴如印印埿印坏文成。名虽无差而时节各异。是故我说中阴五阴非肉眼见。天眼所见。释曰。此上具引。今疏用经便以义间但观经文自分主客。然百论唯识皆说因缘相生。续故不断。灭故不常。不断约果续。不常约因灭。今疏。以中论中义于因果中各有断常。现阴为因先明灭故不常。后虽不至芽而能生芽。此现在阴虽不至后下。以有功能明现阴不断

疏。而中阴五阴亦非自生下。约后阴明非断常。先明非无因常。以中论明无因则堕常过。如外道立时方微尘等故。后既能续前下明续故不断

疏。非断非常是中道义正因性也。总结示也

疏。能生佛果故曰生因道。上释正因。今释生因也。前有六对生了二因。前三对以因为生因。缘为了因皆就能生。后三对以因望果以论生了。今是前意。如乳是生因酵等为了因故。乳等即喻众生。望于佛果而为因也

疏。众生佛性有二种因者。引文证成。如上已引。疏今以了因了彼正因下。结示经文可知疏。初一显无缘了不见正因下。此释第一偈。疏文有二。先正释文。后引难成立。前中三。初正释经。次拣定二因。后结示喻旨。前中先释上半喻可知。后下半法合下释合。然有二解。解虽慧莫能了。前义但有二法成见。谓宝与灯以成正因缘因。后义则三法成见。应须加眼以喻于慧。此中法喻合应各四句。谓一有眼无灯不见。二无眼有灯不见。三无眼无灯不见。四有眼有灯则见。则眼为因灯为缘。因缘合故方得见宝。因缘随缺则皆不成见。以喻善友为缘如灯有慧为因如眼。因缘具故方见真性。亦有四句。一者有慧无友不见。二无慧遇友不见。三无慧无友不见。四有慧有友则见。其第四句则是约人。因缘和合亦成了因。今喻前失故无此句。三句失中唯合初一。其无眼有灯影在后喻瞽者不见明净日中。则明因缘互缺不见。况全缺耶。故不明于无眼无灯

大方广佛华严经随疏演义钞卷第三十六大方广佛华严经随疏演义钞卷第三十七

        唐清凉山大华严寺沙门澄观述

疏。然即缘因即是了因下。第二拣定二因。于中有二。先标二别。因有亲疏者。总示别义。疏者是了亦是缘因。亲者是了非是缘因

疏。善友是缘因而必是了下。出其二相。善友是疏亦缘亦了如酵暖等。是酪了因亦是缘因

疏。佛性名为了因未必是缘。此约智慧性故者显上了因未必是缘。以是亲因故。言智慧性故者。亦是了相。以无漏智性本自具足。本有真实识知遍照法界义故。当体名了。又约行性居然是了。又上所引生了二因中。云六度阿耨多罗三藐三菩提是名生因。佛性阿耨多罗三藐三菩提是名了因。六度能生菩提故为菩提生因。佛性能了菩提故为菩提了因。明知佛性之体即是了因

疏。若以第一义空为佛性者。唯是正因者。拣异智慧性也。然涅槃云。佛性者名第一义空。第一义空名为智慧。此二不二以为佛性。然第一义空是佛性性。名为智慧即佛性相。第一义空不在智慧但名法性。由在智慧故名佛性。若以性从相。则唯众生得有佛性。有智慧故。墙壁瓦砾无有智慧。故无佛性。若以相从性第一义空无所不在。则墙壁等皆是第一义空。云何非性。故下经云。知一切法即心自性。论云。以色性即智性故。色体无形。说名智身。以智性即色性故。说名法身。偏一切处明体本均。今分性相故分二义

疏。若以智慧为佛性者。即是了因者结成上义。生下五蕴是正是生不得名了。五蕴名生者。能生诸法故。名生因。今因五蕴能得菩提岂非生因。如乳生酪。如谷生芽。皆生因故

疏。然复生必对了正必对缘者。以疏参用为顺今经。依涅槃明义有二对。并如上引

疏。今灯一喻。双喻缘了下。第三结示喻旨兼指理源。即涅槃二十六七者。此是南经。北经即当二十八九

疏。又上灯喻既是正义下。第二引难成立。亦二十八。疏文有二。先引经立难。后决择经意。前中二。先师子吼立。后如来难。然疏引文随要略引。若经具云。师子吼菩萨言。世尊一切众生有佛性。性如乳中酪性。若乳无酪性云何。佛说有二种因。一者正因。二者缘因。缘因者。一酵二暖。虚空无性故。无缘因。佛言。善男子。若使乳中定有性者。何须缘因。师子吼菩萨言。世尊。以有性故故须缘因。何以故。欲明见故。缘因者即是了因。世尊。譬如暗中先有诸物。为欲见故以灯照了。若本无者。灯何所照。如土中有瓶故。须人工水轮绳杖等而为了因。如尼拘陀子须地水粪而作了因。乳中酵暖亦复如是。须作了因。是故虽先有性。要假了因然后得见。以是义故定知乳中先有酪性。善男子。若使乳中定有酪性者。即是了因。若是了因。复何须了。善男子。若是了因性。自了者常应自了。若自不了何能了他。若言了因有二种性。一者自了。二者了他。是义不然。何以故。了因一法云何有二。若有二者乳亦应二。若使乳中无有二相者云何。了因而独有二。师子吼言。世尊。如世人言我共八人了因亦尔。自了了他。佛言。善男子。了因若尔则非了因。何以故。数者能数自色他色故得言八。而此色性自无了相。无了相故。要须智性乃数自他。是故了因不能自了亦不了他。又善男子。一切众生有佛性者。何故修习无量功德。若言修习是了因者已同酪坏。若言因中定有果者。戒定智慧则无增长。我见世人本无禁戒禅定智慧。从师受已渐渐增益。若言师教是了因者。当师教时受者未有戒定智慧。若是了因应了。未有云何。乃了戒定智慧。令得增长。师子吼菩萨言。世尊。若了因无者云何得名有乳有酪。善男子。世间答难凡有三种。一者转答。如先所说。何故名戒。以不悔故。乃至为得大涅槃故。二者默然答。如有梵志来问我言。我是常耶。我时默然。二者疑答。如此经中若了因有二。乳中何故不得有二。善男子。我今转答。如世人言。乳有酪者。以定得故。是故得名乳有酪性。佛性亦尔。有众生有佛性以当见故。释曰。此上所引对今疏文则知。广略。但要何须了义。然泽州释云。自下第五师子吼。以其缘正二因证性本有。如来对破。佛破有三。一就喻。二就法。三双就法喻。初就喻中云。若使乳中定有酪性即是了因者。乳中既得有其酪性。性由了有。明知乳中即有性了。破性了中文别有四。一若是了因复何须了者以内征外。乳中先自有其了因。何须乳外酵暖为了因。此即是以外破内。今疏云。又善男子一切众生有佛性者下。即彼就法破。言已同酪坏者。难破须了。师子吼立意性体虽有须修了因。了之令现故举破之。前破喻中若有酪性应有性了。若有性了何须外缘以为了因。破此同彼名同酪坏。喻既已破法全同喻何得不破

疏。结正义云下。指彼最后结文并如上引。但观上来所引经疏。则此中疏居然可了

疏。然上诸义总有二意者。第二决择经意。然有二意。前义即泽州意。后意即疏正意。所以更加后意者。若但用前意犹招来难次下当明。故于后意疏文有三。初正释义。次遮外救。后结示正宗。前中疏。约其体性与有不异者。如矿有金性波有湿性。约其现惑与无不殊者。不得其用。如水成冰无水之软。若言定有名为执著者。暗引经证。即涅槃三十五云。善男子。是故如来于是经中说如是言。一切众生定有佛性。是名执着。若无佛性是名虚妄。智者应说众生佛性亦有亦无。三十六又云。善男子。若有人说言。一切众生定有佛性常乐我净。不作不生烦恼因缘故不可见。当知是人谤佛法僧。若有说言。一切众生都无佛性犹如兔角。从方便生本无今有已有还无。当知是人谤佛法僧。若有说言。众生佛性非有如虚空。非无如兔角。何以故。虚空常故。兔角无故。是故得言亦有亦无。有故破兔角。无故破虚空。如是说者不谤三宝。善男子。夫佛性者。不名一法。不名十法。不名百法。不名千法。不名万法。未得阿耨多罗三藐三菩提时。一切善不善无记尽名佛性。如来或时因中说果。果中说因。是名如来随自意语。随自意语故。名为如来。如来随自意语故名阿罗诃。随自意语。名三藐三佛陀

疏。然众生智慧是佛性因者。此下第二遮于外救。即前意家救。然疏。虽双存二义以后意为正故。假以前师设难救前。救云。汝意加后者。岂不以前义为未造玄。因果二性皆有明文。若有明文如何。不许。故经云。佛性有因有因因。有果有果果因者即十二因缘。因因者名为智慧。果者谓大菩提。果果者谓大涅槃。既有四种。前二本有。后二当有。文理昭然。如何不信因果二性。更别说理故为此通。欲通此义先应反难前师云。向引四性是一处复有处。说是因非果名为佛性。是果非因如大涅槃。是因是果如十二因缘所生之法。非因非果名为佛性。此复云何。设尔通云是因非果是初性。是果非因是第四性。是因是果为第三者理亦可通。非因非果名为佛性如何可通。明知直语佛性之体体非因果。因中取之名为因性。果中取之名为果性。非是佛性分成因果。如瓶取空是瓶中空。世界取空是界中空。空岂有异。故言众生智性是佛性因。菩提涅槃是佛性果。非是佛性分成因果。故结正云然则佛性非因非果

疏。今此经宗下。结示正宗。于中有二。先结正义。后结广劝信。前中言宗于法性者。以无障碍法界为宗。则法性即佛性。知一切法即心自性。若以心性为佛性者。无法非心性则不隔内外。而体非内外内外属相性不同相何有内外。然迷一性而变成外。外既唯心何有非佛。所变无实故说墙壁言无佛性。以性该相无非性矣。加烟因火烟即是火而烟翳火。依性起相相翳于性而相即性。如水成波波即是水。境因心变境不异心。心若有性境宁非有。况心与境皆即真性真性不二心境岂乖。若以性从相不妨内外。若以外境而例于心令有觉知。修行作佛即是邪见外道之法。故须常照不即不离。不一不异无所惑矣。故云即非内非外随物迷悟强说升沈

疏。佛性要义下。结广劝信

疏。此喻了因惑俱者。翳喻于惑。眼喻了因。但见有垢非全不见。然见空华无而谓有。不见于无即不见法

疏。涅槃云。佛性二种下引证。即二十八经。但初云。善男子佛性复有二种。从一者是色下。疏全是经。直至然非失坏一段终毕。然有二意。一以非内非外然不失坏证强说升沈。二证可见。谓佛菩萨见之。了了如眼见色。言非色者。以未证如闻他说故。故云闻见。若涅槃二十七经云善男子。佛性亦色非色。非色非非色。及历相非相常非常等。下释云。色者金刚身故。非色者。十八不共等故。非色非非色者。无定相故。释曰。此约佛性之体名色非色。以如来身智等皆果性故非今所用。第四菩萨

疏。初二句曲径趣寂迷一直道者。迷一直道凡小俱迷。曲径趣寂唯是小乘。若超卓大方不历二乘速成正觉名为直道。若先证二乘后方入大名为曲径。曲径谓其迂回。趣寂明其沉滞。入无余依权教不回。若实教中终竟发意。但动经八万耽三昧酒故

疏。次半有常等倒长世间恶者。以上言通凡小。故此说凡恶。下说小乘之恶。疏三乘纵有亦不名谛者。二乘不见法空。居然不净。权教大乘谓事理不融亦未为净

疏。后偈拂前二见以成真见者疏文有三。初总明偈意。次谓上半下别释偈文。文并可知。后智论云下。引论通释。谓第二十论。彼论偈云。若人见般若是则为被缚。若不见般若是亦为被缚。若人见般若是则得解脱。若不见般若是亦得解脱。脱之与缚俱通见不见。今疏随经之次便以论偈随义解释。初言下半意者。谓下半。真俗之见不忘。此是取着之见故被缚也。言上半意者是论第三句。是忘见之见同无分别智故得解脱

疏。即第六七偈者。以第六偈见佛无取即无取而见。是见般若得解脱义。第七偈证真了俗亦真见般若故皆解脱。疏即第四偈者。第四不见诸法空是无真见故。不见般若岂不缚耶

疏。唯忘言者可究斯旨者。见与不见俱通缚解。岂得随于见不见言。须领见等下意。若言见而被缚。即知是取着之见。若言见得解脱。即须知是无分别见。故什公云。唯忘言者可与道合。虚怀者可与理通。冥心者可与真一。遗智者可与圣同矣。第五菩萨。疏初三所执无相观者。然此中明于三性。上修三无性观。言三性者。一遍计所执性。二依他起性。三圆成实性。三无性者。一相无自性性。二生无自性性。三胜义无自性性。三性之义。已见上文。今疏科文名中一一舍二。今言所执无相观者。所执即遍计所执。无相即相无自性性观。次三缘起无生者。缘起即依他起性。古经论中。亦名缘起性。今疏文从简故云缘起。言无生者。即生无自性性观。后三圆成无性者圆成即圆成实性。言无性者。即胜义无自性性。偏言无性者。向真性上。说无性故。亦是古名并从简耳。又皆双明者。以其三性即三无性故。故唯识云。即依此三性。说彼三无性。初则相无性。次无自然性。后由远离前所执我法性。故二种三性不相去离。然法相宗三性即有性。三无性则无性。有无义殊故彼偈云。故佛密意说一切法无性。意云。既言密意说三无性则不碍于三有性也。若法性宗此二三性有无无碍互夺双亡皆悉自在

疏。初一举分别过者。分别即遍计所执也。古谓为分别性。今疏从简亦欲辨起心动念皆成分别故并成过。故云以心分别一切法邪。不以心分别一切法正。故信心铭云。至道无难唯嫌拣择。但不憎爱洞然明白。疏后二显无相观者。正修三无性中初无性也

疏。一离所取者。谓二偈中初一偈所取。即遍计所执也。上半知于情有者。即遍计中二义。谓情有理无。今知情有即是理无。则知此性即无相也

疏。如迷木见鬼等者。举喻以明。如人夜行云月朦胧。见一杌木以无月光。情怀怖畏而生鬼想。众生亦尔。行生死夜妄想浮云蔽于慧月。睹缘生法不了性空。谓有定性如生鬼想。鬼喻遍计。木喻依圆。若了知鬼是因迷有则知所执定性之法皆由妄情。是人名为妄识所执。故名悟人如实知鬼此释上半

疏。知鬼本无举体是木者释下半也。约法云知妄所执理。本是无但是依圆。为举体是木则见依圆故名见木。故知妄本自真则鬼是木见佛则清净名为见木

疏。如若见鬼则不见木者。有妄执之见如若见鬼故。则为垢不见依圆名不见木。执有定性不见依圆之实名未为见木

疏。下半显得离于鬼见方成见木者。谓离于定性执见。则见圆成之实方为见木。疏依他二义者。三性各二义。依他二者。一幻有。二无性。从分别生释依他义。依他因缘而得有故。分别即他。故唯识云依他起自性分别缘所生。今言世间语言法即所起之法。众生妄分别即是能生。且顺三性义释。亦可诸世间法各无定性。但是众生妄心分别。谓有实耳

疏。二者无性即是下半者。知世皆无生无生即无性也

疏。有无生见同世非实者。由上云知世皆无生。今牒此言云若见见世间。谓见世无生既有此见。见即是生故同世间非真实也。故古人云。无生终不住万象徒流布。若作无生解还被无生顾即其义也

疏。下半见等无生名真见者。以经文言若见等无异。谓见等所见同无生故。能所两忘名真见者。疏初句体有者。圆成有二义。一体有。二相无。法性本清净故是体有。如空无相故是相无。体有即是相无。相无即是体有。本自相融何能说之。欲言其有即相无故。欲言其无即性有故。第六菩萨

疏。智离所知心脱烦恼等者。下半初句。明离二障。言离垢者。离所知障。是慧解脱故。言智离所知。言心解脱者。是离烦恼障。是心解脱故云心脱烦恼。解脱之义通二解脱。言兼二利者。即第四句自度能度彼。以自度二障亦令他人脱二障故。则俱度苦海也。疏二障难除下。总举下半释成初句。二障难除则难断能断众生难度。今难度能度为自强不息。是希有勇健义也。然自强不息。即周易乾卦大象。象曰。天行健。君子以自强不息。谓乾者刚健之象。君子当法天刚健。故自强进德不休息也。今借用之明佛勇猛。自励策修练磨其心。得成正觉为勇健耳。疏如大菩萨见者。大菩萨即于无量劫积智之者

疏。尽即自为者。净名第三香积世界诸菩萨欲还本土。以求少法当念如来。佛告诸菩萨。有尽无尽法门。汝等当学。何谓有尽。谓有为法。何谓无尽。谓无为法。如菩萨者不尽有为不住无为。何谓不尽有为。谓不离大慈不舍大悲等。何谓不住无为。谓修学空不以空为证。修学无相无作。不以无相无作为证

疏。诸行无常速起灭故者。释成尽是有为之义。故涅槃云诸行无常是生灭法速起灭故。刹那不住故

疏。有为之性湛若虚空。便是无为体常遍故者。释其性如虚空故说无有尽。其性即上有为性故。其性之言。略有二义。一但约无性之性以有为法缘生性空。缘生性空即同无为。竖穷三际曰常。横无不周曰遍。故是无为。则上净名。但明不尽有为。不住无为。二相犹别未能显为即无为矣。今明即性之相是名有为。即相之性便是无为故是玄矣。二者其性如虚空即如来藏性。体离断常故如虚空。故胜鬘云。边见者。凡夫于五受阴。我见妄想计着生二见是名边见。所谓常见断见。见诸行无常是断见非正见。见涅槃常是常见非正见。妄想见故作如是见。于身诸根分别思惟现法见坏。于有相续不见起于断见。妄想见故于心相续愚暗不解。不知刹那间意识境界。起于常见妄想见故。又云死者诸根坏。生者诸根起。非如来藏有生有死。如来藏离有为相。如来藏常住不变。是故如来藏。是依。是持。是建立。释曰。据上经文以尽即无尽。是故双非常无常见。故次文云智者说无尽此亦无所说

疏。既如虚空何有无为之相者。我言无尽者。体无可尽故如虚空。非谓有于一物。若高山之出云用之无尽也。故云智者说无尽此亦无所说。由尽即无尽。即非尽非无常矣。无尽既如虚空。则非无尽非是常矣。是为双非常无常。双离尽不尽。亦双非为无为。故中论云。若有有为法则有无为法。既无有为法何得有无为

疏。则不坏于尽者。此有二意。一者拂上有为。二者上来双遣今则双存。自性无尽则有无尽。有难思尽则有尽矣。以泯不碍存故。存亡无二方曰难思。而向言拂上有为者。谓尽则无尽故非尽矣。上来尽即无尽意虽暗拂。而以其性如空别示无为。故今方说拂有为耳。疏但除上病者。即侧用净名第二。但除其病而不除法。二空之体者以法性宗二空即真如空。及所显圆成者。以法相宗二空非真如。二空所显为真如故。真如即是圆成。然空有无碍故。双存两宗。第七菩萨。疏烦恼名诤触动善品者即俱舍界品颂云。有漏名取蕴。亦说为有诤。及苦集世间见处三有等。今用第二句。从烦恼名诤下。至有彼诤故。全是彼文。从故生死者有漏为体即是前段后义。彼疏后云犹。如前说。有彼漏故名为有漏。释曰。此证成有彼诤故。下又结云如是等类是有漏法差别众名故今结云故生死者有漏为体。所以论初名为有漏无漏法也

疏。又二互相待故俱空等者。谓上约因缘因他立称。故无真实不融二体。今明双融此有三意。一相待。二相即三相夺。今初相待俱空即相待门。谓因涅槃方说生死要。因生死方说涅槃。若高下相形。若无有高则无有下。若离涅槃则生死不存。若离生死则涅槃不立。故俱空也。次言二互相夺故皆寂者。此有二意。一者相即门。生死实性即是涅槃。则涅槃之相。假说生死。如波与水举一全收故。生死即涅槃。涅槃即生死。二由相即故便互相夺。生死即涅槃即无生死。涅槃即生死则无涅槃。故涅槃非寂静。生死亦非喧故皆寂也

疏。一佛佛相望者。如云阿弥陀佛有四十八愿能摄众生。余则不能。礼于此佛灭罪则多。礼于余佛灭罪即少。不知诸佛行愿功德无不平等。随根随缘说有优劣故。为颠倒。二三身等相望者。谓念佛化身功德则少。乃至法身功德则胜等。而言三身等者。等取四身。五身。十身。无量身。故以不知三身体融十身无碍。谓有优劣故为颠倒。三心佛相望者。谓佛已成道。功德难思。我心妄惑则名为劣。虽无叨滥不了真源。心佛众生三无差别故为颠倒耳

疏。若取知能知寂者。此即用于禅宗知识之偈。偈中具云。若以知知寂此非无缘知。如手执如意非无如意手若以自知知亦非无缘知。如手作于拳。非是不拳手。亦不知知寂亦不自知知。不可谓无知。自性了然故不同于木石。手不执如意。亦不自作拳。不可谓无手。以手安然故不同于木石。斯为禅宗之妙故今用之。而复小异以彼但显无缘真智以为真道。若夺之者但显本心不随妄心。未有智慧照了心源。故云故须能所平等等不失照。为无知之知。此知知于空寂无生如来藏性。方为妙耳。第八菩萨

疏。后偈序昔以成今说者。偈中但是序昔偈意乃成今说。既执我受苦。明昔说无我为正说也。疏初三觉妄证实是觉察义者。三段显其三觉也。一觉察者如睡梦觉。亦如人觉贼。贼无能为。妄即贼也。二觉照者即照理事也。亦如莲华开照见自心。一真法界恒沙性德如其胜义觉诸法故。三妙觉者。即上二觉离觉所觉故为妙耳。非更别觉。故楞伽云。一切无涅槃。无有涅槃佛。无有佛涅槃。远离觉所觉。若有若无有故为妙觉。故起信云。又心起者无有初相可知。而言知初相者即谓无念。此明非觉而觉也。疏初句拣似比量者。然准因明。总有八义。今此有四故。论云。能立与能破。及似唯悟他。现量与比量。及似唯自悟。谓能立能破现量比量。此之四义各有真似故成八耳。言八义者。一对敌申量。三分圆明开晓于宾故。名能立。二斥量非圆弹支有谬。示悟于主故。名能破。三对敌申量三支缺谬。非晓于敌故名似立。四妄斥非圆弹支有谬。不悟于主故名似破。五于色等义有正智生。自相处转故名现量。六谓籍众相而观于义。相应智起故名比量。七有分别智于义异转。了瓶衣等名似现量。八以似因智于似所比相违解起名似比量。广如彼说。今疏。云无常计常即是第八。如色是无常知从缘生刹那灭故。故是无常。此籍因缘相应智起是真比量。今以相续覆故即似因智起。计之为常。即相违解起名似比量。故为颠倒。今云于法不颠倒故是拣似比量。疏男女天地等见一合相名似现量者。此即第七。一合相者。众缘和合故。如揽众微以成于色。合五阴等以成于人名一合相。如是见者。是有分别智。于义异转故名似现。言一合相。相不可得故。故名为离下。显真现量。不可得者。即金刚经云。如来说一合相即非一合相。以从缘合即无性故。无性之性。是所证理。如是知者是正智生。是自相处转名真现量。上来离于所觉和合之相。已为现量。非唯已下。又拂能所证迹。为真现量。谓若有如外之智与如合者。犹有所得非真实证。能所两亡方为真现。故唯识云。若时于所缘智都无所得。尔时住唯识。离二取相故。故下经云。无有智外如为智所入。亦无如外智能证于如。如是方为真现量也。是故。经云离诸和合相

疏。后偈成现观者。即前真现量也。现观有六。十地当释。今通前三

疏。夫见实者。即净名经入不二法门品。乐实菩萨曰。实不实为二。见实者尚不见实。何况非实。所以者何。非肉眼所见。慧眼乃能见。而此慧眼无见无不见。是为入不二法门。此明实者真实之理。非实者缘生假合。今尚不得所证之如。岂况如外假有之法

疏。见非实者。知其即实者。即诸经意云。若见非实即真名见。非实下。引中论即是法品。前光明觉品已广引竟。然实有二意。且就一相理实为实。事相非实即真俗二谛。俗则一切皆俗。佛亦随俗立名。真则一切皆真知妄本自真。故双照为俱存。互夺即双寂

疏。由无住故无所不住者。即般若中意。彼前更反释云。若有所住则有所不住。从谓不住有下

疏。释上文由无住故无不住义

疏。能住例知者。上辨四句。唯住有句具住不住义。下三皆略。若具住无应云亦不住无无即有故。故能住无。契无实故。俱句云。故能住有无契二实故。俱非句云。故能住非有无契非有无实故

疏。既以无住为住下。释第四究竟不动摇句。即大般若曼殊室利分亦前已引。从方契已下。是疏释义。结归诸佛住于此义。第九菩萨

疏。以无所得得菩提故者。前文已释

疏。本觉自然故无造作者。即将第二句无作字释初句处字。从悟亦冥符下。将第二句无分别字嘱初句所得字。三细已下。释三四二句。即起信论。然由无明为因生三细。境界为缘生六粗。故彼论云。复次依不觉故。生三种相。与彼本觉相应不离。云何为三。一者无明业相。以依不觉故。心动说名为业。觉则不动。动则有苦。果不离因故。二能见相。以依动故能见。不动则无见。三者境界相。以依能见故。境界妄现。离见则无境界。以有境界缘故复生六种粗相。云何为六。一者智相。依于境界心起分别爱与不爱故。二者相续相。依于智故生其苦乐。不觉起念相续不断故。三者执取相。依于相续缘念境界。住持苦乐心起着故。四者计名字相。依于妄执分别虚假名言相故。五者起业相。依于名字寻名取着。造种种业故。六业系苦相。以依业受果不自在故。当知无明能生一切染法。以一切染法皆是不觉相故。释曰。据此则六粗远亦从无明生。然就显著说说境界耳故。楞伽中云境界风所动。起信亦云因无明风动

疏。又不可以识识等者。即取净名见阿閦佛品之经。释此粗细

疏。又有能所下。此中三重释此粗细。此当第三。初约迷真起妄说。后二约反本还源说。而二约识智对觉论。三者理智对辨

疏。次二句双遣性相者。二即是相。相差别故。一即是性。性不并真故。今云无二。即遣相也。亦复无一即遣性也

疏。后偈拂前无二之迹者。即无中无有二。偈初句。牒前无二之迹。次句遣之言无二者牒初句也。非谓有无二下。正释第二句而是反释。若谓有无二即执药成病。若存无二下。出谓有无二之过。从遣之又遣之下。拂迹若不得意千重遣之未免于二。何者谓有人闻无二亦复无。谓无无二为是。亦有所著。故中论云。诸佛说空法为离诸有见。若复见有空诸佛所不化。以楔出楔。以贼逐贼。无有已时。心无所著当法即绝故。故至于无遣。若以无遣为是亦有着矣。此亦借老子损之又损之。以至于无为之言

疏。悟身见起此见如身者。前释非身而说身。此释非起而现起由悟非身。又生非身之见。此见若有执复随生。身既非身见亦非见故云此见如身。从身见两亡下。释下半。身见两亡则法界一相为真法身也。观身实相下通妨。妨云。向来观身是菩萨观解观其自身。那言是佛无上身耶。通意可知。即净名观阿閦佛品。前亦已引第十菩萨智力成就。不可坏故者。智力成就即十住中第十佳。智慧增故。得佛十种智故不可坏。即成今文坚固之名。颂意已下即彼胜进经文。文云已下即今偈意

    十住品第十五

疏。又前辨所依佛德下。上即通明。此下别显。上是古意。此下今意。如前已明。疏二释名下。疏文有二。先得名。后总言下释名。前中然住有二义。一约能所合释。故言慧住于理。则理是所住慧是能住。二唯约慧释。信未终极。慧未安住。得入正位。位不动摇故。云得位不退。然位不退复有二义。一约三乘至第七住位方不退。二约终教入初住位即名不退异轻毛故。今依后义则通十住皆位不退。从初受名故。本业云。始入空界即证初义。住空性位即证后义

疏。前会无胜进下。上正科经文。此下对前辨异。次回向是位下通外难。先牒难也。从三贤位满下通。通有二意。一明有胜进总摄前三故不别立。二亦显下。明无胜进则后无方便。欲证无分别智故

疏。略辨六意者。前三取下论势。然其三意大同小异。异相云何。一是所证法体。欲说此法要。须心冥此体。二非证不说者。拣异未证之人。亦许心合法故。三非思量境者。绝思方说亦通未证故。言大同者。绝思则证。证则契体。四观机则识病所宜。审法则知药功力。不观人根不应说法。不审而说理事或乖。应病与药令得服行矣。五散心不堪诸佛加故。六菩萨常定但为物轨。菩萨将说。尚须入定。况凡夫耶

疏。是众首等者。此有二意。一约教相。云是众首。言余入则乱者。此即论意。谓有问言。岂此海会无如法慧。故应答云。众虽德齐众人争入众则乱故。次应问言何不乱入。答云。众调伏故。故今疏。云余入则乱不调伏故。二显十住下约表法说

疏。任性能知下。释方便言。此有二意。一以绝分别心名为方便。如下文云。以无所得而为方便。初地经中无分别智名大方便。二约善巧事理无碍故。如常所明

疏。互为增上者。前则佛加为入定缘今则入定为佛现缘

疏。言望行犹劣者。行一万故。行向有前望前辨过。今前未有故望后言劣。余义多同十地。虽贤圣位殊仪范相似。又圆教十住似十地故

疏。双说加定因缘。文中二。一略释经文。二料拣同异。前中又二。先嘱四因。后释令汝说法。于中言令汝说法即是加因者。意明加因亦四故。下正释后三复为加因。更添说法即是四因。然为说法即是入定故下引诸会。合说法与定为一。入定本为说法。入定既为加因则说法即是加因。故初标云一赞有加因

疏。然十地论释下。料拣同异。于中二。一辨加定因缘。二明加定先后。前中三。初引论例释。二叙昔顺违。三申今正义。今初。谓诸佛遮那皆由愿力故。二愿皆为加因。而言四段者即上四因。谓诸佛有一。遮那有二。威神为三。自善为四。故而论但有二因。今以遮那之愿是加因。例于后二亦加因耳

疏。以彼经中下。第二叙昔顺违。于中三。初出昔解之源。二正申昔解。三辨有违。今初。然具论经云诸佛皆同一号加汝威神。此是卢舍那佛本愿力故加。二古人下正申昔解。昔人见上诸佛威神加而得定。下云此是卢舍那佛本愿力故加。加因分明故分二因。亦例此经后二皆加因耳。而言转为加因者。不连上因是得定因故云转为。亦展转义。得定由诸佛加。佛加由主佛本愿力故云展转。三便令下。辨有违。违相云何。正由得定无三因故。无之何过。违文理故。何名违文。举其二文。一违又字。夫言又者复重之义。下之所列同是定因。则得言又。又是此因故。既上是定因。下是加因。何用又字。二违结文。既列三因竟。云入此三昧令汝说法。明知此三者皆定因也。然此经文令汝二字在三昧下。今疏。乃安三昧上者有二义故。一以义回。既云善根力故入此三昧则知。令汝义合在上。二者以行向二品为例。十行亦先列四因竟。即云令汝入是三昧而演说法。十向亦是列四缘。后即云令汝入是三昧而演说法。以此故知。理必后三通定因也。从非唯违经文理下结破。言违文者已如上说。言违理者。自无善根主佛不加何能入定。亦乖论释者。论释同号佛加云。何故同号金刚藏加。如来愿力故。何故如来作如是愿。显示多佛故。又此三昧是法体故。汝今既以愿属遮那。彼显愿因云此三昧是法体。明知为三昧故发愿而加。则显愿为三昧因矣。下疏正释更出其相

疏。如实义者下。三申今正义。则初一唯得定因。后三通二。从诸佛即以愿力下。此通妨难。谓有问云。前言此四皆是加因。今何加因但取后三。故今释云初。因有二。一约现文此是十方诸佛共加于汝即是加相。只得以加为得定因。不应以加自为加因。若依论云诸佛昔愿故加。则诸佛亦为加因。是故前云四皆加因。下引论文证成愿为加因之义。盖通论意。而其疏意。加因亦四。自以入定为其一耳。如上所明

疏。问加之与定下。第二辨加定先后。于中二。先问。后古人云下答。答中三。初叙昔。二辨非。三申正义。疏此解亦违下。第二辨非先明违文。后若言同时下。复辨违理。于中又二。先正辨。后亦不应下遮救。恐彼救云。俱舍论云。俱有互为果如大相所相。心于心随转。释曰。俱有者俱时而有也。互为果者释俱有因义。论云。若法更互为士用果。彼法更互为俱有因。下二句指法体。此有三类。一如大者。谓四大种。互相假藉生所造色。故互相望为俱有因。二相所相者。相即生等四大相也。此四大相与所相法更互为果。谓此能相相所相故。复由所相能相转故。故互为果。三心于心随转者。谓心王与心所随转法亦更互为果。释曰。谓彼救云。俱有因果既得互为加定互为。云何不可。故今遮云。彼三类法皆不相离。如相所相。所相无能相不成有为。能相无所相无有依止。今或有加而不入定。或时入定不必须加。许二相离云何成例

疏。若正释下。第三申今正义。言展转相成者。举佛愿等为得加故。所以加者为说法故。若更进释则有四重。一诸佛愿等为入三昧故。二入三昧者为得加故。三所以加者为说法故。四说法为何。为令菩萨增长佛智等故

疏。初口加劝说以增辨者。此中有三意。一口加标名。二劝说是加相。三以增辨是加意。亦加益下二业例此

疏。论名不着辨才者。所为小异与辨等大同。故得引论以释。今经广有义相如十地疏

疏。然三加同时下。上释文此下辨次

疏。楞伽云下引证。彼经第二云。复次大慧如来以二种神力。建立菩萨摩诃萨。顶礼诸佛听受问义。云何二种神力建立。谓三昧正受。为现一切身面言说神力。及手摩顶神力。大慧。菩萨摩诃萨。初菩萨地。住佛神力。所谓入菩萨大乘照明三昧。入是三昧十方世界一切诸佛。以神通力为现一切身面言说。如金刚藏菩萨摩顶。及余如是相功德成就。菩萨摩诃萨。下又云。大慧若菩萨摩诃萨。离佛神力能辨说者。一切凡夫亦应能说。释曰。今疏义引正引后反释之文。兼取前列二相

疏。此四后后以释前前者。亦展转通难。谓有难云。云何事讫入定为受佛加。今已得胜力故。为事讫。复应问云。虽得胜力何不且定。答云。说法时至故。次问云何不定中说。答云定无言说故

疏。然十住体等者。然若立章门十住略以五门分别。一释名。二出体。三辨相。四定位。五诸门分别。今经疏。皆具一名中有总有别。总如品初。别名如本分说。出体即今文。辨相即经文。定位次下当说。诸门分别含在前后文中。今此出体略有三重

疏。今约本体下释文。先案经释。后今依下。傍论释。于中先释总句。文分为四。一略释。二皆当位体也。结前生后。三而得名不同者总征。四然三贤下广说。于中五。一标举。二菩提心有三下。引论辨相。即起信修行信心分中。信成就发心中辨。三所念真如下

疏。释彼论。四然此三心下。历位辨差。正酬总征何以得名。不同。五今此住位下。正释今经。四中直心增故名解者。正念真如是智解故。三心等证。名善决定者。证理无差故。而大悲为首下。通妨。妨云。若总三心何以地体名愿善决定。通意可知。大悲为首即下经文

大方广佛华严经随疏演义钞卷第三十七大方广佛华严经随疏演义钞卷第三十八

        唐清凉山大华严寺沙门澄观述

疏。别中句乃有二下。第二释别句。于初句中分成二义。谓与法界等。与虚空等。是胜住处者。下论释云。大胜高广一体异名故。彼经云。广大如法界

疏。然地经总句下。弹古人。古人亦取下论立其三义。而云一胜善决定。二因善决定。三不怯弱善决定。故今破云。彼中总句是决定故。别句为六决定。今经总句是住处。即合别句为三住处。但取类例如何。一向学彼则好学太过也。此三义理应寻下十地经疏

疏。今是地前故阙此也。且依行布未证真如故。无常果因尽未来际

疏。如空包含无边行海者。此三义中。初一事。次一理。三即无障碍法界。然类六决定。而但有三者。余三证如方得有故。一谓观相善云无杂。二真实善云不可见。三大善云普能救护一切众生。皆未证如故无此三矣

疏。乃至始入空界等者。乃至二字中间则有所超越。皆信受行。常起信心。不生邪见十重五逆四倒八倒。不生难处。常值佛法。广多闻慧。多求方便。始入空界住空性位。故名为住。此后复。云空理智心习故佛法。一切功德不自造心生一切功德故。不名为地。但名为住。释曰。学他非自有故。名住不名地。余可知。十皆彼经。二中谓练治下疏释。三中经。但云长一切行。四中云生在佛家种性清净。五中云多习无量善。六中云成就第六般若。七中止观下疏意。八九全同。十中诸佛下。疏取经意

疏。然此十住得名下。谓于释名门中有总名别名。各有得名释名。今皆具足。从其所喻下。即是释名会六释故。谓发心即住为持业释

疏。若从能喻或依士者。喻劣法故。此一即依主释中开出。然六释义上下多有。今当略出。谓西方释名有其六种。一依主。二持业。三有财。四相违。五带数。六邻近。以此六释有离合故。一一皆具二。若单一字名即非六释。以不得成离合相故。初依主者。谓所依为主。如说眼识。识依眼起即眼之识故名眼识。举眼之主以表于识。亦名依士释。此即分取他名。如名色识。如子取父名。名为依主。若父取子名即名依士。所依劣故。言离合相者。离谓眼者是根。识者了别。合谓此二合名眼。识余五离合准此应知。言持业者。如说藏识识者是体。藏是业用。用能显体。体能持业。藏即识故名为藏识。故言持业。亦名同依释。藏取含藏用。识取了别用。此二同一所依故云同依也。言有财者。谓从所有以得其名。一如佛陀。此云觉者。即有觉之者名为觉者。此即分取他名。二如俱舍对法藏。对法藏者是本论名。为依根本对法藏造故。此亦名对法藏论。此全取他名。亦名有财释。言相违者。如说眼及耳等。各别所诠。皆自为主。不相随顺故曰相违。为有及与二言。非前二释义。通带数有财。言带数者。以数显义通于三释。如五蕴二谛等。五即是蕴。二即是谛。此用自为名。即持业带数。如眼等六识。取自他为名。即依主带数。如说五业为五无间。无间是果即因谈果。此全取他名。即有财带数。言邻近者。从近为名。如四念住以慧为体。以慧近念故。名念住。既是邻近不同。自为名。无持业义通余二释。一依主邻近。如有人近长安住。有人问言。为何处住。答云。长安住。此人非长安以近长安故。云长安住。以分取他名。复是依主邻近。二有财邻近。如问何处人。答云长安。以全取他处以标人名。即是有财。以近长安复名邻近。颂曰。自用及用他。自他用俱非。通二通三种。如是六种释。然下诸品多用本名。但云依主持业等。可以意得

疏。若定位者。此即释别名。复开此义门。言一依唯识五位者即论第九第十总有五颂。位各一颂。一资粮。二加行。三通达。四修习。五究竟位。初资粮偈云。乃至未起识求住唯识性。于二取随眠。犹未能伏灭。论曰。从发深固大菩提心。乃至未起顺决择识。未住唯识真胜义性。齐此皆是资粮位摄。为趣无上正等菩提。修习种种福智资粮故。为诸有情勤求解脱。由此亦名顺解脱分。释曰。谓所修福智二事资益己身之粮用故。涅槃名为解脱行。行行不违故名为顺。分者因义支义。是解脱因之一分故。二加行颂云。现前立少物。谓是唯识性。以有所得故。非实住唯识。论曰。菩萨先于初无数劫。善备福德智慧资粮。顺解脱分既圆满已。为入见道住唯识性。复起加行伏除二取。三通达位颂云。若时于所缘。智都无所得。尔时住唯识。离二取相故。下论文云。加行无间此智生时。体会真如名通达位。初照理故立见道名。四修习位颂曰。无得不思议。是出世间智。舍二粗重故。便证得转依。释曰。从初入地二见道后。住心已去名修习位。论曰。菩萨从前见道起已。为断余障证得转依。复数修习无分别智。五究竟位颂曰。此即无漏界。不思议善常。安乐解脱身。大牟尼名法。此后四位至十地品当广分别。今是三贤之初。即初位之初名初位摄。则知。第四五会。亦初位摄。十地即二三四摄。第七一会是修习余乃第五摄。具等妙觉故下之九义。虽但释位。则以例释差别因果准思可知

疏。二依摄论第六等者。即彼论入所知相分中。论云何处能入。谓即于彼有见似法似义意者。大乘法相等所生起胜解行地。见道修道究竟道中。于一切法唯有识性。随闻胜解故。如理通达故。治一切障故。离一切障故。无性释云。何处能入者。问所入境。及能入位。谓即于彼有见等者。谓于大乘法相等是所生。决定行相似法似义。意言能入于此境界。能入是用。所入境界是入是持。于此意言。或能入在胜解行地。于一切法唯识性中。但随听闻生胜解故。或有能入在见道中。如理通达此意言故。或能入在修道中。由此修习对治烦恼所知障故。或有能入在究竟道中。最极清净。离诸障故。如是四种是能入位。释前本论中有四节。一明所入。二意言为能入。三胜解行地下。明能入位四位能入。四于一切法唯有识下。出四入之相。上释论中已摘破配竟

疏。三依瑜伽等者。论云。云何十二住等。嗢陀南云。种性。胜解行。极喜。增上戒。增上心。三慧。无相有功用。无相无功用。及以无碍解。最上菩萨住。最极如来住。长行释。云谓菩萨种性等。具列其名而无次第。今疏依下释加于次第便引释文。已略释竟。然彼广释中皆先问后答。今初先有问云。云何菩萨种性住(此问位体)云何菩萨住种性位(此问能住人)今疏。引答具答二问。文有三段。初答后能住人问。谓由性仁贤性能成菩萨行德。不由思择制约。有所防护故即善行人。任持等者。二答前位体问也。此言犹略。具足论云。若诸菩萨种性。任持一切佛法种子。于自体中。于所依中。具足有一切佛法一切种子。释曰。阿赖耶识。名为自体。相续之身名为所依。未发心前彼自体中。佛法种子为此住体。种性即住。持业释也。以其宗中立有五性。此即菩萨种性人也。性离粗垢下。三约烦恼轻微重释能住人也。此言亦略。具足论云。又诸菩萨种性住。性离粗垢不能现起上烦恼缠。由此故无造无业。或断善根。二胜解行住者。释文具足论也。彼疏。释云。即以此住有漏种现。及无漏种诸善为体。而犹未证真寂之理。但印持决定而起诸行故名胜解行。三极喜住者。即以所得无为有为无漏善等。而为其体下诸位体。皆同此体。但约初得以受别名。广如地品。三即初地。从四至十二配二地至十地。易故不释。四亦依瑜伽下。即四十九论。复以类例大同。束为七地。一约种性。二约贤位。三初入圣故三住即为三地。四从二地至下。依圣道修。功用行满故束为一。名行正行地。五以八地无功任运增进故名决定。六以九地依无功用起利他行。故名决定行。七因圆果满名到究竟地也。五依仁王等者。即奉持品。若新经如次。牒十住行向十地之名。今依旧经名异义同。经云。大牟尼言。有修行十三观门。诸善男子为大法王。从习忍至金刚顶。皆为法师依持建立。汝等大众应如佛供养而供养之。应持百亿天华天香而以奉上。下经便牒便释。其文繁广亦不列次。今略列其名加以次第。今初言一习种性者。此即十住经云。善男子其法师者。是习种性菩萨。若在家婆差优婆差。若出家比丘比丘尼。修行十善。自观己身地水火风空识分分不净。复观十四根。所谓五情。五受。男女意命等。有无量罪过故即发无上菩提心。常修三界一切念念皆不净故。得不净忍观门。住在佛家修六和敬。所谓三业。同戒。同见。同学。行八万四千波罗蜜道等。下皆广释。今但释难。言善觉者。即欢喜地。初证真如。得无分别智故。二地戒德清净入修慧故。三地闻持发慧光故。故旧为明地。四地是焰慧故。亦云尔焰。亦云所知烧。于所知慧焰增故。五地入真达俗为难胜故。六地般若。寔智常现前故。七地依空涉有为玄达故。八地得一切法是寔觉故。九地善慧具四十辩。普应多会使情非情皆说法故。十三菩萨地。尽能入佛境故。言义当十地等觉者。仁王不立等觉故云义当。六依仁王等者。即依教化品。新经即菩萨行品。十忍品广明。今当略示。言如次配三贤者。伏忍下品当十住。中品当十行。上品当十回向。故彼经云。佛言大王。五忍是菩萨法。谓伏忍上中下。信忍上中下(初二三地)顺忍上中下(四五六地)无生忍上中下(七八九地)寂灭忍上中下。名为诸菩萨修般若波罗蜜。今以璎珞亦有五忍。寂灭亦分三品。中品即当等觉。七亦仁王等者。亦即上品五忍。以文云善男子初发相心信。恒河沙众生修行伏忍。于三宝中。生习种性十心。信心精进心念心慧心定心施心戒心护心愿心回向心。是为菩萨能少分化众生。已超过二乘一切善地。一切诸佛菩萨长养十心为圣胎。释曰。此之十心。是习种性中。为十住因。开因异果故加此十。克实唯五十一。开等觉故亦通诸经。有五十二。八依璎珞等者。但除十信信未成位故。故彼经云。佛告敬首菩萨。汝言义相云何者。所谓十住十行十回向十地无垢地妙觉地。我今当说。九依璎珞等者。即总收大位为四。后二因圆果满为二。并如十忍品释。依楞伽等者。此非立位。不别为门。而欲成五教故此附出。以十门中前四是始教。次五终教。此楞伽当顿教。十即圆教。小非大位故略不论。十依此经者。虽言四十二。以具圆融行布则融前九一经通明。若取差别即第二会终第七会。十信开合者。指前开成五十二。合唯四十二。开合无碍此经必具故十门收之。第五说分

疏。大同初地为得十力故等。即彼住分中当为何义。彼有十句总云为得佛智故。为得十力故。为得大无畏等。十力乃是别中一句。虽广略有异。然皆求佛果故云大同。从又此十力下通妨。妨云。若言大同那。唯一别句耶。答意云。既言大同何妨多异。显于初贤劣初地故。又以十力摄义宽长故。略举此一。如十力章故。故非不缘。余盖文略耳。是以下偈广斯十力。及余诸义皆初发心

疏。问八远生死等者。上正释文。此下料拣答有三意。初一约二利说。二唯约利他。三约悲智。然悲智。多约悲明利他。智约自利。如实义者自他皆具如。悲济九类。智了无生。而可度者即一向利他。有悲无智即堕爱见。有智无悲即滞二乘。无智不能观空。无悲不能起行。多约自利故与初别。然前释乐住生死具悲智二意。今为对远离义故但举悲。故乐住生死。瑜伽下。引文证显。引瑜伽证厌离义恐有误解。谓唯二乘有厌离故闇。引二经双证二义一。即净名舍利弗章。已如前引。二不动真际即大品意及智论文。言成不住道者上。释是俱住义。由俱不住故能双住。由不住生死故。能住涅槃。由不住涅槃故能住生死等。前已广说

疏。又初云下。更有一问答。亦三意。一自不要生。为引众生令修净土因。故二如人不善于水见子堕水。若便入者自他俱没。应求船筏而济度之。三悲故乐住。智故往生。下通十藏难。约权实智说

疏。自解亦三者。次第对上。谓一由内性成故。不随他人。二了唯心故不心外取法。三由了性故如性外一法亦无。疏非但多闻于义不了者。即涅槃经意。高贵德王品云。宁愿少闻多解义理。不愿多闻于义不了。涅槃近因问明已引。疏第三然十无常大同三地下。疏文有二。初总相标释。后论云下。开章别释。于中四解。一依论势作生灭无常释。二依涅槃常无常对释。三傍净名生灭无生灭对释。四取涅槃等双非常无常绝迹以释。初中二。先释总句。命行即无常体。不住即无常义。然复下别释无常

疏。于何无常下。二释别句。前四可知。从五无作下。次下四句从上四句次第而生。由无常。成无作。由苦成无味。由空成无体。由无我成无处。后二句双结离二取也。上言一切世间不可乐想者。即智论第二十六十想之一也。言十想者一无常。二苦。三无我。四食不净。五一切世间不可乐。六死。七不净。八断。九离。十尽想

疏。问涅槃比丘下。第二依涅槃常无常对解。于中二。先问答生起。二依经正释。今初。即哀叹品三修比丘。赞无常等想中文也。比丘白佛言。世尊快说无常苦空无我。世尊一切众迹中象迹为上。是无常想亦复如是。于诸想中最为第一。若有精勤修习之者。能除一切欲界欲爱等。又如秋耕为胜等。又说无我佛便赞其善修无我比丘。答言我等不但修无我想。亦更修习其余诸想。谓苦想无常想无我想。略不说空故云三修。又引醉人喻云。下取意引。譬如醉人见日月转。众生亦尔。无常计常。佛言向引醉人。但知其文字未知其义。谓醉人见日月转。日月实不曾转。涅槃真常而谓无常等涅槃等。实不无常等。谓依如来法门次第。初因外道横计邪常故说无常。诸观中最二乘不晓漫该佛地。双林极唱则常等区分。问答并可知。疏又无常者下。二依经正解。蹑前问答故致又言。上以无常该于涅槃。今以未会涅槃则不该矣。由生死中有无常等。则显法身是常。涅槃是乐。善有不空。自在有我。八自在我者。一能作小。二能作大。三能作轻。四能作自在五能作主。六能远到。七者动地。八随意所欲尽能作得。广如大论及涅槃经说。然以法身性出自古体无变异。偏语其常涅槃寂灭故为真乐。然空亦不净是有为故。涅槃云。净者。诸佛菩萨正法名为善有。如来者即是我义。然别说则尔。若如实言涅槃即具四德故。二十七经云。所言空者。不见空与不空。智者见空及与不空。常与无常。苦之与乐。我与无我。空者一切生死。不空者谓大涅槃。乃至无我者所谓生死。我者谓大涅槃。释曰。其乃至字中间越二。若具说云无常者所谓生死。常者谓大涅槃。苦者所谓生死。乐者谓大涅槃。故一经中。广说生死无常乐我净。涅槃有常乐我净。则知涅槃必具四德

疏。则前四句下。分判经文。上第一释。十句皆无常。今第二释。具常无常。言常故无作者。造作是无常因。以有所作为故。名有为。有为是无常。无所作为。故名无为。无为即是常也。有味皆苦。三界之乐于下苦中。横生乐想故。无味为寂灭乐也。如于名字则不自在。谓小如小名不即成大。安名自在。若有处所则非清净。净无净相方真净故

疏。然二理不偏下。结叹前八。谓常无常等总为二理皆不偏也。明常无常我无我等皆不相离。此为所证。照与之符即是能证。然其此上本即生公常住义中。彼云夫泥洹本有不可为无。三界本无今有。已有还无故。不可为有。泥洹以不。生灭为实谛。三界以生灭为真谛。二理不偏名中道义。彼有问云。常与无常二理相反。云何而为中道不偏之理耶。答二理虽殊理自相资。何者因乖常故有三界无常。因解无常之实性故成常智。所以经引二鸟义旨在此。二理不偏照与之符。犹悬镜高堂万像斯鉴矣。释曰。悬镜高堂即无心虚照。万像斯鉴则不拣妍媸故。以绝常无常之净心。照常无常之圆理。若依此释则一切法言。前四自属有为。故涅槃云。一切法者名为生死。非一切法者。谓佛法僧。及正解脱。又云。我观诸行悉皆无常。云何知耶。以因缘故。若一切法从缘生者则知无常。是诸外道无有一法不从缘生是故无常。如来虚空佛性不从因缘是故为常。今后四句亦云一切法者。性净涅槃不离一切为无为故。既有区分则翻八倒成八行矣。疏又初四句则因缘生灭等者。第三傍净名经。约生灭无生灭释。唯就无常明义。于中有二。先正解。后引证。前中言初四即因缘生灭是无常义等者。等取逼迫为苦义。不净为空义。不自在为无我义。言次四句。则以不生不灭为无常义者。此之一句言含总别。总则该后四句。别则初句。无作是无常义。既无造作则无生灭。然此即净名迦旃延章。迦旃延白佛言。忆念昔者世尊为诸比丘略说法要。我即于后敷演其义。谓无常义。苦义。空义。无我义。寂灭义。时维摩诘来谓我言。唯迦旃延无以生灭心行说实相法。迦旃延诸法毕竟不生不灭。是无常义。五受阴洞达空无所起是苦义。诸法毕竟无所有是空义。于我无我而不二是无我义。法本不生今则无灭是寂灭义。释曰。今疏文中全已用之。但观所引自分主客。生公释诸法毕竟不生不灭是无常义。云无常者。以事灭验之。终苟有灭始无然乎。始若果然则生非定矣。生不定生。灭孰定哉。生灭既其不定真体复何所在哉。推无在之为理是诸法实义。实以不生不灭为义。岂非无常之所存乎。故云不生不灭是无常义。此则正就生灭推之即无生灭耳。又无常者。乃明常之为无常。则所以无无常也。故不生灭是无常义。疏五受阴洞达空等者。受者取也。谓烦恼业因能招此阴故名受阴。言因起有苦下。释疏就经。谓从缘起故起则无起。故生公云。夫苦之为事会所成也。会所成者岂得有哉。是以言五受阴空是苦义五受阴苦之宗也。无常推生及灭事不在一。又通在有漏无漏故言诸法。苦即体是无。义起于内。又得无漏者。不以失受致苦。故唯受阴而已也。洞达者。无常以据终验之云毕竟耳。苦以空为其体故洞达也。无所起者。无常明无本之变理在于生。苦言假会之法所以配起也。今经云一切者。各少分一切。又含余义故云一切。诸法毕竟无所有是空义者经也。人法二空空亦复空。故不如名者。会疏就经也。生公云。惑者皆以诸法为我之有也。理既为苦则事不从己。己苟不从则非我所保。保之非我彼必非有也。有是有矣而曰非有。无则无也。岂可有哉。此为无有无无究竟都尽。乃所以为空义也。中论云。诸佛说空法为离诸有见。若复见有空。诸佛所不化故。毕竟空耳

疏。于我无我而不二者。生公云。既理不从我为空。岂有我能制之哉。则无我矣。无我本无生死中我。非不有佛性我也。解曰。此即无我法中有真我故不二也。诸佛下引中论则二双非也。实相之中二义俱寂。非有无我与我二也。实相之中岂有处所

疏。故庵提遮经下。第二引证引三文而义势各一。初引庵提遮经。则生灭不生灭交络而释。故彼经中文殊师利言。若知诸法毕竟生灭变易无定如幻相。而能随其所宜。有所说者是为常义。以诸法生不自得生。灭不自得灭故。云何无常。谓若知诸法毕竟不生不灭。随如是相而能随其所宜。而有所说是无常义。以诸法自在变易无定明不自得随。如是知者。说为无常义也。释曰。此意正显性相交彻二义相成。生灭相尽无常即常故。不生不灭是无常义。随缘变易常即无常。即生灭是常义也。又性即相故不生不灭是无常义。相即性故生灭是常义。互夺则双非。互成则双立。双树中间入涅槃者即斯意矣。双非之义次下当释

疏。瑜伽四十六下。二引大论。证前不生不灭是无常义。正顺前经亦即是生公常之为无。乃所以无无常故。即不生不灭矣。即诸行而不可得故。入中道非常非无常也

疏。若依辨中边论下。则双证前生灭不生灭皆无常义。而各有所嘱可知。远公释净名经。多用中边论意。意取圆成实性。释不生灭是无常义。故云实相理穷名为毕竟体寂无为。名不生不灭。此不生不灭是彼无常真实性故。名无常义。余例此知。而疏。言初后二性不生灭者。遍计无可生灭故。圆成体常湛然故。疏又无作者。非常非无常下。第四取涅槃意双非释也。亦有二意。一者实相之中二边斯寂。如向所引中论云。诸法实相中。无我无非我。亦应云诸法实相中。无常无无常。诸法实相中。无苦无乐。无净无不净。无空无不空。以破常故说于无常。非谓有无常。破无常故说常。非谓有于常也。二者非常者。性彻相故。非无常者。相彻性故。等思之

疏。无分别者念想无下。上来四重但解前八。此下二句通遣能所。历上四重皆用此二。如第一重不分别无常。无常无坚实也。第二重不分别常无常。常与无常俱无坚实。常无坚者。离常相故。第三重不分别无生无常生灭常义无实例知。第四重亦不作双非分别。未免戏论故。既离四句。双非亦无坚实。亦同净名法本不生。今则无灭是寂灭义。上对四句且引前四今具五矣。上来所说无常之义。并已具足。特由此义常所闻故。更引古来一两师释。肇公云毕竟者决定之辞也。小乘观法以生灭为无常义。大乘之士以不生灭为无常义。无常名同而幽致殊绝矣。其道虚彻故非常情之所能测。妙得其旨其唯净名乎。遣常故言无常。非谓有无常。无常常无故。云毕竟不生不灭是无常义。释曰。斯则美丽理但一重前已含有。大乘法师云。小乘以生灭为无常。谓不生灭为常故。今折彼。汝见有不生灭。为常者。此常还是无常。故云不生不灭是无常义。释曰。此则破其见常之心。而有二失。一者。彼但说无常曾不说常。何得以无常折彼常耶。二者。彼未知常。何得言不生不灭是常义耶。故非经意。下四句大例同此。然疏。上四重解释理无所遗。尚通实教。若华严宗。一切法趣无常无常。摄法无遗义理无尽。方真无常。总收诸义。以为一致皆是此宗。一义所收无常既尔。余句例然。疏后胜进中是护小乘行者。此皆十地论立。下当广释。大意云。观无常等烦恼不生。名护烦恼行。不同凡夫观察诸界。破邪显正不堕小乘。名护小乘行。疏次四界是起见处者。总标也。外道计大为诸法本者。外道有计地为物本。依地生故。或事于水水能净故。或事于火火成熟故。或事于风风成坏故。广如别说

疏。小乘计大为诸色因者。地水火风即是能造。色香味触。以为所造。色香非一已名为诸。况若形若显。五境五根诸色非一。皆大所造也。如萨婆多宗。此说总造。若楞伽第二云。大慧说。四大种云何造色。谓津润妄想大种生内外水界。堪能妄想大种生内外火界。飘动妄想大种生内外风界。断截色妄想大种生内外地界。色及虚空俱计着邪谛。五阴集四大造色生。彼疏解云。谓见有津润妄想大种熏成种子。从此种子而生内外水界。余三例然。但加经见有字耳。然火能成熟故曰堪能。地有形段及体坚住。而可断截

疏。言又成身之体者。净名云。四大合故假名为身。四大无主身亦无我等。第四住

疏。从圣教生者。此牒经即释名也。谓从多闻下。疏引论释。即摄论第六云。多闻熏习者。谓于大乘而起多闻。闻法义已熏心。心法相续所依。其少闻者无容得入此现观故。言等流无漏教法者。即是能熏。此是如来所流。从胜流真如流此教法故名无漏教。似智故名为等流。言生其智故者。智是所生即第四住菩萨之智。由生此智故。名生贵住。唯识等论大意皆同。次引下文复出二能生。从上三义下。结其通局。能生为局。兼所生处即名为通。依能生智还住此故。从又能说下。辨三名所以。三事成于两重能所。佛为能说。教及法界皆是所说。教为能诠。法界所诠要具此三生。义方足故前后互出。从此三生下。结成生贵之名

疏。列中十事同四地十种法智但有开合者。然三贤如次似于十地。就中十住相似最多。以初入下贤如地修故。初住似初地。二住似二地。乃至十住似十地。故疏多引地文释住。而言但有开合者。初二不开。彼经初句云深心不退故。此句自分云自住处。二云于三宝中生净信毕竟不坏故。即是胜进。上二约德行差别。今云亦能生者以上云从佛亲生故。下之二智约智解差别。三真如智即是证智。四即教智。其真如智彼经两句。一云观诸行生灭故。二观诸行自性无生故。上句生空真如。下句法空真如。故此合为一句。善观察法。具上二观故名为善。言亦所生处者。以上三义释名中。法界为所生处即真如故。第四智中彼但有六。此有七句开也。句虽有七义乃略彼。彼六句中。一云观世界成坏。即今世界。二观因业有生。即今业行果报二句。三观生死涅槃。即今六七二句。四观众生国土业故。即此初二此亦合也。五观前际后际故。六观无所有尽故。此之二句今文略无。摄在果报生死之中故全同也。今疏中观众生牒经。空有即观相。佛土即牒经。言权实者。即是观相。下五例知。二种生死四种涅槃下当广说。第五住

疏。初句九字流至于此者。谓句句皆有此菩萨所修善根皆为字

疏。顿现身器故者。前约广。释直语色类之多故云非一。今约深释。藏识顿变根身器世间故。为甚深。言出二量故者。现量比量不能量故。又过量无量故

疏。非是自他共所作故者。中论苦品云。自作及他作共作无因作。如是说诸苦。于果则不然。自他等义。下当广释。第六住

疏。又在执应毁者。上约不取声相而毁为非。今明合毁毁却顺理。商主天子经者。彼经云。又复问文殊师利言。若复有人毁汝所说。彼将何去。答言当向得涅槃。又问何缘作如是说。答言一切无有不毁语言。而能得至圣解脱中者。所以者何。其圣道中。无有名字章句语言可说可示。若不毁者彼等当不解脱。又问何缘作如是说。答言不可已得解脱复得解脱也。故言在执应毁。因言通理言语性空即是解脱。故云就理应赞也

疏。有量无量是断常边者。有量无量略有二义。一约竖论众生当尽不有众生故名为断。若常为众生即堕于常。二者横论。众生无边即堕于常。定有着常故。若傍有边涯即堕于断。傍更无故定无则断。有垢则众生界增。无垢则众生界减。难度则菩萨勤苦。易度即生安乐。又难度常受苦。易度亦得安乐也

疏。以不发心不知垢故名之为无者。是不发心者难度。则显已发心者则知有垢故易度也。如暗室中尘。若有隙光则知有尘。无光之处不见于尘

疏。法界有量等者。有量故断。无量故常。有成即增。有坏即减。若有即增。若无即减

疏。又约众生大悲大愿等者。上量无量等皆悉是过。但以般若正知不动。今明有量无量等。各有所以故皆不动。悲愿无限成其无量。了法界性。双成上二。故下经云。法界非有量亦复非无量。牟尼悉超越。有量及无量。既能超越故心不动

疏。知法界相下。释有成坏。缘成故有成。缘离故有坏。缘成故无成。缘坏故无坏

疏。体有相无下。释若有若无体有是圆成之有。相无是缘成之无。体无相有者则缘成之体。无自性故缘成之相。不坏相故则二体不同。实体则有。妄体则无。若约真俗二义别说。体有相无是真如上二义。体无相有是缘成上二义又体有体无皆真如上二义。相有相无皆缘起上二义。思之可知。上皆出所以故不动。况并下约观心故不动

疏。偈云听闻乃一义耳者。恐人引下文为难。下文云。一切诸法皆无相无体。性空。无实。如幻。如梦。离分别。常乐听闻如是义。故云听闻是一义耳。理实应须思修无相无体等法耳

疏。此与六地取染净等者。彼经初二句全同。但彼皆云平等耳。经云一切法无相故平等。无体故平等。想成即无体。三即无生故平等。谓诸入苦果虚妄分别为本。故无有生。知妄本真即圆成性故。今经云不可修也。四即无成故平等。然成则非有。五即本来清净故平等。所成果法无有真实。即是实性故清净也。上二三句即无染分。四五二句即遣净分。六即无戏论故平等。无戏论故即空。七即寂静故平等。故今云无性。无性故寂静。八九二喻即当彼我非有相。彼有八喻。今但有二而成二义。然前六以无遣有。此二以有遣无。云我非有。但无法我不坏于事。如幻事等非无幻化。幻化非真耳。十总离取舍出没想者。即今经无有分别。彼经云有无不二故平等。即双遣有无故无分别。而上疏。云十总离取舍出没想故者。取舍即论经别句。第六无取舍故平等云。出没即是论释。论云。六遣出没故。释曰出没取舍皆分别故。今既遣之故无分别。然彼句当寂静之后。前来未用留此说之。即与论经前后不同。唯一句耳。亦由有此故。云多同。言染净慢者。由彼五地观苦集是染。灭道是净。今深般若故能治之

疏。此如顺忍者。十地配五忍。四五六地配于顺忍。七八九地配无生忍。无生忍者即不退忍故。次疏。云然此位中已入无生。第七住

疏。今云不退有进趣义者。不退有二。一已得不退。即前心定不动。二未得不退。即今此位念念进入则是不退

疏。又权实方便下。此中通有四义。对前正心以释不退。上三义对前了法平等声如谷响故。此下一义。对前在执应毁就理应赞。故云有无等言皆有在故。从佛则色相虚无下。出有在之相

疏。出离有二约自行义同前文有垢无垢者。即前正心住中。众生有垢无垢上有二义。有垢则难度等。言亦约事理者。事则有出。理则无出

疏。虽许有佛不遍三世等者

疏。中先并出三世无。后俱有可知者。即并举三世有。既言不遍三世则诸计不同。或言过现有未来无。或言过现无未来有等。故云不遍

疏。现在生界未尽下。辨现在无佛义。此师计云。一切如来因地发愿度尽众生。生界不尽不取正觉。现见众生沉沦九有故。知诸佛未合有成。成则违誓。从今有佛者下通妨难。难云。若尔今十方世界诸佛出现。何得言无。答云。皆是菩萨应成佛耳。此师之计最为孟浪。谤无诸佛。理实难容。若尔云何。通于违誓之义。古有多释。一云。本拟度生未期成佛积行淳着行催自成。如拨火杖本欲烧草。不欲烧杖。拨草既多任运烧尽。故三论师詺。为不自在佛不欲成佛。而自成故。有云。成佛若不化生可违本誓。成竟亦化众生。岂违本誓。难云。化生之义虽许得存尽竟方成其义何在。岂得不违。如实义者诸佛皆有悲智二门。以大悲故穷未来际无成佛时。故菩萨阐提不成佛也。以大智故念念速成。又欲化尽诸众生界。自须速成方能广化不惧违誓。尽竟成言又了众生之本如故。化而无化是则常成。亦常不成。亦常化生而常无化。悲智自在。何局执耶。此乃傍来亦是人情好难问故。今许三世皆悉有佛。故下结。云谬说为无正说为有

疏。佛智有尽等者下。此亦常人之所好难就。竖约智体中。自有三义。初约体相说。言尽智者诸惑都亡。诸相皆寂故名尽智。智体湛然尽未来际。体不可亡故名无尽。二约权实说。三约修生本有说含两宗义。修生名尽约刹那尽。即法相宗。若无尽者即无刹那属法性宗。并如玄中

疏。二横就所知等者。一称理无尽。二无法不穷故名为尽。下引法华第一。智论第三论释。佛是一切智人。彼先难云。所知处无量故。无一切智人。答云。智亦无量。如函大盖亦大。是一切智人。函喻所知。盖喻能知

疏。今菩萨穷究下。结成邪正。言知依竖义半了半不了者。总相而言尽皆不了无尽皆了。若别说者。三释之中初一皆了。二中言永尽灭是邪是权。言不永灭是正是实。三中依权宗实则尽为不了。不尽为了。若约当宗随宜之说二俱是了

疏。又相待下。双拂二迹可知

疏。此大同地中乐无作行对治者。即是七地。由六地般若常乐无作。今起十行以为能治。法之有本不得不知。全引彼文恐成繁长。要自寻检。疏于一佛乘说无量故。此对即法华第一中意。故经云。诸佛以方便力于一佛乘。分别说三。又云。吾从成佛已来种种因缘种种譬喻。无量方便。引导众生。即从本流末。言虽有众多皆佛因者。即摄末归本。故彼经中三世诸佛皆云。以无量无数方便。演说诸法。是法皆为一佛乘故。第三云。汝等所行是菩萨道。又云。究竟至于一切种智故皆佛因。是知依实开权。说一即多会权归实。说多即一

疏。转变密意者。即文同义异也。如一名四实九义瞿声。如一无常之言。小乘即以生灭为义。大乘即以不生不灭而为其义。在遍计性则无可常。在依他性即说生灭。在圆成性则以转变。染净为义。故云转变。言密意者则如前引摄论之中。以异言词说异法等。言即如初句下。即指初句为文随于义。一多言同而有三义故

疏。义随于文显了直说下。释后句也。显了对上密意。直说对上转变。言即下三对者。明下三对唯是义随于文。但得释为事理无碍。不得通于事事无碍。及约权实如初句故

疏。若望下。偈云。下重会前义。前中文随于义。但约所诠有事事无碍。未明文望于义相望无碍。今由文成义则文有力全摄于义。由义成文则义有力全摄于文等。故成事事无碍也。以下偈云知。一即多。多即一文随于义。义随文。于是一切展转成。此不退人应为说即其文也

疏。三遍计情有理无者

疏。有两重。第一别约三性以明事理。若法相宗。遍计依他所明二义唯约于事。圆成二义方是于理。今法性宗。遍计理无。依他无性。即是于理。非有即有是理彻于事。有即非有即事彻于理等。其圆成二义即就理。上自论无碍。下第三无性对。于圆成亦然。拣非事事无碍及权实等。故上云三对但显事理无碍。疏又上三中。第二重释。则初三对。以遍计依他为事。二无性为理事理交彻。非有即有者。相无自性性即遍计所执。有即非有者。遍计所执即相无性。次对例知。三如前释。第八住

疏。永离习气唯佛得之者。即十八不共中之三也。如净行品

疏。无十不善失者。此是过失之失。下错谬者。是误失之失

疏。顿悟菩萨者。此法性宗。若法相宗顿悟八地方受变易。渐悟菩萨地前许受变易者。此法性宗。若法相宗渐悟初地许受变易。变易是一故开则为二。意生身者如回向说

疏。即十力智之四智者。解与乐欲本是一故开即为二

疏。此同八地若色若土皆自在者。八地得色自在。一身多身等十自在有净土分。第九住

疏。又知九种命终者。即俱舍论第三。三界命终各起三界心故。如欲界命终三者。一还起欲界心。二起色界心。三起无色界心。余二界命终起三类耳

疏。习气有四如九地说者。一因习气。二果习气。三道习气。四余残习气

疏。上四多同九地十种稠林者。初一摄二。谓一众生字即第一众生心稠林。二受生字即第九受生稠林。二烦恼现起。即彼第二烦恼稠林。三习气相续摄二稠林。一习气即是种子。即当第八随眠稠林。二即第十习气稠林。四所行方便摄六稠林。一摄第三业。二摄第四根。三摄第五解。四摄第六性。五摄第七乐欲。六摄第十三聚差别。以三聚稠林依根解性乐欲说故。释中略已含具。谓诸乘即根解性欲。作业即业所入法门。亦即三聚言及善巧故者。即此经方便所摄六林。皆是涉事为方便故

疏。五知法药是智成就义者。即彼经云。佛子菩萨摩诃萨。住此善慧地。如实知善不善无记法行。有漏无漏法行。世间出世间法行。思议不思议法行。定不定法行。声闻独觉法行。菩萨法行。如来地法行。有为无为法行故。今云无量法也

疏。六知法师轨仪者。即口业成就中具说之德故。经云。为大法师具法师行。论说二十法师。是七知所化处者即法师自在成就中说成就。经云。处于法座为演说法。于大千世界满中众生。随其心乐差别为说是也。八知化时等者。亦即说成就。亦最初经云。住此地已。了知众生诸行差别。教化调伏。令得解脱等

疏。后二依二谛说者。即口业。得四十无碍辩才。不出二谛故。彼文云。词无碍智以世智差别说。乐说无碍智以第一义智善巧说等。中论云。诸佛依二谛为众生说法

疏。菩萨入则观佛教理下。佛合上父。教合前声。色合前理。显然可见故。可化曰贤。不可化如愚

疏。菩萨六度四等万行总持皆力义者。次第合上。施合聚人以财。尸罗合慎危以戒。乃至般若合智。四等合仁。愍伤不杀以为仁故。万行总持合上制敌以众

疏。持财以俭等者。上来释力。此下释持。略举其四。俭则财不散故不可贪也。无信于物。人皆远之故信及豚鱼。况于人乎。大车无輗小车无軏其何以行之哉。故可去食去兵。不可去信。持安以不憍者。在上不憍。高而不危则长守富贵斯则安矣。故百姓者水。圣人者舟。水能载舟亦能覆舟。是故不可不慎危也。若人奢侈则力竭也

疏。为上勿亢者。周易乾卦云。上九亢龙有悔。谓亢极则忧悔至焉。桀纣是也。孝经云。在丑不诤则无兵畏丑者背也。类也。疏菩萨入定同佛不过明以耽其味者。合上昼无故不内宴。昼宴则耽其味。明合上昼。过明者慧增定少也。言不昏沉以滞于境者。合上夜无故不外寝。昏沉合夜。滞境合外寝。无幽不得其味。合宴于侧室。正定不易其心。合寝于正处

疏。情诣于理下。合赞音宜和乐。叹音宜哀思。合哀即哀。合乐即乐。是诣理也。使其欣厌有二义。一成上厌其哀欣其乐。厌生死苦。欣涅槃乐。二者合上其情切其辞文。文故可欣。切故可厌。第十住

疏。多同大尽分智成就说者。大尽分则第十地八分之中第四分。此分有五种大。一智大。二解脱大。三三昧大。四陀罗尼大。五神通大。今经前五即神通兼解脱大。即作用解脱故。后五摄余三大。多同智大故。故智成就说

疏。皆神通力有上无上分者。即第六分其胜进十法。即彼经云。佛子此菩萨摩诃萨。已能安住如是智。诸佛世尊。复更为说三世智。法界差别智。遍一切世界智。照一切世界智。慈念一切众生智。举要言之乃至为说得一切智智

疏。问此经何要十方同说者。此下料拣于中三。初问法同。二问处遍。三论文次。今初问何要。此彼同说十住。那不或有国土说一乘。或有国土说二三等

疏。问说此经处何要遍者。第二问处遍。上约所说之法同。此明所说之处遍。又前明彼此同说。今明一说即遍

疏。有云。此上瑞应下。三辩文次。即刊定难经。偈中疏。一位不退等者。初一不退为二乘。二已得不退。三未得不退。十住品竟

大方广佛华严经随疏演义钞卷第三十八大方广佛华严经随疏演义钞卷第三十九

        唐清凉山大华严寺沙门澄观述

    梵行品第十六

初来意有六者。初一行位相对。前虽有行意在位故。二通别相对。如前初住自分但明缘境发心。胜进但明勤供养佛乐住生死等。二住自分但于众生起利益大悲等十心。胜进但明诵习多闻虚闲寂静等。则十住所修一一不同。今此梵行十住通修故。三道俗相对。以文云一切世界诸菩萨众。依如来教染衣出家。答中广明受随戒等。前之十住不拣道俗也。四即随相实相对。言随相者。即如前别行。行既不同即是随相。今此观意于身无所取。于修无所著。乃至受无相法。观无相法。知一切法即心自性等故。五即因果相对。以问云云何而得梵行清净。从菩萨位逮于无上菩提之道。初菩萨位即十住位也。以说位竟恐物寻因故令修此。如先知灭后示道故。六标释相对。即总释前义。谓前一一位末。皆云欲令菩萨有所闻法。即自开解不由他教。此但总标故。今释云与此观行相应即得初心成佛。知一切法即心自性。成就慧身不由他悟

疏。二释名者。文分四。一正释名。二出体性。三结成本名。四对前拣异。今初有三。一总释。若译就此方应名净行。为拣前故此存梵音二真境为梵约因中释。三涅槃为梵约因果对释。并可知也

疏。梵行以何为体下。二出体性。于中有三。初列三类。二涅槃五行下对辩异同。三然此三下。别释其相。二中言五行者。即涅槃十一圣行品。谓一圣行。二梵行。三天行。四婴儿行。五病行

疏。即四无量亦七善知者。经具此二古德出体亦用此二。其梵行品。在十五经。四无量义次下自明。亦七善知者。经云。善男子云何菩萨摩诃萨梵行。善男子菩萨摩诃萨住于大乘大般涅槃。住七善法得具梵行。何等为七。一者知法。二者知义。三者知时。四者知足。五知自。六知众。七知尊卑。彼文广释。今当略示。知法谓知十二部经。知义谓一切文字。语言善知其义。知时谓如是时中堪修静虑。如是时中堪修精进等。知足谓饮食衣服药等。知自者。谓我有如是信戒等。知众。谓刹利婆罗门等。知尊卑云。善男子有二种人。一者信。二者不信。菩萨当知信者。是善。不信者不名为善。信复二种。一者往诣僧坊。二者不往。往诣者善。不往诣者不名为善。如是礼拜听法。志心思义如说修行。求声闻乘回向大乘。展转皆同初二故。后结云。回向大乘最上最善不出尊卑之名。意云善者为尊。不善者为卑。则后后尊于前前耳

疏。梵即是净下。第三结成本名。此用净名经势会通异释。皆为总意。前释名中。有其三释。今云梵即是净者。是前总释持业受名。但以下会取上二。性净即前真境为梵真境既是净行之因。不得行外说净。净即行矣。又云行净即智慧净者。行净即是智慧之因。不可独以智为行也。智净即心净者。亦不但以真境而为净也。心净即一切功德净者。会前涅槃为净修因为行。今因亦净矣。乃至成佛功归于行者。归净行矣。既涅槃果由净行成。何得偏言涅槃为净。是知行即净矣。言以净名势者。彼经云。是故宝积随其直心则能发行。乃至云随说法净则智慧净。随智慧净则其心净。随其心净则一切功德净。即其文也。文势已知。何以性净则得行净等。谓称理起行。行成智立。由智立故。见心本净心。为其主。何德不成故相由矣。疏然前信下。四对前辨异可知

疏。梵依天行而得成者。涅槃天行经文。不释指在华严。古人出体亦有二义。一指八禅。二即净天。净天即第一义天。见第一义梵行成矣。故梵依天行得成

疏。故不应言净劣梵也。此拣异释。异释云净行品劣故名净行。十住明梵。明知胜也。故今弹云。云何而得梵行清净。梵行是其所净。何得胜于净耶

疏。身通不善者。五阴成身行阴通不善摄。言体非顺理者。顺理生心名为善故

疏。二体是无记者。色是报色故为无记

疏。四自相臭恶者。此中示五不净。即智论云。行者依净戒住。一心行精进观五种不净相。一种子不净。谓揽父母精血。业因识种以成身分故。二住处不净。于母胎中生藏之下。熟藏之上故。三自体不净。谓三十六物以成身故。四自相不净。亦名外相不净。谓九孔常流。眼出眵泪。耳出结矃。鼻中流涕。口出涎唾。大小便道常出不净。五。究竟不净。气绝已后[月*逄]胀臭烂。甚成可恶。今疏已闇配

疏。六种子住处等皆可厌故者。然五不净皆悉可厌。以上配自性自相。下配究竟故。牒此二等取余三。言皆可厌者。智论五皆有偈结之。一种子偈云。是身种不净。非余妙宝物。不由白净生。但从秽道出。二住处偈云。是身为臭秽。不从华间生。亦不从瞻卜。又不出宝山。三自性偈云。地水火风质。能变成不净。倾海洗此身。不能令香洁。四外相偈云。种种不净物。充满于身中。常流出不止。如漏囊盛物。五究竟偈云。审谛观此身。必归于死处。难御无反复。背恩如小儿。结云。行人修此观。成破净倒想。故知五种皆可厌也

疏。十八万户虫者。诸经多说。下十藏品自有明文。观佛三昧海经观相品云。云何菩萨降魔时白毫相光。乃至云魔有三女至菩萨所。白菩萨言。我是天女盛美无比。今以微身奉上太子。供给左右可备扫洒。太子寂然身心不动。以白毫拟之。令三天女自见身内。脓囊涕唾九孔筋脉。一切根本大肠小肠。生藏熟藏。于其中间。回伏宛转踊生诸虫。其数满足有八万户。户有九亿诸小虫等。游戏之时走入小肠。皆有四口张口向上。大虫游戏入大肠中。从肠出已复入胃中复生四虫如四蛇合。上下同时唼食诸藏滓尽汁出。入眼为泪入鼻为涕。聚口成唾放口成涎。薄皮厚皮筋髓诸脉。悉生诸虫细于秋毫。众数甚多不可具说。其女见此即便呕吐。从口而出无有穷尽

疏。全以虫成者。即大婆沙中说。人身内并是虫聚虫头在内食人所食。虫尾在外。辫作人皮故

疏。今此梵行体是可轨者。总明上身十事。非梵行义一一别配。体是可轨对上非法。澄净对上浑浊。余文可知

疏。身之作用名为身业者。俱舍业品颂云。世别由业生。思及思所作。思即是意业。所作谓身语。广如九地说。疏风触七处等者。即智论第七云。如人欲语时。口中有风名优陀那。还入至脐即有响出。响出之时触七处。过名生语言。如有偈说风名优陀那。触脐而上去。是风七处触。项及龂齿唇舌咽及以胸。是中言语生。愚人不解此。惑着起嗔痴。然楞伽第二第三皆有其文。第二云。佛告大慧。项胸喉鼻唇舌龂齿和合出声。释曰。此有八处加鼻一种。鼻塞语虽小拥而亦得语故论略无。第三中说。但有七事。经言云何语。谓言字妄想和合语。依咽喉唇舌齿龂颊辅。因彼我言说妄想习气。是名为语。释曰。于前八中略无项胸鼻。而加颊辅。言字妄想者。显言空故。次经即云。大慧云何。为离一切妄想言说相。大慧菩萨。于如是义。独一静处闻思修慧。缘自觉了向涅槃城。习气身转变已。自觉境界观地地中间胜进义相。是名菩萨摩诃萨善义。释曰。此即下观破意。疏第五观意等者。然此意具即是意根。有说。即第七识唯缘内门不得有梦等。若金光明经。意根分别一切诸法。即许外缘故。海东晓公立外缘义。又密严经云。如蛇有二头各别为其业故。或云第六识无间灭意。今正当此随转理门就他宗说

疏。觉是寻求。观是伺察者。旧名觉观。新译为寻伺

疏。用俱舍等释寻伺言以解觉观。唯识云。寻谓寻求令心匆遽。于意言境粗转为性。伺谓伺察令心匆遽。于意言境细转为性。皆以思慧而为其性。唯识论云。并用思慧一分为体。于意言境不深推度。及深推度。义类别故。若离思慧。寻伺二种。体类差别不可得故。此二俱以安不安住。身心分位所依为业。彼疏释云。身心若安寻伺二种徐缓为业。身心不安匆遽为业。又云。或思名安。徐而细故。思量性故。慧名不安急而粗故。拣择性故。身心前后有安不安。皆依寻伺故。名所依

疏。是不定法者。出总体相。唯识论云。不定谓悔眠寻伺二各二。释相如前故

疏。三分别中是自性分别者。即杂集第二云。有三分别。谓自性分别。随念分别。计度分别。其种种分别。以配余二。言自性分别者。谓于现在所受诸行自相行分别。随念分别者。谓于昔曾所受诸行追念行分别。计度分别者。谓于去来今不现见事。思择行分别。言七分别者。论云。复有七种分别者。谓于所缘任运分别。有相分别。无相分别。寻求分别。伺察分别。染污分别。不染污分别。初分别者。谓五识身如所缘相。无异分别。于自境界任运转故。有相分别者。谓自性随念二种分别。取过现境种种相故。无相分别者。谓希求未来境行分别。所余分别皆用计度分别以。为自性所以者何。以思度故。或时寻求。或时伺察。或时染污。或不染污。种种分别故。瑜伽云。寻求分别者。谓于诸法观察寻求所起分别。伺察分别者。谓于己所寻求己所观察。伺察安立起分别故。染污分别者。谓于过去顾恋俱行。于未来希乐俱行。于现在执着俱行。所有分别。若欲分别。若恚分别。若害分别。或随与一烦恼随烦恼。相应所起分别。不染污分别者。若善无记。谓出离分别。无恚分别。不害分别。或随与一信等善法相应。或威仪路功巧处。诸变化所有分别。释曰。杂集。后四相隐故。引瑜伽释之。今但云分别即是初一。种种分别即是余六。对疏可知疏。上六皆别境释者。别境有五。一欲二胜解三念四定五慧。下。当频释

疏。种种忆念义兼恶作者。即上引唯识偈。云不定谓悔眠寻伺二各二是。释曰。初二字标位总名。论云。悔眠寻伺于善染等。皆不定故。非如触等定遍心故。非如欲等定遍地故。立不定名。次五字分别名字。悔谓恶作悔所作故。追悔为性。障止为业。此即于果假立因名。先恶所作业后方追悔故。悔先所作。亦恶作摄。如追悔言我先不作如是事业。是名恶作。释曰。此有二意。一悔先作恶。二悔先不作善。既追善恶即种种忆念摄。二各二之三字释不定义。下长行释云。应言二者显二种二。一谓悔眠。二谓寻伺。此二二种种类各别故。一二言显二二种。眠是不定者。即上论长行云。眠谓睡眠令身不自在。昧略为性。障观为业。谓睡眠位身不自在。心极暗劣一门转故。昧拣在定。略别悟时今显睡眠非无体用。有无心位假立此名。如余盖缠心相应故。释曰。谓睡眠位下。释上不自在言。谓令身不自在。坐亦睡眠故。他摇动时。亦不觉等故。此令心极暗昧。轻略为性。不能明利沉审故

疏。云意识亦行。即是论一门转故。显五识不行。定心一境略而不昧。故云昧拣在定。悟广缘境不得称略故。云略别悟时。故眠有二。显有别体。必依于心。而五无心。一熟眠者。假立为眠非实眠也。眠必与心而相应故如余盖等。言轻眠有梦者拣异熟眠。得显此眠是不定摄。通善恶故梦有善恶故

疏。此十是心所等者。谓既释于意。意是心王而说所者所不离王故。又五蕴中除其色声。意业摄故

疏。约遍行五征者。唯识第五云。谓触作意受想思。一切心中定可得故。名为遍行。又具四一切故。谓遍一切三性。二遍九地。三遍一切有心时。四遍一切位。谓随何位心所故。谓触和合胜。论列在初。瑜伽等作意在初。作意者谓能警心为性。于所缘境引心为业。谓此警觉应起心种。引令趣境故。名作意。虽此亦能引起心所。心是主故。但说引心。作即是意持业释也。或作俱时意邻近为胜。云何为触触谓。三和分别变异。令心心所触境为性。受想思等所依为业。谓根境识三互相随顺故名三和。触依彼生令彼和合。故说为彼。名三和合位皆有顺生心所功能。说名变异。触似彼起故名分别。根变异力引触起时。缘彼识境。故集论等。但说分别根之变异。和合一切心及心所。令同触境。是触之性。既似顺起心所功能。故以受等所依为业。云何为受。受谓领纳顺违俱非境相为性。起爱为业。能起合离非二欲故。云何为想。想谓于境取像为性。施设种种名言为业。谓要安立境分齐相。方能随起种种名言。云何为思。思谓令心造作为性。于善品等役心为业。谓能取境正因等相。驱役自心令造善等。此后四种并无六释。释曰。以名多同于遍行故。作意观察遍于十段。顺论先释

疏。即上四段亦各是一蕴者。即向遍行五也。约经而言。思即行蕴。想即想蕴。寒热饥渴是十一触。属于色蕴。苦等受蕴作意亦行。然触通身心。上约寒等必与心俱故。属遍行。今约身触故属于色。若尔身触在五识地。今何在意。答有三义故。一由相应义。谓意识与五有同缘境故。二由意识用。强有彼同分缘故。三由意识。于极乐地有乐触故。于极苦趣有意苦故。上寒热准知。上三义中前二约触。后一兼明于受。寒是冷触。热即火大。能造触也。俱舍亦说此之四触亦是心所。论云。食欲名饥。暖欲名冷。饮欲名渴。彼疏。释云。冷饥渴三是触家果。而非是触。今言触者从果为名。故论云。此皆因立果称。释曰。暖欲名冷者。热准于冷。冷热相翻义亦有欲。故此四种皆为意业

疏。后四是受者。即苦乐忧喜。然圣教说受开合不同。或总名受即遍行数。或分为三。谓苦乐舍。唯识论云。领顺境相适悦身心。名为乐受。领违境相逼迫身心说。名苦受。领中容境相于身于心。非逼非悦。名不苦不乐受。或分为五。谓苦乐忧喜舍。唯识论云。诸适悦受五识相应但名为乐。意识相应若在欲界初二静虑近分名喜。但悦心故。若在初二静虑根本名喜悦身心故。若在第三静虑近分根本名乐。安静尤重无分别故。诸逼迫受五识相应但名为苦。意识俱者。有义唯忧逼迫心故。有义通二人。天中者但名为忧非尤重故。傍生鬼趣名忧名苦。杂受纯受有轻重故。捺落迦中唯名为苦。纯受尤重无分别故。三中苦乐各分二者。论云。适悦身心相各异故。由无分别有分别故。尤重轻微有差别故。四不苦不乐不分二者。论云。非逼非悦相无异故

疏。此中思等下。问答拣滥。先问以前意中有觉观思惟。此中亦有思想等故。但思等下答。答意云。思等有二。一约体则扶持心王。同为业具。二约用与王相应同作业故。言故多从受境以辨者。释此为业之由。谓业中十句想即取境。寒等触境。苦等受境皆约境也。则此中思即审虑决定。前虽有觉观思惟多直语心故意业十中思即意业能造业故。想是意之加行。令意成业根本故。次四触数识合根境。由业引故。后四受数。亦由业引故此上皆业眷属。成唯识云。业之眷属亦立业名即其义也。若欲破可知。疏第七观佛言无漏戒等者。等取定慧解脱解脱知见。此从已转受名。广如十藏品。言及眷属无漏五蕴者。即色受等前无漏戒虽转五成。而各取一。以为其主故。今辨定慧等。同时心心所为眷属五蕴

疏。以三祇等者。三祇修成法身。百劫修三十二相八十种好。次一神通化现。即是化身。义兼万类之化。若依大乘唯说二身。法身即是征破。所显故

疏。今一一推征者。疏文。有四。一正破。二引证。三遮难四结成。今初先一异门破。后和合成下因缘门破。二。故中论下。引证具证二义。先证一异初会已释。今疏文。有当重略释。言非阴者即阴不是如来。阴生灭故。不离阴者。离阴亦无如来无相知故。此彼不相在者。三如来不在阴中。四阴不在如来中。此二皆由不异故五阴属如来。谓阴如童仆故。云如来不有阴。何处有如来结破也

疏。阴合下证上因缘门。谓若缘合方生即无自性故。疏进退推求者。离阴别求为退。即阴合求为进。并皆不可故。知体寂

疏。尚非是有者。第三遮难。难云。若尔应无如来便堕断见故。今遮云。邪见有二。谓有为浅。谓无为深。破汝浅邪。何堕深壑。皆中论文并如上引

疏。是知真佛下。第四结成。法身显矣。疏第八观法中三。初通辨意。二然法有下释文。言谓不善不生者。谓约理则法本不生。约行则无不善可生故。净名经云。不善不生。善法不灭。余义可知。此六下约果。三今推征下。后明观相。亦是一异因缘门破。从若以无法下遮救。救云。即此无合是真法矣。故今答云。岂当有耶。后又此举下。就文显意

疏。第九观僧。且依小说者。大乘亦有四果故。言预流者。俱舍云。诸无漏道总名为流。初预此流故名预流。谓断见道烦恼尽忍智具足故。二一来者。欲界九品烦恼能润七生。已断六故次下当知。疏谓断三界见惑者。不同修惑分三界别一时断故。言十六心者。即苦法忍苦法智苦类忍苦类智。集法忍集法智。集类忍集类智。灭法忍灭法智。灭类忍灭类智。道法忍道法智。道类忍道类智。为十六心。谓观欲界苦。有苦法忍苦法智。观上二界名苦类忍苦类智。余三亦然故有十六。夫言见道见未曾见。道类忍中已见上苦故。第十六不名见道。便入修道。广说其相如回向品。疏欲界修惑分为九品者。亦俱舍文合其二处偈文。一云依十五心位建立众圣者。具修惑。断一至五向初果。断次三向二。断八地向三。次论云。次依修道类智时。建立众圣有差别者。颂曰。至第十六心随三向住果。上皆二十三论。此下第二十四论云。已辨住果未断修惑。名为预流生极七返。今次应辨断位众圣。且应建立一来向果。颂曰。断欲三四品。三二生家家。断至五二向。断六一来果。释曰。初二句明家家。谓预流进断修惑。若三缘具转名家家。一由断欲修惑三四品故。二由成无漏根故。三由更受三二生故。颂中略无成根之言。以理合有略故不说。若断三品名受三生。若断四品名受二生。谓九品惑能润七生。且上上品惑能润两生。上中上下中上各润一生。中中中下合润一生。下三品惑共润一生。既上三品能润四生故。断上三四生已损名受三生。更断中上一品复损一生故。断四品总损五生但受二生。故云三二生家家也。所以无断一二品惑名家家者。以得初果起大加行。必无断一二。不断第三。有死生者。亦无断五生家家者。由断五必断第六即证一来。无一品惑能障于果故。若无一品能障果者。何以有断八品未断第九而有死生。答第九一品。一者断竟得果。二者复超欲界故。此第九能障于果。六不超界故不障果。言家家者。家不一故家家有二。一天家家。或于欲天受三二生。二人家家。即于人中受三二生。后证圆寂故。已释上半。下半明其向果。既断六品得于一来。故断下五名趣向第二。论次名不还。云断七或八品一生名一间。此即第三向断九不还果。释曰。有三缘具名为一间。上之二句即是二缘更有第三得无漏根。以为能治易故不说同前家家。以下三品共润一生。故断七八余第九在亦有一生。而为间隔故名一间。有一品惑不证不还。有一生在不证圆寂皆名一间。即此一间是不还向。九品全断更不还来生于欲界成不还果。罗汉向果在文可知

疏。今此欲明下明不广之由

疏。此中观意辨作意观察。就因缘门明无性性空疏况于入流无所入等。上总集八辈以明性空。今明一一皆不可得。即金刚般若经意。彼经佛问须菩提云。须菩提于意云何。须陀洹能作是念。我得须陀洹果不须菩提言不也。世尊(下三果皆有此问答)何以故须陀洹名为入流而无所入。不入声色香味触法。是名须陀洹。二问斯陀含。答云。何以故斯陀含名一往来。而实无往来是名斯陀含。三问阿那含。答云阿那含名为不来。而实无来是名阿那含。四问阿罗汉。答云实无有法名阿罗汉。世尊若阿罗汉作是念。我得阿罗汉道。即为着我人众生寿者。世尊。佛说我得无诤三昧。人中最为第一。是第一离欲阿罗汉。我不作是念。我是第一离欲阿罗汉。世尊若我作是念。我得阿罗汉道。世尊。则不说须菩提是乐阿兰那行者。以须菩提实无所行。而名须菩提是乐阿兰那行。释曰。此是第五胜中无慢住处中文。明四果人已舍慢故。此中大意皆明四圣心离见慢契第一义故不生念矣。初果初入圣流。不入尘境方名入流。若念得果入法尘矣。故不入尘则无念矣。下三果例知。今疏意云。合于八辈已显僧宝性空。况一一无念契真何有僧可依也。疏以无为法而有差别。亦是彼经次前之文。经云。须菩提于意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶。须菩提言如我解佛所说义。无有定法得阿耨多罗三藐三菩提。亦无有定法如来可说。何以故。如来所说法皆不可取。不可说。非法非非法。所以者何。一切贤圣皆以无为法而有差别。释曰。今但用后释文。前之一段亦可证前观法。故具引之。谓一切圣人由证无为有浅深故而有差别。别同无为即无差矣。无为之中何有八辈凡圣相耶。故皆契性空矣。上一段经即证得法身住处文中。智相证得法身文也。疏第十观戒文。三初总明。二其中下别释。三料拣。今初。上来九门结观。于后独今此段先明实观。疏戒性如空等者。即法句经六度皆有偈文。布施云。说诸布施福。于中三事空究竟不可得。施福如野马。戒云。若说诸持戒无善无威仪。戒性如虚空持者为迷倒。忍云。若见嗔恚者。以忍为羁鞅。知嗔等阳焰。忍亦无所忍。精进云。若说诸精进为增上慢。说无增上慢者。无善无精进。若起精进心是妄非精进。若能心不妄精进无有涯。定云。若学诸三昧是动非坐禅。心随境界流云何名为定。般若云。森罗及万像一法之所印。云何一法中而生种种见。一亦不为一。为欲破诸数浅智之所闻。见一以为一。结云若有闻斯法常修寂灭行。知行亦寂灭是则菩提道。释曰。今疏释戒但用戒文。而离破倒余者乃义引耳。疏不杂二乘心者。即涅槃文。是名持净戒等总结上文也。疏乞食四依之一者。四依。谓一长乞食。二粪扫衣。三冡间树下坐。四食腐烂药亦名四圣种。智论七十二云。又受戒法尽形寿着衲衣乞食。树下住服弊弃药。于四种中头陀已摄三事。若俱舍正理婆沙。前三所得食衣卧具喜足为三。四依有无药乃加药断乐修圣种所以不同者。智论意显先古四圣种。即是四依。婆沙等依新论师。除药加第四。以前三为道资缘。四为道体性。言圣种者。谓善故无漏故名圣。即此能生诸功德法。相续不断故名为种。故云乞食即四依之一。言四邪者。智论第四释比丘。名乞士。清净活命故名乞士。如经中说舍利弗入城乞食。得已坐食。有梵志名净目。问言汝食耶。答言食。净目言。下口食耶答言不。仰口食耶。答曰不。方口食耶。答曰不。维口食耶。答曰不。净目言。食有四种我今问汝。汝皆言不。我今不解。汝当为说。云何下口食。舍利弗言。有出家人。合药种谷植树等。不净活命者是名下口食。观视星宿日月风雨雷电霹雳。不净活命者是名仰口食。曲媚豪势通使四方巧言多求。不净活命是名方口食。学种种咒术卜算吉凶。有如是等不净活命者是名维口食。我不堕是四食中。我用清净乞食活命。净目闻已欢喜信解。舍利弗因为说法得须陀洹。五邪者。即智论二十二已见净行品。今更重举。一为利养故。诈现异相奇特。二者为利养故自说功德。三者为利养故占相吉凶。及为人说。四者为利养故。高声现威令人畏敬。五者为利养故。称说自己所得利养以动人心。邪因缘活命故为邪命。疏若依菩萨下。第三料拣。前列十事参大小乘。此方菩萨律仪阙故。于中有四。一总引二文彰大小异。弥勒羯磨唯请一师须归三宝。别有羯磨文等。二此上十境下。次出对会所以。以西天大小抗行寺居不杂。是故结云即如此方。谓依小乘受行大乘行。三又善戒经下。正示大小二相不同。言先受前之三戒者。彼经第五菩萨戒品云。在家出家戒有三种。一者戒。二者受善法戒。三者为利众生故行。释曰。此即三聚也。次云云何名戒。所谓七众戒。比丘比丘尼。式叉摩那。沙弥沙弥尼。优婆塞优婆夷。菩萨摩诃萨。若欲受持菩萨戒者。先当净心受七种戒。七种戒者是净心趣菩萨戒。如世间人欲请于王。先当净治所居室宅。是七种戒俱是在家出家菩萨所受。菩萨戒者亦复如是俱是在家出家菩萨所受。释曰。上语七众通于男女等。今辨三戒唯约比丘。谓五戒十戒二百五十。此三以为菩萨戒前之方便也。彼经云。若言不具优婆塞戒。得沙弥戒无有是处。不具沙弥戒得比丘戒者。亦无有是处。不具如是三种戒。得菩萨戒亦无是处。譬如重楼四级。乃至不从三级。至第四者无有是处。释曰。以此故须先受三也。四故所观境下。结成本义。所观通大小者。依菩萨受亦是所观。依小乘受亦是所观。能观智唯实教大乘者。即相同性离相戒故。疏第四如是观下。辨观成之相者。即如实观成。此有二意今从后意标名言。望前寻伺即为观益者。前来作意观察十境故为寻伺。即念想观犹未除故。今念想观除故为前观之益。义同四加行中四寻伺四如实也。疏初六明三轮清净者。谓具离三轮。然准瑜伽第六。六度各有三轮不同。施三轮者。一施者。二受者。三施物。今皆离之戒离三轮者。离众生事时分别。忍离三轮者。离自他过失分别。进离三轮者。离众生高下事用分别。定离三轮者。离境界众生惑分别。般若离三轮者。离境界智众生分别。今言六句明三者。一即离众生。二三皆离事。言亦通不住前法者。以第三句通不住前众生及事。不住即离故。次三句三时门通是离时耳。兼释不取等言者。即以三时释上三句。不取等者等取不着不住。言以刹那不住过未分之者。刹那生时未生即未。已生即过故。云已未分之。影公云。如疾炎过锋奔流迳刃。刃上一毫亦为二分。故无现在故空寂也。以求现不得故。疏后二句以不迁理释成者。即肇公不迁论意。问明已用今复用之。疏文有四。一标。二此世下用论文释经。论云是为昔物自在昔。不从今以至昔。今物自在今。不从昔以至今故。仲尼曰。回也见新交臂。非故如斯。则物不相往来明矣。三是为因自昔灭下。以论意出经意。四以物各性住下。释不迁所以。上句即肇论所以。后性本空故。疏出所以亦是论意。如下云既无往返之微眹。复何物而可动哉。又云。是以言常而不住。称去而不迁。不迁故虽往而常静。不住故虽静而常往。虽静而常往故往而不迁。虽往而常静故住而不留矣。斯则即动即静之义。故前标云必求静于诸动。故虽动而常静。但以正释。即言物各性住则唯前意。斯则假其性住破其迁流耳。疏有说。无作戒体体即是色者。即萨婆多宗也。有说。非色非心者。即昙无德宗义。依成实论立。疏今言为是色者。显非是色者。其为是之言此征辞也。故双征云为是色。为非是色。征此二法俱不可得。应假答云。非是色亦非非色。今疏离斯二句便破两宗。上句破有宗。下句破德宗。今初显非是色正破色也。以其所立无表依表生。表色无表色者。即出有宗所立色为戒体文也。然俱舍界品立有无表色。有三师义。一杂心师云。表色有变碍无表随彼亦受色名。如树动时影必随动。论主难云。此释不然无变碍故。又无表依表生。表色无表色。如树影依树生树色影亦色。又难云。表灭时无表应灭。如树灭时影必随灭。树影依树生。树灭影亦灭。无表依表生。表灭无表灭。论主云。不然。如子堂牙。子依于父生。父灭子犹在。无表依表生表灭无表在(堂喻牙喻亦然)二云。五识所依大种变碍故无表业亦名为色。即有宗义。若尔所依有变碍故。眼识等五亦应名色。此难不齐。无表依止大种转时。如影依树。光依珠宝。眼识等五。依眼等根则不如是。唯能为作助生缘故。意云。不应以眼等为增上缘之疏依难亲缘。故论主又破云。此影依树。光依宝言。且非扶顺毗婆沙义。彼宗影等显色极微。各自依止四大种故。论主又纵破云。设许影光依止树宝。而无表色不同彼依。彼许所依大种虽灭。而无表色不随灭故。三复有别释彼所难言。眼识等五所依不定。或有变碍。谓眼等根。或无变碍。谓无间意。无表所依则不如是。故前所难定为不齐。变碍名色理得成就。此即论主成第二师。故名第三。释曰上来三义但是二意。以其第三成第二故。虽有二义并依色成无表色义。故涅槃云。菩提王子意疑。比丘善心受戒。至恶无记应名失戒。故经问云。若有比丘护持禁戒。若发恶心当知是时失比丘戒。佛言戒有七种。从于身口有无作色。以是无作色因缘故。其心虽在恶无记中。不名失戒犹名持戒。以何因缘名无作色。非异色因。不作异色因果。释曰。此有两重问答之意。前答不失戒因。因无表故。后非异色因下。自释无表得色名因由。言非异色因者。明以色为因。不是异色之外别物为因。言不作异色因果者。明作色果也。不作异色之外别物之果。既以色为因与色作果故。无表戒得成色也。若将此文释不失戒。则成不知问答之本。余诸异义恐繁且止。然今疏意。但取彼立无表是色而为所破。不克定彼无表色义。若取文同即杂心义。疏今明观意者。即破意也。执破观成。然此正破杂心。不同俱舍破意。彼破其立义不正。今破遣相显理耳。疏谓非色者显非非色者。破德宗意。彼立意云。非变碍故不可为色。非虑知故不可名心。即非色非心。不相应行摄。破意可知。疏虽空不碍涉有故。此释方便自在。即显虽无心于持犯。而七支皎净。三业无瑕摄善利人无不为矣。以前观空非断灭故。疏我不见一法非佛法者前已曾引。谓不毁不持法界平等。由此该融故有第九一具一切也。疏此中五喻者。疏文显指十忍。闇用净名文并可知。疏第二大段等者。此下义则深玄在文可见但当细寻更不繁举。其开发之发等后品当知。不由他悟含有三义如十住品。谓见夫心性性外皆他。自亦不存兼显以心为自心外为他。今自心不存岂心外取法。岂唯定之方寸等者。显自心为自。他人为他。前十住品从粗至细。今此以细况粗耳

    初发心功德品第十七

言举初况后巧显深胜者。初发心位劣功德难思。后后位高德无涯矣。疏一三种发心之初者。起信论发趣道相中论云。略说发心有三种相。云何为三。一者信成就发心。二者解行发心。三者证发心。今即第一故云三种中初。所以知是初者。论云。信成就发心者。依何等人。修何等行。得信成就堪能发心。所谓依不定聚众生。以有熏习善根力故。信业果报能生十善。厌生死苦求无上菩提。得值诸佛亲承供养。修行信心经一万劫信心成就故。诸佛菩萨教令发心等。或以大悲自能发心。或因正法欲灭。以护法因缘能自发心。如是信心成就得发心者。入正定聚毕竟不退。名住如来种中正因相应。次说发三种心已如十住品。又云。发是心故则得少分见于法身。以见法身故随其愿力。能现八种利益众生。所谓从兜率天退等。二解行发心者。当知转胜。以是菩萨从初正信已来经于第一阿僧祇劫将欲满故。于真如法中能深解现前所修离相。以知法性无悭贪故。随顺修行檀波罗蜜等。三证发心者。从净心地乃至菩萨究竟地中。证何境界所谓真如。以依转识说为境界。而此证者无有境界。唯真如智名为法身。是菩萨于一念顷。能至十方无余世界。供养诸佛请转法轮。唯为开道利益众生不依文字。释曰。上已明三种发心。第三登地已上。第二从十行发回向心。以十行中能解法空。顺行十度行法纯熟发回向心。从其因边名为解行。今非后二正与初心相应故。疏二十住之初拣余九住。彼名初发心住故。发亦二义。一发起上求心望后论发。二三德开发者。望前论发。从初信心始入佛法。即发趣求如来果位。寂照双流常观心性。功行既着至此开发。如发金藏见真金等。于中四意。初标。二能知下。示三德相。即下经文。三在于信位下。释开发义。言研穷者。从初信入寂照双流常观心性。精修诸度以此为因。豁然开悟是开发相。如发金藏了见分明。四故得下。仍前释于功德之义。疏三即以初心下。第三宗趣。于中二。一正释宗趣。二然住会下。拣异释。于中三。初正拣。二遮破。三结成。今初即安国意。然彼有二意。一云。此中三贤别说十地。十地一会总说十地故。其四会皆是十地。二者以此品中文义深奥同十地故。今疏一文一时双破。而正破初意。今是十住之会说初发心。是明信成就摄后二。自属第五六会何得浑和。若言别说合说略有四失。一令此经无三贤义。二令余经三贤虚设。三成此经文义杂乱。谓以地义名住行向故。四何不一天总别说耶。而历四天盖有所表。是知此说殊乖教理。故云住会发心定是信成就等。疏生如来家自约解说下。第二遮破。彼云。据文既云初发心时便成正觉。应是初地。况下经云以生如来广大家。能生三世一切诸佛家。永断一切诸疑网。尽除一切诸障碍。若非初地安得尔耶。岂有久习无明。才一发心便成大智。能知前际一切诸佛如来成等正觉。乃至涅槃。能信后际一切诸佛所有善根。能知现在一切诸佛所有智慧。即能振动一切世界等耶。若谓不作齐限而能尔者今何不发耶。已发何不能尔耶。以斯义理应知证发。释曰。此中彼释自有三段。一正立。二岂有久习下引文反质。三若谓不作下。纵破法性。今疏文中亦有三节。但通前二。今初通其第一正立。彼以有生家故名证发心。今拣生家不同故非证也。然彼引四句。今但通一。余例可知。且通生家。生家有六。如法界品。前十住内亦说生家。家言虽同而义有异。岂以解生同证生也。解生生菩提心家。证生生真如家故不同也。此义若成。其余皆成故。故不通余也。若通余三者既许解生。何得不能生三世佛家。断诸疑网除诸障碍。又彼初云初发心时便成正觉。最初建立是初地义。此义前品已曾广释故不通耳。疏若谓久习无明下。即第二通其引文反质。彼引四句今为两节通之。初通久习无明文可知也。后若谓云何下。三通知三世佛法。此即涅槃第六如来性品。南经即四依品云。有四种人。能护正法。建立正法。忆念正法。能多利益怜愍世间。为世间依安乐人天。何等为四。有人出世。具烦恼性是名第一。须陀洹人是名第二。阿那含人是名第三。阿罗汉人是名第四。云何名为具烦恼性。若有人能受持禁戒。威仪具足建立正法。从佛所闻解其文义。转为他人分别宣说。所谓少欲多欲非道广说。如八大人觉。有犯罪人者教令发露忏悔灭除。善知菩萨方便所行秘密之法是名凡夫。非第八人。第八人者不名凡夫。名为菩萨不名为佛。释曰。远公亦詺为种性解行人。非是登地此初依人。既云具缚能知秘密。何言十住不能知耶。前义若成动刹何惑。其第三段纵破法性。文理易故疏不通之。意云。此中非独作无齐限便得尔也。亦久研穷方至此位。何得为此无理难也

大方广佛华严经随疏演义钞卷第三十九大方广佛华严经随疏演义钞卷第四十

        唐清凉山大华严寺沙门澄观述

疏。夫机差教别下。第三结成前义。于中有六。一叹深谦推。二进退立理。三结成损益。四举例证成。五况出功高。六引文成立。今初。初双明教旨深玄叹法也。次明未证谦也。后共详下推也。疏且以浅下。第二进退立理。明有损有益。初住顿具佛法深也。而推在登地。地前所无浅也。故成谤法。智度论云。谤有二种。一者言此非佛说等。即为深重堕大地狱。二者说不契理。并为谤法。即深为浅是也。且以浅为深等者。以初住之浅。释为圆融该博深也。岂非符合于理。理本具故。然此二对亦是泛举一切深浅法也。以远为近者。一僧祇满方证初地远也。今为初住近也。则一生有望岂非有益行人。以近为远者。初住近也。而推在登地此为远也。未历僧祇何由造此。故云法非我分。疏诸佛下。第三结成损益可知。疏且夕钓磻溪下。第四举例证成。以君臣为一对。磻溪即是太公垂钓之处。顿为武王之丞相。岂要历资略举一事其例甚多。诸葛亮受黄钺于茅庐。韩信升将坛于一卒。蔡泽夺范睢之印。张仪霸秦主之威。皆布衣也。才生王宫约主亦是外事。约经即七十八中。譬如王子初生。即为耆旧臣佐礼敬。此菩提心亦复如是。出现品云。如转轮王所生太子。具王相者七宝不散即绍轮王。若约外典其事甚多。如周成王晋献公。皆自小为人主。百战夷项即汉高祖。古人咏史云。百战方夷项。三章且代秦。功归萧相国。气尽戚夫人。十年征战七十二疮。方南面称孤在位无几。岂与上同。疏况十千劫下。第五况出功高。以修行十千劫。方入初住成正定聚。亦非但发无分限心即得尔也。言非聊尔人耳者。聊耳为且略也。史书叙周公为文王之子。武王之弟。成王之叔。非聊尔人耳。今借此言用之。疏是以语其智下。即是功高所成之德也。天池即海也。疏故经云发心毕竟二不别下。第二引文成立。即涅槃文。下半颂云。自未得度先度他。是故我礼初发心。至法界品当更广引。法慧仰推即当经意。如或未喻者。未喻即未晓也。胜鬘有文十地广释。胜鬘说三种智。此即第三仰推智也。疏或曰十六分之一者。如秤斤有十六两故。然此言出涅槃第六如来性品云。若有众生于四恒河沙佛所发菩提心。然后乃能于恶世中不谤是法。受持读诵书写经卷。为他广说十六分中一分之义。虽复演说亦不具足。供五恒佛能说十六分之八分。六恒说十二分。七恒说十四分。八恒佛所方说十六分方具。远公亦举如秤不别解释。疏此云近少。即音义中引大般若。译为坞波尼杀昙。坞波近也。尼杀昙少也。或云近对。谓相近比对。或谓极少也。疏事随性融此彼相即者。如经一毛端中。一切世界差别性者。谓一毛端性即是一切世界差别性。今一切世界。即事随其法性即一毛端。以性即毛端诸界即性故。下句亦然。一切世界中性。即是一毛端性。一毛随性即一切世界。上句多即一。下句一即多。言事揽性起彼此相入者。谓一毛端之事。揽一切世界性成故。一切世界随其多性在一毛中。下句亦然。一切世界揽一毛端性成故。一毛随性遍在一切世界中。言各有同体异体者。谓一毛端。及一切刹为各有也。云何异体一一刹等各有体故。云何同体差别界体同一体故。今一毛中自有体性是为异体。而同诸刹体故曰同体。一一诸刹各自有体。即与毛端共同一体。今诸刹相随其异体。即彼毛端之同体故。刹即毛端毛端。异体随其同体遍于诸刹之异体故。彼体即刹故毛即诸刹体。然上释理性融通之中。却不广出同异体义。但有其意如上文云谓不异理之一事。具摄理性时即同体义。今彼不异理之多事。随所依理皆于一中现。即异体随同也。故云准上思之。疏谓诸缘起更互相生者。一毛之一由刹之多。刹为能生毛为所生。因毛之一有刹之多多为所生。所生无体多即一毛。能生有体毛摄诸刹。上毛为所生。反此可知。一毛是能生即是有力。诸刹是所生即是无力。力摄无力一毛有于多刹。多刹能生一毛一毛即无力。力摄无力毛入多刹。同体异体广如玄中。疏以大非定大故能即小等者。等取小非定小故能即大。及等染非定染故能即净。净非定净故能即染等。至大有于小相不坏于大小入大也。反显至小有于大相不坏小相则芥纳须弥。疏别中言平等者。通相即等者。总取诸句平等。而平等字要须长短等相方有即入故。然云劫者婆沙一百三十五云。分别时分故名为劫。体即五蕴生灭以成于劫。大乘即以时为体。经云长劫与短劫平等等者。意云。长劫即短劫。短劫即长劫。亦是平等。长劫入短劫。短劫亦长劫。亦是平等。就缘即缘起相由门。就性即法性融通门。唯心即唯心所现门。即十因中之三。等取余梦幻等七。疏二三及四文并可知者。二即一多。三即有佛无佛。如过去庄严。现在贤劫。未来星宿。各有千佛名为有佛劫。此后六万二千劫空过无有佛。名为无佛劫。四即多少。如威光修因种种庄严劫中。有十须弥山微尘数佛。法华大通智胜佛处。东南方梵王赞云。一百八十劫空过无有佛。准十住毗婆沙第十云。如经中说。诸比丘是贤劫前。九十一劫毗婆尸佛出。百三十一劫有二佛出。一名尸弃。二名毗式婆。此贤劫中鸠楼孙迦那含牟尼迦叶佛出。六万二千劫空过无佛。疏如胜莲华界等。即寿量品。疏谓于决定境印持为性等。谓以邪正等教理证。力于所取境审决印持。由此异缘不能引转故。犹豫境胜解全无非审决故。疏别中总有十三句者。此是义句以一解为一句故。疏即胜解智所摄者。约十力智言以种种解智亦名乐欲。若约法相欲与解别。皆是别境五中之一。而在十力合之为一。取名有差。疏所望别故等者。前三方便属解。今属诸禅故。疏即他心智者。若是十力即属界摄。疏一切烦恼各有轻重者。分九品故。约起惑下出轻重所由。如一贪惑重者。于下劣境起猛利贪。中者称境而起。下者设于胜境心亦微薄等。三品各三故成九品。疏据难易下。别别相望以论轻重。言种子为重者。如俱生惑种金刚喻定方断尽故。故下经云金刚道灭方毕竟。疏又分别为轻者。真见道中一时顿断故。唯识云见所断惑十俱顿断。以真见道总缘谛故。此约大乘。若通三乘。唯识论云。烦恼障重见所断者。三乘见道位真见道中一时顿断。俱生为重者。于修道位中。数数修习无分别智方能断故。余如十地初说。疏邪见最重者。涅槃经云一切烦恼邪见摄尽。戒经十重谤三宝为最重。十恶亦然。疏嗔恚最重者。如普贤行品一念嗔心起。百万障门开。疏无明爱取为重者。净名经云从痴有爱则我病生。涅槃经云生死本际凡有二种。一者无明。二者爱等。疏三毒为重者。本行经云。世间之毒莫过三毒。又诸随惑等皆从此生。疏见慢为重者。见则遍执一理究彻在心安受圣教。慢既恃己岂复他求。疏我爱慢重者。略有三义。一约识至第七故四惑相应是也。二约行通。至诸禅故。如明法品当辨三约四果阿罗汉。若作是念我。得阿罗汉道。则不得故。疏十大烦恼为重者。唯识云。诸烦恼。谓贪嗔痴慢疑恶见。即六根本。俱舍论云。六由见异十。谓开恶见为五。一身见。二边见。三邪见。四见取。五戒禁取。故疏随烦恼中大中小。随展转轻重者。大随为重中小为轻。中随为重。小随为轻。名为展转。言随惑者。唯识论云。随烦恼。谓忿恨覆恼嫉悭。诳谄与害憍。无惭及无愧。掉举与昏沉。不信并懈怠。放逸。及失念。散乱不正知。长行释云。唯是烦恼分位差别等流性故名随烦恼。彼疏释云。谓忿等十。及失念不正知放逸等。假染心所是贪等差别分位名随烦恼。无惭无愧掉举昏沉散乱不信懈怠七法。虽别分位有体。是前根本之等流故名随烦恼。由烦恼为因此得有。故论云。此二十种类别说有三。谓忿等十各别起故。名小随烦恼。无惭等二遍不善故名中随烦恼。掉举等八遍染心故名大随烦恼。疏释云。然忿等十自类相望各别起故非不共他中大惑俱行位局故名之为小。无惭愧二自类得俱行通忿等。唯遍不善位局后八但得名中。掉举等八自得俱生。但染皆遍得俱生故不可名小。但染皆遍故不得名中。二义既殊故八名大。疏习气为轻者。此即阿罗汉等余习也可知。疏更有异门。可略言也者。上来已有十门解释。有以五住烦恼无明为重。障大菩提故。前四为轻。障见修故。今以前四住亦障菩提。无明住地亦障见修故不存之。又有云。等分为轻称境起故。多分为重过境起故。又云暂起间起羸劣起者为轻。多起常起猛利起者为重。此二即前约品中收之。又云迷事为轻后得智断故。迷理为重根本智断故。此则与前无明为重。障菩提故亦小相违。故略不言耳。非无有理故云可略。迷事迷理至十地中当广分别。疏能生贪等无量烦恼如涅槃说者。即第二十三经。高贵德王菩萨品。经云。复次善男子一切凡夫。虽善护身心犹故生于三种恶觉。以是因缘虽断烦恼。得生非想非非想处。犹故还堕三恶道中。善男子譬如有人渡于大海。垂至彼岸没水而死。凡夫之人亦复如是。垂尽三有还堕三涂。何以故无善觉故。云何善觉。所谓六念。下广说恶觉之过。故云如涅槃说。言加五说有八觉者。即俱舍等论亦名八寻。下疏所列恼觉即是害觉。涅槃通说六念为善。今别说之故以不净等治为善。大意可知。疏利中身见为本生六十二者。言身见者。唯识论名萨迦耶见。论云。谓五取蕴执着我我所。一切见趣所依为业。此见差别有二十句六十五等分别起摄。释曰。后此见差别下。即疏云。一依三世五蕴说者。彼疏释云萨迦耶见具足梵云萨迦耶达利瑟致。经部师云。萨是伪义。迦耶是身。达利瑟致是见。身是聚义。即聚集假。应言缘聚身起见名为身见。萨婆多云。萨是有义。迦耶等如前。虽见聚身。而是实有。身者即是自体异名。应言自体见。大乘法师解云。僧吃烂底萨。便成移转。以大乘心心上所变之法故。言移转身见。依五蕴起此我见。此为依故诸见得生故。言见趣所依为业者趣者投也。惑所归处也。言二十句者。对法第一云。谓如计色是我我有色。色属我我在色中。一蕴有四。五蕴合有二十句也。五为我见余皆我所。谓相应我所(即我有色)随逐我所(即色属我)不离我所(即我在色中)故有十五我所。此即分别行缘蕴不分别所起处。若历三世便有六十。加身即我为六十一。我复异身为六十二。又计常无常等为六十二。如十藏品。论言六十五者。婆沙论云。谓如以色为我。于余四蕴各三我所。谓是我璎珞。我僮仆。我器。即有十二。色为一我。即总有十三。五蕴总有六十我所见。有五我见为六十五。此即分别行缘蕴亦分别所起处。此等皆是分别我见。疏二依异道邪见具如瑜伽八十七说者。论中约迷前际后际为次。今依唯识。约所依见分之。谓于前际计四遍常四一分常。及依计后际有想十六。无想俱非各有八论。共四十种常见差别。有计后际七断灭论。此四十七共因我见而起边见。有计前际。二无因论。四有边论。四不死矫乱。及计后际五现涅槃。故六十二。此六十二以邪见边见二为自体。以余二见而为眷属。依于身见以为根本。此亦举大数。次依瑜伽以释相者。初四遍常者。谓我及世间一切皆常。但有隐显依上中下静虑等。起起宿住随念生四常论。一由能忆二十成坏劫。二能忆四十劫。三能忆八十劫。四依天眼所见现在世。见诸有情死时生时诸蕴相续。彼便执我及世间俱常。言四一分常者。谓四皆一分。一者从梵天没来生此间。得宿住通作如是等执。梵王是常。我等无常故名一分。二闻梵王有如是见。大种是常。心是无常。或复翻此。三有先从戏忘天没来生此间。得通起执不生此者常。我生此者是无常。四有先从恚愤天没。一分同前。此天住处住妙高层级。或三十三天。释曰。若依瑜伽此中即说二无因。以同计前际故。唯识此后即明有想十六等。言十六者有四四句。一我有色。死后有想。执色为我名我有色。取诸法说名为有想。即欲界全。色界一分。除无想天。二我无色。死后有想。执无色蕴为我。此在欲界乃至无所有处。唯除非想。三我亦有色。亦无色。死后有想。执五蕴为我。四我非有色非无色。死后有色。遮第三也。依寻伺等至皆容得起。第二四句云。一执我有边死后有想。执色为我体有分限。如指节等。二执我无边死后有想。执非色为我。遍一切处故。三执我亦有边亦无边。死后有想。执我随身卷舒等。四执我非有边非无边。死后有想。遮第三也。或依寻伺等至皆起。第三四句者。一我有一想。二我有种种想。三我有小想。四我有无量想。一一想者在前三无色。二种种想者。在欲界色界。除无想天。三执少色。或执少无色。为我想。为我所。我与彼合名为小想。在欲色界除无想天。四无量想者。执无量色为我想。为我所。我与彼合名无量想。第四四句者。一我纯有乐。死后有想。在前三静虑。二我纯有苦。死后有想。在地狱中。三我有苦有乐。死后有想。在人欲天鬼畜生界。四我无苦无乐。死后有想。在第四禅。已上寻伺等至皆容得起。无想俱非各八论者。无想八论者。有二四句。初四句者。一我有色死后无想。执色为我得无想定。见他有人得定生彼作如是计。二我无色死后无想。执命根为我得无想定。三执我亦有色亦无色。死后无想。双执色命根为我。于此二中起一我想。四执我非有色非无色。死后无想。遮第三句。等至寻伺皆容起故。第二四句者。一执我有边死后无想。执色为我。其量狭小等得无想定。二执我无边死后无想。执色为我遍一切处等。三执我亦有边亦无边。死后无想。执色为我随身有卷舒故。第四句者。遮第三句。更无别义。等至寻伺皆容得起。后俱非八论者。有二四句。一云。执我有色死后非有想非无想。执色为我。见诸有情入非想非非想定。想不明利。作如是执。唯寻伺执非得定也。二执我无色。死后如前。执无色蕴为我等。入非想非非想定。想不明了故。作如是执。三执我亦有色。亦无色。死后如前。执色无色为我。见有情等同前。上皆依寻伺起非由等至。其第四句遮第三句更无别义。第二四句云。一执我有边。死后非有想非无想。乃至第四句其文易知。如是一切皆执四无色为我。以得非想非非想定。容有此执。一由彼定时分位促故。别以一一蕴而为所缘。执我有边。二由彼定时分长故。总以四蕴为所缘故。执我无边。三由彼定或一一蕴。或总为所缘故。成第三句。第四句遮第三更无别义。七断灭论者。一执我有粗色。四大种所造为性。死后断灭毕竟无有。见身死后有而无故。二我欲界天死后断灭。三我色界天死后断灭。四我空无边处乃至非想。皆云死后断灭。后之四执执彼彼地为生死顶故。前四十见为常。后七见为断。此皆见断名分别起。言有计前际二无因论等者。皆因邪见起。见不正故名之为邪。二无因者。一从无想天没来生此间无宿住通。不能忆彼出心已前所有诸位。便执诸法本无而起。如我亦应本无而起。便起执言我及世间无因而起。二由寻伺不忆前身。作如是执。无因而起。如是二见由无想天及虚妄寻伺二事而起。四有边者。一由一向能忆上下。下至无间地狱。上至第四静虑。执我于中悉皆充满。便作是念。过此有我。我应能见。故知有边。二由一向能忆傍无有边。执我遍满故执无边。三由能忆上下及傍故。双执有边无边四由能忆坏劫分位。便生非有边非无边想。诸器世间无所得故。四不死矫乱者。先总释名。准婆沙意。外道计天常住名为不死。计不乱答。得生彼天。今佛法诃云。汝言秘密等即是矫乱言四种者。一恐无知念我不知善不善等。有余问我不得定答。我若定答。恐他鉴我无知因。即轻笑于我。彼天秘密义不应皆说等。二行谄曲者作是思惟。非我净天一切隐密皆许记别。谓自所证及清净道故。三怀恐怖而无记别。恐我昧劣为他所知。由是因缘不得解脱。以此为室而自安处。怀恐怖故四有愚戆专修止行而无所知。若有问我。我当反诘一切随言。无减而印顺之言。五现涅槃者。一见现在受若天若人诸五欲乐。便谓涅槃。二虽厌五欲现住初定以为涅槃。引在身中名为得乐。见他现在住定亦尔。下皆准此。三厌寻伺故。现得第二定以为涅槃。四厌诸寻伺喜故。现住第三定以为涅槃。五厌喜乐乃至出入息。现住第四定以为涅槃。待过去故名为后际。又此计我现既有乐。后亦有乐。故后际摄。以现乐为先。而执后乐。总名现法。此不依我见起故邪见摄。六十二见大意已周。疏皆已无得即大般若意。至回向当释。疏贪欲即道胜热处说。疏古德判此一段以为摄位修成者。上直就初住之德以为深胜。今明摄位。即初后圆融。不违经宗。事事无碍故云亦是一理。疏力等未证亦定无疑者。即是偈意。偈云。菩萨于佛十力中。虽未证得亦无疑。故十八不共净行品已说。疏望圆极之果等者。当得佛言且顺经文。分为二义。故引晋经梵本。即知当字是译人之意。译人意欲不坏初后故作此译。若此意存不坏初后。则前梵行品。初发心即得菩提。如何会释。此改为当彼亦须改。彼成无妨此即何违。故此即佛正是梵行初心即成耳。且顺彼释故云见性即成智身。若约圆融此后更无别佛。疏三得知身无从等者。释经得如来一身无量身。究竟平等真实智慧。即用上光明觉品偈。释偈云。一身为无量。无量复为一。了知诸世间。现形遍一切。此身无所从。亦无所积聚。众生分别故。见佛种种身。文意可知。疏其十行十向十地皆尔。各自品说者。十行第十智度满故。入因陀罗网境界。明知已摄诸位。十回向品第十入法界无量回向证穷法界故。十地堕在佛数故。如普贤作用下。例引等妙二觉证成。疏二约见性下。此上即藏和尚意。此下即天台圆教之意。故云昔人竖说五种菩提。我即横开六即。此中当其分真即也。于中四。一正明。二若尔下设难。三请以下解释。先喻圆融法。后喻行布。四依于此义下结成。疏又即由此义废高就下等者。亦天台意。智者虽说四教三教及至果处无有实事。但就教中施设有果。进入位后果即便虚。如别教说三贤十地。修三贤位则有可修。及至登地更无有别。别教十地证竟但是圆家住耳。即由此义圆教初住自在过地。不知此意故谓此会是说十地。疏文含多意者标也。前二叙昔。言求之于己尚未免求者。破第二释也。则违净名于一切法应无所求。疏今释有二下。述正义也。前意即顺般若性空。后意则明事理双现。经云。无所求中吾故求之。即方等经中。佛为雷音菩萨。说于法华昔因缘已。又云。过去有佛名栴檀华。彼佛去世甚久。我于彼时如汝无异。彼有菩萨。名曰上首。作一乞士入城乞食。时有比丘。名曰恒伽。谓乞士言。汝从何来。答曰。我从真实中来。又问何谓真实。答曰。寂灭相故名为真实。又问。寂灭相中。有所求无所求耶。答曰。无所求。又问。无所求者。何用求耶。答曰。无所求中吾故求之。又问。无所求中何用求耶。答曰。有所求者一切皆空。得者亦空。著者亦空。实者亦空。求者亦空。语者亦空。问者亦空。寂灭涅槃一切虚空。一切世界亦复皆空。吾为如是次第空法而求真实。又问。菩萨于何处求。答曰。于六波罗蜜中求。恒伽闻已。卖身供养。释曰。然上经文双证二意。以正说求者皆空即般若意。故不碍求即双行意。双行亦即不共般若之意耳。疏而经多劫者。此标举。亦是问难也。应有问言。前来赞经玄妙。则言一生圆旷劫之果。今既圆妙。何以多劫方成。后然余教下答。于中四。一标他宗。二此宗下。示其正说。三起信则以若迟下。双出二宗之意。四并有下结劝修学。三中即起信发趣道相中证发心。后云或示超地速成正觉以为怯弱众生故。或说我于无量阿僧祇劫当成佛道。以为懈慢众生故。能示如是无数方便不可思议。而实菩萨种性根等。发心则等。所证亦等。无有超过之法。以一切菩萨皆经三僧祇劫故。但随众生世界不同。所见所闻根欲性异。故示所行亦有差别。释曰。此即以迟速皆方便也。此宗则楷定为权。以不定或迟或速为实。如前第二段明。故毗目瞿沙暂时执手时经多劫则一生不定。一生无量劫。即一念多劫。岂为多劫故结劝之勿执也。疏大旨同前十住者。同十住中加所为也。此中显示佛法。即前持说佛法故。二智光普照即前觉一切佛法。三开阐实义。即前增长佛智。四证得法性。即所入无碍。五众会欢喜。即善了众生界。及知众生根。六开示佛法因。即前所行无障碍。及得无等方便。七为得一切佛平等。即前入一切智性。八为了法界无有二故。即前深入法界。故结云说如是法明是说因。疏一净业显理者。业净则理显故。二除惑开信者。若无妄想即增信解故。余可知。疏八大人觉者遗教经明。一少欲。二知足。三寂静。四精进。五正念。六正定。七正慧。八无戏论。涅槃二十七加二为十。云善男子。菩萨成就十法虽见佛法不得明了。前七同上。八即解脱。九赞叹解脱。十以涅槃化他众生。十地抄中更当广释。疏亦总相颂前叹深难说。若将别配则令证等互有局者。昔以二十三偈。颂前叹深难说。即分为十。初四颂甚深。二有一偈颂难知。三有二偈颂难分别。四菩提心下二偈颂难信解。五三偈颂难证。六二偈颂难行。七二偈颂难通达。八了法自性下二偈颂难思惟。九二偈颂难说。十有三偈颂难度量。故云若将别配言则令难证等互有所局者。如一切独觉及声闻悉以发心作根本。颂难证者。前文十力十八不共等岂易证耶。故云互有所局。今二十三偈。皆通难信难知难证等。故云总相颂前则令证等互有所局

    明法品第十八

疏。统有四义者。然法光明摄论中释本论。释云。能正了知周遍无量。无分限相大法光明。今疏取诸释意参为四义。初一即世亲意。世亲先牒本论竟。释云。谓正了达十方无边无分限相。如善习诵文字光明名法光明。今疏取意。以能正了达即法智慧。十方无边法即此胜进。能所诠法也。二即无性意。彼牒本论竟。释云。谓正通达十方无边无分限相。显照行故名法光明。今疏取意。无性但有显照行言异于世亲。故取意义以能诠为光明。而无性意亦有菩萨智为明耳。上二摄论所释皆是第七。三即梁论意。梁论即世亲同本异译。而文稍广多。是敌对译故。彼论第十先牒本论云。三能见一切处无量分别相善法光明。次释云。约三乘法说一切处。又约内外法说一切处。又约真俗法说一切处。如此一切处菩萨能见无量相。如佛所说法相。及世间所立法相。菩萨皆能了达。即如量智。如其本数量菩萨以如理智通达无分别相。此二智能照了真俗境故名法光明。释曰。此中论意不异初释。但文广说一切处等耳。而能了达者。亦通诸菩萨智。今取其别意。但取所诠中菩萨之智。异法慧智故为别耳。其第四意一向义加。显此四解后后狭于前前耳。疏德虽无量下总结。谓显其当位已得胜进云何上求。故云而于胜进义非惬当。疏非明无之处即名无明等者。即俱舍第十偈云。明所治无明。如非亲实等。上句正明有体。谓此无明不了四谛。明所对治名曰无明。与明相违方名无明。非是离明之外皆是无明。此拣眼等亦非明无之处即名无明。此即正明有体。下句举喻释成。六地当释。正说中。疏不守根门名为放逸。即瑜伽意。前文曾引此段。疏文乃有三义。初略释名。二涅槃云不放逸下。明先彰所以。三世其体业。二中即涅槃二十四。高贵德王菩萨品十功德中第四。十事利益功德。于中一根深难拔。经自牒云。云何根深难拔。所言根者名不放逸。不放逸者为是何根。所谓阿耨多罗三藐三菩提根。善男子。一切诸佛诸善根本皆不放逸。不放逸故诸余善根展转增长。以能增长诸善根故。于诸善中最为殊胜。善男子。如诸迹中象迹为上(云云)如诸明中日光为最。如诸王中转轮圣王为最第一。如诸流中四河为最。如诸山中须弥山王为最第一。善男子。如水生华中青莲华为最。不放逸法亦复如是。于诸善法。为最为上。善男子。如陆生华中婆利师华为最为上。不放逸法亦复如是。为最为上。师子金翅罗睺大身。乃至佛僧为诸众中最广。引喻竟结云。以是义故。不放逸根深固难拔。即其文也。疏即精进三根下。第二出体业。即唯识第六释曰。谓依精进及无贪等三种善根。此之四法于所断恶防令不起。于所修善修令增长。体是四法约别功能。而假建立名不放逸。非别有体。疏宁起疥癫下。即萨遮尼犍子经。难反复故即净名文。彼第二经云。凡夫于佛法有反复。而声闻无也。疏谓离善知识下。合上四种重任。此合大海最深重难持故。诸山喻菩萨。如十地十山故。草木喻缘觉。独善不从师故。众生喻声闻。有师属故。疏言五印者。即同净名迦旃延章五非常观。然前四非常即是有为。寂静为涅槃。即是无为。摄为无为尽。又前四俗谛。后一真谛。疏言四印者下。即庄严论第十一。名四法印。论云。四法印者。一者一切行无常印。二者一切行苦印。三者一切法无我印。四者涅槃寂灭印。所以知合空入于无我者。论云。此中应知无常印及苦印。为成无愿三昧依止无我印。为成空三昧依止寂灭印。为成无相三昧依止。说此法印为三三昧依止故。疏或名优陀那者。即地持第八亦名优檀那。论云。有四优檀那。诸佛菩萨为令众生得清净故说为四。云何为四。一切行无常。一切行苦。一切法无我。涅槃寂灭。诸佛菩萨具足此法。复以此法传授众生是名优檀那。过去寂灭诸牟尼尊。展转相传。是名优檀那。疏菩萨藏经第二名法邬陀南者。亦是大宝积第三十六菩萨藏会。第十二卷末。即试验菩萨品。经云。舍利子。诸佛世尊。具大智力总摄诸法。安处四种邬陀南中。何等为四。所谓一切行无常。一切行苦。一切法无我。涅槃寂灭。舍利子。所演一切行无常者。如来谓诸常想众生断常想故。所演一切行苦法者。如来谓诸乐想众生断乐想故。所演一切无我法者。如来谓诸我想众生断我想故。所演寂灭涅槃法者。如来为诸住有所得颠倒众生。断有所得颠倒心故。舍利子。是诸菩萨若闻如来说一切行为无常者。则能善入毕竟无常。若有闻说一切行苦。则能兴起厌离愿心。若有闻说诸法无我。则能修习空三摩地妙解脱门。若有闻说寂灭涅槃。则能修习无相三摩地。而不非时趣入真际。如是舍利子。若诸菩萨摩诃萨。能善修习如是法者。终不退失一切善法。速得圆满一切佛法。疏邬陀南者。此云标相者。释经也。言涅槃寂静是无为法标相者。略举亦应云无常是有为法标相。苦是有漏法标相。无我是诸法标相。亦有说。言邬陀南者。应言说也。佛常说故。义当无问自说经。疏印即决定义者。却释法印之名。决定无常等者。诸有漏法决定是苦。一切法决定无我。无为法决定寂静。疏善戒第七下。略示源由。地持第八已如上说。善戒第七者。经云。智有三种。一者能舍外物。二者舍内物三者舍内外已兼化众生。云何教化。见贫穷者先当语言。汝能归依于三宝。不受斋戒不。若言能者。先受三归及以斋戒。后则施物。若言不能。复应语言。若不能者。汝能随我说一切法无常无我寂灭涅槃不。若言能者。复当教之。教已便施。乃至云若能如是先教后施。是名大施。释曰。此即次下。云言三法印者。四中合苦入于无常。即智论所说三法印也。疏瑜伽四十六者。论云。复次有四种法嗢陀南。诸佛菩萨欲令有情清净故。说与地持同。地持即瑜伽同本异译耳。疏或除涅槃等者。此三唯说有为。即不合苦入无常也。言三者。一无常。二苦。三无我也。然嗢陀南此云集施。应与邬陀南异。今论亦云嗢陀南或译之少巧。此三即涅槃三修。疏今以诸印下。结前诸印生后。释一印义。疏法华云佛自住大乘者。即第一经。偈中此前偈云。唯此一事实。余二则非真。终不以小乘济度于众生。疏住地观修者。梁论云。地者对治义。疏虽数名小异大同十行。亦通十度等者。以刊定不许通十行故双定之。彼云。初四五七名同十行。余并全别。不可悬指。次后有文具显十度。释曰。此公虽为十度释经意明但是行法。亦非十行。亦非十度。故今双定俱是无过。次云十行所行即十度者。明二义相成俱明无失。次云欲胜进彼故此前修者。别通十行。以其上意云十行自是后位。何用悬指。今疏通云。夫胜进者进修后位。今十住胜进正修十行何有违耶。从又下文由为物下。通其不许十度。彼云。下文自有十度。此是十度乃成重也。故今释云。彼约说法成度。此约通修。所望既差。亦非繁重。彼唯前四名同。今取其后二说同十行。指文显著前七双具文理自显。疏依彼文次者。五七一二等。如次将今之十以对彼十。此中第一即彼第五。是成熟众生等。疏五深心则可久等者。此则用周易系辞。系辞云。干以易知坤以简能(天地之道不为而善始不劳而善成故曰易简)易则易知简则易从。易知则有亲。易从则有功(顺万物之情故曰有亲通天下之志故曰有功)。有亲则可久。有功则可大(有易简之德则能成可久可大之功)。可久则贤人之德。可大则贤人之业(天地易简万物各载其形圣人不为群方各遂其业德业既成则入于形器故以贤人目其德业也)。易简而天下之理得矣(天地之理莫不由于易简而各得顺其分位也)。天下之理得。而成位乎其中矣(成位况立象也极易简则能通天下之理通天下之理故能成象并乎天地之言其中者则明并天地也)。但观向引。疏文可见但取可大可久之言。而不取易简之义。疏文有五对并显可知者。一见佛持法对。二智深悲广对。三多定广福对。四辩深通胜对。五竖永扩该对。疏金师之子等者。涅槃经说。乃是身子差机十地当引。今且引庄严论说。目连教二弟子。金师之子教不净观。浣衣之子教数息观。久无所证。舍利弗问目连。汝以何法而教之乎。答之以二观。又问。二人从何来。答一浣衣。二锻金。身子云。锻金之子。应教数息。浣衣之子。令修不净。于是目连于法教之。则得罗汉。即说五颂赞身子云。第二转法轮。佛法之大将。于诸声闻中。得于最上智。又云。行自境界中。获得所应得。行他境界中。如鱼堕陆地。我常在河边。习浣衣自净。安心于白骨。相类易开解。不大加功力速疾入我意。金师常吹囊。出入气是风。以其相类故。易乐入安般。众生所玩习。各自有胜劣。释曰。上皆随宜之意

大方广佛华严经随疏演义钞卷第四十大方广佛华严经随疏演义钞卷第四十一

        唐清凉山大华严寺沙门澄观述

疏。释此四分具如杂集第十三者。然此论建立补特伽罗。略有七种。谓病行差别故。出离差别故。任持差别故。方便差别故。果差别故。界差别故。修行差别故。今当病行差别。自有七种。一贪行。二嗔行。三痴行。四慢行。五寻伺行。六等分行。七薄尘行。言贪行补特伽罗者。谓有猛利长时贪欲(标也)虽于下劣可爱境界。而能发起上品贪欲(此释猛利)起即长时无有断灭(此释长时)如贪行者。乃至寻伺行者亦尔。各随自境猛利长行。如理配释。等分补特伽罗者。谓住自性位烦恼。远离猛劣。住平等境烦恼故。随境势力烦恼现行故。释曰。猛拣前五。劣拣第七。住平等境释成自性。随境势力烦恼现行。释自性烦恼。谓胜境贪心即增。劣境贪心则下。不同前五于下劣境起上品贪等。亦犹颜回怒不过分等。或与境等名为等分。又于所起无偏胜劣故云等也。论云薄尘行补特伽罗者。谓住自性位薄烦恼。如前所说自性位烦恼相。今此烦恼望彼微薄故。虽于增上所缘境界。而微薄性烦恼现行。昔所修习胜对治力所推伏故。释曰。非如前等分等于前境。境胜则贪重等。今胜亦劣故不同前。则父母之仇亦无加报。又上有七。经多说四者。取其三毒为不善根故。等分之中摄余三故故疏云等分。分其轻重轻即薄尘。重即正是。等分既等于境。望于薄尘故为重耳。又等皆相似无有胜劣。前三则有互增之义。疏五求人天乐为乐生死者恐有难云。谁复乐死。故今答云。所谓乐生以生必死故。人天之乐是生死中事故。疏乐事寂者。令成理寂者。即为人意。亦即对治。疏即依法不依人者。即第一文连义正对。即依义不依文也。疏以文义显故更不释之。第二句中有其两对。即依法不依人。依智不依识。具法四依也。即净名经法供养品而以义语。智识。了义。不了义。人法而为其次。四依之义三门分别。一释名二出体。三次第。初释名者。义为所诠。凭之起行。是故应依。教虽诠理要须忘言。言非义故。故不应依。智无分别能决断故。是以应依。识为了别能起于染着。故不应依。依了义经不依不了义者。显实分明名为了义。凭之起解。是故应依。隐覆有余名非了义。令人执滞。故不应依。托法起行。是故须依。不随人情。故不依人。然了义经等乃有多门。一法印非印门。与无常寂静无我三印。相应以为了义。不与相应即非了义。二大小乘门。小乘三印亦非了义。大乘方了。如七善知中说。又涅槃第六云。若说如来无常变易名为不了。若说如来常住不变是名为了。三显密门密意宣说名为不了。显了说者即名为了。四又于大乘言未周悉名为不了。周备为了。此上四门初一令物舍邪归正。二舍小归大。三舍密就显。四令寻诠使义周备。二出体者。初一所诠。通事通理。二即能证通根本后得。三约能诠通诠上二。四约能说忘情取法。三次第者。即以上义以为次第。余可思也。疏七断真法爱者。谓真实观智理事无违心生爱着便不证实。故诸圣人少有所念不得圣果。疏设自修此亦为利他者。以此章门标说法时不舍诸度。而下释相。于诸佛所闻法近友等。亦有不因说法所成。故为此通设自修时亦为众生。则不违蹑前随所应化常为说法。疏四进中普发众业等者。此中摄于四修及三精进故。疏双配细寻可知五禅中。疏一诃五欲者。即天台止观。依智论诸经。修正道前立二十五方便。谓一具五缘。二诃五欲。三弃五盖。四调五事。五行五法。五五二十五。今但明诃五欲耳。疏中先彰诃意。后云何诃之下。正明诃相。于中有三。一别示其过诃。二此五欲者结以正诃。三况菩萨下。即无诃相。直顺经文无贪着义余之方便。疏文不要略示其名。言具五缘者。一持戒清净。二衣食具足。三闲居静处。四息诸缘务。五近善知识。言弃五盖前已有竟。四调五事者。一调食令不饥不饱。二调眠不节不恣。三调身令不宽不急。四调息令不涩不滑。五调心令不沈不举。五行五法者。一欲。二精进。三念。四巧慧。五一心。并类前后其相可知。疏即一切门禅者。瑜伽三十三说六度四等各有九门。谓一自性。二一切。三难行。四一切门。五善士。六一切种。七遂求。八此世他世乐。九清净。故彼颂云。自性一切难。一切门善士。一切种遂求。二世乐清净。又自性皆一。一切或二或三。难行皆三。一切门皆四。善士皆五。一切种皆六或七。遂求皆八。二世乐皆九。清净皆十。今九门静虑者。一自性者。谓心一境性。或奢摩他品。或毗钵舍那品。或双运道即十句中。二三及十。第二一切禅者。略有二种。一者世间。二出世间。九次第定通于世间。不住不出是出世间。亦即第二句摄。有三种者。一者现法乐住禅。谓身心轻安远离憍举。离诸爱味泯一切相。二者引生功德禅。三饶益有情禅。如疏已配。第三难行禅有三种者。一已住深定能引诸静虑。而舍彼最胜生于欲界。是第一难。即经第五句。二依此静虑能发种种。超过二乘所行等持。亦第五句。是故疏云即难行相。三依于静虑速证无上菩提。即第十句。疏亦已指。第四一切门禅有四种者。谓一寻伺俱行。二喜俱行。三乐俱行。四舍俱行。即第二句摄故疏已指。第五善士禅略有五种者。一无爱味。即三四句。余四与四等相应。即第八句摄。所缘境界即慈念众生等故。第六一切种者。此静虑有六种七种。总十三种。言六种者。一善静虑。二无记变化静虑。三奢摩他品。四毗钵舍那品。五自他利正审就惟。六能引神通威力功德。亦是第六引神通句。亦通余句。言七种者。一者名缘静虑。二义缘。三止相缘。四举相缘。五舍相缘。六现法乐住。七饶益他。随句相应配之可知。第七遂求者。满众生意故亦神通句摄。略有八种。此一段论文稍广。今略义引之。一能息诸毒等。二能除众病。三降雨止渴。四济诸怖畏。五能施饭食。六能施资财。七能正谏诲。八能正造作。随应可知。第八此世他世乐。静虑有九者。一者神通变现调伏有情静虑。二者记说变现调伏有情。三者教诲变现调伏有情。四者于造恶者示现恶趣。五于失辩者能施辩才。六于失念者能与正念。七者制造建立无颠倒论等。八于世工巧能随造作。九放光息苦。后二亦义引亦随应配之。第九清净禅有十。疏下自配。余度九门十行品说。疏三安住理定寂爱味住者。杂集第九云。如是静虑无色。由四种相应广分别。谓杂染故。清白故。建立故。清净故。杂染者。谓四无记根。一爱二见三慢四无明。由此四惑染污其心。于诸染污静虑定门。令色无色界一切有覆无记烦恼及随烦恼生长不绝。释曰。上即略释论文。下别释。其文广博今略取意。谓由有爱味上静虑。由有见故取上静虑。由有慢故恃上静虑。由无明故疑上静虑。如是烦恼恒染其心。令色无色大小二惑相续流转等。论云清白者。谓清净静虑。无色自性善故说名清白。虽是世间离缠垢故亦名为静。论云。建立者。谓支建立。等至建立。品类建立。名想建立。于诸静虑具四建立。诸无色中唯有三种。除支建立。支建立者取意。谓初禅五支等。言等至建立者。谓七种作意入初静虑乃至非想。言品类建立者。于初静虑具三品熏修。八定皆尔。故初四禅随三品因各有三天。名想建立者。谓静虑中无量名字不可算数。以诸佛世尊所入二乘所不能知故。乃至八定互相摄故等。论云清净者。谓初静虑中边际定力。乃至非想非非想处边际。是名清净。彼疏释云。八定之中所有最后边际。由作用自在离无堪任障故名清净。通有漏无漏但自在作用俱名清净。释曰。今疏三四即离前杂染四无记根是第四清净。五至八即是前名想建立中互相摄故。及品类建立等余可思之。疏五出生诸定者。即杂集名想建立。疏中先明能出生。即依起信修行信心分中之文。前云久习纯熟。乃至得入真如三昧。次论又云。复次依是三昧故则知法界一相。谓一切诸佛法身与众生身平等无二。即名一行三昧。当知真如是三昧根本。若人修行渐渐能生无量三昧。经言无量三昧者。如智论云。五智印等三万五千首楞严等。五万三千方便善巧无量无边。疏此中逆顺应各有超间等者。俱舍定品云。二类定顺逆均间次及超至间超为成。三洲利无学。谓本善等至分为二类。一者有漏。二者无漏。往上名顺。还下名逆。今疏已委释。又彼云同类名均。异类名间。相邻名次。超一超二等名超。至间超为成者。名修超也。谓观行者修超定时先于有漏八地等至。顺逆均次现前数习。次于有漏顺逆均超现前数习。次于无漏顺逆均超现前数习。是名加行满也。后于有漏无漏等至。顺逆间超名超定成。三洲利无学者。明处及人。修超等至唯人三洲处也。仍是利根不时罗汉方能修也。今明菩萨居然能超。如顺超从初禅出应入二禅。而入三禅即是超一。若从初出而入四禅即是超二。直入灭定是谓全超。逆超亦尔。疏亦名师子游步三昧者。腾跃跳踯故。即智论百八三昧中第三名也。菩萨得是三昧于一切三昧中入出迟速皆得自在。譬如众兽游戏之时。若见师子悉皆怖惧。师子戏时。于诸群兽强者则杀。伏者则放。菩萨亦如是。得是三昧。于诸外道强者破之信者度之。故名师子游步三昧。第一百八三昧名离着虚空不染。初一名首楞严。疏第二名宝印三昧者。智度论云。能印诸三昧于诸宝中法宝是实宝。今世后世乃至涅槃能为利益。如佛语比丘云。为汝说法所谓法印。法印是宝是解脱门。若三藏教门以三法印为法印。若摩诃衍但有诸法实相一法印。与实相般若相应三昧名为宝印三昧也。疏又上二三下。上案文释。今以三禅收之。以诸经论多用三故。如初会说。今当重释。瑜伽四十三云。云何菩萨一切静虑。谓此静虑略有二种。一者世间。二者出世间。复有三种。一者现法乐住等。论释云。若诸菩萨所有静虑远离一切分别。能生身心轻安最极寂静。远离掉举离诸爱味泯一切相。当知是名现法乐住。若诸菩萨所有静虑。能引能住种种殊胜不可思议不可度量十力种性所摄等持。乃至若诸菩萨所有静虑。能引能住一切菩萨解脱胜处遍处无碍解无诤愿等不共功德。名能引等持功德静虑。若诸菩萨所有静虑。于诸有情能引义利。彼彼事业与作助伴。下取意引息苦除怖救护。赞三宝德调伏有情为第三静虑。疏又通十种下。即九门中第九也。疏六般若中二。先随文释。后总料拣。前中言后三连环者。以经云一乘普门慧。二入于一切智智之门。三永得休息。此三乃似一句尔。故云连环。而义则别故为三句。疏此中亦有九门之相下料拣。于中二。一对九门般若。二其中虽定慧下拣滥。以互有故。于中有六。一对前定门拣。如前中云知三昧境不违智印入于智地。是定中慧。慧资定也。今此中有入真三昧。是定资慧也。二若全下引证成前。既合定慧明必相资。三后之方便下。以六对七料拣二亦相成四。岂令般若下反成前义。五非唯下总结万行相资之义。六况般若况结深玄。言不得一行无此君者。借外典语。晋书中说。王献之好竹。到处即皆树之。人问其故。答云。人生不得一日无此君耳。意在虚心贞节岁寒不移。今明万行不得暂时而无般若。疏七方便中先随文释。后初九拔济下收束。先以二种方便收。依璎珞经下。通明后四之相。后之三度皆有二段可知。八愿中此求菩提下收束。九力中一契理下收束。十智度中前七成就下收束。疏如慈童女者。智度论说。慈行童女入海采宝。辞白其母。母不从其志。相别误伤母一茎发。便堕火盆地狱。自省无罪。狱主具示罪相。便发大心。见诸罪人知同此罪。便请火盆普为戴之。狱主嗔恚以铁叉击头。寻便命终生于天上。疏贪有二种等。略有此二。然准瑜伽二十六中。总有五种。论云贪有五种。一于内身欲欲欲贪。二于外身淫欲淫贪。三境欲境贪。四色欲色贪。五萨迦耶欲萨迦耶贪。释曰。慈恩二解初贪有二。一云于自内身初起欲界微少之欲故名欲欲。次起重贪故名欲贪。二云内身是自所欲之法。所以言于内身欲。于内身欲上起欲故。即能欲心此名欲贪。则初一欲字是所欲。第二是能欲。第三欲字是结名。释曰后释为胜。濮阳结归两解。初一同大乘法师后解云云。初之欲字义同于前。次欲字即别境欲。与贪俱时缘于所欲。欲缘之欲重云欲欲。后之欲字亦是所欲。缘欲之贪名为欲贪。释曰。此解不及前。以后一皆有别境欲故。然古后四皆通二释思之可知。今亦存一。今此虽二亦以摄五。色贪即初二。财名等即后三。财即三。四名兼第五。等即等三耳。疏又防恶愿如戒经说者。梵网经云。发十大愿已。持佛禁戒作是愿言。宁以此身投炽然猛火大坑。及上刀山。终不以毁犯三世诸佛经律与一切女人作不净行。有十二愿。兼结云。愿一切众生皆得成佛。为十三愿。疏言六和者下。别释六和敬。先依律释。正在小乘义通大小。后又约菩萨三业同慈下。约菩萨明。则外同他善谓之为和。内自谦卑名之为敬。言三业同慈者大小异故。又三名行和。无有利和。一同戒和敬。菩萨通达实相知罪不可得。为欲安立众生于实相理。以戒方便巧同一切。持诸戒品无有乖诤。亦知众生同此戒善不断不常。未来必得菩提大果。是以敬之如佛。故说同戒以为和敬。二同见和敬。菩萨通达实相不得诸法不知不见。为欲安立众生于实相。正见方便巧同一切。种种知见无有乖诤。亦知众生因此知见分别增进开解必得种智圆明。是以敬之如佛。故说同见以为和敬。三同行和敬。菩萨通达实相无念无行。为欲安立众生于实相。正行方便巧同一切。修种种行无有乖诤。亦知众生因此诸行渐渐积功德皆当成佛道。是以敬之如佛。故说同行为和敬也。四身慈和敬。菩萨住于无缘平等大慈。以修其身慈善根力。能不起灭定现诸威仪。与一切乐故身与九道和同。亦知前所得乐众生悉有佛性未来必定当得金刚之身。是以敬之如佛。故说身慈以为和敬。五口慈和敬。菩萨以无缘平等大慈。以修其口慈善根力。能不起灭定普出一切音声言词。与一切乐。故口与九道和同。亦知前得乐众生悉有佛性未来必定当得无上口业。是以敬之如佛。故说口慈为和敬也。六意慈和敬。菩萨之心常在无缘大慈三昧。以修于意慈善根力。能不起灭定现诸心意与众生乐。故意与九道同和。亦知前所得乐众生悉有佛性如来藏理未来必定当得心如佛心。是以敬之如佛。故说意慈为和敬也。疏故白圭之玷。尚可磨也下。此借论语说南容三复白圭。谓毛诗抑篇文也。南容诵诗。至此三复读之。故郑重也。白圭之玷。尚可磨也。斯言之玷。不可为也。毛诗传云。玷缺也。今疏侧用故加三业。疏方便不空者。即侧用净名有慧方便解句。下句即有方便慧解。即涉有不迷于空。是方便有慧。观空不迷于事。即慧有方便也。疏涅槃严地也下。即涅槃经文。下当广引。在文可见。第二答行所成德。疏故柔胜刚等者。即借老子道经云柔弱胜刚强。御注云。柔顺可以行权。权行即能制物。故知柔弱者必胜刚强。德经云。天下之至柔。驰骋天下之至坚。御注云。天下之至柔者正性也。若驰骋伐胜染杂尘境。情欲充塞则为天下之至坚矣。若河上公意。意与前同。亦以柔能驰坚。如水能穿石。今疏意在此。疏若根本智即成内证等者。七事皆有内证及业用故。疏亦即是前所成之德者。即牒前文十种自在总别诸句。初智慧轮。即牒前总句成就三业。智为导故。次之九句牒十自在。但一二不次。一成巧分别即牒前第一得心自在故巧说大法。二广大念力。即第二无畏自在。三善巧智慧。即第三于法自在。及第四于智自在。由巧慧了法故。故合其二。四实相总持即第七陀罗尼自在。五成菩提。却是第五般若自在。般若为先故。六无错谬辩。即第六辩才自在。七得佛加持。即前第八随所演说开譬喻门。八普入佛会即大悲自在诲生不倦。九同一体性。即第十大慈自在。同体慈故。第十一句作大法师。即总结前十

    升夜摩天宫品第十九(第四会初)

疏。则而演说法通上三会者。前第三会不离前二会而升忉利。则各有菩萨承佛神力说前二会之法。今加不离须弥顶上。则加法慧菩萨承佛神力说十住法故。兼前二会通三会法也。余义多同须弥顶品

    夜摩宫中偈赞品第二十

疏。表十行建立故者。此有五义大意可知。初言建立者。于法性无修之中而起修故。二万行非一故。三聚集为十度四等行。显发性德令现前故。故起信云。以知法性无悭贪故。随顺修行檀波罗蜜等。四一一契理曰深。意趣秘妙为密。为相续无间。五扶疏即茂盛之貌。如一布施国城内外头目髓脑。而兴起故等。言庇映者。一一行门与慈悲俱。普荫一切相映带故。若建谓修建。立谓成立。广谓体广多。约类异则五句皆二便成十义。下三各二可知。故下结云可以意消息之。疏宜以当界之佛与当界菩萨共相属对者。以佛是当位之果。菩萨即当位之因。如功德林菩萨下释云。积行在躬功德圆满。故得成于常住之果。二慧为最胜故成无胜眼。三悟胜义谛名为胜林故成无住眼佛。四闻深无畏故成不动。五崇真拒迷成大光净。六事理无差离身心相故得解脱。七了相不动得审谛眼。八照理正修故成明相。九照心本源果成最上。十鉴达诸佛迥超色声心言路绝故名智林。故得果妙明为绀青眼。以菩萨名下文自释故今属对则果号可知。第三偈赞言一尘内身无不周于十方者。以即一恒多故等。疏喻言孟夏月者取意译也。下疏文有六。一总显文意。二梵本下会梵经。此即刊定引梵破经如下当说。今疏取其所引令顺同今经。三西域如来圣教下。出后热月相明其三际。但是佛教所用。俗之所用不必要三。亦说四时等故。四赫日之言下会经通难。即刊定破云。四月赫日岂胜六月故孟夏之言不顺赫日故。疏出意云但取光长者。故晋经云。譬如春后月虚空无云翳日曜清净光。春后与孟夏无违。赫日明取光远。五彼方或为四时下。委彰时分以正滥释。六不见此文下结。破刊定谓彼破译者云。准梵本应云后热月。不合言孟夏月。若取意总译。应云譬如盛暑月。赫日光炽然。于净虚空中。无边光照曜。由方言实无敌对翻故。应取意译也。言后热月者西域时节名字两说。一云一年三时。谓春夏秋各四月。从十一月半已后。至三月半已前名春时。余二时准知。一云一年六时各两月。谓从十一月后半。至正月前半名春时。二从正月半至三月前半名热时。三从此后至五月前半名雨时。四从此后至七月前半名秋时。五从此后至九月前半名雪时。六从此后半至十一月前半名极寒时。今此梵本云后热月者。当此国二月半已后三月半已前。彼方两热月中后热月也。然此与西国时复不同。此地正暄。西域已热。是以但可取意译耳。上即刊定记义。余之二际准知者。应云从五月十六日。至九月十五日为夏。即雨际。从九月十六日至正月十五日。即寒际。即雨热寒之三际也。斯即俱舍光法师义。若泰法师意。从十月半为首。泰公约昼夜停等后说增减。光公约昼夜极长时后说增减。然其两说亦不惬西域记文刊定承谬更斥经义。故云不见此文妄为异解。然疏文已正所引犹哈。今当具引。彼记第二卷云。月盈至满谓之白分。月亏至晦谓之黑分。黑分或十四日或十五日。以月之大小故。然白前黑后合为一月。六月合为一行。日游在内近北行也。日游在外近南行也。总此二行合为一岁。又分一岁以为六时。正月十六日至三月十五日。渐热时也。三月十六日。至五月十五日。盛热时也。五月十六日至七月十五日。雨时也。七月十六日至九月十五日。茂盛时也。九月十六日至十一月十五日。渐寒时也。十一月十六日至正月十五日。盛寒时也。如来圣教岁为三时。正月十六日至五月十五日。热时也。五月十六日至九月十五日。雨时也。九月十六日至正月十五日。寒时也。或岁为四时。春夏秋冬也。春三月谓制呾罗月。吠舍佉月。逝瑟吒月。当此从正月十六日至四月十五日。夏三月谓頞沙荼月。室罗伎拏月。婆罗钵陀月。当此从四月十六日至七月十五日。秋三月谓頞湿缚庚阇月。迦赖底迦月。末伽始罗月。当此七月十六日至十月十五日。冬三月谓报沙月。磨袪月。頞勒窭拏月。当此十月十六日至正月十五日。故印土僧徒依佛圣教坐两安居。或前三月或后三月。前三月当此从五月十六日至八月十五日。后三月当此从六月十六日至九月十五日。前代译经律者。或云坐夏。或云坐腊。斯皆边裔俗语。不达中国正旨。或方言未融而传译有谬。释曰。以此文证邪正可知。又今之坐夏正取西域四时。非佛教所明。故记不许。疏后七中令于依他起修三无性观等者。文分为四。一总标意。唯识第九广明。已如上引。二以余之二性下。出于一性修三所以。三故于一依他下。结成上义。四文即分三下。正释经文。二中有三。初明三性即一性。二明三无性即三性。三明融通为一。初中圆成即是依他之体故。观依他必观其体。离依他性无可横执。故遍计性亦约依他。又迷真似现者。此之一句具足三性。迷即遍计。真即圆成。似即依他。前意明二不离依他。此义明二能成依他。故但观依他已具三性。疏即依三性下。第二明三无性不离三性。全是唯识偈文。具足应云即依此三性。立彼三无性。初则相无性。次无自然性。后由远离前所执我法性。明三无性依三性有也。疏三性尚一下。三明融通。谓三性是有尚犹是一。三无无相岂定有三。故收三性但是一有。三无但是一无。离有无无故有无不二。初句约显。后有无形夺下约遮。余义玄中已具其相。疏初三作生无自性性观者。即第二依他上无性也。即唯识云次无自然性。然三无性名。须弥偈品文中已有。今复略释。谓法从缘无自然生性。故上生无自性即是所无。下一性字是无性性。谓无自然生之自性为其性。故言胜义无自性性者。即第三无性胜义。自性即是所无。下一性字义同于前。显无彼胜义之性为其性故。胜义即是圆成。圆成即是真如。故唯识云。此诸法胜义。亦即是真如。常如其性故。即唯识实性。言相无自性性者。即第一无性。谓遍计之相亦不可得。如绳上蛇。下一性字是第一性。以相无自性而为其性故。疏初句果空。谓缘生果法非先有体等者。即中论先有先无门观也。然亦名夺破。于中先夺破其所计先有。总举诸宗世性。微尘即是外道。及未来藏即一切有部。因缘通大小乘约相。心识即唯识唯心所现。若执定有皆为所遣。从若有来处下。纵破。鸟来栖树即中论青目释无来文。谓先有鸟而来就树。可名为来。今从无之有曰生。曾何先有。疏次句因空者。即经亦无能作者。能作是因。因者即我也。亦即牒辞则通于法。瑜伽论云。顺益是因义。谓无常法为因。无有常法能为法因。又虽无常法为无常因。然与他性为因。亦与后自性为因。非即此刹那。从既无有果下破也。即相待门破可知。从又世性等亦是妄计因缘有故者。亦因缘门。因缘无性故。亦无体门。但有妄计无实体故。疏又初句不自生等者。上之四句各别门破。今通用因缘门。以四开破略无无因。中观论云。诸法不自生。亦不从他生。不共不无因。是故知无生。而杂集论二门释之。一云不自生者。谓一切法非自所作。彼未生时无自性故。不从他生者。谓彼法缘非作者故。不从共生者。谓即由此二种因故非不自作他作故。不无因生者。缘望众生有功能故。二又因缘互夺。释云自种有故不从他等。次后当释。疏又初句非先有等者。前来唯初句用先有门。今通三句皆用先有先无门。中论因缘品云。果先于缘中。有无俱不可。先无为谁缘。先有何用缘。影公云。因中先有则可境界在六根。因中先无则因同非因。因同非因则可钻冰出火。境界在六根则可汤中求冰。若亦有亦无则具上二过。其第四句乃非此门。故中论云。若果非有生亦复非无。生亦非有无生何得言有缘。疏次偈以无生释无灭。略有三义者。一是无体门。二相待门。三因缘门。疏经云无生即是佛者。正是大品法尚答常啼云。诸法如即是佛。诸法无生即是佛等。下句既云斯人见如来。即无生是佛义耳。须弥顶上偈赞品。一切慧菩萨云。一切法无生。一切法无灭。若能如是解。诸佛常现前。疏论云若见因缘法等者。即中论四谛品末云。是故经中说若见因缘法则为能见佛。见苦集灭道。而论引经即智严经。至第十菩萨当具引之。疏各含二义故致兼言者。释上兼修之言。而云各者。正取上半观相。下半观益。为各二义。即依他圆成如下疏列。而下遣能亦含依圆故。此各言兼于能所方顺二偈兼修之言。疏一者成前下。别示二义之相。此即依他中义也。先明观相。由前偈遣能相四相。略举生灭已含住异。此偈遣所相色心法体。由四相相成其有为。当法缘生故无自性。观益可知

疏。二无生真性下。即兼修胜义无性义也。疏后偈遣能观者。然此疏中二义亦通前依圆。前义依他圆成。俱无所了。后义依圆。皆无能了。皆由即性即无性故。故疏结云能所双亡。即正结上二义也。亦通结上二偈能所。疏不了国等依他谓为现见者。而言等者国即共业缘生。以后偈总结云世间国土性。世间之言通有情世间故致等言。言谓为现见者。以中论内小乘被破。皆悉救云世间现见故。意云。不合与世间相违。又佛言。世智说有我亦说有世智说无我亦说无。今现见有国等诸法。岂得言无。故引晋经云当知由所生。所生即现故见国等。第四菩萨可知。第五菩萨。疏后偈显智从生下。疏文有三。一案经释。二会实义。三若准晋下会晋经。今初有二意。前意中云。犹搴芙蓉于深水即显所应。而于木末非所应也。即楚词意。彼云搴芙蓉于木末。此明不应也。疏二者成后智从自种熏习而生者。于中有二。先正释。后释难会通。前中谓由本有无漏种子。与多闻熏习和合。而生无漏智故。依唯识论本有新熏。三师异说。第一护月等师唯立本有。故论云。有义一切种子皆悉性有不从熏生。由熏习力但可增长。第二难陀唯立新熏。故论云。有义种子皆熏故生。所熏能熏俱无始有故。诸种子无始成就。第三护法正义。论云。有义种子各有二类。一者本有。二者始起。乃至云。由此应信有诸有情无始时来有无漏种。不由熏习法尔成就。又云。其闻熏习非唯有漏。闻正法时亦熏本有无漏种子令渐增盛。展转乃至生出世心。释曰。出世心者即是见道。其第三义正同瑜伽三十五种性品。论云。云何种性。谓略有二种。一本性住种性。二习所成性。住种性者。谓诸菩萨六处殊胜有如是相。从无始世展转传来法尔所得。名本性住种性。今疏云熏习即是新熏自种而生者。熏但熏旧无别新成。疏若尔何以经言下。第二释难会通。有两重难。初即引净名第二佛道品难因。净名问文殊言。何等为如来种。文殊师利言。有身为种。无明有爱为种。四颠倒为种。五盖为种。六入为种。七识处为种。八邪法为种。九恼处为种。十不善道为种。以要言之。六十二见。及一切烦恼皆是佛种。何谓也。答曰。若见无为入正位者。不能复发阿耨多罗三藐三菩提心。譬如高原陆地不生莲华。卑湿淤泥乃生是华。如是见无为入正位者。终不复能生于佛法。烦恼泥中乃有众生起佛法耳。今疏引此以为难耳。又入大乘论第一引龙树偈云。不从虚空有。亦非地种生。但从烦恼中。而证成菩提。皆此义也。疏此说在缠下疏答。然约彼经文见无为入正位者不生佛法。则已入见道便不能发。若约迦叶领解云。如是声闻诸结断者。于佛法中无所复益。则诸凡夫地前菩萨。有诸烦恼增修对治。成诸度门得为佛种。若已断结不可得为一切智因。故诸菩萨留惑润生以至惑尽。故摄论云。烦恼伏不起。如毒咒所害。留惑至惑尽证佛一切智。此是经之显意。今疏所明乃是经之密意。而是胜鬘楞伽等义。故云在缠如来藏。烦恼如泥。覆于二藏。然大智自从所藏不空。大智光明遍照法界义生故。二相亦异疏若尔烦恼即菩提。复云何通。即第二重难。既言即者。则不得云二事别也。谓迷真起妄说为烦恼。妄体即真元是佛种。无行经云。淫欲即是道。恚痴亦复然等。疏约体性故下。疏答上难有其二意。一约体性者。烦恼性即菩提。非约相也。故净名云。烦恼是道场。知如实故。无行经云。贪欲及嗔恚。无有能得者。是法皆如空。知是即成佛。故知烦恼实性即菩提耳。亦就相明二事不一。二云约所迷故者。即第二义也。谓迷真起妄。离真则无能迷妄心。故云即菩提耳。真即性净菩提。如波与湿双喻上二。湿是波性。波是湿相。动湿成波是波所依。能所不同故非一也。疏然实义者。下第二会实义通会两章方显中道。正通烦恼即菩提难。是显真妄交彻之义。虽说三门义含四句。谓初二门峙立依理成事则唯妄非真。事能显理即唯真非妄。故各峙立。从若说一者下。明此二章正为破病。若据菩萨二皆会中。又此章则二门峙立。后章则二相寂然。故合此二非即非离。言若说一者则离之令异者。谓有问言。万法即真一如无异。故妄即真有何过耶。答略有三过。一能依即是所依。谓依真有妄。如依水有波。今妄即是真便无能依。以无能依亦失所依。则生灭真如二俱不立。二者二既不异亦失真妄。以妄即真故无妄。无妄对何说真。三者亦失真假二门。若别则三义俱成。如金与严具。波之与水。动湿体相二俱不同。能依所依各有三义呰不杂乱。疏若云异者合之令同者下章云。如金与金色其性无差别等。疏诸识身下释。此有四意。一眼唯见色。耳唯闻声等。二缘会不同者。眼以色等而为缘故。耳用声等而为缘故。三眼无耳用者。对于果位互用而说。初意显自。此意遮他。四又此眼识不合余根者。亦对六根互用义说以互用义。或言眼根发于眼识。而了六境。余根亦尔。即第三意对之。二或言眼根能发六识以了六境。此意对之。此识不合余根。此根亦不发余识。更有说言。言互用者。眼根发耳识而能嗅于香等。亦不出上之二意。从识身同识下结其不同。疏二功能不等下。先法说后举二喻。皆明不等。此亦生公十四科善不受报义。彼问云。善恶相倾其犹明闇不并。云何言万善理同恶异各有限域耶。答明闇虽相倾。而理实天绝。明能灭闇故无闇而不灭。所以一爝之火。与巨泽火同。闇不能灭明。以其理尽闇质故也。思之可知。第六菩萨。疏二章相接显非即离亦互相成者。非即离义已如上明。言互相成者。由非即故方成不离等。故有问言。若言不一者。即应离于金别有器体。若异金有体者。即应与金不异。以同金有体无差别故。言无差别者一种有体故。答只由不异方得不一。何者。若异即妄自有体不依真立。不依真故即不得有妄。今有妄者。由不异故得成不一以妄无自体故妄依真成。以妄成故与真不一。如波依水。由不异水遂得成波。以波成故与湿不一。此上即以不异成不一也。言不一成不异者。即如上章。由有能依所依故。得交彻不异。如有波故说波即湿。由有湿故说水即波等。疏然其能喻不离诸法者。如云众生非众生三世生灭。皆是初句诸法中收。并无差别。斯则难见。若就未来无过去相。则无相理照然易见故。喻色心无相之难

疏。此喻为总者。法非法言该通性相及诸法故

疏。取文虽异义旨乃同者。谓若理若事若真若妄。此文乃异。互相交彻义旨则齐。疏亦同密严者。问明已引云。如来清净藏。世间阿赖耶。如金与指环展转无差别。则金色如指环金体即金。然此上不异总有四句。一以本成末。本隐末存。此即存隐不异。即疏云以妄无体揽真而起。则真无不隐唯妄现也。是矣。二摄末归本。末尽本显。此即显灭明不异。故疏云以真体实妄无不尽唯真现也。三摄本从末末存。摄末归本本显。此则两法俱存。但真妄有异。即有真有妄明不异。故疏云是则无体之妄不异体实之真。故云无有异也。四摄本从末本隐。是不无义。摄末归本末尽。是不有义。此则不有不无明不异。亦是末后二句。又非异故非边。不一故非中非边。是无寄法界妙智所证湛然常住无所寄也。又非一即非异故。恒居边而即中等。又非一即生死。非异即涅槃。非一即非异故。恒住生死即处涅槃等。然其法体圆融无碍。上来所说非一异等。亦是假言故。前疏云善须得意。以法就喻金等亦然。疏横者异法相望者。即一切差别法无差别也。法即是善法。非法即恶法。故百论取般若意云。福上舍何况罪。以金刚云法尚应舍何况非法。故以非法而名为罪。疏又法谓有法者。亦是横论有无相对。疏故中论下。引论证成无法为非法也。即第三论成坏品颂云。从法不生法。亦不生非法。从非法。不生法及于非法。直释偈意。法即是有。如色心等。非法是无。如兔角等。若从法生法如母生子。法生非法如人生石女儿。从非法生法如兔角生人。从非法生非法者。如龟毛生兔角。故彼长行释云。从法不生法者。若至若失二俱不然。从法不生非法者。非法名无。所有法名为有。云何从有相生无相。从非法不生法者。非法名为无。无云何生有。若从无生有者是则无因。无因则有大过。是故不从非法生法。不从非法生非法者。兔角不生龟毛。疏然前义下。断上二说。前义即事理无碍。后义即事事无碍。疏若但用后义下。反以理结。要用上二。谓要由事理无碍方得以理融于事。事事随理而融通耳。此中更有别义。谓又若依前义则心等四类即第五无为。若依后义由无为故前四无差。又依前义是性无异故。无有差。若依后义是同一如体。故无差也。疏第二偈下。初立二相。次所遣既无下。释无实义。以喻下。释合下半。后若以正报下。结弹古释。疏文举一隅应反余二者。应明现在无过未。过去无现未等。故论语云。举一隅不以三隅反。疏诸法亦然真俗并虚等者。故肇公云。涅槃盖是镜像之所归。绝称之幽宅也。岂可以有无标牓。故有余无余乃出处之异号。应物之假名耳。疏若离分别则无一切境界之相者。即起信论。前文已引。此论前文云。一切境界唯依妄念而有差别。次云。若离心念则无一切境界之相。疏反覆相遣显无差理者。谓以所知遣能知。复以能知遣所知耳。疏况当有败。如出现品者。经云。譬如世界有成坏而其虚空不增减。一切诸佛成菩提。成与不成无差别是也

大方广佛华严经随疏演义钞卷第四十一大方广佛华严经随疏演义钞卷第四十二

        唐清凉山大华严寺沙门澄观述

第七菩萨。疏二缘生无作观下。疏文有二。先总科。谓前偈上半无作。下半缘成。后偈上半缘成。下半即无作。二今初下。正释初偈。于中先解上半。自有四重。一破外道。二破小乘。三遣法相。四约无相宗说。今初。非自性等作者。即明非自作也。外道宗计之盛不出数论胜论。数论计自性能作。自性即冥谛能作。而我非能作者。但是知者。而疏言等即等于我。我为能作者即胜论师。次言亦非梵天等他作者。且等取案荼自在梵天。案荼即案荼论师所计。第一疏已明自在。即涂灰外道所计。合上为共作。离上为无因。故但举自作四句已备。疏但以虚妄无业报故者。即总破四句。四句之计皆无业报。言广如三论破者。不欲繁文指广有原。然三论皆破百论广破二宗。今取顺非四句作苦。且依十二门论。释云。然自性一计第一疏抄已广破竟。卫世计我为自。今当更释。即观作者门第十偈云。自作及他作。共作无因作。如是不可得。是则无有苦。长行以因缘门释。则通小乘大乘等。次约破外道说。先总叙云。如经说。有裸形迦叶。问佛。苦自作耶。佛默然不答。世尊。若尔苦不自作者。是他作耶。佛亦不答。世尊。若尔苦自作他作耶。佛亦不答。世尊。若尔者苦无因无缘作耶。佛亦不答。释曰。下论破有二意。一约性空。结云如是四问佛皆不答。当知苦则是空(第一约外道说)。问曰。佛说是经不说苦空随可度众生。作是说是裸形迦叶。谓人是苦因。有我者说好丑皆神所作。神常清净无有苦恼。所知所解悉皆是神作。好丑苦乐还受种种身。以是邪见故。问佛苦自作耶。是故佛不答。苦实非是我作。若我是苦因。因我生苦我即无常。何以故。若法是因。及从因生法。皆亦无常。若我无常则罪福果报皆悉断灭。修梵行福报是亦应空。若我是苦因则无解脱。何以故。我若作苦离苦无我。能作苦者。以无身故。若无身而能作苦者。得解脱者。亦应是苦。如是则无解脱。而实有解脱。是故苦自作不然。释曰。此破我为自作。故疏。云自性等等于我故。次破他作论云。他作苦亦不然。离苦何有人而能作苦与他。复次若他作苦者。则为是自在天作。如此邪见问。故佛亦不答。而实不从自在天作。何以故。性相违故。如牛子还生牛。若万物从自在天生。皆应似自在天。是其子故。复次若自在天作众生者。不应以苦与子。是故不应言自在天作。问曰。众生从自在天生。苦乐亦自在天生。以不识乐因故与其苦。答曰。若众生是自在天子者。唯应以乐遮苦不应与苦。亦应但供养自在天。则灭苦得乐。而实不尔。但自行苦乐因缘而自受报。非自在天作。复次彼若自在者。不复有所须。有所须自作不名自在。若无所须何用变化作万物如小儿戏。复次若自在作众生者。谁复作自在。若自在自作则不然。如物不能自作。若更有作者不名自在。下广有破。具如彼论。乃至云。若自在作苦乐等事。而自成坏世间法等。又自在亦从他作则无穷。无穷则无因。故非自在。次破共作有上二过。故假因和合故非无因。四皆邪见故佛不答。破梵天等例同自在。约人虽异他作义同。然此方妄计亦自西天相传之说。案三王历云。天地浑沌盘古生其中。一日九变神于天。圣于地。主于天地。天日高一丈。地日厚一丈。盘古亦长一丈。如此万八千年。然后天地开辟。盘古龙身人首。首极东西。足极东西。左手极南。右手极北。开目成昼。合目成夜。呼为暑。吸为寒。吹气成风云。叱声为雷霆。盘古死。头为甲。喉为乙。肩为丙。心为丁。胆为戊。脾为已。胁为庚。肺为辛。肾为壬。足为癸。目为日月。髭为星辰。眉为斗枢。九窍为九州。乳为昆仑。膝为南岳。股为太山。尻为鱼鳖。手为飞鸟。爪为龟龙。骨为金银。发为草木。毫毛为凫鸭。齿为玉石。汗为雨水。大肠为江海。小肠为淮泗。膀胱为百川。面轮为洞庭。韦昭同记曰。世俗相传为盘古一日七十化。覆为天偃为地。八万岁乃死。然盘古事迹近为虚妄。既无史籍难可依凭。但是古来相传虚妄耳。断曰。诚如所言。亦依稀西域梵天韦纽等。今既破邪叙之无失。疏三约因缘相待者。十地在下。对法云。自种有故不从他。待众缘故非自作。无作用故不共生。有功能故非无因。斯则以因为自。以缘为他。假因遣缘。假缘遣因。假无用以遣共。假有功以遣无因。十地更广。疏四约以因望果者。初标也。即约无相宗说。中论云。下二引论正释。即破苦品。初引一偈即初总标。偈明四句不作。三此自他言下。疏释初以果为自。引论果法不能自作己体。即青目释因缘品中。不自生义。其以因为自以缘为他。虽同杂集杂集即因缘相夺。此即当句以辨缘生。无果对待正释偈。中于果则不然也。然疏取意释初二句。若论偈中各一偈破。破初自作云。苦若自作者则不从缘生。因有此阴故而有彼阴生。释曰。上半纵其自作不从缘。下半示其因缘明非自作。次破他作云。若谓此五阴异彼五阴者。如是则应言从他而作苦。释曰。此但反显不他作。以今此阴必不异后故不他作。必若令异因则异果。因同非因。自作他作俱不从缘。如何得果以待于因。故不可也。疏离既不成下。疏生起第三四句。后引论正释。释不共句。但蹑前纵破。举况释第四句。故上论云。有因尚不成。无因何得成。疏下半二意者。即经而其得有成。亦复得有坏。前意则上半性空不碍。下半缘成。即事理无碍义。后意由上性空成于下半。即以有空义故一切法得成。则是事理相成门。疏又非但说于苦下。即中论结例之言。成坏之言显兼器界者。中论正约正报。今经意在双含耳。疏故净名云下引证。即不二法门品第十二。那罗延菩萨曰。世间出世间为二世间。性空即是出世间。而于其中不入不出。不溢不散。是为入不二法门是也。又思益第一云。五阴是世间。世间所依止。依止于五阴不脱于世间。菩萨有智慧知世间实性。所谓五阴如世间法不染。又云。五阴无自性即是世间性。若人不知是常住于世间。若见知五阴无生亦无死。是人行世间而不依世间。凡夫不知法于世起诤讼。是实是不实。但是二相中我常不与世起于诤讼事。世间之实相悉已了知故。与此大同疏则显前。非事灭者然灭。有二种谓理及事故上出世间。亦有二种。一约事出。谓地前为世间。登地为出世间。此约事灭。由偈但云彼灭非世间。则通二释。以此文证明非事灭。二者约相名世。约性为出世。即今文意是约理灭。合于净名思益等经。疏则知本自不生等者。既言空故不可灭是无灭义。而结云此是无生义者。以无可灭故是本自不生。即法自在菩萨曰。生灭为二法本不生。今则无灭得此无生法忍。是为入不二法门也。疏又证无性之理者。前约应身论无性。此约真身论无性。第八菩萨。疏若逆推其本业复有因卒至无住者。前偈因业有生即是顺明。今明生依于业。业亦从缘。故云性空。已是逆推言卒至无住。即净名经意彼逆推云。身孰为本。答曰。欲贪为本。又问欲贪孰为本答云。虚妄分别为本。又问。虚妄分别孰为本。答曰。颠倒想为本。又问。颠倒想孰为本。答曰。无住为本。文殊师利从无住本立一切法。今经中三并摄在业。众生即身空寂。无来即无住本。疏身若是佛等者。身谓色相之身。即金刚经云。若以三十二相观如来者。转轮圣王即是如来。后二句结示三即如如。四即如如智。疏以见佛称性不疑同体者。三宝同体。佛即是法。法即是众。故经云清净。如法界者。如即称义。人信法界。难信法佛。故致如言。实则佛身即法界也。疏初知离名为法者。即思益第一已如上引。第四句。云是菩萨遍行。第九菩萨。疏具分唯识者。已如上释。正取真妄合成以为具分。疏乍观此喻似前喻所作等者。即拣刊定。刊定云。前二喻真妄心所作以辨唯识。次二喻真妄心能作以辨唯识。今言似者。大种异色似画师所作。然不离心有彩画者似能作也。则粗观似尔。细寻不然。细寻已下即显正义。疏然依生灭八识下。辨二所由显法相宗但是心境依持。而即如来藏下。辨具二所以。于中先总。后以会缘入实下。别示二相。即以起信真如生灭二门为二义耳。存坏不二唯一缘起。结归华严。会缘入实坏也。不坏相故存也。言二门无碍唯是一心者。结归起信。依一心法立二种门故。须具足二义方名具分唯识。问唯识第九亦说其所转依。有其二种。一持种依。谓第八识。二迷悟依。谓即真如。何以说言然依生灭八识唯有心境依持。答彼虽说迷悟依。非即心境依持。以真如不变不随于心变万境故。但是所迷耳。后还净时非是摄相即真如故。但是所悟耳。今乃心境依持即是真妄非有二体。故说一心约义不同。分成两义说二门别。故论云。然此二门皆各总摄一切法故。以此二门不相离故。广如问明品及玄谈中。疏初偈初句总喻一心者。含真含妄有能有所。论云。所言法者。谓众生心。是心即摄一切世间出世间法故。下合云。心如工画师。次句随缘熏变成依他者。起信论云。自性清净心因无明风动有其染心。楞伽经云。藏识海常住。境界风所动。种种诸识浪。腾跃而转生。亦是不生不灭。与生灭和合非一非异。名阿赖耶识是也。次句不了依他故成遍计者。以经云虚妄取异相故。故起信云。一切诸法皆依妄念而有差别。若离心念则无一切境界之相。第四句喻依他相尽体即圆成者。以言大种无差别故。大种即喻真如。谓心体离念。即是如来。平等法身。从缘无性。即真如矣。又一二两句即不染而染。三四两句即染而不染。故有后偈喻不即离。疏大种中无色身所触故者。坚湿暖动皆是触故。言色中无大种眼所见故者。约显色说。青黄赤白眼之境故。直就法体大种是触。色即是色。若就根得谓身及眼又能造无异色者。然取增胜。地多则黄。水多则白。火多即赤。风多即青。而坚湿暖动共造于青。亦共造于黄赤及白。在能造边同一坚等。及所造边即有青等。故云能造无异画色差别故。疏喻妄依真下合。先合能所异故。亦应具言真中无妄圣智境故。妄中无真凡所知故。从性无差别下。合上又能造无异等

疏。假必依实同聚现故者。诸宗正义。坚等为实。色等为假。唯成实宗。色香味触实也。地水火风假也。以其是数论弟子后入佛法尚顺本师故。故智论云。精巧有余而明实未足。疏然大必能造色下通妨。妨云。上非即中。既云大种中无色。色中无大种。今非离中。何不言大种不离色。色不离大种。答意可知。上明真妄依持但取心中。真如一门对妄染说。疏初一亦明心境不即离者。对上真妄故。有亦言。然后三偈亦似二偈。此偈似前第二偈。以因不即离之便故。先明之。后二偈似前初偈。至下当知。今初。非即离中。言相见别者。且顺上喻有知无知。以见分合心有虑知义。以相分合画无虑知故。以器世间即是第八之相分故。疏喻离心则无境界相故者。三世所有皆是一心作故。疏要由心变于境下解妨。妨一如前。答意亦尔。疏次一偈喻能所变之行相者。大同前喻。心如工画师。分布诸彩色等。先明喻中。先释上三句。所画非心下。释第四句。法合言真妄和合心者。拣异法相宗心。即起信云。不生不灭与生灭和合名阿赖耶识是也。恒言遮断等。即唯识论第八识初能变中。第九因果譬喻门。具云恒转如瀑流。论先问云。阿赖耶识为断为常。答云。非断非常。以恒转故。谓此识无始时来一类相续常无间断。是界趣生体施设本故。性坚持种令不失故。转谓此识无始时来念念生灭。前后变异因灭果生。非常一故可为转识。熏成种故恒言遮断。转表非常犹如瀑流。因果法尔如瀑流水。非断非常相续长时。有所漂溺。此识亦尔。从无始来生灭相续。非常非断。漂溺有情令不出离是也。疏含一切种者。即第三因相门。故彼偈云。一切种相甚深细即含二门。彼偈云不可知执受处了。其了一字即第五行相门。其执受处即第四所缘行相门。其不可知即能所缘行相之内差别之义。论先问云。此识行相所缘云何(即合问也)谓不可知执受处了。了谓了别。为行相故。处谓处所。即器世间。是诸有情所依处故。执受有二谓诸种子及有根身。次论云。不可知者。谓此行相极微细故难可了知(此明见分)或此所缘。内执受境亦微细故。外器世间量难测。故名不可知。故经偈云。阿陀那识甚深细。一切种子如瀑流。我于凡愚不开演。恐彼分别执为我是也。疏次句顿现万境者。亦即彼果相门。云异熟。论云。此是能引诸界趣生善不善业异熟果故。即通辨此识能变之义。此是第一能变顿现万境故。楞伽云。譬如明镜顿现万像。现识处现亦复如是。疏下句喻所变境离心无体者。以无体故无可相知。故问明品云。诸法无作用。亦无有体性。是故彼一切。各各不相知。又常不住下。上约法相。常不住言。是刹那生灭。今明不者。即是无义。常不住者。即常无住。无住即实相异名。故从无住本立一切法。斯法性宗。真心随缘成万有故。深广难思前之经偈亦可证此。疏能画之心念念生灭自不相知者。心虽虑知今取生灭不住故不能知。以前念已灭后念未生。未生无体能知前念。前念已灭复无可知。前念亦不知后。前念已灭无有能知。后念未生亦无所知。能知之心既不自知。安能知所。疏双喻心境下。合文可知。然释此偈总有四意。一明性空。以性空故不能知自心。以性空故不能知画由心故画二。又虽不知下。明虽性空不碍缘起。三又由不能下。明由迷真起似。若悟自心不造妄境。四又正由下。即以有空义故一切法得成耳。故云诸法性如是者。通结四意。上来喻竟。然唯识论第一能变有两偈半。而有十门上随用已辨。今当具出偈云。初阿赖耶识(即自性门)异熟(二果相门)一切种(三因相门)不可知执受处(四所缘境界门)了(五行相门)常与触作意受想思相应(六相应门)唯舍受(七五受俱门)是无覆无记(八三性门)触等亦如是(同上)恒转如瀑流(九因果譬喻门)阿罗汉位舍(十断伏位次门)上之十门。疏中已有。随配可知。前后有此相。当例可知。疏第二五偈合下。疏心者即总相之心也。如前喻中已辨。故然第二句诸世间即诸彩色者。此句有二。一从能画。即属上因。二从诸世间之言。即属于果。则上半是因能变。下半属果能变故。唯识云。能变有二。一因能变。谓第八识中等流异熟。二因习气(即种子现行门)此二习气俱名因能变。此总辨也。论云。等流习气由七识中善恶无记熏令增长(三种子中各生自现除第八识不能熏故)异熟习气由六识中有漏善恶熏令增长(除第七识及无记者非异熟因故前是因缘此增上缘也)二果能变者。谓前二种习气力故。有第八识生现种种相(即前二因所生现果谓有缘法能变现者名果能变种种相者即是第八识相应心所见分等也)等流习气为因缘故。八识体相差别而生。名等流果。果似因故(即现八识三性种子各生自现名等流果所生之果与能生种性是一果故)异熟习气为增上缘感第八识。酬引业力。恒相续故。故云异熟。感前六识酬满业者。从异熟起名异熟生。不名异熟。有间断故。即前异熟。及异熟生名异熟果。果异因故。释曰。以五阴无法不造。皆异熟也。疏如次喻等者。黑即地狱。黑黑业报故。黄即中方。修罗非天。亦复非人。人白者多善业故。天白白者。因果俱善故。九地当广。疏则十法界五蕴者。谓六道四圣。四圣中佛在后偈。二乘菩萨摄在种种之中。既言无法不造。亦不拣二乘菩萨。更云等法者。以今经无法不造。三科万类皆心造也。疏初一举例以合下。疏文有二。先横论。后竖说。前中五。一正消经文。二会旧译。三别立理。四开义门。五总融摄。今初。总释经意。次然心是总相下。出心佛众生三之别相。心是总相者。法界染净万类万法不出一心。是心即摄一切世间出世间法。故名总相。余染净二缘各属二类。然总说十法界中六道为染。四圣为净。疏然佛果契心下。释其下半。上有三法而但说心与佛二法无尽。不言众生者。谓众生有尽故。心即总心以真为体本自不尽。佛果契心始本无二同一圆觉。故亦无尽。迷真起妄无始有终。不言无尽。然其佛果契心则佛亦心造。谓四智菩提则净八识之所造故。若取根本即净第八。若依真谛三藏。此佛净识称为第九。名阿摩罗识。唐三藏云。此翻无垢。是第八异熟。谓成佛时转第八成无垢识。无别第九。若依密严。文具说之。经云。心有八识。或复有九。又下卷云如来清净藏亦名无垢智。即同真谛所立。第九以出障故不同异熟为九有由。又真谛所翻决定藏论九识品云。第九阿摩罗识。三藏释云。阿摩罗识有二种。一者所缘。即是真如。二者本觉。即真如智。能缘即不空藏。所缘即空如来藏。若据通论此二。并以真如为体。释曰。此二即起信一心二门。本觉在生灭门。一心即真如故。故论云。唯是一心故名真如。无论八九。俱异凡识。即净识所造四智三身等也。疏若依旧下。二会晋译则三皆无尽。而二经互阙。唐阙众生。晋阙无尽。故有第三别更立理。疏应云下是第三也。若取圆足。合如是译则三事皆具无差之相。又得显明。从以妄体下。出妄无尽之由。是以如来下。引例证此即涅槃经意。天台用之以善恶二法同以真如而为其性。若断善性即断真如。真不可断。故云性善不可断也。佛性即是真实之性。真实之性即第一义空。如何可断。性恶不断。即妄法本真。故无尽也。疏又上三下。第四别开义门。则却收晋经以为尽理。谓唐经无尽但得二法。又唯约净。次言三皆无尽。又遗有尽之义。今云无差。尽与无尽俱无差也。亦显染净本无差矣。言心总二义一染二净者。净即自性清净。染即本来之染。染净无二为一心耳。言各以初义成顺流无差者。众生本有染故随流背佛。佛随其染岂相违耶。逆流例此。疏又三中二义下。第五染净融摄可知。疏上约横下。第二竖论。于一人上即有三法即观行之人宜用此门。疏三一偈有二义下。言上半合前二三偈之上半者。心不住于身。却是色中无大种。身亦不住心。即大种中无色。此合第二偈上半也。若合第三上半。云心不住于身。即彩画中无心。身亦不住心。即心中无彩画。疏心即能变者。心境依持中心也。及心体故者。即真妄依持中真也。言身即所变下。即上境也。及性之相即前妄也。疏下半双合前两偈下半。不离之义者。即就不离大种而有色可得。即作佛事也。亦前就不离于心有彩画可得。是作佛事也。依心现境。合前第三偈下半。依体起用。即合前第二偈下半。作诸佛事双合上二。体用不碍下释第四句。疏为兼此义不以互无言之而言不住。译之妙也者。美斯经也。若不合第四偈。但合第二三偈。应云心中无有身。身中无有心。即互无之言也。则不显于彼心恒不住义。然不相住与恒不住。义则小异文则兼之。若将此不住同前不住者。以心念念灭故不能住身。身念念灭故安能住心。思之可见。疏末后一偈等者。于中三。一略释经意。二然有二下。开义别释。于中有二释者。一是结归唯心。二观法下是结归二门。三又一是真如实观下。结成观要。言是以暂持能破地狱者。即纂灵记云文明元年。洛京人。姓王。名明干。既无戒行。曾不修善。因患致死。见彼二人引至地狱。地狱门前见有一僧云。是地藏菩萨。乃教王氏诵一行偈。其文曰若人欲了知。三世一切佛。应当如是观。心造诸如来。菩萨既授经偈谓之曰。诵得此偈能排地狱之苦。王氏既诵。遂入见阎罗王。王问此人曰。有何功德。答唯受持一四句偈。具如上说。王遂放免。当诵偈时声所到处。受苦之人皆得解脱。王氏王日方苏。忆持此偈向空观寺僧定法师。说之参验偈文。方知是旧华严经第十二卷。新经当第十九夜摩天宫无量诸菩萨云集说法品偈。王氏自向空观寺僧定法师说之也。第十菩萨。疏故梵本第四句云于不思何思者。此是刊定引梵本证第四句。亦为标章。成于晋经所思不可思义。今疏取其所引亦成第四句为总结义。谓于不思议之法不应思议。以一真心下。总结难思之相。文明可知。疏次四释不可见等者。若顺晋经四皆标章。释亦分四。前二则同三一偈。释所闻不可闻。四二偈释所思不可思。今不依此疏执石。为宝者。涅槃春池喻中。入水求珠。竞执草木瓦石。各各自谓。得琉璃宝欢喜持出乃知非真。亦自诳也。又庄严经论说。有人见雹谓是琉璃。收之瓶内皆悉成水。后见真琉璃。亦谓为雹弃而不取。世人皆尔。不应取而取。应取而不取也。疏又以量无量取则堕断常者。此有二意。谓以量取则堕于断。以无量取则堕于常。二者若以常取则堕于断。若以断取则堕于常。故胜鬘经云。修一切常者堕于断见。修一切断者堕于常见。如步屈虫要因前足得移后足。修断常者亦复如是。要因断常。第三住中已广分别。疏今初。非色现色者。此有三释。一依体现用与无边不同。二又色即空下。事理相即妙即无边。色即是空已为妙色。色空相即离空有边。三又净识所现下。约事事无碍方为妙色。亦是边即无边。无边乃广如初无边。净识所现即唯心所现门。空色相融即法性融通门。此二即事事无碍之因也。疏后二偈净空现色喻下。疏文有二。一正释经文。言此即见中绝思议者。以古人将后二偈明所思不可思。今明不思遍上三段故。指此中身业中不思也。下指语中不思亦然。二问二喻下。问答料拣。于中有二。先问后答。问中言上经者。即初偈法说之文。前经亦有。今只要此亦违诸论。即瑜伽唯识等。疏古德云下。第二答。答中三。一即贤首答。二苑公破。三疏会释。今初。自有二意。一二喻意同。二亦可下。二喻旨别。二有云下。即苑公破师。于中五。一引教反问。二若执佛果唯如如下。定师所立。三无漏蕴界下。以义反质。四亦违下引文正破。五此义具如下。指教证成。成师非正。于前二中。言唯如如等。即金光明亦梁摄论第十三。本论云。自性身者是如来法身。释论云。唯有如如智独存说名法身。又云。身以依止为义。何法为依止。本论云。于一切法自在依止。故释论云。谓十种自在。乃至云。云何此法依止。法身不离清净及圆智。智即如如。如如即智故。除实教蕴界未离断常之见。疏具如智慧庄严经说者。此引本是贤首。证成摩尼随映等喻。此经亦名度一切诸佛境界智严经一卷。在王舍城耆阇崛山顶说。如来放光一切菩萨云集。瞻仰佛。于山顶法界宫殿上。起大宝莲华师子之座无量摩尼宝宫殿等。于摩尼座中出偈。上取意引。次文殊师利问。无生无灭其相云何。佛答。不生不灭即是如来。文殊师利。譬如大地琉璃所成帝释毗阇延宫殿供具等影现其中。阎浮提人见琉璃地诸宫殿影。合掌供养烧香散华。愿我得生如是宫殿。我当游戏如帝释等。彼诸众生不知此地是宫殿影。乃布施持戒修诸功德。为得如是宫殿果报。文殊师利。如此宫殿本无生灭。以地净故影现其中。彼宫殿影亦有亦无不生不灭。文殊师利。众生见佛亦复如是。以其心净故见佛身。佛身无为不生不灭。不起不尽。非色非非色。不可见非不可见。非世间非非世间。非心非非心。以众生心净见如来身。散华烧香种种供养。愿我当得如是色身。布施持戒作诸功德。为得如来微妙身故。如是文殊师利。如来神力出现世间。令诸众生得大利益。如影如像随众生见。次举如日光无心普照喻。谓先照高山等。随其所照而有种种。次云。文殊师利。如大海中。有摩尼珠。名满一切众生所愿。安置幢上。随众生所须。彼摩尼珠无心意识。如来无心意识。亦复如是。不可测量。不可对。不可得。不可说。除过患。除无明。不实不虚。非常非不常。非光明非不光明。非世间非不世间等。广历诸非。结云。文殊师利。如来清净住大慈幢。随众生所乐现种种身说种种法。释曰。大意皆以体无生灭不碍生灭。如非色约体。非不色约用等。次又举谷响无实喻。次后即有虚空喻云。文殊师利。如虚空平等无下中上。如来平等亦复如是。众生自见有上中下。如来不作下中上意。何以故。如来法身平等。离心意识无分别故。文殊师利。一切诸法悉皆平等。乃至云。若得法性则无希望等。又云。若众生着一切法。则起烦恼不得菩提。文殊问云。云何得菩提。佛答。无根无处。文殊重征。佛言。身见为根。不真实思惟为处。文殊师利。如来智慧与菩提等。与一切法等。是故无根无处是得菩提。又云。文殊师利。如来不动名如如实。如如实者不见此岸不见彼岸则见一切法。见一切法称为如来。又菩提者。是不破句。不破句者即无相句。无相句者即如实。下即广释大意。皆以遮过为不破。显实为句。又云。以从本来不生不灭而为真实故又云菩提者。以行入无行。以行者缘一切善法。无行者不得一切善法。又云。无生无灭者。不起心意识。不思惟分别。是故我说见十二因缘即是见法。见法者即是见佛。如是见者名不思议。又云。云何行菩萨行。答不行不生不灭是行菩萨行。下亦广释。后校量功德云。假使诸众生。皆悉生人道。悉发菩提心。为求一切智。如是诸菩萨。皆作大施主。以种种供具。供养无数佛。并及诸菩萨。缘觉与声闻。乃至入灭度。各起七宝塔。高至百由旬。种种宝严饰。若人持此经。或说一句偈。出过此功德。无量无有边。以此经所说。无相法身故。释曰。上已具略经文。其琉璃地喻众生心。影喻佛身。即色即非色。摩尼珠喻则同此经。空无下中上。亦同此经净空现色。故贤首意证唯如如及如如智。苑公误引于和尚之引。故略具出。疏然上二解下。第三疏为会释意在双存。二义融即耳。于中有八。一总会二摄末从本下。收贤首义。三既所现即如下。收苑公义。四然如外无法下。假以苑公重难。意云既如收法更无所遗。何言机感现色无尽。五万法即如下。为贤首通由万法如实无所现故。正现时亦唯如矣。此即疏家立理收贤首也。六如色相即有无交彻者。正融前二。七若定执下。双弹前执。八故今二喻下。出有无无碍之旨必释喻。文言无即但是无他者。此借俱舍论意以会二喻别理。以古俱舍释无为云无为非因果。唐三藏云。无为是能作因。何得言非因。无为是离系果。岂得言非果。故新译云无为无因果。谓无余五因无余四果故。云无耳所以总云非即。非其自体。无即乃是无他故。非无二言理则悬隔。今借此言用之。摩尼现色喻自受用身。有其根本色。但无青黄等异。青黄等异随机映生。虚空以喻法性身。虚空本非色法。岂同摩尼。上显二喻别相。即是显文。从此二不二下。正明融会。即出经意。故下经云下。但引此文以证后义。以扶法相者。不许无色故。有义文显。如苑公难中。空色相融以为真身。亦系表之谈可以双摧二执。疏故以声取是行邪道。若离声取未免断无者。结成上义。上句即金刚经意。若以色见我。以音声求我。是人行邪道。不能见如来。后句即兜率偈赞意。故偈云。色身非是佛。音声亦复然。亦不离色声。见佛神通力。天鼓无心出现当辨。疏若依权教等者。本影四句即如玄谈。若依此宗四句皆用知一切法。即心自性故。质亦自心

    十行品第二十一

疏。仁王名为十止者。即上卷伏忍圣胎三十人。十信十止十坚心故已如上引。疏梵网名为长养者彼立三贤名。云十发趣(十住)十长养(十行)十金刚(十回向)。疏略无助化善根者。十住却有。经云亦是汝胜智力。故云略无。疏捷辨等者。七辩之义前文已有十地更广。疏与法界下。显难思之相。疏文有二。先正释后融拂。前中有三。一就法说。别配事理以为深广。二又超下。对人以显。三又即理之事下。事理相融释。则法界通四法界。虚空是喻。亦含四义。一事法界。二即事之理下。明理法界。于中显非表义名言。及显境名言所及。即不思议也。三况二交彻即事理无碍法界。四能令一行下。明事事无碍法界。仍上而起。要由事即是理。方得以理融事。故有事事无碍。下引证可知。第三事理无碍亦应言虚空不碍于色。色不碍空故。四事事无碍。如空入在一毛孔。即摄无边法界空故。疏又若唯遮者下。第二融拂。恐滞绝思议故。绝但是遮绝心言故。融者即言无言故。故云于中思议不可尽。即用第八真。如相回向偈文。云菩萨住是不思议。于中思议不可尽。入是不可思议处。思与非思俱寂灭。上即前半意。从遮融无二下。即后半意也。疏不可思议即真实行者。例后十地六决定中有真实善决定。彼经云不可见。今以不思议当之。言无观相行者。彼云无杂。无带相之杂故。今经地前犹带如相故。无无杂之言。疏故无。大行者。大行合云遍一切佛刹。普能救护一切众生。今无此言。疏本业云始入等者。经此前总明从住入行。云从灌顶进入五阴法性空。亦行八万四千波罗蜜故名十行。疏彼云得实法忍者。经具云于实法得法忍。心无我我所。疏瑜伽菩萨地六度各有九门者。即三十九为首。明法品已略引之。今更具引疏。但通释六度九门之相。其列名即论。谓字已下。即是疏释。今先具出布施九门。论嗢柁南曰。自性一切难行。一切门善士。一切种遂求。二世乐清净。一自性者。谓诸菩萨乃至身财无所顾惜。能施一切所应施物。无贪俱生思。及因此所发能施一切施物。身语二业安住律仪。阿笈摩。见定有果见随所求。即以此物而行惠施。当知是名菩萨自性施二一切施。略有二法。谓内物外物。又一切施物。谓财法无畏。三难行施有三。谓一财物鲜少而自贫苦施。二可爱惜物甚深爱着物施。三艰辛所获财物施。四一切门有四。一自财物。二劝他得物。三施父母妻子奴婢作使等。四施与诸来求者。五善士施有五。一净信施。二恭敬施。三自手施。四应时施。五不恼乱他施。六一切种有六有七。故有十三。言六者。一无依施。二广大施。三欢喜施。四数数施。五因器施。六非因器施。言有七者。一一切物施。二一切处施。三一切时施。四无罪施。五有情物施。六方土物施。七财谷物施。七遂求施有八相。谓一匮乏饮食施以饮食。二匮乏车乘施以车乘。三衣服。四严具。五资生什物。六种种涂饰香鬘。七舍宅。八光明。皆如初二句。八此世他世乐施有九。谓财无畏法各有三故。财有三者。谓一清净如法物。二调伏悭吝垢。三调伏藏积垢。二即舍财物执着。三即舍受用执着。无畏三者。一济拔师子虎狼鬼魅等畏。二王贼等畏。三水火等畏。法施三者。一无倒说法。二称理说法。三劝修学处。九清净施有十。一不留滞施。二不执取施。三不积聚施。四不高举施。五无所依施。六不退转施。七不下劣施。八无向背施。九不望报施。十不希异熟施。余广如彼论。然九门自性皆一。一切皆二皆三。难行皆三。一切门皆四。善士皆五。一切种或六或七。共有十三。遂求皆八。二世乐皆九清净皆十。而相随度异。然下文中。九门之内或多或少不必俱全。若一一配乃成繁碎。随显配之知法包含。疏今初含摄前四等者。即示此经包含之相下。别配之。一者施主即九门中初一也。杂集第八云。云何施圆满。谓数数施故。无偏党施故。随其所愿圆满施故。依此义故。经作是说。为大施主者此显数数施。及由惯习成性数数能故。疏一若内若外。即九门一切施中前二义也。二若难若易即难行。三财法无畏即一切施中后义。四摄第四一切门第六一切种。五即遂求故摄五门。疏文有五句以种十义者。但观前列具知次第。疏先现行财施等者。即九门中一切施中之三相也。前六度章虽皆略示。今更依摄论释之。本论云。施三品者。一法施。二财施。三无畏施。无性释云。言法施者。谓无染心如实宣说契经等法。言财施者。谓无染心施资生具。无畏施者。谓心无损害。济拔惊怖。释曰。此第一番自施行相。论云又法施者。为欲资益他诸善根。财施者。为欲资益他身。无畏施者。为欲资益他心。释曰。此第二番明施所为。天亲同此论。又云。以是因缘故说三施。梁摄论云。法施利益他心。财施资益他身。无畏施通益他身心。复次由财施故有向恶者悉令归善。由无畏施。摄彼令成眷属。由法施故生彼善根。及成熟解脱。由具此义故说三施。疏依无著论有六意乐者。一方便意乐。谓先作意。二欢喜意乐。谓见求者深生欢喜。遇于乞者称意欢喜。三者恩德意乐。谓遇乞者深心荷恩。由彼令我胜行成故。四者广大意乐。谓广行施唯期大果故。五善好意乐。谓令乞者现在丰乐未来得道故。六清净意乐。谓离障离相成波罗蜜故。疏中先列名后随文释。中方释其相故并举之。疏自期大果。亦广大意乐者。上总释广大。有二义。一谓广行施。二唯期大果故。前一切无违即是初意。今是期大果也。疏亦是善好意乐者。前亦二义。一令乞者现在丰乐。二未来得道。今是后意。疏随相离相行必同时者。即总示仪式。言如大般若者。如般若。清净遍历八十余科递。为其首成百余卷。如清净既尔。若以无生为首。亦遍历诸法无住无依无得无相等。一一皆然。故贤首云。若历事备陈言过二十万颂。今并随相居于一处。并诸离相居于一处。犹般若目。故束乃数纸展则成多。疏我谓主宰诸蕴假者者。即唯识文。论云。我谓主宰。彼疏释云。主如君主。有自在故。宰如宰辅。能割断故。诸蕴假者者。于诸蕴中假建立故称之为我。唯识论云。世间圣教说有我法。但由假立非实有性。解曰。假有二义。一无体随情假。随自执情名我法故。即外道等计。二有体强施设假。随位随缘假施设故。即圣教所说。今于二义准下智论及瑜伽文当初义也

疏。故智论三十五等者。问曰。如我乃至见者。为是一事为各各异。答曰。皆是一我但以随事为异。于五阴中我我所心起故名为我。释曰。次云但是一我下。即上论文

疏。瑜伽大同此说者。论云。于五蕴我我所现前行故。即八十三论

疏。然由迷缘生实性下释其无义

疏。若别别观无之所以如十定品第二定者。即四十经菩萨知一切法皆无我故。是名入无命法无作法者。菩萨于一切世间勤修行无诤法故。是名住无我法者。菩萨如实见一切身皆从缘起故是名住无众生法者。菩萨知一切法生灭皆从缘生故。是名住无补特伽罗法者。菩萨知诸法本性平等故。是名住无意生法无摩纳婆法者。释曰。此即别观无之所以

疏。智度论云。五阴和合中生故名为众生。瑜伽有二解。今是其一。言唯有此法者。有此有情法。有情即识。言无余者。无彼识外余我体也。二云。又复于彼有爱着故。彼疏释云。言于彼者。彼即所爱中八识也。即是有能爱情。名为有情。有情梵言萨埵。旧云众生

疏。三有想者可知

疏。四命者其释文即智论。论中具云命根成就故名寿者命者。释曰。此论双释经中寿命二种。以命根体即寿故。已见问明。世亲释云。一报命根不断故。论偈云不断至命住。大云解云。此是根命。瑜伽亦是二法合释

疏。五种种等新译名异生等者。即大般若第十三。前引智论其文小略。具即大品名为众数。智论云。从我人有阴界等众数之法。又取我人为阴界入诸法之数故。众多之法是种种义。六补特等者。即瑜伽中名

疏。七人者有灵于土木之称。即关中生公语。即智论意。瑜伽名士夫。即十七相中第六论云。言养育者。谓增长后有业故。能作一切士夫用故。彼疏释云。言养育者。令滋茂不断绝义。业令致果有士夫用未来莫穷故名养育。释曰。彼双释士夫养育文便故引之

疏。八摩纳婆。此云儒童即。出智论若瑜伽云谓。依止于意。或高或下。故彼疏释云意高下者。约行以释。然行高下皆由于意。稚年之者高下不定故。以高下而以显之。释曰。稚年高下者。即少年有学者也

疏。大般若第三下。结示本源。古有章门七门分别。一列名。二释名。三体性。四二执。五伏害。六成观。七问答。初诸说互望差别略有三种。一数增减二互有无。三变名字初增减者。第六回向但有其八。略无总我及种种耳。十定有七已如上辨。一作者。二命。三我。四众生。五补特伽罗。六意生。七摩纳婆。略无受者及种种。而加总我。大般若第四说十七相。一我。二有情。三命者。四生者。五养者。六士夫。七补特伽罗。八意生。九儒童。十作者。十一使作者。十二起者十三使起者。十四受者。十五使受者。十六知者。十七见者。第十三中但说十四。阙使作者起者使起者使受者。阙四加异生。异生义当起故。三使大同。故其第二有无已含在前增减之中。三变名字。此云众生。大般若中是有情。此云补伽罗。彼云补特伽罗。此云人。彼云士夫。此云摩纳婆。大般若云儒童。回向云童子。此云有想。大般若云生者等

疏。中已对大般若辨竟。余门可略言也

疏。一外无自共之相状者。自相者。谓色质碍相。受领纳相等。各别所属。共相者。谓五蕴等同无常苦空无我。此二皆外相也。二为无为诸法之体。诸法不出此二

疏。有去不留空者。明空有无二。故有即是空。若去于有即以去空。若有去存空则空有为二故

疏。克获为果者。此释果报有二义。一果通现在。报唯未来。如修初禅为习因。证得初禅为习果。故云习因习续于前习果。克获于后。上一重因果。望其当报总名为因。生于初禅梵众等天方名感报。故上云酬因为报。此则下结示。二又报谓有漏下。则果之与报俱在未来

疏。大施大果等者。此小大等有三。一少物施等为小。多物施为大。二小心施为小。大心施为大。自利无常等为小利。他观空等为大。三近果为小。究竟果为大

大方广佛华严经随疏演义钞卷第四十二大方广佛华严经随疏演义钞卷第四十三

        唐清凉山大华严寺沙门澄观述

第二饶益行

疏。皆显三聚等者。广略皆显故。今初初句为总。总该三聚。是略中具也。即戒自性者。是九戒之一也。意地无染是真律仪者。出三聚相。起心即破菩萨戒故。二亦为生下。摄众生戒下显持戒意含于摄善。亦是于果无依。即第九清净戒之一也

疏。谓一切利养等者。出坚相也。四分戒云。明人能护戒能得三种乐。名誉及利养。死得生天上。若希此三非真坚持

疏。本随烦恼者下。经自出

疏。又具明缠即随惑。缚即根本。言一切恶止者。即是律仪。善行即是摄善

疏。缠谓八缠下。释此缠字。疏文有五。一释八名。二辩障业。三释总名。四明十缠。五者结示。然初八缠广如论释。无惭无愧十藏广明。余之六事前后频有。二初二障戒下。辩障业。杂集第七云。修尸罗时无惭无愧为障。由具此二犯诸学处无羞耻故。次二障止者。论云。谓修止时惛沉睡眠二法。为障于内引沉没故。修智慧时掉举恶作二法。为障于外引散乱故。释曰。此论约二顺障。今疏反此者。以约违障。掉举恶作正违止故。惛沉睡眠正违慧故。后二障舍者。论云于修舍时悭嫉为障。由成就此于自他利吝妒门中数数摇动心故

疏。即障善法饶益者。止观是善法舍即饶益

疏。于相修中缠绕身心者。三释总名。亦出偏说所以也。本论云。数数增盛缠绕于心故名为缠。释论中云。由此诸缠数数增盛缠绕一切观行者心。于修善品为障碍故

疏。或说十缠者。即第四明十缠。俱舍颂第五随眠品云。缠八无惭愧嫉悭。并悔眠掉举与惛沈。或十加忿覆。论云八缠者。品类足论或十者。毗婆沙师言于被举时为重障者。忿以令心忿发为性。覆以覆藏自罪为性故

疏。此即随惑下结示

疏。缚谓四缚者。先标列。后会经。今初。杂集等论但有三缚。谓贪嗔痴由此三缚。缚诸有情令处三苦。今言四者此经第三地文。亦云此菩萨于一切欲缚。色缚有缚无明缚皆转微薄释曰。此即修所断中三界烦恼。及无明故。于见缚之外说四。并前即五住地惑也。今此四缚即按次文。贪利已下。会经四相。初贪利即经贪求为一。二热恼即嗔。三诸难逼迫。毁谤即是戒取。四浊乱即是我见。正于持戒而说四故。然其戒取由痴而生。不了诸难而生。毁谤亦是邪见同意三业故。故亦不出三毒及见。我见持为诸见之主故

疏。不毁不特释经得佛所赞平等正法。故净名第三见阿閦佛品云。不施不悭。不戒不犯。不忍不恚。不进不怠。不定不乱。不智不愚。不诚不欺。不来不去。不出不入。今取此势但用一戒中义耳。不犯故事相无违。不持故了戒空寂

疏。初摄律仪二摄善法等者。唯识十度但有三名而无解释。若梁摄论三学之中具有解释。本论中云一摄律仪戒。谓正远离所应离法。二摄善法戒。谓正修证应修证法。三饶益有情戒。谓正利乐一切有情。无性释云。律仪戒者。谓于不善能远离法防护受持。由能防护诸恶不善身语等业故云律仪摄善法戒。能令证得力无畏等一切佛法。饶益有情戒。能助有情如法所作。平等分布无罪作业成熟有情。有说。后二依初建立。释曰。此下释立三所以。无性云。此能建立后二尸罗。由自防护能修供养佛等善根。及益诸有情故。世亲云。住律仪者。便能建立摄善法戒。由此修集一切佛法。证大菩提。复能建立益有情戒。由此故能成熟有情。准梁摄论及释云。若人不离恶法。摄善利他则不得成。有说。前二为成后一。梁论云。若人住前二种净戒。则能引摄利众生戒为成熟他。梁论三戒大意同前。故彼论云。此三品戒即四无畏因。何以故。初戒是断德。第二戒是智德。第三戒是恩德。四无所畏不出三德故。由此故说戒有三品。本业经云。戒有三缘。一自性戒。二善法戒。三利益众生戒。义皆同也

疏。今初即坚持不犯为第一难者。即难行戒。准瑜伽论第四十二。有其三种。一者谓菩萨。现在具足大财大族自在增上。弃舍如是大财大族自在增上。具受菩萨净戒律仪。是名第一难行戒。二者菩萨若遭急难乃至失命。于所受戒尚无缺减。何况全犯三者。如是遍于一切行住作意。恒住正念常无放逸。乃至命终。于所受戒无有误失。尚不犯轻何况犯重。释曰。今即第一次二疏中具之

疏。只陀末利唯酒唯戒者。末利夫人为救厨子。饮酒涂饰等。只陀太子为顺国人。亦和光饮酒而不忘戒。并如别说

疏。深起大悲是善士相者。论云。云何菩萨善士戒。当知此戒略有五种。谓诸菩萨自具尸罗(一)劝他受戒(二)赞戒功德(三)见同法者深心欢喜(四)设有毁犯如法悔除(五)。释曰。今正当中三疏文自配。自具尸罗前文已有已毁令悔文中略无

疏。谓依似执实者。众生是依他似有故。颠倒谓执似为实。如依绳之依他执为蛇实

疏。依执似起者。即唯识云依他起自性分别缘所生。谓依遍计之执起依他之似。似即众生

疏。第二对明不相在。即不于颠倒内有众生等。疏言不离者。此句牒前。上言不离众生有颠倒等。明因果相待方得缘成。释上义也。依似执实待果成因也。依执似起待因成果也。上辩前对之是。非先有下拣前对之非。即先有先无门。从因中无果下。示其正义。以释经文二句之中皆先顺说正义。后反显先有之过。初云因中无果故。倒内无生者。顺说正义也。次若必下反释拣非。非先有故遍计是因因中有果。故遍计中有依他起。从果中无因故生内无倒者。顺说正义也。若要令有下。反释拣非也。若果有因有众生等即有颠倒。今有不倒众生故。知果中无有因也。第三对中言不坏因果能所遍计者。因即能遍计。果即所遍计。所遍计即依他也。从由前下结归中道

疏。第四对当体以辩者。不对众生说颠倒等故。亦皆先顺明。后反显。如倒心托境方生故。非内即先顺明。次若是内下反显

疏。既如是知下。结成二利

疏。实则愚夫自诳者。如猕猴执月。月岂有心诳猕猴耶。愚夫执虚为实明是自诳。经云诳愚夫者。是愚夫不了之境义似诳耳

疏。即前悲智所成之果者。如是解者觉了一切等即智果也。通达生死及与涅槃具二果也。有大悲故通达生死。有大智故通达涅槃。又自度等即智果也。令他得度即悲果也。二利皆即悲智果耳

疏。亦九戒中二世乐戒者。论云。当知此戒略有九种。谓诸菩萨为诸有情。于应遮处而正遮止(一)于应开处而正开许(二)是诸有情应摄受者正摄受之(三)应调伏者正调伏之(四)菩萨于中身语二业常清净转。是则名为四种净戒。复有所余施忍精进静虑般若波罗蜜多俱行净戒。则为五种。总说名为九种净戒。能令自他现法后法皆得安乐。释曰。今但通说悲智之果。智果了一切行。即般若相应故云亦是。若别配者令他解脱离垢。即是遮止开许斯即制听二戒。可以离垢解脱。其令他安隐即是摄受。令他调伏其名全同。皆令他得二世乐也。五度助戒含在其中有摄善。故第三无违逆行

疏。谦尊而光卑而不可踰者。即周易谦卦云。谦亨君子有终吉。彖曰。谦亨天道下济而光明。地道卑而上行。天道亏盈而益谦。地道变盈而流谦。鬼神害盈而福谦。人道恶盈而好谦。谦尊而光卑。而不可踰君子之终也。象曰。地中有山谦。君子以褒多。益寡称物平施。释曰。上所引文其相并显。但谦之象。地在上山在下。山合出地。今入地下谦之象也。又言褒多者褒聚也。聚其多而益其寡。是益谦义故为平施。若王注云。多者用谦以为褒。少者用谦以为益。随物所施不失平者也。谦下者。忍之本也

疏。若海之下等者。即老子德经云。江海所以能为百谷王者。以其善下之故。能为百谷王。是以圣人欲上人以其言下之。欲先人以其身后之。是以处上而人不为重。处前而人不为害。是以天下乐推而不厌。释曰。特由谦卑天下归之。天下德趣之

疏。一无如前境而自刑害者。天宫云。自害略由五缘。谓贪嗔邪见愚痴不善心

疏。苟心赞他者。智论五十三说。舍利弗赞须菩提善说法。好人相不自赞。不自毁于他外人。亦不赞毁。若自赞非大人相。不为人赞而便自美。若自毁者。是妖谄人。若毁他者。是谗贼人。若赞他者。是谄媚人。须菩提了无生法故。舍利弗虽赞而不谄。以称实赞故。又以断法爱故。心不高亦不爱着。但益无障碍因。所谓一切法无所依止故无障碍。又言取即是着。唯识第八释三熏习中云。惑苦名取。能取所取故。取是着义。业不得名取着。智论取增名著。七十四云。初染曰取。生爱名著

疏。上来皆是清净忍者。论云。略有十种。谓诸菩萨遇他所作不饶益事损恼违越终不反报(一)亦不意愤(二)亦不怨嫌(三)意乐相续恒常现前欲作饶益。先后无异非一益已舍而不益(四)于有怨者自生悔谢。终不令他生疲厌已然后受谢(五)于不堪忍成就增上猛利惭愧(六)依于堪忍于大师所。成就增上猛利爱敬(七)依不损恼诸有情故。于诸有情成就猛利哀愍爱乐(八)一切不忍并助伴法皆得断故(九)离欲界欲(十)由此十相当知菩萨所修行忍清净无垢。释曰。不可别配大意同经

疏。初耐怨害等者。三忍之义略见初会。今更重依摄论释之。无性论云。耐怨害者。是诸有情。世亲释云。能忍他人所作怨害。勤修饶益有情事时。由此忍力化生。虽苦而不退转。言安受苦忍者。是成佛因。寒热饥渴种种苦事。皆能忍受无退转故。言谛察法忍者。是前二忍所依止处。堪忍甚深广大法故。世亲云。堪能审谛观察诸法。或由谛察为前二依者。世亲释云。由此忍力建立次前所说二忍。梁摄论云。由观察法忍。菩萨能入诸法真理。此忍即是前二忍依处。以能除人法二执故疏。此亦九中难行忍也。难行有三。一忍羸劣有情所不饶益。二忍自臣隶所不饶益。三忍种性卑贱所不饶益。今同第三

疏。若说此胜利成善士行者。论云。善士忍有五种。谓诸菩萨先于其忍见诸胜利。谓能堪忍补特伽罗。于当来世无多怨敌。无多乖离。有多喜乐。临终无悔。于身坏后当生善趣天世界中。见胜利已自能堪忍(一)劝他行忍(二)赞忍功德(三)见能行忍补特伽罗慰意庆喜(四)应有设有不忍如法悔除(论阙第五恐是脱漏故今具之)而疏云说此胜利正是第三赞忍功德。如失自要即是第一自不忍。不能令他安忍。今不不之即是第二既自庆慰。亦能庆他当第四五也

疏。故炼磨颂者。即三种炼磨心。断除四处障中之一。即无性摄论第六释入现观云。由何能入由善根力所任持故。谓三种炼磨心断除四处障故。若唯识论第九明资粮位。释于二取随眠。犹未能伏灭。云此位二障虽未伏除修胜行时。有三退屈而能三事炼磨其心。于所证修勇猛不退。一闻无上正等菩提广大深远心便退屈。引他况己证大菩提者。炼磨自心勇猛不退。释曰。即第一菩提广大屈引他况己炼。广者无边。大者无上。深者难测。远者时长。由斯故退。引他炼之。摄论颂云。十方世界诸有情。念念速证善逝果。彼既丈夫我亦尔。不应自轻而退屈。唯识论云。二闻施等波罗蜜多。甚难可修心便退屈。省己意乐能修施等。炼磨自心勇猛不退。释曰。即第二万行难修屈省己增修。炼颂云。汝昔恶道经多劫无益勤苦尚能超。今行少善得菩提大利不应生退屈。唯识论云。三闻诸佛圆满转依极难可证心便退屈。引他粗善况己妙因。炼磨自心勇猛不退。释曰。即第三转依难证屈引粗况妙。炼颂云。博地一切诸凡夫尚拟远证菩提果。汝已勤苦经多劫。不应退屈却沉沦。唯识论云。由斯三事炼磨其心。坚固炽然修诸胜行。释曰。今是十行正是其位故。疏引之言断四处障者。无性摄论但举四云。由离声闻独觉作意故(一)由于大乘诸疑离疑。以能永断异慧疑故(二)由离能闻所闻法中。我我所执断法执故(三)由于现前现住安立。一切于中无所作意。无分别断断分别故(四)释曰。即由此四是四处故。然三炼磨通治四障。然皆由忍三轮故。忍三轮者。自他过失分别也

疏。二诸法空下。令他成忍至皆清净有。十如前已引。今但总相是彼之意亦不别配

疏。然庄严论中由三思五想者。即第二论中。言此三等在安受忍中者。前念无始劫受诸苦恼。即是自业及行苦也。亦令他得此法即况二乘也。言对前可思者。前性空无二即不可得无有真实。即是无常若苦若乐即是苦想广为人说等即摄取想略无本亲。摄在无始生死之中

疏。愍彼沦倒宁怀恨心者。准智论云。罗睺罗被外道打悲泣。人问其故。答曰。我苦少时尔奈渠长苦何。即愍其沦溺而言倒者。亦愍其因但由颠倒。如提婆菩萨被外道开腹弟子欲追。菩萨广说法空诫诸弟子云。此等颠倒妄见我人故生此恶。不了性空无有真实等

疏。斯即九中二世乐者。论云。二世乐忍有九。谓菩萨住不放逸(一)于诸善法悉能堪忍(二)于诸寒热悉能堪忍(三)于诸饥渴(四)于蚊虻触(五)于诸风日(六)于蛇蝎触(七)于诸劬劳所生种种。若身若心疲倦忧恼(八)于堕生死生老病死等苦。有情现前哀愍而修忍行(九)上七皆有悉能堪忍之言。论云如是顺忍得二世乐。斯亦总相愍念众生。令得二世乐也。第四无屈挠行

疏。挠者曲也。弱也者。即周易大过卦意。易云。大过栋挠利有攸往亨。彖曰。大过大者过也。栋挠本末弱也。释曰。大过兑上巽下上下皆阴故云本末弱也。易文以弱释挠。音义云。挠者曲也。曲之与弱义相似也。今取弱义。释无屈挠。则屈者亦曲也。既曰牢强则无屈弱。然梵云钵履耶捺多。此云无尽。即晋经之名。谓大愿之力无有尽耳。此亦大同

疏。此有三义。一大故第一等者。此取十地势十句相释。以二三四释于初句。以五六七释第二大字。以八九十释第三胜字。文并可知

疏。即难行者。在文易知。然皆亡三轮故精进三轮者。即众生高下事用分别

疏。具含三种精进者。唯识说三。一被甲。二摄善。三利乐。无性释云。一被甲。二加行。三无怯弱无退转无喜足。初者谓最初时自励言我当作如是事。即是解契经所说。初有势力句。次即加行有勤句。无怯等者。谓随事意乐所作善事。乃至安坐妙菩提座复不放舍。于自疲苦心无退屈名无怯弱。于他逼恼心不动移名无退转。乃至菩提于其中间进修善品。常无懈废名无喜足。如是三句解释契经所说。有勇猛于诸善法不舍离故。世亲释三精进大同。无性释经五句复云。所以者何。或有最初求于无上正等菩提。虽有势力而加行时不能策励。故说有勤加行。虽复有勤心或怯弱。为对治彼故说有勇。由有勇故心无退屈。心虽无怯逢生死苦心或退转由此退失所求佛果。为对治彼立无退转。无退转者。即是坚猛故不退转。显云坚猛由有坚故逢苦不退。由有猛故不惧于苦。虽逢众苦能不退转。而得少善便生喜足。由此不证无上菩提。是故次说无喜足者。是不得少善便生喜足。此义即显示不舍善轭。由此义故说三精进。然被甲者。从喻立名。如人入阵先须被甲以防弓矢。今求菩提必先誓愿以防退屈。本业经直云一起大誓愿之心。二方便进修。三勤化众生

疏。今初全同瑜伽之文。但论以被甲为初者。四十二论云。一被誓愿甲。若我脱一有情。若以千大劫为一日夜。处于地狱经尔所时。证大菩提乃至过此千俱胝倍无懈怠心。况短时苦薄耶。有能于此生少净信已。长养无量勇猛大菩提性。况成就耶。故云约先心自誓

疏。有深功德为难行者。瑜伽难行精进有三。若诸菩萨无间远离诸衣服想。诸饮食想。诸卧具想。及己身想。于诸善法无间修习曾无懈怠。是名第一难行精进。若诸菩萨如是精进尽众同分。于一切时曾无懈废。是名第二难行精进。若诸菩萨平等通达功德相应。不缓不急无有颠倒。能引义利精进成就。是名第三难行精进。今文具三长劫不懈。况尽寿耶即是第二。一念不悔即亡身无间即是第一。自庆已下即第三。前行初离过亦此第一。第五离痴乱行。疏总。云成就下。释此总句有二。先正释。后解妨。前中即瑜伽九门中自性禅也。论云静虑自性者。闻思为先所有心一境性总也。一或奢摩他品。二或毗钵舍那品。三或双运道也。疏中随标便引文释成可知。言善解世间等者。下云以正念故善解世间一切语言。能持出世诸法言说。乃至心无痴乱

疏。自配无痴乱即正是双运。又以别义善解是观。能持是止。故为双运。疏故下经云禅定持心等者。即第十回向偈中

疏。虽有毗钵舍那下。第二解妨在文可知。正是瑜伽出禅自性也疏。上九别句摄为三禅者。三禅即瑜伽一切禅也。唯识但列而不释名。瑜伽释广。今依摄论。无性释云。一安住静虑。谓得现法乐住离慢见爱得清净故。二引发静虑。谓能引发六神通等殊胜功德故。三成所作事静虑。谓欲饶益诸有情类。以能止息饥俭疾疫诸怖畏等苦恼事故。梁摄论中释三定云。有现世得安乐住。何以故。能离一切染污法故。一依此定者为生自利。谓三明故能引成六通。二引因成通定生随利他。利他即是三轮。一神通轮。谓身通天耳通天眼通。此轮为引邪向正者令其归正。二记心轮。谓他心通天耳通天眼通。此轮为引己归正者。若未信受令其信受。三正教轮。谓宿住通漏尽通。宿住通识其根性。由漏尽通如自所得。为说正教令得下种成熟解脱。由具此义是故说定有其三品。为离痴乱行

疏。正念有观下。疏文有五。初正释顺文。二世言无益下出经局意。三出世不解下立理显通。四故文虽下结成通义。五解事下别释善解

疏。瑜伽第二明四种入胎下。疏文有二。先正释无痴乱言。二示痴乱相。前中文显。俱舍第九论问起云。前说倒心入母胎藏。一切胎藏皆定尔耶。释曰。此牒前倒心趣欲境湿化染香处为问也。论中答云。不尔。经言入胎有四。其四者何。颂云。一于入正知。二三兼住出。四于一切位。及卵恒无知。前三种入胎。谓轮王二佛业智俱胜故。如次余四生。释曰。但观上瑜伽颂文易了。但业智俱胜更须略释。第一轮王以业胜故正知于入。宿世曾修广大福故。第二辟支佛但知胜故正知入住。久习多闻胜思择故。第三大觉福智俱胜三皆正知。谓旷劫修行胜福智故。除此前三余胎卵湿福智俱劣故皆痴乱

疏。凡夫痴乱相下。则第二别示痴乱。先总举其相。后指其源。大集二十七多同涅槃。涅槃十八者。南本十六。经云善男子。人有三品。谓上中下。下品之人初入胎时作是念言。我今在厕众秽归处。如死尸间众棘刺中大黑闇处。初出胎时复作是念。我今出厕出众秽处。乃至出于大黑闇处。中品之人作是念言。我今入于众树林间。清净河中房舍屋宅。出时亦尔。上品之人作是念言。我升殿堂。在华林间。乘马乘象登陟高山。出时亦尔。菩萨摩诃萨初入胎时。自知入胎。住时知住。出时知出。终不生于贪欲嗔恚之心。而未得阶初住地也。是故复名不可思议。二十九者。南经二十七。经云中阴二种。一善业果。二恶业果。因善业故得善觉观。因恶业故得恶觉观。父母交会和合之时。随业因缘向受生处。于母生爱于父生嗔。父精出时谓是己有。见己心悦而生欢喜。以是三种烦恼因缘中阴阴坏生后五阴。如印印泥印坏文成。释曰。此略举男。俱舍第九则具男女。论释倒心趣欲境云。此明中有先起倒心驰趣欲境。彼由业力所起眼根。虽住远方能见生处父母交会而起倒心。若男中有缘母起爱生于欲心。若女中有缘父起爱生于欲想。翻此缘二俱起嗔心。彼由起此二种倒心。便谓己身与所爱合。所泄不净流至胎时。谓是己有便生欢喜。此心生已中有便没。受生有身余广如彼。瑜伽文说彼胎藏者。若当为女于母左胁倚脊向腹而住。若当为男于母右胁倚腹向脊而住。又此胎藏业报所发生分风起。令头向下足便向上。胎衣缠裹而趣产门。其正出时胎衣遂裂分之。两腋出产门时名正生位。并可知。疏别。谓四魔者。四谓天阴烦恼及死。言十魔及业如离世间等者。所谓蕴魔生取着故(二)烦恼魔恒杂染故(三)业魔能障碍故(四)心魔起高慢故(五)死魔舍生处故(六)天魔自慢纵故(七)善根魔恒执取故(八)三昧魔久耽味故(九)善知识魔起着心故(十)菩提法智魔不愿舍离故。十魔业者。一忘失菩提心修诸善根是为魔业。二恶心布施嗔心持戒。舍恶性人远懈怠者。轻慢乱意讥嫌恶慧。乃至第十增长我慢无有恭敬。于诸众生多行恼害不求正法真实智慧。其心弊恶难可开悟是为魔业。四魔如常所辩。谓天魔阴魔烦恼魔死魔。故大品之中四魔。而多说天魔烦恼魔

疏。起信论说者。余论广有此论分明人易寻故今略示耳。即修行信心分中。论云。或有众生无善根力。则有诸魔外道鬼神之所惑乱。若于坐中现形恐怖。或现端正男女等相。当念唯心境界则灭终不为恼。或现天像菩萨像。亦作如来像相好具足。若说陀罗尼。若说布施持戒忍辱精进禅定智慧。或说平等空无相无愿。无怨无亲。无因无果。毕竟空寂是真涅槃。或令人知宿命过去之事。亦知未来之事。得他心智辩才无碍。能令众生贪着世间名利之事。又令人数嗔数喜性无常准。或多慈爱。多睡多病。其心懈怠卒起精进。后便休废生于不信多疑多虑。或舍本胜行。更修杂业。若着世事种种牵缠。亦能使人得诸三昧少分相似。皆是外道所得非真三昧。或复令人若一日若二日若三日乃至七日。住于定中得自然香美饮食。身心适悦不饥不渴使人爱着。或亦令人食无分齐乍多乍少颜色变异。以是义故行者当应智慧观察。勿令此心堕于邪网。当勤正念不取不着。则能远离是诸业障等。释曰。此一段文虽则稍广亦为要用。其中兼有对治则显菩萨心无痴乱

疏。智论除诸法实相等者。论有喻云。譬如绳能缘一切物。唯不能缘火焰缘火焰即为烧故。魔亦如是能缘一切法。唯不能缘诸法实相。若入实相魔即实相何所惑耶。故论云。魔界如佛界如。一如无二如。皆法界印。岂以法界印更坏法界印。又八十二云。魔见解般若菩萨。如捕鱼人见一大鱼入深大水。钩网所不及则绝望忧愁。以离六十二见网故。又七十三魔作大沙门有重威德等。或时语菩萨般若三解脱门是魔说。但是空汝常习此空。于中得证不得证云何作佛法。佛法先行布施持戒等。修三十二相福德。坐道场时尔乃用空。菩萨或行或信或疑远离般若。释曰。依此世魔甚多。七十一又云。魔作知识身说般若空。虽说罪福名而无道理。或说空可取即涅槃。释曰。前七十三。魔令莫修空而须修事行。此中说断灭空令其趣证。故人多惑耳。若得诸法实相亦不舍空修事。亦不谓空碍有。亦不以空为证。则以般若性空导一切行。修无所修则魔不能令菩萨痴乱

疏。今以智觉察者下。示不为痴乱所以。如人觉贼及偷狗者。即涅槃南经邪正品。北经亦如来性品。即第七经。如人觉贼贼无能为。又因迦叶问依四种人。难云。世尊魔等尚能变作佛身。况当不能作罗汉等。佛言。善男子。于我所说若生疑者。尚不应受况如是等。是故应当善分别知。善男子。譬如偷狗夜入人舍。其家婢使若觉知者即应驱骂汝疾出去。若不出者。当夺汝命。偷狗闻之即去不还。汝等从今亦应如是降伏波旬应作是言。波旬。汝今不应作如是像。若故作者当以五系系缚于汝。魔闻是已便当还去。如彼偷狗更不复还。下乃广说佛说魔说之相。此文但令觉察

疏。大分深义所谓空故者。即十二门论但改彼也字为故字耳

疏。共不共等。此有二义前义十地更释。后义出现品明

疏。又随他意行下。即涅槃经意。明佛有三语。随自意语。随他意语。随自他意语。立行亦然如前已引

疏。孱然无差者。孱犹现也

疏。沮坏六根等者。沮亦坏也

疏。五种恶风等者。即治禅病秘要经第一。此经是宋元嘉十八年沙门昙摩蜜多于扬州祇洹寺译。标云治阿兰若乱心病。七十二种法。经云尊者舍利弗所问。出杂阿含。阿兰若事下取意引。即诸释子比丘坐禅。因毗琉璃王象戏惊怖发狂。阿难令闭门白舍利弗。舍利弗牵其问佛。经云。唯愿天尊慈悲。一切为未来世诸阿兰若比丘。因五种事。令心发狂。一者因乱声。二者因恶名。三者因利养。四者因外风。五者因内风。此五种病当云何治。唯愿天尊为我解说。尔时世尊即便微笑。有五色光从佛口出。绕佛七匝还从顶入。告舍利弗谛听谛听善思念之。吾当为汝分别解说。若有行者于阿兰若。修心十二头陀。于阿那般那。因外恶声触内心根四百四脉治心急故。一时动乱风力强故最初发狂。心脉动转五风入咽。先作恶口。汝等应当教是行者服食酥密。及诃梨勒。系心一处先想作一玻璃色镜。自观己身在彼镜中。作诸狂事见此事已。复当更观而作是言。汝于明镜自见汝作狂痴事等。广有治法末后结云。是名治乱倒心法。复次舍利弗既去外声已当去内声。内声者。因于外声动六情根。心脉颠倒五种恶风从心脉入。风动心故或歌或舞作种种变。汝当教令作洗心观。洗心观者。先自观心令渐渐明。犹如火珠四百四脉。如毗琉璃等广说治法。今疏即引后段之文。然彼但云五种恶风下更不说。然似前因五种事便为五风。准金七十论。说五种风。一者波那。二者阿波那。三者优陀那。四者婆那。五者婆摩那。是五种风。一切根同一事。波那风者。口鼻是其路取外尘。是事谓我止我行是其作事。外曰。是波那何根能作。答曰。是十三根共一事(谓十一根并大我慢)譬如笼中鸟。鸟动故笼动。是故十三根同其事。阿波那风者。见可畏事即缩避之。是风若多令人怯弱。优陀那者。我欲上山。我胜他。不如我。我能作此。是风若多令人自高。谓我胜。我富等。是优陀那事。婆那风者。遍满于身。亦极离身。是风若多令人离他不得安乐。若稍离分故如死。离尽便卒。婆摩那风者。住在心处能摄持是事。是风若多令人悭惜。觅财觅伴。是五种风事并十三根所作。释曰。此五必是也。不依常位。从心脉入故发狂乱耳

疏。上皆一切种禅者。瑜伽四十三。一切种禅有六种七种。总成十三。言六种者。一善静虑。二无记变化静虑。三奢摩他静虑。四毗钵舍那品。五者于自他利正审思惟。六者能引神通威力功德静虑。言七种者。一者名缘静虑。二者义缘静虑。三者止相缘。四者举相缘。五者舍相缘。六者现法乐住。七者能饶益他静虑。今云名义即后七中。一二止观。即六七中各是三四。二利即前六中五六。及后七中五六七。故摄十三善。及与无记。亦有通也

疏。斯亦九中清净静虑者。瑜伽四十三云。有十种。一者由世间净离诸爱味清净静虑。二由出世净无有染污。三由加行。四由根本。五由本胜进。六由入住自在。七舍静虑已复还证入自在。八神通变现自在。九离一切见趣。十一切烦恼所知障静虑。皆有清净静虑之言。若配经者。正是九十及与初二离垢障故。然大意清净者。由离三轮故。定三轮者。谓一境界。二众生。三惑

疏。故身子不觉刑害之手者。准智论说。舍利弗。当道坐禅。有大力鬼名为刑害。以手搏之。从禅定起微觉头痛。白佛。佛言。赖汝定力。此鬼之力掴须弥山令如微尘。自今已后莫当道坐

疏。迦叶不闻涅槃之音者。如来二月十五日晨朝出声。普告一切言。如来今日中夜当入无余涅槃。若有疑者今悉可问为最后问。然以佛神力其声遍满三千大千世界。万类皆至而迦叶不闻。定起方觉世界变异惊怪询问。方知如来入般涅槃。上之二事一定中不能觉触。二定中不能闻声故知劣也。今菩萨善知故为超胜

疏。相则念念不住等者。然三相四相一念具足已如初卷。今性相别明。若相融为四者。揽缘名生。生即无生空有无碍虚相安立。名之为住。住即无住圆融形夺随缘转变。名之为异。异即无异两相都尽各无自性。名之为灭。灭即无灭斯则即相而性故无所得

疏。大地为鼓等者。如幻三昧经云。假使以大地为鼓。须弥为捶于须菩提耳边打。不能生微念心乱。何以故。入空定故

疏。即难行禅者。难行瑜伽有三。明法已引。今重取意出之。谓住深静虑舍而利生。生于欲界为一。依止静虑。发无量菩萨二乘境界等持为二。依此速证无上菩提为三。今文正当第三

疏。初句标举一切门禅者。瑜伽云。略有四种。一者有寻有伺静虑。二喜俱行。三乐俱行。四舍俱行静虑

疏。复云门者。即智论问云。何以不但言三昧而复说门。答但语三昧无量数如虚空。无边菩萨云何尽得。是故说门。菩萨入一三昧中摄无量三昧。如牵衣下。同此中意

疏。非唯不乱本定更增者下。出增相。猪以秽身揩于金山。非唯不污而令山色转益明净。斯乃外境之猪益定山之净

疏。住清净念即现世乐等者。瑜伽二世乐有九。一者神通变现调伏有情静虑。二记心变现调伏有情静虑。三教诫变现调伏有情静虑。四于造恶者示现恶趣静虑。五于失辩者能施辩才静虑。六于失念者能施正念静虑。七制造建立无颠倒论。微妙赞颂摩怛理迦能令正法久住于世静虑。八者于诸世间工巧业处。能引义利饶益有情种种书算测度数印床座等事。能随造作静虑。九生于恶趣所化有情。为欲暂时息彼众苦。放大光明照触静虑。今但通举二世乐义耳。第六善现行

疏。体即般若亦忘三轮而照也。般若三轮者。境智众生分别。就标名中二。一总显体。二瑜伽下。正释名。于中二。先引三慧立名不同。后依之释名。前中略出四说。就摄论三中准论具列云。一无分别加行慧。二无分别根本慧。三无分别后得慧。论具释云。无分别加行慧。谓真如观。前胜方便智。无分别根本慧者。谓真如观智。三无分别后得慧者。现诸世俗智。能起种种等事。梁论三慧者。论中释云。从闻无相大乘教。得闻思修。入分别相空。通名无分别。加行般若若入三无性者。无分别智名无分别般若。若得无分别智后得入观。如于所证。或自思惟。或为他说。名无分别后得般若。由具此义故说般若有其三品

疏。本业以照于三谛者。经云。一照有谛慧。二照无谛慧。三照中道第一义谛慧。皆十度明义者。经具列十故

疏。经有十度下。第二依之释名。言今为顺文者。多同瑜伽故。虽彼依六中下。解妨。妨云。唯识云。若依六度则般若具摄三慧。谓加行根本后得。若为十度第六唯摄无分别智。今何引六而成十耶。故今释云。约圆行说亦兼正明义如本业是

疏。古人亦依下初叙昔。二此得次第下辩非。三今约下辩正文。中犹略今具引三慧。瑜伽释三慧相云。云何菩萨一切慧。此有二种。一者世间慧。二者出世间慧。复有三种。一能于所知真实随觉通达慧。谓若诸菩萨于离言说法无性。或于真谛将欲觉悟。或于真谛正觉悟时。或于真谛觉悟已后所有妙慧。最胜寂静明了现前。无有分别。离诸戏论。于一切法悟平等性。入大总相究达一切所知边际。远离增益损减二边。顺入中道。是名菩萨能入所知真实随觉通达慧。释曰。据此即具足加行根本后得三慧。亦具照有照无照中道三慧之体。是第一慧。今经文中第一段内。便具三谛之慧故与之同。二释上第二慧。证真善了于俗故。广知五明等。论云。若诸菩萨于五明处决定善巧演说。如前力种性品。应知其相及于三聚中决定善巧。谓于能引义利法聚。能引非义利法聚。能引非义利非非义利法聚。皆如实知于是八处。所有妙慧善巧摄受。能速圆满广大无上妙智资粮。速证无上正等菩提。释曰。此是后得广知诸法三聚。即前能引义利等。亦即善恶无记兼五明为八。五明即内明因明等。三释能作一切有情义利慧。云有十一种。如前应知者。即三十七论成熟品。成熟自性自有十一。谓由有善法种子(一)及数习诸善法(二)获得能顺二障断净(三)增上心有堪任性(四)极调善性(五)正加行满(六)安住于此。若遇大师不遇大师。皆有堪任(七)有大势力(八)无间能证烦恼障断(九)所知障断(十)譬如痈肿熟至究竟。无间可破说名为熟(十一)前十别明。后一总喻熟相

疏。住无得现现即无得者。住无所得即空观也。示无所得身等假观也。故云住无得现。现即无得上二不二中道观也。故云寂用无碍斯为中道。从若异后下结弹古人。以璎珞三慧别配得中道慧。是相待中非得中也

疏。何者若偏观下。出次第三观过相。有则定有定有着常以离空故。定无著断以离有故。离二明中故是相待

疏。若总观下。示圆融三观之德。于中先有两句。向上成次第之过。明次第三观有一异过故。二者即初二句反释双遮三一。故即一而三下。双融中具有四句。皆融即一而三是一句。即三而一是第二句。双非三一是双非句。由即一而三故。非三即三而一故。非一四虽即一体而三用历然。虽有三用。而一体无二故双照三一。即遮而照。即照而遮。故圆融也。在境下。结成谛观

疏。古德下叙昔。虽非经意释文稍巧故复叙之。故云亦是一理。以唯识观相不明显故。故不为正

疏。故晋经云。非有说有者。今经无此。示意相隐。但有言语道断。即通身意故引晋经意在有说之言

疏。然上之所住下。总释上三业所住不同。一如实心即自性清净心者。胜鬘起信等皆立此名。庄严论第六云。众生于无性及有可得。此二处中互生怖畏。为遮怖心而说颂云。譬如清水浊秽除还本净。自心净亦尔。唯离客尘故以说心性净。而为客尘染。不离心真如别有心性净。释曰。后偈释前偈上半合上半下半。释下半。既不离心真如别有心性。明知但是离于客尘说之为净。净体即是自心。心即真如此自性净心即如来藏。亦是本来净识故。真谛三藏说有九识。第九名阿摩罗识。若唐三藏此翻无垢。即第八异名。谓成佛时转第八识以成此识无别第九。若依蜜严经心有八种。或复有九。又下卷云。如来清净藏亦名无垢智。即同真谛所立第九。又真谛三藏所翻决定藏论。九识品云。第九阿摩罗识。三藏释云。阿摩罗识有二种。一者所缘即是真如。二者本觉即真如智。能缘即不空如来藏。所缘即空如来藏。若据通论此二并以真如为体。故起信一心二门生灭门中。说其本觉即真如门。体无二也。余名随释可知

疏。举多名者即上七名故。收真如法界。略有百名。权教最多。言百名者。谓法性。不虚妄性。不变异性。平等性。离性生。法定。法住。实际。虚空界。不思议界(已上大般若)真如实有空不空性胜义(已上佛地论摄论)无相无为正性(已上思益中)法位(大品)真性。无我性。真实性。心性一心(上亦大品下三亦华严)唯识性。无性法印(第一回向云以法界印印诸善根故)寂灭(智论)三性中名圆成实性。三身中名法身。三净土中名法性土。三佛性中名自性住性。五法中名如如。五藏中名皆是谓法界藏。法身藏。出世间上上藏。自性清净藏。如来藏。四胜义中名胜义。胜义亦通证得。及道理中灭谛(瑜伽六十四中)六谛中亦名真谛。现观七谛通达中名法性。显扬二种佛性中名理佛性。十四谛中名胜义谛。三般若中名实相般若。三三宝中名一体。三解脱中名空(出智论七十四)二果中名智果。涅槃中名性净方便。二谛中名真谛胜义谛。三谛中名空谛(仁王经)四谛中名灭谛。或名实谛。显扬名一谛。或名中道。或名解脱。涅槃中以一百门显解脱异名。或名不二法门。或名无二性。或名实性。或名实相。或名无量义。亦名第一义谛。亦名第一义空。上来众名若在大乘权教中者。但就理名之。若实教中或就即事之理。即理之事。事事无碍。然皆通权实教

疏。五名无得物之功者。若依世俗名以召实。实以当名。故使命火不得于水。命水不得于火。今约真谛故平等无依。此五六句皆先标无依。后若名在法等反以释成。如有一人虽先知。有曾未相识。忽然见面终不得知此是某人。此为见义不知名耳。义即境义。六中有人虽闻其名竟不识面。召火不烧口明知名中无有义也。亦应云言饭已饱等故。智论四十七云。凡有二法。一者名字。二者名字义。如火能照能烧是其义。照是造色烧是火用。二法和合名为火也。今闻火名不得照烧之义。故无得物之功也

疏。然世法与佛法实无二体者。同一真如故。无事非真。事亦即如故。云假约事理以分其二

疏。故以五句显非一异者。初二句当相以辩通。非一异正是非一。三一句正明不异。四一句别明不一。五亦无差别句。即事事无碍。第六了知总出所以

疏。若约漏无漏等者。对上事理此二皆通事理。上初二句即是非一。今约漏等。初二句义却成非异以相即故。三约同体。四不坏事。五事事无碍

疏。非如八地心欲放舍者。八地菩萨证无生忍。便欲放舍利众生事。诸佛劝起令忆本愿利益众生。是不忘本心。不舍愿炷等。即菩提心灯

疏。二堕悭贪失者。法华第一云。自证无上道大乘平等法。若以小乘化乃至于一人我则堕悭贪。此是为不可。第六竟

大方广佛华严经随疏演义钞卷第四十三大方广佛华严经随疏演义钞卷第四十四

        唐清凉山大华严寺沙门澄观述

第七无著行

疏。体即方便者出体。下皆释名。于中有二。先依唯识二方便释。后依本业释。前中唯识但列不释。无性释云。方便善巧者。谓不舍生死而求涅槃。是则说名方便善巧(此总释也)若以前六波罗蜜多所集善根。共诸有情。为欲饶益诸有情故不舍有情。当知即是不舍生死(此释总中不舍生死即唯识拔济方便)若以此善回求无上正等菩提。为证无上佛菩提故。当知即是希求涅槃(此释总中而求涅槃亦唯识回向方便)疏。本业后四下。二依本业释。于中四。一举彼经。二初即回向下。会唯识二方便。三不舍不受下。双出经论有无之因。兼正之义下文当知。四三皆善巧下。正释行名。于中二。先总。后则二不下别。于中三。一合释。前二以二同唯识故。以进趣同回向。即大智故。巧会同拔济即大悲故。此二相即故唯一心。二即一心故不着二。一心即二故不着一心

疏。有是幻有下。第二别约巧会有无释无著名

疏。有能起用下。第三约不舍不受释名也

疏。即圣天梵等后会当广明

疏。谓证法毗尼等者。又此证者亦了知义。故梵本具云苏钵唎味底多达磨毗柰耶。释曰。苏者善也。钵唎味底多了知也。而译人拣异上果果。但了知理谛证故。又约其四法但言是理。对上菩提即是涅槃。涅槃即是性净之理。证即已为圆净涅槃故

疏。先总观迷四谛故等者。然约二愚迷四谛理。即是迷胜义。愚即四重二谛中第二重二谛。今取第三重中胜义。谓即真如故。与四不同。四谛但是俗故

疏。顽嚚即是痴爱。尚书尧典注云。心不则德义曰颂。言不道忠信。曰嚚。故顽即痴嚚是爱也

疏。二菩萨行想念生故者。此有二意。一要须想念方能起行。如梦从想。故智论之中。所闻见事多藉思惟念故梦见也。二未大觉。大觉是佛。近而说之七地已前犹为梦行。八地为觉。又八地之中无明未尽亦是梦境。永断梦妄思想念。无复诸大阴界入。唯佛一人。是故如来独称大觉

疏。如梦度河即八地经

疏。七总结可知者。彼亦释疑。谓有疑云。众生既尔何故菩萨说法赴机。故此释云所说法如实际。即此言说常同实际故。今疏中将初为总。故将后实际以为总结。所以名为略加添改。余义多同但是取意有小异耳

疏。既二经小异等者。晋经即云一切法界如幻。诸佛法如电。菩萨行如梦。所闻法如响。一切世界如化。业报所起如摩[少/兔]摩。化身一切众生犹如画像。种种异形皆由心画。所说诸法皆如实际。释曰。此经亦有八喻。唯如画像以经自合。余但有牒法为喻耳。彼之电喻今改为影。彼摩[少/兔]摩喻今改为幻。故有二幻。此亦是改亦是添义。彼业报所起属摩[少/兔]摩所喻。今将合化亦是改处。又后四喻皆经自释。即是添处。经之添改总为小异。添改二字正约疏明。彼释电云。亦有彼闇照明等用。今由为影。改云亦有应质覆荫等义。彼释第四疑云。果行等可使是空。今世界事广此应为实。由经以界为间则世间通三世间故

疏。改别彼释第五疑。若世如化何有彼因果。有善恶异。释云业报生如幻生。彼疏释摩[少/兔]摩云。古德释云。摩[少/兔]摩者。重义即是重化。今更问得三藏法师。摩[少/兔]摩者。此云意生。亦云意成。即是意生身也。彼身更起化故。释曰。此三藏释亦有重化意耳。但取文别。彼释第六牒疑则同今之疏文。释云如画像随心壁有高下故

疏。其中施设下。随难别释。而经云种种生者

疏。以易故不广释之。今当重释。即四生等。又缘起经说三种生。经中有一苾刍问言。世尊。如是四种生身之相。由生老死有何差别。释曰。四种生身之相者。谓名色六入触受也。经云。世尊告曰。此四种生身之相。若次第生。若属彼生。若如是生。世尊。云何次第生身之相。世尊告曰。于其最初有下种生(一)从此无间有渐增生(二)从此无间有出胎生(三)从此无间有渐长生(四)既成长已受用言说。能得生即受用生(五)如是品类名次第生。次明属彼生。经云。世尊。此属谁生。世尊告曰。蕴界处生都无有我。所以者何。以诸蕴等渐增长故。其性无常。即无常法有此生相。三明如是生。经云。世尊。云何而生。世尊告曰。由命根力有暂时住分限法故。其性无常。即无常法如是而生。涅槃十二说五种生与上大同。南经十一经云。生者出相。所谓五种。一者初生。二者至终。三者增长。四者出胎。五者种类。彼疏释云。初言生者出相总显生义。下别显中。一初生者识支。是其一报之始故名为初。报起名出。二至终者。名色望前所依说以为终。三增长者。即前名色增为六入。此三胎中。四出胎可知。五种类者出胎已后。乃至老死一报之中。运运新起皆名为生。释曰。然此五生即前次第生。以彼第三为此第四。初生即下种至终即渐增。增长即前渐长出胎名同。种类即前受用。涅槃增长意是胎内。缘起经中在于胎外。小有异耳。经云。种种没者或延或促三性等殊。亦即九种命终。缘起经中说六种死。经云。即于此四生身相中复有六种死差别相。一者究竟死。二者不究竟死。三者自相死。四者不究竟死。分差别相。五者究竟死分差别相。六者时非时死。彼释曰。究竟死者。谓业尽死。不究竟死者。翻上应知。自相死者。谓识离身诸根灭没。不究竟死分差别相者。谓业不尽中随缘多种。究竟死分差别相者。谓业尽处中随缘多种。时非时死者。谓八万岁至十岁。或依时命终。或不依时命终。涅槃十二云。死者舍所受身。舍所受身亦有二种。一命尽死。二外缘死。命尽死者。亦有三种。一者命尽非是福尽。谓正报虽亡依报犹在故。二者福尽非是命尽。谓依报灭坏正报犹在。三者福命俱尽。谓依正俱亡。二外缘死亦有三种。一者非分自害。二者横为他害。三者俱害。又有三种。一者放逸死。谓有谤大乘方等般若波罗蜜。二者破戒死。谓有毁犯去来现在佛所制戒。三者坏命根死。谓舍五阴身。今此菩萨悉并委知。第八难得行

疏。各摄上求下化等者。以唯识中有二愿。一求菩提愿。二利乐他愿。释相可知。初即上求。次即下化。故本业有三愿。一自行愿即是上求。二神通愿。今经略无。三外化愿。后二皆是下化愿也。故举上求下化即摄唯识二愿本业三愿。以本业第二外化摄故

疏。由得最胜解受难得名等者。此有三释。初以后成前。即后因前果。二亦可由有难得下。以前成后。即前体后用。三又亦以后一下。通相释成亦具前二意。但前别配后遍通耳。故疏结从前义云别配分明

疏。合上中流亦言生死者。疏文有三。一依文正释。意以中流亦合上生死故。二非生死涅槃之中下。结弹异释。三会取异释。二中先总非。以自古今皆谓二法中间故。有问云中流不唯属于此岸。何以偏名生死中流。二然晋经失旨不应广引者。即别破刊定。刊定先举向问后引古释。以晋译失意古释岂是。晋经云。譬如河水不至此岸不住彼岸不断中流。故古释非一。苑公今并引之。故今总非恐后误解须知昔非。今抄为引一。苑公云。前不趣二处是离有。后不住中流是离无。谓生死无处名断中流。不住无故云不住中流也。二贤首云。如东流水不住南岸不住北岸。亦得说言不断北岸。中流以中无别体约岸分故。若尔南岸亦得。何以不言涅槃中流。由所度生在此岸故。所以偏就生死而说。而刊定具引竟云。今助释有二。初会文。后释义。初中新旧经本说喻不同。谓旧经约河水不趣两岸不断中流为喻。喻菩萨以离有无悲智度众生也。新经约船师不住两岸为喻。喻菩萨以无住悲智度众生也。问若尔梵本岂有异耶。答梵本是一。由译者异。谓此梵文虽云河水意属船师。即是于能依声处作所依声说。是译者若善文义则会意译之为船师。若但知文则按文译之为河水。二释义者。即准此文。有二种中流。一者生死中流。谓两岸中间处自别故。此则存二之中名生死中流。如是见者。不绝生死故。二者涅槃中流。谓离此彼岸即为中流更无别处。此则泯二之中名涅槃中流。如是知者。必证涅槃故。今此喻中喻菩萨大智故不住生死大悲故不住涅槃。悲智唯是一心不住生死时即不住涅槃。以无住故。故但云尔。释曰。上刊定意前会梵本双出二经之意。及其问答结成晋经失旨。以从今经义则善矣。及后释义还同古人。以生死涅槃皆有中流。而以存二岸为生死中流。亡二岸为涅槃中流。由不住故不存二岸。是则住于涅槃中流。则不顺不住中流之义。故疏并非诸释云云文旨显然

疏。有以烦恼为中流下。重叙异释。为其义收略有三义。初一生公释维摩意。约其漂溺从因说者。疏为会取。是生死因故与涅槃意同。二云有以贤圣为中流者。即什公释净名意。约受下会释。三有以中道为中流者。肇公意也。约观下会释并不应住。总收诸义意在不住。若住烦恼不证涅槃。岂能度生。住圣涅槃则无增进。亦不能究竟度生。住中道则不契理。安能成佛度生。上三皆属生死故

疏。正释理无不该。亦由了其非有故不舍者。即大智不舍生死也

疏。已化未化俱有舍着二义者。着已化者言属我故。未化未属故不着也。有着未化者是所应化故。已化竟者故不着之

疏。此文昭著而末学之徒下。结弹法相师。已如玄中而云。但谓者。然彼宗中亦有此义但非究竟耳。以生界有二义。一性义即众生是法界义。二者是性分义。谓众生相。若依究竟相即同性。亦理平等。彼但取分义。众生成佛义则有减。但不尽成故言无减。即少分之义。非究竟理故可悲之

疏。然初自行下。疏文有二。先总彰大意。后文有五对十句下释文。今初。意云菩萨慈悲重重显悲智无碍收上四段。四段别说。一自行。二化他。三双行。四双拂。今明自行即有自他双行。双行既俱义。必不着即是双拂。从增科之显菩萨悲深耳。今初自行能转生死即自行之实。不舍大愿即利他之权。虽前科为四而今疏文乃有六节。一即第一自行。二而谓多明下。起第二利他。三而多似起用大悲者。亦是第二利他中征释之文。四然其复似悲智二心行有前后。即生第三双行。五而犹虑物二事不融下。生第四段上之四段皆初。一句蹑前起后。六岂唯十行下结叹。叹二菩萨一十行难得行。用心之深即所说行。二即功德林能说之人。重重曲巧说斯悲智

疏。且如究竟下。释初一对以为体式。疏文有三。一权实交彻释。二又但言下。拂迹入玄释。唯萧然无寄理自玄会。即肇公百论序前已用竟。三然双非下。又融拂双非。双非即第四段。双照即第三段。融拂二段成玄之又玄。又即此第四段中初权实交彻。释即是双照。后拂迹入玄。释即是双非。双非此二方入玄矣。又既融第三则已具前二故。四门一致方显深玄。故下结云总前诸段理极于斯。下诸句中皆仿于此者。例下诸句诸句多唯明初权实交彻一义。故例令如初句知

疏。若弃恶从善魔业摄持故者。即五十八经说十种魔业。中云舍恶性人远懈怠者。轻慢乱意讥嫌恶慧是为魔业。又云已得解脱已安隐者。常乐亲近而供养之。未得解脱未安隐者。不肯亲近亦不教化是为魔业。即弃恶从善也。第九善法行

疏。今初。唯识二力论但列名。梁论云。思择力者。正思诸法过失及功德。此思择力若得增胜。自地惑所不能动。体性坚强故名为力。修习力者。心缘此法住于观行。令心与法和合成一。犹如水乳。亦如熏衣

疏。四辩即池之四口者。此中四河四口等皆依十定品。一东恒伽河。从银色象口流出银沙。合以义辩才说一切义。二私陀河。从金刚色师子口流出金刚沙。合以法辩才说金刚句。三信度河。从金色牛口流出金沙。合以词辩说随顺世间缘起。四缚刍河。从琉璃色马口流出琉璃沙。合菩萨摩诃萨亦复如是。以无尽辩雨无尽百千亿那由他不可说法等。下别合云云何菩萨四河。一愿智河。二波罗蜜河。三三昧河。四大悲河。并如彼文

疏。或各配属下。上即通释故。或一因成四河等。今此别配言同体悲加故。即以他佛外加为大悲河因。二见心性故。即第二自藏离碍故。自藏即如来藏性。此即心性能观心性名为上定故。为三昧河因。三诸度圆故即第三所照法圆故。为波罗蜜河因。四二智圆满故。即第四能照智具故。为愿智河因。一切智是根本智。重言智者即后得智。后得智摄愿故

疏。三旋绕中下。疏文有二。先彰大意。初成就等即十定。经文从随顺即是下疏释旋绕之相。二文中下释文中三。一总科。二为五对释。三总相收摄。二中先列五对。后今初明理无不证下。别释细寻可知

疏。勒此十身下。第三总相收摄。于中五。初收五不出体用。二体外无用下。融体用为法界。于中言用即智应者。兼融三身以为一体。三随相显十者。出十身之由。四一乘圆融下。通妨难以有难云。地前未证。何得尔耶。故为此答。五更有余义者。指广有本。即是彼十。一即威势身菩萨众中威光赫奕灭诸闇故。二即意生身遍趣生故。三即菩提身正觉无生故。四即福德身福绝三际不可说故。五即智身智契实理故。六即化身随应现故。七即力持身力持不变故。八即法身法界性故。九即相好庄严身。十莲华藏相同于一相周法界故。十即愿身愿转法故。观法无相现相无所不周故。经云毗卢遮那佛愿力周法界一切国土中。恒转无上轮。斯即十地中义。会于离世间十佛同前十地。已会十身然彼约佛身。今约菩萨所得则望彼皆因。以因望果故小有不同。而圆融交彻故得例彼。若不例彼当文自释义亦无遗。又显十身五体五用。谓威势福德智法相好此五皆体。余五为用。体即是真。用即是应。同真应二身融为一味可知。第十真实行

疏。初征名如本分释者。即言行不虚故名真实。又称二谛故。故璎珞经云。二谛非如。非相非非相故名为真实。次经即云诚谛之语等即释名也

疏。体即下出体

疏。今更略释。于中有三。初依唯识二智而论但列其名。无性释云。由施等六成立此智。复由此智成立六种。谓相教等种种品类。是则名为受用法乐。由此妙智能正了知此施此戒此忍进等。如所闻法饶益一切有情之类。是则名为饶益有情智

疏。本业有三下。二约本业便会上二智

疏。下文云下。三依下经会上经论。先会唯识论。后知十方智下。会前本业

疏。诚实审谛即真实义者。次下疏文引下经释。有用金刚四语释。云真语为显世谛故。实语为显世谛修行有烦恼无烦恼。及清净相故。于中实者。此行烦恼此行清净。故如语者。为显第一义相故。不异语者。显第一义修行。有烦恼及清净故

疏。二约现修自他二行者。即由实语故所作皆成。如涅槃第三十一说。昔与调达二人入海采宝。船破之后二人不死。调达悲泣我有二珠。分一与之。又贪一珠遂刺我目我时呻吟。有一女人问我。我即具答。女人问言。汝名何等。我即答言。我名实语。彼云。谁信我。即答言。我于提婆达多无恶心者。令我两目平复如故。言讫如故。忍辱仙人亦同此例。同在此卷。又如说能行亦是如语如行。能说即不异语也

疏。穷法实相谓如是相性体力等者。即法华经云。唯佛与佛乃能究尽诸法实相。所谓诸法。如是相。如是性。如是体。如是力。如是作。如是因。如是缘。如是果。如是报。如是本末究竟等。此之十句天台历十法界一一界中复具十界互相摄故。十界便成百界。界各十如即有千如。更分一一界各有三界。一众生世间。二五阴世间。三器世间。便成三千世间。彼宗以此为实法华经枢要最玄。后明知见但举能知耳。思大师三种读此十如。一以如是为头。云如是相为一句。如是性为二句等。即约假观观十别相故。二云。所谓诸法如为一句。是相如为二句等。以如字为空。即成空观。三以如是字为末。云所谓诸法如是为一句。相如是为二句等。以如是为中道观。一家之意理无不通。第七重颂分偈中。第六行二偈中初偈颂前正辩三谛。次偈初半颂依智起悲。后半颂行成益物。然皆有无对辩具三谛义。古将初半为加行。次半根本。后偈后得。然取摄论之文。论依六度似不会教。若兼正明义理。则可通前文。既依本业今颂不可录旧

疏。第七四偈颂。无著行。初偈即二方便中回向善巧。三方便中进趣向果。已得灌顶是向果故。次二偈即拔济善巧。次半偈即巧会有无。谓善入文字。是会有也。不分别者是会无也。后半一切法不舍不受。若配经文。初偈颂净菩萨道受菩萨记而无所著。次偈颂悲念众生。后二偈颂前于一切世间成熟众生。前约所化种种音等。此约能化一音随类。前令所化不着。此即能化不着

疏。第八安住下。八颂中言颂最胜等十句者。于中初句颂广大解。次二句颂决定解。第二偈除护念一句。颂余七句。后之二偈颂佛护念。以明见故得护念也。二无量下。三偈颂自行。中初偈即能转多劫生死。后二即见者不空。初偈辩不空之果。后偈辩不空之因。由见佛无厌故

疏。我为。最胜等二偈。即最胜义。谓善入平等。及达法界不取着故

疏。同佛善根者。初偈颂最上。同一佛性是调御故。次偈颂离翳。次三偈颂已办及善变化。后偈颂为依怙与佛化他故

疏。颂得佛十力等如文思之者。一偈颂得佛十力。次一超颂转法轮。次二颂无碍解脱。次一偈半颂智慧解脱。后半偈却颂雄猛无畏。次一偈颂了知世间境界。智海法海即智正觉世间。次或现已下四偈。绝生死回流。初二偈八相明绝生死。故方能现生。次一偈非生死身方能现身。次一偈颂入智慧大海。乐观不移是入义故。次于诸下三偈。颂护持正法。初偈神力加持。后二六通护持。其无碍意即他心通神通具足兼宿命漏尽。次其心正定下四偈颂到实相源底。余并可知

    十无尽藏品第二十二

初来意有三。初正明。次准问下释上问。前却妨二义通之。三然明法下。会差别有二义释。初以位拣。后以前后拣。明法即胜进所成者。是胜进家果故。故经云。菩萨满足如是愿时。即得十种无尽藏。所谓普见诸佛无尽藏。二总持不忘无尽藏。三决了诸法。四大悲救护。五种种三昧。六满众生心广大福德。七演一切法甚深智慧。八报得神通。九住无量劫。十入无边世界无尽藏。后是一位之果者。以是第五回向之果故。经云。菩萨住此回向得十种无尽藏。所谓见佛无尽藏。于一毛孔见阿僧祇诸佛出兴于世故等。其中名有同者亦复优劣有异

疏。各有业用者。如信以能除不信浊为业。戒以遮防破戒蔽为业。惭以对治无惭止息恶行为业。愧以对治无愧止息恶行为业。闻以能破无知为业。施以止悭为业。慧以破痴为业。念以治忘念为业。持以治忘失为业。辩以治于謇讷为业

疏。然念慧及戒下。上正释名。此下得名。得名有二。一约随相。二若就下约融通

疏。然约随相前九自利者。二利分别

疏。信为行。下明次第并可知

疏。初三三空信所执无相等者。意以前九别约三性后一总融。前中即依三性信无三性。此初信所执即遍计所执性。云无相者。即相无自性性。二依他无生。无生即生无自性性。三圆成无性。无性即胜义无自性性

疏。后一总信三性无生下。一句总融前九。文中有三。一指前即第二经。清净功德眼自在天王。得知一切法不生不灭。不来不去。无功用行。解脱门广如前说。二言十皆无生者。一即空是无生义。二无相是无生义。三无愿是无生义。四无作是无生义等。三言并通三性者。此有二义。一空等通三。谓遍计空依他空圆成空等。乃至三性难超越。二者无相无生无性亦通三性。下疏依后义作一重云。如一无生若作无相。应云但信依他无遍计之相。则是圆成之相。若信依他无自然之性。则悟圆成之性。是故结云余例可知

疏。若克文取义者。上但当文通释。今对前别释可思

疏。二彼诸下释第二意。文有四义。一谓已得未得下约真如本无增减等。亦即就前广无边涯之经。离二边之偏邪。二寂照下。菩萨寂照契如绝戏论故。三但以世俗下。暗引净名证成。四菩萨既坚信下。结成不怯

疏。五有正慧故下。释常有根本。于中三。初按文略释。次静法云下。引昔解。后此或应尔下。会通言或应尔。且许昔解。后今以理下。引例会通第二戒藏

疏。谓鸡狗等者。涅槃二十四云。菩萨摩诃萨受持禁戒。不为生天不为恐怖。乃至不受狗戒鸡戒牛戒雉戒。乃至是名菩萨修大涅槃是第三戒。又十住毗婆沙论第三明秽土中。多诸外道有持牛戒者。鹿戒者。狗戒者。乌戒者。象戒者。释曰。此皆外道所持恶禁戒。通由二因生此妄计。一由天眼见有众生。从鸡狗等即生天上故。二由非理寻思妄生此计。婆沙一百一十四。有二外道。一名布剌拏憍雉迦。受持牛戒。二名頞剃剌罗栖尔迦。受持狗戒。二人异时往诣佛所。种种爱语相慰问已。时布剌拏先为他问。此栖尔迦受持狗戒。修道已满当生何处。世尊告曰。汝止莫问复再三请。佛以慈心告言谛听。受持狗戒若无缺犯当生狗中。若有缺犯当堕地狱。闻佛语已悲泣哽咽不能自胜。世尊告曰。吾先告言。止不须问今果怀恨。时布剌拏白言。世尊不以此人当生狗趣故我悲泣。然我长夜受持牛戒。或恐将来亦当尔耶。唯愿大慈为我宣说。世尊告曰。准前狗戒。此等皆由不了真道。婆沙又问云。云何受持猪戒牛戒狗戒名无缺犯。答一如牛法。一如狗法。名无缺犯

疏。非如难陀。难陀之缘甚长而人多闻正明。其性多欲染着孙陀罗。佛方便诱引之至于天上。见诸天女端正姝丽过其本妻。见诸天男皆有天女。独于一处见有天女迥异姝丽而无天男。问佛佛令自问。彼女答言。我有夫主即佛弟难陀。难陀答言。我身即是。女言。难陀为僧身披袈裟。闻已便求剃落持戒。本为贪着天女而持禁戒故。阿难讥之。如羝羊相触将前而更却后。汝为欲持戒其事亦如是。身虽能持戒心为欲所牵。斯业不清净。何用是戒为。意云。如羊本拟向前。如汝欲生天上受欲。而更却后。如汝持戒故业不清净(云云)疏涅槃云何故持戒等者。即第二十七师子吼言。何因缘故受持禁戒。佛言为心不悔。何故不悔为受乐故。何故受乐为远离故。何故远离为安隐故。何故安隐为禅定故。何故禅定为实知见故。何故为实知见。为见生死过患故。何故为见生死过患。为心不贪着故何故为心不贪着。为得解脱故。何故为得解脱。为得无上大涅槃故。何故为得无上大涅槃。为得常乐我净故。何故为得常乐我净。为得不生不灭故。何故为得不生不灭。为见佛性故。是故菩萨性自能持究竟净戒。疏家但至涅槃已为究竟故略后三。后三即涅槃中事故

疏。五不同调达者。佛说四依为除比丘四恶欲故。调达加一为五。谓加不食酥盐鱼肉。复皆尽形寿说。虽有同本意不善故。四分律第四卷云。调达以五邪法诱诸比丘。尽形寿乞食为一。尽形寿着粪扫衣为二。尽形寿露地坐为三。尽形寿不食酥盐为四。尽形寿不食鱼及肉为五

疏。不违涅槃者。非涅槃经以无相持顺寂灭故

疏。一非为欲恼众生。先须持戒者。如欲禁龙。曾闻罗汉持戒而能遣龙。遂即持戒是也

疏。如马祀等者。即百论中外道计。杀马祀天得生梵天。即逼恼于马。谓为戒等

疏。定有定无者。今律学者多计为有。禅学之者说戒如空。定有着常。定无著断。此为邪见。杂于正戒

疏。观缘性离者。观缘之相不坏坚持。缘戒性空故不起迷倒

疏。又如十住婆沙论说。一矫异者。谓有贪利养故行十二头陀。作如是念。他作是行当得敬养。我作是行亦或得之。为利养故改易威仪。二自亲者。为有贪利养故。至檀越家而语之言。汝等如我父母兄弟姊妹亲戚无有异也。若有所须我能相与。若有所作我能作之。不计远近来相问讯。我住此者正相为耳。为求利养贪着檀越。能以巧辩牵引人心。三激动者。谓有不计贪罪欲得财物。现于贪相语檀越言。此衣钵尼师坛好若我得之则能受用。若人能随意施者此人难得。又有谓檀越言。汝家羹饭饼肉香美衣服又好。若常供养我我以亲眷必当相与。四抑扬者。谓贪利养故语檀越言。汝极悭惜尚不能与父母兄弟姊妹妻子亲戚。更有谁能得汝物者。檀越愧耻俯仰施与。又至余家语彼人言。汝有福德受人身不空。阿罗汉等常入汝家与汝坐起语言。欲令檀越必谓我是罗汉。五者因利求利者。谓有以衣钵及僧伽梨尼师坛等资生之物持示人言。此是国王及施主等。并余贵人将来与我。令其檀越心中生念。王及贵人尚供养彼况我不与。因以此利更求余利故以名也。第三惭藏

疏。今初然惭愧相别者。此释标章。而双释惭愧。两章之通别言涅槃云惭者羞天等者。即南经第十七。耆婆为阿阇世王说也。经云。大王诸佛世尊常说是言。有二白法能救众生。一惭二愧。惭者。自不作罪。愧者不教他作。惭者内自羞耻。愧者发露向人。惭者羞天。愧者羞人。是名惭愧。无惭愧者不名为人。名为畜生。其成唯识即当第六论云。云何为惭。依自法力崇重贤善为性。对治无惭止息恶行为业。谓依自法为尊贵增上。崇重贤善羞耻过恶。对治无惭息诸恶行。释曰。言自法者。谓于自身生尊重增上。于法生贵重增上。二种力故崇贤重善此是惭相。论云。云何为愧。依世间力轻拒暴恶为性。对治无愧止息恶行为业。谓依世间诃厌增上。轻拒暴恶羞耻过罪。对治无愧息诸恶业。释曰。谓依世间他人讥毁。及自羞恶法而不作等。名依世间诃厌增上。有恶者名暴。染法体名恶。于彼二法轻有恶者而不亲。拒恶法弃而不住。由此增上对治无愧息诸恶业。论又云。羞耻过恶是二通相故。诸圣教假说为体。释曰。此会显扬。显扬说羞耻为二相者是通相耳。从通假说为体。实是崇拒等是别相故。下疏云是二通相。疏俱舍亦同者。即彼第二疏根品之中。偈云无惭愧不重。于罪不见怖。释曰。不重贤善名为无惭。谓于诸功德及有德人。无敬无崇无所忌难无所随属说名无惭。即是恭敬所离。对法云。功德者。戒定慧。有德人者。有戒定慧人也。无忌难者。无畏惧也。不随属者。不作弟子礼也。于罪不见怖。释无愧也。为诸善者所诃厌法说名为罪。于此罪中不见能招可怖畏果说名无愧。翻上即是惭愧之相。谓重贤善等故同唯识

疏。若说羞耻下。释二通相先依唯识已如上引。后依今经以一文中皆有不相恭敬故

疏。自惟即是内自羞耻者。正同涅槃。兼得唯识依自法力。第四愧藏

疏。不觉苦集故无知见者。不知苦果不见集过

疏。依顾世间即顺唯识意

疏。从淫欲生即种子不净者。疏中先说五种不净。一种子不净。二住处不净。三自性不净。四自相不净。五究竟不净。即智论二十一说。梵行品已广其相。但自性不净即三十六物。今当更说。即涅槃十二圣行品云。从头至足其中唯有发(一)毛(二)爪(三)齿(四)不净(五)垢秽(六)皮(七)肉(八)筋(九)骨(十)脾(十一)肾(十二)心(十三)肺(十四)肝(十五)胆(十六)肠(十七)胃(十八)生藏(十九)熟藏(二十)大便(二十一)小便(二十二)涕(二十三)唾(二十四)目泪(二十五)脂(二十六)膏(二十七)脑(二十八)膜(二十九)骨(三十)髓(三十一)脓(三十二)血(三十三)脑(三十四)膀胱(三十五)诸脉(三十六)菩萨如是专念时。释曰。远公不分其中骨有二。脑有二。脑连膜。除二缺二。肠有大小。亦缺其一。余处有胞具三十六。直就经文今具者。复有分垢为一汗为一。则秽字属汗亦具三十六

疏。又垢秽形是内污秽不净者。然有二种。一内二外。论云。云何依内污秽不净。谓身中发毛爪齿尘垢皮肉骸骨筋脉心胆肝肺大肠小肠生藏熟藏肚胃脾肾脓血热痔肪膏肌髓脑膜涕唾泪汗屎尿。如是等类名为依内。释曰。此亦三十六物也。论外谓青瘀或复脓烂。或复变坏或复[月*逄]胀。或复食啖或复变赤。或复散坏或骨或锁。或尿所作或唾所作。或涕所作或血所涂。或脓所涂或便秽处如是等类名为依外污秽不净。二苦触不净。论云。谓顺苦受触为缘所生。若身若心。若不平等受。受所摄如是名为苦触不净。三下劣不净者论云。谓最下劣事。最下劣界。所谓欲界除此更无极下劣最极鄙秽余界可知。如是名为下劣不净四观待不净者论云。谓如有一劣清净事。观待其余胜清净事便似不净。如待无色胜清净事。色界诸法便似不净。观待萨迦耶寂灭涅槃乃至有顶。皆似不净。如是等类名为观待不净。五烦恼不净。论云。谓三界所有一切结缚随眠烦恼缠。六违坏不净。谓五取蕴无常故。恒不可保信是变坏法。是故静虑无色皆名不净。释曰。今疏随胜已略配竟。但观所引论文自然明了。第五闻藏

疏。闻为本故实则多知者。故大品第六云。须菩提白佛言。何等一切法中无碍相应学应知。释曰。即多知之义下。佛答中与此列大同。佛言一切法者。善法不善法。无记法。世间法出世间法。有漏法无漏法。有为法无为法。共法不共法。释曰。此十法但共不共。此中略无以一向是不共般若故。彼经云云何为共法。四禅四无色。四无量心。四无色定。如是等法是名共法。智论释云。凡夫圣人生处入定处共故名为共法。经云。何等名不共法。四念处乃至十八不共法。是名不共法。论释云。菩萨分别知此诸法各各无相。是法从因缘和合生故无性。无性故自性空。释曰。此即圣人法不共凡夫。如十八不共等亦不共二乘也。余大同此

疏。依生引二门开为四重征释者。然第六地广显其相。今文略引。然此一段疏文有三。一总显生引。二然依杂集下。以三缘生会释经文之意。三正释经文。二中二。先正说三缘生。后会释今文。今初。然杂集论云。云何缘生。几是缘生。何义观缘生耶。问也。谓相故分别支故。释曰。彼有十五义。今略用一二耳。论名相者。谓无作缘生故。无常缘生故。势用缘生故。是缘生相由此三故薄伽梵说。此有故彼有。此生故彼生。为无明缘行乃至广说列也。此有故彼有者。显无明缘生义。等具如疏文。即是释也。然功能差别下。更云如从无明力故诸行得生。乃至生力故得有老死

疏。然今经中下。第二会释经文也。于中有五。一正明二门。然此有彼有等。亦兼势用正显二相故。指势用在于六地。二然二门下。出其影略。言前后互举者。谓能所引中明无作缘生。能所生中明无常缘生。三前七许同因位下。出生引所以。言许同者。据三世义。初二次五过现不同。约二世义许得同世。但引五种故不名生。四由此能所引中下。出此经中影略之由。以前于能所引中无作义显。而影取无常。能所生中无常义显影取无作。五故集论下。引证生引之相

疏。然文有染净下。第三释文。文中三初句标也。有染净观者。六地广明。谓无明缘行等。前能生后生死流转为染。无明灭行灭等。反本还源为清净耳

疏。初能引中下。二别释即为四番。初番可知

疏。第二约所引下。约所引染净。例前亦合云识有故名色有。前文亦合有无明无故行无

疏。以识通能引下释。上亦通能所引义。正义正取识名色为所引义。今释上言通能所引。若识支通能引。名色唯所引。故识与名色是能所引对。于中先反释经文。约染观明。然识通能所引者。若取识种为识支即是所引。若取行种为识支识是能引行是能引故。今举二业初业是能引。以取行习气为识支故。实是行种与识俱故名为识支。即集论意。正取业种以为识支。识种乃是名色支摄而缘起。经通能所引业种识种俱名识故。识种但是名色所依非名色故。今第二意即是识为能引。云与名色作缘。从谓由识入母胎下。兼显现行二果。然今下。经义通能所故。六地云。于诸行中植心种子即具二也。其二种业言即六地自业助成章中。然彼二业云识有二种业。一令诸有相续。二与名色作生起因。今取其势以能所引而为二业。约持行种即是能引。约其自体即是所引

疏。今言识无者。上反释经。今顺释也。反上二义可知

疏。第三下。能生所生相对。上爱取有是能生。生老死为所生故。第四可知

疏。后之三门下。料拣然第二门识与名色。识虽有能引之义正取所引。故三皆能所相对。先问后答。答意可知

疏。又为显能引支下。重显前二相次为一所以。识支是所引则能引唯二。识是能引则能引有三。若识取所引则上四番而为三类。初一唯就能引明第二唯就所引说。三四通能所相对故。显十二一一相望皆得此有彼有此生彼生等。不必要能引所引能生所生相对。以明方有此有彼有等故。疏云说者之妙

疏。第二有漏五蕴下。文五。一释总名。已见光明觉。杂集藏果等者。即第二论。其藏果义与蕴义大同。重担与阴覆义大同。然彼论云。蕴义云何。答诸所有色。乃至若近若远彼一切略说。色蕴积聚义故如财货蕴。如是乃至识蕴。释曰。此即藏果义蕴藏色等果法耳。言重担者。论云。荷杂染担故名为蕴。如肩荷担。荷杂染担者。谓烦恼等诸杂染法皆依色等故。譬如世间身之一分能荷于担。即此一分名肩名蕴。色等亦尔能荷杂染故名之为蕴

疏。而标名下。二释世间。世有三义。隐覆名世通为无为。如世界成就品下。二唯有为世间。世即是间。持业释也

疏。然色等下。三料拣。言通无漏者。诸佛五蕴。况因灭无常色获常色等兼通无为。今但取有漏有为蕴。不摄无为义不相应故。留于无漏在后段说

疏。云何知下。四释知相。即大品意。前文已引初知相中。言色以变碍为相者。俱舍第一中。色有二义。一变坏义。论问云。始自眼根终乎无表。世尊何故说为色耶。答可变坏。故名为色蕴。释曰。变者显刹那无常。坏者显众同分无常。论问云。谁能变坏。谓手触等(云云)故即便变坏广说乃至蚊虻等触。此变坏者。即是可破坏义。二变碍义。论云。有说。变碍故名为色。释曰。变谓变坏。碍谓质碍。若尔极微应不名色无变碍故。此难不然。无一极微各处而住。众微聚集变碍义成。余广如彼。杂集亦二义。一问云。色蕴何相。答变现相是色相。此有二种。一触对变坏。二方所示现。触对变坏者。谓由手足乃至蚊虻他所触对时即便变坏。方所示现者。谓由方所随何相示现。如此色如是如是色等

疏。受以领纳者。杂集问云。受蕴何相。答领纳相是受。故领种种净不净业所得异熟。又唯识云。受谓领纳顺违俱非境相为性。疏想者取像者。即唯识文。下云施设种种名言为业。谓要安立境分齐相。方能随起种种名言。杂集云。构了相是想相。由此想故。构了种种像类。随所见闻觉知之义起诸言说

疏。行谓迁流者。俱舍云。造作迁流二义名行。杂集云。造作相是行相。由此行故令心造作。谓于善恶无记品中驱役心故。释曰。俱舍二义今取迁流欲诃毁故

疏。识以了别者。俱舍云。识谓各了别。论云。了别名识。此有六种了别不同。故名为识。杂集云。了别相是识相。由此识故。了别色声香味触法等种种境界

疏。况知一切法趣色者。即于第三义中傍况此义。亦大品经云。一切法趣色。色尚不可得。云何当有趣及非趣。天台为三观释云。初句假。次句空。后句中。然经文但显性空。今疏引意却取一切法趣色。明事事无碍。一中有无量义故。是名善巧多闻

疏。然诸蕴性下。第五解妨。此即以通为别。妨释有二义。初一可知。又摄法多者。第二释也。因此略明五蕴摄法多少。且依大乘百法。识蕴唯摄八识心王。色蕴唯摄十一种色。想受二蕴但摄心所遍行中二数。四蕴但摄二十一法。除六无为。蕴所不摄。余七十三。皆行蕴摄故云多也。百法已见第一疏抄

疏。第三无漏中有四。初释总名。二然无漏蕴下。显类别。三欲显戒下。释立总名所以。言理实亦有世间戒等。上五蕴亦有出世间。然世间戒等自有二戒。一者外道共有十善等戒。四禅等定。世智之慧脱下地惑。于中知见。二者正教之中。亦说十善五戒四禅八定。无见慢修欣厌之慧。脱下界缚了见分明。而是有漏故名世间故

大方广佛华严经随疏演义钞卷第四十四大方广佛华严经随疏演义钞卷第四十五

        唐清凉山大华严寺沙门澄观述

疏。戒定慧下。四随文正释。于中有七。一指例略释。二智论下。引论总释。三然即转前下。立五所由。四释通妨难。五者出体。六会释总名。七会通权实。前二可知。三中二。先正释。即智论及仁王意

疏。故仁王下。引证如次配之居然可了。然新经即菩萨行品。经云。复次道种性菩萨。修十回向起十忍心。谓观五蕴色受想行识。得戒忍定忍慧忍解脱忍解脱知见忍。观三界因果得空忍无相忍无愿忍。观二谛假实诸法无常。得无常忍。观一切法空。得无生忍。今即前五文是旧经故次与此不同

疏。知见与慧下。第四释妨难即相滥难也。先难后答。言佛地三说者。今即第一释。二云一切皆是无碍缘解脱慧。名解脱知见。缘解脱慧者。缘灭谛智也。缘余慧者。缘余三谛等智也。三云一切通学无学。学位分得。无学圆满。诸佛菩萨皆有五故

疏。此五别说下。第五出体。以解脱知见及慧约所照异故。同是慧。慧即与想相应。解脱知见即与识相应慧耳

疏。然此五分法身下。第六会释总名。出世所以引杂集证即上第一论也

疏。问无取五蕴下。第七会通权实。引纯陀如玄中。然杂集第三亦云。无取五蕴当言有为当言无为。答彼不应言有为无为何以故。诸业烦恼无故。不应言有为。随欲现前故。不应言无为。所以者何。无取诸蕴随所乐欲而现其前。无为不尔以常住故。释曰。此乃假说双非以约体用互夺。亦不定言为无为也。又言取五蕴。则显凡夫是有取五蕴。杂集云。取蕴者。与取和合者故。取者。蕴中诸烦恼也。纯陀故实已见玄谈

疏。第四有为先释总名。引二论。瑜伽系属因缘者。正理论第一云。有为者。众缘聚集共所生故。未来未起何为有为。是彼类故亦名有为。如所烧薪于未烧位。是彼类故亦名为薪。或据曾当立名无失。如琴瑟等名为有声。亦如乳房莲华池等。诸未生法不越彼类故名有为。其有生灭此语犹略。杂集论云。若法有生灭住异可名有为。一切法皆有为唯除法界法法处一分。为舍执着无常我故。释曰。此中论答三问。一答云何为有为。二一切法下。答几是有为。三为舍下。答为何义故观有为

疏。今略举四事者。理实智论大品等广有多法。大品云何等有为法。若法生住灭(此释有为义)欲界色界无色界五蕴。乃至意识因缘所生受。四念处乃至十八不共法。为一切智是有为法。智论释云。有为法略说三相。一所谓生住灭。二三界系义。三四念处乃至十八不共法。虽有无为法。以有作故是有为法。无为相是无为法。释曰。今以十八不共等属有记法故。但略出其四。众生则摄蕴处界也

疏。然所依处下。释三界义故。论云者即俱舍第八。等字等余二界。应云色所属界名为色界。无色所属界名无色界。略去所属二字但名欲界等。如言胡麻饮及金刚环。饮之与环俱是总名胡麻金刚并为别称。以别依总名胡麻饮及金刚环。具足应言胡麻所属饮等。略去所属但云金刚环等。界者。总名欲等别称。略去中言云欲界等。论云。此中欲言为说何法。答略说段食淫所引贪。注云。淫贪名贪。食贪名欲。然语犹隐。本业上卷云。佛子见着二业迷法界中一切欲心故。欲所起报分为欲界报。佛子见着二业迷法界中一切色心故。色心所起报分为色界报。佛子见着二业迷法界中一切定心故。定心所起报分为无色报。是故于一法界中有三界果报。若更令易见。欲界有男女形淫欲受身故。色界无男女形唯有色故。无色界谓无色故。前本业言见著者。彼经说有七见六着。经云。佛子无明者。名不了一切法迷法界。而起三界业果。是故我言从无明藏起十三烦恼。所谓邪见我见常见断见戒见盗见疑见七见。见一切处求故说见。复起六着心贪爱嗔痴欲慢。于法界中一切时起一切烦恼。以十三为本。无明与十三为本。无明与十三作念。是以就法界中别为三界想。即云见着二业等如前所引

疏。第五无为有六。一释总名。二开合。三释文。四拣权实。五出体性。六结示多闻之旨。今初。释总名瑜伽下。引证如次二论对前二义。杂集云。无生住灭故名无为。不堕数故。即净名阿难章云。佛身无为不堕诸数。数即有为余义但翻上有为。故疏结云诸论总名大旨无别

疏。然其下。二开合中。然小乘多说三种者。即俱舍等论云。无漏谓道谛及三种无为。谓虚空二灭。而言多分者。分别论有四。一虚空。二非择灭。三想受灭。四真如。大众部说九无为。谓三及四空。缘起支性。圣道支性。化地部亦九。三外加不动三性道支缘起

疏。大乘掌珍说四者。于小乘三上加真如故。或说有六。唯识论等广如下说。或开为八者。杂集第二云。无为法有八种。谓善法真如。不善法真如。无记法真如虚空。择灭非择灭。不动。及想受灭。如是建立八无为中。当知所依有差别故。分析真如假立三种。不由自性善法真如者。谓无我性空性无相实际胜义法界。何故真如说名无我。由彼自性无变性故。谓一切时无我实性无改转故。无改转故说无变异。当知此则是无我性离二我故。何故复说此名空性。一切杂染所不行故。所以者何。由缘此故能令一切诸杂染事悉皆空寂。有时说染。但是客尘。诸相寂静故名无相。无倒所缘故名实际。实者。谓无颠倒。此处究竟故名为际。最胜圣智所行处故说名胜义。一切三乘妙法所依故名法界。如善真如。不善无记当知亦尔。余如彼论。言渐欲下

疏。出论意

疏。此经说六下。第三释文。于中二。先总明有无。后言虚空下。别释多用唯识。有六无为即为六段。初虚空释语全是百法疏意。即唯识依法性假施设有义。彼论先释法性云。谓空无我所显真如。有无俱非心言路绝。与一切法非一非异等。是法真理故名法性。离诸障碍故名虚空。释曰。彼论明法性空但言离诸障碍。百法兼取外空。云无物所显故。俱舍云。此中空无碍

疏。二涅槃者。涅槃即同择灭。先明性净乃傍出异义耳。言涅槃三十四亦同此说者。此即刊定记释。谓同此经所说虚空及涅槃也故涅槃经释缘生。四句中云有非缘生非十二因缘者。谓虚空涅槃是也。此则同性净义。二后义为正。云性净之果即圆净涅槃。应有问言。若是果者。何殊择灭。由因果殊故分二道。所以先总明中以此义为正。云于择灭中开出涅槃二道别故。然大乘下。断上二义。则后解为正者。若唯识解非择灭云。不由择力本性净故

疏。三数缘灭故唐三藏下。出其异名。谓择力所得者。是俱舍论释。故彼喻云。如牛所驾车名曰牛车。略去中言故作是说但云择灭。唯识释云。由拣择力灭诸杂染究竟证会故名择灭

疏。然此灭有二者。别释灭字。此二义称灭。若兼能灭之智。智亦称灭

疏。四非数缘灭者故。唯识云。不由择力本性清净。及缘阙所显名非择灭。释曰。论存二义。初义异小。故上疏文取为楷定。言缘阙者。俱舍论云。毕竟碍当生别得非择灭。下释云。言当生者。当来生法缘会则生。缘阙不生。缘阙之时得非择灭。碍当生法令永不起名毕竟碍。言别得者。谓非择灭有实体性。缘阙位中起别得故。非择灭得不因择灭。但由缘阙名非择灭。论指事明云。如眼与意专一色时。余色声香味触等谢。缘彼境界五识身等住未来世毕竟不生。由彼不能缘过去境。缘不具故得非择灭。释曰。谓眼缘色时。亦合缘声等以专注色故。耳等不缘声等。同时声等刹那已谢故。令缘声等识更不复生。以前五识唯缘现量不缘过去未来。而言触等者。等取法中有与能缘同时为所缘境者。如他心智所缘境是也。此他心智唯缘现在心王。亦合缘心所。以专注心王故于心所得非择灭

疏。五缘起者。疏文有二。一双标。二别谓下别释。先释别。后释通今初。文有四节。一引小乘诸部所立。二智论三十二下。引大乘论立证成上义。此中论文先有门云。声闻法中何以不说如是法性实际。而摩诃衍中处处说耶。答声闻法中亦说此二下。与疏同玄中已引疏。涅槃亦说下。第三引大乘经立无为义。先引涅槃。即北经迦叶菩萨品第三十四经。而为品初。南经三十一北经半卷。向后列二十一诤论。此即第六经云。或说十二因缘是有为法。或有说言十二因缘是无为法。至第三十五方释经中。具云。善男子。我经中说。云何名为十二因缘。从无明生行。从行生识。从识生名色。从名色生六入。从六入生触。从触生受。从受生爱。从爱生取。从取生有。从有生生。从生则有老死忧悲苦恼。善男子。我诸弟子。闻是说已不解我意。唱言如来说十二因缘定是有为。我又一时告喻比丘作如是言。十二因缘有佛无佛性相常住。善男子。有十二因缘不从缘生。有从缘生非十二因缘。有从缘生亦十二因缘。有非缘生非十二因缘。有十二因缘非缘生者。未来世十二支也。有从缘生非十二缘者。谓阿罗汉所有五阴。有从缘生亦十二缘者。谓凡夫人所有五阴。有非缘生非十二缘者。谓虚空涅槃。善男子。我诸弟子闻是说已不解我意。唱言如来说十二因缘定是无为。释曰。若经中言为与无为俱不解意。若远公释各有所以。然有二意。今疏是第一意。第二意云。直就因缘事中现在之者名曰有为。在未来者未现起用名曰无为。释曰。后释顺经后四句意。前释顺经初意及智论等意。疏望今经下。疏家第四出今意。次言大品云下引他经证成上正义。此即中论青目所引。释初因缘不生之义。疏涅槃又云十二因缘即是佛性者。复引涅槃重成上义。即北经三十二师子吼品。经云。善男子。无明不能吸取诸行。行亦不能吸取于识也。亦得名为无明缘行。行缘识。有佛无佛法界常住。若言佛性住众生中者。善男子。常法无住。若有住处即是无常。善男子。十二因缘无定住处。若有住处十二因缘不得名常。如来法身亦无住处。法界法入法阴虚空悉无住处。佛性亦尔都无住处。次下又云佛性者名十二因缘。何以故。以因缘故如来常住。一切众生定有如是十二因缘。是故说言一切众生悉有佛性。十二因缘即是佛性。佛性即是如来。释曰。此上经意正取十二因缘之性以为佛性。故是无为。疏文中虽举十二因缘下。第二释通妨难云。若缘起无性即无为者。诸蕴界等岂有诸蕴界性也。故为此通则意无不该。是故上引涅槃云法界法入法阴虚空。即说三科皆无住处同佛性也。疏法性住者。即真如也。显此法性即唯识等真如异名耳。疏谓非妄下别释其名。初释真如自有二义。初合释唯拣于妄。二又真实如常下。即是离释。即唯识云。真谓真实显非虚妄。如谓如常表无变易。是故疏云拣妄拣事。疏于一切位下。释法性名。故唯识偈云。此诸法胜义。亦即是真如。常如其性故。即唯识实性是也。次释住字亦有二义。一连上释之则三字一名。谓上之二释顺法相宗。加此住字顺法性宗。法性谓随缘。住字为不变。以随缘不失自性故。二义既具即妄即真故。是法性宗义。二若准智论下。别释取上法字及下住字自为一义。成七无为则法字两用。疏然小乘下第四对拣权实。初举小乘。后若大乘下。举大斥小非唯数增已如前说。义亦有异次下正明小乘之义。略如上说。广如唯识广引广破。疏唯识论中二义建立下。正辨大乘无为之相。即第二论。论中先破诸小乘宗等计于无为为实有竟。显正义云。然契经说有虚空等诸无为法。略有二种。一依识变假施设有为。谓曾闻说虚空等无为。遂于识上有此相现。此所现相前后相似。无有变易假说为常。释曰。此空无为而无本质。唯心所变。犹如极微假而无体。于佛等处闻其名故而心变之。次论复云。二依法性假施设有。谓空无我所显真如。有无俱非心言路绝。与一切法非一非异等。是法真理故名法性。离诸障碍故名虚空。由拣择力灭诸杂染。究竟证会故名择灭。不由择力本性清净。或缘阙所显故名非择灭。苦乐受灭故名不动。想受不行名想受灭。释曰。疏取论意以释经文。但顺经有不顺论有。上释非择。有其二义依此论文。疏此中法性下。第五出体性。即彼论示无为体。论云。此五皆依真如假立。真如亦假施设有下。至故名真如皆是论文。为法之性故名法性。是疏义加。亦即前文唯识论意。非离色心别有实体者。取论意结。具足论云不同余宗离色心等有实常法名曰真如。故诸无为非定实有。释曰。言真如亦是假者不得体故。遮空见者说如违有。遮小乘中化地部等。执定实有故说为空。非言无为体即空也。勿谓虚幻有者。虚拣遍计。幻拣依他。即显真如是圆成实。以无虚妄颠倒法故名真如也。疏今多闻之人下。第六结示多闻之旨可知。疏第六有记法中二。先释总名。后别释相。今初。先叙昔即刊定记。大品经亦云。若善法若不善法是名记法。如所说相不舍离故。疏云此乃下辨非。以下无记既非三性。今此有记安得例之。后应云下辨正。疏下出所记下辨相。中先指所余如前后释不欲繁文故。疏四无所畏下唯释此一。言今当略明者。诸经中多以五门分别。一辨名。二出体。三行相四次第。五诸门。今疏但有三门略无出体次第。即分为三。初释名。二辨相。三诸门分别。初中有二。先总名。后别名。今初上二句标章。谓外难无怯故下正释。瑜伽下引证无怯之相。言都不见有如实因相者。谓其所难皆就迹生疑。不知所观真实之理故。此所难无如实因。若实有可难则可怯畏。所难不实何所畏耶。疏无畏有四下。二释别名。文中但列而不解释。释名含在下行相中。故此略无。若具释者。一一切智无畏者。瑜伽亦名正等觉无畏。谓由正觉觉诸法故名一切智。二漏尽者诸烦恼漏种现俱断故。三障道者亦名障法。说障碍法染必为障故。四出苦道者。说出离道。诸圣修习决定出苦故。于此四中得无所畏。皆依主释。谓一切智之无畏等。疏此之四段各有难答下。二辩相也。一一切智无畏难于中有二。初牒举所难。二有诸比丘下正难。于中先出难所因。谓诸部律中多有此言。时诸比丘至如来所头面礼足。佛便问言。比丘住止安乐不。乞求易得不。不以饮食为苦耶等。今云何故问者即是难也。言一切智下结成难也。疏佛自唱言我是一切智人下答也。于中先案定所难。明不失一切智义。若具皆云我于此难正见无由得安隐住无怖无畏。自称我是大仙尊位。二从但为摄受来者下。出是一切智之所以。示现问耳非已不知。言摄受来者。要令发胜心闻佛慰问发道心故。随顺世间师弟人事者。此有二意。一者成上示现之相。二者亦令余人审谛于事佛知尚问。况余不知亦为后人作轨则故。见来发心应为引摄。故云随顺世间。疏二有难云下。第二无畏。先难中文亦有二。先牒举所难。谓经中说言我诸漏已尽。后何以爱下正难。难之所因含在其中。谓罗睺罗被僧驱出在于厕上。佛语诸比丘言。云何野干驱师子子。即爱语罗睺也。调达频为恶行。佛时骂言痴人。或云食唾小儿等。疏佛于此难正见无由下答也。于中亦先案定所难不失漏尽之义。后但为随根而调伏故。即出爱恚所以。谓罗睺譬之慧象。随逐人心。软言即调。调达喻之恶马。楚毒方调。非是如来有爱罗睺。有恚调达。漏未尽也。疏三有难云下。第三无畏先难之中亦二。先牒所难。后何故下牒疑正难。疏佛于下答中亦二。先案定所难。不失欲为障道。若具亦应云。我于此难正见无由。安隐无怯处大仙位故。云自唱德号。后我所说欲能障道下。出不障所以。若说邪行障诸圣道。若说畜妻障离欲道。初二果人性戒久成故断邪行。既未离欲不断妻子斯有何失。故诸染法非不障也。疏四有难云下。第四无畏先难中亦二。先牒所疑。谓如说我为弟子说出离道。诸圣修习。决定出离。决定通达。后何故罗汉下正难。既疮溃蛇螫岂非苦耶。罗汉岂是无圣道耶。岂非相违。疏佛于此难下答亦应具云。我于此难正见无由。安隐无怖处大仙位。我说圣道下通前难。然有二意。一者由于前世故业感身。于此身上得阿罗汉。苦依身在故有此苦。非得罗汉后有此苦。即今疏意。更有意云。无学实无苦果。为现恶因。必有苦报。由此圣者示相受苦。起后教故。亦由世尊受金枪等。示义非实故疏略无

疏。四中初一下。第三诸门分别。即瑜伽论于中有三。初约离障。言次离烦恼。三是出离道者。欲为道障今出离故。四是出离之道者。诸出离道能出于苦。然其后二并约离烦恼障。三是所离之障。四是能离之道。而三就离因为难。四就离果为难。亦可后二通约因位。疏初二自利下。第二二利料拣。然约答难并是利他。如次下明。今约前二就佛身难。是约自利德叹。后二约化他为难。故云利他。疏所以自叹此四者。第三彰叹所以。亦约被根差别则皆是利他义。菩萨为求种智断所知故。初一为之二乘求尽诸漏。第二为之欲皆障于三乘。三乘皆期出苦故。后二并为疏智论二十八下总示其源。然菩萨藏经第五。般若五十三。显扬第四。亦广明之。此中即有次第出体。言次第者。德用自在智最胜故。首而明之。由具一切智能尽诸漏。由具智断说法化生。说法之中先说生死因。后出生死故。而此一门即前二利门中已摄此意。若瑜伽对法出苦为第三。障道为第四。先果后因亦如苦集。又依上次者即倒对四谛。谓一切智约真道为难。二约真灭为难。三约集因。四约苦果。未见经论义必应然。若出体者。总有五种。一克性体。即信进念定慧为体。二引发体。若定若慧。三最胜体。即正体后得二智。四中初一通二智。二即正体。三四皆后得。以是说法心故。若约自住四皆正体。约能答难此四并以后得为性。四相应体四蕴为性。五眷属体。五蕴为性。亦犹十力道共定共无表戒色。助答难故。上之四体即瑜伽五十七。及杂集说。瑜伽云。以信进念定慧及具知根为性。对法云。若定若慧及彼相应诸心心所。又云若起作用后得智为性。若住自性正体智为体。第五一体亦以义加。又无畏若约德说初即智德。二即断德。三四恩德。今就能知并智为体。余义可知。第七无记。疏今初无记二义下。即初征名。于中四。一释总名。二彰不答所以。三别示十四。四总会不同。今初。刊定亦立二义。而以前义为正。今依诸论以后为正。俱舍第十九中。第二明无记中。自分为二。一明无记报。二因便明四记。前即对善恶之无记也。广如彼论第二别明四无记事。颂曰。应一向分别。反诘舍置记。如死生殊胜。我蕴一异等。释曰。上两句指事释之。且问记有四。一应一向记。二应分别记。三应反诘记。四应舍置记(记者答也)如问死者。一切有情皆当死不。应一向记。一切有情皆定当死。如问生者。一切有情皆当生不。应分别记。有烦恼者受生。无烦恼者不生。如问殊胜。应反诘记。有作是问。人为胜劣。应反诘言。方何所问。若言方天应言人劣。若言方下应记人胜。释曰。下即恶趣。如问我蕴一异者。谓若作是问。我与五蕴为一为异。应舍置记。此不应答。若有我体可问一异。本无我体一异不成。如问石女生儿为白为黑。应舍置记。谓石女本自无儿。何得论其白黑。上依毗婆沙说。颂言等者。等取发智本论。及契经说。今当叙经。云何有问应一向记。谓诸行皆无常耶。此问名应一向记。云何有问应分别记。谓若有问。诸有故思造作业已。为受何果。此问名为应分别记。造善受人天。造恶受恶趣。谓若有问士夫报与我为一为异(此假问我)应反诘言。汝依何我作是问。答言依粗我(色蕴上我)应记与报异(报色不同故言异也)此问名为应反诘记。云何有问但应舍置答。若有问世为常(一问)无常(二问)亦常亦无常(三问)非常非无常(四问)世为有边(五问)无边(六问)亦有边亦无边(七问)非有边非无边(八问)如来灭后为有(九问)非有(十问)亦有亦非有(十一问)非有非非有(十二问)为身者异命(十三问)为命者异身(十四问)此问名为但应舍置。此十四问皆不可记。名十四不可记事。以我体既无。是故皆应舍置答也。涅槃三十五亦有四答。而一名小异。谓从经一半向后。因迦叶难佛性义有无。如来答云。善男子。如来为众生故有四种答。一者定答。二分别答。三者随问答。四置答。如问作恶得何果耶。应答得苦果。是名定答。二善男子。如来十力。四无所畏。大悲。三念处。首楞严等八万亿诸三昧门。三十二相。八十种好。五智印等。三万五千诸三昧门。金刚定等四千二百诸三昧门。方便三昧无量无边。如是等法是佛性者。如是佛性则有七事。一常二我三乐四净五真六实七善。是名分别答。如汝先问断善根人有佛性者。亦有如来佛性。亦有后身菩萨佛性。是二佛性障未尽故得名为无。必定得故得名为有。是名分别答。三经云。如我所说一切法无常。复有问言。如是世尊为何法故说于无常。答言。为有为法故。无我亦尔。为何法故说一切烧。为烦恼故。是名随问答。四经云。若有说言。断善根人定有佛性定无佛性。是名置答下迦叶难云。不答名置。如来今者何因缘答而名置答。佛答云。善男子。我亦不说置而不答名为置答。善男子。置答复二。一者遮止。二者莫着。以是义故得名置答。释曰。据上诸文明是不答以为无记。非善恶中之无记也。据十四难正同俱舍。准涅槃意今文正当为遮止义。兼令莫着。疏所以不答下。第二彰不答所以。于中二。先总出意亦智论意。后智论第三下。正引论释。先引第三有五复次多同答十四难。兼经中诸无记法如第一。无实事故正答十四。第二车轮即答何等为生死最初际。第三无利有失。兼答世界来去等。以从集因生归寂灭理。妄征来去即覆四谛。第四人不能知。兼答有几佛几众生。以佛智知无尽法故。第五复次兼答佛等先后通意可知。疏第十七下。二引此文即引昔例。今其文稍略。具云有一比丘于十四难思惟观察不能通达。心不能忍持衣钵至佛所。白佛言。佛能为我解此十四难。使我了者当作弟子。若不能解我当更求余道。佛告言。痴人汝共我要誓。若答十四难汝作我弟子耶。比丘言。不也。佛言。汝痴人今何以言若不答我不作弟子。我为老病死人说法济度。此十四难是斗诤法。于法无益。但是戏论何用问为。若为汝答。汝心不了至死不解。不能得脱生老病死。譬如有人身被毒箭。亲属呼医欲为出箭涂药。便言未可出箭。我先当知汝姓字亲里父母年岁。次欲知箭。出在何山。何木。何羽。作箭镞者。为是何人。是何等铁。复欲知弓。何山木何虫角。复欲知药。是何处生。是何种名。如是等事尽了知之。然后听汝出箭涂药。佛问比丘。此人可得知此众事然后出箭不。比丘言。不可得知。若待尽知此则已死。佛言。汝亦如是。为邪见箭爱毒所涂已入汝心。欲拔此箭作我弟子。为不欲拔箭。而欲求尽世间常无常边无边等。求之未得即失慧命。与畜生同死自投黑暗。比丘惭愧深识佛语。即得阿罗汉道。复次菩萨欲作一切智人。推求一切法真知其实相。十四难中不滞不碍。知其是心重病。能出能忍是名忍法。释曰。即疏下文引论广破。及经结多闻之意是也。论文引毒箭之喻。与涅槃大同。前已引竟。疏楞伽亦云下。即第三经。佛令慎勿习近世间诸论。举昔有婆罗门来问我云。瞿昙一切所作耶。我答婆罗门言。一切所作是初世论。彼复问言。一切非所作耶。我复报言。一切非作是第二世论。复问言。一切常耶无常耶。生耶不生耶。我报言。是六世论。复云。一耶异耶。俱耶不俱耶。一切因种种受生现耶。我报是言。十一世论(广说云云)我言。悉是世论非我所说。是汝世论。我唯说无始虚伪妄想习气。种种诸恶三有之因。不能觉知自心现量。而生妄想攀缘外性彼复问云。痴爱业因故有三有耶。为无明因耶。我报言。此二者亦是世论。彼复问言。一切法皆入自相共相耶。我复报言。此亦世论。婆罗门乃至意流妄计外尘。皆是世论。又问。颇有非世论不耶。佛答意云。外道中无。我论中有非世论。汝诸外道不能知。以于外性不实妄想虚伪计着故。谓妄想不生觉了有无。自心现量妄想不生。不受外尘妄想永息。是名非世论。此是我法非汝有也。偈中云。乃至心流转是则为世论。妄想不转者是人见自心。来者谓事生。去者事不现。明了知去来。妄想不复生。解曰。前偈无妄见。后偈了知妄灭。据今经文正是前文一段所有妄计。其再问痴爱因缘等。虽是正义不了自心故为世论。故智论云。覆诸法实相亦同涅槃。通遣着意。疏言十四者下。第三示十四相可知。若历五蕴三世成六十二见如前已说。疏然诸经论下。第四总会异说。言相或同异者。多同少异。诸处亦说名十四不可说。俱舍十九已如上说。正与此同。智论十七即释大品。大品二十一佛母品云。复次须菩提。佛因般若波罗蜜。诸众生心数出没屈伸如实知。世尊云何知之。佛言。一切众生心数出没屈伸。皆依色受想行识生。佛于如是中。知众生心数出没屈伸。所谓神及世间常。是事实余妄语。是见依色神及世间无常等三句准知。又世间有边是事实。余妄语等四句准知。皆是见依色。末云。依受想行识亦如是。神即是身。是见依色等异身亦然。依受想行识亦然。又云。死后有如去。是事实余妄语。是见依色。二死后无如去。三死后或有如去。或无如去二句。同初结云依受想行识亦如是。释曰。斯即历蕴诸句小异耳。涅槃三十九先尼梵志问。有我耶无我耶等广有问难。亦是小异之相繁不出之。疏文分五段下。二辨相也。便有释文就常等破。皆中论意。疏文分五别。即第二辩相便为释文。疏今初段中句虽十六下。释此第一就我明无记。中二。先辩见所依。后正释文。今初有三。一明不离断常。二言世间下。明世间同异。明见依我起。疏准大品中通三世间者。即上二十一经而三世间是智论释。论云。世间有三种等。余如疏辩。三初有边四句下。释此我不同不出三世。涅槃为起见处。就引中论邪见品。我于过去世等者。偈首之我即今世我。意问今世之我于过去世为先已有。为先未有。若先已有即是计常。若先是无今此新起即是无常。三则双立四则双非边等诸义。次下当释中论涅槃品偈云。灭后有无等。无边等常等。诸见依涅槃未来过去世。释曰。此即总示所依。依前别配可知。疏第一四句等。然论先明常等。后说边等广破常等。例破边等。今顺经次先明边等。文中有三。初辩四句之相。二明不答之意。三破其所见。今初。即前偈中。我于未来世为作为无作。初以无作为有边。而是断见外道亦先偈首之我是今世我。四句之相。疏文自明。二既皆邪见下。明无记义。即出不答所以也。三若欲破者。初之二句皆堕无后世过者。合破二句。论云。若世间有边云何有后世。若世间无边云何有后世。释曰。有边则后无续故无后世。无边则常相续亦无后世。有边则断。无边则常。疏无后世者下。出无后世过。亦即断常过也。论又云。五阴常相续犹如灯火焰。以是故世间不应边无边等。前出过破。定有定无故堕断常。今立理破。如焰从缘不可为无。无定实故。不可为有。故离二边。又前破人我。此破法我。今经正破人我故。不引破法。又论反破云。若先五蕴坏。不因是五阴。更生后五阴世间则有边。若先阴不坏。亦不因是阴。而生后五阴世间则无边。释曰。此亦正破五阴世间。五阴和合为众生世间。既破五阴即破众生。众生即假我故。上云外道依之计。我今破五阴亦已破我。又上二偈亦别破二句。亦兼明第三俱句。疏第三句等者。然论广破常等。后例破边等。故论云。我于未来世为作为不作。如是之见者皆同过去世。然破边等无有身一异破。身一异破即前破常等之中。今依论例破故取前势。若论破第三句云。若世半有边半无边。是则亦有边亦无边不然。彼受五阴者。云何一分破。一分而不破。是事则不然。受亦复如是。云何一分破。一分而不破。释曰。前偈破众生即是遣我。后偈破受阴即是破法。然俱是相违破。无有一法亦常亦无常故。此相难见故。疏取前破常等。例前。破常偈云。若谓我即是。而身有异相。当知离于身。何处别有我。离身无有我。是事为已成。若谓身即我。若都无有我。但身不有我。身相生灭故。释曰。此则破常等以一异门。今将例破边等四句也。疏若谓舍人生天下。遮救即论正破边等之意。然偈云。若天即是人。则堕于常边。天则为无生。常法不生故。若天异人者。是即为无常。若天异人者。是则无相续。释曰。前偈破常即破无边。后偈破断即破有边。次偈云。若半天半人则堕于二边。常及于无常是事则不然。今疏即影公取偈之意。舍人生天人分犹在天分更增等。上即纵立则半天。下正破。结言略明故皆不然。不然之由即如偈文。亦常亦无常二相违故。犹如水火义无并立。疏第四句下。论但蹑前破云。若有边无边是二亦应成。释曰。此即纵破亦相待破。有第三句可待对此有第四非有边无边句。以有无相待故。今无第三之源。何有第四之末。疏中即出过破。非有遮有故。未免于无非无遮无。安得离有。故还成亦有亦无。无第四但非之义。以皆执取非中道故。云何于中下。结斥邪见。疏二常等四句等者。方上破边等。先出四句后方别破。今则常句便立便破。初常句中先立。然前问偈云。我于过去世。为有为是无。即问今之现我过去先已有耶。今初句云有故。过去世我即是今我也。论初破常句云。过去世有我是事不可得。过去世中我不作今世我。疏若言常即有大过等者。出过破也。即彼长行云。先世中我不作今我。有常过故。若常有无量过。何以故。如人修福因缘故作天然后作人。若先世我即是今我者天即是人。以罪业因缘故。作旃陀罗。后作婆罗门。若先世我即是今我。旃陀罗即是婆罗门等。疏若谓我今下。即第二句亦先立。后若尔下。破有二种。破先因缘。破缘作是无常。汝立我常故。二堕无因故。故论云。过去我不作是事则不然。过去世中我异今亦不然。若谓有异者。离彼应有今我住过去世。而今我自生。如是则断灭失于业果报。彼作而此受有如是等过。先无而今有。此中亦有过。我则是作法亦为是无因。释曰。此中初二句牒计总非。次二句标有异过。次二偈二世相对以辩异过。末后一偈独就未来以彰其过。上二句标。下二句显。第三句由今始有故成作法即堕无常。次句指同前非云亦是也。前失业果即是无因。今我自生岂非无因。疏第三见上下。谓见前二过便即双立。从离身下。破即前所引偈中即离门也。二又成上二过者。亦常同初句。亦无常同第二故。第四句但翻用前句而立破。则还同第三论偈但云。如过去世中。有我无我见。若共若不共。是义皆不然。疏又中论云下。即品末之偈。总结上过。示以性空。末后又偈云。瞿昙大圣主。怜愍众生故。悉断一切见。我今稽首礼。即总结一品也。疏三如来灭后下。前明见所依从其后义云依涅槃起。而其前义通依三世我阴而起。顺于晋经。疏若依中论下。第二意中。于中二。先定见所依。及如来不同以外道。自谓勒沙婆等是世尊是如来故。故百论中序德相形。言优楼佉等亦是世尊故。疏有谓如来灭后定有不变者。别示四句。先示可知。后以其四句皆成戏论下。明破无记之意。上依中论涅槃品偈云。如来灭度后。不言有与无。亦不言有无非有及非无。又云。涅槃与世间无有少分别。世间与涅槃亦无少分别。涅槃之实际及与世间际如是。二际者无毫厘差别。释曰。初之一偈依二谛说。后之二偈唯依第一义。与瑜伽同。疏瑜伽八十七下。证成上义。则显中论初偈俱通二谛。约世谛中唯释二句。等字等于三四。约涅槃中但释初二句。从又此涅槃极难知故下。三义通显离四句绝百非。中论末后偈云。一切法皆空。何有边无边。亦边亦无边。非边非无边。何者为一异。何有常无常。亦常亦无常。非常非无常。诸法不可得。灭一切戏论。无人亦无我。佛亦无所说。释曰。此偈可结无记一段。以文相续故此引耳。疏四我及众生有无等四句中。言双立者。双立我法。众生即蕴蕴即法故。故疏直就缘生法理以辩有无。然此四句大品智论俱舍等于此句立二句。大品等云。身与神一及异成二句。俱舍即命与身即及离成二句。初句云。俱有者。谓有执云。但有身处则有神我。有神我处其必有身。身之与神不相离故。释曰。此即身神一句。故智论云。神即是身者。有人言。身即是神。何以故。分析此身求神不可得故。受之粗妙皆是身故。故言身即是神。身异神异者。有人言。神微细五情所不得。亦非凡夫人所见。摄心清净得禅定人乃能得见。是故言身异神异。复次若身即是神。身灭神亦灭是邪见。身异神异身灭神常是边见。释曰。论文但释二句。今经中初句是论初释。身神一句。第二句是论复次身即是神。身灭神灭是邪见第三句。正是身神异句。虽粗妙之异身在俱有。身无俱无为俱句也。第四即复是身神一句。以身随神体皆妙故。俱离有无。疏然此四句亦有单计等者。此对前经中二双立故。亦是智论约边见意。其我有所无正同智论身灭神常。二所有我无者。身粗可见。我无相故。言亦不离初之二句者。我有所有合是初句。我无所无合为第二。疏又合上为第三者。初句我亦有第二句。我亦无初句。所亦有第二句。所亦无故合为第三。四既合一处故互相夺。如我有合我无。则我非有所有。合所无则所非有等遮无。即为第一俱有句。遮有即为第二俱无句。故云亦不出初之二句。问如初我及众生有。即是邪见。以计我故。次句云我及众生无。则是二空有何过耶。故疏中云定无著断。以执定故非缘生无。亦应破云。约计实我。此我非有。随世假我此我非无故说俱无。亦非当理疏第三门竖明中。言有人答问者。即水南善知识。答燕国公张说问云法在前佛在前答云。法在前诸佛所师所谓法故。便被难云。若尔最初成佛前无佛说何由悟法。答云。自然而悟。如月令中獭乃祭天岂有人教。燕公大伏。疏亦为应机者。叹其善对。宁加置记者。为顺经文。从若有初佛下。出不及置记所以。既有初佛佛数难穷。如来具足一切种智直举初佛则可示矣。故虽善对未息难源。疏何法者染净一切法者。即如真妄前后之难也。初会略明初地当广。疏第四门征世间所从中。其诸邪见初卷已广。器界生死共因者出现品说。三谓三灾但坏器界不坏有情。先令有情生上界竟。方坏器界故。四器界因无永断者。如染刹之因。已亡不复更修染因招染刹也。有情染因虽灭阴识不灭。五器界断而复续者。约招成坏之刹。坏后更成。有情若舍异生之性。终不更为凡夫矣。然此与四似当相违。而四则器界约因断果不生。有情因断果不失。五器界约果断果更续。有情约妄因已断妄果不续。疏谓若许有终必有始故亦如初地。疏中论云。大圣之所说等即本际品偈此中初偈引教立理。显无始终。次二句仍上遣中。以无始终可待对故后两句遣其先后略有三义。谓应有问言生死二法为先生后死。为先死后生。为生死一时一时名共。今且总非。下有偈出非所以云。若使先有生后有老死者。不老死有生。生不有老死。若先有老死而后有生者。是则为无因。不生有老死。释曰。前偈破先生后死。生必因死。今先有生则不因老死而有故。云不老死有生。则亦令生无有老死。先独生故。后偈破先死后生。生是死因。今死在前则为无因矣。次破一时偈云。生及于老死不得一时共。生时即有死。是二俱无因。释曰。以生不因死。死不因生故。后结法空云。若使初后共是皆不然者。何故而戏论。谓有生老死。疏既言本际下疏释论。正为证有始终之邪见故。疏又有偈云。此即邪见品破有边等偈后。前已引竟。疏上诸邪见下总结上意。言菩萨善知问答者。具四种答。一正是置答。二如说生死无有始终是一向答。三如云众生器界五种不同是分别答。四若有问云。世尊约何法说我。何法说众生。应答言。约假名说我。约因缘说众生。是名随问答。若通前七以辨多闻。问答居然可知。余可思准

大方广佛华严经随疏演义钞卷第四十五大方广佛华严经随疏演义钞卷第四十六

        唐清凉山大华严寺沙门澄观述

第六施藏。疏如月光王施头等者。即贤愚经第五卷说月光王施头。二十八经中因说如来受波旬请却后三月当般涅槃。舍利弗闻便白世尊。不忍见佛入般涅槃。当先涅槃。佛便许之涅槃讫。佛告阿难。舍利弗非但今日不忍见我入般涅槃先取灭度昔亦如是。阿难请佛为说其事。佛便广引经文浩博今略意引。佛告阿难。过去久远无量无数不可思议阿僧祇劫。此阎浮提有一国王。名旃陀婆罗脾(晋言月光)统阎浮提八万四千国。第一夫人名须摩檀(晋言华施)一万大臣其第一者名摩诃旃陀(晋言大月)有五百太子。大者曰尸罗跋陀(晋言戒贤)王所住城名跋陀耆婆(晋言贤寿)广说庄严王思善因广行大施。告令国内悉令大舍。时边远有一小国王。名曰毗摩思那。心生嫉妒广诏外人。乞取王头无肯从者。后复广诏云。得月光王头分国半治以女妻之。有婆罗门名劳度叉。应诏乞头月光王。国先有变怪。大月大臣复得恶梦。城神遮之不令得入。时首陀天托梦令知月光睡觉。诏令见已。大月大臣思以五百七宝头换之。不得心裂七分死于王前。王许其头却后七日。而遍告国内。国内皆至擗地请留。王不受之。言我计死所经地狱。一日之中舍身无数竟无所益。今日施头持是功德。誓求佛道当度汝等。言讫入园系发于树。树神以手搏婆罗门。王语树神。我此树下已舍九百九十九头。今当满千。汝莫遮我无上大道。树神依之。婆罗门斩下王头。地六震动施头之声声遍天下。时毗摩羡王闻此语已喜踊惊愕心擗裂死。时婆罗门嫌头腥臭。掷地脚踏人又呵之。回来在道无施给者饥饿委悴。闻毗摩羡王已复命终。懊恼愤愤心裂七分吐血而死。王及婆罗门堕阿鼻地狱。其余人民感激死者皆得生天。月光王者我身是也。毗摩羡王波旬是也。劳度叉者调达是也。其树神者目连是也。大月大臣者舍利弗是也释曰。此即世尊本行故云贤行。此明世尊无不能舍。则令施心须成恐无巧慧不善筹量故。云未全可准。夺万姓之欢施二人之死向引已具。疏若不尔下。成上须量之义。菩萨能施。而不施者明是不宜即善量也(八中)疏不自安处求胜乐者。初发心住已会此文。疏非有处所者与理冥故者。即明净土四句之义。谓有质不成无质不成等。如世界成就品。疏十万等殊者。十万即阿弥陀经。从此西方十万佛土有世界名曰极乐故。等者。等于余土远近之数。疏若约通论未来法可以意得者。未来未至故非有处所。缘会当成圣智所知故。非无处所未来故非内。由心故非外。未至何有远近。疏异生果中此最胜故者。上五圣居故。疏已得上品杂修静虑者。谓漏与无漏间杂而修故名杂修。俱舍贤圣品论云前说上流杂修静虑为因能往色究竟天。先应杂修何等静虑(一问)由何等位知杂修成(二问)复有何缘杂修静虑(三问)偈云。先杂修第四(答第一问)成由一念杂(答第二问)为受生现乐及遮烦恼过(答第三问)释曰。初句明夫欲杂修必先修第四静虑。由第四静虑最堪能故。二答成位。谓阿罗汉或是不还。成由一念杂者。谓彼必先入第四静虑。多念无漏相续现前。从此引生多念有漏。后复多念无漏现前。如是旋环后后渐减。乃至最后二念无漏。次引二念有漏现前无间。复生二念无漏名杂修定加行成满。次复唯有一念无漏。次复引起一念有漏。无间复生一念无漏。中间有漏前后无漏以相间杂故名杂修。此一念杂名根本成修第四已乘此势力亦能杂修下三静虑。答何缘云杂修静虑。总有三缘。一为受生生净居天故。二为现乐受现法乐故。三为遮烦恼过。若不还一修由前三缘。若罗汉修除受生一。从此第六明净居处何唯有五。论颂云。由杂修有五。生有五净居。释曰。由杂修第四有五品故。一下品有三心。初起无漏次起有漏。复起无漏。二是中品亦同上修三心。并前成六。三是上品四上胜品。五上极品。亦皆同初各起三心。三五便成一十五心。如次五品感五净居。应知此中无漏势力。熏修有漏感五净居非无漏感。今善现天是第四品。第五善见是极上品。故障至微。疏一旦背恩如小儿故者。即智论文审谛观此身终毕归死处。难御无反复背恩如小儿。疏故智论云由无我故下。亦同此卷已前亦引。第七慧藏。疏今初以四谛慧等者。疏文有四。一料拣句数开合。二释如实知义。三随文解释。四结弹古义。今初有二。一摄十为五。后三即为三。故今初言以四谛慧等者。即无作四谛也。故下四谛差别门中云。若约菩萨能观皆无作也。二收此五下。摄五为二自有四门。一凡圣差别。二又若后三就果下。四谛差别门。三又初二流转下。是流转还灭门。四又前是所知下能所知见门。于四门中前三皆约所知。后一方具能所。四谛之义已见本品。疏前有灭道下。此通妨难。谓有难言。初二流转即五蕴有支而皆有四谛。谓色灭色道等灭道即是还灭。何言流转。后有苦集亦然。故今通云。前五阴等中有灭道者。于蕴等中方始修道期得灭耳。若已证灭则无蕴等言后有苦集者。即三乘中亦以四谛。则有苦集既是还灭何得有之。故今答云。虽是圣人苦集未尽。无余涅槃方始尽故。疏又前是所知下。第四门中二。先正明。后人中有法下通妨。经云声闻法如实知。缘觉法如实知等。何言但是能知之人。故为此通。谓三乘圣人历前诸法成三乘耳。历于四谛下。示其以法成人之相。其四谛之法遍在前七。所缘有支即无明有爱。能如实知诸法故名菩萨。疏皆言如实知下。第二总释如实知可解。疏十中前七下。第三随文解释。于中二。先解前七。后解后三。前中先总后别。总中云。无明与爱有漏性下释妨。谓有问言。无明与爱此是烦恼。云何而言七皆是苦。故为此通。明三义是苦缘生是集。七皆缘生无性。是灭七皆无性。结是理灭。显灭为道者显无性理。言从诠显者。释上显灭为道。谓缘生之法是显灭之诠。若不从缘不知无性故。亦如修行止观显得灭理故。次结云此则总说及就理灭。疏若别说者下。历色等七一一别明四谛之相可以思准。言由他言说等皆瑜伽意义皆可知。不正思惟亦涅槃意六地当明。谓无明触为缘等者。亦瑜伽意。大般若等皆说眼触。眼触为缘所生诸受等。如眼根境识三和合名触。若以明为缘不成有支。由无明迷而受诸受。乐受生爱故是爱因。疏十二支中唯举二下。释文略妨。先牒从发业下。解释略引三文。唯识生引门说。无明发业。爱能润业能引有。二但举无明能润有。三但举于爱已摄取有。二从痴下。引净名释。三从涅槃下。引涅槃经证。即是北经当三十四。南经三十二明二十一对诤论之中。此当第十四有心数无心数义。此文稍略。若具引者经云。善男子。我于经中作如是说。圣人色阴乃至识阴。皆是无明因缘所出。一切凡夫亦复如是。从无明生爱当知是爱即是无明。从爱生取。当知是取即无明爱。从取生有。是有即是无明爱取。从有生受。当知是受即是行有。从受因缘生于名色无明爱取有行受触识六入等。是故受者即十二支。善男子。我诸弟子闻是说已不解我意。唱言。如来说无心数。释曰。此中有三。先明圣人五阴从无明生。二例凡夫。三就凡中明心法展转相生更无别数。此中即三世十二因缘隐显互论。文中先列后结。列中先明过去之因从无明生。言从无明生爱。当知是爱即是无明者。谓无明之心对境染着。即名为爱。是故此爱即是无明。言从爱生取当知是取即无明爱者。即前爱心取着境界。即名为取体性不殊。是故此取即无明爱。言从取生有。当知是有即是无明爱取者。前取心起业名有。是故此有即无明等。次论现果。云从有生受。当知此受即是行有者。此詺识支。以之为受。识支即是现报之体。从因缘得故名为受。即前有支转为此受。是故此受即前行有。亦应即前无明爱取。就近言之耳。言从受因缘生于名色者。受增为名。所托识立以之为色。从受生于无明爱取有行者。从现报受起后因也。从受因缘生于爱触识六入等者。从现报色转。起未来生老死也。亦应宣说名色即是受。乃至宣说六入即受。而文略耳。以下经云是故受者即十二支故。故此末句即是总结。无别受外心法。向前即于过去无明爱等。向后即于名色等故。受即十二支。以今疏引但引初段。证无明爱是十二支本。其即无明爱等。等字等余经文。然其彼经本意为明无别心法。非成无明及爱是有支本。故疏结言亦似斯义。疏又约三际无明为本下。即瑜伽论。至下六地当广分别。今且略释无明横起是本可知。不了第一义谛名无明故。言爱取为际者。即现在所起。若更起爱取则有未来生老死支。若不起者当苦不生。有无由之故名为际。言是二中间有识等五者。是无明支后爱取支。前中间五果。言及生老死者。即爱取支。后望未来世未起爱取支。前为中间耳。以未来更起展转无穷故。疏今悟无明下。出爱取为际之由。义如上释。疏后三约净下。第二释后三段。于中三。初案文释。二又知声闻即是知苦者。会通四谛。以前标云以四谛慧照十法故。三前释通因下。会通二释。虽因果云异亦不殊四谛之意也。疏若定以前二为分段下。第四结弹古义。即刊定记释。疏先叙之。后则小乘三果下。示其过相。后之三乘通因通果。今为变易则三果已受变易。变易入无余竟方始受之。何得三果便受变易。又此三果非此所知。三果是分段故。言直往七地等者。回小入大初地已上容受变易。直往菩萨八地已上方受变易。今总为变易故。七地已还非此所知。亦可直往七地已前应受变易各有二过。疏文影略耳。然分段变易者。胜鬘经云。有二种死。何等为二。谓分段死。不思议变易死。分段死者。谓虚伪凡夫。不思议变易死者。谓阿罗汉辟支佛大力菩萨意生身。乃至究竟无上菩提。释曰。据此明知小乘三果。七地已还未受变易也。四变易义前已广说。疏亦显所知之相者所知者即下性相。要显所知方识能知耳。疏知相知性下。此中有三。一知相。二知性。三知无障碍。无障碍有二。一上性相无碍。二以性融相重重无碍。即四法界是此所知。言无知之知者。是菩萨能知也。即般若无知对缘而照耳。疏又二段中。含前五类等者。谓前以如实知。一一历前五类之法。在文昭著。今明文中义含前法故疏具示。疏自色已上种智已还者。大品略列八十余科。大般若更广。谓色为首是五蕴初故。次历四蕴。次历十二入十八界。次眼等触等所生诸受。次四念住四谛四禅八解脱陀罗尼十地五眼十力大慈大悲四等相好无忘失法一切种智四果菩萨行无上菩提。释曰。上即所历也。疏现见诸法犹如聚沫等者。举五蕴不实破坏之义。以难不坏释意前已频有。疏皆已无得等为少方便者。疏以无得释少方便。下经云以无所得而为方便。若准大般若。亦以无生为方便。无住为方便。无依为方便。皆般若相也。然为方便略有二意。一为入有方便。令有无所得等。二为入空方便亦不住无得。故今正取为入有方便。疏亦如上酥无不入者。解深密经叹真实智无不入也。第八念藏。疏十一分教今当略释者。即第五演教也。文中三。一释总名。二各有二相下释相。三料拣通局。二中先总明。后修多罗者下别释之。此一部分二。先辨二相。其长行缀缉等者。次下当知。二然更有下。辨异名。便彰三相。于中二先列四名。亦如初卷。后言法本下。别释。于中二。一正述远公释。二以彼立下。为出所以。即立三相。以五中后三即三修多罗相故。于中先列。后总。不异前下释。于中二。一正释三相总不异前二相中总也。余二可知。然其后二下。遮破会通。以刊定记自立两重总别。如第一疏钞不许立三。彼第一疏中破云。隋远法师虽说修多罗总别略三。初顺涅槃。二无圣教亦乖正理。三违杂集。杂集论云。修多罗者。谓长行缀缉略说所应说义。彼自释云。略说所应说义即是长行缀缉。曾无先略标举后广释之相。言略者总之异名。谓修多罗一分是总。余十一分是别。今修多罗依藏部。中总相业用而立其名。余藏部名依藏部中别相业用。所以者何。修多罗业用能贯摄故。故余藏余部所诠所化。由此贯摄彼方成故。故涅槃云。始从如是我闻终至欢喜奉行皆修多罗摄。释曰。此即彼之立破。今疏知其所立但是总相更不叙之。言违杂集故。为辨相却用杂集故云不违。此成别相故云长行缀缉。是十一所不摄者。恐义未显故引涅槃。贤首品示之以总长行缀缉即是总相。总相何得拣偈颂耶。疏其略说所应说义。通略相修多罗。即杂集论文而为两段。出别略之据。只用上贤首品一文双证二义。如云尔时文殊师利说无浊乱清净行大功德已者。但是长行缀缉。若云欲显示菩提心功德故即略示相。标下文之所说故。次明不违成实可知。从斯则通十二分者。明略相通也。不同别相十一不摄。疏若十二分中修多罗下。双结藏部二修多罗通局之异。此文正为刊定立二总别。彼云但藏部立名各有两重总别。一谓三藏十二部为总名。修多罗等为别称。二谓修多罗为总号。毗柰耶应颂等为别目。自古相传唯辨前门不论其后。释曰。其后一总别彼为挺拔。今正破之。彼意云。既契理合机名修多罗。则律与论皆有契合。岂不得名修多罗耶。故今示云。二藏有契合者即十二部中修多罗耳。此约义该何须更立两重总别。则三藏修多罗唯局总相。十二分中却分三相故。从总相立于经藏拣异二藏也。疏但开杂集下。结示远公之据。疏有不晓下。结弹。刊定违杂集言却在彼已余十二分文并可知。然随一一分便引当经为证。则显此经具十二分耳(二中)疏涅槃云。佛昔为诸比丘等者。即十五经云。长行具云何等名为祇夜经。佛告诸比丘。昔我与汝愚无智慧不能如实见四真谛。是故流转久处生死没大苦海。何等为四苦集灭道。如佛昔日为诸比丘说契经竟。下全同疏。疏后等字有二。一等余偈。更有一偈云。若能见四谛。即得断生死。诸有既已尽。更不受诸有。是名祇夜经是也。二等取余经文。疏如记弥勒者。涅槃云。何等名为授记经。如有经律如来说。时为诸天人受佛记别。汝阿逸多未来有王名曰穰佉。当于是世而成佛道。号曰弥勒。是名授记经。四伽陀。涅槃中引诸恶莫作偈。二相即是二意立偈(五中)疏二因事方说知本末故。涅槃云。何等名为尼陀那经。如诸经偈。所因根本为他演说。如舍卫国有一丈夫。罗网捕鸟得已笼系。随与水草而复还放。世尊知其本末因缘。而说偈言。莫轻小罪以为无殃。水滴虽微渐盈大器。疏七本事二相中。瑜伽八十一但有初相。云本事者。说佛前际所有事。后际所生事。杂集但有后意论。云本事者。谓宣说圣弟子等前世相应事。疏八本生等。一说如来者。涅槃云。如佛世尊本为菩萨时。修诸苦行。所谓比丘当知。我于过去作鹿作罴作獐作兔作粟散王转轮圣王龙金翅鸟。如是等行菩萨道时舍所可爱身。疏九方广可知。所引杂集皆第十一。开总菩萨藏相应言为四。并总为五余即可知。疏此之十二于大小下。第二料拣通局。于中三。一拣通局大小。次通会。后拣十二互有互无。今初言涅槃第三云护大乘者受持九部者义引经云。若有比丘。供身之具亦常丰足。复能护持所受禁戒能师子吼演说妙法。谓修多罗祇夜授记伽陀忧陀那伊帝目多伽阇陀伽毗佛略阿浮达磨以如是等九部经典。为他广说利益安乐诸众生故等。疏法华第一即是方便品。后偈下半云。入大乘为本以故说是经。下引瑜伽小唯十一。疏然诸经下会通可知。疏然契经等下。料拣互有互无余可知。第九持藏可知。第十辨藏。明七辨十地广明。第四会竟

    升兜率天宫品第二十三(第五会)

疏。菩萨大乘藏经者。或单名菩萨藏经。唯一卷。亦名礼佛忏悔随喜等。后广说回向等功德。先明七宝布施满恒河沙三千大千世界供养于佛。后云行此回向功德胜前功德等。即引无量果乃是义引耳。疏回向心为大利故。即暗引净名佛道品。普现色身菩萨之偈。偈云。富有七财宝。教授以滋息。如所说修行。回向为大利。言故行后明之者。回前行故。疏亦有三义者。一约处名兜率天宫会。二约人名金刚幢菩萨会。三约法名十回向会。疏处此说下。此句征。从表位下答。答有六意。一前行在夜摩。今回向超前故居兜率上。但约次第。二取知足天名。三约天主说之。四再就知足释之。前约自利足。此约利他足。五约中道说之。六约均平释。言又生此天而修三福者。即涅槃三十二。应言修施戒者得上下天身。修施戒定得兜率天身。疏三约功用满等者。故第八地初有总明方便集作地分。集前七地为八地方便。四十地初有方便作满足地分是也。疏未必起神境通等者。此亦即前第十二经初。各随其类为现神通。余说四会等例可知(大文二中)疏或可第二段明回向者。以初约位。是十住三明十度全同十行。故二配回向。四配十地则竖位具足。以第二段中神通不坏等亦有回向意。第四段普入佛刹等亦有十地体势故为此配。由二三前却二四不显故。前正释后三通诸位(正报中)疏情动于中故形于言等者。即子夏诗序。具云。情动于中而形于言。言之不足故嗟叹之。嗟叹之不足。故咏歌之。咏歌之不足。故不知手之舞之足之蹈之也。第五观佛胜德。疏而此文义兼广者。以离世间品初叹佛有名无释。今文有释无名。四纸余经次第具释二十一德。故云文义兼广。四纸余经文广。其中句义该收诸论异释无遗故云义广。由此故于此中引于诸论。将论释经将经证论故云随便。古人亦引诸论在离世间。既无经文论无凭据。由此无名。故古德同迷藏和尚以下总结十句分为十段。刊定以十六三业配之。并如下引今并不用。疏离世间品名妙悟皆满者。上释经中总句。此下会其总句异名。然摄论本论即无著所造。世亲无性二俱有释。唐三藏俱译皆有十卷。此并当第五。今依无性释。所知相中因云。若欲释大乘法。略由三相。一由说缘起。二由说从缘所生法相。三由说语义。论曰。说语义者。谓说初句后以余句分别显示。或由德处。或由义处。释中云。已得在已圆满饶益故名为德。未得在已随顺趣求故名为义。论曰德处者。谓说佛功德即二十一种殊胜功德。释中云最清净觉即是初句。由所余句开显其义疏。亲光释云者。亲光即佛地经论主。二本摄论不解总句。此菩萨解自有三释。疏便以义拣断释之。然此三释有其二意。一别释总句。一释正字。二释最清净字。三释等字。彼无等字义符今经。二者于所觉法影略出之。一为无为为所应觉境。二云一切为所应觉境。三以如所有性等为所应觉。故小异也。又一为与无为总明所觉不出二故。二一切法曲尽差别故。三如所有等通能所故。其如所有性等今当略说。即杂集论第十一云。事边际所缘者。谓一切法尽所有性。如所有性。彼疏释云。事边际等者。事有二种。一是自相事。二是共相事。初能缘心尽法分量。后能缘心如诸经中所有共体俱称边际。此中事即是境。就文分三。初标章。次开二义。后别释。此上是初二段下即别释。论云尽所有性者。谓蕴界处为显所知诸法体事。唯有尔所分量边际。是故建立蕴界处三。彼疏释云。谓尽有为无为诸法自相。论云。如所有性者。谓四圣谛十六行。真如一切行。无常一切行。苦一切法无我涅槃寂静等。空无相无愿。彼疏释云。此中略明四种共相。第一谛门。谓四圣谛。第二行门。谓十六行及真如。第三邬陀南门。谓一切行无常至寂静。第四解脱门。谓空无相无愿。本论举境不举能了。论云。由如是等义差别门。了所知境故名如所有性。疏先释通名次别释此初也。谓由如是四谛十六行等。是尽所有性中差别义。其能缘心如诸法中所有差别。皆悉了知故。名如所有性。论或以谛门了所知境。彼疏云。谓即前所说诸蕴界处。随其所应了知是苦乃至是道。彼疏释四差别即为四段此初文也。谓总观前尽所有性中蕴界处。有漏者观于苦集。其无漏者观其灭道。故云随其所应。论云或以行门了所知境。说一一谛各有四行。及一切法无有差别皆真如行。彼疏云。前谛及法门约所缘得称。此下就能缘得称。即是四谛各别有四行即是。前总作谛解而了蕴等。今约一一谛中。别作四相解。而起四行。及一切法作总相。真如缘而起真如行。即名了无常及真如等行解名行。即前十六行是缘安立行处。后真如行是缘非安立行。论或以诸法邬陀南门了所知境。即诸行无常乃至涅槃寂静。彼疏邬陀南门者。旧为忧陀那讹也。正翻为说。义当无问自说。随义作名。亦总略义。或名标相义。谓一切行无常是有为标相。涅槃寂静是无为标相。论或解脱门了所知境。谓空无相无愿如是等。彼疏云。谓离系涅槃称为解脱。空定诸心所是趣入涅槃所依之门。此中即以空等三空门。以了前境即了所知诸法是空及无相。释曰。二性之义已略备矣。其尽所有唯是世谛。其如所有通于二谛。则显如来自相共相。若教所说。若法本性。无不证知如实觉故。故疏中但云双照二谛平等觉故。然二谛平等则二性无碍。无所不收。既无不知即是遍义。疏谓双照下。疏释第二义。彼经无正等下会四。经文言有影略。总皆含具于中。先例四别。后妙者微妙下会释。疏妙正遍最名义俱别。所拣异故者。妙拣取相。正拣于邪。遍拣不周。最拣未极。如初会说余义可了。疏今各句句配属者。以论中三节各一时并举。谓第一列经二十一句。第二本论一时立二十一德之名。第三释论次第一时牒释故。今各配摘成二十段。疏中文各有二。先释名义。后释经文。今初不二现行。先释名义中具指经论及释三段可知。但无性释论中先牒本论功德之名。后方指经如此段云。谓于所知一向无障转功德者。此即开示不二现行。下皆准此。世亲则先牒经。今疏皆先牒经。后引本论立名故。释名义中。且分为二。一牒经立名。二引释论。释初中其即观察如来五字。是疏义加。顺于此经观佛德故。余皆是彼论文。今初不二现行。先牒经立名可知。疏无性二释下。即第二引释论释。于中三。初无性释。二会二论。三无性生起。今初第一释内又三。初是论释。二此约离所知障下。疏取下生起中意以出德体。三非如下疏释论。第二释中此释二处下。疏会二义。疏世亲同于后释者文全同也。然世亲有四。一牒经名。二自解释。三举本论帖。四重释。如此段云。此中不二现行者(一牒经)谓二现行中无有是故名不二现行(二释义)即是于所知一向无障碍转功德(三举本论帖)非声闻独觉智亦有障亦无障故(四重释也)文多如此。疏亲光下。会亲光释一同此消文。疏无性生起云下。第三段此是无性释论。总毕重复牒初生起次第。而不晓者谓为再释。今亦摘其生起为二十段。句句别配此即蹑前总句生此别中第一句也。故前释云。此经约离所知障不染无知。即所知障体拣异染污无知耳。疏文中二下。二释文双用二论。初广利乐是亲光意。离所知故即无性意。下离烦恼即唯亲光意。若约亲光不二现行。双离二障双异凡小。疏定慧庄严生物善根者。释经以佛庄严至安住善根。言定慧者。即法华第一云。佛自住大乘如其所得法。定慧力庄严。以此度众生故。疏能住所住二俱广大者。所住即法界身遍一切处故。广大智称法身等。彼真性如日光合空。疏具上二义下。结归总句兼例下文。疏第二智慧下。第二德中亦二。先牒经立名。后无性下引释论释。于中又二。一明无性生起。即无住涅槃五字是疏。余皆是论。二然无相法下。疏取释论释。然疏双用二释论文消经及本论名。理无不尽。而文或取舍无性具云谓此真如有圆成相。无遍计所执相。由此道理明无二相。无有无相是实有故。无有有相所执无故。最胜清净能入功德者。谓即真如最胜清净一切法中最第一故。远离一切客尘垢故。于此真如自觉能入。亦令他入。是故说名最胜清净能入功德。世亲释云。趣无相法者。谓清净真如名无相法。趣谓趣入即是于有无无二相。真如最胜清净能入功德。谓此真如非是有相。诸法无性以为相故。亦非无相自相有故。于此无相真如最胜清净能入故。释曰。观上二论以对疏文昭然可见。疏遍住物身心真如性者。如有偈云。我今解了如来性。如来今在我身中。我与如来无差别。如来即是我真如。疏为欲得上下。第二引释论释但有生起义在释文之中。疏文中下。释文为二。从多而言。前段即释经。后段即释论。在文易了。而取论意。若具引释论者。无性论云。谓不作功用于诸佛事有情等中能无间断。随其所应恒正安住圣天梵住。非如声闻要作功用。方能成办利有情事。非如外道虽有所住而非殊胜。天住谓四种静虑。梵住即是悲等无量。圣住即是空无相等。世亲云。谓住佛所住无所住处(性空也)谓此住中常作佛事无有休息(大悲也)今用二论以释经文。疏大悲性空是佛家故者。大悲是利他家。性空是自利家故。法华经明大悲为室净名云毕竟空寂舍。况二相导真实家也。故双安住从故能不住下。即上大悲般若所辅翼故。疏如上佛住下。无性生起也。疏一切诸佛下。蹑上生起以为问端。故今答云和杂而住此亦释经。从一切诸佛下。释论此但标名。文中别释三事。皆先牒名举释论释。后随经别解。初中放大已下是。疏二中普使之言下是。疏三中先明下是。疏此德世亲但配属而已。疏利他之中下。无性生起。谓已惯习下。释功德名。全是无性论文。从故论詺为修治者。是疏释。又已到下。复是无性论释。疏将属经故结云二文互显。从文中下。疏取释论意以释经文。疏由有上能治下。无性生起。从谓教证下是无性释。疏显示如来下。生起谓世八风下释即疏取意略释兼会亲光。以色等五尘是魔境故。至释文中方出释论。文中言不以无信生盲等而不现者。即第一回向中意。疏如有颂云。即无性论。疏由依前方便下。生起。从谓十二下。即疏取论意释。无性具云谓契经等十二分教名所安立。安立彼自相共相故。如是安立非诸愚夫觉所行故。出世间故。此所安立不可思议即是功德。疏云以上加行下生起。谓于三世下释义。即无性释。然前更有文云。谓于三世平等法性能遍游涉。谓于三世平等下。全同彼论。故下经下。证成以游三世。经不明显故以余义文中具之。疏显上利益下生起。义在文中易故不释。无性云。谓随所化遍诸世界示现两身利乐彼故。疏第十一下以于上十方下。生起。诸于诸境下。释义全无性论。文中二疑亦是论文。论但有两句云非于诸法自不决定能决他疑(此反释也)非离决定能断疑(顺也)疏但用上句。若准梁论。具四无碍智能自决疑。具四无碍辨能决他疑。疏菩萨智光月者。即五十九经偈。疏亦可属上现受用身者。此文通二势。上约属十一为自断疑。亦通第十其身流布一切世间。则别断他疑方属第十一。以属后为正故云亦可属前。疏深入缘起疑见亡故者。故净名云。深入缘起断诸邪见。有无二边无复余习。宝积偈云。说法不有亦不无。以因缘故诸法生故。由见因缘能断疑故。疏由所化生性有差别者。即生起也。谓入种种下。释义二论易故但以经属论而已。今疏释意以成就大觉属所知。即随种种心行差别化之。究竟至于一切智故。如释文中。故以法华开示悟入意释耳。疏由即于前下。生起。谓圣声闻下释义。皆无性意。疏如求度者远劫采薪者。即大庄严论第九。因说供养声闻得无量福。何况如来。便引此缘。昔有一人因缘力故发心出家。往至僧坊值佛不在诣身子所。身子观其无少善根。诣诸比丘。比丘先问谁不度汝。云舍利弗。如是展转皆不度之。如来大慈至僧坊门为说偈云。一切种智身。大悲以为体。佛于三界中见诸受化子。犹如牛求犊爱念无休息。以手摩顶。其人悲泣。具说不度因缘。佛说偈云。身子舍利弗。彼非一切智。亦不解体性。不尽知中下。彼识有齐限。不能深解了。无有智能知微细之业报。遂牵入僧坊与度得道。身子问云。我观此人无少善因。云何与度便得道耶。佛言。汝智微浅。此人过去无量劫前为一贫人。入阿兰若。山林取薪为虎所逼。以怖畏故称南无佛。种子今熟故吾度之得罗汉耳。故上云微少善根种子所随

疏。则第十一是自断疑者。若准无性世亲。皆十一断他疑。今顺亲光故为此说。疏由上善巧别知下。生起。此上是疏蹑前生后。无性但云即于所化有情邪正俱行中。所应现相不可分别耳。义在文中。疏而无性云下。会通释论。然无性具云。谓随有情种种胜解现金色等。虽现此身而无分别。如摩尼珠等及箫笛等。广说如彼如来密经。释曰故疏断之则顺今文。疏瞿波观佛毛孔即七十五经

疏。第十五中从为欲引发下。生起。从言等所求下。是疏释经义在释文。于中言此所求智即是无量菩萨所依者。即无性释。而言道下是疏释经。疏谓由无量菩萨至获得妙智。皆无性释。本论此下更有文云。异类菩萨摄受付嘱。展转相续无间而转。由此证得一切菩萨等所求智。释曰。此即疏中所成之智。谓依此智化生令生。成于此智故菩萨皆求。疏为遮所化下。生起。从由满诸度下。疏取意答前疑也。从言无二者。即无性菩萨以彼经文会于本论。从平等有二下。释义二义皆无性论。论云。依平等法身波罗蜜多果位成满故即前意也。论云。或平等者无减无增。于法身中波罗蜜多一切成满。其中无有或增或减。非如于彼菩萨地中波罗蜜多有增有减。释曰。即后意也。二中前义平等属于法身。后义平等属于诸度。然依法身是所满。诸度是能满。下亲光法身即是波罗蜜多。世亲同无性前义。疏和合识破即起信意。前文已有下复重明。疏以外人闻下。生起。谓一切如下释义。此是疏家总释经中不间杂义。疏但经云如来解脱下。会经论异。于中第一引二释论明本论同经。故云胜解名为解脱。云何胜解得名解脱。胜解于境印持为性。如于大地作黄金解便成黄金。一作多解便为多矣。斯则不思议作用解脱。如净名云得是解脱能令须弥入芥子等。二又胜解下。通能所化可知。三亲光下明离障解脱。四观今经下总收诸论。五加佛自离障者。以亲光但令众生离故。疏所以名不间杂下。随难别释。即是释经于中先问。后故所属不同下。释所属不同即无杂义。如千灯各异重重皆遍。是无间义。如光光涉入故上总言如冥室千灯。疏上则心有高下。即净名经意。螺髻语舍利弗。仁者心有高下。不依佛慧故见此土为不净耳。今指上化土是随心高下。今见受用是依佛慧。疏由疑上如来妙智下。生起。此但发挥前义耳。疏言方处者。即下疏略会彼本论及经。从此无中边略有四义下。总会论以释其义。初之四释皆无性意。然此四意者。一以世界为喻。二佛身满世界中。上二皆用世界。三法身遍佛地中。四以契中道故。然疏取意义则已周。若具无性之文云。谓如世界无中边。佛地亦尔。功德方处无有分限。或复世界方处无边。诸佛三身即于其中称世界量。平等遍满以法身即住如是诸世界中非余处故。或法身等于佛地中。平等遍满无中无边无有分限。或此法身等遍一切处。为诸众生现作饶益。然非自性无中无边。释曰。以疏四段对之可知。则亲光意同后一。疏以无碍智身无所依故者。即引出现品。成大圆镜智是无依义智。故彼文云。一切佛法依慈悲。慈悲又依方便立。方便依智智依慧。无碍慧身无所依。然无碍慧即根本智。收根本智收大圆镜故。余转依等义如十地说。四智之义已如前说。疏因惑为种下。释法身清净。清净字两遍用之。故云悉已。谓七识在因四惑相应。但能领揽内缘内熏而成种子。今无四惑即此七识能生自在。更不内熏故云尔也。疏总上诸义则有十身者。一就觉他翻明自觉是菩提身。二成就法身及显如如即法身。三四智即智身。四庄严妙好即相好庄严身。五无能映夺即威势身。六无数功德即福德身。七或现菩萨等即意生身。八令生离惑即是愿身。及九变化身。十业行所成现于世间。即力持身。故云具十。疏以上言无中边相下。生起。谓此法界下。释义即无性释。疏以斯则法界言下。疏会二论以就经文。常即前无性意。清净即亲光意。疏如来亦尔下。善友七事略无次第义无不具。前三通诸教。四从此已下即法华意。则于一佛乘分别说三。为权覆实会三归一示真实相。即以实覆虚上即法说周意。五着弊垢衣即信解品意。谓不说十莲华藏之相。故云脱珍御服而说三十二相等。为着弊垢衣。久证菩提示以三十四心断结等。为执除粪器。六即安乐行品轮王解髻明珠喻。一乘圆旨喻若明珠。昔为权覆如在髻中。开权显实为解髻与珠。七意亦通。疏谓于上利乐下。生起。从深密佛地下。疏辨开合。于中六。一约经论开合。二亲光开。三无著义合。四世亲下二论皆开。五同显无尽下。疏断开合。六今文下显今经意。虽合具无性二利义故。前段中已显常随不舍者。谓无性即自利。无尽虚空下。二句明二利无尽。今显极于法界。中已有利乐无尽。从为顺二论下释文。疏降老死怨者。净名云。譬如胜怨乃可为勇。如是兼除老病死者。菩萨之谓也。今借用之

疏。如涅槃说纯陀施福者。经云我今所供养虽复微少下。佛令汝具足檀波罗蜜。为果多也。疏则是如来最清净觉者。以在最后故复结之。句句亦皆合结也

疏。上所引下总显用文之意。兼结弹古人。疏若别配属义成偏近者。五弹贤首以后十结句科上二十一德之经。彼云然此所现佛法界身岂有限量。今且依下结文分为十门。于中二。先显十门之德。后如是下正结十门之名。前中即为十段。然案后结文少不次第。从初至清净善根来超明第十见佛示现不可思议自在神力门。彼约晋经与今小异。恐寻不晓会取今经。今经即至功德善根悉已清净为第一段神通自在第二已去全依今经。谓第二从色相第一下。却明第一如是信解门。第三获一切智放大光下。第二观察正觉门。第四示现色身不思议下。明入智慧门。第五恒以佛日普照法界下。第四入功德海门。第六以大慈悲现不可说无量佛身下。明第七正念现前观察门。第七以智慧月下。明第五普至虚空智慧门。第八放光明网普照十方下。即第八观察如来诸业相好门。第九为大法王如日普照下。却明第六如是而知众生福田门。第十清净第一离垢光明下。却明第九如是观佛普现世间门。释曰。此即贤首解为十门。以其总名收其别义。皆不尽理故云偏近。况结中不出内德外相。内德不出福智。如何摄得前文。诸德又刊定记科为十六三业。而段段之中三业多阙。亦消文不尽。故皆偏近。依今之释一句无遗矣。疏句各一位者。初信位。二增长是住位。三清净是行位。四成熟是向位。五调伏是地位。疏亦称五号者。一世尊。二善逝。三如来。四应供。五正遍知。然寻常略举下三。今加上二故为五德。疏有云下。叙刊定破经二未必然也总非。三谓初请入下。出其正理。彼破意云。谓入殿即坐。坐竟方叹。故合回文。今明初入殿竟。次即叹处请坐。后方受请。于理何失

大方广佛华严经随疏演义钞卷第四十六大方广佛华严经随疏演义钞卷第四十七

        唐清凉山大华严寺沙门澄观述

    兜率宫中偈赞品第二十四

疏。文中幢者略有五义者。刊定有七。今略其二。言一高出二建立者下。施幢旛中皆有其文。一高出者亦云高显。显即显现亦出义也。下经云愿一切众生建高显幢。然智慧灯普照世间。二建立者下。经云愿一切众生立坚固幢。悉能摧殄一切魔业。其刊定七中。一坚固义。二灭恐怖义。三归向义。四建立义。五高显义。六摧殄义。七不为他坏义。今以坚固即不为他坏。准上引经即建立中摄。又他不坏在灭恐怖中摄。故涅槃三十一云。修戒定慧如帝释幢不移转故。故略其二。谓不为他坏及坚固义。疏。归向义者。列众中有如灯幢为众所归。四摧殄者。七十八云。菩提心者如猛将幢降伏一切诸魔军故。言灭怖者。智论二十四明修八念能除恐怖。言八念者。于六念外更加息怨。于念三宝中引经证云。佛告诸比丘。释提桓因与阿修罗斗。在大阵中时告诸天众。汝与阿修罗斗时。设有恐怖当念我七宝幢恐怖即灭。若不念我幢。当念伊舍那天子(帝释左面天王)宝幢。恐怖即除。若不念伊舍那宝幢。当念婆楼那天子(帝释右面天王)宝幢。恐怖即除。以是故知幢为灭怖畏义。疏故下文慈氏座前等者。即六十七经优钵罗华长者中经云。善男子。兜率天中有香名先陀婆。于一生所系菩萨座前烧其一丸。兴大香云遍覆法界。普雨一切诸供养具。供养一切诸佛菩萨是也。疏一离障成身对等者。以文易故。疏不指经今当指之。二入一切土下入刹对。三于一念下。是四无量无数下是。五恒以净念下是。六以小入大下是。七获一切智下是。八一切如来下是。九则金刚下是。十已得诸佛自在神通下是。初得通。后于一切数下立法。疏从由离数下。释上立法。疏谓世俗幻有下。别示真俗镕融之相。相从缘生举体即空。理非断灭。故常自有。然有三意。此上第一当体以明。二有是空有下。明二谛交彻成上即有是空即空是有。三有空空有下。结成镕融。即仁王云。于谛常自二。于解常自一。通达此无二。真入第一义也。从菩萨智契下。结成能立。第三偈赞。疏总显回向不出悲智下。总文分四。一摽。二即悲下双出悲智为金刚义故。三七十八下。引证悲得金刚之文。四故知金刚下结弹。以今古诸师皆唯般若喻金刚故。不观文中下。成上失意。以金刚经具悲智为金刚故。彼经云。佛告须菩提。诸菩萨摩诃萨应如是降伏其心。所有一切众生之类。若卵生。若胎生。若湿生。若化生。若有色。若无色。若有想。若无想。若非有想。若非无想。我皆令入无余涅槃。而灭度之(悲济九类也)如是灭度无量无数无边众生。实无众生得灭度者等(大智而无所度也)故疏结云悲智双运。疏然夫进修略有五法者。释此三偈。自有二重。一约五法。即智论文。天台取之为二十五方便。此第五五。止观具云。谓前二十法虽备。若无乐欲希慕心。(一)身心苦策(二)念想(三)方便(四)一心决志者(五)止观无由现前。释曰。上即反释。下顺释。云若能欣慕无厌(一)晓夜匪懈(二)念念相续(三)善得其意(四)一心无异(五)此人能进前路。一心喻船柁。巧慧如点头。三种如篙橹。若少一事则不安稳。无此五法。事禅尚难。何况理定。疏又慈氏论下第二九因释也。即瑜伽论。从人詺论。是其造故。醍醐喻经即涅槃经。经有五味。从牛出乳至于醍醐。醍醐喻大般涅槃。故事即三十八经。明三十七品。根本是欲因名明触。摄取名受。增名善思。主名为念。尊名为定。胜名智慧。实名解脱。毕竟名为大般涅槃。广如经说。今即瑜伽引经。故经论无违。疏欲为根本者。起希望故。二作意所生者。数数警觉故。三触所集起者。和心心所对胜境故。四受所引摄者。领在心故。五以念为主者。常名记故。六定为上首心澄寂故。七慧为最胜者。择善恶故。八解脱为坚固者。息缠缚故。九出离为后边者。觉道满故。从有前下总结释。疏次句触集及受者。即于佛得见佛闻法。皆是触对见闻必领在心也。次句定及解脱者。修即心定澄寂也。清净为解脱可知。后句履佛行道即已出离觉道满故。疏因缘和合方能见者。正同金刚经云。如人有目日光明照见种种色。但彼以般若日为法中明心不住法。则内心自有因缘。不同佛力为日也。疏以因夺缘者。因即精进力。言如出现品者。谓佛光救地狱众生生天。便即念言。此是如来威神之力。佛便报言。此非如来威神之力。若一众生于如来所不种善根。能得如来少分智慧。无有是处。是也。疏非谓是非化者。此一向是遮。即拂迹入玄耳。故昔人云。我言非有者。但言非是有。非谓是非有。如人夜见于杌谓之为人。智者告言此非是人。但非其心中计人之执。愚人闻之便谓此杌。是于非人。非人即鬼故。人执虽无。鬼执即起。故为惑耳。故释云上半绝待。则化与非化两亡。疏二不碍化故者。即重释亦复非非化。此即以化遣于非化则上句非变化者即是真身故。亦复非非化者有化用故。前释上半是体下半是用。今此则上半自具体用。依于后义广释经文于中二先总明。然约二身自有多义。一法报合为真身。应化合为化身。二法身以为真身。报应皆为化身。今依此义故云非谓三身独一是化。疏且依真下。第二开章别释。初开义中言各二义者。即真同真如。化同依他。各有二义更无别也。如前已释。但前通相说真如依他。今就佛身以说二义。疏揽缘无性者。则知报身亦缘成义耳。疏二融合等者。真化别合者。即真如上二义自合依他上二义耳。各成四句且真中四者。一真。二非真。三俱。四泯。以前二义易故不明。又是合故不开。但明后二句化中二义亦然。疏二融通者。即将真如二义。与依他二义互相收摄耳。文有四节。前二节明四义交络相融。三复融上二。四真化镕融下。结成一味法界。四中一取真如不变义。与依他体空义合。由在缘不变故显体空。体空即真如。此即真理夺事故真不无。不变体空即是真空。化不有者。依他全体空故。二又由真随缘下。取真上随缘与依他幻有合。此即真理成事门。故化不无以能成事故。真不有举体随缘故。又上二义第一含事能显理门。故云不无化用以有化中空义故。由化生即空故能显理第二义中兼得事能隐理门故。故云不无真理。但随缘耳。疏又由随缘幻有下。第三总融上二以前各别合中。二义已融今复真化互合故。四结可知。疏菩提是有法。定不系时故是宗法者。因明疏云。前陈是有法。后陈是宗。法与有法和合为宗。言有法者。由于前陈为所依。能有后陈故。有法但是持自性法无有轨义。后陈具二。谓由不计时。知是常法如由无常。知是有为等。作初偈量云。日体无分别。不与昏夜合。如来无分别不与三世合(菩提是有法定不系时是宗法因云无分别故同喻如日轮与偈合之日体无分别等也)二约非世为因。菩提是有法。定不系时是宗法。因云体非三世故。同喻如日轮。以偈合云日不属于时。不与昏夜合。佛非世法故。不与三世合。三约超诸数。释菩提是有法。定不系时是宗法。因云非有为故。同喻如日轮。偈云日轮无出没。不与昏夜合。如来非有为不与三世合。又若以超时现时等四句皆宗者。若依前释上二句牒妄情。今将上二句合在下半。成经偈云。如来得菩提。实不系于日。而随众生。说某日佛成道(菩提是有法定不系日随机说日是宗法因云体非三世不碍三世故同喻如日轮日体恒明随映见殊不合昏夜佛体湛然随机应已超三世说三世)故疏云定不系日。随机说日是宗法。而出因云。体非三世不碍三世。等者。等取无分别不碍分别。非有为不碍有为。合等可知(菩提是有法定不系日随机说日是宗法因云体无分别不碍分别故同喻如日轮日离分别随时殊不合昏夜说昏夜佛无分别随机应己离分别说分别菩提至宗法同前因云体非有为不碍有为故同喻如日轮日非有念随时殊不合昏夜说昏夜佛非有为随机殊已超有为说有为)若作偈者五言即云。日明映山故。无时说昼夜。佛体不碍用。常住说三世。若七言云。日体恒明随映殊。不合昏夜说昏夜。佛体湛然随机应。已超三世说三世。对上三因亦应云日离分别随映殊。佛无分别随机应。皆可意得。第七菩萨。疏义亦然者此含多意者下。出三意。一释三身及与佛义。体即法身。依是报身。聚是化身。从所觉已下释佛义。所觉是法身。能觉报身。觉他是化身。二又义名所以。明成佛所以。即具众德故。问明云。一切诸佛身唯是一法身。一心一智慧力无畏亦然故。三又应用下。即约利他辨同。言法身作五业者。即应化法身。言五业者。世亲摄论第十云。第一救济有情灾横为业。于暂时见便能救济盲聋狂等诸灾横故。二者救济恶趣为业。拔诸有情出不善处置善处故。三者救济非方便为业。令诸外道舍非方便求解脱行。置于如来圣教中故。四者救济萨遮耶见为业。授之能超三界道故。五者救济诸乘为业。拯拔欲趣余乘诸菩萨。及不定种性诸声闻等。安置善处。令修大乘行故。于此五业应知诸佛业用平等。若梁摄论当第十五。疏二十一种功德下。即指上品所释。谓所依智等三事佛佛平等无性。亦明是利他德。疏二约十身下。先正释同义。后此有三因下出因。第八菩萨。疏真如体净即第八回向中义。复净世间即今偈意。疏妄惑既寂真智不无者。拣异断空。开示下。即法华开示悟入意也。疏随念随现故名心等者。此有二意。一随念多少。佛亦等之如称一口有一化佛等。二随念浅深。佛应称之见有优劣。从又了心境下。约观心释即心即佛之义耳。第九菩萨。疏谓法性身者。此初一偈。上三句约四身说遍。第四句约十身说遍。此十身正说众生国土等十身故。则有虚空处即虚空身。国土处即国土身等故。无非佛身矣。第十菩萨。疏上十菩萨下。总结。言六相者。一总显佛德。二别则十种德殊。三同则同明佛德。四异则十德互望不同。五成则共成佛德。六坏则各住自性。从所以偈后下。彰无结意。此后一段前二会无。此后例前二会无。亦是三贤之最后故

    十回向品第二十五

疏。二释名中文有二。先得名。后释名。前中二。先总。后然十之别名下。别释。于中三。一成三回向。二开三下开三为十。三会十归三。就第二中。四回因向果。言如深密瑜伽等者。深密第四观自在菩萨白佛言。何因缘故波罗蜜多名波罗蜜多。佛告观自在菩萨。五因缘故。一无染着。二无顾恋。三无罪过。四无分别。五正回向。乃至云正回向者。谓以如是所集波罗蜜多回求无上大菩提果是也。言瑜伽者。即三十七云。云何菩萨无倒回向。谓诸菩萨三门积集所有善根。即善修事业。一方便善巧。二饶益于他。三去来今世一切摄取。以纯一味净妙信心回求无上正等菩提。终不用此所集善根。希求世间余果异熟。除无上正等菩提。梁摄论第十云。由般若回向前六度。为得大菩提故。施等无尽故。般若能引方便。又释方便波罗蜜中云。内欲为利益诸众生故。所作善根功德悉皆回向无上菩提。言等者。无性世亲皆同此说。无性释云。若以此善根求无上正等菩提者。为证无上佛菩提故。世亲释云。所有善根皆悉回向无上菩提。作诸有情一切义利。释曰以文易故。疏但略指。疏六回比向证其文非一者。以文多故。若取现证即前第三中心未净者令得清净。清净即净心地。净心地即初地。未净即比是。回他比令他得证亦是自比。令他得证等。疏八回差别等者。初列忏悔等五门善根。为差别善根。一一回向中皆愿成普贤圆融行故。疏十回顺理事行。向理所成事者。谓初积集资粮位中双顺事理。即志求大乘猛勇无畏等事行。植般若德本深心不动。心宝成就等即顺理行。以言向理所成事者。谓百门真如况所成行即理所成也。疏前十义中下。第三会十归三。疏若依总云下。第二释名。疏因果主伴具足者。因主即金刚幢力。因伴即听者善根。果主即遮那二力。果伴即十方佛加。谓法因下。出五因之由。法因久远愿遂将化是遮那本愿主伴加威即及威神力为主加威。十方佛加为伴加威。疏亦犹十地前十自利等者自利即同所成。利他即同所作。疏然约行布下。结释。明非全取十地中义以释今文。故疏上云亦犹十地。犹者如也。但云如二利其中句义则全不同。言地约说地此约回向者。彼云如实说菩萨十地差别相故。此云所谓说菩萨十回向。居然自别。言况彼义皆次第者。彼中次第显于地前地上等。谓彼云缘念一切佛法故。修习分别无漏法故。此即地前。次经云善选择观察大智光明巧庄严故。即是见道。次经云善入无量智门故。下六句辨修道。此句寄从二地至七地。次下五句寄入八地至佛地。则自浅至深。地前地上见修究竟次第不乱故。今则反此者。明不依彼次。如今经文无彼地前地上见修等。次文之与义俱不全同故。但可云如彼不可依彼次第释也。上之十句所成亦然。但可类耳。疏初三明有作净法力等者。此亦取论势而句多少所用不同。彼十句中初总余别。别中初句他力。下八自力。自力之中二。初一句有作善法净。经云普净法界故。次一句教化众生净。经云普摄众生故。余有六句皆名身净摄为三种尽等。今则有作有三句。无作有二。身净有三。又阙教化众生者。以依次无故。摄在初有作净中。而言四净者。以因中有四义故。一有力能作。二无力不能。三具二能引生。四泯摄前三。称理成德如次配前四净。余广如彼。以句开合不同。亦可类取耳

疏。此是地前有三尽下。通妨可知。从又前加下。亦辨三贤望于十地。事须差别不可全同也。疏然此十句大同地经者。比前诸段彼不全同今为大同。既唯一句前却故得全引。彼释所以。此多同者以有智辨令其有说。则得大同前就所说故小异耳。此中十句须观下十地经。疏不可具引随要略引。言三种同智者。即自相共相及不二相。自相者色心等殊。同相者同无常无我等。不二相者即一实理也。疏或六七前却者。六即不畏辨才。以经云不思议善观察三昧。同彼如来无所畏故。七是教出辨才。以不可沮坏一切善根是教出故。大同地经成道自在故。疏六种正见者。一真实智正见。二行正见。三教正见。四离二边正见。五不思议正见。六根欲正见。疏今初若直就经文下。先按经释。后若取论下。依论势释。前中先释文。后故收前后下。摄为体性。前中先别释三句。后然总论品内下。总显难思。前三句中释第二句。自有四义。一以体释不思议。以用释大。二双约体用释不思议。三体用双融释不思议。四约三大相融释不思议。疏即是广大不颠倒心者。四心之二至第八回向当广引释。救护众生即广大心。离众生相即不颠倒心。上释救护等竟。次回向是行下。以第一别名对总回向。以辨得名。三明知下结弹古义。以救护言为所回向故。四将坠下。别释救护二字。第二不坏回向从所回善根得名。三通能所回悉皆等佛。四从所回向立名。五从所成德。六从所回。七通能所。八亦通能所善根皆同如故。第九从能回向心得名。第十亦通能所回。及所向法界立名。疏二通论一一中下。疏文有五。一总摽有三。二此三各有二义下。明成三之因。三所以下。立三所以。四又此三者其必相资下。融通三相。五结成圆融。今初可知。疏此三各有二义者。第二成三之因。言必由众生者。若无众生菩萨不修行故。即由上义故此修善属于众生是彼之分。如父资财而子有分。言余二流故者。同上必由众生而成。为菩提故为实际故。而修其善即是二流。从菩提分故下。同上是众生之分。一切万行皆菩提分。分亦因义皆称实际。即实际分耳。疏二凡是菩萨下。前就境明。此就人说。又前以人从法。此则摄法从人。又前是顺释。此是反显。疏所以要须三者下。第三立三所以于中二。先取三类。后通约所成。前中有十文。有标列释结。疏一依三法者下释也。三法即智论意。亦三般若及三大也。文中但出三大。真性实际即实相般若。观照即观照般若。资成即是眷属般若。以不同三般若名。又不摄五名故略不配耳。疏二灭三道即三杂染。谓烦恼道业道苦道也。疏三净三聚者。故法集经云。若菩萨舍于三聚回向之心。菩萨不应与彼共住。疏四显三佛性即涅槃意。以第一义空是正因性故。了因虽通万行成于菩提究竟了故。了了见佛性故。缘因亦通万行成于菩提对上正因今以菩提照了故。以向生为缘耳

疏。五成三宝。诸佛所师所谓法也。以法真常体性离故。以众生同体。故我向之。次四但列不释。下但云如次配之。六法身即所证之实际故。报身即能证菩提故。化身为众生故。七证实无惑故为断德。菩提是智。化生是恩。不在言也。八言实相菩提者。下经云。譬如世界有成坏而其虚空不增减。一切诸佛成菩提。成与不成无差别。合中上句即实智菩提。下句即实相菩提。净名云。菩提者不可以身得。不可以心得。寂灭是菩提灭诸相故。九证三涅槃。于中先正释。后若依地论下。结弹地论。地论但说性净及方便净。方便净即真净。今明真净即圆满净。万德俱圆相累俱寂故云圆净。迹尽双树机尽应移故。是方便净也

疏。十安住三种下。此义深难。又复最后故偏释之。释解脱中具有三义。一自解脱。二解解他。若自有缚能解他缚无有是处。三化众生即作用解脱。余如前后说

疏。以斯下结例。先结前。后若立三种菩提下。例释。于中先例三菩提心。即起信云信成就发心者。发于三心。一是直心。正念真如法故。即向实际。二者深心乐修一切诸善行故。即向菩提。三者大悲心。救护一切苦众生故。即向众生。则亦用此十而成彼三。后又此十内下。展转相成成百。三门可知

疏。第四定位有三。初约五位。二略指前文。三约教料拣。今初有二释。前属资粮。后属加行。前中引庄严论证。即第七论偈云。行尽一僧祇。长信令增上。众善随信集。亦具如海满。长行释云。若诸菩萨行。行来一阿僧祇劫。尔时长养于信方至上品。于信增时一切众善随信聚集亦为具足。如大海水湛然圆满。次引唯识成上庄严。后引杂集。转证唯识及上二文。杂集论云。云何菩萨依瑜伽地方便修行证无所得(问也)谓诸菩萨已善积集福德智慧二种资粮。已过第一无数大劫。此结前也。闻已随顺通达真如契经等法。如理作意发三摩地等。五位之义十住略明。广在十地。今但定位是资粮位。信至回向皆资粮故。疏有云此十回向下。第二明是加行。四加行义亦如初地。然有二释。前释即三藏意。言此文为证虽不分明者。以但云四是胜解行摄胜解行位即通指地前。设四加行在回向后。岂不亦是胜解行摄。以四善根未入地故。疏一云四加行中世第一摄者。即真谛意。杂集亦云愿乐行人自有四种。谓十信十住十行十回向。为菩萨圣道有四方便。或有四十人。如须陀洹道前有四种方便。此四十人名愿乐行。于第一阿僧祇修得圆满。亦于地前无别加行故。疏结云则无五位。疏余约四位下。即第二略指。而言等者。彼有十门故。一约五位。二约四住。三约十二住。四约十三住。五约十三法师。六约五忍。七约五十二位。八约四十二贤圣。九约六种性。十约四十二位。圆融兼第九中含于楞伽无复次位。并指如前

疏。上来多是下。料拣即依五教。后四一始教。二有说三贤下终教。三有言一切下顿教。四若依当部下圆教。于中二。先正释。后然与下句数对前融通。疏第五行法差别中。先正释圆融。则一回向行具摄诸回向行。二行布如向所释。别名义中后有以十向配于十度者。即北京李长者释意以名收之。亦有理在者。一救护众生离众生相似施。二不坏似戒。三等佛似忍。四至一切处似进。进故周遍。五无尽功德藏似禅。禅摄德故。六随顺坚固。顺般若故。七等随顺众生同方便故。八真如相似大愿故。九无缚着。似力故。十法界无量似智入故。欲显多途不坏行布。四十位中多分相似。故为此收而一一位中多列诸度。又如第六广说于施。故非正义。故云亦有理在。第五说分。疏又本业云下。先标以空涉有。即先明离众生相。后救护众生也。言不受而受诸受者。受即五阴。及与六受。由了无相故不受诸法。为物现在见闻觉知故而受。又已超五阴现生之阴也。故净名云。以无所受而受诸受。未具佛法亦不灭受而取证也。回易转化者救护非一故。疏今初古人下。文中四。一叙昔。二若顺前名下申正义。三以是初行下通妨。妨云何以将总体为别体。故为此通。四若以为欲下。纵收古义

疏。五怖畏中含三道故者。恶道怖畏苦也。恶名是烦恼。大众威德是业。若举其因五皆烦恼。又死及不活。烦恼为因。余少功德。即是业也

疏。根本不觉者。即起信文即最初无明

疏。一大事义已如初会疏。一福德之轮已圆等者。每句之中有法喻具足。一如日轮圆满为喻。法合即是福德已圆。二唯智一字是法。余通法喻。唯喻日轮广者。周铁围故。深者不分而遍等故。难测者通上二义。六三乘山谷者。十大山王如菩萨乘。黑山为缘觉。高原为声闻。谷兼众生少分可生者。余可思准。上辨中十藏前七者。一信二戒三惭四愧五闻六施七慧

疏。故第三回向明十种乐者。疏文有一等取余九。二无有等比佛三昧乐。三不可限量大慈悲乐。四一切诸佛解脱之乐。五无有边际大神通乐。六最极尊重大自在乐。七遍广大究竟无量力乐。八离诸知觉寂静之乐。九住无碍住恒正定乐。十行无二行不变异乐。疏又不思义法下。疏亦有一等余。二住种种身作诸佛事。三住平等意转净法轮。四住四辩才说无量法。五住不思议一切佛法。六住清净音遍无量土。七住不可说甚深法界。八住现一切最胜神通。九住能开示无有障碍究竟之法。减数十耳

疏。先救八苦。有一生苦。二老苦。三病。四死。五五盛阴。六求不得。七怨憎会。八爱别离苦。八难下当广释。疏尾闾壑出现品当明。疏问众生之苦等者。上略释竟。此下问答。答中三。初正明。二上来下料拣。三问若依下通妨难。疏此依梁摄论第十一说者。本论云。甚深差别者。若菩萨由此方便胜智。行杀生等十事无染浊过失。生无量福德速得无上菩提胜果。释论曰。如菩萨能行如所堪行方便胜智。今显此义。若菩萨能行知如此事。有人必应作无间等恶业。菩萨了知其心无别方便可令离此恶行唯有断命方便。能使不作此恶。又知此人舍命必生善道。若不舍命。决行此业。堕极苦处长时受苦。菩萨知此事已。作如是念。我若行此杀业。必堕地狱。愿我为彼受此苦报。当令此人于现在世受少轻苦。于未来世久受大乐。譬如良医治有病者。先加轻苦后除重病。菩萨所行亦复如是。于菩萨道无非福德故离染浊过失。因此生长无量福德故。能疾证无上菩提。如是方便最为甚深行盗等行亦复如是。涅槃仙预国王者。第十六经梵行品。因说一子地。迦叶难云。若诸菩萨住一子地者。云何如来昔为国王行菩萨行时。断绝尔所婆罗门命。下佛广答。先说慈悲竟。末云菩萨常作是思惟。以何因缘能令众生发起信心。随其方便要当为之。诸婆罗门命终之后生阿鼻地狱。即有三念。一者自念。我从何处而来生此。即便自知从人道中来。二者自念。我今所生为是何所。即便自知是阿鼻地狱。三者自念。乘何业缘而来生此。即便自知我谤方等大乘经典。不信因缘。为国王所杀而来生此。念是事已。即于大乘方等经典。生信敬心。寻时命终生甘露鼓如来世界。于彼寿命具足十劫。善男子。以是义故。我昔为与是人十劫寿命云何名杀。疏近障天乐况大菩提惑习双亡者。释曰。此即大品经意。第一经云。菩萨摩诃萨行般若波罗蜜。增益六波罗蜜时。诸善男子善女人。各各生欢喜意念言我等常为是人作父母妻子亲族知识。尔时四天王天乃至阿迦尼吒天皆大欢喜。各各念言。我等常作方便。令是菩萨离于淫欲。从初发意常作童真。莫使与色欲苦会。若受五欲障生梵天。何况阿耨多罗三藐三菩提。以是义故。舍利弗。菩萨摩诃萨断淫欲出家者。应得阿耨多罗三藐三菩提。非不断欲。从今言淫欲即是道下。诫劝得意之义。前已曾有法界品中更当广释。疏依解节经说有五乐初会已具

疏。顾复之义见于毛诗者。诗云。父兮生我。母兮鞠我。拊我畜我。长我育我。顾我复我。出入腹我。郑玄笺云。顾视也。复反也。言子离虽近犹步步反顾。又笺诗云。是顾是复者。顾念而复之。今菩萨于诸众生亦尔

疏。今初功高二仪而不仁等者。即肇论中文。侧用老子意。老子云。天地不仁以万物为刍狗。圣人不仁以百姓为刍狗。即道经道冲而用之章。注云。不仁者不为仁恩也。刍狗有二。河上公云。刍草狗畜即二物也。御注云。结刍为狗不恃其警吠也。大意明天地圣人无心恃其仁德也。今菩萨亦然。菩萨功高而不恃般若观空故。而弥昏者若无所知也。言高二仪者二仪覆而。不载。载而不覆。菩萨兼之。又但覆身不能覆心及万善等。言明逾日月者。日月之明不兼昼夜。大悲菩萨长烛幽昏。日月照身不能照心。菩萨智慧反此。无法不照。故下文云不求恩报即不仁等义也。疏然一一随相皆具如下诸句离相者。且如上向一切众生即安置众生于无所著法性回向等诸句。又如大般若随一离相遍历八十余科之相。如一清净遍历色等。今不欲繁文故各并一处耳。疏初十四句离所取相等者。此中即具五法。一相。二想即妄想。三名。四如如。其正智含在离妄之中。疏性自无著者。拣非修成无著。修成文在安置之中。疏众生了自性者。自性即真如。具不变随缘故

疏。九总显诸事能成因缘者。诸事即能回能向等。皆从缘生故。疏明上回向不出于十者。即总结也。言由后二句故无性者。二句即能成因缘及缘所起。以从缘起故无性也。言无性故无所著者。结归总句。安置众生于无所著法性回向也。以总该别故皆无著也。疏二离能取想下。疏文有三。初略释经文。二故大品下引证。三释三不同。二中引三经证。一引大品。二即光明觉。三大般若。今初即随喜回向品引文小略。若具经云尔时弥勒菩萨。语须菩提。若新发意菩萨。念诸佛及佛弟子诸善根。随喜功德最上第一最妙无上无与等者。随喜已应回向菩提。云何菩萨。不堕想颠倒心颠倒见颠倒。须菩提言。若菩萨念诸佛及僧。于中不生佛想。不生僧想。不生善根想。用是心回向菩提。心中亦不生心想。菩萨如是回向。想不颠倒。心不颠倒。见不颠倒若菩萨念诸佛及僧善根取相。取相已回向菩提。名为想颠倒心颠倒见颠倒。智论释云。须菩提答。若是菩萨以般若波罗蜜方便力故。能于诸佛不生佛想。及弟子诸善根中。不生善根想。一切法从和合生无有自性故。无有实法名为佛。是不生佛等想。是回向心亦不生心想。是故菩萨不堕颠倒。与此违故即堕颠倒。二光明觉可知。三若依大般若第二会。正当别行大品。文辞小异大旨无别。而大品所引经末亦云。若菩萨摩诃萨用是心念诸佛及僧诸善根。是心念时即知尽灭法。若尽灭法是不可得。回向心亦是尽灭相。所回向处及法亦如是相。而有人谓二经全别故。疏影略引之。皆明性空心无取耳。疏然小乘或说下。第三释三不同。略举三说。小乘有二。初即分别论者说想心见次第起。谓初发微想常无常等。次重起心缘前之想取为定实。后见成就于所取中执见分明。此即三心俱是倒也。若释名者。想谓取境分齐之相。见谓推求。心谓积集。此中想等体即是倒。皆持业释。疏或说一时。义分前后者。即法救论师。心想见三同时义分。唯见是倒。余二非倒。与见相应。为见所乱。名之为倒。是故见唯持业。余二依主。俱舍论主正扶此义。颂云。四颠倒自体。从于三见生。唯倒推增故。想心随见力。释曰。初两句出体。第三句废立。第四句通经。初出体者。谓边见中唯取常见以为常倒。见取中唯取计乐净为乐净倒。于身见中唯取我见以为我倒也。唯倒推增故者。废立也。此举三因以立四倒。一一向倒故云唯倒也。二推度性故。三妄增益故。余或无此三因。谓戒禁取非一向倒执有漏道得净涅槃。虽非究竟断惑证灭。而能暂时离染证灭缘为净故。断见邪见非妄增益无所转故。余贪嗔等不能推度非见性故。是故诸惑非颠倒体。言想心随见力者。通经也。谓有问云。若唯见是倒何故经言于非常计常。有想心见三倒。于苦不净非我。亦有想心见三倒。答理实唯见是倒。想心随见亦立倒名。与见相应故。行相同常乐我净。三四十二故此十二倒。依婆沙师预流永断见及相应见所断故。余如彼说。依此释名。想谓取境分齐。见谓推求。心谓积集。疏若依大乘下。虽标多说但出意。通性相二宗。在文可知。又有释云。若细分别想心二倒可通七识。见是执着局于六识者。即下三藏意。七识既有四惑中。有我见岂无见耶。疏诸宗异说等者。不欲繁文。然上已有三宗之义。其萨婆多中更有一释。想谓于无常苦不净中妄想分别。见谓即于彼所分别中。忍可欲乐建立执着。心谓即于彼所执着中。贪等颠倒皆即心所名心。非心王也。既以王为所。不顺今文。故不出之。大乘之中复有三说。一依起信三倒之中心唯一妄念。亦名不觉。亦名无始无明。而此无明全依本觉还迷本觉。从无始来念念相续未曾离念。即是一切心识之相。然依不觉复生三种。一无明业相等。即以三细业转现三。如次为心见想之三倒也。今菩萨虽未究竟觉已离凡夫不觉。二乘初心相似觉故亦名为离。释曰。以三细诸德正义皆在赖耶菩萨地尽始觉同本方得永离。以此而为三倒。非顺今文。故疏不出。二又依禅宗传于达磨。同楞伽意五识带想总名想倒。第七染净别名心倒。第六意识起诸见倒。释曰。不顺法相故不出之。三云依唐三藏传慈氏论。五识现量总无颠倒犹如明镜现众色相。故第七染识有想心倒。第六意识具有三倒。取我法相名为想倒。于想爱乐复名心倒。于想计着建立乃名见倒此亦分明。上之大小乘大同小异故不委存。恐要委知故复出耳。初释经文乃通诸说。多同唐三藏意

疏。四有四句显如如下。先彰大意。以诸宗或说妄空真有。二真空妄有。三真妄俱有。四真妄俱空。此具四意前明名相。妄想皆空即妄空也。此显如如理有即真有也。而疏云一切皆空者。则涅槃菩提亦空计有为妄情故。又言一切妙有者。即众生善根亦皆妙有。万法即真故。次云又即前之空是此之实者。上明前空此有。今即前之空是此之实。即空即有则空非空。此有即空则有非有矣。由此则妄空真有。即是妄有真空。何者谓虚妄之法。缘生无性名为妄空。真性湛然名为真有。今即上妄法缘生故名妄有。性名为真谛故说真空。此无性空体即是实故即无性有。是故言语则别理无二致。从是即妄名真。回向下。结成本义。此即妄空真有意。然但取除其病而不除法故。于相历然而无取着耳

疏。如此则德本不生者。此是真有本有湛然不生。妄惑本空空无可灭言。又惑累寂然不生。翻上惑不灭为不生真德湛然。不灭翻上真不生为不灭。前惑空无可灭。今空则寂然故不生。前以真无初故不生。今以真无后故不灭

疏。又前明随相等者。上判会菩提入实。即是离相中义。今以小异分之。则可为三。第一随相回向。第二以前会众生入实为离相。第三以今文为随离同时

疏。而言二者善根回向等者。此有四二皆蹑前文。一善根回向为一。二即向言善根亦如是回向亦如是。以总收前二故。二者世与出世为一。二即今经以善根随顺出世。则能随顺是世故。三若有若无为一。二即前妄空真有是四。若即若离为一。二此曲有二。一即随相为即。离相为离。二随离不同为离。此二不二为即。此四种二今并无之。无之所以即下释成

疏。亦同净名布施回向等者。即无尽意菩萨章。即是回向一切智性。下经云。如是持戒忍辱精进禅定智慧。回向一切智为二智慧性。即是回向一切智性。于其中入一相者。是为入不二法门。释曰。但知初度余例可知。故不广引。次疏云斯为不二者。结彼经文以释今经。谓以今经不离是彼一性故不二。以今经非即。重遣不二。则如文殊离诸问答。乃至为真不二。疏文影略者。亦合云业非一切智然不离一切智。而别有业故。云理应因果各有非即非离之义。疏余略不颂。即不颂受恼救护二。迥拔护救也。第二不坏回向故本业云证通事理但有名用事也。念念不住故名不坏者。单取不住。即是刹那无常合是坏义。以无所住故名不坏。则是理不坏义耳。准下供具等皆通事事无碍。疏云不出三宝四信者四信即三宝外加一。然二文不同。若起信论即是真如故。彼论修行信心分云。略说信有四种。一者信根本。所谓乐念真如法故。二者信佛有无量功德。常乐亲近供养恭敬。发起善根愿求一切智故。三者信法有大利益。常念修行诸波罗蜜故。四者信僧能正修行自利利他。常乐亲近诸菩萨众求学如实行故。故下疏云其中理法即信真如。二若准璎珞下卷。四不坏信。前三信三宝。四是正戒。云从今时尽未来际。归依佛归依法归依贤圣僧。归依戒法。如是言说故。故疏云二恶止善行行亦摄于戒。意取为第四信故。四既不定为十何爽。疏前中即双向众生菩提者。以初回向一切智故是菩提。次下二教化调伏一切众生等。即向众生故。下疏云即回向众生意。疏非唯不碍随相。亦能成此随相者。不碍者。如空不碍万象。能成者。如无水即无可为波。亦如无空不能起云霞烟雾。不碍即相遍门。能成即相成门。即理成事。以有空义故。一切法得成也。疏由前法性相应。故随生死而不变下。正辩离相成随相也。此句由与法性相应故。是离相故。法性即是真如。真如随缘故能成事。不失不变故而不改。下九例然。细寻前十一一相对可知。疏由前事不碍理故触境了如者。前之十句离相成于随相者。由理不碍事故。今成离相。由前事不碍理故。上总释意。二于中下总科三。亦如次配。前者从头别释。即配前与诸法性相应回向入无作法。成就所作回向等十句。而前随相行成举前回向。离相为能成。随相为所成故。前云由前法性相应故。随生死流而不变等。今此则举前随相不碍成此离相。若事碍理不即离故。近蹑前事。亦远蹑前离相。谓由前回向与法性相应故。今成了心性之行。二由前入无作法成就所作故。成此知业如幻等。三由前舍离一切诸事想着故。成此中出生无著清净法眼。四由住于无量善巧故。成此具菩萨行。五由前永出一切诸有故。成此于一切相皆无所著。六由前修行诸行不住于相故。成此善能修行同事诸业。七由前普摄一切善根故。成此于白净法恒无废舍。八由前普净一切菩萨诸行广大回向故。成此离一切着。九由前发无上菩提心故。成此离一切着。此句难解故。疏云了菩提性无有二唯一实故。十由前与一切善根同住故。住无著行。十一由最上信解等。即前第十一句。此中对前文小不次。而白净法两重用之。第七已用故。第三回向。疏兼显无间者。上引本业。但证等善根。以云一切时行故云无间。此从所等下。结得名。从以深入下出体性。疏然佛德已圆下。显文意亦是通难。先出难。从尊重荷恩下释。亦犹献芹者。即外典中事。野老美之而献于君。君岂美之。疏二即天住等者。智论云。天住所谓四禅圣住。谓三解脱梵住。谓四无量皆通三乘。今皆约一乘果位故皆无量。疏五种类俱等者。即三种意生身中第三。从十地得至于佛果同增胜耳。而非生死但取变化身耳。三种之义第六回向当辨。八自在我者。即涅槃二十三经云一能示一身以为多身等。二示一尘身满三千大千界。三能以满此三千大千界之身。轻举飞空过于二十恒河沙等诸佛世界而无障碍。四心自在故而得自在。云何自在。如来一心安住不动。所可示化无量类形等。五根自在一根见色闻声等。六以自在故得一切法。谓无得而得等。七说自在故。如来演一偈之义经无量劫。八如来遍满一切诸处。犹如虚空虚空之性不可得见广释如彼。皆明无得无作而有所成故云自在。今但略列而已。十二行永亡者。即上二十一种功德第一。已如前辨。疏三从次满者。此义该下诸句即次第满义。初句信满。二十住满。故晋经云未净直心。证成此句是十住义。十住直心增故。故云心未得净者令得清净。疏各如次第配者。如云不离见佛即由前念佛圆满所成等。净诸神通即是常见佛益。由此句似隐故。疏释云念佛三昧能发通故。于佛法易反复者。即净名第二。凡夫于佛法有反复。而声闻无也。以声闻断结故。下云终竟回心拣异定性。下当广引。疏亦是迷异熟愚众生。对前迷胜义愚。亦如前释。疏然古德将为结上等者。贤首云三结叹相。光统云。此结上三道究竟之义。行等行者。结乐与佛成证道行。积聚等积聚者。结与菩萨成中道行。长养等长养者。结与众生成不住道。远公云。证心游理名行。一备一切名等行。助道渐满名为积聚。一一行中具一切行名等积聚。不住渐增名为长养。一一门中各摄一切名等长养。轨法师云。但起一行名之为行。总众多行名为积聚。增进胜前名为长养。由是前行异名显耳。菩萨所行行既无量不可备举。但等言之故皆云等也。正法师云。善根等者。施等善也。以大愿摄取者。愿大故行大也。行者二利也。等行者等行一切行也。积聚者积行成德也。等积聚者。成一切德也。长养者。从行生行也。等长养者。生一切行也。辨法师云。行者是佛于愿乐位中所行菩萨以大愿。摄同彼行故云等行。积聚者。是佛功用位修积聚。菩萨同修名等积聚。长养者。是佛无功用位修。菩萨同修名等长养。是故上云如佛回向开化一切菩萨。回向亦复如是。此之谓也。贤首云。今更释者。菩萨所有善根。皆以大愿回向力故。令此善根摄成胜行。诸行齐行故云等行。又由愿力摄此善根所成诸行令不散失。故云积聚。有行斯积故云等积聚。又由愿力摄此善根所积众行复生诸行名为长养。一一行中生一切诸行名等长养。是故皆由愿力。令此善根。皆悉广大。具足充满也。静法云。释行及积集增长义则无违。而等字胜正。谓取等佛之义。则不见正字之意。又亦同古以为结前。故俱非也。所以疏云虽穿凿非一。并未会下文。下文积集增长皆有文故。疏若以等为平等。与正相近。亦摄义不尽者。但得回向实际意耳。向余二处及离过等皆不具也。疏前段亦是大悲随顺者。此中通有三意。一约所回善根。即如向科此下第二能回悲愿。二从若据回向下。约所回向。言是绮互者。正是回向绮互。向佛亦向生故。故云一时回向三处。三兼明上大悲随顺。及大悲深重。亦是绮互。绮互亦是影略。疏一离惑故者。即永离一切憍慢放逸。放逸是众惑之根。憍为染法所依。慢能长沦生死故。离此三诸惑皆离。余可思准。疏初总显深广者。为苦海故。余可思准。本即贪欲者。法华第二云。诸苦所因贪欲为本等。疏一切法无来是故无有生等者。此上半以无来释无生。而言等者等取下半云以生无有故。灭亦不可得。此以无生释无灭也。不灭故无有真实。有实则有可灭故。无实故无染。譬如云雾不能染空。故云五句展转相释。疏何名无相体离十相者。涅槃三十一云。大般涅槃名为无相。师子吼问何名无相。善男子无十相故。何等为十。所谓色相声相香相味相触相。生住坏相。男相女相。是名十相无如是相。故名无相疏又无。相约理下。上之四义展转相承唯明一体。此下分能所证以为无相离相。能所契合以为一相。则实际为总。下三别明。疏又如离世间下。有十种业者。即五十八经云。所谓随时开导是佛业。令正修行故。梦中令见是佛业。觉昔善根故。为他演说所未闻经是佛业。令生智断疑故等。恐繁且止。第四回向。疏至是能至等者。文分为二。先释名。后若克陈下出体。前中为四。一标能所至。二谓以大愿下。总示其相。文有三节两重能所。一大愿为能生。二善根等是所生上二皆能至。三一切处是所至。三本业下引证。四然准下文下。总明能至有其十种。前四展转以为能生。从第五已去。通由上四令此六种皆悉能至。五六约事至。七约理八事理无碍。九事事无碍。上皆约法。十即约时。疏或俱高俱下者。略成四句。佛化为佛本迹俱高。菩萨化为菩萨本迹俱下。就菩萨中以位相望亦有高下可知。疏上亦供行因者。即上释权化所由。以如来藏等力故。令供行至故为所因。疏三身十身融故者。出应亦常义所以。若法相说。应虽名常是不断常。今法性宗同是一常。若别说者法身无始无终。报身有始无终。化身有始有终。今化即法故即无始终。况报同法亦无有始。十身融义居然可知。疏香等离盖等更无别体者。如以香等为二十事。但有二十无二十一。以香遍二十故。类如栴檀为二十事。岂别有栴檀。后华等九事各为二十亦然

大方广佛华严经随疏演义钞卷第四十七大方广佛华严经随疏演义钞卷第四十八

        唐清凉山大华严寺沙门澄观述

疏。后如是一一下释此第三段疏文有三。初正释。二从无数下却释前二段中增数之相。三然一一诸言下。拣定言。定通香等者。香等十事为能成体。故得定通。言不全通于盖等者。盖等是所成。所成有二十事。如以香为宫殿则有楯等。香为光明何有楯等。况灯光明为能成。类前亦成盖等。以灯光明。成灯光明。此之光上难具楯等。故云不全通于盖等。以能成中有灯光明。所成之中复有灯光明。故略举灯光以示无楯等。例且如香河。河里如何安前楯等。明知总相则有别相。或无思之可见。疏此为入空之方便者。真空非得而无不得故。疏欲显随相离相无前后故者。释上正用前意也。欲将离相无得导前随相之有故。言义兼于后者。前意是结前。此意是生后。亦不住于离相故。疏准大般若下。例释无得为方便。如清净历一切法则以清净为方便也。若云无生即云行般若波罗蜜时。知一切法无生所谓色无生。受想行识无生。眼无生。耳鼻舌身意无生等。今此犹是略举能入方便广更有多故。复有等言。等取无依无作清净不增不减不垢不净不可取不可见不可动不可坏等。疏谓事法既虚下分二。初总释。次业空故下。别释。此有二意。一正以缘生即空破权小见。显业不能为因招果。果亦不能为果酬因。二兼破外道因中有果等。彼计因中有果者。如乳是酪因。乳中有酪。成酪之后亦有于乳。故曰果中有因疏若约观心者。上约法理通境及智。今约观心。但一是非有即名为寂。亦无心于事理。方称为寂。不失于照故名为用。不取用相即用常寂。疏此与初句但事理之异者。初句约理无入而入。今约事上无入能入。以诸法即事而能深入。故云即事入玄。疏大般若云下。引此文者拣义不同。谓般若意却是即用而寂。同上须弥山顶偈云无见即是见。能见一切法。于法若有见。是则无所见此偈则先正后反。大般若则先反后正。今此中意明理不碍事故意别也。疏末句不有能所见者。以文言不有于法。法通能所见也。何以得知法是能所见。以下句云悉知见故。即同金刚如来悉知悉见。疏待对假言故皆不可得者。出绝事理之意。一相待门。谓待事说理。待理说事。如因长有短短不可得等。二云假言者诸法寂灭本绝名言。今云事理皆假名耳。故皆双绝。上是疏家释成。下句经自释成。疏良以事虚下。出事理无碍之相。是总意。亦十门中相即门。是三义中无碍义也。广如上说。疏上四句下。总融前四。言有未曾损者。法即是空非法灭空。故有未始存者即空之有。有相虚故。言无隐无显者。事存则空隐。理存则空显。今由两亡故非隐显。言存没同时者。空不碍有故存。有不碍空故没。然隐显皆就理明存没。并约事说。亦影略耳。疏四句镕融下。总结。此则非唯离前随相。亦离离相真无碍也。真实际也。疏因缘故有者。然通相说。总有四义。一缘生故有。二无性故空。三缘生故空。四无性故有。今但取因缘二句。谓法从缘生安得言无。二从缘无性故名为空。上二即空有二门。从因缘故不有者。即明中道亦从因缘。谓既缘有。有即不有。既从缘空空即不空。合前二句即亦空亦有。四门之理皆从因缘。后因缘故流转下。辨生死涅槃亦皆因缘。乃至一切下。结例上。所明义略举纲要耳。疏故中论云下。引证皆从因缘。然论此偈前有一偈云。因缘所生法我说即是空。亦为是假名亦是中道义。未曾有一法不从因缘生。是故一切法无不是空者。前偈亦得证前四句成三观义。而后偈释于前偈故但引之。而论略结云是故一切法无不是空者。亦合云未曾有一法不从因缘生。是故一切法无不是假者。又是故一切法无不是中者。今此但取一切法从缘之义耳。疏有为缘生下通妨。妨云。涅槃云我观诸行悉皆无常。云何知耶以因缘故。若一切法从缘生者则知无常是诸外道。无有一法不从缘生。是故无常虚空如来佛性不从缘生是故名常则无为非因缘。何言为无为法皆从因缘。故今答云从缘有二。一从缘生有无常义。二约缘显何得非缘。故说佛性了因所了。岂非因缘生。此是一义。次云因有有为下相待门。释待于有为即从缘义。复云又形夺相尽者。要待形夺相尽故。真无为亦是从缘。疏论云若见因缘法则为能见佛者。上偈及此皆四谛品。下句云见苦集灭道亦可证第二句。疏尚无有二何况有五者。结弹五性。疏以业摄报等者。以经但云业境。今业摄报故有因果。境必对心故有内外。疏六即事显理而不坏事者。有为事也。无为理也。事能显理故。云于有为界示无为法。事即是理故不坏事。若坏于事成断灭故。下句反此可知。疏若灭坏有为下。反成上二。是以若约相即下。结成正义。于中略有数门。一相即门。二若约无碍下。即相成门。又云而非理而非事。即不相是门。即是事理无碍十门中六门。谓真理即事门。事法即理门。依理成事门。事能显理门。真理非事门。事法非理门。又前有形夺相尽。即真理夺事门。事能隐理门。通辨无碍即事遍于理。理遍于事也。八门非异不相是。二门非一故。疏结云为与无为体非一异也。疏示谓显示下。随难别释。第五回向。疏初三可知者。余即经五也。一忏悔。二礼敬三劝请。四随喜。五回向。回向在后。然昔有别章六门分别。一说多少。二释名。三出体。四释相。五明益。六问答。今并具之但略出体。总分为三初明开合即彼多少。二释名辨相。三料拣含余别门。今初。初为八行。言离垢慧菩萨所问经者。唯一卷经。大旨如常可知。二或合礼赞俱是所依忏悔故。三或略供养即但为六。供养亦属佛故。四或但为五。以回向发愿但总别之异者。二俱是愿。回向是总。发愿是别。是别发故。言如十住毗婆沙者。即第三初明至第四方忏悔。即今晨朝忏悔。是第五发愿。即涅槃经阇王发愿后人安之。五今文依此则同上有五。六或但有三即智论第七也。若依善戒即合为二。以礼赞是忏所依依人德故。回向摄愿亦摄随喜劝请。故结云随时广略。又随时者看临其时应用广略。然昼夜三时不宜阙也。疏然忏名陈露下。第二释文即释名辨相。四事即为四段。今初释忏悔。先释名忏悔二字古有二释。今疏即天台释。亦通汉梵二者。今释即半梵半汉。忏悔者梵云忏磨。此云请忍。悔即此方。体是恶作。厌先过失求请三宝。忍受悔过。单云悔者非是六释。合二即是依主。此上释名。二云除恶业障故须忏也。此辨忏益。亦忏意也。疏然忏有二即辨相也。疏如方等者。经中令先严净道场。香泥涂地及室内外。作圆坛彩画。悬五色旛。烧海岸香。然灯敷高座。请二十四尊像。多亦无妨。设肴膳尽心力。须新衣鞋履。无新洗故。出入脱著令无参杂。七日长斋日三时洗浴。初日供养僧随意多少。别请一明了内外律者。为师受二十四戒及陀罗尼咒。对师说罪。要月八日十五日当以七日为一期此不可减。若能更进随意堪任。十人已还不得出此。俗人亦得须办单缝三衣备佛法式。旋绕一百二十匝。却坐思惟等广如经说。佛名经常所见闻。疏如净名说。即优波离章。波离白佛。忆念昔时者。有二比丘犯律行以为耻不敢问佛。来谓我言我等犯律诚以为耻不敢问佛。愿解疑悔得免斯咎。我即为其如法解说。时维摩诘来谓我言。唯优波离无重增此二比丘罪。当直除灭勿扰其心。所以者何。彼罪性不在内不在外不在中间。如佛所说心垢故众生垢。心净故众生净。心亦不在内不在外亦不在中间。如其心然罪垢亦然。诸法亦然不出于如如。优波离以心相得解脱时宁有垢不。我言不也。维摩诘言。一切众生心相无垢亦复如是。唯优波离妄想是垢。无妄想是净。取我是垢。不取我是净。颠倒是垢不颠倒是净。一切法如梦如焰。如水中月。如镜中像以妄想生。其知此者是名奉律。其知此者是名善解等。即一向理观以呵事也。疏若普贤观经初令昼夜六时对十方佛普贤菩萨。遍忏六根即事忏也。复令观心。令此空慧与心相应即是理忏。如前释毗卢遮那。已引经竟。今时常用一切业障海皆从妄想生等。即彼经后总偈。皆事理双明随好品意。至下当明。疏言礼敬者。此牒第二行经。除我慢下疏释初明行益。以我慢故不能礼敬。今摧我慢山即是除恶起信敬善即是成德。二皆行益故勒那下。即辨相也。前七是三藏意。后三疏以义加。略无释名以易知故。然三恭敬礼云五轮着地者。离垢慧经云。一一发愿初总愿云我今五轮于佛作礼。为断五道离于五盖。愿诸众生常得安住不坏五通具足五眼。愿我右膝着地之时。令诸众生得正觉道。愿我左膝着地之时。令诸众生于外道法不起邪见。悉得安立正觉道中。愿我右手着地之时。犹如世尊坐金刚座。右手指地震动现瑞证大菩提。我今亦尔共诸众生同证觉道愿我左手着地之时。令诸众生离诸外道。难调伏者以四摄法。而摄取之令入正道。愿我首顶着地之时。令诸众生离憍慢心。悉得成就无见顶相。余义可思。疏言劝请者此牒第三行也下疏解释。除谤法下先明成益。二声闻自度下来意。三此文略下辩相。疏智论复加请佛住世者。如十住毗婆沙亦请住世云。十方一切佛现在成道者。我请转法轮安乐诸众生。十方一切佛若欲舍寿命。我今头面礼劝请令久住。疏占察经等者。经具五忏悔。劝请云唯愿十方一切菩萨。未成正觉者愿速成正觉。已成正觉者愿常住世。转正法轮不入涅槃。释曰。即具三也。疏次句因闻法故下。即经自辩劝请成益。了相作意等即七作意义如三地释。疏言随喜者此明第四行也。为庆下释先明行名。二除嫉下行益。三然十住下辩相。然智论多同十住婆沙。婆沙论云所有布施福持戒修禅定从身口意生。去来今所有习学三乘人。具足一乘者一切凡夫福皆随而欢喜。释曰。其初三句通三世佛也。疏大品随喜下。重示随喜成益。释上平等善根功德。初引大品即第十七。次引法华即第六经。随喜功德品第十八。尔时弥勒菩萨白佛言。世尊。若有闻是法华经随喜者。为得几所福而说偈言。世尊灭度后其有闻是经。若能随喜者为得几所福。经答文广今当略引。谓有人于会中闻是法华经。随喜已从法会出。至于余处转为人说。是第二人闻已复转为第三人说。如是展转至第五十。其第五十善男子善女人所得功德今当说之。若四百万亿阿僧祇世界。六趣四生充满其中。有人求福一一众生。与满阎浮金银琉璃。[王*車]璖码瑙珊瑚琥珀。乃至象马车乘奴婢人民七宝楼阁。比第五十人闻法华经。随喜功德百分不及一。乃至算数譬喻所不能知。下结云何况最初于会中闻而随喜者。释曰。此显功德多。从此据随喜如来权实功德者。疏出得多所以。大品但通明随喜之福。今就所随喜中分其胜劣。胜境随喜其福更多。言权实功德者。即是法华经。故经云此法华经开方便门(也)示真实相(实也)如来智慧甚深无量(实也)其智慧门难解难入(权也)于一佛乘分别说三从实开权也。十方佛土中唯有一乘法无二亦无三。会三归一会权归实也。世尊法久后要当说真实实也。佛以方便力示以三乘教权也。二十八品三周之文。但显如来权实知见。昔人云此华不有则已有则华实双含。此经不说则已说则权实双辨。明知法华不出权实功德耳。既穷终极唱难信难解。今能随喜故德难量。最初闻人近获六根清净。远则速成佛果故云其福更多。疏然佛是除罪胜缘下。第三料拣。于中曲有三门。一明次第。二然礼等五果下辨果报。三约教下约教拣定。言可思者如前礼佛十重。初二非仪令其知非故辨之耳。三通权小。四是始教顺空义故。五是终教通事理故。六七顿教但礼心佛无礼礼故。八通终教同教一乘故。后三合成圆教。八是能礼一具一切故。九融深浅事随理融事事无碍故。而言摄前六者二非仪故。但礼心佛十重重无尽故。下经云一毛孔中悉明见不思议数无量佛。一切毛孔皆如是。普礼一切世间灯。举身次第恭敬礼如是无边诸最胜。亦以言辞普称赞穷尽未来一切劫。一如来所供养具其数无量等众生等。又普贤行云。于一微尘中见一切诸佛菩萨众围绕。法界尘亦然一一如来所一切刹尘礼等。若依此礼一礼则无有尽功德岂可量哉。余之七门可以思准。不入斯观徒自疲劳。疏又此二段之中具足十八圆满。依佛地经论。此十八种华藏品中已具列释。今经文具。疏但随文配属难则释之。今钞重依彼经论牒经配属。论云经曰。薄伽梵住最胜光曜七宝庄严。放大光明普照一切无边世界(此上显色圆满)无量方所妙饰间列(形色圆满)周圆无际其量难测(分量圆满)超过三界所行之处(方所圆满)胜出世间善根所起(因圆满也)最极自在净识为相(果圆满也)如来所都(主圆满)诸大菩萨众所共云集(辅翼圆满)无量天龙人非人等常所翼从(眷属圆满)广大法味喜乐所持(住持圆满)作诸众生一切义利(事业圆满)灭诸烦恼灾横缠垢(摄益圆满)远离众魔(无畏圆满)过诸庄严如来庄严之所依处(依处圆满)大念慧行以为游路(即路圆满)大止妙观以为一乘(乘圆满也)大空无相无愿解脱为所入门(门圆满也)无量功德众所庄严。大宝华王众所建立(依持圆满)大宫殿中。论曰此显如来住处圆满。谓佛净土由十八圆满净事故说名圆满。次列十八圆满竟。下结云如是十八圆满即此圆满。所庄严宫殿名佛净土。佛住如是大宫殿中说此契经。释曰下随疏释依今经。次释义即彼论广释之文。疏今初先举时辨处下。于此总中数多者。佛所庄严广大刹。等于一切微尘数故。其中已有圆满之相。如方处间列即方处圆满。无分量故者即分量圆满。净识所现者唯佛穷故。谓赖耶净识现于自受用土。第七净识现他受用土。余五净识现变化土。唯佛穷者八识转智唯佛穷故。登地分见见他受用故。虽含有别意皆是总。疏初辨因满下。总明。初句亦总下别。别有五句亦总亦别即清净业行所流所引。亦总下中自利行业亲招为所流。利他行业与物为缘。故云所引故释云随业现故此业即所化者业。以菩萨众生之业为因。亲感他受用变化之土。如来利他为增上缘。随他众生之业成。故云引也泉能成池名为所流。凿池引水水名所引。正同于世界品引生公义行。致净土非造之也。造于土者众生类矣。疏别则唯约受用土下。释上亦别之言。于中三初总明。二引论成立二因之义。三示二因之体。今初因缘亲生曰流。增上缘疏为引。疏故佛地论下。第二引论成立二因之义。此中有三义。一唯立因缘此已含二法。一如来净识。二无漏善合二为因。亦同多闻熏习。与阿赖耶中解性。合之为因也。然引论犹略。若具应云谓大宫殿用出世间。无分别智后得智善根为因。而得生起非是无因。非大自在等而为其因。乃至云此用本来无分别智后得无漏善法种子。三无数劫修令增广。为此净土变现生因。此佛净土如来识中。无漏善根为因而生。则具修生本有二法合为因缘也。二云有义但是增上缘生下。出所以云以外法故。谓以识生识可是因缘。外生净土那是因缘。外土即为增上果故是增上缘。三云有义亦是因缘下。双立。非谓但取因缘亦取增上。亦取因缘故云亦是亲能生故出因缘义。若不尔下反难。成立一切外法。皆因内法熏习为因。明有因缘故。云不尔应无因缘。无则非理。次云外法相望无因缘故者。正成上义将第一师义难第二师。汝已外法故唯增上缘外法。则不得立于因缘。今谓外假内熏明有因缘。若尔内熏其外既非自类何名因缘。境全心变即八识相分亦离心亦因缘矣。意以后义为正。四疏家断取也兼显是通二义。疏有云感报净土以四尘种子而为正因下。出二因体。四尘种子全在识中。即八识中相分种也。言或以自利后得者。上言六度万行则通二利。此依唯识别义。以利他后得为他受用变化土缘。故用自利后得为自受用土缘也。疏依此经宗下。正异前文唯取自利为自受用缘故。二利之行同取他受用之土。从以皆是下。出互通所以故指如世界品。问明品贤首章中亦以明矣余可思准。疏现作一切有情一切义利者。即佛地论文。但略其要。具足论云。如其净土任持圆满。作何事业(问也)作诸众生一切义利(引经文总答也)谓于此中能现作一切有情一切义利。或生一切有情自作义利等。然十八圆满皆初假问生起次引经答。三以论释又皆约宫殿上明。今之所明乃通说耳。以问易知故并不出。疏从初得佛下。即唯识论文。然论云相续变为纯净佛土。今无变字乃是义释谓虽复相续变化。不同他受用土前后改变。故不云变。言横周法界云无际者。即唯识论前所引论后云周圆无际佛地经中同佛地论。又云无际者。谓无长短等分齐相难测故。下说他受用并如世界品。疏果圆满下。引镜智等即世界品。佛地论云。最极自在净识为相。疏三无量下。依持圆满。疏文分三。初引佛地经。二今文下释文。三佛地经唯据下。会佛地论。今初然彼论先问起云。如是净土门既圆满如余宫殿应有所依故。次须说依持圆满(问起)无量功德众所庄严。大宝华王众所建立(举经答也)今疏引经云为所依持者。以先无问后不引释。故但结归名耳。后会彼论于中有二。先出彼论意。以论广释但约华故。论云谓如地等依风轮等。或如世间宫殿依地。如是净土无量功德众所庄严。大宝红莲华王众所建立。即红莲华大宝所成。如是大宝无量功德众善所起。于众宝中胜故名大。宝此红莲华于诸华中最为殊胜故名华王或此宝华望诸菩萨善根所起红莲华最胜故名为大佛法。王是佛最胜善根所起故名为王。又此宝华极难得故名为大宝华中最胜故名华王。又此大华非一。或华蕊多故名为众。释曰。此即唯据事也。以将功德庄严属佛故。若将无量功德通理。则佛地亦有佛力任持故。疏云功德亦通事理。如来所都全同佛地经。论释曰。谓大宫殿诸佛世尊为主非余。以殊胜故唯属世尊。或唯属世尊住持摄受非余所能故。疏辅翼圆满佛地论云。如是净土主既圆满应有辅翼主。必摄受辅翼故辅翼之者。故彼经云。诸大菩萨众所云集。论云谓大宫殿有无数大菩萨僧所共云集。诸来朝者名为辅翼。既有如是大菩萨僧常来辅翼。故无怨敌能为违害。诸声闻等无如是事。其眷属圆满佛地经云。无量天龙人非人等常行翼从。今文无此故以诸众摄之。然皆菩萨化作示净土不空。即彼论释妨云。云何净土超过三界所行之处。而有天等以为眷属。天等皆是三界摄故。答云净识如是摄受变现。为严净土故不相违(第一释也)或为成熟所化有情。示现如是变化种类(第二释也)即阿弥陀经云。是诸众鸟皆是阿弥陀佛。欲令法音宣流变化所作。论云或诸菩萨化作无量天龙等身。住净土中供养佛故(第三释也)或自化身为天龙等。翼从如来是故无过(第四释也四义皆示不空尔)疏初明方所圆满。此即标名。论云。如是净土分量圆满为同三界。为不尔耶(问也)超过三界所行之处(答也)论释云。谓大宫殿处所方域。超过三界所行之处。非如三界自地法爱执为己有。所缘相应二缚随增是彼异熟及增上果。如是净土非三界爱所执受故。离二缚故。非彼异熟增上果故。如涅槃等超过三界异熟果地。乃至云如是净土。为三界同一处所。为各别耶(问也)有义。别有处说在净居天。亦有处说在西方等。有义。同处净土周圆无有边际遍法界故。如实义者。实受用土周遍法界无处不有。不可说言离三界处。亦不可说即三界处。若随菩萨所宜现者。或有在色界净居天上。或在西方等处所不定。释曰。今疏直用其要兼取如实义耳。疏以三三昧为所入门者。即义引也。彼经云空无相无愿解脱为所入门故。疏以经配三门相言入不思议三昧。通该前后者。该前明空等为不思议三昧故。该后以三昧等为摄益故。疏三又此净业下。辨摄益相。彼经云。灭诸烦恼灾横缠垢故。论云。谓于此中远离一切烦恼缠垢。如是及诸烦恼为诸缠垢。如是即名诸灾横因。烦恼缠垢此中无故。所作灾横此中亦无。释曰。离此烦恼等即名摄益。又现证得解脱无烦恼灾横缠垢殊胜福智故名摄益。故疏指上净业名为摄益。疏一者形相即形色圆满者。彼论双问云。如是净土显色圆满形色云何。引经答形色云无量方所妙饰间列。论释云。谓大宫殿无量妙饰方所间列。言无量者。或殿无量。或处无量。妙慧为光。安布为饰。是故说名妙饰间列。释曰。无量相貌间列即形色也。疏二无量光色即显色者。彼经云。最胜光曜七宝庄严放大光明普照一切无边世间。论释云。谓大宫殿用最胜光曜七宝庄严。或宝严故最胜光曜于此所。重且言七宝其实净土无量妙宝绮饰庄严非世所识故。此经云无量光色。又论释放大光明等云。谓大宫殿放大光明普照一切无边世界。或大宫殿其体周遍无边世界故放大光明普照一切。释曰。彼经有其二句。今经云无量光色则已摄二。无量光者是彼放无边光句。无量色者即初最胜光曜等。疏住处圆满彼经云过诸庄严如来庄严之所依处。论释云。谓于此中佛所住处。胜过一切菩萨及余庄严住处。唯是如来妙饰庄严为所住处。由胜彼一切庄严住处。是故说名住处圆满。疏中以超过一切菩萨下。即彼论文。经显处严在文极显。疏亦可并前总标通结上来十八圆满等者。上来过去有二。未来有九。现在有三。但有十四下人宝中有五。事业分佛菩萨遂即重出。除余重出十八云何摄耶。今总标文为主圆满。以言佛土故。别中二十九句有十七圆满。一庄严。二清净。为因圆满。佛地经云。超出世间善根所生。今以清净故为出世。以其庄严为所起严。万善严故。三四事业平等妙好故。五即是路大念慧行为威德故。六七住处广大安乐。八即辅翼叵坏。九眷属无尽。十分量无量。十一依持不动。十二无畏名同。十三显色光明。十四无违。十五可爱皆摄益圆满。无烦恼灾横之违故可爱也。十六照明。十七严好皆果最极清净为其相故。十八精丽。十九妙巧。二十第一皆依持。无量功德众所庄严。大宝华王众所建立故。二十一二三四皆门圆满。三解脱门为最胜等故。二十五六皆乘大止妙观为无上等故。二十七无等。二十八无比。二十九无譬喻皆方所。以遍法界性不并真无比对故。经旨多含略为此配未必要尔。故疏略示令如理思。疏大念慧行为所游路。即佛地经文。言路即道之异名者。是彼论释。彼论具云。谓此中大念大慧及以大行。为所游履故名游路。是道异名。闻所成慧名为大念。闻已记持无离义故。思所成慧名为大慧。依理审思得决定故。修所成慧名为大行。由修习力缘真理故。大者念等缘大乘法而生起故。彼所摄故履三妙慧。净土往还故名游路。此说菩萨因三妙慧得入净土故名游路。疏七念等者。寻常六念加念众生耳。疏上辨佛业者。佛地经但云作诸众生一切义利。论先问云如是净土。任持圆满作何事业。即引向经论云。谓于此中即能现作一切有情一切义利。或令一切有情自作一切义利等。今经上明一切诸佛于中成道故是佛业。今明菩萨常作佛事故是菩萨业。疏大止妙观为所乘故者。即佛地经文。论释云。止谓奢摩他。观谓般若。大义如前大念中缘大乘。故此二等运故名乘。乘止与观随其所应行前道路。疏无畏圆满彼经云。远离众魔。论云谓以此中远离一切烦恼蕴死及以天魔。或令他人远离四魔。如是四种是怖畏因。由是能生诸怖畏故。此中无彼故名无畏。疏即任持圆满者。彼经文云。广大法味喜乐所持。疏即论释也。此文犹略。具云谓于此中大乘法味喜乐所持。食能令住住是持义。乃至云此净土中诸佛后得无漏之智能说能持受大乘法味生大喜乐。又正体智受真如味生大喜乐。能任持身命不断坏故。长养善法故名为食。在文可知。疏亦一乘者。以大止妙观为熏修故。疏此之二段反覆相成者。由见实故离妄。如见杌则不见鬼。由离妄故见实。若无鬼见是见木故。疏思所起者。谓身语业者。俱舍云世别由业生思及思所作。思即是意业所作。谓身语故九地广明。疏以即空故下。此有三义释不坏因果。初同净名色即是空非色灭空故。此约空观。二不碍存故即假观。三不坏假名说实相故。二义双照为中道观。疏俱空叵得。即上云有诤说生死。无诤说涅槃生死及涅槃二俱不可得。此约性空下约显实。疏故楞伽云远离觉所觉前已引竟。疏文殊问云下。亦前已引。影公即中论疏。疏一无众生离众生垢故者。多同净名即目连章中。净名云。夫说法者当如法说法。无众生离众生垢故。法无有我离我垢故。法无寿命离生死故。法无有人前后际断故。释曰。上四句我空故故疏取之。此四即金刚无我无人无众生无寿者。今经辨次不同二经。皆明无定前后也。名亦小异。以作者当我。以补特伽罗当人。若释义者人我等相十行已具。空之所以亦如前辨。今取彼经意案今文释。一法无众生者。已无众生为法故。远公云正明理无其所无有三。一无横计神我。二于假名众生无有定性。三无假名众生之相。此等皆是虚妄分别。相有理无余门类尔。离众生垢者。破情显理取我之心名众生垢。生公亦云。若得见理垢情必尽。以离垢验之知无众生也。二法无寿命正明理无。离生死故释成上义。无寿命谓色心连持从生至死。本无生死何有寿命。又寿命为生死之果。若有实者不合得离。今有永离之人明本无矣。三无有我者。理本无也离我垢故释成上义一同初句。四数取趣净名为人。智论云能造善恶行人法故。取于诸趣三际轮回。本无数取者何有前后际耶。又若定有者不应圣人断前后际。今圣有断明无有人能数取也。疏螺髻亦是净名前已引竟余即可知。第六回向。疏今初牒名。征起中六。一总释名。二本分下会前文。三本业下会他经。四此约下别显得名。五亦可名为下会六释。六即。以无碍下出体性。疏千乘之国者古以一城出革车一乘。千乘之国其地千城也。乘即车乘谓以皮里车革即皮也。生曰革。熟曰韦。每乘管卒七十二人。疏则一洲已去者。轮王有四。铁轮即王一州故。疏二等教十善者。夫轮王以十善化世故。疏具八异熟是增上生者。即瑜伽论三十六净行品已辨。疏别中若望回向下。疏文有四。一举其都数。二于中前二十七下。以内外料拣即一切施中二门明义。三又前二十七下。以四等料拣喜舍二行在下总句中。四又代命救残害男刑下。以三施料拣。即一切施也。疏所谓下。别显中三。一彰所摄之法。二言善摄下总释善摄。三谓舍住着下。释随顺善根。略举六度总结万行。疏第二依标广显于中四。一总相辨异。二然其都门下。正出八十六十所以。以开合有无故。三昔光统下。辨成法门。四此上且约下。总结无量。于中三。初引文成多。次实则下。出其本意以皆成事事无碍重重之行。后故知六十下。结示文旨。疏然阿含唯识食总有四者。唯识第四云。谓契经说食有四种。一段食(即分段义)变坏为相。谓欲界系香味触三。于变坏时能为食事(但触所得)由此色处非段食摄。以变坏时色无用故(恋坏不益眼根故又色粗着与眼相离方能有用不与眼合故非是食也问此三为食为对自根亦对余根答先资身根为资养也后资余根发识明利)二触食触境为相(即心所触为此余体)。谓有漏触才取境时。摄受喜等能为食事(此正显也)。此触虽与诸识相应(七八触境细故不摄喜乐等故)。属六识者食义偏胜。触粗显境摄受喜乐。及顺益舍资养胜故。三思食。希望为相(唯取与欲俱思)谓有漏思与欲俱转。希可爱境能为食事。此思虽与诸识相应。属意识者食义偏胜。意识于境希望胜故。四者识食。执持为相。谓有漏识由段触思势力增长能为食事。此识虽通诸识自体。而第八识食义偏胜。一类相续执持胜故。释曰。此三食势增长。此识亦长养诸根大种。能为食事。由是集论说彼四食三蕴五处十一界摄。释曰。段食是色。触思是行。识食如名。段是香味触三处。思是法处。识是意处。段摄三界。触思法界。识七心界。论此四能持有情身命。令不断坏故名为食。余如彼论。而列段食居其后者。前三有漏通于三界。段唯欲界故。又顺经翻最在后故。疏说出世食有其五种者。然上云阿含即杂阿含。连说九食前四世间后五出世。一禅悦食者。禅定资神轻安适悦即为食义。然其五食既云出世通资法身。二愿力。任持出世之法。法身增长即为食义。三念力。明记圣道现前故。四解脱。除障居然资益。五法喜。内充摄喜乐故。疏下翻方出食义。一翻前思成第三念。以经云智慧释成于念。念慧邻故出其所以。亦如四念慧为体。故邻近名念。二翻触成第五兼于第四。三翻识成第一。四翻段成第二愿食言抟者尚依古译。今以饮水等亦是段食不可抟握。故译为段。形段分段而食故。疏一如饮无间。此即敌体相似。断世渴爱常求佛智。即惑翻也。得法喜乐等即顺也。入海霔雨即同水义也。下诸门中体势亦尔随时解释。疏经说佛大牙后等者。即涅槃十四其施食等。亦皆发愿各是一事与此大同不能繁引。疏义通马等者。以梵语通呼车乘云野(余我切)囊。若别呼车云奢羯吒。若呼车辂云曷罗他。此云野囊。明是车乘故通马等。下第十六即单是车。以梵云奢羯吒故。疏涅槃第九譬如莲华下。即如来性品广叹涅槃之德。疏但举喻彼合文云。一切众生亦复如是。若得见闻大涅槃自未发心者。皆悉发心为菩提因。是故我说大涅槃光所入毛孔必为妙因。彼一阐提虽有佛性。而为无量罪垢所缠不能得出。如蚕处茧。以其合文第一疏已用今但要喻耳。疏九月光开青莲引涅槃二十者。即梵行品耆婆为阿阇世王说。因世尊入月爱三昧放光照王。王问其故耆婆答云。此是如来入月爱三昧放光。王问云何等名为月爱三昧。耆婆答言。譬如月光能令一切优钵罗华开敷鲜荣。月爱三昧亦复如是。能令众生善心开敷。下即广说。今但取月开青莲耳。合以佛智为月行为莲开。疏或以缨身者。在身曰缨在首曰鬘。缨乃鬘类皆结华成因便故来。疏然准瑜伽贤首皆明施灯等者。瑜伽文广事亦可知。贤首偈云。又放光名眼清净。能令盲者见众色。以灯施佛及佛塔。是故得成此光明。疏然灯功德经者。亦名施灯功德唯有一卷。前广说施灯所获功德。近后偈云。于彼佛塔施灯已其人身光如日照牟尼牛王清净眼。以好灯明照彼塔得于无漏无上道。其身光明照十方见四真谛。具十力不共之法。亦究竟得遍见眼成善逝。此果皆由布施灯。释曰。此明至极功德。次有偈校量云。设令一切诸众生。昔曾供养无量佛。具大威德见实义。亿劫来成缘觉道。十方所有诸世界。悉布灯明无有余。以是世界诸灯鬘。若人信心供养彼是人如是修供养于无量劫常不断。若人一灯供养佛得福过前无有量。灯油譬如大海水。其炷犹如须弥山。有人能然如是灯遍照一切诸世界。是人深心怀敬信其志唯求缘觉道。十方遍置如是灯一心恭敬而供养。若人发于菩提心手执草炬暂供佛。是人得福过于彼。我见实义作是说。释曰。案上经文以佛德难思故。举广供辟支不及佛塔非令发愿。今取下七十八大愿为炷大悲为油等。例之应广发愿。令其事理皆广大耳

大方广佛华严经随疏演义钞卷第四十八大方广佛华严经随疏演义钞卷第四十九

        唐清凉山大华严寺沙门澄观述

疏。世医所疗治虽差还复生。即涅槃经第五地中当广引说。疏即金刚身者。涅槃第三有金刚身品。金刚为内照之实即生公释。言非唯金色。亦不全遮。意通内外耳。前已引竟。疏瑜伽三十九云。若有众生来求等者。即彼明菩萨应施不应施。中总有二十三类。今当其一不应施与。下更有论云。何以故。若施彼时虽暂令彼于菩萨所心生欢喜。而复令彼广作种种不饶益事。谓因施故令彼多行憍逸恶行。身坏之后堕诸恶趣。从令施美色下。疏以论难经。疏又云。施妻子时。不应施与怨家。亦是此论次文。其凶暴业者。论具云。又诸菩萨于自妻子奴婢仆使亲戚眷属。若不先以正言晓喻令其欢喜。终不强逼令其忧恼施来乞者。虽复先以晓喻令其欢喜生乐欲心。而不施与怨家恶友药叉罗刹凶暴业者。不以妻子形容软弱。族姓男女。施来求者令作奴婢。论次又云。菩萨若有上品逼恼众生乐行种种暴恶业者。来求王位终不施与。若彼暴恶补特伽罗先居王位。菩萨有力尚应废黜。况当施与。释曰。此皆不应施。又从今云种种下。疏以论难经。答能施有二下。答中先正答。后引证。前中有三意。一菩萨善知不知皆得。二知女无染。三知翻利益。疏故摄论中有利有染等者。即无性论第八两本世亲皆是第九。梁论当第十二。今依无性。然是义引。彼论先并举本论四句。后更牒释。今随举便释本论云。若诸菩萨成就如是增上尸罗。增上质多。增上般若。功德圆满于诸财位得大自在。何故现见有诸有情匮乏财位。释曰。上即问也。释论不解本论答云见彼有情于诸财位有重业障故。无性先总明答意云。今当显说由是因缘菩萨。虽有财位自在。而不施他。释向初答云。谓诸菩萨见彼有情。于其财位有重业障故不施与。勿令惠施空无有果。设复施彼亦不能受何用施为。如有颂云。如母乳婴儿一经月无倦。婴儿喉若闭乳母欲何为。解曰。此即第一无利无染。以一向不能受。何利何染。二本论云。见彼有情若施财位障生善法。故释论云。谓诸菩萨见彼有情虽于财位无重业障。而彼若得财位圆满。便多放逸不起善法。作是思惟宁复现世少时贫贱。勿令来生多时贫贱。故不施彼所有财位。解曰。即第二有染无利。三本论云。见彼有情若乏财位厌离现前故。释论云。谓诸菩萨见彼有情。若乏财位厌生死心便现在前。求欲出离。若得富贵即生放逸。故不施彼所有财位。作是思惟宁彼贫贱。厌离生死心常现前。勿复富贵爱乐放逸不起善法。解曰。此亦成上有染无利。四本论云。见彼有情若施财位即为积集不善法因。故释论云。谓诸菩萨见彼有情。若当施彼满足财位。即便放逸积集种种恶不善业。故不施彼所有财利。如有颂云。宁使贫乏于财位远离恶趣诸恶行。勿被富贵乱诸根令感当来众苦器。解曰。亦有染无利。五本论云。见彼有情若施财位。即便作余无量有情损恼因故。释论云。谓诸菩萨见彼有情。若得富贵即便损恼无量有情故不施彼所有财位。作如是念。宁彼一身受贫穷苦。勿令损恼余多有情。解曰。亦有染无利也。故本论结云。是故现见有诸有情匮乏财位。此中有颂见业障现前积集损恼故。现见诸有情不感菩萨施。释曰。上文五重但有二句。初一无利无染。余四皆有染无利。而义不同。一障生善法。二不生厌离。三自积不善。四损恼于他。其有利有染损益双具故亦不施。为损过微论略不说余可知也。疏法华四安乐行品者。今疏所引初一会诸师义。后三全同生公。生公初一但名行处近处。意是总明远恶近理。下三别耳。宝林基公第一名空行。二名离憍慢。三四同生公。南岳云。一名无著正慧。二明口不说过。三敬上接下。四同生公。大乘法师一正身行。二正语行。三心离诸恶自利行。四心修善法利他行。天台云。止观慈悲导三业及誓愿。初身有止故离身粗业。有观故不得身业。不得能离无所得故。不堕凡夫。有慈悲故。勤修身业广利一切不堕二乘地。有止行故着忍辱衣。有观行故坐如来座。有慈悲故入如来室。止行离过即成断德。观行无著即成智德。慈悲利他即成恩德。恩德资成智德。智德能通达断德。名身安乐行。余口意誓愿愿亦如是。释曰。此即通辨三法为能导其所导。初一是身。二是口。三是意。四是誓愿。大乘法师傍立此名。然诸师立皆从多分。增胜以分通用三法。理则玄妙不彰四别。今取生公之意。合身口在第二取行处近处。及南岳宝林共立一名。名毕竟空行。宝林但语一空似约于境。南岳云无著慧但语于心。今云毕竟空。心境两亡空有双会。故生公云。近处明远恶近理。行处而为履行之宗。在毕竟空耳。此为大智四为大悲。悲智相导于中二三业天台之意亦不失也。又初后成德。中二离过。离过即断德。初智后悲三德备矣。虽义俱通从多故别。是以第一。经中但名行处近处。意在近理行耳。疏已入于理下。即生公释。下疏引经证。既云无行而观。即寂照双流为行理也。下而言等者。等取下文亦不行不分别。释此自有二意。一谓上无行而观皆是不分别。今又不行则寂照两亡也。二者但对上而观诸法如实相。恐滥从行起观。今明正观时亦不行此观。不分别此观。就行约心诣于理。就观约照达于理。今心行不行观无分别。即观无观是寂照双流。故下偈云。又复不行上中下法有为无为实不实法。即不行也亦不分别是男是女。不得诸法不知不见。正是入理即亦不分别也。问若以入理为行住忍辱地等。岂入理行耶。答正是入理。谓无生地寂灭之忍为所住处。柔和善顺即柔顺忍而不卒暴。心亦不惊即音声忍。三忍顿具故为入理。住忍辱地即如来衣。观如实相即如来座。以此导悲即如来室。疏虽未入理下。亦生公之意。远诸恶下引经证。先证远诸恶言及外道等。等取余八。总离十缘。一远豪势。谓国王等为损害缘。二不近邪人法。谓外道梵志等为恶见缘。三亦不亲近诸有凶戏者。见坏乱缘。四又不亲近旃陀罗等。即恶业缘。五不亲近求声闻等。即离劣友缘。六又文殊师利等不应于女人身取能生欲想相。而为说法等即长染缘。七亦复不近五种不男之人。即非器缘。八不独入他家。即讥诃缘。九若为女人说法下。离非轨缘。天台云八离怨害九离讥嫌。十不乐畜年少弟子沙弥小儿等。即散乱缘。上明不应亲近常好坐禅。下明所应亲近。上为亲近之始。为初亲近处。次云复次菩萨摩诃萨。观一切法空如实相等。即第二亲近处。为亲近之终。正明近理以观想未除故名亲近。二身口无过失者。经云。若口宣说。若读经时不乐说人及经典过。长行多唯辨口。偈中则说于身。以油涂身澡浴尘秽亦兼身矣。三心无嫉妒者。经云。于后末世法欲灭时。受持读诵是经典者。无怀嫉妒谄诳之心等。四云。于在家出家人中生大慈心。于非菩萨人中生大悲心等。广如彼经。疏然安乐者下。释安乐行名。初释以果詺因。二因即安乐亦生公意。又常见外道等即天台意。一常见外道因果俱苦者。计我常故修于苦行以期乐果。所修是邪还招苦果。二断见外道不信当报。恣意行恶受五欲乐当受苦果。三析法二乘无常拙度加功苦到。此名因苦。得入涅槃故云果乐。四菩萨如实巧度故为因乐。证大菩提涅槃常乐故。涅槃云下。引证即二十七经。经云。善男子不见中道者。凡有三种。一定乐行。二定苦行。三苦乐行。一定乐行者。所谓菩萨摩诃萨怜愍一切诸众生故。虽复处在阿鼻地狱如三禅乐。二定苦行者。所谓凡夫。三苦乐行者。所谓声闻缘觉。声闻缘觉行于苦乐作中道想。以是义故。虽有佛性而不能见。下经文广。不正释凡夫而道有三种。谓下中上。下者梵天无常谬见是常等。后说生死本际。凡有二种。一者无明。二者有爱。是二中间即有生老病死等者。是定苦行也。疏长阿含。十二因缘经。僧祇律。造塔事未捡故。疏无上依经供佛舍利如芥子许悉得究竟脱生死苦者。经有两卷今当第一。因阿难随佛乞食。见一新城楼阁。心念有人以此胜阁布施四方僧。并具四事。若如来灭后取佛舍利。如芥子大安立塔中。起塔如阿摩罗子大。戴刹如针大。露盘如枣叶大。造佛如麦子大。此二功德何者为胜问佛。佛赞广为引喻校量。初举满阎浮提如稻麻。以第四果及辟支佛。有人尽形四事供养。灭后起大塔供养佛。问功德多不。阿难答多。次举西瞿陀尼。次举东弗婆提。次举北郁单越。皆量渐广供事如前。比所造阁如帝释所处。问于阿难。阿难皆答甚多。佛告阿难。若有善男子善女人。佛涅槃后取舍利如芥子大。造塔如阿摩罗子大。戴刹如针大。露盘如枣叶大。造佛如麦子大。此功德比前所说。百分不及一。千分不及一。亿分不及一。乃至算数譬喻所不能及。阿难。若此功德不回向阿耨多罗三藐三菩提。此功德聚所获福德报。尽娑婆世界微尘数。作他化自在天王。化乐天王。兜率陀天王。夜摩天王。三十三天王。况复转轮圣王。释曰。据此但云福多。若加回向必至究竟。疏当其无有车之用者。即老子道经云。三十辐共一毂。当其无有车之用。注云。此明无有功用相资而成。又下结云。有之以为利。无之以为用。意明假辕厢轮等以成于车。车中不虚则无所用故。约形质粗有之利。以明妙无之有用。今借此语万行缘成之乘。其内无性即中空矣。若不涉有无以利物。若不入空无以道行。以有空义故一切法得成。故为大用也。疏翻三生百劫者。罗汉三生修福。缘觉百劫。今令百千亿那由他劫修等故。疏涅槃第十若犯四重禁等者。明经法资人除惑有十复次今是其一。经云。若比丘比丘尼优婆塞优婆夷及诸外道有能受持如是经典。读诵通利。复为他人分别演说。若自书写令他书写。斯等皆是菩提因缘。若犯四禁及五逆罪。若为邪鬼毒恶所持。闻是经典所有诸恶悉得除灭。如见良医恶鬼远去。当知是人是真菩萨摩诃萨也。何以故。暂得闻是大涅槃故。亦以生念如来常故。若暂闻者尚得如是。何况书写受持读诵。释曰。是则疏但举中。疏又云。犯四重禁不还生无有是处者。即第五经云。又解脱者名为虚寂无有不定。有不定者如一阐提究竟不移。犯重禁者不成佛道无有是处。何以故是人若于佛正法中心得净信。尔时即便灭一阐提。若复得作优婆塞者亦得断灭。于一阐提犯重禁者。灭此罪已则得成佛。若言毕竟不成佛道无有是处。疏如是等文处处皆有者。第六又云。是大涅槃微妙经典。不可消伏甚奇甚特。若有闻者闻已信受。能信如来是常住法。如是之人甚为希有如优昙华。我涅槃后若有得闻如是大乘微妙经典生信敬心。当知是等于未来世百千亿劫不堕恶道。第九经初又云。譬如日出众雾悉除。此大涅槃微妙经典亦复如是出兴于世。若有众生一经于耳者。悉能灭除一切诸恶无间罪业。其余大乘文亦广多。疏九十五种外道邪论者。一依萨婆多律。外道六师各有十六种道。疏二附佛法外道。若不得般若意入阿毗昙则滞有故。疏故七卷楞伽第一等者。七卷即实叉难陀三藏所译。然十卷文广。四卷文悭。七卷处中而文又润。疏所引经具足经文。引意明此呼二乘以为外道。何以得知是二乘耶。以此前有经云大慧此是过去未来现在一切如来应正等觉。觉法自性第一义心。以此心成就如来世间出世间最上之法。以圣慧眼入自共相。种种安立其所安立不与外道恶见共故。次即是疏所引之文。谓前是佛法言不与外道共。早兼二乘况出相不知境界自心分别等即二乘见。又四卷云。大慧。云何外道论恶见共。所谓自境界妄想见。不觉识自心所现分齐。大通大慧愚痴凡夫。性无性自性第一义作二见论。释曰。此则皆二乘见故同外道疏又第二云者。亦复彼七卷经外道二乘同义更显。疏所引经一字无阙。以斯二段明呼二乘同外道也。疏乘四轮乘文三。一引论正释。二料拣。三得名。今初言庄严论第六名四种不放逸轮者。一胜土论。二善人轮。三自正轮。四先福轮。下疏依此论以释其相。一住好国土者。论有偈云。易求及善护善地亦善伴善寂此胜土菩萨则往生。今疏即长行释但小略耳。具云一者易求。谓四事供身不难得故。二善护国王如诸恶人盗贼不得住故。三者善地处。所调和无疾疠故。四者善伴同见同戒为伴侣故。五者善寂。谓尽日无喧杂声故。疏二依止善人。谓有偈云。多闻及见谛巧说亦怜愍不退此丈夫菩萨胜依止。下释即论前三易故不释。论具云。一多闻成就阿含故。二者见谛得圣果故。三者巧说分别法故。四怜愍不贪利故。五者不退无疲倦故。三集胜福德者。偈云。可乐及无难无病与寂静观察此五种宿植善根故。释云。一可乐。二无难。三者无病。四者三昧。五者智慧。第一事由住胜土为因。第二事由依善人为因。第三事由自正成就为因。释曰。疏中将后出方便间名释之。四发大誓彼当第三者。偈云。善缘及善聚善修及善说善出此五种是名自正胜。彼释云。一者善缘妙法为缘故。下四多同一两字异。二者善聚福智具足故。三者善修止观。诸行相应时修故。四者全同五。顺字是欲字耳。上云成论名自发正愿者。论第二四法品云。又经中说人天四轮能增善法。一住善处。二依善人。三自发正愿。四宿植善根。次即明摧八难。次下当知。疏然前二就果者。第二料拣。疏此四何因下。第三得名。于中有二。先明得轮名。即成论文。后已知四轮下。二释得乘名。先依瑜伽。若依已下后依当经圆教辩。四文旨可知。疏本行经说编草为盖等者。贤愚经第八说。过去有王名为金刚。夫人有胎恒有七宝大盖覆于头上。及生太子身紫金色。相好具足盖在其上。名盖事王七宝自至。王四天下即是佛身。佛言。阿难。因过去久远仙人山有辟支佛。涅槃后有长者起塔。以盖盖其上故获斯报名其事也。疏四定地上光明集福德王贤首等。如出现品。四智之义亦具上文智各有四。如出现品

疏。今依贤首是八忍八智者。且依唯识释之。即论释相见道。中缘安立谛有十六心见道。然此有二下即彼论文。但以立十六下有标句。云谓于苦谛有四种心下全同论

疏。一苦法智忍者。苦即苦谛法者。即彼能诠教。智者所谓加行道中缘苦法智。忍者无漏忍。忍前苦法智也。此苦法智忍观苦下如。能断三界见道二十八种分别随眠。欲苦有十。上二界苦各九以除嗔故。三界合有二十八也。二苦法智者。法谓苦如。能缘苦如之智名苦法智。三苦类智忍者。谓苦法智无间无漏慧主等。意云此第三心于一刹那。各别内证法忍法智。谓二心后乃至无学一切圣人法。从此二心彼得生故。故云皆是此类。四言类智者。此智但缘第三苦类智忍。故杂集云。于苦类忍内证印可故名苦类智

疏。前二观如等者。谓法忍法智观如。类忍类智观智

疏。如苦下有四三谛亦然下。类释余三。一谛有四故有十六。皆断二十八分别随眠。然是取意。具足论云。如于苦谛有四种心。集灭道谛应知亦尔。此十六心八观真如。八观正智。可知法真见道无间解脱见自证分。差别建立名相见道。释曰。谓法忍法真无间道见分。法智法真解脱道见分。类忍法无间与自证分。类智法解脱与自证分。印前智故差别立也

疏。二者依观上下等者。论云。二者依观上下谛境别立法类十六种心。谓观现前不现前界苦等四谛。各有二心一现观忍。二现观智。释曰。欲界名下是现前界。色无色名上是不现前界。十六心者。谓观欲界四谛别立法忍法智八种。依观上二界四谛别立类忍类智八种。然论但举欲界苦谛以为法也。一现观忍是无间道。二现观智是解脱道。余可准知如其所应。法真见道无间解脱见分观谛。断见所断百一十二分别随眠。名相见道。释曰。今疏以略配而不法自证者。故彼疏云。以于前十六心后而作此观观渐粗故。今谓观智即法自证。既不观智故不法耳。一百一十二者。欲界四谛四十。上二界四谛各除嗔。故八谛减八故百一十二。余可知。疏。瑜伽五十三。百福行即决择分中文相甚显。但少分者经部许有分受。或多或全。由彼根性有劣中上差别。及持有多时少时等。少时从一日至十日。多时谓一年已去十年已来尽寿可知。然其十种分为四类。初之三十据事以分。次之三十依时有分别。次之二十约自他明后之二十依赞说立。正约行时名为百行。约所生福则为百福。若就十恶名为百非。谓少分杀等

疏。此且就同教三十二相化身而说者。第一会中已广分别。即师子吼品二十八经。南本二十六

疏。体圆德备等者。释智明珠。此有二意。一直就智。上体圆者显是圆智即智性也。德备者。能成一切众德故即是智相。鉴彻即明照无遗。惑亡即所知障尽。略举珠之四德。二融于理智。为涅槃三德。一体圆即法身。二鉴彻即般若。三惑亡为断德。解脱德备通于三德。亦别属法身具足三德方名圆智

疏。亦以权隐实者。上直就佛智以明。今就法华经意兼彰于教。以权隐覆实理即昔开三。三即为髻。隐一乘旨。从开权下即会三归一。文无下成上开义。后若不明解下。出因便明之义。所以反显佛无秘藏故。涅槃说如来但有密语而无密藏。如秋月十五日欲令同见岂有秘藏。众生不了谓之为密。上言如来有秘密藏者。约下位不测耳。有约法体。无约佛心。佛心无吝故疏。故佛本行经说等者。具足经云过去有五百长者子。各出珍宝象马车乘衣服饮食随乞悉与。有一贫人见而问言。汝等施福求何等事。答愿欲求佛道。又问何谓佛道。答中广叹佛德。贫人闻已自念。我今欲习学此愿度一切。复念贫穷无财行施。当持己身而用惠施。念已索蜜遍涂其身卧于冡间。我今以此身施与一切。若有须血肉头目髓脑悉以与之。持是功德用求佛道广度一切。作是愿已应时三千大千世界而大震动诸天惶懅。帝释天眼见于菩萨卧于冡间以身布施。下来欲试化作众狗鸟兽欲食菩萨见有欲来啖。身心便欢喜无有退转倾动之意。天帝复形赞问所求为求轮王帝释梵王。答云不尔唯求佛道广度众生。帝释诸天同赞善哉。语菩萨言。汝此勇猛过彼五百菩萨所施。百千万亿不可计倍当先作佛。时贫人者。今我身是。五百长者子者。今此弥勒五百菩萨是。我以精进勇猛之力故。超诸菩萨所作功德而先成佛(已下二十七经)疏二十七施眼等者。标章引例经中云及余无量菩萨者。贤愚经第六快目王施眼说。过去阿僧祇劫有王名为快目。其目彻过墙壁见四十里。王八万四千国性善好施。有边国王名波罗陀拔弥。不宾王化治正失度快目王举兵往伏彼王。有臣云快目王好施。令一盲婆罗门从其乞眼。快目便许之七日后施。臣佐悲谏太子请以眼代快目王广为说法。令剜一眼置于掌中。广发大愿后置婆罗门眼中。彼即得视复剜一眼。置彼匡中亦即得视。大地震动诸天下赞。帝释问王施眼何求。答惟求佛道。问有悔心不。答言无悔。若不悔者令我如故寻便平复。婆罗门回报彼王。彼王闻已心裂而死

疏。十眼与离世间大同者。今略会之。彼十眼者。一所谓肉眼。见一切色故。二天眼。见一切众生心故。三慧眼。见一切众生诸根境界故。四法眼。见一切众生实相故。五佛眼。见如来十力故。六智眼。知见诸法故。七光明眼。见佛光明故。八出生死眼。见涅槃故。九无碍眼。所见无齐故。十一切智眼。见普门法界故。若会今文一即第八。示导众生令出生死得涅槃证为最胜故。二即九名义全同。次五即五眼用小有异。多同寻常五眼。八即第十名同所见。从能见智是佛一切智双就能所故名普眼。九即光明眼从其能照光明。身智二光照生性空故。就其离过名净离翳。十即智眼如来十力方见诸法故。然彼约菩萨此愿得佛因果小异故。用小殊大旨同也。故疏亦云大同小异

疏。一具佛种性即安住最胜者。谓具七最胜成波罗蜜如第一会

疏。智论十四象王施牙等者。论云如释迦文佛曾为六牙白象。猎者伺便以毒箭射之。诸象竞至欲来踏杀猎者。白象以身捍之拥护其人愍之如子。晓喻殷勤遮止群象。徐问猎人何故射我。答曰我须汝牙即以六牙内石孔中血肉俱出。以鼻举牙授与猎者。虽作象身用心如是。当知此象非畜生行报。阿罗汉法中都无此心。当知此为法身菩萨。疏及十轮第四者。经云。若有苾刍于诸根本性重罪中。随犯一罪虽名破戒。恶行苾刍犹胜一切在家白衣犯性罪者。尚应如是况犯其余诸小遮罪。是故不许国王大臣诸在家者轻慢谪罚。所以者何。善男子。乃至过去有迦奢国王名梵授。敕五旃陀罗。有大象王名青莲华。六牙具足住雪山边。汝可往彼拔取牙来。若不得者汝等五人定无活义。时旃陀罗为护身命执持弓箭。被赤袈裟现于沙门威仪形相。往雪山边至象王所。时彼母象遥见人来执持弓箭。惊怖驰走诣象王所白言大天。今见有人张弓挟箭。徐行觇视来趣我等。将非我等命欲尽耶。象王闻已举目观见。剃除须发着袈裟人。即为母象而说偈言。被殑伽沙等诸佛法幢相。观此离恶心必不害众生。时彼母象以颂答曰。虽知被法服而执于弓箭。是恶旃陀罗乐恶无悲愍。时大象王复说颂曰。见袈裟一相。知是慈悲本。此必归佛者。愍念诸众生。汝勿怀疑虑。宜应速摄心。被此法衣人。欲度生死海。时旃陀罗即以毒箭弯弓审射中象王心。母象见之举声号叫悲哀哽咽。以颂白言。被此法衣人。宜应定归佛。威仪虽寂静。而怀毒恶心。应速踏彼身。令其命根断灭。此怨令尽。以射天身故。时大象王以颂答曰。宁速舍身命。不应生恶心。彼虽怀诈心。犹似佛弟子。智者非为命而坏清净心。为度诸有情。常习菩萨行。时大象王心生悲愍。徐问人言。汝何所须。彼人答曰。欲须汝牙。象王欢喜即自拔牙施旃陀罗。而说颂曰。我以白牙今施汝。无忿无恨无贪惜。愿以施福当成佛灭除众生烦恼病。善男子。当观如是过去象王虽受如是傍生趣身。为求阿耨多罗三藐三菩提故。而能弃舍身命无吝。恭敬尊重着袈裟人。虽彼为怨而不加报。然未来世有刹帝利旃陀罗王宰官居士长者沙门婆罗门等。归于我法而出家者。若是法器若非法器。诸弟子所恼乱呵骂。我已鞭杖楚挞其身。或闭牢狱乃至断命。此于一切过去未来现在诸佛。犯诸大罪决定当趣无间地狱。断灭善根焚烧相续。一切智者之所远离。庄严论十三亦云。昔释迦牟尼为菩萨时。作六牙白象王。时王夫人于象有怨。即募人取与一牸象别处而住。猎师服袈裟怀挟弓箭屏树徐行。牸象语象王。象王问彼着何衣服云着袈裟。象王云何所怖畏。亦说偈云。如是之幢相。不害于外物。内有慈悲心。常护于一切。于是猎人即射毒箭。牸象乃云。大天云有慈悲何以为此。象王偈云。此是解脱服。烦恼之所作。远离于慈悲。悉非衣服过。牸象欲害王言何不治结使。复说偈云。如人鬼入心痴狂毁骂医。医师治于鬼。不责病苦人。群象寻来王恐伤之。向彼猎师安之腹下遣去群象。猎师感之悲泣流泪。象王抚之问为何来。猎师答云。王遣取牙。象王命取之猎不敢取。象王遂以鼻绞牙良久而出血大流出痛苦战掉。有天说偈言。心当坚安住。莫为愚痴闷。当观苦恼众。云何可济拔。复有天云。弟子拔牙苦。悲念于地狱。拔已而住猎师思惟将无悔耶。象王知念说偈劝取以鼻擎牙而授与之。释曰缘起小异大意皆同。而牙有出没。又为难行故重重引证

疏。迦尸国王未见名同月光王缘十藏品已引菩萨本缘经亦有大同小异

疏。及下施血髓并如智论十四中说者。论云。月光太子出行游观。癞人见之要车白言。我身重病辛苦懊恼。太子嬉游独自欢耶。大慈愍念愿见救疗。太子闻之以问诸医。医言当须从生长大无嗔之人血髓。涂而饮之如是可愈。太子念言。设有此人贪生惜命云何可得。自除我身无可得处。即命旃陀罗令除身肉破骨出髓。以涂病人以血饮之

疏。三云意生身。疏文有四。一释总名。二显别类。三彰异名。四结文旨。初总名中言此乃意是举喻者。彼经意生身下便云。大慧譬如心意于无量百千由旬外。忆先所见种种诸物。念念相续疾诣于彼。非是其身及山河石壁。所不能为碍。意生身者亦复如是故云喻也

疏。然此身类下。第二显别类。于中有三。一列名。二释相。三定位。初列中今依七卷。若依四卷初明三昧乐正受。第二名中有重性字。然三段俱是七卷第四。若依四卷即当第三。今更引四卷对决。四卷地位便在释相之中最初列竟。即云修行者了知初地上增进相得三种身。疏。楞伽下。第二释相。即七卷。若第四但略结名及地位耳。地位一同四卷。留待辩位明故初身四卷云。大慧云何三昧乐正受。意生身。谓第三第四第五地三昧乐正受。故种种自心寂静安住。心海澄浪识相不生。知自心现非境界性。是名三昧乐正受意生身。释曰。斯则七卷文简而显。然四卷疏意云。从初至七。皆观三界心意识境界妄想。是故须入三昧灭心意识以起意生法身。经隐前二没后二地略举中间。从种种自心下出体。亦有解云。初二约位未得定故不说意生身。六七已得般若常在无相故。属第二身。今疏依此故下约位云五地前

疏。云何觉法自性等者。四卷云。大慧云何觉法自性性意生身。谓八地观察觉了如幻等法。悉无所有身心转变。得如幻三昧及余三昧门无量相力自在明。如妙华庄严迅疾如意。犹如幻梦水月镜像。非造非所造。如造如所造一切色。种种支分具足庄严。随入一切佛刹。大众通达自性法故。是名觉法自性性意生身。释曰。二经相对居然可见。彼疏释云。谓八地菩萨觉一切法无自性性故。名觉法自性性意生身也。经文释中由八地已上灭心意意识。觉知诸法无所有故。得如幻等无量三昧门也。从无量相下。三昧所起德用。于三昧中得自在故。名力自在名明。以此功德庄严其身故。云如妙华严也。法性生身随念所起如意迅疾也。从犹如下。所起化身不实也。非四大造如四大造色也。从一切色下。辩庄严具足。随入下。入佛境界以化生也。通达自性法故者。释能化所以也

疏。云何种类下。明第三身四卷经云。大慧云何种类俱生无作行意生身。所谓觉一切佛法缘自得乐相。是名种类俱生无作行意生身。释曰。彼疏释云。得如来法身随众生类以现形。而不作意故立其名。言觉一切佛法者。如来觉知一切佛法也。缘自得乐相者。缘自内心所证。自觉圣智乐相欲与众生故作种类身也。大云释云。以八地深证无相于一切法不能圆满。故为佛呵得劝便修至九地。便获四无碍智。具修一切佛法。觉一切法皆是法界。以觉即法界缘内证真如得寂灭之乐。与一切法无差别矣。释曰。此即但说菩萨觉一切法前是恭法师意。谓佛觉也。理实通二。今疏文分二。先略引经正释义当佛觉诸法。从释曰下。将释第三便腾前二显三得名。从三自证法下。正释第三得名便释俱生种类之义

疏。若依地位下。第三辩位。前经已具。言初即五地前者。自有二意。一依密严第三。初地即得意生身则通五地。二依上四卷七卷经。皆以三四五地当其初身。以初二地未得定故。故十卷楞伽第五云。三地修定得三昧乐意生身。八地证无生故得觉法自性意生身。第三身不配地位斯则初身。以初摄后云三地得第二身。以后摄初云八地得故。疏云八地已前由六七地已得般若常在无相。是故觉法自性摄。不尔三得第一八得第二。初唯至五。则六七地何无意生。明是以后摄初耳。三不配者。三本楞伽总皆不配。既以八地向前为第二。则三即九地至十。乃至如来居然可知耳。上依楞伽有云所以已见上文。若无上依经第一不配地位但约三人得。谓声闻缘觉大地菩萨为三意生身。若依胜鬘经云。无明习地为胜缘。无漏业为因。有阿罗汉缘觉自在菩萨三种意生身。西域自有二解。胜鬘一依楞伽二依无上依经前中复有三说。一云罗汉缘觉回心。十千劫至十信仍本名故名为二乘。至十回向终名自在菩萨。即初地已上对前二位故名自在。初地已上即有三种。如前楞伽一云。罗汉缘觉俱回心。至十回向终仍本名罗汉缘觉直往菩萨初地已上名自在菩萨。菩萨亦有三种意生身。一云声闻缘觉同第二释。从二乘有学回心至回向终名自在菩萨。对未发心得名自在。三身得同前二解。二据无上依随三乘人即为三身。前二回心至等觉位名声闻缘觉意生身。后一初地至等觉名菩萨意生身。释曰。后释似非等意。经意但明三乘人皆得三种意生身耳

疏。若成唯识下三彰异名。唯识因解变易生死名。云由悲愿力改转身命无定齐限故名变易。无漏定愿正所资感。妙用难测名不思议。或名意成身。随意愿成故。彼释云。随大悲意之所成耳。意明已下。是疏释论然此异名总有其三。一名不思议变易身。二名变化身。三名意成身。若出体者。总有三说。一云悲愿为体。二云定愿为性。三云无明住地惑。无漏有分别业为性。若问答者。问若所依身随地有别。可说短长而命如灯焰念念生灭非如分段。一期等事凭何说彼无定齐限。答玄奘三藏解云。理实命根无别分限。随所依身假说分限。问若依悲愿而感此身。故留烦恼此复何用。诸法师答云。七地已来自有菩萨受分段身故留不断。八地已上虽受变易。而与圣道不相违故所以不断。又解。八地已上变易生死。还相假籍故留不断。由此惑力资别业力。得受用身非如无学。回心大者唯依一业。问若所知障助业能感生死。二乘定性应不永入无余涅槃。释曰。小乘问也。二乘既有所知障则常感生死不入涅槃。论主答云如诸异生拘烦恼故。释曰。异生有烦恼不趣涅槃。彼趣寂者心乐趣寂。为此心拘驰流无相。不起无上正等菩提。如诸异生为烦恼拘故。论问云。如何道谛实能感苦。释曰。以无漏有分别业即是道故。论答谁言实感。不尔如何下论主答无漏定愿资有漏业。令所得果相续长时。展转增胜假说名感。如是感时由所知障为缘助力非独能感。然所知障不障解脱。无能发业润生用故。释曰。谓第四禅无漏胜定。资色无色已感异熟诸有漏业令所得果相续增长无漏资胜假说能感苦。非无漏业实能感苦。又此能感由所知障助故。所知障不感苦者。不同烦恼障有发润故。论云。彼复何须所知障助。论答云。既未圆证无相大悲。不执菩提有情实有。无由发起猛利悲愿。余可略也

疏。上皆通因下第四结文旨可知

疏。四百福相等者。百福十行品已辩。三十二相至法界品瞿波处广说。八十种好今当略示。大般若三百八十一。今当具引。经云。善现。云何如来应正等觉八十随好。善现。一世尊指爪狭长薄润光洁。鲜净如华作赤铜色。二世尊手足指圆满纤长。佣直柔软节骨不现。三世尊手足各等无差。于诸指间悉皆充密。四世尊手足圆满如意。软净光泽色如莲华。五世尊筋脉盘结坚固深隐不现。六世尊两踝俱隐不现。七世尊行步直进庠审如龙象王。八世尊行步威容齐肃如师子王。九世尊行步安平庠序。不过不减犹如牛王。十世尊行步进止仪雅犹如鹅王。十一世尊回顾必皆右旋。如龙象王举身随转。十二世尊支节渐次佣圆妙善安布。十三世尊骨节交结无隙犹若龙盘。十四世尊膝轮妙善安布坚固圆满。十五世尊隐处其文妙好。威势具足圆满清净。十六世尊身支润滑柔软。光悦鲜净尘垢不着。十七世尊身容敦肃无畏常不怯弱。十八世尊身支坚固稠密善相属着。十九世尊身支安定敦重。曾不掉动圆满无坏。二十世尊身相犹如山王。周匝端严光净离翳。二十一世尊身有周匝圆光。于行等时常自照曜。二十二世尊腹形方正无欠。柔软不现众相庄严。二十三世尊脐深右旋圆妙清净光泽。二十四世尊脐厚不[穴/爪]不凸周匝妙好。二十五世尊身皮远离疥癣。亦无靥黠疣赘等过。二十六世尊手掌充满柔软足下安平。二十七世尊手文深长明直润泽不断。二十八世尊唇色光润丹辉。如频婆果上下相称。二十九世尊面门不长不短。不大不小如量端严。三十世尊舌相。软薄广长如赤铜色。三十一世尊发声威震深远。如象王吼明朗清彻。三十二世尊音韵美妙具足如深谷响。三十三世尊鼻高修直两孔不现。三十四世尊诸齿方整鲜白。三十五世尊诸牙圆白光洁渐次锋利。三十六世尊眼净青白分明。三十七世尊眼相修广。譬如青莲华叶甚可爱乐。三十八世尊眼睫上下齐整稠密不白。三十九世尊双眉长而不白致而细软。四十世尊双眉绮靡顺次绀琉璃色。四十一世尊双眉高显光润形如初月。四十二世尊耳厚广大修长轮埵成就。四十三世尊两耳绮丽齐平离众过失。四十四世尊容仪能令见者无舍无染皆生爱敬。四十五世尊额广圆满平正形相殊妙。四十六世尊身分上半圆满。如师子王威严无对。四十七世尊首发修长绀青稠密不白。四十八世尊首发香洁细软润泽旋转。四十九世尊首发齐整无乱亦不交杂。五十世尊首发坚固不断永无褫落。五十一世尊首发光滑殊妙尘垢不着。五十二世尊身分坚固充实逾那罗延。五十三世尊身体长大端直。五十四世尊诸窍清净圆好。五十五世尊身支势力殊胜无与等者。五十六世尊身相众所乐观常无厌足。五十七世尊面轮修广得所。皎洁光净如秋满月。五十八世尊颜貌舒泰光显。含笑先言惟向不背。五十九世尊面貌光泽熙怡。远离频蹙青赤等过。六十世尊身支清净无垢常无臭秽。六十一世尊所有诸毛孔中。常出如意微妙之香。六十二世尊面门常出最上殊胜之香。六十三世尊首相周圆妙好。如末达那亦犹天盖。六十四世尊身毛绀青光净如孔雀项。红辉绮饰色类赤铜。六十五世尊法音随众大小。不增不减应现无差。六十六世尊顶相无能见者。六十七世尊手足指约分明。庄严妙好如赤铜色。六十八世尊行时其足去地。如四指量而现印文。六十九世尊自持不待他卫。身无倾动亦不逶迤。七十世尊威德远振一切。恶心见喜恐怖见安。七十一世尊音声不高不下。随众生意和悦与言。七十二世尊能随诸有情类言音意乐而为说法。七十三世尊一音演说正法。随有情类各令得解。七十四世尊说法咸依次第。必有因缘言无不善。七十五世尊等观诸有情类。赞善毁恶而不爱憎。七十六世尊所为先观后作轨范具足令识善净。七十七世尊相好一切有情无能观尽。七十八世尊顶骨坚实圆满。七十九世尊颜容常少不老好巡旧处。八十世尊手足及胸臆前俱有吉祥喜旋德相。文同绮画色类丹珠。善现。是名八十随好。但经结次后云是为一二等。今回次在前意不欲。具如经文耳。若瑜伽说与上有异。今当更说。论云。如来八十种好。谓手足具二十指。及以节爪并皆殊妙。是即名为一十种随好两手两足表里八处手四足四并皆殊妙是即名为八种随好。两踝膝股六处殊妙是名为六种随好。两臂肘腕六处殊妙是即名为六种随好。腰膝殊妙各一随好两核殊妙为二随好。阴藏殊妙为一随好。两臀殊妙为二随好。腕胪脐三并皆殊妙各一随好两胁腋乳并皆殊妙为六随好。腹胸项脊各一随好。如是所说除颈已上于下身分六十随好。上下齿势并皆殊妙为二随好(其齿勇出行列犹如华鬘故名势也)[齒*(虎-儿+且)]齶殊妙为一随好。两唇眷属并皆殊妙为二随好。颐盖圆满为一随好。两颊圆满善安其所为二随好。两目眷属并皆殊妙为二随好。两眉殊妙为二随好。其鼻二孔并皆殊妙为二随好。其额殊妙为一随好。角鬓两耳并皆殊妙为四随好。头发殊妙为一随好。如是所说从颈已上二十随好总合说为八十随好。若依无上依经亦有八十。与大般若大同恐繁不引。然释此相好瑜伽之中乃有二门。一列名。二辨释。初中上瑜伽但列名而已。二辨释中论更有五门。一相好起位。二相好之因。三相好位差。四相好废立。五相好优劣。初起位者。论云。如是诸相及诸随好。若诸菩萨入净胜意乐地时。以得异熟从此已上诸相随好。展转获得殊胜清净。二明因者。大同涅槃前疏已引。三位差别者。论云。当知如是三十二相。八十随好菩萨在种性地。唯有种子依身而住。菩萨若在胜解行地。始能修彼能得方便。若在清净增上意乐地中乃名为得。若在诸余上地。如是相好转胜清净。若在如来到究竟地。当知相好善净无上。四废立者。论云。如是诸相是有色故劣中胜品诸有清净易了知故。余有一切不共佛法。皆得名为大丈夫相。唯立此为大丈夫相。又即如是三十二种大丈夫相。由所依性为任持故。释曰。此三十二。与余功德为所依故。偏得立名余不得名。下辨好论云。由极殊妙令端严故说名随好。五优劣者。至随好品当广分别

疏。普见一切众生正觉等者。等有二义。一等下文云乃至普见一切众生入涅槃。皆同一性所谓无性。无何等性。所谓无相性无尽性无生性无灭性等。二等取次下经文佛子菩萨应知如来身一毛孔中。有一切众生数等。诸佛身亦即身藏之义。上则普含众生。此则但含诸佛。上全身含。今是一毛含。遍法界毛当知亦尔故身为藏

疏。藏即名坚者。此即十地初释金刚藏论文

大方广佛华严经随疏演义钞卷第四十九大方广佛华严经随疏演义钞卷第五十

        唐清凉山大华严寺沙门澄观述

疏。如不思议品十种勇健法中第一法说者。经云。谓一切诸佛身不可坏。命不可断。乃至云八部天龙尽其势力雨大金刚山。如须弥山及铁围山。遍于三千大千世界。一时俱下不能令佛心有惊怖。乃至一毛亦不摇动

疏。具那罗延支节大力者。即涅槃北经第十一。南本第十现病品。因佛现卧迦叶怪问。如来已离病恼何故倚卧。便校量佛力云。如十小牛力不如一大牛力。十大牛力不如一青牛力。十青牛力不如一凡象力。十凡象力不如一野象力。次四牙象。次雪山白象。次香山象。次青象。次黄象。次赤象。次白象。次山象。次优钵罗象。次芬陀利象。次一力士。次钵健提。次八臂那罗延。次十住菩萨一节之力。皆前前之十不及后后之一。如前六种故知佛力不可思议

疏。智论十六如毒龙等者。论云。问曰。已知尸罗相。云何波罗蜜。答曰。有人言。菩萨持戒宁自失身命不毁小戒是为尸罗波罗蜜。如上苏陀摩王经中所说。不惜身命以全禁戒。如菩萨本身曾作大力毒龙。若众生在前身力弱者眼视便死。身力强者气往而死。是龙曾受一日禁戒。出家求静入林树间。思惟坐久疲懈而睡。龙法睡时复形如蛇。身有文彩七宝杂色。猎者见之惊喜言曰。此希有难得之皮。献上国王以为服饰。不亦宜乎。便以杖按其头以刀剥皮龙自念言。我力如意。倾覆此国其如反掌。此人小物岂能困。我今以持戒故不计此身。当从佛语于是自忍。眠目不视闭气不息。怜愍此人为持戒故。一心受剥不生悔意。既以失皮赤肉在地。时日大热宛转土中欲趣大水。见诸小虫来食其身肉。为持戒故不复敢动。自思惟言。我今此身。以施诸虫为佛道故。今以肉施以充其身。后成佛时。当以法施以益其心。如是誓已。身乾命终即生第二忉利天上。尔时毒龙即今我身释迦牟尼佛是。是时猎者提婆达多等六师是也。诸小虫辈释迦牟尼佛初转法轮八万诸天得道者是。菩萨护戒不惜身命。决定不悔其事如是。名尸罗波罗蜜。释曰。虽本明戒正是施皮耳。及菩萨本缘经亦有此缘。其事更广。先为大龙有大势力。或化身为人为与诸龙女共相娱乐。至毗陀山幽邃之处。金翅欲食。欲来诸山。碎坏泉池令其枯涸。诸龙龙女化为女人来附此龙。龙为金翅。说慈心法令反本宫。后为诸龙说慈心法亦令行慈。后舍諠就静。山间斋戒。多日困乏暂卧止息。遂遇恶人余同上智论。疏及菩萨本缘集经第四等者。经云。菩萨过去堕畜生中而为鹿身。两胁金色脊似琉璃。余处杂厕种种难名。髀如砗磲。角如金精。其身庄严如七宝藏。身色光焰如日初出。诸天敬重为立名字名金色鹿。善解人语。为诸群鹿宣说正法为大利益。下取意略引。至一河边暴水泛溢损坏树岸。见一溺人投身救之。其人得济白鹿王言。君即是我再生父母。何以报德。鹿王言。我无所须。以身皮妙常恐人见。当默汝言知恩之人具多功德。不知恩者即受苦报。此人背恩还白王知。王即命驾令此溺人引至鹿所。鹿王正睡有乌啄耳觉已瞻望见王兵已近。乃安抚群鹿云。王为我来汝勿惊怖。寻至王所溺者指言此是鹿王两手坠落。王见是事下马诣鹿。鹿却慰王勿令惊怖。我施一切众生无畏。王遂赞言。汝虽兽身非实畜也。王语鹿言。既施一切众生无畏。何为令此溺人两手堕落。鹿王答言。如人犯官重法自招其咎。此人自作自受非我使然。王便长跪叉手白鹿。我从今日长相归依。鹿白王言。若能尔者。愿赐此人无畏如赤子想。此人必堕地狱故可怜愍。王益称敬愿长为弟子。普施诸鹿令得无畏。敕令国内不许游猎杀害众生。广如彼说。更有九色鹿经事缘一同。但云九色。又王夫人夜梦托病。王为求之许分半国。溺人贪利见王言知鹿处当即面癞。后结会。鹿即我身是。王即父王。夫人即先陀利。乌即阿难。溺人即调达。余皆同也。释曰金色义同非正舍皮。云大例相似。疏愿中相好皮者。金色等者。相谓三十二相中第十五身皮金色。好者八十种好中第十六。世尊身皮润滑柔软光悦鲜净。尘垢不着故。疏纤长者。量等者直就事说。若约相好纤长是相即三十二中第三相。圆佣是第二好。赤铜是第一好。能摄者持法界故亦第五十三好。言随好者总指。由此一句别詺文为力为色等。亦瑜伽二十指皆殊妙为二十随好也。齐等者不参差。即第三随好。云各等无差。轮相等即第八十随好。上说八十世尊手足。及胸臆前俱有吉祥喜旋德相。文同绮画。色类丹珠。里面皆有。本那伽吒者。此云满瓶。塞缚悉底迦。此云有乐。故云圆满之言应言满瓶。右旋之言应云有乐。其右旋梵云难提迦物多。故若准观佛三昧海经者。即第一经观相品。疏赤铜者。即是小相好。即第一随好。言事爪则不染尘垢者。亦第一好。又第一好。云一世尊指爪狭长薄润光洁鲜净。如赤铜色。故具此二疏般若波罗蜜犹如大火聚。即龙树赞般若。至胜热处当广引释。疏四十一求法入火者三地有文。又贤愚经云。又复世尊过去久远无量阿僧祇劫。此阎浮提有大国王。名曰梵天王。有太子名曰昙摩钳。好乐正法四方求法。周遍不获愁闷懊恼。帝释化为婆罗门。来诣王所。王请就座为说妙法。婆罗门言。学之甚难。云何便说。太子审问。答言。若能作大火坑令深十丈满中炽火。自投于中为供养者。吾乃与法。太子如教群臣谏喻令愍我等。婆罗门曰。吾不相逼。若不尔者。吾不说法。王知意定令使乘八千里象。宣告一切太子于是却后七日求法入火。诸小王等远近皆集悲哀劝喻。太子告言。我于久远生死之中丧身无数。人中为贪更相残害。天上寿尽失欲忧苦。地狱之中火烧汤煮等。受无量苦未曾为法。吾今以此臭秽之身为法供养。云何止我将欲投火。先请说法。婆罗门为说偈云。常行于慈心。除去恚害想。大悲愍众生。矜伤为雨泪。修行于大喜。同已所得法。救护以道意。乃应菩萨行。闻说法已便投火坑。帝释并梵天王。各执一手而叹之言。一切生类赖太子安。何为投火丧他父母。太子答言。为无上道不惜身命。才投于火火变华池。太子安然坐连华台。诸天雨华没至于膝。尔时梵天王者净饭王是。疏如香城粉骨雪岭忘躯者。下句即涅槃。上句即大般若。大般若文广。今依大品二十七略引经云。佛告须菩提。菩萨摩诃萨。求般若者。当如萨陀波仑。此云常啼。欲求般若不惜身命。闻空中声。汝但东行莫惮劳苦。即当得闻。菩萨闻已作是念言。令我东行何时何处当闻般若。即住立啼泣经于七日。空中有佛即语之言。从此东行五百由旬有城名众香。彼有菩萨名昙无竭。此云法尚。日中三时宣说般若波罗蜜。心念欲往即得无量三昧法门。诸佛慰喻忽然不现。欲见法尚自念贫无以何供养。遂欲卖身。中路有城。以魔蔽故。并无人闻卖身之声。唯有城中长者女闻。帝释化为婆罗门云。不要于人。唯要人血髓用祀天神。菩萨遂刺左臂出血。割右髀肉。复当破骨出髓。时长者女楼上遥见下问其故。答云。我欲供养法尚求闻般若。女遂止之。许供所须。与共同往。帝释即时复天身云。我相试耳。欲求何愿。答云。与我无上菩提。帝释言。是佛境界非我所能。更何所求。答云。乞令其身如故。帝释许之。平复如故。释曰。此即粉骨。言香城者。彼众香城七重。欲往彼故。又至彼城刺血洒地故。言雪岭忘躯者。即涅槃第十四圣行品明。世尊昔在雪山。修行为求菩提。帝释化为罗刹。去其不远遂说半偈云诸行无常。是生灭法。菩萨忽闻揽发举视。遂见罗刹。初疑其人。若闻此偈不合受此可畏之身。又思或于过去佛所曾闻。寻往问言汝于何处得是过去离怖畏者所说半偈。何处得此半如意珠罗刹言曰。我饥讇言。菩萨请言。汝所说者义味不尽。为我说终。我当终身为汝弟子供给所须。又言。我今饥苦终不能说。菩萨问言。汝须何食。罗刹答言。我所饮者。唯人热血。我所食者唯人暖肉。我飞行处处而不能得。菩萨请言。但为我说。我闻偈已以身奉施罗刹又言。谁当信汝。菩萨答言。释提桓因大梵天王得他心者。诸佛菩萨以为证明。次脱衣服以敷高座。罗刹坐已为说余半偈云生灭灭已。寂灭为乐。罗刹又言。偈已说竟。当施我身。菩萨是时深思此义。若石若壁若树若道。书写此偈后升树投身而下。未至于地。虚空之中发种种声称叹菩萨。上至阿迦尼吒。天释复本身接之安置平地。称赞善哉。真是菩萨必成正觉。愿见济度礼足而去。因此乃超弥勒菩萨十二劫在先成佛。言其类非一者。如菩萨本缘经说。虔阇那梨王爱乐正法广召贤达。有婆罗门应召而至。令王剜身千灯经停七日。广集眷属遂剜千灯灯如钱大。添满油竟请说偈法。婆罗门说偈言。常者皆尽。高者亦堕。合会有离。生必有死。闻竟然灯。又发愿言。愿成菩提然大法灯光明照于一切。帝释问云。得无悔耶。答言。不悔。若不虚者平复如故。言毕平复。贤愚经第一。亦有此缘。名虔阇婆梨。又有钉身千道。涅槃二十七亦有卖身重法之缘。恐繁不引。八十经中普贤菩萨自说求法因缘。第三地中亦说求法内外无吝。疏俱舍论说。昔有黄门救五百牛毁形之事等者。与西域记第一全同。彼云。是屈支国旧曰龟兹国。大城西门外路之左右各立佛像。高九十余尺。五年修设一大会。西北渡河至阿奢理贰伽蓝。唐言奇特。相传云。昔时此国先王崇敬三宝。将欲游方观礼圣迹乃命母弟摄知留事。其弟受命窃自割势防未萌也。封之金函持以上王。王曰。斯何谓也。对曰。驾回之日乃可开发即付执事。随军掌护王之还也。果有构祸者。白王。王命监国淫乱后宫。王闻震怒欲置严刑。弟曰。不敢逃责愿开金函。王遂发而视之。乃断势也。曰斯何异物。欲何发明。对曰。王昔游方命知留事。惧有谗祸割势自明。今果有征愿垂照鉴。王深敬异情爱弥隆。出入后庭无所禁碍。王敕弟于后行遂遇一夫拥五百牛欲事刑腐。见而怀念引类增怀。我今形亏岂非宿业。即以财宝赎此群牛。以慈善力男形渐具。以形具故遂不入宫。王怪而问之。乃陈其始末。王以为奇特也。遂建伽蓝。或旌美迹传芳后叶从此立名。疏四如说修行者。此下余经云。善男子。若男若女具足四法谓名丈夫若有男子无此四法。即不得名为丈夫也。何以故。身虽丈夫行同畜生。如来调伏若男若女。是故佛号调御丈夫。疏又四相品即南经。北经即如来性品卷当第四。言四相者。一者自正。二正他。三者能随问答。四者善解因缘义。前亦已引。意云。自正者。明信三宝常住不移。宁以利刀割断其舌。终不说言如来法僧是无常也。二正他者。意云。随机受法智小堪说无常等。智大堪化乃可具说常无常等。三能随问答者。意云。善知如来制听之意随问而说。如有问言。云何不施一钱得大施名。佛言不食酒肉施以酒肉。不饰香华施以香华。无费一毫施名流布。迦叶因言。食肉之人不应受施。便为广说断肉之制。昔开三种乃为渐损其贪耳。四善解因缘义者。意云。知佛有何因缘初不说深法不广制戒。后方说之。知未堪闻故先未说。未有过失故不广制。随过补之。然此四相将为众生闻大涅槃。为能开德通是利他。若别说者。初一自利。自行非邪故名为正。后三利他。令离邪过故名正他。此一正是利他行体。后二化德能随问答。明知法业自在随问巧答。四达根性善知随机授化因缘上说就能开以说。若就所开四者。经云。复次自正者。所谓得是大般涅槃。正他者。我为比丘说。言如来常存不变。随问答者。迦叶因汝问故。得广为菩萨摩诃萨比丘比丘尼优婆塞优婆夷说是甚深微妙义理。因缘义者。声闻缘觉不解如是甚深之义。不闻伊字三点而成解脱涅槃。摩诃般若成秘蜜藏。我今于此阐扬分别。为诸声闻开发慧眼等。余广如彼经。此中但取知其四事名丈夫耳

疏。虽是女人下。亦是涅槃第九经末。前广说女人之过竟。便云。善男子。以是义故。诸善男子善女人等。听是大乘大般涅槃经。常应呵责女人之相求于男子。何以故。是大乘经典有丈夫相。所谓佛性。若人不知是佛性者则无男相。所以者何。不能自知有佛性故。若有不能知佛性者。我说是等名为女人。若能自知有佛性者。我说是人为丈夫相。若有女人能知自身定有佛性。当知是等即是男子。释曰。此文证宗五性者都非丈夫。若具四德不拣男女即丈夫矣。疏然七丈夫总有多说者。疏出其五。一依瑜伽七丈夫。即八异熟中除财位果以属外故。八异熟义即当瑜伽第三十六。此回向初已具引竟。净行品中亦以略出。疏。依小乘七贤圣者。如俱舍贤圣品。离世间亦出七善知。如梵行品已引

疏。于施行中略列诸田。下疏文有三。初随难略释。二料拣诸田。三总结经意。今初。言别人者。谓资财人者。即不思议境界经。普贤菩萨云。又复菩萨为护三昧随法施时不拣福田。怨亲善恶持戒破戒富贵贫穷。又复思惟。施于富者虽无所用。然我自应修习施行。释曰。即有财为别人也疏于中佛塔下。第二料拣诸田有四。一总立五田。谓恩敬德悲苦。二若敬田有病下。辨其兼通。言智论十四者。论云。复次三事因缘生檀。一者信心清净。二者财物。三者福田。心有三种。若怜愍。若恭敬。若怜愍恭敬。施贫穷下贱及诸畜生。是怜愍施。佛及诸法身菩萨等。是为恭敬施。若施诸老病贫穷阿罗汉辟支佛。是为恭敬怜愍施。释曰。论唯此三句。今有非恭敬非怜愍。即上别人。三总收为二者。谓悲田摄苦。敬田摄恩德。四然此二田下。彰其优劣。于中有二。一以二田对辨。二唯就敬田以明。前中三。一约智。二约境。三约悲。亦是三约心。二约境。初融心境故云以理御心。今初。成上以理御心。则心无二。况就于境而有分别。即净名第一善德长者子章中。长者子自于父舍设大施会。供养一切沙门婆罗门。及诸外道贫穷下贱孤独乞人。期满七日。时维摩诘入会诃之云。当为法施之会。何用是财施会为。问曰。何谓法施之会。答云。法施会者。无前无后一时供养一切众生。是名法施之会。后广为说法施。长者子发心解身璎珞价直百千上之。不肯取。再请受之。分作二分。一分施此会中一最下乞人。持一分奉彼难胜如来一切众会皆见光明国土难胜如来。又见璎珞在彼佛上变成四柱宝台。四面严饰分明不相障蔽。时维摩诘现神变已。复作是言。若施主等心施一最下乞人。犹如如来福田之相。无所分别等于大悲不求果报。是则名为具足法施。释曰。既云无所分别。即以理御心。等于大悲亦同体悲矣。又云施主等心施时以理御心也。疏若直就境下。第二约境敬胜。言校量功德经者。经云。施畜生得百倍福。施外道得千倍福等。前已引竟。又甚希有经云。以七宝等供满四洲四果圣人。及灭度后广起塔庙。不如造[麩-夫+廣]麦等佛塔功德。乃至算数譬喻非比。释曰。此即四果尚不及佛。明敬田胜也。疏若就于心下。第三约悲心说。然探玄记引像法决疑经中。乃至施佛菩萨声闻众生。不如有人施畜生一口饭食等。此是伪经。故疏不引。但取亲引于悲。悲是菩萨根故。悲为菩萨体故。若无大悲非菩萨。故净名亦云等于大悲。故从敬则田强而悲心弱下。即罗什法师释净名等于大悲之言。而睿公不许。但以心等故。等即前第一义耳。今取双成后二。故云各有其美。疏若等是敬田下。第二但就敬中以论优劣。以恩德田皆敬田故。于中三。一敬恩分别。二若同是恩下。恩中道俗分别。如舍利弗请问经者。经唯一卷。问云。何故如来说父母恩大不可报。又言师僧之恩不可量。其谁为最。佛言。夫在家者孝事父母。在于膝下莫以报生长养育等。以生育恩深故言大也。若从师学开发知见。此恩大也。夫出家者。舍其父母生死之家。入法门中受微妙法。是师之力也。生长法身出功德财。养智慧命。功莫大也。追其所生乃次之耳。释曰。若据经意。前疏顺前意各自为重。以二相望则出家为胜故。言或约生色身等则优劣可知。即顺经后意也。三等是德田下。就德田中普别分别。引梵网经。即菩萨戒云。若佛子有出家菩萨在家菩萨及一切檀越。请僧福田求愿之时。应入僧坊问知事人。今欲次第请者。即得十方贤圣之僧。而世人别请五百罗汉及菩萨僧。不如僧次一凡夫僧。若别请者。是外道法。七佛无别请法。不顺孝道。若故别请者犯轻垢罪。疏又由主财田等者。俱舍论云。由主财田异故施果差别。此即约分别门。就于三轮皆具优劣。主谓重心轻心等。财谓好物恶物等。田谓若敬若悲等。疏然今此中下。第三结示经旨。三事即三轮。广即约事。深即约理。融有二义。一融上事理。二以理融事。重重无尽。疏义多如此反腾前辞者。即五失本中之一。如初会说。疏须达拏者。此云善爱。或云好爱。经唯一卷。说事甚广。今当略引。阿难请问。佛说过去不可说劫有一大国。名为叶波。王号湿波。无子祷神。后乃有子。内外欢喜。号须大拏。年十五六无艺不通。纳妃名曼垣。生一男一女。太子广行惠施。施王敌国行莲华白象与其怨国。大臣嗔惧白王。摈太子于檀特山。太子出门一切皆施。无拣车马亦为他乞。太子负男。其妃抱女。至其山所。山有道人名阿兰陀。太子遂问道人。云何可居止。答云。山是福地无处不可。乃造草庵而居有拘留国十二丑婆罗门。年四十方娶妻。妻令求奴婢。闻太子好施去山六千里而来求乞。初遇猎师欲杀之。云王遣迎太子猎遂放之。见太子乞子。太子自缚以施之。其母不在。母目瞤动左手复痒。恐子不安遽归三问。太子不应。复问。方答云。我已施讫。其妻闷绝良久乃苏放声大哭。太子言。汝忆过去提和竭佛时。我为婆罗门子。汝为女卖华。我以五百金钱买汝五华。汝寄二华以上于佛。愿为我妻。我时要汝莫违我意。汝答可尔。今何乱我善施心。帝释知其心坚。复化为婆罗门。亦十二丑。就其乞妻太子即施却来寄太子所。太子怪问。方答云。我是天帝。故来相试。遂复天身令其求愿。妻有三愿。一愿卖我子还至本国。二愿我子不至饥苦。三愿我及太子早还本国。帝释曰如汝所愿。太子发愿言。愿一切众生皆得度脱生老病死之苦。帝释叹言。大哉是愿。非我所能。更求何愿。又愿言。今且愿得大富常行布施。又愿国王大臣皆思见我。帝释言。如意。婆罗门将子归。妇嗔何用王种别求奴婢。遂外国卖子。帝释诱引无有买者。遂至本国。国人识之。白王。王欲抱之。啼不肯就。问卖男人。先言男银钱一千特牛百头。女银钱二千牸牛二百。王问。何以女贵男贱。答言。王之后宫与王无亲。出自微贱而受荣宠。王唯一子。逐之深山。曾不眷念。明知女贵男贱。王遂令人追太子还。付以宝藏恣其布施。遂得成佛。父即净饭。母即摩耶。妃即瞿夷。男即罗睺。女即现罗。复成利母。婆罗门即调达。妻即旃遮那摩。山上道人即目连。猎师即阿难。疏现庄严王如大庄严经。疏又菩萨本缘经。说一切持王施二子者。经有三卷。今当第一一半向后至第二卷一半向前。然其缘起全似须大拏。但彼施一男一女。此施二子皆男。又加乞眼。略无王请归。余多同也。更复略引一切持王好施。施王白象行莲华上力能敌国。国人大臣皆悉恐惧。又虑敌国来侵。遂令摈王子于雪山。山中施二子与丑婆罗门。婆罗门卖之至本国。祖王惊叹。后帝释化为婆罗门乞妻。王子施之。便云。汝妻端正。恐为贼劫。且寄于汝。我要当取。王子闻已默然受之。复化婆罗门从之乞眼。王子欲挑。复止之云。我今未用。且寄汝处。我要当取。王子云我云何受二种寄付。释知心坚还复天身云。妻及目二物是我所有。今且寄汝勿复施人飞空而去。雨华称赞必证菩提。疏然所施化实下。第二料拣。言如贤愚经毗沙门等者。即第一经因梵王请佛说法。佛辞众生垢蔽不如速灭。梵王遂引昔缘劝佛。昔无数劫为生求法。乃至一偈。身心妻子而用施与。何不念昔而欲弃生。过去久远于阎浮提。有大国王号修楼婆。领此世界八万四千小国。初以财施后思以坚实法施遂募说者。毗沙门王见欲往试变身为夜叉。色貌青黑眼赤如血。钩牙外出头发悉竖。诣王宫门云。我能说法。王请入宫欲请说法。彼云。先以所爱夫人及所爱子。与我食者乃与汝法王即以所爱夫人及儿中胜者与之。夜叉食竟为王说偈云。一切行无常。生者皆有苦。五阴空无相无有我我所。王闻欢喜书写流布无有悔恨。毗沙门遂复本身赞云。奇特夫人及子犹存如故。王者佛是昔为法尚尔。今何速灭。释曰。此则妻子是实。乞者是化。疏此破菩萨执者。如净名云。十方世界中作魔王者。多是住不可思议解脱菩萨以方便力现作魔王。故云破菩萨执。二乞者是宝引摄论者即第十一。梁论云。或现种种本生。由逼恼他及逼恼怨对。令他相爱利益安乐心。释论曰。为化邪见众生不信因果。令得正法离恶修善故。化现种种本生。如毗笋陀王舍儿与婆罗门。非是逼恼他。此儿是化作。何以故。菩萨无逼恼。此人生彼人安乐故。又如药藏菩萨。令眉絺王与毗提诃王相逼恼。此亦是化作。后悉令相爱利益安乐心。菩萨行如是事有何利益。论曰。生他信心为先。后于三乘圣道中彼善根成熟。是名菩萨甚深制差别。三俱化可知。四俱宝中二根熟者。如一切施王施儿与婆罗门。婆罗门鞭打持去。至一树下更欲打之。树神手拟婆罗门。婆罗门即倒。神欲断彼命夺王子送还。王子告神。请勿害之。我若再还。令我父王檀行不足。即为不孝之子。神遂放之。此即妻子同行也。尚须自舍身命。岂有辞苦而退。言生生行施处者。即七十五释迦女瞿波昔缘中事。当时妙德童女欲事太子。太子要云恐其为障修菩萨道。彼女意云。我无染心请为主者。偈白太子中有偈云。无量劫顶戴广大金刚山。若能眷纳我。甘心受此苦。无量生死海。以我身肉施。汝得法王处。愿令我亦然。若能眷纳我。与我为主者。生生行施处。愿常以我施。释曰。斯皆根熟之者。疏若依璎珞十五轮王者。即三贤十圣等妙二觉。至随好品当广分别。此中即三禅梵王。若依大丈夫行论中。菩萨喜乐过于世间。及二乘涅槃。此论有二卷。或单云大丈夫论。广说世间胜乐之事皆不及菩萨。见乞欢喜末举解脱之乐亦不能及。即过二乘也。疏瑜伽三十九云。又诸菩萨于施障及对治者。于中初标。二列障。三明治。前二具论文。对治中略取论意耳。然论文繁广收义无遗。论后结云。如是菩萨四种施障。当知四种能对治智。对治于彼。一者觉悟。二者忍受众苦。三者遍知颠倒。四者见一切行性不坚牢。是诸菩萨由前三种能对治智。决定堪能正行惠施。由后一种能对治智。能正摄受施福胜果。当知亦名菩萨巧慧而行布施离相也。疏先绝我想者。即欢喜行中。疏一不于法体起增减者。一切法体不出有无。定有则增益。定无则损减。四于诸法义离断常者。就一有上。即有常无常义。从缘而有。即是无常。不从缘有。即名为常。五三有器界唯识顿变。名为影像。为生所依。想即是心非想非心。此释六于法本遗心非心想。以上诸句皆有想言。一切诸法皆想所持通是有心之义。心为法本故。忘心即为非想。今并遣之故。云六于法本遣心非心想耳。疏有即空故者。约缘有明二空一味等无差故。约真如说皆无有义。然法相所立。依他缘有。圆成性有。今明缘有故非有。二空为性。性即非有。言无无想乃有多意者。略有五义。初一遣无物之无。如虚空龟毛兔角等。二明缘有即无。净名云色即是空。非色灭空。色性自空明有即无故。此明非灭色空也。三明遣无为有。四遣无为非有。三四俱遣以空为有义。五者上四遣病明非有。此句显实明非有不碍有故。故下释云非有非非有矣。此引证也。此非非有即是非无。但言非无含义则少。言非非有含义则多。但言非无。得前二义后之二义。言非非有。方始终摄也。然第一义即古人云。我言非有者。但言非是有。非谓是非有。五明有即空故非有。空即有故非非有。上之五句但顺经文以为二句。此下总遣四句合上即俱句。相夺即俱非。有无之本既无俱句非俱何立。未对释结句非非想。中唯取第四意耳。亦可兼于第五不碍想耳。次对双显缚解者。以分别为缚。无分别为解也。疏次对双显。二业者。即思及思已而为二也。后对亦双明缚解者。有心则生死波浪故非心回向。无心则同乎外道故非无心回向。此即无不碍有义。又以无心下。拂迹以明前意。言有心为非有者有起动也。言无心为非者无观照也。此即寂不失照。后意则寂乎唯寂。二皆有理。疏若本无缚其谁求解者。即闇用净名。不二法门中宝印手菩萨曰。乐涅槃不乐世间为二。若不乐涅槃不厌世间则无有二。所以者何。若有缚则有解。若本无缚其谁求解。无缚无解则无乐厌。是为入不二法门。疏傥然无寄理自玄会者。此言出肇公百论序。彼有二对。具云。其为论也。言而无当。破而无报。傥然靡据。而事不失真。萧焉无寄。而理自玄会。反本之道。着乎兹矣。释曰。此通说论旨。前对不失事。后对不失理。虽不据说于事理。而契当于事理。今疏合其二对但取不失于理。以是离相回向故。傥者俶傥。广雅云。俶傥者卓异也。谓无所依据。卓异系象而暗与理会矣。疏三世求生不可得故者。即总显文意。是中论三时门。从无而有故名为生者。立生之理。下别出三世求不得生相。已生未生正生为三。已未不生理易彰显现在正生理隐故。以不住故过未分之。则无现在之正生也。正同净名。若过去生过去生已灭。若未来生未来生未至。若现在生现在生无住。以无住故即属已未。从为生之理下。结成无生。疏静论语识智者。然依智不依识。识是戏论。依智是寂静今并双非。则不可以智知。不可以识识矣。即法四依。四依之义下文当释。疏第二不碍随相中文三。一总辩来意。二言随相下正明不坏之相。言诸佛依二谛为众生说法。即中论四谛品下。更偈云。一以世俗谛。二第一义谛。若人不能知分别于二谛。则于深佛法不知真实义。前已引竟。三然俗是真俗下。融上二谛成无碍义。疏今初然随相之名下。疏文有二。一辩来意。二略显十义下。正明离相受回向名。前即假征。此下解释。于中二。先总。后一过世八法下别。各随所趣立彼岸别。今初利衰毁誉称讥苦乐此之八法即世间法。八法不动名不动岸。二依蕴计我故有二我。若离二我名为解脱。三寻伺即言语道。道是因故实际绝言故。四念想观除为实智故。五身见以为烦恼障本故。但能断便是有余。六苦依身即为依处。智所依身身智俱亡为无余也。七施等即是所作善行故。八菩萨出有入无。而无染故为无住岸。九证于法身是无漏界故。十生住异灭即是有为世间之法。觉心现量生灭流注无有自性。故成自觉圣智岸也。疏菩提性净下。此有二菩提。一性净。二圆净。从缘起者即是圆净。圆净复二。一明缘起。万行为缘故。二明性起。全是真如性净功德之所显故。又缘起无性即性净故。广如出现。此亦法华云。诸佛两足尊。知法常无性。佛种从缘起。是故说一乘义耳。前已广引。从若业依身下。释不于身中而有业。第七回向。疏今初。牒名中四。初正释名。二此从下得名。三故本业下引证。四即以无贪下。出体性。三中三。一引经。二名无下会今文。三有云下释彼经。先叙异说。后应云下正释义。般若方便即净名。及今经七十九中之意下当广释。恶父母者。无明贪爱。即楞伽第三经云。尔时大慧。菩萨白佛言。世尊。如世尊说。若男子女人。行五无间业。不入无间地狱。世尊云何男子女人行五无间业不入无间地狱。佛告大慧。谛听谛听善思念之。吾为汝说。大慧白佛言。善哉世尊。唯然受教。佛告大慧。五无间业所为。杀父母。及害罗汉。破坏众僧。恶心出佛身血。大慧。云何众生母。谓爱更受身贪喜俱如缘母。立无明为父。入处聚落。断二根本名害父母。彼诸使不现。如鼠毒发究竟断彼名害罗汉。云何破僧。谓异相诸阴和合积聚。究竟断彼名为破僧。大慧。不觉外自共相自心现量。七识身以三解脱无漏恶想。究竟断彼七识佛名为恶心出佛身血。若男子女人。行此无间者。名五无间事。亦名无间等。偈言。贪爱名为母。无明以为父。觉境识为佛。诸使为罗汉。阴集名为僧。无间。次第断。是谓五无间不堕无间狱。释曰。言如鼠毒发者。西方有鼠啮人甚毒。毒在身中。其疮虽差。忽遇雷声。其疮还发。使亦如之。忽遇境雷则还动发。余可知。不灭痴爱下。释一合相义。即净名须菩提章。二乘之人灭痴得明。灭爱则脱。今了一性故不灭之体即明脱。知理无二即是契合。合无合相方是真合。疏然其前十下。料拣。言前十一一遍从中十者。从佛境生小等。从法境生小等。从余八亦然。二中十一一能生后十者。从一佛境能生檀等十度。从法生十度。余八亦然。三后十一一容具前十者。谓布施等有小有大。或一或二或三或四。或具足十。不必皆具。故云容具。戒等九度于前十亦然。四前十一一该后二十者。谓从佛境起小施。或从佛境起大施等。或于佛境起小戒。或从佛境起大戒等。理即昭然云思之自显。疏上六皆巧便殊胜者。通即七种最胜成波罗蜜。初会已具。然最胜亦名殊胜。前虽已释。为对经文须知总意。言巧便殊胜者。彼当第五云要无相智所摄故。故上六句皆无相智。言次五清净最胜者。彼当第七云谓要不为二障间杂。别中一无法执及了唯心离所知障。三见性空无烦恼障。次有三心即安住殊胜者。彼当第一谓要安住菩萨种性。次有二心。即回向殊胜者。彼当第六谓要回向无上菩提。今言善决诸义具三回向者。决智决悲决实际故。次有一心。即意乐殊胜者。彼当第三谓要悲愍一切众生。后之二心依止殊胜者。彼当第二谓要依止大菩提心。上显施中即事业殊胜者。彼当第四谓要具行一切事业。具上七下结成前义。故唯识云。要七最胜之所摄受。方可建立波罗蜜多。以上释经文同符契。疏善趣贤首位之行者。圆融十信位也。种性即十住。解行虽通三贤。今正取行向二位故。故解行发心在于十行。发回向心故。疏密迹力士经第二具说者。亦至第十回向明之。庄严论亦引此经者。论当第六偈。菩萨自成就。如前义应知。声有六十种。是说如来事。长行释中具引佛秘密经。佛秘密经即密迹经耳。并至下明。疏复有处说六十四音等者。瑜伽等说有八转者。疏文但举其唐言之名。今兼显梵音。西域国法。若欲寻读内外典籍要解声论。此八转声方知文义分齐。一补卢沙。此是直指陈声。如人斫树指说其人即今体声。二补卢衫。是所作业声。如所作斫树故云业也。三补卢崽拏。是能作具声。如由斧斫故云具也。四补卢沙耶是所为声。如为人斫故云为也。五补卢沙[多*頁]。是所从声。如因人造舍等故云从也。从即所因故。六补卢杀婆。是所属声。如奴属主故云属也。七补卢铩。是所于声。如客依主故云于也于即依义。瑜伽第二。名上七种为七例句。以是起解大例故。唯有梵语声论八转。更加醯补卢沙。是呼召之声故云呼也。然此八声各有三种。一男声。二女声。三非男非女声。此上具约男声说之。以梵名丈夫为卢沙也。疏是八转声各具八德者。即八梵音。贤首品已明。今当重说。一调和者。谓大小得中故。二柔软者。言无粗矿故。三谛了者。亦云最好如迦陵频伽等故。四易解者。亦云易了。言辞辩了故。五无错谬者。亦云不误言。无错误故。六无雌小者。亦云不女。其声雄朗故。七广大者。亦云尊慧。言无战惧故。八深远者。脐轮发生故。如来具此八转之音。疏若将此下属前佛果者。会异释。即刊定记释二段皆属于佛果。故今明修菩萨行及近善友非属佛耳。疏八云非一非异者。即十通中等者标示也。故彼通中广说非一异义。从以了一切下。出非一异是神通相。若一向非一各互相碍不能相作。若一向非异无二可得。将何相作。以非异故一理融通。非一事故得相作等。疏又非一异应成四句者。一非一。二非异。三非非一非非异。四非亦一亦异。十忍当说。疏初之三句显胜妙生者。即前十度章中引唯识释前三为增上生。道感大财体及眷属故。其胜妙生即增上生。名异义同。后三决定胜道。疏六正助无违者。即经业道不违业。业不违业道。俱舍业品云。俱得名尸罗。一妙行。二业。三律仪。四唯初表无表名别解脱。五业道。六释曰。此有六名。今此即当第六。彼论疏释云。又此初念亦名业道第六名也。本求戒思。今曰。究竟依业畅义立业道名。谓戒前之思名之为业。初念戒体名之为道。思所履故。业家之道故名业道。故初刹那名别解脱。初弃恶故。亦得名为别解脱律仪。能防非故。亦得名为根本业道。畅思起故。第二念等不名业道。非畅思故。名为后起。根本后故。今疏全依俱舍论文故不更引古来异释。疏此之事事所以无违下。出事事无违因。略出三因。一法性融通门。二缘起相由门。上二即事事无碍义。三直语同一缘起。通事通理非无碍义。如睹一叶落知天下秋矣。言亦由后二段令此无违者。后二即事理无违。及理理无违。由此故令事事无违。谓既同一味事。复即理由事即理理融于事故。得事事无碍故无违也。疏然上三段无违下。重总料拣。于中二。一同异类料拣。二开此则有下句数料拣。但就刹众生以成诸句。初根本四句。二刹上理事成四句。三约众生上理事成四句。上二三两四句但是事理无碍。四以刹事对生理为四。五以众生事望刹理成四。此后二四方成事事无碍。疏上二四句各初及第三等者。以事理相望。唯就同类即得成故。言各二及四。虽非无碍。亦不相违。义如上说者。以二四皆是不即故。非无碍言亦不相违者。由上同一缘起故。由不坏之事不变之性皆同一缘起故。疏此中初二句。是理理无违者。一刹无性即众生无性。二理同故言。以无可即亦无可违者。释第二句是理理无违义。疏第四句虽非无碍亦不相违者。第四不碍两存故非无碍。而亦同是一缘起故。及第五四中亦不相违。皆同前二三四句中。亦不相违。疏第五四句等者。言此中初及第三句是。第二段理事无违中。异类事理相望者。以将刹望众生无性。众生与刹是异类也

大方广佛华严经随疏演义钞卷第五十大方广佛华严经随疏演义钞卷第五十一

        唐清凉山大华严寺沙门澄观述

第八回向。疏从所依立名义通能所者。但言真如相即是所依善根。一合如故义通能所。此中有五。一上正释。二故本业下引证。言常照者。以有能所况一合相。复有二义。一有无不二即一合相以同如故。二智与境冥绝能所故。则通能所为如相矣。三若梵下会梵本。四即以法界下出体。能所契合为法界故。五此与前后下拣滥。前即第七以平等随顺众生故。后即九十九即离于能所缚着故。十入法界亦契合故。故其四名多分相滥。疏拣可知。余如第四回向者。彼以善根如于实际。故至一切处。前对此拣竟故今不对第四拣之。疏四中初句总标下。疏文分二。一释总句。二三十一愿下。别释。释中先释可爱。后释此下。正明科释。于中三。初双标。次总者下略释总字。三言横下。双释二章。疏三通受用变化者。但言清净。变化亦有净故无诸烦恼则是受用。既众生往生故皆通也。言余皆土中之事者。四即法门流布。五行即菩萨修行。六即天眼常喜世界生者。天眼彻见十方。七则水鸟树林华池宝阁。八护法。九证法。十心无著。疏无漏法林等。即净名佛道品。无漏法林树总持之园苑下。经三昧为园苑故。疏对上草木者。三草二木即法华药草喻品。初会已引五乘差别。但由智异故。将善观察智以对草木。疏第二三愿明果满三德者。能断是般若。所断是解脱。智周法界即法身取所证故。又初即智德。次即断德。后即恩德。恩德故能现世间。故涅槃三德。释中云如来之身亦非涅槃通色身故。疏初句立宗者。即虽善修正业。而知业性空。量云正业是有法。空有无碍是宗法。因云缘成即无性故。同喻云如幻。幻法从缘。生空有不相碍。正业从缘生同彼幻法不相碍。疏十句五对令四心弥固者。即天亲般若论中答住问也。若依无著即当第一发心住处。然无著十八住处住住皆答三问。三问即应云何住。应云何修行。应云何降伏其心。秦经阙修行问合在二中。言发心住处者。经佛告须菩提菩萨。应如是降伏其心。所有一切众生之类。若卵生。若胎生。若湿生。若化生。若有色。若无色。若有想。若无想。若非有想。若非无想(即广大心)我皆令入无余涅槃而灭度之(第一心也)如是灭度无量无数无边众生。实无众生得灭度者(常心也)何以故。须菩提。若菩萨有我相人相众生相寿者相。即非菩萨(不颠倒心也)论偈云。广大第一常。其心不颠倒。利益深心住。此乘功德满。此偈上半标四心下半说住义。四心利益具自他行故。此深心菩萨应住大乘功德尽圆满矣。言四心者。三界九类皆尽度之。是广大心。令入无余涅槃。是第一心。二乘尚有三。余非曰无余。不名第一。今二种涅槃无余第一。四涅槃中。无住涅槃方为第一。今言无余。即佛无住。往昔但有三涅槃。故不言无余耳。彼疏科上二心名加行住。言常心者论云。如是取众生如我身。常不舍离是名常心。偈中利益解其常义。谓度众生常不离大悲同体。如我之心故名常矣。疏科此心为修行定。言不颠倒心者。疏科为折散心。言不颠倒者。论云此示现离依止身见众生等相故。依身执我名为身见。有我等四即非菩萨是名颠倒。今离此四即是菩萨非颠倒心。大云言。此文即根本智。前文大悲。是后得智。由根本智即离我见。故前大智观无众生相始得成就。又大云解。实无众生得灭度者。总有五义。一众生性空故无可灭。二菩萨后得智同体悲。离自身外无别众生。即无他体。于根本智必先自离我见之相即自无体。既无自他实无众生得灭度矣。三一切众生本来寂灭不更灭故。四顺法性法性无念。心若起念即违法性故。五解法界不度众生。天亲解云。平等真法界佛不度众生。以众生名名即法界。众生阴身阴即法界。众生与佛同一法界岂于此理度众生哉。故净名云。众圣贤亦如也。至于弥勒亦如也。若弥勒得受记者。一切众生亦应受记。以同一如不应别故。斯理特深。天亲下文有此解者。谓教地上诸大菩萨。以初地上尽证真如。令地上学佛平等法界观矣。而今天亲即解此文。大悲同体。是教地前学地上观故为此释。天亲妙意今日晓矣。释曰。上皆晖公之意。今谓不然。且问寂灭与空为一为异。若言一者则初三不别。若言异者异相云何。岂不诠言法性本空寂耶。又寂灭言但是尽相为显实耶。若是显实即同第五同一法界。又同体悲宁殊同一法界。又五法界与顺法性复何差别。非无念智不名真解。是知论明法界生佛相望。论明同体菩萨望生故不应二。则上五解唯应为二。其无念义应合在于不颠倒心。经唯举我以为颠倒。法执不亡岂非颠倒。故不颠倒。约止绝妄想同体常心观冥真理。是故经文以不颠倒释上常心。云何以故由无妄故方能契实。由契理故方得无妄。二义相成故无众生得灭度者。一契空如性空寂灭故无可度。二契不空同一法性。法性平等故无可度。足显玄妙皆就诸佛菩萨观心非独约理故。今疏文直取论意便为正解。复顺今经以今经证。天亲解经妙符圣旨。疏顺缘曰如者。即随缘义。净名云。法随于如无所随故。今谓如随于法无能随故。以如性空方能随缘成一切故。疏而起信云下。此论解释分中初释真如门。正举法体有二。一正显如体。二会执释名。初门论云。心真如者。即是一法界大总相法门体。所谓心性不生不灭。一切诸法唯依妄念而有差别。若离心念则无一切境界之相。是故一切法从本以来。离言说相。离名字相。离心缘相。毕竟平等无有变异不可破坏。唯是一心故名真如。释曰。此上论文自有三段。一就实略标。二一切诸法下会妄显真。三是故下结真离妄。此三皆是正显如体。即离妄伪为真离异相为如。今疏所引即会执释名。具足论云。以一切言说假名无实。但随妄念不可得故。言真如者亦无有相。谓言说之极因言遣言。此真如体亦无可遣。以一切法悉皆真故。亦无可立以一切法皆同如故。当知一切法不可说不可念故名为真如。释曰。此上论文中二。先释。后当知一切法下结。前中分三。初正会执。恐有执言。上言离名字相。何故复立真如之名。故云此真如名亦是假说。二言说之极下约名释疑。疑云。若但假立何故不立余名而立真如。释云。真如者言说之极。此后更无有名故。摄论中。谓真如为究竟名故云极耳。因言遣言立此极名。若无此名无以遣名。若存此名。亦不遣名三此真如体亦无可遣下。约相释遣。古有多释今并不依。今谓此即非安立真如。若安立说。遣妄曰真显理为如。同唯识意。今正拂此二无法非真何妄可遣耶。则真非真矣。无法不如何理可显。故如非如矣。斯则无遣无立为非安立之真如矣。故疏结云唯就遮诠顿彰真理。疏二明种类总有六门。谓一二三七十及百为六类。二中有三及六真如并八真如总有十义。余如十藏及前诸会已说。唯七真如今当说之。即显扬论第三卷摄事品第一之三论曰。真如作意相者。谓缘七种遍满真如作意广说如经。一流转真如作意。谓已见说诸菩萨。以增上法行善修治作意。于染净法时思惟诸行无始时来流转实性。既思惟已离无因见及不平等见。二实相真如作意。谓如前说。乃至于染净法因思惟诸法众生无我性。及法无我性。既思惟已一切身见。及思惟分别。众相作意不复现行。三唯识真如作意。谓如前说。乃至于染净法所依。思惟诸法唯识之性。既思惟已如实。了知唯心染故众生染。唯心净故。众生净。四安立真如作意。谓如前说。乃至于染净法体。思惟苦谛既思惟已。欲令知故为有情说。五邪行真如作意。谓如前说。乃至染污法因思惟集谛。欲令断故为有情说六清净真如作意。谓如前说。乃至于清净法体。思惟灭谛既思惟已欲令证故为有情说七正行真如作意。谓如前说。乃至于清净行。思惟道谛既思惟已。欲令修故为有情说。释曰作意之义即菩萨观余可知。疏但列名略嘱而已。疏一成依持用者即唯识论真如为迷悟依。如四转依义中广辩十地再辩。疏起信说有三大等者。疏文有四。一引论三大。二对会今文。三释论用大。四对会百门。今初全是论文而体大中一者。体大下缺一切法言耳。斯即立义分中。彼疏释体云。真性深广而凡圣染净皆以为依故受大名。随流加染而不增。反流除染而不减。又反流加净而不增。随流阙净而不减。良以染净之所不亏。始终之所不易。故云平等不增减也。二相大。论云。谓如来藏具足无量性功德。故疏释云。二种藏中不空如来藏也。今疏略无如来藏言。但约真如以说相故。谓不异体之德故云性功德也。如水八德不异于水。三用大全同彼疏。释云。谓随净业约自然大用报化二身粗细之用。令诸众生始成世善。终成出世善故。彼论下文具显用相。疏然彼依心下。第二对会今经。亦是解妨。妨云彼论依一心法而立三大真如乃是其一。何得真如具三大耶。故彼立义分中云。摩诃衍者总说有二种。云何为二。一者法。二者义。所言法者。谓众生心。是心则摄一切世间出世间法。依于此心显示摩诃衍义。所言义者。则有三种。一者体大等。通局既异何得引耶。故下通云。以一统二。二皆属如故下解释分中分为三门真如即是一法界大总相法门体。又此二门不相离故。故如必有相用二也。疏然违真下。三释用大义。似太局亦名解妨。妨云真如既为一切法体随流。成法。何得不言能生恶因果耶。故为此通。是以璎珞经云。始起一想住于缘。顺第一义谛名之为善。背第一义谛名之为恶。约违义边。不言生恶。于中先明不生恶所以。后然违顺虽殊下。释为恶体。藏和尚云以违真故不得离真。以违真故非其用也。故今疏云。离如则无可违故不离也。如波违水离水无波。疏若会百门下。第四会释经文。具阙至下当知。疏四约教不同可以思准者。小乘但有生空。始教即立二空及六七等不即于事。终教则即事即如。顿教多用非安立义。圆教即是百门重重无尽。疏五释文于中三。一叙昔。二理皆难通下辩顺违。于中二意。初夺分者。次若取下。纵成分义责不出相貌实则纵成二义。三今且十十下。申今正解。上辩顺违二皆有理。后有究竟分则理长。文中先总明。二初遍一切下别显。即为十段。依唯识第九。前虽随地别释。今为对文类例并举。今初遍一切处。及无相为相即遍满真如。谓此真如二空所显无有一法而不在故。世亲释云。谓此法界遍一切行以无少法非无我故。今言二空无有一法非二空故。今疏云遍满一切。遍满义彰无相为相即二空相。疏二中无能测等者。唯识释最胜真如云。谓此真如具无边德。于一切法最为胜。故注云由离犯戒垢。证此真如德庄严故今无测无对即最胜义。三中下。论释胜流真如云。谓此真如所流教法。于余教法最为胜故。注云。由得三慧照大乘法观此教法。根本真如名胜流真如。或证此如说法胜故。今云于法无碍即教法等为众法眼亦胜流矣。四中等者论云。四无摄受真如。谓此真如无所系属。非我执等所依取故。世亲解云。于此如中无计我所无摄我所。如北洲人无系属。故应说此如非我执我慢我爱无明边见我所见等所依取故。今无著无住即无摄受。五中论云五类无别真如。谓此真如类无差别。非如眼等类有异故。注云。谓生死涅槃二皆平等故无差别。今云毕竟无尽无变岂有别耶。六中论云。六无染净真如。谓此真如本性无染。亦不可说后方净故。中边释云。由六地观十二因缘。知缘起法无染无净。非谓如也。由真如故法无染净。詺此真如。为无染净。今云。无有分别。何有染净。七中论云。七法无别真如。谓此真如虽多教法种种安立。而无异故。注云。虽诸教法依如建立。如无异故今云无所不在。何有别耶。有无同如法岂别耶。八中论云。八不增减真如。谓此真如离增减执。不随染净有增减故。即此亦名相土。自在所依真如。谓若证得此真如已。现相现土俱自在故。注云。谓凡位不减圣位不增。故今云。清净平等岂有增减。九中论云。九智自在真如。谓若证得此真如已。于无碍解得自在。故。注云。谓此地中得无碍解名智自在。今遍一切智。何不知是佛境界真自在也。十中论云。十业自在真如。谓若证得此真如已。普于一切神通作业。总持定门皆自在故。今云。住一切地成佛菩萨业自在矣。然此十如约诠辩体。若不尔者且如非先不遍今者方遍。若不约诠说遍何法。上来略取。文中各有二义以成其名。余各八义取类本名可以意得。疏随地别显唯说十如下。第二解妨。总有四妨。第一十百不同妨。二前后无如妨。三如观难成妨。四回向非如妨。今初妨云。彼唯十如此中说百何要将百以同十耶。故释云。为顺十地且说十如。理实真如具无尽德。十十融摄且说百门。百十皆是一周一圆数顺无尽。耳。疏地前通修等者。第二通前后无如妨。妨云。将百门如配十地如。地前等妙应无如矣。故为通云。地前通修十如。等觉遍等十如。妙觉穷证十如。但同地如无不同矣。疏然异从义别下。第三通如观难成妨。妨云。十地菩萨一地之内。唯观一如加行既成方证其一。今罗百数成观何由。况一味之如何由契合。故答云。约行布说别证十如。就圆融修一含众妙。加行有异说十不同。正证相应本唯一味。随门入理略说百门。若契一门自含众妙。如海一滴味具百川。牵衣一角全体来矣。故唯识云。虽真如性体无差别。而随胜德假立十种。十既假立百门亦然。德用多门非体不一。言能同回向亦融摄无碍者。由如融摄行顺于如。亦融摄矣。故初地中遍达十如。随能证行后后建立。疏称如起行下。第四通回向非如妨。妨云。夫如普遍无法非如。何有如外别有回向。以为所喻。通意有二。一以其所信喻所不信。二若取文义下。为立体式则无前难。疏百门之内下。第三释文于中二。先总后最初下别。既依十如则十十科之。疏大般若云。三世诸佛皆以性空而为佛眼者。见性为佛眼故。疏理无惑计有无常实者。即生公十四科实相义中。具云夫惑情所封则两端斯失。失理背宗所计皆虚。理无惑计则有无并实。实则说空可以袪滞有者之惑。明有可以释守空者之迷。斯则空有二教旨俱得实。释曰。此中有三。初约情非。二约理是。三约教真。今当其中但用理是。疏无有少下。文中三初牒经。二如遍非情下设难。三故应释言下会通。然此段疏为遮妄执一切无情有佛性义。就计此义自有浅深。一谓精神化为土木金石。枭獍负块以成于子。情变非情。非情变情。斯为邪见不异外道。众生计生草木有命故不可也。若说无情同一性故则稍近宗亦须得意。彼本立意约于真如自体遍。故真实之性无有二。故涅槃经说第一义空为佛性。故一切法中有安乐性。摄境从心无非心故。色性智性体无二故。如是等文诸经具有。今谓此释太即太过。失情无情坏于性相。若以涅槃第一义空该通心境。涅槃何以拣于瓦砾言无性耶。广如别破。今直显正义。谓性与相非一非异。情与非情亦非一非异。故应释言以性从缘等。一如涅槃者。拣去墙壁瓦砾等故。二无觉不觉者。真性之中无心境故。三无非觉悟。以无情性融觉性故。故引起信文略一句。然其此义前已引竟。今此复要彼论通问。问云。若诸佛法身离于色相者。云何能现种种色相。答曰。即此法身是色体故能现于色。所谓从本已来色心不二。以色性即智性故。色体无形说名智身。以智性即色性故说名法身遍一切处。今取二性相即互融之义说耳。论云等者。引证非正证前故云亦可证此。可为证者。智及智处同般若故。既二性相即下。结释经文。况心为总相下。举况以释。前结一性义。今结唯心义。总相则无所不摄。又融摄重重即本经意。随举一尘即含法界。何令色境非一性耶。第九回向。今初牒名下文有四。初释名。二此约无碍大用下。结得名。三约脱惑障下。会六释。四即上体用下。出体性。今初有三。一约行释无缚着。引证中诸法无二。所见无著。般若无生能见无著。诸法无二通上能所。诸法即无二般若即无生。三世一合相。竖论无著一合相言。文在三世义通前三。一者一切法无二。二者般若无知。三者上二契合。二又解脱下。约用释名。三于何无缚着耶下。别解缚着。于中四。一指前总明。二别申十事。三若约下一事具二。四惑缚着一义中二。一生死为能缚。由离凡故不缚。言不缚生死者。不为生死所缚耳。此即相不缚不着二乘即所见不着。二境相不缚。能见不着。三现惑不缚。所见不着。种子即所见故。四有不能缚。所见空不能着。五惑不能缚。见智不能着。故虽十事不出相惑及能所见也。疏一毫之善下。即生公释。法华一毫之善。发迹显佛举手低头皆已成佛。言无非佛流即涅槃意。乃至外道典籍亦佛法流况内法耶。大小等教皆从如来大悲所流故

疏。愿成普贤兼二回向者。位后普贤是佛即向菩提。等觉位前即向众生

疏。别有十四根者。按经文数故云十四义合二十二根。如俱舍第十一明。疏胜用增上光显义故者。彼论解根有二义。此依萨婆多宗。故彼论云。最胜自在光显名根。由此总成根增上义。解云。根体胜故为最胜。根用胜故名为自在。体用双彰名光显。由有最胜自在光显名为增上。将增上义以释根也。论云。此增上义谁望于谁。释曰。谓二十二根望谁增上颂曰。传说五于四四根于二种五八染净中各别为增上。释曰。传说五于四者。眼等五根于四事能为增上。一庄严身。二导养身。三生识等。四不共事。释曰。初盲聋等非庄严故。二眼见耳闻避险难故。香味触三是段食性能受用故。三生识等。等取心所。四不共事。眼唯见等。言四根于二种者。谓男女命意名为四根。各于二种而得增上。男女于二得增上者。一有情异。谓男女类别。二分别异。谓形相言音乳房等别。命根二者。一能续过去众同分。二能持现在众同分意根二者。一能续后有。二自在随行。谓经云。心能导世间即自在义。心能遍摄受即随行义。如是一心法皆自在随行。言五八染净中者。五谓乐等五受。八谓信等五根三无漏根。谓五受顺三毒染。信等八根顺清净法随生长故论次叙异说云。了自境增上总立于六根(谓发识了境根名增上)从身立二根。男女性增上(同前分别)于同住杂染清净增上故。应知命五受信等立为根。释曰。谓下二句由上二句得增上义故立根名。谓命根于同分住得增上等。五受于染法得增上。信等于暖顶位中伏诸烦恼引圣道故。大同前解。颂云未知当知根具知根亦尔。于得后后道涅槃等增上。释云。言亦尔者。类显一一各能为根。未知根是见。道已知根是修道。具知根是无学道。未知已知于根道有增上用。见道引修道故。已知于具知根道有增上用。引无学故具知于涅槃有增上用。由具知根心得解脱。心若解脱方证涅槃故。已知是未知之后。具知是已知之后故言后后。更有异说未知已知各于自道断惑增上。具知于现法乐住得增上。已知根义正义所立。二十二根经中略无男女二根余皆具有

疏。兼五受根者。颂云身不悦名苦(损恼义故)即此悦名乐(摄养义故)及三定心悦(谓第三禅五识无故无有身乐心悦名乐)余处悦名喜(余处谓初二禅及欲界处心悦名喜)心不悦名忧中舍二无别(中谓非苦非乐此处中故名为舍根舍在身心同无分别任运而生故虽通二身心二舍同一舍根也)见修无学道依九立三根者。释曰。九谓意喜乐舍信等五根。若在见道依此九立未知当知根。修及无学亦依九立已知具知。论云。如是三名因何而立。谓在见道有未曾知当知行转。故说彼名未知当知根。解云。即见道十五心八忍七智。如苦法忍与疑得俱。未知苦谛名未曾知。后至智位必当知故名为未知当知根。如苦忍既尔。诸余七忍亦然。故忍总名未知当知。中间七智虽能正知良由知谛未遍中间起故。亦名未知当知。故说彼在见道行者名未知当知。又论云。若在修道无未知当知。但为断除余随眠故即于彼境复数数知。是故说彼名为已知。释曰。从道类智已去乃至金刚喻定皆名修道。若在修道上下八谛总已知竟无未曾知。但为断除迷事烦恼贪嗔痴慢四随眠故。于四谛境复数起智知名为已知。又论云在无学道。知已已知故名为知(此释知也谓尽智无生智作知已已知之解故名为知)有此知者。名为具知(此释具义有此者成就义也约成译具也)或习此知已成性者。名为具知(此第一解约习释具也)谓得尽智无生智故。如实自知我遍知苦。不复更知。乃至广说。释曰。即以尽无生智为具知根体。四谛之上各有尽无生义故。云乃至论彼所有根名未知当知根等者。此释名。谓彼未知等行者。身中所有此根故名未知根等也。余如俱舍根品广明信等五根前疏已释命根之义问明品说。疏以不退转是定义者。以精进言经文自有定。但有义故以不退当之。进谓进趣定谓不动。故疏金刚界根者。释此一根疏文有二。一正释。二傍通。今初有四。一双标定慧。二金刚三昧下示定。三金刚正智下示慧。四界即是性释于界言通定慧义。智了心性者。智了即慧契性不动是定。然此根体通智通心二俱名根。故第六回向施心中云。愿一切众生得万字相。庄严金刚界心。心体性坚即金刚心智。符心王同不可坏。心智俱能坏惑。坏惑亦即利义受金刚名。今观心性义含王所。亦即未知当知根等者。二傍通也。金刚定慧即等妙觉。今欲具三无漏根故以此当未知根。未知根正在见道何有金刚之义。故言现观位中得不坏故。现观即见道谛现观也。现观之义十地广释。疏金刚焰下。文中二。一正释金刚发焰。金刚如灯。发焰如教。故双了事理。及能所者。照境为所。亦兼照于能观智也。即已知根者。通照事理如修道中故。二故离世间下。引证双证前二根。初证界根知法性故。二又云金刚光焰根。即证前焰根双照之义。先举经。后佛境有二下。释同一所知中已通事理。二分齐境有能观智故。前释云焰通事理及能所故。后二具知根三无漏根具矣。然心名根清净心王于无分别智。有所依增上义故二智名根。即于后后道涅槃得增上故。如前论释。大小乘说六八等殊。三得成根义类相似故得引于俱舍文证。人常了故。疏其业行界下。疏以十力摄五十二。于文有二。先知众生。后知菩萨。前中有十七想。众生是总。十力皆是化生事故余即明十力所知。一初有五想。皆处非处于佛法等相应为处。不相应名非处故。二业力。三行即禅定行。四即界力。五即解力。六根力。七时即宿住。八持即遍趣行。遍持善恶至诸趣故。九烦恼下。三想即漏尽力。十见佛想。即天眼智力想。取其相皆了知故从法轮想下。知菩萨亦不出十力所知。恐繁不配。离四过失等者。从一切佛智下。即具五功德。疏如声闻中有信行法行等。此二通有退思护住者。俱舍二十五云。阿罗汉有六。谓退至不动。前五信解生总名时解脱。后不时解脱。从前见至生。释曰。契经说有六阿罗汉。一者退法。谓遇少缘便退所得。二者思法。谓惧退失恒思自害。三者护法。谓于所得喜自防护。四者安住法无胜退缘。虽不自护亦能不退。无胜加行亦不增进。五堪达法。谓性堪能好修练根速达不动。六不动法。不为烦恼所退动故。前五种性从无学位信解性生。此五总名时解脱也。以要待时方能入定。及心解脱。言待时者。此有六种。一得好衣。二得好食。三得好卧具。四得好处。五得好说法师。六得好同学。后不动种性名不时解脱。谓是利根以不待时便能入定。及心解脱故。从先学位见至性生。释曰。论云从先学位信解生等者。二十三论云。至第十六心随三向住果名信解见至。亦由钝利别。释曰随三向住果者。随三向人至住三果。随钝利根得名不同。若钝根人名为信解。若利根者名为见至。前随信行今名胜解。谓由信故胜解相显名为信解。前随法行今名见至谓由向见得至果见故名见至。此二圣者信慧互增。故标信解见至名别。言谓由向见得至果见者。以法行人见理情多故。次前论云。且依见道十五心位。建立众圣有差别者。颂曰。名随信法行由根钝利别具修惑断一至五向初果断次三向二离八地向三。释曰。初二句明见道位中有二圣者。谓根钝者名随信行。彼于先时随信他言而行义故。若利根者名随法行。彼于先时由自披阅契经等法随行义。故此上二句下。疏更释此中相承故具出之。下四句即前二圣于见道位立为三向。释曰梵行品已引取意不同。今复引之谓于先时未以世道断欲修惑名具修惑。此为一人。或有漏道断于一品至于五品即为五人。兼前六人至见道中名初果向。趣预流果故。若断六七八品名为次三。此有三人。至见道中名向第二果也。言离八地向三者。谓断欲界第九品为一人。次四禅三空为七地名九品。七九六十三兼前欲界一品。即有八地为六十四人。至见道中名第三果向。故上总有七十三人皆在见道。故见道中名为信行法行。至第十六心去修道位中三果圣人。名信解见至。阿罗汉位名时解脱不时解脱。故疏如声闻中有信行法行等。言此二通有退思护住等者。信行至罗汉有前五见至。至罗汉为不动等。即等取堪达不动。就前五中自有上中下。据法华中则不动罗汉亦有上中下三根。声闻悟不同故。五百千二百亦称下故。况前见道之内有多种人亦是上中下也。言随于一品复有信等者。如一下根亦具五根。而于五中互有胜劣。有人定增有慧增等故。其根品多不同也。今菩萨理观深玄。于一根中能都照耳。疏一准无性摄论以难知故者。即第一论释阿陀那识甚微细言。论意云深拣世智。细拣声闻故论释甚细云。诸声闻对难了知是故不为声闻等开示此识。彼不求微细一切智故。释曰本论虽但云细释有微细之言。辩公亦云此等并难知故。衍法师云所知之事。幽微故能知之智。微细亦难知义也。疏一缘谓专注一境故不散者。释曰此下成德翻上诸过。而小不次一缘成上不散。以善寂成上不乱。以善分别成上不迷。以善住成上不怯怖。疏识所了境通于善恶等者。无分别是智。有分别是识。故晋经下。证成上义。思议是心地。不思议非心地也。此中心地不同心地法门。疏于非心处下。于中二。初正释。二拣滥。言即非心量之心量者。此有二义。若楞伽云。非心之心量我说为心量者。此拂迹入玄。谓以非心量为遣心量。若以非心量为是斯即心量。二者不同上意。谓非心量即不思议之心量者不碍心量故。引第八回向证之。住不思议即非心量。思议不可尽即之心量。以二相即夺故。有下半俱寂灭也。以心与非心下引义证成。疏不为此释下第二拣滥。人多误解情作非情非情作情故。下又纵云。设言于非心处示生于心。亦是非情为情者。既言示生非真无情为有情矣。疏今译以非通二义者。一非法是不善。二是无法。今言无法则非不善。但有无义无义自有二意。疏依第二义者。是上非即无物则法本自无因缘生诸者。全是仁王下卷经。然有二义。一本来自空从缘生故。则同第三义。若唯识等从无至有曰生。自有还无称灭。则法本从无因缘生诸。今依第二义异第三亦顺彼经。须弥巨海俱为灰阳。二仪尚殒国有何常生必灭义。若依第三则从无住本等者。无住即实相异名。疏名或小异等者。今当会之一刹即第六世界。二众生即第二众生趣。三一切法果报即第九法。四众生心即第五众生界。五一切说法时即第八入劫。六法界即第七法界。七尽虚空界一切三世亦属第八入劫。八语言道即第四菩萨位德位但假名故。九世间行即第一世间法。十出世间行即第三菩萨行德。甚微细十句结于九门。故一重明而劫即长时。三世即短时耳。第十回向

疏。今初谓称法界等者。疏文有二。初标会异名。第二法界无量即是所入下。别释其相。于中十。一明所入。二何法能入下。释能入。三谓以称法界之大智下双结成名。四此则位满下结示得名。五等何法界下明法界类别。六然其四事下结通。七故不可但以下。结弹古人。即刊定云等是能等回向行。法界无量是所等事。谓尽十方虚空所摄事法界无可限量。今回法施等善根令成无漏体德及用。显彼数量等。彼数量等彼事法界故。故今弹之所等有四无量有二安局事耶。八言无量下释无量义。九前回向下对前辩异。十即以法施下出体

疏。夫法施者。亦古德意。然各二句今各举一。彼云一则发之以智慧为生解之妙方。二则化之以多人。作津济之弘躅。三则为起行之根本。实倚仗之良诠。四则为入圣之阶渐。标引道之要津。疏略以摘其语用故不指古人下引则全是。疏今不生于化者。即金刚三昧经云。若化众生无生于化不生无化其化大焉。上两句遮过。下两句成德。今但要成德耳。疏示果宝渚者。即法华化城喻品云。譬如五百由旬险难恶道旷绝无人怖畏之处。若有多众欲过此道至珍宝处。有一导师聪慧明达。善知险道通塞之相。将导众人欲过此难。释曰五百由旬众释云云。今依生公。三界途阻二乘路险。此五百是菩萨恶道甚难过也。众人即发菩提心欲求佛智以为宝渚。如来以况导师。故下经云。我亦复如是为一切导师。既知是息已引入于佛慧。佛慧即宝亦喻涅槃于理无失。以会相门菩提涅槃无二体故。故疏双合果道即菩提涅槃。疏有始有卒者其唯圣人乎。即论语第十以世人靡不有初鲜克有终。唯圣人能有始终耳。亦由乾卦知进退存亡。而不失其正者其唯圣人乎。疏然广等四心下。解妨可知。四心已见第八回向。疏二中有二十梵行下。疏文有四。初列十戒。二通用下出体。三今开下释文。望智论文开为二十。若望经文束为十戒。皆用智论释十戒文。以会今经。八九即自在戒。十三即无著戒。余文可知。四又安住下收为四等。疏摄论云若自住邪行等即梁论第七引契经说。若无性摄论当其第五。一句小异。云如契经言。若自住邪行便受他讥谤。是人终不能制止他过失。又云若怀嗔分诲他所犯以非利益。非方便故。言不威肃他转违背起诸邪行。如有颂言。慈怜如一子诲举他所犯。决定令受持后不复当犯。疏沙弥求龙是怀毒回向者智论云。昔有罗汉居近龙池。每至食时皆请罗汉入池供养。罗汉神通兼坐绳床。忽然而去。有一沙弥于一日中临至食时。密在床下攀绳床辕。罗汉不知如常运通至龙池中。从床下出龙王怪问。此未离欲何以将来。以天甘露而供罗汉。以人间味而膳沙弥。沙弥涤钵骇其香味。恨师忿龙兼贪龙女兴心欲夺。龙得他心知沙弥意。复兼头痛求其谢过。沙弥心志毒愿不息。加功精诚后足下水出寻至池边。以衣覆头便化为龙。遂入池中咬杀其龙。夺其宫殿妻子眷属报龙已毕。即兴风云震雷降雹。拔倒寺宇净无所有。国王知之复为立寺。复被毁灭国王大怒。遂檄其龙若更为害当填此池。龙遂谢过谓其师曰。自今已后不敢为恶。然是龙身性多嗔毒恐后还发。若见池上有黑云生。即是弟子起于恶心。当令鸣钟。念摩诃般若恶心则息。后如其言每有云起即称念般若鸣钟击磬云则散灭。释曰此沙弥为龙。有其二意一为贪色味。二为嗔恚而皆是毒疏不畏生死长远等者。即三种练磨心。唯识第九资粮位中。偈云。乃至未起识求住唯识性。于二取随眠犹未能伏灭。长行释未能伏灭中云。此位二障虽未伏除修胜行时有三退屈。而能三事练磨其心。于所证修勇猛不退。一闻无上正等菩提广大深远心便退屈。引他已证大菩提者。练磨自心勇猛不退。注云。第一菩提广大屈引他况已练。广者无边。大者无上。深者难测。远者长时。由此退屈引他已证我同彼类何故退耶。摄论颂云。十方世界诸有情念念速成善逝果。彼既丈夫我亦尔不应自轻而退屈。论云二闻施等波罗蜜多甚难可修。心便退屈省己意乐。能修施等练磨自心勇猛不退。注云。第二万行难修屈省己增修练。偈云。汝已恶道经多劫无益受苦尚能超。今修少善得菩提大利不应生退屈。论云。三闻诸佛圆满转依极难可证。心便退屈。引他粗善况己妙因练磨其心勇猛不退。即第三转依难证屈。引粗况妙。练如行施等尚感贵乐。况我所修清净妙善而无果耶。论偈云。博地凡夫初发心尚拟远趣菩提果。我已精进经多劫不应退屈却沉沦。论云由斯三事练磨其心坚固炽然修诸胜行。今疏初不畏生死长远。众生难度即通说也。转依难证下。即倒牒三种练磨之心故总说云不畏。无性摄论当其第六。疏今初以法师下。辩其圆音文分为五。一标数。二会他经。三随难释。四以义通摄。五别释音声。疏即密迹下。第二会他经于中有四。一会同异。二会有无。三会通教旨。四会他经意。然密迹经即大宝积经中金刚力士会。第三之三卷。当第十。尔时寂意菩萨复问金刚力士。如来有几事秘要。答有三种。一曰身密。二曰意密。三曰口密。口中说六十种音。广赞如来无思无想无言之言竟。即云如来从口敷演。如一言词出六十品。各异音声。何谓六十。释曰。然经直列今加次第。一吉祥音。二柔软音。三可爱乐音。四悦意清净音。五离垢音。六显曜音。七微妙音。八明德音。九无乱音。十无愦音。十一师父音。十二无刚硬音。十三无粗犷音。十四善顺音。十五安重音。十六身所吉利音。十七随心随时音。十八如如悦意音。十九天爱安想音。二十无热恼音。二十一方正音。二十二识达音。二十三亲近音。二十四意好音。二十五欢悦音。二十六和雅音。二十七晓了音。二十八精勤音。二十九和忍音。三十重了音。三十一其响去秽音。三十二应师子音。三十三龙呜音。三十四好雨音。三十五海雷龙王音。三十六真陀罗伎音。三十七哀鸾音。三十八鹰畅音。三十九鹤呜音。四十耆域音。四十一英鸟音。四十二雷震音。四十三不卒音。四十四不暴音。四十五普入响音。四十六去非时音。四十七无乏音。四十八无怯音。四十九悦豫音。五十通畅音。五十一戒禁音。五十二甘美音。五十三进行音。五十四广普音。五十五具足音。五十六诸根无班音。五十七不轻疾音。五十八无住音。五十九响声普入众会音。六十宣诸德音。密迹金刚力士谓寂意菩萨言。是为如来六十梵音。其如来音普遍十方诸佛世界。悦可一切众生心行。释曰已具列六十。今经但四十五缺于十五次下当明。然密迹经但列不释。庄严论第六亦引彼经而兼有释。论偈云。菩萨自成就。如前义应知。声有六十种。是说如来事。长行释云。如来有六十种不可思议音声。如佛秘密经中说。寂静慧如来具足六十种声语。所谓润泽柔软可意意乐清净如是广说(上是论释引经下释云)此中润泽声者。众生善根能摄持故。柔软声者。现前闻法得乐触故。可意声者。由善义故。意乐声者。由善字故。清净声者。无上出世后得故无垢声者。诸惑习气不相应故。明亮声者。字句易解故。善力声者。具足功德破诸外道恶邪见故。乐闻声者。信顺出离故不绝声者。一切外道无能断故。调伏声者。贪等烦恼能对治故无刺声者。制戒乐方便故。不涩声者。令犯戒人得正念故。善调声者。教化教授故。悦耳声者。乱心对治故身倚声者能引三摩提故。心了声者。能引毗钵舍那故。心喜声者。善断疑故。喜乐声者。决定拔邪故。无热恼声者。信受不悔故。能持智声者。成就闻因智依止故。能持解声者。成就思因智依止故。不隐覆声者。不恼而说故。可爱声者。令得自利果故。渴仰声者。已得果人深愿乐故。教敕声者。不思议法正说故。令解声者。思议法正说故。相应声者。不违听故。有益声者。如其所应教示导故离重声者。不虚说故。师子声者。怖外道故。象王声者。振大故。雷声者深远故。龙声者令信受故。紧那罗声者。歌音美妙故。迦陵频伽声者。韵清亮故。梵声者。出远去故。命命鸟声者。初得吉祥一切事成故。天王声者。无敢违故。天鼓声者。破魔邪故。离慢声者。赞毁不高下故。入一切声者。入毗伽罗论一切种相故。离不正声者。忆不忘故。应时声者。教化事一切时起故。无著声者。不依利养故。不怖声者。离惭羞故。欢喜声者。闻无厌故。随舍声者。一切明处善巧入故。善友声者。一切众生离成就故。常流声者。相续不断故。严饰声者。种种显现故。满足声者。一音无量声说法故。众生根喜声者一语无量义显现故。不毁呰声者如所立义信顺故。不增减声者。应时量说故。不躁急声者。不疾疾说故。遍一切说声者。远近诸众同依止故。一切种成就声者。世间法义皆譬喻令解故。上依论牒释故缺其二。与彼经亦少不次。其佛秘密经即密迹经。疏然彼无下。第二会有无(此一)乃是名变。论释亦有此缺十五。疏中但列其九。余更缺。六应添。一耆婆。二英鸟。三雷震震与海雷龙王别故此亦喻故更添。四师父。五亲近。六明德。方为六十。疏又此所明下。第三会通教旨可知。疏法有所本下。第四会他经意。兼欲尽其论释。疏中间下。第三随难别释。疏然六十种下。第四以义通收。疏通言下。第五别释音声。疏若彼润玉等者。涅者水中黑泥。缁者黑色。谓若玉在泥中千载不黑。疏法华云彼国等者。即第二经譬喻品中。授舍利弗记云。其劫名大宝庄严。何故名曰大宝庄严。其国中以菩萨为大宝故。疏楚魏之朝等者其文出论语。疏若言严事过者。然严事即是所成。谓座旛幢盖等百事。其宝香华鬘等即是能成。能成如金银铜铁泥木等。所成如以金为佛菩萨华鬘等百事。以银为百事亦然。能成有十一各各能成所成百事。今云若严事已过者。则不应言皆如宝庄严者。宝严有百事。今过百倍即成一万。何言如宝。如宝但有百事耳。下引晋经即是能成为百。如金银铜铁等为百事耳。故云即以香等为百香等。是能成故。言过此倍之三字译者不妙者。谓但列香等百事何要过此百倍之言。以无可过故。若过宝严事百倍则有可过。次云若别理通者。为顺今经故。欲令过前严事百倍则有万矣。而亦文不便故应回过此百倍向宝庄严下。则能成唯十一所成各万则成十一万。兼前一百有十一万一百严事。疏体用理量俱无障者。理量即如理智如量智。佛地论第三亦名二修。一如理修。二如量修。世间所知唯有二种。一人。二法。若能通达此二空者则永证得真如实际。是故名为理量(总释二修)如理修者。不坏人法如此人法本来妙极寂静为性。故无增无减离有离无。寂静相者。自性清净法本来无生。净心不执名为灭谛。是心有自性清净。及烦恼惑障。如此两法无漏界中。善心恶心独自行故。于一念中两心不相应故。乃至如此而知名如理知(别释初修会归理智)如量修者。究竟穷达一切境界名如量智。若见一切众生乖如境智则成生死。若符境智则得涅槃。一切如来法以是义故名为如量(别释量智即第二修也)至初地菩萨得此二智。以通达遍满法界理故生死涅槃二法俱知(二智起种也)又此两智是自证知见。由自得解不由他得。但自得证知。名自证知见(明自证非他也)又此智有二种相。一者无著。二者无碍。言无著者。见众生界自性清净名为无著。是如理智相。无碍者。能通达观无量无边界故是如量智相(二智相别)又此二智复有二义。如理智为因。如量智为果。言如理为因者。能作生死及涅槃因。如量智为果者。由此智故知于如是真俗等法具足成就(因果义别)又如理智是清净因。如量智是圆满因。清净因者。由如理智三惑寂灭。圆满因者。由如量智三德圆满(二因不同)释曰前文频有理量二智。此方广释第五会竟

大方广佛华严经随疏演义钞卷第五十一大方广佛华严经随疏演义钞卷第五十二

        唐清凉山大华严寺沙门澄观述

    十地品第二十六(尽加所为毕)

疏。初来意等者。文分为五。一总明答问可知。二夫功不下。立理明次。前因后果义次第故。解即十住。行即十行。愿即十向。故为贤终。亲证十如故名圣位。先贤后圣亦次第故。三前是教道者。辩定法门。即九种教证中地前地中相对。言证前三心者。谓直深大悲三菩提心。三贤别增此中齐证。四故无性下。引论证成。前为此因即第三论具云。此闻熏习种子下中上品应知亦是法身种子。与阿赖耶相违。非阿赖耶所摄。是出世间最净法界等流性故。虽是世间而是出世心种子性。又出世心虽未生时已能对治诸烦恼缠。已能对治诸险恶趣。已作一切有漏恶业根坏对治。又能随顺奉事一切诸佛菩萨。虽是世间应知初修业菩萨所得亦法身摄。释论中云。虽是世间者。以有漏故。而是出世心种子性者。是无漏心资粮性故在文可知。五然会来下。辩其通别。一会一品来意。即通晋经阙十定品。重会普光故十地他化中说十一品。则会品意趣别也

疏。约处名他化等者。分三。初释天名。二表所入下显表法。三不处化乐下通妨。二中二。先释他化自在。后释第六天义。前中三。一约二智。二约事理。三约自他。今初证如无心若自不化。后得起用如他为化

疏。事理存泯非即离故者。二约事理释。然事理相望互为自他。泯如不自化。存如他为化。言非即离者。自他既别如事理非即。他化自受如二非离。然其通有四句。一存理泯事犹根本证如。二存事泯理如后得观法。三俱存如齐照。四俱泯。如两亡既事理互为自他。则亦应言他人无心我为彼化。而自望他是他之化故。但云他化。又应唯就证如之上亦有自他。一于境无心唯能证智。如他无心我为他化。即存自泯他。二绝能证智唯有如故。如自无心他为我化。即存他泯自。三不坏能所俱无执故。故云都无所得即俱存义。四取都无所得即俱泯义

疏。因他受用而有所作非自事故者。三约自他释。然曲有二义。一自他隐显义。二自他相作义。前中语则是一。义乃有二。一约见他受用身。土名而有所作。非自受用之自事故。二者大悲为首一向利他。非由自已而有其事。二自他下明自他相作义。如第八地十身相作。经云。此菩萨能随众生心之所乐。能以自身。作国土身。众生身。业报身。声闻身。缘觉身。菩萨身。如来身。法身。智身。虚空身。此即自作他也。又随众生心之所乐。能以众生身作自身。即他作自也。若令众生身作国土身菩提身等。亦有以他作他。今但取自他相作之义。然自作他如自身。无作他作自。如令他化作乐具。又自作他如为他化作乐具。他作自如他为己化作乐具。故云自他相作皆自在故

疏。将证离欲下。二通释第六天义。以是欲界之顶邻梵天故。色界梵天即是离欲。如于佛位。今明十地如在第六希欲。将升邻极证故

疏。三约法下。就法释名。分二。一得名。二十是一周下释名。前中二。先解本名。后释别目。今初本业有三义。一持。二生。三成。本论开为四义。住持为二故。一生者。出生。谓出因生果。二成者。成就。亦通因果。又以因望果始起名生。终满名成。又为因名生。为缘名住。故第三名住。住亦住处。故龙树十住毗婆沙云。十皆住处。名之为地。又因满分相应不退。名之为住。住即不动义故。初地云以不动相应故。四持者。通望因果如彼初地。能持自他一切功德。复持二地乃至佛果所有功德。若无初地余不成故。若合住持但是三义。则同本业为功德依。地能持故能持为持。所持为住。住亦依义。然若望离佛智外无可修行。由行佛智而成十地。则佛智为能持。如下经说。十山十德皆依于海。海喻佛智。若望不修十地不得成佛。则佛智功德皆是所持。十地能持。今约此义下会唯识义唯识云与所修行为胜依持故。阙生果义。本论云生成佛智。佛智已含因果。论及经中皆詺此地智为佛智故。况住持中不唯佛智无尽功德皆依持故

疏。有别行下。二释异名。名十住经。即藏中大十住经。以古译十地为十住故。十故毗婆沙亦是十地。言仁王兼明者。有住地二字。言入理般若者。入者证也拣于地前。未证真理所有般若不得名住。是则住字亦有二义。一者以无住住。二者安住不动

疏。三宗趣下。疏文有三。先正明宗趣。二别示体性。三问答料拣。疏。总有二义者。前义以行布为宗。圆融为趣。然总含别义。谓证即初二。初证契合。二即所证故。智即第三。断即第四。修行即五六。寄位即七九。证及修行共为第八。其撮要宗不出上九。亦含在总中

疏。后别中下。疏文有三。一正明十义。二以义收束。三结成宗趣。今初一约本唯是果海者。此义即示说分齐中。论经云。我但说一分。论解云。是地所摄亦有二种。一因分。二果分。说者为解释。一分者是因分。以于果分为一分故。然因果二言略有二意。一唯就十地以明。以证智为果分。方便寄法等并为因分。此复二义。一以修证相对则方便造修为因分。息修契实为果分。二以诠表相对。则以寄法显地为因分。真实证智为果分。二约究竟佛果。对普贤因。说义通一部。谓此证智冥同果海为果分。地相之因同普贤因便为因分。然论唯前意就究竟果说。乃是古德义。取论意疏存二义。故云虽通一部此品正明

疏。二约所证者。约已出障故云离垢

疏。三约智中亦通方便者。正唯二智。以后九方便即后得故。初地方便未是地故。如欲入二地起于十心。是住初地后得智中进修十心。所谓正直心。柔软心。堪能。调伏。寂静。纯善。不杂。无顾恋。广心。大心。此十若满即入二地。二地入三地等皆准此知。初地加行若未圆满正属地前四加行位故。今言亦通者。后九方便望于本地。虽是后得望起后地为方便故。初地加行在十地会。明非回向位。故属初地则此会中。亦有未入地行之方便也

疏。四约所断。谓离二障种现。一者分别。谓邪师邪教及邪思惟。生入初地时便能永断。二者俱生。生而便有此于修道地地断之。此又二种。一者现行。二者种子。若俱生所知种现地地断之。若烦恼现行亦地地断。俱生烦恼种子直至金刚无间道断

疏。五约所修者。所修正约行时故。禅道品等起行各别

疏。六所成者。唯成四故

疏。七约寄位行者。下论名为别地行相。一地一度显位别故。此中寄位唯就大乘显位差别。不同二乘寄浅近法等。故十地说行略有四别。一十地差别行。如第五门。二约三学行。如第六门。三约二利行。如第八门三道品行故。四约十度行。即如此门。然十度行曲复有三。初别地门如今文。二约增胜门。则初地成檀。二地成二度。以戒加檀。前檀已得故。乃至十地加智。十度即圆。谓前已得后不失故。三约圆修门。地地之中皆修十度。初心菩萨尚自圆修。岂况登地唯施无戒等耶。明知具足。今显地差故言各一

疏。八者约法有其三德者。若远公云。宗趣者何。若就经本义要唯有三。一所说教道之行。二所显证道。三所表地法。言所说者。一切地前因分之行随相造修。可以言说故曰所说。言所显者。一切地中果分行德舍修契实离相离言。但可寄彼因分修相。显标真德故说斯德以为所显。言所表者。向虽显德意不在事。为欲寄彼诸佛菩萨离相净证。表彰地法以为所表。良以地法众生自实。情倒谬解处而不觉。今欲即情拂妄显实令人趣入即妄辩真在理难彰。故寄净证以表法也。若就论说宗要有四。一是所释经本言教。二是所成教道之行。三是所显离言证道。四是所表地之法体。今疏就约经中加不住道成真德故略无地法。地法即是所证十如。及与果海之所摄故既不别释。经论不同故不存于论之四释

疏。九约寄乘者。谓初地明施。复显人王即是人乘。二地十善生天是欲天乘。三地八定是色无色天乘。故以初三为人天乘。四地初断俱生身见。观于道品同须陀洹。五地四谛理终寄阿罗汉。六地观缘寄于缘觉。七地一切菩提分法方便涉有故。寄三乘之中大乘菩萨。八地已上既是一乘故不云寄

疏。十撮要者。本分当明

疏。于此十中下第二以义收束不出圆融行布。如二中所证十如。若约十如各异即行布门。若约一如无二。如十如之德各互相收即圆融门。三中约十亲证浅深之异即行布门。若约证如之智。如既圆融智无异相。一证一切证即圆融义。四中若约所断十障即行布门。皆是所知一断一切断即圆融门。八中三德随地不同即行布门。以教同证并皆无住即是圆融。十中六决定不出证智等。例前可知故通二相。初一双非者。以离言故。若说圆融未免于言。言地地别宗者。如初地以施为宗。二地以戒为宗。余非不修不成宗故

疏。别论其趣不异总趣者。第三结成宗趣也。上十别宗初明相异分二不同。后圆融融之十皆具二。一一行布为宗。则圆融为趣。若具二为宗。则一一皆成佛为趣

疏。论其体下。第二示体性也。于中亦二。先别示十体。后以总收别。今初然解上十宗体可例知。但有开合取舍之异耳

疏。六取光明三昧即证入体者。上说如智合明但双举能所证法。今以人就法正明三昧。刚藏以如如智合如如理云正相应故

疏。收此十体下。第二以总收别者。言配属可知。十中初一即离言体。二三四六皆克实体。五七八九十皆总含体

疏。问何为地前下第三问答料拣。先问深浅。后答明欲唯显一乘。有标征释。释中有六。一示三一之相。二若俱下反举非理。三故于地前下顺答其难。四故虚空下引证。五故刚藏下结深。六以文成立四中。引四文证。一鸟迹即示说分齐中。二大海是地影像中。三即第一经云菩萨住于一地具摄一切诸地功德。四文文之内即说分中辩并如下说。五结深如下明

疏。又此一会下。六以文成立。于中二。初标。由无方便及进趣故。知摄前后。故为甚深。后所以下释。于中四。初正明。二若尔下解妨。三若别立下反举立过。四十地甚深下结酬

疏。第四释文下。然下用论小异于古。谓论先具牒经文。后以论释。远公先委释经后复释论。后人多取远公释论之文。不观前文释经之处。故多阙略。今皆对会二处释文为一异也。二昔人或释经竟后牒论释。或复牒论而后释论。今则经中易者则直用论为疏释之。或令义显加一两字。若经文难则先释经后引论释。若论难者先牒论文后方疏释。或先取论意以解经文。后引论证。为二异也。三晋经论经及今唐本三经。不同贤首释。晋远公释论后人但取以释今经。若不善会时有差失。今同则不明。异则通会。为三异也。四古德随难释论而不具用意。令经论相对而讲故。无论本释经不尽。后人则多牒论。又不委释论。语既难对。于论本讲之尤难。今则叹易皆牒。难者则释。设有不引彼论易了故。有论无论讲皆无滞。为四异也。已知文意次正释文

疏。文分二。先总科判。后随文释。前中若准远公。就经分判有其二义。一寄人显德。二就法分别。初中复二。一约化主。二约助化。此二各具体相用三。化主三者。佛成正觉显证法体。次七日思惟以彰德相。下论云。思惟因缘显不共法故。后金刚藏入三昧下彰其德用。二就金刚藏助化三者。初入三昧显证法体。诸佛同加显德胜相故。下诸佛相与赞叹。乃能入是大乘三昧。起分已下是其德用。释曰。此上各三深有所以。以非释法故略不明。今疏科文即是就法分别耳。疏文分二。先傍论依经科。后为四十八下。依论约义科。前中又二。先正科判。后明次第。前中复二。先前后襵叠科。从后襵之则有三重。若从前数应为四段。一此界说地。二结通十方。三菩萨证成。四偈颂总摄

疏。前中或总为一下。二增数展转科。欲明此十须知论中初地八分。谓一序分。二三昧分。三加分。四起分。五本分。六请分。七说分。八校量胜分。下文开合多涉此八

疏。言加分已去皆是流通者。以己之德流彼信地说为流通。若约显法益及末代则属教摄。信行菩萨次下当明

疏。或为四分者。具列应云。一序分。二法说显地分。三约喻显地分。四流通分。言教证准前者。若约教道即正宗开二。已如上列。若约证道即流通开出。应云一序分。二正宗分。三法说流通分。四喻说流通分。然下释文但就教道故。疏但云于正说中

疏。或为五分者。亦准约教道就序分二。一序分为远序。二三昧。加起此三为近序。后三同前四中

疏。或为六分者。即于前五分合初二序为一由致。闻法说显地以为三分。若立名者。一起化由致分。二略说赞胜分。三彰地超言分。四广明修相分。五寄喻显德分。六德成证实分。然其义意下文广明。今当略释。故于疏中皆有一句。如初分云为生物信者。佛法大海信为能入。初分显六成就明信可知。三昧分信其亲证。起分信其将说。第二分云起众乐欲者。示体举名。赞是三世诸佛同说故生乐欲。第三令生正解者。刚藏令知心地无我。令闻空中风画之相。示其深玄不许随识。令随智解诸佛加请。令开胜藏广智妙行。入住展转修习之相。复示分齐义。说二大同不同相超言绝虑故生正解。第四分令起行可知。第五分言显德者。说于四喻显教证德。宝珠大海显证深玄。十山四河彰教深广故名显德。第六分言德成证实感化斯现者。此段意笼下文结说证成地利益。故菩萨证成即是证实。现瑞证成即感化斯现余如下说

疏。或分为七者。于中二先正科合。论入中后二为说通十地故

疏。后问论云下。解妨难。先难。后答于中五。一反诘以成。谓十地皆说何以初地偏受说名。二故知下。正示通义。五尘皆色色独受名。初地在初论偏名说。三若以论云下。引例反成。论主既云初地所摄有其八分。前六既通七何不通。若前六不通应独为初地入定。不应通举十地名体。三家五请应唯请初。前六既通七通何爽。四是知八中下。结示正义。后一即校量胜分。五又下说下。重遮外难。恐有难云。下文论云已说请分自此已下正说初地。明知说局。从既有初地说分下。是疏通难以论例释初地有说地地有说。复应更有难云。若许说通则此一品唯有九分无四十八。亦应答云。随地别科有四十八。十地通说为九无失

疏。或开为八分者。谓说分分二。云七说分八地利益分

疏。或为九分者。即于前八说分中。开应云七法说分八喻说分九利益分。疏或为十分。初为十地即是论意。因便故来下是疏意。既加偈摄则现瑞证成。结通十方。皆属地利益摄

疏。此十次第有下。第二生起次第。先标三章。说即教道。证即证道。三即合二。后初之一义下。随章别释初教可知疏。请分拂相显寂者。刚藏三昧显证深寂。令亡情相知心无我悟于地智本寂默故。疏。寄修相以表德者。此言有二。一通。二别。别则七为修相。八为表德。通则可知

疏。或为四十八下。第二依论约义科。于中二。先正科。后问答。今初先且依论具列对疏可知。论曰。十地法门初地所摄八分。一序分。二三昧分。三加分。四起分。五本分。六请分。七说分。八校量胜分。二地即第四论。论云如是说证正位。依出世间道。因清净戒说第二菩萨离垢地。此清净戒有二种。一发起净。二自体净。三地即第五论。论云依第三明地差别有四。一起厌行分。二厌行分。三厌分。四厌果分。四地即第六论。论云第四焰慧地。依彼净三昧闻持如实智中显示此地差别有四分。一清净对治修行增长因分。二清净分。三对治修行增长分。四彼果分。五地即第七论。论云第五地中。分别有三。一胜慢对治。二不住道行胜。三彼果胜。六地即第八论。论云如五地中三分。差别一胜慢对治。二不住道行胜。三彼果胜。六地亦如是。应知转胜。十地即第九论。论云第七地中。有五种相差别一乐无作行对治。二彼障对治。三双行差别。四前上地胜差别。五彼果差别。八地即第十论。论云八地中有七种相差别。一总明方便集作地分。二得净忍分。三得胜行分。四净佛国土分。五得自在分。六大胜分。七释名分。九地即第十一论。论云九地中有四分差别。一法师方便成就。二智成就。三入行成就。四说成就。十地即第十二论。论云菩萨九地中。以作净佛国土及化众生。第十地中修行令智觉满足此是胜故。此地中有八分差别。一方便作满足地分。二得三昧分。三得受位分。四入大尽分。第五释名分。六神通力有上无上分。七地影像分。八地利益分。已列四十八分。今疏从类例不次。而引对论可知

疏。问初第八中前七下。第二问答料拣。于中有二问答。初问论科通局。后问初不说戒下。释通外难。前中先问后答。答中二。先诃问非以文难义故。后岂不下示正可知

疏。次正释文中言虽有四事下。疏文有三。初引论解局意。二而不言下出论局意。三若以下将论义通

疏。以是初时下。疏文有三。初略释胜义。二论经别行下会今无二七之言。三且依论下正征释初胜。前初有多云且依论。于中有四重征释。一明初七不说义为思惟故于中先依论释。后因者下。以疏释论。引法华中然彼以智慧为所说。此为能说。小异大意是同。故下论释众疑何因何缘。论云为因说者不能说耶。为缘听者不堪闻耶。即其义也

疏。论云本为下。第二征释思不说意可知

疏。论云何故显已法乐下。第三征释受乐之意。成上为利众生。非己自要受乐

疏。何故唯行因缘行下。第四征释唯因缘意。前段及此俱是论文。从谓穷智究竟下。疏释论于中二。先顺论文释其通相审法观察。又因缘下。明唯约所证果海得不共名。疏宫即下。疏释论文

疏。若以欲顶下二难成胜义。于中三。初取意征起。二引论正释。三谓机感下疏释论文。于中二释。一物机为感佛应为果。二又色界下。一向就机能感果报释。下引二经皆明他化能感胜果。若唯约下。反成后义。则前正说义。言失所表者。失地智无心等故。则前正说对下显胜。后将欲顶难对上显胜故。独第六得名处胜

疏。众胜五科中。初文分三。一拣大异小。二拣尊异卑。三拣新异旧。并可知

疏。二叹德略明中。言证佛所证即是如来者。此明是等觉菩萨故。即十定品意。举其十对。以是义故则名为佛。以是义故即名菩萨。恐繁不引

疏。七中若顺三乘者。今依瑜伽论释中明。已见上文。疏五标法主中文有三节。第一释菩萨说。从谓彼同类而能尔故。疏。释疏菩萨众多下。第二释金刚义。上句义生。次何故下皆是论文。后此释下疏释论。但释利义坚义文显。疏下释藏义下。第三释藏。然含摄名藏。前已总释。今将金刚问藏。从此问意下。疏释问意。次而论下生起后答。藏即名坚下。论文。谓如树下

疏。释言就能藏名藏者。金刚即藏。持业释也。从又如怀孕下。论文从此谓子孕下。疏释。所藏名藏。即有财释也。从论下广释合下。论文从此之一合下。疏释论。然能藏即地智。所藏即因果。俱有坚及生长故得通合。余可思准。第二三昧分。疏文有四。一释文。二会论。三出体。四入意。今初

疏。照二无我证如名慧者。照理即根本智。照事即后得智。此二通十地故。能破见惑。局初地证智。谓分别随眠。及无明言通于十地。地地断二愚。离所知故。亦以上二智别对二惑。慧破见惑。智断无明

疏。一拣异凡小者。地前为凡不破惑故。不证理故。不得称大。二乘为小。二乘见道现在前时。唯断烦恼。唯照生空故。二能断下。当相辩大

疏。论经下。第二会论。则光明即智者。光明乃从喻得名。全喻智慧即双含体用。言同唯识第九四定者。四定已见第六回向。出现更广。然论释云。一大乘光明定。谓此能发照了大乘理教行果智光明故。即知大乘之言通体用矣。即今大字

疏。然其体性下。出三昧体。三合为体非独定也

疏。所以入者下。第四入意。言二即以此义显非证不说者论文。唯有上语。此即取意为第二义耳。然非思量境。直就法体显其离言。非证不说约人就法。言余四如十住者。三示法体故。四观机审法故。五上受佛加故。六下为物轨故。其三昧是法体。即次下论文

疏。加分有六。初辩加所因可知

疏。二能加佛现等者。疏文有二。一略消经文。二上二三下。依论解释五段。释文于中分二。先合解。二三同显多故。后别释第四。前中四。一标举显多。二若尔何以下。释成多义先举论。谓无量下疏释。三若尔但趣举下。释成十字。四何要显此多下。释多所以

疏。何要同名加下。第二别释第四段。先问意云。若显多佛。何不说一切异名佛加。岂不更多。故论有二答。初意中二。先举论。然论文有三。初标本愿。二何故如来下。释愿所以。三本行菩萨时下。出愿相。从此中论意下

疏。释论于中。先顺文释。后以义释。前中二。先释论第三愿相后所以同者下。释论第二出愿所以。然上论文显示多佛故。此三昧是法体者。此言稍略。合云显示多佛同依此三昧法体故。此明佛得三昧同于菩萨故。疏云为显菩萨所得法体同于多佛。反释论文。从人异道同下。结成同意故。诸佛菩萨从地门显皆名金刚藏。从回向显皆名金刚幢等

疏。若以义取下。第二义释前明诸佛本愿。今显遮那本愿引下经证。即是次文双辩加定因缘中文。彼既主佛愿加则其愿相同多佛也。第二意可知。然结云前就法理者。证金刚智名皆同故。此就化仪者。谓化仪诱物故。言踊悦者。非金刚体有此悦也。约化仪中二义故悦。一约自行。诸佛证穷金刚之智名金刚藏。我入此定上造佛境是故悦也。二约利他。我入此定将演斯法恐物未知。今佛自说与己名同。众知金刚藏同佛所证。言必信受故踊悦也

疏。第三同赞得定

疏。第四双辩加定下。疏文有四。一略嘱经文。二料拣通局。三彰冥显加异。四定其因数。疏初之一事下。第二料拣通局。然其论文但有前二。无现威自智。论释已具。疏文今先连引论云。彼佛先作是愿。今复自加。后余佛加故。云卢舍那佛本愿力故加。疏离开。论以释二因。则以论文后余佛加为后加相。今主佛愿为后加因细寻可知

疏。若约得定下。第三彰冥显加异。所以辩此者。由古人以初伴加为显加相。后之三因唯是加因。则因与加别为因义成。今既后三皆通定因。今已得定。那言非正加相。加相在后故有此义明加有二。一则冥加。在于定前加令得定。二则显加。要得定后方堪受加故

疏。是则定因下。第四定其因数。伴佛之加唯是定因故。加因阙一足前得定还成四因。故上云赞其得定显有加因。于中三。初正明。二所以第三会下。引例成立。三故不可下。结弹古人。初文可知。二中凡言又亦皆是重义。上已有一下方言又。若初伴佛是其加相。主佛本愿初是加因。何得言又亦字同此。明知伴加已是定因。下三亦是定因故云又耳

疏。故不可下。第三结弹古人。先直非。后若此已下。出其所以。成后复重疏。余如第三会辩者。彼处广显差当故略叙少分。一者十住中古人以初一为定因。后三转为加因。亦非是定因。二者前自问云。加之与定何先何后。若先定后加则不应言汝能入是三昧。此是诸佛共加于汝。若先加后定则不应在三昧分。后又散心不能受加。古人通云加定一时故

疏。前难云为因不成不同俱有因义。加定可分故。示正义云。加有二种。谓冥加在前显居定后等。故云余如彼疏

疏。第五明加所为等者。然论有二问云何故加。复云何加。以复云何加。是征加相。下文重征故。此不释。疏。义虽兼通者。以自利中有善能说法。利他中有习无漏法。则是互有。今通云从多。多有二义。一句多。二如善说法。亦通二利。今取自利之能故。故分二利。略有四门。一就行体。六度等行以为自利。四摄等行以为利他。二就行益。六度四等成之在己皆名自利。劝人修起尽名利他。三约修。说自他二利。自分所成可用化人皆名利他。胜进分中一切行德修之未熟未任化他。唯可自习名为自利。如下第九地法师方便中说。四就义门以分自他。诸行皆同一体互相助成。自利门说皆成自利利他门说。无不利他。今就第四故云兼通从多说耳。文有二十句。分二。初十依自利。后十依利他。前中二。初直释经文。二通会本末。前中又二。初释总。二释别。总中二。初会二经同异可知。二正释经文。二初总标三义可知。二别释三义。分三。初所被机中。言被何等机者征也。二释经一切菩萨。先举论可知。从此通二类下

疏。释然其分位。略有二种。一信二证。趣证方便决定名信。正得云证。若大位以分地前名信。地上名证。故下论云。已入初地非信地摄。即疏初意。若通相说地前地上。皆有未得名信。已得名证。今此菩萨为信非证。即疏后意。于后意中。疏文有二。先标举立理可知。后以摄论中下。引证于中二。先引摄论。意言之义。已见上文。即是意识依名言分别故。是地地加行非正证也。通四位者。五位之中唯除究竟耳。后下释所入下。引当论证

疏。二叹能被法中二。初征可知。二释中。三谓标释结初标可知。释中此明十地法体等者。是疏释论。然道有二义。一即证道当相名道。二道即因义。即疏中意

疏。既是佛因下

疏。释经文。佛法有二义故。一是佛因法。二是佛所证法。同证如故。从心言路绝释不思议。谓言语道断心行处灭故。前文已具。然远公云。叹胜之辞也。据法望情名不思议。以其法外本无情故。其义云何。情相之兴原由妄想。妄想故便有相生。以依相故复起心想。随名取实即是觉观。依此觉观便起言说。既言说已复起心想。取所说法此即言语以之为道。心以为行。于是心想炽然不息。今契法实灭除妄想。相即不生相不生故。立名心灭。名心灭故名即不生。名不生故觉观不起。觉观不起故言说随亡。言说亡故不复依言取于所说不取说故。言语道断心行处灭。心行灭故名不思议。以法出情心言不及。故不思议。今就情望法故不可思议。释曰。言虽繁重亦有理在

疏。二说能证下。即释经光明字。先举论可知。从此谓下。疏释论。于中二。初正释可知。后地法虽多下结成。于中又二。先结成论意。谓地法无量门不出能所二智。故将此二以释光明为至当也

疏。见智虽广下。结成于疏。谓见智二字虽有多释此释正顺论意故云正宜。解深密下证成。此释要当缘总法者。万法虽异一智以贯故云总法。随事相差名为别法。故与疏释义理合也。言见智虽广者。略示一二。般若论见即是智。拣于比智故云见也。拣于眼见故云智也。又远公云。俱是一智随义立名见智。是解得证。是行解有始终。见始智终。推求名见。决断称智。行有始终。得始证终。法显在心名之为得。心冥合如说以为证。上之二解虽各有理不如前解。契合论文故云正宜。以其二义遍摄诸法故。三结可知

疏。三中说此何益下。即释令入智地之经。于中三。初征起总标。二引论释。中二。初解令入。又二先引论证。后此中信乐下。疏释论。若准远公云信乐得证皆是入义。信乐入始。得证入终。于证决定名信。信增名乐。得证如前。此亦有理。疏意可知。二入何法下。解所入。三上说能所下。结归总意可知

疏。此九种入下。是疏解释。先科为四。愿乐即是地前

疏。近地方便下。通妨。谓别九入依总开出以总詺别。皆带入言。即入约证地前未证何得属入。究竟非因岂为地智。故云近地方便等通前愿乐。后胜进下。通后究竟

疏。言九入者下。别释九入全是论文。若有疏释自当指出。初一全是论文。二思义入者。然思慧二句后句思成。此句正思。思必依义云思义入。从方便者下。是疏释论。会就经文。疏。彼彼即是下。疏释。疏修通二利下通妨。谓既言前十自利。那明善说通意可知

疏。五证入者。从言平等下。即疏释论。此入是道正证真如。故唯识论通达位颂云。若时于所缘智都无所得。尔时住唯识离二取相故。释论曰。若时菩萨于所缘境无分别智都无所得者。不取种种戏论相。故尔时乃名实住唯识真胜义性即证真如智。与真如平等平等俱离能取所取相故。能取所取俱是分别。有所得心戏论相故。解曰。此即总释偈意。言俱离能取所取相者。谓能证智及所证如。俱无二取。又上言不取者。离于能取。种种相者。离于所取。余可思准。一次论云。有义此智二分俱无所取能取相故。二有义此智相见俱有。带彼相起名缘彼故。若无彼相名缘彼者。应色等智名声等智。若无见分应不能缘。宁可说为缘真如智。勿真如性亦是能缘故。应许此定有见分释曰。即破前师之义。先破无相。谓如智之上无真如之相而能缘。如色等智上无声等相应缘声等。后破无见中。言勿真如性亦是能缘者。同无见分而能缘故。三次彼论云。有义此智见有相无。说无相取不取相故。虽有见分而无分别。说非无取。非取全无。释曰。说无相取下。即瑜伽七十三文。既无相分何名缘彼。彼论次答云。虽无相分而可说此带如相起。不离如故。如自证分缘见分时。不变而缘。此亦应尔。变而缘者。便非亲证。如后得智应有分别。故应许此见有相无。释曰。谓此缘真如智。挟带真如之体相起。故名所缘。非带相分影像而起。名缘于如不离如故。释曰。上之三师。彼论以后义为正。依今经宗应双取前二。有即俱有能所宛然。无即俱无能所斯寂。此二无碍方名证如。然今疏文先释平等。从二我下。释善清净。释平等中。但观上来所引唯识居然易了。若细委配。言平等者。即无分别智。将论就经。论中平等即是经中无分别义。从无分别智正证真如下。释无分别称平等所以。即唯识中平等平等。疏二我分别随眠不生名善清净者。释论善清净言。论意正明见道时中清净。今疏先释清净。后重解见道得名。言二我者。即人我法我。二我为本而起二障。今言二我。意取二障耳。故唯识云。烦恼障者。谓执遍计所执实我萨迦耶见而为上首。一百二十八根本烦恼。及彼等流诸烦恼随烦恼。此皆扰乱有情身心。能障涅槃名烦恼障。释曰。欲界四谛各有十惑为四十。上二界各除嗔有七十二。为百一十二。并是见道根本之惑。然疑及三见唯是见断。修道之中欲界唯六。上二界除嗔各五为十。故修有十六。见修合辩有一百二十八。论曰。所知障者。谓执遍计所执实法萨迦耶见而为上首。见疑无明爱恚慢等。覆所知境无颠倒性。能障菩提名所知障。释曰。见疑已下。辩出头数与烦恼障同。烦恼障粗有多品类。二乘所断唯是不善有覆性故以数未显。今所知障细无品类。唯菩萨断。亦是异熟无记所摄故不显数。又显法执无明唯一住地烦恼。即是四住地摄故不显数。言慢等者。亦等随惑。言所知境者。有为无为。言无颠倒性者。谓真如理。由处此境令智不生。前则烦恼即障。今所知之障。然二障别义本在我法两字。故二我言即二障。言分别随眠者。分别拣于俱生。谓依邪师邪教邪思惟生。言随眠拣于现行。即是种子由上二不生故名清净。故唯识云。如是二障分别起者。见所断摄。任运起者。修所断摄。二乘但能断烦恼障。菩萨俱断永断二种。唯是圣道能伏二现行。通有漏道。释曰。今是大乘复是断道。异于地前伏及与二乘名善清净。疏。最初照理立见道名者。此释上论见道时中。故唯识云。加行无间此智生时。体会真如名通达位。初照理故亦名见道。释曰。此是彼论释位名也。此智者即无分别智。体者通也。会者达也。照理名见。见即是道。而言初者。此应有难。若照理名见。二地已上岂不照理。故今释云。此最初故以此受名。余随别义。此言时中即真见道中故。唯识云。真见道者。谓即所说无分别智实证二空所显真理。实断分别二障随眠。释曰。既真见实断明是真见道中。二见道义次下当说

疏。六不放逸入等者。初举论说世法不染

疏。会经文言修道者。唯识颂曰。无得不思议是出世间智舍二粗重故便证得转依。释论曰。菩萨从前见道起已。为断余障证得转依。复数修习无分别智离能所取故。说无得及不思议。或离戏论说为无得。妙用难测名不思议。释曰。此释偈初句言余障者。即俱生二障。故今论云一切烦恼障。以所知障亦以烦恼为能障故。任运而起不由分别故名俱生。此上辩立修意断俱生惑故。从复数修下。出所修法体。离能所取下。辩修之德。即释论偈无得不思议言。论有二释。初远离所取名为无得。远离能取名不思议。上唯就体释。下约体用对明。疏。故世法不染者。以经帖论。既离烦恼即世法不染。即唯识论是出世间智也。释论云。分别是世间。无分别智断世间故名出世间。二取随眠是世间本。唯此能断独得出名。或出世名依二义立。谓体无漏及证真如。此智具斯二种义故独名出世。余智不然。即十地中无分别智。释曰。言余智者后得智也

疏。七地地转入中此明修道下。故疏释论文先释地地转入以地非一故。言离障者。即是十障。如本分明。言证理者。即证十真如。如第八回向下说分中随地别说。从于地地中下。释净善根义。于中二。前明正地善根净。后论复有下。明加行善根净。亦即唯识第三句意。论云。数修此故舍二粗重二障种子。立粗重名性无堪任。违细轻故令彼永灭。故说为舍此即总意疏。于地地中双断二愚者。谓开上十障。一各成二故有二十愚。若兼等觉有二十二愚。今约十地故说二十。下说分中亦皆别说今当略示。初地断二愚者。一执着我法愚是惑。二恶趣杂染愚是业。二地二者。一微细误犯愚。二种种恶起愚。三地二者。一欲贪愚。二圆满闻持陀罗尼愚。四地二者。一等至爱愚。二法爱愚。五地二者。一纯作意背生死愚。二纯作意向涅槃愚。六地二者。一现观察行流转愚。二相多现行愚。七地二者。一细相现行愚。二纯作意求无相愚。八地二者。一于无相作加行愚。二于相自在愚。九地二者。一于无量所说法无量名句字后后慧辩陀罗尼自在愚。二辩才自在愚。十地二者。一大神通愚。二悟入微细秘密愚。至说分中地地之初各辩其相。然唯识此后更有二愚。障于佛地位。谓一于一切所知境极微细着愚。即是此中第二智障二极微细碍愚。即是此中一切任运烦恼障种

疏。即大尽分下。疏释论。入如来十种秘密者。经云。又入如来秘密处。所谓身秘密。语秘密。心秘密。时非时秘密。授菩萨记秘密。摄众生秘密。种种乘秘密。一切众生根行秘密。业所作秘密。得菩萨记秘密。如是等皆如实知。疏。故叹净名云下引证。即问疾品文殊叹也。经云。尔时佛告文殊师利。汝行诣维摩诘问疾。文殊师利白佛言。世尊。彼上人者。难为詶对。深达实相善说法要。辩才无滞智慧无碍。一切菩萨法式悉知。诸佛秘藏无不得入。降伏众魔游戏神通。其慧方便皆已得度。今取一句。疏自下通会本末中。二初会末归本可知

疏。后明本末无碍等。以六相圆融者。然远公四门解释。一立意。为破定执。二立依。依初地行例释。三泛就诸法以释。四释文。三中如一色中同时具足有苦无常等诸法义集为一色为总相。无常色等为别相。无常等上皆有色言是同相。无常非苦等是异相。成坏二门约体同异成前二门。以彼异相苦无常等体不相杂。是故随彼差别多色得摄为一故。取摄为成以彼异相苦无常等义不同故。一色随之分成多色。故名为坏非实成坏。如色既尔。即色无常为总亦然。谓色无常苦无常空无常等别余四例知。余同相亦然。色体既尔一切法亦然。今疏文中牒论便释无别释文。又以易故无别立依。但有二门兼取贤首义理分齐中意故。今疏中总有七门。一总彰大意。二标举显通。三彰其立意。四列名略释。五总以喻明。六举例遍释。七指广在余。今初谓欲六相圆融令本末无碍故。从本起末即前直释经文。中依根本入开为九入。根本无别于中说九故。云无别之别。言次摄末归本者。即向会末归本门九入为别。会归根本。言非根本入有此差别者。别而无别

大方广佛华严经随疏演义钞卷第五十二大方广佛华严经随疏演义钞卷第五十三

        唐清凉山大华严寺沙门澄观述

疏。论云。一切所说下。第二标举显通。法之体状目之为相。义别为门。又由此通入证智中故

疏。此言说解释下。第三彰其立意。先举论此显下。疏释即贤首意。为显一乘圆教法界缘起。无尽圆融自在相即。无碍容持乃至因陀罗网无穷理事等。此义现前一断一切断。一证一切证。乃至即具普贤圆因十佛境界故。此言说者。约教道解释故。后勿以下释除事之言。论中但云谓阴界入等。今疏加执取之言以释论意。意不令人随事执取。非阴界体不具六相故。远公云。如阴等色。非受想乃至非识。如是一切以其别相无总相故。不得将别对总说成之与坏。故曰不具。若就体性一一阴等悉具六相。如向泛就诸法中辨。疏言六相者下。第四列名略释。先须总识其相。一总相者。一含多德故。二别相者。多德非一故。三同相者。多义不相违故。四异相者。多义不相似故。五成相者。由此诸义缘起成故。六坏相者。诸缘各住自性不移动故。列名皆是论文。此标下疏参释之。欲分主客先一时出论。论云。总者是根本。入别者余九入。别依止本。满彼本故。同相者入故。异相者增相故。成相者略说故。坏相者广说故。如世界成坏。余一切十句随义类知。释曰。其中有疏可以意得。疏九相渐增者。疏释如摄入是闻慧思义入是思慧。后后胜前。故以渐增为不相似。言揽九缘成一者。成一入故。言分一作九者。九义不同总入随之。故无别一也。然准远公成坏二门。因上异相而有故言成。是略者以彼异中闻思修等体不相应。是故随彼九入复成一入故。名为略。坏是广者。以彼异中闻等九种义不同故。总入随之。分以为九。故云广也。亦可总则揽别而成。别则分总为别。同则别。别带总。异则别。别互乖。成则双揽同异方成。若无异相总不成故。如舍椽梁总皆相似终不成舍。坏则唯别。各住自性故。此三对历然不同。疏又云如世界下。论喻成坏。从犹如下。即疏释论。谓三轮四大等即成刹之缘起。揽为娑婆。故名为成就一分为百亿四天下。无别娑婆称之为坏。非如世界二十劫成二十劫坏。疏亦如梁等下。第五以喻总释。即贤首意。疏余一切十句下。第六举例遍释即论文也。疏别章广显者。即第七指广在余。即贤首教义分齐。彼唯三门一教兴义。二列名略释。三问答料拣。前之二门上已具竟。今但明问答寄就一舍之上辨。其六相例法可知。问何等是总相。答云舍是总相。问此但椽等。何者是舍。答椽等即是舍。独能作舍故离即不成。若尔未有瓦等应即是舍。若未有瓦等不是椽故。以无瓦等对何说椽。若诸缘共出少力共作。不全作者有断常过。但诸少力不成一全舍故舍则断也。不成执有是无因常。今去一椽即非全舍。明椽全成椽即舍也。由此全成便令此椽即瓦栿等以去于椽。即舍便坏则瓦栿等亦皆坏故。故此诸缘皆即是椽舍方善成。一缘既尔。余缘亦然。故缘起法不成。则已成则圆融。第二别相者。椽等诸缘别于总故。若不别者总义不成。由无别时则无总故。是故即以总为别也。问若总即别应不成总。答由即别故。故得成总。如椽即舍故名总相。舍即是椽故名别相。若别不即舍。不是椽故。若舍不即椽。不是舍故。若不相即总在别外即非总也。别在总外即非别也。问若不别者复有何过。答有断常过。谓若无别即无椽等舍不成故。无而执有无因常故。下之四相各有断常。可以意得。第三同相者。椽等诸缘和合作舍。不相违故皆名舍缘。非作余物故。若不同者。诸缘相背则不同。作舍则不成。与总何别。答总相唯望一舍同。则诸缘互望成力义齐。第四异相者。椽等诸缘随自形类相差别故。问异应不同。答由相各异长短等殊。方为舍缘同力成舍。此与别何异。别相诸缘别于一舍。异则诸缘自互相望。第五成相者。由此诸缘舍义得成故。由成舍故椽等名缘。不尔二俱不成。问现见诸缘各住自性。何因得成。答由不作舍。舍方得成。以若作舍失本缘故。舍不得成。今由不作诸缘现在故舍得成。又若不作舍椽不名缘。今既名缘。明知作舍。第六坏相者。椽等诸缘各住自法本不作故。若作舍者即失本法。舍则不成。由不作故舍得成也。又总即一舍别即诸缘同即互不相违。异则诸缘各别成则诸缘办果。坏则各住自法。乃为颂曰。一则是多为总相。多即非一是别相。多类自同成于异。各体别异显于同。一多缘起理妙成。坏住自法恒不作。唯智境界非事识。以此方便会一乘。六相之义略已终矣。疏第二又令得下。十句依利他行。疏文分二。先总明句数开合。言增数十者。依大智度论数法有二。一小二大。以十为十。数狭名小。少减名之为狭。数宽少增名宽名大。七八等名少减。十一十二等名为少增。今据大数名增数十。以十二为十故。疏初句为总下。正释文。先释总句中依论有二解。一就教行解。二教证相对解前中始于地法决定名信。信增名欲。欲是信果故。依欲趣法名为亲近。摄法在心故名忆念。念法不失故说为持。地法是其所持。疏地地皆尔故云十地始终者。疏结释经文。非论文也。十入约次位。始终约行修。行位并举如下经云。复应于诸佛菩萨善知识所。请问第二第三地等相及得果。为欲成就彼地法故等皆其例也。明知地地之内皆有始终。问何故自利云入。利他云始终。答自利以入证为本。故皆云入。利他令知性相。故有始终。疏复有阿含为始下。第二教证相对也。疏中三。初总次别后结示。今初言阿含者梵言。此云净教。既唯以证为终。而行非是证故。前教始行终。并名为始故。疏结云则前皆是教。疏此教证义总有九重下。第二别释也。疏犹下请中字义二藏者。即下如来加请中义。偈云。佛子当承诸佛力。开此法王最胜藏。诸地广智胜妙行。以佛威神分别说。论云。叹此法藏有二种。一义藏成就。二字藏成就。云何义藏。诸地上妙行。即今经胜妙行。论云。行者诸菩萨行。所谓助道法故。妙者真实智故。上者神力胜故。如是显示深妙胜上故。释曰。初是助道真实智即证道。神力胜是不住道。次论云。云何字藏。偈言。分别智地义。即今经诸地。广智及分别说谓十地差别相故。论云。分别说者。说十地差别故。既以分别说为字。明是言教三道皆为义藏。明以行德为证。论以字义为教证故。疏二地前地上相对者。远公云。二约位相对。解行已前依教修行名为阿含。初地已上离言合实说之为证。疏如下请中叹众以地前闻思修等为教净等者。即解脱月叹众堪闻请中文。经云善净深心。此句为总。下九别云。善洁思念善修诸行善集助道。善能亲近百千亿佛。成就无量功德善根。此五别句为教净。次云。舍离痴惑无有垢染。深心信解于佛法中。不随他教名为证净。释曰。以前五句属地前故。疏三真伪相对等者。不与如合随世而修名之为伪。契如为真。疏中先正释。后引证。正释中云即于地中闻思修慧报生识智缘照之解名曰阿含者。此第三教证。不对地前。但就地上而论教证。故云即于地中。总有四法。皆名为教。三慧及报生识智下请分中具明。谓地上菩萨生来即有此智。故云报生识智。非约证如故皆属教可宣示故。真智出言故名为证后下论云下。二引证。即许说分齐中文而是义引。故云闻思修慧是则可说。若具引者。即彼论释经云智起佛境界。非念离心道。非蕴界处门智。知意不及之偈论云。此偈示现思慧及报生识智。是则可说此智非彼境。以不同故。即其文也。疏四修成相对者。引证言义说二大者。即许说分齐中全意。谓如来大仙道等十二偈。分之为二。初七偈义大。后慈悲及愿力下。五偈说大。说大中有证智故云真。有加行后得缘世法故。故云伪。真伪合修义大。中唯明证智。故云舍伪契真。又准下文。解脱月双叹人法请中。此是菩萨最初所行。成就一切佛法故。论云最初所行者。依阿含行故。成就一切佛法者。谓是证智。释曰。此明依修而证。亦修成相对。疏五相实相对等者。其所引文即本分中彰地要胜内文。经云。此是菩萨摩诃萨向菩提最上道。亦是清净光明法门。释曰。上句证下句教。论云叹说者。于中有二义。一者为说阿含。二者为证入义。其论释上句云。增上胜妙法故。疏云增上妙法。论释证句云。大胜妙法者。诸法门中胜故。清净法者。即法体也。光明者。此大乘法。显照一切余法门故。既云照余法。则得修相。既云最上明契本离相。故彼下经自释二句。释初阿含云。所谓说菩萨诸地。释证句云。佛子此处不可思议。所谓诸菩萨随证智。明是相实相对。疏六体德相对等者。谓所成行体为证。成德为教。引炼金喻者。十地皆有炼金之喻。且初地云。是菩萨随所勤修。供养诸佛教化众生。皆以修行清净地法所有善根。悉以回向一切智地。转转明净调柔成就随意堪用。佛子。譬如金师善巧炼金数数入火转转明净调柔成就随意堪用。释曰。火即能炼。喻供养佛等。金即所炼。喻信心慈悲舍等。如世之金在矿石中融治便出。喻真地法与妄和合名曰众生。行人修行至初入地时。出烦恼障。今至地满。复更供养教化众生。如重入火熏发真心。令生信等名为修行清净地法。至二地时。如重以矾石煮之方得清净。初地之时。虽除悭垢微过犹在。至二地时。悭嫉破戒并皆远离如转清净。至三地中。修习净禅令其不退。如秤两不减。四地集起菩提分法。如为庄严具。五地之中。以不住道方便起观修治力故。如砗磲磨莹转更明净。六地以观因缘不住巧智修治力故。如琉璃磨莹光色转盛。七地中具修一切菩提分法益更精妙。如以众妙宝间错庄严转更增胜倍益光明。八地之中无功用修。如持金宝冠置阎浮提主圣正顶上。一切群臣诸庄严具无与等者。九地菩萨智自在修。如善巧金师用作宝冠。转轮圣王以严其首。四天下内一切小王。及诸臣民诸庄严具无与等者。十地菩萨业自在修。譬如金师以上妙金作庄严具。大摩尼宝钿厕其间。自在天王身自服戴。其余人天庄严之具所不能及。释曰。十地皆具金喻。意皆以金喻证。显本性故成信等德。以为教道。是修成故。然云金与钏等者。此经无钏之文。即严身具是。疏七体用相对等者。引文云下珠放光光喻于教。珠体喻证者。即第四地调柔果中。云如摩尼宝清净光轮能放光明。非诸余宝之所能及。风雨等缘悉不能坏。论云。摩尼宝生光喻者。彼证智法明摩尼宝中。放阿含光明入无量法门智处。普照示现。以是义故。此地释名为焰地。即其事也。疏八自分胜进相对等者。引文云下叹金刚藏二力妙智。及辩名为证力坚念教法为阿含者。即大众请中经云。上妙无垢智。无边分别辩。宣畅深美言。第一义相应。念持清净行。谓前四句叹证。念持清净行叹教。论云。初偈叹证力辩才成就。第二偈上句。叹阿含力辩才成就。以证力阿含力故。能有所说。是故赞叹是也。疏九约诠就实相对等者下。引论云。字身住处证智所摄。非无地智名句字身者。即下示说分齐中鸟迹喻也。经云。如空中鸟迹难说难可示。如是十地义。心意不能了。论云。此偈是何义。如鸟行空中迹处不可说相亦不可见。何以故。虚空处鸟迹相不可分别故。非无虚空行迹。如是鸟迹住处名句字身住处。菩萨地智所摄。不可得说。不可得见。不可得闻。何以故。非如声性故。非无地智名句字身。此中深故示义大踊悦。释曰。空处之迹喻教。迹处之空喻证也。然上九重教证。前五前教后证。后四前证后教。又前五教则后后渐宽。证则后后渐狭。后四中证则后后渐宽。教则后后渐狭。疏今当第四者。第三结示兼遮妨难。恐有嫌繁。故以论文但云复有阿含及证。如是次第依初相应知。谓令以阿含为始。以证为终。故云如是次第。依前始终前始后终。云依初相应知。何用广明。疏意恐人教证既多对文生疑。故总并说。岂得为繁。疏次依根本始终有十始终下释别句义。疏文有四。一标指。二总科。三料拣。四正释文。今初。谓菩萨利他行该法界随宜例十耳。二前三地前下总科可知。三此狭前入下。料拣言故此略无者。明有亦无妨。若出所以。此中利他略自所闻。疏一摄始终下。四释文。于中初一句摽名。二牒经。三谓以下释义。此取意释。若具论云。思慧智随所闻义受持说故。谓如经如实说菩萨十地差别方便故。论经加方便之言。谓善巧集成十地之相。今经即差别中收。然论受持即释摽中摄义故。疏云摄持所闻即自摄也。此上释论。称思宣说下。以论释经。若不称思非如实说故。论云思慧智说如实说者。即是摄他。前入即以说为修。此则以说为思。亦是影略。以前说后无修故。以说为修。此中说后有修故。以说为思。疏二欲始终缘念佛法下。以论释经。论具云令证一切佛法故。今谓经明缘念。非是自念。欲令物证所念法故。论云。欲言上品求心者。有二义故。一令物证。二唯缘佛法故。疏三行始终。论释云。观分时中。无漏道品分别修觉相故。论中修字释摽名行字。依念进修名行。行即此经修习故。疏先解修习之言。疏言分别无漏法下。牒经解释。即明地前菩萨于地上法而起观修。但是意识名言分别。次以未证下。释论观分之时即加行位。然观分言论释彼经观字。以论经云观达分别无漏法故。后带相已下。释经分别字。谓带如相故。论名修觉相也。即唯识云。现前立少物。谓是唯识性。以有所得故。非实住唯识。彼论释四加行云。皆带相故未能证实。故说菩萨此四位中犹于现前安立少物。谓是唯识真胜义性。以彼空有相未除故。带相观心有所得故。非实安住真唯识性。彼相灭已方实安住。彼疏释云。心上变如名为少物。此非无相故名带相。若证真时彼相便灭者。即是空所执相。有依他相名空有相位。谓有空相是彼唯识真胜义性。由有此相未证真理。灭空有相方证真故。彼论结云。依如是义故。有颂言。菩萨于定位。观影唯是心。义相既灭除。审观唯自相。如是住内心。知所取非有。次能取亦无。后触无所得。释曰。此则结四加行。谓初二句暖位。次二句顶位。次二句中下忍。次一句即上忍位。合上三句为世第一。末句见位也。疏四证始终。具足论云。四证始终见道时中法无我智方便故。如经善决择大智慧光明方便故。是中善决择者。择中最胜。最胜者法无我智故。大智慧者。过小乘故。光明者。对治无明故。此事中彼时中皆善知故。释曰。此中论有三节。初略释。次引经帖。后是中下随难牒释。今疏摘论锁经。义无遗矣。然经中巧庄严字是相见道。上皆真见道。疏乃当中先释大智。此二见道即唯识第九。今欲释疏须知根源。先当具引彼论。论中先总释偈意已。如上证入中已具引文。今但引二见道。即彼次论云。然此见道略有二种。一真见道。谓即所说无分别智。实证二空所显真现。实断二障分别随眠。虽多刹那事方究竟。而相等故总名一心。释曰。言虽多刹那者。此一心见道以无间解脱并一切胜进故。中间有多刹那论云。有义此中二空二障渐证渐断。以有浅深粗细异故。有义此中二空二障顿证顿断。由意乐力有堪能故。释曰。加行意乐欲俱断故。论曰。二相见道。此复有二。一观非安立谛有三品心。一内遣有情假缘智能除软品分别随眠。二内遣诸法假缘智。能除中品分别随眠。三遍遣一切有情诸法假缘智。能除一切分别随眠。前二名法智。各别缘故。第三名类智。总合缘故。彼疏云。即三心见道。释曰。非安立者即真如也。内谓内身。假者谈其无体。先计有情皆妄所计。但有内心似有情现。今能遣之。缘智者。谓能缘心中。即缘内身为境。遣有情假缘之智。然此中人法二障各分上下。粗者为上。细者为下。合为四类。然二粗者各别除之。以智犹弱未双断故。若上品智方能双断。此即随智说为软等者下也。初智名软。次智名中。胜前劣后后起名上。能断见惑此智最上。然初二智未能殊胜别缘内外身除我法假。第三心时其智上品。广缘内外若我若法。故三别也。言类智者。前智俯故。论云法真见道二空见分。自所断障无间解脱。总别建立名相见道。法者仿学为义。真见道中虽有二空自证分。而见分亲缘真如所以法之。然见分中有无间解脱。随自所断障。虽有四见分无间道中断惑别故。人法二见分各别法之。立初二心。解脱道中证理同故。人法二见总以法之。有第三心故。论云。总别建立名相见道。论云。有义此三即是真见道摄。以相见道缘四谛故。有义此三是相见道。以真见道不别缘故。释曰。论以后义为正。故疏但云相见道有二。论云二缘安立谛有十六心等。前回向品十六智宝处已引。但观上所引论文疏文易了。然疏中有二。先标位云即见道位。通二见道。次大智下牒经以释。当中牒释者大智即是二见道依。依真见道以立相故。故先明真言即真见道者辨位言根本法无我智者出体也。谓即所说无分别智。然唯识论实证二空。今文为简胜二乘故。标法无我言治无明者。根本智用正破迷理无明。疏此智亲证真如下。释善选择大光明言。而善字两用。善观察者实证如故。即上唯识实证二空所显真如。从平等平等下。即前论文正释论偈无得之言。以能证所证俱离二取故。有二平等言离二取相即平等义。若有二取非善观故。疏实断二障下。即全用唯识论文。用释善选择语。二障即烦恼所知。前入就根本能生故云二我。今通就能生所生故云二障。其分别随眠已如前释。疏即相见道下。释相见道中文分三。初正就相见以释庄严。二双就二智以释庄严。三释本论。初中即相见道者。办位也。是后得智者。出体也。故论名方便者。以论证成是后得义。方便即巧者以论会经。疏法真见道种种建立者。释庄严义。具如上引。谓三心十六心。故云种种建立。疏又庄严下。第二双就二智以释庄严。不同前义但用后得。言由得此二善达法界者。法界有事理二智别能了之。亦以无碍二智。了事理无碍法界等也。疏于多百门等者。谓于一念顷得百三昧得见百佛。知百佛神力。能动百世界。能过百佛世界。能照百佛世界。能教化百世界众生。能住寿百劫。能知前后际各百劫事。能入百法门。能示现百身。一一身现百菩萨以为眷属等。故云于多百门皆由二智得自在也。疏论云。此事中下。第三释本论。然古有三释。一云此事中。即真见道。彼时中即前观分之时。二云此事中。同前彼时中。即后修道位中亦须善了。如下发趣果中。须知二地乃至佛果等。三云。此事。即后得相见道中。彼时中即是根本智真见道。皆须善知。今以后义稍正故依傍之而皆属相见道。并是后得故异昔解。以法真见道观彼正证亦后得故。疏相望前真故名为彼者。则相为此也。疏五修道始终等者。修道之义已见入中。疏论云。出世间智智力者。出世间智即根本智。重言智者。即后得智。从以后得下。疏释可知。疏上寄从二地至七地者。以功用行满二僧祇满为一类故。初地二见道。后即是修道。且约地分见属初地故从二说。疏寄入八地至于佛地者。然论但云此处菩萨于菩提有五障。不配地位。配即远公之意。而彼不立等觉。即佛地之中治于二障。又彼云寄在八地至于佛地。则最后句以为佛位。便乖后无佛尽之言。故疏云寄入八地等。则正在等觉断第五障当入佛地故。未有佛尽。然疏文有二。先寄位释。后约通相释。以此五障地前即容对治故。地地用之。由上已配七地故。依远公先配八地已上。然此五障亦虚亦实。谓有此障者不得五种功德。名为实障。已登地者实无此障。假立显得名之为虚。五中前二是其解障。次二行障。后一用障。今初解障。疏不能破邪论障即是所治者。乖理之言名曰邪论。不堪以正摧邪称曰不能。此一段具有瑜伽十五释。因明中论有七例。颂云。论体论处所。论据。论庄严。论负。论出离。论多所作法。第一论体有六。一言论。二尚论。三诤论。四毁谤论。五顺正论。六教道论。一言论者。谓一切言说言音言辞。是名言论。二尚论者。谓诸世间随所应闻。所有言论。下取意略引。三诤论。谓或依诸欲。所起自他所摄诸欲。更相侵夺等(云云)或因恶行所起。自身恶行他相讥毁等(云云)或依诸见所起(云云)四毁谤论者。谓怀愤发者以染污心振发威势。更相摈毁所有言论(云云)五顺正论者。谓于善说法律中。为诸有情宣说正法(云云)随顺正行随顺解故。六教道论者。谓教修习增上心学。增上慧学。增上戒学等(云云)最后二论是真实。能引义利所应修习。中间二论。能引无义。故应远离。初之二论应分别之。第二论处所有六。一于王家。二于执理家。三于大众中。四于贤哲前。五于解法义沙门婆罗门前。六于乐法义者前。第三论所据者。据即依义。所依有十。谓所成立义有二。一自性。二差别。自性谓有立为有无立为无。差别谓有常无常等。能成立法有八。一立宗。二辨因。三引喻。四同类。五异类。六现量。七比量。八正教(云云)同类谓随所立法。望余展转少分相似(云云)异类望余少分不相似。现量有三。一非不现见。二非已思应思。三非错乱境(云云)此下取意释。谓初如眼见等。二如良医授药。色香味足有大势力。才取便成取所依止。病若未愈名为应思。其病若愈名为已思。亦如瑜伽师作地水火等观。建立境界取之所依。三非错乱者。谓想乱数乱等(云云)上总谓有世间现量。有出世间现量。谓出世智所行境。七比量者。谓与思择俱已思应思所有境界。此复有五。一相比量。如见烟比知有火等(云云)二体比量。谓现见彼自体性。比类彼物不现见体。如以现比过未等。又如饮食衣服等现见一分得失之相比知一切等(云云)三业比量。谓以作用比业所依。如见远物无有动摇。鸟居其上比知机等。唯闻哮吼比知师子等(云云)四法比量。谓以相邻相属之法。比余相邻相属之法。如属无常比知有苦。以属苦故比空无我(云云)五因果比量。谓以因果展转相比。如见有行比至余方。见至余方比先有行。见善作业。比知当有大富等(云云)八正教量者。一切智所说言教。此复三种。一不违圣言。二能治杂染。三不违法相(云云)已说论据。第四论庄严者。略有五种。一善自他宗。二语具圆满。三无畏。四敦肃。五应供语具圆满。谓凡有所说皆以其声不以非声。声者具五德。一不鄙陋。二不轻易。三雄朗。四相应。五义善相应者。谓前后法义相符(云云)无畏可知。敦肃者。谓如有一人待时方说而不嚵速是名敦肃。应供者。谓如有一人为性调善不恼于他。乃至言词柔软如对善友(云云)第五论堕负者。谓有三种。一舍言。二言屈。三言过。舍言者取意。谓辞谢。对论者言我不善论等。二言屈者。为对论者之所屈伏。或托余事方便而退。或引外言。或现愤发。或默然等(云云)言过者。谓杂乱粗犷。不辩了。无限量。非义相应。不以时。不决定。不显了。不相续等(云云)第六论出离者。先应以彼三种观察论端方兴言论。或不与论名论出离。谓一观察得失。二观察时众。三观察善巧及不善巧。观得失者。谓我立论无自损损他俱损等耶(云云)观时众有僻执耶。有正见耶等。观善巧不善巧者。谓自观我于论处论据等为善不善等(云云)。第七论多所作法。有三种。一善自他宗。二勇猛无畏。三辩才无竭。由有此三能善酬答。故名多所作法耳。释曰。上所引瑜伽略其大纲。广说如彼。但观所引论文疏文居然易了。今更略释。一随所住处等者。即善于他宗下次第显说兼善自宗。然经云随所住处。亦兼论处所。而文正在执着之处。故次便云次第显说等。疏以宗因喻现比教量显己正义随病治之上皆论所据者。显己正义即所据中所成二义自性差别。此二即是己宗能成。入中文但有六阙同类异类。以此二但约所立与余有少同异。故是喻及宗中摄之。言随病治之者。以所执非一故。疏辩才即论体者。流于听表曰辩。巧应物心曰才。即是言论宣说教道顺正理故。疏亦论庄严者。标下出庄严。庄严有五。无畏一种。前句已有。善自他宗。后所作法中兼明。此但有三。一语具圆满。二顺言者。即是应供。谓不恼于他言辞柔软。故曰顺言。三敦肃可知。疏又上皆论多所作法者。此标谓总收上二门。一句以成所作法。一善自下列。言配文可知者下二可知。善自他宗。即随所著处即善他宗。次第显说即善自宗。疏谓善观察得失等者。等取余二。谓时众及善巧不善巧。从由具上诸义下。即仍前五例释不堕负谓有体有据有严有作。既出离有能何得堕负。疏由破此障得入八地者。谓七地中犹有此障不入八地。破故得入下四句例然。疏上明能破此显能立者。总释意也。因明论云。能立与能破。及似唯悟他。现量与比量。及似唯自悟。此之一偈总有八义。一真能立。二似能立。三真能破。四似能破。五真现量。六似现量。七真比量。八似比量。今此辨于利他故但明能立破。而菩萨离过但有真能立破。无似能立破。疏又上五障下。二重收总释不要对他。则令诸菩萨皆离此五则得菩提。疏第六正显加相等者。疏文有三。一引论生起。何故加结前。云何加生后。言云何者。谓加相云何。二加相有三下。辨加相。言约别说者。谓以身加身。以口加口等。言如实说者。能加则局者。谓能加随举一业即加。所加三业故。三承前语便下。辨加次第。于中二先辨诸佛加次第可知。后若约舍那下。辨本师。次第意加即承佛神力。入菩萨大智慧光明三昧。次身光照触等者。即下如来加请文中。放眉间光照十方竟云。又照十方一切世界。一切诸佛所加说法菩萨金刚藏之身是。后云台下口加者。时光台中以诸佛威神力故而说颂言。佛无等等如虚空。十力无量胜功德。人间最胜世中上。释师子法加于彼是也。言令演者。彼次偈云。佛子当承诸佛力开此法王最胜藏诸地广智胜妙行。以佛威神分别说。即其文也。谓即先须冥加。次放光成台。后方得台中劝说云亦义次第。疏总中令以乐说辩等者。谓以乐说为能说。说十地之法义故。经云辩说说必有词。其所说中名相差别即是法义。论以名相释于差别。亦可在口为辩。辩通四辩也。不违已下释善巧字。疏自他因缘方有说故者。自力为因。他力为缘故。疏摄此九力。此句总标。二以因中有四下。总出四净所以。言因中有四义者。拣非约缘。但就自力因中耳。亦如泛举因缘生法中有其四义。如谷子为因。水土为缘。能生于芽。但就谷子即有四义。一缘不生自因生故。即谷子是有力义。二因不生自缘生故即谷子上有无力义要。具有力无力方能生芽。即第三义总摄上三。即谷子之德是第四义。一有力能作故。有有作善法净。二无力不能作。故有无作法净。三具二能引生故。有教化众生净。四泯摄前三称理成德。故有第四身净。泯谓泯绝。以三不相离互相即故。便互泯夺摄者三不相离举一全收。具泯夺义。故称理成德。又上四义。前三行圆。后一行满。前三之中。前二自利。后一利他自利。二中依体相分故。有有作无作。然其别义正在前二。此二并以真心为体。以真心中有于三大。顺体相大故有无作法净。顺用大故有有作善法净。言有作者即是教行。教行本无顺性德。用而修起故名为有作。有作顺理故名为善。善之自体故名为法。法出垢染自之为净。言无作者即是证行。性出自古不由缘造。故名无作。此无作体更不顺他不立善言。若约性善亦可名善。论依前义。故无善字。法净二义不异前释。然其纯真不生单妄不成。真妄和合方有所作。无明内熏恶友外引。造诸恶行背真流转。真如内熏善友外引。造诸善行反本还源。顺真名善顺真为善。即无妄可治不成善故。由顺性无悭贪故随顺修行檀波罗蜜。则反悭贪成于檀度之善。余可例知。然此二净。若在凡时但可有性名作无作。不得名净。然无作体古今常湛体无增减。约就于缘有隐有显。有始有终说因说果。有作法体本无其体。但可依生方名有作。如树有芽等乳有酪等。非是事有。然虽修生若无有性修不可生。故作无作皆名有性。此二入住有作名为习种性摄。无作名为性种性摄。若就解行有作名方便净。无作名体性净。今就圣位有作名教行。无作名证行。若至果位有作名方便净。菩提涅槃及报身佛无作名为性净。菩提涅槃及法身佛。此二无碍。今明刚藏内顺德用。万行爰增云有作净。心冥性德。思虑斯寂有无作净。大意如是。次正释文。疏一净自善下。释此一净文有四节。初句牒经。二有作善法净依论立名。三即是教行出其行体。四亦约相故名为有作。依体释名。谓由约相约教故有修作。修作即是教行。疏二普净法界故者。释此一净。文有五段。一初句牒经。二无作法净依论立名。三此约证行出其行体。四亦约体故名为无作。依体释名。由约体故无有修作。但出妄染故得称净。如拂云雾显出晴空。故此但约显体名净。不同前门对治名净。五依此性相下。双结上二。先结二净。性即体证。相即相教。后上二皆自利者。结上自利。生下第三利他故也。疏余六句经下。释第四净。疏文有三。第一标名。约体无垢故名身净。第二摄为三种尽下。依论开义。于中亦三。初句标望论是开为三。望经六句六摄为三。二皆显二利满故成德者。总显三尽。但满上三句二利故。下三尽中皆有二利。三成德有二下。出三所以。言后二尽者。一对下彰出。有二乘不同尽。二对上彰入故有佛尽。故此三尽约人为三。一自约菩萨。二出二乘。三上同佛。疏初菩萨尽者下。第三随文解释。于中初句标名。具足论云。一菩萨尽有二种利益。疏初句位满是一益。即显后二句成益为二。今初即经深入法身智身故。从谓十地下。疏释。今疏先以起信意释。后用本论。今初。即释本觉中随染本觉之文。论云。复次本觉随染分别生二种相。与彼本觉不相舍离。云何为二。一者智净相。二者不思议业相。智净相者。谓依法力熏习如实修行。满足方便故破和合识相。灭相续心相显现法身。智纯净故。今正用此智净相。言智净相者。即本觉随染还净之相。不思议业相者。明还净本觉业用之相。此之二门若离染缘则不能得成。故云随染。此智净中论文先明因法力熏习。此是地前非今所用。如实修行此当地上。十地行终故云满足方便。此在金刚因位之极。今疏取意。故云谓十地胜进。从破和合识下辨果也。谓本以不生不灭与生灭和合。名阿赖耶识。今破和合识。由灭生灭之相显其不生不灭之性。此根本无明尽故。心无所合。即显法身本觉义也。即于此时。能染心中灭业相等相续之相不灭心体。故令本觉还源成淳净圆智。以相续心体即本觉故。今疏不引智淳净者。智淳净言意在下疏。疏从非心意识下是本论意。论具云菩萨尽者。法身离心意识唯智依止如。经法身智身故。今疏言非心意识之所能得。即取论意反成法身。了心体离念不可得故说名法身。故虑知集起思量分别安能得耶。从如智所依下。释智身体。此一句向上顺成法身。法身唯为智依。故非心等能得。二向下成智身。即依法身之智。即是智身始觉义也。然此始觉无别始觉。即是本觉随染而作。今染缘既息始还同本。故云淳净即法报一体。故经云。唯如如及如如智独存。名为法身。故次下论云。若无明灭相续即灭智性不灭。明知智身全同法性。如金成像像不离金。从能所证义分二身耳。疏菩萨照寂故云深入者。此以璎珞经释深入义。彼经云等觉照寂妙觉寂照。今是菩萨。故云照寂。则等觉已还未为深入。疏后二句成益等者。此句总标一成现报。才证十地得离垢三昧。末后有一三昧。名受一切智胜职。此三昧现在前时。有大宝莲华忽然出现身坐其上。十方诸佛现身灌顶名为受位。故是现报。广如第十地说。然泛明受位略有三种。一唯就相。如弥勒等。示居长子已穷圣位。授记当来次补佛处。二就相显实。如回向所引名为得位。三唯就实十地行满众累永寂。法身之相显自心源名为得位。虽有三义今取第二故云现报。疏二成后报益。疏有三节。初句标名。二十地摄报下。取论意释经。三正引论释。二中然十地各有摄报之果。初地多作阎浮提王。二地轮王乃至十地。为大自在天王。今是第十。言色形中极者。俱舍云。欲天俱卢舍四分一一增。色天瑜缮那初四增半半。此上增倍倍。唯无云减三。谓色界十七天。初之四天各半瑜缮那。至于第四方二由旬。此上增倍倍。谓第五有四。第六有八。七有十六。八有三十二。九有六十四。第十合有一百二十八。十即无云。欲成上都数故减于三。有一百二十五。则第十一有二百五十。十二五百。十三一千。十四二千。十五四千。十六八千。十七一万六千。故至十七。即色究竟身高一万六千由旬。故云高大。言居有顶者。唯是色界之顶。无色无处故。此便为三有之顶。疏二约三乘下。上就摄报王身为大。今约成佛报身为大。然云约三乘者。以一乘中唯说摄报。多作此王亦不必作。而其实成妙觉。不局于处。不定于天。于阎浮提成亦成真佛故指三乘。而三乘意亦就摄报身为彼王。于彼成佛即周法界。学人便谓报身之佛。在色究竟。则令报身报土皆成局劣。故指三乘便为不周法界。疏论云下。三引论释从智处二义即疏释论二义。亦顺上高大二义。一即就摄报之身智便自在故。贤首品云。摩醯首罗智自在。大海龙王降雨时。悉能分别数其滴。于一念中皆辩了。即其文也。然此天何以为智处耶。以下天定少。四空定多。以四禅中定慧均等色界中极故。又约二乘之人。多以无漏之智熏习禅定故。疏二摄报智满成种智故者。此有二意。一约未成佛。但是十地摄报。居彼智度已圆。故云摄报智满。二就彼天上得成菩提。具足种智名为智处。然论成佛通说有三。一寄化显实。在阎浮提即周法界。二寄报显实。在色究竟成便遍法界。三就实。显实妙出三世。不可定其时处身相。今就中义疏二寄对显胜下。释后二尽。此句总标。一对下彰出下释第二尽也。疏以二乘虽度五道下。疏释上论涅槃道净。言三余者。一无明住地惑。为烦恼余。二无漏有分别业。为业余。三变易生死。为苦余。故有三余。涅槃非净。即佛性论文。故法华云。是人于何而得解脱。但离虚妄名为解脱。其实未得一切解脱。佛说是人未实灭度。斯人未得无上道故等。第一疏中已广分别。今则金刚藏已出三余故。涅槃道净。经言出世善根者。根者即无贪等。既尽所知超度变易。满菩萨行诸度皆圆。常乐我净三德皆圆。处而不住。故涅槃道净。问此句不同二乘义则可尔。上句度于五道则不同凡夫。何名不同二乘。有人答云。但约超胜略无凡夫。此义不然。今谓凡夫此不足论。今明正度五道。有滥小乘故。净涅槃显不同彼。故合二句方成此尽。又二句皆滥二乘。今皆不同。由净善根故不住涅槃。由度五道故不住生死。合二无住故不同二乘。度于五道入涅槃矣

大方广佛华严经随疏演义钞卷第五十三大方广佛华严经随疏演义钞卷第五十四

        唐清凉山大华严寺沙门澄观述

疏。后一望上显同下。明第三尽此句显意标名。言满种智者。释一切智智字。此有二意。一上一切智。是根本智。重言智者。是后得智。此二无碍名一切种智。二依论经意上一切智是佛。下智字是佛智慧。故论云得一切智人智满足故。二义皆是种智。疏自力辨中下解妨问意云。他力唯一句自力有十句者。答谓。他力总彰佛加。不在彰于佛德。自力欲彰刚藏胜德故具列多句。后后胜前前则无德不备。如无作法净。即胜有作善法净。教化众生胜前自利身净。已胜前三皆显二利满故。身净中受位过于位满。后报胜于现前得涅槃道。后胜于前同佛种智。谓位极尊胜方显刚藏从因至果无德不备。方堪说法故广显之。疏第二意加者。当时如来但意地冥被与其智力。都无言说。皆集经者言。疏总中身有二种者。论经总句云。与金刚藏菩萨真实无畏身。无畏即无能胜义。上力被下故名为与。虽己之智即不可他用。约为缘助故得言与。如鬼入身尚增智辩。况于如来。问此与为暂为永。答有三义。一就实相。金刚藏上契佛心佛力下被。相应为与此与则常。二就化体。既金刚藏化周法界。无时不说。随说即与无有暂废亦得名永。三就化相。有说不说。说时即与。此则非永。然此总句亦总亦别。总谓总摄十句为无能胜身故。别谓此句即当色身。后九句别唯属名故。二名已去即得名身。身者聚义。疏后与无碍下。释别句。于中有四。一总显别句不通色身。二所加通三下解妨难谓有难云。上云口加增辩。意加益智。身加增威。今何意加而增身威。此即难前身胜故为此答。亦是此释云。如实意者。能加则局所加则通。故随一业皆加三业。今此意加故益身胜。由意得智便说无碍即益口也。三在心名智下。会论同经。正显所加通加口义。四一与不着下。随文别释。九中前八与其自在说智。后一与其殊胜化业。前中相从摄为三对。初二句一对。前句说能后句能说智。令知世法。次三句为一对。初句说能。后二句能说智。于中前句方便智。后句了理智。后三句为一对。前二句说能。后一句说智。令知教法。然案文影略故为此判。实则智能皆通诸句。故总名与智。已总科判。今当别释。今初一不着辩才。疏文有四。一此上即论标名峻若悬流无涩滞故。二说法不断无滞碍故即是论释。三谓无偏住着故不滞事理。即疏释论四云无碍乐说。疏举经帖下八大同。疏二与堪辩。此论标名。分别法相下。疏以论意会经。由解法相故。能正说解故名堪。正故名净。从论云下。别示堪相。解此四事名解法相。故堪说法。于中二。先举论正释。后此言缘者下。疏释论文。于中三。初取意略释。次然其此四下。略指二经。后今依杂集下。引论正释。于中二。先正释。后而彼经论下。明其次第。疏所应成义者。谓自体差别者。即声为自体。常无常等而为差别。又色是自体。形色显色表无表等而为差别。言现量等者。等取比量圣言量。不违立宗等言者。等取于因。因唯一字。何故不言不违宗因。今等取言。云何等言。如云声是有法定无常故。宗法因云。从缘生故。此言既多。今立宗等言。四字摄之故云等言。疏如火能烧等者。此释自相。下释共相。疏三任放辩才。于中三。此标名。言说恣心故名任放。二说不待下论释三谓随门下疏释论。然论经云与善忆念不忘加。论释加字云是不忘加意力。故所以偏就此释者意加正为不忘故。疏四能说辩者。初举论谓字下。疏会论就经。疏五不杂辩下。初举论三义无乱故云不杂。次三同智下。疏释论。无法不尔下会经。疏六教出辩。然论但云得佛十力不坏。于可度故者。断烦恼故。释曰。谓令众生断惑出离故名教出。而论经云与佛不坏力故。故有不坏之言。今疏云化物。即是教义。断惑是出义。论无得果之言。今会经文成道二字。疏八无量辨中先举论言修多罗等。等余二藏。次言六正见者下。疏释论此六正见即深密中六种理趣。已如普贤三昧品说。此中名小异尔。其能知教法合云教道。前三为本。后三次第释于前三。就其所知名为理趣。就其能知名为正见。全与前同。若约今文前三即理行教。略无果耳。疏上十已辩他力者。然论文中无有自力他力之文。以前口加中有自他力二辩才故以义例之。故此上已有佛正与智故为他力。具德堪加故为自力。疏何以得此三昧者。疏征得三昧之由。上总句中由得三昧故得偏加。今征意云。三昧殊胜何以能得。下别显下。答有二因。一宿愿深重。谓因中发愿。欲证十地智光三昧。故今得之。二是现缘。即三昧身摄功德也。现身无德虽有宿愿亦不能入。然诸菩萨皆具此德。随门显法在金刚藏。故偏言其有。又据佛力能加草木何要有德。欲令菩萨进修具德。上契佛心方得加故。表此地法证方说故。疏此复八种下。就总开别。于中有三。初总科。二别释。三总显为因。今初。先出论文。谓前四下疏释。疏一善净深心下别释。此一句中文有五节上句牒经。二云是因净者。是论立名。三信乐至极趣菩萨地尽皆清净故者。是论释义。论中具云。一因净深心趣菩萨地尽清净故。如经善净深心者。信乐等复是一切善根本故。今疏取后论向前释其信乐字。是论释经深心。即初地契理净心。论主但云信乐。其至极两字。即是疏释深心之言。以信乐殷重故曰深心。由此深心故能得第二第三乃至十地。为菩萨地尽。即论等字。既至地尽障无不除。云尽清净。四故云善净即疏以论会经。五此一为众行本故名为因。即疏释论立名即复是一切善根本也。既此为因则显下德为其行体。疏谓二即智净趣菩萨地尽修道真如观者。举论则显初句是见道。故次如日轮下义取论释。具足论云。此真如观内智圆满。普照法界犹如日轮光遍世界故然。今疏文言含法喻。疏三身转净者。助道能得出世报身名身。初地已上受身非。一后后胜前前名生生转胜。总由助道福行净故。疏四心调伏净空有自在名心调伏。言善断等者。不著有故断粗烦恼。不住无故断微细习。无住而断故称善断。言故云修治者。以论会经。无住是菩萨本业即是修治故。论经云善修本业。本业即今经所作。亦是以无住心修前证助。以为本业言此即断德者。初是智德则显助道是其恩德。已配三德。下配三道。故有亦言。疏五闻摄净。谓闻持智。而为能念其无量法。即是所念持即是念。具能所持故为法器。论云一切如来所说秘密法者。一切明广秘密显深。若不持法不能利他。以闻持而为方便。其无量言便含二义。一多无分量。二深无分量。疏上八句下。第三总显上八行能为因义。疏谓由深心能起行等者。前明深心是起行方便。起行即是精进故。深心为精进因。二由得如智故常不忘。三由助道成胜势力。四由不住道。不住空有生死涅槃故无染着。五由自念法能断他疑。六由神通故令他敬重。敬重即是信入。疏七转法理因者。即无错谬总持法。是教法理是义理。化流名转。谓正法灭时假余外法流通诵持彼正法义故。以总持持余尊法为教理流转之因。疏八教出离因者。具足论云。教授出离因。即经法界智印善印故。谓教授于他。由契法界自出取相。即化而无化也。亦令他出。次引论释此意明下疏释论。疏不离本处等者。今经但云各申右手。论经云尔时十方诸佛不离本处。以神通力各申右手故疏为此释言。即四通者。智论云。一如意通转变自身。以大音声闻一切等。二者幻通转变外事。三法智通。智法无碍。四圣自在通。能于苦中生于乐想。于彼乐中能生苦想。于苦乐中生于舍想。如是一切今于自身但延促一多故。是如意非余三也。疏所以起者。三昧事讫等者。征其起因。乃有四义。论主但云即三昧起者。以三昧事讫故。又得胜力说时复至。定无言说故。释此论文乃通二势。一当句释。二相承释。即今疏意后后蹑于前前。若当句释者。言事讫者。上入三昧为显已证故能宣说。今已显竟故名事讫。二前入三昧为受佛加。今佛已加云得胜力。三前入三昧为观物机。随顺受法物悟在今故云时至。四前入三昧显证离言。今说起定反显所入寂灭离言故云定无言说。当句则显入定有其四义。句句不同相蹑。则得胜力。言含于多意。谓显证得加观机已竟。皆名得力应存二释。疏第五普告下。本分者若约教道分三分者。此下当其正宗。正说地故如品初所明。例如法华方便品去以为正宗。此中本分如双叹二深。下请分如身子三请。说分如彼广明开权显实。故前四分为序。即起说之由。令物生信。今此本分举法叹胜令起乐欲。是所成行。文中有四。一释名。二解妨。三科判。四释文。今初。何名为本生下二分故于此中略示纲要。有体有相说分之中。说于地相以显体故。请分闻于名体而申请故。若别说者。十名地相即说分本说分广显十地相。故云为广本。此中地体即请分本请分广显地体寂灭出言道故。故云亦与请分为其本故。疏不请而说下。二辨妨。妨云下待三请此何不请。答有二意。前意疑说。后意疑法。谓设知欲说不知说何。此即无问自说经也。问上言佛加为令说法。何言不知为说不说。答诸佛虽加不知刚藏承力。说不问上言说不思议诸佛法明。云何言复不知欲说何法。答不思议法中门别非一。故犹不知。若尔上以能加同名金刚藏。则知所为是金刚法。云何不知。答藉相表知而非决定。犹名不知为说何法。疏文分为三下。三科判也。科为三段。若别对者。对下请中互相成起。此初地体起下请中地体寂灭。后显寂灭成此标体。此彰要胜起下大众令生乐欲。下自陈。有根有欲即成于此。其第二段自对说分。此能起彼。彼能成此可知。疏今初地体已如前辨下。四释文即品。初有十体。一离言体。二所证体。三能证体。四能所契合体。五随相体。六三昧体。七就德体。八随要体。九总摄体。十唯因体。今此即当第八随要。以六决定而为体也。疏就总中言菩萨愿下。释此总句文有六段一解菩萨。疏于大菩提下二解愿义。于中有二。初正释愿。愿以希求为义故。后即下初地中发菩提心者。即指下初地住分之中菩提心。生即是此愿故。下论文还指此愿。故彼文云。生是心者是本分中愿善决定。良以心愿体一故二处相指两处之文俱显地体。谓此世真证善根以能增长顺趣菩提故说名愿。亦名发心。体虽是同。随义有异。心愿不同。言义异者。谓于大菩提起意趣向是发心义。要彼属己是其愿义。问愿善是诸地体。说分已下皆是地相。何故偏指初地发心。答曰。就始言故。又问。愿善是体。说分已下但是地相。云何指相而得显体。答总相指彼在地相中。分别指彼即相所显。果分发心是此愿矣。疏此愿所以下。第三释善决定义。愿是希求。若地前愿不得称善决定今是证智相应之愿。相应之愿真能随理故名为善。此善即是决定之义。疏真智即善下。第四会六释。于中有二。先正释。后故论下引证。回文未尽。合言善决定者。善即是决定。疏此已入初地下。第五拣善决定。地前亦有相心之善。非真智摄。不名决定。地前亦有决定。复非至顺于理不得称善。故地持说决定有三。一种性地名为决定。定为佛种。二解行地名为决定。定能发心。三初地已上名为决定。今是第三。拣非前二。疏若通论决定下。第六通显决定得名。唯取第三决定耳。下别句中有六决定。一一皆具今之六义。疏后别中此善决定有六种者。释此别句经前有三。初就总开别。二瑜伽下指文引证。既诸论皆说故要为六。疏此六行相下。三通相料拣。先从后渐收。后是故自体下顺牒结示。疏一无杂等者。文总有四。一牒经。二即观相善决定者。论主立名总中开出故有决定。三真如观一味相故者。即论释也。真如观释观。一味相释相。理绝妄情说之为真。诸法体同目之为如。照理名观。观之体状。故名观相。四谓正体缘如下。疏释上论正体缘如转释真如观。言正体者。拣非后得是根本智名为正体。此是能观如是所观缘即观义。故唯识云。若时于所缘智都无所得。尔时住唯识离二取相故。境智即是二取。离二取相故为一味。即以一味为观之体相。一味是喻。如海虽广同一碱味。亦如众药煮之一器其味无别。能观所观皆无所得即为一味。言则无带相之杂者。以论会经。经云无杂。论以一味相。释无杂也。若是地前现前立少物。谓是唯识性以有所得故非实住唯识。未能忘如为带如相。此相为杂。今俱无所得故无此杂。疏二不可见者。牒经是真实善决定者。论立名也。非一切世间境故者。是论释义。谓此真智下。疏释于论。由此句明行体离过。行成离妄故曰真实。缘观不睹名非世间境。言出世间故者。转释非境。既是出世。世智安知。经云不可见斯乃契实。反望情想虚妄由来不有故名为出。非有世间对之出也。谓此真下疏释可知。疏三广大如法界者。牒经胜善决定即论立名。此明行德行合法界。随义广大故名为胜。疏论总释下。以论释相。然论有二段。一总释。二重料拣前段。疏中先举论文。后此中上句下。疏释论上句。即论云大法界故。下句即一切诸佛根本。以地智是诸佛根本故。如法界之广大也。从法界所以下。别释二句。先释所如法界。后今能如地智为下。合上二义法界为悟之根。今地智为菩提智根。法界为诸法性。今地智为佛本性。况体合下。释成上义。地智所以得如法界者由契合故。合则一味。离于二取故无所如。智即是如。况复相契如是方是真实如法界矣。疏下开义释下。即论第二重分别。于中二。先疏假问生起。后论总释云下。举论解释。先总后别。总中先举论文。后言一体者下。疏释论既是一体异名故不妨将胜释于广大。便更将高释广理亦无违。四义同体故。疏法尔者即是界义者。梵云达摩驮都此云法界。亦云法尔故。疏一双释大胜下。论释能如文有三段。义包四字。于三段中皆初句标举论意。次举论文。后疏释论。并显可知。疏故随义下。总结上三节。又大字为总故。上四节皆有大言。余之三义在三别中。虽无其名义无遗矣。然其三段皆应有说大白。第二显广云说大乘。第三显高特云白也。疏是因善决定者是论立名。二此有下论释。三有释云下。疏释论。于中三。初叙昔。二此顺法相下。辩顺违。三今更下。申正释。于中分五。一正释言用虽亏盈者。正拣智体非无常义。智体如空空非无常所生之色有起有灭。如用应机说为无常。言究竟如空者。谓毕竟无有不如空义。二若会下会三身。明报身不在无常因中。三设智为了因下。遮救。恐彼救云。智为了因了于涅槃。若为生因生于菩提。故今答云。性净菩提亦了因所了。本具智慧光明义故。四故论云涅槃道下释成上义。古译菩提名之为道。是故疏云道亦菩提明论亦说菩提涅槃以为常矣。用是无常若别对菩提涅槃因者。即寂之照是菩提因。即照之寂是涅槃因。寂照既融二果亦融。故云若相融摄故不在言。五言无常爱者下随难释论。疏大善决定者此句标名。二随顺下论释相。三即普覆名大。疏释论名。疏论又云次前下。举论释不住义。于中二。先举论。后谓由下。疏释论。于中三。初牒论正释。二叙异解。三广释不住。今初又二。先正释。后前虽有应用亦智所成者。遮难。恐有难云。常果因是智。无常果因为用。既为应用岂不是悲。答因善中已成不住故为此答。二有云下。叙异解许不违理。即远公意。谓常果因能得涅槃。故于世间不一向住。无常爱果因。及此大善能随世间。故于涅槃不一向住。三然约双遮下。广释不住之义。复有二义。谓住不住。论意即是双住之义。云非一向住不言无住。然即由非一向住故成无住。犹如船师非一向在此岸住。亦非一向在彼岸住。故成无住运载众生。而言谓大悲故常处生死等者。等字多义。一者等取大智。故常处涅槃是俱住义。二大悲故不住涅槃。大智故不住生死。即二俱不住。又一明俱不住者。有二义故不住生死。一见生死过患故不可住。二由见生死本空故无可住。上二皆约智故不住。有二义故不住涅槃。一见涅槃本自有故不待住。二由不异生死故不可住。又智与理冥无别异故。能所绝迹故无能所住也。则双不住生死涅槃。上皆约智。二明俱住者。有二义故住于生死。一由见过患起大悲。故住为练除也。二见空故住不怖也。上句约悲。下句约智。又有二义。一见过生厌故住。二见空即涅槃故住。此即常在生死。恒在涅槃也。此二皆约智。前了相。后了性。有二义故常住涅槃。一常证理故住。二常化众生故住。以所化众生即涅槃故。上句约智。下句双具悲智。又合生死涅槃二境体无二故。无偏住处故云无住。又即住此无二之处故亦云住。又合住不住之二行以为无碍。良以不住为住。住为不住。唯一无分别行故无二也。又合境行二门。以法界法门绝能所故平等。法性唯一味故无境行之异也。上开则多门。合则无二。开合无二。总为一大无障碍门。言思斯绝。疏六为一切下。是不怯弱善决定文中有三。初论立名。于深能入故不怯弱。二上入下论释。三论经下。疏释论会经。言与入智地反覆相成者。智造佛境即入智地。故得佛护此以入智地成佛护。由得佛护得入智地。即佛护成智地。疏论下。六相圆融者。论云善决定者总相。余者是别相。同相者善决定。谓六种同名善决定故。异相者别相故。一观相。二真实。三胜。四因。五大。六不怯弱。相别不同故不同前别。分一总句为六决定。以为别相。成相者略说故。坏相者一一广说故。如世界成坏。前文已有故云类前可见。疏二中以生成住持故者。出同说所以。然生之与成。望于佛果。始起为生。终满为成。亦可生为因成为缘。因有二种。一证二教。果亦有二。一是性净。二方便净。望性净果。证道为因。教道为缘。望方便净果。教道为因。证道为缘。因果功德皆因地智。而住地智能持有斯胜能。故三世同说。疏同说之言文在地相。义兼地体者。地体最为要胜故。又依论经初无寄问征起。释不怯弱善竟。便云诸佛子。此菩萨十地。是过去未来现在诸佛。已说今说当说故。论先云复此十地生成佛智住持故。如经诸佛子此菩萨十地等。方牒向前所引经文。明是三世同说地体六决定也。疏三列名中为对治十障下。疏文有三。初总明。二别释。三料拣。今初。即唯识论文指在说分。然本论此中文有三段。初列十障。二释十地名。三总以喻显。今疏唯广第二喻。显略标初段。即今总明。今当具显论文故。论问云。何故定说菩萨十地。对治十障故。何者十障。一者凡夫我相障。二者邪行障。三者暗钝于闻思修等诸法忘障。四者解法慢障。五者身净慢障。六者微细烦恼习障。七者细相习障。八者于无相有加行障。九者不能善利益众生障。十者于诸法中不得自在障。义如下说。疏今依本论略释地名者。即论第二段也。论先征云。何故十地初名欢喜。乃至十名法云。疏此有二义。上则论文。此下疏释。二利创成是其教行由前修习。今得初成非前能加。故云无上。圣位新得即是证行。理即圣家故名为处。此地证始故名为初。无上拣前初证拣后上二喜事故生欢喜。即是喜心。疏此有三义下。释论。一因离者三离之义。本地具足。今当略释因惑起业詺惑为因。揽因成行詺业为果。行体清净故能对治。然惑有二。一粗。二细。犯亦有二。一粗。二细。细即误犯。粗即故犯。由粗烦恼起于故犯。由细烦恼起于误犯。今无细惑故不起误。何况故耶。此之三义即同十住毗婆沙论。疏此唯一义下。疏释于中三。初顺今经文。闻思修等是所知法。顺法正解故名为照。照法分明称为显现。言当地所闻者。以此地中亡躯求法故。疏若准下二引论重释彼无行慧者。义如下释。疏然唯识下。三引他经论释。以此一地与经名别。故引他论。于中有四。一双标经论。二谓成就下。唯识论释。三此则三义下。疏释论文。四然三慧就初下。会今地论。谓唯识以得三慧方发证智故。慧光为后。疏此亦兼下二义。疏释二义中。前约内证。后约外用。据能烧惑应名火地。但火能烧未必有焰。今取有焰故能普照。疏五得出世间智下。先举论文。远公意云。上二句解难度。难度即释胜义。今疏但通释。此唯下疏释于中有二。先总明。后以三地下别显。初三地下。是一难度。四地下是二难度。多滞已下结前难度。谓三滞世。四滞出世。云滞二边。上明所度之境。从今得出世下。是能度之法。此句由得四地已度世间故。论云十平等心实难得故。从又能随下。即是论文。巧方便智已入五地能度出世。前三滞俗违真。第四滞真违俗。今已度前故化众生而无著俗不违真。证出世智而起用故。真不违俗。则前四地不能胜也。若尔六地已上岂不然耶。故疏通云此初得故。疏六般若下。先举论。后谓妙达下。疏释。于中有二。初解大智。准龙树云。智有二种。一小。二大。小谓因分缘照之解。即妙达缘生。大谓果分灭观智心。即疏引无分别。今取所引故云大智。次亲如目下释现前义。后对后下释有间字。若远公意。二智皆有间。二智皆现前。疏此或下。疏释论。于中三。初为三义释。次第对论三节可知。第二合唯下。为一义释。先标。后然善下别释二字。文并可知。疏此亦三义下。疏释第一义。释报行纯熟曲有二义。一以变易果为报。二依此下。约行德释所有行德。由前修起故名报行。成就在今故云纯熟。即下经释名中。名为无功用地。先以成就故。二释无相。三释无间。即下经名为力持地。他不能动故。意明功用不动。二合一义中轮王喻者。七地菩萨烦恼及相已不动故。而非报行不动。梵王舍欲生于梵天。即功用不动故。证合唯一义。远公意云。离功用相名为无相。空有双现故曰无间。则无相无间俱非前地无相无间也。疏得无碍慧下。疏释。然其论文义通一地。克字取义即说成就。于中有三。初得无碍力。即口业成就。谓内具无碍之智。外以美妙言说名无碍力。二说法成就者。即智成就。三利他行者。即法师自在成就故。疏云遍说遍益方名为善。疏十得大法下。先举论。后此有下疏释。先以法身为云。此地菩萨法身普周一切法界。云大法身。第二义以佛说为云。能受为法。即法器故。论释第十既云得大法身具足自在。恐滥于佛。故寄对显异。先对下叹胜。论云如是受法王位。犹如太子而得自在。后对上彰劣。论云。是处有微细智障故不自在。对治此障故说佛地。释曰。谓金刚心后微细障尽种智现前故。第三次下论云。总喻十地。疏略不出今当具之。于中二喻。一喻十地在障未出。二喻十名所显之德。前中亦二。先喻菩萨云又如怀孕在藏。菩萨十地亦复如是。以诸地有障故。二喻如来。于中又二。先喻体圆。后喻用极。前中论云。如子出时。佛亦如是。事究竟故。二喻用极。论云。又如生时诸根觉了。佛亦如是。于一切境界。智明了故。在文可知。但喻于障。与前小异。前之十障在十地前。如第十地于诸法中不自在障。在于九地若断此障则得十地今明十障。障在当地乃障于后。如十地有障未得成佛。故犹喻在胎。出胎生时方喻于佛。无有障故。第二喻前十名之德。论但有喻而无合法。而于胎中分为十时。以喻十地。论云。藏有十时。一陀罗婆身时。远公云。前三梵语难解。彼疏不释。今以类取即俱舍涅槃之梵语也。陀罗婆者。即最初羯剌蓝。涅槃云歌罗逻。则大同也。俱舍译为凝滑。亦云和合。顺今论意。即喻初地。如智契合。离于生涩。初托圣胎故。论云。二者得捭罗婆身时。释曰。即当俱舍次生頞部昙。此云胞也。喻如二地初成戒身之体。论云。三者尸罗陀身时。即俱舍闭尸。此云软肉。如第三地忍辱柔软亦禅定柔软也。论云。四者坚身时。下皆唐言。即俱舍云闭尸生键南。键南此云坚也。正与此同以四地出世法身坚固。又精进坚牢故。论云。五者形相似色身时。即俱舍次钵罗奢佉。此云支节。与形相似义同。谓五地涉俗不住道行。则于一身有支节分段也。上之五位属胎中名色支。其第五位兼六处支。俱舍更有两句。云后发毛爪等及色根诸相。论云。六者性相似身时。即犹属上支节之位。已具六处。如头等六分成智身性。论云。七者业动身时。于其胎中已能动转。即七地中得方便智起殊胜行故。论云。八者满足身时。释曰。此下喻后三地行德满足。论云。于中有三种根满足时。男女相别满足时。广长诸相满足时。释曰。根满足者。即六根。即俱舍云及色根也。如八地报行纯熟。二男女相别满足时。即俱舍云诸根相。谓九地分自利利他二行故。三广长诸相满足者。亦即俱舍诸相字摄。谓第十地得大法身。充满一切。一切功德皆已满故。下论结云。如是十时诸地相似故。释曰。上来论文总喻十地。大旨易了故。疏不存恐寻论者不能晓了抄具释也。疏此十得名略有四对。下第三料拣可知。疏初句证行者。即经向菩提最上道。谓诸佛证此为因者。释经道字。十地证智为佛因故。今经但云最上。论经则云增上胜妙法。故疏云最上最胜。疏次句阿含者。即经亦是清净法光明门。言法门名为法体者。则显光明是用。体有二义。一即上地法由此证真故能了俗名为光明。二即后得智为体。能了一切余法。余法门者差别法也。疏后二句别显其相者。初句即经所谓分别演说菩萨诸地。疏释可知。疏后句显上证道者。即经佛子此处不可思议所谓菩萨随证智。此有二句。疏云一者是义句故。若分二者。上句叹胜超劣。下句示其体相。本分竟。疏此下请中三者。疏文有三。初总科。二显意。三释文。疏所以默者下。二显意也。然通论请分。总有三意。一明请中所显之法。二依法生成之行。三以请对说互相起成。今三段中具此三意。文中有二。一显默所以。二释请所以。前中令生爱乐请法行故。文中又二。先立理即借老子意。彼道经云。将欲歙之必固张之。将欲弱之必固强之。将欲废之必固兴之。将欲夺之必固与之。是谓微明。释曰。意明君子行权。反经合义。将欲歙敛众生情欲。则先开张极其侈心。令自固于爱欲之念。则当歙敛矣。强弱等例然。此道甚微。而动则着明矣。故云是谓微明。今借此意将欲为说。必先默然令其敬请是欲说也。疏欲令大众渴仰请说者。正显意也。总云请说细辨多意。一令菩萨敬请。二如来加请以显重法。三希佛加被听者。四冀佛教其说仪。义在下科。而论但云何故默然住。欲令大众渴仰请。故。复增菩萨尊敬法故。今疏将论初意以释默之所由。后意转释请意。疏所以俟请下。第二释请所以。此疏有二意。前意之中自有二义。一为生行生于恭敬重法行故。由上首大众。及于如来加被请说。知法可重故增恭敬。二为起说之由令恭敬故。刚藏便说。疏二前本分下。是疏第二意。亦曲有二意。一为生行。谓生正解解亦行故。若以请对说请为生解说为生行。若但就请解亦名行。对所显法就人名行故。二者显法。即次疏言云何生解等。谓征释上解便明显法。云何显法请分。为欲显于地体离言念故。疏得说默之由者。由解脱月意第一怪默腾疑请。第二金刚藏法深难受止。即默所以。故经云。菩萨行地事。最上诸佛本。显示分别说。第一希有难。微细难可见。离念超心地。出生佛境界。闻者悉迷惑。即默所以中显地体也。疏令众生解下。释上显法之意。便成第三请说相成之义。此中正明以请起说。然下说中意义有二。一者明行。二者明说。今请对彼亦有二义。一对彼后行命其起行。若不正解后行颠倒随声取着。行亦谬故。正今文意。二望后教。亦为起教。众有谬解刚藏不说故。上辨起说意。云何以说成此请耶。以后说因分行相。言教诠表。显斯地体真实离相。今明请意故略不论说能成请。疏即复由此下。释第三段所以。言即复由此者。上说默之由。显于地体甚深玄妙。本为彰默之意。傍令物解。第三段中将欲为说特明义说二大显法之深玄。令知所说但是说因说大可说。因于说大悟解深义。亦为令众不随声取离谬解故。故有即复之言。疏第二请中三家。请殊等者。疏文有四初总科为三。二出三所以。三明三次第。四释上首请。疏所以要三家者下。第二出三所以。于中三。初总明显深。二众首显扬下。别明。三前之下结叹。二中有四。一正助分别。二相因分别。三主伴分别。四因果分别。今初众首为正。余二为助。疏道大兼亡下。第二相因分别。相蹑起故道微则自济。道大则兼亡。亡字无心。此训无也。兼于无道之人。故论语云。夷狄之有君不如诸夏之亡也。若加于心。兼忘两字出于庄子。意于自他两忘。若人相忘于道术。鱼相忘于江湖。虽有深意非此所用。疏为顺请主此众堪闻。言不虚者此第二家因第一家起也。谓初刚藏云法深难受故止不说。次解脱月叹众堪闻。请云此众无诸垢。志解悉明洁等。众若不请则非堪闻。今解脱月此言虚谬故。大众请则言不虚。疏为成请者。如来护念而生信受。言有征者即第三请。亦蹑第一家生。谓解脱月末后双叹人法。请云佛子愿承佛神力分别说此不思议法。此人当得如来护念而生信受。何以故。说十地时法应如是得佛护念。得护念故。于此智地能生勇猛即其文也。为成此言故。有第三如来加请文云若为善逝力所加当得法宝入其心。即护念生信言有征也。疏此约因请生请者。总结上意亦是次第者。此中正显三家所以。下文方说三家次第。今此所以兼于次第故。致亦是言耳。疏又佛请者下。第三主伴分别上首为助。但可名请。如来为主故有加言。疏又前二家下。第四因果分别。疏前之二请下。第三结叹。此言因于天台而生。谓彼法华经疏叹身子三请竟云。余经无此殷勤之请。唯华严解脱月请金刚藏可为连类。而彼因人请于因法。此请佛慧故亦不同。今此翻明法华劣。此略言但是一家。细分乃有多异。彼是一家。此有三家。一不同也。彼之一家但是声闻。此有三家是佛菩萨二不同也。彼唯三请。此有五请。三不同也。彼唯因人请。此有佛请。四不同也。但彼云法华请果。华严请因者。然此请因乃是佛因。说分等中因果兼说。是故经云此是菩萨向菩提最上道。亦是清净法光明门。又云如来大仙道智起佛境界。第十地后校量佛德地影像分。十山依地。十德依海。皆明因果相顺。又有因果二分。令于因门彻见果海。所入智地亦通果故。法华虽然请说佛智。及下广说但示因门故。说众生皆有知见。诸佛智慧即此证道。其智慧门即此教道。教证二门该因彻果。非此独因各随所弘自扬圣教耳。疏三请次第者下。第三明次第。初上首请。次由前二止下。大众请。后听说理穷下。如来加请。今初众首下。第四别释上首。于中有四。初辨三请意。二通妨。三科判。四释文。今初自有二意。一顺世得中故。二以止有三下对止须三故。上意通诸经。下意正是今意。言抑扬当时者。三止皆抑。三请皆扬。谓初止通抑不堪。次止正明法深难受。后止劣者不堪故皆抑也。请皆扬者。初请怪默腾疑有疑欲问。次请叹众堪闻后请双叹人法皆是扬也。夫请法者必叹人叹法。叹法有教有证。叹人叹说叹听。故请仪具矣。疏二家助成各唯一请者。第二通妨。谓有问言。若三有表余何不三。通意可知。疏然依三请下。第三科释疏今初下第四释文。疏虽似初二征默所由者。文具二意。前意约所叹分别叹说叹听。故分为二。后释约征请分别征请互有故。依前判言互有者。如初二中何故不说。即正显征默所由。既云何故不开演亦是请说。为顺众欲。如后三中此众皆欲闻愿为分别说。正是请顺欲说。若为宣说众疑即除。相视恭敬义兼征默。故论经云迭共相瞻住一切咸恭敬。即上句正是怪默意也。故云互通。叹说叹听则不互有。故依前判。疏合为征问之辞。总言何故不解释。细论何故是征问之辞。不解释是征问之相。中间净觉是征问所以。故疏合云谓有中间净觉无过。何故不解释耶。疏圣德虽多下。释偏叹所以。具能所治下。别释净义。疏别叹净觉有二下。释此别句。疏文有三。初开章总释。二初中由有下。依章别释。三然念智下会通违妨。疏一杂觉者。常等四倒思求名觉。秽浊之心目之为杂。以四念为治者。观身不净等能治净倒等。疏二杂觉因者。想心见倒能生四倒名杂觉因。忆想分别即三倒也。忆是心倒。想是想倒。分别是见倒。令心亦倒不能见如。妄取染净因果相故。谓随名相转下。即疏释论。由不了如故随名相。若得如智斯倒自亡。疏离悭嫉过者。吝法为悭。忌胜为嫉。正是说法之过。三善根中无贪在初。嗔为菩萨大障。故论举嗔等贪。说法懈怠者。有人虽无悭嫉而堕开演故。疏无不乐说者。有人虽勤而无巧慧。凡所言说令他不乐故。此不乐之言乃属于他。亦可属自。若尔何异不懈怠耶。谓复有人心勤欲说。无有辩才故不乐说。疏然念智正为治杂觉等者。第三通妨难也。谓有问言杂觉是过。有念智等即得名离。悭嫉是过。功德具等岂非能治。何以前觉偏名摄治。此离悭等为离过耶。故为此通。前由先有杂觉故。修念智治之。此先无贪等自无悭嫉故别立名。前犹以药治病。后犹内有妙药众病不生故有二别。又远公释云念智内德对治义显。不贪无失离过义彰。故有隐显理实具通

大方广佛华严经随疏演义钞卷第五十四大方广佛华严经随疏演义钞卷第五十五

        唐清凉山大华严寺沙门澄观述

疏。第二叹听者无过。疏文有二。先总科。后释文。前中引论即是释前偈前论双明说听无过。上疏已明总意及说者无过。故今但引听者无过。彼论云复显听者同法决定故。有乐闻故。复示余者心净故。又显此众皆堪闻法故。偈言迭共相瞻住故。释曰上即听者论文。今疏以偈配之于文可见。同法二字该于二偈。是同生众故。决定二字唯属初偈。有乐闻者是第二偈异上同法。而云余者故是异生。此众皆乐则知双叹。皆者俱故。疏若有欲下双结上二根。约器量无之。则犹牛迹不能受海。欲约爱乐无之。若许由洗耳。疏黠慧即根者。此疏释论。黠即训慧。今分二别。黠即当智。智能了事。慧照理故。故分教证此二无暗通曰明了。根体是慧故以黠慧释根。疏愿大菩提故云勇猛者。然经云勇猛无怯弱。论经云菩萨大名称。今顺经帖愿大菩提即是论释。既云菩提则诸德皆上大愿为主故偏说之。以梵云萨埵有勇猛义。勇猛求菩提故。故二经语异愿求菩提义同。疏由内无怯弱者。即以此经会论经也。以论经云大名称故。上三决定若别相说。前二是证决定。后一阿含决定通皆具二。疏后偈叹欲中下。疏文有三。初略科释。二论云下举论辨意。三其心下随要重释。二中有三。初举论文。二现前是欲下略释现义。三此中意明下。总出论意。就初举论文中。然论初标云决定者。是中有阿含决定等。所以先标决定者。以前偈云同法决定。决定是根。根能受法故云决定。今此意云决定之言根欲具足方称决定。唯根无欲法器不具非真决定故。此标云言决定者。必须根欲。言是中者。是听者中有阿含决定。非证决定者。谓若前偈但有教根而非证根。亦不具足则反显前具有教证。次云但有非现前决定。无现前决定者。明若前偈有教证之根。为非现前决定。而无今欲现前决定法器亦不具足故。结云如是法器不满足故不能听受。则反显前偈有根。今此有欲为具足也。若但两字是疏义加。使义明了不违论意。疏现前是欲下。第二释现非现义。言根但冥具者。有人虽有堪闻之智为冥具。而未欲闻故云冥具。冥具宿成故。如五顶子具足七德堪传六句。而着妻奴未欲其教。疏此中意明下。第三总出论意。即论云示现此众具足决定故能听受。疏其心无怯弱下。第三随要重释。于中有二。先正释此句。后总前二偈。下双结叹意。释于初句及第四句。疏四异想浊者。论云四异想浊妒胜心故。破坏心故。释曰。妒胜就人。破坏约法。又亦通二。今不依论。云贡高等者义广异想。即瑜伽论三十八云。听法由离六种相远离贡高杂染。由四种相。远离轻慢杂染。由一种相远离怯弱杂染。言六种者。一应时听。二殷重听。三恭敬听。四不为损恼听。五不为随顺听。六不求过失听。言四相者。一恭敬正法。二恭敬说人。三不轻正法。四不轻说人。言一相者。谓不自轻蔑。复由五相故无散乱心听法。一求悟解心。二专一极心。三聆音嘱耳。四扫涤其心。五摄一切心。故总有二。谓不杂染心无散乱。一心听法。今疏举前二名。等取怯弱及无散乱。上皆异想。妒胜破坏此二偏重故本论举之。疏五不足功德浊。此段全是论文。善根微少语因中。心不乐住明无现果。谓由善少多缘多病懈怠散动。故于说中心不乐住。疏六愚痴浊。愚谓迷教。暗谓惑理。即释上痴。疏第三一偈双叹中。三初总释偈。二会论经。三别释喻。初中相视为总者。正是此偈之总。既双叹二众则相视之总遍前四偈。而论正说是此偈总。下例余偈皆有总别。则叹异生中不浊是总。上叹欲中欲闻是总。初叹根中决定是总。叹能说中净觉是总。别等可知。疏论经云下。二会经文中三。初举论经。二引古释。三会今经。念通教证者。熟蜜如教。蜜成如证。今念有二。若明记为念即是念教。若无念念者即是念证。故起信云。若知无有能念所念是名随顺。此念教也。若离于念名为得入此念证也

疏。然蜂下三别释喻。法喜如蜜。蜜即食故。故法华云。法喜禅悦食更无余食想。解脱合上甘露。甘露如浆故。故净名云甘露法之食。解脱味为浆。即甘露为食。今以蜜当于食故。以甘露配于解脱。故涅槃中亦以甘露况于涅槃。涅槃即解脱故。疏是总酬答相者。疏文有二。先正释后故后偈意下。以此长行成后偈文

疏。除前疑恼者。由前睹默生疑。疑则心恼。又请未说心尚疑恼。故为除之令心得喜。然大智无畏乃是经家。取当时意赞述说者。是故论主用此成前总令意悦

疏。二不怯弱酬答。论释云离不正说者。若畏大众是不堪说。随情而说是不正说

疏。遣上何因之疑。成上有智者。上云何因何缘不说。论释云为因说者不能说耶。为缘听者不堪闻耶。今云难说非不能说。成上有智者亦由难说。非已无智下。遣上何缘例此可知。疏今初偈末难字下。疏文有四。初释难字二。此难有二者。二别释第四句。上四字明难义相。三何者是下。释初二句明难法体。四此之教证下。释第三句显其难处。三中云觉于佛智所以名佛者。然论但云诸佛之根本者。觉佛智故此语迷人。以佛是梵音觉是此语。若顺西方应云佛佛智。故若顺此方应云觉觉智。故安得以唐释梵为释义耶。此有深意。谓佛智即是菩提。此但云觉。佛陀是人此云觉者。以人得法故名觉者。故今疏云觉佛智故。故名为佛。今十地菩萨为能觉人。亦将因智以觉佛智故。为佛本为分人法。唐梵互彰译者之妙。今加于字以释论故。四中难示难说。即同净名其说法者无说无示。后约难闻。即其听法者无闻无得。然无则一向约遮。难则遮表双辨。若准楞伽宗通自修行。说通示未悟。宗说即是教证。则二全别。今明教证皆有说者。有示有说。但云难耳。则示即说即证说证之相如何可知废诠论实真体一味说之为证。亦如义大及说大三渐次中辨。若真俗诠异说为十地目之为教。以证摄教故俱难说。疏第二释难所以中疏文有二先总明所以。二随文释。初中即是论意。论云行者即牒前菩萨行。事者即牒前地事。义住者语倒应言住义故。疏云由住微妙深义。深义即义大妙理也。疏偈中初二句下。随文解释。疏难得难证故者论经云难得。论释云难得者难证故。即以证释得。今疏经论双牒耳。以论经有难字及难得字。今经但有一难字故。双牒彼经论。论经偈云。微难见离念。非心地难得。境界智无漏。若闻则迷闷。疏难得有四下。释别于中有三。初释对劣彰深。初之二句。二既非四心下。释第三句。三未句云下释第四句。初中一非闻慧境者。有二义。一非所知境。二非分齐境。闻慧之中无此相故。论释闻慧云。粗事不须思惟。谓教法粗事闻慧能得故。二思慧则可了见于心。三世间之修未忘念虑。故并非之。问三慧皆是世间。何以就修偏云世间。答有二义故。一修有真伪。真修似于正证故不拣之。二报生识智亦是修慧。今取世间之修耳。疏四超心地中疏文有四。一以论释经。二谓变易下疏释论。三知无常等释经心地之言。四又此善得下重释论文。二中言善得修道智者。生而即得不假修习故名善得。其由生而知之者上也。言无常等等取苦空无我及常乐我净。以昔久修无漏因故。变易酬彼名为报生。言以非照实者。释不能知。夫照实者忘心体极。今报生识智虽知无常等不契合故不能知此疏未忘心境名为心地者。心地之言通有二义。一就体性。如梵网经说卢舍那佛心地法门。谓心体包含生成住持。亦如法华一切智地斯之谓也。今言心地是所拣者。即是心量法门故。楞伽说觉自心现量。非心之心量我说为心量。心量即心地故。疏二出离于生是无漏故者。如见道名离生。是无漏故。离生之义前已频释。良以论经云境界智无漏故。为此会无漏。出生皆是离过当体得名。生于佛智就于功能望他立称然二相成由无漏故能生佛智。疏即胜鬘三种正智中仰推智者。彼经胜鬘白佛言。云何三种。善男子善女人。于甚深法义离自毁谤。生大功德入大乘道。何等为三。谓若有善男子善女人。自成就甚深法智。若善男子善女人。成就随顺法智。若善男子善女人。于诸深法不自了知。仰推世尊非我境界唯佛所知。是名善男子善女人仰推如来智。除此诸善男子善女人已。余诸众生于诸深法。坚着妄说违背正法。习诸外道腐败种子。当以王力及天龙鬼神力而调伏之。疏所信是何下。释佛胜智字。于中有四。初明地智得佛智所以二佛智有二下开义别释。三即法华下。证成胜义。四于此下对能结所。二中有四对义共成一义。谓一前是菩提实智。后是化生权智。二前是自行。后是利他。三前是证道。后是教道。四前实智称性无分量。后权智则差别。有隐显说权为实。则隐实施权。说权为权则权实皆显。其无边种种即是论文。由佛菩提无有边故。故佛化生所说法门种种差别。疏即是法华下。第三证成胜义。即方便品初云。尔时世尊从三昧安详而起告舍利弗。诸佛智慧甚深无量。其智慧门难解难入。论释云诸佛智慧即证甚深。其智慧门则阿含甚深故。此二句即佛教证二道。故古人云二深先唱警察群座之心是也。彼经自释如来知见广大深远即实智也。如来方便知见波罗蜜。皆已具足即权智也。所以难解者。一当体深故。二权实隐显故。故云唯有诸佛乃能知之下。广文云。诸佛随宜说法意趣难解即智慧门难入也。唯以一大事因缘故出现于世。即智慧甚深也。昔不言三是方便故方便门闭。今云三乘是方便门开。开则见实故彼经云此经开方便门示真实相故。方便门如莲之华。真实相者如华之莲。此华不有则已。有则华实双含。此经不说则已。说则权实双辨。一经唯为说佛智慧故。彼文云。说佛智慧故诸佛出于世。以佛智慧不离教证权之与实。故说二深。即以略示法华经宗。此二亦即净名经中。智度菩萨母。方便以为父。一切众导师。无不由是生。故地智二道彻果海之二深是所信也。四于此二深皆能信故。结成信义。疏心地即二空真理所依之事。谓唯识相者。出义体性也。言所依之事者。明非能依理。理即无我故。言唯识相者。则显非唯识性。唯识性即二无我理。二无我理即胜义谛故。唯识云。此诸法胜义亦即是真如常如其性故即唯识实性。此分性相二门不同。即此心地便是无我事理非异非一。故是此所信。次论云下。论释心地通于二类。初即第八识。二又随心下。次即通七识及八识所缘之境。言内外境界者。六识缘六尘即是外境。第七缘第八即为内境。第八识缘三境根身种子即是内境。缘器世间即是外境。又意识亦通缘内外。五识亦有通内外义故云诸境。而皆名心地者。生成住持义故。依八生于七。七复熏成八。以心变于境托境而生心皆得心地名。疏于此二类下。总相收束一句之意。疏上半喻下半合等者。此段疏文有四。初总科。二此中喻意下总出喻旨。三举论广释。四例释说默。二中三初释喻相。二于中能依下举法合。三然空中风画下。正显喻意。疏论有三段下。第三举论广释。具引论文科释毕备细寻可见。但文中云合上非有即以非自性。合上不住者。由上论云。以非自性不可得是不住故。即知非自性不可得。是声名等从缘无性故不可得。如彼风画依空无住。故云以无自性合上不住也。疏出无性不住所以者。谓声从缘生故无自性。依法立名故是虚假。故肇公云名无得物之功。物无当名之实。名无得物之功非名也。物无当名之实非物也。若实即名见面则应知名。若名即实召火则应烧口。故知名是假设安有自性。即如风等与虚空合。疏然论经云。佛智者即会论经。今经二经同异可知。疏假实既殊故双举之者。出用四所以也。谓声为实名句文假故。即总取四法为教体义耳。疏又假实相依者。重释用四所由。名等依声得有曲屈故。名等为能依。若无名等空有一声不能诠表故非教体。则声依名等故云假实相依。疏若将二喻喻所诠下。第四例释说默。谓上论文但以风画喻于能诠。但以空喻所诠佛智。今例论意唯就所诠自有两重能所之异。兼上论意则有三重。于中有二。先以能依就所依则三重皆不可说。一以诠就旨。二以相就智。三以因就果。后若以果从因下。例以所依就能。则三重皆可寄言。一以果从因。二以智从相。三以旨就诠。是则风画喻于三法。一喻教。二喻地相。三喻地智。当知虚空亦喻三法。一喻所诠。二喻地智。三喻果海。总有四法成三重能所。逆顺互望则有六重可自思之。疏若准上义下。疏文有三。初蹑前微起生下偈意。二意云下。举偈意酬三初句所证下释文。第三叹众堪闻请中。疏此复叹下生起叹意。先问言此复叹者。以前怪默腾疑请中已有四偈叹众请竟。今何重叹。从由闻上言证信下。释重叹意。谓前叹众不因止生。今叹因前法主止生故得复叹。疏一善洁思念即欲净等者。此之五净前二闻慧。三四思慧。五是修慧。欲净是求法心。乐法称欲。随所念阿含得方便念觉净。即是论文。从谓得方便下疏。释论文上言随所念者。所念非一故。得方便念觉。是能念心念是欲念觉是思觉。疏家但释得方便言。然方便乃有二意。一以念觉与闻慧为由。二者不取念相。今疏但出深意耳。疏三业敬顺起求法行者。起行摄法故名为求。但令三业修行顺法即名求耳。疏生得净论当第四。今以论就经耳。益众生处即是上上胜生。悲智胜念即是思心。此顺论文。若远公意云。论文语倒合云得生净。生是所求胜生。得是思慧集于胜念亦是一理。疏即受持净论当第三。持即思慧忆持不忘。经言近佛。论言受持义岂为同。故疏出意云。近佛意在受持法故。然论经约由见多佛受持法故。常得胜生故受持第三。今经约由得胜生故生生见佛受持妙法。故受持第四而同思慧。疏离着善根者。欲入证时先须修行离着之行。十二头陀皆为舍着故。疏得净现智善决定故者。上皆论文谓真见道下。疏释于中有二。先别配现智善决定。后亦可下通配二句。前中以现智二字配真见道。即六现观中第四现观智。谛现观名为现智。疏相见道中下。以善决定字配相见道。言后得智者。然三心见道有配根本智。有配后得。彼论以其后义为正。故今疏中名相见道。是以三心及十六心皆配后得。言审观理智者。三心见道悉皆缘理十六心见道八观真如。八观正智。故知相见道通缘理智。疏亦可俱通等者。通配二句但前所不通。谓前相见道不名现智。今亦得名以论亦名为现观故。三心见道亦是第四现观少分所摄。是观非安立。后得无分别智故。十六心见道即是第五现观所摄。疏真见道中决理无惑者。上真见道但名现观不名善决定。今亦名决亲证真如。于理决定故。疏皆破无明云舍离痴惑者。以上二释会释经文。上但释论现智善决定言。今此所明二种见道皆破无明。是故经云舍离痴惑。谓真见道正能破于迷理无明。故云舍离痴也。相见道中是后得智无力能破迷理无明。而亦能破迷事无明。谓所知障故云离惑。故下刚藏牒此文云虽此众集善洁思念舍离愚痴。及以疑惑。明知痴惑二字义殊。上言六现观者。即唯识第九释二见道。后云此二见道。与六现观相摄。云何六现观者。一思现观。谓上品喜受相应思所成慧。此能观察诸法共相。引生暖等加行道中观察诸法。此用最猛偏立现观。暖等不能广分别法。又未证理故非现观。彼疏意云。思有三品上拣余二劣故非也。喜受相应拣于舍受。此明利故共相即是无常苦等。能引暖等者思生修故。虽未证理而观于法胜于暖等用最猛故偏立现观。暖等近见境界微略。又未证理故非现观。论二信现观。谓缘三宝世出世间决定净信。此助现观令不退转立现观名。释云信亦上品通漏无漏现观。是慧故信为助。论三戒现观。谓无漏戒除破戒垢令观增明亦名现观。释云即道共戒。论四现观智谛现观。谓一切种。缘非安立根本后得无分别智。释云谓在何位但缘非安立。即通二智皆是此摄故言一切种。大论七十五说。三心见道是此现观。故知亦是后得智摄。即见道修道之二智也。不取无学之二智者。与究竟现观不殊别故。论五现观边智谛现观。谓现观智谛现观之后。诸缘安立世出世智。释曰谓缘安立十谛等后所得智。然通有漏无漏。一切见修道。缘安立谛智。大论七十一等说缘安立谛境慧是此自性故。论六究竟现观。谓尽智等究竟位智。释云即无学道后。尽智无生智等而为自性。论此真见道摄彼第四现观少分。此相见道摄彼第四第五现观少分彼第二第三。虽此俱起而非自性故不相摄。释曰第四观缘非安立根本智。即真见道摄。缘非安立后得。即三心相见道摄。第五观缘安立谛故。十六心相见道摄。而通修道故云少分。论云菩萨得此二见道时。生如来家。住极喜地。善达法界。得诸平等常生诸佛大集会中。于多百门已得自在。自知不久证大菩提能尽未来利乐一切。释曰诸平等者。摄论第六得三平等。谓一切众生一切菩萨一切如来。上皆唯识论文。上疏已引意释。但观论文居然可知故。二见道皆是第四现观。谓缘非安立根本即真见道。缘非安立后得即三心相见道。十六心缘安立世出世智故。是第五现观。疏即不行净者。文中有二。先举论。后疏释。前中三。初标名。二修道中者辨位。三一切下释相。疏相见道后下。第二疏释论亦有三节。一定位即初地之中含通达修习两位。从金刚喻定解脱道后方是究竟位。二复数修习下。释修道名。即唯识第九加所为中已广引竟。三灭二粗重皆不行下。疏释论中烦恼不行之言。此言正解不行净义。疏文有五。初正释。二解妨。三引证。四会经。五重解妨。今初唯释云数修此故舍二粗重二障种子。立粗重名。性无堪任违细轻故。令彼永灭故说为舍。疏对见道中初断所知者。二解妨。谓有问言。然见道中双断二障而云所知者何。答以异生性障正取所知以为体故。故唯识云。虽初地所断实通二障。而异生性障意取所知。说十无明非染污故。是故此经云舍离痴惑。痴惑即是偏举所知。次云垢染即是烦恼。疏成唯识第十云。烦恼障中等者。三引证此前论云。此十一障二障所摄。烦恼障中见所断种。于极喜地见道初断彼障现起。地前已伏修所断种。下论与此疏同。释曰就修断中直观论文初地已上能顿伏尽修惑现行。如阿罗汉诸漏已尽无复烦恼。次云由故意力七地之中虽暂现起而不为失。自是一段通于妨难。谓有问云。既如阿罗汉令永不行。如何前四犹起我见。七地已前犹起贪嗔等耶。故此答云故由意力起。谓六地之前容有出观尚有误起。七地之中常在无相为化众生故意而起。起不为失示起示灭。即如下经中七地文云。虽毕竟寂灭诸烦恼焰。而能为众生起灭贪嗔痴烦恼焰。即其文也。论言而不为失者。下经云虽常寂灭以方便力。而还炽然。虽然不烧即其文也。故下经解脱月菩萨问金刚藏言。佛子七地菩萨。为是染行。为是净行。金刚藏言。初地至七地。所行诸行皆舍离烦恼业。以回向无上菩提故。分得平等道故。然未名为超烦恼行。便举轮王梵王为喻。轮王乘空不染贪病未名超人。以喻七地乘波罗蜜乘不染烦恼。未名超烦恼行。若舍王身生于梵天尔乃名为超过人位。以喻八地乘清净乘。尔乃名为超烦恼行。故次下论云。八地已上毕竟不行此之论文甚与经合。而大乘法师释意。如阿罗汉由故意力。连成一句。云如阿罗汉有怖有不怖。不怖者起怖者不然。此则以护法罗汉惧于烦恼不敢起故似非得意。又云。然此中所说见所断者唯顿悟人。修所断者通渐有学渐无学者。二种俱无。又问云。其在地前所未伏者相貌可知。其已伏者与此何别。答道力犹微不能伏尽。为烦恼制少分自行。即我贪等有失念起。故说地前已伏少分。非有别相地前伏之释曰此即释地前渐伏之言。以非正要故在后释。八地已上任运不行道力胜故。此是对法第十四文。疏烦恼即是下。四会经文即知。疏然见道中非不断惑见理义增等者五重解妨也。应有并云修道能断惑。修道名修道。见道既断惑。亦应名修道。又并云见道能见理。见理名见道。修道既重观。亦应名见道。故此释云从增胜义各举一名。言见理义增者。初见理故即显断惑义微。不断俱生故修道除障义胜者。能除难断俱生惑故。数数断故前已见理故。此为微。疏即无厌足净等者。即八地无功用行在法流中。趣果无间故曰无厌。不乐小乘自分坚也。但于胜进上求希欲。即是深心决定释其信解。疏不随他教净者。论立名趣菩萨地尽下。论释然论但云趣尽道中目正行故。今疏加于菩萨地尽释论尽字即是十地位极道圆。地法在心不由他教。故云自正行也。疏劣解之人通凡小等者。经言劣解论经云乐小法者。故疏合举凡。即地前小谓小乘等。等取权教菩萨。此中无小何以拣之。谓此会中亦有小心之众生故。亦可不欲广被即名为小。此虽拣之激令起心即为所被。疏多生疑下。牒经解释。正行已下至善法故皆是论文。然疑从二境上生。既滞二途故无诣理真正之行。惑谓迷惑一向不了故。能不信由此故能破坏善法。远离善法。远公亦将后二句论别。结疑惑二种之过。由有疑故破坏善法。由有惑故远离善法亦有理在。但论二句共一故。字则以通结疑惑二字。疏此明现损。是疏结前生后。言于长夜者。生死昏寝事等于夜。轮转无际名之为长。破法不信坠三恶道故受衰恼。疏初偈颂前段者。即领前所叹。净明有信者。信即顺教。是前段中善洁思念等即长行中善净深心前净深心虽兼教证今为分二故云有信。余皆有证者。广智慧即前舍离痴惑无有垢染。即长行中舍离愚痴及以疑惑。甚深明利能决择即前深心信解已下经文。长行中于甚深法不随他教。疏如山如海双喻教证者。动谓动摇。覆谓返覆。今于教决信不动。更无翻覆于证亦然。疏后偈颂后段即举损违请。疏以取相故但依于识者。返显不取相是智故应依之。第五双叹人法请。疏中有二。先叙意。后文中下释文。前中先征。后示彼下。论释。岂可避之翻前多生疑惑。后避之不说有多过者。翻前于长夜中受诸衰恼。安能成就一切佛法。疏书者是字相等者。初举论后以书记字下。疏释论。书即色法。字即是文不相应行故。言非正字体。言师子形者。牒论解释。然嘶字本从◇娑(上)字流出。即十二音中第四字。谓娑(上)娑(平)枲嘶苏(上)苏(引三)洗鳃苏骚毵索。今嘶字即第四字梵语轻重今古小殊大旨无异。若作十二梵字者◇娑(上)◇娑◇枲◇嘶◇苏(上)◇苏(引)◇洗◇鳃◇苏◇骚◇毵◇索。疏有云如呼师子下即刊定记释然恶字亦不似师子。又西方无此字。疏十四音者此下疏释论此译带古。然恶字合是第十四字。若准兴善三藏译金刚顶瑜伽字母云。一阿(上)二阿(长)三伊(上)四伊(长)五坞六污七[口*呂][口*呂](引去)八力嚧(引)九噎十爱十一污十二奥(引)十三暗十四恶。其里梨字即金刚顶中[口*呂][口*呂]力嚧字。各是二合故成十四。其奥字云引者更有三藏说十二字中上六前短后长。下六前长后短。则奥字不合引西方异同故。今具出疏。谓有二字多字名者若一字名不名为数。二字名三字名等皆名为数。如色即一字名。末那即二字名。阿赖耶即三字名。言必以多字成句者。终无一字句故说者语言义当色法。是则上书字数说总是声名句文共为教体。故此四事总摄一切能诠教法。皆用字母而为其本。疏即迦佉等三十四字者。若古三藏说谓牙齿舌喉唇各有五音。及会音有九。牙音五者。即迦(上)佉(上)誐伽(去引)仰(鼻声呼去)。齿音五者。左蹉(上)惹(才可)酂(上)娘(上)。舌音五者。谓吒(上)咤(上)拏(上)荼(去)拏(旎爽切仍鼻声呼)。喉音五者。多(上)他娜驮囊。唇音五者。谓跛颇么婆(去重)莽(鼻声呼之)。会音九者。野啰逻(上)嚩(无可切)舍洒娑(上)贺乞洒(二合)。已上三十四字足。若般若三藏云。前五句中一句之内。即有五音如迦齿音佉气从喉出。誐字喉音。伽字胸藏音。仰字鼻音。其余四句准例皆然。疏一一字中成十二字者。谓将上阿(上)阿等十二字遍入三十四。如初迦字十二音入便成迦(上)迦鸡(上)鸡俱俱计(上)改姑哠甘伽(去)入。迦字既尔。入佉字等三十三字亦然。复有二合三合乃至六合者。如以啰字半体入迦字时便成舸罗(二合)字成十二字。言啰字半体者啰字具足梵字者◇此字是也。半体者◇此一半是也。若入迦字者迦字梵书◇。此若入半体谓◇此字是也。◇(即迦逻字)即云迦罗(二合里下切一)柯罗(里迦切二)吉里(三)吉梨(四)吉鲁(五)姑卢(六)吉礼(七)吉犁(八)古路(九)吉涝(十)吉滥(十一)吉逻(来下切十二)。若以迦佉字合娑字为遏塞迦。即三合字成十二字。梵字样若此◇言四合者遏悉怛逻。五合者遏悉怛梨(上)也。言六合者谓遏谶(上)弥(上)雉持也。但至六合字已无边。如一字王但有二合云部林有三合云唵部林此等诸义。故非正要经有论。有故须略知耳。疏梵天之书者谓大梵天王劫初时。作此书字以教众生。不同此方篆隶。随时者古书随时有多名目。史籕为大篆。李斯为小篆。蔡邕为八分。程邈为隶书等。皆随时有别。疏释种等者。并如观佛三昧经。及智度论等说释种报定。是故必为琉璃王。杀琉璃王作业定故佛不能谏。疏自陈有根有欲者。有根故堪闻。有欲故乐闻。疏对教名上者。则前双为教证之总。称上者约人以叹明金刚藏所有教证最上也。疏此中叹证辩才有三下释别句。疏依前起祠乐说者。上三辩才即为三节。一真智为本。二依真智能解法义。三依法义起词乐说。然约于心四皆称智。若流在口四皆称辩。然词乐说即是能说法义。二智即是所说。则正说时词乐为能。今约内有法义方起词乐。故词乐为果。诠表深旨即是乐说。滑利胜上即词无碍。二皆约说故并为字。净心即初地者。证心离染故。言由集德成故者。会今经同论经。论经云为十力净心。论言净心即所成初地今经言集功德。即能成因故。下说分初地云。若有众生深种善根。善修诸行善集助道等而为得地所依之身。故集功德成于初地。疏辩才分别说者。意令受持十地法故者。疏但通释。则上句经是正说。下句经是说意。若远公意两句不同。则辩才分别义者。即依前体性分别地义。说此最胜地即依词乐说。说十地法令人受持。以论但云云何令入阿含无碍分别义令受持十地法故。故疏但通相释耳。疏说主既内具二力下。通结二力二颂之意。疏惟愿是总下。直至不生恭敬皆是论文。从以定戒为治下。疏取意释。然论教证各二妄想一时并举。下四对治亦一时并举。今疏教证分说。今但举教之二过。以戒定下取下论治。彼论具云有二对治。堪闻阿含。一定。二戒。定者心调伏故。戒者住善威仪故。今疏乃添字释之可知。次举证二过便牒二治并显可知。但经集正心句。论经云定戒深正意深。即今经集字意即今经心字。又第二句论经云离我慢妄见。妄即今之邪字而论别释妄字。故远公云。初句摄治行门有五。相从为四。要摄唯二。言行有五者。一定二戒三深四正见五正意。正见一门义有文无。以论释云三正见四正意。故云义有。经文则无。相从四者。深与正见合以为一。要唯二者但是入阿含及证行耳。今疏但有二。四不开成。五者以经无妄字妄即邪字。论释妄云。妄者谓妄想见中同使故。而释见但云颠倒见。义通浅深。谓于法妄取名颠倒见。此见则浅拨无因果为颠倒见。此见则深见中同使。则拨无因果之邪见故不开耳。但正字两用。谓正见正意故。所治既唯有四能治集正合治倒见。疏云谓积集深思者。以经集字会论深字耳。深思即称理见也。故论云。深者细意善思惟故。信心欢喜者。正心即是信心也。信解具足故能入证余文可知。疏示现正受彼所说义者。远公四种喻四种求心。谓一求闻等。随喻通合具有五种。一求法心。二所求法。三是依法所成之行。四是依行所治之病。五是求法起行之人。一言求法心者。谓求闻思修证心也。二所求法者。闻思修证四种法也。三所成行者。依法所成闻思修证四种行也。四所治病者。闻思修证四种障也。五言求法人者。且约大位摄以为四。一善趣人。求教起闻。二习种人。求义起思。三性种人。求行起修。四解行人。求实入证。今对此五以喻显示如初一喻。渴是病思是求心。冷水是法略无求人。次二句亦然。第四喻中蜂喻于人。影显前三。亦有求人略无有病。例前应有亦贪字兼之。由贪故思好蜜其成行。即饮食服味。文即现无义已含有。论经云如众蜂依蜜依义同行亦影略耳。虽有五事正意喻能求心至矣。故疏中引论便释具此五义。一谓求闻慧。求即求心闻慧即所求法。初闻即受是行。既云随得而饮必除渴病下。三求心及法例知。二求思中嚼所闻法。即行资身力即除病。三求修中依闻思行即行能去惑习即除病。四安乐行者。现法受乐行故。即行必无疲苦。即病除。疏所求犹通法喻者。甘露是喻。故法即是法故。涅槃中以大涅槃为甘露不死之药。配于上四。在论所无。疏行亦果行者。行有二义。一因行即是十地能得善逝名善逝行。二者果行如出现品者。出现品云。真实行是如来行。无碍行是如来行。真实即契实智无碍即悲智双流。如金翅辟海。依法性空入生死海故。疏自下第三如来加请。疏文有四。初来意。二释名。三拣别。四释文。初中二。先正辨来意。二通妨难。今初故论云。若请者非尊法。非殊胜圣者则不说。释曰此是反明。若也顺说由请者尊故。显所说胜刚藏则说。二前来为分下。二通妨难。于中二。先通伏难。后通蹑迹难。然远公总有五门分别。一能加佛异。二所加不同。三加业有异。四加相不等。五加请分差。今疏皆具。而文中先通伏难者。谓有问言前来已加。今何复加。此为复重难之答。此有二。一前未具故。二所为别。故前中先出不具足。意云为分主伴。由主威力令十方佛加。故前身口不同诸佛。次正显未具。即唯辨意加。谓承佛神力。及加因中毗卢遮那本愿威神。今长行光照为身加。偈颂请说为口加。故具三业加相方具。此即远公第三加业有异。疏又前默与威神下。第二所为别故。亦应问言前何不具。今方具耶。答云。留此身口发起请法故。言令有加请者。前主佛加。令得诸佛加。既得佛加出定说本故便有请。则前主佛加为诸佛加因及三家请因。今主佛加加即是请故不同也。此即远公第五加请分差。疏若尔诸佛前已下。第二通蹑迹难。意云主佛未具身口故今欲具伴佛。已具何得复加。复加即经云十方诸佛悉亦如是。及诸佛威神力故而说颂言。疏前但是加下。答此亦加请分差。此段亦含远公第一能加佛异。以前约所表。皆十方金刚藏佛加。今但云十方表通方故。又遮那亦照十方说法菩萨。则知异名诸佛亦得同加。疏上力被下下。第二释名可知。疏不以常口下。第三拣别。文有二。初则加相不同。后即所被不等。今初有三。初牒异相。二为不轻尊位下。出所以。三要复请下。通蹑迹难。谓有问云。若重尊位何如莫请。答云为重法故前则尊人。此为重法尊极请故故法为重。疏前加分中下。二拣所被不同。即远公所加不等。则前局说者。此通说听。出所以可知。疏文中通有下。第四释文。言卷业经文所无者。以卷约作用已竟。卷归毫光下。既更有余业故经略无。但以如日身当之。而论经舒卷相对故逆明之。故论经云。普照十方诸佛世界靡不周遍。照已还住本处。还住本处即是卷业。止业明光利益。五降伏业明光势力。六敬业显光摄益。谓显佛力令他敬故。即为摄益。疏令众见说听者。皆得佛加者。经文云又照此娑婆世界佛及大众并金刚藏菩萨身故。明知通说听也。疏二正显所作加等者。疏文有三。初列名。二论不指下出体。三故以身对业下。料拣于中二。先成四句。后以身约有体下。出四差别所以。以业约有用。如日身但能皎住故。言非正所为者。本意不为令相见故。故无业无体今经略无。疏今初加于彼三字为总等者。此中经文有其三节。一唯总。二通总别。三唯别。疏文有二。初定总别。二释别相。今初总别有二。加于彼三字二偈之总。其世中上即二十五字之总。除加于彼三字故。言以上即胜者。会今经同论经。疏言四胜下。第二释别相。一自在胜。不为他屈二障即他。二力胜。即能伏他。三眷属胜。即辅弼豪强。四种姓胜族胄尊贵。疏不染如空者。空有多义今取不染。此含二德以离二障。即是断德。能离此者即是智德。故下结云等正觉故。又自在者离烦恼障则心自在。离所知障则智自在。问断痴慧明。灭爱心脱故。净名云不灭痴爱起于明脱。今此何故除痴除爱皆名心脱。以但云烦恼故。事中照用为慧解脱。文云离所知故。释曰二脱有二义。一由解中无染之心名心解脱。照理之智名慧解脱。是为心脱除爱慧脱除痴。二以真识出离爱染为心解脱。事中照用为慧解脱。则心解脱双离痴爱。慧解脱照事无遗余。经多依前门。今论乃是后意。疏十地已还下。释佛无等等之言。谓过下故为无等。以齐上故重言于等。言欲显佛佛等正觉者。此遮复难。谓有问言。何不但说无等。何用重言齐等故。今答云。以诸贤圣望于下地皆名无等。而更有上犹未上齐故。今唯佛方能等佛觉以究竟正觉同也。疏二力胜者。亦是智德多约权智。如十力是体能伏邪智之怨敌故是用。然论经言十力无畏等总为力胜十力是体。无畏制外道等字兼于神力以用降魔。今以无量等言属下眷属胜。以无量字该之故。但将十力以为力胜为顺文故。若将胜功德言。两处用之于理无失。故今取意能伏邪智即是制外。其怨敌言亦有二用。一者邪智即为怨敌。二怨敌言即是天魔。疏三眷属胜。言论经即当无量诸众首者论经等者。彼经下句云。诸佛无等等功德如虚空。十力无畏等无量诸众首。释迦姓法生人天上作加。释曰。由此故远公与论。皆初二句是自在胜。如虚空言独喻功德。今功德字在第二句中。兼属第三胜。则无量胜功德之言通于三处。一以功德属自在胜。二以功德当无畏神通便属力胜。三该无量胜功德。便属眷属胜。今疏顺文别配故但属眷属胜摄。次论云诸众首者下。引论牒释则今之经文同论释语

大方广佛华严经随疏演义钞卷第五十五大方广佛华严经随疏演义钞卷第五十六

        唐清凉山大华严寺沙门澄观述

疏。四种姓胜。疏文有四。初牒名嘱经。二于中又二下开章别释。三由上四义下。结归第二重总。四上云二种加下。结归第一重总。以具二加。加金刚藏故。于中先结二加。后今此具德下。结加金刚藏。前中言有法所依之身者。谓具相好身未成佛时已有故未是果。后依身修起方名为果向约四胜中第四胜。则释师子法。以别开二义唯法一字名为法家。余则生家。今为二加则单取释师子为身加。总取释师子法为具果加。疏第二偈加所为。疏中二。初总辩意。二文中下总科三义藏即胜妙行下。嘱经别释。今初令开法藏示显现故。疏是说所依者。依佛神力说故。故论云此偈中何故令显承佛力说。答有众生于如来所生轻慢想。以自不能说请他而说。为遮此故显是承力非佛不能言开胜藏。一句是总者即开此法王最胜藏句。然此胜藏属于如来故。云开法王藏义藏即是地体。字藏即是地相。疏染净无碍故云神力者。谓经但云胜论詺为上者。神力胜故。疏会释谓。不住道处生死而不染不碍涅槃。在涅槃而不证不碍生死。是为染净无碍。又论但云行为助道其证不住。疏例论释以义顺故论举一隅耳。疏如是显示深妙胜上之义者。总结义藏深即助道助道能穷实故说为深妙。结证道。胜上二字同结不住。论经云上。今经云胜。论结双明胜上。二字藏者即诸地广智。及分别说。若望经文分别说言通说二藏。以论经云分别智地义一句为字藏。今取文同故合第三句四字及第四句三字当之。疏若得上加则法宝入心成闻持者。正顺解脱月双叹人法请。说此不思议法。此人当得如来护念而生信受。由法胜故则得佛加。得佛加故法宝入心。法宝入心即是闻持。既由法胜故加。明是举法胜益以请。疏后一偈转生时胜益。疏文有六。初显意总科。二论经但有下会通二经。三此中大意下总显文意。四以难不障闻下。以论释文五上顺论释下。别申意趣。六问若依下。问答料拣。初中言即具坚种人。谓具金刚种。虽在八难而得闻经。以彰闻经益之深远。种子无上故。地狱天子三重顿圆。疏今经堪受即决定信义者。正会释也。若无信心在善道中。尚不得闻况恶道耶。故次辩大意。若有信心难处尚闻。况非难处。疏以难不障闻故云虽也。下第四以论释文。于中但释前半后半。总科之中以出大意竟。就释前半中。疏文有二。先总明。后别释。今初此言有二意。一者成上所以。不问难不难者。以不信障闻非难障闻故。二者即蹑此意以释虽字。虽者纵夺之词。言含得失。八难是恶而不障闻故。虽难而非难也。言海水劫火即是转生难处者。即总指经文。释论转生之义。疏大海即是恶道下。第二别释也。先释海水堪闻以龙宫有经故。龙至佛会故。后劫火中释火中闻经。疏有文五。一正以释经。二会释论文。三以论会经。四释论等字。五会长寿宽狭。初文可知。疏此即指二禅下。第二会释论文。以论云光音天已上故。疏然二经中文皆巧略下。第三以论会经。言巧略者下云若具应言即显经意。文中是略而云巧者。下云举初摄后对水成文此即巧也略义可知。疏等言等取下。第四释论等字。于中二先显论包含。劫尽有三。谓水火风。火坏初禅。二禅已上得闻水坏二禅三禅已上得闻。风坏三禅四禅已上得闻故。劫火言亦是火劫异水风劫故。论经云劫尽火中者。正取二十住劫已终。又十九劫坏有情竟名为劫尽。一劫坏器名为火中。疏今举初摄后下。二显经之巧。举火劫摄于水风显义巧也。对上海水而云劫火。显文巧也。此言初对长寿天。所以得闻者以彼有天曾从佛闻而为说法故二能下就佛而听法故。如初列众处说。皆由信故难不为难。其为难者未曾闻熏耽禅味故。疏按智论等下。第五会长寿宽狭。即智论三十八云。长寿天者。谓非想非非想天处。八万大劫故。或有人云。一切无色定通名长寿。以无形可化故。不任得道常是凡夫处故。或说无想天名为长寿。亦不任得道故。或说从初禅至四禅。除净居天皆名长寿。以着禅味邪见不能受道。故上即智论等言。等取梁摄论及成实论。皆同智论第三师说。上诸论意皆以上二界寿长。又耽禅味不任受道。故为难处。今有信心并非是难。此上明长寿天竟。疏今不取初禅者。明论小狭二因故除。一有觉观义通余处。二正烧者正顺论文。若说初禅为长寿天难。无由得说火劫。今火烧初禅初禅无人故。约二禅已上得闻长寿之难得闻。疏上顺论释下。第五别申意趣。于中二。先结成论意。后理实八难下。正申别旨。于中又二。先通八难。八难虽则不具不唯有二。谓论已有二。加佛前后为三。海兼地狱为四。修罗兼鬼为五。以五趣明义修罗亦鬼摄故。其生聋盲正绝见闻不可说闻但潜益耳。忽令生于耳目亦容见闻。世智辩聪亦不妨闻。疏今经但云火中者。二别释火中之言。即法华中意在华藏品已引故。华藏云劫烧不思议所现虽败恶其处常坚固。即明火中闻也。火浣之布。火中之鼠。炎铁团内而有虫生。众生业殊岂妨火中闻法。方对海水之内正在其中。疏问若依前义下。第六问答料拣。先问可知。后答中三。初以义正答。二会释经文。三结劝引证。今初然戒能防非止恶。近得人天之身乘者理运弥载远证涅槃之果。为功不等益有浅深。故美乘而轻戒。然戒有随相离相。三聚尸罗体即是乘定慧。若有漏取相亦不能运出。今以随相律仪不动不出。不得称乘定慧。了知性相动出名乘。各举一边以美乘妙。一乘缓戒急者。事戒严峻纤毫不犯。三种观心了不开解。以急戒故人天受生。或随禅梵世耽湎定乐。世虽有佛说法度人。而于此类全无利益。设得值遇不能开解。震旦一国不觉不知。舍卫三亿不闻不见。着乐诸天及生难处不来听受。是此类也。譬如禁系之人。或以财物求诸大力。申延日月冀逢恩赦。在人天中亦复如是。冀善知识化道修乘即能得解脱。若于人天不修乘者。报尽还堕三恶道中。百千佛出终不得道。二乘急戒缓者。是人德薄垢重烦恼所使。是诸事戒皆为罗刹之所啖食。专守理戒观行相续。以事戒缓命终即堕三恶道中受于罪报。于诸乘中随何乘强。强者先牵。若一乘强即闻华严等。三乘戒俱急者。谓具持众戒理事无瑕于诸妙乘观念相续。即于今生便应得道。若未得道此业最强。强者先牵必升善处。随戒优劣欲色等殊。随乘胜劣运出亦异。若一乘急即于人天身中闻华严等。四乘戒俱缓者。谓具犯众戒。又复无乘。永坠泥犁失人天报。神明闇塞无得道期。展转沉沦不可度脱。疏今海水劫火下。第二会释经文可知。疏勉旃下。结劝引证。引证即涅槃第六。因明菩萨忘犯护法。迦叶菩萨白佛言。世尊如是菩萨摩诃萨。于戒极缓本所受戒为具在不。佛言。善男子汝今不应作如是说。何以故本所受戒如本不失。设有所犯即应忏悔悔已清净。乃至云善男子。于乘缓者乃名为缓。于戒缓者不名为缓。菩萨摩诃萨。于此大乘不作懈慢。是名奉戒为护正法。以大乘水而自澡浴。是故菩萨虽现破戒不名为缓。释曰。此意唯以大乘为乘。今疏文意亦取大乘正法为乘耳。故结劝云留心法要。旃犹之也。疏第二一偈教说分齐也。疏文分五。一总显文意。二言渐次下。释总名。三云何为三下。列名出体。四胜智道者下。随文解释。五问答料拣。三中观者所谓观解。始心拣择名之为观。依解得实名之为证。证心清净解脱成德说为修行。如金清净为庄严具。从此即十地之中下出体。体即三智。远公更有一释。云解行为观。初地为证。二地以去说为修行。今以论意皆言十地观等故唯依前释。疏即观行渐次者。疏文有二。先取论意总释。后谓说诸地若加行观下。引论辩其观相。今初道者因也者。以胜智为地智因故。以道为因道即加行。若远公意詺三慧为智。渐增为胜。虚通曰道。就辩观相中。观为能观。依止理为所观。理智相应能生后地。而远公云始观为观。正住名依止。地中满足起后为能生。此三自为观中渐次。似非论意故。疏不依但以加行为证渐次耳。疏以后得智要由证真方能了俗等者。证真竟方能了俗故为渐次。故三渐次唯证一种当证。上论自云三心以为渐次。余二以自望他而为渐次。疏问地地正证者下。第五问答料拣。于中先问。后古德下答。于中二。先举贤首释。后此亦顺理下。疏为会释。以刊定取唯识意约德异故。有十亲证破智明昧故为会释。二义俱取于中二。初句总标。二别会。今初言此亦顺理者。非是不许彼之正义正义即唯识意也。故云此亦顺理。彼疏有二。先难古释。后申正义。难古有三。一难云。谓境智互相如。约智证十如。何不境智互相如约境证一如。二难云。加行后得非亲证。可说彼智有明昧。正体缘如不变影。何得说此有明昧。三难云。能证有分限。所证无分限。以限证无限境智岂相如。下出正义云。应知亲证之言。但望当地加行后得故名为亲。不望后地说为亲证故不相违也。于义可知。今当为古德先通此难。一者我许有十如则应如所难。我唯立一如何因为此难故应顺语答第一云境智互相如说智十遍证。境智互相如约境惟一证二。答第二云。汝证十如不变影一如而说为十如。我证真如不变影。何妨一智十亲证。三酬第三有其二意。一随难通。以能随所证不许有明昧。以所随能证真如应是智。二者反难云。真如无分限不许有明昧。真如体不异十德何由成是则前难未为切要。疏故唯识下。第二别会释。于中四。一举唯识正义。二借文通义。三反难成立。四以喻显示。今初唯识正答如无异难刊定。傍此而斥本师。然唯识疏中释云。真如实无别。随其所证。所生能证胜德假立十种。释曰。既云所生能证胜德假立十种。早有智明昧义矣。疏又云虽初地中下。第二借唯识文通贤首义。然唯识论此一段文自明废立。应有问言。初地之内不达十如。应无发趣之果能达后后相及得果。若已通达何不齐证真如十德。故今答云达即齐达。证行未圆故行位有十。故有十种圆满真如。乃至如来十皆能了。如辩中边论广有分别。言能证者。由于行圆。后后地行别别渐圆。岂非约智有昧明义。虽彼疏释本为废立。即以此义可通明昧故得引之。以非证论中通真如无异之义故。今疏云亦约能证有明昧意也。疏若唯取所证下。第三反难成立。此有二难。一初地未证难。如有十德初唯证一岂是证如。二不通本难难谓本难云。如本无异何有十证。今云当地证于一德名亲证者。无异之难岂得免耶。疏如人观空下。第四以喻显示。眼有小大空无差别。是故生公依于此理立顿悟义。明唯佛悟证如穷故。十地圣贤皆为信境未全证如。故云夫称顿者明理不可分。悟语极照以顿明悟。义不容二不二之悟符不分之理。理智兼释谓之顿悟即斯意也。虽迥异常谈亦为系表之玄矣。疏自下第三许说分齐。疏文分二。先显意总科。后今初下。依文正释。于中二。初释说仪。后释说意。前中二。先举论释经。后观十方佛下。疏释论自有二意。一以无慢对佛。不偏对机。佛请不说便是自高。今承力说安敢慢乎。二亦可下。意欲显通。却以无慢对机。不偏对佛。疏欲令大众下释说意。疏文有四。一依经释。然疏示说正地该通二大。远公以示说为说大。正地为义大。乃成穿凿。二若准论下。引论释。三以前说主下疏释论经中重增之言。四如何得此踊悦下显喜意。于中四一征以总释。二义名所以下释二大名。三闻于二大下。结成踊悦。四然二大体下彰其体性。于中二先总标。后远公下别显二师。远公云。证道所表即是地法者。证道约人契会地法本自有之。犹十二缘以法就人三世流转。废人论法性相常定。疏贤首下。此师文三。初正明二大。二然其后解下。对前拣异。三古德因此下。明可说不可说。于中二。前总后别。前中言下论自明者。论意因分为可说。果分不可说。举论此文即夺古德。从非无眉目下。纵成古义妙理无妨故。疏于中初就义大下。第二别释。于中三。初标章。二别显。三融通。疏义中有三下。别显言可以标举令人知有者。总显三意为义大皆可标举。如前七偈即其事也。不可指斥者。文云言说不能及是也。疏二约证处等者。如鸟足所履之处。以喻所证。而言此处非有非无即为可说。为迹之处不可显示名不可说。疏三约本智等。谓以空中鸟迹喻于证智。说有空中之迹即是可说。不可示其长短大小即不可说。疏摄论云无分别智离五相者。双证说不说义。即无性摄论第八增上慧品。第九论曰此中无分别智。离五种相以为自性。一离无作意故。二离过有寻有伺地故。三离想受灭寂静故。四离色自性故。五离于真义异计度故。离此五相应知是无分别智。释论曰。依智自性说离五相。由遮诠门说智体相。以表诠门不可说。故遣分别门无分别智。其相可了。若异此智应有分别。何有分别。谓后广说无作意等。若无作意是无分别智者。睡眠醉等无所作意。应成无分别智然不应许。由离功用应得无烦恼故。若二是者第二静虑已上应成无分别智。若三是者此智体相难可成立。以彼离心无有心法故。若四是者应不成智。如四大所造故。若五是者。此智不成是无分别性有分别故。论颂云。诸菩萨自性远离五种相。是无分别智不异计于真。释论云。前三句遮五。第四句正说自性。已上引论。今疏中言睡眠醉等略举五相之一。等字二义。一者等取余四。皆为证成第三约智耳。二者等于无想定及无想报。以五位无心略举二故。第五灭定第三相中自拣竟故。从以直诠不到下。即释论意具如上引。上句即不可说。下句即可说义。又上三义且从别义配果海等。而实三义俱通果海理智等三。皆可标举不可指示。寄言遣言。约遮约表思之。又上三义明说不说更有二义。一约自体真法互相显现名为可说。如经云智起佛境界等。谓以如显智。以智显如。名为可说。不可以此性相别取名不可说。二者情实相对。以情望实情外有真可以谈说。据真就情真外无情用何起说。疏是出世间故不可说者。以后得智必由证真故。是出世如何可说。观中行相言不至故者。以修中观必称性修性出名言故不可说。故弥勒云。种性粗相我已略说。诸余实义唯佛能知。疏又诸法自相皆不可说。诸法共相皆是可说者。此依因明论。谓一切法上实义皆名自相。以诸法上自相共相各附己体不共他故。若分别心立一种类。能诠所诠通在诸法。如缕贯华名为共相。此要散心分别假立是比量境。一切定心离此分别皆名现量。如第十唯识疏说。然就说大中约加行智傍出此义。以其加行观法广故。通意言观故傍出也。疏又果海离缘下。上说不说通其六重。此下六重相望则初后唯一中间具二。疏此上不可说下。第三融通于中二。先正融通。二引证。今初以真理普遍故者。真理不可说普遍于事是故可说。言以缘修无性故者。缘修即可说。无性故便同真理不可说也。疏是故下引证。先引当经。即末偈我今说少分。疏涅槃亦云下。二引他经即涅槃北本二十一高贵德王菩萨品。说十功德中。第一智慧功德因辩修行大般涅槃。闻所未闻。琉璃光菩萨从东方不动世界满月佛所。而来问佛便明至不至义。世尊以生不生等释成至不至义。略有六句。四句是复。一不生生不可说。二生生不可说。三生不生不可说。四不生不生不可说。二句单云。五生亦不可说。六不生亦不可说。今略释之。第一句未生之法名为不生。有可生性名之为生。既不生为他所生。故不可作不生说也。第二句谓生相能生可生之法名为生生。今生相不能自生。既不自生何故生他。故不可作生生说。第三句谓生相能生未生之法名生不生今由不生无漏。故不可作生不生说。第四句谓未生时无有生事名不生不生。如虚空未生之时无有生事。不能令生有漏之法。既未生时无有生事。若有缘会则能生耶。故不可作不生不生说也。五生相是生不能自生故不可说。六未生是不生缘会便生故不可说。言有因缘故亦不得说者。经云有十因缘则可得说。远公二释。一以十二缘生。前十共为生支之因。二者即地持等十因。谓一随说因。二观待因。三牵引因。四摄受因。五生起因。六引发因。七定异因。八同事因。九相违因。十不相违因。释曰后义为善。广如唯识等。然彼经中广解不生等相。今但略引证说默之旨。故不广具。第二正申偈中。疏今初正显地智微妙之相下。疏文有三。初定所显之法。二于中论经下。略会论经。三言微妙者下。牒文解释。今初以远公意明初三偈半显佛法微妙。后有三偈。举彼佛法显地出言。故今拣之。明初三偈半亦是显于地智微妙非说佛果。于中三初总标是地智。二引证。三结弹。疏故论云下。二引证也。文中五。一问。二依智地故论答。三依者据也疏释。四云何知下论重征。五上来下论自释。然论但云上来所说皆依智地。后复所说亦依智地。第六偈言智起佛境界故。释曰论无本分请分等言。今疏义加耳。此论引三节文。谓一上来。二者后说。三即今偈本分即前标举。地体相是请分。谓解脱月大众如来皆请说十地。解脱月请经。云何故说地名。而不为解释诸地妙义趣。是众皆欲闻。大众请经云辩才分别义说此最胜地。如来请经云诸地广智胜妙行。以佛威神分别说。如是等文皆是十地之智地耳。非佛果也。疏后说分等者。即论后复所说意云酬请。既说十地法门。明知许说分齐。亦说十地之深义耳。疏即今此中等者。此经第六偈即论经第四指语全同。意云。智从佛境界起。所起之智即是十地。故下释云。智者是地智。起者以何观。以何同行。能起此智。此下释佛境界言。次前论云。此偈示现思慧及报生识智。是则可说此智非彼境界以不同故偈言智起佛境界故。意云此智地唯佛穷尽故。辩所知亦只智地。又境界即如如为佛境。今此智地由于加行观佛境起。明皆说十地智耳。不尔岂有请说皆明十地。今乃示果之分齐耶。疏明知此显下。第三结弹昔义。疏此即双指下。疏释论言圣道是体难知故微者。圣之一字即今经。如来大仙即圣人之道名为圣道。以人取法意在于道。道即地智故云是体。言难知故微者难知是微所以。亦是微相。该于说证。故下开二义。言故净名云者。即菩萨品弥勒章中文也。疏云何难知下。开章别释口欲辩而辞丧者。言语道断故。心将缘而虑息者。心行处灭故。前来频释问既云说时云何难知。答有心不能说故。故净名云。其说法者无说无示。则言而无言矣。疏上大仙道是所证说者。牒经第一句。为其地体。即论经圣道二字上直就法体以论微妙。今以人显法。以是佛因何不微妙。疏初句即说时难知者。次第释上二章也。非念离念语。则非念似南宗义无念。离念似北宗义。释乃非念同北宗修得非念故。离念同南宗本性离故。若二宗相成由本无念要须离念。方知今此云何以非念者。由本离念故。言自体无念者以无缘故。然体无念复有二意。一性净无念。以心体离念故。今非此义以此通一切凡小故。二契理无缘都无所得名为无念。即今所用。若依此义亦异偏就南宗。故南北圆融方成离念。由上二下结即非念离念二义。疏求欲证见难证得故者。以论经但云难得。今经云求见不可得。得之与见俱约证说。故云求欲证见难可得故。次以无见无得下。双证二经。言无见者上经精进慧菩萨云。有见则为垢。此则未为见。远离于诸见如是乃见佛。又善慧菩萨云。无见说为见。无生说众生若见若众生。了知无体性。又功德慧菩萨云。无见即是见。能见一切法。于法若有见此则无所见。无得者智慧菩萨云。有诤说生死。无诤说涅槃。生死及涅槃二俱不可得。真实慧菩萨云。佛法不可觉了此名觉法。诸佛如是修一法不可得。又云一切法无住定处不可得。诸佛住于此究竟不动摇般若宗中。无智亦无得。以无所得故菩萨心无挂碍。诸佛则得菩提。净名天女云。若有得有证于佛法中为增上慢。故无见无得方能证得。得与无得俱绝名言。非离有得而证无得。方为真无得也。亡言亡言。疏下四句别等者。以总明难得。其相犹隐故别显之。然疏文有四。初总标。二列名。三释经。四料拣。疏第一观行下。第二列名。依论次下释顺经。论经云难得无垢浊。智者所行处。自性常寂灭。不灭亦不生。故为此次。疏初句下第三释经。初句释第四功德微。即无生亦无灭句。无生者用而常寂。不灭者寂而常用。故云不一往灭。一往灭者。即同二乘上来释经。即无住涅槃。寂用无碍功德者。结成论名。疏次句清净下释第三清净微。上功德微即是自在我义。此微既约性净即是常义。悟实本净无染可除。先染后净即是无常。疏言离垢者下。释第一观行微即是净义。先顺释。论云智中无无明故。不同世间下。反释故论云有无明杂智是名为浊。以论经云无垢浊故。世间八禅是不动业必杂无明。疏聪慧人下。释第二依止微。即显乐德。言依止者。为行依故。先释能行之人。此聪慧人即论经智者二字。疏彼人之智下。二释彼智所行处。于中三。先总释二征以别显。三正释行相。疏何智能行下征以别显。然有二对。一总别。二权实。今疏合明。然论云智者所行处者。自证知故。自证知者。依彼生故。于中智者见实谛义故。复增上善解法故。增上善寂灭故。复有世间智。随闻明了知故。释曰。今疏意明此中论有总别。先总后于中下别。总中二句皆是实智。别中有实有权故合之。就总就实唯一实智。然总别就文。权实约义。疏云何行处。即第三正释行处。二智可见故。唯约证智。能行即是论中总意。初云此之地智是彼证智自证知故者。即论云智者所行处者。自证知故。次云依彼地智说证智生者。即释论第二句。云自证知者。依彼生故是则地智约本有之证智。约人就法。亦由远公上云三证智。四所表地法思之。疏上四微中下。第四料拣。于中二。先依论从胜以配。后上依增胜下。疏意明通。通相云何。如功德异小。无住功德凡外岂有。观行异凡。小乘外道皆有无明。明彼亦无依止清净。拣异外道。凡小宁有。以并非聪慧。双证二空定契性净为恒寂然。故知论主从胜略配耳。疏此征体相也者。疏释论体相有三。一者标相。如见烟知火见鹤知池等。二者形相如长短方圆等。三者体相。如火热相等。今拣前二故云体相。体相复二。一者事体。如向所引。二者理体如空寂等。今是理体约不同相。虽义兼于事皆事理相即为深义之体也。疏智体空寂名为同相等者。其犹世间色等空寂名为同相。色相差别为不同相。不同犹于自性也。疏总中此是谁相下。释总句有二。先释经后释论经中两重假征以经配答。可知但体性有同有异。异者相据于外。性主于内。体者性相之通称。则宽狭不同。今此所明即性为体。故经云自性。论经云自体。疏何以言同下。第二释论同相之言。先出体。后释名。此即性净涅槃者。出体也。则下言不同。是方便净涅槃。同相有二。一对因彰果本隐今显。二对用彰体。涅槃体净故。不拣修生修显功德彰体齐称性净。若依初义无始法性。名之为体。昔为妄覆今障息德显故名为净。若依后义则涅槃法体名之为性。涅槃体净名为性净。下方便净亦有二义。次下当辩。疏上同诸佛下。后释名也。以体释名由体同故。略举三同显横竖皆同。上下即竖。横同诸法标也。诸法如故下。展转释成文中自有五重征释。一云。云何知皆同诸法。释云。诸法皆如故智体即如故云同也。二征云。经云性空何干于如。故释云如即空故。三又征云。何以得知如即是空故释云。一切皆以空为自性故。自性即是空如。四又征云。岂不言总意别。别在于智何言诸法。故释云。色性智性本无二故。即起信文故以法取性。性随法别。是则智空非说余空。若以法就性性无不同。五征云。纵言性同何以得知是涅槃性。故引涅槃经。证一切诸法中皆有安乐性。安乐性者。即涅槃性故。即涅槃第三四十二问中一问也。疏下句别者下释。此一句疏文有六。初会论经。二释云下。引论标释。三三种空者。即地前下引他论证成。四今云有者下。引论别释。五今经阙有下。会通经文。六三种空义下。结广有在初二可知。三中即宝性论第四云。若散乱心失空众生者。谓初发心菩萨离空如来藏义。以失变坏物修行者。名为空解脱门。此明何义。初发心菩萨起如是心。实有法可灭后时得涅槃。如是菩萨失空如来藏修行。又有人以空为有物我应得空。又生如是心。离色等法别更有空。我应修行彼人不知空。今疏二当第三。三当第二。为顺论中三种谤故。又取意引对文可知。然般若经中四句。正遣此三空疑。一疑空灭色故。以色即是空遣之。二疑空异色故。以色不异空空不异色遣之。三疑空是物。今明空即是色故非别有空也。疏今云有者。即初离谤摄者。四引论别释也。然论先列三病。即返问辩非。后列三名治之即顺问彰是。今初。论云自体空者。可如是取如兔角耶。不也。可如是取。异此空智更有异空耶。不也。可如是取有彼此自体彼此转灭耶。不也。后顺问彰是云。云何取此自体空有不二不尽。如是取此句显离三种空摄。一离谤摄。二离异摄。三离尽灭摄。释曰。上论先举所拣以经对治。今疏乃分其能治所治。兼经五字一一对释于义易了。如云今云有者。牒经言即初离谤摄者。即举论立名。言不谓断灭下。明离前过。如兔角者。即前可如是取。如兔角耶。其不谓两字即前不也二字。断灭两字即取三空乱意中第一乱意。会同论文。下之二摄例此可知。但观上所引论文自分主客。二即疑空异色。三即疑空是物。谓空为有。三中言此明非灭有体之智以成有体之空者。此有两释。今是第一释。由论云彼此自体故。以空为此智为彼既离尽灭故。非灭有体之智等。疏亦非空有物可转灭者。即第二释。前释双就智空上论尽灭。今就空上论尽灭。正顺上第三。谓空为有谤不要约智论有也。疏离此三空下。结成正义。然正义尚难。初二是有。后义非有自互相违何成正义。故说正义智相是有。智性说空。今此智空由有三德离上三谤。一相作义故离初谤摄。谓若无智则无有空。若无真空智不成立故。若诸法不空即无道无果。中论云。以有空义故一切法得成。故论经云。有能离谤摄。既空能成有。岂待灭智方成空耶。二不相碍义。是故不异异即有碍于空。定性有故空碍于有。定性无故既不相碍。故非色外别更有空故离异摄。三相违义。以体非有故无可尽。安谓空为有耶。故初则废他成己故有空。后则废己成他故非有空由初有故不无。由后无故非有非有非无是中道义。故此空有岂得异耶。由空义故与智非一。由前二义与智非异。非一非异是中道故。故此真空是智之体。体相无二为智之相是同相也。同相即是空如来藏。空如来藏即性净涅槃。其揆一耳。疏今阙有字下。第五会通经文。此句征也。此有二意下。释初意。以不尽字摄有字。前明不尽是无。故无可尽则离谓空为有过。今明有体故。不尽则离断灭过。二者下第二意即以无尽二字摄有字。以是有无不二故离断灭。于中先出论文。次意云下释论。后今经亦无定字下。会释今经。言离前二空者。一谓有无不二故离于异摄。二即异故义如前说。二者有无既其不二。岂灭有明无。故离断灭虽有二意后意最亲。疏二有六句明不同相。即方便净涅槃者。疏文有三。第一总彰大意。第二随文解释。第三总结会通。初中有三。初出体。二释名。三解妨。今初即方便净涅槃。对前性净。方便有二。一对因彰果。从因方便而修得故。二对体起用作用差别故名方便。方便即寂故称涅槃。疏断惑平等下。第二释此不同。对于前同。前同有三。今亦有三而少开合。一对下不同众生。言断惑平等者。断惑故异凡夫。平等故异小乘。小乘不断法执故非平等。又谓有惑可断。不解无断而断。今皆反此故云平等。二而能断故。不同外境但是所证。即对前横同诸法。然诸法中含其有无故开为二。今对有境质碍之境不能断惑。但是所证故。三有异相故不同空者。即前诸法中含此无法。又加此空者。前约性净同空义多。今方便净同空义少故云不同于空。不云不同诸佛者此多同佛故。疏涅槃是果下。三通妨难。而文有二妨。一以果违因妨。先问后约分证下答。答有三义文并可知。疏今明地智下。第二所证违智妨。亦先问。后若分相下答。大意可知。然约相融凡是一法即摄一切。若以涅槃为门。涅槃门中摄一切法。若以菩提为门。菩提摄一切法。若法身为门。法身摄一切法。今约地智。地智门中摄一切法。智相即同菩提。智性即同涅槃。今取即相之性故。同与不同皆名涅槃。言二而不二者。性与相殊而复相即故。难说甚深者。欲言菩提即同涅槃。欲言涅槃即说为智。互融双绝难以一事当之故。理圆言偏。理与言绝为难说耳。疏文中解脱是总下随文解释。先解总句。言异前者。异前同相也。疏宝性论下。引论成立。此论前有偈云。佛身不舍离清净真妙法。如虚空日月智离染不二。论云此偈明何义。向说转身实体清净。又清净者。略有二种。何等为二。一者自性清净。二者离垢清净。自性清净者。谓性解脱无所舍离。以彼自性清净心体不舍一切客尘烦恼。以彼解脱不离一切法。如水不离诸尘垢等。而言清净。以自性清净心。远离诸烦恼垢更无染故。又依彼果离垢清净故(云云)。若无上依经第一亦明四德。各有二义。净有二者。一自性清净是其通相。二无垢清净是其别相我有二者。一远离外道邪执我。二离二乘无我。乐有二种。一断苦集。二断意生身诸阴灭。常有二种。一离无常断见。二离涅槃是常见故。上皆取意引经耳。广如涅槃章疏。别中以别显总下。释别句。于中有二。先释于诸趣言二云何下。释余五句五句即显五种解脱之相者标也。下唯列三。后三合故。若具应云三明般若是观行相。四明法身是转依相。五明解脱是无碍相。今以后三合为涅槃。前之二义亦三德开出。般若约决理边。即名观智。约契合边即名观行。无间道断即断惑相。解脱道证即无碍相。故虽五句但是三德。疏言平等者。即牒经解释也。此即第一等二际。是观智相者。即经涅槃平等住。谓世间涅槃下皆论文。从以世间之性下。疏释平等之义。然论云平等摄取。约人说平等。非如声闻不得平等。得与不得并约于人。而疏以性释者。由二乘不了性等故。背生死向涅槃。菩萨了性本平等生死即涅槃故。不舍生死而取涅槃。不离不在纳法在心。故云平等摄取。疏中观云下。引证释成。即涅槃品偈云。涅槃与世间无有少分别世间与涅槃亦无少分别。涅槃之实际及与世间际。如是之二际无毫厘差别。今但义引三句意已具矣。若更广说应有四句。一全涅槃故无毫厘差。以世间实性说为涅槃。涅槃之相说为世间。以性收相无相非性故。唯涅槃亦无有差。二全世间故无毫厘差。以相收性无性非相故。三全世间之涅槃。与全涅槃之世间无毫厘差。以虽互收不坏二相故。四全世间之涅槃非涅槃也。全涅槃之世间非世间也。非世间与非涅槃无毫厘差。以性相互夺异不可得故。义句虽四法唯一事。所谓无事故非四也。是故顺情而取四句俱非。顺法而言四句俱是也。此般若智于外能照诸法皆空。内照之体廓然即空。空四绝故四绝中间即空之神照朗无相之虚宗是般若法也。此即非中之中也。由不碍事之理故。全涅槃入生死。全生死入涅槃。由不碍理之事故差别宛然也。由二俱无碍故入不入俱成也。由二无碍又不二故。入即不入。不入即入。如是方为究竟平等。疏二断惑相下。释此一句疏文有三。第一总明大意。第二开章别释。第三结示圆融。今初谓三时相因俱无定性故。三时无断由无定性。方能断惑故云方说断耳。故云非初下。指经文然杂集第七亦云。从何而说烦恼断耶。不从过去已灭无故。不从未来以未生故。不从现在道不俱故。此即三时无断义也。中观论广说。即以三时门明无断义。无断即是性空义。以有性空义故一切法得成。故成断义下当广明。疏释此有二义下。开章广释于中相翻。疏文有四。一定断处以开三关。二此三惑智下。依关立过。三若尔下。假问征起。四若依唯识下。正彰断义。二中谓智先起有四过者。一本因断惑得无漏智。今智先起则不断惑自成无漏。二智既先起。惑犹在故不能断惑。烦恼二过者。一智已先起烦恼犹在。故后灭时是自灭耳。二惑在不碍智起。故不障圣道。惑智各二故有其四。疏智后同时各具四过者。并出二关。言智后者。即前为惑先灭智后生耶。言四过者。初明二惑。一惑自先灭过。由智未生而惑灭故。二不障圣道过。惑先已灭不碍智故。此惑二过。智二过者。一智有自成无漏过。惑已先灭。智不断惑故。二不能灭惑过。惑已先灭。无可灭故。言同时者。即惑智同时亦有四过。智二过者。既与惑俱。惑不干智故自成无漏。亦不断惑。惑二过者。既与智俱故不障圣道。与智俱时惑犹在故。后若断时亦自灭耳。疏如灯不破闇下。约喻以明通经及论。又涅槃下引经。法说成上法喻并如下明。疏若唯识下。第四正显断义。于中三。一正显唯识。二明顺违。三显当宗。初中言二真见道者。彼疏不释。有云。谓真见道。及相见道。此释非理。言二真故断惑正在真见道故。有云。人法二空此亦难依。二空所证今说能断故。有云。无间解脱为二。此二应非断惑。正在无间道故。若尔何者指南。应是大小乘为二故。次前论云。二乘见道现在前时唯断一种名得圣性。菩萨见道现在前时。具断二种名得圣性。二种即二障。所断广狭小异。大小俱是真见道断故。然彼论意为异萨婆多宗。彼宗所立见道之前断异生性。无间道起与惑得俱说言断耳。故为伏难云。若异生性见道前舍。无漏果起无有凡圣俱成就失。今既依于见断种立。即无间道有惑种俱。异生未断如何凡圣无俱成失。故唯识论云。见道起时彼种不成犹如明生不与闇并。故凡圣二性无俱成失。若无间道与惑得俱。却有凡圣俱成之失。杂集第七亦明此义。疏此但举法相下。第二辩违顺。先纵成后若望下。辩有违。先破秤喻。后破明闇。明闇同喻极似于法理则无违故先印许。后到与不到下。但就无性理破。三论广说。中论三相品中。小乘被破大生小生二互相生。彼便救云。本生生时能生生故。引喻云。如灯能自照亦能照于彼。生法亦如是。自生亦生彼。论主破云。灯中自无闇住处。亦无闇破闇乃名照。无闇则无照。意云明中无闇。闇中无明。明既无闇。为何所破彼便救云。具足之灯无闇可破。初生之灯明体未全。则有闇破故。复破云。云何灯生时而能破于闇。此灯初生时不能及于闇。意云初生名半生半未生。未生之半此半无明。亦不能破已生之半此半无闇亦无所破。彼便救云。何用及闇但使能破故。复破云。灯若不及闇而能破闇者。灯在于此间应破一切闇。又反并云。若灯能自照。亦能照于彼。闇亦能自闇亦能闇于彼。释曰。今闇不能闇于彼。明知是灯不能破闇。由依此义故。上疏云虽则相倾。意云而明闇理别明能破闇。闇不破明。故涅槃第二十九亦同于此。以灯不破闇。喻上毗钵舍那不破烦恼。疏若此宗下。第三辩此宗大意。如前总中及下相续中。文略有四。一总标。二上明非先后下显正义。三由能断无性下。双明能所即空而断。四若定有下。以邪显正疏言相续下释第二章。疏文分四。一总彰体相。二辩三时不同。三依论正释。四结弹古义。今初但就一智自有二种三时。疏就此三时下。二辩三时不同。二种三时前三时长如下大品之文。发心为初。修行为中。将成佛为后。后三时为短。谓唯无间道。然无间之言通于诸位。今且取见道为初。金刚为后。各有三时。疏论云此智尽漏下。第三依论正释文。中分三。初顺释无断义。次明不断断义。后结成正义。今初先引论后此上下疏释疏若尔三时无断下。二明不断断义。于中二先举论文。后此举喻释成。下疏解经论此中亦有古义至下结弹中明。今但直就性相无碍以解正义。于中二。一释论。二引证。今初言经文正显证智者。此中义大是不可说故。唯显甚深。论主若不性相双明岂知是断惑义。疏故大品云下。第二引证证成论主如灯焰义。然大品经具云。须菩提白佛言世尊菩萨为用初心得菩提。为用后心得菩提。初心不在后心。后心不在初心。心法不俱云何善根增益能得菩提。佛反问言。譬如然灯为用初焰燋炷。为用后焰燋炷。须菩提白佛言。世尊非初焰燋炷。亦非离初焰。后焰亦尔。佛问须菩提。炷为燋不。须菩提白佛言。实燋。佛合喻云。菩萨不用初心得菩提。亦不离初心。后心亦尔从初发意行般若具十地得菩提。经已分明。况论释云。佛以甚深因缘法答。所谓不但初心得。亦不离初心得。所以者何。若但初心得不以后心者。菩萨初发心便应是佛。若无初心云何有第二心第三心。以初心为根本因缘。亦不但后心亦不离后心者。是后心亦不离初心。若无初心则无后心。初心集种种无量功德。后心即具足故能断烦恼习。得无上菩提。合喻准法。此中灯喻菩萨道炷喻无明等烦恼焰。如初地相应智慧。乃至金刚三昧相应智慧燋。喻无明等烦恼燋。亦非初心智焰。亦非后心智焰。而无明等燋。成无上道。彼既云非初不离初等。则非唯但取相续之义故。故论云甚深因缘。又彼经中法喻影略。法说得菩提。喻说断烦恼。二义相成同故引证。疏涅槃二十九等者。然涅槃云念念灭者即是空义。由念念灭是无性故。不同小乘何以得知。彼经初师子吼问云。众生五阴空无所有。谁有受教修集道者。佛便以此经答云。虽念念灭而有修道。明知念念灭即是空故。义符今论性相双明。疏上诸经论皆显性相无碍无断之断下三结成正义。于中此上疏文结前。又今经论下。重结正义。谓非唯无碍。而又相成。前则事不碍理。理不碍事。性相双存。今则依理成事。事能显理。亦含双夺疏因缘故无性等者。即中论云。若法从缘生是则无自性。若无自性者。云何有是法即缘生故空义也。次云无性故因缘者。即中论云。以有空义故一切法得成。即无性故有义也。疏若云初念则能断后念方究竟下。第四结弹古义。即远公解。前解经云治必阶渐非定始终。故云非初亦非中后。正论其果断在穷终。不得说言非初中后。今乃据果反谈昔因。因时不顿是故说言非初中后。下释论言非初智断亦非中后。云非初智独断。中后亦然。通取三时方能尽结。次释论。若尔云何断如灯焰非初中后。前中后取。不异毗昙一念有烧始终方尽治结同然。若依成实一念不烧相续方然。治结亦尔。若依大乘慧心明胜一念能断。但相续始终方尽究竟故。经说言念念具足一切助道。于一念中尚能具足一切道品。何有不能断除烦恼。但相续始终方尽究竟。是故今说前中后取。如义正知名之为取。释曰。此公虽明大乘慧胜。要明具足三时始终方断。故疏不依但依前为正义。约性相无碍。释云今依其义开为两关难令同彼毗昙成实。谓应问言。为初念即断。后念方究竟耶。为初念不断积至后念方能断耶。依初则同毗昙。依后则同成实。一念具足道品何所证耶。又但成于断惑之义。不知断而不断。不断烦恼入涅槃义。故结弹云莫失宗旨

大方广佛华严经随疏演义钞卷第五十六大方广佛华严经随疏演义钞卷第五十七

        唐清凉山大华严寺沙门澄观述

疏。上犹通实教下。第三结示圆融。如常可了。于中二。先正结圆融。后若具显下。指广从略。广如五教义分齐中。即是别章上已略辩。谓结弹同毗昙成实。即小乘断结义。引唯识文及具三时即初教义。正约性相无碍即实教义第五结成圆融中。正显圆教义。于无断无不断中兼顿教义。谓若无断者。一切契理故。无不断者。一断一切断故即圆教义。若云尚无有断何有无断。性本寂寥言亡虑绝说为断者。即顿教义。疏三句明三德者。即前体德圆备是涅槃之相。若别说者。法身是体。般若解脱是德。若通相说三皆。称德合为涅槃之体。故云三德涅槃。即对前解脱于诸趣。诸趣有三杂染。般若对烦恼。解脱对业系。法身对生苦。翻三杂染成三德涅槃。释此三德。疏文有三。先别释。后总结。疏初句即般若者。指经辩德。即非言辞所及也。言是观行相者。依论立名。然论无观行之言。依下结中云如是观故。立其名耳。疏无分别观下。取论意释。而论具云如是解脱。可同他音声观耶不也。云何观偈言非言辞所说离语言故。此论有三节。初反问辩非二云何观下顺问彰是三离语言故者。释是异非。今疏文有二。先取意正释。于中先辩。是后不同下拣非。后前云观智下拣滥。前即涅槃平等住。前云一等二际是观智相。谓以智决了生死涅槃二平等理。今即三德中般若。以行契实。余如前会。疏次句法身转依相等者。法身是举德异前般若是转依相依论立名。转是回转。先是无常。今皆常故转亦离义。离于无常惑业等故。疏谓转无常依下。以论意释。然唯识中转依有四。一能转道此复有二。一能伏道。谓伏二障随眠势力不令引起二障现行。此通有漏无漏二道加行根本后得三智。随其所应渐顿伏彼释曰六行伏惑是曰有漏加行渐伏。根本后得能顿伏故。论曰二能断道。谓能永断二障随眠。此道定非有漏加行。释曰。二道除有漏。三智除加行。论释除有漏有二义故。一有漏曾习相执所引。二未泯相故。论释除加行。云加行趣求所证。所引未成办故。释曰。取根本者根本正能断惑故。取后得者。后得虽不能断迷理随眠。而于安立非安立相。明了现前无倒证故。亦能永断迷事随眠。论云。二所转依此亦有二。一持种依。谓即本识。由此能持染净法种。与染净法俱为所依。圣道转令舍染得净。余依他起虽亦是依。而不持种故此不说。二迷悟依谓即真如。由此能作迷悟根本。诸染净法依之得生。圣道转令舍染得净。余虽亦作迷悟法依。而非根本故此不说。三所转舍此复有二。一所断舍。谓二障种真无间道现在前时障治相违。彼便断灭永不成就说之为舍。彼种断故不复现行。妄执我法所执我法。不对妄情亦说为舍。由此名舍遍计所执。释曰。实我实法自性本无。但对妄情妄似于有。今妄情断无境对心。假说此境亦名为断。由此道理名舍所执。诸有处言断遍计者义在于此。论云。二所弃舍。谓除有漏劣无漏种。金刚喻定现在前时。引极圆明纯净本识。非彼依故皆永弃舍。舍彼种已现有漏法及劣无漏毕竟不生。既永不生亦说为舍。由此名舍生死劣法。释曰。余有漏者。即二障余有漏善法。劣无漏种者。即十地中所生现行。圆谓圆满。明谓行相分明。异于菩萨未圆明故。此净八识非余有漏劣无漏依故皆弃舍。此则总释下。有二师义。一云此之有漏及劣无漏。与二障种一时而舍。由二障种有此二故。第二师云。无间道中断二障种。解脱道中方舍此二。由无间道尚是菩萨。犹有生死有所熏识未即是佛。是故皆用解脱道舍。论四所转得此复有二。一所显得。谓大涅槃虽此本来自性清净。而由客尘覆令不显。真圣道生断彼障故。令其相显得名涅槃。二所生得。谓大菩提。然论释涅槃有其四种。一自性清净。二有余依。三无余依。四无住处。论释菩提亦有四种。即是四智。至出现品当广会释。上所引论文已略具今当会疏。然本论释此文有四段。一反问辩非。论云。可如世间智依世间耶不也。二顺问彰是。论云。云何依。偈言出过于三世。三释是异非。论云。转依止依止常身故非如无常意识智。依止无常因缘法。四引经证成。论云。如修多罗中决定说。上具引论科释已竟。疏文之中亦有四节。而有开合。合初二为一。开三为二三。今初合论前二段取意略释。故云谓转无常依云出过三世。二从故此微智依常法身。即论释是。三论云非如下。即论异非上二开论。释是异非为二。四释论引证三中异非非即因中。于中二。先牒论。后此拣未转依时下。疏释论于中二。先总标。后无常意识下。解释。先释未转依时后释今为所转依。今初持种本识是无常因者。即唯识所转依中持种依也。以此能持而为因者。亲是所熏成名言种。二所持染净种子等。是无常缘者。染净即有漏善恶业种等故。言依此因缘起无常意识者。依种起现行也。此即第八种现俱为所依。前七转识等皆为能依。唯识约能持种但取第八为所依。种子等并为能依耳。疏今转无常识下。释今为所转依。即唯识论云。圣道转令舍染得净。谓在因中双持染净。今得圣道舍染得净即名转依。故此转者亦是舍义。疏中先释能依智。后释所依。今初然四智之义已见第一经初。而此唯二者成唯识云。平等性智相应心品。菩萨见道初现前位。违二执故方得初起。妙观察智相应心品。法空观品菩萨见位方得初起。已得法空无漏智故。大圆镜智相应心品。有义金刚喻定无间道得。有义至解脱道乃得初起。异熟识种金刚喻定。现在前时犹未顿舍。与无间道不相违故。非障有漏劣无漏法。但与佛果定相违故。金刚喻定无所熏识。无漏不增应成佛故。释曰。此意正明舍异熟识。方始转名大圆镜智故。成所作智相应心品。有义菩萨修道位中。后得引故亦得初起。释曰。谓第六意识后得引故。于净土中起五识故。论有义成佛方得初起。以十地中依异熟识所变眼等非无漏故。有漏不共必俱同境。根发无漏识理不相应故。此二于境明昧有异。由斯此品要得成佛。依无漏根方容现起。而数间断作意起故。释曰。言不共者。即不共眼根。根唯为眼识等依故。言必俱者。是俱有依。根识同时故。言同境者。即同境依根识共同缘一境故。此三名异俱是五根。皆三依中俱有依摄。所依眼等既是有漏故不能发无漏识智。言此二于境有明昧者。二即是漏及与无漏。无漏即明。有漏识即昧。十地五识既是有漏故。至佛果方成所依。俱有依义广如问明品引。今疏意取成佛时得故。此不言疏依彼本识。如来藏性真如法身以为所依者。二释所依。言真如者。即前唯识为迷悟依。圣道转令舍染得净。然其真如即唯识性。故彼论云。此诸法胜义亦即是真如常如其性故即唯识实性。今即于本识之中依真如性。又法性宗识相识性互交彻故。然于一识有二种门。一真如门。二生灭门。于真如门法身即是真如门摄故。经云。真如平等无相身。若生灭门中。法身即名如言藏性。如来藏性即是本觉。故起信论云。所言觉义者。谓心体离念。离念相者等虚空界。无所不遍法界一相。即是如来平等法身。依此法身说名本觉。然真妄和合名阿赖耶。凡夫但从妄识熏种圣智去妄。虽则本识未舍异熟。而其二智唯依真如法身常理故。论云。转依止依止常身。故疏论云如修多罗下。第四释论引证。于中二。一牒论。二是了义故下。疏释于中亦二。此句出意由是了义故经定说。疏涅槃经下。引经文于中又二。先正引二通妨。今初即南经第三十五憍陈如品。尔时世尊告憍陈如。色是无常。因灭是色。获得解脱常住之色。受想行识亦是无常。因灭是识。获得解脱常住之识。彼经次说苦空不净亦复如是。故说如来五蕴常乐我净。言其文非一者。即涅槃经第二开宗显德即说常住。如玄谈中已广分别。此经上下其文非一。疏问所依本有下。二解妨。先问。后若依唯识下解释。于中又二。先依法相宗言非自性常者。自性则凝然常。此约法身。报身名相续常。即止能依亦说名常。三者化身名不断常。应用不断故。疏若起信下。二依法性宗先引论。谓本觉是法身。始觉是报身。既云始觉同本觉。无复始本之异名究竟觉则二常无别。生公亦云。真理自然悟亦冥符真既无差。悟岂容易不易之体。为湛然常照等并如前说。胜鬘经云。一切法常住者。若别说三身。如来妙色身世间无与等无比不思议是故今敬礼则说化身。如来色无尽智慧亦复然。即叹报身。一切法常住。即叹法身。是故我归依。总叹三身。既云一切法常住则上二身岂非常住。亦同法华世间相常住。世间尚犹常住三身岂得无常。疏三其相如虚空即解脱相者。先举经立名。二从不同声闻下。释显其相亦取论意耳。论亦有三。一反问辩非。云可同声闻缘觉智。有障解脱耶。不也。二顺问彰是云。云何解脱偈言其相如虚空。三释是异非。云无一切烦恼障碍故。释曰。烦恼即法华云离诸苦缚名得解脱是人于何而得解脱。但离虚妄名为解脱。其实未得一切解脱。未脱所知有三余故。今脱二障故不同彼。疏三德之义已见上文下。第三总结三德。于中二。先总结三德。第二别说转依前中总指云见上文者。即问明品。然下出现品复当广明也。疏然圆满在佛下。约位分别。即天台智者意。约圆教六即以明。一理即三德。谓一切众生平等共有即三杂染。烦恼即般若。结业即解脱。苦报即法身。迷成三杂染体即三德。二名字三德。谓于圆理。若因若果。解了分明。三观行三德。三德圆修。障无不寂。理无不照。寂照双流彻见心性。又一空一切空即是般若。一假一切假即是解脱。一中一切中即是法身。四相似三德。谓六根清净身如琉璃照法实相业系不羁。五分真三德。如初发心住得如来一身无量身说法智慧所作自在。六究竟三德。即是如来。今此即当分真三德。今云圆满在佛即究竟三德。十住开发即是分真。此中约因即言分得。亦分真也。从十住初心直至十地皆名分真故。所依果海即等究竟。疏转依亦尔下。二别会转依。即唯识第十释四转依之前。先云如是菩萨于十地中。勇猛修行十种胜行。断十种障证十真如。于二转依便能证得(二转依果即菩提涅槃)转依位别略有六种。一损势益能转。谓初二位由习胜解。及惭愧故。损本识中染种势力。益本识内净种功能。虽未断障种实证转依。而渐伏现行亦名为转。二通达转。谓通达位由见道力通达真如。断分别二障粗重。证得一分真实转依。三修习转。谓修习位由数修习十地行故。渐断俱生二障粗重。渐次证得真实转依。摄大乘中说通达转在真六地。有无相观通达真俗。间杂现前令真非真现不现。故说修习转在后四地。纯无相观长时现前。勇猛修习断除粗重。多令非真不显现故。释曰。通达真俗者。以有相观通俗无相观达真。言令真非真现不现者。入无相观真现非真不现。出观真不现入有相故非真现。言后四地多令非真不显现者。常在无相观故多不现。由杂烦恼未名清净。则非真犹现故有多言。论四果圆满转。谓究竟位由三大劫阿僧企耶。修习无边难行胜行。金刚喻定现在前时永断本来一切粗重。顿证佛果圆满转依。穷未来际利乐无尽。五下劣转。谓二乘位专求自利。一厌苦欣寂。二唯能通达生空真如。三断烦恼种。四证真择灭。五无胜堪能。六名下劣转。释曰。上有六义故称下劣。六广大转谓大乘位。为利生故趣大菩提。生死涅槃俱无欣厌。俱能通达二空真如。双断所知烦恼障种。顿证无上菩提涅槃。有胜堪能名广大转。此中意说广大转依舍二粗重而证得故。问曰。何以不取果圆满转。释云。对菩萨说是以不取。意明上皆约位不出后二大乘小乘。小乘不取故唯取第六。今疏文中但不取小乘。及损势益损势益能但是资粮加行今辩地故。疏此不同相由得前同下。第二总结会通。于中二。先结会同义。后论中下但结不同。今初应有问云。若解脱如空则本来无碍何异同相。故为此会同约体空。此约契空悟本无缚名真解脱。故云由得前同成斯不同。彼能成斯。斯能显彼。能所不一也。结不同中但结五句者。解脱是总于诸趣是脱处。故不结之。言谓如是观而观等者。谓应如是契实而观。莫作余不契之观。而云等者等取依止解脱。谓应如是依止于常。莫依无常应如是双离二障解脱。莫同声闻。言后三对妄显真者。一般若云。不同声闻依声而悟。二法身云非如无常意识智。依止无常因缘。三解脱云不同声闻。犹有智障故牒于真以结此三。令依于真不依于妄故。亦可后三即涅槃故。前二不离三故已如上说。论中此后会六相云如是说已。于中自体空是总。三种智空是别。释曰。此会同相。论又云解脱是总。五种解脱是别。释曰。此会同不同相也。但会总别同异成坏略可知故。疏第二一偈类地行微等者。然远公复云。后之三偈以佛果法类显地实。意云。前二涅槃是佛所行故难。言说类于地实亦难。说闻虽有此理前之四偈曾不说于佛果之相。但指涅槃菩萨得者。是佛所行之涅槃故。故今疏云以上地智。类显地行为甚微妙。故论释行云。谓是檀等非地实故。疏中二。先总科。后初中下牒释。释上半中三。初出偈意。次寂即同相下别释。三何不直说下。征释可知。释下半所类中五。一正释。二举论。三言境界观下。疏释论。四设地是体者拣滥。五将此地智下。重释论。四中正拣远公所类是其地实。以前论言地者。境界观。疏作加行观释故今纵之云。设令地是地实。境界观非是加行。是地实者。意取地实所起之行。非取地实。故论云行谓同行以其地实即是证智。同彼檀等差别行。故明知取行耳。疏第三一偈寄对彰微者。文中二。先总显意取对。即闻思慧。等取报生识也。后初句下随文牒释。四句三节中二合故。初句有三。一取意正释。言起即加行后得者。此二为能起。证智一字即是所起。二皆观如。如亦能起故云并为能起。二故论云下。以论释前加行后得之言。何观是加行何同行是后得。三此即前偈下。疏释论文。然论但牒问云何观等。而无别答。今疏即指偈之论释观及同行。从皆言何下。正示答相。即随地加行等起证智故。其论此智字前疏已释。疏后句明下。释第三句。言故法华中以说为门者。彼释诸佛智慧甚深无量。为证甚深。释其智慧门难解难入。为阿含甚深。阿含即教法。生公云。夫知智在说说则为门。非唯智不可解。门亦难了。了门则达三非。三非难解如何皆以说为门也。疏第四一偈喻者。疏文有四。一拣喻体。二随文解释。三结叹胜能。四对前拣异。今初一同前文风画之喻。疏论云下。二随文解释。于中二。先释喻相。后释合相。前中二。先举论后总显喻下。疏释此下更有论云。何以故虚空处鸟迹相。不可分别。故非无虚空行迹。今疏但义合影在合中。疏此中迹处下。释合相。于中二。一依论正释。二取意展合。前中三。初总合空迹。二何以不说下。合上不可说其长短大小等。三上明粗相下。合上非无。于中二。一正合非无。二又以空摄迹下。空迹互显非有非无。疏若欲开鸟下。第二取意展合。于中三。一展成三事加于鸟故。二若更开下。展为四事开空为二故。三若以迹喻证智下。例前以释。亦有四义。然向四者。一太空喻果海。二迹处之空喻证智十如。三空处之迹喻地相。四鸟喻言教。而迹不喻证智。今例风画。迹喻证智。则应云一太空喻果海。二迹处空喻十如。三空处迹喻证智。四鸟喻言教。地相皆教道故。言如风画中辩者。已上空中风画例同今迹故。然彼处本论但以风画喻阿含。所依之空喻证智。然其阿含约言教说。次下疏云。若将二喻喻所诠者。仍有两重。一以风画喻地相。所依空喻证智。二以风画喻地智。所依空喻果海。今正例第二意然。其风画三遍用之方成四事。一喻言教。二喻地相。三喻证智。兼所依空喻所证十如。四太空喻果海为四。然其风画离于空中风画无别风画。如鸟异迹故风画处空之画以喻地相。画喻能诠也。疏以斯鸟迹下。第三结叹胜能。疏此中鸟迹下。第四对前拣异。于中三。初引论征起。二论云下举论正答。三此意云下疏释论文于中二。先释二喻别意。后若以着心下。引论释取着之过。于中四。一正出五失。论主但有五名。疏中一句举名。如云一不正信一句。释论如云以其随言解不称实故。下四皆然。于中通有三节。一正出五失前二违行。次二违人。后一违法。二意令下。总显文意。三今人下。结弹异释。云言今人者非对古人。但谓如今有人耳。四故叹难说下出体。举五失之损翻成五德。故言五德者。一者正信。二者勇猛。三者正说。四者顺佛。五者重法。疏今初言三成就义者。疏文二。先彰名意。后方释文。前中四。初释名。二辩位。三就文辩定。四解妨难。今初亦二。先释名。后解妨。今初若粗相分别即闻思修慧为三。若细辩相修慧有二。真修为第三。缘修属第二。前二不似正证下。后解妨。兼释通名。谓有问言三种成就并非义大。何以第三独拣义耶。答意可知。从当分下。重复通难。谓有难云。若皆是因何名成就。释云。当分说成。非对因说以为成就。以获得释成就者俱舍云。得谓获成就。故即以此文便释通名。名三成就。疏此三地位下。第二辩位。远公名为约处以定。疏意云。十地皆有三种成就。初地三成前二在地前。余皆地上。故云初二容在地前。若远公意总有二意。一假寄处因。此有三义。一寄种性。种性种子成立。因成就大相顺彼故。二寄解行。解行起修。趣入出道。因渐成就。相顺彼故。三寄地上。地上德成就教说修者相顺彼故。二约实行处说大同疏意。以后义要当但为后解。疏问慈等闻等下。第三就文辩意。慈等等取悲愿力。闻等等取思及修。疏若尔上三渐次下。第四解妨。于中三。初蹑迹为问。二彼从所表下。正为会通。三故上论云下。引论证成在文易了。然此解妨即是远公对前辩异同。其问意云。此三成就何异三渐次。释云。初因成就非三渐次因。二其因渐成就是三渐次体。即前三中观渐次也。皆是闻思修故。三其教说修成就所有观修。是前三中证渐次。此说证智为观修故。其满足修是前三中修行渐次。渐说彼中真修所有教行为满足故。今之疏意并不用此。其因成就及因渐成就皆观渐次。以通诸地皆悉有三因成就即是地加行故。三种成就望于后地皆是加行。望于前地即是后得故。满足观修亦后得摄其证渐次但是深义。前七偈明为不可说故。此说分无证渐次故。今对前以通妨难。然其此义不合傍叙。恐后人不知疏意。故对辩之。疏已知大意下。第二释文。于中二。先结前生后。后因成就大即初二句下。正释初一可知。释第二成就中。言闻思等次第者。释渐字。从闻生思从思生修故云次第。从乃至能成就出世间智因故。者即释因字。前因成就是闻思修因。今云因者是出世智因。疏三圆满下。释第三成就。疏文有六。一标名总科。二释二修相。三总结示。四假喻明。五引例释。六正解文。初一可知。疏真修位极下。第二释二修之相。疏意可知。远公云。满足修者。即真实教道真心之体。随顺集起法界行德。故云满足修。下释论中云。真德之中教行满也。观修者即真实证道真心之体。本随妄隐。今隐对治离妄渐净。始净之心内照法界名为观修。下释论中云。真德之中证心明也。此公意以教为满足。以证为观修。今疏小异。满足则是教道之修。观修亦属教道。教中似证故称为观。则以能显为满足。所显为观修。以未息修不得名证。疏初即称性寂然下。第三结示。疏犹莹下。第四喻显然亦分喻。对前称性寂然即是全喻。对满足教道犹是分喻。但取二修同时。似正证义耳。疏此二种修下。第五例释。于中三。初举能例。二修如于下。次明所例。则二修如等觉。正证如妙觉。亦如七地修无功用未名无功。八地报行方得斯称。后诸有智下结劝。疏文中虑即下。第六释文。于中二。先依今经释。后依论经释。前中言心即真修心体者。谓所证心体恒沙性德唯是真智方能行故。疏若准论经下。第二依论经释。于中五。初总出论意。二故论经下引论。三此明闻思下释论。四次便引偈下重牒论。五此明函盖下结示。疏次观修者下。即经是境界难见可知不可说也。疏中有二。先正牒释。后既难可见下通妨。妨云。既难见闻何不义大中收。后而随修下会释。疏佛不随喜者亦名违法慢心。谓若自说不承佛力言多乖理。不顺圣心故佛不随喜。疏地法为所入者。即当经文如是二字。证智为能入者。论云。此所说地法众生以智入。疏若事若理无不具者。以所入如来藏中恒沙佛法此知理也。事者即因分之行解也。疏身正恭敬待等者。若别释者。形虔曰恭。心重为敬。然实恭敬通于身心。是故疏云心敬则身必恭。论云身正恭敬等。恭谓恭谨。敬谓敬重。由心恭敬则身恭敬。尚书云。恭者恪也。敬者恭也。故二大同。有释云。貌多心少曰恭。心多貌少曰敬。故从多分配于身心实即通也。心正恭者。敬善法故。若于邪法虽复恭敬而非正也。由恭敬故便决定求。即此求心亦名敬相。待有二义。一者停待待我当说故。二者当待当者对也。将恭敬心当对我说。疏无谄无憍慢者。谓胜我者则谄其心必下。劣我者憍慢其心必高心无高下故不谄慢。易云。上交不谄。下交不黩。辩必然之理不改其志操亦斯义也。疏次二句对法彰已善说等者。疏文有三。初科经。二文虽三节下解义。三云何相应下随难别解。二中然论一时总征云。一示现何事。二以何事。三云何事。四依止何事。次重牒其问以对经文。更无别释。今疏取意便牒。便释四重。释中初重有二。先问所谓下。答即果分地法为所显示。故云胜上地法。下之三段文皆有四。一义释问意。二故论云以何事即引论证。三答云下义释答意。四故经云微妙音者。引经证成。斯则经答伏难。论假问起。疏先释义后方引文。此释第二下三句例知疏为依出世善字者。妙音是声善字是名句文。文即是字为名句依故。但云字则四法备矣。上风画喻中云说者以此二事说。听者以此二事听。疏一随方言音等者。随诸方土梵汉等异。二字句等即教与理相应。疏又与能诠等者。上明说人与教相应。复与理相应。理即所诠。今明但称能诠。居然合理。若乖能诠即违理故。三事即声字譬。疏第三示说分齐下。疏文分四。一标大意。二半偈之中下。对经会论。三于中上句下牒经解释。四然因果二分下。释因果义。于中二初总辩顺违。后申正义。前言古有多释者。有云。十地有二义。一约教所安立。十地法门在闻者识上。以义显现名为因分。因此表离言之义故。二者正诠十地证入。十地正行离诸言教。所安立相说名果分。由此因分言所表故。是故因分可说。果分不可说。释曰。此释理似可通。而因分义成果义不显。又似影像教则可说。本质教则不可说。有云。于一证智不坏相边。可言说故名为因分。相即无相言教不及边名为果分。故此二分非一非异。释曰。此解则似下文不说无相。又唯约一证论说不说。教行不言故。又说与不说纵许得成因果不显故疏并略之。疏直望论意下。第二申正义。于中二。先总彰大旨。后更以义取下。开章别明。于中二。一唯约十地。二通佛因果。前中有总有别。别中诠表相对。文有四节。一正释义。二如初三地下指文。三令众因此下。释因果名。四斯皆证智下。明说不说门。疏二约究竟佛果下。通第二佛因果。文中三。初正明。二解妨。三拂迹显玄。初中亦三。一总指。二谓即此下显相。三是则迹处下辩可说不可说。果海绝言易故不明。疏问上论云下。第二解妨。先问即刊定记主难师。后岂不下答。答中即今疏扶昔大义。于中二。一总呵既冥同果海岂非地摄有能所同因果非一。既曰冥同则因果非异。非一非异为真地智。二故上论云下引证。略引三文。一即示说分齐中。释成寂灭佛所行偈。二又上加分即加所为中。自利总句经云。欲令汝为一切菩萨。说不思议诸佛法光明故。论释云。不思议诸佛法者。是出世间道品。明知地智即是佛果法。三引地影像。经证中曲分为五。初正引。二是知论主下结示。三有云下刊定重难。四大海十德下疏引喻反质。五明知下结破。疏又且依一相下。第三拂迹入玄。如前二大说分齐竟。第七说分。疏又请分生其正解等者。上一来意约法以明此之一意。就益以辩。又前约相实相对。此约解行故二不同。疏二释名下。疏文分四。初一正释。二以上请分下。通违妨论云。初地所摄有八分。说分属初那言通十故为此通。疏又初地下。三通展转难。谓有问云。既言初受总名。何以更立校量胜分故为此通。四又论家下。总相会释余如品初。疏此有三义。一得位等者。诸解虽众唯识委具故先引之。谓既断异生之性。便获圣人之性。以成圣位下。二拣异二乘。二拣唯证生空。三拣唯能自利对于二空故云具证。然准摄论二利亦云初得。则以初冠下三皆初得。疏此唯依第三成行义说者。于自利中亦摄初二在文不显故云一义。疏出世间心即是圣位者。亦含二空故能出世。亦以文不显故属一义耳。疏三所断障等者。于中三。初总标。二谓二障下明断障。三明断愚。二中先举唯识释。后此言异生下引梁论辩。前中意明。依分别障种立异生性障。分别拣于俱生种拣现起。分别之言此言犹漫。而本论云。凡夫我相障。知是我执故。下二愚名执着我法愚。彼论释云。虽初地所断实通二障而异生性障意取所知。说十无明非染污行。疏上来就能起下三释断二愚。文中三。初以义生起。二由斯初地下引论正释。三断义如前。下结示断义。二中言断二愚。即是现行及彼粗重者。彼论释云。显彼二种。次文释云。或二所起无堪任性。如入二空说断苦根。所断苦根虽非现种而名粗重。此亦应然。彼粗重言例亦应释。疏四所证理等者。文中有五。初对前生起。以断障证如义相顺故。由前在凡二我之执不见二空。若证二空彼障随断。故斯断证二义相成。二谓此真如下引唯识释。三梁摄下会其异名。四意明下双释二论。谓一切法本是二空。故云遍满等。非别有如来遍诸法。五此地最初偏证遍满者。为遮伏难。谓有难言。下之九如岂不遍耶。岂复非是二空所显故。为此通意明遍行之如。是如总相下之九如。随德别立。今当初得得于总相以受别名。疏二约所成者。大愿昔发至于初地。能如愿作故称所成。复名为行。疏信等十者。即净治地法文在行校量中。一信。二悲。三慈。四舍。五无有疲厌。六知诸经论。七善解世法。八惭愧庄严。九具坚固力。十供养诸佛依教修行。疏然上诸下第二总相圆融。于中四义。对于三四五六。四门来意一门但明次第不离下六释名。通从三四五六得果。一种非正地法。故但对四。疏第七释文。文前更三。一依经科。二依论科。三对前相摄。今初亦三。初正科二。故慈氏下引证。先引瑜伽。二引仁王。仁王即观如来品。文云。般若空故菩萨亦空。何以故。于十地中地地已上文如疏引。三而论下会今论文。疏今且依论下二依论科分二。先正科。后初云住下疏释论。其释名分。最后释者。义通始终。故疏然十地中。既三心齐证。下第三对前相摄。疏今初住分下释疏文有四。初一曲科。二初谓深种善根下疏释。三瑜伽下引证。彼云。菩萨发心因四行相。一者何相发心。二者何缘发心。三者何状自性。四起何胜利。即此四段也。四又此四下会三菩提心。即起信意。前十住品已广分别言。又此四段各含三心者。向就增胜各配其一。一者深心即乐修一切善行故配依何身深种善根。今有集白净法。即是直心。慈悲现前即大悲心。二直心正念真如法故配为何义以求佛智。同念真如故。今有救一切世间等。即是悲心。为净一切佛刹。即是深心。三大悲心。救护一切苦众生故。故配以何因大悲为首。今有智慧增上故有直心。善巧方便所摄故有深心。四有何相总。则具上三心故得入位。今别说者。生如来家是直心相。得菩萨法即大悲相。住菩萨处即深心相。余可例知。疏别有九种集。下疏文有三。初别释二。然小乘下随难料拣。三已知总别下六相圆融。今初先科后释。释中前二皆言眷属者。慧为正道。戒定助道。故疏谓依闻思彼若明若义等者。以前之五集明四善根古来诸德皆云权教。似小拟议立四。华严即无。然华严正约四十二位。文无彰灼。四善根名论无释文义旨含有。是约五位收摄之义。且十地皆有十句加行。起十种心。此心未满犹属初地。满成二地。二地加行十心未满。属于二地。满属三地。下七皆然。未知初地亦起十心。十心已满即入初地。未满属何。例于下九即在地前回向会竟。既非回向。当属何人。为加行位理极成矣。又上深种善根之人。地持判属胜解行人。有如是心。即入初地。明知未具是地前也。彼依四位明义。初一即胜解行人。始从十信终至地前。余三即是见修究竟同于唯识。又依十二住。亦以地前为第二胜解行住三即极喜。明知加行胜解行摄。然判地位总有十门。广如十住。今约五位。初地加行属加行摄。况论释十句。前五约闻思修等。第六方名净心集者前为加行。文理更明。虽局初地而以地前望于地上。即为十地之加行也。故于十地总有三处。总集方便。谓初地。八地及与十地。然初地方便复有二种。一收三贤。皆为趣地之远方便。二者取四加行。为近方便。三贤别会已广说竟。今为加行于理无违。复有人言。此中十句唯属初地。四加行位总属十地。斯人不晓。唯识论文云。为入见道复修加行。明知即是初地加行。故四加行义通于总别。勿复粗心。言四加行者。唯识第九偈云。现前立少物。谓是唯识性。以有所得故。非实住唯识。论曰。菩萨先于初无数劫。善备福德智慧资粮。顺解脱分既圆满已。为入见道住唯识性。复修加行伏除二取。谓暖顶忍世第一法。此四总名顺决择分。顺趣真实决择分故。近见道故。立加行名。非前资粮无加行义。释曰。决择是智。即择法也。决拣疑品择拣见品。疑品择而不决。以犹豫故。见品决而不择。非正见故。今此具二决择即分论暖等四法依四寻思四如实智初后位立标也。四寻思者。寻思名义。自性差别假有实无。释四寻思也。如实遍知此四离识及识非有。名如实智。何故名义各别寻求名义自性及与差别。即合观察问也。名义相异故。别寻求二。二相同故合思察。次论别释四相文云。依明得定发下寻思观无所取。立为暖位。此位中创观所取名等四法。皆自心变假施设有实不可得。初获慧日前行相故。立明得名。即此所获道火前相。故亦名暖。释曰。明得是定。寻思是慧。故云发也。下发皆然。次论云。依明增定发上品寻思。观无所取。立为顶位。谓此位中重观所取名等四法。皆自心变假施设有。实不可得。明相转盛故名明增。寻思位极故复名顶。次论云。依印顺定发下品如实智。于无所取决定印持。无能取中亦顺乐忍。既无实境离能取识。宁有实识离所取境所取能取。相待立故。印顺忍时。总立为忍。印前顺后立印顺名。忍境识空故亦名忍。释曰。忍有三品。下品名印忍印所取无故。中品名乐顺。乐无能取。顺修彼故。上忍名印顺。印能取无。顺观彼故。故论云。印顺忍时总立名忍。印顺俱定名印顺定。忍即智也。次论云。依无间定发上品如实智。印二取空。立世第一法。谓前上忍唯印能取空。今世第一法二空双。即从此无间必入见道故。立无间名。异生法中此最胜故。名世第一法。下论总释云。如是暖顶依能取识观所取空。下忍起时印境空相。中忍转位于能取识如境是空。顺乐忍可。上忍起位印能取空。立世第一法。双印空相。皆带相故未能证实。故说菩萨此四位中。犹于现前安立少物。谓是唯识真胜义性。以彼空有二相未除带相观心有所得故。非实安住真唯识理。彼相灭已方实安住。依如是义故有颂云。菩萨于定位。观影唯是心。义想既灭除审观唯自想。如是住内心。知所取非有。次能取亦无。后触无所得。释曰。此偈初二句暖位。次二句顶位。次二句下忍位。第七句中忍。合前三句为上忍位。其世第一住时促故。此偈略无。末句见位。但观上来唯识论文。四五二集释然自解。疏言治诸蔽漏者。按唯识论。但是伏位。故次论云。此加行位未遣相缚。于粗重缚亦未能断。唯能伏除分别二取。违见道故。于俱生者。及二随眠有漏观心有所得故。有分别故。未全伏除。全未能灭。释曰。今约伏故云白净耳。又上疏言欲集闻慧及思慧等者。彼论次云。此位菩萨于安立谛非安立谛。俱学观察。为引当来二种见故。及伏分别二种障故。非安立谛是正所观。非如二乘唯观安立。释曰。上皆闻思也。又上疏云定谓四禅者。彼论次云。菩萨起此暖等善根。虽方便时通诸静虑。而依第四方得成满。托最胜依入见道故。唯依欲界善趣身起。余趣厌心非殊胜故。次论云。此位亦是解行地摄。未证唯识真胜义故。释曰。即顺摄论。唯四位义也。疏六净心集即善净深心者。上牒名指经。从以得出世正智。即是论释从于所缘下疏释经。前加请分皆已广明。疏七广集者。明护小乘发意旷兼。故名广心。起心殷重故名为深。信解大因求大果故名为大心。慈悲现前。疏释论名。谓多行下即是论释。疏然小乘下第二随难料拣。即是后三。应有问言。何以护心双约二利。护行唯约利他。故为此通。又约自利多同前六。故疏中慈依苦苦等者。然其慈悲略有三义。一别。慈能与乐悲能拔苦。二通。故三地中释慈心广大无量云。广者与欲界乐。大者与色无色界同喜乐。无量者与不同喜乐。经文后三无量例同于慈。更不见释义。当同与乐也。又彼地中依苦众生故入慈悲无量。即慈亦拔苦。今此则二皆拔苦。慈心粗拔二苦。悲心细拔行苦。疏中文二。先顺论总明拔苦。后又明与乐下显二通义可知。疏总云佛智等者。上句举经。谓无上智。即论总指其体。知断证修故。论别显其相。谓知苦断集。证灭修道。苦是报法不可言断。但可言知以令生厌。集则可断。灭是理法但可云证。道是心法可以进修。言约无作四谛者。此疏释论拣非权小。如四谛品言修究竟故者。释妨。恐有问言。既是佛智何得有修。通意可知。疏此智差别下别中九句。一问记业。记即答也。二拣异菩萨者。皆穷尽故。三中平等。有其二义。一二无我理生佛平等。二令众生平等皆证。五中救摄因者。由慈净嗔。能用四摄。广利乐故。从第六无余智下四句经文约五无量界。谓六即众生界无量。七即世界。八即法界。及调伏众生界。九即调伏加行界。如文可知。六中言佛眼观众生者。四眼九眼入于佛眼。皆名佛眼。无余亦有二义。一遍观众生尽无尽故。二以十眼委照性相心行等故。七中言论经阙于净刹者。论云。七无染佛智。一切世间无障无染。自然应化。今信作业智心无碍。如经得一切世界无障净智故。释曰。经无净刹释有净义。即净刹无染心解脱故。化往无障。慧解脱故。今经亦令众生但生信乐而无染着。八中穷尽心行方善调故。九中初举论。法轮即是下疏以经文会论所释

疏。二总结发心中疏文有四。一略释。二而论下辩论释。三前指于此下辩论指文不同前。即指此结文。欲以后摄于前。此则指前总句。欲明以前摄后。总之与结皆是总义故。结云总摄别故。四又但云生心者。释通妨难论有二问二答疏亦两节。一问云。前求佛智。何故唯云生如是心。不云生智。故今答云心是总故已摄于智。知断证修二亦摄。下亦有问言。别有诸德。何故但云生如是心。答云心亦是总总摄诸德。故不别举助道等法。亦应问言。心既是总摄于知断证修。何故前文不求佛心。有二义故。一前是所求。此是能求。故二果位智强心不可知故。疏明以何因生如是心者。此是论文。此中疏文问意梢略。应云第三以大悲下明以何因。次应更云。谓以何因生如是心。今以先科文便释意耳。从意云下疏释论文。引于二经。成立论意

大方广佛华严经随疏演义钞卷第五十七大方广佛华严经随疏演义钞卷第五十八

        唐清凉山大华严寺沙门澄观述

疏。十句文下释文不释总句者。有二意。一以下别成总义故。二者前生起中已显意故。谓菩提心依于大悲为根本故。亦即瑜伽四因之中。大悲因也。疏一增上。大疏文有八。一标名。即经智慧增上智导前悲所以先辨。二细行苦下论释名。细智现前故名为生。三谓若了下疏反释论。四文论释智慧。别释二字。皆先举论。此约下疏释。五复是一门下双结智慧。以智慧名有通有别。通谓分别名慧。决断名智。此义虽别而通事理二。别有二义。一了事名智。如第十度。了理名慧如第六度。二者如今疏文。六自相下牒论解释。七念生下出经论意。不知三界皆苦及苦性相故。八其逆顺下指难。在下二善巧等者等取方便所摄也。四摄释所摄。曲巧释善巧。随宜释方便巧用四摄。随物所宜故。疏三最上下。下取深心所持从。谓向发下是论自释。然论经云。直心深心淳至故。论意以深直是别淳至是总。故标为名。谓深则悲行深重。直则正念真如。悲智相资能尽生界。故云淳至。淳至即最上。然经深心有其二义。一以乐修善行为深。深即重义二契理为深。深即直心故。第二地初有十深心。论经名直则知深心已摄直心。疏四无量大下。此下四大皆明胜进。此谓虽摄佛智亦为利生。疏五善观等者等取下经。具云善观察分别勇猛力智力无碍智现前。论经云善决定众生力智力。论云五者。决定大上妙决定信深智胜对治。今疏开经成三决定。复以无碍智该于上三。即展演经论。六中有名无释。论释云。随顺菩提正觉。即佛自然智。前疏频有故略不释。七中先举论。后大包下疏释就经第四有何相。疏以得出世间圣道故者。圣道是福利正体故。论为总。别有八种过。疏文有三。初依总开别。二入位过下随别解释。三总结不相似。二中前七自分后一胜进。一入位过中先举论。后瑜伽下引证。正性离生是出世义。谓如世人下上即论文。此下疏释。所证即是真如故。摄论云。真如为家。契会为生。前约入位。此约入证下引梁论明生家亦胜。疏子相似法大乘行生故者。上即论文。谓大行下疏释大行。即助道行也。疏道过经有二句。前一句拣异地前。下句明是地上。喻拣可知。引梁论。杀生等即世间道。道即因故。论云。四者道过。世间道不摄。出世间道摄故。异生道相似法故者。谓世间不摄是初句。出世间摄故是下句。异生道相似法者。喻谓人道异于三恶之道。疏中喻文义已分明。五法体过。初至自事。皆是论文。论下云自身体相似法从。若无大悲下疏释论意。义已明显。六论云六者处过。不舍世间方便。不染善巧住故。处相似法。会疏可知。七业过。论云顺空圣智生命相似法故。八毕定过者。大心坚固名为毕定。论云。佛种不断究竟涅槃道。成就相似法故。会疏就经文并可知。疏论云。如是示现下第三总结不相似显成过义。先举论从显与地前下疏释。然论此下更云。如是次第。家不相似。种性不相似。道不相似。体不相似。处不相似。生业不相似。成就不相似。如是说住此地中。是名为住。如次经云菩萨住如是法。名住菩萨欢喜地。以不动相应故。释曰。此论次第别结皆有不相似言。则知十句不似地前。从如是说下释于结文。乍观此论。则似唯取第四段为住如是法。以揽前三成斯相故。故全收四以总该别。皆有烦恼无烦恼异。释名分此中论有生起云。已说住义。次说释名。云何多欢喜示名欢喜(此问得名)以何欢喜(此问喜相为身为心下答具二)此地中菩萨欢喜。复以何念(此问喜因)初说十句(此答喜相)后说二十句(此答喜因)释曰。上论疏已摘用故不并举。恐寻论者怪不见文。故此具出。疏总有三喜者。论主但云欢喜者。名为心喜体喜根喜。疏便开释。但直下彰名据其体性。即是下九此是论主摄别入总。谓下九中前六。自利喜行之体。后三化他显于喜能。前中初二敬之与爱。是喜行心。非正喜体。今摄入总名为心喜。次三正是喜心之体。摄之入总名为体喜。后一明其喜行功能。出生之义说以为根。摄之入总名为根喜。备此三喜故名多喜。今虽直释。至下别中结归此三。言三根喜。由前心体欢喜内充者。心即初一。体即第二。二皆为内。然五受明义。在五根为乐。在意地为喜。二禅心喜亦名为乐。此地身乐亦名为喜就通义故。轻安之言即是善数。亦轻安乐。调畅之言即是受乐所以结云故此喜者亦名为乐。疏又内及观心下。重会前三拣异凡小。观心是初内通前二。谓双证二空离忧喜相。名为无喜。冥契寂静唯证能知。故云之喜。二禅喜相。三地当知。疏一敬喜别九喜中。已如总中之科下。疏便结之。今初尊敬三宝名为敬喜。由证同体信不可坏恭敬转增。然总具下九故名为多。当句言多复有何义。遍敬三宝即是多义。余可类取。疏上二即喜行下结成总中心喜。次三即喜之体相者。即总中体喜。疏前觉后悦义甚。次第者。论经先庆喜。但心自觉胜于地前。次调柔喜离诸矿强。是故身心悉皆适悦。后踊跃者。遍益逾前故名踊跃。是为三句。作初中后之次第也。疏此一喜能者。喜行成就能摄菩提。故名为能。此与念当得喜有何异耶。答念当逆念当果。此念念之自能。故不同也。疏下三化他。即口身意离三业障。故下论云斗诤于言中等。论义通于自他。问此等解释唯约自行。又此三句。初句自他无扰。次句不恼于他。后句不为他恼。疏今初。初句总下疏有三门。一总别分别。二若别显义相下义类分别。三又上十句。初佛下三宝分别。二中因果人法。即有四门。疏且分二。先果后因。疏于中更有总别者。此中之总望前为别。望后为总。即亦总亦别。疏别中六句次第显前菩萨行。则以六句为能显。菩萨行为所显。以别显总故。即显示之义。于六句中自有能所。初一行体为所显。余五句能显。亦是别明显相。此则显理之教义。其次第之言两向用之。初一佛次法后菩萨。今菩萨行等故为次第。二于后六句初体。后显六句次第。疏余三利他皆法云之行者。故论释菩萨地尽竟便云此中余者。约教化法故等。则显余三。是菩萨地尽中事也。疏亦可后三下。然论云此中余者。故疏配在菩萨地尽中。然无显文。故兼显通诸地意。疏转离一切凡夫取着事故者。此即论文上即指经。下即疏释。疏别中有三。初通叙文意。二九中下随文别释。三然此九句下结定。疏总别九句文虽不次者。初即第二生如来家过。二即总句超凡夫地。三即第一入菩萨位入位过。四即第四离世间趣得道过五即第五得菩萨法法体过。六即第三无能说其种姓过失种姓过。七即第六住菩萨处处过。八即第七入三世平等是业过。九即第八于如来种中决定当得无上菩提。名毕定过。余八全同。唯第九舍转离相文小不同。故疏会释。疏文分三。初正释舍转离二即前第八下会通前文。此断前行故须会释。谓前明者。志气成立决成菩提。于如来种中即是行义。行断虽殊决成菩提义则同矣。三言怖畏下释文。于中先举论。不爱是所畏下疏释。疏今初征意。云何以此中说离畏耶者。谓得初地远离一切烦恼业苦。何以偏言离怖畏耶。二答疏有二意。一以五怖偏障初地初地尽断所以偏说余障通障诸地。初地不尽。是以不说。如十使中五见及疑尽在见位偏说断之。贪嗔痴慢通障见修。此中不尽二畏是喜障故偏说之。故于释名分中说耳。疏故论上云远离此因者。以是经前生起之论。故云上也。论文具云。次说何者是怖畏。云何怖畏因。远离此因无怖畏故。释曰。论中怖畏有问无答。经中离畏有答无问。故疏具出。疏四举因显相下疏文有二。先释经文意后五怖畏下开义别释。不次第释经。而取义类以释。于中分二。先总彰五畏之果。后彰五畏之因。及明离义。前中但拣滥相。即为释文。于中三。初拣死不活。二死约爱于善道下拣死恶道。此因上第三第四依身故。为此拣上三有滥。所以拣之。恶名学易德故不释。三但说五者下通妨辨摄。谓有问言。怖畏多种。谓打缚等岂不畏耶。何但说五。故为此通。则五无不摄。如打缚等。即不活死畏所摄等。疏此怖畏因略有二种下。第二彰怖畏因及明离义。文中三。初引论总明。二分别解释。三总以结示。今初观下释文二因自显。疏然此二因下分别解释。于中二。先通后别。别从相显。通约义兼。故明通中即别所拣。谓善根微少别为后二之因。今通为前三之因。不活等者等取死及恶名邪智爱着。别是前三之因。今通为后二之因。畏大众等。等取恶道。疏若取相显下二别配。于中三。初双标。二邪智。即是下释初因。于中四。一牒释论文。二爱着于我下别配三因。三无我我所下彰离。四然不活下会释经文。疏后二因下三释后因。文中二。先因。后今具福下辨离。疏故初三离下等三总以结示。疏结酬初征中三。初释经意。二叙论。三意谓下释论第三安住分。疏所列谛宝等境者。谛即实事理。宝即三宝等。等取世出世善之功能皆所信境。疏信增成欲。欲即信果。疏一敬信。即于德信也。二净信。即于宝信也。离疑浊故名净。即经解清净句。疏上二皆云清净是信之性者。上皆唯识并如前所引。疏三决定信增上。即经信决定故。今取经为名准论云。以信分别故。便名分别信增上。令他证净智故。故令疏以分别字为其释文。疏此三增上下通释。然今经云发起悲愍。故论经云起悲愍心。论释云。起者。转复现前。谓地前修习入地。即现今在地中。云转复现。疏七惭愧信增上是所成行体者。故论云乐修何等行波罗蜜行故以崇重贤善为惭。故成檀等诸度。轻拒暴恶为愧。故治于悭等诸蔽。轻拒暴恶。即不着世间。无恶有善。故曰庄严。故遗教经云。以惭愧服而自庄严。八是得等侣。亦即行缘论云。僧为等侣同事安乐。九者敬法。即行所依论云入何法中谓诸佛教。则亦行所诣。是所入故。疏第二日夜修行中有二。先依论释。后随要别释。前中一亲近集。又是求法方便。二正闻法时直咨为问。直酬为答。设难为论义通难为解释。疏后五句次第修行者。五句即为次第。又先明内观。后辨随缘亦是次第。疏又难得下举世宝六义。显证法六义。一地前所无故云难得。二已断分别故云无垢。三能为二利故云势力。四能严法身故曰庄严。五等同法界故云殊胜。六一得不失故云不改。亦与六决定义同。疏其第六七下。第二随要别释言此中能治即大人觉者。文中具有。但远离一种摄于二事。一摄寂静。二摄无戏论。此二俱治不远离故。言八觉者。一少欲。二知足。三寂静。四精进力。五正意(即正念是)六正定。七正慧。八无戏论。疏八种不净是谓资生者。即涅槃第六邪正品。经文广列而不分数。疏案善生优婆塞经具列。一畜田宅。二种植根栽。三贮聚谷粟居店求利。四畜奴婢人民。五畜眷属群畜。六畜金银钱宝。七畜象牙金银刻镂诸宝大床绵褥氍氀。八畜铜铁釜镬。疏第三求一切智下。回向成就中言总即所求之事名之为家者。论有十一句。初总余别。若随行要分别乃为三节一谓求一切智地是家。二求力无畏不共法为依家。三余句。明无障求故。论别列十一求竟。总云。于中求何等事。求一切智地故。以何观求。观诸佛力无畏不共法故。云何求。求诸波罗蜜无著法故。此三求者。是家依家无障求故。释曰。今疏别摘配释并不违论。故今总句即是家也。言总即所求之事者。此中正明求佛。故一切智即所求等事。故论上云。求何等事名之为家者。即上论此三求中是家。家是三中之一。此即以事为家。从一切智地是求处者。疏以经释论。为家之言。处即家故。疏别即能求之因者。从总开出。皆明求义。虽有三节后二皆因。因中分二。初一为观。即论云。以何观求名为依家者。即前论三求中依家二字。从于前家中。下疏释观义。其十力无畏即一切智地。依彼成观。故名依家。疏余十能求之行者。即上论云云何求。即三求中无障求也。皆治蔽障。故疏或许。多胜等者。兼上有三。一许不与。二许多与少。三与许胜与劣。五不舍求中二。先释文。后勤策下解妨。前中戒法无量者。戒有三聚三千威仪八万细行故。劫数长远者。一受不舍至成佛故。戒法精妙者。防于意地起心动念。即毁犯律仪。论于止作故说为持三聚进善利生云行也。疏难行易败者。不同定慧证法之乐坚固难失。疏后三是欲者。故上文云后三信增成欲。次十是精进者。即修行成就。后十是方便者即回向成就能以少善成无量果。故云方便亦不滞寂故疏上依论辨下更示别理离四障故亦是摄论第六断除四处障也。而有开合。后二即彼第一离二乘作意。初一即第二诸疑离疑。二即彼第三离闻慧我我所执。兼第四断除分别缘法。第四校量胜分。疏谓住此地下文前有二。先释总名兼彰分齐。通一地故。后问经云下问答拣定。先问后答。问中引涅槃三十八迦叶菩萨赞佛云。怜愍世间大医王身及智慧俱寂静。无我法中有真我。是故敬礼无上尊。发心毕竟二不别。如是二心先心难。自未得度先度他。是故我礼初发心。初发已为天人师。胜出声闻及缘觉。如是发心过三界。是故得名为最上。故沙弥发心者。即智论文。昔有阿罗汉。领一沙弥携持衣钵。沙弥忽发菩提心。阿罗汉心知。便取衣钵令其前行。前行之次见诸细虫。思众生多难可化度。便退大心。罗汉即令却持衣钵。令在后行。沙弥问师。师具答云。汝先发大心。即是阿罗汉所归敬处故推于前汝后既退菩提之心。故是凡夫。不合居吾圣人之前。如何下结难。疏然其胜义下答。于中三。初标心体。二此三历位下开章解释。三今此正明下结酬二中。二信胜者。既于大乘决定解故。依深观解起行愿故。云具三心如问明是智净行品中兼明行愿。三解胜者。习种已去。于深法界如实解故。四行胜者。性种已上具依种智一切行故。五愿胜回向大愿向三处。故言此即三贤。别历三心者。从增胜说。通亦具三。如十住品。疏下辨果胜亦三心果者。调柔是行果。发趣是智果。愿智通二果摄报通三果。疏虽历诸地。戒定下会异说。谓远公有十七过。十义同疏。二地净业过。戒清净故。三地定自在过。四地不舍众生修道品过。五地不住道行过。六地甚深解行过。七地寂用双行过。八地利他功用过。九地辨说行过。十地成就微细智过。兼初地中复有两重。一证过如前。二求胜过。谓地满求证无足故。此有十一唯存其证。后至七地功用满故。八地已上无功用故。故云虽历诸地不离三心。于十一中存三除八。疏中前五后一是同已同其九。加第九等觉。故唯十过。问若有十重。今但对地前辨胜便足。何用对于二乘。答良以小乘是大乘所对。凡欲辨胜多皆对之。乃至佛果亦对彼耳。下经非一。法华亦云。诸佛智慧甚深难解。一切声闻辟支佛所不能知。疏文分为三下正释经文。所以三者。即行修始终也。疏故下论云者。以论先广释十愿竟后方以义收束。今先为义门。故言下论凡有下论之言。皆准此知。疏而言大下释此大字有通有别。别指在文。通中有三。初正释。二瑜伽下引证。三今拣异下结示。今初。先举论文。光明善根此举大体转胜增广此示大相。从谓教证下疏释论文。疏兼取所从即后二愿者。正愿但约摄受菩萨善法异于凡小。大愿即显行相深广。故二不同。则正通大别。正未必大。大必是正。故兼二也。疏即以欲胜解信三者。欲及胜解别境中摄。信即是善。并如前释。今希求即欲要印持前境方忍乐欲。而心净故。疏先约行中二。先别明。后若约通。下明通二利。疏一以何身者。此中五句。论有征下即疏答。义属经文。如一以何身论也。谓摄法下是疏嘱经。下四皆然而但释前二后三易故。四众生住处者。即第六承事愿有其二义。今取土中有生往化之义。疏后三不定者。自有三释。初一是古疏意。次二即论疏后三明位下。从初地来证如同圣。故至九地。不离诸菩萨会等。二十地方得三业不空。三如来可知。疏已摄二严等者。初一福严。次二智严。四通二严。五六福严。七八通二。九福满。十智圆。因果行位已如向辨。第一愿一始起要期下释此三句。论在后结中。释今将来此论经二句不同。二云大方便。三云大行。然一一句皆有三段。如初句云。始起要期。是疏出意。二云如是大誓愿。是牒经证。三随心求义。故是论释下二皆然。疏是知此愿亦即是行者。论言起此三行故。疏清净解言信因果故者。因即解字。胜解即于境印持为性。不可引转为业。即唯识论深忍之义。清净是果。若准唯识。乐欲是果。今望上因心净即果。疏一摄功德大等者。此下三大即初地。初六决定中之二。初一即胜善决定中义云一切余善根中胜故。意取胜等不取决定。二三即因善决定。开之为二。第二愿亦初教次证者。上约教理行果以释经文。而论经但有三句。初句明教。次句明证。三云一切诸佛所教化法皆悉守护故。此即用前教证以化众生。故名为行。论下释中教。谓修多罗等。此释法轮书写供养读诵受持为他演说故此释受字。释次句云摄受一切佛菩提者。所谓证三种佛菩提法摄受此证法教化转受。故释第三句如今三云护教下所引论文。上疏顺四故为此配。若配教证亦可后二。护初教法持上证法。疏上约始修下明成就义。行德相应总名成就。论亦三成就四是义加顺四法。故论释第三云。三者。修行乃至如实修行正觉。成就故者。即修上证也。上论三种菩提者。而论自释。即三乘菩提。此有二意。一明菩萨菩提包含二将随宜化物。第三愿以八相如离世间者。今经具列彼各有十。然亦有佛不具八者。如天王佛。白衣成道故。若以离俗为出家则亦具矣。须扇多佛无生可化。则不具转法轮。留一化佛半劫化人。是则亦具。然论释一切处。云顺众生见故下料拣。何故不处色无色界。恐众生云此难处来不为我成故。二云何故不处他化等而生兜率。令众生知舍彼胜乐为愍我故。三问。何故下生人中舍于天乐。为愍我故。四何故处胎示现同生。增长力故。五问。何故自成正觉。示非余佛教化。显丈夫力成就非因他得菩提故。六问。何故入涅槃。为令懈怠众生勤心修道故。此等略举示八相中一义而已。下离世间各具十义。故疏全指第四愿世间出世间各有多异者。谓明出世出略有二义。一约位。谓地前为世。地上为出。二随义。教道为世。证道为出。今下广大无量即是教道。故云世间。不坏不杂即是证道。为出世间。疏论名种种下直至八地已上。三行疏文。意明俗智之行是疏余皆论文。疏法无我下即是论释。谓不杂下是疏释论文有三段。一释经。二若依瑜伽下会异释。三论主意明下会通二论。言义不异前者。即广大无量不坏皆同故。瑜伽便当释论广大等义。第五愿疏彰化所为者。论云何义故化。疏无想天为细者。色界十八天唯除无想。皆名有想。无想天与广果天同处。外道取为究竟涅槃。修无想定生于彼天。得五百劫无心果报。佛弟子不生彼中。疏化生依何依业染生故者。论但云业生。依于因。果染字即俱舍世间品意偈云。倒心趣欲境。湿化染香处。湿生染香。化生染处。疏然四生摄尽六趣。则通局有异者。亦俱舍意。彼偈云。人傍生具四。地狱及诸天中有唯化生。鬼通胎化二。今疏说势小别义理皆同。人具四者。卵生如毗舍佉夫人生三十二卵。卵各出一儿。般遮罗王有妃。生五百卵。卵各一子。胎生如今人是。湿生如顶生王从顶疱而生故。化生者唯劫初起。傍生具四此类可知。化生如龙迦楼罗等。鬼通胎化二者。如饿鬼白目连言。我夜生五百子。随生皆自食。昼生五百亦然。虽尽而无饱。即胎生也。鬼化可知。无而忽有故。疏又以六趣不摄中有化生等即宽狭门故。杂心论云。为生摄趣。为摄摄生。论自释云。谓生摄趣非趣摄生。何者中阴是其化生。趣不摄故。六名色所摄。名色之义六地当说。第六愿疏瑜伽云下辨其异名。今经已下会释。知生佛住处者。知生住处往化。知佛住处往供事故。新经中承事之言其义甚显。偈云。于一毛端微尘中。出现三世庄严刹。十方尘刹诸毛端。我皆深入而严净。所有未来照世灯。成道转法悟群有。究竟佛事示涅槃。我皆往诣而亲近。释曰。前偈即一切相。及真实义无量相。后偈正明承事严刹。亦兼化生。疏一切相等者。一切相是土相。真实义相是土体。及性相相融世界实尔。云真实义。然其分量约三千者。且约权实同用耳。应如世界成就品等。故下第三辨无量相疏云。粗者云色义。当无色界为细。下二界为粗。以释广等既约三千。粗细亦且就三界耳。余义皆如初会第七愿。疏愿清净下疏文有三。初总显立意。二于行相下释文。三上七净中下收束。今初略具三净摄于净土。一清净自土。即是相净如第三净。二安立正法。即法门流布净如第七净。三及修行众生。即住处众生净如第五净。显斯三净即净土意。自他受用及变化土。皆悉具矣。疏一同体净有二意。初明报应净土。皆以法性土而为其体。即事理无碍。二故令一多下。由相即性。以性融相。令报应等及染净土互相即入。疏即自在净者。净土略有二种。一者相净。即第三净。二自在净。即是今文。如摩尼下喻自在相。随机现故。如身子螺髻各见不同。而言普皆清净者。就佛言之。无不净也。故净名云。我此土净而汝不见。即以自在圆通而为净也。如第八地。疏受用香饭下引净名。证身诸惑灭。证离过断德入正位等。证成行德。等者等于净名余经。前教体中已明。至法界品更显。疏具德人居者。亦名人宝庄严。亦同净名不谄众生来生其国等。因净如世界品。疏一所生果者。即生因招临机示现。即依因招即后智通慧。故论结云显智神力等故。第八愿疏一福善同集者。善根是福无有怨嫉。即心同相。智观齐均无二如故。同三谛故疏随意现身者。通他受用及变化也。疏不由他下。然经云任其自心。能知一切如来境界即是证道。威力智慧是菩萨教道。此就能知。若约所知。威力是佛教道之用。智慧是佛证道之德。就菩萨中证知佛境。境即真如。是所知境。威力智慧是佛所有为分齐境。第九愿疏先总明下。然释乘不退轮有二义。前义三业不空是轮之用。后义三业不空是轮之体。疏实则互有者。谓见身亦得实智及断惑。闻声必定断惑。信意决定得智。疏一种种苦者。药王树枝叶华果。各除病故。疏论主对前下即疏别意。于中光出论意。言对前安乐者。即佛地论中利乐之文。总有四对。如光明觉品。此中用断恶为利益。进善为安乐。然前之作业。就行体立名三业所为故。取其成益乃是安乐。今此即就行益立名。从实则下正显疏意。意云。前之三业通有利益安乐。故今二喻各喻一。能药能治病故喻舍恶等。即利益也。宝满人意故喻进善等。即安乐也。故上所喻三业之中。影略已显利益安乐。生信决定即是进善。永离烦恼即是除恶。释云。互通三皆兼二。第十愿疏今初菩提亦是总相者。此有三对。前约自他。对论乘运故。二者体用。故云菩提体菩提作业。三者总别。别依于总。总摄别故。方顺经宗。言真则称性者。约体用二利。此唯是自利之体。但有此句。谓若有妄念。则身智有分有在不在。今妄尽称真故无在无不在。云于一切处而得菩提。若依总别。总既含别。故有下句应则随机感而即形。故无不在。广如出现菩提章说。疏示正觉业者。拣上真成而即体之应故一多自在。此别示菩提而具八相。二三四业。皆转法轮。相而初一说实通于诸乘。二唯说一实。三一音随类顿具诸法。故论云种种。疏说实谛业下四谛之义。如其本品。上求佛智。亦说知断证修。故知为通不可局小。疏论经具之者。彼经云现诸佛境界大神通智力是也。今经神通属下。故亦义兼疏以神通力念念成佛。犹属前业。此为说法所依之身。故举之耳。疏以佛生处必非五难者。必非三涂北洲长寿故。前后虽是约时。亦约必无余二容有非是处故言彼彼胜处者除难处竟于三洲中唯取阎浮。阎浮为胜。堪受化故。百亿非一故云彼彼。疏以一极无二之菩提者。三者正也。菩提云觉也。此是能证其一极无二释经一字拣异二乘。故名为一。拣异菩萨故复云极。出现品菩提章云。菩萨应如是知。成等正觉同于菩提。一相无相。复云。菩提无相无非相。无一无种种。所以疏云一极之菩提。疏契差别之性净涅槃者。性净涅槃即是所证。二无我理本寂灭。故名为涅槃。言差别者。释经一切法界。谓即是差别。而性净故。经云即涅槃相。即相之性方为净性。契通能所。能所契合真菩提故。言则不复更灭者。暗引净名弥勒章中证成上义。彼经云。一切众生即涅槃相。不复更灭。在义可知。出现品中更当广说。上即是证。疏说此证下蹑上释教化义。唯将佛所证法教化。亦同法华佛自住大乘。如其所得法。定慧力庄严。以此度众生也。即佛教证。疏四。以一音下此业一音顿演。故名种种。一音之义前疏已明。下复广说。言称机故者。释经令欢喜言称机故喜。疏不断佛种业者。化化不绝故。此业广如出现涅槃章。明疏法轮复住业者。疏文有三。初正释经。二前即下双结五六。三对实下释名。今初。大智慧即唯一事实者。法华经云。究竟至于一切地智。又云。唯此一事实。余二则非真。言即是佛智者出体。经云。说佛智慧故诸佛出于世。能生下释智地义。地有二义。一者能生。于一佛乘分别说三故。二者终。归究竟至于一切智地故。开示众生如来知见。故曰同归。即法华方便品。初诸佛智慧甚深无量。疏而智慧门下即是法华。其智慧门难解难入。又彼经云。舍利弗。诸佛随宜说法意趣难解。所以者何。我以无数方便种种因缘譬喻言词。演说诸法。即随机无量也。广如法华开示悟入之文。疏前即涅槃下。第二双结五六意。显此经包含。疏对实下第三释名。以复住字难了故。谓教法住持名之为住。实则常住。对实施权故有复言。疏七以法智下疏文有二。先依本论释。后依智论释。今初言显自在所依者。即是三通则知经云自在变化。下正显自在之用。于中先显三通。以含自在之意。由法智通下方释自在。束其三通成无住道可知。疏又依智论释。则以自在亦是一通。但有通名已含作用。十八变义法界品辨。疏药师十二弥陀四十八者。并如彼经。恐繁不引。疏亦摄一切菩提分法如第七地辨者。彼因说七地一切菩提分法。于念念中皆悉圆满。解脱月便问。唯此地满诸地亦满。金刚藏答。于十地中皆能满足菩提分法。七地最胜下说诸地满相。云菩萨于初地中缘一切佛法愿求故。满足菩提分法。即其文也。言彰自勤行者结也。故论云。一常勤修习无量行故。常辨无间无量辨横广可知。疏论云。尽者示现。不断尽者不断。是无尽统摄无尽之法令无有余。名为尽耳。疏初句为总。十愿皆是为众生故者。此段略有三门。一总别分别门。二广略分别门。略以三转摄前九故。三五无量界分别门。即为三段。今初总别略有三义。一者语总。如十地十度等。二者法总。诸法因体互相集成。即六相中总。三者意总。如此中说。意为众生故。疏后三转下即广略门。以世界是众生依报。虚空是世界所依故。合为世间法界。是法可知。涅槃即所证法。佛出现即教化法。如出现品。以无量缘方出现故。故三皆法。其如来智是智亦可知心所缘者。意通能所缘。佛智所入成上能入之智。故皆智转。疏而言转者。别释转字以略摄广。名展转者可知。而言转亦无尽者。所摄之九复能摄故。故转生无尽。疏又十中前四下。五无量界所摄门。然依瑜伽五界者。一即众生界。二世界。三法界。四调伏界。五调伏加行界。无虚空界。今者虚空合后二界。是智论意。若依瑜伽既除虚空。即以心所缘界摄调伏界。余四调伏加行。即方便也。化生法者。名调伏界。度生法者。名调伏方便界。疏先反显者。假设界尽愿尽。疏故下顺明下正明界无尽。故成愿无尽。于中二意。先别出同之所以。后故十尽句下以论成前。前中言前之十愿不出此者。且总相明一一愿皆云广大如法界究竟如虚空等。若别说者。众生即第五所度世界。即第六所知。第七所净。虚空即前第六中十方无量。此四界皆第十愿中三法界。即知一切法界既为化生法。亦即第二第三愿。四涅槃界。即示入大涅槃而不断菩萨行。五佛出现界。即不离一毛端处示成正觉。六如来智。即约佛境界大智慧力。是大智慧地等七心所缘界。即第八愿平等一缘。八佛智所入。即以一三菩提。知一切法界即涅槃相。亦是第四二利六相为所入故。此十句下全是论文。由生界等无有尽故。诸佛以愿利益不休。第二行校量

疏。十心为起行依者。论经但有二心。谓调顺心柔软心。论云调顺心者。彼诸善根中得自在胜故。谓欲起即起。故名自在。论云柔软心者。得胜乐行故。谓内证适神心无刚强故。今有十心故。对下十行治瑜伽十障。与论小异。疏二辨体多。同十藏者。十行望藏有名同者。谓信施惭愧余多义同。六即闻藏。标章云。闻说多知故。五同于念。九同于持。十供养中财供同施。法供同辩。七了世法。即多闻中义。慈悲二行亦是闻中知缘起义。既言多同有不同者。不会无失。亦余处经已出体竟。故取信等多同。亦不取全同也。疏下论云等者。以论先释十行后方始收束料拣故。云下论言尽是障地净法者。下文当释。今且略明。谓尽能治地障故。故以一行对治一障。疏前三是行意乐故名为心者。先释义后引论证。亦是下论。然就通论。十皆是心亦皆名行。故此十种名行校量。于中分别。前三是行方便心。论云深心故。疏以意乐释心。言地持同此者。彼云前三名为心净。后七名行方便净。疏五约二利。即就行分别。言信及无疲是自利行等者。论主次第释前七云。于中依自利行。谓信能信菩萨行及诸佛法。求必能得故。依利他行。所谓慈悲。能安隐他与乐心故。舍者。以财摄他行故。不疲倦者。自摄法行。故知诸经论善解世法者。摄他行故。释曰。以论文虽显。次第相参故。疏摘出二行以为自利。余为利他。疏后三摄护前七者。问直尔信等自能离过。何用惭愧护令离恶。答若无惭愧终不起信。断于不信如是一切。故说惭愧。以为能护。由离障故七皆不着。疏后一摄前七者。摄有二义。如疏所辨。言摄令成行者。为行供养摄令起信等故。论云三者。修行彼垢清净依止行。供养诸佛。摄信等善根故。二由供养得二种身故。令信等得二身果故。论云。是中有二种供养。故得二种身。一者上妙身。所可见者心生敬重。利益不空故。二者调柔心。自性善根成就乐行法故。释曰。久修令熟故曰性成。即论自性善疏并结有六者。结文是疏科经论主不科。但云此菩提所摄本行。入有六种胜。是故信胜。今依疏前科。则释中唯五。故云并结有六。所以论取结者。结中有果同前五故。若尔结中有因。何不对之初立三因。答以被中间五果隔越故。然皆信为句首。疏以易见故不牒经

疏。三不杂染胜者。论唯有标名下便以经帖合。谓证真下疏先通释。后以即边下别释无中边言远公释有二义。一约染净事法辨。二约有无法理辨。今初。然论经云无中边。此公云。生死此边。涅槃彼边。圣道为中。今观生死本性不有。即无此边。涅槃如故。亦无彼边。两边既无圣道亦寂。无有中间。二约有无法理辨。云有为此边。无为彼边。非有非无说以为中。有即非有故无此边。无即非无故无彼边。两边尽泯中间亦亡。故无中间。然此二释约法小异。义旨皆同。二边中道三法皆立。以为所遣。以性空遣二边。相待遣中道。今之所释略有二异。一者中边语通则有无染净。一异断常。生死涅槃。若离若合。皆是二边。中随二边亦有多义。二者以中遣边以边遣中。待绝双亡故皆本无余。如前说。疏亦是三轮化益者。智地意业。说即口业。力即身业。身威力故。第二双起慈悲。疏前中三观即为三段。下疏文有二。先明三观。后即为方便义。前中即是唯识。真乐本有失而不知。妄若本空得而不觉。三段中初即真乐本有。二即妄苦本空。三即不觉不知。然其初一即性净涅槃。下释云三祇方得者。方始契故。故得言证涅槃之乐乐中精极。故云最上。殊胜无加故曰第一。有大义利故名为义。今疏下文约所证释。二即具足生死之苦。疏但失真乐下明为方便。于中二。初立理显过。后正明所起。前中言已为可愍者。则显后后深于前。前但失乐而可慈愍之。更具诸苦故须拯拔。况复双迷于彼二法。迷谬颠倒苦处计乐。乐处计苦。故增妄苦难反真乐。云反本无期。后由初观故下别明所起可知。先总标起念者。菩萨乘前信解佛法。故念法甚深。以甚深故众生失之。以失深乐故可怜愍疏一寂静甚深者。然论一时列其九名。后方重释。释初云寂静者。离妄计实有故。妄计正取故。疏离二句释之。以初句为顺释寂静。从自是妄计下以下句反释寂静下引中论证上二义。即第二卷第十三行品。初小乘有问云。如佛经所说。虚诳妄取相。诸行妄取故。是名为虚诳。谓第一实者。即是涅槃。虚诳妄计即是虚妄之相。何得言一切皆空故。龙树以此偈答上半正答。既无所取即是空义。下半为释前偈佛说虚诳妄取。正是说空。若不空者不名妄取。应名真实故。今但用上半证今论中妄计正取。疏此一遮诠显二是表。又第一离妄。第二显法体。是故论云法义定故。疏谓一心体寂等者。即起信论意。彼论立义分云。摩诃衍者。总说有二种。一者法。二者义故今论云法义定故。彼论释法云。所言法者。谓众生心。是心即摄一切世间出世间法。依于此心显示摩诃衍义。何以故。是心真如相即示摩诃衍体故是心生灭因缘相。能示摩诃衍自体相用故。释曰。今疏云一心即总摄二门言体寂者。正取前是心真如相。即是摩诃衍体。顺经寂灭故。言二门亦寂者。二门即是解释分中。然此立义分中。向所引法已有二门。则真如门示一心体。生灭门中总示三大。然彼论中释云。所言义者。即体大相大用大。今欲明于立义分中已具二门故。说二门已为义也。是总心中之所以故。故明三大但是生灭门义。二门之义义则宽矣。三大二门前来频引。疏三治妄分别障等者。此三释有多门。如下六地。远公云。分别即是妄想。心体相即分别所起事相。取舍即依分别取舍。顺境贪求故愿取。违境厌背故愿舍。亦可约三性说。分别即遍计所执。口译为分别性故。相即依他起。取舍即取圆成之真。今治三性之执。成三无性故。为三解脱门。略无甚深之言。三云空甚深。四无相甚深。五无愿甚深。疏六明离杂染观者。下有三观治三道障。此治证道障。即得真证道。穷终妄想缘智名为杂染。真智殊彼故名为离。以无所得而为方便。名真方便。亦兼显方便道及后不住。即为四道。疏即不住道者。自利大心不住生死。利他广心不住涅槃。论经但云如是无上。而论释义。即是今疏第二具足诸苦观。疏然十二缘下问答显意。问意可知。从业惑苦因下答有二意。此是以因从果名苦故。六地中尽属苦树。二又二流动下业惑是行。行是五阴。体即苦故。动即有苦。引起信证。即三细之初云一者无明业相。以依不觉故心动。说名为业。觉则不动。动则有苦。果不离因故。释曰。今疏意云。细中之细尚当相是苦。何况粗者。远公亦云。苦过重故偏举疏前中分二下疏文有三。初科为二故。论主下引证为二。三欲显前三下出为二所以。曲有二意。一依因果分前三为因。识有二义。为因属前。为果属后。故前三竟。犹言后十者。识为果故。二亦显下。复是一意。亦通妨故。来谓有问言。前三是因因在一处。后十之中爱取有因那与果同。故有此意为拣唯识。唯识论云。十因二果定不同世。前七次三或同或异。若二三七各定同世。二即生老死。三即爱等七即前七。今前二三属于过去次七及八属于现在。即前七支。不定同世。故云许异世故。若远公通爱等为因。云以彼增长未来苦果故与果同。若尔前三何不从后说为苦耶。答云。过去已起因果定故。虽有此通。故今疏云非独因果要分为二。欲显前七可分二故。疏约果结苦者。此释论主明其结过。与后十支同处解释。通意可知。疏总云。邪见下疏文分二。先释邪见。后释心堕。前中先正明后引证。今初。邪见有二。一粗二细。粗则拨无因果。细则理外推求。粗亦名别。细亦名通。通则通诸烦恼。今是通是细非别非粗。疏涅槃亦云下第二引证。即三十五迦叶菩萨品。因说随自意等三种语故。文云。善男子。如来或时为一法故说无量法。如经中说。一切梵行因善知识。则已摄尽。如我所说一切恶行邪见为因。一切恶行因虽无量。若说邪见则已摄尽。释曰。恶行通于一切业惑。故云一切烦恼邪见摄尽。疏本在其中云何名堕下。第二释心堕言。亦通妨难。上即难词。烦恼无始何有初堕。若有初堕。则有未堕邪见之时。从此有二义下。答有二义。初义易了。谓于一身身心澄静念虑瞥生。即名为堕。二约迷真下正通无烦恼之难。真是所迷。妄是能迷。既有能迷义如堕耳。故妄与真皆无始也。言相依无性者。双遗真妄。言相依者。依真起妄。因妄说真。若无能迷所迷不立。安得有真。依真有妄故妄无性。依妄说真真岂定有。故云相依无性。则能所俱空。从若定有真下反成真义离妄。说真定性有故事外真故。若尔已下蹑迹起难。难上相依无性之义。同妄无性应可断故。从妄必可断下答。上约下异难令可断。今约不一答。真叵断如波与湿。虽互相依。波则可灭湿性不坏。不一不异真妄俱成。此是一意。从不空之真下复是一意。上依空之真则同于妄。不空真性非对妄论。即此空有非一非异。方为微妙之真。恐难无穷。故下结云但空妄执自见真源。分别不亡。皆成妄惑。谓如复礼法师有遣问云。真法性本净。妄念何由起。许妄从真生。此妄安可止无初则无末。有终应有始。无始而有终。长怀懵斯理。愿为开秘密析之出生死今疏末句正示秘密故。应总酬其问云。迷真妄念生。悟真妄则止。能迷非所迷。安得全相似。从来未曾悟故。说妄无始。知妄本自真。方是常恒理。分别心未亡。何由出生死。然疏文之中理已具矣。但云无始而有于长怀懵斯理者。则法相事而例难之。今云有妄即真。则同无终始。若分别说应有四句。真理则无终无始妄念则无始有终。真智则无终有始。瞥起妄念有终有始。若约圆融同无终始。既无终始亦复无有无始无终唯亡言绝想。可会斯玄

疏。故论总云下上取义总科。此下第二引论为证。然论前别列九邪见竟。重复牒释云。是中蔽意邪见。憍慢邪见。爱念邪见。此三邪见依法义妄计如是次第。是故疏言论总云也。从斯则下疏释论。乃有二义。初义意云。法上妄计故有蔽意。义上妄计故有后二。即为次第。从亦可下是第二意。则以一法二义三妄计而为次第。下疏偏用初意消文。故云次二迷义

疏。初一句是蔽意。邪见等者。疏文有五。一指经立名。经云无明覆翳。二此依迷法者。即论总示其体。三谓无明下疏双释经论之意。四所言法者。下引起信论释蔽意言。以论经云无明痴暗蔽我意识故。五此无明下结成根本无明。故诸经论皆言无明无因老死无果。唯有无明横从空起。不可复源。六地云不了第一义谛故名无明。若依起信。即是根本不觉。亦是自性清净心。因无明风动有其染心也

疏。次二迷义通四住惑者。一见一切处住地。二欲爱住地。三色爱住地。四有爱住地。上无明住地即当第五。一五通三界二三四即如次辨欲色无色。此上总是惑体。二由前痴故。下释迷义。因缘生法离我我所。今由有我故立我所。我所即法。疏三爱念邪见者未得悕欲说之为念。已得深着说之为爱。其渴鹿喻未得悕欲。其网鱼喻已得之爱。而言如今之爱支者。过去无明亦有如今之爱取。故疏行谄诳下疏文有二。先总释。二由上内计下蹑前生起。论经无悭则唯二过。今加一悭。故第二中有二过合成三过

疏。一初句下释第四邪见。谄谓为罔冒他故。矫设异仪险曲为性。能障不谄教诲为业。谓谄曲者。为罔冒他曲顺时宜。矫设方便为取他意或藏己失不任师友正教诲故。诳谓为获利誉矫现有德。诡诈为性。能障不矫邪命为业。谓矫诳者。心怀异谋多现不实邪命事故。释曰。以上论文明知此二皆虚似实。然此二惑俱以贪痴一分为体

疏。由嫉他身下释经恒造诸趣受生因缘。然论经无悭而云常怀嫉妒而作后身生处因缘。论释云。妒者于身起邪行故。嫉者嫉于资财等。是故生生之处堕卑贱中。形貌鄙陋资生不足。释曰。今但以悭对嫉以嫉对妒。配属分明。然嫉与妒有通有局。若玉篇云。忌贤曰嫉。忌色曰妒。忌色即是身过。今嫉于财却参悭义。故案经释。然论释意此二招于别报。故经云后身生处因缘。今言诸趣受生因缘。言含总报

疏。次三明行中下疏文有十。一此句总标。二初贪恚下别出三中初句经至积集诸业日夜增长。三由前下蹑前追求总释三句。四此句总明下别举初句。五故六地下引例释由惑起业。然彼但蹑无明。今通贪等。通别有异。六亦是行俱无明者。再释贪等。前释举于发业无明在于行前。今与正发业时。所有诸惑皆名无明。覆蔽于业不知过故。七诸业非一下释余经文。八然集业下牒论解释。于中三。初蹑经文生起论意。谓经云三毒起业。而论云受诸受时者。因受生毒故次故论下正引论文。后谓乐受下疏释论意。九然愚痴下拣法同异。十次二句下释别二句

疏。即内心思业为烦恼风动者。此略释经。然经云心通相而说。亦是举于所依心王。今云思业别举业体。以论经云吹罪心火故举思业。次谓于怨恨下论释。其中此思之始及此思之终。是疏释论。余皆论文。疏思通诸恶下释妨

疏。明所引识支等。疏文有三。初标名示体。此依能所引生明之。如十藏品及六地广说。二以其识支下出经论意。通因果义。次下当明。今取前三为因。故取识种。三心意识三下释文。于中四。一释心意识名言如前释者。即问明品。言意识通余四种者。识即前六识。是六处种。六识必含于触受。是触受种除上四外。皆名色种。故云通四。二谁能起下释起字。无记非因者。但招别报不招总报。故如九地说。三善业云何下释用四流之义。四若尔下解妨。先问。后理实下答。有法有喻并如六地所明。言诸经论者。总指非一唯识论具二。以业种为增上缘。识种为亲因缘。今此经中即说识。识受六道身为种。如中论云。众生痴所覆。为后造三行。以有此行故识受六道身。即以业为因耳

大方广佛华严经随疏演义钞卷第五十八大方广佛华严经随疏演义钞卷第五十九

        唐清凉山大华严寺沙门澄观述

疏。第二明中后九支者。亦可言十义如前说。隐现行识即言九耳。下当广明

疏。然论兼结文总分三段者。其结一文。即疏科经。即前具足诸苦观初。以约十二缘明苦故。总科云文分为二。先别明缘相。后如是众生下结成妄苦。就前方开为二。初明前际三支。后辨中后九支。今论乃于中后九中笼取结文分为三段。若直就经文。此下兼第三。彼二颠倒观总应分四。一示九支缘相。二如是众生下结成妄苦。三是中皆空下明缘体空。四取彼二颠倒经文结成迷惑。其第四段是第三观。今为顺论就前三段。开初一为二。合后半及第二为一。以第三为一故。亦有三。就疏之中文分三段。一列三名。二言自相下释三名。三随文释二中言同相者。释有二义者。初即远公义。二即今疏正意。于中四。一正明。二犹如下引例释寻常自相共相。证成则自相全同同相宽狭不等。此唯约因缘故狭。彼通有为故宽。然缘起过患。即是同无常等。三是则现在下结成隐显。未来隐自相显同相者。令厌当果绝现因故。四此释顺论下引论证成

疏。言报相下别释初相。疏文分五。一正释报义。异熟是三界报体故。共名色生明是果报。二故论云下引证。异熟识是报相义。三此含识支下出体。四故摄论下引证三相。五经云下。释文前三可知。四中有三。初引论列名。二释彼论意。三会释二论。今初即第二论所知依品。第二云。论曰。如是已说阿赖耶识。安立异门。安立此相云何可见安立此相略有三种。一者安立自相。二者安立因相。三者安立果相。初谓依一切杂染法所有熏习。为彼生因。由能摄持种子相应。二谓即如是一切种子阿赖耶相。于一切时与彼杂染品类诸法现前为因。三谓即彼杂染品法。无始时来所有熏习。阿赖耶识相续而生。释论中言分析此识自相应相。以为二种。因果异故。释曰。初谓依一切下论自释相。即今疏云。此意明下释彼论意。撮略言耳。若不望因果直语自体者。识之自体双含因果。分出因果即是二相。不分因果即是自相。故上释论云分析此识自相应相。以为二种。因果异故。是则自相为总因果为别耳

疏。今论因相下第三会释二论。问因果相殊。云何此因而是彼果。答今以果识为名色因。非以种子为现识因。是故名殊而体一也。故此中三相。而初二皆是摄论果相。此论果相自是名色之果相耳。言立名虽殊俱通因果者。明引彼三相非证此三但明此识通于果耳。因如前段

疏。所谓名色下出苦芽体相者。文三。一牒经总标。经云所谓名色共生。二论云下引论释。三谓名色共彼下疏释论。论中彼字即赖耶故。于中三。初总显论意。次名谓非色下出色体。后此二与识下显共生义束芦之义。六地当释。即前所引摄论。次文云。阿赖耶识与彼杂染诸法。同时更互为因。云何可见。譬如明灯焰炷生烧同时更互。又如束芦互相依持同时不倒。释曰。灯炷生焰。灯焰烧炷。互为因果。正是果识为名色因义

疏。二不离是因相者。牒经标名。即显本识为名色因者。疏释因言谓是名色下论释其相。言名色不离彼本识者。论主释经不离之言。非是不离名色有六处也。显上句中共生为不离耳。言依彼本识故者。论主自释因相言也。从既依此释下疏家案定明此自相因相中有识支及名色支不同。古释唯取同名色支识支在前邪见中故。今名色依起者。依彼本识因生耳。疏三彼果相者。即此名色增长下经前已科出故。此略无牒经。疏中但释彼果。拣非报相而为果体。今取六处等是报相名色果耳。上言次第者。名色生六处。六处生触等。次第不乱故。恐繁指后。疏二同相中论主易故不释。疏文亦显。然六地中名为苦树。广有其相言文义显者。文即此中有忧悲苦等。唯识云。老死位中多无乐故。此是他文言义显者。生死是苦。忧悲之苦最明显故。故为同相

疏。三颠倒相中二。先总释后。此有四重下别疏僧佉说觉以为神相者。即百论破神品第二中。外曰。实有神。如僧佉经中说。觉相是神。次论复云。优楼迦弟子诵卫世师经。言知与神异。是故神不堕无常中。亦不无知。何以故。神知合故。如有牛人。注云。譬如人与牛合人名有牛。如是神知情尘意合故神有知生。以神合故神名有知。释曰。上即论立。今但云无。不说无之所以。所以广如前后。今当略说。论破僧佉云。内曰。神觉为一耶为异耶。外曰。神觉一也。内曰。觉若神相。神无常故。释论云。譬如热是火相。热无常故火亦无常。今觉实无常。相各异故。属因缘故。本无今有故。已有还无故。外曰。不生故常意明神不生故。内曰。若尔觉非神相。意云。觉无常神常。无常不应与常为相故。彼疏总释云。此二相违凡有三对。一神常觉无常。二神遍觉不遍。三神一觉众。此初段中正就二对生过。神一觉众。在第三重中方破。就初对中有四种过。一以神从觉神则无常。二以觉从神觉应是常。三若不相从体即不一。四必欲令觉是神。神则二种常无常也。亦言觉不觉也。今结四过之中经文有一二。是破觉不应有之。三四略无。余如彼论。二破卫世。先破其喻云。内曰牛相。牛中住故。非有牛中。释曰。有牛是人。人与牛合牛不是人。神与知合知不是神。何得为相。次破其法云。汝言神相情尘意合故知生。是知知色等。是故但知能知非神知。譬如火能烧。非有火人烧。斯则知为神相义不成矣。今云无知。疏若约小乘等者。受蕴名觉。觉苦乐等。三蕴名知。想取于像。行有欲胜解等。皆是知义识义。更明色非此二

疏。约六根说身识名觉等者。若约别明眼见耳闻。鼻舌身三名觉。意根曰知。今取触尘对之为觉。余五说知

疏。现有知觉下通外难。先难随俗故下答。即中论意

疏。又心法有四下亦答上难。于中有二。先举法相。后结酬其问。前中此四即同唯识第九四种胜义。一世间胜义。谓蕴界处等。二道理胜义。谓苦集等。三证得胜义。谓二空真如。四胜义胜义。谓一真法界。广如玄中。今文先列名。次谓随境下释相

疏。此四重中下二结酬其问。汝现见有但是初门。今约后三故言无也。又以第二破其初一。则事非事矣。若以第三破其前二。前二俱无。若以第四拂其空相。空亦不立方名为实。又三以空遣有。四以实遣空。空实无碍。知即无知。然破我与法。广如于前诸会经文

疏。响可喻言声者。此喻亦是遮救无知谓无情之物。动与不动故无知觉。众生有心安无知觉。故引响喻。因心发声。扣谷发响。响无知觉。情发亦然

疏。彼二颠倒等者。颠倒有三意。一迷真随妄即是颠倒。二由迷真故于乐计苦。由随妄故于苦计乐。三不识真故远之。不知妄故随之。故论经云不觉不知而受诸苦恼。虽有三重其旨一也。故疏之中前后互出

疏。既言具苦必知无乐者。此遮妨难。恐有问言。慈是与乐。经中但言见生有苦。何言兴慈。故通云尔。然经慈悲二观影略。悲中睹境却无拔济之言。慈中阙于睹境。却兼拔济之语。二观同缘有苦故。生慈下重举前境。以明拔济成上之悲。置安乐处生下之慈。义皆足矣

疏。一明施所依者。即经随顺如是大慈大悲。则能拔其苦能与其乐。若别说者。财施拔现贫苦。与现富乐。法施拔其当苦。与出世乐。无畏拔现恐怖与安隐乐。文中就初多明于财而言大舍。又云。凡是所有则兼具矣。疏一者外财。二者内财者。前诸会已广。易故疏更不释。论文甚广。今当具出。论释总句。凡是所有一切能舍。云一切物者。略有二种。一外二内。次释所谓下。别中先释外后释内。外中更分总别。释总句。云外者复有二种。一所用。二贮积。如经所谓一切财谷库藏等故。如是次第。释曰。此中财谷是所用。库藏是贮积。经从金银下别论释云。于中广有八种。从金银乃至一切所爱之事。一切所爱之事即今经及余所有珍玩之具。兼取后内以为第九。释云是外事。舍中初舍为总。余九为别。依此有二种喜。一藏摄喜。二利益喜。藏摄喜者。谓金银等。利益喜者。复有八种。释曰。欲兼下内共成二喜故。标云外事有九下释别中第八即是于内。然八中次第异今。今依此经之次。一严饰利益喜。谓珍宝缨络。二者代步利益喜。谓象马车乘。三者代苦利益喜。谓奴婢人民。论当第四。四者自在利益喜。谓城邑聚落。论当第五。五者戏乐利益喜。谓园林台观。论当第三。六者眷属利益喜。谓妻妾男女内外眷属。七者坚着利益喜。谓及余所有珍玩之具。八者称意利益喜。谓头目手足等。后三同彼论次。疏随机所应以何法者。经有三句。此句是总。下二句别。云何所宜。二随力宜。三随现习宜。现习宜者。如浣衣之子。应令修习不净观等

疏。知时已下行相。行相三句知时知量合为一故。开时有三。第三时即知量义。言如是时中宜修定等即涅槃经上已引竟

疏。昼则存心等者。即遗教经。经云。汝等比丘。昼则勤心修习善法无令失时。初夜后夜亦勿有废。中夜诵经以自消息。无以睡眠因缘令一生空过无所得也。当念无常之火烧诸世间。早求自度勿睡眠也。诸烦恼贼常伺杀人甚于怨家。安可睡眠不自警悟。烦恼毒蛇睡在汝心。譬如黑蚖在汝室睡。当以持戒之钩早并除之。睡蛇既出乃可安眠。不出而眠是无惭人也。惭耻之服于诸庄严最为第一。惭如铁钩能制人非法。是故比丘。常当惭愧无得暂替。若离惭耻则失诸功德。有愧之人则有善法。若无愧者与诸禽兽无相异也。释曰。但观所引疏文易了

疏。谓量力所能亦爱亦策勿令过分者。即涅槃经。已如上引。亦如教首楼那调琴之法。言后便休废者。起信论修行信心分。彼约为魔惑故。或卒起精进后便休废。今使勿令过分。则非卒起亦不休废。然疏三时当相以释。亦可此三为初中后。初但明记。次日夜勤修后方不断。此即前惭愧。二利行中者。释经于此行中以后三行摄护前七。惭愧之中已收前七门二利之行。今之二利即前七也。而是惭愧所护行中修坚固也。欲早求度下释勤修。出离已下正显行相之文。此句总明坚固之体。即前遗教之文。不退自分下别释坚固之相。前经已引弥勒问经

疏。利养正行具二供养者。上愿校量中有三供养。一利养供养。二恭敬供养。三正行供养。今以恭敬通上二故。但分财法

疏。第三佛子下结十名体用者。疏文有二。先释文。后然安住下拣法。亦通复重之问。文中有二。先问。后论云下引论答。先举论后前句文略下是疏释论论中无问而但有拣。具足论云。前所说三十句。从信增上等。乃至常求上上胜道。得清净地法。今此十句从信乃至供养诸佛。尽是障地净法。是名修行校量胜。而远公云。前是所净此是能净。意云。前地满故能净此法故为所净。此中十行若无此十地不穷满。故为能净未为得意。不顺于论及瑜伽故。第三果校量

疏。三明分齐等者。疏文有四。初总标分齐。即修非修分别。以修以报各为分齐。二行修唯在下二约当地初后相望。论其分齐。即上二义。遍不遍故。三又初二后一下。约有无论分齐。四又初二果下约法果论分齐。此意正为论主通妨。谓安国法师以见二果之后有结文故。便以前二果唯是地法。后二方是果法。即出心故。故今为通前二通法通果。为法易见后有结故。为果难见故。论判属果。不得此意下结弹安国。疏今云法身即功德法身者。佛地一切通名法身。以约证如十德胜故。见功德身。又约证如来穷极故。真实法身非见相故

疏。理实入华藏下。上约寄位。此下显实。即愿智果中意也

疏。亦兼供僧者。略无法者。已亲证如。真供养故。又此炼行真是修行。法供养故。故略无耳。其供佛中经文易故疏略不释。论云供养者。有其三种。一恭敬供养。谓赞叹等显佛功德。二尊重供养。谓礼拜等。三奉施供养。谓华香等。即衣服下文。其大心深心即能供养心。谓为求佛故云大心。心殷重故名为深心

疏。以同上愿校量中供养愿故。故皆略无。疏去下劣垢。论当第三者。论经亦是第二。论释即当第三

疏。三别地行相中者。初正明。二若不尔下反质成立。三是以具下总明义类以成前理。其五约圆融。一具一切。更有三义。一约相资檀义摄六等。二约相应一念具修。三约理融称性。一多互相摄故

疏。总收三入等者。此所练净有始有终。初但明练。即是其始。后举回向能练令净即是其终。故前论主以回向居二行之后。先明自利利他。后回向胜进故。言信等净法为所练者。即下论云。信等善法。犹如真金数数入火故

疏。第二喻中下疏文有二。先正释喻。后金性本有下解妨释成。于中二。先问。后信等有二下解释。释开二门。地前之信则不喻金。证如之信乃将喻金。如来藏中为惑所覆。如在矿中地。初一净即已出矿地中。地满皆是入火

疏。此二不二并可喻金者。谓真心为体。与信等相不殊。更无有二。以真心上离不信浊。故名为信。二三无有违害。即是慈悲。四无悭吝为施。五无懈。六无愚。七无不重贤。八无不怖罪恶。九无有危脆。十无违佛教。故是十行但一真心而为二义。故无二体。并为本有。故可喻金

疏。虽假供等缘修以成真德者。然第二义自有两义。一约所显性德。二约能显缘修成德。如以知法性无悭贪故。随顺修行檀波罗蜜。今成檀德。克实分别。则初一义可以喻火。对治行故。所显喻金。成德如严具今。且融后二以喻于金。以德因真起故同所显。故云后成严具亦不异金。严具喻于后地。广如前说金例皆金疏既了于真下复融初义。亦不异金。以初妄识为体。今真妄交彻故。妄由真生真该妄末。真非妄外。即妄彻真源。若尔则无能练所练。故云寄相显真故分能所。第二发趣果

疏。一问胜进者。胜进虽向二地。修在初地。亦得名为问初地也

疏。相及得果等者。是所得法相。疏文有三。初依论释相。次出体三再显法体

疏。相即方便智下疏出其体。即同如来加请中三渐次也。言能所观相者。相有其二义。一相差别故。二能到地实故名为相。即观渐次观。即举障显治相。则能所皆相。二得即证渐次。三果即修行渐次。疏又此三者下三再显法体。开根本智以成二道。故不取加行。言地上加行胜进[日*ㄆ]故者。如欲入第二起十种心。此即加行。而是初地之胜进。意云。胜进既是后得故非方便

疏。若准论意等者。今疏意明随地智差别地法。而论云成就诸地法者。所谓信等故。第二知中有三。初略举经意。二论摄十句下论释。三以问摄知。二中言摄十为五者。一二二三三四五一故

疏。行修善巧者。下论云。成坏善巧增长善巧。非詺能知为方便也。此五方便地地皆具。而其随相分别。初一在于解行位中。得在初地。增上在于二地已上。不退在于八地已上。尽至十地。第三增上方便。亦成德殊胜故。行修不顿。初中后别。故有三句。余句可知

疏。若以相等下第三以问摄知。于中二。先以经问摄论之五。后若摄十句者。以经问摄经之知。第三摄报果

疏。初行后愿者。行亦自分愿亦胜进

疏。谓若施若摄者。布施本通二利。今从利他边。说问四摄之初已有布施。何须别说。答有四意故。一布施本是自利。今菩萨行令物仿之。以舍悭贪故。是利他摄中布施一向利他。二布施直论布施。四摄中施乃是摄缘。三布施通于三施。四摄唯约财施。法施乃属爱语中故。四此地正是布施位故。所以别说。经中先明遍施。后常行下常施

疏。如是一切下不失自利者。文中三。初总释文意。二引论释意。二正释文

疏。谓利他事中下第二引论释也。论云言不离者。示现不离自利益故。如是诸念事中行已。成大恭敬除诸妄想。释曰。以论难了故以疏间释成。大恭敬即所念佛等。除诸妄想正是念义。是以前明自利之施。令物除悭。今明利他之行。不失自利。是为菩萨修行善巧。疏所念有十下第三释文。此之十念亦即六念。初三念同。四亦念僧。菩萨僧故。次三功德念。即是施戒。六念中略但举其二。今文广故备于诸度。后四求义念。即是念天。第一义天故

疏。光明功德者。行体清净离垢障故

疏。分别法义者。以词及辩分别法义二无碍也

疏。修行克证禅定胜业者。谓依四禅及四空定发百三昧故。故论云一念发百三昧者。得三昧自在力故

疏。论意取神力等者。论云。以得三昧故。于十方诸佛及佛所加。诸菩萨所修习智慧故。释曰。如金刚藏菩萨。为诸菩萨说十地等

疏。次三有悟机者。一往刹。二光明。三正授以法

疏。是圆融实德故。云过此者。释经复过是数。是数即前出家果中百三昧等论。经此中文广。经云。菩萨愿力示现过于诸数。示种种神通。或身或光明或神通或眼或境界或音声或行或庄严或加或信或业。是诸神通乃至无量百千万亿那由他劫不可数知。论释云。于中身者。是一切菩萨行根本所依故。依彼身故有光明及神通。依光明有天眼。以有天眼见前境界一切眼有五种。应知依神通有音声及行庄严加等。音声者。应彼言说故。行是遍至十方故。庄严者。作种种应现故。加者神力加被故。信者依三昧门现神通力。随众生信利益成就故。业者依慧眼所摄陀罗尼门现说法故。略说一切诸地各有因体果相应知。释曰。后总结因体果相。疏已具释。以前经论并皆易见。例前百身百三昧等故

疏。不显第二离垢地

疏。所以来者。文二。先举论。后言正位下疏释。谓依上见道而有修道。修道修行三学。上正释论。后前地下解妨。妨云。初地岂无戒耶。答意可知

疏。言离垢下二释名。先引瑜伽。后谓性戒下是疏暗引世亲摄论第七。以释瑜伽即拣劣显胜。释成上极远离之言不在作意。而无误故。若具引瑜伽四十八云。如是略说菩萨增上戒住。谓意乐净故。性戒具足故。离一种犯戒垢故。一切业道一切因果了知通达故。乃至云若广说者。如十地经离垢地说。离垢地由远离一切犯戒垢故。彼离垢地即增上戒住。释曰。彼既指此故。宜引彼疏。唯识中言具净尸罗乃有二意。一云具足别解脱及定共道共故。虽第三地始发定增。能离过时此地已满。故有定共。二云或唯别解脱。亦能全离加行根本后起罪故。十住毗婆沙即第一论。入初地品释地名中。疏言邪行下第三断障。即唯识文。先断障。后断愚障中论不释名。摄论云。谓于诸有身等邪行障。意云。身等三业有十恶行名邪行障。谓所知下出体。所知拣异烦恼。俱生拣于分别。分别初地已断尽故。一分唯属此地断者从能障二地下具足论云。能障二地。极净尸罗。入二地时便能永断。释曰。以易不显

疏。由此二下后断愚也。开上一障而为二愚。愚即现行粗重。是种子二。种种业趣愚者。毁责为名。不取恶果。岂名种种业趣。不一即名为种种。种种非一。即是毁责。论更释云。或唯起业不了业愚。谓前一是起业之愚。后一即是不了业愚。非所发业。此二非必能起于业。则其二愚一向是愚。若依此释后之一愚亦愚品类。问所知障不能发润。如何此中能发三业。答唯识第一云。续生烦恼发犯戒业。通所知障。此约误犯故不相违。疏言最胜下第四证如戒为最胜。由具戒故证最胜如。谓此如理最为胜故。如说离欲名为最胜。此亦由翻下是疏释意。弥显戒胜。故智论第十五云。大恶病中戒为良药。大怖畏中戒为守护。死愚闇中戒为明灯。于恶道中戒为猛将。死海水中戒为大船。故云最胜。余如戒经

疏。是以成下五成行。诸论皆同疏。得无等菩提下六得果戒于世间得人天身。故于出世得菩提果。并寄下结示

疏。三聚无误下疏释论科。疏而下列中总句同名直心者。谓今经标云深心下列中总句。则名直心。论经标云直心总句亦云直心则知义一。而疏释深心。云深契事理者。若以深心同论直心。直心即是正念真如。故深契理。若顺起信深心乐修一切善行。即是契事。显义包含。双存事理。疏论云十种直心者。论释总句。言性戒成就者。总该三聚。别对律仪。随所应作下通于二聚。自然而行兼显直义

疏。谓发起下疏释上论。于中有三。初正释。二然性戒有二下释成上义。第二真如性戒成。前发起净中顺理持戒第一久积成性。成前则令自体净中性戒成就。三今称如下双结上二义。疏别中初四下释别句中二。先科后释释中柔软者。引瑜伽意。于他柔软直就论意。是自柔软。柔软即喜乐。则持戒之人心无恼悔故生喜乐

疏。二堪能等者。依此性善持戒是净业也。烦恼已下离业因。既因离果离故。难持能持

疏。所以鹅珠草系下成上能持难持。鹅珠即阿閦佛经大庄严经论第十广有其缘。今当略示。谓有一比丘至金师家。其金师正为王家穿珠。由比丘着赤色衣映珠似肉。有鹅吞之。金师失珠。傍更无人。决谓比丘盗其宝珠。询问。言无。遂加栲楚。比丘了知珠为鹅吞。为惜鹅命甘苦而默。殴击血流鹅来唼血。杖误杀鹅。比丘见已便言珠在。金师问言。何不早陈受斯楚毒。比丘答言。珠为鹅吞。我为持戒惜鹅命故。默受斯苦。鹅若不死。设断我命我亦不言。金师白王具陈上事。王加敬重。言草系者。亦此论第三有诸比丘行于旷野。为贼剥掠衣服罄尽。群贼共议。恐报王知咸欲杀之。中有一贼语同伴言。不须杀之。比丘之法不伤草木。可以草系必不驰告。群贼从之。既无衣服。风吹日炙。蚊蛭虻蝇之所唼食。夜闻恶兽恶鸟之声。长老比丘劝诸少年而作是言。人命无常要必当死。今莫毁戒。说偈劝之。中有偈云。伊罗钵龙王。以其毁禁戒。伤盗于树叶。命终堕龙中。诸佛悉不记。彼得出龙时。能坚持禁戒。斯事为甚难。时诸比丘既闻偈已自相劝诫。引昔作恶。为他杀害丧身无数。今为护圣戒分舍微躯。至于明旦国王出猎。初疑禽兽。复谓尼干。及至询问。具说护戒。王心欢喜解缚称赞。海板比丘同此卷说。此上二句即是行体。后二句行修。三守护根门即修方便。四寂静者。行成离过顺于涅槃。守护根门。前已广引行成离过。不见能持所持戒等。了戒如空顺涅槃矣。疏五纯善下次三摄善中。初一自分摄菩提分善。二者上摄佛善。言如真金者。虽被锻炼精纯无减故。后句离过。又初通摄菩提分善。次句别语戒善。后句亦通离过。七者诸有势力弃而不顾。正是论意。不似难陀下略举戒过于善。例知诸有势力亦因施等之所致故。八九二句明饶益中。前句彰悲正明饶益。后句智导方无爱见。第二自体净疏文有四。一总科。二摄位。三料拣。四释文。今初。律者法也。仪谓轨仪。离诸过恶不违法制。故论名离净。论有二名。初云一者离戒。即后释初门竟云。亦名正受净受即受戒法门。离即随戒行相。不杀等十顺益名善。要期在己名之为摄。离诸过恶名摄善戒。兼济有情名饶益众生。益而离过名饶益戒

疏。此三聚戒下第二摄位可知

疏。律仪通于止作下第三料拣。于中二。先通拣三聚。前二自利。后一利他。前中律仪即是恶止。摄善即是善行。后又初律仪下唯拣初二。初二滥故。于中有二。先正拣。后展转解妨。今初。已是通难。谓有问言。律仪之中既有止作。止即止恶。作即善行。作同摄善何言律仪。但明恶止故有此答。皆百论意。谓论初外道问云。佛说何法。答云。恶止善行法。释曰。杀等诸恶止息不作名为恶止。三业正行信受修习名为善行。外道便为立后重过云。外曰。已说恶止。不应复说善行。内曰。布施等是善行故。谓布施是善非恶止故。复次如大菩萨。恶已先止。行四无量怜愍众生。复止何恶。外曰。布施是止悭法。是故布施应是恶止。内曰。不然。若布施便是恶止者。诸不布施悉应有罪。释曰。此是反难明施非恶止。今翻顺用明不施忍而无有罪。又律仪中作谓持衣说净等。不作有罪。非施忍等。故不同也

疏。若尔下展转通难释成前义。先难后答。初难亦是百论中意。外曰。已说善行不应复说恶止。内曰。止相息行相作二相违故。是故说善行不摄恶止。外曰。是事实尔。我不言恶止善行是一相。但应恶止则是善行。故言善行。不应复说恶止。释曰。此正同今经。杀即是恶。离杀名善。故律义中亦离杀等。摄善戒中亦不杀等故。二难分疏古释下答。先叙昔解。其第二解亦是百论中意。前所引布施是止悭法。答中后决云。复次诸漏尽人悭贪已尽。布施之时复止何恶。或有人虽行布施。悭心不止。纵复能止。然以善行为本。是故布施是善行。释曰。此论意明布施虽有止恶以善行为宗。律仪虽有作持以止恶为宗。斯就正助分成二聚

疏。今更下申今所释。非弹古义。但助成别相耳。大同后义在文易了

疏。今初律仪下第四释文。疏今居地上方行十善者。然十善通佛。此亦不征差别说之人天因耳。故今深玄不合行此。又此善中先离杀者。然小乘四重淫戒最初。初有三义。一者此戒人之喜犯。二者劫初起过此最为先。余之三戒亦皆次第。三者淫爱惑业招润生死。二乘厌离故制在先。今十善十恶菩萨十重皆杀在初者。杀罪过重。善恶皆初。菩萨大慈居十重首。又智度论十三中说杀有十恶。一心常怀毒世世不绝。二众生憎恶眼不喜见。三常怀恶念思惟恶事。四众生见者如见蛇虎。五睡时心怖觉亦不安。六常为恶梦。七命终之时狂怖恶死。八者种短命恶业因缘。九身坏命终堕泥犁中。十若得为人常短寿命。释曰。今但离杀十恶顿亡。故大论云。远离一切杀生者。示现远离利益胜故

疏。二离起因者。其受畜因畜则行杀。为受畜因。有未必杀此则犹疏。故名为缘。其贪等惑起杀则亲。故名为因

疏。二为贪众生者。前则贪财。此则贪味。言今有愍伤之仁者。俗典云。愍伤不杀曰仁。释经仁字恕己为喻此释恕字。即涅槃经第十云。一切畏刀杖。无不爱寿命。恕己可为喻。勿杀勿行杖

疏。二对治中疏文有二。先正释后简滥。今初。言杀生祭祀者。亦百论文。彼论因说舍罪福义。以福舍罪。以无相智舍福。外便救云。外曰。常福无舍因缘。故不应舍。释曰。由前菩萨说舍福因由福灭时苦。是故应舍。外便云。我有常福则无灭因。故不应舍。何谓常福。彼云。如经说。能作马祀。是人度衰老死。福报常生处常。是福不应舍。释曰。今但要彼愚痴故举其过。拣言不同。彼论广破言其无有常福故。是愚痴邪见

疏。此中慈益下二拣滥于中又二。先正拣显因果离。是依主释。今是持业后若尔下通妨。先举妨。从前约本有下释。疏三果行中二。先略释文。后粗中成杀下明具缘成杀。于中三。初依本论正释。二然杂集下引他论会通。三又境相下指广在余。今初四行等者。思即意业。是行体故。言拣错误者。两境历然谓之错。一境易夺谓之误。谓如二人并立。本欲杀东人刃及西人。即名为错。本欲杀张人。王人来替。或居闇处。或不审实。作张人杀。名之为误。本斫非情及欲杀畜。错误害人。亦不成业

疏。五体谓身行加害断命落究竟者。然诸众生揽五阴成假名众生。念念生灭前灭后续。非断非常假立命根。令其色心而得相续。亦刹那灭。前念既灭后念当生。断今不续名为杀生。亦名断命。对前未断名落究竟。故次疏云即拣前四以为方便。余二段可知

疏。一内心止足即离起因者。心足即是不贪故。引廉贞之士。书云。廉士非不爱财。致之以义。意云。此无非理之贪也。文选云。渴不饮盗泉水。热不息恶木阴。恶木岂无阴。志士多苦心

疏。二此地具无尽财者。从初地来檀度满故。即具无尽财故。此地亦具。从然杀中下对前料拣

疏。二对治离等者。慈即与乐故。论云对治者。谓布施故。疏云。则于自资财尚舍而安彼恕己为喻者。我被他盗忧虑百端。则喻于他同我忧苦。言他有二义者。义必有二。而论经但云不坏他财。论云。以不贪故不坏当来资财。以他人易故。论不释

疏。三果行离疏文有三。初分粗细。次而文通为下具缘成犯。后对显差别。二中余处亦唯四缘。今开是他总一缘。成初二缘身拣自身取自身物不是盗故。事拣无情。要是他用。虽非我物他不摄受。亦非盗故。如无主物。想者知是他物。行者即谓思心。言翻终不盗心者。应言盗心取也。若无盗心。虽知他物。应暂用取。或同意取。或拟令他知。皆非盗也。五体谓举离本处者。此是盗业究竟则显前四方便。亦是成业时分杀要。断命不续。淫与境合。盗要举离。如于床上手执其物。虽与境合未名为盗。要须举离。才离于床。纵更不取亦已成盗

疏。杀淫于他下三对显差别。一对杀淫以辨粗细。二又杀有多下唯对于杀显具缘处别。则显盗中通于粗细。以辨具缘

疏。一内心知足离于起因者。起因即贪。贪心难满故行邪淫。二自足妻色。离受畜因者。不足于妻方有邪故。自足故无。则足字两用。一唯取知足属心。二连上自妻足故。离受畜因故。晋译论经下通会二经。自足乃由等者。成彼二经。明登地已上无非梵行。但由寄报示有而已。无有从事。则显自足妻色。知足之言似不惬当但拣淫劮过度。故云知足不妨从事。从知足约心亦不妨梵行者。显今经意。以有知足之言。则有离起因义无贪心故但云自足唯离受畜因耳。亦不妨梵行者。但明心中知足。非于事上知足。正同净名示有妻子常修梵行。则知足之言妙矣。翻显自足之言未有梵行之相

疏。现在梵行净故不求未来妻色者。经说求天五欲修梵行者。名污梵行故

疏。他守护女此为总句者。上取于他妻妾。下取亲族媒定。当中一句为不正中总共护者多人护故。然女有三从。一在家由父。二出嫁由夫。三夫亡由子。纵三尽无由。为宗族所护。言子等者。等取孙侄等。媒定之言通于在室及以曾嫁。上言六亲者。即父母夫妻兄弟之亲

疏。二全谓具足等者。等取半戒十戒及于五戒。以终身故得名为全。疏以其淫境下显无具缘所以。言无想疑者。谓无人非人想道非道想及与生疑。但与境合皆名犯也

疏。约邪淫说者。难言四重之淫境合便犯故无想疑。邪淫之戒岂无想疑。谓自妻他妻想。他妻自妻想。及二生疑。岂无不犯。故今通云。据此即有。今显菩萨于其自妻决修梵行。故不于邪淫而说具缘

疏。违想背心者。设违于境若顺于心。不名妄故

疏。无别贪等以为异因者。贪嗔对杀等即为异因。今诳他思心即是贪等。故无离思之外别有异因

疏。故身三各具三离下通拣三业。此皆论意。然其贪等通与七支而为其因。身三之因亦用思心。然起有难易故。论为此释。是知起因自有二种。谓近与远。身业难起。故明贪等以为远因。隐其思心之近因也。口业易发。但彰思心以为近因。隐彼贪等之远因。故不明因离。且如有人先贪财色。后用思心而起妄语。斯则贪等而为起因。则妄语多因于贪。恶口离间多因嗔痴。又如妻财以不足故。而行淫盗。是知亦有不足财故而行妄语。故外典云。贫不与无信期而无信自至斯则亦有受畜之因。是知论主顺经文略。且从难易及多分说身具三离口四唯二

疏。谓心事。虽实下疏释上论。以其时语恐滥言不应时机。亦名绮语。故显其相。彼绮语中虽是善言。不应时机。亦名绮语。今明回互见时令他损恼。故不同也。疏。以细况粗者。细属于心。声闻不制。今菩萨无心梦亦不妄

疏。此言覆藏之语者。细寻可知。疏即不破坏行此唯约心者。谓若有离间之心发言。则成离间。今无此心故无离间过。无离间心即是离间对治。而论标云。一对治离。二果行离竟。便云对治离者。谓不破坏行。一者心。二者差别。乍观此文。则似论主就对治离中分心及差别。然论意以对治离难解。故别释云谓不破坏行。一者心。二者差别。自是双释对治及果行章。故下释文牒心释对治。明不破坏行。牒差别释果。故疏以心属于对治。以其差别属果行也

疏。如野干诈亲师子者。即四分律有善膊虎。与善牙师子为友。为野干所破。广如彼说

疏。是离间体故名为身者。身苦是体与业何异。身约正破。业约所传。言业之粗细耳

疏。此之四语义一名异者。义即体义体一名异耳

疏。后二明前语体不出二类者。论经无庸贱语。有不断语。而论总释四语之后。有对语不对语鄙恶常行。释曰。即以常行释于不断又重释云。于中现前语者。粗而不断。不现前语者。微而不断。意云。对面为粗。不对为微。不断通二。今以经无不断别有庸贱。故更不举。论中再释

疏。自违于戒者。既能苦他又令嗔恚恼彼深故违恶口戒。亦违自赞毁他之戒

疏。令他违戒者。令犯嗔戒。以忆持不乐遂生怨结。前人求悔善言忏谢。犹嗔不解便犯重戒。疏。润泽者。语必益他名为润泽。故翻苦他令嗔二语。谓柔软者。柔谓柔和。软谓善软。言为戒摄故为柔软。柔和即无毒害。善软即无粗犷。犷谓犷戾。易伤折故。害谓损害。如剑戟故。今柔软故无损无害。论释不犷云受行不断。远公云。常说非暂。故云不犷。故上释犷云易伤折。是故菩萨言必顺道。尽未来际常行善言。斯亦天下之至柔。驰骋天下至坚也。疏。和悦意中而发言者。易系辞云。安其身而后动。易其心而后言。注释云。易和易也。翻上嗔忿。理必然也。疏。说顺人天者。世报适情故云悦乐

疏。又悦意下三语展转相释者。重释此三。上各别配故今展转。谓云何悦意。可乐闻故。云何乐闻。闻者喜悦故

疏。善入人心等者。此以一语翻于三语。言今说顺涅槃故令善入人心等者。等取余二。谓说涅槃则如甘露入于身心。岂如火烧。闻清凉乐岂当热恼。内外冥寂怨结岂生

疏。生三昧故者。总出所以。前则闻时不喜忆时不乐。今闻顺三昧法喜适神。忆其正受轻安怡畅。而言多人爱乐者。论云。怨亲中人无不爱乐。以言顺三昧。何厚何薄。论又云。此语能作二种益。一他未生嗔恨令其不生故。闻爱乐复生三昧。即是悦乐。二者未生亲友令生故。即下身心踊悦。由自身心欢喜敬信。亦令他闻欢喜敬信。欢喜敬信即是踊悦故。疏云自身他身生亲善故。翻前失于相知之乐故。古诗云。悲莫悲兮生别离。乐莫乐兮新相知。世俗之乐尚尔。况出世善友之乐哉

疏。三思而后言者。出论语

疏。略说有三者。一教化生信。二教授生解。三教诫成行

疏。即时字别义者。时即教化体也。以言含于义者。即经义语义即义理亦云义利。疏。有罪者制。如杀盗等。无罪者听。如畜长等。举者。律云。不见不忏恶邪不舍。举弃众外者。为除恶人。今此举者为除其罪。此是彰举非摈举也。言如法举者。具举德故。谓一慈心不以嗔恚。二利益不以损减。三柔软不以粗犷。四真实不以虚妄。五知时不以非时。具此五德名为如法。此云巧调伏。论云。毗尼释以灭诤。毗尼云灭亦调伏义

疏。又此一句下上释决定。下释随时筹量。一则筹量有罪无罪故。律云。知有罪无罪是名律师。二则通皆筹量制听举折等故

疏。总举皆须筹量得所

疏。以贪是业有之本者。有即是业亦是三有。故十二缘中过去名业。现在名有。而贪若未决但名烦恼。决即名业。故为业本耳。不似杀等依贪等心方显身口行杀等事。故云更无所依。所依既非揽因所成不同杀等。故无果行。既无因果安有二离

疏。二他所资用是体者。事但明他拣于自己体即金等。是所贪物体。拣非他用有。虽非我贪不成业如山川等

疏。一所用事谓金等者。然所贪物通于财色。论略举财。亦可于色决贪。是邪淫境故此不论。疏三终起夺想为贪等者。论经有二贪心。经云不生贪心不求不愿不生贪心。多是译人见其言重。略去一贪。复比论经倒为其次

疏。依论次亦倒释经。前轻后重。是则贪心含于总别。总则三句皆不贪性

疏。故意三中要具五缘下拣业异惑。即瑜伽意。本论亦云。前二为细。后一为粗。粗即成业。显今菩萨细亦不起故并不之

疏。治彼染着无利润故者。以善法益。令离彼放逸则名利润。五于发菩提心等者。论云。于发菩提心众生。恐于无量利益行中勤劳疲懈。今摄令起造。治彼疲懈令不退转

疏。非一一别对故云总也者。论云。此慈心等有六种障。此非分别。亦非一障对。释曰。言非分别者。亦非二障三障对前一治。亦非一障对前多治等。故云非分别。今疏但云是总非别已含上二义

疏。增恶名害皆有已生等者。易故不显。若依论中具委说者。自身善法未生令不生。已生令灭。即障善法名怨。自不善法未生者能生。已生者令增长。即增恶名害。后二于他亦然。于他身中不爱事未生令生。已生者令增长。即苦他名恼。他身爱事未生者令不生。已生者令不随顺。即是忌胜名热。疏。前所不说者。上来略论六类之人起慈等六心实则无生不化无益不起

疏。不行占卜等者。邪见有二。此是浅近邪见。非拨无因果深厚邪见

疏。夫吉凶悔吝。生乎爱恶者。即周易意。初会已引悔吝者。言者小疵也。恶凶爱吉。而吉凶尤多。疏此所治七见下上来别释。此下料拣

疏。然邪见恶戒唯是外邪者。邪见唯外。戒取有二。一者恶戒独头而起。此正是邪故偏举之。二附正戒起。今所不取。见取亦二。一执异见。亦独头起。二附内法起。而戒取多独头起故。偏语恶戒。为邪见取少独头起故。多分附内。以难见故。疏家偏明不独起故。故疏云。通内则知有外

疏。后一明信邪者。以信世间为究竟故。故为邪耳

疏。次二是欲求者。即前藏非诈善求五欲故。第二摄善法戒。今初堕恶道者。此即明观。此有三意。一何故知。知诸众生不断十恶堕恶道故。二何因知。由前律仪自断恶故。三何故知。菩萨大悲本为物故。有三种者

疏。依论分三。一者乘恶行往故。此即集因者。论经云。菩萨作如是思惟。一切众生堕恶道者。皆以不离十不善道集因缘故。今经阙集因缘之言。即皆以字摄故。论释云。集因者受行故。谓十不善是所行法。若有受行即堕恶道。疏则非无因等者。论菩萨如是远离无因倒因。善解众生自行恶行住非法处故。非法处者。即是苦果

疏。后起愿行下文有二意。一明起愿之由。由念众生恶因果故。二便起愿故。论通云。菩萨如是深寂思惟已。欲救众生知自堪能

大方广佛华严经随疏演义钞卷第五十九大方广佛华严经随疏演义钞卷第六十

        唐清凉山大华严寺沙门澄观述

疏。第二广观障治下。疏中有二。先总明来意。于中有二。先明观故。论云。复观察障对治不善业道及果。善业道及果。及上上清净后起增上心。求学下即标举行心。全是论文

疏。若直就下释文。先顺经则先明观要心摄善是行。今论既通属佛善。即佛善通于观行。则前四善但明于观。以前三善菩萨不行。其菩萨善先已行故。疏且分为二。先观不善等者。此中总有四门。一障治分别。不善为所治故。二凡圣分别。天人为凡三乘为圣。三大小分别。二乘为小故。四因果分别。菩萨为因佛为果故。四重之中料拣。五重十善不善唯属所治。是故别为一段

疏。以顺理益物正反恶故者。明善是能治。故缨络云。顺理生心名善乖背为恶。又益物为善损物为恶。故云正反恶故

疏。或由三时之心等者。略举四重。一约时。如欲行善时。正行善时。行善已时。三时俱重为上善。随一二轻为中三时俱轻为下。二约境者。如一不杀。不杀蚊蚋为上。不杀畜生为中。不杀人为下善。杀即反此。三约心轻重者。随于一境。如杀一畜。猛利重心。处中心。不获己而杀心。为上中下三品之恶。三重不杀即三品之善。四约自作教他者。具自他为上。唯自非他为中。自虽不作而教他作为下

疏。细论其义多品不同者。将上四事交络相望。则成多品。如约杀境。境是一重。更以重心则为二重。复三时重即为三重。更教人杀为其四重。余例可思。言为不善者反此。可知者此有二意。一者通相前但约不杀。今约杀等。二者如一杀境前来不杀蚊蚋为上善等。今杀蚊蚋为下恶。杀畜为中恶。杀人为上恶等。引瑜伽六十释为不善。至下当明

疏。初标所修善同者。下四十善唯佛一善独云上上。前三但云又此上品十善故。云三乘善同者。若准论经菩萨亦云上上。然云上者。即前人天善中三品之上故。五净居是色界善为上。而圣依此修故。就上善论其差别

疏。次显所用功异者。此语即借庄子第一逍遥篇言也。惠子谓庄子曰。魏王贻我大瓠之种。我树之成而实五硕。以盛水浆。其坚不能自举也。剖之以为瓢。则瓠落而无所容。非不咢然大也。吾为其无用掊之。庄子曰。夫子固拙于用大矣。宋人有善为不龟手之药者。世世以洴澼絖为事(其药令人手不拘折故常漂絮于水中也)客闻之曰。请买其方百金。聚族而谋曰。我世世洴澼絖。不过数金。今一朝而煮技百金。请与之。客得之。以说吴王。越有难。吴王使之将。冬与越人水战大败越人。裂地而封之。能不龟手一也。或以封。或以不免于洴澼絖。则所用之异也。今子有五硕之瓠。何不摅以为大尊而浮乎江湖。而忧其瓠落无所容也。则夫子犹有蓬之心也(蓬非直达者也此章言物各有所宜苟得其宜安往而不逍遥哉)今借此言。一种十善犹不龟手之药也。凡夫用之处乎生死。二乘用之才能自免。则犹漂絮也。菩萨用之兼济无外。则裂地而封矣

疏。于中初句对前彰胜者。三乘皆有胜劣分别。然前劣亦名所观境界。后胜即是能观之行。言以实相智修者。以经云以智慧修习。论经云。与智慧观和合修行。论云。智慧观者。观实相观故。释曰。谓实相者。即四谛理。双照事理实也。四谛之义下当结示。即以智慧心中修十善故

疏。一因集者。昔集小因今成小行。依之集道故名为集。二畏苦者。厌当苦故。三舍心者。即唯求自度。下二兼劣缘觉者。四不及自悟。五不及观缘。彼经云闻声。论云观者。念音声故。何者音声。我人众生等但有名故。释曰。此中论意言声闻者。谓众生我人但有名故。名为念声。义说闻声非要耳闻应具二义故。瑜伽八十二云。从他听闻正法音声。又令他闻正法涅槃。故曰声闻。即声闻声闻。又瑜伽八十四说四种声闻。今是趣寂四声闻义。玄中已明。疏。结成自乘者。论云。如是彼音声解入故。众生无我非法无我。意云。唯生无故。但成声闻乘

疏。然能治下结成四谛为声闻乘恶因恶果二体俱亡。善体不亡。故上为道迷胜义愚等起于十善。此便顺灭。灭此异于人天言成声闻乘义含道灭者。道即因乘。灭即果乘

疏。第三缘觉善者。然缘觉声闻各有二类。总相而说。声闻观谛。缘觉观缘。声闻依声。缘觉依现事。而各成二者。一声闻声闻。谓本求声闻。亦观四谛。于最后身值佛成果。二缘觉声闻谓昔求缘觉观十二缘。于最后身值佛为说十二因缘教。依声悟故名缘觉声闻。言缘觉二者。一缘觉缘觉。谓本求缘觉。于最后身不值佛世。自藉现事因缘得道。二声闻缘觉。谓先求声闻悟得初果。未现涅槃人天七返。七返满已值无佛世。藉现事缘而得道果。今此就其缘觉缘觉以明善法。此人胜故

疏。方便不具力不堪说者。缘觉出世无九部经。故此无所依。故不能说。非是智慧劣于声闻。余可准知。广如瑜伽。本地分中者。有十七地。声闻地当第十三从二十一论至三十四。即此卷中明缘觉地。第十四终此卷。建立缘觉有五种相。一种性。二道。三习。四住。五行。言种性者。谓由三相应正了知一本性独觉。先未证得彼菩提时。有薄尘性。由此不乐愦闹深乐寂静。二有薄悲性。于利生事不乐三有中根性。是慢行希愿。无师无敌而证二道亦有三。一百劫亲承佛修蕴善巧等。二值佛世近善士闻法未得暖等。三已得沙门果未究竟。三习者。依其三种习菩提分。四住者。初名麟角。乐寂静处。后二名部行。亦乐部众等五行。谓依村落等守根正念。神通化物不言说法。又云。一切本来一向趣寂。释曰。今经论中通三种性。总句修习显己有习亦有道。初自觉者。即是麟角。二不能说。即是彼行。亦是前明薄悲种性。三观少境界有二意。前意由有道故。后意通相而明。余多大同

疏。第四菩萨十善疏文有三。初举论四名。次四中下料拣。后言因集下依论牒释

疏。二具足悲愍是菩萨用者。论云。见诸众生习行苦因及受苦时。起悲愍心。意云。见行苦因愍其当苦。见已受苦果悲欲拔之

疏。一观求行证智度满者。论云。三者受大位地。是故求证佛广大智。二尽净诸障断二十二愚。已断二十。唯如来地。亦有二愚。一于一切所知境界极微细着愚。二极微细碍愚。佛善方断。论云。此中但说菩萨地广成便足。何故复说地净波罗蜜净。释曰。此意云第十地净。但用初句即显智地已满。何用后二论。答意云。以下二句显成初句深广之行。谓一从初地来。展转净障至此究竟。故论云。有上上清净故。二者一地一度净故。论云。第一法清净故。第一法者。即波罗蜜义。第五佛善

疏。前三属佛者。是显佛德。唯明观门。后一思齐乃有二意。一约所求德。二地思齐。即是行门。二显佛法殊胜。亦是观门四中。一对凡彰净。二对小彰舍。三通观诸菩萨明方便。四以自对佛明求

疏。一者灭者。谓不善业道。此是止恶。止恶对习故有共言

疏。二者舍者。谓十力等自在成就。十力降魔所作增上。二乘所无。故名为舍

疏。三方便者。通举菩萨善巧修习。令佛十善得圆满故

疏。四菩萨求无厌足。疏文有四。一举经明求。二上虽下拣所行善。三佛善望已下举论意帖。论云。余残无厌足故。四一切智下释经应令具足清净之言。第三摄众生戒

疏。前中显此戒增上者。即论初生起。云已上依大悲利益众生戒增上。上但自善。今悲兼济故云增上

疏。论名时差别者。论就智中云有三种相。一者时差别。二者报差别。三者习气差别。今以后二在知果中。知因是时差别

疏。尽寿作等者。尽寿为上品。多时为中。少时为下。而言等者。此是瑜伽五十三明于百行。亦名百非。十善用之名为百行。十恶用之即是百非。等者等取少分杀多分杀全分杀。自作教人。以无量门称扬赞述。见杀生等深生庆悦。生大欢喜历于十恶。即为百非

疏。余有三品如上十善者。上十善中释三品竟。反例云为不善者。反此可知。瑜伽六十广显差别。今指三品者。彼略有四。一约三时。今已明竟。二约境有胜劣。三约心有轻重。四约自作教他。前十善中胜境不杀善则为下。不伤蚊蚋是上品善。今即反此。如前已明。三约心有轻重者。初义约三时轻重。今约一时即有轻重。故经说言重心杀蚁过于轻心杀人等轻心中容重心以为三品。此心轻重。亦约能起烦恼。有上中下。故瑜伽第八云。软谓不善者。为软品贪嗔痴所起等三品。自作教他。轻重如前善中。故瑜伽六十广说者。正说于恶。论云。杀生所引恶业有其四句。一有作而非增长。为愚童及不思已悔等。二不作而增长。谓思欲杀等事。三俱四俱非。可知余业亦尔。意三业中无第二句。于初句中无不思而作他逼令作。释曰。即上四句。第一为中品。第二为下品。俱为上品。俱非或误杀等。并非三品。上皆瑜伽意。若准如来秘密藏经。大迦叶问佛十恶何者最重。佛答言。杀及邪见。释曰。此即十恶互望。次又云。十恶等乃至小罪坚执名犯。若不坚执乃至无间。不名为犯。释曰。此即约心意明邪见执着为重。言不犯者。意是轻微。故下文中初云。盗塔寺物不名为犯。后言此人因此坠堕。因此解脱。如人自天坠地亦因地起。次经又云。父得缘觉道。子断父命。名杀中重。夺三宝物。名盗中重。母若出家得阿罗汉。共为不净。是淫中重。若以不实语谤佛。是妄语中重。若两舌语坏贤圣僧。是两舌中重。若骂圣人。是恶口中重。言说坏乱求法之人。是绮语中重。若五逆初业。是嗔恚中重。欲劫夺持戒人物。是贪中重。邪见中重。谓之边见。结云此为十恶中重。释曰。此即约境胜劣。但举其重。中下可知。又云。迦叶若有众生具斯十恶。解知如来说因绿法无我无人无法本性常净。不说此人趣向恶道。何以故。无积集故。释曰。此即净名理观忏意。亦是上来无执着心。不名为犯。亦同如来为阇王说。无能杀等非今正要。义便故来令人解灭。疏。依正法念经三途之中各有边正者可知

疏。即人中残报者。天中亦有残报。人中重故多故。所以偏说。疏。杂集瑜伽等论。开习气果以之为二者。即杂集第七故论云。又十不善业道异熟果者。于三恶道中随下中上。受傍生饿鬼捺落迦异熟。等流果者。各随其相感得自身众具衰损。所谓寿命短促常贫穷等。如其所应。增上果者各随其相感得所有外事衰损。所谓外具乏少光泽是杀生增上果。下引经列释。而等流但举其一。多同此经正恶等流其增上果。亦唯举一。唯邪淫果。但言尘坌妄语。则云多诸臭秽。余并大同。然十善亦有三果等流但云谓即于彼处各随其相感得自身众具兴盛。增上果者。谓即于彼各随其相感得外事兴盛。更不别说。亦应例恶得长寿无病等。以经及论不别显故

疏。亦不明差别余报。瑜伽第九大同此说。若准俱舍论云。何缘此十各招三果。答此令他受苦断命坏灭故。且初杀生令他受苦受异熟果。断他命故受等流果。令他失减受增上果。余恶例知。显宗四十四中义亦同此。而以受苦为其加行。堕于地狱。根本断命感于等流。又一师云。先受异熟。后受近增上及远增上。与今大同。则加行根本俱招三果

疏。多是前重后轻者。以嗔恚等流前轻后重。故云多也

疏。若水之流湿者。周易乾卦云。水流湿。火就燥。云从龙。风从虎。则各从其类也

疏。护众生命如护己命下。亦即是前对治离也

疏。依增上悲念众生故者。正释集字。依前摄善起悲摄生。名戒增上。今依上悲欲拔众生。悲心能起利众生事。故名为集

疏。论就别相为八种众生者。此之十心与离嗔中六心有同有异。故论解释亦小不同。前六心者。一慈心。二利益心。三哀愍心。四欢喜心。五利润心。六摄受心。望此十心有四差别。一离合不同。前恶行众生此分为二。所谓恶行及外道故。前摄菩提愿众生。此分为二。谓同行众生。及摄菩提愿众生故同。二通别不同。前于贫乏及苦众生。共起二心。所谓怜愍及与乐心。今此别与。谓于苦众生生安乐心。于贫生悲。三起心不同。前于贫所起怜愍。怜贫苦故。今于非贫所起于悲心。欲拔苦故。又复前者。于乐众生起利润心。令舍放逸住善法故。今起怜愍心。念其当受众苦报故。四前后不同。前第二恶行众生。此为第一。彼第四苦恼众生。此为第三。彼前第一怨仇众生。此为第三。彼前第三贫穷众生此为第四。除此四异余皆相似。疏。于贫苦众生者。前但言苦即违缘逼迫。今言贫苦者。顺缘不足。言愍其放逸者。当受苦故。故经云。福德力故生多放逸。生放逸故即无持戒心。以是因缘故堕地狱。然十句为八者。后三通为菩提。有下中上。下劣于己者。摄如己心。等于己者。推如师心。胜于己者。同于佛也

疏。恶慧恶欲者。论云。恶意恶心。梵云末那。此翻为意。梵云末底。此翻为慧也。声势相近。译者之误。今经为正

疏。我净等者。然其四倒因计五阴依法计我谓想行蕴依身计净。谓依色蕴取像。思虑任运计我。薄皮所覆任运计净。故不假专念。若计心为常。多由思度计受为乐。要对境忘念。则我净如俱生常乐。如分别故有难易。远公以我为常。本净是乐原。便以本末释难易。因说有九种本末。一如起信真如为本无明为末。依于真如有无明故。二无明为本三倒为末。三三倒之中见倒为本想心为末。四三倒为本四倒为末。五四倒之中我净为本常乐为末。六四倒为本生恶道稠林为末。七即此为本起现行惑为末。八诸惑为本诸业为末。九诸业为本苦果为末。今但举第五耳。此之九重于斯非要。亦有少理故复录之

疏。由计等者。计我多欲名计净多欲色。如涅槃者。发心品已引

疏。行于实道者。论释正念。正念即四念。治四倒故

疏。二对怨于心中者。以文不次故举帖之。疏。结上三业者。邪语邪业皆属邪命故。谓宝玩受用者。宝玩即贪。受用即嗔。烦恼所烧通三毒说

疏。然痴有二下别明痴相。疏亦复不知下成上迷。前贪嗔之二即法华意。彼经云。父虽怜愍善言诱喻。而诸子等乐着嬉戏。不肯信受。不惊不畏。了无出心。亦复不知何者是火何者为舍云何为失。但东西走戏视父而已。然彼经火通因果。故彼经云为度众生生老病死忧悲苦恼三毒之火。今此正明三毒之火。宝玩受用亦即果火。故彼经云。亦以五欲财利故受种种苦。失谓不知失于法身。亦是不知苦集过失。此中正明起惑故。疏不引。何者为舍。舍即五蕴。次文用之

疏。二无求出意者。即迷灭道。即是不知何者为舍。是故疏云迷火宅之为乐。是不识灭不解修道。以求出离为无求出意疏。一愚痴者。然其四过皆是集。恶行过痴是根本。谓为现小乐造于罪行。招当大苦故为愚痴。重暗下六字别明三过二字为一。其之所覆障通上二义

疏。二入阴翳下开此过名以为二义。初增恶中阴翳是痴。稠林喻使。使即随眠。由愚痴心与使为因。以因依果为阴翳林故。疏云增长结使。增长结使即是增恶。此增恶事即业之过。此明远善者。论云远离无漏智慧。无漏智慧即是善也。亦由于痴为此善障

疏。三行旷野险道者。疏取论意。按经以释然。此二句论经不同故。彼经云。堕大黑暗处。堕其所见。到种种险道。论释云。受至大对过患。如经堕大黑暗处故。是中对者。黑暗示现。如暗中行处处障碍。如是相似法故受大对。事成至诸恶趣。是故名堕。此释上句多作罪因。于临终时见恶报相。心生悔见过如经随其所见到种种险道故。见险道者。悔见故见本罪相。不能集彼对治正见随其所见者。于死时故。释曰。二经文异。皆上句明果。下句明因。而论经险道在因。今经险道在果。今经旷野即大黑暗处。行即堕义。今疏解释亦不违论。但略受生至大对之言。为受苦报过耳。大即旷野对即障碍。故疏云生死长广即旷野名大。多难障碍即是对字。论语小僻。故按经释耳。经云起诸恶见。即论经随其所见对种种险道。恶见是能对。故论释下句但云多作罪因。于临终时见恶报相。意明。下句是因。所到险道即上句之果。故释上句云受大对事成至诸恶趣。是故名堕。由此今经善得论意译回险道在于上句刊定。不知此意。便合此经二句释论随其所见到种种险道。复将前远善失智慧光明。为论初句。受至大对。或言。今经阙论上句堕。大黑暗处俱不晓也

疏。或悔先所修者。谓解追悔不能修习观行对治。但生追悔以扰于心。故净名令慰喻有疾菩萨云。说悔先罪。而不说入于过去。二疏或起恶见者。谓或平生曾修少善。造罪至多。临终恶报拨善无益。名为恶见

疏。一见如实相者。通于事理。事实明信因果。理实不取诸相。故论经云。得不随他一切如实无障碍智故。疏初句自体者。此句亦总亦别。别即所随生死自体。总即能在。谓修善人也。总疏已明。疏佛虽出世者。具七难故除佛前后

疏。乃至等者。以论云谓梵天等梵世间等以为出世正见故。释曰。梵天是正。梵世间是依

疏。初句依止者。以论经有三句。论云离善导师依不善地。如经远善巧导师故。二者依止怨地。如经入魔意稠林故。三者远离作善知识地。如经远离佛意故。今经以初似三故略无初句

疏。尽论意。合初二句释经一句。依止怨故。是第二句失离恶法。即第一句。以依止怨必失远于离恶之师。此二相成。故得合一也

疏。初一道差别者。然道约轮转故喻河流。界约难出故比牢狱。皆增苦过下明外道小乘多乖道过

疏。求有没中者。造善等业求于有果。名为没中

疏。然其总中者。总以六道为河。今取赖耶恒转也。七识波浪并如前说

疏。故此苦果者。相续义故。如河虽深若无流续则易枯涸

疏。于此生死者。瑜伽八十六明由五种相当知顺流而被漂溺。一若于此漂溺。二由此漂溺。三依此漂溺。四如此漂溺。五漂溺时

疏。已具注于文之下兼解释本论。以经别加四流异于爱故。合四与五以为一漂

疏。由此漂溺者。即瑜伽第二由爱故漂。如河有大名其必深广如恒河等

疏。一显河急者。即瑜伽第五漂溺时也。缓水易度。生死若缓圣道可生。壮色不停刹那迁变。才欲修道三昧已无。此即约果

疏。随欲等者。五尘之境皆有顺违。故生三觉。亦兼八觉。如发心品。此即约因故云依此漂溺。若无恶觉即无漂故。即瑜伽论五中第二

疏。涅槃则以欲等者。即第二经纯陀。反教文殊令显佛无为。喻云。譬如贫女止他客舍寄生一子。是客舍主驱逐令去。携抱是儿欲至他国。于其中路遇恶风雨寒苦并至。为诸蚊虻蜂螫毒虫之所唼食。僧宗曰。为其邪学之所抗折。譬之风雨。未免烦恼吞噬善根。譬如毒蛇虫。今疏意云。经以六道喻河流等。即是果河。应以欲等譬于毒虫。例如宗释。论无别释故引异释耳

疏。第二起难有四者。初一见。次二爱。后一慢。由身见执者。亦即俱舍由二不超欲。由三复还下。释曰。此即五顺下分结。由二不超欲者。即欲贪及嗔。由三复还下者。即身见戒禁取疑。经唯身见。故前行疏云执取之言亦含戒取。是同还欲界之惑。略无疑耳。故贪嗔二如守狱卒。身见等三如防逻人

疏。若准涅槃下欲会论经。先引涅槃。爱见罗刹皆乞浮囊义。如前引回文不尽正会论文。若尽应云水中爱见罗刹故。于中执取正于水即果流故

疏。配蕴窟疏求欲等乐著者。此是论文。初求五欲得己乐楚。众生处处着。故有等言。疏受用事时中我慢大慢憍慢者。多恃才能云受用事。大慢等即三地有文。我慢于等自大故云大慢。于上不恭说为憍慢。自高陵物总显慢义。而云原阜者。尔雅云。高平曰陆。大陆曰阜

疏。四滞枯洲者。论经云我慢陆地之所燋枯。论云。一执。二转还。三中着。四者洲故

疏。皆翻上三段者。谓一自体。二起难。三明失也。六中如一与善因即离自体。既无自体。即无难及失。余五亦然。故云皆翻也

疏。一苦事等者。一鞭杖楚挞故。二费用资财。三亲属分张。四枷锁着体。五垣墙防逻法说五中前三苦者。一病苦。二求不得苦。三爱别离苦。四戒难者。谓后二是业。初犯戒业。上二界离无惭愧故不起犯戒。五见难。当邪见业痴为本故

疏。无始发方便者。则显二是中间所趣不真。三是终造即行不真。此三失道翻有妄集。后三失灭翻有妄苦。前二内苦。一四大即老病苦。二五盛阴苦。三总余五苦。人皆厌苦。由着我故不能得出

疏。唯大涅槃者。翻前失灭得如实法。翻前失道三种如实。前二事实。后一理实

疏。余如涅槃二十一说者。即南经也。北经当二十三。皆高贵德王菩萨品。经中广说三恶觉过。令起六念善觉。后有此喻。经云。善男子。譬如有王。以四毒蛇。盛之一箧。令人瞻养餧饲卧起摩洗其身。若令一蛇生嗔恚者。我当准法戮之都市。尔时其人闻王切令心生惶怖舍箧逃走。王时复遣五旃陀罗。拔刀随后。其人回顾见后五人遂疾舍去。是时五人以恶方便藏所持刀。密遣一人诈为亲善而语之言。汝可还来其人不信。投一聚落欲自隐匿。既入聚中。窥看诸舍都不见人。执诸坯器悉空无物。既不见人。求物不得。即便坐地闻空中声。咄哉男子。此聚空旷无有居民。今夜当有六大贼来。汝设遇者命将不全。汝当云何而得免之。尔时其人恐怖遂增复舍而去。路值一河。其河漂急无有船筏。以怖畏故。即取种种草木为筏。复更思惟。我设住此当为四大毒蛇五旃陀罗一诈亲者及六大贼之所危害。若渡此河筏不可依。当没水死。宁没水死。终不为彼蛇贼损害。即推草筏置之水中。身倚其上。手抱脚蹋截流而去。既达彼岸安隐无患。心意泰然恐怖消除。释曰。上具引经在文可知。下合文广。今当撮略云菩萨摩诃萨得闻受持大涅槃经。观身如箧。地水火风如四毒蛇。蛇有四毒。见毒触毒气毒啮毒。常伺人便性各别异。敬养无益。四大亦尔。又蛇以咒药可治。四大亦尔。应远离之趣八圣道。五旃陀罗。即是五阴。彼旃陀罗令人恩爱别离怨憎集会。又严器仗则能害人。常有害意。遍害一切人无手足刀仗侍从则为其害。五阴亦尔。令人远善近恶。烦恼自严器仗常言一切。若无戒定慧刀善知识侍则为其害阴又过彼。彼害不能令堕地狱。但害有罪。亦不自害。财货可脱。不必常害。唯在一处杀己不堕五阴。反此有智之人。应当远离依八正道六度万行。令心如虚空。身如金刚。一诈亲善以喻于爱。常伺人便令人轮转。但见身口不见其心。爱但虚妄无有真实。爱又过彼。无始终故。难知故。难远故。若有智慧不为其害。空聚落者。即是六入。无人人空器等空者。以明法空。凡夫远望生不空想。菩萨知空。六大贼者。即是六尘。劫人善法不择好恶。令贫孤露作一阐提。无善防卫则为其劫又遇大贼贼劫现在唯劫欲界尘劫三世亦劫三界。唯菩萨勇健有善仆从。不为其劫。直去不回。河喻烦恼。犹如驶流深难得底。堕未至底即便命终。众生亦尔。未至空底即便轮回二十五有。河唯没身不没善法。烦恼反此。故应勤修六度万行。以为船筏至涅槃岸。余如彼经

疏。不定聚众生实有大乘等者。然三聚皆有。且约长时入正定聚动经多劫。故唯不定则可回也

疏。广大佛法者。亦是教道。智慧即是证道。二地竟。第三发光地

疏。所以来者。来意中三。初正明。二引证。三会释。今初有二意。一就三学。二地是戒。三地是定。四地已上皆属于慧。故为次第。则令初地亦属戒收

疏。又前三下二约寄位。谓初地为施。二地为戒。三地为修。此三所以名世间者。世间有情多分行故。故俱舍云。契经说有三福业事。一施类福业事。二戒类福业事。三修类福业事。此云何立福业事名。颂云。施戒修三类。各随其所应。受福业事名。差别如业道。释曰。类谓性类。此三各别。一类性故。定名修者。颂云等引善名修。极能熏心故。谓离沉掉名之为等引生功德名之为引。此定地善。极能熏心令成德类。故独名修

疏。故深密下引经证

疏。此则具前下三会释也。谓一前位持戒未得等持。即三学意。二既言未得世间等持。即寄位意。在文可知

疏。言发光下二释名。于中三。一叙异名。二申正解。三总结拣定。初中金光者。即第三经。经云。无量智慧光明三昧不可倾动。无能摧伏。闻持陀罗尼为作本故。是故三地说名明地。言十住论。即十住毗婆沙。当第一仁王下当释之

疏。今统收下第二正释。后故瑜伽下引证。于中四。一正证闻持等而为所发。二由内心净下证明三学三既言下疏指后义释成能发四摄。论下引例释成。摄论即当第七。论云。由无退转等持等至所依止故。大法光明所依止故。名发光地。世亲释云。由此地中与三摩地三摩钵底常不相离无退转故。于大乘法能作光明。名发光地。无性释曰由无退转等持等至所依止者。谓此地中证希有定。能发智光。明了诸法故名发光。得已不失名无退转。诸静虑定名为等持。诸无色定名为等至。等持者。心一境性。等至者正受现前。大法光明所依止者。谓此地中与定相应无退转故。于诸大乘契经等法得智光明。此地是彼所依因故。名为发光。释曰。此二释论皆当第七。大同小异故

疏。略指同于瑜伽。次云金光明者。如前已引

疏。二以闻持能发下即第二前所发以分能所。于中三。初正立。二以闻法竟下以闻释成。三故瑜伽下引证结成

疏。三以胜定下第三会。取第一二种所发以为能发。于中分二。先正立。后故下论云下引证。于中四。一引本论。二引唯识。三谓由得下释唯识意。以成前义。四故上下引上本分成唯识义

疏。余诸经论下第三总结拣定上。恐学人欲见异释故委出之。实无异辙。余论之言今当更出。显扬第三云。三发光地。谓诸菩萨住此地中。善修治第二地故。超过一切声闻独觉地。证得极净三摩地。蕴大智光明之所依止。是故此地名为发光。则亦不异前矣。又上言仁王名明慧地者。即下卷中明三贤十圣。各修一观门皆名法师故。故经云。大牟尼言。有修行十三观门。诸善男子。为大法王。从习忍至金刚顶。皆为法师依持建立。今言第三地者。彼经云。复次名明慧道人。常以无相忍中行三明观。知三世法无来无去亦无住处。心心寂灭尽灭三界痴烦恼故。证得三明。一切功德观故。释曰。立名小异义理同经

疏。故十净心下此前总结。此下拣定也

疏。若所离下第三离障。初举本分。其名委具。二引唯识立名。则总释义委具。于彼论中先释障。后释愚。障中忘失三慧故名闇钝。三慧别障如下愚中。今但总说后由斯已下释断二愚。一欲贪愚。但略举愚。应有问云。上标所知今何得举欲贪烦恼。答彼次论云。彼昔多与欲贪俱故。名欲贪愚。今得胜定及修所成。彼既永断。欲贪随伏。此无始来依彼转故。释曰。以欲贪故。多住散乱故。障定修慧。以此欲贪依障而转。障尽欲亡

疏。二圆满陀罗尼下此持通四。一法持。二义持。三咒持。四能得忍持。以闻思慧与彼闻持极相近故。所以偏说非不障修

疏。苦约所证唯就总持者。四证如以明所流是教法故。然所证如。论自释云。此有二意。一由得三慧照大乘法。观此教法根本真如。如即胜流故。论释云此如流教最为胜故。二若证此如。说法胜故。故疏结云。能舍身命求此善说。善说即胜。然舍此身下即无性菩萨释摄论言。谓此所流教法最胜。故舍身命求此善说不以为难

疏。其所成行亦唯禅者。即下厌分及求法行。即方便摄行。庄严论云。第三住能生欲界。而不退禅

疏。其所得果亦法及禅者。下引梁论证于得法。引金光明证于得禅

疏。前中四分者。疏文分三。初总科。二此地修禅下解释。三亦可下对属三心疏则异前。二地下疏取彼经以拣今文言更以十心者。能念即此地初十心。于禅定中求欲深故。所念即是二地即十心。以欲求禅却念净戒。戒清净故乃得禅定。次引瑜伽证成上义。先明所念。后复由余十下即是能念。起此十心在于地前修成下中。未入此地故成上品。方入三地。三地即是增上心住

疏。初言净心者。然十皆清净。初句兼总偏得净名

疏。依不舍自乘者。谓所住大乘之法坚心不动。此句是总。下及前十者。即前地十不舍净戒方得定故

疏。若不胜进即名为退者。此未得不退故。论云。五依不舍自乘胜进

疏。谓自他烦恼者。释云二地。二地有何烦恼。谓障三地者。是二地惑。今不现前。故云不坏。疏。等至八禅自在者。论云。三摩提自在。三摩提是古梵语。即三摩钵底。此云等至故

疏。皆以有智故不染烦恼者。以有智故。庆快殊胜处染不染

疏。此广大二心与前后有异者。诸处有智上求为大。有悲兼物为广。前地亦以不染为大。利他名胜。今以利他非小乘故亦得名大。智不求狭亦得称广

疏。厌行分中二。先正科。后又此下摄位。前二自分。后一胜进自分。护小乘之过胜进依前进修

疏。命行二字是所无常法者。即经有为字。此同涅槃我观诸行悉皆无常。疏云何此无常即前命行者。命行是论经即有为此问无常所以亦无常法

疏。何者是无常即前不住者。不住是论经即无常字。此问无常体相故。下经云刹那等。故疏论云。依身转时力生三种苦者。内报迁移名身转时。从触生受从受生苦。已是无常况三苦更起。故是无常。由转生苦。故转为力

疏。形色增损者。食为便利资内污秽垢污不净显现于外。故云不净。以增损故即是无常

疏。依不护诸恶力等者。论经此句亦云无常。远公云。此以无常显于无常。以夭寿等粗相无常。显于有为法性是无常。无我理细不显无常。今经异论。云不安隐故

疏。直释不配无常及与无我。而通两意作无常释。不异远公作无我者遇缘夭逝不自在故。下第五句正无我所。故彼疏云。不定我所反显我无

疏。然无常有二种者。远公云。应有三种。一分段无常。分段两向用之。向前为无常所以。今此为无常体性。故此分段不出此二少时。亦名念念无常故。次经云。刹那生灭四相迁故

疏。二自性不成实下疏文有四。一总释名。二即下三句下别释经文。三约三世迁灭下结示文意。经从前际生即是生义。今非从故名为不生。向后际去即是灭义。今非向故名为不灭。亦应不住。不住通于无生无灭。为对生灭是无常义显不生灭是无常义。顺净名故。四此中三世约相续门下拣门不同。谓诸经论中辨法有二。一相续门者。约就三时以辨一法。当知是法从于过去来向于后世。如人说言。我从生来向于老去。今是此门故云非从前际生等。二以三时对别诸法。名生灭门。是则一法随时为三。三法相望。过去已去。当者方来。现者今住。故引有部。从未来藏入现在等。则谢往名过。过往背今称之为去。在当名未。当起之法。趣现名来。亦可来者是其现义。当法未现名为未来。今名现法。住现相故名为现在。依此门辨无生灭义故。今依前门故。于未来义则可具言。过去已灭。未来未至。现在无住。故无生灭。今依前门故。于未来却名不去。是故结云二门不同

疏。第二至无救者。无常理定非物能裁。故云无救。如四方山来。即涅槃文。如四谛品

疏。别中九高约生老病死者。科文即为四段。初四约死。次二约资生。第七约老。后二约病。而生过不约人所爱故略而无之。就总相言约生老病死。又生一种。含在资生等中。以诸增长位总名生故。又此四段亦摄八苦。二即求不得苦。死兼爱别离苦。病中有怨憎会苦。五盛阴苦通在于四。今初死苦望之远近。故有四句。初言未至者。自少及长皆归死门。一息尚还。假言未至。临风微烛何所依凭。文殊云。生死有畏菩萨。当何所依。净名答云。菩萨于生死畏中。当依如来功德之力。凡夫无此故无所依。二死时将临名为既至。故无常经云。云何保形命不觉死来侵。三死相现前者。诸识昏昧六腑空虚。余息淹淹心魂悄悄。或随业报中阴现前。内识外身皆有死相。阴转死相即曰中间。难向死门故多涕泗。四正舍命风刀解体。故曰分散。气绝神逝名舍命时。故无常经云。命根气欲尽。支节悉分离。众苦与死俱。此时徒叹恨两目俱翻上。死刀随业下。意想并慞惶。无能相救济。五根已苦不能安排。将前忧悲随逐于苦。增心热恼。言同住者。即是与心相应义也。明此死人但与忧悲苦恼同住故。六地云。死时别离。愚迷贪恋。心胸烦闷。为愁涕泗。咨嗟为叹。在五根为苦。在意地为忧。忧苦转多为恼。若准涅槃。直观于死自有十义。云夫死者于险难处无有资粮。去处悬远无有伴侣。昼夜常行不知边际。深邃幽暗无有灯明。入无门户而有处所。虽无痛处不可疗治。往无遮止到不得脱。无所破坏见者愁毒。虽非恶色而令人怖。致在身边不可觉知

疏。次二约资生者。非唯不知追求受用皆悉是苦。亦不知前皆悉是苦。亦不知前皆归于死。而初追求爱顺憎违。求顺不得即求不得苦。憎违而至即怨憎会苦

疏。六苦多乐少者。且顺妄乐名为乐少。积而祸集已是苦矣。散而贪恋斯苦更多。亦爱别离苦也

疏。七于身老时者。第三约老明无救也。壮色不停犹如奔马。西日黯黯熟能驻之

疏。后二约病者。初一少时病。后一老时病。言病因者。乐受生贪。则房色竭其骨髓。滋味煎其肠藏。安得不病苦受生嗔。则愤恚填于心胸。不思危难安不病哉。痴则愚暗不识是非。动皆颠坠安不病哉。九中然老亦病因。而不云因者。老亦即病。谓年耆根熟形变色衰。饮食不能气力虚微。坐起苦极余命无几。岂非病哉。况加客病难复再康枯柳遭霜生茂无日。随风坠叶归树何期

疏。论云后三句皆明身患事何故不在初说者。问意云何。谓前四后三是老病死同身患事。何不一处并而说之。而于中间间以追求。答云示身数数患事者。为欲彰身患事非一。遍于老少故分两处。言可卒加者。病之与死皆可卒至。故复应问言。既云患事非一。何不前明老病相耶。则应答云。死过重故。故前疏云此相显故

疏。菩提菩提断等者。如前已引智相智性即法华意

疏。上二妙用自在者。结上句当体显用。下句寄对显胜。然此五句皆有摄功德大。疏文从略下清净亦然皆带总句。疏三大义下三句。亦前二正明德行圆满。后一寄对显胜。不杂外道故。言大义者义即义利。利他德广故名为大。疏四无讥嫌者。净德殊胜故。无杂者。论名不同摄功德大前云寄对名为无比显胜踰越二乘今云不杂。即胜过外道

疏。一无恼即离惑习无明不杂故者。四住之结名之为惑。四住种子名之为习及无明住地三类皆惑故并不杂。杂即恼故

疏。若依根本亡故忧悲随尽者。身受名苦。心受曰忧。先由身苦后起心忧。是故说苦以为根本忧为涅槃巨害。故偏言之。若据根本应言无苦

疏。一得体等者。无忧即无上苦。无畏即无于惑。惑苦双亡名为无余

疏。二得用者。对上体言无住涅槃。即体用双具。即具大智故不住生死。具大悲故不住涅槃

疏。由俱不住下疏释论也。论云菩萨至涅槃城不复退还。而能利益众生。得世间出世间胜事。疏释意云。由不住涅槃能入世间。由不住生死能出世间。此二无碍即是胜事。胜事即无住涅槃故。无住涅槃唯佛方得名为胜事

疏。以斯为业则翻有为之业者。以前菩提涅槃但无惑苦。不言无业者。以有利乐之业不与惑苦共俱故。翻有为之业耳。上来亦即净乐我常

疏。谓见佛智胜利者牒前护小有为下牒前护烦恼行所以不次者。为顺生后悲心便故

疏。今众生上远慈尊下。此有两重父子。一约人。上远慈尊是孤。不化众生是独。二约法。又无方便为孤。方便以为父故。又阙善心为独。善心成实男故。疏次三依有求。由迷四谛故。前二有障后一无治。故不证灭

疏。空知此辈皆是增上慢人者。即法华经文大意。未得究竟。谓为究竟故。然此上文多同二地。彼以广解

疏。又上总别下上依论文此直就经耳

疏。第二决志救度中。疏文有二。先依论释。后申别理。前中云初三何处救度等者。论为三段。此是第一。次五度行。论云。以何救度后一度果。论云。云何救度。成疏文皆具。然初度处三道。论主皆有妄想之言。谓皆妄想因果可除断故

疏。定慧合说者。问此非慧也。慧合定中亦非戒地。戒何别说。前戒已成不依定故。此中之慧是定中慧故。疏灭除沉掉故云调伏者。沈是昏沉。是定顺障。是慧违障。掉即掉举。是慧顺障。是定违障。定多易沈。慧多易掉。故名顺障。沈不明了。掉不寂静。故名违障。论云灭除沉掉随烦恼使者。沉掉即是随惑使即随眠种现俱亡故

疏。更有一理者。第二申别理也。于中初附论申。次然三学下通不次妨。后若直就经下一向别说

疏。第三修行方便摄行中又二先释行名。后文分下科释。今初就方便摄行之相

疏。文已具今先略示。谓菩萨因前三种观故。知生死多过众生未出。佛智大利众生未得。便念众生堕在众苦。何方拔之令得涅槃。即知不离无障碍智。乃至不离善巧多闻。遂求正法。得已思修入禅无色。依定观法得无生慧。依无生慧。生如实觉。依如实觉得无碍智。便能拔众生出生死苦。得涅槃乐。摄相如是。疏。牒前二行为三因者。二行即护烦恼及护小乘。护小行中有狭及小。故有三因

疏。护烦恼行为离妄想因者。谓三杂染皆为妄想故。疏前释三种杂染皆名妄想。二由念众生常在世间不舍离故。三知一切智智下名精进因者。非勇猛求不能证故。问上文先求佛智后念众生。今何在后牒佛智耶。答前由先念众生处有为过佛智胜利不能得之。故起悲心悲其处过。后求佛智拯此沉溺

疏。论经具有者。彼云。此诸众生堕在大苦烦恼业中。疏第三思得方便于中五。一总举文理。二言有五者下列其名位。三然此五下总显文意。四此五之中下举论总释。五正释文。四中又二。一出经意成论为三之由。二论依此义下正举论释。而论总云是中方便摄行有三种。问前来岂非方便摄行。何以至此始云摄行。答上之二段牒前起后。方欲傍求未得名为方便摄行。今此求得摄生方便。方得其名。证中最极名毕竟尽起中渐增名为上上。第三可知。疏释如实觉云随顺如实觉者。论总云彼尽。以如来所说一切法随顺如实觉起故疏分论文两段释之。先释一切法。而远公云。如来所说一切法略有二种。一三地中从佛所闻之法。二当地中诸佛七劝所说之法。今于此二起如实觉。如实觉者。随顺相应故。一顺三地所闻法。起得无生忍及深行等。疏依此义云因音声忍得无生忍。然无生忍从四地起。亦证三地之中所闻法故。成于顺忍。顺忍之力得于无生故。以顺忍释。论随顺三地所闻即音声忍。二对七劝得如实觉。即八地中得无量身及净佛土。十自在等得劝之后方成此故。今约展转故略不明

疏。三此觉不离无生慧下。第三方便无自相行及共相生为慧行故。疏文委具

疏。得三地满胜进分禅者。净禅有四。一退分。二住分。三胜进分。四决定分。今即第三四。即下于四地决定能发

疏。谓即三地禅中之智者。即修慧也。是下经中观于诸法不生不灭。明是三地自智慧观

疏。彼四地之慧下拣今修慧。但是四地证前相故。寻求趣本。故名彼慧以为光明。由此三地得名明地

疏。此中修慧由闻慧故者。论云。此是彼起依止行。闻慧方便是起所依。是故修行名彼起依止行。意云。由闻解修故。修求闻之行

疏。三节皆慧者。一四地证慧。二三地修慧。三求法闻慧。瑜伽八十三云。慧有多种。言慧光者。即闻思慧。言慧耀者。即修所成慧。然此第五即是闻慧

疏。初结前标后者。标云正法通于教义。五重方便本由求法。故于正法倍复增求。疏。初文有十下分之为二。先释后料拣。今初。十句即是三慧。而有四节。初三唯闻。第四五六通闻思慧。第七唯思。后三唯修

疏。无慢心故者。有慢则不求。二不妒他解故生喜悦。乐法故问。无折伏他心。好心好法名之为喜。终时爱味说以为乐。疏八到法下于后三中初一是定。后二是慧。若随位分到法初地。住法即是四地已上。行法即当八地已上

疏。九住出世间智故者。即释经住法。而论经云。归依法。论释云。依出世间智故。谓四地证智是所归依。疏若望后厌分下第二料拣。于中三。初慧行料拣。二于中初日夜下。能所求料拣。以显勤行者。此即三地能求法行下九皆是所求修行之法。三又此十句下能所受分别。言思通教义者。始依教思。终则依义

大方广佛华严经随疏演义钞卷第六十大方广佛华严经随疏演义钞卷第六十一

        唐清凉山大华严寺沙门澄观述

第三厌分。论云下。问答生起先举论。二不乐下。疏释论。先释厌名。其无量下通妨。以是厌果非厌分故。通意可知

疏。经文下。科释为七相。约义不同。束为三者顺文分段

疏。今初此菩萨下。释修行中三。一正释文。二引瑜伽通示修证。三以经意总相圆融今初。即取次下作意释。此中四相文皆有四。初中四者。一得闻法已。即牒经文。二即依何修者总示义相。三以依正法故者。即释成上义。四即了相作意者。以论义收。下瑜伽中为顺世禅了欣厌相。即厌下苦粗障。欣上净妙离。今云正法其义通深。若约寄位全同瑜伽。若约勤求净菩萨行。则所闻法必当深妙。如下夜神所得四禅。下三各四例此可知。疏次摄心安住即第二相。言即摄乐作意者。下瑜伽释少分触证。是加行益相

疏。次于空下即第三相。言即远离作意者。下释远离。云与断道俱。今空闲处何名断道。故上疏云空闲通事理。理之空闲即是道断

疏。次作是思惟即第四相。言即何故修者。是修所以。良以不修则不证故。言即胜解作意者。下释正是修行。谓胜解于境印持为性。不可引转为业。是故修行非此不成

疏。瑜伽三十三下。第二通示修证。于中二。先正引论后对文显示。前中略释从此超过闻思惟用修行。于所起缘相。发起胜解。修奢摩他毗钵舍那。数修习已。如所寻伺粗相净相数起胜解。如是名为胜作意。前五可知。六加行究竟作意者。论云从此倍更乐断。修习奢摩他毗钵舍那。郑重观察修习对治。时时观察先所已断。由是因缘。从欲界系。一切烦恼心得离系。由此离时伏断方便非是究竟。永害种子。当于尔时。初禅静虑地前加行道已得究竟。一切烦恼对治作意已得生起。是名加行究竟作意。七加行究竟果作意者。论云。从此无间由是因缘。证入根本初静虑定。俱行作意名加行究竟果作意。释曰。论就初禅略释其相。后例所余。今疏总举故取大意。略释而已。下例可知

疏。上修行中下。第二对文显示下。八定中各有后二者。谓即离欲恶不善法等。是加行究竟作意住初禅等即加行究竟果作意

疏。故此总修下。亦总发者然有四句。一总修总发。谓总相修行不偏修。一八定俱起名为总发。二别修别发。谓偏修初禅发于初禅。修二发二修空发空等。三总修别发。总相修行唯发一定等。四别修总发。谓唯修一定发得多定。前二如修后二不如。其故何耶。宿世偏修。今虽总修唯发一定。如地有一种雨。虽普润唯一芽生。四则昔修多门。今虽修一诸定齐发。如多种子共在一处。少分沃润诸芽齐生。望定现前名之为发。望人修得称之为入。然此即是天台之意。今菩萨总修下皆总发。若别修相具如瑜伽智论等说

疏。然皆即妄下。三以经意总相圆融。所以融者。以文毕历别更引瑜伽。欣厌等言。恐谓全是故此拣之。以寄位故引法相宗。证成经文。据鸟迹意理须融会

疏。初结前即何时修证下疏文分四。一正释文。二论经下。对彼辨异。三今经阙下。引今经阙。反成论有四。但前下出经无意

疏。广如别章者。大乘法师法苑法华疏等。皆有其章。今疏四门已略其要。初入意中四。一直显经意。二论云下举本论释。三又示入禅下。会通权实。四然无量下解妨难。二中先问。远公云。菩萨正应修习出世道禅等。世法何要入耶。答为五种众生故。有四类法。四等开故。故成五种。言五为邪归依等者。邪归之人智慧微薄。取信耳目。故为现通方可信受

疏。先释四禅等者。疏文有三。初正释。二故瑜伽下引证。三是以静能下拣定

疏。次无色下二释无色。其超过违害及无容生。三相云何。言超过者。地法增胜故。言违害者。违害有色故。言无容生者。如火中华故

疏。无色谓无色者。所引俱舍皆是定品。二十八论下当具引。言俱舍论中广破有色者。论云。皆无色故。立无色名。外难云。此因不成许有色故。次反征云。若尔何故立无色名。彼答云。由彼色微故名无色。如微黄物亦名无黄。论主问云。许彼界中色有何相。若彼唯有身语律仪。身语既无律仪宁有。又无大种何以造色。若谓如有无漏律仪。不尔无漏依有漏大种故。又彼定中亦遮有故。若许于彼有色根身。如何可言彼色微少。若谓于彼身量小故。水中细虫极微之物亦应名无色。亦身量小不可见故。若谓彼身极清妙故中应有色。若谓彼身清妙中极。应唯有顶得无色名。如定生身有胜劣故。更有广破略知其旨

疏。一修得俱舍云。是善性摄者。颂云。静虑四各二。于中生已说定。谓善一境。并伴五蕴性。释云。静虑有二。一生静虑。二定静虑。定即修得。言于中生已说者。即世界品说十七天即生静虑。即以无覆无记五蕴为性。今疏具有言善性摄者。此言犹漫克实言之。以善等持而为其性。言心一境性者。谓能令心专一所缘故

疏。无色下出无色体。于中二。先正释。就小乘明。后诸教料拣。今初引俱舍云四蕴离下地者。次后偈云。并上三近分总名除色想无。色谓无色后。色起从心。今此正引初之七字。出无色体。谓亦用善性摄心一境性。以善等持为其自性。但并助伴唯除色蕴。无色无有随转色故。其离下地自属别立。四名不同在一句中。因便引耳。下方别释

疏。若大乘宗下。二就诸教料拣。无异辙者。即通诸教。若会相下。正明始教。若事尽理现下。辨终教。从泯绝已下即是顿教。若事理圆融下辨圆教

疏。四禅之中下。疏文分二。先义理。后释文。文前分四。一等立四支。二历禅有异。三举其实法。四建立所由今初分三。初列支名。次四中后三下料拣同异。后虽后后下通妨。妨云。从初一非支上生难。难云。即初离障皆非是支。二禅离障云灭觉观。觉观即是初禅二支。何言非支。今答云。虽是前支于我非支。余二亦然

疏。然四禅通说有十八支者。第二历禅有异。于中又二。先正明。后出所以。今初。俱舍颂云。初禅具五支。寻伺喜乐定。二禅具四支。内净喜乐定。三禅具五支。舍念慧乐定。四禅具四支。舍念中受定故。今疏云初三各五二四皆四

疏。为欲恶下。出彼立支多少所以。病深药多贼微兵少

疏。其间除重下。第三举其实法。此依大乘三事行舍异。后舍受

疏。若分二乐则有十一者。俱舍云。此实事十一。初二乐轻安。内净即信根。喜即是喜受。谓初二禅乐。是轻安乐。第三禅乐是乐受乐。故成十一

疏。内净无别体则唯有九者。谓俱舍内净即是信心。大乘杂集等。但合第三禅舍念正知三支。以为内净。无别内净故。但有九

疏。此等皆为顺益下。第四建立为支所以。以益于禅故。支即分义。及因义故。瑜伽下引证

疏。一烦恼欲二事欲者。烦恼约内事欲约外。内心不与欲贪相应。名相应离。不染外境名境界离

疏。寻伺心粗细者。即是界品。释曰。寻为寻求伺为伺察。心之粗性名之为寻。心之细性名之为伺

疏。国土等者。等取族姓觉及轻安。觉即是八觉。广如发心功德品说

疏。三离生喜乐者。瑜伽十一明断除五法。谓欲所引喜乐。及忧不善所引忧喜及舍。彼五受故生喜乐。言喜者深庆适悦乐者。身心适悦得无损害及解脱乐

疏。庆离欲恶等者。等取不善法。言身心猗息者。猗者美也。此轻安乐异解脱乐

疏。得大轻安身心调畅有堪能故者。即引文重释轻安义唯识第六云。轻安者。谓远离粗重调畅身心堪任为性。对治昏沉转依为业。释曰。谓离烦恼粗重为轻。身心调畅为安。令所依身轻安适悦。名有堪能

疏。顺瑜伽略不释轻

疏。四住初禅等者。先释依止。后而言初下。释初住字。第二禅

疏。觉观粗动发生三识者。谓眼耳身。远公云。初禅之中觉观有三。一定心。二出定时。三识身力粗动觉观。此三并是动乱之心。二禅胜静皆尽遣之。二内净之义前已总释。此具二宗。显扬杂集名内等净。显扬第二云。谓为对治寻伺故。摄念正知于自内体其心舍住。远离寻伺尘浊法。故名内等净。杂集疏云。所言等者。谓内定体由离寻伺体得平等舍住。又念慧非一故名平等。若婆沙云。谓信平等令内心净

疏。前灭觉观下通妨。妨云。谓上灭觉观。今复云无。岂非重复。答意云。前举觉观是此所灭。云显所治。此言无者。不同初禅。用此觉观以为能治。云显能治无。远公云。前灭觉观。如呼灭谛以为无染。此无觉观。如呼道谛以为无染故

疏。本论释一心云下。先引论。后欲异世间是如实修下。疏释论文。上释无漏。此下释一心。然论经一心云心行一处。今释论文。乃以二意释行一处。谓一以不断三昧。即约无漏相续无间。即竖说一心。二以行一境者。约事对缘横说一心。由二禅已上唯以意识行法尘故。从由此即名下。结成三昧无漏。但缘一境即是三昧。今复相续故。是无漏无有漏法来相间故。瑜伽云。世间静虑但舍彼品粗重。不舍种子。无漏静虑二种俱舍。故无有间

疏。如净鉴止水者。欲恶如泥。初禅之定如净动水。今无欲恶复灭觉观。如净止水。是则初禅庆其所离。此庆所得得亡照故

疏。若智论下叙异释也。前解定生。定在二禅。今云定生定在初禅。背于初禅有觉观定。得二禅故。欲界无定为可背故。初名离生

疏。二禅虽离下通难。难云。初禅离欲恶即名为离生。二禅离觉观。亦合名离生故。为此通。通云。初禅离欲恶。无定名离生。二禅离觉观有定名定生。然其设难唯难前解及通难云。初禅有定二解俱成欲界无定为所背故即成前解。初禅有定为所背故。即通后解

疏。初禅离欲大障者。约障大小解离欲大障。初名离生。二无大障。二不名离。第三禅疏。一住舍者即是舍。数者。谓是善十一中。一心数法。善十一者。唯识颂云。善谓信惭愧。无贪等三根。勤安不放逸。行舍及不害。今明行舍即是其一。彼论释云。言行舍者。即精进三根。令心平等正直。无功用住为性。对治掉举不寂静住为业。释曰。此即四法为体。故云精进三根。三根即无贪等善行故。次疏云拣非舍受。舍受唯是无记。非是善性故。行舍善性。故今拣之。行心调停者。行舍通舍贪等三不善根。今对二禅之喜云舍喜过故

疏。显扬下引论显于舍相。唯识通说行舍。显扬正释三禅中舍。故云住舍

疏。于已生喜不忍可者。不忍可言即是舍义。言疏平等正直无动安住者。三品舍相一同。唯识平等为初。离沉掉故。正直为次。于染不怯故。无动安住为后。即寂静住。即上唯识云无功用住。不忘明记为念义故。远公释云。念前喜过守心一境

疏。三正知者。正知即慧。远公云分别喜过。而言正者。论名安慧。远公云。慧静名安。安即正义。静鉴双流故名为正。正故得安

疏。上三下结成胜义

疏。设心受乐者下引瑜伽色身意身俱名身故。故瑜伽下引证。于中有五。初明能治。二令心下显其治能。即前离喜。三离喜寂静下生起下文身受乐义。明是离喜之乐。故云与喜相违心受生起。心受生起即意身受乐。四彼于下正释身受乐义。五是故下结释经文。上约根本说故。远公云。身受者受有二种。谓身与心分别有二。一约根本分别。五识等受依色根生。故名身受。意识中受从意根生。故名心受。二约所益分别身心。下品之受适畅在心。名为心受。上品之受适遍身心。就所遍处从末为名。故曰身受。今从后义。乐实心法。此处增上遍满身心。故说身受。显乐增上乐。是心受之义不待言说。释曰。远公有二义。意但取后。今疏具用。上引瑜伽证成前义。意识名身。故云心受亦名身受

疏。如土石下引山水喻。即顺后义。约所益说有品数故。则土喻于心石喻于身。水总喻乐。初禅心乐故。如水不入石中。二禅已遍身心。如水遍山无石碍故。然为喜覆如土覆水。但是潜润。三禅身乐遍增。如池水在外。水遍山内居然可知

疏。释成胜义者。上举三山已知三禅乐胜故。今方出胜义。于中有六。一上一句标。二谓下正明胜义。无如是乐者。无有无喜胜乐及无间舍者。明无能治行。舍则下地有乐无舍。上地有舍无乐。今有舍有乐。故乐最胜。三是故下引证消经。明其有乐有舍。四故诸乐下结成胜义。五此瑜伽下结弹异解。谓远公将能舍两字。属于上句。云诸圣所说能舍。释云。唯圣弟子能说能过堪能舍离。非凡所能彰此乐深。今将能舍两字属下。云能舍有念受乐故。乐为胜故。诸圣者共说此乐者。最为胜耳。远公但云乐胜。不知何以得胜思之。是故结云有文有理。不应别解。六文中下。会经同论。言但有舍念已殊上下者。有舍念故异下。有乐故异上

疏。第四禅初正明问答。初禅有乐那未断苦。答意可知

疏。若依小乘下约教拣异故。俱舍云初二乐轻安。则显前论皆约乐受。又此正断下明其所宜。此亦遮难。难言。一种相摄何不举不忧不喜。摄苦乐耶。答云。一五受中无别名故。二所对乐近忧苦远故。先已断故

疏。喜心浮动下释无正知所以。三若远显清净下重显清净之言。上但对三禅明四清净。今总对前三以明清净。先引论文。后此论略举六事者

疏。释论文无苦及忧。故云略举。亦以远故。正明从初禅来下地灾患。已断忧及苦之现行。俱在欲界。故略不言。俱舍论云。第四名不动。离八灾患故。八灾患者。谓寻伺苦乐忧喜出息入息

疏。第二四空下释此分四。一义门料拣。二释文。三指广。四观行。四中初一彰差别。二释别名。三例科为四。四显支别。今初。即前所引四蕴离下地。离下地言是显差别

疏。差别既尔下。二释别名。于中六。一总征。二彼次颂下引论答。三谓修定下释论文。四以前三下出异所以。所以同四无色。受名不同者。前三根本不一所缘故。五瑜伽下引例为证。六加行等者。指相在文。五中然瑜伽乃有二意。此是一意。论云。此中依于近分。乃至未入上根本定。唯缘虚空等。若已得入上根本定。亦缘虚空亦缘自地诸蕴。释曰。言近分唯缘空者。约八解脱道中少分而说。解脱亦缘自地蕴故。九无间道此全不论根本。亦缘自地蕴者。初刹那心缘自地蕴。后心而得缘上下蕴。今拣后心故云亦也。第二释者。前三加行亦缘自蕴。取其解脱道中以少分缘义。及无间道缘自蕴故。前释从其多分。俱舍唯取一义

疏。然此四下。三例科为四

疏。问若有下。四显支差别。先问后答。答中四。一双酬。二经论下会通。三如初下示有四故。五下结示

疏。今初空处。下释文有三。初标而言处者。顺正理云。四空名处者。谓有情生长处故。二文中下释文。三总结。二中三句即为三别释。初句中二先双标。今初句者。以经三句连为义句故。曲有三。疏言离障下双释。先释离障后释对治。今初。疏文有四。一总标。二别释三句。三总释想字。四通妨难。今初。言谓离三有对等色者。俱舍界品中。明十八界诸门分别。总有二十二门。今此要二。谓问云。几有见无见几有对无对。偈云。一有见谓色。十有色有对。释曰。十八界中谓色界一。此一是有见。谓为眼根所观照。故名为有见。五根五境。此之十界。有色有对。谓此十界体是色故。极微所成更相障碍。故名有对。论云。如手碍手如石碍石。或二相碍手石名二。应知有对。总有三种。一障碍有对。即十色为体。障碍即有对。持业释也。二境界有对。谓十三界。即六根六识法界一分。谓于法界中唯取心所。此十三法于色等境。而能取故为境所拘。名为有对。境界之有对。依主释也。三所缘有对。其体即是七心界全。今谓六识及意。并法界一分。亦心所也。言所缘者。色等六境。言有对者即七心等。为六境界所拘碍故。然对是碍义。碍有二种。一障碍碍。二拘碍碍。三有对中障碍有对。即障碍碍。余二有对是拘碍碍。论自问云。境界所缘彼有何别。论答云。若于彼法此有功能。即说彼为此法境界心心所法。执彼而起。彼于心等名为所缘。释曰。彼即六境。此即根识等。意云。若根识等于色等境。有能见等之功能故。即詺色等为我境界。若心心所犹如羸人非杖不起。托境方生。即色境等名为心等之所缘也。是则境界有对能缘力强。所缘有对所缘力强。故所缘中但有七心。境界之中具有根识。以根不托境而生故。故能取境边名境界有对。为境引边名所缘有对。而大云释云。碍取境义边名境界有对。碍缘境义边名所缘有对。似非本意。以论引施设足论四句分别境界有对。谓一于水有碍非陆。如鱼等眼。二于陆有碍非水。如人等眼。三俱碍。如捕鱼人及虾蟆等眼。四俱非碍。谓除前根。释曰。以此而明以见等为碍耳。非碍见等也。又论自释碍义。云何眼等于自境界及自所缘转时。名为有碍。答云。越彼于余此不转故。释曰。谓眼缘色不听声等故。眼于色名为有碍。碍我余缘故则碍取境义。斯亦有理。而疏不言碍取余境。但言碍取境边。故非论意。三有对义。彼论为难。今已略显。然第三有对。体虽七心要缘六境。故亦有色。又言等者。等于下别无对色故。此无对色。亦六境中法界摄耳

疏。论云下。第二别释三句。句皆有三。如初句中。初标经二过眼识等论释。三此明超可见有对。即疏释论下。二句亦然。其疏释三句。亦即俱舍界品明五蕴中色。辨粗细门。一可见有对者。谓色境也。二不可见有对者。谓眼等五根声香味触也。三无见无对者。为无表色。今初可见有对。即前界品中一可见谓色。瑜伽名为超于显色。论云。次于虚空起胜解故。所有青黄赤白相应显色想。由不显故。及厌离故。皆能超越

疏。二灭有对想者。标经。三有对言因此句生。耳鼻舌下论释取四识和合。但谓四尘。即声香味触。识必依根即兼前可见。皆障碍有对。故瑜伽云。由不显现超越彼想以为因故。所有种种众多品类。因诸显色和合积集。有障碍想皆得除遣

疏。三不念下释第三句不念。先以论释。此灭下二疏释。先正释。后意识缘下通妨可知。然此第三通于境界及所缘。摄是法尘故。意识缘故。已如上说。瑜伽云。由远离彼想以为因故。所有彼种种聚中差别想转。谓饮食瓶衣车乘庄严具城舍军林等想。一切不作意转。疏皆云想者。第三别释想字。先依小乘后依大乘。前中俱舍云。亦总名除色想。然无色亦二。一者生得。生得即果。果灭色形。二者修得。修得在因身居欲色修空定时。但灭于想。应有问言何不灭余。故疏答云。想取色相故偏说灭。非不灭余

疏。大乘之中下二约大乘。谓纵生无色亦唯灭想。先正释。后若超色相下。以例反成。谓生识处不灭于空。生无所有不灭于识。何生空处而灭色耶。斯理善成

疏。问香味之想下。四通妨。先难后答。答中二。先竖约渐修。后横约顿证。前中又二。先通香味。后色声下通余三想可知

疏。若于色界顿修空定下。约顿证以明。言意缘一切法亦无拣故者。前明意识之中。唯取缘色之想。故今辨之。通缘一切。论主但云灭意识和合故。意识分别一切法。故说别异想曾不拣。言唯取意中之色想耳。故知通也

疏。已明离障云何对治下。二释对治。上二句结前生后。后前三句中下正释。然其不念之言。对治义显。初超次灭亦是对治。上引瑜伽三句之内。皆具对治。谓由远离彼想为因等下总释云除遣。如是有色有对种种想已。余无边想虚空胜解是也

疏。何以不念见无我故者。即是论释不念之言。谓色无自实当体即空。故云无我即法无我。从约菩萨实治下。即疏释论。言但厌下苦粗以为加行者。此即有漏六行伏惑。谓厌下苦粗障。欣上净妙离。略言苦粗。然此对治。经虽无文论主义取不念释耳

疏。从顺正理下引论释成加行之相。然云有法虽与色俱者。有法即空。空遍一切色非色处。今明色中之空。故云虽与色俱。言而其自体不依属色者。空是无碍色是变碍故。故下经云。譬如虚空遍至一切色非色处。非至非不至。何以故。虚空无身故。此约事空。若约理空。义亦同此。故经云。譬如法界遍一切。不可见取为一切是也。上辨虚空之体。从诸有于色下。辨观行之相。言而待色无方得显了者。然显空相略有二义。一灭色明空。谓先有色。今此已无故。二对色明空。此处是色无色处是空。今待色无义含二意故。婆沙八十云。但由加行名空无边处。谓初业者。先应思惟墙上树上岸上舍上等诸空之相。取此相已假相胜解。观察照了无边空相。以先思惟无边空相。而修加行。展转引起初无色定。故说此名虚空无边处。曾闻苾刍出此定已。便举两手扪模虚空。有见问言。汝何所觅。苾刍答言。我不见自身。彼言汝身即在床上。如何余处更觅自身。故知入此定已。亦不见身。起定犹尔。今疏但明加行之相耳

疏。瑜伽云。由已超过下。疏文有三。初引论。二准瑜伽意下。释彼论文。三后之三下结例。二中以加行究竟作意。即是第六。以彼释云。谓心得离系故。言利益是胜解作意者。以虽彼当第二释云正是修行以下。彼二依止是加行究竟果作意。彼释云。谓无间证入则知利益。是正修行矣

疏。又此四义下。第三总结何所超者。谓色云何能超。谓无分别。何缘者谓缘虚空无边尤显此句是修行相。何所证者。即空处心一境性

疏。正理云下。引论证成加行之相。言得入根本。即彼二依止三昧。疏四非想中。疏文有二。先释名。后超一切下释文。释初句中。疏文有三。初牒经标章。次云何下显治。后经阙。下会释。疏即入非有想下。释第三句分二。先略释。后瑜伽下广释。于中二。先释非有想。后又言下释非无想。于中三。初对他释。二唯有下约自地释。三此中所以下。对无漏定以辨忧劣

疏。然婆沙下。指广在余。言诸论者。杂集第九亦广分别

疏。今更下约观心释兼通禅门。第四厌果分

疏。今初所以先明者下

疏。文有六。一来意。二然入之所以下入意。三为对生死下建立。四此四皆缘下释总名。五若总相下出体。六文中下。释文四中疏通始终之教。准大集第九云。如诸众生心性本净。是名为慈。观于一切等如虚空。是名为悲。断一切喜是名为喜。远一切行是名为舍。此通终顿。若圆教明。如下离世间品。各有十义。及圆融等

疏。若总相下。第五出体中二。先总出体。皆以定慧而为体者。杂集十三云。慈等三昧故。后得智中所建立故。然论四无量总有五门。一以静虑为所依。二以有情为所缘境界。三与乐等相应为行相。四定慧为自体。一切功德皆奢摩他毗钵舍那之所摄故。五诸心心所以为助伴。疏皆舍有

疏。若别明下二别出体兼舍行相。此有四句。句皆有二。慈即与乐此明行相。无嗔为体。即是出体。拔苦悲相。不害出体。庆他喜相。不嫉出体。自他舍惑是舍行相。即是善舍是出舍体。俱舍颂云。无量有四种。对治嗔等故。慈悲无嗔性。喜喜舍无贪。此行相如次。与乐及拔苦欣慰有情等。缘欲界有情。喜初二静虑。余六或五十。不能断诸惑。人起定成三。释曰。初句标。次句辨治。治有四种。一嗔。二害。三不欣慰。四欲贪。言嗔等者。等取下三。次二句出体。慈悲以无嗔为性。喜即喜受。舍即无贪。此即婆沙论意。若俱舍论云。悲以不害为体故。疏依之舍以无贪无嗔共为其体。今言行舍是杂集意。次三句行相。与乐是慈行相。拔苦是悲行相。欣慰是喜行相。有情等是舍行相。怨亲平等故。次句明所缘。唯缘欲界上界无嗔等故。次两句明所依喜。初二静虑余六者。谓三无量依于六地。谓四静虑及未至中间或五者。有余师说。唯依五地除未至定。谓修无量者。是定与德。已离欲者乃能修故。或十者。欲令此四通依十地。谓欲界定四静虑根本。及四近分并中间禅。有二义故。不能断惑。一有漏根本缘故。二胜解作意相应故断惑。要须真实作意故。今遍缘一切有情境界故。断惑要缘法作意故。次句明处及成唯在人中。成一即成三种

疏。慈之种类总有其三者

疏。依常义。经论大同。涅槃十五更有一义。云众生缘者。缘于五蕴愿与乐故。法缘者。缘诸众生所须之物。无缘者。缘于如来是名无缘慈者。多缘于贫穷众生。如来大师永离贫穷。受第一乐。若缘众生则不缘佛。法亦如是。以是义故。缘如来者名曰无缘。次更有义。即是今疏所明。于中三。初嘱经文。次初一下料拣。后今初下释文。言与欲界之乐。即五欲乐同喜之乐。二禅之中一切因果。三禅亦然。非唯乐受。三禅已上以喜为患。离故名乐。不二者。三乐平等与故者。论云不二者。亦是广大无量。即重牒前三。以此三乐遍与众生。不拣彼此云平等与。疏次二治障者。即经无怨无对慈行平等不等是障。怨应与苦。今皆与乐。故无慈障。怨与其乐。可名治障。亲与其乐。何名治障。不以亲故偏与之也。故疏云无偏情也。与前不二有何别耶。前唯就乐以明不二。今就苦乐相对遣也

疏。次一清净即经无障。然经云无障。论为清净。前说无障。无障却云治障者。由前治障得此无障。无障即净。又前是慈用。用平等慈治于怨亲。此据慈体体是禅果。所依依禅治下欲恶等染。故名清净。身心不调造十恶业。调故无之。五盖等者。等上十恶及怨亲也。言行清净慈者。即净名观众生品云。行清净慈诸法性净故。契深行净障盖不生

疏。后一摄果即经无恼。先依论释。故论云。欲色界中。正受善果无苦恼事。疏别配释。后故修慈下。引证广释。于中三。初举彼经。次然此中下。束成诸果。后修一慈下结示劝修。三报即现生后。五果即异熟等

疏。一缘圣凡五蕴之法者。是所与乐人见无我故。如诸论说。二者众生所有分别作业法者。即涅槃意随其所作化与乐故。经遍至一切世间者。正约有情世间义兼余二。正觉器界是所与故。然约圆教。下离世间品各有十义。第二五神通明行功用果等者。疏文有八。一上句辨定所属。二前内怀下。次明来意。言从多分说者。会上论文。三妙用下释总名。四文中下列别名。五外色下释别名。六若语其体下出体性。言顺眼义者。就眼辨智。废体从眼。故云约见。天耳何不名废智。就根名闻闻不顺智。不如眼故。七余处下辨次第。亦是三业分别。五通皆智。智皆意业。今从用相。故分三业。八今初身下释文

疏。后别中三种自在者。经有十句。论摄为三。初二各一。后八为一。论亦分八。然总十事亦十八变。文有不足。故论直分。疏以经难留在下说。今且依论作业自在中八者。一傍行无碍。如经石壁山障所往无碍犹如虚空故。二者上行。如经于虚空中加趺而去同于飞鸟故。三者下行。如经入地如水故。四者涉水不没。如经履水如地故。五者其身炽然。如经身出烟焰如大火聚故。六者身能注水。如经复雨于水犹如大云故。七者身能扪摸。如经日月在空。有大威力而能以手扪摸摩触故。八者自在乃至梵世间。器世间。随意转变得自在故。如经其身自在乃至梵者。释曰。曰若会十八变者。三种之中初一即振动。二中有四。一者一身为多身是舒。二者多身为一身是卷。三隐。四显。三为八中摄为五种。一傍行。二上行。皆是往来。三四皆转变。五六皆炽然。七即众象入身。以高大故。八即所作自在。上三段中。初一次四后五。但有其十。余八略无。论见多无。别无科释。余如善住知识处明。疏一以初六心明随烦恼者。疏文有四。一释论立名。二言有贪下别释初对。三即三不善下。例以总释。四论今下。会通论意。二中贪是心所。心王之体与贪相应。名贪缠所缠。余亦如是

疏。二心明使即是随眠者。论中名使。随眠往来犹如公使。随逐捉缚故

疏。或略非略摄之者。以论经无略非略。下释即散不散中开出。今以论中不说于上二无色故。以此当之。无所有想即是略也。非想非非想中。此想亦劣故名非略

疏。四有四心学三昧行者。异后得定。以略释止者。故唯识释睡眠云。昧略为性。略拣寤时昧拣定中。定中是略而不昧故。系缘一境即是略义。略非略中略心为得。非略为失。散非散中。散则为失。非散为得

疏。前二约定者。以论无略非略。但名学三昧行。今以三昧有止观品。故别用之

疏。以得四禅。谓得四果者。得初禅。谓得初果。余三如次

疏。论经名求不求者。仍在上无上前

疏。九有二心大乘得失者。论经无此。论亦无义。令以义释耳

疏。上之九类下。通相料拣有三。一三杂染料拣。二亦即下四谛料拣。三皆如实下总释如实知义。有五教意。初通小乘。初教理实通人法二空故。二亦非心外下。通始终二教。唯识之义通二教故。三若自他相绝下。通于终顿两教。但同一体即是顿教。兼取不坏能所知义。即是终教。又总取双绝双存。亦圆教中同教义故。四又他心是总下。六相圆融。唯属圆教一乘之别教义

疏。即生心时随心用现在前者。此有三重自在。上明散动不能缚。则入定自在。二此段欲入则入欲出则出。入出自在。是则定散皆不能缚。即是地初明盛心也。三大悲方便下。受生自在。则报果无缚。论云。彼淳厚深念心此成就。示现者。谓地初十种深心中第八心。今经当勇猛心故。上论释云。又不随禅解脱力生

疏。释云地满方成正指此也

疏。论主从胜等者。佛菩萨处胜诸秽处及自利者。为满自利菩提分故。近佛菩萨。若约利他。瑜伽地持皆云。随他见已生道法处。故。今疏云。不拣净秽能满二利。菩提分处即生其中。第二位果

疏。不生不灭即法性观者。约真谛观则显因缘而有。是因缘观是俗谛观。不见增减者。以法性中无净秽故。体无增减故性无二故

疏。一者成上者。即随顺观世谛。即入第一义也

疏。二约不坏相者。约即真之俗也

疏。一切法不生般若生者。即大般若文。悟法无生名般若。故知无可生照见惑源。故无可灭也

疏。又以此三地下。结说之由

疏。若合色有者。有当无色今合为一。即上二界总名有缚。故为四缚。四流如初二地说。上辨开合二。见缚先灭下释经。则五中初一见道所断。已隔二地故云先也。论云下先举论。后谓烦恼下释论。言与当地所知障种同灭者。以地地各别断所知障。而种现双断故。此地初云。此地断暗钝障。谓所知障中俱生一分。开成二愚。及彼粗重。粗重即是种子。所知种现体即无明。故云无明习气。习气即是粗重。其俱生烦恼。若约现行亦地地别断故。与所知障种现俱灭。烦恼种子。直至金刚方永断尽。今约现行故得云灭。若约种子。但言微薄。以现断故种随微薄。文断现故亦得薄名

疏。拣细异粗者。望于二地故得名细。非望后地而得细名粗障。见道初地已断者。即分别起粗障修者。二地已断者。然烦恼有三。一正起者初地断。二误心起者二地已断三不善根。使任运性成。三地已上。渐次断之。又贪等惑。略有二种。一者不善。凡夫所起。二者是善爱佛名贪憎厌世间。说之为嗔。分别有无说以为痴。上三处断是不善烦恼。善烦恼断亦有三处。一者正起地上渐断。八地时尽。二者习起。八地已上渐次除断。十地时尽。三者使性至佛乃尽。今此但断不善之性。不说现断。至七地中方说断于求佛贪等

疏。他人陵我以刚强等者。即借老子之言。彼云。柔弱胜刚强。又云。天下之至柔。驰骋天下之至坚。例而用之耳

疏。以万顷之陂为其量故者。蔡邕叹郭林宗云。汪汪若万顷之陂。既挠之不浊。亦澄之不清。言其量大也

疏。受恩常念小恩大报者。即涅槃文。十行已引。众生于我有恩者。若无众生。不能成我普贤行故

疏。譣诐者。毛诗序云。内有进贤之志。而无譣诐之心。苍颉篇云。诐谓谄佞也。摄报果经云。得百千三昧者。初地百。二地千。此为十倍。三地百千。即已百倍。四地亿数。然其百千已用中等数法。百百变之方是一万。若百万为亿。四地望三亦是百倍。五地千亿已是千倍。六地百千亿。若云百个千亿。亦是百倍。若总云百千亿。则数难分。七地百千亿那由他。则已有那由他倍。由有百千亿个那由他故。准阿僧祇品云。一百洛叉为一俱胝。此中等数洛叉为亿。俱胝当兆。次云俱胝。俱胝为一阿廋多。阿廋多阿廋多为一那由他。自此已上皆用上等之数。倍倍变之。故百千亿个那由他。已非心识思量之境。况八地云百万三千大千世界微尘数。九地云百万阿僧祇国土微尘数。十地云不可说百千亿那由他佛刹微尘数三昧等。此上三地皆以刹尘当前一数。故难思中难思也。况一一地中。皆悉结云。若以殊胜愿力复过于此。百劫千劫百千亿那由他劫。不能数知。此约行布。况圆融耶。以登地难量。故略寄数以拣深浅。空中鸟迹难可宣示。缨络亦云。初地一念无相法身。成就百万阿僧祇功德。双照二谛心心寂灭。法流水中不可以凡心识思量二种法身。况二地三地乃至等觉地。但就应化道中。可以初地有百身千身万身乃至无量身等。释曰。据此等文寄其数量。非尽理说。第四焰慧地。疏所以来下。疏文分二。一依三学。二若依本论下依寄位。前中二。先总后别。先总引瑜伽。引深密者。意欲双明具经论故。经当第四波罗蜜品。观自在问言。佛说十地。佛地几清净摄。几分所摄。佛言。善男子。当知诸地四种清净。十一分摄。云何名为四种清净。能摄诸地。谓增上意。乐清净摄于初地。增上戒清净摄第二地。增上心清净摄第三地。增上慧清净摄于后后地。转胜妙故。当知能摄从第四地乃至佛地。释曰。上言十一分者。即十地及佛地

疏。又慧有多种下。第二别明。又分为二。先对后辨来。后又前地下对前辨来。舍于定爱者。前有八定故。有定爱有闻持故。有法爱言今修证彼者。证彼菩提分法

疏。二约地中下。此释有四。一引论正释。然唯识文即摄论意。次下正引。即摄论第七意。世亲释云。由此地中安住最胜菩提分法。由住此故。能烧一切根本烦恼及随烦恼。皆为灰烬。然以菩提分而为慧者。非皆是慧。慧之焰故从喻为名也。二由住第四下。以文成上约地中义。三若唯下反成前义。四以此地正明下释妨难。难云。若许此第一释者。何以诸论多依第二。故为此通。通意可知。于中文二。先正通。后摄论云下出多释文。略举五释。一摄论。即上第七论。二庄严论。当第十三。三引瑜伽论。亦即第四。文多同前。四引金光明。即第三经云。能烧烦恼以智慧光。增长光明故。是修行道品依处。是故四地名为焰慧。五引显扬。亦当第三。论云。焰慧地者。谓诸菩萨住此地中。先善修治第三地故。超过一切声闻缘觉地。证得极清净。缘诸觉分能取法境微妙慧蕴能现前。烧一切烦恼。是故此地名为焰慧。然上五释义皆相成。故疏总云不殊此意

疏。三约地满等者。前约证智为焰。此约教智为焰

疏。然所烧下。三明所断障。疏文有四。一举唯识。二亦摄法爱定爱。兼收本论。三菩提分下正明断义。四由斯四地下。别说二愚。然唯识一分之下。更有论云。第六识俱身见等。摄最下品故。不作意缘故。远随现行故名微细。释曰。第六识言拣第七识。第七识俱以微细名故。此地未断。今言微细望前地说有三义。故立微细名。一第六识中。分别身见名为上品。唯不善故。独头贪等名为中品。通善不善。此唯无记故名下品。二不作意缘故。即任运生义。三远随现行故。从无始来随逐于身故。有上三义故名微细。论云。彼障四地菩提分法。入四地时便能永断。释曰。以有身见。不能观身为不净等。问上言所知障中俱生一分那名烦恼。答此所知障。昔时多分与烦恼障同一体起。立烦恼名。由菩提分正断所知。彼之身见亦不行故。前之三地何不尔耶。以相同世间。今此出世方能离之

疏。亦摄定爱下。二出本论名。名离解法慢障。略云解法。实亦有定。本分中说。亦唯识文。论云身见等言。亦摄无始所知障。摄定爱法爱。彼定法爱三地尚增。入四地时方能永害。由斯四地说断二愚及彼粗重。一等至爱愚。即是此中定爱俱者。二法爱愚。即是此中法爱俱者。所知障摄二愚断故。烦恼二爱亦永断不行。今得无漏定及无漏教者。故违于彼。即疏彼释。愚即所知。爱即烦恼。故说俱断

疏。由此证得下。四所证如。亦前唯识引摄论文。世亲释云。于此如中无计我所。无摄我所。如北洲人无系属故。应说此如。非我执我慢我爱无明边见我所见等所依取故从得此真如下。是今疏结成。次明成行。如文具之。由达无下六得果者。不为我摄方能摄生

大方广佛华严经随疏演义钞卷第六十一大方广佛华严经随疏演义钞卷第六十二

        唐清凉山大华严寺沙门澄观述

第二正说

疏。前中论文分为四。下疏文分四。一依论科。二依四道科。三依三心科。四依论释文。初一可知

疏。又此四分即加行无间解脱胜进。四道者。第二四道科如杂集第九说。俱舍贤圣品云。应知一切道。略说唯有四。谓加行无间。解脱胜进道。释曰。加行道者。谓引无间道前之加行也。无间道者。谓断惑道也。解脱道者。无间道后名解脱道。谓已解脱所应断障。最初所生。胜进道者。除前三外所余诸道。渐胜进故。即解脱道后所起诸道也。是涅槃路。故名为道。释曰。所起诸道者准杂集。即为断二障。谓烦恼所知。有加行无间。更有异释大意皆同

疏。又此四中初一下。三依三心科。具如初地

疏。今初因分者。第四释文。即第一清净对治修行增长因分。以是次二分因故。唯牒一因字耳

疏。今初十法明门下。疏文有五。一单释门。二故论经名入者引证。论经云。当以十法明入四地故。三明为下双释明门。四故论云下举论释。五言证地智者下。疏释论。于中五。初正释证地智光明。二亦犹下引例释。三故前地下引证释。四言所说下释下句中所说法言。五便以下通释下句依彼智光入如来所说法中。论经云思惟是今经观察耳。疏略以三重释之者。一总别释。二染净释。三能所依释。依第三释文

疏。因成有二者。谓人法二空。从二空所显下。会其三观。言即是真如者自有二意。一者顺法相宗。二空非真如故。二成三谛。假名为有谛二空为无谛。真如为中道第一义谛。有三谛三观矣。又空有不二总为空观。不坏假名即假观。合上空假以为中道。下观二假例此成观故。相续结云亦入二空真实。二空真实即是真如异名。名相待假后。结例可知

疏。后五依此所依立能依下。于中有二。先总明。后初三句下别释。今初。此识亦通二宗。若生灭识生。染净依他亦依心有。即法相宗。若真妄和合识亦生染净。即法性宗。并如前说

疏。着欲等者。由着欲故有于欲界。由着受故有于色界。四禅不出于四受故。又着正受故。由着想故有无色界。空想识想无所有想。非想非非想中。虽欲绝想亦不出想。三界唯心总结上文。如下六地

疏。后二广大下。于中三。初依论释。二今经下案今经释三。又皆言下。通释界字。第二清净分

疏。初中文有三句下。疏文有三。初案经释。二辨家不同。三会论释。今初。初句十智为能生者。即下所列之十句也。智因所观而成十智。言得内法者。疏释以证性故。亦是如来教化之法故名为内。何时得耶。论云。此法明入同时得故。应知。若尔何异前分。而云前分为此因耶。答因分观十未得上品。犹在三地得上品竟。即入四地与此同时。若远公云。十智十入名异体。一故得同时。而自问云。两法相似可得言同。明智体一何得言同。彼自释云。此虽体一随门有别。是故说同。云何门别。前就众生世界等十。以彰法明。今此乃就三宝等以说法智。故云别也。复应难云。所观既异。何名体一。故应如前钞家之释。复应问云。前观十明得入四地。此前未观十智云何言生。故应答言。有二义故一前以能化观所所化。今以所化成能化法。为分能所。所观沙殊能所相成。故得一时。二者前十明门了相会性。今此十智虽举十相意在一性。故云内法。性相少异分之成二。性相不离故得一时。问何以将此教化之法为如来家。论云。如来自身所有诸法。以是法故显示如来。释曰。若无此法不名如来。故此十法佛所安住。名之为家

疏。然如来家下第二辨家不同。准下林神八地亦生。生无生忍家故。如来亦名究竟生家。故云略耳

疏。若准瑜伽下。第三会于论释。二论意同。言此中智契下。显所证体成上内法。即前地五方便中第三方便也

疏。谓大乘是菩萨自所住处等者。释上名也。然论主一时列四名已属经竟。重复料拣解释。今初云自住处毕竟智。即初列名。谓大乘下是复重释。论具云菩萨自住处者。谓大乘法中故

疏。上二约行德等者。三宝是已之上故云胜进

疏。四余六句明分别说智者。即论立名。谓是教智下。疏释论分别染净故。是论总释。谓初二句下。是疏释论

疏。故论与经影略而说者。经云因业有生。论云。初二句随烦恼染故

疏。言此顺论意者。以论云烦恼。今将经文生死就论。故云此顺论意

疏。即不滥前因业有生者。今云观众生国土业故滥前也

疏。后二句自利行者。疏文有五。一正释经文。二烦恼影取生死下。以理会经。三菩提之智下。通影取菩提难。恐有难云。涅槃性尽。可云无所有尽。菩提非性。何言无所有尽。故以符理全同涅槃四。然是世谛下通。约顺理解释上难以约理释。滥前如智故。故通云异。异相云何。其犹相见道中。亦观非安立谛。而是后得。此亦如是。虽观于如而是教智。又后二句下。更显别理自有两意。一即四出偈。谓观前际后际故。即本有今无本无今有。观无所有尽。即三世有法无有是处。第五经疏已广分别。后亦是下。观缘生观。然上十智正观如来教化之智。智之别相必由所观。不观所观安识佛智。佛智证彼内法。四地菩萨亦如是证思之。第三对治修行分

疏。大智自利异凡者。二行总有四对。一名自利利他对。二大智大悲对。三护凡护小对。四不住生死涅槃对。即非凡夫行非圣贤行。是菩萨行。后结成无住。以摄前位

疏。论主别有道品论者。出不释所以。今之四门亦无所不具矣

疏。诸乘觉因者。通三乘菩提故。俱舍贤圣品云。觉谓尽无生智。顺此故名分。释曰。觉者无明睡眠皆永断故。尽无生智为此觉体。三十七品顺趣菩提。名菩提分。今顺亦因义

疏。二显同异者。疏文有二。先明大小通局有异。后若准智论下。明法一心异。于中四。一立理。二引证。三拣差别。四广证大义

疏。如分别四谛下。第二引证暗引涅槃。即第十三经。南本十二。迦叶菩萨白佛言。世尊。佛昔一时在洹河岸尸首林中。尔时如来取少许树叶。告诸比丘。我今手中叶多。一切因地草木叶多。诸比丘言。世尊。一切因地草木叶多。不可称计。如来所捉少不足言。诸比丘我所觉了一切诸法。如因大地生草木等。为诸众生所宣说者。如手中叶(迦叶难言)世尊尔时说如是言。如来所了无量诸法。若入四谛即为已说。若不入者应有五谛。佛赞迦叶。善哉善哉。善男子。汝今所问则能利益安隐快乐无量众生。善男子。如是诸法。悉已摄在四圣谛中。下云智有二种。一者中智。二者上智。善男子。知诸阴苦。是名中智。分别诸阴有无量相。悉皆是苦。非是声闻缘觉所知。是名上智。广说(云云)又云。善男子。知爱因缘能生五阴。是名中智。一人起爱无边无量。声闻缘觉所不能知。是名上智。又云。善男子。知灭烦恼。是名中智。分别烦恼不可称计。灭亦如是不可称计。非是声闻缘觉所知。是名上智。又云。善男子。知是道相能离烦恼。是名中智。分别道相无量无边。所离烦恼亦无量无边。非诸声闻缘觉所知。是名上智。释曰。皆明四谛有无量相。而皆摄在四谛之中。故知三十七品。若分别之有无量相。则三十七摄无量道品

疏。但心行大小不同者。三拣差别下。释文中广见其相

疏。净名下第四广证大义。总引三经四文。一引净名二文。一即光严童子经。初已引。今但举其中云三十七道品是道场。舍有为法故。下结云。善男子。菩萨若应诸波罗蜜教化众生。诸有所作举足下足。当知皆从道场来住于佛法矣。释曰。意明得道之处即是道场。万行得道即为道场。即大菩提因也。二即法身因。亦净名方便品。由国王等皆来问疾。因以身疾广为说法。诸仁者。是身无常无强无力无坚。广诃身竟。便云。诸仁者。此可患厌当乐佛身。佛身者即法身也。从无量功德智慧生。从戒定慧解脱解脱知见生。从慈悲喜舍生。从布施持戒忍辱柔和勤行精进诸禅定解脱三昧多闻智慧诸波罗蜜生。从六通生。从三明生。从三十七道品生。既云能生法身。明非小矣

疏。大集名菩萨宝炬陀罗尼者。第三文也。宝具诸德故。炬能破暗故。摄一切法名陀罗尼。岂是小耶

疏。涅槃云下。四引涅槃。即第二十九经。南本二十七。佛言。善男子。众生佛性不一不二。诸佛平等犹如虚空。一切众生同共有之。若有能修八圣道者。当知是人即得明见佛性。善男子。雪山有草。名曰忍辱。牛若食之则成醍醐。众生佛性亦复如是。释曰。斯为正义下。师子吼牒难亦云。如佛所说。若有修习八圣道者。则见佛性是义不然。下难意云。道若是一余人无分。故佛举平坦之路。以况八正。明知八正能见佛性。即非小矣。疏中义引。疏三明体性等者。疏文有二。先正明体性。后总指宗源。前中有三。一假实出体。二五蕴出体。三诸法出体。初中有二。先标列。后辨成三十七义。今初。俱舍贤圣品亦云。此实事唯十。谓慧勤定信念喜舍。轻安及戒寻为体。释曰。寻即此中思惟。轻安即除。除是智论之名。即经猗觉分。猗者美也。即轻安义

疏。由信二戒三下。二辨成三十七义。言信二者。即一信根。二信力。言戒三者。即八正中正语正业正命。言念开为四者。一念根。二念力。三七觉中念觉四八正中正念。言精进为八者。即四正勤为四。五精进根。六精进力。七精进觉分。八正精进。言定有八者。谓四神足为四。五定根。六定力。七定觉分。八正定。言慧有八者。四念处为四。四念慧为体。邻近名念故。五慧根。六慧力。七择法觉分。择法即慧故。八正见。见即慧故。言余四各一者。即除喜舍思惟也。由依渐开及不开者。为二类故不依俱舍之次。而先信次戒等。若毗婆沙即实事有十二。以戒中分出正语及与正业。以身语业不相离故。余九同前。今依瑜伽俱舍故。但有十

疏。复束此十以为三蕴下。第二五蕴出体。曲有三义。初克实出体。唯有三蕴。二五类法中下。约五类出体。由摄受行以为心所。故于五类唯有二类。则无心王及不相应。并无无为故。三若取助伴下。即相应出体。所必依王。必依于想取身等相。故杂集云。助伴者。谓彼相应心心法等

疏。若取所缘通一切法者。第三诸法。出体可知。疏广显下。第二总指宗源。不欲繁文。令知本故

疏。四正释文即是行相者。疏文有五。一标章总示。二总科类别。三明其次第。四随文别释。五总以喻彰

疏。三十七品总有七类者。第二段也。即杂集瑜伽之意。其中义旨至文当释

疏。此七次者下。第三明次第。于中三。初正明次第。二会异释。三辨圆融。今初。即杂集意。故彼论释七觉云。七觉所缘即四圣谛。如实性。释八正云。八正所缘境者。即此后时四圣谛如实性。由见道后所缘境界即先所见如实性为体。释曰。此则八正是修道矣。若准俱舍贤圣品中。七觉即当修道故。彼论问云。当言何位何觉分增。偈答云。初业顺决择。及修道见位念住等。七品应知次第增。释曰。初业者即修别相总相念住。此初业谓能照身等四境。慧用胜故说念住增。言顺决择者。即暖等四位也。具暖法位中能证异品(决择分也)殊胜功德勤用胜故。说正勤增。顶法位中能持善趣无退转位。定用胜故说神足增。忍法位中必不退堕善根坚固得增上义。说五根增。世第一位中非世惑法所能屈伏。得无屈义。说五力增。言及修见道位者。修道位中近菩提位。助觉胜故说七觉增。见道位中速疾而转。通行胜故。说八正增。有余师说。于见道位建立觉支。如实觉知四圣谛故。于见修二位。建立八圣道支。以此二位俱通直往涅槃城故。释曰。后解正顺今经见道。后说修道。见是七觉。前解虽七觉居前而名修道。八正为见义。当约位八正在前。智论亦云。修道用故名觉。见道用故名道。同俱舍初意。亦是义当八正居前。以见道后有修道故。又俱舍云。七觉八道支一句是无漏。三四五根力皆通于二种。则非见道之前别有修也。今疏意符杂集及俱舍后师故。以七觉为现观自体。八正为现观后起

疏。有时八正在前下。会异释。即上俱舍意

疏。然上犹寄位下。第三圆融于中三。初句指前。是约位说随增胜义。次若约行者。诸教证明初心通修者。大小乘说皆初通修。后况入地菩萨下。三况出入证。久已证如岂不齐具

疏。今初对治颠倒道文前有七。一释名。二出体。三辨相差别。四彰所由。五辨其次第。六明倒通局。七明观相异同。今初释名若云念处处唯。约所住。若云念住。住通能所

疏。体实是慧下。第二出体。若准杂集具二为体。论云。念住自体。谓慧及念。由佛经中有随观言及念住言。故今疏随增说慧为体。故俱舍云。四念住正断神足随增上慧勤定为体。实法加行。善言加行善者。即相应五蕴。即下明助伴。正勤神足例此。念处一时辨体。而疏云由念得住者。即婆沙意。若俱舍论云理实由慧。令念住境如实见者。能明记故。所以但取以慧为体。今疏依婆沙者。是其源故。要须明记慧方住故。故具以慧由念而住

疏。杂集云。一切菩提分法下。第三辨相差别。亦当引证。证于前后出体等文。即第十论。先列五名。后今初下约当科释。一所缘如彰四所由。二自体如上出体。三修习如下释文。故此三门列名而已。四破四颠倒下。引论辨果。趣入四谛者。由身念处趣入苦谛。所有色身皆行苦故。粗重所显故。是故修观行时能治于此。轻安于身差别生故。由受念住趣入集谛。以乐等诸受是和合爱等所依处故。由心念住趣入灭谛。观离我识尚无所有。惧我断门生涅槃怖。永远离故。由法念住趣入道谛。为断所治法修能治法故。言身等离系者。是论文。论云。又此四种如其次第。能证得身受心法离系之果。由此修习。渐能远离身等粗重故。问上列有五。何唯释四。答有二义故。一经唯有四故。上疏云文或略无二。前已总明出体中云。若兼助伴五蕴为性故。若别说者。杂集云。谓彼相应心心法等。彼者彼念慧二法。释曰。论云等者。等取心不相应行。及同时四相。亦是助伴类非一故

疏。此身等四前三即三蕴。下第四彰四所由。于中有二。一者对我。二对障。今初对蕴开合。为破我故。我有四类故合为四。即是释前所缘之境故。杂集云。念住所缘即身受心法。上已略明。又云。复有四事。谓我所依事等。今疏但列名。论释云。由颠倒觉愚痴凡夫。多分计我。依止有根身故(即我所依事也)受用苦乐(即我受用事)所了境相(即我自体事)由贪等染污。由信等清净(即我染净事)是故最初为正观察真实事相故。建立此四种事。为所缘境

疏。要此四者下。第二对障。障有四故即是重明第五修果为治四倒。合五为四。言治三可知者。如初句苦治乐倒。无常治常。无我治我故。彼论云。修不治观故。了知诸受皆是苦故。通达诸识依缘差别念念变异故。观察染净唯有诸法无作用者。能如是知。是名修果。疏此次第下。第五彰其次第。先正明后解妨。今初从粗至细者。身色最粗受领外境。望身次粗。心复为次。不约境故。法最为细。摄涅槃故。粗者易治。故云从粗至细。教对治故。次引智论下。证次第对治之相。后言破此四倒下。结行功能。亦是修果。对于常等以无常等而为正行。而非实相。由此悟实。故称为门

疏。若尔下第二解妨。妨次相违。答以义别。此约轻重前约粗细故。谓常倒最重。由计心王而为常故。生邪见等。无因无果无善无恶。故最为重。乐次轻前但计妄乐不必邪见执乐受常等。生过浅故。次于想行计有主宰。主宰不碍有修行故。此复次轻。计身为净但生妄贪。无大过故。故为最轻

疏。然此四处下。第六明倒通局。容各起四。即是通义。如一身上计其相续。但住为常。有身为乐。身即是我。红辉练色如莲如玉。故名为净。余三准思。次从多计下辨其局义。身多计净受多计乐等

疏。然观不净等通于大小等下。第七明观相同异。于中有四。一正明异相。二引证成立。三别示观相。四显通非局。今初。引瑜伽释小乘。略指大乘。具二谛修。然其世俗修多同小乘。但知缘假不计为实。则异小耳

疏。大集般若下。第二引证成立。于中有二。先正证修相。后明破倒。今初。引二经一论。明具二修。后引无行有如实修。而智论云乃至不念身受心法者。越于世谛故云乃至。观身空等亦不取空真如实也

疏。然有二意下。第二破倒。于中有三。初正立理。二广引成证。三结成正义。今初二意。通前经论。但以法性唯破四倒。多约性相双修而说。后意法空寂寥。唯约真实说故。中论云。诸佛或说我。或说于非我。诸法实相中。无我无非我。亦应云。诸佛或说常。或说于无常。诸法实相中。无常无无常。乐净亦尔

疏。胜鬘亦说下。第二广引证成具上二意。胜鬘云。凡夫识者二见颠倒。一切阿罗汉辟支佛智者。则是清净。边见者凡夫。于五阴我见妄想计着。生于二见。是名边见。所谓常见断见。见诸行无常是断见非正见。见涅槃常是常见非正见。妄想见故。作如是见。于身诸根分别思惟。现法见坏于有相续不见续故。起于断见。妄想见故。于心相续愚暗不解不知。刹那间意识境界起于常见。妄想见故。故于彼义。若过若不及。作异想分别。若断若常颠倒众生。于五阴中无常常想苦生乐想无我我想不净净想。一切阿罗汉及辟支佛净智者。于一切智境界。及如如法身本所不见。或有众生信佛语故。起常想乐想我想净想。非颠倒见。是名正见。何以故。如来法身是常波罗蜜。于佛法身作是见者。是名正见。正见者。是佛真子。从佛口生。从正法生。从法化生。得法胜财。世尊净智者。一切阿罗汉辟支佛智波罗蜜。此净智者虽曰净智。于彼灭谛尚非境界。况四德智。释曰。此上经文乃有数重。初见诸行无常涅槃是常。名断常见者。自有二意。一以取相心见不合法体故。斯最深玄。则常与无常。二见双泯。方能见理。二者见生死实有可断。涅槃实有可证。不合法体。不知有净说生死。无诤说涅槃。生死及涅槃二俱不可得故。若如此知即非二见。二从于身诸根分别思惟现法见坏下。唯约生死诸蕴起断常见。三从于彼义若过若不及下。双结上二。以第一义起见着故。为若过。第二义不知刹那坏为断。不知心相续为常。为不及故。上智妄见。四从众生于五阴无常常想下。明其正见。谓破生死无常常想等。为二乘净智见如来法身常乐我净。为菩萨正见。破常等倒。广病而略于药。不言修无常行。以破常等故显如来。常但举其药而略其病。不言二乘。谓法身等亦无常等故。然皆约五蕴即是总明四念。随一一阴。容起四倒之义。若取言总意别。则无常常想。即属心念。若有乐想。即是受念。无我我想。即是法念。不净净想。即是身念。既是三重破于八倒。故云胜鬘。亦以四念能破八倒

疏。既除八倒下。第三结成正义例上胜鬘。亦有三意。若约初意取着。生死无常涅槃常等。即是八倒。无念而知生死无常涅槃常等。即是八行。若依第二意。计于生死若常无常等。皆成颠倒。故为八倒。则非常非无常等。而为八行。若依第三意。谓生死常等佛无常等。即成八倒。若谓生死无常等佛法常等。即成八行。依第三意。即双照常无常故。经引二鸟喻。常与无常不相舍离。依前二意。双遮常无常等故。中论云。诸佛或说我。或说于非我。诸法实相中。无我无非我。亦应云。诸佛或说常。或说于无常。诸法实相中。无常无非常等。余如下说。言涅槃双树四双八只者。引事证成如来涅槃之处。四面各有一双娑罗之树。名娑罗林。娑罗此云坚固。法瑶云。风霜不能改。四时莫能迁。以况法身金刚之质。老死不能变。念念不能易。常乐之相也。言四双者。第三十经云。善男子。东方双者。破于无常以成于常。乃至北方双者。破于不净以得于净。释曰。既云乃至者。应言南方双者。破苦得乐。西方双者。破于无我以得于我。又阇维经云。东方一双在于佛后。西方一双在于佛前。南方一双在于佛足。北方一双在于佛首。入涅槃已。东西二双合为一树。南北二双亦合于一。二合皆悉垂覆如来。其树惨然皆悉变白。第一经云。尔时娑罗树林忽然变白。犹如白鹤。释曰。为对前后。先举东次举西。前为破四倒。右旋而转。又首北者。增一阿含云。表于佛法久住北天。长阿含第四云佛告阿难。安我头南首面向北。使佛法久住北天者。此必译人不善回文。岂有首南而面北耶。故北首为正。然彼经云。表尚顺劣机。今以意求。北方主灭表证寂灭故。兼显履道背苦观于集也。然经文说树无枯荣言。表法之中则有常无常等。案智者之释云。有枯荣也。既表常等。或以义求。或别有据。案僧亮云。树高五丈许。上合下离。其华甚白其实如瓶。香味具足。今以二树鲜荣。二树枯悴。明法不偏。释曰。然未知所据。理甚昭彰。故以一枯表世间无常。一荣表涅槃常等。人不究之。但见于事。不知如来示此祯祥。以表人行遣此八倒

疏。大品明以一切种修下。第三别示观相。然上引证。兼此别示。具五教意。初瑜伽中声闻地说。即小乘教。次约大乘二谛别修。即初教意。二引大集般若。双明通于二意。若性相抗行。即证成前义。若性相交彻即终教意。三引无行经。即顿教意。今引大品一切种修。即圆教意。疏文有三。初引经标示。二征释观相。三结叹深广。今初。言一切种修者。即以一切种智同佛修故。三智之义已如前引。然有三意。一者对大乘。小乘一切智。菩萨道种智。如来。一切种智。今非此意。二者别对三谛。亦明三智。今亦非此三者。约教。圆教一谛三谛圆融修耳。通因通果。今当此意

疏。云何一切种修下。第二征释观相。先征。后应观下释。于中二。一直就四境以明三观后双就枯荣。以明三观。前中二。先别明身念。次身念既尔下例余三念。前中亦二。先约一多以辨三观。后约性相以辨三观前中言法性缘生故。一色一切色者。谓观此身色。非唯但是虚妄颠倒所生之色。或谓不净。或谓为空。乃是迷于法性。合于法性随缘而生。名为性起。以性融相故。一多自在。然即中论四谛品偈意。因缘所生法。我说即是空。亦为是假名。亦是中道义。此偈四句。初句总显所依。下三句皆带此句。谓二因缘故空。三因缘故有。四因缘故中。今法性缘生故。一色一切色。即因缘故有也。若三乘缘生。但各各缘生。今是法性缘生。法性融故。令一色中一切色。大品云。一切法趣色。则一切皆色。况十一色举一全收。次句云缘生即空故。一切色一色者。即论释。缘生故空。则差别万殊。但一性空之色。次法性中故。非一非一切。双照一一切者。即论因缘故中。双非即是双遮。辨中以一与一切互即夺故。下双照辨中。性相历然不可坏故

疏。亦非色非不色。双照色不色者。即第二约性相以明三观。则一多相并。上之数皆属相摄。非色为性。文但显中。略无空假。若具应言法性缘生故色。缘生即空故非色。法性即中故。非色非不色等。亦具遮照中道之义

疏。云何枯荣下。第二双约枯荣以明三观。于中二。先别明身念。后余三下结例。前中亦二。先明枯荣即显空假。后是以八倒双破下。辨其中间。即中道义。前中又二。先举所治之病。后今观色种即空下。明能治法药。言假智常净者。由假观中分别名相。知凡之不净妄计为净。二乘谓实妄。谓不净。今依佛慧如螺髻见。故云常净。于中道中二。先结前生后。即双照辨中。后观色本际下。双遮辨中。余可知

疏。是则对治法药下。第三结成深广。于中有三。初结四念。如常所明。身等但是所缘。观无常等但破常等。今是法性之四。一一皆破八倒。故云法药。称性观智方称为念。四念之处皆具三谛。一切圆融。二一切即空下。结上三观。三只一念下结叹。例余可知

疏。今经但云下。第四显通非局。于中二别

疏。今初观身者。瑜伽明三。各别有体。身是聚义故。外无情亦得名身。智论二意。前约三人修观各别。后约一人修观浅深

疏。今初观内身者。疏文有四。一所缘念处。所缘即身受心法。今明内身。即别举身中少分。以为所缘

疏。次循身下。二修习。先总标举。以何寻求。瑜伽云。即闻思修慧。此杂集意。释论文语隐。故取意释。论云。云何修循身观。由随观分别影像身。与本质身平等。随观于身境。随观身相似性故。名于身循身观。由随观察分别影像身门。审谛观察本质身故

疏。次勤勇下。二别显修仪。疏顺经略。若准杂集云。又修习者。谓欲勤策励勇猛不息。正念正知及不放逸。修习差别故。此有九修。一论云。欲修习。为对治不作意随烦恼。二勤修习。为对治懈怠随烦恼。三策修习。为对治沉掉随烦恼。四励修习。为对治心下劣性随烦恼。心下劣性者。谓于下胜品所证功德。由自轻篾心生怯弱性。五勇猛修习。为对治疏漏疲倦随烦恼。疏漏疲倦者。谓能引蚊虻等处所逼恼。六不息修习。为对治得少善法生知足喜随烦恼。由得少生知足喜故。止息所余胜进善品。七正念修习。为对治忘失尊教随烦恼。八正知修习。为对治毁犯追悔随烦恼。毁犯追悔者。谓于往来等事。不正而行。先越学处后生悔恼九不放逸修习。为对治舍诸善轭随烦恼。舍善轭者。由放逸过失故。于所造修胜进善品。舍勤方便不能究竟。释曰。今经但有其四。而疏文中以四收九。而文有三。初明勤意

疏。过于世间慈父等者。智论云。离别常人易。离别知识难。离别知识易。离别亲戚难。离别亲戚易。离别自身难。亲戚即父母等。故云过也。故须勤勇

疏。勤即欲勤下二正释修相。即以论四修释一勤字。四皆勤类故。次以五六二修释勇。故云勇谓勇猛不息。三念四知同论七八。疏又心若驰散下。三重释念知。含其第九不放逸修。言重释者。上释明本念知。今释策其退败。准西域法。维那秉众。于晨朝时常诵此言。以策懈怠。疏则能鞭心令复本观者。即庄子意。如人驱羊不及群者。谓之为后鞭。令及群故云鞭后。修心如羊驰散如不及群。令复本观。即及群也。无常三途等。即是鞭也

疏。其不净下。谓助伴自性等。疏准瑜伽等者。释后三念处。内等三观。引二论明。初瑜伽意云。如观上内身。以自身五根为境。对之成触。触故生受领不净等。是名内受。观上外身及内外身生受。例然。如受既尔心法亦然。疏智论云者。释有小异。心唯是内者。心是己之心王意根摄故

疏。受法唯外者。谓十二入中。受唯在外。法入摄故。受必受于六尘境故。法谓想行。想取外相。行即思惟等。触前境故。故唯在外。言身通内外者。观于自身为内。妻子等为外

疏。答受有二下论答。疏文有三。初别明三念。内外二义。谓此三念前二各二义。受中一约身心。二受。五根所受名身受。六识所受名心受。第二义就六识中自分内外。次心虽下。明心念二义。后法虽是外下。法唯一义。谓唯心故。初义大同瑜伽。余皆不同

疏。第二正勤下。疏文有四。一来意。二出体。三释名。四释文。今初摄前法喻双辨。若瑜伽但云。如是于四念住中惯习行故。已能除遣粗重颠倒。已能了达善不善法。从此无间于未生善法。为令生故等

疏。精进为其自体者。第二出体。即善十一中勤也。唯识云。勤谓精进。于善恶品修断事中。勇捍为性。对治懈怠满善为业。勇表胜进拣诸染法。捍表精纯拣净无记。即显精进唯善性摄。释曰。勇明念念高胜。非如染法。设虽增长。望诸善品。皆名为退。不得名进。捍表精纯不同无覆无记之净也

疏。故总名勤下释名。于中有三。一正释。二异名。三拣通局。今初分二。先仍前出体。以释总名。后前二勤断下。释别名。义当辨相。于中三。初束四为二。不出恶止善行。二二恶二善皆所缘境者。明所缘三。前中未生下。拣四别相。未生之恶遏令不生者。遏者止也。经云为不生故。瑜伽云。若未和合未现前。名未生。为令不生发起希愿。我当令彼一切皆不复生。言已生之恶断令不续者。经云为断故。瑜伽云。已和合已现前名已生。先已和合为断故发起希愿。我当于彼一切恶皆不忍受。断灭除遣。释曰。只令不续即断灭除遣故。远公云。已起谢往云何可除。此乃断于已生种类。在未来者令不相续。非谓断于起已灭者

疏。后二未生善令生者。经云为生故。瑜伽云。谓于未得未现前所有善法。为欲令得令现在前。发心希愿发起猛利。希求获得欲求现前。言已生令广者。经云为令增广故。瑜伽云。谓已获得已现在前所有善法。于此善法已得不失已得不退。依是说言。为欲令住于此善法。明了现前无暗钝性。依是说言。令不忘失于此善法已得现前数数修习成满究竟。依是说言。令修圆满。今经文略但云增广。亦摄瑜伽令住明了及圆满言。远公亦云。已生谢往云何可崇。此亦崇彼已生种类。在未来者。令其续起。上云圆满已是种类。疏亦名四正断下。第二辨异名。于中五。初正明。次后二是修下别难。三善是断处下总释。四正修断下略示所断。五故瑜伽云下。引论正证。后二是断。以四皆名断故。一律仪断者。即已生恶法。由于已生恶不善事应修律仪。令其断灭不应忍受。二断断者。即未生恶法为欲令彼不现行断为断故断名为断断。释曰。此意明断绝不生。三修习断者。即未生善法。由于善法数数修习。先所未得能令现前。能有所断故名修习断。四防护断。即已生一切善法。由于已得已现在前诸善法中。远离放逸。修不放逸。能令善法住不忘失。修习圆满防护已生所有善法。能有所断名防护断。释曰。上疏云善是断处。正修断者。断懈怠故。即斯意也。由修习为能断故。然瑜伽初释。先明未生恶与今经次同而说四断。即先明已生恶不正释所以。而下结云复云何知此中略义。谓为显示于黑白品舍取事中增上意乐圆满及加行圆满。是故宣说四种正断。释曰。意明二恶二善。各以前义为增上意乐。后义为加行圆满。已生恶令断是意乐。未生不生即是圆满。故先辨已生。此约修行之时。前据说时。先明未生后辨已生。谓为物说时。应云若未生恶莫令生。已生者即须断除。若修行时。尔时有恶即须断除。莫令复生。故远公亦云。恶中先说未生者。此约说时非行时也。善中先明未生者。善非本有习之方起。是以先起未生故。释中又云。亦可。已生是其先。成无明住地细故。后除未生是其四住现惑粗故先断

疏。然其善恶有通有别者。第三拣通局也。疏文有二。先明于局。后约大乘下。辨通此门兼拣权实。疏唯显实。然瑜伽云。云何名恶不善法。谓欲尘染污身语意恶行所摄。及能起彼所有烦恼。云何名为一切善法。谓若彼对治。若善对治。若结对治。释曰。此即疏文中别者是也。论下广说恶不善相。大意不出前也。疏若约大乘下。此言辨通。此应有二。一通一切事恶。二约理说。如今疏文。唯实相为善余皆为恶。则取善相亦名为恶。斯则实教修正断意。亦应言若有可断不名真断。无断断者则无所不断。无勤之勤方名为勤。故法句经云。若起诸精进。是忘非精进。若能无有妄。精进无有涯。疏就一一勤中文皆有四者。释文。文中三。初释勤。次余三下例余三。若二恶下示其果相。初中疏节经文。以为四节。初一所缘。后二修习。第三修果。前已出体。助伴一种念处总明五门具矣。杂集云。正断修习者。如经所说。欲生策励发起正勤策心持心。此中诸句。显修正勤及所依止。所依止者。谓欲乐为先发精进故。故疏云。发希愿心希愿即欲

疏。四勤精进下。即杂集云。正勤者为策励等。于止举舍相作意等中。若由止等相作意。不顾恋所缘境。纯修对治。尔时名策励。即勤精进字。疏发心正断者。谓策心持心者。谓若沉没随烦恼生时。为欲损减彼故。以净妙等作意策练其心。若掉举随烦恼生时。即以内证略摄门制持其心。尔时名为发起正勤。而疏云增上意乐加行圆满者。即瑜伽文。故彼论结云。当知。此中由欲故增上意乐圆满。由自策励发起精进策心持心故。加行圆满。彼瑜伽师云。唯有如是正所应作事。谓为断灭所应断事。及为获得所应得事。先当起希愿乐等。细寻上二论文。疏文易了。若二恶下。第三显果中。已生未生之恶弃舍已生恶。已生未生之善增广已生善。杂集论云。正断果者。谓尽弃舍一切所治。于能治中若得若增。是名修果。疏第三四神足。文前有五。一来意。二神即神通下。释名。引论中二。先喻。后由出世下合。三神足下辨所缘。四神足下出体。五欲勤下明助伴。即是辨相。于中有二。一标释。二出因。今初但标四助者。谓由此四亲能助故。若通明助伴已。见念处之初释中言欲者。瑜伽意云。谓能生乐欲。于诸不善自性因缘过患对治。审正思察起心一境。念于诸善法自性因缘功能出离。审正思察住一境念。即由如是多修习故。触一境性。能害现行故名欲定

疏。勤谓精勤无间者。意云。谓自策自励发勤精进。以断二恶修二善故

疏。心即是定者。谓专心已生未生恶。已生未生善。守护即名为心。此是加行得心一境性。故名为定。杂集云。心三摩地者。谓由先修定力。触心一境性。所以者何。由于前生数修定力。令彼种子功能增长。由种子力令心任运于三摩地随顺转变。由此速证心一境性。释曰。此明由昔种子。其心任运趣定。即是加行。亦有经论名为念定。系意住故。故能守境

疏。由欲增上力下。结成定名。皆从加行受名者。受别名也。即以因名果。若四皆名定。则因从果称

疏。此四加行下。第二彰其所因。因前正勤生故。故前云欲生。此名欲定前云勤精进。此为勤定。前发心中开出策心持心故。有心观二定

疏。标举所修助伴自体者。欲为助伴定为自体故

疏。断行二字总显修相等者。对下依止厌等。别明修相。故云总明。对下成就神足。正明于果。故云亦修之果

疏。八断行者。疏文具足。瑜伽二十九释欲勤心观竟云。如是修习时有八断行。为欲永害诸随眠故。为令三摩地得圆满故。差别而转。一欲二策励。三信四安。五念六正知。七思八舍。瑜伽意云。欲谓希望乐欲。我于何时修定圆满灭恶随眠。二策励不舍加行。三于上所证深生信解。四心生欢喜渐除粗重。五安住其心于奢摩他。六住毗钵舍那慧品。七心造所作能顺止观。八三世之中心无染污。结云。由二因缘于随眠断分别了知。谓由境界不现见思。及由境界现见舍故。对文可知。杂集同此。更依彼释论云。如是八种略摄为四。谓一加行。二摄受。三断属。四对治。一加行者。谓欲精进。信欲为精进依信为欲因。所以者何。由欲求故。为得此义故发勤精进。如是欲求不离于信。有体等故。二摄受者。谓要由此轻安。摄益身心故。三继属者。谓正念正知由不妄所缘安心一境故。若有放逸生。如实了知故。随其次第。四对治者。谓思舍策心持心。二加行力已生沉掉能远离故。又能引发离随烦恼止等相故。与前九修亦大同也

疏。复显修相兼辨所缘者。对上断行总显修故。名之复显。即修习门兼辨所缘者。缘四谛故。即第一所缘也

疏。缘此境时必求修习故。云回向者。杂集之中名为弃舍义一同此

疏。亦是加行等四道者。即远公意。此约分位而释。一加行道。为厌观过厌背故。二见道为离除见惑故。三修道为灭断修惑故。四无学道为舍得涅槃故。亦即杂集八断之中。摄为四义。厌即加行。离即摄受。得轻安故。灭即继属。不忘所缘心一境故。回向于舍。即是对治舍沉掉故。何以念处正勤无此四耶。得定成就方有此故

疏。第四五根文前有四。一总标举。既属忍位。忍可谛理修印顺定故为方便。亦即所缘故。论云。五根所缘境者。谓四圣谛由谛现观。方便所摄作此行故。二增上名根下。总释名。三五根自体下示体性。四此五通于下别释。五得根名。此中有二。先明五根通望出世以得根名。前四复能下。后明前四。复望于后以得根名。谓信起后四进。起后三念。起后二定。起后一。其最后慧根。唯望出世。而有增上。即瑜伽意。疏文中先别明下正释文。于中五。一总科。二显修相。三通妨。四示体。五辨果。初文可知

疏。今此所修下。二显修相。若通显修相。即依止厌等。故下总例云余如前说。今但别示信等之相。于中二。先释信后例释余四。此文稍略。杂集论中皆相蹑云精进根者。既于诸谛生忍可。已为觉悟故。起精进行修习念根。于诸谛宝发精进已。起不忘失行。修习定根。于诸谛宝既系念已。起心一性行修习慧根。已于诸谛心既得定。起拣择行修习。疏文虽略义已备矣

疏。然始入佛法下。第三通妨难云佛法大海初信能入。何以至此方立信耶。通意可知。今由前三科者。即三四也。故瑜伽云。由如是增上心学增上慧学所有瑜伽故。于大师弟子所证。深生胜解。深生胜解已深生净信。此清净信增上义故。说名信根。复应问言。信由三科。信不可拔。余四由何复不可拔。答余四前修至此成根。于理何失

疏。此中念即念处中念者。第四别示体性。前虽总云即信等为体。未知信等从何而来。故此示之。念进定三即前三品。为顺三品故先明念慧。即缘四谛慧即依止厌等念已配于念处。故云慧是缘四谛慧。理实慧根通前三科四念以慧为体故。正勤勤观二善故。神足有观定故。然后二但是助伴故。不说之。四念虽即慧是其体现名念故。所以但云观四谛慧。以为慧也。又前三科。前二虽未建立依止厌等。而义通四谛。故云缘四谛慧

疏。若依位下。第五辨果。于中有二。先依论辨。后就经辨。今初。杂集云。五根修果者。谓能速发智谛现观。由此增上力故。不久便能生见道故。又能修治暖顶。引发忍世第一法。即现此身已入顺决择分位故。今在四地下。二就经辨

疏。第五五力。疏文有二。先出体。后魔梵下释名。于中二。一不为地伏。二能伏于他。二义名力。前中有二。先杂集及瑜伽二十九云。若复了知前后所证。而有差别。随此能于后后所证出世间法。生深胜解。难伏制故。说名信力。谁不能伏此清净信。若天若魔若诸沙门婆罗门。若余世间无有如法能引夺者。诸烦恼缠亦不能伏。故名难伏。此为上首。此为前行。余精进等亦名为力

疏。又能损减下。二能伏于他。引于二论以果释力。文中有二。先暗引杂集论云。所说果者。谓能损减不信等障故。胜过于前。虽与五根所缘境界自体相似。然不可屈伏等义有差别故。别立五力。今疏即此论文兼舍瑜伽。但明伏他。论云。由上诸力具大威势。摧伏一切魔军势力能证。一切诸漏永尽。是故名力。二智论云下。即明引智论以果释力。然依杂集即现观亲近道。义通大小。今约菩萨故得无生法忍。若初地见道称无生者。亦是现观

疏。第六七觉支。疏文有六。一释名。二出体。三释文。四辨果。五分位。六理观。初中二。先总释名。二若依位下。别示觉体释成觉义。是释通名故。瑜伽云。诸已证入正性离生补特伽罗如实觉慧。用此为支。故名觉支。即释名意也。亦即所缘故。杂集云。七觉所缘者。谓四圣谛如实性实性者。即胜义清净所缘故。故疏云觉法自性。法自性者。即四谛如实性。觉即上如实觉慧之用。以所观境释成觉义。亦以能觉显所观境二义相成

疏。觉支自体下。第二出体。然上约如实总体。今辨随相别体。谓念择法进喜轻安定舍。谓七各一法为性。念定择法即别境。五中念定慧三择即慧故。精进猗舍即善十一中三法所摄。精进即勤。猗即轻安。舍即行舍。喜即受蕴。受即遍行五摄。疏文中二下。第三释文。于中三。初总科。二辨相。三会通相摄

疏。然七觉分下。第二辨相兼显分义。于中先总明。谓七于心所各别有体。以觉统余故。唯择法一支以觉为体。余六皆分顺成觉义。后谓念是下。别示其相。全是杂集论文

大方广佛华严经随疏演义钞卷第六十二大方广佛华严经随疏演义钞卷第六十三

        唐清凉山大华严寺沙门澄观述

疏。总收七觉下。第三会通相摄。即瑜伽意。于中有二。先正相摄。念通定慧者。遍行定慧故。四念是慧须得念故。神足是定。心定须念方守境故。后虽是前三下。通妨。谓有问言。既是前三。此何重说。增故名觉

疏。依位所明下。第四辨果。杂集云。觉支修果者。谓见道所断烦恼永断。由七觉支是见道自体故。瑜伽云。最初获得七觉支。故名初有学。见圣迹已。则永断灭见道所断一切烦恼。唯余修道所断烦恼

疏。又虽一刹那下。第五分位。谓虽见道迅速有十六心。义则一刹那中七法俱起。功能不同不可言一。如七味香捣筛和合焚。如麻子七香齐发。念除妄念下。别示异相

疏。大乘七觉下。六明理观。即顿门禅意。不念诸法即是念觉故。昔人云。真如无念非念法。能阶实相。无生岂生心。能到无念念者。则念真如。无生生者。生乎实相故。起信云。若知离念无有能念所念。是名随顺。若离于念名为得入。净名亦云。常求无念实相智慧故。般若云。若念一切法。则不念般若波罗蜜。不念一切法则念般若波罗蜜等。余可虚求。疏第七八正。疏文有七。一约类辨意。二释名。三出体。四释文。五辨果。六类摄。七权实。今初。言约类者。即七类中名现观后起道。言辨意者。为断修道诸惑故。总含杂集五门之中所缘境也。故彼论云。八正所缘境者。谓即后时四圣谛如实性。由见道后所缘境界。即先所见诸谛如实性为体。释曰。即疏文中现观后起意也

疏。离八邪故下。第二释名。瑜伽云。问何因缘故名八支圣道。答诸圣有学已见迹者。由八支摄行迹正道能无余。断一切烦恼。能于解脱究竟作证。是故名为八支圣道。对疏可知。疏八正自体下。第三出体可知。疏文中下。第四释文。即当辨相。全是杂集之文。而合八为六合戒三故。瑜伽文广意不殊此故。释正见云。当知。此中若觉支时所得真觉。若得彼已以慧安立。如证而觉。总略此二合名正见。释曰。所得是一。安立是二。即二见道合名正见。疏中依前所证真实者。即真见道。依实拣择。即相见道

疏。正精进者。瑜伽云。依止正见及正思惟正语业命勤修行者。所有一切欲勤精进出离勇猛势力发起策励。其心相续无间。今杂集意。但显功能不显其相

疏。正念者。瑜伽论云。由四念住增上力故。得无颠倒所摄正念及与正定

疏。若能如上下。第五辨果。言分别诲示等者。上摄八为六。今等取后四故。杂集云。道支修果者。谓分别诲示他。欲令他信。烦恼障净。随烦恼障净。最胜功德障净故

疏。然其八中下。第六类摄即瑜伽意。以戒定慧三流类摄之。于中有二。先正摄为三学。后定慧大同下。对同拣异。异唯在戒故。瑜伽问云。何故此名圣所爱戒。答以诸圣者贤善正了。长时爱乐欣慕悦意。我于何时当正获得。诸语恶行诸身恶行诸邪命等事不作律仪。由彼长时于此尸罗深心爱乐欣慕悦意故。获得时名圣所爱戒。既获得已。终不正知。而说妄语等。释曰。即新建立意也

疏。若依此经下。第七显权实。由上所明皆约寄位故。示本经真实之义。今文略举。具云随顺菩提修八圣道。是菩萨道。所谓正见远离一切诸邪见故。起正思惟舍妄分别。心常随顺一切智故。常行正语离语四过。顺圣言故。恒修正业教化众生。令调伏故。安住正命头陀知足。威仪审正随顺菩提。行四圣种。一切过失皆永离故。起正精进。勤修一切菩萨苦行。入佛十力无挂碍故。心常正念悉能忆持一切言音。除灭世间散动心故。心常正定善入菩萨不思议解脱门。于一三昧中。出生一切诸三昧故。释曰。据此文证。岂不深玄

疏。上之七类总以喻显下。即第五段。然婆沙智论皆有此文。并以树况于道品。故名道树。第二护小乘行可知

疏。大文第四彼果分者。前已指经故此不牒。即从佛子菩萨住此焰慧地所有身见下。是然总唯二果。前一开二。后一开四。便成六果。然有二门。一行断分别故云。二中一离障果。二成德果。二对前分别。故云前从护烦恼生。后从护小乘生。随文释中。具以六果别别对前。今初一是护烦恼者。以修道品对治行故。远离烦恼显涅槃故。业亦随亡。初为二果

疏。所起执着出没是此总相者。此是断惑正断三地正受解法慢故

疏。本即所有身见等者。疏文有三。一释经。此中二我计执自高说为我慢。非定法慢。二而云下释论本字。三此中身见下。出所断体。于中有二。一约实位说。具引唯识已见初地。二约寄位既是初果。初果初断见故

疏。以上三事防护自己所得者。三事即一治故。二我所故。三财物故。自己有所得。即前执着出没法定两慢。此为所护。总用三句释论护字。疏五中下总料拣也。五即前一本二起。三行四护五过

疏。得道品等者。正谓正道。助即助道。方便即方便道。并如前说

疏。第二成德果。文中二。先开章名。如下释。次此之四果下辨所从。言初二护小心果者。对下小行故云小心通上狭心。皆小乘心。今此二果俱从狭小二心所生。言二果者。一增上心欲果。二报恩心果。上护狭心是利他心。上护小心是自利心。护二利行为报佛心。俱护小乘即是心欲。今更增上即是其果。修此二利为报佛恩故。是其果。言后一是护小乘行果者。即发勤精进果。前护行中修二利行。谓成就庄严佛土等有五句。经前四自利后一利他。今皆勤行即是其果。上言后一复从前三果生者。即增上欲本心界满足果。谓于前增上心欲得满足故。报恩心得满足故。于勤精进得满足故。下疏文具

疏。前中初果者下。随文释也。先释第一果。通约护小故云上求下救

疏。今初即牒前小乘中总句者。总句经云。菩萨修行如是功德。为不舍一切众生故。疏文具配释之

疏。二治少欲功德者。谓不欲布施头陀等。今求上上胜法治之。三治不求胜智者。上不求功德。此不求智慧。此二治不摄善。初一治不离恶则恶止善行。总为自利。四即利他则离自利利他二行之过。亦是自分。后二亦胜进。前解后行解。言自见取者。执取自见以为胜故

疏。起报恩心果。疏文有二。先对三地明报恩义。则通对狭小。后上希求下。即近对护小乘中护小心也

疏。先别明后总结。亦可别明是报恩行。总结三心是报恩德

疏。别中彼行有九种类摄为七者。二三各二句故。此是论摄亦可九句。初一报恩心中六报恩行。后二解释。今初总欲起行顺佛化意也

疏。二有二句依同法者。即心极和善同住安乐。和善自行同住不扰于人故。共为同法起报恩心。言顺同行善友意者。以于同行起和顺故。同行即受善友之教。故于善友成报恩行。疏二句依法起行者。依师受法造缘修行。名依法行。顺师受教。知之言知。不知言不知。故名为直。以石投水水能受石。心能受境如水柔软

疏。无稠林行论经下。有一句云无谄曲心。论释云。不妄说己德。经以稠林含于谄曲。疏以不覆亦含自詃

疏。初二依人下。通相收束。约经初有三句。一句于师。二句于友。次三依行。经有四句。前二成德。后二离过。后二依教。一领教二得旨

疏。寂灭通结余句者。无覆无慢受教得旨。皆寂灭义。此依古释直顺经文。若准论经三句小异。忍名善心成就。调柔云寂灭。寂灭云善寂灭。论云善心成就者。是对治修行。增长故者。结前增上心欲果。此果从前第三分护烦恼行。及护小乘行二种对治生。彼治此满故名善心。今云忍者。即忍可也。论云寂灭心成就者。是前对治修行增长力故。即结前二离障果。由护烦恼对治家力。得无二障故。既无二障故曰调柔。论云。如是善寂灭心成就者。彼果前二句显。释曰。善即初句。寂灭即第二句。总合上二为善寂灭。成彼报恩心果。云彼果前二句显。由此一果通。从前二种对治增上。及二远离生故。释曰。总上三句结前四果

疏。谓二利行下。此释果名。于前不舍下。辨所生处。正是无尽行相者。以今经文释成第四无尽行相。先牒前者。此果正从护小乘行生。而是前果成时。此果即成故

疏。若琴弦之缓急者。此是如来教守楼那。彼是大富长者之子。足不履地。出家之后。精勤修道。足下血流。佛问。汝曾鼓琴耶。答云曾鼓。弦缓如何。答云不鸣。弦急如何。答云即绝。当如何可。答云。不缓不急。佛诲之言。修道亦尔

疏。六修习过余者。即经无等等精进。前句行修之初。此句行修之次。依前起行行修胜出。故名过余。后句行修之终故无能坏

疏。九自断疑等。即善分别道非道。言如无畏者。谓如四无畏言是出苦道。若有难言。若言圣道能出苦者。何故阿罗汉有疮疾等。佛于此难正见无由。心无怯畏善为决断故。论云能断疑惑等者。降伏他言正修习故。疏分二疑。二疑皆断为正修习

疏。本心界满足果者。疏文三。初释名。二出因。三引证。初中即是经中总句。心界清净清净即满足。界即性义。心性差别故。先释心界。言菩提分心者。谓依菩提心乐欲心也。即前增上心欲果释满足。云正念真如修上道品者。以称如修是满足故。即前起报恩心果。二由精进故者。是满足因三故。瑜伽四十八下。引证先举论。后故知此果下。疏释论可知

疏。此一自分下。皆胜进者。胜进八句。前六自利。后二利他前中为四。一第二句于他起解。二第三句于他起行。三有三句行成离障。四有一句障除得证。三中一除烦恼障。二除所知障。云秘密疑事。言微细法慢者。是下品慢难知为微细。微细故秘密

疏。八上依佛力下二句利他。此句由佛护故成利他行。九即利他德。先举论。后此除定中智障下。疏拣异第五句智障。今显于化生中现多三昧。定障解脱故。方能化生。第二位果中。疏四地已上寄出世之首故。重明有者。既为出世不依世间法也。言已上者兼五地故。上明有无。从表心出家下。明出家前却。问何以前二在摄报中。此在调柔之中。故云表心出家。于行中说疏。言阿含光者。此地之中道品行德从教修起。故名阿含。又道品智能知教法。亦名阿含。又此道品差别行德。可以言显。亦名阿含。即证体上有阿含起名示现也

疏。风等不坏者。经云风雨等缘所不能坏。不似火光风飘雨湿皆能灭无。今风吹不断雨洗还明。而云等者。余光不夺不似星月日光映。故合中下地不及即合上。余宝不及魔合上风。烦恼合雨。别地行中。不舍众生修道品故。同事偏多。摄报果中破众生身见者。自破微细见故。余例前知。四地竟。第五难胜地

疏。所以来者略有四义。一约寄位。二约三学。三约出世间。四约所得法。初中二。一约地论。二仁王下约他经。于中有二。初双牒二经。约人以配。拣前地论约所观行。二以七地未断分段故者。是贤首略释七地为罗汉之由。然瑜伽摄论唯识皆云初二三地相同世间。四五六地寄同声闻者。正明配位。即仁王文。经云尔焰圣觉达地菩萨。修行顺法忍。逆五见流集无量功德。住须陀洹。第五地云。胜进达菩萨。于顺道忍。以四无畏观那由他谛内道论外道论药方工术故。我是一切智人。灭三界疑等烦恼故。集无量功德故。即斯陀含。第六地云。常现真实住顺忍中。作中道观。尽三界集因集果。一切烦恼尽故。乃至证阿那含。第七地云。玄达菩萨十阿僧祇劫中。修无生法乐忍。灭三界习因业果。住最后身中。无量功德皆成就。无生智尽智五分法身皆满足。第十地阿罗汉梵天位。释曰。言第十者。此经通约三贤十圣。为十三位。修十三观故云十等

疏。言难胜者解深密下。此第一释中。先引经。后。此从初说下。疏释初分经下引证。言初分者。即胜慢对治。而是治当地慢随顺如道。经云。佛子。菩萨住此第五地已。善修菩提分法故善净深心故。复转求上胜道故。随顺真如故。即其文也

疏。唯识同此者。上引摄论即是本论。唯识全取彼论。世亲释下即释摄论。于中二。先举论。能合难合下。后释胜相

疏。瑜伽云者。即四十八论。诸相应增上住文。其庄严论即第十三。彼偈云。难退有二种。能退故难胜。今疏所引即彼论释。其显扬论即当第十三。此但引于当地之文。此前论云。五难胜地。谓诸菩萨住此地中。先善修治。第四地超一切声闻独觉地。证得已下。疏文全同。但有人云。诸法微妙慧蕴。今略无二字义已足故。其十住论亦十住婆沙第一。疏然诸经论下。四结前旨同。若据实位下实寄对辨。既初地中已能双照。岂至五地方有双行。故知。约寄即彼经上卷菩萨行品。疏故此地中下。三明断章。先标名。即前四地下释意则已尽。唯识具云。五于下乘般涅槃障。谓所知障中俱生一分。令厌生死乐趣涅槃。同于二乘厌苦欣灭。彼障五地无分别道。入五地时便能永断。由斯五地说断二愚及彼粗重。一纯作意背生死愚。即是此中厌生死者。二纯作意向涅槃愚。即是此中乐涅槃者。释曰。此地真如名类无别。故缘彼道名无差别。本分名身净我慢障。四地出世取身净故。由此欣灭如前已释。余诸经论言异意同。疏由斯证得类无别真如者。四证如。疏亦约生死涅槃皆平等故成赖无别。唯识释云。谓此真如类无差别。非如眼等类有异故。此由难见。摄论名为相续无差别法界。世亲释云。谓于此中体无有异。非如眼等。随诸有情相续差别。各各有异。无性意同。而梁论云。由此法界。能令三世诸佛相续身不异者。众生迷此万类之异。诸佛证此居然不异。中边论云。由通达此得十意乐平等净心者。上约极果。此正顺今。疏其所成行下。五成行。举此二者。以证净智而达五明。成于真俗不相违故

疏。此二无碍下。第六得果无差别。法身二谛均故。故疏结云义旨相顺

疏。第二正说下。疏文有二。先依论科。后初则加行下。疏释但属四道。不释其名。下疏自释

疏。论云胜慢下。此释分名。然论具云胜慢对治者。谓十平等深净心。同念不退转心故。前已说解法慢对治。今此地中。说身净分别慢对治。释曰。上皆论文。疏已分释。先正释名。后前地下。对前拣滥。前中具分二慢。疏即后总句。顺如与如同一念者。总句。经云随顺真如故。何法同如即十平等。然十平等已是随如。何故名同。由取胜相则不顺如。今若顺如则不取胜相。故为能治

疏。前地治解法慢。对前拣滥。虽与前地同皆治慢。前是世间所治则劣。今治出世身净之慢。则胜于前故名胜慢。安得滥哉。言得出世智不染身故者。前创出世成念处观。不染于身即是身净。取此不染所以为慢。净无净相慢何由生

疏。名深净心者。此句向上成二平等。以约如法而论等。故名之为深。以约净法而论等。故名之为净。故云深净心也。二者向下。则成此地观解之心。则五字分二平等。二字是净所依。其深净心是能依心。故次引论云。于平等中心得清净。言深净心即是论经。今经但云清净心耳

疏。此复何异下。对六地拣先问。后此有三下答。三中一所治通局通染则胜。二能所前后。若举所等以成能等。此心犹浅。若举能观以入所观。此观则深。三能治通局。一向局理。六地则深故

疏。结云此皆地地背相舍离。以胜舍劣。又上三义亦皆相成。由初所治局故。能治则通事理皆等。何独身净由所治通。能治则局一理平等。无染净故。净慢未除以等成观。此五地中已成等观。后六地中以观入理。则以初后成于中间

疏。即果位十力等者。此一等字等余果法。谓四无所畏十八不共三身四智等。非释平等平等净心。前已总释

疏。前中合为三学等者。释前六中二门分别。一约行。二约位。今初略嘱经文。云何见疑二净相显。此二同是根本。六种烦恼之中二故。戒取依于六上开出。又执为道相微难见。别为一句

疏。若约位下。二约位随难委释。言欲生真慧者。即出世见道慧也

疏。次三在见道等者

疏。释此三而文有三。一正释。二入见道时下征问。三涅槃说下引答问中。言十使俱断者。开之成八十八使。答有二意。一引涅槃已约重故。涅槃三十三因释观方。迦叶问云。如来说。须陀洹断烦恼如四十里水。云何言断三结。一我见。二非因见因。三疑网。佛答云。此三重故。亦摄须陀洹人一切所断结故。譬如王出。虽有四兵但言王出。又云。此三何缘独得名重。一切众生常所起故。微难识故。难可断故。能为一切烦恼因故。是三对治之怨敌故。谓戒定慧。又众生闻断多则退转。故但说三

疏。又十使中下。二约见修所断分别言余四通于见修者。谓贪嗔慢无明。见道之中四障见道。亦皆已断有障修者。不与断名。故略不言

疏。三本三随者。随者是末。身见即我。我于过去为有为无故名常见。我于未来为作无作。则起断见。故说边见随于身见。言邪见者。拨无因果以于谛理犹豫不决。遂拨为无。故说邪见随于疑网。既非因计因必取为实。故说见取随于戒取。根本既断枝条自亡。又言随者。三本名转如手转轮。三随名随如轮随手

疏。上五大小并同者。结前五净生后二净。二净大小开合不同。在位亦别。于中有二。先约小乘。后约大乘。于大乘中先行后位。约行同时义分断障。即行断净成德。即菩提分法上上净

疏。若约位分下。二约位。即增微分别。七地已还。虽亦进行断障义增。八地已上非不断障进行多故。是以二位各得一名。第二明如道行。疏又顺经意下。以下依论但顺三心。此之半分及后二分。皆是住心。摄于三位。此随如道摄第五住

疏。智清净等无痴乱故者。即下经文云。十重观察四谛法门。名智清净。正是无痴知第一义。如实而知即无乱义。而言等者。等取利益众生勤方便胜。皆无痴义。与彼行中释于无痴。义甚相顺

疏。摄德无尽故者下有四果。第一即名摄功德果。下三皆是功德果故

疏。总中四句皆是正修行故者。问四中。初一是四地行。何言皆是正修行耶。又后经云。入五地已善修菩提分耶。答有二意。一能治之行。必因所治展转相由。皆是修行。二者四地道品取其净相。以十净心而能治之。即入五地。入五地已。菩提分法不取净相。而非不行。不取而行方能善修故。后十净虽是所治。随如道时。亦不舍前十净心也。若远公云。皆正修行是论通难。恐有难云。若此如道取前净心。净心复取四地觉分。亦应觉分由三地生。何不取耶。故为此答。答云。此四即是四地已上。皆正修行。三地既是世间之法故不言耳。亦是一理

疏。后句虽起诸行不退失前平等净心者。即经随顺真如。论云。随顺如道行者。彼平等中深净心不退转现成就故。随彼平等清净法住。释曰。不退转心即此随如。末句意云。既以前句治于深心。取净相竟。今以不取深净之心随至不退转行。常于平等中住。为顺如道故。疏云虽起诸行不退失前平等深净之心。次论结云。菩萨如是深心安住。名为随顺如道故。疏云则能随顺真如。正是取此论文也。言平等即如者。会论就经。经云随如论取平等。云何是同故云平等即如。如前已释。问论云深心安住。何异前随彼平等清净法住。答前唯住平等故。疏云不失平等。今言深心则行顺如。为深心住

疏。后别明中。显随如行有八种者。问八皆事行何名如行。答有二意。一此八助显真如观故。二如中起行俱无所著。方显随如。别行可知。但第七句念智力所持故

疏。顺经释论。经云得念意与智力故。即以意为思慧。远公云。念是闻慧念持教故。意是思慧思求义故。智是修慧。以能离障上胜进故。此之三句同名智力。今经无意与言故。以念当二慧智当于修。第二不住道

疏。所知法中智清净者。谛是所知之法。智于其中照见离垢。故名清净。慈悲摄物名利益众生。无堕称勤善巧为方便

疏。瑜伽住品者。即四十八。论云。如是菩萨住此住中。多分希求智殊胜性。于四圣谛由十行相。如实了知

疏。言实法者。然有二义。一约真实名实已如疏文。二约对下十门随机异名故。名实法

疏。二明开合者。疏文有四。初一是合。后三是开。三中一约所化法分别。二约所益分别。三约化类分别

疏。三对实法以明通别者。六七八九此四唯别。但各一故。第十门望前五门。则名为别。但观灭道之二谛故。望六至九唯观一谛。则亦名通。远公后五亦言通者。何名通别。所观通四所成唯一。亦得称别疏。今初瑜伽十句不显文词者。即上住品。论云一切文词如契经说。但取经义。其所立义似今论释。但有小异故别出之。疏文有三节者。彼先具列三节之名。一为此说。二由此说。三如此说下。疏具辨。疏如次可知者。如次苦集灭道四谛次第。即是今经六七八九

疏。为说四谛十六行等者。谓苦下有四。即苦空无常无我。集下有四集因生缘。灭下有四灭净妙离。道亦有四道如行出故。是俗谛。疏即四重。二诸谛等者。言四重者。一假实二谛。二事理二谛。三四谛胜义二谛。四安立非安立二谛。广如玄中。今是第三重中者。以四谛为俗故。远公亦说三种二谛。一就相分别。情想之有名为世谛。无相之空名第一义。二相实相对。妄想之法情有理无。名为世谛。即此经中空如来藏真实之法。相寂体有名第一义。即不空如来藏也。三就实分别。不空藏中体名真谛用名世谛。今诸谛第一就第二门似非得意。疏不同瑜伽等者。瑜伽但云依晓悟他。是以通也

疏。为说法空第一义谛者。即四重中第三重内胜义。与前第一四谛之俗。共为第三重二谛也。三之与四明上二谛非一异义。三则非异。四即非一。又三即二而不二故。经云觉自共相。论云俱处四即不二而二。论疑是一由不二故。经了差别由而二故。又四即于谛常自二。三即于解常自一。五即总了二谛缘起相性。即仁王云。通达此无二真入第一义

疏。六为正见者。前中三疑四谬五离正念。并非正见。今无此非方为正见。故可明示四谛差别。则不随事执不谓空无。可令知苦断集证灭修道矣。事谓苦事所有受皆苦故。集能生苦

疏。无学之智如是而知者。是释经智字为答外问。灭是灭理何得言智。故此释云意在取灭

疏。道言无二者。略牒经文。具云出生无二故。论经云起不二行故。既称灭知故不生二行

疏。前列实法下。应有问言。此之四谛与前实法。俱列四谛有何别耶。答意可知。若准远公上释。则前实法四门各别。今则一一皆迷前四。故有不同。亦是一理

疏。未得本质故者。本质有二。一约未证佛智。则佛智为本质。二既未证于如来之智。于一切智所知之法。即是本质亦影像。知一切所证未亲证故

疏。第二利益众生勤方便胜者。既为利益观有为等。何偏明悲。对上观谛智清净故。其中虽有诸行悲为主故

疏。虚妄二字观内五蕴者。是疏标举。谓妄想下论释。从此明下疏释论。常作我想慢事故妄者论释。从此辨下。疏释。疏诈伪二字观外六尘者是疏。标举世法牵取愚夫故诈是论。此显下疏释论。其世法尽坏故伪是论。此明下疏释论。上虚伪二境者。虚是内境伪是外境。皆能引心合皆名诳。妄是内心诈是外心。皆能迷境故合名惑。疏论云常等下。向来疏文。合于二境二心。以配诳惑。论中内外能所别明。先明于内先所取。后能取后世法尽利下。明外能所。亦先明所取。后明能取。细寻易了

疏。愚夫即是依彼正取我慢之人者。上释诳惑下释愚夫。前有两对今唯就前五蕴能所。以明愚夫。五阴是人也。第二别起悲观。疏正明起愿愿救生义者。经云求佛智。而云救生。正同三地。欲救众生不离佛智

疏。今初无明有爱是流转因者。义至于此。从故生下皆属果摄。若取经句。应至故生以为句终

疏。牒前诃后者。牒前深苦诃后重苦

疏。机关苦事者。远公释云。容物动处。名之为机。于中转者说以为关。因名为机。苦果随转说之为关。今疏意亦尔。不别配二字

疏。二欲求中受欲者。欲求开二。一纵情五欲不惧当报。是造恶行者。二但耽五欲未必造恶。今是此人顺境生贪。违则生嗔。痴迷上二。不言习善行者。善行多在有求之中。亦以过轻故略不说。亦得含在受欲之中。疏观如实中下。对前料拣可知

疏。明远彼灭不向灭者。论云趣无畏处。不求十力大圣导师。意云。欲趣无畏之灭。不求证灭者耳

疏。顺怨道故者烦恼结使名为稠林。是魔所行故名怨道。既趣怨道即远真道

疏。略不明老者。上依论观生老病死。生苦在初病可卒加。通于老少故经明之。今生死言即兼死苦。老言不显故云略无。亦合有也

疏。总中无父曰孤者下。别之中经有八事。具释四字。前之四事明其有苦。后之四事明其有恶。各用二事释前之一

疏。常起邪念故为其覆翳者。依无明住地起妄想心。名为邪念。流注相续故曰常起。不同四住善恶间生

疏。不闻正法故为彼缠裹者。四住之惑容有善间。间则不缠。不闻善间故为缠裹

疏。二兴慈中经有三节。一初为物修因。二独一发心下孤标大志。三以是功德下以善益物。初令净障为涅槃因。言毕竟清净亦涅槃果。后乃至获得如来十力无碍智慧。令得菩提果。今疏虽总释义亦已。圆

疏。先牒前总明上来修善者。略举修善。实则兼前智慧观察。见生有苦有恶无治无救。故修善根而为饶益。皆慈相也。以善智慧能饶益故

疏。前二为救未来者。令住善因得于乐果。属未来故。即利乐义。频见上文。上句未住令住。下句先住微善后令增长。故得乐果。亦是上令舍恶。后令增善。疏下有五种令诸外道等者。前五世乐下五出世。五中一起信。二去邪。三正解。四起行。五得果。自下大文第三。疏有四圣果下文二。先指文列名。后四中下释其差别。前中一摄功德胜者。闻等功德修成名摄。二修行胜者。胜进所行善修习故。三四利他中。三利他行。四利他智

疏。一忍辱柔和胜者。能忍他恼名为忍辱。能将护他说为柔和。以柔忍故缘不能动。二皆拒恶故名为愧。唯崇戒善故称为惭。谓内怀下释惭愧相。惭者羞天故不诳幽。愧者羞人故不诳明。不招讥毁即护他也

疏。乃至命难不舍戒者。释坚固言鹅珠草系即命难也

疏。一增长因行者。福能生智故名为因。二依止因行。依慧生福名依止因

疏。六起净土行。论重释云。云何庄严无烦恼染。得坚固智慧众生住在其中。及佛法庄严故者。意云。净土有三种净。一相净。七珍严等易故不明。二住处众生净。三法门流布净。后二难故论重出之。既发意能成即具三净之因。广如初地净土愿中

疏。七依佛法身起行者。依彼相好法身起行求故下依义皆然

疏。九敬重法行者。上来行德依法成故第三教化众生

疏。应化自众者。随彼众类以身同故。即八地中身同事也

疏。一切种爱语中多约开演者。一切爱语皆有三种。一慰喻爱语。二庆悦爱语。三胜益爱语。三皆开示因果之益等

疏。即利行自性者。即九门之一唯有一也

疏。即一切利行未成令成者。一切亦三。此是其一。言有三者。一现法利行。二后法利行。三现法后法利行。以劝离欲令成就故

疏。上三即难行者。难行唯三故

疏。八总愿一切门一切种者。一切门者有四。一不信令信。二犯戒令戒满。三恶慧令慧满。四悭吝令舍满。言一切种者。或六或七。如净行品

疏。利行爱语亦可参用者。示其所学。约令行边即是利行。约其示边即是爱语

疏。如瑜伽四十三者。即指其源。瑜伽九门净行品已引

疏。第二结行成益者。亦名胜进行也

疏。第四随顺世智胜者明染障对治等者。染即烦恼是第五内明为治。障即所知是前四明为治。然瑜伽十三中列五次第云。一内明。二医方明。三因明。四声明。五工巧明。今染在前正顺彼论。疏算数即数建立者。第十五中说声明。论云。云何声明。当知此处略有六相。一法施设建立相。二义施设建立相。三补特伽罗施设建立相。四时施设建立相。五数施设建立相。六处所根栽施设建立相。第一法施设建立相者。谓名句文身及五德相应声。一不鄙陋。二不轻易。三雄朗。四相应。五义善。第二义施设建立。略有十种。一根建立。谓见闻等。二大种建立。谓依持洗润等。三业建立。谓往来宣说思念等。四寻求建立。谓追访等。五非法建立。谓杀盗等。六法建立。谓施戒等。七兴盛建立。谓证得喜悦等。八衰损建立。谓破坏怖畏等九受用建立。谓饮食覆障等。十守护建立谓育养盛满等。第三补特伽罗施设建立者。谓男女非男女声相差别。第四时施设建立者。谓过现未来三时声相差别等。第五数施设建立。谓三数声相差别。一者一数。二者二数。三者多数。第六处所根栽施设建立者。略有五相。一相续。二名号。三总略。四彼益。五宣说。若颂等名为根栽。如是五种总名处所根栽建立。释曰。今当第五。又数以记数算以记位。谓一纵十横等。瑜伽中意略已具矣

疏。咸善通达正当明义者。释其总名也。言种种诸论等者。即七例中论体也。七例如初地

疏。钞具引。即六论为体等。即等上亦等其类。六中随一容有多故。从地水火下略示六论之二。于一诤论自有其四

疏。图书下即六中之第二论也。随世所闻即释上义。出所宗尚故。疏又此图书下重释。即因明中论所据也。所据有十。谓所成立有二。即自性差别能成立有八。谓宗因喻同异类。现比教量。今此出教量下。兼现量

疏。即治所用事者即是本论故。论中但有书字。为所用事中忘障。取与下即论释此障。论但通云取与寄付。闻法思义作不作事。已作未作事。应作不应作事。此对治故。书释曰。今以义节论文。于此一障自为三节谓一事中障。二解中障。三业中障。便以疏解意。言作不作者。但作者书之。言作不作者书之言不作。未必恶不作而善作也。下二准之

疏。印玺亦是现量者。论中有印而无于玺。今以加玺故云亦是现量显现可见故。又治所取物不守护障。即是论释印字。如盐米等以印印之。则无强取

疏。三又善下医方明者。然瑜伽医方明有四。一病相善巧。二病因善巧。三于已生病永灭善巧。四已断病不复更生善巧。今文具之

疏。即四大不调众生毒相病障对治者。即本论文。从善疗下。疏以瑜伽四义解释。一即第三除断方便。二即第四断已不生故。涅槃云。世医所疗治虽差还复生。如来所治者毕竟不复发其疗治除断即是第三。其一善字即当第四。从颠至蛊下。辨初二义。先总指经。后于中下别属颠等。内四大下皆本论释。然颠狂干消正明病相。四大不调故沉重地病相。冷水病相。黄热火病相。风相多端。其颠狂二事。亦是病因。由颠狂故。应食不食。食不应食。应作不应作等。故生诸病。鬼魅蛊毒正是病因。因鬼魅等而生病故。亦是病相鬼等病故。从论经说咒药等者。疏会论经。今经无咒故论以药咒为能治。即是今经善方药摄。病因死因即是所治。以咒药力应死不死

疏。四文笔下工巧明者。瑜伽工巧有十二种。今略有六。一书算计度数印工业。而文笔赞咏但属书摄。其算数计度通其二明。前疏之中已配声明。故此不说。二音乐工业。言皆忧恼障对治者。即是本论。凡言对治皆是本论。弦竹娱耳故除忧恼。三营造工业。四营农工业。而言亦者。草树华果有两句故。布列宫苑即是营造。树之园圃即是营农

疏。此即不喜乐障治者。峻宇雕墙朱轩玉砌。居然悦情。况池塘生春草。园柳变鸣禽。洪波跃渊渔。清风吹落华。纵意林流间。欢爱弥日夕。岂能忧哉。五生成工业。能作能成故。言系闭障对治者。家有千金不死于市。何能闭哉。六占相工业。是所得报分过恶因障对治者。先举论。谓皆由下是疏释论。不知过去作业因感。便取外相为吉凶源。乃造恶业排凶招吉。安得可耶。今示因招使修德业。排凶招吉即为能治。五星者。东方岁星主春主木。西方太白主金主秋。南方荧惑主火主夏。北方辰星主水主冬。中央镇星以主于土。通主四季。星者散也。列位布散。汉书云。星者金之散气。与人相应。凡物之精上为列星也。言二十八宿者。谓角亢氐房心尾箕斗牛女虚危室壁奎娄胃昴毕觜参井鬼柳星张翼轸。广如大集四十中。经云。娑婆世界主大梵天王释提桓因四天王等。而白佛言。过去天仙分布安置诸宿辰曜。摄护国土养育众生。于四方中各有所主。东方七宿。一者角宿主于众鸟。二者亢宿主于出家求圣道者。三者氐宿主水出众生。四者房宿主行车求利。五者心宿主洲渚众生。六者尾宿。七者箕宿主于国师。南方七宿。一者井宿主于金师。二者鬼宿主于一切国王大臣。三者柳宿主雪山龙。四者星宿主巨富者。五者张宿主于盗贼。六者翼宿主于贵人。七者轸宿主须罗吒国。西方七宿。一者奎宿主行船人。二者娄宿主于商人。三者胃宿主婆楼迦国。四者昴宿主于水牛。五者毕宿主于一切众生。六者觜宿主鞞提诃国。七者参宿主于刹利。北方七宿。一者斗宿主尧部沙国。二者牛宿主刹利及安钵竭国。三者女宿主殃伽摩陀国。四者虚宿主般遮罗国。五者危宿主着华冠者。六者室宿主乾陀罗国输卢那国。及诸龙蛇蝮行之类。七者壁宿主乾闼婆善音乐者。大德婆伽婆。过去天仙如是布置四方诸宿。摄护国土养育众生。释曰。此皆西域之事。此方所主分野等。又有差殊。经文有之。略知去就未穷玄象。非我之愆。难胜圣人不习而利。然天垂象圣人则之。故系辞云。辞也者。各指其所之。易与天地准。故能弥纶天地之道。仰以观于天文。俯以察于地理。是故知幽明之故。原始反终。故知死生之说。释曰。其知幽明即中知人情。瑜伽之中余六工业者。一和合工业。二咒术工业。三商贾工业。四成就工业。五防邪工业。六事王工业。广如彼释

疏。杀生祀祠求梵福者。即智论百论皆说。外道杀马祀梵天祈生梵世。今以慈悲喜舍四无量心。能生梵天治其邪见

疏。五四无色定治妄修解脱者。外道以彼为涅槃故。今能入之。示其谬计。此经论中唯说世间为内明者。经明随顺世间智故

疏。上来所释等者。本论亦不全属五明。但有治障治染之别。瑜伽之中广显五明。与此相应故双用之

疏。又论与经有不次下。意拣古人。今疏以论就经之次。古人依论次第异经。刊定记中全写探玄。亦不对会二经之殊。况辨论释与经之异。恐寻论者。及见古疏怪其不同。故结示耳

疏。但于众生不为损恼事者。贤首品云。若见世界始成立。众生未有资身具。是时菩萨为工匠。为之示现种种业。不作逼恼众生物。但作利益世间事。即其义也。而论但云异障中无障故。余皆如疏释。疏三发起清净论经云怜愍众生故出者。出即今经咸悉开示耳。第二位果中。疏证智契如事为真金者。论云此地智光明真如事示现。如经诸佛子譬如真金等。释曰。证智为真金。如为所契之理。智为能契之事。事合于如故云如事。教智能显上之如事故如砗磲

疏。日月等光者。远公云。梵本唯以星光喻于此地。意云。六地方用月光喻。故理应合然余如前释五地竟

大方广佛华严经随疏演义钞卷第六十三大方广佛华严经随疏演义钞卷第六十四

        唐清凉山大华严寺沙门澄观述

第六现前地

疏。所以来者。来意有二。前约寄位及三学说。谓五寄声闻。六寄缘觉。从四地去皆属慧学。今亦对五以辩来意。慧与寄位名义相似。故合为一

疏。又四地下。第二意约断障证如。以辩来意。四五六地同是顺忍。染净相带故举四地。四地出世唯净。五地见染可随。此地能亡染净而言观察。约加行说故。瑜伽下引证。论文有三。一明五地之德证。上能随胜于四地。二而未能下。明无六地之德证。上不能破染净之慢见。然有二意。一不如实观无染净故。二又由下多生厌故。三为令下正对五地不能故。此能来

疏。十住论云。降魔事已者。生死涅槃即菩萨魔事。生死是凡夫行。涅槃是二乘行故。生公云。三界涂阻。二乘路险。五百由旬是菩萨恶道。甚难过矣。今超圣意亦越凡情。故能降之。又智论云。除诸法实相皆菩萨魔事。今证般若能契实相。故过魔事

疏。多修无相此约地初下。释上论文。疏摄论下文三。初引论。次此释下会释。后无性下引彼释论

疏。唯识名为下此文有三。初正释。二以观十平等故者。以经就论。三由斯下重引唯识明断二愚。疏本分下。即引本论正释。后执细染下。疏释论文会通唯识。疏第二正说。疏文有三。初总科。二亦初分下对前相摄。三今且依论下。正依论释。于中三。一对前料拣二释分名。三正释文。今初有三。初标胜相。二胜相云何者。疏假征起。三谓第四下释显胜相。以四五六地皆治慢故。是以对之。远公云。四五六地同是顺忍。行相广同所以对之。亦有理在。若尔前之三地同是信忍。何不通对。七八九地同是无生忍。为难亦然。故依治慢通对诸地。下言渐细则显前粗故。此三地后后细于前前。论文具示三慢。而粗细相隐。今当示之。四治三地。众生我等依世间起。此慢最粗。五治四地身净慢。依出世起。故知渐细。六治五慢。双就世间及出世起。故为更细。疏。众生我慢等者。准四地果中治有四慢。一离众生我着。谓离我人众生寿命。二离法我着。谓蕴界处。三离解法慢。经云执著论云我知。四离正受慢。经云出没。论云离我修我所修等。今此但云众生我慢解法慢者。以四中初二是本。后二是所起。本及所起各举初一以摄一故。略无法慢及正受慢。余如四地广说

疏。身净慢者。四地之中得出世智。修四念处名为身净

疏。所治既细下。出初分为胜。今以上例后。则不住行及彼果分二皆胜也

疏。染净慢者下。第二释分名。即当地能所治。于中三。初举所治。二辩能治。三通妨难。今初先正举染净。可知。后又十平等下解妨。先问后答。问有二句。展转而起下答当知

疏。但约净说下答。此上一句双答前二。一者上问云十平等法。何有染净。故今答云。前十平等但约净法。谓三世佛法及七净故。二者上问云。前五地初取十胜相。以随如道而为能治。如岂染净。故今答云亦约净如以破前十净。同一如故

疏。染相未亡对染说净亦名取净者。此通伏难。难云。前地观于净如。染慢许生何有净慢。故今答云。前所观如入观。则能出观随有犹见染相。染相既存。对染苦集。还生净相灭道之见。故有斯慢。虽有三重救难。染净之相皆存

疏。今以十染净平等而为能治者。第二能治。此之一治。诸难都寂。谓既染净平等则异前地十净平等。二者染净既等。不唯但能观于净如。则双通二三之两救也。又多修无相出观少故。便为能治。疏下观缘起下解妨。上引前难后。今引后难前。缘起逆顺同前四谛染净相。故答云。五地初能入俗悟空未深。无相般若悟空方深

疏。列中十句下

疏。文有二。先别释后料拣

疏。总云一切法者。经中有三。初一切法是平等。法体二无相是平等因。三平等是所成义。别中前七以无遣有。然其疏中解前七句。自有五意。一依论。总句是十二入。则别别句皆十二入。谓十二入体十。二入生等。二者通遣十二入。上三性之义初句遣遍计。故云此遣分别。分别古译遍计之名。次四染分净分俱遣依他。六七皆遗圆成。疏文自具三者。为破前地之慢。慢依四谛而起。初二遣苦故初云想。二云生者诸入苦果。次一遣集。以成是苦之因故。第四句遣灭。故云非灭惑方净。第五句遣道。故云谓道分别。六七亦遣灭。然四是灭惑名灭。六七即显灭理之灭。故皆云真如。四约进观。后位有十二缘观。前三遣染缘起体生即识等。七苦成即三烦恼二业故。次三遣净缘起。谓四遣无明灭行灭等。五遣能逆观之智六即所显真体。七双遣染净。染净平等故。五约五法。初一遣名及与妄想言分别故。次三遣相。染净皆相故。五遣正智无分别故。六七遣如如。以离取舍本来寂静故。然远公更有一意。谓约三空。初之一句遣分别想。即是空门。中间五句遣其名相。是无相门。末后一句遣取舍愿显无愿门。此与初地义同。初地以空门治分别。无相治相。无愿治取舍故。此非无理。疏以十句皆通三空。故不显之。但有五意耳。疏上之九句下。第二总相料拣。疏文有二。一明遣三会一。谓遣有遣无及俱有无会非有无之中道也。二又此不二则不坏有无下。重明第九成不坏义。能遣俱句及俱非句。即分为二初以不坏有无。成俱非义以遣俱句。后以不坏有无。成俱句义遣俱非句。今初先标不二。意云。若无有无将何不二。故涅槃云。若无一二云何说言非一非二。故不二义成于不坏。谓说空遣于有执下辩相。于中先明不坏以成俱非。此句明不坏空。而非相于空故空非空也。言说有为遣空迷者。此句明不坏有。而非存于有。故有非有也。故成俱非。次云有是不异空之有。空是不异有之空者。此二句显经不二成不坏义。次云无别空有而为二者。正遣俱也

疏。又既不二亦不坏有无下。第二明不坏有无。以成俱句遣俱非也。上二句标。从则不异无之有是不有之有下。二显相。此句将不二立有。次云不异有之无是不无之无者。将不异立无也。是为由不二故不坏。不坏则空有双存。结云则遣俱非。疏斯乃四句下。结叹。谓上遣四句。又借俱非以遣俱句。非立俱非。今将俱句以遣俱非。非立俱也。虽遣四句不坏四句。存泯无碍故。结云百非四句诸见皆绝。然远公但有初段。遣三会一。彼云。此与涅槃十一空大同。彼亦用前八以空遣有。第九一空以有遣无。第十空空有无俱遣。彼处大空就空实以论。亦是一理。十一空义至下当明

疏。第四辩行分齐。文中四。一略释经文。二彰忍数类。三会释经文。四彰忍差别

疏。仁王下。第二彰忍数类。仁王五忍历位但成十四。璎珞加一五忍之相。辩差别中当影出之

疏。今四五六皆得顺忍下。第三会释经文。由慢有粗细故。忍分三品。四地治众生我慢解法慢为粗。得下品忍。五地治身净慢次细。得中品忍此地治染净慢最细。得上品忍。故云治于细慢。故云明利。明无不鉴利无不破。然治由习增故。从下至上障由渐断故。从粗至细。言顺后无生者。顺忍有二义。一者顺法故。十忍品云。法有亦顺知。法无亦顺知。二者顺忍未证无生。随顺彼忍故。今约位说。前为后因正宜此释。由此地破相趣入真境故。顺上地无生忍

疏。然约实位下。四彰忍差别。疏文亦三。初总明实寄不同。二寄位何以下。假问征起。三谓若约空无我理下。辩差别相。于中有二。先明通相。后彰别相。前中通则初地明得。谓初地得无我。亦得名空平等理。亦可名为无生无我。即是空无生故。六地名空平等。亦可得名无生。无我空平等理。即是无生空无我故。七地已上得无生忍。亦可得名无我及空平等。以无生理即是无我及空平等。故名为通

疏。今不得者下。彰其别相。则非唯初地未得此忍。而此六地亦未得之。以约分别无我与空及无生理。三相异故。文中二。先总标二。一约空下释有四门。即分四别。第一门中正开前。约理通义初显无我。言破性显空者。若人若法皆无性故空。此则义当信忍。举初摄后故云初地

疏。今此地中破相趣寂名空平等者。岂唯无性相亦不存。故经文云无相无体故平等。非唯有相空相亦遣。方为真空平等理也。义当顺忍。举后摄前义该四五

疏。若约证实下。当无生忍。举初摄后义该八九。而言证实反望者。上之二义。但破空性相故。今已证实反望性相本来常寂何俟破。竟方说无我及空平等。言斯理转深者。则上空平等中。亦合言斯义渐深。文略无耳

疏。若约契本常寂下。即寂灭忍。举初该后。云十地后得。而言契本常寂者。前无生忍证实望相。则前所破与所证未同。今寂灭忍契所破常寂即所证故。故云最妙

疏。二就行分别等者。此约生起名生。七地顿起何名无生。以起行皆遍无可新起。故云无生耳

疏。三约空有者。亦是生起之生。不同前行随一行中有空有故。入观起空出观起有故。间起名生。七地常在观。而涉有不迷于空观空不碍于有。故称方便。更无出入之殊。故云无生

疏。四约修分别者。此约生熟之生。生涩名生纯熟名不生。七地犹有功用。故名生涩。八地无功任运而进。故云纯熟

疏。第二不住道行胜等者。先总科。后今初下别释。然总观心境。远公云。约初入心明不住道。从作是念下。就正住地明不住道。今但为标不取古释

疏。由前观察随顺得至不住道者。故论经云是菩萨如是观一切法随顺得至。论释云。得至不住道行胜故。今经略无随顺得至之言。而言如是观已意则合有故

疏。取论摄前释之

疏。今初三中下。且释能观三悲。疏文有三。初正释文。二彰次第。三义门料拣。初中以虽同一切智观下。释论正释胜字。若无大悲即同二乘。今有故胜。然一切智观者。即大品经以声闻名一切智。菩萨名道种智。如来为一切种智。此则横对大小因果。分此三别不同。谓佛为一切智观三世流转者。将下经意。释论不舍过去现在未来之言。其厌离有为即下论。观名依大悲为首立此观故。而以大悲下。正释胜义

疏。谓以道相智观下释论。即菩萨自智也。不唯但观三世。对上显胜。次遍了诸法下。当相辩胜。言了诸法者。若内若外有为无为无不知故。以此导下。明由智胜故悲成增上

疏。谓以一切种智下释论。即如来智也

疏。三悲为次下。第二彰次第

疏。据论现文下。第三义门料拣。于中有三。初明二护。二明二利。三明不住。而文分二。先别明初门。后三门通例。今初二护自有二义。一按论文。由上文大悲为首者。不舍过去现在未来。即是智义。大悲摄故即是悲义。悲护小乘智护烦恼。后二但言一切法中智清净故。一切种微细因缘集观。明唯约智。疏既三俱下。第二通例观即烦恼护凡悲即护小。二护即具二利。有智故不住生死。有悲故不住涅槃。故三义具矣

疏。前灭后生者。无明缘行。前缘已灭引起后故。若前不灭则堕常故。若后不生即是断故。无明缘行者。由前灭故后方得生。十二支皆然。自是一义释之

疏。言染生净灭者。无明缘行行缘识等。即是染生。无明灭故行灭者。斯为净灭。下引杂集名染净观。又次经云。由着我故世间生为生。不着我者则无生处名灭

疏。第二别明观相等者。疏文有三。初总显深广。二举经辩深。三依论科释。今初文三。初标举深旨。二引论略开。三融通无碍。今初疏云然缘起深义佛教所宗等者。自古诸德多云三教之宗。儒则宗于五常。道宗自然。佛宗因缘。然老子虽云道生一一生二二生三三生万物。似有因缘而非正因缘。言道生一者。道即虚无自然故。彼又云。人法地地法天。天法道道法自然。谓虚通曰道即自然而然。是则虽有因缘。亦成自然之义耳。佛法虽有无师智自然智。而是常住真理。要假缘显则亦因缘矣。故教说三世修因契果。非彼无因恶因故。楞伽经大慧白佛言。佛说常不思议。彼诸外道亦说常不思议。何以异耶。佛言彼诸外道无有常不思议。以无因故。我说常不思议有因。因于内证岂得同耶。是则真常亦因缘显。净名云。说法不有亦不无。以因缘故诸法生。法华亦云。诸佛两足尊知法常无性。佛种从缘起是故说一乘。下经云。一切诸法因缘为本。中论云。未曾有一法不从因缘生。是故一切法无不是空者。则真空中道亦因缘矣。若尔涅槃十六云。我观诸行悉皆无常。云何知耶。以因缘故。若一切法从缘生者。则知无常。是诸外道无有一法不从缘生。是故无常。则外道有因缘矣。释曰。此明外道在因缘内。执于缘相以为常住。是故破之言无常耳。今明教诠因缘妙理具常无常。岂得同耶。况复宗者。从多分说。所以因缘是所宗。尚不应致疑

疏。乘智阶差浅深多种者。乘谓三乘五乘。三乘观缘已如上说。五乘人天亦以戒善为因缘矣。智谓智慧如下所引。下智观者。得声闻菩提等。以大乘中既分因果故。智异小乘。言阶差者。复有二意。一则上结随乘智异。二如一菩提随观深浅。亦多阶级故云多种

疏。龙树云因缘有二等者。第二引证略开。即十二门论文云。谓水土人工时节谷子为因缘。而芽得生。乳及酵暖人工为缘而酪得生。泥团轮绳陶师等缘而器得成。皆外因缘也

疏。然外由内变下。第三融通无碍也。外诸器界。内识顿变增上之果。亦因自业故云内变。言本来相收者。内即是本外即是末。以唯心义。则内收外托境生心。则末亦收内。若以法性为本。法性融通缘起相由。则尘包大身毛容刹土。是故合为一大缘起也

疏。染净交彻义门非一下。当略示者。然瑜伽论云。缘起门云何。谓依八门缘起流转。一内识生门。二外缘成熟门。三有情世间生死门。四器世间成坏门。五食任持门。六自所作业增上势力受用随业所得爱非爱果门。七威势门。八清净门。释曰。然论不释义略可知。八清净即无明灭行灭等。七威势即势用。缘生无明缘行等。六自业所作即正是有支习气。五食任持。即四食不同随界通局。四器界可知。三有情拣外无情。二及外缘门如论说。一内识生。即名言习气。言下当略示者。非但门有其八义。亦无量散在经疏。随文释中及下释缘起竟处。总结十门之意。收十为五。乃至显四佛性融为大缘起等。义门既散。今且就内略示染净。一染缘起。二净缘起。三染净双融缘起。此三缘起各有四门。染中四者。一缘集一心门。二摄本从末门。三摄末归本门。四本末依持门。第二净缘起亦四门者。一本有门。二修生门。三本有即修生门。四修生即本有门。第三染净双融。亦四门者。一翻染显净门。二以净应染门。三会染即净门。四染尽净泯门。以此诸门。及该内外无尽事理。并合为一无障无碍法界大缘起也

疏。今经文内略显十重等者。第二举经显深。于中有二。先总科经文。文有十重以显无尽。后各有逆顺下。展转开显以辩难思

疏。古人兼取彼果等者。疏意不美此释。亦不言非。故举古人不言去取。若依染净逆顺成四十重。三观历之成百二十。斯理然也。疏论三观者下。第三依论科释。于中二。先依论立观。后以论会经。前中有六。一列名二。初但观二谛下释相。皆以前三悲会之。三初一下。同二乘下会同大品二智。四故涅槃云下。以涅槃证成。涅槃开于二乘教行不同故。二乘异大品。合其理果是一。故合二乘。义皆符此故得并引。五前约为物下。释通妨难。为有问言。经是三悲论为三观。岂得引前。以成今说故为此通。六融此三观下。融通显胜。言三观一心者。即同空假中也。一人顿修非约乘分。言甚深般若者。般若有二。一者是共。如云欲得声闻乘当学般若等。法华云。一切诸法皆悉空寂。无生无灭无大无小无漏无为。如是思惟不生喜乐即共般若。此名为浅。今悲智双运。理事齐观故。其所发即是不共。为甚深般若矣

疏。然论三观虽遍释经下。第二以论会经。于中有三。初标举。二别释三观开合。三二利分别。今初言与十门有开合者。如初观总束十门为三。则经开论合。而分第二一心所摄。前半为第一义。即经合论开。其第三观开初门。前半为染净分别观。后半属依止观。即经合论开。以八九二门为无始观。即经开论合

疏。初一切智观下。第二别释三观开合中。初观有二。先正明。后所以分三下出所以。今初言十中初门者。即有支相续门。二摄第二门中之半者。即摄归一心。前半经云。佛子此菩萨摩诃萨。复作是念。三界所有唯是一心是也。三摄余八门半者半即第二一心门中从如来于此分别演说下。及尽第十门

疏。第二大悲随顺观中亦二。先正明。后出所以。今初。一观众生愚痴颠倒者。谓痴迷性相倒执我所故。二余处求解脱者。即谓凡夫愚痴颠倒常应于阿赖耶识中。及阿陀那识中。求其解脱。乃于余处我我所中求解脱故。第二一心门明唯一心。可于中求心外无法

疏。三异道求解脱者。论云颠倒因此有四种。一冥性因。二自在因。三苦行因。四及无因。如次四门破之。一自业助成门明有支。各有二种。由业能生非由冥性。二不相舍离门。明以无明等为行等因。非由自在。三三道不断门。明业惑而为苦因。欲求脱苦当断业惑反修苦行。是起妄业计苦行。心即是烦恼。如是妄想宁是解脱因耶。四三际轮回门。谓既以前际二支是中际五支因。中际三支是后际二支因。何得言无因耶

疏。四求异解脱摄后四门者。谓不识真解脱求三界苦等为解脱故。名之求异。真解脱者。有四种相。一离一切苦相。二无为相。三远离染相。四出世间相。此四即涅槃乐常净我故下。四段破之。一切第七三苦集成。但有妄苦而无真乐。二即第八因缘生灭无有常德。三即第九生灭系缚。但是染缚无有净德。四即第十随顺无所有尽。以顺有故非是出世。故无我德也

疏。此之四门下。第二出四所以。亦拣四门之别相也

疏。第三一切相智观中一染净分别观者。谓计我缘生为染。无我缘灭为净。二依止观摄初门。后半及第二门者。谓初门有二。佛子从后佛子明迷真起妄缘相。次第半门明依第一义。以不知故即起诸缘是为染依第二门明见第一义。诸缘转灭便为净依。三方便观者。即第三自业助成门。谓因缘有支各有二业。为起后方便。若灭前前则后后不生。是解脱方便。四因缘相观。即第四不相舍离门。谓有支无作故。既由前前令后后不断。助成后后则后后无性。何有前前能作。后后即以无作为缘之相。五入谛观者。即第五三道不断门。三道苦集谛故。逆观即灭道故。六力无力信入依止观者。即第六三际轮回门。谓此三际为因义边名为有力。为果义边名为无力。若约三际。前际于现五有力。于当二无力。中际爱等于当有力。于现无力。以斯三际化彼凡夫。令信入依行。七增上慢非增上慢信入观者。即第七三苦集成门。不如实知微苦。我慢即增上慢。若知微苦非增上慢。不知令知名为信入。八无始观者。此有二意。一约俗说因缘为生灭之本。生死无际故因缘无始。二约真说。见法缘集无有本性可为依止。故名无始。摄八九门者。第八门因缘生灭。但一念缘生即是不生。故云无始。第九门随顺转故。而生非有本也。九种种观摄第十门者。即随顺无所有尽门。由随顺有故有欲色爱等之殊。故云种种

疏。然其三观俱通二利下。第三二利分别。三观为三。第三观中先总。后于中下别明。言次二利他者。即六力无力及七增上慢。皆令他信入故。言初二通染净者。初门名染净分别故。次门迷为染依悟为净依故

疏。列云一示染净相。二示染净依

疏。后三唯观染者。以第三方便观一染法之因。自业助成故。上文云亦解脱方便者。约逆观说。本明染法。言二染法之缘者。即第四因缘相。观前约业亲能生后。故说为因。今约助成不相舍离故。说为缘言。后一就染观过者。以入谛观。正约顺观但苦集故

疏。次二利他中等者。有力无力令凡信入。能所生义即增上慢非增上慢。令小信入。以微细行苦二乘不知故

疏。初真谛观者。上释无始。虽通二义约真为正故。后俗谛观者有种种故

疏。次正释文下。第三释文。于中有三。一总示释义。二指文分齐。三依论科释。今初云。并以三观释之。更无别理者。因古德总有四重。一直释经文。后方依论三观重释。不知直释名为何观。既别无观如何异论设有别观。又不出名。亦令论主释未尽理故。云但以三观释之更无别理

疏。经之十段下。第二指文分齐

疏。先依相谛下。第三依论科释。于中亦三。初依论正科。二此三若望十门下。总释三意。三今初成者下。正释经文。于中又三。初总出文意。二辩定所破。三方释文。初一可知

疏。此是正破我执习气者。第二辩定所破。即唯识第八释外难颂。难云。若无外缘云何有情生死相续。故有颂曰。由诸业习气二取习气俱。前异熟既尽。复生余异熟。释曰。下取意释熏习气分名为习气。即是种子诸业。习气即罪等三业。二取习气总有四种。一相见。二名色。三心及心所。四本末。第八异熟名之为本。六识异熟名之为末。业是增上缘。二取因缘互相助成。故生死流转。此第一师义。第二师云。生死相续由诸习气。然诸习气总有三种。下亦义引。一名言习气。二我执习气。三有支习气。有支习气谓招三界异熟业种。广如下明。名言习气前已频引。即下经云。于三界田中植心种子。言我执习气者下。具引论文。谓虚妄执我我所种子。我执有二。一俱生我执。即修所断我我所执。二分别我执。即见所断我我所执。随二我执所熏成种。令有情等自他差别。解云。然俱生我执通六七识。分别我执唯第六识。因我执故。相分之中亦熏五蕴种子。即名言熏习我执种子。令自他差别故。别立之故。有支我执皆增上缘。颂明二取习气即我执。名言取我我所。及取名言故皆名二取。释曰。今经破此我执。亦即俱舍颂说前后中际。为遣他愚惑。以三际愚俱愚我故。如下三际轮回中释瑜伽论中亦遣三际愚惑。于我与俱舍同。又云遣三际愚遣内无知。若遣非情无知即遣我所故。今破二我以显二空。疏文中二句下。第三正释经文。于中有三。初略释经文。二举论经会释。三引论反征。今初先正释。后此直顺下结成。今初言但是苦集者。世间受生即是妄苦。着我之心即是集因。言是灭道故者。若离此着即是道谛。则无生处即是灭谛

疏。论经言下。二举论经会释。于中四。一举论经。二以我执下。以唯识意释成论经。唯识云。随二我执所熏成种。令有情等自他差别。三故论云下。举本论自释。既言五道中所有生死。明是一一道中自他之身差别义耳。四若五道下。以业习气成上我执但令自他差别之义。谓业能令自他共有。若人若天苦乐六道。即有支习气。若我执习气亦二取摄。已如上辩

疏。又论主反征下。第三引论反征。释于中三。初总标。二别征释。三结成无我

疏。初征着我下。二别征释中二句。先征世间受生皆由着我。后征若离此着则无生处今初于中二。先标举。后若第一义下。举论牒释。然论但云若第一义中实有我相者。着我之心即是第一义智。不应世间受身处生

疏。有二释。一依百论纵夺势释。二依因明立量。以释前中数节论文。以为三段。兼疏有四。一初句按定。二次句纵立。三后句正征。四何以着我下。即疏举经反质结破。但观向引论文。自分主客云何结破。然有二意。一结成纵破。纵其有我已成过故。举经反成。二着我既世间生。明知着我之心非第一义智。所著之我非第一义。明理无我矣。即夺破其我

疏。此中应为立过下。第二依因明立量破

疏。文已具。然总意云。谓第一义我是有法。凡应同圣是宗法。以我是持自性法。有彼凡应同圣宗中法。法与有法和合为宗。因云以有第一义中实我智故。同喻如生尽圣人。上三支已具。凡应同圣。此句合结应云生尽圣人有实智。生尽圣人是圣人。凡夫既有实我智同彼圣人。是圣人而言生尽者。遮不定过。若但云圣人。恐有难云。为如须陀洹七反受生之圣人耶。为如罗汉我生已尽之圣耶。故定取后句。大乘顿悟八地已上即同罗汉。渐悟初地许其生尽。从凡既同圣例成一过。凡应同圣是杂乱过。今无圣人是断灭过

疏。次反征。后句下此第二反征若离此着则无生处。文中二。先标举。后又复下牒论解释。然论但云若第一义中实有我相者。若离着我则应常生世间。今疏亦有两重解释。文小异前而分为三。初以百论纵夺势释。二以因明立量以释。三举经双结反质以破。初中然准前论。亦应有三。而文稍略。兼疏为三。初按定所执。二若离此着我应常生世间。即以理正征。三以不称实下

疏。释论意。即同前第二反以纵立。而论含在前若离此着句中。谓第一义中实有于我以为真理。今离着我则不称理。同于凡夫违理妄执。斯则纵成

疏。此中应为下。第二立量。破应云。第一义中实我是有法。圣应同凡是宗法。因云以有无我迷理倒惑故。同喻云如诸凡夫。则三支已具。疏云此结成圣应同凡。即合结也。应云。凡夫有倒惑。凡夫是凡夫。圣人有倒惑同彼凡夫。是凡夫成杂乱过。次云圣既同凡下。例结一过成断灭过

疏。是以经云下。第三举经双结反质以破。言双结者。双结百论因明。结百论者。谓纵其有我圣应同凡为纵破。今离我不生明定无我。即是夺破。若结因明立量。但是纵成其过。是他比量今举经无我。则彼量不成。谓离我既不受生。则知第一义中定无有我。安有我智。故疏结云反显妄情定是过也

疏。二过既成下。结成无我可知

疏。第二倒惑起缘。即论明答下分四。一释答。二就文分三下总科。三今初然十二下。以义收束。四且依十二下正释经文。三中瑜伽对法。皆同为四。今依唯识第八。论文未尽下疏具之。然能所引皆在因中。能生所生因果对说故。唯识第八明十五依处。建立十因中。三习气依处。谓内外种未成熟位。即依此处立牵引因。谓能牵引远自果故。今取起种但名能引。其能所生即彼论云。四有润种子依处。谓内外种已成熟位。即依此处立生起因。谓能生起近自果故。正当今文。爱取有三是已润故

疏。此约二世下。会通经论。若准唯识。三世小乘。今案下经具明二义。言生引互通者。无明行中有爱取有。爱取有中有无明行识等五果。即生老死俱是果位。并如下说。言且依十二者。以此经中次第行列故。又欲总收二世三世故。然就经文且合分五。一无明。二行。三识。四名色。五合辩余支

疏。初至有无是无明支下。此段有五。一科经。二无智是痴。下略释。故论云。此示无明有爱。是二有支根本故。有爱即三有之爱也。亦同涅槃生死本际凡有二种。一者无明。二者有爱。是二中间即有生老病死。三然依三世下。通难释成。应有难云既举二支为有支本。那得上判唯属无明故。为此通。初依三世。即俱舍云宿惑。谓无明则过去。若无明若爱皆名无明。二依二世即唯识文诸惑皆能发业。岂无爱耶。四唯取能发下。正出其体。即唯识初能引后。彼论具云。此中无明唯取能发正感后世善恶业者。即彼所发乃名为行。由此一切顺现受业。别助当业皆非行支。释曰。即彼已下出行支体。下文方用故。引此无明体是见道全修道一分。五希常为有下。以论释经。论云。是中无智至有无者。希求常断余文疏释。疏初云不正思惟是行俱无明者。此有二意。一者为无明支通诸烦恼。已如前明。今取正起行时迷于行过。即行俱无明。非前发业无明支摄

疏。涅槃说此为无明因亦无明摄者。第二意为无明支。要与行俱独头起者。非无明支。则此一句犹是无明。故下疏云蹑前起后。论经但云恒随邪念妄行邪道。邪念即是无明异名。故论云恒随邪念。示无明因。远公释云。明行用无明为因。言涅槃说者。即三十七经。南经三十三迦叶菩萨品。因说无明是一切诸漏根本。迦叶菩萨言。世尊如来昔于十二部经说言不善思惟因缘生于贪欲嗔痴。今何因缘乃说无明。佛言善男子。如是二法互为因果。互相增长不善思惟生于无明。无明因缘生不善思惟。善男子其能生长诸烦恼者。皆悉名为烦恼因缘。亲近如是烦恼因缘。名为无明不善思惟。释曰。既互相生故即无明。瑜伽亦云。问若说无明。以不如理作意为因。何因缘故。于缘起教中不先说耶。答彼唯是不断因。非杂染因故。所以者何。非不愚者起此作意。依杂染因说缘起教。无明自性是染污法。不如理作意自性非染污故。彼不能染污无明。然由无明力所染污。又生杂染业。烦恼力之所熏发。业之初因。谓初缘起是故不说不如理作意。释曰。若瑜伽意。则前凡夫无智是起业无明不善思惟。非无明体不立为支。今明能生无明。亦无明摄。瑜伽克体。此经从通言蹑前起后因果互举者。此中正明行支。即无明缘行故云蹑前起后。即举其因。前正说起业无明。即举其果。故云互举。若准涅槃。无明能生不善思惟。则知无明亦有因义。正为支体不可说因耳

疏。次句就人彰过

疏。文有四。一释经。二故初地下引证。既言颠倒相应。即是求有迷三界苦。谓为乐故。三反示菩萨胜义即是论释。四谓菩萨下。是疏释论。即唯识诸门分别中。第六有漏无漏门。谓有支皆是有漏。无漏非有支故。菩萨胜义即是无漏。亦是第十一学无学分别门故。彼论云。一切皆唯非学无学圣人者。所起有漏善业明为缘故。违有支故。非有支摄。由此应知圣必不造感后有业。于后苦果不迷求故。故今疏文用彼论意。体虚不真故名妄行。菩萨善知故不名妄

疏。若行涅槃下。是疏释论

疏。以三业相应思造三行故者。总出业体。亦即唯识第八三性分别门。大乘三业皆思为体。动身之思名为身业。发语之思名为语业。思之当体即是意业三行。即经中三句。皆通三业则通色非色位。谓由下显三业相。然愚略有二。一迷异熟义愚。二迷真实义愚。初愚谓迷当报。不知善恶感当苦乐。故于现在恣情造恶。谓杀生等有三品故。成三涂因。如一地说。言及人天别报苦业者。五戒及下品十善。是人总报之业。前曾损他感诸根缺等。即是别报。曾决罚他亦招此报等。故为苦业。从然别必兼总下。释感别报。非属行支义故。唯识亦云。由此一切顺现受业。别助当业。皆非行支。以无明支于发业中。有能通发总别报者。有能但发总报之者。亦有但发别报之者。唯取初二。为无明支之所发起行支所摄。第三非是行支所摄故。疏拣云唯感别报非行支故

疏。由迷真实义愚者。即第二愚。三界苦果业惑是集。即道理胜义故名真实。今谓苦为乐迷业是集。故起福行。八禅净业亦是此愚

疏。次于下明识支。疏文有二。先附经略释。后即是所引下引证广释。于中三。一举他教。二会今经。三申今论。初中引二论一经。明所引宽狭。初引唯识。但取识种于中分四。一总明五种是所引支。二约为异熟下。别示五相。既云此五起无前后故不依次。而论具云。此中识种谓本识因。除后三因。余因皆是名色种摄。后之三因如名次第。即后三种。释曰。三因即六处触受

疏。已别配识支。即是第八识种。望当异熟亲因缘故。三因位难知下释通妨难。谓有难言。既无前后。何以先识后触受耶。故为此通。四五不离心下。会释经文。既有五种。何以但名植心种子故为此释。而有二意。一约总别云不离心。二约隐显兼会今疏。但名此段为识支故。识等五支皆通因果。识则显因隐果。四则显果隐因。后果但说生名色芽。不说识故

疏。然唯识论下。第二会通集论。欲显不同。故举集论识通能所引。是彼所立正取业种。是出所以。以行熏心招当果识。故为识支。若尔识种何收故云名色名色宽故

疏。缘起经说下。三会缘起经。于中三。初总举二业种识种下正辩所立。由业熏识招于当识故。以二种名为识支。业种能引识种所引。共为识支。三识种但是名色所依者。出彼难意结弹集论。言但是所依非名色体。依根本识。方说余识有羯剌蓝故。为果既尔为因亦然

疏。今经意同缘起经说下。第二会今经。故双举行识出同之文。既言于诸行中植心种子。义当识支明通取二。疏论云此中下。第三申今论释。显心偏得种名。亦显此是因缘之义

疏。次有漏有取下。疏文有三。初总显文意。二如初地下引证。彼经云。欲流有流无明流见流。起心意识种子。三有漏是爱下。别释经文。既举爱取种。未润时但名所引。爱取润竟故名能生

疏。复起下辩名色支。疏中二。先释总句。后所谓下释别句。总中言现行名等皆生老死者。等取五果。谓识名色六入触受。此五从初结生。直至于受诸增长位。总名为生。诸衰变位名之为老。蕴坏为死。不离此五。依三世说。现在五果即是过去生老死也

疏。二为显前来下。此明二世一时。而辩能生所生支。于中有六。一略标举。二引论证成。三会通异解。四结成正义。五傍摄异门。六依文正释。今初有三。初标十因生于二果。二名色居初下通妨。谓有问言。若生二果应云生生老死。何言生名色芽。答云。为欲显于当来二果差别之相。次第说五故。识在于种故名色居初耳。三谓由前心等下。就经略辩下。别当具。疏故唯识下。第二引论证成。论文具云三能生支。谓爱取有近生当来生老死故。谓缘迷内异熟果愚。发生能招后有诸业。为缘引发亲生当来生老死位五果种已(即指前也)复迷于外增上果愚(覆业无明也)缘境界受发起贪爱(即是爱支)缘爱复生欲等四取(即取支也)爱取合润能引业种及所引因(即五果种)转名为有。俱能近有后有果故。今疏略引。但取合润成有义耳

疏。瑜伽第十下。第三会通异解总有二文。皆唯识论暗通瑜伽。今显所引论名及次第耳。初唯说业种者。意云因是善恶果是无记。名异熟果。识等五种虽正为因能生。无力正生果故。不得名有。故瑜伽次问云。何故不说自体为自体缘耶。答由彼自体。若不得余缘。于自体杂染不能增长。亦不损减是故不说。即斯意也。言如后段说者。后段经云取所起有漏业为有是也

疏。三十八中下。即第二意唯取五种。意取因缘拣去业种增上缘故

疏。实则总有八支下。第四结成正义。业种为一识等为五。则所润有六是有支体。爱取令润如水入芽能所合论故言有八。合八为有有无别体。故云假有。即唯识论诸门分别中假实分别论云十二有支九实三假。一已润六支合名有故。二即生死。三相位别立生死故。今当其一

疏。若以十二下。第五傍摄异门。谓今世十因所依。即前世之二果故成十二。然生老死离识等五虽无别体。增长衰变相有异故。是假有故。故成十二。今文中无故云傍摄

疏。且约有支文有六缘下。第六依文正解。上二句标。由上开二义。今废识生名色。但取有生于生故云且约有支

疏。一业为田下。别释即是行种者。现行之业当念即谢。熏识为种是所润故。望所生果但为增上缘者。如田无种不能生故。疏二识为种者。此识为种以识等五未至现行。即名言种望于后世生死之果。是因缘故。故云亲因。此即自体缘起也。次如世下双喻上二。若无业因识不成种故。感苦乐唯善恶业。是故识种三习气中唯是名言非有支故

疏。无明暗覆等者。释此一句分四。一举论释。二此则下释论意。三举例。四引他论。二中言等能发起者。即俱舍论等起之义。论云等起有二种因及缘刹那。如次第应知。名转名随转。释曰。初句标表无表色。等起有二种。次句分别。一因等起。二缘等起。发业前心名因等起。在先为因故。与业俱心名缘。刹那等起同刹那时故。下句立名。因等起心名转。转名为起。将作业时能引发故。刹那等起名为随转。谓随业转正作业时不相离故。解曰。今取业前无明即因等起也。故远为助

疏。亦是举于前下。三引例。释即依三世为例。前世无明既具一切烦恼。今现在爱取之中。亦具诸惑故

疏。准唯识下四引他论。此之无明亦是能润爱取所摄。前是发业无明。此是覆业无明故不同也。即迷外增上果愚者。出爱支中无明之相。亦唯识文如前已引。次又诸烦恼下。亦唯识文为成前义。又亦不局迷外增上故。唯识云。一切烦恼皆能润业。而润业位爱取力胜耳。次云。以约十因同一世者。十因同世必是生报之业。能发能润一处俱故。若远公意无明有四。一迷理无明。义通终始。二发业无明。在于行前。三覆业无明。此在行后识前。四受生无明与识同时。或在识后。望过去种子心识在于识后。望能生识与识同时。今是受生无明

疏。论主指常求有无之爱。即是举例者故。论云常求有无爱水润故。明是指前。今云即是举例者。此中之爱不异无明支中爱故。亦即是前标中有漏者。前云有漏是爱有。取是取故。是此中爱支。次云以前有爱无明摄者。彼是无明中爱。即发业爱耳。今是润业之爱。故不同也

疏。要数溉灌方生有芽者。故唯识云。于润业位爱力偏增。说爱如水能沃润故。要数溉灌方生有芽。且依初后分爱取二。谓爱初名爱爱后名取

疏。我语等取为我慢故者。即上论云缘爱后生故等四取。释曰。谓一欲取。二见取。三戒取。四我语取。今顺经中。我慢之言先举我语。以等余三。言欲取者。谓取五妙欲境故。瑜伽云。欲取云何。谓于诸欲所生贪欲。见取云何。谓除萨迦耶见。于所余见所有贪欲。戒禁取云何。谓于邪愿所有贪欲。我语取云何。谓于萨迦耶见所有贪欲。有人释云。戒谓恶戒禁谓狗牛等禁。我语谓内识依之说我故。有余师说。我见我慢名为我语。云何此二独名我语。由此二种说有我故。我非有故。说名我语。如契经说。苾刍当知。愚昧无闻于异生类随假言说。起于我执。于中无我及与我所(云云)瑜伽云。欲取唯生欲界苦果。余三通生三界苦果

疏。六见网下疏文有二。先出见网之体。后令无漏下。出见网名意。网即是喻。已下种子复加土覆。恐有虫鸟。罗之以网则禽兽不能侵。今此已下生死之种。更罗见网则无漏鸟兽不能侵损。决定受生故

疏。论总释云者。以论才释无明覆蔽故。常求有无爱水润故。竟便云如是住如是生心故。疏以此二句总显生名色芽。谓识为能住种业为所住地。爱取无明是住因缘故。云由无明爱令上识种安住业地。此释如是住。下云名色心生者。释如是生心。名色为所生心。上皆为能生。疏。却释我慢等者。言却释者。经有六句。方释前四慢。见未释便即总释。释总已竟更释慢见。故云却释。谓我是下。疏释论文。论次释见网等者。此中论文。具云我生不生如是等种种见网。余是疏释

疏。如初地下引证。意云。初地从无明下有九句。经皆名邪见。今上六句。经文无明业识皆名见网

疏。然上诸句下。释生名色芽中三。初结前生后。即是所生下。二立理合云生识故。引俱舍意识正结生蕴故。三今以前下。出称名色所以。所以有二。一约隐显故。二名色与识不相离故。前中亦二。一正明隐显。二出所以。今初五种但显心种。五现但显后四。五种得名望于五果。岂得五果而无识耶。故云略其总报。总报即第八识。大乘第八是识支体。余之七识名色支摄。故依于第八故云所依

疏。欲显识生下。第二出隐显所以。所以有二。一欲显识缘名色故。若种现皆五。则识缘名色不成。二复欲显下显通种现。通种异小。通现异于唯识之义

疏。然名色下。第二名色与识不相离故。如二束芦。先正明后故初地下引证。总引三文。一引前经但云苦芽不局名色。二引论释既名色共阿赖耶生。则知名色依现行识。三即此后文下。引后文证次下当释。以此三文。即知此中具于二支隐于识支显名色耳

疏。次名色增长下。疏文有二。先总指。后然此一段下。出指所以。以此段中未欲显相故

疏。下句拣邪因者。以我为因是邪因故。此卫世意。彼以神我为作者故。若僧佉师。则以冥性而为作者。我是知者而非作者

大方广佛华严经随疏演义钞卷第六十四大方广佛华严经随疏演义钞卷第六十五

        唐清凉山大华严寺沙门澄观述

疏。第三迷真起妄下。文前有五。一标章。二论云下。论主假设外征。谓当相下疏释论。三故经意下。以经之意答论假征。四然成答相三下。征二别相。五略有五异下。答显包含。于中先别明。后有斯五下总结。前中第一约所迷有异。前迷无我即迷真空。此迷真实智即是妙有。以有文云不了第一义故。二约起次不同可知。三约世有通局。言义取亦通五世者。后段当明。言此唯三世者。此句标也。以名色等唯约现故者。出所以也。前段名色等。五就种为义。则是二世。后列五果皆约现行。即果酬昔因。依于果上复起爱取招后生死。则有三世。今此段中既唯约现故但有三。义取亦通一世者。至下当知。疏。四前文欲明三世并备者。第四约缘有隐显。言于无明中。下出备相也。无明在于过去说有爱取。则备三惑矣。行即是有未润名行。润即有故二业必依七苦别说为五。总说为二故。此明过去备十二矣。但举经文。无明之中说有爱取。例余必有。言于现在中说无明故者。明现在之中具十二也。现在爱取之内。既有无明则三惑具矣。则所润有行。已同过去有于二支无明行也。现在八支居然可知。增长衰变亦具生老死矣

疏。五前为答难者。五约答相差别及取下结并可知

疏。文中亦二下释文。然下释名多依俱舍。俱舍与涅槃二十七义。则全同。小有别处。至文当知。初无明支。疏文有三。初辩得名。意明次第。二会论经。三出无明体相。今初辩名。然十二下通难。何于无明偏受迷称。后而无明下。答显可知。言意明次第者。故瑜伽问云。何因缘故无明等支作如是次第。答诸愚痴者。要先愚于所应知事。次即于彼发起邪行等。此无明约人迷理横从空起

疏。论经云下第二会论经。以上云实义空。则是以真空为第一义。准论经意。乃是四谛为第一义。即四重胜义中道理胜义故。次引对法证成论经亦顺涅槃我昔与汝等不识四真谛。是故久流转生死大苦海故。瑜伽中广说无明历一切法。谓若内若外若业若果。佛法僧等皆是无明。今略举四谛。则无所不摄

疏。别有暗法名为无明下。三出无明体相。于中先正出体。别有一法是明所治。后非但下拣滥。此拣二义。即二师解。谓一师云无明者。谓体非明。此即遮诠如非有非无。法体非是有无故。第二师云应谓明无此但无彼明处即名无明。故今拣之。非是明无而已。理则尽矣。犹恐难见具引论释。俱舍第十论云。无明何义(问也)。谓体非明(即第一师非前智明)。若尔无明应是眼等。释曰难也。眼等五根亦非智明故。论云。既尔此义应是无智明也。释曰。此第二释谓明无之处。即名无明。论云。若尔无明体应非有。释曰难也。若是明无之处名无明者。无是无他。体应非有。论云为明有体(拣第二义)。义不滥余(拣第一义)。颂曰。明所治无明如非亲实等。释曰。上句明有实体。谓此无明不了四谛。明所对治名曰无明。与明相违方名无明。非是离明之外皆是无明。故不同第一。亦非明无之处名为无明。不同第二。下句举前释成。论云。如诸亲友所治怨敌。亲友相违名非亲友。非异亲友非亲友无。释曰。此以怨喻无明。亲友喻明。非亲友者。即是怨家怨有体矣。言非异亲友者。非异亲友之外余人皆名非亲友也。此喻无明不滥眼等。言非亲友无者。非无父母朋友即名非亲友也。此喻无明非无体也。言实等者。以上非字贯下实等。亦如非实者。谛语名实。此所对治虚诳言论名为非实。非异于实皆名非实(如杀生等)。亦非实无名为非实(此明非实有体)。等取非法非义非事。如不善法名为非法。不善义名为非义。不善事名为非事。此与善法等相违名非法等。皆明有体非无故。论结云如是无明别有实体。是明所治非异非无释曰。非异拣初义。非无拣第二。无明若无有体。何能与行为缘。经说无明能染于慧。令不清净明有体也。余如彼说

疏。二所作业果是行支者。于中四。一正释经。二而论下引论释。三此出下。疏释论。以名色通为生死之体。以无明等是行蕴等各别法故各自有体。今行该通故取通体。以为其体四远公下举古释义无所违。但引婆沙。名色缘识。此名色在因中。识缘名色是六处别名。则似名色与识有前后义。大乘亦有互相缘义。义则不然。因果之中皆二互相缘。此是因中互为缘义。如下当说疏。三行依止下。识支初举论。二彼即是行下释论。言由行熏心等者。行谓罪等三业。唯识云。此虽才起无间即灭。无义能招当异熟果。而熏本识起自功能。即此功能说为习气。是业气分熏习所成。拣当现业故云习气。如是熏习展转相续。至成熟时招异熟果。此显当果胜增上缘。释曰。但观所引及下。瑜伽疏文可知

疏。四与识下名色支。疏文有三。初正释经。二引异释。三举论释共。今初言四蕴者。谓色受想行。则色蕴为色。三蕴为名。何以无识。故次释云识蕴已属所依识支故。上且顺经

疏。若言四蕴下。第二引异释。先引唯识。即第三论引经证有第八识。下文当具引论文言所依现行之识亦唯赖耶者。以非色四蕴为名。则名色支之中。已有识竟。故唯识云。眼等转识摄在名中。此识若无说谁为识。释曰。故以第八为识支也。恐有救云。名中识蕴是眼等五识支。即是第六识故。故次论云。亦不可说名中识蕴谓五识身识谓第六。羯逻蓝时无五识故。释曰。大小共许。初七日内无五识故。故我大乘。以第七识为名中识。俱舍亦云名谓非色即是四蕴。然其识蕴意在第六。又俱舍说。唯约位说在于识后。不说与识同时互依。上云羯逻蓝等者。此云杂秽。父母不净为杂深可厌患。为秽而言等者。此上初位等余四位故。俱舍总云最初羯逻蓝。此云薄酪。二云。次生頞部昙。此云胞也。三从此生闭尸。此云软肉。四闭尸生健南。此云坚肉。五次钵罗奢佉。此云支节。此之五位皆名色支。此第五位亦六处摄。下有三句皆六处支。偈云后发毛爪等。及色根诸相渐次而转增。皆第五位摄。若取一生皆名色摄。即六处触受皆属名色。故复云等

疏。瑜伽云下后引瑜伽。俱有依根已见问明品。即眼等色根与识同时。名为俱有。意取五色根。等无间依者。要前念灭。引生后念故。此即瑜伽约三际出因缘体文。然此段论文数处引用。今当具引。彼论云。云何缘起体(此问也)答略说由三种相建立缘起。谓从前际中际生。从中际后际生。中际生已。若趣流转。若趣清净究竟。云何从前际中际生。中际生已后趣流转。谓如有一不了前际无明所摄。无明为缘。于福非福及与不动身语意业。若作若增长。由此随业识乃至命终流转不绝。能为后有相续识因。此识将生果时。由外贪爱正现在前。以为助伴。从彼前际既舍命已。于现在世自体得生。在母胎中以因识为缘。相续果识。前后次第而生。乃至羯逻蓝等位差别而转。在母胎中相续果识。与名色俱。乃至衰老渐渐增长。尔时感生受业名色与异熟果。又异熟识即依名色而转。由必依托六处转故。是故经言名色缘识。俱有依根曰色。等无间依根曰名。随其所应为六识所依。依止彼故乃至命终。诸识流转。又五色根若根所依大种。若根处所。若彼能生大种曰色。所余曰名。由识执受诸根随相续故。方得流转。故此二种依止于识相续不断。由此道理。于现在识缘名色。名色缘识。犹如束芦。乃至命终相依而转。如是名为从前际中际诸行缘起生。中际生已流转不绝。当知。此中依胎生者(云云)云何从中际后际诸行缘起生。谓中际已生补特伽罗。受二种先业果。谓受内异熟果。及境界所生外增上果。此补特伽罗或闻非正法故。或先惯习故。于二果愚。由愚内异熟果故。于后有生苦。不如实知。由迷后有。后际无明增上力故。如前诸行若作若增长。由此新所作业故。说此识名随业识。即现法中说无明为缘故行生。行为缘故识生。此识于现法中名曰因识能摄受后生果识故。释曰。此上一段论文三节

疏。要一出名色支体。二亦证名色与识互依。三证二世立三际义。下文略指应寻此文。即四七日来者。示其分齐

疏。论云名色与识共生故下。三举论释共。然不示名色之相。直说共生之义。然论两句相续云名色与识共生故。识名色递相依故。今疏离而释之。则前句正释共义。初地经云名色共阿赖耶识生故

疏。又云识下出共所以。云释前共义。即上所引瑜伽之意。亦同唯识第三。证有第八之文。论云又契经说。识缘名色名色缘识。如是二法展转相依。譬如束芦俱时而转。若无此识赖耶自体不应有故。谓彼经中自作是释。名谓非色四蕴。色谓羯逻蓝等。此二与识相依而住。如二束芦更互为缘。恒俱时转不相舍离。眼等五识。摄在名中。此识若无说谁为识等。释曰。上引论文有三节。初正证相依义。二谓彼经中下。即前证四蕴名故。上云下即当引论。三眼等五下。前已引竟。一段义周故。复重引言如束芦者。如立二束之芦。二头相依方得安立。去东西倒去西东倒。名色与识互依。其义亦然。下第五门亦有此喻

疏。故上答文下。引上为证苦果总为名色。明知名色必共识俱也。然上诸文已显体相。未知何独此二相依。故瑜伽问云。已说一切支非更互为缘。何故建立名色与识互为缘耶。答识于现法中。用名色为缘故。名色复于后法中用识为缘故。所以者何。以于母腹中有相续时。说互为缘故。由识为缘。于母腹中诸精血等名色所摄受和合共成羯逻蓝性。即此名色为缘。复令彼识于此得住。释曰。二义中前标即现果名色与因识为缘。令识得住即名色缘识义故。上行支亦以名色为体。名色总故。后义正辩入胎互为缘义。即今文所用已知互为缘相。四蕴何独皆称为名。第一师云。在胎蒙昧未辩苦乐。微有名而已。此依分位。六处之前识支之后可尔。既二相依从生至死。皆名色摄何得称名。俱舍论云。名唯行摄。何四皆名。总有四释。四蕴称名之义。一师云。随所立名根境势力于义转变。故说为名。问云何随名势力转变。答谓随种种势共立名。于彼彼义转变诠表。即如牛马色味等名。问此复何缘标以名称。答于彼彼境转变而缘。解云。已上论文此师意者。如今时名。随于古昔名之势力。得于义转变诠表。或诠此境或诠彼境。诠彼彼境名为转变。名既如此四蕴亦然。谓受等四蕴随根境势力。于境转变而缘。转变如名。故标名称。言转变缘者。谓缘此缘彼名转变缘也。第二师云。又随类名。此解意者。谓一切法不通二类。一者色类。二非色类。四蕴与名同非色类。以似名故。四蕴为名。第三师云。随名显故。此解意者。谓色法粗着不须名显如眼见也。四蕴微细要须名显。必藉名故。故标名称也。第四师云。有余师说。四无色蕴。舍此身已转趣余生。转变如名故标名称。解云。此师约舍身名转变。初师据缘境名转变。转变虽同二释别也。释曰。上皆俱舍论疏不断得失。若取易知第二三师理易分明任情去取

疏。五六处支于中有三。初正释。二解妨。三总结分位。初中名增成意处者。四蕴为名之时。未分识相。今意识明了故名为增。故上唯识云在名中时但有第七。今发第六故名意处。此增增明色。增增多云成余五。为坚肉时未分五根。但名一色。今色根渐具故开为五。俱舍下引证。生眼等后三和前也

疏。前段为明下。二解妨。谓有问言。前段经云名色增长生五根。今何得言名色增长为六处耶。故为此通。意根本有即是七识故。云生五根。今但意增云成六处。明意非新生故。疏俱舍第十一下。第三总结分位。通结前三。小乘识支初托胎时识明显故。羯逻蓝等五位皆名色支。即从第五位至未出胎。皆六处摄。以第五位经时长故。余如前辩

疏。六触谓触对者。即根境识三和所生。能有触对故名为触。俱舍颂云触六三和生触。虽是一据识分六。小乘有难云。五识根境许同时起。可得三和。意根过去识居现在法或未来。何得三和。彼有二释。一云意法为因发识为果。即三和义。二云意法识三同一触果。即三和义。上之二释不约同世。而说三和。若大乘宗。七为意根俱得同世。然萨婆多离三和外别有触法。是心所法。若经部师三和即触。正顺今文。然此六触摄之为二。前五名为触对。意触名增语触。触虽无对所依眼等是有对故。依主受名。增语是名名能诠表增胜于语。眼等五识唯缘青等不缘青名。意识能缘青等亦缘于名。从境立名名增语触

疏。虽有三和下即俱舍意。颂云于三受因异未了知名触。三受因者。谓三受境境能生受。故名为因。即出胎后三两岁来即未了三。故不名受

疏。七受支俱舍云。在淫爱前受。谓五六岁去至十四五来。已了三受因差别相。未起淫爱但名为受。涅槃云。染着一爱名之为受。谓衣食爱。俱舍颂云。从此生六受。五触身余心。谓于六触生于六受。谓眼触为缘所生诸受等。六中前五名为身受。依色根故。色根聚集即名为身。身之受故。意触所生名为心受。心之受故领纳于触。已如前释

疏。此前四支下。总结行相。若小乘说约位明支。五皆现行。今就大乘识支通种故四现行

疏。八爱支。俱舍云。贪资具淫爱。谓十五六后。贪妙资具淫爱。现行未广追求。但名为爱。然疏云乐等缠绵希求者。等字等余二受。缠绵约乐受。希求通二故。俱舍云。从此三受引生三爱。谓由苦逼有于乐受。发生欲爱。或有于乐非苦非乐受发生色爱。或有唯于非苦非乐受生无色爱

疏。即是中下品贪下。皆唯识论文

疏。九取支俱舍云。遍驰求名取。取谓贪也。年既长大贪五欲境。四方驰求不惮劳倦。爱取别者。初起名爱。相续转盛别立取名。从虽摄余惑下。即唯识论文。正是彼论会此经文

疏。然上二支通现及种者。爱支初起即是现行。当念即能熏识成种。依此爱种而生于取。取即现行。是故经云爱增为取下会四缘中。爱望于取有因缘者。以爱种子增成于取。取即爱种之现行故。故同一贪初心为爱。转盛名取。即此爱种便是取种。是故二支皆通种现。疏十有支者。俱舍云。有谓正能造牵当有果业。由驰求故。积集能牵当有果业。业名为有。若言有当果故。此则有者。但是有无之义。若言当有之果。则有是三有故。唯识云。俱能近有后有果故。则有有二义。一者能有彼果。二者当有今能有彼因从果称故。业名有。然唯识论。虽约二世有义不殊

疏。此约三世者。对前拣滥在文可知

疏。十一生支。言约增上缘云从业起者。以经云从业起蕴名生故。业是善恶生是无记异熟果故。若约因缘。从二取种亲生于生。义如前说。疏始从中有下。彰其分齐。亦唯识文。言从中有者。中有阴灭后有阴生故。未衰变者。四十已来。若俱舍云结当有名生。从此舍命正结当有。此位五蕴总名为生。当来生支即如今识。当来生显立以生名。此与涅槃一无有二故。云现在识名生。现在名色六处触受名为老死。据此经论生支位。局唯初托胎名色位。后皆属老死。不同唯识

疏。十二老死支。疏文有三。初正释文。第二示体。第三解妨。今初即诸衰变位者。亦唯识文。四十已后容颜渐衰。即属于老。若俱舍云至当受老死。义如生支中说

疏。故上二支体通五蕴。唯是现行者。第二示体。然上引俱舍。彼约分位缘起。一一支下皆有彼位。五蕴及无明显故。立无明名等言。则十二支皆具五蕴。今从增胜有具不具故。结此二具五蕴也。余不结者。随本支体而为蕴摄。种现亦然。虽是于苦不同上识。通于种现

疏。欲令生厌下。第三通妨。略有三妨。一云未来生死即现识等。何以现在立五。未来立二。俱舍通此。但云略果及略因。由中可比二。现在五果未来说二。故云略果。现在二惑过去说一无明。故云略因。由中已广故。初后略比二可知。过此更说便为无用。上即论意。若尔何不初后目所不睹。广说因果可比于中。是故应言。示迷本际因合一惑现所起惑。明示始终。令其不行当相辩差别。示五位当果令厌。合为老死。然唯识论。虽约二世亦有此问。论云。何缘所生但立生死。所引别立识等五支。答云。因位难知差别相故。依当果位别立五支。果位易了差别相故。总立二支。以显三苦。则今疏文含于二意。欲令生厌合立二支。即是前意合立二支。故以显三苦。即唯识意谓生显行苦。老显坏苦。死显苦苦。唯识虽约种现不同三苦生厌三世宜用

疏。老非定有者。亦唯识文。应有问言。老位极长何不别立。答意云。谓有夭逝不至老故。疏别离等五下。三有妨云。别离忧悲等。自小及长皆悉有之。何为附在老死支中。通云多故。复应问言。老既不定附死立支。病亦不定何不附立。答云。病又不遍兼不定故。老遍三界故附立支。诸趣界中除中夭者。皆有衰相故。复应问言。名色不遍何故立支。谓色界全欲界化生。六处顿起何有名色。唯识答云。定故立支。胎卵湿生六处未满。定有名色故。又名色支亦是遍有。有色化生初受生位。虽具五根而未有用。尔时未名六处支故。初生无色。虽定有意根而不明了。未名意处故有名色。由斯论说十二有支一切一分上二界有。即是唯识引瑜伽第十文也。余如前说

疏。然此一段有支亦通一生下。第二以义重释。谓即于今生初迷谛理。二即作业。三业依初心为识。如下一念缘生。但通取一生。长时故云前后建立。言唯生一种通取前者。谓有问言。既云一生。生在初托胎时。今居有后那言一生。故今答云。通取前来。诸增长位皆从有起。此有虽是过去之有。但取所生。以成十二。亦可。有支之后所起五蕴。即名为生。既云义取不可克定

疏。后逆观中疏文分二。先随文正释。后结成甚深。前中自有四节。一结成苦。二结无我。三结于空。四结成胜义苦中自有三节。一二世因果相望。唯取七苦为苦树。惑业五因为苦缘。故五种为苦芽。二果为苦树。此瑜伽第十。又于现法下。二以因为果。云于现法中现法之时。亦是二世之义。言润则增长者。亦润行种及识种耳。第三通取十二缘。若因若果为一苦树。无明发业故为苦树根。若不发业不受后有果故。识与名色为苦树身。以识与名色从因至果互相依持。为生死体故。次六入触受。依名色上开显增长。对境领受如枝。依身而开别故。约二世说。但是因中约果说耳。次爱取合润成有。决定当生故。喻如华上十为因故。后二是苦果。上三皆依二世。后之一释可通三世。依过二因招识名色之体。而为树身。六入触受现行开显等为枝。已是苦树竟。依上复起当因故。三为华感当二果。为苦树果则虽是一树义有两重。疏无我下二结成无我。易知。疏无作无受下。三结成于空者。经有者字。则似人空。人空即上无我。今无作受之体。在因为作在果为受。能作能受即是于我所作所受。同号我所。然我为能作唯胜论义。若数论师。我非能作冥性能作。既能作望我有同不同。所作受等非局我所。则自在等亦名作者。故该一切因果之法。名为显空。是则无明亦为能作。行为所作。又行为能受。识等为所受。则亦无性皆悉空寂

疏。复作下四结成胜义者。上显无病所病有异。今明空理一理无差故。异上空

疏。故瑜伽说下第二总显甚深。于中三。初总标次别释。后结会。今初言甚深者。瑜伽第十云。问如世尊说缘起甚深。此甚深义云何应知。答由十种相。应知缘起甚深之义。谓依无常义苦义空义无我义说。释曰下直释十义。但云依无常义者。便列十义。今疏取下释。意便总配云六义依无常一义依苦等

疏。今初一从下。即第二别释。初释无常六义。然此文难解。如从自种子亦待他缘。与第二句从他亦待自。二句何别。故每句中皆有两义从自种子是自生义。亦待他缘不自生义。下三例之。故杂集第四云。又诸法不从自生。亦不从他生。不共不无因生。非不自作他作因缘生。是故甚深。故不自生亦从自生。二不他生亦从他生。三不共生亦从共因缘生。上三句中皆有二义。若唯自种生。非曰甚深若唯不自生亦非甚深故。一句兼二。方曰甚深。正同中论因缘所生法。即空即假即中之义。杂集释不自生等自有二义。至第八门当知。下总结云。若缘起理非自非他遣双句者。犹为甚深。况总亡四句。是故缘起最极甚深。释曰。不见此论瑜伽难了故。从自种子是自生义。亦待他缘即以他遣自义。二从他者。是他生义。亦待自者以自遣他义。三俱从者共生义。无作用者。以无性遣共义。四此二因性非不是有者。以共功能遣无因义。前之三句。有无性缘生二义故。皆有存亡。第四句不立无因故。唯有以共遣无因义耳。五相虽成就而不碍灭。六灭而似停。初之四句就缘所生法以论甚深。五六二句。以所生法对有为之相。以论甚深。前四以是缘生之法。是故无常。后之二句刹那灭故。是故无常。余文可知

疏。由前缘相皆是似义下。第三结会甚深。于中二。先约真实智结。二约法住智结故。瑜伽云。应以几智知缘起耶。答以二智。谓法住智及真实智。云何真实智。谓如观甚深义。然瑜伽甚深之义。皆性相对说。如云从自种子。是相亦待他缘。是性谓以他破自。显不自生故余如上说。今经逆观。唯显不自生义。不显从自种子义。以从自种子即是识为种。复起后有生及老死故。此不说。十义皆然。故云由前缘相皆是似义。十个似义皆在相中故。特由性相无碍故。曰甚深云正在于此

疏。又无作作者下。第二约法住智。结成甚深。故瑜伽云。云何法住智。谓如佛施设开示。无倒而知。次重征识云。问如世尊言。是诸缘起非我所作。亦非余作。所以者何。若佛出世若不出世。安住法性法住法界。云何法性等。答是诸缘起无始时来理成就性。是名法性。如成就性。以无颠倒文句安立是名法住。由此法住以彼法性为因。是故说彼名为法界。释曰。但观论文疏自明了

疏。二约大悲下。疏文有二。先标章。后论总下解释。于中三。一总释。二别释。三却释事观。今初先举论。谓十二下疏释论。远公亦云。不缘无我故曰愚痴。谬执有我称曰颠倒。此言小局

疏。下别释下。二别开二倒。前意由迷缘性故。是愚痴无我。执我故是颠倒。从以着我故下。论举经意明倒所以。第二意明迷于缘起不知从缘。无真实故即是愚痴。疑惑不决即是颠倒。从谓无智故下。以经释成。无智求有释成愚痴。滞断常下释成疑惑。致缘相之相续释疑是倒义

疏。今菩萨下。三却释总中事观。二倒相显事义方明。故在后释

疏。三约一切相智观。文中四。一彰门所摄言及第二观之一半者。第二即依止观。依止有二。一依第一义即是相续门。二依一心即第二一心所摄门。第一义一心故但半耳。二谓初成答下别显二观。初染净有二。前意约因后意约果。即杂集等染净义三相谛观中下举其二观。显此为胜。以前二观但有不知。今具知不知为染净故深细也。四然上相续下。总结一门深广之相。于中三。初成横对三乘三智。三智之义已如前配。二又初顺根本下。局大乘三智。然通因果。三虽无我所下。融其三智而成一心初空即假故不碍起悲。二能所本空下。假不碍空悲而无著。三双穷下。即空即假不滞自他。自即根本他即后得。三观一心下总结无碍成般若因。五一门下结叹深广。第二一心所摄门

疏。今初依论三观下。疏文有二。先略释经。后广开义。今初先举论。后此明修观所以下。疏释论文。从而论经虽云下。后释立观所以。以若取三界虚妄即是所作便属世谛。今取能作为第一义

疏。论云但是一心下。二论释经。从此言则总下。疏释论。上取观名唯是能作。今云三界唯心转故。则通能所。然能所有二。若法性宗中。以第一义随缘成有。即为能作。所有心境皆通所作。以不思议熏不思议变是现识因故。若法相宗。第一义心但是所迷。非是能作。有三能变。谓第八等故。一卷唯识论云。又复有义。大乘经中说三界唯心唯是心者。但有内心。无色香味等外诸境界。此云何知。如十地经说三界虚妄但是一心作。故心意与识及了别等。如是四法义一名异。此依相应心说非不相应心说心有种。一相应心所。谓一切烦恼结使受想行等。皆心相应。以是故言心意与识及了别等义。一名异故。二不相应心。所谓第一义谛常住不变。自性清净心故。言三界虚妄但一心作。是相应心。今依法性故云第一义心以为能作。言转者起作义。亦转变义者。即唯识意。彼论第三总释三能变。云能变有二。一因能变。二果能变。释此二变皆云生起故。彼论云一因能变。谓第八识中等流异熟。二因习气。等流习气由七识中善恶无记。熏令生长。异熟习气由六识中有漏善恶。熏令生长。释曰。种子生现行名因习气。论中先标。后释等流即七识中三性种子。各生自现唯除第八。不能熏故。异熟习气唯除第七。七是无记非异熟因。前是因缘此增上缘。论云。二果能变。谓前二种习气力故。有八识生现种种相。释曰。即前二因所生现果。谓有缘法能变现者。名果能变。种种相者。即第八识相应心所相见分等。论别释云。等流习气为因缘故。八识体相差别而生。名等流果。果似因故。释曰。即以现识三性种子各自生现。论云。异熟增上缘。感第八识酬引业力。恒相续故立异熟名。感前六识酬满业者。从异熟起名异熟生。不名异熟有间断故。即前异熟及异熟生。名异熟果。果异因故。释曰。八识是总果故。是异熟主。主引生余感六识业。名之为满业等。以上论文。皆以生起而释变义故

疏。云转即转生亦转变义。又下论中释。第二能变依彼转缘。彼云转谓流转。显示此识恒依彼识取所缘故。彼疏释云。流是相续义。转是生起义。谓依第八或种或现相续起义。又彼论第一释。由假说我法有种种相转云转。谓随缘施设有异。又云。彼相皆依识所转变。而假施设。又云。变谓识体转似二分。释曰。言彼相者即上我法识体。即是自证分。此相见俱依自证起故。上来正意。为证以起以变释论转字。然已具于能变之相。前后经疏皆要此文

疏。然此一文下。第二广开章门。于中有三。初总标举。云唯识摄论等。皆指华严一心作义

疏。云何一心下。第二征起略释。疏广开有十下。第三开三为十。上三义中初一不开。开二为次三。开第三为后六。然皆从宽至狭。二然相见俱存者。唯识正义四师各立。已见问明。今此从多故云相见。八识心王及诸心所。皆有二分。当体即见分。从并所变相下。即是相分相有二义。一识所顿变即是本质识等缘境。唯变影缘不得本质。言由有支等者。影变因果已如上说

疏。三摄相归见等者。然初及四五皆唯识所破故。彼论初云。又为开示谬执我法迷唯识者。令达二空于唯识理如实知故。此破凡外。今文所无。次论复云。有迷谬唯识理者。释曰。下皆护法广破四师。此标也。次论云。或执外境如识非无。释曰。此即有宗依十二处教执心境俱有是第一义。论云。或执内识如境非有。释曰。此破清辩。依密意空教拨识亦无。论云。或执诸识用别体同。释曰。即大乘一类菩萨。言八识体唯是一也。如一水镜多波像生。即当此中第五义也。论云。或执离心无别心所。释曰。此即经部觉天所计。以有经言士夫六界染净由心无心所相。虽于蕴中亦有心所。但于识上分位假立。无别实有。然清辩计虽拨皆空强违中道。而立唯境。顺世亦立唯四大种成有情故。若依此义。应有四句。清辩顺世有境无心。中道大乘有心无境。一切有部有心有境。邪见拨无都无心境。然其有王无所。即此第四。而今指经论与彼不同。然第三义言如解深密者。即第一经。心意识相品第三。广慧菩萨问佛。菩萨于心意识秘密善巧。佛答云。广慧当知。于六趣生死彼有情。及四生身分生起。于中最初一切种子。心识成熟展转和合增长广大。依二执受。一者有色诸根。及所依执受。二者相名分别言说戏论习气执受。有色界中具二执受。无色界中不具二种。释曰。无色不具即无色根。则唯有相名分别习气。明是唯见。次下经又云。广慧阿陀那识为依止为建立。故六识身转。谓眼耳鼻舌身意识。此中有识。眼及色为缘生眼识。与眼识俱随行。同时同境有分别意识转等。则知皆是唯立见分。此见亦即安慧所立。一自证分。谓多立有相见二分。去相取见为自证耳。言二十唯识者。亦名唯识二十论。有二十偈故。世亲菩萨造。唐三藏释。最初即云。安立大乘三界唯心。以契经说三界唯心心意识了别名之差别。此中说心意兼心所。唯遮外境不遣相应。内识生时似外境现。如眼有翳见发蝇等于中都无少分实义。释曰。此亦明唯心义。复有一卷唯识论。天亲菩萨造。后魏瞿昙般若流支译。细寻乃有二十唯识。同本异译。而文稍显著。先列二十偈。初偈。云唯识无境界。以无尘望见。如人目有翳见毛月等事。偈竟问云。初偈明何义。答曰。凡作论有三义。一者立义即是初句。二者引证即第二句。三者譬喻即下二句。下文广释。亦明外相无实唯心现。故名摄相归见。言观所缘缘论者。但有两纸。陈那菩萨造。论云。诸月欲令眼等五识。以外色作所缘缘者。或执极微许有实体能生识故。或执和合。以识生时带彼相故。二俱非理。所以者何。极微于五识设缘非所缘。彼相识无故。犹如眼根等。释曰。此破前极微生识。长行破意云。眼等能发识。识上无眼相。极微能发识。识岂有微相。故无所缘。又偈云。和合于五识。设缘非所缘。彼体实无故。犹如第二月。释曰。观长行意。此破上和合以生识。谓彼执言。坚等多相和合一处。有是现量境能发于识。破意云。和合法无实故。如眼错乱见第二月。释曰。以无上二相唯有于识。故名摄相归见。然陈那立于三分。今言无相者。相实无故。下正义云。彼所缘缘非全不有。内识如外现为识所缘缘。许彼相在识及能生识故。释曰。长行内识似外境现。为所缘缘。许眼等识带彼相起及彼生识故。结云诸识唯内境相。为所缘缘理极成也。则非全无相。相全属识。故云归见。然上疏引皆贤首意。欲成十义故复引之。法相立识如前所引唯识论辩。疏四摄数归王故。说一心唯通八识。以彼心所依王无体。亦心变故。如庄严论者。具名大乘庄严经论。无著菩萨造。有十三卷。第四卷述求品。第十二中有此意也。论云自界及二光痴共诸惑起。如是诸分别。二实应远离。释曰。自界谓自阿赖耶识种子。二光谓能取光所取光。此等分别由共无明及诸余惑。故得生起。如是诸分别。二实应远离者。二实谓所取实及能取实。如是二实染净。应求远离释曰。此说求染净亦摄末归本义。第五卷初同此品说。求唯识人云能取及所取。此二唯心光贪光及信光。二光无二法。释曰。求唯识人应知。能取所取此之二种唯是心光(即释上半)如是贪等烦恼光。及信等善法光。如是二光亦无染净二法。何以故。不离心光别有贪等信等染净法故。二光亦无二相。偈云。种种心光起如是种种相。光体非体故。不得彼法实。释曰。种种心光即是种种事相。或异时起或同时起。异时起者。谓贪光嗔光等。同时起者。谓信光进光等光体非体等者。如是染位心数净位心数。唯有光相而无光体。是故世尊不说彼为真实之法。释曰。上二偈即是正意也。其释曰字皆论文

疏。五以末归本下。其五六七三门。全同问明。但为明自浅之深故。复重说耳。后之三心即玄中具。谓唯心所现故。法性融通故等说

疏。上之十门下。二约教分别。即具五教。涉权是始教。就实通二。一即终教。终教亦名实教。故其摄相归性亦通顿教。以后三教皆同一乘。并拣于权故。顿亦名实。后三圆融即是圆教。而言不共者。圆教有二。一同教二别教。别即不共不共实顿故。二同教者。同顿同实故。今显是别故云不共。疏若下同诸乘下。约融通说。若下同同教一乘即收。次三就实。若同于三乘亦收前四。以其圆教如海包含无不具故

大方广佛华严经随疏演义钞卷第六十五大方广佛华严经随疏演义钞卷第六十六

        唐清凉山大华严寺沙门澄观述

疏。第二本末依持门。疏文有六。一标门分齐。即八门半。二缘相下假问征起。三论云随顺下。引论正答全同涅槃十二。佛答文殊义已见玄文。四俗为真诠下

疏。释论意。五中论云下。引他论证。即四谛品亦见上文。六此观有六下。依总开别。谓于世谛八门半中为六观故。于中有三。初列释。二料拣三别释初门。今初一一观中文皆有二观字。已上依论标名。观字向下是疏辨意。因有自他故须二门。即染依止名为他因。第二因观名为自因。染有四句故摄三门。他因即第三自业助成。自因即第四不相舍离故。皆染因。摄过即第五三道不断门。谓惑业苦惑业是集故。护过即第六三际轮回门。说此能除外道三过。三过如下。不厌厌观即第七三苦集成门。凡小不厌菩萨厌故。深观即后三门。四句求生不可得故。无生而生故曰深观。岂同情取

疏。六中初二下第二料拣摄六为四。初二染相者。一即能依所依。二即自因他因皆迷染相。下三可知

疏。今此半门下。第三别释中二。初出论意。后科文。今初观因缘有分为染者。此论自释何者是染分。分即支义。从而此染下释染依止。此即论主生起之文。而论但云因缘有分依止一心。疏开释之。次论云。此是二谛差别者。是论解经。具云此是二谛差别。一心杂染和合因缘集观。疏文略耳。从以纯真不生下。疏释。疏后释中论无别释下。疏文分三。初略弹古释二。今谓说主下标示正义。三是以此门下总显包含。于中三。初约体摄二。二约义摄五。三约时摄六。今初一自性缘起者。即二取习气。二爱非爱缘起。即诸业习气。全同唯识由诸业习气二取习气俱前异熟既尽复生余异熟也

疏。二含俱舍下。即第二约义摄五。于中有三。初标列标列唯四。何言摄五。下有例释同时同体义故。二后三下指三在后三。此中正当第一下。别释刹那即消经文。于中有三。初别释。二总结。三例释同体。今初疏故今不必依次者。初即识支。二是行支。三方无明故不依次。而俱舍具有十二。下云。痴是无明思即是行。犹依次第况不依次。非一刹那

疏。谓行此贪事必依心起下。识支然有二义。一依心起是大乘义。即八识心。复了别下即俱舍意。于诸境界了别名识

疏。不生五识唯名十界等者。十界即五根五境。以十八界根识别故。若明十二处摄识在根。故云五识依生乃名十处五根加意故云六处。大乘意根异识支故。俱舍小乘即第六识。是识支体故。云住名色根说为六处。彼疏释云。眼等五识住名色根故。说五根以名六处。虽即胜是五六处摄故

疏。贪必对境者。释触也。论云。六处对余和合是触。释云。余谓识境。释取顺经云是欲取。若俱舍云。与此相应诸缠名取。彼疏释云。即无惭无愧惛沉掉举等。与贪相应也。释有顺经云诸支生。若俱舍云所起身语二业名有。老坏为死全同论文。刹那灭故是彼疏释

疏。此若不断则名连缚下。第二略释余三缘起。论云连缚者。如品类足论。谓遍有为十二支位。所有五蕴皆分位摄。即此悬远相续无始说为远续。上皆论文。释曰。连缚要因果无间相连起也。若情非情皆有生灭。念念相续故。刹那连缚遍一切有为。云谓遍有为分位。缘起要约顺生受业及不定业。三世十二支五蕴分位。若远续者。即前分位远相续耳。故论云。即此相续顺正理论云。远续缘起。谓前后际有顺后受业及不定业。无始流转。如说无明有爱本际不可知等。连缚缘起。取相邻接相系不断。彼疏云。远续唯隔越。连缚唯无间。远续唯异熟因。若兼无情亦同类因。连缚定非异熟。异熟因非连缚。故通同类遍行能作。除相应俱有此二。非前后故

疏。大小理通者。第二总结亦是释妨难。谓有问言。今释一乘唯一心法。何以引俱舍为证。故为此答。一心之义小乘立六大有八等。则有不同。若一刹那具十二支。则大小皆具。疏非圣教量等者。结示令信也。自古不为此释。今总约一念具十二。故以圣教量证非臆说矣。言论主不释殆似疏遗者。论主造俱舍论。非是不知。将为易解故不解释。由论不释令后误解。即似疏遗。殆者近也。近似之言显非失矣

疏。此文正辨下。第三例释。同时同体可知

疏。以此十二有支下。第三约时摄六。于中有二。先广释五世。后二依三世下略例余五。前中先正明。后通妨。今初即涅槃三十七意。南经三十四迦叶问观业苦。如来释之。经云。智者复观烦恼因缘。生于烦恼业因缘故。亦生烦恼。烦恼因缘复生于业。业因缘故生苦。苦因缘故生于烦恼。烦恼因缘故生有支。有因缘生苦。有因缘生有。有因缘生业。业因缘生烦恼。烦恼因缘生苦。苦因缘生苦。善男子智者若能作如是观。当知是人能观业苦。远公释云。此就五世以明因缘。谓过去过去有其二支。烦恼因缘生烦恼者。从彼过去过去烦恼。生于过去无明也。业因缘故亦生烦恼者。从彼过去过去业行。生于次过去无明。其次过去亦立二支。烦恼因缘复生于业者。过去无明生于行支。业生苦者。谓从前行生现识支。现在世中立其四支。言苦因缘生烦恼者。谓于现在五果起于爱取。烦恼因缘生于有者。从现爱取起现有支。有因缘生苦者。从现有支生未来生老死支。有因缘生有者。从现有支生未来有。现在世中善恶二业为同类因。生未来善恶业故。其次未来出于三支。有因缘生业者。未来业行前后相生。言业因缘生烦恼者。从未来世所造业。起未来世润生烦恼。烦恼因缘生苦者。从未来世润生烦恼。生于未来。未来生支未来。未来唯立一支。苦因缘生苦者。从彼未来未来生支。生彼世老死支也。释曰。上以疏文对此经。释于义可了。但疏文稍略耳。疏此依三世下。第二释妨。谓有问言。若过去无明更依过去。则前无始未来老死。更生未来老死之果。则未来无穷则无明非无因。老死非无果。有无穷过故。今答云。今依推过去无明。非自然生。复因宿习未来不得对治。则苦果无穷。因果相关故有五世。五世之外更不关涉。故非无穷。若约三世轮环无无穷过

疏。二约大悲随顺下。此文有六。一标观名故。论征云。云何余处求解脱耶。二谓凡夫愚痴下引论释相。三经明唯是下。以论意引经。而为对治我我等中求为非。于心等求为是。四亦同净名下引例为释。即问疾品因问空室之由。寻末归本有三重问答。一问空当于何求。答曰。当于六十二见中求。又问六十二见当于何求。答曰。当于诸佛解脱中求。又问诸佛解脱当于何求。答曰。当于一切众生心行中求。然寻古释略有三意。第一意云。执见乖空则显空非是。见佛解脱中无见。则知见非解脱。众生心中无佛解脱。当知诸佛解脱中。则非众生亲契空矣。即生公意。二云。空智因于见生。则空智无性无性故智空。诸佛解脱而非有邪因。正生邪亦空矣。诸佛解脱因悟众生心行。则解脱空矣。三者约其空体无二。所以互求理无不遍。此意近于今经。今经正明于真妄心求。见妄性空悟本真体。如下当释。疏言阿赖耶识此云藏释者。此下第五会释论文。然唯识第三明第八识总有七名。故彼论云。然第八识虽诸有情皆悉成就。而随义别立种种名。谓或名心。由种种法熏习种子所积集故。或名阿陀那。执持种子及诸色根令不坏故。或名所知依能与染净所知诸法为依止故。或名种子识。能遍任持世出世间二诸种子故。此等诸名通一切位。释曰。前名心者。望种积集。此种子识唯望能生故不立也。次论云。或名阿赖耶。摄藏一切杂染品法令不失故。我见爱等执藏以为自内我故。此名唯在异生有学。非无学位。不退菩萨有杂染法执藏义。故释曰。然准赖耶有三藏义故。上论云。此识具有能藏所藏执藏义故。谓与杂染互为缘故。有情执为自内我故。释曰。言互为缘即具能所二藏。一能持染种种名所藏。识是能藏。谓现行异熟能持种子。二是杂染法所熏所依。则染法名能藏。此识为所藏。起信疏云。又藏自体于诸法中。大乘法师云。谓由七转识熏成种子。识体与种子无异性故。亦随所藏种子不离转识。藏在转识中。三又为第七之所执藏。今但出二义。阙所藏者约通无漏不说所藏。次论云。或名异熟识。能引生死善不善业异熟果故。此名唯在异生。二乘诸菩萨位。非如来地。犹有异熟无记法故。释曰。此通二乘无学十地菩萨。以如来唯善无无记故。次论云。或名无垢识。最极清净诸无漏法所依止故。此名唯在如来地。有菩萨二乘及异生位。持有漏种可受熏习。未得善净第八识故。释曰。非烦恼依故名无垢。今论唯举二名者。赖耶意在通染。阿陀那意在通净。略举一对。通为所求之处其理已同。故疏云论主意明心含染净

疏。求义云何下。第六别释求相。即示二无我观。于中先举迷。后若我执亡下明悟。即舍赖耶名者。唯识云阿罗汉位舍。以三藏中无我爱执藏故。罗汉位舍。若约菩萨。义当八地已出三界。言妄心斯灭真心显现。即起信意前疏已引。从故下偈云引证。先引当经。具云了达三界依心有。十二因缘亦复然。生死皆由心所作。心若灭者生死尽。次云即妄灭也。非心体灭者。即暗引起信成经灭义。故彼文云。但心相灭非心体灭。楞伽亦云。若阿赖耶灭。不异外道断见戏论。亦前疏已用。疏即当第二依止观者。疏有二解。前解但唯依第一义。故唯约净。此明有支依持。故通染净。第二解中依真起妄者。不了第一义谛。名无明等故。显妄依真者。十二因缘皆依一心如是而立故

疏。第三自业助成者。然杂集论名建立支业。各具二业故。全同今经。依本论初观中二。先总解二因。后别解此段。前中一总标。二远公下叙昔。三他因小通下辨违。以知无明异行故。许其通。而又不知无明望行。具自他义但为他因故。故小通耳。言自因有妨者。以违论故。论主既引无明因缘生行。证离前支则无后支。明以无明为前行为后矣。况自因缘内。无有无明生无明支。四今谓下申今正义。于中二。先别明。后总结。前中二因皆先正明。后故大悲下。引二观为证。大悲观中冥性。即外道之自生与自性义同故。以他因破其自生。自生即外道从他生义故。以自因破其他生。一切相智中。他因乃前为后之方便。自因即为因缘之相。此义极显。故举酪喻正喻自因。亦喻他因酪不从自生。必假乳为因故。此则乳为酪家他因。以乳非酪故。要从乳生。不从蒲石等生故。乳为酪家自因。以若不要从乳生者。因同非因故。若无他义。乳即是酪俱失因果

疏。三观取意下。第二总结由大同故。得引为证。诸德下结弹。然自因他因即俱舍等。此有彼有此生彼生。俱舍第九云。何故世尊说前二句(此问也)论答云。谓依此有彼有此生彼生。于缘起决定故。如余处说。依无明有诸行得有。非离无明可有诸行。又为显示诸支转生。谓依此支有彼支得有。由彼支生故余支得生。又为显示三际转生。谓前际有中际得有。由中际生后际得生。又为显示亲转二缘。谓有无明无间生行。或展转力诸行方生。有余师说。如是二句为破无因常因二论。谓非无因诸行可有。亦非由常自性我等无生因故。诸行得生。若尔便成前句无用。但由后句此生彼生。能具破前无因常因等故轨范师释此二句。为显因果因果不断。及生者为有释。为显因果住生(云云)。释曰。上皆论文今当会释。此即杂集等。及上经中是事有。故是事有。是事起故是事起起即生义已如前释。今且会二因。前支有故后支得有。即自因义以要不离前方有后。故此生彼生即他因义。此支生时彼支别故。故前第四释此有彼有为亲因。此生彼生为展转因。展转者即是他义。要从前支即是自义。若望大悲随顺观。则前第五为破二因。义甚相顺。以自因破无因。酪要因乳故。以他因破常因。必假他因非自性等。故是则先破二因。未为失意。既今经意顺上论意。自他昭然。则诸古德非独阙。寻本论亦不见于他。论之意旨疏。今此一门下。第二别释此段。于中二。先以二业释他因义。后别释文。今初二释。前合释。以自业之他助成后支之因。二别配二字可知

疏。然生起之因下。二别释经文。先释助成。后释自业。前中二。先总释经文。后广显差别。今初经中助成唯增上缘。而云作生起因者。从通相说。别则因亲缘疏通则因即是缘故。俱舍中四缘摄于六因。论云。说有四种缘。因缘五因性。等无间非后心心所以生。所缘一切法。增上即能作。若唯识论亦摄十因以为四缘。六因十因前疏已说。今意但显通耳

疏。于四缘中下。第二广显差别。即唯识缘生中诸门分别。内四缘分别门

疏。多依彼就文有四。一总显具阙。二别释有无。三结例无方。四会通经意。今初彼论具云。诸支相望增上定有。余之三缘有无不定。契经依定唯说有一。释曰。对疏可知。然增上体宽故皆定有。余三缘局故有无不定

疏。谓爱望于取下。第二别释有无于中有二。先明因缘。后辨余二。前中有二。先正明后料拣。前中有四。一依实有。二依不定。三结例。四会通他论。今初爱是取家因缘者。夫言因缘要辨体亲生既爱增为取则爱是取种。能生现取故为因缘。识增为有者。有无别体。由爱取润五种成有。有即识种生支即识现行。识种有生现故。故有得是生家因缘

疏。若说识支是业种下。二依不定。此是唯识会对法意。若以识种为识支。行非识亲因。今以业种为识支。故行得为识之因缘。此则现行为种因缘。识是业种如初章辨

疏。余支下结例。疏而集论下。第四会通他论。先会集论后会瑜伽。今初即第四。于中先标彼有。后依无明时下。显其有义。明是假说谓依无明俱时之思业之习气。与无明俱假说业种。以为无明。实是行种生行现行耳。然集论中名建立支缘。论云。建立支缘者。谓习气故。引发故。思惟故。俱有故。建立支缘随其所应。依四缘相建立支缘。且如无明望行。前生习气故得为缘由彼熏习相续所生诸业。能造后有故。一当于尔时现行无明能引发故。为等无间缘。二由彼引发差别诸行流转相续生故。思惟彼故为所缘缘。三以计最胜等不如理思惟缘愚痴位为境界故。彼俱有故为增上缘。由彼增上缘力。令相应思颠倒缘境而造作故。四如是一切随其所应令尽。当知。释曰。上于无明望行具作四缘。既例一切令尽。当知则十二支皆具四缘。大乘法师释曰。此唯识论依于别体。故互有无。彼依分位故得皆具。彼以无明为法之式。例于余支。今唯识论且偏会之。释曰。此大乘法师意。似明唯识不晓彼意。不合唯会无明与行故。下疏云。既约因言已含余三则皆具四

疏。瑜伽论说诸支相望无因缘者下二会大论。第十说有三缘。无有因缘。上牒大论。从依现爱取唯业有说会上有义。大论言无上具说有。上有四位不定假说。此不须会。但会二位实有因缘也。依现爱取者。会前爱望于取。有因缘义。彼以爱增为取。种生现故得为因缘。今以现行之爱。望现行取。非从自种安得因缘。言唯业有说者。会前有望于生得为因缘。前以识种起生现行。得为因缘。今以业种为有而起于生。业非识体但为增上安为因缘。故瑜伽云。何故相望皆无因缘。答因缘者。自体种子因所显故。今现行爱取非是种子。以业望生非自体故。大乘法师云。若无此论难解瑜伽

疏。上四位相望下。第二料拣非唯识论。是疏意耳。寻上可知

疏。无明望行至有余二缘者。第二辨余二缘。自有三义。初三位具二。次二位具一。后结余皆无。今初先举论文。从并以下。疏释并以现行相望。总出有二缘所以。言无间引生者。明有等无间缘。谓等无间缘。要是现行心心所法。前念谢灭引生后念故。无明心心所灭。引行思心。爱心所灭引起取心。此中爱支亦约现行生及老死。但是识与名色增长衰变。增长心灭引生衰变。故此三位有等无间。言行等思心可反缘故者。明有所缘缘等者。等于取及老死。谓行之思心。可得反缘前无明支。故无明支即是行家所缘缘也。二取亦心所故得缘爱。爱是取家所缘缘也。老死心所可缘于生。生即老死所缘缘也。皆言反缘者。后支缘前故

疏。有望于生受望于爱无等无间有所缘缘者。此即第二二位相望。但具一缘。此上论文。从以种望现故下。释上无等无间义。以等无间要是现行心心所法相引生故。今有是种子生是现行。安得有之受亦种子。爱是现行故非无间。从所生现行却缘种故者。释有所缘缘义。生是现行能缘有种。爱是现行能缘受种。故有及受为所缘缘

疏。余支相望二俱非有者。三明全无二也。余支者。即更有六位相望。总无二缘。谓行望识识望名色。名色望六入。六入望触触望受支。取望有支。所以无等无间者。其果皆非现行心心所相引生故。谓识等至受皆是种子。有亦种子行为识因。取为有因。虽是现行。所生识有即是种故。非等无间。所以非所缘缘者。既非现行心心所法。何有缘虑

疏。此中且依邻近下。第三结例无方。亦唯识论意于中二。先举论文。后以其逆顺下。即疏释成。然其论中乃有四重。一依邻近则异隔越。或唯越一越二越多。二依顺次则异逆次。唯将无明作行之缘。不以行为无明缘等。三依不相杂乱异于杂乱。若集论说。以无明望行乃取无明。其中行种而为无明。故是杂乱。四依实缘起说者。异于假说。如向无明俱时业之习气。实是行种假说无明。后之二义大同小异。从异此相望为缘不定者。即异上四义。是向钞中所异是也。既异隔越等故。疏云以其逆顺各有次第及超间故。且约第一隔越者。如无明与识等五及有。但一增上唯能生起彼种子故。无明与爱取老死为二缘。谓所缘缘增上缘。余一切缘准此可知。二约逆次者。亦有邻次隔越。今合说之。老死与生爱取行无明为二缘。谓所缘增上缘。余但增上。三若相杂乱有二。一顺二逆。顺中有邻次隔越。邻次如对法。前无明望行是也。隔越与前实缘不殊。亦约识等五种而说。若约当生随其所应。逆次之中有邻有间。此应思准。上约实缘起说。此约增上说。然有远近乃至诸支一一应作。然此中识等五。依当起位。诸支隔越逆次超间相杂为缘。一一思准可解。不繁广说

疏。为缘既多义不同下。第四会通经意。于中有二。先明经中但有增上。总言为生起因故。若杂集六因即能作因。名成起相。非谓邻近缘。如无明望行由此无间生当有故。二又约因言已含余三者。即总明具四。如杂集说兼约位故。但言生起因不定增上故。若瑜伽意。生起即是增上缘耳。故论问云。若诸支相望无因缘者。何故说言依因果体性建立缘起耶。答依增上缘所摄。引发因牵引因生起因。故说名为因。故大乘法师释云。即以此文证生起因。唯说增上缘。然生起因若别说者。即十因之一。言十因者。瑜伽三十八菩提分品云。一随说因。二观待因。三牵引因。四摄受因。五生起因。六引发因。七定别因。八同事因。九相违因。十不相违因。谓一切法名为先故想。想为先故说。是名彼诸法随说因。观待此故此为因故。于彼彼事若求若取。此名彼观待因。如观待手故。手为因故。有执持业观待足故。足为因故。有往来业。观待节故节为因。有屈申业。观待饥渴故。饥渴为因故。于诸饮食若求若取。随如是等无量道理应当了知观待因相。一切种子望后自果。名牵引因。余种子外所余诸缘。名摄受因。即诸种子望初自果。名生起因。即初种子所生起果。望后种子所牵引果名引发因。种种异类各别因缘。名定别因。若观待因若牵引因。若摄受因若生起因。若引发因若定别因。如是诸因总摄为一名同事因。于所生法能障碍因。名相违因。此障碍因若阙若离。名不相违因。余如彼释。下复次云。此一切因二因所摄。一能生因。二方便因。当知此中牵引种子生起种子。名能生因。所余诸因名方便因。释曰。意明三五是能生因。次即云因复有四。一因缘。二等无间缘。三所缘缘。四增上缘。当知此中若能生因名为因缘。若方便因是增上缘等无间缘及所缘缘。唯望一切心心所法。前生开导所摄受故。所缘境界所摄受故。方生方转。是故当知。等无间缘及所缘缘。摄受因摄。余如彼论广明。释曰。彼论中十因别义。今云为生起因。即十因中第五因也。即增上缘。今疏依通更以别理。前能生后或亲因生。或是增上或等无间。或为所缘通云生起。如分位缘生位位五蕴故。容具四缘。如上集论说耳。十因之义唯识广明四缘之义。广如二论。今但略知名目大意以消经耳

疏。其十二支各初自业不异前门下。第二释自业。于中先指前。不欲繁词故。后论主下举论解释。于中有五。一标示难故。二然无明下释难所以。三是以十二下。结成迷悟之依。四论主。总以下。出论释意。先举论。后意明下疏释。五不见下结弹古释。远公云。不知。虽是无明。死支为主。摄属死支。如似生时亦有结业。名为生支。即是云云。不身论意。若以一支兼余支者。则须无明遍于十二。何独死中偏说无明。今明老死能生无明。故为此释。诸德既昧故曰云云

疏。二约大悲下文中有三。初总标都门。二论云下总释四门。三别释当门。二中有三。初举论。二此有四下释论。三众生于上邪因下结示经意。二中先总后别。今初为拣滥故。昔人见论云颠倒因有三种。后列乃四。或欲合前二以应前三。不知上三是邪因故。并云颠倒。后一自是无因邪因。无因合成四过耳

疏。一性即冥性下。二别释四因。初性因中先正释。后前云下。对一心门拣滥。所以拣者。由此冥性是其外理。今云行非者。取其能知得解脱故名为行耳。僧伽之计广如玄中

疏。二即迦罗鸠驮等者。此即名也。姓迦旃延。言计自在天者。涅槃十七中。吉德大臣之所师事。谓阇王言。如王所言世无良医治恶业者。今有大师名迦罗鸠驮迦旃延一切知见。乃至云。为诸弟子说如是法。若人杀害一切众生。心无惭愧终不堕恶。犹如虚空不受尘水。有惭愧者即入地狱。犹如大水润湿于地。一切众生悉是自在天之所作。自在天喜众生安乐。自在天嗔众生苦恼。一切众生若罪若福。乃是自在之所为作。云何当言人有罪福。譬如工匠作机关木人。行住坐卧唯不能言。众生亦尔。自在天者。譬如工匠。木人者。譬众生身。如是造作谁当有罪。如是大师今者近在王舍城住。唯速往诣。若得见者众罪消灭。王即答言。审有是人能灭我罪。我当归依

疏。三删阇夜者即名也。是毗罗胝之子。涅槃中实德大臣为阇王说。云删阇夜为诸弟子说如是法。一切众中若为王者。自在随意造作善恶。悉无有罪。如火烧物无净不净。下取意引。如地普载如水俱洗。如风能吹。乃至云如秋杌树春则还生。虽复杌斫实无有罪。一切众生亦复如是。此间命终还生此间。以还生故当有何罪。一切众生苦乐果报。悉皆不由现在业果因。在过去现在受果。现在无因未来无果。以现果故。众生持戒勤修精进遮现果恶。以持戒故则得无漏尽有漏业以尽业故。众苦得尽。众苦尽故便得解脱。唯愿大王速往其所

疏。四无因即阿耆多等者。阿耆多此名也。翅舍钦婆罗弊衣也。亦有云。计阿耆多翅舍皆名也。即悉知义大臣所师。经云阿耆多一切知见(云云)告诸弟子作如是言。若自作若教他作。若自斫若教他斫。若自炙若教他炙。若自害若教他害。若自偷若教他偷。若自淫若教他淫若自妄语若教他妄语。若自饮酒若教他饮酒。若杀一村一城一国。若以刀轮杀一切众生。若恒河已南布施众生。恒河已北杀害众生。悉无罪福。无戒施定等上已释竟

疏。因此便引涅槃余之三师第四无所畏大臣师尼健陀若提子告诸弟子言。无善无施无父无母。无今世后世。无阿罗汉无修无道。一切众生经八万劫。于生死轮自然解脱。有罪无罪悉亦如是。如四大河。所谓辛头河恒河博叉私陀。悉入大海。无有差别。一切众生亦复如是。得解脱时悉无差别。五藏德大臣所宗。即末伽梨俱赊离子。为诸弟子说如是法。一切众生身有七分。何等为七。地水火风苦乐寿命。如是七法非化非作。不可毁害如伊师迦草。安住不动如须弥山。不舍不作犹如乳酪。各不诤讼。若苦若乐若善若不善。投之利刀无所伤害。何以故。七分空中无妨碍故。命亦无害。何以故。无有害者及死者。故无作无受无说无听。无有念者及以教者常说是法。六即日月称大臣所宗。富兰那说如是法。无有黑业无黑业报。无有白业无白业报。无黑白业无黑白业报。无有上业及以下业。彼当第一。末伽梨第二。删阇夜第三。阿耆多第四。迦罗鸠驮第五。若提子第六。已上略明六师之计广如诸论

疏。三约一切相智观。然论但云因缘有支二种业。能起因缘事故。今疏乃义加解脱方便。又二业中。经文后一为起后因。疏意云。若无自业何能起后。故云二业为起后方便。第四不相舍离中。疏初相谛下有二。先释自因。后释经文。前中二。先指前章。疏云唯从无明生行等名自因是也。后又论云自因观下。二引论广释。于中亦二。先标。后谓离前支下释。今初即论主生起之文。引论不尽。此下更云何者。是无明等因缘行不断助成故。释曰。此是论家先举下。经释成自因。以易故不引。又与下广释。义同故略不引。然无明等自生因。观是自义。缘事二字是其因义

疏。谓离前支下。第二广释。即下释经论文。释自因义。然具足论云。自因观者。不相舍离观故。离前支无后支观故。不离无明则成行观。若不离无明有行者。不应言无明缘行。若离无明有行成者。异则不成。是故偈言众因缘生法。是则不即因。亦复不异因。不断亦不常。释曰。今疏以言间论释之。对文可见。今更委释。此中疏取论意。但以不即不离成自因义。不即故因义成。不离故自义成。于中疏文有其三段。一顺释。三反释。三结成正义。今初明要具不即离义自因方成。然文但有不离之言。意则已有不即之义。于中离前支无后支者。以义标次。如不离无明有行等。则指经释成。并同论文。但初阙不相舍离之言。中间加一如字。即出彼论。从则无明唯是行自因。是疏释论意。成其自义。从以是自故下结成二义。谓自及因义。即是论经。然今经文一时并举不断助成。若论经文亦各别历十二因缘。云是中无明缘行者。无明因缘令行不断助成故。行缘识者行因缘故。令识不断助成故等。今初论意云。以无明令行不断为自义。助成是因义。助成是不即。令不断是不离故。上标云自生因观是自义。缘事是因也。自生因观即令行不断。缘事即是助成

疏。若唯不离下。第二反释。太即则无明即行。不得言无明与行为缘。太离则无明不干于行。何殊色于行耶

疏。不即不离则名自因下。第三结示正义。于中先标言亦二义成矣者。即不断助成之二义。后故论主下。二引证。于中先举论偈文。后初句泛举下。疏释论偈。谓初句泛举一切因缘生法。非局此十二因缘。二三两句明不即离。第四一句结归中道。从非断亦非常下。疏中有五重中道不断常义。初一是总。正是因灭不常。果续不断之义。故云不即故不常。即乃因至于果便堕于常。言不异故不断者。从因生果。是果续义故。是不断异则果不续因。便堕于断。次三义于此开出而取意别。第二意于不即不离二义之上。各成不断不常。初言不即因故果不断因不常者。不即则有果故果不断因。不与果俱故因不常。次云不异因故果不常因不断者。果从因生故。果非常不异则因能生果。故因不断。此上因果交络明不断常。第三又以不即故因果俱不断等者。当一句上。即具不断不常不即则有因有果故。俱不断不异故。因果俱不常者。此义难见故。释云。非无因常。不异则果从因生故。非无因常。不即则因由果显。亦非无因常。然无因常。乃有二义。一如涅槃云。是诸外道无有一法不从缘生。是故无常。如来佛性虚空不从缘生。是故为常。则是真常。非此所明。二者外道所计微尘世性。前无有因故说为常。此是邪常。是今所拣。第四又亦反此者。应云不即故因果俱不常。不异故因果俱不断。不断义易故更不释。谓不异则从因有果。俱不断灭不常难见故。今释云非相续常者。若即因者。因则至果如泥至瓶。此因则常果。即是因果亦相续常也。此常则是邪见。故今拣之。前不断相续则是正义。以果续不断故。第五云。又以不离是不即下。合不即离及不断不常以为一致。上五释中。初一望次三。即从总开别。此一望前四。即合于前开故令思之。以成深观。疏文中顺下。第二释经。然论释经。先正释文。后释自因。自因之义前以广引。今但释论子果之言。疏中二。释前一更是上古所释。亦可下是第二释正顺论意。亦顺涅槃二十九师子吼问。阴无系者云何系缚。佛答。以烦恼锁系缚五阴。因此便说名色系缚众生众生系缚名色等师子吼。难云。若有名色是系缚者。谓阿罗汉未离名色。亦应系缚。佛答云。善男子。解脱有二种。一者子断。二者果断。言子断者。名烦恼断。未断果故名果系缚。又引油灯以喻烦恼众生。释曰。此明为因义边名子。罗汉断烦恼因未脱果缚。故似后义。以论言无明有二。是则为因之时。即是前支能起于后。若前支至后但有种子。非是正发后支之因故取子时。子即因耳。故论云。是中子时者。令行不断有二义故。以自体助成二义。皆属前支故。而詺因为子者。如谷子生芽故。果即是行。行时有行俱无明。非发业者故不取之。余支例然。皆以前支为后支缘。令后不断助成后支故

疏。正意在其后解。疏后逆观。论云下文二。先引论。后十二因缘下解释。今初。然经中亦历十二。云无明灭故则行灭。无明因缘无行灭不助成故。行灭故则识灭。行因缘无识灭不助成故等。而论云。先际后际灭中际亦无者。意云。若前际无明行无。中际五果则无。后际爱取有无。中际苦果后更不生。总显无因则无果义。而谓爱取有为后际者。即次第六段三际轮回门中。将爱取有以因从果。名后际故

疏。是故不说有不断助成义等。此释上论。是故不说之言而有二释。前约经明故云不断助成。后约论意云不说之果

疏。三一切相智观中言即以无作为缘之相者。三种缘生中无作缘生也。三种缘生者。如十藏中。谓是事有故是事有。是无作缘生是事起故是事起。是无常缘生无明缘行。是势用缘生。今前二观是无常义。今是无作又无常义。初门已明。势用一门遍于前后。亦广在初门

大方广佛华严经随疏演义钞卷第六十六大方广佛华严经随疏演义钞卷第六十七

        唐清凉山大华严寺沙门澄观述

第五三道不断。疏。摄过观等者。即唯识论惑苦相摄门

疏。过去迷于本际下。约强弱分别。过迷本际建立生死。力强。爱取引果强。二从其本末下。是本末分别。无明是本过去说之。爱取是末现在说之。前则约用此则约体。此亦俱舍以略摄广中云。三烦恼二业。七事亦名苦。略果及略因。由中可比二。释曰。上二句正以惑业苦摄十二。下二句解妨。谓有问云。一种是惑。何以前际唯一无明。中际分成爱取。一种是苦。何以后际唯二。中具五耶。故为此通。后际二是略果。前际一是略因。由中之五比知后二。由中之二比前之一。若更广说便为无用。但出略广不出略之所以唯识则有

疏。若约二世下。是唯识论即释能生。后问答分别故。彼论中前有问言。何缘发业总立无明。润业位中别立爱取。答曰。虽诸烦恼皆能发润。而发业位无明力增。以具十一殊胜事故。谓所缘等广如经说。于润业位爱取偏增。说爱如水能沃润故。要数溉灌方生有芽。且依初后分二。爱取无熏发义。立一无明。释曰。上皆论文以论对疏。广略可知。然彼论问乃有二意。一问立名不同。一种是惑前立无明。后立爱取等。二问广略有异故。问云总立无明别立爱取故。下答中具有二门。先答立名不同。约胜劣门。后要数溉灌下。答第二问发业润业熏不熏。故斯则出于广略所以。言十一殊胜事者。缘起经说。一所缘殊胜。遍缘染净故。二行相殊胜。隐真显妄故。三因缘殊胜。惑业生本故。四等起殊胜。等能发起能引所引能生所生缘起法故。五转异殊胜。随眠缠缚相应不共四转异故。六邪行殊胜。依谛起增益损减行故。七相状殊胜。微细自相遍爱非爱共相转故。八作业殊胜。作流转所依事。作寂止能障事故。九障碍殊胜。障碍殊胜法故。十随转殊胜。乃至有顶犹有转故。十一对治殊胜。二种妙智所对治故。故不说余。亦名发业支。言且依初后者。谓爱初取后分爱取二以爱为初取为后故。其实有多现行润也

疏。业亦有二。已润未润等者。亦唯识论如初章说

疏。三道皆言不断下。亦是释于始终之难。显无始终。先正释后引证。前中从三烦恼生于二业者。从一无明生一行业。从爱取二生一有业。二业生七苦者。从一行业生识等五。从一有业生生老死故。七复生三者。识等五苦生爱取二。生死二苦生无明故。上云不了知故生死流转。如净意菩萨者。彼论与此相应。偈云烦恼初八九。业二及与十。余七说为苦。三摄十二法。从三故生二。从二故生七。从七复生三。是故如轮转。一切世间法唯因果无人。但从诸法空还生于空法。若准俱舍亦为通难故。论问云。若缘起支唯十二者不说老死果。生死应有终。不说无明因生死应有始。或应更立余缘起支。余复有余成无穷失。答云不应更立。然无前过。此中世尊由义已显。云何已显。颂曰。从惑生惑业。从业生于事。从事事惑生。有支理唯此。释曰。初句有二。一从惑生惑。谓从爱生取。二从惑生业者。谓取生有无明生行。次句有一义。谓从行生识及从有生生。皆从业生事。第三句有二义。一从事生事。谓识生名色。乃至触生受及生生老死。二从事生惑。谓受生爱。义亦应有老死生无明。上一事字即是能生。下事惑字即二所生。从生二字两遍用之。第四句结释酬难。谓诸有支唯此十二道理足矣。上所引论文。则小异义意大同

疏。如二束芦者。谓因果互依初门已有。但约识与名色互依。今通十二因缘。然要云束芦者又取中空十二因缘。相有名生虚无名灭。生灭假集亦如束。芦

疏。计苦行心即是烦恼者。正是邪见亦见戒取。亦是愚痴上业。此惑皆集谛故。故是苦因非解脱因。此亦即是宿作因。外道并如前说

疏。三一切相智观中。即第五入谛观者。故疏有二释。前正论意。二又体三道下。即天台意。下都结中。当更分别。第六三际轮回门。初约相谛观中分三。初总标观名。二释三际。三释经文

疏。三际不同下。二释三际。然唯识分四。一叙意合能所引者。初二能引。次五所引。要一世故十因下正立直至及离断常。皆是论文。其生报定同后报。便异是义释耳。三此则但以下结成论意。故彼论次云。施设两重实为无用。或应过此便致无穷。释曰。言无穷者。若愚前际说过二因。更有愚于前前际者。二因犹少应更说多。若谓愚于后际说二果者。亦有愚于后后际者。二果犹少应更说多。四若尔下会通彼论成三际义

疏。二依智论下。即第二释。言生引俱开者。然俱舍中不说生引。今约大乘又对唯识。合能所引故云俱开。是故结云三道抗行。谓无明行即是能生。非要爱等润竟方能

疏。三依此经等者。此第三释即是大乘有三世义。唯识判三为小乘者。特违至教。言为遮前七定同世者。即上唯识言为遮爱等但是润故者。所遮亦是唯识论意。今明爱等同无明行具发润等

疏。示因招果令生厌者。正说以因从果所以。云果过患由爱等因。应厌因故。亦通妨难。谓有问言。前之二世当世以明。何得未来以因从果。答意可知

疏。则能所引生下。结示本义。谓能引之二许有能生。能生爱等中。必有能引所引之五。通其所生。而言容有者。以大乘中虽说三世。而于五果通种及现。约为种边但为所引。约现行边即是所生。未润之二但名能引。已润之二即名能生。发业爱等但名能引。已润爱等即名能生故。皆容互有

疏。明文昭然者。结弹唯识非不许其立二世义。取二非三故为非耳

疏。已知下三释经文

疏。如是方名见过去因能防三过者。亦是遮难。恐有难言。经但说二在于过去。论主何为反覆相属。故今答云。要知过去因能招现果。现果必从过去二因生。方能护于先业等过。如下当释

疏。现在目睹故分两向明其二义者。此亦通难。谓有问言前说无明行之二因。唯对现在反覆相成。今明现在五法亦应反覆。何因两向。故今答云。前来二因因谢过去。故须对现。以说彼因现果已成。方知彼因招果不失。今之现在非独酬于过去之因。复能依现在招未来果故。两向明之。若更相成不异前二。复应难言。前说无明。已说现果酬于过去之因。今何重说是过去果。此应答云。前酬过去为成过去。今说过招为成现在。故非重也。所以二法两向明之

疏。此未来因决得来果一往定故者。上句释成亦是通难。谓有难言。现在爱等从果名未。过去无明等何不从果而名现耶。故今答云。来果未至从果名未。知其决得令其生厌。过因已谢何得名现。复应问言。现在爱等从果名未。现在识等应从因名过。亦如向答。未因决得故从果名未。现在已得何要名过。复应问言。释前过现反覆两向。今辨未来何以但将因对果耶。答前二经文直说过现。不说相成故论相成。今此经文经自将现对于未来。故论不释。言一往定者。结成上义。谓说一分三世名为一往。理数如是。称之为定。对下展转故云一往。是一向理故

疏。已知三际下。第二护过于中二。先过后护。前中一一过内文皆有三。初标名二征释。三辨所从。所从是疏标释论。皆前之二过以前望后。后之一过以后望前。由无明行在报前故。一未受果报业已谢失。果在于后望前之业以成过故

疏。此上辨过下。第二明护于中有四。一结前征后。二若见下总标护义。三然过去业下出过所以。四举经正护。三中二。先泛明不受报业。后今无明下。举今经文明受报业。今初言一未作者。此言难解。谓若未作则未名业故。今依瑜伽其未作业名为不作。论第九云。不作业者。谓若不思业若不思已不起身业语业。释曰。据此不作即任运所起非故。意思设尔有思。又思已不起身口故。不受报故。九地释表无表业云。作无作作即身口。无作即意。如杀盗等。心虽欲作不形身口。故不受报。若全不作名不受报。何要待言。又何得。论云。业有三种不受报耶。不作即无业故。二未润可知。而论但云作已未得报。其未润言是疏义。加三得对治者。即瑜伽中名不增长业。不增长业总有十种。一梦所作业。二无知所作业。三无故思所作业。四不利不数所作业。五狂乱所作业。六失念所作业。七非乐欲所作业。八自性无记业。九悔所损业。十对治所损业。此十名不增长业。除此十种所余诸业名为增长

疏。今无明缘行下。二举今经明得报义。于中二。先正明。后结酬外难。今初对前三不得报。今无明缘行则显已作者。此拣第一未作业也。既为无明所发之行。此行要是能感当报故。非向来不思之业

疏。现识等五则显已润已受者。则前无明行等已得润竟故。今受果。此则过去二因已含发润

疏。爱取有三则知未得对治者。谓若得对治不应依现更起爱等。此后更有论反释云。若断爱取虽有作业。则无明行不能生有。释曰。则显现在亦有无明与行。是所润等观此论意。则过去二因具于发润但举发业之名。现在爱等亦有发润。但显润名故上疏云皆容互有思之。亦可。现在爱取不润过去。后报之业故不能生有

疏。于已作业既有润未润殊斯为异因者。下第二结酬外难。上立三过。语虽影略总相皆由无异因故。异因即我。今明不要我为异因。即已造已润不得对治。而为异因。此语是前说过。后论论出三过竟云此三种过。以见过去世等异因故。受生报等差别故。释曰。上论总出其过总明答之。今出过所以竟方用结酬

疏。已润则受生报下。第四正明护过。三过即为三别。今初虽一身中具六道业润者。先受那得一时。此即已润为异因。二既自造异因下护第二过。二报即是生报后报。此即已造为异因。三若已作业不得对治下护第三过。即不得对治为异因。言势力续故者。小乘则是后后连持。大乘则是已熏成种。后能得果故云势力。三过度矣者结也

疏。后无明灭下逆观中二。先释文。后然十二缘三世并备下第二结示。谓过去二因即含有爱等。能润业等必依过去识等上起。始生终死等过。具十二矣。现七果上起发润等。现亦具矣。然七事中。五即生死而总别分故说具七。当虽说二同现亦具二。必有五及起因故。是以上言皆容互有。并如前说。言但随化迹隐显分三。令知过因下。出隐显意。义如前说。则愚痴绝命下。是逆观意。以智慧剑破发业惑。以智慧火干于现在润业爱取。则七苦不生。能所引生即四面网。此即史记书言。汤出遇畋捕者。祝云。自天而下从地而出。四方来者皆入吾网中。汤见之歇三面网。祝云。可上者上。可下者下。可东者东。可西者西。可南者南。可北者北。负吾命者入吾网中。显法令宽也。今亦不留一面故曰四开。皆出证无生。若鸟出网以适八方

疏。二约大悲等者。文中三。初顺显有因。次若无下反质明有后。斯因下结尔

疏。当力无力下。文中三。初标牒。二谓此三下。疏释论。三如是穷究下结观。二中三。一释力无力。二以斯三际下释信入依义。三化中下释化胜。言笼取三际方显化胜。亦是瑜伽缘起差别故。瑜伽云。缘起差别云何。谓于前际无知等。如经广说。于前际无知云何。谓于过去诸行等起不如理分别。谓我于过去为曾有耶。为曾无耶。曾何体性曾何种类。所有无知等。亦即俱舍云。说前后中际为遣他愚惑故。彼论云。契经何故唯说有情故有。上偈释云。世尊为遣三际愚惑故说缘起。唯约有情。问如何有情前际愚惑。谓于前际生如是疑。我于过去世为曾有非有。何等我曾有。云何我曾有。释曰。此有三疑。初疑我有无。二疑我体性。为即蕴我离蕴我耶。三疑我差别。为当常我无常我耶。问如何有情后际愚惑。答谓于后际生如是疑。我于未来世。为当有非有。何等我当有。云何我当有。释曰。三疑如前。但曾当有异耳。问如何有情中际愚惑。答谓于中际生如是疑。何等是我此我云何。我谁所有我当有谁。释曰。此有四疑何等是我者。疑我自性也。此我云何者。疑我差别也。我谁所有者。疑我因也。谓此现在我。过去谁因所有也。我当有谁疑我果也。谓我当有谁果也。为除如是三际愚惑故。经唯说有情缘起。以契经说。苾刍谛听。若有苾刍于诸缘起已生诸法。能以如实正慧观见。彼必不于三际愚惑。谓我过去为曾有非有等。释曰。大小论殊其旨皆一。今三际无我斯惑自亡。故以三际化彼凡夫。除其我愚信入无我。修无我行为化之胜。第七三苦聚集门

疏。第五不厌厌观等者。先释观。后文中下释经。前中先正释。后二乘虽知下通妨。恐有问言。四禅已上皆唯行苦。三乘已超何言不厌。故有此通。此有二意。一约界内无。即涅槃十二云。苦有无量相。非诸声闻缘觉所知。二及变易苦。谓为出三界究竟无余故疏。顺中自有三门。一随相增减门。二实理遍通门。三三受分别门。上二即唯识三苦分别门。第三即三受分别门。引论广释。今初即随相增减门。言触对生苦者。因于苦缘生于苦心。故云苦苦。然其触受既通三受偏言苦苦者。就增说故。亦诃责故。言老死坏生者。此遮外难。恐有难言。老死无乐何名坏苦。故为此释。则坏苦有二。一者坏乐。二是坏业。正能坏生即是坏业。得名坏苦

疏。若准瑜伽唯识下。第二引论广释。于中二。先正举论。即约实理遍通门。正唯识文瑜伽同此

疏。若约坏生下。第二以疏会释。于中四。一会坏苦可知。二若依舍受下释上坏苦。十一之言除老死故。三以此三苦从三受生下。释成老死。无舍受言即三受分别门也。四二苦皆言少分下。释少分全分。若是二苦必是行苦者。诸有漏法刹那性故。有是已下释二少分而有二义。一二苦不遍舍受。故名少分。二又是二苦下。坏及苦苦各不相摄。兼无舍受故各不摄二以坏苦中无有苦受。苦苦之中无乐受故

疏。二约大悲下疏文有四。一总释观名。二真解脱者下。举正折邪于中二。先举论文。后此四即涅槃下疏释上论。如次配其乐常德等。故涅槃云下。唯证第四我相隐故。三故下四段下。显妄举正。四今此明其下别释此门。三一切相观

疏。不如实知微苦我慢者。此即论文。从此即增上慢下。疏释上论。然论标名有增上慢释中即无故

疏。指论我慢即增上慢。从本说故。从若知下释非增上慢。言又不如实知者。涅槃云。声闻有苦有谛。而无真实故。第八因缘生灭门

疏。初观文前有三。一释观名。二义名深。一无生故。二生与无生无障碍。二此门下第二指经。三释此四句下。广辨义相。于中三。初双标二章。二理外妄计下。总释二章。言是计是依者。计是破邪之所。依是显理之所。是药者是破邪之能。是理者是显理之能。若望显理理为所显。今用不为理。令于自等而见于理。见理因不故以不为能显。后穷生下彰破显之功。三然其所计下别释二章。先破邪中有二。先计后破。计有三类凡小如前夜摩偈说。二小乘言同类因者。因果相似。如善五蕴与善五蕴展转相望。为同类因。言异熟因者。唯诸不善及有漏善相望故也。言俱有因。如四大种更互相望。为俱有因。三约大乘自有三义。前二通法相无相宗。后一是法性宗。皆执法成病故。俱为所破。至显理中当知其相

疏。所计虽众下第二明破。但指显理而为能破。同一不故

疏。显理复二下。第二显理先标后释

疏。法从缘生故不自生者。即对前果法为自。众缘为他义。说通于二论。一通中论。青目释不自生云。万物无有从自体生。必待众因缘。复次若从自体生。则一法有二体。一谓生。二谓生者。若离余因从自体生者。则无因无缘。又生更有生生则无穷。释曰。据此即以果体为自也。二通对法。先明三句无生。后辨不碍三作初云不从自生者。谓一切法非自所作。彼未生时无自性故。释曰。此释同青目意。论云不他生者。谓彼诸缘非作者故。不共生者。即由于二种因故。释曰。二种因者。即指上二句。自他二句各既不生合亦不生。后辨三作。云然非不自作他作因生故甚深。此意以三作释不无因故。云缘望于果。有功能故。因望于果亦然。合上为三作故。既从三作故非无因。然观三作则自亦是因。今疏中释不自他等。即中论偈意。偈释自生。即是下文因缘形夺中用故。云如诸法自性不在于缘中。此即以他破自。次云以无自性故。他性亦复无。此即以自破他。凭公云。以自破他凡有三种。一总二即三相待。今疏即全有此三。初云既无有自对谁为他。即第三相待破无自可待对故。如无长故无短。次云又一切法总为自故。即第一总义万法皆自。如百人一处皆用。己为自则他亦是自。今破一自则他亦破矣。次云又他望于他亦是自故者。即第二即义。谓如两人二互相望。此言是自指彼为他。他亦自言我即是自。指此为他故。其两人皆有于自。破此人自他人之自亦已亡故。从自他不立下。即双用自他破共生义。如二盲人离不见色合岂见耶。从有因尚不生者。即以三作破无因耳。此中非谓非是无因而立有因。举况以释因缘和合。合是生义。尚不得生。岂用无因而立生义。故四句求生。生不可得。无生之理显然可睹。正理既显计何由生

疏。二约因缘形夺者。即就前计。以因为自以缘为他。而显理也。然对法初散释。亦以破自为先。故云又有差别。谓待众缘故非自作。虽有众缘无种子。不生故非他作。彼俱无作用故非共作。种子及众缘皆有功能。故非无因生。是故如是说自种有故不从他等。一如今疏释曰。初句以自破他。如于外法。以谷子为自水等为他。内法识种为自业种。增上缘为他。若无种子决不生果。故不他生。次句以他破自。故云待众缘故非自作。次无作用故不共生。即以和合无性破共。次有功能故非无因者。以共破无因。言论解同此者。今取论解同对法也。如下释文中辨。彼论结云。若缘起理非自非他遣双句者。犹为甚深。况总亡四句。是故缘起最极甚深

疏。若尔下释妨拣滥。古人多以非无因是从因生故。为此问答。引中论证。唯证假他破自。以自破他等已如前说。故此论难见。意云。汝立自性而能生者。不合更假其余因缘。若有自性而复假缘。则此自性应在缘中。今水土缘中无谷自性。明不自生。疏下二句例然者。即以无作用破共非立无作用生。以共破无因非立共也。此别显无生义故。令审详使物莫滥。若显甚深次下当说

疏。二约无碍下。此门更分为二。先明事理无碍。无力故无生。有力故不碍生。则生不碍无生。无生不碍生。亦取前对法偈明之。而用意有别。亦同初门不自生非不自作等。则上三句显不生。第四句不碍三作

疏。此复二义下。依此力无力。成于事事无碍法门。谓成相入及相即义。如前玄中

疏。文中亦有下。第二释文。此以不他生下。是疏释论。论言有分者。分即支也。从二者非自作缘生故者。亦是论文。余皆疏释。言非谓四缘之因缘也者。此句拣滥。以古德释云无。明望行无因缘义。而言因缘者有二义。一自种为因无明为缘。此二合说故云因缘。然隐此亲种显彼胜缘。故云无明因缘也。二但彼增上缘望自增上果。还是亲因故。说无明为行因缘。此解失意故今拣之。若取有力增上。拣无力增上为亲因者。于理则可然。亦非因缘故为失意也。疏后例余者。谓其余支及与逆观。谓顺观尚即自他不生。逆观岂有自他可灭

疏。二约大悲下。言又计妙行者。以六行伏惑为解脱者。解脱因故。既有欣厌心亦生灭耳

疏。第三一切相智观等。言此有二意者。约俗是贤首意。约真是远公意。前中言生死无际者。即中论本际品云。大圣之所说本际不可得。生死无有始亦复无有终。若无有始终中当云何有。是故于此中先后共亦无。释曰。据此则上二偈。前是俗谛无始。后偈便入真谛。而俗谛无终者。约多人说故。今直就事明。但有无始。后意若约真谛俱无始终。何以但言无始。今谓无明从空而起。故但云无始。下引净名双证二义。无住之本即是真谛。立一切法即是俗谛。俗依真立。真既无始俗亦无始。而论但名为无始。致令二德各见不同。今疏以理而通二德并皆全取

疏。故染净真性皆无始终者。结示通妨。染之与净即上俗谛。皆依无住故无始终。言依无住者。非依无住展转生来。既无住即是实相异名。故无一法不同实相真性。即上约真谛说理无始终。显染可除下通妨。妨云。何以但言无始。故为此通

疏。余如别说者。然初地中已略显示。今更略明。谓或说真性无始无终。性无生灭故。恒沙性德依体说相。亦无始终。证净菩提有始无终。创修成故说之有始。冥同真性故无有终。生死妄法无始有终。未曾离念故无有始。妄可断故本有今无。故说有终。若约以因招果说者。无明为始老死为终。有始有终约智符理。理无始终智亦无始。不尔真智不同真故。妄法有二。亦无始终。一则从缘举体空故。无可始终。二即妄同真故无始终。如波即湿即性无终。随顺观俗即真谛故。若有始终不即真故。故疏结云则染净真理皆无始终

疏。论云下引论牒释。即合即门为一无始故双牒释

疏。不言初际生下。通上中际因缘生言意显无初故者。约俗谛门无明无始故。从今不起妄下。反释论意。故云不生。今即中际不起爱取。何有后际生老死耶。第九生灭系缚门

疏。亦名似有若无者。生灭系缚但顺经文。似有若无即是经意。故论云不共生也。文中顺观之内有三。初牒经文。征起共义。二论云下举论解释。非二作是标。但随顺下。论有三释明不共义。三意谓下疏释论文。即就论三义展转相承。疏有二节。先合释前二。后别释第三。今初但行顺无明不得不生。是第一意既言随顺故。明缘会不得不生。即无生矣。二云何以随顺即得无生。行与无明二互相依无知者。故由上二义故非自作。第二若尔下。别释第三义。以不住释上无知。如河中水。湍流奔逝故无相知。从此同对法下。以论证成对法。即如前文。又中论云。即是过意。据文即因果品云。若因众因缘而有和合法。和合自不生云何能生果。如来品云。阴合为如来。则无有自性等。皆其义也

疏。无明灭下逆观下释逆观。但释不共灭义。生灭之相类前可知。第十无所有尽门

疏。然论经下二会二经。今经两段皆随顺无所有。若论经顺观中。经论皆随顺有逆观。方云随顺无所有尽。疏家但含顺观之中。顺有顺无逆观义同。所以不会。今经取缘生无性。论经即无性缘生二义相成。故同遣无因。从无因何失下。是论结无因之过无定因者。若有定因因会则生。不会不生。今无定因故应常生故。无因下结无因过。中论云。无因乃成大过。谓布施持戒应堕地狱。杀生偷盗则应生天。诸修妙行无涅槃等

疏。此即世谛观者。以论经云随顺有故。从即真顺有下。会论经同今经。谓虽顺有虚相都尽。唯第一义谛故云未失顺无。疏自下第三总结下。疏文有三。初释逆顺。二释总名。三以义收束。初中二。先直释经。二引文会释。今初言二门阙逆者。即一心所摄及自业助成门也。所以无者但是略故。若出所以者。其一心所摄之中。本末依持即是顺观。初第一义心是摄末归本。义当逆观故略无耳。其自业助成顺观之中。二业相显逆观。应言无明若不迷于所缘。则不与行作生起因。则似无明无用无体。故略无耳。若欲著者。应言若无无明迷于所缘。则不与行作生起因。亦可着在故云略无。一心中应云。若不迷一心则不起因缘。亦是逆义故。下偈云。心若灭者生死尽。以此疏文但云略无。二然此逆顺若对法下。引文会释。先引论有二逆顺。今经但一。次引缘起经释于对法。谁老死言。此有七十七智。谓十二因缘除无明支。余十一支各有七故。由谁有故即是推因。推此老死从何因生。知从于生。如是老死复由何缘。即是审因。谓审此老死定由何缘定知因生。三世各二故。有其六七即法住智。谓观前所不摄诸有漏慧。遍知义故。谓遍知三世缘起教法。名前不摄。以为第七。前六真实智此一法住智。合成七智。一切异生及诸圣者。俱有此智入见道位。方有四十四智近四谛故。住教等法是闻慧故。名法住智。如实而知是思修慧。名真实智。此约染明逆。若清净逆但改谁有为谁灭耳。然此逆顺约支体说。经以染净。为逆顺者。约顺生死逆生死说。然上钞云四十四智谓逆观老死以至于行。各作四谛观说

疏。言诸缘起下。第二释总名。或名缘起。自有二义。一通约十二缘。二以因对果说。次亦云缘生亦有二说。一生即是起。二约果说者。即生起义。殊是俱舍意。论云。如世尊说。吾今为汝说缘起法缘已生法。此二何异问也。答有二义。一云且本论文此二无别。释曰。即前疏文生即起义。后义即是论主正释。偈云。此中意正说因起果已生。释曰。世亲明此契经中意。十二有支为因义边。即名缘起。因起果故。为果义边皆名缘生。从缘生故。故其十二所望不同。二义皆成

疏。余如瑜伽第九等者。二引文会释结示根本。瑜伽总上四卷。皆明缘起。释名正当第十总有五释。论云。问何故说为缘起。答云。由烦恼系缚往诸趣中。数数生起故名缘起。此依字释名。谓依缘字起字二字别故。而缘非起。即是今疏第二释也。二云。复次依托众缘速谢灭已续和合起。故名缘起。此依刹那义释。三云。复次众缘过去而不舍离。依自相续而得生起。故名缘起。如说此有故彼有。此生故彼生。非余依此义故。释名应知。四云。复次数数谢灭复相续起。故名缘起。此依数坏数起义。释曰。此上三释。皆是今疏第一义。前前为缘令后后起。前前为缘故不舍离。即第三义。前若不灭复何由起。即含第四。前后不同必有刹那。即第二义。故其三意大同小异

疏。合为一。五云。复次于过去世觉缘性已等相续起。故名缘起。如世尊言。我已觉悟正起宣说。即由此名展转传说。故名缘起。释曰。瑜伽五义。初一缘非是起。以因为缘以果为起。二缘即是起。刹那刹那从缘而起。此拣大乘部十二因缘。是无为法亦拣正量部。三即无间因果。前因为缘而后缘起。四无始因果。前已谢灭后更起因招果不断。然通因果即缘即起。五缘是所觉起是教法。依悟说教故名缘起。此是自释五相不同。非余师义。对会疏文已如向说。然五义并依起即生义。唯俱舍意分二不同。又指唯识第八。彼中广释。如上具引。下以诸门分别有十七门。义亦略具。言十七门者。第一假实分别门。谓十二支九实三假。一已润六支合为有故。二生三老死。三相位别故。第二一非一事门。五是一事。谓无明识触受与爱。余非一事。上之二门摄在第一有支相续门。第三染与不染门。无明爱取三唯是染烦恼性故。七苦不染异熟果故。七分位中容起善染故。瑜伽第十假通二业。有通二有兼无记。此即第五三道不断门。第四独杂分别门。无明爱取说名独相。不共余支相交杂故。余是杂相。第五色非色门。六唯无色。谓无明识触受爱取余通二种。第六有漏无漏门。皆是有漏唯有为摄。无漏无为非有支故。上三亦如初门。第七有为无为门。有漏无漏门中已具在今第八因缘生灭。及第九生灭系缚门中已具。第八三性门。无明爱取唯通不善有覆无记。行唯善恶。有通善恶无覆无记。六支合为有故。余七唯是无覆无记。七分位中亦起善染故。瑜伽第十说。七通二性。此一亦如初门。第九三界分别门。虽皆通三界而有分有全。欲界则全二界无染。六处不具无色。唯名故。此门略无。第十能治所治门。上地行支能伏下地。即粗等苦六种行相。有求上生而起彼故。此门略无。第十一学等分别门。一切皆唯非学无学圣者所起有漏善业。明为缘故。违有支故。非有支摄。由此应知。圣必不造感后有业。于后苦果不迷求故。恐有问言。若尔杂修五净居业应非行支。若是行支圣便造业。若非行支如何生彼。感总报耶故论答云。杂修净虑资下故业生净居等。于理无违。意云。不还果等。以有漏无漏前后杂修。第四净虑资无云等三天。故业生净居等。于理无违。此总报业及名言种。凡时已造生第四禅。下三天业一地系故。后由无漏资此故。业生净居天。非是圣者新造业也。此义亦在初门。略具已如上指。第十二二断分别门。有义。无明唯见所断。要迷谛理能发行故。圣必不造后有业故。故非修断。爱取二支唯修所断。贪求当有而润生故九种。命终心俱生爱故。余九皆通见修二断。有义。一切皆通见修二断。大论第十说。预流果已断一切一分有支。无全断者。故若无明支唯见所断。宁说预流无全断者。若爱取支唯修所断。宁说彼已断一切支一分。释曰。皆断一分者。则明无明支非惟见断。由有一分无明在故。爱取二支非唯修断。入见道时断一分故。此门经疏略无。含在初门逆观之内。第十三三受门。十乐舍俱。爱不与受共相应故。老死位中多分无乐。及容舍故。十一苦俱唯除于受。非爱俱故。此门含在第七三苦集成门。十四三苦门。全同第七十五四谛门。即当第五三道不断门中故。有入谛之观。十六四缘门。全同第三自业助成门。十七惑苦相摄门。亦如三道不断门摄。释曰。上十七门全分同者。已如上指故。散在诸门。从多分指恐厌繁博故

疏。略耳

疏。十名可知者。前已广释。疏顺声律小有加减及与回互。大旨无违

疏。然各摄三观下。第三以义总收恐难领会十门义故。于中四。一总出十门之意。二收十为五。三收五为二。四总相融通。初中于上三观相参而用。谓三观小异论取不同。就其经文故可为一一。染净因起者。相谛观中明成答相。答于外难。成无我义。无我即净故。大悲观名愚痴颠倒。以着我故则生为染。无我则得无生为净。一切相智名染净分别。染净正是第三观名。今此中义通于三观。因起之字定通三处。二缘起本源者。直就经说故初观名第一义谛是一心本。世谛一心依本起末。第二观中阿陀那识迷执为我。即染净本。悟即是解脱根本故。一切相智名依止观。故为本源。三因果有空者。相谛观中名他因观。由无明故方得有行。斯则有矣。既从缘有斯则空矣。大悲观中破于冥性。斯有因缘。一切相智观名方便观。以各二业为后方便。亦即有即空义耳。四相成无作者。即不相舍离。相谛观中名自因观。谓离前支无后支故云相成。相成故无作大悲观中破于自在故。须因缘相成。无别作者。一切相智观名因缘相。有支无作故。五陈其谛理者。即三道不断。相谛名摄过观。但摄苦集故大悲名破苦行因。亦由唯苦集故。一切相智名为入谛。兼取逆观即灭道故。六力用交参者。即三际轮回初名护过观。三际因果为因。有力为果。无力能护失业等三过故。大悲观中治异道求中。无因之见因有力故。一切相智观力无力信入。并是力用交参。七穷苦慢。除即三苦聚集。初名不厌厌观。令厌微苦即穷苦义。大悲观中名破求异。中谓三界有涅槃。但是苦故今能穷之。一切相智中名增上慢。非增上慢。信入亦穷微苦非增上慢矣。八形夺无始者。即因缘生灭初即深观。名不自不他。以他夺自以自夺他。大悲观中名无常德。以形夺故。一切相智观名无始观。因缘无初故。九有无无本者。即生灭系缚。初即深观中明不共生。明非二作。互无知者故。有无本无作用故不能生。则无亦无本。二大悲观既无有净德。安有本耶。一切相智观既明无始。始即是本二谛无始故。有无无本。十真俗无违者。即无所有尽。初深观中显非无因。真不违俗无所有尽。俗不违真大悲观。中以顺有故。无有我德一切相智种种观故。亦不违俗故。其三观取文小异大旨多同故。以本意收为一致

疏。复收十门下。第二收十为五可知

疏。故唯四门不出事理下。第三收五为二。言四门者。谓上虽五意但有四门。一事二理。三事理双泯。四事理无碍故。前三意但是事理。三四二门不出事理。故为二也

疏。若从事理无碍下。第四总相融通。即成事事无碍及泯绝无寄。先正融通。后即此因缘下。会通佛性如前已说

大方广佛华严经随疏演义钞卷第六十七大方广佛华严经随疏演义钞卷第六十八

        唐清凉山大华严寺沙门澄观述

疏。自下大文第三彼果胜中文有三。初摄位。二依论下总科。三今初下正释

疏。今初意通五果者。正举经中牒前之意。意明十门通成五果故。遮于古人别配属故。谓远公云。一对治及离障胜。是胜慢对治果。前修十种法平等观。而为对治。此地满中更以甚深三脱为治。名对治胜。前治五地染净慢障。今此文更除微细我心及有无等。名灭障胜。二修行胜。是前不住道行胜果。依前不住更起胜修。名修行胜。三得三昧胜。望前治胜以说果也。前修三脱而为对治。彼治转增名三昧胜。四得不坏心胜者。望前灭障以说其果由灭障故。三昧之心不可坏。名不坏心。五自在力胜。望前修行以说果。依前修行上进无碍。名自在力。释曰。此上意明前之二果。从前文生后之三果。从前二果生。今疏乃有二意。一总释。二亦可下展转释。今初但明总是不住道行胜果。不住道行胜。初总标心境有三悲三智。经云。复以大悲为首。大悲增上大悲满足观世间生灭。释曰。观世间生灭即智对上三悲。以成三智。斯则五果不出于二。于中三节。初二悲智修治。次二悲智所成坚固。后一双明二果自在。此即隔句相对

疏。显二我作用空者。意明人法俱有能作之义故。皆名作者。非约人我独为其空

疏。二无相门下灭障中。疏文有四。初一总释。二谓若入空门下。举正显非智。论云。是三解脱摩诃衍中。但是一法以行因缘故。说有三种观诸法空。是名空门。空中不可取相。是时空门转名无相。无相中不应有所作。为三界生。是时无相转名无作。如城三门。一人之身不得一时从三门入。诸法实相是涅槃城。城有三门。若入空门。不得空亦不取相。是人直入事已办故。不须二门。三若见法先有下。举非显修智。论云。若取诸法空相。生憍慢言我知实相应学无相门以灭空相。四故修无相下。结成修意为灭障故。远公云。二中一灭障即取性心亡。二得对治即得理为治。三念想不行即取相心灭。亦初一异凡夫。后二异二乘

疏。三无愿门中一依止者。智论云。若于无相中生戏论分别。有所作应修无作门。今无戏论分别。即能修无愿故为依止

疏。又上三空下。拣教智。论云。阿毗昙空门缘苦谛摄五蕴。无相门缘数缘尽。无作缘三谛摄五蕴。摩诃衍三门通缘一切法实相。以是三解脱门观世间。即是涅槃。释曰。对文可知。言余如智论者。论云。经说涅槃一门。今言三者。法虽是一而义有三。复次应度三种障。谓爱多见多爱见等者。见多者说空门。爱多者说无作门。爱见等者说无相门。谓无男女等相故。断爱无一异等相。断见皆是彼中余义

疏。初离三想者。离彼我想为一离。作者想为二离。受者想为三离。有无想虽通二门。无愿一门多约离有

疏。此用深空灭离二我者。即离彼我想。通于人法二我无也。云何为深。五地唯约净法。说十平等。今直说深空。又前是加行观察。今已住空般若现前故。二四地道品有身受等故。三此地初用十平等。十相未泯故

疏。初厌相者。前勇猛修中先知后厌。今丈夫志修先厌。后证明渐胜也

疏。又俱未满故俱不住。广如净名者。即净名第三菩萨行品。众香菩萨欲归本国。白佛求法云。唯然世尊愿赐少法。还于彼土当念如来。佛告诸菩萨。有尽无尽解脱法门。汝等当学。何谓为尽。谓有为法。何谓无尽谓无为法。如菩萨者。不尽有为不住无为。何谓不尽有为。谓不离大慈不舍大悲。发一切智心而不忽忘。乃至云。以大乘教成菩萨僧心无放逸。不失众善行。如此法是名菩萨不尽有为。何谓不住无为。谓修学空不以空为证修学无相无作。不以无相无作为证。乃至云。观诸法虚妄无我无人无主无相。本愿未满。而不虚福德禅定智慧。修如此法是名菩萨不住无为。又具福德故不住无为。具智慧故不尽有为。大慈悲故不住无为。满本愿故不尽有为。集法药故不住无为。随授药故不尽有为。知众生病故不住无为。灭众生病不尽有为。释曰。然净名意但拣二乘。谓二乘尽有住无有为三相故名为尽。无为无相故名为住。若尽若住即是有碍。不尽不住为无碍法。然是一法就事相分。故为二别。尽有即无起行修德之地。住无即绝慈悲化道之能。是故大士并不为也。而彼经文先正释不住不尽。后又具福德下。释不住不尽所以谓夫德之积也必涉有津。若住无为则功德不具。具智慧故不尽有为者。智之明也。必由广博若废舍有为则智慧不具故。大悲不尽。然文广故指其文。若望此经但是不住无为之义耳。阙于不住有为之义。今疏向云功德助道。未满足故不住无为。即全同净名文意。言智慧助道未满足故不住有为者。则侧用净名。彼具智慧不尽有为。以尽有为不成广智故不尽矣。今以住有为不成深智故不住矣。则是具智慧故不住生死。具大悲故不住涅槃义耳。言又俱未满故俱不住者。谓应反上智慧助道未满足故。不住无为功德助道未满足故。不住有为谓若住无为不成种智。是为不入生死大海则不能生一切智宝。若住有为自沦生死。安能成就诸佛功德。亦是具大智故不住涅槃。具大悲故不住生死。谓若住涅槃非是亡缘之智。若住生死非无爱见之悲。余义至下当释疏。大品中下亦成上义。若是证时住无为也。故七地云。虽行实际而不作证

疏。即此所为亦是所以者。所为成智慧不住有为等。所以者以有智慧故。不住有为也。余可例知

疏。如来藏包含无外。故云大者。远公云。大者宽广。广谓真识体中统含法界恒沙佛法。同体平等相应而起。无有一法别守自性。是故名空。随顺法界无门不在。故名大空

疏。五观七转识等者。即真识之用。用而常寂故说为空。故疏云皆无自体即是空义

疏。楞伽云下。问明已引。十忍更明

疏。依解起行行修究竟者。此有二意。一释论中。不放逸言。所作究竟离放逸过故。二即复由此修究竟故。经称第一下引论释可知

疏。四因事者依德起用。是释因义。德是用因分别。为智障者。即分别因缘相也

疏。又此十与涅槃十一空多同等者。经当第十六。南经十五

疏。当第六。为答修舍果故。迦叶菩萨白佛言。世尊云何名空。佛言。善男子。空者所谓内空外空内外空有为空无为空无始空性空无所有空第一义空空空大空。彼疏释云。前十相空。后一真空。就彼妄情所取法中以明空义名为相空。就真识中以辨空义。名曰真空。亦得说言前十境空。后一智空真智空矣。于妄分齐情外有法破之显寂故。于十种就境明空。据实以求心外无法。一切诸法皆即真心。真心体寂故。后一种就智说空。故地论云。一切法如说自体空。名智自空。就前十中。初八以无破有为空。第九第一义以有遣无为空。第十空空以其非有非无。双持有无名为空空。与地论十平等同。就前八中。前七明其众生及法无性故空。后一明其众生及法无相故空。因缘假中而明无性名无性空。毕竟空中无因缘相。名无相空。就前七中。初六明其众生无性。即是生空。后一明其诸法无性。即是法空。复前六中。初五就其现在观空。后一就其过去观空。现中初三就内外事以观空理。后二就其有为无为法相观空。就前三中。众生名内非情为外。就内法中。观无神主众生寿命名为内空外空法体。观彼外法非我我所故。名外空等。其无始空。经云。菩萨见生死无始。皆悉空寂。所谓空者。常乐我净。皆悉空寂无有变易。众生寿命三宝佛性。及无为法。是名菩萨观无始空

疏。第一空者。彼名空空者。此当第十。远公云。是有是无就诠辨理。是有牒前第一义空。以有破无故言是有。是无牒前八空。以前八空中以无破有。故曰是无。就此有无以说空义。故曰空空。是是非是是是名空空者。破诠显理。前句虽复就诠辨理。非留彼诠故。复破云。是向有是向无。是两俱非是方名空空。非留有无说为空空是义云何。已如上辨。因缘诸法有无同体故。说无为有说有为无。无为有故有即非有。有即无故无即非无。非有非无故曰空空。三十地菩萨下就人显胜。四如是下寄对显异毗昙论中。说声闻人先观五阴非我我所。直名为空。后观前智。亦复非是我及我所。故曰空空。成实论中。先观生法空无自性。空无自性直名为空。后观前智亦空无性。故曰空空。今此所论离有无相。故曰不同。上来十空与地论十法平等互出其义相似彼中。初一总相明空。余九是别。别中初七以无破有同此初八。彼中第八以有破无。同此第九。彼中后一以双非破有无。同此空空也。释曰。上皆远公之意。以十一空会十平等。今将十一空以会十空义则全别。然此十空由前平等加行而成。故二处多同互证皆得。然远公释义于理于乖。消于经文乃成曲巧。又有为无为唯属生空。义成太局。又总取前有无释于空空。亦经无我摄。今疏释空空。而文中五初牒名对经。二谓前空下略释三。故彼经下引经。四谓是非下释经。亦当体空者。释经是是非是是是名空空义。谓非但有无是非亦尔。谓空有两亡为是计。是即是故名是是。即上空字而不碍双存。故此是是即非。是是即下空字。故言空空。斯则是即非故非是。非即是故非非。故疏云是非亦当体空耳。五如是空空下叹胜。上即科疏下即释也。然经有二句。今疏经前略释。是经上句意。经云是有是无是名空空者。意云。即空是有即有是无。故云是有是无。无既是有则无非无矣。故云空空。既即有是空。则空亦非空。故云空空。正同十平等中有无不二。故平等也。由不二故双存。由非不二故双夺。故今疏云。若有若无本来自空。以有即无故有空矣。空即有故是空空矣。是以遣空总有二义。一以重空遣空。如净名云。唯有空病空病亦空。中论云。诸佛说空法为离于有见。若复见有空诸佛所不化。二以有遣空。谓空即是有。故非空也。故经云。色即是空非色灭空。故空非空也。是则不异有之空。则空非空。不异空之有则有非有。今正取空非空义由空非空即是有非有义。又空故非有重言空故非空。又空故不碍空。重言空故不碍有。非空非有能空能有双融互泯自在无碍。是故十地通达少分。岂是二乘之所能知。故言第一

疏。今亦约少分者。通妨。妨云。既言十地通其少分。今此六地云何证得。故云亦约少分耳。余文可思

疏。今初不坏心者。言由离障灭。即第一果行成是。第二果若。智即第三第一。若悲即第二也

疏。亦可对前十三昧心者。远公云。此九别句即十空三昧。以法空第一义空合故。故九摄十。九中亦四。初四就前观以说不坏。次一就前不放逸以说不坏。次一就前得增上以说不坏。后三就前因事。以说不坏。今初疏云一信理决定者。论云。一信观不坏。即就前入空三昧以明不坏。以论经前云信空三昧故。二疏云行堪调柔者。即论堪受不坏。此就前法空及第一义空三昧以说不坏。取有心息能入法空第一义空故。论云堪受于空不着。经云纯善不着于空。即第一义空

疏。加行字即前观二空之行。三即论云。于密处不惊不怖不坏。就前大空以说不坏。阿赖耶识微密难测。名为密处。经云甚深于密能入。故称不怖。四即论自乘不动不坏就前合空以明不坏。行合如来藏故自乘不退。五即论发精进不坏。就前不放逸第一义空三昧以明不坏。能起行修故云精进故。疏云胜进无息。六即论离悭嫉破戒垢不坏。就前得增上起。空三昧以明不坏。前就行德今就断德。前约利他今约自利。然论经云净心故约断释。今经云广大心。广即悲心大即智心。是二利心二心相导故。泯绝自他下三不坏。就前三种因事以明不坏但七八前却以第六总明悲智。今七八别明悲智前后俱通故。七即论广利益众生不坏。于前教化众生因事不舍离空三昧明不坏。八即论上求胜解脱不坏。就前智障净因事如实不分别空三昧明不坏。义如前说。九即论化众生行不坏就前愿取有因事离不离空三昧明不坏。带空涉有故云方便相应。然疏虽恐繁文不具配属。释文之中皆已含具

疏。顺佛菩提者。能深入趣向故者。以论经云随顺成就起向阿耨多罗三藐三菩提不退转。故为此释。此随顺言亦是顺忍。顺向无生忍故。以经约究竟故直顺菩提

疏。即能伏他力者。是论释义。对前总句不可坏心及决定心。下诸力名皆是论文。二云得法空故者对纯善心以前纯。善。对法空三昧故。然初句全。牒经第二句义牒经下七句不。牒经。直举论文三对前第四不退转心。四对前第三甚深心故。疏云。此与前二前却。以不动故入甚深入甚深故不动故云相成。五对不休息。六对广大。七对无边。八对第九。九对第八会其前后如疏其之

疏。出现品有能持等四种风轮者。即初总明。出现中一名能持。能持大水故。二名能消。能消大水故。三名建立。建立一切诸处所故。四名庄严。庄严分布成善巧故。释曰。既持既严故。非散坏有散坏风复无四种者。意业中第九相云。佛子譬如风灾坏世界时。有大风起名曰散坏。能坏三千大千世界铁围山等。皆成碎末。即散坏风唯一无四也

疏。故起信云。但心相灭非心体灭者。论有问云若心灭者。云何相续。若相续者。云何说究竟灭。答曰。所言灭者。唯心相灭。非心体灭。如风依水而有动相。若水灭者。即风相断绝。无所依止。以水不灭风相相续。唯风灭故动即随灭。非是水灭。无明亦尔依心体而动。若心体灭则众生断绝。无所依止。以体不灭心得相续。唯痴灭故心相随灭。非心体灭。释曰。现文可知。楞伽亦云。若心体灭则本识灭本识灭者。不异外道断。见戏论。第七远行地。初来意有二。一正释约慧寄位双辨。二瑜伽下引证约慧。于中先举六地为入因。后为令下正辨此来

疏。言远行下释名为三。谓标释结。二成唯识下释名总举五释。意符唯识以包含故。言此有三义者。一善修无相到无相边。故名远行。二功用至极故名远行。三望前超过故名远行。及释善修并如前说。二引深密即第四经。亦是前行。后远者指上二义。为前后耳。三引摄论兼释即第七论。四引金光明即当第三。五引庄严论。即第十三偈云。离道邻一道远去名远行。论释云。菩萨于七地中。近一乘道故名为远去。问谁远去。答功用方便究竟。此远能去故名远行

疏。虽有四义下结成。结归二义。十住论即第一卷即当后义。仁王即当下卷奉持品。既言远达则亦通。从前来达向后位

疏。然其能远去行下。第三离障先蹑前。起后后故。所离下正明。亦唯识论具云。七细相现行障。谓所知障中俱生一分。执有生灭细相现行。彼障七地妙无相道。入七地时便能永断。由斯七地说断二愚及彼粗重。一细相现行愚。即是此中执有生者。犹取流转细生相故。二纯作意求无相愚。即是此中执有灭者。由取还灭相故。纯于无相作意勤求。未能空中起有胜行。释曰。今疏便以释言解之。义已委具。由执还灭故求无相。又相有二种。一有二无。无者为细

疏。以常在下四辨所证如。于中二。先举能治。治于前障后故。能下正辨所证。唯识云。七地无差别真如。谓此真如虽多教法种种安立。而无异故。彼疏释云。谓虽诸教法依如建立。如无异故。又于教中立种种名。法界实相而如无异。今疏中云以了种种教法同真无相者。谓虽诸教法随机种种。不失平等一味之相故。中边论云。第七地中所证法界。名种种法无差别。由通达此知法无相。不行契经等种种法相中故

疏。以能下第五成行。疏乃至下。第六得果欲显七门义理相顺。故云乃至。得果者。中边论云。通达种种法无别法界。得一切法无相果故。故知以下结成总意

疏。行中有五种相下文三。初列名。二五中下对三心料拣。三初言下释其名相

疏。今初具足六地下。疏文有六。一略属经文。言义含所治者。正意结前故。二谓前乐无作下。别释方便慧殊胜道之所以。由乐无作不能涉有故。非方便不起胜行。岂为胜道。今以十种下。显得名所由。三是则下释其二名。四于何增上下明其所胜。五前六地下解相滥难。难云。前六地亦有即空涉有。何不得名方便胜道。答意可知。六虽行空行有下。通所治名局难。亦蹑前起难云。前地既许双游空有。何以偏名乐无作行。释意可知。复应问云。前地何以偏乐无作。答治前五地取有慢故

疏。论主摄十为四种下别释四中。前三自利。后一利他。前中论当第一。今当第二。第二是第一。今顺经次。一是离过后二成德。成德中前成福报后成内德

疏。一初句即护恶行。因事者。于中先举恶行。后今由上句下明护。上句护下句。无爱见恶行。下句护上句。无弃利乐恶行

疏。二即财及身胜因事者。成胜报也。下句是身财得上句故。身财俱胜。上句得下句故不滞寂。一同初句。胜财则随物下辨二胜相。此二若胜能集助道

疏。三护善根下于中有二。先正释。言是得彼胜因增上者。胜因增上即观空智。后虽有下通妨结成。谓第一句虽有慈悲但是意乐。未正利他故。三自利。然疏释文皆先释下句涉有胜行。后释上句以导下句。二皆互资例如初门

疏。障有四种如五地随世智中说者。前论云。是中书等有四种障对治。治四种障者。一所用事中妄障。二邪见软智障。三所取物中不守护障。四取与生疑障以书治初障因声。二论治第二障。印治第三障。算数治第四障。今文书是第一治。论是第二等即等取印算。数等无量事业。总以结之。而为能治通上四也

疏。四于大法众会集故为物起严土行者。此上明望益修因。净土之中圣贤集会。诸上善人俱会一处。与诸菩萨同一志行。无有怨嫉令物修因。当获净土人。宝为严而集会故。疏令生五福等者。见唯约眼闻但约耳亲近约身。供养舍财修行通三业。言自身无身同佛法身故者。佛以法为身清净如虚空。所现众色形令入此法中。今菩萨亦无身现身。登地已上分证法身。同佛身故。疏下二亦然者。即总例口意同身。皆即体起用。无言现言无知而知。并如经文

疏。于无长短中随问善释者。三世是长一念是短。今明三世即一念是实。是空则无长短。不碍能知种种时节长短劫事

疏。第三总结胜能者。具此十行入七地故

疏。论释云此十下。所以释者。由上释十句。但明其中所起胜行。未显方便殊胜之由。今总释之。先举论。后皆上下二句下。疏释。于中有三。初解共对。次由此上下各能下释对治。上句治凡者观空。下句治小者起行故。后由二摄取下。通释两个摄取。以上共对亦有摄取对治。亦有摄取。此二摄取大旨则同。上句摄取下句则不滞小。下句摄取上句则不滞凡。此是共对摄取成殊胜行。上句治凡不摄下句。非真实治。下句治小不摄上句。亦非实治。二互相摄皆成胜行。又若别说。上句摄下即空中方便慧。下句摄上为有中殊胜行。二既和合通得名为十种方便。亦得名为十种胜行故。论但云此十种发起殊胜行。既空有无滞故。能对治六地之中乐无作行也

疏。四彰分齐下。言此以行入故。常行不舍者。七地功用行满方便涉有故。得行入之名。第二彼障对治

疏。为所知所化者。所知即智境所化即悲境

疏。要则摄十为五者。所以更为此摄者。以此说无量要治于有量。要唯有五故为此摄。如前频释。一即众生界无量。二世界无量。三法界无量。四调伏界无量。五调伏方便界无量。然此五界唯佛穷证。能化德业周于五界。菩萨修入能化德业。趣入五界。又此五中初一所化。次二化处后二化法。正化即前三是所后二是能。望能化能知。五界皆所。将此十对能化所化。望于菩萨。皆是所入则入。皆修入证入亦了达也

疏。今初先牒前无量下。疏文有四。一略释经。二然任放下。示无功用相。三由功用行。此已满故者出无功用因。四此则修行下结成拣异。第三双行。疏中文二。初总叙名意。后方释文。初中二。初列章。二料拣。今初下文中疏皆具释。今当总释。一内证行止观并起为二行双行。常现相续名为无间。二始起胜进于上决定。名为信胜。三依信起行行有义利故。名为义胜。故名大。修起名作。四行成觉因。名菩提分。分具多义称为差别

疏。四中前三下二料拣。然四含多义故曰总该。亦胜进摄。疏。无有一念休息废舍者。全舍为休暂废为息

疏。以味况审者。睡眠皆以昧略为性。略拣寤时昧拣定中。定中虽略而不味。故今为对审但举昧耳

疏。故三檀等中随取其一者。远公云。施中但有法施。戒中但有律仪。律仪中有三离。一因离。二对治离。三果行离。今唯有因离灭烦恼故。尸罗此云清凉。忍唯辨他不饶益。精进唯明摄善禅。定唯明引生功德。般若唯明第一义慧。然案经文义类易求。故云可知。后之四度是论自释

疏。一念具十下。明得分齐。初心圆观亦即修此。今此证得七地特明

疏。为显十度通二义者。一成义利即前利他。二求菩提即今自利。结文是一而义两成。故云巧用。疏三四持等者。等取三十七品三解脱门。疏文有七。一标别所治拣后所知。二谓依四持下显净惑。要由此三方能净故。三任持下释总名。拣非胜进云持自分。四亦名四家下出异名。所住处故者释成家义。亦可得名四种住处谓智住处等。亦名成位处。五四者一般若家等者下。释四体相。即就家释。六由初二下结成四义。由般若照谛名初二业。得惑灭苦净故有四也。七若约别说下。约位分别则初亦名智位。二见实位。三断惑位。四证灭位。然其此四通于诸位。故云若约别说。以配四位耳。第四前上地胜

疏。先问意云等者。从前一切菩提分法念念皆悉圆满中生。问意可知

疏。得入下胜进趣后者。经中但云得入智慧自在行故。论经云得入智慧神通行故。论释云。通者五神通。智者如前说。释曰如前十方便智上七地。修此十智至于八地无功。而成似于此地故得指之。然论神通即今自在

疏。全二经故以自在指十自在。十自在亦神通故

疏。二通示诸地满相等者。疏文有三。一总示文意。二故论下举论征释。以成前义。三初地愿中满下。正释经文。欲依如来智即求愿义

疏。有少余章未名清净者。即果累无常微细习气故

疏。要由积功以至无功之功者。结成胜后地义。后地无功用因于此地功用成。故名之为胜。非行体胜

疏。一若六地为杂染下。通论染净乃有四门。一云外凡人位说为纯染。善趣已上乃至解行名为染净。初地已上乃名纯净。二善趣亦染。种姓已上为染净。纯净同前。三者地前皆染。初地至七地亦名染净。八地已上乃名纯净。四染义如前。十地皆染净佛为纯净。今是第三门耳。疏。如是此地名为染净非染行故者。谓约行非染约位在染中

疏。以二因故者。二因即经中。一以回向菩提故。二分得平等道故后然未下即经。然未名为超烦恼行

疏。今释云。由上二因故非超也。上用二因得名清净。成于行净。今以二因却同染者。既因回向及分平等而得净名。明非净位故同于染。不同八地报行净也

疏。次喻中轮王喻七地。随分舍功用道者。略举其要此是行净义。拣异梵王报得净耳。然准合中二喻各有五节至下当知。然云梵王游千界者。即千四天下准俱舍论。二禅量等小千。三禅等中千。四禅等大千。婆沙有义。初禅之量即等小千。故生梵世得游千界可知

疏。第二别明。此地双非染净。于中二。先明超过后辨双非。前中有二。一总释。二前求佛之心下示其所超。此有二类。一约所求道中辨。贪嗔痴即是所知障。中智即障义。前六地有。七地都超二又初地下正超烦恼。前之六地。于俱生中分分别超此。都超尽故云诸烦恼众。众即多也。故唯识云。能永伏尽如阿罗汉

疏。而云多下。上明总超即是非染。此下明其细者。未超即是非净。由此生下双非之义。故论先云。住是第七菩萨地过多贪欲等诸烦恼众者。未至报地故。即云是故此地不名离者。明知蹑前明双非也

疏。第五佛子至双行果等者。疏文有五。一释总名。二文分下开章。三远公下辨所从。四又初一下辨双行相。五就初果中下释文。三中然疏意欲通。故引远公局配。于中有四。一由于离障故至此中。三业皆净。二由前双行一念。不舍止观双行。三昧转增故名为胜。三胜行转增故得过地。四由前有方便智起殊胜行。今此行成名得胜行。又初下双辨行相

疏。就初果中复分为四者。一戒清净。二世间智净。三得自身胜。四得胜力。又此四中初三自分。后一胜进。前中初一离过。后二成善。善中二。前行用后行体。然疏皆具拣令易见耳

疏。初明离定障者。二即智障由上对治故离二障。然禅等虽前已释。今略要知。禅即四禅三昧即三三昧三摩钵底。如疏有五。论三摩跋提即三摩钵底之古译耳。神通谓五神通。解脱谓八解脱。经中先彰所成。后然是下对后拣劣。论中先略指云。四得胜力。禅等现前胜如经等。次重分别云。是中依禅起三昧三摩跋提神通解脱。为教化众生故。寂灭乐行故。灭定三摩跋提如是次第。释曰。此中论主明得胜力具足三禅。四禅为能起。一一得三昧等。即引生功德禅。二为教化众生故。即出引生之意。是饶益众生禅。三寂灭乐行下。即现法乐住禅。然九次第定皆是现法乐住。今从最胜举其灭定。正是此地之所安住故。疏云正意在此下。约于此以辨胜行。定散自在故云胜行耳

疏。后此地下离智障者。据此业清净果。即前双行果也。前双行有四。一二行双无间。二信胜。此二三昧为果。三作大义。四菩提分差别。即业清净为果

疏。三依一名说无量义。即知教旨。后一义多名是知教诠。论经三名益意三昧者。义能澄心故

疏。此约寄位者。前六寄凡小故未过也。第四得胜行

疏。不起灭定现诸威仪。即净名第一身子章前已引竟。然十通品第十通云。菩萨摩诃萨以一切法灭尽三昧智通。于念念中入一切法灭尽三昧。亦不退菩萨道不舍菩萨事。不舍大慈大悲心。修习波罗蜜未尝休息。即动寂无二也

疏。准大品经未善巧前亦有其喻者。经云。譬如有人不晓船法。乘船入海没溺而死。菩萨亦尔。未得方便波罗蜜。入实际海则证实际。次云。譬如有人善知船法。虽入大海而不没溺。菩萨亦尔。得方便波罗蜜。虽入实际而不作证。疏家不断行中。虽言不染而示有妻子。即空中方便慧。是观于空不碍有故。虽然不烧即有中殊胜行。涉有不迷于空故。唯此经文具斯二言。上下应有而不具者。皆用二句互相摄导。已具二故。如虽示生死得下而住涅槃。即有中殊胜行。下住涅槃得上示生死即空中方便慧故义已尽。但文不具耳

疏。皆顺五欲十军是魔境界者。约五欲境。即是魔王所缘之境。若将资神及益身等。即分齐境。十军已见初会

疏。即四魔等法者。老病衰退总是蕴魔。死即死魔。老病之时亦有惑。俱即烦恼魔。而言等者。兼有十魔不求有生。即不行其因生必老死故

疏。此有三者。无数烦恼不出此三。谓见爱无明。又见爱即利钝二使。无明兼缚所知则二障皆缚。如佛示学二仙者。如本行集。一阿罗罗仙人。二郁头蓝弗仙人。第八不动地

疏。所以来者有二。一约实位。二又约下寄位

疏。言不动下二释名。总引八释。兼无性世亲释论。则有十释。下结不出三义。而唯识最具。今初先举论。后谓任运故下。疏释即第九论。二与本分大同者。即本论云。报行纯熟无相无间。故名不动。报行纯熟即是功用不动。前地所修今此位成。名为报熟。空有常行名为无间。不为空有间故。常在无相观故。三而金光明者。即第三经。先举经但有二义下。疏释不言不为相动故。但二义由相于前下。疏出经意。前常在无相观。相已不动。此经无相正思唯修。是常无相故。烦恼不动得自在故。功用不动。四摄论先举论。此则略无烦恼。是疏释论。而言略无者非全无也。或以相用即烦恼故。无性下引彼释论当其第一。彼文繁广故。言意云。无性具云。言不动者。谓一切相及一切行。不能动彼心故。第七地中虽一切相所不能动。相不现行故。然不自在任运而转。有加行故。第八地中任运而转。不作加行故。是名七八地差别。次云世亲同此者。亦七论云。由此地所有诸相及一切行。皆不能动无分别智任运流行。五深密者。即第四经。亦以相行即烦恼也。六十住论亦是第一论。此即约人下疏释。七仁王者。即下卷经。后上皆下疏释。即常在无相观故名等观。八下经可知

疏。故所离障亦离下。三所离障。亦唯识论今当具出论文。论云。八无相中作加行障。谓所知障中俱生一分。令无相观不任运起。前之五地。有相观多无相观少。于第六地有相观少无相观多。第七地中纯无相观。虽恒相续而有加行。由无相中有加行故。未能任运现相及土。如是加行障八地中无功用道故。若得入第八地时便能永断。彼永断故得二自在。由斯八地说断二愚及彼粗重。一于无相作功用愚。二于无相作自在愚。令于相中不自在故。此亦摄相土一分故。八地已上纯无漏道任运起故。三界烦恼永不现行。第七识中细所知障犹可现起。生空智果不违彼故。释曰。求无相故名曰加行。令无相观不任运故。五地观心劣故无相观少。六地观染净平等故。无相观多。七地作加行故。然准护法于无相中有加行智。体非是障以善性故。只由所知障令作加行故。说名为加行障也。由此第七有加行故。虽现金等诸相及土。非任运现故。以为障生空智者。谓生空智所引后得智。及灭尽定也。金光明中詺二愚云。一无相法多用功力无明。二执相自在难可得度。无明余二可知。疏但撮要大旨义已略周。余如前说。疏其所证如亦唯识文。具云。八不增减真如。谓此真如离增减执。不随染净有增减故。即此亦名相土自在所依真如。谓若证得此真如已。现相现土俱自在故。以论对疏广略可知。此名即摄论名。世亲释云。谓于此中杂染减时而无有减。清净增时而无有增。无性释云。法外无用所以不增。诸法不坏所以不减。无性复释一同世亲。中边论云。由通达此圆满证得无生法忍。于诸清净杂染法中。不见一法有增有减。上释不增减。又世亲释相土自在所依真如。云于诸相中而得自在名相自在。随其所欲即能现前故。于所现土而得自在。如欲令土成金宝等。随意成故。释曰。相约现身土约器界故。下文中于三世间而辩自在

疏。故所成行下。五成行略有其二故。庄严论第八云。虽净佛土而无起作无功用。即自在义

疏。及所得下。六得果言定自在等者。即梁论云。通达无增减法界定自在等。得法身果。意云等者。等九自在。金光明经。八地发心得证三昧

大方广佛华严经随疏演义钞卷第六十八大方广佛华严经随疏演义钞卷第六十九

        唐清凉山大华严寺沙门澄观述

疏。第二正说下分二。先依论科。后七中下料拣。先以论对经料拣。后又前二下。约三心料拣。七名广义至文当知。略已释竟

疏。先标集德处者。于中先拣滥正释故。论云七地总相。后以是功用下。出总所以。四节之总初地已释。谓一入位。二入地。三入无功用。四菩萨地尽

疏。前三同相者。此是体相非标相也

疏。一二种无我上上证故者。即论文此下疏释。十地同证二无我理下。二句皆有三段。一举经。二举论释。三疏释论。二中不住道清净故是论。三中彼方便智行所摄满足助菩提分法故是论。余皆疏释疏。四常念下。即经常念如来力无所畏不共佛法。次牒论文。后疏释牒论中。论有二节。一先牒前文。二念通达佛法。即以前释此。就牒前文中牒两处文。一所说法分别智。即牒前因分中义。后教化智障净胜。牒前清净分中义。疏谓前十法下。疏释论。依前二段释之。先释牒前因分中义。故云谓前十法明门是智分别故。前疏云。明为能入之门。法为所入之法。此上疏指前经。从依彼智。明入如来所说法中。即彼论释彼论。具云得证地智光明。依彼智明入如来所说法中。释曰。得证地智即四地证智。其光明。即前三地得此四地证智前相。此两处智俱欲通达佛法。佛法是三地求多闻。所得即十法明门中。所观察众生界法界世界等

疏。次教化智者。即释论牒第二段经。先标牒。经具云。以十种智成就法故。得彼内法生如来家。言障净胜者。即论牒前。论释谓灭三地下。疏取意释论。若具论文言。云何于如来家转有势力。依止多闻智障究竟故。除灭智障摄胜故。今疏已释

疏。上之二段下。释论念通达佛法。即以前释此也。二处皆念通达佛法。佛法即力无畏等

疏。五地中等者。即经善清净深心思觉

疏。三种大悲者。即大悲为首。大悲增上大悲满足。观因缘生灭

疏。七中二句者。一大慈大悲不舍众生。二入无量智道。疏云以无量众生界故。入无量智道者。全是论文。入无量众生界。是彼初句无量智道。是彼第十六句。以与此相应故。应具二十句十对。第二句云。入无量诸佛化众生业。三入无量世界网。四入无量诸佛清净国土。余广如彼。第二净忍分。疏文有二。先总科。后然无生下就类明忍成。前三段之中前二段也

疏。今初中下疏文有七。一释初总句入一切法言。二以历事下总科。三四中一破相下显功能。四若寄位下约位。五又此四中下出体。六依佛性论下指广。七事无生下随文解释。初二可知三中然相实名事泯事入理。名事无生。良以无生缘起成事。是故泯事即是无生故。能破相即遣有相也。二破性者。破遣有性也。法体名性。以一切法各有性故。泯性入如名性无生。良以无生缘起成性。是故泯性即是无生。三因泯者。即离因相因有始终。三世分异名数差别。证实返望本无此数名数差别无生故。地持云。不知无言自性事故。三世差别。以知无言自性事故。三世中一切平等。四果离者。即离果相。果位业用名为作业。证实以望无业可得。名业无生。是故结云前二破相入如后二证实舍相。一破有相。二破无相。二俱破相。二俱入如。三四皆证实并舍相。如文思之。四约寄位中舍相入实故。是加行性相双遣故。为根本用。是后得于理必然。三通始终三世别故。五出体中大同第六。三性但合为真妄耳。则妄通依他遍计真唯圆成。依佛性下六指广者。即三性分别。言佛性论者。即彼三性品。论云由有三性故说不了义经。达三性者。自然显了名了义经。如经中说。若人得无生法忍。则不退堕。问云。此言云何成立。答曰。由三性故。则得成立如来约分别性故说本来无生忍。约依他性故说自性无生忍。约真实性故。说惑垢苦本性无生忍。释曰。若取文显。初一似约遍计。以云本来无生故。第二同约依他。以论云自性无生故。后二约圆成。以第三约位有垢净故。第四约佛明所证故。细而寻之。初一修成有依他故。本有即圆成故。约位亦从缘故。佛所入处缘起遍故。又本来无生该下文故。故疏更不广释。但指前文第二经疏

疏。事无生中下。第七释文于中二。先总后别。总中言后三不减。亦即无灭者。略有二意。一者。是无生中别义故。次云以初摄后皆曰无生。二者亦应名无灭忍。即如前疏中说。今亦从总但云无生。然此无生灭即不增减真如。别是此地之所证故

疏。别中七者下。二别释随相执实。即是所治。欲显无生反立七实。然文含二义。一者此之七实通于凡圣故

疏。但案文释。二者约位分别。于中有二。先明前四为遣初地已上。后三为遣外凡解行。前中又二。先别明。后结束。前中一净分法中本有实者是论。谓计自性下疏释。先举所治。今为治此下引经。为能治下七皆然。此初多约初地自性住性。即第一义空以初证故。若谓有物在于心中为事物有故。为所治故今治之。本来无生无生岂是事物有耶。言本性离故者。疏释经文无生之义。若先有生下反以成立。即净名云法本不生今则无灭。得此无生法忍。是为入不二法门疏。二新新生实者。二地已上乃至七地。修道渐增说为新新。能治中言从缘起故者。以从缘起起即无起

疏。三相实者。即第八地至十地无功用相。是上二相智无功用。是集起相。无生理现是本有相

疏。四后际实者。佛果究竟为后。果即菩提涅槃。能治中真如出缠释无涅槃实。菩萨成佛下显无菩提实

疏。上四下后结束有两重。初重约三佛性。三佛性义至十地。更明大旨可知。后又此四下。展转收束。谓何以知无本有实。新熏无成故。何以知无成二相不可得故。何以知不可得。菩提涅槃亦离相故

疏。五先际实下第二释后三句。遣地前执。初即烦恼。二即生体是有为故。三通上二亦即是业。初句治中云烦恼无可坏者。是性空门。菩提作烦恼。约妙有称实门。染净和合以为众生者。此中染即烦恼。净即如来藏。即以不生不灭和合名为众生。上明不生不生。今辨生灭不生也。又前即不空藏者。以佛性妙有故。此即空藏者。不与烦恼相应故。今二藏双遣云皆不可得

疏。上经云下。即须弥顶上偈赞品。善慧菩萨偈以上半为所治。下半其性如虚空故。说无有尽为能治。余并可知。所以先遣地上者。正此所证故。从细至粗故。又后举地前以粗况细。粗未证性此应合有。今不可得况于地上佛性之性

疏。第二无性为性下。此自性无生中有三。一会二经。二释文。三会中道。非有即是无。性有性即是为性。故云义旨不殊。二无性即是下释文。先释无性。执法有性名之为我。如地坚性水湿性等。以无我故名性无生。言非先有今无者。拣断灭无。中论云。先有而今无是则为断灭。故亦非全无。真体下释为性字。于中二。先反立。次以前观事下。顺成妙有故。论云下引证。言观事者。此无我理是四地。乃至七地所观事故。明知是有。又是所忍法故。若无所忍则无如可证。三斯则非有非无下。会归中道。有二中道而文三节。初正立二种中道。二引论证三结成。今初一非有非无为中道。无性则非有为性则非无。既即以无性为性故。云此二不二。即以性无体有。为真谛中道。二又此理下。不即不离为中道。即事显理为二谛中道。七实皆事。不之一字即是于理斯即。于谛常自二。于解常自一。今通达此无二真入第一义也。二故论下引论证上。疏家立二中道。皆因论主无二相言。由无二故。法无我理得为诸法自性无生。远公破古人。言观心与法无我理心境不二。非也者。实如所破。三斯则下结成

疏。第三初中后下。疏文有二。先正明。后拣滥。今初即正证无增无减真如。若随相说前际染增净减。后际净增染减。中际半增半减。今约理性空故并非之

疏。然准瑜伽下。后拣滥。滥前三句故。前三句者即第四后际实。第五先际第六尽实。正约众生当中际故。故今释云此明三世约时辨异。今此约位以明三际。前际即七地已前。后际即九地已后。中际即当八地。虽约位有殊而体无增减。又前三先际唯染。后际唯净。中自约生今之三际皆通染净。又不同也。故疏结云论就染净明之

疏。第四无分别下。疏文有二。先正明。后总结。今初引论正证。同佛入处。以论经云真如无分别入一切智智故。故今疏用佛智释之。若直就今文。但是八地自无分别智耳。要无分别真智方入。非是俗智能入无生

疏。如是四种下总结。以论云如是无生法忍观示现故。今回其文。论意云。此中广说无生理者。成于此地无生观故

疏。第二离一切下。忍净中文二。谓离一切心意识分别想。总为离障。疏文中先释离字。后释所离之中心意识。三别为两类分别想字。通其二处故先牒之。一离心者牒经。谓离报心忆想分别。此即以论释经心字。然论具云。报分别境界想。摄受分别境界想。其报分别境界想正释心字。谓第八异熟识下。疏释论。异熟识是报心故。彼七地中修无漏因。感此变易异熟果体。即是报心。言转现遍行亦不行故者。转现二字。即起信论。以第八赖耶有其三细。谓业转现。业相最细。菩萨地尽方能离之。今得此忍转现不行。即见相二分亦不行也。言遍行者。即唯识等论。第八赖耶与心所俱。唯有遍行五耳。谓触作意受想思。今与此忍相应斯亦不行故。疏总云转现遍行亦不行故。而云亦者如入灭定前七不行。第八持身今八二分亦复不行。显转深也。即是经中离心分别想

疏。二离意识者。牒经二字。离方便心忆想分别者。是疏取论意释经意。为第七识即前六。此之意识是异熟生但名方便。论云下以论证上方便之义。言摄受分别性想者。第七内摄受六识外分别。此等王所居然不行。谓六七下。疏释论意及与经意。谓六七识即是心王。及中心所者。六七二识所摄心所一切不行。故结云心行处灭。不同七地。犹有观求之心也

疏。后无所取着下。释能治中。疏文有三初结前生后。二彰立所以。三别释文相。今初先正明。故论云下以论为证。此之论文亦是拣滥。上云灭一切心意识分别想。但是灭障法想障。法想者。即有分别观解之想。有治想者。即无分别智。是则别境。五中慧所不泯。但无分别。上言不行耳

疏。所以明此下。第二彰立有治想所以。一拣凡小。此是拣劣。外道无想无有此慧。二乘灭定亦无此慧。想受尽灭故。故此比于灭定彼所行者。此亦不行。如前一切心等彼所无者。此中则有。谓无分别智。二拣如来。即拣胜未忘无分别智故。故璎珞云。等觉照寂妙觉寂照。今八地无生亦照寂故。若得寂照即同佛故。是故智障有其三门。一是智障。所谓分别有无之心。二是体障。谓观非有非无之解立已能知。故曰体障。三是治想谓妄识中含如正慧。依此地中有其三义。初一四地乃至七地。断除四五六地。断除分别取有之心。谓解法慢身净慢等。入七地时断除分别取有无之心。八地已上断除体障。前第七地虽除分别有无之心。犹见己心以为能观。如为所观。其所观如不即心。能观之心不即如。心如别故心外求法故。有功用法外立心故有体障。从第七地入八地时。破舍此障观察如外由来无心。心外无如如外无心。心不异如心外无如。如不异心故。能如心泯同法界。广大不动以不异故。自外推求故。舍功用不复如外建立神智故。灭体障。体障灭故名无障想。第三治想至佛方灭。故入八地。虽无障想而有治想。从八地已上。无生忍体转转寂灭。令彼治想运运自亡。至佛乃穷。今此未尽故说非无

疏。故云此想于下。地下第三别释文相。然总将此论释有治义下释三胜。一无功自然行故者。即是论文。谓无取果心者。疏释经文。任性自进是疏释论观心纯熟不假作意。任运趣果名任性自进。无取自进故名为妙。二空遍一切故名治广。显无生智无不遍矣。三者入如而行故深

疏。此则入于下。以起信意总收上义。起信所入即是本觉故。论云。所言觉者。谓心体离念离念相者。等虚空界无所不遍。法界一相即是如来平等法身。依此法身说名本觉。释曰。今入虚空即入法身本觉也。下引论会释结成无生法忍之止观耳。第三得胜行

疏。余七别下疏文有二。先随文释。后总收束治障。今初七中一明七地不知。故云正是对下彰出。二即就胜彰等。等于得八地人。三正示胜相故云分齐殊绝即分齐境也。故下总束三句为境分殊绝

疏。护此地一切所治障想者。护防也舍也。此是论主别释此句拣于上二。恐有问言。但离相想于义已足。何须更离一切执着故。今通云。以上相想言通善恶。今明除所治障想。谓贪求佛法故。论经云离一切贪着非除能治无分别智想以此治想为能护故。如上净忍分中无所取着也。四即二利行体。五即寄对显胜。不可形夺退其胜相云不退也。故合上二句为正行广大。六离功用之动。七有报行之治故。合以为离障寂静。今经但言寂灭现前。论经云一切寂静而现前故。真如一切寂静现前故。释曰。上句教道寂静。下句证道寂静故。疏云以证真如为能治故。一切寂静。其一切言即舍教也

疏。上七别中下。第二收束治障。束七为三。初有三句。二三皆二句故。言四种恼患者。第一有行有间发过。第二净地勤方便过。第三化生勤方便过。第四微细想行过。此之四过。从细至粗。经中说治从粗至细故。下喻中从细至粗

疏。离第四微细想行过者。此最粗也。求如来智慧既未休息。即是恼患。今相想斯绝故无此患

疏。三化生过。言十无量等者。既求十对化众生业名勤方便。今自无分量利他无边。离于有无二边故无此过

疏。后二离障寂灭。离前二过者。此第三节一离第二过

疏。引上二文皆是勤方便。一即前彼障对治中。修无功用行。无功用行即牒前科文。日夜常修即是牒前论经。若今经云。佛子此菩萨以深智慧如是观察常勤修习方便智慧。释曰。常勤修习即日夜常修。二及行住坐卧皆起道等。即引第三双行胜中。二行双无间文。言无有一念休息废舍。行住坐卧乃至睡梦未曾暂与盖障相应。释曰。既修无功即是净地勤方便。未能任运无功。故成其过。一念止观双行亦未息行心。故皆成过

疏。二离第一有行有间发过者。此第三节复离此过。若远公云。谓七地中十方便慧发起胜行。无功用心名为有行有间发。释曰。发即发起。若以十方便为有行。此行最粗。又无功用心即净地勤方便。则似义重。今治即前信胜及作大义。皆有行发起而言有间者。约修无功用未得任运无功用。则有功用之间耳。又上通说第三。二句通离二过。亦得离障离有行有间发过。寂静离净地勤方便过。以离过寂静返覆相成故合为一。双治二过第二喻中灭定之义前地已说。法界品更明。言能依心所忆想自亡者。以论云无彼依止故为此释

疏。合中下合文分三。一正合经文。二结成离过。三别释舍一切功用行者牒经。过所治故者。即论释。谓所治者。即七地中功用之心得无功用法者牒经。得彼对治法者论释。以有八地无功用无分别智为能治故。身口意等息者牒经。以得无功用法自然行者论释。以自然行不作意故。云身口等息。非谓不行行故。云自然行也。如船乘风入海。但见不施功非船不进故

疏。引净忍分中无所取着以为证成故。前论云非无治法

疏。离第一下二结成离过。即结上合意

疏。住于报行下三别释能治。此牒经下疏释。前意明教道者。无功无分别智可寄言故。后约证道正证真如故。证道有五。一举论。二此约下引例案定。三即离下明所离过。四报行者下释经报行。五住真如下重释论文。而有二意。一虽举赖耶但取真如。以第八地舍赖耶名故。故唯识云阿罗汉位舍。释曰。大乘第八地同于罗汉。以舍分段出三界故。二又佛地下。存其赖耶则显译论不善用名。以第八识有其多名故。赖耶但是局凡位故。异熟直至菩萨地尽。虽同第八不应存赖耶名耳。第八名别已见上文

疏。第二梦寤喻中文五。一举前所喻。二显喻意。三释喻相。四释合文。五会通喻合。二论云下显喻意。意明护过。所护过意大意是同。谓护彼过想。同前舍一切功用行。有正智想同前得无功用法。三如从梦下。释显喻相。即喻前意。虽无梦想。喻护彼过想。非无寤想。喻有正智想。从但此行寂灭故云所作皆息者。通妨。妨云。若有正智何以文云所作皆息。答意可知。四合中勇猛下。释合但显护过。化生勤方便不行耳。以内证释二行不行。如觉无二岸。以外缘释相行不行。如觉无人船。船即化生圣道。余略不合者。具即以菩萨合前有人。谓七地菩萨至不动地令觉寤也。五合中见人下会通。喻合可知

疏。第三生梵天喻中分五。一举所喻。略不释喻。二合中下释合文。即经住不动下文三。所以不行下。论释不行所以。明有治故。经文略无。四此离下明离过患。五后此菩萨下别释。此菩萨下举胜。下经谓佛等不顺行者。以论云此中顺行不顺行二分心等佛等不行故。谓一心中分染净二分。以净况染。从则若世下

疏。束成对略有四对。兼于大小则有五对。若世者即经况复起于世间之心。若出世者。佛等心也。若人即佛菩萨。若法即菩提涅槃。若因即菩萨。若果即佛。若智即菩提。若断即涅槃。小虽经无。对菩萨有论文具之。论云。佛等不行不行故。大乘小乘差别故。大乘小乘中众生法差别故。众生是人无学学差别。佛等涅槃差别。应知。是中顺行者。顺行分中心等不行故。如经一切心意识不行故。是中不顺行者。不顺行分中佛等不行故。如轻佛心乃至涅槃心不行故。大乘小乘差别。大乘中差别者。佛菩萨涅槃差别故。小乘中差别者。声闻涅槃阿罗汉等差别故。大乘中众生差别者。佛菩萨差别故。法差别者。菩提涅槃差别故。小乘中无学学众差别。是中法差别者。涅槃差别。无学差别者。阿罗汉差别。有学差别者。阿那含等差别。如是等。皆悉不行故释曰恐欲知论。故复委出。亦不出于上之五对。然论差别之言。一一事中皆有差别。如有学中有三果四向等菩提。有多种菩提等。非全所要故。疏略之就出世中遍多举者。出世易着今无著故。第二发起胜行

疏。回文未尽。应言住本愿力者。谓安住本愿利众生故。得诸佛劝。远公案论释云。本愿住三门分别。一解本愿。从前七地来。同求此地无生忍故。亦为本愿。二释住义。三说住之意。二中得已心息。更无去意故名为住。然住不住略有四种。一观入分别。始时不住终则乐住。从前地来求趣无生。以未得故。所以不住。今此得之乐着故住。二起用分别。始得乐住终则不住。今此始得乐寂故住。以佛劝起所以不住。三就寂分别。始终常住。谓佛菩萨随所证入无暂舍故。四就用分别。诸佛菩萨一切不住。常就世间利众生故。今言住者约前二门。第三说住之意有二。一显此地所得深寂难舍故。二明诸佛劝说所以。释曰。上远公之意顺论解释非不有由。今以此经本愿力故。明其本愿是劝之由。以此释论。应言住本愿也。住忍须劝是下劝益中辨。又由经住故。劝意则有故。疏释云。决彼无生止水。令起无功用行。无生止水即住忍义。若将本愿力住。为住忍者。非经论意

疏。下之七劝下。通妨难。乃有四重。一有妨云。下之七劝义相不同。何以此中但云与智故。此通云。七不出智。二前地未净下。问云。佛慈平等何以偏与此地菩萨。通意可知。三以得此下。复有问言。何以要得此忍。即与智明。答意可知。四一与下复应问言。九十已得何不与耶。得已不失故不重与

疏。于中有七者。七劝如文亦有总名。一自德未成劝。二生愿未满劝。三本愿未充劝。四自德未胜劝。五化业广大劝。六自己所得法门未穷劝。七少作能成增进众德劝。疏文有四。一列七名。二远公下叙古释。三经无下辨违顺。四今摄下申正释

疏。然七皆含转住增去者。正拣远公。前六转住后一增去。如初愿中。勿复放舍即是转住。令勤精进岂非增去。余可思准。远公亦摄前六为三对。二利初对。一自利未满。二所化未出。第二对三所化未满。四自德未胜。第三对五化业未胜。六己德未穷。亦是一理。初劝可知。第二劝中出家多起觉观等者。皆是论意。意云。出家断除烦恼不与之俱。为断此故未善方便。故多觉观。或起恶觉乃至不忘善觉。故言悲心。悲心依上而转者释论。以论初云依彼众生无大利益事。现起烦恼。使彼在家出家分中深着烦恼众生转故。故是大悲依彼转也。第三劝可知。第四劝中初言定其所尚者。所尚即无生法忍。所忍即诸法实性故。三地中詺八地为一切法如实觉。法性即实相真如理无废兴。故云出世不出不异。言以有深无碍智者。即下偈云。法性真常离心念。二乘于此亦能得。不以此故为世尊。但以甚深无碍智。意云甚深无碍智为世尊耳。对下同于二乘故。此不共。言抑同二乘者。此一乘旨二乘绝分。非是共理。约寄位中劝其莫作故。抑令同下。三兽度河亦是抑耳。河即是通理。如身子自领解云我等同入法性故。功行疲倦者。此下是论意。斯则三乘皆功行疲。欲趣于寂是菩萨垢故。论云。依不共义功行疲倦。彼垢转故。谓依转进。五六七劝并显可知。但七云三自在行者。即三世间自在耳

疏。问始行之流下。此下问答。通对不劝之失。劝益为问。先兴二问下具二答。先以四义。答须劝。答初问可知。后但有此深奥下。答第二有无问。今此答云。定有佛劝无有无劝。此自有三。一正明无有无劝。而趣寂者。二又设下假设以明。三为显下。结上不劝之损言耳

疏。论云。彼行中摄功德因胜者。彼行即无生忍行。由有忍行故佛与智。此二皆因。此因皆胜故能摄德。正以与智而能摄德故

疏。论但以与智为因转推。得智之因复由得忍

疏。十中一多身随现下。上通相料拣。此下随句别释。释此初句。疏文有四。一标举即是经中今住。此地得无量身。二所以多下。举论释多所以。信解即是胜解。胜解印持一切菩萨即是我身故有多身。三谓智契下。释上信解。为一所以。前来诸地虽有信解未与理冥。今与理冥故成多身耳。四此实报下。释通妨难。难云。前之初地百身。二地千身。如是渐增乃至七地。有百千亿那由他身。何得言一。故今答云。彼前多身皆云示现。即变化为非实报得。以前七地功用分别未舍离故。不能合法。凡所为作名心自在。非法自在。是故不得就法说多。此地功用分别心息契合法界。凡所为作名法自在。以法门无量随法论身。身亦无量举身既尔。余可例知

疏。此一对前下。释其余句余并可知。疏。大文第四净土分中。先问答显意。初问后答。答中二。先开二门。后今约下拣定。既约位释成。始起于此故偏有净土分也

疏。智所行境者。即世界成坏能观智。即下如实知。此总科。方便善巧下别牒释。言即无功用因者。由于七地得空中方便慧。有中殊胜行。修此无功故

疏。初知四大差别即是广相者。谓知大分齐

疏。小相者下。散心所知少故名小。定心所知广故名大。初禅量等四洲。二禅量等小千。三等中千。四等大千。故云乃至量既遍等故。能遍缘无量相者。佛智称事理之实。故无分量差别相者。是法分齐者。若言大小即是分齐。知地坚相水湿相等。名知自相。同无常等名知共相。二相皆是法分齐也

疏。细者透金尘故者。俱舍云。极微微金水。兔羊牛隙尘。虮虱麦指节。后后增七倍。隙尘乃尘中最粗。无一极微独处而住故不说初而七极微为一微尘。此亦最细而名是通故。取第三透金之尘以为细也。言一尘之中含多法者。能造所造一聚而现。必具坚湿暖动色香味触。故云多法

疏。斯即楞伽责所不间者。谓大慧菩萨发一百八问云。我名为大慧。通达于大乘。今以百八义仰咨尊。中上下问云云何净其念。云何念念增长等。列问竟。佛赞善。牒问竟然后责其所问不尽。云诸须弥山地巨海日月量下中上众生身各几微尘一一刹几尘弓弓数有几肘步拘楼舍半由旬由旬乃至云是等所应谓何须问余事。声闻辟支佛佛及最胜子身各有几数何故不问此。释曰。此即责所不问也

疏。佛法中凡境为小者。问无色无色无有分量。何有大小。答大乘之中许有色故。离世间品明。菩萨鼻根闻无色界宫殿香故。此有二意。一无粗有细。二无其相色有通果色故

疏。以身不必同其所化者。如有居士欲见佛身。为现佛身。佛身不同居士。而随其心乐名心同事

疏。今就行体者。以智正觉一切法故

疏。经略烦恼故论具之者。论云。是中众生世间器世间。彼二生因业烦恼是染分故

疏。谓因法智殊显三乘别者。智法有殊故三乘异。亦以三乘明法智故。二皆是净。言义兼理空者。无量周遍等皆兼于理。亦由此故为二所依。疏云。何法智虚空得为自身者。此假问也。法中理法理法无形。智体虚空皆无形质。不可作身云何言作答。意云。智证于法自然应现。即是作义。亦犹体理成智理寂。无相而成有知故。令于虚空下。通虚空作自。此三作自既尔。自作此三亦然。冥同理智及虚空故

疏。所以相作下。出其所因。以经文中但云随众生心之所乐故。则唯是业用门而无德相故。具出所以例前可知。则经文中但有第二义。第一义略无。第二引晋经文证者。第二因缘和合是缘起故。上显相作之因。论主但明相作之意。然随众生乐通因通意。意欲摄生故是意也。就随意能作即业用因

疏。若总开三界五趣则具十者。色身兼欲色二界。加无色为三界。集业烦恼为二。报身即五趣报故为十也

疏。又重重现下。双释普入及方网言。尘能受刹刹以尘成。亦能受刹重重皆入。名为普入。既交络入。九方入东东入西时。带余九入。西入南时带东诸方。而入于南。故成重重。即初地中如帝网差别故。为真实义故

疏。四自身舍利住持故者。舍利梵言。此翻名身。若云舍利罗。此云身骨。论经名受神力身。此身是佛摄受众生。留化神力故。出现品中医王延寿喻。正喻力持身也

疏。六所有光明等者。论经名光明身故。远公云。善软众生慈光摄取刚强众生。威光伏取故云摄伏

疏。九法身者。所有如来无漏界故者。即是论文。同于唯识转依之果。论云。此即无漏界。不思议善常。安乐解脱身。大牟尼名法。论曰。前修习位所得转依。应知即是究竟位摄。此谓此前二转依果。即是究竟无漏界摄。诸漏永尽非漏随增性净圆明故。名无漏界。是藏义。此中含容无边稀有大功德法。或是因义。能生五乘世出世间利乐事故。释曰。此即释其初句。今疏所用诸漏永尽者。此即离彼相应缚义。非漏随增者。此即显离所缘缚义。性净拣异二乘无学。有所知障不名净故。圆明拣彼十地菩萨。未圆满故。具此诸义名无漏界。余义可知。释第二句。论云。此转依果。又不思议超过寻思言议道故。微妙甚深自内证故。非诸世间喻所喻故。此又是善白法性故。清净法界远离生灭。极安隐故。四智心品妙用无方。极巧便故。二种皆有顺益相故。违不善故。俱说为善。此又是常无尽期故。清净法界无生无灭。无变易故说为常。四智心品所依常故。无断尽故。亦说为常非自性常。释第三句云。此又安乐无逼恼故。清净法界众相寂静。故名安乐。四智心品永离恼害。故名安乐。此二自性皆无逼恼。及能安乐一切有情故。二转依俱名安乐。二乘所得二转依果。唯是远离烦恼障种。无殊胜法故但名解脱身。大觉世尊成就无上寂静法。故名大牟尼。此牟尼尊所得二果。永离二障亦名法身。无量无边力无畏等大功德法所庄严故。体依聚义故得名身。故此法身五法为性。非净法界独名法身。二转依果皆此摄故。释曰。今此疏中正用初句义。则包含正取所证能证四智智身摄故。彼处通说菩提涅槃二种果故。四智之义。频见上文。言此通四身者。智冥于理同法性身。大圆镜智相应净识能顿现于自受用身平等性智现他受用身。成所作智起变化身。是则智身通于四也。又妙观察智亦通四身。通观四故

疏。但两重下通非圆宗难可知

疏。六智身中果唯证入相离前三者。此明智身了于法界。有达证二义不同。今就果说故唯证知。言相离前三者。离闻思修相。如初地示说分齐中说。然此通约因果而说。若分三乘。小乘四果为果。趣四果因为行。中乘无学为果。有学为行。无数出入故无四果。大乘之中佛果为果。余皆为行

疏。小乘十智等者。则法类四谛他心世俗及尽无生。前已曾解。中乘七十七者。广如六地钞中。共不共义前已频释。后二通于三乘修成分别者。即学无学。前行果中中乘虽约学无学明意在行果。小乘学中。亦有果故。大乘位位容有果故。故疏上来但约总说。又此学等略有三门。一约理。三乘同学未证名学。证竟无学凡夫非学非无学。二以小望大。二乘于大亦非学非无学。三就修成之德义同初门。今就智明

疏。云修成分别耳

疏。七知法身中文二。先通拣滥谓第六智身及此法身。对上如来身。上十身中智身法身以料拣耳。后文有五下。别释一法身者。前佛中取法。此法中取佛为门各异也。拣理异事下遮难。难云。若是平等法身应名第一义智所知故。为此答第一义智无分别故。亦犹相见道中。观非安立谛。而是后得智摄

疏。四即重显理法所遍之境者。即经云。众生非众生法差别相论但云有根无根差别相。故有根身即众生有根身故。无根即非情。今以四法收法无遗。谓教理行果。理是所诠乃通事理。初句明理。此句即事。理外无事故。言所遍之境。此通染净等。皆悉平等则显前之法身是净法。法身故。前释云法门虽殊同诠平等

疏。论云第一相者。有二义。疏是一义。更云三宝最胜故。言随智有异三种不同者。即一切贤圣皆以无为法而有差别。大品云。由平等故分别须菩提等故。所显理亦说浅深者。小乘人空如兔之足。中乘修习如马之足。大乘二空深彻底故。若约功德等异者。小乘三生缘觉百劫。菩萨三祇乃至三学万行。差别非一。皆以一相统之。则四法一揆

疏。三不可见者释无形相世人见者。但见空一显色者。杂集第一云。云何建立色蕴。谓诸所有色。若四大种。若四大种所造色者。谓眼等五根色声香味触所摄一分。及法处所摄色。次释色云。色者谓四大种所造眼根所了义。谓青黄赤白长短方圆粗细高下若正不正。光影明暗烟云尘雾迥色表色空一显色。此复三种。谓妙不妙俱相违色。此青等二十五色建立。由六种因。谓相故。安立故。损益故。作所依故。作相故。庄严故。如其次第。四十八云迥色者。谓离余碍触方所可得。空一显色者。谓上所见青等显色。释曰。若智论说上空。谓作青白彯色见故。又依小乘毗昙宗。空有二种。一是有为。除色为空。二是无为。本来常无有为可见故。今世人同共见之。无为不可见故。今说言不可见相。成实论中虚空唯一不可眼见。世人见者。但见空中光明之色。想心于中知无实物。作虚空解。便谓见空。其实不见。涅槃经中同成实说。广破虚空有为可见。今此经疏符不可见

疏。六能通受色相此即论文。释经显现色身相。疏文可知。而论经云显色身别异相。意云。能显于色而与色异。上言无异自约空体耳。若远公云。谓因色像空有差别。谓屋内空屋外空等。此乃以色显空。不顺今经空能显色。第五自在分。释曰。此中通有四门。一辨相。二治障。三出因。四得位文皆已具

疏。此但约智通说者。对下六度但明一智。为通远公别配。修前器世间自在行故。得财自在。一切世界庄严之事。悉能示现。修前众生世间自在行故。得生自在随化众生。处处现生。修前智正觉世间自在行故。得六自在。一得命自在。证第一义成法身故。欲久近住随意悉能。二得心自在知二谛故。能入无量三昧法门。三得业自在。于报身中得自在故。一切业报随意示现。四得信解自在。知如来身。及知声闻缘觉菩萨故。信生信解。五得法自在知法身故。六得智自在。知智身故。通修前三故。得二自在。一得愿自在。一切所欲随心皆得。二得如意自在。于三种中随意转故。释曰。虽有此释乃成穿凿故

疏。但云约智通说。别配依下取于摄论六度为因

疏。二得命下疏文有三。一别释经文。即辨相及因。经但标名。今依论经一一具释。经有难见。即以论释。兼以摄论六度之因次第配释。二于此十中下。通释自在。三论以下明其所治。于中先举论。后此十亦即下。会五怖畏。三约因。此地下会通行位可知

大方广佛华严经随疏演义钞卷第六十九大方广佛华严经随疏演义钞卷第七十

        唐清凉山大华严寺沙门澄观述

第六大胜分

疏。一入自在者。即经云如是入已牒前十自在也。二成就智。即经云如是成就已。即牒前为不思议智者等

疏。故经云随行智为导首故者。经文但有身语意业随智慧行。论经云智慧为首随顺转故

疏。具用二句之意。以智先导释其随行。初智导起起已不失于智即是随行故

疏。二中十句依七种功德。谓依此七种功德。宣说彼所住功德法故。此段名所住功德大也

疏。后二慈悲利他者。余处慈能与乐悲能拔苦。今悲不舍众生。慈却救护世间。以慈悲皆通与乐拔苦故。言后三愿行相符等者。愿即第八。行即第九。佛护即第十。第七释名分

疏。一地释名。约法明位者。广明此地有不动德故。二约人者。广明住此地菩萨有不动德故。法即本有此德如于菩提。人由得地故成胜德。犹如觉者。今初十句论摄为六者。初二四六皆摄二故。疏文有三。一总科。二依论释。三顺经释。今初。初二自分。前一离过毕竟。后一所证深玄。余句可知

疏。言为六下二依论释。初染治中功用。小愿魔业。皆是业染。第七地功用之心。名功用行。第六地中乐空之心名小乘愿。前五地中著有之心。名诸魔业。亦可。七地中所起行修。名功用行。二乘之心名小乘愿。凡夫之心名诸魔业。今离功用治功用行。远离有无间隔过故。治小愿魔业故名不动。此一为总。故诸经论皆立此名。疏三有二句发行清净者。即胜进中发修离过。前句发修之时离功用过。名为发净。后句修行之时。离不成过。名为行净。随意成故。论经名王子者。经云。名为王子地离家过故。远公释云。如世王子生在王家。无有营农等过。菩萨如是。生在佛家无有修行功用之过。释曰。观经之意但取离过

疏。四次二句下。兼第五门。即胜进中因修成德。德义不同有其二种。一者有作。即教道功德。本无今有方便修起。故名有作。即第四门。二者无作。即证道功德本有今显。非从修起名为无作。即第五门。与加分中有作善法净无作法净相似。今明第四中功德名世间。智慧名出世间。前中随世有作释经名为成地。自无所作。释经更无所作故。下句中以智慧善分别故。即是论经。智障净故是论释。上善分别言皆决定义。疏将彼经及论。皆就今经决定之言

疏。五有一句下。即证道也。即经名为变化地。随愿成就故。今经但有其用。论经云名为涅槃地。善起大愿故。远公云。涅槃地者即无作体。体寂灭故。善起大愿故者。即无作之用。以用显体。非小涅槃故

疏。释云。化不滞寂成无住涅槃

疏。六有二句分位过前者。即远公依德成位。上句可知。下句胜七地有功用。此地报熟名无功用。言先已成就者。论经云善起先道故。远公就诸地中分别有三。一不起先道。谓前六地当地别习不兼前行。二起而不善。谓七地念念修起一切佛法。前六地中所有诸行。至此皆起。而功用心起不名为善。三亦起亦善。谓此八地前七地中所修诸行。是其先道。至此地中报熟现前。名起先道。报熟现前非功用生。故名善起。疏意顺经先已成就即是七地之中修无功用。为先已成就。故今无功。此意是总。易故不释。疏今更指文者。第三顺经释。但是指文义不异论故。疏云则似论家阙指明据。疏智者释名中。一向不动是胜进行也。一体不动是自分行。先明胜进者。举彼胜求显于自分从上满也

疏。今初文有四句皆含二义者。谓一向一体。以远公将此总属于一向不动则此四句明一向义。后十方明不动故。疏案定云皆含二义。谓由入佛境故。一向上顺亦与菩萨同一体性。下三句准之。以论先释四句竟。方云是中一向不动者。如经日夜常为善识加诸佛加等故。疏将此四句为总。三者近者由其前二故近佛也

疏。谓金刚等现形卫故者。此前七地亦有但冥卫耳。如来常有八金刚神列其八面。此地菩萨随分得之。前三自分者。即三轮也。谓身口意。疏论云一向不动故者。论释结文如是通达。如是通达故一向不动义耳。疏一智不坏者。论经云善思量大乘道故。即是证智法智通者。以论会经既云智大。经云获大神通明是法智通也。即十通第九。于六通中漏尽开出故。亦证智。二教智三不住。上三自利下六利他。初句净土行。后五化法益物于中前三自分即意身口。称三际说者。先际生死后际涅槃。中际圣贤也。后二胜进。坐道场称佛方便成正觉者。成佛度人前中泛明坐道场。略有三说。一就法门即万行道场。二就实成约金刚三昧一念成佛。三约化相菩提树下。今正约后。然经但言普伏一切魔邪之道。而论云坐道场。坐道场即降魔故。伏魔亦三。一约法门。一切生死涅槃皆是魔道。修一切智则伏其道矣。二约实说。无明习气以为魔道。金刚喻定方能摧之。三约化相。菩萨树下降于天魔。今亦据后

疏。九正觉不坏者。上入佛境同佛觉故。即是一切法如实觉故同无障碍智。余如初地中说。第九善慧地

疏。言善慧下。二释名。总有九释。一摄论当第七论。从即下文下

疏。会经二庄严论。即第十三颂云。四辩智力巧。善说称善慧。今疏即是彼论长行。此同下文即疏会经。三金光明。即第三卷。从此兼下疏会释。四深密意者即第四卷。经云获得广大无碍智慧。五瑜伽住品。即四十八论。上文来意亦同此卷。论云。由此地中。一切有情利益安乐意乐清净。逮得菩萨无碍解慧。由此善能宣说正法。是故此地名为善慧。六十住论亦当第一。论云其慧转明调柔增上故。七成唯识亦当第九。论云。成就微妙四无碍解。能遍十方善说法故。从文词下。会上三论。八仁王下亦即下卷。九智论可知。疏故所离下。第三离障亦唯识文。具云九利他中不欲行障。谓所知障中俱生一分。令于利乐有情事中。不欲勤行。乐修己利。彼障九地。四无碍解。入九地时便能永断。由斯九地说断二愚及粗重。一于无量所说法无量名句字。后后慧辨陀罗尼自在愚(此总标也论自释云)于无量所说法陀罗尼自在者。谓义无碍解即于所诠总持自在。于一义中现一切义故(一也)于无量名句字陀罗尼自在者。谓法无碍解即于能诠总持自在。于一名句字中现一切名句字故(二也)于后后慧辨陀罗尼自在者。谓词无碍解。于言音展转训释总持自在。于一音声中现一切音声故。二辩才自在愚。辩才自在者。谓辩无碍解善达机宜巧为说故。愚能障此四种自在。皆是此中第九障摄。释曰。此用能障无碍解所知障种以为体性。以八地已上六识中所知障无现行故。金光明亦云。一说无量名句味。无量智慧不能持无明。二四无碍辨未得自在无明。释曰。此则第二愚。亦许通四。但上能持。此约能说即说上三耳。梁论云。一无量所说法无量名句味。难善巧言自在陀罗尼无明。二于四无碍解决疑生解无明。释曰。第二愚亦通四无碍解。本论名离不能利众生障。释曰。唯识不欲此论不能。不能故不欲耳。疏但撮略以对论文广狭可知。互相映发

疏。论俱易疏故所证下。四所证如亦唯识文。摄论名同。无性释云。谓此地中得无碍解所依止故。分证得智波罗蜜多于一切法不随其言。善能了知诸意趣义。如实成就一切有情受胜法乐。释曰。无碍解等释自在义。分证得等释于智义。中边论云。有四自在。一无分别自在(即相自在)二净土自在。三智自在。四业自在。法界为此四种所依止义。第八地唯能通达初二自在所依止义。后二如次在后二地

疏。便成善达下。第五成行庄严。论云四辩自在成熟众生(即此经自在说法)无边总持广受法行(即此经善达法器)

疏。梁论云下第六得果。初即成熟众生果。后即总持法义果

疏。如月普现前地有故者。偈云。譬如日月住虚空一切水中。皆现影。住于法界无所动。随心现影亦复然。从此法师下。即九地之德。下文广具

疏。第二正说文三。一总科。二四中初一下。会三心。三然第八地中下。显地别相。此是论文亦是通难。恐有难云。第八地中于三世间已得自在。普与众生身心同事。复能多身多音说法利乐众生。何以此地方名法师。有说。成等故为此通。从成就一切相下。辨胜过劣

疏。前得二谛等智故者。二谛即是净土分中。等者。等取诸佛劝起无量智慧。思量观察即是思修。若准论经云无量智慧善思量智。远公云。广谓无量。深曰善思量。上佛劝与无量智即是广也。净忍即是深智。然不出二谛故。疏但以二谛等之

疏。初句利他等者。此依论主有两对二利。疏意更有二意。一为三节以合初二为自利故。二者十句皆通二利。然远公云自分所成以用化人。胜进所成未堪化人。业未熟故但可自利。疏意云。更求胜进岂无利他

疏。三依根熟下。五门利他。言根熟者。阿含行成堪能入证。绝念修行可利生故。四不观智性尽为邪念。五未知令知。六邪归依者。即诸外道取信耳目故。以通化。七诸佛净土超过诸天。无退转故。上五下结上。以利他竟故。后三易知。第二智成疏不二即无记者。不同前二。故云不二。净即是善顺理清升故。染即不善违理杂秽故。疏。于净法中开漏无漏者。俱舍云。有漏无漏法。除道余有漏。于彼漏随增。故说名有漏。四谛之中苦集二谛是有漏法。漏即烦恼漏过无穷故。漏法于彼苦集随增。苦集有彼漏故名为有漏。论云。无漏谓道谛及三种无为。由其道谛是有为无漏故于有漏除于道谛。今疏中云与漏相应即漏随增义。言施戒等取相心修者。以于善中开出漏故。举其施等。等取忍进禅慧。今漏于彼施等善法而随增故。相心修善是集谛摄三界因故。言无漏反此者。即离相心修漏不随增。即属道谛。俱舍云缘灭道谛。诸漏虽生而不随增。故非有漏。约于见道分世出世。前来频有思不思议。乃有二意。前约圆融行布。地前地上对明。后约教证二道。唯就地上。疏彼有漏思议等者。以思议通二义。今明定能证入。意取地前思议故。兼取有漏之善。言定能证入者。大乘之中。种性坚固。名之为定。为缘所动名为不定。故仁王受持品云。习忍已前行十善菩萨有退有进。譬如轻毛随风东西。是诸菩萨亦复如是。虽以十千劫行十正道。发三菩提心。乃当入习忍位亦常学三伏忍法。而不可定名是不定人是定人者。入生空位圣人性故。必不起五逆十重等。若通诸乘说。小乘忍心已去名定。余必不定。五总上诸善开出三乘者。三乘皆有漏无漏世出世教证二道定不定等。故云皆通

疏。六于三乘下。先举论。后此是下疏释于中二。先辨。次二灭谛下正释。然为无为及漏无漏。如十藏品。世及出世教证二道初地已广。今随三乘略明为无为等。灭谛即是小乘无为小乘四谛三是有为故。缘性即是中乘无为。逆顺观等皆是缘相。缘性离是名无为。彼岸真理大乘无为。大约六度故云彼岸彼岸有二。一是涅槃修六度因。得涅槃果居然无为。二穷行究竟即同无为。又真理言通于三乘。同入二空之真理故。道谛已下三乘有为对前可知。如来无为前已频释

疏。三乘圣人下释上论文依顺行言。然有二意。一依起行。二亦依无为成差别位。第三入行

疏。一众生心者是总故者。疏文有二。先随文释。后释总名。前中此言总别通有三意。一约本末即如今文心为本是总。十林是别。然本末容可知。由一生多总别要一具多。是经宗意。二就末中。三杂染为总。余七是别。此约依本开末。七不离三故。三以三聚为总。根等为别。此约以时该于法故。今初心为总者。论云。依共者。论唯二字。以通为下

疏。释先释共字。共染净共依。但释共字。菩萨依此下。方释依字

疏。余十是别不出三杂染者。即第二重总别义也。言生是苦果今当第九者下。是总释论。然论经今经已前是因。生是苦果。皆当第九。论以三是总故以生居前后。习气三聚俱通因果

疏。论释余七云下。二释余七。于中四。一总释七林。二重释根等。三例释三聚。四会二名殊。今初有三。初句标举。二依共染下举论。三谓次根等下疏释。然上论七林总有四节。一依共字。摄根解性欲四林。二染字即随眠林。三烦恼染净等。即习气林。四依定不定时即三聚林。四节皆合有其依字。初一后一有依。中二略无。以初依字该于中二。若具应云。依共依染依烦恼染净依定不定时也。今释四节文亦有四。初释共字。谓根解性欲同是业故。二随眠即烦恼种下。释染字故。三地中显超烦恼名贪嗔痴。显超随眠名为染也。以常随心令心秽浊无时暂净。故名为染。然论经名使如下当释。三受生即生如前已说者。此非释论。以经次第至于生故。指前总中故。前云不出业烦恼生也。四从余二通三故不出三下释论。第三四节习气三聚二稠林也。于中二上二句总释。言余二通三者。二即是习气。及三聚林通三杂染故。不出者。随眠是烦恼。根等是业。今二复通。故上标云不出三杂染也。疏二云何通下二别释二林。此句微问。后谓习气下。释前论第三云。烦恼染净等是习气林。染摄烦恼故。疏略无烦恼之言。又欲将染净通根解性欲。而言等者。等取生杂染。以三杂染皆有习气故。故下释中。有烦恼习气业习气道差别。习气即是生故。不言心习气者。心是总故为十依故

疏。三聚但是约时定不定故者。释上论第四节。依定不定时是三聚林故。疏论又别释下。第二重释根等相似之义。即重释上依共之言。以言共者。共是于业复相似故。于中四。一生起论文。二彼复定不定时下举论。三由下经文。下彰释所以由相似故。经举根林以例三林。论上云共故。今显共相似之义。四亦须约时下正释论文为四。展转相生皆征上起下。而文分五。一释彼复定不定时云。亦须约时蹑上四义。但云亦须约时。合云根等四林。亦须约时。亦者。释论复字。以前释三聚约时。今重约时故云亦也。二约何论时下第二节征于上句释下根等次第三云何次第下征上第二释下根等相似。四似何等下。征上第三释下信等二字。五如宿习下。显上相似次第之义。唯初根解。此二相望。有于次第及与相似以性欲但明相似之义。次第可知。故略无之。疏若相似未熟下。第三例释三聚。三聚亦由上四生故。是故上云三聚为总。疏论经詺解下。第四会二名殊。可知。疏十皆名稠林下。第二释总名。于中三。初正释稠林。二论经十林下会释二经。三然此下指广辨异。第二依章释。心意及识六种别故者。第八名心。第七名意。前六名识。然有通别。已见问明。今更略释。大乘法师云。心积集义。意思量义。识了别义。积集有二一集行相二集种子。初通诸识。后唯第八。思量有二。一无间觉。二现思量。初通诸识后唯第七。了别有二。一细二粗。细通诸识粗唯前六。疏此八缘境许得齐起者。唯识第七云。依止根本识。五识随缘现。或俱或不俱。如涛波依水。释曰。此有二门。初句六识共依门。下三句六识俱转门。此中正是后门。论云根本识者。阿陀那识。染净诸识生根本故。依止者。谓前六转识以根本识为共亲依。释曰。此释第一句。举阿陀那通至佛果故。若言赖耶位局染故。但言六者。第七识缘恒时具故又此正明六识义故。言为共亲依者。共依即是现行本识。识皆共故。亲依即是彼种子识。各别种故。次释下三句六识俱转门。论云。五识者。谓前五转识种类相似故。总说之。随缘现言显非常起缘。谓作意根境等缘。谓五识身。内依本识。外随作意五根境等众缘和合。方得现前。由此或俱或不俱等。外缘合者有顿渐故。如水涛波随缘多少。此等法喻广说。如经释曰。言种类相似者。一俱依色根故。二同缘色境。三俱缘现在。四俱有间断。言谓作意等即眼具九缘等。经初已说。言广如经者。即解深密云。广慧如大瀑流水。若有一浪生缘现前。唯一浪转。乃至若多浪生缘现前有多浪转。诸识亦尔。然彼更有净明镜喻。恐繁不引

疏。极少犹有遍行五者。即如第八心所俱门。谓唯与触及作意受想思俱。余识心所多少之义广。如彼论。论云住异生灭行者。住释上轻。异释上转。生释于生。灭释不生。疏云何离者。从初至不可得。唯除此句假征。余皆论文。从身者下。疏释言心体离念等者。等取虚空界。法界一相皆无形义。疏取境不同故名为自者。此下疏释八识缘境有同有异。前五转识缘五尘境。是现量故。第六意识缘一切法。通三量故。第七末那缘赖耶为境。是非量故。第八赖耶缘于三境。种子根身器世间故。亦现量摄。广如唯识。疏上之四下结前。言心之空性者。空如来藏故。涅槃云空者。所谓生死故。后四净心随缘者标也。次由第五下总释也。随现烦恼故。有第六随烦恼种故。成第七故。论云第六七心染不染故。心缚解故。此二句烦恼染示现第八。双随业生染故。论云。第八句心随道故生染示现。以随业受生故。云随业生缘。菩萨幻生亦菩萨业

疏。谓第五清净下当句别释。此即自性清净心。对前空性是不空。性是则相。辨真空性为妙有也。不染染等前已频释。疏随因受生者。通释二句。菩萨以下。别释二句。幻所作相同于摩耶大愿智幻耳。第二释烦恼稠林。摄为三种事者。一即远入相。二难知相。三染相。一远入者明分齐。深至于有顶故。四住拣于无始无明。现惑拣种故。弹古云下至金刚自约种说。远公见偈云。禅定境排仍退转。金刚道灭方毕竟。便释有顶云。谓至十地金刚顶故。今弹云。彼颂随眠稠林约俱生种。何得证此

疏。二无边引起者。论云二难知无量善根等修业行故。余如疏释。言恒沙等上烦恼者。以善无边一一善上皆有烦恼故。亦即所知未尽。则无法之上而无惑也

疏。三俱生下先总释。后初三句下别释三段。就此三中。初句既总。即能所缚。即二为能缚。三即所缚妄心。今初论自释随所缚。云迭共同事。迭共相依。不相离故。今疏取意开展释之。以论同事释经俱生。言生即是事者。然有二义。一夫言俱生必有二物。烦恼是一与何物俱。即妄心事同时生也。二生即生杂染。则烦恼与生事俱也。从然离惑下。以论相依释经不舍。疏二眠起一义者。别明能缚。如世缚贼。为用绳耶为用锁等。云以何缚。从谓使为能缚下。出能缚体。从现行由使下。释其缚义。烦恼缚心使缚烦恼。如毛绳缚人。由入水故令绳缚急。然下辨使等者。通相滥妨。此中使同下使故。答意云。此约使为惑因。后正显使故不滥也。远公云。使有二义。一系缚义。通性及起。二随逐义。局在性成。今约系缚亦是一理。而下随眠亦有系缚。故但依疏。疏三与心相应下。即别举所缚。然虽别显能缚所缚而必互有。如绳缚人。若言以何物缚。是单说能。而必有所缚之人。不尔者何得缚名。如说何人被缚必有能缚之物。故下二句各兼能所。而二正取能。三正取所。思之。疏事即真心者。出所缚体。即自性清净心。若被下即被缚相。因无明风动不守自性。成其染心也。染而不染云心性净。言示可解脱者。若定是染则不可脱故。中论云。集若有定性。先来所未断。于今云何断。疏二随趣下。谓就生杂染中明于烦恼。先举论总释。从苦报下释论。从上句下。以经对论道界因。道界因言彰惑之过

疏。三爱见下先总明。初句下别释。释初句中先牒论。言三分下疏释。三即爱见痴是业之因。疏文委具。而文有四节。一以二求释三分业。二慢通上三下。会通经论。经有四惑。论但说三故。又三求中唯说二故。通意可知。三上三俱障下。以论障解脱言。释经如箭深入过患。四亦可知下。疏别立理。疏下句下释三业因缘不断相。疏结中八万至贤劫经中亦有其相者。然随好品正明烦恼。贤劫自说八万度门。而取所治亦是烦恼。故复引之。此经具名贤劫定意经。有十三卷。第二卷末有喜王菩萨。宴坐七日。过七日已诣佛咨请。行何三昧能悉通达八万四千诸度法门。佛告喜王。有三昧门名了诸法本。行菩萨行时。便能通达诸度法门。诸度法门者。诸佛有三百五十功德。一一功德各修六度为因。然彼第二卷末。喜王菩萨起请。如来初列章门。第三卷初。喜王再请。一一解释。至第九卷经方终其三百五十度中。最初名修习进行法修度无极。其度无极言。即波罗蜜义。乃是三百五十之总名。其光耀度乃当第二。其分布舍利是最后度。其间诸相随好力无所畏十八不共三十七品。五眼六通等皆是所成。即以六度为二千一百。其一一各有六度。随事各各不同。而初言二千一百竟。即云是二千一百。其中别有一百度无极主。除四大六衰令无有余。独步三界。亦可。将此都成前度。言如是二千一百诸度无极。及是百度无极。是二千一百诸度无极。贪欲恚痴等分四事。二千一百合八千四百。各有十事合八万四千。不言十事是前四大六衰。及至第九经总释竟。即云是八千四百。一度为十。合八万四千诸度无极亦不言十。对四大六衰。次云此八万四千诸度。除八万四千众垢尘劳。遂成八万四千三昧门。立八万四千空行。设以义取。应以四大六衰成八千四百。而人以四大六衰成二千一百。似非经意。又此皆是菩萨所修之法。亦非如来一代经如是多度多会说法。下诸卷广说千佛名及因缘。然不说四大六衰之相。第十三卷末云三毒五阴十二牵连四大六衰诸蔽睡眠。则义当四大六尘。六尘衰损善法故。经中但言一度为十。经既不释。今以义推。乃有二义。一如古释四大六衰成之。二义推。如一施度下经具十。余五亦然。则八千四百。既一一具十。斯理无失。亦有云。四大者贪嗔嫉妒及众生想。此能障四无量故。六衰者。悭嫉放逸不忍懈怠散乱愚痴。能障六种波罗蜜故。此乃理求未有所出。难以取凭。又经中既云于其一百对四大六衰。若如向说。则尽对四大六衰。又有云。若依大乘菩萨藏说。贪嗔邪见及慢为四种。各二万一千。有唯贪香味触法色不贪声等。有唯贪声不贪色等。有俱贪香味触法。当知亦尔。色中多种。有贪外色不贪内色。有反此者。亦有俱者。外色中有多差别。十形四显八差别等。各别俱贪或少或多或遍贪着。声香味触各亦多门。是故贪行二万一千。嗔邪见慢当知亦尔。释曰。非无所以。未详所据。第三业稠林。然论有二。先正解后重分别。今疏将下重分别。文合在前文。正解中用九句分二。前八对果辨业。后一明定不定。就前八中远公摄为三对。初三一对次三一对后二一对。三对之中皆初对果明业为因。后就业体随义分别

疏。初一因者。此即对果明业。疏文有二。先通三性感五趣果。后唯善恶。今初引业。唯善恶者。俱舍业品云。一业引一生。多业能圆满。释云。引业谓总报业。但由一业唯引一生。若许一业能引多生。时分定业应成杂乱。若此一生多业所引。应众同分。分分差别。以业果别故。注云分分差别者。谓数死数生。多业能圆满者。别报业也。谓一生身圆满庄严许由多业。譬如画师先以一色图其形状。后填众彩。一色图形喻引业一。后填众彩喻满业多。是故虽同禀人身。于其中间有支体色力庄严缺减

疏。各有三品二地已说者。彼经云。十善业道是人天。乃至有顶处。受生因意明。下品十善是人因。中品十善是欲天因。上品十善是色无色界因。下辨三乘。除如来因。皆同上故。其十恶业略有三种。经云。佛子。此菩萨摩诃萨。又作是念。十不善业道。上者地狱因。中者畜生因。下者饿鬼因。皆三品也

疏。满业通三性名言熏习亦通三性许为因种故者。唯识第八云。然诸习气总有三种。一名言习气。谓有为法各别亲种。二我执习气。三有支习气。下二习气六地广明。其名言习气问明已释。为明三性故。复重举论。释名言习气云。名言有二。一表义名言。即能诠义音声差别。二显境名言。即能了境心心所法。随二名言所熏成种。作有为法名别因缘。彼疏释云。名言熏习即三性法。各目亲种。表义名言即能诠义音声差别者。拣无诠声彼非名故。然名乃是声上屈曲。唯无记性。不能熏成色心等种。然因名起种名名言种。谓因于名令心了知而成种故。今经从因起之义。乃显境名言故。云许为因种。疏又俱舍十七以三性因对五种果。无记亦能招果故。论通以三为道因者。彼疏第五初论云。前所言果有五种。此中何业有几种果。颂曰。断道有漏业。具足有五果。无漏业有四。谓唯除异熟。余有漏善恶亦四。除离系。余无漏无记三。除前所除。释曰。断道即无间道也。广配如彼。彼中第二三性相对。论云。已总分别诸业有果。次辨异门有业果相。于中先辨善等三果。颂曰。善等于善等初有四二三。中有二三四。后二三三果。释曰。上善等即业。下善等即法。初即善业以善法为四果。谓除异熟。异熟唯无记。以不善为二果。谓士夫增上以无记为三果。除等流离系故。云初有四二三。言中有二三四者。中即不善业。以善为二果。谓增上士用。以不善为三果。加等流。以无记为四果。谓除离系。言后二三三果者。后即无记。以善为二果。谓士用增上。以不善为三果。除异熟离系。以无记为三果。亦除异熟离系。解曰。既无记望善恶无记有二三三果。明有果也。况别不离总为因无失

疏。或既不招异熟等。二明道因唯是善恶。谓既曰无异熟总报果体。即无果义。论主言总明三为道因。别意但取善恶为因

疏。二有表示等者自性差别。此下二句唯就业体随义差别。云自性者造作之义。是业自性。论初释中但云自性差别。从论云此有二种下。此是论主后重释文。论主但云一筹量时。二作业时。从此在意地下。疏释初义。言在意地者。未形身口。言有审虑决定二种思者。今言唯有审虑一种思者。正明论中未作之意。虽在意地未有决定。未成业道。未受报故。如六地业有二义不受果报。一未作业。上引瑜伽已广显示

疏。二作业时者。此句论文从释经作字下。疏释通三业也。言决定思者即是意业。至决定思方成业道。能招报故。言若在身语下。辨余二业成唯识下引论证成。彼论第一广破外宗表无表色竟。小乘引经问言。世尊经中说有三业。拨身语意岂不违经。故论答云。不拨为无但言非色。能动身思说名身业。能发语思说名语业。审决二思意相应故。动作意故。说名意业。释曰。此出三业体。然思有三种。一审虑思。二决定思。三动发思。然初二思是发身语远近加行。然发动思正发身语。即二业体。然初二思与意俱故。作动意故。名为意业。故总以思为三业体。释曰。故意业中要具二思。方成业道如上已明。今约成业。但云决定故。晋经云分别不可分别相

疏。然今既云有表示下。但顺经文而非论意。表即表彰相可见故。无表反此。俱舍业品云。世别由业生。思及思所作。思即是意业。所作谓身语。释曰。谓有问言。世从何生。初句答云。从业而生。次句示二种业。一者思业。二者思已。即下二句开二为三。然其意业约等起立业。既是思与意相应。意等引起名为意业。言身业者。约所依立身。谓色身业依身起故名身业。言语业者。约自性立语即业故。次开二业成表无表。偈云。此身语二业俱表无表性。释曰。论释此二其文繁广。今当略示。初立有宗正理云。身表许别形。故形为身表。如合掌等。许有别形。形即是表表善恶故。表即是业。此之形色依身起。故名为身业。次破正量部云。非行动为体。行动即是有为。有为有刹那后有尽故。此之灭法更不待因。身表是果。果必待因故。论主次复破有宗云。形色非实有。应二根取故。谓依多显色假立长等。无别极微故假非实。若言有实。显是眼境形可身取。今显即形应二根取。形虽是表而非是业。业是思故。依身行门故名身业。次立语云。语表许言声。谓且许之。以其言声为语业体。业体亦以发语之思以为语业。语门行故。语之业故。则分同大乘。言无表者。俱舍云。无表虽以色为其性。如有表业。而非表示。令他了知故名无表。又颂云。乱心无心等。随流净不净。大种所造故。由此说无表。上依小乘次下依大乘。明表无表。然唯识示正义云。然心为因。令识所变示色等相生灭相续转趣余方。似有动作表示心故。假名身表。然因心故识变。似声生灭相续。似有表示假名语业。释曰。唯识但约心变。即异小乘。次明无表云。表既不实无表宁真。然依思愿善恶分限假立无表。理亦无违。次下大小乘对辨也。然俱舍意。唯身语二俱表无表。而唯识意。无表既依表上假立。是故疏云表则三皆是思。若以非色非心而为无表。则意亦有矣。故瑜伽五十三云。云何表业。略有三种。一染污。二善。三无记。若于身语意十不善业道。不离现行增上力。有身语表业。名染污表业。所治三也。若即于彼誓受远离。所有身语表。名善表业。此身语善表也。若诸威仪路工巧处一分所有身语表业。名无记表业。此身语无记表业。若有不欲表示于他唯自起心。内意思择不说语言。但发善染污无记法。现行意表业名意业。释曰。此显意业亦具三性。自能晓了。我今造作如是事业别表。于后意俱之表名为意表。意为无表。如理思之。释曰。故知大乘三皆有表。广如别章。大乘法师法苑中。十门分别。一辨名。二出体。三假实分别。四具支多少。五得舍分齐。六依他有无。七四大造性。八应成差别。九先后得舍。十释诸妨难。广如彼说。疏方便差别者。心为起业之方便故。经云。与心同生不离者。业共心生。生已不离。此言业行常依心王也

疏。与等起意识共生者。俱舍云。等起有二种。因及缘刹那。如次第应知名转名随转。引论解释已如六地。然今此中正同缘等起也。与所起业同刹那故。故云意识共生。言随其善恶生已即熏成名言等种者。此文影略。若善恶熏即成业种。意识等熏成名言种。由上有意识共生故。然要由业熏心。方成种故云尔耳。疏中等言。等于业种。言种似能熏亦有二义。一似善恶。恶生苦果善生乐果。二似名言。所熏第八成异熟种。能熏七识等。成名色等种。上二并言不别生果。言即不离义者。结归于经。谓业种不离心。得果不离种也

疏。四尽集果者。此下第二对三句。前二句对果论业。后句约业差别。前中此句明业得果不失坏也。而言得持至果者。即俱舍得得连持义。论偈云。得谓获成就。非得此相违。得非得唯自。于相续二灭。然此得得以持此业。如券持债故。古经论名不失法。中论云。不失法如券业如负财物。然大乘虽立有得。不许有实。而云熏习成种。前句已引

疏。前念虽灭下。释经次第之言。然有二意。一即就上因灭果生。以明次第。二亦是因即顿熏下。唯就果中以明次第。如六地明

疏。论云已受果等者。此句明业得报迟速言过去生报业现在已受者。且约一相随近以明。若今世受更是前前所造之业。即亦得是后报之业。名为已受。是则后报之业已润有报。未润无报。亦应云已熟已受未熟未受

疏。更有一理者。上是六地缘生中。护外三过中。此通业无报难。上论答云。业有三义故不受报。一未造。二未润。三得对治。前即第二义。今即第三义。未造之业即前未作是也

疏。初二黑白相对等者。释论对差别。然其论经具有四句。云黑业白业黑白业。非黑非白业。论释云。黑业对白业。白业对黑业。不黑不白对二业。二业即是第三黑白业也。故云。后二漏无漏业。无漏即亦黑亦白业故。又今黑黑之言。全依俱舍。次下当引。疏四中初一因果俱恶下别释。然以恶释于黑。乃是通义。别者因恶染污果恶鄙秽不可爱乐。通以善释于白。别亦不同。因白体不染污。果白则可爱乐故。然上黑是因。能招黑果故。下黑是。果能酬黑因故。白因白果例此可知

疏。谓诸无漏业无异熟故者。无白异熟故曰非白体。非染污故曰非黑。今以无漏非染义可知故。但云无异熟耳。然俱舍论云。此非白言非密意说。以佛于彼大空经中告阿难陀。诸无学法纯善纯白一向无罪。释曰。既言纯白明非白者。是密意说。为成四句。致非白言故。疏云对上黑白二业立双非名。若准杂集。但言非黑白业。无两非字故。论云。非黑者离烦恼垢故。白者一向清净故。然上四业前二因果。共立黑黑白白。第三唯就因中立名。第四亦双就因果立名。因明非黑果明非白

疏。上三有报者。由约异熟名报。无漏无异熟故说有三报。若约果名报。无漏既有四果。则上之四句皆名有报

疏。若俱舍意等者。为生后释不许善恶同时故。此指俱舍。明约相续非约自性。然上四句全俱舍意故。彼论云。又经中说业有四种。或有业黑黑异熟。或有业白白异熟。或有业黑白白异异熟。或有业非黑非白无异熟业。能尽诸业其相云何。颂曰。依黑等有殊。所说四种业。恶色欲界善。能尽彼无漏。应知如次第。名黑白俱非。释曰。上来疏文用论已周。细寻自见。谓初二句总标。次句即前三业恶是欲界恶业。色是色界善业。欲是欲界善业。能尽彼无漏。即第四业。彼即前之三业以为所治。无漏能治之。谓能尽彼前三是无漏业。后二句结可知

疏。余广如杂集第八等者。俱舍之义上已。具用杂集之义。大同俱舍。今更具出论云。复次有四种诸业差别。谓黑黑异熟业。白白异熟业。黑白白黑异熟业。非白黑无异熟业。能尽诸业。黑黑异熟业者。谓不善业由染污故。不可爱异熟故。白白异熟业者。谓二界善业不染污故。可爱异熟故。黑白白黑异熟业者。谓欲界系杂业善不善杂故。云何一业亦善不善。此中不约生刹那相说一种业亦善不善。然约意乐及方便。总说一业。是此经意。约此二种。若黑若白互不相似。建立一种黑白业故。或有业意乐故黑。方便故白。或有业方便故黑。意乐故白。意乐故黑。方便故白者。如有一人为欲诳他。先现其相。令信己故行于惠施。乃至出家方便故。黑意乐故。白者如有一人欲令子及门徒远危处安。由怜愍心现发种种身语粗恶。遂于此时发生杂染。非黑白无异熟业能尽诸业者。谓于此方便无间道中。诸无漏业以方便无间道。是彼诸业断对治故。非黑者。离烦恼垢故。白者一向清净故。无异熟者生死相违故。能尽诸业者。由无漏业力。永拔黑等三有漏业与异熟习气故。释曰。在文易了。但云非黑者非烦恼垢。此拣前黑黑业。一向清净者。拣前有漏善业。为烦恼所发。言由无漏业力永拔者。即苗加行无间二无漏智。同时思业从智慧说故。言永拔所拔即三有漏业习气也。余义与上所引俱舍。一而无二故。疏总指。疏因缘差别者。彰业能为缘。容因种故

疏。随田高下有殊令种亦多差别者。上句单约喻。下句双含法喻。又云令种差别者。且约喻明。如谷子随田肥瘦。非令种谷而生豆芽。若约江南为橘江北为枳。则亦少有变种之义。然亦疏类非全差别也。若约法说。识种无异。由业善恶识招苦乐。即令种异也

疏。出世未集等者。约凡未能集圣法故。以释经文凡圣差别故

大方广佛华严经随疏演义钞卷第七十大方广佛华严经随疏演义钞卷第七十一

        唐清凉山大华严寺沙门澄观述

疏。九十二句定不定差别等者。疏文有二。此上标章。后前句明下别释。先释第九句文三。初标举论文。二释经文。三释论定不定义。疏谓现作下。疏释经文三受之义。疏文已具。然经部师云顺现受业其力最胜。必受生报。后报若顺生受其力稍劣。必受后受不受现受。顺后受业其力最劣。不受现生唯受后受。随初熟位名顺现等也。释曰。义似有余。或有各造一生之业人天并造。先受人报后受于天。岂要令其重受人耶。然此三受略说有三因。一由于因。如于佛僧慈定灭定及无诤定见修道中作供养者。得现乐报。于父母王等作损恼业。得现苦报。二由业体。如不动业得乐生报。五无间业得苦生报。三由行愿。多福之人罪得生报。现世轻受疾得菩提。多罪之人都无现报。以造重恶趣生报故。诸相好业皆得后报。不可一生即成佛故。又诸轮王多受后报。劫减修因劫增受果故

疏。于此三中各有定不定下。第三释论定不定言。于中上二句标。谓前二下释。然即俱舍意颂云。此有定不定。定三顺现等。或说业有五。余师说四句释曰。初句标。次句别释现生。后三即三定业。加于不定即有四业。或说业有五者。或有欲令不定受业复有二种。谓于异熟及时有定不定。开为二种。一异熟定时不定。谓果必定。受于三世时即不定也。二异熟与时二俱不定。谓果与时俱不定。受但有果定时不定。无有时定果不定者。但于时定于果必定。以时离果无别性故。虽开合有异。其理无别也。余师。说四句者谓。譬喻师说业分八种故。为四句。彼许时定于果不定于不定中时复分三。兼前五业。故成八种。第一句者于时分定异熟不定。谓顺现等三业三世时定。于果不定。若现在世获其果即受。现若不受。永更不受。于时必定。于果不定。顺现既然。生后亦尔。此分三种。谓一顺现定果不定。二顺生定果不定。三顺后定果不定。第二句者。有业于异熟定于时不定。谓不定业定得异熟。此但为一。谓果定时不定。第三句者。有业于二俱定。谓顺现等定得异熟。此有三种。一顺现时果俱定。二顺生时果俱定。三顺后时果俱定。第四句者。有业于二俱不定。谓不定业非定得异熟。此但为一。谓果不定时不定也。释曰。上俱舍三师后后渐开。疏中总摄而言小异。言此三俱有定不定者。已总摄三师。而正收初师。即俱舍云此有定不定三顺现等。兼不定为四。疏谓前二下。别示其相。虽通第三师四句。而有通局。前二时定者。以现若受名现报业。现若不受非现报业。生报亦然。要次生受方名生报故。说前二时则定也。报通定不定者。有造现报之业。应合现受。更遇胜缘排而不受。此报不定生报亦尔。无有移此更别时故无时不定也。后一俱通定不定者。即第四句时报俱不定。及第三句时报俱定。并第二句报定时不定。谓顺后受不定业。有业定受而不定。一生二生多生故。是报定时不定。有不定业于第三生应合受之遇缘业坏。是为时定报不定也。或复有业未定生数而受果报。忽遇缘坏故俱不定。然俱舍中报定时不定。义通三报今何就于顺于受耶。答俱舍以业就时。谓有业定受而或现或生或后。今明以时取业。要现受报方名现业。现若受者即现定业。现若不受即非现业故。无现报时不定也。若是生受即是生业。不受则非生报之业故。无生报时不定也。各取一义亦不相违。问现见有业合受现报。而以力排便受生报。或合受生报由异因缘便受后报。如末利夫人专精施戒。合受生报生兜率天。临终小嗔先生蝎中。七日之后转报生天。问据此三业。皆有报定而时不定。何得言无。答现报缘排而受生者。即是生报不名现报时不定也。生报亦然。思之可解。对前三师。疏意便当第四师也。业力甚深不妨广解。或当更有余经论明

疏。定者难度等者。此约非乘及与二乘各于自分而已定者。大乘若定更不须度。是故不言定者易度

疏。根等诸门皆成八万者。由惑有业惑有阶降。业亦如之。惑依根有胜劣性有差异。解有浅深。欲有轻重。各成八万。言翻此即显等者下。明能治一一惑等。皆到彼岸穷理尽性。即是八万四千度门。若于惑等寂妄不动。即是八万四千三昧。若于惑等一一无羁。即八万四千解脱。第四根稠林。根义已见第九回向

疏。别中十相为九差别者总科也。束九为三。初六随法义分别。次二就人分别。以论云声闻菩萨故。后一约行以辨其根。初中又三。初三净根。第四染根。后二通染净

疏。受有迟速等者。钝者迟少利者速多。中者之间浅深亦尔。疏三乘根性相形者。小乘为下。缘觉为中。大乘为上。亦犹羊鹿牛形大小也

疏。谓喜乐等者。喜乐生于贪。忧苦生于嗔。舍根生于痴。后于此类烦恼而有胜用故。多烦恼染根

疏。大乘中熟者定等者。前章约业明定不定。今此约根居然自别。又前约定不定明难易度。今此约熟不熟明定不定耳

疏。即离世间中待时方化者。彼有十种清净舍。然有二类待时。今皆当之。一以第四云于法器。众生待时而化。于无法器亦不生嫌清净舍。释曰。今但用法器待时。二第九舍云。或有众生根已成熟。发生惠念。而未能知最上之法。待时而化清净舍。今全用之。是以疏云且暂舍之

疏。一依身顺行者。此论语倒。合云身依顺行。今疏正用

疏。谓六入展转。递共相缚者。如意识遍缘。于六根中根法随识亦行。六中眼见自身。耳闻自声。声身并在内根所摄。由根随识缘于眼根。令根被缚不得解脱。余例可知。故云展转。疏二生灭顺行。此言是倒。若正应云顺行生灭。根与心王相随染污故顺生灭。易可异灭者。以生住。释轻。以异释转。以灭释坏耳。三观行顺行者。以觉观心行六尘故

疏。根网中收者。六根取于六尘根网尘也。六尘引于六根尘网根也。故其根网摄论取相

疏。七声闻净下下二约人。今初声闻。言望凡夫二乘行增上故者。然论下重释云。声闻净者。行增上灭障能成故。今疏取论释经。此上释增上。谓二乘净根对望凡夫。不求涅槃今能求故。故于出世得增上也。从以二乘根下。释无能坏。兼释论中灭障能成疏八菩萨净即大乘根。三不退者即位正念也

疏。九远随下。此一约行。即经远随共生不同相。论经云深入共生种种差别相。种种即不同。深入即远随。言示一切根摄下。是论释经。论重释云。一切根摄差别者。始行方便报熟根异故。从谓三无漏下。疏释论文。初修为始正行善巧为方便。究竟故名报熟。配三无漏义见上文。谓前信等下。以论会经。释不同远随之言。其信等共三无漏根。释共生义。根与法行相应起故。而随下释不同义。自始至末下。释远随义。此之三根下。释成根义。以胜用光显增上名根故。及此上九下总以义收。并如回向品

疏。第五例三下。然解性欲三略如十力章广如发心功德品。言性相顺入者。依根生解。依解成性。依性起欲。皆悉相似。名为相顺。义理相参名为顺入。以此例根更不广说

疏。第六释随眠者。先释总名。后别有下依论摄释。今初。言此唯约种者。案瑜伽第二云。于诸法自体中所有种子。若烦恼品所摄。亦名粗重亦名随眠。若异熟品所摄。及余无记品所摄。唯名粗重不名随眠。若信等善根所摄种子不名粗重。亦非随眠。何以故。由此法生时。所依自体唯有堪能。非不堪能故

疏。前六明何处随逐等者。论中且据随逐以明。若约系缚。亦应云何处系缚以何系缚。若顺随眠。亦应言何处随眠以何随眠。故下释中云久安眠处等

疏。今初为五者。一约心明处。二就界明处。三就位明处。四就时明处。五约行明处。今初言报心者。异熟赖耶总报体故。微细等义频见上文。言不离现事而生故。但云心者。故唯识等詺前七识。为异熟生。非是报体。酬昔心种不得名报。而七识皆依第八托缘现起。名不离现事。种随现起或有或无。名暂回转处。如人假寐不必本房

疏。二相应不相应中。初取论意立名。唯与下。疏释相应等相故。论云下。引证约界言之。从无色惑微下。疏释论文下中上言。等取色界惑中欲界惑上。此约惑体。远公云。欲界为下等约界胜劣。从虽则随眠下通妨难。谓有问言。随在一界皆成三界所有随眠。如生上界下界惑种亦皆成就。如何云有相应及与不相应耶。故今答云。就其现惑说种相应。非生上界失下界种等。然今案经。但有相应不相应言。故为此释。若准论经云相应不相应。不离相则现惑有相应不相应。而随眠常不离也

疏。一至金刚之顶者。谓金刚喻定之前。犹有生死之有。故名有顶。以俱生惑种此时方断故。以上烦恼林中云下至金刚。自约种说。虽有二义疏意扶此故。上科云三约位明处。从今取通下会论经。不言金刚者。欲通大小故。下偈既云金刚道灭方毕意。即前义为正也。九地之言亦通二义。对上三有之顶。即三界九地之九。谓欲界四禅四空应为九耳。若顺前义。即善慧地。第十当其断尽位故。四约时易了。疏唯智能怖下。此即论意以论经云无始来不恐怖相故。论为此释。论云。无边世界唯智能怖畏如怨贼。未曾有闻思修慧。是故不灭。疏取论意会释今经可知。疏不能随顺正修行者。论经神通下。有正修行言故余可知。疏后三界下。明以何随逐。中除第四句。彰随眠体虚。余五亦就前处以明随逐。而文不次一即就前第二约界明处。以明随逐。不断即是随逐之相。二即于前第四约时明处。以辨随逐。即经令无边心相续现起相。而论经云无始来相续集相。疏中双会无始无边。然其相续即随逐相。三开诸处门。即于第一约心明处。以辨随逐。集生六识即随逐相。余如疏文但言今经义含者。诸处之中意处摄赖耶故。疏坚实下。彰随眠体虚不就前处。言不实坚实者。经云坚实难治。论云不实随逐。不实即是随眠随逐。至禅定等故。是坚实即不实。难治是随逐相。疏五地处等者。五即就前第三约位明处。以辨随逐。言九地中六入处者。以论经云地入随顺不随顺相。论释云。九地中六入处烦恼身随逐故。释曰。身即体也。然九地下是疏释论。对二有顶存二九地。二约善慧九地中。就所知障种。十地犹有等觉二愚。从入初地来地地双断故。于九地已断十八。故云此地分有断除。次引金刚方毕竟。双证上二。金刚方毕。明十地犹有。既言方毕明九已有除。又约烦恼障种。金刚顿断亦成于经。地地之中皆有成就义

疏。六离苦随逐者。此就前第五约行明处。辨随逐义。唯以出世圣道方能离者。则反显于世间之道。诸定等不能离也。故论云余行不能离故。此以不能难即随逐相。前第五中以有成就为随逐相。第七受生稠林。论通为八者。八中前七对因显果。后一句约对后苦彰能生集。就前七中摄为三对。谓初二次三后二。其三对中皆初当相论生。后对因说生就初对中。一身种种当相论生。二业因种种对因辨生由业不同故。生成种种。第二对三句中。前二句当相论生。三住处种种非唯六趣一趣之中无量处故。疏四四五二句色想上下种种者。今经二句为论中一句。经云有色无色差别相。有想无想差别相。二界有色。无色界为无色。无想天为无想。余皆有想。而言上下者。以无色为上有色为下。无想为上有想为下。应更有非想非非想。亦无想收。而论但云色想上下。故远公问云。无色云何得为色中上下。释云。彼无粗色有细色故。又问。无想云何得为想中上下。答义同前意。云彼无粗想有细想故。余如初地中辨。疏五同外色种种。即对因辨生。以举过业之因。显有芽故。广如六地。第三对中。六自体种种即当相论生。亦如六地。然有体唯色有体具二。故云种种

疏。七本顺生下。即对因辨生。此上论文。谓痴爱下疏顺论释。若远公云。论文语倒。若正应云顺本生因。谓现在之生本因痴爱。依今生上还起痴爱故云顺本。亦不违理。疏八末后二句下。约对后果彰其生集故。名集苦谛种种。谓三求下。疏取论意以为解释。于中先总释论名。后上句下别消经文。先释上句二求。言欲受者受即乐受。欲生五欲增取追求。招于当苦。言欲生者。体即是想。取三界胜相而欲生故。下句即邪梵行求中。初总明。此言轮回。即论往来上下。次贪求三界下。别说小即欲界。大即色界。无量即空识二无色。并如八地。妄谓涅槃总。相而说。或谓拍腹。即檀提婆罗门拍腹唱言。我身即道。是计欲界为道。无想即计色界为道。非想即计无色界为道。则上二无色亦在其中。二界偏举此二天者。外道多计为涅槃故。然论经云贪着三界想出想故。而论以无想天释经想字。意云。彼有细想外道妄计以为无想。有想谓无云想出想。成实论中。亦谓无想天。但无粗想。而有细想。故论结云外道妄计谓出有轮。故知三求。但增集因。展转招苦。第八习气稠林。总中有四。一双标。二引证。三正释。四通结。今初。即余习熏习而为二义。标章通故

疏。虽标习气下。引文证成熏习之义故。唯识第二云。内种必由熏习生长。亲能生果。是因缘故。外种熏习成有或无为增上缘。所办成果。必以内种为彼因缘。是共相种所生果故

疏。熏谓熏灼下。第三正释。于中二。先释名。即唯识文。二即赖耶下释熏习义。于中三。一法相宗。二法性宗。三通拣滥。今初。亦唯识文。问明已广。今疏文具更略示之。论云所熏能熏名具四义。令种生长故名熏习。何等名为所熏四义。释曰。疏云即赖耶识以为所熏者。出所熏体。唯有赖耶具四义故得名所熏。以恒住一类下即出四义。此上一句即第一义。论云。一坚住性。若法始终一类相续能持习气。乃是所熏。此遮转识及声风等性。不坚住故。非是所熏。二是无记性者。即第二义。论云。二无记性若法平等无所违逆。能容习气乃是所熏。此遮善染势力强盛无所容纳故非所熏。由此如来第八净识。唯带旧种非新受熏(北极善故)三可受熏故者。即第三义。论云三可熏性。若法自在性非坚密。能受习气乃是所熏。此拣心所及无为法。依他坚密故非所熏(心所不自在无为性坚密)四能所共相和合者。论云四与能熏共和合性。若与能熏同时同处不即不离。乃是所熏。此遮他身刹那前后无和合义。故非所熏。此义疏家在于能熏第四合举。疏前七转识以为能熏者。即出能熏体。从由有生灭下。即出四义。论云何等名为能熏四义。一有生灭。若法非常能有作用生长习气。乃是能熏。此遮无为前后不变无生长用。故非能熏。二势力增盛者。即第二义。论云。二有胜用。若有生灭势力增盛。能引习气。乃是能熏。此遮异熟心心所等势力羸劣故非能熏。彼疏释云。言胜用者。谓前七识可是能熏。拣前六识异熟生者。及第八心王心所虽是能缘。而不强盛不名为胜故非能熏。三有增减故者。即第三义。论云三有增减。若有胜用可增可减。摄根习气乃是能熏。此遮佛果圆满善法无增无减故非能熏。彼若能熏便非圆满。前后佛果应有胜劣。疏能所共相和合故名熏习者。即合辨第四能熏。第四论云。四与所熏和合而转。若与所熏同时同处不即不离。乃是能熏。此遮他身刹那前后无和合义。故非能熏(自他不得互熏前后不得互熏)论云。唯七转识及彼心所有此胜用而增减者。具此四义可是能熏。释曰。所以能所第四合者。有二义故。一以二种第四但能所异言全同故。二用此文别为总结故。论结云。如是能熏与所熏识俱生俱灭熏智义成。令所熏中种子生长。如熏苣胜。容名熏习

疏。依起信下。第二法性宗中熏习之义。并如问明

疏。前中虽闻等下。第三拣滥通妨。亦唯识意故云前中。亦为拣于起信等中善友闻法为外熏故

疏。今并通此者。通结上文性相二宗熏习之义。及除习义。经文皆具

疏。别中十种差别下。二别释疏文有二。先当句释。后总结束。结束中略。今若具说。前七约时明习。次一约道后二约人。前中又三。初二对过说习。次三现在望现说习。后二以现望后说习。疏文皆具。今初初句即因习也。二即果习

疏。如大威灯光仙人所问经者。彼云问疑经。此仙为首。广有问答。末后诸仙

问此义。云众生义持犹如流星各各别异云何得成真实聚集。下取意引。佛言无时方处而得聚集。过一乘已菩萨地中方得聚集。无余涅槃中方得聚集。如百川归海。又云。我虽说烦恼平等中得聚集。亦非聚集。如风吹虫聚在一处。风息还散。众生亦尔。业风吹聚地狱饿鬼等处。业尽还散。又问意云。先同在六道。后人中相遇。云何得知先来聚集。佛言大仙人。所有众生若相见时。心不欢喜。生嗔结恨。或时头痛或时失禁大小便利。当知是辈已于先世地狱之中曾聚集相。又问。若先世曾在畜生中。有百千万身一处者。云何可知。佛言。彼生人中各相见时。结成嗔怨常见其便。我当何时觅得其便。即畜生中曾聚集相。若饿鬼中来常乐臭秽。复多贪食。设欲与他心不去离。生恼贪着。或复见彼富贵势力。心生嫉妒。复常欲得彼人财物。若有先世同在人中。曾共一处者。于现世中若相见时更生欲心。若有先世共在天中。若相见时各以眼道。远相摄取共相眷爱。仙人闻此称赞如来。是一切智。疏三随众生行者。此下三句现望现在。以说习气。昔王不立厩于寺者。即智论文。谓此王有象可以敌国。每有怨敌庄严器仗。无不克胜。后敌国皆惧。久而无敌。遂于寺中立厩养之。久闻僧众礼念熏心驯善成性。后有邻国兵众相侵。严象敌之。都不肯战。其王忧愁虑其国败。智臣白王。此象久处精舍。见闻善事与之化矣。可处屠坊令常见杀。后未经久恶心还起。畜生尚尔。况复于人。近善不善近恶不恶耶

疏。四随业下。四五二句约因说习。第四约于作业之因。第五约于善恶之因。四中言如锻金之子等。明法品已引庄严经论说。舍利弗。错教二弟子。一白骨观。一数息观。经历多年各不得定。以是因缘即生邪见。言无涅槃无漏之法。设其有者我应得之。何以故。我能善持所受戒故。我于尔时见是比丘生邪见心。即唤舍利弗而呵责之。汝不善教。云何乃为是二弟子颠倒。说法。汝二弟子其性各异。一是浣衣。一是金师。金师之子应教数息观。浣衣之子应教白骨观。以汝错教令是二人生于恶心。我于尔时为是二人如应说法。二人闻已得阿罗汉果。是故我为一切众生真善知识。非舍利弗及目连也。释曰。以此文证明是工业之习。非业因也。业因即下善恶是耳

疏。如人喜眠者。即涅槃十九。十六大臣。若为阇王。说此偈曰。若常愁苦。愁遂增长。如人喜眠眠则滋多。贪淫嗜酒。亦复如是。疏中有即是本有后故者。以经文随入后有。论判为中阴熏故。故俱舍云。本有谓死前居生刹那后。则本有即是今身。未至当有。于二中间说为中有。俱舍云生死二有中五蕴名中有故

疏。七次第等者。此言后有即当本有也。远公释次第云。中有能与生阴之果为方便故。名为次第。疏意云。如在因中先多作善后则兼恶。后与果时初即多乐。后便有苦。先苦后乐。义亦准之。则受果时如因次第。言上二约现望后者。第六现望中阴第七现望当有

疏。八不断下。此一约道明熏习。无漏圣道亦有熏故疏九实非实下。后二约人疏亦舍三乘余习之相者。智论第三云。譬如香在器中。其香虽去习气故在。譬如人被缚。初得脱时。身犹不便。如毕陵伽骂恒河女。亦第三论。舍利弗嗔亦第三论。谓身子为上座。罗睺罗瘦。佛问其故。彼说偈云。若人食油则得力。若食酥者得好色。食麻滓者无气力。大德世尊自当知。佛问。谁为上座。答和上舍利弗。佛言舍利弗。食不净食。令日中炙。后复令止。不肯归已。炙不合止。佛遂引昔为蛇伤王。咒师设火坑令其嗽毒。若不嗽者当入火坑。彼自思惟我已能吐。云何更嗽。遂投身入火。故其嗔习至今不已。其大迦叶舞。即智论四十七。余如第二疏钞疏法华安乐行品。令不亲近二乘者。经云。又不亲近求声闻比丘比丘尼优婆塞优婆夷。亦不问迅。若于房中若经行处。若在讲堂中不共住止。即不令近也。恐习成种。即是疏释

疏。上来十种下。第二收束等并显可知。第九三聚稠林。论为五者。五中一约生死涅槃之果以分。次二偏就生死之因。后二偏就涅槃之因。初中先举论。后无即邪定下疏释。于中三。初正释三聚。次此就下。拣定约位非约本性。后又约一期下。拣法相宗无性之义

疏。此约解惑者。解为善因惑为恶因。正见即三善根中无痴定起善业无贪无嗔。不定起善则为不定。涅槃经说。邪见一种定起恶业。故为邪定。二则轻微善恶以为不定。前三善根则名不定者。四善根中唯世第一定入离生故。三不定。疏总结前三者。即一法师方便成就。二智成就。三入行成就。大文第四疏初牒前总显者。住此地已名为牒前。了知已下即是总显。先了心行。后教化调伏令得解脱。即是善说

疏。问此二何异下。问答料拣。先问。后前二下答。谓前二别知智成。如别知本草别明入成如别明脉经。今此依脉知病授本草药。教道以将化生者。文无教证故各含之。其教证言在前总中。教化调伏即是教道。令得解脱。即是证道。此三乘中皆具此二。以论经文总中。但云此菩萨住善慧地已。如实知众生如是诸行差别相随其解脱而与因缘。无有教化调伏之言。及至此经所知法中。论经却云。是菩萨如实知化众生法。如实知度众生法。说声闻乘法。说辟支佛乘法。说菩萨乘法。如实知如来地法。论释云何者。随所知说解脱器得熟故(即教道也)解脱体正度故(即证道也)疏依论经有教证义。仍取前文教化等言。故云含有

疏。论主通收为七者。谓收上总明。为第一器收下总结为第七器。一说所说法对器中先举论。即总中下指经。疏别中初能随等者。别但开总故。先配总中二句。以初后六字配经中智随行句。以中间诸林配一切行处。而疏但配属论。以前将论属经意故。疏初众生心性欲解者。牒经经无心字。论中文有。及下喻中复要此心故。依论义加。然论经具云。菩萨如是知已。如实为众生说法令得解脱。随心差别随使差别。随根差别随信差别随境界差别。随种种行习气。随顺一切境界智。随顺性行稠林。随生烦恼业习气转。随聚差别随乘信解。令得解脱而为说法。释曰。论依上经分成七器。初有总心今经略无心。后有使今经为眠缚。在于向后。今经云性在于第二。论经云性行文在于后。故今疏中。但顺经文会取论意。以配属耳。此五正显已成信等者。然心一种但是总依。未成器故。论经中则有心字释义不牒。但云随根随信而为说法故。疏但云已成信等法器。不言于心。以是总依故言有五

疏。一约能行之行名种种异行器等者。然论经中具于二句。论别将属于二器。一云随譬喻器。如经随境界差别种种行习气故。二云。随种种异行器。如经随顺一切境界智故。今经既阙二句。但有所行有异。即论前句中种种行习气故。疏取意开成二器。以顺论文。言种种异行者。如根有如能行信进念定慧等。言所行之境者。即所信佛法僧等。乃至所知。如根既尔。性解欲等亦然。能胜解者即持心印。所胜解者即所印境。谓所解真理等。能行即有根性等殊名种种行。所行境中随于一境。即须有五故为譬喻。如种一谷即具五义。谓修一定。一定如谷。一须作意如有心物。以物心断种不生故。二有定根。三习成性。如一茎谷。虽有心根。今已枯椊即无生性。四现起乐欲。五胜解印持不可引转。名决定可生故。疏结云喻上心等。疏定不定根转器者。定通邪正二俱不定。即是转言通上根等者。根性欲解皆悉有于定不定义

疏。以彼生烦恼者。即三杂染生即是苦。烦恼摄眠缚。眠缚即是随眠。是论之使而论乃在第一心下。故此不言。然其类例不合在前。多是译人见其性义。谓是随眠故。类前后名之为使。以性同种性似种子故。而论前文阙性字义。必译人失论经意。故今疏文直案今经论意。以释义甚符顺疏。三结成益下。即第七器。言以上诸义不出自乘者。上六器义不出三乘。疏今初亦是智成者。义有两兼故云亦是。而智先已说。此中之智为成口业故。论但云口业成就。文中二。先总释大意。二何名具法师下释文。于中又二。先引本论后引他文。前中但举论列名。后云广释如论者。以文多稍易非正释经故略指耳。今具出之。论二十德分之为二。前十五种是随顺说。外顺说仪故。后之五德是清净说。内心无过故。前十五中义分为六。初有两句量他所宜。二有二句量法所宜。三有三义量化所宜。此与量他而有别者。前者量他受法之心及法威仪。今此量化量物机性。四从八示下。三义量物所宜。五第十一具德一句。亦量自所宜。与第二量法异者。前量说心及量说事。今量说智。六从十二不毁下。四义明其说能顺益。已知大旨次当解释。初言时者。观察物心无留难时。而为说法。论云。是中时者无八难故。如偈说云。如王怀忧恼病恚着诸欲崄处无侍卫。谗佞无忠臣如是八难时智臣不应语。心王亦如是。非时不应说。释曰。论但两偈更无解释。今当释之。前一偈半是喻。但半偈合。王喻众生。于所说法取舍自在故。一如人忧恼言不入心。众生忧恼法不入心。二病苦喻。众生有苦法不入心。三恚四欲可知。五崄处喻八难处。六无善法为侍。七恶友谗佞。八无善友忠臣。此八皆为法之难。二正意者。论云。正威仪住非不正住。此义云何。自立他坐不应为说法。如是等事如戒经中广说。何以故。诸佛菩萨敬重法故。以恭敬故。令他生尊重心。闻法恭敬摄心听故。释曰。上量他所宜竟。二有二句量法所宜者。即三顿四相续。论云。顿者是菩萨正意。为一切众生说一切法离悭法垢故。释曰。说一切法是法顿也。离悭法垢故即心顿也。生多法广事虽难尽。但舍悭垢即名顿矣。论云相续者。说无休息舍诸法中嫉妒意故。释曰。说无休息者说相续也。舍嫉妒意心相续也。事难常俱但舍妒心。即名相续。第三三句量化所宜者。谓五渐六次七句义渐次。论云渐者如字句次第说故。释曰。此约教明。论云次者如字句次第。义亦如是说故。释曰此依义也。论云句义渐次者。说同义法不说不同义法故。释曰。此依行法次第说。亦可。于前教及义中说同义法。不说不同义法。是义云何如四谛中苦说有作集。灭道中亦说有作苦说无作。集灭道中亦说无作。如是一切不相间杂。故曰同义。四有三句量物所宜者。谓八示九喜十劝。论云。示者示所应示等故。释曰。如小乘根应示小等。等者。等取授所应授。照所应照等。论云。喜者喜所应喜等量宜开晓。令欢喜故。论云。劝者怯弱众生劝令勇猛故。五一句亦量自者。论云具德者。现智比知阿含所证具说故。释曰。现比一对情意分别教证一对约境分别。备此四种能说之德。故云具德。六有四句。明具说能顺益。谓十二不毁至第十五。论云不毁者。随顺善道说故。释曰。说能随顺出世之道。论云不乱者。不动不杂正入非稠林故。释曰。此明说能顺理。不动者言不太浅。太浅失理名之为动。不杂者说不太深不杂深隐。言正入者显前不动。言能显理令人正入。非稠林者。显前不杂语不深隐不如稠林难见知故。论云如法者。具说四圣谛故。释曰。谓说称于四谛法相。能令人知苦断集证灭修道故。论云随众者。于四众八部。随所应闻而为说法故。释曰。此明说顺于人故。论总结云如是十五种相菩萨随顺利益他说一切法故。后之五种是清净说者。谓十六慈心下是。论云慈心者。于怨众生起慈心说法故。释曰。怨多嗔故。论云安隐心者。于恶行众生中。起利益心说法故。释曰。恶行必当受大苦故。论云怜愍心者。于受苦乐放逸众生中。起怜愍利乐心说法故。释曰。于受苦者愍其现苦。于受乐放逸者。愍其当苦。论云不著名闻利养者。心不希望常行远离故。释曰。未得不悕。已得能离故。论云。不自赞毁他者。离我慢嫉妒随烦恼。为众生说法故。释曰。随缘现起名随烦恼。以离我慢故不自赞。以离嫉妒故不毁他。论结云如是五种相菩萨自心清净故。论又总结云。具此二十事能作法师。是名住大法师深妙义中。疏涅槃具七善知下。二引他文。此中有三。一引涅槃。先虽广引今略列名。一知法。二知义。三知时。四知足。五知自。六知众。七知尊卑。二慈氏下引瑜伽论二十者。一善知法义即摄三事。一渐。二次三句义渐次。第二能广宣说摄二。即顿及具德。第三处众无畏。即随众。第四无断辩才。即相续。第五方便善巧摄三。谓一知时。二示。三喜。第六法随法行摄二。即如法及安隐心。第七威仪具足即正意。第八勇猛精进即摄二义。谓劝及怜愍。第九身心无倦摄于三德。一不毁。二不乱。三慈心。第十成就忍力。即摄二德。一不著名闻利养。二不自赞毁他故。诸经论开合不同。大旨无别

疏。三会之亦同下。会瑜伽同上二文。一会七善知。谓一善知法义即是初二。二具上二义故能广说。三处众无畏即知众。四辩才无断即知时。五善巧方便即知尊卑。六法随法行即知自。七威仪具足亦知尊卑。八勇猛精进即是知足。九身心无倦。十成就忍力。皆由具上七故

大方广佛华严经随疏演义钞卷第七十一大方广佛华严经随疏演义钞卷第七十二

        唐清凉山大华严寺沙门澄观述

第二正明口业。今初先显名体者。文有三节。一显名体。二约位辨胜。三征列名字。今初经文。是一义含名体。谓经从初至而演说法。皆是释名。有二名故。次辨体者。重取善巧智字以为辨体。义无碍下。随难别释义名所以。知是差别即后得智。无心照理即通正体

疏。约位显胜。文意可知。然此无暂舍离。论名不坏论。云不坏者。不动故即无暂舍义

疏。后何等下。三征列名字中二。先释通名。上释名中。但释辩智。今释无碍。后一法者下别释四名。然唯识云。法无碍智缘能诠教法。为境义无碍智。即于所诠总持自在。于一义中现一切义故词无碍智。即于言音展转训释。总持自在。于一声中现一切音声故。乐说无碍智缘机巧说为境。又云。辩才自在者。谓辩无碍解善达机宜。巧为说法。俱舍亦以法缘能诠。释云名身者。所谓想章字总说。释曰。以想释名以章释句。以字释文以总释身。论云。名谓作想。解云。想者取像。或契约义。若取像名想。想是心所。如说于色能生色想。因名生想名为作想。若契约义。想即是名。谓诸贤圣共为契约。立色等名名即是想。由此名想显有诠表故名作想。余义准说。今之本论释法无碍。不局能诠故云法体。如色碍相。然论一时列名云。是中四无碍境界者。一法体。二法境界体。三正得与众生。四正求与无量门。后方牒释。今疏四中文皆三节。一牒经举论立名。二谓字下是疏释论。三故论云下。举论牒释。今初法中论牒释内。以色从缘集非定断常。故离二边辨俗异真。云生法所摄。即二执所依之法言如色碍相者。正出法体。二义中第三段内。文曲有四。一举论牒释。二然得此下。远公释论。以法为俗以义为真。应有问言。法义不同何以论文。皆有远离二边生法所摄故。释意云。随顺观察世谛即入第一义故。三上即远公下。疏成远公义。四亦可下。是疏别义。于中二。先正释。后言如实下解妨。妨云。若义亦俗谛何名如实。答云。约如事实。三词可知。四乐说中云正求与者。邪求不与。疏二广显中下。文前有三。初总释十门。二言十者下。列名略释。其十相名即是论文。谓字已下皆是疏释。三然十中下。总就十中释无碍义。言亦多以词说于法乐说说义者。如第七大小乘相中。法知一乘义知诸乘。词云说一切乘无差别。即同一乘。乐说云说一一乘无边法。即同说诸乘意。疏今初自相有四下。此别释。文三。初总标。次一生下别释。后此自相下总结。二中然论诸段皆有三节。一总列四名。二总举经帖。三重更牒释。疏文之中。以论三段一一别配四无碍义。今初自相。论总列名云。一生法自相。二差别自相。三想坚固自相。四彼想差别自相

疏。一生法自相者。论标名也。谓知色下疏释。世法集起故名为生。自相门中辨此生法。名生自相。下三例然。疏二义者。差别自相者论立名。谓知下疏释。即生法之中差别义也。十一处者。五根五境及法处所摄色也。上二义下。疏结前生后。然上诸义论无重释

疏。三想坚固自相者。是论立名。从起言下疏释。即论重释中意。论具牒释第三句。经云。是中不坏说者。随所觉诸相。随彼彼众生说法故。今疏中先释想字。言亦以慧心取彼二种相故者。总释。言慧心取者拣异凡想。一随自所觉诸法者。即论随所觉诸法相。二随彼下。即释随彼彼众生说法。从说无错下以经成论。从论经下会通二经

疏。四彼想差别者。是论立名。想义下。即疏释亦论重释中意。论云。次第不断说者。次第不息无量众多异名为坚固彼义故。疏文可知。令他爱乐亦乐说义

疏。第二同相中论亦三节。谓列名经帖重释。一同于前文中。初总标法义。二一一切法同相下别释四义。此初知法先论立名谓字下。疏释论无重释。二中从同生灭下。疏释论谓观无常下即论重释。论具云是中无常门入无我义中。第二同相。初智境界成。疏文有四。初释是中无常门。二得入下释入无我义中。三故无我下。释第二同相初智境界成。四是则下。疏以义结。若准推无常门入初无性。亦是不生不灭是无常义。今以经中法尚自性即是常也。义明生灭是无常也。故以无常生灭是无性。常家义用。三词四辩准此可知

疏。第三行相论亦三节。疏亦先总分法义。一生行相者。论立名。次现法缘下疏释论名。后设知下论重牒释之意。疏中有二。先取意释。论本文云。一一世现在世故。从故论云下。明引论释。释上一一现在之言。二已生下知义。先举论。后设知下疏取义释。具足论云。见过去未来世知现在世。彼菩萨智境界成。释曰。疏文分二。先正取意释。二是则下。结示上二。云何逆见过未知现在耶。见过去法谢未法未生则知现在。从未而生必当谢灭。三四可知

疏。第四说相约本释以分法义。即释法等。次随音随心以分词辩。别必带总皆合有说。前三略无。疏第五智相。疏文有五。一分法义。二定境体。三辨通局。四辨其相。五指其源。今初既以法比分于法义下。约说浅深分词乐说。比即类也。二然所知下定其境体。若例前后法比二智是所知境。经文既云以法智知差别不异。即是就能为无碍体。二谛为境。然法比约情智。二谛约事理。三又法比下辩二行通局。法比则通无碍则局。言故涅槃说者。证无碍智局。即第十六经梵行品广说四无碍竟云。声闻无四无碍。无三种法故。一者必须软语。然后授法。二者必须粗语。然后授法。三者不软不粗语。然后授法故。言声闻设有少故名无者。是通妨难。即彼经中迦叶菩萨难云。若声闻无者。何以如来说舍利弗等有四无碍。佛答意云。如四河入海。此之四河皆有无量水。而言等海者无有是处。即少故名无意也。次下又云。或得一得二三不得具四。故名为无。即其义也。从若就二智所观下。结成通局。非唯法比通于大小。今无碍智所观亦通大小。但能观无碍局大乘耳。即以法无碍智知法知境及能知智。名法智知差别不异也。下三例然。四于大乘中下。正明大乘法比之相。即是释文。于中二。先双标法。比二法智观如下。别释四相。论云。一现见智。疏中先释现见。后谓观差别下。释成现见所以。即论重释中意。然论经云。以法无碍智知诸法差别不坏方便。释曰。其不坏方便即今经不异。论重释云。是中法智者。知谛差别不异方便法智差别不坏方便故。释曰。其知谛差别。即释经中知法差别。二谛不同名法差别。言不异方便者。释不坏方便。从法智下重举经帖。故取意云。差别二谛同如不异。同如即是不异所以。二比智即观下。释义无碍。比智二字是论。即观下疏释。亦即论中重释之意。彼经云。以义无碍智以比智如实知诸法差别。释曰。此与今文颠倒论重释云。比智者。如实分别余亦如是比知。如实谛差别可知。释曰。以现所知类度诸法故。曰如是。疏中取意。其观前能观。如实分别之智。即如实分别。从类余下释论余亦如是。从类何等下征释。比智如实谛差别知故。为顺经中云差别如实故。如实在下差别即如实。正辨顺上二谛同如。了二谛如即如实谛。知差别耳。细寻易见。三欲得方便智者。即论谓字下。释证第一义名之为得。欲趣向证必假俗谛为方便故。论经云。以词无碍智以世智正见故。知说法。论重释中不释此句。疏以相见道释正见。言四得智。即论谓字下。取论意释。论重释云。第一义智方便者。非颠倒异。乐说应知。以论经云乐说无碍智以第一义智正方便说。故论牒之。疏中先释论非颠倒。次故云下。结以经帖。后可以证下。释论立名。疏余如下。第五指其本源。论则可知。回向即第六回向十六智宝处明。彼说三心见道亦有法类。一内遣有情假缘智。二内遣诸法假缘智。三遍遣一切有情诸法假缘智。前二名法智各别缘故。后一名类智总合缘故。有说。十六心见道。自有二义。一依如智。二依上下谛。并如前说。然有部则时通处别。现智知于三世之法。名为时通。比智亦然。现智唯知欲界之法。比智知于上二界法。名为处别。若依经部成实论明。则处通时别。二智通知三界。名为处通。法智知于现在。比智知于过未。名为时别。成实十六无边空处品中问。此定能缘何地。答此定缘一切地及灭道。问曰。有人言。诸无色定虽能缘灭。但缘比智分灭。不缘现智分灭。是事云何。答曰。缘一切灭。以现智缘现自在地灭。以比智缘余灭道。亦是能缘一切。释曰。现智即法智也。若依深密相续解脱经时处俱非定现见。见法名为现见智。知他方及他世名为比智。又更分别于一切现所知名现智。类度解者名为比智。故不可时处定也。俱舍即当第二十三。大同唯识。观上下谛一十六心偈云。世第一无间。即缘欲界苦。生无漏法忍。忍次生法智。次缘余界苦。生类忍类智。缘集灭道谛。各生四亦然。如是十六心。名圣谛现观。此总有三种。谓见缘事别。释曰。从世第一法无间。即缘欲界苦圣谛境。生无漏法。名苦法智忍。苦忍无间缘欲苦谛。次生法智名苦法智。此智无间次缘余界苦圣谛境。有类智忍生名苦类智忍。此忍无间即缘此境。有类智生名苦类智。如缘苦谛。余三亦然。有十六心言苦法忍者。苦是苦谛法忍。缘苦法名苦法忍。果是等流智唯无漏。为显此忍亦唯无漏。举后等流以为标别。故忍名智者从果为名。如苦果树树非苦果。从果得名。故云智忍余可例知。言现观者。现前观圣谛故。言有三者。一见现观即无漏慧。见谛分明故。二缘现观。此无漏慧及慧相应心心所法。同一所缘故。三事现观。谓前相应及余俱有同一事业故。余俱有者。谓道共戒及生等四相俱有因。故名俱有也。余广如彼。疏第六无我慢中。言约真俗者。通就三乘二谛明之。故世谛中历三乘法词及乐说。但总别分之。疏迷蕴著积聚我者。以聚生门种族是蕴处界义故。迷积聚为蕴。谓有我人。亦谓聚色以为色蕴等。次言迷界着异因我者。约法我说六根六尘生识。正因因各异故。有此法我若外道计中。有人我以为异因。使知尘等。言迷处着欲我者。迷于六入。根尘相顺眼见色等。遂生贪着则有法我。或谓神我于中能着。犹如一人在于六向见色闻声等。言迷谛等者。迷于四谛十二因缘。皆谓以因能作果故。人我可知故。疏双结。并是法我亦通人我

疏。今随顺下上辨所遣之病。即是我慢。此下辨能遣之药。即是无我观世缘生故无有实。无实即实为第一义故。上六地论云随顺观察世谛。即入第一义。从故蕴界等下。结成蕴等为智之境。第七大小乘相者。知实为法知权为义。会三归一为词。开方便门为乐说。言唯一事实者。即法华第一云。唯此一事实。余二则非真。二中顺机说权即是义意。三中三乘同归一实者。亦第一经云。舍利弗。当知诸佛语无异。于佛所说法当生大信力。世尊法久后要当说真实。告诸声闻众及求缘觉乘。我令脱苦缚逮得涅槃者。佛以方便力。示以三乘教。众生起处着引之令得出。又第三经云。汝等所行是菩萨道。渐渐修学悉当成佛。三周之经。皆是会三方便归一真实。言解脱相中无差别者。第三经。药草喻品云。如来知是一相一味之法。所谓解脱相离相灭相究竟涅槃常寂灭相。终归于空。即解脱中无差别也。又第二经云。但离虚妄名为解脱。其实未得一切解脱。则一切解脱三乘同归也

疏。法华云下。释成上论。亦方便品先有一偈云。舍利弗。当知钝根小智人着相憍慢者。不能信是法。释曰。此偈则明如来有畏。畏其谤故。次即云。今我喜无畏。于诸菩萨中正直舍方便。但说无上道

疏。即开方便门者。开方便有二义。一于一佛乘分别说三。名之为开。即初施权故。信解品末云。随诸众生宿世善根。又知成熟未成熟者。种种筹量分别知已。于一乘道随宜说三等是也。二开者。开除开发故。第四经云。此经开方便门示真实相。斯即说三为方便名之为开也。然皆为一事下疏是也。第一经云。我此九部法随顺众生说。入大乘为本。以故说是经。亦即长行中云。诸佛世尊唯以一大事因缘故出现于世。又云。舍利弗诸佛如来但教化菩萨。诸有所作常为一事。唯以佛之知见示悟众生。即其文也。故引论明随顺解脱。即方便多门皆顺解脱也。第八菩萨地相者。说地体为法地相为义。三词者。说相不违体。四乐说者。说相随机。此之体相即证教。二道亦即前义说。二大亦即不可说及可说义。总收一品之意。广如本分及请分中

疏。一智相下。即前释法无碍。上句论标名。从一切下牒经解释。有两重征释。何者下此微法体。即经法行智行。后征法智何以名菩萨行。答意可知。故经云下双举经论以帖。言论云观智说者。论具云。是中一切菩萨行者。法行智行是现观智说故。疏斯则异前。义大者显义无碍。即是说大。前法无碍是义大也。三中巧说十地者。释方便言。从授与众生下。释无差别言乃有二意。一称机不倒为无差别。二不违证道为无差别。如鸟迹合空。疏九如来地相中。以始本无二释一念者。以起信云谓一念相应慧无明顿尽。名一切种智。言一念相应者。即始觉与本觉相应故。彼论云。如菩萨地尽满足方便一念相应故。觉心初起心无初相。以远离微细念故。得见心性心即常住。名究竟觉。正是始本无二相也。次上论释本觉竟云。何以故本觉义者。对始觉义。说以始觉者。即同本觉。又云。若得无念者则知心相。生住异灭以无念等故。而实无有始觉之异。以四相俱时而有皆无自立。本来平等同一觉故。故以始觉同于本觉。无复始本之异。为一念相应。亦是一念顿觉一切法故。故净名云。一念知一切法。是道场成就一切智故。余并可知。第十作住持相中。约就能所以分法义。亦是总别。总知如来所转法轮名法。别知八万四千差别为义。而前意义长故

疏。但举一意词及乐说同体义分。依前法义起说名词。词中差别说为乐说。疏随自意等者。论主但云语者能说法故。疏以涅槃意明如来说法不出三语。即三十五迦叶品中因说。若言众生定有佛性。名为执着。若言定无是则妄语。便云。如我说十二部经。或随自意语等。初会已引。今更略示。如五百比丘各说身因问佛。佛言我为欲界众生。说父母以为身因。结云是名随自意语。次云。如答把吒长者问。瞿昙知幻应是幻人。佛乃反问汝识王舍城中气嘘旃陀罗不。答云我知。佛言。汝知旃陀罗。而非旃陀罗。我知幻者岂是幻人。结云是名随他意语。次言世智说有我。亦说有世智。说无我亦说无。是随自他语等。十力已下转法轮之德。言上皆一切智智下结释经文。是佛现觉故为说德。第三法师成就。于正显中二。初一总科。二则前下料拣。于中三。一二分分别。二又前下对释标文。三于此下摄位分别。疏今初先列下文三。初总出意。次初三下总科。后一义持下别释。然以人望法十皆所持。约三业中亦有能所。初三意中义教所持。三是能知身业。三中通能所摄。而初二以正报摄。后一以依报摄。后四口中七以教摄。八以辩九十所说深广。九无尽乐说深说者。深约契理何有尽时余可知。第十法云地。初来意有三。初引瑜伽。唯摄第九于中先明九地所能。次而未下明前地不能。则是举劣显胜。后今精勤下显此地之能。即举胜拣劣。二论云下引本论通摄前九。故云于九地中非第九也。已作净佛国土即第八地。及化众生即第九地。既通前九而偏语八九者。后三通无功用故举拣异。又八多约身。九多约口。今云智满多约意业。故胜于前。言智觉满者。智度圆故。菩萨地尽故。三又一乘下。唯对后三。以后三地皆一乘故。亦成前义。疏次释名下文分为三。初总标。二云者下开释。三然诸释下总结。二中四。一释云。二约法下释法。三空亦下影出如空以标名。虽无释有空故。四摄大乘下。以诸经论释上空云。总有九释兼摄论。三义成十一义。一引摄论。二金光明。三唯识。四瑜伽。五无性。六真谛。七庄严。八十住。九重引瑜伽。今初摄论释有三义。此即第一义从此喻含水义下疏释彼论。此句即疏从总缘一切下。无性释论彼释具云。由得总缘一切法智总缘一切契经等。不离真如。此一切法共相境界智。譬如大云陀罗尼门三摩地门。犹如净水智能藏彼。如云含水。有能生彼胜功德故。释曰。共相境智者。云与空合如智与境冥。又共相即是总释之义。今疏取其要言。释彼本论义已尽矣。疏又云。譬如大云能覆下。即摄论第二义。从此喻覆空下。疏释彼论。从即以前智下。取无性意释。彼释具云。又如大云覆隐虚空。如是总缘一切法智。覆隐如空广大充遍惑智二障。言覆隐者。隔义断义。疏又云于法身下。摄论第三义。从此有二义下。疏释亦取无性意。无性释此云。又如大云澍清冷水充满虚空。如是总缘一切法。智出无量殊胜功德。充满所依法身。释曰。彼言虽多疏以收尽。次四可知

疏。真谛三藏下六引真谛。于中先言虚空喻三法身者。譬如虚空空有三义。一容受义。譬如自性法身不碍生死。二无边义。譬如显了法身。谓虽得显了犹未究竟如空。有清净处有尘雾处。如道内法身遍解惑中道也。三清净无尘雾义。譬如圣果法身。言云喻三道之智者。即智慧如大云。譬如如智有其三义。一道前性得。二道内修得。三道后至得。文言遍者。性得如如智遍如如理。满者修得如如智满如如理。覆者至得如如智覆如如理。境智相称云即是雨。雨有三义。一能除尘。谓道前自性智清净无染义。二能洗垢道内灭除恶业。三能生萌芽。道后能生如如萌芽。又虚空如法身云如应身

疏。此法喻亦齐下。二疏断得失。先取。后似非经意下夺之。谓若如上释。道前应得法云之名。名既此立故。似非经意而言似者。以约理可通故。谓道前虽有云义。三义未足不得此名。十地位满方得名耳。此则可通故云似也

疏。庄严论下。七引庄严。先引论。此从法下疏释。十住论第一瑜伽又意下。第九重引瑜伽。先举论。从是则密云不雨下疏释。即周易小畜卦语。易云。小畜亨密云不雨。自我西郊。彖曰。小畜柔得位而上下应之。曰小畜健而巽。刚中而志行乃亨。密云不雨上往也。自我西郊施未行也。释曰。彼况文王当纣之时。身为西伯有君之德。犹如密云。未有君位德未施行。犹如不雨。今况十地含佛之德。未等正觉故云含德而已

疏。所覆下即第三离障。于中四。一标。二谓于下能障名体。三此障下所障之业。四斯即下。断愚证理成行得果。文并可知。疏第二正说中。疏文有二。一依论总科便以疏释二。后之二分下。料拣于中三。初料拣论次。若依前下以经对论。后六中下对于三心

疏。即九地自分行者。则显后二相是胜进行

疏。真如是佛行处者。今此九地入向十地。何名入如来所行。答十地同佛境相应故

疏。七地尽至入相者。即经名为得下。经文十地学穷名为地尽。依行得证说为至入。第二三昧分别中。九定离八种垢者。六七合故下。疏一一结之。若从上科八中前七自分后一胜进。前中前六自利。后一利他。前中前五法身行。后一摄净土行。前中三。一解二行三成德

疏。不与惑俱者。释无垢义。然就总开别皆带无垢。无垢即不与惑俱故。初句示其带。总云不与惑俱。疏下三成德者。即身口意密也。初放光中疏双就身智二光。正意在身

疏。上句无量则尽法界之疆域者。即经虚空界广大三昧。此同自受用刹。下句穷国土之体性。即法性土此能穷究。第三受位分自有十相者。文中法喻合结。一如世之华上者。为主菩萨之华大宝故上。二广大为量。三事则众宝间错故胜。法则众德为严亦如上说。有同时具足相应广狭自在一多相容等德故。四法界智地为生处故。五因如种植。六成如出水。七第一相。然华有三时之异。一华而未敷。二处中盛时。三雕而将落。今非初后正处中盛时。正观普照等彼流光。法界现事如开。菡萏披敷见莲华实。双美事理昭著权实开荣。八世之莲华人德感故。今此之华出世德感。九琉璃为净栴檀为乐。玛瑙为我檀金为常。四德为体。十智光圆照照如来藏。教网遐张为庄严也

疏。同声相应者。即周易乾卦文言之语。易云。同声相应同气相求。水流湿火就燥。云从龙风从虎。圣人作而万物睹。本乎天者亲其上。本乎地者亲其下。亦各从其类也。今取同位故曰同声。同谓何能有相益。显如世朋友互相成益故下。彼光照此此增智力。今此照彼益彼何疑。疏若约教相者。显有二意。前约教相。人之所贱莫过于足。人之所贵莫过于顶。顶光入足故。显敬深。二若约证下自有二意。文乃有三。一顶光入足。显此菩萨入他佛境。二故论下引证。三显证佛境。即自证故者。是第二意入自佛境因圆趣果故。论言平等摄者。此有二意。一如来下摄足收其光。菩萨上摄光入佛境云平等摄。二入他佛境即入自境。自他佛境无二体故云平等摄。是以处中引论。证上证下第一平等。下疏自具而约二光以明相摄。谓菩萨顶光入足。佛光入顶。今但入足已显相摄。余可知也。第四至同声相应文中有四。一总显相应之由。二表内下释德相放光之由。三又上下对前会释。四德圆下释光名号。疏。于中十业者。以文显故。疏不指经。若欲指者。二无数下是。三示现下。四开悟下。五周遍下。六灭除下。七隐蔽下。八示一切下。九如是下。十示现下是。疏若约化相者。疏但有二。初身光入菩萨色身之顶。但为化相。即上收下就实约义。中曲复有二。一约相显实。即诸佛智光入菩萨心顶。二直就实论。自智已圆当成之果显在心源。是故结云果成在已。论云下引证。谓菩萨下疏释。言亦因收果者。上义佛果下收菩萨。今菩萨顶收得佛光耳。上释迭互摄受入则下释平等摄受

疏。初喻随何身者。即经云如转轮圣王所生太子。母是正后身相具足是也。然论经云玉女宝所生。准智论玉女宝不生。乃是一说。准萨遮尼犍子经第三云。千子皆玉女生。彼名夫人宝余则可知

疏。随所得位者。然论释云。此菩萨同得位时名为善住。远公有二释。一明同上王子得位时。二同佛得位时

大方广佛华严经随疏演义钞卷第七十二大方广佛华严经随疏演义钞卷第七十三

        唐清凉山大华严寺沙门澄观述

第四大尽分中。文前有四。一依论科。二此五依下论释义。三前二下料拣。四文中下辨经义。二中五义之内义字向上。皆是论文。义字已下即是疏释。然前二离惑智二障。成心慧二解脱。后三利他即是三业。一意二口。虽云意持正在口说。三即身通。今初集智下。疏文有四。一总彰大意。二文中下总科。三然通真妄下总辨义类。四在文六重下对文收摄。今初。然论中文有三节。一总立七名。谓一集智大等如向疏引。二总辨七智之所依起。略显其相。三总释七智之相。今疏文中分为七段。一一智内皆有三重。如今集智云今初集智。即第一列名。二依能断疑力。即论第二依起之一。三了法缘集故。即论第三段释义下之六智。皆具此三。然远公释缘集云。统唯一种。或分为二。一妄缘集。三界虚妄唯一心作。如梦所见但是心解。二真缘集。一切诸法皆真心起。如梦所见皆报心作。或说为三。曲有三门。一真妄离合为三。离为前二合为第三。第二约心识论三。一事缘集。从事识起一切法。二妄缘集。从其妄缘起一切法。三真缘集。真识体中具过一切恒沙性德。互相集成故言缘集。又从真识起一切法故。经说言。若无藏识七识不住。不得厌苦乐求涅槃。由如来藏故起诸法。三就有为无为说三。一即有为缘集。二无为缘集。三具二缘集。并如六地已说。三摄以义类。即前三中第一三也。四中在文。虽六不出前三。收摄已竟。释义已周。一唯染中已摄六集。二有七集。三唯一集。四有三集。五唯二集。无为有三虚空已别说竟。但二无为。一净二灭。涅槃有四。余无余及与无住。皆约修显故。得称净。六唯一集故有二十也。第六段中四。一标通三。二故论下引证。三以法界下疏释。顺上善法界为净。不善法界为染。无为法界为灭。无为与善为正。不善不正。四而论诸句下会释论文。然上以其三事开合故为六段。而文不次。又今经与论经次亦小异。若依今文辨次第者。然望论经论经阙二。一无世界集。二无最后入一切法分别决定智集。彼意为世界即世界成坏。将后入一切法集。属于总结故。但十八并结十九。今为世界是总。通佛众生如世界成就品。通有唯成无有坏义。成坏之刹唯属众生。彼次与此亦小有异。以法界居虚空之后。众生识界居为无为前。且依今经以辨次者。先明三界通于依正。总辨众生所依。次云世界通于染净。次辨法界向上为上四所依。向下。与为无为等而为所依。法界是总以性从缘。则有为无为。众生是能迷之人。识界为众生之本。虚空是众生等住处。涅槃是众生所归。烦恼是能迷之因。行兼于业则显前皆是果故。此句初有此菩萨言。由烦恼因感界成坏。次三辨反源之人。如来下四辨反源之果。结云一切者。非止二十故也。第二应化智。亦具上三。谓一列名。二依起。三释相在文分二。先标名总科。后别中十句下随文别释。前中即将蹑经前文。释论第二牒所依起。其第三释义易解不举。论云是中应化智者众生应化等差别。远公云。然化有三种。一据始起有分别心。而作变化。二就息想论。物见我化我实不化。三就真实说。缘起门中皆是真实作因。法门之所示现。今依后义。是故前缘集智而起化用。第三加持智中。文亦具三。初牒经立名。二论云下辨所依起。三谓依彼下疏释论依起。便是第三段中释义。常化不绝为加持故。即以不绝是转义。如转法轮

疏。初三不断三宝者。不断是三宝中持义。谓佛种不断即是佛持等

疏。愿等因体者。望上时持故名因体。就体有二。愿是起行方便之心。供养及行即依愿。正行供养摄福行摄智故。第四微细智中文三。一牒经标名。二谓智下解义。三故论下蹑前辨依起行中。先举论。后谓依前下疏释。言三智者。一应化。二加持。三善集。即前缘集智所以合者。集智是智应化是悲。悲智无碍为佛微细。疏非但八相。一具余七者。但应化一智。即能令一而具一切。今一一事皆具三智故为微细。以如来证此法门故。别有十事多同八相。八相不具第五密处智。文中有四。一标名。二依护根下辨所依起。三现粗下释秘密义。四初三下释文。文含多义。前诸疏文已皆具矣。第六入劫智文有五。一标名。二依命行下举论依起。三谓劫下疏释论含于入劫之相。四亦十世下结成玄门。五以得下出即入所以。第七至入道智文中有四。一标名。二论云下依起。三谓遍入下疏释依起。四别中下释文。三中显前标名具于三义。一明知凡夫道。道谓业惑以逆顺等皆所知故。二若约下知化凡夫道。谓一切善法论名对治。即顺字摄之。及第三知化凡夫即是佛道。文正出此。四别中总句义通三义。别显三种中。前二皆第一知。凡夫道其中观破抟聚者。四十八经当具解释

疏。次四句能化之行者。即化凡夫道。亦兼第三知凡夫道。即是佛道。后四化果其中思议等并如九地。第二解脱下总有四对。疏中已配义并可知。第五释名分。疏今此一段从所受立名下。此文有三。初此上拣别。二引论释。三谓佛身下疏释论。然此一段若从所受应名法雨地。若从能受应名法海地。今从受处名为法云。云当佛身而论意。又以闻法相似犹如虚空。则以虚空为能受。菩萨身遍覆故。云为所受之法。以云义多含故论影出之。疏由前七智等者。七智正是此地别行所以举之。成就念力偏语受法之德。此智实成下释经随顺无量菩提之言。由因成果就故云随顺无量菩提无量之德皆随顺也

疏。上二句性故者。论一时具云闻法者。性故作故二事示现

疏。离破之谓三慧下。疏释论大法明下。牒论释经。然今经云安受摄持。论经云受堪思持。思即是摄。堪即是安。受堪虽倒俱是闻慧。疏取义顺经不违论释。余并可知。第六神通力有上无上分智慧明达。即起通之智者。经但两句。论经亦但云住此地于智慧得上自在力善择大智神通随心所念。而论云。是中依内者有四种。一不思议解脱。二三昧。三起智陀罗尼。四神通如前所说。释曰。今疏取意。各别配经。亦具此四论。言如前所说者。即大尽分中五种大。但合智及陀罗尼耳。以陀罗尼智为体故。此之二段者。即以转变外事为神通自相故。疏无所不融故能一身包含无外者。此金刚藏正用前作住持相中。于其身中示有无量国土庄严之事。及于自身示现佛身。疏此中亦即大尽中事者。前文标中已有五大。今复结之。故云亦是。谓初总标三业。即神通自在余具五大。一观察三世。即第一智大。二三昧境界。即第三三昧大。三智慧境界。即第四陀罗尼大。四游戏一切下。即第二解脱大。五变化下。即第五神通大。疏问中即举菩萨疑佛者。谓信菩萨神通谓佛应不胜。前举佛疑菩萨则谓佛得。亦疑菩萨不得故问同意别。疏第二乃至说法断疑等者。文中有三。一正显断疑。二然此下文下会释经文。三若准下依经解释可知。第八地影像分。于中分二。先总料拣。后正释文。前中有三。一约二道分别。二约修显分别。三非一异分别。初即论意。于中三。一依经标名。二前二下以二德收之。三依论列释。二中远公前三皆阿含。今以海喻十德互遍故喻证德。此二教证亦可隔句相对。池望于海是修成相对。地中真伪合修为教。如池喻起修之行。海喻舍妄契真。实德互遍犹如义大。第二小喻第四珠喻。即约诠就实。相对寄言显十如。彼十山为教智。真体无二如珠更含。余义略示其一

疏。前中池喻下。第三依论列释标功德名。皆是论文。余皆疏释。然下论随文释中。亦自解释。释第一池喻云。依本愿修故。释第二山德云。依一切智增上行十地故。释第三海喻云。因果相顺故。今十德遍海。即因顺于果海揽十德即果顺于因。释第四珠喻云。过十宝性即障尽证坚

疏。又十地有三者。第二修显分别。以修成法三而收四喻。前二是修故亦是教。次一是成亦顺于证。三是法地顺佛果海故。以海喻融前二也。前二即是修成含池山珠之三喻也

疏。又此四喻下。第三非一异分别。于中四。初约因果明非一异。二约前后。三结成圆融。四结示本意。今初分二。先总标。后初一之下别显。池非是海故云始异。入海即池之水故云终同。同异先后即始差别终无差也。二出喻一佛智地出十地山故。云无差之差。上二下结前生后。三海则因果交彻。四珠虽一证智不碍分十

疏。又初喻前后体别下。第二约前后论非一异则十地相望以为前后

疏。初一即是圆家渐者下。第三结归圆融。此言自天台生。而小不同。彼处渐圆是渐教家圆。今亦圆教行布之极耳。圆圆亦与彼不同。乃是初后圆融名圆圆。非圆教圆满名圆圆也。是知上取相显。前二喻教后二喻证。理实四喻一一之中。皆有教证。如珠喻体即证治穿等教。池初四河即是于教入海为证。故约非一皆是教道。约非异义皆是证道。又非一非异二义不同。即是教道互融为证。勿滞语言

疏。上来所解下。第四结示本意。言上来解者。唯除四喻。喻四功德余皆疏意。故云在论虽无

疏。今初修行德中下释文。然论但云是中修功德者。依本愿力修行以四摄法作利益行。自善增长及得菩提自利益行。应知。次论牒经帖义文意可知疏第二总以喻显中。然此十山与俱舍论多同小异。彼偈云。苏迷卢处中。次踰健达罗伊沙陀罗山揭地洛迦山苏达梨舍那頞湿缚羯拏毗那怛迦山尼民达罗山。于大洲等外有铁轮围山。前七金所成苏迷卢四宝。释于梵名如升须弥山顶品。然须弥处中。次七金绕轮围。第九今有十山为次。又别为顺十地所出异故。一雪二香。俱舍九中所无。三鞞陀梨陀梨亦云驮罗。下偈复云毗陀。则正当第三伊沙陀罗。此云持轴。与种种持义亦大同。四神仙应是第五苏迷梨舍那。此云善见以仙居故。五由乾陀罗。即第二持双。六马耳全同第六頞湿缚羯拏。七尼民陀罗全同第八。彼却无翻。但约形名为鱼嘴。八斫羯罗同彼第九。九计都末底义同揭地落迦。彼亦无翻。但说其相故。论经名众相山。十苏迷卢全同第一。既加香雪应除象鼻。三藏楚夏既各不同。言词轻重难为克定

疏。第三法喻对显中二。先明山体。后若语下辨其所有。于中二。一直辨所有以况于法。二论以义拣。今初文并可知。但计都山并大力修罗处者。准经论说。修罗总有五种住处。一在地上。一最居下。最居下者。在于海底。即毗摩质多罗阿修罗王。其力最大统领无量修罗眷属。次上二万一千由旬有阿修罗王。名曰勇健威势次劣。亦统无量修罗眷属。次上二万一千由旬有修罗王。名曰花鬘威势转弱。亦统无量修罗眷属。次上二万一千由旬有修罗王。名曰罗睺势力最劣。亦统无量修罗眷属。今此所说应是彼王。最居上者

疏。论云前三下。第二论以义拣。于中二。先举论释喻。后论但显喻下疏义释。今其四地道品即第一治贫穷。五地即第二治死。七地即第三治俭。八地即第四治不调伏。九地即第五治恶业。十地即第六治修罗。并可知。疏二互相显者。前意但因依果。今则互依于中有四。一正明互显。二论云下义引海喻证。三前言依地下会违。四又地则但依下拣二别相。相别有三。一但依兼入别。二又山在海下显非即离别。三又山出海下等不等别。疏合中总云下疏文分四。一顺释不夺。二若夺下反以成立。三喻中下会通法喻。成俱不夺。以喻中云得大海名不可移夺。明约果也。法合则云名菩萨行不可移夺。故知约因。四故论下别引论证成。由经影略故论双明。然论具云难度能度大果功德者。因果相顺故十地如大海难度能度。得大菩提果故。今以言拣之故论易了。然上说有三种地。一修地。二成地。三法地。今明相正顺在后二度即到也。疏以深广故者六深七广余可知。然涅槃三十三明海有八德。一者渐渐转深。二者深难得底。三者同一碱味。四者潮不过限。五者有种种宝藏。六者大身众生所居。七者不宿死尸。八者一切万流大雨投之不增不减。释曰。彼经通喻佛法广有合相。今喻次第喻于十地。故加至十不同彼次。疏第四宝珠喻中合于十宝者。八辈为八缘觉果行为二。总成为十。缘觉根利不数入观故。无多果依学无学。但分为二。无利生用者。合不能出宝。下引论出故取者。正证出宝兼出海义。疏一出功德。论具云一出功德选择而取以善观故。疏已折开解释。大文第九利益分。供养功德者。非谓供养能生功德。显此法胜能令供养。是地功德上生信亦然。疏然闻有二义下。疏文分二。先正释顺明不取闻相。即涅槃经云。若有闻经。不作闻相。不作说相。不作句相不作字相。如是一切乃为闻经。释曰。此称理而闻如前已引。从初后圆融。即此经意。言等佛者此经说佛智慧观境。今能正闻如彼真观故云等佛。疏闻已等佛下通妨。先妨。后若更下答。亦由一多无障碍故

疏。第二动地者。然准论经云一动。二踊。三上去。四起。五下去。六吼。远公释云。上去是令人觉。下去谓振下。如世虚物振撼。余如华藏品。余文可知

    十定品第二十七

疏。谓前明普门中所具差别正位等者。此中意有三节。初第二会为所依普门。次四会即普门差别。此会即会别归普。初即根本。次即依本起末。后即会末归本故言重会普光。意在斯矣。言等妙二位全同如来普光明智者。结成人普所以。以此会说等妙二觉二觉全同普光明智。即是会归之义。问等觉同妙觉于理可然。妙觉之外何有如来普光明智。为所同耶。答说等觉说妙觉即是约位。普光明智不属因果该通因果。其由自觉圣智超绝因果故。七卷楞伽妙觉位外。更立自觉圣智之位。亦犹佛性有因有因因有果有果果。以因取之是因佛性。以果取之是果佛性。然则佛性非因非果。普光明智亦复如是。体绝因果为因果依。果方究竟故云如来普光明智

疏。二约次第等者。疏文分二第一正明次第。二以极果下释妨。于中二难。一释重会。二通蹑迹之难。今初谓有难言。若次第明位何以重会普光故。为此通。后谓前依本不动下。显其所以。何以极果由于始信。信依本智而起。今不离本智故。斯则以因成果。摄果酬因。然因有二种。一约本有恒沙性德。信解行愿等无不具故。二约修起。谓依本信德而起信心。依本解德而起解心。如起信云。以知法性无悭贪故。随顺修行檀波罗蜜等故。一一修起皆带本有俱来至果。无间道中一时顿圆。解脱道中因果交彻。名为得果。果亦有二。一者本有菩提涅槃。一切佛法本觉具故。二者修起今证菩提始觉悟故。始觉同本无复始本之异名究竟觉则二果无碍。然二因本从本觉体上起来。则二因与本觉无碍。始觉既同本觉。则二果全同于二因则二因与果交彻故。因该果海果彻因源。故今重会普光。表斯玄趣。问若此交彻即是圆融。何名次第。答虽带本有起因。因亦次第。先因后果。得果虽该于因亦成次第故。得果后方说融前。前圆融中若因若果并是普光明智差别之德。别常依普不相舍离。说有前后成在一时故不同也

疏。后出现因果下。二通蹑迹之难。谓有难云。极果由于始信。重会普光极果之后何得更有平等因果。故为此通。明此因果皆属极果。故不违理。疏品以普贤三昧无碍自在无边大用。而为宗趣者。不同前文宗趣。别说者有二义故。一者例前。令物证入为趣二者令诸菩萨亦得无碍自在无边大用。而为其趣。则此疏文通宗通趣。疏正释文下文分二。先总科因果。后别显因门。前中亦二。先正科。后然六品之因下解妨难。此有二难。今初正通重会之难。谓有难云。若约差别因果者。因因不同。因与果异。如何等觉之因与妙觉果。同会而说。故今答云。若约差别不合同会。有圆融义所以得同。故云若约圆融等同果相故。疏果是对因下。二有难云。若尔因是圆融可同果会。果是差别之果何得同因会。耶。故今答云。只缘是差别果对因说果。是相待之果劣故同因之会又复难云。对因之果劣故同因之会。平等因果因果俱胜何同此会。故今通云。平等因果由差别成。若无差别平等无依故须同会

疏。今初此因下。第二唯显因门。但释六品。疏文分三。初总彰大旨。二引教成立。三决断有无。今初以诸古德不立等觉。故案定有。疏是以诸教下。二引教成立。虽有开合疏意扶开。故下结云有等觉明矣。引二经一论文有二节。二经一开一合。一论具于开合。说六种性及六坚六忍等者。即彼经第一品。当第三贤圣觉观品。经云。佛子六种性者。是一切菩萨功德璎珞庄严。菩萨二种法身。菩萨所有百万阿僧祇功德行璎珞。若一切菩萨不入璎珞功德门得入正位者。无有是处。佛子六种性者。所谓习种性性种性道种性圣种性等觉性妙觉性。释曰。一习种性即十住。二性种性即十行。三道种性即十回向。四圣种性即十地。五六可知。复名六坚者。谓信坚法坚修坚德坚顶坚觉坚。顶坚即等觉。觉坚即妙觉。言六忍者。经云。复名六忍。信忍法忍修忍正忍无垢忍一切智忍。而言等者等取六慧六观。经云。复名六慧。闻慧思慧修慧无相慧照寂慧寂照慧。经云。复次六观。住观行观向观地观无相观一切种智观。亦有相承说于六定。璎珞无文。言六定者。一习定二相定三性定四道慧定五道种慧定六大觉正观慧定。此五种六皆以第五当于等觉故有明矣。疏论复有文亦立等觉者。即第五十论明百四十不共佛法。约因果位辨差别中云。若时菩萨坐菩提座。住最后身。于菩萨道菩提资粮极善圆满。尔时无师修三十七菩提分法。得一刹那名无障碍智三摩地。是其菩萨学道所摄金刚喻定。彼疏云。此明因满菩萨位中最后位也。此位亦名等觉菩萨。论从此无间第二刹那。顿得其余不共佛法。谓如来十力为初。一切种妙智为后。皆极清净悉得无上彼疏云。此彰得果。释曰准此论文。于十地后起金刚喻定一刹那中。名为等觉。第二刹那为妙觉也。故说八义与佛不同。论云。问一切安住到究竟地。菩萨智等如来智等。云何应知。此二差别。彼疏云此初问也。论云。如明眼人隔于轻縠观众色像。一切安住到究竟地。菩萨妙智于一切境。当知亦尔。如明眼人无所障隔睹众色像。如来妙智于一切法。当知亦尔。二如画事业圆布众彩。唯后妙色未净修治(云云)如画事业圆布众彩最后妙色已净修治。三如明眼人于微暗中睹见众色。如明眼人离一切暗睹见众色。四如明眼人远睹众色。如明眼人近睹众色。五如轻翳眼观视众色。如极净眼观视众色。六如处胎身(云云)。如出胎身。七如阿罗汉梦中心行。如阿罗汉后觉时心。八如昧智体如明智体。释曰。其云云下。皆前配菩萨后配如来。唯第六喻改妙智字为一身字。第七喻改智为心。八改灯为智体。余五皆如初句。彼疏释云。初之五喻约二智用以辨差别。第八一喻约二智体以明差别。第六七喻如次身心以辨差别。观前五喻义通生法二智用故。等觉之位第八识有漏故身亦然。义同处胎。即五八识有漏虚妄义同在梦。论曰。是故当知一切安住到究竟地。诸菩萨众与诸如来妙智身心有八差别。又瑜伽论菩萨地。更有一文。言劣无漏者。唯识第十释转依中名所弃舍。谓劣无漏种。即第十地中所生现行。金刚道中方能舍故言未舍。白净无记者。即异熟识第八地中舍赖耶名。第十地中犹名异熟识。至如来位方舍异熟名无垢识。三由未舍有漏善法者。即与二障种俱。其二障种是所断舍

疏。今经欲显开合无碍下。第三决断有无。言故存其义者。即六坚固法已是有文有义定矣。下第十三昧广说等觉之相。云此菩萨住此三昧得十种法。同去来今一切诸佛。何等为十。所谓得诸相好同于诸佛等。普眼问云。若此菩萨得如来法同诸如来法。何故不名佛。何故不名十力。何故不名一切智等。亦有十句。普贤具答云。佛子此菩萨摩诃萨。已能修习去来今世一切菩萨种种行愿。入智境界则名为佛。于如来所修菩萨行无有休息。说名菩萨。如来诸力皆悉已入。则名十力。虽成十力行普贤行无有休息。说名菩萨。知一切法而能演说。名一切智。虽能演说一切诸法。于一一法善巧思惟。未尝止息说名菩萨。知一切法无有二相。是则说名悟一切法。于二不二一切诸法差别之道。善巧观察展转增胜无有休息。说名菩萨等。下引伊罗钵那象王。为供帝释化身上天。或舍象身现作天身。无能分别是象是天。象之与天更互相似。此等觉义岂不昭然。更有余文。恐繁不引。疏二十一种功德要寻升兜率品。自当晓之。然此段文。亦是古德所不能知。今以摄佛功德释之。有如符契智者当晓

疏。所以此中特名入刹那际者有三。一总征说意。前后叹德皆无此故。二为显下正酬所问。三菩萨地尽下释刹那际。然有二释。今初以本业起信参而释之。菩萨地尽是起信文。义通二处。言唯有果累无常者。即本业下卷经云。菩萨尔时住大寂门中。登大山台入百千三昧证佛仪用。唯有果累无常生灭二心心心无为行过十地。解与佛同坐佛坐处等。释曰果累无常生灭者。未转依位变易生死。名为果累体。是无常有生灭也。言生相未寂者。即起信意业相未亡也。犹名识藏者。亦起信意未显现法身故。上辨等觉尚有刹那。未至其际。从若以无间下释成际义。刹那尽处名之为际。故云即无刹那。亦起信文前已曾引。若入此下释诸佛三昧。亦起信文。应有问言。上云菩萨地尽是等觉者。何名诸佛三昧。故引此文。成诸佛义

疏。亦显前来差别下是第二义。上约合前后无际。今明后际不离初际。是穷生死之本际。第四本分初十句明上等佛果者。亦是等觉之义显矣。然一品始末等佛义多。初定文易可知。第二定明重现无尽喻。菩萨帝网身土者。古德立帝网义。经有帝网之名而无广说之处。以昔未有此品经文。故此一段文诚可证也。疏于诸世界下释其所以者。释上不坏不住之所以也。此句标从由定无分别而不坏相下。正释所以。先释两对经文。前对约定后对约慧。定慧之中皆权实无碍。而动静相即。上句释于诸世界无所分别。亦不坏于世界之相。次句慧观一相而不坏诸。即释经观一切法一相无相亦不坏于诸法自性

疏。既事理双游下。结成释上定无分别慧观一相故不住也。定不坏相。慧不坏诸故不坏也。又二句中不坏即不坏相。二句中无分别观一相故。即不坏性。二句中不坏诸相故不住理。二句中无分别观一相故。不住事故。由双游得不坏不住

疏。若不坏不住下。释经住真如性恒不舍离。不坏性相故住真如。以真如即事而真故。由所无住故住真如。以诸法本无住故。若心有住则为非住故。大品云。若住一切法。不住般若波罗蜜。不住一切法则住般若波罗蜜。又云。若住一切法不住一切法。若不住一切法。则住一切法。故上经云。一切法无住。定处不可得。诸佛住于此。毕竟不动摇。善知识云。无住住者则住真如。即其事也

疏。既即事不舍下。结成喻中重现无尽之义。谓由住即事真如如融于事。事便如理理既无所不在。身即理故亦无所不遍。真如无所不包。故即如之身亦含一切。故云如无不在。故同真如内外互入

疏。以得幻智同于佛故者。经文有三。一明得智。二如诸下举所同。三菩萨下明能同。初有十句。一总得难思。二到究竟岸。三见如幻际。四以斯知如幻之智等能入世幻。五用上幻数思诸幻法。六不违幻数则不碍幻存。七尽于幻智则不碍幻亡。八存亡无碍故。鉴达三际皆不异幻。九得斯决定。则横尽幻边减数十也第五定歌罗逻者。此云薄酪者。梵语唐云俱是古义。新云羯剌蓝。此云杂秽。第八定是知菩萨之定常入常起者。结成难思。若以定门观则常入定。以用门观则常出定。实则动寂必俱故。常双入出矣。然动静唯物。据其体极动静斯亡。故常无入超。又入即起故无入。起即入故无起。若然何以经云粗细入起等。故下释云为显自在故。寄诸境界交络而明。若云一入多起即云自在。若云无入无起何名自在。常入常起自在之相亦然。广如贤首品辨

疏。约理事相望则无差别为细等者。由标云喻粗细大小二对。及经合中云无差别中入定差别法中起等。故为此释。于中先释粗细。后释大小。前中有二意。取义虽异粗细是同。前则理细事粗。后则总粗别细。别于一一事中而入理故。则后对唯约理说

疏。无差别则大周法界。下释上大小一对。亦有二意。初一事理对明大小。若唯约事下。唯就事明大小可知。第九定谓于毛孔中入眼等定。显互用自在者。然常途所明互用者。但眼处能作耳处等事。耳处能作眼鼻事等。故六根互用。今约十八界明。则有数重之互。一诸根互。二分圆互。毛孔身根中互能入眼等定故。三一多互。谓一根顿作多根事故。四根境互。谓根入境定如贤首品说。以此云法界必该十八界故。五复有一根入多境。一境入多根。六复有以六识对境以明互入等也。第十定二智通权实等者。此有十一句。但指二三四七四句释之。故云余七可知

疏。初三句始观者。以妙悟皆满是佛。今就等觉故云观顺。据观据顺故名菩萨。据三句见即名为佛耳。皆等觉之义

疏。即于所知一向无障转功德者。即摄论无著立名。然有二义下释初义。即无性释无著义。后意乃是佛地论亲光所释。疏家顺经但取亲光所解消文

疏。过前十地故云穷十方际者。十地华云量等百万三千大千世界故。今尽十方。知是过也。上十信及十地莲华。亦不言叶数。今叶等皆不可说。明是等觉之依报也

疏。谓此真如下释文。先释无边故。经云无相者。无有无等相故。即无有无二边之义。言不可说法即离言真如者。真如有二。一安立真如。谓真实如常寄言显故。二离言真如。故起信云。心真如者。即是一法界大总相法门体所谓心性不生不灭。一切诸法唯依妄念而有差别。若离心念则无境界差别之相。是故一切法。从本已来离言说相。离名字相离心缘相。毕竟平等无有变易。不可破坏唯是一心故名真如。以一切言说假名无实。但随妄念不可得故。言真如者。亦无有相。谓言说之极因言遣言。此真如体无有可遣以一切法悉皆真故。亦无可立以一切法皆同如故。当知一切法不可说不可念。故名真如。释曰。此即离言真如意也。次下论文云。复次真如依言说分别有二种义。何者为二。一者如实空。以能究竟显实故。二者如实不空。以有自实体无漏性功德故。释曰。上即依言真如也。法华云。知法常无性。此义玄中已引。今是义引。若具云。诸佛两足尊知法常无性。佛种从缘起是故说一乘。无去无来重显真如。即是中道者。中道非唯非有非无非断非常等。皆中道义

疏。世界性空故无体下。释经有体性无体性世界门。文有三释。一双约事理明。谓缘生故有无性故空。即法性宗一义。亦无相宗义。二云。又法性土故有体者。亦约性相而含二宗之义。若就法性宗释。性上取空义相上取有义。今性上取有义相上取空义。谓缘生故空义。若共二宗释者。法性有体是法相宗义。事土无体是法性宗义。然可会通故。今通用三。又净刹顺理下。唯就相土以明有体无体之义。净顺于理是事净。顺上法性土。染刹妄成即从缘无性义。又第二义亦顺璎珞仁王。三贤十圣住果报唯佛一人居净土三贤十圣忍中行唯佛一人能尽源。亦顺涅槃空者。所谓生死不空者。谓大涅槃余义如前后说也。其一品内更有文义。皆前后已有故不委示

疏。近则逆结上来进德之文者。前经从于诸法智但应安住不应称量下。是进德文。今有十一。如是初一后一即是总意。初句明前皆普贤行。末后明前皆为摄生。中间九句摄前进德即为九段。一如是圆满菩萨境界。即前经云应为请问如来佛法下三句。以三句中初一上求佛道法。二下化众生皆是菩萨之境界故。二如是通达出离之道。即前应观诸法。一切如幻下三句。如幻如声皆无体性是出离法故。三如是受持三世一切佛法。即前应知诸佛愿力下三句。四如是观察一切智门。即前应常安住平等法界下三句。五如是思惟不变易法。即前应不分别佛下二句。六如是明洁增上志乐。即前应当明解世间所作下八句。八句皆增上志乐故。七如是信解一切如来。即前于一切佛深生信解下三句。八如是了知佛广大力。即前于广界中拔出众生下至成就诸度四句。九如是决定心无所碍。即前所谓亲近一切智下四句。末句如是总结摄生已如前释。对前诸段类取耳

大方广佛华严经随疏演义钞卷第七十三大方广佛华严经随疏演义钞卷第七十四

        唐清凉山大华严寺沙门澄观述

    十通品第二十八

疏。二释名下疏文有三。初正释今经。二晋经下会通他经。三然通与明下拣滥会释。于中二。先正引论明通明相异。后会释经文。今初。论有问曰神通与明有何等异。答曰。直知过去宿命之事。是名为通。若知过去行业为明。复次直知死此生彼。是名为通。知行因缘际会不失。是名为明。复次直尽结使不知更生更不生。是名漏尽通。若知漏尽更不复生。是名为明。释曰。此论前文释明行足。所谓三明因以三明对于六通辨差别也。今疏但举一明。末云等者等于后二。疏今以此经通即委下第二会释经文。于中二。先会晋经明。顺文顺义义皆委照。文有证故。后晋经意存顺义下会今经文。言务不违文者。文有十通同六通故。明但有三十无从故。通梵语云吃[口*栗]地(平声)明云婆(上声)哆

疏。一他心二天眼等者。以经无总列故今列名。文中有四。一列别名。二此十皆言智通下辨其通称。通名神通已如上说。今但释智字。便当出体。若随相下辨智差别。三此十亦是下对六开合。但看前列次第在文易了。四然小乘下通妨难。谓有难言。十通全异可分权实。十六之殊既依六开。何能过六。故今释云。名数小异义旨全乖。文有三节。一明小乘。二辨三乘。三释一乘。言小乘智用有分者。宿命但知八万劫事。天眼但见三千世界。天耳他心神足皆局三千之内。漏尽不尽所知故云有分。三乘平遍明其不尽重重。一乘重重居然有异。如天眼见尘中之刹刹中之尘。尘刹之佛佛身毛孔尘刹重重。彼重重刹中如来说法。天耳皆闻彼中众生。他心尽了一念即知多刹。况局八万之中一尘。即往刹无穷。况局三千之内。三明虽知因起未尽重重。故云尚越彼明。况于三乘小乘六通之境。次有难云。若尔但明六通而义有异。已拣权实何要十耶。故云托事显圆故开为十。十十法门是本宗故。疏。标云他心下疏文有二。一释名。二辨相。文中有三。初能所合释。智为能缘他心为所缘。二直就所缘去能就所释。三若所若王下。显智宽狭

疏。然智缘他心下第二辨相。于中二。先叙异释。后会今经。前中即彼二十唯识偈云他心智云何缘境不如实如知自心智不知如佛境不知如佛境者。唯佛得本质故

疏。依唯识下。二会今经意。于中有三。初标所取取前安惠。云前亦未为失。二以摄境下出无失所以。三若离佛外下。结弹第二护法所释。二中亦三。初直出所以。二示法性他心之相。三结成正义。初中直出所以。即示法相宗有其三义。一云摄境从心不坏境者。即示心境有无。彼得本质恐坏唯心。既不坏境得之何妨。坏有何失。以无心者无心于万物。万物未尝无。此得在于神静。失在于物虚。谓物实有故。若唯心坏境则得在于境空。失在于心有。故以境由心变故说唯心。所变不无何必须坏。若以缘生无性则心境两亡。故云借心以遣境。境遣而心亡非独存心矣。二云能所两亡不碍存故者。上不坏境且遣惧质之病。今遣空有之理故心境并许存亡心境相籍故。空有相依缘生故有。有即存也空即亡也。空有交彻存亡两全。三云第一义唯心非一非异者。正出具分唯心之理。上第一释。虽有唯心之义尚通生灭唯心。第二义虽两亡不羁。而未言心境相摄。今明具分唯识。故云第一义唯心。同第一义故非异。不坏能所故非一。非一故有能所缘他义成矣。非异故能所平等。唯心义成矣。云正缘他时即是自故者。结成得于本质无心外过。以即自故不失唯识

疏。以即佛心之众生心下。第二正示法性他心之相。此有两对前对明所缘。后对明能缘。今初言即佛心之众生心者。此明所缘众生心即是佛心。此明不异。次云非即众生心之佛心者。此句明众生心与佛心非即。非即故有所缘义。非异故不坏唯心义。言为所缘者。结成所缘拣非能缘也。次下辨能缘云以即众生心之佛心者。此句明能缘佛心即是众生心。此明非异。次云非即佛心之众生心者。此明佛心与众生心有非一义非一。故为能缘。非异故不坏唯识之义。言为能缘者。结成能缘拣非所缘也。更以喻况如水和乳。乳为所和喻众生心是所缘。水为能和喻佛心为能缘。以此二和合如似一味鹅王[口*(一/巾)]之乳尽水存。则知非一。然此水名即乳之水。又此乳名即水之乳。二虽相即而有不一之义。故应喻之。以即水之乳非即乳之水为所和。以即乳之水非即水之乳为能和。义可知矣

疏。如是镕融非一非异者。第三结成正义

疏。若离佛外下第三结弹护法。言却失真唯识者。不知外质即佛心故。第三宿住通。皆以菩萨得九世眼如见现在故下。此释知义。而云见者是知见也。此上正明。二若不尔。下反难成立三若但曾经下遮救。谓恐救云。昔曾见事事则虽灭见种犹存。故得知耳。是则下为遮此救文有三破。一夺破。谓但见心不见法故。所见不同。岂见现心名宿住智。二又曾不经下纵破。纵许有种能知见者。昔不经事应不知见。谓昔为人何能普见。今得宿智广远皆知。三又但见现在下结成。即乖名破。第四知劫通。然大乘宗未来世法体用俱无今云何知者。总征知义。谓小乘或说三世俱有。未来但未有用。或纵可见而未有体。大乘体用俱无则无可知见。次依方便教下答中有二。初依权教立理。答谓见因知果。如见色相知后吉凶

疏。若一乘下二依一乘真实。答于中有四。一正明实义。二然非现在之现在下通妨。谓有问云。若尔何名见未来耶。答意可知。三此有若是下立理重难。纵其性有缘有二俱有过。四若今时看下以理会通。谓不向今时看未。若向今时看未。此未即现在。未来如何得有。若逐下向未来看未。未是未之现在矣。故异于今。第五六七三通文并可知。第八无数色身通。今初由了法界无定实色下。疏文有二先彰大意。后于中六句下释文前中意明。此是即色之空。非色绝之真空故不碍现色。于中先明即色之空。故能现色。由上无实色故即色是空。既即色是空故非断空。又无定实则显非常。非是断空。又显非断。以定有则常定无则断故。今非断常即真法界。从空中无色不碍色故者。明空不碍色故能现色。存亡隐显下结成上义。至下当知。然此段文乃含多意。第一谓色空相望总有三义。一相违义故云空中无色。二不相碍义故云不碍色故。三相作义故前云无定实色举体即空非断空故。谓此幻色若不举体即空不成幻色故。亦合云色中无空故色不碍空。故举体即色非断灭故。以此正说了无色义故。唯说色即空边。下第二段能现色边。方合明于色不碍空等。此三无碍方曰真空。亦称妙有。第二此之二句遣于地前三空乱意。谓无定实色举体即空。非断空故。遣第二疑空灭色取断灭空。以空中无色遣第三疑空是物。谓空为有。今明空尚无色岂有体耶。况色中无空空定无体。次云不碍色故。即遣第一疑空异色取色外空。既云不碍于色明非色外。离此三过方曰真空清净法界。第三亦含法界观意。即第一真空绝相观。彼有四门。第一会色归空观。即今门空意。第二明空即色观。是第二段能现色意。第三色空无碍观。即此第三段无色现色意。第四泯绝无寄观。亦在此段之中。彼第一会色归空观中有四句。各先标。后释前三标语。皆同云色不即空以即空故。今云无定实色以举体即空。非断空故。即彼第一句。彼云以色不即空是断空。故云不即空。以色举体是真空故。云以即空故。今云不碍色即彼第二句。青黄之相非即真空之理。故云色不即空。然青黄无体莫不皆空故。云以即空故。良以青黄无体之空。非即青黄故。云不即空。即要有青黄方说无体。明不碍色矣。次今云空中无色。即彼第三句空中无色故不即空。会色无体故。云以即空故。良由会色归空空中必无色。是故由色空故色非空也。上三句以法拣情。第四便云色即是空。谓凡是色法必不异真空。以诸色法必无性故。是故色即是空。此即今疏第一法界无定实色举体即空是也。疏存亡隐显皆自在故者。总结前义。于中二意。一者结上空中无色亡也不碍色故存也。举体即空非断空故兼存亡也。存亡约色隐显约空。空理真常不可言亡。而色存即空隐。色亡则空显。此唯约会色归空以说。若兼第二不碍现色。是明空即色观。论存亡隐显者。色即是空则色亡空显。空即是色则空隐色存。然皆即亡即存即隐即显。故云自在。即以总结。为彼第三空色无碍观。其泯绝无寄在下释文。疏但妄分别求叵得故下。即彼泯绝无寄意也。彼云。谓此所观真空。不可言即色不即色即空不即空。一切法皆不可。此语亦不受迥绝无寄。非言所及非解所到。是谓行境。何以故。以生心动念即乖法体失正念故。以今疏文对彼所引。相摄可知。疏以即空之色为妙色故者。此以前成后。由前即了无色。而现色故成妙色。次云又色空不二下。将今对前反覆相成。初空色不二成上真空。以全成前。次不二而二。以前成后。次色空融即下融上二文。归初法界。后缘起无尽下。成后无涯。其真空妙色之旨广如问明。第九一切法智通。然此三对释有三义者。然此三义散在经论。古德随见取舍不同。以今疏意并皆收之。而取义各别。并为正解。合其三意方尽玄旨。然此三对皆由下句成别。上非异句义旨皆同。同是遣差别相故。下句对上别成三重。第一唯约显实者。则拂迹入玄。非异者拂差别相也。非不异者。拂上不异之迹则遣之。又遣之以至于无遣耳。而文中二。先总明两句。故云则相待而空故。次先破异。云异相互无故云不异者。此即中论破合品中意。以小乘立见可见。见者三事和合因。将异以破之云。异法当有合。见等无有异。异法不成故。见等云何合。释曰。此但总明无异。异则无合。次例破异。云非但可见等异相不可得。所有一切法皆名无异相。释曰。上总言无。下出无所以。云异因异有异。异离异无异。若法所因出是法不异因。谓如眼于色异。色于眼异是名为异。今明因色异故眼异故云异因异有异。若离于色眼与谁异。故云异离异无异。然则眼色二异相因而成。则无定眼色。而成于异。故云若法所因出是法不异因。亦由梁椽成舍舍不异于梁椽等法。故云法所因出法不异因。若眼如舍则色加梁等。若色如舍眼如梁等。故互为所因。所以疏。云异相互无谓眼色相因无定异故。又如长与短异。长中无短相。长无可对故无有长。短中无长相。短无可对故无有短。既无长短孰言异耶。故云异相互无故无异。又长中自无长相。短中自无短相。将何长短而说异耶。亦中论意亦百论意。故中论云异中无异相。不异中亦无。无有异相故则无彼此异百论破一品中。外道立一内破云。若因果不异三世应为一。彼救云不然。因果相待成故如长短。注云如因长见短因短见长。如见泥团观瓶则因观土则是果。内破曰。因他相违共过故。非长中长相。亦非短中及共中。注云。若实有长相。若长中有若短中有。若共中有。是皆不可得。何以故。长中无长相以因他故。因短为长故。短中亦无长相。性相违故。若短中有长不名为短。共中亦无长二俱过故。若长中有。若短中有先已说二过故。将何共耶。长相既无短相亦尔。若无长短云何相待。上来破异竟。次疏云遮异言不异下。以相待门释无不异谓无异可待故。故二双绝。以契性空。亦百论云若无长短云何相待意也

疏。二约双显者。谓上但显实则唯性而非相。今性相皆具故云双显。谓由体一故非异相。差别故非不异。此举双是以显双非。疏三约双遮下文有二意。一前明相即故得双遮。谓相本是异。今即性故无有异也。故非异性本是一。今即相故无有一也。故非不异。二又相非相下。明当相自离故。得双非故。离二边下结成玄旨。疏法性不并真故一相。即影公云。法性不并真。圣贤无异道。由理无异味故

疏。一亦不为一故无相者。即法句经云。森罗及万像一法之所印。云何一法中而当有差别。即上一相也。次云。一亦不为一为欲破诸数。浅智着诸法见一以为一。即下句意。疏有无皆法待对故无者。释非无非有。谓有即有法无即无法。故云有无皆法。言待对故无者三论初章中。偈云若有有可有则有无可无。今无有可有亦无无可无。谓因无立有有假无生故非有。因有说无无因有立故非无。若蹑上起。上云无相即是无义。今非彼无相故云非无。无尚不存有安得立。故云非无非有。皆待对故无也

疏。法与非法但假施设者。然法非法有其三义。一者有法为法无法为非法。上已破有无故。今非此义。二者恶法为非法善法为法。三以相为法以性为非法。今通此二。善恶相因亦假施。设遣相之法明性为非法。相既不存性不安立故。法尚应舍何况非法。性相相因亦假设耳

疏。并就实而求下结成显实。上一一对中。多以上句为所治下句为能治。如虚是所治实为能治。法是所治非法为能治。既并归实故皆双寂。余皆仿此者。释不随于俗非不随俗已下经文。第十定通。初标名下。疏文有二。先释相后事理。非一故下释名。前中亦二。先正释。后斯即下拣定。谓对余宗拣定体用。于中三。初拣理事。二拣功能三遮救重拣。今初斯即理灭者。即是本宗法界体寂故不同已下。是法相宗。但事灭故要心不行方称为灭。疏但事灭下。第二拣功能不等。先明事灭六七不行何能起用。后证理灭下。辨理灭功高既即事而理故定散无碍

疏。亦非心定下。第三遮救重拣。恐彼救云。心想虽灭定前加行令身起用故今拣之。亦非我宗。心正在定不能起故。此遮法相。次言亦非独明定散双绝者。此遮禅宗。止观两亡不定不乱约理顿明。亦顿教意故非经宗。但事理下方显正义。契无碍之理故得定散自在。上七地下引二经证。并如前说

    十忍品第二十九

疏。三宗趣者。疏文有二。先正辨宗趣。后然此忍行下义门料拣。于中三。一定位。二体即下出体。三虽是一智下辨类。言是一者。一无生忍。二谓人空法空忍。三谓佛性论说三无性忍。及地持论说有信忍顺忍及无生忍。四者一有二义一如八地论中。一事无生。二自性无生。三数差别无生。四作业无生。二者思益经中说有四忍。一无生忍。二无灭忍。三因缘忍。四无住忍。释经序中已具引竟。言五忍者。即仁王经。一伏忍等如十地说。而言等者。乃有多义。一等六忍如璎珞说。十定初已引。或说十忍。如八地或说十四十五如仁王璎珞。并如十地十住品引。言诸教不同者。通辨诸忍约教不同。小乘不立忍名。上来诸门多通始终。独一无生兼通顿教

疏。名中前三约法者。疏文分二。先总科后三中初一下别显。于中亦二。一释法二释喻。前中又二。先当句释。后拣通局前二可知。无生忍中自有二义。一理智双明。二若约无生之智下。唯就智说。具如八地即是忍净。忍净复二。一智不生。即无分别智体无念虑故。二烦恼不生。妄想不起故

疏。又此三忍下。第二料拣通局。先通后局。通中三。初正显通二若约当位下反显非局。谓依地持音声属资粮位。顺忍属加行位。无生忍属于正证。故言三忍超然。超然不同。以不应下结非局义。三顺但顺理下通妨难。文有两难。第一正难云。加行之位顺无生忍故名顺忍。今不约位那有顺忍故今通云。顺有二义。一顺无生忍即是加行。今顺无生之理故非约位。次蹑迹难云。若尔何异无生。次顺忍通顺事理下通难。既通事理故。不同无生但顺于理。经云已下引经证成。然无生异顺更有一义。谓但顺理无生惑智不生。欲明顺忍双异二义故。但约双顺事理足拣二别。又上疏云前二通为无生加行者。约此等觉自说加行。不同前取三忍超然

疏。又依五忍下。第二辨有局义是胜非劣。五忍明义无生则当七八九地。三忍明义正证已后。俱通无生。虽有此义而此既有音声顺忍。是知定通句非正意

疏。后七喻中下。第二释喻于中二。先会六释。后光统下料拣通局。于中亦二。先叙昔。后疏为会通。前中总有七家。一光统。二贤首。三摄论。四远公。五金刚论。六大品。七楞伽。然光统有二。先叙昔。后会通前中。先以七喻对上三法义类同故。后又云幻者下。别显喻相大同摄论。言起无起者。幻法从缘无定性故。境无境者。六尘之境如焰似水而非水故。知无知者。梦中知觉非实觉故。闻无闻者。谷所发响非本声故。住非住者。电即晋经取净名意。是身如电念念不住。从今既云影下。类彼以释。亦净名意。经云。是身如影从业缘现。故云现无现相。化以无而忽有故云有无有相。空以不碍施为故云为无为相。皆取喻中别义

疏。此则能喻下。第二疏为会通。言能喻局于一相者。幻中但有起无起相。而无境无境相。知无知等六相。乃至空喻但有为无为相。而无起无起等。故云局一。言所喻义通多法者。如起无起相。通明缘起之法。不局内外等殊。有无有相但明万有即虚。不局菩萨能化等故通多法。如境无境闻无闻亦有局义故。疏致于义通之言。从在文虽无下纵成其义

疏。又古德下。第二贤首释。先叙昔。后此释下会通。文则纵成意则暗夺。谓后离世间品偈有别喻。义则可成。而下正释所喻既通。但顺后经故为暗夺。言离世间偈者。经云观色如聚沫。受如水上泡。想如热时焰。诸行如芭蕉。心识犹如幻。示现种种事。如是知诸蕴智者无所著。即其文也。言故今影喻亦喻于行者。今文影喻当晋电故。对上光统故致亦言。疏若依摄论下。第三引摄论分二。先引论。后经论对辨。今初不欲繁文。疏中义引。恐欲委究故钞具明。论云。复次何缘如经所说。于依他起自性说幻等喻(此总问也)于依他起自性。为除他虚妄疑故(此总答也)世亲释虚妄疑云。谓于虚妄依他起性所有诸疑。论云。他复云何于依他起自性有虚妄疑(牒征也)由他于此起如是疑(总牒标也下别释)一论云。云何实无有义而有所行境界。为除此疑说幻事喻。解曰。此中疑意从前论生。以前论云依他起相是虚妄分别唯识为性是无所有非真实义。从此生疑故。云若无实义何有境界。下文诸疑皆从此生。故每疑前皆有云何无义。喻释之中皆云为除此疑说如焰喻等。无性释幻喻意云。如无实象而有幻象为所缘境界。依他起性亦复如是。虽无色等所缘六处周遍计度时。似有所缘六处显现。解曰。无实似有何要实耶。下文诸喻酬意皆尔。二论云。云何无义心心法转。为除此疑说阳焰喻。释曰。又如阳焰于飘动时实无有水而有水觉。外器世间亦复如是。三论云。云何无义有爱非爱受用差别。为除此疑说所梦喻。释曰。又如梦中睡眠所起心心所法聚。极成昧略。虽无女等种种境界有爱非爱境界受用。觉时亦尔。四论云。云何无义净不净业爱非爱果差别而生。为除此疑说影像喻。释曰。又如影像于镜等中。还见本质而为我今乃见影像而此影像实无所有。非等引地善恶思业。本质为缘影像果生。亦复如是。五论云。云何无义种种识转为除此疑说光影喻释曰。又如光影由弄影者映蔽其光起种种影。非等引中种种诸识。于无实义差别而转。六论云。云何无义种种戏论言说而转。为除此疑。说谷响喻。释曰。又如谷响实无有声而令听者似闻多种言说境界种种言说语业亦尔。七论云。云何无义而有实取。诸三摩地所行境转。为除此疑。说水月喻。释曰。又如水月由水润滑澄清性故。虽无有月而月可取。缘实义境之所熏修。润滑为性。诸三摩地相应之意亦复如是。虽无所缘实义境界。而似有转。此与影像有何差别。定不定地而有差别。有说。面等众缘和合。水镜等中面等影生。分明可取。如众缘力颇胝迦等种种色生。为不尔耶。所取差别如离水镜月面等影分明可得。颇胝迦等所现众色。则不如是。故非同喻。又非我等许有水等种种实义。有法不成故非比量。八论云。云何无义。有诸菩萨无颠倒心。为办有情诸利乐事故思受生。为除此疑。说变化喻。释曰。又如变化依此变化说名变化。虽无有实而能化者。无有颠倒。于所化事勤作功用。菩萨亦尔。虽无遍计所执有情。于依他起诸有情类由哀愍故。而往彼彼诸所生处。摄受自体。论下总结云。应知此中唯有尔所虚妄疑事。所谓内一外二受用差别。三身业。四语业。五三种意业非等引地。六若等引地。七若无颠倒。八于此八事诸佛世尊说八种喻诸有智者闻是所说于定不定二地义中。能正解了。解曰。上依彼论次第具引。其释曰下。皆无性释。其解曰下。即钞家意。然其论释疑。但由疑异故举八喻。不必相蹑故论皆牒最初若无有义。疏直依经文之次第以引论文。若刊定记一一相蹑。既经论中次第不同。如何经中复成相蹑

疏。然彼论无空下。第二经论对辨然论望经略有四异疏有三节。初明有无。二而影是镜像者。是显名异。三更有映质下。辨其开合。于中有二。先辨论开所由。由义异故。后今经以义下。明经合所以以类同故。更有一意为成十故。以加三法故合此三。下文当说。然若唯为成十。何不合在于余喻中。故疏但显类同之义。言至下当知者。即影喻中广开其相。四者经论次第而有前却。经为对前三种法故次不同论。下释具出易故此无。疏远公下第四叙远公有四。一取意叙昔。二辨其顺违。三假征正释。四结广从略。今初。然远公依于二谛解斯七喻。前六为俗知俗非实故说如幻。知俗假有。故说如焰。知俗心起故说如梦。知声不实故说如响。知俗暂有故说如电。知变易无体故说如化。后一知真知真离相故如虚空。前六是有为空。后一即无为空。以前六喻多同光统。及与摄论故。疏不引但取意。见其摄论八喻依他故不立空今经有空。明喻无为。疏非不有理下。二辨顺违。初句顺理空比余喻。似无为故。而违已下辨其违文。以文中空喻宽故。疏若尔下三假征正释。先征意云。彼既违文。自云何解。从谓彼疑情下即疏正解。取摄论势。以解空喻彼论虽无。假使有者应如我释。疏余义下。四结广从略。摄论之广已如上引。别章之文抄已略具。疏金刚般若下。第五叙般若。论言九喻者。罗什译经但有六喻。九依魏经。偈云一切有为法如星翳灯幻露泡梦电云。无著论当第十八上求佛地住处明流转不染。天亲当二十七说法入寂疑。谓佛既涅槃。何能说法。故举此偈。为了有为如幻等。即无有为。是为大智故不住生死。然非无幻等故不离有为。即是大悲不住涅槃。以是无住涅槃故。能入寂而说法也。无著颂云。见相及于识器身受用事。过去现在法亦观未来世。论自解云。此偈显示四有为相。一自性相。即初句摄三喻。二着所住味相。即如幻喻。三随顺过失相。即露泡二喻。四随顺出离相。即梦电云三喻。释初相云。于中自性相者共相见识此相如星。应如是见。无智暗中有彼光故。有智明中无彼光故。解曰。古有二释。一者古来诸德。皆以共相见识解自性相含于三喻。此三皆是生死自体性故。从此相如星下。别解星喻。而云此相者。但此上相字非此一句。以见属翳喻。识属灯喻故此解甚分明。但不顺天亲。天亲云能见法亦复如是耳。以天亲云譬如星宿为日所映有而不现能见心法亦复如是故。又见相二字于偈不次。若回偈云相见及于识。理则无违。而天亲又以星配于见翳配相故。二者大云别为一解云。此相如星者。全指上文共相见识。以为此相。谓第六识起分别见。缘共相境故。喻如星夜有光明。五识各缘故非共相。第七意识恒行染污配属翳喻。若八识所缘行相俱不可知。以微细故。又无计度强分别故。不合星喻。星喻要须有智明故。见即分别耳。此释亦是一理则成。论家不释自性相义牒之何为。又令共相见识之中灯喻不明故。不及前解。今为一解。并异两家。谓此相之言。全指前共相见识。则如大云。而不将此句独解如星。谓如星下别解三喻。应云此相如星如翳如灯。以星喻在初故先牒解耳。又不依古星喻相分。今以星喻喻于见分。星有照了之能同见分故。亦顺天亲能见心法亦复如是翳喻相分犹有妄见。谓有空花之外相故。灯喻自证分。此不异论。若为此解亦顺偈中见相及于识。义次第故。亦得论家共相见识解自性义。又通八识三分共是识故。而为自相。不独第六而为共等。论别解星喻。言无智暗中有光等者。若无般若喻之如暗。便有见分名有彼光。若有智日识见便空。云有智明中无彼光矣。论次解翳喻云。人法我见如翳。应如是见。何以故以取无义故解曰。眼若有翳妄取空花。心有妄见妄取我法无处。妄取名取无义。论次解灯喻云。识如灯应如是见。何以故。渴爱润取缘故炽然。解曰。爱润于取而成识缘故。令识炎炽然增盛。则爱如油取如炷。识犹灯焰。灯体即是第八。炎盛即是七转。二解着所住味相。论云。于中着所住味相者。味着颠倒境界故。彼如幻应如是见。解曰。即偈器字。六境为所住爱心味着。无实为实为颠倒境。如幻六境令人谓真。三解随顺过失相。论云。于中随顺过失相者。无常等随顺故。彼露譬喻者。显示相体无有。以随顺无常故。解曰。即偈中身字。是身无常不久散灭。如朝露故。论云彼泡譬喻者。显示随顺苦体。以受如泡故。解曰即偈受用事也。受如泡者不久立故。三受即为三苦。无乐可著名随顺苦。四解随顺出离相。论云。随顺出离相者。随顺人法无我。以于攀缘得出离故。说无我谓出离也解曰。出离攀缘也。云何随顺。论云随顺者谓过去等行。以梦等譬喻显示。解曰。但以梦等观于三世则随顺出离矣。梦者论云彼过去行所念处故。如梦寤念梦时都无所有。梦望觉时即是过去。论曰。现在者不久时。故如电可知。论云未来者彼粗恶种子似虚空。引出心故如云。解曰。依空出云如种生现。有漏为粗恶。论结云。如是知三世行转生已则通达无我。此显示随顺出离相故。上依论经故有九喻。若依秦经但有六喻。加一影喻。云一切有为法如梦幻泡影如露亦如电应作如是观。次第亦不同。论。而将影喻添前则成十喻。古人亦将影喻摄星翳灯云。则六喻摄九。疏若依大品下。第六段大品智论所明十喻。十喻者。一如幻。二如焰。三如水中月。四如虚空。五如响。六如犍闼婆城。七如梦。八如影。九如镜中像。十如化。智论第七广明其相。什公有传睿公有赞。下释文中并已含具。但阙揵城大同幻故。欲成十忍故不出之。又加三法故合三影。皆为成圆十耳。疏楞伽亦通者。即第七多同大品。疏今经长行下。第二疏为会通。言偈有局者加下响喻。云一切诸世间种种诸音声非内亦非外。了知悉如响是也

大方广佛华严经随疏演义钞卷第七十四大方广佛华严经随疏演义钞卷第七十五

        唐清凉山大华严寺沙门澄观述

第三广释中疏谓闻无相不惊等者。此不惊等同金刚经诸论皆释。天亲论第二有其二解。一云不惊者。谓于诸无生之理心不惊愕趣生道故。不怖者。谓于诸法无和合相心不怖惧。而于世俗和合相中相续分别不执为实故。不畏者。心不如是永决定故。第二释云。复次不惊等言如其次第。谓闻时思时修习时心安不动。众生等想已远离故。无著论第二云。声闻乘中。世尊说有法及空法。于听闻时闻有法无有故惊。闻空法无有故怖。于思量时于二不有理。闻不能相应故畏。更有一释约三种无性故。即下疏意能断金刚般若论第二云。惊者谓于非处生惧(若正释梵音应云越怖也)违越正理如越正道可厌恶故。言怖者(应云续怖)相续生惧怖既生已不能除断故。言畏者(应言定畏)生决定心一向畏惧。此等若无便成心离惶惑。今疏中总有三释。初一即无著。第二释而展彼论文。次释即合其三释。一正是天亲。第二约三慧释。亦别配论文。二初句越字次句续字后句定字。即正是能断金刚意。三者即此三字亦兼天亲第一释意

疏。又闻有无所有等者。即第三释即同无著第一解故。疏三释已含诸论五释。疏爱乐者思慧之初等者。论云云何菩萨法随法行。当知此行略有五种。谓如所求如所受法。身语意业无颠倒转。正慧正修(此标列五行也)论云。云何菩萨于法正慧。谓诸菩萨独居闲静。随所闻法乐欲思惟。乐欲称量乐欲观察。乃至云。是菩萨由即于此已所得忍数数作意令坚牢故。能于其修随顺趣入。释曰。乐欲思惟即经中爱乐。随顺趣向初终之义。论中广明。今疏略显。爱法乐观为初。久思向修为终。疏专心忆念者修慧之初等者。论云云何于法正修。当知此修略有四相。一者奢摩他。二者毗钵舍那。三者修奢摩他毗钵舍那。四者乐修奢摩他毗钵舍那。乃至云。如是一切所作业。由前四种修相皆得成菩提。释曰。论说四种修相。即此经中专心忆念修习安住。修初后相。论亦广明。今疏略具。以起加行为初。以成加行根本定及依定发慧。而为其体。疏具如瑜伽菩萨地中者。即第三十八万种性品。菩萨所受学法七种方便。于中具多胜解。法随法行第二方便中。广说此义。论云。云何菩萨具多胜解。谓诸菩萨于其八种胜解依处。具足成就净信。为先决定喜乐。乃至云。八者于善言善语善说胜解依处。具足成就净信。为先决定喜乐。谓于契经应颂记别等。皆具多胜解。彼疏云。契经等法是解所印之境。名胜解处。信与胜解得递为因。今取彼信所生胜解。故信为先。言决定者。显胜解之体。喜乐言显胜解之果。喜乐即是喜受也。或即欲乐。释曰。论言信解即此经中深信悟解故。晋经中但云信解。第二顺忍释中。皆用止观者。既行顺诸法行中之要。唯止与观故。疏止思一境者。谓创修之时系缘一境不拣事理。经云思惟。疏止安事境顺其理故者。谓前创修事理容别。今渐深入故。即事入玄。上之二止皆通随缘。体真止中停止止也。二处之观并通空假。皆观达观也。疏谓止惑不生者。即止息止也。以妄息名止故。其正住修习者。即双住空有中道不偏故云正住。义通观穿及与观达。故云观彻前境。疏寂冥理境者。即不止止谓既与理冥。非止非不止强名曰止。智显于心者。即不观观。法界洞朗非观非不观。而强名曰观耳。疏上四皆止观俱行者。亦容有止观别修。则未为真实顺忍。若俱运者方为真耳。第三无生忍。疏释中释初征意云下。疏文有二。先正答前征。后此则以缘集故下。释上答。文偈文具有者。偈云菩萨亦如是观察一切法。悉皆因缘起。无生故无灭是也。疏释第二征意下。此中疏文有三。初明举总摄别称为无生。二以初摄后。但标无生。三重释前义。疏若从别义下。即第二以初摄后释。但标无生。是以信力入印度经等者。彼经广说初地之相。其第二卷云。复次文殊师利菩萨摩诃萨有五种法。则能清净初欢喜地。得大无畏安隐之处。何等为五。一谓菩萨生如是心。我已得住无生法忍故。生安隐心为令他住无生忍故。起安慰心又言无生忍者。谓证寂灭故。二谓菩萨生如是心。我已得住无灭法忍。故生安隐心。为令他住无灭法忍故起安慰心。又言无灭法忍者。谓证无生法忍故。三谓菩萨生如是心。我已得住身念智故。生安隐心。为令他住身念智故。起安慰心。又言身念智者。谓离身心故。四谓得受念智。受念智者。谓息一切受。五谓得心念智。心念智者谓起心如幻故。后二略引势同前三。今但取前二故。疏不具引。然引有二意。一正证第二义。明有无灭忍。二兼证初义。以无灭成无生故。故彼经云无灭忍者。证无生故。亦得名无尽忍等。疏又此诸句各有二义下。第三重释前义。谓无生中顿具诸义。具相云何故下广释。于中疏文分三。一双标二门。二开章别释。三结弹古义。今初。然二门总释前之初义。其第一后后成前前。兼释第二从别之义。以得无生忍则得无灭等忍故。无灭等忍净无生等忍故。疏然文旨下。即第二开章别释。正释第一门含释第二门。故下牒初门。疏今初云何下释。唯就约理。然无生理中无有次第。由所遣生等有次第故。以不不之亦成次第故。疏先明生灭尽等理所依是事之次第也。后今由前前无下。方显无生理之次第。疏故以后后显成无生者。上方明前前有故后后有等。今例结前以前前释后后以后后成前前疏次四显理者。以尽是有为垢是烦恼。差别是事处是方隅。并所观境。今了即真为理无生。疏后六显智无。生者。以心妄动即名为生。若心寂静即智不生。故偈云下引证约智。理智契合下结成上义。偈举一句。具云无灭故。无尽无尽故无染。释曰此即前四约理也。次偈云。于世变异法了知无变异。无异则无处无处则寂。静其心无染着愿度诸众生。释曰。即后六显智。疏举一句显智分明。等言等余皆约智相。疏三唯约智下。初由了从缘成智之由故。智无起契上理故。起即生义。湛然不迁体不灭无。不动约理无生可灭。正同十地义大之中无生无灭。非一往灭耳。余皆甚深般若无生智相真智妙用不同但空唯遮诸过审须思之

疏。若唯约知下三结弹古义。即刊定记彼中但云。谓法从缘故各无自生。生既无生灭依何灭。故今弹云。若理无生知之为忍。小圣亦有故非等觉深玄之忍。第四如幻忍

疏。今初有三等者。疏文有二。先总科。后初一切下别释。释中有三。初别释第一段。二合释前二段。三别释第三段。初中有四。一正释一切法言。二故大品下引证通义。三涅槃虽真下释经妨难。四引文决择。三中谓有难言。妄法缘生可许如幻。涅槃真实又不从缘。如何同幻故牒释之。释有二意。一明虽真而亦从缘。虽非缘生而是缘。显亦空无性。二明涅槃非幻为破着涅槃心。云如幻耳。是则破心中涅槃亦显涅槃体。即真空而成妙有故。并如智论

疏。广中合云下。第四引文决择中。初引局文明涅槃非幻。次然有法世下。以法通真故该涅槃。次此为有为所隐覆下。释真是世义。后云下引经成立该通一切

疏。就法喻中下。第二合释前之二段。以开五义中具有能所成故。于中分四。第一总开义门。第二对经显意。第三释通妨难。第四别明义理。今初五法不出三性。初一圆成。二三依他。谓二因三果。四明依圆相即五即遍计所执

疏。今经云下二对经显意。于中言以第二为因者。从缘生故令悟。第三即是依他成。第四者即事归理遣。第五病者遍计情亡。归第一者圆成理显

疏。然缘亦下第三释通妨难。谓有难云。若以第二惑业为缘。令第三依他为无性者。第二业惑应当是实不从缘故。故今释云。亦从缘起谓业从惑生。惑由虚妄分别。卒至无住。皆托因缘故。引中论明因果俱幻故。论合云。如初幻化人是则名为业。幻化人所作则名为业果。既未曾有一法不从缘生。为彰缘起故分能所

疏。然上五义下。第四别明义理。于中二。先成有无后成四句。言有无者。以三性中各有二义。皆有无故。圆成二者。一性有。二相无。依他二者。一缘有。二性无。遍计二者。一情有。二理无。今初中即圆成二义。术马皆是依他二义。而术是能成之因。托真而起故。用有体无。用有即是缘有。体无即是性无。三马是所成之果故。相有实无。相有即是缘有。实无即是性无。四明依圆不离。即事同真生喻于妄。死喻于真事泯理显故。生无死有。以无碍故者。出其所因。即事理无碍也。五中就情则有。妄见分明故。就理则无以是妄计必非有故。所以幻喻广说有无者。以惑情所执有无皆失理。无惑计有无皆真。是知幻喻诸法非实非虚非空非有。若无于有不成于无。若无于无不成于有。有无交彻万化齐融故

疏。又五中各具四句等者。第二显成四句也。于中有二。初一重四句。后重重四句。今初又二。先正显后拣非。今初也。初性有相无四者。一有真性有故。二空无诸相故。三亦有亦空义门异故。四非有非空互融夺故。二用有体无四者。一有迷真有用故。二空依真无体故。三亦有亦空体用不坏故。四非有非空无体之用故。非有即用无体故非空。三相有实无四者。一有事相现故。二空缘成无实故。三俱存无性不碍缘成。缘成不碍无性故。四俱非缘成即无性故非有。无性即缘成故非空。四生即是无死即是有四者。一真性显故。二依他即无性故。三性相双存故。四性相即夺故。五情有理无四者。一遍计妄情能招生死故。二即理而求不可得故。三要由理无方知情有。若无情有不显理无故。四情有即理无理无即情有故

疏。然皆具德不同四谤者。拣非也。言四谤者。谓定有者是增益谤。若定无者是损减谤。亦有亦无相违谤。非有非无戏论谤。疏以具德故出不同所由。谓上明四句即是具德。以称真故。不同情计定执四句。今重显初门具德之义。一真如是有义以迷悟依故。不空义故不可坏故。二真性是空以离相故。随缘义故对染说故。三真如亦有亦空。以具德故。逆顺自在故。体镕融故。四真性非有非空以二不二故。定取不可得故。余之四句前已略明。又皆即有之空方为具德之空。即空之有方为具德之有。是则非有之有非空之空为具德耳。又尽有之空尽空之有方为具德。又随一句必具余三。若随阙者则非具德。又四句齐照成解境故。四句齐泯成行境故。皆言亡虑绝方为具德耳。是知若依四谤四句皆绝。若依具德四句不亡。不即不离方知幻法故。楞伽第二令观四句。谓一异俱不俱有无非有非无常无常等

疏。若以诸门交络成多四句等者。第二重重四句也。总有四节。成二十重。第一节有八重。一以第一门中有。对第二门中无成四句。谓一者缘起是有以真性妙有故。二缘起是无业惑无体故。三亦有亦无双照真妄故。四非有非无真妄双绝故。二以第一门中无。对第二门有成四句。谓一缘起是有业惑有用招生死故。二是无一真法界绝诸相故。三亦有亦无双照真妄故。四非有非无真妄双绝故。三以第一门中有。对第三门中无成四句。谓一缘起是有真性有故。二是无以事无真实故。三亦有亦无双照事理故。四非有非无事理相即互相泯故。四以第一门中无。对第三门中有成四句。谓一事相有故。二理相空故。三空有双现故。四空有互泯故。五以第一门中有。对第四门中无成四句者。谓一真性有故。二事即虚故。三双照二故。四互即夺故。六以第一门中无。对第四门中有成四句。谓一无性之理有故。二理无相故。三二义齐现故。四非有非无真中道故。七以第一门中有。对第五门中无成四句。一真理有故。二情计于理无故。三有处妄计无故。四性有即是理无。理无即是性有故。八以第一门中无。对第五门中有成四句。一有在情有故。二无理无相故。三俱存要理无相方是妄情有故。四俱非妄情之有即真理无相故非有。真性无相能为妄情所依故非无。此上以第一门有无。对下四门有无成八重四句。第二以第二门中有无。对下三门又成六重四句。第三以第三门中有无。对下二门复成四重四句。第四以第四门有无。对第五门有无成两重四句。都成二十重四句。不得以后为首更对于前。以不异前门为首对于后故。今具出八重。其十二重取类思之。恐繁不出。疏一约相类者。如睹一叶落知天下秋。见一华开知天下春矣

疏。二约圆融下疏文自有三意。初一事理无碍义。二以理融事下。两门事事无碍义。前门即法性融通门。第三即缘起相由门。就第三门中疏文分二。先举一门后相即。既尔下例于余门于中三。一以即例入。二异体既尔下以异例同。三一门下以门例门。如缘起相由门既尔。无定性门唯心现等诸门亦然。又相即入既尔。微细相容安立门等亦然。疏所非之事亦可次第对前情非情境者。如非男非女。即对前了达众生。非地水火风即对前了达国土等。疏象等非术故等者。即因果相异门。依他之果非遍计缘故。下句反此者。术非象等明遍计非依他。下明相有。即因果相成。疏动寂无二下此下疏文有五。一总释经文。二引证。三释不得有无之义。四举喻帖成。五义门料拣。初门可知

疏。故经云智不得有无而兴大悲心者。第二引证也。即楞伽第一大惠赞佛偈然彼经叹佛了达三性。初偈云。世间离生灭犹如虚空花。智不得有无而兴大悲心。此明了遍计。次偈云。一切法如幻。远离于心识。智不得有无。而兴大悲心。远离于断常。世间恒如梦。智不得有无。而兴大悲心。此上二偈明了依他。次又偈云。知人法无我。烦恼及尔焰。常清净无相。而兴大悲心。此偈明了圆成。又此上偈准金光明意。即显佛具三身。谓了遍计成化身。了依他成报身。了圆成成法身。然四偈下半皆同。今经正引依他中如幻下半。其如梦下半如梦忍中更引

疏。由了体空下。第三释不得有无之义

疏。如象生即是象死者。第四举喻帖成。疏此二相对应成四句下。第五义门料拣。于中四。初就第二门似有无性显成四句。第二对第一门明非一异。第三例余三门。第四例释前后。今初成四句者。一非异二非一。三非非一非非异。四非亦一亦异。其所遣病者。一者异。二者一。三者非一非异。四者亦一亦异。如疏思之。楞伽第二名见妄想故须破之

疏。若以巾上二义下。第二对第一门辨非一异。疏文有三。初标所依。二一以巾下列释十句。三若以不异门下总结义旨。今初言巾上二义者。一住自性义。二成象义。初即不变义。后即随缘义。象上二义者。一体空义。二差别义。初即无性。后即幻有。第二别释十句中。初四句非异。次四句非一。九十二句收上二门明非一异。就初非异中。第一句即随缘与差别不异。第二句不变与体空不异。第三句即合前二句以无碍。第四句即合前二句以相夺。今初句中。疏经云法身流转下引证。引二经证。问明已辨。今当更释初法身流转五道名曰众生。即不增不减经。法身即是真如。流转五道即是随缘。名曰众生是差别义。次如来藏受苦乐与因俱。若生若灭。即楞伽第四。彼云大慧七识不流转不受苦乐非涅槃因。大慧如来藏受苦乐与因俱。若生若灭。解曰。七识念念生灭无常。当起即谢。如河流转自体无成。故不受苦乐。既非染依亦非无漏涅槃依矣。其如来藏真常普遍。而在六道迷此。能令随缘成事受苦乐果。与七识俱名与因俱。不守自性而成七识。依此而得生灭云若生若灭。此明如来藏即是真如。随缘故受苦乐等

疏。二以巾上住自位义等者。住自即是不变。体空之相即是如故。二义相顺而会相归性故。云以末归本。本即是性末即相故。疏经云。一切众生即如下引证。即净名经弥勒章中。然彼经中云。为从如生得授记耶。为从如灭得授记耶。若以如生得授记者。如无有生。若以如灭得授记者。如无有灭。一切众生皆如也。一切法亦如也。众圣贤亦如也。至于弥勒亦如也。若弥勒得授记者。一切众生亦应授记。所以者何。夫如者不二不异。若弥勒得阿耨多罗三藐三菩提者。一切众生皆亦应得。所以者何。一切众生即菩提相。若弥勒得灭度者。一切众生亦当灭度。所以者何。诸佛知一切众生毕竟寂灭。即涅槃相。不复更灭。是故弥勒无以此法诱诸天子。今疏文略举二句之要。而言等者此有二意。一者等余净名之文。如上所引。是二者等余一切皆如之文。故此经云。一切法皆如诸佛境亦然。乃至无一法如中有生灭等

疏。三以摄末所归之本下。此句即合前二句令无障碍成此一句。斯乃即差别之体空。与即不变之随缘相成故不异。言摄末所归之本者。即差别之体空也。是前第二句体空是本。差别是末。斯即本融于末也。令末同本故差别即体空。言与摄本所从之末者。即不变之随缘也。是前第一句。由不变举体随缘成差别故。末融于本令本同末也。故云此二双融。由不变举体随缘故。本不碍末差别即体空故。末不碍本故云无碍。特由法身成众生故。得众生即如。由众生即如方知法身流转五道作众生也。则第一句本等于末。第二句末等于本。故云本末平等。正本等末时即末等于本故。上二经亦不相违。故云前二经文不相离故。既合前二句相成为第三句。故用前二经以证此句。疏四以所摄归本之末等者。此句亦合前二句。相夺以成此句。谓以即体空之差别。与即随缘之不变相夺故不异。然同用前二句而为悬隔。第三句用第一句。取即不变之随缘故本成末。今第四句用初句。取即随缘之不变。即本夺末也。但颠倒而已。第三句用第二句。取即差别之体空故末成本。今第四句用第三句。取即体空之差别末夺于本也。亦但倒耳。故义悬隔。言所摄归本之末者。即体空之差别也。即第二句。言所摄随末之本者。即随缘之不变也。即第一句。由随缘即不变故。夺差别令体空。则末寂也。由体空即差别故夺不变令随缘。故本寂也。以全本为末故本便隐。全末为本故末便亡也。是则真如随缘成众生。未曾失于真体故。令众生非众生也。众生体空即法身时。未曾无众生故。法身非法身也。故二双绝。二既互绝则真妄平等无可异也

疏。次下四门非一者。此句总标。谓第五门性相相违故非一。第六门性相相害故非一。第七门但合五六二门明违害不同故非一。第八亦合五六二门明不泯不存不同故非一。其五六门但交互第二门耳。谓上第二门以不变对体空故则不异。今对差别则不一耳。第六亦然。五中先正明。言本末相违相背故者。谓本则寂无二相。末则差别万端故相违也。疏。楞伽云下引证可知。起信疏云。此中唯生灭是七识。唯不生灭是如来藏。二义既分。遂使梨耶无别自体故云不在中。此约不二义非约不和合也。何以故。此中如来藏不生灭。即七识生灭之不生灭故。与自生灭不一也。七识生灭即如来藏。不生灭之生灭故。与自不生灭不一也。此中非直不乖不异。以明不一亦乃由不异。故成于不一。何以故。若如来藏随缘作生灭时失自不生灭者。则不得有生灭。是故由不生灭得有生灭者。是则不异故不一也。释曰。上所引义和会非一异义。今此分门正明不一。若会非一异令其相同。即第十门。今以因七识生灭之文便引会耳

疏。六巾上成象等者。上第一句以成象对差别则不异。今对体空故不一。先正明。又楞伽经云。七识不流转下引证。即第四。经如前已引。但前虽具引意在如来藏受苦乐。以取随缘成法故。今疏虽具引意取七识不流转义。以成相反末即空故。言七识不流转者。以本害末令末空故无可流转。唯如来藏受苦乐者。末害本故不守自性。清净之体随缘成有。始欲成象被体空违。方欲体空被成象违。故非一也。疏七以初相背等者。此句即合前五六二门敌对不同。谓相背如二怨家不喜相见。亦如参辰。夫妻反目相害如二怨家。以死相敌。如父母之仇不与同天。亦犹二虎之斗势不两全

疏。八以极相害俱泯而不泯等者。即亦合五六二句。取不泯不存明不一。俱泯不泯即第六句。俱存不存即第五句。何者以前第五相违是存。第六相害是泯。然存上有不存之义。泯上有不泯之义。若唯泯无不泯则色空俱亡无可相即。以不泯故虽相即而色空历然。若唯存无不存则色空各有定性不得相即。由有不存故虽历然而得相即。以体虚故是以第七但合五六之存泯。今第八门乃合五六之不存不泯故。七八二门虽同合五六二义不同。言此是成坏不一者。不存是坏不泯是成。第九门非一不是非异故。二门不一。第十门总融前八称真法界。故亦非异。既无二理岂一异。有殊。疏若以不异门取下。第三总结义旨。疏巾象相对既尔下。第三例余三门。疏上下诸门下第四例释前后。若依睿公十喻之赞。多显空理。如幻喻云。幻惑愚目流眄无已。长勤世间。父父子子我实非我妄想而起。若了如幻此心自止。然彼有十喻。水月镜像既合影中。更有犍城之喻应同幻摄。彼犍闼婆城喻赞云。世法空廓如彼鬼城。凌晨敷影现此都京。愚夫驰赴随风而征。终朝乃悟穷噭失声。第五如焰忍。疏若十喻论法喻各有多义者。智论释如焰云。焰以日光风动尘故。旷野中动如野马。无智人初见谓之为水。男女之相亦复如是。结使烦恼日光热气。诸行之尘邪忆念风。生死旷野中转。无智者谓为一相。为男为女是名如焰。复次若远见焰想之为水。近则无水想。无智之人亦复如是。若远圣法不知无我。不知诸法空。于众界入性空法中。生人想男想女想。近圣法则知诸法实相。是时虚诳种种妄想尽除。以是故说诸菩萨摩诃萨知诸法如焰。释曰。彼就妄说生死。为旷野。今就真妄合说。故以空地喻如来藏。睿云。焰惑痴爱乐之无极。非身想身非色见色。实无可乐莫之能识。若有智慧此心自息。第六如梦忍。疏然开此梦义下。疏文有二。先开义后消文。前中疏一所依谓悟心以喻本识者。若无所熏故则无无明等。亦可喻如来藏。喻本识者诸宗共许故。法相宗明如来藏不受熏故。疏。二所因谓睡盖者。智论云。复次如梦中无喜事而喜。无嗔事而嗔。无怖事而怖。三界众生亦复如是。无明眠力故不应嗔而嗔等。疏。四此梦事非有而有者。智论云。复次梦有五种。若身中不调若热气多。则梦见火见黄见赤。若冷气多见水见白。若风气多则见飞见黑。又复所闻见事多思惟念故。或天与梦欲令知未来事故。是五种梦皆无实事而妄见。世人亦复如是。五道中众生身见力因缘故。见四种我。众色是我。色是我所。我中有色色中有我。如色。受想行识亦复如是。四五二十得道实智慧。觉已知无实。释曰。论中身见力合上身中不调。五道众生亦可合前五梦。初火如地狱火涂道故。白如人善法故。黑如畜生愚痴故。多思如鬼天与如天故。然周体列子皆说六梦。与此五梦有同有异。言六梦者。一正梦。二噩梦。三思梦。四寤梦。五喜梦。六惧梦。正梦谓不思虑忽然而梦。共天神与梦大同。余五多是见闻多摄。庄子第二齐物篇云。庄周梦为蝴蝶。自逾适志与不知周也。注蝴蝶而不知周。则与殊死不异也。然所在无不适志。则当生而系生者。必当死而恋死矣。由此观之。知夫在生而哀死者。误之矣。俄然觉则蘧蘧然周也。不知周之梦为蝴蝶欤。蝴蝶之梦为周欤。周与蝴蝶必有分矣。此之谓物化。意云。昨日之梦今已化矣。生死之变岂异于此。又自周而言蝴蝶称觉。未必非梦此亦可喻万法如梦矣。又列子中有人。昼为主役而夜梦为人君主。则夜梦被役。二者各有其美也。疏。但心变故非见前法者。此通喻合约。喻者即通妨难也。谓有难言。若无实者。何以梦中见色闻声等耶。故智论云。不应言论无实之事。何以故。得缘便生梦中之识有种种缘。若无缘云何生。故今答云。梦中五识不行。所见五尘但心变耳。故智论云无也。不应见而见故。如梦中见人头有角见身飞等。人实无角身实不飞故。二约法者。但心变故合而有义。不见前境合非有义。疏文中初明俱非下。第二释文。于中疏文有三。一总彰文意以成四句。二重释。三引证。疏然此四句皆由以是梦故下。第二重释。于中此上二句标。谓一以是下释。于中有二。先释有无二句复释双非。前中又二。先正释。后然语有下。拣滥于中又二。先举正。后拣非。今初举正。谓有无交彻即梦事而性虚。即性虚是梦事。约法即性空是幻有。即幻有为性空。若是定有不得为空。若是断空不得为有。既无性故有即全摄无而为有也。既缘生故空则全摄有。而为无故结云非有二相。疏非但相有性无而已者。二拣非也。谓诸宗计多有此说。但空自性不空于法。如法相宗。但无遍计非无依他。设学三论不得意者。亦云。法无自性。无自性故说为空。则令相不空矣。今既无性缘生故有。有体即空缘生无性故空。空而常有要互交彻方是真空妙有故。其言大同而旨有异。故令思之。若得此意则下二句义旨可知。疏三以是梦故下。二释双非中亦二。先正释。后然此俱非下融通。亦为拣滥。谓寻常双是义涉相违。寻常双非义参戏论。故令双融令离二谤。成具德句。谓非但二不相违。亦乃二句相成。故云若不夺无令尽无以为无。言夺无令尽者非无也。夺有令尽者非有也。谓若无非无则无亦无。何者若无不尽是定性无故非真无。下句亦然。若无非无则无亦有。以有不尽是定性有。非真有故。故以非有非无。成上亦有亦无。亦更合说俱句成于俱非。含在俱句。及下结中故略不明。若欲别明。应云以亦有是即无之有故成非有。以亦无是即有之无故成非无。疏存亡不碍俱泯自在。方为梦自在法门者结成也。存即是有亡即是无。俱即亦有亦无。泯即非有非无。皆互交彻故云自在无碍。又存者存四句。亡者亡四句。俱者亦存亦亡。泯者非存非亡。故曰梦自在法门。互为坑行岂名自在

疏。经云世间恒如梦等者。第三引证也。即楞伽第一此即中间两句。若具应云远离于断常世间恒如梦。智不得有无而兴大悲心。前如幻忍抄已具引。疏上之四门各双存互夺以成四句者。如第一常无常门云。一者常。二是无常。三合前即成亦常亦无常故云双存四约互夺即成非常非无常无常夺常故。非常常夺无常故非无常矣。谓正以体虚无实即自性无常故。下三门例知也。疏后一句明觉即止观门。下疏文有三。此上标门。二谓要在觉下说立觉所以。三观了上之多门下释止观义。就立觉所以中亦是解妨。谓有问言。此明梦忍那说觉时。故今释云。觉梦相成故须说觉。于中初以觉成梦。以未觉时不知是梦故。于中初要在觉时方知是梦者。正辨须觉所以。谓大梦之夜则必有彼大觉之明。谓我世尊方知三界皆如梦故。上引楞伽叹佛能了于梦。次正在梦时不知是梦者。谓为实故。为诸凡夫长眠大夜不生厌求故睿公云。梦中蒙梦纯昏心也。次设知是梦亦未觉故者。此通妨难。谓亦有人梦知是梦。如人重眠忽有梦生了知我梦。以睡重故取觉不能。喻诸菩萨。从初发心即知三界皆如梦。岂非是觉。何用更说觉时。故今释云。亦未是觉未大觉故。故起信云。若人了知前念起恶能止后念令其不起。虽复名觉即是不觉有生灭故。无明覆心不自在故。次云觉时了梦知实无梦者。非唯觉时知梦。亦知无梦。如八地菩萨梦渡河。喻证无生忍。不见生死此岸涅槃彼岸。能渡所渡皆叵得故。况于大觉。故经云。久念众生苦欲脱无由脱。今日证菩提豁然无所有。疏然由梦方有觉故。辨梦觉时者。上辨以觉成梦。此辨以梦成觉。对梦说觉无梦无觉。既了梦无梦对何说觉。故觉梦斯绝。如无不觉则无始觉觉梦双绝方为妙觉。疏观了下释止观义。照上四门故名为观。觉梦斯绝即不取于梦妄故。无量义经叹佛云。智恬情怕虑凝静意灭识亡心亦寂。永断梦妄思想念无复诸大阴界入。即知究竟了梦唯我世尊。睿公云。长夜之内大梦所成。皆由心画遍造众形。神传五道备尽跉竮。若能悟之即破无明

大方广佛华严经随疏演义钞卷第七十五大方广佛华严经随疏演义钞卷第七十六

        唐清凉山大华严寺沙门澄观述

第七如响忍。疏文可见。睿公赞云。声以响酬相和如一。缘扣而应谁辨虚实。业虽虚妄罪福不失。若映斯照朗如皎日。又为赞曰。响无所在缘会发声。不知自我喜怒交争。妄和真心事像万形莫知其本终日营营。第八如影忍。疏性则非修相乃不舍者。释成双照之义。如前文云非是世间义当出世。下句云非出世间。即拂上出世。世与出世俱拂故曰双遮。今文若云非修菩萨行。则由通双遮。既云非舍于大愿。明是双照。谓非修菩萨行即为照实。非舍于大愿。即是照权故。得双照之名耳。次明非实非不实。例然双照真俗耳

疏。遮照一时为双运等者。若约权实俱行为双运者。则第二段。已是双运竟。今遮照为双运。则此中方有。即合前二门。为此第三门矣。既言遮照一时。则全遮为照全照为遮。则二门峙立。以照夺遮遮亡。以遮夺照照寂。则为遮照两亡矣。言无碍者自有二意。一遮不碍照照不碍遮。二者双存不碍双夺。双夺不碍双存。故云无碍。如此方称自在。故下结云以此结上二段。同斯无碍故曰深玄。疏今初若约影喻别喻菩萨现身等者。疏文有二。先拣所喻通局。后其河泉二种下。拣能喻通局。言虽通能现者。以河泉之中见日月故。故为能现。言且为所现者。以下经云于油于水下方明能现故。今河泉以为所现长河飞泉入镜中故者。出是所现之相。登楼持镜则黄河一带尽入镜中。瀑布千丈现于径尺。王右丞云。隔窗云雾生衣上。卷幔山泉入镜中。明是所现矣。疏二能现中亦有通别等者。疏文有二。先通辨文旨。后别开喻旨。今初。言别喻机感及应现处者。日月既喻菩萨则水等喻机。亦喻菩萨应处如影落百川。喻菩萨身充遍法界。百川江河喻机及所现国土之处也

疏。然此文具摄论三喻下。第二别开喻旨。此二句总标下成三义。即分三别。疏一以油水对上日月。为水月喻者。则日月喻菩萨悲智。水喻机心。水中之月喻定地境界。谓定中见佛等。亦喻遍处定境青黄赤白等故。出现偈云。譬如净月在虚空。能蔽众星示盈缺。一切水中皆现影。诸有观瞻悉对前。如来净月亦复然。能蔽余乘示修短。普现人天净心水。一切皆谓对其前。睿公云。水月不真唯有虚影。人亦如是终莫之领。为之驱驱背此真净。若能悟之超然独醒

疏。二以于身对上日月为光影者。日月喻为菩萨悲智。身喻物机。日照发影以喻现身等。而言映日等者。等取经上月字及灯烛故。疏。弄影多端故喻于诸识者。上约别喻菩萨现身。此约通喻一切诸识。动身俯仰即是弄影。形端影正形曲影斜故云多端。以况八识依身有异。亦喻七识依第八识对境差别。上皆摄论意。睿公云。光不照处谓之为影。不照慧明生死长永。舍远夷途而行榛梗。若能悟之狂灭自醒

疏。三以宝镜等对上男子等者。释第三喻。疏文有二。先正属配经文。后对喻辨异。今初。疏从通说云喻非定地果报此摄论意。对前水月等定境。故云非定地则镜喻于因。故云谓无明等本质喻缘。影喻果报。故净名云。是身如影从业缘现。又镜喻本识如来藏性。本质喻无明业等。像喻果报。如问明品。若将镜像别喻现菩萨身。则镜等喻菩萨。本质喻机。像喻菩萨所现之身。疏以镜中影像离于本质等者。第二对喻辨异。明此镜像得果报名。果与因别故。若影在身外。前映质下辨前异此。日月在天影光在身。身即喻因则所现法得与因俱。疏故喻诸识虽托境生异自在我非在于境合上虽随日等影乃随身。此就通喻诸识以说。若将光影喻菩萨现身。则影随身异。不在日光则身由生异。不在菩萨智日令异。睿公云。形不入镜光照而有。世亦如是业影而受。不知此者长婴其咎。若能悟之还神气母。疏于中一异合离通显影义者。此拣经中诸对通局。此通三影故云通显。次于川流下。唯明水月之影。疏然一异约此影彼影者。自拣二对义旨不同。显无重言之失。言此影彼影者。江中之月若与水一不可在河。若与水异江河不同。应有两月。言合离约影对水等者。水影若合水流月亦应流。水影若离去水应有影在。又合离者合意。亦二如二掌合。一异不尔。一则无双如冰成水。影与水异则月可出水。影与水一则有水即月亦不可移。合离之义不异前释。疏不通二影者。唯水月故非通镜像及于映质。以文但云川流池井故。言月映淮流者故。文选云月映清流。疏兼于镜像者。以文云虽现其中故。通镜像亦不通映质。映质之影无现中故。若取日照身影入于水中。则亦通之。然是水影中摄。疏不知此影无远近故者。即释经中影不随物而有远近。如执镜临池池中月出。而此影不近天上之月。去地四万二千由旬。影落潭中而亦不远。以喻菩萨远在他方恒住此故。虽在此处常在彼故。安有远近之异相耶。一切远近皆类此知。第九如化忍。疏仁王云。法本自无因缘生诸者。证上不实相现二义。然有二义。一因缘生之即是相现。由缘生故有来。即无云法本自无。即无实义。二者两句共成一义。谓自者从来也。从无之有曰生。非本先有故。云法本自无。遇缘即起故云因缘生。诸斯即但用因缘生诸。即成二义。谓因缘生故相有。缘生无性故无实。正顺无而忽有名化故。引此文。此文即第二卷护国品。第五普明王为千王说偈。此后更有偈云。盛者必衰实者皆虚。众世蠢蠢都如幻居。声响俱空国土亦如等。总有八偈。及事缘并如彼经也

疏。净化二义仿此可知者。即不实相现之二义也

疏。慈悲复依方便立者。即下出现品文故。彼偈云。譬如树林依地有。地依于水得不坏。水轮依风风依空。而其虚空无所依。一切佛法依慈悲。慈悲复依方便立。方便依智智依慧无碍慧身无所依。彼说五重相依。今此但要慈悲依方便方便即后得智。慈悲以后得智为体。后得智中与乐拔苦故

疏。谓无有亦无故者。经有二句。云非有非无有。今偏释非无有句。谓非有即是无有。今亦遣彼无有故云非有非无有。故云无有亦无。上句易故不释。睿公云。众生如化非有非真。不达此者转如车轮。解法清净无我无人。众垢消除如日无云。第十如空忍。疏标云。如空如空所喻通一切法等者。此下疏文有四。一显所喻通局。二明喻相不同。三引论会释。四结成大意。初中上是本经之意。通喻一切。二佛地论喻清净下。引论明通局

疏。然其喻相下。第二明喻相不同。于中有四。一唯将空喻对前六喻。辨相不同。二又此诸喻若约能喻下。通辨七喻所破差别。三又前六遣有下。三重将空喻对六明空有不同。义成诸喻共喻于空。空喻却成于有。四又上所喻即通一切下。通辨七喻能所通局。言此中能喻则具多义者。谓如一空。有无相义有无起义一味义等。言所喻各随别义喻一类法者。谓无相但喻事法界。无起但喻世界。一味但喻教法等故

疏。然龙树下第三引经论会释。于中引一论二经。一智论四义略如文具。二佛地十义。三八地十义。此之二经文皆十义。意各不同。佛地十义唯喻如来清净法界。八地十义知虚空身十相不同。谓一无量相。二周遍相。三无形相。四无异相。五无边相。六显现色身相。文唯有六例合有十耳。但语于空又不别喻于法。佛地十义今当具引。即第三论去至第四论。方终第一义者。经云。妙生当知。清净法界譬如虚空。虽遍诸色种种相中。而不可说有种种相体唯一味如是。如来清净法界虽复遍至种种相类。所知境界而不可说有种种相体唯一味。二云。又如虚空虽遍诸色不相舍离。而不为色过所染污。如是如来清净法界。虽遍一切众生心性。由真实故不相舍离。而不为彼过所染污。三云。又如虚空含容一切身语意业。而此虚空无有起作。如是如来含容一切智所变化利众生事。清净法界无有起作。当第四卷初。故云。又如虚空中种种色相现生现灭。而此虚空无生无灭。如是云云。诸智变化利众生事现生现灭。而净法界无生无灭。五云。又如虚空种种色相现增现减。而此虚空无增无减。如是云云。显示如来甘露圣教有增有减。而净法界无增无减。六云。又如虚空十方色相无边无尽。是虚空界无边无尽故。而此虚空无去无来无动无转。如是云云。建立十方一切众生利益安乐。种种作用无边无尽。清净法界无边无尽故。而净法界无去无来无动无转。七云。又如虚空三千世界现成现坏而虚空界无坏无成。如是云云。现无量相成等正觉。或复示现入大涅槃。而净法界非成等正觉。非入寂灭。八云。又如依空种种色相坏烂烧烁变异可得。而虚空界非彼所变亦无劳蔽。如是依止如来净界众生界内种种学处身语意业毁犯可得。而净法界非彼变异亦无劳蔽。九云。又如依空大地大山光明水火帝释眷属。乃至日月种种可得。而虚空界非彼诸相。如是依止如来净界戒蕴定蕴慧蕴解脱解脱知见诸蕴可得。而净法界非彼诸相。十云。又如空中种种因缘展转生起三千大千无量世界周轮可得。而虚空界无所起作。如是如来清净法界具无量相诸佛众会周轮可得。而清净界无所起作。释曰。上之十义具出经文。如是字下皆有如来清净法界之言。余并依经而论皆广释大意相似故。疏不引论亦不具列经文。言大意相似者。通与一切法非即离义耳。上正辨五法之中。一真法界故以虚空十义为喻。若略取别相者。一者体唯一味。二性净无染。三无起作。四无生灭。五无增减。六无去来动转。七无成坏。八无变易劳倦。九非诸相。十无所起作。观其经文十与三同。而三是含容无起作。十是生起无起作。二合云无能所。若观论结十应言无分别。三应云无作意。今略引论释。释第一云。次当显示净法界相。释难决择法界差别。谓有难言。若诸如来法界为性。法界则用真如为体。真如即是诸法共相。诸法既有种种差别。法界随彼云何无有种种差别。法界若有种种差别云何清净。非颇胝迦种种依止共相应。故无种种相。为释此难故说最初太虚空喻。意云。虽遍种种不随成形。不舍自性故。唯一味下取意。引论。二有难云。法界遍在一切则与贪等而共相应。云何不如有漏心法成不清净。故今通云。性清净故非彼体故不为所染。三有难云。如来清净法界真如为体。则无戏论亦无起作。云何得容利有情事。故今通云。由先愿力为增上缘与诸众生作利乐事。任运而住无有分别而无戏论。四有难云。若净法界遍在一切不相舍离一向随转。是则法界应有生灭故。故今通云。虽遍一切世俗施设则有生灭。真胜义体不生不灭。五有难言。若净法界遍在一切不相舍离。如来圣教现有增减法界亦应增减。故通云。然一切世俗理说有增减非真法界而有增减。六有难云。若诸如来法界为体。如来施与有情利乐。或去或来法界应有来去。故今通云。就受用身说有去来。非法界体而有去来。七有难云。若无去来云何得有成等正觉。故今通云。成者约世俗胜义无成坏。八有难云。若法界遍一切有情之类。云何有情得有毁犯。故今通云。众生有毁犯法界无变异。九有难云。若法界遍一切。应无有戒等无漏蕴相故今通云。有增上缘增长一切自无诸相。十有难云。若一切佛法界为体应无受用。云何得有众会差别。故今通云。约别别因缘所得。非如来身有戏论分别等。以上十难对上经文居然易了

疏。然别义有此不同下。第四结成大意。然文有三。初总明。二故睿公下引证。成于空义是同。此但总结十喻之赞。若别明空赞云。空唯有名无用无色人亦如是。莫之能识。妄造妄苦百艰孔棘。驰空求空空竭其力。亦显空义耳。后余无碍义如前后说者。三结成此经之大意也经疏前已有说。如如幻忍等。后亦有说如德齐空中说。前后远文文更多矣。疏世界共业所起者。出现品当说

疏。四即反此者。谓无性故有。缘生故空。并如问明品。若对经文应言从缘有故为世界依。无性空故而无所依。四句但出空义所以差别耳

疏。无法出空下别释。譬如虚空一切世间皆现其前。非现一切世间之前

疏。一味解脱不殊故者。涅槃云。一切同一甘露一解脱味。净名云。解脱味为浆故。余文及颂文并可知。十忍品竟

    阿僧祇品第三十

疏。初来意有二等者。一通以后三品对前三品。二别则此品对十忍品。自有三意。一答第二会初。二一为远答下。答第一会中十海。三又通下显一部之数。初中复有二意。一直辨菩萨。又二难思下明菩萨知佛德下。科偈文亦具此二意。疏全带数名者。无数乃是一百二十四数之一故。疏。人法双举者。若人法不同即是相违下。言及菩萨所问之算数即是依主。疏然僧下通妨。妨云。僧祇非初又非是后。何以偏标通意可知

疏。四释文下此先总科有二。一直就法科。后然此三品下约人料拣。疏表数不离者。此释心字。数与非数下释王字。王以自在为义故。又显此数下双明心王二字。心者统摄诸法一切最胜故。王者统御四海为最胜故。从所以偏问下。料拣所问。言转者谓阿僧祇。阿僧祇为一阿僧祇转等

疏。始从一二终至正载者。从一至十为十。次有十三数。谓十十为百。十百为千。十万亿兆京垓梓坏沟涧正载。言载者天地不能容载

疏。小乘六十已至无数者。即俱舍论说六十。向后更无数也。即第十二论引解脱经说六十数中阿僧企耶。是第五十二数。彼文具列。从一至十为十。乃至跋罗搀为一阿僧企耶。于此数中亡失余八。但五十二。今云小乘六十已至无数者。此之无数谓此外更无。非是阿僧企耶也

疏。若依俱舍则以洛叉为亿者。彼论十一释三轮颂云。安立器世间风轮最居下。其量广无数厚十六洛叉。次上水轮深十一亿二万。下八洛叉水除凝结成金谓十一亿。是此方言下。洛叉即是梵语。若并从此方合云下八亿。是水余凝结成金。故知以洛叉为亿

疏。便有四个不可说字者。谓取前例合云不可说不可说不可说不可说。为一不可说不可说转。上两不可说不可说是所积之一数谓一个不可说不可说。两个不可说不可说。乃至不可说不可说个不可说不可说故有四个。今以此又字替却两个不可说字。岂非妙耶。所以举此者。以刊定记破经此又字为长故

疏。果德深广因能趣入者。趣入约证诣前善穷约解了。又所举德一约无碍。二约深广则二不同。然趣入善穷应通无碍深广盖影略耳

疏。称法性之一毛等者。此中文亦影略。若具诸刹毛孔皆有称性及不坏相义。今毛上取称性义故。如法性之无外。刹上取不坏相义故。不遍称性之毛而着。悟者之言更有一意。亦文影。略谓毛安悟者。则显刹因迷有。迷则有分悟则无边。前义直就法论。后义约人取法。思之可见。疏内外缘起非即离故者。亦有二义。一约内外共为缘起。由不即故有能所入。由不离故故得相入。二约内外缘起与真法性不即不离。此复二义。一由内外不即法性故有能所入。不离法性故毛能包刹能遍入。二者毛约不离法性如理而包刹。约不即法性不遍毛孔思之成观。然十段之中一段举数即一段不举。不举欲略举恐失次耳

疏。且从相显下结释显深

    寿量品第三十一

疏。来意中二。先立理二正显。前中正显十身寿量。且寄三身明之。谓真身无修短应身示有修短。前中玄谓玄理鉴谓鉴照。理智冥契以为真身。玄故则虚凝鉴故则朗彻出乎数。不可语其寿命短长出乎域。不可言其形量所在。又出乎数。不可说其一身多身出乎域。不可同其人天之寿。若开上能所证别则三身义具。然应物下辨其应化。故经云。佛以法为身清净如虚空。所现众色形令入此法中。又云。如来真身本无二。应物随机遍十方等

疏。故上品下第二正显来意。于中二。一近广前品兼菩萨寿。二亦为下远答初会唯如来寿。疏二释名等者。亦依真应以立其名。然诸经论说三身寿量。化则有始有终长短万品。报则有始无终一得永常。法身无始无终凝然不变。故法华中以伽耶生双林灭化身也。我本行菩萨道时所成寿命报身也。常住不灭法身也。此经宗意三身既融三寿无碍。即长能短即短恒长。无长无短长短存焉。一一圆融言思斯绝

疏。已邻刹海平等者。犹有数限故致邻言。刹海平等无数量故

    诸菩萨住处品第三十二

疏。来意中三。一广僧祇。二亦远答下酬其初会。三昔将此品下叙异说义如第二会说。疏山海包藏下释山海意。此句约事山藏海纳。言仁智栖止者。寄外典说。夫子云。仁者乐山智者乐水。意云。仁者好山如山之安固不动。智者好水。如水之德清鉴洗涤流止从缘。故非要仁即住山智即近水也。从表大智下正约所表。唯一大智双合上二。高如山深如海。止即是山照即是海。疏应是雪北之香山者。凡有应是之言。即是带疑事难融会不可勇知。固当多闻阙疑矣。言雪北者。俱舍论说雪北香南有阿耨达池。故知雪山在香之南至。疏五清凉山疏文分六。一略释经文。二彰其所表。三定其方所。四显其灵圣。五征其源由。六劝物修敬。今初然略有二名。言代州五台。即五台县及繁峙两县之界。往者非一可略言也

疏。表我大圣下第二彰其所表。多出金刚顶瑜伽。亦有以理推析。言大圣者即文殊也。不指其名直言大圣。今山中称念但云大圣菩萨。即举总称别指吉祥耳。言五智者。若准佛地经论五法摄大觉性谓四智菩提一真法界。依金刚顶即一真法界名清净法界智。故成五智。二五眼可知。三言五部者。一佛部。二金刚部。三宝部。四莲华部。五羯磨部。一切诸天真言皆属宝部。诸鬼神真言属羯磨部。四五阴者即我五阴。表是五台中有大觉。即不动智佛妙慧自在。即是文殊五言首戴五佛之冠者。诸大菩萨多有此冠。而大圣不论戴冠。六复常有五髻。然诸五义类例大同。谓当中髻即中台表之毗卢遮那佛居。是佛部主法界清净智亦佛眼也。其东一髻即是东台是阿閦佛居为金刚部主。是大圆镜智即是慧眼。其南一髻即是南台宝生如来所居。是宝部主是平等性智。即是天眼。其西一髻即是西台阿弥陀如来所居。是莲华部主。即妙观察智即是法眼。其北一髻即是北台不空成就如来所居。是羯磨部主是成所作智。即是肉眼。七若配五乘中即佛乘。东菩萨乘。南缘觉乘。西声闻乘。北是人天乘。若人天乘别北即人乘。合佛菩萨余如次第。八若清五浊但取五不同。不必如次。若配五阴中即识阴。东为行阴南为想阴。西为受阴北为色阴。例为其次识为主故。然五如来皆有种子。一一观行各各不同。学密教者方知其要。今但略属而已。疏然但云东北下。第三定其方所。以经不指国名但云东北故。引经定所。以此经不指者。以在八方之例余之七方皆不指国名在下文故。今恐浅识者惑故引经证。此经亦名八字陀罗尼经广说文殊之德。疏引犹略今更引之。谓彼经金刚密迹主菩萨问如来云。文殊师利于何处方面住。复何方面能行利益。如来答云。我灭度后已下疏文全引。下有偈云。文殊大菩萨不舍大悲愿。变身为童真或冠或露体。或处小儿丛。游戏邑聚落。或作贫穷人衰形为老状。亦现饥寒苦巡行坊市廛。求乞衣财宝。令人发一施与满一切愿。使令发信心。信心既发已为说六度法。领万诸菩萨。居于五顶山放亿众光明。人天咸悉睹罪垢皆消灭。或得闻持法一切陀罗尼秘密深藏门。修行证实法究竟佛果愿。具空三昧门习尽泥洹路。文殊大愿力与佛同境界。下更广赞其德。不能繁叙要当寻经

疏。其山灵迹下第四显其圣灵。于中二。初略指诸文。后自述所睹。前中本传甚广略有六门。一立名标化。二封域里数。三台顶塔庙。四诸寺庙宇。五古今灵应。六闻名礼敬功德。然今文中皆已略有。今初二句通指诸门。地里志云。其山层盘秀峙路径纡深。灵岳神溪非薄俗所居。悉是栖神禅寂之士。冥搜造微之俦矣

疏。余幼寻下二自述见闻。于中有二。先叙至山源由。由此菩萨住处清凉山之文。当时逆寇乱常兵戈蜂起豺狼满路。山川阻绝不惮而游。故云委命栖托。途虽五千反覆万里。始本暂游日复一日倾驰圣境。一十五年作疏至斯正当十载

疏。其感应下正叙见闻。从其山势寺宇下略指佳境。其山在长安东北一千六百里。离代州之东南百余里。磅礴数州七百余里。左邻恒岳秀出千峰。右接孟津长流一带。北临绝塞遏万里之烟尘。南拥汾阳为大国之艮。背回泊日月蓄泄云龙。虽积雪夏凝。而名花万品寒风劲烈。而瑞草千般丹嶂横开。翠屏叠起排云拨雾。时逢物外之峰。扪萝履危每到非常之境。白云凝布夺万里之澄江。杲日将升见三尺之大海。五峰一一难具言也。言寺宇者。北齐崇敬置立伽蓝。故壤二百余所当时栖托寺有八焉。贞元已来数早过十。或五峰抱出或双岭中开。或叠起岩中或耸居云外。不可具言也

疏。自大师晦迹下。第五征其源由。兼彰圣迹。初对正叙本源。大集经中佛将涅槃委诸菩萨。分卫大千。此土多有毒龙为害人多爱乐大乘故妙吉祥菩萨处斯以行化。故云妙德扬辉于东夏。文殊般泥洹经云。若但闻名者。除十二亿劫生死之罪。若礼拜者恒生佛家。若称名字一日七日文殊必降。若有宿障梦中得见。得见形像斯人位阶圣果应化广大。故曰扬辉。次对成上两句。初成上大师晦迹。兼通妨难。谓有问言常在灵鹫山及余诸住处。何言晦迹。故今答云。二圣之本本皆湛然。二圣之迹迹有隐显。今灵鹫山尽是荒榛所翳。鸡山即是鸡足。亦鹫岭所管。应现下成上扬辉于东夏。山似灵鹫故言鹫岭得名。次下当说

疏。神僧显彰于灵境等者感通传云。宇文后周时文殊化为梵僧。来游此土云欲礼拜迦叶佛说法处并往文殊师利所住之处名清凉山。唐初长安师子国僧。九十九夏三果人也。闻斯圣迹跣行至此。礼清凉山皆神僧显彰也。言宣公上禀于诸天者。南山感通传云。时有天人姓陆名玄畅。来诣云。弟子周穆王时生天。余乃问曰。宇内所疑自昔相传。文殊在清凉山领五百仙人说法。经中说文殊久住娑婆世界。娑婆则大千之总号。如何偏在此方。天人答曰。文殊是诸佛先师。随缘利见应变不同。大士大功非凡人境界。不劳评薄。但知多在清凉五台之中。往往有人见之不得不信。故云上禀于诸天。又今山南有清凉府五台县。山北有五台府。亦可万代之龟镜故无惑矣。疏。汉明肇启于崇基魏帝中孚于至化者。按感通传云。今五台山东南三十里。现有大孚灵鹫寺。两堂旧迹犹存。南有花园可二顷许。四时发彩人莫究之。或云。是汉明所立。又云。魏文所作互说不同如何。天答曰。俱是二帝所作。周穆王时已有佛法。此山灵异文殊所居。周穆于中造寺供养。及阿育王亦依置塔。汉明之初摩腾天眼亦见有塔。请帝王立寺。山形似于灵鹫。故号为大孚灵鹫寺。大孚者弘信也。帝信佛理立寺劝人。花园今在寺前。后之君王或改为大花园寺。至则天大圣皇后。与于阗三藏译华严经。见菩萨住清凉山。因改为大华严寺焉。五顶攒拥中开山心。离坎乾坤得其中理。千岩耸秀万壑森沈。拔鹫岭之仙峰成华严之一叶。信可谓众灵翔集之冲府参贤觐圣之玄都矣。所以前云鹫岭得名于兹土。疏。北齐数州以倾俸者。传云。北齐高帝笃崇大教。置二百余寺于兹山。割八州租税而供山众衣药之资。至今犹有五道场庄。疏。有唐九帝之回光者。自我大唐至于今圣。相继九叶无不回于圣鉴。言今圣者。当德宗帝倾仰灵山。御劄天衣每光于五顶中。使香药不断于岁时。金阁岧峣于云端。犹疑圣化。竹林森耸于岩畔宛似天来。故得百辟归崇九州持供。云委雾合匝地盈山。非我诸佛之祖师积万行于旷劫。慈云弥漫而普覆。智海黯湛而包纳。廓法界为疆域尽众生。为愿门矣。孰能应感若兹宿善何浓。遇斯遗迹情跃不已形于咏言

大方广佛华严经随疏演义钞卷第七十六大方广佛华严经随疏演义钞卷第七十七

        唐清凉山大华严寺沙门澄观述

疏。五天殉命以奔风下。第六劝物修敬。初二句引例劝修。五天竺国粗云二十万里。孰知其实数耶。若以陆行途经数百国。云山几万重。或扪索凭虚。或飞梯架回或风行雪卧。或木食松栖。或恶兽盈群。或盗贼相继。若以水行洪涛无岸。云岛潜回精怪摇风。鲸鲵鼓浪日月出没于波底。魂魄飘扬于梦中。纵使浪息风停。只见水涵于天际。舟行棹举犹将息念作生涯。虽此难危而三藏名僧相继而至。总缘大圣委命轻生。故云五天殉命以奔风。言八表妄躯而竞托者。自东自西自南自北。天徼月窟海潮日出。有耳目者不惮艰辛远而必至焉疏。其有居神州下。正劝即反举不往之失。以彰往者之得。谓葱岭之东地方数千里曰赤县神州。即有唐中华之国也。去清凉之境途程不遥。坦然通衢车马溢路。随方观化不失家常。往必感征如何不往。是知不往即是三亿之徒。故今秉钺分茅方面之重无不倾仰。西域诸王恨生五天不产东夏。岂唯遥礼大圣。每多仰羡此君。故有游西天者。先问曾居五台山不。若不曾居弃而不顾。今此国众生宿因多幸。得诞中华。诸佛祖师不解修敬。故此劝之。三亿之徒者。智论第十一云。佛出世难值如优昙华时乃一有。如是罪人轮转三恶道。或在人天中。佛出世时天人不见。如说。舍卫城中有九亿家。三亿家眼见佛三亿家耳闻有佛而眼不见。三亿家不见不闻。佛在舍卫国二十五年。而此众生不见不闻何况远者。故今中华有人曾到台山。即亦闻亦见。有闻清凉而不得到。即同闻名不见。只近五台亦有不闻不见之者。况于远乎。故劝修敬若见文殊。功德之广如前略说。广在经文

疏。案西域记第七等者。彼云吠舍厘国即毗耶离。梵音楚夏。云城东南行十四五里。至大窣堵波是七百贤圣重结集处。佛涅槃后百一十年。吠舍厘城有诸苾刍。远离佛法谬行戒律。时长老耶舍陀住憍萨罗国。长老三菩伽住秫菟罗国。长老厘波多住韩若国。长老沙罗住吠舍黎国。长老富阇苏弥罗住娑罗梨佛国。诸大罗汉心得自在。持三藏得三明有大名称众所知识。皆是尊者阿难弟子。时耶舍陀遣使告诸贤圣。皆集吠舍厘城。犹少一人未满七百。是时富阇苏弥罗。以天眼见诸大贤圣集议法事。运神足至法会时。三菩伽于大众中右袒长跪扬言曰。众无諠哗钦哉念哉。昔大圣法王善权寂灭。岁月虽淹言教尚在。吠舍厘城懈怠苾刍谬于戒律。有十事出违十力教。今诸贤者深明持犯。俱是大德阿难指诲。念报佛恩重宣圣旨。时诸大众莫不悲感。即召集诸苾刍。依毗奈耶诃责制止削除谬法。宣明圣教。七百贤圣结集。南行八九十里至湿吠多补罗僧伽蓝。层台轮焕重阁翚飞。僧众清肃并学大乘。其侧则有过去四佛座。及经行遗迹之处。其傍窣堵波无忧王之所建也。如来在昔南趣摩揭陀国。北顾吠舍厘城中途止息遗迹之处。疏。巴连弗邑等者。西域记第八云。摩竭陀国殑伽河南有故城周七十余里。荒芜虽久基址尚存。昔者人寿无量岁时。号拘苏摩补罗城。唐言香花宫城。王宫多花故以名焉。逮乎人寿数千岁。更名波吒厘子城。旧云巴连弗邑讹也。初有婆罗门高才博学。门人数千传以受业。与诸学徒相从游观。有一书生徘徊怅望。同俦谓曰。夫何忧乎。曰盛色方刚羁游履影。岁月已积艺业无成。顾此为言忧心弥剧。于是学徒戏言之曰。今将为子求嫂婚亲。乃假立二人为男父母。二人为女父母。遂坐波吒厘树。谓女婿树也。采时果酌清流。陈婚姻之绪。请好合之期。时假女父攀花枝以授书生曰。斯嘉偶也。幸无辞焉。书生之心欣然自得。日暮言归怀恋而止。学徒曰。前言戏耳。幸可同归。林中猛兽恐相残害。书生遂留往来树侧。景夕之后异光烛野。管弦清雅帏帐陈列。俄见老翁策杖来慰。顷有一妪携引少女。并宾从盈路袨服奏乐。翁乃指少女曰。此君之弱室也。酣歌乐宴经七日焉。学徒疑为兽害往而求之。乃见独坐阴树若对上客。告与同归。辞不从命。后自入城拜谒亲故说其始末。闻者惊该。与诸友人同往林中咸见花树。是一大宅僮仆役使驱驰往来。而彼老翁从容接对陈馔奏乐。宾主礼备。诸友还城具告远近。十岁之后生一男子。谓其妻曰。吾今欲归未忍离阻。适复留心栖寄飘露。其妻既闻具以白父翁。谓书生曰。人生行乐讵必故乡。今将筑室宜无异志。于是役使灵从功成不日。香花旧城迁都此邑。由彼子故神为筑城。自尔之后因名波吒厘子城焉

疏。摩度罗亦云摩偷罗。亦中印度境。西域记第四者。彼记名秫菟罗国。记中不说孔雀之缘。言有舍利等塔者。等取大目揵连及富楼那塔。言寺北有岩等者。记云城东行五六里。至一山伽蓝疏崖为室因谷为门。尊者乌波鞠多(唐言近护)之所建也。其中则有如来指爪窣堵波。伽蓝北岩间有石室。高二十余尺广三十余尺。四寸细筹填积其内。尊者近护说法化道。夫妻俱证阿罗汉果者乃下一筹。异室别族虽证不记

疏。安筹虽是后事等者。恐人设难云。既是鞠多建窟乃是佛灭之后百年中事。今是始成说经。那是彼窟故为此通

疏。三俱珍那城者。大同释娇陈如名

疏。目真此云解脱等者。西域记第八云。自支邻陀龙王池其水清黑其味甘美。西岸有小精舍中作佛像。昔如来初成正觉。于此宴坐七日。入定时此龙王警卫如来。即以其身绕佛七匝。化出多头俯乘为盖。故池西岸有其室焉疏。摩兰陀国未详所在者。更以义推。摩兰陀即摩伽陀。无碍龙王建立正是普光法堂。是今说法之处耳。以不指云此处故云未详所在

疏。大集但名慈窟者。即月藏分第十亦但列名。无别指处。下当具引月藏之文

疏。此云多思惟者。婆沙亦云支那。此云汉也。西域记云大汉具云摩诃支那。故真谛三藏云衣物。意云。是衣冠人物之国。皆是义翻。疏翻为正

疏。亦青州分野者。禹别九州东为青州。则天下分其九分野矣

疏。然今之到此山者。相传云。以是秦始皇筑长城到此毕工故立其名

疏。八疏勒国等具云佉路数怛勒者。西域记第十二云。出葱岭其乌铩国。此国城西二百余里至一大山。从此北行山碛旷野五百余里。至佉沙国。旧云。为疏勒者。乃称其城号也。正音具云室利讫栗多底。疏勒之言犹为讹也。释曰。疏依古疏。即日照三藏释西域记云。佉沙国周五千余里。多砂碛少壤土。稼穑殷盛花果繁茂。从此东南行五百余里。济河踰沙至斫句迦国。唐言沮渠周千余里。国南境有大山。崖岭嵯峨峰峦重叠。草木凌寒春秋一观。溪涧浚濑飞流四注。崖龛石室棋布严林。印度得果人多运神通。轻举远游栖止于此。诸阿罗汉于此寂灭者众。是故多有窣堵波也。今犹现有三阿罗汉居岩岫中。入灭心定。形若羸人须鬓恒长。故诸沙门时往为剃。而此国中大乘经典部数尤多。佛法至处莫斯为盛也。十万颂为部者凡有十数。自兹已降其流寔广(释曰据此华严等经却在此国)从此而东踰岭越谷行八百余里。至瞿萨旦那国。唐言地乳。即其俗之雅言也。俗语谓之汉那。凶奴谓之于遁。诸胡谓之豁旦。印度谓之屈丹。旧曰于阗者讹也。瞿萨旦那国周四千余里。砂碛大半坏土隘狭。宜谷稼多众果。宗尚佛法伽蓝百余所。僧徒五千余人。并多习学大乘教法。王甚骁武敬重佛法。自云毗沙门天之祀胤。也昔者此国虚旷无人。毗沙门天于此栖。宅无忧王太子在呾叉始罗国。被抉目王怒谴。谪辅佐迁其豪嫉出雪山北。居荒谷间迁人逐牧。至此西界推举尊。豪首立为主当是地也。东土太子蒙谴流徒。居此东界群下劝进。又自称王岁月已积风教不通。各因畋猎遇会荒泽。更问宗绪因而争长。忿形辞语便欲交兵。或有谏曰。今何遽乎。因猎决战未尽兵锋。宜归治兵期而后集。于是回驾而返各归其国。校习戎马督励士卒。至期兵会旗鼓相望。旦日合战西主不利。因而逐北遂斩其首。东王乘胜抚集亡国。迁都中地方建城郭。忧其无土恐难成功。宣告远近谁识地理。时有涂灰外道。负大瓠盛满水而自进曰。我知地理。遂以其水屈曲遗流周而复始。因即藏躯忽而不见。依彼水迹峙其基堵。遂得兴工即斯国治。今王所都于此城也。城非崇峻攻击难克。自古已来未能有胜。其王迁都作邑建国安人工绩已成。齿耄云。暮未有胤嗣恐绝宗绪。乃往毗沙门天神所。祈祷请嗣。神像额上剖出婴孩。捧以回驾国人称庆。既不饮乳恐其不寿。寻诣神祠重请养育。神前之地忽然隆起。其状如乳神童饮吮。遂至成立。智勇光前风教遐被。遂营神祠崇先祖也。自兹已降弈世相承。传国君临不失其绪。故今神庙多诸珍宝。拜祀享祭无替于时地乳所育因为国号。王城南十余里有伽蓝。此国先王为毗卢折那。唐言遍照。阿罗汉建也。王城西南二十余里。至瞿室[飢-几+夌]伽山。唐言牛角山。峰两起岩隒四绝。于崖谷间建一伽蓝。其中佛像时烛光明。昔如来曾至此处。为诸天人略说法要。悬记此地当建国土敬崇遗法遵习大乘即今处也。牛角岩有大石室。中有阿罗汉入灭心定。待慈氏佛。数百年间供养无替。近者崖崩掩塞门径。国王兴兵欲除崩石。即黑蜂群飞毒螫人众。以故至今石门不开释曰。据此亦为圣居。或指江表牛头者。即金陵南四十里有山名牛头。谓由此山有双峰。故一名双阙。一名天阙。一名南郊。一名仙窟。皆以累朝改革不定。按域地志云。此山高一千四百尺周回四十七里。准西域记及旧华严经菩萨住处品。心王菩萨告诸菩萨言。东北方边夷国土名牛头。若按新经云。疏勒国有一住处名牛头山。如前所引西域记文。此与真丹处则异也(此文见金陵塔寺记)古老相传云。是辟支佛现形之所。而前后文多云菩萨于中止住。而其灵应往往有之

疏。迦湿弥罗记第三云。北印度境末田乞地即阿罗汉名。昔云末田乞地。新云末田底迦迦湿弥罗国。周七千余里。四境负山山极峭峻。虽有门径而复隘狭。自古邻敌无能攻伐(云云)昔此国本龙池也。佛世尊自乌仗那国降恶神已欲还中国。乘空当此国上。告阿难曰。我涅槃后有末田底迦阿罗汉。当于此地建国安人弘扬佛法。如来寂灭之后第五十年。阿难弟子末田底伽阿罗汉者。得六神通。具八解脱。闻佛悬记心自庆悦。便来至此。于大山岩宴坐林中。现大神通。龙见深信请咨所欲。阿罗汉曰。愿于池内惠以容膝。龙王于是缩水奉施罗汉。神通广身。龙王纵力缩水。池空水尽龙翻请池。阿罗汉于此西北为留一池。周百余里自余枝属别居小池。龙王曰池地总施愿恒受供。末田底迦曰。我今不久无余涅槃。虽欲受请其可得乎。龙王重请五百罗汉常受我供乃至法尽。法尽之后还取此国以为居池。末田底迦从其所请。时阿罗汉既得地已。运大神力立五百伽蓝。于诸异国买鬻贱人。以充役使以供僧众。末田底迦入寂灭后。彼诸贱人自立君长。邻境诸国鄙其贱种。莫与交亲谓之讫利多(唐言买得)今时泉水已多流溢

疏。乾陀罗国。西域记第三云。健驮逻国有伽腻色迦王。以如来涅槃之后第四百年。应期抚运王风远被殊俗内附。机务余暇每习佛经。日请一僧入宫说法。而法异仪部执不同。王用深疑无以去惑。时胁尊者曰。如来去世岁月逾远。弟子部执师资异论。各据闻见共为矛盾。时王闻已甚用感伤。悲叹良久谓尊者曰。猥以余福幸遵前绪。去圣虽远犹为有幸。敢亡庸鄙绍隆法教。随其部执具释三藏(下取意)遂召众僧七日供养欲议法事。宣先下令去凡留圣。圣众犹多复去有学。无学犹多次留具三明六通具者。犹多次取内具闲三藏外达五明。乃至四百九十九人。后一世友未得罗汉等。广集三藏凡三十万颂。王以铜鍱镂写。石函封缄。全舍此国与僧故多圣居也

疏。苫末罗者。此翻为黄杂色。初品经巧幻术修罗王苫末罗王乃偈共长行。唐梵互出。与此释不同偈云红色光神。又其城东南十余里有窣堵波。中有佛牙长可寸半。其色黄白彼多圣迹故是圣居

疏。相传云。是佛留影处者。即西域记第二说。那揭罗国城西南二十余里有伽蓝。伽蓝西南深涧峭绝。瀑布飞流悬崖壁立。东岸石壁有大洞穴。瞿波罗龙之所居也。门径狭小窟穴冥闇。崖石津壁溪径余流。昔有佛影焕若真容。相好具足俨然如在。近代已来人不遍睹。纵有所见仿佛而已。至诚祈请有冥感者。乃暂明示尚不能久。昔如来在世之时。此龙为牧牛之士。供王乳酪进奉失仪。既获谴责心怀恚恨。即以金钱买花供养受记。窣堵波愿为恶龙破国害王。即趣石壁投身而死。遂居此窟为大龙王。便欲出穴成本恶愿。适起此心。如来已鉴愍此国人为龙所害。运神通力自中印度至龙所。龙见如来毒心遂止。受不杀戒愿护正法。因请如来常居此窟。诸圣弟子恒受我供。如来告曰。吾将寂灭为汝留影。遣五罗汉常受汝供。正法隐没其事无替。汝若毒心忿怒起时当观吾影。以慈善故毒心当止。此贤劫中当来世尊。亦愍汝等皆留影像。释曰。此与观佛三昧海经大同。已如初会钞引。然西域记云。此国无别君长。属迦毕试国。去健驮逻国不远。或曾属之耳

疏。具如西域记及大集月藏分第十者。此即总指上来诸处引。西域记不局一卷。月藏分的指第十。然月藏分当第十二。有十卷经。第十卷中。即建立塔寺品第十九。尔时娑婆世界主大梵天王释提桓因曰。四大天王等。及诸眷属从坐而起。合掌向佛一心敬礼。而作是言。佛说于此四天下中所有过去诸佛如来之所建立住持。大塔牟尼诸佛所依住处。于现在世及未来世。而常不空。佛与菩萨摩诃萨等。降大法雨皆悉充满。初名众仙所兴。次名德积次名金刚焰次名香室次名睒婆梨次名贤城次名须质多罗次名水光次名香熏次名善建立次名遮波罗次名金灯次名乐住次名牟真邻陀次名金刚地次名慈窟次名那罗延窟次名渠摩娑罗香次名惠顶次名大德窟次名善现次名青郁茂次名虚空子次名牛头栴檀室次名难胜。此是过去诸佛建立住持大塔常为菩萨等之所加护。是故我等常所供养。世尊所有声闻弟子。于现在世及未来世。复有几所塔寺住处。令我等辈护持养育。然此初数处与此经同可以意得。故不具引。下取意引。尔时世尊微笑。面门放种种光。时四天下有无量百千诸佛住处而现。东州八万佛现。北州百千西州五百南州二百五十千佛处现。广说诸国各有佛现等。下诸天龙等发愿护持

    佛不思议法品第三十三

疏。初来意者文二。先正明后解妨。今初古德但有三品者。以后二品别为平等因果故。用品虽广狭不同答果义等。疏若答前问下二解妨。先问以前六会共答前问。皆不重请故。问此品何以重请。从因果隔绝下古德答。此乃有二意。一因果隔绝。前诸会同因故不别问。此下是果果隔于因故。此重问。二念法希奇果不思议故。复念请。从因德已下出念法希奇之相。上是通意。二别明下唯明此品。疏别就宗中三门分别。初通辨佛德。二别显义相。三显不思议。今初通辨中。言百四十不共者。已见光明觉品。今重举总数。谓三十二相八十种好四一切种清净十力四无所畏三念住三不护大悲无忘失法永断习气一切种妙智为百四十。而言通权小者。小乘亦说。但相劣耳。权大说者皆悉超胜。此约五教已有其二。若五法下正明实教。故云通权。权实皆有。但实教中会归法性不坏相耳。若言唯一味下二即顿教。若言具无尽下三即是圆教。从故后文中下四辨今经是圆教德。疏二别显义相下。于中有三。初正显二德。二四句融通。三拣权异实。今初言信等者。此通行位信为万行之首。则该进念定等位。亦以信为初。五十二位所有行德皆有二故。疏此二无碍下第二融通可知

疏。若权教所明下第三拣权异实。初明权教。言不杂者。如转依果有二。一者所生得即是四智。二所显得即是涅槃。涅槃本有四智修生。修生有为修显无为。故二不杂

疏。法报四句亦有差殊者。遮救。恐外救云。我宗亦有四句。何异前融。谓一唯法即在缠法身。二唯报即四智菩提。三亦法亦报。谓真如出缠具诸功德。四非法非报所谓应化。今言亦有差殊者正拣权也。虽有四句染净时乖法报非一。思之。后依此经宗下显实举喻四句喻上四句。一本有如真金。是前第二句。二修生如严具喻第一句。三然由严具方显金德。喻第四句修生本有。四严具无体全揽金成喻第三句。此即合初二句成三四句。离初二句无三四句。三四两句同在一时。更无别体。以此细寻权实斯显。五故唯金不碍严具下结第二句归初句。六唯严具亦然。结第一句。归第二句。此约喻说。若望前法但初句为第二。第二句为第一耳。从既互全收下结归本宗无碍之相。今更以喻总喻二德。如修生在因渐显于本有。在果圆满于本有。非本有理有渐有圆。如初生月明虽渐满。而常带圆月。以圆月常在故。故十五日月遍在初一二三等中。则知满果遍在因位。亦令后后常具前前。前前常具后后。以初一日有二日月乃至十五日月以十五日月即初月。故法合可知。由此故云修生本有。以初圆时先已圆故。本有修生以初生时亦已圆故。妄怀思之。疏三显不思议中三。初泛举法体。二就后一中下别语此经。三前并是宗下结归宗趣。二中四者。一何者不思议征不思议法体。答谓智悲等。二于何不思议征不思议人。答谓世间等此人不能思议。三云何不思议征不思议体。谓闻思等思不及故。四何用不思议征不思议意。谓如来说法本欲利生。今绝言思于物何益。答意云。令信入故。谓欲证入要。须心绝动摇言忘戏论耳。疏后四别显佛德者。是疏新意。欲将五品答其十问。然有三重。一此品总明佛德。具答十问。如下科释。二者一一门中含答十问。亦如下释。三者五品广答十问。如下说分之初。疏古德后二品下叙昔。疏且述古。便依三品科经

疏。后诸佛下正显所念。疏文有三。一略示法体。其不得一向下结弹异释。二然此下对前相摄。三此十义相下指前释相。二中今当先列第二会初二十句问。一如来地。二如来境界。三如来神力。四如来所行。五如来十力。六如来无畏。七如来三昧。八如来神通。九如来自在。十如来无碍。十一如来眼。十二如来耳。十三如来鼻。十四如来舌。十五如来身。十六如来意。十七如来辩才。十八如来智慧。十九如来最胜。二十欠光明故唯十九。然句句皆有云何是言。经中十句次第可知。此中摄彼不依次第。对前成三类故。一前开此合。二前合此开。三无开无合。欲以此少摄彼之多故。先明前开此合。于中乃有三句。摄前十六句。第二前合此开。以前二句摄五句。第三节彼一句。则此中初合有三。次此开有六。后此不开有一。具足十句。后前初开有十六。次合有二。后不开合亦一成十九句。就初前开中。第一身摄六根者。身即六中之一。兼摄欠光明一句故有七句。第二智慧摄三。兼能摄智为四。第三自在摄五。兼能摄自在为六故成十六。第二前合此开。中亦有三节。而初境界开国土无能摄句。境界由前智慧已摄竟故。故虽三节但有二句。境界是所化之境。国土是所依之境。第二节所行摄三。即有能摄。然三皆行故。言出现与行互有宽狭者遮难。恐有难言。彼十门出现行是其一。如何此行能摄彼耶。故以互有宽狭通之。如以菩提为门则菩提之性摄于涅槃。若以涅槃为门则涅槃般若摄于菩提。疏前之无碍此开解脱者。是第三节则前但有一。此则具于无碍解脱。疏音声即辩下。第三无开合。前后各一句更为立图

佛不思议品初十问○──如来名号品二十问○┐

┌─────────┘　　┌────────┘

└○一国土○───────○二如来境

    二本愿○┐　　┌────四所行

    三种性○├──┘　　┌─十一眼

    四出现○┘　　　　　│　十二耳

                        │　十三鼻

    五身○───────┤　十四舌

                        │　十五身

                        │　十六意

                        └─二十光明

    六音声○────────十七辩才

                        ┌─一佛地

    七智慧○──────┤　十八智慧

                        └─十九最胜

                        ┌─三神力

                        │　五十力

                        ├─六无畏

    八自在○──────┤　七三昧

                        │　八神通

                        └─九自在

    九无碍○─┬──────十无碍

    十解脱○─┘

疏。七智性无差为次第者。成十九最胜。彼欠二十光明行。次第本性无差性随次第而终不易

疏。果德离言藉因显故者。此文有四节。此对表华之义。经宗有因果二分。十地已明华引果故。二因果同时下表莲华义。谓有问言。是华引果何要莲华。故答云。余华多华前果后。此华不有则已有则华实双含。又无染故。故举莲华。三又问言。莲华有四何要举青。故答云最超胜故。论云水生华胜者。即优钵罗华故。四又莲华一莲多子。表一含一切故。此释藏义。疏二者此品具答十问下。文中三。先总标示。二昔以初十下叙昔。三今谓下显正。于中三。初略示大意。二文分为下正科三。今初下释文。但明记上十问寻文易了。或开或合显义无方耳。疏如文殊般若中辩。光明觉品已引。疏别中十句多同出现。身之十相者。彼之十相即是十身。一普入成益相即威势身。二无心普应相即是化身。故云种族调善。三平等随应。即菩提身。由菩萨智无所住故。平等随应。四无著无碍。即智身。五周遍十方。即是法身故云一性。六严刹益生。即福德身七无生潜益。即相好庄严身。八严好满愿。即是愿身。愿力周法界恒转妙法轮故。九穷尽后际。即力持身故。彼经中以医王延寿为喻。喻佛虽涅槃而不失利乐。十圆回等住。即意生身。故云心念则现。以彼十相十身对今经文。一无差异其有难者随句已释。若依彼次此一即彼三。二即彼七。三即彼四。四即彼二。五即彼一。六即彼九。七即彼五。八即彼十。九即彼八。十即彼六。但彼文广理无二也。疏后一意生等身净者。由言解脱自在故云意生身。言等身者。等取愿身化身等也

疏。四即三念处行者。亦云三念住。念谓能缘之慧。处谓不增不减平等之理。初一心听法不忧。二一心听法不喜。三常行舍心。以法界中减退相不可得故。增进相不可得故。即涅槃相故。如次配之。疏三后善谓究竟离垢等故者。等字等取及一切究竟离欲为后边故。法性离垢故。能学者亦离垢故。修行究竟得离垢故

疏。诸经论中更有多释恐厌繁文者。智论云。赞布施为初善。赞持戒为中善。赞二果报生天净土名后善。复说声闻独觉。大乘亦名三善。宝惬经云。知苦断集名初善。修八正道为中善。证灭名后善。是名声闻初中后善。若不舍菩提心不念下乘。回向一切智。是名菩萨初中后善等。释曰。今疏全依瑜伽故指余释

疏。余七经文略无者。谓略故无非是全无。今依瑜伽具出论云四者文巧谓善缉缀名身等故。及八语具者。一先首二美妙三显了四易解五乐闻六无依七无违八广大。如瑜伽二十五说。五义妙。谓能引发利益安乐。六纯一。谓不与外道共故。唯佛法有外道所无。七圆满无限量故最尊胜故。义丰且胜故名圆满。八清净。谓自性解脱故。一刹那自体解脱故。或法自体解脱故。九鲜白。谓相续解脱故。设多刹那亦解脱故。能学之者亦解脱故。十梵行之相。谓八圣道支灭谛名梵。道谛名行与灭为因。此具八道名梵行相。当知此道由纯一道等四种妙相之所显说(四十七经)疏今初十力是别名下。疏文有六。一总科。二是则标中十力一一遍下别中下融通。三古德下叙昔。四则令别中下辨违。五设欲下遮救。六十中一广大下正释。四中言亦令余门。无广大义者。以广大为初门故。言初门无最上等者。初门唯有广大故无余九。最上在初略举其一等于下八。疏设欲下五遮救。谓彼救云。虽则互有何方从多立名。故今答云。从多可尔不应顺次。以逆次配与文相顺故。下释文一一从多。逆次名释。然总名那罗延幢者。即帝释力士之名。疏耆婆入火现相已引。入狱问罪即报恩经第四。令耆婆往阿鼻地狱问调达云。汝今受罪云何。答云。如第三禅乐。今取入中问罪苦不能害耳。疏心善解脱由三相者。即瑜伽八十五说(四十八经)

    十身相海品第三十四

疏。如来十身标人显德者。疏文有四。一释名。二辨类。三出体。四辨因。若准探玄宗中有佛相章。八门分别。一释名。二体性。三种类。四出因。五积成。六修时。七建立。八业用。今四门中已具其要。疏观佛三昧下第二辨类。即引证以辨。于中二。先正明二料拣。前中即第九经菩萨本行品第八。佛告阿难。如来有三十二大人相八十随形好。金色光明。一一光明无量化佛身。诸毛孔一切变化。及一切色。略中略说者。我今为此时会大众及净饭王。略说相好。佛生人间示同人相故。说三十二相。胜诸天故说八十种好。为诸菩萨说八万四千诸妙相好。佛实相好我初成道摩竭提国寂灭道场为普贤贤首等诸大菩萨。于杂华经中已广分别。释曰。略中略言即是经文。二略三广。乃疏取意释之。以前有略中略则必有略矣。又彼先说八万四千。今有十莲华藏故。对彼为广。则彼经文从为诸菩萨说八万四千诸妙相好。为第二段。从佛实相好我初成道下为第三段。文亦分明。疏三中初通下第二料拣。依前三类三重料拣。第一约乘。二约三身十身。三约机见。今初兼含五教。初一小乘及始教。二即终教。三即圆教。其顿教以无相为宗。后二兼举因显果。言示同于人端正不乱者。俱舍说轮王相云。相不正圆明。故与佛非等。此明轮王有三十二相。有三义不及如来。一处不正。二相不圆。三不明了。今正不乱即处异轮王。其端正二字是明是圆故示同人而胜人矣。疏次唯大乘等者。即明果相。如因中断八万四千烦恼成八万四千波罗蜜。获八万四千相好。无量寿观经云。阿弥陀佛有八万四千相。一一相有八万四千随好。一一好复有八万四千光明。一一光明遍照法界念佛众生摄取不舍。即此中等相也

疏。又初化下第二约三身十身料拣。若配三身二是报身。三是法身。若约四身。二由属他受用报有分限故。后即自受用报及法。又法身无相。今前二属三身。后一属十身。十身必融三身故。后具前二。疏又初凡圣同见下三约机见料拣。次唯地上者。他受用故。上报化不同。后唯圆机即属圆融不分地前地上。故云然通五位。此五位者。即三贤十圣等妙二觉六位之中除果位耳。若开十信即除等觉。疏若语其体下第三出体。二即定慧者。以法门为相故

疏。若语其因下第四辨因。通纯杂者。即是圆融相因如前主水神处已明。疏前二相因如瑜伽等者。指广有源。瑜伽四十九云。一切菩萨资粮皆感相好。作恶业者宣说种种业。各各感等。如是三十二相无有差别。当知皆由净戒为因。若犯戒尚不得下贱人身。况佛相好。若言各各业感如契经说。即是别因。就中有一行感一相。如云若诸有情有所希冀随其所乐正舍珍财感得颊如师子。是或一行感多相。如能施悦意发喜饮食严具等感身皮金色常光一寻一毛孔一毛生身皮细滑等。或多行感一相如言于其父母种种供养于诸有情诸苦恼事种种救护由往来等动转业故得足下千辐轮相。又由四种修事业感一切相。谓决定修感足下善安住。由委悉修感千辐轮等。由恒常修感纤长指等。由无罪修感余相皮金色等。又诸佛加行感异释曰。此即一行品类所感不同。论云。此相好种性地有种子。胜解行地修方便。清净增上意乐地名得。余上地转。胜清净。佛地善净无上。即此相由所依性能任持故。由极殊妙令端严故。说名随好。释曰从即此相由所依下释好义。好义后品方用。因便此引其智论涅槃等经。初会主水神处已引。若观佛三昧海经。次前明三品相后云。佛告阿难。如来往昔无量无边阿僧祇劫。以智慧火烧烦恼薪。修无相定不作非时证。是故获得如是相好。一一相中无量化佛何况多耶。释曰。此通后二相因。疏令修无尽之行显成为趣者。显约本有成约修正。疏普贤本是会主者。此下通不请之妨。有二意通初意可知。二或前品末下。二约五品答问通。谓先列国土等十问。前品答种性问。此下四品更答四问。余之五。问或在此品之前已答。经来未尽所以略无别属问答。前品已明

大方广佛华严经随疏演义钞卷第七十七大方广佛华严经随疏演义钞卷第七十八

        唐清凉山大华严寺沙门澄观述

疏。第二佛子下。疏文有三。初举数总科。二或略不具下料拣。三细论一相下大科。于中先纵成经次。后今以类例下大科十九。言斯即顺观相海者。观佛三昧海经。观佛相海有二。一总观有三十二等。二别观一一诸相。就别观中复有二义。一从顶至足名为顺观。二从足轮至顶名逆观。故云今是顺观。据普贤言应言顺说。为欲成观是本意故名为顺观。即彼第九经观像品第九。疏若尔余可不然者。上正圆融。此下通妨谓有问言。若表圆融何不诸相皆具三十二耶。答意可知。而文亦三。初正答二故。善生下引证。三此约相好相对下亦是通难。难云。诸经论说伏于人故。说三十二相。伏诸天故。说八十种好故。人中轮王许有三十二相。而无八十种好则好胜矣。故为此通。谓此约相体以对好体。相胜于好。彼约人具则具好为胜亦如世人一尺之面不及三寸之鼻。三寸之鼻不及一寸之目。则相相相望以辨胜劣。若有人有三寸之鼻一寸之目。更无余相。则不及身总具多相为贵人矣

疏。一列名名从用立者。谓此名光照一切方等。下辨业用云一一咸放摩尼宝光等。明知从用以立光名。下诸文势皆悉如是。或从用立。或从体得可以意求。疏观佛三昧经云如合拳者。即第四经。引此成上如拳。拳言尚隐合拳即覆拳于顶上有隆起之相也。然此相能灭一切罪。长一切福故。佛顶尊胜正明于此。即乌瑟尼沙暂念暂观。延善住之寿灭地狱之苦。不受七反畜生水离人间残报疏。即具十楞等者。亦观佛三昧经第二广说观白毫相。彼经先说白毫之因云。从舍心不悭不见前相不忆财物无所封着而行布施(下取意引)持戒忍辱六度十力四无所畏诸妙功德生。次云。我灭度后有诸弟子昼夜六时能于一时中。少分少分之中能须臾间念佛白毫。令心了了。无谬乱想。分明止住注意不息。念白毫者。若见相好若不得见。如是等人除九十六亿那由他恒河沙微尘数劫生死之罪。佛告父王。如来有无量相好。一一相中有八万四千诸小相好。如是相好不及白毫少分功德。释曰。故应观察。况依此经如是而观

疏。福德人至鼻等者。即智度论文。或至梵世即法华经如来神力品。尔时如来出广长舌相上至梵世。或覆三千。即阿弥陀云。出广长舌遍覆三千大千世界说诚实言等

疏。无俟观破搏聚者。金刚经云。须菩提于意云何。三千大千世界所有微尘是为多不。须菩提言。甚多世尊。须菩提。诸微尘如来说非微尘。是名微尘。如来说世界非世界是名世界。释曰。此段论名第十色及众生身搏取中观破相应行住处。大意云。众生世界但揽尘成。今从粗至细乃至极微皆无实体。故云世界即非世界。今云无俟观破者。观破但是假想为未了者。若了法本空不待观破。又彼云搏取。今云搏聚是义引耳。故什云欲破极微。觉贤云。以一故众以众故一。微自无性则为空矣。余如前说

疏。故佛涅槃四牙不碎者。即后分经圣躯廓润品

疏。四中有法乳等三者。论第三十八云。五想听法。一如宝。二如眼。三如明。四大果功德。五无罪想。今云法灯合明眼二义。大果即资法身。无罪总明离过。疏上来略列下结释料拣。于中有四。一总辨名数言译者安置者以晋经无数故。二既不说尽下明立理。欲合盈百故。言既不说尽者。十莲华藏尘不可说尽故。三况此中所列下。重以理成合成百义。四晋经有遗下遮其傍救。恐有救云。如大慧百八岂要圆数。凡立名数多有所表故。故今通难云。此有九十七即有所表。晋有九十四复何所表。昔表为是今表即非。是故不应生情配属。若表亦须成九十八

    如来随好光明功德品第三十五

疏。二释名中二。先辨得名。言随逐大相者。即观佛经意前品已引。二如来之随好下释名

疏。照七地者。一种性地。二胜解行地。三净胜意乐地。即是初地。四行正行地(从二地至七地)五决定地(八地)六决定行地(九地)七到究竟地(从十地至如来地)疏。如是展转况于诸相等者。上有五重今越中间。故云展转。然其举况亦合五重。谓一以因一光况果一光。所越应云。二果一光尚尔。况果多光。三足下好光尚尔。况余好光。四好光尚尔况于一相。五一相尚尔况于多相。疏文但有初及后句余可例耳。复应更有二重。谓六外相尚尔况于内德。七一德尚尔况于多德。故瑜伽四十九广说举况因。说相好因竟云。又于此中以要言之。一切有情福聚量等。尔所福聚能感如来一毛孔处。乃至一切所有毛孔随入福聚。能感如来一种随好。乃至所有一切随好随入福聚增至百倍。尔所福聚能感如来相中一相。乃至一切所有诸相随入福聚。除白毫乌瑟腻沙增至千倍。尔所福聚能感如来眉间白毫。乃至白毫增至百千倍。尔所福聚能感如来其顶上现乌瑟腻妙无见顶相乃至白毫随入福聚增至俱胝百千倍。尔所福聚能感如来诸相随好。而不摄余大法螺相。由此法螺随如来欲发大音声。普能遍告无边无际诸世界中所化有情。如是无量福聚资粮修证圆满。能感如来不可思议无上无等遍一切种极圆满。所摄自体下取意引。又此相随好略由三因说为无量。一时无量。三僧祇修故。二意乐无量。缘无量众生利益安乐故。三品类无量。无量善业差别故。故云无量福聚能起如来诸相随好。释曰。经中说所感之相。论举能感之因而因果相成。此文证知佛德难思。可证前后数节之文。疏文从诸相不及法螺。可证出现圆音之义。前妙严品已略指耳

疏。谓虽修乘戒行宽故者。初地已引此下别有一解。以全悟意。往昔亲近众善知识。亲近法华涅槃经等众善知识。心不放逸。显曾修行依诸经修行。后闻此经因该果海果彻因源。便生毁谤故堕地狱。由闻历耳种金刚种。以为宿因。毗卢遮那大威神力以为现缘。因缘相资顿升十地等。据此即非是戒缓堕于地狱故。十地品云。虽此众净广智慧甚深明利能决择。其心不动如山王。不可倾覆逾大海。有行未久(十生五生)解未得(未有华严圆融之解)随识而行不随智闻。此生疑堕恶道。我愍是等故不说。此即是生疑堕地狱。又偈赞品云。如来广大身。究竟于法界。不离于此座。而遍一切处。若有闻此法。恭敬信乐者。永离三恶道一切诸苦难。释曰。定知不是戒缓。又出现品云。如干草[卄/積]等须弥。投芥子火必烧尽。供养如来少功德。必令灭苦至涅槃。何以故。性究竟故。全悟虽是后辈。不忍见疏失于经意。所以扶同拯教异于古人。缘疏已行不可改疏。请后贤审详

疏。恶业善根下遮难释文。恐有难言。地狱及身既由恶业。即从恶业中来。前业报成佛即从善根中来。何以并言非十方来。故今释云。正由从业。即是从缘无性来即无来。若不从缘则有定性不得无来。中论云。若法从缘生是即无定性。若无定性者云何有是法。即因缘故空义耳。疏因缘者。名为智慧者。即略暗引涅槃二十一为证。前疏已引。彼经云。智慧之法不从因缘。云何问于因缘。今取此势。汝诸天子何因向疑。何因发此微妙之音

疏。先教识受生令舍曲见者。涅槃二十一说。若见如来实王宫生纳妃生子双林灭等。是二乘曲见。疏是知佛化所生非没生也者。即净名经观众生品。舍利弗问天女。汝于此没当生何所。天曰佛化所生吾如彼生。曰佛化所生非没所生。天曰。众生犹然非没生也

疏。先明法身遍而叵见者。叵不可也。故出现品云。譬如法界遍一切不可见取为一切。诸佛境界亦复然。遍于一切非一切

疏。非谓得选生处者。本行经说。如来将欲下生。以净天眼观阎浮提何处堪我下生。乃至云唯有净饭王家堪。余家不堪。则似有选生处。无分别智实无选择。即智之悲应物然耳。则选无所选

疏。后如法正教此上标章。后夫欲悔过下广释其相。于中分二。先明所治之病。后显能治之药。此即天台止观之意。今初但略彼名。若具云。一自从无始闇识昏迷烦恼所醉。妄计我人。计我人故起于身见。由身见故妄想颠倒。由颠倒故起贪嗔痴。痴故广造诸业。业则流转生死。二者内具烦恼外值恶友。扇动邪法劝惑我心倍加隆盛。三者内外恶缘既具。能内灭善心外灭善事。又于他善都无随喜。四者纵恣三业无恶不为。下七全同。但八言虏扈者。亦云跋扈。皆不尊敬貌。下结云。是为十种顺生死流。昏倒造恶如厕虫乐厕。不觉不知积集重累不可称计。四重五逆极至阐提。生死浩然而无际畔

疏。次起十种下。二显能治之药。彼云。今欲忏悔应当逆此罪流。用十种心翻除恶法。先正信因果决定孱然业种虽久久不败亡。终无自作他人受果。精识善恶不生疑惑。是为深信翻破一阐提心。二自愧克责。鄙极罪人无羞无耻。习畜生法弃舍白净第一庄严。咄哉。无钩造斯重罪。天见我屏罪。是故惭天。人见我显罪是故愧人。以此翻破无惭无愧心。三怖畏恶道人命无常。一息不追千载长往。幽途绵邈无有资粮。苦海悠深船筏安寄。圣贤呵弃无所恃怙。年事稍去风刀不奢。岂可晏然坐待酸痛。譬如野干失耳尾牙。诈眠望脱忽闻断头心大惊怖。遭生老病尚不为急。死事不奢那得不怖。怖心起时如履汤火。六尘五欲不暇贪染如阿育王弟坐于御床希大帝王。闻旃陀罗朝朝振铃一日已尽六日当死。虽有五欲无一念爱行者。怖畏苦到忏悔不惜身命。如野干决死。绝无所思念如彼怖王。以此翻破不畏恶道心。四当发露不覆瑕疵。贼毒恶草急须除之。根露条枯源流倾竭。若覆藏罪是不良人。迦叶头陀令大众中发露。方等令向一人发露。其余行法。但以实心向佛像前自求改革。如隐处有痈覆讳不治则致于死。以此翻破覆藏罪心也。五断相续心者。一忏已后更不复作。若忏悔已更作者。如王法初犯得轻。若更作则重。初入道场罪则易灭。更作难除。若能吐之云何更啖。以此翻破常念恶事心。六发菩提心者。昔自安危人遍恼一切境。今广起兼济。遍至虚空界利益于他。以此翻破一切处起恶心也。七修功补过者。昔三业造罪不计昼夜。今善身口意策励不休。匪移山岳安填江海。以此翻破纵恣三业之心。八守护正法者。昔自灭善亦灭他善。不自随喜亦不喜他。今守护诸善方便增广不令断绝。胜鬘经云。守护正法摄受正法最为第一。翻破无随喜心。今疏但云随喜他善者。取意对上耳。九念十方佛者。昔亲狎恶友信受其言。今念十方佛念无等慈。作不请友念无等智。作大导师翻破顺恶友心。十观罪性空者。了达贪欲嗔痴之心皆是寂静门。何以故。贪嗔若起在何处。住知此贪嗔住于妄念。妄念住于颠倒。颠倒住于身见身见住于我见。我见则无住处。十方谛求我不可得。我心自空罪福无主。深达罪福相遍照于十方。今此空慧与心相应。如日出时朝露皆失。一切诸心皆是寂静门。乐寂静故。以此翻破无明昏暗。是为十种忏悔。顺涅槃道逆生死流。能灭四重五逆之过。若不解此十心。全不识是非。云何忏悔。设入道场徒为苦行。终无大益。涅槃云。若言勤修苦行是大涅槃近因缘者。无有是处。即斯意也。是名忏悔事中除灭重罪。彼止观中更有别忏悔。见罪亦有十心翻破前十。而皆约观行。别历十心大意观罪性空中意。与下经文同。不能繁引。其中释文。此疏不广。及下释经皆已暗用。今皆并引使知来处。亦分疏中主客之言。疏向以起心之次第者。从微至着故翻破则从粗至细。谓先起信心次生惭愧等。如垢衣受垢。先微后着。若洗濯时先去粗垢后除细垢。言此中则以胜劣为言故者。谓菩提最胜等故

疏。一发菩提心为忏所依者。依菩提心忏方为真忏。不发心忏非是真善。故五十八经云。忘失菩提心修诸善根。是为魔业故。从以是行本下通不次妨。义如前说

疏。余如别说者。此有二事。一明二障者体下疏更明。二明别说见障。即如向引止观说也

疏。一一佛前及众生前者。佛为忏悔之主。凭佛能除众生是所对之境。昔曾恼害故

疏。既人天凡圣等者。一一生众中有天。一一佛前即圣。圣天见我屏过。人见我显过故为惭愧。此一段疏用一段经。而有二意。一以遍对翻无惭愧。二从由遍运意下。亦以遍对翻第四纵恣三业。疏兼显妄计我人等者。观罪性空正破妄计而言兼显者。以此有二意故。一兼显所治故下。三事皆是所治。次下一一皆有能治。谓胜义空破妄计我人显非断常。破拨无因果。对十方佛翻外遇恶缘。二者观空正破横计我人。今加后二故云兼也。唯一性空破于三过

疏。今初业为报因三障首故下。出别忏业及先忏所以。在文可知。从非先有体下。释经于中有二。先释不从东方等来。无体性故。即是空义。二释从颠倒生。言释空所以者。从因缘生即空所以。以从颠倒生故。成无体性空义。从由业障海下。即普贤观经之文。引此成上二义。即一切业障海。皆从妄想生。若欲忏悔者。端坐念实相是也。言令此空慧与心相应者。亦即普贤观经文。将此释今经决定明见无有疑惑。空慧相应斯慧决断故。能如是知却释菩萨字。以令天子忏悔乃云菩萨。如是者。由见二空之理即为菩萨故

疏。以喻俗有真无者。即中论意。缘生幻有为俗。无性空理为真

疏。有无二文三彰影略者。谓说有中略无报障。说无之中略无烦恼。从既无我下会前十心

疏。若谓为空诸佛不化者。中论云。诸佛说空法为离于有见。若复见有空诸佛所不化

疏。故今显非断无下。会上十心以是缘成无性之无故。非断无所以。经言而受其报。亦同净名无我无造无受者。善恶之业亦不亡

疏。定有即常定无则断者。亦中论偈。偈云。定有则着常。定无则着断。是故有智者。不应著有无。言俱亦是二者。谓有无俱者。则二见相违。亦不离亦断亦常言故。双破二见者。故经云。诸佛不说有断常法。疏故虽空不断下。亦中论偈。论云。虽空亦不断虽有而不常。罪福亦不失是名佛所说

疏。令其真念十方诸佛者。若不了唯心见从外来取色分齐岂知即心即佛。若知心佛众生三无差别。为真念佛。善知识云。念佛即是念心。念心即是念佛。佛无形相心无生灭。心境一致故云真念

疏。又业亦如幻者。重幻之义如前已引。从又幻非有无下。上辨性空。此下说中道

疏。以三昧力声普闻故者释妨。妨云。此土兜率天鼓说法。云何益及百千亿等刹耶。答意可知

疏。今初皆有故字等者。疏文有五一牒经义。言似牒前为因者。则似由闻回向及得十地并得三昧。此三为因见佛为益。二从而前来未有下。出不合加故字所以。三是以晋经下引古经为证。四应言闻说下。正其经文。五上句言位者下释文。位即十地。言下句成行者。即诸力庄严三昧分。得十力下释诸力义。谓十力是佛果德。今言得者即分得耳

疏。或迷说成谛等者。即第五地中十谛之义。言十谛者。即是十种观察四谛。谓一善知俗谛。二善知第一义谛。三善知相谛。四善知差别谛。五善知成立谛。六善知事谛。七善知生谛。八善知尽无生谛。九善知入道谛。十善知一切菩萨地。次第成就乃至善知如来智成就谛。今言说成者。即论经中第五成立谛名也。以其第五观于四谛缘起集成故。偏举之随言显示故。论中名为说成也

疏。然二皆有理者。即疏会通并未见文故。未可去取。但以理通。然其前解似喻于烦恼故。后似约业故。又迷十谛惑义多故

疏。更有异释如贤劫经者。会通异释九地已引

疏。今初准晋经云。种一恒河沙下。疏文有二。先通释清净金网。后别释一恒沙言。前中有三。一引晋经梵本成宝网义。二牒举今经。三引缨络。成上二经。今初。言多个轮王者。即宝网是一。等取金网琉璃等多故。有一恒沙也。言非一轮王之多善者。则以旧经弹于今经。云种清净金网转轮王一恒河沙善根。则一轮王有多善耳。言梵本亦然者。即以梵本成于晋经

疏。而言清净金网者。第二牒举今经

疏。准缨络上卷下。第三引缨络经成立二经。于中三。一引经。二成晋经。三成今经。今初。言至第七地十三宝相轮者。以初地七宝二地八宝三地九宝四地十宝五地十一宝六地十二宝七地十三宝。八地已上不增宝数。故但云大应宝相轮等

疏。若顺晋经下第二成晋经。谓今得十地成九地已上善根。白净同白云宝故。从即前香幢云者。引前行经证成晋经。晋有白字前有云字。二经合成缨络白云宝义疏。若然但是所等则金网无失下。第三会取今经。于中又二。先顺晋经收今经。谓晋经得十地。有九地已下白净宝等诸轮王善。彼云白净宝网等。等即等于金银轮等。若是能等为金网。则十地非金。若以所等为金金等何失。则晋经从九地向下等。今经从十回向当中向上等故。言无失则亦是多个轮王善根。谓得金网等一恒河沙轮王善根故云无失

疏。若取十地为清净金网正当十地者。下直顺金网一转轮王多善根义。以三义证成。一以无畏珠为清净义。二以人摄化分齐同十地义。即次行经云。住此转轮王位。于百千亿那由他佛刹微尘数世界中。教化众生正同十地摄报果中所化分齐。三故下此王下。以转益文证成。此王转益尚皆得于十地。故知此王即是十地。故彼经云。菩萨安住清净金网转轮王位。亦复如是。则金网非所等。正是十地但其金字。缨络虽无。余经或有。故金刚顶经广说金轮佛顶

疏。言一恒沙者下。第二别释恒沙善根。虽金轮为所等。能具义则不同。一恒沙善根二经须一。言九地已还者。正顺晋经从白净九地向下等故

疏。今经影在后喻合中者。出今经阙光之理。即后得初禅。喻合中经云。菩萨摩诃萨住清净金网转轮王位放摩尼髻清净光明是也

疏。若直言得遇斯光下。以理成立

疏。犹是牒前合中者。即是前明镜世界喻中合文。文云。菩萨安住清净金网转轮王位。亦复如是。若有暂得遇其光明。必获菩萨第十地位。以德依地成下。出重牒所以。不然下反以成立

疏。此品之末经来未尽者。以说展转益竟。应须结归本光及随好力并现瑞成益等。今并无此明是未尽

    普贤行品第三十六

疏。通谓二品明出现因果等者。疏文有二。先正明。后若尔何以下解妨。先叙妨有三。后即以此义显。是会前下释通。于中二。先出所以答。后经来未尽答。前中亦二。先此上二句总答。后若更别。问下别答三问。初答不问之难。二欲会前故不以瑞隔。通前第二差别果终而无瑞难。三普法希奇下。通第三平等因竟便有瑞难

疏。又前应有下第二经来未尽答。以第四十八经终无结束故。此后更合有经。然此但通第二前无瑞证难

疏。别谓此品等者。疏文有二。先直就平等因果明。后亦远答下对前问说。于中又二。先正对前问。后前虽已答下解妨。文中分三。初正答重难。谓先若未答应须答之。不思议品已答。何须重答。故为此通。二亦犹下引例。三而妙中之妙下。重通伏难。谓有难言。若例相海等。但是重答。何以别为平等因果。故为此通。古德等者。然平等因果乃是古意。为欲顺古故为此通。若疏正意欲将五品皆答所成果问。已如不思议品初说

疏。初通显二品义名下。疏文有二。先约平等释。后约出现释。前中亦二。先约同归一理所以平等。依性起修约因。起用约果。相尽同真所以平等。后又因是果因下。约二事交彻。故云平等。以是得果不舍之因。故云因是果因。依果起果之果。故云果是果果。如空法界二文影略

疏。因果俱尽下。二约出现释

疏。别则品名下。疏文有二。先总后别。总中言品明所行非说人体者。密弹苑公。以彼释云。普者遍也。贤者善也。行者道也因也。谓若依若正普遍法界尘毛为普。具满众善德海为贤。得道不舍因行为之因行。后便广引普贤三昧品中释普贤身周遍之义。曾不说于行行之相故。又以普属人贤属德。故今弹云。为此以人取行非说普贤之身

疏。然普贤行下别释普行。于中三。一标举。二释相。三料拣。今初。言诸经多有其名者。法华经云。若有受持读诵正忆念解其义趣如说修行。当知是人行普贤行。释曰。此即有名而相犹隐。则受持读诵是事行也。正忆念通智行理行也。普贤观经名观普贤行法经。亦是持经礼忏坐禅皆其行耳。故多有名少辨行相。故今辨之。疏言品中虽广者。长行与偈一一皆是普贤之行。犹散难见故复束之

疏。一所求下二释相

疏。上之十行下。三料拣。于中二。先融通。谓前有圆融行布事理等殊。今总融为一。若不说事理等异。无可融故。故略述其十。后方总融。二又上十行下约位重拣。兼会六释普贤位者。已见上文。二若独位后下结弹异释。即是前总中所破。然复有二。一破其独用位后普贤故。如前所引疏文。二广释普贤下。结成非说人体。兼示说人之处

疏。结缚等名如常所辨者。非唯易故指于常解。然上经文早已频释。恐后学难寻。今更具出。经云。一无智者。即是无明。此通独头相应二种。二作恶者。即诸缠。此有八种十缠。言八种者谓一昏沉。二睡眠。此二障止。杂集第七云谓修止时昏沉睡眠为障。于内引昏沉故。三掉举。四恶作。此二障观。论云。于修观时。掉举恶作为障。于外能引散乱故。释曰。上一举字即是观也。五悭。六嫉。此二障舍。论云。修舍时悭嫉为障。由成就此。于自他利吝妒门中数数摇动行人心故。七无惭。八无愧。此二障尸罗。论云。修净尸罗时无惭无愧为障。由具此二犯诸学处无羞耻故。言十缠者。更加忿覆。俱舍颂云。或十加忿覆。杂集云。数数增盛缠绕身心故名为缠。由此诸缠数数增盛缠绕一切观行者心。于修善品为障碍故。更有五缠。谓爱恚慢嫉悭。经云。结者。杂集第六云。问结有几种云何结耶。何处结耶(此有三问)答结有九种。谓爱结恚结慢结无明结见结取结疑结嫉结悭结。应为颂曰爱恚慢无明见取疑嫉悭。论云。爱结者谓欲界贪。恚结者。谓于有情苦及顺苦法心生损害。慢结者。即七慢等。无明结者。谓三界无知。见结者。即三见。谓萨迦耶见边执见邪见。取结者。谓见取二戒禁取。疑结者。谓于谛理犹豫。嫉结者。谓耽着利养不耐他荣。发起心妒。悭结者。耽着利养于资生具其心吝惜。释曰。云何结何处结(二问)广答如论

疏。故晋经云。起一嗔心等者。以今经译者为顺文令人误解故。引三经以正其义。谓习禅者。闻经不见诸法为大过恶。便云恶本性空故云不见。见则妄想。虽是正理不顺今经。故引三经明是无恶过此。为不见有耳。决定毗尼者。经但一卷。优波离。白佛言。世尊。或有欲相应心而犯于戒。或有嗔相应心而犯于戒。或有痴相应心而犯于戒。何者为重。佛言。若有菩萨如恒河沙欲相应心而犯于戒。或有菩萨由一嗔心而犯于戒。因嗔犯者。当知最重。所以者何。因嗔恚故能舍众生。乃至云。所有诸结能生亲爱。菩萨于此不应生畏。所有诸结能舍众生。菩萨于此应生大畏。乃至云。大乘之人因欲犯戒。我说是人不名为犯。因嗔犯者。名大过恶。名大堕落。于佛法中是大留难

疏。是以大般若中下。证于菩萨起嗔中最重。彼说魔见众生互相是非。亦生欢喜而非大喜。若见菩萨互相是非则生大喜。过于常喜。如二虎斗小亡大伤。二俱无益。菩萨亦尔。自他并损皆失二利故

疏。二何等下征列者。疏文有四。初标举。二古人寄位下序古释刊定同此。三此释非不有理下。辨顺违。四又所障下结成正义。犹是古释故有又言。疏意取此不欲局配故为正义

疏。亦从前十及次十而成。然有开合者。疏恐文繁今当略配。其中名字有同初十。有同次十。今且如次配于次十。一由知深法了众生心行。众生心行最甚深故。二由近友成胜业报。三由护法故知佛法。四了达空界知深理趣。五深入法界成妙义持。六观无边心即是所诠故。得能诠辩才演畅。七具菩萨行能随心演。八同菩萨善故能普遍。九不着诸劫常现影像。十顺诸佛法具一切智。从次十生既如次第。从初十生义同前说。上依不开若开合者。如初二法皆是深法。则此开前合。若此总持由于近友护法而成。则此合前开。约理无方故云开合。实则如次义已周圆。如三对前二。既然四五承前可以思准

疏。第二正显颂中文三。初总科。二此是伽陀者。是孤起偈。拣非祇夜不重颂前。三前是略明下拣二文别

疏。此中玄妙宜审思之者。大经文理触途多妙。但文言浩博不能具释。又理玄文易故令思之。既云玄妙。今重略释。初偈法喻双标。能观之智明横周竖永。次偈达二世间假名无实。即是假观。三一偈双离分别及无分别。以成空观。四有一偈解念无念。即中道观。又二即是观。三即是止。四即双运。五不动游刹于器界自在。六融念劫于时自在。上二事理双游。七遣二不二善会中道。通二世间。八结三世间等同法界。九结能遍身。十结能所不二。上半无二遣二。下半复遣无二。若着无二即是于二有能所故。故知无二非二故无所著

疏。九一颂知四种说法行者。即三世间及时为四。若时分三世间则成六种。若于三世各三世间。则有九种。总一切说即是十义。从而刹等说者释义。刹及三世此义微隐故。疏释之。言融通者。一尘即摄一切。何得刹中无说。言显理者。如色即显质碍即显缘生即显无常即显无性等。言则触类成教者。证显理义如前教体中明

大方广佛华严经随疏演义钞卷第七十八大方广佛华严经随疏演义钞卷第七十九

        唐清凉山大华严寺沙门澄观述

    如来出现品第三十七

疏。答第二会所行问者。以不思议法品中出现即第二会所行故。疏二释名者。疏文分三。初正释。二若唯约化下结弹古义。三若来即出现下会六释。初中四。一总释。二如来虽下结前生后。三若依法身下别释。然法身若约报上论法应云真如出缠是法身出现。今以出缠为报。直就体上故。云如理常现。余二可知。四今以新佛下融通会释。于中二。先会三身十身。后会品名证成前义。前中有三。初以法报相对。二真应相对。三结融三十。今初。言新佛旧成曾无二体者。以报就法如出模之像。像本旧成故无二体。言新成旧佛法报似分者。以法就报如金成像。金像似分以有未成像金故。今成像竟似分二矣。前对是非异。此对是非一。非一即非异故。言似分竟无二体

疏。无不应时下。第二真应相对。以辩融通。法报皆真体上常用故。即真成应用不离体故。即应而真

疏。三佛圆融下第三结融三十。谓以三佛收十佛。不出三身。三身既融。十身即三自体无碍故。辩应成下结成正义

疏。是以晋名下第二会品名。二经品名即为二别。先会晋经。初二句总标。以将晋经用成前义故。有是以之言虽是义加者。梵本无故。后以应虽从缘下释性起义顺应现义。于中总有六义。证成性起。今初。立理即不相违门。然出现义亦名缘起。亦名性起。若取相说览缘出现故名缘起。谓由众生业感如来大悲而出现故。八相成道从法性生故名性起。今以从缘无性缘起。即名性起。又净缘起常顺于性。亦名性起故云应虽从缘不违性故

疏。无不从此法界流故者。第二引梁论证成。即相成门明性成于缘故。此性起自有二义。一从缘无性而为性起。二法性随缘故名性起。前段即初义。今段即后义。亦应云无不还证此法身故。此乃缘智相成即缘成性。即是前义。但前取无违。今取相成是故此为相成门也

疏。以净夺染性即起者。第三明相夺门。亦是通妨。谓有问言。性起唯净缘起通染。云何缘起即是性起。故为此通。谓缘起有二。一染二净。净谓如来大悲菩萨万行等。染者。谓众生惑业等。若以染夺净则属众生故唯缘起。今以净夺染唯属诸佛故名性起

疏。若离于缘性叵说故者。即第四是相即门。亦是通妨。谓有问言。缘起约事性起约理。如何相即。故为此通。从缘无性方显性起。又由见缘推知性起。若离于缘复论何性。离缘有性是断空故。疏下加性起者。即第五段引当经证。即以人表法门

疏。妄虽即真下第六以妄隐真门。亦是解妨。妨云。若缘即性妄本自空。当体即性何以不得染夺净耶。故为此通净缘顺性染缘违故。故璎珞云。始起一想住于缘。顺第一义谛为善。违背为恶

疏。今以起义多含直云出现下。第二会通今经。则性起局性。出现即起。起含缘性故曰多含。言从性者。性起即法身。从因者。缘起缘起即报身。从真从感即是化身。而从真约佛通于缘性。谓依法报而起于化名曰从真。从感约生即是缘起。由上诸义故云多含。结弹六释并显可知

疏。一众生外增上业者。拣异内异熟业

疏。谓多有情应生此界共业同变者。即唯识论释初能变中处之一字。论云。所言处者。谓异熟识。由共相种成熟力故。变似色等器世间相。即外大种及所造色。虽诸有情所变各别。而相相似处所无异。如众灯明各遍似一。释曰。此释共变之义相似名共。论又云。谁异熟识变为此相。有义一切。所以者何。如契经说。一切有情业增上力共所起故。有义不许。乃至云经依少分说一切。言诸业同者。皆共变故。释曰。此拣通局。即今疏文

疏。依此义云应生此界故下。经云各随所宜而得受用。若不应生岂安乐界所有众生变为此界之秽土耶

疏。于中有四句。谓共中共等者。即唯识第二引瑜伽论说共不共中。各有二种。共中二者。一共中共如山河等。非唯一趣独能用故。二共中不共。如己田宅及鬼所见为水火等。即于彼境非互用也。不共中二者。一不共。中不共如眼等根。唯自识依用之缘境。非他依故。二不共中共如自浮尘根。他亦受用故

疏。一约同居等者。地前菩萨未生受用同居变化。亦以善业共变此土

疏。二约能化。谓随诸众生等者。即净名意能化菩萨非自业成。以大悲故取土摄生及众生之类。皆净名经。并如世界成就品引

疏。先成器界等者。俱舍十二云。坏从狱不生。至后器都尽。成劫从风起。至地狱初生。论释云。谓成劫中初一劫起器世间。后十九劫起有情渐住。坏中后一劫坏于器界。前十九劫有情渐舍。二十中劫初劫唯减后劫唯增。然此二时等中十八成坏。时量法尔先成必在后坏

疏。一品之中下。总显喻意

疏。广大难知周十方故者。是下结文

疏。以十句各结一喻。文皆暗用。可以意得

疏。体无生灭亦是下结文结第三也

疏。准五卷大悲经第三云。有千叶故者。结云。阿难何故名为贤劫。阿难此三千大千世界。劫欲成时尽为一水。净居天子以天眼观见此世界。唯一大水见有千枚诸妙莲华。一一莲华各有千叶甚可爱乐。彼净居天因见此华心生欢喜。踊跃无量而皆赞叹言。奇哉希有。奇哉希有。如此劫中当有千佛出兴于世。以是因缘遂名此劫号之为贤劫。我灭度后当有九百九十六佛

疏。次第合前者。一清净离垢光合善净光明风轮。此约能成。若约所成义类亦同此。一能成如来无漏无尽智合成色界。色界离于欲过故如无漏。四禅不坏如无尽也。二普照光合净庄严风轮。三持佛种性合坚密无能坏。四迥出无能坏合胜高轮。五一切神通合不动轮。六出生变化合安住轮。七普随顺合庄严轮。八不可究竟合无尽藏。九种种庄严合普光明藏。十不可坏合坚固根。其所成德可以意取

疏。所成唯果德者。唯释于法如无漏无尽智不倾动力等。皆果德也。能成通因果者。如持佛种性。一切神通皆通因果。疏以缘夺因者。此中化生众生。自力为因佛力为缘。余可思准

疏。大诺健那者。此云露形也

疏。其量广无数厚十六洛叉者。是俱舍颂上二句云。安立器世间。风轮最居下

疏。故净名云。其无碍慧无若干者。即第三菩萨行品。经前已频引。今更略示因说香饭为佛事竟。便明诸佛功德平等云。阿难汝见诸佛国土地有若干。而虚空无若干也。汝见诸佛色身有若干。其无碍慧无若干也疏。若将一一通前十下结弹古释

疏。净意如空总以喻显等者。此中有深止观宜审思之。第二身业疏唯有五界者。结示正义非是略也。弹于古释。古云。应有十句。但文略耳。故今弹之

疏。明如来出现有十种身者。疏文有四。一正科经文。二此即八地下会释十身。三四是菩提下随难重释。四一一喻中下释文。此亦古德同迷之处。不知此十即十身故

疏。初二合初句世出世异故者。谓初二句皆合破暗作明初句。灭恶生善。即世间破暗作明。恶即黑暗善即明故。后句破愚为智。即是出世破暗作明

疏。三拔四流等者。即大慈救护大悲度脱。合变湿令燥。四流是湿出世是燥。定水是湿菩提是燥。不沉定水故

疏。道品通长下合上生长草木。三乘草木即药草喻品三草二木。初会已引喻。高原喻声闻者。不生佛法莲华故。即净名第二。譬如高原陆地不生莲华。卑湿淤泥乃生此华。如是声闻诸结断者。于佛法中无所复益。烦恼泥中乃有众生出佛法矣。前亦已引。故法华经法师品内穿凿高原。亦况声闻

疏。又既约机说异则照高未能兼下等者。如照高山未照黑山。若照黑山即照高山。谓说华严是照高山二乘不预。说阿含等菩萨常闻等。余例可知。疏又若舍化下。约会权归实。然经但有先照高山之言。无有后照高山之语。今以义求必有之矣。会权归实先弃人天。非出离故。如平地落照。次舍声闻。令自悟故。如高原无光。次舍缘觉。令起悲故。如黑山掩曜。次舍三乘。归一乘故。如山衔夕阳故。先大后小即从本流末。于一佛乘分别说三等。舍小归大即摄末归本。则二义皆具。疏略中五事皆盲等者。亦通外难。谓有问言。五事皆盲。何不言无解等眼。答意可知

疏。此即涅槃下。会涅槃第九。初明三罪最重有涅槃因。不说阐提。后圣行品下收阐提云。一阐提人虽复断善。犹有佛性。故总收之。此四明至恶不舍。言三罪者。一谤方等经。二犯四重禁。三作五逆罪。此三未必拨无因果。拨无因果即一阐提

疏。令离苦集者。现在身苦为苦果也。及诸烦恼未来苦因义兼惑业。上二皆集。第三语业。疏圆音之义下分三。初总明。二释文。三弹古。初中疏一叙昔等者。昔有三义。一云。诸佛唯是第一义身。永绝万像无形无声。直随机现无量色声。犹谷无声随呼发响。然则就佛言之无音。是一约机论之。众音非一。而言一音圆音者。良由一时一会异类等解随其根性。各得一音不闻余声不乱不沓。显是奇特。故名一音。音遍十方随机熟处无不闻故。名为圆音。非谓如空遍满无别韵曲经云。随其类音普告众生。斯之谓也。二云。就佛言之实有色声。其音遍满无所不遍。但无五音四声等异。无异曲故名为一音。无不遍故名为圆音。但是圆音作增上缘。随根差别现众多声。犹如满月唯一圆形。随器差别而现多影。亦如长风随其众窍声有多种。经言。佛以一音演说法。众生随类各得解。三云。如来于一语业之中演出一切众生言音。是故令彼众生各闻己语。非是如来唯发一音。但以语业同故名为一音。所发多故名为圆音。如舍支声尚多音齐发。况如来耶。二辩违者。上来三解偏取皆失。初第一义无形无声。非一音义故。但随他音非自音故。第二唯是一语无多音故。一不即多岂为圆音。有则多亦应有。无则一亦须无。何得一有而多无耶。第三虽但是多。又无一故。若语业同一切众生岂一音耶。故并非也。第三会通者。上但责偏不谓全失。合上三义。方是圆音之一义耳。谓多即一。若多不即一则非一音。一复即多若一不即多。即非圆音。二即是空空即是二。若二不即空是所执故。不无性故。非圆非一空不即二非音非圆故。镕融无碍即是圆音。此中三义。谓初是无生灭义。次一是无邪曲义。后一是普至义。是知得其正义。则傍收无遗不得正意。并为乖理。疏文有十音下。第二正释经文。在文可见。但初一即随类音亦同净名。佛以一音演说法。众生随类各得解。皆谓世尊同其语。斯则神力不共法。释曰。此即词无碍解。以辩一音。三四皆引宝积。亦即净名宝积长者子偈赞一音。次上所引第二偈云。佛以一音演说法。众生各各随所解。普得受行获其利。斯则神力不共法。释曰。此即法无碍解云一音也。第三偈云。佛以一音演说法。或有恐怖或欢喜。或生厌离或断疑。斯则神力不共法。释曰。此即义无碍解云一音也。疏此十圆融下结成上义

疏。是知或谓无声下。第三结弹古说。但结前二。以其第三可入正故。言皆大地之一尘者。约收以结则此一尘不离地界。积多小尘可成大地。积其多义以为圆音。若约斥弹异说之微。岂同正解广大智地

疏。今初收上十声下。疏文有三。先释经文。二更以四句下以义融摄。四句可思。后名为如来圆音下结叹

疏。若佛音声是有法非非法者。释曰。此非法言即是真理为非法耳

疏。一将成正觉念相欲尽等者。即起信论意。数段论文参而用之。论云。菩萨地尽一念相应。觉心初起心无初相。以远离微细念故。得见心性。心即常住。名究竟觉。今取意释。故云将成正觉。言念相欲尽者即微细念也。此念亦名生相。即论三细之一。论云。一无明业相。以依不觉故心动。说名为业。动则有苦。果不离因故。释曰。此念即细中之细。今无此相云细念都亡。言得见心性者。即上论文言等虚空界法界一相者。即论释本觉之文。论云。所言觉义者。谓心体离念。离念相者。等虚空界无所不遍法界一相。即是如来平等法身。依此法身说名本觉。释曰。今略取二句彰所显本觉。言始本无二者。即所成始觉。彼论释前说名本觉。竟后云何以故本觉义者。对始觉义说。以始觉者即同本觉故。始觉义者依本觉故。而有不觉。依不觉故说有始觉。又以觉心源故名究竟觉。不觉心源故非究竟觉。释曰。今疏取意。故云始本无二。言契同诸佛。平等法身下。结成上来无二之义。平等法身即前本觉。言故云说法界下以经帖成

疏。三德涅槃者。涅槃章明。疏在法华经以体从用。名如来知见者。涅槃约理知见约智。知见有性非无有理。涅槃亦有般若之德非无有智。涅槃乃是摄用从体。但称涅槃以为所证。法华经明以体从用但名知见。故法华论释开义云。开者无上义。即双开菩提涅槃。示法身同即唯约理悟。约菩提即是于智明其理智。况知法无性岂非理耶。故今疏云以体从用等

疏。深固幽远者。即法华经法师品文。文云。此法华经藏深固幽远。无人能到。今佛教化成就菩萨。而为开示。释曰。幽远深固名为秘密。疏初心同禀下解妨。解妨云。法华经除诸菩萨众信力坚固者。又三根声闻初发大心。皆禀法华如来知见。何要此位方为说耶。故为此通。约究竟故。为等觉说实则此法通被始末

疏。更一下生者。第二会。初已广分别

疏。有说初地即得者。六地已引。即仁王云。若得信心必不退进入无生初地道

疏。为说信等者。即初地净治地法。信悲慈舍无疲厌。知经论了世法。坚固力惭愧庄严供养佛也

疏。后后圆净者。释经宝字。以此十法净治地障。地地渐净故云后后

疏。十地地智一一开发者。即释智慧华开敷。不断二利者。不断大悲行等。地地之中有二利故。疏中道者名为佛性。初二会中已广分别。言为上上智观者。亦涅槃文六地已引。应以法空智断一切惑者。此有二意。一以法空拣于人空。照惑无本无断断故。二言一切者。兼断所知亦烦恼故。第四出现意业。疏约体遮诠下释此段经。疏文有三。初总释文意。二别叙异释。三会释归宗。今初。心即是王。就王辩体。智则是所。约所明用。体则表诠不逮故但遮诠。用则相可照着故寄表诠。然用亦有遮诠。同体故。无分量故。若一向遮则无由显妙。故寄表诠以辩玄极。而言寄者。谓寄所显王寄用显体。又用及心所皆有遮义。今但寄表以显于深

疏。然此一文下。第二别叙异释。于中二。先标。后一云下别说。略有三说。不离一宗即分为三。初二师即法相宗。二结前生后。三叙法性宗。就初师中有五。一正明。二解妨。三反成。四引证。五重解妨。今初。言无彼有漏染心心所而有净分者。唯有八识心王及二十一心所。即遍行五别境五善十一也疏果位之中解妨。有征问云。若尔则王所俱有。何以王上言不可得。故此释云。果位之中识劣故云不可得。智强故云智无量。言识劣者。以二分中。但有净故。不同众生分别强故。言智强者。无恶慧故。决断胜故

疏。若必无王下。第三反以成立。智是心所。若无心王智何所依

疏。故成唯识下第四引证。言是净无漏界者。漏即垢染。既言无垢识则有识矣。又云圆镜智相应。明有心王与所相应。非所独立。是故结云有王明矣

疏。言转识下。第五重通妨难。谓有难言。既言转八识成四智。明唯智无识。故今释云智依识转等。言依识转者。识为主故。智非主故。然唯识转有三师义。今并用之。此是一师上智强识劣。亦是一师。疏一云。以无积集思量等义下。此义有三。初正明。二引证。三遮救。今初。以集起名心。思量名意。分别名识。今果位中八不积集种子而起现行。七不思量第八为我。而言等者等取前六。又不分别诸境。所以尔者。以皆与四智相应故言无耳。非不有彼无集第八。无思第七。无分别六。是故结云非无心体

疏。故摄论下。二引证。非心非思义故者。明八非积集七非思量等

疏。亦非非心为所依止者。三遮救也。恐有难云。若非心义无分别智。应依于色。故今显云。所依之王非全无体。此上总标有也。次心种类故下释成有义。谓是心种类安得非心。次云。以心为因下。复释上文心为种类。言此位者即是果位。谓以集起等心为因。引得果位净八识故。不可名为非心也。如无表色依表色生故得名色。据此亦得名无集起心等

疏。上之二解俱明心意识有者。第二结前生后。明结前二是法相宗。生后一解是法性宗。问二俱是有。复有何别。答前释有净无染。后释有体无用。故义不同也。然二义相成。以无思等故说无染。以无染故说非积集思量义等。疏一云。佛果无实心意等者。即第三师是无相宗。及法性宗。先正明可知。故金光下第二引证。论当第三。论云此中自性身者。即法身也。释论云。唯有真如及真如智独存。名为法身

疏。上之二宗偏取皆妨。下第三会释归宗分二。先明不可偏取。二明会成正义。前中亦二。上二句标。后若依前义下解释。于中又二。先离破后合破。前中先明法相宗妨

疏。文分三。初夺破。次纵破。后遮救初中二。先明违义。以不得即有即空故成增益。后亦不能通。不可得言下。明其违文。以文但云心意识俱不可得。不言染不可得故。疏又此净分此何不说下。第二纵破纵许净有染无。经何不言有净分也

疏。彼无垢识而得说耶下。第三遮救。二句疏文遮其两救。上句恐彼救云。净相难说故不言之。故今遮云。彼庄严经何得说有无漏识耶。岂非是净。下句恐彼救云。经言叵得意在于染。故亦遮云。经何不言染不可得

疏。若依后义下。明法性宗妨。于中二。先夺后纵。前中亦二。先明违义。以空碍有故云损减。二亦不能通下明其违文。文中既言智无量故知如来心。不言知如来智。明知假智知心心则有矣。何得言无

疏。又心既是无下。第二纵破。纵汝心无智有亦有二过。一违义。心王最胜尚说为无。智无所依岂当独立。如无君主何有臣下。二非唯下明其违文。言上二论者。即唯识摄论言涅槃灭无常则通五蕴。故经云。憍陈如因灭无常色而获常色。受想行识亦复如是。既有常识则有心矣

疏。若二义双取下第二合破二宗。成四谤故。此亦遮救。谓有救云。上之二宗偏取不可。合岂过耶。故云。合则相违。以其定谓有无非即有之无即无之有故。若尔互泯双非可乎。故答云宁逃戏论以无诠当故

疏。若尔何以指南下。第二会成正义。于中有四。一征前起后。二今释此义下双标二章。三今初若后宗言下别解二门。四然佛尚不说下谦退总结。初二可知。三中分二。先别会二宗后通会二宗。前中即分为二。先会法性宗。意云。心即是如智即如智。离心无如则知有如已有心矣。况即体之用故称如智。即用之体即是真如。如一明珠。珠体即如。明即如智。岂得存如亡于心矣

疏。前宗以纯如下会法相宗。意云。即如之有。有岂乖如。如境即虚则有心无失

疏。是知即真之有下第二通会二宗。即真之有是法相宗。即有之真是法性宗。两不相离方成无碍真佛心矣

疏。后消经意下第二释经文。于中有三。初略明即双标遮表二故。晋经下引证双证遮表。既言知心无量则有心矣。言无最失。疏云何深玄下。第三广释。即双释遮表。即分为二。第一释寄遮显深。第二释寄表显深。前中四。初明偏语不能尽理。二结性相二门难思。三明总具性相不可别彰。四明不即不离故难显说。今初。略有四对。一有无者即别对二宗。二染净即法相宗。三一异者通对二宗。四情非情亦对二宗。初对义者事即理故非有。理不失事故非无二。染净对。净约绝相染约契性。言不断性恶者。恶同以心性为性。若断性恶则断心性。性不可断。亦犹阐提不断性善。三一异对。通对二宗。即体之相能包。即相之体一味。四情非情对。亦对二宗。即用之体同色。即体之用彻幽。言无殊色性者。即起信论云。以知色性即智性故。说名智身。以知智性即色相故。说名法身遍一切处。又梵行品云。知一切法即心自性故。情非情性曾何异体

疏。口欲辩下二结性相难思

疏。是知佛心下。三总具性相不可别彰。皆双融前二宗之法

疏。心中非有意下。四明不即不离故难显说。于中三。初约八识心王辩。二王所对辩。三一一结例。言非有者是不即义。二相别故。亦非不有。是不离义。无二体故。又非有者。以无二体互摄尽故。亦非不有者。二俱不坏力用交彻故

疏。言寄表下。第二释寄表显深可知

疏。然佛尚不说下。第四谦退结成。佛尚不说者。即此经云心意识皆不可得。是不说也。释迦掩室于摩竭。净名杜口于毗耶。皆佛不说也。果海离言唯证相应。皆不可说。有因缘故者。即四悉檀。因缘则得无说之说耳

疏。合中谓诸乘下。疏文有三。初正释文。二岂不依心及依理者设难也。依心约法相宗。依理约法性宗。三岂不向言王所无二下释通。此释依心。后良以佛智下释依理义。于中四。初正释。二引例。三引证。四举况。今初。即回向经云。无有智外如为智所入。亦无如外智能证于如。今但通上岂不依理难。故但引前句。谓彼难云。上言唯如如及如如智独存。则智依如矣。何言无依。故今释云。智外无如。故无所依。然彼回向经文。自有三意。一约如体性空故。智外无如。智体性空故。如外无智。二如智一味同一真体。安得智外更有如耶。三约事事无碍举一全收。今但用初二意以酬难竟。后意即在第四举况之中

疏。亦犹净名法随于如无所随故者。二引例也。即目连章。彼约性相相对。此约如智相对。义非全同义势相似。故云引例。言法随于如者。法即一切。一切法即如。故云随如。言无所随故者。经自释随如之义。由法即如。法外无如。故云无所随。故若有所随能所未泯。岂得随如。又法外有如。法非如矣。故无所随方曰随如。此中亦尔。若有所依智外有法。能所未忘不名如智。如外有智智亦不如。故得引例

疏。文殊般若云。若无境界则无所依者。三引证也。文义全同。故得引证。即大般若曼殊室利分光明觉品已引。今当更引。经云。若知我性即知无法。若知无法即无境界。若无境界即无所依。若无所依即无所住。释曰。今但要无依之言故但引一对

疏。况佛智外无法可得下。第四举况。谓上引二经。但明契理无依心境双寂。即事理无碍之义。已通前难。况今约事事无碍举一全收。即回向中第三意也。佛智称真收法界尽。差别之事皆随于理在佛智中。况所证如宁在智外。此约相入门。下句云以一切法即佛智故者。释上无法可得。约相即门。佛智即一切一切即佛智也

疏。即转释前依者。谓疏意明初喻为总含下九喻。故下喻中节节指初。今以第一喻云虚空为一切法所依。喻佛智为一切世出世智所依。故今释之。云得为依依彼出故

疏。虽出诸智佛智不减菩萨成佛佛智不增者。如山出云山亦不减。如谷纳云谷亦不增。海中板喻即十行品

疏。列名中衍英诸公等者。疏文有三。初叙昔。次此释亦无大过下会释。上句总明。果地具此三道下。为其通释。恐有难云。助等是因何将释果。故为此通。三今更一下申今正解。于中二。先总明。后一大圆镜下别辩。然取唯识论以为疏文。心无染着巧方便智宝为大圆镜智。论云。一大圆镜智相应心品。谓此心品离诸分别。所缘行相微细难知。不忘不愚一切境相。性相清净离诸杂染。纯净圆德现种依持。能现能生身土智影。无间无断穷未来际。如大圆镜现众色像。释曰。观上论文自分主客。但云不忘者常现前故。不愚者不迷暗故。余义可知。论云。二平等性智相应心品。观一切法自他有情。皆悉平等大慈悲等恒共相应。随诸有情所乐。示现受用身土影像差别。妙观察智不共所依无住涅槃之所建立。一味相续穷未来际。释曰。由昔因中执有我故。自他不等。今由我无故皆平等。言一味者一无漏味。余义可知。由涅槃故。此识恒共悲智俱行。论云。三妙观察智相应心品。谓此心品观察诸法自相共相无碍而转。摄观无量总持定门。及所发生功德珍宝。于大众会能现无边作用差别。皆得自在雨大法雨断一切疑。令诸有情皆获利乐。释曰。摄谓摄藏观谓观察。功德珍宝即六度道品等。论云。四成所作智相应心品。谓此心品为欲利乐诸有情故。普于十方示现种种变化三业。成本愿力所应作事。释曰。四智广义初会已明。今以疏有故复重引。令知主客

疏。同法华髻中明珠下。七喻之中此当第六。如安乐行品明。一乘圆智居佛心顶。以权覆实如在髻中。开权为解。前亦已引

疏。然约下智不及下释上密义。故法华云。我以无数方便种种因缘譬喻言词演说诸法。是法非思量分别之所能解。唯有诸佛乃能知之。所以者何。诸佛世尊。唯以一大事因缘故出现于世。释曰。种种说法皆为一乘。众生不知故云秘密。故涅槃下引证。亦如前引

疏。体胜用深下疏文有二。先释经。后解妨。今初。言纯净圆德现种依持者。纯即无杂净即离染。圆者满义。现行功德之依。种子功德之持。自性明善名为清净。有漏永亡云离诸杂染。余如前释

疏。今以四智圆融下二解妨。妨云。何以将法相宗释法性义。故为此通。谓彼四智超然不同。今一具四。岂得同耶。先将四宝以况四智。此即别义。于一宝上复具四德。即圆融义。况四圆融十中之一。岂得言同。欲显包融故用释之

疏。第五珠消海水喻蹑前以释。疏文分二。先明智断不同。后又前下横竖分别。一佛果中具有四智名横。菩萨历位具有四智名竖。言皆是释上为依之义者。即虚空无依为依。喻中之一义也

疏。起世婆沙等说者。起世即经。婆沙即论。皆同俱舍。俱舍云。此下过二万无间深广同上七捺落迦。八增皆十六等是也

疏。俗典云。沃燋石者。山海经说尾卢壑。又云注下亦如彼说。庄子秋水篇亦明。已见回向品

疏。别显用相下疏文分三。初叙昔。二辩顺违。三申正义。今初。即灵辩法师。此三昧名。即唯识第九。论云。一大乘光明定。谓此能发照了大乘理教行果智光明故。二集福德王定。谓此自在集无边福如王势力无等双故。三贤守定。谓此能守世出世间贤善法故。四健行(平呼)定。谓佛菩萨大健有情之所行故。摄论第八意亦同此。首楞严者。是梁论名。即健行义。然是梵言。此云一切事毕竟。又英法师云。初定空智除不善障。二除着禅障。三除烦恼障。四除所知障。贤首云。初能除流散杂染业。二能除味定着静障。三能除根本无明障。四能除尽成果智障。与前大同

疏。此释配定可尔下。第二辩顺违可知

疏。今更一解下。三申今正义。于中有二。先总后别。今初所成即是四定者。如唯识论。定为能发智为所发。四智即是所成。今明佛具四智。令诸菩萨能具四定故。智为能成定为所成。竖配之相下别当具。疏谓一佛以即事而真智下。第二别释。一一智中文皆有三。初举能成智。二治于下治所破病。三令得下显所成德。文并可知

疏。肇公亦云下。即涅槃无名论。第七妙存中文。然则玄道存乎妙悟。妙悟在于即真。即真则有无齐观。有无齐观则彼已莫二。所以天地与我同根。万物与我一体。同我则非复有无。异我则乖于会通。所以不出不在而道存乎其间矣。何则涅槃夫至人虚心冥照理无不统。怀六合于胸中而灵鉴有余。镜万有于方寸而其神常虚等。今但引两对足显经意

疏。四戒定息热者。此唯定下合别显用相。中有净戒头陀。疏文多影略者。为分能所成故。能成者即如来悲等。所成即菩萨悲等。如在佛为方便在菩萨为深心。在佛禅定为叶。在菩萨净戒头陀为叶。在佛即是菩提为果。在菩萨即无生忍等

疏。是知现恶明无则无恶必有者。即生公意。生公忍死待得大经。以证大义。如何至今犹不信耶。广如玄中。今当重释。言现恶明无者。正作阐提拨无因果故无。无恶必有者。由拨因果之恶故无。今无此恶是则有矣。故应问言。颇有新作一阐提不。复有阐提后生信不。若有新作未作之时有佛性不。若未作时有作时无者。佛性可断。若先无者则不由于阐提无也。本自无故。后生信心亦复如是。若有佛性佛性是可生之法。前则本有今无。此则本无今有。若发信心亦无性者。此亦不干阐提故无。故知但是约于长时未成果善。抑言无耳。谓抑令恐怖使发大心。未作阐提令其莫作。故皆诱物何定言无。疏故涅槃下引证。此引二经。先引涅槃。自有二文。唯证阐提有性。成上不舍邪见水轮。初意即第九经玄中已引。今复略明。经云。彼一阐提虽有佛性而为无量罪垢所缠。不能得见。如蚕处茧则有而非无。三十五经云。断善根人以现在世烦恼因缘能断善根。未来佛性力因缘故还生善根。亦有文也。复云。若能发心非阐提者。即二十六经高贵德王菩萨品。经云。善男子。一阐提辈若遇善友诸佛菩萨闻说深法。及以不遇俱不得离一阐提心。何以故。断善根故。一阐提辈亦得阿耨多罗三藐三菩提。所以者何。若能发于菩提之心则不名为一阐提也。即其文矣

疏。法华云下。二引法华。亦有二文。以证定性二乘皆成佛义。一即法师品。药王汝当知。如是诸人等。不闻法华经。去佛智甚远。若闻是深经。决了声闻法。是诸经之王。闻已谛思惟。当知此人等。近于佛智慧。释曰。既言决了声闻法。明昔净名等经声闻如根败之士。其于五欲不复能利。及如燋谷芽。佛名经说。如燋谷芽虽逢春阳无希秋实。及深密等说于定性不得成佛。三乘圣人心皆犹预。今皆作佛。故云决了。第一经云。菩萨闻是法疑网皆以除。千二百罗汉悉亦当作佛。故云决了。复恐人云。千二百外定性声闻即不作佛也。故引次文。即五百弟子授记品初。千二百悉皆求记。如来先授陈如作佛。次授五百。末后偈云。其五百比丘。次第当作佛。同号曰普明。转次而授记。我灭度之后。某甲当作佛。其所化世间。亦如我今日。国土之严净及诸神通力。菩萨声闻众。正法及像法。寿命劫多少。皆如上所说。迦叶汝已知。五百自在者。余诸声闻众。亦当复如是。其不在此会。汝当为宣说。释曰。据此非唯列千二百。则灵山之会万二千人。五千拂席增上慢者。应是声闻不厕灵山法华胜会者。令此会中声闻菩萨转为授记。余如玄中

疏。有引向来所拣下即举邪显正。谓法相师以水轮中证有无性。地狱深坑证有定性趣寂二乘不观已下破其妄引。疏有三节。初指经中却收之义。二引第十等有喻意。三减损佛性下以理结劝。谓唐三藏创自西回。荐福寺有一人大德。不肯修敬。后因见日照三藏远涉流沙广取经论。诚曰劬劳。然减损佛性增足烦恼。未知与圣意相应。不言减损佛性者。以五性之中唯一性半有佛性耳。谓菩萨性及不定性之半。以不定性容有无故。余三性半一向言无。谓一无种性人。二定性声闻。三定性缘觉。言一半者。即不定性中或无是也。言恐谤一乘者。以罪怖之。然法华经特称妙者。以佛昔说三乘五性。今法华云一乘一性。谓一切众生有如来知见。更无余性故。惟一乘涅槃云佛性者。名为一乘。以凡是有心定当作佛。故唯一乘。法华又云。唯此一事实。余二则非真。终不以小乘济度于众生。又第四云平等大慧。又彼疏自立一乘为宗。及其立义定有五性。却以一乘而为方便。此岂不是谤一乘耶。谤一乘罪。法华具明。事不可轻。如增上慢不信不轻。皆作佛言即为谤耳

疏。广明留惑润生具如前章者。即义理分齐别有一门。第十喻法说中三。初略消经文。二以上言潜流下对前辩异。三此有三意下。别解文旨。文三。初顺释。二释疑。三及以理成。初中亦三。一明生等有因。二明因有果智。三自他交彻。今初。先正立。后则知无性下反成上义。即涅槃经云。除墙壁瓦石皆有佛性故。无佛性则非众生。凡是有心定当作佛。则无一不有。以一切人皆有心故。故知作佛言无佛性则无心也。无心宁异瓦砾。此是涅槃一性之宗。故云已过五性

疏。二者众生在缠之因等者。二明因有果智。拣胜初义。但有佛性。于中三。初正立。二正拣。三结劝。今初。谓远公等释涅槃经。言因性本有果性当成。今因有佛智佛智非因。故超前也。所以有者。因果二性无二体故。若因无果性果是新生。便有始故。新生有始佛性非常住故

疏。非但有性后方当成者。第二正拣前义。于中二。一拣因果不同。谓前义意如木有火性钻方生火。乳有酪性缘具成酪。今此中意果尚本有。况于因性。况当有耶

疏。亦非理先智后者。二拣理智两别。若唯理性为先有者。则第一义空不名智慧。理智异故。无漏智性本自有之。不应理故。大智光明非本有故。智后生者果无常故。能证所证成二体故

疏。是知涅槃下第三结会劝信。谓涅槃终极之说。会昔有余四十九年多说三乘五性之教。机习已久。难可顿移。且说有心皆有佛性。一经前后纵夺合离。而其明言凡是有心定当作佛

疏。后学尚谓谈有藏无者。即大乘法师法华疏意。彼意涅槃经言一切众生皆有佛性。总谈皆有欲奖众生。实而明之亦有无者。藏在一切总有之中。言通别类异者。通相皆有别拣有无。有无不同不应一类

疏。况闻等有果智谁当信者。即举今宗结成难信劝令信耳

疏。三彼因中之果智下。第三自他交彻。谓诸凡夫因中果智。即他诸佛已成果智自身佛性。一身竖论。他佛智在凡自他横辩。故更玄也

疏。不尔此说众生下以理成立自他平等。谓此章中举其十喻以辩佛智。忽引众生有佛智者。何名为说诸佛心耶。明知是说众生心为佛矣。斯则玄下结叹归宗

疏。如壮士迷于额珠。岂谓肤中无宝者。即涅槃第八如来性品。北经第七。佛告迦叶。善男子。譬如王家有大力士。其人眉间有金刚珠。与余力士捔力相扑。而彼力士以头抵触。其额上珠寻没肤中。都不觉知是珠所在。其处有疮。即命良医欲自疗治。时有明医善知方药。即知是疮因珠入体。是珠入皮即便停住。是时良医寻问力士。汝额上珠为何所在。力士惊答大师医王。我额上珠乃无去耶。是珠今者为何所在。将非幻化忧愁啼哭。是时良医慰喻力士。汝今不应生大愁恼。汝因斗时宝珠入体。今在皮里影现于外。汝当斗时嗔恚毒盛。珠陷入体故不自知。是时力士不信医言。若在皮里脓血不净何缘不出。若在筋里不应可见。汝今云何欺诳于我。时医执镜以照其面。珠在镜中明了显现。力士见已。心怀惊怪生奇特想。上具引经文下合文。广以意引之。谓以良医喻之善友。烦恼为皮肤。佛性为宝珠。不知为失。惑尽乃得证知了了。如彼力士于明镜中见其宝珠。荐福解云。贫女金藏通喻凡夫不知佛性。此喻菩萨二乘观心之首隐其佛性。已发三乘心名为王家。以未入佛家故有观心力名为力士。中道佛性之珠在其心间。与倒竞力观于俗境名为相竞。观心取境名头抵触。取相隐理名寻没肤中。以相求理不能得见。名不知所在。取相见空名之为疮。访友为命医。佛为良医。知佛性珠取其空相。名知是疮因珠入体。定得之性在上相内。名珠入皮即便停住。是时良医下问性所在。相覆真性故。力士不知所在。先因发心。将非虚说。名将非幻化。恐无性流转名忧愁啼哭。次佛慰云。言性不失汝之妄竞性隐无我。名珠入体在于皮里。因本有理有理性相。名影现于外。汝观空等时其心猛利。如嗔恚盛。因斯陷入故不自知。此上有性不见喻二乘。是时力士下拒教不信喻。若在皮里脓血等者。谓在凡夫苦等相中。有漏不净性净应出。何缘不见。若筋等者。若是真理真理。无相不应可见。汝今云何下正明不信经。是时良医下依教见性喻。珠在镜中明了显现者。定得之性惟大涅槃理教能显。如镜照面了了分明。力士见已者。众生则闻见。十住则目见。余可知

疏。如贫得珠非今授与者。即法华第四五百弟子授记品。说系珠喻领解得记。经云。譬如有人。至亲友家醉酒而卧。是时亲友官事当行。以无价宝珠系其衣里与之而去。其人醉卧都不觉知。起已游行到于他国。为衣食故勤力求索。甚大艰难。若少有所得便以为足。于后亲友会遇见之而作是言。咄哉丈夫。何为衣食乃至如是。我昔欲令汝得安乐五欲自恣。于某年月日以无价宝珠系汝衣里。今故现在。而汝不知。勤苦忧恼以求自活。甚为痴也。汝今可以此宝贸易所须。常可如意无所乏短。不合可知。然系有二。一约结缘则圆解为珠。为说为系。烦恼昏醉少有微解。故曰系珠。五道求乐为勤力艰难。证小涅槃不求大果。云得少为足。后闻法华为会遇亲友。示以知见如得衣珠。以因易果无乐不得。昔已系之。故云非今授与。二约无性然其昔系亦非新与。未知令知故云系耳。则不全同喻。今疏取无性系珠以成本有。故云非今授与

疏。是以涅槃恐不修行下。以涅槃经结成上义。执着过轻乍可言有。妄语过重不可言无。况无著而知。决须有矣

大方广佛华严经随疏演义钞卷第七十九大方广佛华严经随疏演义钞卷第八十

        唐清凉山大华严寺沙门澄观述

疏。始本无二绝二碍者。此有二意。一则众生本有佛智。是则本觉不碍始觉。如是而证名无碍智。二者断障显了则无烦恼所知二碍

疏。合出经益物等者。疏文有二。先正释文。后然如来藏经等下引例释者。言九喻者。如来藏经具有九喻。一二不同余经。或有一二三四。多少不定故致等言。言如来藏经者。即如来在王舍城耆阇崛山。成佛十年后方说之与大比丘百千人菩萨六十恒河沙云云。尔时世尊于栴檀重阁正坐三昧而现神变。有千叶莲华。大如车轮其数无量。色香具足而未开敷。一切华内皆有化佛。上升虚空弥覆世界。犹如宝帐。一一莲华放无量光。一切莲华同时舒荣。佛神力故。须臾之间皆悉萎变。其诸华内一切化佛结跏趺坐。各放无数百千光明。于时此刹庄严殊特一切大众欢喜踊跃(云云)金刚慧菩萨问佛下。为答云。我以佛眼观一切众生贪欲恚痴诸烦恼中有如来智如来眼如来身。结跏趺坐俨然不动。善男子。一切众生虽在诸趣烦恼身中有如来藏。常无染污德相备足如我无异。又善男子。一譬如天眼之人观未敷华。见诸华内有如来身结跏趺坐。除其萎华便得显现。如是善男子。佛见众生如来藏已。欲令开敷为说经法。灭除烦恼显现佛性。善男子。诸佛法尔。若佛出世若不出世。一切众生如来之藏常住不变。但彼众生烦恼覆故。如来出世广为说法。除灭尘劳成一切智(云云)每喻之后皆有偈文。二复次善男子。譬如淳蜜在岩树中。无数群蜂围绕守护。时有一人巧智方便先除彼蜂。乃取其蜜随意食用。惠及近远。下取意合。蜜喻如来藏。蜂喻烦恼。人喻如来。除蜂喻说法除烦恼。三复次善男子。譬如粳粮。未离皮糩贫愚轻贱谓为可弃除荡既精当为御用。合云。糠喻烦恼。米喻如来知见说法除烦恼净一切智。于诸世间为最正觉。四复次善男子。譬如真金。堕不净处隐没不现。经历年载真金不坏。而莫能知。有天眼者语众人言此不净中有真金宝。汝可出之随意受用。法合例知。五复次善男子。譬如贫家有珍宝藏。珍宝藏不能言我在于此。既不自知。又无语者。不能开发此珍宝藏。一切众生亦复如是。如来知见力无所畏。大法宝藏在其身内。不闻不知耽惑五欲。流转生死受苦无量。是故诸佛出兴于世。为开身内如来法藏。无碍辩才为大施主。六复次善男子。譬如庵罗果内实不坏种之于地成大树王。善男子。我以佛眼观诸众生。如来宝藏在无明[穀-禾+卵]内。犹如果种在于核内。善男子。彼如来藏清净无极。大智慧聚妙寂泥洹。名为如来应正等觉。七复次善男子。譬如有人。持真金像行诣他国。经游险路惧遭劫夺。裹以弊物令无识者。此人于道忽便命终。于是金像弃捐旷野。行人蹑迹咸谓不净。得天眼者见弊物中有真金像。即为出之一切礼敬。合有如来微妙宝藏。八复次善男子。譬如女人贫贱丑陋。众人所恶而怀贵子。当为圣王王四天下。此人不知经历时节。常作下劣生贱子想。合有如来宝藏。九复次善男子。譬如铸师铸真金像。既铸成已倒置于地。外现燋黑内像不变。开模出像金色晃曜。合云有如来身众相具足。下校量功德。受持此经供养过去恒河沙现在诸佛。造恒河沙七宝台高十由旬。日日如是。乃至五十恒河沙七宝台供养恒河沙如来。不如有人喜乐菩提受持此经。乃至算数譬喻所不能及。上之九喻。初莲华有佛喻与青莲在泥喻。大同小异。其金堕不净处与摩尼堕深厕中大同。彼阙此如金在于矿。如蜜在山中。余多大同。而不次第者。此取圆意略举十耳。山中有蜜。又与尘中佛性小异。故略无之。又此引为顺圆融。自凡至圣具含诸义。故乱引之。若依佛性论具释九喻。虽不引如来藏经。而与此经喻次全同。各别有意。广如佛性论。别钞中已引。言余经或有一二三等者。涅槃胜鬘等经皆说。不能具引。金矿之喻涅槃第十有文云。复次善男子。譬如金矿淘炼滓秽。然后销镕成金之后。价直无量。善男子。声闻缘觉菩萨亦尔。皆得成就同一佛性。何以故。除烦恼故如彼金矿除诸滓秽。以是义故。一切众生同一佛性无有差别。以其先闻如来蜜藏。后成佛时自然得知。如彼长者知乳一相。何以故。以断无量烦恼故。释曰。以是长者多牛[(殼-一)/牛]乳一色喻。复转以显故。第五经中有雪山甘药喻。全同淳蜜在岩喻。余有多喻不能具引。大价摩尼垢衣所缠者。即楞伽第二。疏当第五。经云尔时大慧菩萨摩诃萨白佛言。世尊。世尊修多罗说。如来藏自性清净。转三十二相。入于一切众生身中。如大价宝垢衣所缠。如来之藏常住不变亦复如是。而阴界入垢衣所缠。贪欲恚痴不实妄想尘劳所污。一切诸佛演说。释曰。此中大慧引昔之说下。难同外道说我。佛下答不同外道故但是虚妄无有真实。如来说如来藏有时说空无相无愿如实际法性法身涅槃自性不生不灭本来寂静自性涅槃。如是等句说如来藏等。余经所有可略言也

疏。总结上来十喻等者。疏文有二。先结上十门以成未尽

疏。故应更以下正释经文。由经云以如是等无量相知。如是指前等即等后。更明别义。此结有四。一无量。二无碍。三不可思。四广大。并遍上十及所不说。第五出现境界

疏。正显分齐下疏文有三。初出体。二依初义下对前二义以辩来意。三由所缘下融上二义。疏后正显所缘下分二。先随文释。后若约二谛下义门料拣。第六出现之行前明分齐下文有二。先彰来意。后虽智海下通妨。谓有问言。行在因中今果满何有。释云。行虽无量总不出二。谓智与悲。智行已圆自利满故。而运即智之悲利他不息。若尔何以下文说真如行。答此即果之行。将说悲智无碍之行。故说真如行之本耳

疏。真如之名言含法喻者。经云如真如前际不生等。即以真如喻佛行也。若佛行契如行即是如故即是法

疏。过未非缘者。过去缘已谢未来缘未会。故曰非缘。由非缘故过去无可生。未来无可动。现在虽在缘中不与缘合。故云离缘。故回向中明。遍在三世不同三世。遍在一切而非一切。故缘虽起而湛然无起

疏。若谓无量即是量故者。离量有无量故。故楞伽云。无心量之心量。我说为心量。谓以无心量而为是者。而还是心量耳。故心弥虚下上句明无量不碍量。终曰行句明量即无量。但涅槃云下引证。即第十一经。远公有二释。一云辩行所依谓如来先成之德。修习趣入亦可五行。是其教行显性成行。是如来。行显如来性以成行故。意云此一即是证行证性而成行故。第七出现菩提

疏。圆行之果下明来意有二。上约真菩提辩来意。对缘造修下约应菩提以辩来意

疏。二明体等者此引二论。二互相成。摄论第九智论第三。二智即根本后得。二断即断烦恼所知。此经圆宗故。通一切下。云得一切法量等三轮自他平等因果交彻。如是等义故通一切

疏。三辩种类中二。先正辩后料拣。今初者。言夫如者。不二不异者。即弥勒章。下当辩意。涅槃云下智观等。六地已引

疏。或分为五如大品等者。智论五十八云。一发心菩提。无量生死中发阿耨多罗三藐三菩提心故名菩提。因中说果。二伏心菩提。断诸烦恼降伏其心行诸波罗蜜。三明心菩提。观三世诸佛法本末总别相。分别得诸法实相。谓般若波罗蜜。四出到菩提。于涅槃中得方便力故不着。若灭一切烦恼见一切佛得无生法忍。出三界到萨婆若。五无上菩提坐道场断习气。得阿耨多罗三藐三菩提

疏。或具十如离世间品者。即五十九经十种成如来力为十菩提。经云。佛子菩萨摩诃萨有十种成如来力。何等为十。所谓一超过一切众魔烦恼业。故成如来力。二具足一切菩萨行。游戏一切菩萨三昧门故成如来力。三具足一切菩萨广大禅定故。四圆满一切白净助道法故。五得一切法智慧光明善思惟分别故。六其身周遍一切世界故。七所出言音悉与一切众生心等故。八能以神力加持一切故。九与三世诸佛身语意业等无有异。于一念中了三世法故。十得善觉智三昧。具如来十力。所谓是处非处智力。乃至漏尽智力故。成如来力是为十。若诸菩萨具此十力。则名如来应正等觉。句句皆有成如来力言。此十菩提多同今经

疏。唯十为圆下第二料拣先示别教。后三除前二下约同教门拣而收之

疏。四明业用等者。以下科经有其十门。兼体相用。今唯辩用有其十耳。不出下文

疏。离诸缘者。有观则有缘无缘则绝观。如海下释文以成上义。非无所了下成上观极于无观义。谓观智之极谓之无观。无彼分别取相之观。非无甚深无分别观。故引晋经解一切义合明二经。应云解一切义无所观察。若改为解义则圆足。译经之人见下文有知众生心故。此但明无观之义

疏。既观念斯寂下。上明成智即无分别智。今明断障即断烦恼

疏。无观是体下结成具三。无观是体者无念体也。照智是上无分别智。断即是向无惑习种。合为相者。谓寂照无二为菩提相。犹如明镜无心为体鉴照为用合为其相。亦即禅宗即体之用。自知即用之体恒寂。知寂不二为心之相也

疏。二等同万法者。释经于法平等无有疑惑。即是下文三轮平等

疏。上二已摄。摄论体者。初是实智。断烦恼障。二是权智。断所知障。故二句中已具二智二断体也

疏。三一成一切成者。释经无二即是下文因果交彻。于中有二。一明生佛不二。即一成一切成故。下释云。如来成正觉时。于其身中普见一切众生成正觉等。暗引净名一切众生即菩提相。即菩提相于何不成。二明能所不二。即下释中皆同一性。又引净名不二是菩提离意法故。法即是所意即是能。良以心境同一性故。生佛亦然。此引净名。皆弥勒章

疏。四总指前三体相寂灭者。释经无相。即是下文。体离亏盈下释云。成与不成常无增减。菩提非相非非相故。由寂灭故无有亏盈寂灭即是无相义也。故引净名。云灭诸相故释于寂灭

疏。五即心行处灭者。释经无行。即是下文相无增减。故云湛然不迁耳。释云若无有相则无增减

疏。六虽觉而常定者。释经无止。以不住定故。即是下文用该动寂。下释云。住善觉智三昧而现多身。由不住止故能动用

疏。七有二义等者。释经无量。即是下文周于法界。此中有二下释亦二。一明一毛含于多佛周遍法界。即是此中初义。二云如来成正觉身究竟无生灭故。即第二义

疏。八亦二义等者。释经无际。即是下文普遍诸心。下释亦二。一云菩萨应知自心念念常有佛成正觉。即此竖无际畔。二下释云。何以故。诸佛如来不离此心成正觉故。即第二意念念应即是化身。一得永常即是报身。心无初相下契同法界身。然此一句即起信论。论云。菩萨地尽觉心初起。心无初相。以其远离微细念故得见心性。心即常住名究竟觉。下云不离此心即冥符理义。然觉心初起心无初相。自有二意。一者觉是能觉心是所觉。心是初相即业相是微细念。最初迷真不觉心动。今无此相故。二者觉心合明。谓正觉心起无能起相。故与理冥。若有起相不合理故。正此取意。故云心无初相冥符于理。义兼于前。以无细念故。无觉相由依法相。化身有始有终。报身有始无终。法身无始无终。今符于理报亦无始。故云始觉同本觉。无复始本之异。名究竟觉。故云无前际故则无始也。无终同于上句无后际耳。法报既融即体之应念念无断。三身融矣

疏。九离边契中下释经远离二边住于中道。即是下文普遍诸心。下释云。广大周遍无处不有。不离不断无有休息。入不思议方便法门。疏文有二。先释离边。后释住中。今初。经云离边。未知何是。故举晋经。及取下释略举四种。以等一切染净约惑缚脱通惑业。有无通事理。一异约心境。何以有此。谓成菩提既离细念。妄惑尽矣。显现法身智慧纯净。若为此见未免是边。故上经云。若有见正觉解脱离诸漏不着一切世。彼非证道眼。今了于惑体性本空后无所净故离二边。又染净交彻故无住着。是曰离边。缚脱者谓昔常被惑业系缚流转无穷。今得菩提释然解脱。若为此见即是住边。菩提智了本自无缚。于何有解。无缚无解则无乐厌。故得离耳。有无上言通事理者。若昔谓惑有今了惑空。昔谓心空今知妙有。又真乐本有失而不知。妄苦本空得而不觉。今日始知。空者妄苦。有者涅槃。若如是知并未离边。又烦恼业苦本有今无。菩提佛身本无今有等。皆三世有法。菩提之性不属三世故。三世有无皆是边摄。真智契理绝于三世故。离有无之二边等。一异有二。一者心境不了则二。契合则一。亦成于边。二者生佛有异今了一性亦名为边。今正觉了此中无有二无二。亦复无大智善见者如理巧安住故。离此边而言等者。谓断常来去生灭依正。离是二法皆称为边。又二与不二亦名为边。今一契菩提一切都寂。故云远离

疏。不偏住着等下释住于中道。然通妨难生下契中。谓有难言。若离于边未免于边。有取舍故。故释云。不偏住著名曰离边。非见有边而可离也。谓不偏住染染性空故。性即净故。不偏住净。若无染则无净故。净相离故。同染性故。染净交彻安可住耶。智契此理故曰离边。故言非见有边。边即中故。复有难云。有边即有中边。既即中则无边矣。既无有边对何说中。故次答云无边无中方住中道。此有二意。一顺上答。谓诚如所言。无边无中故曰中道。若有中边非真中也。二者反上答。谓中道有二。一者相待则离边住中。二者绝相即边而中。相待而空则有边中。无边无中为真中矣。故相待绝待尚是相待。得意亡言言不尽矣。历上染净等一一皆然

疏。十总显离言。释经出过一切文字言说。即是下文体相甚深。斯则上九寄言显深。今菩提离言显深

疏。无所现有三义者。一无心现约止。二所现空约观。三无别体约止观契合。又一约心。二约境。三心境两冥。又一约智。二约理。三理智冥契。就第三义中。疏先正释。后自体显现故名为觉者通妨。谓有难言。若无别体何能普现众生心行。故答云。自体显现如珠有光自照珠体。珠体喻心光喻于智。心之体性即诸法性。照诸法时是自照耳。故引起信文甚分明。然论问曰。虚空无边故世界无边。世界无边故众生无边。众生无边故心行差别亦复无边。如是境界不可分家。难知难解。若无明断无有心想。云何能了名一切种智。答曰。一切境界本来一心离于想念。以诸众生妄见境界故。心有分齐。以妄起想念不称法性故不能决了。诸佛如来离于见想无所不遍。心真实故即是诸法之性自体显照一切妄法。有大智用无量方便。随诸众生所应得解。皆能开示种种法义。是故得名一切种智。释曰

疏。但引中间以证自体显照。前后可知。故不广引

疏。意轮等故何所疑哉。缘上标章云于法平等无有疑惑故

疏。今初。有十三身下疏文有三。初略释文。二皆言量下别释量字。三是以圣人下结成玄旨。即肇公涅槃无名论通古中文。出前穷源中云非众生无以御三乘。非三乘无以成涅槃。然必先有众生后有涅槃。是则涅槃有始。有始必有终。而经云涅槃无始无终湛若虚空。则涅槃先有非复学而后成者也。释曰。此文以修得。难今涅槃有始终义。以涅槃无始终难其修得故通古。答云。无行名涅槃。至人空洞无像而物无非我。造会万物以成己者。其唯圣人乎。何则非理不圣非圣不理。理而为圣者圣不异理也。故天帝曰。般若当于何求。善吉曰。般若不可于色中求。亦不可离色中求。又曰。见缘起为见法。见法为见佛。斯则物我不异之效也。所以至人戢玄机于未兆。藏冥运于即化。总六合以镜心。一去来以成体。古今通始终。同穷本极末。莫之与二。浩然太均。乃曰涅槃。释曰。彼虽明涅槃。亦以能证所证契合故物我一体。今虽约菩提亦取能所一体。故得用其文耳

疏。今初八相之中下。疏文有四。初略消经文。二会净名。三对前拣异。四广征释。疏此文正同下第二会净名。于中三。初正显同。二出彼经意。三正会释。今初。即菩萨品。弥勒为兜率天子说不退转地之行。净名难云。为从如生得授记耶。为从如灭得授记耶。若以如生得授记者。如无有生。若以如灭得授记者。如无有灭。一切众生皆如也。一切法亦如也。众圣贤亦如也。至于弥勒亦如也。若弥勒得授记者。一切众生亦应授记。所以者何。夫如者不二不异。若弥勒得阿耨多罗三藐三菩提者。一切众生皆亦应得。所以者何。一切众生即菩提相。若弥勒得灭度者。一切众生亦当灭度。所以者何。诸佛知一切众生毕竟寂灭即涅槃相。不复更灭。释曰。今正释成正觉义。故但引菩提。若据经文云乃至入涅槃。则亦有亦当灭度之义故。今具引耳

疏。弥勒示迷此旨下。第二出彼经意。既为补处何理不穷。寄于受屈以悟时听耳。言但谓理诘之言者。即是迷相。然迷有二意。一约弥勒受难。云一切同如而我独得授记。诚乖理也。故云理诘之言。二者弥勒不受难云。理虽一如行满得记。何得以理而难事耶。故云理诘

疏。不知真得菩提实如所诘者。三正会释净名。非曰妄诘。真实菩提诚乃一得一切得耳。则受难不受难俱迷此理。若显不迷应对净名。实如所言。我已见生得记作佛入涅槃竟

疏。又前章下三对前拣异。则前是普遍。此是广容。言一性平等反覆相成者。前章明平等此章明一性。故下释中皆同一性。由平等故唯是一性。由一性故何不等耶。故云相成疏。此中之成下。第四广征释。先征。后此是华严大节下释。于中二。先标示。后然诸众生下别释。即五教意兼人天为六。初人天乘。二小乘下二乘。三大乘下始教。四或说唯如来藏下终教。五更有下顿教。六若依此宗下圆教。于中四。一正释。二解妨。三结例四重释

疏。若尔下二解妨。于中五。一申难。二若就众生下解释。此中意云。以理融通不可作理事别解。三若尔下以能难所。佛既了达何用化耶。四不如是知下释化之由。五如是化下结成真化。言无不化时即常化也。故引相续正成常恒

疏。随门不同种种有异下第三结例。即类结余门。门虽有多且略分四。一约性。即一真法界。二约相。即无尽事法。三约性相交彻。显此二门不即不离。四以性融相德用重重。初约性门者。问体是佛不。答是若无碍应成四句。一是佛法性身无所不至故。经云。性空即是佛故。二非佛绝能所觉。为其性平等一真法界。非佛非众生故。三亦佛亦非佛。以法性身无自性故。四双非。性与无性双泯绝故。经云。无中无有二。无二亦复无。三世一切空。是则诸佛见。二就相门乃有二义。一情。二非情。真心随缘变能所故。然此二门各分染净。谓无明熏真如成染缘起。真如熏无明成净缘起。染成万类净至成佛。以修净缘断彼染缘。方得成佛。依此二义则生佛不同。于净缘中复有因果。因有纯杂果有依正。若约纯门随一菩萨尽未来际唯修一行。一一皆然。若约杂门。万行齐修尽未来际。若约因门尽未来际常是菩萨。若约果门尽未来际常是如来。经云。为众生故念念新新成等正觉。若双辩二门。尽未来际修因得果。若约双非。尽未来际非因非果。便同真性。前之二门双具悲智双融心境。第三性相交彻门中。曲有四门。一以性随相同第二门。二会相归性同第一门。三双存无碍具上二门。依此则悲智双运性相齐驱。寂照双流成大自在。四互夺双亡则性相俱绝。没同果海无成不成。第四以性融相门。相虽万差无不即性。性德包含全在相中。以性融相相如于性。令上诸门皆无障碍。因果交彻纯杂相融。事事相参重重无尽。今就性门四句之内。是即佛门不取余三。就相门中约有情门。是净非染是果非因。是一分义。非此所用。就交彻门。佛则性相双融。生则会相归性。今经正约第四以性融相。一成一切皆成。谓以佛之净性融生之染。以佛一性融生之多。令多染生随一真性。皆如于佛已成佛竟。非唯有情。会万类相融为佛体。无不皆成。故肇公云。会万物而成己者。其唯圣人乎。又云。故至人空洞无像物无非我。以佛之性融于物性。同佛皆成。以物之性融佛之相。故令三业等于万类。即今经意而非余门。故云随门不同。今是成佛门也。顿教多同约性四门。终教即同性相交彻。始教有二。一者幻有即空同会相归性。但唯心现多同第二。小乘人天皆同相门。由此有云无情成佛。是约性相相融。以情之性融无情相。以无情相随性融同有情之性。故说无情有成佛义。若以无情不成佛义融情之相。亦得说言诸众生不成佛也。以成与不成情与无情无二性故。法界无限故。佛体普周故。色空无二故。法无定性故。十身圆融故。缘起相由故。生界无尽故。因果周遍故。远离断常故。万法虚融故。故说一成一切成也。非谓无情亦有觉性同情成佛。若许成佛此成则能修因。无情变情情变无情。便同邪见。余义具如前后广说

疏。又此众生乃是像上之模者。四重释此是一义。前同佛心尘中经卷。下同第十普遍诸心。以见自成即见他成。同下自心念念常有佛成正觉

疏。二释中先总释等者。此有三意。一云同一无性故得现成者。谓既无二性佛证一性得成佛故。生随一性皆成佛矣。二云妄性本虚生元是佛者。生自有妄见生非佛。佛了妄虚生何非佛。三真性叵得非今始成者。若有可得今得成佛。证性叵得佛非始成。佛非始成佛本是佛。佛之本佛何异生佛。是故一成一切皆成。亦可说言若一不成一切不成。同一性故。今是成佛门故。故一切皆成佛也

疏。后释所无有十二句下。疏文有二。先消文后成对。前中言非独妄空真有等者。拣宗显别。妄空真有法相宗说。遍计是空圆成是有故。涅槃经说。生死是空涅槃不空。三论中云。妄说为有真谛空故。今十二句生即是妄。佛即是真。真妄俱非不应偏说

疏。以性融相法界圆现者。示其正理生佛真妄皆是相异。融同真界故。说一成一切皆成。是以结云由此无性说成正觉。若有取成非真觉故。是故文云亦复无有成正觉性

疏。又摄十二下二成对也。一能相所相对者。相为所相尽即能相。所相法体即。是有为不出染净。言相待有故者。释成无义。染待净有故无染相。净待染有故无净相。是故经云无相性也。言无尽性者。尽即能相。生灭染净全是有为。然生灭四相略有二种。一刹那尽云念念灭。以缘灭故显无灭性。二一期灭如烦恼性尽。以性空门显无灭义。二生灭对。凡则缘生故本不生。性净涅槃本来寂灭故不更灭。此对皆净名意。前约灭惑此约灭苦。由灭惑苦则菩提生。故今遣之。言约佛菩提非始生者。性净菩提非始修得。何有灭耶。三我非我对。以缘破我以我遣非我。言我尚不可得则非我。何可得。即不二法门。诸法实相中下以实相门双遣。上二即中论文。前已频引。四缘非缘对。众生是缘揽缘无性故无众生。非众生为非缘。缘尚不可得。非缘何可得。即相待破。五能证所证对。并因缘门双破能所。故上经云。知菩提性从缘起。入深法界无违逆。六合非合对。虚空无体不与物合。亦以因缘显无虚空。成正觉者能所契合。亦因缘门释无正觉。故一合相非一合相。疏物物无性下疏有二意。一由证无性故得成佛无性。即是大悲之体故得起悲二又只由下。由生不知佛证无性故化令知

疏。是谓高而无上广不可极者。显高广义。此及下大包天地等。皆是肇公涅槃无名论位体中文。彼云。经言。菩提之道不可图度。高而无上广不可极。渊而无下深不可测。大包天地细入无间

疏。初明一毛含多下。疏文有二。先总科所属。后此与下拣异。第八有三重拣。一约能现。前身为有分此毛为无分故。二又此下约所现拣。前通多类者。但言现身此云现佛故。三又前下约义相拣。前住体遍应者。即缘起相由门。由住缘起。一佛身体遍应一切。成多类故。一则如理下是法性融通门。法性如空有其二义。一则广大无所不包故。譬如虚空具含众象。二则体性周遍故。喻云。譬如虚空遍至一切色非色处。一毛含多即广容义。遍法界毛即是普遍。是谓大包下一毛广容即大包天地。多身入毛即细入无间

疏。是知坐菩提下举况显胜。有顶即是权教中说真成之处。鹿园即是八相化身转法之处。今于此成即周法界。此处转法轮即于法界无尽处转。疏此文正显佛菩提者。成上非约因人有性是佛性义。今说佛菩提。而言众生心有之者。即他果佛在我因人之心内耳。第八出现转大法轮。今初等者明转法轮。释曰。然法轮义广如别章。今略以三门分别。一释名。二出体。三转相。今初。然俱舍论亦名梵轮。如来大梵之所转故。言法轮者。法即轨持。轮者如帝王轮。从喻得名。略有四义。一圆满义。具毂辐辋轴等体用周备故。二摧坏义。摧坏烦恼如摧未伏等。三镇遏义。已伏烦恼令势转远故。如镇已伏。四不定义。从见至修修。至无学。从自至他。他信至解。解至行果等。而言转者说也。故总释云。流演圆通名之为轮。自我之彼故名为转。若别说者。略有四义。转谓动也显也运也起也。动宣言教显扬妙理。运圣道于声前。起真智于言后。圆摧障恼名转法轮释曰。此四约教理行果。如其次第下出转体不出四故。出体转相在文具之

疏。夫转法轮不出此五者。此五即是出体。亦是转相。且第二出体者。大小诸教有多差别。今以大乘学贯通诸说。体总有五。一轮自性。谓择法觉支正见正知等。通见修无学或取八圣道具轮辐毂辋故。正见思惟如毂。是根本故。正语业命说名为辐。由毂有故。正念动定说名为辋。摄录余故。二者法轮因。谓能生后圣道诸教闻思修等。诸经论中多说佛教为法轮故。三法轮眷属。圣道助伴五蕴诸法。四法轮境。圣道所缘四谛因缘三性等理。五法轮果。谓因道所证菩提涅槃无为等果。大乘法师收取五体。不出教理行果。意明二即是教四即是理。一三皆行五即是果。今经五句即摄此五。一能转心即是眷属。二即自性。三即第五。四即第二。五即第四。若以教理行果摄今五者。后三可知。初一是行。二所诠理。亦是行摄。三转约于见修等故。又此五句即是转相。第三转相者。瑜伽九十五说。由五种相转法轮者。当知名为善转法轮。一者世尊为菩萨时。为得所得所缘境界。二者为得所得方便。三者证得所应得。四皆自既得已以他相续。令于自证深生信解。五者令他于他所证深生信解。今经五句即摄彼五。一即第四令他信解。二即第二。三即第三。四即第五。五即第一。会释可知。但言所得方便者。即以三周正转见修无学。随其次第知见现观名得方便。瑜伽又说三周行相。名得所得之方便也。然上出体与其转相皆大乘意。细寻二门多有相似。或应为一。彼是法相之所宗师。且顺于彼。以今一五摄彼二五

疏。此五今皆即事契真者。拣实异权名数则同。意旨悬隔

疏。二所转体即示劝证者。一示相转。二劝修转。三作证转。第一示相转者。诸佛世尊正证诸法。随何等器而指示之。如转四谛言此身是苦。业惑为集。此灭为灭。能灭为道。示因缘等真理妙智例皆同此。当尔之时生圣慧眼。由示依去来今世有差别故。如其次第得眼智明觉。此之一智总名为眼。有三行相名智明觉。非于四谛别起四智。由真见道唯一刹那。不同小乘上下别观。依诠证灭说通三世。非是灭谛通三世有。第二劝修转者。如说四谛云此是苦。汝当知。此是集。汝当断。此是灭。汝当证。此是道。汝当修。亦生眼智明觉。若转因缘真实法等例此可知。第三作证转者。如转四谛云此是苦。我已知。此是集。我已断。此是灭。我已证。此是道。我已修。亦生眼智明觉四行。转余例于此十二行。然其三转。尊者妙音八正为转。唯是见道。以憍陈那见道生时说名已转。若通相说。诸有圣道皆名法轮。显宗论说三转即是三道。谓初是见道。二是修道。三是无学道。如憍陈那名已转者已初转故。大乘法师意取彼义。若成实师初转生闻慧。次生思慧。后生修慧。无十二行。唯作一期行相。此言却通。以说陈如即得初果未经修道。何有初果第十六智。是修道故。又初虽示是苦集等。未劝知断何因成果。若示劝转已得果竟。何用引己而为证耶。是以见道通于三转。义却长也。况通诸法皆有示劝及与证耶。故今经中始成正觉演大华严。转一乘轮亦具三矣。大乘见道唯在初地。则彼地前应非始转法轮矣。若别配二道者。第二转者谓是有学。以其妙慧如实通达。我当于后犹有所作。应当遍知苦谛。应当永断集谛。应当作证灭谛。应当修习未修道谛。如是有四种行相。如前应知。第三转者。谓是无学。以得尽智无生智故。言所应作我皆已作。谓我已遍知未知苦谛。乃至广说。我已修习未修道谛。亦有四行例前可知。释曰。此即大乘诸师别配三转属于三道。而言证者。是彼自证。非佛证也。然今经文即是三转中道法轮。永离边见。亦具说于知断证修。即是大乘无作四谛已申转体。得果等四皆可虚求

疏。是知其轮本来常清净者。即暗引净名宝积云。三转法轮于大千。其轮本来常清净。此言古来多释。今取即事之真性净之理为法轮体也。故后四段明相用深广。则迥异余宗。为不坏相略引余释耳

疏。岂同三乘但用佛声为法轮等耶者。拣实异权而言等者。就佛声中拣寻常言。如问晴雨安慰弟子等亦非法轮。唯取转法。又要令他断惑见理。方明法轮。今此乃至数重深玄。一则不论断不断等说即名轮。故经云如来所转妙法轮。一切皆是菩提分。若能闻已悟法性。如是之人常见佛。二者寻常之言亦是法论。如来无有散乱声故言不虚发。如涅槃说。如来一切语言皆名转法轮故。三者能令三界所有声。闻者皆是如来音故。四者不拣声与非声。遍于法界皆法轮体。况复一多交彻相映融即。岂同三乘之法轮哉。第九出现涅槃。疏文分三。初来意。二彰大旨。三开章别释。今初。转化既周。蹑前起后。安住秘藏显真涅槃。为物示灭显应涅槃。文具二故

疏。然大涅槃下第二总明大旨以显深玄。多用肇公涅槃无名论。有十演九折。十演者。谓一开宗。二位体。三超境。四妙存。五辩差。六会异。七明渐。八动寂。九通古。十玄得。九折者。一核体。二征出。三搜玄。四难差。五责异。六诘渐。七讥动。八穷源。九考得。开宗为初。次一折一演。折为有名之难。演即无名之答。共相研核显无名旨。今多用者。亦显肇公凭此经故。今初。大旨多用开宗言。众圣归宗冥会之所者。总显深广包含无外。故论云。九流于是乎交归。众圣于是乎冥会。谓三贤十圣必会其中。犹于百川朝宗于海。寂寥无为者显深。而广大悉备者显广。形名已下复拂深广之迹。眹者迹也兆也。论云。夫涅槃之为道也。寂寥虚旷。不可以形名得。微妙无相。不可以有心知。故净名云。不可智知。不可识识矣

疏。今以无名强名下第三开章别释。此句总明开意。涅槃二十一云。羝罗波夷名为食油虫。无有名字强立名字。善男子。是大涅槃亦复如是。无有名字强立名字位体中云。有余无余者。盖是涅槃之外称。应物之假名耳。而存称谓者封名。志器像者耽形。名也。极于题目。形也尽于方圆。方圆有所不写。题目有所不传焉。可以名于无名。而形于无形者哉。则无名亦假

疏。一释名者。若具梵云摩诃般涅槃那。具翻为大圆寂入。谓那即入义。应回在上。言正名为灭者。取其义类。乃有多方者。即生公释。远公同此。言多方者。或云不生。或云无作。或云无起。亦云无为。亦云无相。或云不灭。或云寂静。或曰安隐。或名解脱。皆是义翻。法华序品长行之中。便于中夜入无余涅槃。次即云佛灭度。后偈中又云。佛此夜灭度。明知古德正翻为灭。亦云灭度。超度四流故

疏。总以义翻称为圆寂者。即唐三藏等在义周圆。疏而言大下先总后别。总以横竖释。如题中涅槃二十一云。譬如虚空不因小空名为大空。涅槃亦尔。不因小相名大涅槃。释曰。此即绝待当体受名

疏。若约义开下别释。约三大释三大。虽通本有修成。欲分三异。性净约体。圆净约相用。约修成。兼含三身下对三大。亦有三入。若有那字。没在圆寂之中。今无那字。以般释入。梵语出息名为安那。梵言入息名为般那。那是息义。欲明此章具足真应三四涅槃。故对三大别释三入。性入即是清净涅槃。真入即是圆净涅槃。示入即方便净。远公上三约已证说。一就实论入。息妄归真从因趣果。二真应相对。辩入息化归真名入。三唯就应现舍有为道趣入无为。故名为入

疏。若圆融无碍即大涅槃者。若不圆融三入各别法相宗故

疏。二出体性者。疏文分二。一总显深玄。二别出体性。今初。先显体深。后体用无碍。初中妙绝常数者。即第十九演玄得中文。彼云何者。夫涅槃之道妙尽常数。融冶二仪涤荡万有。均天人同一异。内视不己见返听不我闻。未常有得未常无得。今取此言总叹深旨

疏。恬怕希夷者。恬和怕静夷平也。亦开宗中言。彼云然则有无绝于内。称谓沦于外。视听之所不暨。四空之所昏昧。恬焉而夷。怕焉而泰。九流于是乎交归。众圣于是乎冥会。斯乃希夷之境。太玄之乡。而欲以有无题牓标其方域而语其神道者。不亦邈哉

疏。虽迥出百非下明体用无碍。亦开宗中文。文云冥冥杳杳谁见谁晓。弥纶靡所不在。而独曳于有无之表。今反用之

疏。今以义求下第二王出体性。然远公亦以三法为体。与此小别。一色。二心。三非色非心。灭无常色获得常色等故择灭无为故。广如前说。亦非全要。不欲繁叙

疏。言今以义求者。取其深义。三德为体则身智常住无不包含故。于中三。初正明。第二所以三者下出三所以。第三然此三种下融通无碍。二中有二。一翻对说三。二当体辩三。今初。前回向中释三回向。具对十义。今略有三翻。三杂染者。烦恼为般若。烦恼即菩提故。菩提即是涅槃之中般若德也。翻于结业以为解脱。翻苦依身。即是法身。心体离念本法身故。故三杂染即性净三德。二成三德者。般若是智解脱是断。法身是恩。法身兼应应物恩德。三成三身者。般若法门身法身。是法性身解脱为应化身。作用解脱亦解脱故。若真应对辩则有真实三德应化三德。应化三德一一别从真德而起。今从通义应身但解脱德摄

疏。能证大智下第二当体明三。然荐福法师总有四释。先总释云。身是能证身。般若是智慧火。解脱则烦恼等灭。此三法合名证涅槃。言四义者。一云身是自受用身。余二即金刚心后智断二德。二云。身即法身法身即如如。摩诃般若即如如智。解脱即是一切余究竟尽故。法身为所证。般若为能证。解脱为离障。三又释云。身者即法性。有佛身义。作二所依故。有智慧义。遍照法界光明故。有解脱义。性离一切障故。此三亦不相离。彼自结云。此三释中。初顺经意欲明报身是常涅槃不灭身故。四又释云。身者色身四智为般若解脱。准前释曰。上之四解初约报身。二约法身。此二约真四通真应。三即约理为性净三德。今疏但举第二义者。欲显圆具。通因通果通真通应。应即常身。即法身故。应即是法。况自受用。自受用体。亦全法性。法身但约在缠。出缠异故。能证所证及与离障十地分得故。通因果故。举一义理无不收。疏然此三种下第三融通无碍。有法喻结。法中通因通果。理具此三即性净三德。能如是知即名字三德。依此修观即观行三德。初住分证如来究竟。直就出缠法身即具三故。成不别义

疏。故此三法下结成涅槃。涅槃第二云。我今当令一切众生及以我弟子四部之众。悉皆安住秘密藏中。我亦复当安住是中入于涅槃。何等名为秘密之藏。犹如伊字三点。若并则不成伊纵亦不成。如摩醯首罗面上三目。三点若并不得成伊。三点若别亦不成伊。我亦如是。解脱之法亦非涅槃。如来之身亦非涅槃。摩诃般若亦非涅槃。三法各异亦非涅槃。我今安住如是三法。为众生故名入涅槃。荐福释曰。若将喻类法喻文不足。以法云解脱之法亦非涅槃等。喻中应云。唯一一点不成伊也。以解脱等三有一一不成故。夫证涅槃须有能证身。须有智慧火烦恼等灭。此三法合名证涅槃。若唯身亦非涅槃。唯般若亦非涅槃唯解脱亦非涅槃。此三各别未有断证。亦非涅槃。喻别亦不成。若智者意四义各殊。东西曰横。南北曰纵。纵即竖也。谓若法身本有。次修般若后得解脱。则是纵义。以经生越世弥亘净秽故。如纵三点。不横者。三法异体同时如三列火。并乃合为一体。别乃各居一处。即但用一法。今摩诃般若亦非涅槃等。是合纵并。竖明此三曰纵。举一摄二曰并。故云般若非者。般若中已摄二故。三德若异亦非涅槃。即双合横别。一一异体即合于别。异体同时即合于横故。故上云三点若别不得成伊。已合横别也。亦可横即是并。对纵为横对别为并。故经但有三句于义成四。而总释云。今三俱不思议焉可纵。俱不思议焉可横。俱不思议焉可并。俱不思议焉可别。意云。即一而三即三而一。非三非一双照三一。焉可作一三等思。若作体一用别而明。尚未免于并别也。然有云。伊字如品字。有云。如倒品字。后义为正。由此见异。古德解义取舍不同。或一德在上二德在下。或二德在上一德在下。并不得意。西方伊字三点在上。天目之喻不可二目在一目上。如来恐人误作此解。故以天目转喻伊字。则不得定一二上下。但取不可纵横及并别耳。若定说言一上二上。非唯义理不得圆妙。致令二喻自互相违。谓梵字样者[(口*口)/口]。此西方伊字。三目之一当于眉间【图】。此其状也。诸公何惑。言秘密者以深妙故。远公释云。昔隐不说故名秘密。权教所覆故复名藏。故下文云。十一部中所不说者名之为藏。又于其中包含诸德。亦名为藏。荐福释云。皆非二乘境界故名秘密。二贤皆是对昔显密。今明深妙当体秘密

大方广佛华严经随疏演义钞卷第八十大方广佛华严经随疏演义钞卷第八十一

        唐清凉山大华严寺沙门澄观述

疏。三显种类者。疏文有三。初总明深广。二今自狭下正明种类。三有余无余下对经辨定。二中言余无余者释有多义。依小乘中自有二义。一有二义。一有宗云。涅槃体一约时不同得二名字。言体一者。于此宗中烦恼业思以道力故应起不起。择灭无为是涅槃体。此体是一约对身智得二名字。身智未尽说前涅槃以为有余。身智尽竟向前涅槃转名无余。非身智灭即名涅槃。以身智起已谢灭是无常故。若断因故令后不起。是非择灭故非涅槃。二依成实。涅槃体二。生死因尽名一涅槃。生死果尽名二涅槃。由有宗中要道亲断方称择灭。身口二业及生死果。非道亲断故不取之。成实由断烦恼余不起故。见修断故。亦得择灭故名涅槃。然望大乘皆名有余。有余变易故。若依大乘。远公自有四别。一云二死因尽名曰有余。二死果尽名曰无余。二云分段因果尽名曰有余。变易因果尽名曰无余。三云分段因果及变易因尽名曰有余。变易果灭。名曰无余。四者唯就变易因果为二。分段因果属小乘故。若依金光明约三身说。三身品云。善男子依此二身一切诸佛说有余涅槃。依法身者说无余涅槃。何以故。一切无余究竟尽故。依此三身一切诸佛说无住涅槃。何以故为二身故不住涅槃。离于法身无有别佛。何故不住涅槃。二身假名不实念念灭不住故。数数出现以不定故。法身不尔。是故二身不住涅槃法身者不二故。不住生死。依三身故说无住涅槃。准上经文法身即是自受用身。常在密严佛土。一切余尽者是烦恼正习分段变易皆尽。肇公云。生名有余灭名无余。亦即此中意下疏用之。若依唯识云一有余依涅槃。谓即真如出烦恼障。虽有微苦所依未灭。而障永寂故名涅槃。二无余依涅槃。谓即真如出生死苦烦恼既尽。余依亦灭众苦永寂。故名涅槃。释曰。此通大小而说真如为体。即异小乘。论下料拣云。如何善逝有有余依问也。虽无实依而现似有。惑苦依尽说无余依。非苦依在说有余依。是故世尊可言具四。释曰。此答有二。前明示有同于二乘。后明以无漏蕴为有余依。故云非苦依在。疏。二性净方便净者。亦名二德。亦名二寂。亦名同相不同相。并如初地示说分齐中辨。性本净故从因方便之所显故。作用善巧故。亦是体用余如别章

疏。二即自性真应者。上明真应。自性合其二佛约净。今开自性通于染净。疏或分为四。即唯识论。论云一本来自性清净涅槃。谓一切法真如。理虽有客尘而本性净。具无数量微妙功德。无生无灭湛若虚空。一切有情平等共有。与一切法不一不异。离一切相一切分别。寻思路绝名言道断。唯真圣者自内所证。其性本寂故名涅槃。二有余依。三无余依。具如上说。四无住处涅槃。谓即真如出所知障。大悲般若常所辅翼。由斯不住生死涅槃。利乐有情穷未来际。用而常寂故名涅槃。一切有情皆有初一二乘无学。容有前三唯我世尊独言具四。下疏结文用此四也。疏有余无余下三通相料拣。非独应灭拣于异释。疏四彰业用初正明。亦即无名论第十玄得演中言也。彼云。故能囊括终古导达群方。亭毒苍生疏而不漏汪哉洋哉。何莫由之哉。故梵志曰。吾闻佛道厥义弘深汪洋无涯。靡不成就。靡不度生。然则三乘之路开真伪之途辨。贤圣之道存无名之致显矣。释曰。彼后叹无名。今略不举。二涅槃云下引证。前疏已引。三则出现下结成深广。今以出现为总门。则涅槃当其一德。若涅槃为门出现九门皆涅槃出矣。四然诸门下指广在余。已摄诸妙故云略在文具。疏今初根本自性者。此三行疏已具上列一二三四诸涅槃矣。思之可见。疏二指理同事者。事即真应涅槃。于中三。一略释经文。二真应无本下总显文意。三所以列十下释十之由。二中先反显真应涅槃。若无自性涅槃为本。皆非不生。而真涅槃由性净。显共许不生而应涅槃皆谓生灭故。今特说应无性净安得不生。后故以本下。顺显以性净本该真应末。真应对性净称末故。真与性净二俱为体。该应化用皆为无住三德涅槃。三释十所由中。究竟妙道者。即无名论难差中文。文云。有名曰涅槃既绝图度之域。则超六境之外不出不在。而玄道独存。斯则穷理尽性。究竟之道妙一无差。今取意引

疏。是知玄道下结成正义。言妙悟者即能契。是由能契即真。方得成此所契即真即是性净。即妄即真生无生矣。岂非齐观。齐观一味能所两冥。故全真性以为我体。真既湛然故知双林应灭非灭。以常住故言无灭者。本寂灭故。然此亦即妙存中。文上意业中用其一半。彼已其引。今侧用两句。谓彼天地与我同根。万物与我一体。今顺经文以真如等为涅槃本

疏。涅槃不空者。谓有善色者。远公引此证色为体。今亦一义。常身法身栴檀座塔楞伽之义前皆已引。疏。妙色湛然者六卷泥洹经纯陀叹佛云。妙色湛然常安隐。不为时节劫数迁。大圣旷劫行慈悲。获得金刚不坏体。余可知。疏第三至出没常湛等者。以此中经文有二。先明出没之迹。后而实如来下明常湛之本。疏中有五。一立理。二无不为下直消文。三不碍出没下覆疏显意。四是知寂然不动下结成相融。上句体不碍用。下句用不碍体。五岂可随于下。结弹惑情。然此五段多用无名第三位体。论云其为称也因应而作。显迹为生息迹为灭。生名有余灭名无余。然则有无之称本乎无名。无名之道于何不名。是以至人居方而方。止圆而圆。在天而天处人而人。原夫能天能人者。岂天人之所能哉。果以非天非人故能天能人耳。其为治也。故应而不为因而不施。因而不施故施莫之广。应而不为故为莫之大。为莫之大故乃返于小成。施莫之广故乃归乎无名。又下云。意谓至人寂怕无兆隐显同原。存不为有亡不为无。何则佛言吾无生不生。虽生不生无形不形。虽形不形。以知存不为有。经云。菩萨入无尽三昧尽见过去灭度诸佛。又云。入于涅槃而不涅槃。以知亡不为无。亡不为无虽无而有。存不为有虽有而无。虽有而无故所谓非有。虽无而有故所谓非无。然则涅槃之道果出有无之域。绝言象之迳断矣。子乃云。圣人患于有身。故灭身以归无。劳勤莫先于有智。故绝智以沦虚无。乃乖乎神极伤于玄旨者哉。上一段论文义理连环。但观所引自见疏意。其结弹文亦彼章末云。而惑者居见闻之域。寻殊应之迹。秉执规矩。而拟大方。欲以智劳至人形患大圣。谓舍有入无因以名之。岂谓采微言于听表拔玄根于虚坏者哉

疏。后合然法身无像等者。疏文有三。初正释。二引证。三拣定。今初亦前章后意。次彼论云。经云法身无像应物而形。般若无知对缘而照。万机顿赴而不挠其神。干难殊对而不干其虑。动若行云止犹谷神。岂有心于彼此。情系于动静者乎。既无心于动静亦无像于去来。去来不以像故无器而不形。动静不以心故无感而不应。然则心生于有心像出于有像。像非我出故金石流而不燋。心非我生故曰用而不勤。纷纭自彼于我何为。所以智周万物而弗劳。形充八极而无患。益不可盈损不可亏。宁复痾疠中逵。寿极双树灵竭天棺体尽焚燎者哉

疏。故摄论下第二引证释。先举论。后是以经言下会释经文。论云此颂显示显现甚深在喻可知。合者释论云。众生心中无奢摩他清渊定水。佛影不现非如来咎。如说如来是真妙道。即无漏影有感斯现生盲不睹。释下半云。诸佛法日放契经等光。遍照有情世间。有缘教光斯现。如日流光盲者不睹

疏。然此下第三拣定。亦展转通妨。于中三。初正拣定。恐有问言。今说法身何名涅槃。释意云。涅槃必具三德。此即法身。余之二德从法身流则法身故。二若尔下对前身拣。先问。后出现身下答。三此有般若下三对菩提。拣解脱无滥故不拣之。于中先问。后若分相下释。于中先明分相。即唯识等意。唯识第十释转依果云四所转得。此复有二。一所显得。谓大涅槃。此虽本来自性清净而有客障覆令不显。真圣道生。断彼障故令其相显名得涅槃。此依真如离障施设故。体即是清净法界。二所生得。谓大菩提。此虽本来有能生种。而所知障碍故不生。由真圣道力断彼障。故令从种起名得菩提。起已相续穷未来际。此即四智相应心品故。大乘法师云。理凝本有离缠而号涅槃。智照新生果圆而称正觉。乃四德之鸿源三明之妙本矣

疏。若摄相说下后明摄相中文有四别。一约理智相摄。以离理无智离智无理。如珠之明如明之珠故。般若云。觉法自性离诸分别为菩提故。则有理矣。涅槃中有般若德故。二智性本有下本有修生相摄。则性净但名涅槃。方便净者方为菩提。今明二净俱通上二。今疏但显别说所无故。于菩提说性净等。上说菩提如虚空故世界成坏无增减故。涅槃经说。修习常住二字为灭相者。我于其人为般涅槃。彼中宣说本隐今显。法常名常方便修生报常名住。修此二字为大涅槃寂灭之相。大般涅槃犹显其心故。佛证之为般涅槃。故知各具方便性净。三随一为门下双结前二。四今以涅槃下结归涅槃

疏。第五示灭妙存灭既示灭即无灭矣。故为妙存。妙存二字全是无名。第四章名彼论云。圣人处有不有居无不无。居无不无故不无于无。处有不有故不有于有。故能不出有无不在有无。怕尔无朕斯为妙存。然出没常湛兼明于出。今但无灭故不同也

疏。第六至随缘起尽。合中四。初正释文。引法华者以法华中诸师异解。今将此文楷定彼义。二然现灭现生下彰其大意。明生与灭皆涅槃故。三故摄论下引证。四既起灭在缘下结成常住。亦是无名位体中义。第四已引。疏第七存亡互现意随机见故

疏。第八至大用无涯。疏文有二。先释文后拣异。今初即无名论。第十五动寂彼云。圣人无为而无所不为。无为故虽动而寂。无所不为故虽寂而动。虽寂而动故物莫能一。虽动而寂故物莫能二。物莫能二故逾动逾寂。物莫能一故逾寂逾动。所以为即无为无为即为。动寂虽殊而莫之可异也。疏。涅槃受纯陀供处等者。即举同拣异。彼第十经大众问品云。尔时一切菩萨摩诃萨天人杂类。出大音声唱如是言。奇哉纯陀成大福德。能令如来受取最后无上供养。而我等辈无福所致。所设供具则为唐捐。尔时世尊欲令一切众望满足。于自身上一一毛孔。化无量佛一一诸佛。各有无量诸比丘僧。是诸世尊及无量众。悉皆现身受其供养。释迦牟尼如来自受纯陀所奉设供者。尔时纯陀所持粳粮成熟之食。摩伽陀国满足八斛。以佛神力悉皆充足一切大会。尔时纯陀见是事已心生欢喜。踊跃无量一切大众亦复如是。释曰。彼经虽言无量化物。但云受大众供。无此重重等众生数尽未来际。此但约文以明优劣。非当时化不能普周。亦以彼证无尽化现皆涅槃用

疏。第九至体离二边。亦即彼超境中意。彼中有名。先征出云。请核妙道之本为有为无。果若有也虽妙非无。虽妙非无故则入有境。果若无也无则无差。无而无差则入无境。总而括之即而究之。无有异有而非无。无有异无而非有者明矣。而曰有无之外别有妙道。非有非无谓之涅槃。吾闻其语矣。未即于心也。第五超境答云。然则有无虽殊俱未免于有也。此乃言像之所以形。是非之所以生。岂足以统夫幽极。而拟夫神道者乎。是以论称出有无者。良以有无之数止乎六境之内。六境之内非涅槃之宅也。故借出以祛之。庶悕玄之流。仿佛幽途托情绝域得意亡言。体其非有非无耳。岂曰有无之外别有一有而可称哉。今但云体离二边。非唯离有离无。若实若虚若处非处等皆二边也。于中先反释。身是体故先明。后由非实故下顺释

疏。第十至结归无住结上九门。皆归无住涅槃。于中二。先释经文。后结归无住。今初即是结前之义。言谁独非涅槃而欲舍之耶者。即侧用玄得中文。彼以第九考得难云。经云众生之性极于五阴之内。又云。得涅槃者五阴都尽。譬犹灯灭等下结意云。若有可得涅槃。五阴不都尽。阴若都尽谁得涅槃。故玄得答云。且谈论之作必先定其本。既论涅槃故不可离涅槃而语涅槃也。若即涅槃以兴言。谁独非涅槃而欲得之耶。意云。众生即涅槃故。更不可得下。引净名众生即涅槃相。此明一体故无可得。今言一体故无可舍。众生即涅槃。若舍众生即舍涅槃也

疏。是则初住实际下二结归无住。于中四。初正归无住。无住涅槃前已具引。二由双住下出无住所以。经中是住。今乃结归无住者。由若不住实际安能不住生死。若不安住大悲安能不住涅槃。然则亦由俱不住故。而能俱住。今此顺文经是俱住。结归无住故但用住。以成无住。三前即大智下别举成无住因。即唯识文。四自性涅槃众生等有下释归无住之意。涅槃有四。何以但归无住。无住涅槃唯佛得故。皆是论文具如上引。即安住下是涅槃经

疏。初句无生之生者。如无生性无生也。佛出兴之生也。下句例知。后句一切义成故为大用。上三句是体第四句是用。故云余不颂者含在此中者。不出体用故。第十出现见闻。疏。不出智断恩者。初三句标三德果。初句智德般若满故。次句即断德解脱满故。次句恩德法身究竟故。次二句总成上三。三俱愿满皆不虚故。后六句复释上三。初三句释上无尽觉慧。不尽有为此成事智。随顺无为此生理智。此二因圆。生诸佛智即是果满。次二句释上究竟大悲恩德尽未来故。种智行成得法身故。后一句释上断德。得至佛地无障可断故。解脱功用故。故上出现意。业中云。得如来地息一切用

疏。宝性论亦明如来为菩萨六根境界。论有四卷。此当第一。是成就自利利他偈云。诸佛如来身如虚空无相。为诸胜智者作六根境界。示现微妙色出于妙音声。令嗅佛戒香。与佛妙法味使觉三昧触令知深妙法

疏。亦同法华乃至举一手。即第一经前已引竟

疏。如来秘密藏经明骂药等者。具云大方广如来秘密藏经。此即下卷。大迦叶问。唯愿说是如来秘密藏法佛言迦叶于汝意云何。汝谓我行菩萨道时所舍手足头目耳鼻皮肉骨髓血及妻子略说。乃至一切财物处处逼恼于菩萨者。是诸众生不堕地狱畜生饿鬼及诸恶趣。何以故。本行菩萨行时志意净故。及大誓愿净戒聚故。于诸众生大悲纯至及坚忍故。以大慈故大功德法故。牢强精进向大乘故。息心净故。大愿饶益故。不喜自乐故。其有众生触娆菩萨毁骂之者。菩萨德故不堕恶道。迦叶我今引喻以明斯义。迦叶犹如病人。良医授乐而是病人故骂是药及与良医。先毁骂已然后乃服此药。迦叶于意云何。药以骂故不为药耶病不除耶。不也世尊。虽复毁骂药不失势而能除病。如是迦叶。菩萨如药及彼良医不生恭敬如种种触恼。然是菩萨纯净志意无有缺减。又举大宝珠有大势力有人毁骂不失宝力。又骂明灯烧之亦能除闇。言骂沈者义引。彼云。骂赤栴檀以手槌打连燎弃之。为作何香。迦叶答言。作栴檀香。又云。如人抱执粪秽弃之。以华香供养。是人有何等气。答有秽气。佛言供养外道。但有见畏地狱畜生饿鬼等畏耳

疏。涅槃喻以毒涂之鼓者。即第九经如来性品。南经亦第九即菩萨品文云。譬如有人以杂毒药用涂大鼓。于众人中击令发声。虽无心欲闻闻之皆死。唯除一人不横死者。不横死者即一阐提人。释曰。彼经犹拣阐提。此意取不欲闻。以喻不信而得益耳。法华不轻可知。菩萨之名起自闻谤之日者。亦即此卷答云。云何未发心而名为菩萨。如日光明诸明中大。大涅槃光能入众生诸毛孔。故众生虽无菩提之心。而能为作菩提因缘。迦叶问言。云何未发心而作菩提因缘。次如来举梦中见罗刹喻。初闻不信梦中罗刹令其发心。云汝若不发菩提心者。当断汝命。寤已发心。或于三涂续复忆念发菩提心。即大菩萨也。生公云。菩萨之名起自闻谤之日。疏岂言象之能及。即周易略例中意。言者所以存象得象而忘言。象者所以在意得意而忘象。第二会已引。疏则庶几出现之旨者。庶几即周易系辞云。颜氏之子其殆庶几。有不善未尝不知。知而未尝复行。彼释云。殆者近也。庶者众也。几者事动之微也。谓圣人见几贤人庶几。今令效学亚夫圣贤也

疏。法集经云等者。经有六卷。即第六卷末云。善男子是法门多行于婆伽罗龙王世界。多行于帝释住处。多行于阿那婆达多龙王处。然后行阎浮提中。常于诸佛所护众生中行。于直心不谄曲众生中行。于能信深法者。常在如是众生心手中行。疏般若论云法欲灭时者。即金刚般若无著论上卷。释经须菩提白佛言。世尊颇有众生得闻如是言说章句生实信不。佛告须菩提莫作是说。如来灭后后五百岁。有持戒修福者。于此章句能生信心。以此为实。当知是人不于一佛二佛三四五佛而种善根。已于无量千万佛所种诸善根。论云。为欲得言说法身住处故。经云正法欲灭时者。谓修行渐灭时应知

疏。若约教道三祇亦未入玄者。即古十玄意。然历三祇设未究竟。亦已入位。何以得言未入玄耶。是故上云若约教道。施设三祇教既未真。则成佛义亦非真也。教不实故。若约正道三祇修行。必已克证。修权既深则入实也

疏。无性摄论等者。即第六论。若世亲释云。由此能令诸佛种性不断绝故

疏。十住毗婆沙等者。即此第二。释初地常生如来家文云。初地心生必能常集诸善根不休息。故名为常生如来家。如来家者即是佛家。下广释如来义意。以涅槃实相四谛三空等皆名为如。智慧到彼故名为来。结云。如来者所谓十方三世诸佛。是诸佛家名如来家。今是菩萨。行如来道相续不断。名为生如来家。释曰。具如来道即佛行也

    离世间品第三十八

疏。约处名三会普光明殿之会等者。疏文有二。先正释。后解妨。前中亦二。先标。后第七重会下释意明。第七已曾重会。故今名三会。而便明七八俱会普光而有差别

疏。而前分生解差别下。解妨文有二妨。一伏二显初有伏难即重会不同妨。谓有问言。一种重会何以前历多会。此唯一会。答有二意。一前约解故须多。今约行故须一。以顿起故。二前约行布故历位不同。今约圆融故一会顿起。在文可思

疏。此中不隔余处。何有重会之义。即第二显难重会不成妨。先难。后若约次第下答。答有二意。一约行布不坏相边。约时明重。如人前于此讲。续前再讲岂非重耶。二若约圆融下就圆融门。约义明重于中有三。初标。二故不动前二下反难以成。三以喻别显。二中谓汝向问意云。第二至第七中隔四会故得名重。第七第八中无有隔何得名重。今谓第二望七亦不隔越。何者既不起觉树而升四天。四天觉树定是一时。第六他化天后即说第七。曾何隔越。则二七不隔亦得名重。今七八不隔何不名重。明知约义者结成。七八重会皆是约义而言不动前二者。文中虽云不起觉树以普光近觉树故不别言之。实则不起前二顿升四天也。疏。亦犹灯光下。第三以喻明也。光虽涉入随灯有异。时处虽一约义不同。以约圆融一时顿演故为此通。亦似灯炷下。复以喻显。前喻灯异光重。此则灯一光异。灯一喻于二处。光重喻三会不同。答难二千经者。准度世品。普智菩萨白佛言。世尊诸来菩萨达者。无碍中下之士各怀犹豫各心念言。事物繁闹不知何事可舍可奉。愿佛分解。佛叹善哉当为汝说。佛言普智用有二故。故问二百答以二千。问二百者。有神贪身计有吾我。有内有外在有在无所可咨问。皆除吾我内外有无。则有权慧开化无际。答二千者。十方一切皆来集会。其心各异意行不同。达者闻要则以至道。不能达者为演多辞。晓谕文说牵攀义旨。自所睹形以喻其意。乃得解慧。此经乃在迩字函中。文只六卷长行文毕后有二百三十二颂义甚富赡。二得名中世间性空。即是出世者即净名不二法门。前来已引即那罗延菩萨。二明事下引十行偈义则可知。度世品云品名度者。一切众生闭在世间。五阴六衰之所覆盖。缠绵生死不能自拔。以权方便智度无极。消去五阴捐弃六衰。不计吾我。不在生死不住灭度。譬如日月昼夜演光。权慧如是。忽然无迹德如虚空

疏。经云佛常在世者。即法身经下半云。不分别世间敬礼无所观

疏。然今文中等者。就别得名中二。一上别显三义。二次下会释经文。明具三义。若事若理下即是总结。然若事即前事离。若理即前性离。此正约法因果即兼结前行位也。然此释名疏文妙矣。易则易焉。故不委释

疏。二中明佛二十一种下。既指前释有疑当寻。彼疏钞不繁重举

疏。前则多人具德等者。以举多数次即叹故。后列普贤诸上善人而叹德故

疏。余九如次前已配释者。如前云一契理愿圆。即是释德。普眼满故。即是属人。二摄法上首即是显德。言为普化故者。即普化菩萨。三受持正法即是显德。有普慧故即是菩萨等

疏。佛华严者。万行披敷严法身故者。释佛华严三昧。华者菩萨万行也。以因能感果故。言如华严者。行成果满契合相应。垢障外消证理圆洁随用赞德故称严也。三昧者。理智无二交彻镕融。此彼俱亡能所斯绝故。亦可华即是严理智无碍故。华严即三昧以行融离见故。华即是严。一行顿修一切行故。华严三昧一行即多而不碍一故。华严即三昧以定乱双融故三昧即华严理智如如故。晋经云。一切自在难思议。华严三昧势力故。此即据行为言。名华严三昧如贤首品。疏前皆有加下。上略释文。此下对前料拣。然有二意。前意自他对说。后意亦通伏难。难云。前释入定云为受佛加故。今无佛加何须入定。故为此通。结云多端不可例难

疏。以无碍用一句是总标虚句者。次下别问众生无碍用等十问。下文各以十句答之。其无碍用句即用众生无碍用等十句释之。明是虚句

疏。此经总三遍说六位者。上直科释。今出为六所以。于中五。一正明。言三遍说者。一差别因果。是第一遍下法界品寄位修行为第三遍故。此为第二。既云此约行说。则知前约解说后约证说也。二故度世下引证。证其二义。一证约行云诸菩萨行。二证六位。云从始至终。三彼经虽不下遮伏难。恐有难云。既云始终何必即配信等。故为此通。四此经所以下会今经。亦是通妨。妨云。彼中别别问答。纵许配位此中通问。何得例彼故为此通。五此经上下及本业下会异释。即破刊定。于中二。先叙彼问。后为会释。今初即刊定问。然其问意不问十信。从十住问亦为六段。谓前四三贤十圣后二即等妙二觉。则今六段尽皆不同。谓以信为住以住为行。以行为向以向为地。以地为等觉。以因圆果满为妙觉。此判既乖。今苑公于此一品经不解一句。以判六段尽皆错故

疏。此有深意下疏为会释。即答其问也。于中五。一总明为行故。初有十信。二等觉之位下释不开等觉所以。虽举三义而取第三别开。但摄在第六因圆之中。三若尔此中依言下。即出刊定救义。欲令初是问十住故。四此难尤非下。今疏破其所引之文不得文意。五不究斯旨下结弹。援者引也。引文不当义旨全乖故。上判其不解一句。以信为住明不解信亦不解住。以住为行明不解行。亦不解住等。故一品经不解一句。疏英云云兴二百问等者。彼有九会礼赞。第八会云法门当再席。法雨更滂流悬河二百问。瓶写二千酬一心穷性海万行炳齐修。五位因成满八相果圆周。今略举二句。复改其悬河字。作云兴字耳

疏。普贤位行示成佛故。通向四门是果之义

疏。若尔此则普别具足者。上正释普别。此下通妨。后非谓守普下解释。释有二意。一别不失普故名普贤。不名别贤。二又普必有别下。明别不必普普能摄别故名普贤。如一缕下出别无普。以锦外之缕故不必普则有缕未必有锦有锦必有其缕。兼成前义别不失普。是普中别故

疏。此乃等无极下结叹

疏。今初一门一类下文中有四。初总标。二首明依下辨初门来意。三然二百门下总科诸段。四今此依中下正释经文。疏忘失菩提心下。即五十八经

疏。一毫之善等者。回向已释。文殊云我不见一法下。即大般若曼殊室利分前亦已引。疏。涅槃云外道之法等者。初卷宗中已引文意

疏。三入益中谓谤有二义等者。以得证实方无细谤。即是益也

疏。非显受记相殊如瑜伽等者。如下五十五经不坏回向中十种受记中说。瑜伽即当菩萨地。由六相故佛为授记。一安住种性未发心位。二已发心位。三现前住。四不现前住。五有定时限。谓尔所时证菩提。六无定时限。谓不说时限与授记。又善戒经非种性人亦得授记。如不轻授四众记。种性如十信得记。疏又此约十信下结成上义。则得授记。瑜伽竖说授记相殊。疏第六说三世者。疏文有二。先释总名。后十中下别释。释中疏文有二。一略消经文。以文三世之中有不同故。二然此三世下释十世义。中四一征起。二古人下叙昔。三若依下辨违。四今谓下申正义。于中有三释。一具约九世缘起相由。释昔设用九日而为九世于理无违。二但以三世下。以三世缘起相由释。三唯就一念释。二中先明九世。后成十世。前中初正明。二引证。三释妨。今初正明也。是中论破时品意。谓小乘立有实时。菩萨以相待门破之。若因过去时有未来现在。未来现在时应名为过去。若过去时中无未来现在。未来现在时云何因过去。释曰。此中论意以过去为因。现未为果。果由因有故无二时。前偈纵成则果应名因。亦因中有果后偈夺其因。既不名为果则果不从于因。亦应以现在为因。过未为果未来为因。过现为果但长行例耳。今疏具明。而以一为果。以二为因。初以过去为果现未为因。过去果中应有因起故。下引证云。若法所因是出。法不异因则果不异因。是果中有因也。次现未下例释二世为果。亦各用二世为因。谓现在果因于过未。未来之果因过现也。从是以三世各有三者总结。疏中观云下二引证。即是第二论观合品具云。异因异有异。异离异无异。若法所因出是法不异因。十通品已引。此中但取果不异因之一义耳。如因梁椽以成于舍。梁椽若坏则舍立坏。果不异因故。若果不异因则过去为果则应名现未。现未即是过去因故

疏。中论破执下第三解妨。妨云。此是中论破时。则果中有因。因中有果皆成杂乱。既不相有明无定时。今何将过以为其德。故有此通。遣执成德二义悬差。若执三时有定性者。尚不能见无性之理。安知一中即具三耶。今由无性方互相由成无尽耳。疏以病成下结赞其能。疏总云下释成十世可知

疏。即此一念下成其九十。先成九世。此一念上虽因前后。而其三世全在一中。一中之三更互相因。故为九世。本之一念故为十耳

疏。故以一下以一对九互融相成。结成上义。九约于义。一约实体体用相融故。常九常一无有障碍。体用相夺离九一相故同果海

疏。假十下总收前正义亦是释疑。疑云。既以绝言而为果海何要十耶。故今释云。假之为门则是说大。同果绝言即义大也。上即圆教之义。二况积念下即始教义。三又无念等故即顿教义。四又法性同故即终教义。故结云有四后三通余宗者。谓法相无相大乘等宗也。上取同义。若取别义第四法性同故即理性融通之门乃圆教义。故云后三通于余宗。非全同余宗。则显二三亦是此宗同教一乘。若作法性融通释者。然此九世时无别体。唯依缘起。缘起无性即真法性理融通故。今时融通无碍自在。略有四重。一相泯俱尽。二相与两存。三相随互摄。四相是互即。初中以本从末唯事而无理。以末从本唯理而无事。二中全事之理非事故。一相无时全理之事非理故九世不乱。三中由随事之理故。令一时能容一切时。由随理之事故。令一切时随理入一时中。多一反上互入可知。四中由即理之事故。令一时即一切时。由即事之理故令一切时即一时。唯理无物可相即入。唯事相碍不可即入。要以事理相从无碍。方有即入思之可见

疏。一示成正觉故即前菩提身者。但唐梵之异

疏。了本性故者。非约所了所了即法界故。然佛下会释二门。总名广如别章。即华严章门中亦义分齐内疏大文第二发普贤心下。疏文有六。一标章。二古德下叙昔。三非不有理下纵成。四今取下正释五。若依圆融下通妨。妨云。既没位名意存大行何须别配。故今释云。行既有二意取圆融即没于位。约于行布不妨次第。若无次第何所圆融。六初四门下正依位科。下文解释。若有疑者但观前经自当晓了

疏。今初总发名普贤心等者。列中文三。初约三心菩提以释。二又前七下约二护释。三又初三下约四弘释

疏。亦即是前胜进行等者。但举其二等于余八。十者。谓一勤供养佛。二乐住生死。三主导世间令除恶业。四以胜妙法常行教诲。五叹无上法。六学佛功德。七生诸佛前恒蒙摄授。八方便演说寂静三昧。九赞叹远离生死轮回。十为苦众生作归依处是也

疏。文相多同恐繁不会。今当为会。一即第二。二即第一。其三四五六如其次第。七即第九。八即第七。九即第八。十成大菩提方堪为苦众生依故。其间小有异处会意皆同尔

疏。此与前自分行中发心因缘互有影略者。彼经中十。一见佛世尊形貌端严。二色相圆满。三人所乐见。四难可值遇。五有大威力。六或见神足。七或闻记别。八或听教诫。九或见诸众生受诸剧苦。十或闻如来广大佛法。发菩提心求一切智。今言影略者。前五下化众生即前第九。或见众生受诸剧苦即正当第二。则彼略此广。彼一义含此五此影取也。后五上求佛道。第六第八即摄彼前六。则此略彼广。第七即前七八记别教诫九十即彼第十广大佛法。故云影略

疏。后之五句即彼此互阙者。彼五即摄受守护同己师心导师心彼阙此五可知。疏此门即胜进中近善知识者。彼具十句。云所谓诵习多闻虚闲寂静近善知识。发言和悦语必知时。心无怯怖了达于义。如法修行远离愚迷安住不动。释曰。后之四句在后清净之中。今言近善知识。即彼第三。第三是总。下四五六句皆是发心之德。即此中别意。其彼初二句文中略无。疏梵云波利戍提者。戍字率音。戍提者此云清净。波利是遍是极

疏。彼开一慧为十观察者。经云。此菩萨以十种行观一切法。何等为十。所谓观一切法无常。二苦三空四无我五无作六无味七不如名八无处所九离分别十无坚实。皆如初句有一切法

疏。即前胜进十法观察众生界等者。彼经云。所谓观察众生界世界。观察地界水界。观察欲界色界无色界。影略可知

疏。四证知一门明生贵住等者。彼自分行云。此菩萨于圣教中生成就十法。何等为十。所谓永不退转。于诸佛所深生净信善观察法。了知众生国土世界业行果报生死涅槃是为十。疏会异同可知

疏。但云所修诸行皆为众生者。略义而已。具云皆为救护一切众生。二饶益三安乐四哀愍五度脱。此上皆同初句。有一切众生之言。六令一切众生离诸灾难。七出生死苦。八发生净信。九悉得调伏。十咸证涅槃。后五先明令一切众生。疏。兼其胜进解众生等者。彼经云。菩萨应劝学十法何等为十。所谓知众生无边。二无量。三无数。四不思议。五无量色。六不可量。七空八无所作。九无所有。十无自性。皆如初句有知众生言

疏。故闻赞毁心定不动者。彼云。此菩萨闻十种法心定不动。何等为十。所谓闻赞佛毁佛。于佛法中心定不动。二法三菩萨四所行。五闻众生有量无量。六众生有垢无垢。七众生易度难度。八法界有量无量。九法界或有或无。十法界有成有坏。皆如初句

疏。即彼胜进中行等者。彼云。菩萨应劝学十法。何等为十。所谓一切法无相。二无体三不可修四无所有五无真实六空七无性八如幻九如梦十无分别。皆如初句有一切法言。前却可思

疏。闻说心不退转者。大同前位亦有十句。一闻有佛无佛于佛法中心不退转。二有法无法。三有菩萨无菩萨。四有菩萨行无菩萨行。五菩萨修行出离修行不出离。六过去有佛过去无佛。七未来。八现在同过去。九闻佛智有尽无尽。十闻三世一相三世非一相。皆如初句。疏。涅槃二十八中广明不退相者。中有文云。有六种法坏菩提心。何者为六。一者吝法。二者于诸众生起不善心。三者亲近恶友。四者不勤精进。五者自大憍慢。六者营务世业。释曰。无此六事则不退也

疏。此门即自分行由三业无失故有无著等者。彼具云。所谓身行无失语行无失意行无失。随意受生知众生种种欲。知众生种种解知众生种种界。知众生种种业知世界成坏。神足自在所行无碍是为十。今疏配用可知

疏。后门即彼胜进现变化等者。彼云。彼菩萨应劝学十法。所谓知一切佛刹。二动三持四观五诣六游。上皆有一切佛刹言。七游行无数世界。八领受无数佛法。九现变化自在身出广大遍满音。十一刹那中奉事供养无数诸佛。今疏举一以等于余

疏。故能善知十法者。彼经云。此菩萨善知十种法。所谓善知诸众生受生。二诸烦恼现起。三习气相续。四所行方便。五无量法。六诸威仪。七世界差别。八前际后际事。九演说世谛。十演说第一义谛。句句皆有善知之言

疏。后门胜进学法王处等者。彼云。佛子菩萨应劝学十法。何等为十。所谓法王处善巧。二轨度三宫殿四趣入五观察六灌顶七力持八无畏九宴寝十赞叹。十门皆如初句。后五略无处字

疏。此门明成就十智等者。彼胜进云。此菩萨应劝学诸佛十种智。何等为十。所谓三世智佛法智法界无碍智法界无边智。充满一切世界智。普照一切世界智。知一切众生智。知一切法智。知无边诸佛智是也

疏。后十变化故能动刹等者。即彼经自分十法云。此菩萨得成就十种智。何等为十。所谓振动无数世界。二照明三住持四往诣五严净。上五皆有无数世界言。六开示无数众生。七观察无数众生。八知无数众生根。九令无数众生趣入。十令无数众生调伏

疏。然此变化即实如化非要化作者。谓缘生如化故。若变化作无而忽有故。佛地论第三云。化身三种。一自身相应化。谓自身作轮王等。二他身相应化。谓变化王为佛身等。三非身相应化。化大地为宝等今并非此

大方广佛华严经随疏演义钞卷第八十一大方广佛华严经随疏演义钞卷第八十二

        唐清凉山大华严寺沙门澄观述

大文第三十行

疏。十中初三三宝持下疏文有四。一取论意释。二然第十地下会论同异。三既数名下会论同释。四上辨陀罗下会三处持字可知(五十四经)疏夫说法下即净名目连章中。时目连于里巷中。为诸居士说法时。维摩诘来谓我言。唯大目连为白衣居士说法。不当如仁者所说。所以者何。夫说法者。当如法说法无众生离众生垢故。法无有我离我垢故等。说法既权实下义取净名之意

疏。非但依戒者。阿难四问佛令依戒为师。彼以戒为饶益。即是依止之义

疏。岂畏众生相恼害耶者。以无违逆行多约耐怨害忍故

疏。八中十句五对者。疏文有二。先标所依法相。而有二意。后然各有二意下双释上二。言各二意者十句五对。各具上二也。下依二意释之。先直就法体但约二谛以明。即释前约境心等五。后二约迷悟下即释上约五法明通。就迷悟以释。上即约境不出二谛。今此约心不出迷悟。悟即正智迷即妄想。由此二故说成五法。五法即分为五。一约相上以如对之。故无相是如。二就妄想上以正智对之。三就如如之上。唯就如如得失以明。四就正智上亦约正智得失以明。五就名上亦唯就名得失以明。五中皆通迷悟。然迷即有名相妄想。悟则唯正智如如。智契于如一味平等。余如前后说

疏。九中初融三事心佛众生三无差故。后离融相故释不融。然不融中有二。一不坏相。二离融相。离融相约理无可融故。约心无想念故。不坏相约本自融不可融故。从三事下指文引证

疏。仙陀四实。谓盐水器马前已广释。九义瞿声。即俱舍论云方兽地光。言金刚眼天水。于斯九种事智者立瞿声。唯金刚二字一义余八各一

疏。如寒得火等即涅槃经

疏。五以异言说异法者。即摄论第四秘密中第四转变秘密。论云。复有四种意趣四种秘密。一切佛语应须决了。四意趣义已见普贤三昧品。四秘密者。一令入秘密。谓三乘中依俗谛理说有人法。令入俗谛。二相秘密。谓说法相三自性等。三对治秘密。治八万四千烦恼。四转变秘密。欲令悟入总名秘密。论释第四转变秘密云。谓于是处以其别义。诸言诸字即显别义。如有颂云。觉不坚为坚善住于颠倒。极烦恼所恼得最上菩提。无性释云。谓于义转变差别。杂集云。谓说无余义名句文身隐密转变更显余义。无性释上偈云。谓刚强流散说名为坚。此非坚固。说名不坚。即是调柔无散乱定。即于此中起坚固慧。觉彼为坚。世亲释云。不坚谓定。由不刚强驰散难伏故名不坚。于此中起尊重觉詺觉为坚。释曰。彼二家释论言异意同。皆能密说顺得菩提。若取显了于散乱心起坚固慧。则远菩提。今取秘密于定不坚起坚固慧。则得菩提。言善住于颠倒者。无性释云。谓于四颠倒善能安住。知是颠倒决定无动。释曰。若取显了则住于无常计常等四倒之中。不得菩提。今则秘密知于常等于无常等上横计。而起决定知此名为善住。住于颠倒能得菩提也。世亲释云。是于颠倒中善安住义。谓于无常等是能颠倒。释曰。此则到彼所计义名善颠倒。于此安住故得菩提。言极烦恼所恼者。无性释云。为众生故长时劬劳精进所恼。亦引上偈云。一同无性二释无别。释云。若取显说为贪嗔等恼乱行者名烦恼。此即远离菩提。今取秘密精进勤苦劬劳行者。亦名烦恼则得菩提。其第四句得最上菩提。该上二义。庄严论第八对法第十二。皆同此说

疏。亦犹小乘十遍处者。大乘亦有广略不同。今顺定十故引小乘。至法界品当广分别

疏。亦犹依禅成八解脱者。亦如法界品

疏。念想观除者。即智论文。文云。般若波罗密实法不颠倒。念想观已除言语法。亦灭无量众罪除。清净心常一。如是尊妙人则能见般若是也。念想观除约于内智。则不受外境。见色如盲等而言善巧者。非涉事善巧不念不受是入理善巧耳

疏。初有八句别知缘相者。十二因缘相。二知迷下十二句知染净者。即双知性相迷悟染净犹是约相。广如六地。第一义中二俱叵得。即约性说。三知住下明知心行者。即能知性相观照之心。此中可以寂照虚怀而了。亦为明示心观处也

疏。亦犹三法印等等取四印五印。并如明法品说(五十六经)疏。如善治船不惧海难。即大品经意。第七地已引

疏。涅槃春池可于中说者。然此经喻乃有二意。一约教说。二约理说。今引涅槃乃是约教。即第二名春池喻。经云。譬如春时有诸人等在大池浴。乘船游戏失琉璃宝没深水中。是时诸人悉共入水求觅是宝。竞捉瓦石草木砂砾。各各自谓得琉璃宝。欢喜持出乃知非真。是时宝珠犹在水中。以珠力故水皆澄清。于是大众乃见宝珠故在水下。犹如仰观虚空月形。是时众中有一智人。以方便力安徐入水即得宝珠。远公释云。此即对前比丘叹昔所解无常苦空无我。真法教其甄拣。于中先喻。后约喻教劝喻中有三。一求真取伪喻。二欢喜持出下知伪非真喻。三是时宝珠犹在水下舍伪取真喻。上方喻意下约喻教劝比丘。文别有四。一约初喻呵其取伪。经云。汝等比丘不应如是修集无常苦无我想不净想等。以为实义。如彼诸人各以瓦石草木砂砾而为宝珠。二约第三喻教其取真。经云。汝等应当善学方便。在在处处常修我想常乐净想。三约第二喻劝知昔伪。经云。复应当知先所修集。四法相貌悉是颠倒。四重约第三喻劝修令真。经云。欲得真实修诸想者。如彼智人巧出宝珠。谓我想常乐净想。关中释云。譬如春时有诸人等在大池浴者。全为设譬使知昔非而学今得。是为用也。春既可乐又开浴之端而大池清旷濯之。甚宜除垢合时。寔唯昔说无常想者。沐浴来集如林集听本为涤累。以譬在大池浴。今喻不称故云有诸人等。经言乘船游戏者。既听致惑遂有失言。言迹似漫。义曰浮虚而在言先则应前过听者。乘以为实。是泛舟之像。离内之外无有实功为游戏也。经失琉璃宝没深水中者。常与无常理本不偏。言兼可珍。而必是应获由乘漫乖之为失宝也。乖则永隐为深没矣。经是时诸人悉共入水求觅是宝者。听本应取言旨。以从失成求。岂曰知之理数然耳。求必就说为人入水矣。经竞捉瓦石至乃知非真。言旨虽俱以乖为隐。然一本显譬浮。一本密譬沈而取互其实非宝。为草木瓦石之沉浮也。皆谓得真莫不欢喜持出。于伊字之譬及佛判非。明外乃知非也。经是时宝珠至水皆澄清。于取不得为故在水中。于知非为义真旨始现乎语。旨现不复浑迹则是珠力使澄清矣。经于是大众至虚空月形者。既自知谬方见语旨。犹在言下明显如月。无复有暗而理可仰故。如仰观虚空中月也。经是时众中至即便得珠。如说修行为安徐入水。要在修习我常四法而不废替方便之义。先修于常后知无常。如是得成在我岂非智哉。经不应修习无常等想乃至而为宝珠者合也。譬中已悉故略合耳。昔修都非而以为是似彼痴人也。经汝等应当善学方便在在处处常修我想常乐净想者。处处常修此四法者。必以得之为方便也。经复应当知先所修习四法相貌悉是颠倒者。知是则知非。知非则知是。对观然后无惑矣。经欲得真实修诸想者。如彼智人巧出宝珠。所谓我想常乐净想者。要常修得我常乐净。然后都得真实如彼智人也。上生公释远师大同。而不委此此上约权实教旨故引涅槃。若直就经宜用心观约理以说。经中初法次喻。后合。以一切智清净妙法而为宝者具三德故。明为般若净即解脱妙为法身。即体之智曰明。即照之寂为净。斯二不二为法身体妙之至也。凡夫如泥二乘有浅智如潦。光色不改不坏自心令浊水清。即是利他。远见烦恼。异于凡夫。求一切智异于二乘故非凡夫行。非贤圣行是菩萨行也(五十七经)

疏。初一明清净对治等彼有四分。今具其三。但略无果果非正地故。然诸门一一皆与彼本分相应。有不晓者寻前自了

疏。今初前三地下疏文有四。初明以此门释四地所以。二谓离有为下释总名。三地经有十下会通彼经。四结云下拣大异小耳。然此中离生有二。一离却生。二离生涩出生亦二。一从无之有曰生。二生长名生余可思。疏瑜伽四十六明菩萨随德假名者。彼论云。一切菩萨当知。复有如是等类无有差别随德假名。所谓名为菩提萨埵摩诃萨埵。成就觉慧最上照明最胜真子最胜住持普能降伏最胜萌芽。亦名勇健。亦名最圣。亦名商主。亦名大名称。亦名怜愍。亦名大福。亦名自在。亦名法师。如是十方无边无际。诸世界中无边。菩萨当知乃至内德各别无量无边假立相号。释曰下引二论与此全同。一二小异义无以别

疏。又商主天子经有五义者。一于菩提分住持入故。故名菩提萨埵。二入大乘故。满大乘智故。故名摩诃萨埵。三不可求法智德入故。故名最胜萨埵。四不与烦恼共住为诸众生灭烦恼故。发精进故。故名净萨埵。五令诸众生行净道故。故名极净萨埵

疏。言义唯实教者。总生下六段。四以回向无休为实。五以定知三昧出入为实。六通天眼但见三千等。三明十力方见过未今。见死此生彼便同力义。非是实教无此义耳。七以加悲念众生为实。又云亦是广七觉中一念觉者。地经约道品等明治。今五根八正即是道品。此广念觉。兼有七觉则与前文影略明耳。八正中以顺一切智异于二乘为实。九定权实双行为实。如初禅离欲恚害是实。而能逆化是涉权故异权小之九定也。下并可思。对前三地九次第定。则知此中权实双行。以实教定故。下指前文

疏。四门同显道义下出经总标。所以约义须分下出疏。别配所以四中前二是五地修道为六地。庄严道是七地。故云约义须分后二属后。恐是译人一时标耳

疏。十中前四各一无量者。会五无量界也

疏。二无量助道下疏文有四。一显同前文。然彼有三分。一胜慢对治。二不住道行胜。三彼果胜上十平等是治他地慢。随如道即治自地慢。俱是第一分。今此即二三两分。二以智契如下释成不住道义。便仍前释正道。三今以圆融下通难释成难云。今是助道岂是不住道行胜等中行耶。故答云。俱为正道并为助道。则助道中有正道故。得合为不住道耳。四然正道不随事转下复有问言。既俱互通那得经中分成二名。故答云。虽则互通而文之中密已拣异。则显文中密已同用空等。显互通义。随事不隐显二别义

疏。第六无量修道下文四。一显修道是六地所由。二无去来下显其同相。上显义同此显文同。三十中前四下别科配属。四四中下随文别释。于中有二。先释十平等言云。彼从别义开成前八者。一无相故。二无体。三无生。四无成。五本来清净。六无戏论。七无取舍。八寂静故。平等言今总明之。下略有三义。一不起心者约定故。经释云无动作故。二称本性约观智了本性心境冥故。故经释云如本性故。三遣修相者。即上二修亦不立故。释云无自性故

疏。亦可配三性等者。如初来去即遍计所执性。以不不之即相无自性性下。二以依他圆成。对生无自性性胜义无自性性。可以意得

疏。四举七喻通显无著者。七喻全同彼文。论释云。此明遣我非有相而有二释。一者前七句以无破有。七喻以有遣无。令不着无故。二者例同于前。亦以无遣有故云我非有相。幻梦影像不坏虚相取不可得

疏。今别明五藏者。谓脾肾心肺肝也。上总举一腹所有。此唯此五藏下唯一心约事即然。约法皆十融无尽故

疏。初明十眼等者。疏文有五。一指前经文释成眼义。如实知见为眼义故。二十中下随文会释。三出体。四明次第。五余如别章示。原然诸教章门多分为七门。一释名得名。二辨体。三修成次第。四类差别。五见境不同。六约人辨异。七问答分别。今但义合五段之中。初一义当释名。照瞩名眼故。别名随释中辨。二随文会释中。对余五眼辨开合同异。于中先释前五。但明业用同异。后五即开合同异。前中先总明同异。后别释即分为五。一肉眼中然明见不见。略有五义。一见粗不见细。二见近不见远。三见明不见暗。四见前不见后。五见障内不见障外。斯即亦是见境不同故

疏。释及引论影出其三而言等者。等取粗细明暗。言天眼方见远等。等取余四。此乃成不见远等非释天眼。今肉眼下举此显胜。四十四下引彼指此。其应字合言说字。此中不说者。即智论指摩诃般若为此中

疏。然天眼下二释天眼中。先序五眼。言假和合者。即是出体以肉天二眼皆是清净四大。不可见。有对色为体。但人天趣别耳。言不见实相者。即是所见境但翻前见近不见远等。则前五不见。天眼皆见而不见实相。实相是慧眼境故。从今明见心下显此十眼。言似同彼者。心若约相非实相故。今具性相故亦不同

疏。此中慧眼下三释慧眼。言似法眼者约所见境异。以彼法眼见事及根欲等。今见众生诸根境异故同彼法。此中法眼似彼慧眼者。彼中慧眼见理境故。即如实相也。从所以互下出不同之由。以慧眼但见理故。不见尽灭一异。今举彼不见故云过彼。则显慧眼亦能见。理但同者不举耳

疏。此中法眼下四释法眼。亦举彼不能显此之能。则一切法如实相言通事实理实。若尔云何分于法慧。然法慧二眼俱以慧数为体。五眼中明自有二义。一慧眼以正体智为体。法眼以后得智为性。二云。法眼从所知法为名。所知亦通于理。慧眼从能知智为名。今正取后义则显慧眼亦通二慧

疏。彼佛眼下五释佛眼。先举他宗亦约所知境。后今举下会释今文。而有二意。一直案文则十力狭于一切法也。故云举胜。下又云十力下别显同。彼不出十力之所知。故显唯属佛拣异法慧。故举十力耳。然彼释名有三义。一云。四眼在佛皆名佛眼。此即佛身之眼从主为名。二云。佛者觉义觉即是眼当体为名。三亦可照达佛性名为佛眼者。涅槃云。若人能见身中佛性。虽是肉眼即名佛眼故。以十力当体照达名为眼耳。彼出体云。佛眼即以无功用智为性。或以圆镜等四智为体。皆十力义耳

疏。后五中下释后五眼。言义兼法慧者。根本智即慧眼摄后得智兼于法慧。又能知即慧所知即法。其出生死眼者。亦前慧眼。慧眼见理故。释无碍眼先正明。后为不坏相下通妨。妨云。若尔一眼即足何用说十。故为此通释。一切智眼中言即是普眼者。名异体一。晋名普眼即佛眼总义。然普眼略有三义。一见普法故。二普见诸法。三所见即眼故。以前二义况出第三。具如毗卢遮那品。若法相宗言。后佛眼下五眼皆佛眼摄。一切智眼即是佛眼

疏。故知十眼下第三出体。随相别体以见于前。此即圆融总相体耳

疏。若辨次下第四辨次。唯约十眼明次。次别知根境即慧眼。次引入如实即是法眼。次令得佛力即是佛眼。次寻光而见即通智眼及光明眼。光有智光即同智故。次同归寂灭即出生死眼。后等同法界即一切智眼。其无碍眼以是总故通于前后。若法相中明次第者。约修以明。为导养身先修肉眼。肉眼见粗不见细等。次修天眼。天眼见色未见真境。故修慧眼。慧眼见理不能见事。故修法眼。法眼未圆故修佛眼

疏。余如别章者。诸章门中皆广说之。然大意要妙上已略具。今更出其见境宽狭。然所见有四。一事。二法。三理。四实。阴界入等差别是事。苦无常等众生根性是法。二空真如是理。如来藏中真常佛性是实。此之四法五眼所见。一肉眼所见见障内等。然凡夫肉眼见百由旬。二乘肉眼同凡夫见。菩萨肉眼如大品说。极远见三千界。如来肉眼与菩萨同。见境分明。天眼有二。一报得随在诸地及于下地。下不能见上。若修得者。智论云。凡夫天眼见一四天下。以小声闻见小千界。大声闻见中千界。阿那律见三千界。缘觉小者见中千。大者见大千。菩萨修得者随人大小所见不定。远者见一切世界。故地持云。菩萨以一切世界为天眼境。报得者大品经说。极喜见三千如来见一切。后之三眼不可以方所定论。唯约得法深浅以辨。二乘慧眼唯见生空。菩萨慧眼具见二空。不能穷尽。如来毕竟。二乘法眼但见苦无常等诸法总相。粗观不能微细。若约不知根欲即无法眼。菩萨法眼了根欲性及一切法。若总若别。若粗若细。而无不穷尽。如来与菩萨同皆悉穷尽。佛眼二乘全无。菩萨人中进退不定。地前菩萨闻见佛性。未有佛眼。地上眼见故有佛眼。若准涅槃。九地已还闻见佛性。十地眼见而未了了。但见自身所有佛性。不见众生所有佛性。于自身中十分见一。如来佛眼穷尽。此明见实。若约人辨余则可知。佛之三身化身具五。报身无肉眼。法身无五眼。若约法性之眼亦得具五。然随法相宗差别。斯法性宗中一一圆融。具如上说(五十八经)疏。与三施九施等者。三施即财法无畏。九施即一自性。二一切。三难行。四一切门。五善士。六一切种。七遂求。八二世乐。九清净。乃至六度四摄皆有此九。十行之初已广说竟。故随显直释者。财施若显。即名财等难行等。不更广引九中别义三中别义

疏。今初十施等者。言一无向背即清净中别义者。清净有十。今但有无向背之一耳。彼当第八。二遂求施者。遂求皆八今但有一。三二世乐者。二世乐有九。今亦唯二所以引梵本者。不乱之言不顺二世乐。以应时济难顺二世乐故

疏。余七皆一切施者。一切即是三施。然亦九中之一。然一切有二。一内外之二。二有其三即财法无畏。故下结中十皆通三。今前三有其别相。后七无余施别相故。云即一切耳。五虽兼清净之义不求异熟。即十中第二也。六亦难行者。以兼一切施故云亦耳。难行皆三即三中第二。七内外财等者。内外即一切中初义也。财等通一切中三也。八九下通释后三。先总标。此回向巧即别释第八。治第一过即经中远离有为。治第二过即远离无为。上解释句行不住道下结成标句也

疏。十度皆有三轮者。梵行品已说。轮即施家三轮

疏。又四难行忍下上约三忍。今约九忍难行有三。今是其一。于下能忍是一难行。对于上流生忍则易。童仆子息生忍则难。彼合敬顺我合责罚故。言恕不逮者。即晋书中意。晋卫洗马凡所发言皆为实录。时有一人非理相忤。后有仆使所为非理于此二人并无愠色。人问其故。彼对之曰。非理相忤可以理遣。人之不逮可以情恕。故云恕不逮故。以释经中为上能宽。此亦外典。谓居上能宽为下能敬。君子之行也

疏。又前五于所知等者。上约摄论三慧以明。今此下文即瑜伽论说三相以释五六七

疏。第二二门明福智者下疏文有二。一总标二门。二福智即道下释二助道具言。乃有三义。一单福是道单智亦然。二合二为道。三双绝为正道。助道具亦三可知

疏。六坚顺位等者。十忍品初已广引璎珞明竟。十智即智论二十六

疏。俱舍云大种谓四界者。次句即地水火风即是界品。具云大种。谓四界即地水火风能成持等业坚湿暖动性。释云。初句标三义称大。一体宽广故。谓四大种遍所造色其体宽广。二增盛聚中形相大故。谓大地等。三能起种种大事用故。如地能持等。一义释种与所造色为所依故。大即是种能持自性故名为界。次句辨业。地能持用。等取水能成相火能成熟风能成长。后句出体可知。今但要初句以证界为毒蛇耳

疏。二明了法者。下疏文有三。一来意。二总。以普贤下显能了智。则是圆智了法无法非圆。今但约相则所了通小耳。三一是凡夫下随文解释。以稚释经之童。以昧释经之蒙。易蒙卦云。蒙亨匪我求童蒙童蒙来求我。初筮告再三渎。渎则不告利贞。彖曰。蒙山下有险险而止蒙。蒙亨以亨行时中也。匪我求童蒙童蒙来求我志应也。初筮告以刚中也。再三渎。渎则不告渎蒙也。蒙以养正圣功也。象曰。山下出泉蒙。君子以果行育有德。注云。山下出泉未知所适。蒙之象也。释曰。今正取蒙昧未知所适义耳。言长四善根即暖顶忍世第一法。初地已广

疏。二谓随信他言而行道故名随信行等者。俱舍贤圣品论云。且于十五心位建立众圣有差别者。颂云。名随信法行由根利钝别。释曰。见道位中圣者有二。一随信行。二随法行。由根利钝别立此二。谓钝者名随信行。彼于先时随信他言而行义故。若利根者名随法行。彼于先时由自披阅契经等法随行义故。此二若至修道。初名住信解。后名见至。疏已具用

疏。然今既云下拣实异权。先正明小乘。但知我空尚谓法有。安觉自性。而云等者。见真实谛是须陀洹。知无往来是斯陀含阿那含人。不念受生法阿罗汉人。成就四义辟支佛人。一味缘起言义皆通大故有等言

疏。是以智论下。引证成前通大之义。天台引此立于通教。通大通小通浅通深。今先列名。后当释义。初列名者。一干慧地。二性地。三八人地。四见地。五薄地。六离欲地。七已办地。八辟支佛地。九菩萨地。十佛性地。大品云。菩萨从初干慧地至菩萨地。皆学而不取证。佛地亦学亦证故云通三乘法也。二解释者。干慧地者三乘初心通名干慧。即是大乘三贤之位。小乘即是五停心等。谓一五停心观。二别相念观。三总相念观。总观无生四真谛理故名干慧。意云。未得定水故。二性地者。若用总相念成三十七品。初发有漏善入暖法顶法忍法世第一法。皆名性地。成内凡故。三八人地。谓信行法行二人体解见道假。以发真断见惑。在无间道即八人地。四见地。即是三乘同见第一义谛之理。同断八十八使尽也。五薄地者。发六无碍断欲界六品惑。证第六解脱。欲界烦恼薄故。六离欲地。谓断欲界五顺下分结尽。离欲界烦恼也。释曰。五顺下分结者。一身见。二戒取。三疑。四欲贪。五嗔恚故。俱舍颂云。由二不超欲即四五也。由三复还下即上三也。七已办地者。即发真无漏断五顺上分结八十八品修惑。尽断三界事究竟故言已办。释曰。五顺上分结者。一色爱。二无色爱。三上二界掉举。四二界慢。五二界无明也。贪过重故二界别明。余三过微二界合说。有此五结不超上界名顺上分结。八辟支佛地者。缘觉功德力大故能侵余习气故。九菩萨地从空入假。道观双流深观二谛。断习气色心等无明。得界外法界道种智。游戏神通学佛十力等故。十佛地者。大功德力资于智慧。一念相应慧观真谛究竟习气究竟尽也。故智论云。声闻智慧力弱。如小火烧木。虽然犹有炭在缘觉。智力强如大火烧木。木然炭尽余有灰。在诸佛智力大如劫火炭灰俱尽。亦如兔马等喻。菩萨佛地名异二乘。何得言通。答名字虽异同是无学。应供得二涅槃共归灰断证果。是一名义不殊。是名同义。究竟俱同也。广如天台四教

疏。此上二下结。第二三即上所引俱舍意也

疏。四第八人者。俱舍二十三贤圣品释住果极七返偈。先问云。此预流名为何义。若初得道名为预流。则预流名应目第八。若初得果名为预流。则倍离欲全离欲者。至道类智应名预流。下答意明初得果故名为预流。以超断者不定初得故。俱舍大疏宝公但云若预流名目初得道。即初见道第八人应名预流。亦不释于第八所以离欲等言。小疏释云。其苦法忍即是第八人。于八忍中从后疏之为第八故。若义林法师大疏钞云。八人地谓预流向也。四向四果从后数之为第八故。婆沙三十六第八圣者。谓随信行及随法行从胜数为第八故。又更一解。与小疏同。探玄引大般若。亦初果向同于林公从后数之。泽州远公引古婆沙论。詺须陀洹向以为第八。而对见道前七方便故名第八故。彼论中问言。云何为第八人。所谓信坚及法坚。钝根之人见道名信坚。利根之人名法坚。释曰。此上全同林公引文。而取义逆顺为别。俱未见文。以义取人远公理长。第八之名所以顺故。远公又云。外国相传云。更有八人者初发心人而未有行。二有相行人憎厌生死乐修善法。三无相行人学观空理破离欣厌。见人行恶心无忿怒。见人修善亦不欣庆。四方便行人虽见法空而常随有起诸善行。此四在于善趣地中。五者习种。六者性种。七者解行。八者圣种。初依地前未同圣种故非第八。第八人者不名凡夫。彰异于前云不名凡夫。拣异初依名为菩萨。当相以论不名为佛别异于后。释曰。远公解前顺今文。后非今意。彼释四依故可用之。因便引来以彰异辙。今疏正意取初果向。而俱舍小疏亦是初向而局苦忍。义成大局亦彰异辙。非用指南下引智论八人。亦初果向通十五心。而若约超断容余果向

疏。故智论中有八人地者。证前文是初果向。案前十地。第三八人在于见道无间道故。五十九云。八人地者。所谓见谛道中信行一。法行二。须陀洹极六七世生三有须陀洹今世烦恼尽得阿罗汉。四有家家须陀洹三世生已入涅槃。五有中间须陀洹。六除第三余中间入涅槃。七住六住无碍五解脱中者八。皆是须陀洹向。释曰。此则初果向中有八种人故名八人地。非独第八。然此八人望七方便皆是第八。二义俱成。谓亦名第八亦名八人地也。故疏引来证成初向。望后第五既是初果。此为初向次第分明。若唯取于苦法忍者。余之七忍何以拣之。又十四心何以不取。又十五心皆未得果。论主何独将苦法忍而为难辞。林公成立为初果向理则无违。而从胜进数亦无所以。正义如前

疏。若约超断等者。此下拣滥正取初果之向。不取二三果向。以超断人不定初得故。经略无。以义合有故复出耳。即俱舍云。具修惑断一。至五向初果。断次三向二。离八地三向。至第十六心。随三向住果。名信解见至。亦由利钝别。释曰。今疏取意展彼颂文以成长行。理皆已具耳。上智论文名家家。亦俱舍义颂云。断欲三四品。三二生家家。断至五二向。断六一来果。释曰初两句明家家下两句明向果。即预流者。进断修惑若三缘具转名家家。一由断修惑三四品故。二由成根德能治彼无漏根故。三由受生更受欲界三二生故。颂中但说初后二缘不说成根者。预流果后进断修惑诸无漏根理必合有。义准已成故颂不说。言断三四品受三二生者。若断三品名受三生。若断四品名受二生。谓九品惑能润七生。且上上品能润两生。上中上下中上各润一生。中中中下合润一生。下三品惑共润一生。既上三品能润四生。故断上三品四生便损名受三生。既言中上亦润一生。故断中上品惑。复损一生兼上损四。都损五生受二生也。问何故无断一品二品五品名家家耶。答必无有断一品二品不断三品中间死生。无有断五品不断六品而有死生。谓由圣者得初果已断欲修惑起大加行。必无未断一大品(三品名二大品也)有死生故。故断一品二品必断三品也。断第五品不断第六品者。谓第六品证一来果。以无一品能障得果故。断五品必断第六。余如彼说。所以引此文者。即下一来不还断惑多少皆要此故

疏。五初果等者。即前共十地中见地也。然俱舍等以第十六心先已见理不明见道见。道要须未见今见故。今道已先见乃重虑修行。故名修道。智度论意至第十六是解脱道。断惑方终见谛始圆故名见地

疏。释众结断乃有二意。先总后别总有三正三随者。三正即涅槃经。谓身见戒取疑。俱舍说断其六故加三随。边见随身见。执断常者必依身故。见取随戒取非因计因必计胜故。邪见随疑疑无之心断善根故。亦可下二别明八十八使。前俱舍中共引颂云。苦下具一切集灭离三见。道除于二见上界不行恚故。欲苦有十集灭各七为十四。道下有八成三十二。上二界四谛各除一嗔。故两界各二十八。故成八十八。此见所断。若语修道欲界断四。谓六根本除见及疑。但有贪嗔痴慢。上二界各唯除嗔。二界各三故有六。合欲之四共成十使。即三果已后断之。复合前名九十八使。更加十缠为一百八烦恼

疏。由见谛断无明漏者。无明漏亦名无明流。四流之一

疏。六一来果者。更一往天上一来生欲界故。而知无往来者即般若意。金刚十八住处中。第五胜中无慢住处。经从须菩提于意云何。须陀洹能作是念。我得须陀洹果不下。是意明。小乘四果尚得离慢。岂况菩萨求大菩提于初回向不离慢哉。故判此文是十回向初救护众生离众生相回向。言离慢者。是离我慢。文中四果皆有三段。此初果中上即如来反问。二须菩提言不也世尊此即答也。意明无念。三解所以者。经云。何以故须陀洹名为入流。而无所入。不入色声香味触法是名须陀洹。释曰。意云。须陀洹梵语此云入流。入圣流故。谓至第十六道类智心即入圣流。所以入圣流者。由了第一义谛无所入故。则不起心念言我入流。若有念虑言我入流不契谛理。则不入圣流。而此无念无入即无漏圣智。故不入于六尘之境。故上疏云。由见谛理断无明名生无漏。二一来果。经云。须菩提于意云何斯陀含能作是念。我得斯陀含果不(问也)须菩提言不也由尊(答也下释云)何以故。斯陀含名一往来而实无往来。是名斯陀含。释曰。断六品惑解脱道中契于谛理更不生于一往来念。若有心念即有我慢。岂得圣果。故今疏云知无往来。三不还果。经云。须菩提于意云何。阿那含能作是念。我得阿那含果不。须菩提言。不也世尊。何以故。阿那含名为不来。而实无来是名阿那含。释曰。大意同前亦无心念断五顺下分结名为不还。疏乃至八地惑皆断者。非但断欲修惑。更进断四禅三空并前欲界故云八地。当处不还。以非想惑皆断尽者。成阿罗汉故。八地则已该于三界。故云不乐三界。上之二界犹不爱乐。故云而实无来。四无学果。经云。须菩提于意云何。阿罗汉能作是念。我得阿罗汉道不。须菩提言。不也世尊。实无有法名阿罗汉。世尊。若阿罗汉作是念。我得阿罗汉道。则为着我人众生寿者。释曰。阿罗汉断五上分结。总说所断之惑。有八十九种。若见所断总有八品。即上下八谛。若修所断三界九地。地地有九成八十一品。亦证八十九品无为为应果体。言应果者。应受人天一切供养。若有心念不契无为。即是我慢着我人等。由无心念故名应果。故实无有法名阿罗汉。今经略无无念之义。八无学下辨罗汉法。六通等义前后已具。今取前后曾未说者即八解脱。略示名相。俱舍颂云。解脱有八种。前三无贪性。二二一一定四无色定。善灭受想解脱微微无间生。由自地净心及下无漏出。三境欲可见。四境类品道自上苦集灭非择灭虚空。释曰。初句总标。次两句别名前三解脱。第四句别明次四解脱。第二行颂明第八解脱。后一颂总明所缘。言解脱有八种者。一内有色观外色解脱。谓于内身有色想贪。为除贪观外不净青瘀等色。今贪不起故名解脱。第二内无色想观外色解脱。谓于内身无色想贪虽已除贪为坚牢故。观外不净青瘀等色。令贪不起名为解脱。第三净解脱身作证具足住。谓观净色令贪不起名净解脱。观净色者显观转胜。此净解脱身中证得名身作证具足圆满。得住此定名具足住。四无色定为次四解脱。四解脱各能弃背下地贪故名为解脱。后第八灭受想定解脱身作证具足住。弃背受等名为解脱。依婆沙论此言解脱者。谓弃背义。前三无贪性者。初三解脱无贪为体。近治贪故。三中初二不净相转。作青瘀等诸行相故。第三解脱清净转。作光鲜行相转故。此三助伴皆五蕴为性。二二一一定者。上二即初二解脱。下二即初二禅以初二解脱依初二禅起。故云二二。一一定者。上一谓第三解脱。唯依第四禅起云一一定也。以第四禅离八灾患慧心澄净故。有净解脱。四无色定善者。四无色定解脱以善定为体。非无记染非解脱故。亦非散善性微劣故。无散善者如命终心也。灭受想解脱微微无间生者。灭受想解脱也。有解厌背受想。有解背一切有所缘心。有云。解脱定障故名解脱。微微心后此定现前。入灭定心总有三种。一者想心。二者微细心。三者微微心对前心已名微细。此更微细故名微微。从微微心入灭尽定。由自地净心及下无漏出者。明出灭定心也出灭定心。或有顶净心或起下无所有处无漏心。如是入心唯是有漏。通从有漏无漏心出。三境欲可见者。初三解脱唯以欲界色处为境。有差别者。初二境可憎。第三境可爱。四境类品道自上苦集灭者。四无色解脱各缘自地上地苦集灭谛。及缘九地类智品道。为所缘境非择灭虚空者。无色解脱亦缘自地上地苦谛集谛上非择灭。及缘九地类智品上非择灭及虚空。为所缘境。问第三静虑宁无解脱。答第三定中无眼识所引欲色贪故。自地妙乐所动乱故。故无解脱。问行者何缘修净解脱。答为欲令忻故修净解脱。前不净观令心沈戚令修净观。策发令忻或为审知自堪能。故谓前所修不净解脱为成不成。若观净相烦恼不起。彼方成故。问何故经中第三第八解脱得身证名非余六耶。答以八中此二胜故。二界边故得身证名。第三解脱唯取净想。令惑不起名为殊胜第八解脱以无心故为殊胜。第三解脱在色界边。第八解脱在无色边。疏文对会可知。言余义已见上文者。谓六通即三地及十通品说。九定即此品。灭定亦如六七地辨。广如九地。诸论即瑜伽智论唯识等说。然萨遮尼揵子经第五亦广说六通等

大方广佛华严经随疏演义钞卷第八十二大方广佛华严经随疏演义钞卷第八十三

        唐清凉山大华严寺沙门澄观述

疏。今初十魔下分三。一总释为魔之义。二然四魔下对四辩异。三若欲下与四相摄

疏。二有十魔下分二。先总释业相。二十中下释文

疏。二于蔽度下释第二句分二。一总释文意。二夫真道者下立理。于中有二先约智说则蔽度两亡。后又悲化恶故下约大悲说先正明。后况恶为善资下。即借老子意释成上义。即道经无辙迹章结文。彼章具云。善行无辙迹善言无瑕谪。善计不用筹策善闭无关键。而不可开。善无结绳约而不可解。释曰。意云。无心于此五何有辙迹等耶。次云。是以圣人常善救人而无弃人。常善救物故无弃物。是谓袭明。释曰。心无所系无可无不可。何所弃哉。次云。故善人不善人之师。不善人善人之资。不贵其师不爱其资。虽知大迷是为要妙。释曰。此有二意。一约密意。谓虽师法善人资取恶人而不贵。不爱师资两亡以为玄德。凡俗虽知而大迷于道谓之要妙。二约显意。善者所法恶是我资。而不贵爱。则虽知善恶乃是大迷。善恶皆善是谓要妙。则顺上文无弃人物。今疏用此故令化恶也。密用曰袭

疏。今初即是果现下疏文有六。一会同前文。二释见义。三随文释。四总结圆融五摄之成对。六总显包含。今初此中所见即前十佛者。即十信末五十三经。然探玄记引法集经菩萨入十种法能知诸佛。何等为十。所谓集气佛果报佛三昧佛愿佛心佛实佛同佛化佛供养佛形像佛乃至广说。若欲会者。集气即义当随乐佛。其本集而欲见故。果报即业报佛。次三全同实佛。义当法界。同佛即本性。本性同故。化即涅槃供养即正觉。形像即住持。二然此中明见下释见佛义。于中亦三。初正明。二若菩萨下反显。三亦不得下遮救。恐有救云。半就能见如无著佛等。半就所见如出生等。岂不通耶。故今遮云。不得半就能所令人致惑取解无由。故十种见义成杂乱故

疏。一无著者下三释文。释此一句。疏文有三。一正释正觉标其所见无。着即正觉之相二。又邪慧下。则正觉无著二义不同。所见能见名须具二。今所见有正觉德圆。略无邪慧而不离。能见则有无邪智而不离。略无正德而不圆故。令佛中影取无著。能见之中影取正觉。是故疏云佛见影略。三此即下结成总别

疏。二乘愿出生中文云下引证。即华藏品言。又乘此愿下。上约生身此约生德。疏故下善财等者。引证。即七十七经。善财修观此约真身。又云。一切化佛从敬心起。明知敬属于机能见化身。信属于佛因信成果

疏。亦能令见者信者上约真身信自属佛。今就真身信亦属机。以相好庄严显由此成故令物信

疏。四随顺众生等者。即论中意。又随顺众生以圆音下即海东意。谈玄之中已显不违正理。故双出之

疏。深入涅槃故能示灭者得无住涅槃。能建大事。言深入生死则示灭非真者。悟生死性即性净涅槃。故知示灭非真灭也。称性常在故六法身者。初以如智契合具德法身。故云满于法界。法界是所满故下。约法性身云为佛体。疏七湛然安住者。择安住见。真唯识性即是心佛。疏八寂然无依释见一义。次以无依释三昧佛。后触类下释无量义。疏九平等亦二义释。先能所合明。后本觉下唯就理说。疏十随自他意下即意生身。然有三义。一如意速疾。二随自意成。三随他意乐。今用后二释随乐言。随自所乐普受法身。随他所乐欲受何类

疏。依上十见下四六相圆融总即一佛。别分为十。同带于佛异则正觉。相好等差。成则揽十共成真佛之义。坏则十身各住自性

疏。又此十种下第五束之成对

疏。又此十见各有十义下。第六结成包含即海东意。海东顺于晋经名有数异故。今取义亦有小殊。今直就此经相应引证。一正觉佛无著见者。有十无著即此品云。所谓于一切世间无著。于一切众生无著。于一切法无著。于一切所作无著。于一切善根无著。于一切生处无著。于一切愿无著。于一切行无著。于一切菩萨无著。于一切佛无著。此十虽因彻于果位。一切无著而不思议品。十种离果清净亦果无著。等二愿佛出生见亦有十种出生。不思议品云。诸佛世尊有十种念念出生智。何等为十。所谓一切诸佛于一念中。悉能示现无量世界从天来下。二菩萨受生。三出家学道。四菩提树下成等正觉。五转妙法轮。六教化众生供养诸佛。七不可言说种种佛身。八种种庄严无数庄严如来自在一切智藏。九无量无数清净众生。十三世诸佛种种根性种种精进种种行解。于三世中成等正觉。释曰。其一二等数经文所无。句句皆如初句。有一切诸佛至世界之言。即是从后得智愿生八相等。三业报佛深信见。若约庄严应如不思议品十种最胜无上庄严。今取因行则不思议品果中所无。即如十藏品云。信一切法无相。信一切法无愿。信一切法无作。信一切法无分别。信一切法无所依。信一切法不可量。信一切法无有上。信一切法难超越。信一切法无生。释曰。以此为因成果也。亦可如十地中十种信。四住持佛随顺见者。若约随顺众生住持。佛法即十种为众生作佛事。不思议品云。诸佛世尊有十种为众生作佛事。何等为十。一者所谓一切诸佛示现色身。为众生作佛事。二出妙音声。三有所受。四无所受。五以地水火风。六神力自在示现一切所缘境界。七种种名号。八以佛刹境界。九严净佛刹。十寂寞无言。释曰。句上皆有一切诸佛。句下皆有作佛事言。一如初句。寂寞无言即自身舍利住持自在。若约圆音住持。即如下文如来应正等觉转法轮时。以一事故于众生心中种白净法无空过者。即随顺义。何等为十。所谓过去愿力故。大悲所持故。不舍众生故。智慧自在故。随其所乐为说法故。必应其时未曾失故。随其所宜无妄说故。其身最胜无与等故。言辞自在无能治故。智慧自在随所发言悉开悟故是为十。五涅槃佛深入见者。即出现品云。欲知如来大涅槃者。当应了知根本自性。释曰。了知即是深入义也。经云。如真如涅槃如来涅槃亦如是。二实际。三法界。四虚空。五法性。六离欲际。七无相际。八我性际。九一切法性际。十真如际。释曰。具足皆如初句。如是了知名为深入六法界佛普至见者。若直约法界说。如至一切处回向云。譬如实际无处不至。至一切物。至一切世间。至一切众生。至一切国土。至一切法。至一切虚空。至一切三世。至一切有为无为。至一切语言音声。然今但有九有为无为。应分为二若就佛上明遍至者。即不思议法品云。佛子诸佛世尊有十种法普遍法界何等为十。所谓一切诸佛有无边际身色相清净。普入诸趣而无染着。二无障碍眼于一切法悉能明见。三无碍耳悉能解了一切音声。四鼻能到诸佛自在彼岸。五有广长舌出妙音声周遍法界。六身应众生心咸令得见。七意住于无碍平等法身。八无碍解脱示现无尽大神通力。九清净世界随众生乐。现众佛土种种庄严。而于其中不生染着。十菩萨行愿得圆满智。游戏自在悉能通达一切佛法。释曰。十句之中皆如初句。有一切诸佛有无边际言。舌中有广长故关无边际语。七心佛安住见者。不思议品云。诸佛世尊有十种无量住。所谓常住大悲。住种种身作诸佛事。住平等意转净法轮。住四辩才。说无量法住不思议一切佛法。住清净音遍无量土。住不可说甚深法界现一切最胜神通。住能开示无有障碍究竟之法。释曰。此是佛心之所住也。经唯九句应开净音遍无量土为二。八三昧佛无量无依见者。不思议品云。诸佛世尊有十种无量不可思议佛三昧何等为十。所谓一切诸佛恒在正定。于一念中遍一切处。普为众生广说妙法。二普为众生说无我际。三普入三世。四普入十方广大佛刹。五普现无量种种佛身。六随诸众生种种心解现身语意。七说一切法离欲真际。八演说一切缘起自性。九示现无量世出世间广大庄严。令诸众生常得见佛。十令诸众生悉得通达一切佛法。无量解脱究竟到于无上彼岸。释曰。具足皆如初句。有一切诸佛恒在正定于一念中遍一切处之言。虽有此无量而心无所依。九本性佛明了见明了即是智身故。四十七云。诸佛世尊有十种知一切法尽无有余。何等为十。所谓一知过去一切法尽无有余。二知未来一切法。三知现在一切法。四知一切语言法。五知一切众生心。六知一切菩萨善根上中下种种分位。七知一切佛圆满智及诸善根不增不减。八知一切法皆从缘起。九知一切世界种。十知一切法界中如因陀罗网诸差别事。释曰。十句皆有尽无有余之言。十随乐佛普受见者。普能受领随乐现故。即四十六诸佛世尊于一切世界一切时有十种佛事。何等为十。一者若有众生专心忆念。则现其前。二者若有众生心不调顺则为说法。三者若有众生能生净信必令获得无量善根。四者若有众生能入法位。悉能现证无不了知五者教化众生无有疲厌。六者游诸佛刹往来无碍。七者大悲不舍一切众生八者现变化身恒不断绝九者神通自在未曾休息。十者安住法界能遍观察是为十。释曰。斯则普随众生之所受也

疏。又如瑜伽九十下重释净戒。先举所治。后亦有五相下举其能治。此五亦可对前五。唯三四不次。一由佛许还净故不自责。二由灭无知不惧天所诃。三已生无犯之意不惧恶名。四于同行悔不惧同行之责。五佛许悔除故不惧恶道。而其实义此五通能治于前五

疏。俱舍十九云一慢等者然文具有。疏引彼论以释今经。恐不知主客今重具引。俱舍云。慢七九从三皆通见修断。瑜伽杂集大同俱舍。今依俱舍。疏中三。一依俱舍列名。二今文下对文开合。三前三即慢下释文。先别释初三于中二意初标。次故彼论下全引论文正释慢义。初一轻人下别释三句

疏。四自高下释过慢。从是于他下全是论文。五中先指同会释。二有德下将经。就论文具云于他胜谓己胜名慢过慢。慢他过故。六邪慢。论具云于实无德中谓己有德名邪慢。上皆论文下即论释。从自起诽谤下疏牒今经会通论文。七卑慢中疏以经就论。即自求高座下是。论具足云。于多分胜谓己少劣。名为卑慢余皆疏释。八亦邪慢者。即见有德人下是也。嚬戚粗犷即是恶行。此即将前论中成就恶行收之。九言我慢所吞故者。以经释成知是我慢。若论具云。执我我所令心高举名为我慢。恃我起故。释曰。疏以易故不引论释十即增上慢下。疏中先以经会论。后其但以下随难重释。前中具足论云。未得谓得名增上慢。瑜伽云。己无实德谓己有德。杂集云。谓于未得上胜证法计己已得上胜证法。疏会释论文易可知。上论偈云。慢七九从三者。即是九慢从前七慢三慢而生。言九慢者。发智论云。一我胜慢类二我等慢类三我劣慢类四有胜我慢类。五有等我慢类。六有劣我慢类。七无胜我慢类。八无等我慢类。九无劣我慢类。言从三者。一慢。二过慢三卑慢。初三中一我胜慢类。从前过慢出。二我等慢类从前慢出。三我劣慢类从卑慢出。四五六三如次。从卑慢及慢并过慢出。七八九三如次从慢过慢卑慢中出。释曰。然上九慢既从三生。则成三三皆有别相。论更不释细详可见。但有难云。问于多分胜谓己劣卑慢可成。有高处故无劣我慢。高处是何。答谓自爱乐胜有情聚反顾己身。虽知极劣而自尊重得成无劣。我慢类也。言皆通见修断者。七九同故云皆通也缘见所断起者名见所断。缘事起者名修所断

疏。若约八慢等者。即刊定意涅槃成实者。皆有八慢。天台智者引文殊问经。释法华八鸟。明八慢。谓一盛壮慢如鸱。二性慢如枭。三富慢如雕。四自在慢如鹫。五寿命慢如乌。六聪明慢如鹊。七行善慢如鸠。九色慢如鸽(五十九经)疏诸经论中多用初缘者。谓今此菩萨自然化生等。智论皆然。探玄记有问云。据此经兜率命终即入胎等。何故梁摄论明化身二十年在中阴。真谛三藏金光明疏中释云。有小乘别部云。听待父母受生竟故二十年在中阴。释曰。此乃机见不同故。言二十年等多小劣见

疏。五乘愿化生者。明非没生也

疏。谁能于佛恃种族者。瑞应经云。从劫初已来代代相承。作转轮圣王。近来四代虽不作转轮圣王。而作人中之王明是万代金轮之种。故种族无上

疏。说智慧藏为胎藏者。显智德生佛。以离垢藏即是断德。以法界藏即五藏之一。正是法身。八即般若九即解脱。乃用三德为胎藏耳。故下疏合为能所。证智之与断皆能证也

疏。十方各行七步者。即涅槃第四如来性品云。善男子此阎浮提林微尼园。示现从母摩耶而生。生已即能东行七步。唱如是言。我于人天阿修罗中最尊最上。父母人天见以惊喜生希有心。而诸人等谓见婴儿。而我此身无量劫来久离染法。如是身者即是法身。非是肉血筋脉骨髓之所成立。随顺世间众生法故示为婴儿。南行七步示现欲为无量众生作上福田。西行七步示现生尽永断老死是最后身。北行七步示现已度诸有生死。东行七步示为众生而作导首。四维七步示现断灭种种烦恼四魔种性。成于如来应供正遍知。上行七步示现不为不净之物而所染污。犹如虚空。下行七步示现法雨灭地狱火。令彼众生受安隐乐。毁禁戒者示作霜雹

疏。显自在奇特下。总显大意

疏。如瞿波者。七十五中广说因起

疏。三一言骂佛。六载受饥缘如大乘方便经第二者经有三卷。亦编入宝积部中。当第一百六十八。此即当一百七经。先总云。善男子汝今善听。以何因缘菩萨苦行六年。善男子非是菩萨宿业余报受此苦也。欲令众生于一切恶业报中生厌患心归向菩提。释曰下经文广今当略引。复次善男子昔迦叶佛时。有婆罗门子名树提。有亲友五人久近恶友失菩提心。奉事外道不能信解佛语佛法。彼师自言我是世尊。树提欲引五人转其邪心。至瓦师所作如是言。我不欲见秃头道人。何有秃人能得菩提道。菩提之道甚深难得。后经少时与彼五人在一屏处。瓦师往彼赞佛功德。令住见佛。树提思惟五人根生。我若赞佛必彼生疑。自护本愿故。般若波罗蜜报行方便故作如是言。我不欲见秃头道人。何有秃人能得菩提。菩提之道甚深难得。云般若波罗报者菩萨行般若波罗蜜无有菩提想。无有佛想不见佛菩提。不于内外中间见菩提。知菩提空故行于方便。作如是语。后于一时与五人在河水边。瓦师承佛神力即至其所。赞佛难遇固不肯去。瓦师遂捉其发牵至彼所。五人随往彼之国法。执人发者罪应至死。时人见之皆言佛有何德。乃令瓦师忘死引之。既至佛所。五人礼敬发心呵责树提。又闻佛德辩才发菩提心。为说菩萨藏不退转陀罗尼金刚句无生法忍。五人得无生忍。释曰。是如菩萨为化五人般若观空而发于言。即大乘方便岂有报耶

疏。四五浊众生皆有重罪至亦如彼说者。即其后经云。复次菩萨尔时为化五人示自业报。使余若知不知苦乐报者念言。一言诽谤迦叶佛而彼菩萨得解脱。况我不知而作恶言。是故我今当自悔除一切过业更不得作。释曰。然化五人言义明显示六年之意。事犹未显恐是五人兼已为六耳。彼五人似当五俱轮。经文又云。为伏诸外道日食一麻一麦。故又为化五千二百粗行诸天及外神仙粗行菩萨。是名菩萨摩诃萨行于方便

疏。皆言示者。久已降故者即涅槃第二。佛许受纯陀之供云。纯陀。施食有二果报无差。何等为二。一者受已得阿耨多罗三藐三菩提。二者受已入于涅槃。纯陀不受此言广难如来。谓二女先施。是杂食身非金刚身常身法身等。岂得言同佛。答云。尔时破坏四魔今入涅槃。亦破四魔。是故我言亦施果报等无差别。末后云。如来之身已于无量阿僧祇劫不受饮食。释曰。此身不受饮食。则显此身久已降魔

疏。魔王多是大菩萨者。即净名经当第二卷不思议品。因说室句广坐。皆不思议解脱之力方便广说不思议事。迦叶悲叹竟。尔时维摩诘语大迦叶言。仁者十方无量阿僧祇世界中作魔王者。多是住不可思议解脱菩萨。以方便力教化众生现作魔王。即其文也

疏。无有恶魔下。亦大乘方便经意。下指经文。具足经云。菩萨坐菩提树下。使恶魔波旬至菩提树下。不欲令菩萨成就阿耨多罗三藐三菩提。善男子。魔本不能至菩提树下。若我不召而能来者无有是处。善男子。尔时菩萨坐菩提树下。如是思惟于四天下谁最尊第一。此四天下今为属谁。菩萨即知恶魔波旬欲界最尊。今我与魔共斗。魔若不如一切欲界所有众生悉皆不如。尔时诸天人众和合。而来到菩提树下。到已必发清净信心。下取意引。魔众天众八部见菩萨游戏发菩提心。尽得解脱故。疏云胜降余伏

疏。一示德诤者。小人力诤故。二破魔佛谁愈者愈犹胜也。经文自显亦方便经意。第三缘即彼经次文云。善男子菩萨如是思惟已。放眉间白毫相光。能令波旬宫殿黑暗。尔时三千大千世界以光明照故。普令大明。此光明中出如是声。彼释种子出家学道。今当成阿耨多罗三藐三菩提。过魔境界胜出魔众。减损当来一切魔众。令彼菩萨与魔共战。善男子尔时波旬闻是声已。心大忧愁如箭入心。时魔波旬严四种兵。满三十六由旬欲为留难。菩萨尔时住大慈悲及大智慧。以智慧金色之手。而以指地。一切魔众寻即散坏魔众。坏已八万四千亿天龙鬼神乾闼婆阿修罗迦楼罗紧那罗魔睺罗伽拘槃茶。如是大众见菩萨威德身体殊妙容颜端严威力勇健。发阿耨多罗三藐三菩提心。是名菩萨摩诃萨行于方便。释曰。疏但义引耳。疏及本行集者。大意则同但文广耳。故彼经意。诸天本见魔王自在将谓胜佛。故决彼疑令知佛胜。七一被者。亦涅槃经云。尔时欲界主魔王波旬。与其眷属诸天采女无量无边阿僧祇众。开地狱门施清净水。因而告曰。汝等今者无所能为。唯当专念如来应正遍知。建立最后随喜供养。令汝等长夜中获安隐乐。时魔波旬即于地狱息诸刀剑等。次云。持诸供具胜过一切人天所设。其盖小者覆中千界。来至佛所稽首佛足白佛言。我等今者爱乐大乘守护大乘。世尊若有善男子善女人。为供养故。为怖畏故。为诳他故。为财利故。为随他故受是大乘或真或伪我等尔时当为是人除灭怖畏。说如是咒

啅枳咤咤罗啅枳卢诃隶摩诃卢诃隶诃啰遮啰多啰莎诃

释曰。此即翻护法文也

疏。小乘以眼智明觉系于四谛等者。已见出现法轮章中

疏。次四智具即四悉檀者。问明已广。即智论第一论别有解释。总名悉檀者。诸三藏译皆云义宗。具云悉檀多。有云遍施乃意释耳。疏第十涅槃下初总明。后初二下别释。此中即用涅槃第二经因三修比丘叹无常等以为上想。佛广诃之。后为正说云。汝等若言我亦修习无常苦无我想。是三种修无有实义。我今当说胜三修法。苦者计乐乐者计苦。是颠倒法。无常计常常计无常。是颠倒法。无我计我我计无我。是颠倒法。不净计净净计不净。是颠倒法。如是等四颠倒法。是人不知正修诸法。汝诸比丘于苦法中生于乐想。于无常中生于常想。于无我中生于我想。于不净中生于净想。世间亦有常乐我净。出世亦有常乐我净。世间法者。有字无义。出世法者。有字有义。何以故。世间之法有四颠倒故不知义。所以者何。有想倒心倒见倒。以三倒故世间之人乐中见苦常见无常。我见无我净见不净是名颠倒。以颠倒故。世间知字而不知义。何等为义。无我者名为生死。我者名为如来。无常者声闻缘觉。常者如来法身。苦者一切外道。乐者即是涅槃。不净者即有为法。净者诸佛菩萨所有正法。是名不颠倒。以不倒故知字知义。若欲远离四颠倒者。应知如是常乐我净。释曰。上具引经者。以此十句多分用故。三明涅槃是乐者。翻上无乐即是第二。言以涅槃下出得乐名所以。四翻色身无常者。文中有三。初正释。即上涅槃。云常者如来法身。二故晋经下引证成是常义。以今经文阙常字故。恐人误谓此显净德。故次引证。三以法身下释成法身遍得常名之所以也兼显此用法身之言。以是三德大涅槃故。今已出下显与涅槃经小异之相疏。次三明生死无我者。即上经云无我者。所谓生死

疏。八明涅槃是坚即自在我者。涅槃二十七云。我者谓大涅槃。上第二云。我者即是如来。自约别义至下当释。今明涅槃故说涅槃为我义耳。言亦兼常义者。以有坚牢言故。然常已配法身故此属我

疏。九翻有为等者。疏文有三。初正释。即上涅槃。云净者诸佛菩萨正法无生无起。般若体故亦名正法。远公云。正法偏名净者。以治障故。彼约三宝之中法宝说之。二然是下正显今经净法之体性净涅槃三德本具不由治净随缘生死。即经云。而有聚集散坏即相之性即无生无。起如是方是涅槃正法。以约涅槃说于净德。不同涅槃第二别约正法。三涅槃第二下会通涅槃。第二涅槃就于义如来为我。今说涅槃故不同彼。疏然常等四德下二正释上文与涅槃不同之由。涅槃二十七云。空者所谓生死。不空者谓大涅槃。无常者所谓生死。常者谓大涅槃。无我者所谓生死。我者谓大涅槃。苦者所谓生死。乐者谓大涅槃等。即具四德则如来正法亦具四德。言从其别义。各显不同者。即涅槃第二意也。远公亦云常乐我常理实通遍一切佛法。然今隐显我偏就人。余三就法。我是佛者自在名我。自在之用在于佛人故说为我。又复我者人之别称。故就佛人而说其我常法身者。佛体显本法成。性出自古体无变易。顺常义显故说为常。乐云涅槃者。涅槃是灭灭离众苦寂灭义显故说为乐。净是法者谓三宝中法宝之体。能治超胜故说为净。释曰。上来疏中多已用之。就义稳便小有改易

疏。上以四荣下结成破倒。广如四地略如上引涅槃之文偈中。疏菩萨迦楼罗下。其中第五偈云菩萨智光月等者。论经云。菩萨清凉月游于毕竟空。乘光照三界心法无不现余可知

    入法界品第三十九

疏。初来意等者。分来品来二意。先约四分以明来意。后亦远答下就前总别以明来意。九会共答十海问故。疏会品下此中亦合有三来意。然离世间虽亦一会一分一品。而其所对分会品差有三来意。此中前无分会品别对故但为一

疏。三品名者。疏文有三。初总明。二得名。三释名

疏。然法含持轨下第二得名先释法后界有下释界于中二。一约理法界。二双约事理法界。前中言梁论十五者。彼本论云。复次诸佛法界恒时应具有五业。释论云。此中明法身业。而言诸佛法界者。欲显法身含法界五义等余同。疏。论下结云由法身含法界五义。诸菩萨应见法身恒与五业相应。无时暂离其五业。谓除有情灾患业等。上文引竟。然正是此下论文。若世亲论无此五义但说五业耳。五义可知

疏。复有持义下第二双约事理释法界。于中先标三义。后然持曲有三下别释持义。及以法持自体义余二可知

疏。于中下三释名。然直语一法则无六释。故会六释唯释界字。于前五中除前二兼于后三故有六义。皆唯持业从心境合目下即通品名会六释耳。疏第三宗趣。其无始时来界已见问明

疏。及五种色并八无为者。五种色即杂集第一云法界处所摄色者。略有五种。谓极略色。极迥色受所引色遍计所起色定自在所生色。极略色者。谓极微色。极迥色者。谓离余碍触色。受所引色者。谓无表色。遍计所起色者。谓影像色。定自在所生色者。谓解脱静虑所行境色。前释迥色云。谓离余碍触方所可得。又释空一显色云。谓上所见青等显色。就此二色析至极少名极迥色。余之色义已见上文。言八无为者。已见十藏。谓六中开真如为三性故。其无碍门亦见问明。不合不散即不一不异义也

疏。二无寄门者。然形夺要二相假无寄则当法自离故不同也。相及俗谛皆有为性。及真谛皆无为。言非二名言所能至者言语道断故。表义名言不能至也。心行处灭故。显境名言所不能至。从解深密下引证俱非。疏一普摄门者。谓不坏前四门之相而为一致故。故引善财随事差别。皆入法界后圆融门。才举一门即融诸门。然以理融事令事如理以事显理令理如事。故云理非无分。谓理即事事既有分理亦有分。不尔真理不即事故。理既如事随举一法即一法界。若举多法即多法界。然由一非一故下。复融上一异。一若定一不能即诸。以一即理故即非一。以非一故能即诸也。以非一故与诸不异。下句翻此准事显理既互相即。则涉入重重方成无障碍义。引善财证暂时执手明时圆融。才入楼阁明处圆融

疏。上来五门下总结圆融。总即法界别有五种。同则十门皆同法界。异则有为与无为等相望有差。成则五义共成法界。坏则有为自住有为。余四亦尔

疏。二明能入下先别列五门。后此五下对前料拣。言如其次第各是一门者。一有为法界本有种子差别之法。但在明信。二无为之理性净妙德皆须明解。三亦有为亦无为。法界事理有异必须双行。四非有为非无为界。双遣玄寂唯证方契。五无障碍非满不穷显义多门。为此别配取义圆备互遍方周。若无信心安能见理。况无障碍无信安穷

疏。第二法界类别者。上来虽有五界通该诸法。今于总法开从别类。然类开五门。五门各五。初二文显。后三文隐

疏。五无障碍法界者。此中亦有五义。一前四融为一味。二四相历然故云一异无障碍。三一异双存。四一异互夺双泯绝。故云存亡不碍。五自在圆融。谓欲一则一欲异则异。欲存即存欲泯便泯。异不碍一泯不碍存。方为自在。常一常异常存常泯名为圆融疏此五能所如次及通可以意得者。通则随一能入遍入五所。入随一所入皆用五能斯为正意。言如次者一身入法法界。二智入人法界。三身智俱存入无二法界。四身智俱泯入人法俱泯法界。五人法圆融入无障碍法界。此为第三能所浑融无二中之五句也

疏。四能所谓融形夺俱泯者。此亦有五。一以所夺能唯法界。二以能夺所唯能入。三能所俱存。四能所俱泯。五此四圆融无有前后

疏。五一异存亡无碍具足者。亦有五句。一能所一味。二能所历然。三一异双存。四一异双泯。五上之四句无碍具足。故令如理思之

大方广佛华严经随疏演义钞卷第八十三大方广佛华严经随疏演义钞卷第八十四

        唐清凉山大华严寺沙门澄观述

疏。第三约位明入法界者标也。于中有三。初约所入有因有果。次明能入唯渐与顿。后因果既其无碍下双结能所

疏。次正释文。然科二会总有四义。从总别圆融下融上四义。一总别圆融融第四总别本末无碍融第一本末二会略无第二因果相即第三渐顿该罗至下末会之初重会释之。从又前即亡修下通正圆融。兼前五对。而前四唯对本会故一时并举。后一通对诸会正宗故别明之

疏。西域记云。昔有古老仙人等者。即第六卷。然室罗筏即舍卫国。梵音楚夏耳。疏。多出聪敏博达人物者。总相言耳。然其此城说有四德。一者尘境德。六尘之境多美丽故。二财物德。七宝珍奇无不有故。三圣法德。三藏圣法无不备故四解脱德。人人皆有解脱分善得解脱者实繁广故。具此四德远闻诸国。故人物言为道相耳。亦表此经具此四德。一五种法界皆佛境故。二七圣财宝无不备故。三因果能证皆圣法故。四契入法界真解脱故。广说如来解脱海故。疏。逝多者。梵音华言战胜者。即波斯匿王所生太子。太子初生王战得胜故以为名。表依善友胜出魔军及凡小故。故上文云以表依人

疏。给孤独者梵云须达多者。经出太子梵语。疏出长者西音举长者德表具法财。能令一切证法界故。从长者侧金下出双举二人之由。西域记智度论庄严论等皆说只桓记中其事更广

疏。一得现观者。大乘唯识有六现观。一思二信三戒四智谛。五智谛边智谛六究竟现观。十地已辩。小乘俱舍有三现观。一见现观二缘现观三事。现观。今此正当见现观也。义兼后二

疏。二入正性离生者已见四地。无方便慧已见七地。若有方便不证实际

疏。三所学已穷者。谓于其自乘所学之法名为深入。非谓深入甚深法性。故引法华即三乘同入之法性耳。三兽渡河已见八地

疏。古人亦将上三等者。疏意云。见修是前三果。今是罗汉正当无学。后必具前理则可通故不言非

疏。四生分已尽等者。上即我生已尽。若具大悲留惑润生处有化物。今由阙悲但自速出如獐透围

疏。即逮得己利者。己利即证涅槃。有余依者名为有为。无余依者即无为耳

疏。六已尽有结者。经云离结使缚故。以九结释经结字。亦已见上。今略示名。一爱结二恚结三慢四无明五疑六见七取八嫉九悭。由此九种数数现起损恼自他。招当苦增偏名为结。十使谓六根本开见成五。此等以为生死因故名为有结。言现行离者故。法华经论此句即诸漏已尽。论为现行异得烦恼是种子故

疏。八心善解脱等者。二种解脱亦见上文。今略解云。离定障故名心解脱。离性障故名慧解脱。又离无明贪爱等体名慧解脱。彼相应心得离缚故名心解脱。由证此二获得第五有为无为二种功德

疏。十明非定性者。定性二乘非此宗故。言信入佛智者。法华第二汝舍利弗信佛语故。随顺此经非己智分。此经即佛惠故

疏。如来不思议境界经者。此是第一列众之中。经云。时有他方诸佛为欲庄严毗卢遮那道场众故。示菩萨形来入会坐。复有无量百千亿菩萨。下与疏全同。引此明实彰前定迹

疏。善入无际际者。深入无际实际故。然皆反上声闻之德类例可如

疏。九佛不共德等者。发心品菩萨于佛十力中。虽未证得亦无疑故

疏。十一切种智证信入者。证信即初地已上拣异声闻未得此信。十地皆依佛智海故。疏。大文第二请分下。疏犹叶公好龙者。事出庄子。叶公姓沉名诸梁。故春秋注云。叶公子高沈诸梁。食采于叶。僣以称公。亦有云。与楚同姓楚姓芊(绵婢切弭音)即子张见卫君君不全待子张云。公之好士犹叶公之好龙。叶公好龙。井厕之间皆画其像真龙知其好乃现其庭。叶公绝倒不敢视。叶公之好好于似龙。非好真龙。今君好士但好似士。非好真士也。今声闻之请法。若彼好龙不睹希奇若不识真物也

疏。以初十句明自体圆着下出所问法为两段所由。以前三十句内唯初十句是所请法。谓佛境等是佛自体圆满着明故。同果海绝言。最后十句化用普周者。然后三十句请随机演有二十句是所请法。以前十是请说往故偏举。后十化用正合开化故。疏故晋本拣择下。释上修在思前。晋经则闻思修不失次也。疏又此十句通有二意等者。谓既唯诸佛加等方知明是显深佛加既知故请佛加而演说也。非器难解有器可闻也

疏。一财等有殊者即十自在。谓一财二命三心四业五生六解七愿八通九智十法。广如八地离世间品

疏。七与初会名义全同者。则有二事名异义同。有一事此彼互无故有三类。第三类中乃有二意。后意亦是名异义同

疏。一因圆果成即佛海下上总明。此下别释。每一句内皆有二意。一当句解释。如云因果成。即经云往昔趣求一切智心一切智即果趣求之心即因。二云即佛海者。二即会同初会十海下诸句皆然。而当句释皆蹑前起如二云成必演法成必二字。蹑果成而起余可思准。九即安立海。大文第三三昧分

疏。今初无方大用下疏文有四。一明入定之由。二即以下辩次第。三佛自入下辩能入人。四不言答者下通妨

疏。就入因中等者。四悲即因

疏。又此四悲亦是从佛向机之渐次者。依悲之体入悲之门。以悲向前为化生之方便也。疏第三正明入定。疏文有三。初总标。二言嚬申下释名。三故依古德下释义。二中二先叙昔即刊定意。后然旧经下辩顺违。于中三。初明汉梵非类。如云修多罗修妒路素呾囕。虽则不同声势一类。其奋迅毗实言势天隔故。二涅槃二十五下引二文。证明是此言。三但敌对下纵成引梵为自在义

疏。故依古德下第三释义。先略后广。略中三。初二句结前生后。次嚬申奋迅下就喻辩相。后总相释下就法辩相。疏若别解者下第二广释。于中二。先总明所据。后开章正释。前中引于二文欲释师子。今初涅槃师子吼品。即南经二十五。若准北经当二十七。言广有喻合者。今当具出。此是师子吼菩萨请问如来。如来对众称赞令敬菩萨。即说其德名之由。故云今于我前欲师子吼。善男子。如师子王自知身力牙齿锋铓四足据地安住岩穴振尾出声。若有能具如是诸相。当知是则能师子吼。释曰。此下即说为十一事经一时合今先别合师子。经云。善男子如来正觉智慧牙爪四如意足六波罗蜜满足之身十力雄猛大悲为尾安住四禅清净窟宅。释曰。此即具有喻合合师子也

疏。又离世间品下二引当经。言为身等者。等取下经。下经云。四谛为其足正念以为颈。慈眼智慧首。顶髻解脱缯。胜义空谷中吼法怖群魔。言未必楷定者。生下喻合不全依于上二经文。又如宝云经第三亦云。善男子。复有十法譬如师子。何等为十。谓无所畏。不畏大众去终不还能师子吼。具足辩才乐处林野在于山窟。摧伏大众具勇猛力善能守护。彼广释之。故此师子与上二经又复不同。明知不必楷定喻合但取义便耳

疏。今会取诸文下。第二开章正释先标二章。后今初下别释。但取此中义便故。总取诸意会成一说。结云如此师子随一一毛皆称法界者。即金师子章意。如金师子毛。毛尽金法界师子何非法界可知

疏。次言为十一事下释第二章。于中又二。先合十一事而又此中法喻双辩。仍取涅槃之意。以就今经。今先具引涅槃之文。未见彼文难晓会故。彼经喻云。真师子王晨朝出穴。嚬申欠呿四向顾望发声振吼。为十一事。何等十一。一为欲坏实非师子诈作师子故。二为欲试自身力故。三为欲令住处净故。四为诸师子知处所故。五为群辈无怖心故。六为眠者得觉悟故。七为一切放逸诸兽不放逸故。八为诸兽来依附故。九为欲调大香象故。十为教告诸子息故。十一为欲庄严自眷属故。一切禽兽为师子吼。水性之属潜没深渊。陆行之类藏伏窟穴。飞者堕落。诸大香象怖走失粪。诸善男子如彼野干。虽逐师子至于百年。终不能作师子吼也。若师子子始满三年则能哮吼。如师子王。释曰。此下经合喻。先合师子已如上引。次合为十一事云。一为诸众生。而师子吼摧破魔军。二示众十力。三开佛行处。四为诸邪见作归依所。五安抚生死怖畏之众。六觉悟无明睡眠众生。七行恶法者为作悔心。八开示邪见一切众生令知六师非师子故。九破富兰那等憍慢心故。十为令二乘生悔心故。为教五位诸菩萨等生大力故。十一为令正见四部之众。于彼邪见四部徒众不生怖畏等。从圣行梵行天行窟宅嚬申而出。为欲令诸众生等破憍慢故。欠呿为令诸众生等生善法故。四向顾望为令众生得四无碍故。四足据地为令众生具足安住尸波罗蜜故。师子吼者。名决定说一切众生悉有佛性如来常住无有变易。善男子声闻缘觉虽复随逐如来世尊无量百千阿僧祇劫。而亦不能作师子吼。十住菩萨若能修行是三行处。当知是则能师子吼。释曰。上两节引经喻合一段义尽。既知彼意今当正合。今此疏文分二。初合十一事。二合随逐略不合嚬申欠呿等。以彼经文对观今疏则主客自分。如初摧破诈师子吼故。即是喻文。若云摧破魔军即是合文。此全同彼故无别义。二示众等者。如云示身力故。即是彼喻。若云示众十力即是彼合其神力及等力。即是今经是彼之例非同彼文。此中正明如来入法界定现神力故。故加神力。而言等力者。十力但明十种智力。今等力者。谓法界力。若三昧力若功德力但有力义。即是身力耳。下出所因中即是力相。三中彼经但以开佛行处合令住处净。此经则以净法界土则法合小异。余七同异可以意得

疏。又野干下。第二合随逐师子可知。疏。五十七中十奋迅等者。经云。佛子菩萨摩诃萨有十种奋迅。何等为十。所谓牛王奋迅映蔽一切天龙夜叉乾闼婆等诸大众故。象王奋迅心善调柔荷负一切诸众生故。龙王奋迅兴大法蜜云曜解脱电光。震如实义雷降诸根力觉分禅定解脱三昧甘露雨故。大金翅鸟王奋迅竭贪爱水。破愚痴[穀-禾+卵]搏撮烦恼诸恶毒龙。令出生死大苦海故。大师子王奋迅。安住平等大智以为器仗。催伏众魔及外道故。此五有喻下但约法六勇健奋迅七大智八陀罗尼九辩才十如来奋迅一切智悉成满等。广如彼说

疏。谓严阁显自体缘起者。法界体上缘起万德。依此自体有为无为中。故此三缘起即光统意。谓破情显法者。约心即事会真约境。疏下之三段兼亦别答前来问中。后二十句者。上来七方唯通答二十句。中前十中一句。此下三方通答二十句中三句。而上下二方兼别答耳

疏。九下方毛孔中十句。答前九问者。以前十中神通一问前七方答竟故据下释中既五句答因五问四句答果五问何名答九以神通问重别显故然则前已广答故但云九疏此句应显趣求者以文云出说一切三世菩萨行方便海音声云故标云答行以互正答行故此一句义显趣求一切智心以是行始言修行耳

疏。然问就如来因中等者。通将此中对问辩异

疏。其助道下出不答余因句之相上通答方便更加此助道出离。则此下方通答三因别答五因兼上方便又通答二问一本事因缘二所入诸地故具答十因其上方中波罗蜜问义便故重。疏别约初句答入一切众生所住处等者上辩通答因中二句此下别答果中三句前下方有五句问答此有三句并第八问答第十影像及现相答国土故十问具矣。疏其答问中或不次者下料拣次第

疏。又皆言下通释本事之言。此约法性宗释文中有三。初正释以法性常住相即性。故相亦常矣。此即与体非异不坏三世。与体非一性相本尔。即德相门。随其令见即业用门故双结二皆得自在。凡但理然不得德相成业用耳。二故密严下引证。先证业用。后乃至云净所依止者证德相门。三若理事别修下拣异他宗。现法体用俱有等即大乘义。况于小乘即有宗义。以彼过未有体无用者出异所以。有宗过去冥伏有未来性有故有体也不同现法事有故无用也。今以体性融故。体用俱有。斯即有即非有非有之有耳。疏亦名三种三业者一名近佛三业。二摄化三业。三神通三业。疏下四倒明四辩者。初句乐说无碍。二得一切下词无碍。三于虚空法界下义无碍。四知一切法下法无碍。大文第五举失分

疏。今初舍利弗然诸弟子古今译殊。今多依罗什三藏。言鹙鹭者。大乘法师云。是百舌鸟。亦云春莺。古德引经亦云。其母辩才如彼鸟故。此中是旧梵语。新云奢利弗怛罗弗怛罗即子也。又舍利亦翻为身。母好身品故。或舍利云珠。母之聪利相在眼珠故。并从母之称。增一云。我佛法中。智慧无穷决了诸疑者。舍利弗第一。智论四十一。称为如来左面弟子。父名优婆提舍

疏。目连梵语即古译义即新译。新梵语云摩诃没特伽罗。然疏约从母氏得名。若从父称此名俱利迦。亦云俱俪多。亦云俱律陀。此云吉占。智论云。舍利弗以才明见贵。目连豪彦最重。智艺相比德行互同。增一云。我弟子中神通轻举飞到十方者。大目连第一。智论四十一称为右面弟子。焚德胜之殿蹴耆域之车。压调达五百之徒。寻佛声过恒河沙界德难称也

疏。此云饮光者。真谛等同译为饮光。上古译云龟氏。其先学道灵龟负图应之。因以命族。增一阿含云。罗阅只大富长者名迦毗罗。妇名檀那子名毕钵罗。子妇名婆陀。其家千倍胜瓶沙王。十六大国无与为邻。毕钵罗即迦叶名也。其父祷此树而生故。付法藏传云。毗婆尸佛灭后。其塔中像金色缺坏。时有贫女得金珠请匠打为箔。金师欢喜治莹佛毕立誓为夫妇。九十一劫天上人中。身恒金色恒受快乐。最后为迦叶夫妇。畏胜王得罪减一犁。但用九百九十九双牛金犁。又经云。其家有[疊*毛]最下品者直百千两金。以钉钉入地十尺。毡不穿破如本不异。六十库金粟。一库管三百四十斛。又经云。以麦饭供养辟支佛。恒趣忉利各千返。受乐身三十二相。但论金色耳。剡浮那陀金在浊水底。光彻水上在暗暗灭。迦叶身光。胜于此金光照一由旬。增一云。佛法中行十二头陀难行苦行。大迦叶第一。言拣余迦叶者。即如十力迦叶优楼频螺等

疏。离波多此云室星。其言即古今同释。法华云离婆多。新云颉丽伐多。当梵音轻重。或云所供养者。即音义释也。假和合古今同也

疏。即智论二鬼食人之事者。谓此人行涉空亭止宿。见二鬼争尸。皆言我先持来。二鬼共言取其分判。此人实见小鬼持来。及被鬼问。窃自思惟。我随言一持来。彼不得者必当见害我。宁实语而死终不虚诳而终遂如实答小者持来。被其大鬼拔其手足。随而食之。得尸之鬼便取其死尸手足随安。彼鬼食竟拭口而去。及明忧恼不恻谁身言假和合。初常疑云。若我本身眼见拔去。若是他身复随我行住。疑惑犹预逢人即问。汝见我身不众僧见之云此人易度。而语之云。汝身本是他之遗体非己有也。悟此假合因即得道。以常问故。故云常作声也

疏。生而室空者。相师占云。是善相故亦云善吉。亦云空生。其义一耳。解空第一得无诤三昧有供养者。现与其福故云善吉

疏。阿[少/兔]楼驮等者。亦云阿泥[少/兔]豆。或云阿那律。亦云阿泥噜多。并梵音楚夏。皆云无灭。亦云无贫。言一食之施者。贤愚经说。弗沙佛末世时饥馑。有辟支佛名利吒。行乞空钵无获。有一贫人见而悲怜白言。胜士能受稗不。即以所啖奉之。食已作十八变。后更采稗有兔跳抱其背变为死人。无伴得脱待暗还家。委之于地成金人。拔指随生用却还出取之无尽。恶人告王欲来夺之但见死尸。而其所睹即是金宝。乃是现报若是。九十一反即果报也。又其生已后家业丰溢日夜增益。父母欲试之。盖空器皿往送拨看百味俱足。而其门下日日常有一万六千。取债一万六千。还直出家已。后随所至处人见欢喜。欲有所须如己家无异。即世尊之堂弟斛饭王之次子也

疏。难陀等者。即放牛难陀

疏。劫宾那者。疏释即音义中大乘及天台等旧译为房宿。然有二义。一以父母祷此宿星感此子生故。二云与佛同房宿故。谓初出家时未见佛。始向佛所夜值雨。寄宿陶师房中以草为座。晚又一比丘寄宿。即推草座与之自在地坐。中夜相问欲何所之。答云觅佛。后比丘即说法辞去豁然得道。后比丘即佛也。增一阿含云。我佛法中善知星宿日月者。劫宾那第一。则亦从所知为名

疏。迦旃延者。即大乘法师释。谓上古多仙山中静处年岁既久。鬓发稍长无人为剃。婆罗门法要剃发故。一仙有子兄弟二人俱来观父。小者乃为诸仙剃之。诸仙愿护后成仙道。尔来此种皆称剪剃。疏富楼那具云满慈子者。梵语云弥多罗尼子。满愿。是父名。父于江边祷梵天求子正值江满。又梦七宝器盛满中宝入母怀。母遂怀子父愿获满。从此立名。母名弥多罗尼。此云慈行。亦云四围陀中有此品名。其母诵之以此为名。尼者女声也。以母詺子名为慈子。增一云。善能广说分别义理。满愿子最第一

疏。如智论及音义说者。音义略说已如上引。智论多说缘起即引四阿含等经。然其列名或从德行胜劣。或从出家先后。如法华阿若憍陈如在初等故。报恩经说。初度五人次度耶舍门徒五十人。次度优楼频螺门徒五百。次度伽耶门徒三百。次度那提门徒二百。次度身子门徒一百。次度目连门徒一百。今举大数成一千二百五十人。若十二游经兼出其年云。佛成道第一年度五人。第二年度三迦叶。第五年度身子目连。则尔后更多。故法华初有万二千罗汉。后二千学无学等。今此但举五百以从胜劣列之。即法华第三周第一与记者。体德大同故。故成佛名号等亦皆同也。望今本门即皆大菩萨故偏举之

疏。多同念请果中初之十句者。神力即前如来力。严好即前如来身。境界全同。游戏即前自在神变亦是三昧。三昧现故。尊胜即如来智。如来智最胜故。妙行即前智行。威德即前无畏。住持即前加持故皆同也。前来心念佛向示之皆不见耳。重阁同空下略示向来神变及游戏相

疏。法华游戏神通等者。举法华拣异亦是通妨。今云拣异者。即法华信解品四大声闻自叙云。世尊往昔说法既久我时在座身体疲懈。但念空无相无作。于菩萨法游戏神通净佛国土成就众生心不喜乐。即闻而不乐也。下偈兼出不乐所以。云一切诸法皆悉空寂。无生无灭无大无小无漏无为。如是思惟不生喜乐。释曰。既了无生故不喜乐。是以结云勿滞冥寂。故八地云。诸法真常离心念。二乘于此亦能得也。言通妨者。此何令其不闻彼何令其得闻。此义至下释之。既本下结劝修实

疏。所无在前者。即前无如是善根故。无如是智眼故等

疏。此段亦同法华自释等者。亦信解品。言自释不喜乐者。彼前文心不喜乐。后便云何以故等。如疏意云。世尊昔说声闻有究竟极果。我今已证故。菩萨法非我所学故不乐也。既已得证即住自乘故。虽上根身子乐十力等。而复自嗟我无此物。疏一道者。即释经成就声闻道。言见修等者等取方便及无学也。言断惑集者。集即集谛通于业惑。菩萨无住等者。等取教道证道一道二道乃至无量道。而教证等名二乘亦有。特与异者。即无住道。若约其义教证亦殊。故云等也。第二喻显中先总料拣。次随文释后逆配阙因十句前中二先叙昔总许。后今解有二下申今正义。便弹古义以举今正。拣昔成非故。于中先通中二。一总辩摽通。通有二义。一通因果二通喻诸句。后以合文下引证辩通。文有三节。一正引文证通于菩萨。二又不喻下反以义证。合通菩萨。三又合文中下。正引文证通喻诸德。疏二者别喻等者。亦举正以拣昔非。于中有八。一总出别喻之由即反显也。二然虽别下拣异昔非。三而前九下通明十喻异相。四于前九中下总示别喻德相。五又第一五十下约迷悟之人拣其喻相。六又唯约声闻下别示迷者异相。七且就前九下将欲释文重拣第三诸喻别相。八前九德中下通收通别二意

疏。今初鬼对恒河下疏文有二。先总显喻意。后言饿鬼等下牒释经文。十喻皆然。言生分已尽为鬼者。如鬼已舍生人故疏。即是业余者三。余之义已见上文然。总相说以无漏有分别业名为业余。今未得无生未得法界未证真解脱皆分别也。行苦所迁者苦余。即变易生死意生身。此约已入无余者。今约未入无余已得有余余苦依身即苦行也。疏空见为乌鹫下皆是烦恼余。然烦恼余通是无明住地。即是智障。智障有二。一所知之障。即以业障喻所知之障。故云蔽其眼故。二所知即障故。经云智障甚盲冥。谓真俗别执。今于有无作决定解。即真俗别执故。是知障鸟归虚空故喻空见。兽依于地故喻有见。不同法华鸱枭雕鹫等喻界内烦恼

疏。虽睹世尊下此明二乘但见自分境界耳。五俱邻等最初受道。岂见世尊始成正觉身遍十方智入三际等

疏。不曾已下合裸形等者。无生忍衣法界行食。皆一切智诸善根也

疏。及菩萨大会下十一句者。谓一菩萨大会。二菩萨普入。三菩萨普至四普诣五神变六游戏七眷属八方所九庄严师子座十宫殿十一菩萨住处。今文梦往须弥。即普至普诣普入善见大城等宫殿。即菩萨宫殿。城池园林即是住处。天子天女即眷属。开华奏乐即是神变。歌咏戏乐即是游戏。住止周旋即有座矣

疏。然此下八喻亦约二乘料拣。以初一喻声闻。但有不得法喜之一德耳。故此下八具于通别

疏。喻菩萨所入三昧及观察嚬申勇猛供养如喻思之者。然合文自具。若约喻者。伏藏犹如三昧。聪慧分别即是观察。随欲而取即是嚬申。有福力即当勇猛。奉养父母即供养也

疏。喻菩萨受记等者。不能采取即无勇猛不得受用。即无受记成就义也

疏。喻菩萨法身下五句者。即菩萨法身清净菩萨智身圆满愿身示现色身成就菩萨诸相具足。释曰。五句不出菩萨形相威仪

疏。言遍处等者。疏文有三。初释名二会释三会通经意。今初俱舍颂云。遍处有十种八如净解脱。后二净无色缘自地四蕴。论云。谓八自性皆是无贪。若并助伴五蕴为性。又云。有余师说。唯风遍处缘所触中风界为性。言八者。即青黄赤白地水火风。如今经辩。论云依第四静虑者。缘欲可见色。如净解脱。后二如次空识二处。若无色为其自性凡缘自性各缘自地四蕴为性。应知。此中修行者。从诸解脱入诸胜处。从诸胜处入此遍处。以后后智胜前前故为修解脱。但于所缘总取净相。未能分别青黄赤白。后四胜处虽能分别青黄赤白。而未能作无边行相。前四遍处谓观青等一一无边。余如疏辩。言胜处者。颂云胜处有八种。二如初解脱。次二如第二。后四如第三。谓前二解脱各分多少有四。后四即青黄赤白。能制伏心缘境处故名胜处

疏。然瑜伽智论下第二引论会释。于中五。一双标经论。二先观青等下依俱舍释相。三前八依第四下辩所依定已如上引。四瑜伽十二云下明其建立。于中有二。先问。后由此二种下答问。言色触者。问意云何。以十二处中唯依二处。谓青黄赤白是色处。地水火风是触处。以坚湿暖动是身所触故。答中二。先明立二之由。此有三义次下当知。后从眼等下明于十处不立遍处所以。亦有三节。次第对上。一眼等根色唯属自身者。对上通自他身。二香味二尘不遍一切者。对上遍有色界。以二禅已上无鼻舌识故。亦无香味二尘。三声尘有间者。对上常相续故。声发即闻不发不闻故。有间断言是故不说者。通结上三节。于十色处中不说八色处为遍处也。五无色界下释于后二。可知

疏。今已宗别下第三会通经意。于中二。先以经会论。后例此下以论例经。重释前天遍处。谓上论所拣今皆取之例天遍亦可通所拣

疏。第九二天随人可知

疏。第十灭定不行喻者。然灭定之义六地已略明。今当更说。萨婆多宗此定唯依有顶地起。以下诸地皆名有想。行相粗动难可止息。此有顶地名为非想。行相微细易可止息故。唯有顶有灭尽定。俱舍颂云。灭尽定名体为净住有顶。谓灭尽定以二十二法为体。谓修定前有二十一心所及心王故。言二十一心所者。谓大地十大善地十。欣厌随一为灭定故。有二十二法不相应行替处名为灭定。随灭尔许心心所法为定体也。若成实论第十六灭定品云。问曰。若此中意以泥洹为灭者。是汝先言。九次第定中灭定心心数灭是则相违。答曰。灭定有二。一诸烦恼尽。二烦恼未尽。烦恼尽者在解脱中。烦恼未尽在次第中。一灭烦恼故名灭定。二灭心心数法故名灭定。灭烦恼是第八解脱。亦名阿罗汉果。若唯识第七云。灭尽定者谓有学无学(即罗汉及独觉辟支)或有学(即三果身证阿那含)已伏惑障无所有贪(谓无所有已下诸贪灭)上贪不定(已上贪未灭也)由止息想作意为先。令不恒行(六识)恒行染污(染污第七)心心所灭(合上二识俱不行故)令身安和故亦名定(谓有心定令身令心平等安怗和悦为安和今无心定由定前心力能令身心平等和悦如有心定故亦名定)由偏厌想受亦名灭彼定也(即加行心)显扬第一云。灭尽定者。谓已离无所有处欲。或入非非想处定。或复上进入无想定。或复上进由起暂息想作意前方便故。止息所缘不恒行诸心心法。及恒行一分诸心心法灭。余文可知。疏又上十喻从后逆次配前阙因。后之十句者。疏但出三。谓一鬼对恒河喻。喻无法喜法喜为食故。二梦游天宫喻。喻不知菩萨如梦幻故此相甚显。三愚对雪山喻。喻不从如来加被之所生故。彼合经云。以诸菩萨入智境界。具自在力得见如来神变自在。即如来加被之力。其捕猎者。即无加被也。四伏藏难知喻。喻本不发一切菩萨诸大愿力故。谓无福力即阙大愿。五盲不见宝喻。喻本不求超出世间。不共菩提诸善根。故无眼不见于宝即阙不共善根。六净眼无障喻。喻本不得诸菩萨眼所知境故。此喻更显诸人不见。喻于二乘不见净眼境故。七遍处定境喻。喻本不得严净佛刹神通智故。青等遍净即净刹也。八妙药翳形喻。喻本不成就如来出世诸善根故。翳形药即出世善根。九二天随人喻。喻本不修习生一切智诸善根故。二天见之。即一切智人不见天故无此也。十灭定不行喻。喻本在生死流转之时。不劝众生求于最胜大智眼故。诸识不行岂当有眼。故于六境都不见知。是故十喻对前十因。文相甚显令如理思

疏。其前十句但通为不见之因者。即前本不修习见佛自在善根故。本不赞说十方世界。一切诸佛刹清净功德等别相。不显逆顺配之俱不全似故。但通为不见之因。欲显具于通别义故。疏第三何以故下。征以结成。疏文分二。先正释文。后通妨难。今初言余皆如次者。一如来境界甚深。结鬼对恒河喻。二广大结梦游天宫喻。三难见结愚对雪山喻。四难知结伏藏难知喻。五难测结盲不见宝喻。六难量结净眼无障喻。七超诸世间结遍处定境喻。八不思议结妙药翳形喻。九无能坏者。结二天随人喻。十非是一切二乘境界。结灭定不行喻。六根作业皆不行故。其间文意极相顺故

疏。上来法喻下。第二会通妨难。于中三。初结前文以为难本。二难三释。二中引于三经而有二难。一引大品难无现缘。言若智若断者。彼经具云须陀洹若智若断皆是菩萨无生法忍。斯陀含若智若断皆是菩萨无生法忍。阿那含若智若断皆是菩萨无生法忍。阿罗汉辟支佛皆别之。若智若断皆是菩萨无生法忍。下结难可知。疏。又文殊巡行经下。后引二经难不令闻。今此一经略以义引耳若具引者名文殊师利巡行经。以经说文殊遍巡五百比丘房。皆见寂定因以为名。最后难舍利弗。以显甚深般若。问舍利弗言。我时见汝独处一房结跏趺坐。折伏其身。汝为当坐禅耶不耶。答云坐。难云。为当欲令未断者断故坐禅耶等。因此广显性空无得之理也。时五百比丘从座而起。于世尊前高声唱言。从今已去更不须见文殊身。不须闻其名字。如是方处速应舍离。所有文殊一切住处亦莫趣向。所以者何。文殊烦恼解脱一相说故等。舍利弗令文殊为决了。文殊言。实无文殊而可得故。若实无文殊可得者彼亦不可见等。广为说法四百比丘漏尽得果。一百更谤陷入地狱。后还得道广如彼说。故云五百比丘闻而不信。意云何。以此会不令其闻而不信耶。疏。法华不轻亦令其闻者。引意同前。即第六经常不轻菩萨品。不轻遍礼四众云。我不轻汝等。汝等行菩萨道皆当作佛。即宣一切众生皆有佛性。如来知见平等之理为令闻也。众人或以杖木瓦石而打掷之。复于千劫入阿鼻地狱受大苦恼。从地狱出还遇常不轻教化。即跋陀婆罗等菩萨。既二经之中皆令其闻。一时之谤后皆成益今何不尔也。疏答为显不共下。第三会释于中五。一显不共般若。二显化仪不同。三明通局有殊。四约开显有异。五者结成缘起。今初。不共般若已如前引。若准天台意前以通教难于圆别。今以圆别拣异于通

疏。又大圣化仪下。第二化仪不同也。于中四。一通上巡行法华之问。二或以威力下。拣外谤显。彼经云众中之糟糠佛威德故去。三或令在会下。即通前所难。四然法华下。会释二经此依化仪渐顿二教通释经意法华是渐者化仪渐故。先说三乘引导众生。然后但以大乘而度脱之。故云渐也。非法门为渐。言将收败种者义如前引。谓二乘结断如根败士无利五欲。如燋谷子不能生芽即昔教意。今至法华三根声闻皆得记别。不在此会亦为宣陈则燋谷生芽。盲聋视听死尸再起。寒灰重热。而言将收者尚未广说。先且斥之使在会者自欣多幸故云笃励。是以经云。此众无枝叶唯有诸贞实。关中云。繁柯既亡则贞干存焉。广说之后方复收之。故不在会亦合为说。言此经顿教之始者。初成顿说故未有滞权不须引斥。直彰不共显法难思。在会不闻由无因种。若修因种于何不闻。故云令修见闻种

疏。又复大乘该于小乘下。第三通局有殊也。小乘犹如百川不摄大海。大乘犹如大海必摄百川。言小智不知大智者。即庄子意。彼云小智不测大智。小年不测大年。朝菌不知晦朔。蟪蛄不知春秋。小乘萤光岂知日照

疏。又若以开显下。第四开显有殊。法华对昔以权覆实故。今开显万行同归华严。直显一实深玄。须对权令知故如聋哑。于中三。初法说。二其犹下况喻。三是以若约下法合

疏。既非其器下。第五结成缘起。即是华严圆教别来之意也。大文第六偈颂分可知大文第七开发分

疏。此法句望前方便。即是所用者。此有三重能所。一普贤是能有方便是所有。二方便是能用法句是所用。三法句是能开三昧境为所开。大文第八毫光示益分

疏。即此能入亦是所益者。此有两重能所。一遮那光照是其能益。得解等十即是所益。二此解三昧等是其能入。法身色身等即是所入。不因佛光不得能入。不得能入安得所入。故能所入皆是成益也

疏。总句即前三昧结中者。前总明所入有十一句。初一是总今不别广。即前三昧结中是广上总。上总云是故皆得入于如来不可思议甚深三昧。尽法界虚空界大神通力。今广中三昧结。云菩萨以如是等不可说佛刹微尘数三昧。入毗卢遮那如来。念念充满一切法界三昧神变海。是故三昧结即前总句。此下但广前别十句耳。而言不次者。此一即前六。二即前五。三即前四。四即前九。五即前三。六即前一。七即前二。八即前十。九即前八。十即前七。文并可知。大文第九文殊述德分。大文第十大用无涯分

疏。故知善财诸友即此会之菩萨者。如独一无侣即德云等。二沙门即海云善住等。三婆罗门即最胜寂静等。四苦行即胜热等。五充盛即善见休舍等。六医王即普眼弥伽等。七商主即无上胜等。八净命亦婆罗门。义当不动具足等。八妓乐者义当婆须等。九奉事天身即大天等。十工合伎术。即自在主童子等故皆同也

大方广佛华严经随疏演义钞卷第八十四大方广佛华严经随疏演义钞卷第八十五

        唐清凉山大华严寺沙门澄观述

第二末会疏。今初夫圆满教海下。此文有二。先标。后故非顿下释。前标有三对。今疏释有二。一出三对之由。二明该罗等义。今初。若无顿证法界。岂显此经圆妙。若无善财渐进众生如何趣入。若无本会佛为其主。何有末会皆得成经。若无末会善财成益。岂显本会顿证之实。然此一对语出肇公维摩注序。彼以不思议中以分本末云。此经所明统万行则以权智为主。树德本则以六度为根。济蒙惑则以慈悲为首。语宗极则以不二为言。凡此众说皆不思议之本也。至若借座灯王请饭香土手接大千室包乾象。不思议迹也。然幽关难辩圣应不同。非本无以垂迹。非迹无以显本。本迹虽殊不思议一也。今但借其言不取其义。自以二会为本末耳。非人无以证法者。法无废兴弘之由人故。非法无以成人者。不证性原岂名菩萨。故中论云。以法知有人以人知有法。离法何有人离人何有法

疏。故前明不异渐之顿下。第二明该罗等义。三对为三。一明渐顿该罗。二互不异即该罗义。其多门而众人同契。即不异渐之顿相也。上不坏多门入法身等。十种别故即是渐义。众人同契即是顿义。或一人证多。或多人同证故即顿也。一人历位即是渐相。而圆修故不异顿也。二前即不异末之本等者。本末交映也。虽卷而恒舒即不异末之本相也。卷谓不离祇园。而恒舒者而罗身云于法界也。言虽舒而恒卷者。谓虽罗形于法界。而未动足于祇园。是不异本之末也。本末无碍下结第二门。三今托人进修下释人法融会也。语则不似前二但似结成。今会意亦具矣。谓托人修进者。人融法也。使大教弘通法成人也。言即斯本意者。语则正结第三意。则通结上二成总显会意也

疏。二会数开合中二。先局。言二诸乘人会者。即初至福城东会也。后若约能所下明通。于中三。一标数。就第三会开五十三成五十五。二虽人有五十四下。次释成上义。言五十四者。善财初遇文殊从德云至瞿波。有四十人寄于三贤十圣。摩耶已下天主光等有十一人。已五十二及弥勒普贤故五十四。举此五十四者。乃成会违。一向都望人五十四。兼比丘诸乘二会则合有五十六会。若望善财并见五十四人。即合自有五十四会。何以惟五十三。故下释云。文殊一人四会说故。故虽五十四人有五十五会。若尔一人四会。即五十四中加三成五十七。何言五十五。故次下云。德生有德同一会故。又减其一遍友不成会。又减其一人亦五十五。若取遍友成一会故。善财有五十六兼前五十六。为遍友不成主伴。但标五十五耳。疏是以唯就能化下结成通义。疏若约主伴下开成百一十。下有三释。正义一人当两故。故前案定为五十五。从若约散说下三约教结成。疏三会主多少。如上开合应自知之。疏四定会名义者。谓无佛说而称经会者。以本统末故。言滥觞者滥泛也。觞杯也。谓江出岷山。初出之源但可泛一杯而已。所出虽少源在于此。故虽千里万里而云江出岷山。故虽散在诸方而云经会。疏若尔下解妨可知。疏五二位统收者。别有三圣圆融观。大意此已尽矣。但普贤所信所证。虽是一理而约生约佛位分染净异。故分之成二。疏又理开体用等者。此即三圣观中会归经题。理开体用。即大方广。大即体性包含。方广业用周遍。故智分因果。即佛华严。佛是果智。华即因故。疏先以二门各自圆融者。初融文殊信解智三。后依体起行下。融普贤所信及行并所证三。疏是以文殊三事下。总结上三。虽开两段义有三重。一二圣三事各自圆融。二二圣三事各对圆融。三总融二圣。谓初三事既自圆融。次以三事各对圆融故。其六法但成一味。而言文殊三事融通隐隐者。信智圆融不坏相故。普贤三事涉入重重者。以理融事。事不泯故。若二不二成毗卢遮那。则文殊是华严。普贤是大方广。冥合为佛。为佛已竟无二味故。故前本会下引文证成。非情见故。疏六分五相有三。初双标。二二皆下双会。三具依下正释。疏照前行等唯一圆智者。行即寄位修行等取次二。四其后四相下。此立别理则不坏。依五相中三。一总为寄位修行。二今从下且为五相却归前释。三此五下别义料拣。言五行者一历位上升故云高行。二同入一实故为大行。三具上高大成补处因故名胜行。四般若绝相故称为深。五一一称性故云广也。疏不出二十类者。此二十类摄五十四人菩萨摄五。一文殊。二观自在。三正趣。四弥勒。五普贤。二比丘摄五。一德云。二海云。三善住。四海幢。五善见。三尼唯一。即师子嚬申。四优婆塞唯一。即明智居士。五优婆夷摄五。一休舍。二具足。三不动。四婆须蜜。五贤圣。六童男摄三。一自在主。二善知众艺。三德生。七童女摄二。一慈行。二有德。八天唯一。即大天是。九天女亦一。即天主光。十外道亦一。即是遍行。十一婆罗门摄二。一胜热。二最寂静。十二长者摄九。一解脱。二法宝髻。三普眼。四优钵罗华。五无上胜。六鞞瑟胝罗。七坚固解脱。八妙月。九无胜军。十三先生唯一。即遍友。十四医人亦一。即弥伽。十五船师即婆施罗。十六国王摄二。一无厌足。二大光。十七仙人唯一。谓毗目瞿沙。十八佛母唯摩耶夫人。十九佛妃唯瞿波。二十诸神摄其十。一安住地神。二婆珊婆演底夜神。三普德净光夜神。四喜目观察夜神。五普救众生妙德夜神。六寂静音海夜神。七守护一切城增长威力夜神。八开敷一切树华夜神。九大愿精进力救护一切众生夜神。十岚毗尼林神。即圆满光故。二十类摄五十四。疏四约相辩异不出菩萨五生者。即瑜伽四十八品中辨。一息苦生亦名除灾。如为大鱼等即饥世救苦海中救苦等。二随类者随一切类故。三胜生。亦名大势生。谓形色族姓富贵等。四增上生。从初地至十地。为诸王等。五最后生。即最后身菩萨。今小不同者意将彼义摄此友故。摄论第六明胜生亦名最胜生。谓诸世间安乐生处。应知此是说法功德。疏通即前四各具五生者。向就第四约相有五。今通于前果因及义亦各具五耳。疏于中菩萨有六者。即二十类中就最后而辨异也。等取文殊及普贤也。疏三现相者。如大天等。四表义者。如山表位如海表悲等。疏叉前依佛法界流等者。约表说法也。疏比丘义如常者。古有五义。一曰怖魔。初出家时魔宫动故。二言乞士。下从居士乞食以资身。上从诸佛乞法以练神故。三名净戒。持戒渐入僧数应持戒故。四云净命。既受戒已所起三业以无贪故。不依于贪邪活命故。五曰破恶。渐依圣道灭烦恼故。新云苾刍。苾刍草名具五德故。疏于我无我得不二解等者。即释经诸世间主雨供具云等。以主即自在义。既我无我不二方为自在。此即净名迦旃延章。五非常义前三地已引。即于我无我而不二。是无我义。无我法中有真我故。二约表者。诸佛显扬皆依般若等者。文殊表般若。若无般若不能说故。已是一义。究竟下又表所说。虽复千差究竟至于一切种智故。放光还入智顶。后句即法华意。疏若无爱见而修则无疲矣。即净名问疾品意。前文已引。疏一眼具斯四用故称无碍者。正是上第三义也。第六十二经疏表顺福分善者。十信为顺福分善。三贤为顺解脱分善。所修善根顺趣解脱故。四加行位名顺决择分善。顺趣真实决择分故。决择即是道义。如十地。今表十信故是顺福。疏不别演说故非别会者。以刊定记开此诸乘人会为两会。谓三摄诸龙会。四摄诸乘人会。故今遮其谬释。自下第三摄善财会。疏唯初信内有三会者。问此摄善财何以笼前二会。答以通末会为五相故。故初二会是十信收。而善财中自具五相。最初信位义兼前二故。就此序。疏三示方不同此段有四。一总辨类殊。二别释南义。三对类料拣。四叙昔顺违。今初即总收诸友以为三类。言地前多在南者。以正趣一人从东方来不言南故。言地内无方者。从婆珊婆下有十善友皆无南故。言地后兼二者。瞿波指于摩耶。但云此世界中有佛母即不云南。摩耶指天主光。云此世界三十三天。天主光指遍友。言迦毗罗城有童子师。遍友指众艺。云此有童子。众艺指贤圣。云此摩竭提国有优婆夷。此上五会皆无南也。贤圣指坚固解脱长者。即云南方有城名为沃田彼有长者。坚固指妙月。但云即此城中有一长者。妙月指无胜军。即云于此南方有城名为出生彼有长者。无胜军指最寂静。亦云于此城南方有一聚落名之为法彼有婆罗门。最寂静指德生有德。亦云于此南方有城名妙意华门。德生指于慈氏。亦云于此南方有国名海岸。文殊普贤二俱无方地。后三相有十三会。五会有南八会无南故云兼二。疏然南方者下第二别释南义。疏南方之明万物相见者。即周易说卦中义。易曰。离者明也。万物皆相见南方之卦也。圣人南面而听天下向明而治。盖取于此也。疏北主于阴显是灭义者。亦周易意说。卦云。坎者水也。正北方之卦坎也。万物之所归也。世尊金棺下引内教证义。如前引余可知。疏此五义中下第三对类料拣。对前三类亦可思之。疏有人唯取下四叙昔顺违。即苑公意于中三。一叙其所立故。彼疏序云。善财询友表随顺以南行。二非前下叙其破古。谓正明之义既出周易故是此方耳。三宁知西域下今疏破之。此有二意。一则正斥其破。既未寻西域内外典诰。安知西方无正明义。亦如今人相承。皆云此方立于四时。西方但明三际。及见西域记。彼亦立其四时。但以正月十六为春首耳。是以未能周览无信凡情。二况通方下为其立理。小乘教说。虽非我所制例于余方所不应行者。亦不应行名曰随方毗尼。况于大乘。况华严通方之说。一说一切说随类随方一时普应。何但义求。疏无此二缘不叹者。略者如休舍优婆夷及天主光后诸善知识。疏婆须达者以此文中复有须达长者。故释此一拣异初会精舍之主。疏财多属依者。亦有法财故云多也。疏今初由已发心故下疏文有三。一总出说因也。二此菩提心下问。三古有多释下释。于中四。一叙其上古。二有云古不足依下叙其下古。破昔自立。三然此师下破其下古。有二意。一纵破显不异昔。下古即刊定记也。二又以此文为证下。夺破显其引证难凭。以违余文故。四贤者云下叙其中古。以为正义。于中亦四。一正叙昔义。二若尔下叙昔成立。于上三生之中揩定。今解行生为是何位故先自问。从谓以在信下自答。三此之一解下疏辩顺违。于中先正许顺理。后但更有下疏正其释。以向古释复似违前故。谓前定三生今生但是解行而非证入。及至后释即言寄地。即是地位岂非证耶。故今正之。一时顿具即是第三证入生故。亦成渐顿得交彻故。四地狱天子下。疏引经文证成正义。结弹刊定。于中又二。一正证。二何以善财下弹昔。于中三。一正弹其释。二又定初地下审定其释。三无得管见下结其有违。疏余皆所起之惑者。上来初释第一句。愚迷下释第五句。魔王下释第七句。童蒙下释第八句。今余即二。三四六句。然三界下释第二三句。略不释四六二句。四望于五。五是发业之本。四是润业之爱。六通发润。即六地中无明所覆爱水为润。我慢溉灌生名色芽也。言苦集者。初三及八即是苦果。余五皆集略无有业含在魔王及后二偈行邪之中。疏失正行邪者。由前无明而起行故。又前三句即起业之惑。亦业俱之惑。第四句即所起之业。后偈初句即覆业烦恼。由于前二迷我我所。以我对所而生三惑。一于未得处而生谄诳。二于不可得处而生于嫉。三于已得处便生悭憍。后之三过。在覆业中疑惑弊眼。即正能造业。疑于有果无果。不见未来故造恶业。不见现苦故造善业。故下三恶即恶业果。诸趣即通善业。疏驰骤三界者。书云。尧舜安车夏殷步骤。言其道不及前。今以一乘为安车。安车牛车尚异二乘羊鹿。岂况三界步骤

疏。初四颂求悲智定摄利他乘者。总相释也。初偈是悲二是智三定四即四摄然下四段皆明乘义。今当别配。初偈有五。一愿行相扶如轮致远。二一切佛法皆依大悲。犹如众辐以凑一毂。三信心不退如轴居心。四坚忍不动如辖贯定。五诸功德宝而为庄校。即通五度。末句结求可知。第二偈三义。一总持摄法如箱摄物。二慈愍覆荫如张幰盖。三四辩演法如鸣銮铃。第三偈三义。一梵行严洁如净茵蓐。二三昧适神如侍婇女。三法音警物如击鼓声。第四偈三义。一四摄益物无尽如藏。二功德圆净如宝庄严三牛有羁鞅离过引车。人有惭愧拒恶崇善

疏。次三求十度自行乘者。初偈四度。一施为行首如轮为车本。二戒能妨非诸行皆净故如涂香。三内忍贪嗔外忍违顺。则万行端严也。四精进坚牢策万行故。次偈三度。一禅能摄散如箱持物。亦能空心如四周箱中空为用。二三二度共为轭者。般若观空方便涉有。有方便慧解。有慧方便解。此二相资共成一观。犹如一轭二头交彻可以引行故。于余处名为父母。具上三度调伏不退。后偈三度。一愿令行满故喻于轮。然初施轮是行之首。此之愿轮以导于行故有二轮。慈氏云。如龙布密云必当霔大雨。菩萨发大愿决定修诸行。行愿相扶故有二轮。二即力度。力有二种。一思择力故有总持。二修习力故有坚固。如车坚固能持是有力义。三智度决断无行不成。如有巧智令车成就。故云闭门作车出门合辙。疏次四求二利灭障乘者。初偈三义。一普贤之行周匝庄严一乘之体。二悲不伤物故云徐转。三上二无缘。故所向无怯。不畏众生难化万行难修故。次偈三义。一般若证理。如金刚坚。断迷理惑如金刚利。二方便善巧依根本成。犹如幻化断迷事惑如车之巧。三具斯二道二障皆亡。云一切无碍。次偈即无缘慈与乐即慈普被。称广大无缘故净。如车中虚则无不载。故如虚空等法界也。后偈断三杂染降魔制外。皆取二轮摧坏之义。疏后四求运载广大乘者。初偈取车备体庄严义。二取中虚普益义。三取安稳速疾义。四取不动普益义。疏上四三贤等配文甚显。疏法无人弘虽慧莫了。即暗用上经须弥顶上偈赞云。譬如暗中宝无灯不可见。佛法无人说虽慧莫能了

疏。涅槃二十者。此是阇王寻路而来如来遥叹。经云。尔时佛告诸大众言。一切众生为阿耨多罗三藐三菩提。近因缘者莫若善友。何以故。阿阇世王。若不随顺耆婆语者。来月七日必定命终堕阿鼻狱。是故近因莫若善友疏乃至广说以为全分者。即涅槃二十六。说第四功德谓亲近善友。广引舍利弗等。非是众生真善知识。我是众生真善知识。广引昔事见佛成益。最后云。常修恶业以见我故即便舍离。如阐提比丘因见我故。宁舍身命不毁禁戒。如草系比丘。以是义故阿难比丘说半梵行名善知识。我言不尔。具足梵行乃名善知识。是故菩萨修大涅槃。具足第四亲近善知识。释曰。此言顺于西域。若顺此方。应言善知识是半梵行。我言不尔。善知识是全梵行故。疏义引耳。疏文有二势下。疏文有二。一对前料拣。二就此诸句下随文别释。于中先释总句。后余九下释别句。于中三。初横释次竖释。后双结。疏则摄众魔为侍者。即净名问疾品。文殊问言。此室何以空无侍者。广答空竟云。又仁所问何无侍者。一切众魔及诸外道皆吾侍也。所以者何。众魔者乐生死。菩萨于生死而不舍。外道者乐诸见。菩萨于诸见而不动。释曰。此中但用摄魔耳。言不溺实际之海者。对于小乘已见七地。疏大圣此中下。总显文意。疏人能行此是人善友者。然贤首有三义。一者人善知识。二者法善知识。三者合辩。疏上列五即皆是人故。结云人能行此即人善友。二法善友彼有六位。一人天法。二小乘法后四即四教法。故今疏通云教理行果皆善友也。三合辩者彼亦有六。谓于上六法各说一门而授机故。疏意不存第三。第三不异初门故。疏设有实过尚取法亡非者故。什公常说偈云。譬如淤泥中而生青莲华。智者取莲华勿观于淤泥。即其事也。疏况权实多端生熟难测者。亦涅槃第六经四依品云。如庵罗果生熟难知。谓内怀腐烂外现律仪此为外熟内生。内具深法。外示毁禁之相。为内熟外生。是则以貌取人失之子羽。又说有迦罗迦果。镇头迦果。二果相似。迦罗迦果则恶药人。镇头迦果则好益人。喻善友恶友外相相似故难知也。其权实多端通于诸经。此经须婆胜热无厌等逆行此为权示。岂得为非故难测也。诗云采葑采菲无以下体。是以大贤。缩德露疵舍光匿曜不可知也。疏然此德义就事就表通皆具之者。就事即约德云身上。就表即约初住法门。亦具定等四义。疏善财求法不懈等者。即暗用净名第三菩萨行品如来为众香菩萨说法中不尽有为之义。经云。何谓不尽有为。谓不离大慈不舍大悲。深发一切智心而不废忘。教化众生终不厌倦。于四摄法常念顺行。护持正法不惜躯命。种诸善根无有疲厌。志常安住方便回向。求法不懈说法无吝等。今但要二句耳。疏阇王之遇耆域者已如向引。净藏之化妙严。即法华经妙庄严王本事品。净藏净眼为王现变。王乃发心诣佛得益。王自述云。世尊。善知识者是大因缘。所谓化导今得见佛发阿耨多罗三藐三菩提心。疏谓令不观种姓者。即菩萨戒不得观法师种姓。经云若佛子。初始发心未有所解。而自恃聪明有智。或恃高贵年宿。或恃大姓高门大解大福饶财七宝。以自憍慢而不咨受先学法师经律。其解法者或小姓年少。卑门贫穷诸根不具。而实有德。一切经律无不尽解。而新学菩萨不得观法师种姓。而不来咨受先学法师第一义谛者。犯轻垢罪。疏不耻下问。即论语云。孔文子何以谓之文也。不耻下问。疏宁可少闻便证入故者。暗用涅槃高贵德王菩萨品。彼文具足云。宁愿少闻多解义理。不愿多闻而于义不了。大文第二古德科判从一至十者。初总为一。谓各一位故。二依远公分之为二。初亲近善友。后告示下听闻正法。其系念思惟及如说修行并在文中。就初近善友于中有四。一闻善友。二求善友。三见善友。四请问法要。就初闻善友中亦四。一列国名是通处。二山等是别处。三善友名。四教往诣。二求善友于中有三。初闻心喜。二礼足辞去。三渐行访友。三见善友中二。先往见。后设礼退住。四请问中三。一白已发心明已有机。二而未知等正问行法。三我闻等叹德请说。近善友竟。二闻正法于中有二。先叹发心。后正为说法。说法中二。初说证量法门。后仰推等说教量法门。此上科文诸位多同少有不同者。三辩法师分为三分具如疏文。就中有人云别说有三。一约人。二约法。三合辩。初约人者。初闻名等为方便。二正见人为法界。三问法等彰其胜德。二就法中三者。一言教为方便。二智眼所得为法界。三通明业用以显其德。三人法合辩亦具三法。初闻名至处为方便。次见人得法为法界。后说往因及推胜等以显其德。释曰。虽有此三辨公本科但是后合耳。四衍法师等分为四量。一闻名等是教量。二依教寻求是信量。三见彼依正是比量。四闻彼所说是现量。此四即是闻思修证也。更有开为五。于上第四现量之中。开出自分胜进二位。余同前辩。更有分五亦如疏辩。六依意法师等分作六分。一明求诣心行。二明见敬咨问。三赞说已知以授善财。四说已未知。五更示知者劝令往诣。六辞退奉行。若依五台论亦作此释。或有一师分之为七。于前六中第二内先致敬。后咨问法要。八或分为八。于前七中第三之内。先赞发心。后说已法。九或分为九。于上八中第五段内。先示已劝往。后教问叹德。十或分为十。于上九中第六段内。先致敬。后辞去。上十种科中。前五约位科。后五约会科。文并通在今疏。从其要当存其三释。取六释文而名小异者。随稳便故将抄中六对疏。自知就疏六中前之四段。各可为二。一中二者初念前友教。二趣求后友。二中二者先见敬。后咨问。三中二者先称赞。后授法。四中二者先谦己知一。后推胜知多。下别科多然。后二不开还成十段以表无尽。疏今此正明初发心住者。如入空界慧住空性。得位不退故名为住。疏若善财略友云何领者。初谓经家之略及观新译普贤行愿品梵本亦具。乃是译人略耳。疏后所谓下。别牒前问者向者善财若不具问。此云何牒故疏前云友云何领。疏亦即为满者。上释由了为无为非一非异方能当满。今意云了非一异即已穷究故。故为即满。疏今由胜解于境忍可者。谓唯识解信云。谓于实德能深忍乐欲心净为性。前已频引今离用此言耳。疏文殊般若明一行三昧等者。然文殊有文殊问及文殊说经。今之所用即大般若中曼殊室利分。总收彼二经皆入大部故。又彼意云欲入一行三昧。先亲近解般若者。听闻咨受然后能入。言一行者。一法界行亦无一故。又云。法界一相系缘法界不动法界。疏以本解性闻熏之力者。净行品已说十信满心入此初住。由信满故明决定住菩提心。三心之中解心增故即是住体。言开发者发心有二。一者发起通于十信。二者开发在于初住亦如前释。又高齐大行和尚宗崇念佛云。四字教诏。谓信忆二字不离于心。称敬两字不离于身口。彼论云。往生净土要须有信。信千即千生。信万即万生。信佛名字不离心口。诸佛即救诸佛即护。心常忆佛口常称名。身恒常敬始名深信。任意早晚终无暂住阎浮之法。此策初心最为要也。疏以如为佛则无境非如者。大品法尚答常啼云。诸法如即是佛。金刚云。如来者即诸法如义。既以如为佛一切法皆如也。何法非佛耶。疏又若报下。然修念佛三昧多约渐修。谓先为化身观。次报。后法。今则一时耳。疏诸盖诸取者盖即五盖取。谓二取故上经云。不见十力空如幻虽见非见。如盲睹分别取相不见佛。究竟离着乃能见故。疏最初善友先明念佛法门下。此明次第上问也。五十五友法门不同而初说者何耶。从以是下答其先说之意。略有二意在文可知。若更进论有其十义。一如疏引智论。二依佛方能成胜行故。三功高易进以奖物故。四观通浅深能遍摄故。五消灭重障为胜缘故。六双兼人法易加护故。七十地菩萨皆念佛故。八三宝吉祥经初说故。初此念佛海云听法。善住依僧为次第故。九即心即佛为一境故。十为表初住缘佛发心乐供养故。第十即疏中第二意也。疏今初无边智慧下。然其推胜略有二意。一通指诸菩萨行。如今总中但云菩萨无边智慧等。二就其一门但知少分。如下别说二十一门。我唯得一等下。诸善友多约后义。疏释此总乃含二义一即下。诸门是别就一门知少分意。二及所不说即有通该诸德之意。疏二别中有二十一门下。疏文分五。一总释文意。二古德下叙古释。三克实下辩顺违。四又此诸门下别释由致。五然其念佛下开章别释。于中三。一标所念二且寄下约三身以辨。三若约十身下约十身释。二中有三。一明所念差别。二会释经文。三以能念收束。今初可知。疏今此二十一门下。第二会释经文。中三。初标。二智光下别会并可知。三然上就所念下结成。疏然约能念下第三约能念收束。然古人已有五门云。一称名往生念佛门。二观像灭罪念佛门。三摄境唯心念佛门。四心境无碍念佛门。五缘起圆通念佛门。此之五门初二名扃。又但称名亦阙念义。第五一门名则尽善及其释义。但事理无碍故今改之。故初一门兼摄前二。此中第五方是性起圆通事事无碍义故。疏若约十身下即第三别约十身。言各二门者。初二即愿身初门愿生兜率天宫。后门愿周法界。三四二门即智身。前门十力智。后门了法智。五六二门即法身。前门法普周一切等无差别。后门体不可见不妨大用。七八二门即力持身前门持令多劫。后门持令常见。九十二门意生身。前门随意生刹。后门随意生世。十一二两门化身。前门化周诸境。后门化故示灭。十三四二门即威势身。前门无住。后门普周。皆威势故。十五六二门即菩提身。前门一毛多佛成菩提。后门一念遍刹成菩提。十七八二门福德身。前门放光演法。后门随乐现形。十九二十二门。即相好庄严身。前门应化相好。后门华藏刹中相好。第二十一门该于十身。故等空法界。亦与离世间十佛相当并如前会。第二海云寄治地住。谓常随空心净治八万四千法门。清净洁白治心地故。疏初依教正观下。疏文分二。先显意。后释文。前中二。先对文释。后对前释。前中有二。皆外典中意。一论语云。温故而知新可以为师矣。二又前即学下。亦论语云。学而不思则罔。思而不学则怠。怠谓疲怠。罔谓罔然无所得也。今并反上。故学而能思。思而能学。疏然思前下。第二对前释。即涅槃经意。于中有二。先正立理义合属前。以涅槃四事是涅槃近因。谓一亲近善友。二听闻正法。三系念思惟。四如说修行。故知后二即属前二。此即远公分为二意也。疏今以前义下。第二明今疏将后二属后会意。谓思修二门即前会之义。今为后会进趣故。故依教趣求。言后义属前友指来者。即是前会指示后友。后友依正等合属后会。由前友指来故属前会名为钩锁。所指是主能指是伴。又思修属前此约位判。今从会判。故属后也。疏又此十心多同治地自分十心恐繁不会者。彼十心者。所谓利益心。大悲心。安乐心。安住心。怜愍心。摄受心。守护心。同己心。师心。导师心。今此一即大悲。二即利益。三即安乐四安住心。离恶法住善法故。五即怜愍。六即守护。令离碍故。七即同己。遍法界故。八即摄受。法界虚空皆往摄故。九即师心。见诸佛故。十即导师心。入种智故。疏次前念佛下生起次第。疏一纪已周者十。二年为一纪故。周十二辰故。过十千劫者十信满十千劫入正定故。十二住者已见十住品。疏智海十义如十地说者。海有十德。表十地故。言今是悲海者故。此十德与十地小异。取称法故。即前十种悲心一即利益心。利益宽广故。二即大悲心。大悲甚深无能测故。三即安乐心。始于世乐种种与故。四即安住心。谓恶行众生令住善行故。即是众宝。五怜愍心。悉包纳故。六摄受心。种种外道摄令正信。如水多色同在海故。七守护心。已发心者皆守护故。是为无量众生依住。八同己心。谓摄菩提大愿。众生如己身有为大身故。九即师心。谓于大乘道。习进趣者推之如师。师必咨受大法雨故。十导师心。谓具功德者敬之如佛。故湛无增减。以斯十悲对斯十喻有如符契。故上叹十心即是法说。今此海喻喻前十心弥复相当。疏二忘诠求旨为见佛亲因者。此中唯有四句。一广二多三深四胜。初二即前第一开出。三即第二。四即第六。一海众色故为殊特。余六句不出深广故但举四。又余之六句余处容有。故牒此四显其奇特。问既叹奇特何名忘诠。离前十相更求过此。即忘诠求旨意也。由此忘求故得见佛。疏以深观心法海等者。法海即是悲海。而法名通对上自心观心。即心华开敷观大悲法。即二利行发。疏普诠诸法故者。此有三义。此一约深。二普诠诸法约广。上二直就所诠三即从益立称。既一法中见一切法。则其一眼见十眼境。所见之中已有能见。能见之中有所见矣。以一法中有一切故。广如毗卢遮那品。疏先总显所持法多者。即海墨书而不竭。然入大乘论引此经文云。是海幢下。说法门全同于此喻相小异。云大海水尽以磨墨。积大纸聚犹如须弥山。四天下草木持以为笔。三千世界水陆众生悉为法师。于一刹那顷所受法门犹不能尽。此约书文不尽。彼约领多不尽。疏旋转者。如下弥伽。然此十句文并可知。亦即治地中胜进十法。谓诵习多闻虚闲寂静等。但有开合可以意得。疏具斯四义名无上宝。存以梵音者。以具梵音经题云楞伽阿跋多罗宝经。阿之言无。跋多罗云上宝。即此方之言。又多罗亦是宝义则译人双存。楞伽正是难往之义。上之四义前二。即无上宝。后二明于难往高显。伽王之所居。故即得通者不难往故。疏表此住中观一切法如虚空无处所故者。彼具云此菩萨以十种行观一切法。所谓观一切法无常。二一切法苦。三空。四无我。五无作。六无味。七不如名。八无处所。九离分别。十无坚实。释曰。皆有一切法言。今但举三八二句以顺住空。然余八亦是空义。第三善住寄修行住。谓巧观空有增修正行故。疏显此住中善观众生等十种界故者。彼经云。佛子此菩萨应劝学十法。何等为十。所谓众生界法界世界。观察地界水界火界风界。观察欲界色界无色界是。疏今初有十二句。初一他心等者。且顺文配。若约开合取之即具十通。一他心。二三皆宿住以殁生言故。疏云兼于三明十通知过去殁生亦宿住故。四即未来际劫智通。五即天眼。六合二通言语即分别一切众生言音智通。音声即天耳通同一天耳开出故今合之。七八九三皆一切法智通。七断疑智。八知根智。九知时智。十及十一并一切法灭尽智通。前句刹那尽。后句长时流转尽。十二神足即无体性。及无量色身通。亦俱神境开出故。故此文中通十通义。疏百二十刹那等者。此广俱舍颂文。颂云。百二十刹那。为怛刹那量。腊缚此六十。此三十须臾。此三十昼夜等。疏亦有处说昼初分时等者。智论等文。弥勒下生经亦说。谓释迦修难行苦行得成菩提。弥勒修安乐行而得菩提。谓昼夜三时礼拜忏悔等。谓日初分时日中分时日后分时。夜初分时夜中分时夜后分时。合为六时是也。黑分白分即西域分黑白。黑前白后故。正月十六为正朝一时即二月。二月为一时。四时亦同此方春夏秋冬等者。等取三际并如偈赞品。即西域记第二言仁王九百生灭等者即第二经。疏言十八变即是瑜伽三十七文。颂云。振动及炽然。流布并示现。转变及往来。卷舒众像入。十同类往趣。隐显作自在。制他施辩才忆念及安乐。放大光明等。转余有情物。令成余物故。名能变神通。谓一振动。二炽然。三流布。亦名遍满。四示现。亦名显示。五转变。六往来。七卷。八舒。九一切色像入身。十所往同类。十一隐。十二显。十三所作自在。十四伏他神通。十五施他辩才。十六施他忆念。十七施他安乐。十八放大光明。此十八名转变。后三句明能变。今文辩相义并可知。疏非戒不能治心地故者。上约此中法门释。此句约表位释。然德云是定。海云是慧。此中明戒显三学为初故。疏有二十句下。案文解释在相可知。此二十戒亦即第十回向。二十梵行。但彼约自能清净方能益他故。先护重首明不破不缺等行。此彰菩萨本为利他。故先明大悲后显无垢。名或小异。今当略会。一大悲戒。即彼第二十无恚梵行。恚是悲障有悲故无。二波罗蜜戒。即第十一。三世诸佛所行梵行行佛之道故。三大乘戒。即第十七。无比梵行余乘无对故。四菩萨道相应戒。即第十八。无动梵行不动二利故。五无障碍戒即十三。无著梵行由见真如成圣道故。故无障碍。六不退堕戒。即第十五。无灭梵行顺理而持。常不退灭故。七不舍菩提心戒。即第十六。安住梵行心常诣理故。八常以佛法为所缘戒。即十四无诤梵行。事理具足无非佛法何所诤哉。则常缘佛法性矣。九于一切智常作意戒。即第七诸佛所赞梵行。称理持戒动契圣心。是缘佛智佛何不赞。十如虚空戒即第九无所得梵行。不得能所自在持故。十一一切世间无所依戒。即第八无所依梵行。不依现世名闻利养。不求当世人天果故。十二无失戒。即第五无失梵行。定心持戒吉罗不犯故。十三无损戒。即第六无能蔽梵行。鹅珠草系。不能蔽之令有损故。亦不损他。十四无缺戒。即第十二不缺梵行。不犯十三等无残缺故。十五无杂戒。即第三不杂梵行。不念破戒种种因缘。闻环钏声亦不染故。十六无浊戒。即第十九无乱梵行。定共相应故无浊乱。十七无悔戒。即第十二无碍梵行。犯罪追悔是障碍故。十八清净戒。即第十增益菩萨清净道梵行。不同小乘唯事净故。十九离尘戒。即第四无点梵行。不犯堕罪无尘点故。二十离垢戒。即第一不破梵行若犯四重十重。犹如破器无所复用最垢重故。若依上释即为凭据。亦同智论十戒如回向品会。疏达里鼻茶。新译为达罗比吒。唐言持富饶。亦顺生贵之义。疏以三世圣教法云雨一切故者。约表位说。即彼经云。此菩萨应劝学十法。所谓了知过去未来现在一切佛法。二修习三圆满各三为九。十了知一切诸佛平等是也。第四弥伽疏寄生贵住者。生佛法家种性尊贵故。疏今初所以师礼资下。征释所以上征问。后以菩提下答。先正释以敬法重人故。二故法界下引证。一引论。二又发心毕竟下引经。即涅槃三十七至迦叶赞佛。前来已引今当更引。具云发心毕竟二不别。如是二心先心难。自未得度先度他。是故我礼初发心。初发已为天人师。胜出声闻及缘觉。如是发心过三界。是故得名最无上。今略引三句耳。上引他经。若当经中其文繁博。下慈氏中。发心功德品上下。善友亦广称赞。疏况未说不别立礼之所以。言不乖重法者。以师礼资义似自轻。升座方说不乖重法。言重法者。涅槃第六云。有知法者若老若少。故应供养恭敬礼拜。犹如事火婆罗门等。如第二天奉事帝释。佛言我于经中覆相说。是不为学声闻人。但为菩萨。释曰。由后义故。故下通难。云为僧敬俗事不便故。即约声闻不轻佛法。若是菩萨常不轻。是四众皆礼故为重法

大方广佛华严经随疏演义钞卷第八十五大方广佛华严经随疏演义钞卷第八十六

        唐清凉山大华严寺沙门澄观述

疏。今初言轮字下。疏文有二。先明义相。后辩次第。前中二。先叙昔。后今更依毗卢下。申今于中三。初叙意。次如最初下正辩字相。后其字下深义下辩字义。文并可知。疏所以次前而辩斯者下。二明次第上问下答。即密用毗卢遮那经意。彼有偈云。甚深相无相。劣慧所不堪。为化是等故。兼存有无说。释曰。寄字即存有无相智即存无。如有偈云。八叶白莲一时开炳现阿字。素光色即存有也。阿表无生义。即存无也。会之不二即是中道。疏又为总持令不失者。人俗化导总持差别故。从既为医人下。即直就有说。从圣教中生约表位说。疏然字即四十二字如众艺处说。十四音初地已明。疏五诠深密者。略有三义。一诠于理智。即事而真如。三德涅槃名秘密藏等。二密意故三具三密故

疏。年耆德艾者。耆即长也。艾者老也长也。色白如艾云事长于人者。年德俱高也

疏。皆为度脱等者。具足经云。云何为菩萨具足方便住。此菩萨所修善根。皆为救护一切众生。二饶益。三安乐。四哀愍。五度脱。上四皆同初句。有一切众生。六令一切众生离诸灾难。七出生死苦。八发生净信。九悉得调伏。十咸证涅槃。皆如第六句。有令一切众生。今疏随便引于二句。疏第五解脱长者。寄具足方便住者。带真随俗习无量善巧化无住故。疏结前发心之相便为请问之端者。如经前言为欲入于清净藏中。以一切相而庄严故。即为请问云何得入于清净藏中等。余皆仿此

疏。如来无碍庄严总有五义者。而文中皆含如一云如来各具无碍庄严者。即上经。云种种光明诸庄严事。若因若果若依若正。即无碍庄严也。二一一如来互遍无碍者。以身中现十方各十佛刹。微尘数佛无杂乱故。三与长者身无碍者。以身不大而刹不小。亦无来去互遍无碍。谓以含刹之身入身中之刹。无不充遍。是内外一多无碍故。新译经云。身与佛刹互相涉入不相障碍。即此便有重重之义。谓含刹之身入身中之刹。身中刹内之身亦能容刹。所容之刹亦能有身故。身身无穷刹刹无尽。四长者彻见等者。经云亦见诸佛成正觉等。尚令善财见闻。况长者耶。故下出定告。云我入出此定即见东方阎浮檀金光明世界龙自在王如来如是等。十方诸佛欲见即见。五长者智持无碍者。以是唯心三昧力故。所以出定能持能说疏故无碍言兼得旋持等者。即第五义不违前普摄一切佛刹无边旋陀罗尼。普摄佛刹之义定中相显。而中智持不违总持。疏既了境唯心等者。上经云若人欲了知三世一切佛应观法界性一切唯心造。言了心即佛者。经云如心佛亦尔。如佛众生然。应知佛与心。体性皆无尽。既境即是心心即是佛。则无境非佛。况心心耶。加以志一不挠精诣造微。佛应克诚于何不见。疏初总明相无来往者。体性寂灭故。疏了彼相虚唯心现故者。以我即寂之唯心。叩彼即体之妙用能念所念何动寂之相千。疏一如梦对下。此之四喻唯影。别喻余三皆通。若准新译。梦响二喻具通与别。影幻二喻唯别无通。今初梦喻彼经别喻。云如梦所见从分别生。见一切佛从自心起。上二句喻下二句合。则梦境喻佛。分别梦因喻能念心。故观无量寿佛经云。是心作佛是心是佛。诸佛正遍知从心心想生。缘生非实故。能所见空无往来也。疏般舟下引证。此经有三卷。题云般舟三昧经。一名十方现在佛悉在前立定经。后魏沙门支娄迦谶译。在罗阅只加邻竹园说。跋陀和菩萨问。第一问事品。今引亦第一卷行品。第二佛先今远恶近善。修此念佛三昧。故举诸喻示念佛相。经文浩博今疏略引。今当具引一喻。经云。何因致现在诸佛悉在前立三昧如是。跋陀和。其有比丘比丘尼优婆塞优婆夷。持戒完具独一处止心念。西方阿弥陀佛今现在。随所闻当念彼国。去此千亿万佛刹。其国名须摩提。佛在众菩萨中央说经。一切时常念阿弥陀佛。佛告跋陀和。譬如人卧即于梦中。见有种种金银珍宝。或复梦父母兄弟妻子亲属知识相与娱乐喜乐无比。及其觉已为人说之。复自泪出念梦中所见。如是跋陀和菩萨。若沙门白衣所闻。西方阿弥陀佛当念彼佛。不得缺戒一心专念。若一昼夜若七日七夜。过七日已后见阿弥陀佛。于觉不见于梦中见之。譬如梦中所见。不知昼不知夜。亦不知内亦不见外。不用在冥中故不见。不用有所蔽碍故不见。如是跋陀和菩萨心当如是念。时诸佛国界名大须弥山。其有幽冥之处悉为开辟。目亦不蔽心亦不碍。是菩萨摩诃萨不持天眼彻视。不持天耳彻听。不持神足到其佛刹。不于是间终。不生彼间佛刹耳。乃见便于此间坐。见阿弥陀佛。闻所说法悉受持。得从三昧起悉能具足为人说之。释曰。次下即有须门女喻。从七日已下即示合相。取如梦见无定实义。彼经有多梦喻。今但引二。前七宝喻喻即有而空。觉无所得故。后如梦喻喻空不碍有。有即事故。然合二不二为中道义。故但取意略引其二。又约义别说。心性如境。观如缘想。观成如梦。此唯就于能行人合。又法身如境。报身如想。应身如梦。此唯约佛境合。又彼佛如境。行人如想。见佛如梦所见。双约感应。此之三释。释经通喻一切诸佛及以我心皆如梦故。言有女名须门者。经有二人以念三女。经云譬如有人闻堕舍利国中有淫女人名须门。若复有人闻淫女人名即凡和利。若复有人闻优婆须。然经言小隐。若贤护经缘事全同。而文分明。经云复次贤护。如此摩伽陀国有三丈夫。其第一者。闻毗耶离城有一淫女名须摩那。彼第二人闻有淫女名庵罗波离。彼第三人闻有淫女名莲华色。彼既闻已各设方便系念勤求无时暂废。然彼三人实未曾睹如是诸女。直以遥闻即兴欲心专念不息。后时因梦谓在王舍城。与彼女人共行欲事。欲事既成。求心亦息希望既满。遂便觉寤。寤已追念梦中所行。如所闻见如所证知。如是忆念来诣汝所具为汝说者。汝应为彼方便说法。随顺教化令其得住不退转地。究竟成就阿耨多罗三藐三菩提。彼于当来必得成佛。名曰善觉。又云如舍卫国等者。即智论第六似引此缘而有小异。论云。如佛在世三人为伴。闻毗舍离有淫女名庵罗婆和。舍卫国有淫女名须曼那。王舍城有淫女名优钵罗盘那。并端正无比。三人各闻长念心着。便于梦中与彼从事。觉已心念。彼人不来。我又不往。而淫事得办。因是即悟诸法亦尔。于是共至跋陀婆罗菩萨所而问其事。菩萨答言。诸法实耳。皆从念生。菩萨乃为其方便说法。皆得不退转地。释曰。大意同经但阙授记耳。然经论大意。却显念见佛竟。方悟性空有无无碍。与疏意同也。疏二水影对中等者。乃是别喻。心但喻水。为影缘故。若取通意心佛皆则影。然新译经亦是别喻。而加于器可喻净身。然水在器依江河等物皆可为器。而般舟经亦有影喻具水月镜像。以喻自见非从外入非从内出。正与疏同。明非入出兼唯心义。疏心之定散准喻思择者。然水有四类。谓一清二浊三动四静。疏合中水浊对前皎净。波腾对于澄潭。以法就喻通有二义。一有惑无信为浊。二有信无惑为清。散乱为动。有定为静。四事交络成多句数。一水浊而动。若黄河汨流。此喻有惑无信。又多乱想。二浊而不动。如稀泥无波。喻如有惑无信并无攀缘。然此一句曲有多义。一有惑而静。二无信而静。愚痴之定也。三清净而动。喻无惑有信。而多觉观对上第二亦有三义。一无惑而乱。二有信而乱。三明了而乱也。四清而且静。喻无惑有信而定。略举定散实含清浊。而第一人设有念佛而见佛者。如黑象脚加睒烁不定。第二人见同灰炭色安住不动。第三人见或睹相好。忽有忽无乍离乍合。第四人见则色相端严凝停不乱。唯见唯静逾观逾明。今同第四而念见也。故法华云。深入禅定见十方佛。故云心之定散准喻思择。然其大意。佛既如影。安有有无一多胜劣去来入出等相。非空非有中道观成。若水喻心性。则佛之月影。皆是众生真心中物。心佛交彻真唯心也。疏三如幻对者。但有通喻。新经别喻云。又知自心犹如幻术。知一切佛如幻所作。谓有能幻法方有幻事。无能念心无所见佛。疏中具显三观初空观。次而不无幻相下即假观。后正喻下中道观也。四如响对亦唯通喻。新经别喻云譬如空谷随声发响。悟解自心随念见佛。释曰。此唯一义。则法身如空谷。自心如发声。见佛如响应。而疏释经通相之喻。心佛皆响故两句释之。初喻佛如响。则谷等同上。后以佛为缘下。喻心如响则以自性清净心为空谷。佛应为声起见佛心即如响也。故疏结云此但总喻缘成之义。然亦声谷皆喻缘成之义。声谷皆缘喻二心为缘而有佛响。二佛为缘而心得见。故上二皆响。而上四喻皆言对者。虽喻有三法本但喻于心佛二。故上之四喻皆具四观。一正喻唯心。二唯心故空。三唯心故假。四唯心故中。融而无碍即华严意。若皆具四何用四喻。兼别义故。一欲广唯心无性等故。二从增胜说四义不同。谓梦喻不来不去。影喻不出不入。幻喻非有非无。响喻非合非散。又梦喻散心意。言分别故。水喻定心。同静水故。幻喻起用心。如幻术故。响喻胜劣。心随念见故。又前三喻喻见佛身。后一兼喻闻法。三中梦喻法身。但有想见竟无见故。影喻报身。相明净故。幻喻化身随意成故。又幻喻是心作佛。影喻是心是佛。梦喻诸佛正遍知海从心想生。响喻随心胜劣见佛有异。具上诸意四喻不同。故上疏云别喻唯心兼明不出入等。疏后结成唯心者。即释经我如是忆念所见诸佛皆由自心。疏家便引经证。先引观经。略如向说。后引般舟依止观中引文稍阙略。今当次第具引经文。经云。作是念。佛从何所来去到何所。自念佛无所从来。我亦无所至。自念三处。欲处色处无想处。是三处意所为耳。我所念即见心。作佛心。自见心。是佛心。是怛萨阿竭心。此云如来。是我心。见佛心。不自知心。心不自见心。心有想为痴。心无想是泥洹。是法无可示者。皆念所为。设使念为空耳。设有念者亦了无所有。如是跋陀和菩萨。在三昧中者所见如是。佛于尔时颂偈言。心不自知心。心不自见心。心有想为痴。无想即泥洹。是法无坚固。常立在前念。以解见空者。一切无想念。释曰。对疏广略可知。次释疏文。初明佛无去来随念即见佛。二心作佛下。明唯心念佛观成。初知是我心作佛心外无佛故。所见佛即见自心。言是佛心者。我心佛心心无二故。若见自心即见佛心如如即佛故。略不出。言是我心见佛者。结成唯心决定是我心。见心外无别佛也。故疏结云上方摄境归心。下又拂者先拂上心自见心夫心为能见佛为所见。刀不自割指不自触。云何自心还见自心。能所不分见相斯绝。下句拂上知是我心。既能所知二皆是心。则亦绝能所故无知耳。故结云有想则痴。然般舟别译。隋朝沙门阇那崛多。即大集贤护有文五卷。初品名思惟。第二品名三昧行。此中义在初品余可知。第六海幢比丘寄正心住。成就般若了法性空。无住无依无邪无正故。闻赞毁真正其心念不动故。疏一灭受想定。如此品初及七地说。引净名经亦如前说。疏布十善令向佛法故者。经文自具。细寻可知。疏十法雨即十住者。寻经易了。疏显方便行不离般若者。既了俗由证真故说后得明不离也。疏能知三世佛法者。上约善友释此约表位。经云。佛子。此菩萨应劝学十种广大法。何等为十。所谓说一即多说多即一。文随于义义随于文。非有即有有即非有。无相即相相即无相。无性即性性即无性。即广大法海也。余可思准。第七休舍优婆夷寄不退住入于无生毕竟空理。心心常行空无相愿。止观双运缘不能坏。湛犹澄海。故疏涅槃亦有此数者。即第六经如来性品说四依义。后经云迦叶菩萨白佛言。世尊。如是经典正法灭时。正戒毁时非法增长时。无如法众生时。谁听受奉持读诵令其通利供养恭敬。书写解说。下取意引。尔时佛赞迦叶。善哉善哉。善男子。汝能问如是义。善男子。若有众生。一恒河沙佛所发菩提心。乃能于恶世不谤是经。不能为人分别广说。若二恒河沙佛所发菩提心。乃能于恶世不谤信乐受持读诵。亦不能为人演说。若三恒河沙佛所发菩提心。具第二人德。虽为人说未解深义。若四恒河沙佛所发心。亦具前德为他广说十六分中一分之义。虽复演说亦不具足。若五恒河沙佛所发心。能广为人说十六分中八分之义。若六恒河沙佛所发心。能广为人说十六分中十二分之义。若七恒河沙佛所发心。为他广说十六分中十四分义。若有于八恒河沙佛所发心。然后乃能于恶世中。不谤是法受持读诵书写经卷。亦劝他人令得书写。自能听受亦劝他人令得听受通利等。然经但有积一至八。三十六言乃是义取。一上加二为三。三上加三为六。六上加四为十。十上加五为十五。十五上加六为二十一。二十一上加七为二十八。二十八上加八为三十六。是则积于八人二三四等。共为三十六也。虽是义取理必应然。疏天女云者。即净名经。前已引竟。疏故彼住文云。出广大遍满音者。即胜进十法中之一句耳。第八仙人寄童真住者。心不生倒不起邪魔破菩提心故。疏正如此方楸树。乃至余如音义者。音义具云。楸树下云。然甚有香气其华紫色。子如枇杷。具云。其叶如此方柳树。子似枇杷子。承蔕如柹。然其种类耐老。诸树中最能高大。疏执手表授与之义。约教相说言相摄有力者。约义理说上通诸教。此在华严知识有力。善财无力。力摄无力。故因知识令善财见。若善财有力。则仙人无力。力摄无力。仙人所证善财皆得。故互相摄。疏文有十句五对下。疏文有三。初通相总明。二然初对下展转释。则无胜幢之总。为第一能益余四展转。皆以所益转为能益。三若约能照下。就总别释无胜幢之总含于五义。初之一能虽标总称即受别名。故言能照皆是总中别义细寻可见。疏是以善财一生能办多劫之行者。既善友力瞬息之间。或有佛所见经不可说不可说佛刹微尘数劫修行不倦。何得一生不经多劫。仙人之力长短自在故。如世王质遇仙之棋。才看斧柯烂已经三岁尚谓食顷。既能以长为短。亦能以短为长。如周穆随于幻人。虽经多年实唯瞬息。故结云不应以长短之时广狭之处定其旨也。疏善知三际故长。善知胜义故直者。即义引第九住。又经云。此菩萨善知十种法。何等为十。所谓善知诸众生受生。善知诸业烦恼现起。善知习气相续。善知所行方便。善知无量法。善解诸威仪。善知世界差别。善知前际后际事。善知演说世谛。善知演说第一义。释曰。若克实取唯取第八及第十句。若通相说除第十句。余皆三际之法。第九胜热寄王子住者。从法王教生于正解当绍佛位故。疏故智论云。般若波罗蜜犹如大火聚即第二十论。疏又释刀是断德等者。上唯就般若上说。此下即三德。涅槃刀山是解脱德。火是般若德理即法身。疏今初刀山不可执下。疏文有三。一直消文意即就前约般若上说。般若能成众行故。二此中下。通标三毒深玄之义。三然有五义下。开门别释。一言诸部般若其文非一者。文中广说三毒四倒悉皆清净。广说贪欲嗔痴性皆空寂故。二如净名行于非道者。即第二经佛道品。文殊师利问维摩诘言。菩萨云何通达佛道。维摩诘言。菩萨行于非道是为通达佛道。又问。云何行于非道通达佛道。答曰。菩萨行五无间而无恼恚。至于地狱无诸罪垢。至于畜生无有无明憍慢等过。至于饿鬼而具足佛法。乃至示行嗔恚而常慈愍。皆言示行即幻用摄生。又云。云何为如来种。文殊答云。有为为种。无明有爱为种。贪恚痴为种等。结云六十二见一切烦恼皆是佛种。曰何谓也。答曰。若见无为入正位者。不能复发阿耨多罗三藐三菩提心。譬如高源陆地不生莲华等皆菩萨幻用化生。言先以欲钩牵者。亦是此品净名答。普现色身之要言也。经云。示受于五欲亦复现行禅令魔心愦乱。不能得其便。火中生莲华。是可谓希有。在欲而行禅希有亦如是。或现作淫女引诸好色者。先以欲钩牵后令入佛道。既言现作。明是幻用。三在惑用心者。以是俗流带妻挟子。是其常业。未能舍事。事上用心令了性空。但我妄念。未得自在非以为是。令惑渐薄便能远离。上经亦云。菩萨在家与妻子俱。未曾暂舍一切智心等。四留惑润生出现已释。净名不入生死大海。此前喻云。譬如不入大海不能得无价宝珠。疏但合文。五当相即道者。是道体故。理无二味故。无有一法非佛法故。言不思议故者。总相叹也。不可作欲等思。故引无行经文。前曾一用取欲空性则用初义。今取即道。亦如智论第七。喜根菩萨为于胜意菩萨而说偈言。淫欲即是道。恚痴亦复然。如是三事中。无量诸佛道。若有人分别淫怒痴及道。是人去佛远。譬如天与地。道及淫怒痴是一法平等。若人闻怖畏。去佛道甚远。淫法不生灭。不能令心恼。若人计吾我。淫将入恶道。见有无异行。是不离无有。若知有无等。超胜成佛道。都说七十余偈。皆即道也。喜根于今现在东方。过十亿佛土作佛。其国土亦号宝藏。佛号光喻日月王。文殊言。胜意比丘我身是也。尔时不信受无量苦。佛问。闻偈得何益。答能毕众苦世世利根解深妙法等。疏上疑为拣其真伪下。疏文有五。一直释经意。二魔亦能为下设疑难。三以此善友下解释。四若尔下蹑迹生疑。五以显法故下释显疑意。疏净名云受诸触如智证者。即第一迦叶章中。谓智证实相。则触而非触。触而非触。受亦当然。心境两冥为亲证也。疏表振动等者。彼经云。佛子。云何为菩萨灌顶住。此菩萨成就十种智。何者为十。所谓振动无数世界。二照耀。三住持。四往诣。五严净。上四皆同初句。六开示无数众生。七观察无数众生。八知无数众生根。九令无数众生趣入。十令无量众生调伏。今以无畏贯斯十句。第十慈行童女寄灌顶住者。从前观空得无生心最为上首。诸佛法水灌其顶故。疏般若中云了色是般若等者。即大品经意。具历诸法且初历五蕴。云了色是般若一切法趣色。色尚不可得。云何当有趣非趣。如是具历诸法皆然。若般若意。似当诸法之性不异色性。故皆趣色。色不可得当法性空。既无所趣安有能趣。若智者意一切法趣色。是假观。色尚不可得。是空观。云何当有趣非趣。即中道观。今疏用意但要初句。以取色性为诸法依。以性普收故皆趣色。则一色中具一切法。是事事无碍之意。故随一法皆收法界。故得依果一一境中具诸庄严。则庄严属果以果詺因名普庄严。第二意即因自庄严。疏言三十六下。但约表义。若约事释。如休舍处。疏又彼总此别者。谓地经之中。但云无量百千阿僧祇陀罗尼门。解脱门三昧门亦然。设有列者。但列其十。今有一百一十八门总持。故云别也。疏用上三眼下。释此名大文第三十行位。疏初善见比丘寄欢喜行者。施悦自他故名欢喜。疏初二约菩萨者。理智一对。初一报类难知者。如回向品说。二妄想为因即无性者。妄想为因释依想住。即无性言释于甚深。故楞伽云。前圣所知转相传授妄想无性。斯为自觉圣智之境。故甚深也。疏三染分行业等者。以约众生故。如一孔雀毛一切种因相等。疏四感异熟识者。行相深细故。经云。阿陀那识甚深细等。亦如楞伽上中下。修照见自心生灭流注。又经云。诸识有二种生。谓流注生相生。有二种住。谓流注住相住。有二种灭。谓流注灭及相灭。古同释云。流注是八识相续。然相有三种。已如前引。今此即刹那流注。与上照见自心生灭流注义相符也。若常照之见其无性即自觉圣智故。疏五所变影像等者。相分即是影像。第八缘三种境。境即相分。谓种子。根身即内境也。器世间即外境也。变现心所等皆是内也。色为二所现。影亦通内外。外即五尘内即五根等。疏六名无得物之功。已见上文。疏七文字言说皆解脱故者。即净名中天女折身子。已如前引。疏皆严法界而无严者。故金刚云。庄严佛国土即非庄严是名庄严。谓虽复庄严无能严心。则称实理。事理无碍方真严也。余二可知。言总上二分下结法所属。疏此则但是一相者。以晋经合其身殊妙属后尼拘陀。故今经二相彼但成一。然如尼俱陀者。其枝横布与上耸相称。非如建木一向直耸。非如傍覆一向婆娑。故云上下端直。若顺树相圆满最妙。此明不长不短。如人横寻与身相称七尺之人。寻亦七尺。此为福相。疏明其心相者。然世之相亦有三类。一色相。二声相。三心相。心相最胜。然可修成。含弘仁惠是胜相也。今此正明菩萨心相。言即止观双运者。经初二句标示止观。初智慧为观。后于诸境下即止。从止过下释若沈若举已下经文。然沈举略有二种。一昏沉掉举。此相即粗今所不论。二细沈举。即如疏辨。若静无遗照动不离寂。则是双行不沈不举。故云正受现前。然经一切皆息总该上四。而疏释之四对别显。上释第一若沈若举竟。二不智不愚则双契中道者。即取下皆息该此名不智不愚。若智牒前观也。非智牒前止也。今由皆息则止观两亡。为真止观方契中道。三起念下。释动转皆息。若有止观即为动转。今由两亡故无动转。四双非已下释戏论字。言双非者。非止非观。斯则第四戏论谤也。再遣者又亡双非。谓非非止观等。由迹不忘如楔出楔。故并戏论。今由皆息戏论自亡。上但遮过。从得佛下显其成德。故疏云。虽止观双运而无心寂照等。双运即为双照。无心即为双遮。遮照同时互融平等。即是如如平等之境。第二自在主寄饶益行者。三聚净戒能益自他。故云饶益。疏持戒现世果故者。戒经云。明人能护戒能得三种乐。名誉及利养死得生天上故。疏福河常流注者。不持戒者可犯之境皆有犯分。由持戒故于无尽境皆发胜福故。疏有智能护戒者。文殊主智故。此言亦是戒经云。当观如是处有智勤护戒。戒净有智慧便得第一道。释曰。上二句以智为因。下二句是智之果。疏四重十重者。四重通二乘别解脱戒。十重已下大乘四重通。亦唯大故。弥勒受戒羯摩但受四不可过。谓十重之中最后四戒。谓悭嗔赞毁及谤三宝故。疏成五明者。五明在下业中。上之诸名体但是声明中义并如五地。今当略释。疏二业用中三初总明者。此之总文亦即声明书。即声明中法施设建立名句文身等故。其数算印即声明中数施设建立。通治取与中生疑障其界处等。法即是因明故。新经云。种种论是论体。即言论诤论等。疏杂辨诸明者。即余三明。一即医方明于中风痫消瘦是病相鬼魅所著亦是病相。亦是病因因鬼等病故。其能疗治即是除断。能字亦是断已不生。二亦能造立下。即工巧明。瑜伽十五有十二工巧。今略有五明。一营造工业。二以善调练种种仙药者。即和合工业。三善营理田农。即营农工业。四商贾。即商贾工业。其一切诸业。即该诸文所不说者。更有七不说。谓音乐书算成熟方所事王变化咒术。五又善别知众生身相。即占相工业。三作善作恶下即是内明。然瑜伽有四施设建立。一事二理三摄圣教四圣所应知。今文唯明于理。于中有二。一知六趣因果。二此人下知三乘因果。从如是等下。总结兼于余三。谓令其习学决定究竟即摄圣教。圣教所知应辨事。理事即三藏故。下知算亦声明摄

大方广佛华严经随疏演义钞卷第八十六大方广佛华严经随疏演义钞卷第八十七

        唐清凉山大华严寺沙门澄观述

疏。第三具足优婆夷寄无违逆行。忍顺物理名无违逆。疏又表忍必自卑下。上直约善友依报释。此下约表位释。忍必谦卑卑而不可逾。故小而大容。上通三忍法忍同如。即谛察法忍。内空外假者埏埴以为器。当其无有器之用即假能用。即空能大无有不成于空故。故因外假而内有所用。故老子云。有之以为利。无之以为用。无空不成于假。故空能多容。此二无二中道器也。疏二乘虽然不立忍名义如玄中。疏约事如受乳糜者。即世尊初成道。受二牧牛女所有乳糜。亦如前引。约法餐上品寂灭忍者。上品属佛故如十忍品。疏净名香积与此大同者。谓受食已得圣果等故。然净名有二处文。一香积品中取饭来竟。维摩诘语舍利弗等诸大声闻。仁者。可食如来甘露味饭。大悲所熏。无以限意食之使不消也。生公释云。以其向念故教食也。亦欲因以明食之为理。泥洹是甘露之法。而食此食者必以得之故。饭中有甘露味焉。大悲所熏者。使人得悟为外熏义。岂曰食能大悲力焉。然则饭之为气大悲熏也。无以限意者。饭出大悲即无限矣。而限言少者则不消也。释曰。此乃以悲熏食得涅槃果。以果詺因为甘露味。未言食即表于涅槃。若即食为涅槃之理。义则善成。二菩萨行品。因净名文殊礼觐世尊。阿难怪问。今所闻香昔所未有是为何香。佛言。是彼菩萨毛孔之香。身子亦言。我等毛孔亦出是香。问其从来。云食是香饭。阿难问净名云。是香气住当久如。维摩诘言。至此饭消。曰此饭久如当消。曰此饭势力至于七日然后乃消。又阿难。若声闻人未入正位。食此饭者得入正位。然后乃消。已入正位得心解脱。若未发大乘之意至发意乃消。已发意得无生忍。已得无生忍至一生补处。皆有食此饭者然后乃消。譬如有药名曰上味。其有服者诸毒灭已然后乃消。此饭如是。灭除一切诸烦恼毒然后乃消。彼疏广释相竟。问云。香饭是色法。云何断惑。远公释云。由大悲香饭不思议力所以能断。如轮王有一宝床圣王居上。即能离欲逮得四禅玉女。虽见如观佛像不生欲心。况佛菩萨所受境界。如华手经说。菩萨有一照法性冠。着此冠时一切诸法悉现在心。诸事亦尔。楷公云。虽有此释道理不然。岂有色法性能断惑。但以香饭资发观智能断烦恼。非是食体即能断惑。释曰。此亦诸古德意并未惬当。且约胜缘以解香饭。不知香饭以表法门。是以生公稍近于理。故云七日消者不过七日。一生补处即七日之内必有所得矣。然一食之悟亦不得有二阶进也。今止一生补处者。显佛无因得也。无生菩萨及正位之人。岂得假外方得进哉。而今云尔者。以明此饭为宣理之极。备有其义焉。释曰。此以有表理意也。然净名中食意通理智大悲。甘露味饭即三德涅槃。涅槃经中亦以涅槃将喻甘露。其饭香气即表大悲。从体起用熏众生故。今此寄位故表于忍。忍通五忍无法不摄。能忍是智所忍是理。广说利他大悲熏也。然净名云。得忍则消。亦该五忍之意。不为此释殊为浅近。疏第四明智居士寄无掘挠行者。勤无怠退故。疏同四住中生者。四住生圣教家。以三贤十圣大类相似。故前同四住后同四地。疏食有五果者。即涅槃第二如来告纯陀云。我今施汝常命色力安无碍辩。由施于食益命益色益力益安益辩才故近得此五。由是无常终得常五。并如回向品中已释。今此具配。疏第五法宝髻寄于无痴乱行者。以慧资定静无遗照。动不离寂名无痴乱。疏寻教得解即教四门等者。但约诠旨以为二种四门。亦约教为信行。约理为法行。若准新经言面各二门故有八门。则亦可即就四门存泯不同以为八耳。如一有门见心妙有。而入法界则是有门。若取于有即拂有相名非有门。此有中有二矣。二空者知法空寂即是空门。以空为空门。便权说非空门。三若谓妄惑本空真智不空。即亦有亦空门。谓有二体斯门亦权。故说妄因真立妄无妄源。真对妄宣真非真矣。则双存两亡。则为亦有亦非有亦无亦非无门。四若谓欲言其有无相无名。欲言其无圣以之灵。为非有非无门。若滞双非未逃戏论。故复拂之此双非门。为但是遮为有所表。但遮同无。有表同有还成有无故。此双非言思亦绝。名非非有非非无门故有八门。得意为门失意此八亦非门矣。疏第六普眼长者。寄善现行者。慧能显发三谛之理般若现前故。疏无量有二下。疏中先释无量。后知见下释知见。于中亦二。先别依法华论。后通即般若论。论云。如来悉知是诸众生便足。何故复说如来悉见是诸众生。若不说如来悉见是诸众生。或谓如来以比智知。恐生如是心故。若尔但言如来悉见是诸众生便足。何故复说如来悉知是诸众生。若不说如来悉知是诸众生。或谓如来以肉眼等见。为防是故说知见二语。功德施论上卷云。何故知见俱说耶。为开显一切智故。此复云何。贵于诸境界耶。然现觉非如比智见烟知有火。不能照了故诸相差别。亦非如肉眼见粗近细种。远处即不能知。但随他说或如彼。故智论二十九。明十八不共法解脱无减中。问曰。解脱知见者。但应言知。何以复言见。答曰。言知言见事得牢固言。如绳二合即为坚。复次若但说知即不摄一切慧。如阿毗昙所说。慧有三种。有知非见。有见非知。有亦知亦见。有知非见者。尽知无生智五识相应知。有见非知者。八忍世间正见五邪见。有亦知亦见者。余师诸慧若说知谓不摄见。若说见则不摄知。是故说知见则具足。复次如从人读诵分别筹量是名知。自身得证是名见。譬如耳闻事尚有疑是名知。亲自目睹了了无疑是名见。解脱中知见亦如是差别。瑜伽八十六云。问知见有何差别。答照过去及以未来非现见境此慧名知。照现在境此慧名见。又所取为缘此慧名知。能取为缘此慧名见。又闻思所成此慧名知。修所成者此慧名见。又能断烦恼此慧名知。断烦恼已能证解脱此慧名见。又缘自相境此慧名知。缘共相境此慧名见。又寻求诸法此慧名知。既寻求已伺察诸法此慧名见。又缘无分别影像此慧名知。缘有分别影像为境此慧名见。又有色尔焰影像为缘此慧名见。无色尔焰影像为缘此慧名知。释曰。尔焰为所缘也。成实论第十九见知品云。问曰。正见正知有何差别。答曰。即是一体无有差别。正见二种世间出世间。世间者。谓有罪福等。出世间者。谓能遍平等平等。诸谛正智亦尔。乃至问曰。经中说知者见者。则同漏尽有何差别。答曰。若智初破惑名知。入诸位已名为见。始观名知。达了名见。有如是深浅等别。俱舍二十六。通明忍智见别。论云前品初。说依法忍法智于后复说正见正知。为有忍非智耶。为有智非见耶。颂曰圣慧忍非智。尽无生非见。余二有漏慧皆智六见性。释曰初句及第三句余二字明无漏慧。有漏已下明有漏慧也。圣慧忍非智者。圣慧忍谓见道中八忍也。忍非智性决断名智。忍起之时与非得俱。未成决断故不名智。尽无生非见者。尽无生智不名为见。推度名见此之二智。已息求心非推度故。故不名见。余二者余无漏慧皆通知见二性。已断疑故推度性故。有漏慧皆智六见性者。诸有漏慧皆智性摄。于中唯六亦是见性。谓身见等五及世间正见。如上圣慧及有漏慧皆择法故并通性摄。大婆沙九十五论云。应具分别见智慧三自性差别。云何为见。答眼根五见世俗正见学无学见。问何故眼根说名为见。答由四事故。一贤圣说故。二世俗说故。三契经说故。四世现见故(云云)。问何故此五说名为见。答以四事故。一观视故。谓能观视所应取境。二决定故。谓能决定所应取境。三坚执故。谓于自境坚固僻执。非圣道观不能令舍。四深入故。谓于所缘锐利深入如针堕泥。云世俗正见者。谓善意识相应慧。是见性故说名为见。学见者谓学有漏慧。无学见者谓无学正见。此二俱是见性故名为见。五见为境如阴夜见色。世俗正见于境如晴夜见色。有学见于境如阴昼见色。无学见于境如晴昼见色。云何为智。答五识相应慧除无漏慧。余意识相应慧。五识相应慧有三种。一善二染污三无覆无记。余论说诸见是智断。应作四句。有见非智。谓眼根及无漏慧。忍有智非见。谓五识身相应慧尽无生智。余五见及世俗正见。余意识相应有漏慧。有见亦智。谓五见世俗正见。除无漏忍及尽无生智。余有漏慧即学八智及无学正见。此无漏慧及前五见。世俗正见皆具见智二种相故。第三句摄有非见非智谓除前相。相谓所有所有若名若法。是前三句所表皆名为相。除此余法为第四句义次广前来一经频有。无厌繁文。疏眷属般若者。然般若有五。一实相般若即所证理。二观照般若即能证智。三文字般若即能诠教。古唯有三新说有五。加四境界般若。实相唯悟真境兼后智体。今境界通事六尘之境皆为境界。五眷属般若即与慧同时诸心心所。今此具五城为实相。长者为观照。释无量中已有境界。今有眷属文字通四。疏别明十度之因感十身果。疏中但案文直释。此十亦即菩提愿等如来十身。一施度即相好庄严身。二戒获意生身以遍至故。三忍获威势身。四进策万行故成菩提。五禅获福德无等。六显法身。七成化身。八亦成愿身。九还成力持。十亦成智身。后一总净十身。疏第七无厌足王寄无著行者。方便涉有不迷于空。事理无滞不舍不受故名无著。疏先念教成益有十七心。初欢喜为总余十六别。一净信者信乐闻法。二下化上求。三法乐怡神。四勇求进趣。五欣庆所得。六悲智双流。七不取不生。八以德严饰。九不着万境。十不碍起修。十一物我齐均。十二不被心使。十三无住而住。十四称理普周。十五见佛相严。十六不舍佛智。疏后行深玄中。疏文有五。一总标令信。二然善财下征其疑心。三逆行下出其疑意。四贪益下通其伏难。五言深玄下。示其深玄先标后证可知。疏第八大光王寄难得行者。无障碍愿力乃能得故。疏二十八相因未满者。未见经论应阙无见顶及眉间白毫梵音广长舌。以善生等经校量最胜故。谓三十相不及毫相。三十一不及乌瑟尼沙。总合不及如来胸中所出梵音义。合将二十九相以校白毫。三十中一是梵音故。长舌无文义为胜尔验之。疏第九不动优婆夷寄善法行说法授人动成物轨。思择修习一切法故。疏五中初二所持内德等者。然此五法即下因中所念五事。谓思惟如来福德智慧。皆悉清净总持三昧。不可思议神通自在辩才无碍。谓思念何因得斯五德。彼佛便教发十种心。一谓应发不可坏心灭诸烦恼。二应发无能胜心破诸取着。三应发无退怯心入深法门。四应发能堪耐心。救恶众生。五应发无迷惑心。普入于一切诸趣受生。六应发无厌足心。求见诸佛无有休息。七应发无知足心。悉受一切如来法雨。八应发正思惟心。普生一切佛法光明。九应发大住持心。普转一切诸佛法轮。十应发广流通心。随众生欲施其法宝。释曰。十中初二成其所念福智故。今得第一难摧伏智慧藏解脱门。疏已取下佛教以释其相。下四亦尔。次以第三无退怯心。酬其所念总持故。今得第三一切法平等总持门。三以第四救恶众生。及第五诸趣受生示神通因。今得第二菩萨坚固受持行门。遍生五趣救恶众生。是大神通是菩萨行。四以第六求佛无厌。第七受法无足心酬其三昧。今得第五求一切法心无疲厌三昧门。五以后三示其辩才无碍因。今得第四照明一切法辩才门。在文可知故。疏取下十句示因。释今所得五法之果。而念福德含在智慧之中。其下释十法中。方云上来已取十句释五法门。但与下念五法不次显无优劣故。疏正明发心坚固者。即前五果之因。一求佛智慧即求法三昧。二求佛十力即求智慧。三求佛辩才。四求佛光明。即是总持。总持以慧为体故云光明。余皆坚固受持行愿。发是心已下总结坚固。疏第十遍行外道寄真实行。智度已圆称于二谛。言行不虚故名真实。大文第四。疏今初青莲华长者寄救护等者。大悲增上救护众生。大智无著离众生相。悲智无住以立此名。疏回向实际义通广大者。佛境方穷横周法界众生界故。疏上四各有事理思之者。如一知香体异约事可知。约理者如烧香。谓以智火发挥万行普周遍故。涂香者以性净水和之饰法身故。末香者以金刚智碎令无实故。即以智及性净等为生处也。如第二约类辩异。言约理者香即习气行。天之因是天习气熏灼成果故。亦是道习从天而来好光净等余类例。然三知力用者。上二约文但约世香而含约理。此则文自具二。如厌有为等约事。治诸病者白檀治热。熏陆治冷约理即诸对治行。所谓慈悲不净观等断诸恶者。如安息香能辟恶邪。正见智慧无恶不断。又十善行等。生欢喜香。如沉檀等即称根器行施悦自他等。增烦恼香如兰麝等。谓爱染行如有漏定增爱味等。灭烦恼香如牛头旃檀。先陀婆等。即诸智忍等。令于有为生爱着等唯约理说。此即人天胜因厌离有为。即无常等舍憍逸香。无我忍辱。不放逸等。发心念佛香。赞佛功德说净土行等。证解法门深观行等。圣所受用即观真如。无分别等。一切菩萨差别者。三贤十地所修胜劣等。一切菩萨地位香者。所证如智有浅深等。疏二人间有下疏文有二。初释象藏。后释余九。前中有二。先就事释可知。后若就菩提心下二约法。似如来藏即是形相。似如来藏本觉真心。性德圆备称理发心故似也。二因善恶相攻而生。即同因龙斗生故。六波罗蜜经云。善恶互相熏犹如二象斗。弱者去无回。妄尽无来去。起信云。真如熏无明故能发心厌求。三若一发下。出现四霔法雨。是成就五心所及下清净。六得法喜乐即安隐。七离惑业苦即方便。八展转兴慈即境界。九志愿纯净即威德。亦业用通前七。疏余之九下。二释余九言次五如次五分法身者。戒定可知。三王及四兵皆腾空者。慧证空故。四心念于佛脱五欲故。五集听法是知见故余可思之。疏第二婆施罗船师至寄不坏回向者。得不坏信十种善根而回向故。名为不坏。疏佛道为高下。新译此有十事五对。今经但有四对阙第四安危。疏但略示其相而未言等者。等于余义具说观相乃有多意。一不坏相则五是可依五不可依。二不坏性则不见高卑。无夷险等一无高卑。是故经云。不见一法是佛法者。不见一法非佛法者。故金刚云。是法平等无有高下。二住正道者。则不分别是邪是正。三不见业惑以为所断。不见智慧以为能断。非有烦恼非离烦恼。四不见生死为杂乱。不见涅槃为寂静。生死涅槃二际无差故无安危。五无大小三乘及一乘。非乘我所说故三性及相双俱不坏。则虽无高下不坏高卑。无高无卑为真高等。一一契中上三即三观意。四者以无所得而为方便。一时具观一具一切方真观矣。疏若佛法海者。准下推胜乃有多海。略举其二余例可知。疏色无色等依识心定。劫数浅深者。沈空滞寂即漩澓义。无色初二万后后二二增。非想八万劫为深。二万即为浅。色无昼夜殊。劫数等身量则初禅最浅上上渐深。未有无相皆识心定故为心识相也。疏有方便为坚等七地已说。疏又谓修行有住无住者。上约外境世之八风。此约正修无住为顺出离。有住为逆。又有住则顺生死流。无住反此。疏若开第三第五各三者。三中三者。一漩澓浅深。二波涛远近。三水色好恶。五中三者。一知其船铁木坚脆机关涩滑。二水之大小。三风之逆顺。此二各三为六并其余三为九。如是已下总结为十。可行则行可止则止。虽是总结义当一故。疏第三无上胜长者寄等一切佛回向者。谓等同三世一切如来能回向道所回向善故。以得胜通下释名。此约得法释等。于下约寄位释。疏由等诸佛不见美恶者。彼经云。如是修学回向道时见一切色乃至触法。若美若恶不生爱憎。心得自在无诸过失。广大清净欢喜悦乐。离诸忧恼身心柔软。诸根清凉是也。疏第四至一切处善友者。谓以大愿力令其善根。所成供等遍一切故。疏一无漏林树等者。多是净名佛道品偈云。总持之园苑无漏法林树。觉意净妙华解脱智慧果。八解之浴池定水湛然满。布以七净华浴此无垢人等。疏此云水天者。总持教中有此天也。疏初地证发心者。疏中随难但释二句。今当略释二地三聚圆满故。三地修八禅故四地无行无生行慧光故。五地如疏。六地般若现前遍照普得故。七地有中殊胜行。修习一切菩提分故名普庄严。八地得无生忍。于三世间皆悉自在。得忍如空念念入法流故。九地以无所得而为方便力度偏增。具足辩才演一切法为庄严故。十地十障已摧十度已满三祇已圆故。疏智论第八一切三昧皆入中者。论有喻云。譬如大海。谓若百川归大海故。又云有人言。王三昧者。在第四禅故。有人云。佛三昧谁能知相。一切佛法一相无相无量无数不可知唯佛能知。佛神足持戒尚不可知。况复一切三昧。释曰。此但叹胜耳。疏第五无尽功德藏由回向力能成无尽功德藏故。疏第六入一切平等善根回向善友者。事理无违皆入等理故。疏楞伽云。无有涅槃佛等者。即是经初。大慧赞于如来具知三性以成三身。初有四偈。明了遍计依他。谓世间离生灭等。十忍品已引。今此即叹具于圆成。云一切无涅槃无有涅槃佛。无有佛涅槃。远离觉所觉。若有若无有是二悉俱离。牟尼寂静观是则远离生。是名为不取今世后世净。有二偈半。大云解云。初一偈令了一如。谓此约无愿观以显圆成。无涅槃佛故无愿矣。初句谓色心等一切法中无得涅槃。以一切法本性如故。若得涅槃。是断常见。灭法是断。证得是常。次二句既无涅槃云何有佛。故下经云。见断烦恼而得成佛。此则名为坏佛法者。烦恼与佛性寂灭故。三四句中所觉如故无有涅槃。能觉如故无有得佛。离觉所觉混同一如。释曰。然上所解。理则尽矣。而消文未妙。今谓初句遣所证涅槃。次句遣能证之佛。第三句无能所契合。第四句总结所由。由离能所故皆无矣。无即空义。同一如矣。次若有下两句明不生二见。正显圆成远离见过。前偈破执此显不着。初句人法是有无我是无。二障是有无相是无。涅槃及佛此则是有。离觉所觉此则是无。皆成见过义须离之。故云是二悉俱离。后一偈明牟尼正观。此叹世尊寂静功德。了一切法本来寂静。无有一法而是生者。生见既亡不生。岂有无生无灭。故无可取亦无可舍。非染非净故二世净。今初但引二句足证不般涅槃耳。疏佛种从缘起佛缘理生者。上句是法华经。下句是生公释。古有二释。并如前引。今引生公。正顺经中佛种无尽之言。其即是常身法身亦涅槃文。涅槃二十三云。又善男子。断烦恼者不名涅槃。不生烦恼乃名涅槃。诸佛如来烦恼不起是名涅槃。所有智慧于法无碍是为如来。非是凡夫声闻缘觉菩萨是名佛性如来身心智慧。遍满无量无边阿僧祇土。无所障碍是名虚空。如如常住无有变易名曰实相。以是义故如来实不毕竟涅槃。释曰。此皆明无永灭之涅槃与是常住真实涅槃矣。疏第七等随顺一切众生善根者。谓以善根等心顺益诸众生故。疏文有四。一略释名。二在补怛下略释处。三又观自在下广释友名。四文中下释文。今初。三业归向。如下别中六通赴缘者。谓天眼遥观。天耳遥闻。他心遥知。神足速赴。宿命知其可度。漏尽令其解脱。摄谓摄受。利谓利乐。并如下经。由此下释寄位名。疏又观自在下。三广释中三。初双标二名二。梵云下双释二名。三随字别释。二中有五。一以梵言轻重分成二名。二而法华下成观音义。即彼经最初。答无尽意。佛告无尽意菩萨。若有无量百千万亿众生受诸苦恼。闻是观世音菩萨。一心称名。观世音菩萨。即时观其音声。皆得解脱。释曰。上即总意亦兼心语。三若具三业下成自在义。亦彼经文初标故。彼经下出三业相。初一语业。称名除七灾者。经云。若有持是观世音菩萨名者。设入大火火不能烧。由是菩萨威神力故(其一)若为大水所漂。称其名号。即得浅处(其二)若有百千万亿众生。为求金银琉璃砗磲码瑙珊瑚琥珀真珠等宝。入于大海。假使黑风吹其船舫。漂堕罗刹鬼国。其中若有乃至一人。称观世音菩萨名者。是诸人等。皆得解脱罗刹之难。以是因缘名观世音(其三)若复有人临当被害。称观世音菩萨名者。彼所执刀杖。寻段段坏(其四)下取意引上。一火不能烧。二水不能漂。三恶风不吹。四刀杖段坏。五恶鬼莫视。六枷锁离身。七怨贼解脱。二身业。礼拜满二愿者。谓设欲求男。便生福德智慧之男。设欲求女。便生端正有相之女。三意业。存念净三毒者。若有众生多于淫欲。常念恭敬观世音菩萨。便得离欲。若多嗔恚多痴准例上贪。斯即三业归向也。彼经略举。若准下经及彼偈文。危苦众生多应时权救斯为自在。四而今多下。结成观音也。今取下结成自在。上通相释。疏然观即下。第三随字别释。言观即能观者显属菩萨。通一切观者。即智者意。然彼繁博。今取意释。谓三业归依观通心眼了见诸相而无所著。彻见体性空无障碍。一切种智圆顿观察。故经云。真观清净观。广大智慧观。悲观及慈观。常愿常瞻仰。无垢清净光。慧日破诸暗。能伏灾风火。普明照世间。皆是观义。言世是所观。通一切世者。世略有三。谓三世间。若山若水悬崖邃谷畏难之处器世间也。无量众生即众生世间。亦观佛会所有众生。常在一切诸如来所。即是观察智正觉世间。从若云自在下。案文就义自在则宽直。就名言自在却局阙所观故。然有能观必有所观。不尔于何而得自在。能所无二不坏能所。一观一切观。无观无不观。为真观矣。疏又令归向本所事者。本事即阿弥陀故。念诵者令先称本师之名。顶上化佛即是弥陀故。疏又门即普门普门示现曲济无遗故者。以普门字释经行门普门之名。即法华经观音品目曲济无遗。是生公释具云。曲济无遗谓之普。从悟通神谓之门。天台智者说有十普。一慈悲普。二弘誓普。三修行普。四离惑普。五入法门普。六神通普。七方便普。八说法普。九成就众生普。十供养诸佛普。此十一一称实普周。今经下文业用之中略列十一门即十一普也。疏然大圣久成正觉者。即千手千眼陀罗尼经。依无量寿经继无量寿当得作佛。号普光功德山王佛。亦迹门尔。疏方法华经三十五应者。即无尽意问云。观世音菩萨云何游此娑婆世界。云何而为众生说法。方便之力其事云何。佛告无尽意。若有国土众生。应以佛身得度者。即现佛身而为说法。二辟支佛。三声闻身。四梵王。五帝释。六自在天王。七大自在天王。八天大将军。九毗沙门。十小王。十一长者。十二居士。十三宰官。十四婆罗门。十五比丘。十六比丘尼。十七优婆塞。十八优婆夷。十九长者妇女。二十居士妇女。二十一宰官妇女。二十二婆罗门妇女。二十三童男。二十四童女。二十五天。二十六龙。二十七夜叉。二十八乾闼婆。二十九阿修罗。三十迦楼罗。三十一紧那罗。三十二摩睺罗迦。三十三人。三十四非人。三十五执金刚神。皆如初句次第义加。以长者居士宰官婆罗门。共一即现妇女身而为说法故人谓之三十二应。理实四类。各各不同故。妙音中云或现长者居士妇女身。或现宰官妇女身。或现婆罗门妇女身。明知四类有四妇女。况妙音中有转轮王及菩萨身。又加地狱饿鬼畜生及诸难处。皆能救济岂无彼身。则三十五亦未为尽。若开四妇女各成二人以妻女别故。则此已有三十九矣。明知观音诸大菩萨。各能万类之化皆略举耳。疏但是此中或现色身及说法耳者。以三十五应皆云即现其身而为说法。具如初一。明知通是此二义耳。疏皆五怖畏中事者。准十地论五畏摄诸畏故。若是新经下文有颂一一具颂此十八怖。法华观音偈中亦不离此怖。恐繁不引。今略明五摄然五多约果略由二因。一邪智妄取我见爱着故即不活恶名死畏之因。二善根微少即大众威德及恶道畏因。今此十八有通因者然险道有二。若世险道即不活及死畏摄。若恶道因为险即是邪智。热恼有三。一失财热恼。不活畏摄。二处众热恼。即大众恶名畏摄。三毒热恼。即是畏因。迷惑有二。若迷惑方隅等。即众热恼不活畏摄。若心迷惑。大众畏因系缚。亦是不活畏摄。杀害死摄。黑暗迁移乃有二意。现暗迁移皆不活摄。恶趣黑暗三涂迁移即恶道畏摄。爱别离怖正唯死畏兼及不活怨憎会怖。正唯恶道。亦兼不活逼迫身怖死及不活。逼迫心怖大众威德及恶名摄。其忧悲怖死及不活二畏之相。亦通余三。疏即能离因者。谓三业归依我之三业。能令解脱令住正念。即无我我所及邪智故。第八正趣菩萨寄真如相善友者。谓善根合如成回向故。第九无缚无著者。谓不为相缚不为见着。作用自在故名解脱。第十入法界无量者。等以法界善根回向法界故

大方广佛华严经随疏演义钞卷第八十七大方广佛华严经随疏演义钞卷第八十八

        唐清凉山大华严寺沙门澄观述

疏。大文第五。有十善友寄十地。第一婆珊婆演底夜神。寄初欢喜地者。初获圣性具证二空。能益自他生大欢喜故。以于春时主当等者。盛德如春和畅发生故。表分别见日皆已亡者。初地断见惑即分别烦恼故。疏宗说兼通者。前已引竟即楞伽意。故彼第三经云。佛告大慧。三世如来有二种法通。谓说通及自宗通。说通者。谓随众生心之所应为说种种契经是名说通。自宗通者。谓修行者离自心现种种妄想。谓不堕一异俱不俱品。超度一切心意意识。自觉圣境离因成见相故。一切外道声闻缘觉堕二边者所不能知。我说是名自宗法通。释曰谓初了唯心谓不堕下。境界则灭。超度一切下。能取亦无。自觉圣下。正悟自心不由他悟。离三量成故离因成。一切外道下。对他显胜。经结劝云是名自宗通及说通相。汝及余菩萨摩诃萨应当修学。偈云谓我二种通宗通及言说说者授童蒙宗为修行者。释曰而前引竟今复重说者。前约证者能说故先明宗通。今约从教修证故先明说通。亦前从根本起后得。今从加行入根本耳。文小异。故第一疏中已引前文今复引后。古人云。说通宗不通如日被云蒙。宗通说亦通如日处虚空。疏法门星象下。此中法喻双辩。一身以表如体。星象以表法门。星象不离一身犹法门不离如体。下对亦然。教化表于大用。毛孔以况真性。其二愚二无我等并如地品。第二普德净光主夜神寄离垢地者。谓具净尸罗离于能起微细毁犯烦恼垢故。疏别中三是智法光明者。疏但随难解三。今当重释略有二意。一作总别释。初一总余九别。别中一观外相。二念内德。三知所证。四放光。五常光。六变化。七圆音。八名号。九调生。二约十身释。一菩提身。二相好身。三智身。四法身。五愿身。如贤首品毛孔放光皆宿愿故。六福德身。七化身。八力持身。圆音持法尽未来故。九意生身。随意立名故。十威势身。结云威力故。十身并彰内外皆具。若专念此何行不成。疏初明攀缘如实禅同如来清净禅等者。楞迦第二说有四禅。经云。大慧有四种禅。云何为四。谓愚夫所行禅。观察义禅。攀缘如实禅。如来禅。云何愚夫所行禅。谓有声闻缘觉外道修行者。人无我自性共相。骨琐无常苦不净相计着为首。如是不异观前后转进想不除灭。是名愚夫所行禅。云何观察义禅。谓人无我自性共相。外道自他俱无性已观法无我。彼地相义渐次增进。是名观察义禅。云何攀缘如实禅。谓妄想二无我妄想。如实处不生妄想。是名攀缘如实禅。云何如来禅。谓入如来地行自觉圣智相三种乐住。成办众生不思议事。是名如来禅。故偈云凡夫所行禅观察相义禅攀缘如实禅如来清净禅。释曰然古皆配位自有二师。一云初凡小。二至七地。三八地已上。四即佛地。二大云言。亦初凡小。二十信至回向。三即加行。四即初地至佛地。以证如故皆名如来。若修观者凡夫直用如来净禅。今此文中即以第三同于第四不同初二。初二是凡小二犹未亡法无我。故即以三四因果交彻。谓见佛法界即缘如义。无取无入即同如来清净禅义。又如来禅不碍下。文广利乐故疏文有十非大同。中论八不者。不全同故名为大同。而涅槃等多分全同。以其八不摄理尽故云全同耳。初四全同后六合为四。言非实非妄即是不常者。常有二义。一虚妄计度生死有常。今云非妄即非常矣。二者出世实法名常。今云非实亦无常矣。诸法实相中无实无非实故非迁非坏。即是不断者。断亦有二。一世法迁移即有断灭。二灭坏烦恼成于断德。今并非之故不断也。又此十句标多约体。释多约用意。明体用皆无二故亦可。总为五对体用。初不来不去即体用自体。二不生灭即体用相。三非实虚即体用力。四非迁坏即体用性。五一相无相即体用德。如十行辩。疏后思惟下正显四禅者。斯则以如来禅导于四禅。不同三地寄位四禅。四禅不同即为四别。然大小虽异支林功德名数。皆同有十八支具如三地。地论皆摄以为四类。一所离障。二对治支。三利益支。四彼二依止三昧。四中后三是支初一非支并如前说。疏离自忧者约五受说初禅已离忧受。今大悲救护即忧众生之忧。离忧合是所离。今念他忧却生喜乐故为利益。疏二禅中等者。然二禅具四支内净喜乐定。初明灭觉观即所离障。疏次摄一切众生是一心者一心摄故。然一心言是三地经有故。彼经云灭觉观内净一心无觉无观定生喜乐住第二禅。然其一心是释内心义。无觉无观即是净义。具此二法名之内净。又小乘内净但是信心。大乘内净即合二禅三支所成。谓舍念正知此之三心。尚为喜覆力用未胜但能离外寻伺故合为内净。今摄众生一心摄故已有合义。疏三禅中下。然具五支舍念喜乐定余如前说。疏四禅中者。四禅有四支舍念中受定今四支俱亡是所离障。即舍念清净为对治支。既无苦乐即是中受为利益支。然其舍受世为利益出世望之亦是热恼故。今疏云于下苦中横生乐想。既一切息灭则舍亦舍矣。方是真舍余如三地。疏修四念处等观者。念处观者即无常苦。不净无我等者等取十想。与智度论第二十六十想大同故。言十想者论云。一无常想二苦想。三无我想。四食不净想。五一切世间不可乐想。六死想。七不净想。八断想。九离想。十尽想。今有十三故云大同。第三喜目观察众生主夜神寄发光地。谓成就胜定大法总持。能发无边妙慧光故。疏神通度生菩提分等者。以瑜伽有四菩萨行。一波罗蜜行上已广竟故列下三。疏后类通余行具四菩萨行者。初菩提分法行。以从初发心积集功德皆助菩提是菩提分。二入诸三昧下。即三昧行。三得净天耳下。即神通行。得菩萨解脱下。成熟众生行。故后结云分别显示成熟众生。疏未解即心自性者。前劫未得十住自分。此劫未得十住胜进。疏未得六地深顺之忍者。六地得上品顺忍故。八妙胜劫下。无结说得之言。合言未得七地。而前劫但云修行最胜道即是已得六地耳。疏故其劫名亦顺地义者。此是疏家复为一释。以初劫名寂静音。已得初地二天胜劫。天即净义亦顺离垢。三梵光顺发光。四功德月顺焰慧。月有光明发光焰故。五寂静慧顺禅增故。六善出现顺善现故。七集坚固王功用满故。已得方便不可坏故。八胜妙劫顺于不动无功用故。九千功德法师位故。十无著庄严智慧无著二严满故。第四普救众生妙德主夜神寄焰慧地者。谓安住最胜菩提分法烧烦恼薪慧焰增故。疏后二句是等觉者。不言十地者上二句文十地显故。余位义隐故别指耳。疏表真精进却从定生者。真精进者离身心故非定无此。第五寂静音海主夜神寄难胜地者。谓真俗两智行相互违。合令相应极难胜故。疏后答中即分为四者。下疏文有三。初总科二问中下。料拣三今初。下释文二中由答与问不次第故。于中有四。初正通不次之妨初答第三。二答第一。三答第四。四答第二。故为不次。今释意云。问中初二是所成故。三四两问皆是能成。三成于初。四成于二。故今答中以第三能成成第一所成故。先答第三。次答第一。以第四能成成第二所成故。后答四二也。二又由能起所下。通伏难也。难云隔句相对于理甚明。而其二对问中何以先明所成。答中何以先答能成。故今释云由能成所故先答能。复应问言问中何以不先问能故应答言。问睹所成求能成故。见果推因犹如四谛。疏不明者。意易见故。三又观察中下。三通杂乱难。谓有问言。若以观为能成者。何故答中有所观耶所行之境是所成者。何以境中有能成行耶。故今答云观察之中虽有所观为成能观。如般若中虽有实相为成智慧。所行境中若能若所皆是所行。如诸菩萨行深般若能观所观皆所行矣。四故四问全别下。结引证兼结弹古人。古人以第一所起方便。及第二事业。皆答第一事业之问。以其第三答观察。双答第二第四两问。以观察境界不相离故。以答第四行何境界。却答第三起方便问。若为此释非但四答相不分明。抑亦答不次第杂乱故。疏释竟今乃结云四问全别。是以晋经中下。引经正证所行境中有能行义。谓若所知境唯是所行。若分齐境即有能行。是故疏云非但所观。以晋境界含能观故。疏二文影略者。前有大劫之名略无小劫之数故。应影取后文小劫。此中但明小劫之数略无大劫之名。故应影取前文大劫。则共有二佛刹尘数劫。疏若以普光明劫为刹尘之一者。上以普光即是大劫于中已有刹尘小劫。今为小劫之名。积普光等小劫之数经佛刹尘。言阙二字者。合云从此命终还即于此世界中生。经二佛刹微尘数劫。故引晋经定有二字。言佛弥多矣者。向以普光为大。大中有刹尘之佛。今普光为小劫。一小劫中已有刹尘。经二刹尘小劫之佛。二刹尘小劫之佛故佛弥多也。疏艮以前之四问皆业用者。望于菩萨解脱门故。事业但是四中之一。疏随一深法有多品类者。如一施度有九门等。四一一类中有多事法者。如一外施有多财宝等。五如一施食有多支派。第六守护一切城增长威力主夜神寄现前地者。谓住缘起智引无分别最胜般若令现前故。疏二十五有理无二故者。偈云四洲四恶趣梵王六欲天。无想五那含四空并四禅。义如前释。第七开敷一切树华主夜神寄远行地者。谓至无相住功用后边。出过世间二乘道故。疏五浊为因感三灾果者。三灾果有二者。一小三灾谓饥馑疾疫刀兵。谓七年七月七日止。谓各是一七二大三灾。谓水火风坏于器界。今此是前经文。具云初明饥馑以天不降泽故。二多诸疫病即疾疫也。三驰走四方靡所依怙义兼刀兵。然三灾复有二义。一约劫欲尽时人寿十岁等。二者少分往往多起。今此明约少分灾耳。疏先深起大悲者。钞消经文此悲心与第二地中集果多同。初一总明谓三求众生皆堕无底生死深坑难免出故。余九为别。又分为二。初一解邪理外推求总名为邪。横计世间常乐我净。起贪等惑故令住善业。余八行邪于中别显三求众生。即分为三初五悲欲求众生。次二悲有求众生。后一悲邪梵行求众生。初中又二。前三悲现行得五欲受用生过。后二悲未得五欲追求生过。前中即为三别。一悲不共财众生。欲资身命为生老等苦之所逼迫。而不得安令不着财则心安矣。二悲受无厌众生。内心难满恐得恶名。怖失财利故令得佛因。三悲贮积财众生。不能了达财多祸多。名无智眼决其疑见即为方便。第二痴闇所迷下。二门悲未得五欲追求生过。上三悲其起惑。此二悲其造业。前门悲求后报造有漏善。如夜暗行迷失道路当示慧炬。后门悲求现报造诸恶行。诳己所有嫉他胜己。谄诳求财诸惑浊乱。若绝诸恶则法身清净。第二长时漂溺下。二门悲有求众生。前门即道差别。谓五道循环藏识漂溺惑苦大海故令升彼岸。后门即界差别。谓眼等诸根六尘等。牵不得自在无有出期。以佛威神引之令出。第三以第十门悲邪梵行求众生。行不正道迷无我理。随逐邪见乃至九十五种别故引入智门。上十悲中。皆有所对能治。略以显示余如二地。第八大愿精进力主夜神寄第八不动地。谓无分别智任运相续。相用烦恼不能动故。疏今初由前起同己等者。疏文有三。初得同之因。二同有四义下示同之相。言由见初故则不殊余二者。谓由证见法界体同。故上同诸佛下同众生。云不殊余二则于菩萨为究竟之同。三良以八地下。偏说此文明同之由。疏所救千佛等者。法华经如来寿量品云。我实成佛已来经无量无边不可思议阿僧祇劫故。疏初明内契理事者。此义全同十通之中一切色身智通。前已广说故但略科总出其意。今当重说由内证实故外现色。所以起信论云。问曰若诸佛法身离于色相者。云何能现色相。答曰即此法身是色体故能现于色。所谓从本已来色心不二。以色性即智性故色体无形说名智身。以智性即色性故说名法身遍一切处。所现之色无有分齐。随心能示十方世界。无量菩萨无量报身。无量庄严各各差别。皆无分齐而不相妨。此非心识分别能知。以真如自在用义故。释曰彼虽约佛。今此位极大同佛也。次释经文又此三段。初明内契理事明色即空。二明大用广现色身者空即色故。后结深广不碍悲故。今初由了法界无定实色举体即空而非断空。空中无色不碍色故。色空无碍存亡隐显皆自在故。方能随乐现种种色。故先明其内契事理。经中先明证实离相。后双了性相。今初悟一切法自性平等者。此句总明云何平等。次云入于诸法真实性故。谓真实性中无差别相。无种种相无无量相。万法一如何有不等。此真实性依何立。故复次明证无依法。所谓不依于色不依于空。若万法依空空无所依。今万法依真真无所依。即无依印法门故。舍离世间。世间即有种种差别。斯则性尚不立何况于相。亦不依空立色。亦不依色立空。亦无异无不异。无即无不即斯见亦绝强名内证后悉知。诸法色相差别下。双了性相初明了相即空。空即色故。后亦能了达下。此明了性色即空故。又上句色中无空下句空中无色。又上句色能容空。下句空能容色。又上句。空能显色。下句色能显空无障无碍。疏二而恒下。明无涯大用者。经中初句云而能示现无量色身者。牒前起后故云而能由上空不碍色故能现色。又若以色为色不能现色。今即色非色故无不现。又即空之色方为妙色。故蹑上明色空不二。成上真空不二而二。斯为妙色。色空融即为真法界。缘起无尽即一现多。起信等论明八地当色自在者。起信云。四者现色不相应染。依色自在地能离故。释曰何以得知论是八地前有七地后有九故。言等论者等取瑜伽等。即上八地由证无生绝色累故。得十自在十身相作如影普现皆色自在。疏上诸夜神叹深皆仿斯法喻者。然多问发心时之久近而答智轮。即体用故。然斯五喻非无有义皆前已有故疏不释。疏膑谓刖足者。然俗有五刑劓墨宫割膑大辟也。疏义当彼时已得四地者。初地百。二地千。三地万。四地百万故。第九岚毗尼林神寄善慧地者。谓成就微妙四无碍辩。能遍十方善说法故。疏此十通于六位下。疏文有五。一约位竖配亦名行布释。二然依行布下结前生后生后圆融。三若约圆融下通诸位释亦名圆融释。四若定须具十下结成上竖五若定竖下结成须横。实则横竖无碍是此中意故存二释文义昭然。疏亦初住生家者。恐人误为初地生家。然其生家略有六位。一初住生菩提心家。二四住生圣教家。三初地生真如家。四四地约寄位生出世家。五八地生无生法忍家。六如来地究竟生家。今是初住即第一生菩提心家。疏即净心地者。疏随难释今更委释。言得如来菩提光者。明心菩提故入菩萨方便海者。证真了俗故舍诸有趣。亦由已断异生性故。成就自在者分身百刹故。修菩萨殊胜行者。净治地法十行常修故。具菩萨根者。由证信故余皆成根。又大悲为首故悲为根。已断所知故心明洁十愿成熟故愿不动。同佛证如故得佛护。分别顿尽名坏诸障具上诸德为物依处。疏戒忍进等者。等取禅慧各一增故。末后二句上句三业善巧见者必欣下句。功用行满。又以无功得诸行故。疏六中下。初至为生佛家此有两句。一正释标。二即解释。初之二句得无生忍是释生家。契同法性即释随诸佛住。佛住甚深真法性故。上即净忍分成就。一切甚深法门下。皆得胜行分此句为总故疏不释。已下皆甚深法门故其愿度增上释具三世已下经文。善根一体释得一切佛下经文。谓同无功用之善根故。同契无生法忍体故。从惑等下释具出世白净法。上皆前经不可知义。经安住已下即是前经正行广大。入诸三昧下即离障寂灭。后三句即三轮化益并易故不释。疏七中因佛力下。经疏俱易若欲释者由佛七劝。名入诸佛力此为总句。游刹下别二句起行速疾。从了一切下。是净土分中事。于三世间得自在故。初二器界。自在。次二正觉。后三众生说法度生故。疏八观普智门言即法师之德者。亦法师方便成就。言于三性等者三性即是化法为智成就等。等字等取入行成就智十一稠林。经一一门下。即口业成就具四十无碍故。能长演余皆法师自在成就。一三昧自在随心顿演故。二受生自在。三于有差别下。于法自在事理交彻故。疏从即事知理下释此初对了即事入理即理入事。亦前句事能显理后句依理成事。又前不坏假名而说实相。后不动真际建立诸法。又前动不离寂。后则静无遗照。于无量下有无自在。于少境下广狭自在。通达下真俗齐照。以文显故云可思准。疏九普现庄严先释名后已得下总释大意。若别说者。初句严依。余皆严正。正中并秘密智初三句身秘密。演清净下口秘密。随其心下皆意秘密。疏十中下经文显然。皆与本位义理相符。不为此释实抑经文余并易了。第十释女瞿波。寄法云地者。谓大法智云含众德水。蔽如空粗重充满法身故。疏悲智逆顺权实寂用无碍双行之行者。此中疏有四种无碍。亦名四种双行。其十句中句句皆是双行。约双行事有十差别。其中双行但有四别耳。如第一句云云何于生死中。而不为生死过患所染者。即悲智无碍。谓于生死中即有大悲故。不为生死过患所染。即具大智故二了法自性。而不住声闻辟支佛地即寂用双行。三即实而权双行。四即权而实双行。五即逆顺双行。六即寂用双行。七八皆即实而权。九十皆权实双行。九约化生。十约供佛。十一真俗双行各有别相。疏然前长行但名帝网等者。此即显帝网之义也。疏先具相者。经有三十二相。前文指此广明。以文具故今当略说。准瑜伽四十九。及大般若第三百八十一说。然彼经次与今不同。今依彼经次第列名以今经文注之于下。经云佛言善现。云何如来三十二相。善现。一世尊足下有平满相。妙善安住犹如奁底。地虽高下随足所蹈。皆悉坦然无不等触(今经当第三相)。二世尊足下。有千辐轮纹网毂众相无不圆满(四)。三世尊手足皆悉柔软。如睹罗绵胜过一切(八)。四世尊手足二指中间。犹如鹅王咸有网鞔。金色交络文同绮画(六)。五世尊手足所有诸指。圆满纤长甚可爱乐(义当第二)。六世尊足跟广长圆满。与趺相称胜余有情(七)。七世尊足趺修高充满。柔软妙好与跟相称(五)。八世尊双腨渐次纤圆。如伊泥耶仙鹿王腨(九)。九世尊双臂修直佣圆。如象王鼻平立摩膝(十四)。十世尊阴藏相势峰藏密。其犹龙马亦如象王(十一)。十一世尊毛孔各一毛生。柔润绀青右旋宛转(二十九)。十二世尊发毛端皆上靡右旋宛转。柔润绀青严金色身甚可爱乐(三十)。十三世尊身皮细薄润滑。尘垢水等皆所不住(二十七)。十四世尊身皮皆真金色。光洁晃曜如妙金台。众宝庄严人所乐见(二十八)。十五世尊两足二手掌中颈。及两肩七处充满(十)。十六世尊肩项圆满殊妙(十三)。十七世尊膊腋皆悉充满(十五)。十八世尊容仪洪满端直(三十一)。十九世尊身相修广端严(义当第一)。二十世尊体相纵广量等。周匝圆满如尼瞿陀树(三十二)。二十一世尊颔臆并身上半。威容广大如师子王(十二)。二十二世尊常光面各一寻(欠此一相含在第二乐见之中)。二十三世尊齿相四十。齐平净密根深白逾珂雪(十八)。二十四世尊四牙鲜白锋利(二十)。二十五世尊常得味中上味。喉脉直故能引身中诸支节脉。所有上味风热痰疾不能为杂。由彼不杂脉离沉浮延缩损坏壅曲等过。能正吞咽津液通流故。身心适悦常得上味(义似颈文三道即当十六)。二十六世尊舌相薄净广长。能覆面轮上至发际(二十一)。二十七世尊梵音词韵和雅。随众多少无不等闻。其声洪震犹如天鼓。发言婉约如频伽音(二十二)。二十八世尊眼睫犹若牛王。绀青齐整不相杂乱(二十四)。二十九世尊眼睛绀青鲜白红环间饰皎洁分明(二十三)。三十世尊面轮其犹满月。眉相皎净如天帝弓(义是颊如师子则当第十七)。三十一世尊眉间白毫相右旋柔软如兜罗绵鲜白光净如珂雪等(二十五)。三十二世尊顶上乌瑟腻沙。高显周圆犹如天盖(二十六)。善现是名三十二大士相。释曰上依彼次具引。今经望之阙于圆光一寻。含在人所乐见之中。若依瑜伽开四十齿。与牙齿鲜白有异则具三十二。今更依今经次列之。注大般若次第于下。一端正殊特(十九)。二人所乐见(含于第五甚可爱乐及第二十二圆光一寻)。三足下平满(一)。四轮相具备(二)。五足趺隆起(七)。六手足指间皆有网鞔(四)。七足跟齐整(六)。八手足柔软(三)。九伊尼耶鹿王腨(八)。十七处圆满(十五)。十一阴藏隐密(十)。十二其身上分如师子王(二十一)。十三两肩平满(十六)。十四双臂佣长(九)。十五身相端真(十七)。十六颈文三道(义当二十五)。十七颊如师子(义当三十)。十八具四十齿(二十三)。十九四牙悉皆齐密(大般若合上二则亦当二十三今皆瑜伽开也)。二十四牙鲜白(二十四)。二十一其舌长广(二十六)。二十二出梵音声(二十七)。二十三眼目绀青(二十九)。二十四睫如牛王(二十八)。二十五眉间毫相(二十一)。二十六顶上肉髻(三十二)。二十七皮肤细软(十三)。二十八如真金色(十四)。二十九身毛上靡(十二)。三十发帝青色(当第十一)。三十一其身洪满(十八)。三十二如尼俱陀树(二十)。释曰上略会二经。若依瑜伽及涅槃说相因各异。又小不同具如初会。疏三宝女求归者。女人谓嫁曰归。故周易中有归妹卦。大文第二会缘入实相。疏中有五。一总科释。二然人虽下料拣。三摩耶既会下解妨难。先问后岂不下释。四又此一下别示义门。五初天主下。总释诸会而有二意。一即等觉入俗之意。二即是前别明会缘。后归此二。今初下释文前五中皆牒彼所得初天主光且须正念无失者。彼得菩萨解脱。名无碍念清净庄严故。二可为世师即遍友不得法门。三遍穷下即善知众艺童子得解脱。名善知众艺而广说字母。四无依无尽则贤胜优婆夷得无依处道场。又得三昧名为无尽故。五无著清净。即坚固解脱长者得解脱。名无著念清净庄严故。六清净即净智发光者。即妙月长者得解脱。名净智光明故。七发光则智相无尽者。即无胜。军长者得无尽相解脱故。八无尽则诚愿不违者即最寂静婆罗门。得解脱名诚愿语故。九方能还归幻住者。即德生有德得幻住法门故虽下总结。疏今初摩耶昔云天后者。新译为幻术故云昔也。亦云幻生得幻智门故。疏已能暗合愿智幻门者。以今文云具净法身。以如幻业而现化身。以如幻智而观世间等故。疏冥契下文天后所现者下见正报现无量身云。今此未见已知现身故云冥契。疏但总意若别配之。此十七身。摄下经中四十身。四十身各有二句。上标下释。一随意生身即总显随愿。二无生灭身即下二色身谓不生色身无生起故不灭色身常寂灭故。三无来去身即下二身。谓无去色身于一切趣无所灭故。无来色身。于诸世间无所出故。四非虚实身亦摄二身。即下经云非实色身得如实故。非虚色身随世现故。五不变坏身即下不坏色身。法性无坏故。六无起尽身即不生色身。随众生身随众生业而出现故。恒示现色身尽众生界而无尽故。上二句皆标之以性释之以相。异上一向无生灭也。七所有诸相皆一相身下。云一相色身无相为相故。八离二边身即是通意皆事理无滞故。若别配者。如下云法性色身性净如空故。大悲色身常护众生故。上句离有边。下句离空边。又上句有智不住生死。下句有悲不住涅槃等。九无依处身即下无处色身。恒化众生不断绝故。十无穷尽身即无尽色身。尽诸众生生死际故。十一离诸分别如影现身。即下无分别色身。但随众生分别起故。又即如影色身随愿现生故。十二知如梦身即如梦色身随心而现故。十三了如像身即普对现色身。以大自在而示现故。犹如明镜质对像生。十四如净日身即清净色身。同于如如无分别故皎日无私故。十五普于十方而化现身。即下化一切色身。随众生心而现前故。十六住于三世无变异身。即下无动色身生灭永离故。十七非身心身即下总显其体。云如是身者非色所有色相犹如影故。乃至离识菩萨显智空无性故。以一切众生言语断故。已得成就寂灭身故。故今结云犹如虚空所行无碍。超诸世眼唯是普贤净目所见略为此配。余纵不尽可以类收。疏即初地净治地法。十种胜行文少不次者。彼次云佛子菩萨如是成就十种净治地法。所谓信悲慈舍无有疲厌。知诸经论善解世法惭愧坚固力。供养诸佛依教修行。释曰其供养诸佛依教修行。即如说行之一行耳。疏故央掘经等者。央掘之缘玄中已引。今直释所引之义。然第二经后世尊令其三归依。答云我唯一依佛即是法法即僧故。意明一学至第三卷。佛问云何为一学。偈云一切众生命皆由饮食住。是则声闻乘斯非摩诃衍。所谓摩诃衍离食常坚固。云何名为一。谓一切众生皆以如来藏毕竟常安住。次二谓名色。三谓三种受。四谓四谛等皆然。此即云何名为五。所谓彼五根是则声闻乘斯非摩诃衍。所谓彼眼根于诸如来常决定分明见具足无减修。耳闻鼻嗅舌尝身触一同于眼。然有二本。一本云了了分明。一本云决定分明也。次云云何名为六。所谓六入处是则声闻乘斯非摩诃衍。所谓眼入处于诸如来常明。见六入门具足无减修。闻嗅尝触皆同眼也。意入处云所谓意入处。明说如来常不闻违逆心净信来入门。义如疏释遍历七觉八正九定十力皆举大折小。说如来藏如来常乐我净为无缺减也。故疏云余可知可知有二。一则例央掘。二例此中余三昧等。疏普贤之华者此中虽不举华量。十定云无有边际也。疏上二并是住体遍应者。然此即缘起相由门中三义。一诸缘各异义。二互遍相资义。三体用无碍义。今言住体即诸缘各别。言遍应者即互遍相资即住体。而遍应是第三体用无碍也。然上摩耶万类殊应即异体中多。今此善财一类之身遍对摩耶即同体中多。若约摩耶善财并不分而遍。同异虽殊住体遍应义无别也。摩耶亦是同体一即多。以随所应异无二体故。下自言非一处住非多处住。善财亦是同体多即一诸处善财。即一身前之善财故。又二圣互望并含同体异体。以一摩耶应多善财故。此即摩耶为同体。以多善财对摩耶故。即善财异体。疏不坏小而广容。即广狭无碍门。无生起而生起。即事理无碍门。又愿收普贤等者。上约别愿今是通愿。无愿不收无智不摄。等愿智相融皆是大幻。成不共般若故生佛也。疏本来无二者称一性故者。疏以蹑上即此多身。便云本来无二多皆称性故。若约事说亦可本唯一耳。下非一处住非多处住总有四释。第一唯就体上以辩双非故非多。云不如事故者。谓理唯一味不如事之多也。第二对约不坏性相说。上句不坏相。下句不坏性。亦是不坏一多说。此一即是对别约事之一。第三对约事理相如说。相如即无碍之义耳。亦是事理相遍第四对唯约于事互相融说。即事事无碍义。然具即入二门通缘起相。由理性融通及同体异体。言并是释中智幻之义者。以名中云大愿智幻上广引愿为诸佛之母竟。故此结中是释上名中智幻之义也。疏天主光女父名正念者。即第三会问梵行之王也。又云往三十三天者。是摩耶舍化所生天也。则知摩耶非独在天。故晋经云在迦毗罗城耳。第二遍友可知。第三众艺中二我恒下。显其业用者。疏文有三。一标章立意。二总科。三释文。今初言字母为众艺之胜书说之本者。出偏示所以也。以标知众艺而偏释故。故智论云诸陀罗尼皆从分别语生。四十二字是一切字根本。因字有语因语有名因名有义。菩萨若闻其字乃至能了其义。是字初阿后荼中有四十。得是字陀罗尼多所成益乃至广说。又如本行集云。尔时菩萨为诸童子一一分别字之本末。乃至训化三万二千童子。劝发无上真正道意。是知字为众艺之本故。十地中以喻十地为诸法本。二有标下总例。三皆言般若下释文。先释总标于中三。一暗引毗卢遮那经。二明引遮那。三引五字经。今初彼有偈云甚深相无相劣慧所不堪为化是等故兼存有无说。释曰因字是有无相智是无。故念诵瑜伽之者。先观字相后入字义也。阿字相观云。八叶白莲一时开。炳现阿字素光色斯即字相也。而智表菩提心。悟本不生圆满具足犹如月轮。即是字义相有义无。故云兼也。是以今经唱阿字时即是相也。入般若波罗蜜门即是无相智也。智论云。此字是实相门则显三种般若。不相舍离字即名字般若。入般若波罗蜜门。即观照般若。悟不生等即实相般若也

大方广佛华严经随疏演义钞卷第八十八大方广佛华严经随疏演义钞卷第八十九

        唐清凉山大华严寺沙门澄观述

疏。故毗卢下。第二明引遮那。又上义证今即文证。不可得言即般若相。故般若中广说无得为般若故。疏又文殊下。第三引五字证为般若门。疏然初五字下。第二释别列中合为四十二段。今疏有三初别释五字。二释所余。三总结示。今初五字约五字陀罗尼经。而引不空会通字音。然古诸德于此经中不多解释。静法有章名为漩澓。六门分别。一释名。二体性。三建立。四释相。五利益。六问答。而其释相亦广引诸经而不全具。又诸经字音参杂。以梵音轻重三藏解释不看下义。但取字同故多乖舛。如涅槃以阿字为恶不中以啰字为多。此等不以义定故多讹谬。今亦别有一章。总引十经一论。一兴善译华严四十二字门。二大般若第四百九十三。引大品般若第八。四放光般若第六。五光赞般若第十。六普耀经第三。七兴善三藏别译文殊问般若字母。八别译金刚顶瑜伽字母。九涅槃第八。十即今经。言一论者即智度论。其五字经唯释初之五字。一一具引对会异同。今疏但用大般若及兴善别译四十二字。以二本多同故。初之五字用五字经。余文全要钞更引证余在别章。然上十经前五释四十二字母。次四即释五十二字母。次第不同义则多同。五字经中唯释五字。大品放光光赞但大般若广略之异。字义相同。次第不同义则多同。智论又释大品义亦同也。故疏但用二经具释三十七字故。今案定用五字。疏文分二。先别释五字。后收摄圆融。今初五字钞却广引五字。分为五段。文皆有三。一牒本经字母。二以彼经义释之。三会今经之意。今初一阿者。即第一牒经字母。即今经云唱阿字时。今但略取所牒之字下。四十一字皆然。二是无生义即五字经释义。三以无生之理下。会释今经意云。诸法皆悉无生故无差别故。上经云一切法无生一切法无灭。若能如是解斯人见如来。而大般若金刚顶全同上释。大品云阿字门一切法初不生故。智论释云若菩萨一切语法中闻阿字时即时随义。所谓一切法从初来不生相。阿提此言初。阿耨波陀此言不生。故释曰论文二节。一随经释义。二阿提此言初下。会释方言下四十一字皆然。见此论文则知四十二字皆是所依之相。从此入于无得般若。故名为般若之门。放光云。阿者谓诸法来入不见有起。光赞云。阿者因缘之门。一切法已过去者亦无所起。释曰上二经起即生义。因缘之门从缘生也。文殊问经云。阿者是无常声。普曜云。然此言云无者。是宣无常苦空无我之音。上二经似同小乘之无。若取无彼常等即与无生义同。此阿字上声短呼故译涅槃恶字当初。虽呼小异义亦同也。故云恶者不破坏故。不破坏者名曰三宝。喻如金刚亦同无生义耳。疏二多者此牒经也。彼经第二下疏有五。一依五字释。二今云多下案今多释。三如即无边差别者会经也。四应是译人下。会释偏正。言字形相近者。今示二梵之形多[虱-(乏-之+虫)+ㄠ]啰[虱-(乏-之+虫)+工]。此二小近声相滥者同叠韵故。五若顺无尘下。正以啰字会释经文。以诸经字义第二多同故。大品云啰字悟一切法离尘垢故。放光云。二啰者垢貌于诸法无有尘。光赞云。是啰之门法离尘垢。金刚顶云。啰者一切法离故。涅槃云。啰者能坏贪嗔痴说真实法。亦坏尘垢义。智论云。若闻啰字即随义。知一切法离垢相。以啰阇此言垢故。以上诸经皆第二啰字。同离垢义故无惑矣。疏三波者别译及余经多是跛字。今依五字跛字释义。大般若言跛者。一切法胜义教。大品云。跛者第一义故。放光云。跛者诸法泥洹最第一义。文殊问经云。出胜义声。释曰上诸经皆独明第一义但是所遣。唯金刚顶云跛者第一义不可得则具般若相矣。故疏云谓真俗双亡下。会经前二字。以第一义遣俗。今亦无第一义则复遣真。为双亡真俗是真法界上即所照。从诸法皆等含普照义。智论云。若闻跛字即知一切法入第一义。以波啰末陀此言第一义故。释曰此亦但入第一义耳。疏四者兴善译为左字。义则全同五字经也。文中先释义。后诸行既空下。会经大般若云。入者字门悟一切法远离生死。若生若死皆无所得。释曰诸行即生死体也。然诸经多明生死之行。大品涅槃义当遮字。俱明出世之门。大品云遮字修不可得。涅槃云。遮者即是修义。调伏一切诸众生故。然出世行亦不可得。方为般若之门耳。智论云。若闻遮字即时。知一切法诸行皆悉非行。以遮利夜此言行故。疏五那者别译为曩。字义亦全同。文中先依五字释义。后谓性相双亡下。会释经文诸经多是那字。大般若云。闻那字门入一切法远离名相。若名若相皆以无所得而为方便故。大品云。那字门诸法离名性相不同不失故。放光云。那者谓于诸法字本性亦不得亦不失。光赞云。是那之门一切诸法离诸名字。计其本净而不可得。普曜云。其言不者出不随众生离名色之音故。文殊问经云。曩字是遍知名色之声。金刚顶云。名色亦不可得。上三经皆云名色。名即名字总取二字为生死自性。涅槃云。那者三宝安住无有倾动喻如门阃。释曰真实三宝永离名相。智论云。若闻那字即知一切法。不得不失不来不去。以那素此言不故。疏又云以那字下。第二收摄圆融。于中四一从后倒收。谓由第五双无性相何有第四诸行。诸行即相故有相则有第三第一义谛。既无有行。何有第一义谛。由第一义空故。有第二本来清净。既无第三何有第二。由第二本净故方说不生。既无第二何有不生。疏以阿字法本不生故。那字无有性相者。旋转互收以初阿字生第五那字。则周匝如环。谓不生之中何有性相。故令五字互相生起旋转无碍。疏汝知是要下。结成观行悟本清净成三空观。云离我我所我所即法。故上三段皆五字经文。疏遮那经下。会释二文亦是结前生后。结前五字生后余三十七字。言多依彼经即毗卢遮那经。及阿目佉所译即别译华严四十二字门。此则别译义既与大般若同。则是依大般若而有二三字音小异故不言依耳。然阿目佉别译皆先牒经般若之名。而别名为先。后方释义次下当见。疏六逻字彼为攞字。云称攞字时。入无垢般若波罗蜜门。悟一切法出世间故。爱支因缘永不现故。释曰今疏但引释义更不引经。彼与今经全同。但此别名在下。彼别名在上耳。然准五字及彼译四十二字。初十二字唯第五有不可得言。余十一字即以不生清净亦无无有等。为般若相。余三十字皆有不可得言。不可得言即般若相。其不生等亦般若相。故有不生更不要于不可得言。若诸字中无不可得及不生等。则但是所依之法。如前遮字无有诸行。若无无有但言于遮。遮即行故但是所依。如色即是空是般若相。若但云色但是所空耳。诸字例然。亦如下第十五迦字云作者不可得。若无不可得但是作者耳。迦即作者故余皆准之。此下诸字文亦多三初牒字母。次引彼释。后会经文。牒字之文下钞不科。后二皆科而经若易兼无会经但引义耳。今此具二先引彼释。后离世间下会释今经可知。然大品放光等多为逻字耳。智论云。闻逻字即知一切法。离轻重相以逻此云轻故。意明有惑为重断即为轻。今不可得亦无轻矣。即无无明亦尽也。疏七拖字别译为娜字。大品为陀字。放光为拖义皆同也。文中先释义。后方为不退转下会经也。智论云。若闻拖字知一切法善相。以陀摩此言善故。释曰调伏寂静真如平等善之极也。疏八婆上声字别译及般若。皆为么字。与蒲我切义大同。文中先释义。后方入金刚场者会经。如佛入金刚三昧。断如金刚。惑在金刚场则无缚解为真断也。智论云。若闻婆字即知一切法无缚脱。以婆他此言缚故。疏九茶字别译为拏字。二俱上声。大品放光亦为茶字。文中先释义。后是普摧义即会经也。智论云。若闻茶字即知矫法不热。天竺茶阇陀此言不热故。释曰若茶是不热。则前离热已是所遣得清凉故。方为般若之相。疏十沙(史我切)字别译为洒字。大品放光等皆为沙字。文中先释义。后如海含像者会经。像之与水不相碍故。智论云。若闻沙字即知人身六种相。以沙此言六故。释曰以大品云沙字门诸法六自在王性清净故。即内六处为六自在王。心海湛然不碍见闻觉知。犹如湛海不碍像故。疏十一嚩(房可切)字此下疏文恐繁不举次第。今钞牒疏欲令不乱皆如次第。若有会经即科出之其释义文。或略不指。文中能遍安住即是会经。此乃仍上释义便会经文。智论云。若闻嚩字知一切法离言语相。以嚩嘙他此云言语故。疏十二哆字从不动则圆满发光。会经也。如密室灯定如止水影圆。契于如如知无动矣。智论云。若闻哆字即知诸法在如中不动。以哆他此言如故。疏十三也(以可切)字。悟如实不生是释义。则诸乘下会经。智论云。若闻夜字即知诸法入实相等。不生不灭以夜他跋此言实故。释曰得此论释知异第一阿字。彼云初不生今云如实不生。则不生所依法体异也。疏十四瑟吒字后普光明下。会经智论单云吒字。论云若闻吒字即知一切法无障碍相。以吒婆此言障碍故。释曰障碍即制伏任持。疏十五迦字悟作者不可得。此字上略一切法下。犹有不可得此后诸字。皆上有悟一切法。下有不可得。疏文从简故并略之。下方总说耳。从则作业如云下会经智论云。若闻迦字即知诸法中无有作者。以迦谓迦罗迦此云作者故。释曰既无作者何有作业。业既云云不可承揽。无我无造故无差别。疏十六娑(苏我切)字。但有释义。具云悟一切法。时平等性不可得故。故智论云。若闻娑字知一切法一切种不可得。以萨娑此言一切故。释曰论云一切种智故。普曜云。其言智者出智慧不坏音。金刚顶云一切法谛不可得。涅槃云娑者为诸众生演说正法。意明种智应时而说亦不可得故。今经名降注大雨也。疏十七么字者。别译为莽么。字却为第十八。大品云。么即悟一切法。我所执性不可得。我慢高举下会经。智论云。若闻么字知一切法离我我所义。以么迦此言我所故。疏十八伽(上声轻呼)字。别译为誐字。义亦全同易故不会经。若欲会者以行取故而能安立。智论云。若闻伽字即知一切法底不可得。以伽陀此言底故。释曰行取即生死底甚深故。疏十九他(他可切)字。疏但释义易不会经。会者真如平等是所依处。出生一切终归此故。智论云若闻他字即知四句如去不可得。以多他阿伽度此言如来去故。如去即是处所如来时去故。疏二十社字。别译为惹字但举其义若会经者有能有所。是世间海故贤首品能缘所缘力。一切法出生速灭不暂停。念念悉如是今不可得成般若矣。智论云。若闻阇字即知诸法生死不可得。以阇提阇罗此言生死故。疏二十一锁字别译是娑嚩字。若会经者念佛庄严最安隐故。智论云。若闻湿波字即知一切法不可得。如湿波字不可得。论云湿波字无别义。而光赞中云无所起。无所起即安隐义。疏二十二拖字。别译为驮字。义必然者。以第七亦有拖字注云为上故。然经云拣择法聚即能持界性。法聚差别即是界义各各持自性也。智论云。若闻驮字知一切法性不可得。以驮摩此云法故。疏二十三奢(尸苛切)字。别译为舍。大般若云舍。涅槃云奢。若会经者寂静则顺佛教。智论云。若闻赊字即知诸佛寂灭相。以赊多(都饿切)此云寂灭故。疏二十四佉字。若会经者智慧等空故能含藏。智论云。若闻呿字知一切法等于虚空不可得义。以呿伽此言虚空故。疏二十五叉(楚我切)字。别译为漩澓字。若会经者业海深广无不包含。非是无为终竟须尽。智论云。若闻叉字则知一切法尽不可得。以叉耶此言尽故。疏二十六娑(入声)多(上声)字。先释义后惑障为非处下会经。智论云。若闻娑哆字即知诸法边不可得。以阿利迦哆度求那。此言是事边不可得。释曰。以大品云多字门诸法有不可得故。论为此释以有即有边必对无故。有是妄惑故为非处。以为有边无是真空故。名为处故为无边。惑智双绝即不可得。疏二十七坏(轻呼)字。别译为娘字。若会经者能所知性即智慧门。能知为智慧智慧即门。所知为智慧智慧之门。智论云。若闻惹字即知一切法中无智相。以惹那此言智故。释曰但有能知必有所耳。疏二十八曷攞哆(上声)别译为攞他(上声)后执着为下。会经言境义者。总有四义。一文义是所诠义。二境义是所缘境。三道理义谓苦无常等。四性义即第一义空。今是第二生死是果执着是因。并是智慧所观境义。智论云。若闻曷攞哆字。即知一切法义不可得。以阿利他此言义故。疏二十九婆(上声呼引)字圆满之言下。会经兴善译为道场者。故彼云称婆字入一切宫殿道场庄严。般若波罗蜜门。以梵云曼茶罗。通圆满道场二义故。智论云。若闻婆字了知一切法。不可得破坏相。以婆伽此言破故。释曰经中宫殿庄严以从缘故。亦可破坏以不可得即非庄严。方为圆满成般若矣。从然此婆下。会其文谓顺于诸经多是去声故。疏三十车(上声)字别译为縒。若会经文既方便。随喜乐故各别圆满。智论云。若闻车字即知一切法无所去。以伽车此言去故。大品亦云。闻车字时入诸法欲不可得。而论云去者以放光云车者无可弃去。即是乐欲所去耳。疏三十一娑(入声)么。会经可知。智论云。若闻湿淼字即知诸法坚牢。如金刚石义。以阿湿淼此言石故。释曰意明专念坚牢。我心匪石不可转也。亦不可得。疏三十二诃婆(并上声)字。别译为诃嚩。文中释义无缘召令有缘即会经也。智论云。若闻火字即知一切法无音声。以火夜此言唤来故。疏三十三縒字。别译为哆婆字。若会经者勇健方能修入功德。智论云。若闻縒字即知一切法无悭无施。以末縒罗此言悭故。释曰无悭最勇健施为行首。勇而能行故偏说耳。疏三十四伽(上声)字。若会经者如地之厚平等能持亦能含藏。如海平等能持能包云雨说法。智论云。若闻伽字即知诸法不厚不薄。以伽那此言厚故。释曰厚薄之事事则已入般若矣。疏三十五吒字。别译为姹(上声)字。若会经者积集念佛故能普见。智论云。若闻咃字即知一切法无住处。南天竺咃那此言处故。释曰念即处也。疏三十六拏(奶可切)字。别译为儜字先释义。后谓以常观下会经。智论云。若闻拏字即知一切法及众生。不去不来不生不灭不坐不卧不立不起。众生空法空以南天竺云拏此言不故。释曰去等即是喧诤。无即是不上二俱不可得方为般若。疏三十七娑(入声)颇字。别译但云颇字。若会经者化生究竟方为遍满果报。智论云。若闻颇字即知一切法。因果皆空。以颇罗此言空故。释曰因果俱空方为圆满。亦不可得。疏三十八娑(同上)迦字。别译为塞迦。若会经者蕴积为广大藏。无碍光轮所积蕴也。智论云。若闻歌字即知一切法五众不可得。以歌大此言众故。释曰五众即五蕴也。略举一蕴耳。疏三十九也(夷舸切)娑(苏舸切)字。若会经者衰老性即佛法境界。兼余老死者。菩萨勇猛观境也。智论云。若闻磋字即知磋字空诸法亦尔。释曰以是通相更无别释。然衰老性即是别义。疏四十室者字。别译云室左。文中先释义谓积集即下。会经诸处即是足迹者。佛所行迹故。智论云。若闻遮字即知一切法不动相义。以遮逻此言动故。释曰以大品云遮字门诸法行不可得行即动义。足即能行即因行有迹迹为所行。若依此义法雷遍吼即行法也。疏四十一咤(耻加切)别译为吒。文中先释义。后谓无我下会经。智论云。若闻吒字即知一切法此彼岸不可得。以吒罗此言岸故。释曰即无我驱迫。令至彼岸亦不可得。若约表位此当等觉故。法身欲满始本欲齐故亡二岸。疏四十二陀(引声)文中先释义。后谓此究竟下。会经从然新译下。会经字音即兴善别译也。智论云。若闻茶字即知一切法必不可得。以彼茶此言必故。释曰唯至究竟为必不可得故。般若中以无所得则得菩提。又约表位此四十二当妙觉。故大品云。茶字门入知诸法边竟处。光赞云。是吒之门一切法究竟边际尽其处所。无生无死无有作者皆菩提意也。若约初发心时便成正觉。则初阿最后茶。疏上来从娑字下。第二总相结束于中三。一会释上文以疏恐繁故文略之。若欲说时应须一一具其上下一切等言。如云陀字悟一切法究竟。处所不可得故。而上引智论多具上下。二其中难者下会上之义。三更有对会下。指广在余。于中有三。一对会同异前已会竟。二修观仪式。三所得功德。后之二门皆兴善别译。今当叙之先明所得功德者。彼文结云又善男子。如是字门是能悟入法界边际。除如是字表诸法门更不可得。何以故。如是字义不可宣说。不可显示。不可执取。不可了知。不可观察离诸相故。善男子譬如虚空。是一切物所归趣处。此诸字门亦复如是。诸法空义皆入此门方得显了。若菩萨摩诃萨。于如是入诸字门得善巧智。于诸言音所诠所表皆无挂碍。于一切法平等空性尽能证持。于众言音咸得善巧。若菩萨摩诃萨。能听如是入诸字门即显字印。闻已受持读诵通利。为他解说不贪名利。由此因缘得二十种功德。何等二十。谓得强忆念。得胜惭愧。得坚固力。得法旨趣。得增上觉。得殊胜慧。得无碍辩。得总持门。得无疑惑。得违顺不生恚爱。得无高下平等而住。得于有情言音善巧。得蕴善巧处善巧界善巧。得缘起善巧因善巧缘善巧。得法善巧。得根胜劣智善巧。得他心智善巧。得观星宿善巧。得天耳智善巧。得宿住随念智善巧。神境智善巧。生死智善巧。漏尽智善巧。得说处非处智善巧。得往来威仪施设善巧。是为得二十种殊胜功德。大般若放光光赞大同于此。第三修观仪式者。彼文标名大方广佛华严经入法界品。顿证毗卢遮那法身字轮瑜伽仪轨释云。夫欲顿入一乘。修习毗卢遮那如来法身观者。先应发起普贤菩萨微妙行愿。复应以三密加持身心。则能悟入文殊师利大智慧海。若能修行者。最初于空闲处摄念安心。闭目端身结跏趺坐。运心普缘无边刹海。谛观三世一切如来。遍于一一佛菩萨前。殷勤恭敬礼拜旋绕。又以种种供具云海。奉献如是等一切圣众。广大供养已复应观自心。心本不生自性成就。光明遍照犹如虚空。复应深起悲念。哀愍众生。不悟自心轮回诸趣。我当普化拔济。令其开悟尽无有余。复应观察自心。诸众生心及诸佛心。本无有异平等一相。成大菩提心莹彻清净。廓然周遍圆明皎洁。成大月轮量等虚空无有边际。复于月轮内右旋布列。四十二梵字悉皆金色。放大光明照彻十方。分明显现一一光中具无量刹海。一一刹海有无量诸佛。一一诸佛有无量圣众前后围绕。坐菩提场成等正觉。智入三世身遍十方。转大法轮度脱群品。悉令现证无住涅槃。复观悟入般若波罗蜜四十二字门。了一切法皆无所得。能观法界悉皆平等无异无别。修瑜伽者若能与是旋陀罗尼观行相应。即能现证毗卢遮那如来智身。于诸法中得无障碍。第四贤圣优婆夷可知。第五坚固长者无念约心者。即以无字两用。若无著念三字连释。则无著约止而不碍念念明记即止观双行也。亦离二障则以智断而严法身三德备矣。第六妙月长者可知。第七无胜军解脱有二释。一约用无尽。二又诸心境下约体无尽。从既见佛下。以法释名。第八最寂静即如次释前二义者。先释始终无妄。后善男子我以住是下。释随行不虚心。行称言故所作成满通二利满。从虚诳言息下。以法释名。于中初释最寂静。次寂静即为净行释婆罗门。后言行君子之枢机下。释其城名。然此一句即周易系辞子曰。君子居其室出其言善。则千里之外应之况其迩者乎。居其室出其言不善。则千里之外违之况其迩者乎。言出乎身加乎民。行发乎迩见乎远。言行君子之枢机枢机制动之主枢机之发荣辱之主。言行君子之所以动天地可不慎乎。虽为外典意与斯合。但所言所行内外异耳。疏会缘之终此二满者。即悲智满。言将见慈氏绍佛位者。慈氏悲满。佛位智满耳。第九德生有德三就五类法中等者。疏文有三。一释一切法即有为。一切以无为下。出拣无为所以。同掌珍论真性。有为空故。从异熟识等。出余四类之果。异熟是心。等余七识及心所色法并不相应。二从无始下。释我见等能成之因。然我见有二。一与七识相应即执第八以为内我故谓我所与四惑相应。今言我见等者等取爱慢。二者与六识相应我执。兼外取妄境以为我所。及起余惑故云种种。三故感已下辨因。感果可知。疏四五二句。别明不相应者。然不相应有二十四。今二门中略遣其四。等于所余。四中言即是时者。释经三世三世是二十四中之一时故。从谓依行下。出三世如幻之由。行即五蕴刹那生灭。前后相续。已谢为过去。未起为未来。生已未谢名为现在。离行之外何有分位而有三世耶。况所依行空能依何有。疏五即无常生老等者。即二十四中之三。一无常。二生。三老等。即等上经言生灭及死。皆无常摄。生老二字。即是二法但略无住。又诸圣教多合生灭名为无常。所以然者生名为有。有非恒有不如无为。灭名为无。无非恒无不如兔角。由不同彼无为兔角二常之相。故名无常。疏谓依生已坏灭下。显如幻所由。故唯识第二云。然有为法因缘力故本无今有。暂有还无表异无为假立四相。本无今有有位名生。生位暂停即说为住。住别前后复立异名。暂有还无无时称灭。斯即依生已坏灭分位建立也。言皆妄分别者正显幻因。然其忧悲苦恼即生老中事。体非不相应行。又上四五亦是前十二因中别义。四明三世生老死耳。疏既有妄想故心见皆倒者。即出三倒也。一想倒二心倒三见倒。然十行品已广分别。彼有多义。今是一义。以心见非倒见由想乱故令余二皆倒耳。疏幻法非有等者。此中且约有无一异。兼下中道以为三观。亦应有离四句。又以合性相非一非俱非句。非异之义当非俱句。既离二边已是中道。亦亡中道绝待中也。上即事理无碍由斯交彻下。即事事无碍。余义如前。疏约事则其中下。先释广大。有多下释毗卢遮那。阿僧祇下释庄严。蕴多楼下释藏。疏具云迷谛隶者。西域记亦翻为梅怛丽。皆梵音轻重。然有三缘者。此三展转相生。谓由遇慈氏如来故得慈心三昧。得三昧故母亦慈也。慈依智住者。上以楼阁为二智故。疏句各四事可知者。此四亦即涅槃四近因缘。前已频释故云可知。初二句即亲近善友。第三句即听闻正法。第四句即如说修行。正念思惟遍于四句故。句句皆令起如是想。亦可第四句合正念思惟。又第一句是具四之人余三可知第二相竟

疏。自下大文第三慈氏一人者。先来意后故办一生下。释摄德成因之名。疏契法性之真源者。文有十句。初四法说一向契实。前三约法后一约人。人亦得名圆成实故。次四喻明。就相契实。即法而虚同实理故。皆上句标相下句释成。后二句约法结其性相。经言无有生递兴谢者。以更兴谢故无定生。下句既从缘生。明无定性。无性即法界也。疏此三无碍即三观一心者。初假次空后中说有前后。善财观心一念顿具。非是从假入空等也。今初报酬善恶者。文有十句但释其四事相滥故。业是增上缘即诸业习气。果即异熟由名言种。从信起佛通真。应信为道源必到佛地故。化佛应现敬心便感。机感于佛。云感他化身信心成佛乃是自佛。余易可知故。疏不释。疏二契无性下。有十一句略不释初三及八十一。若具释者既回向菩提。岂谓后身而无果也。二即理故非常。以执定有则着常故。既知正因非无因矣。断见无果此见无因。释第四句中常计无常是二乘倒。不见涅槃妙有实理。无常计常是凡夫倒宁知二空如实之理。疏自在见者。即第五句妄谓自在能生万物。今知从业故不从他。自修人业尚不生天。安得由他令我苦乐。释次二句疏文可知。其往来见易故不释。影像随身去来无实。随业六道实无往来。中论云。诸行往来者常不应往来。无常亦不应往来。众生亦复然。有无可知。离一切法见。释有三句初以理遣者。法性空中法即非法。二缘会不得不生。缘离不得不灭。故一切法不得自在。三以愿为因出生诸法。因成无性净法亦无。末句易见。疏三会归中道者。疏中有二先总明。后别释。前中言随一句皆离上诸过者。如随种生茅即离断常无因颠倒等。今且通说者不对诸过。但通相说中道义耳。疏如种生芽下。别释唯就种芽示中道相。余并略之。说此中观便收前二。即显空假是此中道之空假耳。非是从彼空假入斯中矣。如是离断常等者。例释上文总离诸过。疏种芽横喻万法者。言知一切法故。谓若善若恶若内若外皆从自种假缘生故。如印生文。竖喻诸法者。此阴亦灭即现在阴灭也。彼阴续生者。三世相望故。即涅槃经须弥山顶品已引今复略示。谓此阴亦灭者中阴生也而此五阴不至中阴。中阴五阴非余处来。因现在阴有中阴阴。如蜡印印泥者。蜡印况于现在阴也。泥上文成喻中阴阴也。印坏者现阴灭也。文成者中阴阴生也。印不至泥如现在阴不至后阴。以印因缘而生是文。即如因现在阴有中阴阴也。现阴不至后阴即是不常。后阴非余处来。因现阴有即是不断。不断不常是中道义。余如前说。疏了世心现亦唯心观者。正是中道故致亦言。即就唯心以辨三观。假心缘现即假观也。现而无性即空观也。上二不二即中道观也。下法喻句对前可知。叹所住楼阁。义理宏博。经文浩大类例可知故不委释。疏尔焰地者。此云所知等者。疏略引入大乘论。论云。菩萨有无量无边阿僧祇功德。到尔焰地向于涅槃。以愍众生还入生死。阿僧祇劫示受勤苦。出过一切声闻辟支佛上。具足一切功德智慧。是故超度尔焰之地。乃至云菩萨处生死海中。第一阿僧祇劫修净治地行求净解脱。第二阿僧祇劫修净禅定行。第三阿僧祇修净智慧行。除尔焰地障。是故菩萨名乘自在乘。满足十地得无碍无障。一切具足故得阿耨多罗三藐三菩提。是故以尔焰智得成大果。释曰。尔焰梵语此云智母。亦云智度。亦云境界。亦云所知。即所知障亦名尔焰。以经云令过尔焰海故。疏但用所知一义。即论中第三劫过生死海也。论中又云入十地时便能永断。由斯十地说断二愚及彼粗重。皆取尔焰为所知也。若据初云到尔焰地。及后结云以尔焰智。得成大果即含余义。今取经意但举一耳。疏百一十善知识古有多释者。略叙三释。初一即上古释。二贤首释先叙后若依此下刊定破师。三有云下即刊定记释。于中亦二。先叙彼释。后若尔下疏破其释。明其立义前后相违。上皆叙昔。疏若会通下疏为会释。总会三释从后倒会。二然下复云下会藏和尚意。取一百一十表法为妙。言设有三贤亦唯具十者。十地一一摄三位故。一位尚得总摄于十。况三贤望地类例相似摄之善成故。十地中各修一度。十行之位亦各一度。十住之位初是发心。后是灌顶十地之位。初证发心后亦灌顶而受位。故依开等觉合信属住。若合等觉即开十信。开信是退开等觉是进要令十一成百一十。其第一师义设经来未尽者亦百一十。疏界城即十八界者。十八界是生死因相故。晋经云三界。三界为城郭约果相故。言界地即地等四界者。俱舍云。大种谓四界即地水火风。能成持等业坚湿暖动性故。及六处等并如二地。疏即凡身一生者。约圆融说。亦解行一生约行布说。故千年之乌下。成第一凡身一生之义。依实修者下。通伏难。恐有问言约法圆融是则可尔。岂得有凡身一生而得成办。故为此通非独善财行者岂能即得。余如发心功德品。三入十住者此中十句文有三节。初二总具行位。后四亦通。中间四句乃有三义。一但摄三贤。以三是智慧入法界同住义故。四五皆行故六是愿故。二又上四下重以此四摄十地。三即十地证智证十法界故。四即别地行故。五即称理具修行故。六即大。愿导诸行故。三又上四下义含通别者。别如初配通谓位故。疏文有二百二十一句。下文分为二。先总科。后别释。前中总有四意。初明通发三心。二且分为二。三又前多明下依三种发心分之为二。四又前明菩提心殊胜功德下。约高广分即光统意故。依之释文。若顺第三意则前段但是三贤。即分为三摄上十二。初三段十住次五十行。后四十向。二意皆通。有宗法师。于二百二十一喻皆立别名。亦不分判亦无别理。疏以金刚智终成菩提故者。既始从种性终至金刚菩提之智。竖配理明。初心顿具诸位功德。正顺经宗。故毗卢遮那品云。一切功德皆在最初菩提心中住即其义也。又后一百三句自在德中。若唯配十地亦可束之。十住为初地。十行为二地。十向为三地。初二三地并为四地。四五为五地。后五依前如次判之。亦顺本文恐繁不配其中行相。疏其间梵语广如音义者恐繁故指。疏中随难已释其二。谓毗笈摩婆楼那余未释者。今当具之言大应伽者。应伽云身。然身有四名。一曰伽耶。二曰设理罗。三曰第诃。四曰应伽。然应伽亦云分谓支分也。次云树名珊陀那者。此云和合。或云断续。谓此药能令已断伤者再续和合也。次药名阿蓝婆者。此云药汁其药出香山及雪山中。天生在于石臼之内。或云得喜。谓得此药生欢喜故。四须弥下四地德中波利质多罗树。波利此云遍也。亦曰周匝质多罗。此云间错庄严也。意言此树众杂色华周匝严饰。或曰圆妙庄严。次云婆师迦华。具云婆利史迦。言婆利史者此云雨也。迦谓迦罗。此云时也。雨时生故。瞻卜迦华此云黄色华。其华有香气而形似栀子华也。苏摩那华此云悦意华。其华形色俱媚令见者心悦故。五椰子下明五地德。药汁名诃宅迦。此云金色水。甚于九转还丹之力也。迦陵频伽鸟前已释竟。此云美音。或曰妙声。此鸟本出雪山在[穀-禾+卵]能鸣。其音和雅听者无厌。摩诃那伽此云大龙。亦云大象。今此力士力如龙象。八如人下八地德中摩竭鱼者。此云大体也。谓即此方巨鳌之类。两目如日。张口如暗谷。能吞大舟。凡出濆流即如潮上。噏水如壑。高下如山。大者可长二百余里。安缮那青色药也

大方广佛华严经随疏演义钞卷第八十九大方广佛华严经随疏演义钞卷第九十

        唐清凉山大华严寺沙门澄观述

(入第七十九经)疏然此六皆是悲智之中所有者。阁表悲智故。疏六干城依空喻。然十喻中前六有合。七八九无。第十幻中一时总合从后倒合初以弥勒菩萨威神故合于幻师。二及不思议幻智力故。以合大海海印之义即智海故。三能以幻智知诸法故即合夜叉与人互不相见。以如幻故。四得诸菩萨自在力故。合于干城依空无碍现自在故。以在幻后皆带幻字。以有两重之意。故有十喻差别不同。若不为此释则谓经文繁不要也。疏前来得旨等者。前则以定为门。此则以用为门。动寂无二真入法界。疏从法智缘生者。疏中以初法智为缘释。如是自性已下。经文明自性如幻是所现相。以后悉不成就。结成自性如幻梦等。初之一对是约依他即三论意。缘生故无性无性故从缘。从由不守自性下。一对约真实性辨即法性宗。真如不变随缘之义。上释悉不成就明性相双寂。今云亦是性自具者。恒沙性德本来具足。非今新成云不成就疏庄严藏有二义者。前义约理融事。已是事事无碍。后更明心境互融。从故此门下仍上主门释眷属也。疏若先定有来处下。上约顺明。此下反释先有先无门会归中道。从既离下结释经文。疏此三即法报化下结成上义都有四重。然前之三重。三段疏中一一具足。如初云一约体是第一义。二实法身是第二义。三来即无来是第三义约理也。次二段对三亦然。其第四云又初唯理者。以义包含故。言中一具事理者。谓从大悲大慈等即约事也。从无动摇无取舍即约理也。以行兼事理故。疏摩罗提者。随难解释即化用中也。疏余可思准者。疏唯释五句以难见故。余五易了故故但例之。然此十句一行因二行缘三行相此三疏已释竟。四以愿扶行。应云若发大愿即生妙行。五化他谓若有悲心即行四摄。六观理谓若观妙理。即成般若。七随事理谓若事理双游。是名大乘即方便善巧。八益物故疏云教化众生即是觉他。九住果谓权实双流。则证无生忍故。从有智慧故下是也。第十上顺谓具修万行合三世佛家。又上句亦通所生者翻将下句为能生行。谓上求下化名为菩萨。即得生于菩提心家。下经以菩提心为家故。则前七可通二解。后三必须依于前释。故疏先明上句以为能生之行。后方翻例耳。疏一实智虚凝与阴俱静者。此言本出庄子第五外篇天道章中。彼云故曰天乐者其生也。天行其死也。物化。静而与阴同德。动而与阳同波。故知天乐者无天怨。无人非。无物累。无鬼责。故曰其动也。天其静也。地一心定而王天下。其鬼不崇其魂不疲。一心定示万物服。言以虚静推于天地通于万物也。此之谓天乐。今借其言况父母之为阴阳之仪。故易云先有天地然后有父母。疏先彰实报等周法界。亦同出现品无量三轮。疏拘吒聚落此云楼阁乃是一义。或云小舍或曰多家。故上经自译为房舍聚落。今疏取一义耳。疏如莲华有三义者。初一生行解。次一成果。后义见理皆因闻教则教理行果四法备矣。然疏但释莲华之言。而经云为欲教化释迦如来所遣来者。今当说缘。案观弥勒菩萨上生兜率天经。佛于舍卫国。说优波离问。佛答。此人从今十二年后二月十五日上生兜率天。岁数五十六亿万岁尔乃下生于阎浮提。佛灭度后我诸弟子。若有精勤修诸功德。威仪不缺扫塔涂地。以众名香妙华供养。行众三昧深入正受。读诵经典如是等人。应当至心。虽不断结如得六通应当系念。念佛形像称弥勒名。如是等辈若一念顷。受八戒斋修诸净业。发弘誓愿命终之后。譬如壮士屈伸臂顷。即得往生兜率陀天。于莲华上结跏趺坐。百千天子作天伎乐。持天曼陀罗华摩诃曼陀罗华。以散其上赞言善哉善哉。又言如是等众生。若净诸业行六事法。必定无疑当得生于兜率天上值遇弥勒。亦随弥勒下阎浮提第一闻法。于未来世值遇贤劫一切诸佛。又云得闻弥勒名者。闻已欢喜恭敬礼拜。此人命终如弹指顷即得往生。又云善男子善女人。犯诸禁戒造诸恶业。闻是菩萨大悲名字。五体投地诚心忏悔。是诸恶业速得清净。未来世中诸众生等。闻是菩萨大悲名称。造立形像。香华衣服缯盖幢旛礼拜系念。此人命欲终时。弥勒菩萨放眉间白毫大人相光。与诸天子持天曼陀罗华来迎此人。此人须臾即得往生。值遇弥勒头面礼敬。未举头顷便得闻法。于无上道得不退转。于未来世得值恒河沙等诸佛如来。释曰。此亦释迦所遣来者。以行释迦教故。若弥勒下生经罗什法师译。无如是我闻直云大智舍利弗问佛。佛诫听为说云舍利弗四大海水以渐减少三千由旬。是时阎浮提地长十千由旬。广八千由旬平坦如镜。名华软草遍覆其地。广说庄严等华藏品已引。次云城中有大婆罗门主名曰妙梵婆罗门。女名梵摩波提。弥勒托生为父母。身紫金色三十二相。身长千尺胸广三十丈。面长十二丈四尺。肉眼清净见千由旬。常光四照面百由旬。穰佉王奉七宝台。弥勒受已施诸婆罗门。弥勒见其毁坏修无常想出家。学道于龙华菩提树下。树茎枝叶高五十里。即以出家日得阿耨多罗三藐三菩提。有无量人发心出家学道。尔时弥勒见诸大众作是念言。今诸人等不以生天乐故。亦复不为今世乐故。来至我所但为得涅槃常乐因缘。是诸人等皆于佛法中种诸善根。释迦牟尼佛遣来付我。是故今来皆至我所。我今受之是诸人等。或以读诵分别决定修妒路毗奈耶阿毗达摩。修诸功德来至我所。广叙布施持戒忍辱精进。结云善哉释迦牟尼佛。善教化如是百千万亿众生。今至我所弥勒如是三称赞释迦如来。然后说法言汝等众生能为难事。于彼恶世贪欲嗔恚愚痴迷惑短命人中。能持戒行作诸功德甚为希有。善哉释迦牟尼佛。以大悲心能于苦恼众生之中。说诚实语示我当来度脱汝等。如是之师甚为难遇。深心怜愍恶世众生。救济苦恼令得安隐。释迦牟尼佛如来为汝等故。以头布施割截耳鼻手足支体受诸苦恼以利汝等。弥勒如是广安慰已然后说法。其龙华树园纵广一百由旬大众满中。初会说法九十六亿人得阿罗汉。第二会说法九十四亿。第三会九十二亿。更有诸本经大同小异可以意得。此经正明释迦遣来

○第四智照无二相绝境智等者。谓一境智无二。二始末无二亦信智无二。三染静无二。四智断无二。五理事无二。由证理事无二义故染净两亡。惑性智性一性平等。始末无差能所齐融。亦不生二不二分别故。前经云心不称量诸二法。但恒了达法无二。诸法若二若不二。于中必竟无所著方为真不二耳。疏或于一城值于多友者。如诸夜神多在佛会。言或求一友历于多城者。如解脱处经十二年求于普眼经。历城多等。此义胜前。疏初一总余八别者。总即示教利喜。示谓显示法门。教谓劝令修行。利谓觉悟成益。喜谓称根令悦。经从具足无量下别句。疏随难释先出初句异于第六。二三四五并皆不释。后释七八二句而有二意。一当句释属于二人。二相合释文殊能住。普贤道场是所住。故此亦义同示于后友者。亦安普贤行道场故。文无正示故云义同

疏。转遇胜缘修行敬事者。疏文分三。初标二章二然此诸友下料拣。三又此诸友所得下指广在余。二中三。一近对前后释。二又通论下通对诸友释。三又前诸友下。玄门义理释。大文第五显因广大相。先释名。言随一一因皆称法性者。释广大义异前摄德成因未。说一一称法界故。又前但因今明因彻果海故。文殊下对前辨异。摄相归性事理无碍。秘密重重。事事无碍

疏。若以二圣下。后三圣相望辨其能所

疏。文中分三。初依下先释文。后以是显因下通辨文意

疏。今初初闻前人法等者。疏文有三。初生渴仰。二明修处。三正修观。二中分三。初约表释。二约事释。三然此经下总释文意。谓所以却就金刚场起观者。何于中有二。先繁表出意。谓华严一切皆悉具十会亦应然。合有第十摄末归本重会。觉场谓菩提场是根本会起。于中八名为末会。谓第十会摄前八会归于初会。无不从此法界所流。无不还归此法界故。后今且依文者。以明无十故就第九以明此三。一者本会。二者末会。三自普贤以为摄末归本之会。本有二种逝多乃是此会之本。今归觉场是诸会本

疏。一见瑞相十句五对。各前所依净土等者。然其十句皆是净土。而其后句意在众生。如初对云见一切佛刹清净一切如来成正觉即属净土。二云见一切佛刹清净无诸恶道。无诸恶道即是住处众生五对皆然

疏。又前粗此细者。前但云见一切佛刹。今一一尘中出一切世界故。此为细。言前体相此业用者。前但云见今尘中出故。然毛孔出生等广如玄中。今更略示谓彼普贤游入十方。略有十门。一入世界。法界缘起。互即入故。二入众生界。生界佛界无二体故。三明供养一一供具皆称真故。四明请法穷法界智无时不请。诸佛无时不雨法故。五大智摄生了生迷倒。而无众生不碍化故。六明现通十方尘刹互入。重重震动现相而无息故。七常寂定未曾一念有起动故。八广出生念念毛孔出现诸境无穷尽故。九者说法念念常雨无边法雨雨一切故。十明总说。上之九义举一全收无前后故广说难尽余广如文

疏。于中有三世间者。菩萨亦是众生亦为正觉余二可知

疏。以没现相如法性故者。斯则没而无没。现而无现真法性中无出没故。此约事理无碍。下句云此彼相相即故者。即事事无碍法界。然相即有三。一约刹此刹即彼刹。一刹即多刹故。二约人此身即彼身。一步即多步故。三约劫一念即是无量劫故。又此彼相炳然具故。秘密隐显俱时成故。此彼时处互相在故。帝网重重同时具足皆不动故

疏。故长行偈文因果绮互者。长行显普贤因。偈颂显善财果。故云绮互

疏。然通赞毗卢遮那十身圆满二十一种殊胜功德者。通有两重。一者近通通前法喻。二者远通通取此卷末结德无尽二偈经文。良以二偈亦是最后无尽德故。其二十一德一经数节。出其名义文有隐显。欲彰如来无尽德故。大体无异故复出之升兜率品已广分别。今皆略指。初二偈即于所知一向无障转功德者。然此二偈含于总句妙悟皆满妙悟即是妙觉智故。以无著论下不释总句。疏略不明若欲明者初偈当之。今但显别即当第一。然准上文二十一德皆有三节。一举经名如此德经即二行永绝。二无著菩萨立功德名。即今疏。云于所知一向无障转功德。三引二释论解其本论。即今疏。云佛无碍智下文是也。是无性意即是智德故。经偈云佛智广大初之二句即是德体。三及后偈即于所知无障转也。谓即于其极远时处品类皆知故。无有知及与不知之二相也。第四句了俗由于证真故。不起分别亦是真实离智障也。若亲光释不二现行云。谓凡夫二乘现行二障世尊无故。谓凡夫现行生死起诸杂染。二乘现行涅槃弃利乐事。今前偈唯了生死杂染。后偈唯证涅槃广大利乐

疏。二有一偈者。约经即达无相法。疏中先引无著立名。后谓了真如下即无性释意。故无动念是疏以经怗。然无性詺此为无住涅槃。既自入真如故不住生死。亦令他入故不住涅槃。今经三句即不住涅槃。第四句是不住生死

疏。三有三偈下。约经即住于佛住。疏中先依无著立功德名。后谓住佛下即无性释。无性生起云为欲得上无住涅槃。故次明之即是恩德。谓佛虽遍圣天梵住而空。大悲偏善安住。由住空故不住生死。由住悲故不住涅槃。一切时中观所调伏故随物欲或见不同

疏。四有十五偈下。约经即得佛平等。疏中分四。先依无著立功德名。次谓由诸佛下即彼论释诸佛有三事平等。即疏所引二同是也。次故前经云下。指经即离世间品初也。以彼具足二十一种功德名故。次亦同摄论下。引他论会释。结云此释已妙者。古来诸德不知此即二十一德。亦不知此是佛平等。但云如来随机隐显。忽列诸佛莫知其由。今云显佛平等故广列诸佛皆相遍耳。岂非妙耶

疏。今更下即就佛平等中。显实是本师互遍。更过平等之意趣耳。于中文前有八。一总举大意。二谓此文言下。引此经文。质成正义。三若言别赞下。遮其欲救彰其谬解。四况华藏下。引前经文成属我师。五法华央掘下。引他经文成立今义。六故知法藏下。遮其引难为决他经。七以理推下。结成正义反质令见。八然此段下。辨其包含。重成本义。二中自有三意。一东方之佛云在此者。明阿閦即是本师。二阿弥陀充满十方亦合遍此。同于本方即释迦矣。三通取或见明是本师。或有见为阿閦弥陀诸佛异耳。三遮救中。恐外救云。今明阿閦弥陀遍等。自是别赞弥陀阿閦。何得引是本师佛耶。故今遮云若如此者。普贤本赞本师释迦如来。今云东西诸佛遍此何成赞我本师耶。四中引华藏者。娑婆当中刹海种内第十三层。而有十三佛刹尘数世界围绕。无量寿佛国。但言从此西方过十万亿佛土。尚未能满一合之尘。况于一刹尘数。况十三佛刹尘数。其十三重内。皆是化境。况华藏世界刹海有十不可说佛刹微尘数世界种。一一种中有不可说佛刹微尘数世界。皆是本师之所严净。其中皆是遮那如来分身化往。安养近在十重之内。何得非是本师释迦。故云岂非是此佛耶。五引他经成立中。二经分身已如前引。既十方中皆是释迦分身之佛。何得弥陀阿閦佛等近而非耶。六遮其引难者。谓外引二经。一引清净平等觉经说法藏比丘。然大宝积第十七无量寿如来会。说名法处比丘。佛在耆阇崛山说。阿难起问白佛言。大德世尊色身诸根悉皆清净。威光赫奕如融金聚。又如眼镜凝照光辉。从昔已来初味曾见。喜得瞻仰生希有心。世尊。今者入大寂定。行如来行皆悉圆满。善能建立大丈夫行思惟。现在去来诸佛。世尊何故住斯念也。佛赞圣知便为说。往昔过无边阿僧祇无数大劫。有佛出现号曰然灯。此前展转复举诸佛。最后云世主佛。前无边数劫有佛。出世号世间自在王。彼佛法中有一比丘名曰法处。有殊胜愿诣如来所。以偈赞佛既赞佛已。佛为说二十一亿清净佛土具足庄严。彼比丘悉皆摄受。摄已满足五劫。思惟修习便向彼佛。发四十八愿发愿已后。经多劫修行成就功德乃至成佛。后阿难问。此法处比丘成佛。为过去耶。未来耶。为今现在。佛告阿难。西方去此十万亿佛刹。彼有世界名曰极乐。法处比丘在彼成佛。号无量寿。今现在说法。然后广说其土庄严。释曰既如来说他昔因今果。何得判为即本师耶。二引法华经十六王子。即第三大通智胜佛。经云彼佛弟子十六沙弥。今皆得阿耨多罗三藐三菩提。于十方国土现在说法。有无量百千万亿菩萨声闻以为眷属。其二沙弥东方作佛。一名阿閦在欢喜国。二名须弥顶。东南方二佛。一名师子音。二名师子相。南方二佛。一名虚空住。二名常灭。西南方二佛。一名帝相。二名梵相。西方二佛。一名阿弥陀。二名度一切世间苦恼。西北方二佛。一名多摩罗跋栴檀香。二名须弥相。北方二佛。一名云自在。二名云自在王。东北方佛名坏一切世间怖畏。第十六我释迦牟尼佛。于娑婆国土。得阿耨多罗三藐三菩提。释曰既第一佛名曰阿閦。第九王子即为弥陀。十六释迦。本因既殊。得佛又别。云何浑乱言皆本师。故疏。释云皆是方便。复更问言。岂法华经判为方便。今当还引法华答之。法华寿量品云。于是中间。我说然灯佛等。又复言其入于涅槃。如是皆以方便分别。则等言已等十六王子。复应问言。然灯去今方一僧祇可为方便。自在王佛大通智胜。已经无量无边不可思议阿僧祇劫岂为方便。故应答云。然灯虽已久矣。比之寿量劫数不多。谓说大通但磨三千大千地种以为其墨。过于东方千国土即下一点。以为校量彼佛灭度。但过是数无量百千阿僧祇劫。岂同寿量说成佛远。经云。譬如五百万亿那由他阿僧祇三千大千世界。假使有人末为微尘。过于东方五百千万亿那由他阿僧祇国。乃下一尘。如是东行尽是微尘是诸世界。若着微尘及不著者。尽以为尘一尘一劫。我成佛以来复过于此。百千万亿那由他阿僧祇劫。释曰。以此之喻方之大通。三千墨点非可类矣。自此劫来皆是方便。故然灯等言无不该也。是以昔人云。十六王子尚掩成道之初。斯言惬当。则知弥陀阿閦佛等。皆是本师成佛后事义无惑矣。自在王佛展转多劫。但以数明劫。岂如末尘为劫耶

疏。以理推下。第七结成正义。十方诸佛皆我本师海印顿现。且法华分身有多净土。如来何不指己净土。而令别往弥陀妙喜。思之故知。贤首弥陀等佛皆本师矣。复何怪哉。言贤首者即寿量品中。过百万阿僧祇刹。最后胜莲华世界之如来也。经中偈云。或见莲华胜妙刹贤首如来住其中。若此不是叹本师者。说他如来在他国土为何用也。且如总持教中。亦说三十七尊。皆是遮那一佛所现。谓毗卢遮那如来。内心证自受用。成于五智。从四智流四方如来。谓大圆镜智流出东方阿閦如来。平等性智流出南方宝生如来。妙观察智流出西方无量寿如来。成所作智流出北方不空成就如来。法界清净智即自当毗卢遮那如来。言三十七者。五方如来各有四大菩萨。在于左右。复成二十。谓中方毗卢遮那如来四大菩萨者。一金刚波罗蜜菩萨。二宝波罗蜜菩萨。三法波罗蜜菩萨。四羯磨波罗蜜菩萨。东方阿閦如来四菩萨者。一金刚萨埵菩萨。二金刚王菩萨。三金刚爱菩萨。四金刚善哉菩萨。南方宝生如来四菩萨者。一金刚宝。二金刚威光。三金刚幢。四金刚笑。西方无量寿如来。亦名观自在王如来。四菩萨者一金刚法。二金刚利。三金刚因。四金刚语。北方不空成就如来四菩萨者。一金刚业。二金刚法。三金刚药叉。四金刚拳。已上总有二十五也。及四摄八供养故三十七。言四摄者即钩索锁铃。八供养者即香华灯涂戏鬘歌舞。皆上有金刚下有菩萨。然此三十七尊各有种子。皆是本师智用流出。与今经中海印顿现大意同也。问若依此义岂不违于平等意趣。平等意趣云言即我者。依于平等意趣而说。非即我身如何皆说为本师耶。答平等之言乃是一义。唯识尚说。一切众生中。有属多佛多佛共化以为一佛。若属一佛一佛能示现以为多身。十方如来一一皆尔。今正一佛能为多身。依此而赞方赞本师

疏。然此段下第八辨其兼含。此含第十七德。故至下文说相则少。所以此中兼此德者。有二意故一为类例义相似故。不欲繁文故现妙喜极乐等土。二者以第十七成于此段。全是今师由差别土皆是本师一佛现故不见此意。岂知经旨勿轻尔也

疏。文中有三。前二云同者顺功德中平等德故

疏。五或见释迦下。约经即到无障碍处。疏中先引无著立功德名。后谓一切时下。将释论意以会经文。彼论具云谓已惯习一切烦恼。及所知障对治圣道即一切智。及定自性以为能治故。无著论詺为修治。又已到于永离一切障处故。经。名为到无障处。经中别说但明十度。而揭总云供养诸佛修行道。则无所不具

疏。有等言

疏。既云已经多劫。则不定始成者。即此段初半偈经云或见释迦成佛道已经不可思议劫。所以疏中牒此言者。遮天台师之谬释也。谓彼学者多云。华严虽则玄妙。而有二事不如法华一兼别义。是故不说声闻作佛。二说如来始成正觉。不说本师寿量久成。故疏中指此经文。即是此经说久成处。若以此后不得该前则法华寿量不能该于我始坐道场者于三七日思惟等迹。就彼师以久成为本。始成为迹。今经之本则非古非今。若就迹门则能今能久。生公亦云是以极设长寿言。伽耶是之。若伽耶是者非复伽耶。伽耶既非。彼长安独是乎。长短斯非则所以长短存焉。诚为妙悟。不说声闻得作佛者。约不共义。既不厌舍曾何弃之。况一成一切成。无一众生不具佛智。善须得意勿杂释经

疏。六有三偈下。即经不可转法。疏中先引论立名。后于中下便以论意释经。彼论具云由有上德故。他不能转。利有情事故次明之。谓教证二法皆不为他所转动。故无有余法胜过此。故言初二即教证二道者。二偈之中各含教证。初句证道次诸地句含于教证。次半偈唯教后偈之中。堪忍不退皆是证道余即教道

疏。七或现兜率下。约经即所行无碍。疏中先出功德名。后于中下科文解释。彼论具云显示如来于所化之中。无高下碍故次明之。谓世法八风不能拘碍故。八风即利衰毁誉称讥苦乐。降神处宫即是利也。弃荣离俗即是衰也。若生若灭有苦乐也。学异行者兼于苦乐多明苦也。坐道树下示降魔毁也。正觉誉也。涅槃起塔亦为衰也。次三处天多明四顺。次六巧化义兼逆顺

疏。八如来住下。即经立不思议。疏中先依论立名后科文释义。论云。由依前方便能作利益之事故次明之。谓十二分教名所安立。由深广故不可思议释经可知

疏。九具足下。即经普见三世。疏中初依论立名次谓记别下。是指论解。论云以上加行利有情事三世诸佛悉皆平等。故次明之。谓于三世平等性中。能随解了过去未来曾当转事。皆如现在而授记故。后从故云皆悉明见矣。是举经帖

疏。十有四偈等者。约经即身恒充满一切世间。疏中但出功德之名耳。无性詺云。显上利益一切顿遍非次第作故。次明之。经中多分说变化身略无受用

疏。十一等者。约经即智恒明达一切诸法。无性释云。以于上十六彼彼之处。作断疑事故次明之。疏中先出功德名。后于一切下论释于一切境。善决定故欲断他疑。要须自断方能断他。经中既为世师内外兼了。故能断疑

疏。十二有九偈等者。约经了一切行。疏中先出功德名。后谓遍了下论释无性生起云。由所化生性有差别故次明之。离世间品。但名了一切行。若深密等。云于一切行成就大觉。无性云入种种行法成大觉故。经文中随其心行现种种形。说种种法乃至为说觉分诸宝华诸圣功德。即是皆成大觉义也

疏。十三如来下。约经尽一切疑。十一是断自疑。此断他疑。疏中先出功德名。后谓佛智下解释。彼论具云。由即于前所化。有能善巧别知故次辨之。谓圣声闻。言此人全无少分善根。如来知彼善法当发现证。过去微少善根种子所随故。故经文中无碍智见一切众生。以无边门皆令成熟

疏。十四下。即经无能测身。疏中先立功德名后谓随解现身故即论释也。若解深密。云凡所现身不可分别。不可分别即无能测。无性生起云由上云善巧别知故。此次云于前所化邪正及俱行中。无有分别。故今经中。情与非情万类皆现。乃至云佛身功德海亦尔无垢无浊无边际等

疏。十五下。即一切菩萨等所求智

疏。中先出功德名。后意云下。以论意释。具足论云为欲引发不定种性声闻。菩萨唯赞大乘故次明之。言等所求者无不求故

疏。十六如来下约经即到佛无二究竟彼岸。疏中先论立名。后释经法身相。今初无性释云。为遮所化于大师所疑一切智非一切智故次明之。由满诸度是一切智。论云平等。释经无二。平等有二。一法身平等。于法身满中诸度故。二果位诸度无增减故名为平等。亲光则以住于法身即是彼岸。无著则以彼岸是于法身所有。二义俱通。疏然同下二。释法身相即第九论彼果分。中论云。诸佛法身以何为相。应知法身略有五相。一转依为相。谓转灭一切障离染分依他起性故。转得解脱一切障于法自在转。现前净分依他起性故。故经云虽无所依。成离染依故也。无不住得净分也。二白法所成为相。谓六波罗蜜圆满得十自在故。故疏。云圆满自在。三无二为相。谓有无无二为相。由一切无所有故。空所显相是实有故。有即为二为相。业烦恼尽非所为故。自在示现有为相故。异一性无二为相。由一切佛所依无差别故。无量相续现等觉故。故经云其性非有非无故。正是初意。四常住为相。谓真如清净相故。本愿所引故。所应作事无竟期故。此有三身常义故。经虽无不至。即应化普周受用广遍。二身常义。而不去者。自性身常不去。即不变常无不至。即相续不断常耳。五不思议相。谓真如清净自内证故。无有世间喻能喻故。非诸寻思所行处故。故经云一切三界无伦匹即无喻能喻。以出世间言语道故非寻思所行。而五相相融为法身体

疏。但略配故钞委出

疏。或略不喻者。以案文释空中之画。若准新经乃有三喻谓如空白日。亦如梦则空可喻二。谓无所依及常住相。如白日喻喻白法为相。如梦一喻喻无二相。欲言其有觉竟无实。欲言其无梦境历然。故非有无为无二相。其不思议后偈显之疏。十七有一偈者。约经即具足如来平等解脱。疏中先立名。后既随解而现下释经。论云。以外人闻上平等谓同一性故。次说言不相间杂。谓一切如来十身体用各各别故。犹如冥室千光。结此一段差别佛土。上第四门已兼明竟。故此但略显不思议故不可为喻

疏。十八下。即经证无中边佛平等地。疏中但出功德名耳。无性云。由疑上如来妙智究竟非一非异其相云何故次明之。此无中边等。常无常等皆二边相。论立名中言方处者谓诸世界。无分限者。释无中边。无中边言略有四义。一虚空无中边。佛德如彼无有分限。二世界无中边。诸佛十身即于其中。称世界量平等遍满。三此法身等于佛地中。平等遍满无中无边无有分限。四此法身等遍一切处。为诸众生现作饶益。然非自性无中边故。经中明身如摩尼具无量色。即第二充遍一切。然非色非非色为无中边。即第三四义其随现无住。亦第三义及第一义无分限故。亲光詺此为真如相殊胜功德。义亦全同以其双非复无住故

疏。十九一偈摄三种功德者。约经即极于法界等虚空界。穷未来际配三德名。疏文具之即以实际。配于经中穷未来际。然第十九功德。无性云。以上言无中边相。云何无相故次明之。极于法界谓此法界最清净故。离诸戏论是法界最清净相。能起等流利益之事。极此法界无有尽期。第二十等虚空界无尽功德。无性云。谓上作利乐皆无尽故。此约自利无尽。故论云。谓如虚空经成坏劫性常无尽。如来一切真实功德亦复如是。其穷未来际。云究竟功德者。论云。如未来际无有尽期。如来利他功德亦复如是究竟无尽。然上二句无著但云无尽功德等不言开合。无性开二故但云第二十初有一生起。上来且欲将后二偈。以为总结故。配三德。理实后二正是等虚空界。穷未来际无尽功德。故疏。云亦是别显无尽功德

疏。法性深广下。即大文第四谦赞回向。上半谦赞上句赞下句谦。下半回向三处。初回向实际。后二回向众生及回向菩提。然回向菩提复有二意。一自成佛菩提。二令他成。令他成者。义同回向众生。菩萨发心不期自为即以向他为自益耳。故令含识同证菩提。贤首法师发愿偈云

  誓愿见闻修习此　　圆融无碍普贤法
  乃至失命终不离　　尽未来际愿相应
  以此善根等法性　　普润无尽众生界
  一念多劫修普行　　尽成无上佛菩提

大方广佛华严经随疏演义钞卷第九十


大方广佛华严经中卷卷大意略叙

    No. 1740 [cf. No. 279]

大方广佛华严经中卷卷大意略叙

        北京李通玄造

    第一卷(菩提场第一会说六品经至第五卷　世主妙严品第一)

佛成道。在摩竭提国。说法于菩提场中。往劫与佛同修故。令众海云集

    第二卷

傍生品类。上界诸天。如来果海之中。各分证解脱

    第三卷

四王八部。杂类诸神。皆以妙请之词。歌咏难思之法

    第四卷

形色万类。部从千般。各说解脱之门。偈赞如来功德

    第五卷

如来不思议力。菩萨皆从座起。流天地。降于征祥。海会供无边诸佛

    第六卷(如来现相品第二)

大众同与念请。如来现相以酬。光声召于有缘十方新众云集

    第七卷(普贤三昧品第三。世界成就品第四)

普贤入藏身三昧。如来以圣力加持。起定说十海法门。广明世界成立

    第八卷

风轮持于大水。大海涌于莲华。安布刹种香河。重叠世界于中海

    第九卷(世界成就品。华藏世界品第五)

右旋十海。递相接连。交络重重。如天珠网

    第十卷(至第十一卷　毗卢舍那品第六)

所管刹海。随直至于轮围法界等。华藏庄严。举果劝同生信乐

    第十一卷

毗卢舍那。往劫曾为太子威光。供十须弥山微尘数诸如来。令获十莲华藏世界之果海

    第十二卷(普光明殿第二会说六品经　佛名号品第七。四圣谛品第八)

如来名号多种。逗生几器不同。四生圣谛。随方以立名。各令闻法而证悟

    第十三卷(光明觉品第九。菩萨问明品第十)

文殊与九首菩萨。问明十种甚深。皆显性相融通。破一切众生疑执

    第十四卷(净行品第十一。贤首品第十二)

净行起无边大愿。文殊令善用其心。贤首彰德行。咏收显信有无涯大用

    第十五卷(贤首品)

毛光照益三昧。举喻表玄旨幽深。叹经难思而劝持。诸佛摩顶而随喜

    第十六卷(忉利天宫第三会说六品经　升须弥顶品第十三。偈赞品第十四。十住品第十五)

须弥偈赞。彰佛德不离而升天。十住解门。辨菩萨入位之宗趣

    第十七卷(梵行品第十六。初发心功德品第十七)

梵行令了境空寂。不生二解之心。发心现功德无涯。初念便成正觉

    第十八卷(明法品第十八)

明法说三宝不断。下能安乐人天。十行十种法门。上求升进之位

    第十九卷(夜摩天宫第四会说四品经　升夜摩天宫品第十九。偈赞品第二十。十行品第二十一)

夜摩偈赞。彰佛德之不穷。兼显十行之法门。广论菩萨之巧妙

    第二十卷(十行品)

无著等真之四行。明自利利他之两门。端证已来难思偈颂再收于前德

    第二十一卷(十无尽藏品第二十二)

十无尽藏。三世诸佛同遵。不唯属十行之法门义。亦过回向之胜进

    第二十二卷(都率天宫第五会说三品经　升都率天宫品第二十三)

上升都率。化主赴缘。睹佛神光。天王获益

    第二十三卷(偈赞品第二十四)

知足之天偈赞。十回向之初。显菩萨悲智无涯。长劫救众生苦

    第二十四卷(至三十三卷　十回向品第二十五)

坚心不坏等。诸佛之法门。行愿弥纶。回善逝于时处

    第二十五卷

善因含果。立无尽之藏名。善根合真。即同如性之不尽

    第二十六卷

从施车马乃至以身。大因十段长文。内外咸舍

    第二十七卷

菩萨舍连肤顶髻。乃至救于残形。以万行庄严其身。成十种丈夫之相

    第二十八卷

始终睹佛出现六十种大施之门。前后三卷长文。总收坚固回向

    第二十九卷

所顺众生无相。能随心行。亦如二施。广阿僧祇。愿生具足于财法

    第三十卷

百门之德。一如贯之。行善等于虚空。亦同性相之弥广

    第三十一卷

由无相惑缚着。得解脱回向之名。六种微细智门。愿证普贤之德

    第三十二卷

罗一身于法界。收万像于毛端。回等法界之善根。成普贤尘刹之大用

    第三十三卷

依正二果。皆以无数宝严结叹。劝修普贤位之功满

    第三十四卷(他化天宫第六会说一品经至三十九卷　十地品第二十六)

他化摩尼宝殿。创开十地法门。三加五请。方陈首明初地之相

    第三十五卷

离垢地菩萨。修三聚十善之法门。八定五通。发无边妙慧之焰相

    第三十六卷

能证智之慧焰。进修菩提分之法门。寄声闻四谛观门。显菩萨胜地之相

    第三十七卷

般若现前。十种观缘起之法。远行时久。七地超前后之功

    第三十八卷

不证无生之理。由佛致七劝之桥。大悲观众生十种之稠林。大智流菩萨才辨而演法

    第三十九卷

云雨自他之广德。小分未等于如来。于中。因果相参。多喻校量不测(三禅天第七会阙文)

    第四十卷(重会普光第八会说十一品经至四十三卷　十定品第二十七)

极果必由初信。是故重会法堂。普贤承命以宣扬。方定陈十定之胜用

    第四十一卷

遍住国土三昧。爰及十种庄严。说菩萨自在神通。显普贤无尽功德

    第四十二卷

差别自在三昧起入之用无他分。四口而波涛心。流四辨而演说

    第四十三卷

无碍大轮三昧。遍法界而为胜能。如天众王之化。类等觉而同妙觉

    第四十四卷(十通品第二十八。十忍品第二十九)

卷舒自在辨才。辨十种之身。神通法喻。双明陈十忍之相

    第四十五卷(阿僧祇品第三十。寿量品第三十一。菩萨住处品第三十二)

僧祇寿量。表佛德之不穷。感应随方。示菩萨之住处

    第四十六卷(至四十七卷　不思议法品第三十三)

大众怀疑念请。未知德相云何。青莲纵辨以返酬。谈佛不思议之果法

    第四十七卷

始终广大佛事。修乎解脱之门。高建勇健之法幢。宣畅圆音之远彻

    第四十八卷(如来十身相海品第三十四。随好光明功德品第三十五)

十身相海与随好光明。皆显德用难思因深果远

    第四十九卷(普贤行品第三十六)

普贤行品。一惑为百万障门。偈颂别明十行。参而不杂

    第五十卷(至五十二卷　如来出现品第三十七)

如来出现。法喻多门。十身含纳而融通。一理济平而映彻

    第五十一卷

口辨泻圆音之相。酬明智水之潜流。破微尘而出大经。剖凡心现圣智

    第五十二卷

境行与成等正觉。转法轮及涅槃。亲近见闻不空。成金刚不坏之坚种

    第五十三卷(三重普光第九会说一品经至五十九卷　离世间品第三十八)

菩萨处世不染。即离世间之品。现普慧云。兴于问端。普贤瓶泻以酬答

    第五十四卷

始从十种欣慰。乃至无等住门。三百余段长文。以酬十行之相

    第五十五卷

十种无常之意。后彰自在等门。其中旨趣无边。述前回向之位

    第五十六卷

首题十种无碍。至大师子吼之显文。颇有无数法门。广前十地之德

    第五十七卷

断十种余习。后论胜进之心。广有三十三门。通明离垢之行等

    第五十八卷

始从菩萨净施。下至降生十门。其中行愿而不穷。酬因果满之相矣

    第五十九卷

降生母胎之八相。偈劝修持之。一心二千出离之行门。一部修成之分矣

    第六十卷(祇洹重阁第十会说一品经至八十卷　入法界品第三十九)

如来不离逝多林中。入师子频申三昧。菩萨睹法界之神变。声闻皆聋盲而不知

    第六十一卷

普贤以能开十句。如来展白毫一光。文殊徒从而南行。皆显定门之果德

    第六十二卷

大圣诫善财。求友南行。访德云海云。与善住法门。幽奥而不测

    第六十三卷

遇弥迦与解脱长者。证旋陀罗尼之妙门。后见海幢比丘。睹身毛所现之胜事

    第六十四卷

礼休舍瞿沙之友。才执手而游览十方。劝诣胜热之刀山。投火聚而获三昧

    第六十五卷

始从慈行童女。后至明智居士。其四人善友。皆寄十行之法门

    第六十六卷

宝髻普眼之长者。无厌大光之国王。不动谈礼佛之往因。法门含逆顺之深意

    第六十七卷

遍行化六趣之形类。鬻香主五分之法门。无上胜将四拶以度人。师子尼处于座谈法

    第六十八卷

婆须及观音菩萨。大天与安住地神善友。修回向之法门。婆珊云初地之圣位

    第六十九卷

夜神普德。授游步解脱之教门。喜目身云。供多佛而势弥远

    第七十卷

普救纵毫光一道。善财获清净三轮。问答明历事于多尊。远劫遇良友而开通

    第七十一卷

寂静与守护城。为善财开解脱之门。一一并深广难思。重重皆结会今古

    第七十二卷

开敷树华之友。说解脱名。太喜光明轮王。设法施之作场。夜神会修目之古事

    第七十三卷

大愿法门。善财睹胜妙之邑。父王见佛。太子免刑戮之愆

    第七十四卷

妙德灵神。主十种受生之藏。摩耶母腹。现三千神变之奇

    第七十五卷

善财访于瞿波德神。示求友之诫。遇佛为姻之往事。同修行愿之胜缘

    第七十六卷

摩耶为诸佛之母仪。愿处言行之典则。其众艺主光之善友。皆会缘入定之所由

    第七十七卷

童子童女。诫善财事友百重法。慈氏慈念。偈赞令归于本师

    第七十八卷

善财感遇而启言。弥勒具德而能容。经有三百余段。显菩提心胜而功高

    第七十九卷

善财入于阁门。见尘刹无边之劫事。法喻问答而退席。当成道果而再期

    第八十卷

文殊展手而如持。善财功证于极果。普贤摩顶而偈劝。慎勿疑于此经

大方广佛华严经中卷卷大意略叙竟

大永七年亥二月十八日写毕书写之志者。华严经者。一代根本法轮。直显如来之内证。依之一度触耳者。永离生死之苦报。通玄居士者。华严之祖师。讲经之协佛意。故从口放金色之光。云彼云此。不信不可有者也。然八十卷之大意。才拶尽掌中之纸墨。微妙之要术也。宪每日为顶戴之。不顾料纸之轻乏。励恶笔写之者也。愿者三宝冥众。哀愍纳受给　　　快宪(四十七)


大方广圆觉修多罗了义经略疏

    No. 1795 [cf. No. 842]

    大方广圆觉修多罗了义经略疏序

        金紫光禄大夫守中书侍郎尚书门下平章事充集贤殿大学士裴休撰

夫血气之属必有知。凡有知者必同体。所谓真净明妙虚彻灵通。卓然而独存者也。是众生之本源。故曰心地。是诸佛之所得。故曰菩提。交彻融摄。故曰法界。寂静常乐。故曰涅槃。不浊不漏。故曰清净。不妄不变。故曰真如。离过绝非。故曰佛性。护善遮恶。故曰总持。隐覆含摄。故曰如来藏。超越玄閟。故曰密严国。统众德而大备。烁群昏而独照。故曰圆觉。其实皆一心也。背之则凡。顺之则圣。迷之则生死始。悟之则轮回息。亲而求之。则止观定慧。推而广之。则六度万行。引而为智。然后为正智。依而为因。然后为正因。其实皆一法也。终日圆觉。而未尝圆觉者凡夫也。欲证圆而未极圆觉者菩萨也。具足圆觉。而住持圆觉者如来也。离圆觉无六道。舍圆觉无三乘。非圆觉无如来。泯圆觉无真法。其实皆一道也。三世诸佛之所证。盖证此也。如来为一大事出现。盖为此也。三藏十二部一切修多罗。盖诠此也。然如来垂教。指法有显密。立义有广略乘时有先后。当机有深浅。非上根圆智。其孰能大通之。故如来于光明藏。与十二大士。密说而显演。潜通而广被。以印定其法。为一切经之宗也。圭峰禅师。得法于荷泽嫡孙南印上足道圆和尚。一日随众僧。斋于州民任灌家。居下位以次受经。遇圆觉了义。卷未终轴。感悟流涕。归以所悟告其师。师抚之曰。汝当大弘圆顿之教。此经诸佛授汝耳。禅师既佩南宗密印。受圆觉悬记。于是阅大藏经律。通唯识起信等论。然后顿辔于华严法界。宴坐于圆觉妙场。究一雨之所沾。穷五教之殊致。乃为之疏解。凡大疏三卷。大钞十三卷。略疏两卷。小钞六卷。道场修证仪一十八卷。并行于世。其叙教也圆。其见法也彻。其释义也端如析薪。其入观也明若秉烛。其辞也极于理而已。不虚骋。其文也扶于教而已。不苟饰。不以其所长病人。故无排斥之说。不以其未至盖人。故无胸臆之论。荡荡然实十二部经之眼目。三十五祖之骨髓。生灵之大本。三世之达道。后世虽有作者。不能过矣。其四依之一乎。或净土之亲闻乎。何尽其义味如此也。或曰。道无形。视者莫能睹。道无方。行者莫能至。况文字乎。在性之而已。岂区区数万言而可诠之哉。对曰。噫是不足以语道也。前不云乎。统众德而大备。烁群昏而独照者。圆觉也。盖圆觉能出一切法。一切法未尝离圆觉。今夫经律论三藏之文。传于中国者五千余卷。其所诠者何也。戒定慧而已。修戒定慧而求者何也。圆觉而已。圆觉一法也。张万行而求之者何。众生之根器异也。然则大藏皆圆觉之经。此疏乃大藏之疏也。罗五千轴之文。而以数卷之疏通之。岂不至简哉。何言其繁也。及其断言语之道。息思想之心。忘能所灭影像。然后为得也。固不在诠表耳。呜呼。生灵之所以往来者。六道也。鬼神沈幽愁之苦。鸟兽怀獝[狂-王+戊]之悲。修多方嗔。诸天正乐。可以整心虑趣菩提。唯人道为能耳。人而不为。吾末如之何也已矣。休常游禅师之阃域。受禅师之显诀。无以自效。辄直赞其法。而普告大众耳。其他备乎本序云

    大方广圆觉修多罗了义经序

        唐终南山草堂寺沙门宗密述

元亨利贞干之德也。始于一气。常乐我净佛之德也。本乎一心。专一气而致柔。修一心而成道。心也者。冲虚妙粹炳焕灵明。无去无来。冥通三际。非中非外。洞彻十方。不灭不生。岂四山之可害。离性离相。奚五色之能盲。处生死流。骊珠独耀于沧海。踞涅槃岸。桂轮孤朗于碧天。大矣哉。万法资始也。万法虚伪。缘会而生。生法本无。一切唯识。识如幻梦。但是一心。心寂而知。目之圆觉。弥满清净中不容他。故德用无边。皆同一性。性起为相。境智历然。相得性融。身心廓尔。方之海印。越彼太虚。恢恢焉晃晃焉。迥出思议之表也。我佛证此。愍物迷之。再叹奇哉。三思大事。既全十力。能摧树下魔军。爰起四心。欲示宅中宝藏。然迷头舍父。悟有易难故。仙苑觉场。教兴顿渐。渐设五时之异。空有迭彰。顿无二谛之殊。幽灵绝待。今此经者。顿之类欤。故如来入寂光土。凡圣一源现受用身。主伴同会。曼殊大士创问本起之因。薄伽至尊。首提究竟之果。照斯真体灭彼梦形。知无我人。谁受轮转。种种幻化生于觉心。幻尽觉圆。心通法遍心本是佛。由念起而漂沈。岸实不移。因舟行而鹜骤。顿除妄宰。空不生华。渐竭爱源。金无重矿。理绝修证。智似阶差。觉前前非。名后后位。况妄忘起灭。德等圆明者焉。然出厩良驹。已摇鞭影。埋尘大宝。须设治方。故三观澄明。真假俱入。诸轮绮互。单复圆修。四相潜神。非觉违拒。四病出体。心华发明。复令长中下期克念摄念而加行。别遍互习业障惑。障而消亡。成就慧身。静极觉遍。百千世界佛境现前。是以闻五种名。超刹宝施福。说半偈义。胜河沙小乘。实由无法不持无机不被者也。噫巴歌和众。似量腾于猿心。雪曲应稀。了义匿于龙藏。宗密[髟/石]专鲁诰。冠讨竺坟。俱溺筌罤。唯味糠粕。幸于涪上。针芥相投。禅遇南宗。教逢斯典。一言之下。心地开通。一轴之中。义天朗耀。顷以道非常道。诸行无常。今知心是佛心。定当作佛。然佛称种智。修假多闻。故复行诣百城。坐探群籍。讲虽滥泰。学且师安。叨沐犹吾之纳。谬当真子之印。再逢亲友。弥感佛恩。久慨孤贫。将陈法施。采集般若。纶贯华严。提挈毗尼。发明唯识。然医方万品。宜选对治。海宝千般。先求如意。观夫文富义博。诚让杂华。指体投机。无偕圆觉。故参详诸论。反复百家。以利其器。方为疏解。冥心圣旨。极思研精。义备性相。禅兼顿渐。勒成三卷。以传强学。然上中下品。根欲性殊。今将法彼曲成。从其易简。更搜精要。直注本经。庶即事即心。日益日损者矣

大方广圆觉修多罗了义经序

大方广圆觉修多罗了义经略疏注卷上之一

        唐终南山草堂寺沙门宗密述

将解此经。十门分别。一教起因缘。二藏乘分摄。三权实对辩。四分齐幽深。五所被机宜。六能诠体性。七宗趣通别。八修证阶差。九通释名题十别解文义。初有通别通谓酬因酬请显理度生。一代教兴皆由是矣。若原佛本意。则唯为一大事因缘故。别者。有十所为故说此经

一显示因行有本故　圆照净觉了无明空。发清净心方修万行

二泯绝果相成圆故　本无菩提涅槃。唯是清净觉性。故无始终增减。方为究竟之果

三决择悟理应修故　普贤问意云。觉性本圆一切如幻。幻空无体。谁曰修行。如其不修何因证觉。佛说因起幻智以除诸幻。幻尽智泯觉心圆明。然今唯说空幻者。溺在无修。修习之徒缚于有得。良由悟修之意似反而符。故最难明。理须决择

四穷尽甚深疑念故　菩萨难意云。众生本佛。今既无明。十方如来后应烦恼。佛答意云。即此分别便是无明。故见圆觉亦同流转。如云驶月运等。但一念不生。则前后际断。如医差华亡等。众生即佛。人罕能知。知而寡信。信而鲜解。解亦难臻此境。今经决了实谓穷源。苟能精通群疑自释

五除断轮回根本故　发业成种。无明为根。润业受生。贪爱为本。若不识其相贼即能为。若不达其空。永不可断。故答文殊弥勒。究了尽其根源

六搜索菩提隐障故　谓我人众生寿命。虽名同诸教。而行相深密。从粗至细展转难除故净业一章重重搜索

七少文能摄多门故　文唯二十八纸。义具顿渐空有悟修性相

八一法　一一文中。无不标依圆觉结入圆觉

巧被三根故　普眼观门被上根。三观诸轮被中根。道场加行被下根

九令修称性深禅故　三观皆以悟净圆觉为本

十劝事离相明师故　佛本是而勤修。惑元无而须断。无轨可则。无迹可依。必须离相明师触向晓喻。故令亲近尽命亡躯等

二藏乘分摄者。谓三藏之中修多罗摄。二藏之中菩萨藏摄。诸乘之中一乘所摄。十二分中　一契经。二应颂三授记。四讽颂。五因缘。六自说。七本事。八本生。九方广。十未曾有。十一譬喻。十二论义

契经方广二分所摄。三权实对辨者。然西域此方古今诸德立宗判教离合有殊。或一味不分或开宗料简。今将略叙。且启二门。初则不分。后明分教。不分之意其有五焉。一理本一味殊途同归故。二一音普应一雨普滋故。三原佛本意为一事故。四随一一文众解不同故。五多种说法成枝流故。故不可分。即后魏流支。姚秦罗什。立一音教。是此意也。其分教者。有其八意　初五翻前后三别说

一理虽一味诠有浅深故。二佛虽一音教随机异故。三本意未申随他意语故。四言有通别就显说故。五由辨权实不住枝流故。六王之密语语同事别故。七不识佛意。以深为浅失于大利。以浅为深虚其功故。八诸佛菩萨亦自分故。以斯等意。开则得多失少。合则得少失多。但能虚己求宗分。亦何乖大旨。故今分之。然就分教。又诸德不同。今依贤首大师。统收为五。一小乘教。二大乘始教。三终教。四一乘顿教。五圆教。初者以随机故。随他语故。说诸法数一向差别。以其简邪正辩凡圣分欣厌明因果。然其所说法数有七十五但说人空不明法空。唯依六识三毒。建立染净根本未尽法源。故多诤论。二始教者。亦名分教。以深密第二第三时教同许定性无性俱不成佛故。今合之总为一教此既未尽大乘法理。故立为初。有不成佛。故名为分。广说法相。削繁录数犹有一百。少说法性。所说法性即法相数。决择分明故少诤论。三终教者。亦名实教。定性二乘无性阐提。悉当成佛。方尽大乘至极之说。故立为终。以称实理故名为实。少说法相多说法性。所说法相亦会归性。故无诤论。上二教并依地位渐次修成。总名为渐。然大乘教总有三宗。谓法相破相　二皆渐教之始。即戒贤智光二论师。各依一经立三时教。互相破斥。而传习者。皆认法性之经。成立自宗之义

法性　通于顿渐。渐即终教。终于始故。顿如后说

今将法性对二宗料简。即为二门。一对法相。二对破相。初中性相二宗有多差别。今随类束略叙十条。一三乘　性五故也。初小次一不了。后具三乘为了。深密云云

一乘　生一故也。初小次二不了。后唯一乘为了。法华等云云

三五性　楞伽等中皆说五种性故

一性　法华楞伽涅槃皆唯一性。趣寂声闻余国佛度故。菩萨与记当作佛故。阐提有佛性故。摄论立法一居三后故法华破三多嫉怨故

三唯心妄　八识从惑业生

真　八识通如来藏

四真如凝然　八识生灭故非随缘

随缘　八识依藏性故但是真如随缘成立

五三性空有离　遍计空依圆有

即　无性即圆

六生佛不增不减　定性无性决不成佛故。生界不灭。一理齐平故。无增无减

七二谛空有离　真俗条然

即　第一义空该通真妄

八四相前后　灭表后无

同时　体性即灭

九能所断证离　根后缘境断惑。以有为智证无为理

即　惑即菩提。见即真如

十佛身有为　四智依生灭识种故。报身有为

无为　智依如来藏故。佛化身即常即法不堕诸数。况报体耶

若知二教权实。二宗亦不相违。谓就机则三。约法则一。新熏则五。本有无二等。二对破相者。略有五别。一无性　以诸法无性为真如

本性　以常住真心为真如

二真智　能了无性者

真知　一心真实本自能知。通于理智。彻于染净。如华严问明品说

二二谛　色等俗也空即真也

三谛　加第一义谛。谓一真心性非空非色。能空能色如镜之明

四三性空有　空宗有谓依计。空谓圆成性宗。即遍计情有理无。依他相有性无。圆成情无理有。相无性有

五佛德空　虽说佛身五求不得。得则虚忘。无得乃真。离一切相名佛功德

有　诸佛皆具常乐我净真实功德。身智通光一一无尽。性自本有。不待机缘

略辨此五。余可例知。然得意者亦不相违。谓一切法既皆是真心缘起。缘起无性还即真心。始不异本。知外无智。余谛性等例之可明。然此门与前后别。但教有始终渐顿之殊法非深浅之异。四顿教者。但一念不生即名为佛。不依地位渐次而。说故立为顿　思益经。云得诸法正性。者。不从一地至于一地。楞伽经云。初地即为八。乃至无所有何次

总不说法性。唯辩真性。一切所有唯是忘想。一切法界唯是绝言。五法三自性皆空。八识二无我都遣。诃教劝离毁相泯心。生心即妄不生即佛　泯之迹绝方显真性故

五圆教者。明一位即一切位。一切位即一位。是故十信满心。即摄五位成正觉等。主伴具足故名圆教。即华严经也。所说唯是无尽法界。性海圆融缘起无碍。如帝网珠重重无尽。已知五教贯于群诠。未审此经与彼何摄。今显此义分作三门。一彼全摄此。此分摄彼。谓圆教也。二此分摄彼彼不摄此。谓初二也。三彼此克体全相摄属。即终顿也　权实对辨讫

四分齐幽深者。约起信论明诸染法本末五重。以显诸宗所诠分齐深浅。论中初唯一心为本源。二依一心开二门。一者心真如门。谓心性不生不灭。二者心生灭门。谓依如来藏与生灭合。名阿黎耶识。三依此识明二义。一觉义(始本)。谓心体离念等。二不觉义。谓不如实知真如法一。不觉心起等。四依后义生三细。一依不觉故心动名业相。二依动故能见名转相。三依见故境界妄现名现相。五依最后生六粗。一智相　依境分别也。即法执俱生

二相续相　依智起念不断。即法执分别

三执取相　心起着故。即我执俱生

四计名字相　我见分别。上四皆惑

五起业相(业也)。六业系苦相(报也)　言诸宗所诠分齐者。谓人天乘唯齐业报。小乘唯后四粗。法相极于三细。终顿通诠本末方穷初一心源。初一心源即此经圆觉妙心也。经标圆觉为宗本故。说染净法皆从觉心所现起故　第一重

文殊章末即真如门。经名如来藏差别。即生灭门　第二重

普眼一章即始本觉。征释无明即是不觉　第三重

净业一章即三细二粗　第四重

弥勒章初轮回因果。即后四粗　第五重

是知圆觉极尽五重。标云。幽深良在斯矣。五所被机宜者。略有二种。初料简。后普收。初谓乐著名相以文为解者。系滞行位高推圣境者。情尚于空触言宾无者。自恃天真轻厌进习者。固执先闻担麻弃金者。如上皆非其器。反上即皆是器。后普收者。一切众生皆本有佛性。但得闻之无不获益。谓宿机深者悟入。浅者信解。都无宿种者。亦皆熏成圆顿种性。如华严经食金刚喻。六能诠体性者。略作四门。一随相门。复有二种。一声名句文体。体用假实相资故。故十地经有空中风(喻声)画(名等)之喻。二通摄所诠体。若不诠义文非教故。二唯识门。前二不离识故。然有本影之异。三归性门。此识无体唯是真如故。四无碍门。心境理事交彻相摄故。以一心法有二门故。七宗　当部所崇

趣　宗之所归

通别者通论佛教因缘为宗　于中有小乘空宗法相法性圆融等异。今即法性

别明此经又有总别。总以心(寂也)境(空也)空　遍计如蛇鬼等。下云。非作故无等

寂　依他如影像等。下云。四大不动等

觉性圆满　由空寂故圆满成实

凡圣平等为宗　下云。觉圆明故。乃至根尘遍法界等

令修行者忘情　由悟宗故即下缚脱八不等佛　由情忘故

观行速成为趣。又以前趣为宗。令惑业消灭永绝轮回起大神用安乐自在为趣。别者有五对。一教义对。教说为宗义意为趣。二理事对。举事为宗显理为趣。三境行对。理境为宗观行为趣。四行寂对。观行为宗绝观为趣。五寂用对。绝观心寂为宗起大神用为趣。此五亦是从前起后渐渐相由矣。八修证阶差者谓若但。约教文唯生义解。忘诠修证复有其门。故以心传心历代不绝。自佛属迦叶展转于今。灯灯相承明明无尽。然所传法不出定慧悟修顿渐。无定无慧是狂是愚。偏修一门无明邪见。此二双运成两足尊。故天台修行宗于止观。其顿渐悟修者。顿悟　日出孩生　渐修　霜消孩长

为解悟渐修顿悟　伐木入都

顿修渐悟　磨镜学射

渐修渐悟　如登九层台。足履渐高所鉴渐远

并为证悟。若顿悟顿修　斩染綟丝

则通三义谓先悟　廓然顿了

后修　不着不证旷然合道

为解悟先修(服药)后悟(病除)为证悟修　无心忘照悟　任运寂知

一时即通解证。若云本具一切佛德为悟　如饮大海

一念万行为修　得百川味

亦通解证。此圆觉经备前诸说。为文殊一章。是顿解悟。普眼观成是顿证悟。三观诸轮是渐证悟。又三观一一首标悟净圆觉。次明行相。后显功成。初中为对是顿悟渐修。中后为对是渐修顿悟。此等顿渐皆语用心。不同前门但是判教。苟得其意皆成定慧。如其失旨妄想无记。冀诸学者审而修之。其第九第十两门。便随本文注解。故不牒其科段

大方广圆觉修多罗了义经　上五字所诠。谓圆觉是法。大方广是义。故文中标结指陈。一一只言圆觉不言大等。下六字属能诠。谓经是教法。修多罗了义。叹教胜能。经有五名。首题唯二。良以宗本体用是法义之宏纲。诠旨功能是言象之皎镜。事周义尽。须建五名。简要标题且存两号。大等三字是体相用。各有二义。大者当体得名。常遍为义。当体者。不同法相宗拣小之大。大外有小可拣。犹是分限。岂为至大。今以圆觉体无边涯绝诸分量。强名大也。常遍者。常则竖通三世。遍则横该十方。竖者过去无始未来无终。无有一法先之。唯此先于诸法。故名大也。故涅槃经云。所言大者。名之为常。横者十方穷之无有涯畔。涅槃又云。所言大者。其性广博。犹如虚空。方者就法得名。轨持为义。轨生物解。任持自性。持自性者。一切众生皆有本觉。虽流浪六道受种种身。而此觉性不曾失灭。生解者。众生悟入知见。虽因善友开示。然其智解从觉性生。如水土之润生谷等牙。牙从种生不从水土。故文云。圆觉流出菩提涅槃及波罗蜜。教授菩萨。广者从用得名。广多广博为义。广多者。此圆觉性。本有过尘沙之妙用。潜兴密应无有休息。无有穷尽。广博者。此无尽之用一一同于觉性。无有边际无有分限。故文云。觉性遍满圆无际故。当知六根遍满法界。如是乃至八万四千陀罗尼门遍满法界。圆觉者直指法体。若不克体标指。则不知向来说何法大说何法广。圆者。满足周备。此外更无一法。觉者。虚明灵照无诸分别念想。故论云。所言觉义者。谓心体离念。离念相者等虚空界。即是如来平等法身。依此法身说名本觉。释曰。此是释如来藏心生灭门中本觉之文也。故知此觉非离凡局圣。非离境局心。心境凡圣本空唯是灵觉。故言圆也下文说。涅槃昨梦世界空华。众生本成佛道。又云。一切觉故。又云。幻灭觉圆满。或唯觉之一字是法。余四皆义。意言。此觉有广大义。有方圆义。谓体大而用广。理方而义圆。方是正直不偏不邪。圆是满足无亏无缺亦可大。方是体广圆是用。谓体大而方正不偏。用广而圆满无缺。故复以方连大。以圆连广。又上三字是别。圆字是总意明。此觉具足三大之德。故名圆也。是则总别之德具彰。法义之门双指。故名大方广圆觉。后能诠修多罗三字总指诸经。了义二字叹此一部是诸经决了之义也。故下文云。是十二部经清净眼目。经之一字正是此典。修多罗者。此云契经。契谓契理契机。经谓贯穿摄化。谓贯穿所应知义。摄持所化生故。了义者。决择究竟显了之说。非覆相密意含隐之谭。然诸经中何者了义。何者不了。清凉大师答顺宗皇帝所问诸经了义云。佛一代教。若约本为一事。则八万度门莫非了义。若圆器受法无法不圆。得之由人亦皆为了义。此二不足简别。今约开方便门示真实相。则有了不了。故净名涅槃宝积等经皆云。依了义经。不依不了义经。不了义经。谓小乘教。了义经者。谓大乘教。大乘复有了不了。谓有大乘。虽六度悲智兼修。而定说三乘不一。亦非了义。若有会归一极。以玄炉陶于群像。智海总乎万流。无二无三无不成佛。中道理观不共二乘。方为了义。又大宝积经云。舍利弗。何等经中名为了义。何等经中名不了义。舍利弗。若诸经中宣说世俗名不了义。宣说胜义名为了义。宣说作业烦恼名不了义。宣说烦恼业尽名为了义。宣说厌离生死趣求涅槃名不了义。宣说生死涅槃无二无别名为了义。宣说种种文句差别名不了义。宣说甚深难见难觉名为了义。释曰。据上说了义行相。皆与圆觉相。当佛自料简固应无惑。经者契经。亦如上释。逐便从简。又略契字。问修多罗与经但唐梵之文异。今双置题目。岂非繁重。答上则总指诸部。此则唯目当经。对总叹别。故非重也。亦如大方等修多罗王经。岂不亦修多罗王四字是总指诸部以叹其经耶

罽宾沙门佛陀多罗译　开元释教目录云。沙门佛陀多罗唐言觉救。北印度罽宾人也。于东都白马寺。译圆觉经一部。不载年月。续古今译经图纪。及贞元目录亦同。北都藏海寺道诠法师疏。又云。羯湿弥罗三藏法师佛陀多罗。以长寿二年龙集癸已。持于梵本方至神都。于白马寺传译两卷。总二十八纸。其度语笔授证义润文诸德具如别录。此下正释经文。总分三分。谓序正流通。序中证信便是发起。谓佛入大光明藏。与一切佛同住众生清净觉地。现诸净土。菩萨主伴皆入三昧。同一佛境。以表因果无异凡圣同源。显发此经旨趣如是。然证信序诸经皆同。是阿难请问佛令置之。亦为断疑息诤及异邪故。然虽具六成就。今随文便均于广略。总分为三。一信闻时主。二说处依真。三同体法众。今初信闻时主

如是　且兼我闻合释。即指法之辞也。如是之法我从佛闻。佛地论云。谓结集时诸菩萨众咸共请言。如汝所闻当如是说。传法菩萨便许可彼言。如是当说。如我所闻。释曰。以佛地经在净土说故。论释结集者云是菩萨。又纂灵记云。摩诃衍藏。是文殊师利与阿难海。于铁围山间结集故。离释如是者。信成就也。智论云。佛法大海。信为能入智为能度。信者言是事如是。不信者言是事不如是。故肇公云。信顺之辞也。信则所言之理顺。顺则师资之道成。又圣人说法但为显如。唯如为是。故称如是。又真不违俗名如。俗顺于真为是。又如者当理之言。是者无非之称。又有无不二为如。如非有无为是。若唯就当经说者。凡圣因果不异圆觉名如。唯此因果方离过非为是

我闻　闻成就也。我即文殊及阿难海。五蕴假者。云何称我。我有四种。一凡夫遍计。二外道宗计。三诸圣随世假分宾主。四法身真我。今是后二。故无过也。闻谓耳根发识。虽因耳处。废别从总故称我闻。非邪慢心而有所说。若无相宗。我既无我闻亦无闻。从缘空故。不坏假名即不闻闻尔。若约法性。此经旨趣传法菩萨。以我无我不二之真我根境非一异之妙。耳闻真俗无碍之法门也

一时　时成就也。师资合会说听究竟。总言一时。一时者。简异余时。时者随世假立。如来说经时有无量。不能别举。一言略周故但云一时。如涅槃云。一时佛在恒河岸等。又诸方时分延促不同。故但言一时。若约当宗。即说听之时。心境泯理。智融凡圣。如本始会。此诸二法皆一之时

婆伽婆　主成就也。涅槃云。能破烦恼名娑伽婆。即当断德。以显法身。净土说经法报不分非应化矣。故佛地经云。是薄伽梵最净净觉。极于法界。尽于虚空。穷未来际。若约诸经。多是佛字翻云觉者。谓心体离念。觉了真妄性相故。觉具三义。谓自觉觉他觉满。若约佛地论。则具十义。谓具二智离二障。于一切性相能自开觉。亦能开觉一切有情。如睡梦觉。如莲华开。故名为佛。若依华严则说十佛。谓成正觉佛。愿佛。业报佛。住持佛。涅槃佛。法界佛。心佛。三昧佛。本性佛。随乐佛。若出其体即圆觉也。如题中释二说处。依真者。处成就也。谓佛入法性源。现无边无碍刹土。亦不定分自他受用。故曰依真。然诸大乘经在净土中说者。今略举十以为其例。谓深密经法集经。称赞大乘经。密严经。心印经。兴显经。大毗卢经。入印法门经。虚空藏经。佛地经云。如是我闻。一时薄伽梵。住最胜光曜。放大光明普照无边世界。周圆无际超过三界所行之处。彼论释云。此土受用土摄。说此经佛是受用身。此净土量无边际故若尔。此地上菩萨所应见闻。何故于此化土中结集流布。论自答云。佛为地上诸菩萨说。令传法者结集流通又云。说此经时地前大众。见变化身居此秽土为其说法。地上大众。见受用身居佛净土为其说法。所闻虽同所见各别。而传法者。为令众生闻胜希愿证佛功德。故就胜者所见结集。言婆伽梵住最胜等。文中二。初摄相归真。后称真现土。初中三。一标入智用之源。二明与凡圣同体。三总彰称体圆遍。今初标入智用之源

入于神通大光明藏　藏即宝性法界藏。起信心真如。是诸佛众生之本源。神通光明之性体。尘沙德用并蕴其中。百千通光皆从斯起。故云藏也。亦名法性。土亦名常寂光土。息诸分别。智与理冥名为入矣。然诸佛有常光放光。若约常光光即是藏。谓心性本明。迷之似闇。妄想既尽显焕无涯。故论云。心性不起即是大智慧光明遍照法界。若约所放光及所起通。即神通光明之藏

三昧正受　唐梵双彰也。安住藏中不受诸受名为正受。又三昧此云正思。谓在定时。于所缘境审正思察故。二明与凡圣同体者。既入其源即同其体。故论云。无漏无明种种业幻。皆同真如性相。华严亦云。心佛及众生。是三无差别。文中二。初明圣同

一切　十方三世

如来　本觉名如始觉名来。始本不二名曰如来。是则众生有本无始。是如不来

光严　重重交光照曜炳着

住　安住永绝攀缘

持　任持不失不坏后明凡同

是诸众生清净觉地　迷真起妄妄见众生。妄体元空。全是本觉。心地妄不能染故云清净。故论云。一切众生本来常住入于涅槃。然圣证此境。直曰住持。凡不知同但指觉地。三总彰称体圆遍

身心寂灭平等本际　凡圣身心取相似异。相皆虚妄当体寂灭。寂灭故平等皆同一际。即圆觉本际

圆满十方　既与觉体无异故。随体圆满周遍法界

不二随顺　随顺不二也。西域语倒。译者回文不尽故也。生死涅槃为二。凡夫顺生死。二乘趣涅槃今皆不住故云随顺。又依报则净秽不二。正报则生佛不二。克体则身心不二。通该则自他不二。与此相应是随顺矣。二称真现土

于不二境　佛无现土之念。如明镜无心

现诸净土　无念而应缘。如明镜无心而现像。故肇公云。净土秽土益随众生之所宜。净者示之以宝玉。秽者示之以瓦砾。美恶自彼于我无定。无定之土乃名净土。随类普应。故云诸也。然土虽多种不出其三。一法性。二受用。三变化。若开受用自他即成四土。统唯二种。谓净及秽。或性及相。然此二种。一质不成净秽亏盈。异质不成一理齐平。有质不成搜原则冥。无质不成缘起万形故。形夺圆融无有障碍。前凡圣一体者。从自受用入法性土。此应诸菩萨即从法性现他受用。故次云。与大菩萨乃至同住如来平等法会。三同体法众文三。二总标

与(并及)大　登地已上

菩　菩提此云觉。即所求佛果

萨　萨埵此云有情。即所化众生。又此人有了悟之觉。余缘虑之情。又此是求菩提之有情也

摩诃萨　摩诃大也。谓此有情信大法解大义发大心趣大果修大行证大道故。故华严中地前云摩诃萨。然今例者唯是地上

十万人(标数)俱　一时一处一别列

其名曰　夫圣人无名为物立称。多依行德。随宜别标。标立千差皆有所表。今各以所论法义对释其名。文理昭然。非强穿凿

文殊师利菩萨　此云妙首。亦云妙吉祥。表信解之智故。亦云妙德。表证智故。文中说本起因地。究真妄以成正解。成就信根故。请问人当此菩萨

普贤菩萨　略有三释。一约自体。体性周遍曰普。随缘成德曰贤。二约诸位。曲济无遗曰普。邻极亚圣曰贤。三约当位德无不周曰普。调柔善顺曰贤。表于理行。今此门中依圆觉妙心征幻法。而明正行。故当其问行解不二。即是毗卢遮那。是为三圣。故次文殊

普眼菩萨　由此法门令观身心无体。根识尘境。世及出世。自身他身。一切清净遍满法界。普同诸佛。观行成就顿见如此境界。是真普眼也。此含悲智。谓普见诸法清净。是大智普眼。普见众生成佛。是大悲普眼

金刚藏菩萨　从喻为名。金刚坚而复利。坚则无物可坏。利则能坏一切。此菩萨智亦尔。烦恼不能侵。外魔不能。动坚也。能破诸障断人疑惑。利也。故起三重甚深之难。以消末世之疑。疑心既无。即具无尽功德。故复云藏

弥勒菩萨　此云慈氏。慈是其姓氏也。名阿逸多。此云无胜。胜德过人故。今以姓而呼但云弥勒。由此门深究爱根荡除细惑。所以五代修证皆属轮回。弥勒是等觉菩萨一生补处。表除微细惑习即得正觉圆明

清净慧菩萨　表在此门修证地位因果相中。而智慧不住不着。虚心忘相。不为行位差别之相所染

威德自在菩萨　三观成就功用猛利。邪魔不能娆。妄惑不侵故

辩音菩萨　佛以一音逗于万类。虽此门统明三观。而随机单复不同。故二十五轮各皆证入。此菩萨善能辩别随类圆音。故当其问

净诸业障菩萨　一切业障尽依四相而生。此门问答。除之诸业自然清净

普觉菩萨　从前诸过已离四相又除然于用意行心仍余作止任灭之病。觉犹未普。至此决择四病觉性无瑕。普觉诸病故当此矣。若具指者。普觉本末。普觉粗细。普觉浅深

圆觉菩萨　然此正宗中诸菩萨等。与佛问答。发扬本意。欲显圆觉。但缘节节过患未尽。义意未圆。收机未普。故表法菩萨未标圆觉之名。今有三意得名圆觉。一前虽病尽理圆。仍恐下根难入。此又曲开方便三期道场。即上中下机普归圆觉。二由前节级行解已圆。至此名为证极。证极之境更无别体。唯是圆觉。三最初标指圆觉为陀罗尼门者。从本起末。今显义已周还至圆觉者。摄末归本。表此三意故当此门

贤善首菩萨　调柔善顺曰贤。贤之与善义意无别。贤则亚圣。善则顺理。首是头首。欲使万善齐兴。俱顺真理成正因位。亚次圣果者必藉经教流通。经教流通是贤善之首故。流通分中当此菩萨

等　等有二意。一等所列。二等所余

而为上首　为十万之标领也。三总叹

与诸眷属　称性之众必具主伴。如华严说。此约自他融摄。若但约自心。即智度为母等

皆入三昧　由入定故得住佛境

同住如来平等法会　当尔之时凡圣体同因果一相故。言法会者。法性之会无我无人。自下正宗分中十一重问答。束之为二。初一问答。令信解真正成本起因。后十问答。令依解修行随根证入。初者顿悟本有圆觉妙心。本无无明生死。方名真证信解。不认妄念不执异见故也。成本起因者。最初发起之因。然顿教因地总有三重。初了悟觉性次发菩提心。后修菩萨行。谓若不了。自心何知正道。故多劫修行非真菩萨。次不发大心无由起行。故善财先陈已发方问行门。论中亦先问示二觉。次令发三心。后方修五行。今本起因即初二也。至文当示。文中四。一申请。二赞许。三伫听。四正说。此四段下十皆同。初中三。初进问威仪。次正陈辞句。后三展虔诚。下十初段皆有此三。今初进问威仪

于是　指住之辞

文殊师利菩萨　名义已如上释。次下皆咨求法要恭敬之仪

在大众中即从座起　与一切凡圣同住平等法会。从法空之体起悲济之用

顶礼佛足　以己最尊之顶。礼佛最卑之足敬之至也。敬是意业。意业无状故。以身口表之。经标白言及下叹大悲。即口业矣

右绕　随顺义也。表顺觉性

三匝　显佛一体三宝三身三德。表自愿灭三道等。诸有三数表义例知

长跪　安危不易

叉手　信解合体心境交参

而白佛言　上皆经家缀缉。次下即菩萨正陈辞句。文三。一问本起之心

大悲　咨求法要本为众生。故偏举大悲之德。六波罗蜜经云。云何大悲能除重担示胜义故。成就有情住法性故

世尊　第十号也。具上九号为世所尊

愿为此会　平等法会

诸来法众　皆称法性故

说于　指下所请宣说之法

如来本起　佛昔根本所起最初之法

清净　圆照本体元无烦恼

因地　因行所依之心地也。上文云。是诸众生清净觉地

法行　称真法之行。大集经说。若有比丘读诵如来十二部经。乐为四众敷扬广说思惟其义。是名乐读乃至是名思惟。不名法行若有比丘能观身心。乃至境界都息。永离烦恼其心寂静我则说之名为法行。然菩萨所请说者。意云。夫求果者必观于因。因若非真果还是妄。如造真金佛像。先须辩得真金。成像之时体无增减故。请说本起因地。为万行所依也。下文佛答。照圆净觉本无无明等。为因体也。即前第一重了悟觉性。二问发心离病

及说　及有二义。一简前义。显是二问。二合集义非但请说因地。亦及请说发心

菩萨于大乘中　大乘之体是本始觉。今请于觉悟心中说发心

发清净心　即前第二发菩提心也。直心正念真如故清净矣。故偈中直云。菩提心也。华严云。忘失菩提心而修诸善根。魔所摄持。既为所摄。即过患众多。故请发心因缘令得永离。且中间忘失善根。犹彼摄持况都未发心诸行。岂离彼业

远离诸病　一发之后永无忘失。无忘失故魔惑不娆。下佛答。有无俱离觉照亦泯。能所绝等即离诸病。此乃不发一切心。名真发清净心也。三明远被当来

能使未来末世众生　佛灭度后正法像法各一千年。末法万年。末法即为末世。去圣遥远深可悬忧。故显益中偏垂结指。又初标此会。后结当来。影略而言。现未俱益。金刚三昧经中解脱菩萨。亦为末劫五浊众生。请宣一味决定真实令等同解脱

求大乘者。不堕邪见　谓末法中正解难得。其有或恣心五欲。或宗习异道。或执滞二乘者。置之言外。总有发意唯求大乘。若不闻此法门亦堕邪见。离本心外别有所求。见妄见真并为邪见。后三展虔诚

作是语已　正语而礼非仪也

五体　四支及头

投地　不唯拜手而已

如是三请终而复始　若唯一度未展虔诚。若过于三礼烦则乱。故三周终始。显示真心。佛虽已知垂范应尔。二赞许

尔时　文殊礼毕之时

世尊告文殊师利菩萨言　先赞后许

善哉善哉　智论释云。再言之者善之至也。大乘了义理合宣扬。针芥未投且默斯要。既当嘉会根熟咸臻。将演妙门必资发问。今之所请实谓起予。利乐寔多。再言叹善

善(顺理)男子(刚断)汝等　等诸菩萨虽一人之言言众人之意也

乃能为诸菩萨。咨询如来因地法行。及为末世一切众生求大乘者　此下乃至不堕邪见。牒所问辞正述善之所以

得正　非住于法

住　安心觉海永息攀缘

持　任持万行无漏无失

不堕邪见　释成正字

汝今谛听当为汝说　许也。诫令审谛勿杂余缘。无以生灭心行听实相法。智论偈云。听者端视如渴饮。一心入于语义中。踊跃闻法心悲喜。如是之人可为说。三伫听

时　佛赞许时

文殊师利菩萨奉教欢喜。及诸大众默然而听　既蒙许说愿乐欲闻。洁已虚心收视反听而寂默也。赞许伫听之文。下十一段皆同此释四正说下十段文皆有其二。初长行后偈讽。今初分四。一标示真宗。二推穷妄宰。三释成因地。四结牒问辞。一中又二初明本有觉心。后明悟则成佛。初中又二。一示本体

善男子。无上法王　佛也。于法自在更无有上。然虽无一众生而不具有圆觉。且尘经未出宝藏犹薶。既不自知宛受贫苦。唯佛全得其用故。但标大觉有之

有大　当体无边

陀罗尼　此云总持。谓圆觉体中有尘沙德用。从本已来持之不失故。然总持有三。谓多字一字无字。今即无字也。故大宝积经陀罗尼品云。如来之智摄诸善巧。所有宣说无不清净。无有少法所得。皆归于空。乃至此是诸菩萨等入陀罗尼门。若据智论即云。陀邻尼梵音小异尔论自翻为能持。亦云能遮。谓种种善法持令不失。恶不善心遮令不生。既言持善遮恶即是万行之本故。此标之矣

门　出入义也。出者一切染净诸法皆从中出故。次文云。流出一切等。下说生幻化无明等。入者若了悟圆觉体用。则百千万法悉皆悟入。故下文云觉圆明故显心清净。乃至遍满等。是知欲了万法。须从圆觉中入。又从本起末为出。摄末归本为入。又迷之则出。悟之则入。有出入义故名为门。此中门者是根本义。不同世法门浅室深故。宝积经连前次云。由是门故出生广大差别觉慧。此则无门之门。门清净故。形相门者。则为非门。所言门者。犹如虚空。一切诸法依于虚空而有生灭。又荷泽云。知之一字众妙之门。皆说根本矣

名为圆觉　上但述义相。今则正指法体也。已如题中所释。二彰德用

流出　非别有。法从中流出于外。但依觉性显示诸门。功德无有穷尽。应用无有疲厌。名为流出。故论云。若心有动则有过恒沙等妄染之义。对此义故。心性无动则有过恒沙等诸净功德相义示现尔

一切(总标)清净　简诸有漏有漏之法皆真理故。性本无故

真如　圆觉自性本无伪妄变异。即是真如。真谓真实显非虚妄。如谓如常表无变易。谓此真实于一切位常如其性故。又真者体非伪妄。如者性无改异。伪是诈伪。鋀如真金。妄是虚妄。影如本质。异就横说。多物同时而各殊改。约竖论一体先后而变易。今皆离此故曰真如。谓此实体于未来常如过去。于色中常如受中。真实相如非为妄似。论云。心真如者。即是一法界大总相法门体。所谓心性不生不灭。乃至竟无变坏。唯是一心故名真如。又云。真如用者。诸佛因地摄化众生不取相者。以如实知众生及与己身。真如平等无别尽故。以有如是大方便智。除灭无明见本法身。自然而有不思议业种种之用

菩提　此翻云觉。义见题中。始本不二无法不知。本无无明故云觉也。二三四智及发心伏心明心。出到无上五种菩提。皆此摄也。因圆果满无不由之。业用无边不可具载

涅槃　此方正名寂灭。取其义类乃有多名。总以义翻称为圆寂。谓觉性既圆无法不寂。本无生死。具足三德。翻三杂染等。故二三四种亦皆此摄。故彼经云。能建大义。又华严云。不为菩萨示现涅槃。欲令常见佛圆满故。但为令众生生欣乐恋慕故。现出现没。佛日常现净心器中。心浊器破则不得见

及　简因果义别也。又非但流出理果亦及因也

波罗　此云彼岸

密　具云蜜多。此翻云到。若回文顺此方俗。应云到彼岸也。谓离生死此岸度烦恼中流。到涅槃彼岸。然一切众生即寂灭相不复更灭。但以迷倒妄见生死名为此岸。若悟生死本来空寂名到彼岸。且约对翻六蔽略有六种。谓性无悭贪。毁禁。嗔恚。懈怠。动乱愚痴。顺本性故。修行施戒忍进定慧。既称性而修。即皆到彼岸菩提资粮论中慧为初者。由慧成五。五助慧故。故彼论云。既为菩萨母。亦为诸佛母。般若波罗蜜。是觉初资粮。施戒忍进定。及此五之余。皆由智度故。波罗蜜所摄。起信摄为五者。止观相由定慧相。即故唯识。开为十者。助治十障证十真如故。若总翻诸染即八万四千。义如下释

教授菩萨　显上所流真如等法之业用也。菩萨是所。教真如等是能。教故谓真如是理次二是。果波罗蜜是因理实因果是可轨故。谓约其情执即似都无情。既本空此非新得。顿悟理者。依之修行能生物解。名为教授故。论云。顺本性故修行檀等。涅槃亦说诸佛师法。后明悟则成佛。上且标宗未为酬问。今显悟之成佛方名本起之因

一切如来本起因地　牒其所问

皆依　无佛不尔

圆照　即能照也。离于偏局

清净觉相　即所照也。寂寥虚廓了无情尘亦可照。体清净是觉之相。非关能所。但以初悟能所未忘故云相也。此正同善财初遇文殊。表信智见其身相。后见文殊。表证智不见身相

永断无明　本觉既显无明本无。毕竟不生名为永断

方成佛道　尘沙诸佛以此为因。第二推穷妄宰文二。先示其相。后显本空智。论云。佛有二种说法。先分别诸法。后说毕竟空。正是此也。初中三。谓征释结。今初征

云何无明　征释此者。有其二意。一由前云永断无明。恐谓定有可断欲待断尽方成佛道故。今征释显其本空。二谓此无明是八万尘劳之根。十二因缘以首。河沙烦恼由此而生。尘劫轮回以之不绝。非想定后还作狸身。无为坑中犹名病行。今欲明清净觉性。欲示圆顿妙门。不先推破无明。所作尽扶颠倒。故决真心本有。便推妄性元无依此。了悟分明始得名为因地。二释言无明者。无他智明故。谓虽有本觉之明。而无始觉照了。始觉从缘始显。对本故名为他。论名不觉。但文异尔。亦名为迷。亦名颠倒。论云。不如实知真如法一故不觉心起等者。明迷自也。此云妄认四大等者。明认他也。然迷自必认他。认他必迷自。二文互举。其业用者。论说能生三细。此云。由此故有轮转生死。然一切有漏之法。无不是此任持。无不是此发起。故论又云。当知世间一切境界皆依无明而得住持。此下文云。身心等相皆是无明。文中三。一案定其非。二正释其相。三出其过患。今财案定其非。但云颠倒未显其相

善男子。一切众生　除了圆觉性者。其余悉该

从无始来　未曾悟故

种种　如下所明

颠　心识狂乱

倒　背觉合尘倒有所执。颠但荒狂由颠故倒。如由迷自故认他也

犹如迷人四方易处　如人乍至川原。或入聚落。忽然心惑以东为西。既一方迷余三俱转。故云易处。然正迷之时方亦不转。勿然醒悟还是旧方。反推此迷了无踪迹。无本来处。无今去处。二正释其相者。即迷自法身真智。认他四大缘念是无明之相也。故肇公云。法身隐于形壳之中。真智隐于缘虑之内文二。一法

妄认四大为自身相　认为我也。然四大从缘假和合有。无我无主。毕竟是空离我我所。又如下文。皮肉筋骨皆归于地等。然凡夫种种造业长劫轮回只由迷自法身执此四大为我

六尘缘影为自心相　此有二释。一者六尘是境识体是心。心对根尘有缘虑相。虑相如影举体全无。自心灵明本非缘虑。今认缘虑谓是自心。念念随之漂沈苦海。如珠明彻本非青黄。对青等时即有影像。愚执其色谓是其珠。如迷自心认缘影也。故唯识云。诸心心所依他起故。亦如幻事。非真实有。为遣执心心所外实有境故。说唯有识。若执唯识真实有者。亦是法执。佛顶经云。此是前尘分别影事等。故知缘影决定是空。若清净真心本无缘虑。灵知不昧无住无根。今认缘心诚为妄矣。二者此一句。经译者回文不尽。应云缘六尘影。六尘影是所缘。妄识是能缘。六尘无实犹如影像。从识所变。举体即空。故此缘心亦无体也。余同前解。前标颠倒云种种者。通论则我法二执。于中各有种种相转及凡夫二乘。各有四倒。若克就此文。即上迷身迷心。总有四对颠倒。谓四大非我认为我。法身真我而不认。是第一对。四大如幻。本无而见有。法身真实。本有而见无。是第二对。缘念生灭认为真心。真心了然而不自认。是第三对。缘念如珠中黑色。全空而执有。真心如珠中明相。实有而见无。是第四对。一三我执。二四法执。如斯等见不因师宗。但是凡愚任运如此。既四对八只不同故云种种。二喻文二。初直喻前文

譬彼病目见空中华及第二月。善男子。空实无华。病者妄执　翳眼观空里。无华妄。见华。捏目望月轮。月边别见月。空华幻月皆喻妄见。众生一念迷心。翳自圆明觉性。而于圆明体上妄见生灭身心。故曰空实无华病者妄执。妄执之言。正对前妄认之语。若悟真如无相。但是一心。如空本无华。天唯一月故。首楞云。见闻如幻翳。三界若空华。闻复翳根除。尘消觉圆净。又云。汝身汝心。外洎山河虚空大地。咸是真精妙心中所现物。亦可别配二喻。谓华喻认身。月喻认心。身则但因心迷当体妄认。如空华但因眼翳外无别依。心则内根外尘相依而起。如幻月下因捏目上因本月相依而生。故配身心昭然义现。然月喻例华亦应云。月实无二捏者妄执。经文影略故不具之。又为一解。翳捏皆喻见分。空华二月皆喻相分。眼喻智慧。空及本月喻真理。世亲般若论以翳喻相分者。据释处之意。取所见之华也。后展转到见

由妄执故　牒前生起转计所以

非唯惑此虚空自性　虚空之性清净无物。今执华生空处。即似空变成华。妄见空华。无生而生。无物成物。是迷惑虚空之性也

亦复迷彼实华生处　既执华从空生。即不知从翳而起。翳则实是华之生处。非谓真实之华。若具法合。应云。非唯惑此真空自性。亦复迷彼身心生处。此乃但怪空里有华。不觉眼中有翳。外嫌身心苦恼。不知内畜迷情。三出其过患

由此　因前妄认身心相也

妄有　生死不实

轮转生死　妄执身心。若无过患任其长执。不必化之。既由此执尘沙劫中轮回不绝。地狱鬼畜八苦五衰为害之深。故须开示。三结

故名无明　明即令人解脱。故知令人轮转即名无明。二显本空。文三。初标定

善男子。此无明者。非实有体　言无体者。但是假名。内外求之了不可得。推其本际元是妙明。故论云。念无自相不离本觉。又云。依觉故迷。若离觉性则无不觉。了斯无体诸行不生。不生故无灭。生灭灭已寂灭为乐。是知十一支法皆有所因。唯此无明横从空起。今悟无明灭则行灭。行灭则识灭。乃至老死灭也。次喻释

如梦中人梦时非无。及至于醒了无所得　前说种种过患皆归无明。今又云无体。道理难见言语路绝。故约喻释。谓睡时梦物且见是有。故前种种说其行相。寤欲求之终不可得。故此显示云无体也。问求不得者何处灭去。故次答云

如众空华灭于虚空。不可说言有定灭处。何以故　征意云。若无灭处即应还在。以何义故。言空无也

无生处故　意云。见幻华时若实是有。今不见时即说灭处。见时本无生处。不见何寻灭处。问前云实华生处。此复何通。答约前妄执之时而言有也。悟了始知有时元无。以法合之昭然可见。故楞严经云。此迷无本性毕竟空。昔本无迷似有迷觉。觉迷迷灭。觉不生迷。此正是无生之理。若决定忍可于心。名无生忍。华严云。一切法无生。一切法无灭。若能如是解。诸佛常现前。后断疑疑云。前说生死。由于无明。无明既无。何有生死。故释云

一切众生于无生中妄见生灭　无明及与生死本末一切俱无。众生于此无中迷情横见生死。前就横见故说有。此就实论故说无

是故说名轮转生死　指前文也。由是横见之故。故前文说名生死。第三释成因地。上来所说妄空真有者。有佛无佛性相本然。今明依此通达心意冥符方成本起因地。释成正答所问。文中三。初依真悟妄顿出生死

善男子。如来因地修圆觉者　牒前所标。即依真也

知是空华　悟妄也。下皆顿出生死

即无轮转　无生死之法也。既知万法如空华。岂更见有轮转。还丹一粒点铁成金。真理一言点凡成圣。亦释因不异果。如斯因地方谓真修

亦无身心受彼生死　无生死之人也。谓若计有我是免轮回之者。即是未免我执。我我所忘方为解脱。即是照五蕴空。度一切厄。外遗世界内脱身心。不计身身同虚空。不计心心同法界

非作故无。本性无故　非由我作观行方得身心空无。本性空寂元来无故。故金刚三昧经云。若化众生无生于化。不生无化其化大焉。次展转拂迹释成正因。拂有四重

彼知觉者犹如虚空　一拂觉妄之智。谓能觉身心性本无者。亦如太虚都无所有

知虚空者即空华相　二又泯其拂心。知能觉无者。即同空华体即无也

亦不可说无知觉性　三遮其断灭。但不起念分别空有。不是无心

有无俱遣　四总结离过

是则名为净觉随顺　释成因也。有无既不当情。斯即心言路绝。清净觉体从此显彰。但不背之合尘。即名随顺。亦非别有能顺。故罗什云。无心于合合者合焉。随顺净觉。故言净觉随顺。如是执尽病除。然后兴心运行。则聚沙画地合掌低头皆成佛道。如斯修习可谓正因。后征拂所由。释归圆实

何以故　身心幻妄可说全空。知觉称理因何又拂。有无俱绝约何修行。次释意云。相因对待皆是从缘。从缘之法岂实有体。生心动念即乖本性。失正念故。圆实性体俱无如是等故

虚空性故　一切法空不生灭也。谓如上相因诸相。犹若虚空。本自不生今无可灭。非谓拂之方令空也。故佛藏经云一切法空无毫末相等

常不动故　一切法寂不来去也。非已去非未来非现起故。故法句云。诸法从本来寂灭无所动。法华亦云。常自寂灭相

如来藏中　上二句明诸法。此下皆是显一心也。论指一心云如来藏故。楞伽亦云。寂灭者。名为一心。一心者。名如来藏。此经下云。圆觉妙心涅槃即名佛性。今此一句总标。次二句空藏。后三句不空藏。通云如来藏者。由三义故。一隐覆义。谓覆藏如来故云藏也。故理趣般若经云。一切众生皆如来藏胜鬘云。生死二法名如来藏。如来法身不离烦恼藏。名如来藏如来经藏云。一切众生贪嗔痴诸烦恼中有如来身。乃至常无染污。德相备足如我无异。便以九喻喻之。一萎华佛身。二岩蜂淳密。三糠糩粳米。四堕秽真金。五贫家宝藏。六庵罗内实。七弊物金像。八贫女轮王。九焦模铸像。二含摄义。谓如来法身含摄身相国土神通大用无量功德故。又亦含摄一切众生。皆在如来藏内故。三出生义。谓此法身既含众德。了达证入即能出生故。十地论云。地智能生无漏因果。亦能生起人天道行。此三义者。初约迷时。后约悟时。中间克体然约真妄和合。总有二种行相。谓此经下云。如来藏自性差别。论云。真如生灭。然真妄各有二义。真谓不变随缘。妄谓体空成事。真中不变妄中体空。即真如自性也。真中随缘妄中成事。即生灭差别也。初真如性中。复有二相。胜鬘云。有二种如来藏空智。所谓空如来藏脱离一切烦恼藏。不空如来藏。具过恒沙不思议佛法。论中亦说如实空如实不空。义全同此。后生灭中亦有二相。谓漏无漏。无漏复二。有为无为。有漏亦二。谓善不善。此等行相皆有业用。初真性者。有其二业。一能持自体恒沙功德。从本已来不失不坏。二能御客尘恒沙烦恼。无始时来不染不污。后生灭亦有二业。一能起惑治业。旷劫长受六趣生死。故楞伽云。如来藏者。是善不善因。能遍兴造一切趣生乃至若生若灭。二能知真达妄发心修行证三乘果。如前所引十地论等。由是二业故。宝性论引经偈云。无始世来性。作诸法依止。法性有诸道。及证涅槃果。长行引胜鬘释云。性者。如来藏。依止者。如来藏。是依是持是建立。诸道者。有如来藏故说生死。是名善说。证涅槃者。若无如来藏者。不得厌苦乐求涅槃。既诸佛因果始终依之。故入道行人先须信解。离此别信信则堕邪。故密严经诃为恶慧。华严亦云。不能了自心。云何知正道。彼由颠倒慧。增长一切恶。据此则了之方知正道。故胜鬘云。若于无量烦恼所缠如来藏不疑惑者。于出缠无量烦恼藏法身亦无疑惑。华严初会普贤即入如来藏身三昧。意在此也。然虽此心凡圣等有。但果显易信因隐难明。故浅识之。流轻因重果。愿诸道者深信自心

无起灭故　释上所知生死等

无知见故　释上彼知觉者等。此上二句释空藏矣。谓见生死起者。即云执情。见生死灭者。即云知觉。今以如来藏中既无可起可灭。何有能执能知。又迷时生死非起净心非灭。故无迷也。悟时净心非起生死非灭。故无悟也。无悟故无知见矣。此乃非唯不可识识。抑亦不可智知。识智俱如。方为自体真实识知。大智慧光明遍照。为下三句不空藏矣

如法界性　法界性与如来藏体同义别。别有其二。一者在有情数中名如来藏。在非情数中名法界性。如智论明佛性法性之异。二者谓法界则情器交彻心境不分。如来藏则但语诸佛众生清净本源心体。如云能造善恶能起厌求。就法界言。即无斯义。据此则藏心克就根源。界性混其本末。混则普骇之义易信。克则周遍之理难明。故指藏心如法界性。亦乃摄其二义之别。归于一体之同。方显觉妄因依。诚非究竟圆实

究竟　竖穷三际始终常然

圆　遍周虚空

满　众德具足

遍十方故　无边际故。良由如来藏性本自如斯。岂须减旧添新灭惑生智。是以三重泯绝冥合觉心。将此为本修行始得正名因地第四结牒问辞

是则名为因地法行。菩萨因此。于大乘中发清净心。末世众生依此修行。不堕邪见　但结前文更无别义。此下偈讽文二。一标举

尔时世尊欲重宣此义。而说偈言　然偈有二种。一伽陀。此云讽颂。谓孤起偈。今非此也二祇夜。此云应颂。颂长行也。或为钝根重说或为后来之徒。或为增明前说故。今此经偈皆祇夜也。然凡言长行偈讽相望。有五对之例。谓有无广略离合先后隐显。今经问目皆长有偈无。答皆长广偈略。余随相当对文当指。二正陈。然此段中五偈。但重讽长行。更无别义。故如次依前四段科之。但经文增减故科段名亦小殊。四者。一讽了悟本觉

  文殊汝当知　　一切诸如来　　从于本因地
  皆以智慧觉

义不异前。二讽推破无明

  了达于无明　　知彼如空华　　即能免流转
  又如梦中人　　醒时不可得

上二段皆长离偈合。三讽拂迹成因

  觉者如虚空　　平等不动转　　觉遍十方界
  即得成佛道　　众幻灭无处

上二句长先偈后

  成道亦无得　　长无偈有
  本性圆满故　　四讽结牒问曰
  菩萨于此中　　能发菩提心　　长隐偈显
  末世诸众生　　修此免邪见

大方广圆觉修多罗了义经略疏注卷上(之一)大方广圆觉修多罗了义经略疏卷上二

        唐终南山草堂寺沙门宗密述

自下大段。第二令依解修行随根证入。谓创因法镜照心。顿能信解。至于长久修证。则节级不同。良以障有浅深根有利钝。习气厚薄心行依违故须处处随根引令得出。然其修证阶降虽殊。必籍本因。故云依解。前则信解。此则行证故华严一部亦唯此四矣。文中二。初征释用心。后广明行相。所以然者。以悟修之理一异难明意实相符言而似反。故须征释令解用心。然后随性随缘。广为明其行相。今初征释文中大科四段不异初门。申请中三亦同前列。今初进问威仪

于是普贤菩萨在大众中。即从座起。顶礼佛足右绕三匝。长跪叉手而白佛言　普贤是行中之体故。标首为下所依总别观门不离此故。二圣表法已具前文。次正陈中文四。一就当根征起

大悲世尊。愿为此会诸菩萨众。及为末世一切众生修大乘者。闻此圆觉清净境界。云何修行　信解圆觉即是当根。虽达天真未明缘起。大士悲悯接下垂方。反覆征问用心解行如何契合。二问解行相违。于中复二。一幻幻何修问

世尊。若彼众生　指前当根

知如幻者身心亦幻(解也)云何以幻还修于幻　行也。谓一切如幻正解方成。幻法非真复何修习。故解与行进退相违。征释用心实由斯矣。此问从前知是空华即无轮转等文而来。意云。身心既如幻。能知亦是幻。将幻还除幻。幻幻何穷尽幻者谓世有幻法。依草木等幻作人畜。宛似往来动作之相。须臾法谢还成草木。然诸经教幻喻偏多。良以五天此术颇众。见闻既审法理易明。及传此方翻成难晓。今依古师解华严如幻之文。法喻各开五法。喻中五者。如结一巾幻作。一马。一所依巾。二幻师术法。三所幻马。四马有即无。五痴执为马。法中五者。一真性。二心识。三依他起。四我法即空。五迷执我法。下诸幻喻皆仿此知。二断灭谁修问

若诸幻性一切尽灭则无有心。谁为修行。云何复说修行如幻　此问亦从前拂迹中来。谓若以幻故一切皆空。能所总无。遣谁修习。云何复说修行如幻。金刚三昧亦云。众生之心性本空寂。空寂之心体无色相。云何修习得本空心。三遮不修之失

若诸众生本不修行。于生死中常居幻化。曾不了知如幻境界。令妄想心云何解脱　意恐惑者又云。一切如幻无不是空。觉性无生本来清净。知之即已何有修行。故此遮云。本空本不修。多生生死苦。今空今不修。云何则脱苦。不了如幻境界者。未达缘起事相也。从来不达事妄想不解脱。今还不了知。如何得解脱。溺斯意者近代尤多。但恃天真不观力用。四请修之方便

愿为末世一切众生。作何方便渐次修习。令诸众生永离诸幻　上。遮不修之失。已知决定应修故。问对治之门。如何永离诸幻。论云。若人唯。念真如。不以方便种种熏修。终无得净。对于暂离故言永离。谓初观一体虽觉全真。后遇八风纷然起妄。行如穷子。解似电光。何法修治。永除病本。然经云。一切众生作何方便。两句之间文意断绝。译之太略。应添分别演说等言。意则连续。达者详焉。后亦频尔。此下三唱经文。仿前科段

作是语已。五体投地。如是三请终而复始。尔时世尊告普贤菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。修习菩萨如幻三昧　此云正受。由达身心如幻。则冥本觉真如。如镜受影非受非拒。故名正受

方便渐次令诸众生得离诸幻。汝今谛听。当为汝说。时普贤菩萨奉教欢喜。及诸大众默然而听　正说长行中四。一标幻从觉生以为义本。二明幻尽觉满。以释前疑。三令离幻显觉。正示用心。四辨幻觉不俱。结酬其请。今初第一云义本者。以普贤但征修幻。不问幻之所生。佛说生于觉心。未为正答所问。且要标之为本。凭之显幻尽觉圆。故得修幻义成。幻尽元非断灭。故论云。自性清净心因无明风动。乃至无明灭智性不坏。如风止动灭湿性不坏等

善男子。一切众生种种幻化　有漏五蕴十二处十八界等。偈云。幻无明故

皆生　诸有漏法皆从性净真心而生也。依真起妄故

如来　此心虽凡圣同依。唯佛圆证故。约佛标之

圆　离相故

觉　非空故

妙　染而不染故

心　中实神解故。梵云干栗驮。是坚实之心也。不同缘虑集起之义。言皆生者。本觉心体为因。根本不觉为缘生三细业识为因境界为缘生六粗。故楞伽云。大慧。不思议熏不思议变是现识因。取种种尘。及无始妄想熏。是分别事识因。是知诸法皆无自体。无自体故。必假所依。依圆觉心而生起也。如幻马无体必依于巾。巾喻真心。马即蕴界。配前五法本末应知。问既真能生妄。真是妄源。何故前云无明无体。答妄托真起说真为源。现且迷真真本无妄。如二月托本月而起。说本月为起二之依。本月实无二轮。即是二无其体。故经说种种生于觉心。不是心生种种。然诸经论俱说万法一心三界唯识。宗途有异。学者罕知。今约五教略彰其别。一愚法声闻教。假说一心。谓实有外境。但由心造业之所感故。二大乘权教。明异熟赖耶名为一心。遮无境故。三大乘实教。说如来藏以为一心。理无二故。四一乘顿教。泯绝染净但是一心。破诸数故。五一乘圆教。总该万有即是一心。理事本末无别异故。此上五教后后转深。后必收前。前不摄后。然皆说一心。有斯异者。盖以经随机说论逐经通。人随论执。致令末代固守浅权。今本末会通。令五门皆显诠旨。相对复为三门。初约所诠。逆次顺法从四至一展转起末。谓本唯非染非净。一法界心。由不觉之名。如来藏与生灭合成阿梨耶识。复由执此为我法故。转起余七成八种识。各由识体起能见分。由能见故似外境现。执取此现为定实故。造种种别业共业。故内感自身。外感器界一切诸法。二约能诠。顺文逆法从一至四展转穷本。谓佛对下劣根性未能顿达万法所起根本者。且言从业所感。此则初声闻教。次为机稍胜者。说能所感。一切唯识展转乃至唯一真心名顿教等。皆由根有胜劣故。令说有浅深。若执前前即迷后后。始终通会方尽其源。三能诠所诠逆顺本末皆无障碍。由称法性直谭不逐机宜异说故。即圆教也。唯心之义经论所宗。迷之则触向面墙。解之则万法临镜。况此标为义本。如何不尽源流。达者审之。勿嫌具列。此下第二明幻尽觉满。以释前疑。然上说幻从觉生。染缘起也。此明幻尽觉满。净缘起也。故论云。有四种法薰习义故。染法净法起不断绝。染法者。以依真如法故有于无明。无明熏习真如故则有妄心。妄心熏习无明。不了真如法故。不觉念起现妄境界。妄境界染法缘故。即熏习妄心。令其念着造种种业。受于一切身心等苦。故胜鬘云。不染而染。法身不增不减经云。法身流转五道。名曰众生。华严云。心如工画师等。净缘起者。论云。以有真如法故。熏习无明。则令妄心厌生死苦乐求涅槃。以厌求故。即熏习真如。自信已信知心妄动无前境界。修远离法。种种方便起随顺行。不取不念。乃至久远熏习力故。无明则灭。无明灭故心无有起。境界随灭。心相皆尽。名得涅槃成自然业。然净缘起翻前染缘。缘无自性。染净俱融合法界性。起唯性起故无断尽。如华严说。依此方名幻尽觉满。文中分三。一举喻该释前文。二法合唯谭本义。三兼拂同幻之觉。今初

犹如。空华从空而有　喻前义本。谓空中毕竟实无起灭。但以眼翳空里见华。既翳时华依空现故。言从空而有。如圆觉妙性毕境无生但以心迷性中见妄。既迷时妄依觉现故。言生于觉也

幻华虽灭空性不坏　正喻此段释疑之文。谓翳差则见华灭于空中。华虽灭而空常在。然华生时不生。灭时不灭。有翳有差见生见灭。二法合唯谭本义

众生幻心还依幻灭　谓此幻心由智了达方得除灭。所了是幻能了亦幻。则前疑云幻幻何修。今答意云。不妨以幻除幻。又前云。幻尽断灭。次下答云

诸幻尽灭觉心不动　此乃能所双亡即契圆觉。其犹波因水起波灭水存。幻从觉生幻灭觉满。三兼拂同幻之觉。拂有三重

依幻。说觉亦名为幻　拂觉妄之觉也。对缘而起故亦是幻

若说有觉犹未离幻　恐修习者作是念言。对妄之觉则名为幻。不对妄者本有之觉则非虚幻。若起此心起则如幻

说无觉者。亦复如是　若谓二觉俱无即名真者。此意居然如幻。举要而言。起心动念言妄言真无非幻也。相蹑起念。势极三重

是故幻灭名为不动　若泯绝无寄。分别不生。圆觉真心自然显现。元无幻化。故言不动。三令离幻显觉。正示用心。即答前请问修习之意也。前不疑合修不修。但于修中疑用心违妨一向但请如何修行离幻。兼已自遮不修之失。故前段释疑了。此段正示用心。后段即会通。方便渐次之语。既令离幻修行。便已通得不修之失疑也。故无别答之文。文中三。谓法喻合。法中二。初展转离幻

善男子。一切菩萨及末世众生　标指当机

应当　诫劝之辞也。展转四重

远离一切幻化虚妄境界　一离诸幻境

由坚执持远离心故。心如幻者亦复远离　二离离幻之心。言如幻者。简非幻心

远离为幻亦复远离　三遣离幻之离

离远离幻亦复远离　四遣离离之离。亦可一离妄二离觉三遣离四遣遣。皆言远离者有二。一止二观。止离者。休心息意水不追攀。如人遇怨不应共处。观离者。虚妄之法体性皆空。如梦枷锁寤则已离。故下文云知幻即离。后密显真觉

得无所离即除诸幻　梦中见梦。转转觉于前非。直到寤时所见方实。故云尔也。无所离者。有其二意。一则冥于真觉。真觉则不可离。二则到真觉之中。自然无如上节节之幻可离故。荷泽云。妄起即觉。妄灭觉灭。觉妄俱灭即是真如。二喻

譬如钻火两木相因火出。木尽灰飞烟灭　如有一段干木。以一木燧钻之火出。还将却烧二木。木火既尽烟自然灭。既成灰烬任运飞散。不同二木形质为碍。如次四节以配于法。木段喻所修幻妄。木燧喻能修幻智。烟喻离。灰喻遣。经文先云灰飞。译之倒也。定合是烟先灭余灰飞散。喻中阙于显觉。盖文略尔。前法后合悉。皆具有。若欲具之。应以地唯圆觉。由前木等本从地出。烧灭总尽唯有地存。如种种幻化生于圆觉妙心。幻化数重遣尽圆觉元来不动。二合

以幻修幻亦复如是。诸幻虽尽不入断灭　上三句正合喻之现文。下一句兼前密显真觉。四辨幻觉不俱结酬其请

善男子。知幻即离不作方便。离幻即觉亦无渐次　前云作何方便渐次修习。令诸众生永离诸幻。故佛示用心竟。结答不作方便亦无渐次。如是乃能永离诸幻。会通问中之文也。但能知之是幻己名为离。但得离幻即元是觉。更无阶级渐变为觉。如人梦见身疮问医求药。寤来既知是梦。更欲作何方便。若待方便修之渐离。即是实法。何幻名化。若执实有还是妄计。何名修行。故云尔

一切菩萨及末世众生。依此修行。如是乃能永离诸幻　结成真离。亦是通结前用心之文。第二偈讽中四段。依次重讽长行。科文全同。不烦重写

尔时世尊欲重宣此义。而说偈言　且标举也。下文仿此

  普贤汝当知　　一切诸众生　　无始幻无明
  皆从诸如来　　圆觉心建立

标指生。无明之言长无偈有

  犹如虚空华　　依空而有相　　空华若复灭
  虚空本不动　　幻从诸觉生　　幻灭觉圆满
  觉心不动故

展转拂迹长有偈无

  若彼诸菩萨　　及末世众生　　常应远离幻
  诸幻悉皆离　　如木中生火　　木尽火还灭

长离偈合。又法合及密显真觉。长有偈无

  觉则无渐次　　方便亦如是

其结酬之文长有偈无。征释用心竟

自下大文。第二广明行相。有九问答。类束为三。初四问答通明观行。上根修证。次四问答别明观行。中根修证。后一问答道场加行。下根修证。然此三门前前不假后后。后后必蹑前前。初中四。一开示观门同佛。二征释迷悟始终。三深究轮回之根。四略分修证之位。就初门中文四文三皆同前也。今初进问威仪

于是普眼菩萨在大众中。即从座起。顶礼佛足右绕三匝。长跪叉手而白佛言　义亦同上。次陈词句中三。一举法请

大悲世尊。愿为此会诸菩萨众。及为末世一切众生。演说菩萨修行渐次　标请修行渐次者。由普贤所问幽深。如来称理而答。先欲消除心病。然后万行俱修。或有闻前说云知幻即离不作方便亦无渐次。谓言知之即已都不假修。普眼欲使教法圆足。请问起行之门。故佛令持戒宴坐恒作是念等。展转乃至观行成就也

云何　此下皆别列也

思惟　观察真妄即思慧也

云何住持　悟得妙境安住其中持之不失。即修慧也。下伫听佛说。生闻慧也。从凡入圣必假三慧。故普眼为众咨求。上皆问智也。此下问悲云

众生未悟。作何方便。普令开悟　此同法华。欲令众生开示悟入。以开摄示。以悟摄入。以开示约能化悟入约所化故。约今经者。此后佛答全用先所显示如来净圆觉心为本。以观人法二空。及灭影像。无边虚空觉所显发。觉圆明故显心清净。乃至等同诸佛。即是普令开悟也。二反显请

世尊。若彼众生无正方便及正思惟。闻佛如来说此三昧。心生迷闷。即于圆觉不能悟入　反明得闻佛说方便思惟即开悟也。言闻此三昧者。是前离幻法门也。故佛前云。汝能修习如幻三昧。三结牒请

愿兴慈悲。为我等辈及末世众生。假说方便　言假说者。以觉性本圆妄法本寂实无所修。但以初悟之人迷习难为顿息。是以请于无修之中假说修习方便。下三唱仿前

作是语已。五体投地。如是三请终而复始。尔时世尊告普眼菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨。及末世众生。问于如来修行渐次思惟住持。乃至假说种种方便。汝今谛听。当为汝说。时普眼菩萨奉教欢喜。及诸大众默然而听　第四正说。长行中四。一起行方便。二观行成就。三顿同佛境。四结牒问词。今初

善男子。彼新学菩萨及末世众生。欲求如来净圆觉心　标指当机

应当正念远离诸幻　指前征释离幻。以为起行之本。若执法定实。即观行不成。故须蹑前为方便矣正念者。则无念也。故智论云。有念是魔业。无念是法印。论云。离念相者等虚空界。又云。一切众生不名为觉。以从本已来念念相续未曾离念。故知无念是正念也。然正念与离幻反覆相成。由离幻故正念。正念故离幻。何以故。外存有法则内起缘念。内有缘念则外见有法。由此双指在诸行初。第二观行成就文二。初戒定

先依如来奢摩他行　奢摩他此云止。止是定义。下文释云。至静为行。定有浅深。故标如来简非粗浅邪小之定。若乱心持戒。不堪入此观门。故先定后戒。亦可文虽先后修无先后

坚持禁戒　一向绝缘的不拟犯。名曰坚持。防禁根门诫约身口。故名禁戒。戒品虽多统为三聚。一摄律仪。二摄善法。三摄众生。今意说律仪。义通余二。律仪戒者。谓十无尽。取要而言。即唯四重。此四清净则一切枝叶不生

安处徒众　即同行同见人也。行业既同。互相雕琢迭共商量。为长道缘。故须安处。故宝积经七十二云。得人身者。彼应依善知识听三世佛平等法。闻已应发勤精进。依城邑聚落。与大众共居具四部处。更互相疑论量佛法。学问难答。三世佛法平等得现在前。解一切法无有自性。修此解故烦恼渐除

宴坐静室　宴默也。坐为摄身。身住则心安。心闲则境寂。欲住身心故须静室。静室处众岂不相违。此有二释。一根性不同。故或多昏沉籍众策。发或多掉举宜自息。缘非为一人而行二事。二定慧等学故。谓圆通观行。要止观相资。须依善友。或同见同行终日议论法门。无令用心差错。差之毫厘失之千里。故净名云。不必是坐为宴坐也。虽同众住。不妨在自房室。初中后夜或除论法转读。便须静坐思惟闻思修慧圆明。岂但申申夭夭故无违也。此依定持戒处众静坐答住持问。二观慧文二。初明二空观。后明法界观。初二空者。众生旷劫漂沈。或堕邪小不成种智者。良由二障。一障不断由于二执。欲除二执必假二空。故于法界文前。先作二空观智。执亡障尽。即圣性现前应用尘沙。名之为佛。文中二。一破执。二显理。初中二。一我空。二法空。我空又二。一观身无我。二观心无我。夫计我者。既皆因五蕴。五蕴自相唯身与心。今且大段开之。然始别别分析。如此驰逐妄计何逃。若约身为总。则色心为别。今约我为总。故身心为别也。今初观身。身为诸爱根本。了之虚妄。则一切烦恼自除。如其耽着。则起无量过患。故净名因疾广说无常苦空无我。劝令患厌。涅槃喻以四蛇亦令舍离。金光明经智度论皆云背恩。文中二。初寻伺观。后如实观。先因寻求伺察。方见如实之理故。今初

恒作是念　行住坐卧一切时中。当如是观也

我今此身　执受既坚故遍观也

四大和合　坚湿暖动假和合也。故宝积经云。此身生时。与其父母四大种性。一类歌罗逻身。若唯地大无水界者。譬如有人握干糗灰终不和合。若唯水界无地界者。譬如油水无有坚实即便流散。若唯地水无火界者。譬如夏月阴处肉团无日光照即便烂坏。若唯地水火无风界者。则不增长。净名亦云。四大合故假名为身。四大无主身亦无我。故此经文还分四大各归来处

所谓发毛爪齿。皮肉筋骨。髓脑垢色。皆归于地　坚碍为地

唾涕脓血。津液涎沫。痰泪精气。大小便利。皆归于水　润湿为水

暖气归火　可知。然气是四大之本。不唯是风。故水火大中亦云气也

动转归风　净名云。是身无作风力所转。谓迷性起心。心运风力转余三大。而有动作。作无自性。故云无也。四大皆云归者。此身既合四大所成。今推身无主故还归四大

四大各离　正观之时各有所归。即名为离。不说命终方名为离。故庵提遮女了义经说生死义云。若能明知地水火风四缘毕竟未曾自得有所和合以为生义。若知地水火风毕竟不自得有所散是为死义。此意正明即合而散即散而合。故合散之文。皆为不自得

今者妄身当在何处　且地有形碍而沉滞。风无形碍而轻举。敌体相违。水火亦互相陵夺。故知四大相违各各差别。未审我身属于何大。若总相属。即是四我。若总不属。即应离四别有我身。故云尔也。后如实观

即知此身毕竟无体。和合为相。实同幻化　谓因前寻伺。见如实之理。定知四大非我。但约和合假名为身。亦无实体。智论十四问云。若自身无我而计我者。他身无我亦应计我。答亦有人。于他物中计我。如外道坐禅入地观时见地即是我。水火风空识亦如是。又如有人远行独宿空舍。夜见一鬼擎一死尸来。复有一鬼来争等。又秖缘计我而为自身。即以余身为他故生难也。后观心无我。夫心无自相。托境方生。境性本空。由心故现。根尘和合。似有缘心。内外推之。何是其体。长轮生死。由不了心。苟能了之圆觉自现。故首楞云。狂性自歇。歇即菩提。胜净妙明。不从人得。文中二。一寻伺观

四缘(四大)假合妄。有六根　四大和合成于一色。于此色上方有六根。离此色身根元无体。各分四大。色尚不存。窍穴六根更何依附

六根四大中外合成　四大为中。六根为外。内外和合假成此身

妄有缘气于中积聚。似有缘相假名为心　由依四大六根和合成身。即有六尘妄现。由此内外根尘。引起妄心缘虑不绝。念念生灭刹那不停。缘合即有。缘散即无。推其自体了不可得。故曰假名为心。此虚妄心虽假缘生。不离真心气分。故曰缘气。言似者。明非实有。缘相者。缘虑之相。后如实观

善男子。此虚妄心。若无六尘。则不能有。四大分解。无尘可得。于中缘(四缘)尘(六尘)各归散灭　心托六尘。尘依四大。四大无体六尘即空。故云散灭

毕竟无有缘心可见　缘尘既灭心体即空。故决判云。毕竟无有。言缘心者。则前缘气之心也。问无尘可得。下三句亦说法空。何得一向判属人空。答此指缘尘各散正显心空。故结云无心可见。身之与心总属我执。第二法空

善男子。彼之众生幻身灭故。幻心亦灭。幻心灭故。幻尘亦灭　前于身心之中推求无我。故名我空。此则身心及境一一自空。故名法空。然身等本空非今始灭。故经云。色即是空非色灭空。但以迷时执有。今执尽始无。义言灭也

幻尘灭故。幻灭亦灭　有遍计之情即见幻生。有观察之智即见幻灭。对幻生故则言幻灭。对情执故则言智慧。对待之法皆属缘生。缘生则无相。故皆云灭。般若心经云。无眼界乃至无智亦无得。楞伽云。一切法如幻远离于心识。智不得有无而兴大悲心。大文第二显理。即二空所显真如理也由前执尽故此理现。如云散月出尘尽镜明。非谓无云便名为月。但于无云之处而见月矣。非谓无幻便是真如。但于无幻之处见真理矣。文中二。初法

幻灭灭故(蹑前)非幻不灭　正显也。显圆觉性本净圆明独体全真不因修得。众幻虽灭自性常存不假缘生。故云非幻。金刚三昧经云若得空心心不幻化。然对前妄尽释云真如。若以本宗但名圆觉。后喻

譬如磨镜垢尽明现　虽云磨镜。却是磨尘。所言修道秖是遣妄。夫镜性本明非从外得。尘复则隐。磨之则显。隐显虽殊明性不异。今谓。人执法执是垢。寻伺如实是磨。真心本觉是明人法二空是现。自下大文第二明法界观也。文二。初印前显后。二拂迹入玄。二圆彰法界。初中谓印前二空显后圆通法界。文中又二。初标

善男子当知。身心皆为幻垢　此印前也。幻谓虚幻无有实体垢谓尘垢坌污为名。由迷幻相执取系着。坌污净心故云幻垢。诸佛菩萨虽有身心。由了如幻不取于相。无坌污义故非垢。由了幻空故非幻

垢相永灭十方清净　此显后也。根尘诸法十方法界普清净也。此由身心垢翳妄执自他故成局碍。今既我空法寂。何所不通。后释文二。初喻

善男子　由珠镜二事所喻不同。故复标告

譬如清净摩尼宝珠映于五色。随方各现。诸愚痴者见彼摩尼实有五色　谓摩尼体性莹净绝瑕都无色相。由性净故。一切色相对则现中。青黄赤白黑五色各各随方而现。然此一喻亦喻印前亦喻显后。言印前者。五色喻五道。随方喻随业。愚人不了珠体。但见全是青黄。既是青黄则不见珠体。故华严云。凡夫见诸法。但随诸相转。不了法无性。以是不见佛。若以三性配者。摩尼喻圆成实性。即前所显之理也。现色喻依他起性。即前幻也。愚人定见青黄。喻遍计所执性。即前尘垢也。若远即前身心等相。以此文印定前文之义。故指前也。言显后者然此圆珠由彼愚人执其定色。所以破色因配三性以印前文。然但无计执之人。即此珠种种之色一一清净一一同体。悉是圆珠妙用应现。无体可破。以喻后文十方法界一切清净圆满不动交参无碍。故言显后。然前之境喻但一面明。又云因磨而现。表二空之理破执方显。对执得名。今摩尼珠本净本明十方俱照。以显后法界之宗也。后法

善男子。圆觉净性现于身心。随类各应　即前种种幻化生于觉心也。义如彼释

彼愚痴者说净圆觉。实有如是身心自相　显圆觉虽现非其定实。故云愚说。论云。一切染法所不能染。智体不动。具足无漏熏众生故

亦复如是　合前喻也。余义喻中以具对释。详之可知。第二拂迹入玄

由此不能远于幻化。是故我说身心幻垢对离幻垢。说名菩萨　此上先说迹之所以然。其迹也相蹑而起。亦相蹑而拂本。以众生妄执幻化故。佛说云幻垢。众生依教离垢故。复说名菩萨。此下正拂其迹云

垢尽　幻垢如珠中之色。达之本无故云尽也

对除　所离之垢既无。对离之智何立

即无对垢及说名者　者字贯通两句。谓对垢者菩萨也。说名者佛也。既无对治之智。何有起智之人。深浅之执本无。何有说教之者。故俱无也。对机之佛亦不可得方见法身。法身说经义在斯矣。然上人法各三。三对六只尽是所拂之迹也。谓法有执垢离垢及与名数。人有众生菩萨及佛。问曰。人自有差法本无异。何说三名。答克体虽无。义说即有。为对人法各分能所故也。第三圆彰法界。文二。初一真法界。后三重法界。言一真者。未明理事不说有空。直指本觉灵源也。下对诸法圆泯圆收。方说三重等别。今初

善男子。此菩萨及末世众生　标告及指当根所证者。为欲进显不思议境界。境界殊前故。却蹑前功用明其得入。所以发起后之文势

证得诸幻　观行成就

灭影像故　依他亦泯

尔时便得无方清净　约身为主外见东西。我相既无更何方所

无边虚空觉所显发　然虚空离识亦非实有。故首楞云。若有一人发真归源。十方虚空一时销殒。谓迷情所覆觉处见空。尘影既销空元是觉。显谓空销觉现。发谓妄尽心开。翻覆观之俱无边际。首楞又云。闻复医根除。尘销觉圆净。净极光通达。寂照含虚空。却来观世间。犹如梦中事。是知空有双绝。但是觉心。独鉴明明灵知不昧。后三重法界者。一真空绝相观。二理事无碍观。三周遍含容观。此中义意全同华严法界观门三重行相。故依彼科之。今初第一真空观者。彼观门中有四句。谓会色归空观。明空即色观。上二皆简情显解三空色无碍观。解终趣行。四泯绝无寄观。行起解绝。今经文二。一色相空净。二空色同如。今初经文皆云清净者。谓由前二空观门简情显解。次拂迹灭影。同于行起解绝。故皆清净为真空矣。故智论云。毕竟空即是毕竟清净。清净与空皆绝相义。若就心说。即如净名经。妄想是垢。无妄想是净等。故云清净。文中七。一内身根识

觉圆明故　蹑前显清净之因也。由拂泯等故得圆明

显心清净　比迷觉心心中执法。今见法性法即皆空。故云清净。如人不识珠体但执青黄。若见摩尼即色清净。七段之中皆同此也。然展转蹑前以显清净者。义如后释。今且销释法数名体。心者总相明其我心。即赖耶体。成唯识论说第八识种种别名。于中有四种名。通一切位。心即一也。迷时由执藏及能所藏。故名赖耶。今观智成就觉性圆明。故但云心。没赖耶名矣。心既清净同无垢识。故此下文顿同佛境

心清净故　牒前也。下皆准前

见尘清净　下闻觉等例此皆云尘也。谓由我心计执故。见一切色相。由执相故即见等是尘。不单说外色等名尘。亦不独说根识名尘。根尘识三自有文故。寻此见尘等体。还是我执之心。但以就取相生过之处。而别立名。又亦不离根境识三而别有体。知五蕴之法与蕴中之我非别非同

见清净故　但牒见字不言尘者。足显即见是尘非外尘也。闻等亦然

眼根清净　下余五亦例此也。六皆名根者。识所依故。能发识故。前五各从自种生自现行。四大所造净色为体。意根即第七识。由此攀外起意识故

根清净故。眼识清净　下余五亦例此也。皆云识者。随六根境种类异故。由具五义随根立名。一依根之识。非由境色识定生故。如盲不见等二根所发。识由根变异识必变。异如眼根损见青为黄。非色坏时而识坏也。三属根之识。由识种子随逐于根而得生故。非色种子识种随也。四助根之识。由根合识。识所领受令根损益。非境界也。五如根之识。根识二法俱有情数。非彼色法定是有情。根五胜义故说依根。若依起信皆名意识。此六皆依意所起故。意之识故。故彼释生灭因缘云。所谓众生依心意意识转故。心即梨耶自体。意即五意。以梨耶二义中有不觉义故。不觉而起。能见能现能取境界起念相续。意识者。即此相续识。依诸凡夫取着转深。计我我所。种种妄执随事攀缘。分别六尘名为意识。亦名分离识。又复说云名分别事识

识清净故。闻尘清净。闻清净故。耳根清净。根清净故。耳识清净。识清净故。觉尘清净。如是乃至鼻舌身意亦复如是　上皆释竟。然八识中不言第七者。义当见闻等尘也。以七合第八。名见等尘。故瑜伽云。赖耶识起必二识相应。又七合第六。名见等尘。以意识缘外境时。必内依末那为染污根方得生起故。故上引论云。即依此相续识。乃至名为意识故。论及此经所列无别末那。楞伽亦尔。皆由第七计内为我合于转相。计外我所合于事识。若不连前带后。则显示心数相蹑生起。义不便故。二外境六尘

善男子。根清净故。色尘清净。色清净故。声尘清净。香味触法亦复如是　六皆名尘者。坌污心识故。约凡夫说也。亦云六境。此通凡圣。言色等者。眼等所取故。色有通别。今即别也。谓唯眼所取。有见有对变碍之相。最粗显故。声等可知。唯意所取法尘一境通于一切。三内外四大

善男子。六尘清净故。地大清净。地清净故。水大清净。火大风大亦复如是　即于根尘不取发识牵心之义。直取四大之体也。宝积经说四大各二。谓内及外。地界二者。内谓自他身内所有坚者。谓发毛等。外谓身外所有坚者。谓土木等。水界二者。身内润性泪汗等。身外润性雨露等。火界二者。身内热体热相能消饮食等。身外热体热相能成熟等。风界二者。身内风体风名速疾住四支等。身外风体动转等。四世间诸法

善男子。四大清净故(牒前)十二处　六根六尘是生识处。处是生门义故。亦名为人。意识常昏根尘相入故

十八界　六根门中根识尘三各有分界故。亦是因义。种族义故。前为六二。解者息于业因。此是六三。观之治于我执。兼之五蕴即具三科。大小乘宗无不约此以明诸义。前说妄认四大身心。及云中外合成等。即五蕴义。故此略之

二十五有清净　四洲四趣四禅四空无想净居梵王六欲为二十五有。此皆是有。各约实报非正智摄故。然梵王在初禅。无想净居在第四禅。四禅位中别举此者。梵王有见。外道无想。净居唯圣。异余天故。五出世诸法

彼清净故　想牒前世间诸法也

十力　然如来唯一诸法实相智力。此力有十种用故说为十。总名力者。能摧怨敌故。不可屈伏故。一知是处非处。谓总知一切诸法因缘果报。则降伏无因恶因。知人可度不可。二知过现未来善等三种业及顺现等三报。知所度有障无障。三知诸禅解脱三昧垢净。及知依此所得诸果。四知信等五根上中下。五知种种欲乐。令舍不净增净。六知一三五乘贪嗔痴等种种性欲。知即时异时谁可度不可等。七知一切道至处。八知宿住。九知死此生彼。即天眼智也。独此从所依得名。十知自解脱无疑。亦知众生漏尽涅槃。然佛力无量。度人因缘故但说十足辨其事

四无所畏　一正知一切法。谓佛诚言我是一切正智人等。二尽诸漏及习。言我漏尽等。三说一切障道法。四说出苦道。佛作诚言说此四法。决定无畏

四无碍智　智缘四境无拘碍故。一法。如说地水火风等。二义。如坚湿暖动等。三辞谓得彼方言以说地等。四于三种智中乐说。上依智论。若约华严则初二异此。谓一知自相。二知别相。又一知自性。二知生灭。又一法智。二比智。又一知一相。二知蕴界等。又一知一乘平等性。二知诸乘差别性。后二则同。谓辞则说于法义。乐说乃辞中别义

佛十八不共法　力等二乘有分。此无分故。一二三如次配身口念无失。四无异想。五无不定心。六无不知已舍。七欲。八精进。九念。十慧。十一解脱。十二解脱知见。上六皆云无减。十三四五一切身口意业随智慧行。十六七八以智慧知过未现在通达无碍。问无见顶相等亦无与共。云何不说。答此十八中但说智慧功德。不说自然果报法。上从力等。至此四科全依智论

三十七助道品　助谓资助。助正道故。道即是因。所谓止观。品即是类。正因类故。亦云菩提分。分亦因义。三十七者。谓四念处四正勤四神足五根五力七菩提分八正道分。然但以十法为体。谓精进定慧各八。念四。戒三。信二。轻安喜舍思惟各一。初四念者。一观身五种不净。谓种子住处自相自性究竟。二观三受皆苦。谓苦乐舍。三观心念念无常。四观诸法无我。此对治凡夫四倒也。又观身毕竟空。观受内外空。观心无所有。观法但有名。此对治二乘四倒也。四正勤者。四念处火。若得勤风则无所不烧。故次办之。精进为体故总名勤。异外道勤故名为正。虽是一勤。随义分四。一未生之恶遏令不生。二已生之恶断令不续。三未生善令生。四已生善令广。四神足者。欲勤心观。欲谓乐欲。勤谓无间。心谓定也。专一境性。观谓慧也内自拣择。以勤过散乱智火微弱故须定制。即所欲自在。神即神通。足即是定。由出世法最胜自在。欲等四定能证此故。名为神足。亦名如意足。所欲如心故。五根者。信进念定慧。此五通生出世间法。由前三科此不可拔故。前三至此总得名根。五力者。即前五根增长。魔梵等不能屈伏。又能损灭不信等障。故名为力。七觉者。谓念是所依支。由系念故。令诸善法皆不忘失。择法是自体支。觉自相故。精进是出离支。由此势力能到所到故。喜是利益支。由心勇悦身调适故。轻安定舍皆不染污支。能除粗重故。依定转依故。行舍平等永舍贪忧。故七皆云觉支也。虽一刹那七法俱起。而随行相各说功能。八正道者。谓正见是分别支。依前所证真实简择故。下七亦一一云正。思惟是诲示他支。如其所证方便安立。思惟名义发语言故。下三皆是令他信支。谓语者。善依所证问答决择。令他信有见清净故。业是身业。进止正行具足。令他信有戒清净故。命者。如法乞求依圣种住离五邪命。精进是净烦恼障支。由此永离一切结故。念是净随烦恼障支。由不忘失。正止举相。永不容受沉掉等故。定是能净最胜功德障支。由此引发神通等无量胜功德故。上之七类次第者。谓闻法已先当念持。次即勤修。勤故摄心调柔。柔故信等成根。根增为力。七觉分别。八正正行。总已喻显。法性如地。念处如种子。正勤为种植。神足如抽芽。五根如生根。五力如茎叶增长。开七觉华。结八正果

清净　通言力等皆清净也

如是乃至　超越多法。谓三身四智五眼六通地度果向缘谛处定等

八万四千　然法门广说无量无边。今齐此结数者。对治尘劳故。尘劳即有八万四千。一一对翻即皆净法故。染与净数无增减故。论云不觉念起见诸境界。故说无明乃至具有过恒沙等妄染之义。对此义故心性无动。即有过恒沙等诸净功德相义示现

陀罗尼　得总持菩萨。于一一法中。持一切法故

门　从一一法中。入一切法故

一切清净　总结也。问世出世法二相有殊。如何此经皆云清净。答前已说之。今复更释。谓若凡圣对治。即胜劣全殊。若称法界而观一种。总是幻化。皆从缘起无自体故。如有一镜现种种杂秽瓦砾。复有一镜现种种胜妙珍宝。痴孩不了贵贱悬殊。智者达之一无差异。观智圆明心识净者。亦复如是。见世出世若圣若凡。一切皆空。空是觉体。故下文云。见佛世界犹如空华。生死涅槃犹如昨梦。秖缘称理平等。所以名曰圣人如其重圣轻凡欣真厌妄。纵令修习。岂证真源。然上从觉圆明故。展转蹑前相由。以显世出世间诸法清净。至此五段历法备周。余六七两段。但是结通他身他界。更无别义。五段相由者。谓心本清净。由不觉故名赖耶识。相应于意复曰见尘。起于现行有根识境。中有能造故说四大。由是具足处界诸有有漏之法。对治此等有修有证。复成无漏因行果德。今既觉了圆明故。心意识及所变等展转清净。皮之不存毛无所附。然无漏法若约人修证。则先因后果。今据法本末。故先果后因。亦如论中根本灭故粗染随灭。六自他正报

善男子。一切实相　然凡所有相皆是虚妄。从缘生故。会缘入实即为实相。故智论云。照色等空即名为实相。性空实理离于颠倒非虚伪故于空见空亦名颠倒于空无著乃是实法。是实相者即是非相。是故如来说名实相。无迁无变究竟常住。无量义经云。如是无相不相不相无相是名实相

性清净故　此实相从本已来自性清净。一切妄法所不能染。比迷似染。今悟本净名性清净

一身清净　由前悟得根识尘大世出世间诸法皆归实相清净。方始成就此人。一身清净故诸段清净。皆牒前文。唯此独指实相。以为净之所以

一身清净故。多身清净　既于自身证实相理。亦见一切众生同一清净实相。以观一切众生不取于相同圆觉性故。志公云。以我身空诸法空。千品万类悉皆同。又下文云。圆觉普照寂灭无二。始知众生本来成佛

多身清净故。如是乃至十方众生圆觉清净　以般若正智遍观众生。菩提涅槃无漏智性本来具足也。此乃一人悟性。知一切众生本性清净。非谓一人修道多人成佛。七一多依报

善男子。一世界清净故。多世界清净。多世界清净故。如是乃至尽于虚空圆裹三世　国土净秽皆由自心。众生劫烧我土安隐。羸髻鹙子二相不同。案地宝严坐莲无异。况乃心冥觉性。识智无生。身土依真。染净俱泯。廓通法界。清净湛然。圆谓圆遍虚空。裹谓含裹三世。三世者竖极。虚空者横周也

一切　横竖总该

平等　本末味同

清净　都结七段

不动　冥于一如。然上七段悟时既相蹑清净。迷时亦相蹑垢染。应云。觉不明故令心不净。心不净故见尘不净。见尘不净故眼根不净。如是乃至一多世界不净。文势及义意对经可知。第二空色同如前之七段。即空色无碍。此当泯绝无寄。彼观云。动念即乖法体。反显法体本不动也

善男子。虚空如是平等不动　蹑前起后也。由前云尽于虚空平等清净。即知相尽同空。空既本无生灭动摇。当知诸法亦本不生亦不待灭。一一当体如如不动

当知觉性平等不动　然一切法唯依觉性生灭动转。诸法既尽虚空皆不动故。则觉性不动也。如波不起水则湛然不动。理齐故言平等。故法华云。是法住法位。世间相常住。法句经云。诸法从本来无是亦无非。是非相寂灭。本来无所动。然诸法与觉性平等。未名理事无碍法界者。夫理事无碍。要须多事全同一理而寂然。一理全成多事而迁变。即动即静即静即动。生灭广陜一切皆尔。翻覆无碍。今但一向不动。但是摄色等事同真空理。故唯名真空观

四大不动故。当知觉性平等不动。如是乃至八万四千陀罗尼门平等不动。当知觉性平等不动　还如前七段历诸法门。经恐文繁略标首末。义兼中间故云乃至。后段乃至之言亦例此知。第二理事无碍法界

善男子。觉性遍满清净不动。圆无际故。当知六根遍满法界。根遍满故。当知六尘遍满法界。尘遍满故。当知四大遍满法界。如是乃至陀罗尼门遍满法界　据法界观此有十门。一理遍于事。二事遍于理。三依理成事。四事能显理。五以理夺事。六事能隐理。七真理即事。八事法即理。九真理非事。十事法非理。今言遍满法界者。正是第二门行相。兼于余门义理。谓此即理之诸法与理不异故。一一自遍法界。不同前门没体摄归理中。故此名理事无碍也。既遍法界。即知动静无碍一一周遍。言觉性圆无际故当知六根遍满者。由前门已显六根等与觉性平等。平等者。即无分毫之异也。即与觉性不异。觉性圆无际故。当知六根亦圆无际。故遍满法界。若言不遍满即是有际。有际即与觉性成异。异则乖于前门。故蹑前云。圆无际故。故首楞云。性见觉明觉精明见。清净本然周遍法界。六尘已下皆例前知。第三周遍含容观。即事事无碍也。谓随举一尘即遍一切法中。又含一切法在自尘中。一尘既尔。一切法皆然。故云周遍含容

善男子。由彼妙觉性遍满故　举所依性。为事事遍满无碍之所由也

根性尘性　此是各指根尘自性。非谓泯根摄尘归于一性

无坏无杂。根尘无坏故。如是乃至陀罗尼门　谓根之与尘皆是事法。例前七段。事事皆然。故云乃至等也

无坏无杂　便就喻释

如百千灯光照一室。其光遍满无坏无杂　如一灯光已满一室。更有一灯。光亦全满。百千灯光一一如是。各不相坏。亦不浑杂。室中之空喻于法界。灯之光相喻以根尘。谓一灯光容多光相。即一光相遍多光中。一一皆然重重无尽。前七段事法一一例此可见。含容周遍斯之谓欤。所以然者。唯是真心所现。皆如幻梦影像故。与所依性非一非异故。故得遍多入一摄一容多等也。大文第三顿同佛境。于中三。一用心同。二见境同。三称实同。初中二。一法

善男子。觉成就故　总指圆彰法界已下之文。由斯故得同佛境界

当知菩萨不与法缚。不求法脱。不厌生死不爱涅槃。不敬持戒。不憎毁禁。不重久习。不轻初学。何以故。一切觉故　于四对法无胜劣心。如佛于三念之境。故言同也。同之所由。经自征释云。由一切觉故。故论云。所言觉义者。谓心体离念。今则离前与求厌爱敬憎重轻等八念也。举八境者。显于心也。喻云光无憎爱。后云修习此心故。二喻

譬如眼光晓了前境。其光圆满得无憎爱。何以故。光体无二无憎爱故　光即眼识现量所得。故无憎爱。首楞云。其目周视。但如镜中无别分析。汝识于中次第标指。云其目者。意取眼识。云汝识者。即是意识。亦可但随凡俗情见以目瞳为光。如法华云。梵王是众生父。二见境同

善男子。此菩萨及末世众生。修习此心得成就者　近结八境安心。远结观行成就

于此无修亦无成就　泯前心迹起后依正。凡圣平等之文。若不泯之。则虽无憎敬。尚见持毁等。故须泯之。方同佛见。自此已下正显其同

圆觉普照寂灭无二　由自心已空但是觉照。宁有凡圣差别之二焉。冥一如之无心。即万物之恒寂故。普照是用。寂灭是体。佛之所极极于寂照。故缨络经说等觉照寂妙觉寂照。今云同佛。是等觉义。故云普照寂灭。金光明经摄大乘论皆说佛果无别色声功德。唯如如及如如智独存。三种世间融无碍故。世界即器世间。众生即有情世间。成佛即智正觉世间也

于中　即于寂照中也。圆无际故

百千万亿　此方下数

阿僧祇　此云无数。是华严十大数中之首。经论多用故此举之。十者。谓阿僧祇。无量。无边。无等。不可数。不可称。不可思。不可量。不可说。不可说不可说也

不可说　大数第九

恒河沙　谓恒河中所有沙也。此河从阿耨池东面流出。初出象口周四十里。金沙混流。沙细如面。细故数多也

诸佛世界　上僧祇等算此世界之数也。谓有百千万亿僧祇等数之河。一一河中一沙为一界。以显世界如是多矣。然此中意者。直至尽虚空遍法界所有世界。不是算其数量。为欲引机造无边境故。假增积多数尔。然净秽等土皆佛统之。故云佛界

犹如空华　缘无自性全体即真。真性夺之无余。故得相皆虚幻。如前理夺事门中说。亦如善财求法。展转至摩耶等处。会缘入实得愿智幻解脱门。见一切世界皆如幻住

乱起乱灭　此有三意。一者一切世界皆依妄念。念既刹那不住。界亦起灭不停。二者华严云。染污众生住故。世界成染污。大福众生住故成染净。信解菩萨住故成净染等。三者成坏相也。然成住坏空。各虽二十增减。而世界无量无数故。总观起灭缤纷。问然佛化土许可如斯。自受用中如何起灭。答依实教所明。无形为净土。生公云。佛有形累托土以居。佛是常住法身。何须国土。故华严云依真而住非国土。此经云。入于大光明藏。余义已如前辨。问法华云。我此土安隐。天人常充满。复云何通。答彼据理即事门。此约理夺事门。二皆无碍

不即不离　明此世界不即圆觉亦不离圆觉。如华与空。如金与器。由不离故觉性。夺之成空华。由不即故。世界不妨有起灭

无缚无脱　文通上下。上则由世界无净秽故。下以众生本成佛故

始知众生本来成佛　始知即始觉。观行成就方能知故。本成即本觉。知与不知本是佛故。佛是究竟觉。始之与本非二觉故

生死涅槃犹如昨梦　亦无始觉之异。四相本来同一觉故。又寂灭无二。是自觉。世界及众生。是觉他。成佛二字及生涅如梦。是觉满。成就是满义故。动寂双亡方圆满故。然说生本成佛。唯是圆觉华严。余成义含不的指注。但以语惊凡听理越常情。佛既罕言。愚夫多谤。今详教理略举六门。一者小乘有部。唯悉达太子一生成佛。余皆无分。二者大乘始教。三无数劫行位满足方得成佛。三者终教。相尽性显名成正觉。四华严说。十信位满初发心住即成正觉。五者顿教。一念悟时即名为佛。六者圆教。本来成佛。故华严云。如来成正觉时。于其身中普见一切众生成正觉。乃至普见一切众生入涅槃。皆同一性。所谓无性。又云。菩萨摩诃萨应知自心念念常有佛成正觉。何以故。诸佛如来不离此心成正觉故。如自心一切众生心亦复如是。悉有如来成正觉。今经文者。若约观成方能知之。即当四五两门。若约所知。众生本来皆佛。则唯第六。三称实同。称法界真实性故

善男子。如昨梦故　蹑前也。由见生死涅槃如梦。即称圆觉实性同佛境也。此有二意。一但有能依之梦。必有所依之人。梦是人之神游。亦见闻之气分。无别体故。二但了梦体空无。即证自身真实。迷自身者。由执梦故。大梦之境必有大觉之明故。当知下有四节。初总明称实云

当知生死及与涅槃无起无灭　迷时生死无起涅槃无灭。悟时非灭却生死发起涅槃。称体而观都无起灭

无来无去　圣法非新来。凡心非灭去。又直言体。无起灭来去不约圣凡。二别指能所云

其所证者无得无失。无取无舍　所证之境非得真失妄舍粗取妙

其能证者无作无止。无任无灭　能证之心都无分别。离于四病。三双泯能所云

于此证中无能无所。毕竟无证。亦无证者　故华严云。若有见正觉解脱离诸漏不着一切世。彼非证道眼。四总结称实云

一切法性平等不坏　可知四结牒问辞

善男子。彼诸菩萨如是修行。如是渐次。如是思惟。如是住持。如是方便。如是开悟。求如是法亦不迷闷　可知偈中唯三。略于第一起行方便。故初讽观行成就二。余二如次全同长行

尔时世尊欲重宣此义。而说偈言　且标举也

  普眼汝当知　　一切诸众生
  身心皆如幻　　身相属四大
  心性归六尘　　四大体各离
  谁为和合者
  二空观也　　如是渐修行
  一切悉清净　　不动遍法界

法界观也长广偈略

  无作止任灭　　亦无能证者
  一切佛世界　　犹如虚空华
  三世悉平等　　毕竟无来去
  初发心菩萨　　及末世众生
  欲求入佛道　　应如是修习

第二征释迷悟始终文四初三今初

于是金刚藏菩萨在大众中。即从座起。顶礼佛足右绕三匝。长跪叉手而白佛言　可知。二正陈辞句中三。一庆其所悟

大悲世尊。善为一切诸菩萨众。宣扬如来圆觉清净大陀罗尼因地法行　此是一切行位根本。后必蹑前故重指也

渐次方便与诸众生开发蒙昧。在会法众承佛慈诲。幻翳朗然慧目清净　可知。二难其所疑

世尊。若诸众生本来成佛　蹑前段文为此疑本

何故复有一切无明　疑谓真能生妄

若诸无明众生本有。何因缘故。如来复说本来成佛　疑谓说妄为真

十方异生本成佛道。后起无明。一切如来何时复生一切烦恼　牒而纵之。责无穷过也。此上三难者。意云。本来是佛烦恼何生。若无生中妄生起者。如来成佛同本无生。无生之中还应妄起。成佛义等生否应齐。齐生即果佛何尊。齐否即因违现事。进退不可。故有斯云。三结请通释

惟愿不舍无遮大慈。为诸菩萨开秘密藏　据此三难诸典无文。唯佛了知登地方受。今乃请宣成教普示末世凡夫。故曰无遮。开秘密藏。秘谓非器不传。密谓覆相而说

及为末世一切众生　秘藏如不开柜。密藏则一法含多。今请不简末世则开秘藏。显了而谈则开密藏

得闻如是修多罗教了义法门　由此标于经目

永断疑　通论疑者。于诸谛理犹豫为性。能障信心善品为业。别显则五盖。中疑有三。一疑自。谓己不能入理。二疑师。谓彼不能善教。三疑法。谓于所学为令出离为不出离。如有病人疑自疑医疑药病终不愈。今三疑中即疑法也。此疑复有已起未起。今皆含之。刚藏为他请问令永断故。然断疑方便者。若疑境界令悟唯心。若疑法性令观无得。余皆例知

悔　悔是不定之法。悔善则恶。悔恶则善故。今请永断。即属恶也。然入道人若未通决生佛同异。则或用功多时反自疑悔。下三唱仿前

作是语已。五体投地。如是三请终而复始。尔时世尊告金刚藏菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨。及末世众生。问于如来甚深秘密究竟方便　秘密有二。一如来之密藏。谓一乘如来知见。佛于渐教门中久默斯要故。故云究竟方便。下答云妙觉圆照离于华翳等是也。二如来即秘密。由证密藏能所无二故。三业业具皆秘密也。身密谓非色现色。如摩尼等。语密于一言中演无边法海。如谷响等。意密无心成事等。二义之中经显所证矣

是诸菩萨最上教诲了义大乘。能使十方修学菩萨。及诸末世一切众生。得决定信　则顿同佛境。义当信根成就初发心住。今但通决疑难以成前义

永断疑悔。汝今谛听。当为汝说。时金刚藏菩萨奉教欢喜。及诸大众默然而听　第四正说长行四。一反覆起疑之本二喻释现起之疑。三显浅难造深。四结问不当理。初中又三。一总指轮回。二真随妄转。三结指前疑。今初

善男子。一切世界　总指情器也。无著金刚论以四蕴为世界故。若不约情何成轮回。次下六对办其轮回。谓但住有为即属轮回心也

始(创变)终(极证)生　新新而起

灭　念念落谢

前(过去)后(去来)有(住劫)无(空劫)聚(成劫)散(坏劫)起(现行)止(调伏)念念相续　情界器界皆依妄念。既所依不断故。能依亦然

循环往复　器界空已复成。情界灭已复生。惑业袭习报应纶轮。尘沙劫波莫之遏绝。上二句正示轮回之相

种种取舍皆是轮回　取谓取着。执我我所。舍谓厌离。厌苦所依。又于根身则厌苦粗障为舍。欣净妙离为取。于器界则厌此娑婆为舍。欣彼极乐为取。若取若舍种种不同。皆是颠倒妄心变现轮回之相。故论云。一切分别即分别自心。心不见心无相可得。首楞云。自心取自心。非幻成幻法。二真随妄转文三。一法

未出轮回而辨圆觉。彼圆觉性即同流转。若免轮回无有是处　能观是轮回之心故。所观圆觉亦尔。如梦见实物物亦是梦故。二喻

譬如动目能摇湛水　由目数动。湛水如波摇

又如定眼由回转火　次眼识迟钝。旋火成轮相

云驶月运舟行岸移。亦复如是　想之可见三合

善男子。诸旋未息　眼目云舟也。喻生死垢心

彼物先住尚不可得　水火月岸也。喻圆觉

何况轮转生死。垢心曾未清净。观佛圆觉而不旋复　正合也。三结指前疑

是故汝等便生三惑　即前三种疑也。据此结文的指。即知定是先责起疑之本末是答难。若是偏答三中之一难。即不合总结三惑。智者详焉。然虽非正答。已是标举建立答义之势。意令息如上之念。即前疑早合自亡。况复空华金矿分明晓喻。二喻释现起之疑文二。一空中华无起灭喻。二金中矿不重生喻。初中三。一喻释。二法合。三结成。今初曲分为二。初翳差华亡喻。后空不生华喻

善男子。譬如幻翳妄见空华。幻翳若除。不可说言此翳已灭。何时更起一切诸翳　谓不知华因翳有。妄执从空而生。不知迷真故妄生。横执真能生妄。既得翳差都不见华。闻说从翳而生。又执何时更翳。以喻比来迷倒妄见轮回。因闻普眼法门。了悟根尘清净。闻道因除迷心故得清净不是新得妙门。又执早晚更迷。犹如何时更翳。问翳差之者。或有他时更生。不必的定永无。如何以此为喻。答夫喻者。但取当日一席之事。不说终身。但以愚人晨。旦见华食时眼差。见华乱生乱灭。谓言翳亦速起速停。念念候之。故云不可。故诸经论喻释佛云如大梦觉。岂可难云睡起梦觉何妨明夜更睡还梦。若如是难岂识喻焉

何以故。翳华二法非相待故　翳不与华期。华不随翳生。但翳故妄见。非华实生。二法各不相知。况复一空一有。故云不相待也。纵使心迷生死亦寂。但缘迷故妄似死生。众生本自不生。幻华毕竟不起。莫将翳待。莫以迷求。刚藏问目正似此也。下空华喻云

亦如空华灭于空时。不可说言虚空何时更起空华。何以故。空本无华非起灭故　此喻前已含释。文易可知。二法合

生死涅槃同于起灭。妙觉圆照离于华翳　迷见生死似华起。悟得涅槃似华灭。言圆觉离华离翳。则双拂生死无明。虚空非暂有无。觉性何关迷悟。众生既如华起。约谁更难无明。无明生死既空。何责本来成佛。空华终不再起。果位何得还迷。由己计度不休。见他觉性流转。若如是解顿遣三疑。三疑钩锁连环。不是三科别答。下金矿喻即唯答佛不再迷。此疑过深。故重喻也。三结成

善男子。当知虚空非是暂有。亦非暂无。况复如来圆觉随顺。而为虚空平等本性　虚空世法尚不同华起灭。况如来随顺圆觉湛然真常是虚空之体性邪。觉为空性者。佛顶云。空生大觉中。又云。寂照含虚空。复言平等者。然圆觉虽是虚空之性。而冥合不分。周遍法界无分无限无别能依所依。故云平等。此意云。空在觉中空尚常寂。况觉为空性。岂增减耶。喻犹不及故云况复。后金矿喻

善男子。如销金矿。金非销有　金在矿中销矿金现。非销始有。若因销有。销顽石等亦应得金。故知虽假炉冶销镕。金性要须本有既已成金。不重为矿

经无穷时金性不坏　此明在矿则隐出矿则显隐显虽殊金性本来平等

不应说言本非成就　释成金性本有也

如来圆觉亦复如是　法合也矿喻烦恼。金喻觉性。炼出洁净即有晶光。及能随匠随模。作佛等像或种种器。喻佛三身也。然此一喻唯答佛不再迷之难。前就圆悟之理生佛俱是本真。以成普眼段中众生本来成佛之义故举空华元来不起非后始灭。法合云。生死涅槃同于起灭。所以俱通三难。今就不坏因果之相。故说销矿出金。华则始终本无。矿则因销始尽。意云。圆顿之理虽齐。迷悟不妨成异。既有多生习障。还须背习显真。真显则究竟清净。若但用前喻。即拨无迷悟因果之相。便成邪见若但用此喻。即成众生觉性本来不净。失真常理。亦成邪见。道理微妙一喻难齐。故说两事。是知此喻唯答第三难也。三显浅难造深文二。初所造离念

善男子。一切如来妙圆觉心　先标觉心为宗。后方拂迹者。明非断灭。但离所拂非无觉心。拂有三节

本无菩提及与涅槃　拂转依之名也。由转烦恼生死故曰菩提涅槃。体虽即真名因妄得

亦无成佛及不成佛。无妄轮回及非轮回　此。两节皆双拂对待。圆觉性中都无。此事若有少见则迷圆觉。故华严云。于法若有见此则未为见。若无有见者如是乃见佛。二能造带情文四。一举胜彰劣。二举喻显情。二诫息妄心。四重彰妄义。今初文有两对。初小圣理智对

善男子。但诸声闻所圆境界。身心语言皆悉断灭　沈空滞寂灰身灭智

终不能至彼之亲证所现涅槃　若未入灭即有余涅槃。若已入灭即无余涅槃。下第二凡心真觉对

何况能以有思惟心　种种计度

测度如来圆觉境界　此上两对意云。小圣真智尚不能亲到小圣之理。况凡心劣于前智。真觉又超前理。转转悬隔何能造耶。如百寮尚畏宰相百姓岂亲天子。此正同金刚经四果之人尚无心言我证得四果岂。如来有定法得阿耨菩提耶。二举喻显情

如取萤火烧须弥山。终不能着　举喻也。此下显情

以轮回心生轮回见。入于如来大寂灭海。终不能至　即知前举胜此举喻。并是显分别心不能证觉。密讥前三种翻覆疑难。前云有思惟心。即是此云以轮回心。前云圆觉境界。即是此云大寂灭海。可深照之。三诫息妄心

是故我说。一切菩萨及末世众生。先断无始轮回根本　指前未出轮回等文也若远指即文殊章先断无明。或指余经皆如是说。四重彰妄义文二。一无实体

善男子。有作思惟从有心起　举能起之根识有。心者识也。起者心所也

皆是六尘妄想缘气　举能牵之尘境

非实心体　实心无念故

已如空华。用此思惟辨于佛境。犹如空华复结空果。展转妄想无有是处　纵实有思惟。思惟尚不能证觉。何况此心早已如于空华。自无其体。向上更欲求证。何异空华结果。故言展转妄想。二无胜用

善男子。虚妄浮心多诸巧见。不能成就圆觉方便　从第一核疑之本。兼此第三一段。大意总是责问者滞情分别过患。所以其中此节最亲。因前三番之疑便都指但是浮心巧见总不能证觉。四结问不当理

如是分别非为正问　乍看连次之经。即似唯结巧见之文。细详其义乃都结第三一段。问前赞善哉。此责非正。何也。答前赞者美其起教。此责者显其实理。此一段疑最障修证。若不征起。末世长迷征有斯益。故前赞也。刚藏所征意在佛责。故知责此之过。始彰征起有功。乍看似前后乖违。细详乃始终符合。可审玩味。妙在斯焉。偈中四段。前三全同长行。后二句全别

尔时世尊欲重宣此义。而说偈言

  金刚藏当知　　如来寂灭性
  未曾有终始　　若以轮回心
  思惟即旋复　　但至轮回际
  不能入佛海

长行先举妄相。偈文先标实性

  如销金矿　　金非销故有
  虽复本来金　　终以销成就
  一成真金体　　不复重为矿

略不颂空华。影在后段故

  生死与涅槃　　凡夫及诸佛
  同为空华相

所造离念良由长行华无起灭。喻中结文与此段同。故此亦取空华之喻。意该前后

  思惟犹幻化　　何况诘虚妄

能造带情

  若能了此心　　然后求圆觉

此第四一段是依解起行也。与长行第四互有互无

大方广圆觉修多罗了义经略疏注卷上二大方广圆觉修多罗了义经略疏注卷下(一)

        终南山草堂寺沙门宗密述

第三深究。轮回之根者。谓穷其展转根元。推其差别种性故。于中文四。初三。今初

于是弥勒菩萨在大众中。即从座起。顶礼佛足右绕三匝。长跪叉手而白佛言　同上。次正陈辞句文二。初庆前

大悲世尊。广为菩萨开秘密藏。令诸大众深悟轮回　因舟行岸移等喻。悟得真随妄转

分别邪正。能施末世一切众生无畏(决定)道眼　五眼之中即慧眼法眼。具真俗故

于大涅槃生决定信　永不信余。首楞云。妙信常住一切妄想灭尽无余

无复重随轮转境界起循环见　不执月运岸移等。二请后文二三举法问。二结益请。初中二。一问断轮回

世尊。若诸菩萨及末世众生。欲游如来大寂灭　大般涅槃

海　具足三德能建大义。体深用广故如海也

云何当断轮回根本　因前章云。先断无始轮回根本。故今问断之方

于诸轮回　前云种种取舍皆是轮回。故此云诸

有几种性　既一切皆是轮回之相。未审有几种性。二问修悲智

修佛菩提几等差别　法门无边誓愿学故。即从假入空成大智

回入尘劳。当设几种教化方便度诸众生　众生无边誓愿度故。即从空入假成大悲。惑病既多方药非一。若无方便少汤添水。恐落爱见大悲。故须问也。一结益请

惟愿不舍救世大悲。令诸修行一切菩萨。及末世众生。慧目　即能照也

肃清　缘尘不杂

照耀心镜　即所照也。心净如镜故。六祖偈云。心如净明镜。身如明镜台

圆悟如来无上知见　无能无所自在圆明故。即同法华双开菩提涅槃是无上义。下三唱仿前

作是语已。五体投地。如是三请终而复始。尔时世尊告弥勒菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。请问如来深奥秘密微妙之义　本清净之轮回。无差别之种类等故

令诸菩萨洁清慧目。及令一切末世众生。永断轮回心悟实相。具无生忍　真性无生本来清净。众生未悟。妄心见生。生即必灭。故是轮回。今悟实相了心无生。心既不生轮回永绝。如是忍可名无生忍。上皆赞也

汝今谛听。当为汝说(许也)时弥勒菩萨奉教欢喜。及诸大众默然而听　次下正说长行中二。一答断轮回。二答修悲智。前中二。一推本末令断。二明种性令知。初中二。一示所断。二劝令断。初中四。一指爱为本。二欲助成因。三展转更依。四起诸业报。初中二初约贪欲以标指

善男子。一切众生从无始际。由有种种恩爱贪欲故有轮回　谓对所贪五欲。标指能贪之爱是轮回之本。首楞云。流爱为种纳想为胎。交遘发生吸引同业。以是因缘故有生死。又涅槃云。因爱生忧因爱生怖。若离贪爱何忧何怖。又佛名经云。有爱则生爱尽则灭。故知生死贪爱为本。先令断者。如树除根等。谓由于五欲引起爱心。能令众生生死不绝。言种种者。或天属之恩如父母等。或感事之恩如得惠赍等。或任运生爱。即自身及名利色味六亲等。或因敬成爱因恩成爱。或因爱结恩。恩之与爱应成四句。谓因非爱等。又所贪之境众多。故能贪之爱不一。然贪与爱亦有四句。谓贪非爱等。若对治简境则有顺有乖。若约妄简心则皆为过患。又唯就爱复有其三。一恶爱。谓禽荒色荒及名利等。二善爱。谓贪来报行施戒等。三法爱。谓乐著名义。及贪圣果而修行等。故下云。法爱不存心。渐次可成就。我身本不有。憎爱何由生。后约受生以结定

若诸世界一切种性。卵生胎生湿生化生。皆因淫欲而正性命。当知轮回爱为根本　卵等四生则受生差别。故瑜伽释众生云。思业为因。壳胎湿染为缘。五蕴初起为生。若以四生配六道者。天及地狱化生。鬼通胎化。谓鬼子及地行罗刹是胎。余皆化生。人畜各四。人具四者。毗舍佉母卵生三十二子。胎则常人。湿则柰女。化为劫初。畜具四者。金翅及龙。余兽皆胎。余鸟皆卵。然着地飞空若水若陆。微细蠢动或卵胎。或湿化。不可具分品类。皆因淫欲正性命者。淫谓耽染爱着。但是情染总得名淫。纵使化生亦依业染。但约欲界轻重者。俱舍云。六受欲。交抱执手笑视淫。四洲之人同四王界。余诸异类卵湿胎形。心染气传。难具分析。受性禀命莫不由之。既性命由淫。淫复由爱。故云爱为根本。二欲助成因

由有诸欲(境也)助发爱性　心也即爱之种子

是故能令生死相续　由外尘欲牵起爱心。亦由爱心贪着于欲。贪欲故造业。造业故受报。由此生死不断。故肇论云。众生所以久流转者。皆由着欲故也。若欲止于心。则无复生死。潜神玄默与虚空合其德。是名涅槃。三展转更依

欲因爱生命因欲有。众生爱命还依欲本。爱欲为因。爱命为果　欲谓贪淫。命谓身命。无爱欲则不生。无欲身则不有。当知欲因爱有。身因欲生。既有此身还生于爱。由爱身故还为欲因。复感未来生死果报。如是展转相续无穷。四起诸业报文中二。一别释。二总结。初中三。一恶业苦报

由于欲境起诸违　不可意

顺(可意)境。背爱心而生憎嫉。造种种业　由爱彼境。境不顺心便生热恼憎嫉。憎嫉故起嗔。嗔故杀害逼恼打骂凌辱。种种恶业从此便兴。亦可境称爱心而生耽着淫盗饮啖侵夺绮妄种种恶业。文无者略也。言种种者。十不善等

是故复生地狱饿鬼　三恶报也。无畜生者。取其文润成句。以二例知。亦可翻译传写脱漏。义必合有。故华严云。十不善业道。上者地狱因。中者畜生因。下者饿鬼因。二善业乐报

知欲可厌　知爱欲心是恶道因。于彼欲境深生厌离

爱厌业道　怖彼恶道不造恶因。于离恶法门深生爱乐

舍恶乐善　比由爱欲故造恶。今知欲可厌故。舍十恶乐十善也

复现天人　乐报也。华严云。十善业道。是人天受生因。判云乐报。粗相言之。若论人间八苦天上五衰地居斫截残害驱摈。岂能免苦。若于天鬼畜中。开出修罗即戒六道。三不动业报

又知诸爱可厌恶故弃爱乐舍还滋爱本　知其爱恶爱善俱未免苦。弃彼爱心乐修舍法。舍法即四禅八定。而不知乐舍之心还同彼爱。故云还滋爱本

便现有为增上善果　上二界殊胜依正二报也。由于欲界修得此定。各随其地而生彼天。二总结

皆轮回故　爱为根本故皆轮回

不成圣道　不了自心故非圣道。前指无明此标贪爱。发润备矣。然十恶业一向须除。十善八定则但除其病。第二劝断文三。初正劝

是故众生欲脱生死免诸轮回。先断贪欲及除爱渴　既知生死皆由贪爱故。欲脱生死先断此二。远公报应论云。夫事起必由其心。报应必由于事。是故自报以观事而事可变。举事以责心而心可反。渴者喻其至切。二通妨。恐有难云。若尔云何菩萨亦有贪爱故受生邪。故下通云

善男子。菩萨变化示现世间。非爱为本。但以慈悲令彼舍爱。假诸贪欲而入生死　菩萨示现受生。非爱为本。但以大悲益人为利。欲行教化。须现受生示同凡夫同事利物。故净名云。众生病则菩萨病。示现等者悲深也。非爱者智深也。三显益

若诸末世一切众生。能舍诸欲及除憎爱。永断轮回。勤求如来圆觉境界。于清净心便得开悟　先能除舍方可勤求。如出矿金始堪为器。故首楞云。如是贪欲。有名鬼伦。无名天趣。有无相倾起轮回性。有无二无无二亦灭。于佛菩提方可希冀。问从前但云贪爱。何故此云及除憎爱。答由爱身爱境。境违于情或身被恼。故生憎也。是知憎亦由爱。故虽兼憎意但说爱。二明种性令知者。谓由前说始终动静乃至思度佛境皆是轮回。故弥勒问其种性。意云。比闻余教只言五道轮回。今何得三乘行人亦未能免。故佛为说。由本贪欲显出五性。故属轮回。不以悟净圆觉为本因故。然菩萨性中修证行相。但除其病不除其法。余如广疏。文中二一总标因依

善男子。一切众生由本贪欲。发挥无明。显出五性差别不等　厌恶乐善。三乘教熏积习既深遂成别性。楞伽云。随说彼而成。皆名教熏起

依。二种障而现深浅　若遇邪师教者。则于人法二我极为坚执。名之为深。若遇二乘人说人空理。于法虽未离愚。于人已无坚执。对前为浅。若遇菩萨及佛。深浅相望可知。二别释差等文二。一所依。二障

云何二障　依起信释

一者理障碍正知见　根本无明也。不达法界性相。是碍正知见义故。故彼论云。是心从本已来自性清净。以不达一法界故。心不相应。忽然念起名为无明

二者事障续诸生死　六种染心也。三细乃至起业受报。是续生死义故。故彼论云。此清净心为无明所染。有其染心。染心义者。名烦恼碍等。广如彼说。二能依五性文三。一征

云何五性　此皆新熏。不同法相宗中本有之说。两宗五性义见悬谭。今此又与彼所引楞伽等文大同小异。如文详之。二释中二。一总明未熏

善男子。若此二障未得断灭名未成佛　本以发心修证约断二障。故成五性。此都不断故非五数。亦未发心遇教。故言未熏。若据楞伽之文。即当第五无性。二熏成五性文四。一二乘性合辨二也

若诸众生永舍贪欲。先除事障未断理障　知生死苦止息攀缘。故云除事。其实未能除三细也。意责不先悟理但先除事。故有先除未断之言

但能悟入声闻缘觉　障有事理。执有人法。今唯断于前。故云但能

未能显住菩萨境界　虽至长者之家。犹在后园除粪。止宿草庵未敢当堂。故云尔也。二菩萨性

善男子。若诸末世一切众生。欲泛如来大圆觉海。先当发愿勤断二障。二障已伏。即能悟入菩萨境界　此约地前以辨其相。故言已伏

若事理障已永断灭即入如来微妙圆觉满足菩提及大涅槃　此约入地乃至果位以辨其相。故言永断及菩提等。三不定性

善男子。一切众生皆证圆觉　定知身心本来具有。以已证知一切有情无不是觉。译经讹也。应云证诸众生皆有圆觉

逢善知识。依彼所作因地法行。尔时修习便有顿渐　觉性虽圆遇教不同。欣趣有异故

若遇如来无上菩提正修行路。根无大小皆成佛果　遇于胜教皆成。即明无别定性。反明不遇胜缘则随所闻成小。文无者略也。由此名不定性。故上标顿渐。四外道性

若诸众生虽求善友。遇邪见者未得正悟。是则名为外道种性　内心虽胜。宿遇邪宗既熏其心。积习成种。故于圣道难起信心。上明邪种也。下明师过云

邪师过谬非众生咎　意显此性定是新熏非自本有。故云非众生咎。前诸种性亦例此知。但文略也。则知众生本同觉性。但遇教成差有大有小有邪有正。故知发心之者。切须善辨宗途。然余经论目第五性云无性者。但明本来不觉染心相续。未有邪正师教所熏。无三乘种故闻亦不信。由此滥于本有。今云外道性者。决了新熏之义彰矣。三结

是名众生五性差别　二答修悲智。既识轮回之病用心。免落异宗。即须依解修行速求证入。然菩萨修行不出悲智二利。故须明之。前问中先智后悲。今答则先悲后智。意表即智之悲即悲之智无先无后。故互明之。文中二。初悲

善男子。菩萨唯以大悲方便。入诸世间　前问云。当设几种教化方便。今答意云。但以大悲方便示现种种形相。顺逆随时无定种数。言唯以大悲方便者。虽遇种种之机。唯用此二各随其类而应化也。但有大悲必能普化。但有方便必称根宜无其过累。故思益经云。众生行世间而不知世间。菩萨行世间明了世间相。世间虚空相。虚空亦无相。菩萨知如是。不染于世间

开发未悟　令知妄法本空真法本净

乃至示现种种形相　如观音随三十二类而应其身

逆顺境界　论云。或为眷属亲友。或为怨家。能令众生增长善根。若见若闻得利益故

与其同事　四摄中之一也意该余三。余三者。布施爱语利行

化令成佛　不取余乘。故法华云。我本立誓愿。欲令一切众。如我等无异

皆依无始清净愿力　菩萨因地之时必发度生之愿。乘此愿力所生之。处更不退转。心若疲倦即忆昔愿力。以自策励所为。不是随情故云皆依愿力。又非希望报恩。亦非爱见之悲。故言清净。云无始者。同体大悲称性大愿性本具之。非别新得但由迷悟有发不发。发即无始二智

若诸末世一切众生于大圆觉　此下正明大智上求菩提。对前大悲下化众生

起增上心　决定趣向

当发菩萨清净大愿　弥论诸行速至佛果若。无愿力则多退转

应作是言。愿我今者住佛圆觉。求善知识。莫值外道及与二乘　决定不趣余乘。不同前随五性。故言莫值等

依愿修行　亦是所为不随情逐念。但依愿力而自策励。如前悲中所说。愿是总相通悲通智。故二段中皆说愿力。具悲智愿即菩提心

渐断诸障　理虽顿悟其空。事乃渐除方尽

障尽　即下解脱

愿满　即下证大圆觉

便登解脱清净法殿　障尽则行住坐卧一切时中触向无非解脱故以清净法殿喻之

证大圆觉妙庄严域　愿满则触目对境。一切诸法无非圆觉。故以妙庄严域喻之。域谓强域。偈赞中二。全同长行

尔时世尊欲重宣此义而说偈言

  弥勒汝当知　　一切诸众生
  不得大解脱　　皆由贪欲故
  堕落于生死

示所断也。长离而广。此合而略

  若能断憎爱　　及与贪嗔痴
  不因差别性　　皆得成佛道
  二障永销灭　　求师得正悟
  随顺菩萨愿　　依止大涅槃

劝令断也此及明种性亦长离此合

  十方诸菩萨　　皆以大悲愿
  示现入生死　　现在修行者
  及末世众生　　勤断诸爱见
  便归大圆觉

上来究轮回之根竟

此下第四略分修证之位也。既显觉智之源。复究轮回之本。已知圆觉凡圣无殊。但未办随顺圆觉之心从凡至圣如何差别。故次明之。言略分者。三贤统为一位。十地等觉合之一门。修即修圆觉。证即证圆觉圆觉无差。约修智以明位地。文四。初三之初

于是清净慧菩萨在大众中。即从座起。顶礼佛足右绕三匝。长跪叉手而白佛言　同上。次陈辞句文中二。初庆前

大悲世尊。为我等辈广说如是不思议事　于一味净觉之中。说轮回本末种性差别杂染等法。而无乖失故不思议

本所不见。本所不闻　立相之教染净迢然。破相之宗染净俱绝。今显出觉性染净融通。故此之前未曾闻见

我等今者蒙佛善诱。身心泰然得大饶益　荡除细惑。二请后中文二。一正问

愿为诸来一切法众。重宣法王圆满觉性。一切众生及诸菩萨。如来世尊所证所得。云何差别　举所正觉性。问能证位地。觉心一味因果皆差。二义既乖故须起问。二结益

令末世众生闻此圣教。随顺开悟渐次能入　下三唱仿前

作是语已。五体投地。如是三请终而复始。尔时世尊告清净慧菩萨言。善哉善哉。善男子。汝等乃能为末世众生请问。如来渐次差别。汝今谛听。当为汝说。时清净慧菩萨奉教欢喜。及诸大众默然而听　正说中长行二。一明圆觉无。证二明对机说证。初中二。一法二喻法二。初正明无证。后征释所以。今初

善男子。圆觉自性非性　非前五性及贪爱等轮回差别之性

性有　前差别性皆有圆觉

循(循随)诸性起　圆觉不守自性。随缘遍诸差别之性。诸性起时全觉性起故法身。不增不减经云。法身流转五道。名曰众生

无取无证　非当情之境

于实相中。实无菩萨及诸众生　次下便自征释所以云

何以故　何以无菩萨众生

菩萨众生皆是幻化。幻化灭故无取证者　约有幻垢名曰众生。对离幻垢名为菩萨。故二皆空。然前轮回及此修证皆云无者。前似岸移。此如镜像。二喻

譬如眼根不自见眼。性自平等。无平等者　夫眼能见一切。唯不能自见眼根。又如眼光照瞩物时。境则万差见即是一。故云平等。但约于凡圣无分别胜劣之心。说平等义。亦无有能作平等之者。二对机说证文二。一总标大意。二证位阶差。前中二。今初功用有殊

众生迷倒　众生若无迷惑颠倒。则无差别之义。故先标此。约之以明证觉差别。迷倒之体即根本无明及三细六粗。论中亦约翻此。以显始觉阶位

未能除灭一切幻化　执之为实

于灭未灭　即论四位中前三觉前不觉后也。谓障习渐尽如一分尘尽一分镜明

妄功用中　七地已还皆是梦中修道。故华严有梦渡大河之喻。圆明证悟始知烦恼本无。则见能断智慧功用亦是虚妄。如梦中以药治病得差寤后则药病俱无。故言妄功用也

便显差别　正是总标位地。二功极不异

若得如来寂灭　诸佛同证此理故

随　与本相应

顺　无乖也非谓起心别求寂灭

实无寂灭及寂灭者　无能所也。意明心念。不生不见有寂灭之法。亦无能寂灭者灭之令寂。二证位阶差文中二。一明依位渐证。二明忘心顿证。初中四。一信位。二贤位。三圣位。四果位。此四即论中逆次约息除生住异灭四相粗细。寄显反流四位以明始觉分齐也。然心性离念本无生灭。良由无明迷自真体鼓动起念。能令心体生住异灭从细至粗微着不同先后际异。先际最微名为生相。中间二三名住异相。后际最粗名为灭相。今因本觉不思议熏力。起厌求心。又因真如所流闻熏教法熏于本觉。益性解力。损无明能。渐向心源。始息灭相终息生相。朗然大悟觉了心源。本无所动今无始静。平等平等无别始觉之异。大意如此。今以论意释之。初信位者。论寄息于灭相。经文分三。一标具足凡夫

善男子。一切众生从无始来　此初一段未入信位。所以有此文者。不约凡迷即无位地。故先标此翻之彰信。即论文翻四相成四位之谓也

由妄想我　我体元无妄想为有。四生九类无不皆然

及爱我者　执为我故便生爱着。上句我体即所执也。此句我见即能执也。具明我义下自有文

会不自知念念生灭　我体本无。唯心故有。心既念念无常。我亦念念生灭。故净名云。是身如电。念念不住故。论云。一切众生不名为觉。以从本来念念相续。故说无始无明

故起憎爱耽着五欲　迷执之过也。由执我故。顺我则爱违我则憎。故着五欲。二明闻法觉悟

若遇善友。教令开悟　即闻熏也

净圆觉性　即内熏也

发明起灭　慧照朗然显发心性。无始妄习一时悟现。如寤时觉梦然迷时即起灭。妄念是我。故妄念不自见于妄念。如眼不自见。今既开悟心冥真觉。不以妄念为我。故以冥真之慧。照于起灭之念。起之与灭念念皆知。翻前曾不自知念念生灭

即知此生性自劳虑　即此生灭之心。迷性之时性即起灭。妄念还自劳役心虑。千营万计念念不停。三明息妄随真

若复有人劳虑永断　绝求作之心

得法界净　若理法界。则法界体中绝诸劳虑尘境不生。名之为净。若事法界。则分别念虑之心差别尘境之法。十八界等当体不生。名之为净。何者。法界净秽皆由自心。心秽则秽。心净则净

即彼净解为自障碍　粗念既尽得少轻安。于彼净时心生爱着。于净起解名为净解。系心在净故成障碍。非外尘所扰。故言自碍

故于圆觉而不自在　结成信中证觉之相。作意于觉故不自在

此名凡夫随顺觉性　结成信位也。二贤位。论寄息成异相。文云觉于念异念无异相等

善男子。一切菩萨见解为碍　见前净解之碍也。是蹑前位以辨此位之相。即觉于念异也

虽断解碍　超前位也。言虽者。预显劣后。念无异相等

犹住见觉　正当此位

觉碍为碍而不自在　结成地前证觉之相劣于登地。所觉是碍故能觉亦碍。此则将碍除碍。故不自在

此名菩萨未入地者随顺觉性　结成贤位。三圣位。论寄息于住相。文云觉于念住念无住相。今文分三。一悟前非。二明证相。三结成位。今初

善男子有照　信中净解

有觉　贤位中觉碍之觉

俱名障碍　正显前非。即论中觉于念住。二明证相。谓以智证理理智冥符。如日合空。如珠自照。但是本觉显现。非能所故。文中二。一不住证。二不住教前中三。谓法喻合。今初

是故菩萨常觉不住照与照者。同时寂灭　能所契合也。故唯识见道偈云。若时于所缘。智都无所得。尔时住唯识。离二取相故。智无所得。则此常觉不住。常觉即是无分别智。不住即不取种种戏论相故。离二取相。即此照与照者寂灭。智与真如平等平等。俱离能取所取相故。彼文虽局于见道。而证理之义十地无殊。亦可不同凡夫。故云常觉。不同地前。故云不住。此则念无住相觉住相无故不住矣。次喻

譬如有人自断其首。首已断故无能断者　如把刀剑自断其头。头未落时即无能断之义。头若已落。复无能断之人。后合

则以碍心　觉碍之觉

自灭诸碍　所觉之碍

碍已落灭无灭碍者　如火出木尽烟灭灰飞。二不住教。谓地前未证真理难忘言教。登地证理不住名言。不住故名真解教。故华严初地文云得经论智。文中二。一标以喻释

修多罗教如标月指。若复见月了知所标毕竟非月　夫设言象在于得意。无言象而倒惑。执言象而迷真。故以标月之指喻于言教。谓见月须藉指端。悟心须假佛教。因指见月见月忘指。因教筌心悟心忘教。存指则失真月执教则失本心。意令证实忘标故。云毕竟非月。二具以法合

一切如来种种言说开示菩萨。亦复如是　此明诸佛同以言诠显理。故文殊般若云。总持无文字。文字显总持。三结成位

此名菩萨已入地者随顺觉性　论亦结云名随顺觉。四果位。论寄息于生相。文云。如菩萨地尽满足方便。一念相应。觉心初起心无初相。以远离微细念故。得见心性。心即常住名究竟觉。今文分三。一明境

善男子。一切障碍即究竟觉　总标也谓智明圆觉无分别心故。列十对法皆同真实。即论中见性常住等也。又若见有障可断。断已名觉。觉非究竟故障碍。即觉方究竟矣。障碍者。标每对中上句。究竟觉即标下句。十对者

得念失念无非解脱　一识智对。无念则得其正念。是智也。有念则为失念。是识也。故论中说。觉则离念念则不觉等。今明念本自空元是无念故皆解脱

成法破法皆名涅槃　二成破对。众缘相会曰成。缘离曰破。又进修曰成。毁谤为破。缘无自性成破一如。故皆涅槃

智慧愚痴通为般若　三愚智对。大宝积云。痴从分别生。分别亦非有。痴性与佛性。平等无差别

菩萨外道所成就法。同是菩提　四邪正对。思益云。住正道者不分别是邪是正

无明真如无异境界　五真妄对。涅槃云。无明本际性本解脱。古德云。迷则真如是妄想。悟则妄想是真如

诸戒定慧及淫怒痴。俱是梵行　六染净对。夫戒定慧翻于三毒。三毒本空元是梵行。诸法无行经云。贪欲即是道。恚痴亦复然。如是三事中。有无量佛道

众生国土同一法性　七依正对。涅槃云。我以佛眼遍观三界有情无情一切人法悉皆究竟。究竟者。即法性也

地狱天宫皆为净土　八苦乐对。极恶业成天宫即见地狱。极善业熟地狱即是天宫。二业之念由心。地狱天宫岂定。心既本空一切清净。故宝积经有地狱三昧天宫三昧。然诸法皆尔非唯天狱。今且约敌体相违之法。以例余

有性无性齐成佛道　九有性无性对。有性者。三乘性也。无性者。阐提性也。非为他日回心。现已齐成佛道

一切烦恼毕竟解脱　十缚解对。佛顶经云。根尘同源缚脱无二。识性虚妄犹如空华。然烦恼依识。识性既空烦恼何缚。上之十对名相虽异其意不殊。但缘佛证觉心心无取舍。故得诸法普同圆妙。故今但各引例而已。不更一一推求相即无碍之由。二明心

法界海慧　法界深广故如海也。慧则是用。称法界故名法界慧

照了诸相犹如虚空　理量齐鉴无倒正知。内分别心诸相差别。今海慧离念故诸相如空。又能照之慧离分别念。犹如虚空。即同净名其无碍慧无若干也。如镜照物镜自无心。上来皆是论中。满足方便一念相应觉心初起心无初相也。三结位

此名如来随顺觉性　二妄心顿证。前由普示教门。就机说有深浅。今恐存分别则悟入无期。故示圆顿安心。于觉成真随顺。前是随相。此当离相。亦如华严。先说差别位地因果。后以平等因果融之。即差别中之平等。平等中之差别。此中意趣正同彼也。文三。一忘心入觉。二验果知因。三印成佛智。初中二。一指示安心

善男子。但诸菩萨及末世众生　指示末世安心。文有四节。每节二句

居一切时不起妄念　妄念者。攀缘取着外法也。念则违觉。故令不起

于诸妄心亦不息灭　若求真舍妄。犹弃影劳形。若灭妄存真。似扬声止响

住妄想境不加了知　境从心现元是自心。若加了知即迷现量。故经说非幻成幻。论云。心不见心。但不生情自然如镜照物。且心体本自知觉。何必更加了知。知上起知名为加矣

于无了知不辨真实　能知既寂即真实知。真实即知。谁知真实。如眼不自见等。二依法顿入

彼诸众生闻是法门。信解受持不生惊畏。是则名为随顺觉性　彼当根众。若闻此方便心无疑惑。体达分明领受任持。则坦然合道。亦同金刚经中不惊不怖不畏甚为希有等。二验果知因

善男子。汝等当知。如是众生已曾供养百千万亿恒河沙诸佛及大菩萨。植众德本　悫云。验今闻悟顿契佛心。方达宿因。曩承熏习。若但就现世即是顿机。若推其因已是积习。金刚亦云不于一二佛等。三印成佛智

佛说是人。名为成就一切种智　谓一切种智由此而得。因果相摄决定无疑。是以如来印言成就。又此经宗分同华严因该果海果彻因源称性互收无别先后。彼云。若诸菩萨能与如是观行相应。于诸法中不生二解。即同此安心之文。即得阿耨菩提。同此一切种智。偈赞中三。初二全同长行。第三两句总结长行无也

尔时世尊欲重宣此义。而说偈言

  清净慧当知　　圆满菩提性
  无取亦无证　　无菩萨众生

上圆觉无证下对机说证

  觉与未觉时　　渐次有差别

上总标大意下证位阶差

  众生为解碍(信位)　　菩萨未离觉(贤位)
  入地永寂灭　　不住一切相(圣位)
  大觉悉圆满　　名为遍随顺(果位)
  末世诸众生　　心不生虚妄

忘心顿证

  佛说如是人　　现世即菩萨
  供养恒沙佛　　功德已圆满

印成佛智

  虽有多方便　　皆名随顺智

总结顿渐故云多方便。上来四段通明观行竟次四问答别明观行。中根修证言别明者。有其二意。一则由一类人已依前门证入不必修此。故此名别。二则此门各各自别。如三观或一人具三。或一或二单复交络成二十五种。各应一机故云别也。其所离障亦各不同。且如四相。或一人具四。或三二一。其四病者。人各有一定不兼余。以相违故。故此两四皆是别相。不同前无明及爱但是凡夫悉有故。前通此别矣。然通别观行中。皆与惑障同科段者。由是障观行之惑。惑除则成观行故。文二。初二问答三观修行。后三问答两重除障。初中二。初示三观行相。后明单复修习。初中文四。初三之初

于是威德自在菩萨在大众中。即从座起顶礼佛足。右绕三匝长跪叉手。而白佛言　同上。次陈辞句二。一庆前

大悲世尊。广为我等。分别如是随顺觉性　领前依位渐证

令诸菩萨觉心光明承佛圆音。不因修习而得善利　领前忘心顿证。暂闻已得善利。况勤而行之。二请后文二。一问所修。二明所为。初中二。一立理

世尊。譬如大城(圆觉)外有四门(行门)随方来者非止一路　如从东来不可西门而入

一切菩萨庄严佛国。及成菩提非一方便　法合可知。谓前说观行理趣分明。今复咨询。恐涉非分。故先立理请更投机。二正请

惟愿世尊。广为我等宣说一切方便渐次　所修之行

并修行人总有几种　能修之人。二明所为

令此会菩萨及末世众生。求大乘者速得开悟。游戏如来大寂灭海　下三唱仿前

作是语已。五体投地。如是三请终而复始。尔时世尊告威德自在菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。问于如来如是方便。汝今谛听。当为汝说。时威德自在菩萨奉教欢喜。及诸大众默然而听　次正说长行中四。一标本举数。二正示观门。三引例障圆。四校量显胜。初二。一约称性之行以标本

善男子。无上妙觉遍诸十方。出生如来　十方诸佛同证同修。证义如前。此问修矣

与一切法同体平等　色心不二凡圣无差皆依觉性。故同平等。智论云。在众生数中名为佛性。在非众生数中名为法性。上皆所称之性也

于诸修行实无有二　能称之行也。即如前二空观门。根尘普净贪爱俱寂。悲智双行离相离心常无所得。一切菩萨无不如斯。随事虽差此意无二故。二约随机之行以举数

方便随顺其数无量　然众生根性利钝不同。烦恼厚薄沉掉不等。随其根性设教多端。不尔难为趣入。故楞伽云。所说非所应。于彼为非说。彼彼诸病人。良医为处方。如来为众生。随心应量说

圆摄所归循(循随)性(根性)差别。当有三种　众生根性虽有万差。而此三门一切收尽。必须三者义如下释。二正示观门三。一泯相澄神观。二起幻销尘观。三绝待灵心观。然禅观纲领已具悬谭。修习菩提非此不证。但以教随机异展转诸途。邪正凡圣大小权实事理渐顿有共不共。今此托法进修。以成圆顿观行。即事理定慧俱无碍也。与论中修习真如三昧。体相大同小异。小异者。彼不开为三也。今初泯相文字有三。一标本

善男子。若诸菩萨悟净圆觉　谓发心修行欲趣佛果。先须了悟身中净圆觉性以为行本。本即解也。依解而修方为妙行。膏明相赖目足更。故下标本等皆同此矣。二三释三。一起行

以净觉心　约其所悟而起行也。以者用也。凡夫用妄。菩萨用觉。迷悟异故

取静为行　虽悟即动即静。为欲对治动乱之习。一向以静境安心。渐渐修行方得成就。不取于法为取静也。悫云。然觉心初建力尚尪微。理宜取静安详方能展照。论云。若修止者。住于静处端坐正意。不依气息形色虚空地水火风见闻觉知。乃至当知唯心无外境界。即复此心无自相等

由澄诸念觉识烦动　由前以静澄心诸念不起心合静源体非分别。故见分别之识烦劳动扰。苦自是识则不能见识。如眼不自见。今由念澄智显故觉识也。二功成

静慧发生　由前念澄觉识。慧性开明。因静生慧故云静慧。比隐今显故云发生

身心客尘从此永灭　由慧发生身心相尽尘妄不起。名为永灭。客非本性。尘污自体

便能内发寂静轻安　由离根境内心自闲。寂静清虚轻安调畅。喧尘永息粗重长袪。三感应

由寂静故。十方世界诸如来心于中显现　众生圆明性体与佛不殊。但以妄情凡圣似隔。今身心相尽妄念不生。圆觉妙心凡圣交彻。理实而言。我之身心亦遍现十方佛中。故先德云。黄昏戌。寂寞身心总无物。恒沙诸佛入我身。我身常入恒沙佛。今但约入观者为主。故云诸佛于中显现

如镜中像　如诸镜入一镜中诸镜即成影像故。诸佛心入行人观心。如影像也。然尘镜之性本明。磨莹即呈物像。众生自心亦尔。心静即现如来。故论问云。若诸佛有自然业。能现一切处利益众生者。云何世间多不能见。答曰。诸佛如来法身平等遍一切处。无有作意故说自然。但依众生心现。众生心者。犹如于镜。镜若有垢色像不现。如是众生心若有垢法身不现。经云佛心。论云法身。身心一也。皆据能现之本。若就所现应云应化。此约心静故。则知佛心亦然。故名为现。非谓佛心有所现也。此乃镜明则像像历然。智显则心心交映。故净名云。如自观身实相观佛亦然。三结名

此方便者。名奢摩他　此翻云止。定之异名。寂静义也。谓于染净等境心不妄缘故。若准涅槃经释。即名能灭能调寂静远离及能清等。结云以是义故名为定相。二起幻锁尘观文三。初标本

善男子。若诸菩萨悟净圆觉　同上。二正释中五。一起行

以净觉心知觉心性。及与根尘皆因。幻化　蹑前标解也。心性是识。识与根尘三和合有。各无自性。但是无明迷真而起。故名幻化

即起诸幻以除幻者　正明起行也。诸幻即幻智也。幻者。即根本无明是能幻之者。除幻者。依如幻始觉力。分觉根本不觉。始息灭相。终息生相。即是除幻

变化诸幻而开幻众　随机应化说法开示如幻众生也。若观心释者。变起差别幻智。遍观八万尘劳之众。一一称真清净非障非蔽。即为开也。二功成

由起幻故。便能内发大悲　根尘既消自他无二。故能内发同体大悲

轻安　由悲从定起。非其爱见故。轻安畅适。三结通

一切菩萨从此起行。渐次增进　明诸菩萨从此观门方能起于悲智乃至佛果。四简滥

彼观幻者。非同幻故　拂幻法也。简识殊智。能所胜劣异故

非同幻观皆是幻故　拂幻智也

幻相永离　五总结

是诸菩萨所圆妙行　结成非幻称真之行

如土长苗　如种谷等依土长苗收子之时苗土俱弃。种喻觉心。土喻幻法。苗喻幻智。谓悟净圆觉。依幻法而起幻智。从幻智而忘心入觉。入觉则前二皆袪。三结名

此方便者。名三摩钵提　亦名三摩钵底。此云等至。等持之中能至胜位故。又等谓齐等。离沉掉故。至谓至到。到胜定故。故前有如幻三昧。三绝待灵心观文三。初标本

善男子。若诸菩萨悟净圆觉　如上。正释中二。一起行

以净觉心　蹑其所依

不取幻化　离第二观

及诸净相　离第一观

了知身心皆为挂碍　有身有心悉皆是妄。了知是能身心是所。托所起能故二皆碍。此下明其所用。于中又三。谓法喻合

无知觉　即上所了身心也。谓身触为觉。心缘曰知。由此分别。障正知见

明　正显灵妙之体。然此灵心上而无顶下而无底。傍无边际。中无在处。既无当中。何有东西上下。欲言空寂不似太虚。欲言相用不从缘起。欲言知见异于分别。欲言顽碍异于木石。欲言其觉不同醒悟之初。欲言其明不同日月之类。故诸经教于寂静空无呵为邪小。于知见明觉互泯互存。各有深意。今此欲入观门。恐知字引分别念。故宜但云明也

不依诸碍　诸碍者。身心能所。不依者直造灵明

永得　究竟常然

超过　回殊对待

碍　前观幻涉于烦恼

无碍境　前取静同于涅槃

受用　属己资缘

世界　共居国邑

及与身　宛然形质

心　还有见闻

相在　不异寻常

尘域　不离旧处。此由执认没体。同他今不生情岂拘灵照

如器中锽声出于外　锽字不定。恐译人错。遂为三释。一依锽字音横。准切韵训和训乐。不是器中之声。今率愚详之。取其声势不取训字。此应是金石等中声相也。今且现闻击钟磬之类。其声锽锽然。即知锽是此类声之相状。译人回润稍拙。应云如今器声锽锽出外。二作鐄字音同。即大钟也。是诸器中之一数。故云如器中鐄。准此则顺本经文。回润非失。但笔受或写录。错误以鐄为锽尔。三者皆簧音黄。即笙簧之类。以有簧之器非一故。不局云笙中簧。乃云器中簧也。亦如管籥之属。皆能发声出于外故。准此则译人不善此方声韵文字。故字与音俱错尔。后正释喻者。前三虽异合法皆通。皆器喻世界身心。声喻灵明观智。谓声从器出。器不能拘。故声闻四远器局本处。以喻观智约身心修得。身心所不能拘。观智廓尔无边。身心不离旧处。但所喻相当何争喻所依物。悫云。如万钓之镛星楼受碍。摇杵一击声振寰区。自体兼他不能留碍。岂以楼拘钟相便响不通。形碍管声令音不透。观此文势未免怀疑。复不能决通。媕婀邈之而已。意亦同前。仍法合最具。谓加楼喻世界。余准上知

烦恼涅槃(如器)不相留碍　如锽二功成

便能内发寂灭　不取幻化幻化即寂。不取静相静相即灭。非故寂之灭之。又但是真心实理非对静幻。故楞伽云。寂灭者名为一心。此非息动之寂生已而灭。故云内发

轻安(同上)妙觉随顺寂灭境界　在观之时用心同佛。故随顺妙觉寂灭

自他身心所不能及　唯独自明了余。人所不见。故他不及。自己心识之量亦不能造。如萤烧须弥。必须离情方契。故自不及。又依体起智为自。根尘发识名他。不可识识智知。故皆不及

众生寿命皆为浮想　一切众生寿命。但为浮想任持。本无实体。故华严云。一切众生但想所持。其犹空云是空之浮气。了虚空者。即知浮云毕竟非空。众生寿命是真之浮想。了真寂者。即知众生毕竟非真。三结名

此方便者。名为禅那　此云静虑。即虑而静故无散动。即当定义。即静而虑故非无记。即当慧义。故四静虑定慧平等。问既是定慧平等。云何科云绝待灵心。答正由不滞此二直造心源。故定慧等。释相文中绝待之义甚明。固无疑矣。然释相中指修行者妄情用心。故显。双非绝待。后但约义以结。故取双是齐融。齐融绝待双是双非皆是中道故释相与结名互显三观文初皆标悟者。闻前经故。谓初静观修文殊中解。次幻观修普贤全普眼前半之解。后灵心观修普眼后半刚藏全章之解。对配前经昭然可见。然此三门与涅槃经三相大同小异。与天台三观则义理同而意趣异。同者。一泯相即空观也。二起幻即假观也。三绝待即中观也。异者。此明行人用心方便。彼则推穷诸法性相。此多约心成行。故不立所观之境。彼多约义生解。故对所观三谛。三引例彰圆

善男子。此三法门皆是圆觉。亲近随顺十方如来。因此成佛十方菩萨种种方便。一切同异皆依如是三种事业　此三门皆依悟净圆觉而起观行。观行亦皆趣入圆觉。始终不离故。云亲近随顺。佛及菩萨同证同修。随机随事行相各异。或多人同修一门。或一人具修多行。若三五若百千。同之与异随类难准。然必皆依此三种业。三种业中或具依三。或一或二同时前后单复绮互。具如二十五轮所明。此是修行人之事业矣

若得圆证即我圆觉　趣入虽从一门。功成即三皆圆证。若偏修一行但名亲近。三事圆通名证圆觉。四校量显胜

善男子。假使有人修于圣道。教化成就百千万亿阿罗汉辟支佛果。不如有人闻此。圆觉无碍法门。一刹那顷随顺修习　初举劣。后不如下显胜。且如劝得一人二人持于五戒十戒。据诸教说。福已甚多。况令尔许亿人成就辟支罗汉。具足六通八解。永超三界十缠。而乃不如有人暂习圆觉。时中极促唯一刹那。岂况长时圆修妙观。悫云。牛迹巨海何可校量。闻此等者闻慧。随顺者思慧。修习者修慧。偈中唯三。阙校量故。余全同长行

尔时世尊欲重宣此义。而偈言　且标举也

  威德汝当知　　无上大觉心
  本际无二相　　随于诸方便
  其数即无量　　如来总开示
  便有三种类　　寂静奢摩他
  如镜照诸像　　如幻三摩提
  如苗渐增长　　禅那唯寂灭
  如彼器中锽　　三种妙法门
  皆是觉随顺　　十方诸如来
  及诸大菩萨　　因此得成道
  三事圆证故　　名究竟涅槃

上来三观竟

自此第二明单复修习文四。初三之初

于是辨音菩萨在大众中。即从座起。顶礼佛足右绕三匝。长跪叉手而白佛言　同上。后陈辞句中二。初庆前

大悲世尊。如是法门甚为希有　可知。二请后有二。一问所修

世尊此诸方便　指前三观

一切菩萨于圆觉门　指前所依行本

有几修习　前说三观。虽行相分明。未审诸菩萨所修为复一人具三。为三人各一。为前后。为同时。为依次。为超次。二明所为

愿为大众及末世众生。方便开示令悟实相　可见下三唱仿前

作是语已。五体投地。如是三请终而复始。尔时世尊告辨音菩萨言。善哉善哉。善男子。汝等乃能为诸大众及末世众生。问于如来如是修习。汝今谛听。当为汝说。时辨音菩萨奉教欢喜。及诸大众默然而听　正说长行中四。一举意标数。二观网交罗。三结成正因。四总示修习。今初

善男子。一切如来圆觉清净。本无修习及修习者　明所依之本

一切菩萨及末世众生。依于未觉幻力修习　正明诸轮大意。无修之修。义同前段

尔时便有二十五种清净。定轮　轮者摧辗义。能摧惑障令正智转。故名为轮。二观网交罗。于中三。初有三轮单修三观。次有二十一轮。交络三观。后有一轮圆修三观。悫疏于此二十五观约喻各立一名。今全用之。初中三一澄浑息用观

若诸菩萨　此下二十五轮皆有标列结。亦应一一标云悟净圆觉以为起行所依。为前有故。经恐文繁。故略不载。又此初三观行相前已具释。此为分成二十五数。故略明之以显单复之相。是故三观皆标云唯。结云单。意显不兼余二。力所未兼。非轻余行

唯取极静　不兼余事

由静力故。永断烦恼究竟成就　由静心之力。觉身心空。瞥念尚无烦恼何据。烦恼不起即是觉心。故云究竟成就

不起于座便入涅槃　不起法空之座。便入寂灭涅槃

此菩萨者。名单修奢摩他　结名二庖丁恣刃观

若诸菩萨唯观如幻。以佛力故。变化世界种种作用。备行菩萨清净妙行。于陀罗尼不失寂念。及静诸慧。此菩萨者。名单修三摩钵提　庖丁是晋时屠子。十九年以一刀解牛锋刃不损。喻菩萨利众生修万行应。缘入俗自智无伤。余义已如前释。三呈音出碍观。谓器质音融。随扣应响

若诸菩萨唯灭诸幻。不取作用　以诸幻境无边难可穷究。故直云灭。灭者绝念也。作用施为又妨禅寂。故云不取。入佛境界经云。诸法犹如幻。如幻不可得。离诸幻法故敬礼无所观

独断烦恼　独者不假诸行也。正是绝待之义

烦恼断尽便证实相　但与灵心相应。烦恼自无所有。无所有处即为证也

此菩萨者名单修禅那　结名。后交络三观。每以一观为头。兼于余三。交络成七。三七故有二十一轮。兼前三单及后一圆。足二十五然每一观为头。七段之中皆有四节。初两段二二共合。次两段三行次第。次有一段先一后齐。后有两段先齐后一。今每观为首之中。但长科七段。又缘每轮辨其先后。一一须牒观名。今恐文繁。每观但各举一字以论其次。谓初静次幻后寂。寂与静异者。静是二乘境。寂是佛境。又静是禅定。寂是涅槃。文中三。初七轮静观为首。兼于幻寂。次七轮幻观为首。兼于静寂。后七轮寂观为首。兼于静幻初中七观。一运舟兼济观。菩萨修定以出尘即运舟。发慧以化物即兼济

若诸菩萨先取至静　标静观为首

以静慧心　从静蹑迹起也

照诸幼者。便于是中起菩萨行　兼修幻观。若无静慧则自居幻化。何能照幻

此菩萨者。名先修奢摩他。后修三摩钵提　结名。二湛海澄空观。湛海则波澜不动先静观以反流。澄空则水性清明。后寂观以显性

若诸菩萨以静慧故(静也)证至静性　寂也蹑静而兼修寂矣

便断烦恼永出生死　二观功用断烦恼是因亡。出生死是果丧

此菩萨者。名先修奢摩他。后修禅那　结名三首罗三目观。三观俱修。如摩醯首罗面上三目

若诸菩萨以寂静慧(静也)复现幻力种种变化。度诸众生(次幻)后断烦恼而入寂灭(后寂)此菩萨者。名先修奢摩他中修三摩钵提。后修禅那　结名四三点齐修观三点者梵之伊字。悫意云。一人俱修三观。即名为齐。非谓同时

若诸菩萨以至诤力(静)断烦恼已(寂)后起菩萨清净妙行。度诸众生　幻也。烦恼既尽爱见已无。故所起行无不净妙。可解他缚

此菩萨者。名先修奢摩他中修禅那。后修三摩钵提　结名五品字单双观。上单静观如上一口。后双明寂幻。如下两口。故云单双

若诸菩萨以至静力(静)心断烦恼。复度众生。建立境界　齐兼幻寂。初句是寂。后二句是幻。内断烦恼外度众生

此菩萨者。名先修奢摩他。齐修三摩钵提禅那　结名六独足双头观。白泽图中有山精。头如鼓有两面。前后俱见此喻静幻双照二利齐运。如双头也。单寂观如独足也

若诸菩萨以至静力。资发变化　齐标静幻。以至静力资助策发变化之力。以度众生

后断烦恼　兼寂。前二利备故入中道。此与前异。前则静独为初。后始兼寂幻。此则静与幻齐为初。后始单兼于寂

此菩萨者。名齐修奢摩他三摩钵提。后修禅那　结名七。果落华敷观。即以静定之树。结寂灭中道之果。后敷华者。复以幻观入有情界。度诸众生。同令获得涅槃之果

若诸菩萨以至静力用资寂灭(齐灭)后起作用变化世界(兼幻)。此菩萨者。名齐修奢摩他禅那。后修三摩钵提　次七轮一一标幻为首。次兼余二。今初先武后文观。武王伐纣后铸戈戟为农器。喻此菩萨先变化种种已后入静观

若诸菩萨以变化力。种种随顺(标幻)而取至静(兼静)。此菩萨者。名先修三摩钵提。后修奢摩他　二功成退职观。菩萨发慧利物即是功成。习寂内修名为退职

若诸菩萨以变化力。种种境界(幻)而取寂灭(兼寂)。此菩萨者。名先修三摩钵提。后修禅那　二幻师解术观。先起变化作术法。后归静体寂故解术

诸菩萨以变化力而作佛事(幻)。安住寂静(静也)而断烦恼(寂)。此菩萨者。名先修三摩钵提中修奢摩他。后修禅那　四神龙隐海观。起幻化生如神龙布云雨。归体入静。如隐海也

若诸菩萨以变化力。无碍作用(幻)断烦恼故(寂)安住至静(静也)。此菩萨者。名先修三摩钵提中修禅那后修奢摩他　五龙树通真观。先起幻后归静寂。如龙树初行幻术广化邪途后习真乘自阶圣果

若诸菩萨以变化力。方便作用(幻)至静寂灭。二俱随顺　齐兼静寂

此菩萨者。名先修三摩钵提。齐修奢摩他禅那　六商那示相观。商那和修即优波鞠多之师也。先以神力示相降伏鞠多弟子慢心后。乃入定归寂

若诸菩萨以变化力。种种起用资于至静(齐静)后断烦恼(兼寂)。此菩萨者。名齐修三摩钵提奢摩他。后修禅那　七大通宴默观。大通如来先化用利物。后自归寂

若诸菩萨以变化力。资于寂灭(齐寂)后住清净无作静虑(兼静)。此菩萨者。名齐修三摩钵提禅那。后修奢摩他　后七轮一一标寂为首。次兼余二。此初宝明空海观。佛顶经云。同入如来宝明空海。今灵心观。即本觉明。如宝明也。后静观如空海也

若诸菩萨以寂灭力(寂)而起至静住于清净(兼静)。此菩萨者。名先修禅那。后修奢摩他　二虚空妙用观。灵心之体如虚空。起化即妙用

若诸菩萨以寂灭力(寂)。而起作用。于一切境寂用随顺(兼)。此菩萨者。名先修禅那。后修三摩钵提　三舜若呈禅观。舜若即虚空神。遇日光映之暂现。如此先寂次静后幻

若诸菩萨以寂灭力。种种自性(寂)安于静虑(静)而起变化(幻)。此菩萨者。名先修禅那中修奢摩他。后修三摩钵提　四饮光归定观。大迦叶也。先证体次起神通。后乃归定

若诸菩萨以寂灭力。无作自性(寂)起于作用清净境界(幻)归于静虑(静)。此菩萨者。名先修禅那中修三摩钵提。后修奢摩他　五多宝呈通观。多宝佛先成道证如体。后于塔中发起法华。如静幻无碍

若诸菩萨以寂灭力。种种清净(寂)而住静虑起于变化　齐兼静幻

此菩萨者。名先修禅那。齐修奢摩他三摩钵提　六下方腾化观。即法华菩萨六万恒沙从下方现

若诸菩萨以寂灭力。资于至静(齐静)而起变化(兼幻)。此菩萨者。名齐修禅那奢摩他。后修三摩钵提　七帝心含变观。此宝含诸物像。对即变应应而还空。如灵心观成包含德用应缘起幻而复安静

若诸菩萨以寂灭力。资于变化(齐幻)而起至静清明境慧(兼静)。此菩萨者。名齐修禅那三摩钵提。后修奢摩他　后有一轮圆修二观。此名如意圆修观。如意宝珠四方俱照。大智顿觉三观齐修

若诸菩萨以圆觉慧　称圆觉而发慧故

圆合一切　圆融和合一切事理性相真妄色空等类。举体相应。是为圆合。谓由圆觉合理理即非理。故全即事。又由以觉合事事即非事。故全即理。余性相等皆同此说。中道义谛于是现焉。非理非事双遮显中。即理即事双照显中。遮照同时是为圆觉

于诸性　依此修静观

相　依此修幻观

无离觉性　依此修寂观故。科云圆修三观矣。又以圆觉合一切。是从体起用。性相无异觉性。是会用归体。体用无碍寂照同时。是为圆满无上妙觉

此菩萨者。名为圆修三种自性清净随顺　三结成正因

善男子。是名菩萨二十五轮。一切菩萨修行如是　可见四总示修习

若诸菩萨及末世众生。依此轮者　示修习者。修此二十五轮之时。于事中威仪法式及用心方便三业事理。具足修习之意

当持梵行(戒也)寂静(定也)思惟　慧也。具戒定慧心在观门。如是修行必定成佛

求哀忏悔经三七日　多生业累恐障净心。忏悔求哀发露先罪。日数若少虑不精诚。三七日中已彰恳祷。忏悔之义下道场加行中当释

于二十五轮。各安标记　书此二十五轮名字文句。安置道场之中。礼念虔诚精祈一行

至心求哀随手结取　若自的乐一门。随便积习。若胜劣难分不能自决。即凭圣力以卜应修。信手取之不宜简择

依结开示便知顿渐　依所捻结。开而视之顿渐自知。无贪余观

一念疑悔即不成就　心怀疑阻并失前功。纵使再修稍难成就。据根验理必在于兹。无乃等闲轻于事相。偈中亦四全同长行

尔时世尊欲重宣此义。而说偈言(标举)

  辨音汝当知　　一切诸菩萨
  无碍清净慧　　皆依禅定生

今修观之人先以所依之体为本而起观行。长行云圆觉清净。无能所修心宜此理。即禅定义

  所谓奢摩他　　三摩提禅那
  三法顿渐修　　有二十五种

长广偈略

  十方诸如来　　三世修行者
  无不因此法　　而得成菩提

正结所为

  唯除顿觉人　　并法不随顺

简非所为也。长无偈有。今为二释。一者两句皆作上根释。谓唯除上根圆顿悟解之人。并及于一切定相之法不随顺者。则不必具依二十五轮及道场探结等。不随顺法者。不取相也。既不随相即随真觉。此乃顿入圆明触目合道。不可加之绳索伤乎无疮。是前知幻即离不作方便等类。故除之矣。二者下句作无信下根释。谓都不信者。闻之不能随顺。依此则上智与下愚不移也。前释不随。不随倒法。此释不随。不随正法

  一切诸菩萨　　及末世众生
  常当持此轮　　随顺勤修习
  依佛大悲力　　不久证涅槃

大方广圆觉修多罗了义经略疏注卷下一(终)大方广圆觉修多罗了义经略疏卷下(二)

        唐终南山草堂沙门宗密述

次后有二问答。两重除障。初净业章除我入觉。后普觉章依师离病。此皆观行中障。故同大科。初中虽约计执浅深说有四相差别。然唯是我见。故经文除别列四名之外。节节皆有我字。若除此执便是圆觉。故云入觉。文四。初三之初

于是净诸业障菩萨在大众中。即从座起。顶礼佛足右绕三匝。长跪叉手而白佛言　同上。陈辞句中二。一庆前

大悲世尊。为我等辈广说如是不思议事　前总明观行。一向称理而修。犹可领解。今于一味之中。广张诸轮屈曲差别。差别不乖一味。尤为难见。故不思议

一切如来因地行相　远成所答文殊之问

令诸大众得未曾有。睹见调御历恒沙劫勤苦境界。一切功用。犹如一念。我等菩萨深自庆慰　悟因行也。夫果德称真约理可照。因行治染体解是难。今一念备知炳然齐现。如琉璃瓶盛多芥子。故深庆矣。二问后又三。一正问

世尊。若此觉心本性清净。因何染污。使诸众生迷闷不入　此中问意不说本来都迷。意明已知觉性圆明诸法清净。何得凡心宛在不合觉源。所作所为情犹憎爱。自他全别难自浑融。比对果人天地之远。觉心本净悟即应同。更有何法染污。令我用心异佛。故云因何迷闷不入。二情后

惟愿如来广为我等开悟法性　法性者诸法之性。若直谭本体则名觉性。若推穷差别之法。皆无自体同于一性。即名法性。今推破四相豁融诸法。全同觉性。故云开悟法性。从前经文但云觉性。唯此段云法性。意在此矣。三结意

令此大众及末世众生作将来眼　下三唱仿前

说是语已。五体投地。如是三请终而复始。尔时世尊告净诸业障菩萨言。善哉善哉。善男子。汝等乃能为诸大众及末世众生。咨问如来如是方便。汝今谛听。当为汝说。时净诸业障菩萨奉教欢喜。及诸大众默然而听　正说长行中四。一总叙过由。二别释四相。三存我失道。四断惑成因。初中总叙四相。为过患之因由。文二一明过患本起

善男子。一切众生从无始来　未曾悟故。故下有生盲之喻

妄想执有　无中横计

我人众生及与寿命　统唯我相但由展转约义。故有四名。四名复有二相。一迷识境。二迷智境。初者谓取自体为我。计我展转趣于余趣为人。计我盛衰苦乐种种变异相续为众生。计我一报命根不断而住为寿者。如金刚两论所说。迷智境者。即此经说。至文当知

认四颠倒为实我体　真我本有。迷之谓无。妄我本空。执之为有。四皆横计。故云尔也。二明过患滋多文四。一展转生妄。二违拒觉心。三动息俱迷。四结成障道。今初展转者初四句由迷起惑。次二句由惑造业。次二句由业招报。后一句反于五道堕于二乘

由此便生憎爱二境　谓由执四相为实我体。所以于自生爱于他生憎。顺我者爱。违我者憎。如是爱憎皆由执我。故曰由此

于虚妄体重执虚妄　四大五蕴迷性妄生。众缘假合已是虚妄。更于其上重执我人。故云尔也

二妄想依生妄业道　由前二妄故。生起造作种种妄业。业能引至苦乐之果。故名为道

有妄业故妄见流转　业成即受生死流转。生死流转是所至之果

厌流转者　厌三界不安皆如火宅。息缘断惑

妄见涅槃　趣寂耽空志在灰身灭智。然上十句总当二乘宗中生灭四谛也。谓初六句集谛。次二句苦谛。次一句道谛。后一句灭谛。二违拒觉心

由此不能入清净觉　正是结答前问。前问云何迷闷不入。今答云。由认四相展转生过。纵离六道复堕二乘。是故不入

非觉违拒诸能入者　前问云因何使诸众生不入。故此答云。非觉违拒使之不入。但由认我故不入也。如梦身未忘不能合于本身。非本身违拒

有诸能入非觉入故　释成非觉违拒。意云。入时若是觉入。不入即是觉拒。既入者自是信解行等。觉体元无出入。入与不入何责于觉。三动息俱迷文二。一正明

是故动念　即前苦集八句

及与息念　即前灭道二句

皆归迷闷　结成不入二征释文二。初征

何以故　动念既为背觉。息念即合契真。何故皆称迷闷。二释分一一直释

由有无始本起无明　最初根本而起。又从本源而起

为己主宰　由将无始住地无明为我主故。动是我动。息是我息。我相既在动息俱迷。二转释。前是对征之释。此又委细释于前文本起之义

一切众生生无慧目　未曾悟故。如人若十岁二十始盲。则眼前虽不见物。说之即能了知。若胎中无目生来便盲。则对色之时种种为说终无所益。则先须金錍抉膜然后指示是非。故涅槃经说。如盲人不识乳色。他人为说展转譬喻贝米雪鹤。竟不能得识其乳色

身心等性皆是无明　前得本起因地。则所修皆是佛因。此用本起无明。一切皆是魔业。又前以觉圆明故根尘普净。结云一切是觉。今以无明为本。故云皆是无明。前如金为千器器器皆金。此如土为千器器器皆瓦

譬如有人不自断命　由爱故得身。若断身即违爱。如人身纵卑陋病苦亦自保命终不能断。断余或可。自断诚难。认我亦尔。断一切烦恼恶业。容有得者。欲令断我其可得乎。何以故。我终不能还断我故。又有我故必不觉我。如眠不自见故。必情忘想尽与觉一体。觉是真我则妄我本无。方名为断。如梦身纵令至劣至苦梦时终不肯断。必须觉来合于本身方嫌梦苦复无可断。四结成障道

是故当知　指前意势。直从我体起憎爱已来。乃至不断命等。此都结之以成障道所以云

有爱我者我与随顺　对顺生爱以明我

非随顺者便生憎怨　对违起憎以明我

为憎爱心养无明故　双指上二唯滋无明。故知迷心修道纵令勤苦种种行门。但助无明何成佛果

相续求道皆不成就　正明障道。言相续者。本从无明而生憎爱。憎爱还熏无明。种子现行相续不断。将此求道毕竟不成。故宝积经云。于身生宝爱。不离于我人。彼作是修行由斯堕恶趣。二别释四相。然此我等行相殊常。常者但约迷执。初果已除。此乃直就修证。罗汉未晓。文中即为四段。一约事验我。二悟我成人。三了迹迹生。四潜续如命。初谓验其任运分自他者是其我相。文中二。一标释粗相。二结指细相。初中二。一征起标示

善男子。云何我相谓诸众生心所证者　夫我难自见。约事证知。但验自他各殊。即证自中有我。设令修道舍妄证真。但觉有心。总名我相。二约喻以释

善男子。譬如有人百骸调适。忽忘我身四支弦(紧急)缓　缓慢皆是支体不调手足失度之状

摄养乖方。微加针艾则知有我。是故证取方现我体　此况道者燕居静室或隐深山。心绝经营境无违顺。习闲成性暂得忘情。不觉自他谓证无我。若违顺所逼宛有心生心。既未平方知我在故下云。若复有人叹谤其法即喜恨等。二结指细相

善男子。其心乃至证于　上能下所

如来毕竟了知　于所证中又上是能了知也

清净涅槃　所了知也

皆是我相　谓非但了知二乘涅槃为我相。设使了知如来涅槃亦是我相。然涅槃但是觉体。非别有可证。今既证得涅槃不忘能所。即是我相。二悟我成人。悟前非者是此相矣。文二。一粗相

善男子。云何人相。谓诸众生心悟证者　觉前非也。者字正名人相

善男子。悟有我者不复认我　不作证心

所悟非我悟亦如是　同前非也

悟已超过一切证者　绝所证之过。除能悟之累

悉为人相　结成也。二细相

善男子。其心乃至圆悟涅槃　不取能所故

俱是我者心存少悟　此智不袪为存悟矣。非诸差别故云少也

备殚证理　无非不尽故曰备。殚尽也

皆名人相　结成细相。三了迹迹生。谓前二相俱是心迹。总不执之故免我人。然此了心又亦是迹。故云了迹迹生。文三。一征起标示

善男子。云何众生相。谓诸众生心自证悟所不及者　觉前能悟悟是所觉。悟既成所觉又名能。展转无穷皆成能所。能所及处皆是相待。了此无定。故离前非计所不及。谓免诸过。不觉此计又是众生。众生者不定执一之谓也。二举喻征释

善男子。譬如有人作如是言　借世人语辞以为义势。显众生相

我是众生则知彼人说众生者。非我非彼　双标非也。下自释云

云何非我。我是众生则非是我　以自是众生故非我也

云何非彼我是众生　以云我是众生不云彼是众生故非彼也

非彼我故　非彼人之我也。又显于自于彼不计我人。故非彼我。三指前对辨

善男子。但诸众生了证(我相)了悟(人相)皆为我人　指前二相也。下对之以辨众生之相云

而我人相所不及者　了证者空则我不及。了悟者空则人不及。不执主宰故离我人

存有所了名众生相　心不忘故即。上者宇四。潜续如命谓。都无所执但拟修行由。不起心免前三过。即此无执之业智相续未忘。非故生心。故言潜续。文二。一征起标示

善男子。云何寿命相。谓诸众生(可知)心照清净　即心之照故云清净。即自觉也

觉所了者　觉前三相即觉他也。证悟等尽彻于真源。无别能觉。故上云心照

一切业智　拟将此智修习一切无漏之业故

所不自见犹如命根　虽能除妄而不自除。故不自见。不自见故犹如命根。如命根者。兼取相续不断之义。二展转细释又三。一以义正释

善男子若心照见　是此门之相

一切觉　是前三相

者(通二)皆为尘垢　双指过患下释过患所以云

觉所觉者不离尘故　由将此心见前诸觉故不离尘。以心未忘故。二以喻反释

如汤销冰。无别有冰知冰销者　汤销冰尽同成一水。更无能知尽者。反明此业智既照前三相皆尽。则是我病未尽。如冰若言我尽。即此言尽之冰便是不尽。若细配合则水喻真性。冰喻四相。汤喻智慧。煎水名汤。悟心名智。故谓水冻成冰。还煎水以销之。冰汤俱尽湿性独存。以喻心迷成我还悟心以消之我智俱尽照体独立。三以法正合

存我觉我亦复如是　若以同喻反合。应云无别有我知我尽者。今翻喻势顺前正释。故云正合三存我失道文二。一总标失道

善男子。末世众生。不了四相。虽经多劫勤苦修道。但名有为　由前四相皆有取证

终不能成一切圣果　既将此心修行。则行行。皆带能所。故不成圣。正同华严多劫六度不名菩萨

是故名为正法末世　正宗佛法之末世也。夫正法之时。修则皆证。末世之时人多取相。今既取证相。则正法亦同末世。若遇此教了达病源。则虽末世还同正法。后展转广释文四。一认我为真。二说病为法。三将凡滥圣。四趣果迷因。初中二。一征释其过。二结成障觉。初中六。一久修如何不证征。二认我取证非真释三取证云何妨道征。四爱寂憎喧非脱释。五何知证法非脱征。六赞喜谤嗔验我释。今初

何以故　劫数既多行又勤苦。以何义故不证圣果。释中二。一法

认一切我为涅槃故。有证有悟名成就故　良由认我以为涅槃故。虽多劫勤修终无所益。如认梦身以为自己。勤为家业种种疲劳。终无一事益于资产。二喻

譬如有人认贼为子。其家财宝终不成就　贼若在外犹可堤防。养之为儿如何捡慎。又知贼是贼贼无能为。认之为儿宁免破败。以喻六根取境犹可制御藏识妄我难以辨明。故如来藏中功德之宝念念衰耗。由此贪穷难集福智。三证何妨道征

何以故　纵使认我取证。何以便妨于道。憎爱非脱释

有我爱者。亦爱涅槃伏我爱根为涅槃相。有憎我者亦憎生死　夫生死轮回本自憎爱。欲求解脱须尽二源。今爱涅槃还是本爱。今憎生死亦是本憎。弃苦欣乐虽殊。憎爱元是本习。带之修道佛果岂成。伏我爱根为涅槃者。由伏之故不起。不起之相似涅槃相。以似为真故云尔也

不知爱者真生死故。别憎生死名不解脱　本爱涅槃拟除生死。爱心既在即生死根。爱根憎苗岂名解脱。五何知证法非脱征

云何当知法不解脱　法者涅槃。由前释知爱涅槃者名不解脱。故此征云。若爱生死许是系缚。今悟涅槃是寂灭法。以何相知云不解脱。六赞毁验我释者。谓实证者必无我无我故即无嗔喜。今为法嗔喜。即知证法非真。我未尽故。文中二。一标我未尽

善男子。彼末世众生习菩提者。以已微证为自清净　外知根尘假合。内觉性体寂然

由未能尽我相根本　正标未尽。二以境验知

若复有人赞叹彼法。即生欢喜便欲济度。若复诽谤彼所得者。便生嗔恨　然世境违顺粗重易明。唯就法门最难觉察。但言为法嗔彼度此。不知此心元是我相

则知我相坚固执持　因对外境验得内心我无间断

潜伏藏识　种子也

游戏诸根曾不间断　现行也。遇境则发相续流转。通而言之。谓因对外境。验得内心我执犹坚潜藏相续。虽慧军数举魔众频摧。且阿赖耶城难攻主宰。末那常侍防护牢强。意识谋臣经营内外。旁监五识之将。以镇六根之门。由是贼主频通游戏。时时偷号惑我法王。往往侵强扰我观境。虽外怯般若。昼伏夜行。而内挟无明昼夜不断。二结成障觉

善男子。彼修道者不除我相。是故不能入清净觉　二说病为法文一。一正释其非二结成障觉。初中二。一覆推。蹑前为法嗔喜之次推穷。以成说病为法之过

善男子。若知我空无毁我者　恐闻嗔喜是我便拟忍受不嗔用为无我。故推征云。若见彼是毁人我被彼毁而不嗔者。此亦是我。故云。若知我空无毁我者。既见有毁我者则未得我空。亦应云。若知我空无我说法。故次云

有我说法我未断故　然毁者是彼。说者是我。经文于毁者言无。反明过也。于说法者言有。顺明过也。翻覆推过者。下拟决断为病故

众生寿命　阙人相者。取其文润成句

亦复如是　例于我也。二决断

善男子。末世众生说病为法　指前所推之过也。即是四相四相若存总名为病

是故名为可怜愍者　以病为法诚可怜愍

虽勤精进增益诸病　带病修行故增诸病。反此而言。则称实修行唯益实德。如药草等种有甘苦。水土所滋各唯增益。苦喻我相为本。甘喻净觉为本。水土则喻万行。二结成障觉

是故不能入清净觉　三将凡滥圣文二。一正明相滥。二结成障觉。初中二。一抑圣同己

善男子。末世众生不了四相。以如来解及所行处。为自修行终不成就　佛说了义称理法门。皆言心境本空惑业本净凡圣不异因果皆圆。就佛见之理实如此。且众生迷倒已久种习根深纵令信解法门。现用元来随念。但以分别心识。解他无碍言教谓言佛意亦秖如然。心既是念。故不觉念。不知冥通。证入异于随相信心。认佛平等之谭。不能断惑求证。故经印言终不成就。华严亦云。如贫数他宝等。二骋己齐圣。前则抑高就下。此则骋下齐高。文二。一认其圣智

或有众生未得谓得　理也。乃至圣人所具功德

未证谓证　智也。则圣人冥证之智身。今谓得谓证者增上慢人。若自知不证而言证者。则根本戒中大妄语戒。非此文意。二验出凡情

见胜进者心生嫉妒　然诸圣人形类不定。得与不得内证在心。何以辨他未得未证。故观心行以验真虚。夫圣人用心他己无二。见他胜进或法教流行。念念喜欢必能随顺。自验内心如此。或即证悟不虚。若自觉己衰他盛则嫉。己盛他衰则喜。纵令深解妙境但是心之所缘。勿错认之谓得谓证。二结成障觉

由彼众生　双指前两类之人

未断我爱　前云终不成就者。以佛无我爱凡有我爱故云云。见胜进嫉妒。亦由我爱。由我爱故下云

是故不能入清净觉　四趣果迷因

善男子。末世众生希望成道(趣果)无令求悟惟益多闻　迷因也。即知先须悟道然后多闻增慧。末世之人多迷此意。唯宗名数不务了心。心既不通。解义唯多我见唯长。故下云

增长我见　华严亦云。不能了自心增长一切恶等。又智论云。多闻无智慧是不知实相。譬如大闇中有灯而无目等。四断惑成因二。一顺释

但当精勤　诫劝之辞

降伏烦恼　别标所断

起大勇猛　通劝修断

未得令得　修也。谓真实境中一切功德妙用

未断令断　断也。颠倒境中一切障碍之法。即下所列云

贪嗔爱慢　根本烦恼中三也。爱无别性贪数所摄

谄曲嫉妒　小随烦恼

对境不生彼(他也)我(自也)恩爱一切寂灭　重举此者。生死根本最难拔故。念尽则自他俱寂

佛说是人渐次成就　结成因也。由前说除我用心。当时虽悟仍虑长时难离我习。故佛诫云。但得顿我悟空勤断烦恼。我见习气渐尽。无上佛果自然渐成

求善知识不堕邪见　商人入海须假导师。学者修行必资善友。二反释

若于所求别生憎爱。则不能入清净觉海　反明不生憎爱则入觉也。偈赞中四。如次讽前。全同长行。故不烦写

尔时世尊欲重宣此义。而说偈言　且标举也

  净业汝当知　　一切诸众生
  皆由执我爱　　无始妄流转(一也)
  未除四种相　　不得成菩提(二也)
  爱憎生于心　　谄曲存诸念
  是故多迷闷　　不能入觉城

三也。城喻觉者。法喻各有三义一了心性空众惑不入。如防外敌。二见恒沙德则万行圆增。如养人众二道无不通。如开门引摄

  若能归悟刹

刹是世界如入唐国率土属唐蕃境亦尔。故知若到悟境。则法法属悟。迷境亦尔

  先去贪嗔痴

痴长无偈有。慢则长有偈无。文影略也

  法爱

爱涅槃

  不存心(断也)　　渐次可成就(成因)
  我身

憎爱之本

  本不有　　憎爱何由生

所依既空能依何有

  此人求善友　　终不堕邪见
  所求别生心　　究竟非成就

四也。悟刹我身皆长无偈有。自下依师离病者。谓广劝依善知识。除去四病及诸细惑。文四。初三之初

于是普觉菩萨在大众中即从座起。顶礼佛足有绕三匝。长跪叉手而白佛言　正陈中二。一庆前

大悲世尊。快说禅病(四相)令诸大众得未曾有。心意荡然获大安隐　二请后曲有三

世尊。末世众生去佛渐远。贤圣隐伏邪法增炽　一明请问之意。如人有子病者偏忧。菩萨大悲先哀末世。贤圣隐没正法将沈。欲令广益当来。是故悬兴此问。次下正请问。前皆有我相。未可施功。今既障除方堪修习就此运用复有是非。故须依师免溺四病

使诸众生求何等人　由前云求善知识不堕邪见。故此请问何等之人是善知识。答中具指

依何等法。行何等行。除去何病。云何发心　文相皆显

令彼群盲不堕邪见　三明所为也。下三唱仿前

作是语已。五体投地。如是三请终而复始。尔时世尊告普觉菩萨言。善哉善哉。善男子。汝等乃能咨问如来如是修行。能施末世一切众生无畏道眼。令彼众生得成圣道。汝今谛听。当为汝说。时普觉菩萨奉教欢喜。及诸大众默然而听　正说。长行中五。一指示明师令事。二分别四病令除。三辨事师之心。四明除病之行。五显发心深广。如次答前五问。然复有少相滥。故且显经文。今初答第一问也。文三。一令识。二令事。三显益。今初

善男子。末世众生将发大心　简余乘也。正因

求善知识　正缘也。善能知真识妄知病识药。故初心便令求者。文殊告善财云。亲近供养诸善知识。是具一切智最初因缘。故光赞般若经云。欲学六波罗蜜者。当与真善知识相随常当承事

欲修行者　为行求解

当求一切正知见人　标指也。善达觉性不因修生决择无疑。名正知见。法句经云。善解深法空无相无作无生无灭了达诸法从本已来究竟平等无业无报无因无果性相如如住于实际。于毕竟空中炽然建立。是名真善知识。华手经云。有四法者。当知为善知识。谓善知教化修道各及过患

心不住相　离凡夫烦恼境界。谓不应住色生心等

不着声闻缘觉境界　离二乘滞寂境界。称赞大乘经云。宁在地狱经百千劫。终不发二乘之心。亦可正知见者简外道。不住相简凡夫。不着等简二乘。上皆顺行下逆行云

虽现尘劳　即贪等也

心恒清净　现染之中而不染也。如净名云。虽有妻子常修梵行等。华严云。菩萨在家与妻子俱。未曾舍离菩提之心

示有诸过　欲度有过众生。先以同事相摄。心既相亲方能受教。如净名云。入诸淫舍示欲之过等。亦同华严善财善友婆须蜜女等

赞叹梵行。不令众生入不律仪　或为利益。或有别缘。所作非仪暂乖真教。秖得贬已承非。不得饰非说理以误凡下。此乃不同邪人自造诸过。复说非梵行事为其真实。令无量人堕大险趣。但为同事摄故。虽现诸过常须赞叹真实梵行。故论云。坏见之人虽不坏行。不堪与众生为其道眼。虽坏行而不破见者。是则人天真胜福田

求如是人。即得成就阿耨多罗三藐三菩提　结成大益。二令事文二。一举身命之难。二例身外之易。初中二。一正举

末世众生见如是人。应当供养不惜身命　如雪山舍身香城破骨之类。儒典尚令竭力事父致身事君。何况为法。故大乘四法经云。诸苾刍尽寿乃至逢遇丧命因缘。必定不得舍善知识。二遮疑

彼善知识四威仪中常现清净　指前顺行

乃至示现种种过患　指前逆行

心无憍慢　正明不疑。夫菩萨化现权道难测。但依法门莫疑其迹。不以顺行即效虔诚或睹逆行便生憍慢。故智论云。于诸师尊如世尊想。若有能开释深义解散疑结。于我有益则尽心敬之不念余恶。如弊囊盛宝。不得以囊恶故不取其宝。又如夜行险道弊人执炬。不得以人恶故不取其照。菩萨亦复如是。于师得智慧光明。不计其恶。然为师之难为徒不易。勿因此诫误敌粗人。欲验真虚如前简择。已谙其道如此遵承。又此药治徒。师勿错服。服之增病。无药可治。以缚解缚无有是处。二例身外之易

况复搏　搏食也。译之讹略。应云段食

财(钱帛)妻子(最亲)眷属　仆从对前身命之难。故言况复。二显益

若善男子。于彼善友不起恶念　由前无慢故也。憍慢若起恶念便生障覆自心。法何得入

即能究竟成就正觉　既无恶念之覆。即得正觉成就

心华发明照十方刹　觉心既明即慧光开发触向无染。故曰心华。称体无边照十方刹。二分别四病令除者。答第二问。标以妙法。释依圆觉。圆觉是所依法故。此法离于四病方可依故。除病之问下自有答。然文似滥故含而科之。文三。一总标征起

善男子。彼善知识所证妙法。应离四病。云何四病　心病无边要唯此四。随有其一即不堪为师。二别释行相。皆名病者。总缘不以教为绳墨不以师为指南但自举心作如是意。故经文皆云。若复有人作如是言。言是意言矣。文四。一生心造作

一者作病(标名)若复有人作如是言。我于本心作种种行。欲求圆觉　辨相也。思惟揣度计校筹量。兴心运为拟作行相。造塔造寺供佛供僧。持咒持经僧讲俗讲。端然宴坐种种施为。止息深山游历世界。勤忧衣食谓是道缘。故受饥寒将为功德。观空观有爱身厌身。于多行门随执其一。托此一行欲契觉心。既是造作生情。岂合无为寂照。此病从前幻观中来。彼云。一切菩萨从此起行。至诸轮中皆云度生起行起用。失彼文意成此作病

彼圆觉性非作得故　指体以破也。圆觉性非造作。造作如何契之。若了觉性本圆。不用兴心求益。不兴心处即合觉心。合觉心时自无诸妄。无诸妄已则所作相应。积土聚沙皆成佛道。即于上来诸行。遇缘力及便为。随病随治不顺妄念。但得妄尽性自开明。歇即菩提岂从外得

说名为病　结名也。此上四节。下三亦同。二任意浮沉

二者任病。若复有人作如是言。我等今者不断生死不求涅槃涅槃生死无起灭念　意云。生死是空。更何所断。涅槃本寂。何假修求。不厌不欣无起灭念

任彼一切随诸法性　如火热水湿之类。各各差别之性也。今时见有一类人。云妄从他妄真任他真。各称其心。何必改作。作亦任作好闲任闲。逢饥即餐。遇衣即着。好事恶事一切不知。任运而行信缘而活。睡来即卧兴来即行。东西南北何定去住。此病因前云圆觉清净本无修习依于未觉幻力修习。失彼文意。自谓已觉何必作幻。故成任病

欲求圆觉　谓言闲即契道

彼圆觉性非任有故　前则驱驰觅佛。此乃放纵身心。设令善恶不拘。即名无记之性。七贤岂是大道四皓宁为圣人尚昧欲天焉冥觉体。行人至此溺水沉舟。宜自警怀。勿沾斯病。故前云。若不修行常居幻化云何解脱

说名为病　三止息妄情

三者止病。若复有人作如是言。我今自心永息诸念　生心恐非。随情虑失。一向止息岂合任之。但止妄即真。何须别照

得一切性　息念故离相。离相故得性。是诸法无性之性。非即觉性

寂然平等　意云。由我心生妄想故。招苦乐差殊。今但止息妄心。妄尽自然平等。此病从前静观中来。迷彼取静为行。及证诸念之言。因成此病

欲求圆觉　谓言止妄即真

彼圆觉性非止合故　觉本无念。见念既乖。性本灵明。迷照亦失。念无而有。既止息令无。照有而隐。何不观察令显。又真本无念。念既乖真。性本无止。止亦违性。故言非止合故。故前云。于诸妄心亦不息灭

说名为病　四灭除心境

四者灭病　前但止息心念令寂。此则计于身心根尘本来空寂。又前不妨见有根尘。但不随念爱染。故云止息。此则于根尘亦无。坚持空寂之相。由见空无故云除灭

若复有人作如是言。我今永断一切烦恼。身心毕竟空无所有。何况根尘虚妄境界　意云。烦恼之本即是身心。若执身心烦恼何断。故标断烦恼。释身以空。又断尽烦恼空却身心身心尚空根尘何有

一切永寂欲求圆觉　身等本空故名永寂。诸相既。泯寂相现前拟将此心求证圆觉。此病从寂观中来。彼诸轮中皆云。寂灭及断烦恼。迷彼成此

彼圆觉性非寂相故　夫觉体灵明不唯寂灭。今灭惑住寂。岂得相应。况圆觉者非动非静。双融动静。恒沙妙用无碍难思。住寂之心何能契合。言即似近理即全疏。与理相违故言非也

说名为病　三结明真伪

离四病者则知清净　将前四行自验其心。随落一门则知是病。故言离者则知清净。然上四门皆是诸经观赞。况前三观具有斯文。今此以为病者。有其二意。一者四中皆无观慧。二者但以率心偏住一行。不穷善友圆意。不究佛教圆文。才悟一门之义。便不能久事明师。才见一经妙文。便不能广穷圣意。但贪单省执一为圆。是以经文总诃为病。若能四皆通达不滞一门。即此四中并皆入道。虽然作种种行。元来任运清闲。虽顿觉身心本空。习起还须息灭。又须常冥觉体。不得取四为心。则自然休时非休。作时非作。故净名云但除其病而不除法

作是观者名为正观　即上所释病除法在。是正观也。虽不取四病。而慧解昭然不得惧落四中便不建志立节

若他观者名为邪观　复有闻斯四过离四。又更生情便信胸襟别为见解。故云邪观。又作是观者离四也。他观者取四也。问为说简师之时求于离病之者。为说学人自离四病。若说师病者。何以问中别标其目。又结云作是观者等。若说学人病者。云何标云彼善知识所证妙法应离四病。答二皆不异。既闻经识病。须求离病之师。既事此师。即修离病之行。然别释之中。若师若徒病无别相。虽含二意而无二途。解释结文之中即须科简。若结行人即依前释。若结简师。师无四病即须归依。名为正观。若纵智别求。名为邪观。故菩萨戒云。其法师者或小姓年少卑门贫穷。而实有德。是故不得观法师种姓。意云。但观病中离与不离。莫观种姓贵之与贱。三辨事师之心。此当答第三行何等行之问。故标云欲修行者。结云如是修行。然且唯说事师更无别行。故但作此科判以当修行。谓菩萨行门本无定迹。随当时事随差别机。但令善事明师。明师必自临事指示。亦同善财于文殊处发菩提心已闻菩萨行。文殊亦不具说。但令亲近善友矣

善男子。末世众生欲修行者。应当尽命供养善友事善知识　如善财南迈普贤西游等也。涅槃经说。是具足因缘故。故法句经说。善知识如父母眼目脚足梯蹬衣食铠绳药刃等。乃至云。善男子善知识有如是无量功德。是故我今教汝亲近。大众闻已举声号哭等

彼善知识欲来亲近。应断憍慢　夫善友度人种种方便。师徒心契法意方传。是以俯就物机相亲相近。愚者无识憍慢便生。慢既翳心即不入道。故云应断

若复远离应断嗔恨　或欲除慢或遇异缘。相去相离便生嗔恨。云疏我亲彼。说爱说憎既一念嗔百万障起。非论失道。亦堕三途。故此令断。论语云。唯女子与小人为难养也。近之则不逊。远之又怨。怨则此嗔恨也。不逊则此憍慢也

现逆顺境　远离名逆。亲近名顺。又违情曰逆。随情曰顺。故胜鬘云应摄受者而摄受之。应折伏者而折伏之。则佛法久住

犹如虚空　心无改易

了知身心毕竟平等。与诸众生同体无异　结示同体悲智。所以然者。若不了善友及诸众生与己同体者。则虽知菩提可进。而不能屈节事师。虽知萨埵可悲。而不能忘躯弘道。故此示也

如此修行方入圆觉　结因成果。四名除病之行。是答第四除去何病之问。文二。初明所治

善男子。末世众生不得成道。由有无始自他憎爱一切种子故。未解脱　自他憎爱前已频明。今复说者。是种子故。是入道微细病故。由此种子难契圆明故。随所闻法门。即生心作意舍此取彼。憎妄爱真难忘能所故后能治云即除诸病。现行粗而易觉。种子细而难明。故偏指也。后明能治文二。一等心观人

若复有人观彼怨家。如己父母心无有二。即除诸病　七品行慈之中此当上怨。同上亲也。观之既同应与上乐。二等心观法

于诸法中自他憎爱亦复如是　前既云怨家父母无二。例此观法应云涅槃生死不殊。不殊则无自他憎爱。故知诸病秖由爱真憎妄见自见他故。不能久事师宗。但自生情起行。今既断斯种子。则诸病自除。所以观人中云即除诸病此云亦复如是。又此于诸法中明自他憎爱。尤显异于前段。前段不言法故。五显发心深广。正答第五问也。文三。一总标发心。二别明心相。三通结离邪。今初

善男子。末世众生欲求圆觉。应当发心作如是言　诸佛因地皆发此心。依此愿修方成正觉。若无心愿策引。所修行亦不成。二别明心相。此同金刚经中具四心也。四心者。彼经弥勒颂云。广大第一常其心不颠倒。今此文二。文二合故。一广大第一

尽于虚空一切众生　广大心也。彼云四生九类。

我皆令入究竟圆觉　第一心也。彼云入于无余涅槃。各随宗故。然菩萨发心皆无分剂。等众生界不择怨亲。普使修行同归圆觉。虚空众生无有边际。菩萨悲愿亦复如然。由发此愿自熏成种。承此愿力任运而化。不要起心。三世诸佛悉同于此。若不尔者。即与二乘无异。二常不颠倒

于圆觉中无取觉者　常心也。我入觉时我即圆觉。众生亦尔何有取者。故天亲云。自身灭度无异众生。故名常心。若见有众生因我入觉。即非常也

除彼我人一切诸相　不颠倒心。故天亲云。远离依止身见众生等相。故无著云。已断我见得自行平等想。故信解自他平等。上来总是彼经实无众生得灭度者。若有我人等相即非菩萨。三通结离邪

如是发心不堕邪见　可知。偈中文五。全同长行

尔时世尊欲重宣此义。而说偈言　且标举也

  普觉汝当知　　末世诸众生
  欲求善知识　　应当求正见
  心远二乘者(一也)　　法中除四病
  谓作止任灭(二也)　　亲近无憍慢
  远离无嗔恨　　见种种境界
  心当生希有　　还如佛出世

三也。长行达已同凡。此乃敬师如佛

  不犯非律仪　　戒根永清净

四也。但讽前能治。以所治憎爱是犯戒因。云未解脱亦违戒德故。此云不犯及永净也

  度一切众生　　究竟入圆觉
  无彼我人相　　当依正智慧
  便得超邪见　　证觉般涅槃

五也。此句长无此有。般涅槃之义。留对下佛出现文以释。后一问答。道场加行下根修证。得道之处名曰道场。谓于此处誓志克期。加功用行以求证入故名加行。下根修证者。谓虽信解前法。而障重心浮。须入道场自为制勒。缘强境胜则功用有期。问此入道场但是修前三观。何得别为大科。答观行法门虽同。修之方便有异。随机施设故。故此文先结前云。若在伽蓝安处徒众随分思察。如我已说。结已然后说道场仪式。故知别是一段矣

于是圆觉菩萨　义如前释。文四初三之初

在大众中即从座起。顶礼佛足右绕三匝。长跪叉手。而白佛言　正陈中二。一庆前

大悲世尊。为我等辈广说净觉种种方便。令末世众生有大增益　解之可知也。一请后

世尊。我等今者已得开悟　蹑庆前之文

若佛灭后末世众生未得悟者　举所为也。下正请云

云何安居修此圆觉清净境界　间道场也

此圆觉中三种净观。以何为首　问加行

惟愿大悲。为诸大众及末世众生。施大饶益　结请。下三唱仿前

作是语已。五体投地。如是三请。终而复始。尔时世尊告圆觉菩萨言。善哉善哉。善男子。汝等乃能问于如来如是方便。以大饶益施诸众生。汝今谛听。当为汝说。时圆觉菩萨奉教欢喜。及诸大众默然而听　正说长行中二。一答道场。二答加行。初中二。一结前

善男子。一切众生。若佛住世若佛灭后　正法像法

若法末时(末法)有诸众生具大乘性　宿有闻熏种也。不同唯识永简余性

信佛秘密大圆觉心　闻慧初开

欲修行者　菩提心发。上皆明当机也

若在伽蓝安处徒众。有缘事故随分思察如我已说　指前普眼法门及三观诸轮所说。谓圆机菩萨不滞空闲。种种施为作诸利益。广度群品。修学法门。随其闲暇分中。则便思察三观。故言随分。非谓见解未圆名为随分。二正说文三。一道场期限。二限内修行。三诫取邪正。今初

若复无有他事因缘　菩萨逢益即为。遇缘且赴。如法华中官事当行之类

即建道场。当立期限。若立长期百二十日。中期百日。下期八十日　若无胜利。须建道场克志加功以期圣果。则三期皆是自利。为简利他故名无他事。亦可王贼命难名为他事。定三期者。过则情生疲厌。少则功行未圆故量克三期亦无别义。然约三根配之。有其二意。一约障尽难易配长期下根。中期中根。下期上根。二约精进懈怠配者。即反于此。根有利钝期有远近。对病设药斯之谓欤

安置净居　欲使内外清净身心洁白事理称可。二限内修行文二。一明道场行相。二明遇夏安居。初文二。一明随相用心

若佛现在　对当会菩萨众

当正思惟　明不假设像等。当知唯心无外境界

若复灭后　对末世众生

施设形像。心存目想生正忆念。还同如来常住之日　明设像之意。谓大师去世不睹真仪。设像谛观引心入法。相即无相即见如来。亦可想佛真身常在不灭。若称理说者。观行无间是佛现在。间断之时是佛灭后。断后复作观行思唯。是设像存想。今且依事行释也。次下明礼忏仪式

悬诸幡华　严持坛场也。备如方等经说

经三七日　去其久近。无别所表。方等经极少七日。久则不遮。次下正明法事。准离垢慧菩萨所问礼佛法经。总有八重。一供养。二赞佛。三礼佛。四忏悔。五劝请。六随喜。七回向。八发愿。今略唯二。谓礼佛忏悔。然文虽略法必具行。论中亦云。应当精勤礼佛忏悔劝请随喜回向常不休息。得免诸障善根增长。华严亦令礼敬称赞供养忏悔等

稽首十方诸佛名字　礼佛也。以名召体观而礼之。准勒那三藏礼佛观门。优劣有七。一我慢礼。二唱和礼。此二非仪。三恭敬礼。敬从心发运于身口五轮着地。四无相礼。深入法性离能所相。五起用礼。观身与佛皆从缘起如幻如影。普运身心遍礼一切。六内观礼。但礼身内法身真佛不缘他佛。七实相礼。若内若外若凡若佛同一实相。见佛可礼亦是邪见。观身实相观佛亦然。名平等礼。故文殊云。不生不灭故。敬礼无所观等。然后四礼皆属观行。谓第四空观礼真谛佛。入法之性故。五假观礼俗谛佛。从体起用故。六中观礼第一义谛佛。不计空色直见本觉真性故。七则三观一心礼三谛一境佛。不取真弃假泯绝无寄故。今经既是随相门中。且当第三第五礼也。余在下离相摄念中

求哀忏悔　具云忏摩。此云悔过。若别说者。忏名陈露先罪。悔名改往修来。其所忏法不出惑业报等三障。今欲忏者须知展转起由。由无始不觉。起贪嗔痴发身口意。造一切业受诸苦恼。忏有二意。若约责心三障俱忏。若就所作唯忏恶业。恶业复有性罪遮罪。遮罪依教作法忏之。性罪即须起行。起行有二。一事行。如方等佛名经等。二理行。如净名经观罪不在内外等。余意如上

遇善境界　感应也。或见佛像。或睹光明。不作圣心名善境界。若作圣解即堕群邪。故下文云。非彼所闻。一切境界终不可取。若天台意。即与信等相应。名善境界

得心轻安　获益也。身心调畅轻利安和。神爽气清支体柔润。二明离相用心

过三七日(蹑前)一向摄念　亦名会缘入实。谓初以尘心粗重。令托胜相为缘。相既皆虚诚宜入实。摄念者。论云。若修止者住于静处端坐正意。乃至心若驰散。即当摄来住于正念。正念者。当知唯心无外境界。然论与经皆先以礼忏等。除惑业之浊。次以正念摄驰散之动。空而又寂。方能现佛之像。二明遇夏安居。文三。一标异声闻

若经夏首三月安居。当为清净菩萨止住　然建道场。或在伽蓝。或于余处。期限未满夏首已临。入众安居则乖誓约。作念结夏又杂观心。道场中人由此疑惑。如来远念故为辨明。为俗乖律即非。因大废小无失。故决定毗尼经云。持声闻戒是破菩萨戒。持菩萨戒是破声闻戒

心离声闻　大小不同。次即下说

不假徒众　不必六和

至安居日。即于佛前作如是言　言在下也。二正陈辞

我比丘　梵语也。此含三义故存梵不译。一怖魔。二乞士。三净戒

比丘尼　尼女也。女比丘

优婆塞优婆夷　此云近事男近事女。谓亲近比丘比丘尼而承事故。即三归五戒之士女也。小乘局于二众。大乘道俗俱沾

某甲　各称其名

踞(踞居)菩萨乘　简羊鹿车

修寂灭行　简四谛行

同入清净实相住持　简事相住持

以大圆觉为我伽蓝　此云众园。园是众居处故。圆觉则万德所依。以八识海澄流注寂灭。体遍法界故得名大。于四智中则圆镜也

身心安居　身即五识。依色根所发故。心即意识。以五识取尘意识分别熏动心海波浪从生故不名安。今意无分别。五不妄缘识浪永寂与体一如。故名安也。身安故即成所作智。心安故则妙观察智

平等性智　此以四惑相应妄计赖耶为自内我。于平等理中。起不平等见。今既所缘性寂。能缘七识自如。如性皆同。故平等矣

涅槃自性无系属故　为简二乘计着方处。今顺法性故无所属

今我敬请。不依声闻。当与十方如来及大菩萨。三月安居。为修菩萨无上妙觉大因缘故。不系徒众　小大安居略有八异。一所依异。别界圆觉。二假实异。定实示现。三住持异。事相实相。四结安异。对首作法独自称名。五成安异。身不出界心不起念。六失安异。身出越界念起背本。七还界异。身不逾时及界。念不间断而觉八所期异。阿罗汉果无上菩提。有此八异。故云不依及为修等。大因缘者。不拘小节之意也。三结示休期

善男子。此名菩萨示现安居。过三期日随往无碍　道场三期已满。小乘夏限未终。以本非小乘安居故。不妨随往无碍。三诫取邪证

善男子。若彼末世修行众生。求菩萨道入三期者　指前行人

非彼所闻一切境界终不可取　总标加行中所证之境。诫其邪谬。谓信解行证虽阶级不同。而所信乃至所证之法元来不异。谓解则解其所信。修则修其所解。证则证其所修。今明证得境界。若非本所信等法即不应取。二答加行文三。一别修三观。二遍修三观。三互修三观。初文二。一别释。二总结。初中三。一静观。二幻观。三寂观。初中又三。一修观成

善男子。若诸众生修奢摩他。先取至静不起思念　义如上释

静极便觉　超动静相圆觉显现。如前从空入中也

如是初静。从于一身至一世界　释上静相自他普遍。遍静虽无先后。约行人趣入故。从陜至宽

觉亦如是　例于静也。应云如是初觉从于一身至一世界。静即是体是定。觉即是慧是用。初观成不见自身之相。名一身静。以身静时当体是觉。名一身觉。世界亦然。二起功用

善男子。若觉遍满一世界者。一世界中有一众生。起一念者皆悉能知　知众生念者。世界既全成觉。众生全在觉中。故所起念无不了达。如影入镜镜照无遗

百千世界亦复如是　类此可解。说则以一例多。觉发则同时已遍。三诫邪证

非彼所闻一切境界终不可取　文义俱同上也。二幻观文二。一明正观

善男子。若诸众生修三摩钵提。先当忆想十方如来十方世界一切菩萨。依种种门。渐次修行勤苦三昧　前至静观不假外缘。大起幻门中须凭圣境。前威德段中圆说。故约大悲化生。今道场之内且自克修。故约大智求佛。亦可诸佛菩萨必以大悲为本。但依佛菩萨种种之门。自然具大悲也。道场之内且学悲心。限满对缘即将化用。渐次者前至静归体功则顿现。今随差别之相故应渐次。所以前有起于功用。今则无文。是斯意也

广发大愿自熏成种　愿者。希求欲乐之义。众生无始已来。念念希欲五尘之境。今已了悟。故发心念念希欲悲智六度等境。熏心成习故云种也。二诫邪证

非彼所闻一切境界终不可取　同上。三寂观文三。一修观成

善男子。若诸众生修于禅那。先取数门　此有二意。一者先用数息观门。治诸觉观渐入妙境。然修出入息者。有六妙门。谓一数。二随。三止。四观。五还。六净。或依次第。或随便宜。广如疏释。二者即下所知生灭心念。便是数门

心中了知生住灭念分齐头数　由前心息相依息调心净。故了知心中生住异灭。粗细妄念本末分齐头绪数量。谓生灭各一。住四。异二。经无异字者。或脱或略。义必具有。据论所说十信凡夫觉灭相。三贤觉异相。十地觉住相。位满觉生相。觉生相者。动念都尽唯一心在。故论云。心无初相。而言知初相者。即谓无念。若得无念者则知心相。生住异灭乃至皆无自立。本来平等同一觉故。释曰。既云动念都尽本来平等同于一觉。正当此门绝待中观。问文无无念之言。如何同此。答三观体用文在前章。今此但明修之方便。彼有绝待之念。又有寂灭之文。由是科云灵心绝待。绝待无念一觉灵心岂非同邪。是知绝念之慧。方能了知生住灭念。故于此观明之

如是周遍。四威仪中分别念数。无不了知　初则宴坐照见。后则行住皆知。知即无患。譬如妖魅所欲着人。若知其名自然消灭。涅槃云。如人觉知是贼。贼无能为。二起功用

渐次增进乃至得知百千世界一滴之雨。犹如目睹所受用物　净身是圆觉自体。世界本在其中。观行成就全合灵源。如雨滴数固宜本分。非唯雨滴万物皆然。举一例诸。且标雨滴。凡夫之类迷此真心。随念所知。故无其用。三诫邪证

非彼所闻一切境界终不可取　文义准前。二总结

是名三观初首方便　前问云。三种净观以何为首。故具答已结云。是名等也。即知前段三观诸轮虽具释相。趣入方便是此所明。二遍修三观

若诸众生。遍修三种勤行精进。即名如来出现于世　如来本所示生。秖缘劝物修习。今三观既修则万行已圆。故就此人已名佛出。又即此人本觉离念。名为佛出。然前离四病。云证觉般涅槃。今修三观名如来出世。今以出世涅槃相对而释。有其二门。一约实义。二约对机。实义有三。一缘起即空之真谛。则非出非般。故大经云。如来不出世亦无有涅槃。二真如缘起之俗谛。则念念处处而出现。念念处处而涅槃。大经又云。菩萨应知。自心念念常有佛成正觉。如自心一切众生心亦复如是。即念念也。又云。当知无有少许处空无佛身。即处处也。涅槃者。即如上遍一切处出现之佛身。既是缘起有为之相。念念即生即灭四相同时。今以生生即灭。为念念处处而般涅槃。三约第一义谛。即常住世常涅槃。谓寂而常照为住世。照而常寂为涅槃。对机者。机缘感则菩提树下而出现。机缘尽则双林树间而涅槃。故大经云。佛子诸佛如来为令众生生欣乐故。出现于世。欲令众生生恋慕故。示现涅槃。譬如日出普照世间净水器中等。对今经意配释可知。然此三观虽各有证相。理实遍修方契圆觉。如前文说。三互修三观文三。一明修观不成

若后末世钝根众生。心欲求道不得成就　下中之下力不遂心。二令忏除惑业

由昔业障当勤忏悔。常起希望。先断憎爱嫉妒谄曲求胜上心　重发誓愿决心欲证。加功励志忏业断惑。论中亦云。若人修行信心。以从先世罪业众多障碍。应当勇猛礼忏等。三令随便互修

三种净观随学一事。此观不得。复习彼观。心不放舍渐次求证　有人色相所碍。空静之观难成。先观色幻。幻即全空静观方成。复有执定实色。碍于心识难修幻观。先知其体本无而不妨睹相。方成假幻。复有修中难成绝待。先知假全空而无假。空全而假无空。空假俱无绝于对待。方成寂灭。又有人直见心源。方知诸法即性故空。不坏相故假。或但从性现故假。无别所现故空。先后绮互如诸轮说。偈赞中二。全同长行

尔时世尊欲重宣此义。而说偈言

  圆觉汝当知　　一切诸众生
  欲求无上道　　先当结三期

期限也

  忏悔无始业　　经于三七日
  然后正思惟

限内修行

  非彼所闻境　　毕竟不可取

诫取邪证

  奢摩他至静　　三摩正忆持
  禅邪明数门　　是名三净观(别修)
  若能勤修习　　是名佛出世(遍修)
  钝根未成者　　常当勤心忏
  无始一切罪　　诸障若消灭
  佛境便前

互修结前及安居之法。长有偈无。佛境出现长先偈后。余但文略耳

大文第三流通分。谓正宗之分法义已周。欲使广益他方远沾来世流传通泰展转无穷。故有此分。都无人传是不流。流则不住不滞。传之遇其障难是不通。通则不壅不塞。文五。一庆闻深法请问流通。二赞许伫听交感流通。三依问宣说内护流通。四禀命加卫外护流通。五时众受持总结流通。初文三段同上。今初

于是贤善首菩萨在大众中即从座起。顶礼佛足右绕三匝。长跪叉手而白佛言　可知。二正陈中二。一庆闻所诠

大悲世尊。广为我等及末世众生。开悟如是不思议事　近庆道场远该一部。二请问能诠

世尊。此大乘教　然正宗分中但问所诠法义。法义虽已圆备。凡心难可任侍。闻时令会分明。过后恐还遗忘。事须持教以教贯穿。文既不遗。随文解义。依义起观。方成真正修行。故此问经教也

名字何等　解义先须识名。迷名于义不了

云何奉持　前虽已说持法。今问持教

众生修习得何功德　依理修行证圣。已知功德无边。受持名教。恐无利益故问

云何使我护持经人　使我诸菩萨等于末世中云何卫护受持此经之人

流布此教至于何地　十法行也。若人一向于此了义经教。供养写施听受读诵说释思修。如是分布流传。未审此人智慧功德毕竟至何位地。下三唱仿前

作是语已五体投地。如是三请。终而复始。尔时世尊告贤善首菩萨言。善哉善哉。善男子。汝等乃能为诸菩萨及末世众生。问于如来如是经教功德名字。汝今谛听。当为汝说。时贤善首菩萨奉教欢喜。及诸大众默然而听　三依问宣说文二。初且标能说能护之人

善男子。是经百千万亿恒河沙诸佛所说　说此经佛既是真身。真身无碍尘沙同体。故一说即是多说。华严云。十方诸如来同共一法身。一心一智慧。力无畏亦然。又不了义经则随方有说不说。了义之教无佛不谭。如华严云。我不见有佛国土一说此经等

三世如来之所守护　亦如华严经云。我等诸佛护持此法。令未来世一切菩萨未曾闻者皆悉得闻

十方菩萨之所归依　因行之中无不从此成佛

十二部经清净眼目　良以推穷迷本照彻觉源。是以理贯群经义无不尽。于此若解则诸教焕然。若不了之何知正道。故云眼目。二正答所说所护之法文五。一答名字。二答所至。三答奉持。四答功德。五答护持。今初

是经名大方广圆觉陀罗尼。亦名修多罗了义　经有五名。二名已释

亦名秘密王三昧　非器不闻名秘。随器异闻名密。三昧之名其数无量。圆觉三昧是彼根源。故称王也

亦名如来决定境界　极证之处

亦名如来藏自性差别　如来藏即圆觉在缠之名。妄不能变名为自性。随缘起妄名为差别。又空如来藏不空如来藏。即是差别

汝当奉持　敕令依此名义而持。谓已悟者文性离而持法。未悟者无离文而持义。是奉持之相也。然答奉持之问者。若以文显。则不妨。因说经名承其文势便于此答。若以义求。则在后顿渐门中。二答所至文二。一标行所依

善男子。是经唯显如来境界。唯佛如来能尽宣说　前云是诸众生清净觉地。又说无明贪爱四相四病。今云唯显如来境界者。下句自释。唯佛能说。故说无明等皆无所有正是佛境。佛境若不显现。众生岂得皆空。生若不空岂彻觉地。故华严信位即佛境甚深。虽智与知殊。皆佛境界。是此意也。二依修所至

若诸菩萨及末世众生。依此修行　十法行也

渐次增进至于佛地　由经唯显佛境故。修之必至佛地。三答奉持文二一法

善男子。是经名为顿教大乘。顿机众生从此开悟。亦摄渐修一切群品　宗是顿教。事具渐门。既顿渐俱收。则迟速皆益。入与不入总可留心。故正宗中分上中下。二喻

譬如大海不让小流　谓渐教则乖顿教。顿门必具渐门

乃至蚊虻　此喻二乘受持

及阿修罗　此喻菩萨受持

饮其水者皆得充满　大海有无量之水。饮之则量腹少多。圆觉有无边法门。受之则随器顿渐。四答功德文三。一以施宝校量显闻经胜。意明其福。以福校量故。二以度人校量显说经胜。意明其智。非智不能度人故。又闻者假令不解。亦生其福。说者必无不解。故唯智也。三以宿因反验。显信经胜双明福智。初中二。初举劣

善男子。假使有人。纯以七宝积满三千大千世界。以用布施　积福可知。二显胜

不如有人闻此经名及一句义　如金刚经校量文例。谓世珍盈刹。能为漏果之资。妙法一言必获菩提之报。二以度人校量者。谓前以劣福显胜福。此以劣智显胜智。文二。初举劣

善男子。假使有人。教百恒河沙众生得阿罗汉果　积德可知。二显胜

不如有人宣说此经。分别半偈　凡全偈者。所谓四句。句有二种。谓文句义句。若约文句。即两句为半偈。若约义句。即说一切法本来空寂。是半偈也。显空体不空方为全偈。或无常真常为半及全。三以宿因显信经胜。双明福智者。经文自显文二。一明闻信

善男子。若复有人。闻此经名信心不惑　二验宿因文二。一反显

当知是人。非于一佛二佛种诸福慧　二顺明

如是乃至尽恒河沙一切佛所。种诸善根。闻此经教　亦如金刚文势。然此宗信者。必是即解之信。信该果海不是小缘。故验宿因。亦非聊尔人耳。五答护持

汝善男子。当护末世是修行者。为令恶魔及诸外道。恼其身心令生退屈　前问云何护持。今答意云。但莫令恶魔外道恼身心者。即是护持。然恼身心俱通魔外。若以义配者。外道以邪智惑人令疑。是恼心也。魔以神力令种种不安。乃至病等。是恼身也。故经说。众魔者乐生死。外道者着诸见等。二事皆令初心行人退屈。实藉护持。四禀命外护文三。一力士众

尔时会中有火首　首头也。头有火焰故

金刚　执此杵故。若取名者云露肩神

摧碎金刚尼蓝婆　未详唐语

金刚等八万金刚。并其眷层。即从座起。顶礼佛足右绕三匝。而白佛言。世尊。若后末世一切众生。有能持此决定大乘。我当守护如护眼目。乃至道场所修行处。我等金刚自领徒众。晨夕守护令不退转　此神初发心时常发大愿。愿为力士护修行人

其家　在家众也

乃至永无灾障疫病销灭　凡发大心多有障难。障难多种略举灾病。故云乃至也。今由神护一切皆除

财宝丰足　修道资缘也。不必富奢方名丰足。故次但云

常不乏少　不乏少故。进趣妙门不退屈也。二天王众

尔时大梵王　别指初禅王娑婆世界主

二十八天王　总指三界

并须弥山王　别名帝释

护国天王等　别显四王。别标三类者。以梵与释诸佛转法轮时皆为请主护世持国使灾害不生故。于总列之外而更别明

即从座起。顶礼佛足右绕三匝。而白佛言。世尊。我亦守护是持经者。常令安隐心不退转　正明护持三鬼王众

尔时有大力鬼王。名吉槃茶　亦云鸠槃茶。食人精血。其疾如风变化稍多。住于林野。管诸鬼众。故号为王。来至道场而为上首

与十万鬼王　其数十万。一一若斯。依附深山或居岩穴。其形可畏通变极多。不属人天。住居鬼趣

即从座起。顶礼佛足右绕三匝。而白佛言。我亦守护是持经人。朝夕侍卫令不退屈　无障难故不退

其人所居一由旬内　一由旬则四十里。一云十六里

若有鬼神侵其境界。我当使其碎如微尘　碎鬼神境界者。护佛菩提心故。五时众受持

佛说此经已。一切菩萨天龙鬼神八部眷属。及诸天王梵王等。一切大众。闻佛所说皆大欢喜。信受奉行　文殊所问经说。有三种义欢喜奉行。一说者清净。不为取著名利所染故。二所说清净。以如实知法体故三得果清净。即说益也

  自惟无始迷心海　　旷劫漂沉生死波
  尘沙诸佛出人中　　浮木盲龟难值遇
  何幸此身逢了教　　千重疑滞类冰消
  寻思累世积闻熏　　惭愧多生善知识
  上士慈悲哀末世　　始终次第为咨询
  能仁应感称心源　　本末无遮顿演说
  已采群筌扣真寂　　随应圣旨解斯文
  普回功德向众生　　同入神通大光藏

大方广圆觉修多罗了义经略疏卷下二

    圭峰定慧禅师遥禀清凉国师书

  (宗密)庆以天幸窃禀

和尚华严疏文。虽乖礼足且解生焉。(宗密)恨以累有事故。不获早赴起居。下情伏增惶惧。既未系目。敢自陈心。若不粗述本缘。宁表诚素。欲书实语。恐尘渎视听。进退无已。伏惟照恕幸甚。(宗密)本巴江一贱士。志好道而不好艺。纵游艺而必欲根乎道。自龆年洎弱冠。虽则诗书是业。每觉无归。而复傍求释宗。薄似有寄。决知业缘之报。如影响应乎形声。遂止荤茹。考经论。亲禅德。狎名僧。庄居屡置法筵。素服滥尝覆讲。但以学亏极教。悟匪圆宗。不造心源。惑情宛在。后遇遂州大云寺圆和尚法门。即荷泽之裔也。言下相契师资道合。一心皎如万德斯备。既知世业事艺本不相关。方始落[髟/米]披缁服勤敬事。习气损之又损。觉智百炼百精。然于身心因果。犹怀漠漠。色空之理。未即于心。遂屡咨参方蒙授与。终南大师华严法界观门。佛法宝藏。从此顿彰。同志四人琢磨数载。一句中理论则通宵未休。一事中义旨则尘沙莫算。达水常湿宁疑波湛之殊。悟镜恒明不惊影像之变。净刹秽土非坏非成。诸佛众生何起何灭。由是念包三世同时互促互延尘与十方。全体相即相入多生。谬计反覆枉受于沉沦。今日正观始觉元同于大用。然后所显境界。离情则随照分明能诠大经。配文则难为通会。章句浩博因果重叠。理虽一味势变多端。差别义门囡尽血脉。不知科段意莫连环。纵使历诸讲场。不添已悟。名相繁杂。难契自心(宗密)谓言章疏例只如斯。遂休心传教。适志游方。但以终南观门为助缘。以离情顺智为自力照融。通法界而栖托。指事理悬说。为利他以梦幻身心游影像世界。神冥妙境智历义门。跋涉江山至于襄汉。于恢觉寺遇灵峰阇梨。即和尚门下一哲人也。寝疾数月渐至羸极。相见三日才通其情。愿以同声之分经及疏钞。悉蒙授与。议论未周奄然迁逝。斯则夙缘法会忍死待来。若见若闻无不叹讶(宗密)渴逢甘露贫遇摩尼。腾跃之心手捧而舞。遂于此山返关绝迹。忘餐辍寝。夙夜披寻。以疏通经。以钞释疏。寻文而性离。照理而情忘。偶之于心会之于教。穷本究末宗途皎如。一生余疑荡如瑕翳。曾所习义。于此大通。外境内心豁然无隔。诚所谓太阳升而六合朗耀。巨海湛而万象昭彰。妙德妙智而顿开。普贤普行而齐现。五周四分一部之网在纲。六相十玄三乘之流会海。义则色空同于中道。教则权实融于圆宗。理则体用即寂。而性相宛然。智则凡圣混同。而因果不坏。显随缘而不变。弘经则理趣周圆。指幻而识真。修观则禅心使旷。荡九会经文无不契心。由斯可谓契经矣。使一真心地无不印经。由斯可谓心印矣。是知执三藏文者。诚为失道。局一性义者。犹未圆通。想夫斯流固宜绝分。声闻聋瞽谅不虚哉。(宗密)未遇疏前。每览古今著述。在理或当。所恨不知和会。禅宗天台多约止观。美则美矣。且义势展转滋蔓。不直示众生自心行相。虽分明入处犹历渐次。岂如问明释文殊偈。印灵知而心识顿袪。悬谈开分齐章。显真空而相用繁起。起不异性故。事事融通。通而互收故。重重无尽。悟此则全同佛果。方是圆因。随缘造修无非称体。开顿渐禅要。可以此为楷模。传权实教门。可以此为轨范。药得雪山善见。群疾俱消。宝获沧海摩尼。千珍随念。况悬文卷半。诸义尽包。备核源流。遍穷名体。然后融成本部。全拣全收。苟能精之。已领百家之文义。少功多获。要在兹焉。凡曰释流孰不可习。(宗密)夙生多幸同种善根。遇如是经逢如是疏。顷于王膳未敢即餐。今得明文印决。心意泰然。誓愿生生尽命弘阐。当时便被僧尼徒众。因请赞扬务自温习。课虚顺命。但依文配读而已。讵足以发明于人。为显圆宗多惊抚掌。爰有宿机坚种闻即禀承。从始洎终可数十人。誓愿修学。盖兹疏文玄妙。传之不虚。岂以微才能感如是。襄阳讲罢。暂往东都。礼祖师塔。便拟驰赴。拜觐盖缘夏逼。且止永穆寺。襄阳徒众迤逦访寻。再邀第二遍讲。复闻兹经遂允众请许。终悬疏却赴上都。今月七日才毕。听徒泰恭遂断一臂云。自庆所逢之法。玄妙难思。用表恳诚。厥愿修学。此乃和尚道威德洽。教令将行。门下宗枝有斯精苦。伊且割截支体伤断筋骨。都无痛恼。神色宛然。自初至今身心仍旧。若道若俗无不异之。观智之功感应昭著。时台省询验。事迹分明。留守崇敬大经已申中书门下。据伊本意。岂尽显扬。然发起门亦藉旌表。沿伊手疮未愈。官司牒寺委令将养。未便游行。以此礼觐转见迟违。下情无任伏增惶惧。谨差听徒僧玄圭智辉。先具申述(宗密)才微语拙领悟难陈。伏乞慈悲特赐摄受幸甚。不备学徒(宗密)惶恐百拜上

华严疏主清凉国师大和尚

  唐元和六年辛卯岁九月十三日在东都上清凉国师诲答

十月十二日玄圭智辉至。得汝书。遥伸师敬。备述行迹。领大教之玄趣。说传赞事诚感凄然。心纳矣。吾自传扬。或面言心授。或展转分照盈于异域。然仲尼倾盖伯牙辍弦。亦藉形声矣。不面而传得旨系表。意犹吾心未知有也。非凭圣力必藉夙因。当自慰尔。转轮真子可以喻也。泰恭断臂重法情至。加其恳祷。然半偈忘躯一句投火。教有文矣。意存身外有重法之宝尔。宜诫之。后学勿使效之。当断其情虑。勿断其形骸。当断其妄心。无斩其肢分。则浅识异学安其所不惊视。苟俗无发肤之诫。则玄化不广而自博矣。汝当笃志幽趣。傥得一面印所悬解。复何嘉焉。如忽缘阻。但当心契玄极。岂山河形声所能隔哉。勉之不多云。老僧澄观付

宗密法子收

十月二十三日学徒(宗密)裁书再拜

本讲华严疏主。玄圭智辉回。伏奉诲示。纳所微悟。许厕法席。顶戴奉持不任忻惧。多惭陋质。未效勤劳。空呈寸心。坐蒙收采自惊侥幸。喜极成悲。伏蒙慈愿弘深降斯过分。一经印决顿觉光辉。学流进功时辈增仰。幸甚。(宗密)便欲奔赴给侍。缘泰恭臂疮未愈。慎风不敢冒路。再三涕泣。愿侍随行念伊迹苦。不忍弃遗。伏惟照察。不备学徒(宗密)再拜上

本讲华严疏主

大方广圆觉修多罗了义经略疏卷下二


大慧度经宗要

    No. 1697 [cf. No. 223]

大慧度经宗要

        释　元晓撰

将说此经六门分别。初述大意。次显经宗。三释题名。四明缘起五者判教。六者消文

第一述大意者。夫波若为至道也。无道非道无至不至。萧焉无所不寂泰然无所不荡。是知实相无相故无所不相。真照无明故无不为明。无明无不明者谁灭痴闇而得慧明。无相无非相者岂坏假名而说实相。斯则假名妄相无非真性。而四辨不能说其相。实相般若玄之又玄之也。贪染痴闇皆是慧明而五眼不能见其照。观照波若损之又损之也。今是经者波若为宗。无说无示无闻无得绝诸戏论之格言也。无所示故无所不示。无所得故无所不得。六度万行于之圆满。五眼万德从是生。成菩萨之要藏也。诸佛之真母也。所以无上法王将说是经。尊重波若亲自敷坐。天雨四华以供养。地动六变而警喜。十方大士最在边而远来二界诸天下高光而遐至。常啼七岁立之不顾骨髓之摧。河天一座闻之便得菩提之记。至如唐虞之盖天下周孔之冠群仙。而犹诸天设教不敢逆于天则。今我法王波若真典诸天奉而仰信不敢违于佛教。以此而推去彼远矣。岂可同日而论乎哉。尔乃信受四句福广虚空。舍恒沙之身命所不能况起谤一念罪重五逆。堕千劫之无间犹不能偿者也。所言摩诃般若波罗蜜者皆是彼语。此土译之云大慧度。由无所知无所不知故名为慧。无所到故无所不到乃名为度。由如是故无所不能能生无上大人能显无边大果。以此义故名大慧度。所言经者常也法也。常性无所有故先贤后圣之常轨也。法相毕竟空故反流归源之真则也。此经六百有十六分。在前四百以为初分。初分之内有七十八品。于中在前明起经之缘故言初分缘起品第一

第二显经宗者此经正以波若为宗。通而言之波若有三。一文字波若二实相波若三观照波若。今此经者后二为宗。所以然者文字但是能诠教故。后二是其所诠旨故。今欲显是宗义略作三门。一明实相二明观照三者合明二种般若。初明实相般若相者诸法实相说者不同。有义依他起自性上遍计所执。自性永无所显真如是为实相。依他起性实不空故。瑜伽论云。若诸名言熏习之想所建立识缘色等相事计为色等性。当知此性非实物有非胜义有。唯是遍计所执自性当知假有。若遣名言熏习之想所建立识。如其色等相事缘离言说性。当知此性是实物有是胜义有乃至广说故。或有说者依他性空真如亦空。如是乃为诸法实相。如下文言。色无所有不可得。受想行识无所有不可得。乃至如法性实际无所有不可得。又言诸法实相云何有诸法无所有。如是有是事不知名为无明乃至广说故。或有说者依他起性亦有亦空。世俗故有胜义故空。空即真如真如不空。如是名为诸法实相。如下文云。世俗法故说有业报。第一义中无业无报。瑜伽论云于胜义上更无胜义故。或有说者二谛法门但是假说而非实相。非真非俗非有非空如是乃名诸法实相。如下文云。有所得无所得平等是名无所得。论云若颠倒少许有实者第一义谛亦应有实故。问诸师所说何者为实。答诸师说皆实。所以然者皆是圣典不相违故。诸法实相绝诸戏论都无所然无不然故。如释论云一切实一切非实。及一切实亦非实。一切非实非不实是名诸法之实相。案云此说四句是实相者如其次第许前四说。离着而说无不当故。若有著者如言而取无不破坏故非实相。离绝四句不可破坏。如是乃名诸法实相。如广百论颂曰

  有非有俱非　　诸宗皆寂灭
  于中欲兴难　　毕竟不能申

或有说者依此大般若经以如来藏为实相般若。如下理趣分中言。尔时世尊复依一切住持藏法如来之相。为诸菩萨宣说般若波罗蜜多一切有情住持遍满甚深理趣胜藏法门。谓一切有情皆如来藏普贤菩萨自体遍故。一切有情皆金刚藏以金刚藏所灌洒故。一切有情皆正法藏皆随正语转故。一切有情皆妙业藏一切事业加行依故。佛说如是住持甚深理趣胜藏法已。告金刚手菩萨云。若有得闻如是遍满波若理趣胜藏法门信解受持读诵修习。则能通达胜藏法性藏速证无上正等菩提。如宝性论云。无始世来性作诸法依止。依性有诸道及证涅槃果。长行释言。此偈明何义。无始世来性者如经说云。诸佛如来依如来藏。说诸众生无本际不可得知。所言性者如圣者胜鬘经云。世尊如来藏者是法界藏。出世间法身藏。出世间上上藏。自性清净法身藏。自性清净如来藏。依此五句摄大乘论及佛性论以五义释无相。论云所言性者自有五义。一自性种类义。二因义。三生义。四不坏义。五秘密义。乃至广说。今此经云一切有情皆如来藏普贤菩萨自体遍故者。谓此菩萨意为一切有情唯一法界无别有情。由此道理长时熏修。是故自心变异遍诸有情以为自体。如是菩萨随分观心尚能如是况诸如来圆满观心。是故诸有情皆为如来藏所摄名如来藏。如是释也。如佛性论云。一切众生皆在如来智内。皆为如来之所摄持故。说所摄众生为如来藏。如来所摄名如来藏故。以金刚藏所灌洒故者谓佛地所有大圆镜智相应净识所摄。种子变异为诸有情。以为等流果故言所灌洒故。皆随正语转故者普贤菩萨变为诸有情。时随自正语变异生故。诸有情皆是正法也。皆妙业藏者以如来藏自内熏习力故生诸有情二种业。谓避苦求乐。诸善事业一切加行善心皆依此二业生故。言一切事业加行依故。由此道理名为妙业

次明观照般若相者如论说云。诸菩萨从初发心求一切种智。于其中间知诸法实相慧是波若波罗蜜。总说虽然于中分别如下论文诸说不同。今于其中略出四义。一有人言无漏慧眼是般若波罗蜜相。何以故一切慧中第一慧是名波若波罗蜜。无漏慧根是第一故。二有人言般若波罗蜜是有漏慧。何以故菩萨至道树下乃断结使。先虽有大智慧有无量功德。而诸烦恼未断。是故菩萨波罗蜜是有漏智慧。三有人言菩萨有漏无漏智慧总名波若波罗蜜。何以故菩萨观涅槃行佛道。以是事故应是无漏。以未断结使事未成办故应名有漏。四有人言是波若波罗蜜不可得相。若有若无若常若无常若空若实是波若波罗蜜。众界入所不摄。非有为非无为非法非非法。不取不舍不生不灭出有无四句适无所著。譬如火炎四边不可触以烧手故。波若波罗蜜亦如是不可触以邪见手烧故。问曰上种种人说波若波罗蜜何者为实。答曰有人言各各有理皆是实故。如经说五百比丘各各说二边及中道义。佛言皆有道理。有人言末后答者是实。所以者何不可破不可坏故。若有法如毫厘许有者皆有过失可破。若言无亦可破。是波若波罗蜜中有亦无无亦无非有非无亦无。如是言说亦无是名寂灭无碍无戏论法。是故不可破不可坏是名真实波若波罗蜜最胜无过者。如转轮圣王降伏诸敌而不自高。波若波罗蜜亦如是能破一切语言戏论。亦不有所破。出第十一三即中。案云此中前三义者依迹显实。通取地前地上波若有漏无漏随义而说。第四义者唯显地上无分别智。证会实相绝诸戏论超过四句远离五相。故言末后答者为实。是就最胜作如是说。而非尽摄一切智慧。故言诸说皆有道理。如下文云。波若波罗蜜摄一切智慧。所以者何菩萨求佛道时应学一切法得一切智慧。所谓求声闻辟支佛佛智慧。是智慧有三种。学无学非学非无学非学非无学。智者如干慧地不净安般欲界系四念处暖法顶法忍法世第一法等。乃至广说

第三合明二种般若。由非一故假说二种。而离能所毕竟无异。所以然者菩萨修行般若之时推求一切诸法性相。若我若无我若常若无常若生若灭若有若空。如是一切都无所得。不得一切所取相不起一切能取之见。是时远离一切相见平等证会诸法实相。无二无别无始无终无生无灭非有非空。超过一切语言之路永绝一切心行之处。云何于中有二般若。但一切诸法无不同然是故强名诸法实相。一切分别无所不离是故亦名无分别智。无智而非实相无实相而非智。如论说云。菩萨观一切诸法非常非无常非我非无我非有非无等。亦不有是观是名菩萨行般若波罗蜜。是义舍一切观灭一切语言离一切心行。从本已来不生不灭如涅槃相。诸法亦如是是名诸法实相。乃至广说。问观照般若若有三分不。若有见分何言无见。若无见分何名观照。有自证分证自体者则此智体不同实相。云何得言无二无别。若无见分亦无自证则同虚空不得名慧。答有义此智有见无相。有义此智无相无见。唯有自证证于自体。或有说者若就有别开分三分俱无。若依无异假说三分俱有。谓即于此平等之中无相为相无见为见。无别自证非不自证。如是自证无所不证诸法实相无非自故。故此自证无非是见。见实相者是无所见有所见者不见实故。故此见分无非实相。如是三分只是一味。若如是说有见不见无障无碍即是解脱。若存能见即堕有边。若无见分则堕无边。不离边故即为被缚如论偈云

  若人见般若　　是即为被缚
  若不见般若　　即亦名被缚
  若人见般若　　是则得解脱
  若不见般若　　则亦得解脱

上来第二显经宗竟

第三释题名者。摩诃言大般若云慧。波罗蜜者名到彼岸如论说也

将释此名即作三门。先大次慧后到彼岸。所言大者总而言之。凡诸所有大事大法不可思议神力威德皆是般若之所成办。以是义故名之为大。如下文云。般若波罗蜜为大事故起。不可思议事故起。不可称事故起。无有量事故起。无等等事故起。何以故波若波罗蜜中含受五波罗蜜。含受内空乃至有法无法空。含受四念处乃至八圣道分。是深般若波罗蜜中含受佛十力乃至一切种智。譬如灌顶王国土中尊。诸有官事皆委大臣国王安乐无事。如是须菩提所有声闻辟支佛法若菩萨法若佛法一切皆在般若波罗蜜中。般若波罗蜜能成办其事。乃至广说。别而论之乃有众多。今撮其要略释四义有胜力故。得多闻故。生大人故。与大果故。有胜力故名为大者。谓诸菩萨能学般若波罗蜜故。有不思议殊胜神力。如经言欲以一毛举三千大千国土中诸须弥山。掷过他方无量阿僧祇诸国土。不娆众生者。当学般若波罗蜜故。得多闻故名为大者。谓诸菩萨学般若故过去未来一切诸佛所说言教。已说当说皆得遍闻如经言。过去诸佛已说现在诸佛今说未来诸佛当说。欲闻闻已自利亦利他人。当学般若波罗蜜。论曰菩萨有三昧名观三世诸佛三昧。入是三昧皆见三世诸佛闻其说法。问过去未来诸佛音声至现在故菩萨得闻耶。声不至现而三昧力能闻已灭未生音耶。若彼音声至现在者云何已灭重生于现。云何未生先现于今。若彼音声不至今现则彼音声已灭未生。未生已灭即是无声。云何得闻于无声耶。答彼过未音虽不至今而能得闻三昧力故。如障外色虽物所隔而能得见天眼力故过未音声当知亦尔。虽时有隔而能得闻。得闻曾有当有之声非闻已灭未生之无。若彼过未诸佛力故声至于今。而令闻者凡夫二乘皆得听闻。非谓般若三昧之力。故此经言已说当说。当说即是当有之音已说即是曾有之声。问菩萨现能闻于曾当。佛岂不能令声至。今若能令至不离前难。重生逆理不应理故。答谁言诸佛不能令至但说闻至非般若力。当知诸佛法轮音声遍于三世无所不至。能至所至不可得。故如华严经言譬如章文字悉入一切数所入无所入。法轮亦如是。如来转法轮三世无不至。所转无所转求之不可得。虽去来音至于今现而非重生亦非过理。所以然者。佛知三世长远之劫即是极促一念之顷。而不令劫促亦不令念长。是故当知彼声至今无重生逆理过失。如彼经言。无量无数劫即是一念顷。亦不令劫短究竟刹那法。且止乘论还述本宗。生大人故名为大者。四种大人皆从般若而得生故。如论说言一切世间中十方三世诸佛是第一大。次有菩萨辟支佛声闻。是四大人皆由般若波罗蜜生故名为大。与大果故名之为大者。能与一切众生无边无尽果故。如论说言。复次能与众生大果报无量无尽常不变坏。所谓涅槃故名为大。余五不能故不名大。依是四义般若名大。六种释中是有财释

第二释慧义者。解了义是慧义。能了一切所知境界故。无知义是慧义。有所知者不知实相故。破坏义是慧义坏。一切法可言性相故。不坏义是慧义。不坏假名而证实相故。远离义是慧义。永离一切取着相故。不离义是慧义证会一切诸法相故。复次无离无不离义是般若义。于一切法都无所离无所不离故。无坏无不坏义是般若义。于一切法永无所坏无所不坏故。无知无不知义是般若义。由得无所知无所不知故。无义无非义义是般若义。不得一切义不得非义故。如是等义如论广说。如是十种般若之义。若约境智非一之义观照名慧是持业释。实相名慧是依主释。若依能所无二之门亦一实相般若亦持业释。问若彼般若之名此土译言慧者。何故论说此二不称。如下文云。不亦称者称名智慧。般若之实相甚深极重智慧轻薄。是故不能称。又般若多智慧少故不能称。又般若利益处广。未成能与世间果报成已与道果报。又究竟尽知故名称。般若波罗蜜无能称知。若常若无常若实若虚若有若无如是等不可称义。应知。答此论文意正明智慧之名不称般若之体。非谓般若之称不当智慧之名。何者文称名智慧者是举能称名为智慧。般若甚深极重者是显般若之体离言绝虑。智慧轻薄者是明般若之名不离言虑。是故此名不能称体。又般若多智慧少者般若之体无量无边所知所证无限量故。智慧之名有限有量能称能知唯一名故。是故少名不称多体。次言般若利益处广者。是明般若之体利益处广。智慧之名所不能诠。是故言不可称。次言究竟尽知故名称者。是明智慧之体。名称于尽知而般若体都无所知。谓常无常虚实有无如是一切不可得故。是故言不可称。又释尽知体相故得以名称其体相。而般若相无能知者。常无常等不可得故。由是道理故不可称。以是四义释不可称。是显名体不得相称也。问般若之体无所知故尽知之名不得称者。则如前释言。无知义是慧义。是名可称般若之体。答无知之名亦不称体。直是遮诠不能表示故。但遮于知非表于无故。问若尔甚深极重之言是举其体故能表示。能表示故非不可称。若甚深言亦不称者何谓此言是举体耶。答甚深等言亦遮诠。但遮浅薄不得深故。是故此言亦不称体。然论主意向般若体而发此言。就般若名说轻薄言。为显是意故言举体。非谓甚深之言能称般若之体也。问若如是者前以十义释般若名。皆不称实般若之体。亦不称于般若之业。云何而言是持业释。答般若非然故不当诸名。而非不然故能当诸名。又持业释。且是假说非谓实然故不相违也

第三释到彼岸义者。到彼岸义乃有众多。依此经论略出四义。一者从生死此岸到涅槃彼岸故名到彼岸如论释言。三乘之人以是般若到彼岸涅槃灭一切忧苦。以是义故名波罗蜜。二者从有相此岸到无相彼岸故名到彼岸。如论释言。是般若波罗蜜等以色心二法推求破坏不得坚实。以是义故名波罗蜜。三者从未满智此岸到究竟智彼岸故名到彼岸如论释言。彼岸名尽一切智慧边智。名不可破坏相。不可破坏相者即是如法性实际。以其实故不可破坏。是三事摄入般若中故名波罗蜜。四者从有此彼岸到无彼此岸。无所到故名到彼岸如下文言。此彼岸不度故名般若波罗蜜。金鼓经云生死涅槃皆妄见。能度无余故名波罗蜜。此四义中第一第三因中说果是有财释。第二第四说其已到是持业释也。若以此大慧度之名目能诠者是依主释也

第四明说经因缘者。如论说云。问曰佛以何因缘故说摩诃般若波罗蜜经。诸佛之法不以无事及小因缘而自发言。譬如须弥山王不以无事及小因缘而动。今有何等大因缘故佛说是经。答中广出众多因缘。今撮其要略出六因。一为广示菩萨行故。二为不违诸天请故。三为欲断诸人疑故。四为欲治众生病故。五为欲说第一义谛故。六为欲伏诸论议师故。初为广示菩萨行者如论说言。佛于三藏中广引种种譬喻为声闻说法。而不说菩萨道。唯中阿含本业经中佛记弥勒当得作佛。亦不说种种菩萨行。今欲为弥勒等广说诸菩萨行故说是经。二为不违诸天请者论说言。尔时菩萨菩提树下降魔众已得无上觉。是时三千大千世界主梵天王名尸弃。及色界诸天等释提桓因及欲界诸天等皆诣佛所请转法轮。亦念本愿及大慈悲故受请说法。诸法甚深者般若波罗蜜是。以是故说此经。三为欲断诸人疑者论云。有人疑佛不得一切智。所以者何。诸法无量无数云何一人能知一切法。佛住般若波罗蜜实相清净如虚空无量无数法中自发诚言。我是一切智人。欲断一切众生疑。以是故说此经。案云此中发诚言者谓不妄语。有长舌故。喻如世共知有长舌者如世典云舌长覆鼻必不妄语。依此比量证成道理证知如来所言非妄。是故如来有一切智以是断除众生疑也。四为欲治众生病者论云。一切众生为结使病之所烦恼。无始已来无人能治常为外道恶师所误。我今出世为大医王集诸法药汝等当服。以是故说此经。五为欲说第一义谛者论云。佛欲说第一义悉檀相故说是般若波罗蜜经。有四种悉檀何者为四。一者世界悉檀二者各各为人悉檀三者对治悉檀四者第一义悉檀。此四悉檀摄一切十二部经八万四千法藏。皆是实不相违背。世界悉檀者有法从缘和合故有无别性。如车辕辐轴辋和合故有无别事。人亦如是五众和合故有无别人也。问曰如经说言一人出世多人蒙度。又佛二夜经中说。佛从得道夜至涅槃夜是二夜中间。所说经教一切皆实而不颠倒。若实无人者云何说人等。答曰人等世界故有第一义故无。如如法性实际世界故无。第一义故有。人等亦如是。第一义故无世界故有。所以者何。五众因缘有故有人。非如一人第二头第三手无其因缘而有假名。如是等相名世界悉檀。云何各各为人悉檀。观人心行而为说法。于一事中或听或不听如经中说。杂报业故。杂生世间得杂触得杂受。又余经说无人得触无人得受。前为断见人后为常见人。如是等相名为各各为人悉檀。云何为对治悉檀。有法对治即有实性则无。如不净观于欲病中是善对治。于嗔病中不名为善非对治法。如是慈心于嗔是善于欲非善。如是等相名为对治。云何名第一义悉檀。一切法性一切论议一切是非一一可破。诸佛辟支佛阿罗汉所行真实法不可破不可坏。且于三悉檀中所不通此中皆通。乃至广说。案云总而言之一切教门不出二宗。所谓二谛但于世谛有多差别。故于其中分出二种。此二之余皆属初一。中二悉檀有何异者。通而言之为人悉檀无非对治。对治悉檀亦是为人。然于一事中有无异说。是由人异故名为人。不由病异以授别药。唯一事故不名对治。若说别法以治异病。病别药异故名对治。非于一事中为人异说。故于中不名为人。除此二种说世俗事皆是世界悉檀所摄。问诸佛说法无不为人。无非对治众生病者。云何初后二种悉檀不名为人不名对治。答通相而言有如来问。但为直示世俗假名又为直显胜义实相。如是二种由谛故异不由人异不由病别。是故别立初后二也。问若说人等世谛故有非如一人第二头等者。蕴界处中何法所摄。又若有人即是有我。何异犊子部所立耶。答萨婆多宗说无有人如第二头。蕴界处法所不摄故。犊子部说实有人法。不即不离虽蕴界处之所不摄。而在第五不可说藏。今大乘说因缘故有而无别性。色心等法皆亦如是。若实有人是增益边。若都无人是损减边。大乘不尔。从缘有故离损减边。无别性故离增益边。蕴界处中何法摄者。心不相应行蕴中摄。二十四中众生同分摄。当知法界法处所摄。且止乘论还述本宗。六为欲伏诸论议师者论云。欲令长爪梵志等大论议师于佛法中生信故说是经。彼若不闻般若气分离绝四句第一义法。小信尚不得何况得道果。乃至广说。长爪梵志论议因缘此中应广说。其余诸缘广如论说。说经因缘略述如是

次第五判教者分判佛教诸说不同。今且略出二说平章是非。有人说言一化教门不出二途。一者顿教二者渐教。渐教之内有其五时。一四谛教二无相教三抑扬教四一乘教五常住教。从浅至深渐次而说。今此经等诸般若教在第二时名无相教。或有说者出世教门不过三品。所谓经说三种法轮如解深密经言。胜义生菩萨白言世尊。初于一时在波罗泥斯仙人堕处施鹿林中。唯为发趣声闻乘者以四谛相转正法轮。虽是甚奇甚为希有。而是法轮有上有容。是未了义是诸诤论安足处所。世尊在昔第二时中唯为发趣修大乘者。依一切法空无自性无生无灭本来寂静自性涅槃。以隐密相转正法轮。而是法轮亦是有上是未了义是诸诤论安足处所。世尊于今第三时中普为发趣一切乘者。依一切法空无自性无生无灭。本来寂静自性涅槃无自性性。以显了相转正法轮。无上无容是其了义。非诸诤论安足处所。今此大品并诸般若皆是第二法轮所摄。问是二师说何者为实。答二种教门三种法轮是就一途亦有道理。然其判此大品经等皆属第二时摄。第二法轮者理必不然。违经论故。如此论释毕定品言。须菩提闻法华经说若于佛所作小功德。乃至戏笑一称南无佛。渐渐必当作佛。又闻阿鞞跋致品中有退不退如法华经中。毕定余经说有退有不退。是故今问为毕定为不毕定。乃至广说。以是验知说是经时在法华后。即示第二时者不应道理也。问若判此经在法华后者是说云何通。如仁王经言尔时大众各相谓言。大觉世尊前已为我等大众二十九年说摩诃般若金刚般若天王问般若光赞般若波罗蜜。今日如来放大光明斯作何事。答摩诃般若非一众多。有在前说有在后说如论说言。此经二万二千偈。大般若十万偈。若龙王宫阿修罗宫天宫中者千亿万偈。乃至广说。以是义故不相违也。又此论云复次有二种说法。一者诤处二者无诤处。诤处者如余经。今欲明无诤处故说是摩诃般若波罗蜜经。以此证知。今此经者同于第三显了法轮。非诸诤论安足处故。而判此经等示第二法轮。是即此经为诤论处。不应谓论说是无诤。又此经言欲求三乘菩提当学般若波罗蜜。又言波若波罗蜜中虽无法可得。而有三乘之教乃至广说。如解深密经中。亦言一切声闻独觉菩萨皆是一妙清净道。当知此经同彼第三普为发趣一切乘者。以显了相转正法轮。而彼第二法轮中言唯为发趣修大乘者。何得以此属彼第二。又此经如化品言。若法有生灭者如化。若法无生无灭。所谓无诳相涅槃。是法非变化。须菩提言如佛所说一切诸法性空。非声闻作乃至非诸佛作。云何涅槃一法非如化。佛言如是如是。一切法性常空。若新发意菩萨闻一切法皆是性空乃至涅槃亦皆如化心即惊怖。为是新发意菩萨故分别生灭者如化不生灭者不如化。须菩提言。世尊云何令新发意菩萨知是性空。佛告须菩提。诸法先有今无耶。以是文证当知。此经说涅槃法亦无自性。而彼第二法轮中言一切诸法无生无灭本来寂静自性涅槃。不言涅槃无自性性。第三了义法轮中言一切诸法无生无灭乃至涅槃无自性性。以是故知。今此经宗超过第二同第三也。又华严经云。生死及涅槃是二悉虚妄愚智亦如是。二皆无真实。今此经云。色受想等如幻如梦乃至涅槃如幻如梦。若当有法胜涅槃者。我说亦复如幻如梦。当知此经同彼华严无上无容究竟了义。但其教门各各异一耳。第五判教略述如之

第六消文依论广释

大慧度经宗要终


大毗卢遮那成佛经疏

    No. 1796 [cf. No. 848]

大毗卢遮那成佛经疏卷第一

        沙门一行阿阇梨记

    入真言门住心品第一

大毗卢遮那成佛神变加持者。梵音毗卢遮那者。是日之别名。即除暗遍明之义也。然世间日则有方分。若照其外不能及内。明在一边不至一边。又唯在昼光不烛夜。如来智慧日光则不如是。遍一切处作大照明矣。无有内外方所昼夜之别。复次日行阎浮提。一切卉木丛林。随其性分各得增长。世间众务因之得成。如来日光遍照法界。亦能平等开发无量众生种种善根。乃至世间出世间殊胜事业。莫不由之而得成办。又如重阴昏蔽日轮隐没。亦非坏灭。猛风吹云日光显照。亦非始生。佛心之日亦复如是。虽为无明烦恼戏论重云之所覆障。而无所减。究竟诸法实相三昧圆明无际。而无所增。以如是等种种因缘。世间之日不可为喻。但取其少分相似故。加以大名。曰摩诃毗卢遮那也。成佛者具足梵音。应云成三菩提。是正觉正知义。谓以如实智。知过去未来现在。众生数非众生数。有常无常等一切诸法。皆了了觉知故名为觉。而佛即是觉者。故就省文但云成佛也。神变加持者。旧译或云神力所持。或云佛所护念。然此自证三菩提。出过一切心地。现觉诸法本初不生。是处言语尽竟心行亦寂。若离如来威神之力。则虽十地菩萨。尚非其境界。况余生死中人。尔时世尊往昔大悲愿故。而作是念。若我但住如是境界。则诸有情不能以是蒙益。是故住于自在神力加持三昧。普为一切众生。示种种诸趣所喜见身。说种种性欲所宜闻法。随种种心行开观照门。然此应化。非从毗卢遮那身或语或意生。于一切时处。起灭边际俱不可得。譬如幻师。以咒术力加持药草。能现种种未曾有事。五情所对悦可众心。若舍加持然后隐没。如来金刚之幻亦复如是。缘谢则灭机兴则生。即事而真无有终尽。故曰神力加持经。若据梵本。应具题云大广博经因陀罗王。因陀罗王者帝释也。言此经是一切如来秘要之藏。于大乘众教威德特尊。犹如千目为释天之主。今恐经题大广故不具存。入真言门住心品者。梵本具有二题。初云修真言行品。次云入真言门住心品。窃谓入住之义以兼修行语。故离烦文但着其一。真言梵曰漫怛攞。即是真语如语不忘不异之音。龙树释论。谓之秘密号。旧译云咒。非正翻也。此品统论经之大意。所谓众生自心。即是一切智智。如实了知。名为一切智者。是故此教诸菩萨。真语为门。自心发菩提。即心具万行。见心正等觉。证心大涅槃。发起心方便。严净心佛国。从因至果。皆以无所住而住其心。故曰入真言门住心品也。入真言门略有三事。一者身密门。二者语密门。三者心密门。是事下当广说。行者以此三方便。自净三业。即为如来三密之所加持。乃至能于此生。满足地波罗密。不复经历劫数。备修诸对治行。故大品云。或有菩萨初发心时。即上菩萨位得不退转。或有初发心时。即得无上菩提便转法轮。龙树以为如远行。乘羊去者久久乃到。马则差速。若乘神通人。于发意顷便至所诣。不得云发意间云何得到。神通相尔不应生疑。则此经深旨也

经云。如是我闻。一时薄伽梵。住如来加持法界宫者。经初五义。如智度中广明。然此经梵本。阙无通序。阿阇梨云。毗卢遮那大本。有十万偈。以浩广难持故。传法圣者。采其宗要凡三千余颂。虽真言行法文义略周。以非大经正本故。不题通序。今以例加之。于义无伤也。薄伽梵者。论师所解具有六义。今此宗中。薄伽梵是能破义。如人执持利器多所摧伏。其本未有此名。世议观其事迹。故号为能破者。世尊亦尔。以大智明。破一切识心无明烦恼。此等本自无生亦无相貌。然慧日出时。暗惑自除。是故义名为破。释论亦云。婆伽名破婆名能破。能破淫怒痴。故名婆伽婆。二乘虽破三毒。亦不了了尽。如盛香器余气故在。又如草木薪火。以力薄故。灰炭不尽。如来如劫烧火。一切都尽无烟无炭。故名婆伽婆。复次帝释声论。谓女人为薄伽。是欲求因缘。能息烦恼义。又是所从生义。金刚顶宗。即翻此义。云女人者。即是般若佛母。无碍知见人。皆悉从是生。其有志求因缘得与相应。烦恼戏论皆悉永息。非如世间欲热虽小止息。而实更增也。以密教不可直宣故。多有如是隐语。学者当触类思之。又薄伽梵者。即带有声。如人多有资财。名持资财者。以有金故。名持金者。以如来具殊胜德故。名持众德者。释论亦云。婆伽言德。婆者言有。是名有德。婆伽名名声。婆者言有。是名有名声。一切世间。无有德名声如佛者。则其义也。经中多译为世尊。是叹德之总称。西方语法。言及尊者。不敢直斥其名。必先叹其功德。如云大智舍利弗。神通目揵连。头陀大迦叶。持律优婆离等。故此经中。例云薄伽梵毗卢遮那。今顺此方文势。或以世尊居下也

经云。薄伽梵住如来加持者。薄伽梵即毗卢遮那本地法身。次云如来。是佛加持身。其所住处。名佛受用身。即以此身。为佛加持住处。如来心王。诸佛住而住其中。既从遍一切处加持力生。即与无相法身。无二无别。而以自在神力。令一切众生。见身密之色。闻语密之声。悟意密之法。随其根性分种种不同。即此所住名加持处也。次又释叹加持住处。故云广大金刚法界宫。大谓无边际故。广谓不可数量故。金刚喻实相智。过一切语言心行道。适无所依。不示诸法。无初中后。不尽不坏。离诸过罪。不可变易。不可破毁。故名金刚。如世间金刚宝。有三事最胜。一者不可坏故。二者宝中之上故。三者战具中胜故。此与释论三种金刚三昧中喻。意大同。法界者。广大金刚智体也。此智体者。所谓如来实相智身。以加持故。即是真实功德所庄严处。妙住之境心王所都。故曰宫也。此宫是古佛成菩提处。所谓摩醯首罗天宫。释论云。第四禅五种。那含住处。名净居天。过是以往。有十住菩萨住处。亦名净居。号曰大自在天王是也。今此宗明义。以自在加持神心所宅故。名曰自在天王宫也。谓随如来有应之处。无非此宫。不独在三界之表也。一切持金刚者皆悉集会。次明妙眷属也。如来在此宫中。为独处耶有眷属乎。故云此中乃有无边眷属常所集会。所谓执金刚等也。梵云伐折罗陀罗。此伐折罗。即是金刚杵。陀罗是执持义。故旧译云执金刚。今谓持金刚。兼得深浅二释。于义为胜。故随文便互为其辞。若世谛常途所表。则云生身佛。常有五百执金刚神。翌从侍卫。然此宗密意。伐折罗是如来金刚智印。如是智印其数无量。能持此者亦复无边。所以然者。心王所住之处。必有尘沙心数。以为眷属。今者心王毗卢遮那。成自然觉。尔时一切心数。无不即入金刚界中。成如来内证功德差别智印。如是智印。唯佛与佛乃能持之。约菩提义。即有无量无边金刚印。约佛陀义。即有无量无边持金刚者。由此众德。悉皆一相一味到于实际。故名集会。若少分未等一法未满。即不名一切集会也。然以自在神力所加持故。即从心王毗卢遮那。现加持尊特身。尔时无量法门眷属。一一皆现执金刚身。显发如来威猛大势。譬如帝释。手执金刚。破修罗军。今此诸执金刚。亦复如是。各从一门。持大空之战具。能坏众生无相之烦恼。故以相况也。如来信解游戏神变生。大楼阁宝王高无中边。诸大妙宝王种种间饰。菩萨之身为师子座者。大众已集。应有说法处。故次明所住楼阁及师子座也。信解者。始从真正发心乃至成佛。于是中间通名信解地。梵云微吃哩抳多。是踊跃义。游戏义。神变义。谓从初发心以来。深种善根。起种种愿行。庄严佛土。成就众生。恒殊胜进。不休息故。即是超升腾跃义。如人掉动鼓舞。能以善巧三业。普悦众心。故此腾跃。即名游戏。如是游戏。即是菩萨自在神通。言毗卢遮那本行菩萨道时。以一体速疾力三昧。供养无量善知识。遍行无量诸度门。自利利他法皆具足。能得如是如来智宝之所集成。秘密庄严法界楼观。于一切实报所生最为第一。犹如真陀摩尼为诸宝之王。故曰游戏神变生大楼阁宝王也。其高无穷。当知广亦无际。以边不可得故。亦复无中。此是遍一切处身之所住处。当知如是楼观。亦遍一切处也。次明楼观庄严之相。犹如有人以种种杂色金刚。严饰金刚。然其体性无有差别。今亦如是。还以如来种种功德宝王。间饰楼阁宝王。何以故。更无有法出如是宝性故。然此第一寂灭之相。以如来加持神力。令应度者随诸法门表像。若可见闻触知。即以此为门而入法界。如善财童子。入弥勒宫殿因缘。此中应广明菩萨之身为师子座者。上说金刚法界宫。即是如来身。次云大楼阁宝王。亦即是如来身。今云师子座。当知亦尔。所以云菩萨身者。谓本行菩萨道时。次第修行地波罗蜜。乃至第十一地。当知后地。即以前地为基。故云如来以菩萨身为师子座。释论云。譬如师子于众兽中。独步以无畏。佛亦如是。于九十六种外道中。一切降伏无畏。故名人中师子。其所坐处。若床若地。皆名师子座。今此宗明义。言师子者。即是勇健菩提心。从初发意以来。得精进大势。无有怯弱。犹如师子随所执缚。必获无遗。即是自在度人无空过义也。若浅略释者。言诸菩萨深心敬法。乃至以身荷戴佛。师子座。故曰菩萨之身为师子座也。其金刚名曰虚空无垢执金刚。乃至金刚手秘密主。如是上首。十佛刹微尘数等持金刚众俱。及普贤菩萨。慈氏菩萨。妙吉祥菩萨。除一切盖障菩萨等。诸大菩萨前后围绕。而演说法者。次明同闻众也。问曰。佛所说经。何故先明住处眷属耶。答曰。譬如国王若有政令。必先出居外朝制断刑赏。时史署记云。某时王在某处。与某甲大臣等集议。有如是教命。欲令境内信伏行之不疑故。法王亦尔。将说大法。必于大眷属菩萨众中令作证明。以是因缘闻者生信。由信心故。能入如是法中。修行得证。倍复生信。故先列众也。虚空无垢执金刚者。即是菩提心体。离一切执诤戏论。如净虚空无有障翳。无垢无染亦无分别。如此之心。即是金刚智印。能持此印。名虚空无垢执金刚也。复次虚空游步执金刚者。游步是不住义。胜进义。神变义。以净菩提心。于一切法都无所住。而常进修万行起大神通。故曰虚空游步。复次虚空无垢执金刚。即阿字门平等种子。修无住行。譬如种殖方便根牙渐生。故次明发行金刚印也。第三虚空生执金刚者。如萠芽已生。四大时节为缘。虚空不碍念念滋长。菩提心亦复如是。以无所得为方便。万行为缘。得真实生者。所谓大空生。故名虚空生。第四被杂色衣执金刚者。如萌芽增长。茎叶花。实渐次滋繁。菩提心树王万德开敷。亦复如是。故云具种种色。复次以种种法界色。染此无垢菩提心。成大悲漫荼罗。故名被杂色衣。第五善行步执金刚者。此善字。梵云毗质多罗。有端严义。种子义。譬如已得果实。复还为种子也。善行步者。即是诸佛威仪。谓善知时宜可度不可度等种种通塞。以身口意方便。俯应群机。曲中规矩。皆成佛事。故以为名也。第六住一切法平等执金刚者。谓住一切佛平等性也。谓因果自他有为无为等一切诸法。入此如实智中。究竟平等。同一实际。能持此智印。故以为名也。然上来五句。亦皆是如来真实功德。无深浅之殊。为欲分别令易解故。作次第说耳。第七哀愍无量众生界执金刚者。此哀愍亦名救度。谓已住平等法性。自然于一切众生。发同体悲愍之心。诸众生界无量故。如是大悲亦无限量。此是如来一功德。故能持者。因以为名。第八那罗延力执金刚者。已发哀愍之心。若具大势。则能救护。故次明也。经中挍量六十象力。不如一香象力。乃至末后那罗延力最胜。佛生身一一毛孔。皆等那罗延力。故以喻法界身那罗延力。第九大那罗延力执金刚者。谓持秘密神通力也。如一阐提必死之疾。二乘实际作证已死之人。诸佛医王明见如来性故。则能必定师子吼。于救疗因缘。心不怯弱。诸菩萨尚不能尔。故复明不共一切摩诃那罗延力。第十妙执金刚者。妙名更无等比。更无过上义。犹如醍醐融妙已极。不可复增。常不变易。无间无杂。如来亦尔。一切功德。悉皆无比无上。诸有所作。亦唯为此一事因缘。故名妙执金刚。第十一胜迅执金刚者。胜谓大空。大空即是遍一切处。故能起速疾神通也。住此乘者。初发心时即成正觉。不动生死而至涅槃。故名胜迅。第十二无垢执金刚者。即是离一切障菩提心也。譬如真金体性纯净。若种种练冶众宝磨莹倍复光明。则知初质。尚与微垢共住。能持此毕竟净金刚印。因以为名。十三刃迅执金刚者。此刃字。梵文是忿中之忿利中之利。义翻犹如刀刃也。持此金刚利智。一切难断处悉断。难灭处悉灭。故以为名。十四如来甲执金刚者。如来甲所谓大慈。由此严身故。摄护众生施作佛事。不为一切烦恼所伤无能降伏俎坏之者。故以为名。十五如来句生执金刚者。句名住处。即大空生也。诸佛自证功德。从如来性生。此加持身。从如来自证功德生。以不离阿字门故。名如来句生。十六住无戏论执金刚者。所谓住大空慧也。谓观缘起实相。无生无灭不断不常。亦非去来一异。是处诸戏论息。法如涅槃。持如是智印。故得以为名也。十七如来十力生执金刚者。谓佛方便智。如是妙权从何处生。谓从如来十智力生。持如是印。故得以为名也。十八无垢眼执金刚者。即如来五眼。以菩提心毕竟净故。以一切种观一切法。了了见闻觉知。无所挂碍。能持如是金刚印。故以为名。十九金刚手秘密主者。梵云播尼。即是手掌。掌持金刚与手执义同。故经中二名互出也。西方谓夜叉为秘密。以其身口意。速疾隐秘难可了知故。旧翻或云密迹。若浅略明义。秘密主。即是夜叉王也。执金刚杵常侍卫佛。故曰金刚手。然是中深义。言夜叉者。即是如来身语意密。唯佛与佛乃能知之。乃至弥勒菩萨等。犹于如是秘密神通。力所不及。秘中最秘。所谓心密之主。故曰秘密主。能持此印。故云执金刚也。如是上首十佛刹微尘数等持金刚众俱者。若具存梵本。于列名下。一一皆有多声。应云虚空无垢等。虚空游步等。乃至秘密主等。所以然者。此等上首执金刚。一一皆有无量眷属部类。大本当具存耳。然统其纲要。则枝末随之。于宗通之用。不足为阙。所云十佛刹微尘数者。如来差别智印。其数无量。非算数譬喻之所能知。且以如来十种智力。各对一佛刹微尘。以表众会之数。世界海世界性。及一佛刹义。如释论中广明。然此毗卢遮那内证之德。以加持故。从一一智印。各现执金刚身。形色性类。皆有表象。各随本缘性欲。引摄众生。若诸行人殷勤修习。能令三业同于本尊。从此一门得入法界。即是普入一切法界门也。次列菩萨众。以四圣者而为上首。前明诸执金刚。一向是如来智印。今此菩萨。义兼定慧又兼慈悲。故别受名也。亦是毗卢遮那内证功德。如执金刚有十佛刹微尘数众。当知诸菩萨。法门相对。亦有十佛刹微尘众。以加持故。各得从法界一门。现为一善知识身也。又般若释论。生身佛成道时。阿难密迹力士等。是名内眷属。舍利弗目建连等诸圣人。及弥勒文殊诸阿毗跋致。一生补处菩萨等。是名大眷属。今谓佛加持身亦复如是。诸执金刚各持如来密印。名内眷属。诸菩萨大悲方便普门。摄受无量众生。辅佐法王。行如来事。名大眷属。故大品云。欲为诸佛内眷属。欲得大眷属者。当学般若波罗蜜也。普贤菩萨者。普是遍一切处义。贤是最妙善义。谓菩提心所起愿行。及身口意。悉皆平等遍一切处。纯一妙善备具众德。故以为名。慈氏菩萨者。谓佛四无量心。今以慈为称首。此慈从如来种姓中生。能令一切世间不断佛家。故曰慈氏。上云普贤。是自证之德。本愿已满。欲化众生令得此道。故次明之。妙吉祥菩萨者。妙谓佛无上慧。犹如醍醐纯净第一。室利翻为吉祥。即是具众德义。或云妙德。亦云妙音也。言以大慈悲力故。演妙法音。令一切闻。故次弥勒明之。除一切盖障菩萨者。谓障为众生种种心垢。能翳如来净眼。不能开明。若以无分别法。灭诸戏论。如云雾消除日轮显照。故曰除盖障。如来诸有所作。悉皆为此一事因缘。故次妙音明之。复次行人。虽学般若波罗蜜。若无禅定。犹如盲者虽遇日光。无所能为。故次文殊妙慧。明除盖障三昧也。此四菩萨。即是佛身四德。有所偏阙。则不能成无上菩提。是故列为上首。以统尘沙众德。诸大菩萨者。具出梵文。应云摩诃菩提萨埵。释论云。菩提名诸佛道。萨埵名众生。或名勇心。是人尽欲得诸佛功德。其心不可断不可破。如金刚山。是名萨埵。复次此人。心能为大事。不退不转。大勇心故。多众生中。起大慈悲成立大乘。能行大道得最大处。故必能说法。破一切众生大邪见大爱大我心等诸烦恼。故名为摩诃萨埵。阿阇梨云。具据正义。当云菩提索哆。此索哆者。是忍乐修行坚持不舍义也。然声明有如是法。若论文字。其义虽正。音韵或不流便者。得取便安之。故世论师谓为萨埵。传习者随顺其辞。就踰伽宗。萨埵略有三种。一者愚童萨埵。谓六道凡夫。不知实谛因果。心行邪道修习苦因。恋着三界坚执不舍。故以为名。二者有识萨埵。即二乘也。才觉知生死过患。自求出离。得至涅槃。着保化城兴灭度想。于如来功德。未生愿乐心。故以为名。三者菩提萨埵。无上菩提。出过一切臆度戏论种种过失。是一向纯善白净微妙不可譬类之义。即是众生本性不思议心也。能忍如是成道事。愿乐修行坚固不动。故名菩提索哆。于如是人中功业最大。堪能转授一切众生。故名为摩诃萨埵。此等大众。前后围绕大日世尊。以无量身口意供养恭敬。为听法故。次明群机嘉会之时所同闻法。即经所谓越三时如来之日加持故。身语意三平等句法门也。然此经流布阎浮提。略有十万偈。若十物刹微尘大众。各各广演身口意差别法门。则无限量。此说法时分。复当云何。故结集者云。尔时住于佛日而演说法者也。如世间时分。则有过去未来现在。长短劫量种种不同。且约日行四天下。一周昼夜各有初中后分。乃至三十时等。刹那不住代谢相推。以净眼观之。三际之相了不可得。无终无始亦无去无来。即此实相之日。圆明常住湛若虚空。无有时分修短之异。然以佛神力故。令瑜伽行者于无量劫。谓如食顷。或演食顷以为无量劫。延促自在咸适众机。无定相可得。故云如来日也。如此时中佛说何法。即是身语意三平等句法门。言如来种种三业。皆至第一实际妙极之境。身等于语。语等于心。犹如大海遍一切处同一碱味。故云平等也。句者梵云钵昙。正翻为足。声论是进行义住处义。如人进步举足下足。其迹所住处谓之钵昙。言辞句逗义亦如是。故同一名耳。今就此宗。谓修如是道迹。次第进修。得住三平等处。故名为句。即以平等身口意秘密加持。为所入门。谓以身平等之密印。语平等之真言。心平等之妙观。为方便故。逮见加持受用身。如是加持受用身。即是毗卢遮那遍一切身。遍一切身者。即是行者平等智身。是故住此乘者。以不行而行。以不到而到。而名为平等句。一切众生皆入其中。而实无能入者无所入处。故名平等。平等法门。则此经之大意也。时彼菩萨普贤为上首。诸执金刚秘密主为上首。毗卢遮那如来加持故。奋迅示现身无尽庄严藏。乃至有情类业寿种除。复有牙种生起者。谓将说此平等法门。故先以自在加持感动大众。悉现普门境界秘密庄严。不可思议未曾有事。因彼疑问而演说之。则闻者信乐倍增。深入语义。如法华序分。从地踊出品因缘。此中当广说之。复次普贤秘密主等。上首诸仁者。即是毗卢遮那差别智身。于如是境界。久已通达。然此诸解脱门所现诸善知识。各引无量当机众。同入法界漫荼罗。为饶益此初入法门实行诸菩萨故。如来加持。奋迅示现大神通力也。如师子王将欲震吼。必先奋迅其身。呈现材力然后发声。如来亦尔。将欲必定师子吼。宣说一切智门。故先奋迅示现无尽庄严藏。所谓庄严者。谓从一平等身。普现一切威仪。如是威仪。无非密印。从一平等语。普现一切音声。如是音声。无非真言。从一平等心。普现一切本尊。如是本尊。无非三昧。然此一一三业差别之相。皆无边际不可度量。故名无尽庄严也。如来秘密慧经云。除盖障菩萨于法会中。欲知佛身量故。令大目揵连寻之。目连上至梵宫。犹睹如来若对目前。佛身威仪说法音声。与本无异。乃至尽其神力。往诣他方佛土。亦不异梵宫。尔时除盖障菩萨及以目连。不能测故。自往观察。过十方各如恒河沙世界。皆见如来。不起于座而演说法。乃至周极十方尽其神通势力。亦复如是。然后还归。方见除疑天女。去佛不远见入于三昧。便作是念。我闻此天女。通达无量三昧门。我当观之。今住何定也。又尽心力观之。不测其心所行之处。聚集无量天鼓。一一皆如须弥山王。以神力同时发声。欲令出定而不能得。乃至佛言。我未发菩提心时。是天女已能住此三昧。即是无边际义也如是毗卢遮那。普于十方一切世界。一一皆现佛加持身。是一一身。各有十佛刹微尘数等。菩萨金刚大众。此诸大众诸根相好。亦复无边如胡麻油。遍满法界于中无空隙处。又如国王有大库藏。若须示人。则自在开发而陈布之。故曰庄严藏也。复次此诸大众。但以佛威神力故。得见如是不思议境界。如来若舍加持。即不现前。非其自心限量之所能及。如行者内修般舟三昧。外蒙神力护持。能以父母生身见十方佛。如晴夜光无云仰睹众星。听闻法音了了无碍。然此境界。由行者心净故生耶。由佛加护故生耶。若由内心。即是从自性生。若由佛力。即是从他性生。悉皆不异外道论义。以自他无故。和合亦无。又复非无因缘而得成就。何以故。内因外缘随有所阙。即不现前故。当知如是庄严之相。显时无所从来。隐时亦无所去。毕竟平等不出于如故。经云非从毗卢遮那佛身或语或意生。一切处起灭边际不可得。而毗卢遮那一切身业。一切语业。一切意业。一切处一切时。于有情界。宣说真言道句法。此转释佛庄严藏。所以无尽无边际者。以不异如来遍一切处常住不灭之身也。虽常无起灭。而能以一切三业。普于十方三世一切时处。说最实道教化群生。轨匠其心令至佛道

经云。又现执金刚普贤莲华手菩萨等像貌。普于十方。宣说真言道清净句法。所谓初发心。乃至十地次第此生满足。缘业生增长有情类业寿种除。复有牙种生起者。又广前相。言非但示现佛身。充满十方一切世界。所现金刚菩萨等身。亦复遍一切处也。且如十佛刹微尘数。诸执金刚菩萨等。身口心印差别不同。如是一一本尊像类眷属。皆如毗卢遮那。充满十方一切世界。如因陀罗网互不相妨。今略举三圣者。以为称首也。执金刚对金刚智慧门。降伏方便。普贤对如如法身门。寂灾方便。观音对莲华三昧门。增益方便。举此三点。则无量不思议妙用。皆已摄在其中。故特言之。所云等者。乃至诸天八部五通神仙。以外现漫荼罗之所表示。例可知也。如是等种种因缘无数方便。普门应现教化群生。虽深浅不同粗细有异。然究其实事。无非秘密加持。各能开示如来清净知见。若离如是实相印。余皆爱见所生。与天魔外道作诸营侣。岂得名为清净句义耶。次又释言所谓清净句者。即是顿觉成佛神通乘也。若余乘菩萨。志求无上菩提。种种勤苦不惜身命。经无数阿僧祇劫。或有成佛或不成佛者。今此真言门菩萨。若能不亏法则方便修行。乃至于此生中逮见无尽庄严加持境界。非但现前而已。若欲超升佛地即同大日如来。亦可致也。复次行者。初发心时得入◇阿字门。即是从如来金刚性生牙。当知此牙一生。运运增进更无退义。乃至成菩提。无行可增。然后停息。故云次第此生满足。此中次第者。梵音有不住义精进义遍行义。谓初发心。欲入菩萨位故。于此真言法要。方便修行。得至初地。尔时以无所住进心不息。为满第二地故。复依真言法要方便修行。得至第三地。尔时以无所住进心不息。为满第四地故。复依真言法要方便修行。得入五地。如是次第。乃至满足十地。唯以一行一道。而成正觉。若于异方便门开显密意。亦皆不离如是宝乘也。缘业生者。谓为有情痴爱因缘。造身口意种种虚妄不清净业。乘如是业生六趣身。增长轮回备受诸苦。今修平等三业清净慧门。一切蕴阿赖耶业寿种子。皆悉焚灭。得至虚空无垢大菩提心。一切如来平等种子。从悲藏中生法性牙。乃至茎叶华果遍满诸法界。成万德开敷菩提树王。然以四不生义观之。都无所起亦无起处。当知此生。即是大空生也。故云有情类业寿种除复有牙种生起。复次如来所现。十佛刹微尘数等。诸善知识及法界门。假令次第观听。则无量无边阿僧祇劫。不可周遍。以佛日加持故。于会坐之顷皆悉现前。即是将说此经。示不可思议神通瑞相也。如文殊师利。睹见白豪所照万八千土。诸菩萨种种因缘。皆是行菩萨道。即知诸佛。将欲开权显实说法华经。当知金刚手等。亦复如是普见加持世界。唯说平等法门。即知如来。将演遍一切乘自心成佛之教。故下文所问。乘此而生也。尔时执金刚秘密主。于彼众会中。坐白佛言。世尊云何如来应供正遍知。得一切智智。乃至如是智慧。以何为因。云何为根。云何究竟者。如来自证之智。设以神力加持。亦不可示人。前云奋迅示现无尽庄严藏者。皆外用之迹耳。智者见其条末。则喻其宗本。如观象迹超绝众群。其所踊践倍复深广。虽不睹其形。当知此象。身力必大。又如迅雷澍雨。能令鸟兽震死。百川奔涌坏山襄陵。虽不测其本。当知此龙威势必大。今诸大众亦复如是。以观如来无尽身口意。能一时普应法界众生。妙合根宜曲成佛事。则知如来智力。必于一念。普鉴群机本末因缘究竟无碍。照俗之权尚尔。其契实之境界。当复云何。若法不然。则有微迹可寻。我已尽睹然。不知是法从何得之。故执金刚手因众会疑心。而问佛言。云何如来应供正遍知。得此一切智智也。梵本云怛他揭多者。怛他是如义。揭多是来义。知解义说义去义。如诸佛乘如实道。来成正觉。今佛亦如是来。故名如来。一切诸佛。如法实相知解。知已。亦如诸法实相。为众生说。今佛亦如是。故名如实知者。亦名如实说者。一切诸佛。得如是安乐性。直至涅槃中。今佛亦如是去。故名如去。释论具含四义。然古译多云如来。有部戒本云如去。阿阇梨意存如去如说。今且顺古题也。梵本云阿罗诃者。阿罗是烦恼。诃是害义除义。释论谓之杀贼。佛以忍进铠甲。乘持戒之马。定弓慧箭。外破魔王军。内灭烦恼贼。故以为名。又阿名为不。罗诃名生。谓佛心种子。后世田中不生矣。无明壳皮脱故。复次阿罗诃。是应受供养义。以有如是功德故。应受天人最上供养。故以为名也。梵本云三藐三佛陀者。三藐名正。三名遍。佛陀名知。故曰正遍知也。释论云。若有人言何以故。但佛如实说如来如去故。应受最上供养耶。以佛得正遍智慧故。正名诸法不动不坏相。遍名不为一法二法。故以悉知一切法无余。是名三藐三佛陀。然此宗中。佛陀名觉。是开敷义。谓由自然智慧。遍觉一切法。如盛开敷莲华无有点污。亦能开敷一切众生。故名佛也。梵云萨婆若那。即是一切智智。释论云。萨婆若多者。即一切智。一切谓名色等无量法门。各摄一切法。如是无量三四五六等。乃至阿僧祇法门摄一切法。是一切法中。一相异相漏相非漏相。作相非作相等一切法。各各相各各力。各各因缘各各果报。各各性各各得各各失。一切智慧力故。一切世一切种尽遍知解。是名萨婆若。今谓一切智智。即是智中之智也。非但以一切种遍知一切法。亦知是法究竟实际常不坏相。不增不减犹如金刚。如是自证之境。说者无言观者无见。不同手中庵摩勒果。可转授他人也。若可以言语授人者。释迦菩萨蒙定光授决之时。即应成佛。何故具修方便。要待无师自觉。方名佛耶。又如目睹世人。为刀杖所伤。虽复信其受苦无可疑惑。然种种令说终不证知。若自身触受乃得明了耳。问意言。云何令我等。逮得如是自觉之慧。云何得此慧已。能为无量众生。广演分布。随种种趣种种性欲。种种方便道。宣说一切智智。所谓安立无量乘。示现无量身。各各同彼言音。住彼威仪。而此一切智道。犹同一味。所谓如来解脱味。此妙方便。复云何而得也。此中种种趣者。梵云娜衍亦名为行亦名为道。下云大乘道等义同也。毗婆沙说有五道。摩诃衍人多说六道。如是广衍。乃至此世界中。已有卅六俱胝众生趣。何况十方一切世界耶。性欲者。欲名信喜好乐。如孙陀罗难陀好五欲。提婆达多好名闻等。乃至诸得道人。亦各有所好。大迦叶好头陀。舍利弗好智慧。离波多好坐禅。优婆离好知毗尼。阿难好多闻等。当广说之。性名积习。相从性生。欲随性作行。或时从欲为性。习欲成性。性名染心。染心为事欲名随缘起。是事释论中具明。种种方便道者。龙树云。般若与方便本体是一。而所用有异。譬如金师以巧方便故。以金作种种异物。虽皆是金。而各异名。今毗卢遮那亦复如是。能以遍一切处真金智体。造种种乘。复次此中问意。即是发起大悲胎藏漫荼罗也。于萨婆若平等心地。画作诸佛菩萨。乃至二乘八部等。四种法界圆坛。此一一本尊身语心印。皆是一种差别乘也。且如有人志求五通智道。即从大悲胎藏。现韦陀梵志形。为说瞿昙仙等真言行法。行者精勤不久。成此仙身。更转方便。即成毗卢遮那身也。如是或现佛身说种种乘。乃至现非人身说种种乘。随类形声。悉是真言密印。或久或近。无非毒鼓因缘。故经云。皆同一味所谓如来解脱味也。所以然者。一切众生色心实相。从本际已来。常是毗卢遮那平等智身。非是得菩提时。强空诸法便成法界也。佛从平等心地。开发无尽庄严藏大漫荼罗已。还用开发众生平等心地。无尽庄严藏大漫荼罗。妙感妙应。皆不出阿字门。当知感应因缘所生方便。亦复不出阿字门。譬如大海中。波涛相激迭为能所。然亦皆同一味。所谓碱味也。复次执金刚承佛神力。为欲发起大悲胎藏秘密方便故。复说五种譬喻。所谓虚空地水火风也。初句云譬如虚空界离一切分别。无分别无无分别。如是一切智智。离一切分别。无分别无无分别者。如此即是毗婆沙义。虚空无过无德。今如来智身。离一切过万德成就。云何得相喻耶。但取其少分相似。以况大空耳。此中相况有三义。一者虚空毕竟净故。二者无边际故。三者无分别故。一切智心性亦如是。故以世间易解空。譬难解空也。初云离一切分别。梵云劫跛。次云无分别者。梵云劫跛夜帝。所以重言。是分别之上更生分别义。例如寻伺。略观时名寻。谛察名伺。又如眼识生时有粗分别。次意识生是细分别。旧译或云。以劫跛为妄执。喻意云。犹如虚空以无妄执分别故。无分别亦无无分别也。又如虚空离种种显形色相。无所造作。而能含容万像。一切草木因之生长。有情事业依之得成。佛智虚空亦复如是。虽离一切相常无分别起作。而无量度门种种妙业。皆得成辨。故以为喻也。第二句云譬如大地一切众生依。如是一切智智。天人阿修罗依者。如世间百谷众药卉木丛林。随其性分无量差别。皆从大地而生根牙。乃至茎叶花果次第成就。为一切众生作依止处。而养育之。亦不作是念。我今荷负一切世间。不念恩德无有劳倦。增之不喜减之不忧。深广难测不可倾动。一切智地亦复如是。大悲漫荼罗一切种子之所出生。即此诸乘无量事业所依止处。于生死涅槃其心平等。世间八风不能动摇。以如是等少分相似故。以为喻也。第三句云譬如火界烧一切薪无有厌足。如是一切智智。烧一切无智薪无厌足者。譬如火种。假使积薪充满世界。皆如须弥山王。次第焚之无有怯弱。不作是念。我当烧尔所薪。不烧尔所薪。炽然不息胜进无厌。要所焚尽已。然后随灭。如来智火亦复如是。烧一切戏论烦恼薪尽。乃至缘待皆尽。即此慧光亦无所依。复次如世间之火。贵贱所同用。能于暗夜而作照明。迷惑颠坠者咸得正路。又悉能成就一切诸物。如是一切智火。圣者异生平等有之。于无始大夜之中。令诸行人见如实道。次第成就一切佛法。故以为喻也。第四句云譬如风界除一切尘。如是一切智智。除去一切诸烦恼尘者。如大风起时。烟云尘雾一切消除。大虚澄廓三辰炳现。蔚蒸热恼众生皆得清凉。能使卉木丛林开荣增长。亦能摧坏一切物类。又如风性遍无所依。自在旋转无能挂碍。如来慧风亦复如是。涤除一切障盖烦恼游尘。令证涅槃清凉法性。又复能令一切世出世间善法增长。摧坏无明大树。拔其根本。而此无障碍力。都无所依。故以为喻也。第五句云譬如水界。一切众生依之欢乐。如是一切智智。为诸天世人利乐者。如水大从高赴下多所饶益。能润草木而生华果。又复本性清洁无垢无浊。悉能满足饥渴众生。洗诸滓秽蠲除热恼。澄深难入不可测量。于坑塪之处性皆平等。如来智水亦复如是。从真法界流趣世间。润诸等持生助道法。成大果实利益群生。体无烦恼故清洁。能离诸惑故无垢。一相非异故无浊。诸有得之思愿尽息。获清凉定洗除尘劳。湛寂难思。证平等性。故以为喻也。复次金刚手说此五喻。即是发起下文五字义也。◇阿字门为地。◇嚩字门为水。◇啰字门为火。◇诃字门为风。◇佉字门为空。又如世间种子。地水火风为缘。虚空不碍。然后得生。随阙一缘终不增长。一切智性如来种子。亦复如是。即用一切智门五义。自为众缘。能至菩提常住妙果。所谓不可思议不生不灭之因缘也。金刚手观知如来独一法界加持之相。心所惟忖。必知将说如是法门故。先喻其功德。发起大会生解之机。然后问佛。如是智慧。以何为因。云何为根。云何为究竟耶。从此已后。如来智印即定其心。广分别说。例如弥勒菩萨。睹佛神通之瑞。即时愤愤悱悱心有所存。为说是道场所得法。为授菩提记。文殊发挥名体。指云妙法莲华。然后如来印以实相。乘机演说。令动执之徒得离疑网。譬如春阳之始萌种甲坼。雷风鼓动时雨润洒。得离莩壳苗能出生。若无机之人。虽则遇际会。不能发起深益也。毗卢遮那佛。即告持金刚秘密主言。善哉善哉执金刚。善哉金刚手。汝问吾如是义。汝当谛听极善作意。吾今说之。乃至诸法无相。谓虚空相者。以执金刚手秘密主。预测如来加持深意。又能发起时众。作生解因缘。仰测圣心。不失机会。故重言善哉善哉。我观一切天人沙门婆罗门。乃至浅行诸菩萨。无能于世尊前。发如是问者。所以者何。以此三句义中。悉摄一切佛法。秘密神力甚深之事故。复叹言善哉金刚手。汝能问吾如是义也。以如来善哉言音所加持故。尔时金刚手。无量功德倍增。复明于所受法终无漏失。次即诫言汝当谛听极善作意吾今说之。亦为未来弟子。明此嘱耳。深心受法之仪式也。故释论云。若人心善直信。是人可听法。若无是相。则不能解。如说。偈云。听者端身如渴饮。一心入于语义中。踊跃闻法心悲喜。如是之人应为说。及无尽意经。用心听法有二十三句功德。广说之

经云。佛告金刚手。菩提心为因。悲为根。方便为究竟者。犹如世间种子。籍四大众缘。故得生根如是次第。乃至果实成熟名为究竟。然以中智观之。毕竟不生不灭。是故因果义成。若法不然。有生灭断常之相。则堕於戏论。皆悉可破。因果义不成也。今行者观心实相。亦复如是。出过一切戏论如净虚空。于内证所行得深信力。萨婆若心坚固不动。离业受生成就真性生。万行功德从此增长。故曰菩提心为因也。此菩提心。为后二句因。若望生死中所殖善根。则名为果。以睹佛法前相故。譬如有人闻善知识言。汝今宅中自有无尽宝藏。应自勤修方便而开发之。可使周给一国常无匮乏。彼人闻已即生谛信。如说而行。乃至施功不已渐见前相。尔时于宝藏功德。离疑惑心。堪能发起殊胜加行。故菩提心。即是白净信心义也。释论亦云。佛法大海信为能入。如梵天王请转法轮时。佛说偈言。我今开甘露味门。若有生信者得欢喜此偈中。不言施戒多闻忍进禅慧人能得欢喜。独说信人。佛意如是。我第一甚深法微妙。无量无数不可思议。不动不倚不着无所得法。非一切智人则不能解。故以信力为初。非由慧等而能初入佛法。为令如是净信心坚牢增长经中次说大悲为根。根是能执持义。犹如树根执持茎叶花果。使不倾拔也。梵音谓悲为迦卢拏。迦是苦义。卢拏是剪除义。慈如广植嘉苗。悲如芸除草秽。故此中云悲。即兼明大慈也。且如行者修供养时。若奉一花或涂香等。即以遍一切处净菩提心。兴供养云普作佛事。发起悲愿回向群生。拔一切苦施无量乐。由自善根。及与如来加持法界力故。所为妙业皆得成就。即是普于一切智地。乃至无余有情界。皆悉生根也。随行者以无住心所修万行。即由大悲地界所执持故。大悲火界所温育故。大悲水界所滋润故。大悲风界所开发生故。大悲虚空不障碍故。尔时无量度门任运开发。由如牙根枝叶次第庄严。即是于一切心法。具足因缘之义也。方便为究竟者。谓万行圆极无可复增。应物之权究尽能事。即醍醐妙果三密之源也。又净菩提心者。犹如真金。本性明洁离诸过患。大悲如习学工巧。以诸药物种种练冶。乃至镜彻柔软屈申自在。方便如巧艺成就。有所造作随意皆成。规制中权出过众伎故。其得意之妙难以授人也。如摩诃般若所明。六度十八空三昧道品总持门等。皆入大悲句中。即彼万行所成一切智智之果。说名方便。由内具方便故。方便之业即是利他。是以梵音邬波娜。亦名发起。如从种子生果果还成种。故以为名也

经云。秘密主云何菩提。谓如实知自心。即是开示如来功德宝所也。如人虽闻宝藏发意勤求。若不知其所在无由进趣。故复指言如上所明。第一甚深微妙之法。乃至非一切智人则不能解者。此法从何处得耶。即是行者自心耳。若能如实观察了了证知。是名成菩提。其实不由他悟。不从他得。问曰。若即心是道者。何故众生轮回生死。不得成佛。答曰以不如实知故。所谓愚童凡夫。若闻是法少有能信。识性二乘。虽自观察未如实知。若如实自知。即是初发心时便成正觉。譬如长者家穷子。若自识父时。岂复是客作贱人耶。尔时行者。正知心实相故。见一切法悉皆甚深微妙。无量无数不可思议。不动不倚不着都无所得。毕竟如菩提相。故经复云秘密主是阿耨多罗三藐三菩提。乃至彼法小分无有可得。无上正遍知义。前已说之。此中言小分者。梵云阿耨。即是七微合成。于从缘生色最为微小。故以为喻。言彼法者。离此无相菩提心。外更无一法也。经中次说因缘云。何以故。虚空相是菩提无知解者亦无开晓。何以故。菩提无相故者。譬如虚空遍一切处毕竟净故。离一切相无动无分别。不可变易不可破坏。以如是等小分相似故。以喻无相菩提心。然是中。复有无量无边秘密甚深之事。实非世间虚空所能遍喻。冀诸学者。得意忘筌耳。又如虚空远离戏论分别。故无知解相无开晓相。诸佛自证三菩提。当知亦尔。唯是心自证心心自觉心。是中无知解法无知解者。非始开晓亦无开晓之者。若分别少分能所犹如微尘。即取法非法相。不离我人众生寿命。岂得名为金刚慧耶。复次经中自转释。言何以故菩提无相故。如释论云。佛智慧清净故。出诸观上。不观诸法常相无常相。有边相无边相有去相无去相。有相无相。有漏相无漏相。有为相无为相。生灭相不生灭相。空相不空相。常清净无量如虚空。是故佛智无碍。若观生灭者。不得观不生灭。观不生灭者。不得观生灭。若生灭实。不生灭不实。若不生灭实。生灭不实。如是等诸观皆尔。以如是净菩提心。出过诸观离众相故。于一切法得无挂碍。譬如虚空之相亦无相故。万像皆悉依空。空无所依。如是万法皆依净心。净心适无所依。即此诸法。亦复如菩提相。所谓净虚空相。故经复云。秘密主诸法无相谓虚空相也。尔时金刚手复白佛言。世尊谁寻求一切智。谁为菩提成正觉者。谁发起彼一切智智。佛言。秘密主自心寻求菩提及一切智。何以故。本性清净故。乃至无量功德皆悉成就。时执金刚闻佛所说义。萨婆若慧唯是自心。乃至无有少法出此心者。为未来众生断疑惑故。而问佛言。菩提心名为一向志求一切智智。若一切智智。即是菩提心者。此中谁为能求谁为所求。谁为可觉谁为觉者。又复离心之外都无一法。谁能发起此心。令至妙果者。若法无有因缘。而得成者。一切众生。亦应不假方便自然成佛。故佛答言秘密主自心寻求菩提及一切智。何以故。本性清净故。虽众生自心实相。即是菩提。有佛无佛常自严净。然不如实自知。故即是无明。无明所颠倒取相故。生爱等诸烦恼。因烦恼故。起种种业入种种道。获种种身受种种苦乐。如蚕出丝无所因。自从已出而自缠裹。受烧煮苦。譬如人间净水。随天鬼之心。或以为宝或以为火。自心自见苦乐。由之当知离心之外。无有法也。若瑜伽行人。正观三法实相。即是见心实相。心实相者。即是无相菩提。亦名一切智智。虽复离诸因缘。亦非无因而得成就也。复次世尊欲令众生如实知自心故。更以方便分别演说。所以然者。若但言自心不生不灭。以无所因故义则难解。故先示其着处。经言心不在内不在外。及两中间心不可得。如摩诃般若。以无量门入诸法实相。今欲举其宗要。但观内外十二处。即摄一切法也。行者心无始来。多于内法取着心相故。先于内六处。以即离相等方便。一一谛观心不可得无生无相无有处所。而作是念。此心或在外耶。复于外六处如实观之。心亦无生相无有处所。犹恐错误更合观之。于两中间亦不可得。即悟此心实性。本自无生无灭。毕竟常净戏论云披。譬如珠力故水清。水清故珠现。定不从余处来也

经云。秘密主。如来应正等觉。非青非黄。非赤非白。非红紫非水精色。非长非短非圆非方。非明非暗。非男非女非不男女者。前约一切法明心实相已。今复约真我明心实相。此宗辨义。即以心为如来应正等觉。所谓内心之大我也。如有一类外道。不了自心故而作是言。我观真我其色正青。余人所不能见。或言正黄正赤。或言鲜白。或言如燕脂色。今义云红紫也。或言我见真我。其相极长极短。乃至如男子相等。唯此是实余皆妄语。然此等众相。悉从缘生无有自性。云何得名真实我耶。对如是种种执故。佛说如来应正等觉非青色等。所以者何。是青相毕竟不生故。则为非青。青实相不坏故。而亦非非青。当知如来应正等觉。无一定相可说。亦不离如是诸相也。如有外道阿阇梨。于黑月夜引诸弟子至大象前而告之言。我于今者示汝真我。时彼众人。或以目睹或以身触。其视形者则言。我今已识。真我其色甚白杭然高大。其触牙者则言。真我如戈。触耳者则言如箕。触足者则言如柱。触尾者则言如索。各随所遇情计不同。虽复更相是非。终不能识其真体。若瑜伽行者。开发心明道时。照见心王如来。如大明中目睹众色。则不生如是诤论也。次云秘密主。心非欲界同性。非色界同性。非无色界同性。非天龙夜叉。乃至人非人趣同性者。亦是对诸妄执。显示自心无变易。故说言此心不与三界同性也。有诸外道计。我性即同欲界。或同色无色界。乃至谓非想处即是涅槃。或言梵王毗纽天等生一切法。然此三界。皆悉从众缘生。求其自性。都不可得。况令心性同于彼性耶。次广分别无量诸众生趣。一一言之。皆不与彼同性。譬如虚空中雨八功德水。一味淳净。随所受之器种种差别故。或辛或酸。或温或浊。然八功德性不与彼同。温解浊息时。清凉如故未曾变异。又如真陀摩尼自无定相。遇物即同其色。然其宝性不与彼同。若与彼同性者。是色随缘生灭时。宝性亦应生灭也。复次世尊将欲开示大悲胎藏生漫荼罗故。先正开示心实相门。何以故。如行者本尊三昧中。说有显形男女等相。及普门示现六趣之身。恐诸行人。不了心因缘生故。于宝王真性而生戏论。故佛说言如来非青非黄。乃至此心不与三界六趣同性。若能如是观察。则不障菩提心也。又经云秘密主。心不住眼界。不住耳鼻舌身意界。非见非显现者。前说不在三处。已摄一切法。为未悟者。复一一历法分别。若心不与诸趣同性。为住眼界等耶。乃至住意界耶。若心住眼界者。眼从众缘生故。性相自空无有住处。况复心之实相住在眼中。如眼界者。乃至阴入诸法皆应广说。复次前已破种种外道。今说不住诸法。为破边见声闻故。如犊子阿毗昙中说。譬如四大和合有眼法。如是五象和合有人法。是人法在不可说藏中。说一切有道人言。神人一切法门中。求不可得。如兔角龟毛常无。而阴界入实有自性。以如是戏论法故。不识其心。若能观心不住诸法。则心无行处。戏论皆尽也。非见非显现者。如有人言。一切众生本有佛知见性。但无明翳膜除时。自能见理。或有人言。如是常理非可造作。但除缠盖云雾除时。日轮自现。皆以世谛言之耳。若净菩提心。是可见可现之法。即为有相。凡有相者。皆是虚妄。云何能见无上菩提。又经中自说因缘。何以故。虚空相心离诸妄执亦无分别。犹如虚空毕竟净法。一切色像无能染污之者。心性亦尔。一切分别无能染污之者。若无分别。即是离一切相也

经云。所以者何。性同虚空即同于心。性同于心即同菩提。如是秘密主。心虚空界菩提三种无二。此等悲为根本。方便波罗密满足者。如上种种入清净门。皆为发明自心求菩提义。今复结言虚空无垢即是心。心即是菩提。相本同一相。而有三名耳。即此一法界心。虽因缘毕竟不生。而不坏因缘实相。以不生故。则无能所之异。以不坏故。亦得悲为根本。方便波罗密满足。即是究竟不思议中道义也

经云。秘密主。我说诸法如是。令彼诸菩萨众。菩提心清净知识其心者。佛已开示净菩提。略明三句大宗竟。即统论一部始终。无量方便。皆为令诸菩萨。菩提心清净知识其心。如此经者。当知一切修多罗意。皆同在此。如释迦如来所说法者。当知十方三世一切如来。种种因缘随宜演说法。无非为此三句法门。究竟同归本无异辙。故云我说诸法如是。乃至知识其心也

经云。秘密主。云何知自心。谓若分段或显色。或形色或境界。若色若受想行识。若我若我所。若能执若所执。若清净若界若处。乃至一切分段中。求不可得者。世尊前已广说净菩提心如实相。以众生未能得意悬悟。复作方便。说此顿觉成佛入心实相门。亦为决了十方三世一切佛法故。如一切经中。或说诸蕴和合中我不可得。或说诸法从缘生都无自性。皆是渐次开实相门。彼言诸法实相者。即是此经心之实相。心实相者。即是菩提。更无别理也。但为薄福众生。而不能自信作佛。自信作佛者甚为难得。故世尊且令净诸垢障。将护其心。要令时义契合。然后为说即心之印。今经则不如是。直约诸法令识其心。所以为秘要之藏也。初句云谓若分段者。是总举从缘生法。以法待因缘成。必有差别相故。行者当知如是观察。今此分段中何者是心。乃至分析推求都不可得。即知此心。出过众相离诸因缘。以知心性常如是故。尔时一切诸法。自然不异于心也。显色谓青黄等。形色谓方圆等。境界谓六情所对。即六尘也。为令人易解故。复历法观察。今此显形众色中。何者是心。色本非情无觉知相。况于是中有心可得。如显形者。当知一切色尘亦如是。如色尘者。乃至声香味触法亦如是。行者于外尘中心不可得。复观内身五蕴。亦如聚沫泡炎芭蕉幻化。自求性实尚无所有。况于其中而得有心。如是从粗至细去广就略。乃至现在一念识。亦无住时。又复从众缘生故。即空即假即中。远离一切戏论。至于本不生际。本不生际者。即是自性清净心。自性清净心。即是阿字门。以心入阿字门故。当知一切法。悉入阿字门也。已说观诸法实相。次明观于我相。故云若我若我所。若能执若所执。若清净。如上于诸阴中。种种方便观心。而不可得。何况我人寿者等法。从本以来但有假名。而于其中有心可得。清净者即外道所计。最极清净处。以为涅槃也。如长爪梵志。不受一切法而受是见。今亦如是。取着观空智慧。而生是清净想。即于如是想中。正观自心无有生处。得入真净菩提心也。以上广对五阴。次复说十八界十二处。乃至一切分段中求不可得。阴界入义。阿毗昙中广明。此三法已摄一切法。复云乃至一切分段中求不可得者。即是摩诃般若等中。历法广明者是也。如于阴界入分析求心。心不可得。当知六度万行。乃至一切总持三昧门中。种种求心亦不可得。以心不可得故。是心常乐我净非常乐我净等相。亦复如是不可得也。复次如声闻人。初观阴界入时。即阴求我离阴求我。皆不可得。相在亦不可得。尔时于八直道中。远尘离垢正法眼生。真言门菩萨亦如是。初观阴界入时。即阴求心离阴求心。皆不可得。相在亦不可得。故即时悬悟自心本不生际。于如来知见大菩提道中。远尘离垢得法眼净。若不作如是方便先从着处观之。而但言是心遍一切处毕竟无相。则一切众生无由悟入。当知此观。最为秘要法门也。如余远离方便诸菩萨。渐次修习戒定智慧。于无量劫。以种种门观人法二空。犹未能远离心之影像。今真言行者。于初发心时。直观自心实相。了知本不生故。即时人法戏论净若虚空。成自然觉不由他悟。当知此观。复名法明道顿悟法门也

经云。秘密主。此菩萨净菩提心门。名初法明道。菩萨住此修学。不久勤苦。便得除一切盖障三昧者。入佛智慧。有无量方便门。今此宗。直以净菩提心为门。若入此门。即是初入一切如来境界。譬如弥勒。开楼阁门内善财童子。是中具见无量不思议事。难以言宣。但入者自知耳。法明者。以觉心本不生际。其心净住生大慧光明。普照无量法性。见诸佛所行之道。故云法明道也。菩萨住此道时。从妄想因缘所有烦恼业苦。皆悉清净除灭。譬如有人。暗中为利宝所伤。谓为蛇毒。以作毒想故其心执着。便成毒气遍入支体。垂欲命终时。有良医诊之。晓其本末。即时引至伤处。以明灯照之。犹见所伤之宝。有血涂相。其人了知非毒。毒气亦除。分别玩好之具而生喜乐。行人亦复如是。因净菩提心照明诸法故。少用功力。便得除盖障三昧。见八万四千烦恼实相。成八万四千宝聚门。故经次云菩萨住此修学。不久勤苦。便得除一切盖障三昧。若得此者。则与诸佛菩萨同等住。是中障有五种。一者烦恼障。谓根本烦恼。乃至八万四千上中下品障。盖净心及由宿世偏习故。妨碍道机不入佛法。二者业障。谓过去及现在世造诸重罪。乃至谤方等经。是人虽有。得道因缘。以先业障未除故。种种留难不入佛法。三者生障。谓是人若得胜上无难生处。必当悟道。然乘先业更受无暇之身。以报生即为障不入佛法。四者法障。谓此人已得无障生处。又有悟道之机。以先世曾有障法等缘故。不逢善友不闻正法。五者所知障。谓此人乃至遇善知识得闻正法。然有种种因缘两不和合。妨修般若波罗密。如大品魔事中广明。亦是先世。或曾差化道机故喜生此障也。行者已得净除五障三昧。尔时于自心中。常见十方一切诸佛妙相湛然。如观明镜。乃至于诸威仪去来睡寤。皆不离如是佛会因缘。时诸圣者。常以胜妙方便启悟其心。梵音慰喻为决疑网。行者随闻随喜悟已。网障随除。不久成就一切佛法。故云若得此三昧者。即与诸佛菩萨同等住。当知行人。则是位同大觉也。以其自觉心故。便得佛名。然非究竟妙觉大牟尼位。犹如净月虽体无增减。然亦明渐渐增。乃至第十五日。方能动大海潮也。又行者犹与如来共同等住。即能以方便力起五神通。不动本心游诸佛刹。现种种身语意。兴种种供养云。以无尽大愿广修诸度。复由意根净故。次得解无量语言音声陀罗尼。如一世间中三十六俱胝趣。随彼上中下性种类。若干方俗言辞。各各差别。皆晓其旨趣。应以随类之音。如一世界者。一切世界亦如是也。梵本噜多是大声。罗尾多是小声。涅瞿衫者是长声。又兼多声。所以具足言之。欲显总持境界无所不了。对此方文字难以具翻也。以得陀罗尼。故能知一切众生心行。谓如是众生。嗔行偏多而贪性薄。或如是众生。贪行偏多而嗔性薄。乃至通塞之相无量差别如释论道种智中广明。是菩萨。非但意根得知。乃至视听臭触。亦皆互用无碍。又能观彼根缘为除盖障。以种种方便成熟众生。庄严佛土行如来事。当知真言门行者。乃至一生可得成辨也。复次如上所说诸功德。一切众生皆悉如其本性。等共有之。但以无明障盖不自了知。未能起发如是秘密神通之力。今此真言门修行诸菩萨。以见法明道故。即生获除一切盖障三昧。得此三昧故。即能与诸佛菩萨同住。发五神通。以五神通故。获一切众生语言陀罗尼。获此陀罗尼故。能知一切众生心行而作佛事。以能广作佛事。不断如来种故。则于一切时一切处。常为十方诸佛之所护持。犹如婴童始生。父母爱心偏重常不舍离。当知如是诸句。皆悉次第相释也。复次行者。以内具如上功德。外为诸佛护持。是故处于生死而无染着。犹如莲花出水。不为淤泥之所染污。常以四摄方便拔苦众生。乃至无量无边阿僧祗劫。常在无间狱中。身心精进炽然不息。无有退没不辞劳倦。何以故。净菩提心。其性法尔如金刚故。如是极坚固性。即是不从师得。住无为戒。无垢无浊不可破伤。戒者梵云尸罗。是清冷义也。譬如水性常冷。虽遇薪火因缘。则能灼烂诸物。然其自性终不可迁。若除薪息火。自然清冷如本。真言行者亦如是。获除盖障三昧时。心之本性即是尸罗。非造作法不由他得。故言住无为戒也。如声闻净戒。要由白四羯磨众缘具足。方始得生。又须方便守护。如防利刺。一期寿尽。戒亦随亡之。此戒则不如是。世世生处恒与俱生。不假受持常无失犯。又由住斯戒故。实智增明。逮见不思议中道甚深缘起。制止八颠远离二边。故经次云远离邪见通达正见。迦叶亦云自此以前。我等皆名邪见人也。是中慧不正故说名邪见。由凡夫二乘。不能决择正知自心实相。于谛实之理。乃至空谓不空不空谓空。不见古佛所行大菩提路。今此菩萨。以照见心明道故即时无碍智生。于一切法。皆悉现前通达无有错谬。犹如明目者。于日光中睹见种种诸色。虽无量天魔。皆悉化作佛身。各说相似波罗密。终不能动其少分疑网之心。故经次云。复次秘密主。住此除一切盖障菩萨。信解力。故不久勤修。满足一切佛法。以如是正见犹若金刚。即是最上坚信解力。依此进修如实巧度故。得诸佛力无所畏解脱三昧。及余无量佛法。皆悉成就也。龙树以为如冶人。以种种方便消融矿石。然后成金。若神通者。能使土木之类即成金体。故云不久勤修便得满足。一切佛法以是菩萨初发心时即名佛故。真实功德不可度量。假使如来。于无量无边阿僧祇劫。分别演说犹不能尽。故佛言。取要言之。是善男子善女人。无量功德皆成就也。尔时执金刚秘密主。复以偈问佛。乃至不知诸空。非彼能知涅槃。是故应了知空。离于断常者。如上佛说经之大旨。心实相门略已周备。时金刚手。为令未来众生。具足方便无复余疑故。以偈问佛。请世尊广演其义。是中略有九句。云何世尊说此心菩提生者。即是菩提心生也。如花严诸经。广叹发菩提心功德。今此中。直问心之密印。云何了知此心菩提种子发生。若已发生其性云何。第二句云。复以云何相知发菩提心者。相谓性成于内。必有相彰于外。如般若中广明阿毗拔致相貌。今此中亦问菩提心生时有何相貌也

经云。愿识心心胜自然智生说者。是如实叹佛功德。请敷演前二句义。初云识心。是心自觉之智。次又言心。即是心之实相。意明境智俱妙无二无别。故重言之。自然智。即是如来常智。唯是心自证心。不从他悟。言佛既于识心人中。最为第一。必能知此菩提发生及其微相。唯愿说之也。第三句云。大动勇几何次第心续生者。大勤勇。即是佛之异名也。叹德而复发问。有几心次第而得是心也。第四第五句云。心诸相与时愿佛广开演者。问此诸心差别之相。及相续胜进。凡经几时。而得究竟净菩提心也。第六句云。功德聚亦然者。言是心微妙功德。亦愿世尊广开演之。故云亦然也。第七句云。及彼行修行者。次问当以何行。云何修行。而能获得无上悉地。亦可分为二句也。第八第九句云。心心有殊异唯大牟尼说者。谓众生异熟识心。与瑜伽行者殊异之心。亦愿世尊分别广说。牟尼者是寂默义。言佛身语心。皆究竟寂灭过语言地。以对二乘小寂不可为譬故。云大牟尼也。阿阇梨言。如是九句。或可分为十句从此以后迄至经终。皆是如来酬九问之意。广分别说。然佛观当时众会。务令得意求宗。或后问先答文无定准。次或转生疑问以尽支流。如下文入大悲藏漫荼罗等。即是答修行句。百字果等。即是答殊异心及功德句。其余随有相应处。皆以类观之。义可知也。次如来答金刚手偈中。善哉佛真子广大心利益者。以从如来种性生。从佛身语心生故曰真子。如前大日世尊。现广大加持境界。今秘密主。亦欲普为如是无量应度众生。使速成大行裂大疑网。同获三平等句无尽庄严故。佛叹言善哉佛子。汝今能以广大心。为利益无量众生故发如是问也。次云胜上大乘句。心续生之相。诸佛大秘密。外道不能识者。略有七义故名大乘。一者以法大故。谓诸佛广大甚深秘密之藏。毗卢遮那遍一切处大人所乘。二者发心大故。谓一向志求平等大慧。起无尽悲愿。誓当普授法界众生。三者信解大故。谓初见心明道时。具足无量功德。能遍至恒沙佛刹。以大事因缘成就众生。四者以性大故。谓自性清净心金刚宝藏。无有缺减一切众生等共有之。五者依止大故。谓如是妙乘。即法界众生大依止处。犹如百川趣海。卉木依地而生。六者以时大故。谓寿量长远出过三时。师子奋迅秘密神通之用。未曾休息。七者以智大故。谓诸法无边故。等虚空心自然妙慧。亦复无边。穷实相原底。譬如函盖相称。以如是七因缘故。于诸大乘法门犹如醍醐淳味第一。故云最胜大乘也。乘名进趣。句名止息之处。故云大乘句也。心续生之相者。虽此心毕竟常净。犹如虚空离一切相。而亦从因缘起。有心相生。犹如大海波浪。非是常有亦非常无。若常有者。不应风颷止息则澄然而静。若常无者。不应风颷才起鼓怒相续。当知是心从缘起故。即是不生而生生而不生。无相之相相常无相。甚深微妙难可了知。诸佛秘密之印。不妄宣示。是故凡夫二乘两种外道。非但不识无生灭心。亦复不识生灭心。故云诸佛大秘密外道不能识。我今悉开示一心应谛听也。次偈云越百六十心生广大功德。其性常坚固知彼菩提生者。是略答初问。云何即知菩提心生。今佛告言越百六十相续心。即是净菩提心。如有人问云何知此乳中醍醐生。答言若乳酪生熟苏。粗浊变异之相。悉已融妙无复滓秽。当知即是醍醐生也。行者最初开发金刚宝藏时。见是心性如净虚空超诸数量。尔时离因业生。佛树牙生。此牙生时。已遍法界。何况枝叶花果。故云生广大功德。以过心行戏论故。不可破不可转。犹若阎浮檀金。无能说其过恶。故云其性常坚固。若知自心有如是印。当知是菩提生也。次有一偈半。略答菩提心相貌。以世间更无有法。可以表示净菩提心相者。唯除大虚空喻少分相似。故云无量如虚空。譬如虚空。不为烟云尘雾之所染污。其性常住离诸因缘。假使八方大风吹尽世界。亦不能令其动。自本初以来常自寂灭无相。非适今也。心相亦尔。从无始以来本自不生。以本不生故。无有一法能令染污动摇。常住不变永寂无相。故云不染污常住。诸法不能动。本来寂无相。尔时行人。为此寂光所照。无量知见自然开发。如莲花敷。故云无量智成就。此智成就。即是毗卢遮那心佛现前。故云正等觉显现。梵本云三藐三佛陀菩提现也。佛已略说如是心实相印。若行者与此相应。当知已具坚固信力。然此信力。本从真言门供养仪轨行法。如说修行得至净菩提心。故云供养行修行。从是初发心也。此中供养有二种。一者外供养。二者内供养。下文当应说耳。或有说言。但观心性无相无为。不应种种纷动行菩萨道。此说非也。如以四种不生观矿中金性。虽复在因在果。常自无减无增。若不以方便消融滓秽。则此不生之金无由可得。行人亦复如是。若不以三种秘密方便供养行门。消融百六十心矿石之垢。何以得此净菩提心。龙树阿阇梨中道正观。正以从缘起故。无生义成。而汝谓龟毛兔角为无生。是故堕在失处。又如世人睹真金百练不移。以为妙性穷极。若五通仙人。以诸药物种种练冶。能化土石之类尽为金宝。其有服食之者。住寿长远神变无方。当知真金性中。自有如是力用但世人无秘密方便故。不能得耳。净菩提心亦复如是。若以大悲万行。种种练冶。得成神变加持不思议业。故不应未得谓得。保初心为极果也

经云。秘密主无始生死愚童凡夫。执着我名我有。分别无量我分。秘密主。若彼不观我之自性。则我我所生者。以下答心相续义也。欲明净心最初生起之由故。先说愚童凡夫违理之心。无始生死者。智度云。世间若众生若法。皆无有始。经中佛言。无明覆爱所系。往来生死始不可得。乃至菩萨。观无始亦空。而不堕有始见中。愚童义如前说。凡夫者正译应云异生。谓由无明故。随业受报不得自在。堕于种种趣中。色心像类各各差别。故曰异生也。其所计我。但有语言而无实事。故云执着我名。言我有者。即是我所。如是我我所执。如十六知见等。随事差别无量不同。故名为分。次释虚妄分别所由。故云秘密主。若彼不观我之自性。则我我所生也。若彼观察诸蕴。皆悉从众缘生。是中何者是我。我住何所。为即蕴异蕴相在耶。若能如是谛求。当得正眼。然彼不自观察。但展转相承。自久远以来祖习此见。谓我在身中。能有所作及长养。成就诸根。唯此是究竟道。余皆妄语。以是故名为愚童也。经云复计有时者。谓计一切天地好丑。皆以时为因。如彼偈言。时来众生熟。时至则催捉。时能觉悟于人。是故时为因。更有人言。虽一切人物非时所作。然时是不变因。是实有法。细故不可见。以花实等果故。可知有时。何以故。见果知有因故。此时法不坏故常。亦以不观时自性故。而生如是妄计也

经云。地等变化者。谓地水火风虚空。各各有执为真实者。或言地为万物之因。以一切众生万物。依地得生故。以不观地之自性。但从众缘和合有故。而生是见。以为供养地者。当得解脱次有计。水能生万物。火风亦尔。或计万物从空而生。谓空是真解脱因。宜应供养承事。皆应广说

经云。瑜伽我者。谓学定者。计此内心相应之理。以为真我。常住不动真性湛然。唯此是究竟道离于因果。不观心自性故。如是见生以为真我。但住此理即名解脱也

经云。建立净不建立无净者。是中有二种计。前句谓有建立一切法者。依此修行谓之为净。次句谓此建立非究竟法。若无建立所谓无为。乃名真我。亦离前句所修之净。故云无净也。由不观我之自性。有如是见生。广说如上

经云。若自在天。若流出及时者。谓一类外道计。自在天是常。是自在者能生万物。如十二门中难云。若众生是自在子者。唯应以乐遮苦。不应与苦亦应但供养自在。则灭苦得乐。而实不尔。但自行苦乐因缘。而自受报。非自在天作。又若自在作众生者。谁复作此自在。若自在自作。则不然。如物不自作。若更有作者。则不名自在。如彼论广说也。计流出者。与建立大同。建立如从心出一切法。此中流出。如从手功出一切法。譬如陶师子埏填无间。生种种差别形相。次云时者。与前时外道宗计少异。皆自在天种类也

大毗卢遮那成佛经疏卷第一大毗卢遮那成佛经疏卷第二

        沙门一行阿阇梨记

    入真言门住心品第一之余

经云。尊贵者。此是那罗延天。外道计此天湛然常住不动。而有辅相造成万物。譬如人主无为而治。有司受命行之。以能造之主更无所尊贵者。故云尊贵。又此宗计。尊贵者。遍一切地水火风空处。昔有论师欲伏彼宗计故。往诣天祠。于彼天像身上。坐而饮食。西方以饮食之残为极不净。皆共忿怒。论师云如所宗。岂非遍一切处地水火风空界相。答言如是。论师言彼即地水火风。我亦如是。以之相入。何所不可而忿怒耶。彼众默然。不能加报。亦由不观我之自性故。生如是妄计也

经云。自然者。谓一类外道计。一切法皆自然而有。无造作之者。如莲花生而色鲜洁。谁之所染。棘刺利端。谁之所削成。故知诸法皆自尔也。有师难云。今目睹世人造作舟船室宅之类。皆从众缘而有。非自然成。云何自尔耶。若谓虽有而未明了。故须人功发之。是亦不然。既须人功发之。即是从缘。非自然有也

经云。内我者。有计。身中离心之外。别有我性。能运动此身作诸事业。难者云。若如是者。我即无常。何以故。若法是因。及从因生。皆无常故。若我无常。则罪福果报皆悉断灭。如是等种种论义。至挍量中广明

经云。人量者。谓计神我之量等于人身。身小亦小身大亦大。智度云。有计。神大小随人身。死坏时神亦前出。即与此同。然彼宗。以我为常住自在之法。今既随身大小。即是无常。故知不然也

经云。遍严者。谓计此神我能造诸法。然世间尊胜遍严之事。是我所为。与自在天计小异。如论中破自在。云自在天何故。不尽作乐人尽作苦人。而有苦者乐者。当知从爱憎生。故不自在。今遍严者。既能造诸福乐。而不能以乐遮苦。何名遍常自在耶

经云。若寿者。谓有外道计。一切法乃至四大草木等。皆有寿命也。如草木伐已续生。当知有命。又彼夜则卷合。当知亦有情识。以睡眠故。难者云。若见斩茢还生。以为有命。则人断一支不复增长。岂无命耶。如合昏木有睡眠。则水流昼夜不息。岂是常觉。皆由不观我之自性故。生种种妄见也

经云。补特伽罗。谓彼宗计有数取趣者。皆是一我。但随事异名耳。若有从今世趣于后世。是则识神为常。识神若常。云何有死生。死名此处灭。生名彼处出。故不得言神常。若无常。则无有我。如佛法中犊子道人。及说一切有者。此两部。计有三世法。若定有过去未来现在。则同有数取趣者。失佛三种法印。西方诸菩萨。作种种量破彼宗计也

经云。若识者。谓有一类执。此识遍一切处。乃至地水火风虚空界。识皆遍满其中。此亦不然。若识神遍常。应独能见闻觉知。而今要由根尘和合。方有识生。则汝识神为无所用。又若识神遍五道中。云何复有死生耶。故知不尔也。经云阿赖耶者。是执持含藏义。亦是室义。此宗说。有阿赖耶能持此身。有所造作含藏万像。摄之则无所有。舒之则满世间。不同佛法中第八识义也。然世尊密意。说如来藏为阿赖耶。若佛法中人。不观自心实相。分别执着。亦同我见也

经云。知者见者。谓有外道计。身中有知者。见者能知苦乐等事。复有计。能见者。即是真我。智度云。目睹色名为见者。五识知名为知者。皆是我计。随事异名也。难者云。汝言能见是我。而彼能闻能触知者。为是我不。若皆是者。六根境界互不相知。一不可作六。六不可作一。若有非我者。是亦同疑。故知根尘和合有所知见。无别我也

经云。能执所执。谓有外道言。身中离识心。别有能执者。即是真我。能运动身口意。作诸事业。或有说言。能执者但是识心。其所执境界。乃名真我。此我遍一切处。然内外身受心法性。皆从缘生。无有自性。是中所执能执。执尚不可得。何况我耶。亦由不观我之自性故。作是说也

经云。内知外知者。亦是知者别名。分为二计。有计内知为我。谓身中别有内证者。即是真我。或以外知为我。谓能知外尘境界者。即是真我也

经云。社坦梵者。谓与知者外道宗计大同。但部党别异故。特出之耳

经云。若摩奴阇者。智度翻为人。即是人执也。具译当言人生。此是自在天外道部类。计人即从人生。故以为名。唐三藏云意生。非也。末那是意。今云末奴。声转义别。误耳

经云。摩纳婆者。是毗纽天外道部类。正翻应言胜我。言我于身心中。最为胜妙也。彼常于心中。观我可一寸许。智度亦云。有计。神在心中。微细如芥子。清净名为净色。或如豆麦。乃至一寸。初受身时。最在前受。譬如像骨。及其成身。如像已庄。唐三藏翻为儒童。非也。儒童。梵云摩拏婆。此云纳。义别。误耳(此二名是菩提阇梨解)

经云。常定生者。彼外道计。我是常住不可破坏。自然常生无有更生。故以为名也

经云。声非声者。声即是声论外道。若声显者计。声体本有。待缘显之。体性常住。若声生者计。声本生。待缘生之。生已常住。彼中复自分异计。如余处广释。非声者。与前计有异。彼计声是遍常。此宗悉拨为无。堕在无善恶法。亦无声字处。以此为实也

经云。秘密主。如是等我分。自昔以来。分别相应。希求顺理解脱有。经中略与三十事。若随类差别。则有无量无边。如人坐得四禅。即计此法为真实常理。或生是念。我是得禅者。如是等皆是我分相应。例可知也。皆由不观我实相故。但从久远以来相承。祖习此见。各各自谓有大师薄伽梵。一切知见者。以善修瑜伽故。现觉此法。而为世间说之。唯此是究竟道。更无余道。如劫初时。独有一天。先生梵界。而作是念。若更有众生。来与我共住。岂不善哉。时有上界天。命终来生此中。先生者即谓之言。由我念力故。汝得生此。汝即我所生也。然彼亦作是念。是尊能生我等。便相随顺。计为最初有我者。从是以来。谓是梵天王能造世间。如是展转生于异见。不可胜记。希求顺理解脱者。顺理梵音瑜只。即是古昔修瑜伽行者。谓彼得真解脱是万物之宗。今顺彼行希求解脱。故云然也。已上皆是破坏内外因果违理之心。次明最初顺理之心。顺善即是世间八心也

经云。秘密主。愚童凡夫类。犹如羝羊。或时有一法想生。所谓持斋。彼思惟此少分。发起欢喜。数数修习。秘密主。是初种子善业发生者。羝羊是畜生中。性最下劣。但念水草及淫欲事。余无所知。故顺西方语法。以喻不知善恶因果愚童凡夫也。世间从久远来。展转相承有善法之名。然以违理之心。种种推求而不能得。后时欻然自有念生。我今节食持斋。即是善法。然犹未是佛法中八关戒也。彼由节食自戒故。即觉缘务减少。令我饮食易足。不生驰求劳苦。尔时即生少分不着之心。其心欢喜而得安稳。由见此利益故。数数有修习之。即是最初微识善恶因果。故名种子心也

经云。复以此为因。于六斋日。施与父母男女亲戚。是第二牙种者。此六斋日。即是智度中。上代五通仙人。劝令此日断食。既顺善法。又免鬼神灾横。如彼广说也。由见止息贪求内获利乐故。欲修习此法令得增长故。于持斋之日舍己财物以与六亲。自念我无守护之忧。而令他人爱敬。获孝义之誉。以见此因果故。转生欢喜。欢喜故。善心稍增。由如从种子生牙也

经云。复以此施授与非亲识者。是第三疱种。谓欲成此守斋善法。修习无贪慧舍之心。由数习故善心渐增长复能施与非亲识人见此平等施心功德利益故。尔时善萌倍复增广。犹如牙茎滋盛未生业时。故名疱种也

经云。复以此施与器量高德者。是第四叶种。谓已能习行慧舍。藉此为因。渐能甄择所施之境。如此之人德行高胜。我今宜应亲近而供养之。即是慧性渐开。遇善知识之由渐也

经云。复以此施。欢喜授与伎乐人等。及献尊宿者。谓慧性渐开。复甄别所施之境。见其利他之益。以伎乐人能化大众。令其欢喜故赏其功。凡如此类众多。是以云等也。尊宿。耆旧多所见闻。及学行高尚世所师范。以其多所遵利故。推诚欢喜而施与之。亦令我施时心倍欢喜故。即是花种也

经云。复以此施。发亲爱心而供养之。是第六成果者。谓所习醇熟。非直欢喜而已。复能以亲爱心。施与尊行之人。又由前施因缘。得闻法利。知彼内怀胜德。谓能出离欲等。狎习亲附而供养之。望初种子。即是成果心也。复次秘密主。彼护戒生天。是第七受用种子者。谓已能造斋施见其利益。即知三业不善。皆是襄恼因缘。我当舍之护戒而住。由护戒故。现世获诸善利。有大名闻。身心安乐。倍复增广贤善。命终而得生天。譬如种果已成受用其实。故曰受用种子也。又云从一种子成百千果实。是一一果实复生若干。展转滋育不可胜数。今此受用果心。复成后心种子。亦复如是。故曰受用种子也

经云。秘密主。以此心生死流转。于善友所闻如是言。此是天大。天与一切乐者。若虔诚供养。一切所愿皆满。所谓自在天等。乃至彼闻如是心怀庆悦。殷重恭敬随顺修行。秘密主。是名愚童异生生死流转无畏依第八婴童心。已知尊行之人宜应亲近供养。又见持戒能生善利。即是渐识因果。今复闻善知识。言有此大天能与一切乐。若虔识供养所愿皆满。即能起归依心也。虽未闻佛法。然知此诸天。因修善行得此善报。又渐信解甄别胜田。复闻佛法殊妙。必能归依信受。故为世间最上心也。问曰。前说自在天等皆是邪计。今复云归依此等是世间胜心。与前有何异耶。答曰。前是不识因果之心。但计诸法是自在天等所造。今由善根熟故。于生死流转中。求无畏依。欲效彼行因冀成胜果。故不同前计也。商羯罗。是摩醯首罗别名。黑天。梵音噜捺啰。是自在天眷属。龙尊。是诸大龙。俱吠啰等。皆世所宗奉大天也。梵天后。是世间所奉尊神。然佛法中。梵王离欲无有后妃。从波头摩以下。所谓得叉迦龙。和修吉龙。商佉龙。羯句擿剑龙。大莲花龙。俱里剑龙。摩诃泮尼龙。阿地提婆龙。萨陀龙。难陀等龙。皆是世间所奉尊神也。天仙。谓诸五通神仙。其数无量故不列名。围陀。是梵王所演四种明论。大围陀论师。是受持彼经能教授者。以能开示出欲之行故。应归依也。于彼部类之中。梵王犹如佛。四韦陀典犹如十二部经。传此法者犹如和合僧。时彼闻如是等世间三宝。欢喜归依随顺修行。是第八生死凡夫无畏依也

经云。秘密主。复次殊胜行。随彼所说中殊胜住。求解脱慧生等者。谓即此第八无畏依中。复有殊胜心也。既闻如上所说世间诸薄伽梵。宜应供养归依。后遂生心。此诸三宝何者为胜。我当择其善者随顺修行。由前善根力故。随彼所说法中得殊胜住。有求解脱智生。然以未知缘起法故。所有观空智慧不离断常。故曰常无常空。但随顺如是说。而勤修学。此中复有二种。若求解脱智生名殊胜心。已于空法作证名决定心。若离分说之。并前凡有十心也。世尊欲对明出世间观空智慧故。次说言。秘密主。非彼知解空非空义了知断常。虽作非有非无平等观绝诸戏论。然亦不能双离是见。由彼未解正因缘故。然佛法中。以知因缘有故。则离无见。以观自性空故。不生有见。若离有无见者。即不堕断常。若不达如是空义。虽复不著有无离言绝相。终是以分别想。作此无分别心。犹如长爪梵志观诸法实相。不受一切法而受是见。夫真空离于分别。云何分别空耶。若不解空义者。虽复一心精进勤求解脱。非彼能知涅槃。是故佛言。汝欲求涅槃者。应了知缘起之空离于断常也。由彼初种子心减损少分贪垢。即顺少分净心。从此以后斋施渐增。即是净心势力渐得萌动。由此熏习。则能甄择所归依处。有求解脱慧生。若不遇善缘。还从断常空。退入邪见。然其八心种子终不败亡。若闻佛法。但于断常空。令观缘起空即入正道。若是未生种子无机之人。虽种种为说。终不能信解也。又如行者于第八心。求生死无畏依时。若遇善知识。为说三宝真归依处。由彼渐识现世因果故。即能信受。复置是事。如彼修斋时。是人若遇善知识。告言。汝观何利故为此斋施。彼即答言。我观贪求保护因缘有种种忧苦。少欲行施得欢喜安乐住故。时善知识告言。善哉善男子。如佛所说。众生以悭贪故。现世有种种忧苦。命终以此因缘。堕恶趣中。以心离悭贪垢故。现世安乐有大名称。命终生天。后得涅槃。是故汝今更应以胜上心受八斋法。彼闻已。即便信受如说修行。若无机之人。但说世间苦乐皆是自在天造。或地等变化。以时为因。则闻如是八斋少分安净。尚不能信。何况余深事耶。问曰。如是八心最初种子。复以何为因。答曰。由世间自久远以来有善恶之名。种子从是生也。如劫初众生贪食地肥。尔时即以多食者为不善。少食者为善。或有见多食因缘起诸过患。便作是念。我今少食此味常自诫节。不亦善乎。然此众生。亦未识因果后世之报。但展转相承。谓仁义惭愧等以为善法。有能如是行者。世间共称誉之。又如少劫终竟时。众生忽尔发心。知世间恶法过患。更相劝导共行善事。尔时亦无善知识劝导使然。当知皆是自心实相熏习因缘力也。如最初种子。离微尘许心垢时。即显如微尘许净心势力。虽云善种子生。其实即是不生生。以是坚固性故。在众生识心终不败亡。未至自心实际大金刚轮中间。更无住处。离果复成种展转滋长。然亦不出阿字门。故云最上大乘句。心续生之相。诸佛大秘密。外道不能知。法华药草喻品。亦意在于此也。复次行者。归依三宝随顺如来律仪。于一日中受八斋法。由圣戒所防护故。寂静安乐。以安乐故。则信贤圣所行。数数修习。是名初种子。为令此善增长。而修诸善。乃至由戒醇净。决定生天。后至涅槃。是名受用种子。复由亲近善知识故。闻正法利。不起异归依心。是生死流转凡夫。第八真实无畏依。又于此中殊胜住。有求解脱慧生。思惟观察生决定想。从此即发声闻菩提初种子心。皆应准傍前文广分别说。乃至三乘一一地。皆具十心。迄第十地。亦具种子牙疱叶花果等。有求佛地智生。观毕竟空得至金刚际也。尔时金刚手。复请佛言。惟愿世尊说彼心。如是说已。佛告金刚手秘密主言。秘密主谛听。心相。谓贪心无贪心。嗔心慈心。痴心智心。乃至云何受生心。谓诸有修习行业彼生。心如是同性。此答前问中诸心相句也。初列六十心名。次释其相。秘密主。彼云何贪心。谓随顺染法者。谓染着前境。即是染污净心。若随顺修行此法。名有贪心。以心法微细难识。但观彼所为事业。必有相彰于外。譬如鉴烟之状貌。则火性可以比知。故诸句多以顺修明义。以可例然也。此等皆是未得出世心以来。与善种种杂起之心。若行者善识真伪。犹如农夫务除秽草以辅嘉苗。则净心势力渐渐增长。勿谓是因缘事相。轻忽至言。使心没其中。不自觉知也。第二云何无贪心。谓随顺无染法者。谓与前心相违。乃至所应进求善处。亦复不生愿乐。是故不染善法。俱障善萠。与无染污心。名同事异。最须观察也。是故行者。但观贪心实相。自然贪不染心。不应起如是无慧不贪之行。第三云何嗔心。谓随顺怒法者。怒谓嗔心发动。事彰于外。以心法难识故。以顺修怒法释之。若数起如是不寂静相。即知是嗔心相也。但于此众缘中观察嗔心。自无所住则此障不生。第四云何慈心。谓随顺修行慈法者。此慈亦是与嗔相违。爱见心垢之慈。非善种所生也。上慈字据内心。下慈字是外相所为事业。既觉知已。但治妨道之失。转转修慈无量心。即是对治。第五云何痴心。谓顺修不观法。谓不观前言善恶是非。遇便信受。凡所为事业。不能先以慧心甄别筹量是非。如是等多诸误失。皆是痴心相也。第六云何智心。谓顺修殊胜增上法者。谓是人于种种所说中。皆以智简择此胜此劣此应受此不应受。取其胜上者而彼行之。即是无痴相也。然过人之法。非智力筹量所能及之。唯信者能入耳。是故观察世智辩聪难。是彼对治。第七云何决定心。谓遵教命如说奉行。第八云何疑心。谓常收持不定等事者。今先择疑心。令决定心相易解明了故。谓此人随有所闻。便生不决定心。如受戒时。便自生疑心。我今定得戒。为不得戒耶。或疑师疑法。诸事例尔。如人道行。以疑惑故不能前进。智度偈云。乃至譬如观岐路。好利者应逐。是彼对治。又决定心者。谓随闻善友等如法教命。便即不生疑虑。至心奉行。然亦当以慧观察。生正决定心也。第九云何闇心。谓于无疑虑法。生疑虑解者。谓如四谛不净无常等。世间智者不应生疑。然彼闻之心怀犹豫。如夜见株机生种种忆度之心。若见有如是相者。当知暗心使然也。第十云何明心。谓于不疑虑法。无疑虑修行者。谓于决定法印非可疑虑之法。彼随所听闻即能悬信。当知是明心也。然是中若过若不及。即是障道之心。更处中慧。是彼对治。第十一云何积聚心。谓无量为一为性者。谓此人随于一事生信解已。更闻种种殊异法。皆合集为一。如人学得一三昧已。见余经教无量法门差别胜事。皆谓说此定心。离此之外更无余法。故名积聚心也。第十二云何斗心。谓互相是非为性者。谓闻他所说言教。常好辨论是非。谓是义应尔是事不然。假使所言合理。亦以种种方便伺求其长短。欲令堕在失处。设他来问。亦复求其长短。言此问乖僻。我不应答。有如是相现。当知是斗心也。第十三云何诤心。谓于自己而生是非者。谓内怀是非之心。如自思惟一义竟。辄复自设异端推求其失。虽善心咨受于人既领受已。还自推求得失。谓此事合尔此不合。多有如是相现。当知是诤心也。第十四云何无诤心。谓是非俱舍者。准梵本转声。云于六十心下。皆合有为性之字。例可知也。谓其心不怀向背。虽先所宗习作如是见解。更闻异言以违合理。即受行之。或先以为是。闻他以为不善。即能改之。情无所执是非俱舍。如有如是相。当知是无诤心也。觉知无记无诤之心。修诸法实相无诤之心。是彼对治也。第十五云何天心。谓心思随念成就者。如诸天以先世果报故。若有所须。不加功力随心而生。数起如是愿乐。当知是天心。亦由曾生上界故。有此习也。如真言行人。不期远大之果。但为自心所率。能障净菩提心。当自觉知勿贪世间悉地。是彼对治。第十六云何阿修罗心。谓乐处生死者。阿名为非。修罗名天。以其果报似天。而行业住处不同故。以为名也。此知有解脱之利。但深乐生死果报快乐。不能进趣。若行人有此相貌。当知名修罗心。亦由先世曾生此趣故。有此习也。观察无常苦等。是彼对治。第十七云何龙心。谓思念广大资财者。谓数作是念。我当以何方便。获如是广大资财胜妙珍宝。有此多贪无厌之想。是龙趣之心也。亦本从龙趣中来。故生此习。喜令行人愿求世间悉地。障出世净心。思惟少欲知足无常等。是彼对治。第十八云何人心。谓思念利他者。谓好追求思念。某甲于我有恩。我当以如是方便令得大利。某甲曾于我所有不饶益。今当报之。及种种理人利物之计。皆是人心也。当念自观心行早求法利。不应纷纭思虑他缘。是彼对治。第十九云何女心。谓随顺欲法者。亦是人趣心。但以多欲为异耳。如经说言。女人多欲百倍于男子。常念所经乐事。或想他容色姿态等。能令行者障蔽净心。亦是多生曾作女人。犹有本习也。是中以不净念处等观身实相。是彼对治。第廿云何自在心。谓思惟欲我一切如意者。自在即外道所事天神也。彼宗计。自在天能随念。造诸众生及苦乐等事。修此法者。亦常系念。愿得如其本尊。若真言行人。数念如是悉地。念我随念成就。当知是自在心。亦先习使然也。当观诸法皆悉属众因缘无有自在。是所对治。第廿一云何商人心。谓顺修初收聚后分拆法者。如世商人先务储聚货物。然后思惟分析之。此物当某处用。彼物当其处用。可得大利。若行人先务内外学问。令周备已方复筹量。此是世典当如是处用。此二乘法用应接某人。此大乘资粮是某缘所要。此名商人心。亦由先习使然也。修捷疾智是彼对治。谓随闻何法。即应观彼因缘事用。岂待多闻蓄聚。方求用处耶。第廿二云何农夫心。谓随顺初广闻而后求法者。如学稼者询问老农。云何知地良美。云何耕植耘耨。云何候时。云何获藏。如是一一知已方就功力。此心亦尔。先务咨承智者。广闻道品。然后行之。皆宿习使然也。以利智为所对治。如闻诸蕴无常。即知界入缘起等其例皆尔。又如毒箭入体。岂得俟三农月广问。而后拔之耶。第廿三云何河心。谓顺修依因二边法者。此心性双依二边。或时修常或时修断。或复邪正兼信。如河水双依两岸。其所漂流之物。亦不定系一边。此中对治。谓行人专心一境。则能有所至到。若心不定守能令事业俱辨。无此理也。第廿四云何陂池心。谓随顺渴无厌足法者。譬如陂池。若众水流入终无厌足。是心亦尔。若名利眷属等事来集其身。终无厌足。乃至于所学法亦尔。如已得乳糜不务速食。更复渴望余味。是中少欲知足以为对治。第廿五云何井心。谓如是思惟深复甚深者。谓如俯窥井水浅深之量难知。此心性亦如是。凡所思惟好尚深远。所有善不善事。皆欲令人不能测量。共行住同事亦不识其心行。当知是井心也。缘起法门及善人相。皆显了易知。是彼对治。第廿六云何守护心。谓唯此心实余心不实者。如世人为护己身财物等故。乃至周墙重阁种种防守。不令为他所伤。此心亦尔。常守护身心。乃至如龟藏六。不令外境所伤。谓唯此行为宝。诸余有作之务皆为不实。学声闻者多生此心也。以兼护他人。为所对治。又有人自保所解。不欲令他种种异论所伤。谓余见解悉皆不实亦是也。第廿七云何悭心。谓随顺为己亦与他法者。谓此人诸有所作。皆悉为自身。故财物伎艺乃至善法。皆好秘惜不以惠人。有此相者。知是悭心。以念施及无常等。为所对治。当念财物伎能。设无常时。无有随我去者。然今此身。念念不可自保。何惜此耶。第廿八云何狸心。谓顺修徐进法者。如猫狸伺捕禽鸟。屏息静住不务速进。望至度内然后取之。此人亦尔。遇闻种种法要。但作心领受记持而不进行。冀待良缘会合。则当勇健励行之。又如猫狸蒙种种慈育。亦不识恩分。若人但受他慈惠善言。而不念报。是狸心也。以不待时处如闻辄行常念恩德。为所对治。第廿九云何狗心。谓得少分以为喜足者。以狗以薄福因缘。所期下劣故。遇得少分粗鄙之食。便生喜足。若稍过于此者。则非本所望。此心亦尔。闻少分善法。便以为行不可尽。不复更求胜事。此声闻种习所生也。以增上意乐为所对治。乃至心如大海。少亦不拒多亦不溢。第三十云何迦楼罗心。谓随顺朋党羽翼法者。此鸟常恃两翅挟辅其身。所往随意以成大势。假少一羽则无所能为。此心亦尔。常念多得朋党与辅翼相资以成事业。又因他所作而后发心。不能独进。如见人行善。便念彼尚能行。我何不为。当念勇健菩提心。如师子王不籍助伴。为所对治。第卅一云何鼠心。谓思惟断诸系缚者。如鼠见他箱箧绳系等。辄好非理损坏。亦不作念。由断此故令我得如是利。但尔无趣为之。此心亦尔。所有系属及与成事。好为间隙而俎败之。第卅二歌咏心。梵本缺文不释。阿阇梨言。此喻传法音也。如世人度曲于他。得善巧已。复为他人奏之。出种种美妙之音。闻者欢喜。此心欲从他听闻正法。我当转为众生。以种种文句。庄严分别演说。令此妙音处处闻知也。多是声闻宿习。亦能障净心也。当念我当得内证自然之慧。然后普现色身而演说之。是彼对治。第卅三云何舞心。谓修行如是法。我当上升种种神变者。如世人支分散动说名为舞。神变亦尔。现种种未曾有事。令前人心净悦眼。多是五通余习者。若偏尚如是悉地方便愿求。亦障净心也。当念除盖障三昧心无散动。神通不起灭定。而作加持神变。勿贪世间少验。是所对治。第卅四云何击鼓心。谓修顺是法。我当击法鼓者。鼓能警诫众生。令得觉悟。若行人作如是念。众生长夜昏寝。我当习种种无碍辨才。击大法鼓而警悟之。亦能妨碍净心也。当念早证无量语言陀罗尼。以天鼓妙音普告一切众。勿以世间小利妨大事因缘。是彼对治。第卅五云何室宅心。谓顺修自护身法者。如人造立舍宅庇卫其身。得免寒热风雨盗贼恶虫等。种种不饶益事。此心亦尔。我当持戒修善以自防护。令今世后世远离恶道众苦。多是声闻习也。当念救护一切众生非独一身。是所对治。第卅六云何师子心。谓修行一切无怯弱法者。如师子于诸兽中。随所至处皆胜。无有怯弱。此心亦尔。于一切事中。皆欲令胜一切人心不怯弱。自心谓无有难事。莫能与我粗其优劣者。若自觉知已。当发释迦师子心。当令一切众生遍胜。无有优劣。是所对治。第三十七云何鸺鹠心。谓常暗夜思念者。此鸟于大明中无所能为。夜则六情爽利。若行者昼日虽有所闻。诵习昏愦不得其善巧。至暗夜思忆所为之事。重复筹量便得明了。乃至修禅观等。亦以暗处为胜。若觉知已。当念等于明暗。令所作意无昼夜之别。是所对治。第三十八云何乌心。谓一切处惊怖思念者。如乌鸟若人善心附近惠养。或时伺求其便。俱生猜畏之心。一切时性常如是。此心亦尔。虽善友欲为饶益及陷误之者。一概猜阻而怀疑惧。乃至持戒修善时。亦于生死怀惊怖心。若觉知已。当修安定无畏心。是彼对治。第三十九云何罗刹心。谓于善中发起不善者。如人见为善事。皆作不善意解。佛说造诸塔庙得无量福。而彼反作是言。由此故横损无量小虫烦扰施主。将何所益当受苦报发起谓如是等不善心生起也。是中但以观功德利益不念彼矩。为所对治。第四十云何刺心。谓一切处恶作为性者。犹如棘丛于一切处多所损妨。令近者不安此心亦尔。若行善事如大施等。既作已便生追悔之心。若作恶事竟。复自思惟亦怀惭惧。是故常怀恶作动虑不安。此中对治法。若有犯速务忏除。勿生悼悔。所为善事。应自思惟生庆幸心。第四十一云何窟心。谓顺修为入窟法者。谓诸龙阿修罗等。皆在地下或海底深窟中。多有神仙诸药。能得长寿自在。行者或念彼中多有美女。端正同于诸天。可无夭逝之忧五欲自恣。或念留住彼中。可得劫寿见未来诸佛。皆是窟心也。当念如法修行。可于此生见法明道乃至成佛。不应抂路稽留念此世仙之法。是彼对治。第四十二云何风心。谓遍一切处发起为性者。风性散乱由不住故。此人心亦尔。于一切处遍种善根。谓于世间外道种种天尊及三乘诸行中。皆令有分。而作是念。如多种子于一切处遍之。会有成者。当如是风心也。当念石田不毛虚费种子。当求良美福田膏腴之处。专意耕耨所获必多。是彼对治。第四十三云何水心。谓顺修洗濯一切不善法者。如水性清洁。虽暂为诸垢所污。澄之则净又能洗除垢秽。此人心亦尔。常欲发露垢恶忏洗三业众罪。以见此垢此净我如是行。则能障碍净心。但当观心实相。了从本来垢法不生。自能除一切盖障。是彼治行也。第四十四云何火心。谓炽盛炎热为性者。如火性赫奕躁疾。此人心亦尔。若造善时。须臾间能成无量功德。造恶亦少时成极重业。此中治行。应思惟猛暴之心多所败伤。以柔和慈善之水方便令灭。而炽然善事务令恒久。是彼对治。第四十五泥心。梵本缺文不释。阿阇梨言。此是一向无明心也。乃至目前近事亦不能分别记忆。故律云犹如泥团。又如泥泞以淖弱故。难事越度。要令有所由藉。谓假桥梁等方能越之。若觉有此方便。必须归凭善友。令方便开发。乃能渐去无知还生慧性也。第四十六云何显色心。谓类彼为性者。譬如青黄赤白等染色。若素丝入之便与同色。此人心亦如是。见闻善法亦随彼行。见闻恶事亦依随修学。乃至无记亦尔。对种种境界随事而迁。行人自觉知已。当念专求自证之法。不由他悟不为他缘所转。是彼对治。第四十七云何板心。谓顺修随量法。舍弃余善故者。如板在水中。随其分量受载诸物。过限则不能胜。终亦倾弃之。此人心亦尔。简择善法业随己力分。行一事已便作是语。我承上以来。唯行此法不知其他。乃至习行八斋即不舍离。更不慕行余善。以发广大心学菩提行。是所对治。第四十八云何迷心。谓所执异所思异者。如人迷故。意欲向东而更向西。此人心亦如是。意欲学不净观。而反取净相。自谓我今修不净观。若修无常无我时。反行常我倒中。谓我今修无常无我。由心散乱故使然也。当念专一其心。审谛安详无倒观察。是彼对治。第四十九云何毒药心。谓顺修无生分法者。毒谓龙蛇药草诸恶毒也。如人中毒闷绝。转趣死地无有生分。此人心亦尔。不生善心亦不生恶心乃至一切心不能生起。但任运而行。渐入无因无果中。故名无生分法也。行人自觉知已。应发起大悲众善离断灭空。即是所谓甘露妙药。第五十云何罥索心。谓一切处住于我缚为性者。如人为罥索所缚。乃至手足支节不得动转。此心如是。堕于断见我缚之中。此见能缚行者心。乃至于一切处。常为所拘不能自出。最是重障也。既觉知已。应速以缘起正慧刀决除障盖。是所对治。第五十一云何械心。谓二足止住为性者。在手曰杻在足曰械。如人为械所持故。二足停住不得前进。此心亦尔。常好端坐。寂然住立而修定心。及观察法义为此所拘。故名为械心。此中治行。当于一切时处。思惟修习使静乱无间。是所对治。第五十二云何云心。谓常作降雨思念者。如西方夏三月中。霖雨特甚。以常滞淫昏艺故。时俗忧乐思虑之心。蔚翳滋多。故云作降雨时思念也。觉知已。则当行舍心。离于世间忧喜随顺法喜。是所对治。第五十三云何田心。谓常如是修事自身者。如人有良美之田。常修治耕垦芸除莣秽。种种方便令得清净。此人亦尔。常好修事其身以香花滋味等。灌涂奉养务令光洁严好。觉知已。常念回此功力修事其心。以如是诸供养具。播植福田资成胜果。是彼对治。第五十四云何盐心。谓所思念彼复增加思念者。如盐性碱。凡有所入处皆增盐味。此人心亦如是。于所思事复加思念。如忆想欲色之时。适生此意。还复自推求。是心由谁而生。作何相貌。观此心未决。复念此推求之虑有何因缘。如是则无穷尽也。既觉知已。当一向安心谛理务。使穿彻。又心性离念非忆度能知。不于分别之上更增心数也。第五十五云何剃刀心。谓唯如是依止剃除法者。剔除鬓发是离俗出家相。谓此人心但作是念。我已剔除俗相。令恶法不得复滋。更何所求。当知此心最恶。以自作分限故。能剃所有善根令不得生。当念一切贤圣所应断者。所谓无明住地三毒之根。若能剃此令妄想不生。乃名真出家也。第五十六云何弥卢等心。谓常思惟心高举为性者。如须弥山高绝众峰。无能出其上者。此人心亦尔。常以高举为性。乃至师僧父母等所应尊敬处。皆不能下意。犹如高幢不可屈挠。若欲挠之要必当折。终不改其常操。以忍辱谦卑。于一切众生作大师想。为所对治。第五十七云何海等心。谓常如是受用自身而住者。譬如大海百川归之吞纳无限。此心亦尔。于一切胜事。皆归之于己。谓嫌余人无有比者。常自持如是众多所长。自受用此而住。前心务高此心务广。故云与海等同也。行者觉知已。当念三贤十圣等。无量大功德海。展转深广。自克心行曾未得其尘渧。不应起大慢之心也。第五十八云何穴等心。谓先决定彼后复变改为性者。譬如完坚之器。后若遇缘穿穴无所堪任。此心亦尔初时多所受持。后稍穿漏也。或初发心受戒时。具足无缺不久渐生漏法。同于已败之器法水不停。凡如此例。皆名穴心也。故行者常令所为之事皆有终始。又知性多变改。最能障碍坚固菩提心。为彼对治。第五十九云何受生心。谓诸有修习行业彼生。心如是同性者。如人由白黑业受善恶报。由所作种种杂故。受彼彼无量差别身。此心亦尔。所修诸行。皆欲回向受生。当知得果亦兼善恶也。故行者当念甄择善恶。除去不善纯修白法。就此善中。又复以慧更去粗矿。如是次第。乃至得成纯一清净醍醐妙果。是所对治也。第六十心。梵本缺文。阿阇梨云。少一猿猴心也。猿猴之性。身心散乱常不暂住。行人亦尔。其性躁动不安故。多所攀缘。犹如猿猴放一捉一。大略言之。众生尽然。今就偏盛而言也。此中以不随动散之想。系缘一境。是所对治。犹如猿猴若系之于柱。则不复肆情跷踯腾跃。是所治也。然此六十心。或时行者本性偏多。或由行道用心发动先习。或一时杂起或次第而生。当于一切时留心觉察。自然得顺净菩提心。若阿阇梨为弟子平治心地时。亦当一一简去也

经云。秘密主。一二三四五再数。凡百六十心。越世间三妄执。出世间心生。乃至四分之一。度于信解者。亦是答诸心想及心殊异也。由有无明故。生五根本烦恼心。谓贪嗔痴慢疑。所以不说五见者。以属见烦恼多在六十心中也。此五根本烦恼。初再数为十。第二再数成二十。第三再数成四十。第四再数成八十。第五再数成一百六十心。故云一二三四五再数成百六十心也。以众生烦恼心。常依二法不得中道故。随事异名。辄分为二。就此二中。复更展转细分之。其名相。具如十万偈中说。若更约上中下九品等。乃至成八万尘劳。广则无量。譬如从一种子生五根本。于一根本皆破为二枝。至第五破则成百六十心小枝。从此复更离分。则条叶不可胜计。又如劫初时。人皆化生。以念为食。身光自然安乐无碍。然以不知心实相故。稍贪着地肥。由食味多少。色貌随异。是非胜负之心。犹此而生。以有憍慢心故。福利衰减地肥隐没。乃至地肤林藤亦复不现。次食自然粳米。始有男女之类。淫盗杀妄等种种非法。次第而起。是事阿含中广明。从是以来。有种种族姓种种方俗。起种种业烦恼结。成种种众生趣。造种种五阴之身。自非一切智人。则不能究其条末。诸阿阇梨。所以为此喻者。欲表一无明心随事离分。即成阿僧祇妄执也。越世间三妄执出世间心生者。若以净菩提心为出世间心。即是超越三劫瑜只行。梵云劫跛。有二义。一者时分。二者妄执。若依常途解释。度三阿僧祇劫得成正觉。若秘密释。超一劫瑜只行。即度百六十心等一重粗妄执。名一阿僧祇劫。超二劫瑜只行。又度一百六十心等一重细妄执。名二阿僧祇劫。真言门行者。复越一劫。更度百六十心等一重极细妄执。得至佛慧初心。故云三阿僧祇劫成佛也。若一生度此三妄执。则一生成佛。何论时分耶。然就第一重内。最初解了唯蕴无我时。即名出世间心生也。度世间六十心。离我倒所生三毒根本。名越三妄执也。复次有三妄执。所谓根境界淹留修行。根谓六根。境谓六尘。界谓六识界。以内外十二界即是根境。故合言之。此是三果学人所留滞处。故云淹留修行也。复次有三妄执。所谓业烦恼株杌。及无明种子。即是无学圣人所断。最难断处。凡有三种三妄执也。学摩诃衍人。初得出世初。心与小乘见道适齐。然不堕声闻正位。所以尔者。由彼从初发心。即知心性但为我倒所覆。未得现前。尔时谛观阴界入等。悉从缘生无常变异。是中何者是神耶。作如是推求。即了神本不生。度无量见网。净菩提心少分增明。由得菩提心势力。所以不堕二乘地也。然彼行者有法执当心。若修禅定道品种种诸度时。虽不于中起诸我倒。而心住于禅慧等法稽留淹滞。不能速至菩提。以非如实巧度故。名淹留修行也。然亦稍离下地三执。能拔业烦恼根本无明种子。生十二因缘。知如是甚深之法。有佛无佛性相常尔。如前所说。建立净不建立无净等。种种宗计皆不相应。乃至长爪先尼诸大论师等。自心以智慧利根。推求诸法实相。皆亦不能图度。此十二因缘义。如稻芉等经广明。言湛寂者。寂是不生义。谓五根本烦恼。及百六十随烦恼等。皆毕竟不生故名为寂。湛者是甚深义。譬如清潭万仞澄恬镜彻。临视之者不测浅深。故说云三兽渡河。各随足迹之所至处。独有大香象王。能渐次深进入到其源底耳。此中有三乘之人。同以无言说道。得诸法实相。然声闻入法性最浅。故厌怖生死。自谓已得涅槃。生灭度想。辟支佛所入差深。故于生死不甚忩遽。然不能以方便力发起大悲。菩萨悟如是法时。即知是心垢渐除。所以净心渐现。尔时便得菩提心务力。能以不住道学种种度门。故同前共一法中。而升沉有异也

经云。一切外道所不能知者。此宗中说有两种外道。外外道。犹如睹见清潭。逆生怖畏不敢习近。内外道。虽能游泳其中。适热除垢得清凉乐。然不觉是中有无量宝王。一则不入而不识。二则入而不识。故云一切外道不能知也。先佛宣说离一切过者。言十方三世诸佛。唯有此一门。诱进群迷出于火宅。是处无复障碍戏论不生。故种种因量诸师。无能出其过者。然未度法障。未名真净菩提心。如莲华已离浊泥尚未出水。故经云。出世间心住蕴中也。以行者于瑜伽中。湛寂之心虽已明显。然涉事时。根尘识等犹尚当心。由厌怖有为故。着无为法。然以菩提心势力。自然不由他教也。有如是慧随生能于蕴等发起其心。修离着方便。于五种譬喻观察无性空。初句观察聚沫者如水上浮沫。虽可目睹有种种形。推求性实了不可得。色阴亦尔。若粗若细。无不从众缘生。缘生生无性。即是色本不生也。次句浮泡者。如夏时暴雨。水上浮泡。亦但属众缘。四句观之都无起灭。受阴亦尔。诸苦乐等。皆从情尘和合生。从缘无性。即是受本不生也。次句阳炎者。如春月地气。日光望之如水。迷渴者生企求心。奔趣徒勤去之弥远。众生亦尔。不知缘起性空。有法想生。若悟实相。即想本不生也。次芭蕉者。如人求芭蕉中坚实。乃至分分披拆之。至于邻虚亦不可得。行阴亦尔。一微涉于动境。无不从众缘生。缘生无性。即是行本不生也。次幻事者。如世间咒术药力。蔽惑人心现种种未曾有事。识阴亦尔。从一念无明。幻心初出三界。究其源本。都无生灭去来。当知从众缘生无自性故。亦复本不生也。声闻经中。虽说此五喻。而意明无我。今此中五喻。意明诸蕴性空。如观五蕴者。当知十二入十八界六入十二缘等。皆应广分别说。如大般若中说。行者如是观察时。从无性门达诸法即空。得离一重法倒了知心性。如是不为蕴界处能执所执之所动摇。故名证寂然界。证此寂然界时。渐过二乘境界。如莲花虽未开敷。而稍出清流之上。行者亦尔。不复心没蕴中。故名出世间心。若据正译。当言上世间心也。秘密主彼离违顺八心相续业烦恼网者。如前所说种子根疱等。及归依三宝。为人天乘行斋施善法。皆名顺世八心。若三乘初发道意。迄至拔业烦恼根本无明种子生十二因缘。名违世八心。或可就见道修道等诸位分之。各自有八心也。大乘行者。了达诸蕴性空故。于一切法中。都无所取亦无所舍。双离违顺八心我蕴两倒二种业烦恼网。是名超越一劫瑜只行。瑜伽译为相应。若以女声呼之。则曰瑜只。所谓相应者。即是观行应理之人也。依常途解释。是菩萨从发心以来。经一大阿僧祇劫。方证如是寂然界。今秘密宗。但度此一重妄执。即是超一阿僧祇劫。行者未过此劫。与辟支佛位齐时。名为极无言说处。尔时心滞无为法相。若失方便。多堕二乘地证小涅槃。然以菩提心势力。还能发起悲愿。从此以后三乘径路始分。然所观人法俱空。与成实诸宗未甚悬绝。犹约偏真之理。作此平等观耳。故以三乘上中下出世间心。合论一僧祇劫。至第二僧祇。乃与二乘异也

经云。复次秘密主大乘行。发无缘乘心法无我性。何以故。如彼往昔如是修行者。观察蕴阿赖耶。知自性如幻阳焰影响旋火轮乾闼婆城者。即是明第二重观法无我性也。梵音莽钵罗是无义亦是他义。所谓他缘乘者。谓发平等大誓。为法界众生。行菩萨道。乃至诸一阐提。及二乘未入正位者。亦当以种种方便折伏摄受。普令同入是乘。约此无缘大悲。故名他缘乘。又无缘乘者。至此僧祇。始能观察阿陀那深细之识。解了三界唯心。心外更无一法而可得者。乘此无缘心。而行大菩提道。故名无缘乘也。此无缘乘心。即是法无我性。以行者初劫修观行时心没蕴中故。以五种无性空门。观法无我。然望缘生中道。犹属对治悉檀。若失般若方便。即堕于断灭。名恶取空者滥方广道人。今大乘不可得空相。空相亦不可得。虽观诸法无所有。然亦于诸法无所空。故须离有离无道。观法无我性。为欲净除智障故。随顺古昔诸菩萨修学。观蕴阿赖耶。即楞伽解深密等经。八识三性三无性。皆是此意。经言知自性者。即是知三界唯心也。如幻阳焰影响旋火轮乾闼婆城六喻。皆是双辨有无。明蕴阿赖耶别缘起义。与前劫上五喻观无性空意。复有殊矣。阿赖耶。义云含藏正翻为室。谓诸蕴于此中生于此中灭。即是诸蕴窠窟。故以为名。然阿赖耶有三种义。一者分别义。二者因缘义。三者真实义。如大乘庄严论求真实偈中。以离二及迷依。无说无戏论故。应知三性俱真实。所云离二者。谓分别性真实。由能所毕竟无故。迷依者。谓依他性真实。由此起诸分别故。无说无戏论者。谓真实性真实。由自性无戏论故。次说求真实譬喻偈云。如彼起幻师。譬说虚分别。如彼诸幻事。譬说二种迷。释曰。如幻师依咒术力。变木石等以为迷因。如是虚分别依他性亦尔。起种种分别为颠倒因。又如幻像金等种种相貌显现。如是所起分别性亦尔。能取所取故。二迷恒时显现。次偈云。如彼无体故。得入第一义。如彼可得故。通达世谛实。此中意言。如彼幻事无有实体。此譬依他分别二相亦无实体。由此道理。即得通达第一义谛。又如幻者幻事体亦可得。此譬虚妄分别亦尔。由此道理。即得通达世谛之实。又偈云。彼事无体故。即得真实境。如是转依故。即得真实义。释云。若人了彼幻事无体。即得木等实境。若诸菩萨。了彼二迷无体得转依时。即得真实性义也。又偈云。是事彼处有。彼有体亦无。有体无有故。是故说是幻。此偈明幻事有而非有。何以故。有谓幻像事。彼处显现故。非有谓彼实体。不可得故。如是有体与无体无二。由此义故说彼是幻。又偈云。无体非无体。非无体即体。无体有体无二。是故说是幻。此偈明幻事非有而有。何以故。非有。谓彼幻事无体。由无实体故。而有。谓幻事非无体。由像显现故。如是无体与有体无二。由此义故说彼是幻。此幻即譬诸蕴。是故当知虚妄分别。有而非有。何以故。彼二影显现。而实体不可得故。故说色等有体即是无体。复次虚妄分别。非有而有。何以故。彼二都无实体。然有影显现故。故说色等无体与有体无二。由此有无不二。能遮建立诽谤及趣小乘寂灭。所以然者。由于无体知无体故。不应安立。由于有体知世谛故。不应诽谤。又以彼二无别故。不应厌体入小涅槃。彼偈又云。幻像及取幻。迷故说有二。如是无彼二。而有二可得。骨像及取骨。观故亦说二。无二而说二。可得亦如是。前偈意云。迷人于幻像及取幻。以迷故说有能取所取二事。彼二虽无而二可得。由迷显现故。后偈意云。观行人亦尔。于骨像及取骨。由观故说有能观所观二事。彼二虽无而二亦可得。由观显现故。问曰。如是观已。何法为所治。故彼复说二偈云。应知所治体。谓彼法迷相。如是体无体。有非有如幻。应知能治体。念处等诸法。如是体无相。如幻亦如是。前偈意云。何所治体。即是迷法相。迷法相者。谓如是如是体故。然如是体可说为有。由虚妄分别故。亦说非有由能取所取二体。与非体无别故。如是有亦如幻。无亦如幻故。说此相如幻。后偈意云。能治体即是诸法。谓佛所说念处等。如是如是体故。彼体亦皆如幻。何以故。如诸凡夫所取。如是如是有体故。如诸佛所说。如是如是无体故。如是体无相。而佛世尊示现入胎出生踰城出家成等正觉。如是无相。而影显现。是故如幻。问曰。若诸法同如幻者。以何义故。一为能治一为所治。彼偈答言。譬如强幻主。令余幻王即退。如是清净法。能令染法尽。由此义故。菩萨虽修众行。而无所得也。彼论明观察蕴阿赖耶。了知自性如幻。最与此经符会。故具出之。当知阳焰影响旋火轮乾闼婆城。亦应如是广说。前劫五喻有泡沫芭蕉。此中所以不论者。此三事。犹带拆。法明无性空。然此中幻焰等喻意。明唯识无境体法难解之空。即是粗相转融故不论也。行者解诸蕴唯心。即是知法自性。未了如是自性时。畏堕有所得故。不能尽理观有。畏堕断灭故。不能尽理观空。非但见有不明。亦复见空未尽。今以如幻等门。照有空不二。而人法二空之相。亦不当心。乃名真入法空。悟唯识性故

经云。秘密主。彼如是舍无我。心主自在觉自心本不生。心主即心王也。以不滞有无心无挂碍。所为妙业随意能成。故云心王自在。心王自在。明即是净菩提心。更作一转开明倍胜于前劫也。心王犹如池水性本清净。心数净除犹如客尘清净。是故证此性净时。即能自觉心本不生。何以故。以心前后际俱不可得故。譬如大海波浪以从缘起故。非是先无后无。而水性不尔。波浪从缘起时。水性非是先无。波浪因缘尽时。水性非是后无。心王亦复如是。无前后际。以前后际断故。虽复遇境界风从缘起灭。而心性常无生灭。觉此心本不生。即是渐入阿字门。尔时复离百六十心等。尘沙上烦恼一重微细妄执。名第二阿僧祇劫。故经云。知自心性。是超越二劫瑜只行也。此中无为生死缘因生怀等义。如胜鬘宝性佛性论中广明。今且明宗义故不详说。然上来原始要终。自发一毫之善。以至于超度人法有无二障。虽宗极炳着转妙转深。犹是对治心外之垢。尚未开此心中秘密种种不思议事。从此以后方乃说之。若不作如此对辨则常情各玩先习。不能觉其微妙也

经云。复次秘密主。真言门修行菩萨行诸菩萨。无量无数百千俱胝那庾多劫积集。无量功德智慧。具修诸行无量智慧方便。皆悉成就者。即是欲明超第三劫之心。欲令见闻者信乐尊重故。先叹其功德耳。可知如余教中菩萨。行于方便对治道。次第渐除心垢。经无量阿僧祇劫。或有得至菩提。或不至者。今此教诸菩萨。则不如是。直以真言为乘。超入净菩提心门。若见此心明道时。诸菩萨无数劫中所修福慧。自然具足。譬如有人以舟车跋涉。经险难恶道得达五百由旬。更有一人。直乘神通飞空而度。其所经过及至到之处。虽则无异。而所乘法有殊。又世尊所以先广说如上诸心相者。为教真言门诸观行人。若行至如是境界时。则须明识。不得未到谓到。而于中路稽留也。复次如轮王太子初诞育时。众相备足无所缺减。虽未能遍习众艺统御四洲。然已能任持七宝。成就圣王家业。何以故。以即是轮王具体故。真言行者初入净菩提心。亦复如是。虽未于无数阿僧祇劫。具备普贤众行。满足大悲方便。然此等如来功德。皆已成就。何以故。即是毗卢遮那具体法身故。是以经云。无量无数劫。乃至智慧方便皆悉成就也。又如王子始生。又已龙神兆庶之所宗归。初发净菩提心。亦复如是。已为天人世间迷失正道者。作大归依。若常途诸论所明。证此心时。即名为佛。是故舍利弗等一切声闻缘觉。尽其智力。不能测量。经云所谓出过一切声闻辟支佛地也。以行者得此心时。即知释迦牟尼净土不毁。见佛寿量长远。本地之身与上行等从地踊出诸菩萨。同会一处。修对治道者。虽迹邻补处。然不识一人。是故此事名为秘密。又此菩萨。能于毕竟净心中。普集会十方法界诸佛菩萨。亦自能普诣十方。供养诸善知识。询求正法。唯独自明了。诸天世人莫能知。由此因缘。复名秘密。前二劫中。虽云度二乘地。虽须菩提等。犹能承佛威神。衍说人法俱空。而于此秘密一乘。心生惊疑。不知所趣。乃名直过声闻辟支佛地也。时大威德诸天。不见菩萨心所依处。咸生敬信。故释提桓因作如是愿言。今此上人不久成佛。若彼成佛时。我当奉吉祥草。四天王亦生此念言。若此菩萨成佛时。我当献钵。梵天王亦生此念。若此菩萨成佛时。我当请转法轮。故云亲近敬礼也。已叹入真言门功德竟。然行者复以何法入此门耶。故经次云所谓空性。空性即是自心等虚空性。上文无量如虚空。乃至正等觉显现。即喻此心也。前劫悟万法唯心心外无法。今观此心即是如来自然智。亦是毗卢遮那遍一切身。以心如是故。诸法亦如是。根尘皆入阿字门。故曰离于根境。影像不出常寂灭光。故曰无相。以心实相智觉心之实相。境智皆是般若波罗蜜。故曰无境界。以此中十喻望前十喻。复成戏论。故曰越诸戏论。第三重微细百六十心。烦恼业寿种除。复有佛树牙生。故曰等虚空无边一切佛法。依此相续生。既不坏因缘即入法界。亦不动法界即是缘起。当知因缘生灭。即是法界生灭。法界不生灭。即是因缘不生灭。故曰离有为无为界。若如来出世若不出世。诸法法尔如是住。故曰离诸造作。如般若中。一切法趣眼是趣不过。犹如百川赴海更无去处。是故当知眼即是第一实际。第一实际中。眼尚不可得。何况趣不趣耶。耳鼻舌身意亦如是。故曰离眼耳鼻舌身意。行者得如是微细慧时。观一切染净诸法。乃至少分犹如邻虚。无不从缘生者。若从缘生。即无自性。若无自性。即是本不生。本不生即是心实际。心实际亦复不可得。故曰极无自性心生也。此心望前二劫。犹如莲花盛敷。若望后二心。即是果复成种。故曰。如是初心佛说成佛因。故于业烦恼解脱。而业烦恼具依。此中云佛说者。世尊以十方三世佛为证。言以此一事因缘。为众生开净知见。其道玄同也。行者解脱一切业烦恼时。即知一切业烦恼无非佛事。本自无有缚令谁解脱耶。如良医变毒为药用除众病。又如虚空出过众相而万像具依。若住此不思议解脱时。即是真阿罗汉。不着于有为无为。一切世间应受广大供养。故经云。世间宗奉常应供养也。复次阿阇梨。欲明此应供养故。统论三劫始终。作宝珠譬喻。犹如有如意宝在石矿之中。以世人不识故。弃在衢路之间。与瓦砾无异。然别宝者。见有微相才影彰于外。即便识之。先用利铁镌去钝石。既近宝王其石渐软。复以诸药食之。使矿秽消化。而复不伤其质。尔时粗垢已除尚有细垢。既洗以灰水磨以净叠。种种方便而莹发之。既得光显。置之高幡。能随一切所求普雨众物。尔时世人生奇特想。尊重是宝犹如大天。以能充满所希愿故。然此宝于一时间普应众心。随其所得各各差别。然此众物。为于宝中先有耶。先无耶。若先有者。即此小珠何能顿藏众物。若先无者。又何能顿雨众物。即此世间宝性。已不可思议。何况众生菩提心宝耶。是故诸善知识。才见众生世间八心适萌动时。即便识是真宝。知有可凿之理。如彼相者以曾多识名宝。是以遇便识之。诸佛菩萨亦尔。久已证知亲从一毫之善。自致大菩提道。是故鉴彼情机。即大欢喜。方便诱进令受三归。如前已分别说。譬如收彼顽石置在家中。次以三种三心。拔业烦恼根无明种子。如利铁开凿去其粗矿。次观无缘乘法无我性。如渐至软处。以药物消化而不伤之。次生极无自性心。如灰水莹拭使极光净。尔时生于佛家。名置在高幢雨种种宝。以此因缘故。堪受世闻广大供养也。若行者。直从真言门得见心宝。如仙人善咒术。以神力取之。虽巧拙难易不同。而获宝终无异路。故此经。从浅至深广明心相。皆为开示菩提心本末因缘。若但依常途法相。则不得言诸佛大秘密我今悉开衍也

经云。秘密主信解行地。观察三心无量波罗密多慧观四摄法。信解地无对无量不思议。建立十心无边智生者。此经宗。从净菩提心以上十住地。皆是信解中行。唯如来名究竟一切智地。如花严中。初地菩萨能信如来本行所入。信成就诸波罗密。信入诸胜地。信成就力。信具足无所畏。信生长不可坏不共佛法。信不思议佛法。信出生无中边佛境界。信随入如来无量境界。信成就果。于如是诸事。其心毕竟不可破坏。不复随他缘转。故名信解行地。亦名到于修行地也。观察三心。即是因根究竟心。若通论信解地。则是初地菩萨。得此虚空无垢菩提心时。自然于十无尽界。生十大愿。乃至满足百万阿僧祇大愿。以此即是菩提心为因。从二地以去。增修大悲万行。即是无尽大愿。于十法界生根。乃至渐次增长。至第八地。以去皆名方便地。佛性论云。八地以上境界皆同。但约方便为降阶耳。若观一一地。亦自有三心。如以众多十因缘得入初地。名为因缘。既安住已。以种种大悲万行净治是地。名为根。说净治地果相及方便业。名究竟。余皆准此。此经无量波罗密多四摄法。即是治地也。行者从此无有待对。出过心量不思议地。有十心无边智生。即是初地果相也。花严云。发十大愿已。则得利益心柔软心。随顺心寂静心。调伏心寂灭心。谦下心润泽心。不动心不浊心。次又成就十种净诸地法。所谓信慈悲舍无有疲厌。知诸经论善解世法。惭愧及坚因力。供养诸佛依教修行。复次住是地已。善知诸地障。善知地成坏。善知地相果。善知地得修。善知地法清净。善知地转行。善知地地处非处。善知地地殊胜智。善知地地不退转。善知净治一切菩萨地。乃至转入如来地。如是等有众多十心。若广分别。即有百万阿僧祇度门。故曰无边智生也。更约前三心。作十心说之。若通论信解地。则初地为种子。二地为牙。三地为疱。四地为叶。五地为花。六地为果。七地为受用种子。八地为无畏依。所谓果中之果。九地为有进求佛地慧生。是最胜心。十地此心决定。此二心无别境界。还是于第八心中。约方便转开出之耳。若一一地中。亦自具此十心。且如住初地时。成就净治诸地法。及知诸地相。即是先解一地竟。籍此为因智慧增长。更解二地。以十心类例。推之可知。花严有众多十法门。亦当准此次第广分别说也。然此经宗。从初地即得入金刚宝藏故。花严十地经一一名言。依阿阇梨所传。皆须作二种释。一者浅略释。二者深秘释。若不达如是密号。但依文说之。则因缘事相。往涉于十住品。若解金刚顶十六大菩萨生。自当证知也

经云。我一切诸有所说。皆依此而得者。如上一切智地无尽庄严境界。及余无量修多罗。佛所称叹一切行果。无不因此得之。是故余经。如是广叹娑罗树王茎叶花果。今此经中。唯明此树王种子及生育因缘。若离此因缘能成彼果者。无有是处。所以称大日经王者。非为此乎。经复举益劝修云是。故智者当思惟此一切智信解地。复越一切升住此地。即是初入此信解地。是复越百六十心一重细惑。名度三大阿僧祇劫也。行者初观空性时。觉一切法皆入心之实际。下不见众生可度。上不见诸佛可求。尔时万行休息。谓为究竟。若住此者。即退不堕二乘地。不进得上菩萨地。名为法爱生。亦名无记心。然以菩提心势力。及如来加持力。复能发起悲愿。尔时十方诸佛。同时现前而劝喻之。以蒙佛教授故。转生极无自性心。乃至心之实际亦不可得。虽解脱一切业烦恼。而业烦恼具存。至此不思议地。乃名真离二乘地也。就前三句义中。更开佛地为上上方便心。至此第四心时。名究竟一切智地。故曰此四分之一度于信解也

大毗卢遮那成佛经疏卷第二大毗卢遮那成佛经疏卷第三

        沙门一行阿阇梨记

    入真言门住心品之余

经云。尔时执金刚秘密主。白佛言世尊。愿救世者演说心相。菩萨有几种得无畏处。乃至当得一切法自性平等无畏者。犹是答前心相句。以金刚手既闻此教诸菩萨。直乘真言门上菩萨地故。问世尊此菩萨行道时。有几种得无畏处。佛还复约前三劫。作差降对明也。梵音阿湿嚩娑。正译当言苏息也。如人为强力者所持扼喉。闭气垂将闷绝。忽蒙放舍还复得苏。众生亦复如是。为妄想业烦恼所缠。触缘皆闭。至此六处如得再生。故名苏息处。亦如度险恶道时。其心泰然无所畏惧。故名无畏处也。佛言秘密主。彼愚童凡夫。修诸善法害不善法。当得善无畏者。善义通于浅深。今此中意。明十善业道。如世人以十不善道因缘。漂沉恶趣无有穷已。后得顺世八心。也渐受三归戒。于无量世生人天中。后至涅槃。以免离三途剧苦。名最初苏息处也。若真言行者初入三昧耶。依三蜜供养修行位。与此齐等也

经云。若如实知我。当得身无畏者。如修循身观时。见此身三十六物之所集成。五种不净恶露充满。终不为此而生贪爱。次复观受心法。得离不观我性四种颠倒。于身诸扼缚得苏息处。若真言行者。本尊三昧众相现前时位。与此齐也

经云。若于取蕴所集我身。舍自色像观。当得无我无畏者。谓观唯蕴无我时。于阴界入中。种种分折推求我不可得。舍此自色像者。譬如因树则有树影现。若无树者影由何生。今五蕴尚从缘生都无自性。何况此积集中而有我耶。如上所说。乃至证湛寂之心离一切过。是于我之扼缚得苏息处。若真言行者。于瑜伽境界一切分段中。能观心不可得。不生爱慢位。与此齐也

经云。若害蕴住法攀缘。当得法无畏者。谓行者心住蕴中。欲令发起离着。尔时幻焰等喻。观察诸蕴即空。得离违顺八心证寂然界。然离蕴之扼缚。于法得苏息处。法谓十缘生句也。若真言行者。现觉瑜伽境界。皆如镜像水月无性无生位。与此齐也

经云。若害法住无缘。当得法无我无畏者。即是无缘乘心。观察法无我性。于心外有无影。像智都无所得。心王自在觉本不生。得离法之扼缚。于法无我得苏息处。若真言行者。于瑜伽道中心得自在用时位。与此齐也

经云。若复一切蕴界处。能执所执我寿命等。及法无缘空自性无性。此空智生。当得一切法自性平等无畏者。谓观自心毕竟空性时。我之与蕴法及无缘。皆同一性。所谓自性无性。此空智生。即是时极无自性心生也。于业烦恼等。都无所缚亦无所脱。故云得一切法自性平等。尔时于有为无为界二种扼缚得苏息处即是真言行者虚空无垢菩提心也然此心在缠出缠皆毕竟无相。以如来五眼谛观。尚不能得其像貌。况余生灭中人。今所以广明三劫六无畏处众多心相者。皆是拟仪外迹。以明修证之深浅耳。上已明见烟之相。可已比知火性。但知心垢尽处戏论不行。即是第六无畏依。更欲如何表示耶

经云。秘密主。若真言门修菩萨行诸菩萨。深修观察十缘生句。当于真言行通达作证。乃至如实遍知一切心相者。是略答前问中修行句也。如下文万行方便中。无不藉此十缘生句净除心垢。是故当知最为旨要。真言行者特宜留意思之。然统论此品中十缘生句。略有三种。一者以心没蕴中。欲对治实法故。观此十缘生句。如前所说。即空之幻是也。二者以心没法中。欲对治境界攀缘故。观此十缘生句。如前所说。蕴阿赖耶即心之幻是也。三者以深着没心实际中。欲离有为无为界故。观此十缘生句。如前所说。解脱一切业烦恼而业烦恼具依。即不思议之幻也。摩诃般若中十喻。亦具含三意。今此中云深修观察者。即是意明第三重。且如行者于瑜伽中。以自心为感佛心为应。感应因缘。即时毗卢遮那。现所喜见身说所宜闻法。然我心亦毕竟净。佛心亦毕竟净。若望我心为自。即佛心为他。今此境界。为从自生耶。他生耶。共生无因生耶。以中论种种门观之。生不可得。而形声宛然即是法界。论幻即幻。论法界即法界。论遍一切处即遍一切处。论幻故名不可思议幻也。复次言深修者。谓得净心已去。从大悲生根。乃至方便究竟。其间一一缘起。皆当以十喻观之。由所证转深故。言观察也。且如四谛义。直示娑[口/可]世界已有无量无边差别名。又况无尽法界中逗机方便。何可穷尽。今行者于一念净心中。通达如是尘沙四谛。空则毕竟不生。有则尽其性相。中则举体皆常。以三法无定相。故名为不思议幻。如四谛者。余一切法门例耳。是故唯有如来。乃能穷此十喻。达其源底。此经所以次无垢菩提心。即明十喻者。包括始终综该诸地。既触缘成观。不可纬说。今且依释论。明其大归耳

经云。云何为十。谓如幻阳焰梦影。乾闼婆城响。水月浮泡。虚空花旋火轮。乃至云何为幻。谓如咒术药力。能造所造种种色像。惑自眼故见希有事。展转相生往来十方。然彼非去非不去。何以故本性净故。如是真言幻。持诵成就能生一切者。佛说药力不思议。如人以药力故。升空隐形履水蹈火。此事非诸论师等。能建立因量出其所由。亦非可生疑。谓定应尔或不应尔。过如是筹度境界。唯亲行此药执持行用者。乃证知耳。又如药术因缘。示现能造所造种种色像。虽于众缘中一一谛求都无生处。而亦五情所对明了现前。虽展转相生。往来十方。然亦非去非不去。是事亦非筹度思量之境。释论云。佛问德女。譬如幻师幻作种种事。于汝意云何。是幻所作内有不。答言不也。又问外有不。内外有不。从先世至今世。今世至后世不。幻所作有生者灭者不。实有一法是幻所作不。皆答言不也。佛言。汝颇见闻幻所作伎乐不。答言我亦见亦闻佛言若幻空欺诳无实。云何从幻能作伎乐。女言。大德是幻相法尔。虽无根本而可闻见。佛言。无明亦如是。虽非内有乃至无生灭者。而无明因缘。诸行生。若无明尽行亦尽。乃至广说。今此真言门。喻持诵者亦复如是。如下文广说。依三密修行。得成一切奇特不思议事。虽一一缘中谛求毕竟离于四句。法尔如是。不异净心。而自在神变宛然不谬。此事亦非诸大论师等。聪辨利根者所能测量。独有方便具足得成悉地者。自证知耳

经云。复次秘密主。阳焰性空。彼依世人妄想成立。有所谈议。如是真言相。唯是假名者。释论云。以日光风动尘故。旷野中动如野马。无智人初见之为水。众生亦尔。结使烦恼日光。动诸行尘耶忆念风。于生死旷野中转。无智慧者。谓一相为男。一相为女。复次若远见之。谓以为水。近则无水相。如是远圣法者。不知无我及诸法空。于阴界入性空法中。生人想等。若近圣法。则知诸法实相。是时虚诳种种妄想尽除。此经意云。如世人远望旷野。远望之者。徒见此炎。炎之相强立假名。求其实事都不可得。故云妄想成立有所谈议也。如真言行者于瑜伽中。见种种殊特境界。乃至诸佛海会无尽庄严。尔时应作此阳焰观。了知唯是假名。离于慢着。转近心地。则悟加持神变种种因缘。但是法界焰耳。故云如是真言相唯是假名

经云。复次秘密主。如梦中所见。昼日牟呼栗多刹那岁时等住。种种异类受诸苦乐。觉已都无所见。如是梦真言行应知亦尔时。释论云。如梦中都无实事。谓之有实。觉已知无而还自笑。人亦如是。诸结使眠中实无而着。得道觉时乃知无。觉亦复自笑。又如以眠力故。无法而见法。无喜事而喜。无嗔事而嗔。无怖事而怖。众生亦尔。无明眠力故。不应嗔恚忧怖。而生嗔忧怖等故。今复明此梦事不思议边。如梦中。自见住寿一日二日乃至无量岁。有种种国土及众生族类。或升天宫或在地狱受诸苦乐。觉时但一念间耳。于觉心眠法因缘中。四句求之了不可得。而梦事照然忆持不谬。以一念为千万岁。以一心为无量境。此事非世间智者。忆度筹量能尽其原底。亦非可疑之处。独梦者亲证知耳。今此真言行者瑜伽之梦。亦复如是。或须臾间备见无量加持境界。或不起于座而经多劫。或遍游诸佛国土。亲近供养利益众生。此事诸众因缘中观察。都无所起不出一念净心。然亦分别不谬。此事谁能思议出其所以。然实独证者自知耳。行者得如是境界。但当以梦喻观之。心不疑怪亦不生着。即以普现色身之梦。作无尽庄严。故云深修十句也

经云。复次密主。以影喻。解了真言能发悉地。如面缘于镜而现面像。彼真言悉地。当知如是者。此中言影。即是释论镜中像喻。彼论云。如镜中像。非镜作非面作。非执镜者作非自然作。亦非无因缘作。何以非镜作。若面未到镜则无像故。何以非面作。无镜则无像故。何以非执镜者作。无镜无面则无像故。何以非自然作者。若未有镜未有面。则无像。像待镜待面。然后有故。亦非无因者。若无因缘。应常有应常无。若除镜除面亦应自出。以是故非无因缘。当知诸法亦复如是。以我不可得故。一切因缘生法不自在故。诸法属因缘故。非自作。若自无。他亦无故。非他作。若他作则失罪福力。亦非共作以有二过故。亦非无因。如先世业因今世善恶行缘。从是得苦乐。一切诸法必有因缘。以愚痴故不知耳。如少儿。见镜中像心乐爱着。失已破镜求索智人笑之。失乐更求亦复如是。亦为得道圣人所笑。今此真言门中。以如来三密净身为镜。自身三密行为镜中像因缘。有悉地生犹如面像。若行者悉地成就时。乃至起五神通。住寿长远面见十方国土游诸佛刹。皆以此喻观察是事。从自生。他生耶。若谓他三密加持能授是果。则众生未修行时。佛亦大悲平等。何故不令成就。若谓自如说行能得是果。何因观察三密净镜之身。求加被耶。若共主则有二过。何以故。若谓我心为因。待彼众缘方得成就者。即此因中先有悉地果耶。为先无耶。若先有之。众缘则无所用。若先无之。众缘复何所用。然是悉地成就。亦复非无因缘。故智论镜像偈云。非有亦非无。亦复非有无。此语亦不受。如是名中道。不应如彼少儿妄生取着也。如作如是观故。行者心无所得。不生戏论故。曰应如是知

经云。复次秘密主。以乾闼婆城譬。解了成就悉地宫者。释论云。日初出时。见城门楼橹宫殿行人出入。日转高转灭。此城但可眼见。而无实有。有人初未曾见。意谓实乐。疾行赴之。近而遂失日高遂灭。饥渴闷极。睹热气如野马。谓之为水。复往趣之。乃至求之。疲极而无所见。思惟自悟渴愿心息。行者亦尔。若以智慧无我无实法者。是时颠倒愿息。声闻经中。无此乾闼婆城喻。又以城喻身。说此众缘实有但城是假名。为破吾我故。菩萨利根。深入诸法空中。故以乾闼婆城为喻也。此中言悉地宫。有上中下。上谓密严佛国。出过三界非二乘所得见闻。中谓十方净严。下谓诸天修罗宫等。若行者成三品持明仙时。安住如是悉地宫中。当以此喻观察。如海气日光因缘。邑居严丽层台人物灿然可观。不应同彼愚夫。妄生贪着。求其实事。以此因缘。于种种胜妙五尘中。净心无所挂碍也

经云。复次秘密主。以响喻解了真言声。如缘声有响。彼真言者当如是解者。释论云。若深山峡谷中。若深绝涧中。若空大舍中。以语言声相击故。从声有声名为响。无智人谓为有实。智者心念。是声无人作。但以声转故。更有响声诳人耳根。人欲语时。亦咽口中有风。名忧陀那。还入至齐。响出时。触顶及断齿唇舌咽胸七处而退。是名为语言。愚人不解而生三毒。智者了知心无所著。但随诸法实相。真言行者若于瑜伽中。闻种种八风违顺之音。或诸圣者以无量法音现前教授。或由舌根净故。能以一音遍满世界。遇此诸境界时。亦当以响喻观察此。但从三密众缘而有。是事非生非灭非有非无。是故于中不应妄生戏论。尔时自入音声慧法门也

经云。复次秘密主。如因月出故照于净水。而现月影像。如是真言水月喻。彼持明者当如是说者。释论云。月在虚空中行。而影现于水。实法性月轮。在如如法性实际虚空中。而凡夫心水。有我我所相现。又如小儿见水中月欢喜欲取。大人见之则笑。无智者亦尔。身见故见有吾我。无实智故见种种法。见已欢喜欲取诸相。得道圣人笑之也。复次譬静水中见月影。扰水则不见。无明心静水中。见吾我憍慢诸结使影。实智慧杖扰心水。则不见。以是故。说诸菩萨知法如水中月。持明行者亦如是。由三蜜方便自心澄净故。诸佛蜜严海会悉于中现。或自以如意珠身。于一切众生心水中现。尔时应谛想观之。今此蜜严之相。从我净心生耶。从佛净身生耶。自他实相尚自毕竟不生。何况相违因缘而有所生。又如一切江河井池大小诸器。月亦不来水亦不去。而净月能以一轮。普入众水之中。我今亦复如是。众生心亦不来。自心亦复不去。而见闻蒙益皆实不虚。故当以慧杖搅之。便知无实。不得如彼婴童。欲作方便取之。以为玩好之具也。既能自静其意。复当如如不动为人演说之。故曰持明者当如是说

经云。复次秘密主。如天降雨生泡。彼真言悉地种种变化。当知亦尔者。声闻经以受譬浮泡。般若中以泡为喻。虽实无性。而因缘犹是实法。欲十句中有如化而不明泡。喻今此经譬。意复殊也。如夏时雨水自雨水中。随渧之大少生种种浮泡。形类各异。然水性一味自为因缘。四句推求无别所生之法。是故此泡举体从缘。泡起即是水起。泡灭即是水灭。故以此喻即心之变化也。如行者即以自心作佛。还蒙心佛示悟方便。转入无量法门。又以心为漫荼罗。此境与心为缘能作种种不思议变化。是故行者以浮泡喻观之。了知不离自心。故不生着也。释论又云。修定者有十四变化。天龙鬼神亦能作化。如化生光无定物。但以心生便有心灭则灭。是法无初中后。生是无所从来。灭亦无所至。当知诸法亦如是。复次如变化相。清净如虚空无所染着。不为罪福所污。诸法亦尔。法性如如实际。自然常净。譬如阎浮提四大河。一一河有五百小河以为眷属。此水种种不净。入大海中皆悉清净。与泡喻意同也

经云。复次秘密主。如空中无众生无寿命。彼作者不可得。心以迷乱故。而生如是种种妄见者。释论云。如虚空者。谓但有名而无实法。虚空非可见法。远视故。眼光转见缥色。诸法亦如是。空无所有。人远无漏实智慧故。弃实相。见彼我男女屋舍城郭等种种杂物。心着如少儿仰视青天。谓有实色。有人飞上。极远而无所见。又如虚空性常清净。人谓阴曀为不净。诸法亦如。是性常清净。淫欲嗔恚等曀故。人谓不净。此经云。心迷乱者。如人以疾病非人等种种因缘。其心迷乱。妄见净虚空中有种种人物形相。或可怖畏或可贪着。若得本心时。则知此事生时不染虚空。灭时亦非还净。本来不碍虚空。亦不异于空。行者修观行时。若有种种魔事种种业烦恼境。皆当安心此喻如净虚空。虽于无量劫中处于地狱。尔时意无挂碍。如得神通者。于空一显色中自在飞行。不为人法妄想之所尘污也

经云。复次秘密主。譬如火烬。若人执持在手。而以旋转空中。有轮像生者。如人持火烬。空中旋转作种种相。或方或圆三角半月。大少长短随意所为。愚少观之。以为实事而生念着。然实都无法生。但手中速疾力。能运一火成无量相耳。真言行者若于瑜伽中。随心所运无不成就。乃至于一◇阿字门。旋转无碍成无量法门。尔时当造斯观。但由净菩提心一体速疾力巧用使然。不应于中作种种见计。为胜妙而生戏论也。释论无火轮喻。别有影喻。云如影可见而不可捉。诸法亦如是。眼情等见闻觉知。实不可得。又如影映光则现不映则无。诸结使烦恼遮正见光。则有我相法相。又如影。人去则去人动则动人住则住。善恶业影亦如是。复后世去时亦去。今世住时亦住。报不断故。罪福熟时则出。然是影非有物。但是谁眼法。如旋火[火*曹]疾转成轮。亦非实有。喻意大同也。秘密主。应如是了知大乘句心句无等等句。必定句正等觉句。渐次大乘生句者。梵音谓句为钵昙。义如前释。此十喻皆是摩诃衍人甚深缘起。非声闻缘觉安足之处。故名大乘句。心之实性。更无一法可以显示之者。亦不可授人。但如是深观察时。障盖云披。自当证知耳。故名心句。如来智慧。于一切法中无可譬类。亦无过上。故名无等。而心之实相。与之函盖相称间无异际。故曰无等等。若以十缘生了知心处。则安住其中。故曰无等等句。诸佛以此十缘生义。必定师子吼说如来性心实相印。若有能信解者。假使十方世界一切诸魔。皆化身作佛说相似般若。亦不能变易其心。使法相不如是。故曰必定句。以此中道正观。离有为无为界。极无自性心生。即是心佛显现。故曰正等觉句。以深修观察故。如入大海渐次转深。乃至毗卢遮那。以上上智观。方能尽其源底。故曰渐次大乘生句。当知如是六句。次第相释次第相生也。毗卢遮那即以此十缘生句不思议法界。作无尽庄严藏。从十世界微尘数诸法界门。常出生根力觉道禅定解脱诸宝。遍施众生犹尚不匮。故曰具足法财。一切如来智业由此具足。故曰出生种种工巧大智慧。若于一念心中。明见十缘生义。则上穷无尽法界。下极无尽众生界。其中一切心相。皆能了了觉知。以皆从缘起。即空即儗即中故。故曰如实遍知一切心相。阿阇梨言。行者初修观行境界现前时。由内因外缘力故。自然有缘起智生。不同常途习定功力苦至而后通彻也。梵本中云。自此以后。次说真言者持诵次第。如法悉地。如法果生。此是传法者所记。故不于经中具出其大意言。已说净菩提心诸心相竟。从此以下。明进修方便及悉地果生也

    入漫荼罗具缘真言品第二

入漫荼罗具缘真言品第二者。上品已约种种心相。对辨一切智心竟。然此妙果。以何方便而能得至耶。故此品。次明入漫荼罗行法。具众缘支分及所要真言。皆于此中广明。譬如已知乳酪有醍醐性。即教令具诸器物方便攒摇。以从缘起故。当知不异十缘生句也。复次声闻经中。以毗尼为秘藏。要择人简众方乃授之。若未发律仪不合听闻修习。摩诃衍中亦以持明为秘藏。未入漫荼罗者不合读诵受持。还同盗听布萨反招重罪。所以然者。如世人慈育稚子。虽复情无所吝。而不授与干将莫耶。以不知运用方便故。必伤其体。今此法门亦复如是。即心成佛旨趣难知。恐未来众生轻慢法故。不能咨访善知识。未蒙三密加持。而自师心执文。辄自修学。久用功力无所能成。反谤此经谓非佛说。又此经文。有浅略深秘二释。就深秘释中复有浅深。辄尔披玩者。以不解密号故。谓是因缘事相。心生慢易自言。我行真道何用咒术事耶。以如是等因缘。感匮法业。于无量劫堕恶趣中。所以修学真言者。要令先入漫茶罗也。漫荼罗名义下当更释

经云。尔时执金刚秘密主。白佛言。希有世尊。说此诸佛自证三菩提。不思议法界超越心地。乃至一切支分。皆悉出现如来之身。遍至十方。还来本位中住者。即金刚手。承佛神力领解上文。先叹世尊甚为奇特。由具大方便故。乃能说此诸佛自证三菩提。所谓自心自觉不可思议法界。出过一切心地。的无所依也。如世人举趾动足皆依于地。菩萨亦如是。依心进行。故名此心为地。以心尚有所依故。未名正遍知。如来已度此微细戏论进趣都息。故名超越心地也。虽究竟寂灭不可言宣。而能以种种方便道。为众生类。如本性信解而演说法。即是领解一切智心无尽庄严之迹也。不思议法界即喻莲花台。种种方便道即喻莲花叶。此领解中文虽简略。而提举宗通妙旨。无所不周。次即请佛。唯愿世尊。次说修真言行大悲胎藏生大漫荼罗王也。今且约胎藏为喻。行者初发一切智心。如父母和合因缘。识种子初托胎中。尔时渐次增长。为行业巧风之所匠成。乃至始诞育时。诸根百体皆悉备足。始于父母种姓中生。犹如依真言门。学大悲万行净心显现。又此婴童。渐具人法习诸伎艺。伎艺已通施行事业。如于净心中。发起方便修治自地。随缘利物济度众生。故名大悲胎藏生也。复次初入净菩提心门见法明道。如识种子歌罗罗时。前七地以来。为大悲万行之所含养。如在胎藏。无功用以去渐学如来方便。如婴童已生习诸伎艺。至如来一切智地。如伎艺已成施于从政。故名大悲胎藏生。又是一重秘密漫荼罗也。今以莲花喻此漫荼罗义。如莲种在坚[穀-禾+卵]之中。枝条花叶之性已宛然具足。犹若世间种子心。从此渐次增长。乃至初生花疱时。莲台果实隐于叶藏之内。如出世间心尚在蕴中。又由此叶藏所包。不为风寒众缘之所伤坏。净色鬓蕊日夜滋荣。犹如大悲胎藏。既成就已。于日光中显照开敷。如方便满足。今此中妙法莲花漫荼罗义。毗卢遮那本地常心。即是花台具体。四佛四菩萨。醍醐果德。如众实俱成。十世界微尘数金刚密慧差别智印。犹如鬓蕊。十世界微尘数大悲万行波罗密门。犹如花藏。三乘六道无量应身。犹如根茎条叶发晖相间。以如是众德轮圆周备故。名漫荼罗也。然以如来加持故。从佛菩提自证之德。现八叶中胎藏身。从金刚密印现第一重金刚手等诸内眷属。从大悲万行。现第二重摩诃萨埵诸大眷属。从普门方便。现第三重一切众生喜见随类之身。若以轮王灌顶方之。则第三重如万国君长。第二重如朝廷百揆。第一重如宗枝内弼。中胎如垂拱之君。故花台常智。为大漫荼罗王也。若自本垂迹。则从中胎一一门。各流出第一重种种门。从第一重一一门。各流出第二重种种门从第二重一一门。各流出第三重种种门。若行因至果。则第三重之所引摄成就。能通第二重。第二重之所引摄成就。能通第一重。第一重之所引摄成就。能见中胎藏。由此言之。则诸众生类本性信解。虽复无量无边。而此漫荼罗法门。所为义利。亦复罄无不尽。故云为满足彼诸未来世无量众生。为救护安乐故也

经云。尔时薄伽梵毗卢遮那。于大众会中遍观察已。告执金刚秘密主言。谛听金刚手。今说修行漫荼罗行。满足一切智智法门者。此中大会。即是法界漫荼罗所摄应度众生。今佛欲说深密之行。为令不差道机故。以慧眼观察。即此慧眼所加持故。先世善萌无不开发。犹如良田已布善种。则堪受时雨之施也。此修行。梵音娜耶。即是乘义道义。谓从一念善根乃至成佛。于是中间。一一诸地所乘之法所行之道。通名娜耶。漫荼罗中诸善知识。如造乘治道及将导者。众生乘而行之。名修漫荼罗行。此行。梵音折利耶也。且如下文云。先为弟子择治平地。若论外事自如常释。若为我倒凡夫。择得一念守斋种子心治令平正。亦名治地。乃至为一生补处菩萨。择去心中无明父母极细之垢。亦名治地。由此言之。则经文一一言之下治地之义。凡有几重。例如十缘生句。皆渐次转深不可穷尽也。执金刚作如是劝请。佛佛还以此印印之。而后衍说。故云满足一切智智法门。若此地不满。则不能普为一切众生作救护安乐也

经云。尔时毗卢遮那世尊。本昔誓愿成就无尽法界度脱无余众生界故。一切如来同共集会。渐次证入大悲藏发生三摩地者。以如来本行菩萨道时。立如是誓愿。我当成就一切诸佛法界。悉皆度脱无余众生界。今所愿已满。而应度众生不尽。以众生无尽。即是法界亦无尽也。界有三种。所谓法界心界众生界。离法界无别众生界。众生界即是法界。离心界无别法界。法界即是心界。当知此三种无二无别。为欲转释法界义故。次言无余众生界。以众生界未得一切解脱。即是法界未得遍满成就。故如来勤修事业。无有休息也。即以此本愿因缘故。一切如来同共集会。如僧中有大事因缘若结界说戒之类则众僧集会同共印持。以一戒一见故。不应别众也。今将说满足一切智智法门。亦是诸佛大事因缘。以同一本誓同一法界故。皆悉集会。共以神力加持也。渐次证入者。如初无畏时。以声字观修漫荼罗行。第二无畏。于有相观中修漫荼罗行。第三无畏。于唯蕴无我心中修漫荼罗行。第四无畏。于法缘心中修漫荼罗行。第五无畏。于无缘心中修漫荼罗行。第六无畏。于平等心中修漫荼罗行。离垢地以去。各于自地观心中修漫荼罗行。略以行位分之。已作十六重深浅不同。此一一位。自有菩提种子心。有大悲胎藏增长因缘。有慧方便业受用之果。如前所说。从一一门。各流出种种门等。其中从因向果。则三密方便展转不同。容极至心王大海。方一味无别耳。今此十方诸佛。本行菩萨道时。各乘一法门。到于一切智地。以将说普门众行发起因缘。同共入此大悲胎藏三昧。从本所修行道。渐次证入一一观之。如菩萨修禅时于九次第定中。逆顺出入定散超间。奋迅游戏无不自在。是诸如来。渐次证入大悲藏发生三摩地。亦复如是。或观无尽法界。以一切心为一心。以一切门为一门。或观无余众生界。以一心为一切心。以一门为一切门。若以此十六重玄义。即横竖统摄十二部经。则旋转无尽也。经云。世尊一切支分。皆悉出现如来之身者。前现庄严藏时。普门一一身各遍十方。随缘应物。今欲说漫荼罗圆位故。还约佛身上中下体。以部类分之。自齐以下。现生身释迦示同人法。及二乘六趣种种类形色像威仪。言音坛座各各殊异。及其眷属展转不同。普于八方。如漫荼罗本位次第而住。自齐以上至咽。出现无量十住诸菩萨。各持三密之身。与无量眷属普于八方。如漫荼罗本位次第而住。然此中自有二重。从心以下。是持大悲万行十佛刹微尘诸大眷属。从心以上。是持金刚密慧十佛刹微尘诸内眷属。通名大心众也。从咽以上至如来顶相。出现四智四三昧果德佛身。即此八身于一切世界中。徒众刹土名号身业。诸受用事皆悉不同。亦于八方。如漫荼罗本位次第而住

经云。为彼从初发心。乃至十地诸菩萨者。谓初发净菩提心时。见此漫荼罗。已遍法界。升第二住。又逾广逾深作十转开明。乃至第十一地而后所见圆极。如是安布分位已。即皆遍至十方。于自法界门。施作真言事业。示现进修次第。教授众主。此相现前了了无碍。下文所说。但开出此心作名字流通耳。又令普现随类身。而言悉现如来身者。明本迹俱不思议加持不二。岂欲令独一法界作种种形耶。行者如是解时。观毗卢遮那与鬼畜等尊。其心平等无胜劣之想。辄从一门而入皆见心王。是故作佛事已

经云。遍至十方。还来入佛身本位。本位中住而复还入。意明一切方便毕竟同归也。经云。时薄伽梵。复告执金刚秘密主言。谛听金刚手。漫荼罗位初阿阇梨者。从此已后迄灌顶教诫竟。金刚手问得几所福德聚。而白佛言。从今以后我当供养是善男子善女人。何以故。彼善男子善女人。同见佛世尊故。此明入漫荼罗众多支分。又自大力明妃。迄第二品末。明缘坛行事所要真言也。就众多支分中。最初明阿阇梨支分。所以然者。佛说此经要从师受不得辄尔修行。若无明师。则所传无寄故也。然以解二种义故。得阿阇梨名。所谓浅略深奥分。若观前人。未有深解之机。则顺常途随文为释。若已成就利根智慧。则当演畅深密而教授之。今还以此二分释阿阇梨义。若于此漫荼罗种种支分。乃至一切诸尊真言手印观行悉地。皆悉通达得传教灌顶。是名阿阇梨。若度违顺八心证寂然界。是名阿阇梨。若已心王自在。觉自心本不生。名阿阇梨。若生极无自性心。得入如上漫荼罗海会。名阿阇梨。从此复有十重深行。乃至于解三密人中。最为上首如金刚萨埵。是名阿阇梨。复次毗卢遮那。是名阿阇梨。是故作最初阿阇梨事业时。即须观照自身。即同于金刚萨埵毗卢遮那。以身语密印而作加持。乃名善住师位。不尔无所能成也。自余深行者即可以意得。次明阿阇梨众德

经云。应发菩提心者。谓生决定誓愿。一向志求一切智智。必当普度法界众生。此心犹如幢旗。是众行导首。犹如种子。是万德根本。若不发此心。亦如未托歌罗罗。则大悲胎藏何所养育。自不能建立善根。况复为人师耶。当约一一地作深密释。乃至毗卢遮那。始名无尽法界究竟发心耳

经云。妙慧慈悲者。般若有二种。有与六波罗密和合般若。有实相般若。此中意明初句。此慧犹如巧风。能轨匠歌罗罗心使百体成就。行者犹有慧。故则能善知通塞判决是非。于漫荼罗一切事业中。动合规矩心无疑滞。乃堪作阿阇梨。以要言之。若同毗卢遮那智业圆满。是名深行阿阇梨也。慈悲。谓怜愍之心彻于骨髓。诸有所作。皆为建立众生。必使成就无尽法界之乐。度脱无余众生界之苦。若无此心。则如胎藏不成。又安能有所含养。乃至毗卢遮那以本愿故。住于加持世界。普现悲生漫荼罗。是名深秘阿阇梨。兼综众艺者。谓妙善世间种种伎艺也。谓声论因论。十八明处六十四能。算数方药观相工巧之类。缘漫荼罗所要皆不假于人。则造次施为无阙乏之过。然后堪作阿阇梨。复次行如是法中。尽与实相不相违背。名为妙善众艺。复次于一切总持三昧门道品。诸度四辨四摄力无畏等。皆得善巧。则能随意造作秘密漫荼罗。名为妙善众艺也。善巧修行般若波罗蜜者。即是深修观察十缘生句。见甚深中道。照不可得空。是事如摩诃般若中广说。若行者于文字及观心中。善得通达离于见着。乃应为人作世间阿阇梨也。复次初劫智慧犹与二乘共行。非深般若。二劫智慧尚与二乘共闻。亦非甚深般若。第三劫等虚空心无边智慧。一切二乘不能思议。乃名甚深般若。堪作秘密行阿阇梨也。就秘密中又渐次转深。乃至佛为十地说般若。则九地非其境界。唯大毗卢遮那得名究竟阿阇梨也。通达三乘者。谓于大小乘三藏教中。善其文义也。能难能答。堪可匠成三学拔除弟子恶邪。乃应作阿阇梨。若不尔者。或为他论议师辈之所摧屈。则于传法无力生他不信也。又此经宗。横统一切佛教。如说唯蕴无我出世间心住于蕴中。即摄诸部中小乘三藏。如说观蕴阿赖耶觉自心本不生。即摄诸经八识三无性义。如说极无自性心十缘生句。即摄花严般若种种不思议境界。皆入其中。如说如实知自心名一切种智。则佛性一乘如来秘藏。皆入其中。于种种圣言。无不统其精要。若能持是心印。广开一切法门。是名通达三乘也。复次真言门。乘三密印至佛三平等地。名为通达三乘。浅深重数如前说。善解真言实义者。如真言门。有种种真言种种身印种种本尊。乃至具缘供物一一支分。声字形色诸相不同。随事分别识其性类。知如是法寂灾处用。如是法增益处用。如是法降伏处用。如持明藏苏悉地等广分别说。此是通达真言实义。所以然者。一一真言。皆如来妙极之语也。如真言中有质多字。浅释只名为心。若作深秘释。质谓遮字带三昧声也。遮是无迁变义。无迁变即是佛性。佛性亦名般若波罗蜜。亦名首楞严三昧。是故定慧具足。多字是一切法如如解脱不可得义。若如是说心。乃名妙极之语也。复次如身印。左手是三昧义。右手是般若义。十指是十波罗蜜满足义。亦是一切智五轮譬喻义。如本尊形。女是禅定。男是智慧。黄色是金刚身。白是大悲。赤是大慧。青是大空。黑是大力。乃至一切缘中。皆有第一实际义。岂可如文生解耶。若通达如是实义。乃应作阿阇梨。亦约三劫十地以明深行也。知众生心者。以阿阇梨善知三部上中下用。种种性类差别。及住瑜伽故。以加持方便。能了知众生心行也。如有来求法者。师应谓言。汝且随所安。我当思惟。即是持彼名字。入于静室如法持诵。观彼因缘。以本尊加被故。当见相貌。若是外道欲来盗法。或伺求其便而来诈亲。尔时本尊或现外道等形。审观像类自然可识。应方便遣喻言。善男子。夫求法者。应先除断一切恶见巧伪之心。又诸菩萨为度众生故。能作种种难行苦行。汝今岂能为此难行事耶。且随本缘而作利益。若境界中。见本尊在漫荼罗。将引弟子为其灌顶。或持以付之。如是等种种善相。则应摄授。复次若本尊舍本色像而作赤色。是人性多嗔恚。黑色多痴。黄色多贪。白色多善。缥色多无记。及于漫荼罗中。观察花所至处。上中下类种种微相。亦可知彼心机是器非器也。然于如是相中不应取着。亦以十缘生句而观察之。于如是事一一明了。堪住师位也。复次深秘释者。知众生心。即是如实知自心。以能知自心故。即能明识他心。如家有宝藏即善鉴他宝。乃至诸根性欲本末因缘。心所动作戏论。无不了了通达。是名深行阿阇梨也。信诸佛菩萨者。阿阇梨言。一切善法以信为首。当最初说之。今顺梵文语便。兼以通于后位故。作不次说耳。谓此宗。初入法门时。意尤浅近难识。且三乘实相。无不离于文字。而真言者。要须口诵梵文心亦观之。或屈申身分支节犹如戏弄。或修三昧乃观女人之像或忿怒等形。或以水灌顶。或造作火坛。若欲以心识筹量。则加持之迹又不可见。自非具深信者。安得不疑惑耶。又此行者。于此众缘事相。皆以谛信行之。若勤苦多是未蒙现益。尔时即自思惟。由我功行未至。或由三毒垢染惑障重故。如浣衣钻火。但勿中途休废。自当纯净目睹光明耳。复当思惟幻喻。如药物和合而得升空住寿。亦非利根智慧所能思识。但令妙解其术无不成者。以此深心净信离疑惑故。渐得法验现前。复由法验现前故。信解转增不可俎坏。若不如是者。则同无手之人。虽至不宝藏中空无所得。况在阿阇梨位乎。复次众生一念心中。有如来寿量长远之身寂光海会。乃至不退诸菩萨。亦复不能知。当知此法倍复难信。故法花中。补处三请如来四诫。然后演说。今此经。具有修入方便。乃至一生可成。若能谛受不疑。到于信地或度于信解。乃名深行阿阇梨也。得传教灌顶善解漫荼罗画者。灌顶有二种。谓于弟子法中得灌顶已。渐次进修。乃至成就阿阇梨众德。尔时得阿阇梨欢喜。更为造漫荼罗作传教灌顶。如法慰喻言。佛子汝已于秘密藏中。随顺修学具足明了。堪能教授于他。汝今已得善利。乃至诸贤圣众亦皆称叹。今已作灌顶竟。汝当以真净心传持流布。使如来秘密藏久久不灭。如是随其所应种种慰喻已。即应为人作漫荼罗阿阇梨也。复次行者于瑜伽中。阿阇梨众德成就。尔时深行阿阇梨。为作心漫荼罗。尔时弟子了了。明见得蒙大毗卢遮那。以大悲水作心灌顶。是事下当更说。乃至地波罗蜜满足时。十方诸佛现前灌顶授佛职位。皆名得传教灌顶也。已得传教灌顶。不应作最后断种人。应绍先师事业度诸弟子。即此最初方便。须解漫荼罗图像。故次明之。谓此中一一方位相貌。调布众色缋画庄严。皆应自善其事不看他面。乃堪作阿阇梨。复次能于净菩提心。以慧方便。画作无尽庄严大漫荼罗王。乃名深行阿阇梨。其性调柔离于我执者。此我执。梵本作灌顶字。阿阇梨相传云。此字义不相应。当云离于我执也。其性调柔。即是安住传教威仪住忍辱地。柔和善顺而不卒暴。虽种族色相多闻智慧。无不出群绝众。亦不生高慢之心。能慈心下济诱诲新学。乃至卑小姓等。亦不怀下劣之想嫉妒之心。但一心以法自调依法而住。如是调柔。即是离于我执。是转相释也。复次调柔者。如百练纯腊以调柔故。随工巧之手无所不为。今行者净治此心。一切粗矿尽故。随巧慧之手无所不为。故能住忍辱地随缘应物。又诸佛菩萨法门中入道。犹如上族。诸天龙鬼法门中入道。犹如下族。即以此身。作大日如来尊特相海。犹如色貌第一。望不能作者。犹如垢衣蕞漏。于一心中悉闻诸佛说法。分别不谬。名为多闻。望六根暗塞者。名为少闻。无量智慧自然开敷。名为智慧。无明三毒名为愚痴。以如是诸法毕竟等故。不应心有高下。故名调柔。唯佛一人。乃名一切调柔善住阿阇梨法也。于真言行善得决定者。调于造立漫荼罗种种方便中。心得决定离诸疑网。所谓如是护身如是结界如是迎请。如是净诸供具而以奉献。以如是真言手印加持。乃至持诵进修。及成悉地时。亦有无量次第法。如是备在下文及供养次第中。不能缕说。若行事时。及他决择违妨。方复踌躇观察。或取本寻捡。不名善作阿阇梨也。复次阿阇梨。以于瑜伽得决定故。随有所作。皆与三昧相应。如献花时。即与花三昧相应。此中本尊明了现前。若奉香灯涂香阏伽水等时。亦与香三昧乃至香水三昧相应。一一本尊亦随事现前。如是一一缘中。皆是入法界门皆见善知识。旋转运用皆与理相应。不复临事稽留方始作观。当知是人堪作秘密阿阇梨也。究习瑜伽者。谓善修相应法也。谓于三部真言上中下成就等事。一一通达。皆与正理相应。名善修瑜伽。又于息灾法中。即能以此方便增益降伏。或增益法中。即能以此方便降伏息灾。于降伏法中。即能以此方便息灾增益。随彼彼相应之法。皆能善分别之。名善修瑜伽。又于漫荼罗中种种本尊。三昧形色字印性类威仪。及供养成就时运心观察方便。皆已相应修习。此中障碍及悉地相。亦善觉知乃可传法也。复次大悲胎藏发生三昧中。有种种法界门种种善知识。如善财童子次第询求。或于如是法门已善修行。而于余门未能究习。若入普门世界时。则能于一念中具足相应。是名深行阿阇梨也。住勇健菩提心者。勇健是雄猛无怯弱义。所以须此心者。以真言行者未见真谛以来当有违顺境界。或现种种可畏形色。或作异声。乃至震动大地。或有大力毗那野迦现作留难。尔时安心不动。无有退屈。依于法教而净除之。犹行者见此净菩提心有大义利故。自然出生入死无怖畏想。彼彼魔事不能留碍也。又未见菩提心时。于瑜伽中。当有种种相见。所谓地水火风虚空。青黄赤白黑色等诸异相貌。尔时心未明了故不能甄辨。亦不应生退转之意。但作是念。此事非无因缘。若我见谛时。于菩提心明了无碍。自当解耳。又当以十缘生句观之。心不取舍。但当勇进行菩萨道。既证菩提心已。即知往昔某时有如是相。复于某时更有如是事相。皆为如是因缘。无不鉴其先兆识其本末也。复次行者照见心明道时。即于无尽大愿得坚固力。乃至毗卢遮那金翅鸟王。俯观法界大海如视明镜。奋止观翅搏天人龙。乃是勇健菩提心也。秘密主。如是法则阿阇梨。诸佛菩萨之所称叹者。以众德兼备故。即能流通密教不断佛种。是名佛之真子。从真言行生。常为众圣之所称叹也。若弟子修瑜伽行。则能见此上人天龙八部恭敬供养。或见十方诸佛称其名号劝发大众。如释迦牟尼。说菩萨萨陀波仑求法因缘也

经云。复次秘密主。彼阿阇梨若见众生。堪为法器远离诸垢。有大信解勤勇深信常念利他者。即是阿阇梨支分中。明摄受弟子仪式也。此中众生有二种。或已发菩提心。往诣善知识所求请真言行法。或未发菩提心。而师自鉴别之。知彼堪为法器能持是法。或于瑜伽中见彼根缘。或诸佛菩萨之所嘱累。令为灌顶而教授之。或亲见众圣为其作灌顶法。然后付嘱令其教授。有如是相乃可传法也。如贫里秽食。不可置于宝器。轮王妙药。不可使薄福之人辄尔服之。以不消故。或能断命故。须函盖相称则授受皆得其宜。又如弊衣垢腻滋甚。则不可顿加染色。先当教令浣灌。然后可以施彩绘之功。众生亦尔。若先习垢染。则不染法界之色。故须远离诸垢也。有大信解者。此信解。梵音阿毗目底。谓明见是理心无疑虑。如凿井已渐至泥。虽未见水必知在近。故名信解也。下云深信者。此信。梵音舍攞驮。是依事依人之信。如闻长者之言。或出常情之表。但以是人未尝欺诳故。即便谛受依行。亦名为信。与上文信诸佛菩萨义同。梵语本是两名。唐音无以甄别故。同名言信耳。若人闻说如上不思议法界。以宿殖善本。神情明利故。即能忍受其言。知众生心中决有此理。名为信解。又先世已曾亲近善知识故。于三宝缘深。虽不可比量筹度处。即能悬信。故曰深信。勤勇是精进别名。释论云。譬如穿井以见湿泥转加精勤必望得水。又如钻火已得见烟。倍复力励必望得火。故次信解而明勤勇也。所以然者。今此自然智慧。要因瑜伽。而此瑜伽。必须大精进力。故释论云。禅定智慧。不可以福愿求。亦非粗观能得。要须身心精勤急着不懈尔乃成辨。如佛所说。血肉脂髓皆使竭尽。但令皮骨筋在不舍精进。如是乃得定慧。得是二事则众事皆辨。故须具精进性者。方可传授也。复次精进是一切善法之根本。能发动先世福德。如雨润种能令必生。若无勤勇之心。则虽有宿殖之业。无由发起。乃至今世利乐尚不可得。何况菩提道邪。是故由发行因缘便得深信。以深心故。即能志求胜法荷负众生。须养以大悲胎藏令得增广。故云有常念利他之性者。方可传授也。复次阿阇梨。于瑜伽中。见闻诸佛菩萨称其具如斯德。或见在众圣前。至诚勤恳希求道要。经历多时初不懈退。乃行利他之事救摄众生。本尊哀愍遣令教授。诸如是例可以意知。又深行阿阇梨六根净故。见彼无量劫来障道成道因缘。无有错谬。又于普门漫荼罗根缘相摄之处。亦悉知之。乃名善观弟子也

经云。若弟子具如是相貌者。阿阇梨应自往劝发如是告言者。此有二义。一则除弟子疑心故。但恐无智疑悔则为永失。是以不妄与人。必是可传。自当求而授与不俟来请也。二为除阿阇梨吝心故。乃至无间火聚中。有可流通亦当往赴。况遇良缘求而不惠耶。次有五偈。明其劝发方便。初偈云。佛子此大乘。真言行道法。我今正开演。为彼大乘器者。意言。汝佛子当知。今此大乘真言行所乘之道法则仪轨。以汝是大乘器量故。堪能信受。我今当正说之也。次偈。过去等正觉及与未来世。现在诸世尊。住饶益众生。如是诸贤者。解真言妙法。勤勇获种智。坐无相菩提者。即是开十方三世诸佛一切方便门。唯以一道成佛更无余道也。以佛佛同道故。今还引诸佛证明。是事如法花中广说。又言住饶益者。谓多所饶益安乐众生。即是如来住处也。诸贤者即是如来。由普贤愿行悉以圆极故以为称。皆由解此真言妙法得大勤勇。成一切智。就偈颂省文故。云种智也。坐于诸法寂灭。即是菩提。非已成今成当成。无法可观不从他得。当有何相耶。此菩提。不可说以示人。故次偈更以外迹明之。偈云。真言势无比。能摧彼大力。极忿怒魔军。释师子救世者。意言。虽无定相而具一切威力。能伏诸魔制诸外道。开甘露门转大法轮。一切人天见如是迹。故号为释迦师子救世间者。如见烟知火。故当信受也。次偈云。是故汝佛子。应以如是慧。方便作成就。当获萨婆若者。是劝发行人令求彼果。汝今幸自有心何不证之。但当以此妙慧而作成就。不久自当成一切智也。上文。金刚手直问毗卢遮那。云何得一切智智。佛亦直答。如实知自心。是名一切智智。今此中教授义亦同。然直举无相菩提。便即劝令修证。更无行位差别可以错于其间。虽前品广明诸相。作种种名字庄严。至论心处意皆如是也。经偈云。行者悲念心。发起令增广。彼坚住受教。当为择平地者。言阿阇梨已得弟子。次明治地支分也。此中行者字。梵本云真言者。以偈中不可六字故。取意删之。下文颇有此例。不复烦说。谓真言者数数。以如是善法发起其心。即令彼意乐渐得增广。知彼坚住受教不复移转。方为作漫荼罗。或于瑜伽中见彼根缘已固。然后择地也。金刚顶大本。及苏悉地等经。广说地相。然其大意者。今此世界。自不如余净域怛然平正。但随下文所说诸胜处中。择取平正端严可造圆坛之处。辄便动作施为无所妨碍。便可充事也。复次今造诸坛何处皆得。如毗卢遮那遍一切处平正心地。方作大悲漫荼罗。但随所说胜处中。有少分平正可净治处。便于此中开出万德漫荼罗。浅深重数准前广释也。偈云。山林多花果。悦意诸清泉。诸佛所称叹。作圆坛事业者。诸胜处中。最以山林为上。虽重严众峰端严幽寂。若无花果流泉人所不乐。则众缘多阙亦不堪任。故须有种种名花甘实。兼有清净泉池情所爱悦之处。则是佛所称叹。可作漫荼罗事业也。或行者于三昧中见如是胜处。若闻圣尊之所称说。令于彼处作之。下文例尔也。复次山者梵云娜伽。是不动义。谓阿阇梨瑜伽中观此行人。住于四性法中。所行善事坚心不动。谓敬事师长孝养父母等。随有八心花果开萠。可出生净法处。便可建立漫荼罗也。复次净菩提心。安住谛理坚固不动。八方大风不能震摇。大悲方便花果处处弥布。常流净法利乐众生。最是佛所称叹。好作漫荼罗处也。次偈云。或在河流处。鹅雁等庄严。彼应作慧解。悲生漫荼罗者。若不得名山。即泉水为其次。谓诸河流常无断绝之处。妙音好鸟翔集游咏。端严清洁远离嚣烦。即可作坛也。雁非正翻。梵本云娑罗娑鸟。状如鸳鸯而大。此声甚清雅。此方所无。故会意言耳。虽世谛漫荼罗。亦须慧解。持真言人乃能建立。故云应以慧解作悲生漫荼罗。复次水是流不住义。其心不滞常能胜进。名之为水。福河不断。名之为水。以先能安心谛理人自不可多得。但使从本净流出已。正趣是中者。即可运无碍慧。为建立悲生漫荼罗也。妙音众鸟庄严。是能宣扬善法之义。亦是常念利他故众生所归。咸得欢乐。叹其恩德有大名称也。偈云。正觉缘导师。圣者声闻众。曾游此地分。佛常所称誉者。若山泉福地众圣所曾游履。自属上条。今此中意言。虽非如上胜处。而是诸佛缘觉及声闻弟子等。得道涅槃之处。或久住其中。又其次也。如西方。八塔及三乘圣众遗迹甚多。皆是大威德诸天常所护持瞻礼。犹如般若经所在之处。诸小鬼辈不敢停留。故法验易成也。佛所称誉。谓如仙人住山。世尊记说于中易可得道之类是也。复次若人已发菩提心。即是诸佛生地。亦是得道转法轮般涅槃处。亦是久住其中。以四威仪广利众生之处。虽未闻秘藏。但得三乘共行处。亦名吉祥。谓观察性空无相无作。无有我人众生寿者。此是二乘成道入涅槃处。亦是种种本生经。菩萨弃舍身命学波罗蜜处。皆可就中作漫荼罗。复次自谓已得涅槃生灭度想。是声闻辟支佛所。游地分。若不得一向求菩提人。即应平治此中画作悲生漫荼罗。偈云。及余诸方所。僧坊阿练若者。除圣迹之外。但随方国土诸梵行者所居。僧坊。梵音毗诃罗译为住处。即是长福住处也。白衣为长福故。为诸比丘造房。令持戒禅慧者。得庇御风寒暑湿种种不饶益事。安心行道。令檀越受用施福。日夜常流无有断绝。故名住处也。阿练若名为意乐处。谓空寂。行者所乐之处。或独一无侣。或二三人。于寺外造限量小房。或施主为造。或但居树下空地。皆是也。复次若离菩提心而修一切善法。所谓广行檀施。受无量律仪修种种禅定。受持十二分教思惟义理。慈悲精进化度众生。以众行无奖道故皆名无圣迹。僧坊亦然凡圣同居。是生福之处亦其次也。除共二乘般若。自余声闻缘觉一切法门。以远离大悲自求出要。皆名无圣迹阿兰若处。亦可即就其中。择治平地画作漫荼罗也。偈云。花房高楼阁。胜妙诸池苑者。若不得如上福地不可便停。应择取俗间胜处。若端严清净便可作法。房是上古以来众生以惭愧故。不欲令襞慢彰着。亦可以庇卫其身自护护他。楼阁是西方重屋上高显平露处。池谓清净池沼。多有水生诸花。人与非人咸所爱乐。苑谓园林。多名香软草芳木郁盛。萧然幽静可屏喧烦。皆又其亚也。复次若见行人。虽未入余方便道中。然其体性具足惭愧。常能自护亦能护他。或其心明白易知少诸障碍。乃至犯罪亦能发露。向人求自清净无所隐秘。亦可传授也。又池是渴水无厌义。谓此人虽未得深法味。而能虚心听受渴仰无厌。园是多人游观处。谓此人。性多悲愍好行慈济。咸所归仰赖其荫庇。此皆大乘种性亦可匠成也

大毗卢遮那成佛经疏卷第三大毗卢遮那成佛经疏卷第四

        沙门一行阿阇梨记

    入漫荼罗具缘真言品第二之余

偈云。制底火神祠。牛栏河潬中。诸天庙空室。仙人得道处者。或虽非圣迹及僧所居。但随于地分有起制底之处。于其四傍便可造作漫荼罗。火神。是净行梵志火祠之所。尤为清洁故可立坛。牛栏者。西方聚落牧牛共在一处。去村或十里五里。既积多时。牛屎尿遍地重积。梵俗亦以为净。虽然。须牛移去。若牧牛见在亦不中作也。河滩。正翻当云攒流处。谓有两水或多水。于此处会合。此侧及中间。频经泛涨荡涤无诸秽恶。天庙。是宗事世天者斋祈之室。亦多清闲。然有诸外道邪见不信。则不应于此处作也。空室。谓世人所造居室。后时舍之而去。以无诸愦杂故堪作法。仙人得道处。是世间求五通者。久所栖止得成就处。必无余好处。亦可于中造漫荼罗也。复次制底。是建立高胜义。谓此人常能建立白法志不屈挠。虽未现修圣教。当知先世树福内有善根故名为塔。又火能樊灭荒秽。谓此人身口意。虽未能清升出离。然内有慧性好行净业。有过能改。故名火祠。牛是行义。栏是闲防义。谓此人质性调柔易可驯御。兼于五情嗜欲。能自制止不至放逸。故名牛栏。攒流。谓于三乘中其心犹豫。不知定趣何道。阿阇梨亦当以法劝喻言。此诸方便皆是佛教。但随汝最欣乐处一向学之。所到会同不应疑虑也。若是邪正杂信。则当断其迷津示其正路。以能兼信故。即是先世曾经法水荡涤其心。亦名河潬也。天祠。谓不求三乘而志愿天乐。为欲授受令离三恶。生正见天中故须摄受。是名天祠。空室。谓此人虽在尘俗。而性好虚寂厌世嚣烦。是善根将熟之相。如女人胎渐成就。则欲意自轻。故堪教化。若志求无色天道。亦名空室也。仙人得道处。谓但发心求五通持明仙道。或愿长寿成就世间种种悉地。亦可随彼情机而诱接之也。复次有诸异学。深乐围陀火祠之法愿生梵世。闻佛秘藏中。亦有火天真言行法旨趣甚深故。即从此门而入正法。复有奉事自在毗纽那罗延。日月尊等种种世天。若闻佛秘藏中。亦有彼等诸天真言行法。乃至毗卢遮那大我之身。即便信受而入正法。或有志愿生三界诸天者。闻佛秘藏中。具有诸天乘真言行法。能令于无量世生彼天中。不复退堕终成第一义天。由此深心愿乐得入正法者。或有宗习世间五通仙法者。闻佛秘藏中。具有迦叶瞿昙大仙等种种真言。能令获得不思议神通。乃至如毗卢遮那住寿长远。彼便踊跃志求得入正法。以如是等种种门故。佛说火神诸处皆可造漫荼罗也。偈云。如上之所说。或所意乐处。利益弟子故。当画漫荼罗者。乃至求诸胜地皆不能得。不可令此密教遂无所传。但随阿阇梨心所好乐。谓有利益之地。即可造漫荼罗也。若深释者。但观彼有少分善根正希愿者。皆可择其心地治令平正。为造大悲漫荼罗也。又此众生。乃至好乐遮文荼荼吉尔者世间小术。亦于此门而摄受之。能得见此本尊时。自然得见无量圣众也。问曰。上明择弟子中。要具众德堪为法器方乃教授。而今择地义中。乃至一豪微善无不得传者何耶。答曰。是中有二种弟子。若求传法弟子堪绍阿阇梨位者。则简非其人道不虚行。若结缘弟子。则举手低头之善。无所不摄也。又深行阿阇梨以明见根缘故。或有人过去道机已熟堪为法器。而于现世之中。没在泥滓截余豪发善根。故阿阇梨即择此中少分平地。开出秘藏漫荼罗。何必待安心谛理之人。方作佛事。故与前说不相违也

经云。秘密主。彼简择地。除去砾石碎瓦破器。髅髑毛发糠糩灰炭。刺骨朽木等。及虫蚁蜣螂毒螫之类者。次明治地支分。谓于前所择地中。简取置坛之处。掘深一肘以来。于其土中一一精择。有诸不任用物及虫等。皆当去之。若有此者能生众难于法有障也。其石及沙砾。少可择者当选去之。若沙石众多。此处聚积彼处复有。不可简治令净者。当舍弃更求余处也。然大石平整有圣教说。可于上立漫荼罗。但土中杂者应除去耳。西方俗法多于瓦器中食。食竟辄便弃之。谓为秽触不复受用。如是比及余种种破坏器物。并髑髅杂骨。种种爪发皮毛糠糩秽草。及诸灰炭剌橛朽木。以要言之。如是等种种不任用物。非本净土者皆择出之。若多不可择。亦应舍弃更求余处。故云等也。虫蚁。梵音吃[口*栗]弭。此语通含。皆是微细小虫。皆择去也。蜣螂。是其大者。更有丘蚓等义可准知。毒虫。谓蛇蝎蜈蚣蚰蜒之类。皆应作方便驱遣令去。若多不可除。即是有妨难处应可弃之

经云。离如是诸过者。此例众多。得意者自当临事甄别。谓地或倾侧或高下不平。或色味不应圣教。其色中以黄白为胜。若纯黑则不堪取。而尝之味甜及淡则善。辛苦碱涩等则不任用。或掘之更填坑内。土不得满即不堪。若更填盈出即好。又就一处所中。南方则为下地。但可作阿毗遮鲁迦耳。复次阿阇梨。既而知弟子心地。堪可于中建立大悲漫荼罗。即当住于深定审谛分别观之。以慧甄择。去无所堪任杂秽诸垢。然后治令坚实为作庄严。不然则宿业余气能生障碍也。砾石。如不信正法坚执我分拨无因果等见。以难可雕[鎨-十+向]相浸润故。终不能生善苗。加功陶治亦无所出。细执甚多互不相受。故譬沙砾也。碎瓦破器。如造五逆犯四重禁谤方等经等。以心器败坏故无所堪任。设加法味亦不停住。为诸善众之所弃捐。先当以慧方便手。方为择去如是诸障也。髑髅。如破坏菩提心障。昔时曾具人法。于众支分中最为上首。由命根绝故。百体隳败无所能为。缘此恶习设令重发菩提心。还复成障自喜令退屈。故尤宜洗除使尽余气。毛发。谓六十心等。与善种八心共体而生。及以觉察则宜除剪。未得出世间心以来。杂起纷乱难可条绪。故名毛发糠糩。如无明妄想。以取着戏论故。但得名相皮失实相米。故以为譬。灰炭。谓乐小法起二乘心。若善根为此所焚。则归于灰断不生大悲条叶花果。故以为譬。刺骨。谓曾于众生作种种不饶益行。犯种种杂碎律仪。此是过去生死宿对残障。故名为骨。朽木。谓不欲懈怠之类不堪树艺匠成。又梵文兼有株杌义。谓久远以来。于诸烦恼有所偏习。余枿深固难可拔除。以如是诸过去业。含藏在心地之中故。一心行道时魔事易兴。故须豫加简择。若多不可择。则应弃舍此地别就余机也。虫蚁蜣螂毒螫之类。喻种种现行烦恼蝼蚁喻痴蜣螂喻贪毒虫喻嗔。此类甚多譬种种随烦恼。诸微小者譬无量恶觉见。观此辈皆有如来性。尤宜将护勿使绝其命根。但方便驱遣。使勿妨行道不秽污漫荼罗而已。若欲使极净道场者。百六十种上中下微垢。皆应择使无余。乃至灌顶地中。佳非净土者悉宜简去之。方名究竟净也

经云。遇良日晨定日。时分宿直诸执。皆悉相应于食前时值吉祥相者。因择地事便明择时支分也。凡所为法事皆须与时义契合。今将择治此地。故于吉日警发地神。余法事例可知耳。良日晨者。谓作法当用白分月。就中一日三日五日七日十三日皆为吉祥。堪作漫荼罗。又月八日十四日十五日最胜。至此日常念诵。亦应加功也。定日者。西方历法通计小月合当何日。若小月在白分内者。其月十五日即属黑分。不堪用也。又历法通计日月平行度。作平朔皆合一小一大。缘日月于平行中又更有迟疾。或时过于平行或时不及平行。所以定朔或进退一日。定望或在十四日或在十六日。大抵月望正圆满时。名为白分十五日。月正半如弦时。亦为八日。但以此准约之。即得定日也时分者。西方历法昼夜各有三十时一一时别有名号。如昼日即量影长短计之。某时作事则吉某时则凶某时中平。各各皆有像类。言宿直者。谓二十七宿也。分周天作十二房。犹如此间十二次。每次有九足。周天凡一百八足。每宿均得四足。即是月行一日裎。经二十七日。即月行一周天也。依历算之。月所在之宿。即是此宿直日。宿有上中下。性刚柔躁静不同。所作法事亦宜相顺也。诸执者。执有九种。即是日月火水木金土七曜。及与罗睺计都合为九执。罗睺是交会食神。计都正翻为旗。旗星谓彗星也。除此二执之外。其余七曜相次直日。其性类亦有善恶。如梵历中说。食前时者。昼夜各有三时。食前可作息灾暮间可作增益。夜可作降伏事也。入漫荼罗灌顶与息灾相应。故云食前。遇善境界意者。谓作法时。或地上或空中。有色声等种种异相。地上。谓或遇见童女。执持五种牛味瓶或香水瓶。或所持物与轮印等同类。或是世中所尊上物。及器盛白糠米等洁净盈满。或所被服端严鲜丽。或说种种吉祥相应之音。皆是成就相也。空中。谓忽睹庆云瑞气氤氲五色。或有彩虹鲜明间错非时而见。或作火色飞动如护摩成就之形。或于日傍有五彩见。或作人形貌如住寂。或于空中有好美妙音声。谓白鹤孔雀鸳鸯鸿雁之类。清彻和雅人所乐闻。如是等亦皆成就相也。所以须顺世谛者。以胜义漫荼罗微妙寂灭。醇信白心人尚难信受。况怀疑虑乎。以所度之人。曾习韦陀祠典伎艺明处。若见造漫荼罗时分舛谬。虑恐致不吉祥。便生疑怪言。我闻总持智慧者无所不达。而今观之。尚不能择得好星善时。况余深事乎。由此疑师疑法。故失坚信力反招重罪。故须顺彼情机也。复次如是执曜。即是漫荼罗中一种善知识门。彼诸本尊。即能顺世间事业而作加持方便。以阿阇梨善择吉祥时故。与彼真言本誓法尔相关。为作加持得离诸障也。复次种种世谛门。皆是法界摽帜。所谓良日晨者。意在菩提心嘉会之晨也。深行阿阇梨住瑜伽中。观察所欲度者本初种善根时。为久为远。因缘属谁。从何事起。如行者初发心时。或因见佛说法。或睹神变。或见种种可悲苦事。或于菩萨声闻缘觉而发道心。或以花香等。供养如上福田心得欢喜。便即发愿希求佛果。由彼先因现缘相感发故。种种机悟不同。或如是时中菩提心有寂静力。或如是时有增进力。或如是时有威猛力。顺种种悉檀方便而建立之。则功不唐捐不生障碍也。定日者。日喻本尊身。月喻修习瑜伽行。以行者定心之月。或时增明或时微昧。或发行太速或发行太迟。或过于中道或不及中道。致使机悟之时亦有盈缩。如循照常理可至某缘。某时中宜应建立。然有缘境迁移。或未到时处而熟。或过此时处乃熟。如是变通皆应善知。故云定日也。时分者。就行者一一地中。自有十心。此一一心。各有因根果。合为三十心。于此三十牟呼[口*栗]多中。亦应深审细甄择。何时堪折伏烦恼。何时可增益功德。何时当顺中道寂心而住。是名解时中细微之相也。宿直者。是行人瑜伽之月所涉缘境。于一切缘境中皆见心性。如列宿小大像类。虽复差别无不圆明也。如月行经二十七宿。以所经之宿好恶不同故。令世间候月之占亦复随异。如箕星好风。月行入箕则风起。毕星好雨。月行入毕则雨降。菩提行亦尔。遇缘对境势力不同。令折伏摄受。及寂行所施方便随转。若阿阇梨能深察根缘晓知是事。名为善观宿直也。九执者。梵音釳[口*栗]何是执持义。阿阇梨应观彼心力之手堪持何事。则所传密印不至唐捐。如诸佛金刚慧印。唯有金刚心菩萨乃能执之。若授与下地人。则名执曜不相应也。就九执中。日喻本净菩提心。即是毗卢遮那自体。月喻菩提之行。白月十五日众行皆圆满。喻成菩提。黑月十五日众行皆尽。喻般涅槃。中间与时升降。喻方便力。当知已摄百字明门也。土曜持中胎藏。水持右方莲花眷属。金持左方金刚眷属。木持上方如来果德。火持下方大力诸明。复次如是五执。即持五色苏多罗。土为信。木为进。金为念。水为定。火为慧。其余二执。罗睺主为覆障。慧星主见不祥。故不直日也。初日分如净心显现。中日分如发起众行。后日分如万德已圆功用渐息。初夜分如自证之地住大涅槃。后夜分如念本誓愿起加持力。周则复始巡转无穷。日体是一而四洲时分各异。今此漫荼罗意。欲开发菩提心日故。取食前时也。遇善境界者。是心无相无境界。非是有为无为。以佛五眼谛观。亦不能见其相貌。然亦有种种善根发相。可得了知。若是见谛阿阇梨。自当现前通达。若未见谛。当于三昧中察其境界。或见彼修行六度时种种六蔽不能留难。或为众生之所称叹乃至授菩提记。或如前种种印相于三昧中。现炳着奇特有异于常。以因果类之可以意得。乃至普门相摄处皆亦可知也

经云。先当为一切如来作礼。以如是偈警发地神者。阿阇梨将欲警发地神。先运心思惟。毗卢遮那无尽庄严身周遍法界。十方三世一切如来。亦复如是。一一无尽庄严身周遍法界。从十住地乃至初地诸菩萨。分证庄严身。无量无边满于法界。无有间隙如胡麻中油。当观此身遍至一切众圣前。以清净三业至诚作礼。由此因缘获无量福。便当以无倒心施彼弟子。愿无障难速成无上菩提。次当说偈警发地神也。如释迦牟尼佛。初坐道场时谓魔王言。汝由先世作一无尽施故。今得自在天主之身。然我从无量劫来。修如是大施不可胜数。乃至身肉手足亦无所吝。云何与我[角*交]其优劣耶。魔言。我所作福汝已为证。汝之福业谁当证明。若无证者即堕负处也。菩萨尔时申右手指地说真实言。我本于此地上行菩萨道。种种难行苦行地神证知。当知此指即是身密印也。尔时无量地神从地踊出。现其半身而作证明。魔王军众由是退散。今阿阇梨欲令弟子不久绍如来位故。亦以此印警发地神。时彼地神。生大叹喜而作是念。今此佛子乃能建立大事因缘。为将护我等令无损恼故。而见警觉。我应方便守护亦令离诸魔业。以此众缘力故。即令此地同于金刚也。所说阿利沙偈。名为自然成就真言。若作法时当诵梵本。今具录之也。七遍诵右手五轮按地

怛文(二合汝也)睇微(天也有女声)娑(引)吃屣(二合护也)捕多赐(亲也于也)

译云汝天亲护者(于字入下句)

萨么(一切也)勃驮曩(佛也有多声)哆以难(引度世也即有导师义)

译云于诸佛导师

浙唎耶(二合行也)娜也(修行也)尾世铩数(殊胜也)

译云修行殊胜行

部弭(净地也)播啰密多(到彼岸也)素者(等也)

译云净地波罗蜜(义合等字)

摩啰(天魔也)塞(去声)年(军众也)野他(如也)毫釳难(奴痕反破也)

译云如破魔军众

赦吃也(二合释迦也)僧(悉孕反)系娜(师子也)哆以那(救世也)

译云释师子救世

怛他(引)痕(如我也)魔罗(魔也)若延(降也)吃[口*栗](二合也)埵(伏也)

译云我亦降伏魔

漫荼蓝隶(漫茶罗也)履佉(引画)藐(密也反)痕(我也)

译云我画漫荼罗

偈意先告地神云。汝天女亲守护此大地者。已曾供养亲近一切诸佛导师。修殊胜行。净治诸地净满诸度。及余种种功德。如摩诃般若中历法广明。是以云等。今译偈五字为句不可具存然地波罗密中。亦已含此众德也。次偈陈所以。警发之意说诚实言。如世尊昔在菩提漫荼罗。降伏天魔军众时。汝于大会中现作证明。由是世尊号为释迦师子。能独步无畏救护世间。我今亦欲随佛所行绍如来事。是故画此漫荼罗也。我虽未得一切同于如来。然以毗卢遮那三密所加持故。亦能现作佛身。普集一切漫荼罗大会。是故汝今亦当现作证明。使诸魔军众不能俎坏也。复次地神是女天。女是三摩地义。即是大日世尊。护持一切众生心地三昧也。如实相世尊。昔在菩提漫荼罗。降伏无明住地魔王及与尘沙大众时。以般若波罗蜜手屡舒五力。案一切众生心地。时汝三昧现作证明。是故无量应度众生四种魔军。由此退散。是故号为寂业师子。能以自在神通救世间者。我今亦欲平治弟子心地。画作大悲漫荼罗。汝亦当为作证明。令伏四魔军众也。复次以字门释此阿利沙。具无量义。然要其宗极。正在他字之中。梵音怛多是如义。多字长引中即带阿声。以一切法本不生故。如于实相不增不减。即以此义警发一切地神也。彼诵偈时。应长跪两膝着地。由智慧手舒其五轮。平掌案地。方诵此阿利沙偈。一七度印之加持七遍。此即是名真言印相应也。阿阇梨言。欲作此法时。先以三昧耶法界金刚自性加持自身。皆如供养法中所说。用啰字门。自净心地及此道场地已。于瑜伽中。先起半月风轮以诃字加持之。次起水轮以缚字加持之。次起金刚地轮以阿字加持之。一缘谛观相应明了。善调心及气息。一气诵阿字门相续不间。力极息还又复诵之。或一息或三息。乃至令有所觉触也。以如是一缘方便故。即入三昧。逮见秘密庄严佛菩萨大会。或自见内外地中诸过咎也

经云。以涂香花等供养。者非但警发而已。又当以种种香花灯明等。供养十方诸佛及地神也。然此中地有三种。谓以啰字门。净除自心地弟子心地及道场地。皆以阿字门持之使成金刚。若就秘密释中明供养义。亦复如是。若阿阇梨。以净菩提心种种功德。回向一切智智印。即是供养自法界中一切诸佛及持地者。以此功德回施弟子。资助成佛因缘。即是供养弟子心法界中一切诸佛及持地者。若用庄严此金刚道场。即是以法供养十方世界中一切诸佛。供养已。复应归命一切如来。例解可知也

经云。然后治地。如其次第当具众德者。谓凡欲造漫荼罗。先须作如是法。方乃掘地择治。亦兼三种地义。浅秘两释。乃至如经所说次第具诸支分。故云当具众德也。时金刚手。为欲发明如来深密之旨。断除未来弟子疑惑心故。头面礼世尊足。而说偈言。佛法离诸相。乃至不顺法然道者。谓我亲从佛。闻诸法实相远离一切诸相。法佛所住住于法位。若如来出世若不出世。常自寂灭不可思议。非思量分别之所能及。亦非因量譬喻所能表示。若法相常尔。则非诸佛所能造作。何况有为诸相能集成乎。何故天中之天大精进者。今乃说此择地造坛等有为事相。及与真言次第行法。令修学者。辨种种香花供物。口随觉观言说。身学手印威仪。心缘本尊色貌形位。既是有为有相。岂能正顺无为无相法尔之道乎。唯愿世尊开发是中深趣。除世间如言妄执及疑谤之情也。尔时薄伽梵以下。世尊偈答。初云善听法之相者。以诸法实相义甚深难见。是故诫令善听也。夫法常无性从众缘生。即是八心之相越诸戏论。汝欲更于何处。求觅无相无为之法耶。故次句云法离于分别及一切妄想等。若了知诸法本无相如是。则照见心之实相。从本初以来常自不生。尔时一切身口意业。皆如虚空不可尽。故云我成最正觉。究竟如虚空也。然一切愚童凡夫。以不如实知故。邪倒妄执种种境界。所谓时方诸相貌等。乐欲无明覆。常为爱水所润无明所覆。若我舍于方便。直为众生说如是自证之法。彼等云何悟解而能进趣耶。故偈次明设教之意。云为度彼等故。随顺方便说也。佛意言。我以甚深法相不可直宣说故。以方便力。寄此漫荼罗具缘支分。令初业者。措心有地所作不空。即以此蒙佛加持。兼得观察十缘生句故。能不动实相游戏神通。普观一切善知识。庄严一切诸佛土。不欲令诸行人。放舍诸行住于无相。又不令执着诸行住于有相。故云虽说时方所作业。而实无时方。无作无造者。彼一切诸法。唯住于实相也。若一切有为之法。皆悉住于实相。岂得如彼痴人。或欲逃避虚空。或欲贪着虚空乎。复次阿阇梨。于此中广说法花经三车譬喻。如彼长者诸子幼小无知。虽种种善言劝诫。欲令出于火难。终不能得。时长者观彼深心所著唯在嬉戏。即以方便而告之言。今此门外有三种妙车。汝等当往取之可自娱乐。时彼诸子以闻游戏之名。适其愿故。情皆勇锐奔竞而出。及其等获宝乘庄严第一。乃非彼等宿心之所图之。此漫荼罗法门亦复如是。如来以世间因缘事相。拟仪况喻不思议法界。以俯逮群机。若可承揽。便能普门信解勇进修行。及以蒙三密加被。自见心明道时。乃知种种名言皆是如来密号。亦非彼常情之所图也。如言三月持诵。乃是性净圆明中三转方便。岂可但作九旬解耶。又如东方宝幢佛。乃是初发净菩提心义。岂得但作四方解耶。以此例之。则诸余法门皆可意领。故云而实无时方。乃至唯住于实相也。复次世尊大悲无限。哀愍诸未来世障重根钝众生。不能顿入法界故。于此深秘藏中。以旋转总持兼存浅略方便。设于事相之中思惟修习。亦成世间悉地功不唐捐。三密冥资终成佛果。故次偈云。复次秘密主。于当来世时。劣慧诸众生。以痴爱自蔽。唯依于有相。恒乐于断常。时方所作业。善不善诸相。盲冥乐求果。不知解此道。为度彼等故。随顺方便说也。是故传法之人。当善识根缘又知法门分剂。应病授药勿使差机。若着相之人。而辄尔为说甚深空义。则令怖畏疑惑增其不信。若利根深智。而辄授以浅略法门。则以为不顺无为正道而生轻慢。既于他无益。又自犯三昧耶。故应先住瑜伽观彼本末因缘。善了知已。当观此问答中施权显实之意。散入一切诸方便门而教授之。则能多所饶益。故不生障难也

经云。秘密主如是所说处所中。随在一地治令坚固。取未至地瞿摩夷及瞿摸怛啰。和合涂之。次以香水真言洒净者。如教所说。凡造漫荼罗。于七日内须毕。于最初日。阿阇梨当住大日如来自性。然后警发地神。严身方便皆如供养次第中说。警发已。即用不动尊真言加护之。然后掘地如法择治。彼应先掘中心一肘量。择毕还复填之。若盈满有余为上地。如旧为中。不满者为下。如是次第除诸过已。细治所掘之土稍稍填之。润以牛液筑令坚固。平正犹如手掌。次用瞿摩夷瞿摸怛啰和合涂之。若浅略释者。此是牛粪及液。为顺彼方俗法以为清净故。就秘密释之。瞿是行义。以入阿字门故。则是诸法无行。摩是我义。夷则乘义。何故诸法无行。以一切法我不可得故。若无有我。则无所乘及与乘者。尔乃名为大乘也。瞿摸义同前释。怛啰是如如离尘垢义。即是心之实相。若行者能如是净治心地。则能毕竟清净离诸障碍也。凡择地平治了知其方分。即穿漫荼罗中心深一肘许。用成辨诸事真言。加持五宝五谷五药。安置其中。去垢辟除等皆如供养法中说。若深秘释者。即是安立菩提心中五智之宝。能起五种善萠。灭除五种过患。故云五谷五药也。如是安置了。更复净涂使极平正。应取欲灌顶瓶。贮以净水。勿令大满。插诸花果。中置五宝谷药。于埋宝处置之。自第三日置瓶以后。当日日三时。诵辨事真言一百八遍加持此瓶。然后作余事业也。至第四日暮。次用香水真言加持香水。或一百八遍乃至千遍。然后洒净。彼真言曰

南摩三曼多勃驮喃阿钵啰(二合)[口*底](丁以反下同)三迷(二)伽伽那三迷(三)三么多奴揭帝(四)钵啰(二合)吃[口*栗](二合)底微输(上)睇(五)达摩驮赌微戍达儞(六)莎诃

初句普归命诸佛。如毗卢遮那三身遍一切处。十方三世一切如来。亦复如是。今皆以普遍心。一切归命已。然后说此真言。欲令此诸世尊不越本誓故。同共加持而作证明也。下一切真言例尔。不复广释。第二句中。以最初阿字门为真言之体。所谓种子字也。余诸字门。皆为庄严此字故。以此字门即是菩提心本原。今所造大悲藏生漫荼罗王。乃先用香水洒净。皆为治如是心地令离诸垢秽故。若论外境。亦是所持金刚心地。是故余字皆为成此字门也。阿字是一切法本不生义。次云波罗字者。波是第一义谛。罗名为尘。以一切字皆入阿字门故。即是尘垢本来不生。尘垢本来不生。即是第一义谛。第一义谛。所谓净菩提心也。次有底字。正体是多字门。以带三昧声故转为底。底是心义。亦是如如义。如如于自心如实之相。即是净菩提心。净菩提心。于一切法都无染着。即名莲花三昧。住是三昧者。乃至诸法空相二亦不可得。所谓为诸佛大空故。次明娑字么字门。以定慧均等具三昧声。故云三迷也。此中但约字门解释。如诸大乘经论。约四悉坛四不生等。以种种因缘譬喻。广演阿字门。则有无量句义。又以一切语言中皆带阿声故。一一字门皆具一切字门。若得意者当自在旋转说之。以下不可具论也。复次真言中。有字义有句义。字义已如前说。若句义者。此阿钵啰底三迷。是无等无对义。谓此心地漫荼罗王。出过一切语言譬喻。乃至无有一法可为伦匹。故云无等。何故如此。以具含如上字门所说义故。第三句义云虚空等。言此心地。毕竟净无分别。无边际等同虚空也。复次伽字门是行义。那是大空。于法自在义。以伽字入阿字门故。一切法本初以来都无所行。如来于此法中到于实际。又复更无所行。以不行故。即是住于大空于法自在。以我心地与此大空毕竟等故。当知弟子心地及道场地。亦复如是。故云等虚空也。第四句义云等随者。以金刚地等虚空故。即能等遍一切众生界。普现随类之身。故堪画作漫荼罗也。复次娑是漏义。么是我义意义。此等诸众生界。本不生故皆悉如如。是故法界众生界毕竟等。努者大空三昧。如来住此大空三昧。无行无到亦无去来。而能如其心量随缘应现。故云等随也。第五句义云本性净者。还转释阿字净菩提心门。及香水义。如来以等至法界之香。之与大悲三昧水和合。能普洒一切众生心地。除其垢秽。何故如是。由彼本性净故。如水性本净故能净诸垢秽。如来香水亦如是。由本净故。能以净一切众生心故。次明第六句义。云净除法界也。犹如香水洒地为除秽故。如来亦尔。以性净之戒香。和合性净之悲水。遍洒法界众生性净之心地。为令一切戏论皆净除故。亦当以诸字门而广衍之。以一切如来同说如是大誓故。名为真言也。复次法界者。即是众生界。众生界者即是心界。心界者即是本性净。本性净者即是遍至一切等同虚空。等同虚空者即是无等无等阿字。门如虚空无边。故当知阿字门亦无。边如虚空无染无变无动故。当知阿字门亦无染无变无动。如虚空离一切相而含万像。离一切作而世间事业因之得成。阿字门亦复如是。无相无作而具足无尽庄严。成就普门不思议业。如是当以种种门自在说之。然复有无量无边未曾有法。非彼虚空所能譬喻。是故阿字门为真言种子。过于譬类也。末句云莎诃。是警觉义。以一切如来本行菩萨道时。同见如是义故。必定师子吼发诚实言。我要当以此阿字门。遍净无尽众生界。若我此誓不虚者。其有一切众生。诵我诚言不亏法则。则当如其所愿皆充满之。我今以随如来三昧耶教说此真言。唯愿不违本誓故。令我道场具足严净。故云莎诃也。以下诸真言云莎诃者。其义大同。凡内五宝时。即应如前敬礼十方诸佛。而请白言。我明日当作请法。从此第三日以去。渐当准定漫荼罗大小方位。或四肘或十二肘等。乃至诸圣天位处。皆用白檀点记之。若阿阇梨不能具记持者。乃至画其形相或书字记之。使一一分明。及香水洒净竟。当用白檀涂作圆坛。剂十二指量。最初置中胎藏大日世尊之位。次于东方大勤勇处。置一切如来位。东南维真陀摩尼处。置一切菩萨位。次于东北维虚空眼处。置佛母位。次于大日右边置连花手位。次于大日左边置金刚手位。次于西南隅置圣者不动位。西北维置降三世位。正西是通门处。即阿阇梨所住。修供养瑜伽处也

经云。初第一我身。即毗卢遮那位。以五佛当共置一坛。第二诸救世者。即是诸佛菩萨。亦分为二位。第三彼同等。即是佛母也。如来名为无等。而般若波罗密与无等等。故云彼同等也。第四莲华手。第五金刚部主。第六云不动尊。则降三世可知。此即皆是成辨诸事持明。当知举此六位。则摄一切诸尊也。如是作竟。当布列香花供养具。准同供养次第仪式。然后观作宝莲花台宝王宫殿。于中敷座。座上置白莲花台。以阿字门转作大日如来身。如阎浮檀紫磨金色。如菩萨像。首戴发髻犹如冠。形通身放。种种色光被绡谷衣此是首陀会天成最正觉之摽帜也。彼界诸圣天众。衣服轻妙乃至无有铢两。本质严净不复假以外饰。故世尊俯同其像也。若作深秘释者。如来妙严之相。法尔无减非造作所成。故不以外宝为饰。乃至十住诸菩萨。犹因承佛神力。得见加持身。其于常寂之体如在罗谷。故以为况也。阎浮金。亦是自然性净。色又最深。明佛金刚智体最为深妙。通身放种种光。即是普门开示大慧明也。次于四方八叶之上。观四方佛。东方观宝幢如来。如朝日初现赤白相辉之色。宝幢是发菩提心义也。譬如军将统御大众。要得幢旗。然后部分齐一。能破敌国成大功名。如来万行亦复如是。以一切智愿为幢旗。于菩提树下降伏四魔军众。故以为名也。色如朝日。亦彼相应义也。南方观娑罗树王花开敷佛。身相金色普放光明。如住离垢三昧之标相。始自菩提心种子。长养大悲万行。今成遍觉万德开敷。故以为名。离垢即大空义也。证此大空时。犹如真金百练垢秽都尽故。佛身相亦然。此是世间上妙之金。若比阎浮提金。则色浅而稍浊。不得如彼自然镜彻清明。以花叶上佛从心量因缘生故。有差降也。次于北方观不动佛。作离热清凉住于寂定之相。此是如来涅槃智。是故义云不动。非其本名也。本名当云鼓音如来。如天鼓都无形相亦无住处。而能演说法音警悟众生。大般涅槃亦复如是。非如二乘永寂都无妙用。故以为喻也。次于西方观无量寿佛。此是如来方便智。以众生界无尽故。诸佛大悲方便亦无终尽。故名无量寿。梵音尔尔名为仁者。又以降四魔故名为胜者。故偈具翻其义。谓之仁胜者。此二佛亦作真金色。稍闭目下视。作寂灭三昧之形。诸佛例如是也。花台四维有四菩萨。如下文说之。其一切如来位。但观一佛在金坛中。即同一切佛身。余各依经中像位。皆应转字成身。使一一明了也。凡漫荼罗转字之法。一一诸尊皆用本种子字。或以诸余部通用字。如三部阿娑嚩等。若恐浅行阿阇梨。不能如是速疾旋转者。但观阿字门生无量光。光所至处即现彼尊身也。至法事夜。亦皆放此。凡修观行时。先当以五字持身。如供养法中说。即观自心作八叶莲花。阿阇梨言。凡人污栗驮心状。犹如莲花含而未敷之像。有筋脉约之以成八分。男子上向女人下向。先观此莲令其开敷。为八叶白莲花座。此台上当观阿字。作金刚色。首中。置百光遍照王。而以无垢眼观之。以此自加持故。即成毗卢遮那身也。以此方便观毗卢遮那身。令与我身无二无别。而在二明王中间。名为住于佛室也。至画漫荼罗竟时。阿阇梨移座位出檀门外。当于此佛室之位。置意所乐尊或置般若经。以金宝槃盛严饰供养。或置所持数珠若金刚杵金刚铎等。又凡欲择治地时。当自观心莲花上。如意宝珠内外明彻。彼谛观察时。所有善恶之相悉于中现。阿阇梨即当以慧方便而择治之。令得坚固平正。观弟子心亦如是。此中深秘之趣可以意得耳。行者住于佛室。如上谁观圣尊竟。当转阿为嚩。金刚萨埵加持自身。奉涂香花等如法供养。皆如次第法中广说。然后兴大悲心至诚殷重。诵请白阿利沙偈。如经文也

今存梵语如左

三漫嚩(引)诃囒(存念也)睹迷(我也)萨啰鞞(二合一切也)　尔曩(引仁者也即诸佛)迦卢拏怛莽(二合)迦(悲者)部迷钵[口*履]薜啰(二合)诃(请受持地)迦(引)[口*梨]也(二合作也)娑补怛[口*(隸-木+士)](二合并佛子也)湿务(二合)儞那[口*底](丁结反)曳(平明日也)

此偈意言。诸佛悲愍者。唯愿存念我等。我今请白。当作受持地法。并诸佛子。明日当共降临为作证明。梵音于存念声中。即有请赴之意也

○(三)一切菩萨○(五)(火)金刚手○(七)圣不动尊○(二)(东)(木)一切佛位○(一)五如来位○(九)(西)(金)阿阇梨位

此是白檀漫荼罗位

○(四)佛母虚空眼○(六)(水)莲花手○(八)降三世尊

至第五日暮。复当次第具诸法则。好自严身观入漫荼罗位。奉请结护等一一周备竟。当诵不动明王或降三世尊。与密印相应。满一百八遍加持此地。阿阇梨言。从第三日以去。每日三时念诵时。皆诵不动真言一百八遍。用加持地。非独此应一切处用也。又从初日至三日以来。若有留难。即当收摄停止。若已涂白檀位竟。设有种种魔事两不和合。要当勤加方便必使得成也。余如瞿醯中说。其第五夜诵不动真言竟。次当以大日如来身。即诵持地真言及作三昧耶印。说彼真言曰

南么三曼多勃驮喃　萨婆怛他揭多(引二)地瑟姹(二合)那(引)地瑟祉帝(三)阿者丽(四)微么丽(五)娑么(二合)啰[嬭-不+(采-木)](平六)钵啰(二合)吃[口*栗](二合)[口*底]钵履输(上)睇(七)莎诃

初句归命一切诸佛。第二第三句义云。以一切如来加持而加持之。此意云。如彼金刚道场。一切如来神力共所加持。今令此地亦复如是也。复次我已平治弟子净心地竟。此是心王如来。图画大悲藏漫荼罗处。我今说诚实言。以一切如来神力而加护之。使得坚固不动也。第四句云阿者丽。是不动义。第五句云微么丽。是无垢义。此意言。以一切如来神力正加持之。令得安固不动。非但不动而已。又令离一切垢也。正以第四句初阿字。为真言体。如来以何法加持。能令毕竟不倾动耶。谓即以此阿字门故。有如是力用也。第六句是忆念持义。犹如比丘作羯磨法。令众僧一心。和合同共受持。今此真言亦尔。用阿字加持竟。请一切如来忆念本誓故同共受持也。第七句是本性净义。此即转释前句。何故诸佛同心念加持。由本性净故。若法入阿字门。即是从本已来无动无垢。十方三世诸佛由此义故。皆同一戒一见。所以同共加持也。末句云莎诃者。如僧羯磨竟。更加忍可印成句。若我所发诚言必定无谬。唯愿诸佛不越三昧耶故。令所作圆满也。此中所有字义。亦当广分别说。时彼阿阇梨。当往东方一切如来坛位之外。东向诵持真言或三遍或七遍。能多益善。次往南方。次往西方。次往北方。皆背白檀座位而诵持之。如是一周竟。次往虚空眼位。当面向东北背坛位诵之。次往东南。次往西南。次往西北。又一周竟。更当至诚作礼种种供养。就阿阇梨座位。东面而坐诵本受持真言。住于本尊三昧。皆如供养次第中说。又次第持白檀位诸尊真言。并结彼印。阿阇梨言。先持部主大日真言一百八遍。所余八位。观彼真言大小持之。若更能诵者。兼持第二院四菩萨。第三院释迦等上首诸尊。乃至都诵诸位亦得也。其白檀位但涂泥干。香水洒竟即得作之。亦不克在第四日。自置了后。皆须依此持诵。至法事夜。亦准此可知也。其受持地夜。阿阇梨如法持诵竟。乃至以金刚讽咏遍叹诸佛菩萨。宴坐疲极。即于此置坛处如法护身。即于东面而卧。当于所度弟子极生大悲怜愍之心。若瞿醯且坦啰。受持地竟。又有结苏多罗受持弟子名号法也。彼安寝时。当思惟心莲华台中么字门一切诸法。我不可得故。即是无障碍菩提心也。亦复如意宝珠。又云。此如意珠只是阿字门耳。彼阿阇梨。当于梦中。或见无量诸佛及菩萨。大名称者示现作诸事业。谓随种种应度众生。三轮化导。或亲自安布建立悲生漫荼罗。或以微妙音声安慰劝嘱言。汝今愍念众生故。造作此漫荼罗。善哉摩诃萨埵。汝之所画甚为微妙。如是种种境界。阿阇梨当以慧心善决择之。当知众圣已共加持是地。可随意作法也。若有障碍者。应作相应护摩方便净除。当发大勤勇心要令所作成就。复次若见谛阿阇梨。则于莲华三昧净菩提心如意珠中。自然明见有障无障因缘了了无碍。心佛现前嘱授为决所疑。如其觉知魔事。当以大智慧大方便。旋转作护摩法。要令所持心不动不退堪建立法界漫荼罗。然后休息也。复次阿阇梨。自初警发地神以来。便不应舍离如是道场之地。恒于是中加持念诵审谛观察。随有未平正处辄修治之。又思惟众缘支分皆令素具。勿得临事阙乏而生疑惑也。自受持地竟。即应规画界域布定方位。至灌顶夜方造诸尊。若不能速成者。持地以后渐次修之亦无咎也

经云。复次于余日。摄受应度人。以下迄授与香水令饮彼心清净故。明摄受建立护持弟子支分。受持地已。次明夜当作弟子法。故云余日也。因此广辨弟子应度之相。偈云。若弟子信心者。谓阿阇梨观彼现在根性或久远因缘。于此不思议缘起。三种秘密诸方便中。直信不疑无有能怖畏。乃堪摄受。余如师德中说偈云。生种姓清净者。谓于婆罗门等四种大姓家生。若是旃陀罗等。以家法相承习行不清净事故。姓多弊恶。若为作传法灌顶使流通大法。则生他轻慢或成匮法因缘。由如比丘受具。亦简去毁辱众僧极卑下姓也。若但结缘受法则非所论。复次若久远以来。曾有发菩提心因缘。即是如来种姓中生。最为胜族也。偈云。恭敬于三宝者。谓于佛法众僧。起淳厚谦下之心。常好亲近供养尊重赞叹。当知是人有先世行道因缘。乃至如常不轻菩萨。是名深敬一切众生。信佛法僧宝也。深慧以严身者。如是等虚空无边佛法。非劣慧者心器之所能堪。故智性深利以自庄严者。乃至为说也。堪忍无懈倦者。此是有所堪能无所退屈之义。梵音与忍辱不同。谓求法因缘。虽种种艰苦之事皆悉能作。假使一度不成。复更发迹修之。如誓抒大海尽而后已。若人志性如是则可传法也。尸罗净无缺者。谓于在家出家律仪。乃至于本性受诸禁戒。随所奉持。则深心防护无有毁缺。若具如是性者。虽入三昧耶平等大誓。亦当敬顺不违。故堪传法也。忍辱不悭吝者。此中分为二句。忍辱。谓于内外违顺境界八种大风。其心安忍无所倾动。如智度尸波罗蜜中广说。当知是人。必不犯持明重禁作不利众生行。故堪传法也。不悭吝。谓于所有财法常念惠他。设来求者心无鄙吝。如智度檀波罗蜜中广说。当知是人。必不犯持明重禁悭吝正法。故堪传授也。勇健坚行愿者。亦分为二句。勇健。即是阿阇梨德中。勇健菩提心种性。于行道时。虽遇种种可畏色声心不怯弱。乃至出生入死无怖畏想。正顺菩提萨埵大人所行。故应传授也。坚行愿者。此是要心之愿梵音与求愿之义不同。如自立志。令每日三时念诵。则终竟一期。虽过种种异缘初不间绝。如是事有始终。若行菩萨道时亦不亏本誓。故堪传法也。然此所说弟子十德若兼备者。当知是人甚为希有。但使偏有所长堪可一匠成者。即应摄受耳。又如声闻受具。时观察种种遮难。所谓太小太老色貌瑕疵。诸病患等。恐白衣嫌诃故。辄简去之。今此摩诃衍则不如是。但令道机可济。虽有诸余过失。皆无所观也。偈中云或十或八七。或五二一四者是一期道场。作阿阇梨灌顶之限数。此中约超数取之。谓从一至二。从二超至于四。从四至五。从五超至七。从七至八。从八超至十人。是故一漫荼罗中。不得同时为三人六人九人灌顶。盖如来密意。阿阇梨不释所由。又同大方等陀罗尼经。不得过十人已上也。过此已外。恐阿阇梨心量有所不周。当待后缘别为作法。又此十人以下者。谓俱时发心各舍内外所有。供养三宝同共成辨漫荼罗。故得同时作法。若人因遇道场便。云法缘难值乞并为济度者。未合为作阿阇梨灌顶也。若复数过此。若但求结缘于一门本尊法中受真言印者。则不依如是剂限。阿阇梨亦当发起大悲。随有能起少分善心者。皆为发生立菩提种子。故云或复数过此也

经云。尔时金刚手秘密主。复白佛言世尊。当云何名此漫荼罗。漫荼罗者其义云何。此因如来简人限众。为晓诸未悟者。转生疑问也。金刚手本请世尊。称此加持境界。演说大悲藏生大漫荼罗王。则是平等大悲无复限量。而今世尊所说。虽有德可传者。犹不过十人。似是随转一明非其具体。故问当何名此漫荼罗也。又漫荼罗是轮圆之义。今既限局名数。似于理未圆。故复问此中漫荼罗者为是何义。凡有二问。世尊答中。初答名次答义。就答名中。还复申明本旨云。夫漫荼罗者是发生义。今即名为发生诸佛漫荼罗也。下菩提心种子于一切智心地中。润以大悲水照以大慧日。鼓以大方便风不碍以大空空。能令不思议法性牙次第滋长。乃至弥满法界成佛树王。故以发生为称。夫雷雨作解。随甲圻者先萠。不可以卉木滋荣性分不等。遂令平分之施亦成限量也。次答义中。梵音漫荼罗。是攒摇乳酪成苏之义。漫荼罗是苏中。极精醇者浮聚在上之义。犹彼精醇不复变易。复名为坚。净妙之味共相和合。余物所不能杂。故有聚集义。是故佛言极无比味无过上味。是故说为漫荼罗也。以三种秘密方便。攒摇众生佛性之乳。乃至经历五味成妙觉醍醐。醇净融妙不可复增。一切金刚智印同共集会。于真常不变甘露味中最为第一。是为漫荼罗义也

经云。又秘密主以下。广演漫荼罗义释除疑妨。复分为三。初明法界圆坛普门无限。次明限人简众生所由。末句劝嘱阿阇梨令兴平等悲愿。就初文中。哀愍无边众生界。是大悲胎藏生漫荼罗广义者。若行人自见中胎藏时。即知一切众生悉有成佛因缘故。其所起大悲漫荼罗亦周法界。且如十世界微尘数诸执金刚菩萨众等。随以一门作漫荼罗主。余为眷属。则成一种漫荼罗。如是旋转无穷已。非算数譬喻之所能及。何况是中各以无量门庄严。种种方便引摄众生。又可胜纪乎。若行者于此一字法门中。摄广为略衍略为广。出生法财遍施一切。常无断尽。乃名善解漫荼罗广义也。次云秘密主如来于无量劫。积集阿耨多罗三藐三菩提之所加持。是故具无量德。当如是知者。此释广义所由也。如花严入法界诸善知识。各各于一门中。所通达法深广无际。然亦互不相知。如来昔行菩萨道时。普门亲近如是等佛刹微尘数诸善知识。于彼一一功德藏。皆到极无等比无过上味。以如是内证之德无量无边故。其所加持现作法门眷属。亦复无量无边。彼真言门行者。当通泰其心作如是解也。已知内德无限。次明本地漫荼罗度人无限。何以故。以副大悲愿故。故经文次云。秘密主非为一众生。故如来成正等觉。亦非二非。多为怜愍无余记及有余记诸众生。故如来成正等觉。以大悲愿力。于无量众生界。如其本性而演说法。此中发菩提心义。如入法界品。及智度摩诃萨论议中广说也。无余记者。如佛现前授决。某甲众生于某劫中作佛号某如来。有如是国土眷属第。以了了记故。名无余记也。有余记者。如告众生言。汝于未来某佛时当毕是罪。某甲如来为汝授记之类是也。复次如世尊说若我在世或灭度后。诸有闻法华经一句一偈。我皆为授无上菩提记。是名无余记。若言一切众生悉有佛性。彼生善根相续不断。当至无上菩提。是名有余记也。我本为此等众生。来成等正觉。况今所愿以满。开众生自心之宝。如其本性而给与之。当有何限耶。且据恶世弘经浅行之一迹。故云一期法事剂至十人耳。从此以下第二句。即释此限人简众所由。经云。秘密主无大乘宿习。未曾思惟真言乘行。彼不能少分见闻欢喜信受。又金刚萨埵若彼有情。昔于大乘真言乘道无量门进趣。以曾修行。为彼等故。限此造立名数者。此意云。若诸众生。未曾于过去无量佛所久种善根。于此秘密乘未曾修习。则造次闻之不能信受。若传法人。徒以善心差机为说。或当增其诽谤断彼善根。故法花云。无智疑悔则为永失也。十方世界诸众生。少有志求声闻者。求缘觉者转复少。求大乘者甚希有。求大乘者犹为易。信此法者最为难。故以普眼观之。堪受是法者。犹须弥大海之尘渧耳。既将护彼意时乃说之。安得不略制造立名数乎。所云无量门进趣者。即是兼释漫荼罗名义。夫漫荼罗者名为聚集。今以如来真实功德集在一处。乃至十世界微尘数差别智印轮圆辐凑。翼辅大日心王。使一切众生普门进趣。是故说为漫荼罗也。所云略此造立名数者。如以阿字五转。统如来无边内德。以字轮百明。摄如来普眼法门。此则名之略也。以刹尘方便开八叶之坛。以无极大悲制十人之限。此则数之略也。然其学者。随于一法明道而得悟入。即是普入一切诸总持门。如从一门见王。即是遍入千门万户。若不能如说而行。则虽以种种文辞广为开示。无所益也。故第三句。次明限略名数自不碍于广。是以经云。彼阿阇梨亦当以大悲心。立如是誓愿。为度无余众生界故。应当摄受无量众生。作菩提种子因缘。谓造立此漫荼罗。是随有见闻触知。下至举手低头一念随喜。皆必定成于阿耨多罗三藐三菩提。故阿阇梨虽不得差机误。授为作具支灌顶。然系珠毒鼓之缘。岂当已乎。故当运大悲心务令广洽也。复次如人家有秘宝。恐为盗贼所窥故掩以蔽衣。今此曼荼罗法门。亦复如是。以秘密之藏不可直宣说故。回转密意覆以有相方便。今言限以十人者。乃是世谛漫荼罗耳。然阿阇梨自当平治心地。画作大悲漫荼罗。普眼度人多多益善。勿得如言而解也

大毗卢遮那成佛经疏卷第四大毗卢遮那成佛经疏卷第五

        沙门一行阿阇梨记

    入漫荼罗具缘品之余

偈云持真言行者。明弟子支分中护持建立方便。至第六夜。师及弟子皆澡浴清净。着新洁衣赍持供物。诣如前所造白檀漫荼罗处。当如法加持自身道场及诸弟子。其护弟子方便。如下文入灌顶时所说。时阿阇梨如次第法则具修供养。观白檀位诸尊。与密印相应持彼真言。瞿醯云。手案中胎漫荼罗诵真言一遍。如是一诵一案乃至七遍。余位亦尔也。次当为诸弟子。随顺说法开导其心。教彼三自归依忏悔先罪。既忏悔已。身心清净犹如明珠。堪能真正发心。是故次令发苦提心。皆如供养法中所说。次当授与涂香花等。教令运心供养诸尊。然后为受三世无障碍智戒。此受菩萨戒法。别有行仪也。菩萨所以发心摄受方便学处。皆为成就如来清净智慧。于一念中了达三世诸法。无挂碍故。其有住斯戒者。乃至初见心明道时。即有如是不思议势分。以此戒亲能发生佛慧。又对二乘律仪有限量故。以三世无障碍智为名也。次当授与齿木。令诸弟子嚼之。因即观彼人成器及非器相。所以为此法者。亦是顺彼方俗谛。因用秘密方便而作加持也。印度国人。凡请僧食乃至世人。相命皆先遗其齿木。以种种香花严饰而授与之。当知明日请彼饭食也。所以如是者。为明爱敬之心。恐彼先有痰癊宿食因缘。若受我供或令发动不安。故先以善意将护而警发之。令彼先净身器。或服呵梨勒等。则明日随意饮啖。无所犯触身心安乐也。今阿阇梨亦尔。授弟子杨枝时。即当寄此方便为说深法。我方当授汝佛性醍醐拯无过味。已教汝发菩提心净除三业宿障。以三世无碍智调伏之牙。噬诸烦恼竟。欲复以此秘密加持。涤除身心过患。汝又当净其口过。在所游方勿妄宣传。明日当贻汝不死甘露皆令充足也。彼当取优昙钵罗或阿说他木端直嫞好者。不粗不细剂十二指量。凡一切量法。皆用大拇指上节。侧而相捻是。其正数也。此二木。是过去佛菩提树。若无者。当求有乳之木。谓桑谷等。记木上下之别。皆以枝末为上根柢为下。以香水灌洗。又复涂而薰之。于其下末。以白线缠花用为庄严。亦作标志。令上下易知故。当以手案则不动真言加之。或百遍或千遍。素令严备。既受戒已。师当取一齿木奉献诸尊。余者分授弟子令出坛外。向东或向北。如法蹲局嚼之。嚼已。令向所面之方。而正掷之而验其相。若嚼处向外者。是人悉地不成。向身者悉地成就。若远掷却来近身。是不久成就之相。若首直竖向上。成就更速。首向下者。是人当入修罗龙宫。若掷在空中。当知此人先已成就也。又向北方东方为上成就。西方为中成就。南方为下成就。虽如是。若人先向东掷。而嚼处向东。即是背身。亦不得成就。余准此方类而可知。余如瞿醯中说也。次当作金刚线法。凡作綖。当择上好细具缕。香水洗之极令清净。令洁净童女右合之。合五色缕。当用五如来真言各持一色。然后以成辨诸事真言总加持之。造漫荼罗綖亦尔。五如来色者。谓大日佛加持白色。宝幢持赤色。花开敷持黄色。无量寿持缘色。鼓音佛持黑色。阿阇梨先自取綖三结。作金刚结。用系左臂护持自身。次一一为诸弟子系臂。如是摄受弟子。则入漫荼罗。是离诸障难也。其金刚结法不可缕说。当从阿阇梨面受之。复次五色綖者。即是如来五智。亦是信进念定慧五法。以此五法贯摄一切教门。是故名为修多罗。古译谓之綖经也。若见谛阿阇梨。能以如来五智。加持弟子菩提心中五种善根。贯摄万行系持于瑜伽之臂。使经历生死常不失壤。若能如是摄取弟子。乃名善作金刚结也。阿阇梨言欲此夜作弟子法时。其所供养当减第七夜之半。又当观彼情机赞扬密教。发生乐欲坚固其心。并为分别十种方便学处。然此三世无碍智戒。凡结缘者皆令预闻。其四种根本及三昧耶又一偈。则当耳语戒之。具支灌顶者。乃应闻耳。其所教诫二偈。亦是阿利沙。能具诵梵本益善。列之于左

阿儞也(二合从今也)庾涩磨(二合汝也)鼻啰睹逻(无对又无等)罗婆(引利也)腊驮(获也)摩诃(引)怛么(二合)鼻(大我也)曳曩(诸也)萨婆(一切也)尔奈(乎佛也)喻延(汝也)娑补怛[口*束*頁](二合并菩萨也)[口*履]诃(此也)赦娑泥也(教也)萨啰梅(二合一切也)跛[口*履]蚁哩(二合)系哆(引)萨他(二合摄也)阇耶磨囊(生也)么扈(大也)捺耶(引辩事也)帝曩喻延(汝也)摩诃(引)夜泥(引大乘也)湿附(二合)若哆醯(明晨生也)婆尾屣也(二合)他(得也)

偈意云。汝从今以去。便为已获无等之利。位同于大我。大我。谓诸如来成就八自在我。于法自在者。及诸摩诃萨埵也。次云一切诸如来。并此教中摩诃萨众。一切皆已摄受于汝。此教。谓此大乘秘教中。十佛刹土金刚菩萨等也。次云成辨于大事者。即是能成大事能成辨大事因缘。所谓开示悟入如来知见。故经中会意言之次云汝等于明日。得大乘生。谓入大悲漫荼罗。得灌顶已。生于一切如来种姓之中。复次离缘业生得大空生故。云大乘生也。时阿阇梨如是教诫印持竟。还令次第于漫荼罗外东向而坐。阿阇梨复当供养。以至诚心迎请诸尊言。我于明日。为哀愍弟子供养诸圣尊。故建立大悲胎藏漫荼罗。随力供。养唯愿慈悲忆念。当于明日。悉皆降集漫荼罗而作加持。大意如此。余如瞿醯中说。彼至诚三请已。宣说金刚句偈称叹诸尊。然后如法发遣。复为弟子广说法要。教令系念思惟。藉吉祥草面向西寐。彼于梦中。若获种种境界。晨起皆当白师。则知行人悉地成不之相也。若是见谛阿阇梨。自当住深瑜伽。明见弟子本末根缘无有错谬。设不作如是事相。及随顺世谛行之。一切无咎。若未见谛师。则当谨依法则勿令亏失也

经云。梦中见僧住处者。谓所见清净微妙种种严饰。身入其中礼跪旋绕。遇诸庆善之事。园林者。谓所见滋荣殊特花果繁盛。或亲自采掇。或升践树抄履空而行。堂宇。谓种种花房绮疏殊异严好。而在于中自在受用身心适悦。楼观。谓层台显敞远觌四方。见种种胜境神情熙畅。凡如是比皆为吉祥。是中法门所表。亦如择地中说。若与此相违。如见塔寺焚摧荒秽之类。则非善梦也。幢谓旗帜宝幢。崇高端丽而现其前。或用麾导众人莫不从命。是建立大菩提心轨成万行之像。盖谓孔雀尾等五色间错。或在空中而荫其上。或人授与之执以游行。是悲愿普覆之像。摩尼珠亦谓圆明照彻。或能出生众物给施众人。此是净心觉宝四摄利他之像。刀谓莹饰鉴彻精刚锐利。或人授与或自执持。是慧性成就之像。悦意花。谓种种水陆生花。随其性类有上中下。如色以鲜白为上。味以甘醇为上。皆善萌开发之兆。当以意分别之。女人是三昧像。男子是智慧像。亦取端正威德人所爱敬之类。密亲谓父母等。善友谓传法上人善知识等。或见牸牛群牧乳味丰盈。或人构之或自饮吮。皆是大悲漫荼罗醍醐上味之像。或见经夹净白无垢。整齐严饰字色分明。记说种种殊胜之事。则为善相。若卷帙垢坏字义残缺之类。当知不善。或见诸佛亲为摩顶现前记莂。以微妙音而慰喻之。或见声闻辟支佛等。乃至住于虚空中示现无量神变。皆当随事甄择。识其所为因缘。诸果谓世所希有珍奇妙果。或有人授与或从空下等。皆悉地之像。或渡河池大海。乃至自梦饮之须臾皆尽。皆为吉祥。若漂流漂溺无所拯援之类。当知不善。或闻空中有种种好声。歌咏法音奏诸伎乐。或称扬三宝功德。心所乐闻或言吉祥。或言应当与汝意乐之果。如是等皆为善梦。当以上中下类而分别之。如寺宇等。则有依地在空之别。其所见人。亦有男女圣凡之异。是故经云。宜应谛分别之。若与如前善相相违。或梦其身为狂象等所逐恐怖危急。或乘驼驴。或见可恶弊恶之人服饰弊坏。或自见身转卧青泥粪秽之中。或诸不净从空而堕。皆是相违相也。若是深行阿阇梨。自当于瑜伽中。悉知彼所梦之事及所为因缘。弟子晨起白师时。当随机劝发为断彼疑网也。若观彼人无有成辨之理。则不应具足傅法与之。恐彼久无功效或生疑谤故也。或如瞿醯所说。为作寂灾护摩得离诸障。然后召入。若见种种殊胜境界。应以法言慰喻令得欢喜。所云善住戒者。梵云谓之苏嚩啰多。是弟子之美称。如言佛子之类也。经中说偈亦是阿利沙。兼诵梵本弥善。亦具存之于左

翳沙(此也)磨喇伽(二合道也)嚩啰啰(愿也)室[口*履](二合)[璊-王+月](引殊胜也德也)摩诃(引大也)夜囊(乘也)摩护(大也)捺也(心也)曳曩(能)廋延(汝也)俨弭洒(所演也)睹(求也)波费(成也)设他(就也)怛他(引)揭哆(如来也)萨(婆枯反)焰部无(自然智也)摩诃(引)娜伽(大龙也)萨么嚧羯(世人也)写(二合)制[口*底]耶(敬如塔相也)阿悉[口*底](二合有也)那悉[口*底](二合无也)尾也(二合俱也)[口*底]羯囒(二合岚音)多(越也)磨迦(引)奢(虚空也)弭嚩(同也)[口*沮](无也)底岚(垢也)严避囒(深奥也)萨婆(二合一切也)达谜鼻(上法也)[口*月*葛]钵啰(二合)怛坚(世智不能了知也)么那(引)罗阎(无含藏)萨啰么(二合一切也)钵啰(二合)半遮啰[口*係]单(离一切戏论妄想)钵罗(二合)半制(平戏论也)[口*月*葛](无故也)钵啰半只单(亦是戏论重言也)萨婆(一切也)吃哩(二合)耶避(所作也)啰睹兰(无比也)萨[口*底]也(二合谛也)捺嚩(二合)也也(二合)参(引)磨设啰(二合)阎(依也)伊能(奴痕反此也)呾儞夜(二合也)囊(乘也)沫(无渴反)囒(愿也)室[口*(隸-木+士)](二合)瑟咤(敕闲反殊胜也)罗避设(得也二合)他捺曳(道也)萨[口*體]哆(二合住也)(凡梵本说偈了皆加助句声云伊[口*底]也)

初半偈称叹秘密乘道。殊胜愿者所谓一切智愿也。若入此净菩提门。则照见心法明道。所谓古佛大菩提道。故云此殊胜愿道也。大心义如前摩诃萨埵中说。过去未来现在诸大心众。无不乘是宝乘直至道场。故云大心摩诃衍也。次一偈。赞叹行人发菩提心功德。即以一切如来必定法印。为授大菩提记。故云汝今能志求。当成就如来。自然智大龙。世间敬如塔也。自然智。是如来自觉自证之智。昔所未闻未知之法。自然了了现前无所挂碍。故以为名。摩诃那伽是如来别号。以况不可思议无方大用也。制底翻为福聚。谓诸佛一切功德聚在其中。是故世人。为求福故悉皆供养恭敬。汝今发菩提心。亦能摄受一切如来无边福聚。是故世间。应当敬如塔想也。次有一偈半。显示净菩提心如实相印。即是开佛知见使得清净也。有无悉超越者。即是从众缘生不可思议中道。出过断常非有非无。一切心量所不行处。故名无垢虚空金刚智印也。诸法甚深奥者。以心性甚深故。当知阴界入等乃至一切种智。皆亦甚深。以一切法不出心实相故。如是实相。唯佛与佛乃能知之。非思量分别之所能及。故云甚深奥也。世智不能了者。言此心性。非一切世间聪慧利根者所能思议。假令长爪梵志等诸大论师。以种种因缘譬喻。庄严比况量度。终自非其境界。苦思惟求徒令发狂。独有信力坚固者。依此秘密方便乃能入之耳。无含藏者。所云难可了知者。正在如是无含藏处。以如实知蕴阿赖耶本不生故。无所执受亦无含藏。尔时一切心意识妄想戏论。皆悉清净。法界圆照如秋月在空。故次句云离一切妄想也。梵本云离一切戏论妄想。今以偈中语略。又意义无异故不具存。次句云戏论本无故者。若具存梵本应言戏论无戏论故。以一切戏论。皆悉从众缘生无有自性。无自性故。即是本来不生。是以释前句。云即此戏论自无戏论也。今以会意言之。故曰本无。次有二句。明此净菩提心究竟方便。以出过一切妄业。即能成就如来智业。普门导利。无非大事因缘。是故一切所作。皆无伦匹。故云一切业无比也。次转释前句。统论权实之大纲。故云常依于二谛。即是故论云诸佛说法常依二谛也。然此经宗。作种种具支方便皆随世谛。由此因缘。得一切智智印即是真谛。是故世谛为因真谛为果。因如四味皆悉无常。果如醍醐是则为常。然以十缘生句观之。世谛实相即是第一义谛。是故权实相即俱不可思议也。此二句文虽简略。能令行者。于一切如来方便无复余疑。故当触类而长。使贯通一部文义耳也。已略开示大菩提道竟。又结劝印持故。云是乘殊胜愿汝当住斯道。亦是重明授记之意也。尔时住无戏论执金刚。白佛言。愿说三世无碍智戒。无菩萨住此者。令诸佛菩萨皆欢喜故者。上文但说受三世无障碍戒。未显其相。是故住无戏论金刚乘。开发问也。复次世尊所以待问方说。亦为法门眷嘱相发明故。今此净戒。正以住无戏论金刚智印为体。所以特告此尊。欲令人法相应流传有寄也。阿阇梨复言。此戒相亦是加持句。若传授时。先当诵持梵本。然后以方言释之弥善也。今具列于左

室哩呶(能矩反谛听也)矩罗补怛啰(二合族姓子也)怛惨沫(无渴反)囒(彼戒也)曳(入)怛啰(二合若也)矩罗补怛啰(二合族姓子也)迦(引)耶嚩岌莽(二合)娜娑(身语意也)谜羯怛啰(二合)儞吃铩(二合)布那(引)囕婆(合为一也)阿吃[口*履](二合)邪(不作也)萨啰么(二合)达磨赦(平一切诸法也)迦哆么者婆(云何名也)也阿(去)怛莽婆(去)嚩(观诸自身也)钵[口*履]怛也(二合)隅(舍奉献也)勃驮菩提萨哆吠(二合)[口*弊](佛菩萨等也)咀羯娑摩(二合)睇睹(引何以故也)哩庾[口*係](何以反)阿(引)怛么(二合)婆(去)鑁(平若自身也)钵[口*履][口*底]也(二合)若[口*底](舍施也)谛娜嚩萨睹(二合)怛[口*履](二合)延(彼三物也)钵[口*履][口*底]也(二合)羯单(二合)婆(去)嚩[口*底](舍作也)羯哆莽室者(二合)嚩怛(入二合)窣堵怛啰(二合)延(云何名三物也)也弩哆迦(引)邪(引)嚩岌莽娜伊(上)[口*底](谓身语意也)怛萨瞒咀[口*履]系(二合是故也)俱罗补怛啰(二合善男子也)迦(引)邪嚩岌莽娜三嚩啰三勿[口*栗](二合)帝那(受身语意戒也)菩提萨怛吠(二合)娜(菩萨也)婆尾怛勿焰(二合当得也)怛羯娑摩(二合)睇睹(引何以故也)[口*栗]曩(二合)迦(引)邪嚩岌莽娜珊(引)钵[口*履]底也(二合)尔也(二合舍离彼身语意也)释叉釳啰(二合)诃赦(平应当学也)矩(入)蔓(无寒反)[口*底](作也)菩提萨埵(引)摩诃萨埵伊[口*底](菩萨摩诃萨也伊[口*底]是助句声)

初句言佛子谛听者。梵云矩罗。是族义部义。补怛罗是男子义。若世谛释。于四姓中生。皆名大族。故名族姓子。今得生如来家。于诸族中最为殊胜。故名族姓子。阿阇梨言。宜会意云佛子。于义为着也

经云。若族姓子住是戒者。当以身语意合而为一者。此戒梵云三嚩罗。是共缘共成此戒之义。所谓慧方便等之所集成。若尸罗者。但是清净义也。又三嚩罗是平等义。佛言以身口意合为一者。即是住三平等法门。所以得名三世无障碍戒也。如佛为诸声闻略说教诫。则云此三业道净是大仙人道。从十二年后。稍演其义成种种律仪。今此持明略戒义亦如是。若行人三业方便。悉皆正顺三平等处。当知即具一切诸佛律仪也。复次裂诸想网。是三嚩罗义。谓戏论诸见之网。经纬相成重复交络。故名为网。今行者观身口业自无别体。统末。归本唯是一心。而此心实相常是平等法界。是故住此戒时。种种身口意业皆同一相。无量见网皆悉净除。是故得名住无戏论金刚印也

经云。不作一切诸法者。种种五阴依于烦恼。烦恼依于业。是种种业皆由身口意生。如约身口意分为十种善恶业道。究其条绪则无量无边。是故三业凡所修行。则有进趣之行。失进趣者则为倒想。由倒想故有无量相生。为此诸相所碍。不得佛无碍智。今行者深观十缘生句。了知三业毕竟不生。法性自尔常无动作。是名住无为戒也。如是净戒尚非如来所作。况住斯戒而造作诸法耶

经云。云何为戒。所谓观察舍于自身。奉献诸佛菩萨。何以故。若舍自身则为舍彼三事。何等为三。谓身语意。次明持无作戒具足慧方便也。行者观身实际之中身不可得即是如来解脱。是故磬舍此身。用施一切如来。从此以后。动止施为凡有所作。皆为如来解脱。非为己身也。虽种种炽然万行。庄严佛土成熟众生。法性自尔非所造作也。其能如是奉修者。是名无边福聚。是名无尽福河。随造涓滴善根。以投法界海中故。受至拯众生界亦无穷竭。阿阇梨言。梵本诵中有偈云。若有解脱人。持此解脱法。供养解脱者。此福最为胜。若真言行人。不晓如是净戒。则虽口诵真言身持密印心住本尊三昧。具修次第仪式供养诸尊。犹名造作诸法。未离我人之网。云何得名菩提萨埵耶。故经次云。是故族姓子。以受身语意戒。得名菩萨。所以者何。离彼身语意故。菩萨摩诃萨应如是学。此中应学。旧译名为式叉迦罗尼。犹如第五篇戒。总摄毗尼揵度威仪行法。大乘学者亦如是。当持此戒方便。普入一切真言行中。苟戒有亏而得成菩萨行。无有是处也

经云。次于明日。以金刚萨埵加持自身。为世尊毗卢遮那作礼者。即是受戒之明日。谓第七日暮也。作造漫荼罗诸作务时。皆当用金刚萨埵加持自身。谓观自身即是执金刚也。是中方便。如下品经文及供养次第中说。若见谛阿阇梨。则是住于金刚萨埵心。所谓无等等菩提心也。以此秘密加持故。诸有所作无能阻坏之者。次当如前运心。为大日如来作礼。然后持诵降三世真言加持净瓶。此亦是成辨诸事真言也。先当取如法净瓶汲清洁之水。如法观漉。中置五宝五谷。又取种种香水众妙花果枝插中。种种庄严。用鲜净帛彩系颈。皆应依供养次第辟除去垢。净以法界心字然后加持也。大凡真言遍数无有定限。应以字计之。如苏悉地中说。又彼中随作三部漫荼罗。各用部心或部母真言加持。今此经中。通用办事真言加持。其真言又兼广略故。不具论遍数。当以意裁之。若极大者诵至百遍。次者五百遍。少者令至千遍也。既加持竟。当置在白檀。先所规画檀门之外。欲入漫荼罗者。当先以此洒之。令彼宿障净除。方得见漫荼罗也。又于别器调和香水。以郁金龙脑旃檀等种种妙香。亦以真言加持。授与令饮少许。此名金刚水。以秘密加持故。乃至地狱重障皆悉除灭。内外俱净堪为法器也。阿阇梨言。此即名为誓水。亦顺世谛犹如盟誓之法。令于一切众圣前。噬此香水自誓其心。要令不退大菩提愿也。复次以无碍戒香。和合嚩字门清白心水。诸有饮触之者。皆必定成于无上菩提。如此清净其心。则堪入秘密漫荼罗也。尔时执金刚秘密主以偈问佛以下。明造立漫荼罗支分。偈中先赞叹佛。唯愿一切智。诸说法中最第一者。说彼时分也。此时分。即是初画漫荼罗迄事竟以来。时分限剂。次云大众于何时。普集现灵瑞者。谓大悲胎藏中一切普门随类身。于何时普集道场现前。神力加持示现威验也。若弟子诸根净利应度机深。或于此时。即亲睹无边圣众。如灵山会坐者。同见三变净土分身诸佛。无有异也。当知尔时即是漫荼罗阿阇梨。传持诚谛之语行如来事时。故云殷勤持真言也。说此偈已。尔时世尊告持金刚慧者言。常当于此夜。而作漫荼罗。谓于此第七夜中。使法事都毕也。是中从日没后。至明相出以来。总名为夜。初入夜分。即当图画诸位安置诸供养具。明相未出已前使发遣竟。若违此法则生障碍。乃至令所依住处亦不吉祥也。然深秘密释中。正以道机嘉会为时。或以加持方便。促百劫为一夜。或演一夜为百劫。修短在缘无有定限也。若浅行阿阇梨。则须具依于法则。于昼日分。即当规画界域。以白檀等。草定诸尊形位分段。至日将夕。预备香花灯烛等。皆合素办。瞿醯云。于漫荼罗北面一处。以白色规画。办事真言僻除诸难。置诸供具也。阿阇梨言。若不能于一夜中遍画诸尊者。从第五日受持地以后。渐次作之。于理无妨。又别有尊形印字三种方便。如下文所说也

经云。传法阿阇梨。已知时分即明造立轨仪。至日入时。阿阇梨及助伴弟子。各如法澡浴已。着新净衣兴大悲心。赍持供物往诣漫荼罗所。先应一一具法加持。如供养次第中说。次当如法护持自身。呼所度弟子。为彼作护洒以香水。皆令一处次第而坐。然后阿阇梨至道场门前。普遍运心。稽首顶礼十方一切诸佛亦如上说。然后持五色线。向漫荼罗位立而顶戴之。次观自身作毗卢遮那。经所谓大毗卢遮那而自作加持也。所以然者。以大日如来是此大悲胎藏阿阇梨。是故行者。若行阿阇梨事时。即应以自身作毗卢遮那。若作缘漫荼罗诸作务时。即以自身作金刚萨埵。其加持方便。如下文及供养法中说也。复次行者应知护方八位。凡所造作漫荼罗随此而转。东方因陀罗次第随转至。南方焰摩罗。西方嚩噜拏北方毗沙门。东北伊舍尼东南为护摩。西南涅哩底。西北为嚩庾。其上方诸尊。多依帝释之右。下方诸尊多依龙尊之右。上谓空居。下谓地居也。又环中胎藏三重界城。皆已预为摽志。使方隅均等图位素定。要令大日之位。当五种宝聚之心。至此图众相时。阿阇梨先至因陀罗方如法作礼。次住火方北向而立。助伴弟子在伊舍尼。对持修多罗准定于外界。弟子次当右绕至涅哩底。师亦右回西向而对持之。阿阇梨次复右绕至嚩庾方。弟子亦右回北向而对持之。弟子复右绕至伊舍尼。师亦右回东向而对持之。凡一周竟。皆令当齐在虚空中均等平正已。至第二周亦如前右转。次第絣之以为界道。次复准定四维。阿阇梨复当右绕至涅哩底。弟子先在伊舍尼。右回相向持之。弟子次复右绕至嚩庾方。师即右转至护摩方。弟子亦右回相向持之。皆令当脐而在空中准定其位。弟子次复右绕至涅哩底。师即右转至伊舍尼相对絣之。弟子次复右绕至护摩方。师即右转至嚩庾方亦相对絣之。阿阇梨言。其正四方十字界道。经虽不言理必有之。亦须右旋相对絣定也。如是已定外界及八方相竟。次当入中先定中胎外界。亦如前旋转絣作四方相。其八方相已定。更不复作也。次定第一重外界。次定第二重外界。亦同中胎法则。其广狭之量。皆当展转相半。假令中胎藏纵广八尺。第一重当广四尺。第二重当广二尺。第三重当广一尺。阿阇梨言本法如此。若恐大少相悬者。稍以意均调之。于理无失也。如是分竟。复于一一重重更分为三分。其最向里一分。是行来周道。故云佛子所行道。次一分是安置诸供养物处。次外一分是安置诸尊座位。故此二分皆是圣天之位处也。次于此外复作周匝界缘。于此虚空位之中。当运心观察随其方面。分位相应诸尊皆都请供养。所以尔者。为阿阇梨临事有所忘误。安置诸尊或不周悉。其应请召而无位次者。皆当运心于此中供养也。分此三分位法。先于第一重外界之里。随取少分用作界缘。其阔狭之量。当以意裁之。趣得稍通座位也。于此界缘之内。作三分均分之。当先定诸尊座位内界分了。次定行道供养中间界分。如是第一重竟。次于第二重。亦从外向里渐次分之。次分第三重亦如是上文所说。从大日如来脐以下光明。是此第三重位。自脐以上至咽所出光明。为第二重位。自咽以上乃至于顶相之光。为第一重位。其中胎藏。即是毗卢遮那自心八叶花也。所共建立漫荼罗金刚弟子。须善通达真言法要。亚近于师。则能更相佐助无所遗失。若不得如是人。但取已曾如法灌顶者。临事指授行之也。又无此人者。当置橛为之。先于火方师位下橛。次伊舍尼方亦置之引线。即师先心记火方橛此是师位。然后从伊舍尼引线至涅哩底。余准此行之可知也。阿阇梨又云。欲共引线。要须取所欲灌顶弟子耳。先以加持香水洒之与共行事。所画檀位等。且以物覆之勿令见也。方等有四门者。谓重重院皆设四门。使中正均等。开西向一门以通出入。余门以线界横断之。瞿醯云。凡诸方开门。皆随彼方隅广狭。准为九分。取中一分为门。其余八分。则于门之左右各得四分。所出入门稍令阔作。自余诸门。以白色末作画闭之。阿阇梨言。用金刚线作界横断竟。犹如金刚不可越之。越者犯三昧耶。又经文通门西向。若有因缘向余方开之。于理无咎也。余如下文所说。诚心以殷重。运布众圣尊者。谓图画时先住瑜伽。观此漫荼罗大众会一一形色相貌威仪性类座位诸印。皆悉现前具足明了。然后以无量殷勤恭敬心。而彩画之。乃至大小疏密之度。亦令均停相称。故云如是造众相。均调善分别也。内心妙白莲者。此是众生本心。妙法芬陀利花秘密摽帜。花台八叶。圆满均等如正开敷之形。此莲花台是实相自然智慧。莲花叶是大悲方便也。正以此藏。言大悲胎藏漫荼罗之体。其余三重。是从此自证功德流出。诸善知识入法界门耳。正方四叶是如来四智。隅角四叶是如来四行。约此现为八种善知识。各持金刚慧印。故云遍出诸叶间也。如是十六法。一一皆等法界。乃至无有少分不平等处。故其摽相亦与冥符。略摄如来万德以为十六指。申而长之则无量无边。故此漫荼罗。极小之量剂十六指。大则无限也。鬓蕊。是一切三昧门陀罗尼门六度十八空等。如大般若之所说。从此一一鬓蕊。以加持神力故。现出三重漫荼罗中一种庄严眷属也。此是如来秘传之法。不可形于翰墨。故寄在图像以示行人。若得深意者。自当默而识之耳。从此实相花台中。则表于大日如来加持之相。其义已如前释。其所余秘密八印下品及图说之。次于东方内院。当大日如来之上。画作一切遍知印。作三角形其锐下向纯白色。光焰围之在白莲花上。即是十方三世一切如来大勤勇印也。亦名诸佛心印也。三角是降伏除障义。谓佛坐道树以威猛大势。降伏四魔得成正觉。鲜白是大慈悲色也。如来师子奋迅大精进力。正为是事因缘。乃至放大悲光常遍法界。故云普周遍也。次于大勤勇北。至于北维置虚空眼。即是毗卢遮那佛母也。佛母仪如般若经佛母品中广说。真金是如如实相之体。毕竟净句是彼教门之外饰。故曰缟素以为衣。一切戏论灭时。心日光明无所不照。故曰遍照犹日光。恬怕一心人乃能见此。故其摽帜。犹如天女住于正受之像也。次复于大勤勇南。至于南维作一切诸佛菩萨真陀摩尼印。此是净菩提心无边行愿之所集成。常能普雨世出世间一切财宝。诸救世者。皆从性净莲花台中现如是宝。故云住于白莲上。阿阇梨言。此是通一切印。亦可于诸方面皆置之。若诸佛菩萨。经中不言所持印相者。亦执此无价宝珠。皆得也。大凡此第一重。上方是佛身众德庄严。下方是佛持明使者。皆名如来部门。右方是如来大悲三昧。能滋荣万善故名莲华部。左方是如来大慧力用。能摧破三障故名金刚部也。是故入阿字门一切诸法不生。是法身义。入娑字门一切诸法无染着。是莲花义。入嚩字门一切诸法离言说。是金刚义。如下字轮品中。以此三字统摄百明。意在此也

经云。大日右方置大精进观世自在者。即是莲华部主。谓如来究竟观察十缘生句。得成此普眼莲华。故名观自在。约如来之行。故名菩萨。顶现无量寿者。明此行之极果。即是如来普门方便智也。此像及菩萨身。皆作住现法乐熙悦微笑之容。观自在身色。如净月或如商佉。即是上妙螺贝。或如军那花。其花出西方亦甚鲜白。当总此三譬。言其光鲜润彻白中之上也。次于观音右边。画多罗菩萨。凡诸圣者皆面向大日。今言观音右边。即是座西。他皆放此。此是观自在三昧。故作女人像。多罗是眼义。青莲华是净无垢义。以如是普眼摄受群生。既不先时亦不后时。故作中年女人状。不太老太少也。青是降伏色。白是大悲色。其妙在二用之中。故令二色和合。以是义故不青不白也。其像合掌。掌中持此青莲。手面皆向观音。如微笑形。通身圆光如净金色。被服白衣。首有发髻作天髻形。不同大日发冠也。观音左边置圣者毗俱胝。其身四手。右边一手垂数殊鬘。一手作施愿印。左边一手持莲花。一手执军持。面有三目。如摩醯首罗像。首戴发冠。如毗卢遮那发髻冠形。所云持者。如言地持万物。即是载承之义也。其身洁白圆光围之。光中具有黄赤白三色。不纯白纯赤纯黄。故云无主。凡黄为增益色也。白者寂灾色。赤者降伏色。以此三昧光中兼具三力。是故用为摽帜也。次近毗俱胝左边。画得大势尊。如世国王大臣威势自在名为太势。言此圣者。以至得如是大悲自在之位故以为名。所以持未敷莲者。如毗卢遮那实智花台既成果已。复持如是种子。普散一切众生心水中。更生未敷莲花。此尊迹同是处。亦能普护一切众生潜萌之善。使不败伤念念增长。即是莲花部持明王也。次于明王左边。画明妃耶输陀罗。译云持名称者。身真金色。以诸璎珞庄严令极端严。如女天之像。右手持鲜白妙花枝。果叶相间长条茂好。其花或有初疱。或有欲开或有正开敷者。若五若十乃至数十。左手持钵胤遇。亦是西方胜上之花。以得大势明王。主安立一切众生菩提种子。而此明妃。主含藏出生此中种种功德。故其被服摽帜。皆与此义相应也。多罗之右置半拏啰嚩悉宁。译云白处。以此尊常在白莲花中。故以为名。亦戴天发髻冠。袭纯素衣。左手持开敷莲花。从此最白净处出生普眼。故此三昧名为莲花部母也。次于观自在菩萨下。置何耶揭唎婆。译云马头。其身非黄非赤。如日初出之色。以白莲花为璎珞等。庄严其身。光焰猛威赫奕如鬘。指甲长利双牙上出。首发如师子项毛。作极吼怒之状。此是莲花部忿怒持明王也。犹如转轮王宝马巡履四洲。于一切时一切处去心不息。诸菩萨大精进力。亦复如是。所以得如是威猛之势。于生死重障中不顾身命。多所摧伏者。正为白净大悲心故。故用白莲璎珞而自严身也。已如法建立观音诸眷属竟。次于大日如来左方。安置金刚部明王。所谓执金刚能满一切愿者。其色如钵胤遇花。是淡黄色也。或如绿宝。是绿靺羯宝。犹如虚空显色也。以净法界色与金刚智礼和合。是故其身黄白。如是智身。犹若虚空不可破坏。一切无能降伏之者。故用虚空显色以为摽帜。此意言。若法乃至少分犹如极微。是可得者。则为无常变易诸行所随。是故毕竟空智。于坚固性中最为第一。所持密印。即是五股金刚也。五如来智。皆兼权实二用。而以金刚慧手执持其中。故云左执拔折罗。此印当以光鬘普遍围绕。故云周环起光焰也。首戴三峰宝冠形若山字。峰间如仰偃初月之形。以种种微妙杂宝一切璎珞。庄严其体。此意言。般若波罗蜜至果地心中。转名一切种智。故云首戴众宝冠。以此妙慧广历一切诸法。自在旋转出生无量法界庄严。故云间错互严饰。广多数无量也。次于金刚部主之右置忙莽鸡。所谓金刚部母。亦持金刚智杵。以诸璎珞严身。此是出生金刚智力三昧。所谓金刚三昧也。次于部母之右置大力金刚针。素支译云金刚针。持一股拔折罗以为幖帜。此拔折罗。是一相一缘坚利之慧。用此贯彻诸法无所不通。故名金刚针也。其下有二使者皆女人形。胡跪微笑而瞬仰之。其状卑而充满浅黄色。以金刚为标。是彼摧坏重障三昧也。次于执金刚之左。置金刚商羯罗。译云金刚锁。其印执持连锁。两头皆作拔折罗形。锁下亦有二女使。与金刚针使者无异。以此智印。摄持一切刚强难化众生。使不退于无上菩提。故以为名也。次复于执金刚下。置忿怒持明。降伏三世一切大作障者。号月黡尊。面有三目四牙出现。如夏水雨时云色。作大笑之形。以金刚宝为璎珞。此是持金刚者。以无量门大势威猛。摄护众生三昧也。以无量眷属而自围绕。皆悉卑而充满。作忿怒形。乃至一身具百千手。操持种种器械。竖立森然。若不可尽画者。要作一二使者乃至五六。皆应住莲花上。意明此莲花心中。法尔成就一切勇健大精进力。不从余处来也。已建立金刚萨埵诸眷属竟。次往西方画如来持明使者及诸执金刚众。有种种形色性类种种密印摽帜。皆于图中出之。是一一尊大慧光明悉遍法界。所现身口意密亦遍法界。故云普放圆满光。为诸众生故也。于此下位依涅哩底方。画不动明王。如来使者。作童子形。右持大慧刀印。左持罥索。顶有莎髻。屈发垂在左肩。细闭左目。以下齿啮右边上唇。其左边下唇。稍翻外出。额有雏文。犹如水波状。坐于石上。其身卑而充满肥盛。作奋怒之势极忿之形。是其密印摽帜相也。此尊于大日花台。久已成佛。以三昧耶本誓愿故。示现初发大心诸相不备之形。为如来僮仆给使执作诸务。所以持利刃以罥索者。承如来忿怒之命。尽欲杀害一切众生也。罥索是菩提心中四摄方便。以此执系不降伏者。以利慧刃。断其业寿无穷之命。令得大空生也。若业寿种除。则戏论语风亦皆息灭。是故缄闭其口。以一目视之意。明如来以等目所观一切众生无可宥者。故此尊凡有所为事业。唯为此一事因缘也。镇其重障盘石。使不复动。成净菩提心妙高山王。故云安住在盘石也。复次于下方西北隅际。作降三世忿怒持明王尊。首戴宝冠持五股金刚印。瞻仰毗卢遮那。如请受教敕之状。偈云不顾自身命者。谓应图作至极忿怒奋不顾命之容。谓欲摄召法界众生。皆使顺从法王威命。此亦是成办诸事真言也。为此五如来智大自在力之所涤除摧灭者。皆悉至于果地庄严。非唯无所障碍偏证但空而已。是故持五股印。首戴宝冠而在风轮之中。即法花经。诸有所作。皆为开佛知见。使得清净之意也。已安立第一漫荼罗上首诸尊竟。次往第二院画释迦牟尼。阿阇梨言。此中第二是隐密语耳。若从中向外。当以释迦牟尼眷属为第三院。今则以毗卢遮那法门眷属为第一。释迦牟尼生身眷属为第三。诸菩萨在悲智之间上求下化。故为第二。所以如此互文者。此是如来密藏。为防诸慢法人不从师。受者。变乱经文。故须口传相付也。于东方初门中。先置释迦牟尼。身真金色。并具光辉卅二相。所被袈裟作乾陀色。坐白莲花作说法之床。谓以左手执袈裟角。如今之阿育王像。右手竖指。以空水轮相持。是其摽帜也。此白莲花。即是中台净法界藏。世尊为令此教广流布故。以此生身摽帜而演说之。然与本法界身无二无别。故云住彼而说法也。次于世尊北边。安置佛眼。亦是释迦牟尼佛母。此方译为能寂母也。当作世间乐见端严无比之身。通身皆有圆光喜悦微笑。此是如来。出生随类生形三昧。此三昧。正以大慈普眼为体。观察应度众生而导利之。慈眼之光无所不遍。故云遍体圆净光也。次于佛母之北。画如来白豪相印。住莲华中作商佉色。身有圆光手执莲花。如半敷之状。内有如意宝珠。此是如来无边福业之所集成。如观佛三昧等经广说。能满足一切众生愿也。次于释迦师子之南。置如来五顶。第一白伞佛顶。第二誓耶译为胜顶。第三微誓耶。此用多声呼也译为最胜顶。第四谛殊罗施。译云火聚顶

经云。众德者。正译当云大分。是具大德义也。第五微吉罗拏。译云舍除顶。是弃舍一切烦恼义。亦是摧碎义也。此是释迦如来五智之顶。于一切功德中。犹如轮王具大势力。其状皆作转轮圣王形。谓顶有肉髻形。其上复有发髻。即是重髻也。余相貌皆如菩萨。令极端严欢喜。所持密印如图也。次于东方。最近北边布列五净居众。第一自在天子。第二普花天子。第三光鬘天子。第四意生天子。第五名称远闻天子。当次第列之。其印相具如图说。阿阇梨言。此是五那含天子耳。过此已上。有菩萨受佛职位处。亦名净居天。多是一生补处菩萨。是第二院所摄。非此中所明也。此天次南豪相之右。复画三佛顶。第一名广大佛顶。第二名极广大佛顶。第三名无边音声佛顶。其形相皆同五顶。是如来三部众德之顶也。其五种如来顶。有五种色。所谓真金色。郁金色。浅黄色。极白色。浅白色。是中真金郁金二色相似。然真金光净。郁净色稍重也。三佛顶则有三色。谓白色黄色赤色。此是兼具寂灾增益降伏色。此八佛顶皆周身有光。光极广厚。以诸璎珞严身。由如来本誓愿力故。悉能满足一切愿也。东南隅右列诸火天众。住火焰中。额及两臂各有三灰画。即婆罗门用三指取灰。自涂身象也。一切深赤色。当心有三角印。在焰火圆中。左手持数珠右手持澡瓶。此是普门之一身。为引摄火祠韦陀梵志。方便开示佛围陀法。故示此大慧火坛。净修梵行之摽帜也。次于右方直大日之南。作焰摩法王。手执檀拏印。印相。犹如棒形上有人首。作极忿怒之状。以水牛为座。身作黑玄色。阿阇梨言。少时当因重病困绝神识。往诣冥司睹此法王。与后同共语言。貌甚慈忍。然此檀拏印。以忿怒形捡效生来所犯。口出大光至为严切。及验出家以后功业。便尔寂然不复有言。焰摩王及后。寻即降阶善言称叹。殷勤致敬求受归戒。因放却还。比至苏后。其两臂绳所系持处犹有疮痕。旬月方愈也。阎摩之西作阎摩后及死后。亦是阎摩后也。东边作黑夜神及七摩怛里。译云七母皆女鬼也。其形悉皆黑色。次于西南隅。画涅哩底鬼王。执刀作可怖畏形。是护方罗刹王。嚩噜拏是西方护方龙王。持罥索为印也。于东方五顶之南。当画因陀罗释天之主。坐须弥山天众围绕。首戴宝冠。身被种种璎珞持伐折罗。及余诸眷属。谓舍脂夫人。及六欲天等。具如图中所示也。释天眷属之南。置日天众。在八马车辂中。并二妃在其左右。所谓誓耶微。誓耶。译云胜无胜也。日天眷属布诸执曜。盎伽在西。输伽在东。勃陀在南。勿落萨钵底在北。没儞没遮在东南。罗睺在西南。剑婆在西北。计都在东北。又于南纬之南置涅伽多。谓天狗也。北纬之北置嗢迦跛多。谓流火也。释天眷属之北近净居天。置大梵王。戴发髻冠。坐七鹅车中。四面四手。一手持莲花。一手持数珠。已上是右手。一手执军持。一手作唵字印。此上是左手也。印当稍屈头指。直申余指。侧手案之而作语状。是名净行者吉祥印。所余四禅诸天皆列其左。无热等五净居天列在其右。毗尼所谓观净居天被服仪式。制齐整着三衣内衣戒是也。西方近门置地神众。次北置萨啰萨伐底。译云妙音乐天。或曰辨才天次。北并置其妃。又次置微瑟纽。旧译谓之毗纽。此是那罗延天也。并置商羯罗天。此是摩醯首罗。于一世界中有大势力。非三千世界主也。经中下文更有噜捺罗。即是商羯罗忿怒身。从事立名。又置塞健那天。即是童子天也。皆于其侧置妃。阿阇梨言。此是天众。当于释梵王左右序列之耳。最西北隅。置护方风天眷属。西门之南。与日天相对应置月天。乘白鹅车。于其左右置廿七宿十二宫神等。以为眷属。次于北门。当置毗沙门天王。于其左右置夜叉八大将。一名摩尼跋陀罗译曰宝贤。二名布噜那跋陀罗译曰满贤。三名半只迦旧曰散支。四名娑多祁哩。五名醯么嚩多即是住雪山者。六名毗洒迦。七名阿吒嚩迦。八名半遮罗。及诃栗底母功德天女。经文阙之。阿阇梨言。功德天随毗沙门合在北方。若本位亦可置在西方也。凡此等诸大天神。皆是众所知识。世间众生各各随性欲因缘。宗奉供养。毗卢遮那为欲普门摄众生故。遍一切处示同彼身。即以世间共识之摽帜。为出世间秘密之摽帜。犹如帝释之像安住妙高山王。如来因陀罗三昧。亦复不移此处。开出净菩提心妙高山王。自余法门例皆如是。不可详说。但行者随彼一一乘中。功行成就自当开解耳。又释迦牟尼座下。应作忿怒持明。右边号无能胜。左边号无能胜明妃。并白色持刀印。观佛而坐其间。所云地神者。即前所说西门中地神。当捧持宝瓶虔恭长跪。其瓶中置种种水陆诸花。余如图说。并于通门。第二重厢曲之中置二龙王。右曰难陀。左曰跋难陀。首上皆有七龙头。右手持刀。左手持罥索。乘云而住。此皆漫荼罗中所要。故云真言行者。当以不迷惑心。依次作之也

经云。所余释种尊。真言与印檀。所说一切法。师应具开示者。如释迦部中佛钵锡杖印等。其类甚多。经不具出。但随此方空缺处。采择余经所说。逐便安置之。设令缺之亦无过咎。但经中所出上首诸尊等。必应一一如法画之。不得遗谬。其莲花部金刚部等诸方。亦例此可知也。经中。次说第三院菩萨眷属。当释迦之内正东门中。画文殊师利。身郁金色。顶有五髻作童子形。左持泥卢钵罗。是细叶青莲花。花上有金刚印。极熙怡微笑坐白莲花台。此其秘密摽帜也。阿阇梨言。郁金即是阎浮金色。用表金刚深慧。首有五髻者。为表如来五智久已成就。以本愿因缘故。示作童真法王子形。青莲是不染着诸法三昧。以心无所住故即见实相。金刚智印。能以常寂之光遍照法界。所以坐白莲者。意明不异中胎藏也。文殊北边当画光网童子菩萨。身真金色。执持宝网。以种种璎珞庄严。坐宝莲花中。文殊持无相之妙慧。而光网持万德庄严。如智度所说。以盐调和诸食。倍增其味而不可空啖。故行人失般若方便。单修空慧则堕断灭中。纯修福德则堕有所得中。所以观佛长子者。意在此也。次作文殊五使者。一名髻设尼。二名优波髻设尼。三名质多罗。四名地慧。五名请召。于妙吉祥左右次第列之。盖各持文殊一智也。髻设尼是发端严义。邬波是其亚者。文殊以五髻征表五智。故此使者。亦以美发为名。质多罗是杂色义。其五使者下。各作一奉教者。皆跪向使者。如承受音告之形。悉是文殊三昧。故经云。侍卫无胜智也。次于第二重。大日如来左方画除盖障菩萨。西方俗法。东向而治故。以东为初方。南为右方。西为后方。北为胜方。今此漫荼罗坛。门向西故当大日左方也。图中除盖障菩萨。左手持莲华。华上置摩尼宝珠。右作施无畏手。此菩萨及诸眷属。皆是大慈悲拔苦除障门。正以此菩提心中如意宝珠。施一切众生无畏。满其所愿也。经云。舍于二分位当画八菩萨者。谓除盖障之侧。当作二使者。然后如其次第置八菩萨。凡列诸眷属。皆令最初者在右。第二者在左。第三复在右。第四复在左。如是一左一右。次第置之。今于此八菩萨中。先以除疑怪在除盖障之右。施一切无畏在左。次复以除一切恶趣在除疑怪之右。以救意慧在施无畏之左。次复以悲念菩萨在除恶趣之右。以慈起菩萨在救意慧之左。次复以除一切热恼在悲念之右。不可思议慧在慈起之左。诸余位布例。皆放此也。次于北方画地藏菩萨。于种种间饰杂宝庄严地上以金银颇胝水精四宝为莲花座。亦令穷极巧丽。其菩萨在花座上。光焰周遍其身。如在胎藏。故云处于焰胎也。此圣者。主持宝王心地中性起功德无边宝藏。故其摽帜。以一切珍奇杂宝绮错庄严也。其余眷属菩萨。义亦同之。当于地藏之右置宝处菩萨。地藏之左置宝掌菩萨。次于宝处之右置持地菩萨。宝掌之左置宝印手菩萨。持地之右又置坚固意菩萨。如是上首诸尊。又各各于其左右。画诸眷属以自围绕也。次于西方画虚空藏菩萨。被鲜白衣左手持莲花。花上有大刀印。刀印上遍生焰光。及诸眷属皆坐正莲花上。此菩萨持如来等虚空慧。所以持大刀者。利慧之摽帜也。被服白衣明白净无垢。是其教门外饰也。譬如虚空。无所分别亦无积集。而世间万像依之以生今。此法门亦尔。于毕竟空中。出生不思议自在之用。无有穷尽。如大集虚空藏经中广明。故名虚空藏也。此中法门眷属。所谓虚空无垢菩萨。虚空慧菩萨。清净慧菩萨。行慧菩萨。安慧菩萨。亦如前次第左右列之。所以皆云等者。明此上首诸尊复各有无边眷属也。其形相皆如图说。此偈末云。略说大悲藏。漫荼罗位竟。此二句是传度者以义结之。非经中本文也。如上所说。菩提心为因。大悲为根。方便为究竟者。即是心实相花台大悲胎藏开敷。以大悲方便。现作三重普门眷属。以是义故。名为大悲胎藏漫荼罗也。如于一世界中。普现六趣随类之身。于一切世界中。亦复如是。于彼彼众同分中。最为上首。其所说法。亦于彼法之中微妙第一。复由此义。普能摄受无尽众生故。毗卢遮那名为法界王也。今此上首诸尊。同共集会印持如是法。故彼一切同类众生。各各生希有心言。我之所尊无与等者。亦复在此众中。当知此法甚为希有。以生希有心故。随于一切法界门而种善根。乃至长夜兴不善根。欲破坏正法者。既至道场。见彼所宗奉大天。又蒙不思议法食之施。恶心即灭弃舍魔事。或生一念随喜之心。以生一念净心故。便可于中开出大悲胎藏漫荼罗也。复次此漫荼罗种种法门。虽同一法界。然其功用浅深各有差别。如一地所生一雨所润。然诸药草性分不同。若医王观之。则知如是药草。于某病中非对治所宜。然于某病则势力珠胜。若于此等普门方便中。一一分别不谬。乃堪作大阿阇梨也。十万偈大本中。彼诸圣尊。各自宣说自所通达法界门。种种异方便法。今此略本。但举其普通趣道之要法耳。若行者如法修行不亏法则。蒙不思议加被时。自当曲示方便无所不通也。阿阇梨言。凡行者不住瑜伽。不合为人建立漫荼罗也。初欲画时。先用字门转作诸尊。座位形色性类一一相应。即观如是大悲藏即是我身。方起手画之。如是深行阿阇梨。必则于一切时。常不离如是佛会也。画了作法事时。如法次第起金刚地。观此宝王宫殿。在须弥山顶。所有一一庄严。皆如下品中说。如是明了已。方可请召也

大毗卢遮那成佛经疏卷第五大毗卢遮那成佛经疏卷第六

        沙门一行阿阇梨记

    入漫荼罗具缘品第二之余

阿阇梨所传漫荼罗图位具列如左

上方　　　　　　　　　　　　　　　　右方　　　　　　　　　　　　　左方　　　　　　　　　　　　　　　　　　下方

○如来如意宝　　　　　　　　　　　　△能授一切尊(满一切愿也)　　　□妙金刚　　　　　　　　　　　　　　　　【图】降三世尊

○如来甲胄　　　　　　　　　　　　　□莲花部女奉教者

○如来罥索　　　　　　　　　□莲花部奉教者　　　　　　　　□青金刚

□如来怖魔　　　　　　　　　　　　　□莲花三股戟　　　　　　　　　□金刚莲　　　　　　　　　　　　　　　　□金刚铎【图】

○如来脐　　　　　　　　　　　　　　□莲花戟

□如来马藏　　　　　　　　　　　　　□莲花尊　　　　　　　　　　　□寂静金刚

○如来唇　　　　　　　　　　　　　　□金刚莲　　　　　　　　　　　□大迅利金刚　　　　　　　　　　　　　　□金刚罥索

□如来十力　　　　　　　　　　　　　□莲花轮

○如来牙　　　　　　　　　　　　　　□莲花刀　　　　　　　　　　　□金刚牙　　　　　　　　　　　　　　　　□金刚刀

□如来大护　　　　　　　　　　　　　□莲花德菩萨　　　　　　　　　□那弭荼金刚(因因立名又云短也)

△无所畏大护者【图】　　　　　　　　□大水吉祥　　　　　　　　　　□赤体金刚

○如来无所畏　　　　　　　　　　　　□大吉祥　　　　　　　　　　　□佛奉教者

□如来铃铎　　　　　　　　　　　　　□僧吉祥【图】

○如来商佉　　　　　　　　　　　　　□佛吉祥【图】　　　　　　□越无量虚空

□如来三昧耶金刚　　　　　　　　　　□金色菩萨　　　　　　　　　　△月黡尊【图】

○如来正勤　　　　　　　　　　　　　□名称慧菩萨【图】

□如来三昧耶　　　　　　　　　　　　□白色菩萨　　　　　　　　　　□难降大护者(女形【图】)

○如来舌　　　　　　　　　　　　　　△坏诸怖畏大护者【图】　　　　□金刚部生

□如来豪相　　　　　　　　　　　　　□大势至菩萨

○一切如来座　　　　　　　　　　□毗俱胝菩萨【图】　　　　　　□金刚连锁【图】　　　　　　　　　 □不可越护门者【图】

□如来大勤勇　　　　　　　　　　□观世音菩萨　　　　　　　□执金刚

□如来眼　　　　　　　　　　　　□多利尊【图】

○如来心　　　　　　　　　　　　　　□观音母　　　　　　　　　　　□金刚母【图】

□如来铄底　　　　　　　　　　　　　□大白菩萨

○无堪忍(如来无堪忍)　　　　　　　　□资财主菩萨　　　　　　　　　□金刚针

□水自在尊　　　　　　　　　　　　　□遍观菩萨　　　　　　　　　　□金刚钩　　　　　　　　　　　　　　　　□相向守护门者【图】

□如来念处　　　　　　　　　　　　　□吉祥菩萨　　　　　　　　　　△金刚无胜大护者【图】　　　　　　　　　△如来使者

○如来刀　　　　　　　　　　　　　　□带塔德菩萨

□如来轮　　　　　　　　　　　　　　□宝德菩萨　　　　　　　　　　△军荼利金刚【图】　　　　　　　　　　　□金刚拳

□如来莲花　　　　　　　　　　　　　□鹿皮衣形

□如来顶　　　　　　　　　　　　　　□莲花军持　　　　　　　　　　△大力金刚【图】　　　　　　　　　　　　□无戏论金刚

○如来结界　　　　　　　　　　　　　□莲花鬘

□如来施愿　　　　　　　　　　　　　□莲花斧　　　　　　　　　　　□虚空无垢金刚　　　　　　　　　　　　　□金刚斧

○如来平等说　　　　　　　　　　　　□莲花索

□如来口　　　　　　　　　　　　　　□莲花铎　　　　　　　　　　　□素啰多金刚(妙住)

○如来腰　　　　　　　　　　　　　　□莲花螺　　　　　　　　　　　□大身金刚　　　　　　　　　　　　　　　□金刚轮

□如来焰光　　　　　　　　　　　　　□莲花部使者　　　　　　　　　□大胜金刚　　　　　　　　　　　　　　　□金刚捧

□如来钩　　　　　　　　　　　　　　(□莲花部使者△马头观世音)　　□广眼金刚

□虚空眼　　　　　　　　　　　　　　□莲花捧　　　　　　　　　　　□拔折罗金刚　　　　　　　　　　　　　　【图】圣不动尊

                                右第一重竟

□无垢光童子【图】　　　　　　　　　□贤劫菩萨【图】　　　　　　　○大慧菩萨【图】　　　　　　　　　　　　□贤劫菩萨

□光网童子【图】　　　　　　　　　　　　　　　　　　　　　　　　　□寂慧菩萨【图】　　　　　　　　　　　　□金光菩萨

□男奉教者【图】　　　　　　　　　　△行慧菩萨【图】　　　　　　　△无垢慧菩萨【图】　　　　　　　　　　　○金色菩萨

                                                                                △宝德菩萨

□男守卫者【图】　　　　　　　　　　○胜妙天菩萨【图】　　　　　　○无尽意菩萨【图】　　　　　　　　　　　□贤德菩萨

□男使者【图】　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　○花幢菩萨

□女使者【图】　　　　　　　　　　　□宝严菩萨【图】　　　　　　　□不思议慧菩萨【图】　　　　　　　　　　△计都菩萨

△六面尊　　　　　　　　　　　　　　　　　　　　　　　　　　　　　△大慈起菩萨【图】　　　　　　　　　　　□无垢光菩萨

                                    △宝印手菩萨【图】　　　　　　△无像菩萨【图】

△降阎摩尊

                                                                  ○救意慧菩萨【图】

□地慧童子【图】　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　△清净慧菩萨【图】

                                    ○宝掌菩萨【图】

□优波计设尼【图】　　　　　　　　　　　　　　　　　　　　　　　　□施一切无畏菩萨【图】　　　　　　　　　□虚空慧菩萨【图】

【图】文殊师利　　　　　　　　　□地藏菩萨【图】　　　　　　　△除一切盖障菩萨【图】　　　　　　　　　○虚空藏菩萨【图】

□计设尼【图】　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　□虚空无垢菩萨【图】

□质多罗【图】　　　　　　　　　　　○宝作菩萨【图】　　　　　　　□除疑怪菩萨【图】　　　　　　　　　　　△法慧菩萨【图】

□请召者【图】　　　　　　　　　　　　　　　　　　　　　　　　　　○除一切恶趣菩萨【图】　　　　　　　○慧步菩萨【图】

                                    ○持地菩萨【图】

□女使者【图】　　　　　　　　　　　　　　　　　　　　　　　　　　△悲念菩萨【图】(亦名大悲缠)　　　　　　□剌泥弭菩萨(无墙也)

□男使者【图】　　　　　　　　　　　□贤意菩萨　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　△泥弭菩萨(墙也)

□女守卫者【图】　　　　　　　　　　○宝冠菩萨【图】　　　　　　　□除一切热恼菩萨【图】　　　　　　　　　○宝幡菩萨

□女奉教者【图】　　　　　　　　　　△发心即转法轮菩萨【图】　　　○海慧菩萨【图】　　　　　　　　　　　　(□金光菩萨△光明菩萨)

□宝冠童子【图】

                                    □善住意菩萨【图】　　　　　　△妙慧菩萨【图】　　　　　　　　　　　　○妙幢菩萨

□月光童子　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　□无边幢菩萨

□善财童子　　　　　　　　　　　□贤劫菩萨　　　　　　　　□贤劫菩萨【图】　　　　　　　　　　□贤劫菩萨

                                右第二重竟

△火天护方神　　　　　　　　　　□伊舍那护方神　　　　　　△涅哩底护方神　　　　　　　　　　　　　【图】风天护方神【图】

△火天　　　　　　　　　　　　　　　□鸠槃荼众眷属　　　　　　　　△女罗刹【图】　　　　　　　　　　　　　【图】风神后

△火天后　　　　　　　　　　　　　　□阿名揭拏(羊耳)

△婆私瑟吒大仙　　　　　　　　　　　□阿湿嚩揭拏(马耳)　 △罗刹众【图】　　　　　　　　　　　　　△迦楼罗女【图】

△竭伽大仙　　　　　　　　　　　　　□戍婆揭拏(箕耳)　　　　　□贤劫菩萨　　　　　　　　　　　　　　　△迦楼罗【图】

△未建荼大仙　　　　　　　　　　　　□杂宝藏神【图】　　　　　　　○童男菩萨

△瞿昙大仙　　　　　　　　　　　　　(△荼吉尼【图】△荼迦【图】)　○比丘众　　　　　　　　　　　　　　　　(△非人眷属△一切人眷属)

△迦叶大仙　　　　　　　　　　　　　□童男菩萨　　　　　　　　　　○日光菩萨

△诸执曜神等　　　　　　　　　　　　□比丘众　　　　　　　　　　　□西南日轮遍照胜德佛　　　　　　　　(□童男菩萨□比丘众)

△毗逝耶后　　　　　　　　　　　　　□离尘勇猛菩萨

△日天子　　　　　　　　　　　　　　□东北方定胜手德佛　　　　　　○菩萨众　　　　　　　　　　　　　　　　□宝胜菩萨

△逝耶后　　　　　　　　　　　　　　□菩萨众　　　　　　　　　　　○比丘众　　　　　　　　　　　　　　　　□西北方一宝盖佛

□那罗延并眷属　　　　　　　　　　　□比丘众　　　　　　　　　　　○童女菩萨　　　　　　　　　　　　　　　□比丘众

□魔天他化自在天　　　　　　　　　　□童女菩萨　　　　　　　　△苾[口*陵]蚁[口*栗]知　　　　　　　　　□童女众

□化乐天　　　　　　　　　　　　　　□女部多【图】

□兜率陀天　　　　　　　　　　　　　□部多药叉类【图】　　　　　　△诸毗那夜迦　　　　　　　　　　□贤劫菩萨

□焰摩天　　　　　　　　　　　　　　□住雪山药叉将【图】　　　△摩诃迦罗(黑神)　　　　　　　　　　　　(○小讫[口*栗]瑟怒二龙王○讫西瑟拏二龙王)

□(东方提头赖吒天王并揵闼婆众)　□娑多祁哩药叉将【图】　　○优婆路系多二龙王

□舍支夫人【图】　　　　　　　　　　□半遮罗药叉将【图】　　　　　△毗卢遮十眷属【图】　　　　　　　　　　○路系多二龙王

□帝释三十三天　　　　　　　　　　　□毗洒迦夜叉将【图】　　　　　　　　　　　　　　　　　　　　　　　　　○优婆臂多二龙王

□童子菩萨　　　　　　　　　　　　　□痾吒嚩迦药叉将【图】　 △毗舍支十眷属【图】

□比丘众　　　　　　　　　　　　　　□毗沙门子药叉将【图】　　　　　　　　　　　　　　　　　　　　　　　　○优婆束讫劳二龙王

□欢喜菩萨　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　　○束讫劳二龙王

□上方欢喜德菩萨　　　　　　　　　　□摩尼拔陀罗神【图】　　　　　　　　　　　　　　　　　　　　　　　　　○沙伽罗龙王

□菩萨众　　　　　　　　　　　　　　□护方神后【图】　　　　　　　△寒冷地狱　　　　　　　　　　　　　　　○阿那婆达多龙王

□童女菩萨　　　　　　　　　　　　　□俱吠啰护方神毗沙门【图】　　△热恼地狱　　　　　　　　　　　　　　　○得叉迦罗龙王

                                    □吉祥功德天　　　　　　　　　　　　　　　　　　　　　　　　　　　　　○摩迦斯龙王

□阿难陀　　　　　　　　　　　　　　□满贤药叉将【图】　　　　　　□毗楼博叉王【图】　　　　　　　　　　　○矩利迦龙王

□须菩提　　　　　　　　　　　　　　□诃栗底母(男五女五)　　　　　　　　　　　　　　　　　　　　　　　　　○羯句吒迦龙王

□舍利子　　　　　　　　　　　　　　　　　　　　　　　　　　　　　△阎摩殁[口*栗]底后　　　　　　　　　　 ○和修吉龙王

□大目连　　　　　　　　　　　　　　□散支大将【图】　　　　　　　△阎摩后　　　　　　　　　　　　　　　　○阿难陀龙王

□大迦叶　　　　　　　　　　　　　　□童男菩萨　　　　　　　　　　△阎摩但荼　　　　　　　　　　　　　　　(○大莲花龙王○波头花龙王)

□无量音声佛顶　　　　　　　　　　　□比丘众　　　　　　　　　　　△阎摩罗法王　　　　　　　　　　　　　　○商佉龙王

□广大佛顶　　　　　　　　　　　　　□胜授菩萨　　　　　　　　　　△质呾罗笈多讯狱者　　　　　　　　　(○缚噜拏后【图】○嚩噜拏龙王【图】)

□火聚佛顶　　　　　　　　　　　　　□北方胜德佛　　　　　　　　　△夜黑天　　　　　　　　　　　　　　　　□毗楼勒叉护方天王【图】

□胜佛顶　　　　　　　　　　　　　　□菩萨众　　　　　　　　　　　□辨才天【图】

△如来锡杖　　　　　　　　　　　　　□比丘众　　　　　　　　　　　□童男菩萨　　　　　　　　　　　　　　　○优婆逊那守门者【图】

○如来钵　　　　　　　　　　　 □童女菩萨　　　　　　　　　　□比丘众　　　　　　　　　　　　　　　　　通门

○如来牙　　　　　　　　　　　　　　□贤劫菩萨　　　　　　　　　　□离优菩萨　　　　　　　　　　　　　　　○逊那守门者【图】

□豪相　　　　　　　　　　　　　　　□主田农神　　　　　　　　　　□南方无优德佛　　　　　　　　　　　　　○地神【图】

△无能胜尊　　　　　　　　　　　　　□主象马厩神　　　　　□菩萨众　　　　　　　　　　　　　　　　○龙王并后眷属【图】

□释迦牟尼佛　　　　　　　　　　　　　　　　　　　　　　　　　　　□比丘众　　　　　　　　　　　　　　　　○童男菩萨

△无能胜妃　　　　　　　　　　　　　□主王库藏　　　　　　　　　　□童女菩萨　　　　　　　　　　　　　○比丘众

○佛母　　　　　　　　　　　　　　　□主外道福处神

                                                                  □别异地狱　　　　　　　　　　　　　　　○行慧菩萨

○如来铄底印　　　　　　　　　　　　△主严穴神　　　　　　　　□贤劫菩萨　　　　　　　　　　　　　　　○西方宝焰佛

□童男菩萨　　　　　　　　　　　　　□主伏藏神　　　　　　　　　　△遮闷拏　　　　　　　　　　　　　　　　(○菩萨众○比丘众)

□比丘僧　　　　　　　　　　　　　　□主碛神　　　　　　　　　△娇吠唎　　　　　　　　　　　　　　　　○童女菩萨

□普光菩萨　　　　　　　　　　　　　□主尸林神　　　　　　　　　　△吠瑟拏味　　　　　　　　　　　　　　　○主平相侵神

□东方宝性佛　　　　　　　　　　　　□主波池神　　　　　　　　　　　　　　　　　　　　　　　　　　　　○主日历神

□菩萨众　　　　　　　　　　　　　　□主龙泉神　　　　　　　　△娇唎　　　　　　　　　　　　　　　　　○主时分神

□比丘僧　　　　　　　　　　　　　　□主井神　　　　　　　　　　　△燕捺唎　　　　　　　　　　　　　　　　○主业作神

□童女菩萨　　　　　　　　　　　　　□主空中宫菀神　　　　　　　　△嗟捺唎　　　　　　　　　　　　　　　　○主宿神

□佛袈裟　　　　　　　　　　　　　　□主宫室神　　　　　　　　　　△未啰弭　　　　　　　　　　　　　　○主宿对神

△佛军持　　　　　　　　　　　　　　□主海神　　　　　　　　　　　□紧那罗妃【图】　　　　　　　　　　○主夜神

□白伞佛顶　　　　　　　　　　　　　(□主室宅神□主巷曲神)　　　　(□紧那罗○童男菩萨)　　　　　　　　(□主月神○主日神)

□最胜佛顶【图】　　　　　　　　　　□方神　　　　　　　　　　○比丘众　　　　　　　　　　　　　　　　○六时神

□摧碎佛顶【图】　　　　　　　　　　□主街陌神　　　　　　　　　　○莲花手菩萨　　　　　　　　　　　　　　○主直神

                                    □主河神　　　　　　　　　　　○东南莲花胜德佛　　　　　　　　　　　　(○主廿八宿神○主十二宫神)

□最高佛顶　　　　　　　　　　　　　□主道神　　　　　　　　　　　○菩萨众　　　　　　　　　　　　　　　　○月后名赤色

□辟支佛　　　　　　　　　　　　　　□主旷野神　　　　　　　　　　○比丘众　　　　　　　　　　　　　　　　○月后名月祥

                                    □主郊野神　　　　　　　　　　○童女菩萨　　　　　　　　　　　　　　　○月天子

□大梵并明妃眷属　　　　　　　　　　□主痁肆神　　　　　　　　　　△慕诃囊　　　　　　　　　　　　　　　　○月后名月相

□四禅天　　　　　　　　　　　　　　□主城神　　　　　　　　　　　△阙名火神　　　　　　　　　　　　 ○童男菩萨

□无色天

□净居自在天子　　　　　　　　　　　□主村神　　　　　　　　　　　△劫微　　　　　　　　　　　　　　　　　○比丘众

□普花天子　　　　　　　　　　　　　□主洲神　　　　　　　　　　　△芒囊娑　　　　　　　　　　　　　　　　○莲花胜菩萨

□光鬘天子　　　　　　　　　　　　　【图】主鸟神　　　　　　　△讫洒也　　　　　　　　　　　　　　　　○下方莲花德佛

                                    □主山神　　　　　　　　　　　△社吒啰　　　　　　　　　　　　　　○菩萨众

□意生天子　　　　　　　　　　　　　□主悉地物神　　　　　　　　　△句[口*路]诞囊　　　　　　　　　　○比丘众

□名称远闻天子　　　　　　　　　　　□主悉地神　　　　　　　　　　△没栗拏　　　　　　　　　　　　　　　　(○童女菩萨○贤劫菩萨)

□大自在妃并眷属　　　　　　　　□主仙药神　　　　　　　　　　△露系多　　　　　　　　　　　　　　　　□阿修罗女眷属【图】

□大自在天并眷属　　　　　　　　　　□主药计神　　　　　　　　　　△芒噜多　　　　　　　　　　　　　　　　□阿修罗眷属【图】

□摩醯首罗子及妃　　　　　　　　　　□主药神　　　　　　　　　　　△捺噜迦

□持明妃　　　　　　　　　　　　　　□悉地持明妃【图】　　　　　　△娑摩醯捺罗　　　　　　　　　　　　○摩睺罗伽女【图】

□持明仙　　　　　　　　　　　　□悉地持明仙【图】　　　　△诸火仙等　　　　　　　　　　　○摩睺罗伽

                                右第三重竟

阿阇梨言。第一院东方如来钩。乃至如来甲等。皆是毗卢遮那三昧。一一作天女形。如漫荼罗方圆以辨其色。坐白莲台上。手中复持莲花。花上各以物像用为摽帜。如钩轮刀槊商佉铃铎罥索甲胄等。皆依本相画之。顶相豪相口舌牙唇等。准例推可解。如来脐于莲上图作连环圆好之相。如来腰亦颇旋曲如数珠鬘形。如来藏如轮王马宝藏相不现之形。如来施愿当作与愿手。如来法及辨说等或持经藏或作说法手。念处十力等皆是止观相应法。作寂然三昧之容。三昧耶当作佛顶相。如来顶相具摄一切功德。凡手中无物可为幖帜者。皆应置之。若漫荼罗不作尊形但示秘密印者。于金刚座上作莲华台。台上如前画作幖帜。其作字漫荼罗者。经中有种子字。当如法置之。如经不载。当取梵名中最初字为种子字。或可通用阿字也。北面莲花部诸尊。若经中不说形相者。通作红莲花色或净白色如金色尊等。则依名辨之。所持印相亦如佛部中说。然用莲花为幖帜。如莲花轮像。当以四莲花叶如十字之形用为轮辐。辐外作刃环围之。莲花刀当于莲上置刀。刀锋上又用莲花以为摽帜相。金刚杵戟等皆亦如是。莲花罥索以莲华为两茸。铎则以莲花为系。鬘则贯穿莲花以庄严身。或于所持花上置之。戴塔吉祥于顶髻上置窣堵波。或在所持花上。莲花尊则于花上重置莲花。宝德尊莲花上有宝。能授一切愿明王能满一切希愿。其状非一如观世音手持莲花。花上或置如意宝。随息灾增益降伏事。在彼相应坛中。大吉祥二手各持莲花。水吉祥或莲中出水或手垂出水。被鹿皮尊当以鹿皮严身。如梵天像。其契印漫荼罗例同前说。通用娑字为种子也。南面金刚部诸尊亦可依经。初所列名者皆具置之。随作方圆三角半月等坛。身色亦尔。或持一股拔折罗。或持三股五股。上下二锋等种种金刚标相。如经中所说随意置之。其刀斧钩针等。皆以金刚为摽帜。刀则刃锋柄饰。皆作金刚杵端铦锐之形。罥索连锁两端皆如三股拔折罗像。轮以十字金刚为辐辋。利刃环绕围之。铎以一股金刚为上系十字金刚为舌。余皆例推可解。契印漫荼罗。亦于金刚座上置白莲花。花上各表其物。若作字漫荼罗。执金刚所统眷属通用缚字。余金刚通用[合*牛]字为种子也。第二院诸菩萨众。若经中具载形相者。一一如其本教画之。无文者通用真陀摩尼印。当持莲花。花上置如意宝。周匝焰鬘围之。或随彼名中义趣以表其相。如宝冠菩萨即于花上置冠。宝网菩萨则于花上置网。宝掌菩萨掌中置宝。发心转法轮印手中持论。所有诸阙位处。皆置贤劫菩萨。其使者奉教等。皆作卑下之容。其使者操持刀捧状如夹门守御。奉教者或执持于捧印或瞻仰所尊。若受指麾教敕。守护者则如守门通信有所咨白。各随其类也。降阎摩尊是文殊眷属具大威势。其身六面六臂六足。水牛为座面有三目。色如玄云作极忿怒之状。当捡文殊梵本具足图之。凡此等诸尊。若余经中具说形相者。亦可依彼图画入曼荼罗时中。此诸尊。毗卢遮那经不载真言手印。即别出余经者。当依彼经授与真言手印。令依此经供养次第法行之也。第三院十方佛等。各依常相图之。若作契印当以如来顶相。种子则以阿字。声闻缘觉一同比丘仪式。是中缘觉小差别者。谓或有肉髻等大人之相。若契印当用钵袈裟锡杖等。其种子字如经中真言所说。东方日天之前或置摩利支天女。如陀罗尼集出之。北方夜叉八将图中阙少者。其形大抵相似。皆被甲胄持伽驮印。身相圆满端正。以彼趣所求无乏常快乐自恣故也。羊耳马耳象耳等。皆是鸠槃荼眷属。其形不同夜叉。皆露身垂毛作非人之像。耳同畜兽。图云持明仙者。是余药力等所成。悉地持明仙者。皆是专依咒术得悉地人。直言诸仙者。皆围陀事火之类。勤修苦行成五通神仙。又有夜叉持明。是彼类中福德最胜。天趣之所摄者。与世仙又殊也。其山海河池林树谷药城邑道路等神。各以本名为摽帜相。山神坐山河神在河。其树药等或手执持或依其上。当以义类推之。花严中更有足行神身众神。是护诸跂行之类及护身神。亦可依次列之。西方非人趣者。当知毗卢遮那普门身中。纯是杂类鬼神傍生等。图中无别名相者多在其中。所摄最多也。路系多是赤色。辟多是黄色。讫嘌瑟拏是黑色。其青色亦是中摄。若依此方中明义。则当各别出之。讫劳是白色。皆是一类龙王。各依本色画之。若加邬波字者其色稍浅。逊那邬波逊那亦是护门大龙王。皆右手持刀左持罥索。主年月时分神等皆作天女形。执持花枝等以为标相。若主善事者。其花亦令色相圆备。若主恶事者。则持萎萃花果等。其主六时神。亦可持六枝之花。作随时荣落之像以表其事。主昼夜者。亦可以花敷花合明之。他皆放此。南方苾陵吃嘌知。是摩醯首罗子。身极枯瘦。以常降伏怨敌。假使骨肉消尽要令得胜。故为此形。私谓即是智度所云。常修苦行割肉祀火。感生诸恶神者。所以位在南方。其十二火天。经中略说形像。有一神阙名者。但依诸火天总相形。余如图中所示也

经云。尔时执金刚秘密主。于一切众会中。谛观大日如来。目不暂瞬者。时佛如所示现普门漫荼罗。演说诸尊图位竟。秘密主以普眼观此一一诸尊。皆不见根本亦无住处。悉是莲花台藏实相之身。出生种种方便不可穷尽。尔时深自庆幸发希有心。倍于此法生难遭想。将欲更问深义。故先说偈也。初偈意言。一切智慧者。出兴于世间。如彼灵瑞花。时时乃现一耳。佛优昙花虽则难遇。然此真言法要倍复难遇之。何以故。此是如来秘藏。长夜守护不妄授人。苟无顿悟之机则不入其手。世尊在世犹多怨嫉。况末代乎。复次此经。自释难现因缘。若众生一见此漫荼罗者。无始以来恶业重障。摧灭无余。必定得大菩提记故。非钝根薄福之人所能遭也。一见尚难。何况次第修行。当知是人转复希有。常为普门海会之所称叹名闻十方。又同大日如来有种种名号。故曰无量称也

经云。行此无上句者。即是修行无上菩提句。此阿字门为一切真言之王。犹如世尊为诸法之王。故曰真言救世者。次二句明救世之业。所为能令行人成金刚性。止断诸恶趣一切苦不生也

经云。若修如是行。妙慧深不动者。若具存真本。应言慧极深不动。如大海之心以极深广故。又极远离二边故。乃至大风起时不能摇动。若行者入此真言大海心时。亦复如是。以妙慧甚深无量。又极远离二边故。一切诸法不能动摇。如娑竭罗龙王降雨六天时。于自宫三业都无动作。若解如是义者。则知漫荼罗种种方便。皆悉住于实际也

经云。时普集会一切大众。及诸持金刚者。以一音声赞叹金刚手者。彼诸大众。闻佛广演曼荼罗图位竟。欲问此中法界幖帜及金刚事业。敬重世尊故未敢发言。以金刚手能观察众心乘机说偈。必知欲决疑网。普利无量众生。是故称赞证明劝令发问。又十佛刹微尘众等以一心一味。令一人诵此法音。非谓人人俱时别说也。偈云善哉善哉大勤勇。汝已修行真言行。能问一切真言义。我等咸有意思惟者。真言行即是三平等法门。汝于持三密人中最为上首。故能问世尊普门深义。如仁者所欲问佛义。我等亦皆有是思惟。今悉同心思欲当速陈说也。次言。一切现为汝证验。依住真言之行力者。言我等初发心时。由住此无上句故。乃至能于金刚慧海甚深不动。是故必定师子吼。于汝前所说偈现作证明。我等诸有所作。皆由住真言行依真言势力。而与得成就。若汝咨问如来秘密方便者。诸有求大乘人。当于真言行法皆得通达。以通达故不久勤修。亦与我等无异。以见如是利义故。以一音声同心劝助也。尔时秘密主蒙大众劝发已。即说伽他广问世尊。初一偈问彩色义。有四句。第一句问云何是彩色义。第二句问当以何色。第三句问云何安置此色。先于何处。内耶外耶。第四句布色时以何色为先。此是造漫荼罗时一种支分也。次偈问诸门摽相。有三句偈。第一句问门旗形量。第二句问门厢形量。第三句问建立诸门法度形量。如是种种秘密摽帜。阿阇梨皆应善通达之。又是一支分也。次有二偈。大凡有八问。第一句问云何奉食及花香等。第二句问宝瓶法则。当知一切诸供养具皆在其中。阿阇梨当随事相办其性类。又是一种支分也。第三句问云何引召弟子入漫荼罗。第四句问云何作灌顶法。第五句问云何儭奉所尊。然此中复有二种。若初心行人依世谛漫荼罗。云何召入灌顶奉献阿阇梨。若已修习瑜伽作秘密灌顶。云何召入灌顶奉献阿阇梨。正作法时。所有加持教授方便皆此中摄。又是一种支分也。第六句问护摩处所。亦有浅密二释及息灾增益降伏等诸异方便。第七句问真言部类字义句义。第八句问三昧门浅深差别之相。凡阿阇梨未善通达如是法者。不应建立漫荼罗。又成三种支分也。如是问竟。大寂法王告执金刚言。汝当一心谛听。次说偈言。最胜真言道。出生大乘果者。大乘果即是佛无上慧。要由如是方便得生。由汝善言能请问我故。今普为诸摩诃萨。开示演说也。初一偈答色义云。染彼众生界。以法界之味。古佛所宣说。是名为色义者。犹如世间染色。能染净叠使同味故。以味解色。如云袈裟味者。即染作袈裟色也。今此漫荼罗色义亦然。以法界不思议色染众生心。同一净菩提味。复次如世间染衣先以。灰水洗。则易受染色。今以啰字门焚烧弟子心垢。使成灰烬。然后以嚩字门大慈悲水洗之。使纯一清白离诸戏论。然后染作法界漫荼罗。令种种普门身。皆同实相色也。次有两偈通答三问。问中云当以何色。今此答中具用青黄赤白黑五色也。偈云。先安布内色。非安布外色者。是答云何布色。何处先起何处后起也。洁白以为初。赤色为第二。如是黄及青。渐次而彰着。一切内深玄。是谓色先后者。是答是色谁为最初也。洁白是毗卢遮那净法界色。则一切众生本源。故最为初。赤是宝幢如来色。既发菩提心于明道中。降伏魔怨灭除盖障。故第二。黄色是娑罗树王色。以成正觉时。万德开敷皆到金刚实际。故第三。青是无量寿色。既到金刚实际。即以加持方便。普现大悲漫荼罗。如净虚空中具含万像。故第四。黑色是鼓音如来色。所以垂普门之迹。皆为显本。本者即是如来自证之地。住大涅槃。若舍加持神力。则一切心量众生非其境界。是故其色幽玄。而最居后也。复次如世间净帛。先受染色故。最后黑是染色之极。以最深故不可复加。是以居后。漫荼罗色义亦然。白是越百六十心垢义。此名信色故最初。赤者大勤勇义。是精进色故第二。黄谓一念相应时。定慧均等七觉开敷。是名念色故第三。青者大空三昧义。是名定色故第四。黑者谓大涅槃义。即是如来究竟之慧。是名慧色故名第五。或有说言白色最初。黄为第二。赤为第三。青为第四。黑为第五者。此约受染浅深有容有上之义。又白是信义最初。黄者犹如金刚不可俎坏。即是进义故第二。赤谓心障净除光明显照。即是念义故第三。余如上释。法门所表各殊也。复次白是寂灾色如来部义。故最初。黄是增益色莲花部义。故第二。赤是降伏色金刚部义。故第三。青是成办诸事亦出生随类之形。故第四。黑是摄召义。即诸奉教忿怒等所为众务。故第五也。复次如世间彩画不过五色。然更相涉有种种深浅不同。巧慧者善分布之。出生万像无有穷尽。法界不思议色亦复如是。统而言之不过五字门。然亦更相发挥。成种种差别智印。如来以普门善巧。图作悲生漫荼罗。乃至出生世界微尘数随类之形犹不穷尽。若瑜伽行人若得此中意者。当触类而长自在施为。寂灭真如中当在何次。如偈中所说。且举一途法门提其纲领耳

经云。先安布内色。非安布外色者。凡图画法。当先建立内心秘密莲花藏竟。次造第一重伊字三点诸内眷属。次造第二重四菩萨等诸大眷属。以及第三重一切世天眷属。又诸界道。中央及第一重当具五色。先以白色为周界竟。次于其外布赤色界。次外又布黄色。次外又布青色。最外次布黑色。其第二重。亦依如上次第布白赤黄三色。第三重周界。但布纯白一色。皆极令均调正直。渐次右旋布之。其行道及供养处外缘等。随作一纯色界。瞿醯云。但用白色也。所以先白色从中向外者。明此菩提心五种根力渐次增广。乃至住于大般涅槃。则遍一切处无所不在故。黑色最居外也。若从浅至深自迹归本。则世尊府同六趣为初门眷属开发净菩提心。若众生入此明门超百六十心时。则已出过世间上菩萨位。故第三漫荼罗。唯以白色为界也。第二漫荼罗。于白之上更加赤色黄色者。赤是勤勇。菩提心中进修万行。黄是如来念处万德开敷。尔时即入重玄门居寂光土。乃至近居补处犹故不识一人。故于第二重。但以三色为界也。第一重漫荼罗。于三色之上更加青色黑色者。青是大空三昧。所谓如来身口意密无尽加持故。作大虚空色。黑谓如来寿量常住之身。如是妙身毕竟无像。故作深玄色。此二句是如来秘藏。非普为一切众生。故名眷属也又入此深玄色者。即是如来自证中胎花藏。尔时见五智色。皆同一法界色。何有浅深之殊。而诸众生。有渐入者有超升者有顿入者。然其所趣毕竟同归。故云一切内深玄也

经云。建立门幖帜。量同中胎藏。厢卫亦如是。花台十六节者。漫荼罗夹门。皆竖幢旗以为幖帜。谓之门幖帜。二摽相距尺量。令与中胎正等。上置横括。其广亦然。幢竿上皆置偃月。月下置旗帜像。取缯帛裁令正方。可隅角破之以为两帜。各附幢竿之外。上锐下垂也。四维际亦置幢竿并偃月。其摽帜两向置之。于大勤勇门偃月上。各置如意宝。金刚手门偃月上。各置拔折罗。莲华手门偃月上。各置商佉。其四维上亦皆置宝也。夹门厢卫处如亚字形。而于中间通道。每于曲际皆置金刚撅。撅首如一股拔折罗形。其下铦锐。一箱六撅两边总十二撅。四门并四角总二十八枚。三重例尔。并备五色线。皆以不动真言或降三世真言。加持一百八遍或一千八十遍。阿阇梨正作法夜。既画曼荼罗竟。先观中胎及第一院知无阙少。即下金刚撅。其金刚撅。以金刚线周匝围之。至通门处。则止不须横断。三重皆如是置之。若不能尔者。其第三院。必应具依此法勿得阙少。至通门处。当举线随门摽。屈曲而上使不阂头。既结界竟。当依门出入不得辄越余处。每出入时。仍须诵不动真言。若是瑜伽阿阇梨。亦可周匝以线围断。若须出入时。想举此线而于下过。过已即还如故。或去门远急须出入者。当观自身作毗卢遮那以无挂碍身。勿生越线之想。随意出入无咎也。六撅间回屈处。皆令尺量均停。仍须通行道往来界院。最外门厢卫两边。亦与中胎正等。故云厢卫亦如是也。花台是灌顶处。莲花坛规制。大同中胎八叶之藏。极小者剂十六指。余义下当更说之。但开一门。其门令向大坛也。偈云。应知彼初门。与内坛齐等。谓第一重门相。当准约九分令广狭正齐。使门之中道正当花藏之心。所余第二第三。亦以此为率分之。自然渐次增广各得其所。于第二重门厢曲中。置二龙王兄弟。难陀在南拔难陀在北。其余众宝庄严。大同秘密漫荼罗位品。阿阇梨言。若作深密释者。四面方相正直均平等。是四念处义。四门是四静虑。亦是四摄法。门摽是四梵住。厢曲是四正勤。四维是四真谛。金刚线即是修多罗。以此连持三十七品作法门分剂也。所以外门摽相长短广狭之量。皆与中胎正等者。明如来一一法门。皆与法界相称。乃至无有毫牦增减。又合所行中道。正当莲花台实相之心。其普门之迹远而逾广。故云智者于外院。渐次而增加也。偈云。略说三摩地。一心住于缘。从此以下。答漫荼罗中三昧支分。若未修瑜伽者。不得作阿阇梨。以阙支分故法事不成也。经中。初略释三昧名义。次深广说之。初略释者。谓心系缘一境而不驰散。是等持义。故偈云略说三摩地一心住于缘也。且就有相瑜伽。自有上中下三种。上谓观毗卢遮那等诸如来身。中谓观文殊师利等诸菩萨身。下谓观因陀罗等随类之身。一一如漫荼罗所示。色像威仪秘密摽式或印或字。但一心住缘不复驰散。即是彼尊三昧门。以要言之。如漫荼罗海会佛刹微尘数一一善知识。皆一种入法界三昧门。若总观如是普门大众。一心住缘而不驰散。即是普眼三昧门。亦名普门世界三昧门。如一门及一切门者。或但入正遍知部三昧门。或但入莲花部三昧门。或但入金刚部三昧门。或以文殊眷属普皆集会为一三昧门。余三菩萨亦尔。随行人心量大小。种种不同也。行者修习瑜伽。或观本尊或观秘密印或观真言时。有种种境界现前。不与本观相同。皆是邪观也。如于定中。或见日月众星光明粲丽。或见大莲花王遍满空中。或见宝树楼阁殊胜庄严。犹如天宫及诸净刹。或复豁然不复有身心。相或见诸佛菩萨无量大众。或闻种种异声。或见悬崖巉绝至无间狱。以不依本所缘故。皆不应取。但如常一心意。虽得与定境相应。应须深修观察十缘生句。不应味着也。若见异境界以为殊妙而取着之。名为我慢定。亦名悭执定。但与正观相应时。自然得见俱胝佛刹。此中佛。谓百千众事刹为净处也。如是相应时。即知承前已来种种事相非无因缘。以如是如是因缘故。有如是如是事相。不由他悟而无所挂碍也。复次深秘释者。诸于一一善知识法门身真实相中。心住于缘。不生妄想戏论。是等持义。如入阿字门一念法界。是毗卢遮那三昧。于法莲花印一心不乱。是观自在三昧。于金刚慧印一心不乱。是秘密主三昧。乃至梵释诸尊。各于一法界门而得自在。若于彼解脱身一缘不乱。各彼净天眼三昧。若于大悲藏云海中一心不乱。名普眼三昧。亦名普现色身三昧。若使如来于无量阿僧祇劫。演说是中广义。犹不穷尽。今欲以两偈摄之。使究尽无余。故云广义复殊异。大众生谛听也。此中复二。初明如来三昧印。次明三昧道中差别印。偈云佛说一切空者。即是入阿字门。乃至无有少法而可得者。亦无定相可名三昧。住如是一心法界。名为正觉之等持也。所以然者。若出此心性。外有境界可缘。即非常住之境。为四相所迁时。住缘之心亦复随境界流。云何名为定耶。是故正觉三昧。觉诸法本不生故。唯是心自证心心自知心。从久远以来。常如实际无有变易。即以如是心自住如是缘故。得名为等持也。此正是毗卢遮那本尊。所现无尽庄严藏。亦不离如是本尊。若他观者。皆名邪观。故次说必定印言。三昧唯证心。非从异缘得。若据梵本质言之。当言彼更无异得。意言。更不从余处得之也。次云。彼如是境界。一切如来定者。如大般涅槃经明。一切有心者悉有佛性。此佛性即名首楞严定。亦名金刚三昧。亦名般若波罗蜜。佛佛道同更无异路。若行人初发心时。能如言正观心性者。亦即名为入如来定。岂烦渐超四处。方至究竟乎。复次瑜伽行人。若蒙诸佛威神加被故。乃至于三昧中。具见十佛刹土微尘众等。无量圣尊三种密印。互不相杂。或复一心不乱转成自身。虽则奇特难思。尚以有相有缘故。名为世间三昧。若此三昧现前时。行者观察十缘生句。净除一切妄相戏论。与空寂相应。即悟如是漫荼罗海会。皆悉从众缘生。如镜像水月干城等观无性相。是名出世间三昧。然尚以空病未空故。未得名为大空。及坐道场自证心性时。即知如是等加持境界。皆是心之实际。尔时心不住相亦不依空。而照见空与不空。毕竟无相而具一切相。故名大空三昧。住此三昧者。即是住于佛无碍慧。佛说是人一切智智究竟圆满。所以经云。故说为大空。圆满萨婆若也

经本第二卷初云。尔时毗卢遮那世尊。与一切诸佛同共集会。各各宣说一切声闻缘觉菩萨三昧道者。如来已说究竟三空三昧印。为令普门进趣者无留难故。复说三昧道中差别印。三重漫荼罗所示种种类形。皆是如来一种法门身。是故悉名为佛。此等一切诸佛。各于本所流通法门。自说彼三昧道。若现世天身者。则说彼天三昧道。若现声闻身者。则说声闻三昧道。若现辟支佛身者。则说辟支佛三昧道。若现菩萨身者。则说菩萨三昧道。若现持金刚身者。则说金刚三昧道。当知此中偈颂。如是无量刹尘。非世间结集经卷所能具载。然诸行人。若深入瑜伽境界三昧时。自当了了听闻。如正说时无异。是以故名为佛加持日也

经云。时佛入于一切如来一体速疾力三昧者。谓入此三昧时。则证知一切如来皆同一法界智体。于一念中。能次第观察无量世界海微尘等诸三昧门。知如是如是若干众生。于彼彼三昧门中。应得入道。知彼善知识。已为若干众生作种子因缘。未为若干众生作种子因缘。或有众生入如是法门。可得超升成佛。入余法门。久远稽留不得成佛。如是等种种根性不同。进趣方便皆亦随异。乃至游戏其中。次第修习出入超世间。于一一门。各得能成就无量众生。故名一体速疾力三昧也。尔时世尊遍观察已。了知种种三昧道。同归一体皆是佛乘。复为执金刚。说一切三昧道中成菩提印。初有二偈。明成佛之外迹谓我初坐道场。以此一体速疾力三昧。降伏天魔军众。然是中更有难降伏处。所谓烦恼等魔。无有形相方所亦无足迹。难可觉知。于一念中亦皆殄灭。故云降伏四魔也。以大勤勇声者。谓佛以诚实言告魔波旬。我于无量无数劫。为调伏众生故。弃舍身命不可称数。而今悉已成就。有入道之机故。我将证菩提。为彼等众生开发净眼。汝之势力何能留碍耶。适发此声时。一切众生怖畏悉除。天魔迷闷擗地寻皆退散。若有众生受持如是三角印者。乃至除无间狱中无量怖畏。何况天魔鬼神等怖耶。故言以大勤勇声。除众生怖畏。尔时地神欢喜展转称说。乃至声及净居。尔时大梵天等八部众生。徒见此伏魔之外迹。是故有名称生号为大勤勇者。然我实成佛处。则非彼等所能测量也。故次有二偈明菩提实义。我觉本不生者。谓觉自心从本以来不生。即是成佛。而实无觉无成也。一切众生不解如是常寂灭。想分别妄云有生。沦回六趣不能自出。今虽闻正法音。还于种种有为事迹中。推求挍计冀望成佛。何有得理耶。出过语言道者。从此已下皆是转释阿字门。觉本不生即是佛。佛自证之法。非思量分别之所能及。亦不可传授与人。智度谓之言语尽意不行处也。诸过得解脱者。一切妄想分别。名之为过。即是生灭断常去来一异等种种戏论。以不知诸法实相故。悉皆可破可转。若了诸法本无生际。即于如是一切过失。皆得解脱。是故金刚之身。远离百非也。远离诸因缘者。若法界体有生灭之相。则有因有缘可得宣说。而今法从缘生。则无自性。若无自性。则是本来不生。因缘和合时亦无所起。因缘离散时亦无有尽。是故如净虚空常不变易。大经亦云。唯有如来离诸因缘也。知空等虚空者。本来不生即是毕竟空义。以自性净无际无分别故。同于大虚。是故以世间易解空。譬不思议空也。如实相智生者。心之实相。即是毗卢遮那遍一切处。佛坐道场如法相解时。种种不如实见悉灭无余。是故萨婆若慧与虚空等也。已离一切暗者。于一切法相不如实知。即是无明。是故觉本不生时。即生遍法界明。以一切种观一切法。无不见闻触知也。第一实无垢者。此最实事更无过上。名为第一实际。所谓自性清净心。以离一切暗故。佛之知见无复垢污。皆是转释本不生义也。次有二句结云。诸趣唯想名佛相亦复然者。言六趣众生与毗卢遮那。本无二体。但随众生种种妄想。立种种名耳。佛亦如是。一切世间徒。见我降魔成道方便度人之迹。随彼心相而称说之。或云大沙门。或云大勤勇。乃至花严所说。于一世界中有无量异名。非谓自证法中。如其所说而可表示也。次一偈复释通世谛。明起教所由。故云。此第一实际。以加持力故。为度诸世间。而以文字说。谓以佛眼观之。如是种种名言。复不出第一实际。而诸众生入道因缘。种种不同。若应以文字语言得度者。则如来不动实际。以自在神力。加持彼彼声字而演说之。若众生如法修行。得与三密相应时。则知世谛不异第一义谛也

经云。尔时执金刚具德者。得未曾有开敷眼。顶礼一切智。而说偈言者。具德。谓具足一切如来秘密庄严之德。如连花增长具足时。蒙日光所照。自然开敷端严可爱。执金刚亦尔。心莲花眼遇菩提印光。朗然开敷万德皆备。美畅于内彰于外容。亦有青莲花目开敷之相。而说伽他领解前旨也。初云。诸佛甚希有。权智不思议者。具存梵本。应云一切诸佛希有智方便不思议。智谓领解前偈中觉本不生。方便谓领解前偈中加持神力。复次智谓心莲花台具足。方便谓叶蕊开敷。二种具不可思议。故云希有也。次云离一切戏论。法佛自然智。是广叹不思议智。而为世间说。满足众希愿。是广叹不思议方便。若法依师而得。从于众因缘生。即是戏论生灭相。非法性佛自然之慧。若是自然之慧。则非修学可得。亦不可授人。如内证天甘露味。假令种种方便为未尝者说之。终不能解。然佛大方便力。以无相法身。作种种名相加持。令诸众生以因果法。证得非因非果法。是故权实二慧具不可思议也。次云。真言相如是。常依于二谛者。是结成不思议二智。领解。上文施设二谛之意。以知名相即实际故。能以实际加持而作名相。以知浅略即是深秘故。能以深秘为浅略。随众生所成义利。皆实不虚。若能解此世谛时。自当通达第一义谛。故云诸佛说法常依二谛也。次有一偈。明信解佛菩提印得无量福聚。故云。若有诸众生。知此法教者。世人应供养。犹如敬制底。制底是生身舍利所依。是故诸天世人福祐者。皆悉供养。若行人信受如是义者。即法身舍利所依。堪受一切世间供养恭敬也。复次梵音制底。与质多体同。此中秘密。谓心为佛塔也。如第三漫荼罗。以自心为基。次第增加。乃至中胎涅槃色。最居其上。故此制底甚高。又从中胎八叶。次第增加。乃至第三随类普门身。无处不遍。故此制底极广。莲华台达磨驮都。所谓法身舍利也。若众生解此心菩提印者。即同毗卢遮那。故云世间应供养如敬制底也

经云。时执金刚说此偈已。谛观毗卢遮那。目不暂瞬。默然而住者。时执金刚。已闻毕竟三昧印。欲问三昧道中差别印。若以语言白佛恐乖至理。是以默然观佛一心而住。即是甚深发问也。复次执金刚默然住者。欲表如来照机义故。如常教所传。云佛于昼夜三时。观可化众生而度脱之。此随声闻心量。自作如是说耳。若佛眼观而后见。不观则无所见。观时则智慧生。不观则智慧不生。是则生灭明暗之境。不得名为平等大慧也。以如来无相无分别慧法尔无碍。常照法界根缘。如大海潮终不过限。是故金刚手适有可传之机。如来即为演说。不待问而后答也。复次金刚手。了知世谛即是第一义谛。所行处不异毕竟处。是故默然无言。如来了知第一义谛即世谛。毕竟处不异所行处。是故广分别说。为令众生通达二谛相故。更相发明。而实同归一致也。就如来答中。略有四句。第一句云。复次秘密主。一生补处菩萨。住佛地三昧道。离于造作知世间相。住于业地坚住佛地者。此是最上灌顶位。故先明之。如余经所明。此是一生所系菩萨。从此上生兜率天宫。次继佛位。故名一生补处也。今此经宗。言一生者。谓从一而生也。初得净菩提心时。从一实之地。发生无量无边三昧总持门。如是一一地中次第增长。当知亦尔。迄至第十地满足。未至第十一地。尔时从一实境界具足。发生一切庄严。唯少如来一位未得证知。更有一转法性生即补佛处。故名一生补处。此是究竟发菩提心。于一切三昧道中。最为牢强精进。进入佛道。故云住佛地三昧道也。离诸造作者。作谓修治地业。乃至庄严佛土成就众生。以有智分别心。犹是世间之相。今此菩萨。正行大空三昧。远离从缘生法微细戏论。故云离造作也。如世间相。谓实知世间实际。毕竟不异涅槃际。而能不动实际。悉见世间本起因缘。是故住此三昧道中。念念进趣如来地。住于业地。梵音质言之。当云作地。即是学如来金刚事业。皆得善巧。璎珞亦云入重玄门学佛威仪也。坚住佛地。即是于如来坚固不动。名之为住。与前住字义殊。如人渴乏求水。已经历多时。忽得睹见清凉池。中间更无障碍。但一心进趣无复异缘。是名补处三昧道。已到清凉池中希愿尽息。亦为佛地。故虽同名大空定。而义有差别也

经云。秘密主八地菩萨三昧道。不得一切诸法。离于有生知一切如幻。是故世称观自在者。如上已说十地道。若次第而进当说佛地。若渐下者当说第九地。何故说八地耶。以一切菩萨初度第七地时。上不见诸佛可求。下不见众生可度。谓是住大涅槃。于万行休息。尔时十方佛。以此三昧道发起其心。得度菩提心难地。是故别说。从此进入九地中无别说。从此过患难故。不须别说行处印也。从初发意以来。深观十缘生句。入此地时得度性空彼岸。故云不得一切诸法离于有生。复以善巧方便。于如如不动中。起十缘生无边大用。以如幻三昧。遍至十方佛刹。亲近种种善知识。普学无量度人门。随诸众生应以何等像类言音而得度者。即皆现之而为说法。是故世间见如是事迹故。号为观世自在者。是初入莲花三昧之异名也。此中自在。梵本正翻是富贵义。如人得大势位具足财宝。随心所欲自然成就。此菩萨亦尔。假令十方世界一切有情。希求世出世间种种资具。随其性欲种种不同。能以如幻三昧一时给与。各得满其所愿。然未能绝起用之迹。使诸有所作皆如金刚。故分为二印耳。复次此中。应说初法明门三昧道。于上品中已说。故不重言。又如上所说一生补处及八地三昧。是约教道法门。作如此说耳。然秘密乘人于世谛中。即能通达第一义谛者。从初发心时。即具行大空三昧。其谓不然。则于一生之中。不能顿满诸地也

大毗卢遮那成佛经疏卷第六大毗卢遮那成佛经疏卷第七

        沙门一行阿阇梨记

    入漫荼罗具缘品第二之余

经云。复次秘密主。声闻众住有缘地。识生灭除二边。极观察智得不随顺修行因。是名声闻三昧道者。如阿毗昙。明九想八念背舍胜处一切入三三昧等。皆名住有缘地。依此等三昧为方便故。令其心恬然而静。得正观察。觉世间出世间法。皆悉有因有缘。世间以集为因。以苦为果。出世间以道为因。以灭为果。如阿含中广明。毗尼中举要言之。所谓诸法从缘起。如来说是因。彼法因缘尽。是大沙门说也。以知因缘生灭故。灭有无见远离断常二边。得真谛智生。故名极观察智。以能极观察故不倒不谬。故名为谛也。从无明至老死。此有故彼有。此生故彼生。乃至轮回无际。若随此而轮。名之为顺。既见四真谛已。背生死流随行圣道。乃至能自记说我生已尽梵行已立所作已办不受后有。是名不随顺。如是种种不随顺行。要三昧为因。故曰得不随顺修行因。声闻三昧。虽复诸部异说种种不同。但合如是法印者。即名正行。若无如是印者。是名邪行也

经云。秘密主。缘觉观察因果。住无言说法不转无言说。于一切法证极灭语言三昧。是名缘觉三昧道者。因果即是十二因缘法。如声闻极观察智解了唯蕴无我。以厌怖心重故。疾断烦恼自证涅槃。不能分折推求十二因缘实相。辟支佛智慧深利故。能以总别之相深观察之。见一切集法皆是灭法。此与声闻异也。阿含云。十二因缘法者。有佛无佛法位常住。龙树亦云。此中法位即是如之别名。此是一切世间最难解处。故世尊始成道时不乐说法。意在于此。辟支佛所入渐深。故云住无言说法。言不转者。谓住此第一义时无有声字。故不可转以授人也。世尊得无碍知见于法自在。能于无言说法中。为作名字转受众生。辟支佛智慧有碍。是故不能演说。复次辟支佛。观一切集法皆悉如涅槃相。于种种有为境界中。皆亦戏论风息不知所云。故名证极灭语言三昧。修瑜伽与此相应。是名缘觉三昧也。此二种三昧。皆是菩提心难处。然但是所行道中一种心相。非谓不思议心性。可有如是三乘定相。是故行人。以此法印自印知已。便当直过无碍。若不善知识知。则为所留碍也

经云。秘密主。世间因果及业若生若灭。系属他主空三昧生。是名世间三昧道者。谓一切世间三昧。以要言之。至于究竟之处。皆灭坏因果及从因办果时所有作业。谓此三事若生若灭。皆系属于他。他谓神我也。所以然者。若行人不解正因缘义。而修证诸禅。必当计着自心以为内我。彼见世间万法因心而有。则谓由神我生。设令不依内我必依外我。即是自在梵天等也。若深求此中至赜。自然拨除因业。唯我性独存。乃至无一法入心。而证空定。最是世间究极之理。是故垂尽三有还堕三途。虽于禅定中。发种种世间胜智具五神通。研其宗趣终归是处。故以斯一印。统收一切世间三昧道。若行者入此心时。当自觉知也。经中佛说摄偈。就五种三昧道中。大分为二。谓佛菩萨缘觉声闻四种。皆名出世三昧。若诸天等所说真言法教道。皆属世间三昧。出世间三昧皆有实益。故云摧害于诸过。世间三昧但有权益。故云为利众生故也。如余经所说。求小乘人。当修行作观。即便于世间法教深生厌离。求大乘人。又于声闻法教深生怖畏。此皆为未知秘密藏者。作此方便说耳。就此经宗。则五种三昧皆是开心实相门。如行者初住有相瑜伽。则是世间三昧。但于此中了知唯蕴无我。即是声闻三昧。若以十缘生句观诸蕴无性无生。即是菩萨三昧。余如住心品中广明。不同余教以心性之旨未明故。五乘殊辄不相融会也。若更作深秘密释者。如三重漫荼罗中五位三昧。皆是毗卢遮那秘密加持。其与相应者。皆可一生成佛。何有浅深之殊。今偈中所说。就彼等自所流传法教而言耳

经云。复次世尊。告执金刚秘密主言。秘密主。汝当谛听诸真言支分也。大判真言。略有五种。谓如来说。或菩萨金刚说。或二乘说或诸天说。或地居天说谓龙鸟修罗之类。又前三种。通名圣者真言。第四名诸天众真言。第五名地居者真言。亦可通名诸神真言也。如圣者真言。亦说阿字或啰字等。彼诸世天乃至地居鬼神等。亦复说之。彼相有何殊异者。阿阇梨言。若佛菩萨所说。则于一字之中具无量义。且略言之。阿字自有三义。谓不生义。空义。有义。如梵本阿字有本初声。若有本初则是因缘之法。故名为有。又阿者是无生义。若法揽因缘成。则自无有性。是故为空。又不生者即是一实境界。即是中道。故龙树云。因缘生法。亦空亦假亦中。又大论明萨婆若。有三种名。一切智与二乘共。道种智与菩萨共。一切种智是佛不共法。此三智。其实一心中得。为分别令人易解故。作三种名。即此阿字义也。又如啰字亦有三义。一者尘义。二者以入阿字门故即是无尘义。又有波罗密义。以究竟到彼岸故即是本初不生。当知亦具三点。三点即摄一切法。如阿字啰字者。余诸字义皆然。又一切语言中带阿声者。皆阿字门所摄。若带啰声者。皆啰字门所摄。余字亦尔。与大论语等字等中释义亦同。下文不复广释也。若诸菩萨真言有阿字者。当知各于自所通达法界门中。具一切义。非于普门法界中具一切义。若二乘真言有阿字者。当知只约尽无生智寂灭涅槃明不生义。若梵天所说真言有阿字者。是约出离五欲觉观不生明义。若帝释护世真言有阿字者。是约十不善道及灾横不生明义。余皆以类可知也。如上所说皆是随他意语。明浅略义耳。若就随自意语明深密义。随入一门。皆具一切法界门。乃至诸世天等。悉是毗卢遮那。何有浅深之别。若行者。能于无差别中解差别义。差别中解无差别义。当知是人通达二谛议亦识真言相也。复次经中自说诸真言相。初偈云正等觉真言。言名成立相。如因陀罗宗。诸义利成就者。此明如来真言通相也。今但约最初三昧耶真言说之。言谓一一字。皆是一种入法界门。如言阿三迷者。阿字是无生门。娑字是无谛门。么字是大空门也。名谓此一一字门共成一名。阿名为无。三迷名为等。若更合之。即是无等也。成立为籍此众名。始终共成一义。如初句云无等。次云三等。次云三昧耶。共相成立。即是无等三平等三昧耶也。复次如以多名共成一句。所谓诸行无常等。乃至综此多句共为一偈。然后义圆。即是诸行无常是生灭法生灭灭已寂灭为乐等。皆是真言所成立相。余皆放此。如因陀罗宗者。因陀罗是天帝释异名。帝释自造声论。能于一言具含众义。故引以为证。世间智慧犹尚如此。何况如来于法自在耶。诸义利成就者。谓如来真言。于一一言。皆具能成就一切义利。一一名中。亦具能成就一切义利。一一成立相中。亦具能成就一切义利。且举三昧耶真言。最初阿字。以本不生义故。即有息灾用。以本不生故。一切功德具足无缺。即有增益用。以本不生故。无量过失殄灭无余。即有降伏用。更无一法出此本不生者。即有摄召用。如是本不生中无所有功。即能成办一切诸事。如阿字者。余一一字亦如是。如一一字者。一一名句及成立相。皆亦如是。是故当知即此真言中。具足一切功用也。已说真言通相竟。次明真言别相。故云有增加法句。本名行相应。谓凡作真言事业。当观此真言中。本所立名及所为意趣。辨其部类差别。随性相所应而行用之。若真言名义与所用。或不相应。则当依法增加语句。如真言中。法界法性大空不思议界种种差别名言。与如来自证真体相应者。当知是佛部真言。设令是余部者。亦可作佛部用。若有大悲普眼无染着等相应名义。当知是莲花部用。若有金刚不坏无戏论等相应名义。当知是金刚部用。如是等义无量无边。瑜伽者当以意推之。不可详载也。复次经中。自说名行相应之用。谓若诸真言中。有此◇(唵)◇([合*牛])◇(发)◇(磔迦)◇(颉唎)◇(媲)等字者。当知是佛顶名号也。若有【◇】(揭[口*栗]佷拏也)(是执取义)【◇】(佉陀耶)(是食义)【◇】(畔阇)(是破坏义)【◇】(诃娜)(是打义)【◇】(摩罗也)(是杀义)【◇】(钵吒也)(是扑义)如是等字义类。当知是忿怒等诸奉教者真言。可作降伏摄召用。如说啖食义者。啖食谓令诸忿怒等。吞灭一切毗那也迦之类。果如所言。诸佛则有杀众生罪。今此宗明义。所谓毗那也迦。即是一切能为障者此障皆从妄想心生。若能啖食如是重障。使心目开明。当知是名真忿怒者。以此佉字门。啖食一切众生障。则是如来所使。行如来事。余以类推之可解也。复次若真言中。有【◇】(纳么)(是归命义)【◇】(莎缚诃)(是摄取义)等字。当知是修三摩地。寂静相应真言也。或有【◇】(扇多)(是寂义)【◇】(微成陀)(是清净义)等字。当知是成满一切诸愿真言。又此扇多亦是息灾义。佛部相应。余如苏悉地等详说也。如上所说。皆是诸佛菩萨真言相。次云。若声闻所说。一一句安布者。以声闻因他得解入法性未深。不能于一言中具含众德。如说诸行无常一四句偈。要令次第安布文义无缺。乃成真言。不得以字门明义及增加名句。辟支佛虽无言说。亦能以神通力现出真言。诸有受持之者皆获义利。是中少有差别者。谓辟支佛与声闻。漏尽则同而三昧有浅深之异。能以神通利物。令其所愿皆得成就。除四大弟子之外。余声闻力所不能。又其真言唯说十二因缘寂灭之理。故云。谓三昧分异净除于业生也。经中次说真言如实相。故云。复次秘密主。此真言相。非一切诸佛所作。不令他作。亦不随喜。何以故。以是诸法法如是故。若诸如来出现。若诸如来不出。诸法法尔如是住。谓诸真言。真言法尔故者。以如来身语意毕竟等故。此真言相。声字皆常。常故不流。无有变易法尔如是。非造作所成。若可造成。即是生法。法若有生。则可破坏。四相迁流。无常无我。何得名为真实语耶。是故佛不自作。不令他作。设令有能作之人。亦不随喜。是故此真言相。若佛出兴于世。若不出世。若已说若未说若现说。法住法位性相常住。是故名必定印。众圣道同。即此大悲漫荼罗一切真言。一一真言之相。皆法尔如是。故重言之也。若如是者。则是诸真言相。毕竟寂灭不授与人。何故有时出兴有时隐没。故经复释所由云。秘密主成正等觉。一切智者一切见者。出兴于世。而自以此法。说种种道随种种乐欲。乃至种种诸趣音声。而以加持说真言道。此意言。如来自证法体。非佛自作非余天人所作。法尔常住。而以加持神力。出兴于世利益众生。今此真言门秘密身口意。即是法佛平等身口意。然亦以加持力故。出现于世利益众生也。如来无碍知见。在一切众生相续中。法尔成就无有缺减。以于此真言体相不如实觉故。名为生死中人。若能自知自见时。即名一切知者一切见者。是故如是知见。非佛自所造作。亦非他所传授也。佛坐道场证如是法已。了知一切世界。从本以来常是法界。即时生大悲心。云何众生。去佛道甚近不能自觉。故以此因缘。如来出兴于世。还用如是不思议法界。分作种种道开示种种乘。随种种乐欲心机。以种种文句方言。自在加持说真言道。虽从机感因缘生。而不动实际。虽善巧方便无所不为。然非佛所作。虽普门异说。而但以佛之知见示悟众生。若行者于此真言十喻中。妄见有为生灭更增心垢。则非如来之本意也。复次世尊。以未来世众生钝根故。迷于二谛不知即俗而真。是故殷勤指事。言秘密主。云何如来真言道。谓加持此书写文字。以世间文字语言实义。是故如来即以真言实义而加持之。若出法性外。别有世间文字者。即是妄心谬见。都无实体可求。而佛以神力加持之。是则随于颠倒。非真言也。已知所加持处。如来以何法加持耶。故佛次言秘密主。如来无量百千俱胝那庾多劫。积集修行真实谛语。四圣谛四念处。四神足十如来力。六波罗蜜七菩提宝。四梵住十八佛不共法。秘密主以要言之。诸如来一切智智。一切如来自福智力。自愿智力。一切法界加持力。随顺众生。如其种类开示真言教法者。谓以如来无量阿僧祇劫所集功德。而作遍一切处普门加持。是故随一一言名成立中。皆如因陀罗宗。一切义利无不成就。又此一一功德。即同真言之相。法性自尔非造作所成。今且约阿字一言以辨其义。如行者自证心时。了知世出世间因果本不生故。无苦集灭道而有一实谛。见此一实谛已。必定师子吼。广为众生说之。是名积集修行真实谛语。又知八倒本不生故。成如来念处。知四如意足本不生故。成法性神通。知是处非处智等本不生故。成佛自然智力。知六蔽本不生故。到于六度彼岸。知七菩提分本不生故。成七种无师觉宝。知四梵住本不生故。成无缘慈悲喜舍。知十八种法本不生故。是故出过心量不与一切众生共。乃至种种法门。当自在说之。复次如此经初品中义。若了知唯蕴无我。乃至证寂然界时。当约我人众生寿者本不生故。明种种法门。以五喻观察性空时。当约诸蕴本不生。故明种种法门。观察蕴阿赖耶。乃至觉心前后际不可得时。当约心之影像本不生。故明种种法门。极无自性心生时。当约净菩提心本不生。故明种种法门。乃至如来地。当约大悲胎藏漫荼罗究竟不生义明种种法门。如阿字不生门者。迦字无作门等皆应广说。如一一字者。乃至一一名一一成立皆应广说。复次世尊于法自在。或以一字摄菩提心等种种一法门。或以二字摄止观等种种二法门。或以三字摄三空等种种三法门也。或以四字摄念处等种种四法门。或以五字摄根力等种种五法门。或以六字摄六度等种种六法门。或以七字摄七菩提宝等种种七法门。或以八字摄八直道等种种八法门。或以九字摄九定等种种九法门。或以十字摄十力等种种十法门。乃至以无量字摄无量法门。诸名句等亦复如是。若就真言通。相如行者持一阿字门时。随彼性欲机缘。或悟四念处或悟四神通等。各各不同。然随解了一法门时。即具诸余法门。种种法宝不求自至。若就别相。如以四字摄四念处门。若如法修行时。虽自昔未曾正观身受心法。自然悟念处门。而入法界诸法门。常途名义如智度等广说也。复次如来以种种法门。不可遍举故。复举要言之。初云一切智智者。即是总举十方三世如来一切金刚智印。以此同共加持。则无所不周。又一切如来本行菩萨道时。所集无边福聚。发生无尽大愿。至萨婆若中究竟圆满。是故皆得智名。言以如是福愿智力。及一切法界本性加持力。随顺世间。如其种类而作加持。是故于一切众生种种身语意。皆可开示真言教法

经云。秘密主云何真言法教者。即谓阿字门等。是真言教相。虽相不异体体不异相。相非造作修成不可示人。而能不离解脱现作声字。一一声字即是入法界门故。得名为真言法教也。至论真言法教。应遍一切随方诸趣名言。但以如来出世之迹始于天竺。传法者且约梵文。作一途明义耳

经云。谓阿字门一切诸法本不生故者。阿字是一切法教之本。凡最初开口之音皆有阿声。若离阿声则无一切言说。故为众声之母。凡三界语言皆依于名。而名依于字。故悉昙阿字。亦为众字之母。当知阿字门真实义。亦复如是。遍于一切法义之中也。所以者何。以一切法无不从众缘生。从缘生者。悉皆有始有本。今观此能生之缘。亦复从众因缘生。展转从缘谁为其本。如是观察时则知本不生际。是万法之本。犹如闻一切语言时即是闻阿声。如是见一切法生时。即是见本不生际。若见本不生际者。即是如实知自心。如实知自心即是一切智智。故毗卢遮那。唯以此一字为真言也。而世间凡夫。不观诸法本源故。妄见有生。所以随生死流不能自出。如彼无智画师自运众彩作可畏夜叉之形。成已还自观之。心生怖畏顿躄于地。众生亦复如是。自运诸法本源画作三界。而还自没其中。自心炽然备受诸苦。如来有智画师既了知己。即能自在成立大悲漫荼罗。由是而言。所谓甚深秘藏者。众生自秘之耳。非佛有隐也。迦字门云一切诸法离作业故者。梵音迦哩耶是作业义。如诸外道计有作者使作者等。诸部论师。亦说有作有作者。有所用作法。三事和合故有果报。若因般若方便。谓有决定即堕无因。若堕无因一切法即无因果。能生法名因所生法名果。是二法无故。作及作者所用作法。罪福果报及涅槃道。一切皆无。复次作作者相因待生。若定有作法。则当定有作者。皆是不异外道论议。如中论观作作者品中广说。今正观察作作者等。悉从众缘生。即入本不生际。本不生际者。有佛无佛法尔如是。谁造作之首。是故若见迦字。则知一切诸法皆是造作所成。名为自相。若是作法者。当知毕竟无作。名为真实义也。佉字门一切诸法等虚空不可得故者。梵音佉字是虚空义。世间共许虚空是无生无作法。若一切法本不生离诸作。是毕竟如虚空相。今此空相亦复不可得也。何以故。如世间无色处名虚空相。色是作法无常。若色未生。色未生则无灭。尔时无虚空相。因色故有无色处。无色处名空。中论观六种品中广说。此中义亦如是。若色本来不生。何者名为无色处。无色处不可说。则无虚空定相。复次诸法如虚空相。是为不诳相涅槃。如经说五阴灭更不生余五阴。是涅槃义。若五阴本来不生。今何所灭而名涅槃耶。是故如虚空相亦不可得。是佉字门真实义。哦字门一切诸法一切行不可得故者。梵云哦哆也(二合)是名为行。行谓去来进退不住之义。今从阿字门展转释之。以诸法本不生故无作。无作故则无所待对可说为空。空者即是不行处。不行处尚不可得。况行处耶。中论观去来品明行止义。以相续故名行。如从谷子生牙茎叶。及无明缘诸行等。以断故名止。如谷子灭故牙茎灭。无明灭故诸行等灭。若法已行则无行。已行故未行亦无行。未有行法。故行时亦无行。不离已行未行故。以如是等种种门观察。毕竟无行。无行故则无所止。以无行无止故。则是无有往来诸趣者。亦无住涅槃者。复次若人。不动本处即是所诣处者。当知是人无行无到。故云一切行不可得也。伽字门一切诸法一合不可得故者。梵云伽那是密合义。如众微相合成一细尘。诸蕴相合而成一身等。中论观合品。诸论师言。以见可见见者三事故。而有所见。当知有合闻可闻闻者。乃至染可染染者等诸烦恼亦然。答者云。凡物皆以异故有合。而今一切法异相不可得。是故无合。如彼广说。以字门展转相释故。且以行义明之。凡有所行。当知必有行可行行者三事相合。今一切法。本不生故则无所行。若无所行。云何行可行行者得合耶。复次若诸法各各异相。终无合时。若至本不生际。则无异相亦不可合。是故一切法毕竟无合也。遮字门一切诸法离一切迁变故。梵云遮庾(二合)底即是迁变义。又梵音遮唎耶是诸行义。如见遮时。即知诸行迁变不住。中论观行品云。诸行名五阴。以从诸行生故。是五阴皆虚妄无有定相。如婴儿时色乃至老年时色。中间念念不住。分别决定性不可得。性名决定有。不可变异如。真金不变。今诸法虽生不住自性。是故当知无性。如彼广说。若无性者即是本初不生。本初不生者即是如来之身。常恒安住无有变易。故云离迁变也。复次若一切法是和合所成。则有迁变。今诸法无生无作乃至无所行故。则无和合。无和合故则离一切迁变。凡诸字门。皆当逆顺旋转相释使无挂碍。今且约次第相承耳。车字门一切诸法影像不可得者。梵音车(上声)野是影义。如人影像皆依自身。如是三界万法唯是识心。因缘变似众境。是事如密严经广说。乃至修瑜伽者有种种不思议事。或能面见十方诸佛普现色身。亦皆是心之影像。以心本不生故。当知影像亦无所生。无所生故乃至心无迁变故。影像亦无迁变。所以然者。如影自无定性行止随身。心影亦尔。以心动作戏论。无一念住时故。世间万用亦复为之流转。若了心如实相时。影亦如实相。故不可得也。惹字门一切诸法生不可得故者。梵云惹哆也是生义。如泥团轮绳陶师等和合故。有瓶生。缕绳机纻织师等和合故。有叠生。持地筑基梁椓泥草人功等和合故。有舍生。酪酪器钻人功等和合故。有苏生。种子地水火风虚空时节等和合故。有牙生。内法因缘亦如是。无明行等。各各生因而复生。是故若见惹字门。即知一切诸法无不从缘生。如说偈言。众因缘生法是即无自性。若无自性者云何有是法。是故生不可得也。外道论师。说种种邪因缘或无因缘生一切法。佛法中人。亦有失般若方便故。取着因缘生灭相。如中论广破。复次阿字门是诸法本性不生。惹字门以十喻观生。虽从缘有而不可得。若生毕竟不可得。则不异无生际。又十喻是心之影像。不出法界。故生亦不出无生际也。社字门一切诸法战敌不可得故者。梵云社么攞是战敌义。若见社字。则知一切诸法皆有战敌。如世间善不善法。逆生死流顺生死流法。布施悭贪。持戒乃至智慧无明等。更相待对胜负无常。乃至如来出世。以一切智力破魔军众。亦名为战。然一切法中。义不成故。智慧烦恼竟为属谁。而言毗婆舍那能破烦恼耶。若言明生时暗灭故名为破者。为已生故破。未生故破耶。已生则无暗。更何所破。未生则自无有体。又何能破。若生时名为半已生半未生。故明暗毕竟不相及。又一切法本不生。乃至无影像故。便同一相不出于如。云何佛界如与魔界如战。故佛坐道场时。但了知诸法无对。而世间谈议自立战胜之名耳。吒字门一切诸法慢不可得故者。梵音吒迦啰是慢义。谓见彼法卑下此法高胜。如三界六趣种种优劣不同。所起慢心无量差别。略说有七种相。如毗昙中广明。乃至求三乘人。犹有上地下地不平等见。今观诸法无生乃至无待对故。则知阿耨多罗三藐三菩提。于法平等无有高下。是故如来亦名一切金刚菩萨。亦名四果圣人。亦名凡夫外道。亦名种种恶趣众生。亦名五逆邪见人。大悲漫荼罗正表此义也。咤字门一切诸法长养不可得故者。梵音毗咤钵那是长养义。如世间种子为因五大。时节为缘。渐次滋长得成果实。内法亦尔。于业田中下识种子。无明所覆爱水所润。而得滋长。如稻芋经中广明。今此经违世顺世八心。相续增长亦有因缘。乃至净菩提心。以五字门为缘生大悲根。佛娑罗树增长弥布满于法界。然一切法。即由此五字门。本不生离言说自性净无因缘如虚空相故。长养不可得。复次从阿迦字以来展转相释。乃至诸法毕竟平等无有高下。以无高下故。当知即无有增长也。拏字门一切诸法怨对不可得故者。梵音云拏么啰是怨对义。如世间仇仇更相报复故名为对。又前云战敌是彼此相加。此中怨对是避仇之义。梵音各自不同。毗尼中。佛说以怨报怨怨终不绝。唯有无怨怨乃息耳。又说女人是梵行者怨。无量义经。亦说生死怨敌自然散坏。证无生忍半佛国宝。是故行者见拏字门时。则知一切法悉有怨对。名为了知字相。又以诸法本不生。乃至长养不可得故。当知怨对亦复本来不生。乃至无有长养。是故如来毕竟无有怨对。名为字门真实义也。荼字门一切诸法执持不可得故。梵音[王*易]迦是执持义。以荼字上安置点。是故转声为[王*易]。其体则同。又云檗哩何者。亦是此别名

经云。鬼魅所著。或云非人所持。智度云着襄。皆是檗里何鬼所作。以着人不相舍离故。以为名。其日月五星等。亦以终始相随故。梵语名檗哩何。翻为九执。正相会一处。天竺历名正着时。此执持义。与陀罗不同也。见此荼字门。即知一切众生从无始来。为四魔所著不能舍离。是名字相。今以阿字等种种门。展转观一切法。皆不可得故。当知一切法无有怨对。以怨对本不生故。终不以平等法界执着平等法界。故云一切诸法执持不可得也。多字门一切诸法如如不可得故者。梵云哆他多是如如义。语势中兼有得声。证得如如即是解脱义。如谓诸法实相。种种不如实见戏论皆灭。常如本性不可破坏。若见多字门。即知一切诸法皆是如如相。名为字相。然有一类外道。计有如如之性。若知见此有名为解脱。虽作此说。只是于我见上转作异名。龙树以为声闻经中言法住者。亦是诸法如如义。以所入未深故。而生灭度之想谓证涅槃。然生死涅槃是相待法。若知生死从本际已来。常自如涅槃相。复待谁故说为涅槃。是故一切法。毕竟非实非虚非如非异。中论亦云。涅槃之实际及与世间际。如是二际者厘毛无别。以无差别故。一切法无怨对。无怨对故无执持。无执持故亦无如如解脱也。他字门一切诸法住处不可得故者。梵音萨他娜是住处义。亦是住义。如人从此住处升上某处。其所依处所说名为住。诸贤圣地位亦如是。约诸行道人心迹所依所止息处故。说种种名。若见他字时。即知一切诸法无不待缘成故。当知悉有所依住处。是为字相。然诸法本来不生。乃至如如解脱亦不可得。则无去无来无行无住。如是寂灭相中。当有何次位耶。复次入多字门时。了知诸法皆空故。不住生死中。即此如如亦不可得故。不住涅槃中。尔时行处尽息诸位皆尽。遍一切处的无所依。是名以不住法住于如来大住也。娜字门一切诸法施不可得故者。梵云檀那是舍施义。若见娜字。即知一切诸法皆是可舍相。所以者何。以一切法离合在缘。无有坚住。若于中执着生爱。必为所焚。乃至十地诸菩萨。于自地所生净妙功德。未到舍彼岸。故犹有不思议退失。不名第一安乐处。今观诸法不生故。施者施处及所施物。皆悉本来不生。乃至一切法无住处。无住处故。即此三事亦无住处。是故佛坐道场。都无所得亦无所舍。于虚空藏中无所蕴积。而普门流出遍施群生。是名见檀实相。亦名具足檀波罗蜜。又如来秘宝之藏。皆是法然。所谓不可授人。若施他时。还就众生心室中开出之耳。是故经云。一切诸法施不可得。名为字门真实义也。驮字门一切诸法法界不可得故者。梵云达摩驮都。名为法界。界是体义分义。佛之舍利亦名如来驮都。言是如来身分也。若见驮字门。即知一切诸法悉皆有体。谓以法界为体。所以者何。若离诸法实相。则一切法体义不成故。夫法界者。即是心界。以心界本不生故。当知法界亦本不生。乃至心界无得无舍故。当知法界亦复无得无舍。舍尚自无。无法可舍。况可得乎。若法界是可得相者。即是从众因缘生。若众因缘生。当知自无本体。何况为诸法体。故法界者。唯是自证常心。无别法也。复次如来大施者。所谓大悲漫荼罗。法界者。即是普门实相。如是实相。不可以加持神力示人。是故无法可得。波字门一切诸法第一义谛不可得故者。梵云波罗么他。翻为第一义。或云胜义。萨底也此翻为谛。谛义于娑字门说之。今此波字门正明第一义相。龙树云第一义名诸法实相。不破不坏故。复次诸法中第一。名为涅槃。如阿毗昙云。云何无上法。谓智缘尽。智缘尽即是涅槃。若见波字。即知一切法不离第一义。第一义不离诸法实相。是为字相。若字门真实义者。第一义亦不可得。何以故。无爱无著故。智论又云。以众生着涅槃音声。而作戏论若有若无。以破着故说涅槃空。是名第一义空。不破圣人心中所得。以圣人于一切法中不取相故。复次一切法。皆入平等法界则无高下。岂欲令无生法中有胜劣相耶。是故第一义不可得也。颇字门一切诸法不坚如聚沫故者。梵云沛奴译云聚沫。如大水中波涛鼓怒。相激而成聚沫有种种相生。乃至固结相持遂有坚固。然从粗至细一一观察。只是缘。复从缘不可撮摩。都无实性。至其本际。则举体是水都无所生。今世间种种五阴。亦复如是。今摄末归本去丈就尺观之。乃至如丝忽之际个然微动。皆是展转从缘。若是从众缘生则无自性。若无自性。当知是生即不生至。至于本不生际。但是心性海耳。而随六趣妄情。遂有世界之目。夫心性海者。即是法界。法界者即是胜义涅槃。若能如是见时。虽复洪波震荡作种种普现色身。亦不坏澄清之性也。么字门一切诸法缚不可得故者。梵云满驮此翻为缚。如人为缧绁所拘不可得动转。是缚义。若以方便解是结时。则名解脱。若离身绳。无别缚解法。如天帝释。以微细缚缚阿修罗王。置忉利天上。起念欲还时。五缚已在其身。若息念时缚自除解。若波旬罥网。复过于此百千倍数。何况业烦恼无为缚等耶。以要言之。若离诸因缘不堕诸法数者。乃谓无缚。是为字义。中论云。离五阴别有众生者。则应以阴缚众生。而实离五阴无众生。若离五阴别有烦恼者。别应以烦恼缚五阴。而实离五阴无别烦恼。以如是等种种因缘。当知无缚。无缚则无解。无缚解故涅槃即生死。生死即涅槃。如观缚解品中广说。复次若诸法本来不生乃至如聚沫者。是中谁为能解谁为所缚。是故诸缚不可得也。婆字门一切诸法一切有不可得故者。梵云婆嚩此翻为有。有谓三有乃至二十五有等。若见婆字。即知一切诸法皆悉有因缘。众缘合故说名为有。无决定性。所以者何。若法定有有相。则终无无相。是即为常。如说三世者。未来中有法相。是法来至现在转入过去。不舍本相。则堕常见。若说定有无。是无必先有今无。是则为断灭见。因是二见故。远离佛法。如中论破有无中广明。今观诸有。从缘即是本不生义以本不生故。无作无行乃至无缚无脱。是故婆字门。以从缘有故具足一切字门。若具一切字门。即是三昧王三昧。能破廿五有释迦牟尼。由此义故名为破有法王也。野字门一切诸法一切乘不可得故者。梵云衍那此翻为乘。亦名为道。如人乘驭舟车。则能任重致远有所至到。若见野字门。则知一切众生以种种因缘。趣向生死果报及趣涅槃者。各有所乘。亦知无量诸乘悉是佛乘。名为字相。今观诸法本不生故。即是无行无住不动不退。是中谁为乘者当乘何法耶。复次是乘。从三有中出至萨婆若。五百由旬无非实处者。欲行何道往诣何处乎。是故一切乘不可得。乃名摩诃衍道。啰字门一切诸法离一切尘染故者。梵云啰逝是尘染义。尘是妄情所行处。故说眼等六情行色等六尘。若见啰字门。则知一切可见闻触知法皆是尘相。犹如净衣为尘垢所染。亦如游尘纷动。使太虚昏浊日月不明。是为字相。中论以种种门谛求见法。无有见者。若无见者。谁能用见法分别外色。见可见见法无故。识触受爱四法皆无。以无爱故。十二因缘分亦无。是故眼见色时即是涅槃相。余尘例尔。复次以阿字门。展转观察诸尘。以其本不生故。无造作故。乃至无所乘法及乘者故。当知所可见闻触知法。悉是净法界。岂以净法界。染污如来六根耶。鸯掘摩罗经。以佛常眼具足无灭。明见常色。乃至意法亦如是。是啰字门真实义也。逻字门一切诸法一切相不可得故者。梵云逻吃洒此翻为相。有人言性相无有差别。如说火性即是热相。或言少有差别。性言其体。相言可识。如释子受持禁戒。是其性。剃发割截染衣。是其相。若见逻字门。即知一切法皆悉有相。相复二种。一者总相。谓无常苦空无我相。别谓诸法虽无常无我。而有各各相。如地坚水湿火热风动等。舍为施相。不悔不恼为持戒相。心不变异为忍相。发勤为精进相。摄心为禅相。无所著为慧相。能成事为方便相。织作生死为世间相。无织为涅槃相等。今观有为无为法体性皆空。此相与谁为相耶。如中论三相品及十二门中广说。复次净法界中。百六十心等种种诸相本不生。则无造作。无造作故乃至毕竟无尘。无尘故离一切相。以离一切相故。名为诸佛自证三菩提也。嚩字门一切诸法语言道断故者。梵音嚩劫跛名为语言。若见嚩字时。即知一切诸法不离语言地。以是诸法无不有因有缘故。若法本来不生。则是离诸因缘。是故语言道断。复次若法是作相。则可宣说。无作则语言道断。若虚空相是有相者。则可宣说。以诸法如虚空相亦复无相。是故语言道断。若法有行有迁变有影像。则可宣说。若无行无迁变无影像。则语言道断。乃至诸法若是有相者。则可宣说。今一切法离一切相。故不可表示不可授人。是故语言道断。复次无相亦无定相。当知一切法即相无相。即非相非无相。如彼三目不可思议。是故语言道断。余法门例此可知也。奢字门一切诸法本性寂故者。梵云扇底此翻为寂。如世间凡夫。获少分恬泊之心止息諠动。亦名为寂。乃至二乘人等。永断诸行轮回得涅槃证。亦名为寂。然非本性常寂。所以然者。诸法从本来常自寂灭相。三界六道何者非是涅槃。无漏智生时。复与凡夫何异。而今独于其中作灭度想。岂非颠倒耶。又若诸法本性寂者。于四十二地中。何者非是如来地。何者非是凡夫地。若弥勒菩萨以本性寂故。得一生记者。一切众生皆亦应得记。若一切众生于本性寂中。不妨修学凡夫事者。弥勒菩萨亦应修学凡夫事。而今作差别想。岂非戏论耶。若入奢字门时。则知是法平等无有高下。常无所动而无所不为。故云解脱之中多所容受。大般涅槃能建大义。皆以此也。沙字门一切诸法性钝故者。若梵本存质。当云性同于顽。顽谓犹如木石无所识知无触受之义。所云同者是兴喻之言。非一向即同于彼也。又大品云。般若无知自性钝故。即与此字门义合。故饰文者存古译之辞耳。夫自性钝者。即是极无分别心。不愚不智不慧。无识无智无妄无觉。乃至一切诸法不能动摇。但是一纯固金刚地耳。所以然者。如世间人以取舍不妄故。尚智慧而弃愚痴。尊涅槃而贱生死。而今一概本不生。乃至一概本性寂。则谁利谁钝耶。如彼金刚利刃。以对不坚物故。以偏用一边故。则名为利。若令所向之处悉是金刚。举体皆圆不可偏用。则利相同归于钝矣。娑字门一切诸法一切谛不可得故者。梵云萨跢也。此翻为谛。谛谓如诸法真相而知不倒不谬。如说日可令冷月可令热。佛说苦谛不可令异。集真是因更无异因。因灭则果灭。灭苦之道即是真道更无余道。复次涅槃云。解苦无苦是故无苦。而有真谛余三亦尔。乃至分别四谛。有无量相及一实谛。如圣行品中说之。是为字门之相。然一切法本不生。乃至毕竟无相故语言断故。本性寂故自性钝故。当知无见无断无证无修。如是见断证修。悉是不思议法界。亦空亦假亦中。不实不妄无定相可示。故云谛不可得。中论四谛品中。亦广辨其义也。诃字门一切诸法因不可得故者。梵云系怛嚩即是因义。因有六种。及因缘义中因有五种。如阿毗昙广说。若见诃字门。即知一切诸法无不从因缘生。是为字相。以诸法展转待因成故。当知最后无依。故说无住为诸法本。所以然者。如中论。以种种门观诸法因缘。悉不生故。当知万法唯心。心之实相即是一切种智。即是诸佛法界。法界即是诸法之体。不得为因也。以是言之。因亦是法界。缘亦是法界。因缘所生法亦是法界。前说阿字门。从本归末毕竟到如是处。今亦诃字门。亦从末归本毕竟到如是处。阿字从本不生生一切法。今亦以无因待为诸法因。终始同归。则中间旨趣皆可知矣。复次此中旋陀罗尼字轮相者。谓以一字释一切字义。以一切字释一字义。以一字义成立一切字义。以一切字义成立一字义。以一字义破一切字义。以一切字义破一字义。如一字一切字者。逆顺旋转例此可知。云何以一字释一切字。如释迦字时。但以种种因缘观本不生。即见无所作义。乃至释诃字时。亦以种种因缘观本不生。即见无因义。云何以一切字释一字。如释阿字门时。以种种因缘观无造作。即见本不生义。乃至以种种因缘观诸法无因。即见本不生义。余字例尔。当广说之。云何一切字成立一字。谓一切法本不生。以无作故。如虚空无相故。无行故无合故乃至无因故。云何一字成一切字。谓一切法无作。以其本不生故。乃至一切法无因。以其本不生故。云何以一切字破一字。如人执诸法有本有生。应破彼言。若诸法离于造作而云有生者。是义不然。乃至若诸法因不可得而云有生者。是义不然。云何一字破一切字。如人执有造作。应破彼言。若诸法本不生义已成立而云有作。是义不然。乃至执有因者。亦破彼言。若诸法本不生义已成立而云有因。是义不然。云何逆顺旋转。所谓若法本来不生则无造作。若无造作。则如虚空无相。若如虚空无相。即无有行。若无所行。则无有合。若无有合则无迁变。乃至若无因者当知法本不生。是名为顺。若法无因。则谛不可得。若谛不可得则自性钝。若是自性钝者当知本性寂。若本寂者当知无相。乃至若本不生者当知无因。如是八种义门。自在旋转说之。复次今言一切法者。是总相耳。若依摩诃般若经。色乃至一切种智。一一别异说之。义则无量。又一一门。当约真言住心品中浅深之相。次第分别。以字门转故义亦不同。以是义故。能出生百千万亿旋陀罗尼也。复次如来一切言说。无非真言故。当以如是字义。普入一切修多罗。是故智度论云。菩萨若一切语中闻阿字。即时随义。知所谓一切法从初来不生相(阿提秦言初。阿耨波陀秦言不生)若闻罗字。即随义知一切法离相(罗字秦言垢)若闻波字。即时知一切法入第一义中(波罗末陀秦言第一义)若闻遮字。即时知一切行皆非行(遮利夜秦言行)若闻那字。即知一切法不得不失不来不去(那秦言不)。如彼论四念处品中广说。复次一切名言中有阿声者。悉入阿字门。有迦声者悉入迦字门。乃至有诃声者悉入诃字门。是故一字门中具无量义。非从诃字门中但有无因义也。余字门当知例尔。且如娑哆也是谛义。是故经云。娑字门一切诸法谛不可得。又娑哆是着义。是故供养法中云。娑字门一切诸法无染着。又如婆嚩是有义。是故经云。婆字门一切诸法有不可得。又婆嚩娜是观义。是故供养法中云。婆字门一切法离诸观。余皆放此。所以大品经。及花严入法界品。皆说四十二字门。涅槃文字品。文殊所问经。大集陀罗尼自在王品。各释悉昙字母。与此经所说其义或同。若得此意。则诸经冷然悬会。无所违妨也。复次一一字门皆言不可得者。为明中道义故。今且寄车字门说之。如观镜中面像。以本质为因净镜为缘。有影复现为见。为是所生之法。妍蚩之相现前不谬。故名为有。以种种方便推求都不可得。是名为空。此有此空皆不出镜体。即一名中。三相不同而同不异而异。是故世间论者不能思议。今真言门亦尔。以观心为因三密为缘。普门海会现前不谬。故名为有。以种种门推求都不可得。是名为空。此有此空皆不出法界。故说为中。三谛不同而同不异而异。一切方便乘人不能思议。余法门例皆如此。不可遍举也

经云。秘密主仰壤儜曩莽。于一切三昧。自在速能成办诸事。所为义利皆悉成就者。于迦遮吒多波五类声中。复各有五字。其第一至第四字皆是慧门。已如前说。第五字皆是证门。今合说之。梵书以此五字皆同圆点。且如迦佉哦伽四字。增加至第十一声。皆于首上安点。若欲除去此点。而于次后字上累加仰字等。其字即与有点不殊。又梵字十二声中。第一是本体故。即次第二字是行。第三以去以诸画增加者。皆名三昧。第十一其上安点是证。第十二傍置二点是般涅槃。若此仰字。能遍智慧三昧声故。当知即是大空义。是故别说。不与前字相合论也。涅槃经此五字亦具明字义。今毗卢遮那宗。寄此五字以明大空。大空是证处无法可说。故但以圆点表之。又此圆点虽自体无门。而遍一切法门。如虚空远离众相而含万像。是故一切字门若加空点者。具自在之用。悉能成办诸事也。且如阿字门无生妙慧。一切众生等共有之。但以不自证知故。如贫女宝藏不能得其势力。发行时如方便开发。入证时如宝藏现前。尔时随意受用所求必获。故云加此空点者。诸有义利皆得成就也。次世尊说偈中。真言三昧门。圆满一切愿者。具存梵本应于真言之下更加道字。加行人一缘住于阿字。即名阿字三昧。此阿字三昧。即是开心明道门。余一切字亦如是。一切愿者。梵云萨嚩奢。是心所祈愿之愿。谓诸众生修此三昧门者。一切志求皆得圆满。此愿圆满时。即是诸如来不思议果也。常住之果无师之慧。犹能给与众生。何况世间悉地之愿耶。复次如来一一三昧门声字实相。有佛无佛法如是故。即是故不流即是如来本地法身。为欲以此法身遍施众生故。还以自在神力。加持如是法尔声字。故此声字。是诸佛加持之身。此加持之身。即能普作随类之身。无所不在。当知加持声字亦复如是。是故行者。但一心谛缘观此声字。自当见佛加持身。若见加持身即见本地法身。若见本地法身时。即是行者自身。故此一一门。即是如来不思议果。不从别处来也。具足众胜愿。真言决定义者。具存梵本。当云具一切所有胜愿。真言决定实义。此中胜愿。梵云嚩嚧。是具足种种功德。所谓三昧总持力无畏等。所愿已满所求悉备之义。与前愿字梵音各殊。所云决定者。且如阿字门。若声若字举体不生。声字之义即全举体不生。若证时。还只证此不生。中间更无间杂亦无异路。若见此真实义时。假使十方诸佛同时现前。说种种相似波罗蜜。欲令改易其心。然亦不生疑惑。故云决也。复次具足众胜愿者。是如来十世界微尘数内证功德。以决定故。一一皆成金刚印。从此自证身复起加持身故。云超越于三世。无垢同虚空者。即是净无垢不思议心地也。以大方便。于此地上画作普门漫荼罗。故经次云。住不思议心。起作诸事业。梵本具云心地。以偈中五字成句不可累书。然地即是心体。故但云住不思议心也。真言三昧门中。虽有如是不思议果德。堪能周给一国等赐众生。若诸众生。不能生难遭想供养修行。譬如王膳盈前无心饮啖则诸佛其若云何。故经次云。若到修行地。授不思议果。此修行地。即是净菩提心初法明门。例如声闻见谛以后复入修道位也。此菩萨于百字明门中。各见莲花胎藏漫荼罗世界海。其庄严相皆悉不同。先从佉字门大空轮中。以诃字门起大风轮。次于其上以嚩字门起香水海。次于其上以阿字门起金刚地金刚轮山。余如花严经说。于此百莲花藏一一世界菩提漫荼罗。各有十世界诸菩萨金刚等。以为眷属。此瑜伽者能不起于座。悉至如是诸佛会中。亦能次第询求诸善知识。故云初地菩萨化满百佛国也。非起见之而已。亦能以此百莲花藏转作自身。至于初地牙茎花庖等十心满时。一明门中开出十解脱门成千世界。皆是随分蒙授不思议果。至十一地畔。于虚空云海明门中。一一皆见莲花藏庄严世界性相形类展转不同。用作自身自在无碍。是名不思议果满也。次有二偈。劝信印成故云。是第一真实。诸佛所开示。此中开示。即是佛之知见。与法花义同。次半偈云。若知此法教者。当获诸悉地。是引诸佛道同劝信世谛。若真言行者。明解此法教中次第方便。以必定信如说修行。当得成就一切悉地。若为此说不然。是十方三世佛。有违负本誓欺诳众生罪也。次一偈劝住真谛。然此悉昙字母。幼童皆亦诵持。至于护摩供养等。韦陀世仙亦皆共作。而今此真言门。所以独成秘密者。以真实义所加持耳。若但口诵真言而不思惟其义。只可成世间义利。岂得成金刚体性乎。故偈云。最胜真实声。真言真言相行者谛思惟。得成不坏句。此声即是真言门。语密之体。如阿声中第一真实义。所谓本不生也。初云真言。梵本以多声呼之即是。即是总指百字门世谛字轮之相。次云真言相者。是此真言实相也。即此真言实相。由谛思惟故。一一皆入莲花台。句是迹息之处也

经云。尔时执金刚秘密主。白佛言。希有世尊。佛说不思议真言相道法者。如声闻法。解脱之中无有文字。而维摩诘。不离文字说解脱相。故名不思议解脱。今此字轮亦尔。即以无相法身。作种种声字。种种声字作无相法身。故名不可思议真言相也。不共一切声闻缘觉。亦非普为一切众生者。此经是法王秘宝。不妄示卑贱之人。如释迦出世四十余年。因舍利弗等殷勤三请。方为略说妙法莲花义。今此本地之身。又是妙法莲花寂深秘处。故寿量品云。常在灵鹫山。及余诸住处。乃至我净土不毁。而众见烧尽。即此宗瑜伽之意耳。又因补处菩萨殷勤三请。方为说之。苟无顿悟之机。则不入其手。故不普为于一切众生。亦是领前偈中。到修行地方授不思议果。次云领解劝信印成二偈。故云。若信此真言道者。诸功德法皆当满足。若满足时。即是具足众胜愿也。已上广说真言支分竟。执金刚复承蹑上文。请佛次说入漫荼罗所须次第。世尊说偈中。先答奉食香花等及与众宝瓶二句。总名供养支分也。就诸供养具中。先明献花。凡所奉献。各随诸尊性类及漫荼罗方位等。一一善分别之。当令色香味触适悦人心。其水陆不祥诸花。但可作折伏用耳。白黄赤三色中。如来部类当用白色。莲花眷属以黄色。金刚眷属以赤色。复次当如漫荼罗方位。圆坛者以白。方坛者以黄。三角坛者以赤。复次诸佛用白。诸菩萨以黄。诸世天以赤。其余香等亦当准傍此意。兼采苏悉地瞿醯等文用之。不可备载也。钵头摩是红莲花。凡青赤白莲等水生诸花。皆可通献诸尊也。龙花奔那伽者。此奔那伽是龙树花。弥勒世尊于此树下成佛。其直云龙花者。是龙中所尚之花。西方颇有其种。其计萨啰花末利花。得檗罗花瞻卜花。无忧花底罗剑花。钵吒罗花娑罗树花。皆是天竺所有。此方不可具识

经云。是等鲜妙花者。梵本兼有或声。谓此等诸花皆可通用。故举以为例。然或余方所有彼方所无。但使人心所好世间以为吉祥者。皆可供养。当一一存意善分别之。采集以为鬘者。谓错杂庄严。或缀或结。以行人殷净淳厚心故。则令诸尊欢喜护念也。次明涂香。其旃檀青木郁金妒路婆草。是西方苜蓿香。与此间苜蓿香稍异也。及余妙涂香。如沉水甘松丁香桂心西方豆蔻香附子等。如苏悉地瞿醯中说。又云。其涂香中勿用众生身分及与紫矿并虫食等。当取净好者以水研之。若献佛。当用新好郁金或黑沉香。和以龙脑。莲花眷属当以白檀。金刚眷属亦当以白檀。自余诸尊随意而合用之。随所合香皆置龙脑也。次明焚香。当用沉水香松香嚩蓝香龙脑香。白檀香西方名为么啰庾。是山名。即智论所云除摩梨山。更无出旃檀处是也。白胶香是娑罗树汁。室利嚩塞迦香者似此方薰陆香。室利是具德吉祥义。言此香乃至天神皆悉爱乐。故以为称也。及余焚香类。芬馥世称美者。亦如上说。瞿醯云。烧香用白檀沉水相和。供养佛类。其树汁香。供养莲花类。黑沈及安悉供养金刚类。或依彼法作香。普遍和合以献诸尊。应当随法教者。谓以真言密印去垢加持等。如供养次第中说。自余涂香及花等。例此可知。次云依教献诸食者。如经大本中。诸食供等各有修治方便。至于深密之意。一一与法门相应。此方既不具。但依苏悉地等。如法造作结护加持。即名依教也。乳糜者。西方粥有多种。或以乌麻汁。或以诸豆并诸药味。如十诵药法等文广明。然最以乳糜为上。凡献食时。当更加以苏沙糖等。令色味兼具而先奉之也。又西方饭有多种。亦以酪饭为上。献此食时。应配以沙糖盐姜诸味。又当奉羹。依彼方造食之法。或随国俗所用也。欢喜丸。应以苏煮诸饼。糅以众味及三种辛药等令种种庄严。漫荼迦是此方薄饼。其叶饼是天竺饼法。以糖蜜诸味和面苏油煮之至为甘美。沙糖饼者。此沙糖名为蹇荼。状如益洲所出者。而色甚鲜白。触之便碎用此和水。先以面作饼。数渍其中。然后食之。净妙谓务令精洁。使色香兼备也。布利迦译云着[飢-几+監]饼。以种种上味和合。为鉴作之。间穴饼有二种。或刺为孔穴。或状如乱丝重重间穴。加以众味也。末涂失啰饼。亦着[飢-几+監]。兼以糖蜜涂之。媲诺迦饼。用起面作之着鉴。以苏油煮。状如水上浮泡甚可爱也。无忧是卷缘沙糖饼。播钵吒食是不起面饱[飢-几+俞]。如是诸肴膳者。又谓随诸方国。所有上味及珍妙果。随意献之也。其白糖石蜜沙糖苏蜜。又各别置之。种种诸浆饮者。西方浆法甚多。皆杂以香药。美而愈疾。及蒲陶等诸非时浆。如毗尼所说。其食乳酪。亦用毕拨或龙脑等。如医明食法为之。大抵西方造食及饮啖先后次第。多依药术。有养性防身之功故。多尽其天年鲜夭死之患也。凡置食处。当以涂香周遍涂之置食院内遍布莲荷叶或芭蕉叶等令使周遍。无应用新净白叠或净布。极以净水浣濯以香遍涂。布食时。上首诸尊当增加之。谓中胎藏毗卢遮那。第二院观音金刚手。次院文殊等四菩萨。外院释迦牟尼及所奉本尊等。假令余位置一分者。上首诸尊当二分。或余位置二分瞿醯云。漫荼罗主当数倍加之。虽有此阶降不同。然上自诸佛下至世间鬼神。皆应等心供养。务令丰厚均等也。乃至不办者。但当供养部主。或置食内院。运心供养一切诸尊。所奉香花等例此可知也。次说奉献灯明者。香油之类甚多。谓薝卜香油苏摩那花香油等。凡作香油法。当取新花如作鬘法穿之。悬置日中承以油器。以物取油。于花上灌之。令还堕油中。又复取而灌之。如是周而复始。从日出至日入乃停。明日又取新花作之如前。令此油香气。与此花香气均等然后止也。其献食及灯明等诸器。以众宝为上。若不能办用银铜等。乃至新净瓦器亦得充事也。四方缯幡盖者。若有财力。当于一一尊所各别置之。亦以杂宝为上。若不能办。彩乃至绘画画时当用净物。不得用胶等也。若不能广造者。下至四方各置一盖。门标铃铎等。皆随力分作种种庄严。兼准约入秘密漫荼罗品中所示之相

大毗卢遮那成佛经疏卷第七大毗卢遮那成佛经疏卷第八

        沙门一行阿阇梨记

    入漫荼罗具缘品第二之余

经云。或以心供养。一切皆作之者。如世尊说。诸供养中心最为上如。前一一供物。皆当运心遍及法界。以真言秘印持之。如供养次第中广说。或观大宝树王遍覆一切世界。如花严菩提树王之相具足庄严。随一一所须受用之具。悉于中出无有穷尽。遍至一切贤圣前。广大供养并普济一切众生。如是运心已。当用虚空藏转明妃加持。自然随意成就也。次说吉祥瓶法。当用金银等宝。乃至无者。应以瓷或净瓦为之。极令圆满端正又不泄漏。如毗尼中方便观漉净水盛满其中。内五宝五谷五药于瞿。醯中说之然此。五药夫皆出五天此方不。能遍有也取如。前所说诸涂香末和水。兼置龙脑牛黄。于瓶口捽以宝花。或随方土所有名花。取其花果条叶茷好圆具者。使间错垂布令极端严。以彩缯缠颈并系花鬘涂以众香。结护作净方便。亦如供养次第中说。中胎藏当安五瓶。最中大日瓶安在花台。余置外花蕊中。凡献中胎食时。四佛四菩萨各随本座。在花台内。奉毗卢遮那者。置花台前也。若有力者。于一一尊所皆置一瓶。如不能尔。随内外方于上首诸尊处置之。其四门处各置一一瓶。四角各置一瓶。通门外别有一瓶。用降三世真言印加持之。拟出入时洒身自护。及召弟子入时亦用洒之。护摩处又别置一瓶。大略可百余瓶者也

经云。六瓶者。是最少之限。当于中胎四方各置其一。其门外一瓶必定不得。阙之若用十八瓶者。中胎置一瓶。第二院大勤勇处。莲花金刚类主。及门凡四瓶第二院四大菩萨。谓文殊等各置一。瓶外院四门四角及门外。者用之适。足所欲受灌顶者若。多各随人数令造一瓶。不得阙少也。如香水瓶者。诸阏伽器亦然。当用金银白琉璃等为垸。乃至商佉熟铜石木。或以树叶新瓦。盛众香水置诸名花。如前所置瓶处亦一一置之。又当于诸尊处各奉净衣。如前所说。上首诸尊亦准献食法倍增已。故云各奉兼服。若不能办者。但于上首诸尊处置之。或以箱箧随其所有。置在中胎院内。运心供养一切诸尊。凡献中胎供具。当置胎外一重空界中。若献无名诸尊。当置三重界缘之内。又供养时。先当奉阏伽水。次献涂香。次献花烧香饮食。后献灯明。经文先后不次也。复次若深秘释者。涂香是净义。如世间涂香。能净垢秽息除热恼。今行者以等虚空阏伽洗涤菩提心中百六十种戏论之垢。以住无为戒涂之。生死热恼除灭得清凉性。故曰涂香。所谓花者。是从慈悲生义。即此净心种子于大悲胎藏中。万行开敷庄严佛菩提树。故说为花。烧香是遍至法界义。如天树王开敷时。香气逆风顺风自然遍布。菩提香亦尔。随一一功德。即为慧火所焚。解脱风所吹。随悲愿力。自在而转普熏一切。故曰烧香。饮食是无上甘露不生不死之味。若服此果德成熟更无过上味时。即名入证。故说为食。所谓灯者。是如来光明破暗之义。言至果地时心障都尽。转无尽慧遍照众生。故说为灯若竖说者。一一地中皆具如是五义。若横说者。一一门中皆具如是五义。例如上文所明诸食。虽适口则一然。随调膳人身手。有种种滋味不同。余香花等当知例尔。若行者善能以五字门。作金刚舞戏普应众生。譬如和五味布五彩。韵五音调五药。虽性分不过五种。而千变万化巧转不穷。当知是人则解涂香三昧义。亦解花三昧烧香三昧。饮食灯明三昧义。亦解此五种陀罗尼义。以如是种种法门供具。供养心王如来。能令诸尊欢喜所求必获。若以此中意趣。反观世谛香花等。自然知彼色香性分所应用处。无量方便触物而生也

经云。如是修供养。次引应度者。以下明正作法时。加持教受支分及护摩支分。就加持教授中。凡答金刚手三问所谓云何引弟子。云何令灌顶。云何供养师。问此三句讫已。方问护摩处。今此答中先说引弟子了。即明护摩。方答所余二句。然护摩通一切法事中。非但加持弟子而已。故宜别作一种支分也。于前卷中。已明第七夜正作法时画漫荼罗位。中间别明所要支分。是以文势间断。今更承蹑前文。作次第说之。阿阇梨既画漫荼罗竟。周遍观察知已圆备。方出外如法洒净。如前运心普礼一切如来。忏悔归依自净三业。然后依供养法。结结三昧耶明等以护其身。其诸供养物。亦以无动真言去垢辟除清净。如法素具而预备之。又当被服金刚甲等使一一如法。阿阇梨言。作如来身时用如来甲。作金刚身时用金刚甲。当转换用之。又准苏悉地等。以如来肉髻圆光诸相。而自严身尤善。或可通用。或成办诸事真言作之。如是作已。然后向漫荼罗位。随其所应而坐。住于瑜伽。先用啰字门遍净其心。次复净道场地。悉除众患相同虚空。然后以诃字起大风轮。于风轮上。以嚩字起香水海。即用阿字门。起金刚地妙高山王。当知此漫荼罗。即在其上。如供养次第中方便。观作种种庄严。以虚空藏持之。次于一一漫荼罗诸尊位上。各观本种子字。从此诸字皆转作本尊身。若彼阿阇梨。观道未融恐延时节者。但于中胎莲花台上。而观阿字。字门出无量光遍照诸尊座位。尔时诸尊即现。尔时以方便。转观如是诸尊与我身无二无别。即是诸尊即在身中。阿阇梨言。若行者未住瑜伽。云何能造如是坛法。乃至初建立时。已观在身中然后图画。若深行阿阇梨。则常与如是大悲胎藏圣众共俱。亦证知即是我心。同彼十缘生句毕竟不可得也。即观本尊已。次更运心作种种宝乘。以不动真言印加持。以此奉迎众圣及净治道路。次作请召。瞿醯云。当各以本真言奉请。或以漫荼罗主真言都请诸尊。或依本教所说。当随意广略。兼用召请真言印也。又此经宗。即于本座受请。还以不来相而来至此道场。不同粗方便中有此彼之相。大众集已。当用无动明遣除障者。即示三种三昧耶而作加持。次当奉阏伽水及与敷座。而作是言。善来世尊善来世尊。以本愿力而来降赴。愿垂加持。受斯所请及与微供。大慈悲故唯垂纳受。时阿阇梨欲作金刚事故。更以无动慧刀自除身障。转作金刚萨埵降伏魔业。仍以慧刀结诸方界。复更以如来大界真言印。重结周界。以四大护各护一方。又持无堪忍大护皆普护之。阿阇梨言。凡造漫茶罗。从初已来即用不动尊。或以降三世尊护持是地。中间每持诵时。即如法结界了还解之。至作法夜。更剂金刚线内具足结界。其灌顶护摩坛处。当于漫荼罗外。更以线为周域。令与内界相通。并置所出入门。漫荼罗外界。普以金刚线围断者。至护摩供养时。亦当运心。于通门之所举上金刚线。令通诸尊来往。又结界时。但当于本座处如常作法。若欲行绕一匝而结周界者。亦皆成就。若结界了忽尔妄念故。界破或种种魔事起。即当念持无堪忍大护。若欲令一切时无障者。其周界及供物等。皆先用大护护之。后时障起又当更用也。次当作礼奉阏伽水。以大慧刀遍洒诸供养具。净以不思议法界心。若献涂香时。即当住涂香真言持之。次第供养时。又一一加以彼尊真言。或通或别。或以自所持者。其余供物例尔。复当作心供养法。持以虚空藏明。及以金刚阿利沙吟讽赞叹。次又出外施旷野鬼神食。据图。于东门外施毗那野迦。南门外施蘖[口*栗]何。是魅鬼着人者。西门外施檗啰。是行疾疫者。北门外施荼吉尔。于门之左右各置四位。然瞿醯云。皆是罗刹毗舍遮部多。诸食啖血肉者。种种非人之类。或居地者或居树林者。及以心所念着。各随本方召集而遍施之。一切缘漫茶罗供养之食。悉皆取之和合一处。并及诸香花等。亦皆别出其分共置一处。阿阇梨当起大悲无限法施之心。于瑜伽中。观作种种受用之具。亦以虚空藏转明加持。而周散施。此诸鬼神受食。不作漫茶罗障也。当从东方为首。次往南西北方。如是一周竟。又施东北方。次往东南方西南方西北方。又一周竟。复至坛东施上方鬼神食。次往坛西施下方鬼神食。大凡三遍下食。于诸法事中此法尤难。当尔或自现种种极可畏形。或闻大声雷震野干吼等。如是种种异相。阿阇梨当自好安心。又欲施时。先更防护其身使一一如法。若彼食尽更求者。应复施之务使丰厚。令其欢喜。若物少者但随所有而已。凡坛中献物。亦当以平等之心。不得有所匮阙。瞿醯云。若行食时错误阙少。即应补之仍乞欢喜。所行食类若不遍者。应以余物充数也。施诸方食都竟。洗手洒净。于门前烧香供养。次入于内奉献阏伽烧香。运心奉献衣服以为儭施。然后住瑜伽座。以五轮字持身。首置百光遍照王。以无垢眼观自心花台本不生字。方作普门持诵。先于毗卢遮那心月中炳现真言。而后诵持并示密印。周遍中胎藏已。次及第二院诸尊。乃至终竟。或一一现前观之而作持诵。或自身作彼本尊。于其心月。现真言字而作持诵。乃至顿作漫荼罗身。而作持诵。随行者观。心势力。若不能尔者。当以一心诵部主真言百遍。所余上首诸尊各诵七遍。并作彼印也。具如供养次第中说。阿阇梨如是作法毕已。复以诚心顶礼诸尊。然后召诸弟子一一令入。以前香水洒净。授彼涂香令用涂手。次授净花。略为宣说住心品中菩提心实义。令知自归依处作真正发心。至诚殷重忆念一切诸佛。所以然者。以行者能发佛心。即是佛子。当受法王子灌顶之位。生如来种性中故。当动止云为不忘诸佛。今此经中。每将说一切真言。辄云普归命一切诸佛。即是此意也。言净佛者。声闻法中阿罗汉亦名为佛。诸余大乘未了义经。亦有成佛义。然不得名为遮净。今正明本心常佛故。以净字甄之。梵本正翻。佛家当云佛部。是种族部类之义也。时阿阇梨观弟子身作五轮。以五字持之。兼于心花台中置阿字等。使即同大日之体。以入佛三昧耶印印其顶上。次以法界生印印心。又作转法轮印印齐轮上。各三诵彼真言。次即转彼心中阿字门为嚩字门。结金刚萨埵印印诸支分。所谓五处。所以如此。为欲成彼金刚事业也。时阿阇梨。亦当更以三昧耶等而自护持。次取新净白叠或余缯帛。先以不动真言如法作净。复用本部真言王。三转加之。如作大日漫荼罗。即用毗卢遮那真言。莲花手金刚手亦当准说。用此彩净帛。周覆弟子面门。当深起慈悲护念之心。耳语告彼三昧耶戒。勿令诸余未入坛者闻声。此一偈当于转字轮漫荼罗行品中说之。又观彼顶上有一啰字。字上安点。故云严以大空点(此是囕字也)此字四边遍有光焰。犹如花鬘连环不断。字中又遍流出白光如净满月之晖。以此净法界心所加持故。能除内外诸障。次引至第一重门。逊那优波逊那二龙王守卫之处。令正当门厢不得前却。师当为彼结作三昧耶印。三遍诵彼真言。置花印上。令弟子以至诚心向道场散之。随花所至之处。当知即是行人。往昔因缘法门善知识。即依此方便门进趣修行也。瞿醯云。将入坛时。阿阇梨应作是言。我某甲如法。作此漫荼罗。将弟子入。随其福德种性及与成就所堪法器。唯愿于此漫荼罗中。示现其相。既散花已。次应开面令瞻睹道场。以欢喜心而告之曰。汝今观此妙漫荼罗。深生敬信。汝已生诸佛家。诸明尊等同共加护。一切吉祥及与悉地皆现前。是故坚持三昧耶戒。于真言法教应勤修习。次令弟子以香花等。普供养漫荼罗圣众。即于道场授与本真言印。令坐一处诵之。次引余人入。凡阿阇梨。当观花所至处辨其性类。若堕佛首上成就佛顶及豪相等。堕面上应成就佛眼。在身中分当知成就诸心。若堕下分成就诸使者等。又随佛身上中下分。知上中下成就。莲花金刚亦然。自余诸尊。但知上中下之相。若花堕去彼尊远者。久远方乃成就。若堕供养院。随所属之尊授彼真言。若堕两尊之间。当观其远近。若先堕内院即移出外院者。彼人信心不具。若强持诵得下成就。堕诸界道及行道院者。彼人无决定心不获成就。若彼欲更掷者。应为作护摩然后掷之。余如彼说也。次当为诸弟子作寂然护摩。是扇底迦法。亦可翻为息灾也。次此是一种支分。今如来答中。约行事次第故。说加持教授支分。未竟。即于此中间说护摩。或可与灌顶等法。合为一种支分耳

经云。作寂然护摩。护摩依法住者。上言护摩。谓应作此护摩之法。次云护摩者。是诫作法之人。若护摩时当依法住。故重言之。此中以瑜伽法加持自身。乃至奉请结界等。皆依念诵方便。故云当依法住。初自中胎藏。至第二之外。于漫荼罗中。作无疑虑心者。上文密语。以释迦眷属院为第二。大坛之外令与中胎藏相当。阿阇梨又在其外。面向漫荼罗。于此二位之中而置火坛。梵文故为密语云。阿阇梨漫荼罗中作护摩坛。若不从师受者。多失其旨。或于漫荼罗院中而造作之也。今以灌顶坛。又须正对中胎。可移此坛令稍近南。乃至西南角以来。皆是三位相望。于理无失。不疑虑心。即是息灾之意。应一缘不乱作之。若行者住奢字门。而观诸法常寂然。疑悔求尽盖障净除。即是寂然护摩之本意也。作漫荼罗法。取自身肘量纵广一肘。其深半之。周匝安缘。广四指节高亦如是。凡护摩坛。方圆三角随事业而转。但此中作法当用方坛耳。瞿摩夷瞿摸怛啰涂。洒以香水。中表金刚印者。谓于炉内当画作拔折罗。所以然者。护摩是如来慧火。能烧业因缘所生一切灾横。廊然荡尽无复遗余。方坛名大因陀罗。是心王之义。明此慧火之印穷彼源底。从金刚性生。是故同于金刚不可破坏。至下世出世护摩品中。世尊自广说因缘。若真言行者但作世谛护摩。不解此中密意。则与韦陀火祀岂不相滥耶。故译者兼智之名。庶令浅深二释义用兼举

经云。师位之右方。护摩具支分者。假令大漫荼罗门向西开。火坛当在大坛西。阿阇梨又在火坛之西。东面而坐。诸护摩所用具缘支分。当在师位之南也。护摩薪当用乳木。谓桑谷之类。或用牛膝茎截之。剂十二指量。皆须湿润新采者。取其条理端直。当观上下一向置之。以香水洒净令根本向身。若欲燃时。当于乳酪苏蜜之中。揾其两头掷置炉内。或以沉水香。量长四节粗如拇指。揾苏合香。作一百八遍用之尤善。其应漫荼罗中所献诸食及香花等。各各取之用辨事真言。如法洒净置于座右。其阏伽器当置左边。所献诸食。当用苏酪等调和共置一器。及诸五谷。亦以苏油等润之和合一处。置于别器皆令素辨。若作深秘释者。此护摩支分。是众因缘义。由此因缘能生三有灾患。今还以此为慧火之资。供养一切普门身。增益不思议势力

经云。烦恼为薪智慧为火。以是因缘成涅槃饭。令诸弟子悉皆甘嗜。即是义也。又为弟子作法时。于阿阇梨北边。籍以生茅使蹲踞而坐。阿阇梨亦当坐于茅座。不得加以床褥之类也。然受用生茅略有三义。一者其性洁净离处乐触。可以蠲除行者昏怠恣慢之心。二者此是吉祥草。世尊以为敷坐而证菩提。是故能除一切诸障。三者以此吉祥茅表慧性也。此草两边多有利刺。若坐卧执持无方便者反为所伤。若顺手将护之则不能为害。一切诸法亦如是。若顺谛理观之。一切尘劳皆有性净之用。若失方便。则能损坏智身。故以为法门表像也。若于大石上作漫荼罗。或重阁上不可穿掘。作炉者。当用彩色画之。极令分明严丽便可充用。是名略作护摩处。若室中造漫荼罗。隘迮者。当出外于望见道场处如法作炉。炉四面皆当周匝布以生茅皆令右旋。次第皆令相压而出其头。余如护摩品中所说。又当周匝广厚勿令露地。遍以香水洒之。当用成辨诸事加持。以上文所说洒地真言也。此中护摩行法。凡阿阇梨。初于漫荼罗中供养持诵竟。次当出外而作火法。东向在吉祥座。先取乳木干薪置于炉中。用苏洒上燃之。后置湿薪用辨事真言。去垢辟除并洒净已。当住瑜伽以火天之种子转作火尊。在三角漫荼罗中。如下品中所示十二火尊。随取其一事业相应者。既相应已。当观火尊之身与己身无二无别。如火尊者。当知火漫荼罗亦然。当观三处皆同一相。然后以火天真言而奉请之。苏悉地云。欲奉请时先作是言。我今奉请火天之首。天中之仙梵行所宗敬者。唯愿降临此处受纳护摩。次说火天真言曰

【◇】南摩三曼多勃陀喃阿揭娜曳莎诃

初句归命诸佛义如前说。第二句阿揭娜曳。是火义也。此中以最初阿字为种子。以一切诸法本不生故。即同金刚智体。俄是行义。以诸法本不生故。虽具足万行而无所行。是故名为无师自觉。若是无师自觉。即是同于大空遍一切处。故与娜字同体也。以诸法无师无行故。自遍一切处。故于三界不动出。而至萨婆若。是故无乘及乘者。尔乃为大乘。所以也加三昧声。意明此乘定慧均等也。诸佛行菩萨道时。皆以如是慧火。焚烧一切心垢炽。然正法光明。是故如实说之。即成真言也。若请召时。当增加伊系伊系字。至发遣时加揭车揭车字。其印相如下品中说。既请召已。先以阏伽香水三度洒净。三献嗽口之水。即取诸五谷苏酪等物。以上所说真言。三遍护摩供养火天。凡护摩时。皆先以大杓盛满净苏焚之。次则焚柴。次护摩饭。次及诸谷。或以乳粥。次又以莲花等随意烧之。其中间所施皆以小杓。所以经云。应当持满器。而以供养之也。供养已。重洒香水及倾阏加。如人食已用水澡漱。更以香花等供养。当运心引送火天置于本座。次当奉请诸尊。先取一花。以成辨真言去垢作净。部主真言加持。两手合捧心生口言。唯愿诸尊加持此处受我微供。即当隔炉掷向漫荼罗。随其远近欲掷时。先观此花。遍至一切诸尊座位。作彼随类相应座。复用成辨诸事。于炉内去垢作净。方请诸尊。或以彼尊真言一一别请。或随一部眷属。乃至用真言王一时都请。又此火炉既同火界。请时但观诸尊不动本座而来降临。事了时。亦以无去相而还本处。每为一尊护摩。辄香水洒炉及澡漱水。以下文云寂灾真言七遍供养。如是一一竟。更作护摩百八遍。还以满器焚苏一遍。乃至不能尔者。当总供养。一百八遍或一千八十遍。念言随此所有。唯愿诸尊同受供养也。次当遍乞欢喜。如法供养已。方忏悔回向并作金刚讽咏。其所焚香无令断绝。又奉阏伽。然后顶礼诸尊。召诸弟子。如上文所说作散花等法。乃至告语都竟。方引一一弟子于护摩处。于阿阇梨左边以恭敬心蹲踞而住。师以左手执弟子右手大指。而诵寂灾真言。每一诵一施火食如。此至二十一遍。诸弟子如是作之。瞿醯云。复以香涂手按其胸上。随意持诵而发遣去也。今次释此寂灾真言

南么三曼多勃陀喃阿摩诃扇底(丁以反)檗多扇底羯啰钵啰睒摩达磨唨若多阿婆嚩萨嚩婆嚩达摩三曼多钵啰钵多莎诃

此真言以初阿(去急呼之)为体阿是诸法本不生义即是金刚智火之体加三昧点是本生行金刚慧火三昧傍有二点是涅槃义。言入此阿字门。慧行具足故。能焚除一切障盖得大寂涅槃也。所以为寂灾真言正在此义。复次作法时当观此字。周匝光鬘从火而出具备三色。本体黄白色。其三昧画作赤色如阎浮金。傍二点黑色如劫灾火。以本性白净故有息灾用。兼黄色是增益用。赤色是降伏焚烧用。黑色摧伏大障并摄召用。又此字体是方便门。当知即同大空之色。具种种事业也。复次于下文十二火中。阿字智慧火。三昧画是行满火。具摄召义是风燥火。具降伏义是卢醯多火。黄赤和合是没栗拏火。兼赤黑色是忿怒火。兼备众色是阇吒罗火。以要言之。悉备十二种用。当广演之耳。次下诸句皆转相释。初句摩诃扇底。是大寂义。檗多是逝义。言如来以此一字义故。去至本性常寂大涅槃中也。阿字体是本寂。以具三昧画故善逝。具净除点故涅槃。不动是处即行即到。同于大空无所不遍。故云大寂。次句扇底羯啰。是作寂义言此字门方便满足故。常遍十方三世。遍作普门事业成就众生。皆令去至大寂之中。故云作寂也。次云钵啰睒摩达磨涅若多者。钵啰是最胜义。睒摩是证此寂。重释前句以作寂故即是寂中之寂。所以者何。以寂毕竟不可得故常作。作毕竟不可得故常寂。一切世间不能思议。故云最胜也。达磨是法[口*(臼/工)]若多是生。从何而生。谓即从此不思议寂业中生也。以动寂毕竟等故。从本不生句中。具生根茎枝叶花果。成菩提树王。犹如火界能烧能养。金刚智火亦尔。用净除点烧。三昧点养也。次云阿婆嚩萨嚩婆嚩。又是转释前句。故云无自性。一切自性以本。性寂而从缘起故无自性。从缘起者皆本性寂。是故为一切法自性。以此义故。妄想不生而大空生也。次云达么三曼多钵啰钵多。又转释前句。以此义故。如来于一切法平等。谓成无上菩提。钵啰钵多是获得义。以无所得故得此平等句也。余如上释。凡护摩时当有种种相现。或时烧火不燃。燃或速灭不甚炽盛。或烟起无焰或烟甚浊。或出声犹如驴畜等音。人不乐闻。或言不成就等。当知障碍不成之相。或烟焰中作宝瓶宝网师子车乘等种种妙形。或声如钟铃螺贝等音乐之响。或出吉祥成就之音。当知是无碍悉地之相。乃至善作护摩者。当于是中曲蒙旨授了了具知通塞之相也。凡护摩各随所应事业。或以寂静或以欢喜。或以威猛之心。所被衣服有白黄赤。当北向东向南向而坐。其漫荼罗亦有圆方三角之异。色亦可知。其护摩薪。息灾用树最上枝。增益用树中枝。若折伏事应以树根。若息灾事。应以苏乳大麦密及乳粥。茅草之牙军那花白檀香无忧木。若增益事。应以乳粥酪饭蜜乳酪粥胡麻。天木回香天门冬龙花诸谷等。若折伏事。应以赤白芥子或芥子油。毒药骨发诸荆蕀等有刺之木。虽经不具说当以类推之。又随焚苏遍数胡麻亦然。余则随意多少。最初最后皆应满[打-丁+夕]苏护摩。诸余法事例尔。凡息灾护摩。先须作降伏法。若所用真言中有降伏义者。直尔依本而诵。若无其义则当依法增加。用芥子等降伏相应物。作一七遍或二七遍护摩。次观增益相应句义及其供物。又作一二七遍。方乃具足作寂灾法。如作增益护摩。先须作降伏法。方乃具足作增益法。其降伏护摩。一法直成不须设前方便。当知此漫荼罗。具有三种法事也。瞿醯云。灌顶了后。复当依法护摩。先用漫荼罗主真言焚苏百遍。次当以寂静真言。用苏密酪和饭百遍。次用胡麻百遍。方乃广示漫荼罗。至事毕将散时。师当自洒其身更奉阏伽。次第供养一一诸尊。次以曼荼罗主护摩八百遍。次以寂静真言百遍。次以部心作廿一遍。次以一一诸尊真言。用牛苏各护摩七遍。然后以本持真言随意护摩。方作解界发遣等法。或复依前作总相方便亦得。今此经中。阿娑嚩三字。如字轮品所说。即是三部。心真言也。若是余时三种法事。但于檀中持诵毕已。即当出作护摩。或若作成就护摩。则须五处相直。第一本尊。第二火炉。第三所成就物。第四苏器。第五阿阇梨座位。其所成物。先以净叶承覆。每一取苏等。皆以[打-丁+夕]加于叶上。方乃焚之。若成就有情。当于置物之处图画其像。余如上说。若为人护摩。则一一称名方投火中。若无漫荼罗但作护摩法者。当绕炉作一重漫荼罗置诸尊座位。欲请诸尊供养。广略随意耳。苏悉地云护摩了已。皆当用本持真言。加持净水以手巡绕。散洒炉中三度。须复请火天重受余供。乃至想还本座。所残谷苏密酪等总和一处用火天真言三转持之而作护摩。重作护身护方等印。乃至解界方可发遣也。瞿醯云。第六夜作弟子法竟。为除障故先作降伏护摩。次为自增益故以部心真言护摩。然后以寂静真言作息灾护摩。至临作法事时。若数有不善相者。当以部母真言作息灾护摩。焚苏及薪各百遍。于作法之明日。为满所阙乏故。更作息灾护摩八百遍。然此火法。亦是支分中难事。以将除灾障增益正法威势。是故诸为难者。皆于此中伺求其便。若不一一明了当自损伤。不可率情妄作也

经云。行者护摩竟。应教令儭施。以下是答秘密主问中云何供养师句。犹属加持教授支分也。所以自教弟子令其儭施者。非为贪着是物而求索之。为发生彼善根成就灌顶功德故。若弟子能以内外所有种种资财。为求大事因缘无所悭惜。至诚殷重奉报传法之人。则能摧坏无量宿障。又自见檀那利益深生庆幸之心。我今舍此世间所爱之财。五家所共多诸过患。用货无上法宝正法之财。遍施众生常无穷尽。以是思惟已其心欢喜。欢喜故则离疑悔。离疑悔故便得内寂安乐而住。然后以法水灌之。则能永离尘垢也。若无物者。乃至舍身而供养师。谓以此身奉事供给阿阇梨。不惮疲苦常不舍离。咨求正法乃至不惜躯命。为求道故。尔时阿阇梨。感其殷重生悲念心。诲以深秘方便。乃至自所受持真言功行。垂满于道场中。作法回用施之。少用功力得大成就。此是诸施中上也。瞿醯云。弟子当于护摩处。以至诚心顶礼阿阇梨。先当奉献衣裁二匝。然后舍施余财。又彼文是灌顶了。广示漫荼罗相。教真言印方乃奉施。与此经不同。任随所用耳。经云。已为作加护。应召而告言者。谓从初召入以来。皆是加持方便。今为起发其心故。又复教授而告之言。今此胜福田。一切佛所说。为欲广饶益。一切诸有情者。谓世尊见众生等。自从无始以来。恒常匮乏内外资财。诸有所为不得自在。以是因缘堕无暇处。不能疾至无上菩提。是故同以加持神力。说此无上福田也。以此大悲藏中。一切普门大海无不毕集。今于此中广种无限善根故。从今生以后尽未来际。常作如意珠身虚空藏身。能满自他一切希愿。故云广饶益一切众生也。复次已施第一义僧及传法人竟。复教令供养世谛和合僧。若施和合僧时。十方一切凡圣众僧。皆悉有分。是故此福。如虚空云海不可思议。当获于大果者。是究竟利。若于此中树福。如食金刚毕竟不消。要至金刚地际然后止住。故生公云。一豪之善皆趣佛果也。次明世间希愿故。复说世间义利。所谓无尽大资财。世说常随生。此是世界悉檀。故云世说。如薄拘罗以一诃梨勒施僧故。九十一劫以来。常无疾患终不横死。阿那律以一食施辟支佛故。亦于无量劫来。常与宝藏俱生。如本生经中广说。故云常随生也。复次有部毗尼中说。大迦叶舍利弗目干连须菩提四大弟子犹如贤瓶。若人净心供养竟。希求世间现报无不如愿。何况施一切僧者。当知十方世界诸如是等具德之人。皆在其中。乃至无学圣人欲延寿住世。犹籍僧力。是故汝今为欲成就悉地果故。当令所修檀施具足无缺。复当以欢喜心供养世谛现前僧。以十方僧不可尽集故。但于界内随现前集会者施之。即是施一切僧也

经云。尔时毗卢遮那世尊。复告执金刚秘密主。以下明灌顶法。亦属加持教授分。然此灌顶亦通诸余法事。或可别为一种支分也。阿阇梨作第二漫荼罗。当与中漫荼罗相对。去大漫荼罗二肘。第二是次小之义。即是相待言之也。凡火炉应当中胎。若处所不便。得渐移近南。乃至对西南角。此灌顶坛又在火坛之北。亦令四方均等。唯置一门。门向坛开也。其坛四角外画四执金刚。火方是东南。置住无戏论。涅哩底方置虚空无垢。风方置无垢眼。伊舍尼方被杂色衣。坛中作八叶大莲花王鬓蕊具足。于四叶中置四伴侣菩萨。帝释方曰总持自在菩萨。焰摩方曰念持菩萨。那伽方曰利益心菩萨。夜叉方曰悲者菩萨。其四隅之叶置四奉教者。火方名著杂色衣。涅哩底方名满愿。风方名无碍。伊舍尼方名解脱

经云。中央示法界。不可思议色者。即是此嚂字作纯白色。所谓不思议法界之摽帜也。复次深秘释者。方坛即是大因陀罗心王金刚界。住无戏论。即是本原性净三世无障碍智戒。由此戒故一切戏论皆息。戏论息故得成无师大慧。尘翳都尽如净虚空。故名虚空无垢。如虚空中无垢障时。极目十方无所不睹。般若亦尔。由离一切相故于一切种。无不见闻觉知。故名无垢眼。如明眼人则能自在作诸事业。今以无碍悲普观一切根缘已。即当普现色身而道利之。故名著杂色衣。若已此四种金刚慧印。于一心具足无缺。即能镇此心地。堪持灌顶慧身。犹若菩提树下。从金刚地际以来皆悉坚实。是故如来成道时不倾不陷也。四伴侣者。谓心所有法是心王伴侣言。此净法界心王成就四法。能行四种如来事。则堪灌顶受法王位。初云陀罗尼自在王者。即是通达阿字门。见此真言王时。即能于一切陀罗尼门皆得自在。故以为名。又以总持自在故。成如来念觉如意三昧王。能持万佛国。如彼龙宫秘宝。能持大海不令泛溢。亦能持之令无秏竭。故曰念持。已得如是念宝便忆本愿。普雨法财充满法界。遍施众生名利益心。已出无尽资财作无限大施。而诸下劣众生。无心受用不肯求之。为此兴大悲心。种种方便调诸穷子。故曰悲者菩萨等。言奉教者。即是从此四门。折伏摄受行如来事。当知着杂色衣。即是陀罗尼自在王所为事业。满愿是念持如意宝王所为事业。无所挂碍是大慈悲法施所为事业。解脱是大悲方便拔苦众生所为事业。故名四奉教者也。复次四宝所成瓶者。即是毗卢遮那四德之宝。置在中胎四角。如上所说。以不动明王作加持已。复次四菩萨真言各持一瓶。普贤是无尽愿行宝。慈氏是无尽饶益众生宝。除盖障是无尽净知见宝。除诸恶趣是无尽大悲方便宝。复次普贤是遍法界净菩提心。慈氏是此净心于胎藏中发生根牙茎叶。除盖障是此净觉树王妙严花果显现开敷。除一切恶趣是收此果实后种一切众生田中。如是旋转相生无有穷尽。故以此四宝之瓶。盛满种种宝药诸谷所渍性净之香水。用灌莲花台中不思议法界心。是故得名法王之子。当知一种宝瓶。还与一菩萨一金刚一使者机感相应。以方位法门对之。则可知之也。凡欲灌顶时。用辨事真言加持座物。安置莲花台上。阿阇梨复为弟子如法护身。先以不动明王用除诸障。次用三种三昧耶加持三处。金刚萨埵加持支分已。令依吉祥坐法而坐其中。所有涂香花灯阏伽水等。先已如法加持。一如上法。阿阇梨先当奉彼香水。次用涂香遍涂其身。以花鬘冠饰其身以为璎珞。次奉焚香薰之。诸灯明布列其前并献诸食。凡此供养物。总有十三坐。谓四金刚四菩萨四使者并及弟子。其弟子供物最令丰厚。犹如供养本尊也。亦可于大曼荼罗中置位供养。至灌顶时。但当持彼名号请加持弟子。其四菩萨。于第一院各于一方置之。使者如来下挟门左右。又备新净白伞。上悬花鬘及与白缯。亦先用不动去垢除障。以大日如来真言持之。阿阇梨自执用覆其上。复令余人执净牦牛拂及扇香炉。皆以辨事真言加持。又于箱中置衣并诸吉祥之物。即是金[箅-丌+廾]明镜轮宝商佉之类。并持四宝之瓶而以供养。并奏摄意音乐。此曲具在瑜伽大本中。若献涂香时即有献涂香曲。花灯饮食等皆亦如是一。一歌咏皆是真言。一一舞戏无非蜜印。乃至无人解者。阿阇梨当自奏之。若不能尔不名兼综众艺也。言摄意者。如世人见美妙色声心为之醉。情有所注不复异缘。今此金刚伎乐。能感人心亦复如是。如马鸣菩萨自奏赖吒和啰曲。五百王子闻之。同时舍家入道。即其义也。瞿醯中。但云若得辨者应作音乐

经云。吉祥伽他等。广多美妙言者。此颂凡有三种。一名曰吉庆。二名吉祥。三名极吉祥。皆是阿利沙伽他。用此庆慰其心。仍有加持之用。阿阇梨当自说之。次于下文且出吉庆一种。于此方所用。已粗周备耳。说此偈时。当自持白拂而拂其身。赞诵毕竟。阿阇梨复当顶礼漫荼罗一切诸尊。为灌顶故至诚启曰。即持宝瓶徐绕漫荼罗三匝已。复更如法加持。至弟子所先用啰字为火。焚烧其身悉成灰已。方用四瓶次第灌之。灌已。观此灰中作嚩字门。其色纯白。从此出生五字。所谓阿鑁囕[合*牛]欠。持其五轮。次说暗字在其顶上。转成中胎藏。又从此字生三重光焰。一重遍绕咽上。随所照及之处诸尊随现。即成第一院漫荼罗。次一重光遍绕心上。诸尊随现成第二重漫荼罗。次一重光遍绕脐上。诸尊随现成第三重漫荼罗。尔时弟子都成漫荼罗身。若更深释。即是普门法界身。次当引至一处。阿阇梨亲为着衣首冠白缯。以香涂身饰以花鬘。焚香灯明如法供养。并络膊系金刚线及臂钏指环。其制作法如悉地供养中说。又阿阇梨先用啰字加持金[金*(由/廾)]。暪字加持明镜。法轮法螺真言加持轮及商佉。复当弟子前。以金[金*(由/廾)]莹拭其目。而为说偈。当观啰字门净其目中垢障。次又现前示彼明镜。而为说偈。当观暪字门净其心中垢障。次持法轮置彼二足之间。并授商佉于其右手中。而为说揭。各用彼真言持之。所以然者。若彼行人能以净眼现前自观心镜。即是成大菩提。成大菩提已当转法轮。转法轮者。非为若干数量众生而作限剂。乃当觉悟一切众生。是故吹大法螺。凡秘密宗中。皆说因缘事相以喻深旨。故作如此传授也。阿阇梨次当持伞用覆其上。引令旋绕漫荼罗三匝。先绕第一行道院。次绕第二行道院。后绕第三行道院。如是行道时。阿阇梨当诵吉祥极吉祥等偈。或可诵吉庆梵文。既周毕已。复至西门二龙厢卫处。令其殷勤礼拜。其伞当随身上下而以荫之。即当为说三昧耶偈。所谓秘密藏中四种重禁。此等皆是阿利沙偈。下当释之。瞿醯云。弟子至西门礼拜已。阿阇梨当白诸尊云。我某甲已与某甲灌顶竟。今付属诸尊令持明藏。作是语已。应当放伞令其起立。对漫荼罗前为说三昧耶戒。汝今已成就漫荼罗持明阿阇梨竟。诸佛菩萨及真言主一切天神。已共知汝。若见众生堪为法器。怜愍彼故。当为建立漫荼罗而教授之。然此经中自有传法螺偈也。如西方世人受灌顶法时。取四大海水及境内一切河水。具置宝药谷等。作境内地图。令此童子踞师子座。以种种珍宝庄严所统眷属。随其大小列次陪奉。韦陀梵志师坐于象宝。以临其后持此宝水。以注象牙令堕其顶上。而后唱令以告众人。又叹说古先哲王治人济代之法。如是随顺行者。当得寿命长远。本枝繁盛尧绍转轮之业。若不作如是事者。则当自退其位殒身绝嗣。如是一一而教诲之。今此法王子灌顶。则不如是陈列。密严佛土法界大图。坐于妙法莲花自在神通师子之坐。以本性清净智慧慈悲水具含万德。而灌其心。尔时诸菩萨众。下至八部众生。莫不欢喜赞叹而生敬仰。时阿阇梨。以法王遗训而教训之。从此以后。当得生如来家定绍佛位。若不如是对明。则不知正法尊重也

    吉庆阿利沙偈(出嚩驲啰阿避庾经中译云金刚起经也)

落吃涩弭(三合吉相也)达啰(持也)建者曩(金也)钵喇么(三合山也)多(引)婆(光也)悉怛[口*履](三合)路迦(三世也)曩(去)他(导也)悉怛[口*履](三合三也)莽罗(垢也)钵啰(二合)系(乎异反)拏(除也)没度(佛也)微没诞(引开敷也)亩阇(水生也)钵怛啰(二合叶也)泥(去)怛嚧(二合眼也)怛懵檗嚂(是彼庆也)系多羯嚂(饶益也)钵啰(二合)他(上)门(最初也)钵啰(二合)社难(引诸众生也一偈)

谛怒(轻)波儞瑟吒(二合彼所宣说也)钵啰(二合)嚩啰(胜法也)悉怛嚩(二合)釰秕也(二合不动也)契(弃夜反)多(宣说也)悉怛[口*履](三合)路计(三世也)捺啰(人也)泥(去)嚩布尔也(二合应供养也)达啰慕(二合法也)瞻莽(殊胜也)扇[口*底](寂也)羯啰(能作也)钵啰(二合)社难(诸众生)路计(世间)儞尾(二合)[口*底](去)延(第二也)输(上)婆(善也)懵檗嚂儋(嘉庆也二偈)萨达喇摩(二合正法也)欲吃多(二合相应也)室噜(二合)[口*底](闻也)懵檗逻(引喜庆也)迟邪(二合宣也)僧躣(众也)[口*但][口*栗](二合人也)泥(去)嚩(引天也)素啰(非天也)诺吃屣(二合)腻也(应供者)颉唎(二合愧也)室唎(吉祥也)麌儜(引功德也)迟耶(二合富也)钵啰(二合)嚩嚂(殊胜也)巘儜难(引众也)路计(世间也)怛哩(二合)[口*底]延(第三也)输(上)婆(善也)懵檗儋(庆嘉也三偈)曳(入)懵檗嚂(如彼庆也)睹史多泥(去)嚩(升兜率天也)微莽(去)曩(宫也)檗喇娑(二合也)那赐(亦如也)儞何(引此也)嚩多罗(下也)睹若檗睹(于众生也)系多(去)也(利益也)塞(去)印捺[口*束*頁](三合与帝释)素[口*束*頁](天也)钵[口*履]勿[口*栗](二合)怛写(围绕者)怛他檗多写(如来也)怛懵檗(彼庆也)婆嚩睹(得也)扇底(寂也)羯嚂(作也)哆嚩(引)儞也(二合今日也四偈)曳(入)懵檗嚂(如彼庆也)补啰(宫城也)嚩(入)[口*犁](胜也)迦秕罗(古云迦毗罗)诃嚩(平二合)曳遮(名也)儞吠(无害反天也)么诃(大也)怛么毗(德也)罗避瑟[打-丁+朱](吒矩反二合)哆(叹反)嚩(无汗反)儞儞怛写(敬礼者也)阿(引)赐(引亦如也)梛震[口*底]也(二合不思议也)但舍逻写(善者)怛他檗多写(如来也)怛懵檗蓝(彼庆也)婆嚩睹(得也)扇底羯蓝(寂儞也)怛嚩(引)儞也(二合汝今日也五偈)曳(入)懵檗嚂(如彼庆也)枳娑攞瑜(花枝条也)入嚩(二合)攞(光也)补涩波(花也)梛提(严饰也)嚂迷遮(悦乐也)婪弭尼(园名)嚩(去)宁(园也)么护(无量也)泥(去)嚩(天也)乳瑟[齒*束](二合所居也)曩(去)他写(导师也)然莽儞(诞生也)嚩部嚩(时也)婆嚩(无侃反)多迦写(有尽者)怛懵檗嚂(彼庆也)婆嚩都(得也)扇[口*底]迦嚂(寂作反)怛嚩(引)儞也(二合汝今日也六偈)曳(入)懵檗嚂(如彼庆也)尾尾驮(种种也)耨(入)佉(苦也)囊设曩耶(除灭也)赌瑟室也(三合喜悦也)怛布嚩(无侃反)曩(苦行处也)莽避(趣也)没啰(二合)若睹(往也)[口*賴]驮(二合)啰怛[口*犁](二合中夜也)阿(引)赐(亦如也)素[口*束*頁](天众也)播唎勿[口*栗](二合)怛写(园绕者)纳莽(礼也)塞吃[口*栗](三合)怛写(作者)怛懵[卄/壁]蓝(彼庆也)婆嚩睹(得也)扇[口*底]迦蓝(寂作也)怛嚩(引)儞也(二合汝今日也七偈)曳(入)懵檗嚂(如彼庆也)部若伽(龙也)啰阇(王也)纳莽塞吃[口*栗](三合)怛写(作礼者)捺儞夜(二合河也)萨跢(二合)[鹵*來](岸也)钵履勿[口*栗](二合)怛写(围绕者)系者洒半[口*底]也(二合鸟行列也)扇[口*底][口*栗]他(二合寂义也)莽捺部(二合)单(奇也)莽部(得也)嗢婆嚩(有也)苏捺曩写(断除者也)怛懵檗嚂(彼庆也)婆嚩睹(得也)扇[口*底]迦嚂(寂作也)怛嚩(引)儞也(二合今日也八偈)曳(入)懵檗嚂(如彼庆也)薄伽伐睹(世尊也)窣噜(二合)莽(树也)啰阇(王也)慕[口*犁](根下也)昧底唎(二合慈心也)沫丽曩(力也)微尔帝(降伏彼也)莫胡(无量也)忙(引)啰(魔也)博吃刍(党也)囊囊(种种也)钵啰迦罗(异类也)莽婆嚩(有也)娜部(二合)尾(遍人间也)瞻(去)沫丽者(至天也)怛懵檗嚂(彼庆也)婆嚩睹(得也)扇[口*底]迦蓝(寂作也)怛嚩(引)儞也(二合汝今日也九偈)曳懵檗嚂(如彼庆也)钵啰(二合)嚩娜都嚩啰(上妙也)达啰(二合)莽(法也)斫吃囇(轮也)嚩啰(引)捺斯(古曰波罗奈)悉[口*體](二合)多(住也)嚩多(于也)苏檗怛写(善逝者)舍窣睹(道师也)曷谛(入)部儋(希奇也)部费(人间也)嚩簿(时也)婆嚩多迦写(有尽者)怛懵檗灆(彼庆也)婆嚩睹(得也)扇[口*底]迦嚂(寂作也)怛嚩(引)儞也(二合波今日也十偈)曳(入)懵檗嚂(如彼庆也)系多羯嚂(作利益也)钵啰门(第一也)跛尾怛灆(三合吉义也)本昵也(二合福也)吃[口*履](二合)耶(利也)迦罗儜(饶益也)忙哩也(二合圣也)若囊(众也)毗乳瑟(示咥称赞叹也)吃[口*栗]瑳(入)曩(二合遍也)若伽(引)娜(说也)薄伽梵(引世尊也)牟尼铄(引)吃也(二合)僧(思孕反)诃(师子也)怛懵檗蓝(彼庆也)婆嚩睹(得也)扇[口*底]迦嚂(寂作也)怛嚩(引)儞也(二合汝今日也十一偈)

  持吉祥众德　　具相金山光
  三世之导师　　除灭于三垢
  开敷正觉眼　　犹如水生叶
  是饶益众生　　最初之善庆

右先明一切吉庆所以得生。皆由如来出世。故梵云落吃涩弭(三合)翻为吉祥相。或云具相。亦是嘉庆义吉祥义。吉庆义嘉慰义。威德义好相貌义。当知此名摄一切功德。故会意言之。次句云开敷亦是觉悟义。水生是莲花异名。以具如是义故。如来出世多所饶益。故云最初善庆。或云吉庆或云嘉庆。大体同耳

  及彼所宣说　　第一无动法
  开示于三界　　人天应供养
  殊胜法能令　　诸众生永寂
  是则为世间　　第二之善庆

右世尊一切所说。究竟皆至第一实际。故曰无动法。梵云契(弃夜反)多是宣说义。亦是开示义。此中三界者。梵本正云三世。意通过现未至及三有也。以能普示世间第一实际故。一切人天皆应供养是法。为报大恩故。梵云扇[口*底]羯啰译云作寂。此作是能作。能令能得之义。此法能令众生悟一切法本性常寂。内外诸障毕竟不生。故云永寂。以下例然。以如来出世则能宣说此法故。云第二善也

  正妙法相应　　获得多闻庆
  人天修罗等　　应供福田僧
  富吉祥惭愧　　功德殊胜众
  是则为世间　　第三之善庆

右梵云萨达喇摩。译云正法。或云妙法。为满句故今具存之。此中相应梵云欲吃多。是应合如是之义。即是契合冥苻之义。与瑜伽稍别也。次句由多闻此法行与理契。是大庆故曰多闻庆。据正译当云富闻。今顺旧译耳。又此应供梵名。与阿罗诃不同。此应供是诸天人等。为求福故应当供养之义也。第二偈初云富。与前富闻义同。亦是具备无乏之义。富吉祥富惭愧富功德也。末句云众。但是众多之称。梵名与僧伽不同。僧伽兼有和合义。由正法藏出兴于世。则有修行果向之人。故云第三善庆也

  如在兜率陀　　天宫藏时庆
  及与从天降　　利益诸群生
  帝释天神众　　翊从如去者
  汝今得同彼　　作寂之嘉庆

右此藏字。梵音云檗喇婆。是中心之藏中胎藏之藏。与比吒迦俱舍等。其义各殊也。如菩萨在天宫中及从天降时。于诸世间有无量无边吉庆之事。如花严等经广说。修多罗即是诸天众。为欲简异诸天故为阿修罗。立世等论谓之非天。又怛他揭多译为如来。又云如去。谓从如实道去至涅槃中。不复更生。故以为名。用释从天下时于义为便。故互文耳若兜率天有补处菩萨。则世间佛种不断。若人于秘密藏中受灌顶位者。乃至一生中或成正觉。故云同彼庆也

  如在迦毗罗　　胜宫城庆时
  诸大威德天　　称叹而作礼
  犹若不思议　　如实善来者
  汝今得同彼　　作寂之嘉庆

梵本如彼庆中即含时义。以下例然。此是菩萨处胎时。一切世间有无量吉庆之事。亦如花严入法界离世间品中广说。乃至十方无量大菩萨众同集腹中。为听法故。是故不可思议。对前偈如去之义。今以来成正觉释之。亦于义势为便也。如菩萨虽在胎中。一切大威德诸天无不称扬作礼。汝今亦于虚空眼佛母藏中。而托圣胎。是故八部龙神共所宗敬。故云得同彼庆也

  如在华园庆　　光花遍严饰
  悦乐林微尼　　无量天众居
  道师初诞生　　有尽后边身
  汝今得同彼　　作寂之嘉庆

梵云枳娑攞瑜。是林树上兼带条叶之花。次云补涩波。正目花体。如花鬘散花之类。皆用此名。故上句以华园甄别之。菩萨初诞生时。于一切世间亦有无量吉祥瑞应之庆。乃至无量诸天众等。为供养故皆集林微尼园。又有无量不思议解脱菩萨。亦如阴云笼月同时下生。汝今亦于秘密藏中初得诞生。一切法门眷属皆已萌动。若能勇进修行者。亦是生死后边身。故云得同彼庆也

  如灭除在家　　种种苦时庆
  中夜心欢喜　　往诣苦行处
  亦如诸天众　　敬礼围绕者
  汝今得同彼　　作寂之喜庆

此是菩萨初出家时。梵但云灭除种种苦。即含在家之义。所谓舍离在家种种恩爱系缚之苦也。苦行处。梵云正翻当云修身处。如菩萨初始逾成往趣修身处时。一切世间有无量无边吉庆之事。亦如花严等广说。尔时净居天众乃至诸护世者皆大欢喜。知正遍觉优昙花不久开敷。悉皆顶礼围绕。或亲承马足而奉送之。汝今亦于秘密藏中。初与无明父母别。往诣初法明道修身之处。当知净居天等亦皆欢喜敬礼。知其不久同于世尊。故云得如彼庆也

大毗卢遮那成佛经疏卷第八大毗卢遮那成佛经疏卷第九

        沙门一行阿阇梨记

    入漫荼罗具缘品第二之余

  又如彼龙王　　恭敬礼时庆
  河滨众飞鸟　　环绕而行列
  逮希有寂义　　将摧诸有者
  汝今得同彼　　作寂之嘉庆

此时菩萨。已到苦行源底知无义利。受牧牛女人乳糜已。于河中澡浴相好圆满。尔时去佛道渐近。有无量青雀之瑞。如本行经中广明。此鸟正名搡沙。形似青雀而小者。方俗间所谓仙人鸟也。菩萨澡浴已。思惟诸法本寂心。明见大菩提路生奇特心。自知必能以大势力摧坏诸有。是时复有无量无边吉庆之事兴于世间。汝今亦于秘密藏中。弃舍九十五外道中。种种疲劳形神无有义利之苦行。啖阿字一味乳糜。增益常命色力。以净法水灌浴其身。明识心王大道将诣毗卢遮那坐道场处。故云得同彼庆也

  犹如婆伽婆　　树王下时庆
  以慈心力故　　破无量魔军
  种种随类形　　遍天人世间
  汝今得同彼　　作寂之嘉庆

世尊坐道场树下。降伏天魔成正觉时。一切世间出世间。有种种庆嘉之事。如天树王上春之月具足开敷。本行菩萨道时所有希愿已得如意。即便普现色身。遍于世界开化众生。又此中言魔军者。梵本正音博吃刍。是羽翼党援之义。今依古译会意言耳。汝今发菩提心。当知已得安坐佛觉沙啰树王根本之下。以如来加持神力遍伏魔军。若从此坚固不动。逮见心明道时。即是初发心中便成正觉。以除盖障三昧普现漫荼罗身。故云得同彼庆也

  如善逝导师　　住于波罗奈
  初转最无上　　法轮嘉庆时
  奇特未曾有　　世间时分尽
  汝今得同彼　　作寂之嘉庆

世尊以十义故转正法轮。如花严等广说。梵云钵啰嚩娜睹嚩啰。是上妙义殊胜义。即是世间第一更无过上。故云最无上。复次世尊诸有所说。皆为大事因缘。故云最无上。一切世间初来未曾闻。亦不能转。故曰奇特未曾有。梵本正云奇希。今会意言耳。自度诸有。亦令无量众生住最后边身。乃至意生粗重之有亦令永尽。汝今亦尔。若于此生逮得除盖障三昧语言陀罗尼。起自在神通时。亦能如毗卢遮那而转法轮。故云得同彼庆也

  如彼为利益　　第一吉义庆
  福利所饶益　　称赞诸圣众
  遍说具德尊　　牟尼释师子
  汝今得同彼　　作寂之嘉庆

梵本云系多翻云利益。次云吃[口*履]耶。此翻为利。迦啰儜翻为饶益。本名各异。传度者无以别之。譬如初哉首基肇祖元胎。虽复同归于始。然有小殊也。初句为利益。亦是令利益之义。结成叹佛偈。次句云第一吉义。结成叹法偈。次二句明供养修行所成胜果。总结叹僧偈。次二句结成总结释迦牟尼本行中七偈。以要言之。如是等一切功德。汝今已具得之也。世尊般涅槃时与成正觉时。无二无别。若就世谛。则云三界虚空众生福尽。是故晦而不言。然此中结会三宝及如来本行。即是大涅槃义也。此十一偈中具无量义。当广诸修多罗分别说之。恐妨说漫荼罗义故。今略明训诂而已

    金筹偈(梵本)

阿壤(引)曩(无智也)钵吒嚂(膜也)嚩瑳(佛子也)阿跛儞啴(都根反决除也)尔乃(平声仁者也)萨哆(二合)嚩(为汝也)舍逻枳(去声善用筹也)昧(无害反)儞也(二合)啰折窣都(医王也)曳(入)他路羯写(如世间也)昧(无害反)补啰(引声犹如也)

佛子。佛为汝决除无智膜。犹如世医王善用于金筹。西方治眼法。以金为箸。两头圆滑中细。犹如杵形可长四五寸许。用时以两头涂药。各用一头内一眼中涂之。涅槃金箄亦此类也。一切众生心目。本有佛知见性。但以无智膜翳故。诸法实相不得明了现前。若令拙医救之。非徒无效而已。或更增其翳膜。或伤损目瞳。如来方便具足善用金筹者。则不如是。如郢匠运斧尽力除垢。然于不可伤处则不令伤。若豪发之间盈缩失度。则为断空所翳。不成无碍知见也。又此病眼目中见色之性。世间若有医王若无医王。法尔成就。但遇可治际会。则便开明。非筹药之功今始创造也。法莲有盲人譬喻。此中当广说之。一切诸佛种种异方便门。究其旨归悉皆意在于此耳

    明镜偈(梵本)

钵啰(二合)[口*底]嚩(微[摛-禸+儿]反像也)么莽耶(形也)达摩(法也)阿车(引澄也)输(上)驮(清净也)阿囊尾罗(不浊也)阿檗啰(二合)系耶(二合)曩(无执也)毗逻必夜(二合)室者(二合离言说也)系都(因也)羯么(业也)三母嗢婆(二合)嚩(引发起也一偈)翳文(如是也)壤怛嚩(引二合知也)伊[目*尹]瞒(引此也)达么(法也)[嗨-每+(臼/工)]娑嚩(二合)婆(去)嚩(引无自性也)曩囊微嚂(不浊也)矩噜(为也)萨怛嚩(引有情也)喇他(利也)莽赌嚂(无比也)勃驮喃(诸佛也)若多(生也)悉怛嚩(三合汝也)冒啰娑(心也)

  诸法无形像　　清澄无垢浊
  无执离言说　　但从因业起
  如是知此法　　自性无染污
  为世无比利　　汝从佛心生

梵本初句但云形像。然与无相法文势相连。意明法无形像也。性本净。犹如明镜澄然清净。无有秽浊而能普现众像。当知此像不从镜中生。不从外质生。不共生。亦非无因缘有。种种戏论皆不相应。亦复不可执取。但属众因缘耳。缘合不生缘离不灭。即言无常无断无去无来。当知即像是镜即镜是像。若能如是解时。即见诸法实相。知心自性本无染污也。以之如镜之心鉴如心之镜。故说心自见心心自知心。智之与镜无二无别。所以决去眼膜。正为观如此法界故自明之。若与此相应时。即于普门漫荼罗。得除盖障三昧。能为一切众生作无比利。或云无对或云无称。谓不可称量也。以能自生心佛家故。是名佛心之子。从心佛生故。曰汝从佛心生

    法轮法螺偈(梵本)

阿捺也(二合今日也)钵啰(二合)勃哩(二合)[口*底](已后也)路羯写(世间也)斫羯兰(二合轮反)沫(无割反)唎多(二合)也(轮转也)哆(引)演难(引救世者也)阿(引)布[口*束*頁]延(吹也)三漫多讷嚩(无害反二合普遍也)达么(法也)商佉(螺也)莽(无也)努哆嚂(上也一偈)曩(无也)谛怛啰(二合)建吃洒(二合彼虑也)尾末[口*底]喇嚩(二合异慧也)[嗨-每+(臼/工)]喇尾(二合)商计曩(无疑也)制哆娑(引心也)钵啰(二合)迦(引)奢也(开示也)娑嚩(二合)路计悉泯(二合世人也)瞒怛啰(二合真言也)遮唎邪(二合行也)曩演(道也)钵嚂(胜也二偈)医梵(如是也)吃[口*栗](二合)哆茸(作愿也)勃驮喃(诸佛也)邬跛迦(引)[口*履](恩德也)[口*底]拟(疑异反)也细喝(唱也差说也)谛遮(彼也)嚩驲啰(二合)驮喇(执金刚也)萨喇鞞(二合一切也)[口*落]吃铲(二合)[口*底](护也)怛嚩(汝也)萨婆奢(皆常当也三偈)

  汝自于今日　　转于救世轮
  其声普周遍　　吹无上法螺
  勿生于异慧　　以无疑虑心
  开示于世间　　胜道真言行
  常作如是愿　　宣唱佛恩德
  一切持金刚　　皆当护念汝

犹如字轮旋转相成共为一体。如字轮者印轮身亦然。是故解圆镜漫荼罗义时。即解秘密藏中转法轮义。转此法轮时。以一音声。普遍十方世界警悟众生。故曰吹大法螺也。梵音于普遍字中。即有声义有吹发义。又有令彼普遍闻义。异慧是分别妄想之慧。无疑心即是疑悔永尽住于实智。以住实智故。即能必定师子吼。开示人天无上真言行道法。汝若能发如是愿。于一切处一切时。为报正法大恩。宣布佛之恩德。即是如来所使。行如来事。是故一切持金刚皆护念汝也。复次汝之心王。于初法明道中。成佛转法轮时。已有无量无边金刚智印。周旋翼补共护持之。何况毗卢遮那究竟心王成佛时所有威势。故当为此法故发大精进也

    三昧耶偈(梵本)

阿儞也(二合)钵啰(二合)勃哩(二合)[口*底](从今以后)谛嚩瑳(作佛子也)阿秕贰尾哆(不惜命也)迦罗儜多(半声故也)阿钵[口*履](不应也)[口*底]夜(二合)[歹*勇]系(舍也)萨达摸(正法也)菩提质哆(菩提心也)沫怛钵啰(舍离也一偈)莽(去)瑳(上)[口*履]延(悭也)萨婆达谜数(上声于一切法也)萨怛嚩(二合诸众生也)曩忙(勿也不也)系且者也多(半声利益行也)医帝(此也)三昧耶系(戒也)三勃台(佛也)啰(引)契也(二合引)哆(引说也)萨怛嚩(汝也)苏没啰(二合)哆(善住戒者二偈)曳他(犹如也)娑嚩(二合自身也)贰尾单(命也)落吃铲(平二合护也)怛他蕗吃铲(引二合亦护也)伊迷(如是也)怛嚩(二合)也钵啰(二合)抳钵儞(二合首稽于也)虞嚧(引尊也)始史(二合弟子也汝也)室者啰絮瑜薄吉[口*底](恭敬也)嚩瑳啰(虔诚也三偈)阿[口*驃](毗庾反)闭耶(依教奉行也)萨坦(二合)多(诸有也)萨喇瞒(二合所作也)[嗨-每+(臼/工)]室旨(二合)帝(无也)囊(也)坦啰(疑虑也)坦莽(二合)娜(引心也判偈)

  佛子汝从今　　不惜身命故
  不应舍正法　　舍离菩提心
  悭吝一切法　　不利众生行
  佛说三昧耶　　汝善住戒者
  如护自身命　　护戒亦如是
  应至诚恭敬　　稽首圣尊足
  所作随教行　　勿生疑虑心

前云耳语言告一偈者。犹如僧祇家授六念。萨婆多授五时法。以此验知曾受具戒以不。今此四戒如受具竟已略示戒相。当知即是秘密藏中四波罗夷也。如人为他断头命根不续。则一切支分无所能为。不久皆当散坏。今此四夷戒是真言乘命根。亦是正法命根。若破坏者。于秘密藏中犹如死尸。虽具修种种功德行。不久败坏也。第一戒不应舍正法者。为一切如来正教。皆当摄受修行受持读诵。如大海吞纳百川无厌足心。若于诸乘了不了义。随一切法门生弃舍之心。如声闻乘中。若对堪作法人。心生口言随舍一法。亦成舍戒。虽于具足毗尼不堕众数。然非犯戒之罪。今此秘密大乘。毕竟无有舍义故。则成重罪也。又此一切法门。皆是大悲世尊。于无量阿僧祇劫之所积集。为欲普门饶益一切众生故。而演说之。犹如字轮不可弃一。如声闻乘人随舍一事。犹固和合义断丧失律仪。何况摩诃衍耶第二戒不应舍离菩提心者。此菩提心。于菩萨万行犹如大将幢旗。若大将丧失幢旗时。即是三军败绩堕他胜处。故犯波罗夷也。有人虽爱重三乘法藏心不弃舍。然作是念。无上大乘种种难行苦行。非我所堪。且当于小乘中而取灭度。或云。我当广植善根供养三宝。长受人天福报。无上菩提是普贤文殊诸大人等之所行处。今我何能得之。如是等种种因缘。退菩提愿。即是自断命根。犯波罗夷罪。又此菩提心。毕竟无有可退义。故不同声闻法中。乃至放舍三归退为白衣外道者。佛亦慈悲爱愍听诈也。第三戒者于一切法不应悭吝者。有人虽不舍正法不离菩提心。然于正法悭吝。不肯观机惠施。亦犯婆罗夷罪。所以然者。因如来出世然后有是正法。乃至一句一偈。无非世尊丧舍身命为其僮仆然后得之。是一切众生父母遗财。非独为一众生故。而今窃为已有故。此秘密藏中。同于盗三宝物也。略说法有四种。谓三乘及秘密乘。虽不应吝惜。然应观众生量其根器而后与之。若辄尔说诸深秘之事。令生疑傍断彼善根。则于第四戒中犯波罗夷罪。其直尔悭财不肯惠施者。于十种方便戒中结犯。下品说之。第四戒勿于一切众生作不饶益行者。此是四摄相违法。四摄是菩萨具戒中四依。初受戒时。先当开示此遮难。若能奉行者方为受之。不能奉行。则非摩诃萨埵。不得为受。所以然者。菩萨发一切智心。本为普摄一切众生。为作三乘入道因缘故。而今反作四摄相违法。起众生障道因缘。一切众生亦同字轮之体。不得相离故。随损一一众生善根。或于彼舍饶益行。皆犯波罗夷罪。例如声闻法中。随舍七众一人。即是不和合义。断失具足律仪也。但随烦恼之心。造淫盗杀妄等。而未损彼三乘善缘。犹如声闻法中偷兰遮罪。是方便学处中摄也。次下是阿阇梨教戒之语。佛说三昧耶者。梵本兼有此字。言十方三世佛。共说此三昧耶。同行一如实道。更无异路。今漫荼罗中。一切集会现为证验也。梵云苏没啰多。翻为善住戒者。以其善住三昧耶故。亦名善住戒者。即是异门说佛子之名。如护汝父母生身所有躯命。今爱此法身慧命。亦当如是也。汝今以受具戒竟。当至诚于彼诸尊作礼而退。自今以后凡有所作。当具依真言法教如说行之。同彼新受戒者一切事业。先当问师。勿得卒心专檀令生恶邪疑悔也。复次阿阇梨说持明藏中二部戒本。一一皆是真言。可以成办诸事。如来以此加持诸弟子故。今此中诸偈亦尔。作法时当诵梵本。兼以字门而广释之。尔时金刚手。白佛言乃至同见佛世尊故。是因受具已竟。明真言门中无作功德也。如声闻法中若受具足戒竟。如淫盗杀妄等是一一学处。各于三千大千世界一一众生处。皆得无作功德。福河流注迄至命终。乃至不饮酒戒。于一切众生咽咽。皆生无作功德。坏生掘地戒。于一切草木自金刚际以来。一一微尘各生无作功德。以此因缘故。虽具诸结使凡夫。得与无学圣人。同在应供之数共秉圣事。今此秘密藏中。以初戒故。于十方三世一切正法藏中。皆生无作功德。由第二戒故。于十方三世一切菩萨行中。皆生无作功德法。由第三戒故。于十方三世一切度人门。皆生无作功德。由第四戒故。于十方三世一切众生及四摄事中。皆生无作功德。非独以一期为限量三千为境界也。又声闻一切律仪。因缘造作终。至无余涅槃归于灰断。今此菩萨律仪。本从一切智生。终趣萨婆若海。本末究竟等皆如金刚。又如声闻法中。虽有具足烦恼学无学等阶次不同。然所发无作律仪。则无优劣之异。今此菩萨律仪亦复如是。虽复最初发心乃至四十二地阶次不同。然一时普遍法界。发起无作善根。则与如来更无增减之异。复次如初发心时一切功德。即与如来等。从此以后经无量阿僧祇劫。于一念中恒殊进。转深转广不可思议。以此义故。名为秘密藏中无作功德也。以之经云。金刚手问此善男子善女人。入此大悲藏漫荼罗。获几所福德聚。佛言。从初发心乃至成如来所有福德聚。是善男子善女人福德聚。与彼正等也。此福非一切众生思量分别之所能及。唯有诸佛乃能知之。今但示其入处。欲令领会圆意故。云以此法门当如是知也。譬如轮王太子适在胎藏之中。已能持四天下使福德无减。八部群神皆宗敬之。何况绍灌顶位时所为利益。故佛言。由彼所有福德聚与如来等故。当知即是从佛口生佛心之子。其所在方。即为有佛施作佛事。犹如声闻经中佛说。随舍利弗之所游行。于彼方面我则无事也。一切众生所以供养亲近如来者。以能出生无尽福慧故。而今此善男子善女人所有福德聚。与如来正等。是故世尊以大悲故。嘱累一切众生。若乐于供养佛者。当供养此善男子善女人。若欲见佛者。即当观彼也。初入世谛漫荼罗时所有福德聚。与如来等。初入瑜伽深秘密漫荼罗时所有福德聚。又复与如来等。乃至广说。随入一一地位漫荼罗时。所生福德聚。皆悉与如来等。是中亦有差别亦无差别。以见如是金刚界故。名为金刚手。以见如是法界故。名为普贤。故此上手圣尊。与一切金刚菩萨众。皆共同声说言。我等从今以后。应当恭敬供养是善男子善女人。何以故同见佛世尊故。犹如轮王辅佐。以明识轮王种性故。见出兴世间多诸义利。欲令七宝常不隐没故。皆以至诚。礼敬胎中太子而卫护之。非以矫饰之辞也。瞿醯云。阿阇梨如上所说作护摩已。用净水洒诸弟子顶上。广示漫荼罗位。教彼大印及明王真言。令坐一处持诵之。次教以香花。供养本尊及余诸尊竟。次第而坐。师自诵般若经令彼听之。次为都说三昧耶戒。汝等从今日。常于三宝及诸菩萨诸真言尊。恭敬供养于摩诃衍经。恒生信解。凡见一切受三昧耶者。当生爱乐。于尊者所恒起恭敬。不应于诸尊所怀嫌恨心。及与信学外道经书。凡来求者随力施与。于诸有情恒起慈悲。于诸功德勤心修习。常乐大乘。于真言行勿得懈废。所有秘密之法无三昧耶者。不应为说。大略如此。余如供养法初品中广明。如是教授已。各各示彼本尊真言印所属之部。并为解说本曼荼罗。然后作最后护摩。护摩竟。更如法护身施诸方食。施毕洗手洒净。与诸弟子以香花等。次第供养一切诸尊。诚心顶礼并乞欢喜。复执阏伽。各各以本真言如法发遣。或依本教。或以漫荼罗主真言。一时发遣准同请法。诸供养食当施贫人。不应与狗乌等食啖。所有财物。阿阇梨应取随意受用。若不能用当施三宝。伞拂等施佛。涂香烧香等施法。衣瓶器等施佛及四方僧。若无僧当与七众。其弟子乃至少分不得用之。若用犯三昧耶。如彼广说也。尔时毗卢遮那。复观一切众会。告执金刚秘密主等以下。明漫荼罗法事时所要真言支分。阿阇梨宜应解了故。次说之也。将显示如来语密之藏故。复普观大众而加持之。如生身佛将发诚实言时。或示广长舌相遍覆其面。而告应度者言。汝经书中。颇见有如是相人而出虚妄语不。若摩诃衍中。或示舌相遍覆三千世界。今者世尊将说如来平等语故。明此语轮横竖皆遍一切法界。故曰广长语轮相。此相字。梵本正云漫荼罗。前已开示普门身漫荼罗。今复显示普门语漫荼罗。如如意珠寂然无心亦无定相。而能普应一切皆令称悦其心。故名巧色摩尼。复从巧色摩尼身。出巧色摩尼语。示巧色摩尼心。普雨法财。满法界众生种种希愿。如是应物之迹。常遍十方三世。以无量门植众德本。无穷已时。住不可害行。即是于一切事业中。皆悉不可留难不可破坏之义。故名三世无比力真言句。此是总说诸真言所出生处也。至下文所明大力大护等。即是从如意珠轮所生出称机之用。尔时一切大众。自知心器纯净。又蒙如来不思议加持故堪受大法。即时以无量门。各共同声请佛言。世尊今正是时。善逝今正是时。据梵本。前时名迦罗是长时之时。如一岁有三分等。后时名三摩耶是时中小时。如昼夜六时之中复更有小分等。如有人言。今正是东作之时遇获膏雨。宜趣时下种勿使失其机会。故重言之也。尔时世尊既受请已。将说大力大护明妃。故住于满一切愿出广长舌相。遍覆一切佛刹清净法幢高峰观三昧。此中言出者。梵本正翻当云发生。旧译或云奋迅。出此广长舌相。即是如来奋迅示现大神通力故。会意言之也。此三昧。于如来广长舌相遍满一切佛刹巧色摩尼普门大用中。最为上首。犹如大将之幢。故云清净法幢也。梵云驮嚩(二合)若。此翻为幢。梵云计都此翻为旗。其相稍异。幢但以种种杂彩摽帜庄严。计都相亦大同。而更加旗旗密号。如兵家画作龟龙鸟兽等种种类形。以为三军节度。有处亦翻为幢。故合言之。若具存梵本。当云清净法幢旗也。如大将于高峰之上建立幢旗。备见山川倚伏敌人情状。指麾百万之众。动止言一离合从心。以战必胜以攻必取。若拙将暗于事势又失幢旗。则人各异心败不旋踵矣。如是净菩提心。为万行幢旗亦复如是。住中道第一义谛山上。安固不动。以健行三昧普观十方。悉见无量度门材性优劣所应用处。及与诸地通塞正道因缘故。能得摄持无量功德普护一切众生。凡有所为不可阻坏也。尔时世尊作如是念。我从初发意以来。常以此勇健菩提心。护持正法及与众生。于种种难行苦行事中。犹如金刚无有退转。正为成就如是三昧。普护十方诸佛刹故。今我所愿皆已满足。作所应作正是其时。即时发遍一切如来法界。哀愍无余众生界音声。说此持明法句。若我所言诚实不虚者。其有诵持修习。令其势力与我无异。故名大力大护也。阿阇梨言。明是大慧光明义。妃者梵云啰逝。即是王字作女声呼之。故传度者义说为妃。妃是三昧义。所谓大悲胎藏三昧也。此三昧是一切佛子之母。此佛子者。即是清净法幢菩提心。如彼胎藏始从歌罗罗时。含藏覆护。令不为众缘所伤。渐次增长乃至诞育之。后犹固勤心守护而乳养之。是故说母恩最深难可报德也。从此三昧起者。入住出时皆是不思议法界。非如世间禅定。动寂相碍有退失间隙时也

南么萨婆坦他(引)蘖帝[口*弊](毗也反一)萨婆佩野微蘖帝[口*弊](二)微湿缚目契弊(三)萨婆他唅(四)欠啰吃沙摩诃沫丽(五)萨婆怛他蘖多(六)奔昵也儞(入)阇帝(七)[合*牛][合*牛]　怛啰磔怛啰磔　阿钵啰底诃帝　莎诃

初句归命一切诸如来。次句能除一切诸障恐怖等。是叹如来一切大力大护之德。又次句叹无量法门。毗湿嚩亦是巧义。所谓无量巧度门。即是法幢高峰观三昧普门业用。今欲说此明妃故。先归敬一切如来如是功德也。次云萨婆他。是总指诸佛如是功德。欲令同入一字门故。次有唅欠两字。正是真言之体。亦名种子。以下诸句皆转释此二字门。诃字是因义。所谓大乘因者即是菩提心。以一切因本不生故。乃至离因缘故。名为净菩提心。是成佛真因正法幢旗之种子。上加空点是入证义。所以转声云唅也。佉是大空。上加点转声为欠。即是证此大空名为般若佛母。正是明妃之义。于此虚空藏中含养真因种子。即是大护义也。复次佉字门。犹如虚空毕竟清净无所有。即是高峰观所知境界。诃字是菩提幢亦是自在力。以此二字相应故。犹如大将能破怨敌。又诃字门是菩提心宝。与佉字门虚空藏和合故。得成巧色摩尼。能满一切希愿。今此真言中阙此欠字。下文具有也。次句云啰乞叉即拥护义。如人恐怖厄难若恃怙有力大人。或得高城深池之固。则泰然无虑。彼诸怨敌虽以种种方便。无若之何。行人亦尔。依倚菩提心王。以般若胎藏为城郭。犹如虚空不可破坏。即是转释前义也。次句摩诃沫丽。翻云大力。诃字菩提心中。具足一切如来力。今与佉字合故。离诸系缚无复挂碍。如虚空中风自在旋转。故名大力。又诃字自在力。与佉字无量巧度门合故。犹如力士具足千种伎能。是故众人无能胜者。故名大力也。第七句释此大力所由。故云从一切如来功德生。言此大坚固力。本犹诸佛金刚种性生。又于无量劫以来。常以此诃字真因。具修法字万德。一一皆如金刚不可破坏。今众德已满诸力悉备。复当以此法幢高峰观三昧。大摧法界怨敌普护众生。次即发诚实语。所谓[合*牛][合*牛]字也。[合*牛]是恐怖彼声。所以重言之者。一摧外障一摧内障。复次外是烦恼障内是智障。若释字门。如来以何法恐怖诸障耶。谓即以此诃字门也。下三昧画即是具修万行。上有大空点即是已成万德。诃字即是法幢旗三昧。空点合故即是高峰观三昧。诃字是一切如来种子者。上点是明妃之母。下画是胎分日增。如是义故。适发声时魔军散坏也。次云坦啰吒。是叱呵慑伏之义。如师子奋怒大吼时众兽无不慑伏。亦重言者。是对根本烦恼随烦恼。乃至对治一切烦恼。界内烦恼界外烦恼也。末句云阿钵啰[口*底]诃谛。是无对无比力义。结持上文。以此因缘故。名为大力大护明妃也。莎诃是警觉诸佛令作证明。亦是忆念持义。如前已释

经云。时一切如来及佛子众说此明已。即时普遍佛刹六种震动者。谓大日如来发此普遍法界声时。一切诸佛菩萨。以无二境界故。皆悉同声而共说之。今此所加持句威势具足。又以如来诚谛言故。即时十方佛刹六种震动。以明佛之大誓真实不虚也。六种震动义。余经具说其相。今依此宗秘密释中。六种谓贪嗔痴见慢疑六根本烦恼。一切众生心地。常为此重垢所持不能自起。今以世尊至诚之所感动。悉皆甲坼开散佛种萌生。故云六种震动也。尔时一切菩萨。见此浅略深秘二种地动因缘。无不心自开敷。得未曾有。以微妙偈称叹大日世尊。而经云。于诸佛前者。谓佛说此明时。十方世界诸菩萨等。各见彼佛前亦皆说之。是故同一音声俱时领解。即寄此文证成大护之威力也。领解偈中。诸佛甚奇特者。具存梵本。应言奇哉一切诸佛。说此大力护。即是一一世界诸菩萨。皆悉同时领解十方一切诸佛所说真言也。以十方诸佛共护持故。犹如金刚城重固高不可升。又环以汤池深不可越。是故一切诸作障不能侵陵也。由彼护心住者。谓诸行人能以此真言密印。守护身心而住。是故所有为障者。诸毗那夜迦恶形罗刹等自然退散也。又此住字若依梵音。亦在名。为镇在其心。若作深释者。言此净菩提心人。以此明妃实义护心而住。是故三种重障诸恶罗刹等皆悉驰散。不能伤彼善根。下至生心忆念时。亦有如是力势故。末句更结成也

经云。薄伽梵广大法界加持。即于是时住法界胎藏三昧。从此定起。说入佛三昧耶持明者。梵音毗富罗是广大义。谓深广无际不可测量。如是诸法自体。名为毗富罗法界。诸佛实相真言实相众生实相。皆是毗富罗法界。以此更相加持故。名为法界加持。复次如男女交会因缘。种子托于胎藏而不失坏。即是相加持义。如是诸佛国王明妃和合。共生毗富罗种子。为大悲胎藏所持无有失坏。故名法界加持也。世尊普遍加持一切众生。皆作平等种子竟。即时入于遍法界胎藏三昧。观此一一种子。皆是莲花台上毗卢遮那。普门眷属无尽庄严。亦与大悲漫荼罗等无有异。而诸众生未能自证知。故名在圣胎俱舍。若出藏时。即是如来解脱也。世尊如是现观察已。即时从三昧起。说三昧耶持明。三昧耶是平等义是本誓义是除障义是惊觉义。言平等者。谓如来现证此三昧时。见一切众生种种身语意。悉皆与如来等。禅定智慧与实相身亦毕竟等。是故出诚谛言以告众生。若我所言必定不虚者。令一切众生发此诚谛言时。亦蒙三密加持。无尽庄严与如来等。以是因缘故。能作金刚事业。故名三昧耶也。言本誓者。如来见证此三昧时。见一切众生悉有成佛义故。即时立大誓愿。我今要从普门以无量方便。令一切众生皆至无上菩提。剂众生界未尽以来。我之事业终不休息。若有众生。随我本誓发此诚实言时。亦令彼所为事业。皆悉成金刚性。故名三昧耶也。言除障者。如来见一切众生悉有如来法身。但由一念无明故。常在目前而不觉知。是故发诚实言。我今要当设种种方便。普为一切众生决除眼瞙。若我誓愿必当成就者。令诸众生随我方便。说此诚实言时。乃至于一生中。获无垢眼盖障都尽。故名三昧耶也。言警觉义者。如来以一切众生皆在无明睡故。于如是功德不自觉知。故以诚言感动令得醒悟。亦以此警觉诸菩萨等。令起深禅定窟学师子频申。若有真言行人说此三昧耶者。我等诸佛亦当忆持本誓不得违越。犹如国王自制法已还自敬顺行之。故名三昧耶也。持明者梵云陀罗尼。明谓总持一切明门明行。乃至尽此三昧耶誓愿以来。终不漏失。故名入佛三昧耶持明也

南么三漫多勃陀南阿三迷呾[口*履]三迷三么曳娑诃

初句自归命一切诸佛。如上释。次句云无等次云三等。连下句言之。即是无等三平等三昧耶也。复次阿是诸法本不生义。即是法界体性。娑是谛义。迷是三昧义。么是自证大空亦是我义。世尊证此三昧时。谛观一一众生心力普门漫荼罗皆等于我。是故更无待对无可譬类。名为无等也。三等为三世等三因等三业道等三乘等。即是转释前句。所以无等之意。呾[口*履]谓心如实相。一切尘垢本来不生。三世如来种种方便。悉皆为此一大事因缘故。即是除障之义也。结云三昧耶者。即是必定师子吼说诸法平等义故。立大誓愿当令一切得如我故。欲普为众生开净知见故。以此警觉众生及诸佛故。是故此三昧耶。名为一切如来金刚誓诚。若不先念持者。不得作一切真言法事也。世尊以遍满一切佛刹身语心轮。说此三昧耶已。一切诸佛子众无不闻之。既闻是已。于一切真言法中不敢违越。所以然者。若菩萨于众生诸法中。作种种不平等见。则越三昧耶法。若于此平等誓中。作种种限量之心。亦越三昧耶法。诸有所作随顺世间名利。不为大事因缘。亦越三昧耶法。放逸懈怠不能警悟其心。亦越三昧耶法。以越三昧耶故。有种种障生。自损损他无有义利。是故诸菩萨等。奉持此三昧耶如护身命。不敢违越也

经云。时薄伽梵复说法界生真言者。世尊前入法界胎藏三昧时。见一切众生悉有菩提种子等同诸佛。故说入佛三昧耶持明。以此持明得入佛平等戒。即是托圣胎义也。尔时世尊复以普眼。谛观一切众生皆悉圣胎具足生在佛家。尔时无尽庄严亦复与如来等。从此三昧起已。即说法界生真言。又以普眼谛观见此一一众生金刚事业具足成就。尔时无尽庄严亦复与如来等。从此三昧起已。即说金刚萨埵真言。故此三种皆名三昧耶也。复次由入佛三昧耶故。于胎藏中不令夭折由法界生故。初出胎时离诸障碍。由金刚萨埵故。能转家业备诸伎艺。又以入佛三昧耶加持秘密中胎藏。以法界生加持金刚菩萨二重眷属。以金刚萨埵加持种种随类之形。入佛三昧耶如莲花藏。法界生如莲花敷。金刚萨埵如莲花成就复还为种。故此三种皆名三昧耶也

南么三漫多勃陀喃达摩驮赌萨嚩婆嚩句痕

达摩驮睹是法界义。萨嚩婆嚩是自性。亦名本性。句痕是我义。其句义云我即法界自性也。以必定师子吼。言我及一切众生皆是法界自性。是平等义。我当设种种方便。令一切众生皆悉证知。是本誓义。以知我即法界自性故。能除一切分别开净知见。是除障义。诸佛唯愿忆持本愿故。令我此身即同毗卢遮那法界自性。是惊觉义。当以字门广释之

南么三漫多伐折啰赧伐折啰呾么句痕

初句将说金刚萨埵真言。故归命一切金刚。即是从无量门持如来金刚智者。皆令忆持护念也。次句云伐折啰呾么句痕。谓我身即同金刚也。金刚即是法界自性。以成就大坚固力不可沮坏故。异门说为金刚。如来以普眼观一切众生金刚智体与我无异。是平等义。以众生不自觉知故。从无量金刚智门。作种种金刚事业。要摧如是大障令至实际。是本誓义。如是实际名为无垢眼金刚眼。即是除障义。以此师子吼声震动十方佛刹。即是警觉义。故名三昧耶也。复次真言行者。以初三昧耶故。得同如来秘密身口意平等之身。以第二三昧耶故。得同如来加持法界宫尊特之身。以第三三昧耶故。令此身土皆如金刚。与无量持金刚众而自围绕。佛说初三昧耶。为自受用故。第二三昧耶为成就法性身诸菩萨故。第三三昧耶为折伏摄受随类众生故。佛说初三昧耶为建立大悲胎藏漫荼罗故。第二三昧耶为作毗卢遮那阿阇梨事业故。第三三昧耶为执金刚弟子事业故。初三昧耶为加持如来眷属故。第二三昧耶为加持莲花眷属故。第三三昧耶为加持金刚眷属故。是故佛说三三昧耶也。次说金刚铠真言者。为庄严金刚萨埵身故。行人已发金刚誓愿。欲为一切众生摧灭诸障故。以牢强精进被服金刚甲胄。且如六波罗密一一如实相。皆如金刚不可破坏。又一一度中皆具五度。是故周体密致无有间隙。如六度者。三十七品十八空百八三昧五百陀罗尼等。皆当广说。以被如来金刚甲故。旋转六道出生入死。一切烦恼业苦所不能伤。若就浅略释者。由行人以此真言自加持故。一切诸天龙等。见皆同于金刚萨埵身。遍体皆被金刚甲胄。坚密无际光如猛焰。是故一切为障者。皆不能伤也

南么三漫多伐折啰赧伐折啰迦嚩遮[合*牛]

伐折啰是金刚。迦啰遮名甲。如来以金刚眼普观众生。无不被此金刚甲胄。是故以诚实言而演说之也。以最初嚩字为真言体。嚩是诸法离言说义。若是戏论言说所行处。悉皆可破可转无有坚固。是故以嚩字为体。次字皆转释之。何故诸法离言说。以生不可得故。何故生不得。以自性清净故。自性清净即是金刚萨埵身也。次明甲义。若法是造作故所成。当知但有假名。从缘迁变尚不能自固其性。况能蔽捍六尘利箭耶。今观金刚体无尽庄严。皆悉离诸造作。是故坚固不坏。百非所不能干。是故名为金刚甲胄。末后[合*牛]字即是无所畏声。亦是自在力义亦是欢喜义。以定慧具足证此诃字门时。自知必能摧坏诸障普护众生。是故大欢喜也。次说如来眼真言者。如金翅鸟王威力具足羽翮完坚。又得极明利眼于虚空中。俯观大海如视镜像。则能随意自在搏获诸龙。当知真言行人亦复如是。以此如来净眼自加持故。漫荼罗海会当现其前。备见一切根缘及遮道法。由此金刚事业随意皆成。故次说之也

南么三漫多勃陀喃怛他揭多斫吃刍尾也嚩路迦也莎诃

右句义中。怛他揭多斫吃刍是如来眼。次云尾也嚩路迦也是观义。言以如来眼观也。用最初多字为体。多是诸法如如义。以一切法本不生故。即此如如亦不可得。是故如来观一切法毕竟非如非异。虽不可见而亦明见。如诸佛者诸众生眼亦然。若行者说此真实语时。则蒙不思议佛眼加持。渐得眼清净也

次有涂香等六种真言。皆是入漫荼罗修供养时所要故。于此品中说

南么三漫多勃陀喃微输驮健杜纳婆嚩莎诃

右句义中。微输(上)驮是净义。健杜是香。纳婆嚩是发生义。所谓净香发生也。以句初微字为体。于嚩字上加伊字之画。是故转声为微。嚩字是金刚义离言说义。三昧是住义。如是定慧均等。即是住无戏论执金刚三世无障碍智戒。如是戒香。其性本寂无去无来。而常遍满法界。故名净涂香也。一切众生虽复等共有之。然以未发心故。此香未发。我今已用此戒香遍涂法身。故能净香普熏一切也

次华真言

南么三漫多勃陀喃摩诃妹呾[口*履]也毗庾檗帝莎诃

右句义中。摩诃妹呾[口*履]也。是大慈义。毗庾檗帝是生义。所谓大慈生义也。以昧字为真言体。即是莽字加三昧画。是故转声呼之。莽是心义我义。亦名大空。言此心莲花。为妄我所缠不得增长。今自证知心实相故。从慈悲藏中。八叶须蕊次第开敷。故曰从大慈生也。复次净菩提心树王种子。从慈悲地中。滋长茷盛开万德花。以方便故成实。故曰从大慈生也。当以字门广释之

次烧香真言

南么三漫多勃陀喃达摩驮赌弩檗帝莎诃

右句义中。达摩驮都是法界义。弩檗帝是随至义。亦是遍至义亦是逝义进不住义。译云遍至法界也。以句初达字为体。以众生界本不生故。乃至法界定相亦不可得。如是法界。深广无际不可度量。而瑜伽行人。恒殊胜进不休息故。身语心业悉遍如是法界。下至一花供养佛时亦遍如是法界。即是烧香义也

次饮食真言

南么三漫多勃陀喃阿啰罗迦罪罪沫邻捺娜弭沫邻捺泥摩诃沫履莎诃

右初云阿啰啰。是不可乐闻声不善声义。如人高声喧聒。令听闻者心不寂静。次云迦啰啰。是止前不善高声。是恬漠寂怕之义。此中正以法喜禅悦为食义。是故寄此言之也。若就字轮之相。阿是本初义。以有此本初则有二种尘垢。谓烦恼知障也。由此二种尘垢故。则有戏论喧聒之声。今以诸法本不生故。二种尘垢亦本不生。即是开甘露门成涅槃饭。故名阿啰啰。复次若人勤修万行。望得如是法味。以造作故二障还生。非是常命色力真甘露味。今以诸法无造作故。内证之味不从他得。如食乳糜更无所须。故云止前不善声也。沫邻捺娜弭者。凡西方享祭之食。上献诸佛下及神鬼通名沫[口*梨]。其句义云。我已饮食奉献也。次云沫邻捺泥者。此意言。受我所献食已。当还与我妙食。如世间人以肴膳奉施福田。为令今世后世饮食无乏。故今以无尽法食。加持世间之供养奉施诸尊。还当与我所愿。令常充足不死不生之味也。次云摩诃沫履者。即是于诸食中倍加广大丰美。以此料简上句。云我今所献及与所祈。皆在极无比味无过上味。不求有量之食也

次灯明真言

南么三漫多勃陀喃怛他揭多唎旨萨叵啰儜阿嚩婆娑那伽伽猱陀哩耶莎诃

右句义中。怛他揭多是如来。喇旨是焰明。次云萨叵啰儜是普遍。阿嚩婆娑娜是诸暗。伽伽猱陀哩耶是无限量等虚空。意言。如来焰光普遍诸暗。等同虚空无有限量也。此真言以句初多字为体。如于心之实相。即是毗卢遮那大智明。普照世间无所不遍。言诸暗者即是无明。以无明本不生故体即是明。是故如来光明普遍诸暗。言等虚空者。以无明等虚空无量故。如来智光亦等虚空无量。乃至老死如虚空无量故。如来智光亦如虚空无量。如十二因缘者。一切诸法亦如是说。如是决定义故。名为灯明真言。以此加持灯明而供养佛。即是诸供中最也

次阏伽真言

南么三曼多勃陀喃伽伽那娑摩阿娑摩娑诃

右句义中。伽伽那是虚空义。娑摩是等义阿娑摩是无等义。所谓等虚空无等也。如来法身。本性净故无分别故无边际故。等同虚空。然复有无量无边不思议功德。非彼虚空。所能譬喻。故云无等也。复次阿娑摩是不等义。不等者所谓二乘。今既等同虚空。又等此无等故云等虚空无等也。以最初伽子为真言体。众生界中来去亦不可得。法界中来去相亦不可得。以如来如去不可得故名为大空。以此大空性净之水。用浴无垢之身。是为阏伽真实之义也。

次下有四真言。亦是曼荼罗阿阇梨庄严之相。故于此品中说

初如来顶相真言

南么三漫多勃陀喃伽伽那阿难多萨发啰儜毗输驮达摩儞阇多娑诃

右句义中。伽伽那阿难多是虚空无量。萨发啰儜是普遍。毗输驮是清净。达摩儞阇多是法界生义。此言如来顶相。犹如虚空出过数量普遍清净。当知如是顶相。从法界胎藏生。非从世间父母胎藏生也。此真言亦以伽字为体。言如来髻相。无去来相同于大空。而一切众生以去来相观之。是故周于十方不能见其边际。若行者以必定心。自知我之顶相亦复如是。是名佛顶真言也。阿阇梨自作毗卢遮那时。解髻而更结之。若出家人应以右手为拳置于顶上。然后说此真言以加持之。则一切诸天神等。不能见其顶相也

次如来甲真言

南么三曼多勃陀喃伐折啰入嚩罗微萨普啰吽

右句义中。伐折啰入嚩罗是金刚光。微萨普罗是普遍义。言此金刚智光普遍一切。能除生死暗障。亦能映夺之者。则是如来甲义也。此真言以最后[合*牛]字为体。具足三解脱门。谓上有曩字空点是大空义。即是空解脱门。本体是诃字离因缘故。即是无相解脱门。下有邬字三昧画。以本不生故即是无作解脱门。如是三门。一切诸障所不能入。以此慧光遍严身故。名为如来甲也。捡密印。其中梵本似有残缺。疑此是金刚萨埵圆光真言。更当访余梵本

次如来圆光真言

南么三曼多勃陀喃入嚩罗摩履儞怛他檗多[口*栗]旨[卄/娑]诃

右句义中。入嚩罗是焰光义。摩履儞是鬘义。以焰为鬘轮环不绝。故名如来圆光也。次句云怛他檗多[口*栗]旨。是如来光明义。此是明白之光。梵音与焰鬘之光其名不同。正用此[口*栗]旨字为真言体也。上有啰声是尘垢义。下体遮字是迁变义。以入阿字门故。即是本无尘垢亦不迁变。即是如来常寂之光。又带伊字三昧声。言此常寂之光定慧具足。是故寂而常照照而常寂。阿阇梨以此加持身故。一切诸天神等。如来焰鬘遍被其体。威猛难睹犹如日轮。是故诸为障者不得其便也

如来舌相真言

南么三曼多勃陀喃摩诃阿摩诃(二)怛他檗多尔诃嚩(二合)萨底也(二合)达摩钵啰底瑟耻(二合)多[卄/娑]诃

右句义中。摩诃阿摩诃是大无大。义怛他檗多尔诃嚩是如来舌义此舌广长之相遍覆一切佛刹。故名为大。此大更无过上故。无可待对故。大相亦不可得故。名为无大。次云萨底也(二合)是谛。达摩是法。钵啰[口*底]瑟耻多是成就。译云成就实谛法也。如来无量劫来。常修真实谛语故。得此平等语轮。成就实谛之法。所发诚言必定无异。故以最后多字为真言体。明如来所有语言。常如实相无诳无异也。阿阇梨以此加持身故。转说法教皆如金刚。乃至能以一音遍诸佛刹。凡此诸真言等。皆当以字门广释之

    息障品第三

尔时金刚手。又复白佛毗卢遮那问世尊。云何曼荼罗画时。为障者得除息。真言等持诵者无恼害。云何持诵真言果彼云何。此毗卢遮那如来所加持故。金刚手承佛神力断大众疑。及为未来众生复发此问也。大毗卢遮那世尊言。善哉善哉大众生能发此说。为大利益诸众生故。我今当为开示一切随汝所问也。佛言障者自心生。由昔悭随顺。为彼因除故。菩提心此念。若分别除心思有。菩提心念忆。持诵者离诸过者。佛言。一切障法虽复无量。以要言之但从心生。又由行者过去世随顺悭法故。今世多有诸障。当知亦是从心因缘生也。当知彼悭贪等是诸障之因。若除彼因诸障自息。此中对治即是菩提心也。若念菩提心故。即是能除诸障之因也。又复一切诸障由分别生。此之分别由从妄心。思有者思即是障。谓心中烦恼随烦恼等。此中有字。梵音亦云生义也。心思有若能离诸分别。即是净菩提心。由行者忆念此心。即能离一切过也。意常思惟不动大有情。能除一切为障者。彼当结此密印者。此即是前所说不动明王。此是如来法身以大愿故。于无相中而现是相。护一切真言行者。若行者常能忆念能离一切障也。所谓不动者。即是真净菩提之心。为表是义故。因事立名也。此明王闭一目者。有深意也。以佛眼明鉴唯一而已。无二无三也。其印下当说之。秘密主风当诵阿字门。亦有意。正取阿字为身。以此本无之字门而作我身也。无我作诃字心诵。涂香点作地七点。此风先想诃字在中。加七点而后盖之也。方依嚩庾。以瓦碗盖合之。于此瓦器大众生弥卢思念。时时彼上阿字并点作。是风大缚继先佛所说。谓造立坛时。或有大风为障。以露地立法故。当须止之。当想此阿字遍于身分之内。此字作金刚不动色。谓真金色也。如是想已。又心诵诃字。于风方(西北也)用涂香于地。画作七小圆点。各如弹丸许大。如是作是用瓦器盖之。于瓦器心想。即是上想阿字。以此字为金刚山而押之也。三千大千诸须弥山。合为一体而盖其上。又当时时器上作此字。此阿是金刚不动义。加一点是遍一切处。令此金刚不动遍一切处。即是增广之义也。水障法当思惟啰字。遍于身内作赤色大力焰。即是火焰之鬘。从内身而出遍于身上如鬘也。作大力可畏恶形。手执大刀印。作嗔形已画地作云像。或作龙蛇之像。用刀印斩断其形云即散灭。以云是诸水之所因依故也。随所起障之方而作之。如雨从东来即于东方作也。或作金刚橛用止此风雨。其橛用佉陀罗木作独股金刚。以金刚真言加持之。想同一切金刚而以打之。亦随所在方面也。此应自身同于一切金刚。然后作之。作此橛是一股金刚。三股除边支股即是也。其小者名金刚针。或一切障息。复说念真言。大恶不动大力本漫荼罗中住。持诵者作漫荼罗。中作形像。于彼顶左脚蹋彼。当除息去死。无疑惑者。复更明异方便。方便除一切障也。即是前所说不动明王。此不动明王本漫荼罗。即是三角漫荼罗其中黑色是也。持诵者想己身作不动明王之像。又于此中作法有二意。一者想不动尊在圆中而蹋彼上。也二者想自身是不动尊。即以本真言印加之。而蹈其上也。三角中画彼为障者形。然后入中。以左脚蹈彼顶上。以大忿怒形加之。彼当应时退散。若彼违戾不受教不去者。乃至必自断其命根。是故持诵者。当生慈心念言。勿令彼断命也。然此中密意。所谓为障者。即是从心所生悭贪等法。能为行人作一切障事。今此不动明王。即是一切智智大菩提心。当知此心即是大力威猛。能永害一切随眼等过。令彼永断。即是死义也。如瑜伽所云说。佛初成正觉。大集会一切漫荼罗所摄三界之众。有摩醯首罗者。即是三千世界之主。住三千界之中。心慢故不肯从所召命。而作是念。我是三界之主。更有谁尊而召我耶。复作是念。彼持咒者畏一切秽。我今化作一切秽污之物。四面围绕而住其中。彼所施咒术何所能为。时不动明王承佛教命召彼。见其作如此事。即化受触金刚(即是不净金刚也)。令彼取之。尔时不净金刚。须臾悉啖所有诸秽令尽无余。执令彼来至佛所。彼复言尔等是夜叉之类。而我是诸天主。何能受尔所命耶。寻即逃归。如是七返。尔时不动明王白言世尊。此有情何故犯三世诸佛三昧耶法。当以何事治之。佛言即当断彼也。时不动明王即持彼。以左足蹋其顶半月中。右足蹋其妃首半月上。尔时大自在天寻便命终。即于尔时于闷绝之中。证无量法而得授记。于灰欲世界成佛号月胜如来。此皆秘语也。食一切秽。是啖彼恶业烦恼等垢秽滓渭之法。云命终者。是彼一切心法永断。入无生法性故于中得一切佛记。非是杀也。尔时诸天等。见三千世界天主。以不顺诸顺三昧耶故自取命终。一切敬畏自相谓言。天主尚尔我云何不往。即共诣佛所。于大漫荼罗中而得法利。时不动明王白佛言。此大自在天当更云何。佛言汝应起之。时不动明王即说法界生真言。尔时大自在者即复苏息。生大欢喜白言。甚希有也。我初召至已问佛。此夜叉是何等类我所不解。佛言是诸佛之主。我作是念诸佛一切之尊。云何以此而更为主耶。是我所不解。今乃知之。由此大王力故。令我现前得记作佛。当知实是诸佛之尊也。所以然者。大自在天三千世界之主。即是众生自心。所谓无始无明住地。于诸惑中而得自在。唯除大菩提心无能伏者。断其命已。即是于寂然界作证。所谓生者。即是起佛慧门。是故真言行者。应一一思惟诸佛密语也。又法用芥子及诸毒药。二种相和。作彼为障者形像而用涂之。令彼身如火烧速被中伤。故云速被着(惠略也惠命也)略乃至大梵等为障尚被着。何况余耶。又凡此法。皆是久持诵得成就者。解法则乃能作之。若但闻法。即求得如是用。无此理也。其佉陀木橛。必无此木。用苦练木乃至用宾铁。亦得耳。足是智足也。尔时金刚手白佛言。如我知佛世尊所说义。我亦如是知自漫荼罗位住。世尊尊主现威令作彼位。如是如来教敕不敢隐弊。何以故。以此佛三昧耶。一切诸真言所师。谓性住者。谓金刚手白佛言。此大力不动明王(即是尊主也)能作如是威猛之事。能为调伏。为传如来秘密之教令使。如本尊是佛部。即坐金轮中之类。若如是作必令有灵验。此之现威即是效验之语也。令作者。今谓若如是作必令有效也。诸生死中普得闻知。不敢隐弊此真言。是故持金刚者。大力威猛所不敢隐弊。谓此尊有灵验故所作善事皆成。诸为障者不敢隐弊如来所教敕也。应作事。此亦即是十方三世佛三昧耶。我等一切执金刚。亦应作所应作。随此三昧不敢失坠。何以故。此即是诸金刚姓。是故常住斯法。四姓等各各有家法。若失家法。则不名敬顺先祖父之教。世人名为恶子。今此大雄猛调伏难调宣布难信之教。是我金刚等家姓之法。所谓如来种家之家法也。是等真言门菩萨。修行等菩萨。本位住一切事作者。是金刚手以身劝勉行人之意。我等所应作事。若修行持真言者。亦当住此位。所谓如来家法。应以无量门降伏诸障。令如来法无敢隐弊也。此行人亦放诸尊。若欲作降伏。即须自身作不动尊住于火轮中等。佛言如是。秘密主如是如说。即是印可诚如汝所言也

大毗卢遮那成佛经疏卷第九大毗卢遮那成佛经疏卷第十

        沙门一行阿阇梨记

    息障品第三之余

秘密主若说诸彩色诸漫荼罗彼尊尊色。先佛所说者。谓本尊各有形色。下当更说之。如上说随本位而作事业。今复说色也。谓于会中所有诸尊。若见其黄色即应坐金轮中。白即坐水轮。赤火黑风也。次下有色字梵音别。此是形相也。如见寂然貌即须坐圆檀等。类而说之。应一一依教而画。是古佛所说。其道玄同非我故说。欲令众生起决定信也。秘密主。未来世当有众生。劣慧不信闻此说。以先无信根故。闻此而能不信也。无慧疑增多者以此众生等钝根少智信不具。故闻此甚深之事不能晓了。更增疑网。此即说为障所由也。如是真言画及持诵等。一一皆有深意。尽是如来不思议事。如人得如是药。即能升空或入火等。此但众缘合故决定不虚。非是不虚。非是诸人所应筹量说其所以也。如此画色等。若依法不疑。乃能深入法界不思议境。此唯信者得入。若欲以心数卜量。云何得知所以而不疑耶。如世人得药飞空。此事汝尚不胜能具解。而心愚轻毁。谓非如来真空无相之法。徒自伤也。闻唯坚住不修。彼自损损他。如是说有外道法等。如是非佛说者。是人虽闻此法。不能决定信心。如说修行而求现验。以不能故而生谤言。云何以如是着相之法。而能成菩提。此必是外道等说。非佛法也。如人得天甘露。但当决心生信而服之。自见现验。口不服之而求白日升天。以不得仙知故。而谤此药。当知非智人也。故彼无智人如是作解。一切智佛一切法已得自在众生利。此已字亦云通达。是正义也。谓具方便无事不解之义。已彼先此一切说。梵音回互也。上文已明诸佛。今此下句。方云先佛作如是说。已彼此一切说利益求者。彼愚夫不知诸法相空。一切诸法相说。常当住真言业作。善无疑者。此意言。如来具一切智。于诸法中而得自在。以众生劣慧。未堪顿说如来自体不思议力用故。作此画色等方便。令诸众生随所作者。能满所求而得利益。所以然者。以诸众生未解诸法空相。是故于无相中而作有相方便说之。若人得佛深意者。当住真常住之行。诸有所作皆。入理体同于一切智智之心。如是无疑虑者。一切障法无得其便也

    普通真言藏品第四

尔时执金刚中。金刚手为上首。菩萨中普贤等为上首。于佛毗卢遮那稽首。于大悲胎藏生大漫荼罗王。如所通达法界清净门。各各广语句真言说乐欲佛请者。是诸菩萨金刚。为欲圆满成就此法故。各各稽首大日如来已。于自心以通达清净法界法门。各各乐欲自陈说之。所以然者。如是大漫荼罗王清净法界之体是。一一菩萨。各从一门而得自在。称其所解而广说之。若有众生。从彼一门而进行者。不久即得同彼菩萨。此诸菩萨。皆是大日如来内证之德。为欲广开是知见门故。一一菩萨各演一门也。尔时佛彼执金刚及菩萨。无尽法尔加持告。诸善男子。说如所通达法界。众生界净除真言句者。时佛随彼所请。以此无尽。或可云无害或可云不动或。可云不坏。以下义为正也。如人论堕负不可复救。复有人能离彼过失他不能伏。不坏义如此也。无尽庄严自在之力。法然所得无功用力。而普加持彼诸大众。然后告言。善男子今可说之。如汝自所通达法界之门。为欲净除一切众生界虚妄之垢。悉令同彼真法界无尽藏故。各当自说真言之句也。时普贤菩萨。即于佛庄严境界三昧住。无碍力真言说者。诸菩萨中彼为上首。于此佛境界庄严法门而得自在。即时入此三昧也。佛境界者。此是诸佛自证真实境界。非声闻等所能及之。如法花方便品中所说。庄严者。即是如来自证之体。体有无量德。德各无量名。以无量庄严而自庄严也。此即是不思议离名字法。云何在此定中。而得有言说耶。谓彼菩萨住此三昧故得无碍力。从其自心面门发种种光。光中说此真言也

三曼多(等也)奴[王*曷]多(进义也去也往也)微啰阇(微是离也啰阇是尘垢也谓除一切障也)达摩儞阇多(上句法也。下三字生也何等法生谓从诸法体性而生也)摩诃摩诃(上声摩是第五字遍一切处谓大空也空中之大名为大空故重言之更无可得为等比者故名为大重空之中更无比也)

此意言。等者即是诸法毕竟平等也。进者是逝义。谓佛善逝而成正觉。然此平等法界无行无到。云何有来去耶。次即释言。以能离垢除一切障。即是胜进之义。无行而进最为善逝也。以如是进行能成法生。即是从平等法性而生佛家也。故次言大中之大。即等等无碍证中大空。大空者佛境界也。然此真言以诃字为体。诃者喜也。所谓修行菩萨修也。若众生从此法门。而受持读诵或观照者。即同普贤之门。不久能得佛境界庄严三昧自在之力。时弥勒菩萨。住于普遍大慈发生三昧自心说者。普谓平等。遍满一切法界也。称于法界而生大慈。能遍与一切众生正法之乐。是彼所入门也。如其自所进达。入于三昧而说真言。故言自心说也。说义亦如上

阿誓单阇邪(此谓无能胜也阇邪是胜阿是无)萨缚萨埵(一切众生也)阿奢也(心性也谓彼先世所习行诸根性欲)奴竭多(知也谓能了知众生诸根性行)

然此真言以阿字为体。即是本不生义生。者生老病死一切流转之法彼。即体常自不生是阿字义也。以知诸法自性不生。是故诸一切众生为无有上胜。上无等也。又能知法体不生故。达鉴群机一切心性。无所不了现觉。随彼所应得者而成就之。即是慈中之上。遍施众生无有穷尽也。是故若有众生。能通达受持读诵此法。行行者不久即同弥勒之行也

尔时虚空藏菩萨。入清净境界三昧自心说者。所谓住此三昧。能知自心本性清净。了达如是清净法界之境。即是大空之秘藏也。又此虚空藏。即是大悲胎藏。能长养成就菩提。之心也

阿(长)迦奢(是虚空义也)三曼多(等也谓一切法等于虚空也)奴竭多(了知也)吠质怛缆(二合)(杂色衣也。是种种奇妙显色之义也)嚩(伐)啰(衣也)驮(是执持义也)啰(被着也此德生即是被种种衣也)

此真言以阿(长)字为体阿(长)本不生体。今此阿(长)是第二声。即是空义。以本不生故同于虚空也。即是一切法皆等于虚空。自得如是了知也。杂色衣。即是种种万德庄严法门。若人能证此空三昧。即能万德庄严其身。如净虚空明睹显色也。余准前说　尔时除一切盖障菩萨。入悲力三昧真言说者。即是法性之悲。以自在力能除一切众生一切盖障。于此障中而得自在能住此盖障中又能除之。即是如来大悲也

阿(引)(降伏义。摄伏义此是真言体也。阿字本不生长声第二字是金刚三昧又加不动之点是降伏义也)萨埵系多(有情利益也)骠庾竭多(发起也起生也)呾缆呾缆(二合)(怛即多字如如义也缆有罗字是无垢义加一点是么字即是大空入证也)缆缆(中罗字无尘义。加一点即是大空证也)

此真言意云。体于如如。以此自在之力。而除一切尘垢之障盖。证于空也。空中之空即大空义。此相微细难遣。处处说破无明三昧。净除自体之惑相。故重言之。缆缆二字。又更重言之也。又相释者。以住(◇字故。能为一切众生。作大饶益发生此性除去众垢也。)若有众生入此真言门者。不久即同彼菩萨之德也。凡观照时。唯以本体一字为主。持诵则具言也。此即是种子之字。又凡诸字次第相释如先有恶字。以次字皆转释之。准上字门中　不遍不名为普也。以此普眼而观众生。故名观自在者。入此三昧已。从其心出种种光。光中现是法门真言也

萨嚩怛他竭多(即是一切如来谓十方三世诸佛)嚩路吉多(观也。同彼佛所观故名诸如来之观即平等观也。即是普眼观也)迦嚧尼么也(体也。所谓大悲为体也犹如金人以彼自体纯是金故名为金人此菩萨亦尔纯以大悲为体)啰啰啰(啰是尘义入阿字门即是无尘也。所以三重者谓除凡夫尘障也)

吽。是恐怖义以大猛威自在之力怖彼三重尘障令得除净而同佛眼。惹。此最后字是种子也。诸字皆为释此字义。即生不生是阇字义也

或以初萨字为体。亦同用之。是惊觉义也。吽字中有诃字。是欢喜义。上有大空点。是三昧。下有三昧画。此中下画字亦三昧。二三昧中行也。三世诸佛皆同此观。故名等观也

得大势亦入此三昧与观音同。由是彼眷属故。髯髯是生义。所以有二重者。上是烦恼障生次是所知障生。入阿字门即是二生举体皆不生也。上有点是大空义谓除二障得大空生也。娑字是真言种子之体。娑是不动义。不动住动之法即有生灭。凡物有生灭者。即有住动之相。故经云。动不动法皆是不安之相。傍加二点同于涅槃。即是坚住义。已离二障同于大空。坚住此位如诸佛住。即是大势位也。如世人有大官位多诸财力。威伏多人名为有势之人。此势即是位也。言度二生同于佛生。即是如来之位。得此大位大势。故名得大势也

次多罗尊亦是观自在眷属。所入三昧亦同前说

迦卢拏(是悲义也所谓悲者)陀婆(二合)费(生也。谓从悲者而生。悲者即是观音此菩萨从彼尊眼中生也。犹见诸法实相名为普眼所谓见于如如之体。从此眼三昧生也)多[口*(肄-聿+余)]多唎尼(多[口*(隸-木+匕)]是度义然此真言。以初多字为体。两多字中初字也)

多是如如之义。傍一点是阿字。所谓如如之行也。啰字是尘。六尘即是生死大海。观此如如之理性故。一切诸尘劳。即同于如本来不生。即是度大海义。能度此等生死大海。即是于诸法得度也。重言者。释梵云极度。自得度已。又普度一切众生。名为极度。若人自未得度而得度人。则不应尔。若自度又能度人。斯有是处也。次多字即是如来之体。观于如如而度尘劳大海。得成如来之自体也。如大本中有五百多罗尊。皆从观音眼生。皆是阿弥陀姊妹三昧也

次毗俱胝入三昧如前

萨婆陪也(一切恐怖义)哆罗(二合)萨儞(又是恐怖也)吽(引)吽(亦是恐怖义也)萨颇(二合)吒也(残害也破障)莎诃

所以重说恐怖者。前是有畏。后是无畏。一切众生皆有恐怖以未得无畏处故。然于此中而生怠慢。我执自高。故恐怖彼。令离有畏而得无畏。由恐怖彼令得无怖。故重说也。残害即是破一切障也。然此真言以多啰字为体。诸字皆为释此。多是如如。罗是尘。傍角一点是阿。阿即行也。诸尘劳体同于如如。以此如如之行。能折伏摧灭一切生死见慢我执之幢。即大摧伏义也。佛大会中。时诸金刚现大可畏降伏之状。状如无有能伏之者。时观音额皱中现此菩萨。西方谓额上皱文为毗俱胝。如今人忿时额上有皱也。此菩萨现身作大忿怒之状。时诸金刚皆生怖心。入金刚藏身中。时彼毗俱胝进至执金刚藏前。时彼亦大怖畏。入如来座下而言。愿佛护我。时佛谓彼毗俱胝言。姊汝住。时毗俱知即住已白佛。唯佛所教敕我当奉行。尔时诸金刚怖畏亦除。皆大欢喜而作是言。此大悲者。而能现此大力威猛。甚希有也。此中秘意当问之。次白住处菩萨。当存本梵音

怛他竭多(如来也)毗舍也(境界也。如来境界。所谓如如)三婆吠(从彼生也)钵头摩(二合)(白花也)摩利儞(以波头摩为鬘。因以为名也。即是。此利儞是处义住义也)

然此真言。以初怛字为体。即是如如也。如如即是诸佛境界。我今从彼而生也。白者即是菩提之心。住此菩提之心。即是自住处也。此菩提心从佛境界生也。常住于此能生诸佛也。此是观音母。即莲花部主也。次马头菩萨

吽(恐怖义也)佉陀(是啖食义。谓啖诸障也。然此真言。以佉字为体。佉字空也。傍角点是行。陀是授与义)

所谓空者。即是诸法实相。犹行此行而得实相之果。复常以此而授与人也。今言啖食。即是以此空行。啖一切能障菩提法也

畔阇(畔是欲色三界。阇是生也。合说二字。即是顺坏义也)萨普吒也(普破碎令尽也。谓以此空行破一切法。遍无有余也)

除诸法实相。余皆是障菩提法也。以食啖坏破此悉尽故。得成猛威大势也。此菩萨是莲花部明王也。次地藏菩萨真言。时此菩萨入不可坏金刚行三昧。金刚者即是菩提之心。此菩提心即是不可坏。依此进行是金刚行也

诃诃诃(上诃字是真言体也诃是行义。亦是笑义喜义。入阿字门即离喜。喜者即生灭法)

所以有三。者即三乘行也。此菩萨以种种法门利益众生也

苏多奴(苏是善。多奴是子义。所谓善子也。是轻安义也)

犹善能行此利益有情之行。真是佛子。从善性而生。故名善子。从佛而生。故名佛子也。此菩萨即能说种种三乘行门。利益众生。如十轮广说。次文殊入佛加持神力三昧。此加持三昧如上毗卢经初说也

醯醯(是呼召义)俱摩啰迦(是童子义。即是呼。召令忆本愿也)

又俱是摧破之义。摩啰是魔眷属。所谓四魔。此真言以么字为体。即是大空之义。证此大空摧坏一切魔也

毗目吃底(二合)钵他悉体(二合)多(解脱道住者。谓呼此童子住于解脱道者。即是诸佛解脱。所谓大涅槃也)娑么啰娑么啰(忆念忆念也)钵啰底若(先所立愿也)

此真言意云。醯醯童子住解脱道者。忆念本所立愿也。一切诸佛法身成佛。入身口意秘密之体。一切有心无能及者。然忆本愿故以自在之力。还于生死救度众生。此真言意亦尔。此童子久已法身成佛。故请其。以忆本愿而度众生也。由请菩萨本愿。若有见闻触知忆念我者。皆于三乘而得毕定。乃至满一切愿。此菩萨久已成佛。所谓普见如来。或云普现如来。以大悲加持力示童子身也

次金刚无胜三昧。更无等比名为无胜。由现觉诸佛金刚之体能持诸佛智故。名执金刚。归命诸金刚者。金刚即诸佛智印也。即诸佛之别名也

战荼(极恶也。恶中之极也。谓示形状暴恶无有过者。乃至啖食一切世间令无有余。恶中之极也)摩诃卢瑟拏(此是大忿怒也极恶之中而又忿怒甚也即是谓佛第一威猛。残害世间尽其巢穴。令入法界归于金刚之界)吽(引)

此真言体也。无怖畏义也。诃是行。上一点是大空。下画是定。所谓大空行三昧。即是大金刚三昧之异名。以能降伏更无胜者故也

次金刚母所谓忙莽计。忙言母义。莽计亦是多义。即一切金刚之母。诸金刚智慧从此生也

怛[口*履](二合)吒(轻)怛[口*履](二合)吒(轻)

此中以上怛[口*履]字为体。多是如如义。啰是离尘垢义。伊是三昧也。即是如如无垢三昧。诸金刚智慧由此生也。吒字不成是半体。破坏体不成即是死义。由此三昧杀无明住地人也。已杀无明住地故。若衍底(丁以反)是胜义。亦是生义。如了达如如。垢障净除得无胜之生。故为众母。无胜而生。即是生诸金刚。金刚是无胜者。亦是生诸无胜人也。此无胜生亦名甘露生也

次金刚琐真言

畔陀畔陀也

此嚩字由谓下有娜字。以此字加于嚩上。以此娜字即是大空之点也。若上缚着点。即次陀字不须加娜也。此中以畔字为心。是缚义即金刚缚也。畔陀是遍护之义。是遍一切处以结彼也。遍一切处结彼者。即是结彼法界体也。◇一点是遍一切处义。已了达法界金刚之体结彼令不坏。是结护义也

暮吒暮吒也(是牢固义已作金刚之缚缚上更缚令其牢固)拔折啰嗢婆吠(是金刚生也。从金刚界而生。也。即是诸佛金刚智生也)萨嚩多啰钵啰底诃底(此是诸无能害也。如金刚宝体一切无能害者。犹识达此金刚体性。金刚之缚固体密致故无能害也金刚缚即是无间隙真如也)

次忿怒月压金刚真言

缬唎(二合)

以上缬利字为心也。缬唎是摄召之义。亦是召请之义。有诃字是行。有啰字是离尘垢。加上画是三昧义也。两点在傍即同涅槃。此是具足诸佛功德。愿我亦然也。次吽字是恐怖义。为速满此诸佛功德。以牢强转进离垢三昧同于涅槃之行。大怖一切诸魔皆令退散也。

伴吒(是叱呵之义。即诃叱一切魔障令灭没也)

次金刚针真言

萨缚达摩(一切法也。以上萨字为种子体)抳(上)鞞陀儞(是穿义也)拔折啰苏只(金刚针也)伐啰弟(胜愿也)

此意言针是利智之义。以此如金刚铳利之智贯达之。法无不穿。慧达法性意。是金刚针义也。所谓穿彻无明至实相际

次一切持金刚真言时十佛刹尘数金刚。同入金刚无胜三昧。犹如金刚手无异。亦于自心出不思议光。光中现此真言。当知余眷属准有也。吽吽吽。以初字为体。亦是大空行三昧也。此三昧即是大金刚无胜之行人也。入此三昧故名大空。行三昧也。三字是众多义。一切众生多金刚同说故合三字也

伴吒伴吒伴吒(诃障之义与上同也。私谓再说者谓诃三障也)

髯髯阇是生义。上有一点是大空也。已破诸障。当得大空之生。即是诸佛生也。金刚智生。即是诸佛法身之生。如央掘经生此不生之身。即其义也

次诸奉教者说此真言。此谓专在本尊之侧。承命往来随有所作者也。亦同上诸金刚。入大金刚无胜三昧而说真言。此一切诸部奉教。同用此真言也

醯醯(上醯字是种子也。亦是呼召义)

此诃是行是喜。中有翳字是三昧。重道者谓行极行。言极定也

紧只啰曳(入)细(何不速也。此是约敕之义如人处分使令。何不速为此事而稽迟也)蚁哩(二合)痕拏(二合)蚁哩(二合)痕拏(二合)(执持守义。谓持上所说金刚行三昧。第二重说此语是守护义既执持执持之。又守护。不令散失使不为诸障所逼夺也。令金刚行三昧速成也)佉驼佉驼(是啖食义。食诸烦恼又极啖食令尽。故重说也。私谓食界内界外烦恼。故重说)钵唎补啰也(是充满也。谓极啖食而令满足。谓满行人所有胜愿而令满足。第一愿者。为金刚行三昧也)萨缚枳迦啰喃娑嚩(二合)补啰(二合)底染(长声。谓本所立愿也。随彼先所立愿应当满足也。上句云满此下句云本所立愿。相连也)

通三部使者用之

次释迦如来入于宝处三昧。宝从彼出名为宝处。犹如大海出种种宝。若至彼洲。则随意所须无所不足也。佛入此三昧已。从其面门出种种光。光中现此真言。乃至普遍一切佛刹。余真言当知皆如此说也

萨缚讫隶奢(一切烦恼也)泥苏驮娜(摧伏也。通上句云摧伏一切烦恼也)萨缚达么(一切法也)嚩势多补啰钵多(二合)(得自在也。通上句云于诸法中而得自在也。以除诸障故得自在也)伽伽那(虚空也)娑摩(平声中有阿声)娑么(娑么无等义。即是等同虚空也。是行等空无边清净也。于一切自在无碍。同于名字也下句与阿相连是无等也。不等者即是二乘。以有所阙故名无等。即是施权之意)

然此真言。初萨字为体。娑者是漏义亦是坚义。入阿字门即无漏无坚。若有坚牢。即是生灭坏破之法。若令同于阿字。此坚本来不生。即是诸法之中。而得自在等于虚空。能为一切宝洲也。私谓释迦以大悲力。于周体密致犹如金刚一阐底等。亦令破坏此见而入佛法。施其大宝之愿。岂非于诸法中而得自在。能破一切坚牢也

次豪相真言者。此是如来无量功德之所成就以为庄严。此是功德之聚。故作三昧女形也。是释迦眷属。亦入宝处三昧而说此真言耳

皤啰提(与愿也能与一切众生愿也)皤啰补啰(二合)钵底(谓云愿得。即是得愿也。如人有宝乃能与人。由我自已成就此愿故。能自在施人悉令充足)

吽此心是种子也。诃字是行同于大空下。有邬字是三昧上。点即大空行三昧也。凭此进修得至宝所故。能自在与人令满所愿也

次一切佛顶者。一切佛顶谓十佛刹土微尘数佛之顶。顶是尊胜之义最在身上也。即是十八佛不共法之别名。此本尊形像。一同释迦具足大人之相。唯顶内髻作菩萨髻形为异也。亦住宝处三昧而说此真言

鑁(无敢反)鑁鑁(以上第一字为种子。是缚义也。入阿字门即是无缚之义。又缚是言语道断之义。字上有点同于大空也已成就极。令成就。故三说之。极令成就清净也)

[合*牛]是恐怖之义。以威猛之力。遍破诸缚同于大空。泮吒是不生义。犹体坏不令生。故必当死。谓破诸法无所不遍悉令永不复生。同于大空诸佛解脱。即入佛不共法之顶也

次无能胜真言。是释迦之眷属。亦入宝处三昧如上而说真言。此是释迦化身。隐其无量自在神力。而现此忿怒明王之形。谓降伏众生而尽诸障也

地[口*陵](二合)地[口*陵](二合折廉反)

以初字为体以初第一字陀[口*陵](二合)为种子。陀是法界义。啰是尘障诸垢之义。若入阿字门即是无尘障。即是法界。当知即同法界故。更于何处而有尘耶。此即大空之义。若人住此三昧。则一切盖障无不破坏。重说者极破尘障之义也。故以说无尘三昧。所谓陵字门。次说驲陵(二合)字是三昧即是诸障不生而得大空生也。此种子字有种种定慧庄严。故能于生死中而得自在。坐佛树下摧破四魔兵众也。无能胜即无不可破坏之义也

次无胜明妃。作女形也。说此真言入三昧如前说

阿波(入)啰誓帝(无能胜也)阇演帝(胜之别名。即是战胜之义。能降伏他之义也)多雉帝(摧伏胜竟之义。也此中荼字是战义。佛坐道场以斯定力。与四魔共战而得大势。无能损者。由此三昧力也。以第三字为种子)

次地神真言。地能持万物。一切万物依之生长。当知即是佛心。犹如来心能持万物。深入持本三昧而说真言也。亦是释迦方便化身耳

钵[口*栗](二合)体毗曳(二合)(地神名也。即以彼名而作真言。若人诵持修习。不久亦得如来心地也以真言第三字。为种子字是离言说义。中有伊声是三昧。入此离名言三昧即证心地。此三昧名普载为三昧。以同大地故也。末后毗曳字是缚义也。即衍。那是处义。翳是三昧。亦是指物之声。即指彼真言之体也。由此离言心地三昧故。于离系之乘而得进行也)

次毗纽天有众多别名。即是那罗延天别名也。是佛化身。三昧同前毗瑟纽(二合)费(即以本名作真言也)。以第一字为种子。毗是空义。瑟纽是进义生义。乘空而进。所谓此天乘迦娄罗鸟而行空中也。私谓释迦于五部佛中乘迦娄罗坐。即是虚空进行之义也

次噜捺啰。亦佛所化身。是摩醯首罗之化身也(亦名伊舍那)噜驮啰(二合)也(即以本名为真言也)以噜字为心。驮啰是授与之义。犹自多有能惠他人。所谓诸乘乘即已也字义也。自通达如是宝乘。能遍施一切众生。噜即无尘垢三昧。自得此三昧复以施人也

次风神真言。亦佛化身也。三昧如前。皤(平)也吠(平即以本名为真言也)以皤字为体也。吠是缚义。入阿字门是无缚之义。即解脱也。傍有阿字之点。即行也。第三吠字是无言说之义。又加伊字是三昧耶也。是诸乘。以无碍乘而度一切

次美音天。是诸天显咏美者。与乾闼婆稍异。彼是奏乐者也

萨罗萨伐(二合)底曳(二合)(即美音之名也)

以初萨字为体是坚义。若有坚住即有生住异灭之相。入阿字本来无坚。则无成坏故也。余字皆为释此。私谓以此妙音悦可众生。言辞柔软悦可众心令得欢喜者。说无坚令知无常。验得如来坚固之法也

次泥哩底。是罗刹主。亦佛化身也

啰(垢也)吃刹(二合)娑(食也。娑是坚义。都是能啖义)

彼常啖食众生。如来亦尔。能食一切尘障之有情无有厌足也。提钵底曳。提字有驮声即是法界。加伊是三昧。所谓法界三昧也。钵底名住。住此法界三昧名为妙住也。观一切垢障即是法界入于法界。即是能啖入腹之义。最后曳字是乘也。此乘者速疾无比也。处门体种子字

次焰摩王真言。亦佛化身也

毗缚萨缚(二合)哆也(亦以本名为真言也。以初字为体更问之。所谓无。缚三昧也)

毗嚩是坚固住义。亦是除诸缚也。谓以理除缚不以非法也。埵字中有多声即是如如。萨字有坚固义也。也字是乘。乘此如如之乘而进于行。傍有阿字之点即是行也。乘相如如而进行者。即是去成正觉也

次死生真言。此是阎罗明王也。亦为成就大悲发生漫荼罗故。随所通达而说此真言

没[口*栗]底(二合)吠(此即死义也死是杀义断。其根本名之为杀。由本意愿我断一切众生命根命根即是无始无明诸烦恼也)

一切众生断彼令尽无有余。即是杀也。此明于死法门而得自在。即佛所现化。非真杀一切众生也。以初没字为种子

次黑夜神真言。此即阎罗侍后也

迦(平)罗啰(引。都名黑也)底哩(二合)曳(平声。即夜也)

以初迦字为体(作也)以夜暗之中多有恐怖及诸过患。为欲除彼无明黑暗中。长夜诸障垢等怖畏。故说此真言也

次阎罗王七母。有七姊妹。此七母名准余经。皆以本名作真言也。今说总者如左

摩怛哩(二合)弊(去也)也(二合。摩怛哩是等义。等是非一众多之义。谓七姊妹等也)

以初摩字为种子。是无我义也

次释提桓因

释迦啰(二合)也(即字名也)

释迦是百福德义。以因中曾百度修福。所谓一百遍作大无遮施会普施众生。故得成此胜生。以初释字为种子。因以为名也。是止息义。止息诸障。障既息已增益其福。迦罗是增进也。又奢(入)即是奢摩他也。常以深言利益诸天。故心为真言。亦佛化生也

次嚩噜拏龙王真言。此是大海中龙也。诸龙王同此真言

阿半(脯其反水也)钵多(某也)也(助声也)

以于水中而得自在故名水主。以初阿字为种子也

次梵天真言。为欲成彼大悲胎藏亦如上说也

补啰(二合)阇(一切生也)么多曳(主也)

即是众生之主也。一切众生因梵天故。名一切众生主。能生一切有情故也。以补啰(二合)字为种字也。补是第一义。啰是障垢。于胜义中即障无障。一切圣者皆从此生故。主生主也。亦是佛化身

次日天子真言

阿(本不生也)地(与也)多邪(二合)也(日也)

以初阿字为种子。即本不生义也。自通达此理而授与人。即是常利益众生。义犹如彼日也。世人谓日为常利益众生者

次月天子真言

战(不死也)达啰(即月名也。以初字为体)

若不死者则亦不生。不生不死者是名甘露。世人以月能除毒热烦恼同于甘露。故以为名。一切甘露之味无过净月三昧也

次诸龙真言　前是龙王。此是一切诸龙是通用也

迷迦(云也)扇儞(吃啖也)曳

此释为啖云也。是黑暗。即诸众生垢障。能啖诸障而得自在。故以为名也。以初迷字为体。即我义也无我也

次难陀跋难陀守门二龙王真言

难徒(以初难字为体。是观义也。即观离观而住于中。自通达已以利众生也)拔难陀庾(拔字声势有邬波者)

邬是越也。自越诸法生死流转住于最胜处。以此护持世间。故以为名也

右上释迦眷属罄了。皆是住于宝处三昧。以佛化身。为欲成就大悲藏而说真言

时毗卢遮那佛自教迹不空悉地乐欲一切菩萨母明妃。说者自教迹者。即是法佛自证之教。即秘密平等教也。为于此中诸为修行者皆悉不空。不空是不唐捐义。随彼力能皆向法身之理。即同彼佛故云不空也。如上诸菩萨说真言各欲引摄同类行者。若有修行即同于我。今法佛自说明妃真言。若有修行者。即从虚空眼而生法身。如我无异也

伽伽娜(以初字为心。伽是无去来义。又伽伽娜是空也。所谓诸佛大空也)皤啰(愿也)落乞叉(二合相也)努(大空也。此愿胜上。即同虚空一相清净。无边不可分别也)伽伽娜(空也)三迷(等也。如上大愿如虚空相。与虚空等也)萨皤都(一切处也)竭多(更无比也。谓此等虚空空愿遍一切处。皆无有与为等比心。上有阿声相连)陛萨啰(坚不可坏)三婆吠(从生。也谓从不可坏而所生)阇嚩(二合)罗(光英明义也。由住无去无来之行。成大威光无与为比也)娜母(归命也。由住斯法故我归命也)阿穆伽喃(不空者也。所归命我为归命)

真言首归命普遍诸佛者。以一切之名犹自普遍。如指东方一切佛。即不遍十方。为简此少分一切故。云普遍诸佛。他放此。一切佛菩萨母虚空眼竟。时佛又复一切为障者息故。火生名三昧证。说此大摧障真言。此有威势能除一切修真言者种种障难。乃至佛在道树。以此真言故。一切魔军无不散坏。何况世间诸障也。又此障略有二障。一者内障。谓从自心而生。其类甚多不可详说。二者外障。谓从外事而生亦甚多。皆能摧灭也

战荼(极恶也。所谓暴恶之中又甚暴恶也)摩诃嚧瑟拏(大忿怒也)萨颇吒也(破坏也)[合*牛](恐怖也)怛啰迦(坚固也)唅(平)鑁(无甘反)

用后二字为种子。诸句义皆成就此也。初战荼者。战是死义。入阿字门即是本无生死义也。荼是战义。以此无生死大势之主。即与诸四魔战也。次么是我义。入阿字门即无我亦是空也。诃是喜义亦是行也。嚧瑟者有啰字是垢障。有邬声是三昧也。即奢么他谓三昧也。拏是空义。第五字即大空三昧也。萨是坚义。颇是法义。了知世间如聚沫故易破败也。傍有阿字之点即行也。吒是战义能敌障怖令破也。也是乘义也。[合*牛]是大空行三昧如上说。怛(是如如也)啰是无垢也。迦是作也。谓一切法无作也。唅字诃是行义。又有阿声是怖魔障金刚三昧也。点即大空也。以此大空不动动行。大怖一切魔障也。鑁字么是我义。入阿字门即无我也。又以此大空无我三昧。而怖畏众魔。以此字亦有阿声及点也。诃嚧唅鬃四字皆有阿声。即是重重怖魔。极怖内外二障之义也。若圣者不动主真言了

次降三世明王真言。皆是毗卢遮那如来。住于法幢高峰观加持三昧。如初序品中说也。如来说此二明。皆是彼法佛三昧。为令行人从初发菩提心。守护增长令生成佛果圆。终不退失不堕在非道者。即不动明王是也。为降伏世间难调众生故。即降三世明王是也。相次说之。所谓三世者。世名贪嗔痴。降此三毒名降三世。又由如过去贪故今受此贪报之身。复生贪业受未来报。三毒皆尔。名为降三世也。复次三世者名为三界。谓毗卢遮那如来。始从有顶迄至下地。从上向下相次。一一天处皆化。化无量眷属大天之主。今胜彼天百千万倍。彼怖未曾有。更有何众生而胜我耶。乃至以法而降伏之。即次第而下。以能降伏三世界主故。名降三世明王也

诃诃诃(诃是行义是喜义。此三行者。即是三乘人行也。此字行即此三行本来不生。由本不生故即越此三行。是为佛行也)毗萨么(二合)曳(此是奇哉怪哉之义也。如佛常教。以慈对治于嗔。以无贪治贪。以正见治邪见今乃以大忿嗔而除忿嗔。以大贪除一切贪。此则最难解难信。故言怪哉也)萨嚩怛多揭多(一切诸佛也)毗舍也(境界也)三婆嚩(生也。谓从诸佛境而生也佛境者所谓诸法实相。从此实相而生故号为降三世也)帝(入)[口*(隸-木+士)](二合)路迦也(二合)(此是三世也)吠阇也(此是降胜之义也)[合*牛](义同上说)惹(呼召惊觉之义也。若诵此。能遍入一切众生之心而惊觉之。令障尽等于法身之佛也)

然此真言。以此帝[口*(隸-木+士)]字为体。上有多声即是如如之义。啰是垢障。有伊声即是三昧。以如如之体即是本来不生。以不生故。即垢障亦自本来不生。称此理而修定慧俱足。故能降伏三世也

次声闻真言

醯都(因也)钵啰(二合)底也(二合缘也)也毗揭多(离也)羯磨(业)泥社多(生也)[合*牛](怖障也)

通释云离因缘生也。生由于业。离生即由离业也。初醯(有诃声是行是喜。即声闻行也三昧伊声声闻定也)次都字(有多声。即声闻所入如如也。亦有邬声三昧)次钵字(声闻所见第一义也)次啰字(小乘所对六尘也)帝也(乘如之义也。即是声闻所乘之义也)毗(有嚩声是缚也。伊声三昧也)揭多(离也)余以类广说之。怖障义如上所说。但以声闻行为异。此是法佛大悲愿力为利有情。于三昧中而现声闻缘觉真言。若众生应以此法入道者。令从此门入大悲藏也

次缘觉真言

嚩(言语道断义也。即是如上所说缘觉证极无言说界也。自从此中得证。复以此法利益众生。自己通达。亦以此法利他也)

如上说。声闻缘觉以句法为真言。今以一字者。此是宗极之要。即彼极修行住处故。用一字也

次诸佛菩萨心真言

萨嚩勃驮(一切佛也)菩提萨埵(菩萨也)诃[口*栗](二合)娜耶(心也)[帝*也]毗舍祢(入也此总释言入一切诸佛菩萨心也)娜么(归命)萨嚩毗睇(与愿也谓与一切智智之愿也。萨是坚义。能离诸坚也离非坚也)

上啰是垢下嚩是缚也。毗是言语道断。又有三昧也。睇是授与义。伊声是三昧也犹自足故则与人。犹自得一切智智故。能以此愿与人也。当此是诸佛之心。帝也(二合)此字为种子。与上句阿声相连。正以此阿声为种子体也。即本不生义也

次普世天等诸心真言

嚧迦嚧迦(世间也。即是暗冥之义。所谓无明也。此字侧皆有阿声。即本无义也。无暗即是真明也。阿嚧迦是明)迦啰也(作也。所谓是照义。作明也。以作明相。现此八部等普之身。而除彼暗使作明行。作是明令世间明也)萨缚提婆(天也)那伽(龙也)夜乞叉(如字也)健闼缚(如字)阿修罗(如字)揭露荼(乐主)紧那罗(乐声)摩呼罗伽(如字)儞(等诸部摄)诃[口*栗]驮夜娜夜(二合心也)迦沙也(摄也。此八部等心而令作明也)费只多罗(二合)揭帝(种种行也。亦是巧色之义随类示现一切可爱乐身名巧色也。亦是杂色义。以种种行种种杂色法。门而除世间之暗。即诸明中无比之义也)

以最初路字为种子也

次一切诸佛真言

萨缚他(一切也)毗末底(无慧也。以无慧故名之为疑。此字正释为疑也)毗结啰拏(除也。此色尘叶之义如人除弃秽名为除弃也)达摩驮都(法界也。谓除一切无慧。皆令住于法界也)涅阇多(生也。此涅字即是大空三昧。从此而生。即是法界生也)参参诃(此三字者皆是种子也。萨是坚义。犹除此坚固为最胜生也。点是入三昧。如二乘入于涅槃。此即是坚固义。乃至若有坚者。即是生住之相故。一切动法皆是不安。犹极除此。都有重空三昧之义。诃即此行。所谓如来行)

次守护者真言。此即是不可越。正为难持(谓力持义观瞻不可得也亦有难降伏义)法佛奉教者常在内门右边也。名为不可越使者。诸佛三昧耶威力。不可过越也。金刚之戒奉以行之。一切不敢违越也。亦名无能见者。由此奉教者威猛炽盛如百千日无敢视者。犹如初生小儿不堪仰视日轮。故以为名也。常在佛内门。有所教命如说而行。故名奉教者

奴达哩沙(此是其名。即是不可视越义也。驮达是法界有罗声是无垢。奢即奢磨他也)摩诃嚧瑟拏(大忿怒也)佉佗也(吃也。谓啖一切妄相烦恼也。以佉字为种子。诸字皆为释此。即空义也。陀即与义。也是乘义也)萨缚怛他揭多(一切如来也)瞻(长声呼之。是教敕也。与前句阿声连)俱嚧(作也。即令行如来教敕也。随所教敕而作不相违。可瞻受教敕义也)

次相对守门者真言

醯(呼召也)摩诃[言*本][口*栗](二合极也)战荼(大忿怒暴恶也。是极忿义)阿鞞目佉(相对也准前守门)萨[口*栗](二合)诃拏(二合摄取也)佉陀也(食吃也。亦以佉字为种子)紧只罗曳细(何不速也)三么耶(如前解)么努萨么(二合)啰(忆念也。谓忆念三摩耶也。由忿怒甚。不可观拟不可观视。与前相对故为名也)

奉诸佛教敕以不可得空。食啖食一切着相众生。难可化度降伏者令无有余。即是大忿怒义也

次结大界真言。如佛所说。更有无量持明。恐更有持真言者等。以不结护故。能破法事损持诵人。故设结界之法。由结界故。乃至诸持明亦不能破坏。犹比丘结界作法事。在界外比丘虽作法不能障破也。随方皆遍也

萨嚩多罗(二合)努揭底(一切方处所也。谓十方皆须结遍)畔陀也死曼(母减反。上句结下句界也。此意云一切方处所结界也)摩诃三昧耶(大三昧耶也。即以此大三昧耶而结诸界)儞啰社(二合)底(从生也。谓从大三昧耶生也)萨末(二合)啰拏(奴皆反。忆念也。谓忆念一切佛教也)阿钵啰(二合)底诃底(无有能害也。亦云无挂碍也。亦是无能坏也。由结界故无能坏也)驮迦驮迦(光威也由光威故成界驮是法界。迦作也。言法界体离诸作离作即是法界也)遮啰遮啰(遮是灭义。谓生灭迁移也。罗是垢障也。句亦是行。平声。是遍往十方结也。亦是行即是来去也。重称之即是极来之义此是急来也)畔陀畔陀(释句是结义也。上是能义下是空。犹无能邪破等于虚空。以此结界故无能坏也)娜奢(上声十也)儞膻(方也。即是结十方也)萨缚怛他揭多(一切佛也)奴壤多(教也。是一切诸佛之教。前所念令忆念也)钵啰(二合)嚩啰(所证也)达摩(法也。即诸佛所证之法也)罗(入)陀(获也证也得也)毗阇曳(即无能胜也。于诸障中为胜。即不可败坏)薄伽筏底(此是真言主也。叹世尊德也)毗俱[口*(隸-木+士)](除也。能除垢也初劝除。亦是劝念令作)毗俱丽(前句除有相垢也。正是莫作正是除也。后句除离相之垢即是除一切障也)隶(种子也)噜(长引)补[口*梨](句义是宫也处所也。以真法除垢相。即是诸佛所住之宫。令同此界也)

更加微炬丽字也。但以此最后句中隶字为种子。罗是相。加此翳声即是三昧。具一切相而离诸相。此是界之体相也。以下说种子字(从一字能生多故名种子也)

恶(菩提种子也。凡持诵者。皆有此心希求无上菩提故先说此字。从此生一切法也。即菩提心也)　阿(行也。即是修菩提行之种子成就福智故)　暗(成菩提种子也。前字是菩提心。更加上点即是大空证此大空是成菩提)　恶(涅槃种子。也傍有二点者皆急呼之是诃声也。是除遣之义。遣诸垢是入涅槃也)　诃(去声降三世也。诃是行。加阿声是极行。以此除遣诸行。则是不行一切行。故有除遣义以此能降三世也)　悍(不动主也。诃是行。阿声又是行点即大空。由住是位能降一切。为菩提心作大护也)　阿(除盖障也。阿是障。傍有二点即是除。遣此即除盖障义也)　娑(上观自在也。娑是诸漏傍有二点即是诃除遣诸漏无漏之观故自在也)

缚(金刚手也。缚义。傍有二点即是除诸缚也。此是金刚种子也)　瞒(文殊师利也。本体即是空。上又点又是空。所谓大空也。越十八空名为大空住空之位名为大空即是大般若也)　严(虚空眼也。伽是去来离去来。法即同大空故加点也)　嚂(一切佛菩萨。皆从是中来法界也。啰是垢。上有点是。离垢同于大空。是法界义也)　欠(大勤种子也。佛坐道场伏诸魔。故一切天人号为大勤勇也即毗卢遮那也。佉是空义上点是大空以大空净一切空也)　髯(水自在菩萨也。由从水生名水自在。即菩萨名也。大本中有之今此漫荼罗位不言安置处。当详。阇是生义除诸生灭同于大空也)　耽(多罗尊也。多是如如也。如如之性即同大空)　勃[口*履](毗俱知也。婆即三有。哩是三昧于三有中而得自在。傍有二点除遣三有也)　参(得大势也。娑是诸漏。同于观音种子。而上有点。言此诸漏即同大空也)　半(自处。观音部母也。跛是第一义体犹如虚空也)　含(马头也。诃是行。加大空即大空之行也)　阎(耶输陀罗。即莲花部明妃。也是乘义。上有点者。言是乘清净同于大空也)　参(宝掌菩萨种子。同大势至以宝处为定也。以宝为手。故宝从彼生也。亦有常义也亦有作义也)　髯(光网菩萨。即文殊眷属义亦同前)　婆(上。释迦也。婆是三有。傍有二点。即是除遣三有义也)　[合*牛]吒蓝(上诃是行。下邬是三昧。上点是大空也)　蓝(下吒是战敌。啰是垢。傍邬声三昧。上有大空)

右三佛顶种子。同前以次配之

邻(白伞也罗是相。上点相同大空也)　苫(社是障也。是怨敌相对义。一切有对法。同于大空无胜劣也)　赐(信反最胜佛顶也。娑是坚固。离坚非坚即是大空。又有三昧也)　怛[口*憐](二合)(多是如如。啰是垢。又有三昧及大空义此火聚也)　诃婪(二合)(诃是行。啰是垢邬是三昧。点是大空此是除盖障佛顶)

右五佛顶种子

耽含半含阎(如如也。上有空。即如如不可得同于大空也)　[合*牛](行也。入阿字即行无行又空)　微(入。第一义也离第一义也)　枳履(行也离行也)　儞履(一切乘也。即乘无乘体同于空)

此五字是世明妃种子字。虽是佛化相同世间。谓天等也。遍一切所有明妃。随取其一

吽(无能胜种子三昧)　微(缚此地神种子字也)　枳(作三昧)　履(离相三昧)　相离(文殊使者计设尼也因发结端严妙得名)　儞(定空)　履(施者也定相也。陀是施也。于无相中能满一切愿也)

此邬波计设尼也(空定)弭履相如。前(此文殊使者。名质多也么是空是我。下罗是相。犹有相故有我。离相故无我。亦文殊师利定也)

系(喜行)　履相(文殊使者财慧也。即是能满一切愿皆令喜也。更有一使名阿迦沙尼。是呼召取物使者。经中少种子字未得。)

右文殊五使也。每一使各有一奉教。同种子字同使者了

次除疑怪菩萨

诃娑难(行行离空。又大空。所谓法甘露也)

总句是喜义(是欢喜踊跃义)

次一切无畏施

罗娑难(垢如上。犹此字义故有畏。若入阿字门能除一切畏也)

总句是味也(以无上真实法味满一切愿)

次除一切恶趣

持懵(法界缚)娑难(如上总句是破碎义也。如人手执物击物令破)

次愍惠(从哀愍一切得名)

微(缚。三昧伊声是定)诃(喜)娑(坚)难(如上总句。以种种善巧方便。令众生欢悦至是处也。增长积聚义)　谄(大慈生菩萨种子也。此慈极大。无比。从此慈中生也。乘也是去来义离去来同大空也)　阎(此大悲缠菩萨种子字。由大悲故自缠其心。故得名此)　缢(除一切热恼菩萨也。能除三毒热恼是极三昧义也。邬亦极三昧义也)　污(此不思议慧菩萨也。以不思议慧除无慧也施也由自有故得慧与人)　滩(奢摩他。又大空宝生菩萨也。犹能生一切法宝故。得名)　衫(此宝手菩萨也。如如意殊在手能满一切人愿。此菩萨亦尔。故得名也　俨也。第五字是空又大空也)　噞(此持地也。犹如大地持万物佛地持众。生此菩萨亦尔也。以此字义持一切也)　髯(染字也。亦第五字又大空经本缺菩萨名。检前)　汔(颇是聚沫不坚义。了一切法自相如是同于大空。)

此宝印手菩萨种子也

赧(坚固意菩萨也。空又空也即是坚意菩萨空内即息垢也)　邻(虚空慧也。如空无边无碍。是菩萨慧亦如是也)　含(虚空无垢也。此慧如空清净无垢。行因于空行成就已等同于空)　空(如如惠来　句者底是去。谓去成正觉　至于如如如)　檗丹(清净慧也空垢)　地嚂(行慧心常以是慧利益众生)　[合*牛](安慧也。常住是慧以利众生故得名也)

句云无怖畏也。安住是慧犹如金刚山定也

地(法界)室唎(二合)(止定无垢)唅(行空)没蓝(缚垢空)

此四字诸奉教者。通同随取其一字用

吃沙(二合)(作止)拏(二点是恐怖令除战)啰(点是极战令彼怖是大胜也)阎(如如无垢达一切乘)剑(作与非作皆离。以何得离由体大空故也随取一种子字欠此多第三)

右六字如上所说十佛刹尘数菩萨种子也。随用一字即得通用之耳。凡诸真言中。随取初中后字用为种子皆得也(观察取宗要之字耳)

次净居天真言

摩奴啰摩(意悦也。由受种种乐故)达摩三婆缚(法生也。此佛所化生。非关世天垢言从法生也)费婆缚(随有三种也三亦种子也)迦他那(说也。通上云随其有所说也。随彼法生以解之法为众生说法也)三种子三(亦种子坚与不坚皆离。体同于空极令空故重字)

次罗刹真言。即用彼方言为真言也

吃嚂(心也)计[口*履](兼三字乃种子也)

中有二迦二啰。即是能食一切业垢。二医字三昧也。重说者重净也

次荼吉尼真言　此是世间有造此法术者。亦自在咒术。能知人欲命终者。六月即知之。知已即作法。取其心食之。所以尔者。人身中有黄。所谓人黄犹牛有黄也。若得食者。能得极大成就。一日周游四域。随意所为皆得。亦能种种治人。有嫌者以术治之。极令病苦。然彼法不得杀人。要依自计方术。人欲死者去六月即知之。知已以术取其心。虽取其心然有法术。要以余物代之。此人命亦不终。至合死时方坏也。大都是夜叉大自在。于世人所说大极。属摩诃迦罗。所谓大黑神也。毗卢遮那以降伏三世法门。欲除彼故化作大黑神。过于彼无量示现。以灰涂身。在旷野中以术悉召一切法成就乘空履水皆无碍诸荼吉尼。而诃责之。犹汝常啖人故。我今亦当食汝。即吞啖之。然不令死彼。伏已放之。悉令断肉。彼白佛言。我今悉食肉得存。今如何自济。佛言听汝食死人心。彼言人欲死时。诸大夜叉等知彼命尽。争来欲食。我云何得之。佛言为汝说真言法及印。六月未死即能知之。知已以法加护勿令他畏得损。至命尽时听汝取食也。如是稍引令得入道。故有此真言

诃唎(二合)(诃定行唎垢)诃(行)

除彼邪术之垢也

次药叉女真言　能啖世间能食诸业垢等恶。是夜叉义(乘)

药(如上)吃叉(二合)(言语断定)尾(施乘)儞夜(二合)(乘)达(法界)[口*履](无垢定)

句义云持夜叉明者心是。用彼方言作咒也

次毗舍遮真言(翻是。极苦楚义。此辈多是饿鬼也)

比(第一义定)旨(死)比旨(极第一义灭也)

亦是随方言作之

次部多真言　此是夜叉之类也

喁(去空)缢(定)喁缢(极也)懵(我坚)散宁(空定也)

次阿修罗真言。各各别为种子字。随取其一

啰(垢)吒(战)啰吒(重言也)持懵(二合)耽(法界无缚犹如虚空)没啰(二合)(如犹空)没啰(二合)(言语道断离诸垢也)

句中有染欲嗔言。谓除彼多欲嗔故说也

次摩睺罗。亦种子字随取其中

[卄/(阿-可+辛)/木](来去)啰(垢也)蓝(相也谓生死)[卄/(阿-可+辛)/木](缚)啰(垢)蓝(相也)

次紧那罗真言

诃(喜)佉(行)散(坚也所谓我报也)难(空又空上句也)微(缚定)诃散难(如上下句也)

此句义。上句是欢喜。下句是与人欢喜义。由能除我执而坚而证大空。是故踊跃无量。既自得已亦能与人也。诸人真言。各是种子字也

壹(定)车(去。影像傍有阿声行也)钵(第一义)嚂(尘即大空)么(无我即大空)弩(空又空也伊声是空)么(空)曳迷(乘人定)莎诃(同上)

右诸真言别相竟

次毗卢遮那说真言心者。以如上诸真言等。随一一中。则有根本真言心真言随心真言。如是等无量无边不可知数今总说诸真言之心。即此阿字是也。此是诸法本不生义。若离阿声则无余字。即是诸字之母。即一切真言生处也。谓一切法门及菩萨等。皆从毗卢遮那自体自证之心。为欲饶益众生。以加持力而现是事。能实即体不生。同于阿字之法体也。此字于真言中最为上妙。是故真言行者。常当如是受持也。是故一切真言住于阿字。犹住此故诵之即生也。右普通真言藏品竟。此中真言通一切处用。下诸法中各是别行也

    世间成就品第五

第三经云。尔时世尊复告金刚手秘密主言。谛听谛听者。前已问佛。[尒-小+(恭-共)]腾前答之。故无问自说也。如真言教法。成就彼果者。谓真言行人如于法教。依于正教而修法行。此行善成得悉地果。佛意言。若有众生欲得成就如上大果者。先当依此品次第而修行之。即是最初发足处也。当字字相应。句句亦如是。作心想念诵。善住一洛叉。初字菩提心者。如上一一字各有字义。从此字入实相门。即真言字也。又此诸字合而成句。则有句义。此句正诠实相之体也。是故持真言行者。必令字字相应句句相应也。或住心种子之字。或想真言令成轮像。或如鬘形或如系珠。明净无垢。循环相续无有间断。如是令现前明了已。想此真言轮。明白如淳净乳。次第流注无有断绝。从口中而入。从上向下遍洒下品。头尾相接牵入此中。身心流布灌身分。以此因缘。能令行者身心诸障悉得清净。所谓一洛叉者此是隐语。梵音别意。即是一见义也。令心住此境一缘不乱。字字相应句句亦相应。想此一一字。明白净彻如净明珠。一一字皆又明了。遍有光鬘次第不断。而注其心如甘露灌洒。如是一缘之时。假使有种种障起。或作大可畏像。诸散心人见者狂乱。或作大声。假使山王亦可破碎。有如是事时。行者住真踊健菩提之心。一缘不动无有取舍。故名住于一见。若不如是者。虽经百年诵满千万落叉。犹不得成就。何况一落叉耶。复次此字者。即是菩提心。由一一字即是入实相门。皆得法界之体。所云字者。梵云阿刹蓝。阿是不坏义即是净菩提心也。如此行门为净菩提心故。若不除垢。本尊三昧无由现前。故行者令一一字。与净菩提心相应也。第二名为声。句想为本尊。而于自处作者。又当观想字字句句真言之声。如前次第相续轮环不断。一一声相明了。如铃铎风梵之音次第不断。而入其身遍。其体内。以此因缘。能令身心扫除垢浊。如火起时诸尘悉净。亦当心一境善住不乱。假使有种种境界。亦如前说也。又句中义者即是本尊之体。先想本尊明了。次即自观己身同于本尊。令内外明了也。字真言观即是真言身。声真言观即是真言主。句义观即是真言之体。即真言心也。句是义趣所归趣处也。即本尊心也。身语意净三事清净平等。犹如内有明眼外观净境。又无暗障。三事等故明了现前。以此三事等故。身口意皆住一见。众缘具故则有成就之乐也。此三事等明见本尊。故当于自处作也。又即自观其身亦同本尊。以三事等故名世间成就。尔时本尊及诸菩萨等。随想而现随念而至随问而答。然后入修学出世真言之行。不如此者。徒捐其功无有益也。第三句当知。即诸佛胜句。行者观住彼。极圆净月轮。于中谛诚想。诸字如次第者。次当观佛即观本尊。随彼所欲为事。各有像类法门。如色即有白黄赤等。坐起身印之形。随所欲作事而极观之。如欲寂心息灾。即观息灾之像。既得成就明了无碍。又想月轮圆明清净。观字轮在此轮明净心中。如前成就。此即净菩提心义也。由三业平等清净。能见诸佛相。净菩提心与念佛三昧相应。明了无碍。唯独自明了余人所不见也。云于中谛诚想者谓观圆明本尊及字。谛了分明无有隐昧。名谛了分明也。云中置字句等。而想净其命即。是如上先观字观声观本尊(或去句更问)然后观佛。佛即本尊也。随彼所有缘者而观之。皆是佛普门之身。故无异相。同名佛也。先作是三种观。都合方成种子。以为子故必当得果。次观本尊为欲成果也。如人有种子者种之良田。方便将养为成果。故云是成种子。已为成一切智智之果故。观佛也。行者初观之时忽暂与相应。犹如电光暂得见道。尔时不应生着。所以然者。如西方有一阿阇梨弟子。作此观时忽暂相应。心生贡高而向余同学说之。彼即谓之若见法者即是成果。夫真言果者。即具一切种慧。我昨造得偈颂汝能知乎。若汝于此近事犹不能达。当知诸佛境界未可通达也。所以说此事者。若人见字明了之时。由与法相应故。必当身心有异。先来愚钝乃得总持。随闻一句通达无量义趣。说不穷尽。况为我慢等过所动。而生高慢取着心耶。是故行者。当离如是法爱勿令自退也。又行者观本尊时初忽见。随灭不应爱味取着或生忧悔。但当一心行之久自谛了分明。若见尊时诸有所想自然成就。圆光月轮及字等。随念而现洞然明彻。若见字者字外皆有光炎。犹明火焰明净无比。或作字轮如前所说。亦于轮上具有光明随心成就。乃至观此圆明。欲小便小欲大便大。乃至周遍十方佛刹皆悉周遍。或欲睹见十方诸佛无量无数色像言语所演秘藏见神通事。皆得明见。譬如善巧金师得好真金。百练清净柔软无垢。随意所为随心而成一切无碍。此名持诵之果。又所谓出入息者。如世人息。入身复出出已复入。无有断绝间隙。此入观见字轮圆明亦复如是。从本尊心念念流入其身。犹如入息。复从自许身心之中念念流出。入于本尊之心。念念心无间犹如出息。如是念念周环无穷。即是真言行人之出入息也。如是出入息流注身心。净诸垢秽渐得诸根清净。又随事而观字轮种子之色。如息灾白降伏青黑等类。可以类知。如是作是亦能随心成办诸事也。又经中所云。命者所谓风也。风者想也想者念也。如是命根出入息之想虽复净妙。犹是想风所成。亦当净之。所云彼等净除已。作先持诵法者所云阿字者。以一切种子皆从阿字而生。若观种子相即不观阿。若并观者即有二相。是故但观阿字为一切种子。以一切法不出阿字门故。斯谓先观种子别相。次至此中。一一须入阿字门。若入阿字门。即见本不生理体也。如是见已即三业皆通。以身通故。普见色身随类普见所喜见身。以语通故。能以一音遍至十方佛刹。亦能普应一切众生语言差别。以心通故。乃至一切众生心所动作心。所戏论无不明了知之。亦能知诸如来秘密之事。即是究竟六根清净成种智也。修真言行者。先承事一月念诵。谓一月之中。先当作如此如上观之。又秘释者一岁十二月而成。还复本际得其元本。亦如菩萨十二地。即十住等妙之觉。犹如十二月。故此中得一月之分。即是入初住地。一一句字或本尊等。随一一谛了成就无有障垢。故云一一句相应也。行者前方便者。如是观行之时。若以一花献佛。至心回向。愿令此通达一一句中解也。并下文花遍十方一切刹土普作佛事。尔时应念即成。乃至香食等事。一一如是广说。设天大旱或有种种灾患。尔时行人一花供养。愿令此旱得除降注大雨。或愿诸患自息无不应时成就。复以此一一功德回向菩提。普施一切众生。如此菩提大愿亦当成就。何况余事也。前云一月者即是心与一境相应也。一一句通达者。谓前观字轮观声轮及本尊种子。一一明了现前无有错谬。名通达一一句也。先观佛得成即见圆明随一得成余即成就谓观本尊明了之时。圆明字轮等相自然成就。此月即是月喻三昧。法性清凉乃能普现众生心水之中。非如世间月也。但借心为喻耳。但随一成余者自成。然所以具说者。至下文各有用处故。须具明观月法用也。诸佛大名称。说此先受持者。即是最初成就种子也。次当随所有。奉涂香花等者。谓能以一花普遍法界。乃至愿力因缘。能除众生种种苦恼。如普门常所说。岂是一花而能成就如是力愿耶。为成正觉故。回向自菩提者。当知即是自心菩提种子。明净显现自在之力用也。次云此中释两字深义。如是于两月。真言当无畏者。即是及于悉地义。今此是大用耳。第二月也。第一月谓成种子故。第二月谓成位故。次满此月已。若成世行者入持诵者。若成世间说者。即是初一月持诵。次一月于世间法中而得成就。谓种种药物以法成之。能得闻持一闻不忘。乃至力通明行皆得善成。于大空而得自在。若出世义说。即是随其成就之时。能满一切所愿。所谓山峰牛栏者。观义。作成就时如于山。即与中道山相应。一一事皆与理相应也。谓不动名山。即是大菩提心。在此菩提心最究极之地故名山峰。如人登山下观万物莫不明了。此法性山亦尔。下观法界圆照无碍也。牛栏者牛是五净所生。能却秽除障成就清净之事。以牛净所养故。细草丰茂自然滋长。此菩提心牛栏亦尔。能防妄想分别之过净诸心地。以大悲水洒之平等地。所生功德任运成长也。两河义上已说之。两河者谓流注不绝。是生死流又心心寂灭趣于法性大海。是出世流。于此中间。是中道妙住之境。堪造妙成就也。言四道中者。谓四圣谛道中也。一室者。谓除诸境分别在于如如之行。以此为室也。大天室者。所谓涅槃之室。以此成办菩提自在力也。若不入如是大天之室。云何能成自在力耶。曼荼罗义如上说之。四角为作金刚三股之象。周匝相接名金刚宫。若作秘说者此是大智莫能坏者。以彼金刚妙智。结金刚界护菩提心故。所作皆办也。作护谓以降伏三世明及不动明。而护诸事。若理说者。此降伏三世不动明王。即是大菩提心。堪能守护一切众生令彼善根自在成就也。药物力成者。谓空青苏油牛黄等。随事成办。如余处说之。理说者即是身口意成就。所谓三业无尽庄严之藏奋迅示现。成就法界众生也。佛法法尔。先以事中成就。然后用净慧大空而观察之。即是出世成就也。药及与心成就之时。有上中下相。日出为上夜半为中初夜为下。于此时中有相。当知随事即知是上中下成也。初夜是初入未证之义。半夜是菩提心义。谓从此以从背暗向明。然犹未即是大明也。至日出是成相。犹如大日普照世间也。于此时中。或有[合*牛]声。或种种鼓声。或大地动。或闻妙音声种种妙相。人所乐闻悦可其意。或在空中或在坛中。若有是相。当知即是世悉地成也。若理说者。一一法合之处得果。谓三乘之果。或转法轮得大势。乃至长寿寿量无数。胜进游于虚空净眼明照。净了无碍净心遍智耳。已上成就世间品竟

大毗卢遮那成佛经疏卷第十大毗卢遮那成佛经疏卷第十一

        沙门一行阿阇梨记

    悉地出现品第六

尔时世尊复观诸大众会。为欲满足一切愿故。复说三世无量门决定智圆满法句者。观察大众非无因缘。先以佛心。而观察彼众生种相体性。堪受何法应何种而得利益。如是观已。当知于彼彼法门而得悟入故。为欲说此故先观机也。三世无量决定智门。谓于一念三世之中。无量无碍智门。佛以种种方便说斯妙法。一切众生各随所应智门而得决定。其门无量故言无量门也。佛观大众会。为说此普门法界趣入之门。欲令各随本缘而得决定故。名决定智门也。法句者。谓先触事从事能生于理。故名为句。即是句偈依。世句偈法以名字说。满足者入此法门能生法门。能生法界无相如来自证秘密之法。将欲以如是法满足一切众生。令无空过故也。此句即是偈也。未及会句。后当以义作句偈也。虚空无垢无自性。能授种种诸巧智者。谓一切智智之心等空。无垢无量无碍。无有分别。即是诸佛大空现证之法。无自性者。谓此空无垢清净法界。亦复无有自性不可执取也。以如是即彼大空。无为亦无自性故。能生一切智智。即是巧智。智之异名也。若非巧智。岂能随一切众生种种心行。见其所乐见身。说其所宜闻法。称其得解之机。皆悉不虚而入一切平等法界。即是巧中之极巧也。以平等空亦无自性。有相生灭亦复无性故。于法自在能生巧智。普与一切众生之愿。不可思议度量也。由本自性常空故。缘起甚深难可见者。此不可得空之自性。即是第一常住法佛之身。以离空非空等八颠倒相。是即甚深从缘起法。无为无作而能不动法界普应众生。机应相关如月现清水。如是缘起法不可思议也(空之自性常有不是先无今有已有还无故谓空本性如是也)于长恒时殊胜进。随念施与无上果者。恒谓常修如是法行。乃至大空亦不可得。无自性故犹如大空。而能生起万行。此甚深平等法界之行。行者若能常如是行。即能随众生所思愿而满足之。乃至无上大愿亦能与彼也。譬如一切趣宫室。皆依虚空无著行者。此恐人不信解更引譬譬之。如一切世间。皆依于空而得安住。而此大空更无所依。不作是念。一切世间由我而生依我而住。此世间亦于处空不念恩德。而求报之不作是念。此空力故令我得如是安稳。何以故不见虚空有造作之行。故不念报也。故次会云。此清净法亦如是。三有无余清净生者。合云如上所说之行。亦同于空。除三有之障令无有余。能生清净之法。所称法性清净妙身之生也。次云。昔胜生严修此故。得有一切如来行者。更引古为证。胜生谓先生也。先生谓先觉是法者。若觉此法即无尽庄严。无尽庄严定慧神力妙严之藏。谓过去菩萨名为胜生严。此即佛子也。即是先修行者。如言先生也。梵云避部。是不久满足诸财宝。谓法财也。即此德以严身也。此先觉者。即曾得如是法。一切诸佛亦皆得此法也。次云。非他句有难可得。作世遍明如世尊者。次意云。若离此更于余法句中。能成如是不思议法界之果。无有是处。假使于中求之。亦无得理。如水中求油无有是处。若人能得此自证非他。不由他悟之法。即能照明世间如日照之。亦如佛出世时。普为一切无明世间而作大明也。说极清净修行法。深广无尽离分别者。佛说此极清净无分别离分别甚深自证之法。此法深广。不可思议不可破坏。无有穷尽。即是叹法德之意也。尔时毗卢遮那世尊。说此伽陀已。观察金刚手等一切大众。告执金刚言。善男子。各各当现法界神力。神力亦是动用神变也。此神变是广义。从一得多也。悉地流出句。若众生见如是法。发欢喜踊跃得乐受住者。佛观大众非无因缘。为欲令彼各各说。从不思议法界自在神通之力。流出悉地之句也。此流出名为门。是梵音多含。今此中意明流出也。谓从自证法界佛心。而流出无量巧智之门。即是如前一一菩萨金刚各是如来内证之德。从此现法门。门有传法摄众生者。引彼一类从此门入。而到一切智智之地。佛意令彼各说入实相门。若有众生种。彼根性者。当生喜悦发起善根。即从此门成胜进行。住于如来安乐之行也。时诸执金刚。为毗卢遮那世尊作礼。如是法主依所教敕者。依佛所命不敢有违。然如来是法主。若于法主前各各异说。则非所应。是请佛自说令一切闻也。何以故。世尊于世尊前。自说如是随所通达法。非是所宜。此是回文也。时诸金刚复请佛言。惟愿世尊哀愍我等。示现悉地流出句。何以故。于尊者薄伽梵前。而自宣示所通达法。非是所宜者。此意云何。如来法王尊胜无上。以于此法中现前通达。究了明见无有余故。我等由佛恩力各从一门。随自心量而得通达。若于如是大法主前而自称说。则非所应。此是惭愧谦退之意也。如是陈意。愿佛自说也。何以故。为未来世众生。当遇是法得大利益。开佛知见速得成办如来安乐行故。如是说已。如来告金刚手等言。善哉善哉善男子。此如来所说法毗奈耶中称赞一切。所谓有羞。若有羞善男子善女人。见如是法速生二事。谓不作所不应作。众所称赞者。佛赞意言。此诸善士。虽于所入法门得善通达。以仰敬如来生惭愧故。不敢陈说。当知即是善士之相。故言善哉善哉也。次即因其所行而引接之。故言如来所说法律之中。唯常称叹一法。所谓羞耻也。西方梵音与惭愧异名。更相释云何惭愧。谓具羞耻。若人具羞耻之心。即是有惭愧也。如来常称叹此一法。若人能有羞耻者。则成就秘密之行。当知即是发迹之处。故因有羞耻故。得具二法。一者所不应作事业皆悉不作。云何不应作耶。如世间人。各当观察自种性中不应作事即不敢作。世间名为有羞耻人。今此善男子亦尔。于如来种性之中而自观察。知此法中一切恶业。皆当不作。即一也。由不作恶故。则为如来之所称叹。非但如来。亦为十方诸天人阿修罗沙门婆罗门众及凡圣大众。常所称叹传宣说。此即是不作众恶之果报也。又众所称叹。即是俱行一切善义。由具一切善故。为大众称叹也。复有二事。所谓未至令至者。谓未至者令至得到一切智智之妙宝洲所。由有羞耻故能行二法。由前二得则能至所至处。昔所未悟而今得悟。昔所未闻而今得闻故。是一也。二者由得至所未至故。即是生于如来种性之中也。与一切佛菩萨共同一处。常不舍离微妙胜进。即其二也。复有二事。谓住尸罗者。所谓除热得清凉是尸罗义。如其热者思清凉池凉室。善得入者即离热恼众患。又如热病之人得除热毒病。即身心清凉善得安乐。义同清凉义也。菩萨之人性戒成就。不由制戒任运而有。譬如大海其性自尔不宿死尸。非有人物令彼如此。非同声闻戒也。第二法者。由具戒故常得生于人天中。此谓未得法身地者。世世生处常在人中天上。得离障见佛闻法。此即大利也。善哉谛听善思念之。我当宣说真言成就流出相应句者。此善哉中有二仁者义。谓佛叹彼贤善之德。而或告之令善听也。流出者如佛出光。先有出处。谓面门豪相顶髻等处。出作佛事已周竟已。而复还入。此流出真言亦如是。当知从真言中流出也。谓流出悉地之果。此真言本从如来自证之德。于佛心地而出现。作无量法门大作佛事。作佛事已。令彼应度众生。即从此门入佛法界。故名流出也。故次言此所流出相应句。真言门修菩提诸菩萨。速于是中当得真言悉地之果者。此中果者。谓得不思议一切智智之果也。次之初首。若行者见漫荼罗。尊所印可成就真语者。自此以下更明次第供养法。先得见漫荼罗。非但得见而已。须为师加法引入如前所说。非但得入而已次第修行。随法修行故。得阿阇梨印可传法。得印可灌顶故。次云真言成就也。复次世间持诵品中先观圆明中。有环绕真言字轮(头尾)念诵时从初字。于口中入流入身中。犹如入息周遍身分。此是如来自在神力之所加持。如是念者。能除众生一切业垢也。如是遍身已还从口出入尊足下。遍至本处。如是一一字流入之时。以次字即相续不断次第连环也。若初学人。恐心散乱不能如是成者。当只观种子字。如前作之。乃至心串习已渐加字也。移此一段入前品中。如前说。见漫荼罗又得入已。作诸法事乃至灌顶。既得受法如法修行。善解真言中次第法用。明了无碍。堪能传法得师印可。经言尊者即是师也。又能发菩提心者。所谓为求如来自在之业。普门利益一切众生故。而行此行。非为余事。深信慈悲无有悭吝者。谓于甚深广大不思议法。决定正信无有疑心也。又于财法心无悭吝。以大慈悲心哀愍一切。常作利他之行不求自利也。住于调伏者。谓自调六情诸根。此即性戒也。能善分别从缘所生法者。譬如明镜。现对众色明了现前。如是等法。非由镜中先有。非由色从外来。当知二法和合亦不能生。而于是中宛然明了。不可执取不可求得。而亦非有非无。但从众缘和合故有可见。如是一切法当知亦尔。乃至十喻皆能通达。如是观已。于真言悉地之果。亦如是观之。此悉地相。由自持诵者及本尊真言和合因缘。则有一切不思议事。法界镜像不可取着。而种种成就也。受持禁戒者。即是持明之具戒。于中一一法则皆善受持。以是因缘不犯三昧耶法。得悉地成就也。善住众学者。即是真言门上中下法成就之相。一一所应学事皆善通达。即是善住上中下法之中也。具巧方便者。即是体解如来善权之用。如修真言行时。或于出家二乘法戒有所违犯。不应生如是迷执。我由此事故毁犯是戒。当知去恶趣。心怀恶作而妨正修。何以故如来所有方便。唯为如是大事因缘。若令为不持方便诸乘清净戒故。而妨真言圆满之行。无此理也。是故行者设有犯时。当生是念。我今志求无上大乘。普利一切有情故。事不兼遂故。于是中有所违犯。若我逮得成就果已。当应悔过。以此善心非是犯戒因缘故。不名犯戒也。勇猛者义如前师弟子中说。知时非时者。真言门中一一次第法用。不得回前着后回后着前。应先作者先作。应后作者亦如是。即名为时。乃至饮食睡眠种种诸行。各有时非时相。如真言行者。若昼复睡眠通夜不寝。如是等事亦非三昧耶。非合时也。好行惠舍者真言行菩萨常以财法施。摄取众生令入佛道。若不能如是随力作者。即犯持明戒也。心无怖畏者。若在众中。有诸异解异见众生。或断疑或试问深浅故有所咨问。尔时安住于法。以无畏心无取着心。随问为说令得入于正见之中。心不怯弱也。勤修真言行法者。于修行门。终不中断无有停滞。若在中路悠废。即非精进之相。当得者不得。已得者退失。即令于道有碍。是故行者一心精进如救头燃。以精进不放逸故。乃至能于此生得佛知见。何况诸余助道之法。不尔犯三昧耶法。通达真言实义者。知上中下成就中甚深意趣。一一字中男女声等。从所入门乃至成佛。于中通塞之相善分别知。所以尔者。此诸真言即是如来自证之德。以此庄严法身。令诸众生。各从有缘之门见实相故。若入一字之时。即具无量门功德。无二无别也。常乐坐禅乐作成就者。于真言门中。心住一境而不散乱。如观字观声本尊种子。随于一事心不外缘。即能得大成就。若心在散乱。设经无量劫中欲求成就。尚不可得。何况一生现得法利耶。次说真言成就之相。或有疑言。诸法实相无为法中。亦云何有如是种种事相耶。今欲悟彼故。答言此事实有不应生疑也。且取世事为譬喻。又秘密主譬如欲界有自在悦满意明。乃至一切欲处天子。如大乘中说。欲界有卅六处。谓寒热地狱各八共成十六也。又四大洲。此四洲又各有二随州(合十二州并前廿八)及六天并傍生鬼(合三十六)此自在天主以此悦满意明力故。现种种杂色欲乐之具。能于一时满此卅六处。又云于此迷醉出众妙杂类。乃至而亦自受用之者。所为一切天子天女等示现内外有情无情之境。如现食味音乐等。一一可得现前受用。若见女色等身。亦可五欲自娱。各随彼心之所欲。为遇极妙五欲境故。心皆迷醉也。何况如来真言。而不能普见色身作佛事耶。又善男子。如摩醯首罗天王有一明。名曰胜意生明。以此真言力故。能于一时作大变化。遍此三千大千世界。现为一一众生。现所爱乐诸利益事。随彼受用皆实不虚。又化净居天身及彼微妙受用之事。如经所说。何况如来真言力耶。且置是事。如世幻者尚能以其真言。云现种种园果及乘人畜等。又如阿修罗自有真言。能化其身同于帝释。坐于三十三天善法堂上。令一切天皆生疑怪。又如世人有真言。能摄诸毒及寒热众患。又有[怡-台+乇]怛哩天自有真言。能为一切人作大疾疫。乃至世间现有人。以真言故。变火为冷变冰令热。何况如来自在神力所加持真言。而不普周法界大作佛事耶。是故当生信心。信此威德力用真实不虚也。彼持诵者未得悉地以来。当疑心定有此事为定无耶。如此不思议果。若以心量为分别之。终无得理。为除此疑说前喻。然此真言威力。不从真言中出。不在持诵者处。亦不入彼所加持者身口。推求性相了不可得。而能作一切事随应曲成此即甚深缘起。法性从众缘有。如彼水月镜像。不可思议缘起也。善男子真言加持力故。法尔而生无所过越。以三昧不越故者。所谓真言悉地本来成就。何以故。如来现证如是不思议法。所谓阿字自体。从本已来具足无量自在力不思议力。此悉地体常住不变。但由行人不自了知故。不得如是之果。今以此行净其身口意业若能与法相应。即自成就。诸法自尔终不虚也。此不思议果。众缘会时自当生起。如大海潮终不失时。又此真言。自无始无终。若有始终则有穷尽。则是无常败坏之法。云何名为如来自在力耶。以此法体出过三世常在三世。是故于三时中所作佛事。自然常不休废不失期限。如大海水若白月正圆。自然鼓涌无有失期也。甚深不思议缘生理者。若真言本体先不成就。则不能随感而应不失期限。若真言虽有是力。而行人心行未与相应。则亦不能令彼加持显现。然缘会自成。故知不从彼来不从此去。亦非二处。无性而能缘会。亦成悉地果。亦非自然有之。当知即是甚深法界不思议果。从缘而起常自无性不可思议。若行人修行不断。必是极果合于至理。如是至理。不可以思量分别而能了知。是举前喻劝信也。是故善男子。随顺通达不思议法性。常不断绝真言道者。此真言不思议果。既非分别能知。亦非随力分。有着行处小对治行而能取证。是故唯信力坚固者。乃能入之。故先举喻。次更明至理。劝令依于此门。观不思议缘生至理。常求通达如是不思议法性。随顺此理。而修真言之行无令间断。自然成佛也。此真言道。即是不可思议法生处。由不思议因故。得不思议果也。尔时世尊复住三世无碍力依。如来加持不思议力依。庄严清净藏三昧力者。依三世无碍力。依佛不思议力。此有二种依也。此三昧是不思议三世无障碍加持力用所依止处。依此法体。能成如来不思议业。所谓普遍十方三世。普门利益一切众生。皆令毕竟住于一初智智之地。此如来不思议依自证之法。无量定智诸力。以自庄严清净者。即是真言体也。此是如来众德之藏。无尽庄严无有缺减。具足成就相也。即时世尊从三摩钵底中。出无尽界无尽语表。依法界力无等力正等觉信解。以一音声四处流出也。谓从阿字出三字成四字此四合为一而遍布一切处也。声门字出亦遍一切也。普遍一切法界。与虚空等无所不至者。佛住三昧之时生此表业。表者标也。此声能遍一切。所谓诸佛之所印成。印者即是标表义也。即是如来语表也。谓从如来信解之力(序分已解)声闻者所出声处名为门。此声闻即是阿等四字也。以从此阿字而出声故名门也。此阿字即是佛口。即是佛心。即是说者。即是闻者。法界依力无等之力。而生平碍语表出无量声。即是如来普门导利之语业作用也。从如来心出此平等妙音分为四处。如从无热大池生四大河流注无竭。此真言依处亦如是。以一妙音能表无尽法界。展转相生无有穷已。此四处者。谓四字四德四色四与愿也。从法佛心四德开敷。此中以事表内证之理。则四字不同四色用异。所与愿等亦复不同也。此之四德普遍虚空界。如虚空无量无分别。离中边故无有穷尽。此真言示现亦复如是也。次明佛心中分四处也。真言初云归命一切如来。次句种种门者。微湿缚是种种义亦是巧义。目契弊是门义。即是普门示现种种妙智业巧度门也。萨缚他是一切也。非但身口致礼而已。乃至三业遍皆归命。如身表中内外身一一支分。皆遍礼一切如来也。次真言体。阿(上)阿(上引)暗恶。此四字义已说之。从是普遍等正觉(回文也)心从是普遍。即时一切法界诸声门。从正等觉幖帜之音者。则从是真言四德。普遍一切如来之心。如从一字而生二字。二字生四字。四字生八。八生十六。如是展转无穷。然最初字即同第二字。第二字亦即同第三。平等无差别也。此四字是此一部经中正宗体也。一切秘藏皆从此生。即是毗卢遮那佛心也。此标表音声互出声者。如上从一出四。从四出无量字及声周遍法界。一一字声皆互出声。此一字声中。出余一切字声。余字亦尔。此即是佛之标表用。此不思议声互相通达。表一切如来自他无量德也。于一音声中。各出无量种种音声句义。故云而互出声。诸菩萨见闻是已得未曾有。故云希有也。开敷眼者。心在定时其目不开不闭。今见是事怪未曾有。故开敷其目。今私谓如莲未开因日光故开敷。此菩萨心目亦尔。因佛加持示现故开也。发美妙言音。一切智离热者前而说颂曰。谓于一切智智离热恼者前。而称叹也。奇哉真言行。能具广大智者。叹此真言之行甚为奇特。乃能从如来心而现四德。从此各出无量不思议秘妙之音周于法界。一一声又互出一切声无二无别。而有差别用成佛事。即表如来妙严之藏秘密法身。具有无量功德庄严也。故云能具广大智句。此智无边际。犹如大虚普含万像。故云广也。故此广智。即是无等智无比智。由此智句能令成佛。若此普遍者。所谓以此真言普遍一切世界。即此阿字门也。成佛二足尊。于真言字中。以此妙音普遍世界。能令闻者必定于无上菩提。故云成佛两足尊也。是故勤精进。于诸佛语心。常作无间修。净心离于我者。有二勤。上勤是精进不间。下勤是常修不间也。梵音别故谓于此一切如来所说真言之心。即是如上四字劝诸众生。当于如是所说真言之心。应勤心修学句令无间断。常当以此而净其心。净谓净于内外一切妄业诸障也。离我者谓离人法二我故也。当知此心即是佛心。佛心者即是真言心也。尔时薄伽梵。复说此法句。于正等觉心。而作成就者。前品已说世间成就。送于行人令至出世成就。是以于此中。说用佛心作出世成就之业也。佛心谓如上真言四字。随取一字作之。皆得也。作此成果当得出世之果。正等觉心即真言心也。欲作此成就者。当先择处。园苑谓人所种殖栽接园苑之处。若不种自成。即是广野非苑也。寺者毗诃罗。此方译为住处。窟是山间自然石窟。或是人功所穿作之。或复行人心所乐处。亦得于中修道也。若就秘说者。园苑谓大菩提心。此处宽广无所不有。依此修道最为第一上处也。住谓四梵住。或云是大悲。以一切菩萨常乐住此中故。窟谓幽邃清闲之处。即是甚深禅定之窟。师子兽王亦住其中也。或意所乐处。即是于诸法门随便宜时。随一一门系念而行。谓六度等如般若所说。于中随自意修也。观彼菩提心。乃至初安住。不生疑虑意者。谓即以心而观自己菩提心此是出世成就之正行。作住于此无有异缘。即是三昧。于此观中常自觉故。一切疑网渐当净除。乃至到于不疑之处诸疑不生。即是真住菩提心也。当时有种种相貌等。勿生疑虑。即渐见真实如也。然此中行时。略有二地。一者谓非三摩呬多地。亦是三摩呬多地(译为等引也)于未成就时。要当先有成就之相。乃至欲成就时。亦有欲成就相。此皆是非三摩呬多地也。谓初得世间成就时。所加药物等皆有不思议力用。乃至能游佛刹。是未成就之相。犹得此现验不思议事故。心得决定信。更增胜得入等引地也。行者初修出世间观方便时。先观本尊。依画像善观已。初时闭目而得明了。其后渐开眼亦见。显现明了无有隐昧。此是未等引。若以得如是事故。其心倍生信乐。由此信故其心清净。渐当不取着等心无二。此无二亦除。无有中边差别之见。除诸心缘万法平等。尔时名等至相也。以众相现时虽未成就。然由此故能得渐成故。云彼为未等引地也(私谓如世间未到地定也)随取彼一心。以心置于心。证于极净句。无垢安不动。不分别如镜。现前甚微细。若彼常观察。修习而相应。乃至本所尊。自身像皆现者。初观本尊得明了现已。于四字中随取其一。置本尊心上。此是经中云与心相应也。谓以此佛心之字。安本尊心上(取心谓取佛心字也置佛心上名与心也)随取一真言。心于本尊心上。而想置心真言。或自身为本尊。而置心字于心上。故云以心置心等也。如是观时。作极净无垢之观。以一切心本尊常尔故。如是观净之时。以不外缘安住不动。不分别一切法相。而不生妄想。尔时与观佛三昧等相应。譬如净眼之人面对明镜。此中镜者。即是观本尊心上圆明清净无垢。所谓极微者。谓初观种子字时极令细小。以是心种子故也。先既观见本尊像已。于本尊心上观此明净镜。镜中有此字。一心观此字。即于此中得见本尊真实之相。亦自于圆中自见其身。此犹是未等引相也。如是唯住一境。不为垢障所动。常如是修习故。自影像现时。心上亦有圆明及字。初观之时。随见一字三事自然现也。后时心中圆明上见本尊。本尊圆明上复见自身。如是互相照见无有障碍。名影像成就。此亦是非等引地也。次第二正觉句者。初观本尊今但观佛。所以尔者。一切尊形皆是见法身门故。于镜漫拏罗。大莲华王座。深邃住三昧者又此镜中如有窟像。观此窟甚深中有如来。在此窟中深邃而坐之也。总持发髻冠。无量光围绕。离妄执分别。本寂如虚空。于彼中思惟。作摄意念诵。一月修等引。持满一落叉。于中作如是观。是名真见佛也。如是见时。彼佛心上作字。真言字一心诵之。此是一向摄意。在于一境更无一外缘。心心念诵不令人闻。然于定中自然有声流出。如流水不断也。所云落叉者此译为见。谓心住一缘明了现前也。若就世语则是十万遍耳。一月诵者。一月是等引圆满入于初地。于秘藏中。初地是第一月也。此是等引之地。前云三句。菩提心为种子。大悲为根。方便为后。此中具说行法也。第二句观佛在于心镜深窟中。乃至自形作本尊。先观本尊心上圆明净镜。镜中有窟状中有本尊。即是真见佛也。见佛已。此佛心上复有圆明圆净。初观此极净心镜甚微少。后渐大也。对面宛然故云现前也。净无比中有种子字。一心正观此种子字。即是诵彼字也。从此得见其心。又见己身。如本尊体相在佛心中。若观自心上圆明。亦是如来本尊在中。如是展转相现不相妨碍。本尊清净离诸分别。剂此名见。菩提之心为初成佛种子也。此亦名为一见一境。故名一落叉。此是出世行中先承事法。如此成者是入信地也(更问菩提心行相)次云摄意者。从一至一十。亦如是一若至一百一千一万等。亦皆是一。以遍多时故。至多时能自见也。梵音即云三摩呬多是等引义。亦名摄心一境之义。即一心义也。次于第二月奉涂香花等。而以作饶益。种种众生类。又复于他月。舍弃诸利养者。如前世间行中。亦有涂香等供养。此中复说者。意与前殊异也。此中已得等引。其以清净调柔。随事能成。随奉一香。即能如实遍满法界。普遍一切众生界作种种利益。随事皆成。如花严回向中广说其相。如香花者。随有一切所作。亦复如是。无不成就大作佛事也。又他月者此中有两月行。即到初地(更问)弃舍诸利养者。以文解之即是舍于八法违顺之事。为妨道故。若作秘意。是此菩萨大种善根。此报无尽不现。得无量法门功德之宝。不应于中而生取着。若生取着利养。则不速入于正位。故须舍此利养也。彼时行者复更如理思惟。即是菩提心而发悲愿。理摄而起故。言如理思惟也。此中思惟意者。谓我当谓如是应理思惟而得自在。时彼于瑜伽。思惟而自在。愿一切无障。安乐诸群生。即是发决定悲愿。云何众生同有如是觉性。而不自了受大苦恼耶。即生大勇猛心。要当以无数方便而成就之。必定皆令到一切智地。除彼一切垢障使无有余也。乐欲成如来。所称赞圆果者。谓如来无量知见。究竟成就巧度妙权。若不得此。云何能以一大事因缘而出于世。如是诸佛所称叹。彼妙方便我当速成。满足一切。有情众希愿。应理无障盖。而生是攀缘。如是无有障碍。以如是攀缘而念诵也。以我功德。拔一切苦等者。以大悲心。满一切众生之所希愿。拔彼大苦而与现乐。亦能成就。何以故。行者自心无垢障故。即有大势力能。又为众生随分除障。由彼我无障因缘。即能随事成就也。此即普贤行愿也。此相云何。谓生如是大悲之愿也。傍生相啖食。所有苦永除。常令诸鬼界。饮食皆充满。地狱中受苦。种种诸楚毒。当愿速除灭。以我功德故者。以我所生无量胜福。他月舍利养。谓第三月。于内外无所贪着。名舍利养。然外事从不求不受施也。舍此利养而不舍众生。由真言行故皆得成就也。及余无量门。数数心思惟。发广大悲愍。三种加持句。想念于一切。心持诵真言者。此等悲愿亦有无量种。不可初一月二月持诵。亦谓如是发愿。但初二月以信解心作。然未能成。第三月所愿皆成。故回向自他也。真言行者若得意时。随事而作如是。频以大悲之水而洗其心。渐令此菩提心有大势。迄至第十一地以来。渐渐力用增长。皆由此圆满也。初一月菩提心。次月观佛形像名正觉句。第三住真言离一切相。名三月亦名三落叉。又广大加持。谓如来加持神力。由三句得成。今欲行如来事故。思想念此三句也。故经云。以我功德力。如来加持力。及与法界力。周遍众生界者。此三句和合。而广大加持力生。如是念已。应诵念此句。此是一切真言心也。取三句功德。随取花等以心念加之。如花即以花真言。香以香真言加之。乃至一切处。拔苦与乐献佛等皆成也。若不用本真言加之。用后明妃亦成我功德力于众生界。周遍如来加持力等法界也。诸念求义利。皆悉饶益之。彼一切如理。所念皆成就也。由住理故。随所系念而成也。乃至除苦苦即除等。以我功德力故。以如来加持力故。以法界平等力故。以此三缘合故。则能成就不思议业也。如此作者。当知广应理故。言当得如理也。与虚空等力虚空藏明妃真言。相接次也。尔时如来。复说虚空等力虚空藏转明妃真言曰者。如虚空不可破坏一切无能胜者。故名虚空等力。又藏者。如人有大宝藏施所欲者。自在取之不受贫乏。如来虚空之藏亦复如是。一切利乐众生事。皆从中出无量法宝。自在受用而无穷竭相。名虚空藏也。转顺明者。转顺能生之义。此藏能生一切佛事也。如前所发悲愿。谓如以一花供养时运心。遍一切佛及凡圣。皆供养已。即回向一切智智。语诸受我施者。愿以此力令我得如上愿。如是愿讫。以此真言加之无不成也。初敬礼一切如来等

微湿嚩(二合)目吃弊(毗也反巧门等亦是种种门等也)萨嚩他(一切也)欠(平声空也通上言一切智空也此是种子字也)邬特揭(二合)底(生也)萨泮(二合)啰醯门(普遍也)伽伽那剑(虚空也)

此是虚空藏虚空等力之义。等一切法空中而生此物。普遍一切虚空也。持此三转者。谓随以一花奉献。无不遍法界。上献一切圣贤。下施一切有情也。随彼所生善愿皆亦成就。谓以此真言加之。皆得成就。如从藏中自取宝物无不随心也。若诵此三遍。随所念彼亦成就也。凡所献花等。以三力回向而以明加之。一切随意成也。谓悲花献一切佛等。自在成也。言行人于满月。次入作持诵者。先供养承事已得成就之相。因前相。然后于白月十五日作持诵法。即是满月也。随上中下事作成就法。上事山峰中事牛樠拦下事林间或河滩。乃至四衢天室等。皆谓通上中下成也。或随意所乐处作之。于山峰等造漫荼罗。初第一重周匝画金刚。此坛三重作。皆以金刚为界。其所方神诸佛菩萨等。在后有说处此中未分别也。于此中布列诸尊。总同前倒。但倍以金刚相连结为异耳。言一切金刚色者。所画金刚周匝为界。画此皆令清净无过作之。无过谓圆整端妙也。严净同金刚者。其金刚相周匝如此。悉皆黄色。此有三事同于金刚。色同金刚体同金刚名同金刚也。是故云严净同金刚。即是净同金刚也。言彼中诸障者。摄伏心迷乱者。以此三事同于金刚。无有能破坏者无能过者。无能胜者。无能降伏者。由具严净作此金刚界故。令诸障者悉皆迷惑无敢娆者。既得离障。则所成药物而得成就也

经云。四方相周匝者。此有二义。谓坛正四方作。又金刚印亦四方作。亦正当四方面也。云一门及通道。金刚牙连属。金刚结相应。金刚结者。如上周匝安金刚。皆般般相连。即是金刚结义也。安一门并缘(缘即如上所说开一路空处为外缘也)相应者。谓此门随事相应也。上成就门向东。中成向北及西。下成门向南也。其界金刚互连属。亦是金刚义。门门二守护。不可越相向。乃至朱目奋怒形者。为作成就之物最为守护。以此守护门为要。即是上所说。威光难视及相向守门者也。一一相为印(印在下说)。二俱赤白作极忿怒之形也。殷勤画隅角。输罗焰光印者。即是独股金刚。但有角处皆置之。有光焰也。中妙金刚座。方位正相直。其上大莲华。八叶鬓蕊敷者。于漫荼罗最中。置十字羯磨金刚座。令正四方(正当四方面作之也)于彼上作大莲。八叶并蕊(在金刚作)此即是金刚座也。故言金刚同也。当结金刚手。金刚之慧印者。当即是结金刚手金刚五股印。故云金刚三昧慧金刚印也。言稽首一切佛者。随彼处作护药物作净也。当作礼时如上所说。广大悲愿。数数坚誓愿者。谓自誓运心。弘普誓不为己。乃为一切众生故成此药物。愿加持力令速成就。以此成故。能利一切众生也。应护持是处。及净诸药物者。然具有多法。广本有之。凡取药时。须解法用次第。求自采亦有方轨。乃至作护作净。皆有次第法用及洗等。此中未具。当更问也(或可苏悉地等通用也)于此时持诵。清净无障阂者。而有下中上之成相。若得无障成就者。上成有三相转。谓初夜暖生。中夜烟起。五更焰出中成有二相。谓除焰出。下成有一相。谓但暖生。转者谓从少得多从暖得焰等也。既得成已。真言者自取。游步于大空者。或食涂点等。而得自在游诸佛刹。从一至一。住寿大威德者。便得具寿无量劫数威光自在。于生死自在者。即于生死种种自在故。是名真佛子也(世界上行即是履世界行也)物成已。以金刚印护自身护本尊护物。方取之为五分。师及先成就仙助伴己身及佛也。其物随彼于生。于三宝处用。先成物。若有仙来取当与之。不来取分为二分。一与伴一自取。师物若师在他方。当掌之待来与之。若师不在。缘彼所生为作功德也。刀等不分。亦标心为分剂也。从初至末。皆用金刚自护护物乃至取也。言行于世界顶。现种种色身者。谓为诸众生作大佛事也。其供养药亦有方法。谓献也

经云。具德吉祥者。展转而供养者。得成就已。持至十方。随意献十方佛也。诸佛及与阿阇梨助伴。各有分数。方法也。当更问之。真言所成物。是名为悉地者。若得如此成就者。是名有分别成就也。以此药物等事。犹是成相之法故。名有分别成就也。以分别药物。成就无分别者。因有分别而得无分别成就也。此能分别为因也。依此有分别而得无分别果者。无为无相不思议无染之果。虽非因成。而以有分别为因。然成此无得无为之果也。秘密主一切世界诸现在等。如来应正等觉。通达方便波罗蜜多彼如来知一切分别本性空以方便波罗蜜多力故。而于无为。以有为为表。展转相应。而为众生示现遍法界者。谓无为之果。而以有为方便。能成此事。不可思议。现在未来过去三世佛。皆以通达方便波罗蜜故。而说此法一也。举三世佛。欲明同以此入也。虽复设此有为方便。然即了此分别之法本性常空。如是因缘起法。离于生灭断常一异去来。但如幻化不异中道。若舍离此而求无为别体。不可得也。以无为之性即不异有为。了达如是甚深缘起法故。能以此有为即成无为之果也。是故一切三世如来。以方便力故。虽证法界。而能从此无为无作本体之果。而以有为作诸眷属。如大日如来于此自证之德。以加持力故。而于无为。以有为为表者。本性无所为。因有所为而能成无为也。展转相应者。未持诵时性本不净。由持诵故便得清净。能度众生也。则现不清净身。复为他作清净因缘。名展转相应也。还从无为生有为为表也。故现十世界微尘金刚菩萨。一一以真言门引接众生。皆令得至无为之果是也。以此方便遍于法界。普应一切众生令得义利也。令得见法安乐住。发欢喜心。或得长寿五欲喜游而自娱乐。为佛世尊而作供养。证如是句。一切世人所不能信如来见此义利故。以欢喜心。说此菩萨真言行道次第法则者。谓诸如来以方便故。从无为界以加持力不舍众生。随众生示现修众行。或令见法住安乐行发欢喜心也(即法喜初地也)或得长寿者。谓得无数劫恒睹佛兴也。或得净好五欲而自娱乐。又能供养一切如来。此事无方便者不能信也。彼作是念。真言之体。即同法界无为无作。云何能成是事。若生是事。即是有相分别。云何应理耶。是故生毁也。言此中佛有秘密难解者。是无方便者说也。故不能解了。然此中以心自在说为长寿。如此寿量。即是如来法寿之命也。五欲者。谓四无量及菩提心。一切圣人以此现法而自娱乐。供养如来。即是真法供养法身佛也。若行者依佛方便甚深缘生。得世法成就即于此中观本性空。即是无为成就也。如是不思议法。凡夫自不能信耳。然诸佛如来及菩萨等。见此利义故。说此真言行次第之道。不可谤为无也。何以故。于无量劫勤求。修诸苦行所不能得。而真言门行道诸菩萨。即于此生而获得。如余菩萨。为求无上道故。难行苦行如救头燃。经无量劫尚不能得如此成就。此真言行者。若具方便圣可成就也。以知甚深缘起十喻义故。以真言等。愿作种种成就而无取着。不异于如是法微妙速疾也。复次秘密主。真言门修菩萨行菩萨。如是计都朅伽伞盖履屣真陀摩尼。及安膳那药卢遮那等。持三落叉而作成就。亦得悉地者。次明所成药物。谓如上且先一落叉。次二月持诵已作漫荼罗。于中置此所成物而作念诵。更三落叉方成也。此漫荼罗神位等。即与大悲胎藏同故。此中不说之。但以所欲成物置中。以大日如来置方隅也(决问得)。幢以竹为茎缠以净叠。更悬垂一丈以来。如幡状上作层形。其上安跋折罗也。然刀以镔作骨柄。伞有上中下成。谓金银孔雀也。[焉-正+臼]履以皮作。先种种勋洗极净无气。更以药治之。乃至火不能烧。又极香方中用也。如意取净好宝置之幢上。眼药用安膳那作。此膳那有二种。一极轻逆水而上(更问)牛黄者更有无量药。谓空青朱沙雄雌黄等。皆可成就也。又金刚杵等无量物亦可成就。大本具说方轨。苏悉地亦有次第也。如履[焉-正+臼]得成。即可乘之游佛刹无碍。眼药等成就者。即见十方佛刹。即能腾游十方佛刹。余可解也。又有画作鸟兽种种形。随取其一作法成。即堪御往十方刹自在也。或以法加童男女。亦令彼成就以为供侍。即游十方刹也。西方有一人成。引五百人升空。而去。不知所去也。此法成即是持明仙也。此物随心所欲作之。彼持诵时亦得境界。令作如是如是物也。或可运心而作此物。亦得成矣

经云。秘密主若具方便。善男子善女人。随所乐求而有所作。彼唯心自在而得成就者。世人所不能信彼人得之。谓作成就人也。不能可信希奇之事。皆能得之也。是故云善男女方便具。欲求之物但自心自在。唯如是得成就也。言彼自心自在。唯如是成就者。谓随意所欲。唯心所转即成就也。唯谓唯用自心不藉余缘。唯亦是暂义。才心作念即成就也。秘密主诸乐欲因果者。秘密之法非彼愚夫之所能知真言诸真言相者。若人于此真言行中作如是念。我今行如是因。当得如是果。当知如此非正说也。唯是愚夫虚妄计也。何以故有诸外道。说一切法从我而生。若如是自在喜故即与。不喜故不与。如是等人不能解此道也。应则是万物皆得从因生。若从因生此因则有性。若有自性则堕常见。常法云何能生。若因灭果生即断灭法。云何能生耶

经云。说因非作者。彼果则不生者。意明。因者。因空。因因既空何有果也。故中论智度中广破。当知此因。以智观察尚不得其原。此因无依。无依即是本来不生。本来不生之因何能生果。故如彼果本不生也

经云。此因因尚空。云何而有果者。谓明因非实有。因既非真实终不能生实果。当知果本不生也。又复是因本性空寂。当知果相亦复如是。若于如是缘起法中。而言有因有果即是遍计所执。堕于断常一异不入中道。是故证知如是真言。永离因业故即是法界也(不思议界也)

经云。当知真言果。悉离于因业者。则明因是有所作法。法因既有作。当知果亦有所作。既有所作何能成真实。当知果离于因业也

经云。乃至身证触。无相三摩地者。言此因果等相。妄想故有。正观察之本无所住。无住故果体不生。即同无为也。是故行者若作是念。我诵真言修真言行。当得成果徒自欺耳。若此真言者虽从缘起。而实无作。从本以来本是法界。无生无灭非净非染。法体如是云何得成耶。经云。真言者当得。悉地从心生者。当知真言行者。但以方便自净其心。若三业清净。当于是中自得明了。而自觉悟也。譬如有人。梦中修行种种六度而净佛国。觉见则无成果之相。但是一念无明心中。有因果万行耳也。又如暗室之中而有宝藏。若以方便燃火明灯。虽因缘生灭推不可得本同于空。然亦明法任运起。而以心明因缘则见宝藏。非此宝藏因方便生也。修真言行者。本为除遣惑业。当体解法界无生灭净染离诸分别。知此真言之体。即是法界之体也。若了知真言之体。即同法界等于大空。自然能得无相三昧故。悉地现前当生如是信解也。次尔时金刚手。复白佛言。世尊惟愿复说正等觉句悉地成就句。即是如上所说。一字能生四字。乃至遍满法界。此即见佛心句。今问此中成就之法也。诸见此法善男子善女人等。心得欢喜受安乐住不害法界者。此即是随于此中而修觉者。若得成就名见法也。成就。即以此生而得见谛也。彼见法者。闻佛说此成就之法。必当深得法喜。住安乐行现法乐住。故请问也。不害法界者。意言。非此法界中有所妨碍也。乃至受种种世乐。而世乐即是法界终。不因此而妨碍损法界也。故不害。何以故。世尊法界者。一切如来应正等觉。说名即不思议界。是故世尊。真言门修菩萨行诸菩萨。得是通达法界不可分折破坏者。然此四字究竟成就。与法界无所妨害也。此四句皆是佛心。岂以佛心而妨法界耶。住此成就者。及法界无二无别。故无妨碍。此悉地彼法界。都无所妨。何以故。法界不思议故。是故无量佛得道成就。而法界不增。无量众生灭度。法界不减。若众生胜进亦非加益。若破烦恼亦无所损。亦即不思议界。性同金刚不可破坏。若有妨碍则有彼此。有彼此则可破坏。今无妨碍故不可破坏也。当知此不坏。亦是不可分析之义。谓种种门种种世出世事。同一法界。不可分析令成别体也。行者若能如是通达。即是得见法成就也。世尊告执金刚秘密主言。善哉善哉秘密主。汝复善哉能问如来如是义者。即明重叹执金刚秘密主。为能哀愍未来修真言行者故。发如此之问也。汝当谛听善思念之吾今演说者。此意都语会众言。汝当谛听善思念之。吾为汝说如是之事。秘密主言。如是世尊愿乐欲闻者。重明如来慈悲遍满。印顺斯问而为解说也。佛告秘密主。以阿字门而作成就者。即是于正等觉句中。作成就法也。若在僧所住处。若山窟中或于净室者。随意所欲乐处及秘释。如上已出之。以阿字遍布一切支分。持三落叉。谓以心布此阿字也。从顶及眼耳等。乃至遍于内外身分。又诵此字三落叉。即成也。又彼说云。本尊种子及圆明为三也。字在圆明中。圆在本尊心上。观一成时三皆自成。一缘于此三境。故名三落叉。落叉是见义也。诵此三落叉已。至白月十五日为满月。依文诵三落叉竟。次于满月。尽其所有而以供养者。此谓白月十五日作成就漫荼罗也。作此法时。尽其所有供养三宝。作成就法也。作成就法时亦诵此字(秘说如前可知)作此法时乃至普贤菩萨。文殊师利菩萨。执金刚等。或余圣天现前。摩顶唱言善哉行者。此解言。或余诸金刚此不可定准。随有一尊来为成就也。然见时亦言上中下相。若亲见分明与对目无异。为上成也。若但闻声现前示教利喜。为中成也。若梦见等。为下成也。又见时。明昧等殊。即知有障无障等也(秘说可以心得)。如是本尊等现前加被时。即应当稽首作礼奉阏伽水。此即香花之水。加以五宝谷等。如上说之也。即时得不忘菩提心三昧。行者以得三昧故。令其身心皆得轻安(轻安谓垢障除也)又以如是身心轻安。而诵习之。当得随生心清净。身清净者。谓即以此轻安布想念诵极持。身等五根清净也。如六根品中所说。万像皆见能知佛心等也。以身心清净故即得随生。意生之身随念而生也。随生为因念诵为净。便获随生身心清净也。若置于耳上持之。当得耳根清净者。此解行者若欲耳根净者。想布阿字于其耳根而后念诵。即得耳根清净闻持不忘。能闻十方佛所说法乃至天等之声。亦如法华说也

经云。以阿字门作出入息。三时思惟。行者尔时能持诵。寿命长劫住世。此明阿字菩提心不生不灭门。若欲住寿长久者。想阿字同于出入息(谓以此字作出入息令出入分明不断也)若短命者。如是想念日日三时思惟。即得常寿也。秘说者。字及句并本尊为三时也。若欲摄一切毒。想是阿字。或自或他想在身。若如自在者。想此字于有毒之处。渐遍身分而驱下之。毒渐渐下字亦逐之。逐出尽即除也。毒有二种。一物之毒。二有情毒。谓龙蛇等毒也。若秘说者。毒谓三毒。三毒盛时欲除。亦如前作。谓逐之令尽也。愿啰惹等之所爱敬者。即以阿诃字门作所应度者。谓若欲令人爱念及彼归依者。想阿字作其自身。想诃字作彼身。自身想持商佉。又想莲华即彼持之。互相观看。心中诵此阿字。设彼忿怒憍慢。亦即爱心顺伏也。秘说者。若欲摄伏其心。想自作阿字想心作诃字。心有莲华手有商佉。而令相顺即能摄伏也。一切难伏者亦可伏之。谓上烦恼及随也。佛又告金刚手。诸如来有意生。名业作戏行舞者。从佛心业而生。作种种戏行现种种戏舞类之相。即是普现色身。随类作六道之形等也。舞谓种种神变幻作之事。随事亦现其类众多。不可备言也。四界摄持。谓地水火风界。虽现此身内外依正。然此是心王安住同于虚空。虚空常不动而含容一切也。故唯从佛心业生。随心而有。体同于空不可取也。见谓种种舞戏之相。非见谓涅槃之理也(云又见谓世间果非见谓菩提果此类无量故云广大也)亦见。三乘修行种种法门。随彼所愿而令满足。即是能现种种可见不可见事也。乃至愿求禅定智慧法门众多宝。亦随类示现而赐与之。犹如如意宝王。随心所求一切施与也。等引神通等令起。三摩呬多是等引义(等引神通等令起非等至也)时毗卢遮那佛。一切大众会观已。告金刚手秘密主言(已如上解)金刚手行舞。一切作成坏果广大。亲一切与者。舞是戏也。复普现色身随类曲成。作种种应。此非真实但如幻耳。是故名为如来之舞。犹如舞者能悦可众人之心。虽种种意解不同。皆令心悦。佛亦如是。然非四界之色所作。随佛心意而生。从心而生从心而灭。虽常法而能随缘生灭。此兴废随缘。故云生灭之果。即谓成坏也。此迹遍于法界广大无边。故云广大也。作已遂灭。故云成坏也。广大成坏。此成即是变转义也。故坏。然此成坏即是如来妙应。从佛法界机感而生。虽生不生虽灭不灭。即同于幻不异法界故也。犹所作不实。故名为舞。三世诸佛皆作此舞也。亲一切与者。我亲于先佛授得此法。今复亲授于汝。故言一切亲与也。言亲。谓亲能现前授与一切所愿之果。此义正也。言先作真实相者。如上所观种子真言及本尊。由观见本尊。见已即转自身而作本尊。展转相即不相妨碍。即是见于金刚之果菩提之心。故名先作真实相也。如是次第住者。谓住前所观者。心依善住也。先已见实相已。阿字也

经云。如先正思念。谓如上文所说思惟法而念持也。阿字自己作。并点作广。一切黄极悦意。四角金刚标中。思念持诵诸佛一切处光字也。此等一切佛自当相说者。谓观阿字令作深黄色。其色相端正严好令人悦意。在于自己心。又此字经云。并点广者。即是字上加点义。增加即是广也。于字外作四角金刚标栏。此栏同三股金刚。股更互相叉而作之。于中置字。见此阿字已。即转此字作毗卢遮那本尊之形。即是自身现同本尊之像。其像一依本印而作也。此佛通身有光。此即菩提心中所见实相之佛。犹净琉璃中内见真金像。非同余心数中妄想也。当知如是见者。即是见心实相之佛。作此成就者若无疑虑。即能普为一切众生作大饶益也

经云。谓广大希有者。犹如幻人。谓有种种异事也。犹如诸大菩萨随心所欲利众生事。如幻幻水月而应万类皆得成也。此即如来如幻三昧之句。若能如是作者。无始生以来恶业。及三有逼迫之果。乃至无间重业现身即灭。何况余者。当以要言之。三有众苦果报皆灭也。何以故。犹持诵者以得住于三摩呬多地故。若观如是实相离苦

经云。若观于彼心。无上菩提心。谓观行者自心中无上菩提心也。云心者即是无上大菩提心。若住斯观。即能净身口意业。由能净业故。净与非净业离也。意言。有如是业生。净不净皆不能染也

经云。当业。谓当生此净心之业也。此果皆不能污。何以故。常与理相应故。譬如莲华虽生于淤泥之中。而不为彼之所污染。如是行者即同诸佛。何以故。能生一切诸如来故也。此即是仁中之尊佛也。意云。才观菩提心已得如来之果。况身现证而成佛乎。复次时毗卢遮那如来。又复住于降伏四魔金刚戏三昧。四魔降伏六趣解脱。一切智智满足金刚字句说者。住此三昧能降伏四魔。能除六趣烦恼业苦。而与解脱之乐。亦能满足一切凡圣所有希愿也。佛住此定而说金刚句真言义。此五字即是降四魔真言句也。阿是行。所谓本不生行也。傍二点是净除义。以此义能降伏四魔除一切苦也。味是缚义。加上画是无解三昧。即不思议解脱也。啰是净六根义。由六根净故无尘也。诃义如上已说之。佉义上亦有解处也。又[合*牛]有三义。即如来三解脱也。修行除障故而三解脱。而住大空。欠者大空也。佛说此真言时。金刚手及普贤等。得未曾有开敷眼(如上说)稽首一切一切智。如是说言(一切一切智即诸法一切如者所谓诸如来也)一切即于此中梵音意云。无所不足。即是府库义也。言以此五字为库。能满一切财富也。一切诸佛菩萨救世者。此一切佛菩萨救世者。缘觉声闻害者。此叹声闻之德。谓害随眠等也。又解云。苏啰多是害烦恼者。能遍所行地。起种种神通者。财富即是如来法宝。以给一切众生犹尚不匮。如是无穷大智宝藏。故名富财者也。由法财富能施一切。而说此真言之门。上从诸佛下及声闻。无不依于此句。而能施作种种神变利益一切也。故云随其行地。而现种种神通力也。言行地。谓凡所行处。如偈云寻地山林遍无等也。言彼得无上智。佛智无上智者。非但神通而已。亦由此句。一切圣贤得成智慧。乃至同成一切智智也。然二乘智。对世间亦名无上。今更明佛无上者故。重言之也。先赞已后请说佛此五字次第广说也。及布想等种种类者。所不言此更皆请此中说也。于布字想字上中下成。色用差别种种方便。皆请佛广为宣说也。种种门中。成就进趣顺行此法。名为教也。请自说此教者。请佛亲演说之也。若佛广说此法。诸行大乘无上真言行者。当得见法。若已见者亦皆欢喜。见法谓证得也。当住者谓自见已。复授诸众生也。由见此事自他俱获无上法利。故请佛广说。本经有三千五百偈。说此五字义也。三摩醯多。正议是住心一境之义。佛欲说金刚之句。普令大众住一心境而听也。欲作此金刚真言之成就之法。先令作金刚座。如佛初欲成道时。在于金刚道场。复除此座已。更无余座堪能胜致此也。于时大金刚为从地尽地际也。此地际加持下身者。为欲说阿字。意云。此字最胜也。字第一。加持者今为欲说此法故。先以加持自身也。即下身。谓自脐以下想皆作纯金刚也。此有内外。内谓如上所说。外谓想自身坐处在于方金刚坛中。其坛已如上。说方标栏者也。名大因陀罗者。此是金刚中之极刚者。能破金刚。而金刚不能破彼。又是极黄色也。如此紫磨金色。此想阿字为之名金刚轮也。于此座中思惟一切。即是瑜伽之座。此是修行应理者之坐处也。即思惟一切。谓一切事皆此中思惟作之也。事众多云一切也。右初释阿字为座竟。次说长声之阿。此是阿第一命根也。以能活诸字故言命也。若无阿字诸字即不生。故第一命也。此是能摄召句。若想此字能摄召。长阿即是行。若触阿字即引一切佛行。故云摄召也。摄召一切内外之法。摄召是摄令属己。自在受用义也。此阿字门。能摄召一切如来功德令归自身。亦能满足一切之行故也。次说暗字。若想此字。能摄除一切毒及病等诸障也。内外诸障皆能摄而去之。内障谓种种障道之法。但有现前皆能灭除。外障谓一切外物为障。亦悉能除也。又除诸毒诸病。病谓有种种皆能除之也。又能除者。乃至失心即能救之令得本心。又以此字能摄心一境。速与三昧相应也。若想此字得如上功德。一切能与者。言与即是满其所愿授悉地果也。若持诵者。一月中即结金刚慧印。而诵暗字。于一月中日别三时作之。一切无智城破也。一切众生无明之所婴绕。四合坚固犹如牢城不可破坏。以此字门而能破坏也。得不动坚固者。谓天人阿修罗等所不能坏也。凡一切增益事若欲作。皆坐此座。增益亦名圆满。谓能满一切所愿也。若秘释者。一月是一见也。若得见法入于初地。任运增益一切三昧陀罗尼等及诸地位也。若欲作此增益法时。持诵之人于此金刚坛中。想佛住于三昧身真金色也。光焰有威光义。有威光者。即是兼明本尊义也。梵音如此。即周匝炎光。以发为冠。此即是大因陀罗也。此大金刚之坚。即是佛智之义。能破一切无能除者。想此佛在方金刚坛中。随意作一切成就物也。经云。金刚莲华等者。谓此等一切事。当于此轮中作也。若成就金刚法。五股纯金作之。置于坛中而加持。商佉等上中下成就。亦如上说。谓皆持诵此阿字也。若欲成就佛顶者。以真金为佛顶而加此法。若得成者。即同大日如来之身。或不可须别物。但以自在想作佛身而加持之。若成即同佛身也。若作金刚成就。持诵之者即同金刚手菩萨也。莲华者。以金作八叶莲华等此中持诵。若成即同观音也。刀者。作亦有法。若成即同文殊童子也。鹅者。作法若成即以此。自身成梵天身也。于成就外财之中。或成就金或地(地谓伏藏也)或如意珠等。但与增益相应者。皆用此法作之。具有上中下法也。言大因陀罗观者。谓于金轮中观故也

大毗卢遮那成佛经疏卷第十一大毗卢遮那成佛经疏卷第十二

        沙门一行阿阇梨记

    悉地出现品第六之余

复次凡加持法。如前云加持风等。作七点等法犹未尽。此中具足明之。凡一切为障害道者。皆用此法令不动也。一切一境者。令一切住心而体也。作此法。先想八峰须弥山王。八峰谓四面周匝作于山峰。于八峰上想莲华。华上有三股金刚。其股向上

经云。置彼顶。是杵上头也。向上此上想作阿字。光焰围绕之。如是想已。一切障皆令摄除也。如是摄彼。令住一境而不得动也。非是不动尊。是定住义也。自在随意修道无碍也。又成就药法。凡如是等欲成就时。具有次第法用。今此中但略明大宗耳。作药加法一百遍。凡言百者皆加八遍也。诵已自证饮或以与人能除一切病患。乃至先业之病亦能除之。凡增益事。与金刚黄色相应也。次明嚩字门。即是上◇字。先明其体后兼三昧之画也。其想法。想此字纯作白也。犹如雪山及牛乳等鲜明皎洁。先从脐以上。想作白莲花极白鲜明想。缚字纯白色在于白花之上。成就已。即回此字以作本尊也。此是息灾之中最为第一也。其佛本尊亦作寂然之像。极寂之仪住于寂定。纯白无比同于秋夜月光也。彼漫荼罗当重圆。犹如九重月轮作之。作如霏微白云雾状。而住其中。作此法成。一切烦恼热等皆能止息。凡一切息灾相应。皆此中作也。牛乳珠鬘同者。想此字中。如上牛乳流水连滞不绝。犹如白珠而下灌注其心。或自或他若想此灌之。一切内外热恼无不除也。或想如月或如水精净月之光普皆流注。凡有一切热恼之患。以此注之皆除。一切扇底迦法。与白色相应。此中作也。前阿字是金刚漫荼罗。此缚字名为水漫荼罗也

    □金刚地黄　　○水地白　　△火地赤　　【图】风地黑

空无定形而现种种也。从月轮雾聚漫荼罗中出。如乳流注能除一切热恼。谓内外障即是热障。此悉能除也。免离。谓脱此苦患也。如是系缘一境。成就苏乳珠鬘及藕水精或酪或水。如是等物其数众多。随心所欲作者。但与寂灾相应皆得成就。或求长寿久住无量。或现种种身端妙奇特之相。或云最上者。是爱敬中最上也。令人所爱敬。或求闻持或求聪明。或求智慧及息诸病。如是等皆得成也。若此缚字安点。然除病患等事内外诸毒。皆速成就。此是息灾吉祥漫荼罗也。然摄除有无量事。故云等也。次说啰字除障漫荼罗。于除障中最为第一真实之法。此啰字是赤中之赤火中之火烧中之烧。由能烧灭种种烦恼业苦。乃至现作五无间罪。若修此字门。亦能净除使无有余。既罪灭已则生诸善功德也。此字门所作与不动明王相应。然不动明王句。能作三品一切事也。其法先如上住心一境。观作极赤三角漫荼罗。极令悦意。此悦意定谓令鲜明妙整也。又悦意是当心作之。此秘语也。周匝作于焰鬘。知烈火光焰之状。中观啰字。成已转作不动明王。作寂然之像。非嗔非笑其形寂然也。又云先想不动明王。于其心上作三角。中有罗字。字成回作不动明王也。除障故罪灭。寂然故息灾。即是罪灭福生之义也。次此成就是物者。谓指此三角坛也。言釳罗。是执日之眷属。凡有八曜皆名为执也。凡日等诸执及火天等。同在东南隅作法大同也。谓须火用作之。或转火令冷等皆此中作。然秘之意。是作日故智火也。日亦是慧日也。摄取者。摄取恶法难调之人。皆令柔顺调伏也(义准廿八及十二房等与月水同位)此中摄伏恶人者。谓能摄伏烦恼而得自在人也。及发怨者。能令自他俱得成也(谓发彼怨等)消枯枝分者。能令彼身枯竭无所堪能也。一切身分三毒为本体。令彼消竭无余也。若外相而言。沽涸即是竭龙池等也。彼一切作者。一切降伏相应事。皆此中作也。然皆与慈悲相应。为令彼等降伏善调。得作佛道因缘故。诃字第一真实者。此是风漫荼罗也。风性能增益也。风生者。谓应是作风用之事。皆此坛中出生也。亦是生此诸事也。万物能消耗变化无方。此字事用亦尔也。谓因业等生。种种增长滋茂之事。皆得自在。若上安点。即能坏彼一切因业等事也。其法先想本尊。于其额上连眉作半月形。◇于中安字。先想外作即回作自身也。其半月有大威德威光之像。黑焰遍出于外。作风吹动之幖帜。恶谓其像作极忿怒形也。云此但是风轮之尊。非降三世也。其像亦作深青色(即黑类也)若作此成就。能为一切众生作种种义利也。次成就。谓下所列物于风中作也。即能此现身皆得成也。谓升虚空神足变化。及天眼天耳没隐其身。开谓开阿修罗宫等也。下云念者。只是用心作也。此五字皆是心作成就坛也。亦可以事法作坛。而观心与相应也。若如以事相作坛而修神足。亦于彼中坐作之。若藕等亦置于坛中作也。想白乳流满中。昔佛坐道树下。从此字门。而降伏天魔无量军众。持诵者若能如法习行。不久即同如来。现身能伏彼军也。大名称即彼降魔者也。次即因诃字门转明佉字。诃即因义也。有因故即有随业受果之相。然此第一义中。诃字门本自不生。以不生故因不可得。此因尚本自来不生。况于其中而有业果耶。如是观时。因业与果之事。寂然皆不可得。若能如是观者。即同如来。坐于道树而降伏魔。以此因等不可得故。即是其相犹如虚空。空而复空故也。大德世尊说彼色者。谓说虚空色也。若于上加点。即入欠字门也。此欠字门所说尊者。名为尊也。谓尊中之尊即大空也。若欲成就一切器物。皆得成就。其名种无量不可具言。其漫荼罗无方圆半月等相。当知虚空无相。而能成就相。此坛作种种色也。空现种种色相也。慧刀印共作。谓兼以刀印护之而作成就也。若作刀。用镔铁作。索用线或藕丝作。其轮或以金或以镔作

【图】(利处在下名那罗遮也)

【图】(此名没檗蓝)

    此等器甚多。不可具载别有也

如上诸器随作一事。用此欠字成就之。若得上中下成就。随事而用。乃至得成。持之以游历诸佛国土。名持明仙也。次更细说五字之义。若住此理随事相应。即能成办一切事也。是故佛观大众。告金刚手言。是真言菩萨修菩萨行。阿字自本色。内外一切舍。得一切句义者。得与阿字本体本色而相应也。体本体不生。同于金刚实相之身。若与此相相应。即能舍一切法。粗妙等同。犹如瓦金齐观。犹善住平等观故。一切三毒罪业悉离。若如是者当得净心。得此净者。即同诸佛牟尼之尊。普能利益一切众生。出过为罪离诸过患也。次明嚩字门。若能与此相应解诸法则(即是真言次第法则也)即能为一切众生。作大利益之事也。先当如上观此字。白如雪乳流注其心。若流注充满其身。内外皆净。一切见者即同佛身也。又从其身而流注出。遍于一切众生身中。极令净满。又更流注满于大地。当知此即于秘密释中。是大慈悲水也。观于世间极热恼故而利益之。能令或饮或触。或除众患必定于无上菩提。有能是此水现同甘露。或显或秘于二释中。皆有世出世利用也。无疑谓当生决定信不疑也。次明罗字门(加点也)亦如前观之。皆寂赫然光明如火轮。周匝有光。遍于内外皆作此色。向外流出乃至照于他身。亦令此渐次转广遍于法界。能除一切众生种种恶事。随所欲乐而满足之也。亦能作诸神变也。次行者从脐以上安啰字。脐中安嚩字。俱现神变。从啰生火。从嚩生水。而除寒热等患。乃至八大热地狱。热能以嚩字而作清凉而息灭之。八寒地狱。能以啰字作温暖而息灭之也。次又下安啰字等。标幢上而安诃字。能除自他一切罪苦也。又如上作大金刚轮。此是刚中之刚者也。于彼金刚大因陀罗轮中。双作阿嚩二字。而自龙方(西方也)即能摄伏一切也。风能遍一切处。或开或坏。开谓开修罗宫及一切质碍之物。坏谓摧而折毁之。种种杂色内外业因所成。皆能开坏也。色漫荼罗。谓依本色。即是前所说风坛也。心摩触者。谓想此字在圆明中。而当其心中。能令意得清净。即法华所谓意根净也。于经行中而念诵之。观此字而作轻举。轻举想。即能举身升空现种种神足。或坐而想阿字在于耳根之中。以此字出入。闻声即得天耳根通了也。或云随用一字皆得。或可此文是阿字用也(更问)。意生身者。此是举要言之。随意所欲皆成。如得意生身念至十方也。当知如来有如是自在方便。能令无相离相行中。而普现色身。成办一切佛事。才持诵时。能坏一切生死种子。成就菩提之种子。转者即是转诵之转也。行者若能如是修行。诸佛常当现其人前。如影随身而满其愿。行者既得满所愿已。即能不舍一切众生。亦复常现其前。而满其愿令得法喜也。故云同于影像。于一切处。随顺一切众生。所以尔者。此如来住于三平等地。无有分别戏论。复越度一切心境界相。时方作业一切亦离。时谓生灭于三世之时。方谓方所。作谓众业。虽现万像。而无所现同于十喻。法与非法皆远离故。犹得如是无尽庄严藏故。能普应一切众生。是故行者当勤求是真言之行无上悉地。所谓如来一切智智。当知诸成就中最在其上。无与等无相比也。此一切智由于真言行生。故当勤学之。右得悉地品竟

    成就悉地品第七

时执金刚吉祥。希有花开敷眼者。金刚喻如来秘密慧也。金刚无有法能破坏之者。而能破坏万物。此智慧亦尔。不为一切之所破坏。而能摧坏一切能坏难坏者。所谓三毒根本也。复次此菩萨身。即是金刚之体。而十方一切佛。同以如来金刚智印授其手中。故名持金刚也。吉祥者。叹金刚手菩萨之德。众善功德具足无缺。即是吉祥义也。时彼菩萨闻如上说诸佛甚深希有奇特之法。发希有之心。其眼开敷。一心观佛不暂舍。方发四弘也。复次如世莲华渐渐增长。若不崇日月光明及时节等。则不能敷荣。菩萨亦尔。虽有秘密菩提心如来功德实相之藏。若不崇诸佛平等大慧烈日光。则不开敷。今此菩萨。妙得是妙法莲华台真实知见故。复而问佛。欲弘广传此心地之法度与一切众生。咸令亦得如此开敷也。复次如上所说。即是阿字门如来金刚性。而功德藏具足无缺。常住妙理之门也。转金刚杵者。有微旨。谓欲转此无碍密慧。入一切众生心也。所以者何。如是自证寂灭之法。微妙清净为无有上。而众生不自觉知。为此因缘故于无量诸佛秘宝藏中而受无量恐怖苦恼。谓是事故生大悲心。欲转此智令一切。皆得开敷心眼故也。火光微发者。火喻般若波罗蜜。四边不可触以不可执着故。又体性无垢。能烧一切烦恼虚妄之垢。如劫烧火无复遗余也。遍照佛刹者。以此慧光。普照无量法界一切有缘应度者。无不普现其前。以所喜见之身称机说法。咸令得入如是阿字之门也。诸佛刹即无余世界也(私谓此世界者即是净心之土常无毁坏金刚之国土也)发美妙音赞法自在牟尼者。谓发微妙之音而问如来也。诸法自在者。如世间长者。具足于财无所乏短故。能随意所欲皆得成办。如来亦如是。为诸法之王。一切法财无不具足。故能办大事不可思议。一切皆办也。牟尼者寂默义也。常寂之土。微妙寂绝幽深玄远。不可以言说之。如是法界寂然大灭度法。唯佛一人究竟清净。故名牟尼也。真言诸行说。彼行不可得者。谓平等三业。真言之行。犹此如来之行。得成无上大果报者。此诸行。愿佛为我等说也。问意言。此真言及行。佛说能成办一切如来功德广大甚深之事。以要言之。无量无边未曾有法。皆得成就。然一切法无不入于阿字之门。若入阿字者。即是从本以来本无。诸法本不生故。若法本不生者。即此真言尚不可得。何况是中发起众行耶。即此无生无起无法可得。而具一切功德。即是不可思议佛之境界。唯佛与佛乃能知之。佛佛自证。若闻见证之者。即能以无量方便示悟众生。若心不自证。则无由能筹量如是事而为人说。如是不思议不生不灭。云何修行。又此行者。从何所来。去至何所。意问无生之行如何发趣也。所以然者。若生灭法。可说有成就破坏之相。今此法则无如是等相。云何而得成就也。此义亦甚深也。真言本体寂净云何发行。愿佛为我宣说。一切为我说者。意言。总为我演说之也。谓说此希有无上之法也。如是甚深法性。犹如大海万流之所归趣也。此万法归趣。正顺于大般涅槃。即是发行义也。如世间大海种种色味。入大海之中。皆同一色一味。无有差别不可变。如来大海亦如是。一切万法万行入此中。皆同一不思议解脱之昧。无有差别也(如是说竟)次如来答云。摩诃萨意处。说名漫荼罗等者。心处亦可名为心位。即指此众生自心之处。即一切佛大悲胎藏漫荼罗也。所以者何。一切众生即是华台之藏。然以四种烦恼常自生故。为彼自覆弊故。不能明了而自觉知。若能自觉心处者。即知此心自性常净。如是净无垢处。即是诸佛大圆满实相之地也。是故佛答意言。若欲知真言行及果。当于心处求之。皆如是说者。谓十方三世佛。亦皆如是说。一道无异。非独我如是说也。真言诸心处。彼识知果受者。果谓诸佛无上菩提之果。受谓证得也。佛意言。若能入此阿字门者。即能识于心处。若知是处。即得真言果也。佛意又言。诸法尽犹心有。如人眼见色者。眼根与色对。不能了知青黄赤白等。次眼识即生不定虑。此青黄耶。次意识即分别分析。言此是青黄赤白等种种众相。当知但由心分别而有也(更问)决定悦心心处者(此心梵云只多是虑知心也又次干栗太者是处中心也)如二乘入道。亦先须得决定心。此决定心。即三昧也。犹得决定心故。心得悦乐。即是内心自证现法之乐也。犹有定故。即生实知见。然三乘各有定。深浅不同。今此中意言。若能证此心处心中之心(此即干栗太)即是如来大决定心(谓三昧也)犹有此定故得入阿字门。入阿字门故。即能了知真言行之与果也。若了知彼行及果。即是授得无上大果也。佛意言。犹心住定故。得究竟一乘如实之见。即能自知是事。不然虽闻无益故。此已下正明习定初门也。如上执金刚所问。此真言之心。从何所来去至何处云何得果者。今者佛意答言。夫真言者从自心发。乃至欲识真言行及果报者。亦从心而现。出此心外无别法也。所以者何。此漫荼罗名之为净。以一切众生自心本来清净。而以无明蔽覆不能了知。若净此心。即是漫荼罗处。不从余处来也。行及果报皆亦如是。以一切万法乃至形显等色万类差别。莫不从心分别而有。今此阿字门亦不从外来。但从心生无别来处也。所以者何。以有方便修定故。其心渐净。以心净故。阿字现中。此阿字者。即是一切诸佛之心。从心轮净故能现阿字。由入阿字门故即是成大果报相。故知此果亦心得。其实无人能授与者。由此自觉了而得之也。当引央掘不盗戒义。然此心源微妙寂绝。无名无相不可示现。以何方便而能得见耶。今诸佛为化真言行菩萨故。直从凡夫心处之心而作方便。亦不作余对治行等也。此心之处。即是凡夫内心。最在于中。是汗栗驮心也。将学观者。亦于是处思莲花之形。所以者何。一切众生此心即是莲华三昧之因。以未能令开敷故。为诸烦恼等之所缠绕。所以不能自了其心如实之相也。是故先当观此心处。作八叶莲华观。令开敷诸蕊具足。于此台上。思想阿字而在其中。从此字出无量光。其光四散而合为鬘。犹如花鬘。所以谓之鬘者。谓连多花贯穿相续不断。由合多为一故名为鬘。此亦如是。合无量光以为一光之鬘也。何故须观八叶不多不少耶。此有二义。一者一切凡夫心处。虽未能自了。然其上自然而有八辩。如合莲华形。今但观照此心令其开敷。即是三昧观而且便也。然其理者。若观此八叶之花。即得与理相应。此八叶者即是四方四隅也。四隅即是如来四智。初阿字门即是菩提之心。次暗字即是成无上菩提。次阿(长)字是行菩提之行。次恶字即是大涅槃。其余四隅之叶即是四摄法(更问其相)先从阿字门发菩提心(即是真言来处)次知彼果(更问次第之意)次由此是字轮四阿字义。欲成大果报故。而修如来之行。以修行故而得证大涅槃。证大涅槃故能见心性。即知此心法界之体本来常寂灭相。故末后恶字门也。所以云蕊具足者。亦有其意。谓此莲华三昧之心若开敷时。无量法门无不具足。谓六度十八空三十七品禅定解脱。百八三昧门五百陀罗尼门。如是等无量无边无不具足也。当知一切法门。皆是从心而有也。念彼莲华处。谓于彼莲台之上观于阿字故。名坐上也。周遍普照明众生类故者。观此花鬘之光。若现前时。即从此心生寂照之光。普照一切众生之类。一切众生亦有如是之性。但由无明覆故。不识自心之性。故不得如是自在之用。若自了心源之时。亦能如是普现色身十方。教化如佛无异也。云众生者。谓彼以无明故。乘业而生即受四生之报。以乘业而生故名众生也。今欲散彼众生。令尽识心之实相。开彼华台令得佛之知见。知见者如俗言心开意解。此意有理也。以心开故即入阿字门也。又言坐上者亦含多意。或言花坐或言自身坐时。或是成就大漫荼罗者。漫荼罗中作此观行入阿字门。即能见光明普现色身。而作种种佛事也。然行者初学观时。心未纯熟未得现前。当先画作妙莲。如上所说极令微妙。兼置阿字常现前观之。当于圆明中画也。此圆明由如圆净之镜。其中极深阿字圆光。于中谛观久久。即能现前分明见。既于外处见已。回观自心。于圆明中而观阿字。如阿字者当知么等诸字例可解也(更问)行者内观具足纯熟见阿字时。其光从心中四散。普遍十方一切佛刹。此光从顶至足。周匝环绕行者之身。不可以喻言也。问观莲华不观余花耶。此亦有意。如世莲华出淤泥之中。生处虽恶。而莲华体性清净妙色无比。不为诸垢所染。凡夫亦复如是。虽种种不净三毒过患无量无边。亦此莲华三昧甚深果实。皆生其中。即是如来平等大慧之光也。千电集会者。如世间一电之光。尚不可谛观。以映夺人眼故。况无量电光聚集也。此释光鬘四散威猛炽盛之意也。然此光从心遍此之时。即能普遍一切世界一切众生应度之者。皆现其前。以其所喜见身。赴机演说妙法令其得度。皆实不虚矣。如世明镜中现种种形。然有所不照不能普现。净心之镜则不如是。十方无碍圆现法界。但借以为譬。然实不可为比也。行者见圆明阿字时。能遍诸方而行佛事。然亦寂然无所动作。由如水月随器不同一时顿能现也。然以智慧观之。若水性不明月亦不现水虽澄净。而无月者亦不能现。无有去来而现前明白。但缘合有耳。复次如月出时。虽能成就四天下万物之类皆令得益。然亦不作是念。能普照万物而生长之。行者观于自心亦复如是。同彼水月而现众像也。从此品以前说真言之果。从此品以后。次第明修行入证之方便。从此为首也。此中复有坐起威仪众多秘法。下别出之。此经圣者所秘。故不明白次第说也。如上观八叶及阿字门。先用净除自心华台得现。今欲令彼长养滋茂成大果报。更明方便观[口*菴]字门也。前入阿字门虽云了知心性。然亦未得究竟现前。是故更入[口*菴]字门。此是三昧。将用成就菩提心也。如世莲华依水而长。若无水者不久枯朽。行者菩提之心亦复如是。若无三昧之水灌注其心。即亦不得滋荣开剖也。此[口*菴]字当观在顶上骨缝四方会处。令字正面着之直立头。后更有秘密观法。又别也。观字点为行者头。余为身分四支也(问水从阿字下流入别字不)以行者未识自心故。方便令识。先观莲华。又以定水涤净其心。令此阿字明白彻见之时。六根诸垢皆总清净。由六根纯净无垢故。心性无垢犹如水精净月之光。当知此即名见。见者即是成就。成就者即是体同法界。当知此法界本来寂然。一切众生世界之所依持。犹如有情依世界。乃至地轮依水。水依风风依空空为一切依止而无所依也。法界亦尔。以众生无明垢故。不能自了。今以六根净故。即明见也。未见时更有方便。亦在别品中。又非直观此二字也。行者自观时。更以诸字令普遍支分。明是作时。事事明了即成持明人也。以能自直用此诸字门故。成持明仙。又此法界云见者。非是有得见。以无垢故即能见。见即是法界体也。如镜净故万像自现。而不作如是分别。我能见彼彼是所见。亦不分别去来之相。但缘合见耳。一切众生皆亦同此法界之体。若如是见之时。即是悉地之相。能普现色身。示无尽庄严藏也。行者由心净故。非但具足妙天之乐。亦得大涅槃微妙之乐。亦见如来句。句是诸佛之坐处也(谓佛住处也)如上见时。犹未名究竟成就之见也。更有方便。谓观啰字门。行者于两眼上置此二字。光明如灯赤炎光辉。行者当坐时少屈其颈。以此无垢光明而内观照其心。犹此啰字故。能见心性也。低咽当不令太曲又不太直。此有二义。一即调身不生病苦。以坐太曲太直即四大不调和故。二者为净眼根速达心源故。此啰字门者。即净知见之明灯。由此智同观心莲台之实相故。速得成。又坐时舌亦不得着上齶及太垂着下。当处中也。如是净眼观于自心。亦无能所等相。但因缘具故得如是见也。以上佛告金刚手去来之相。此行从心而生。心为照明能见如来之道。行即是道也。道者即是行及果报也。非但我如是说。三世如来所说亦复无异也。如上所说真言方便乃至此心处。无垢清净犹如圆镜常现前。当知此即是先佛共所宣说真实之心也。如是心性。常恒安住无有变易不可破坏。即是诸佛大般涅槃。故名真实也。以啰字门等净此心故。生真实智慧光。故即见古佛所行之道。所谓秘密藏真言也。行者见此真言道之时。识亦发光。识谓六识也。如小乘中说心意识。但是名之差别。大乘即有别相。谓六识身。但是三缘和合。不能决定了知诸法。能分别者是心也。以心净故六识亦皆光明辉发。犹如大宝珠体性常净。而不为尘垢所染。若人莹冶。渐去粗垢乃至转明。即能无碍雨降诸宝光色无比。众生六识亦尔。以心源净故。六识亦皆纯净。所谓六自在王性清净也。彼持真言行者。如是见心性时。即是见于正觉两足之尊。永离邪倒名之为正。以此正知见现觉诸法也。人天二足中尊名两足尊(更勘经释)所以者何。若离此心性。更于诸处见于如来。无有是处也。行者见此心佛之时。即名悉地第一成就。所谓得第一常身也。悉地有众多种。或世间或出世间或无量差别。今此成就者。即是出世间第一成就。所谓成就第一常身。此常身即是诸佛金刚不坏身也。见此心时即是见如来句。知一切法皆如十喻。不生不灭性常不生。得此真实之智。见于实相也。虽如是说。然行者犹未即能究竟明了见于心性。更有明了方便。所谓转啰字为览字也。前于月中作观阿字而观于心。今更转此啰字令作览字。还如前小低其咽。令不太曲直。舌亦高下得所。而观于心中阿字也。此之啰字是相义。上有点是大空三昧。所谓第一无相之法。诸相本空也。以一切相者皆是不坚固法。以此相当体不生故。同于大空。即是坚固实相之法。如是思惟一切空句与理相应。即是不死句。不死句即是诸佛常住之身也。由此览字方便离一切相。即是常身。常身即是一切法空不死句也。若欲广大智五通。成持明悉地明等长寿童子。未得持诵者。乃至是不随顺。广大智身即是如来身也。谓一切三乘功德。下至五神通长寿等事。离览字无相之门无有得义。所以者何。若人心着于相则生盖缠。随业而转不得自在。乃至世间悉地尚不可得。何况五通等耶。五通等尚无得理。何况如来平等智身耶。是故佛说三乘世间一切功德利益。皆从无相法中而得成办。如神通有多种。若行者以心离相无著故。乃至能得二乘五通。若更深修。乃至能得菩萨五通。此五通即是入地菩萨自在之用。比于二乘之通。如用日光等彼萤火也。持明者。谓持诵人得妙成就悉地之果。即能遍游一切佛土。供养诸佛成就众生也。若不观此离一切相本来空寂法门。此仙亦不可得。此即是入于菩萨地也。长寿。谓于寿自在常住世间。利益众生亲近诸佛。童子。谓寿无量岁常如十六童子。容色鲜妙。亦是持明仙也。经意言。若不随顺如是离一切相法门。此仙尚不可致。何况究竟法身不思议业。真言智发起真实智。是极上一切诸佛财富者。以入览字门故。离一切诸相即见如来。即是平等大慧真实之智。如是真言之智。于一切法中最在其上。一切诸佛以此为资财。资财是受用义。如是智宝财其数无量。自在受用成办佛事普施众生。即是法华大长者义也。菩萨救世者乃至二乘。游涉土地住诸佛刹。有所宣说示现。亦皆由此法门。乃至由此行故得成无上道也。故经云。离一切相则名诸佛也。悉地成就品竟(悉地是真言妙果为此果故而修因行故此中成就者是作业成就)如上金刚手问佛真言去来之相及行。果佛已答竟

    转字轮漫荼罗行品第八

如来复观察大众。以大慈悲修习眼观察众生界者。大众。即是十佛刹土微尘数金刚等会也。如来以无量劫来久修大慈悲之眼。而观世界亦有意怀。所谓复将宣说微妙方便。令一切世间皆蒙大益也。如是观已。入甘露生三昧者。如世人饮毒即时夭命。或有遇天甘露而得饮之。即时不老不死。一切诸患疾苦无不除愈。身心清凉快乐得未曾有。今此三昧亦如是。若得闻思修行者即得出世间第一之乐。寿量常住成如来现法之乐也。从此定起。复说一切三世无碍力者。三世无有能破坏者。此明力如是也。破除一切无明烦恼之闇故。名之为明。然明及真言义有差别。若心口出者名真言。从一切身分任运生者。名之为明也。由增长义故女声呼之。如王以尊位故其妃亦复尊重。故云明妃也。如上金刚手初问佛。佛即从初至究竟。皆答此问。中间他语间断。今佛复腾前意而答也。如上览字门义已略说讫。今依前。佛为修真言行者。欲令众缘具足速得无上道故。复从甘露生三昧起。说此明妃也

伽伽那三迷(等空也)阿钵罗底三迷(问之)萨嚩怛多揭多(一切如来也)三曼多奴揭底(与诸如来同至所住也更问)伽伽那三迷(等空重言)缚罗落叉[嬭-不+(采-木)](缚罗胜愿也落叉相也)

伽伽那三迷者。伽伽是行义。重言行者。明即此行即无所有。则行无行也。先指次破坏也。谓此无相无碍之法。于空无量无碍无所不遍。然复有异义。所以者何。若一切法直尔如空者。即是无过患无功德。今此中虽无相无碍犹如虚空。而具一切如来真实功德。无所不备。故次明第二句义也。虽举此空为况。然有无量无边离相之德。非虚空所能喻也。此功德者。即是等于如来。是一切如来所至之处也(第三句也更问)。次复言伽伽那三迷者。虽具万德而无所表示。同于大空故重言也(更问句义)。此中云无碍力者。不可破坏义亦是无相义。以无碍无相故不可破坏也。佛于三昧中现此明妃也。口说名真言陀罗尼(男声也)身现曰明。以此善男子明妃如来身无二境界。由是力故。佛菩萨大名称。得无碍法。能苦除灭者。言此明妃者即同如来之身。若不悟此理无由成佛。若证无相无碍理。即是于法而得自在成就菩提。如是无相。即是如来甚深境界。唯佛与佛乃能知之。故言是佛境界也。十方三世佛及菩萨。由入此门故。遍于法界普门示现。成就众生无有穷尽也。是故得大名称闻于十方。故云大名称也。得无碍法者。以无障无相无挂碍故。能除一切众生身口之苦。真实不虚。皆令究竟至于无上大菩提乐也。犹不了真谛故言无明。由无明故。即有诸行而生种种诸苦。虽菩萨入于地位。然由未了如来甚深秘密之境。即是微细无明亦复是苦。今佛为彼等故。咸令究竟佛之境界。故云除一切苦也。除无明苦。即是与其不思议解脱诸佛无量无边功德现法之乐也。妃者。如世女人能生男女。令种胤不绝。此明能生一切如来所有功德。故义云妃也。行者修真言行时。虽如上有种种方便。然须持此明妃。若不尔者众德不具也。时毗卢遮那诸佛。寻念我始初不生金刚执力故。告上首执金刚言者。如来从甘露生三昧起已。寻念我本初不生一切佛身。由不生故即与诸佛无二体。故如是取本不生阿字。加持自身及执金刚而告之也。以不生加持之也。如是思念已。方便告上首诸金刚也。上首者。非但秘密主。一切皆入阿字门。即是无言体主而已。十佛刹土诸执金刚皆是上首也。谛听善男子。字轮转名漫荼罗行品中广。真言门修行菩萨。作佛事能住彼前者。轮谓阿字门。此一字中入一切字。入此一字。于一切法旋转无碍也。如世人之轮。不转则已转则无有穷尽。寻其首尾亦不可了知。故名轮也。又如世间之轮。若旋转时。能断一切草木之类。随彼根茎枝叶。遇此轮者无不摧破。何以故。以边刃利故。此阿字轮亦复如是能除一切无明烦恼。随彼所闻无不摧灭也。漫荼罗是清净义。下更释之。品广者。此中之义能遍一切处。品者只是一分之名也。广义如轮无有断尽。然此一分之经。亦不离此轮。故以为名也。诸品皆云广者准此(即是言略故一分义广故无尽也)本不生者即是阿字轮。入此轮即是与诸佛同体无二也。佛为成就修真言行菩萨故。欲说此阿字轮。而先叹其功德。若得此轮。能令诸菩萨普门示现。以一切众生所喜见身。普住其前而化度之。以大因缘而作佛事。故云住彼前也。尔时执金刚顶礼佛。金刚旋下相应。下金刚莲花坐已叹佛者。此菩萨。以金刚杵上而有莲华台。以此为坐也。金刚即是诸佛智印。此佛智印。大漫荼罗之台故有所表也。如掷金刚慧虚空中。回转而下于地。此菩萨亦尔。闻佛更说阿字轮故。欢喜踊跃。即时此台。于金刚上旋转无量。从坐而下为佛作礼。当下时。与掷杵空中回旋而下相似。故云与彼相应也。此亦表佛智无碍也。为闻法恭敬故。下地致敬也。归命菩提心者。即是归命一切众生心也(如上云此心菩提)。归命菩提心发生者。又复顶礼能发生此心者(即是净菩提心入明门者也)稽首行体地波罗蜜者。次归敬真言行体。行体即是其地地及波罗蜜也。敬礼先造作者。以一切众生。虽有此菩提之心而不能自了故。归命古昔发心成果转示众生者。念大恩故又更礼拜也。重言归命顶礼者。此义大同小异。重言者恭敬深至故尔也。如此叹佛已复请者。如世人养蚕为利故而善养之。此亦如是。为请佛更说深义。自利利他故。先叹佛也。空证。即是证于无相无碍平等之法也。白佛言世尊。唯愿法王宣说。哀愍我及一切众生故。法王者。于法自在故名为王。愿哀愍我及护念我。及为利众生故。为法王哀愍我故。护念我故为众生利故。如说修真言行者令得圆满故。愿佛更说阿字轮也。圆满者。随彼上中下行。各随性分而得利益。皆当成就妙果也。次佛告秘密主言。我初。诸最胜佛世所依称号者。将说秘藏。先自叹德。以此法难信故。如将说法华亦同叹也。本初即是寿量义(更问)。世所依者。如一切草木皆依于地而得增长。又如商人依于导师。入海者依于船师。病苦者归依大医。此有多门皆当说。今佛亦尔。为一切依也。然更有深意。虽云自叹即是说法意也。如梵音云我者。于中即有阿声(案本)即本不生义也。此常住不生之体。即是一切之所依止也。称号者我觉此不生故。一切世人称号为佛。非平等法界有如是名也。说法无等比。此无比中。诸外道所说皆是有上之法。故云有比。凡一切不了内证秘密法者。皆是外道也。由佛说此无可等比况喻法故。说法亦无比也。又此中我◇字(又么声即是不生义也亦是叹中说法更问也)本寂无有上者。此本字中即有阿声。即不生义。以不生故即是不灭。是故本来寂然。此法第一微妙更无过也。能寂诸根故。六根常净诸恶永灭故云寂也。此阿字即是一切佛心也。今佛偈中说此阿字者。即是说自证法中一切语意中。虽有所说。然此内证之境终不可了知。由自证法不可说故。佛虽自叹美。即是称叹此阿字也。以此字本初以来是世所依。今说此自证之法。非彼二乘外道之境。于彼法中无可喻况之者。故云无比也。如饮水者冷热自知。尚不可为不饮人说。况如来境耶(当引深密)然佛以加持力故。说此不可说不可说之法。令金刚藏等皆得知之。此事即为希有也(云本寂者当知本来寂灭之法一切二乘外道中所无非彼心境所及也)由加持故。执金刚并诸菩萨。佛菩提座胜愿能现。谓佛说此偈已。以佛神力加之。尔时诸金刚菩萨即能现菩提座也。此座者。但以世间意说。但是座处耳。然西方名此座为满荼。满荼者。是坚固义是不动义。是更无等比义是遍周法界义。今现此菩提坐。亦如酪中现苏。诸味共会一处而不相离(更问)加持故能现也。此座即是如来功德之所庄严。无量大愿之所成就。即同佛身。普现一切众生界中而作佛事。故云胜愿也。佛虚空如无戏论。从行无二与理相应相。成就是业者。即此座者。犹如虚空离一切分别。虽诸菩萨如是修行种种方便。然亦无二无别。不离如是妙理。故云理相应也。如行行者。彼得果亦如是。即同彼座无二无别。成就者。谓修行者之所成就悉地也。于时佛诸支分身。皆悉出现是字。于一切世间出世间声闻缘觉静虑及观。悉地成就勤修者。谓遍佛身分。佛身分皆现此阿字真言。此阿字门。即是世出世间二乘定观等之慧命也(摄心不散名定次当观照如行者初摄心时观圆明等是观也以下义势常相连也)如寿一字。诸寿同种子同命同依处同救度同现者。如上世出世间一切所作妙业。阿字即为彼命。如人若无命。根一切作事皆悉弃废。一切世出世间功德定慧等亦尔。若离阿字门。即不得增益成就。如彼死人无所能为。复阿字是开口声也。若无阿声即不能开口。口若不开者一切字皆无。是故阿字为一切字之种子。当知一切万行亦如是。以阿字门而为种子。若离阿字亦不成也。同依处者。如众生等若无大地则无住处。此阿字门亦如是。若离阿字即无所依处也。救度亦同者。当知阿字门。即是一切世间之大救护也。末后云现者如上佛为菩萨大众现金刚座故。此一切胜义皆能悉现也。次即说此真言门。谓南谟三曼多佛陀喃(敬礼普遍佛等也)阿(此正是阿字真言门)善男子此真言者。十方诸佛以法身同所加持。诸有修行之者。以此真言故。即能作诸佛事。乃至普现色身。为一切众生界开示佛之智慧。如佛能作是事。此阿字门亦能如是作之。当此彼体即同一切佛身也。阿字门一切法转者。由转此阿字。即成种种功德也。从此阿字门修行转也(更问)是故秘密主。真言门菩萨等。欲见诸佛者(谓欲见一切佛净法身也)。欲供养者(谓游一切佛刹供养承事闻法修行也)。欲证发菩提心者(谓证菩提令心净也)。欲与诸菩萨同会者(谓与那罗延菩萨等等共一处受现法乐也)。欲利众生者(谓如毗卢遮那常为一切众生作大佛事种种成就之也)。欲求悉地者(此中最上成就所谓佛身尚可疾得况余成就耶)。欲求一切智智者(然此阿字门一切义利无不成辨以要言之欲求一切智智亦决定当得也)。此诸佛心勤而修之者。佛言。如上所列之事。汝欲求者更无他术。但当勤修此阿字之门也。尔时毗卢遮那佛。此大悲胎藏生漫荼罗王。敷置诸本尊位。定三昧神通真言行不思议法说者。如前以广说敷置漫荼罗位。今何以更说。此有多义。欲更开发一类众生故。令前已听闻者倍得明了故。前虽说诸位地。然尚未普周遍。今更说令无所阙乏故。又前但说其名。由多未说形状。今更说令具足故。何故不并说之。而更分折于此处说耶。于此亦有意。乃至深乐法者。犹不顿为说之欲令发起珍重之心。渐渐开道也。复次若但以图画尊容。用为真实者。如彼画师等。亦可成就阿阇梨功德。然不但以图画故。而得成彼真言之行。当须一一与三昧神通相应。方名不思议行。今佛欲开示彼之故。云三昧等法说也。谓与三昧神通相应而说之也　彼阿阇梨一切智门阿字住。取线礼一切佛者。如上已说。中心作阿字及眼作啰字等。前品已具说。今欲作坛。先须住此三昧令与理相应。以相应之智而运布规量也。凡合绳。当令得所不得大缓。若不调者。令师及弟子多病为障所娆。若用时断绝。亦令致损耗也。次当知方所者。所以先谓审定方面者。若弟子临修时错误。或谓东为西等。即为障者之所得便也。次礼一切佛者。即是礼于阿字真言之体也。师礼已在坛巽地北向。弟子艮方南向。引绳相对。次师引绳转向乾维东向。弟子回身西向。次弟子右回至坤维北向。师回身南向。次师右回还至巽地西向。弟子回身东向。即四方位竟也。弟子次更至干地维向巽。师与相对。即定干巽隅竟(云云更问也)凡定四方。必须如前审谛不得移易。若定四隅及中心十字界者。但令逐便右转。不令妨碍即得也。如是作已阿阇梨复于瑜伽中。转于心中阿字而作缚字。如前布置。啰字等方便不异于前。但改心中阿字。即成金刚萨埵身也。亦复观想己身即同彼身。执持如来智印也。虽改阿字为嚩。然亦不相离。何以故。由不生故。即是本来无有系缚。体一门异也。如上引绳。犹未至地拼之。既作此观。即与弟子。更入中台之中。还如上引绳准前次第。于中台定方所也。如上。无二相应形如来形空性形者。转相释也。叹此无二形即是如来形。如来形者即是性空形也。所说。前引线当心。师及弟子相对。引受四方及四角十字道。但以绳印持而未下也(先以作标相在四角置了方作也)当知如此定时。顶上想于阿字遍其身(皆如上说也)然大日如来。入大悲胎藏生三昧。此大悲胎藏三昧。岂与前品大悲胎藏漫荼罗有异耶。正谓前坛诸方未满。色像亦复未具。故更说也。次定方竟。师想嚩字如上说。于遍身分。想自身同执金刚之形。入于中胎如前引。线定方所遍即下之拼也(更先方定了下拼耳为直尔下拼也)假令中台方六尺者。量半为三尺。即是台外第一院广狭量也。分此三尺以为三重(即有三线道也)。第一为行道。第二为置供养物处。第三重是诸尊坐处。第四是外缘(其三重皆等外缘狭也)。计此三尺内。均调令得所也。当供养时。师当运心一切应来会此。然无图位坐者。皆于此外缘中供养也。次折第二院三尺取半。为一尺五寸。三重院量。亦于中均布四道如上也。次更折一尺五寸取半。当七寸五分为外院量也。亦于此七寸半内。均置四道令得所也。第一台外门口。即与行道处相连。当取少许用其门位。余通行处(以此门住世天)。其三重门外若有宽地。任意大作。多侵地无妨也。前漫荼罗中云。第二院置释迦。第三院文殊师利。此文互也。由先定中胎竟。直向第三院定之。故云第二。非是第二。则是第三重也。今此中自有诚文。文殊在第二重。释迦在第三重也。想阿字定外院。次想嚩字而作中台。次作第二院想文殊。或想嚩字。亦如前遍身分等。次第三院当想释迦。或作婆字也(重声婆字)经中从定线位语竟。至定色以来。解由未明了未记(更问之也)

经云。复次毗卢遮那我加持彼印。广法界寻念彩色下者。谓下彩色时。阿阇梨当想毗卢遮那如来或彼印。此印即是广大法界之印也(尔时当想自身即是大日如来)如是想已先下白色。尔时阿阇梨自想其身即是法界。法界之体明白无染也。如是想念时。非直我身如是。一切有情亦复如是。即净除同如来。亦一切过离者。自身等如来谓白色也。白是法体离一切过。然所云一切有情。皆同妙法界者。当以何法得之。然此非无方便也。谓啰字门。入此字时。即能令己身及弟子乃至一切众生。究意皆等如来法界身。永离诸过也。故次云想罗字。其字色白如车磲(或云商佉即是宝贝也其色洁白第一)师云。此中即有阿字有嚩字也。故啰字白色。想字炎光。寂然光出如乳。以此清净成无垢色离一切过也。及君陀花(是西方花也亦鲜白无比也)或如皓月之状。其字之焰亦白。寂然恬定而曜光明。如是想时又诵啰字。至百遍或千遍方下色也。凡加持色法。先于色中想字。字成已即转为佛也。此有二种。阿利荼。谓左手当胸上为拳。而申风指直坚。右臂如击物。直申举之。其左脚向前。右脚去三尺以来长引。即是也。白朱黄青皆用之。当想佛形而作此印也。凡作印有二种威仪。若立作印皆须作此威仪也。四佛作寂然之形用此印也。第二下赤色应记之者。明言阿阇梨当审谛也。将下赤色时。当想◇字。此字照明如日初出之色。或赤或黄。此即赤黄杂也。此光明照赫奕。此字即是宝幢佛字也。此是无能降伏最胜无比之佛也。兼想自身即同诸佛。赤色啰字安点加之(不合是阿字也义合用罗字加点耳)余方便准前

大毗卢遮那成佛经疏卷第十二大毗卢遮那成佛经疏卷第十三

        沙门一行阿阇梨记

    转字轮漫荼罗行品第八之余

次下黄色时。当想◇字作真金色。其焰亦然。是金色牟尼佛也(牟尼是佛都号)迦义是作业义。以无作故永离诸过。住此三昧害诸毒光明一切遍也。当入定依教者(用意谛观不散乱意也)次下青色时。当想摩字。彼上思惟么字。谓于青色上想之也。即是度生死义。释迦牟尼也。此佛坐于大菩提座。一切佛用此字。除众生恐怖也。而降诸魔军众也。其字如虹之外轮有青莲之色。西方名虹为帝释宫也。其光亦尔也。余方便如前。次下黑色时想诃字。如劫灾大火之时。以太极盛故紫黑色之光。此字光亦复如是也。此是阿閦如来。其佛以大慈悲。为护一切伏诸障故。作毗俱胝怒形。兼作印拟于作诸障之者。此毗俱胝皱眉如前说也。余方便如前。此一段当在前。此尊名钵啰底(丁也反)哩荼(凶山日反)梵字也。此印举左手。申左脚屈右脚也。此是降伏通用也。作金刚忿怒形。不须作佛形也。此二尊通一切用身印也。次金刚有情金刚执我加持者。彼印或缚字。或于内入中台漫荼罗置之者。欲作谓师先定线道竟。欲入中台时。即自加持作金刚手也。然师以阿作己身。即同毗卢遮那之佛。不应自有所作务。故转作执金刚菩萨之身。以阿字本不生与缚字不相离故。得转用也。如是第二漫荼罗。亦本寂我加持力故。无二相应形佛空性形者。次复叹嚩字之德。以阿字义入中故。亦复本寂也。即是本不生义也。无二相应者。嚩字即阿字。无二无分理常相应也。以本寂之故。如来之形亦空无自性也。次二分天位。舍外漫荼罗三分。远界道弃舍。东面线申等者。谓每一院皆有三重。舍第一第二重。于第三院安神位也。次舍第二院。于第三院下色也。以上当在五色之前。义犹未了更问之。尔时毗卢遮那佛从三昧起。住于无量胜三昧。当于定中一切遍无能害力明妃一切如来境界生说者。如来前者住于甘露生三昧。而说此上法门已了。谓欲满足修真言菩萨诸方便令具足故。复从定起。更入无量胜三昧。无量胜三昧者。无量胜即是无能害义也。由住无量胜三昧故。感发生起此明妃也。此明妃名一切如来境界生。即是佛之境界也。诸真言行菩萨。由此明故即同如来境界。亦生如是不思议境界也。由入佛境界故。所作功德亦复同于如来也。遍一切无能害力者。无能害即是无障碍义也。非直遍于如来境界。亦遍一切声闻缘觉境界乃至最初发心之者。但能修此明妃之行。亦即入于如来境界也。南谟萨嚩怛他竭多者。归命一切如来等也。犹诸如来生。是故非一。以非一故云等也。萨嚩目佉弊也(二合)者。一切诸佛以为首望也(更问之)。阿娑弭无等也。以从一切如来境界生故无等也。又秘释此中阿字即佛本身。三迷是等。等同诸佛。即是等于阿字体也。钵罗弭(译为第一也以无等故即是第一更无过上也)秘释者。此钵字即是第一义谛。由上阿字同一切如来体故。即是第一义谛与如来等也

阿遮梨(不动也由阿字故即同第一义谛第一义者即是言语道断心行寂处故不可破不可转也)伽伽儞(空也由不动故等同虚空性浮广大不可分别限量也)萨么(二合)啰[嬭-不+(采-木)]者(寻念也谓寻念于阿字之义即是于恒恒时于常常时思念此义亦无间绝之义也)萨嚩怛啰(二合)奴揭底(遍至也由常思念如是义故能遍至一切处非直遍至一切佛亦遍一切声闻缘觉乃至初发心等处也)娑嚩诃(娑嚩自也诃是本也更问)

警觉诸佛令忆本誓愿也。如来昔立如是决定大愿。修此真言行者。皆当如持建立令速满所愿。我今如是修行故。警发诸佛。当念本所立誓愿也。次调彩色法。佛般若波罗蜜多作礼。诵此明妃八遍诵之者。谓调彩色将图彼如来本真之像。先当读诵大般若经敬恭供养。即是作礼义也。凡调色时须如是作也。又想彼色中字类(谓字作等)诵此字或百遍千遍也又诵明妃八遍也。师调色已。从定起绕已入中。于弟子想念。大慈悲力即师自作金刚及字印也。从定起绕漫荼罗发大慈心。即以此大慈悲力加彼弟子已。阿阇梨作成事金刚萨埵加持。嚩字施愿金刚等并之者。此阿阇梨以如来加持及阿字故。即是毗卢遮那如来。以如来自作成事所不应故。嚩字并施愿吉祥金刚者。是文殊也。次种子是么字即空点也。用加嚩字为么字耳。更以嚩字加持。作金刚萨埵身而画诸像也。当作时想同己身。如上说之。又诵此嚩字百遍或千遍等也。画大悲藏生漫荼罗。内漫荼罗安祥者。师如是自加持已。安祥而起入于中台。徐徐运布众彩。而作毗卢遮那之像也。其像本形。坐于白莲华座上。以发为冠不加彩饰。用极细绢为下裙。更用极细罗縠轻纱用为上服。令肉色相映内现也。身作阎浮金色。色之深金极光莹者是也。其佛缘身皆生光焰。相合为鬘连环不断。而遍身也。所以漫荼罗中须造此佛形者。为欲令彼弟子速生胜愿。及以加持之力成满一切智身故。先须造立也。复次造坛有上中下法。若弟子财力丰瞻堪能广办者。师即当作画色像之坛。为示本尊身印之相故。若力不能办而作字坛。即犯秘法隐覆之罪。若观弟子心。极殷重乃至不惜身命。尚能舍身而奉于师。何况当有所吝。然资力不办者。听作字漫荼罗。即于此置佛之处。但画作阿字。即是如来之体也。置阿字竟。中台之外院直东作阿字加大空点。又于东北自在方置于伽字。此伽字即是虚空眼也。是一切佛及菩萨之母也。次火方一切佛菩萨。真陀摩尼印。或置于字也(迦也)北方观自在及弥勒。贤劫一生补处菩萨以为眷属。置于娑字。南方金刚手等。或作形或作印(谓三股拔折罗)或作缚字也。又此中置字。与前坛方位或不同。问之。复彼分位三弃舍。一切执金刚诸印画。或彼字者多三弃舍。亦如前释。不异字印作[合*牛]字也。次罗刹方(西南方也)毗卢遮那下。画不动尊。石上坐手执刀及罥索。遍身焰鬘。一切作障者期克。或但作印于上(印谓罥索及刀也)或作字者谓唅。次于风方(西北也)作降三世胜。害一切作障者。头光焰貌作大忿怒。如阎摩罗形。黑色于恐怖可畏之中。又极令之恐怖。当如是作极可畏形也。其手中转拔折罗(是三股金刚印也此是定)或但作字。谓(长诃字)次于四方画作四大结护。东方画作无畏结护(名也)身金色白衣。面少嗔状手持棒。若但置印者(但书棒印也)或但置字(嚩字也)北方作坏诸怖大护。白色右手持刀。着白衣并光。若作印者但画刀形。若字者作博字。西方难降大护。无有能制伏者。故以为名也。身作无忧花色(如此间深紫蜀葵花色也)所著衣亦赤。然少浅于身色。其面微笑在圆光中。其作观大会众之状。谓四方众会也。印但作其刀印。作字者谓索字。南方金刚无胜大护。犹若金刚更无有胜。故以为名也。复次金刚。是天帝释别名。然此大护。势力又过于彼相故为名也。其身黑色忿形皱眉。衣亦黑然稍浅于身面之色也。头上但作发髻。自身焰光也。手持棒。若但画印亦但置棒也。字作忏字也。上来四大护。皆须并置眷属。眷属即使者也。皆坐白莲华上。持真言者当如是而敷置之也。次出外向第三院。画牟尼王释迦种姓。着袈裟衣具足三十二相。是一切众生施无畏者(以教法利益一切皆令得无畏故)其印当置钵袈裟等(等谓锡杖之类)若字者作婆字。此最为胜者。谓秘密胜上义也。次外漫荼罗。法界自性加持菩提心发趣者。作法界自性观也。法界即是如来之身。观自身即同一切佛法界身也。以此加持住菩提心心也(此发趣是向义至义修行义更问此一段)彼三分位舍。三作礼佛毗卢遮那寻念。如前调色者。谓置释迦已。次第二院当礼毗卢遮那。如前谓色中方便图画也(更问)东方作施愿金刚童子形(即文殊师利别名也)左手执青莲华。上置金刚。以一切璎珞严身。上妙细绢以为下裙。极微细縠以为上服。又令细于下裙身色映现也。身作郁金色。头上有五髻子。彼印但画青莲华。华上置金刚杵也。若作字者谓鑁字也。于文殊右边(北边也)置网光菩萨。一切身分圆满。左手执宝网右手执钩。若但置印者或画印或钩也。字者。谓染字也(但置此印得也)南方画除一切盖障菩萨。金色发冠(云无璎珞也)左手执真陀摩尼珠在莲华上也。若但作印者。置莲华上有摩尼珠。或但作字者谓恶字也。北方作地藏菩萨。色如钵孕瞿花。西方出此花。如此间粟谷之色。花房亦如谷穗甚香也。此菩萨手执莲华。以诸璎珞庄严其身。若但作印者但置莲华也。若置字者作伊字也。西方虚空藏菩萨。亦以诸璎珞庄严其身。身白色着白衣(其白衣色昧身作肉红与身色少异也)身有光焰执大刀。作彼印者但画大刀也。若但置字者作长伊字。然此坛中所少位次尚多。即云造了者。亦是上下互现也。造了时。阿阇梨先在门外坐。住法界兼菩提心。梵本云。次持诵者住法界。我即法界性。住菩提心。此菩提心即是法界性也。向东方而作金刚印(坛门向西开故师向东面也)造坛了。当坛面向东坐想同于佛。佛即是法界体也。既同诸佛。然后作度人事业也。作事金刚。谓诸事金刚。即是三股拔折罗印是也。凡言作金刚者。字身印皆悉作之。作佛亦尔。恐烦不广一一言也。次供养作殷勤者。更戒行人。应戒慎作之勿忘次第也。梵本云。当结金刚印。次作金刚事业。殷勤而供养。现一切佛救世者三昧耶。又现印三昧耶等者。三昧耶印众多。故云等也。供养及作佛等。皆作三昧耶诵三遍。作事多用处故等也。由作此法。即以此随所作心能遍一切方所。警觉一切如来。由佛本愿故。即皆警觉而作加持也。先念遍一切所。谓漫荼罗中。随方面一切诸尊运心普遍。若深行者。即是漫荼罗诸尊悉地方示三昧耶也。次外唤弟子令彼护净者。弟子先在门外唤之。请诸尊法。用二种使者成办诸事真言即得也。若最捷疾慧。一一用本真言印别请亦得。令近门向坛立。又当先教彼如法洁净也。此即请尊耳。次结界乃至发遣。皆在供养法中。准用即得也。既结护已为授三归。此三归谓印法也。初印护身。次法轮印护诸身分。次具有一印下当说之。初印印顶。次印印支分。上云金刚有情也。由此三印故。即是住菩提心也。作法界法轮印时。彼当一心作自体者。谓行者运心作此法界时。即观自身同于法界也。结印时。同彼印自体也。上法界自性印结之。彼法轮印次结。先想弟子髻中有阿字。然后以法界性印印之。以印案之。自诵真言三遍或七遍也。次当以衣帛覆其面。师当发大悲心而愍念之。为令彼永度生死开佛知见故。其弟子尔时。亦当自发殊胜无上愿也。不空手作菩提圆满故。谓彼弟子。欲令无上菩提速圆满故。随上中下力分办。随其所有供养诸佛本尊等。或持宝华等而献之也。时师欲令弟子结护故。耳语教之。所谓令住菩提之心。别有说处也。彼既发菩提心。一心诚仰而住。师自作印。向其顶上着之(更问何印)。然后令掷花。当记彼堕在何尊之处。就一处本尊之身。又有上中下左右之殊。随彼所堕之处。而授彼相应印真言也。弟子法教。如是作三昧耶故。一切与(更问)尔时执金刚具德。又复问此佛灌顶法。愿佛自说者。请佛自说也。时佛住法界性中。告金刚手。谛听一心。我说此法令修行者。于此法中自在得。所谓令得胜上教法也。此自在者。亦是速得义又是自在义。是义与上所云多财名自在义不同也。我说一切诸法教。所谓最上自在摄者。谓心有愿求。悉能摄取自在满愿。如于一国自在所为必成也。阿阇梨如来本形意加持作彼印者。随彼上中下法。或作如来或莲华金刚部等。随彼所主之坛。而作彼形而为灌顶也。如来本形加持。谓阿阇梨以如来性加持自身。如来性即是本体也。或用彼印。谓以印加持。想自身以阿字遍支分。此阿字即是法界之体性也。由此庄严故即同佛身。方唤弟子也。若是得定阿阇梨。或已得法验者。所作任运成就。若不能如是者。当用印及想而作也。次引弟子将向大华王漫荼罗(谓坛外先作灌顶坛处也)四宝作大菩萨加持大瓶者。是中台四大菩萨所加持瓶也。以菩萨宝而用庄严也。次当作生一切支分印。而于弟子顶上灌之。凡灌顶时作此印。结已取瓶为灌也。若不以此印者。则法式不具。令彼弟子。不能住菩提心则有退转。与空洒香水无殊也。又复未灌顶前。于弟子顶十字缝上。想作闇字。其心中极想作阿字。又想阿字在于胸上。亦可但想阿字遍一切处用也。金色光发冠坐白莲华者。谓想彼弟子心中。作白莲华开敷圆满。毗卢遮那如来座于其上。然后灌之

经云。仁者。即是毗卢遮那如来也。若以此法而灌顶者。即是同于十方诸佛。灌以法水而授法王位也。不尔者徒灌而已。无能为也

    密印品第九

尔时毗卢遮那佛。观察诸大会众者。佛已略说灌顶仪法了。将欲更有所说故。随观察十佛土微尘等大会。非无因缘。谓将说如来身密之印也。次即告金刚手。有印名为如来庄严具同法界趣标帜同者。言一切佛以此为庄严故。得成如来法界之身。若有众生行此法者。以印加持故。亦同如来法界身也。此印者即是法界之标帜。以此印故。标示法界之体。即名法界幢也。诸佛其由此严身故。于一切大会中。建此无上大菩提标帜幢。能令八部等众恶邪者远而去之。善根性者。亲近奉教修行也。汝可谛听极善作意。吾今将宣说之也。世尊今正是时。佛今正是时者。此两语有意也。初说迦罗之时。意言。今此四众无有支叶。纯是真实堪受大法。如来应机而说。正是其时也。次三摩耶之时。即时分之时。今正是时。说法时也　尔时世尊住于无害身力三昧者。佛为满斯愿故。复入三昧。此即是如来无量之身自在之力故。无能害也。住此三昧而发三明真言。其明名为无碍无害无等力也。由此三昧耶诸学者。得听闻得入正法。若不作者即不合入坛。亦不合听秘教也。若修此明即能得身净语净。所愿满足会于三身。故名为三明也。三力者。谓三世力或是三平等力也。无等力者。即此三力也。其明次当说之耳

南么三曼多佛陀南。阿娑迷(无等也)怛哩三迷(三等也)三么曳(即三昧耶也)娑诃(警发也)

阿娑迷者。此明即以阿字为首。即同诸佛法身无相离相。当知此法身是无与等比也。三迷者。谓佛三身。谓法报化合为一身。教化众生也。亦体同阿字之门。无相离相故言等也。三昧耶者是不可越义。是无等三等。诸如来之所同说也。佛住三昧。说此明无害无等力。由此明故能入三昧耶。此三昧耶即是誓愿。犹如于敕。是三世佛本所要誓也。此法门难信难入难得听闻。由法不可遇故也。以是故三世佛同说此真言。以此三昧耶真言加被。得入听闻修行此法也。如尊之教不可违越。若不闻者。即不得入亦不得听闻也。娑诃是警发义也。以此真言警发诸佛。说此明时。诸佛即警发。而起加持行人也。此明力故能满诸地能令修者得现三法。谓成就有三法。谓本尊之力真言及印。此三法界即得成就也。次说手印之相也。不越三法道界者。此界是结大界之果。非驮都也。于界道当中而行故。名不越耳。今此中先说十二种合掌名相。凡诸印法。此十二极要。宜明记也。第一合掌。令当中心坚相着。十指头稍相离少许开之。此名宁(上)尾拏(上)合掌(此名坚实心合掌也)第二次以十指爪相当齐等。以指头相合。掌中心小不相着。名三补吒合掌(此名虚心合掌)第三又次以十指头相合。指亦齐等。然掌内空令稍穹隆。名屈满啰合掌(此云如未开莲也)第四次以二地指二空指相着。余指稍令开敷。名仆拏(收间反)合掌(此名初剖之莲也)第五次又以两掌仰而相并。令俱向上正相并铺之。名嗢多那(上)若合掌(此云露也)第六次又并仰两掌。与前相似。而令诸指相就稍令屈合之。如人掬水之状(勿令大屈也)此名阿陀(上)啰合掌(此云持水也)第七次又令十指头相叉。皆以右手指加于左手指上。如金刚合掌也(此云归命合掌)梵音名钵啰(二合)拏(上)摩合掌。第八次又以右手加左。反掌以十指头相纹。亦以右手指加于左手指上。名微钵哩哆合掌(此云反叉合掌也)第九次又以右手仰左手上。以左手覆在右手下。稍似坐禅人手相加之形。此名毗钵啰哩曳萨哆合掌(此云反背互相着合掌)第十次仰二手掌。令二手中指头相接而仰之。名帝(上)哩曳(入)合掌(此名横柱指合掌)第十一次又俱覆二掌。亦以二手中指相接。名阿驮啰合掌(此云覆手向下合掌)第十二次又双覆两手。以二大指并而相接。十指头向外。亦同名也(亦云覆手合掌也)今此三昧耶印。先合三补吒掌(先以手相远渐近令相着掌内稍空者是也)。以二空指并而直竖之。勿令大低勿大傍侧。正令二空指向上也(其五指中小指名地无名指为水中指为火头指为风大指为空左手为定右手为慧也)亦可左手小指为檀度。以次向上数之头指为定。右手小指为慧度。以次向上数之头指为智度。此三昧耶印。若初修行作诸善品之时。若先不作者。不合作诸法也。非直作此。亦须诵前真言。作法。先以三摩耶印置顶上。诵前真言一遍。置其印于右肩。次置左肩。次置心上。次置喉上。每置时各诵明一遍。凡诵五遍而印五处也。然此真言有何功德耶。以此真言故。能除宿障以净自身。令身净故外障亦净。以外障净故诸障皆不得入。此即为大护也。由此不思议能护故。福任运增长罪自然除。诸佛警觉满其所愿也。又次法界生真言曰

南谟三曼多佛陀南。达摩驮都(法界也)萨嚩婆嚩(性也)俱唅(我也)

达么驮都是法界也。法界者即是佛身。下句云我者。言我即是法界也。又此行者虽未能即体真性。但作此印而诵真言。亦即体同法界也。其印以二空指内掌中。以左右手地水火三指。压而作拳。竖二风令直(两手各别作拳而竖风指也)先竖二指合当胸。即向里而转。令两手指。从顶两边。各近左右颊颈。而向里曳稍下曳之谓初竖指。稍令指头向下。指背向里。近头颊渐渐指头近下也。至心即散手也。凡诵真言作印。喻如耕牛二牛同进不得前后也。次更作印。先作反背手合掌。以二地指反相勾(令右加左上也)余水火风三指。以次亦反相勾讫。末后綟二空指。令至掌内相柱也。此是转法轮印。由作此印故。令彼身心清净。能现见十方佛转法轮也。真言曰

南谟三曼多佛陀喃。伐折啰(金刚)怛么(二合)俱唅

此真言上已释之(更勘)次作刀印者。刀喻利智。以能令除断为义。谓除恶见山峰也。如大山之峰撩乱甚多。烦恼亦尔。今作此刀印。由此印故(如上说之)。即屈二风指。令指头相对。以二空指并而压捻之。令如大刀之形即是也。其真言曰。南谟三曼多佛陀喃(如上)大刀无垢法。现俱生身见截断。如来信解生。无贪法生。此真言梵音诵之。在经中。此已注义竟。如上说也。此真言以初么字为心。是我义。又是五空点字。即是遍一切处义也。今此中意。正欲害此我见也。当知此刀印。即是诸佛大智。能断绝诸见故。以刀截烦恼根。却即得无垢法现也。身见俱生之类。即是垢也。今断是垢竟。即休息邪。未休息更有胜法。谓除是垢已。当生如来信解(此义如最初解)如来信解。谓是何法。谓无贪等善根也。由此故次生诃字。是中诃字为因。为除是因故。傍有长阿之点。即是一切法本不生故也。下有邬故三昧。上有点为大空。诵此者。能令行者满三种身。以此字中有三义。即是法身现也。三藏云。西方尤秘印法。作时又极恭敬。要在尊室之中及空静清洁之处。当澡浴严身。若不能一一浴者。必须洗净手嗽口。以涂香涂手等方得作也。又作时须正威仪。跏趺等坐。不尔得罪令法不得速成耳。即次作吉祥商佉印。先作空中合掌(如前)屈二空指。以二风指压之。令如商佉形。作印已。即近口吹之。如吹螺之法也。此是满一切愿吉祥法螺印。由作此印故。即满一切善愿。宣说大法。能令十方普得闻知。此即是寂静涅槃印也。其真言归命同前

萨嚩哆(遍一切也)暗

此是真言之心。一切法本来不生。上又有点。即是大空遍一切处也。此大寂涅槃之体性。万德寂然遍一切处也。次金刚不坏坐。印法先以二空指二地指皆相并。余舒散如开剖之莲

经云。令如铎形也。次即改以地及空指相捻。中间六指并如旧舒散。其中火风指相合。水指单立即是也。此是莲华之坐。亦名金刚座。犹坐此座故。能生诸佛。诸佛皆由此坐。即名吉祥之坐也。故名金刚不坏座也。真言归命如前

◇

此是真言之心也。此长阿字为行。傍二点为三昧。为令此法坚固故。故后有点也。然作拳法有其四种。第一如常作拳法大指竖之。此是一也。次以空指在于掌中而拳之名金刚拳。第二也。叉二手而合作拳。令十指出现于外。此名指在外拳。第三也(并右指加左)次以十指相叉。皆令十指头在于掌内。此名二手拳。第四也(亦右指加左上)次作金刚印。二手皆屈水指向掌内。以二风指捻火指背。而不相合。此即金刚印也(二空指并而竖也)由此金刚印。能坏无智之城。一切不能坏也。其真言归命如前　咒体但有吽(引)字(义如上准说之)

次佛顶印。先作指向内拳。即申二中指令相并。次以二风指加于中指之背。而屈二空指令相并。即是也(其指向内拳即是指头向内也)此大印名佛顶。结此法印时即同仁者也。仁者谓如来也。谓作此印即同诸佛身也。此是真言。亦是具三昧解脱义也。初为因后为果。因是如来之行。果即是佛也(合加顶上更问)次如来豪相印。以智手。为出大指之拳。置于眉间即是也。作此印即同如来。豪相具足也。其真言归命如前

◇(知也)◇(因也)◇(生也)

以此不生之行净一切因也。阇谓生不可得也。次作如来钵印。左手持两衣角(其法取袈裟近手尖角及搭肩之角绕臂回入手中令二角如双耳也)仍以二手相重。令以右加左上。如坐禅手。引上令当脐。稍屈如重手承钵之形即是也。作此即同如来。持此袈裟诸佛标帜之仪。亦能令一切非器众生。皆堪为法器也。真言归命如前　婆　是有义。即三有也。以本不生故即离三有。三有本来不可得也。除此三有而得如来真实之有。谓诸佛法身也。次作施无畏手印。左手如前持衣二角。舒而当脐。右手指向上。而向外舒之。如拓物之像(如瑜伽中释迦印即是也)若作此印。能除一切众生种种怖畏。爱恚即时皆息。亦除彼未来种种大可怖畏也。其真言归命如前

萨嚩他(遍也)誓那誓那(胜也)婆也那奢那(上声是除恐怖也)

遍是普义。即是遍一切处也。于一切处方便之中。而最为胜皆能胜彼也。初离异生等烦恼。次离二乘烦恼。故重言之。即是胜中又胜也。如来以此之故。能遍一切处。普除一切怖恼也。次如来满愿手印。左手亦持衣角。展之如前。右手向外舒而下垂。如瑜伽中。宝生佛印也。作此印时。即以如来之力故。一切佛满其所愿。皆得成就也。真言归命如前

嚩啰驮(与也)嚩折啰(金刚也)怛么(二合)迦(我也亦身也)

意云。愿诸佛与我金刚身也。亦是授我大愿之身也。此即是满其所愿。次怖一切为障者印。以右手为拳(大指出者)而舒风指竖之。当于眉间。以指头柱眉间也。云等引者。谓作毗俱知形。其面如忿怒。而心住一境不动也。此一切佛大印。能现如来威猛大势之力。恐怖一切为障难者令其降伏。亦能满一切众生所愿。行者结此印时。为障者莫不四向驰散。乃至大力天魔军众亦自然退散。如来证菩提道时。以此印即能伏诸魔也。真言归命如前

摩诃嚩梨(大力)伐底。驼奢嚩梨(十力也)驮婆(二合)吠(得也)摩诃弥底[口*履]也(大慈也)发也

此真言诸佛大力也。此大力是何等耶。即是如来十力。一切力中最大自在也。如来云何得此十力。谓从大慈而得此十力。故言此力从大慈所生也。次佛眼印。先为拳。乃以空指压风地二指(其指屈之空指捻其甲上也)而申水火指。用右手作之。作已。用此二指柱于其眼。先加右眼次加左眼。以此秘密方便能净眼根。成就佛眼得见如来深密境界也。真言归命如前

伽伽那(空也)嚩啰(愿也)迦卢拏(悲也)摩也(礼也)怛他揭多(如来也)斫吃刍(眼也)

夫虚空虽无相无碍。而不能成办大事。今此如来之空虽无所依。而能成就一切胜上之事。过彼虚空不可为匹也。大悲体者。即是如来之眼。此眼从大悲生能生大悲也(更问)次如来罥索印。先作十指向内之拳。即舒二风指。指端相柱。屈而相接圆环之状。其二空指亦以右压左。双内掌中即是也。此印能缚一切为恶者。亦能坏彼令其除息诸恶也。真言归命如前

系系

此中有诃声即是因也。兼有三昧义。此系是呼召声也。谓呼此成佛之因也。此因以本不生故离因果。即令此因净复净

摩诃钵奢(即大索也即此离相之因以本不生故离因果相令此因净而复净之因是名大索)婆卢(普也)娑唠驮理耶(如空也言此大索广普如空无所不遍也)萨埵驮都(言此索广普作何事耶谓于有情中而持之除其痴故)费慕呵迦(痴也除破痴也)怛他揭多(如来)提目(信解生也亦是发诸佛本愿也诸佛行菩萨道时时于大恶尽度一切众生今以此因要当成就果令除此痴使究竟于佛果恒作佛事也)

又此索者从何而生。谓从如来信解中生。信解义如经卷初已说。如来以此信解之力。普门示现种种类形或作大忿怒事。或为持明之仙。具大力势折伏摄受无量众生。咸令获于如来妙果。即是大索广普同有情界义也。次作如来钩印。先以左手空指。压余四指之头令如环状。次以右手三指内于环中。右手大指加左大指之外。而屈入掌中。捻右手三指亦令如环状。舒右手风指。而稍屈第三节。令如钩形即是也。作此钩印。能召十方一切诸佛菩萨。皆令集会道场。亦能满足十地之位。况余八部之类未生善心者。而不来至耶

阿(引行也)萨嚩怛啰(二合)钵罗底诃多(无碍义一切所害也)怛他揭多(如来)央俱舍(钩也)菩提折哩也(二合菩提行也)钵唎布啰迦莎诃(是涅槃义是满足也)

此中行者。谓由此行。能招诸佛大功德海也。如世间钩。则有处所分位。不能遍一切处而作钩召。今如来钩则不如是。普及一切无所不加。乃至能招大菩提果。以要言之。悉满一切如来功德。普召一切众生亦令得此道也。故次句云遍一切害(害即是钩取残之也)遍害一切不调伏者皆令于菩提之行而趣妙果。而得满足也。次如来心印。作法皆准于前。唯加舒火指。此所舒二指。皆屈第三节是也。真言归命如前

诺(上)怒(智也)那婆(二合)缚(生也)

即是诸佛之智。此智不从他得。还从佛心生也

次如来脐印。亦准于前加舒水指。凡舒三指亦屈第三节也。真言归命如上

阿没[口*栗](二合)睹(甘露也)嗢婆(二合)嚩(生也)

甘露者智智之别名。能除身心热恼。得而服之不老不死。可以喻于如来之智也。今以此智除一切众生热恼。令得常寿之身。此甘露味亦从佛心生也。次如来腰印。亦准如来钩作之。内风指而舒水指为异耳。此水指不须屈第三节也。是右手水指也。真言归命如前

怛他揭多(如来也)苏婆嚩(生也)

当知此智印。即是从如来生也。凡印真言皆自呼其义。他皆放此。次如来藏印。先作三补吒合掌(空心也)水风二指皆屈入掌中(合指相对当)其二手火指直申。而令指头相合。二空指并而压于风指。二手地指亦舒。勿指头相到。而稍屈之皆令曲即是也

嚂嚂落落

啰是无垢义。上点是大空三昧也。第一除凡夫二乘障。第二住于如来甘露之空也。次二字傍二点是净除义。第一除凡夫垢。第二除二乘垢也。次结大界印。准前如来钩印法。但二手各举水指。令直竖即是也(更问之不分明)此中大界者。谓从发大菩提心乃至成佛。于其中间不令间断。不复生死不退菩提。即是大界义也。真言归命如前

丽(离相三昧)噜(噜音二罗各乘相也)补(第一义也第一义不可得也)履(离垢也)微(离缚也)矩(矩音作也)丽(离相也)

此等皆是三昧。如来以此诸三昧而为庄严。更无过上。此是诸佛大界也

次作大护印。准前如来藏印。申二水指令指头相柱如峰。其二火指头亦相拄而稍屈。微如莲环之状。又开二空指。相去二寸以下即是也。真言曰

萨嚩怛他揭帝弊(归命一切如来等也)。萨嚩婆也微(上)檗帝弊(能除一切怖障等也亦是叹佛归命也)。毗湿嚩目契弊(种种门也亦是巧妙之义诸佛巧现种种功德门也)。萨罗嚩(二合)他(遍也谓一切时一切处一切方所也)唅欠(诃是因义欠是空义也点又是空以此空净一切因又复空者此空亦空也)啰乞叉(拥护也非但护于二乘亦护一切诸佛诸佛由此故不舍有情常作佛事无有休息不住寂灭也)么诃么[口*(隸-木+士)](大力也即是如来十种智力也)萨嚩怛他揭多(如来也)奔抳也(二合)宁啰社(引)帝(生也言此力从如来功德生也)。[合*牛][合*牛](第一恐怖其障也第二为令满佛之三德故重言谓极怖之也)。怛啰吒怛啰吒(摄伏也伏内外障又为成佛法身故重云之也)。阿钵罗(二合)帝诃帝(是无害也无障义也)

此名无堪忍大护。由彼威光猛盛。如初生小儿不堪视烈日之光。亦此如是。一切不能堪忍而敢映夺之者。故名无能堪忍大护。以此护真言之行者也

次如来普光印。二空指并而屈入掌中。二风指直竖(各不相着皆直竖之)。二火指头相合。稍阔其节如铃铎形。余指同前即是也。真言曰既命如前

阇嚩啰(阇者生也嚩缚也罗相也侧有阿点与不生义同无相不生也)摩履儞(摩是我也有长阿声履是想也想义即观也离有观无观也)怛他揭多。(此是如来光也如来光以从无相无观等义中生也)

次如来甲印。作三补吒合掌。以二风指傍置中指背上而并烈之是也。其真言阙之更勘本。如来舌印(亦阙之勘本)如来舌真言曰归命如前

怛他揭多誓诃嚩(二合舌也)萨[帝*也](谛也)达摩(法也)钵啰底瑟耻多(性也)

如来者即是如实也。犹如来舌常作如语不诳语不异语。以如是真实故常住也

次如来语门印。准前印。即作三补吒合掌。即以水指风指头聚合于掌内。以二空指并压之其二地指二火指并直。而头相并尖如蜂形即是也。真言归命如前

摩诃嚩迦怛啰(二合此是语也)毗湿嚩若耶(种种巧智也)摩诃驮耶(大广也)

谓此语从如来无量门巧慧而作。此智广大无量也

次如来牙印。作三补吒合掌。屈二风指入于掌内。令指节背并是也。真言归命如前

怛他揭多能(去)设吒啰(三合牙也)啰娑啰娑(味也味中之味故重言之即如来法味也)揭啰(此字与前句相连前句未有阿声与阿相连也是胜上之义胜上之味也)三钵啰博迦。(得也)怛他揭多(如来)毗奢(上)也(境界也)三婆嚩(生也谓此胜上之味从如来境界生也)

次如来四辩印。作三补吒合掌。以二风指勾曲。当二火指背上。头勿相着即是也。如来由此印故。处众无畏为人演说正法。乃至于一字中含无穷义。此辩才不可穷尽也。真言归命如前

阿轸[帝*也](二合不思议也)那步(二合)多(奇特也)曷鲁婆(语之分段也亦此奇特也)嚩迦三曼哆(普至也。佛以一音说法。普至一切众生之前其所至处。各各自谓佛同我音为我说法也)毗输(上)陀(清净也)萨缚啰(言音也。由所发言离语业粗恶等过。微妙清净令人乐闻故云清净言音也)

次如来十力印。屈地空指在掌中。令头聚合相柱。余指作三补吒合掌是也。真言归命如前

[合*牛](是三德也。摩是空也。点是三昧也。阇是生义又招召也。更问得招。此印能持如来十力也。此之三字合在句后。如大本中也)驮(入)舍嚩兰伽(十力身分也。其兰字以上是十力。即此兰字长阿声。与伽相连是身分也)陀罗(持也)

即是由此智印之力能持如来十力支分也

次如来念处印。作三补吒(此皆如未剖之莲。极空中合掌也。更捡前文勿令错也)以二空二风。聚相捻即是也。其捻法。当令四个指指甲相到耳。真言归命如前

怛他揭多悉密[口*栗](二合)底(丁以反念也如来念也)萨埵系多(众生利益也)弊庾(二合)驮揭(二合)多(生也起也)伽伽那三么(虚空生也)阿三么(无等也)

言此念与虚空等不可限量。然又虚空不得为比。故复云无等也。所以然者。虚空无所有性。不能为一切众生作大利益也

次一切法平等开悟印。作三补吒合掌。以二水二空指聚而相捻即是也。真言归命如前

萨嚩达摩三曼多(一切法平等也)钵啰补多(至也得也至得一切平等也)怛他揭多(如来也正义谓如去也)奴揭多(随也如也。谓随诸如来也。同彼得如是开悟也)

次如意摩尼普贤印。所以名普贤者。以此菩萨所有三业普皆贤善。诸佛菩萨之所赞叹故也。其印作三补吒。以二风指转加二火指之背后。当节令圆是也。余如常。真言归命如前

三曼多奴揭多(平等望也)吠啰阇(无垢也无尘也)达摩涅阇多(法生也言此无垢从法而生也)摩诃摩诃(此义重言此犹如言天中之天也。诸菩萨等供养于佛。佛转供养普贤。犹普贤身与三世佛等故。此即大中之大。供养中供养也故重言)

次慈氏印。作三补吒。而屈二风指。令指头至火指根下。二空指并而厌之。余如常。此印如窣都波形者。以持一切如来法身塔故。犹如观音持佛身也。真言归命如前

阿誓担(古云阿逸多。此呼其名也。其义谓无胜也。一切爱见烦恼乃至二乘等无有胜之也)社耶(得胜也。于无胜中而得其胜也)萨嚩萨埵(一切众生也)阿世耶(性也)奴揭多(知心起也。起即是知义也。谓知一切众生性也。字阿阇梨云此是弥勒种子字也)

次虚空藏印。虚心合掌。以二空指并屈入于掌中是也。真言归命如前

阿迦奢(空也)三曼多(等也等于虚空也)奴揭多(得也前云知义起义。此中云至得义亦相会也)髀质哆嚂么嚩(二合也此么即是点。以加啰字之上即为多蓝也)啰(髀质多是种种义。么嚩罗是衣义也)驮啰(着也。谓着种种衣也。如虚空无色而能现种种形。此菩萨亦尔。犹如虚空而能满种种愿现种种形利益众生也)

次除盖障菩萨印。三补吒合掌。以地水指皆屈入掌中。余如常(其地水指合甲相柱也)真言归命如前

阿。萨埵系多(阿是能除义。系多是利益义。谓利益众生也)骠也(二合)嗢揭(二合)多怛囕怛囕。囕囕(是除义。亦是开发其善性令现也。如上所谓除着除其何事。谓除四垢也。凡夫爱见垢一也。声闻垢二也。缘觉垢三也。菩萨垢四也。除众生垢故入声闻位。除声闻垢故入缘觉位。乃至除菩萨垢故入清净位也)

次观音印。初作开剖合掌。以空指地指聚而相捻。余六指散之。其火风指皆并相着。水指独立即是也

萨嚩怛他揭多(如来也)阿嚩卢羯多(观也谓如来之观也)迦卢拏(悲也)未耶(体也言以大悲为体也。身心内外纯以悲为身也)啰啰啰(三垢也)[合*牛]阇(若也反。此[合*牛]字谓行解脱大空为三也。阇是生义谓从缘生法也)

此中如来观者。言菩萨虽未成佛。而见等同于佛。由见蕴性故得观名也。唯以悲为体。此悲从离三毒得无贪等三善根。而生成三解脱也。故有三啰字也

次大势至印。作三补吒合掌。屈十指相柱令周圆。如未剖之莲也。此未开莲。即是如来宝箧。犹开敷已而却合故。真言

瞻(是生也)娑(是等智也更问)

离世间主又超菩萨生住平等智中也

次多罗菩萨印。先作指向内相叉拳合掌。即竖二风指头相合如针。二空指并竖压之即是也。真言曰

多[口*(隸-木+士)](呼彼也)多利尼(上声。渡也。犹如渡人于大河置于彼岸上也)迦嚧拏(悲也)嗢婆(上)嚩(生也。由此菩萨从悲而生。亦渡众生到于悲处也)

次毗俱知印。如前向内作拳合掌。其二风指亦竖之。但参差相压。令右指压左即是也。其形势大同多罗。但参差指为殊耳。真言

萨嚩婆也(一切恐怖也)怛啰萨儞(亦是恐怖也。于一切恐怖之中。又以恐怖而恐怖之。令彼退散也如见不调伏者。又以刚强残威势而降伏之。令不得为非也)[合*牛](三义如上)泮吒也(是破坏义令彼诸怖退散也)

此真言毗俱胝持诵母者。于诸持诵之中犹如于母。功能最尊也

次白处菩萨印。双屈二水指入掌。其二空指亦并而屈之令相到。余作三补吒合掌。真言

怛他揭多肥舍耶(如来境界也)三婆嚩(生也言从如来境界生也)钵昙摩(二合)摩里底(鬘也严身具也。此即能生诸佛佛功德以为庄严。庄严法身也)

次马头印。作三补吒。屈二风指合甲。去空指根下。挟一麦许不相着。其二空指并竖。稍仰其甲头是也。真言

佉驮耶(啖也言啖食诸障也)畔阇(打碎也)萨破吒也莎诃(谓打击此障令四散也)

次地藏菩萨印。作向内相叉合掌作拳。申地水指令头相合(如峰刃也)二空指直并而竖之。真言

诃诃诃(离三因也。谓声闻缘觉菩萨之因也。凡此中诸真言。皆自说本尊之德行。此总持地藏菩萨之德也)苏哆奴(妙身也。内身极净故名妙身即法身也)莎诃

瑜伽者住(谓行者作如是印也)

次圣者文殊印。先作三补吒。以二火指反压二水指之背。二风指屈之。与空指头相捻即是也。真言

系系(此中诃声因也谓离二因即是超度二乘境界也。亦是呼召之声也)俱摩啰(童子也。破坏诸魔亦名俱摩啰矣)毗目底(解脱也)钵他悉体(他以反)多(道也言住何处。谓住解脱之道也)萨末啰(念也)萨未罗(念也)钵啰底惹(而战反。昔所愿也今念昔所愿也尊者昔所愿。悉渡一切众生令与我无异事。是故今当忆昔誓故也)

次光网菩萨印。以左手作拳。而申风指稍屈第三节。令如钩形。空指竖压火指即是也

系系俱末罗(释如前)摩耶揭多(摩耶幻也。揭多知也知一切法如幻也)娑(上)嚩(性也)婆嚩悉体(他以反)多(住也了知。诸法皆如幻故。即住诸法实性本性中矣也)

次无垢光印。舒左手一切指。皆令稍屈第三节即是也(空指亦竖并小似屈而已)。真言

系(呼也)俱摩罗(如前)肥质多啰(种种也)揭底(行也谓种种行也)俱摩啰(谓本誓愿。当普门示现身种种。以种种行而利一切。或现童子身或现壮年身或现老年身也)摩奴萨末啰(忆昔所愿也。圣者昔于佛前立此愿。愿愿如此愿当忆念之也)

次继室尼印。先以右手作拳。而申火风指令并合直竖。其空指亦竖而相并也。真言

系系(如前)俱摩梨鸡(童子作女声呼也亦是文殊之三昧也)若(上)那(奴干反与愿也)萨末罗(忆昔)补罗底然(本愿也。此意言。尊者于文殊处。所得胜愿本所愿妙愿。今亦授与我也)

次邬波继室尼印。先右手作拳而直申火指。其大指亦竖之(如常大指向外之拳。但申中指耳)。真言

频(去)驮耶(穿也)若那(智也前句末有阿声相连即是无智也。言以妙惠穿以无智。达于实相也)系(呼也)俱摩哩鸡(童女也亦是三昧。以女声而呼名之也)

次地惠幢印。先以左手作拳(亦是大指在外之拳)而申地水二指即是也

系(乎也)萨末啰(忆念也)若那(智也言当忆此智也)计都(幢也由此妙惠幢故摧诸魔今当忆念令我亦尔矣也)

次召请印。以上来五菩萨。皆文殊使者也。右手作拳(亦是大指在外者也)而屈风指令圆屈如钩。与空指头少许不相到即是也。真言

阿迦哩囇(二合)邪(招召也召请也摄召也。皆是钩来至此之义)萨鑁(上)俱嚧(一切作也。一切取与等皆是也。谓如尊者文殊所招召之事。皆当作之)阿然矩忙啰写(指此圣者之身也)

次诸奉教者(亦是文殊奉教者。与使者少异也)先作向内相叉合掌拳。而申二风指。头相合而屈第三节。二空指亦竖并也。真言

阿(行也。傍有点。谓示忿怒形也)微三昧耶儞曳(满愿也。希有之事无所不成也。能令一切希有奇特之事皆得满也。曳声即指此尊者也)

次憍都褐罗菩萨(此议谓除疑也。或除垢也。如大众人皆有所疑怪之事不能决了此菩萨即往其所而断其疑网以能为不请之友常断一切众生疑惑。故以为名也)。其印作向内相叉拳合掌申二火指头相合。屈第三节即是也(二空指如常在外竖也)

肥末底(无惠也谓所不了知也)制(去)驮迦(截断也。截断无知令智惠生也亦是决断之义也又是断坏之义。犹如能断金刚般若之义矣)

施无畏菩萨印。作施无畏手。瑜伽中(如释迦印也)申臂向上。令掌外向即是也。此印示行五法也。地为信水为进火为念风为定空为惠。诸佛菩萨以身口说法。今此印是表此五根力也。真言

阿婆演驮驮

即是无畏施也。以何法施无所畏耶。谓住阿字门离一切生。尊者所愿已满。我等未得。愿施我及一切众生也

次除恶趣印。即如前舒手令掌向上。而令向上举之即是也。真言

阿骠(波庾反)驮罗拏(举也)萨埵驮都(众生界也)

此义者以一切众生无始以来。以无明故常在三恶趣中。今圣者已得如是五力。愿举之令得清升也。所以者何。尊者已自能拔出。亦当举一切众生界也次救护惠菩萨印。如前舒手置心。当以掌向身而掩自心。大指稍竖向上耳。真言

系(离因也又呼召警发之义也)摩诃摩诃(大中之大尊中之尊也)萨末罗钵啰底然(本愿也。本愿除一切苦。以除苦故云为救护。今呼彼名令忆本所愿。而救护一切也)

次大慈生菩萨印。如前无畏施手。以空风指相捻。如人持花之状。余三指竖而向上即是也。真言

萨嚩(自也)制妒(心也)特揭(二合)多(生也言此慈从自心生不从他得故名大慈谓从自性清净心生不从大种心生故名自心生也)

次悲念菩萨印。如前舒手覆掌掩心。而屈中指当心而拄之是也。真言

迦卢拏(悲也)未卢(二合更问界也)尼多(上念也)

此意言尊本愿除一切苦。今当忆念也。然此菩萨名悲念者。意由未尽。其意者言。此菩萨系属于悲也。如人被他执持故不得自在。此菩萨身心系属于悲。为悲所持故不得自在也。又如人役属于王不得自在。此菩萨亦尔。常为悲所牵不得自在。犹此义故。当念本愿救一切众生耳

次除一切热恼菩萨印。作与愿手即是也。谓舒右手仰掌垂下之。如瑜伽中宝生佛印也。真言

系(如上)嚩啰驮(与愿也以离因之法而满一切众生。愿也)嚩啰补啰补多(二合。先得也。若不先得所愿。云何能授与人耶。犹先得所愿皆自满足故。今忆本所愿。而与一切众生。令除一切热恼也。所以者何尊者本立誓愿志求佛道。今已得之故当忆本所愿广度一切众生。皆令入佛道)

次不思议惠菩萨印。以施无畏手。空风指相捻如执珠之状也(其手当侧之如拟人合指捻珠。珠向上也。又中指稍相离而向内。余二指并竖之也)

萨缚阿奢(一切愿也)跛梨补啰迦(满也。谓令满一切众生种种胜愿如如意珠也)

次地藏菩萨旗印。先作指向内相叉拳。申二火指竖之。令指头一寸许不相到即是也(二空并竖如常也)计睹是旗也。此印如旗也真言

诃诃诃(离三因如上也)吠萨末罗(希有也。一切有情常有我想恼。截念之我想即除。此为希有也。亦是希奇义也)

次宝处菩萨印。右手作拳(大指在外者)即舒地水火指并竖之即是也

系(如上)摩诃摩诃(大中大也)

所以名宝处者。如宝生于海。从彼处生故名宝处也。如宝在海。从彼而有故得名也

次宝手菩萨印。右手作拳。以空指压诸指而直申水指竖之即是也。真言

啰怛奴(二合宝也)嗢婆缚(出也宝从手出也。言此圣者从宝而生。从何宝生耶。谓从菩提心宝而生也)

次持地印。作二手背反相叉合掌。右仰左覆指头相压。即以大小指相纠也(谓左手大小指向上而以右手大小指向下相句压即是)。真言

陀罗尼(地也。以地能持一切物故以为名也)陀啰(持也。持诸佛地荷负众生。故以为地。亦令众生皆得此地名也)

次宝印手菩萨印。先作向外相叉拳。申二火指令头相拄。大小指皆并竖之。其二风指当中指背。而句屈之。勿令着中指背。状如五股金刚即是也。真言

罗怛那(二合宝也)涅誓多(生也从诸如来宝而生也)

次坚固意菩萨印。如前五股之状。令诸指头并相着即是也。真言

缚誓罗三婆缚(从金刚生也。亦从于金刚不可破坏智印而生。故以为名也)

次虚空无垢菩萨印。作三补吒。以空风指头相捻令合聚是也(与如来刀印同)。真言

伽伽那(虚空)阿难陀(无量也)娱折罗(行也无量行同虚空故名也)

次虚空惠印。如前转法轮印同也。真言

折羯罗(轮也)伐底(转也)

言圣者先以得是法轮。愿为一切众生故。转此法轮也

次清净惠菩萨印。作三补吒。双屈二空入掌。以二风压其背上(其风指环屈。令甲相向即是也)

达摩(法也)三婆嚩(生也)

言此菩萨得自在同佛境界从法而生。故名法生也。谓从自性清净之法而生也

次行惠菩萨印。同观音莲华印即是也(空地相捻六指开敷如上也)。真言

钵昙摩(二合莲花也)阿赖耶(藏也藏即菩提心也。从彼胎藏而生也)

次安惠菩萨(或云住惠更审也)作向内相叉拳合掌。申二风指竖之。头边少许勿相着即是也(二空并竖也)。印此与多罗菩萨相似。但小开耳(与前异更问)。真言

若那(智也)嗢婆缚(生也从智而生)

次执金刚。如前作五股印。其二风指去火指上节一麦许即是也。真言

室战荼(战字有遮声。是生死义。谓离生死也上有鲇是大空言此生死同于大空也荼是战敌义也犹离生死等于大空。是以无能对敌之者也。句义战荼是暴恶也)摩诃卢瑟拏(大忿怒也。如上所说无能敌者。所以为忿也)吽(长声同前三解脱也)

以如上之法恐怖众生。令离生死得三解脱也

次摩么鸡印。如前五股金刚。其二空指二地指皆入掌中。亦右压左。即如前向内叉合掌无异。但火风指如金刚也(金刚母也)

怛栗吒怛栗吒(此中多声。即是平等同于如如理。是三昧也是离我慢也。住此如如。所有我慢自然无也。再言之者最极之义意也)社也底(胜也。谓以如如无我之法。降伏一切障难。令恐怖而伏之。即是战胜义也)

次金刚商佉罗。是金刚连璅也(大智之璅也)。如前作转法轮印是。以地水火风指相句。即向下旋转向里转之。当于胸前令二空指向外。其二空亦令右压左相勾也。真言

[合*牛](三称如前)畔陀畔陀(缚也。谓离二种缚。即是烦恼所知缚也)母吒也母陀也(如壮士捉缚无力人戾渐至颈令身分破坏。令碎二障亦复如是。故以为义)伐折噜(金刚也)驮吠(生也从于大智而生也)萨缚怛啰(一切处也)钵罗底呵低(无有能害也)

次金刚月黡忿怒印。此金刚在佛额豪相而生。故以为名豪相明净犹如满月。故号月黡也。如前五股金刚印。屈二风如勾而捻二空。令少屈不相捻着即是也(与前异也)

颉唎(二合。离因无垢傍有点极忿义也)[合*牛](三称也)泮吒(极令除故)

次金刚针印。作向内相叉拳竖二风指头相著令如针状。其二空指并屈而入掌中。真言

萨嚩达么(一切法也)涅鞞(上)达儞(穿也以金刚慧针。贯达一切法也)伐折啰素胎(金刚针也。以何物穿之。谓以金刚智针也)嚩啰提(与愿也犹先愿力故今得此愿。亦当令一切众生皆达诸法源也)

次金刚地捧印。作向内相叉拳。二空并竖之为拳。并二肘相近稍高竖之。以象槌形也(举向右边。如欲嗔打状也)。真言

萨普吒也(散也。以金刚慧槌击三毒缚。令散分破坏也)三婆(上)吠(生也。谁能作此事谓从金刚生者乃能作也)

次难胜金刚印。右手作拳。竖风指而当心上。左手作拳(皆大指在外)直舒臂。令拳稍高与头齐也。以一切魔不能娆乱胜之故得名也。真言

杜达里沙(去难降伏也)摩诃卢瑟拏(大忿怒也以何法而伏众魔。犹有大忿怒也)佉陀耶(食也食一切烦恼等障结也)萨嚩怛他揭多阿曳然(一切如来教也)俱卢(奉也。谓奉一切如来教当随教敕而作也)

次相向金刚。犹与难胜相对挟门。故得名也。其印如上(唯翻右为左耳)

系(如上)阿毗目佉(相向也)摩诃钵啰战荼(极大暴恶也)佉驮耶(食也)紧只罗拽细(何不急速也)三昧耶(本誓也)摩奴萨末罗(忆念也。本于一切如来前。立三昧耶誓。啖一切烦恼。今何不忆本所愿急速作之也)

次如前佛钵印。即是释迦佛钵印也。真言

萨嚩吉隶铄(一切烦恼也)涅苏达儞(掘也如利钁直下令彻底)萨嚩达摩(一切法也)钵啰钵底(得也谓于诸法而得自在也)伽伽那三摩(虚空等也。以于诸法得自在故等于虚空。以此法而掘烦恼也)

次如前毫相印。即释迦豪相印也。次以右手五指。聚捻之置于顶上。此即一切佛顶印也。真言

鑁鑁(鑁音嚩也。二嚩谓烦恼所知之缚悉令如空也)[合*牛][合*牛][合*牛](离三因得三空证三昧也)

次左手作拳舒风指火指。以空指压地水指甲为刀鞘。其右手亦如是作之为刀。内刀鞘中。即不动尊印也。其鞘手仰刀手覆也　降三世印。如五股金刚(更问)

次佛眼印。作三补吒。双屈地水入掌。竖二火令如针二风指转。捻二火指第三节上。由如眼形。二空指并竖稍屈。令当二中指下。使指头如竖眼之形。即是三昧也。其地水指如向内合掌之法。如前名为佛母印。此中名佛顶印。亦名佛菩萨母印也

次白伞佛顶印。散舒左手。令指头相去各寸许。以为伞。右手作拳。而竖风指为柄。以柄柱左掌心是也(凡言作拳者皆大指在外他皆放此)。真言如前耳

次作胜佛顶印。如前刀印是也。谓作三补吒。火指竖合。风空相捻即是也

次最胜佛顶。如前转法轮印即是也

次除业佛顶。如前钩印即是也。谓作向内相叉合掌。而屈右手风指令如钩形。二空亦右绞压左。今单手。即右手为拳。竖风指稍屈上节

次火聚佛顶印。同前佛顶印也　广生佛顶印。如前五股金刚印也

次发生佛顶。作莲华印(即前观音印也)无量音声佛顶。作商佉印如前说(谓三补吒双屈二空以风并压之)

次豪相印。以右手为拳。便以风指于眉间柱之。名真陀摩尼。即是毫相印也

佛眼印如前佛母印作之。是中少许异者。谓开空指令去火指背。一麦许不相着。如似五股之形即是也

次无能胜明王印。右手如执莲华印(风空指头相捻。火指垂屈当中。地水指正竖即是也)直舒左手五指向上。而向外托之(指头舒散也)。其手稍令高于头即是也。其立如前钵栗底(丁也反)哩也

次作内相叉拳。其二空指相并而为拳。极相离开而屈之。其节如钩。此名为口状也。即是无能胜明妃印也

次舒右手而托右颊。稍侧头就手少许相去即是净居天印(此是思惟手也一名自在天)

次同前自在天。舒右掌。其中指稍亚头向里共头指稍作烈形也。即普花天子印(手当胸前侧之次脱一天子印)

次亦如前舒右掌。而以风空相捻。如持花形。即满意天子印也(余三指相并合之也)以上并净居天子耳

次地天印。先合掌其十指头。并屈而相捻令圆屈之。空指令入掌内。其形如瓶子即是也

次如前施无畏状。而曲屈空指令当掌中。即是请召火天印也

次两手各以空水头相捻。余指端直双掩两耳。遍声音天印也。以火风两指头掩两耳也。此合在地天前。谓其声令众普知也。亦是净居天也。并净居天印合为五天也　作施无畏手。以空捻地指第二节。即一切仙印也。从此下与经列。第二也。此是普一切仙也。先大指捻小指第二节。其三指竖并也。如其次第。先开头指次开中次水。与地少相离。次即放散五指。此是五大地仙也。依经次第也

次阎罗印。作三补吒二风二地屈入掌。令头聚合。以二空捻二风背节(当第二第三间也)其空指头稍屈令合以二空当火指是也(是坛荼印)

大毗卢遮那成佛经疏卷第十三大毗卢遮那成佛经疏卷第十四

        沙门一行阿阇梨记

    密印品第九之余

次右手舒指。令如铎形向下垂之。阎罗后印也

次以左手。握地水指入掌。火风相并而申之其空指如寻常作拳也。此黑夜天印也。阎罗王后也

次如前印相。但屈头指。以大指头捻头指第二节。噜捺罗后印也。自在天后印也(更问)

次以左手。犹如执莲华形。梵天后印也(谓舒掌以空风相捻其中指屈当掌内图中直申也)梵天无欲。反如人等身云何言后耶。此是梵王明妃印相义云妃也

次左手舒掌。而屈地水二指入掌中。回风指捻。着火指之背。空指亦稍句屈。即是娇末离砾底印也(砾底是器物印也图如之)此是大自在之子名羯底迦。此娇末离是其妃名也

次以左手申地水火三指。令各舒散。以风捻空。此是那罗延后印也(持花印掩胸也今此印向外掘也)

次以左手作拳。直申空指向上。是阎王七母等印也(以七母皆通用之)

次舒左手。而令曲如承触髅之状。当胸前仰之。是遮文荼印也　左手以空。捻地水甲上。而申火风并竖之。即涅哩底刀印也

次以左手单舒散之。如前转法轮印。但单手不相句绞乃为异耳。此是那罗延天印

次舒散十指覆之。以二空相绞即一切龙印也。因即以右加左上。是难陀龙。回左加右。是小难陀也。如前九头龙印。直申四指分为羽。是金翅印。凡地居多分单手作也

次舒竖左手。令指头勿相着。即以空地相捻。捻小指甲也。是商羯罗印也(是骨璅天也)如前印而并合三指。即是乌忙那印。是商羯罗之后也。二印相似。前头指少屈。此直竖而散也。左手作半莲华印一如作观音印法。此不同但一手作之耳。此是梵天印

次显露合掌。乃屈二风指头。捻火指第三节背上。令与其二水指头相到也。其二水指亦在中指第三节之背也。其月天印。一如梵王无异。但想有白色为异耳

次合掌屈风地入掌聚合。其火水指令团圆。屈如弓。此是日后社耶印风印。如前者。须申左手侧掌。屈地水指是也。此是风幢印。先仰左手当脐。如承把瑟状。右手风空捻余散申之。向身运动如弹弦之状。是妙音天印也。此即摄乾闼婆等。此是天后。亦言乾闼婆类

次如前罥索印(谓作内相叉拳而申风指钩屈相捻是也)但以左手作之。即是缚噜拏龙王印

次以左手如音乐天印。图中右手屈风指。加大指甲上。余皆散舒之而覆当。临左手之上。阿修罗印也。其真言曰

伽啰逻演

伽行也。以行不可得故。啰者是无垢故。逻者离相故。演者无所得故。上有点大空也　乾闼婆作内掌拳。并舒水指头相到。是本部三昧耶。若事业印。即单作。谓大指加三指甲上。而直申水指。是乾闼婆印。真言曰

肥输(入)驮(清净也)萨嚩啰(音也)嚩醯儞(平声。出也义言出清净音也。皆世间三昧也)

次以左手作拳。屈风如钩。与空指头少许不相着。一切夜叉印也(亦可合作)。真言曰

药乞叉(药是乘也。句义是啖食义也)湿嚩啰(自在也于食一切烦恼而得自在故以为名也)

次以左手空指。捻地指甲头。而申水火。以风指捻大指节上。一切药叉女印也(亦可合作)。真言曰

药乞叉(食也)尾驮(大也反明也。句云药叉持明也。亦是缚义谓啖食此缚也)

次左手以空指。捻三指甲。即但申中指。一切毗舍遮印也(亦可但如作拳形而申中指即是也)。真言曰

毗舍遮揭底(揭底趣也。第一义趣不可得故)

次亦准前而稍屈中指。毗舍支女印也。真言曰

毗只毗只(毗是第一义。遮是离生死义。以知第一义故离于生死。重呼者言极离生死也)

次二手合掌。二空指亦并。与极磔之。令与余指相离。仡栗何印也(此别是一趣。非人非鬼也。能恐怖人。非人所持者是也。今非此也是曜)。若近宿。即合取九执为定也。真言

揭栗系(行也垢也因也)湿嚩里也(自在也)钵啰补多(得也)乳底(明也诸曜故为明)么也(是性义也。于性中而得自在也呼彼名言于此中而得自在也)

次先作三补吒。其二火指二空指皆相交右押左。是一切宿印。真言曰

那乞叉哆啰(诸宿也)涅那(二合谓声也)达儞曳(食也谓食诸声也)

那是空义。乞叉曳是尽义。谓一切除尽也。哆啰如前是垢等义。准言之。谓食诸障垢也。即以清净之声普令流布。所谓无垢声也。凡如上所说真言。皆以义言称彼实德。发觉彼而令欢喜也

次作三补吒。双屈二水指入掌。余如常。一切宿印。即是罗刹娑印也。凡上来所说地居天类之印。双手作或一手作者皆得也。若持诵作务等因缘不暇两手结。但左手作即成耳(上来经中云左手图上两手者当用此耳)。真言曰

罗刹娑(罗是垢也。傍有点是阿声。即是行也乞叉是履空也)提阇多(王也。指其德也。令彼闻已欢喜满众生愿也)

次舒左手覆掩口。以舌触掌。即荼吉尼印也。颉[口*履]字离因无垢。上有三昧。傍点示忿也。诃是因义。上有点亦忿也。此等为首者。如上所说诸印。乃至荼吉尼为后。若广穷部类眷属则种类无边。如大本十万偈中所辨。今此品所说。乃是略举其上首。如提纲举目众纲目皆举耳。秘密主。如是等。佛信解生菩萨摽者。如来已证平等法界。以本所愿大悲力故。以神力加持。而现此方便身密之门。为令一切众生皆得信解。同入一切智地。是故如是等印。当知从佛信解生也。当知如是印等。是诸菩萨之摽帜也。谓以此方便示如来内证之德。故云摽也。如印众多。乃至身分举动止住皆是印者。若阿阇梨明解瑜伽。深达秘密之趣。能净菩提之心。以心净通达秘密法故。凡有所作。皆为利益调伏众生。随所施为。无不随顺佛之威仪。是故一切身所有举动施为。无不是印也。何但身业而已。乃至一切所有语言。亦复皆是真言也。以是秘密主。真言门修行菩萨。已发菩提心。当住佛地作漫荼罗。若谓今末世诸真言行菩萨等。同越三昧耶罪。决定堕恶趣者。谓今末世诸真言行菩萨。已发大心者。当住于佛地。然后造立漫荼罗。若不如此而檀作者。即为谤佛也。是故上来所说。阿阇梨当可知彼印真言等法。一一善达轨则。又当久修瑜伽之行。净身口意业。体解平等三业法门之行。由此瑜伽及真言并身印等所加持故。即是同于诸佛菩萨等身。同于佛位。以此相应三昧事理不相违。而建立圆坛乃至方所色像等。一一称理又不错失善知次第。当知必定获大利不虚也。若不尔者。即得越三昧耶罪。三昧耶者是自誓也。一切如来本所立誓愿。为欲普为一切众生开佛知见。令悉如我。以方便故而立此法。是故犹如世间大王之教敕不可过越。为越者必获重责也。是故当与菩提心相应。住于佛地而作之。有不顺教者。徒费功夫虚弃光景。终无所成。徒招罪咎无所益也。是故行者。当审求经法。又访明师开示。勿为自误耳。已广说印品竟

    次明字轮品第十

佛复告金刚手者。前者金刚手所问。佛已次第答之。前文有所未周者。今更为说。故告令谛听也。有法门名遍一切处。彼菩萨字位住时。一切所作皆得成就者。即此字轮法门。是遍一切处法门也。菩萨若住此字轮法门者。始从发妙菩提心。乃至成佛。于是中间所有一切自利利他种种事业。由入此法门故。一切皆得成就。无有挂碍也。又上来所说。阿阇梨住于佛地者。义犹未了。谓此中字门即是也。最初阿字即是菩提之心。若观此字而与相应。即是同于毗卢遮那法身之体也。谓观此阿字之轮。犹如孔雀尾轮光明围绕。行者而住其中。即是住于佛位也(更问)此字轮。当作三重。于中而置阿字。余字眷属在外也(更问)又此阿有五种。阿阿(长)暗恶恶(长)又每字轮。初先有三重归命三宝真言之心。谓阿字娑字嚩字。即此三字显三部义也。阿字是如来部。娑字是莲华部。嚩字是金刚部。每三部随五字轮而转。随义相应之相。前言漫荼罗今云轮者。即是漫荼罗义。前者坛法中心是大日如来。即同此中阿字。北边置莲华及诸眷属。皆在一处。即是此中之娑字。南边置执金刚及诸眷属。即是此中之嚩字也。今从阿字而更生四字。即是大悲胎藏之叶也。从一嚩字转生多字。故名为轮也。第一阿字。即是菩提心体。次有迦佉哦伽等五音。皆取四字(各除第五声)次又取也啰乃至乞叉。皆是男声。悉入阿字轮也。行者已发菩提之心。当进修如来之行。故次明阿(长)字轮。是行也。其三部者。谓阿沙嚩三字是也。次迦字乃至乞叉。亦皆傍角加点。用为长声字轮也。既已具足如来之行。则成菩提。故次明暗糁鑁字轮。此三部也。此阿上有点。是大空义。犹此菩提之心。离一切诸相。即名诸佛。是成菩提也。次迦字乃至乞叉。皆加上一点为暗字轮也。已成菩提当至何所。谓大涅槃。故次于此中。而明恶索嗼等字轮也。三部也。如迦乃至乞叉。皆傍加二点。即涅槃轮也。其恶(长声)字一字是方便轮。所以中无也。此是释迦佛轮也(羯磨部遍入一切轮故无别坛。瑜伽云尔)凡字轮大为三分。初阿字即为一分。次迦乃至二十字为第二分。次也字乃至诃字为第三分。除去乞叉字。由此字已重故也(谓有迦娑二声故重也)以上皆是智慧字也。次有伊(上)伊邬(上)乌翳爱恶(多)奥八字。加此八字即成就三昧。皆是三昧声也。亦随五轮而恒转其义可知。次有俄(鱼可)若(而可)吒囊(上)莫(莫可)此字遍一切处。谓遍于定慧中也。然此五字亦随五轮而转谓加傍点或加上圆点或加傍二点等。此五皆成五字也。所谓字轮者。从此轮转而生诸字也。轮是生义。如从阿字一字即来生四字。谓阿是菩提心。阿(长)是行。暗是成菩提。恶是大寂涅槃。恶(长)是方便。如阿字者。当知迦字亦五字。乃至佉等凡二十字。当知亦尔。次有十二字。谓伊(上)伊邬乌噜留卢留翳爱乌奥十二字。即同字上之点。谓三昧也。仰壤拏曩莽亦有五字。即同上头之点也。其也啰等八字。即同字傍之二点。是除之义也。当知此字轮。即遍一切真言之中。若见阿字。当知菩提心义。若见长阿字。当知修如来行。若见暗字。当知成三菩提。若见恶字。当知证大涅槃。若见长恶字。当知是方便力也。若见迦等二十字。亦随义类而演说之。当知此诸字等。皆是慧也。若见啰等八字。当知即同傍点。亦是随类相应也(谓啰是无垢等)若见伊等。即显三昧。若见仰等五字。当知即大空之点也。大空离一切诸相。即是成佛义也。若行者如是了达。即能入一切陀罗尼义。旋转无碍。故名为字轮也。如是秘密主。字道门善法真言道住次第。诸佛神力加持三藐三佛陀道菩萨行舞者

经云。如是。即指上字轮也。如上来所说定慧空等。即是佛道之门。能成正觉之道也。若了知字义。即能住于真言之道。其中次第法则证入之相阶位差别。亦悉晓知。明达通塞无有疑滞也。然此悉昙字母。乃至世间童子亦常修习。何能顿办如是事耶。然此诸字。皆是如来以加持神力。从如来内证体性而流出之。故能有是不思议业用。若人明解此中意趣方便。即是通达三菩提道也。善能通达者。谓达一切众生诸根性欲。当以何法而得入道。当从何门而得晓悟。如是等无量无边皆能了知。而随众生受与妙法。皆令得至如来之地也。舞者如世人舞。而于大众中。动种种身业屈申俯仰。又出种种微妙巧便之音曲。顺众生之所欲乐。彼大众或令欢喜。或令悲思或令恐怖。以一身口所出方便。令诸众生所益不同。由彼善知去就。能顺众生心故。菩萨亦尔。现种种威仪无不成印。出种种妙法音。皆是真言。圆应无方皆得大利故。名菩萨舞也。三世如来皆作是说。已说今说当说者。如是字门真言净道。十方三世诸佛道同。皆如是普现色身。以种种门开示佛道。同彼舞伎曲顺人情也。无彼我者。我以佛眼遍观三世一切佛刹。同说此门。一切佛与我无异。一切佛与彼诸如来。亦复如是无有异说。故云无彼我也。此即一切佛教。应当如是修之。若异此者方便即不具也。以是故者。是如来结成彼义。而告金刚手。若告金刚手。当知即是告一切大会也。谓彼真言行菩萨。若欲速得古佛之法者。应当修学如是遍一切处法门。勤心听闻思惟修习。由此之故。或能一生之中。得一切如来种种舞戏歌咏而悦众生也。初中后相加者。谓阿等五字为初。迦等二十字为中。啰等八字皆是傍点。此诸字皆是助成字义。故后分也。凡迦遮吒多波等。皆属阿字门。阿字是菩提心。此中初中后相加者如阿字单是菩提心。若傍角加画即是行。此是菩提心并行也。若上加点者。即是菩提心并大空离一切相成菩提也。若阿字傍加二点。即是菩提心并除一切障得涅槃也。他皆效此。而转相加。或但一义或二或三义可知也。或有阿字。上虽无点。而其次有字是重字。有其仰壤拏曩莽等声。以此连前即是暗字。所以尔者。此仰等是点。用加于前即阿字成暗音也。或阿字无点。其次有重字有也。如迦佉俄伽重加四字。用于仰字为点也。遮车阇社字用壤字为点也。他效此。啰等声以配于前。即成恶字也。所以然者也。啰等皆是傍二点。今以连前。阿即成恶声也(更审问)夫法体无言离诸分别戏论。复能一切如来。以自在加持神力故。成此字轮故。能作如来事利益群品也。迦遮吒哆跛。三昧品证菩提心行佛受与并涅槃。此等说字等相加有真言教初中后俱(此是。经文已释文竟)如是知随意持诵者。决意一一句用之知觉。当授与句无上殊胜者。如是知者。即是一切智智名之差别。若行者如是了知字轮之义。即能所欲皆得成就。以要言之。所谓一切皆随意成者。谓成如来一切事业也。若成此者。即是同于法王。于一切法中而能自在。亦得随本所愿为一切众生。开净知见令得佛慧也。何人得此利益。谓如理具缘善持诵者。故次云持诵者也。谁得此决定意耶。谓有慧之人。善觉了识知字轮义故。随于阿等诸字一一字门随所修行。决定悉皆得成菩提之果。勿生疑惑也。此中觉知何法。谓如阿字是菩提心。加点即是菩提行。加于大空即成佛也。若菩提心清净除一切盖障。即是大般涅槃。更无他义也。如是等一一通达了知。即是受得无上殊胜之句。无上句即是成菩提也。此无上菩提之心。即是诸佛自然之智。实无有能授与之者。但行者方便具足善知字轮之义。自然得之。即是授与无上菩提也。如是一轮。轮转字轮知持诵者。常明世间如世尊毗卢遮那。轮转者如世间之轮若旋运之时。不可知是终始之际。无有边际不可穷尽。当知此一一字轮。亦复如是。从阿字旋转出生一切诸字。此字轮即遍一切真言名字之中。回转总持无有边际。不可尽原遍一切处。即是百千万亿旋陀罗尼也。行者若能如是了知字轮之义者。则能以此常明而照世间。常住之明即是大日如来之体。同彼毗卢遮那而转法轮也。此中常明即是大慧日也。此日即是菩提之心阿字之体。无生无作无有变易。非由造成。如是常住实相之慧故名常明也。若行者勤功久修无有懈退者。决定得之也。然上来所说漫荼罗方轨法用散华灌顶。乃至或授以明镜。如以金錍决其眼映。如是等。皆为创发菩提心者。以方便加持次第法用。成彼坚固之心。作入佛法之阶渐。然此中秘旨在于字轮也。所以者何。若行者为人作阿阇梨。欲造立漫荼罗者。先谓住于世尊之位。谓以此诸字门而合集成身。即是身同于佛也。谓瑜伽阿阇梨观行成就。随心所作任运皆成。观此字轮遍布身分。犹明见故。同于佛与佛同位也。然布字之时当分为四分。即是四重漫荼罗也。头为初分。是阿字菩提心位。从迦佉俄伽仰等。乃至奢娑诃。凡是第一声者。皆属菩提之心也。当从行者眉间白毫相处。而观迦字。从佉以下当右旋逐日而转。以次一匝布之。令环转相接。次从咽以下为第二分。属长阿字门。亦当中与白豪上下相连。右行布之一匝相接。此是菩提之行也。次从心以下为第三分。属暗字门。从心上布于欠字。以次右旋一匝相接。次从脐以下属恶字门。是大涅槃。亦从中而置迦(入)字。以次右旋一匝相接头为上分。咽心为中分。脐为后分(私谓发菩提心为初。行果为中。大寂为后也)其第五恶字遍一切处。随意所作皆得也。此在身外。如佛身光。随意而用不在身内布字之位也。闇字亦尔与恶同也。师既如是成身已。其漫荼罗亦如是布之。亦当想弟子令如是作之三事皆成。是秘密漫荼罗也。若不了达此中意趣。虽依前事法而作。不名善作。虚费功夫亦无所成也。又此布字之法。是秘密漫荼罗。自非久习真明之行。堪传授者方以意相传。不可以文载。故师以口相授。经所不说。但云如毗卢遮那轮转也。复次行者须知诸字之色。谓初阿字及迦等二十五字。及也啰乃至诃字。皆属于阿作其黄色。所谓金刚之色也。第二阿字转作黄白色。所谓寂静色也。阿字体黄三昧为白。二色合故黄白也。第三加头上点者亦作黄白色。暗也。阿字黄大空白。故黄白也。次第四恶字转作黄黑色。阿字黄二点涅槃色黑。故黄黑也。亦可二点是降伏义。犹如涅槃坏灭摧破一切障法。此亦如是故。二点作黑也。第五恶字者。阿字体黄上点即白傍即黑。当知即是种种杂色也。凡布漫荼罗亦为三重。第一重迦字乃至诃周匝。内重名为金刚轮也。此金刚轮持一切法。犹如世界金刚之轮持于世界也。即是行者最初菩提心轮。谓欲坚固菩提心故。先作内重也。次第二轮谓阿暗此是长阿及暗二轮。同是中分若用迦为轮。即不须用欠字轮也(私谓迦是行者因欠是证是果也)次第三轮用恶字轮。亦顺中如上布之令环合也。其伊等十二字在外散布。犹如光焰也。此即是三转法轮之义也。如是布已。持诵者即是持明之身。犹如大日如来神力加持。等无有异。此轮亦名因缘轮也。师及弟子并漫荼罗。皆作如是秘密之轮。又此诸字即是真言之轮。故凡有四种轮也。又字轮者。梵音云恶刹啰轮。恶刹罗是不动义。不动者所谓是阿字菩提心也。如毗卢遮那。住于菩提心体性。种种示现普门利益。种种变现无量无边。虽如是垂迹无穷尽。能实常住不动。亦无起灭之相。犹如车轮虽复运转无穷。而当中未曾动摇。由不动故。能制群动而无穷极也。此阿字亦复如是。以无生故即无动无退。而生一切字轮转无穷。是故名不动轮也。若行者能了达如是不动之轮。而布诸明。即以其体自然。身有所表无非密印。口有所说悉是真言。凡有见闻触知之者。皆必定于无上菩提所成福利。真不虚也。如能如是。即同毗卢遮那。而作佛事常照世间也。凡行者持诵时。当观字轮或为句轮。所谓句轮者。观本尊心上有圆明。而布真言之字。轮转相接。令明了现前。持诵时观此字犹如白乳。次第流注入行者口。或注其顶相续不绝。遍满其身乃至遍于支分。其圆明中字常明了。如常流水而无有尽。如是持诵疲极已。即但住于寂心。谓观种子字也。其观法如上已具说之。若得见种子字已。即从种子字中而见本尊也。如是成已即能遍布字轮。而成持明之体。方堪作诸事业也。如是阿字是不动义是金刚体。凡欲令事坚固不动。或令若自若他道心不动等。皆用阿字加之。余一切字亦随事相应用之也

    秘密漫荼罗品第十一

尔时毗卢遮那世尊。复次入一切法界如来眼界观。法界藏奋迅如来平等严藏三摩地证(现证也)法界无尽严现故。以是真言行门度无余众生界本愿满足故者。上来已说字轮品竟。次明秘密漫荼罗品。由秘密故凡有所说。皆是如来加持神力。则不可表示故。名神力加持字轮品也(余一切品皆如是释之)已说字轮品了。次欲成就此字轮故。复入三昧。此中经所云者是出三昧名也。一切法界者即是无相法界也。已是无相法界。以佛眼等观如是法界故也。又秘释者。如上字轮即是诸佛之法界。以佛眼观此法界也。当知此佛眼观。即是如来加持之力。若离加持则不可说也。法界藏者。此藏梵音云俱舍。是鞘义也。犹如世间之刀在于鞘中。此藏亦尔。故以义翻也。故此中云法界藏者。即是如来所出之处。谓一切如来处在其中也。奋迅是流出义是流溢义。如师子王在深窟中安住不动。有时出穴频申奋动。即是其身本不动今则离其常处而动故也。佛亦如是。安住如是甚深密藏之中。若非如来加持神力。则微妙寂绝不可得示现。今乃示现无尽身口意种种形声。遍满法界。即是诸佛奋迅也。示现如来平等严藏。此是胎藏之藏也。犹入此法门中。十方三世一切如来身口意。皆悉平等平等。佛佛道同故名等也。严谓庄严其身也。即以无量佛道之门。而用庄严法身。以度众生也。即以平等法界庄严法身。故名严也。犹如世间众军之处有大幢相。名之为严。此三昧亦尔。由此三昧能表示如来秘密之事。故以为名也。此中藏者梵音名揭诃。即是流出无尽庄严。奋迅示现不可穷竭。犹如大宝之藏。此平等法界藏。即是如来藏义也。以法界庄严不可穷尽。犹如字轮旋转不可穷尽。名无尽藏也。如来何故处此三昧。然亦非无因缘。正谓开示如来甚深秘要之事也。故次经云。以是真言门。度无余众生界。满足本愿故。佛本行菩萨道时。立大誓愿。悉令一切众生。同入如来法界之藏。今者所愿满足。由大悲故。奋迅示现而度众生。如法界严藏不可穷尽。众生界亦尔不可穷尽。今欲普以真言行门平等利益。咸令开净知见究竟无余。即是所愿而得满足。故云满本愿也。复次作法未得成就。犹未成就故。修真言行者。不得速成无上道。今更决择悉令得显现故。入此定也。次在定者。谓佛住于三昧。而现希有之事普利群生也。于此定中。现何等希有之事。谓无余众生界。声门等如其意业生成就受诸果报色形之音。随心思说种种法。令一切众生欢喜。一切毛孔等法界增身出者。此声梵音亦是吼也。犹如大龙出现雷音。震吼。一切皆悉闻之无所不遍。如来吼亦如是。遍于无余有情之界。此界无量声亦普闻。非如世龙则有限量也。众生界中上中下品。随以何业而得果报。故云业生成就也。犹如世人受得食而未啖。犹固未名为受。若领受吃已。乃名受彼食供也。今异熟受报亦尔。各称先因而受彼果。形显色等差别万殊音说不同。意乐信解各复殊异。佛以一平等妙音。应彼彼心如其志意。随彼语言而示悟之。发彼思觉方便开诱咸得欢喜。即是三昧中未曾有瑞相也。此中说种种者。如声论中义。假令三音和合共表一义。若义未圆则更加一字令满。若四音共表一义。今用三音其义已周。则除一字。如是随宜加减之。今此中亦如是。但以一阿字门具一切义。于事无不周圆。故名为说。非同说法之说也。梵音有异更问之。法界增身出者。平等法界。究竟寂灭无有出入之相。以如来神力加持故。而出无尽色身。谓从佛一一毛孔中。随现如前吼声。又出种种形故。云法界增身也。其实从缘而起无生性。如是实相即同法界之体。何有增加生灭耶。虽缘起法体常如相。然以如来加持力故。从一一毛孔各现吼声。或以软言或以粗语。或深或浅应彼心机。如大海潮不过常限。其身亦尔。或大或小或忿怒形。或行六度或以威伏。差别万殊。所度有情无有错谬也。前示字轮。今从法界轮中而现形声也。出已虚空等同世界中一音声法界表如来生偈说者。如虚空无有边际。此声亦尔等同于虚空。表谓表示也。即是如来语表之业。谓表现一切众生。皆令称悟平等法界也。以此妙音而表示法界故。云法界者心也。一音即是阿字之门轮转无穷。等虚空满法界也。三世诸佛皆从如是妙偈中生。故名如来生也。今佛从此一音之门。而说妙偈。普令无余世界。平等闻知随类得解。故以为名也。如上所说字轮。欲表如来功德也。故佛于一一毛孔。出妙音声遍于此界。说是字轮甚深义。所谓能生诸佛之偈也。若有众生。了知如是字轮之义。即成菩提故。云一切诸佛从是生也。然诸佛法身离于生灭。若如来有生即是着相。夫着相者尚不能离生死。况能成大菩提。今言生者是真实离相之生也。以清净法身离一切相。然佛以加持力故。用此字轮开示如来秘密内证之德。由佛自在神力所加持故。因此有相方便。能生无相之相也。犹彼未觉了时。因此字轮以为方便。渐能了达观察阿字之门。以入阿字门故。即能究竟自在法身也。偈云。生随类形法诸法相者。谓入阿字门故。即是平等法身。由此无相法身故。即能随缘感应普现色身。随彼种种类形。以所喜见之身。而为开示如来智慧也。偈云。诸佛声闻及诸缘觉。救世菩萨勇进如佛亦然者。由此无上无相之身故。一切诸佛皆从是生。非直诸佛从此而生。一切声闻缘觉菩萨种种行位。乃至一生补处之位。皆由此阿字之理而生也。非直生一切圣贤之果。乃至一切有情世间及器世间。种种差别次第增长。皆亦由此阿字义而生也。故此中生者略有三种。上品生者。谓生如来真净法身常住之果体。次生诸佛菩萨二乘。随在何地而除彼障。下品生者。即有情及器世间。皆亦由此法门而得成立也。生住等诸法所生常者。然此中所说。不同外道断常之见。诸法虽从因生。而生因无相。虽从缘生。而此缘无相。虽从缘起而法本不生。虽从缘起灭而无生住之相。是故为常。非同外道之见故说生灭常也。偈云具智方便兼离不慧疑者。了达阿字之轮。诸法毕竟空无所有。寂灭无相之体。从本不生是为慧也。真言身印瑜伽等。能令行大利益入于佛慧。是方便也。若依方便而无慧。但有慧而无方便。终不能成不可思议自然之用。要因方便及智慧具足。方便得入于字轮之秘藏也。离不慧疑者。若离如是二法。当知是人为不慧人。由不慧故。当处处生疑不能进趣也。又行者若智慧方便兼具。自然离于无慧不生邪疑也。偈云。观此道诸佛所说者。非但我如是说。以一切等正觉皆如是说无有差别也。由十方三世佛。同得此道然无差别。一相一味无异说也。尔时法界生如来身。一切法界自身表化云遍满毗卢遮那心自在诸毛孔中佛生转展者。此中法界生身。即是毗卢遮那法身也。以从法界真实而生故。名法界生也。一切法界自身表者。表谓能令一切悉知见也。谓于一切法界中。自身表化云皆遍满也。谓如来身表普现色身。如彼大云遍于法界。云是遍满义也。言此化身之云遍满法界。遍于十方世界不可限量也。此中心自在者以义翻也。正义云心才。谓才敛念之时即不用功力。即能如是广大弥满也。此即是能于心得自在也。诸毛孔中佛生展转加持者。犹如来才入三昧。即时顿现如是普希有之事。即如来是加持神力也。转展者互相涉入也。从佛身毛孔。流出如来本身展转相入。一一身皆现如上神力。化而复化无有穷尽也。此等义当更详言之。转展加持者。谓以佛自在神力之所加持。此即是如上所说法界性字轮之所加持也。从佛自身一一毛孔出种种身云。随其上中下分。谓头为内胎。心以上为第一院。脐以上为第二院。脐以下为第三院。即配前圆坛四位。随彼左右前后上中下分。而为显现本尊之身。各依本位而出。于世界中施作佛事。从一一身展转出。作诸佛事故云展转也。时执金刚亦知佛意。今佛世尊现于希有未曾有事。非无因缘。必将更说深秘之法。谓如上所说有所未了遗阙者。必将说之。诚心希仰而住。故佛即更告言。秘密主有造漫荼罗造尊位分并种子作标记。谛听善哉极善作意思念吾为说者。时佛为执金刚等。现如上分位已。时诸尊等既作种种佛事。还从本位而入毗卢遮那如来之身。亦如出时位次无异故。彼经云。复入法界宫也。尊分位种子者。如上诸尊。皆是如来内证之德。各从一一。而表如来所显法界甚深之趣。今若有阿阇梨欲作坛。是先住此瑜伽。如彼从佛身一一位次。如其形色观已。于彼心上作圆明。于圆明中而观彼种子。如是一一安置。方成作法。若不如是者。终不能加持建立彼诸弟子。亦不得阿阇梨名也。如前所言烦恼种子断已。次生法界性种子。即是一切有情平等种子也。此平等法界性种子。即是如来一切智地之所生长。如世间种种草木种种。随其性分各各差别。皆依大地而得生长。根茎枝叶种种不同。增长大小性分各异。然皆是大地之性犹地而生。虽毕竟皆归于地。但因缘合故而有生长。然实无有自性无生无起也。若众生既蒙安立如是种子。即是同于如来之位。由此种子从法界性生。能生法界故。名法界生种子。法界生者。即是如来自性身也。摽帜者。如世间种子各各差别。若小草种子有智观之虽未成长。然已知彼性分大小所极之势也。若见众生行如是如是因位种子皆亦如是。然今种子。乃是法界性之种子。当知彼性必定。能生如来平等法智身。是故名为摽帜也。又此漫荼罗一一分位各有种子。用摽记彼差别法界之门。当知一一入于阿字。见于内证之摽。即知如来内证之德。故名摽记也。随彼四重分位。从位出者。即是佛之摽帜。或从菩萨分位而出。或从二乘分位而出。或从天龙八部分位而出。当知阶降差别各各表知。种子字不同也。时佛告于秘密主已。金刚手白佛言。愿乐欲闻者。欲为普利一切众生故。流传演布。普为一切未来众生。亦为利益诸大众会故。请佛演说也。上来虽说漫荼罗法。尚未说色及种子秘要之藏。故一心听愿佛演说也。次佛告意者。凡阿阇梨欲建立大悲胎藏建立弟子时。当先住于瑜伽而观自身。从脐以下当作金刚轮。其色黄而坚。次从脐以上至心。当作水轮其色白。次从心以上至咽。当作火轮其色赤。次从咽以上至顶。当作风轮其色黑。复次地轮正方。水轮圆。火轮三角。风轮半月形。最上虚空作一点。其种种色。在于顶十字缝上置也。○【图】△○□此是轮形。正与身分相称也。此五位者。即是前说五字。方中置阿字。圆中置于嚩字。三角中置于啰字。半月中置于唅字。点中置缺字。当更捡前卷中也。师既自观其身次第如是。方色加持自身并观置种子。种子字已。次观坛地。即翻倒置之。最上作金刚轮。金刚轮下作于水轮。水轮下作火轮。火轮下作风轮。风轮下即是虚空轮也。所以者何。以一切世界皆是五轮之所依持。世界成时先从空中而起风。风上起火。火上起水。水上起地。即是漫荼罗安立次第也。坏时。地轮最先坏。乃至但有空在。即是师自加持次第也(更问之)今行人修道亦与此相类。最初发信心。次菩提之心。次乃至大空也(更问)其阿阇梨既如是加持已。即当安置诸尊。如其位次。一一以瑜伽观之。如其方色形相。于其心上置于圆明。圆明中有种子字。一一令明了无障。能如是作者。即是法界胎藏漫荼罗分位。为能令一切如来同共加持。一切尊等皆悉集会。共加持行人建立弟子。毕竟。不退正等菩提。不然虚费功力而无益也。又此瑜伽之座。其黄金刚方轮。即是金刚之座也。方是息灾。圆是增益。三角是伏降。半月是摄召。点是成办一切事。此虚空轮但用心念作之。不以形相故也。世界坏时。亦先从风轮坏地。而生于火。火竟次风。更问之。如是作五轮。当知上下皆有虚空轮也。以从空轮而生于风火水地。又从地轮渐上乃至于空。故上下有空也。作漫荼罗时。师应自观其身及地。又观所度弟子。亦当如是而安立之准于师法。若不如是不名如法也。时金刚手毗卢遮那。如来身。语意地升法界平等。观者犹此菩萨能知。如来身口意密故。名秘密主也。如来意密之法。唯佛与佛乃能究了。如意者。当知是身口亦如是。今此菩萨亦能知之。当知是位同大觉。为欲度众生故。示为菩萨而相起发也。此中身密者。即是诸印。如四重大漫荼罗一一本尊各有密印。若观此身印。即知此尊所表秘密之德。随类上中下差别有无量种也。语密者即是诸尊所有真言。闻此真言。即知此尊内证之德也。意密者即是本尊瑜伽之观。亦随四重方位各各不同。与此相应即入如来意秘密之藏也。此中身语意密。上从佛菩萨位。及二乘诸天八部无量差别。广而论之。乃至十世界尘数各各不同。略而言之。如此经中所表之位。谓皆表如来身口意秘密之德。若能如实了知。即同于秘密主也。今秘密主菩萨。住于法界平等观。为念未来众生。普令一切裂大疑网。故即于佛前而说大真言王。如文可知也。真言曰

南谟三曼多佛陀喃(归命普遍诸佛也)阿娑摩补多(无尽)达摩驮都(法界)竭帝竭多(超越无尽法界。超越者即是叹于如来秘密身口意之德也)萨嚩他(谓于一切十方三世一切时一切方所。超越无尽法界而能普门利益一切也)暗欠暗恶

此四字即是四轮也。第一字为地。金刚轮第二字水轮。第三字火轮。第四字风轮也。暗此字本体是金刚界体。兼有长声为行。行即火轮。上有点即空轮。以为庄严也。次欠水轮者。佉是空义。亦有长声是行。有点为空。即大空也。次暗字为火者。梵音阿竭喃是火也。恶是涅槃性。黑即风也。复次虚空无色。而能含受一切色像。今此佉字有行有点。即是谓一切色像。夫大空者。亦如虚空具一切法色像也此空即是成办一切事。是故欠字得作水用(更问)糁索(地)唅鹤(风)蓝[口*洛](火)鑁嚩(水)如上阿字有四字。谓长声上有点。及傍二点。短声亦有上点及傍点。二字为四。今此娑等当知亦尔。皆有四字。今但举其短声。合为长声二字。在于短声之前。准上而说也　糁索唅鹤(此是也余效此)又总而论之。阿字是佛部。娑是字莲华部。嚩字是金刚部。风火遍三部用也(更问)如莲华部中。自有地水火风。若息灾即须金刚方轮。若增益即须水轮。降伏即须水轮等。随类用之。当知此阿娑诃啰嚩五门。即同上之五字轮。随一轮中自有四轮也。如金刚部嚩字自有四轮。随作息灾增益降伏。各随类用也。若读余真言。随其部类有此等字者。即知彼所应用处。各有所应最为宗辖也。此一段未明了更问之。更有三道真言

【◇】(此身真言也)【◇】(此语真言也)【◇】(此意真言也)

此三道真言。即摄如来身语意平等法门。然此三真言。若着娑诃字亦得。若不着亦得。行者得意时。自看方便也。又复此真言。由最胜故。号之为王。如上说。虽各有四字。然此中相含。但名为十二字真言王也。此中四种轮。各随彼地水火风轮。而加持阿阇梨身。即得自在之用。其身口意真言亦合。加持自身口意业也。此事未明了(更问之。又云前是布字法。今此中用别计合是随五种事相应字。即摄彼中之用更问也)时金刚手如是说大真言王竟。时一切如来十方世界住。舒右手摩执金刚菩萨顶而叹言。善哉善哉善男子。佛子汝已毗卢遮那身语意地越。遍一切真言道平等住。为欲作诸菩萨明故。说此真言王者。今此中摩顶。非是十方佛舒手就此土摩其顶也。然此秘密主。当于佛前说此真言王时。即以真言王故。普于十方一切世界一一如来前。以平等遍满声一时而说。是故一切如来。各各申手而摩其顶也。越者超入之义也。如毗卢遮那于阿迦尼吒天坐于道场。以此真言王故。得身口意毕竟平等自在之用。汝今亦得超入如是身口意平等法之地。等于毗卢遮那。即是一切如来叹其真实德也。言汝已得如是平等之地。为欲普门利益一切众生故。为欲照明修真言行菩萨除其暗冥。是故说此真言王也。真言王能裂一切法界疑网。疑即是暗。能断一切疑惑。即是为作照明也。何以故。此毗卢遮那世尊应正等觉。坐菩提座。观十二字真言。四魔降伏。此法界现生三处流出天魔降者。谓大日如来坐道场时。平等观于法界。而说此十二句真言王。即以此力。能降四魔除其罪垢也。然四种魔中。三魔无色。是佛于阿迦尼吒天时。已降伏之。唯天魔有相。为欲令世界中知自在力故。复于此土而现伏天魔也。三处者。谓如上所说佛身上分出一切诸如来。中分从心至脐。出一切菩萨。下分从脐至足。出一切八部天神等。皆从如来平等三业。普门示现示大漫荼罗胎藏庄严之位。即是本尊真言及印也。当知佛从于内证之德。现如是事时。即于尔时。普伏四魔无有遗余。今阿阇梨欲造漫荼罗时。亦须想于自身一同毗卢遮那。即得自在之力。亦同彼佛能伏四魔也。次世尊身语意平等。得量同虚空。得如是身语意。获如是智。一切法得自在者。谓佛坐于金刚道场。才念此三道真言。谓如所说身口意三真言也。当如是念时。即得身口意平等之地。身及语意皆是法界之体。无有边际由如虚空。即以如是之力而伏四魔也。前所云三道者。有一释云。此三道真言。身口意自在平等之力。即是从佛出也。由此身口意三道真言故。如来得超入三平等地。随上中下类。普门示现种种本尊之身种种真言种种印法。等同虚空无有其分限。普周法界而度群生。究竟皆令同得超入如是三平等地也。身具无量功德。犹如虚空不可知其限量。语意亦尔。由观此真言故。得如是功德同于如来也。由三业无尽故。若应以身度人。即普现种种色身。若应以语度人。即普门示现种种语言。随宜导示令得入于佛之知见。若应以意度人。亦如是种种感通不可穷尽。非直身语意无有限量。具足一切功德由如虚空。当知智慧亦得如是无有限量犹如虚空也。若得如是无碍妙智。即是于一切法中。而得自在同于世尊也。所云自在者。谓于一切不自在事也。一切众生之类。由未究竟清净法界故。皆为业烦恼之所焚笼。系属生死。不能得自在之力。今如来于彼生死大海之中。以种种法门宣示如来深密之法要。为一大事因缘故。种种方便而成就之。皆令到于一切智地。即是于一切法中得自在义也。以证如是法。于是法自在。以自在故。即能无碍演说曲成众机也。如来所以得如是自在之用。皆由观此十二字轮法门。当知此十二字法门。即是法界之体性也。时十方佛。见金刚手说此真言。同于古佛之道。我等一切如来。亦由观此十二字门。而成究极妙身。未来诸世尊。亦复当如是。是故大欢喜。而摩菩萨顶而告之言。一切诸佛以于法自在故。为一大事因缘故。以身口意平等而说此法门。汝今亦复能说之。即是亦证此法同于如来也。然金刚藏。虽未即究竟一切种智。而同于妙觉世尊。但以十方诸佛神力共所加故。亦于大会中。亦如如来所证同等。若离神力加持。即亦未得究竟与如来等也。故善男子。毗卢遮那身语意平等证。一切佛如是知者。知是觉之别名。由知诸如来普门无尽之行。证于如来三种平等。谓知如来身密之藏。亦知语意微密之藏也。若证知此法者。即是同于如来也。如是叹印竟。复令更请如来。所以者何。如是深密之藏。唯佛与佛乃能究了。故一切菩萨。莫有能发问者。今十方佛。同以神力加金刚手。为利益一切众生故。今乘诸佛神力而问大日如来也。此中问何事。意为先所说之事所有深密之义。尚未周备故(更问其枢要也)一切智成者。即是大日如来。薄伽梵义如六义中说。前亦已解。毗卢遮那者。如日出于世能除暗冥。能成就一切众生所有事业。大地所生之类无不蒙益。此实相自然大慧之日。亦复如是。若有众生了知自证如猛风吹云日月出现。亦有如是功力。普于法界中而作大利。如日光而照世间也。主者。以于诸法得自在。故名为主。今诸佛。令金刚手。问此大日如来真言行句秘密之事也。殊胜说自教则广者。由于一字法门达一切法。证得十方三世如来平等身口意。不可穷尽。故名为胜也。教则者。即是法则之别名。法是轨则之义也。以是我往昔发菩提。无上菩提宣说我一切法涅槃至。现世界诸佛世尊证知者。言我等往昔行菩萨道时。亦由如是真言门故。成自然智。复为一切众生如是演说。咸令得至大涅槃也。我今此语缘起甚深。一切有心者尚不能发问。何况能信解。唯有十方一切如来。同至此法。可以为证。终不虚也。汝今已得我等所行之迹故。宜更问如来也。时执金刚具德者。犹手所持如来智印。即是具足一切诸佛种种功德。皆同一味。所谓如来解脱之味。以彼智印同于如来故。言具德者也。时彼菩萨。由诸如来共所加持。以大欢喜。即得深知如来之语。亦知如来之心。先所不逮而未能问者。今皆自在能问如来。无有疑难也。今欲问如来。先叹法界之德。而说偈言。是法无尽。亦无自性者。尽谓有始有终有生有灭。以有生灭故。即是有起尽之法。而今平等法界之性。离如是过。无有始终也。无生灭故。即是不可尽义也。无尽者即是无相之别名。由无尽故。一切诸法皆无自性。无有动摇无有变易亦无住处也。阿赖耶。是房义是盛受义。今平等法界中。无有如是受藏之相。故无住处也。若一切法皆无自性。即是无作。无作故无有生灭果报等。本来寂然常自寂灭之相。即同不思议解脱也。诸佛同位者。如此甚深寂灭之法。一切名言之所不及。更无可以为喻者。唯是佛同所证知。可以为喻。故言同于正觉也。然一切法。若但究竟无生无作也。言究竟者。即是无有诸乘分别差降一切圣人等位。便堕断灭中证于实证。不能利益一切故。次复言。方便佛等。悲愿转无相教开发。觉悟如是相。由具方便故。能满一切所愿。此方便者即是大悲愿也。由此大悲愿故能转也(更问)于此无相法中。无人能说无可表示。而能令一切得之也。亦自证得。当知是即大方便力也。此法无人能教授者。不由他悟而得证之。即是自觉无师之智自然成佛道。于道场现寂。觉如是法之实相也。此皆是偈语。后当饰之耳。复次若言法界无尽无终始者。即是于断灭。不能为众生作诸利益。何以故。已于生死作分限故。然是尘劳之俦。是如来种。若一切无生无性亦无住处。何能普应世间。作诸佛事耶。然诸菩萨有二事故。不堕断灭中。谓大悲及方便。由有此故。能自开发也。之中云开发者。谓菩提心自然开发也。若此言说表示。因他教悟。而能得如是自然无师之慧者。无有是处。所以者何。但因行者如实自觉。如实自观无尽法界故。得如是实相之慧。非由他悟也。经意云。法相如是。故云如是相也。既得如是实相之法。即以此法大悲方便。而为众生开示演说。然实不由他悟不从他传得也。如盲人问乳色何似。乃至闻乳色如雪便生冷想。又闻如鹤便生动想。乃至以种种喻方便表示。终不能解。徒增心妄计而已。何以故。由彼自无明目故。第一义谛亦尔。若不如实自了知者。设他种种开导。终无得理也。若人自不开发如是内证之法。而为人说欲令他悟。亦无有是处。何以故。如有无足之人。呼召众人作如是言。我当为汝而登妙高山上。当知此人。必为智者之所轻笑也。何以故。若自无足者。尚不能自登如是妙高山王少分高处。况能为一切而登彼顶耶。又如有人自未能渡大海波浪。而谓他言。我当渡汝令达彼岸。当知亦是无有得理也。行人亦如是。若自未觉无师之慧。而欲令他闻法得悟。必无此理也。时金刚主以此。偈叹如来已。次说优陀那偈而以问佛。乌陀那是总摄义也。以一偈之义。而摄无尽法界离相之法无量法义。故言摄也。叹说偈已。念彼未来世众生。修真言行者。于此大悲藏生漫荼罗有所阙故。不得疾成无上菩提故。次第问佛秘要方便也。断一切疑者。若不能普断众生种种疑网。则不名一切智人。以于一切法中自离疑网。方能断他疑网也。今佛既自断一切疑网。是故我今请问。愿为断疑也。离热恼者。言永断三毒根也。今为一切众生故。请问导师。以于一切法中。而能引导令至佛慧故。名大导师也

大毗卢遮那成佛经疏卷第十四大毗卢遮那成佛经疏卷第十五

        沙门一行阿阇梨记

    秘密漫荼罗品第十一之余

复次即以偈颂次第问佛。今次列之。未结偈句也。漫荼罗何者先作(谓漫荼罗有多种事。当先作何者也。谓先作何事)阿阇梨有几种(亦说之也)弟子复有几种(大牟尼亦说)云何知地势。问地好恶(谓好地取地上中下成就等)云何简择地。既择已云何作净(唯有三问更问)作净已。云何安住(虽作净了。恐复为障者所恼。故问云何而得安住也。)唯有三问更问云何为弟子作净。愿佛说(前问有几种弟子。今既得弟子已问先为何事也)净已之相复云何(此中问师问地问弟子。三事三句问也)问用何护。地作护复云何(亦问师自作护及护地护弟子有三问)加持地复云何。结护持等有多义。亦问三事云何初作用(谓持地护净竟缘坛所应作事。此中所作事有二种。外所作事谓缘造坛众事内所作事。谓师自观其身如大日如来等种种瑜伽之法也)用何真言等法也。为先作护为先净除。即问前事先后也。此二事是作用。线为几种。量地复云何(谓用线量地。并合线)用线作界分也。供养复有几种。云何华香等(此中更有涂香灯等及宝网宝楼树等种种献供之物任准例而作所以言等。等者多声也)问献香花有何方法。花合奉献谁(谓花有若干。所应献之尊亦有差别也。献佛用何花。菩萨天等用何也)香等亦然(准法而问)献食等(食有上中下差别也)护摩云何作问献佛及护摩有何次第列。法则即是次第。此是名通也。云何奉诸尊座(佛菩萨八部等座。合坐何物云何献也)法教。法则方法次第轨仪皆得。显形色等(显谓诸尊青黄赤白等。形谓坐立大小之事。色相貌也。谓喜笑忿怒寂静住之类)此三问也愿次第说。不与法则同诸尊印及以自座(谓自常念诵之座也。谓茅席等。愿导师说也)印复从何处生。说此印复作何用(如世作印。为王等令他信用不疑真伪故。今如来印复云何耶)其印名号复云何。得故名为印(欲得知也)灌顶有几种(欲得知解也)三昧耶有几种。持诵者剂几时(准有三问)持诵者勤修真言门。几日得成菩萨道。一切智者愿说也。几时应见谛(谓于真言门得如实知见也。合义得时也)悉地有几种(欲得解)几时悉地生。及说悉地时(准有三问)云何升太虚空。云何身秘密(准有二问)云何不舍此身。而得成天仙身。成就已种种变化云何生(谓一切事随念皆得成。从何处得生此耶。从自心耶从他耶)种种诸变化谁生。彼复从何得生也。日月火方执曜时分等诸不祥云何除(日月为变成火灾或方所有怪。宿是廿八宿星是众星)及生死受苦。彼起者云何悉令除灭也。不有是除义。云何行者常与诸佛同会一处。护摩有几种。此中问护摩时须用几种火。欲得知也。火中增威是增益法也。复有几。此增威。如花等一切处用也。尊异类诸尊性(谓佛菩萨八部形及性类)须识本性忿寂喜等。愿导师说。无余世界及与出世间果。是有几其数如何(出世谓佛菩萨。世间谓八部等得成就时量及果及数皆云何有六问也)复问世间出世三昧云何也。俱有殊胜定。并前为八。作业成就在。何处问成就受果在何方所。其未成者亦如是。问不成就。复云何时能离业生故得解脱。时金刚藏乘十方佛威神。说偈问佛故。彼真言行菩萨有所阙少。法要方便未周备故答。时一切智毗卢遮那世尊离众恼者。闻彼所问秘要之事。而叹之言善哉善哉勤勇大心。是一切时中大也。大心大愿大行等。秘密漫荼罗配尊位决者。谓决定安列诸圣者坐位等也。秘密者。即是如来秘奥之藏。久默斯要如优昙华。时乃说之苟非其人则不虚授。不同显露常教也。漫荼罗。是具种种德义。即是如来秘密之德。如是秘密之德。如莲华开敷而自庄严。配尊位决者。是决择义也。如是莲花秘密之藏。分别种种分位。所应作事皆决择之也。决谓定说也。大悲根原。从大悲根本生发。大乘无上诸佛最秘者。谓此漫荼罗。即是无上大乘根原也。谓此菩提之心。以大悲而为根本。亦如胎藏。故言根本也。乘者。谓真言行菩萨事。由是具足方便故。行大直道。一向无留难得至于真实。犹如乘调良之乘行大直道至于大城。此即是诸佛最上秘要之法。若广说者。尽未来劫亦不可尽。今但以方便而略说之。今于一言亦具一切义味。故名略说也。是佛密事。汝能问之我当略说也。已先叹法许为略说。次即随彼所问次第答之也。佛告金刚手。谛听大力漫荼罗十二支句生明王大力。漫荼罗初业先答也。先当作之者。此即如上所说十二支句生(从十二支持句生此大力明生)十二句法界体。彼应最初作明王也。由此明王。悉摄一切世出世间所有。初作坛。应先住彼明王三昧。王者只是大日也。此谓心中置十二字中最初字。取最初字以持身也。真言悉于中摄尽故。欲作漫荼罗。要须先诵也谓将造漫荼罗时。要须先诵。然后即住瑜伽。瑜伽即是此明王应理之行也。既住瑜伽。当正观察。今此所作宜以何事。谓随五部。如上所说五字差别之用。或方或圆三角半月等类。于上中下坛宜作何用。弟子根性云何。如是等种种皆知方可作也。然此中于真言王中。分别种种差别之事。犹未明了。更问之。复次先知即有二种。由是见谛之师。能于如是真言王中。见一切根缘通达无障碍。若未见谛师。即须依教及于师所传。所传旨趣而观察之。亦其次也。既观察知已。随所应作事而为作之。故先须此真言王也。以本三昧持身已先知识瑜伽道。然后随意作诸事业也。然以秘释之。此十二真言王。即是金刚三昧。必菩萨坐道场入于金刚界故。则蒙十方诸佛同时灌顶所共加持。得入佛位。入佛位者。即是成就大悲藏生大漫荼罗究竟义也。金刚手犹入此真言王故。亦于此经中。得蒙十方诸佛同所加持。今更决择大悲之藏。若不如是。何能获得诸佛灌顶同如来法王之位耶。然造漫荼罗法。先须阿阇梨。故次答也。应知师有二种。凡师位者。须具解真言及印本尊之相。于中一一了达无疑。了知上中下法差别之相。然彼复有二种分。分者为二也。一者解深秘。二者通略。所谓深者。能了知深广也。谓得真言行中三昧之行善知理趣。广解大乘堪受付嘱。此中堪受付嘱者谓善知时宜了解根性。堪授者。则为不请之友。令其不失大事因缘。未堪者。即将护其意。更于余深法中示教利喜。由此名为堪委付也。当知即是佛之长子。由见谛故见法。谓见现世果报也故不取诸法相。离于心量分别之境。故名离也。谓离现世利直求佛道也。当知此师。即是蒙十方佛现前。各申右手而摩其顶。以法灌顶而付法藏也。第二师者。但得现法中利也。世间成就之益。痴句中加有缘念也。为彼而造坛也。然亦具解造漫荼罗等种种方便。无有错谬。蒙师灌顶以下。是重说深行师也。灌顶。得阿阇梨位。亦名佛所印可也。由彼于漫荼罗中亲对诸尊。而受灌顶师位故。印可也。当知此中蒙佛灌顶者。为深秘之师。蒙世间人师之所授者。为显略阿阇梨也。金刚藏所问。皆是缘漫荼罗所须。佛亦次第以偈答之。此偈今未断句。后当饰文也。佛答师以次答弟子之相。所以然者。虽但有师而无弟子。则阙传法之缘。令佛种不得相续故。次分别弟子之相有其四种也。一者时念诵弟子。二者非时。三者时非时俱。四者时非时俱非。此谓四也。所谓时者。如弟子求阿阇梨而请真言行法。师若是见谛者。自当照彼境缘。知其堪任于事。授与其行法令作念诵。限若干时当得成就。更作成就方便。若世间师者。虽不现鉴前机。但依教而作。令弟子念诵。祈境界交感之相。师亦自念诵。若相应者。弟子得境界许受法。时师亦自当知之。既得相应授其法行。亦令如上念诵。此亦具有方轨也(更问)非时者。亦如前法令修真言之行。当于某时而得合成就也。如时法验不成。须加作加行。故名非时也。时非时俱者。虽如上受师言教。然未得如法依行。未至成就之时。此不在时亦不在非时。如在学地。故名俱句也。俱非者。但发心归依。然都未有次第。师虽已摄取之。然待时待缘。有所未具未得与彼真言法要。故名俱非也。复次具足诸相者。相有二种。一者外相。谓支分等无有阙减。如前当广说之。二内教。一一能如法修行。如佛教敕不敢违逆。如是等是内相也(佛敕者当知即是师教以师顺佛教作故更问也)然此四人。皆在修学之地未满足也。既有弟子最初知地相。地教当次说也。所谓心地也。知地相应造漫荼罗。造漫荼罗先须择地。故次明择地也。所谓地者。即是菩提之心。先净此心。即是先作净。先已说。谓八叶等心如前作之也。先净其地也。如前所说净菩提心方便。谓观八叶莲华。于华台上而观阿字。乃至常顶而置于暗字。眼亦安蓝字。而观其心。其咽勿令太低大直之类。此等皆是净其心地之方便也。既净心地。次安置啰字于其两目而以观之。即是择得心地。而更除遣诸秽也。此方便前已具说。当如前作之耳也。言若离过心地得无畏者。能以净菩提心离诸相。是则能离诸过。谓离烦恼随烦恼等见爱之惑故。名离诸过。以离如是烦恼险畏恶道种种不安稳故。而得安乐之性。故言无畏也。当得清净时离一切过者也。当得一切净者。由离诸过心无所畏故。能究竟净菩提心也。若已至如是。坚固住于净地。即得见三菩提。知谓如是知也。如是知即见佛处也。当坚住其中。谓已得离一切过。不为杂染分别所污。当守之不动勿令退失。必定能至无上菩提也。但见如是净菩提心。究竟无余。即是成一切智智也。异此非能净地。若分别住非净地者。若异于此者。非能净其地也。言阿阇梨若不如是。而自净其大悲胎藏漫荼罗地。则非名净择其地也。以不能离于妄想分别幻故。恒于诸过之中。不能得免怖畏衰恼。云何得名善净漫荼罗地耶。是故经云。若持诵者住在分别。若作净地者非净。秘密主离菩提心故。二种师皆须住菩提心也。分别之中则非净地也。如前造坛中说。剂一肘以来。治法虽治地亦未成。仍须少时住菩提心离此不成也。穿去恶土择去沙砾毛发瓦石之类。若微细之恶无由能一一遍简。又复一肘之内虽净。然过一肘设有种种秽物。是亦不能择之。云何令此漫荼罗而得究竟清净。是故当知。若能净此菩提之心。舍离一切分别戏论之粪。而净其自觉之地。当知乃名善修其地也。若人师如文取解。但依前言次第法用随事而作。当知此人在愚夫地。不能了达秘密之用也。当知作如是解。即非一切智人之所说也。所以然者。若不能净此心地。犹有分别妄想。则未能舍离苦因。是故非是等正觉者之所说也。内外由心。心净故地净。是故应舍分别净除一切地。缘地事总答了。既净菩提心竟。当以大悲胎藏而长养之恐所说诸坛阙法。我次第广说也(此次第谓依法也)彼不知先所应作事。愚痴故不解(但问果上中下不知住心地也)若不住心而求世间无上之佛。无有是处也。亦非名为一切智也。乃至不能舍是等分别之苦因也。恐其退殁故须结护。故经次云。以不动尊而守护之即是不动明王也。当取不动真言之心。为净菩提心。为者是所作事也。劝弟子如是发心。即是住菩提心也。当护弟子谓不动也。即是诃字门也。诃是因义。言此净菩提心。即是一切。先住菩提心。师弟俱住之。然后以此二尊护之也。智智之因也。傍有长阿是行。上有圆点是证是大空义。以此妙因而起正行。行等于空。用此三法而护其心。令其究竟不可移夺也。若不用不动护者。用三世明王亦得。世谓三毒。犹彼降伏三毒。而于世间得大自在。故名三世胜也。此亦有方便更问。若弟子能成此事者。非痴所摄。痴是执着也。有执着则不能住离痴。离痴即是不动也。有所观有所得皆是痴也。谓不为妄执之所动摇也。必定成于无上菩提。清净无垢同于虚空。虚空无能动摇。广大无际。而能含容一切色像。当知一切智心亦复如是也。次又加持地者谓阿字门。当用阿字而加持之。此是诸佛之教也。一切如来昔因此门而成正觉。以此护心。或加暗。于顶及加啰于眼等。是坚固菩提心。是故得成自在之业。若异此者不得心自在也。故云非余。非余者。言一切如来成佛。无有异路唯此一门也。初加持地依于佛教。佛谓阿字也。第二心自在。谓安点也。点即是三昧。定慧等故一切自在也。更不应异此教也。初依佛教发心。即阿字后即成佛等于佛。即是阿字也。菩提心依佛而起。是故一切分别除。虽未成佛即是无缘之种子也。前既问答加持地了。既加持地。次须用綖而定漫荼罗位。綖者。梵音名为苏(去)呾缆。是连持众德令其不散。故名綖也。线有四种。谓白黄赤黑。念此念谓应念持也。更加一种谓虚空色也。虚空能含一切色像。即是具一切色。若但依空色。即是浅青之色。如草木叶色也。白是信义。黄是精进。赤是念。黑是走。定色同于涅槃色也。慧者即是大空。大空具一切相而无有相。故为一切色也。凡合线时。若一一依法者。当别造漫荼罗。安置宝瓶香花涂香灯等及诸饮食。作种种供养(更问方法)然后令童女合之。当先为受八戒着新净衣。香水澡浴使内外清净。坐于坛中而合之。合线之法。先预作细丝令极均调。大小缓急皆令得所。又不得中间断续连接之也。又合时以帛掩口也。每一色丝来去襵牒使成九丝。然后合为一缕。其丝但有一头而屈襵之。中间不得接。一缕一色。凡五色合为一绳也。若合绳缓急粗细不调。又不尽心作之。明则生障法。损师亦损弟子。或令其发狂乱等。不可不慎也。私谓童女是三昧也。由三昧极均等调停。得成五力五根。由此根力即能连持众行也(更问)虚空中等持者。此有二种。若是深行阿阇梨。欲作坛时。既净菩提心地竟。于瑜伽中为度弟子故。正观胎藏大漫荼罗加持之位。一切分位宛然明白了也。如空中等持。等是普遍也。持谓应如是作也。作谓知次也。先定空也。尊位均等也。第二以线置漫荼罗地。如对目前。然为度人顺世谛故。以方位加于坛地。然后于上。用五色线像等而定方位也。若是深行阿阇梨者。亦须先用此线而定方位。定方位竟。当一一用心而布置之。亦令所有方位如对目前。或可用纸笔抄之。临时案用。不得临事疑误也。此云空中等者。即是如上所说。先共弟子对立。引其线而定方位。且勿令着地。先于空中对引。各令当心。如其次第令得周匝。若未有具法弟子未堪共造坛者。亦可置橛于弟子处而作也。既如是定竟。即运心布定位次。然后得絣绳画一一。若是瑜伽阿阇梨者。亦于此中而作方位。见诸佛菩萨天神等宛然位定。方顺世间法亦絣线案位。案其形色而表出之。当知此为最上之位也。一切诸佛智者诸佛子。叹菩萨具智慧也。一切诸佛子诸智者。莲华悦意胜吉祥世称。谓世所叹以为吉祥也者。此次答座位表像也。如世人以莲华为吉祥清净能悦可众心。今秘藏中亦以大悲胎藏妙法莲华。为最深秘吉祥。一切加持法门之身坐此华台也。然世间莲。亦有无量差降。所谓大小开合色相浅深各各不同。如是心地花台亦有权实开合等异也。故云智者当知也。若是佛。谓当作八叶芬陀利。白莲花也。其花令开敷四布。若是菩萨。亦作此花坐而令花半敷。勿令极开也(其花或白或黄或作宝莲华皆得但赤色者是世间花在下也)若缘觉声闻。当坐于花台之上。或坐俱勿头花叶上。浅识博以为一边之智也。此是青莲花也。此但是青色之莲。然更别有青莲花。坐芰荷青莲叶也。从莲花所生叶也。种非此类也。若净居诸天乃至初禅梵天等。世间立号为梵等。皆坐赤莲花中。念谓忆持不妄也。其色纯赤。世称为坐王也。若欲界天及地居等。各随其位而用表之。如帝释像即画须弥山王。山神坐山上。水神坐水上。树神坐树上。城神坐城上。如是甚多可以意得耳。以下诸天分地为坐。谓欲界天等或坐草或干叶等也。念谓思念也。复次三藏说。西方莲花有多种一者钵头摩(复有二种一者赤色即此间莲华也二者白色今此间有白莲是也。非芬陀利)优钵罗(亦有赤白二色。又有不赤不白者。形似泥卢钵罗花也)俱勿头(有赤及青二种。又云俱勿头是莲花青色者)泥卢钵罗(此华从牛粪种生极香。是文殊所执者。目如青莲亦是此也。更有苏健他迦花。亦相似而小花)分荼利迦(花可有百叶。叶叶相承圆整可爱。最外叶极白渐向内色渐微黄。乃至最在内者与萼色相近也。此花极香也。昔琉璃王害释女时。大迦叶于阿耨达池。取此花裹八功德水洒之。诸女身心得安乐命终生天。因是投花于池遂成种。至今犹有之。花大可爱。径一尺余尤可爱也。此法花所引申者是。是漫荼罗八叶者也)

次答供养义。然此中答。或不依问次。然皆依所问义。于理不失也可智耳。当知供养略有四种。一是供养香花等(及涂香灯等乃至饮食。此是世间供养也但以物献也)。二者合掌(谓礼敬也此是印也)。三慈悲。四运心。谓想香花满法界。运心已即用合掌印也。并慈悲三事皆运心也。然经中不言香花等。于义必当有之也。花手此是都牒合掌印也。此花从手生也　发生。奉一切支分生。印观菩提心者。花手发生。谓作印。作印已即运心供养也。此一切支分生印者。前已有真言。而云未有印也。当捡之。如是以印加持已。当念菩提心。想见此花从手出也。以此为供养也。各各一切。此运心也。诸佛及彼所生子等。殷勤以是无过花。美香光显法界为树王。想树遍法界生花供养佛也。供养以真言。加持胜妙。复多大云法界中生。从彼雨花诸佛前等者。谓从诸佛菩萨。乃至二乘八部。各各依彼本真言及印。用加持所供养物。而供养之也。行者供养香花时。当以真言如供养花即用花真言等也。心若不住定何由得然。故云三昧自在转也。及印加持。然后运心。此花香美无诸过恶。愿生胜妙复多犹如大云。从法界中生也。从彼而雨花。谓从法界生也。常遍诸佛前生种种光明。又以此花等遍周法界为一大树。如天意树无异。雨种种花云花香幡盖等及饮食物。无量无边不可穷尽。普遍一切如来之前。种种供养令一一周遍。如是运心。即以真言加持之。谓一一尊所供养。各以本尊真言及印加持也。次卑于此者。谓八部等。亦有随其本类用真言及印也。然此诸尊。又卑此诸天神。今次说诸天如本瑜伽。谓各各相应。谓与本尊相应也。如忿怒用赤等。或经中有真言及印。或有阙无者。别有一普通吉祥之印。如花者。涂香等亦如理相应相念也。当以空水二指头相捻。余三指皆舒散之。用此印加持诸物。乃至坛中一切供养之具。悉用加之。皆得成也。设本尊自有本印。临时志者。亦用普通印加之。亦得也。其香花等真言。即是前所说香花灯等真言。各随类也。如般若经所说。若欲以一花。普供养一切诸佛者。当修是般若波罗蜜即是。此中但运心以一花香。以加持及三昧故。即普能供养一切贤圣遍于法界。令此善根不可穷尽是也。若不作普通吉祥印者。更有金刚拳印或莲华印及观音印。但右手作也。唯地居天合左手作。然恐左手有所执作等。使右手作印加物亦得也。然供养时。先用印加已。即当捧之标心奉献。方置诸尊之所。若是涂香者。或用涂彼尊身香。亦随所应庄严处置之。或置其前也。其捧花等时。亦言高下等之别。若是佛。当高齐其身头顶。菩萨在心已上。二乘在脐上。净佛菩萨持在心。世天当脐。此定也。地居等天在脐下已。次而下。结印已引向空中献佛也。乃至地居等令转下也。如上有四等诸尊从佛身出。今献花高下亦准前。脐下以配当漫荼罗位也。然有二种师。若瑜伽成者。但用三昧心自在故。已得通达真言门故。随心所作便成。不必待于事法亦得成也。若第二世间师。必须依于事法。用真言及印加之。乃可成也。次答护摩义。应知护摩有二种。一内二外。所谓内外。分分即别也。护摩是烧义也。由护摩能烧除诸业。以一切众生。皆从业生由生转业。轮回无已。以业除故生亦得除。即是得解脱也。若能烧业者。名曰内护摩也。从于何处得解脱耶。谓从烦恼业苦而得解脱也。既离世间即生种子。所谓白净菩提心也。如世间之火。若烧物已但成灰烬。今则不尔。既烧一切烦恼。如劫烧火无有遗余。而亦即从此中得有牙生。所谓菩提牙也。此中能烧即是智也。如前所说观于啰◇字周匝火鬘。令想此周遍其身。其身又持刀及索。以此啰字门故。得尽诸业净除诸障。业障净已得生自净种子也。是故次观菩提之心。当知菩提心得生种子也。如此观时。当想嚩字遍于一切身分。于其毛孔中流出白色甘露。周遍十方以洒一切众生之身。以此因能当令种子渐次滋长。故名内护摩也。次释外护摩者。有其三种。一本尊。二真言。三印。一本尊者(本尊也。为供养故置之。随所宗之门而置之。或火中可有是漫荼罗位也。更问)。二真言者(炉。置火处也。此即真言也。火中有)。三印者(印也。即是阿阇梨坐处。自身即是印也)。当作外护摩时。令此三位正相当也。此三亦是净三业义。本三位。谓身炉本尊三位。各有三位本尊真言印也。净三业成三事也(谓息灾等也)。尊是意业。真言是口业。师身之印是身业。由此因缘。能净三业成三事。谓息灾增益降伏也。三业道者。道是会义。言与理同。同故会也。汝等所行是菩萨道。即是三道同归一致也。又三事观字各异。若作息灾观啰字。当上加点而作白色。增益想嚂字黄。降伏想暗字或黑或赤。如字者本尊及自身色。亦如是三事相应即成也。就中复有上中下差别。谓息灾为上。增益为中。降伏为下也。如是作者名外护摩。当知此内外护摩皆名殊胜。若不与此相应。徒作无益也。犹作外护摩故。能令引入内护摩中。然内外之理本无差别。为求世间成就者。作此分别令作外护摩耳。若异此作者。谓不依所说方轨。当知此人无所知解。唐捐其功无有果报也。由离于真言之智。随己无明之心而妄作之。终不能得世出世间悉地之果。故云不得果也。次答色及形类。然大略有三部。毗卢遮那是佛部。即是如来法界之身白色。次观世音是阿弥陀佛也。其身黄色。次金刚藏即是释迦牟尼。其身赤黄色(即杂色也)佛说诸真言及诸佛所说者。上言佛。是举佛如来部中诸真言。部谓从佛所生。乃至诸神。佛所许可皆是佛部也。下云诸佛者。直是诸佛所说。不通菩萨以下也。此二种皆具二种色。谓白黄也。诸部下言诸佛所说真言。谓毗卢遮那所说也。次第应当知。金刚手杂类。观自在诸真言白。随事分者。此但云应当知。以白黄和合也。谓不太黄太白也。杂色谓具五色也。谓随事分别而用之也。佛部一向是息灾用。白随事业分。观音纯白。然其部中。则随事业变转也。其色当白。莲华部一向是增益用。其色黄。金刚部一向是降伏用。其色杂也。亦随一部中自有三事分别。如佛部中。自有息灾增益降伏也。若息灾。即依本法而作白色。若佛部中作增益时。但依此法而作黄色。若佛部中降伏者。但依此法转作杂色即是也。如佛部者。当知莲华金刚类可解也。白事分者。谓随色类而分其事也。观自在诸真言者。此中诸声。即是举莲华部。以例佛及金刚部也。次说漫荼罗形。计合息灾在前。今随声便事便。增益在前也。诸增益事漫荼罗。方□(而黄色)息灾坛。圆○而中白色。降伏坛。三角△其中黑色。摄召坛。半月【图】其中杂色。摄召。谓杂取物呼召等也。经云四方普者。是举一例诸也。如中坛方。谓方则普皆方。为圆亦如是次第也。三角等亦然者。乃至外院皆方。若中圆者乃至外次第皆圆。护摩作炉亦尔。若坛方火坛亦方也。余皆例知耳。次明诸形像也。应以相貌为正义。亦可谓色像也。偈云色像初应知。初谓我今说也。色类然诸尊色类种种不同。大而言之略有二种。谓男及女。男是智慧故为首。女是三昧为次之也。或一切处随形色者。如此经中或复余经尊形。或随一处显形色。谓应物示形不定。故名不思议也。各各不同。然以类制之。若言作白色即是息灾用。黄即增益余可解也。见彼男女之殊及色貌。即知所用处矣。不思议智生者。如本尊合作白色。然须作增益事。随行者心观作黄色。即有增益之用。随心而转。然所作事皆实不虚。由不思议界智所得故然也。今谓法界之色。于一色中即是一切色。能观之智亦与境相应。故得如是自在而用也。为除无智故有种种智生。虽知无量知其实是一智。前云智是一切智也。以一智现一切智也。前问本尊形量大小。今次答之。然佛普门示现。皆为应赴群机。机既万差。当知垂应亦大小无定也。至诠一一本尊之形。莫不量同法界。无有边际及与始终。由智有浅深量有大小故。所见身各各差别。是故当知所观本尊。随行者心大小无有定量也(当明密迹经三密事)所云证智者。即是佛也。以无尽之智而证无尽之境。如函大盖亦大也。前问尊形量中。兼问坐及印。今亦答之。身既无有定量。当知座及印亦如是也。乃至心能广。座亦同彼量也。印亦如是。如其次第谓随其大小也。又次第者从佛。令本尊与座相称也。至天亦然。次答此印从何生者。佛言。如佛所生处。印亦如是从于彼生也。所以者何。一切如来。皆从佛性种子菩提心生。当知一切印。亦从菩提心生也。印从法界生。而印弟子。如王以印印之一切信受。今以一切法界生印印之。即法印也。即是大人相印也。次答此印作何用者。以此法界印印于弟子也。印是不可违越义。由自及他皆不违越故。谓始从菩提心乃至究极佛慧。于是中间不退不转。是故世间号之为菩提萨埵。由此印故。住菩提心更不退转。故名不违越也。此印即是印生死门开法界路。略而言之。此印量同法界。由以此法界之印印之。即令彼人已有法界之标帜。同法界普门之身。故名印于弟子也。以法界印为略。谓以一法印之也。若广不可量也。此即大人之标帜相也。前问灌顶几种。今次答之。佛子善听者。准梵本正语当具殷勤谛听。何以上来诸问不言善听。至此方说耶。然余法若不善听致有妄失。其过犹小。若灌顶不成。则不合闻真言及印等。此日不得作此过尤大。故殷勤戒之也。譬如世间刹利之种。谓欲绍其继嗣令王种不断故。为其嫡子而作灌顶。取四大海水。以四宝瓶盛之种种严饰。又严饰子身众物咸备。又饰大象。于象背上持瓶。令太子坐于坛中。所统毕集。于象牙上水令流注太子之顶。灌此水已。大声三唱。汝等当知太子已受位竟。自今以后所有教敕皆当奉行。今如来法王亦复如是。为令佛种不断故。以甘露法水而灌佛子之顶。令佛种求不断故。为顺世法故有此方便印持之法。从此以后一切圣众咸所敬仰。亦知是人毕竟不退于无上菩提定绍法王之位。诸有所作真言身印瑜伽等业。皆不敢违越也。然灌顶有三种。一者但以印法作之离诸作业。此是入秘密漫荼罗。谓有弟子诚心殷重。深乐真言行志求大乘。然资力乏少。若令一一具求众事反当于道有碍。如是之人师当深起慈心。观彼心行而摄引之。然但得为此人而作之。不得多为人作。何以故。恐彼资力能办者生怠慢心。而不尽心损众德本故。作时随力令办少供供养三宝。此第一最胜。谓本尊身语意三合为一。三俱净故以此印印之。此最胜也。师秘受其真言手印之类也(初但以手印二俱具法事三在三昧灌顶也)二者以作事业而灌顶者。即是师及弟子皆先作事业也。谓先令弟子七日以来诚心礼悔之类。师亦于七日以来。为其持诵秘求感应。及令办诸供养物香花之类。缘坛所须一一令作。然此之灌顶与前者不殊。但以有资力故。令尽其所有。于诸佛海会之中而作无尽供养。由此因缘。福施之果不可穷尽。故须劝彼令具作也。三者但以心而作灌顶。如是灌顶不择时不择方。谓向东设位或向南等皆得也。由此弟子已修真言之行。于秘密藏中有所堪任。令师心悦。此又最胜也。师弟子俱得瑜伽以心灌顶。犹如摩顶受记也。又能尽心承奉其师。于种种善事无有违越。以是因缘令尊欢喜。故为作心想灌顶。其灌顶法也。瑜伽阿阇梨先入净室而住三昧。如前所说以身四分。作四重漫荼罗位。亦如毗卢遮那所现之方位。一一无异也。如是作已。以秘密加持故。令彼弟子。先在外而待命者。自然而得金刚手威神加持引之令入。亦自然而解作印等一一如法。既入室已。以金刚手所加持故。现睹漫荼罗诸尊之位宛然现前。一一本尊尊形及印字等。亦悉明了。尔时行者复以加持力故。手中自然蒙授妙花。而以供养大众。随所堕本尊之处。其尊即起以妙音声。而安慰之为作摄授。尔时本尊取一一大会诸尊处甘露三昧之水。而为彼弟子现前灌顶。尔时阿阇梨但坐一处。而入三昧寂然不动。而能成就如是胜事也。令尊欢喜相应。谓承事本尊本尊欢喜。以行者现前而为灌顶。以遍数及行具作故也。承事念诵令尊欢喜。现前说法如所说而作之也。准前例之。如弟子能事师令欢喜。师为灌顶教授也

次答三昧耶有几种者。今世尊答略有五种也。三昧耶者如有人于众多国王大臣所尊重集会之处。而自发言作太要誓。我今如是之事永当不作。如是之事当依行之。以自对可信之人而发诚言。若有所违即得重罪。是故三昧耶者。即是不可违越义也。略而言之即是戒义也。此中五种者。第一但得遥见漫荼罗。谓如造漫荼罗时谓见具足漫荼罗也。忽有诸人善心随喜。欲求礼拜供养。尔时阿阇梨。听令引入于坛外。遥令礼拜以花香等。遥散道场而作供养。得见如是法会。故无量罪业皆得灭除。然未合授彼真言及印是第一也。第二见漫荼罗坐位。谓引彼入于坛中。礼拜供养投花散于本位。师告彼汝花堕某尊位上。为说本尊名号。并得入坛门内悉见诸位也。此人说名第二三昧耶也。若请真言及印。亦得随所应者授之。第三见漫荼罗及印位并作诸事者。谓阿阇梨从首至末。为此人而作漫荼罗。乃至诸尊及印等一一告示。又授真言手印。一一行法皆教授之。此是第三也。第四者已能依随修行真言门所有法则。言一一通解。具知缘坛所须方便众艺。堪在师位悦可师意。师即为作传教漫荼罗。告言汝自今已后。亦如我无异造漫荼罗。度诸弟子令法久住。佛种不断故。此第四也。第五即是秘密三昧耶。如教所说印坛配位皆见。若不经入此坛。秘密智不生。是故当于秘密坛中如法作灌顶。是名第五。智者应知也。若异此者不名三昧耶也。即前所说第三灌顶时所入也。若异此五事不名善作三昧耶也。然秘密漫荼罗复自有五种。第一谓于师所授得真言印法。依教修行与瑜伽相应。得于定中见诸尊大会。然未蒙引入(此例如第一人也)次第二人已蒙引入秘密坛中得巡礼供养。而未蒙圣尊现为灌顶等。第三既蒙引入大圣众中。从初至末一一秘密之行。皆蒙圣者方便告示如第三人也。四者以善修秘要之道。现蒙诸尊为作秘密传教三昧耶。即为如来所使行如来事也。第五已具前事又见己身。于大会中自作阿阇梨师。即是入地人也。此人才入三昧。即见一切佛会。乃至十世界微尘大会悉能集之。而于其中同彼尊位也。若观察于意善住者。告金刚也。觉其心不得于三处。真言者得菩萨名。谓以义得名也。由自有觉不着三处。谓自身所观法及成时。若着此三不名觉心。以于此三无所得名菩萨也。前说菩萨义依法相说。今此义得名也。金刚手前问剂几时得菩萨名者。今次答之。若观意心觉。善住三处不得持诵者。说名观。谓始从师处受瑜伽法。略有三事。谓心观本尊口有真言身有法印。汝当如是观之。既受法已如闻修行。得了了明彻犹如镜中而睹面像。是为观也。觉者觉了自心境界真实之法也。善住者即指金刚手。佛说法次号名而告之也。或可同彼修行之人。犹觉了自心故得无所住而住。故名善住也。既得如是与法相应。得见本尊无量境界广博严净不可思议。行者尔时即以无所得而为方便。以智慧观察。如是之法从内生耶。从外来耶。从内外合生耶。行者自身心即名为内。本尊境界是所对境名之为外。是二合缘名为中间。如是观察了知。此法种种不思议境。不从内出不从外来。亦非内外和合中间而有。当知本来清净。毕竟无所得无所生也(外境内心以此身心观照为中问)此三事悉除。即是本清净一相平等也。所以者何。以行者内心外境及心缘和合。正观察时。此三事和合。即有不思议观境现前。以三事和合从缘起故。当知即是无生无性不可得也。复次行者。身有秘印口有真言。心有本尊境界之观。以三事毕竟无生故。即是三轮清净一相平等也。由行者离于三执净于三轮而离四相。剂此以来即得菩萨名也(四相谓为我人众生受者如金刚经中分别)然行者作如此无生无性观时。心无所得不着内外之相。即是诸法究竟皆空都不可得。然则从发心来修行种种福业。及利众生所修万行。云何于此毕竟空中。而不堕于断灭也。然行者有方便力故。不堕如是过失也。所以者何。如行者初观时种种有相之境。即是从缘起法。以从缘起故。不自生不他生。不共不无因。是故常无生。若无生者。此因缘法即缘同于法性。湛然清净。具足一切不思议性起功德。随缘机起犹如镜像水月。有而不有不有而起。虽从缘生而不堕二边。是故虽毕竟空。而能成就种种功德。普利一切众生。大悲化物不堕实际。故经云。以方便故。而为众生作菩提之种。无缘观行智者。当知此仁者。即是成菩提也。无缘观即是中道。合同佛义。验之不思议观也。佛已离一切执。为度人故。种是栽种之种也。已成佛同无缘觉。得于本寂法中起方便利他。以方便利众生。以何方便。若住本寂即违本誓故。以方便为众生种菩提也。此因之利益别名。为度人故。回无缘作有缘之义也。仁者佛名越众生。谓过人也。仁者是寂根得胜也。前问云何名见谛。今次答言。本寂法无自性。彼诸安住于本寂法中。弥卢等心。彼诸道修行人也。知法本寂无性故。不动如须弥是名见谛也。名见谛者如上所云。先从师所授得真言观行方便。得与三昧相应明了现前。次即如实正观三事。皆无生无灭性不可得。由是因缘。即能现觉一切法从本以来常寂灭相。此中云彼诸法者。即是指前所观照之境。即于此中而了知本寂。住于自证之理也。已得安住如是法体。实智慧中疑悔永除。犹如须弥山王无有动摇。须弥卢即是不动摇义也。犹住此名齐此以名为见谛也。以此实如空者。实即如空。犹空也。无自性名实。实者即如空也。实者非妄语也。次云以是所见犹如佛(见实即同佛也)先佛亦如是见也。我亦如是见故云及也。实及空非妄语。并所见如佛也如是。先佛者是释见谛义也。夫见住者。即是安住实智慧中。故名实也。犹觉了无性空本性净故。当知诸法皆空。空谓离虚妄分别而住谛。俱是为实也。见此理者。即是见于古佛所见之道。解与诸佛玄同。往昔如来亦从此路去成正觉。既得如是自然之智。复当转受众生。今我所得亦与此无异。故名为实。实者即是无虚义也。前问诸得菩提心。彼悉地更无过上者。从此之外更有五种悉地也。次问云何名悉地。复有几种。今先答果。夫言成就悉地者。谓住菩提心也。此菩提心即是第十一地成就最正觉。如是悉地。诸地中最在其上。故

经云。彼悉地更无过上也。次答。入修行。是住信行地也。次升于地位。谓越世间五神通佛及缘觉等。悉地有几种者。谓此无上悉地以前。略有五种悉地。一者信。二者入地。三者五通。四者二乘。五者成佛。此是五种悉地也。初信者。谓随分能分净诸根。深信如来秘藏决定不疑。信佛有如是如是方便。若依行者必成菩提。此是地前信行也。次入地者。谓入初欢喜地也。准望声闻法中犹如见谛人也。第三五通者。谓了知世间五通之境。犹如幻梦水月镜像不可取着。尔时度五通仙人之地。名第三也。第四二乘者。谓观察二乘境界。心得无著心不堕实际。尔时得度二乘境界。尔时到第八地也。五从第九地修菩提行道。转转胜进成如来位也。然诸经论师。大略皆作如此说尔。若秘藏中义复有异。谓初欢喜地自十心。从初心至第四心得度五通境界。从第五至第八心得度声闻缘觉境界。从第九心一向行菩萨修道。至第十心名为成佛。佛者觉也。谓觉自心性净本来常寂灭相也。然此十心中。从第一至第八名为见道。从第九至第十名为观。见观谓见于谛理。此进修观。谓一向观于如来不思议界秘密功德。如是秘密之境。非所见法出过心量。故别名观道也。觉者是觉知义。已度二乘境界。了知二乘心与菩萨异也。若入第二地时。亦至第四心度五通。第八心度二乘。第十心成佛。准此有信取入位名。与初地十心不异。但此十心转复光显离垢也。乃至第十地亦有十心。即是凡有百心。一一转胜可准知也。如华严真金之喻可准知耳。此初地十心满。即能分身为百佛土等。如彼可知。但百心成佛。是宝炬陀罗尼经所说。甚深微细。此经未度东国也。修实不息令心心净也。次答修行事业不息乃至心续净。心续净谓不歇功用也。如是成熟(谓不熟令成熟当得于悉地也)亦可云彼。当悉地。悉地何时生者

经云。世世生生乃至业业不除。果令成熟彼时悉地成。一时业生令寄在身。得持诵者悉地从意生。此生生世世是义语也。梵云散跢那是识也。谓内心中也。犹如世间众生造种种业。乘此业故而受果报。或一生百千万等生。此业不失熟即受报。今答此悉地生亦如是。如行人随上中下期愿。依真言法要而修得成悉地。由此悉地在身故。乃至世世生生。常在行人身中犹如业果。虽复从众缘生常自空寂。不有不无。而亦不败不亡。从此悉地成后。世世受果无失败也。乘悉地之业而受彼果。名为生悉地家。既生悉地家已。乃至成佛已来终不失坏。故云业不能除也

经云。熟者。熟即是果也。令成熟者。是受用果义也。一时谓一时之顷。即是行者初依法持诵。既得境界许其作成就法。即于此一夜之中而得悉地。由一时间作。而于长时。寄在身中长不失坏。犹如置毒乳中。乃至醍醐悉能杀人也。如人造天业受果。既得天报随念即得。不加功力随念而成。此悉地亦尔。于一切生于彼时间。彼持诵者从所修善净业生时。次持诵者得悉地从意生。净业与所生心。俱等无分别也。业生心等。于彼一时间悉地成也。常得随意而生。故言随意生也。次答云何升空界者。言行者乘悉地之力。游步空界自在无碍。犹如于幻法中得无畏者。无所畏者。谓于幻法方轨法则。悉能了知无疑难故。所欲成也。如彼幻师化作种种境界。能随人所欲而为示现。然彼幻师。实无动摇亦无有变异。但以真言药物因缘惑众人心故耳。今此悉地亦尔。不舍此身悉成悉地。真言幻犹如帝释网。而步虚空界游诸刹土种种自在。然亦未曾动摇。但是真言幻所作故得如是耳。此幻师真言名帝释网。犹彼网于一切事。显示相现有种种相。而实无有一一实事。故名帝释网。此即是彼幻人世间真言。借以为喻喻出世真言之幻也(又云网是不断绝义。若网人则令人蒙昧不能自出。此真言网诸人心。亦彼蒙昧妄有所见。故名网也。)次答。如乾闼婆城身秘密者。彼所有住人。非身复非识也。云何身秘密者。言此悉地之人。不舍此身不舍此识。而能秘密其身。犹如乾闼婆城。于中见种种宫殿人民众物之相。虽似有是而实非有。亦不有而有。或时可见或时而无。此行人秘密其身。亦如乾闼婆城但从众缘而生。其实非实或隐或显。由真言观行众因缘故。而令此身随缘生灭。亦如是也。复次如梦中梦上三十三天。受天种种妙乐。犹人于梦中而游诸天宫。不舍于此身亦不于彼去。如是瑜伽睡真言者。住真言行此身如虹霓。过于一劫及其梦觉。乃少时顷耳。彼人不舍此身不往彼天。但犹眠法之心有此不思议事也。不可以心识而能测其所以。今成就悉地者。游诸世界亦如是。但以瑜伽梦因缘得有斯事。成种种事宛然不无。然知彼皆如十喻。不生取着也。身净故有悉地。犹如虹霓。真言同如意珠。加持功德业有是悉地也。虹在天不知从何而有。能见众色。真言如如意珠。随身语意种种生也。随念出诸资具。虽生而无分别。无分别而生。得悉地亦如是也。又如彩虹在天。五色绚明宛然可睹。今观是事。为从空有耶从地气生耶。若从空生。空本无法云何而得有如是色。若从地生。是亦不可。而有此事悦可人心。观当知彼法。不自生不他生。不共不无因。但众缘合耳。今悉地之身亦如是。以真言持诵功德力故。而有如是不思议种种神变之用。亦如彼虹也。复更释疑。如有人言。此真言事相之法。云何能成无相见谛真实之法。然此真实之法。实不离于因缘也。即观此缘生实相。不思议境界也。如如意珠在于幢头。能满一切人愿。随心所欲可彼所求心而至。今观是彼从珠得生耶。从人心生耶。若从珠出。何故一切时不出。要待人心希愿方出耶。若从人心出。则人心得何不自求而待珠耶。当知不从珠出不从人心出。不共不无因缘。但和合有耳。今悉地不思议神变亦如是。但犹真言观本尊及身印等缘而成悉地。由真言故口业净。观本尊故意业净。印故身业净。三事平等故自然而有不思议业。然亦不可分别。无思无为也。若尔既同如意。当知是有相法耶。为除彼见处说太虚空喻。犹如虚空无相无分别。然而一切有情种种作业去来进止。皆因于空而得成就。种种万物一切色相。亦因于空而得显现。而虚空性常无分别。无有生起之相。真言亦如是。本性常净同于虚空。一切有为所不能染。而亦能成种种作业。普门变化不可思议。云何是有相耶。当知世间种种有相之法。取是形相名之为相。因由此分别而为立名。名之为名。如是名相之法皆同十喻。但从因缘故有。因颠倒生故。说其实无生无性。即同法界如如性也。若能如是观者。即是与一切如来同会一处。是人虽未即能究竟佛慧。然其所解与诸佛同。犹与法相应称同诸佛故。即是与诸佛同会一处也。明十方空也譬如虚空方明十方空也。离一切有为行不染。真言者不染污一切分别行。若如是观察解了唯是想。真言者观察时。诸佛同随喜也。护摩有二种者。前虽略说护摩之相。今更分别内外护摩也。如两足尊所说。护摩有二种者。外护摩谓作法。除烦恼随烦恼等障。二内护摩谓。诸佛两足尊。说二种护摩。所谓内及外。息诸境界十二缘生等也。然外护摩。与内护摩而作方便。即是彼因也。有难者言。今作此护摩之施而求彼果。即是有所希望岂得成真理者。答我今无以希求。问若尔何不随檀那常法。遍施一切贫苦之人。而虚作此焚烧令尽。有何义也。答然凡夫之人。若有所施而有受者。即有希愿之心。或求反报或希施果。以此因缘不能对治希求之心。以不能治故。即不能绝贪爱之原。以是因缘不能与内护摩而作因缘。今烧此施正为绝彼过失。而作观对治。作无著慧因而为内护摩方便。故如此而作也。犹持此供物而奉本尊。即知希求之心亦如此物无异。一切如薪尽火灭。无可取者亦无方所。故能与内护摩为缘也。深行。作增益分中有增威。如献花时。先除垢秽已。即更增益威光。然后供养。如是既尔护摩亦然。阿阇梨即作内护摩。若浅行人即作外法。而究竟为内法因也。复次诸尊之别相本性须证知。谓佛菩萨二乘天神上中下。观察其形色等即可知也。修行真言复有种种差别。今料简之。若世间人。依彼自部之尊而修真言之行。谓如大自在天等。有无量种类各各不同。不可具载。经但举其一隅。以大自在为端也。然彼等作法供养之时。各各望得成就自部本尊之果。随彼性位差别不同。各怀希愿求成彼果。心有限量果等亦然。世间真言等说量。世所知识诸天自在福德者。彼所说真言。及与大力印。悉皆现世果。故说量有少殊异者。谓是生灭法无有坚住。谓当来世无也。说量者。佛说彼是有限量法。如是说也。虽然。不同如来所说护摩修行之法也。以世人但求顺彼本天神等果报而欲求证故。佛亦作出世护摩之法而对治之。故有真言行护摩之法也。然彼世人之尊。若于彼法之中极究竟者。但得与彼本尊为类。不得过上。彼真言及印亦尔。但随彼尊植福深浅势力所堪。而说真言手印本尊等。随彼势力。但得成彼本尊之果。又但能成现世之果获世间成就。终不能成出世间果也。善修如来真言印等。则不如是。永不穷竭失坏。此其异也。如牛蹄之涔。设令停水。随故势力所极。即自涸竭。若人以此水置于大海之中。即无竭尽之理。何以故。以与一切水性和合一味故。不可尽也。修如来真言行者亦如是。乃至成佛以来。世世受此悉地之果终不可尽。终乘此力而得菩提。何以故。己与一切如来大海同一味故也。出世诸真言。本初作不生无作也。诸业生悉断。离身口意三过而成佛。出世间真言本始不作生者。然彼世间之尊自在独角(本云犀角论云麟角)及佛声闻众菩萨等真言。我今说其量。天等所说真言。皆是有作之法。从彼尊生。出世真言超越于三时。从缘而生起。亦可用皆字也。可见非见果。从身语意生。则不如是。非是如来自作亦非古昔诸佛所作是。世间所称说果能经一切。等正觉所说真言果逾劫数也。故当知此真言印等。从本际如来法性自尔。非有生作也。问若言无作无有生者。今现见诸人为求悉地之果。而勤方便得成彼果。既有生有果。则有所作云何不生耶。答是义不然。夫真言之性及以手印持诵之者。体同虚空。所生之果亦复如是。由从真言手印本尊三事平等因缘。能净三障。从此而生不思议果。是故此不思议果。其量不可得。如彼真言印等同虚空。当知此果亦同虚空也。乃至声闻缘觉及菩萨等所有真言。亦同彼量皆越三时。三时者谓过去未来现在也。以离三时故。乘此悉地之果永无失坏。究竟成于无上菩提也。果缘生起者。谓缘真言手印本尊等众缘具故。而得成就。是故此量。即是平等中道之实相也。果有二种。一是可见法。谓现世而得成就。二者非可见法。为当来果报永无尽故世世受果。展转胜进以至成佛。然非表业非色非心法。不有不失而不败亡也。然由身口意业净因缘。而得生此无生无性也(以上有多种答更捡本问对之)

大毗卢遮那成佛经疏卷第十五大毗卢遮那成佛经疏卷第十六

        沙门一行阿阇梨记

    秘密漫荼罗品第十一之余

次答果数寿量几时者。然世间之尊所有真言势力。极上不过一劫。佛所说者则逾一劫数。谓逾一劫复逾一劫。如此无量乃至成佛也。是故世人所护悉地寿量及果。则有数限不逾一劫。今则不失。寿量无尽过于一劫数之量也。若事中释者。但随力能过若干劫。或过无量劫寿量不尽。亦是过彼世天也。故云超劫者。是通含不定之语也。克实而谈寿量。出过劫数受报亦无限量也。次答三昧者。略有多种。若诸佛及佛子。诸佛之大仙佛子众三昧。清净离诸想。有想为世间。二乘名离想三昧。若是世间瑜伽名有相三昧。此中三摩是等义。地是慧义。以慧观照如前三事皆空。以三事体空平等合而为一。是名三昧地也。然佛与菩萨三昧。皆离想清净。以此三昧正观三事。皆等更无分别离诸想故。本性纯白离诸染污。故名清净也。若有想者。谓世间一切三昧。谓随其果修行。望果修因有所希望。极至四禅八定处不得过。故非清净也。声闻缘觉虽得清净。然未能一切清净。以于烦恼所知二障尚未遍知故。未纯净也。世三昧又有二种。一者断见。二者常见。若断见而无分别。常者有少分别也。从业得果者。有成熟熟时。若得悉地者。于业自在得回转。须受亦得不受亦得也。心无自性故。心性离因果。云不者无也。于解脱相。业生生等诸虚空。成就及熟时业得果。若悉地得。当业回心之无性故。果因亦离。业生解脱。生如虚空者。谓世间有相三昧。犹有业望报而修故名成就。得是成熟名悉地也。若以此世间空。而回向此心之无自性。体既无相等于虚空无际。故得功德亦广也。回此心之无自性者。心名质多。质多者。犹如众彩庄严积聚名为质多。犹众彩所成故。即是无有自性。此即是因也。本因既无自性。当知所生之果亦无自性。所以者何。若因有生者果可有生。今既因尚待缘而成无生无性。当知生不可得也。以因果皆如是故。得解脱诸业也。或有说言。若如此者。便是无因无果堕断灭见者。此亦不然。但离业生之性。既离业生即有法性之生。等于虚空。虚空无边故。当知所成功德利众生事。亦无边无尽。故非断也。右以略说偈答金刚手问了。更以长行说之。云复次者。由前已说之事有所不尽。更续明之。故云复次也。谛听者。以此法转深秘旨要故。重戒令谛听也。此中略说五事。谓印色尊位及住并三昧。印谓手印契印也。改为形相也。色。谓本尊形相分段差别。置者谓方圆半月三角之类也。尊位谓漫荼罗中所住方位各各处所也(布置圣者位次)住谓本尊之像。非直彩画。而由真言及印等所引故。来至本坐加威而住也。现威验也。三昧谓随上中下分。寂忿悦等仪相也。请本尊如法。为印及形相。配置尊位。威验现前住于三昧所趣(所住处为)所住处名为趣。谓三昧趣也。要具明此五缘方。所云五趣者。趣是别别之义。由此五缘差别故云五也。由具此五故。世及出世间所有漫荼罗皆能解了也。然此五事。乃是古昔诸佛成最正觉。先佛成三菩提也(诸佛法也)法界虚空行。法界虚空行者。由体同法界成如来行故也。如是诸佛谓度无余界有情本愿故。为利乐安乐修真言门诸菩萨故。演说之。故令殷勤谛受也。金刚手言。如是世尊唯然愿闻者。是金刚手等十世界。及普贤等十世界大众。蒙佛告敕皆同声白言。唯然世尊愿乐欲闻。故佛更说秘密漫荼罗法也。佛言有正等觉漫荼罗。置秘密中密。无上大悲藏等名。若无量等世出世漫荼罗同者。即是如来最正觉究竟之说也。然此大悲藏生。前已说竟。何故更说有何差别耶。然前虽说者是为秘密更。有秘中之秘。若不说此法者。即通达前法亦不得成。故为最秘要也。若解此者。一切世间诸漫荼罗悉皆同用之。无所不入也。其作法者。先作四方漫荼罗。其界唯用羯磨金刚智印。周匝相连以为其道。唯安所。其十字中又作十字金刚印。印如前作之。但以十字为异耳。其十字金刚印。上作莲华。仰而半敷。令此十字如花之状也。其花上又安八叶之花。即如前五佛四菩萨方位也。当以心想而置九点。即是台及八叶中各想一点也。此点即是大空之证。此成正觉义也。于此八业及中。当作方圆漫荼罗而画本尊之像。佛方坛菩萨圆也。此但是行人自为已作。不令示人。若作法时自在坛门而坐。自作灌顶等法。然后得作一切法事也。此事尤秘。但心存作之。不可形于翰墨也。又其台上当想如上十二字真言王。令其字一一分别置于坛上也。更问。连环置耶。以何为次第耶。又云花中安子者。谓画莲子。或十或过减无在

经云。流出者。谓人了解此秘密法。一切世出世坛皆于中流出。随义相应可解也。略有四种造秘之法。谓事业(即是从初至未缘坛。种种事业所应作者也)形(谓本尊等形显分段)悉地(即所成果)安置位(即置本尊方位也)。了解此四法。即通一切流出之法也(更问)从此流出诸坛。皆依本教所说也。佛子者告彼也。谓金刚也。又四菩萨者普贤巽。文殊坤。慈氏干。观音艮。是其位也。前缘起列众中。或以除盖障替观音。或以除一切恶趣替文殊。其义各异。课用一事亦得也。此中用观音为正也

已上毗卢遮那漫荼罗竟

次初正觉者最初说也。明诸佛漫荼罗。即佛部

【图】

【图】

作此佛部漫荼罗。作圆漫荼罗。其圆如月。中白如贝色。此圆中先作白莲花。花上尽三角。此三角中作赤色。其中画佛像也(作何佛更问)绕三角以金刚围之。如图也。绕三角置点。点标也(更问)其外轮作光。如却敌形也。圆外周匝安点(疑此点一一皆是本尊之位。更问。或可置字)光普皆流出者。谓想光从佛身中流出。渐次流布在三角外也。真言主谓本尊也。遍身有光流出。前大坛中亦有三角印。与此用处不同。前者但是印。此中置佛或置印。作法圆具于彼也

次莲华部

○　　　此语属上件。世出世同画者。此同

    亦可名有也。言世出世有

○─○　无量漫荼罗欲令善听也　□移在

│　　　上。当知此是最初悲生坛

○

【图】

作方漫荼罗内画商佉。商佉上有莲花。莲花上有金刚。金刚上又有莲花。莲花上置观音菩萨。或可安印或安字也。诸印上皆安种子字。谓商佉金刚及花上也。其次院安大势等。周遍作光勿生疑虑也。以本种子巧安置之而作种子也。等处当置七白吉祥。一一皆有二使。此经但略说言之。自别有观音部法中。具载当别详捡也(更问)明妃资财主。是能自在施与求者也。及大势至等。如法作之也。作得自在之尊。持标相印也。当殊妙作之。曰如法作之。住三角中马头。合在可处用坛中画之。其余诸尊。亦各有形色等别及方圆半月三角等。合可用等。皆如广本也。前所云须通五事。谓形色契印本尊及位。即此事也。如画本尊。合作何色及形像等。各各有印。前者大悲藏生是嘉会坛。今此中随三部各各别有也。如此中莲花部坛。中胎是吉祥坛。以观音为主。胎外留空地。空地外即是第二坐位。悉置观音部诸尊等。余尽如作大坛中法。其空处亦置十方佛。其第三坐位。亦置八部众等。准前可解也。三角中犹如日出之晖。谓日初出赤黄色也。在明王侧者。在大势至侧也。次复若作马头漫荼罗者。当在三角中置之。在外三重。其漫荼罗亦皆随之作三角也。作此时诃耶在中。即移观音替居势至之处。余眷属皆围绕之。余皆回互可以意得耳。次作第二漫荼罗者。谓从莲花部数之。莲花为初即金刚为第二部也。我正宣说之。谓善说也。非前非后依次而说也。为第二部也。其漫荼罗四方作普以金刚。以三股者作界缘相接围之。围中黄色。中安莲花。花上有瓶。瓶白如月色。或用金刚围之。或用余物围之(谓随彼尊之印。展转为中心。亦如其印围之)彼瓶上有大风。谓半月形也。此中如黑云状(如雨时云叆叇垂黑也)其下状如幡形。如大风吹形势流动。彼半月中如大猛火炎作三角形。其三角亦以金刚围之。三角中赤如日初出色。其中置莲。莲极赤如劫灾大火灾色(谓殷深赤或可赤黑)莲上画金刚(谓或画本尊形或画五股印或字也)其金刚流出种种焰光。若画形者。心上安种子字。谓吽字也。若画印者。想[合*牛]字诵而加持之也。印上置字也。此是汝漫荼罗者。佛亲对金刚手说之。故告之是汝漫荼罗也。古昔诸佛皆说。我亦如是说也。诸明王各依本。坐类形色者。谓或金刚母及金刚针锁之类。众多金刚眷属。各依本尊形色差别。或画形或作印或置种子字也。各依其法次第相应。谓成就妙悉地故安此。金刚手为中台。诸部类为第二院也。此皆说中台也。转作无量坛也。先道者安右后道者安左。随所开门以办左右也。复次我前说众多金刚之别名也。自在谓于金刚得自在。复次此说我金刚执自在者。如前大悲藏大会中。毗卢之下不动降三世中间。画诸金刚者。皆未列名。今方列之。故云复次也。谓虚空无垢金刚。金刚轮金刚牙。苏喇多金刚(妙住也谓共住安隐也)名称金刚大分(谓大者之分即是大心众生之体分也)金刚利(谓极迅锐之称)此坛总以印为之。寂然金刚(寂静义如涅槃义也)大金刚(名也)青金刚。莲华金刚。广眼金刚。执妙金刚。金刚金刚(慧以金刚单为名)无住戏论金刚。虚空无边游步金刚(以上列名也各在处在大坛中安之也)如是等坛方圆等。依前顺其色形亦如此也。依名作次也。周而复始也。白黄赤黑等随文次第。最在前者白。次黄次赤次黑。次者又白。如是次第也。及诸所不说者。准此例解。随其本类形色而作之也。此金刚有十佛刹尘数。前列众与此中互有出没。或此有彼中无可知。又此等金刚所持之印或三古或一古(即针也)此准前次第。初作三股周而复始。或两头。此两头即五股也。此印周匝作四廉状。如四金刚。其中有一。状如五股而不开也。或鬘者。或持金刚鬘也。此等金刚。各以其本名为真言。即此名最上字为种字也。次随别字及通用。各于心上置吽也。其手印。通用上五股金刚印也。不动尊漫荼罗风火俱者。风谓半月火谓三角。谓于半月坛中画三角。画三角中作不动尊也。在泥哩底方者。故毗卢遮那之西南方作也。或三世胜异者。谓在于风方。以此为殊。余同不动也。三处以金刚围之(谓所执印)三处者。谓或作形或印或字也。然此不动尊漫荼罗若别作者。不动在中毗卢在中院东方。余金刚眷属周通围绕也。次说佛母漫荼罗。前布置漫荼罗形。先应知此谓金色。但列名未辩尊形及印。今列之也。先说作漫荼罗。金色四方。以金刚为界围之。此最上者尊形自上者。谓自此当说也。谓此佛母漫荼罗。于诸坛最为上胜也。次于漫荼罗中作莲花。黄色有炎。莲上作佛顶印【图】。其印如佛顶髻形。令顶高隆。傍画两眼形也。若作佛母形者。当如天女像。心置种子字。或可但画印(即顶髻也)或但作字耳若佛顶为中胎。诸佛眼等为眷属围绕也。佛恒自身火炎中住。种子布之。谓此印于炎中住。中置种子即是也。舍三分位。谓舍三座位而置佛眼。前说菩萨部中。普布种子。谓于坛中遍布之也。未说者今更说之。凡是诸菩萨。应须作漫荼罗。当作圆明之像令极白净。于中作十字台。台上大真陀末尼。各置标如承珠标。其头皆置如意珠。殊有光炎也。其本尊菩萨。于十字中心置之。诸余菩萨。在次院中次第而布。更外置八部也。极白是寂静色。当极令明净寂然而住。此等菩萨皆能施一切愿也

次作释师子漫荼罗(即释迦也谛听佛子也)当作金刚四方令普(此金刚即是如上所说五轮中金刚轮方坛也普者正四方之称也)其坛黄色极令鲜好。于中画金刚杵(三股)杵上安莲花。莲花黄色。花上置钵。钵四边通有炎光。若作佛形者。当画释迦佛持钵。又以金刚围之。右边置袈裟(即僧袈梨)左边置锡杖也。次五佛顶。其白伞佛顶。置座座上置印。且依本部。如佛部一切方。或依事。息灾圆等也。以伞为印(画之)胜佛顶以刀围普。若有说处即依文也。光皆流出犹如烧铁火炎也(谓赤炎光)最胜佛顶以轮为印。除障佛顶以钩为印(摧碎)火聚佛顶画佛顶髻形(大士者号金刚也)会通大佛顶以金刚为印也。阿毗发生佛顶也。揭多佛顶(是最胜尊义一切超以莲为印)无量音佛顶以珂贝(谓商佉也)色类应观知(谓如前说)佛豪相用如意珠为印。此名印漫荼罗。此印法等。灌顶成就物等用也。其息灾等。则随形色转变。非此所用也。成就皆以本尊在中观色类。谓白黄赤等也。佛眼当作佛顶髻形。两边置眼。其佛顶黄色。以金刚围之。无能胜明妃持莲印(谓空风指捻花。余指申之。捻花指向心前持也)若诸尊有印者。依文置之。若无文取本部主印置之。唯种子字中也。无能胜王作口印在黑莲之上。谓画作忿怒口。其口双牙上出者是也。此等诸位。若以释迦为中。则佛顶等列之居次院。若随一一本尊中。取一为漫荼罗主。即移释迦在外。余皆可例解耳。更以次说净居天印

经云。净境行者。谓以禅定为味以净为行耳。其印今次列之。思惟手(谓稍屈地水指向掌。余三指散舒三奇杖稍侧头。屈手向里。以头指指颊)善手(谓手)施无畏。皆用左手右亦得也。妙好义也。笑手(谓回思惟手当心前令三指向上也)花手(以风空捻花。而申三指。其三指或仰掌舒之。或竖舒皆得)虚空掌(谓侧右手散指而在空中)彼画法则。谓依此法画之也。此等天或作笑或作思惟。或作与愿等皆得。次地神印。作宝瓶。圆白之中其瓶插诸宝谷花果等严之。以金刚围之。请召火天印。当侧申右手。其风指第三节稍屈。又屈空指上节向掌中。若先直而屈。是请召也。若先屈而还展。是发遣也。当以诸大仙而围绕之。谓迦叶瞿昙仙等皆次画之。并在火院之中。火院即是三角坛。其中色赤名赤院也。其印如前五通仙人说四围陀印是也。此是梵行者秘记。若诵围陀者见此手印。知是何论何部等也。瞿昙仙(虚空中行欲有二渧污下地生地甘蔗日炙生二子为释王者是)末建拏(坐禅蚁作对遍身恐损蚁复入定者是)竭伽仙(山名约处得名也)嚩私仙(即旧云婆薮仙人者也)[央/瓦]竭罗私(是身汗液义也。此仙不从胎生从汗液而生故得名也)南方阎摩王当作风坛。坛中画但荼印(若印等此坛一角向身一角向外也或随彼便安置)。王右边画死后。以铃为印。若画形即持之。左边画黑暗后。以幢为印此幢也(梵云计都亦旗也)大自在。忿怒作输罗印。此输罗也。大自在子之后。作铄底印。此铄底也。大梵天明妃作莲印。谓未开莲也　那罗延作轮印。七母同用没檗罗印。此是也。俱吠离耶。作在毗沙门方顶骨印。此颅骨。以笑手状持之(谓屈水地指于掌中散舒余三指如笑手状以持顶骨如持钵状)七母等眷属。谓鹫狐及婆栖鸟(似鸱少黄土色觜亦黄是鹯类也此鸟有秘身法也)此等并在风轮中。围绕七母等(凡阎王部类皆在风轮中也)若持花得此鸟等亦持七母真言也。此等各别自有持诵法。今入此漫荼罗会故。尔皆悉以为庄严。泥哩底方当作大刀印。那罗延天作轮印(如上)俱摩罗作铄底印(大自在之子)难陀龙兄弟作云印(云中有电。复有水形。俱在坛门边也)商羯罗三戟印。商羯罗后钵致印　月天作白瓶并有莲。日天作车辂印在金轮中(即是正方坛也)社耶毗社耶作弓印(亦在金刚轮中也弓傍须有箭)风天作风幢印。妙音天作琵琶印。嚩噜龙作罥索印。如首。作圆漫荼罗。取本种子字围之。大我即告执金刚也。右此等略标印记。若广作者具如法中。谓彼类各自在真言别行法也。以上释迦部类行法也。以下明菩萨漫荼罗(此是大坛第二重诸菩萨位也)文殊漫荼罗。正方以金刚围之如前(火出即是)作此中三角。三角中作青莲花印。种子字也。诵之想遍其中。真言字于中安之(非但于中安之亦四边安也)其三角内傍界边。周匝作少青莲。以围绕大青莲华印也。所以作印。为识此尊法门义趣等故。各随形色等观之而识秘意也。如法取种子字而种子之。即是(安置此字作种子也)彼中作是印如次作此。勤勇者即是文殊也。谓青莲种子等。如法次第作也。随形色等观之识秘意也。光网童子作钩印(若作身持钩也)宝冠童子(持宝为印)无垢光童子(持未开青莲华也)所说使者。此是文殊部所说使者。持诵者如所相应。而知彼印以法相应作者。谓以下童女也。智者即自文殊也。亦可名具德也。计设尼(大刀为印)小计设尼(输罗为印)杂色使者(以杖为印)地慧(以幢为印)招召使者(以钩为印以上并如童女)诸奉教使者。普皆作小刀印(如经中及图)此刀作锯齿形。云小刀非正翻。右如上所作。皆于方坛中作印以青莲围之也。以上是东方文殊部类眷属也。若文殊为中胎。余菩萨为第二重。八部为第三重。他效此。南方除盖障菩萨。以如意珠为印。亦作四方金刚轮。中又作三角坛(即名火轮也)所说相当以如意宝也。尽大精进者种子。所谓如意宝。当于三角中画如意珠。眷属围绕也。以下菩萨。皆是应当以眷属围绕。当知彼印相今广说眷属也。此中眷属者。于彼中当作印画之。如次第。即是如法也。彼文有此字。指之如左也。除疑怪菩萨(即娇都也)其印金刚印。曰瓶(音越)中作瓶。瓶上插一股金刚。半在瓶中也。无畏施菩萨作施无畏手(如瑜伽中释迦印)除恶趣菩萨画作发起手(谓舒手仰掌从下向上举之)救意慧菩萨作悲手置心上(谓水空相捻当心余令申散也其捻指向心)大慈悲起菩萨作执花印(空风相捻如执花形余指申散而竖)悲念菩萨(屈火指向心前余指皆申散)知者即道此菩萨名也。除热恼菩萨作与愿手(舒指仰掌向下流注甘露水指等者等谓诸指也)不思议具慧者菩萨作思惟手(与如意轮菩萨手同亦如前净居天印也)具不思议慧

右皆作方坛置莲华上也(谓画此手印等也)。此皆除盖障眷属。余义如文殊中说之。北方地藏菩萨印。于大因陀罗轮也。金刚轮中作宝。所谓在中先置座也。庄严地。地上画莲。具种种色。花上作幢。幢头安宝。不画形但画幢也。若作此印者极上色者。此是形相也。此说名最上形。是叹也。于诸印中最为胜上殊妙也。此菩萨有无量眷属。今略说彼上首者。如左宝作菩萨印。彼中画印殷勤作之也。三股金刚在于宝珠之上也。但于宝地之上作印也。若画形者。亦坐莲如地藏法。宝掌菩萨作一股金刚。安此金刚在宝上也。持地菩萨作两头金刚安于宝上是也(于一股中有五股形如前印也)宝印手菩萨印。作五股金刚置宝上(即是五佛金刚也)坚意菩萨作十字金刚(即羯磨金刚也)右一切皆彼漫荼罗中安置者。皆于方轮中作宝地。地上置宝。宝上有印也

次西方虚空藏菩萨。即是文殊会中西方部主也。作圆坛令明净鲜白。坐白莲上手持刀。若不画菩萨形者。但置刀。其刀极利如霜。又如是。谓如是坚利也。又坚固。以种子字而围绕之也。智者以自种子而种子之。即是安本种子也。次列眷属上首菩萨。即画彼印形如教。谓皆依教如法作也

虚空无垢菩萨。亦本围之还以轮围之也。此本即是自也。印作轮(即四技刀轮也)置轮亦自围之也。在风坛中。虚空慧菩萨印。于风坛中置商佉(即半月坛也)清净慧菩萨。画白莲印在风坛中置。次行慧菩萨印。于风轮中置商佉。商佉中插青莲华。安慧菩萨印。风轮中画花。花上置金刚也。凡此于大悲藏大坛中文殊一会。凡四菩萨。随以一菩萨为主。置于中坛。余者各于第二院案方而列。第三院置八部也。复次若是大悲中第二院者。假令以观音为部主。其金刚部及佛顶等。并依方位而列为第二院。次应当知其第三院置八部。即不须置文殊会菩萨也。若释迦会者。即如是上说(更问)此说是定义也。此事更问审不

秘密漫荼罗品竟

    入秘密漫荼罗品第十二

入秘密漫荼罗品者。谓诸佛身口意秘密之藏。唯执金刚秘密

尔时世尊复说入秘密坛法。秘密主乃能知之。故佛复告之也。然此执金刚。即是毗卢遮那之所化身。为欲发明此深密之法故也。此法无能发问者。唯佛与佛相问乃可知耳。如金刚顶经分别积品下。佛入三摩地已。从佛身中出字形印形本尊之身。各从方方出施作佛事。所谓是大因缘开佛知见。如是作已复入如来之身。尔时空中出问法之声。问佛一百八号。云何名佛。云何名正遍知等。乃至问十六大菩萨及真言印等。如彼广说。尔时佛即自叹言。善哉善哉能问斯事。乃至随问而答。尔时大众得未曾有而作是念。今从佛身而问于佛。犹如幻事。无作无生者而成佛事。今此执金刚亦如是。从佛金刚慧印而生。复持如来金刚慧印能有所问。而佛答之。恐人不信。若自问自说则不足尊重。故以佛身而问佛身也。又所以名执金刚号者。犹能持如来身密口密心密故。名持金刚智印。尔时世尊又复宣说入秘密漫荼罗法者。上已说金刚手秘密漫荼罗。而未明入秘密之法。故次宣说也。持诵者遍学秘密漫荼罗。真言者应遍学(谓一切处须解也)古者秘密坛。即智者是通达也。无所疑滞故名智者。智者尽烧一切罪。弟子法如是者。持诵者即是成就之人。谓阿阇梨也。应遍学者。然唯佛与佛乃能遍知。遍学一切诸法。能具此德乃可为师耳。今末代此人难得。云何得有传法师耶。然阿阇梨虽未得如佛。应遍了知此经宗旨次第法用一一明了。及随顺此经所有诸法缘。漫荼罗要者应善知之。应修瑜伽之行。晓了众生种种根性利钝及有遮无遮。及本尊之真言身印之类。乃可传法为弟子。作入秘密漫荼罗法也。所以然者。今此诸佛法要甚深难解。共所守护不妄宣传。久默斯要不辄尔宣说。若末代人师。不能了知魔事及入道方便次第。而妄教人。即无所差别差机误他。故须遍学也。所云智者。即见此遍学人是也。能知应与不应与应入不应入如是种种。故名智也。若不闲方便徒有所说。而不能令他建立无上善根。速入一切如来之位。更招极大障法自损损他。云何名智人耶。烧弟子罪者。犹彼从无始来。具有无量无边罪障。弟子法如是者。谓如法入坛作法也。深厚之障若不为除。则身器不净犹障有故。不合为说一切如来具足道。犹如声闻人。有十三难等不合为授戒也。烧彼寿令不复生。烧除灰烬者。今岂以世间之火而焚彼身。令命根不续为灰烬耶。今自有妙方便大慧之火。而焚彼业烦恼身。使不复生也。一切众生皆以业烦恼蕴积相续。而得生长轮回无绝故。名为寿。今即焚之令尽无余也。业烦恼为薪。方便智为火。以此因缘而得无余。此薪既尽能治亦遣也。所谓烧者即是字义。当以阿字为弟子身。使以阿字遍作其身也。次以此慧火之字。焚彼菩提之性真金之矿。令垢秽无余。故以罗字而焚阿字也。然既焚竟。岂如二乘断灭灰烬而不复生耶。不如是也。诸垢之薪已尽更有妙生。所谓净菩提也。真实生也。此生即是清净之性。如来种子也。师以何方便令此灰烬。复烧尽同于灰。彼等复更生也。以字烧字者。谓想阿字同方坛。弟子在中。而以啰字烧之。以烧故同为一体也。身同阿字。而以啰字。自烧一切烦恼罪除。乃至身亦除体同金轮也。生妙牙也。谓生嚩字门也。当于心上观圆明。于圆中而安嚩字。从此嚩字而生水轮。犹如白乳而以注之。以此方便复生净菩提心佛种子也。生此清净之身。内外无垢如百炼之金。而加莹饰随用成器也。当知火动之时即与风俱。风轮者即是诃佉字义也。又嚩字上加点。此点即是大空欠字门也。微妙法水从空而注。以净其心器。当知即具地水火风空五字之义也。然此皆是如来秘密之义。非徒如文而已当善思之。行者既得如是遍净无垢身。寿命还活悉皆无垢也。意生之。复为欲令坚固如是意生之身故。更有方便。犹置十二字复得十二缘。谓十二支句也。此即是前说。十二字真言王。当用布满其身也。初有四字布于上分。谓从顶至额也。一字虚空字也。顶上二字在耳。一字在额也。次如本性配生。从眼起好也。有四字在中分。谓二肩上。及心上咽上也。次有四字在下。谓脐上腰上一字在腿上一字在足下。然单足二皆有之。今但于一足置之即管两足也。当知此十二处。即摄余一一身分。如二耳字即摄二目等也。如上所说之字。当取上真言王。从初字次第而布之耳。然作此方便有三等。一者师自布。二者用作漫荼罗(更问布字云何起也)三者加弟子身。此是瑜伽秘密加持也。如是作已即能成于法器。故云作彼器也。如是作已。即是成就三昧耶。所谓三昧耶者是等义。谓我等于佛佛等于我。无二无二分究竟皆等也。阿阇梨者等于佛。佛即等于弟子。此弟子非但等于十方三世一切如来。亦等一切诸菩萨。亦等一切声闻缘觉。亦等一切世间天仙之众。若如是等于一切。即是毗卢遮那身也。故云诸世间等同等同顺。亦是法花皆与众实相不相违背。应作如是解等同诸佛也。无违背义也。称此三昧耶秘密漫荼罗中。入一切法教中。自在诸漫荼罗。如是等我。若称此三昧耶秘密漫荼罗。入诸法教中诸坛得自在(虽不入亦得自在摄取也)如我等。持诵者(谓我与彼行者不异合为一是名三昧耶也)亦然。持诵者不异。三昧耶名说者。解是解了之义解知之义。若解此入秘密漫荼罗方便。即是遍入一切漫荼罗也。此弟子以同遍入一切漫荼罗故。即业自在修行一切法门无有留难也。佛以诸法究竟等。释三昧耶名。故云三昧耶名说也。如经初具有入大悲胎藏漫荼罗等诸法。乃以此法为要用之法。不于前说。乃在此说之。若不解此。上来所作漫荼罗终不得成也。所于回互前后不相承蹑者。岂佛不有吝惜耶。但为欲令入正法者应须依师而学。犹如佛于声闻经中呵贼住人。云得具满和上阿阇梨。如法受戒决修梵行。何故如盗住也。今末代学人亦尔。不[(弟*ㄆ)/刀]近善知识咨承法要。而自师心欲望成就如来自在之业。直尔披文。便欲作之望得成就。无有得理也。非但自损。又欲求名利故而妄作人师。自既违法。而欲更建立他无上善根。何有此理。由此无有效。故更招谤法。破法之缘成无间之业。何有无间业人。而能自利利他俱成妙果耶。是故行是法者。[(弟*ㄆ)/刀]求明师。一一咨受微旨晓了明白。先自成立。堪能建立他人无上善根。犹如声闻法中。五法成就自成五分法身。亦能成他五分法身。得离依止得在师位。尔时乃可传法利人。其或不然。慎勿妄操利器自损其手也。故经云。差机说法为人师冤。今不善遍学持明瑜伽之藏。而欲随他本缘而授其法。亦犹是也。入漫荼罗有三昧耶偈。可有十四五偈。即是与弟子受菩萨具戒。及教授教诫要誓之言。此土未传耳(具问)次住秘密漫荼罗品。前品说入秘密漫荼罗方便。所谓三种加持也。谓以真言加师之身及所入之坛。并加弟子令住坚固。然后得安住于秘密藏中。故次说住证之品也

    入秘密漫荼罗位品第十三

尔时大毗卢遮那世尊。彼时等至三昧地证。未来众生观念从定住者。毗卢遮那义上已释之。今更释。所谓毗卢遮那者日也。如世间之日。能除一切暗冥。而生长一切万物。成一切众生事业。今法身如来亦复如是。故以为喻也。然世间之日则有方分。则有照外则不能照内。明在一边即不及一边。唯能照于昼日而光不及夜。今如来日则不如是。遍照内外无有方分昼夜之别。圆明常住。一切众生若得此日出时。则能生长一切如来善根。行如来事。世间之日不可为喻。但得其少分故加以摩诃之名也。佛所以入此三昧者。佛住毕竟无相寂灭之法。以大悲故住于三昧。令一切大会及无量众生。得见此大悲胎藏漫荼罗庄严大会微妙之法。即是于无相中而现有相。虽复有相。而从因缘生即不生义。同于性净之法。而令众生各随本缘。见种种色闻种种声获种种法。各随心器如法修行。有如是大因缘故。又为满足金刚手所问之法。令明白无余故。而入三昧也。等至者三昧名也。上云尔时。此复云彼时如来入于三昧者。对前因缘次复有此事故。分别云彼时也(更问)。等至者。犹过去一切诸如来。皆乘此道至成正觉。如过去。未来现在一切如来亦复如是。皆从此道乘此方便而成正觉。故云等至也。如三世佛至成正觉。我亦如是。如我今乘此道而至道场。一切佛亦如是。佛佛皆等。本末究竟悉等。故云等至也。又复如前所示大漫荼罗方位之相。如佛所入三昧而示现者。若阿阇梨住于定中而度弟子。亦当布此方位之相。与彼无异。一一皆是入法界诸尊善知识普门行法。若作此观以加弟子。亦令得见如是大会也。令内心所观与外事所布。内外平等无有差别。故名等至三昧也。佛入此三昧故。令金刚手等诸大菩萨。皆得满足所问之疑。佛于三昧中所现之事。即是示其方位法用。故入此三昧也。彼佛入三昧时。彼佛事等如是。等者等同也。犹如手掌平正。所谓地平者以三昧而言。即是得见净国庄严其地平正。无有瓦石诸山及沙砾等也。然此即是净菩提心之义。以信力故平其心地也。除去所有阿赖耶之所。含藏沙砾株杌等类。唯除毕竟平等净菩提心体性之地。若能平净此地。即可成就大悲胎藏佛会庄严也。五宝间错者。谓金银等五宝五色之宝而间错其地也。五行者即是白黄。五宝谓五色也。赤绿黑次第也。白。间错。是戒也。黄是信赤是进。绿是定黑是慧也。上释云初白次赤次黄。今以此释为定前释非也。从此已下一一庄严皆有义释。今此中未解。别处一一对其法门也。然其处非但五宝间错其地而庄严门标。而已。又有门标。即是大悲胎藏之门标。令知所入之门方位之相也。言标者。此标即是如上所图者。然有画作者及立作者。画作如所画图。其立作标者。亦依此相而作也。其门有柱。柱上横木。标知是门也。四方之门即是四念住。标是四梵住也。涅庾呵是门。都啰亦是旗也。即是标杂色者非但五方之色。更有种种杂色也。此杂色幡其相广长。而在门标之上。大宝盖。在上都覆之如坛法也。然此盖者。此盖之量遍覆诸佛刹。故云大也。此标上又悬白拂宝铎以为庄严。前是彩幡。幡有宝铎及幡拂之类。并悬宝幡而间错之也。并种种杂好彩之束。即叚束之是杂彩也。杂彩名衣悬垂周布。私谓即是如文着杂色衣之义也。从第一无相之法。而出生如是大悲藏生之相普现色身。种种方便说无量法。是杂色义也。杂色幡以来。皆在门标也。建谓立幡于标也。八方隅建大摩尼幢。幢以摩尼作也。幢者谓四方及四隅。各建摩尼妙宝如意之幢也。此外复有八功德水净妙浴池。湛然清净。复于池中有无量水生禽鸟。嬉戏自在。出种种微妙音悦可一切。又生种种时花。时谓六时之花。各适时而现也。非但名花。又有种种宝树罗列也。八方分分布之。分即方也。五宝璎珞绳继也。此八柱之上。周匝宝绳而相连系。此中云璎者。梵音与前所云璎珞有别状也。谓垂如仰半月形。而垂下宝璎周匝相接也。其地细滑如绵纩衣乐受极触乐者。如西方有纯绵之衣。如此地轮中之类。极柔滑。案之则没。举身复平如旧其平也。极细最生乐受也。又有无重乐器弥满空中。在于空中不鼓自鸣。其声深妙令人乐闻欢喜快乐也。于此布列庄严之地。复生无量随诸菩萨福德。所感意生。之座及宫殿。从如来信解生。其座罗列亦作三重。如上大悲藏生漫荼罗布列次第也。然各随菩萨净妙功德。五尘乐具而生有种种差别。举要言之。则有十世界微尘数等。各各不同而布列其位也。此等皆在八宝幢柱之内。并从如来信解力生。以如来本愿力故。于等至三昧中普门示现也。法界标。标即从法界生。即是法界坛标帜也。标者此中有性义。梵文语含也。标即是性也。法界体性。本来常净第一无相。还用法界而庄严之。中有大莲花王。此花即同法界。遍一切处自性清净也。当知彼中如来止住者。花既量同法界。当知佛身亦复如是。此即中台八叶之花也。然生大莲华。如来住彼法界第一。随意解众生喜悦。此第一是第一法界身。随诸众生信解令得欢喜。极微细之意最难见之性。故极微细也。此第一者。义谓当云性也。随意者。佛本愿力为度一切众生故。普门示现。各各随彼所喜见身。应其机导利令得欢喜也。彼如来诸支分无碍力。从十力信解生无量色形庄严之身者。如来支分有无碍力无坏力。以一切世间天仙及二乘声闻菩萨等力尚犹有碍。由有碍故。更有胜上力者。即能坏之。今佛力无碍不可坏。由如金刚。故云无碍力也。此无碍力从何生。当知从如来十种智力生也。从佛身支分上中下。为分三分流出种种类形。乃至一一毛孔皆悉出种类。若干形色各异。或方或圆三角半月。或青黄赤白黑。寂心欢喜忿怒等形。其数无量。即是诸本尊等。皆当坐于意生所感之坐也。今此十力复从何生。谓从如来无量阿僧祇劫以来。修行六度十度乃至百千万不可说阿僧祇诸度万行。即此诸行功德资长也。以功德所资长。身出现也。从法身而出现也。彼出现已。于诸世界大会之中。诸谓十方也。然此非但现形而已。复出种种妙音。演布不思议常寂秘密之法真言之行。普令一切皆得闻知也。此所生菩萨各说种种。有音声表作如此说。谓。偈也。妙偈而叹于佛。犹如下方踊出之会赞。大日如来犹住三昧。此是三昧所现花台中。毗卢遮那世尊。于身分中示现此耳。从此法界生莲花中。佛出种种形之时。又从佛身出种种声而演妙法

经云。音声者即语表也。此音演偈略有二偈。初偈云　奇哉一切佛。方便不思议。于无藏性中。以慧令为藏　此偈叹佛之意。见上示现不思议事故。叹佛之功德甚为奇特也。叹一毗卢遮那。即是叹一切如来。故云一切佛也。是故当知如来所现奇特之相。即是如来大慧及方便中生。此不思议业也。云何不思议耶。谓住无藏性而能作有藏也。藏者梵云阿赖耶。此翻为藏。或云宫室舍宅之义。如世间舍宅。一切众生各随己分安住其中。既有此窟宅。即有善恶含藏不能自出。如来已离如是阿赖耶窟宅。故云无藏性也。佛虽无一切藏。然以慧方便而有藏生。谓于无相法中而示种种相。无妄想法中而出种种音说。即以此藏令一切至于无藏也。次偈若识无得者。法之诸法相获无得。而获得诸佛导师。此意言。法性无得不可识。若有所谓。无得是空义。若得此者即佛也。即是有妄无藏。非是如来无师之慧。若可识即是心所行处。非究竟胜义也。所以叹佛不思议者。乃于无得不可得法而能得之。所谓上来境界无相而相。令一切众生。以无所得而得之也。谁得此法。谓诸佛导师也。复次前偈云奇哉者。梵音奇哉。即于初首而有阿声。此偈已表法竟也。此即是本不生义。能生一切诸法。谓如来身所示种种形声。皆从阿字而生也。时出种种形竟。还入佛身支分。又复还入如来不思议法身之中。各随所生之处而入。故经云。又复入如来秘法身不思议。此不思议梵音阿真底。亦有阿声。意明从阿而出又从阿而入也。此两头上下指两阿字。明一切法出入即同法界之体也。彼佛告执金刚秘密主者。意明彼佛即毗卢遮那也。当更问。彼佛者为是三昧中所现之者。为是本如来耶。当是本如来也。从此以下。佛从等至三昧起已。而告金刚手也。佛所以住三昧。而现如前种种希有之相。谓地平如掌。乃至布列诸尊。及八叶花等方位者。欲示执金刚等内心瑜伽之境。以外况内而表于义也。是故今从定起复说内心漫荼罗入秘密藏之法。而示执金刚也。善男子谛听心内心地中漫荼罗。彼秘密主。身地即是法界自性。以真言印加持之。本性清净故也。如前以大日加持。次即以羯磨金刚萨埵。作加持而作事业也。如大本中。有二十种劝令听法之相。佛为执金刚除一切尘垢。及修行真言行诸菩萨等法要未具。不得疾成无上菩提。今复次说满足前义令法要圆满。若不知解此。则前法皆未周悉。以此因缘劝令谛持也。如是二十种因缘当广说。前所呈示。是三昧力故呈示外境。今则内心观之。以于行者自心之中而具佛会大海。十方通同为一佛土。唯自明了他所不见。故名秘密漫荼罗也。犹如作外漫荼罗。先谓持地。平我人众生寿者。去沙砾株杌等事。次当平治令悉坚牢平正。方可于中而建立之。今此亦尔。欲于内心建大漫荼罗者。亦先须平地去株杌等过。此云身地者。此语即含地水火风也。云何治耶。谓先当建立瑜伽之座。瑜伽座者。即是所持真言之字。以加持之。取彼所持真言最初之字。即是真言心也。其字当去点等。但取本体。即是阿字。阿字是金刚地也。所以如此者。犹如释迦初成正觉时。入金刚三昧而成正觉。除金刚地更无能胜者。今此亦如是。为欲建立内心毗卢遮那大漫荼罗会故。若不先建金刚心地。则不能安立也。阿字是金刚轮。为欲升金刚座故。先观阿字为始。还以金刚而持金刚也。观此字当作方形。然此字形体亦方也。观此字正方而作金刚之色。遍满行者内身。由如身之地大无所不遍也。次作水三昧者。谓观缚字处在圆明。其色正白亦遍满其身。然此字形亦圆也。前观阿字已遍一身。今复遍身。犹如水大遍洽一身。与彼地大不相妨也。次观啰字作三角赤色。此字即作三角形状也。啰亦犹遍一切处。犹如身中火大也。次观诃字作侧半月之形。其色黑。彼字在中色又深黑。亦遍于身犹如身中风大也。地水火风是外境。从外内照。即是阿嚩罗诃字。以加其身也。此阿者即是法界之性。以一切法本不生故。即同法界也。以阿字故。余水火风当知亦是法界清净之性。从因缘起而知本不生。以此一一真言之字加持而加持之。当知此字本性清净也。缘者谓因此得生也(恐是故字义)业金刚有情加护。离一切尘有情寿者满奴所生末那仙生作者等株杌过患者。金刚有二种。一者智金刚。二者业金刚。此梵云金刚羯磨。谓所作事业也。以此金刚业而加持故。得净除其地也。离一切尘者。尘谓过患等也。欲平其地。先当除去沙砾株杌等。所谓一切垢见也。次略说其相。谓有情寿者等见。及满奴所生者。是一类外道见。满奴是我。言一切依我而生也。末那仙生者。言一切从彼生也。亦是一类外道等见也。即是垢障不平之性。亦以金刚作业。除彼不平之过。去彼株杌方净结此心地。而建秘密大漫荼罗也　四角四门。西向门常开出入门。傍安缘周匝者。如前所示外相中门摽之类。及周匝八大宝柱。柱上悬宝璎白拂等种种庄严。令内心瑜伽亦与彼无异也。然彼一一皆是内心法门。应更问其名义耳。于中有从意生大莲华王。八叶有茎蕊。周遍妙彩画。于中如来。一切人中尊也。超越中语意。身心地登升。心地至得。殊胜悦意果授者。谓在此内心大平地庄严中。有大莲华王座上也。如上所现大花王。其体净妙量同法界。今此内心所观犹如于彼。故名为大花王也。其花有茎有蕊。诸色间错妙彩画作。皆谓内心观作。如彼画工。运布众色作诸色像。虽众缘合无有自性。而相貌宛然也。此上有一切人中尊。即是毗卢遮那也。此是行者自性无师智大毗卢遮那佛。非从外来也。身语意超身语意心地。得至净心地。获悦意殊胜果。超染污心地。得至净心果地也。身心地登升者。如一切世人。未得身口意三平等。故不能入此心地法门。如来悉离三业众过。得三平等至于一切诸佛地。谓得净菩提心毗卢遮那如来悦心地故。于一切中尊也。复次一切众生同有此性。如来秘藏具足无缺。而不能自信不自了知耳。唯如来明了自证。而为一切普皆觉之。亦令同得此。故名一切众生中尊也。悦意果谓最后果。当知得是心地者。即是毗卢遮那如来也。授与谓有人传授。复自观察修行而得斯果。犹如人与。是实自悟不从他得也。如上毗卢遮那在花台上。以次八叶东方观宝幢佛。亦名宝星佛。南方开敷华王佛。因陀罗亦是王义。若重言王不便。故存梵音也。北方鼓音佛(前置阿閦今改为此名也)西方阿弥陀佛。其四隅之叶。东南普贤。东北观自在西北弥勒。西南文殊其花诸蕊中。置佛母诸波罗蜜三昧等。佛母即虚空眼等也。此花叶下面。置诸持明忿怒等。皆叶下。其花茎。即以执金刚秘密主持之。以为其茎也。复有无边大海众。即金刚也。亦有种种供具花香之类。今略说之。下文自有安布方便也。其花茎下。观为大海水。海岸之外。为成三昧耶故。须办花等。为欲与一切入坛故心念花而令入也。地居天众。各依方观布之。复次灯花以下偈也。意生谓从心生花等。画之殷勤者。谓彼持诵者布于身心。犹如细画也。此心漫荼罗之上。有佛在中。故曰大我。大我者佛之别名也。自作谓自内观作之谛了分明也。然此秘密漫荼罗。为师观弟子。深是法器诚心愿求。为而力不能具众缘如上广作者。师得为作此法度之。自余当须众缘。不得用此也。然若弟子已得瑜伽。师欲令入秘密佛会。亦作此也。啰字净除者。先已作阿字及啰字净除了。亦如前法净除弟子也。即是如前方便。观于啰字之火。而烧除彼障法积业。令悉净已。方复以甘露法水而灌洒之。得于死灰之中而出道牙也。是故次授彼暗字也。师当住瑜伽之座。观阿字上加点。置弟子其顶上十字缝中。当知此上有点。即是甘露法水用灌其顶也。寻念如来者。谓师将度弟子入秘密藏故。寻念三世佛所行方便。欲令同证同护持之也。师既自住瑜伽之座。以其身心而作佛海之会。唯独自明了余所不见也。次授弟子花。令投师身上供养内心之佛。而观本缘。随彼本缘而观其法。若本尊摄受花。于中彼师皆观之不谬。而弟子未得瑜伽者。但见在其身上耳也。其花投处。大略心为八叶之位。从脐至心为金刚台。脐为大海。从脐以下是地居诸尊位也。此者何义。谓从诸佛大悲海而生金刚智。从金刚智出生一切佛会也。于一切漫荼罗中。此最为上无与比也。自见已向彼说之。谓师是心中所见堕处也。上文说持诵者观其肉身。内心八分作八叶作开敷。及啰字置目等。若行人不如是修行成就。而能作此秘密度人。无得理也。要当先自成就。堪住瑜伽师位。又为阿阇梨所许。方能办此也。今此所作。虽是度人方便。然行者若于此。自持诵观照之时亦当如法习之。用此灌顶之内而自灌洒。为除一切障速入佛会故也。前品名入秘密。今复云入者。此入是证入之入。犹如人已入室宅。一一明了细分别之。出入自在。家内所有悉皆知之。不同初入门人也

大毗卢遮那成佛经疏卷第十六大毗卢遮那成佛经疏卷第十七

        沙门一行阿阇梨记

    秘密八印品第十四

尔时毗卢遮那世尊。观察大众会。告金刚手言。彼秘密主。有秘密八印甚极秘密者。如来前品中。说入住秘密漫荼罗法竟。时诸大会复作此念。如是秘密甚为难解之法。更有何方便具足之相。速令真言行者得成就耶。时彼如来知众所念。此秘密中为更有甚密耶。为剂此耶。以不能测故。无能发问者。故佛不待彼问。但无问而自说也。所谓有神验者。若行者或内或外。敷列彼本尊等漫荼罗座位之时。以此八印及真言本尊之所加持故。彼诸尊等自然降赴道场。满彼正行之愿事也。复于本尊位中。安置有神验同。同谓等同本尊威神也。竟乃去也。此是不思议感应之性。犹如水火镜中日月应之。尚不可思议。而况如来不思议法界之感应也。此是阿阇梨所行之印。不得辄尔而习。假令已入漫荼罗者。亦不得于前辄尔而作。况余人作耶。非直以本真言趣为摽帜。趣谓如六趣等。此是真言趣。兼漫荼罗如本尊相应者。如本尊有如是法。我亦有之故为具也(此如是一事以上同彼尊也谓形色坐立喜亦尔)自身住本尊形当如是知。知见如本尊位而得悉地也。若行者依此八印真言及漫荼罗。相应而配住位。若能知此将近悉地。不久而得。如本尊住者。前虽配秘密漫荼罗。若请本尊。谓须作此法方乃可得也。若不作此则未圆也。此经皆前后相成。共为一事绮互其文。行者甚须相照览乃可知也。若行者持诵之时。亦须作此法。谓请本尊及所欲愿等。则得速自建立也。其第一印者。作三补吒虚心合掌。其二风地指直而开张。余如旧即是也。此是毗卢遮那如来大威德生印。从此中如来大威德生。此是一切智智之明也。其漫荼罗作三角形。于其四边又有四三角围绕之。故曰周也【图】。其中当观毗卢遮那世尊而在其中也。其三角漫荼罗。当观八叶华。华台上作三角漫荼罗也。即是前瑜伽座。作此三角其尖向下。其色赤也。前云三角尖向上。今向下者义用殊也。想佛在此中而作威光印也。其真言曰

◇(蓝)◇([口*落])

第二如前作印。而双屈二风指。以指二空指头。合皆如◇嚩字之形。此是金刚不坏印。金刚者是如来智。非从缘生不可破坏。故名金刚不坏也。其漫荼罗形圆如◇嚩字(是波字第五声)以金刚围之(当是金刚有炎光也)。问其金刚。亦在漫荼罗四边。如上也。所谓嚩字者此漫荼罗正圆而白耳。亦在花台之上。其中有大日如来。以下皆效此也。然此八印。持诵者随取其一。随事用之也。其真言

◇(鑁)◇(缚)

第三印如前作。即三补吒合掌。其二水火指开张。其地风指先以开张。作初割花形。此如来藏印。亦名莲花藏印也。漫荼罗如前作圆月轮。但以四莲围之为异耳。中亦观大日如来。其真言

◇(三)◇(索)

第四印如前第三印。其二地指相并双屈入掌。此是佛音庄严印。亦是万德庄严印也。亦云内外庄严也。如世间人有种种室宅衣服事所等。众宝之具无所不有。以庄严之则名万德皆具。今此若内若外。如来众德庄严皆具也。漫荼罗半月形。而侧以点围之。余如前思之也。真言

◇(憾)◇(郝)

第五如前三补吒合掌。而稍开曲。其二空指开张(稍向里曲)开掌心如掬水像也。名从佛支分生印。谓从如来一切支分而生也。其漫荼罗如瓶形者意取瓶腹即是形圆也以四金刚围之余如前。其真言

◇(暗)◇(恶)

第六印如前。二火指稍圆屈。俱屈入掌。钩曲背相合也。柱此中指也。余依旧。谓如第五印即是也。此是法住印也。其漫荼罗如虹形。有诸色间错。犹如虹之晕色也。其形如覆虹。其下平上有金刚之幡也。从上来诸漫荼罗。有莲有金刚有点等。今此漫荼罗。一一皆取以庄严围之相间错也(更问)。其真言曰。此初字为种子。谓嚩字。即无缚也。勃驮陀罗尼。佛总持。萨没哩(三合)底(念也)末啰驮那迦哩。字引声。迦梨。作益也。谓益念力。驮啰驮啰耶。上谓自持持我也。次谓持他持一切也(此一切属上句也)萨畔薄迦嚩低。世尊也。呼本尊也。叹法。阿迦啰嚩低。谓具形相者。三么曳(释如上也)莎诃。此恐未审更勘梵本。第七印如前三补吒。以二手地空。各相捻在掌内而开火指其水风指。头相合也。二地上火也。漫荼罗虚空形(方形作之)杂色间杂。此是虚空色也。如空中含一切色像。如来大空智含一切法也。其两边各一点侠之。真言曰

◇

此是种子也。此一字行。阿吠驮(一)谓具一切智也。谓己证之智也。费提(二)即以此所具之慧。持惠他人也。莎诃。第八印合掌(掌心相到)已。先左转(转时右手覆而左仰相合如旧也)次右转(转时左覆右仰仍合不散)即是也。此是如来迅疾持印。谓如来秘密神通之力。力持迅疾之义也。漫荼罗同前虚空。但改作青色。以众多白点围绕之。真言曰。此◇字也。加三昧是种子也。瑜伽大瑜伽谓诸佛瑜伽也。摩诃瑜只(上)儞(二)。此真言主住大瑜伽也。未得瑜伽令得之。谓能授与修行者愿。于瑜伽而得自在也。瑜艺诜伐哩(三)欠(平)。空也。阇哩。生也。谓空生也。迦是作也。作此生等于空也。鸡(四)莎诃

复次第一东方宝幢佛　第二南方开敷花王佛　第三西方阿弥陀佛　第四北方鼓音佛　第五东南普贤菩萨　第六西南文殊师利菩萨　第七西北弥勒菩萨　第八东北观自在菩萨　当知此八印。皆毗卢遮那印也。如东方印则宝幢佛印。亦是大日如来印。他效此也(次依已四印也)经中次诫阿阇梨应授法。若未灌顶。一切不得示也。次若调柔人(谓柔和善顺而不卒暴等)次勤精进能有坚固胜愿者。谓能发勤精进。自能发无量大愿弘誓者。次恭敬师长(谓阿阇梨)谓如法华身为床座等。又念恩德者(念报佛恩)清净者(内外俱净也)自身舍者(若求法不惜身命如雪山大士等)虽是入漫荼罗。要有如是德乃可为说。不得辄尔示人也。所以者何。此是如来秘藏之要。在所游方不得妄宣传也。此亦佛教阿阇梨耳。若弟子之位未得许可等。固不在言限。何可妄说。令他轻谤。自招无间大狱之罪耶。六月者举数也。初六月不成。更六月作。展转乃至得成乃止。如说三月亦例可解也。先持诵经六月。若无相更经六月。若有相已方作成就也。若秘释者。六月谓净六根故也。云三月者为净身口意也

    次持明禁戒品第十五

时金刚手。为彼修真言行诸菩萨等。当有持明禁戒之法。犹未说是因缘。是以次复以偈问佛。故言讽诵也。然戒。西方音有二。一者此是修行戒也。谓净身故须行之。尸罗。二者没栗多。尸罗。戒有二。谓本性戒及制戒也。性戒。谓净诸根今没栗多须成就。故制之也。别后服风等也。如律因事制也。今课中戒是禁戒。或云制戒。皆是没栗多也。是长时所持之戒。没栗多是有时愿之戒。谓行者持诵时。或心一月乃至年岁等。此事了时此禁亦罢。故无大名也。今此问中具问二义也。先问云何明制戒。即上二种。云何发起。次问云何修行。谓知是已。修所随所在方。云何修行得无著也。住处而修行之也。问中意者。诸法寂灭无相无有能修所修之相。若有所持即是有着。今云何于修行之中。而即无著得成大果故也。次问修行有时节不。如世间戒等则有时限。乃至声闻受具则剂一形。今此明有限剂不也。然问意者。此戒既是从缘而得。即有始终。然寂灭法无有始终之别。云何相应。设令有智以何为限量也。复次云何持戒者增长威德。谓今依止何处云何修行。以何法而令此威德增长。同于如来一切威德成就也。又问持此戒时方也。问何时得离此等也。云何时方作业法非法等。当于何时而得离也。然佛戒者。即如来自然之慧。非时非方。离法及诸作业。今问何时。而得离此诸事入于一相也。时谓一月一年一日一时等限。方谓所住之处。何处可修宜在何处也。云何速得成(谓如上事)愿佛说其量。谓速疾事量也。既问终始。次问其量。问此离相之戒其量几何而可得也。金刚手言。我已于过去先佛所。已了知此法。今为修真言行者。令彼未来世中。速得成就如来戒故。而发此问。非为有所他求及名利等。今我诚言此心。为人证知耶。唯以如来为证。而我深心唯佛自了知也。既已两足尊为证。固请人中尊为我说也。此为未来众生故。证者仁中尊。此即指佛也。如法相而证。故云如所证也。已上凡有五颂。是问也。时大日如来闻彼发问诸佛持明戒。故叹言善哉善哉大勇猛。今佛以彼为一切众生故问。是以还为一切众生故而叹之。勇者谓能除自他一切障故。又勤精进自心无有休息。处生死中而无厌倦。能除一切无明之怨。以此众多义故名大勇猛也。犹行大愿求大法。起大行成大事。所谓普令一切众生入佛知见。故名大士也。此有情者。梵正音索哆。是着义。犹世间人。深着身心不能暂离也。今菩提索哆亦尔。着此大菩提行。乃至无有一念休息放舍之心。故索哆也。又名萨埵是有情义。以于有情之中能修无上道。能荷负一切诸余众生。即是众生中之无上故。名大有情也。众生随所执着义。今能自出复令他出。故名大有情也。以能持如来秘密故。名金刚手。又名大福德者。是佛叹金刚手之功德其异名也。叹其有福德者。即是积集如来功德也。今从此以下佛亦以偈答耳。所制戒殊胜先佛宣说者。佛又引佛为证。此戒过去佛所说。我今亦如是说也。究竟之法古佛道同。故引此证明无二道也。明制戒发智。制戒正觉住者。由持此戒故。发起真言之行而得悉地也。即以住此持明戒故。即同正觉。正觉是佛之别名。以行如来所行道故。即同于佛也。以此修行故。今世人而得悉地之果。此答云何住戒也。佛意言。如佛所住之戒。行人亦当如是而住。即是三平等故。福智增长故。悉地得成也。自真言等起无疑虑者。当修禁戒若得等引者。自真实谓自持真言手印想于本尊。以专念故能见本尊。本尊者即是真实之理也。非但见本尊而已。又如实观我之身即同本尊。故名真实也。此有三平等之方便。身即印也。语即真言也。心即本尊也。此三事观其真实究竟皆等我。此三平等与一切如来三平等无异。是故真实也。行者修行时。佛海大会决定信得入。若有疑虑。则真言之行终不能成故重加诫劝令不生疑也。以无疑故而得等引。等引者。梵云三摩呬多。即以三平等法。引摄一切功德摄在自身。故言等引也。举此三平等。即是普摄一切功德。照此三事究竟皆等摄入自身。名为等引。又定慧等合为一。名为等引。能住如此真实乃至等引。即是住佛戒也。菩提心法修学业果。若一相和合作业离戒。佛所得智不异。戒一切法得自在者。菩提心即是如来正因(谓心王)法谓心法。即是一切地波罗蜜自在力等。以要言之。一切功德之法皆是也。此法皆是佛之眷属。亦是菩提心之眷。属。如花台之有叶蕊也。此之妙果即同于佛。所谓业者。一向是善业。私谓即如来妙业也。以此修行等同于佛。从初发心乃至戒及业等。皆等同于佛。佛离一切相而住净戒。所谓离诸相一切一味。若能如是离一切相而住于戒。此戒即是佛戒也。其所作业即佛业也。其所得之果即佛果也。以其一相无相离作业故。若行者分别此是戒此是持者此是所持法。以此不真实故。有所得故。即非持佛戒也。又此戒者。即是如来无师之慧也。由住如来智故。即于一切诸法而得自在。以于法自在故。照了一切众生真实之性。亦能如实而利益之。令一切皆等于我也。由住此戒。摄一切法名自在。自在者即是摄取之义。谓自得法又能利他也。故次经云。有性义中通达是也。义者谓善利也。即所谓义利也。常无所著修行。则等瓦砾诸宝者。谓自得一切法自在亦利众生。离于是法非法等种种差别之见。心无所住也。由无住故。等于粗恶及珍妙之宝。心无增减也。尔时行者观五逆阐提。与如来功德等无有异。不生增减。何况余耶。若至观于一切烦恼恶业与如来功德。不生取舍。况瓦砾之与金宝耶。次答持戒量。既有始者可时当终。故佛答言。乃至落叉见诵真言数。常应时月禁而竟者。如浅略有持真言戒。剂尔所持戒剂尔所持数。谓一遍十遍乃至落叉等。或一夜一月乃至年岁。故今此中佛。言当至落叉乃终竟也。落叉者。若浅略说是十万遍。今此不尔。落叉是见也。若见实之时。此真言行即得终竟。不然无有中息之义。非如世持诵者剂尔所。尔所即求其浅末之效也。然此中持诵。应如上先作三等之方便。谓真言身印及观本尊。见本尊时。其心相应而住。无有能动乱之者。又观所持真言。从本尊心中流注而入其口。犹如花鬘无有间绝。即以如是佛之功德自满其身。亦不从身更流出也。然将成满时渐有相现。或如本部中说成就之相。或自身有种种疾苦而得瘳愈。或有诸小虫之类不止其身。悦白清净无诸垢秽。或先钝根劣慧。而今逮得不忘总持。随于一字能演多义。乃至合偈讽诵心无所碍。此是前相也。故佛言若见时乃竟。落叉是见义。亦是成就义也。行者心住三昧得见本尊。寂止正定。假使妙高山王崩坏震动。尚不能间动其心。或种种异相。如菩提场中可畏魔事。亦能安心不怖。乃至魔宫美妙婇女。亦不能倾动于其志令生杂念。何以故。以住真实戒之所持故。当知尔时去见道不远也。或时一切所食之味乃至苦涩皆如甘露。以此缘故其身适悦。粗弊五欲之味不能移之。是贪息相也。其嗔息相者。行人六根渐净故。犹如行大旷野盛热之时。日光沙砾郁蒸之中。忽遇清泉而自灌洗。尔时诸忿害等所不能娆也。复次等金石者。即是三平等也。月时数者。皆是持诵之限也。又落叉是垛义。如射中齐也。如首楞严文殊经习射义。若住谛理任运相应。是落叉义也。复次如上所云。一味一味真实之见难信难解。如来复以异方便世间持诵之法。而助真实见。故次说六月持诵法。然皆是秘密究竟。与前不异也。其第一月当观金刚。是方漫荼罗黄色也。观其自身而坐此中。即以自身而作阿字。其◇字正方黄色。当令内身充满无缺。举体皆是此字也。当结五股金刚印。不须持数珠。其印作虚心合掌。双屈二水。以右加左相句掌中。二空双并出。二风句屈向中指背。即是金刚手印也。当于一月中。但服乳不食余物。但观所持真言从脐而出从鼻而入。如调喘息无异。尔时但观以此真言而为喘息也。其色亦黄。若观真言。即以一一句为一息。若观种子字。但无间作息也。虽云一月。然一十一百乃至一落叉月等要以见为限。复次一者即是一相一味之义也。见此名满一月。次第二月住于水轮。其轮圆而白色。自想身在中。如上方便手作莲华印。二地二空聚为台。余三指开敷。令火风稍合相并。即前观音印也。观其身作◇嚩字。色白。亦以白真言为出入息。问为观尊◇字耶。为本所持种子作白色耶。是月结莲花印。于二月中但服水而已。余皆不食。所谓服水者但以此真言水入息白乳之字为食也。行者若相应时自得法味。持不复有他食想。但法喜味而充满身耳。严备谓于中坐也。尔时但观此字。不观本尊像也。第三月在火轮中。谓三角赤漫荼罗。住胜上火轮也。观在其中以其啰字为身也。作慧刀印。谓三补吒合掌。屈二风捻二空也。其出入息赤色。三月义如前。谓三月三十日三千日等。以见为限也。此三月中不求一切食。谓不得乞食等。若有施来者。得随意食之。无人施与则不食。但以啰字为食耳。以此方便烧一切罪障。令无有余也。以此义故一切暗尽明成。谓佛慧明也。备谓备具用此印也。第四月在风轮中。是侧月也(与上同)其中色黑。用◇诃字为身。出入息等如上说。此一月中。但饮风而住不食一切食也。此饮风。亦是以诃字出入息为食。非如外道饮气而生也。当作转法轮印。此即是反手相叉。前所作者也。此难作者。第五月从金轮至水同等诸佛。处金刚水轮中。谓作方黄漫荼罗。内有圆白漫荼罗。身坐其中。脐以下黄。中以上白中也。不作印。用阿嚩二字。余如上。此五月中不得食。尽不食。谓断一切食。但以二真言作出入息为食也。自五月以来。修无著离我之行。同于一相寂灭。即同佛也。次第六月处风火轮除一切障。亦是风轮中有火轮。准上事知。下是风脐以上是火。用诃罗为食。得与不得亦一切不食也。迄舍利养。次佛说其功德。行者以此方便行故。一切梵释龙鬼八部。远而敬礼共所守护。来至其前作奉教命。乃至药神等亦来。问其所欲而奉给之。诸持明仙住其左右。一切恶鬼罗刹七母等为人害者。亦远而敬礼。见其身如大劫之火威光猛盛。随一切善愿自在成就。诸为障者皆不得便。犹如大吉祥金刚观音文殊等。无有异也

    次阿阇梨真实智品第十六

上虽广说阿阇梨弟子之相。及方便作漫荼罗度弟子等。尔时执金刚。次复请问大日世尊。诸漫荼罗真言之心。然是中阿阇梨真实之相。犹未广说。今者金刚手。为满足其义味故。更次复问。云何是一切真言之心。为持何法以何方便而得阿阇梨名。又诵持何等心真言。而得阿阇梨名也。次佛以金刚手。能建立一切众生善根满彼真言行故。而观此发问悦可其心。故叹也。知彼众心所欲闻法。而问之。故令欢喜也。尾扶是佛之别名。亦是法王义。谓声便故用此音说也。又复此中真言心者。此心梵音汗票驮之心。即是真实心也。从前以来皆是偈问答。今亦偈也。次答言秘密中最者。真言智者。谓智中智之无上无过也。今我将说此法。汝宜一心谛听也。次云佛子善哉善哉大有情者。佛叹金刚手。欲令彼大众生欢喜故。如是说言。谓随问答。秘有之相最秘相也。从心真言所生智。此最为大。所谓一切心者即阿字也。以一切言音皆从此字为首。若无此阿声。即离一切之语无有可说。当知但开口声。即是◇阿字之声也。上文俄若拏那么(并上声)虽云离阿声。然阿有内外。若外声虽无。然不得离阿字内声。内声者即谓喉中阿声也。当知此阿。即是一切法本不生义。若能如是照了本体不生离因果者。即得常住不生也。此心真言即是无量义处。遍生一切世出世间之法。离一切戏。于诸戏论永息而巧妙智生。此智即是奢摩他毗钵舍那之智。从此智有无量慧方便生。以离分别戏论故。遍一切处也。巧妙智者。即是一切智智之别名也。何等秘密主。云何阿字。是一切真言心也。一切真言心者。佛又自征问而答也。然此阿字即同种子。如世间。佛两足尊说阿字名种子。种子能生多果。一一复生百千万数。乃至展转无量不可说也。然见子识果。因既如此。当知果必如之。今此阿字亦如是。从此根本无师自然之智。一切智业从之而生也。布诸支分者。支分即是自心也。由此心即摄一切身分。离心无身离身无心。亦同于阿字。故互文也。若布此者即同诸佛。谓从字有果果即是佛。能正遍知故名为正觉。由识此字之理性故。得如来名。此字之理性者。即是此心本不生之义。是故一切如是。谓皆同阿字。皆是诸真言也。及安住支分。谓虽加诸字。亦有阿字在中也。又遍住于支分阿字为心。如人有心能遍支分。此心皆受苦乐。阿字亦遍一切支分也。然即是此心本不生之义。佛两足尊说。是故一切支分安住。支分布。如相应依法一切遍授者。次劝行者当布支分中。谓布在心上也。梵云阿伽罗。阿字遍一切字。若无阿字则字不成。要有阿字。若字无头即不成字。阿为头也。遍谓遍一切。一切有事理。谓言说理证。真言理皆遍。故重云一切也。此阿者。如人身支分及内心。此阿一切遍也。若布一切字。无身心即支分不具也。是身支分也。依法如理是布一切处。遍谓遍布也。虽未能遍布一切字。以此阿字为初首。即是遍布一切诸字也。然此阿字。能说一切世间语言。复因此语言。得解一切出世之理也。所以者何。要因此阿字。生一切世间之语言。然此语言不离阿字。以不离阿字故。即知是不离于法体不生。是故因阿字门。是有世间一切法。因世间一切法。得悟阿字门也。又以此心即是遍于一切身分。是故随布在于身之支分。即是依法如理过布诸支分也。是故遍一切字。亦遍一切身之内外也。故今遍应理。是相和合义。犹阿字遍一切字故。即是和合也。即哩比字加于阿字也。然迦字等。若口无阿字之声。则不成字。当知此字本无言德名字。因阿字而得有也。如人无头即一切支分皆死。此迦字等亦如是。若不以阿字为头。即不成亦不名字也。故阿字为命也。哩比得伊伊等三昧声。亦因定发起也。假令迦字若无阿。但于喉中作短裓声。道迦字不成也。以加阿字即成迦故。当知阿字不生。迦是无作。其义即是相应和合成。他效此。经文是故此能遍诸身。能生种种。此种种是毗湿缚。谓巧也。能生种种不思议法也。能遍一切身分也。然字者梵有二音。一名阿刹罗也是根本字也。二者哩比鞞。是增加字也。根本者即是本字。如阿字最初二音。即是根本也。次从伊(上)伊乃至乌奥凡十二字。是从生增加之字。悉皆是女声。其根本字是男声也。男声是慧义女声是定义也。其根本字遍一切处。次诸增加字亦有遍一切处。根本增加不相异也。皆以根本字体有本而加点画。是故根本增加不一不异。犹如器中盛水。因器持水水不离器。此亦如是。更相依持能遍内外也。相应者梵音瑜只。即阿字义。相应即是瑜只之义也。非但阿字遍一切处。从迦佉等乃至娑诃。亦遍一切处。何以故。此等皆是根本音。其根本音即同于阿字。如迦字等。各各有从生增加之字。如迦字中即有计鸡矩俱鸡盖。俱皆是女声也。然迦字体上加于画。则成增加之字。体是慧。而加是定。定慧相依持。合而为一其体不失。止观双行亦遍一切地也。增加遍于根本。根本遍于增加。滋生遍于种子。种子亦遍于滋生也。又此阿等之字。从字有声。如从一阿字。凡一切语声中有阿声者。不得离此字也。从字表而得有声生。以有声故生于支分。能表一切出世间之法。若但有其字。不能诠表于理。要因声音语言得有所表。谓赤青黄白等。东西南北大小方圆上下尊卑等一切事类。方可领解也。然从阿生一切语言之声。当知此声表种种差别。既从本不生义而生。见彼生表之时。即解本不生也。是故声出之时理性即显。本不生与一切从缘生法。互相能生互相表解也。然此阿字。非直遍于身分。然一切非身亦皆遍满。是故从此阿字之心。生种种功德也。今欲说此布字法门。为令行者即于自身。而具生一切如来种种功德。犹如下种子已。无量果实展转相生。故复劝行人明听谛受也

经云。佛子谛听者。此佛子即当应谛听。我今说此布字心经文也。布谓字也。心谓内心也。梵音名苏罗多。是着义也。着微妙之法故名苏罗多也。复次苏罗多者。是共住安乐义。谓共妙理而住。受于现法之乐也。复次乐着妙事业。故名苏啰多也。又以弃邪趣正义故。名苏啰哆也。又是遍欲求义故。多苏啰哆也。次佛答中。心心作余支分布。如是一切皆作。我佛自住瑜伽座者。以心布于心。余者布支分。如是一切作。即同我自身。作谓置也。谓如是作之也。布于心故名心心也。如常说心心者。谓意及末那。今此中义有异。谓以阿字而布于行者之心。阿是一切法心。而布于心。故名心心也。犹此是最初故先布于心。心是一切支分之主。阿字亦尔。是一切真言之主。既布此竟。其余诸字则布于一切支分。如下品说也。然此布阿字法。即是前文所说。先观其心八叶开敷置阿字其上。此阿字即有圆明之照也。将行者染欲之心与真实慧心而相和合。即同于真而共一味也。如是观者即是如来。故云彼若如是作者即是我也。我者佛自指也。又复大我者即是如来。故云即是我也。即是我者即是阿阇梨。非但以此瑜伽故得是阿阇梨。亦以此故得成弟子也。住瑜伽座者。谓四方。谓大因陀罗坐也。金刚轮坐也。住于阿字之上。以此为座。与此真理相应座名瑜伽座。坐此瑜伽金刚座者。即是如来也。寻念如来者。谓观于诸佛。有称此广大智。称即知也。若能依教而知者。正觉大德尊。说彼为阿阇梨也。称此故即是如来。如来即是彼。谓如是名号也。即是其身也。若具斯法。则得广大智成就心。能成就广大智故。得阿阇梨名也。若是阿阇梨者。当知即是佛。即是地。谓能持世间所有一切及报受等种种苗稼。我亦能持一切众生报等。而无分别也。妙音是天名也。金光明云大辩天女。大辩谓舌也。我出音胜百千梵声。故得名也。梵谓涅槃。先大梵是解脱。此中梵是梵志者。谓未证也。梵行谓修梵行者名。当知即是菩萨。当知即是梵天。当知即是韦纽天。自在天别名。正云毗瑟纽。当知即是日天。当知即是风天。月天。梵是帝释。大梵。当知即是黑夜天。即是阎罗。具大涅槃名为梵。尾是空瑟纽是定。是定是佛四神足也。自在谓于法得自在。如薄伽六义也。能除一切众幽暗。谓大悲日也。又嚩噜拏是水龙。由主水故。即是具大悲水能遍洒一切也。如月长养世间一切物。佛亦能长一切众生菩提心也。帝释因百施得成也。百度开四城门广施也。释是百。迦落是勇施也。佛具无量百施。故名帝释也。造立世界主。谓五大天。世外道谓造立世界主。亦是毗首羯磨。我亦生一切心心主。故得名也。迦罗时。三时即是我也。谓阎摩者也。谓将有所去。谓善到恶到也。将至杀害处名阎摩罗。然我将至善处。而杀害彼烦恼也。也谓三乘车。么即我也。是我所立时过三时。皆是我。悉是心也。对彼时外道也。浴言天名。谓净身口意最是第一浴也。说谓外道其名。谓我即是也。即是比丘。即是尽者。即是。吉祥者谓功德天。我亦具一切法也。谓持秘密为三密也。一切智亦外道有此名。我即如实是也。由自证故。非但有空名也。一切见亦是天名也。一切法自在。亦是世传有此天也。我即如实是也。财富者亦天名。谓自在须与即与。佛即是也。若住菩提心及以声智性。不着一切法说名遍一切处。谓一切种智之别名。是具一切智也。云菩提心即是定。从字有声出。以智分之即智也。即是持诵者。真言从我生故。我即是持诵者。亦是持真言者。由从我生故。我持之也。由真言字从我生。我即持故。具大吉祥者亦即真言王。谓我也。即是执金刚。谓持此密慧也。次所有字轮若在于支分。心位心住随便安置也。住于位位即所住也。即是地天。即是妙音天。即是常浴及常梵行者。亦即是常澡浴外道之本尊等。钵罗是解脱义。即梵天也。亦即是比丘。即是漏尽者。即是妙吉祥。即是持秘密者。即是一切智者。一切见者即是。一切法自在王。即是住菩提心者。即是智性。即是一切法中不着。即是一切遍皆说。即是持吉祥。即是真言王。即是持金刚。以要言之。一切大漫荼罗之所布列者。及如来一百八号等。无不即是也。何以故。以此阿字法体常遍一切处故。若能如是相应。即同毗卢遮那遍一切处也。故佛于经中作如此说也。上来说心竟。次布身分。谓于眉间当置◇字。此是一切执金刚所持处也。次于心上四寸许观置◇字。即是一切莲华手部所住处也。我心住一切遍自在。我皆遍种种有情非有情阿字第一命者。谓即以阿字为心。故遍于一切自在而成。言此阿字不异我。我不异阿字也。乃悉遍于一切情非情法。此诸法即以阿字而为第一命也。犹如人有出入息以此为命。息绝即命不续。此阿字亦尔。一切法有情以此为命也

次◇字水说名(谓想嚩即同水也)次想◇即同火也。次想◇吽即一切忿怒持明也。又想◇佉字即同空也(当有诃字即是风。今欠之更问。即是也)所以作此观者。欲布一切字。于是身分。即是一切如来法界之法。万德皆备。犹如坐道场时。非金刚坐则不能胜。今亦如是。欲备一切如来功德。先须用此地水火风。四轮及空。然后作具法也。以能如是第一真实若解者得阿阇梨名。坛中名字虽殊。皆是诸佛功德。为度彼故说也。是故诸佛说一切应知常作勤修者能得不死句。犹阿阇梨以阿字加其身。故即是漫荼罗一切大会天等也。了达其义。即是真实阿阇梨也。次劝常当如是修行即得不死句。是常住义常住即佛也

    布字品第十七

即义与上相连也。亦明古佛道同。引一切佛同说也◇迦字(咽下)◇佉(上齶)◇哦(颈)◇重伽(颊也谓从顶十字直下至喉此中间也)◇遮(舌根)◇车(舌中)◇阇(舌头)◇重社(是舌生处)◇吒(胫是两胫也)◇吒(腿髀)◇拏(腰谓绕腰带周匝处)◇重荼(二臀坐处)◇哆(大便处)◇他(腹)◇陀(两手)◇重陀(二胁)◇波(背也遍之)◇颇(胸也)◇么(二肘已上膊下)◇重婆(臂下)◇莽(心也)◇也(阴藏)◇罗(两眼)◇攞(遍额)◇伊(上)◇伊(目精或目角也此二字先配右后配左目凡一切配有左右者皆先右后左也)◇邬◇乌(两唇也先上次下也)◇翳◇爱(二耳也先右次左)◇汗◇奥(右颊也先二次左)◇暗(成佛句也在顶十字)◇恶(是涅槃义无处所不遍配支分)。若能如是作。即是佛即是一切智。即是资财(具一切法财者也)即是佛子也告之也

    次菩萨戒品受方便学处品第十八

金刚手于经首。已问佛菩萨戒义。佛前说入漫荼罗时为弟子授戒时。即合说此戒法要。先受此戒已。住斯学处。然后合闻如来秘密之行。此戒未造漫荼罗前。即合为说也。佛前说入漫荼罗时。为正说入漫荼罗方便故。未及说之。故金刚手腾前事复问。故经云。尔时金刚手秘密主。白佛言。愿世尊说诸菩萨大有情等句。是具迹义住处义即学处也。修学句具方便智慧。谓众德归趣此人备具此戒也。谓诸方便等得在于身也。普来义也。慧方便等普趣其身。此正译也。离疑惑谓二意也。如在岐路不能进也。恶意无疑虑令生死流转不坏。此以上皆经文也。谓菩萨住此学处故。能令不舍于大悲离于恶意恶意即是疑惑也。即以此戒故。于生死流转中而不可坏。不坏即是常住无能害也。问意言。云故何于生死流转中而得此戒。常不毁坏不可破坏也。时毗卢遮那世尊。处一切以佛眼观一切法界。告执金刚秘密主言。谛听金刚手也。法界佛眼观金刚秘密主告言谛听者。佛以大士请说一切菩萨根本之行。将欲答。故先以如来眼遍观大会者。即是遍观法界也。此中云诸法界者。谓观佛界法界众生界。观此三法界故名诸法界也。观法界。即是一切如来境界众生界者即是一切众生应度因缘。皆是法界也。既遍观已。知有堪任闻此深行之戒者。故答金刚手也。次告言谛听金刚手。今说善巧修行道。若菩萨摩诃萨住于此者。即于大乘而得通达修行道善巧说。若于此住菩萨大有情。而得通达大乘者。此修行道即是菩萨戒也。三世诸佛皆由此道至菩提。故名修行道也。住此诸佛修行道故。诸菩萨即能通达大乘也。何以故。今此戒即是一切众生自性本源之戒。若住此性净金刚戒。自然于一切法而得通达也。持不杀生戒所不应为。谓应持不杀生命戒也。谓加诸生命字。不得断命也。次佛告其戒相。谓不杀生命。不得不与而取。欲邪行。诳语恶口两舌语绮语。及贪嗔邪见等。即是菩萨戒也。此中不杀者。谓于一切有命之类。乃至不生一念杀心。以无杀心故名不杀戒。余效此而说也。初授此戒时。阿阇梨先当授与三归。此中三归者。即是常住秘密之三宝。非是法僧别住。同于有余不了义经。如涅槃鸯掘等中。应引之广说也。又如上文中师为授三归法也。既授三归了。阿阇梨次当劝发其心令生决定大誓。受此十无尽藏。还三遍授之。受已令彼自表白。我某甲。今依十方诸佛及阿阇梨边。受得所戒竟。今日今时我某甲得名为菩萨也。此戒无有时节。乃至尽形受之。尽未来际无有舍义也。若如上所说戒。于一月一年等入道场时。谓行此方便。事了即休等则有时限。然深义说之。亦至见真方息也。菩萨戒略有二种。一在家二出家。此二众中复有二种戒。一自性修行。二是制戒。今此十戒。是菩萨修行戒也。以是善性故。一切菩萨应行之。即涅槃所谓性自能持戒。或云自性戒也。所以谓持者。以生谤故。须将护彼意。又随顺彼意故又须持也。所以然者一切世间诸天轮王。亦有十善法。一切外道亦有十善戒。一切二乘亦有十善戒。若菩萨不如是持者。彼等即生轻慢非毁之心。我等皆有如是善法。今此人自云大士行尊妙行。而无净戒。当知所学非真也。以生彼等疑惑不善心故。即为前人作无义利非善知识。以是故须持此戒也。二佛所制戒者。即是自具方便也。如声闻法中。为欲修梵行尽苦原故。佛为设此方便以防护之。以是故速得成果。今大乘中亦有制戒。所谓具方便智善巧也。以有善巧方便故。今此十善成不共戒。不与声闻外道等共。故经云。善巧修行也。此经十万偈大本。具有授此戒等方便。今未到此土。然金刚顶中自有授法。与彼不殊。当出之耳。如声闻有四重禁。于此中乃是偷兰遮。非重禁也。所以者何。此十善戒。为随顺将护二乘外道故。以善巧方便而具持之。然菩萨自有根本重禁。此中所谓杀盗淫妄。但是偷兰。非彼菩萨极重也。如前三世无障碍戒中。先令不舍三宝。又令不舍菩提之心。此即菩萨真四重禁也。若菩萨生如是心舍离于佛。即名破于重禁。所以然者。如来即是一切善法所从生处。菩萨以自归依佛故。方有一切地波罗蜜等万行成就。犹因种子方得生果。若舍阿字本自然之智。则一切善不得生。故舍佛。即是断一切菩萨之命。而绝其成佛之根。若行淫盗杀妄。但于道有碍。非是绝成佛之根本。故但成偷兰也。以佛不可舍故。法僧亦尔。如声闻经。尚云舍一卷经戒舍七众生一人。即和合义断不成具戒。况一切菩萨。同乘一道而至道场。佛佛无异无别。故当知随有所舍。即断一切法命也。菩提心亦尔。是一切诸行之本。若离菩提心。则无一切菩萨法。故舍之亦犯重也。如声闻经犯重已。即非沙门非释子不入众数。今此中。若舍佛法僧菩提心。即不入众数。如彼二乘毁四重也。然行者自知犯戒。更自洗浣其心而重受之。即还得戒。不同二乘戒。折石断头无再得义也。复次菩萨自有十重戒。如前不杀等不在其数。乃是偷兰也。云何十耶。其四如前所说。更有六重并为十也。第五重禁者。谓不谤一切三乘经法。若谤者即是谤佛法僧谤大菩提心。故犯重也。以秘密藏中一切方便皆是佛之方便。是故毁一一法。即是谤一切法也。乃至世间治生产业艺术等事。随有正理相顺是佛所说者。亦不得谤。何况三乘法耶。第六不应于一切法生于悭吝。若犯毁重禁也。以菩萨集一切法。本为一切众生。若有所秘惜。即是舍菩提。故犯重也。第七不得邪见。谓谤无因果。无佛无见道人等诸邪见。皆是也。若生邪见。自然舍佛法僧及菩提。故犯重戒。而声闻但得偷兰。是故当知方便不具足。但是随一途说也。第八于发大心人。从前劝发其心。不令退息也。若见其懈退而不劝发。或阻止其心。若令离无上菩提之道。即是违逆一切如来所应作事。故犯重也。第九于小乘人前。不观彼根而为说大法。或于大根人前。不观彼根而说小法行。犯重禁。此即是方便不具。以违逆如来方便故。差机说法为人天怨。故犯重也。第十菩萨常当行施。然不得施与他人害物之具。谓施酒施毒药刀杖之类。一切不饶益他之具。即犯重也。以菩萨常行利他行。今则相背。故犯重也。当知前不杀等。是将顺他人意。又初入法者所持之戒。今次说十事。乃是一切菩萨正行之戒也。若菩萨以正顺后十戒故。假使行前十事中。而不为犯。次佛言。秘密主。如是修学句。若菩萨随所有修学。即与诸佛菩萨同行。当如是学。声闻以近彼佛戒等名近同。今与佛同等也。修学句。菩萨随所修学。诸佛世尊及菩萨同事。应当学者。此身三口四意地之三。即是一切菩萨修学句。是一切菩萨学处也。此即是一切菩萨随顺众生戒。随顺即是同事也。又一切佛菩萨皆如是行。以一切菩萨法尔当行故。今我亦如是行。即是与一切佛菩萨同事业也(更问)此本性戒自然合行故涅槃云性自能持戒也。次金刚手问意云。尔时执金刚秘密主。白佛言。世尊于声闻乘。亦说此十善业道。世尊于世间人民及诸外道。亦于此十善业道。常愿修学。常愿谓要心常持。即受戒之别号也。转具者。具谓具此戒。转谓皆也。皆具行也。世尊彼有何差别。云何种种殊异也。声闻缘觉亦有十善戒。亦谓息世讥嫌。及性善故持之。一切外道世天亦有十善戒。今佛复说菩萨戒者。但十善即是。然则有何差别耶。故佛次为分别之。叹言善哉善哉秘密主。又复善哉。汝能问如来如是义。应当谛听。今当为分别者。分别有无量。今合为一。今说此法门也。能问如来如是之义事次答也。谛听当分别道一道说法门者。谓一切法不出阿字门。即是一道也。道者谓乘此法。而有所至到之义也。一道者即是一切无碍人。共出生死直至道场之道也。而言一者。此即如如之道。独一法界故言一也。于此一道中。而分别种种差别。犹如无量岐路皆至宝所。殊街同归也。又如以一阿字门分别一切字。当知虽有差别。不异阿字门。今此十善亦尔。随上中下智所观自成种种。非一切众生本原戒而有差别也。然佛为破大众所疑。答金刚手所问故。亦于一道中而分别。答其差别相耳。此分别意云何。佛言。同一如我所说。声闻学处离慧方便。教令成就开发边智。非等行十善业道不无其异也。故次言若声闻乘学处。我说彼方便教令。成就边智开发。非十善业道等行者。此答其与大乘别也。彼声闻十善。但是教令成就。犹如国王有所约敕。自今若行如是事者。当与如是等罪。彼人以畏罪故。顺而不逆不敢违越。声闻亦尔。以佛所制威德波罗提木叉教命。尊重法王所制故。不敢毁犯。非是具足方便自性能持。又但为自持。非为普顺一切众生。是以但是一边之智。非中道实相之戒。是其差别也。诸外道我复不着他因。复次世间离执着我故所转者。次明与外道异也。彼宗所计。我神等而生一切。今我此身乃自非我。是大我所生耳。若是我所生者。善恶因果皆因彼出。今此身心即自无我。持戒之果为谁而转修。谁受其报耶。当知因果义不成。故犹如无种子之花果及石女儿。能以空花为鬘无有是处也。此石女儿喻。捡佛性论意具说。复有着于断常而行十善法。若常则无果报。今持十善依何而住。若断者亦无果报。亦何依耶。故十善名同。如虫食木偶得成字。不可比也。次明大乘十善差别之相。若菩萨戒者。以方便智摄一切法。平等入当勤修习。言此戒入一切平等法。离于自他而普净自他。自开一切如来知见亦尔。一切等同于我。以入一切平等法界而修此戒故。与一切不共也。佛次更欲广说菩萨十善戒相。令真言行菩萨无有疑惑。故以大慈大悲眼。眼观察众生界。告金刚手言。此梵音眼。而有二名。今具存之。以慈眼悲眼故重说二名也。先说不杀相。谓尽形寿乃至舍一切刀杖等。杀法杀缘杀因杀业等。凡与害命相应者。皆远离之。观一切众生内怨之心。悉同于己。乃至有形之类永无害意。然不但以不杀成持戒也。当谓其方便慧。谓观此人必造五无间谤法等缘。当增重障无由出离。以大悲心筹量。若害之能利多人。或令彼有出离因缘。宁自入恶道。谓将护彼。以大悲心而加害之。此即方便。非彼二乘共也。次盗亦尔。虽一切乃至草叶不取。亦为破彼匮乏因缘。观彼聚积无厌。由此自损成大障业。乃至方便取之。为修种种功德。然后告之令彼随喜等。如是种种方便。但随顺深行十戒之行。以大菩提心而为导首。一切无犯。此是持犯之相也。前已略说杀戒。次牒更具说。秘密主菩萨尽形持不杀戒。当舍刀杖离杀害意。护他之命如护己命。余谓有异方便也。谓余方便也。随诸众生类中。随其事业为免彼。故云随彼业而作之。殷勤修之。令彼免报应离怨害意也。形类是众义。如彼类造极恶事极重业。欲免彼故。假令行刀杖等无过也。声闻戒亦有对小罪除大罪以轻易重。故今亦尔。如救水中女人等可知也。菩萨戒准亦可知。尽形持不杀命戒。当舍刀杖杀害。如己同他我生命护之。余类众生如类物。脱自形类。作而受报。应离怨恶意者。此第一戒相也。尽形者非但一期而已。若菩萨从初发心及成菩提。一切有命之类。尚不生一念害心。况起身口耶。其所有随缘杀具。如杀戒中种种广说之相。亦乃至一念不畜。况施行方便杀耶。恼害心略有九种。谓憎我身。及恶我善友。好我之怨。过去未来现在为九也。又有一类。于非情生嗔。如迦叶佛时一比丘。经行为株机所倒。大怒引鑺掘之。为刃所伤自致殒弊。即于须臾受毒蟒身。时彼弟子同学等。方焚其身时。后身毒蛇在彼焚处遇佛。以因生恶心欲害之。时佛教诫彼。尔前身以忿非情故。自致此报。今又甚彼。将更受恶身也。其后不久有童子等。以彼害人。即共杀之而焚其身。彼又以见害忿怒及欲害因缘。入大地狱。即于焚故身未了时。后报二身同时被见烧。当知此是于非情处生嗔。所获报也。又如律中。比丘经行。伊叶刺额血流。怒言。佛何故乃制此戒。有何义利耶。因掣异方。谓是缘生受大苦。蟒身五百商人。为护他故。以大慈悲害蛇。令蛇免罪生天。商客悉患勉也。断之如有部大律说也。非情处尚尔。况有情处耶。菩萨观此事故。自不生心亦劝他离也。余如前说。金枪缘广说。又师子救贾客害蛇因缘。在宝藏经大方便经等。复次菩萨持不与取戒。他所摄受用物取不起心。况复余物不与取。诸余有情见悭悭不施与。无福作随类形。众生悭害已彼离施。为彼与时如是持不取戒(对不杀广说今此戒亦然)若他所摄受用物。不起触取之心。况复余物不与而取。有余方便(虽不言方便义亦有之)见诸有情而极悭吝积聚而不施与。不造作福随众生像类。害彼悭故离于自他。为彼行施得妙色等(谓劝发他施也)

大毗卢遮那成佛经疏卷第十七大毗卢遮那成佛经疏卷第十八

        沙门一行阿阇梨记

    受方便学处品第十八之余

若时菩萨发起贪心而取之。秘密主菩萨有退菩提过分。于无为法毗尼有过也。施妙色等得。有菩萨贪心发起取者第二戒也。一切他所摄物。义如毗尼广说。乃至不生一念取触之心。乃至菩提欲心尚不生。况作方便取触耶。然菩萨有方便触取。谓见有众生不信因果不行惠舍。于所有物封着不能自割。又生此心。何处有施福耶。以如是故。种种方便引化皆不能得。尔时菩萨以方便。盗取其物亦不生入己之心。但为彼人故作种种福事。因方便招召令观见之。使其发希有心。此大士乃能于物不吝而以与人。我自观己则不逮也。如是渐次菩萨又方便说施物之利。有如是如是果报。彼能渐信伏。亦于己物自不能舍。菩萨后时观彼心渐通泰。如法之告言。我昔来所用施物。乃汝物耳。以汝不能自用。犹如收谷而不更种必致穷乏。先福已尽更无所望。故为汝用之。今先施福皆是汝有。如先佛说。凡施当获妙色力安无碍辩等种种大利。勿谓无福也。以是因缘。令彼出恶道饿鬼之难。成菩提因当知菩萨以具慧方便故。能作斯事。二乘外道所无有也。随类者。谓有如是一类众生。宜以此化也。又次随类者。非但此一方便。更有无碍妙方便。以要言之。以能令彼开佛知见。而有导首。非为余事。此相甚多不可具说。当随此况之。举一例诸。则可类解也。菩萨害其悭者。害是对治义。如言永害随眠。今亦如是。害彼悭结也。然此菩萨实不生贪物自取之心。若取者。即是害菩提支分也。由此贪心故。害于成正觉之缘。令支分不具。故云害也。亦即是越菩萨毗奈耶也。草结比丘云。佛所制戒我不敢引之也。有为戒者。此是修行方便。故云有为戒也。然无为戒者。即是本性戒。非是修成。对此有所行之方便。故言有为。然深观即同无为戒也。以不离阿字门故。次不净行戒。云菩萨持不邪行戒(此中有重犯云皆是持不犯意不异故不注)他所摄自妻自种族护自贪不发。况复交会非道。菩萨持不邪行戒。若他所摄自妻自种族标相(谓尼等即是自种标相也)不发自贪(谓心中事)况复非道二身和合。有异方便色类事准上也。及二形相向。余色类事。此第三也。他所摄谓他所有妇女姊妹之类。如律十种护等也。然菩萨有二种。若出家者一切欲心尚不得生。何论他护及非时等。然亦谓解相故。律具言也。若在家菩萨。于自妻非时等即名为邪行。如智度于尸波罗蜜中具说也。又非时非处者。如近塔尊明现之处皆是也。以明中即是对天神等故亦制也。自种族者。谓同姓不婚等也。又族者。楚音亦是标帜义。如西方法。若女人炫卖女色。自官许。已有人与彼若干物。随尔所时即是彼所摄也。然彼有人时。即于门置标令他人知。异人见之即知彼已有所护。若固尔干犯即同邪行也。自贪不发。谓尚不应与贪染之念相应。况非道行淫。及正境等而和合分剂耶。然有异方便为成彼大菩提因。则有犯义。不同声闻也。如大本菩萨戒说。有菩萨从生已来修童真行。未尚面睹女色着心。当于山林修道。后年十八。因入村乞食。有童女见其端严美妙。生欲心告言。我于仁者深生欲心。仁者行妙行。正为利一切耳。若我愿不遂恐致绝命。即是违仁本愿而害众生也。彼菩萨种种呵欲过失。彼终不舍。以不获所愿因即闷绝。时彼亲属念言。必是夜叉也。形貌异人。我女见而躄地。将不夺彼精气耶。共持刀杖执缚。将欲害之。女少苏已见之。即具告父母因缘。彼言是女之过。非比丘罪也。即便舍之。女又追随不止。比丘念言。若彼不得所求。必自丧命而入恶道。遂从彼愿多时和合。伺彼欲少息时。以法劝导而说法利彼女。以深爱敬故。即顺其命共修梵行成大法利。然此菩萨但以大悲方便。能以下劣忍于斯事。而非欲贪所牵而作非法。若不由大悲。但以欲邪行心而作。即是犯戒此也。即是具智方便故尔。随类者即是指前义也。同盗戒故不广说。例可知也。如经说。群贼捉得紧那罗女施菩萨。受之。因此得财无量。时行施。又如美发菩萨乞食。女人见闷绝。为护女故(上疑是药叉之因此念菩提心不舍众生故)恐离菩提心。因受为妻。久后劝导同发道心。眷属亦发心生天(善巧方便灭罪行也)次持不妄语戒。尽形存活因妄语持不妄语戒当尽形寿(回文向上)设为活命因故。不应妄语。即成欺诳佛菩提。秘密主是名菩萨住最上大乘。若妄语者越佛菩提。是故秘密主。此法门应如是知。舍妄语业所不应为。是名欺诳诸佛菩提。秘密主菩萨最上大乘。若妄语者越失佛菩提。秘密主法门应如是知。不舍实语。此第四戒也。活命因者。即是种种名利事等。或因余饮食衣服囚禁苦厄如是等。如作妄语即身命存。不作即有待之形将不存立。故名活命缘也。菩萨有如是因缘。尔时尚不生一念欲诳他心。况起方便耶。然略说有八非圣语八贤圣语。谓不见言见。不闻触知而言闻触知。见言不见。及闻触知而言不闻不触不知。是八非圣语也。反此即名八贤圣语。谓见言见。余三亦尔。不见言不见。余三亦尔。如毗尼说也。五分大妄语戒有。若菩萨如是犯者。即是谤佛菩提。何以故。菩提者即是一向实义。而今此乃妄诳之因。正与彼相背。故名破菩提也。复次如来无量劫修谛诚故。所可言说。人皆信受。乃至说不可思议法。非彼心量所行难信难解。以佛无量劫诚实故。人亦信之。今菩萨而诳众生。即是生彼诳法因缘。亦是破菩提也。是故菩萨住此最上大乘地真言之行。不得生一念诳他之心及彼种种缘。具如律说其相。若违犯。即是越佛菩萨也。此亦合有随类方便语。文无略也。如菩萨戒大本中说。有一女人杀害父母。作此无间业已。自念。我此恶业决定入无间狱。极恶已成。更有何等善法来近我耶。以此因缘故。更不改过修善。但静然而住拱手待罪。菩萨种种劝之令忏悔修善。乃至告语大乘法中有方便可灭此罪。终不信受。菩萨生大悲心。又化作妇人投彼止宿。因自说。我亦作如是业。彼妇人自念。余人亦有作此事耶。我今得伴可共同止。如是多时。彼化人渐以方便。欲共改悔行善。而不从彼说。谓言汝必欲作便可作之。然我自念终无益也。彼化人即于彼同住中。示行善事渐获法利。具大神通而示见之。告言。我今行善。先罪已灭今得此法。若法罪不灭。何由能获如是事耶。彼生希有心言。彼与我同犯。彼尚能除。我何不作。因与同行。菩萨方便化之。罪垢得除渐入佛法。此即是菩萨慧方便故。能如是持戒。非二乘世人共也。又僧伽吒经说。有一大夫。其妻艳丽婉美尤相爱重。后时命过。情不能舍恒负之而行。乃至枯朽而不肯弃。菩萨化之不得。因化作一妇人。亦负一夫云。此人我所爱念。而命终尽情不能割。故恒负之彼念言。此则我伴与我同事。因共止住。后时菩萨伺彼。方便即弃彼二尸于恒河水。妇人及彼觅尸欻皆不得。便叹怨云。我等负之乃至枯朽。今见异伴。遂相与结爱而弃我等。当知其情不可保也。鬼尚如此。况生存乎。彼见此事变心顿息。即发心厌欲修道。菩萨有此慧方便故欺狂。非是恶心而作也。次粗语戒。菩萨软细心信受摄众生。复次秘密主。持不粗恶骂戒。应当以柔软心摄受诸众生等　随彼像类语言(回文向上谓随顺言也)秘密主菩萨初行。所谓义利众生(此行最先也)或余菩萨住恶趣因众生。而作粗语等。随类形语言何以故。此是菩萨初行。为众生故。或菩萨恶趣因众生住粗恶语。此第五戒也。粗者。谓有所言说。能令彼心不顺。令生不善之心或高声现相。所谓粗犷等。皆是如毗尼说相也　菩萨常当柔和善顺而不卒暴。所可宣说悦可前人心以此因缘。能渐渐摄彼令入佛道。而今作违恼之因。即是乖背四摄方便。故犯罪也。然亦有方便而作粗语。如菩萨戒大本有一人常行粗语以为常性。一切无能化者。菩萨化作一人。所行崄暴躁恶。更过于彼无量倍数。彼见已欢喜。此人所行皆胜于我。我当自谓无与等者。而今彼所作事堪为我师。因请言为汝弟子。同事已久。菩萨渐示厌离。稍叹柔顺行呵粗暴事。后自改已劝彼令改。而犹未从。菩萨后时以示舍恶行故。稍自修道得大法利。现示神道。彼发希有心。此人所行先过于我。尚能自改而获此法。我何不为。又以彼为师而入法利。即是菩萨以慧方便而示粗恶也。次不两舌。复次秘密主。菩萨应持不两舌戒。离离间语离恼害语。若犯非名菩萨。菩萨不生离间众生心。或余异方便。见有众生随所见处而生执着。随彼像类作离间语。令彼住一道故。所谓住一切智道者。菩萨无离间语无恼乱语。犯者非菩萨行。于诸众生不生离折心。或有情随见处而着众生见。彼随类作离间语。如令众生住一道。谓一切智道住。此第六戒也。两舌之相如毗尼中具说。乃至野干师子因缘。云云。然菩萨常修无恼害行。随上中下类。皆令欢喜和合。不作彼别异因缘。然见有种种异见众生。各着所宗不能自出。以此因缘方受大苦。菩萨尔时为引彼令舍恶知识故。而作离间之语。如过去有外道师。领徒千人说邪道法。菩萨观彼有堪化因缘。入彼秘法中而作弟子。不久学法皆尽其奥。慧悟绝伦。彼师叹尚此人传我法已毕。乃分徒五百令彼领之。尔时菩萨渐以方便。入彼见中而稍化之。经久知彼于己深生信伏。渐示深法。尔时五百弟子见心渐正而成慧性。时彼师闻其法异。来观闻之。彼因种种开示师亦悟解即时五百人亦师菩萨而受新法。于是千人皆入正法。如是等类。即是方便破彼和合也。菩萨行甚广不可具说。举一例诸其随类可知也。次绮语戒云。秘密主菩萨持不绮语戒。随彼类语时方和合者。当持不绮语戒。随彼形类有所言说。时方利益。彼方有此语当说。违律者不应说。随彼方相应和合也。出其义利。谓令彼有义利也。出谓作也。谓行此义利。随方随时作也。令一切众生得欢喜心净其耳道。谓耳根净也。何以故菩萨有殊异语。谓差别种种随他意语也。有菩萨异方便。以戏笑为先。欲令众生欢喜住佛法中。为众生故。虽出无利语。处生死中利益众生。其谓种种备具也。处生死流转而无所著也。和合出利。令其一切有情。诸心喜悦耳道净除。何以故殊异语故。有菩萨以此笑。先令众生欢喜安住佛法中。欲无利语除弃语不出。如是菩萨生死流转。此第七戒也。绮语。谓世间谈话无利益事。如毗尼中说种种王论贼论治生入海女人治身等。或城邑国土是非评于世间事。以要言之。一切顺世间法无出离因缘皆是也。然菩萨应当时方利和合语所谓时者。虽欲开导于彼。然彼都未有信入之机。诚乐未发辄尔说之。令彼不信。慢毁谤已亦无有化。即是非时也。反此名为时语。或大众闹乱多人之处其心不静。而委有所说不入其心。因失道缘亦非时也。方谓非处也。谓彼正造恶时。即于彼所作之处而为说法。以彼方着所行之事。反生背忤之心。因生彼不善之心也。亦反此名随方语。利者谓一向无诸不利令修善。顺彼情机而出言也。若菩萨如是行者。能令有情欢喜信伏。自益益他也。以彼闻己得利己亦不唐捐其功故也。然菩萨有殊异(谓异方便也谓异于前也)谓笑为初首。如戏笑者。乃至歌舞伎乐艺术谈论。即是前所说种种世间有也。菩萨为令彼欢喜。既得欢喜其善顺悦。因匠其情方便化导。令其安住佛慧。虽了知无益心不生着。然观时观方。义利故而有作之。虽作无利。然以无利而除彼无利之事也。以彼先时造恶恶与道反。直尔舍置方便而急持之。反更惊拒。故方便同事彼后即令入佛道。故此无利即是有利之因。如大良医然变毒为药也。若如是作者。乃是菩萨出流转生死之因。不应同彼声闻无方便慧者。一向拘[尸@句]唯遮诸过。无开通之行是故不慧满足也。自出流转亦令他出。故名离流转也。如花严说善见女人即是也。为欲引摄众生故。生淫女家。于五百淫女而为上首。妙丽绝伦具诸女德。六十四态一切妙巧方便皆悉具足。夫女人本性善摄人心。而此女人又无种不具。以是因缘趣之者众。菩萨先以方便力故。同彼邪行因缘。令彼极生爱念。有所言语人无违者。观彼情机随缘开导令见欲之实性。即从此门而入佛慧。时彼诸人以信爱彼故。即能谛受其言。以是因缘所利无量。虽在非利之中。为能成此大利。即是菩萨具慧方便持戒也。经中此类甚广之(菩提三藏云漫怛罗是密语也西方若二人别语更有异人来即相简别或有人见彼别语云勿往于他密语此名漫怛罗也)复次秘密主。菩萨应持不贪戒。于受用他物之中不起染思。何以故。菩萨应常作无著心。菩萨若有是心者彼于一切智无力。无力谓退息也。由斯法故。于一切智无力而住一边。即不具足义也。又秘密主。菩萨应发欢喜生如是心此亦同也。我所应作今自然而生。善哉极善数数修异方便。不令彼诸众生损失资财也。持不贪戒。复次秘密主。持不贪戒。彼他受用中他物中不起思染。何以故。无菩萨受心。有菩萨思染心无力彼一切智门一边。亦秘密主。菩萨欢喜起如是及发此心。若我作彼自然而生。彼善极善数数而欢喜。不令损失资生彼诸众生此第八戒也。前者已明身口戒已。今乃次明一向心戒也。此是从心所起之贪也。若菩萨见他有种种胜事。谓色力财富之辈有无量门。菩萨不生思念彼人有如是事而我无之。以是因缘而生仚羡有所欲愿贪着躁求之心。皆亦此戒摄也。由念此故又当生于受恼之因故不为也。菩萨不应如是。若有无力者。譬如有人具无量方便艺能。有时病患则无所能为。菩萨亦尔。若以贪爱而病其心。令菩提心无量力势皆能无力也。一切智者。即是万德皆备无所缺减之义。由起此心。令此万德无缺之体支分不具。是故于一切智门。即是无力也。然菩萨见他有种种胜己之事。当自庆悦而作是念。我本立大誓愿。为一切众生故。行菩萨道皆使万德兼具也。若此等有所乏者。我尚欲不惜身命难行苦行而利乐之。而今自能成办。即是我之大利。诚可欢庆也。菩萨以此自安慰其心。我所应作。自然而至故欢喜也。我为众生故。尚欲以无数精进。求贤瓶劫树自然之用。破彼穷匮之业。何况彼能自致。而更损之以自利己。以此悟心不复生着。即持戒之相也。如长阿含中说。过去俱流孙佛时。波罗奈国王名思利(或云思益)以常思利益一切故以为名也。时有五百大臣而白王言。今者国土极为丰乐。人心盈满无思难之心。恐不可以应敌。王宜以事授之以习劳苦。则堪犯难庇卫王土也。时思益王仁甚慈忍而作是念。我云何以非时之事而加于人乎。乖我本心无此理也。时群臣知王正意遂不复言。帝释知之而作是念。此王所行乃菩萨道。未知坚固以不。我可试之。因告邻国王长手令其伐彼。此长手王所王。亦名五支城。以其统摄之境但有五城。是小国也。彼闻帝释言而作是念。我闻妇人之仁思不及远。今此王所为过于仁爱。犹妇人耳。今我兼而有之。寻兴四兵往伐其国。诸大臣白思益王言。先以忠谏而不见纳。今人不习武又无其备。难出不虞将若云何。王即思惟而答之言。彼所欲有国土人民及府库耳。我不与争。则又于人无害。卿等勿忧也。寻即挺身而出。往深山中而修梵行。时长手王无血刃之功而有其国。经历多时购求思益王。而不能致。时南方有梵行婆罗门。以先业故极为匮乏。无以奉养父母师长。闻思益王好行惠施故。往投之求自资给。行往彼国至山林间。遇到故王修道之所。时思益王先意问讯召令安处。给其食物温问劳苦。今何所往耶。彼梵行者具答所由。尔时故王闻已愍然不悦。我常享国势力自在能随给人。今罄身失国何能满彼也。思惟是已因告婆罗门。思益王即我是尔。今已失国故在于此。时婆罗门闷绝良久而念言。我薄福故远求冀有所得。而复邂逅岂非命耶。时王慰喻尔勿大忧。我有方便可致耳。彼王以我是怨敌故。常见购求。若人获彼首者重加赏赐。汝今以我首往。必大见酬赐也。彼答言。我净行者云何杀人。甚不可也。王言若尔者。但以绳系我而往。于理无失。时彼即系至王门。尔时旧臣等见已。皆共嫌责婆罗门。尔净行者。而不应募害此贤王以求自利。深非道也。破净法矣。何道之有。彼即具言非我之咎。是此大王行菩萨道使我为之耳。诸臣寻入白王。王卒闻大惊。以为来夺其国。及闻说始末心生愧伏。如是行菩萨道者。而我夺其国。何以长人而王天下。因告思益王。可复本位自在行施利安万人。我当反于旧国。各复其所无相侵害。尔时二国交好无复怨敌之患。如是等本生经当广说之。此即不贪因缘也。次不嗔戒。秘密主菩萨持不嗔戒。复次秘密主。菩萨应持不嗔戒。彼遍一切常当安忍。不着嗔喜其心平等。彼如友等怨而转。何以故。菩萨不应忆念恶意。谓功德在身名三摩耶缚揭多。律中大德存念意亦同也。所以者何。以菩萨本性净故。上本性是性得戒。下云心者。谓从心所变现之法。于本性中常清净故。是故菩萨应持不嗔戒。彼一切遍忍多。常喜嗔不着。平等等心。彼如友等怨转。何以故。非菩萨此意恶具。以是故菩萨本性清净心。是故。秘密主持不嗔戒。此第九也。嗔谓于一切众生起于害心。不饶益行从心而起。所以持此者。若菩萨有人来。种种加害乃至断截支分。尚不生害彼之心。而向轻于此耶。若不尔者非菩萨也。应遍一切处而行大忍。若他种种加害时。应自念。我先世无明因缘。生此有患之身。又无量世来常恼他故。今则业熟而受斯报。何预前人而怨咎之。如是种种正观。又念此身从缘而生。无有自性无有我人。谁害谁受。以此观于实相。而不生害彼之心。此是嗔忿之念。即是众恶之具也。以能如是欢喜故。心常欢悦善寂慈忍。不着我人诸法而常平等。此平等者即是怨亲不二。有益无益轻重之类。一切平等心无增减。而不生心造诸恶具。常行饶益利他之行。等观世间犹如一子故。以此菩萨正观实相。照了此心本性清净故。如经说。过去南方有王名曰师子。城名丰乐。正法理国不害于人。然以王国法故。出城校猎示现威武。虽无害人之意。为护国土安万人故。欲令邻国怀德畏威也。时王挍猎。见有奔鹿而自驰逐。绝山履险要令及之。以无害心故。既及。但鞭其角寻即舍放。何以故。欲示武艺威万人故。既入深山无人之地。侍从不逮乏息山中。有母师子。见王形貌异人而生欲心。因来逼之示现欲相。王畏彼故寻即和合。时劫初兽等亦解人言。然女物之性若有慧者。受胎之时则能了知。因告王言。我已怀王之胤。后有若诞生当云何也。王以手所持印留遗之言。若生子可系此置我门侧。后既生儿。体貌类人而甚猛毅。以兼兽性故也。其母如先约。夜逾城置王门侧而去。明旦阍人见之尤生怪心。云何似人而复少异。我当白王。白已。王默念之不以告人。因敕令为己子。字曰师子善奴。王后厌于国政因使摄国。以本性故好食鲜肉。一时急求厨膳。膳夫求肉未至。遇有新死小儿。即以为食进之云云。如贤愚经智度论说。乃至日日令求人肉。已食小儿数逾五百。城中共相告语。必有夜叉入国。凡诸小儿当谨护之。日未及暮。皆持入室守护甚严。膳人求之不得。又往大臣等家取之。又失五百。后一时持死小儿。而臂钏在其人手上。见人见识之因执缚。谁执事者。此人盗小儿。当知前后所失必是此人也。因彼首伏乃云。王之咎非我也。群臣以白父王。今太子犹有兽性。兽性不可为主。愿王自理国。王言我己灌顶而授彼位。云何夺之。不从所请。群臣遂谋欲害之。彼因持利刀遁入山中。初时取死尸焚食之。后渐食人。乃至执王子五百。常求肉饲之渐取而食。时国人立其弟为王。名为善奴。慈人惠和正法化理。后有四梵行者求上善法。王念言。此人利我不少当后报之。未及与彼而出羽猎。群臣谏言。兽王近在山中。或能为害王勿出也。王念言。我欲利一切不爱其身。今若取我而食。乃吾本愿满也。遂出至林中。彼见兽王闻弟出故。即来取之。猛健故。诸婇女等皆悉散走。为其所执乃至悲泣等云云。如智论说。未报梵行者之意。与共约而放之。王言汝火未尽当必还到(以彼先焚薪待烟尽方烧人而食也)彼念以法何故。乃能不惜身命而来赴斯。因问之。彼即欲不杀行等如法广说。彼虽猛恶而有慧性。闻即悟解得未曾有。念言彼即我师欲求何愿。王言汝今在林野中犹如猛兽。何能满愿耶。答言我以念师恩故。要有所报必可说之。王言若求愿者。我之本怀唯在不杀。所愿在此耳。彼即许之誓不害命也。又放五百王子而修善法。放已与王同归。王知彼已行善行。还立为王使正法化世。而自出家。当知菩萨于如是怖畏之中。尚不生嗔而彼作利益之行。况余事耶。如是本生等经中当广说之耳。第十邪见戒。复次秘密主。菩萨当舍离邪见住于正见。观当来世而生怖畏。当无害是随烦恼。问东答西问西云东者也。捡问之。无曲无谄其心端直。于佛法僧其心决定。决定谓乃至归命三宝也。是故秘密主。邪见最为极大过。能断菩萨一切善根。一切诸不善法之母。如悉昙字母能生诸字。邪见亦尔。能生一切不善也。是故秘密主。下至喜笑因缘。乃当不起邪见之心。复次秘密主。菩萨舍离邪见。彼正见他世见。无害无曲无幻。端直佛法僧心性决定。是故秘密主邪见离。诸过菩萨一切善根断转母等。如是一切是不善诸法。是故秘密主。乃至戏笑观看亦不起邪见。此第十戒相也。经持邪见戒者。邪见是不善之本。谓害此邪见而持于戒。故云持邪见戒也。承上九戒亦例此。可知应言持不杀戒。乃云持杀戒者。亦准此说也。邪见谓各各于其本法之中。即见理不正顺于邪道者皆是也。此是害三世善之根本。谓由过去行业。而有今世五阴依止之果。复由今世行业。而有未来果报。由先了此因缘法故。得入无常无我等门。从此无常无我之智。得入法空如实相。当知离此世间正因果。外别无正见正慧也。若谓无果无因。即坏三宝四谛法。以坏三宝四谛法故。无四沙门果等一切圣法及世出世善法。今尽拨无此事。即是外道宗计也。当住正见。谓即翻前非。决定正信因果谛实之法也。谛者即是如来真实句。若谤此。即是害一切善也。无害之害者。害谓烦恼支分。由此故能见障一切善。障一切善故名害也。次转释之。云何无害。谓无曲也。曲即邪见也。犹如蛇未入竹筒所行屈曲。见心亦尔。若未入诸法实相道中。则曲而不正也。次又转释。云何无曲。谓同于幻等。观此心实相。从缘而生犹如于幻耳。以其达实故离於戏笑。离戏笑者。即是无幻也。若如此者。即是住于端直之心。于三宝境界心常决定也。以入实相端直道故。即是于三宝中。常得决定之性也。是故劝诸菩萨。离此诸过之根本也。以不善所谓能害一切善法之根本也。以善故菩萨持戒当离此过恶也。转谓徙恶为善。如经说。若无明转即变为明。今邪见亦如是。举体即是慧性。为若转令端直即是正见。不同声闻厌诸烦恼别求圣法也。不善亦尔。转此善性而为不善。如结水为冰无别性也。母等者。母是能生之义。言因邪见能生一切不善之法。犹如于母也。以是义故。菩萨乃至戏笑观看。亦不生邪见。举要言之。不生一念犯此邪见戒之心。况复多耶。如声闻经中。戏笑语等不自犯于学处。此则不尔。乃至於戏笑等中作邪见等事。亦不可也。而况故思之业耶。然菩萨有慧方便故。即能于诸见不动。而修三十七品。即于邪相入于正相。何以故。以众生无始以来多习此法。卒难为正。如彼良医。先同其事业后夺彼权。如涅槃等说也。又如菩萨藏本生中说。乃往过去有城名波罗奈。王名梵施。然此乃久远劫之事。而今城名即是彼先旧地。当知世界中。数数还于旧地而得本名也。然近曰波罗奈。王亦名梵施。数数与古同名也。时彼王大臣婆罗门生一子。其子生时。空中四方云色青黄赤白。各随一方彩绚弥布。乃至遍阎浮提而降微雨。凡婆罗门法。若生子时。必请天仙圣智之人。先令观相而为制名。时大臣求得一仙令观其子。仙问是子生时有何瑞相。当依此制名。父以前事对之。仙人曰。我韦陀典中。若生时有此相者。必通四韦陀典。流演法泽布于四方。因名为庆云。然大臣种族习四韦陀典。是摩纳婆宗。故依本宗号摩纳婆也。此童子年渐成立传习其业。凡四明宗旨无不洞晓。而作是念。不唯解故而获义利。当思择行之。寻究此文上下宗旨。当依何法而得出离也。所以者何。以此童子宿殖德本久资慧性故。虽生异见之宗。而能自生此觉悟之心也。然一一寻究经宗。但生梵天而无出世之道。而白父言。今所习中未有出世之道。更有何法而为增上耶。父言。我自祖宗相承唯此法最妙。又是梵王所说。但可尊行。何能更求胜法耶。子复念言。今所学未竟云何懈怠。必当更求胜慧。父言。我闻雪山之中有大仙人。于四韦陀外别有决择深义。名计磔婆(此名问答随心也)即以此教故。号此仙为计磔婆仙。我今当往问彼。父言。此仙所住崄绝非人迹所至。云何能至耶。时子去心不息。寻即诣彼。时诸天神。以此童子必能利益众人。因共加持遂达仙所。彼仙见此容貌奇特有过人之表。先意问讯近彼坐已。时彼仙有五千仙人。而为上首常演深法。即问童子何由至此。童子具述前事。因白大仙。我于人间学此四典。恐有僻解不合本旨。请仙敷述唯大仙印许。时即广陈所解。大仙叹言。此童子慧悟过人我之所解所不能及。然童子所云出世道者。我亲从梵王闻之。有大仙当出于世。号一切智者见者。唯斯人能演斯法。非我等志中所及也。又随所解分别之旨具教授之。时童子以先世善根。今闻一切智名得未曾有。深因荷师恩念欲报之。然梵志报师之法。须鹿皮之衣以黄为梵綖及五百金钱。念已。欲寻求之。闻南方有王当立。欲示威德受灌顶位。广施梵行者。欲于彼求之。然彼先有梵志等。令王备羊马人各千。杀以示威用为灌顶。冀获名称远闻。童子后至。时王闻彼童子名而大欢喜。我将立。而感此贤人大吉祥也。即引为上宾令共定仪法。童子召诸婆罗门一一究问。今此杀生之祠出何文据。研核苦至彼并理屈。因告王言。此灌顶法非真道也。王可于一日中。于四城门办具一切供具。随来求者悉以惠之。其福无量名亦远布。王亦先有善根闻即悟解。敬从其教厚为之礼。童子但取五百金钱及鹿皮綖直而去。中路至宝定城(此城近揵驮罗界也)王名军胜(以军战必胜故立名也)以然灯佛初出于世。严饰城邑方欲迎之。洁清衢路种种布花香。特异常日。童子见已问人何故如此。为以我至故耶。为有他缘乎(时童子名远布所在厚接敬之故自疑也)城中人报云。有佛出世名曰然灯。王欲迎之耳。童子闻佛名豁然大喜。今此名号出过已典。将非大仙所说者耶。因用所得之物求觅供物。欲往献佛。时天魔以彼心大故。恐引无量众生出过己界。蔽一切人无有可买之物。时有女人以先福。与童子久远因缘故。魔不能蔽。童子从求买花。答曰我欲献佛。设令一花以百金钱亦所不卖。童子言汝已定卖。即以百钱而买一花。乃至五茎用五百金钱。女人即要言若不与汝。汝若世世能为我夫者乃可得耳。童子深念。女人妨菩萨道。我宁不买此花。寻欲置去。女言我要世世助成真道终不相碍云云。如经律说也。及持花至佛所散以供养。于空中为盖随佛入城。童子得未曾有。佛为说法深得法利。又于道路泥泞处。欲布鹿皮衣令佛蹈之。魔王五度掷去之而告言。童子汝所行真道。一切世间汝最为上。云何自弃真道。学沙门邪道之法乎。彼终不以介意为念。前有狭道而泥泞。佛必由中过。因候至时。布衣及发以掩之令佛蹈过。次弟子欲随佛过。佛言止止。此大心者。汝等蹈之坏汝大福。佛因案顶而授其记。当于尔时。即见十方各如恒沙佛国。皆案其顶而为授记。即登菩萨第九地也。时无量百千天人众。以此大士因缘。皆舍邪见而入正道。此即示菩萨慧方便故。先示入于邪道。尽彼宗旨方便回心故。能引彼无量同类。故名慧方便具足也。当更捡经具说之。尔时执金刚秘密主。白佛言。世尊愿世尊说彼十善道戒断极根断。谓如断草虽断更生。若断多罗即不更生名极断。此说戒功力也。云何菩萨王位自在处于宫殿。父母亲戚围绕。受天妙乐而不生过。如是说已。佛告执金刚秘密主言。善哉善哉秘密主。应当谛听极善作意。吾当演说菩萨毗奈耶决定善巧。秘密主。应知彼二种菩萨。云何为二。所谓在家出家。秘密主。彼居家菩萨受五戒句。王位自在种种方便道。随彼时方自在摄受(随方时自在作之如示邪见治大邪等)求一切智。所谓具足方便。示现舞伎天祠主等种种艺处。随彼彼方便。以四摄法摄取众生。令彼志求无上菩提。彼持不杀生命戒不与取妄语欲邪行邪见等。是名在家五戒句。菩萨受持如所说善戒。应善修学。应具信心随顺往昔诸佛学处。谓随昔诸佛而学也。由住有为具慧方便。能得如来无上吉祥无为戒蕴。学者思学。故得也。已说十戒相竟。金刚手白佛。愿说十善业道戒极根断。云何菩萨王位自在。宫室男女亲属父母围绕。天妙乐受不过生。此中问意。更有何法能害此戒之根。令善法不生。极者即是具害一切善也。问意言。云何处世法中而不为所污耶。然菩萨为众生故常须在世间。必须有戒方便令不害其善也。佛叹已令谛听。即说言。菩萨调伏决定善巧。决定谓一切恶自害。一切善皆由彼生。即是自性之善也。菩萨有二在家出家。若居家者受五句戒。如前王位自在不妨行菩萨道。以此五事也。种种方便道。时方摄自在。一切智求。谓方便具足。舞伎天祠等种种艺处示现。随彼方便众生四摄法摄取者。经文也。时谓观时非时。不待不失如海潮也。方谓随方处。应以何法而入道。顺世界悉檀也。以方便慧具足故。种种自在施为。而摄众生置于一切智也。不同彼无方便之五戒。但自拘[尸@句]志求自护也。以观利益摄一切故。入种种道。乃至彼我入天祠。示同学彼所学。渐以正见引之。以如是等方便无边故。所利为限。即以四摄之法引入佛道。四摄如宝云菩萨藏等中具说也。若在家菩萨如是持五戒。谓不杀盗淫妄邪见。于此五中以方便持之。其余一切无碍。务令引入佛道而已。以此五戒为首。而能成一切智地如来之位。故云得无漏性戒成也。由住此具慧方便。是为学处也。此本性万德皆具足戒。即是无为戒也。更重释之(与前不异讲后重叙以前未明也)上云。菩萨有二种谓在家出家。此五戒句。即在家菩萨所持也。以在世间有种种事务。由持此五戒句。由此戒具能具慧方便故。诸烦恼恶业不能害之。由此因缘得成佛也。故经云。如是善戒善修学具信。此劝持也。劝持意者。佛引古佛为证。过去诸佛由持此五戒故。处于世间。同众生种种事业而摄取之。不妨自行。故得成佛万德圆具。无漏自性之戒亦由此生也。方便智具者。此方便。即是身印口真言心观本尊三昧。以此为方便又有妙慧。即观此三事从缘而生入于实相。是故万行顿具而得成佛也。如声闻经。俗人所以持五戒者。为防护身口令入见谛故。今此中亦尔。以此五句戒为方便。而防护之。令得成真言之行而见谛也。非直在家菩萨。然此五句诸出家者皆共行也。复有四根本重业。修真言行者。乃至失命因亦不应犯。云何为四。谓诸法谤一。舍离菩提心二。悭三。恼害众生四。嗔恚何以故。此四性染是非菩萨戒也。以下偈文非持菩萨戒此性是染。以上经文也。真言行菩萨有此四重禁。即同声开四根本罪也。若犯此者即断根本善业。一切功德皆不得生。如声闻经中断多罗树等喻也。然大乘中无永断义。更受自新即是生也。若犯此者即非菩萨。犹如声闻犯重非比丘也。所以然者。由此四事于菩萨法中是能染性。能障一切功德令不得生故。乃至失命因缘亦不毁犯也。次佛又引证。谓过去未来现在一切佛皆由具慧方便修行此戒。而得修学无上菩提。得大悉地。大悉地者。即是妙行之果。谓成菩提也。无有漏者性戒也。方便离智学处。亦说声闻。大勇士人彼者。经文也。意言。佛为声闻亦说具戒及四重等。然此摄彼一类小根性故。权作此说。非为究竟。是故此戒离于方便。方便及智不具足也。若能趣大更学妙戒。乃能具菩萨戒耳。大勇士者。指金刚手而告之也。佛以下劣有情无大乘志愿。欲摄入长者之家。不令久在贫里。唐自疲苦而无所得故。此法而摄入之。非佛本出世之意也。故此戒者非是佛慧无漏不思议之戒。若入佛无漏智即自证知耳

    次百字生品第十九

尔时毗卢遮那佛。观察诸大会众。教不空悉地。尔时毗卢遮那世尊。观察诸大集会。说不空教随乐欲成就于一切。真言自在真言之王真言导师具大威德。安住三三昧耶。圆满三法故(此安住位如在车上坐或卧或立乘之也)以美妙言告大力金刚手言。勤勇士一心谛听。诸真言真言导师。即时住于智生三昧。随乐欲一切真言自在真言之王真言导师大威德说。三三昧耶圆满故告言。以上经文也。上来虽说真言种种方便。然犹未具故更说之。所以更观大会。照彼心机。皆此众中普是真实。堪为法器乃复为说也。复次为以不思议神力加持于彼。令得法力堪任闻此妙法故。观察之也。诸真言如上已广说耳。此是暗字。一切真言之心。于一切真言最为上首。当知此即不空教真言也。不空者。随一切众生有所见闻。触知。无空过者。皆必定于无上菩提。故名不空也。复次随彼善愿皆能满足。乃至众生大菩提愿亦能满足。如大宝王在高幢上充足一切。故名不空也。一切真言自在者。犹如如来为诸法之王于法自在。今此真言亦如是。于一切真言而得自在也。以此因缘。复名真言之王。复名真言导师。如多人入海依于导师。乃至有所进达得大宝聚还归受用。此真言王亦复如是。为一切真言导师也。真言导师即是救世者。言此真言即同于佛也。又复具大威德。如来自在秘密神通之力。皆由此生。若行者能如法行。即亦同此真言。而得如此也。三三昧耶坐者。谓身口意三三昧耶也。口真言身法印心本尊也(座义更问之)今谓即金刚坐也。三法圆满者谓理行果也。教即上来所说今于教下满此三法。究竟无余也。佛出妙音告金刚手。我说此法。汝大力勇士一心谛听也。前说真言品即合说之。何故不说至此方说耶。为迷彼寻经文人也。佛具大悲。何不显说而迷惑众生耶。答曰非有吝也。但谓世间有诸论师。自以利根分别者。智力说诸法相。通达文字。以慢心故不依于师。辄尔寻经即欲自行。然此法微妙。若不依于明导师终不能成。又恐妄行自损损他。若隐互其文。令彼自以智力不得达解。即舍高慢而依于师。以此因缘不生破法因缘。故须如此也。佛将说此真言导师。即住巧智生三昧。谓此三昧。能生如来普门善巧之智。故以为名也。百光遍照真言说者。谓从此一字。而放百法光明遍流而出也。此字若翻为遍。亦不正当其理。若翻为放光。放光义亦未尽。大都是遍出之意也。百威德之光从此而出也。此真言也。先归命一切佛乃说。金刚手此真言真言救世者。大威德。佛自即是一切法自在牟尼。佛告金刚手。此一切真言。真言救世者。成就大威德。即是等正觉。法自在牟尼(谓于一切法自在也)破诸无智暗如日轮普现。即为我自体大牟尼加持。应现作神变(本文云变化作变化也)随所欲利众生(随其所欲而利饶益之)利益诸众生。乃至令一切随思愿生起。谓随彼心所思愿即令得生也。悉能为施作此神变无上句。是故一切种胜中(谓于一切所欲中谓诸欲中)谓于一切事中。不如求此正觉句也。应故当一切种。清净身离诸障。应理常勤修求正等觉句。清身离障。谓行者自净其身。令离一切障而修行之也。一切种。谓于一切方便色类中修也。一切无智闇破。日轮现同见。自是我加持。大牟尼现作变化众生利益。乃至是众生等思起令发生。常为作此变化最上句。是故一切种种方便欲勤修。应理当作清净我者。以上经文也。此真言即同救世者即佛也。有大威德谓如来威神也。此真言即是一切法自在牟尼。此即毗卢遮那之别名也。此真言慧方便之光。能破一切无智暗。犹如大日出时众冥自灭。普谓一切众生。顿除一切无明之暗也。当知此字即我所加持。即同于我与我无异。我即佛自体也。我以此真言门故。随类普现色身。遍法界一切众生之类。随彼种种喜见之身。能一时普见其身。随其心欲而为示现。非但现身而已。然彼心愿思念无量不同。乃至一须臾间。有无量乐欲皆能满足。故云思发智也。又复起彼入道之机。故云发智也。住位。住此最上句也。故此种种方便句应勤修学也。若修者即得清净我。此中清净我者。即是毗卢遮那也。然此字轮最中置此真言王。次外一轮有十二字。谓从伊至奥。凡十二三昧声也。次外轮布于百字。先从◇迦等廿五。次◇等廿五。次◇等廿五。次◇等廿五以此中俄(上)若(上)拏那么五字。是大空之点遍一切处。故同布烈也(又别时释云此五字在别外十二字同圆布之更问)若作五重布者。此◇等廿五字为第一轮◇等为第二轮◇等

为第三轮◇等为第四轮亦得也(更问之意未尽)其布字次第逐日右转也。次品说此真言王之果也

    百字果相应品第二十

秘密主若得入正觉大智灌顶地。自见住于三三昧耶句。秘密主若入此世尊大智灌顶。陀罗尼形示现佛事。尔时佛世尊。随住一切众生前而作佛事。宣说三三昧耶句。尔时毗卢遮那。告金刚手秘密主言。佛世尊入大智灌顶地。得三三昧耶。合身口意平等为一也。住立我见。当此秘密主入大智灌顶。陀罗尼形佛事示现。以上经文也。大智灌顶地。即是如来第十一地也。由住此第十一地。入大智灌顶。乃能作如来事。故翻此大智地。为陀罗尼身。而作佛事也。由此故能为一切众生。而作佛事也。陀罗尼形者。谓总束真言轮而以为身。即成普门身也。由住此总持身故。于一切众生前。示所喜见身说应机之法。无有差谬同入佛智也。尔时世尊。众生诸佛事。三三昧耶句宣说。随住秘密主。观我语字轮神化广长。无量世界遍清净门。如是性一切众生欢喜。令法界随类表示门。亦如今者释迦牟尼世尊。殊异虚空界流遍世界勤作佛事。秘密主。非诸有情能知佛如是语轮流出正妙音。庄严璎珞胎生佛影像。随众生性欢喜作现生。以上经文。佛如上说已。次告金刚手。汝可观我语轮。即观佛陀罗尼身字轮境界也。佛以神力加持大会。非但今秘密主观我语轮境界广长。遍至无量世界清净门。如一切众生本性。表示随类法界门令发欢喜。亦如今者释迦牟尼世尊。流遍无尽虚空界。于诸刹土勤作佛事。金刚手得观此一切大会。亦得同观此不思议神妙之境也。所以者何。此大智之身。常住寂灭离诸因缘。非有心之境。离佛神力所加持。则一切菩萨非其境界也。佛既示已告言。汝等且可观我字轮境界广长无量也。长谓人所不及也。私谓此即云何也。其广横遍于一切众生界。其长云何竖穷佛界。故云广长也。如是广长之身。普应一切。从何得乎。乃从此一字真言王。而现此事也。以一真言印身示一切身。以一真言字音而出妙声。普周法界。以一真言本尊之心。普示一切智慧之境也。释迦牟尼者。即是此不空见之身。普入世间而作佛事。故此所示即是牟尼身也。佛作佛事。即此释迦从毗卢遮那字轮而出。然无二无别皆遍一切处。以此一字同于大空本不生故。当知百字之身亦如是也。殊异者。谓如来三三昧耶之身流遍世界。及十方虚空悉遍。无有虚空而不遍者。当知虚空不可量。身亦如是。秘密主。非诸有情能知世尊。是语轮相流出亦捡花严。心我妙音生诸佛等正觉妙音。庄严璎珞从胎藏生佛之影像(形相也)庄严。谓以语言庄严其相也。从心胎藏生佛形也。广长无际而作佛事也。非众生知者。即此佛之字轮也。亦非菩萨之境。若离神力则不能观。而何众生知其所益。诸言音中佛为最上种种庄严率种种等。以要言之。以无相庄严也。从心现生佛随类身。由住此妙音三昧故。普现其前。随其本性令得欢喜信解也。生之处乃所往所住之境乎。此后微妙音庄严。胎藏者。从一字而生名胎藏也。从此一字而生为胎。随彼生者以为影像。如一镜圆净而对众色也。既不来镜亦不往。然而因缘和合影像炳然。不生不灭不一不异不来不去不常不断。即同彼体不可思议。如来影像亦复如是。无思无为而应一切。皆随彼心令得欢喜。而为现生佛事也。即以一佛言音。能生一切佛事。如六根净品。尚能以一妙音满三千界。况如来究极圆净之六根耶。尔时无量世间海门(亦是口义)中法界成菩提。勤修普贤菩萨行愿。菩萨此花布地。胎藏世界种性海生受。种种性清净门。佛刹净除菩提座现。佛事中而住。以上经文也。由此大智灌顶无量世界海门。门者所从入处义也。无量世界海口印。指众流所趣所入之门也。由知此无量世界海门故。勤修菩提。而此一菩提非是一菩提。乃至遍法界之菩提也。以众生无量故。法界无量。今乃普令得成。尔时世尊。于无量世界海门法界。殷勤劝发成就菩提。满足普贤菩萨行愿(普贤即如来功德也)出生普贤菩萨行愿。以加持故现相如后也。于此妙花布地胎藏世界。言于此者。即此素诃世界也。于种性海受生(种性谓受生处海谓无断广多也)以种种性清净净除佛刹。现菩提场而作佛事(谓加持作佛事无不遍也)复次菩提。如已无异同入法界。此乃是大菩提之行耳。若如是发行。即是普贤之行。如是起愿。即是普贤之愿。菩萨为此事。由是初发心也。花地者。如净治平地扫洒清净。散布种种色香味触可爱之花。周匝端严而坐其上。今此大悲藏之心地亦如此也。胎是初起。便即是如来所起处。以从如来性生。如来性生。是字而生也。如是发心。即是初地位也。海谓如来种性之海也。从此实性。而生如来一切功德也。胎谓从此以为根本。由普贤行如来行。从如来性海之胎藏。渐渐具足一切如来六根之支分也。此普门身。随众生种种心行差别性欲各异。即以清净妙门而净其心。无得究竟。如是净其心。即是庄严一切土也。行者如是住菩萨地时。即能以普见世界。现如来身座于道场。而净法界轮。即能遍知一切句。谓成佛也。亦能随所欲乐。而满其愿不空过也。故次经云。复次正遍知句求者。乐欲心无量。知身无量。证身无量。知智无量证。复次乐求者。还修菩萨道也。即是佛事也。众生见彼道故。即劝发心学道也。复次乐欲勤求正遍知句者。知心无量。即知身无量。知身无量即成智无量。知智无量知众生无量。证众生。无量知虚空无量证而得此也。秘密主心无量四无量而得。已成正等觉。即知众生无量。知众生无量即得知虚空界无量。秘密主。以心无量而得四种无量。谓除心余身智众生虚空也。得已成最正觉。具十种力降伏四魔师子吼云云。成十力四魔降伏无畏师子吼。此一切勇士智句最上学处百门。于诸佛心说。以上经文也。此意言。犹入此大智灌顶门。住菩萨种性故。即知心无量。以知心无量故。即知一切身无量。以知身无量故。即知智无量。以知智无量故。即知虚空无量也。所以者何。一切法由心而有。了达此即法无量。即知身无量也。缘生见之身乃赴机。度门之智应彼而起。亦复无量一一等同虚空也。以身智众生虚空无量故。名为四无量也。由此无量即从心生故。名四无量心也。若得此四无量心。即是成正觉。即是具十力降四魔。即能无畏师子吼。如是等事。皆由住此四无量心。住于一切最上法句而得成就。故名◇字悉地之果也。此百门非但我自说。一切佛亦同是说也。此谓指上十力等功德勇士谓秘密主也。如是勤学勇士最上觉者句。于百门学处诸佛所说心(意云所以成佛由学此百门心也)右百字果受用品。谓随一一门有相应者受用也

大毗卢遮那成佛经疏卷第十八大毗卢遮那成佛经疏卷第十九

        沙门一行阿阇梨记

    次百字位成品第二十一

尔时金刚手秘密主。白佛言。希有世尊。以下偈说真言救世者(谓上百门王也)谓能生诸真言也。真言救世者。真言诸真言生知。云何谁于何处。大牟尼诸真言谁生。云何谁说。此一切大勇士说。与愿者说。以上经文也。时秘密主。闻佛所说得未曾有。白言希有世尊。说此真言救世者。救世者即是佛也。如佛于一切众生中。有大归依救护之处。此真言亦尔。于一切真言中同于救世者。为彼诸真言救护之处也。如佛是一切归趣之处。此真言亦尔。为一切真言归趣之处也。是大圣者闻佛说。即以一字能生无量真言身口意差别。随众生性示种种身。说种种法现种种神变。因问此真言云何生。又谁证知。生在何处。问此三事也(更问未审)大牟尼叹也。云何知一。知者谁二。于何处谓经何得也三。谁生诸真言四也。前问谁得知。此四后问生者是谁。大勇士是佛也。此一切愿说。中上者说之也。愿一切智与愿者说。此即叹佛之德。能与一切愿而满足之。故名与愿者。因请佛说也。佛大法自在牟尼满。如是说已。世尊大法自在牟尼。普皆遍诸世界。毗卢遮那佛一切智告言。善哉善哉摩诃萨具德金刚手。吾当一切说(谓为汝一切说之也)秘密最希有诸佛之秘要。一切诸外道不能知。诸大乘灌顶悲生漫荼罗(从此生坛灌顶也)调柔具善行。常悲利他者。有缘观菩提。彼常不能见(不可得见也)普遍皆世间悉遍者。时佛为欲说此真言心法。即以神力加持遍周法界。悉有此言音而告金刚手也。一切智毗卢遮那。善哉善哉大众生金刚手大德。说吾一切秘密第一希有诸佛之最秘。一切不知诸外道。以上经文也。佛叹金刚手。善哉善哉执金刚大德。大德具万德也。此法乃是一切如来秘密中之秘密。于诸秘藏最在其上。共所守护不妄与人。第一希有难得之法也。今此诸法之秘。一切外道所不能知。然外道有二种。一者世间种种外道。二谓佛法内有诸外道也。以虽入佛法中。而未能知如来秘密。犹是邪见心行理外之道。故亦名外也。此法乃二种外道所不能知。此佛法中外道。即二乘中人也。佛既不妄与人。久默斯要待机而与。今何人合闻此法耶。故次言若人于大乘中。得入大悲生灌顶之法者。乃合闻之。不然不得也。次又以问之。谁引入灌顶然须灌之。若其人性调柔质直具诸善行。如是之人。乃可引入灌顶之法也。又有常悲者。乃合引入漫荼罗也。常悲者。谓如有人。于此时中有悲。此时中无。或有此方有此方中无。或亲处有而怨处无。今则不尔。于一切时处常有悲心。又复广普平等。如是之人。乃合引入灌顶。既得灌顶方合闻此。非如常流布之经也。此法华偈中。亦广说简人。可引之耳。复次有缘观者。亦不合得闻此法也。佛法离一切相离一切缘。若有相有缘。即不离断常见。故不得闻此法也。今言无缘者。岂是拨一切法。都无无所有耶。非如是也。佛法虽离缘离相。而以方便。具足一切善功德神力不思议种种境界。即相无相。即无相而具一切相。即缘无缘。即无缘具一切缘。非谓但空直无所有而已也。其大意者。谓具菩萨大行大愿发于大心。如是之人乃可为说也。前问从何生者。今答从佛心生也。导师即是佛也。若随导师随所住处。此真言即彼有能知内心之大我。谓叹此心也。随彼生。谓从一切支分生也。随其自心位。导师所住处。八叶从意生。莲华极端严。圆满月轮中。无垢同于镜。于彼常安住。真言救世尊。金色具光炎。害毒住三昧。如日难可观。彼一切众生。如是八叶意生。莲华极端严。圆月中无垢镜同。彼住常居真言救世大德。金色具光焰三昧住者。谓此华台从心意生也。即是观于自心八叶莲华。此花不从余处生。即从意生。意即是花。无二无别也。此华台圆明如月。清净无垢同于圆镜。以世间更无物可以为喻。唯有圆镜可以喻况。令彼得意忘言。然实过于彼百千万倍。不可为喻也。今此圆中有真言救世者。具大功德。真金色具有焰光。住三昧寂然而住此。当观此一字真言王。从此真言王。即观本尊或大毗卢遮那。如上瑜伽法中说耳。说未分明当更问之。然上文彼具可引捡也。害谓一切烦恼。悉以除害。其威光如和合百千日威光猛盛。犹七日童子。不能仰观烈日而观其明。今此光亦尔也。彼一切众生观于日轮。而不能见其本质。今此佛光亦如此也。恒常于内外。普周遍加持。以如是慧眼。而知于意镜。作心镜亦得也。真言者慧眼。而观是圆镜。当见自形色(自见身形也)寂然正觉相。身及从身所生影像。身身所生像。上身有为有漏。下身无为也。心生心。谓垢心生净心也。常出生清净。种种自作业(染污阿赖耶之业能生净业也)不净业除。净业当现。净业现已。生光如电普照也。次当彼光现。圆照如电焰。亦不取电义也。但取种种杂色光圆满也。圆满杂色光照也。真言者能作一切诸佛事。普遍内外当镜意知者。镜即是圆明中华台。当知此镜即是意。当知此镜即是自心也。以何方便而得观知耶。谓即如上方便。于二日置啰字。以此慧眼而观实相圆镜之心。故得明了现前也。谁能观之。谓真言行人也此行人即以啰字之眼妙慧光明。而观花台之镜。初作意外观。宛然炳着。于此圆明中。如来乃至音声色像皆悉无边。既如是明了。即引此而为内身。谓前来所观毗卢遮那之身。寂然正受威光无际。之观为己身。即令己身同于彼尊。于圆明之中寂然而住。同于彼佛也。以离一切相而现示相。名真实相也。所以然者。此莲从意而生。谓先以啰字置眼而观于心花台之镜。即是外见。即以外见而成内见。即自了其心也。故经云。慧眼如是。慧眼持诵者。镜观见自形色。寂然佛相。身身生缘意心生出。常净种种自业。次光彼电焰。彼围持真言者。作一切诸佛事。见若净我亦说。作一切事意思。以上经文也。所云生者。谓身语意生。先观圆明佛像金色等。当知从意而生。即引外向内。如身同佛身印。语同佛真言言音。心同佛心。生皆从意生也。即以生此生。而能净一切业。故云常净种种自业。谓离一切业也。若离一切业。即名诸佛也。若如是觉知。即能以圆光遍照。遍照者即是作佛事也。随身口意遍照庄严。当作一切佛事。即同毗卢遮那也。谁能作此佛事耶。谓持真言者也。此皆佛答金刚手。真言所生处也。谓此真言。即从行者身口意而生。若如是知。即是内外清净而作佛事也

经云。自业者即是佛事也谓普现色身。或示处处行菩萨道八相成佛。诸本生事业无量无边。以要言之。皆是如来自业也。若能如是知。是成佛也。持真言者。由住前观。次第方便此真言行。是身有缘起。更无殊胜异于佛也。故经云。若见者成清净。闻等亦复然。见闻触知者悉得清净。此中能字是含多义也。如意所思念。能作一切事。次光彼电焰彼。围持真言者。作一切诸佛事。若净我亦说作一切事意思。亦尔。秘密主真言门菩萨行行菩萨。如是心中生缘起。无有佛殊胜是也。以上经文也。师说未分明可更问之(且可思其义次第配像)像也缘起者。谓观心八叶之花。花上圆明。同于净镜之类。初时未即明了。以啰字慧眼方便故。渐自明了。乃至于圆镜中见自身。即同一切佛等。如是法生。即是从因缘起。若从缘起者。观此不生门。即入法界体性也。以慧眼为因。净镜为所缘。无量自业等佛事。从因缘而生。然实不自生不他生。不共不无因。如中论等所说也。此法殊胜更无过上也。如上皆说离一切相无对无缘。而今作此观等岂不相违耶。如从阿字生一切字。生一切字时即本不生义。此亦如是。佛以方便力故。故无相寂灭法中。而作此瑜伽之行。无相之中而说诸相。即此诸相即是无相也。所谓相者。即是从缘所生之法。然实不自生不他生。离于八不。即是第一无相。不离于相而说别有无相也。若别作此说。即同外人之断空矣。然有难云。今此观本尊身语意等种种境界。又秘密主。真言门修菩萨。从身所生影像。谓身影像起也。身谓垢身。影谓净身也。此所起莫过于佛也。意言。影像起中殊胜。莫过于佛也。如眼耳鼻舌身意等取如是。彼自性空唯有名字。所执同于虚空。无执着从因业生。等于影像者。即是相。相者即是世间法。今佛说真言成佛之行。而乃更明世间三昧有相之法何也。故佛次引喻明之。如眼耳鼻舌身等四大种。摄取彼自性空。唯有名字。所执当知同于虚空无所执取。从因业生影。经文也。因如镜业如身。如对镜而影现也。如行者先观外缘心之明镜。然引入己身。若自他平等无二。即是瑜伽成也。自身为因所缘是缘。因缘合故有影像生。若了此因缘即成等正觉也。谁成正觉。谓真言行人也。此意者如世间五根等。从四大因缘生。业等生。虽有相有缘。然自性空。即同第一无相之法。今此瑜伽亦尔。虽若有相而从缘生。缘生实相。即是阿字法界之体。何得难言是有相也。若了如是义即成正觉也。故经云。如眼耳鼻舌身意等四大种。摄取彼自性空。如是空名唯取着。虚空同无执着。因业生影等。如来成正觉。彼互相缘起。无间断中相续若缘生。彼即影像生。是故诸神尊即我。我即神尊。互相发起。尊身身生像天形生。以上经文也。我之所起。因于圆镜见明镜时。自身影像现。由未见圆明故。即无影像。如来成正觉。彼互相缘起。如镜中生像像互相生。因缘不断中。自垢身生净身。彼互相生不间断也。间断中相续。即是无间断也。若从缘生。彼即如影像生。此明不离因缘也。是故诸尊即是我。我即是本尊。互相发起。由互相生故。从身生身(谓生净身)如是尊形像生。身生于身。谓垢身生净身。净身即是佛本尊之形。当如是解也。己身心己身净已。又即同彼。互相缘起无有间断故。云缘生即是影像生也。以内外相因。更相分发展转相见故。诸尊即是我。我亦即是诸尊。佛即是我。我即是佛也。身生形相生者。谓从自身生也。观己秘密主。法缘通达慧。通达慧缘法。彼等互相作业。不住性空。云何秘密主意意生。影像能生。通达是证果义。至于所至处也。此通达当言证也。秘密主观此。如前说镜喻。心中明镜现像影时。无有分别但从缘起。今观此法。为从镜生耶从面生耶。如是求之皆无实处。若从镜有。无面亦应常有。若从面有。镜无亦合不无。然俱不可。故知但从缘有。而实常空。此是法也。因观此法得成证慧。然此慧。戏论永绝不可显示谈说。若不说不度人。复违本愿。更从证智还生法。缘从佛因见法成佛。成佛已复说法也。亦可此从缘生复成法也。譬如白黄赤等。意作者作时染着意生。彼同类如是身转。以上经文也。意言。秘密主观法。法性空寂之相。因缘此相。以慧而能通达也。法是离诸相法。法即是缘。由观此入法性而通达法也。若通达法即是达缘。达缘即是达法。互相发起也。同知法空寂即是达法也。由有分别起。知法是空无智缘。缘依法法依缘。互相缘起。是名诸法性空也。若法如是性空。云何从意生起愿。经文彼等互相不住性空。秘密主云何意能生影像。秘密主。譬如若白若黄若赤作意者。此引喻也。如人眼初见白时未明了。次即生心分别此是缘耶。此上无问也。金刚手非为不知。为众生故而发起疑问。若如是者彼意从心生。谁能得知耶。佛即说喻由如白。何以故。以异青黄等故。心生此解。即是起从心生心。世间尚尔。当知从染心生净心亦然也。染着意生者。如见白时心作白解。由此白故令心亦白也。如比丘观白者见一切亦白。见青者一切亦青也。作时为于白上作白意成就也。识心从白心生不从外起。如人观白时即见一切白也。如月灯三昧说。如女人好自庄严。照镜自见还自生爱着。若智者观此从何生何处来。一一观之不可得也。由此言之。从心生像还自染。若了知此但从缘生即无染着。以此证于自。是自心而生于心也。彼同类如是身转。谓即是童女自见其身也。若染即是生死。若称但从缘生无有自性。即是涅槃。故云同类身转也。从内观意中下是偈也。秘密主。又如内观意中漫荼罗。以疗热病。彼众生热病即除。谓一刹那顷即是也。刹那提婆无疑。不用此天字也。非意异曼非曼异意。何以故。彼曼一相故。作意者。观青黄赤白等。如修十遍处等。想青色时一切皆青。此青但由心生也。以久久用作意。意能生之。此色随心而现。心既能缘。能生彼类也。染是执取义。当知从心意生与彼同类。心既如是身语亦然也。次又引喻。又如意中起立漫荼罗。作三角等如上说。且如除热方便。作圆漫荼罗。白色中有鑁字。或种子字。面上安点等。余类此可解也。此点即除热恼为甘露味。由作此法从心作之。而能除热。乃至刹那之顷彼病即除。彼从心起也。当知彼心不异于漫荼罗。漫荼罗不异于心。以一相故也。言此漫荼罗。与心无二无别。今此法亦如是可解也。次佛又引喻。如幻者。化为男女等。即此秘密主。又如诸幻者变化作男子。次幻男子复作变化。于意云何。秘密主何者为胜。金刚手答言。世尊此二人者无相异也。何以故。世尊不实生故。二男子本性空。等同于幻。如是秘密主。事谓悉地等事。等谓多也。意中所生事。皆从意生。此二性空无所分别(谓无二无别也)从意及意所生。彼二俱空无二无别也。化人又复作化也。如是二幻何者居尊何优何劣。何长何短何好何丑耶。经云谁胜者。即是问此二幻何者尊胜也。答言此二无异。何以故以皆从不实生故。二俱本性空故。夫幻而作幻。而作幻者有何殊异耶。佛因言汝且观此法。如从心生圆镜等。心即是镜镜即是心。无二无别。不可论其差别之相也。若染心者即是世间。若染离心即是出世间心也。右此成百字位品。说未分明当更问之。然其大意。以先修瑜伽故。成乃至极大广普。然不以此慧方便。观空实相洗涤其心。即犹是世间之法。故须作此观行。令入漫荼罗实相。成大空之坛无所不有。常恒毕竟清净。此其大略也

    次百字成就持诵品第二十二

经云。谛听秘密主。真言救世者。身身不异。谓身不异彼身。所谓处于心。是而用彼真言之身。意从意生。前是有生之意。后是净意也。能令意净除也。普皆有光彼处流出。从净心中流出。言彼即指前意也。光与瑜伽相应而生。由与瑜伽相应。从彼心而生是光也。愚夫常所不能知。谓愚夫所不能知。于此道不能了达也。乃至身所生分分不异于身。从身所生身也。有无量多种也。身既无量如是真言言说有无量。如如意宝。谓吉祥如意珠也。随所欲利而得成。如是世间照世者身一切利成。秘密主云何无分别。法界一切所作随转。秘密主又如虚空界云云。佛告秘密主。谛听真言救世。身身不异。意生意。善令净除。彼处流出普皆有光。相应支分处。愚夫所不知此道。乃至身所生分无量多种。经文也。犹持真言故。此言有异。从意生意。能善净除。彼所流出。即以此身不异彼身从自身生。即是从意生。由净除诸垢故一切事成也。由有是德随诸支分。流出光明而作佛事。如斯等事凡愚所不能知。由不知此道故得愚夫之名。此道者即真言行也。以成真言得悉地故。从于此身更有身生。谓欲色界等其类众多。皆从一真言而出无量身口意。如上所说从佛上中下分生于无量身。此行人亦如是。能随身分上中下。或现四佛四菩萨乃至诸八部等。犹如大悲藏中所说。其数无量也。又疑难云。上说真言。无相无缘同于大虚。不可分别。云何而有此种种事耶。答喻如如意珠满一切愿。乃至三事亦能净也。若人欲其身净。珠力故令其身如琉璃。若欲语意净。亦随意分而净世法尚尔。何况如来如意珠妙宝。而不能作如此事耶。如世珠。虽作种种事满种种愿。而寂然不动无思无为不来不去也。为成一切。何况如来大宝耶。是故无分别法界。如大龙在宫不兴心动念。而随业力等降差别之味也。以是义故于无相空中。而现无量身口意普门之事。即身可得。不须疑也。又喻如虚空非众生数而众生所依。非身寿者非摩纳婆作者受者等。一切妄想皆除。悉离分别无去无来。然不异众生界。一切众生依止作业皆由此成。滋益众生成种种事。不可以虚空能成一切事故。便谓虚空有为有相也。今此大空漫荼罗亦如是。毕竟清净无所不为。常住寂然而不空成就。故经劝信云。当如是知勿生疑惑也。尔时世尊。又复无尽众生界净除句。三昧流出句。不思议句。转他门句宣说若本生无所有。随顺世法。当空云何知。生修行者。若自性如是。觉不可得。当虚空等心。生菩提生。当发悲生。一切世间随顺。以上经文也。住无尽众生界净除。谓本立誓愿。欲净除无尽世界一切众生也。以众生有垢故不能自度。今欲为彼普开如来知见使得清净。令彼身口意地皆得净无垢秽也。当知此净除无尽众生句。即是三昧流出句。三昧流出句。即是不思议句。不思议句即是转他门句。转他有垢为自性净。转他无明为如来明。故名转他门句。他谓众生也。以转秽为净。而说是法门也。本生无所有者。若本无所有。随顺世间生。云何当知空。谓当云何。谓知诸法空也。生此瑜伽者。偈中自有问也。是承佛神力有此问也。若言本生无所有。有随顺世间者。彼修行者。云何当令修行者生此空。谓净空也。若言无有者。云何生此净空也。若本无所有者。此生亦随于本无。即是本不生也。云何瑜伽者云何识于空。此空即是真言之性也。云何生瑜伽者也。若自性如是。觉名不可得。谓观名字不可得也。正合为观。观与觉同也。当等空心生。谓菩提心生。此引上明十喻也。以觉本不生无相不可得故得此等空之心。清净无分别等。如上非但空而即有智生。谓菩提也。应发起慈悲。随顺诸世间。住于唯想行。即名为诸佛。谓如来了达诸法本自不生本无所有。谓随顺世法度众生故。有有。谓普门示现种种方便利众生事。从机感因缘故有。而本无所有也。众生之性本性无所有。由修行故。知此众生之性本性空寂。由觉知是性空故。唯有名字而不可得也。谓空空性唯有名字。毕竟求不可得。此即是不可得空。非如劣慧者执是空性以为实有也。观众生同诸虚空。虚空本性离于观照。离一切妄念戏论。于如是了知虚空。即知真实之理。不应取是空法也。此虚空以不可得故。非是都无所有。而实有其自性。所谓空自性者即不空也。当知此不空者。即是虚空等心。虚空等心者。即是净菩提。从此净菩提心而生大悲心也。所以然者。行人了是菩提心已。而作是念。一切众生皆悉如是。具有如来宝藏。而不自觉知。以是因缘。唐受疲苦而无利益。菩萨以此四缘故。而起大悲心也。由不了知此心。即生死浩然轮回无已。了知即是菩萨。菩萨以一切众生。皆有可觉之性而不能自悟。为是事故而生大悲。将说方便而加救护也。即以此大悲。为除无尽众生垢故。随顺世间而设方便。以无尽众生界种类。若干性欲根缘展转差别。菩萨顺彼而化导之。故云随顺世间也。想唯心住。即名诸佛。当知从想造立生。所谓空。从于想中建立之。住于唯心已。还得此唯心。建立一切法。观此为空空。意谓空空之号。从观而有。亦但有名。空从心生也。下数之法转。从一二三之分异(言谓此一二等别异也)此分去声也。勤勇彼空如是。乃至增长如次第。即此阿字等。想言唯想义也。如上此阿字即是想也。亦自然智。是佛谓佛所加持也。若造立想空不空。观察下数之法转。彼从一二三为始分异。如是彼空勇士。乃至增长随其次第。阿字此首字相应加持自然智。经文也。前说得虚空心。即是菩提心生。菩提者觉也。此心岂是空耶。而实具足恒沙功德。虽具如来无量功德。而无相无名不可显示也。如法相家说十六种空。大般若说十八种空等。皆为明此义也。若但空都无所有性者。云何成就如是不思议神变德度众生。当知此空是自证之理也。想既空无所有。名亦如是。是处不可示。言辞相寂灭。若以如是自证之法。为凡愚说之。终不可得也。当知此但有空名。于十八空中最在其上。即是诸佛大空。而实不虚也。此中算数喻者。犹如世间人下算之法。最初画置一字以为其本(西方算皆于土中画之未已还画之耳)乃至亿载阿僧祇等。皆从是生。然最初未下算时本无是数。从此空地本无算数之中。而下一算。若二若三乃至无量。乃算毕已除去众位。还空如本。然所校计之数。下算者心自证知宛然不失。虽从本无中立数。今已如本而实无有。然数法持在于心而无所失。即是不有而有。有不有也。今此阿字门亦如是。从本不生中。为随顺世间故。随次出身无量法门。虽出是无量方便。然亦不异于阿字本性不生之义。犹如彼数不离于一也。以初算法从一起故。一切数法皆不离于一。乃至一万。即是万一不得相离。余一切数可解也。今此一切法不得离于阿字。亦由是也。然有论师又复引喻。犹如虫行。有无量虫相随不断而成导径。或有种种方圆屈曲等相。若离而异之。各各自是一虫。无复曲直长短等相也。今此法亦尔。于毕竟自证不思议空法之中。而具一切功德。然从缘生无有本生。不离于一本不性理也。此阿字为首。相应加持自然智者。由自然智加持此字门故。生无量语。语有无量声。声有无量理。即同彼数之一一遍一切。大空亦尔。具一切法遍一切法。此阿字亦然。一切真言门。皆从阿字而有。犹如万像从空而有。非直生一切字。即此所生之字一一门中。即显不生之理也。次云。秘密主观此空中流散假立。阿字之所加持。成就三昧道。秘密主如是阿字。种种间布图位。乃至有形无形有相无相。一切从阿字也。置位谓种种庄严也。观者谓令秘密主观此也。谓住种种形像庄严。而分别其位也。此诸法本不生故。显示自形。自形即是阿字也。于自形中。显示本不生也。阿字如是。秘密主种种置位间布。我观住不生。诸法自形显示。是经文也。观此阿字。于空中流出世间万像。一切世间皆从此生。然本不生也。阿字假立加持三昧成就。证三昧具般若成万行。皆由此阿字。得福慧圆满皆从此阿字门也。此字能生种种色。谓青黄赤白黑。乃至杂间有无量种。及种种形。谓三角方圆半月之类。及本尊等无量不同。若识此中真实之义。无不举体入于阿字之门同于毗卢遮那也。上来所说阿字门。即是显示自身我。即我自身本不生亦无灭。不生不灭者。即是如来之身。当如是观察也。故云阿字以自形显示其德也。次或无所得义也。从嚩字形显示不可得义。此嚩以证本不生也。嚩字形现即是下文言语道断之义也。此明何义。佛言。阿字具有一切功德。或直从阿字门。以本不生而显说之。或从异门显之。即是嚩等诸字门也。其义虽异门亦有殊。然所示我之自身本不生义。无有异也。若法有一是生。即是可说之相。非言语道断之法。以嚩字言语断心行灭故。入阿字门。以阿字故。即知此嚩不可说示也。以下皆是异门之相。或一切法中造作离故。迦◇字形现。此即明一阿字门。然欲明一切法本来无作故。现此迦字。然此迦字。即明阿字义也。如迦字。若上不置横画。即不成迦字声。所以不成者以迦中阙阿声也。此迦字上头即有阿形。当知此百字皆尔。下例可解。若无阿声在中。即不开口亦自无有声也。或一切法虚空等故。◇佉字形现。或行不可得。◇哦字形现。或一合相不可得。◇伽字形现(阿赖耶含一切染净种子是含藏义)或诸法离生灭故。◇字形现(遮正翻即是死灭之义也)或诸法无影像故。◇车字形现(如世间法因日树等和合即有影生也)或一切法离生不可得故。◇惹字形现。或一切法离战敌。◇社字形现(此是有此有彼义有此彼即有战敌也)或一切法离卑下。◇吒字形现(吒是我慢自高之义。对此即有卑下。若有慢有卑下。即有生灭义不与阿字相应。以阿声在中故。即明无卑无慢之义也)或一切法离养育故。◇咤字形现(是滋养成立义。如调和水土等而养株木等即得滋养。然一切法入阿字也)或怨离故。◇拏字形现(怨谓一向自身于一切处作恶。恶即对非恶处为二也)或灾变离故。◇荼字形现(是灾变义。谓世间蝗虫水火之异。及盗贼侵伐来是也)或诸法如如离故。◇多字形现(若观有如如即有所观。有所观故即有生有灭。即不与阿字相应。故如如亦须离也)或诸法离住处故。◇他字形现(若有是处有非处。即有是非心生。不与阿字相应)或一切法离施。◇娜字形现(若有此彼所施之物等。即不与道相应也。如般若说)或一切法界不可得。◇驮字形现(界谓各持本位也。诸法界其像万端。界者众像在中之意也。此界不可得)或一切法谛不可得。◇波字形现(第一义谛亦不可得也)或一切法同沫不坚。◇颇字形现(沫是不坚义。犹离不坚即阿字之德也)或一切法离缚故。◇摩字形现(若见有缚解。即有执心故也。入阿字即无缚无脱以不生故)或一切法观无所得。◇婆字形现(观即观照也。以观照成即有受生处。若了本无即无生无观也)此中释字。不合释此么字也。此是空义别释之。文误也。或诸乘不可得一切法。◇野字形现(乘谓三乘。凡乘船车之类有所至到。皆皆义也。若有所乘即有所得也)或一切法尘离。◇啰字形现(啰是染义。染污谓令清净色染污此即是尘染也。诸法离一切垢)或一切法无相。◇逻字形现(若有相者即对无相。与阿字不相应也)。或一切法离言说。◇嚩字形现。或一切法离寂故。◇奢字形现(奢谓寂然义。若有寂然即有散乱。无寂无乱法体如是也)或本性愚钝一切法。◇沙字形现(沙是愚夫无所识义。愚智为失不与本体相应)或谛不可得。◇娑字形现(此谛是真实之义。谛非谛为二是世间法)此是现字形也。言现字者(一切法门功德皆在此中也)或一切法离因。诃字形现(诃是因义。若有因即有果。即是生灭法也。入不生门即无因无果他效此)秘密主。随入此等一一三昧门。秘密主观是。乃至卅二大人相等。皆从此中生。仰壤拏曩莽等于。一切法自在而转。此等随现三藐三佛陀随形好。成就及此等三藐三佛陀随形好。秘密主一一三昧门随入见是。秘密主。乃至卅二大人相等皆此中生。经文也。即此一一字。有卅二三昧门。此卅二门互相入故。能成卅二相也。谓上迦等廿字。也啰等八字。及此四字。并为卅二也。一一字中三昧。皆具卅二相也。次俄惹拏那么五字。一切法中自在而转。此等正等觉成随形好成就随现经文也。此五字遍于定慧中。亦能成三昧。亦能成智慧。能遍成如来八十随形好也。是故修真言行者。当识此等字义。若真言中有此等字者。随义相应即知意。明如此事也。以明如此义故。即知此真言有如是功德力用等也。此中有一偈。从秘密主真言门菩萨。乃至百字生三昧耶。此是别处文。不和入此。本文误也。亦解此诸佛广作我。亦得成一切佛人中尊者。如上三十二相八十种好等。一切成佛之因一切功德。皆由此广行。而得成就一切佛。由此行得成天人中尊。若行者如是行者。亦得成人中尊也。右百字成就持诵品竟

    次百字真言法品第二十三

(复次秘密主。于此三昧门句。以空加持。于一切法自在得成正觉。是故此字。即本尊阿宇第一句)

复次秘密主。三昧门句。于此中空。加持一切法自在佛得是故字本尊。阿字第一句。明法普周遍。以字而围绕。彼尊无有相。远离于见相。无相诸圣尊。而现相中来。阿字第一句。明法普皆围绕。无相彼尊。现离相无相尊相中而来者。佛为欲满彼修真言行者令圆满故。复说此三昧句也。于此中。空者谓阿字也。阿字即本不生不可得空也。犹此毕竟不可得不可得空具足众德。普摄一切佛法也。此摄。于梵音是摄取之摄。如摄取诸物令在己身之义也。由以此空加持力故。能摄一切法成佛也。此中自在者。梵音与观自在之自在有异。此是摄取义。谓能摄取一切法也。如王者于其境内。随意摄取皆得自在。如来法王于一切法自在。亦如是也。是故此字最为尊者。言此字即是尊。即为天为神。天者众中之首。此字亦如是。于一切法中最为其尊。犹如世间地居中帝释为第一。诸世仙圣中梵王为第一。诸圣智中佛为第一。此阿字于一切真言门中。最为第一也。由此一字成无量功德。故无上也。明即真言之别号也。明法普皆字围绕者。谓从一字亦无量字生。无量明周匝围绕。如前所说字轮也。虽有如是围绕。而体即空寂无相。于无相中见相。即此相中而离于相。又于无相之中。而现有去来等事。普应世间。当知皆是真言不思议加持之力也。以阿字加持自身故。即同于空。于此空中而成就一切佛法。犹如世间万物因空得成。而空本体无相。于无相中而现种种形声也。尊是义字是相。即前品义同也。声字出字真言生。真言真言生果成就。一切救世者声。声从于字出。字生于真言。真言成立果。诸救世者所说。当知声性空。即空所造作。一切众生类。如言而妄执。非空亦非声。为修行者故说空知空所作世间一切随类。如是而妄执非彼空非及声修行故说。即声通达入。即三昧证。依法置相应。字照阿字句多种真言相。经文也。依于阿字同虚空。当知本来离于诸相。离相而有来去之相。从阿字而有声生。阿字既本空也。所以者何。此声者众缘而有。谓依喉舌齶等众缘相触。而有声生。但属众缘无有自性。而此能生众缘亦得从缘。当知即是本不生也。而因缘有真言生。真言即有果成就。如是即救世者所说也。若识此声即空等。从空而有。声表于字。空声相依。若知此者。所作世间事业其相万端皆不出阿字门也。以随顺世间故。有分别而起。不了者。依此而生种种位想执取之心。然实虚空及声。二俱离故。即是真言行者所说也。若了知者。即此偈互相释也。即入声解脱也。是谓于声得自在。了知本性空即证于三昧。以声表于空空示于缘。互相释也。此令入二俱空中也。声耳即空。即此理即具万德。以识空声等故。即入真性之理。入真性即是住三昧也。与此三昧相应。即是法也(更问)虽本不生而生一切法。即百字轮青黄等种种色。方圆三角等种种形。乃至无量不可说等差别之相。依此而照明也。自他皆空。从空立理。皆是加持用也。进入者通达也。由住斯理即是住三昧也。证此依法置相应。此相应作和合亦得也。置与布同也。此字为照明。照明谓成其德也。复阿字等类。意例一切字也。多种真言想。想谓有所分别义。例此一字。称于一切真言义也。想改为分别。种种真言名。谓由一字中。现无量义现无量说。于一切众生类中。各现无量言语。皆从此一字生也。于此中立众多真言名也。现证此理者。依法置相应字。即是上来一字中。置无量字。形色各异。如百字轮等。皆依此现。应如是照知而观察之。当知阿字有无量义。无量种种差别真言亦如是也。此字义乃至自本来。今佛佛道同有。此真理之字义。及此成自然慧之妙门真言等行。非世间人所立也。此即如来自然智门。非是他起。亦非如来为一类众生故创立。乃佛佛道同法位常住。虽从本自成。亦要因缘方便。乃得明白显现也。此中但明一字。然百字法门皆可知。故言百字门。谓举一字则百字可知也。此百字法品竟(法谓众多义。非达磨之法也谓百字之轨仪也于百字中生种种德名法也。最后卷并第二。弘记入经初品少许)

    说菩提性品第二十四

次菩提性品。即腾百字法品中义而说喻也。故经云。犹如虚空方。犹如虚空一切方遍依常。如是一切法真言救世者。常遍一切无所依。亦如是真言救世者。于一切法无所依。犹如虚空物(谓烟云等)虽见无所依(谓空等虽见一切日月烟云等然空无所依也)物等不依彼空也。真言救世亦然。非彼之所依。如教说世所极成也。虚空远离于三世。真言救世者。亦离于三世。真言救世者同于虚空。三世等离。经文也。犹如虚空遍一切方所。一切万有皆依之而得成立。然虚空无所依。如是一切真言。皆依于此真言救世者。此见是现见。现量见烟等。不染空亦然也。住于唯名行。远离作者等虚空假名等。等谓有种种假名也。谓世人说为虚空。但是假名也。导师所宣说。而此真言本不生体。教无所依同彼虚空遍一切处也。又如世间观于虚空。谓有所见。而实虚空观一切观。不与眼对也。约虚空具一切相而非此空。具一切相空亦不入彼相中。自他俱离。当知此真言救世者亦如是。与虚空无异也。虽无所不有。而毕竟清净体同虚空。虽同虚空毕竟清净无法可得。而无所不有无所不成也。又如虚空离于三世。即过去未来现在也。真言亦尔。随世间故说有三世。谓当修已修正修。当证已证现证之类。而真言之体。出过于三世等同于虚空况。随顺世人说三世尔。救世者。谓分别空见种种法。此法既从本不生而生。当知此体亦同根本也。亦唯名行诸作者。等离虚空假名字等。宣说导师非名依所有。如虚空真言亦然。真言自在此字见。经文也。如虚空唯住于名行。此行亦可趣。谓有名趣。谓唯名之趣只名是趣也。唯立之名趣。亦合谓即是言语之义也。虚空假名等(此等是顺世间故立此名也)假施设也。前偈云。空但有名。后偈意云。此名亦同于空不可得也。唯有名字而不可得。离于作者。如世间人。以分别戏论相故。取是空相以为实有。而生种种妄计。或言虚空是常。或言众色所围。此孔穴中是虚空等。或言此空依作者处而生。此等诸见无量无边。如经论广说。以要言之。皆不离断常二见。乃至世小乘师。亦立空法以为实有。以是因缘有无量过失。名亦无所有。亦同于虚空。真言主亦然。见住于假名。谓无量假立也。诸非云云。非净秽受生。或果亦不可生。此或是多种义也。诸果亦不生也。若无如是等种种世分别。于彼常勤修求一切智句。谓志求此也。今此中云虚空。即是不可得空。即是大空空。又复空但有名字。而实体即不空。离空与不空之相也。导师以方便故。假以言说以开悟众生。然亦空名亦不可得。若有名可存。即是有相。有相即心生灭不入实智。云何得名阿字自然之慧实相之智耶。如空无所依。当知真言亦如是。毕竟无所依。佛以方便。欲令众生普入于佛慧。从空立假。令依此假而至于理。空既本体无生。从空所依之假。从何而有。当知是生于实见也。如是知见。即是菩提之性。菩提性者不离真言耳。此真言之义即是菩提。离此之外别有菩提。无有是处也。非火水风地。非日月等执。非昼夜。非生死。非损伤。非刹那牟呼栗多。非年岁等。非成坏劫数。非净非非净。受生果或亦不生。若无如是等分别种种世所。于彼勤修。当作一切智句乐欲。经文也。言真言之性。非地水火风等。如虚空遍地水火风。此四依空成一切事。而空无依。此真言中地水火风等不思议用。依阿字门。而此阿字非地水火风之句也。非日非月即九执等曜。皆世人所立。非真实也。今此菩提之性。无明无无明等差别。云何得有昼夜之异耶。离于因缘实相常住。即是大日如来之体。云何不离生死耶。害是损伤义。亦是衰秏义也。而此真言之性常恒无变。离诸衰恼变秏之事。无有时分劫数成坏之相。当如是正观真言之性。不依于妄执也。乃至劫初时不成。劫尽时不坏。其本无始。其未无终。故离劫数分等也。以无所不有故非净毕竟空。故非非净。一切众生以此阿字。而具一切垢秽之法。如来即以此而成一切功德。故非净非非净也。若言从观而生。以有所观有所成故。随行受生。真言皆离此也。乃至从净观功德。从无量功德而受意生之身。亦复皆无故。无受生之果也。以此等皆是有所得法。而真言之性自然实智。于一切法都无所得。当知如上种种分别非真实见。其数无量。以要言之。真言之性皆离如是世间分别之见也。若了知此。而如是修真言之行。即是一切智句也。乐欲者随意即成也。句是住处义。一切智之住处。即是佛住也。当知菩提性等于虚空。空等于菩提性。菩提性者。即是阿字门一切智句也

    次三三昧耶行品第二十五

时金刚手。问此三三昧耶法言者尔时执金刚秘密主。白佛言。世尊说言三三昧耶。云何说此法为三三昧耶。如是说已。次佛告执金刚手秘密主言。善哉善哉秘密主。汝问吾如是义。秘密主汝当谛听。极善作意吾当演说。金刚手言。如是世尊愿乐欲闻。前已说之而不周备。腾上而起问。故言此也。问意言。此三三昧耶者。何法是三三昧耶。佛以此问是大事因缘故。加叹已而诫令谛受。乃至唯然受教。如文可解也。此三三昧耶。大本中广释。可有一千二百偈。今此中举其大宗。余义不出此门也。佛言有三种法相续(相续是生也)除其为障与无障相应。言障除。即是无障相应生也。名三三昧耶(由与瑜伽相应无障即三三昧耶也)云何彼法相续。次佛答中初三法者。相续不间断。是三昧耶义。然梵音相续。与障义同。亦可具含二音也。以相续若有间断即非三昧耶。此即障生。故兼二义也。所谓无间相续者。即是言行相续心口相应。一发心已。身口所行不相违越。口有所誓心行亦如是。修之名三昧耶也

经云。初心不观己性。自此发慧。次如实智生。无尽分别网。离菩提心相。第二非分别佛句。如实见。无尽众生界观。秘密主悲自在转。无缘观。菩提心生。谓一切戏论离。无相菩提心众生住安置。此三三昧耶。经文也。初心不观自性(本性也初也)从此发慧如实智生。谓了实相了是智也。离无尽分别网。是名第二心菩提相。无分别三菩提句。秘密主彼如实见已。观无尽众生界。悲自在转。无缘观。菩提心生。所谓离一切戏论。安置众生。皆住无相菩提。心生所谓离一切戏论安置众生皆住无相菩提。谓此大悲愿也。是名三三昧耶句。此三中。最初但能发心誓欲成佛。然未能正观如来功德。不能了知以何法而得成佛。未能具有观照之慧。但有求佛之心。而未能了达自己身之本性有何功德。但有此慧性。能于生死中。最初发心而求佛果。此是初三昧耶也。从此心后得如实智生。谓能以慧决择。了知此是功德此非功德等。是处非处邪正之相。以得如实智故。能离无尽分别妄见之网。善灭诸戏论。安住真实相中。然此实智。即是菩提心。三昧耶是等义。然此心等发名三昧耶也。初心虽未具实智。然亦誓成佛度人。即是等心。故亦得三昧耶名也。从此心第二心相续。无间无障故。次即于此真实句中。了真假已。于一切无尽众生。而起大悲心。是第三三昧耶也。以一切众生皆同此性。而不能自了。而受生死轮回无际。我今已自觉了。当普开佛之慧光令悉如我。即大悲也。由见实故。非实自除。非从外有法来入身也。除妄时实相自现也。上说此经有三句义。菩提心为种子即初句也。大悲为根即第二也。前以大悲为根。今乃居第三何耶。此中以照了为根。以能照了是非故。方能生悲。义相成也。第三方便为究竟。此云大悲。亦相成也。由兴大悲故。施方便而摄一切。此三事从初至后相续不间。名三三昧耶也。以住真了妄。为彼众生故。而兴大悲。除一切众生戏论。从此以后。即以方便而作佛事也。戏论者。如世戏人以散乱心。动作种种身口。但悦前人而无实义。今妄见者所作者。亦同于彼。故名戏论也。菩提众生住者。为令众生住于斯法如我无异。即是安住诸子秘密藏中之义也。次三三昧耶。初以大悲方便成佛已。复次秘密主。云何三三昧耶。最初名佛也。初心等正觉。第二名为法。彼续次生心。所谓和合僧也。此三三昧耶导师如是说。住于此三等。修行菩提行。次种种导首(谓广流布种种导门)为利诸众生。当得成菩提。三身自在转。复次从佛有法。次从法有僧。此三即一体。其实无二性。以是等故名三昧耶也(前别时解云娑是佛么是法也耶是僧义也)复次三三昧耶者。谓住此三昧耶即成菩提。住菩提为众生故。现种种色说种种道。当知即以此心能摄三身。是三昧耶义也。如上说。三宝是三三昧耶也。三昧耶是等义。即此三宝等故。名三三昧耶。从此三三昧耶。次具三身。亦名三三昧耶也。住三身故。有利益之事。利益何等。即是利益众生也。住三身中示现种种道。亦摄得众生。摄是自在摄取义也。秘密主。佛正教表示作一身加持。所谓初化身者。教即十二分教也。此中种种方便。秘密主。三藐三佛陀。安立教故。以一身加持。所谓初变化身。复次秘密主。次于一身示现三种。所谓佛法僧。复次秘密主。从此成立说三种乘。当广作佛事现般涅槃成就众生。利益众生皆一身所持。所谓变化身也。犹住三昧耶故。有如斯利益也。次于一身中示三身。谓佛法僧也。即是一体三宝。当知皆是从一身之中起也。此中三三昧耶。皆相承次因前生后也。次承上复有所生。谓示说三乘广作佛事导引众生。所作办已入于涅槃。于涅槃之后。复成就无量众生也。谓一类众生。佛在时未能发心。因佛灭度或于像法之中。乃成就者皆是也。秘密主观彼三三昧耶。知诸真言门。秘密主。观彼解了三三昧耶。诸真言门修菩提行诸菩萨。于真言法则而作成就。彼不着一切妄执。无能为障碍者。对此有异名为除不欲懈怠无利谈话。不能生信心积集资财。复应不作二事。谓饮诸酒及卧床上。行修行菩萨。真言法则持诵。彼不着一切妄执。住无为障者。经文也。佛告金刚手。观上来所说。皆由住三三昧耶。由住此三昧耶如法持诵。心心不间。所谓不着一切妄执也。由妄执故诸障得生。若住此三平等者。即不着一一妄执。即此三平等者即是菩提。诸障何由得生耶。此即是离一切障之大宗也。复有余障生之由。谓不欲。即于此真言行中以有障故。顿尔无由乐欲尔也。或由不欲心生故。障得入之也。不欲即是不愿求等。懈怠(以不勤进故。如钻火未热数息即障入之也)又无益谈论。于真言行不念诵不勤修行。以此虚度时日亦尔。障得其便也。不信。由不信故障得便也。又广聚资财。以求时忿动守护勤劳。失时受苦。以如是等种种因缘。令行者为障所得便也。以上皆是障生之缘。复有二种。谓不得饮酒。酒是生障之缘。此第一也。以饮酒故。诸不善得生。又不卧床上。此第二也。以安寝床上。生种种欲心放逸之想。故不得也。当敷草藉。西方持诵者多用吉祥茅为籍也。此有多利益。一者以如来成道时所坐故。一切世间以为吉祥故。持诵者藉之障不生也。又诸毒虫等。若敷此者皆不得至其所也。又性甚香洁也。又此草极利。触身便破。如两刃形也。行人持诵余暇。而休息时寝此草藉。若放逸自纵即为伤。故不得纵慢也。又佛所以自藉此草者。除世间憍慢心。故为太子时种种放逸。坐卧宝床宝几承足等。若出家犹习之。即与本在家无异。以此能舍如是事而坐草藉。一切人天皆生敬心。亦效除慢心入正法。佛尚如此何况我等耶。观如是功德故修行

    次明如来品第二十六

尔时执金刚秘密主。白世尊言。云何为如来。云何人中尊。云何为菩萨云何说名佛。导师大牟尼。愿断我等疑。菩萨大名称。弃舍疑虑心。当修行大乘。行王无有上。次品。金刚手又白佛。云何如来。云何人中尊。菩萨云何。尔时毗卢遮那世尊。观察诸大众会。告执金刚秘密主言。善哉善哉金刚手。汝能问吾如是义。汝当谛听极善作意。吾今演说摩诃衍道。菩提虚空相。离一切分别。乐求彼菩提。名菩提萨埵。成就十地等。自在善通达。诸法空如幻。知此一切皆同也。谓知此一切皆同也。知诸世间之所趣。故说为佛陀。法如虚空相。无二唯一相。正觉十力具。是名三菩提。唯慧害者。唯作以亦得。谓以慧害烦恼也。自性无言说。自证之智慧。故说为如来。云何觉此我疑。导师除。大牟尼疑虑弃舍。菩萨大名称。当行大乘。行王无有上。以上问也。意言。佛上来说法已。处处云佛或菩萨。然我虽闻此。犹未蒙决择名义之相。以何义故。得菩萨名得佛名。得如来名得人中尊名。为自从父母所生便有此号。为德成行满方得此号耶。大乘行王无有上。是叹佛德方问也。佛次又叹善哉。乃至敕其谛听方答也。大乘道虚空菩提。一切分别离。若彼菩提乐求菩萨名。此答菩萨名也。虚空无有相。菩提亦如是。犹如虚空无相无分别。又虚空无相而众德所依。万像依之而立。菩提亦如是。毕竟无相无分别。而具一切功德也。于如实相欲求证达。是名菩提也。次释佛义。十地得成。自在善通达。知法空如幻。此一切同趣行。知一切世间于佛得名。此答佛义也。谓满足十地自在通达。于一一地中。皆善通达而得自在。了知诸法同于空幻。又知众生深心所行各各趣向。以有斯德故。一切世间号之为佛。佛之名字因斯而起也。虚空相法。无二唯一相。十力佛是名正觉号。亦释佛义也。前但云知法空如幻。今云虚空之法一相无相。即以此中了达故。以十力遍知一切法。无所不知。如菩萨藏经中说十力甚广也。此菩提如虚空无二相。于一相中心无所住。以此故得佛十力。由正住此十力。名正等觉也。佛与正觉。名号殊而体一也。善调身口意。摄伏自在故。能降诸魔。非但降于外魔。内障亦遍降伏之。世出世中以为尊。故复号人中尊。此义经中阙文不释。余文如是解也。慧害唯无言说自性。自证智。说此是如来。此答如来名也。此慧能害无明。故云慧害。虽不云无明。然所害者即是无明。其义自显也。此自证境界。出过语言道。以知自证非可宣说而授与人。住如斯智故。得如来名也。又如佛之理自然而证知。名为如来。又如诸佛所行之道。自然证处我亦如是而去。故名如去也。大本中具答此。各有百余偈。传法者但略其宗要。各一偈答之。其大意亦具也

    次护摩品第二十七

外典净行围陀论中。有火祠之法。然大乘真言门亦有火法。所以尔者。为摄伏一类故。以言韦陀事而摄伏之。然其义趣。犹如天地不可相并。今欲分其邪正之相。令行者无复余疑故。传法人。于此品中广出缘起也。佛欲除彼未来世中诸净行者我慢心故。自说本生作梵王时。演外韦陀之法。令彼邪宗心伏。然后说此真言门正行也。复次秘密主。往昔一时我为菩萨。住于梵天行菩萨行。即是梵住此梵天也。时梵天问之。大梵欲知火有几种。时我如是说言。谓对彼作如是说也。彼火名我慢自然。次梵天子所生火。名簸嚩句。是世间最初之火。谓我先世行菩萨道时。示作梵王。尔时有诸梵行学者。而来问我。火祠之法有几种火。我具说之。今成正觉。乃证前说为非今说为正。是故行者。当从今正行之火法。不宜用先虚妄不正之法也。以下次列邪宗火祠之法。皆是韦陀典中所明也。先说火神之本。最初是大梵王。以彼有如是计一切皆从我生。有如是我慢故。又计自说常故。得我慢名及自然之号。即大梵王也。次梵天子即是梵王。意念欲有众生而彼应念而生。梵王。以为己所生子者。此是彼天火初也。自然生者。次梵天子以下是偈。所生簸嚩句。此是世间火名也。从此已下次第相生。皆是彼法中火神。但供养而无用处也。梵饭子(是火天名即梵子之子也)毕怛罗(又其子)吠税婆囊啰(又其子)诃嚩奴(又子)合毗嚩诃囊(又子)簸说三鼻都(又子)阿闼末拏(又子者也)钵体多(又子)补色迦路陶(又子)以上皆供养者也。置胎时用者(是净行者初娶妇置胎时。忙路多火用也。用此火神名而加之也。火名在经中此不出也下同)欲后澡浴时者(彼受胎六月。夫为其浴。仍结发为相。以此火神名真言也。缚诃忙囊火)浴妻之时用。[口*夢]檗卢火(生子之后者。生子七日后。浴妻。又母解发用此火神也。钵伽补火也)立名时者(其子既生。请仙人作法立名之时用也。簸体无火)食时用此火者(谓子能吃食时。父母先以此火神咒。加持苏等然后啖之。韦陀一一有方用也。戎脂火)为子作发时(谓子渐长剃胎毛发时。留朱荼之发。用此火神也。刹毗火)受禁戒时(是童子渐长与持本族戒时也。有文阇草似此间佛箭竹。治之作绳。三股线系身络背持曲杖即古之三岐杖也。三谟婆嚩火)军持被鹿皮。依其服戒也。持戒十二年常乞食。持赤铜钵乞食。作是言。有施者住。少时不得即去。归至火炉分食为三分。自浴已取一。分食供养火。取灰印三处。参父母师已。以一分食。与其随彼食与不食任意也。然后自食一分。于十二年中勤苦学韦陀法。十二年满方出梵种。谓娶妻也。禁满施牛时。谓戒满十二年已。谓报师恩。以物报偿。并[牛*孛]牛及犊子施师。师受已。又令彼婚。故说娶妻因缘。告言。过去劫初索里耶火大梵王。下世间作牛形而行淫欲。因生种类。由此有婆罗门种。今此母牛子。即是其遗体。尔宜劾之继存梵种。乃至广说。尔时用此火加护彼。皆火神名也。童子婚时。然彼婚法。娶妻时诵火神梵天本咒。大意言。梵天本意云云。乃行牛行也(用瑜赭迦火)造作时者。即以下供养等诸业。初受此法时。火神名别。以后造作。又随事别有火神咒等也。用邬波那迦火。供养天神者。然彼法供养时。取铜作碗有柄。即华果叶及是等诸食满盛之。其法云。一切天神皆共供养也。用簸嚩句火。谓如家中井窖门户堂屋类。一一皆遍。每处持一摄食与之。而诵其神神咒。乃至户门施竟。余食置屋上。以与先祖等及饿鬼也。次造房。用梵火(造立房等亦须也)钵罗罗梵火也。以法加之使成净法。不然不净也。行惠施时。即施其本类也。此净行者。不与三性语。物亦不与之。但于自类而行施也。施时称此火神名。以咒加之。本意云也扇都火。为此物从梵天得。今还施梵天。汝亦施梵天也下句亦云莎诃

大毗卢遮那成佛经疏卷第十九大毗卢遮那成佛经疏卷第二十

        沙门一行阿阇梨记

    世出世护摩法品第二十七之余

缚羊时者(谓戒已满梵种已出四姓已具。得杀羊而食之也。彼法云。梵天生四种故娶妻。娶四姓之女各各生子。即是梵天生四种也。然所用阿缚河宁火。生子自有优劣。其杀羊时。首陀所生子侍之。刹利所生子杀之。毗舍所生子割之。婆罗门姓所生子食之。当尔时亦以真言加之。此即婆薮仙人造法也)触秽时者(谓失净法。如沙门犯戒也。或谓有时放逸不觉。人截其发。或络身绳断。或三奇杖折。或食时为首陀触等。欲忏悔自罚。集三二百同姓者。大众中用微笑至火自悔。尔时诸净行者同声言。日月诸天证知此人。从今以去复清净如本也。时忏者用火供养彼等。尔时用此火天神咒加法也)熟食时者(彼法凡欲作食。先取生菜物等。以此火天名咒加之成净。方熟之。若谬不作则失法不成净食也。用娑诃沙火也)拜日天者(梵行法。日未出时合掌。东方望日。日出即拜谒诵咒。以此火神法作之。用合微誓耶火。至日欲没。又向西送之如上法。每日如是作。又有都集处多人同作也)拜月天者。归已。至月出时。又于家又迎月。礼敬所用神咒亦别也。用儞地火满烧(此是施火食法。取食盛满于一器。炉中烧之也用阿密栗多火也。)息灾(凡灾事令息用此火神咒。用那噜拏火)增益(用息灾等神咒。言此威猛如劫灾之火。其势威猛。用讫栗旦多火。即火神真言名也)除障(即降伏也。用日忿怒火。忿怒火是神名也)摄召(谓凡所求事欲成。及令人喜等也。用迦摩奴火)烧林木(彼法不得焚林木等。然有时稠林枯萃。欲烧之令更新茂。用此法也。用使者火)暖腹(谓食己身中火大销化其食。无病等用也。其真言用社咤路火。意云。以持我身。若从我身出即我子也。)次薄叉火即于授诸火食等用(更问)次海中火。名缚拏婆目佉。劫坏时火名。瑜干多火但举其名。无用处也(净行有在家出家。若生子者。从童真行即入山学道。乃至得五通。无此娶妻等法也)右以上皆梵行事火者邪护摩法。佛为汝诸仁者。已略说诸火。修行吠陀者。梵行所传读。此四十四种。我尔时所宣说。显正故腾出已。方辩真法也。秘密主。我于尔时。不知彼诸火性。作诸护摩。亦非护摩行。以下又偈也(又非得业果也)十二种火次说之。我复成菩提。说十二种火。复云何。智火最为初。名大因陀罗。佛意言。我尔时为大梵王。以诸焚众来问韦陀典而演说之。令彼依此修行获得世五通等事。然我尔时未了火之自性及其业用。以不知故。当知尔时所作之事。不名善作亦不得名为护摩。非行非业亦不得其果。及我成菩提时。方了火之自性及彼方便作果等。所谓火之自性者。即是如来一切智光也。佛所以作此说者。欲伏诸外道分别邪正。令彼知有真护摩。故以诸净行等于所宗韦陀之典。自谓秘密而生慢心。今佛自说韦陀原本。而于其中更显正理真护摩法。此佛韦陀。当知最为第一秘密之藏。彼闻已生希有心。即生信解也。我昔未成正觉无所晓知。略说如上四十四种火法。广则无量。如韦陀典中具明。今成正觉复说真慧之火十二种法。所谓能成大事。除尽一切垢障之暗而成大事。不同往昔邪道非法之行也。第一名为智火。方名称色黄。端严增威力。与火光焰三昧。住智智满足。此中最初火者。即是菩提心之慧光也。形方色黄。即是表金刚座也。端严者是内庄严。言此智火。本尊之形具一切佛功德故也。增威是外事。谓十力等用也。此智火者其性如是。内外功德庄严圆满能与力。故名增威也。由识此火故。烧无始以来无明薪积。无复遗余如劫烧时火。灰烬皆尽荡然无垢。一切如来功德自然成就也。然此火神即名为智。其相端严作金刚色。以圆光焰鬘而自围绕。处此光中寂然正受三昧。由住此三昧故。智性满足。此智光者。即是毗卢遮那之别名也。即以此尊而表此智。若初观即观此火神。能成一切事。若深了其性即如上说也。此中方坛者。梵名摩诃因陀罗。是帝释尊之别名。又则金刚轮别名也。智是内证。其外发之表作金刚杵形。此方座形与相似也。然但观四角之坛中有本尊即是也(此杵头有四角形也)上云增威者。若作形像所表而论。即是体貌圆满丰备之言也。然据理之言。即心法门也。然火有二法。若能修瑜伽者。唯观此尊形表之相而诵真言(其名即是也)即名内心火法。若顺摄世间故而作坛者。当作方炉而周匝有光焰。自身亦着黄衣。想炉火中有此本神。住三昧如上。然后所作事成。不然不成也。此法与息灾相应。是坚固法也。此配初菩提心阿字门也。由此因缘智具足也。第二火者名为行满。即案名表义。其梵音亦即真言也。初发菩提心。次修于行。其行满者即名为佛也。谓此即大悲为根菩提心种子故也。其形如秋夜月。光晖照朗四面周匝。身服白衣具种种德(谓身端严肥满可喜也)其右手持数珠。次左手合持军持也。此像住于月轮中也。如上所说。即是心性圆明清净之义。以此妙行之火。焚于垢心戏论之薪也。若作观时。亦即观此圆明为本尊形也。上文云皆体如来内证之德竟于次外故。以法门表示故也。若外作者为圆炉。以白檀末涂。以白花等为供养。自亦着白衣。此是息灾法也。灾有无量。诸外世间如水火虫霜降惶等种种寂耗。及内身一切病恼之类。其形万端。自身他身皆能净除之也。又无始以来有疑心。谓于深法而生犹豫。不决定信此即障也。此火能净除此障。亦是息灾义也。此息灾护摩亦有二种。但瑜伽相应念诵。或外护摩而作火法也。然若能办供者。为兼事作。若不办者但心作即得。有物可为而不作之。但以心作不如法也。第三火尊名为风燥。从风所生。是为风子形燥黑也。此谓内色黑而外加燥形。如上涂灰等也。此尊处风轮中即半月形也。亦作端坐三昧之形。谓行人初发菩提心虽欲进行。而无始来妄惑烦恼根本未除。数来牵破观心而加暗蔽。谓作此法也。风是不住义。又如世间风能坏重云。此不住之火亦如是。能散坏诸障也。此尊坐风坛中。手执帛去头三五寸两头执之。如天衣形。其色青也(此是表风义也更问)此是阿毗阇噜迦法。亦有内外二法。第四赤如日晖住三角中。右手执刀端坐。刀表利慧断结也。如世日初出时。夜除昼现暗尽明现。故取此色也。火神如是形色。光焰亦尔。身相端满。如前住于三昧作微怒形也。第五没栗拏是和合义也。此尊作淡黄色。谓黄兼有火色也。和合者是兼二法也。其像左边作怒状。右边作熙怡微笑形。各生半身也。此微笑是不嗔不大喜。寂住也。身上有毛。谓髭鬓发之类稍多。然不可过也。若多置令不端严也。其项长而有大威光。其身色一边赤一边黄也(怒边当赤)其坐亦右方(半金刚坐也)左三角(半火坐也)左持刀右持跋折啰。有内外二法。例前也。此和合者。能遍一切招召息灾。俱成也。内用即智光。烦恼即灭无生也。若外作时。香花身服亦须二种。念诵时亦作此形如本尊也。仍一目怒一目寂然。灾除愿满一时得成就。以此等遍之理故。得有如是之用。不同偏方之教也。第六火神名为忿怒。即以此名义为真言等如上也。其身烟色者。谓非甚黑非甚白。闭其一目(如不动尊也)其发散上如蓬头之状。作大吼形。谓状如开口大呼吼状也。口有四牙俱出。二上二下。此亦摄二事。一火一风也。第七名温腹。如上世间火中。谓是身内之火能消化食物资身也。此正法中义则不尔。腹内之火即是内证之智也。迅疾谓其形更加忿怒又甚于前也。极忿谓作此恶字也。有种种色。谓形具五色也。义准前。第八名费耗是除遣义。谓一切业垢等事令无余也。此尊能除身中一切障。即毗那也迦之类皆令消耗也。其色如聚集众多电光。不可瞻睹之状。此是金刚轮同类也。第九名意生。谓从意所生之法。随意成也。种种形皆作所念皆能成就。巧谓毗首羯摩也。即是随类现身。普门成就之义。自在之慧随作皆成也。有大力也。第十受食火名劫微。谓火施时受饮食之义也。受食者谓施火食时。受而食之(更问)其尊作持唵字印者。即是梵志仪法也。净行者凡有所言语。皆侧右手作印形而举案之。以唵字声而作相故也。第十一本文缺少第十二名悉成。谓能悉成一切。即是所作已办处。寂灭道场而伏魔义也。又如有一类众生。而为恶不可止遏。假加劝导更增其恶。若纵之又趣恶道。以方便故而伏其身。令悉目闭都无所知。以此因缘善恶俱不能造。次即渐引导之。令入正法也。如金刚顶又金刚手降伏大自在天义。说如上也。此皆住方便道所为也。秘密主此等火色所持者。随自谓火神色。药物等同彼。谓随彼色类也。又偈云。而作外护摩。随意成悉地。复次秘密主。复次明内法也。一性而具三。三处合为一。瑜秖内护摩。大慈大悲心。是为息灾法。彼兼具于喜。是名增益法。忿怒从胎藏。而作众事业。又彼秘密主。如其所说处(谓随类用)随相应事业。随信解焚烧。自己色及药物彼。同外护摩。作此悉地随意者。言此十二种形色。及所持物等。谓识其性。前内外合论。今说外也。三和合。谓火不异神神不异自身也。彼同。是自他俱同也。内作者。本尊即火火即自身也。今谓理释者。本尊即是毗卢遮那。此毗卢遮那不异于自然之慧火。此火不异于我身也。即以一自性三和合。名内护摩也。和合为本尊即火火即同于自己。三事等也。上文如意悉地者。随世上中下事。随意即成也。若不了此火法。无由得成也。内法亦相况耳。若了此慧火者。随出世上中下成就。随心即成也。复次三和合者。谓身口意也。身印口真言心本尊。此三事和合毕竟等。是名三和合也。若能观本尊则自身渐净。净即同于本尊。若见一性即三事俱净。平等皆是。次明内护摩法。即以此三事等。中作息灾即用大慈大悲。此三平等。大慈大悲和合时。一切息灾尊。为第一悲也。若作增益。即以悲及大喜和合也。若忿怒者。火为胎作事。胎即心也。谓有因缘须作忿怒之事降伏于人。即从其内心中而起忿怒。此忿怒非如世间之忿怒也。谓从大悲心中照了忿之实性。而以方便起之。以降伏恶法也。如是等。但内作护摩即能办诸事也。故凡护摩义者。谓以慧火烧烦恼薪。令尽无余之义也。然今此中。略说所用火神及内外之相。当知诸余法教之中。皆有火法等。随应作何事者。皆准此法住于三昧。随彼相应而施作之。即成也。若不如此。但焚薪木空尽供养。不尔。滥于外法又不能成也。又经所言物者。谓所缘火法薪苏食物众具也。尔时执金刚手。白佛言。世尊云何世尊(问世尊云何也)云何火炉三摩地。云何散洒。云何顺敷茅草。愿佛说也。金刚手右问佛。上来数说此火法。然犹未决。当于何处置火。何处安炉等更有何法也。谓洒散敷茅及以物等。皆问佛也。次佛告执金刚手秘密主言。秘密主。彼火炉如其肘量。普皆四方。其缘四指量。金刚围之。次以下二偈。次佛答之。彼火炉如肘量。普遍四指缘金刚围之。谓随所住处。穿深一肘方亦如之。口上安缘。高阔皆四指。用大指节量也。绕缘以金刚围之也。四面各一相接。如上八印等中说也。等者谓深及方圆等也。如方炉。及三角半月圆等可知也。偈云藉以青生茅。绕炉而右施。勿以未加本。应以本加末。谓勿以梢押根。应以根压首也。以茅而右洒。法教当如是。奉涂香花灯。当献于火天没栗拏火。以一花供养安置于座处也。安置已。真言者复洒净之。智者以本真言而作于满施。次息灾护摩。或间增益法。如是世护摩。说名为外事。复次内护摩灭除于业生。谓业生灭也。了知于末那。谓意也。远离色声等。眼耳鼻舌身语意等。皆悉从心起。依止于心王。茅谓青湿。右绕敷之者。谓布茅缘上之法也。当令根首相压。首是上青稍之苗也。假令布东方时。根在北苗在南。仍以苗压次南者之根。不得以根压苗也。次第右绕敷之。至南方即谓根在东方苗头向西。乃至北方次第准此也。洒水谓阏伽水也。阏伽别有方法。如悉地中说耳。然此洒水有二法。若以茅作小束。置阏伽碗中而洒之。洒时顺洒右旋洒也。若直用手洒亦得。然顺洒也。此又二种。若初净火时。谓右旋顺洒。若净了供养之时。当直洒之。不谓旋转也。如悉地中辩之。然未洒时谓请火尊。有真言及印。上品已说。乃是此中所用也。洒了献花次第供养诸物。尔时当观本尊形在此炉中。取上真言遍洒也。满施者。即是用杓物投于火中也。杓有二种。初大方杓名满施。当满盛投火中。次小杓即相续取内火中。然亦须满盛也。别有法亦如悉地中略指。息灾增益折伏三事。当知一切事准此而作也。复次内护摩业生灭。了知彼意者。欲识意者当离于境。既离境。亦知于离根也。然其语在舌摄身意等。从心生依于心王而起也。眼等分别生及境界色等由慧未生时。依心王有妄也。欲息此者。用风燥火灭之。谓以智风火烧也。烧除妄执令得净菩提心也。合有净语也。故云此名内护摩。为诸菩萨说也。以慧是火由风而生。慧是止净心为观。从此已上明世间之事。今次说内护摩出世之事。谓以智火除业生等也。从业受生从生复造业。轮转无已。今言护摩者。正是净除此业。令得清净法生也。业生既除然后用意生。意即心之异名也。此从心生法。离色声香味触。离眼耳鼻舌身意。此等皆心为主。此心王而生分别。当以慧净此心王。即一切法净也。然慧未生时。为障法所动。当准上文。取风燥火而烧灭之。谓用上文深意也。由深慧未生即有分别。以分别故有根境等垢障。今用风燥火而净除之。此火即是菩提心别名也。此菩提心火。而烧妄想等事悉令净除。是名内护摩义也。如是智者。乃可名为菩萨也。所云世出世者。即是事理两法事。即方便所加之火。出世即是慧性之火也。世出世火品了。若论其世间火天。作梵天形。今内法火神。作三摩地形。寂然住三昧也

    次本尊三昧品第二十八

尔时执金刚秘密主。白佛言。世尊愿说诸尊令威验现前。令尊现形。诸真言修菩萨行诸菩萨。由作其形。令行者观缘尊形。即本尊形同于自身。无有疑惑而得悉地。如是说已。佛告执金刚秘密主言。善哉善哉秘密主。汝能问吾等。尔时金刚手秘密主白佛言。世尊愿说本尊灵验。令诸真言行菩萨修行菩萨行。本尊形像观。佛言秘密主。诸尊有三种形。谓字印形貌也。彼字有二种。谓声及菩提心。次印亦二种。谓有相无相。相是色义。谓有像无像也。尊形亦二种。谓净非清净。彼证净形。形谓身也。体同空离一切相。非净有相之身。即有显形众色。彼二种尊形成二种事。有相故成有相。非相故随生非相悉地。上亦列着之。次引佛为证。有相故成有相。佛常如是说也。若心住非想。即成非想也。佛语先标之也。是故成一切种。当住于悲想。言事随心故。宜求出世也。既观本尊形已。为无疑悉地得。此以上金刚手问也。本尊者。梵音娑也地提嚩多。若但云提嚩多者。直所尊之义也。尊亦云自尊。谓自所持之尊也。然彼行者。犹身印真言及观本尊。此三事和合故。本尊即自降临道场而来加被也。然此行者初行之时。尚是凡夫自无德力。何能即感佛菩萨等如是而应耶。但由彼佛菩萨等。先立诚言大誓愿故。若有众生依我此法。而修行之不亏法则者。我必冥应。或虽不来而遥加护之。若行人法则如法而不应赴。即是违本所愿。故不得不应也。如方诸向月而水降。圆镜向日而火生。因缘相应而无思念。此法亦可为喻。非是诸佛有心行。而同凡夫之赴应也。若心不相应事缘有阙。则本尊不加护念。故无应验。非佛菩萨等之过也。然行者以此事故。当须正观本尊清净身。清净身若见已。即以自身而为本尊身。如是无疑虑者。所求悉地无不成果也

经云。缘者。即是行者若约其本尊作如是观也。无疑者。犹与彼尊相应故。无复疑难之心也。是故所修必成。已上问竟。佛言善哉善哉秘密主。汝能问吾如是之事。是故金刚手。极善作意我说之。乃至愿乐欲闻。以金刚手善能次第问疑。为劝未来真言行诸菩萨故。又复慰喻诫劝也。次佛言秘密主。本尊形有三事。谓字印形也。形即尊形也。彼字二种。声菩提心者。谓行者最初修行字。略有二种。观于字义。一但观菩提心。此菩提心即是字也。谓阿迦遮吒多婆等。但举其首。然诸字皆是也。以为初首故。云菩提心也。或观字轮。谓以所持真言为轮形入身。如上持诵品说。或观种子字皆是也。或不观字但念于声。谓上观此声。如铃铎声等次第不绝。及以此声调出入息。如上说皆是也。已说字竟印形亦有二种。谓有形无形也。形即是青黄赤白等色。方圆三角等形。屈伸坐立及所住处之类也。印谓所执印。即刀轮罥索金刚杵之类也。初心别缘而观。谓先观画尊等。约此而观名为有形。后渐淳纯。又以加持力故。自然而现与心相应。尔时此本尊。但从心现不别外缘。故云无形也。私谓或可初得世三昧。见其本尊如是形如是色。如是住处如是坐立。如是漫荼罗中持如是印等。犹是有相故名有形。后转真言宛然直见。如镜像等不想而见。故名无形也。次本尊形有二种。谓清净非清净。谓彼行者初因有相引入无相。先观圆明佛菩萨印身。初作不见。别画像等而观。渐则法力所加。渐得明了。尚有所障。闭目即见开目不见。次渐开目闭目皆得明见。渐渐不加作意亦见。乃至触身亦复无有碍。犹如目对世人等也。由此有相渐引入于清净处。以有相故名为非净。由此三摩呬多所等引故。住清净处寂然无相。名为净也。净者是果。非净是因。非净谓形色印像之类也。由此非净引而成净。由无常之因而至常果也。私谓此三事各有二种。即行次第也。观持真言观于字。次观声渐细。次观尊形又细。次不别缘而观又细。次就无缘又有净不净及纯净也。或可横说之。此三事各有世出世方便。故皆有二也

经云。彼二种。二谓上来三事各有二种也。彼二种中即有二种事。成就有想故有想。非想故非想。悉地随生等云云。谓若以有想事观见者。于有相有得成就。若无相者。亦得无相悉地成就也。又云此三事二种中。随以一事即致成就。然皆有世出世成就及事成理成也。故前三种中。各有二种成就二事。经有想有想欲成。若住非想则非想成就。是故成一种事。当住非想。此劝令离一切想住于非想也。结劝也。以住非想理成就故。一切不思议神变。不加心想自然而成妙业。非如世间成就。在于生灭心行之中而力有限。又非究竟。故劝取其胜者也。私谓然大般若等中。具说洗涤观心之事。然须有本也。今行人先于缘起观。乃至具见十方佛会诸世界等种种境界。以为悉地。而后于般若洗涤净除。即成不思议大用。顿入佛果。若不知行之次第。但观彼文不入深秘致。多错会经意。忽尔入空失圆顿道也。故此一两品。最须谛观其意耳

    次无相三昧品第二十九

复次大日世尊。告执金刚秘密主言。秘密主。彼真言门。修菩萨行诸菩萨。乐欲成就无相三昧。当如是思惟。想从何生。自身耶。自心意耶。然彼身因业而生。等草木瓦石。谓自性如是也。业生之身自性如是也。顽同木石。业生谓从一起此。观是有想。有想为外。外所有身语等。如是观之也。顽同草木性离于作。谓业思生也。从因业生是内也。外生谓木造是外也。次品佛告金刚手秘密主。彼非想三昧成就愿欲。真言门菩萨行修行诸菩萨。如是思惟。从何想生。自身自心意者。即是修瑜伽者。已能观于本尊等。乃至现得种种奇妙之境。然犹是世三昧摄。未得平等慧。今更开示入三平等观也。若此观明白。了自身口意实相。即入净菩提心初法明门。上菩萨地也。此是多释。然大意如此也。先明身实相观者。谓经云。彼身业生草木塼瓦等性。如是作离顽如外作。或业生如形像见等为等。经文也。上来言当住非想等。今此品中。若修真言行者。若欲得此非想三昧成就者。当造斯观也

经云。自身自心意者。谓从心有思生。心是清净心。意是分别也(更问)然此身同木石。其性顽愚者。言此四大若离于心。即同木石也。如大般若观身心处中说。如明目人自观仓囷之中种种米麦等。此身亦如是。身念处观开时。自见三十六物各各异相。尔时身相即除。如开仓见米麦时仓囷名除也。乃至一一皆缘生次第深说也。次又明如身同于像也。如作像者以土木杂物和合为像。或佛或天或余父母形等。以不善观故。随生所尊所爱之想。然一一细观。但众缘合会都无自性。今我身亦尔。诸缘假合。自不了故而生身见。若细观时。都无自性。但从缘有。如幻等境从缘而生实不可得也。又此身者。以因心故状。若六根有知。然实不尔。如人心亦观察则有所住。则虽日月之明或有所不见。雷电之响或时不闻。又如过去一心禅观比丘。乃至道行。有大军过而不见之。当知若离于心。则此身虽具眼耳等根。犹如木石无知也。又如像喻。若此木石等像。或谓火所烧水所坏。刀所伤金刚等所碎。或忿怒粗语加之。不能动其少许心想令生不喜。或种种供养。被以妙衣献以名馔。涂以妙香炫以妙色。乃至人天之供具丰盈于前。亦不生喜。当知像本。性自空。自是我心分别而生增减。或毁或供。俱颠倒不实耳。如外观像者。为以此观而观自身。尔时不见身相离于分别。如是观察其身见身实相。即证无相三昧也。凡观察时见。谓触相有相之缘。渐次深入自然。即相无相即缘无缘。若不得此方便。但直尔观空。而不知以何因缘故空。着是空法多生异见。故修行次第须有指适也。何以故愚童凡夫。于自性空形像。自我分生。谓从自身生我分别也。由此颠倒不实起诸分别。或供养或除供养等或毁骂毁。皆除舍之也。然观身之次合有语观。语观以摄入身观故不别说。今略显之。即是合论之也。今此语从何有耶。谓从齿喉咽唇舌脐等众缘。心动风。互相触故得有此声。犹空谷响都无自性。凡夫不了。故闻好生欣闻逆情生怒耳。今如是见声实相。即知此声不生不灭同于实相。是音声平等性也。次即观心。以法无形相。观闻觉知。先从粗观。了此身平等语平等。自知深入之也。复次秘密主。心性离一切相。思惟性空当思惟此也。秘密主。心于三时求不可得。离彼三世。彼性如是当思念之而离相。复次秘密主。亦自可观察之。行者尔时既观外相。次了内心亦空。此心离一切相。于三世中求皆不可得。如虚空离三世。心亦如是。出过三世出住灭法也。然凡愚以不了心实性故也。复次秘密主。有心想者。谓愚童凡夫之所分别。谓心取相不能了知。不实妄起故。有如是说。彼不如实知。谓由有是妄执。不能如实知也。如是思念。谓凡夫起是思惟也。如是。谓凡夫有此分别也。已上属心句也。复次秘密主。以此真言门修菩萨行诸菩萨。说相引无相也。谓当了知有相而起无相也。谓诸菩萨。如是思惟。得无相三昧。由得住于无相三昧故。秘密主。彼人当得证由除妄故。真言实相实体现前行住坐卧常现前也。如来所说真言。彼常亲对而自住。由识真言之体如前十喻。即是悉地相也。妄谓我心我愚我智我顺我违。自生种种能着之想。以前虚妄故。所有身口亦皆虚妄也。故不知何事耶。谓不见真实。由不见真实故。由如婴童无所晓解。若见心实相时自然离如是一切戏论分别也。以不知心实相故。而生妄执名为凡愚。若了知者即名诸佛也。次经云。秘密主真言行菩萨证得无相定如无相定住得如来说真言亲对而彼常住。此经文引不具。当捡经细观也。此意言。此真言行菩萨。如是离相修行之时。名住无相定也。由住此无相三昧故。如来所说一切真言。皆现前而证。故名亲对也。如是证理之时。即名常住。住者即同佛住也。今品合次于十心说之。说义次第于彼先言不便。故以此中结会而说也。私谓上来经文。大意不过此行。谓口真言身法印意观佛也。然此三事皆缘生法。缘合有。都无自性不生不灭。即是阿字之门法界之性凡夫不知云何得入。故佛先说此三真言门。渐得三昧。乃至亲睹本尊。见种种神变之境。犹是心有所著。不得三平等住。今说入三平等法门。若行者于瑜伽心中。而复能如是观察。离于身口意分别戏论。即得现前而证真言实相同于佛住。自体常住同于如来也

    次世出世持诵品第三十

复次秘密主说秘密念诵法。亦令一一诵诸真言。佛菩萨等别说。谓随彼之中取一一。谓各各也。于诸真言中。随取一一。各别而作心念诵。第二作出入息念诵。此二法最为第一相应也。当如是作此二法。是名第一念诵也。勿异此法也。若异此者。于念诵有所阙。支分由不具故也。然以内外相应。分之有四。我先已说也。今下更说也。彼世间者有所攀缘。谓三种中但观于一字印身。观之识其本性。如印即字字即身。无碍而心湛然。是念诵也。若以字作出入息者。知字即真言之体。以此出入资力。名出入息也。然此二中由出入息。有少所攀缘。故当知意念诵即最为上也。字印尊无所分别。作出入息亦得也。此世出世间持诵品。上来一部经意。只为修真言行诸菩萨等。作持诵入道之法。而今此品。专得其名。当知说一部之要旨也。经初金刚手。已曾问佛持诵之法。上来亦有略答之处。然未具悉。今为决择故。更具分别其宗要之行也。其秘密者。上来诸品所明非不秘密。然此中宗要。乃秘密中之秘密也。一一念诵。或作意声念诵。或作出入息念诵。此明差别行法不同也。一一念诵者。谓专心口诵真言。真言中声出时。一一声字皆悉谛了。不间断攀缘也。作意者。即直是心持。作心想念诵不出声也。出入息念诵。如上所明服风等是也。二相应者谓于三念诵中。其作意及出入息。此最相应为第一也。当勿异者。谓常当依此而作。勿异缘异想也。若不尔者。徒用功无益也。持真言者阙支而用。谓字有点而不道。或字阙。或应长声而作短声呼之。如是类甚众。皆名阙支分念诵也。右此内外相应。合有四种念诵也(即四色是也)言世间有缘相续。所谓字句。句是举足行步。谓观此字如一一步。字即种子字也。次于前已出世念诵身字印合为一即得。今世间念诵即异之。或观字或观尊或观印也。谓句乃本尊。就世间中念诵。出入息最为上也。前出入息最为上者。前出入息。变字为出入息。今世间念诵。见出入息中有字了了分明。是有分别也。前出世间不作如是分别也。于真言中分别为二。即世间持诵者。彼有缘相缘字字句。此中或取一字缘之。或取句等想在本尊心上。如前具明。是外念诵也。取一字者即是种子字。或真言初首之字。若真言小者或具想其句。如上说。如连环等布于本尊心上圆明之中。此二种或字或句。随息出入不绝不间。欲诵时绕也。有经明此义。如观镜像分明而见。今观字见字。观印尊即见之。此是有相也。若行者见此真实相时。即不住有相。然由未入无相。若观菩提心。是一向无相也。此心即是佛。佛即是自身也。自身即成佛。成佛故一相无异。故名无相。随谓或来或去随心也。世间念诵以出入息为上也。当知出世间意念诵。远离于诸字。自本尊作一合相。不坏谓不分为二取。谓分别着于相也。一合相。谓合一为令不取着。不坏此相也。不坏意色相。像与心不相异。故云不坏也。勿异法则谓教法如是也。住如是法。则诵三落叉。如前说我所说。多种念诵谓遍数时节现相增益等。三落叉是数。数是世间也。出世间落叉。是见三相。谓字印本尊。随取其一一合相是也。字印尊等身语心等。名见乃至能令持诵者净。令一切罪除。若不净更一月等如前也。而今所说念诵数。谓牒上文也。不应异此法则也。是故。今耳闻息出时字出。入时字令随息出入也。今谓天台之诵经。是圆顿家数息。是此意也。今以此字一缘与息出入。自然念念相续心不散乱。恬然易入三昧也。此为世间念诵中最上也。又上明尊神者。言此字句念诵之法。诸尊皆尔。上从佛部下至八部。凡有念诵。皆当如是作之。其出入息念诵。亦随本尊法一一有此行法也。出世间者。当知是意念诵之法。离于文字也。岂拨离前来真言字等。方名离文字耶。不如是也。谓能达字之本性即是圆明。当住本来不生者。即心是也。心之体性圆明清净。具足众德而无分别。当观如是之字也。此字者还即即前来本尊真言之字及句耳。但了知此字从心而生。心既圆明湛寂。从心所生之字。其性亦尔。所云离字声等者。谓离分别缘念之心及声想等也。然持诵时有诵有观。或可观行或可兼行。或但修观照也。诵谓如上缘于声字或出入息等。照谓观此字之体性也。然初观时常于有相。若观种子一字其圆明。初即小作。若具观句等。即大作圆明状如连环等。以心观照令宛然分明。后即从此而观其性也。本尊一相作不坏取。意不坏形。勿异法则者。本尊即是初观圆明之字也。次即观本尊。如上已说。一相者即身口意也。观本尊心上作此圆明。即是心。其身印等即是身。其真言字等即是语。今已明见本尊。而观本尊三事。一相平等如于实相。又观本尊三事。平等一相即同于我。我之三相。亦复一相平等不异于本尊。此圆明之性不异菩提心。菩提心不异本尊。自他平等也。又所观字虽不同。然皆是三昧门。若解一字之性相。即解一切字之性相。字即本尊本尊即心。心即法界体性也。是故此阿字。即是不思议字。如阿者。一切亦尔也。如字者。印等亦如是也。于此不思议三相。谓字真言相身印相本尊心相。不遣不立不增益不损减。当作一切平等相观。而达一切法成一切智。当依此法则。勿异此而作也。此即是三落叉义也。落叉梵音。是相义亦是见义也。我于种种经教中。凡有持诵相应处。多言诵一落叉或三落叉等。或言为除罪障故诵一落叉。极重障者不过三落叉。便得罪业清净。然此义有余。今当决之。所谓落叉者是相也。若得三相当是罪得除也。先明身相。谓身体先时粗重今则轻安。乃至或行百里千里。迅疾而往不觉劳倦。速疾异常。先时静坐系缘。多为小虫蚊虻等所恼。今悉不生。无复腻垢可恶之相。广如大品中所说。此是身相也。口相者。随有所诵。暂发声时本尊即至。又如大品所说。口发诚言。非人不娆于他之类。皆是语业净相也。意亦有殊异相。谓发生无量慧解。如经一月四月分别不尽等。或先时贪嗜如是如是食味。或不得者身即不安。尔时寂然不复思念。乃至多日不食。恬然得喜悦之味。无余食想身亦不困。或先多种种烦恼。今皆净息。皆是意净相也。由具此三净相故。名三落叉。若不尔者。徒口诵遍数。无所益也。既得此三相。当更增修胜行也。或时诸天八部飞行空中。不敢履践其影。或来敬礼问讯。天诸童子以为给使问其所须。如此是谁得知耶。但诵持者自知而已。此亦罪除净相也。然上来明离一切相。今说三相。与此云何相应耶。今答此三相以阿字故。此三字即一相。亦非一亦非异。如天台所解。与此略同。谓一相一切相。非一非一切。即相即无相。即非相非无相。皆是此意也。如是三相。平等住实相。是三落叉义也。身实相是一落叉。除一切身垢。语真言相是二落叉。除一切语垢。意实相是第三落叉。除一切心垢。三垢除已三功德生。即是分证如来功德也。又落叉是垛义是标义。如文殊经中明学射。初虽远垛。后渐近之。乃至任运中的。首楞严三昧亦尔。以是因缘名落叉也。复次身印口真言意本尊。即是三行差别不同。即是三相。即此三相入阿字门故。离于三相一相平等。如是照见。是三落叉义。落叉者见也故云勿异者不得他观也。复次前云三句义。谓菩提为心种子即因也。大悲为根方便为究竟。从首至终。皆明此三事。或自显此三德。或为成他三行。言三落叉者。即与此相应也。谓行者最初先须有菩提心相应。此是一切佛法因也。若不发心。即离于妙因何有进行耶。虽已有心若望路不进。有愿无行何能成就大悲胎藏生一切功德身乎。或虽能进行。以离方便故而有疑心。因疑心故一切不成。亦不得入实相也。是故佛诫诸行人。必须依师而学。不得自专以自利根分别力故。辄寻经文便自行之。随闻便用。不入漫荼罗。不受三平等戒。不能具解方轨。以不知故。虽发心修行勇猛精进。然以方便差失故。所为不成。故而生疑心。以疑心故。谤毁如来秘密之藏。即是五无间因。趣五无间道。以是因缘。须具三句义不得阙少。是三落叉义也。已此事故。次后品付嘱中。复明择弟子相。文相承蹑耳。次是观嘱品。经虽不言其义如是也

    次嘱累品第三十一

次佛告大会。即是经文初。云十世界尘数金刚菩萨也。今说经欲了。故加付嘱也。汝等应住不放逸者。即是承摄前文。此大乘密教。当如是法相承。若授受失宜。即是专檀自恣而越法则故。云住不放逸也。复次如上三句义。自利利他之行。汝等当住阿字义。秘密教中而为佛事。若不随此。即是住于放逸也。以差机而授或损彼善根。故经云。有智若闻即能信解。无智疑悔即为永失。若菩萨不深观众生本末因缘种相体性。而率尔传法。即是为人天怨。是为大放逸行也。故次云。若不知彼根不得授与。根即信等五根利钝之相也。除我弟子者。谓已依我教而住。心相体信方堪授之。若余世间外道之类。未入正法信心未固。当且于余深法中示教利善。不得辄尔为说也。若菩萨照机。固自由己智力。今为末代传法人等。更明外迹可传之相也。前经初明择弟子相。今又说之。然皆略举宗。大本中具明也。良晨生者。大本中具明如是宿次如是执曜时节而生。则有如是根性如是相貌。宜即与如是教法。其言甚广。又一一皆有浅略深秘两说。今此中但举其纲目耳。求胜上事。即是发菩提心。唯求如来具足道之行。凡所施为非求余事。所行广普妙也。微细者。谓闻一字一句。即能自以智力广解无量义趣。广演无僻之类也。思念恩德者。乃至从师闻一句之义。乃至成佛。犹不忘报之。常知恩报恩也。渴仰者。谓心殷勤希求胜法。犹如萨陀波伦之类。乃可为说。欢喜住者。谓闻妙法心喜踊跃遍于身心也。不求彼法者。乃至不受余经一字之类也。次又辩其外相。略说其色。谓青白也。即是非白又非大黑。是吉祥色也。大本广明。今但举一隅耳。头广。谓如罗云顶如伞盖之类。然不太广又不合小。要直丰纤得中而相具也。高颈。谓颈不太长又不太短。以要言之修直得中而不过甚也。额广而严。亦谓极理太广。又须具足端严之相也。鼻修者。谓非太隆高非太卑平。当如金铤之类也。略说身心堪为道器之相。如是之人乃堪传习也。彼具相者。谓佛子。如是人当与之。殷勤摄受教之也。瑜伽论十地中说也。又劝嘱必是堪继传者。当勤教授之勿令失时也。时金刚手等具大德者(即是上来会众也)时彼听众闻说是者。于诸本尊所说之教。我顶戴受持得已。谓已如受王教奉行流布。当作供养。时众重起礼佛。为法久住故请佛加持也。问佛所说顶受奉持。为一切智作礼而请如来加护。所以者何。佛已付嘱如是秘藏。以荷重任行如来事其职不轻。然此妙法。如来在世犹多怨疾。何况末代恶世之中。然我等已发诚愿。要令如是之经广行流布也。是故请佛以自在神力。加护我等令所愿得成也。法眼道久住世遍一切者。即是弘经之愿。以佛加持愿令此法眼久行于世也。此是开佛知见之大慧道。一切诸佛所行之路。故云法眼道也。当令此道久住于世穷众生际。又横遍世界无不流通也。即是上行等云。随佛有迹之处我皆誓传此法。此本问弘经之意也。时佛受彼请故。即以真言而加持此法。如经中说也(未说句义更问)时诸上首菩萨等。闻佛说已顶戴受持。已广说摩诃毗卢遮那成菩提加持神变经竟。问前三句。一者菩提心为种子。二者大悲为根。三方便为后。今就大悲藏漫荼罗说之。为以中台为菩提心。次八叶为大悲。外三院为方便也。答云此有二种。若有修行者因中说之。有如来之果地说之也。且如最外院八部等世天。即是前八心中从初解守斋已去。乃至受用果等也。然有善根开发与正道相应。即是大悲胎藏花台之因也。如来以方便力而引导之。乃至令成就世间八心以来。即是外院之位。次渐渐向里。及二乘亦在此内。次又知有胜法无上心。稍进引入第二第三。皆是大悲句也。次成佛果入中胎。即是方便句也。然此八叶及中胎五佛四菩萨。岂异身乎。即一毗卢遮那耳。为欲分别如来内证之德表示于外故。于一法界中。作八叶分别说耳。且如四菩萨东南。普贤者何也。普贤者是菩提心也。若无此妙因。终不能至无上大果。故最初得名。次文殊师利者大智慧也。先发净菩提心。如普贤观经次第。乃至毗卢遮那遍一切处。常乐我净波罗蜜等之所摄成。皆是净菩提心也。次即说第一义空。我心自空善恶无主。观心无心法不住法等。即妙慧也。以此第一义空之妙慧。净彼遍一切处净菩提心。平等慧利刃。断无始无明根。即入菩萨正位。故虽有菩提心而无慧行。即不可成果。故次明文殊也。次西北方弥勒。即是大慈大悲。俱是第二句中之义也。以此大悲藏。增长成就妙菩提树枝条花叶。故次说弥勒也。若慧而无悲。则方便不具。则不得成菩提。不能具六度摄众生也。次东北观音。即是证也。证谓行愿成满。得入此花台三昧也。若就未成果时观之。此则差次浅深。今以如来平等慧观。从因至果。但是如来一身一智行耳。是故八叶皆是大日如来一体也。若如来但住自证之法。则不能度人。何以故。此处微妙寂绝出过心量。说何示人耶。故渐次流出渐入第一院。次至第二院。次至第三院。虽作如此流出。亦不离普门之身。其八部之众。皆是普现色身之境界也。若就情机而说。则三重坛。从深令至浅。乃至世天真言义浅。但是应身道。方便未究竟也。若开实性。即世天真言与大日如来。何相异耶。从如来。则从深至浅从内渐外。而成三重坛。从众生。则从浅至深从外渐内。而成三重坛也。又如字义。即是此之次第也。初阿字在东方。如梵音阿字即有动首之义。以顺世间法诸方中东为上故。喻菩提心最是万行之初也。其名曰宝幢佛。次即是阿(平)字是行也。若但有菩提心。而不具修万行。终不成果。与前四菩萨义不殊。其佛即是花开敷也。次即暗字三菩提也。以万行故成正等觉。其佛名阿弥陀。即西方也。次鼓音即是大涅槃。其恶字是正等觉之果。果故次说也。次即入中恶(长声)字。是方便也。此是毗卢遮那佛本地之身花台之体。超八叶绝方所。非有心之境界。唯佛与佛乃能知之。为念本誓开示大悲藏。普引众生入佛慧故。复以加持神力。普现身口意。遍满生死中。当知此即是方便也。若离方便。如来本地尚不可说。何况以示人耶。不可为诸上首等菩萨说。何况流入生死中耶。以此方便同于大空。而现众像。当知一切大会漫荼罗。皆是一身无别身也。即是普门身。即是法界身。即是金刚界身也。又菩提黄色。是金刚性次行赤。是火义。即同文殊之义。万行以妙慧为导。不得离慧而有作也。次成菩提白色。即是圆明究极之义。又是水义。如我昔所愿。今已满足。化一切众生。皆令入佛道。为是事故。是起大悲故也。次即是大涅槃迹极返本。众生有缘之薪尽则如来方便之火息。故涅槃也。佛日已隐于涅槃山。故色黑也。中心空。具一切色。即是加持世界漫荼罗。普门之会。毕竟清净无所不有也。其百字轮。所以从外向内。亦是此义。如中台者。一切本尊亦如此说。如金刚手种子◇字。嚩即成五事。嚩是菩提心。◇是行。◇是三菩提◇是涅槃◇是方便。所以云方便为后。是此义也。如莲花尊亦有五事◇娑是菩提心◇是行◇是成菩提◇是涅槃◇是方

便。如文殊以◇字为种子。亦有五义◇菩提心◇行◇成菩提◇涅槃◇方

便。余一切尊种子字。皆亦如是广说。以是义故。金刚手者即是大日如来。观世音者亦是大日如来。文殊师利者亦是大日如来。乃至鬼神八部一一亦有此义。亦即是成大日如来。体虽是一。而义各异。所以瑜伽中云。毗卢遮那言我即是文殊观音等。我即是天即是人。即是鬼神即是龙鸟。如是等无不即是者。由此义也。又云。此大悲藏本尊位次等及形色各殊。为未深入瑜伽者初学之时。不正观本尊故。佛以方便示此。令心有所缘耳。及观成时。以法力所加故。自然恒与佛会相应。设不作念犹自明了。况加观耶。如是时。自然真见漫荼罗也。此地者。即是净菩提心是。已上所表。皆是大日如来法身妙庄严之相也。又观音文殊普贤弥勒。已在八叶中。即大日如来大法身也。为度人故渐出于外。故次图中复有文殊观音等。以类可解也。又云。如八叶中。普贤是菩提心。文殊是慧。弥勒是悲。此菩提心即是大日如来。而有菩提心也。大慧即是大日如来。不离此大日如来别有慧也。悲即是大日如来。不离于大日如来别有悲也。当知准此说之。万德皆尔。犹如天台法身般若解脱义。若但法身主得名之类。与此相合也。问百字轮外内。一一作如是次第。即是漫荼罗引入。渐摄至于中之义耶。答此谓于因果也。若修行者。初发菩提心。次进行。次成正觉。次住涅槃。次起方便。即作如是次第也。若自果地而说者。即以◇迦字最在内。次◇行。次◇菩提。次◇方便最在外也。其◇迦字同于◇阿体。即为法体之果。不作菩提心因地之说也。从法身起应。次流向外。以度众生。犹如漫荼罗自中台出。至八部世天之位。又从外引入佛果。犹如漫荼罗从乃至八心之初。直至成菩提方便等也。云仰壤拏那么等字。亦随出入义。或在百字内。或在百字外也(更问)又问就行者心中观行。作漫荼罗大悲藏义。即以中台为菩提心。渐次向外。乃至世间天位为方便耶。答凡进行者。有次第也。先依法持诵。作真言手印等观于圆明。或但观字或但观印。随作一事成时。三事成也。初观圆明亦不能见。由手印真言及念本尊故。三业渐净心障净故。即渐见圆明。若见圆明时。或于其中有本种子字宛然明着。如其形色也。若得如是见时。自心乱想息除。湛寂心常一。不为外缘所动也。既如是见犹是外缘。次当引外向内作如是观察。此圆明者。即从我心而出。当知内亦复如是。夫圆明清净。即心之体性。无别法也。犹勤方便观察内心故。即见此圆明字。唯是自心。不复外缘也。乃至若外圆中。明见本尊等。如上方便。今内观时。即是自身作毗卢遮那等本尊也。既如是与瑜伽理相应。即是随分成就也。以瑜伽相应。所观随意即成。即观此心八叶。如上方便。即于此心花台上。为漫荼罗中胎。其外八叶。亦随佛位次列布也(又云此八叶即是大悲藏第一重也)尔时行者。观心八叶作中胎。观其身即是漫荼罗。从心以上为第一院。从心下至脐第二院。从脐以下为第三。世间天院。诸尊形色相好。各各差别宛然。其自身中而现对之。犹如亲入佛会也。然未见谛人。犹未能如毗卢遮那作种种神变等。但是观心成就耳。然有一事真实不虚。所谓我即是也。我即是者决定谛信我即法界我即毗卢遮那我即普门诸身。此事不谬。如上真言。加持义中我即法界是也。又云。法身而有自在神变加持。此不足疑也。如瑜伽金刚顶中引数百喻。大本广说其意。云如帝释处在天宫中。其地一切皆琉璃宝。外内清净。一一天众自居其宫室内。而见帝释常在其宫宛然相对。何以故。以此地等一切皆妙宝所成。递相晖映更相引发。彼不来此不去亦不相和合。而缘具故如此。而实无生无所有。不可不信也。又如诸天在欢喜园。放逸太甚。尔时以其宿业力故。从树叶于中有法教之音。呵彼令住正行。尔时天等。即暂止放逸心念善行。然实一一树叶中。求不可得。亦不从天身中生。不自不他而成此事。又如与修罗战时。天鼓出声安慰天众。令发勇健之想。令修罗怖畏退散。而实此鼓无形无住处。但以诸天功德众缘所成。皆不可思议。况法身耶。又如大梵王在本宫中。一切天众念欲得见者。无不皆现其前。以诸天等。皆知彼清净行又端严相好第一故。烦恼贪欲等心息。为生无量善愿。随分进修净行。然梵王于本宫中。不动不摇亦不作意。我当普应于彼而。各各皆现其前。皆作是念。独为我现为我说法。是等世间以少福愿。尚有如是不思议用。何况如来法身。而不能成就如是自在神力加持神变耶。然常途说法。或云法性或云法身。寂静如空无所动作。都不说具足如是力用。以为凡起神变。皆是有为之心三昧之力。而不言法体。如是此其未了也。问漫荼罗第一院东方。唯有三角虚空眼及如意宝三事。余空缺云何。答如真言及手印中。如如来毫相如来舌。如来牙如来齿。如来脐如来甲等。皆在此重也。当次列之。其佛顶在第三院。此中无也。问宝幢佛是何义。答此是菩提心也。如世军中有幢。是众中之军首之标帜。咸所瞻望。进止之节莫不随之。犹如一切万行。皆为此菩提心也。以之为标为主。故得名也。次宝幢即云华开敷佛何耶。自此是行义。十度万行资菩提心。次第敷荣。牙茎花叶滋荣可爱。故得名也。次花开敷云阿弥陀何也。此是受用佛。即是成大果实受用其果。无量不思议现法之乐。皆得名也。次鼓音佛者方便也。既得大果。是自受用而已即普为一切众生演之。种种方便成所作智。犹如天鼓之音无思而成事业。故得名也。又前云北方阿閦者。经误也。此是瑜伽义。与此不相应。以鼓音佛为定也

大毗卢遮那经释义卷第二十

嘉保二年二月廿日于金刚峰寺奥院东庵室观音院大僧都奉受了

观音院大僧都宽意大御室性信御付法也式部卿敦贞亲王御息东寺第二长者存日辞退高野山御笼居云云　从嘉保二年至宽永六年五百三十五年也

                      广泽受法末资显证记之


大毗卢遮那经供养次第法疏

    No. 1797 [cf. No. 848 Fasc. 7]

大毗卢遮那经供养次第法疏卷上

        零妙寺僧释不可思议撰

  稽首毗卢遮那佛　　实相法智缘起法
  圣者妙音阿阇梨　　垂恩令证法性海

    大毗卢遮那成佛神变加持经供养次第法真言行学处品第一

释此经法四门分别(初述大意　次说来由　三释题目　四随文解释)

初述大意者。夫真性至理离言绝像。应机示现无相非显。所谓阿字等门妙明其理。今此经者理蕴于词意绝文外。是故以如来加持神力对以秘印导以真言。所以若不从师受学。禁入其门。非其人者制妄授传。未经灌顶禁其辄闻。若得见闻顶礼者灭除恒沙之罪。如说奉行者德海集于其身也

次说来由者。昔在中天竺国王有四子者。其王临命终之时。王后请问大王。若崩以后何子当为嗣位。王即答曰。小子可能继位也。于是父王崩后。大臣百寮皆悉来集请问遗制。王后即答如王终言。是时王后及诸兄并大臣等奉请小子将继王位。小子答曰。我有誓愿。出家学道望济群品。不堪继位也。母后等再三重请如父王遗言。小子亦如前辞谢。母后等再三请已后强令继位。小子不敢违逆。遂即王位之后更亦思惟。我住此国不得出家。我之阿姨邻国为后。宜以投托必能出家。方便逃出奔赴其国。到彼国境即有镇将问曰。汝何人也。小子即答曰。我是中天竺国之王也。镇将曰。若是国主何以独来也。答曰。我本冀望出家学道。若久住本国必不得出家。深冀出家学道礼拜。遣使闻奏。王后闻之使人来迎。小子见王后胡跪说志愿。王后闻说悲泣流泪哀愍伤心。良久曰。汝姓是刹帝利。净饭王子孙释迦如来远从侄也。我闻释迦舍太子位。出城入道乃成正觉。天下难舍唯弃宝位。汝同释迦舍国王位发大誓愿。必得成佛哉。今日以后随百姓门。持钵乞食粗饭持斋。可以悲伤矣。虽然大丈夫所冀至心誓愿。无可奈何。便许出家。为请境内高德法师。为作弟子出家学问。小子禀姓明慧。一闻便领妙宗。二问比知千百。虽学不多年。所学者尽达。于是其法师辞曰。我之所解尽矣。更无所以演说。吾闻其国贤圣太德。宜到彼所而学也。小子奉教礼谢而退。往至贤师之所。修学如前。乃至经历五十余国。乃至北天竺。乃有一城名乾陀罗。其国之王仰凭和上受法念诵。其经文广义深。不能寻遂供养次第。求请和尚供养方法。和上受请。于金粟王所造塔边求圣加被。此供养法忽现空中。金字炳然。和上一遍略读分明记着。仰空云。谁所造也。云我所造也。云谁我也。云我是文殊师利也。即唤书人遂便写取。即与其王一本。自写一本随行将行流通四方也。所谓小子者。厥号善无畏三藏和上。即是小僧不可思议多幸。面咨和上所闻法要随分抄记

三释题目者。大毗卢遮那成佛神变加持经供养次第法真言行学处品第一者。大者即是无边义也。毗卢遮那者是日。所谓即慧日也。成佛者证正觉正智义也。神变加持者神力所持也。经者贯穿缝缀能诠在此矣。供养者理事供养。理者会理入证。是云理供养也。事者尽心竭力营办香花供养佛海。是言事供养也。次第者作礼及发遣之前后次第也。法者轨则之义也。真言者简虚妄也。行学者行学真言也。处者此四种。一如法界自性。二教本也。三传教师也。四妙山辅峰等也。品者品类也。第一者此法有五品。此品最初故言第一也。是以言大毗卢遮那成佛神变加持经供养次第法真言行学处品第一

四随文解释者。此中有三分。谓序正流通。第一品是序。次三品是正说。末后一品是流通。就序分中初有二颂。归敬劝信序。然初以下精勤修行序。初中有四门。初中二句者敬主叹德门。次二句者依经所现门。次二句者成法得益门。次二句者契本结说门。毗卢遮那此云日也。开敷净眼者开悟妙理也。我者文殊也。供养者理事供养也。所资者诸本尊也。众仪轨者诸印真言等也。为成次第者礼拜发遣也。如彼者指慧日尊也。令本心者令悟本不生理之心也。我今一句者结上已来之意。精勤修行序中分为六门。初一偈之全成就信解门。二一偈之半劝信三宝门。三有情信解以下廿五偈劝行制戒门。四依此正住一偈依正戒重禁门。五妙真言门一偈觉心得益门。六欲于已下十偈一生成佛门。就初段中。然初自他利成就者举所成果。无上智愿之方便者明能成智。成彼者指所证果。发起等者举果显因。约第二段中。于满悉地诸胜愿等二句总表佛僧二宝。彼等等一偈别释也。真言形者即是真言字所庄严身。所住种种印威仪者明印及右胁而卧也。所行道者即是如法界自性。方广乘者即是大日经也。以上明谛信三宝了也。问此中归敬三宝与初分归敬佛宝其义云何。答初分者显文殊自敬。此中明后代修行者法则。问文殊归敬三宝不耶。答归敬。所谓我依大日经者即是敬法。不轻自身即是敬僧也。同体三宝可知。约第三段中。有情信解上中下者即是六趣众生也。若于最胜等者指前大日经。调伏行者不犯三昧耶也。别律仪者谓大日经也。具缘众支分者是修造道场支分也。一心住者一心系师所。三昧耶者明平等本誓等也。道场者妙圆坛也。教本者是毗卢遮那经。亲于尊所者为灌顶之师也。获胜三昧耶及护者受传法灌顶之人所得也。摄正真言平等行者。于本不生理中安心不动也。入此真言最上乘者入者解也。最上乘者即是毗卢遮那所证理自体。密行者行真言行者。轨范者即阿阇梨等也。广大诸功德者。轨范者即是功德大海。功德大海住在其身也。何以故。经云。若欲见佛礼拜。若欲供养佛礼拜供养。此人与佛无异也。何以无异者。以五种真言心及印等庄严其身故。契经者指毗卢遮那经。莫过嗔者如华严经广说也。净菩提心者即是真言也。常怀忍辱不观过者。于世间法忍中难忍。唯有背恩德者故劝励忍也。俟者待也。所谓俟时者。正欲修真言者三昧之时也。忽有檀越请讲说者。即语道我修三昧。以后为汝讲说。当时不可也。清白醇净法者。于体理中恒有得恒沙性无漏功德及布施等诸度门也。由诸酒者。此酒放逸之本。若饮者乱三昧也。增我慢者。增妄执。妄执深则习定更远。今已等者叹略言义深。令广知解生决定者赞多闻之益也。从上以来戒理定慧略说已了。第四段中依此正住平等戒。正住平等戒者。住戒性心不起持戒心也。前以明德此禁犯因。第五段中妙真言门觉心者等相应者有二。先观本尊。观本尊熟自身作本尊。此心不散乱言相应也。智者悟本不生理。第六段中明法者真言也。智者蒙师等二句结前起后也。妙山辅峰以下三偈半表行者所依处。此中有四处各有表制。一妙山者高妙名山也。辅峰者大山怀里之峰可居安隐也。半岩间者石壁之中有穴可居也。龛者有三种。一室龛。二土龛。三石龛。谓似窟而安尊像处名为龛也。窟者石室也。两山中者泉石清洁修行安稳处河等处。芰者菱角也。荷莲叶也。泾川者常流水不绝也。洲者水中可居所也。岸者侧傍也。谓河之崖侧清洁之处可居修道。次一句现离可不宜处也。愦心乱也不静也。谓人物所烦乱闹也。三明草木林树处。扶疏者树木敷茂貌也。林薮寂寥可住修行处也。乳木者桑谷也。祥草者此土黄茅也。次二句明其可不也。四明寺塔处。练若者三。一达摩。二檀陀伽。三摩登伽。达摩者是菩提场也。檀陀伽者是无秽草也。摩登伽者无諠动处也。此中所说者约摩登伽也。次一句明简可不也务事也。五欲者色声香味触。诸盖缠者五盖。悭贪嗔昏沉睡眠掉举散乱疑盖。悉地者成就亦云成菩提。云净命者小欲知足之行。胡语头陀之具有十六。经论隐显故说十二。十六衣四食六处六。衣四。着粪扫衣。着毳衣。着纳衣。畜三衣。粪扫衣者。火烧牛嚼鼠啮死人衣等。外国之人如此等衣弃于巷野。事同粪扫名粪扫。行者取浣染缝治用供身。问何唯受此衣。三品。下治生活贩种种邪命得衣服。中远离前过受僧衣且越施衣。上不受僧且越受粪。何不受僧受此衣。僧法须同断理僧事。处分作使断事宾人乱心废道。何不受且越。若受且越。为衣追求多堕邪命。又则生亲着难得出离。又得处偏亲不得处便疏。妨等化。又数得生慢不得怨言。彼无知不识福田应施不施。或自鄙耻生忧悔。又数往废道不去致恨。又憎嫉好人谗谤良善。不欲便往见。是多过。是故不受且越施衣。何唯受粪。少事增道离过无罪。故唯受之。言毳衣者。湿洗鸟狩细毳。行者无粪可取得此为衣。言纳衣者。朽故破弊缝纳供身不着好衣。何者。若求好衣生恼致罪费功废道。又好衣未得道人生贪着处。又在旷野多致贼难或至夺命。言三衣者。五条七条大衣。上行之流唯受此三不畜余衣。何者。白衣求乐畜种种衣。外道苦行裸形无耻。佛住中道舍离二边。故畜三衣。又求多衣费功废道。少不济事畜三衣。然三衣供身事足。若营作务大小行来着五条。为善事着七条。化摄俗人令至敬信须着大衣。又在屏处着五条。入众时着七条。若入王宫聚落之所须着大衣。又调和温暖之时着五条。寒冷之时加七条。寒苦严切加以大衣。故往一时正冬以夜天寒裂。如来于彼初夜分时着五条。夜久转寒加七条。于夜后分天寒转盛加大衣。佛便作念。未来世中不忍寒苦诸善男子以此三衣足得充身。以此多义故畜三衣。食中六者。一乞食。二次第乞食。三不作余食法食。四一坐食。五一揣食。亦名节量。六不中后饮水。乞食者。人中有三。下中上。下品之流虽恣出家邪命自活。耕田种植活生。方博作诸工巧种种邪命自在活。中品舍离前过受僧食且越请。上行之人不受僧食且越请食。唯行乞食。何不受僧且越请。过同前。何义故专行乞食。所谓有二。一自为省事修道。二为他福利世人。次第乞食者。通亦乞食收。彰乞食时离于偏过。别论凡愚贪味弃贫从富。小行悲狭舍富从贫。上行之流离贪去狭等慈众生。不简贫富次第乞等。言不作余食法者。律中说。有人虽复次第乞食。于求处数得正食余食法数数食。行者作念。此余食法世尊虽开听病者。我今无病不应受。是故不作余食法。通而摄一坐食收。故经论中多不别说。律中别者。彼一坐食不于中前食余小食。此约远离数数正食有此不同。见故别说。一坐食者。有人虽不数数生食。而于中前数食其余饼果粥等。行者作念。愚夫养身为增烦恼受数数。我今为道不为养身。为破烦恼。不为增结。故受一食。又思为求一食已妨道。况求多食。故唯一食。又观。饭食多若中生。若受多食恼乱弥多。故受一食。又观。饭食信心所施。一食叵消。何况多食。故受一食。一揣食者。经中亦名节量食。一受便止名一揣食。节俭少食名节量食。何况爽。有人虽受一食法。于一食中恣意饱啖。腹满气胀睡眠消息。半日不灭妨修道法。故须节量。又多食增长烦恼难可折伏。故须节量。又多食增长睡眠。难消如病令身不安。故须节量。又行者为求法身渐舍食身。故宜节量。节量至几许。随己所堪三分留一施诸鸟兽。余便自食。能少益善。所言不中后饮浆者。有人虽节量饮食而犹贪味。于中后饮种种浆果浆蜜浆石蜜浆等。为求是浆多致邪命费功废道。是故不饮。又观。此心难放纵。如马无勒左右啖草不能疾疾随。御者意加以辔勒。方能速进随人意去。故裁断。处中六。一在阿兰若处。二在冢间。三在树下。四在露地。五常坐。六随坐。阿兰若者此翻名为空闲处。如杂心说者。一弓有四肘。去村五百弓名一俱卢舍。半名阿兰若处。计有三里许。头陀行者极近在此。能远益善。何在此。行者作念。我本在家父母亲属共相缠缚。为是舍之今出家已。若还师徒同学知识共相结着。与俗无异。是故须舍在兰若。又聚落男女参杂多增俗染。不宜住中。又近聚落音声愦闹妨修定意。言冢间者。冢间多有尸尸。烂坏膖胀臭秽。睹臭秽易入不净观门。又冢间死尸破坏。由食火烧分离散灭。睹之易入无常观门。又冢间骇骨分散。见之易入空无我观。故在冢间。言树下者。前在冢间观察死尸得道事办。故舍冢间来至树下。又前冢间取死尸相。然彼多有哭泣等声妨修止观。故来树下系念思察。又树荫覆事同半舍。安身修道。故在树下。有佛贤圣得道证果多皆依树。故在树下。露地坐者。树下荫湿久居致患。故至露地。又树上多有鸟雀音声。闹乱妨修定意。故在露地。又行者久在树下着树心生。或复分别此好彼恶。为除是患故须舍树来至露地。明了显现所谓无碍。故在露地。又露地月光明照心想明净易入定。故在露地。常坐者。四威仪中行立太苦。卧则太乐。坐离二边堪能长久。故须常坐。又行立心即掉动难可摄持。卧则昏沉入睡眠中。坐离沉掉故须常坐。又求道者大事未办。诸烦恼贼常伺人便。不宜安卧故须常坐。又中多有成办食易消化。气息调和故须恒坐。言随坐者。随有草地得处便坐。故曰随坐。随别细分有此十六。经论就此隐显合宣说十二。依四分律。衣中立二。食中立四。处中立六。合为十二。衣中二者。一着纳衣。二着三衣。余皆不论。食中四者。一乞食。二不作余食法食。三一坐食。四一揣食。次第乞者乞食中收。所言中后不饮浆者。一坐中摄故不别论。处六同上。依十二经衣中立三。食中立三。处中立六。合为十二。衣中三者。一着粪扫衣。二着毳衣。三畜三衣。余皆不论。食中三者。所谓乞食一坐一揣。余皆不说。次第乞食中收。不作余食法食及中后不饮浆一坐中摄。处六如上。大智度论十二与前复异。衣二着纳衣着三衣。与四分律同。食五。一乞食。二次第乞食。三一坐食。四节量食。五中后不饮浆。不作余食法摄入一坐更不别立。处中说五除随坐。余如上。若依如上所说修行者名为净命人也。若虽如是依如上说。求名利者亦名不净行人也。亦道邪命人也。亦道佛法中大贼。是故经云。诸鬼见此者扫其脚迹。即其义也。说净命行竟。已下说邪命不净行。邪命四种。一方口食。二仰口食。三遗口食。四下口食。十住论第二云。五邪命法。一矫异。二自亲。三激动。四抑扬。五因利求利。矫异者。有人贪求利养故。若作阿练若。若着纳衣。若常乞食。若一坐食。若常坐。若中后不饮浆。受如是等头陀行。作是念。作是行得供养恭敬。我作是行或亦得之。为利养故改易威仪名为矫异。二自亲者。有人贪利养至檀越家语言。如我父母兄弟姊妹亲无异。若有所须我能相与。若有所作我为作。我不计远近能来问讯。我住此者正相为耳。为求供养贪着檀越。能以口辞索别人心。如是等名为自亲。三激动者。有人不计贪罪。欲得财物作得物相。如是言。是钵好若衣好。若户钩好若尼师檀好。若我得者即能受用。又言。随意能施此人难得。又至檀越家作是言。汝家羹饭饼完香美衣服复好。常供养我。我以亲旧必当见与。如是示现贪相是名激动。四柳杨者。有人贪利养故语檀越言。汝极悭惜尚不能与父母兄弟姊妹妻子亲戚。谁能得汝物者。檀越愧耻俯仰施与。又至余家作是言。汝有福得受人身不空。阿罗汉常入出汝家。汝与坐起语言。作是念于檀越生是心。更无余人入出我家。必谓我是。是名柳杨。五因利求利者。有人以衣若钵僧伽梨若尼师檀等资生之物。持语是人言。若王王等及余贵人与我是物。作是念。檀越或能生心。彼诸王贵人尚能供养。况我不与。是人因以此利更求余利。故名因利求利。若顺诸佛菩萨行者。行人捧心示于佛。以此身心对人畜。又对墙如人面。无处造恶佛欢喜。故言顺佛菩萨行。于正真言坚信解者。谓此真言知从清净法界流。以此智慧力如金刚不动不摇坚信解。具净慧力能堪忍者。知此身心妄想起。妄想休息如太虚八风。所过不动念。故言慧力能堪忍。精进不求诸世间者。弃舍名利如涕唾。莫心回顾如烂尸。直求悉地救头燃。故言精进不求世间。常乐坚固无怯弱者。勇猛精进如金刚。随不失如师子。是以坚固不怯弱。自他现法作成就者。见他得利如自获。若见自身得利必与他。故言自他作成就。不随余天无畏依者。住心本尊直进修之。傍闻赞天不改动。故言不随余天无畏依。具此名为良助伴者。世间出世所有善凡圣见皆欢喜。故言具此良助伴

    增益守护清净行品第二

将释此品四门分别

初释名者。随修性理清净行。护戒保身言守护。修必得果言增益

二来意者。前品所说清净戒。此品能护所说人。是故第二此品来

三宗趣者。能修行人蒙法力。以用此品为所宗。用不坏身住佛心。自悟悟他。此品所趣

四摄文者。此品大分有二。初二偈半当品之总序。二次于脐以下别释。初总序中初二句结前起后。每日先住于念慧者。每日者。受法当日初修乃至成佛。于其中间三时不阙言每日也。念慧者念师慧也。依法寝息者。右胁而卧。右手为枕。左手长申髀上押着。即是也。初起时者。受法夜即其后夜出明相时也。为障者。生死流转三毒烦恼为根本。悟三毒烦恼本不生。即是除障也。是夜者。受法以前生死长夜也。放逸所生罪者。根尘和合所生罪也。殷勤者。如救头燃依法念诵也。寂根者。悟根本不起也。具悲利益心者。慧简劣小乘。显大悲勇猛也。誓度者。众生界不尽我愿不休也。如法澡浴者。外浴必用香汤水也。或不浴者。内浴达无身法可浴也。二别释中有十五真言。即是十五门也。门皆有偈颂真言。就颂中斋室空静处者。妙山辅峰等处中所造作坛念诵成就悉地室也。散妙华等者。凡所奉献各随诸尊性类及漫荼罗位等。一一善分别之。当令色香味触适悦人心。于白黄赤三色中。如来部类当用白色。莲华眷属以黄色。金刚眷属以赤色。复次当如漫荼罗方位中。圆坛者以白。方坛者以黄。三角坛者以赤。诸世天者以赤。钵头摩是红莲。青黄白等水生诸莲皆可通献诸尊也。龙树花弥勒世尊于此树下成佛。其直言龙花者。是龙中所尚之花。西方颇有其种。其计萨罗花娑罗树花皆是天竺所有。此方无也。但使人心所好。世间以为吉祥者。皆可供养。当一一在意善分别之。采集以为鬘。为错杂庄严。或缀或结。以行人殷净淳厚心故。则令诸尊欢喜护念也。随置者前所造堂也。典者大日经也。当依本尊所在方者。一云。前念诵堂本尊所在方也。二云。十方世界随机显方。如东方药师西方阿弥陀清凉山文殊等亦得。一心住者。结心本尊目不暂舍等也。五轮者身中五支也。归命者。众生所重命为最珍。用此宝藏奉献三宝。用真言印等也。身口意清净业者。舍命归尊言净业也。真言中作礼方便者。由此作礼真实言者。真言即是实相智。诸尊以实相智为身心。以实相智真言诵。即遍至实相智尊。实相智尊一时顿受真言礼。故言即能遍礼十方佛。右膝着地以下一段出罪方便真言门。诵真言同前。实相智自无罪。若执有罪。此智能令解无罪。是故言出罪。南无十方三世佛以下第三归依方便真言门。此真言智外无妄。外无妄处即是真言。自身若诵此真言悟自真。故言归依。亦有诵真言。颂中南无者。度我也亦云礼敬也。三种常身者。法身等三身。悟生死本不生故言常身也。正法藏者。正者蕳邪。法者轨则。藏者含恒沙德也。大心众者。菩萨乘也。我净此身离诸垢以下第四施身方便真言门。亦有诵真言。真身以外无别身。三世如来亦同体。众生妄执有别身。此真言门能令解我身佛身等无别。故言施身。净菩提心胜愿宝已下第五发菩提心方便真言门。有诵真言长行。我身佛身既无别。佛菩提智同我智。此真言令悟此法。能令知云发菩提。增加者能显真言义加也。菩提心者自性清净自觉也。心者中实义也。故云离一切等也。蕴者五蕴也。界者十八界也。处者十二处也。能执者妄心也。所执者妄境也。舍离也。法无我有者离妄境等也。自心平等者无妄想也。又自心者妄想自心也。平等者妄想自心本不生也。是故云能执所执乃至本来不生。如大空者。大慧日轮中无生死昼夜别。自性者慧日即为身。捧妄不生令同真性故云如也。此增加句译人赞叹梵本也。若能诵梵本者第一。依汉文得意读诵亦得。道场者寂场也。十方无量世界中以下第六随喜方便真言门。亦有诵真言。如实智自无有嫉。自无嫉智令无嗔嫉。至诚念诵此真智令不异真实之智。故言随喜方便法。我今劝请诸如来以下第七劝请方便真言门。颂真言同前。真智大悲恒利物。利物故降法雨。至诚念诵此真言令请法住世。故云劝请。愿令凡夫所住处以下第八奉请法身方便真言门。颂真言同前。法身恒住于本真。以恒住故令至法身。诵此真言直奉请。故云奉请方便法。所修一切众善业以下第九回向方便真言门。颂真言同前。本觉真智外无散。以无散故同回向。勤苦念诵此真言。归真本法云回向。复造所余诸福事以下第十入佛三昧耶明门。是生法之身也。此中有颂印真言。所余者念诵真言以外也。遍清净者。自三业中不净令不生也。哀愍救摄者。即是他三业中不净令不生也。心性者。如心本性自清净也。身随所应者。面向本尊也。又于三部五部中以何尊是我本尊者也。以安坐者。头顶鼻脐皆悉正直结跏及半坐等也。净除三业道者。不生三业不净即是道也。印者。真言所依身也。问身智云何别。答身是诸功德所依。智即照明义也。然则约用别而约体一也。入佛三昧耶持明经云。时薄伽梵住广大法界加持。即于是时。住法界胎藏三昧。从此定起说入佛三昧耶持明者。梵音毗富罗是广大义。谓深广无际不可测量。如是诸法自体名为毗富罗法界。诸佛实相真言实相众生实相皆是毗富罗法界。以此更相加持。故名为法界加持。复次如男女交会因缘种子托于胎藏而不失坏。即是相加持义。如是诸佛国王明妃为夫人。和合共生毗富罗种子。为大悲胎藏所持无有失坏。故名法界加持也。世尊普遍加持一切众生。皆作平等种子竟。即时入于遍法界胎藏三昧。观此一一种子。皆是莲华台上毗卢遮那。普门眷属无尽庄严亦与大悲漫荼罗等无有异。而诸众生未能自证知。故名在圣胎俱舍。若出藏时即是如来解脱也。世尊如是现观察已。即时从三昧起说三昧耶持明。三昧耶者。是平等义是本誓义。是除障义是警觉义。言平等者。谓如来现证此三昧时。见一切众生种种身语意。皆悉与如来等。禅定智慧与实相身亦毕竟等。初发心时与地波罗蜜满时亦毕竟等。是故出诚谛言以告众生。若我所言必定不虚者。亦一切众生发此诚谛言时。亦蒙三密加持。无尽庄严与如来等。以是因缘故能作金刚事业。故名三昧耶也。言本誓者。如来现证此三昧耶时。见一切众生悉有成佛义。故即时立大誓愿。我今要从普门。以无量方便。令一切众生皆至无上菩提。剂众生界未尽已来。我之事业终不休息。若有众生随我本愿发此诚实言时。亦令彼所为事业皆悉成金刚性。故名三昧耶也。言除障者。如来见一切众生。悉有如来法界。但由一念无明故。常在目前而不觉知。是故发诚实言。我今要当设种种方便善为一切众生决除眼瞙。若我誓愿必当成就者。令诸众生随我方便说此诚实言时。乃至于一生中获无垢眼。障盖都尽。故名三昧耶也。言警觉义者。如来以一切众生皆在无明睡故。于如是功德不自觉知。故以诚言感动令得醒悟。亦以此警觉诸菩萨等。令起深禅定窟。学师子频申。若有真言行人说此三昧耶者。我等诸佛亦当忆持本誓不得违越。犹如国王自制法已。还自敬顺行之。故名三昧耶也。持明者梵云陀罗尼。明谓总持一切明门行。乃至尽此三昧耶誓愿以来终不漏失。故名入佛三昧耶持明也。初句归命一切诸佛如上释。次句云无等。次云三等。连下句言之。即是无等三平等三昧耶也。复次阿是诸法本不生义。即是法界体性。娑是谛义。迷是三昧义。磨是自证大空亦是我义。世尊证此三昧时。谛观一一众生心中普门漫荼罗皆等于我。是故更无待对无可譬类。名为无等也。三等为三世等三因等三业道等三乘等。即是转释前句。所以无等之意。呾[口*履]谓心如实相一切尘垢本来不生。三世如来种种方便悉皆为此一大事因缘故。即是除障之义。结云三昧耶者。即是必定师子吼说诸法平等义。故立大誓愿。当令一切得如我。故欲普为众生开佛知见故。是故以此警觉众生及诸佛故。是故此三昧耶名为一切如来金刚誓戒。若不先念持者。不得作一切真言法事也。世尊以遍满一切佛刹身语心轮。说此三昧耶已。一切诸佛子众无不闻之。既闻是已。于一切真言法中不敢违越。所以然者。若菩萨于众生诸法中作种种不平等见。则越三昧耶法。若于此平等誓中作种种限量之心。亦越三昧耶法。诸有所作随顺世间名利。不为大事因缘。亦越三昧耶法。放逸懈怠不能警悟其心。亦越三昧耶法。以越三昧耶法故。有种种障生。自损损他无有义利。是故诸菩萨等奉持此三昧耶。如护身命不敢违越也。能净如来地者。念诵真言及作印即能除烦恼所知障也。地波罗蜜满者。净除诸障。皆以出现佛地功德也。成三法道界者。印真言及意密。道界者即是果也。合而云成三法之果也。次结法界生以下第十一法界生真言门。是养法之身。此中有印真言颂。经云。薄伽梵复说法界生真言者。世尊前入法界胎藏三昧时。见一切众生悉有菩提种子等同诸佛。故说入佛三昧耶持明。以此持明得入佛平等戒。即是托圣胎藏也。尔时世尊复以普眼谛观。见一切众生皆悉圣胎具足生在佛家。尔时无尽庄严亦复与如来等。从此三昧起已即说法界生真言。又以普眼谛观。见此一一众生金刚事业具足成就。尔时无尽庄严亦复与如来等。从此三昧起已即说金刚萨埵真言。故此三种皆名三昧耶也。复次由入佛三昧耶故。于胎藏中不令夭折。由法界生故。初出胎时离诸障碍。由金刚萨埵故。能持家业备诸伎艺。又以入佛三昧耶加持秘密胎藏。以法界世加持金刚菩萨二重眷属。以金刚萨埵加持种种随类之形。入佛三昧耶如莲华藏。法界生如莲华敷。金刚萨埵如莲华实成就复还为种。故此三种皆名三昧耶也。达磨驮睹是法界义。萨嚩婆嚩是自性。亦名根本性。句痕是我义。其句义云我即法界自性也。以必定师子吼言。我及一切众生皆是法界自性。是平等义。我常当设种种方便令一切众生皆悉证知。是本誓义。以知我即法界自性故。能除一切分别开净知见。是除障义。诸佛唯愿忆持本愿。故令我此身即同毗卢遮那法界自性。是警悟义。当以字门广释之。如法界自性者。以显所观法体。谓即是大日智体也。而观于自身者。显行者能观之智。或以真实以下二句非但意业。亦以口诵真言也。三转者三遍也。当见住法体以下四句明行者所得之益也。为令彼坚固以下第十二金刚萨埵真言门。是坚固法之身也。又有印真言及颂也。令彼坚固者。欲令依法界生修行者坚固其身心也。观自金刚身者。同于金刚萨埵身也。结金刚智印以下二行偈明所作印。是人当不久等二句以现作印之益也。真言印等二句显救世者所见之相也。常如宝轮转等二句于救世者所见中举事宝轮况法宝轮也。金刚萨埵真言门初句将说金刚萨埵真言。故归命一切金刚。即是从无量门持如来金刚智。皆令忆持护念也。次句云伐折罗呾么句痕。谓我身即同金刚。即是法界自性。以成就大坚固力不可俎坏故。异门说为金刚。如来以普眼观一切众生金刚智体与我无异。是平等义。以众生不自觉知故。从无量金刚智门作种种金刚事业。要摧如是大障令至实际。是本誓义。如是实际名为无垢眼金刚。即是除障义。以此师子吼声震动十方佛刹。即是警觉义。故名三昧耶也。复次真言行者。以初三昧耶故。得同如来秘密身口意平等之身。以第二三昧耶故。得同如来加持法界宫尊特之身。以第三三昧耶故。令此生身皆作金刚。与无量持金刚众而自围绕眷属。佛说初三昧耶为自受用故。第二三昧耶为成就法性身诸菩萨故。第三三昧耶为折伏摄受随类众生故。佛说初三昧耶为建立大悲胎藏漫荼罗故。第二三昧耶为作毗卢遮那阿阇梨事业故。第三三昧耶为执金刚弟子事业故。初三昧耶为加持如来眷属故。第二三昧耶为加持莲华眷属故。第三三昧耶为加持金刚眷属故。是故佛说三三昧耶也。即是执金刚者。金刚萨埵是也。勿生疑惑心者。劝修行者令定信心。次以真言印以下第十三金刚甲胄真言门。亦有颂真言印。初二偈总现印德。是中密印相以下一偈半正显印相。次二句结前起后。无垢者览字。次说金刚铠真言者。为庄严金刚萨埵身故。行人已发金刚誓愿。欲为一切众生摧灭诸障故。以牢强精进被金刚甲胄。且如六波罗蜜。一一如实相皆如金刚不可破坏。又一度中皆具五度。是故同体密致无有间隙。如六度者。三十七品十八空百八三昧五百陀罗尼等皆当广说。以被如是金刚甲故。旋转六道出生入死。一切烦恼业苦所不能伤。若就浅略说者。由行人以此真言自加持故。一切诸天龙等皆见同于金刚萨埵身遍体皆被金刚甲胄坚密无际光如猛焰。是故一切为障者皆不能伤也。伐折罗是金刚迦嚩遮名甲。如来以金刚眼普观众生。无不被此金刚甲胄。是故以诚实言而演说之也。以最初嚩字为真言体。嚩是诸法离言说义。若是戏论言说所行处。悉皆可破可转。无有坚固。是故以嚩字皆转释之。何故诸法离言说。以生不可得故。何故生不可得。以自性清净故。自性清净即是金刚萨埵身也。次明甲义。若法是造作所成。当知但有假名从缘迁变。尚不能自固其性。况能蔽捍六尘利箭耶。今观此金刚体无尽庄严。皆悉离诸造作。是故坚固不坏。百非所不能干。是故名为金刚甲胄。末后吽字即是无所畏声。亦是自在力义亦是欢喜义。以定慧具足。证此吽字门时。自知必能摧坏诸障普护众生。是故大欢喜也。啰字色鲜白以下第十四囕字真言门。亦有颂真言。初一偈明所置之处。此中初一句指字体色相明净。次一句明庄字法用也。如彼者指金刚也。次一句显诵持者所安囕之处也。设于百劫中以下一偈现持诵者所得之益。啰者是垢。上有点是大空义。谓是离垢同于大空。是法界心之义。亦名无垢字。真言同法界者是也。即谓真法界以外其真言无所从来处。故下云无量众罪除。谓显真言德用也。不久等二句明持真言者所得之位也。一切触秽处等二句明持诵者出入秽处之时。以用严身之法。赤色等二句围绕囕字光焰之相。其字用梵字。约供养仪式品云。现前观啰字。具点广严饰。谓净光焰鬘赫奕如朝日晖。持诵法则品曰。囕字初日晖。彤赤在三角。加持本心位。是名智火光。入漫荼罗具缘真言品云。顶戴无垢字。严以大空点。周旋开焰鬘。字门生白光。流出如满月。疏云。又观彼顶上有一啰字。字上安点。故云严以大空点。此是囕字也。此四边遍有光焰。犹如华鬘连环不断。字中又遍流出白光。如净满月之晖。以此净法界心所加持故。能除内外诸障。谓润益义故。悉地出现品云。第一摄除相安以大空点。啰字真胜真实。佛说火中上。疏云。次说啰字除障漫荼罗。于除障中最为第一真实之法。此啰字是亦赤中之赤火中之火烧中之烧。由能烧灭种种烦恼业苦。乃至现作五无间罪。若修此字门。亦能净除无有遗余。既除罪已则生诸善功德也。出现义故。次为降伏魔已下第十五无堪忍大护明门。亦有诵真言。此中降伏魔者有四。烦恼魔阴魔天魔死魔。无能堪忍者。魔鬼等者见此持诵真言人。开眼欲见不能见。故言无堪忍明也。漫荼罗法事时所要真言支分门。尔时毗卢遮那复观一切众会告执金刚秘密主等以下明漫荼罗法事时所要真言支分。阿阇梨宜应解了故次说之也。将显示如来语密之藏。故复普观大众而加持之。如生身佛。将发诚实言时。或示广长舌相遍覆其面而告应度者言。汝经书中颇见有如是相人而出虚妄语不。若摩诃衍中或示舌相遍覆三千世界。今者世尊将说如来平等语故。以此语轮横竖皆遍一切法界故。曰广长语轮相。此相字梵本正云漫荼罗。前已开示普门身漫荼罗。今复显示普门语漫荼罗。如如意珠寂然无心亦无定相。而能普应一切皆令称悦其心。故名巧色摩尼。从巧色摩尼身出巧色摩尼语。示巧色摩尼心普雨法财。满法界众生种种希愿。如是应物之迹常遍十方三世。以无量门植众德本无穷已时。住不可害行。即是于一切事业中皆悉不可留难不可破坏之义。故名三世无比力真言句。此是总说诸真言所出生处也。至下文所明大力大护等。即是从如来如意珠轮所出称机之用。尔时一切大众自知。心器纯洁。又蒙如来不思议加持故堪受大法。即时以无量门各共同声请佛言。世尊今正是时。善逝今正是时。据梵本前时名迦罗。是长时之时。如一岁有三分等。后时名三摩耶。是时中小时。如昼夜六时之中复更有少分等。如有人言。今正是动作之时。遇获膏雨。宜趣时下种。勿使失其机会。故重言之也。尔时世尊既受请已。将说大力大护明妃故。住于满一切愿出广长舌相遍覆一切佛刹清净法幢高峰观三昧。此中言出者。梵本正翻当云发生。旧译云或奋迅。出此广长舌相。即是如来奋迅示现大神通力。故会意言之也。此三昧于如来广长舌相遍满一切佛刹巧色摩尼普门大用中最为上首。犹如大将之幢。故云清净法幢也。梵云驮嚩(二合)惹此翻为幢。梵云计都此翻为旗。其相稍异。幢但以种种杂彩标帜庄严。计都相大同而更加旒旗密号。如兵家画作龟龙鸟兽等种种形类以为三军节度。有一家亦翻为幢。故合言之。若具存梵本。当云清净法幢旗也。如大将高峰之上建立幢旗。备见山川倚伏敌人情状。指麾百万之众。动止齐一离合从心以战必胜以攻必取。若拙将暗于事势又失幢旗。则人各异心败不旋踵矣。如是净菩提心为万行幢旗亦复如是。住中道第一义谛山上。安固不动以健行三昧普观十方。悉见无量度门种性优劣所应用处及与诸地通塞障道因缘。故能摄持无量功德普护一切众生。凡有所为不可俎坏也。尔时世尊作如是念。我从初发意以来常以此勇健菩提心护持正法及与众生。于种种难处行苦行事中。犹如金刚无有退转。正为成就如是三昧普护十方诸佛刹故。今我所愿皆已满足。作所应作正是其时。即时发遍一切如来法界哀愍无余众生界音声。说此持明法句。若我所言诚实不虚者。其有诵持修习。令其势力与我无异。故名大力大护也。阿阇梨云。明是大慧光明义。妃者梵云啰逝。即是王字作女声呼之。故传度者义说为妃。妃是三昧义。所谓大悲胎藏三昧也。此三昧是一切佛子之母。此佛子者。即是清净法幢菩提心。如彼胎藏。始从歌罗罗时含藏覆护。令不为众缘所伤。渐次增长。乃至诞育之后。犹固勤加守护而乳养之。故说母恩最深难可报得也。从此三昧起者。入住出时皆是不思议法界。非如世间禅定动寂相碍有退失间隙时也。初句归命一切诸如来。次句能除一切诸障恐怖等。是叹一切如来大力大护之德。又次句叹无量诸门。毗湿嚩亦是巧义。所谓无量巧度门。即是法幢高峰观三昧普门业用。今欲说此明妃。故先归敬一切如来如是功德也。次云萨婆他。是总指诸佛如是功德。欲令同入一字门故。次有唅欠两字。正是真言之体。亦名种子。已下诸句皆转释二字门。诃字是因义。所谓大乘因者即是菩提心。以一切因本不生故。乃至离因缘故。名为净菩提心。净菩提心是成佛真因正法幢旗之种子。上加空点是入证义。所以转声云唅也佉是大空。上加点转声为欠。即是证此大空名为般若佛母。正是明妃之义。于此虚空藏中含养真因种子。即是大护义也。复次佉字门犹如虚空毕竟清净无所不有。即是高峰观所知境界。诃字是菩提幢亦是自在力。以此二字相应故。犹如大将能破怨敌。又诃字门是菩提心宝。与佉字门虚空藏和合故。得成巧色摩尼。能满一切希愿。今此真言中阙此欠字。下文具有也。次句云啰乞洒。即是拥护义。如人恐怖厄难。若恃怙有力大人。或得高城深池之固。则泰然无劳。彼诸怨敌虽以种种方便无若之何。行人亦尔。依恃菩提心王。以般若胎藏为城郭。犹如虚空不可破坏。即是转释前义也。次句摩诃沫丽翻为大力。诃字菩提心具足一切如来力。今与佉字合。故离诸系缚无挂碍。如虚空中风自在旋转。故名大力。又诃字自在力与佉字无量巧度门合。故犹如力士具足千种伎能。是故众人无能胜者。故名大力也。第七句释大力所由。故云从一切如来功德生。言此坚固大力本从诸佛金刚种性生。又于无量劫以来常以此诃字真因具修佉字万德。一一皆如金刚不可破坏。今众德已满诸力悉备。复当以此法幢高峰观三昧。大摧法界怨敌普护众生。次即发诚实语。所谓[合*牛]字也。[合*牛]是恐怖彼声。所以重言之者。一摧外障二摧内障。复次外是烦恼障内是智障。若释字门。如来以何法恐怖诸障耶。谓以此诃字门也。下有三昧画。即是具修万行。上有大空点。即是已成万德。诃字即是法幢旗三昧。空点合故即是高峰观三昧。诃字具一切如来种子者。上点是明妃之母。下画是胎分日增加。具如是义故。适发声时。魔军散坏也。次云怛啰吒。是吒呵摄伏之义。如师子奋怒大吼时众兽无不摄伏。亦重言者。是对根本烦恼随烦恼。乃至对界内烦恼界外烦恼也。末句云阿钵啰[口*底]诃谛。是无对无比力义。结持上文。以此因缘故。名为大力大护明妃也。莎诃是警觉诸佛令作证明。亦是忆念持义。如前已释。经云。时一切如来及佛子众说此明已。即时普遍佛刹六种震动者。谓大日如来发此普遍法界声时。一切诸佛菩萨以无二境界故。皆悉同声而共说之。今此所加持句威势具足。又以如来诚谛言故。即时十方佛刹六种震动。以明佛之大誓真实不虚也。六种震动义余经具说其相。今此宗秘密释中六种震动。谓贪嗔痴见慢疑六根本烦恼。一切众生心地。常为此重垢所持不能自起。今以此世尊至诚之所感动。悉皆甲折开散佛种萌生。故云六种震动也。尔时一切菩萨见此浅略深秘二种地动因缘。无不心自开敷得未曾有。以微妙偈称叹大日世尊。而经云。于诸佛前者。谓佛说此明时。十方世界诸菩萨等各见彼佛前亦皆说之。是故同一音声俱时领解。即寄此文证成大护之威力也。领解偈中诸佛甚奇特者。具存梵本。应言奇哉一切诸佛说此大力护。即是一一世界诸菩萨皆悉同时领解十方一切诸佛所说真言也。以十方诸佛共护持故。犹如金刚城重阁高不可升。又环以汤池深不可越。是故一切诸障不能侵凌也。由彼护心住者。谓诸行人能以此真言密印守护身心而住。是故所有为障者诸毗那夜迦恶形罗刹等自然退散也。此住字若依梵音亦在名。为镇在其心。若作深释者。言此净菩提心人以此明妃实义护心而住。是故三种重障诸恶罗刹等皆悉驰散不能伤彼善根。下至生心忆念时。亦有如是力势。故末句更结成也。由才念故。初起南么乃至莎诃。于其中间即云才也。彼一切者。毗那夜迦之类也。驰散者。驰散于十方莫知去处也

大毗卢遮那经供养次第法义疏卷上大毗卢遮那经供养次第法疏卷下

        零妙寺僧释不可思议撰

    供养仪式品第三

将释此品亦四门分别。谓初释名。二品来意。第三宗趣。四释文

初释名者。行者供养合圣海。圣海欢喜受。初供一供种种供养满圣海。故言供养仪式品。所谓供养有三。一者外供养。谓香华饮食及燃灯庄严道场等也。二者行供养。谓如说奉行及礼拜持戒等也。三者理供养。谓心住法体无外攀缘也

二者此品来意者。前品守护能持戒者。正供养时。所以此品来也

三宗趣者。尽心供养本尊本尊领受。以为宗也。来世作佛为趣也

四释文者亦有二门。先摽摄颂后别说。其摄颂者三颂半。初句云如是正业净其身者。摄于别说中现前观罗字等三偈半。第二句住定观本真言主者。摄别说中最初于下位乃至随类而相应。第三或观诸佛胜生子等二句者。摄别说中若观世自在乃至依前法而转。第四以真言印而召请一句者。摄别说中次以真言印乃至不善心众生。第五先当示现三昧耶一句者。摄别说中次奉三昧耶乃至诸明欢喜故。第六稽首奉献阏伽水一句者。摄别说中所献阏伽水乃至三摩莎诃。第七行者复献真言座一句者。摄别说中次奉所敷座乃至是即莲华印。第八真言相应除障者兼以不动慧刀印二句者。摄别说中复次当避除乃至悉能普护之。第九次应供养香华等四句者。摄别说中及余供养具乃至品末不应诽谤生疑悔者。据别说中。初段略明能观心所住处及所观本尊所住处。第二段中有五门。初三颂及三真言者是世界成就门。二是轮如金刚乃至阿字置其中者是庄严道场门。三次当转阿字乃至自然发髻冠者是成画大日门。四若释迦牟尼乃至真言者所居者是成画释迦门。五若持妙吉祥乃至瞒字者是成画文殊门。初门最初于下位者。能成世界之风轮也。彼风轮者诃字。所初安半月之轮也。黑光焰流布者。则是诃字光也。于诃字真言门中。诃字是菩提幢亦是自在力。犹若大将能破怨敌故。又诃字是菩提心宝。犹如摩尼宝王能满一切希愿。次上者。能成世界水轮也。安水轮者。嚩字所安满月轮也。雪乳者。满月色也。颇胝月电光者。缚字色也。嚩字是诸法离言说义。若是戏论言说所行处悉皆可破可转无有坚固。何故诸法离言说。以生不可得故。何故生不可得。以自性清净故。自性清净即金刚萨埵身。故坚固不坏。百非所不能于也。复于水轮上者地轮也。金刚轮者阿字所安四方轮也。本初字者阿字也。黄色者阿字色也。毗卢遮那真言心门毗卢遮那说真言心者。以如上诸真言等随一一中则有根本真言心真言随心真言。如是等无量。无边不可知数。今总说真言心。即此阿字是诸法本不生义。若离阿声则无余字。即是诸字之母。即一切真言生处也。谓一切法门及菩萨等皆从毗卢遮那自证之心。为欲饶益众生。以加持力而现是事。然实即体不生同于阿字之法体也。此字于真言中最为上如是故真言行者常当如是受持也。是故一切真言住于阿字。犹住此故诵之即生他一切字德。二庄严道场门。如金刚者如理也。大因陀罗者理具德义也。普皆遍流出者阿字所出光也。于彼中者所出光。导师诸佛子者光所作尊也。水者能观定也。白者本不生理也。莲者理离染着也。妙色者理光也。金刚茎者无非理也。八叶者略现毗卢遮那佛德也。具须蕊者恒沙性大悲也。众宝者理恒沙德也。常出无量光者上佛所放佛菩萨也。百千众莲绕者化主所坐。右三颂现阿字德也。其上以下四颂显道场庄严也。大觉师子座者。即师子者能降伏烦恼义也。宝王者能满众生愿也。大宫殿者金刚法界宫。宝柱者诸波罗蜜也。幢盖者幢能降伏盖能利益。珠鬘者方便波罗蜜等也。宝衣者离过义。何以故。自离过离他过也。香者戒也。华者慧也。云者[糸*愛][糸*逮]也。众宝者布施等四摄也。杂华者慈悲等四无量也。严地者生成佛智住持故。缤纷者繁布义。谐韵所爱声者。非但有宝能出常乐我净声也。诸音乐者闻者净耳根也。贤瓶者所有无非慧也。阏伽者能洗烦恼垢也。宝树王开敷以下二颂显能化主德。初句直显能化主。摩尼灯者如阎浮金色等也。三昧是定也。总持是慧也。三昧总持即是地也。婇女者般若智。智能养义也。佛波罗蜜者佛部真言也。等者等取金刚也。菩提妙严华者莲华部真言也。菩提所觉也。妙严华能觉也。方便者应机也。众伎者能说也。妙法音者诸尊真言也。以我功德力以下一颂显自他法力德可知。右释深秘道场庄严也。浅略释可知。发愿如上所说。尽心供养本尊。次诵真言作印。次释虚空岁转明妃真言门。经曰。尔时如来复说虚空藏力虚空藏转明妃真言曰者。犹如虚空不可破坏一切无能胜者。故名虚空等力。又藏者如人有大宝藏。随所欲者自在取之不受贫乏。如来虚空之藏亦复如是。一切利乐众生事皆从中出。无量法宝自在取用而无穷竭。故名虚空藏也。转明者。转是能生之义。能生此藏能生一切佛事也。如前所发悲愿。谓如以一华供养时。运心遍一切佛及凡圣。皆献已即回向一切智智。诸受我施者愿以此力令我得如上愿。如是愿已。以此真言加之无不成也。初礼敬一切如来等巧门等(亦是种种门等也)

萨嚩他(一切也)欠(平声空也通上言一切皆空此是种子字)邬特揭(二合)帝(生也虚空藏也)萨泮(二合)啰醯门(普遍也)伽伽那剑(虚空也)

此即虚空等力之义。于一切法空中而生此物。普益一切众生也。诵持此者随以一华奉献令遍法界。上献一切贤圣。下施一切有情已。于中发如上大愿。以此真言加之皆得成就。如从藏中自取宝物无不随心也。诵此三遍。随所思念彼亦成就也。凡所献华等以三种力回向。而以此明加之。一切随意成也。谓以华献一切佛等自在成也。由此持一切者。此者真言印也。一切者所愿供养也。真实者如金刚法界宫中供养也。一切法不生等二句现阿字义也。想念者能观心也。置其中者八叶莲中台也。三成画大日门。次当转阿字者。次者本不生法。绝言相寂心行亦灭。假言强道。大悲之法应机显现。谓即能现阿字也。次应两足众生为两足故。即转阿字成两足尊。故言次当转阿字成大日牟尼也。圆光者大日圆光犹如明镜。于明镜中皆现万物。何况尘垢本不生如来圆光。千界者三千大千世界也。增数者。大千为一数。乃至不可说不可说。光焰谓所致法也。流出者大日所放也。轮者具德义　谓降伏烦恼能生善牙故名轮也光明者身业也。令开悟者。口业故言身语遍一切也。阎浮金色者。从阎浮池出金。此池近在阎浮树侧。由此得名。于金中最胜也。跏趺坐者。凡坐法圣善之寺三藏和上边面受。左足先着右髀上。右足次着左髀上。名为莲华坐。单足着左髀上。名为吉祥坐也。别此坐者非圣坐也。若欲求菩提学佛坐为得。正受者入定相也。诸毒者三毒相也。绡縠衣者金罗文也。自然发髻冠者非从人作。四成画释迦门。彼中八叶莲中台也。想婆字者。梵字安彼台也。勤勇者佛异名也。袈裟者乾陀色也。四八者佛三十二相。释迦种子心真言门。婆是三有。傍有二点即是除遣三有义。瑜伽者。行者能观心所观本尊也。不相离故。能所别故。有相观。行者身心即是佛故无想念诵门也。入者解也。本体者所放化身即是大日尊故。体用无别。故涅槃经曰。化身即是法身。此其义也。流出者。若多若少皆亦如是。于佛右莲上者。得菩萨为本尊者自本尊也。执者于手中有金刚故云执金刚也。前后华台中者。非但前后亦乃左右亦得。何故。菩萨大眷属无有方所故。金刚眷属非但左右方亦乃十方亦得。何故。金刚内眷属如来内德故。问若如是者。何故说有方。答约画处事有限故。是经云。十方菩萨从所来方。结跏趺坐听闻说法。金刚亦尔。用心可思量也。真言者念诵人也。所居者。于画像地右下角也。问要须令画佛尽也。答不也。有力者得令尽。无力者单画本尊亦难。何况令尽也。五文殊种子真言门。中者八叶华台也。无我字者梵瞒字。问何故以文殊师利菩萨佛次说耶。答三藏和上边而受。诸佛甚深智门故。佛部中摄亦得。莲华部中摄亦得。是故佛次列也。瞒文殊本体即是空。上点是空门。所谓大空也。越十八空名为大空。住空之位名为大空。三段中有三门。先列众。次为令心喜故乃至随类而相应。显印真言结界等。心喜者。行者因为供养故得福圣者心喜。非是圣者得供养故心喜。奉献等三句依别本法则。谓出供养真言等也。若无自法依不动去垢。避除者碎障也。使光显者。香等上用加持香真言故。言本法自相加。及护持我身等三句别本自有护身等法。护身等若无别法。通用此法。故言或以降三世。及诸相别义也。何以故。香真言与护身真言别故言及也。召请等四句别本自有依法用。若无别法用此通法。故言及此普通印等。圣者不动真言门。时佛又复一切为障者息故。火生名三昧证。说此大摧障真言。此真言有大威势。能除一切修真言行者种种障难。乃至佛在道树。以此真言故。一切魔军无不散坏。何况世间诸障也。又此障有二障。一者内障。谓从自心而生。其类甚多不可详说。二者外障。谓从外事而生亦甚多。皆能摧灭也

战荼(极恶也所谓暴恶之中又甚暴恶也)摩诃卢瑟拏(大忿怒也)娑颇吒也(破坏也)[合*牛](恐怖也)怛啰迦(坚固也)唅漫(无甘反)

用后二字为种子诸句义皆成就此也。初战荼者。战是死义。入阿字门即是本不生死义也。荼是战义。以此无生死大势之主。与诸四魔战也。次么吾我义也。入阿字门即无我也。亦是空也。诃是喜义亦是行义也。卢有罗字是垢障。有邬声是三昧也。瑟者即奢摩他谓三昧也。拏是第五字。即大空三昧也。萨是坚义。颇是沫义。了知世间如聚沫。故易破散也。傍有阿字之点即行也。吒是战义。能敌阵怖令破坏也。是乘也。[合*牛]是大空行三昧。如上说。怛是如如也。啰是无垢也。迦是作也。谓一切法无作也。唅字诃是行义又有阿声。是怖魔障金刚三昧也。点即大空也。以此大空不动之行。大令恐怖一切魔障也。鑁字摩是我义。入阿字门即无我也。又以此大空无我三昧而怖众魔。以此字亦有阿声及点也。诃嚧唅鑁四字皆有阿声。即是无行无垢。重重怖魔极怖内外二障之义也。右圣者不动主真言了。四段中有颂真言印。次以真言印乃至不善心众生。召请方便真言门

南么三曼多勃驮喃(归命一切诸佛)阿(行也)萨嚩怛啰(二合)钵啰(二合)底诃谛(一切所害也)怛他揭多(如来)矩奢(钩)菩提浙[口*履]耶(二合菩提行也)钵[口*履]布啰迦(满足也)

此中行者。谓由此行能招诸佛大功德也。如世间钩则有处所分剂。不能遍一切处而作钩召。今如来钩则不如是。普及一切无所不加。乃至能召大菩提果也。以要言之。悉满一切如来功德。普召一切众生。亦令得此道也。故次句云遍一切害。害即是钩取残之也。遍害一切不调伏者。皆令于菩提之行而趣妙果而得满足也。第五三昧耶真言门段中有印真言颂。诸明者本尊也。第六段中有颂真言。先以具严备者。以虚空藏转明印。以众香华五谷五药。运心中严备也。现事严备可知。以本真言印者。不动尊印真言。阏伽真言门右句义中伽伽那是虚空义。娑摩是等义。阿娑摩是无等义。所谓等虚空无等也。如来法身本性净故。无分别故无边际故。等同虚空。然复有无量无边不思议功德。非彼虚空所能譬喻。故云无等也。复次阿娑摩是不等义。不等者所谓二乘。今既等同虚空。又等此无等。故云等虚空无等也。此最初伽字为真言体。众生界中来去相亦不可得。法界中来去相亦不可得。以如来如去不可得故名为大空。以此大空性净之水。用浴无垢之身。是为阏伽真实言也。第七段中有颂真言印。证最胜菩提者。能修行者所得果也。如来座真言门。阿是障。傍有二点即是除遣。此即除盖障义也。以此为座毕竟不起一切障故。何故。阿字是障。阿字能除障也。第八段中有四。初复次当避除乃至令尽无有余。明不动尊印真言德。自身所生障者。妄想所生内外障。二智者当转作乃至作金刚萨埵身。成金刚萨埵身门。智者等一颂总明成金刚萨埵身。金刚种子心门鑁字者所转梵字鑁字自性清净心。成金刚种子字故。言诸法离言说。问何以故供养法中上置点。经本傍有二点。云二共金刚种子。答供养法自体。经本显法大用。是故二共无妨。离言说者鑁字义也。具印者能成生萨埵印也。等者鑁字也当知已下二颂能所作印也。金刚萨埵真言门

南么三曼多伐折啰(二合引)赦(归命一切金刚也)战拏(是暴恶也)摩诃(引)路洒赦(大忿怒义也)[合*牛](恐怖也)战荼(战字有遮声是生死谓离生死)

上有点是大空。言此生死同于大空也。荼是战敌也。犹离生死等于大空。是以无能对之者也。句义。战荼是暴恶也

摩诃路瑟拏(大忿怒也如上所说无能敌者所以大忿怒也)[合*牛](同前具三解脱也)

以如上之法恐怖众生。令离生死得三解脱也。问第二品中说金刚萨埵印真言。其义云何。答第三品中成金刚自体。第二品中现此金刚转法轮用。问云何知。答说金刚种云。智者当转作金刚萨埵身。次说欠字即言。先应住此字门。然后作金刚萨埵身。是知未作金刚萨埵身。不合作转法轮印真言也。问何时作金刚身。答入佛三昧耶前。令作五字等身也。金刚萨埵真言者。作印所诵真言也。作半金刚印者。右手无暇半作亦得。余契经者别本经也。金刚铠字者。用护持印护身成金刚铠。前已说者。护持印也。佉字及点者。金刚所著顶上欠字门也。右非但金刚所庄严身。念诵行者亦庄严。欠字门真言欠者大勤勇种子也。佛坐道场伏诸魔故。一切天人号为大勤勇也。即毗卢遮那也。佉是空义。上有点是大空。以大空净一切空也。南么三曼多勃驮喃(同前)三次应一心作乃至必定皆退散。明降伏魔真言门。次应等二颂总成觉金刚行者身降伏魔真言门。此一切佛大印。能现如来威猛大势之力。恐怖一切为障难者令其降伏。亦能与一切众生所愿。行者结此印时。为障难者莫不四向驰散乃至大力天魔军众亦退散。如来菩提道场以此印能伏诸魔也。真言归命如前

摩诃(引)沫罗嚩底(大力也)驮奢嚩路(十力也)嗢婆(二合)吠(得也)摩诃(引)昧怛[口*履]也(三合大慈也)毗庾(二合)嗢[(薩-文+(立-一))/木](二合)帝(发也)

此意言。诸佛大力也。此大力是何等力耶。即如来十力。以一切力中最为大也。如来云何得此十力。谓从大慈而得此十力。故言此力从大慈发生也。四次用已下乃至悉能普护之。结大界真言门。次结大界真言如佛所说更有无量持明。恐更有持明真言者等。以不结护故。破法事损持诵人。故设结界之法　由结界故。乃至诸持明亦不能破坏。犹比丘结界作法事。在界外比丘虽作法不能障破也

萨嚩多啰(二合)弩[(薩-文+(立-一))/木]帝(二合一切方处所也。谓十方皆须结遍也。又随方皆遍也)满驮也徙瞒(母感反上句结下句界。此意云。一切方处所结界也)摩诃三昧耶(大三昧耶。以此大三昧耶而结诸界)呾阇帝(从生也谓从大三昧耶生也)沙么(二合)啰[嬭-不+(采-木)](奴皆反。忆念也。谓忆念一切佛教也)阿钵啰(二合)[口*底]诃帝

无有能害也。亦云无挂碍也。亦是无能坏也。由结界故无能坏也

驮迦驮迦(光威也。由光威故成结界。驮是法界迦是作言。法界体离诸作。离作即是法界之义也)折罗折罗(遮是灭义。谓生死迁移也。罗是垢障也。都句亦是行辨。是遍结十方界也亦是来去也。重称之即是极来也)满驮满驮(释句是结义。上是缚义下是空。犹无缚故等于虚空。以此结界故无能坏也)奈奢(上声呼十也)儞膻(方也即是结十方也)萨婆怛他(引)[(薩-文+(立-一))/木]多(一切佛也)弩壤帝(教也是一切佛之教。前所令忆念也)钵罗(二合)嚩罗(所证也)达摩(法也。即诸佛所证法也)腊驮(获也证也得也)微若曳(即无能胜也。于诸障中最为是胜也)薄伽嚩[口*底](即真言主也。叹世尊德也)征矩[口*履](除也能除垢也。初劝除亦是劝令莫作)微矩丽(除也前句除有相垢。后句除离相之垢。即是除一切障也。即是莫作正是除也)丽(种子)噜(长引)补[口*履](句义是宫也处所也。以真法除垢除相)

即是诸佛所住之宫。令同此界也。更加微矩丽字也。但以此最后句中隶字为种子。啰是相。加此翳声即是三昧。离相三昧。具一切相而离诸相。此是界之体相也。第二略说真言门

南么三曼多勃驮南(归命如前)

此中大界。谓从初发大菩提。心乃至成佛。于其中间不令间断。不复生死不退菩提。即大界义。句义

丽(离相三昧)噜(吠音二罗二我相也)补(第一义第一义不可得)[口*履](离垢)微(离缚)矩(矩音作)丽(离相)

此七皆是三昧。以此诸三昧而为庄严。更无过上。此是诸佛大界也。第九段中有二门。初或以不动尊乃至悍总表成辨门。二次先恭敬礼乃至摩诃沫履莎诃广明营辨门。有六陀罗尼可知。初中不动尊种子心真言门。悍诃是行。阿声又是行。点即大空。由住是位能降一切。为菩提心作大护也。二广明营辨门中。如经说香等者。用种种香华五宝五药五谷。加于所献阏伽水中。数以密印洒之。如法所持阏伽严水中。用不动尊慧刀印。清阏伽水中。所有供养中洒水也。复频诵真言者。洒水时诵不动尊真言也。各说本真言者。香等真言也。及自所持明者。念诵者本尊真言也。称名者香等也。涂香真言门。次有涂香等六种真言。皆是入漫荼罗条供养时所要。故于此品中说。右句义中。微输(上)驮是净义。健杜是香。纳婆嚩是发生义。所谓净香发生。以句初微字为体。于嚩字上加伊字之画。是故转声为微。嚩字是金刚义。离言说义。三昧是住义。如是定慧均等。即是住无戏论执金刚三世无障碍智戒。如是戒香其性本寂。无去无来而常遍满法界。故名净涂香也。一切众生虽复等共有之。然以未发心故此香未发。我今已用此戒香遍涂法身。故能以净香普薰一切也。心莲华真言门。右句义中。摩诃妹呾[口*履]也。是大慈义。毗庾蘖帝是生义。所谓大慈生也。以妹字为真言体。即是莽字加三昧画。是故转声呼之。莽是心义我义亦名大空。言此心莲华为妄我所缠不得增长。今自证知心实相。故从慈悲藏中八叶须蕊次第开敷。故曰从大慈生也。复次净菩提心树王种子从慈悲地中滋长茂盛开万德华。以方便故成实。故曰从大慈生也。当以字门广释之。烧香真言门。右句义中。达摩驮都是法界义。弩蘖帝是随生义。亦是遍至义亦是逝义进不住义。释云遍至法界也。以句初达字为体。以众生界本不生故。乃至法界定相亦不可得。如是法界深广无际不可度量。而瑜伽行人恒殊胜进不休息。故身语心业悉遍如是法界。下至一华供养佛时。亦遍如是法界。即是烧香义也。灯明真言门。右句义中。怛他揭多是如来。唎旨是焰明。次云。萨叵罗儜是普遍。阿嚩婆娑娜是诸暗。伽伽猱陀哩耶是无限量等虚空。意言。如来焰光普遍诸暗。等同虚空无有限量也。此真言以句初多字为体。如于心之实相。即是毗卢遮那大智光明。普照世间无所不遍。言诸暗者即是无明。以无明本不生故体即是明。是故如来光明普遍诸暗。言等虚空者。以无明等虚空无量故。如来智光亦等虚空无量。乃至老死如虚空无量故。如来智光亦如虚空无量。如十二因缘者。一切诸法亦如是说如是决定义名为灯明真言。以此加持灯明而供养佛。即是诸供养中最也。饮食真言门。右初云阿罗罗。是不可乐闻声不善声义。如人高声喧聒。令听闻者心不寂静。次云迦罗罗。是止前不善高声。是恬寞寂泊之义。此中正以法喜禅悦为食义。是故寄此言之也。若就字轮之相。阿是本初义。以有本初则有二种尘垢。谓烦恼障智障也。由此二种尘垢故。则有戏论諠聒之声。今以诸法本不生故。二种尘垢亦本不生。即是开甘露门成涅槃饭。故名阿罗罗。复次若人勤修万行。望得如是法味。以有造作故二障还生。非是常命色力真甘露味。今以诸法无造作故。内证味不从他得。如食乳糜更无所比。故云止前不善声也。沬邻捺娜弭者。凡西方亭祭之食上献诸佛下及神鬼通名沬梨。其句义云。我以饭奉献也。次云沬邻捺泥者。此意言。受我所献食。食已当还与我妙食。如世间人以[飢-几+希]膳奉献施福田为令今世后世饭食无乏故。今以无尽法食加持世间之供养。奉施诸尊。还当满我所愿常充足不死不生之味也。次云摩诃沬履者。即是于诸食中倍加广大丰美。以此料简上句云。我今所献及与所祈皆在极无比味无过上味。不求有量之食也。第十段中。及余者。有力者非但五种供养。亦有广大供养。谓四海水作莲池。建立青白纯莲华。清净香食非心所侧。清净山水草木华香美果子比极乐等虚空。放香云遍满大地。建幢盖摩尼宝树满大地。以上种种供养具故言及余供养具。依随此法则者。不动尊也。是则持众物者。运心供养。乐欲供养佛者。即作普通供养印。所愿皆成就也。平等如法界者如理也。亦言契当也。普入诸趣中者。入者趣入也。福德而生起者。问从运心生耶从佛菩萨生。亦从真言印生耶。答非从独生。和合生。故名能生也。幢幡等乃至供养成佛事。所生也。各雨者。一一供养物成云。一一云转雨诸供物。如是展转不可穷尽。何以故。从理所生故。理无穷尽故。思惟者所供本尊也。以虚空藏明等者。能出供养法也。三转者三遍也。持虚空藏明乃至功德自圆满显功德藏。虚空者理虚空也。藏者能出能藏也。增加句者显能义也。随时等二句道心劣慧人也。此生求悉地者。慧力勇猛期克佛果也。但作心者运心也。所为既终竟者。至显相也。外仪轨者事相供养也。阿梨沙者叹佛功德也。无等无所动乃至三界无所依。叹佛功德门。初一偈拔苦也。二一偈与乐也。三一偈拔苦与乐无限际也。四一偈无有限时也。五一偈无能蔽也。六一偈济无不及也。七一偈无不与者也。八一偈能令生果也。九一偈愿不休也。十一偈毕定与也。当诵梵本者梵文也。不得梵文依唐文得意亦同。诵持如是偈赞已以下六颂半结前愿叹乞重制禁门。初二句结前起后。次二句乞愿。次四句叹德。次六句重乞。次八句重叹。末后四句劝制。问第一第二请第一第二叹有何义耶。答前愿请果。后愿请果用。前叹佛我德。后叹虚空藏明具众德

    持诵法则品第四

四门同前

初释名者。能修心中所修法则了了记持。故言持也。所修法则口中能诵。故言诵也。法则者能持因心也。所得果报毕竟不差。故言法则。言所持诵法即是法故持业释也

二来意者。前品中供养之人持诵故此品来也

三宗趣者。所说不差是为宗也。得利与他是为趣也

四释文有二。先标后释。标中初二句结前起后。圣天等者。圣者菩萨也。天者净也。大日所化应机天故。住相应坐者。入道场对本尊坐即时也。入三昧者专注一境也。住心本尊心不暂舍故。四种者左文观本尊。本尊心中圆明照见真言字。次第而受持也。静虑者反谓定也。住心四处外无散故。轨仪者观彼四即轨仪也。能所合故。能令内心者即自心也。望合理今称本心生喜乐故。故言生喜乐也。以真实义者。深观真言悟不生故。加持者真言上中安观心故。当得者初观心时也。成等引者合本不生故。约后释有十门。一若作真言念诵时乃至是名世间具相行。有相念诵门。二四支禅门复殊异乃至瑜伽胜义品中说。二无相念诵门。三次应转变明字门乃至于前品中说。是变字成身门。四本尊三昧相应乃至随息而出入。是本尊三昧随息门。五或修意支法乃至复为一方便。是意支念声真言门。六诸有修福慧等一偈。是修无定门。七若乐求现法乃至具支供养应如是知。是乐求现法成就门。八复为乐修习乃至速得成就悉地。是大日三密速得门。九复次若观念乃至速得成就。是释迦真言成就门。十复次本尊之所住乃至智者应当悉知解。是秘密事业可解门。初中念诵时者。捻珠初起念诵即时也。今者上时言今也。彼方便者。初念诵时即言彼也。所开示者。于供养仪式品中开示本尊也。令心净无垢者。贪嗔痴等不起念也。数者所说数满也。时分者克限日月也。相现等者。图像塔中出诵声光明也。有相者自身以外带相观故。二四支者。右四种也。复殊异者。自身已外不观本尊。凡正观时即作自大日。少者修时不多也。福者外香华无力难辨也。成就者悟妙契大日本地智故。下一句引证说也。三身秘之幖帜。本自见自身本尊形也。彼乘位者自本尊位也。四以心者种子字也。置心者完心也。为种子者。行者因心。念诵真言从因得果。故言种子也。菩提心者真言也。郁金色者真金色也。童真者童子异名也。文殊师利菩萨真言门。次文殊入佛加持神力三昧。此加持三昧如上毗卢遮那经初说也

醯醯(是呼召义)俱摩罗迦(是童子义。即是呼召一一忆本愿也。又俱是摧破之义。摩啰是魔眷属。所谓四魔。此真言以么字为体。即是大空义也。证此大空摧坏一切魔也)毗目底钵他悉体多(解脱道住者谓呼此童子住于解脱道者。即是诸佛解脱。所谓大涅槃也)娑么罗娑么罗(忆念忆念也)钵罗底然(先所五愿也)

此真言意云。醯醯童子住解脱道者。忆念本所立愿也。一切诸佛法身成佛。入身口意秘密体。一切有心无能及者。然忆本愿故。以自在加持之力还于生死救度众生。此真言意亦尔。此童子久已法身成佛故请其。以忆本愿而度众生也。由请菩萨本愿。若有见闻触知忆念我者。皆于三乘而得毕定。乃至满一切愿。此菩萨久已成佛。所谓普见如来。或云普现如来。以大悲加持力示童子身也。普通种子心真言门。迦字一切诸法离作业故者。梵音迦哩耶是作业义。如诸外道计有作者使作者等。诸部论师亦说有作有作者有所用作法三事和合故者果报。若因般若方便。谓有决定即堕无因。若堕无因一切法则无因果。能生法名因。所生法名果。是二法无故。作及作者所用作法罪福因果报及涅槃道一切皆无。复次作作者相因待生。若定有作法。则当定有作者。是皆不异外道论议。如中论观作作者品中广说。今正观察作作者等。皆悉从众缘生。即入本不生际。本不生际者。有佛无佛法尔如是。谁造作之乎。是故若见迦字。则知一切诸法皆是造作所成。名为字相。若是有作法者。当知毕竟无作名为真实义也。一切诸菩萨真言门

南么三曼多勃驮喃(归命如前)萨婆他(一切也)微沬[口*底](无慧也。以无慧故名之为疑。此字正释名为疑也)微枳罗儜(除也。此是除弃之义。如人除弃粪秽名除粪也)达摩驮啫(法界也。为除一切无慧皆令住于法界也)涅阇多(生也。涅字即入大空三昧从此而生即是法界生也)参参诃(此三字皆是种子也)

萨是坚义。犹除此坚固故为最胜也。点是三昧。知二乘入于涅槃。此即是坚固义。乃至若有坚者。即是生住之相。一切动不动法皆是不安。犹除此故有重空三昧之义。诃即是行。所谓如来行也。当得等虚空者。理虚空也。说诸法亦然者。非但伽字一切字亦然。其首内者首骨内脑上也。初字者金色阿字也。纯白者着点阿字也。于百明中最胜王也。心者胜中王也。眼界者眼处也。无垢字者揽字也。所谓安眼处故。现前者眼共心得见也。彼心处者行者完心也。从此心起者。初阿字心起声字。迦字以为首者初也。初者因也。因种子也。余字门者。字门别故本尊别故言或复也。皆当修是法者。迦字以为种子也。念以声真实者。理无造作也。或所持真言者。自本尊真言也。环列者广真言也。圆明者心圆明也。单字者种子也。句因者三字以上即是句也。能诠法故令物解故。因者字相依故相由故。然真言法中一一字具足能诠法故令物解故。随息而出入者自息也。五或修意支法者。意支者简心外事也。应理者心至理也。方乃者持诵处时也。懈者疲也。复为一方便者。从因至佛一依此法故。六诸有修福慧者。劣慧少福初念诵人也。七若乐求现法者。深慧勇猛人也。上者佛也。中者菩萨也。下者断烦恼声闻也。心受持者简辨事也。随力者亦得也。一落叉者十万也。亦言见也。若一一数中不离本尊心不散乱言满一落叉也。若散乱人万万落叉亦不成就。要得定心得见本尊。故言见也。经第二月具支方便乃修者。第三月一日为初作成就法。谓待蒙佛指魔方作也。以心意持诵者。待见光等也。八段中经于一月者。满一落叉亦言一见。次说彼方便者。欲满欲见念诵时也。当依者左法也。大日如来种子心真言门。阿字者一切诸法本不生故者。阿字是一切法教之本。凡最初开口之音皆有阿声。若离阿声则无一切言说。故为一切众声之母。凡三界语言皆依于名。而名依于字。故悉昙阿字亦为众字之母。当知阿字门真实义亦复如是。遍于一切法义之中也。所以者何。以一切法无不从缘生。从缘生者悉皆有始有本。今观此能生之缘。亦复从众因缘生。展转从缘谁为其本。如是观察时。则知本不生际。是万法之本。犹如闻一切语言时即是闻阿声。如是见一切法生。即是见本不生际若见本不生际。即是如实知自心。如实知自心。即是一切智智。故毗卢遮那唯以此一字为真言也。而世间凡夫不观诸法本源故。妄谓有生。所以随生死流不能自出。如彼无智画师。自运众彩作可畏夜叉之形。成已还自观之。心生怖畏顿躄于地。众生亦复如是。自运诸法本源画作三界。而还自没其中。身心炽然备受诸苦。如来有智画师既了知已。即能自在成立大悲漫荼罗。由是而言。所谓甚深秘藏者。众生自秘之耳。非佛有隐也。问此阿字是种子。前第三品中是大勤勇种子即疏云是大日种子。其义云何。答阿字是生菩提果。欠字是现果涅槃。是故二俱种子亦是无妨也。如来豪相真言门。归命如前。阿行。痕因。若生。以此不生之行净一切因也。阇为生不可得也。如前转阿字等一颂总叹能成字。住本尊瑜伽以下广释依能成字庄严行者身。前中如前转阿字以用阿五字等加持行者身上。所加持五字能转。故言成大日尊。广释中住本尊瑜伽等一颂明字所安置处。于三摩等一颂明能观心所作用。五种真言心门五字为身。豪相印置眉间。阿字为百光成果。开无垢眼见性净之理坐无生宫也。阿字遍金色等一颂明字色并所安处。此中用作金刚轮者。字所安四角金刚轮也。与字色少浅也。加持于下体者。真言者腰中也。瑜伽者佛身与我身无异。故言瑜伽也。座者依佛坐法故。水等瑜伽可知。[金*(离-禸+ㄆ)]字等一颂明悲水瑜伽。雾聚者行者自齐也。亦雾聚者字所安满月轮也。览字等一颂明智火瑜伽也。中三角者明字所安处也。与字色少浅也。唅字等一颂明自在瑜伽也。风轮者字所安半月轮也。佉字等一颂明大空瑜伽也。想成一切色者。非但字成一切色。字所安四角处亦成一切色。字与处处少浅也。百光遍照王者有点阿字也。无垢者囕字也。心月圆明处者。有想念诵者所见本尊心处也。若无相念诵人所观即是自完心处也。声鬘者。种子字置中间。余字周匝围绕。随处而受持者。自本尊真言也。第九段中释迦如来真言门。次释迦如来入于宝处三昧。宝从彼出名为宝处。犹如大海出种种宝。若至彼州。则随意所须无所不足也。佛入此三昧已。从其面门出种种光。光中现此真言。乃至普遍一切佛刹。余真言当知皆如此说也

萨嚩讫隶奢(一切烦恼也)泥苏驮那(摧伏也。通上句云摧伏一切烦恼也)萨嚩达么(一切法也)嚩势多补罗钵多(得自在也。通上句云于诸法中而得自在也。以除诸障故)伽伽那(虚空也)娑(入)摩(平声中有阿声)娑(入)摩(娑摩是平等义。即是等同虚空也。行等空无边清净也。于一切自在无碍同于虚空也。下句与阿相连是无等也。不等者即是二乘以有所阙故名无等。即是施权意也)

然此真言以初萨字为体。娑(入)是漏义立是坚义。入阿字门即无漏无坚。若有坚牢即是生灭坏破之法。若令同于阿字。此坚本来不生。即是诸法之中而得自在。等于虚空能为一切宝州也。私谓释迦以大悲力于周体密致犹如金刚。一阐底等亦令破坏此见而入佛法。施其大宝之愿岂非于诸法中而得自在能破一切坚牢也。如是者。于毗卢遮那释迦牟尼法中念诵者如所庄严身也。本经者简别经也。亦当如前方便者此经也。字门观者种子也。若依此如来行者。简菩萨金刚等也。大悲胎藏者。如来大悲业也。王者毗卢遮那是也。得阿阇梨灌顶者。得传法阿阇梨灌顶也。如律中受具足戒。持明灌顶者。如律中未受具戒者。但自作本尊真言印念诵。不得广行学也。若欲得遍学者。至蒙佛加被至诚念诵。得加被已后。请传法阿阇梨得蒙遍学阿阇梨灌顶。乃能广行。四支禅者本尊等也。非但灭烦恼。于修行者具足法则也。本法者入佛三昧耶等也。十段中有五种门。初二句总。本尊之所住者。三部等中得何尊。漫荼罗位者。随得本尊造坛尔。次二句释。彼形色者本尊色也。依此瑜伽者。本尊金色坛金色。本尊郁金坛郁金。二初二句总标。次二句略释。有三种者。从因至果有三种义。于其中间寂灾者。亦心念诵故。悟三毒烦恼不生言寂灾也。增益者。悟烦恼不生智即是佛果。得佛果故言增益也。降伏心者有二义。一得佛已后烦恼不起言降伏也。二以不起故能摄万德。亦有摄召义也。三纯素等二句释彼色形。凡四分者。素者圆场也。角者方场也。赤者三角场也。深玄者八角场也。即是莲华场也。纯色二种字通四场也。北面等八句广释悉地作用。住莲华座者。结跏坐是。所谓先左脚着右髀上。后右脚着左髀上也。吉祥坐者。右脚着左髀上。亦言半跏坐是也。在贤坐者。蹲坐双脚跟着身后分至地是也。蹲坐者。后分不至地。以右脚跟支左脚不至地。膝稍亚向前即是也。幖帜者印等也。性者本尊所住自体也。自体者自位也。形色本尊外相也。威仪者所持宝等也。随所应者。随本尊供何华香也。舍处远游者遣去是也。摧害者三角之场所作法也。莲华场作亦得。真言之初等八句转变真言门。此中初二句南么三曼多勃驮喃唵(某甲)[合*牛]发莎诃。谓念诵者三毒不着。今同不生故言寂灾也。次二句者南么三曼多勃驮喃。唵(某甲)[合*牛]发。谓实相法中有真实。行者取用吃法食故言摄召用。次一句南么三曼多勃驮喃。纳么(某甲)[合*牛]发。纳么。谓行者吃法食后。得法力故言增益用。次一句南么三曼多勃驮喃。[合*牛]发。谓行者得法力后。尘沙烦恼一时顿灭。故言降伏用。次句中通三处者。寂灾增益降伏之处

    真言事业品第五

四门同前

初释名者。真言如前。事者差别也。业者造作

二来意者。前品之中依于法则持诵。诵者必有真言事业。故此品中来

三宗趣者。所谓本尊还归本处为宗也。真言饮食不茇天命。终归无相菩提为趣

四释文者有十门。一上弘下化修供门。二从次持所造乃至我亦如是发愿。是如佛我修回向门。三从次当奉献乃至皆悉圆满。是献阏伽后送尊门。四从又应如前乃至无有异也。是被甲现修如佛门。五从次复起增乃至不应饮啖。是自住佛身读经门。六从次奉搏食乃至真言所说。是搏食奉献本尊门。七从复诵施十力乃至休息少时。是诵十力明本尊瑜伽饮食门。八从复当礼拜乃至随类悉地。是修业无间得益门。九从常依内法而澡浴乃至是谓世间之悉地。是净水澡浴摧障门。十从次说无相最殊胜乃至当得出世间成就。是无相最胜证请门。第一段中如前事业者。不动尊真言印也。作金刚萨埵身者。用鑁字成身也。第二段中证知解了者。内证境界也。如来大住者。本不生处也。兴大悲愿者。自所得理欲与一切众生也。第三段中各当随所安者。从本不生来今还本不生。后复垂哀赴者。赴为众生来。后请还度我不舍去也。若深密释者。既自作本尊。何时离佛海也。法界本性者囕字也。明者真言也。印者手印也。三印者入佛法界萨埵也。皆悉圆满。于明相中入道场坐时事了也。日中初夜亦复如是。第四段中又应以下叹依法念诵者德也。第五段中次复起增上心以下于出道场以后外读经处事业也。观世者菩萨名也。莲华者莲华部主也。眼者诸佛眼门也。本性加持者。本尊种子印等也。观自在种子心真言门。娑是诸漏。傍有二点即是阿。除遣诸漏。无漏观故自在也。观音菩萨真言门。次观音菩萨入于普观(去声)三昧。住是平等无所不遍名为普入。以此普眼而观众生。故名观自在者。入此三昧已。从其心出种种光。光中现是诸法门真言也

萨嚩怛他竭多(即是一切如来。谓十方三世诸佛也)嚩路吉多(观也。同彼佛所观故名诸如来之观。即是平等观也即是普观也)羯噜拏(悲义也)么也(体也。所谓大悲为体也。犹如金人以彼自体。纯是金故名为金人。此菩萨亦尔纯以大悲为体也)啰啰啰

啰是尘义。入阿字门即是无尘也。所以三重者。谓除凡夫二乘尘障。[合*牛]是恐怖义。以大威猛自在之力怖彼三重尘障。令得除净而同佛眼也。阇此最后字。是种子也。诸字皆为释此字义。即生不生是阇字义也。或以初萨字为体。亦同得用之。是惊觉义也。吽字中有诃字。是欢喜义。上有大空点。是三昧。下有字亦三昧。上者三世诸佛皆同此观三昧中行也。故名等观也。第六段中搏食者。搏是节量食也。随意食法者。凡有饭四分。一供养本尊。二行者自分。三同学者来可食。四为饥贫济。若待同学不来者。行者自食亦得。增减者动也。悦泽者妙面完色也。第七段中如是者十力明也。真言心者不动种子。休息者眠也。第八段中忏者此云请受也。悔者解也。复当礼拜者。日中入道场时也。乃至者日中念诵以后出道场时也。恒依是住者。一日三时念诵不阙也。后日分者初入道场时也。事业金刚者鑁字严身也。次当运心者。初夜入道场。至中夜念诵了时也。系意在明者。欲睡眠时。出入息中以用种子字在其中也。何以故。睡眠自作本尊三昧睡故。本尊息即是真言故。若如是睡者。尘沙三昧从睡得故。恒沙功德从睡悟故。睡觉不离佛海故。此人即是金刚法界宫中人也。床上者若好水土行者地中卧亦得。若恶水土损其行者床上亦得。然者不得太高。何以故。本尊道场着地。不令人坐太高故。若下床得损腰。离损故。若自作本尊三昧者不论高下故。圣凡不别。故论高下者着相凡也。得名号者非人间也。十方佛国佛边也。展者策也。第九段中常依内法者。着相凡夫不知外法空。何况知空亦空。若能解了外相空。渐入实相法平等无取舍故。如经所说阿字门等也。而澡浴者。若能得悟尘劳空寂。最净浴也。触食者。若能悟人法皆空。所成食等何有触也。若有行者起念动心即须羞。若能得羞离生死饭故得阿字等故。若起念吃食净念乃吃。若得不触食等要知食空。已上食等为乞食念诵者说也。住持是身有二。一为护他故。二除自执故。法界心者。画着流水中安字。以下住若坐若立。取安字处水浴也。不动等者。不动降三世各用亦得。双用亦得。护方等者。辟除结界也。自性观者自作本尊也。转者遍也。持者诵也。默然者有三处。一食时。二大小便时。三洗浴时。降三世种子真言门。诃字是行。加阿声是极行。以此除遣诸行。则是不行一切行。故有除义。以此能降三世也。降三世明王真言门。次降三世明王真言皆是毗卢遮那如来住于法幢高峰加持三昧。如初序品中说也。如来说此二明。皆是彼诸佛三昧。为令行人初发菩提心守护增长。令至成佛果圆终不退失堕在非道者。即不动明王是。为降伏世间难调众生故。即降三世明王是也。故次说之。所谓三世者。世者名贪嗔痴。降此三毒名降三世。又如由过去贪故。今受此贪报之身。复生贪业受未来报。三毒皆尔。名为降三世也。复次三世者名为三界。谓毗卢遮那如来始从有顶迄至于下地从上向下。于一一天处皆化作无量眷属大天之主。令胜彼天百千万倍。彼怖未曾有。更有何众生而胜我耶。乃至以法而降伏之。次第而下。以能降伏三世界主故。名降三世明王也

诃诃诃(诃是行义是喜义。是三行者。即是三乘人行也。此字入阿字门即此三行本来不生。由本不生故即越此三行。是为佛行也)毗萨么(二合)曳(此是奇哉怪哉之义也如佛常教以慈对治于嗔。以无贪治贪。以正见除邪见。今乃以大忿嗔而除忿嗔。以大贪除一切贪。此则最难信难解。故言怪哉也)怛他揭多(一切诸佛也)毗舍也(境界也)三婆嚩(生也。谓从诸佛境而生也。佛境界者所谓诸法实相。从此实相而生。故号为降三世也)帝(入)隶(二合)路迦也(二合即是三界也)微阇也(此是降胜之义也)[合*牛](义同上说)惹(呼召警觉之义。若诵此能遍入一切众生心。而警觉之令除垢障等于法身之佛也)

然此真言以此帝(入)[口*(隸-木+士)](二字)字为体。上有多声即是如如之体。即是本来不生。以不生故即是诸垢障亦自本来不生。称此理而修定慧具足。故能降伏三世也。洒净者。掬水中诵三遍头上洒也　具者三昧耶等也。圣天者本尊等也。为净身心利他故以下入于念诵道场对本尊时。三等者三密也。限量者同本尊也。句者法也。第十段中真实缘生者。真实者是本不生法。妄言相寂无凡可度。法慧常照无边无断。故知世间日净明在中无夜相也。缘生者。真智其体。强言大悲。众生不知本自觉体。令悟觉体故然言缘生。离攀缘者。既知觉体然外缘佛也。末后一偈流通中甚深流通。此中初一句表无相法体。次一句深法之中劣慧所不堪。次一句为劣慧人故现相法。次一句非但有相亦有前后差别耳。右阿阇梨已下翻译家语也。此中阿阇梨者。圣者文殊师利也。又说彼于真实缘生句者。彼者阿字也。真实者本来不生理也。缘生者缘众生也。句者法也。又可云。依于真实缘生句者。依于真实者依本不生理也。缘生者阿字也。临机示现声字故。内心支分离攀缘者。内心支分者能证智也。离攀缘者沉心本不生理也。甚深无相法者本不生理也。着相劣慧不得悟入之理故。问唯有沉心者更有妙用也。答若能沈理即是具也。何以故。能行融故。问理用身心耶不耶。答若能用其印者。是为其身心也。问阿谁向本法呼造本不生耶。答有三种。一秘密释。二秘密中秘释。三秘秘中秘释。一秘密释者。毗卢遮那佛说本不生故。二秘密中秘释者。阿字自说本不生故。三秘秘中秘释者。本不生理自有理智自觉本不生故。此供养法一卷从初至末唯有为一大事。所谓彼于真实缘生句内心支分离攀缘。又可云。甚深无相法劣慧所不堪为应彼等故兼存有相说。此文造人新罗国零妙之寺释僧不可思议。随分穿凿。愿此文见独知于本不生理中证

大毗卢遮那经供养次第法义疏卷下

元禄十三年庚辰之夏以古来之点一校了


大品游意

    No. 1696 [cf. No. 223]

大品游意

斯道幽微。深远难测。无知无照。无名无相。理绝百非。道亡四句。言语无所厝其辨。情识无所没其虑。虽复一相无相。万用无亏。至寂至空。道光法界。故开经宗之始。以不住法住。辨其义之终。以无得为得。是故绝相必假言宣。无名要由教显也。摩诃波若波罗经者。此云名之为大。大者。广博苞容莫先为义。波若者。释论云。如猛火聚四边不可触。触之皆烧。此意正法波若。翻不翻皆不可得也。波罗蜜者。此云度彼岸。经者。训法训常。前贤后圣莫能改之。故云常。阶摸行人心识。目之为法。故云经耳

般若义有五重

  第一释名　第二辨宗　第三会教　第四明缘起　第五出部傥也

第一释名中有五。第一摩诃。二波若。三波罗蜜。四修多罗。五序也

摩诃有名。谓摩诃摩醯优波。此云大也。龙树云。摩诃有三。谓大多胜也。大者。以广博苞容莫先为义。如大经中说。明此大义有两家。招提涅槃师述庄严义云。大义有十种。一境。二人。三体。四用。五因。六果。七导。八利益。九断结。十灭罪也。第一义境遍法界。故名境大。会此法者。名为人大。故十二门论云。世音大势等大士所乘故。故名为大也。实相般若。是万行之本。容受万品。名为体大。所谓百华异色皆成一阴。万品体殊皆归波若。波若能照第一义空。此用最胜。故名为用大。上句直谓智能。此句作用为异耳。菩萨修万行。名为因大。因既广大。所得弥博。故名为果大。二乘所道。唯止于三。菩萨遍导万行。故名导大。既导万品。利功最胜。故名利益大。二乘唯断正使见谛思。不及习气无明。唯菩萨兼断。故名断结大。故大品经云。一念相应慧断无量烦恼及习也。二乘唯灭轻罪。不及四重五逆。故阿含经云。阿阇世王堕[毯-炎+白]鞠地狱也。菩萨顿灭。故名灭罪大。大品云。若闻此经。即灭恶创癞病。释论第五十九卷释法称品云。恶创癞病者。谓四重五逆也。故经云。世王灭罪。谓此也。龙光述开善义云。大有六种。人境体用因果也。后导与灭罪等四。摄入用大中也。并云。此皆望小名大。而未照也。今假若就横门释者。于义亦得。而言同旨异也。今所用者。唯存体用两大。何者。义不出中假故。前家所明十种六种。皆是用大也。就此义中。大义有三。一者待小名大。谓大小小大因缘也。二者对小名大。此破小乘狭劣之病。以广大上句直明因缘相。此句偏明除病之耳。三者秤赞名大法。绝离如大火聚。而大胜义轮。以大名秤赞其本。此非大非小。强名为大耳。问。若非大非小名为大者。亦应非偏非中名为中。何故非有非无为中耶。答。义有左右。何者。若相摄明者。亦应非有非无名为大。非大非小名为中。而互相避者。各有故生故也。何者。佛常行中道。为众生说有说无。此有此无。非是令保。义在表理。故十地经云。从有无方便。入非有非无。故即非有非无。名为中也。欲赞理极。强名摩诃。恐有还着。故云非大非小名为大也

第二波若。波若名义。经论不同。今略出六种。一者波若。二者斑若。三者钵若。四者钵罗若。五者蔓多罗。六者摩何曼多罗。或云毗昙。此云无比法也。此翻译不同释论第十八卷云。波若是智慧第四十三卷云。波若是智慧。又六波罗蜜经云。波若是智慧也。道安法师造折疑论。以经无间品云。般若觉远离。睿法师云。波若是清净也。而开善述者云。远离清净等。皆是波若中用。非正波若义也。如空慧中。有忌与导等多用故。第十八卷云。波若是慧者。正翻波若。余皆义训也。今解不然。何者。此经初云。波若非愚非智。论云。波若深重。智慧轻薄。故不可翻。故正法波若。不得以一义翻译。而三代法师说此文者。一者云。不得以下地智慧翻上地波若也。一云。此说无文。不足为依所。依成论世谛品说。何者。彼品云。缘世谛心浅。缘第一义谛深。故不得以浅智慧翻深波若也。今解。正法波若。非愚非智。慧智等法。是其末用。故不得以其末翻彼本体。正法是其源。仍授波若秤。智慧是末。故与浅名多。长安睿法师。与什法师对翻大品。其序云。胡音失者。正之天竺。秦言谬者。定之字义。不得翻者即而尽。是以异名炽然。胡汉殆半。应述其言也。而经论此云智。此云慧者。欲举一义令生信乐。非是正翻也。大品经云。波若谓诸众生。毗婆沙那谓声闻缘觉。阇那谓佛菩萨也。成论释此文者。凡夫之人。依教翻痴根生无痴善根。故与波若之名。二乘见四真谛。分亦见空。故与见秤。菩萨照境决断。故授智号也。今解。凡夫二乘菩萨皆见正法之用。凡夫唯有趣向之心。而无用道别起。仍授体名。后二者同前释也。复次经云。说智及智处。皆名般若者。成论师云。谓教行境也。何者。教能诠智。智能照境。境能发智。此皆波若之缘。故总名波若。而观照波若。实是智慧。故能照境。第一义空。是智之缘。故名实相波若。何者。我心悟理即生明解。违即生惑。故此三种。其相性实异也。今解不然。何者。若有境智之别。境不生智。智不照境。即是性义不离断常矣。今解。境能发智。智能照境。境智智境。境智是空境智即非境非智。平等无二。是有所办之宗也。此不二为物所开。即名教行波若。开而不歔。即名正法波若也。既是空境空智。是以言智不失境。言境不失智。故知成论境智定异也。又成实论云。断惑之导。唯须空慧。何者。已与执相违故也。而开善义。在东山时。说五方便。皆缘于假理。故第一法。与苦忍不为习因也。还阳州时云。五方便皆缘于真。故缘假解对退不伏进不断。而死时云。先说谓得。何者。成论四无碍品云。何者近法住世谛智。论主答[惴-山+而]顶是也。今解。有四句。假伏中断。中伏假断。中假具断。中假具伏。如断伏义中具说也。成论师云。无始以来。所染烦恼。随心成就。如影随形。故修行十地。渐断诸结也。今即不尔。许心造空。即名断惑。无有成就。如影随形。而迷得悟。故经云。无明即变为明。而颠倒本空寂。去无所至。故经云。明与无明。真性无二也。但佛果断惑不断惑以来有二。开善云。佛地即惑。此义难解。何者。若佛心起时。烦恼灭者。即应惑属佛地也。庄严云。灭惑生解。如因灭果生。故佛地不即惑。若尔烦恼自灭。解不开于也。解云。常迫迮伏惑力转弱。理应灭惑时。解力转胜。方可生时。故虽不相经干。有存亡。理数然尔。般若义。释论出八家。第一家云。无漏为般若。成论主所用也。第二家云。有漏为般若。数家所用。何者。见有得道故也。第三家云。有漏无漏合为般若。第四家云。因中智慧。是般若故。经在因名般若。果萨般若也。第五家云。无漏无为不可见无对般若。第六家云。离有无四句。为般若。第七家云。前六并是也。第八家云。前六中。唯第六家所说解。是也。龙树菩萨唯出八家而已。不复简是非也。今解。若如前五家所执。只是般若中一片。是非般若正义。第七家合取为般若者。此举时用。第六家云。正是般若体也。所以明般若者。诸师有二释。一云。初教所破。是有法无诸利益。故立正因果。以破其执。既立因果。故以有相为宗。而未申本意。故第二说般若。是慧观法师所申也。一者云。初教亦说无相。故见空得道。而言相教。从多论耳。既是略说。故第二广说无相般若也。而释论以十九复次。广辨之。而无一复次因于此释也。今略者。一二复次。第一复次云。为弥勒广菩萨行故说般若也。第二断邪见疑网。第三破邪见。令信入中道。第四断有无二见。令进入中道。第五令信正法。第六复次云。为四悉檀故说般若也。第七复次云。次别大小乘故说般若。其余复次。如论中说也

波罗蜜第三。波罗者。亦名波伽也。波罗此云彼岸。密者言度。又贤劫经云。波言岸。密者言究竟也。释论中广说此彼两岸及度也。今略举三。以示其相。第一者小乘为此岸。大乘为彼岸。何者为小乘人委曲授教。未及广远。名为此岸。为大根人说大乘满教名彼岸。檀波罗蜜为中流。此行至果。名为度。而龙树云。在海中为度。已至彼岸为到。亦眼目之异名。第二双者。魔为此岸。佛为彼岸。中流如前也。第三双者。世间为此岸。涅槃为彼岸。受是生死河。八正华为中流也。成论师有相为此岸。无相为彼岸。生死为此岸。涅槃为彼岸。众惑为此岸。种智为彼岸。此即三同前释。而实硕异也。赖殰假舍此经彼。必为度彼岸也。今则不然。无有一法以此到彼。唯远我无我。不二名为度。度者水勉也

明修多罗第四。三义之中。有一分名经。何者是三。一者佛口说。二者神眼见。三者光明也。如坐席众中弟子所说也。言放光者。若入林磎答。正造论时。佛放光明。表有疑者。即入修多罗。若阙此三义者。虽有圣明之德。不入经疑。故佛在舍利弗。造阿毗昙。迦旃延造毗勒论。昙摩陈那比丘尼亦造论。皆名为论也。如外典圣人所说。名为经。贤人所吐。名为书也。修多罗。略有三名。谓修多罗。修岚林。修多懒。而经论翻译不同。仁王经云法本。大经与杂心云契经。成论云。直说圣言。或经云经也。言经者。有时一云。直别经论之异。如圣说名经。异人说名书。非翻修多罗也

明序第五。从来释者。序是由渐义。若非时方人正教无由。故所因谓之序也。而序训有三。一屋。二舒。三王也。天子正坐大极殿。诸臣所居。左庠右序。若谓王所从。庠序而进。不得直就。说之时。必因五事。不得顿说。故以序品初。以况圣义耳。既有时方人者。教自开敷。诏之序也。正行教也。名为王者往也。如王命之事道而不塞。非命之事。应而不行者也　秡渠者。此云品也。义类不同。谓之品也。若具言。应言佛陀槃遮摩诃般若波罗蜜。此云修多罗。凡说法有五。一佛。二弟子。三诸天。四仙人。五化人。故简圣余名。故云佛说。记胡来经本有经名字。皆题经初。故皆唯道安法师竺法真。欲令易故。以题内面也

第二辨宗体。有五重。第一明体。第二明宗。第三简因果。第四明长短。第五辨远近

明体凡有四释。第一家云。以理为正经。何者如拖多多罗长者。以五阴十二入十八界。检魔所说阴十三入十九界。故理是正。经文云是傍。如龙光云。理为能印。文为所印。第二灵味寺实法师云。教理相合。因成假为经。何者。文理相科合为经。偏即非经。故外道有教无理。如虫食木也。而成论云。异法一时。具曰因成假。若如此释。直是因成假也。第三灵耀寺盛法师云。文是文经。理是理经。教理各是经耳。何者。文能诠理。理是所诠。教诠教能诠教理所并是经也。第四太创寺宗法师。与白马寺要法法师。以教为经。此开善寺之师也。开善师云。十四种色中。色声两尘。是经体也。后时营法师加触也。何者。闇中摩石碑。即知字义。故声触皆是经体也。成论云。是音声性法入所摄故。五尘中唯是法尘。何者。诠辨之功。于行乃得。故摄入法尘也。今解。万法无非是经。何者。色表有色。心表为心。诸法例然。故缘觉悟缘。虽而得道。岂有教耶。一方所须。各是所主。故香积佛香作佛必。释迦化土。以音声作事。此化缘不同故也。善见毗婆沙中。阿难以七义。明修多罗。一发。二善语。三秀出。四经强。五涌泉。六绳墨。七綖也。凡为佛语。必有所诠之实。外道言诠之教无理。以内外相望者。佛有妙开之实。谓之征发。既有当之绝。名为善言。开发妙理。名为秀出教理相开。谓之住强。南北为住。东西为强也。诠理无穷。谓之涌泉。裁形就正。名绳墨。以教持理。如糸补衣。谓之綖。且胡见卖系之肆。谓之修多罗也。阿毗昙以五义辨之。一云出生。二显示。三涌泉。四绳墨。五结鬘。准可知也

第二明宗。成论师释。若以色声为经体者。体异于宗。若以所诠为经体者。体之是宗。而以所辨为宗也。辨宗有三家。第一新安耀法师云。以境智为宗。何者。非境无以生智。非智无以显境。境智于[卄/積]。是圣义。故以境智。合为经宗也。第二家[袖-由+鳥]法师云。权实二智为宗。此法师只存四时。故般若维摩。合为第二。故以二智。为二宗也。第三治城道法师云。唯实智为宗。何者。第一义空。诸法之本。世谛是末。故以照一真智为宗。照末为傍。故实智为宗也。今经境智。皆从不二起。故非境非智。是体宗。是境智智境圣未用

第三明因果。庄严云。波若唯止于因。不通于果。故经云。在因波若。至果萨波若。又云。般若有佛法。有二乘法。是菩萨法。又云。欲得一切种智果。当学波若波罗蜜。故知唯止于因也开善云。波若通因果。所以通因果者。大经云。解脱之法。亦非涅槃。摩诃波若。亦非涅槃。又胜鬘经云。明佛智所断。佛菩提智所断。罗汉悟波若。是胡悟。故智通因果也。今解波若非有智。非因非果。以因怙为因。以果怙为果。故在因名般若。至果名萨波若。因名十地。果名法界。因名佛性。果名涅槃。此皆随所辨说。更无异法。而或者迷名生法痴有断争讼耳

第四辨寿命长短。成论师说不同。云初教佛寿八十年。第二佛寿无量。故释论佛有二种。一者父母法身即是经中常身佛也。二者法性身。寿命无量。光明无量。即是经中特尊佛也。又大品云。欲得寿命。当学波若波罗蜜又释论婆伽梵子。一村众生。犹寿命长。何况佛度无量众生。故寿命无量。第三七百阿僧祇。第四如法华中说。第五明常住。一云。初教与第二品。是八十。若尔云何示特尊佛耶。解云。八十年即现特尊佛。非别有佛也。慧观师义。自第二已明常也。今解不尔。何者。经说无定。或云七十九年。或云八十五年。又阿含经云。佛寿无量。别有净土。唯现余报耳。若尔云何定报耶。若一往判者。初教八十。第二教佛寿无量。此是长短方便。故言长不失短。短不失长。是因缘

第五明远近。成论师云。初教明唯成道。不明前世所行。故弥勒经云。此阿逸多具凡夫未断诸漏者。谓此也。自第二始开佛道长远。故大品第八卷云。于华严城燃灯佛所。不离六波罗蜜。为无所得。又云。弥勒已修六波罗蜜。为无所得。故此皆明前得道。故自第二长远矣。今则不尔。只是近远方便。故近而无暂。远而无久。岂有远近之异乎。而或者执远近之方。执近失远。持远失近。故堕有所得断常。今解。无碍法门何义。岂长短不可定。谓如当说也

第三会教。成论师云。佛教不出三。一者顿教。如华严大乘等也。二者偏方不定教。如胜鬘金光明遗教佛藏经等也。三者渐教。如四阿含及涅槃是也。就渐教中。有二教。一者诸法师。作四教。阿含为初。波若维摩思益法鼓楞伽等为第二。法华为第三。涅槃为第四也。所以波若思益。合为第二者。大品经诸天子云。见第二法轮。思益云。见第二法轮也。作五教师不同。两义本是慧观师所说也。一家云。阿含为初。禅经为第二。波若维摩法鼓等为第三。法华为第四。涅槃为第五也。一家云。阿含为初经。维摩思益法鼓为第二。法华为第三。波若为第四。涅槃为第五。所以波若为第四者。释论云。须菩提闻法华。举手低头。皆成佛道。是故今问退不退。故知法华故后也。广州大亮法师云。五时阿含为初。离三藏为第二。如优婆塞经也。波若维摩思益法鼓为第三。法华为第四。涅槃为第五也。慧观法师云。阿含为初。波若为第二。维摩思益等为第三。法华为第四。涅槃为第五也。二经同云见第二法轮者。一是为小中。第二是大中。第二也。开善寺所述也。今解。半满两教。何者。经中唯说半满两处。又释论第百云。法云波若。是显现教。法华涅槃。是秘密教。若尔维摩波若等。还浅深法华等乎

次辨五家味相生。第一家云。十二部配当阿含。修多罗配禅经。何者。定能发智以修多罗。配当禅经也。方等配波若思益等。波若配法华。醍醐配涅槃也。慧观师所以十二配阿含者。阿含约事分别。四谛理配为十二。分别法性也。第二无相教。名修多罗者。所说二谛体生行人。空理万法之本。故受法本名也。第三名方等者。就教得名。此改小乘。无狭劣之通。故名方等也。第四名波若者。能令众生。同佛寿量。平等大慧。如多宝佛品中论也。第五名大涅槃者。永除生死。如醍醐体性清凉。故名涅槃。今解。小教名为十二部经。如提谓等三归五戒等也。修多罗配小乘半字。何者为。满字。作本故也。方等总配满字。波若别配波若。何者。方等虽广。波若为要。得果之主故也。既有能得之因。应有所得之果。故第五别配圣果。而涅槃与波若。是眼目异名故。故诸大乘中。皆得配之。非汝所谓第五教涅槃。唯是极果。前皆非极也。就五时四时辨教。宗蜜亦不同。慧观师新安师大令正小。庄严营师云。自第二已明常住。何者。仁王经云。超度世谛第一义。一转妙觉常湛然。又大品昙无歇菩萨品云。法身无来无去。净名经云。金刚之身。佛身无为。不堕诸教。故已明常住也。开善寺云。前四时教。唯明无常。无量光明与倍数。终归于磨灭。故俱是无常也。而仁王经云。一转妙觉者。经说三谛有多种。或就因果说二谛。或就假实明二谛。故成实论云。色等及泥为真谛。四大五根为世谛。已此二谛入真实之时。与理冥同。更无退转。故云湛然。非谓无生灭也。今解。常无常。非常非无常。迹义也。仁王经云。超度世谛。第一义谛者。即语非有非无。谓又妙觉具二谛。是故可谓。从有无方便。入非有非无者。亦五时名目不同。慧观师云。初教名为相教。第二名通教者。本空未转故。说通教者。勒取三乘果。故经云。欲得菩萨果。乃至欲得声闻果。当学波若波罗蜜也。第三维摩名贬教。第四名同归教。第五明常住也。开善等云。以第二教破初教者。此义不尔。云何佛自破圣言耶。初教名为三乘别教。何者。别说三乘果故也。第二无相教。亦名三乘通教者。通者非二乘果为通。唯取所学之法。名为通教。何者。欲得菩萨果乃至声闻果。常学般若波罗蜜。故知所劝为通。且先劝三乘。后即贬故。经云上人法。第三为抑扬教。发轸初毁小故。经云。广原陆地不生莲华。卑湿淤泥乃生莲华。又入正法倍曾。终不发阿耨三菩提。起我见。如须弥山。不能发菩提也。第四名同归教。亦名善法教。何者。彼云汝等所行是菩萨道。又云。举手低头皆成佛道。以教为名也。第五教名常住。即□可见也。明寿命不同。如辨宗中说也。而七百之言。维摩思益等经。无有此言。唯首楞严经云。东方庄严王佛。七百阿僧祇入涅槃。即我身是也。所以异经为失。第三教者。理自应尔。何者。初教寿八十。第二无量。第四复倍上数。第五常住。若尔七百之寿。应入第二。故云七百阿僧祇耳。今解。此皆随机所说。无有八十与七百阿僧祇之殊。故经云。十方法诸如来。同共一法身。既以正法为体。岂有常无常长短之异乎。显现秘密有二种。一者法。二者其事可见也。显现秘密者。净名经云。佛转法轮于大千。其轮本来常清净。天人得益斯证者。名为显示等也。显现秘密者。释论第百卷云。法云般若显现。法华涅槃是秘密。而成实论师云。大品等五时波若。唯解果内浅事。非是难解。故名为显现教。所以然者。仁王云。若三界外。别有众生者。是大有说。非七佛所说也。其法华经。兼内外事深。故非易可见。名为秘密也。今解不然。何者。法云等发轸。顿开本经。故名显教。法华涅槃。先改执。后显正法。故名秘密教也。显现秘密。有异圣究竟。如常说也。且成论师云。十二年前。说小乘后说。今则不然。有四句。一始终大。二始终说小。三初大后小。四初小后大。何者涅槃经中。叹十二年童子迦叶三十六问等无有异。故知佛初成道。既说涅槃。而成实论师云。是华严经也。涅槃既尔。余经应然。何者。释论云。须菩提闻法华。举手低头皆成佛道。今问不退。若云何得定言法华以前说般若耶。且诸佛化众生。应有缘即说。何后时乃说大耶。故知应有四句也。次明但不但义。但是住义。是不行义。若是佛教大小。皆是无迹义。故云有不住有。言空不住空。而一往开者。小乘是但。大乘是不但。何者。小乘为浅行人。施四谛因果法门。名为但也。大教为大士。开不住法门。以示诸法无迹。为不但也。大小两乘。既有二智。人亦有二。何者。小乘人。保昔经教。名为但。大乘人如幻化。无有去就。名为不但。故人法但人但不但义也。若例前句。应有四句。如二句上例。三者但不但俱不但。四者但不但俱但也。如十地论成论等所执。皆存大小之相。名为但。若如今说。大小俱无迹。名为不但也。若就两佛者。一往释迦教是但。舍那教是不但。而释迦教。有但不但。何者。难化众生说故也。舍那佛唯一大乘故。无但不但也。且经云。华严经不入二乘手者。二乘存着故。即为圣教不入不云都不闻见也。大品初佛说五品为不共。第二传教须菩提说善品。为共说故也

第四波若部傥。释论云。有二种波若。一者共。二者不共。有二种释一云。共者。大品云三乘通教是也。不共者。别第十地行闻波若。非九地行所闻也。一云。只就大品中。亦有共不共。何者。经云。欲得菩萨果乃至声闻果当学者。此是共般若。复有菩萨所对。名为不共也。今则无别深般若。但二乘分亦得闻。谓之共。菩萨之殊于二乘。名为不共。此就有方便无方便。简圣共不共。无别深波若也。复有三种波若。一者上。二中。三下。上者光赞波若是也。若具翻者。应是五十卷。而存长时遗少唯翻十卷。即竺法护所翻也。中者是大品也。而卷数不定。或二十七卷。并什法师翻也。放光波若。是二十卷。是朱士行取于于阗国。即是大品也。下者小品是也。有七卷。则是随行也。复有四种般若。谓上中下与金刚波若也。一云。上中下与不共波若也。复有五种波若。谓摩诃波若。天王问波若。光赞波若。仁王波若也。从天王问波若。出五般若。一者须真天子问波若。有七卷。二者法文天子问波若。有三卷。三者四天王问波若。有一卷。四者文殊师利问波若。五者思益梵志问波若也。从光赞波若。出二波若。一者成具波若。二者光净般若也。或云金刚波若。其本有一卷。此是校量功德一品。而抄为别经也。一云。五时波若中。一时说也。若其依仁王经法者。金刚波若。是第二也。而一义云。金刚波若。理应最初。何者。以三义验耳。一者从众。二者乞食等事。三者经中有文。何者。大品众是五千。分金刚众是千二百五十。云何前多。后还成少耶。且大品中。不数地。虽地四寸。金刚经足数于地。且经中云。所得慧眼。未曾得闻。此三义故。其非后耳。或云。如仁王经中列法也

次第五明缘起。魏时沙门朱士行。导赞小品。即知文义未尽。故甘露六年于于阗国。相经本遇得大品。而彼国名僧。唯信小乘。故朱士行将还时。彼僧白王曰。汉通人弃佛正教。以持波罗门经。将还本国而宣流。王今不应捡许。王即顺语。遮而不许。于时朱士行。即白王言。我今不顾身命而来。正止由经。王若不许此经者。应捡一愿。即誓言曰。若此经于汉地有缘者。投火即应灭。誓言即摩诃波若波罗蜜经者。斯道幽微深远难测。无知无照。无相无名。理绝百非。道亡四句。言语。无所厝其详。理绝二边。情识。无没其虑。虽复一相无相。万用无亏。至寂至空道光法界。故开宗之始。以不住法住。辨义之终。以无得为得。是故绝相必假言宣。无名要由教显。摩诃波若波罗蜜者。摩诃者。翻云大。大者广博为义。苞容为义。莫先为义。波若者。释论自云。如猛火聚不可触。触即皆烧。翻不翻皆不可得也。而约用□亦得皆翻也。即波罗蜜者到彼岸也。经者训法训常

大品经游意一卷(终)


法华经义疏

    No. 1715 [cf. No. 262]

    法华经义疏序

钦惟。我朝肇自八聪王子。而圣君贤臣靡不世遵崇于西方慈仁之教。梵容绀字眩耀于方舆。圜颅畦服栖止于林薮。贝叶琅函线华琪轴藏诸名山。充溢于轮栋。三宝备着既旧矣。予忝预僧数自少遍历禅丛染指教海。都以南京以北久游诸家之讲坛。每览朽简逸编于蠹鱼之遗。虽暑之流金寒之折胶。孳孳焉誊摹之。遂致蔚然填箧。稇载而旋。盖效慧布得之勤耳。饭坞灵讲主学富才迈伦辈罕及。顷阐畅法华文句于台麓。仍日抉剔开显权实立阴观妄。蛣蜣性恶即具三千之妙髓。俾听者想味于甘露醍醐。讲演之暇适顾余曰。昔者姚秦什公亲翻妙经于震旦。上足僧融创开九辙。睿生等林立诸曹相继而有著作。在齐之时刘虬居士共十名僧务捃舆师之异言。撰为注法华。逮乎梁初光宅法师师受中兴。独为雄匠。尝讲法华屡感天雨华之征。又谓灯明佛之所曾诵兹典。方策所详不亦诬矣。第恨其所注疏记厄之当时。漫弗复存。唐宋而降丰闻硕学皆不及睹。而幸独此方存焉。敢请以其所褚刊行于世。克寿其传庶几使后乎千百世之人。赖之溯乎千百世之上。若同堂接膝而相摩轧。此岂细故也哉。予欣然叹曰。韪哉主言。夫天台之道迨至荆溪克任荷负。尤加光显。窃阅其笺释于玄文。台家宗体一翕一张。靡不昂然精核震发。然至析丹丘[(爽-(爻*爻)+(目*目))*斗]酌于光宅。锄刬乎玄论之意。令人嘅焉不能无议。盖不窥二书故也。其嘉祥玄论已行于世。此疏尚未及翻刻。予亦甚歉于衷。以谊不忍辞丞欲镂梓以公同好。或谓。古之消释此经南二而北七。各以长相当莫之适从矣。惟我天台奏师子弦投师子乳。其说超绝宜废古今。犹若龙烛之于萤爝。照曜虽多隐而弗见。尝谓的倾光宅余则自溃。以此观之区区亡编之传。足以弥缝何阙耶。予曰子之言也噫。知天台之非不高。而不知光宅之非不深。莫认荆山之璞奚睹赤水之珠。虽谕斤运之巧妙。而不喻垩质之尤难也。况圣慈纯化或贬或褒。或捶或砧总在成于器不在乎迹。不师其迹善学下慧者也。若徒有优于迹而弱于实。锢诸古而牖于今。犹迂辙以即涂胶舟而求济。此非特疏乎光宅。寔亦不肖于天台者也。且又近代叨袭翏翏苟简之弊。援以屑屑臆凿之见。而日趋非日趋虚。言如近而弥远理似邃而愈浅。呜呼际之末运尽力其间。而不相逮者其能莫愧于斯哉。此予所以僣升篇首。数思砭今而复古也。不以人废言则予可无虑矣。夫予可无虑矣夫

  时

元禄岁在丙子孟春日浪华后学[泳-永+(虍-七+(一/八/八/目))]凤潭槃谈谨叙

法华义记卷第一

        光宅寺沙门　云法师撰

释迦如来初应此土乃。欲觉悟长迷远同极圣。但以众生宿殖善微过去因弱。致使五浊障于大机。六蔽掩其慧眼。又崄难长远生死无际。是故不可顿明一乘因果大理。事不得已故初诣鹿苑。开三乘异因。指别为趣果。如是荏苒至于大品明教度人。庵罗说法弘道经年历岁。犹明异因别果长养物机。于是八部四众积年睹圣。曩日修福遂令五浊障轻大乘机动。至今王城始称如来出世之大意。破三乘定执之心。阐扬莫二之教同归之理。于时且废权于往日。谈实于当今。明因则收罗万善以为一因。语果则复倍上数以为极果。今言妙法者妙名是绝粗之奇。语法则因果双谈。何者昔日佛偏行六度为因。感有为无为二种之果。若论无为果只断分段结使。三界报亡为之果。初言八十后言七百阿僧祇住世。以己所得传化未闻。小小益物作有为果用。然此因此果未尽为极之美称之曰粗。今日明因总括万善。为同归之路。将三乘行人度五百崄难。遂到宝所。亦有二种果。断绝三界内外两因。灭除此彼二报无为果极。有为果用者。种智一朗佛果齐明。理而推之。于时则应入无余涅槃至寂然之地。但大悲之意不限。度人之心无穷。近藉神通之力。远由大众万行之感。遂能延金刚心留住于世。寿命无穷益物无崖。故能常应在三界之中殊形入六道之内。使见色闻声之徒生莫二之大福。是则因绝众粗之名。果极唯精之极。是故因果两法俱称为妙法。莲华者外譬一物必花实俱有。若谈莲家之花则如果家之因。若语花家之莲则如因家之果。是故此经家要双明一乘因果似若此花。故借譬受名故云莲花。经者盖是佛教之通名圣语之别号。然经之为义本训常训法。常是不坏之称法是可轨为目。欲明诠之教不可移易。先圣后圣不能改其长度。天魔外道不可俎坏此法。令其不害理故称为常。从之者则离恶行善出凡登圣。故称为法也。然经中正明因辨果。但因果两法喻若莲花。今举所明理以目此教。故言妙法莲花经也

次辨广释。前叙大意竟。次更细解。何者今言妙法者。是因果相待之名。对昔为论。昔日因果俱粗今日因果俱妙也。先明两因后辨二果。相待之名但今日称妙备有三义。昔日称粗亦备三义。言今日备三义者。一明今日因体长故称妙。即对昔日因体短故称粗。二者明今日因义广故称妙。即对昔日因义狭故称粗。三者明今日因用胜故称妙。即对昔日因用劣故称粗。所言今日体长昔日因体短者。昔日止修三界治道为因。不及三界外治道。且自当昔日之时不道更有三界外之治道也。今日长者纵论。自发心以上迄金刚。以还三界内外治道一切万善以为因体。此则今长故妙昔短故粗。复言广狭相对者。昔止言偏行六度不及其余诸行。此则是狭义也。今日明因横论。是善遍行逢福尽修此是广义。今广称妙昔狭称粗。第三言用有胜劣相对义者。但烦恼有二种一是四住地烦恼二是无明住地烦恼。但昔日因力止断四住烦恼。不及无明住地烦恼。此是用劣之义也。今日非唯止断四住烦恼。亦断无明住地烦恼此是用胜之义也。是故今昔两因粗妙如此也。今果对昔果亦各有三义。今果有三义者。一明今日果体长即对昔日果体短。第二义言今日果义广即对昔日果义狭。第三义言今日果用胜即对昔日果用劣也。所以言今日果体长者。但昔言果止言寿命八十七百阿僧祇。今日明果寿命长远复倍为数。是故下经文言寿命无数劫久修业所得。取五百那由他阿僧祇三千大千国土墨点取为喻。言寿命复过于此但昔日无有如此之寿。然罗汉辟支不无边际智所延之寿然终自无有长远之期。是故以今日长远之果对昔日短促之寿。昔粗今妙其义如此。第二言广狭相对。但昔无为果不足只有断分段生死无为而已。今日断两种生死故无为为具足也。昔日有为果体有功德智慧。然功德未圆智慧未备。唯照有量圣谛不照无量圣谛。亦可唯照三因三果不照一因一果也。唯有尽无生智为体义狭。功德未圆者。但慈悲三界内众生不及三界外众生故称未圆也。今日明有为果智照八谛复照一因一果功德。为论慈悲于内外众生。故功德智慧圆而且备。然今广故妙昔狭故粗。第三明果用胜劣相对者。然此果更无别用只是殊形万象神通益物。下文言神通力如是于阿僧祇劫常在灵鹫山及余诸住处。非唯止在灵鹫益物。亦复分身十方度人。见形者三毒灭闻声者四倒除。但昔日之果不无小小说法然不足是语。是故以今日神通无方益物之用胜。对昔日之用劣昔劣今胜。劣者为粗胜者称妙二名相待其意如此。又复作一种解因果各判为三。言因三者一者体广二者位长三者用高。体广者收罗五乘诸善为因体得言广也。位长者今日明因位从发心以上极至金刚。治五百由旬崄恶道故言位长也。用高者今日所感明因所感之果。果出于五百由旬上。能感之因用何容不高也。因正以感果为用。所感已高能招事成不下今日。果备三义者一者体广二者用长三者位高。所以言体广者此有二义。一者功德圆。昔日不导一切众生成佛。则慈悲功德不满。今日明悉趣佛果故所以称广也。五乘诸善相与成佛果上更有五乘习果之义故称广也。智慧亦广。今日更有照一乘因果之智故称广也。二用长者果以何为用正以化物为其用。所以住世至无量劫者据欲神通益物所以用长也。位高者今此佛果位在五百由旬之上故称位高也。回换之意谛思可得。就此经所明长寿之义。但昔七百阿僧祇为短今复倍称位长。然今者更无别长只续昔七百阿僧祇为长。如柱长五丈埋藏二丈。唯出三丈。睹三丈为短又出二丈则有长义。但无别有长正以今二丈续昔三丈有五丈之用也。寿命亦尔。昔七百为短今复倍为长但无别长续短成长。无异三丈是短是粗今日复倍是长是妙也。此是无别长义。家义今明因三义并是显一句中不在开三句中。明果三义并是显远句中不在开近句中也。法者非是轨则故名法。法名自体。明所妙之法各有体。然法语通漫无的因果。表明因亦是法果亦是法故知此法妙因妙果法也。此位既以因果为体故借莲花为喻。经者训法训常为义也。若具存胡本应言萨达摩分陀利修多罗。外国云萨此方言妙。天竺云达摩此翻为法。胡云分陀利此方云莲花。外国云修多罗此方对经。今具存此土之音故言妙法莲花经也。所以知妙名翻萨者只是善。然恶既是粗鄙之法。善即是精妙可珍。如赞咏唱萨。则是唱善善即是妙。复言法翻达摩者此则与三宝义中法宝相会。外国云达摩此方言法宝也。大智论云外国云分陀利此间言莲花也。修多罗既是外国语。然经出之时翻译之始仍用经字代修多罗。然经既训法训常。是故大智论解修多罗备有五义。一出生二微妙发三涌泉四绳墨五花鬘也。五义之中有涌泉绳墨。今取二义与法常相符。何者涌泉无穷此与常义相会。绳墨之用本除斜取正。正而不斜可轨可则。此与法义相符。曲解经字如大涅槃义记所述也。若泛论众经标题差别不同。略述所见可有五种。何者。一者单法标经。二者单人标经。三者人法两标。四者但譬标经。五者法譬双举。单法者则是大般涅槃者圆极佛果之法。故知单以果法标经名也。人标经者则是四天王经。树提伽经也。人法两存者即是维摩。胜鬘经也。但譬标经者即是成实所云斧柯喻经也。法譬双举者即是此法华经上出妙法下出莲花为譬。缘此得双显因果之义。夫水陆所生类杂无限。今的取水生莲花以譬因果者。此花不有则已。有则花实必俱。用此俱义譬此经因果双说也。寻诸经宗旨要略有三。一者以因为宗。二者以果为宗。三者以因果为宗也。以何故者如胜鬘圆经单以因为宗。语万善之因明同归之路。括五乘皆无异路。又有单果为宗者即是大小两本。是故首称涅槃。涅槃之号是极果总名非是因地通目。今此法花则以因果为宗。自安乐之前开三显一以明因义。自踊出之后开近显远以明果义。夫欲识经旨归唯应谛思经题。是故胜鬘经昔呼目一乘极教经初标宗矣。今此经首题称言妙法表明因亦是法果亦是法。故用莲花为譬双显因果二理也。然胜鬘虽明一体三宝此则为因。故明果下唯结言说入一乘。不结一体三宝。此则单以因为宗。然涅槃经亦言护法得金刚之身不杀感长灵之报。双明缘正两因具述佛果之业。此亦为果故明因终不以因为宗。是故开宗之始辨义之初仍言礼今施汝常命色力。今此经明因之处亦有果义即言开佛知见。辨果之中亦有因义即言久修业所得。前则为因故明果后即为果故明因。故知因果双说是经正宗。此意是光宅法师今述而不作也。寻诸经品目皆非佛语。何以故然但佛说法时直尔散明因辨果正是八音妙响说法度人乃至无有文字纸墨况复诸品但随根性有五时差别于时时众如说修行。但阿难比丘曩劫怀愿亲承金口。佛灭度后仍采拾三藏具述五时。致有书写纸墨卷盈世界。欲令后代时人虽复不睹真容亲听金口。览卷寻文彻见始终说法大意。故作诸经品目。故知皆是出经者制亦可密承圣旨述而不作照然。品义只以类例不同所明各异之义也

今一家所习言经无大小例为三段。三段者第一詺为序也第二称为正说第三呼曰流通。然今三重开科段。第一开作三段自有三阶。初释名义序以缘由为义为正说作诠序也。正说者。正明一经大意蕴在其中。显同归之因明长寿之报也。流是行为义借譬为名通是无壅塞为义也。三段名义如此。三段文句起尽处者。初序品一品则是序段。第二从方便品以下讫分别功德品中弥勒说偈颂。佛长行以来凡有十四品半经。是经之正说。因果两法显此文中也。第三流通者。分别功德品中从弥勒说偈后长行初。言佛告弥勒菩萨其有众生闻佛寿命长远如是乃至能生一念信解当知以为深信解相以下。尽经凡有十一品半经。皆是流通付嘱。次明相生。夫圣人施教度人明理化物有此三种说者。第一凡夫昏迷情重染着意深。三毒自缠五尘为累。是故将明妙理之前先现殊常之相。时众既眼见异相耳闻异声。开动物情生未曾有意。是故文殊言诸人今当知合掌一心待佛当雨法雨。充足求道者乃至诸求三乘人若有疑悔者佛当为除断令尽无有余。缘是义故时众相与欣心澍仰冀闻妙说。是故第二如来从三昧中起仍告八部大众。明同归妙因辨长寿极果。说法度人随根授道。会前三乘归同一路。随器大小皆得利益。第三流通说者。于时乃应息八音之教。罢化人之方。但自如来大悲之意不限度人心无穷欲使此一乘因果妙法远播未闻。千载不绝。且又欲示圣人善始全终。是故有此第三流通说也。然则三段名义如前。起尽如次。相生意致如后也。次第二重。又就此三段之中各开为二。序中二者第一从如是我闻讫退坐一面以来詺为通序。正明众经通有称通序也。第二从尔时世尊四众围绕尽品詺为别序。正言众经各异部部不同也。故如欲说涅槃大音宣告放光动地以为别序。欲说胜鬘父母送书以为别序。欲说维摩长者献盖为别序。此经天雨四华地六种动为别序也。然通序亦名证信序。明佛法理同。别序亦名开发序明此经意异也。正宗中有两段者。但此经只以因果为宗。是故第一方便品以下尽安乐行品有十二品经。正开三显一以明因义譬莲家之花也。第二从踊出品以下。竟分别功德品中弥勒说偈颂佛长行以来凡有两品半经。詺为开近显远以明果义。喻若花家之莲。前辨因义后明果宗。然则因果双说经之正体也。第三流通中有两段者。第一从弥勒说偈后长行。言佛告弥勒其有众生闻佛寿命长远以下。竟妙庄严王品有十二品半经。詺为化他流通。明此一段高行菩萨非唯自能受持读诵复能传授未闻。是故维摩经言。譬如胜怨乃可为勇。如是兼除老病死者菩萨之谓也。第二普贤劝发品一品詺为自行流通。所以尔者。前药王妙音等诸大菩萨苦行通经。皆亡身济物没命度人。但始行菩萨未全能尔。便于通经之道生退没之心。是故如来劝人言。若使不能丧身护法弘经化他者。亦可自能受持读诵。自受持读诵即是自行流通。何故然者。若使此人不自受持读诵者。经于此人则不流通。此人既能受持读诵经于此人得流。即是通也。次第三重开科段者。减一明义通别两序各开为五。明因辨果。二正说中各开为四。化他自行二流通中各开为三也。通序五者第一如是第二我闻第三一时第四出说经住处第五从与大比丘众讫退坐一面列同闻众也。别序五者第一众集序第二瑞相序第三疑念序第四发问序第五答问序也。从尔时世尊四众围绕讫供养恭敬尊重赞叹。是第一詺为众集序也。从为诸菩萨说大乘经讫以佛舍利起七宝塔。是第二詺为瑞相序也。从尔时弥勒菩萨作是念下讫今当问谁。是第三詺为疑念序也。从尔时弥勒菩萨欲自决疑竟四言偈。是第四詺为发问序也。从是时文殊师利语弥勒菩萨尽品。是第五詺为答问序也。今第三重料简。若直对正说明此五序相生者。只由尔许徒众天龙八部聚集然后得说此经。即是待伴漏尽是故众名为序也。由先现瑞相然后得说此经。瑞相即成序也。由时众怀疑抱念然后得说此经疑念即成序也。由有发问故然后得说此经发问称序也。由有答问故然后得说此经答问即成序也。又此五序有次第相生。所以现有端相正由大众聚集故。第一生第二。所以怀疑抱念由见瑞相故第二生第三。所以有发问由有疑念故第三生第四。所以有答问者由发问故第四生第五也。又有倒相生义。何者如来所以从三昧起说此经者。由文殊师利答弥勒问仰测如来心应说法华。故正说之由藉文殊答而生。文殊所以答问者由弥勒发问故。弥勒所以发问者由大众有疑念故。又大众所以有疑念者由睹瑞相故。又如来所以现此瑞相者由大众聚集故也

正说第一段明因中有四段者。第一略说开三显一动执生疑。第二怀疑致请。第三广说开三显一断疑生信。第四别流通开三显一之义也。从方便品初讫佛以方便力示以三乘教众生处处着引之令得出以来。是第一詺为略说开三显一动执生疑。所以尔者但三乘行人执昔日三乘方便教。铿然言尔谓三家所行其道必别。忽闻如来道佛以方便力示以三乘教。又言世尊法久后要当说真实。昔日不言三乘是方便今言是方便。昔日言理极于此今日更有真实可说。是故执三情动疑一意生也。从尔时大众中有诸声闻众以下讫是等闻此法则生大欢喜以来。是第二詺为大众怀疑致请。是则执情既动有可除之义。疑心既生堪为入道。是故论云疑者解之津也。大涅槃经云宁堕疑中莫入见丛也。然则执动生疑请情又至。是故从尔时佛告舍利弗汝已殷勤三请以下讫授学无学人记品有七品半经。是第三广说开三显一断疑生信。然则时众相与解无三之理信同归之义。于明因段中粗已周足。是故从法师品见宝塔品持品安乐行品有四品经。是第四詺为别流通开三显一。是别流通开三显一因义也。辨果之中有四段者第一别序开近显远动执生疑。第二略说开近显远动执生疑。第三怀疑致请。第四广说寿命长远断疑生信也。从踊出品初讫当精进一心我欲说此事四行偈以来。是第一詺为别序开近显远。即是别叙寿量之义也。尔时世尊说此偈已告弥勒菩萨我今于此大众宣告汝等下竟我今说实语汝等一心信我从久远来教化是等众以来。是第二詺为略说开近显远动执生疑。所以尔者如来十九出家三十成道。如来自言寿命八十或言七百阿僧祇。而今踊出菩萨皆久殖德本积行深远非始发心人。而佛自言我从久远来教化是等众。若实寿八十七百者云何言久远教化是等人。是明执八十七百之情动疑长远寿之意生也。从尔时弥勒菩萨等心怀疑惑怪未曾有尽踊出品是第三詺为怀疑致请也。从寿量品初下入分别功德品中尽是弥勒说偈讫佛长行以来。一品半经是第四明如来广说寿命长远断疑生信也。今因中四段果中四段有三同一异。何者果中第二略说开近显远动执生疑。因中第一略说开三显一动执生疑此一同也。果中第三时众怀疑致请。因中第二舍利弗等怀疑致请此二同也。果中第四广说开近显远断疑生信。因中第三广说开三显一断疑生信此三同也。盖是三段名同三段意异也。一异者果中有别序因中无别序。果中无别流通因中有别流通是一异也。今明因中无别序果中无别流通者此同。是近故。何以故然。今明因中无别序者此去通序近不假立别序也。果中无别流通此去总流通近不假立别流通也。复言因有别流通果中有别序者此同。是远也。今明因中有别流通此去总流通远。是故立别流通。明果中有别序者此去通序远是故立别序也

二流通各有三段者。化他流通中有三段者。第一分别功德品中从弥勒偈后长行初佛告弥勒菩萨其有众生闻佛寿命长远如是乃至能生一念信解以下半品经。随喜功德品法师功德品常不轻品凡有三品半经。先明弘经益物者勋重报深命觅弘经之人。第二从神力品初五行一文明下方踊出菩萨堪弘经者受命流通也。第三从神力品中尔时世尊于文殊师利等大众前现大神力以下半品。嘱累品药王菩萨品妙音菩萨品观世音菩萨品陀罗尼品妙庄严王品凡六品半经。正明如来以经付嘱也。自行流通中有三段者。第一经家先明普贤菩萨为劝发故从东方来此土也。第二从白言以下正明普贤菩萨与佛问答缘是得劝发时众。四种闻经因缘生受持之意也。第三从说是普贤菩萨劝发品时尽经广明时众闻法得益多少。结成自行之义也。问者言第一通序亦是别序何以知然故如王城之处得说此经不得说涅槃经。呴尸城处得说涅槃不闻说法华。如此流例处所各别事义不同岂非别序。解释者言。不无此义。今所论者诸经明住处相与为证我闻不谬故成通叙言不无此义者故如诸经同闻人。使有两义有通序义。是故通序中有。又有别序义。下别序中言尔时世尊四众围绕。四众即是前同闻人。又如涅槃经中通序中与八十亿比丘俱。下别序又言时八十亿比丘俱。彼此两经前出为证一时。后出为正说作序也。难者言通中有五序。证信义同。故称通序。别中有五序望正说义等。亦是通序。二义既齐亦可前称别序后称通序。解者言前证五义同更无别。后望正说更有别意。何者此经五别为因果作序。大经五别为常住为序。意致不同义则显然。今言如是者此是通序之第一也。有人解言。文则称如理则称是。又有人言如明无异是辨无非也

今一家所习言如是。两字更无别意。正为总举一部经为我闻作诠叙。言如是一部经我佛边闻也。我闻者此是通序中第二。表明阿难述而不作。正言如是一部法华经我从佛边闻。非我自造。所以尔者。但佛在世时开教度人明理化物。尚有性执取斜见不信受者。况如来我灭后人情浇伪率易可化。然阿难实处亦可已成种觉。借其学位无谢法王今据迹谈事。是三乘之中小乘学人等是小乘。小乘之中自有四果。阿难是初果须陀洹位。忽登法座有所宣说。抚臆论心未易可信。但不达之徒多以小废道。如来既悬见末代有必然之事。是故诫敕阿难出经之时先白四众言如是。一部经我从佛边闻非自造。于时四众既意重如来心尊至极。闻传佛语信受无疑。是故维摩经言诸有所作亦不唐捐。此之谓也。师习不同意致如此也一时者此是通序中第三。明阿难佛语可传之意不虚。此经既是如来应机适会之教云何秘而不传。夫涉言化物凡有两种。一不见根性盲心说法。二审见根性明理化物。然不见根性而说法者凡有三种。一者闇会前人根性。此则益而不损。二者不称所宜此则损而不益。三者承平不益不损也。见根性中乃有差降。今论极照莫过如来说法唯益不损。是故可传。今言一时正明此教与机同会无差。故如此人且时堪闻三段。如来即于且为说三段。四谛亦然。但不见机者有逗机之过。有后机之失。如来无有逗机之过后机之失。故称一时也

佛住王舍城此下是第四出说经之处。此住处即证成我闻。汝言如是一部经我从佛边闻。若使审忆闻经之处。我闻之言可得信受。若不忆闻经之处我闻之言云何可信。是故出闻经之处证我闻不谬也。今就此出说经之处自有二阶。一广二狭。王舍城是广也。然外国之法国若大者别有国名。国若小者从城立号。但王城因缘从来旧闻不假记也。耆阇崛山中此是第二阶的出住处。然王城处凡有五山。未知如来的在何山。今的明佛在耆阇崛山中说法华经。外国言耆阇崛山此方言灵鹫。言此山中往古诸人服药学道成仙。又山顶有似鹫鸟故言灵鹫山也

与大比丘众此下讫退坐一面是第五出同闻众证成一时。前言应机之教不可不传。今未知与谁根性相应。今出此徒众明与此万二千人根性相应。乃至天龙八部相应也。难者言。何故不证成如是耶。解言如是两字止为总举一部经更无余意。不假证也

今就此同闻众中自有三段。第一人先列声闻众。第二从菩萨摩诃萨以下即列菩萨众也。第三从尔时释提恒因下讫退坐一面列凡夫众也。但众来之始未必如此。黑白前后无的次第。盖是出经者比次前后令条然可视。又欲分别高下目铭凡圣致使有此次第也。又意致寻求则有事有理。所言事者声闻常在佛左右。旦夕承奉不辨于游方益物。唯护戒清净形迹交密。是故在前而列。尚其亲密之怀。菩萨既以慈悲为先荷护度人为誓。无方利物化他为务。不得常在佛侧旦夕侍觐。形迹交疏于中而列也。凡夫进则不及菩萨退则有谢声闻。唯以五尘自呴受爱染为累。是故经家贬其凡猥在后而列也。理者声闻背生死苦乐涅槃乐。凡夫乐生死苦背涅槃乐。是故声闻在前凡夫在后。何以知然。声闻之人为三毒所恼八苦所煎。是故弃背生死之苦乐求涅槃之乐。凡夫爱著有为憎坏无为。菩萨则两舍居空虽乐涅槃不同声闻。畏生死苦自求涅槃。虽乐生死不等凡夫有爱着之心。但为求化他常求利物。是故维摩经言不舍有为不住无为此之谓也。二意如此三众可见

今且就列声闻众中自有两段。第一意学无学二千人以来先列声闻比丘众僧也。第二从摩诃波阇波提下竟耶输陀罗此则列声闻比丘尼众也。所以有此两段者为欲取男女尊卑两别也。又就僧尼两众之中各有二段。僧众二者第一与大比丘众下竟大阿罗汉詺为有名闻众。何以知然。此一万二千比丘常随如来处处说法。天上人间殊方异国远近知闻詺为有名闻众也。第二从复有学无学二千人以下詺为小名闻众。未必常随如来不尽为远近知识也。尼众亦然至时当道。今且就初众中自有六段。第一先谈人类第二称众数第三明阶位位登无学第四叹德第五列名第六如是下即释疑结句也。今言与大比丘众者此是第一明其是出家丈夫之类也。问者言何故不得罗汉是类比丘是位耶。解释者言。所言位者本据得果报处。今云罗汉此则位居极果。何异初地二地之位。但菩萨心行长广唯制因位。声闻情意狭劣唯制果位。此处为异也。难者又云。今言比丘即是出家之位非在家之位。解云不无此义但此处义隐。今就出家众中明其有类有位。何异俗间仕官之人亦有类有位耶。比丘是天竺语此间无的名翻译。古旧相传皆以三德释之。若使备此三德乃称比丘。何者一曰怖魔二言破恶三者乞士也。魔罗是外国语此方言杀者。若通途为论一切恶知识尽皆是魔。今的明者据第六天魔。然第六天魔未必常尔但偶于释迦一化不信正道。今一人出家魔宫振动。所以尔者此人发意踰越生死永弃五尘出魔境界。非止灭魔一人。然此人复有一灯之化。是故魔宫振动六师慑怖也。第二破恶者即是修戒定慧防身口七支诸恶及意地三毒四倒九十八使。此使诸恶法是累中之甚妨道之巨患也。第三乞士者夫出家之人不可终日自营。非唯增长贪爱故亦妨乱行道虽。然本出家之意以身许道。但有累之身未能亡餐。复应将护身命行道进德。不可空弃一身徒劳剪落。应须携钵到家资身行道。是故净乞自活表示清素。又此三德次第相成。问此人何故犹能怖魔余人不能。只由此人能破烦恼恶故。复问此人何故能破烦恼恶。只由净乞自活也

万二千人俱此是第二称其数也

皆是阿罗汉此是第三明此一万二千人阶位。位登无学也。罗汉亦是天竺正音于此亦无的翻译。相传旧解亦以三德释之。备此三德乃称罗汉。何者第一不生第二杀贼第三言应供也。若使此人后犹生三界流转六道者非谓罗汉。今明罗汉之人一殂之后不复受生。既断绝生因生果亦亡。故言我生已尽梵行已立所作已办不受后有。此之谓也。第二言杀贼者。贼之为用能夺人财宝伤人身命。今明九十八使烦恼诸贼无过嗔恚断人慧命。是故遗教经言。劫功德贼无过嗔恚。明诸罗汉结贼已亡功德不失慧命长存。是故维摩经云行罗汉慈破结贼故。第三应供者此人智断既圆堪生物福。亦取譬良田有秋收之实。是故下经文言我等今者真阿罗汉。一切皆受人天供养。又此三德亦得相成。只问此人死后何故不生。正由杀烦恼贼。又问此人何故能杀烦恼贼。由有应供之德故。亦有倒相生义那得有此应供之德。只由杀烦恼贼故云何得知杀烦恼贼。此人死后不复受生也。今将比丘三德来成罗汉三德。用罗汉三义呼比丘三义。何者比丘怖魔之德以成罗汉不生之德。比丘破恶之德以成罗汉杀贼之德。比丘乞士之德以成罗汉应供之德。出家之始詺为怖魔者为令终成不生之德。若唯存怖魔名不成不生之德者。虽有怖魔之名无有怖魔之实。若使在始有怖魔之名终成不生之德者。真是怖魔也。破恶之德又成杀贼者故。如临阵执刃能令前阵星散者。此则破而非杀。若使执刃能入阵能令当却无遗亡头失首者乃称杀贼。然九十八使有根本枝条。若使出家之名有始折伏枝条终则永断根本。可谓真杀贼也。乞士之名成应供者。在始虽复到家至户净乞活命。然未尽活命之方终则端坐。侍至事同化他。是故如来立比丘三义令终成罗汉三德。名不徒设意致如此也

诸漏已尽此下是第四叹德凡有五句。詺为依位叹德。初言诸漏已尽无复烦恼。此两句叹罗汉不生之德。根本无明本是漏也。今所明者是业及润生。明诸阿罗汉业及烦恼生因既尽故言不生也。逮得己利此一句即叹罗汉应供之德。明诸罗汉智断既圆堪受物供应养即是己利也。尽诸有结心得自在此两句即叹罗汉杀贼之德。尽诸有结此句正叹杀贼。心得自在此句结成。欲明诸结尽时心得自在。心得自在时诸结尽其无前后。而义有始终。只得言诸结尽故心自在。不得言心自在故诸结尽也

其名曰此下是第五列名。虽有一万二千罗汉今略列二十二。又阿若憍陈如者。阿之言无若之言智。詺为无智。憍陈如是外国姓此方无翻。所以尔者佛未出时此人是外道唯计有为病。如来出世知其根熟为说无生空理后得罗汉。明此人从无生空理生智故言无智憍陈如也。摩诃迦叶者摩诃言大迦叶是姓此翻为龟也。所以呼为大者异不三小迦叶故呼此人为大也。优楼频螺迦叶此下三人皆是兄弟。领五百徒众各在一处。迦叶犹是姓也。优楼频螺者是外国音此间翻为木蓏林。明此人昔领徒众住在木蓏林中今因本住处为名也。伽耶迦叶者昔日亦是外道。其人事火领五百徒众住在伽耶城中。如来往化即舍邪徒正得罗汉道。仍以本所住城为名也。那提迦叶迦叶犹是姓也。那提者河名也。昔是外道其人事外神领五百徒众住在那提河边。值佛受道得罗汉道犹以昔河为名也。舍利弗者亦是外国音舍利言身弗之言子。其母名身故言身子。后得罗汉其人聪明第一也。大目揵连者亦是外国姓此方无翻。字狗律陀是树神名也。其母无儿恒祠树神乞子。后得子时其不达业行谓言树神所惠。因此立名但谓狗律陀也。既值如来得阿罗汉果其人神通第一。又与舍利弗至心周旋要先得道者誓相报语也。摩诃迦旃延者摩诃大也旃延是姓。既得罗汉其人论义第一也。阿[少/兔]楼驮者亦是外国音此间翻者阿之言无[菟-?+?]楼驮言贫。谓无贫比丘。此罗汉乃非多积财宝但凡所至处衣服饮食触事胜人。此人昔日五百世中广行布施给救贫穷。今余报未尽称无贫。劫宾那者亦是外国语此间翻言坊宿。正言此人在僧坊中宿。如来知其根熟仍化作老比丘。与同共宿即于尔夜化令得道故言坊宿也。又解言此人是劫宾国人从国受名。前解必然后未必尔也。憍梵波提者外国名此间言牛齝比丘。此人虽得罗汉犹有二事似牛。一者口中空喘二者其脚迹似牛蹄。常被诸比丘诸讥笑。如来神力接置梵宫然诸天不笑故接置天宫。仍说往缘谓。此人昔日五百世常作牛王。是故无量寿经言尊者牛王即其人也。离波多者此间言星宿比丘。其母无儿恒拜求星神后得有子。既不达业行谓为星惠故言星宿。亦言假合身也。毕陵伽波蹉者亦是外国语此间言余习比丘。骂恒水神事也。诸比丘问佛佛说因缘。谓昔五百世中常作狱卒既得罗汉犹有余习也。薄呴罗者此间翻言善容比丘。能举动容仪可观也。又持一不杀戒得五不死报也。摩诃狗絺罗者此间翻言摩诃谓大也絺呴罗言膝。谓大膝比丘即是。长爪梵志是人舍利弗舅也。难陀者译为欢喜。明其人过去世中常行忍辱。今身见者皆生欢喜。又即是佛弟也。孙陀罗难陀是佛小弟。其人在俗有妇名孙陀利。今举其妇标之令知是小弟也。其人虽得罗汉但余习未尽。于只陀林中常行不等之心。现在作羯磨师。过去有分鱼等事也。富楼那者姓弥多罗尼子者此翻为满愿子也。是故无量寿言尊者满愿子即其人也。须菩提者译为善吉明其人有德常以吉事利人。所以尔者此人昔于福田所生嫌嫉之心。仍流转地狱无穷受苦。今者立誓誓不恼他。是故涅槃经云若有众生嫌我坐者。我当终身立不移处。行卧亦尔。誓有所为作于物为吉也。阿难者译为无染。其人形容可爱常随如来。人中天上瞻五尘之色见可爱之境。常求利物无有爱染之心。又得须陀洹果总持第一也。罗睺罗者译为障。由塞鼠穴因缘。六年处胎因此名为覆障比丘亦得须陀洹果也

如是众所知识此下第六段释疑总结。时众疑言万二千人中唯有一万一千九百九十八人是阿罗汉。阿难与罗睺罗此二人自是须陀洹学人之类。今何故与无学人同耶。解言此二人虽是学人然为大众亦知识。是故类入有名闻中与大。大阿罗汉等问者又言。颇有小阿罗汉故今言大阿罗汉耶。解言罗汉位齐实无大小。今形七种学人詺为大也。问者又言七种学人不名罗汉何所形耶。解言圣人立名有通有别。别则不尔通则皆然。何异须陀洹人亦名为学

复有学无学二千人僧众中本有二。此下是第二呼为少名闻众。未必常随如来也。就此众中准前亦应有六义。但前众既已备明六段。今此众中唯有两段。第一言学无学即是谈其阶位但出二种。初言学即是七种学人也。次言无学即罗汉无学也。第二言二千人即是谈其数也

摩诃波阇出家声闻众中有二。此下是第二列尼众亦证同闻也。又言尼众亦有二种。初有名闻后是有小名闻。第一言摩诃波阇波提比丘尼詺为有名闻众。何以知之。备二义故。一在家为论即是佛姨母。为如来所尊。二就法义。盖是女人中出家先首。为大众知识故在先而列。第二言耶输陀罗比丘尼此詺为小名闻众。何以知之。亦有二意。一者在俗时不为如来所尊。二者法中往取。此人出家复晚不尽远近知闻形前尼众呼为小名闻也。各有三义今就有名闻众中有三义者。第一言摩诃波阇波提此是出其名也。摩诃言大也波阇波提言爱道。谓大爱道也。第二言比丘尼此即谈其人类明其出家女人类也。与眷属六千人俱此是第三叙其眷属少多也

罗睺罗母此下是第二少名闻尼众亦有三义。初言耶输陀罗此则出其名也。第二言比丘尼即是人类也。第三言与眷属俱此即明眷属多少也

菩萨摩诃萨此下是第二列菩萨众所以中者意亦如前也。今就此众中亦有六段。第一谈其人类也。第二叙其数第三明其阶位。第四叹德第五列名第六举类举数总结也。今言菩萨摩诃萨者先谈其人类是大乘人类也。若具存外国名应云摩诃菩提萨埵。译摩诃言大菩提称道萨埵云心言大道心人也。夫称大道心人必有二义。一长二广。远求佛果不中途取证此心曰长。发意兼济此心称广。然二乘不逮贬其狭短有谢菩萨也

八万人此是第二叙其数也

皆于阿耨多罗三藐三菩提不退转。此是第三谈其阶位。但此中所谈据八地已上。明此诸菩萨居在不退位中。夫退有三种。一者位退二者行退三念退。自六心以还轻毛位信首五根未成。遇恶友时能断善根退入恶流故称位退也

第二从七心以上讫六地以还詺为行退。正明入忍之行有退失也。第三七地一地呼为念退。正明二谛之念不恒故言念退。然退之中亦有不退之义。何以知之。夫一善染神历劫不杇是习因之义不亡。招乐之义不失应非是退。但六心以还唯有一善染神不退。复有三种退义。即是位退行退念退。是故不得受不退之名也。又七心以上六地以还亦有不退之义。位登信首五根不复流转。乃至初地以上六地以还心会无相之境意入二谛之中。是故维摩经言受不退常寂然。所以不受不退名者。但位虽不退犹有两退之义。一明入忍之行相似无漏无得而失。二明二谛之念不恒现在前。是故受行退之名也。七地菩萨位登初忍实无退失。入忍诸行兴心即得。但杂相烦恼未尽犹有出入观异。致令二谛明解不恒现在前。故受念退之名也。今明八地以上菩萨永绝下地三种退义。位登法流长不出观。念念皆明岂有念退。所以尔者。有其二义。一明位登此地不复进退学。二明枝恶未尽唯断根本也。所以言于三菩提不退者。三菩提者正遍知道也。道者即是因也。正明此诸菩萨于无上正遍知因中不复退转也

皆得陀罗尼此下是第四叹德段也

凡有十二句合作四重。又合四重以为两双。何者初有三句叹德。第二从供养无量下有三句詺为叹行。第三从以慈修身下有四句名为叹体。第四从名称普闻以下有两句詺为叹名也。所以为两双者前二是德行后二是体名。所以先叹德行后叹体名者。夫言体名则善恶通有凡圣皆然。如来有体阐提不无。若言佛最善人便有体者则阐提极恶应无有体。而今佛与阐提皆有体者。故知好恶不在体也。名亦如此。如来妙响流播共闻阐提恶名天下皆知。故名体通漫凡圣皆有也。欲验真伪未若有德有行。是故先叹德行后及体名问者言等是先叹。何故先叹其德后叹行耶。解言为二义。一言德据其果行据因。二者言德据现在为用。行据往日修习。果与现在二义相会。因与往日二义相符。是故先叹其德后叹行也。问者言体名云何解。言亦有内外何以知然。要先有好体然后有胜名外闻。是故先叹其体后叹名也。又就此四段叹中各开为二。叹德中有二者。第一言皆得陀罗尼乐说辩才。此两句先叹内德后一句名为外化。陀罗尼是外国语此间译为总持。十方诸佛所说妙法皆能总持也。乐说辩才者有人解言是外化。德正言乐为人说也。今一家所习犹是内德。何以知然。有二义故。一理二教。理者本言四辩是智门非是功德。智慧门中本无外化。今言乐说辩才即是四辩中之一。云何是化耶。教者即大品经云解法智慧名为法辩。解义智慧名为义辩。解辞智慧名为辞辩。缘乐说智慧名乐说辩。缘乐说者只是前人机也。如声闻之机乐闻四谛缘觉之人乐闻因缘。只知前人所乐之法。法是前境今举境目智故言乐说辩也。转不退法轮者。第三句是叹德中第二意。名为外化。正明八地以上境智。轮者借譬为名也。世间者明轮有摧伏之义。今明轮体取八地以上境智无三退名为不退法轮。而俱满众生之性喻若轮体之圆也。能令凡得圣如轮转义也。能折伏众生之烦恼如轮有摧伏义也。说此八地以上境智以与前人故言转不退法轮也。叹行中有二者。初两句正叹行后一句证成。供养无量百千诸佛此句先叹菩萨殖行之始也。于诸佛所殖种德本此句叹行终也。此二句正叹行。但八地以上是众德。七地以还是众德之本常为诸佛之所称叹。此一句是第二证成叹行。不同二乘之行或叹或毁。初云随顺我法我即欢喜复毁言燋谷种也。叹体中有二者。一句叹身三句叹心。初言以慈修身此句叹身。问者言八地以上唯有智慧云何有身。解者言本谈应身岂有实报。所以尔者。由旷劫行慈慈本利物。应身得有由慈悲力。是故与乐拔苦不关余德也。善入佛慧此下三句是第二詺为叹心又此三句即作三慧初善入佛慧此句明照空之慧。但初地以上七地以还亦入佛慧未得称善。唯有八地一入法流常照无生故言善也。第二言通达大智此句明照有之智也。第三到于彼岸此句即总结空有。所以善入所以通达者良由到彼岸故也。夫理有浅深智成大小。七地以还未入法流名为此岸。八地以上常照二谛。长不出观名为彼岸也。名称普闻此下两句是第四叹名亦有二者初句正叹其名。明此诸大士德行高远名播之道有识含情无不共知也。第二言能度无数百千众生此即释成此名。由此菩萨分身救物是故天下共知故知释成也。其名曰此下是第五略列十八菩萨名也。如是等菩萨竟八万人是第六举类举数总结也

尔时释提桓因列同闻人有三段。此下竟退坐一面是第三列凡夫众。所以有后者意如前述。今就此中有六种众即成六段。第一先列天众第二列龙众第三鬼神众第四阿修罗众第五列金翅鸟众第六人众。今两种料简初明不次第意。次明无六道意及无无色意。所以别尊卑不次第者。但如来在人中说法。阿阇世王即是王舍城主。主人有让客之义是故先列前五众后又列人众。又客众之中不次第者。但五客众中天报最胜。是故先列天众后及余道。若客众次第列者天后列修罗。但龙有两义故胜。一者是天眷属二者于人有恩。龙能升云降雨似天义。是以世人常言天雨有此两德。是故在前。所以列鬼神众在次列者。然此众悉诸天乐神随诸天后行。是故在之后列也。又此六段中无有六道。何以故。地狱众生罪障报深重不能得来唯有五道也。所以有六段者但龙与金翅鸟同是畜生。今离为两众故有六段也。又列天众之中有所不尽。唯列欲色界天不及无色。所以尔者其二意。一据小乘经故彼处无有色。既无有色不去不来。二明三界果报彼处最胜。由着情深妨受正道即是长寿天难也。今且就列天之中自有两段。第一先列欲界诸天第二列色界诸天也。列欲界天中又不尽。唯列初二天后二天合有四天。略无中间二天也。又不次第。释提桓因者此是欲界第二天。是佛天上檀越故在前列。外国名谓释提桓因译言能为天主也。下名月普香宝光等皆是帝释辅臣故次第下列之也。四天王天此则倒列欲界第一天。即是须弥四埵头首亦各有眷属也。自在天子者是欲界第五化乐天诸有所须能自化作也。大自在天子者即是欲界第六天。他化自在天明诸所须皆是他人化作也。略不列第三炎魔天第四兜率他天。既列前后四天中间二天可知也。娑婆世界主梵天王此下是列天中第二列色界诸天。今言梵天王者即是初禅梵王也。尸弃大梵者即是二禅梵王也。光明大梵者是三禅梵王也。等即等第四禅天也

有八龙王此下是第二列龙众也。此下龙神等四众例皆有三。一者总唱数二者列名三者总结也。难陀者译言欢喜。跋难陀者译为善欢喜也。变为人形佛边听法于人有染润之恩见人皆欢喜也。龙唯五时中不得变身。一眠二睡三嗔四淫五死时也。娑加罗者因国得名也。和修吉者译为多头即九头龙王也。德叉迦者译为多舌也。阿那婆达多者译言无热也。诸龙相与连甲中有小虫唼食。故于热沙中曝。复有热沙之苦。唯此龙无小虫故无热沙之苦也。摩那斯者译为大身则是绕须弥七匝也。沤钵罗者池名也。此龙住在塸钵罗花池之中因池立名也

有四紧那罗王此下是第三列鬼神众。皆是帝释作乐神。初有四神名为法乐。后有四神名为俗乐也。紧那罗者翻为疑神也。初言法紧那罗者此神丝竹之中显出四谛之法。妙法紧那罗者此神丝竹之内奏十二因缘法也。大法紧那罗者此神丝竹之内显出六度之法也。持法紧那罗者应言总持法经文略。此神丝竹之中并说三乘法轮也。有四乾闼婆王此下四神是帝释俗乐神。初言乐乾闼婆王者直乐神无音声者也。乐音者有音声者也。美乾闼婆者无音声中胜者也。美音者音声之中胜者也

有四阿修罗此下是第四列阿修罗众。阿之言无修罗言酒詺为无酒神。为下善所得。实非是鬼其多谄曲贬为神。神之果报率多嗜酒。此诸修罗神力因缘皆不饮酒也。婆稚者译为被缚

毗摩质多罗有女名舍脂。形容可爱为帝释所重即纳还天上以为妃主。既主之后不与妇公交通。毗摩质多罗王即遣波稚领兵征伐帝释。帝释既奉事如来常诵波若神咒。咒力因缘即令波稚被缚也。佉罗骞[馬*犬]者译言广肩胛也。毗摩质多罗者即是帝释妇公相传无翻也。罗睺阿修罗者译为覆障。其人手脚甚长有时以手障掩日月故言覆障

有四迦楼罗此下第五列金翅鸟众。有大威德故言大威德也。身量实大故言大身。欲食诸龙常得满足故言大满。欲食诸龙自在随意故言如意也

韦提希子此下是第六列人众自有三。第一列名阿阇世王母韦提希。今举母名子故言韦提希子也。外国言阿阇世此间译言未怨也。第二与眷属若千人者总列众类。第三致敬。以此类上五众。例应各礼佛足退坐一面。经文略故无也。辨通序竟

从尔时世尊四众围绕以下竟品是第二詺为别序。正明众经各异部部不同之意。具如前述。又别序有五亦如前释。一者众集二瑞相三疑念四发问五答问序也。今就五别序中各开为二。众集序中二者第一正明众集第二从供养恭敬以下即叙众集体宜也。今言四众围绕者此是第一正明众集也。虽有天龙八部莫过四类。即出家四众也

供养恭敬此下是第二叙众集之体宜。就中自有总有别。初言供养即是总。下别出三业供养。恭敬即身业尊重即意业赞叹即口业。在口则誉扬圣德意地则尊重如来。涉身则恭敬于佛。然此诸句皆是经家语也

为诸菩萨说大乘经此下竟以佛舍利起七宝塔是第二瑞相序。亦有两段。第一先明现相于此土。第二于此世界尽见彼土以下明现瑞相于他地。此两段中各有六段。今初段中六种瑞相者。一说无量义经二入无量义定。三者天雨四花。四者地六种动。五者大众欢喜。六者佛放胜光明。又此六种瑞相合成三双。初一双者动则说法度人静则入定观理。此则动静相对。第二双者上则明天雨四花下则明地六种动。此则上下相对。第三双者时众则内心欢喜如来则外放光明。此则内外相对也。呼为瑞相者相据于外瑞据于内。然相即是瑞。瑞亦即相。但密报称瑞表异称相。何以知然。然将欲显说一因一果之理明三乘行人同归成佛。以此六种相报众生呼之为瑞。即此六种表必说法华名为相也。所以无量义经为法华作游序者凡有两家解。一家解言。此经明无量万善同归皆成佛道之义故名无量义经也。但法华所明正言无二无三会三归一。然无量义经直明万善成佛不言无二无三破三归一与法华有异。是故得有法华作游序。第二家言。无量义经明无生空理不可边量往求故名无量。即此空是万有之义也。是则大品维摩亦明无相空义。何故不为此经作序。伊家通言居然如此。前明三乘后明一乘此是真序。更欲何觅。解释者言。五时次第不无此义。但执义之家好序太过。今明为法华之序正明一时一坐一部经教各自有序。何异五时之教皆有序正流通。今明无量义经犹是堪闻法华徒众闻此经。但未说法华之前仍说无量义经。大品维摩虽明无相空义犹言三家行因为量三乘得果不同。然无量义经言夫行善者皆得佛果。是故有异大品维摩。又直言万善成佛不明会三归一。是故复异法华。既居两过之间。是故得为法华作序也。此经是大乘教故言为诸菩萨说大乘经。是佛所重故言佛所护念也。即用此经表必说法华。即是相义。又有密报之能即是瑞义也

佛说此经已下此是第二瑞相。只说无量义经竟仍入定之意。为欲譬坐令弥勒问于文殊。若不入定弥勒便应问佛。是故入定兴问有由也。问者言。只应入法华三昧何故入无量定耶。解释者言。若入法华三昧云何得有为法华序耶。无量义处者无量义经明万善成佛。佛果是无量义所归之处。又明如来将欲说法华义故。是故先入无量义定表必说法华。即是相义密报时众即是瑞也

是时天雨此下是第三明天雨四花以为瑞相。曼陀罗花者译为小白团花摩诃曼陀罗花者译为大白团花。曼殊沙花者译为小赤团花。摩诃曼殊沙花者译为大赤团花也。虽有四花今合为两双。前二白团花譬在家二众。后二赤团花譬出家二众。虽两双有共一意。何者欲明四众昔来所行皆是花而未果也

又散佛及大众者明众生万善花必得佛果。是故花散佛及大众也。表必说法华即是相也。有密报之功即是瑞也

普佛世界六种震动此是第四瑞相。普是有缘感佛世界以来皆悉振动。大地常安而今忽动。此即奇事明义。但三乘行人人有六种执。执三因三果言决定言决定不同。此即惊动执固之心。又一解尔时六种者动众六道众生皆成佛也

尔时会中此下是第五瑞相。大众欢喜好事应来。预通灵瑞表必说法华即是相也。有密报之能即是瑞也

尔时佛放此下是第六放光瑞相。光本除闇而能显色令现。欲明此光密表一因一果之解。如显色而能遣执三之迷如除闇也。前明能照后明所照。在上放者譬如人身头最为上。密表一乘因果超坐三乘之上也。在眉间者亦密表一乘因果是中道之理。从照东方以下明所照。然光应照十方今的明东方者。借此一方表一因一果也。且又东方是诸方之上也。万八千世界者。一万是极数此密表时众必得果因满也。八千者不足之数明三乘人昔来所行是因而未足也。靡不周遍者即是横论。东方万八千土光尽照乃至八方也。下照无间上至色究竟者竖论。上下光皆至欲表天下万善皆归极果也。今就教为义未明无色有色是故略不道也。有一种解从下至阿鼻地狱以下是第二现瑞相于他土。若因此解于下偈极便。今且依前判。从于此世界尽见彼土此下是第二明现瑞相于他土。中亦有六种瑞相。第一因光见六道众生。第二又见彼土现在诸佛者明因光见东方诸佛。第三及闻诸佛所说经法者明因光闻他土佛说法。第四并见彼诸比丘以下明因光见二乘人修行。第五复见诸菩萨以下明因光见大乘人修行。第六复见诸佛般涅槃以下明因光见他方佛般涅槃乃至起塔供养也。旧解言。定有六见一闻事。不见此义。一家所习不尔也。又此六种亦成三双。初一双者始见六道众生终见诸佛此即凡圣相对。始离成凡夫终会成圣人也。第二双者初闻佛说法次见二乘人修行。此即说法受行相对。始则如来说法后则弟子受行也。第三双者见菩萨修行见佛涅槃。此即因果相对。始即行大乘因终则得大乘果也。第五瑞相中言种种因缘者。明菩萨备行四等六度净佛国土诸因缘也。种种信解者信解行向等。乃至净佛国土也。种种相貌者舍物相貌持戒相貌忍辱相貌。故言种种相貌也。即是他土六种瑞相表必说法华。即是相也。皆有密报之能即是瑞也

尔时弥勒菩萨作是念。自此下是第三詺为疑念序。亦有两段。第一先明弥勒有疑念。第二从尔时比丘以下竟今当问谁。即叙大众有疑念也。就弥勒疑念中凡有三念。始具两疑终事决成一疑。大众有两念即是两疑也。弥勒三念者从尔时弥勒作是念下竟以何因缘而有此瑞。此是第一念即第一疑。此正疑上二六种瑞相何故现耶。自有二句。初尔时弥勒作是念下明疑前之念。次以何因缘而有此瑞正明疑也。但瑞相之名皆得换易。亦可言今佛世尊现神变瑞相以何因缘而有此瑞相。亦可双举言今佛世尊现神变相瑞。以何因缘而有此相瑞。神是内力变据外用。何者若据内谈如来种智则物莫能测。即是转海水为苏酪。长短改度小大相容等也。第二从今佛世尊入于三昧讫当以问谁谁能答者。此即是第二念。既有此瑞相疑不知问谁。即是第二疑也。亦有二。初今佛世尊入干三昧下明疑前之念当以问谁以下正明疑也。佛若不入定我当问佛。佛今入定我当问谁。从复作是念是文殊师利讫我今当问此是第三念。即知文殊是可问之人此是第三念即决上第二疑。上第二疑不知问谁今既知文殊是可问之人。故知即知决上第二疑也。唯有第一正疑瑞相在也。是故弥勒凡有三念始具两疑。终成三念一疑也

尔时会中比丘比丘尼此下讫今当问谁。第二叙大众有疑念。今就大众有两念即是两疑。初念正念上二六种瑞相。又即是第一疑。疑言此瑞相何所为也。光明于六中最显。是故举显者为首也。第二念言今当问谁此即是第二疑。疑言不知问谁也。上弥勒第一疑中有二。初明疑前之念次正明疑。今者大众第一疑中唯有疑前之念。略无第二正明疑也。上弥勒第二疑中亦有二。今者大众唯有第二正明疑不知问谁。略无疑前之念文句略互遣明义也。但弥勒三念大众二念。当乎尔时皆非发言。直是经家述取其意也。大众所以无第三念者。若论实处无谢弥勒。而念弥勒应有第三念。知有可问之人而大众无者。为欲高推弥勒是补处大士能知有可问之人。大众既非补处之位不辨能有第三念也。且自今日所宜只弥勒腾大众疑以问文殊。不言诸大菩萨不能腾疑。但高推补处是故无第三念也。问者言。若果正在定云何问佛。且取自待佛出定然后问佛。佛使即说此经即是正说。云何称序。只应问文殊引古证今。知出定必说法华。是故叙秪为序。难者又言只问弥勒为自有三念为物者耶。解释者言居本为物。何容自为问答。为物者何为许人耶。解释人言定只为始行菩萨及凡夫也。问者又言即此时众有得他心智者。即见弥勒有如此疑如此为义。岂成为物耶。解释者又言。只如此智即成为物。今得他心智人于时只宜知弥勒心中实自为物有此疑念。应问文殊。文殊名答非他心智。人既有此智密资进行类知。如来应说法华。如此为义于物有益。是故诸有所作亦不唐捐。此之谓也

法华义记卷第一妙法莲华经义记卷第二

        光宅沙门法云撰

尔时弥勒菩萨欲自决疑此下尽偈。是第四发问序。亦有两段。第一经家叙弥勒自欲问之意。第二从而问文殊师利言以下竟偈是正问也。又此两段之中各开为二。经家叙欲问中有二者。第一言尔时弥勒菩萨欲自决疑。经家叙弥勒自欲问意也。第二又观四众竟众会之心。此明经家叙弥勒有兼他之意。兼他之意者欲腾大众疑念以问文殊也

而问文殊师利言此下尽偈是第二正问段也。就此亦有二者。第一从而问以下尽五十四行偈以来詺为正问也。第二从佛放一光下有八行偈詺为请答也。又此二段各开为二。正问二者。第一是长行略问。第二五十四行偈重颂广问也。第二八行请答二者。第一佛放一光下有三行偈。先举所见之事正请答也。第二从四众欣仰有五行偈即释伏难结请也。所以长行称略说偈中言广问者。若据理为义则长行是广偈中是略。何以知然。长行之中各总问彼此二六种瑞相。尽故及至偈中各别颂不尽故。今就文为义则偈中是广。长行为略。何以故。偈中文多长行文少故也。今且就略广二说之中又各开二。长行二者第一而问以下竟神通之相。总问此间六种瑞相也。第二放大光明以下竟国界庄严。总问何故使我见他土六种瑞相也。就问他土瑞相中有二。初放大光明以下明瑞相之由。第二悉见彼佛国土以下是正问也。今广问之中虽有五十四行偈又分有二。第一有四行偈广颂上问见此间瑞相也。第二从眉间光明以下有五十行偈广颂上问见他土瑞相也。今者四偈唯颂四种瑞相。不颂第一第二瑞相也。初一偈颂第六放光。次一偈半颂第三天雨四华。次半偈颂第四地动。次一偈颂第五四众欢喜也。今者初偈问放光。詺佛为导师也。但初何故句。是通冠诸瑞相也。雨鬘陀罗此一行半今颂上雨华。上有四华今者唯颂二华。唯小白华小赤华但半行颂也。栴檀香风一行义出故摄属雨华也。而此世界半偈颂上地动也。时四部众一偈今颂上四众欢喜也。上总问中含有六种。今者偈中的颂四种也。然略不颂说无量义经。亦略不颂入定也。所以略者有二意也。一者文略也。二者事中不便。何以知然。如来在世未曾不说法度人。今日云何忽尔更问言何故说无量义经耶。诸佛世尊常在三昧悉见诸佛国土。不以二相忽尔重问何故入定。此即事中不便是故略不颂也

眉间光明此下有五十行偈。是第二广颂上长行中略问见他土瑞相也。判此五十偈凡有二种。今且依长行初判为两段也。第一眉间光明一偈半颂上第一见瑞相所由。此光明乃非他土瑞相。但由此光明见他土瑞相也。第二余四十八行半颂第二正问见他土瑞相也。唯颂五种瑞相略不颂第四瑞相也

今就四十八行半中大分为三段。第一从诸世界中下八行半。先略颂见他方三种瑞相也仍道。第三我见彼土恒沙菩萨下三十八行半广颂问二瑞相。即是他方大士修行及他方佛般涅槃。乃至起塔供养也退道。第二从文殊师利我住于此下有一行半偈。詺为结前略开后广也。初八行半略颂三瑞相者。初有一行半颂第一见六道众生。第二半行颂第二见东方诸佛也。第三有六行半颂第三闻他方佛说法也。又就初一行半自有二阶。初一行一句正颂所见也。第二言于此悉见一句则明能见也。就所见中凡有四意。初诸世界中下半偈正明六道。生死所趣一句明詺是生死。善恶业缘一句明因。受报好丑一句明果报也。善恶业缘者此即是六道之因也。善恶两字是别善即三善道因也。恶即是三恶道因也。业缘两字即通于善恶也。受报好丑者。受报两字即总举六道果。三善道亦是受报三恶道亦是受报也。好丑两字别名得六道果报。何以知然。好即是三善道果报也。丑即是三恶道果报也。又睹诸佛圣主师子此半行是第二即颂见东方诸佛也。演说经典此下有六行半偈。是第三即颂闻他方佛说法也。就六行半中自有五阶。第一言演说经典微妙第一。半偈问言何故令我闻佛说法出胜天魔外道表耶。第二其声清净一偈。问言何故令我闻佛说法出群圣之外耶。第三梵音深妙一偈。问言何故令我闻佛说法称悦时众之心耶。第四种种因缘一偈问言何故令我闻佛说法。能上弘佛道下济众生耶。初三句明上弘佛道。开悟众生一句明下济苍生。第五若人遭苦下三行。问言何故令我闻佛说法。称可三乘人根性耶。三行即道三乘。初偈为声闻。若人有福一偈为缘觉。若有佛子一偈为菩萨也

文殊师利我住于此此下一行半偈是第二詺为结前略复开后广也。就中自有二意。初三句先结前略也。第二及千亿事下复有三句复开后广也

我见彼土恒沙菩萨此下有三十八行半偈。是第三偏广颂第五问见他方菩萨大士修行。及第六他方佛般涅槃及起塔供养也。略不颂第四三乘人修行文句虽略义中得兼。何以知然。只颂闻佛说法。既有说法必有受行之者。故义兼第四三乘人受行也。就三十八行半又分为二。第一三十一行半颂第五问他方大士修行。第二又有菩萨佛灭度后下七行颂第六他方佛般涅槃后事也。就三十一行半中自有三段。初一偈先总举菩萨行大乘行作问也。第二或有行施下有十三行偈。举菩萨要行作问。要行者即是六度也。第三从又见佛子定慧具足下有十七行半。广举见菩萨遍行杂行作问也。今就第二十三行明要行中。明六波罗蜜即为六段。或有行施下六行明檀。两行明戒一行明忍一行明精进两行明禅一行明波若也。或有行施以下有六行。先明见菩萨行檀波罗蜜也。次文殊师利我见诸王以下两行明戒波罗蜜。初一行明得戒方便。后一行正明得戒。或见菩萨而作比丘一偈明忍波罗蜜也。他人不能独处而伊能独处岂非忍也。夫忍有两种。一者打骂不嗔加恶不报。二者弃亲爱眷属住空闲之处。亦是难忍。能忍。忍今据此为义也。次又见菩萨勇猛精进一行即明精进波罗蜜也。次又见离欲两偈明禅波罗蜜。初偈明定与定果。五通即是禅定果。后偈明禅定用也。复见菩萨智深志固一偈明波若波罗蜜也

又见佛子定慧具足。此下有十七行半偈。是第三举见菩萨行杂行作问。就问杂行中凡有五种杂行。第一又见佛子一行半明见菩萨说法作佛事也。第二破魔兵众而击法鼓半行明见菩萨降魔作佛事也。第三又见菩萨寂然宴默一行偈明见菩萨寂寞作佛事。第四又见菩萨处林放光下一偈明见菩萨光明作佛事也。上来四种作佛事皆不开也。第五从又见佛子未尝睡眠下有十三行半偈。明见菩萨乱行六度作佛事。此中初一偈明精进也。次一偈明戒。一偈半明忍。两偈明定。五偈明檀。三偈明波若也。何者又见菩萨未尝睡眠一偈明精进也。又见具戒下一偈明戒也。次又见佛子住忍辱力一行半明忍也。若被恶骂始似誉扬若加刀杖则如华雨。真可谓忍也。次又见菩萨离诸戏笑下有两行明定也。或见菩萨肴膳饮食下五行明檀也。或有菩萨说寂灭法下有三行明波若。就中自有三意。初偈明智慧。说法之相明化他人之能也。次一偈明照空也。次一行明照有也。然空有皆是自行要用。空解在前有解在后也

文殊师利又有菩萨佛灭度后供养舍利。自此下有七行是第二颂第六问他方佛般涅槃后起塔供养。就此七行中自有三段。初一偈未暇得起塔且明尊重供养舍利也。第二从又见佛子造诸塔庙下有四行偈正明起塔供养也。第三从文殊师利诸佛子等下两偈释疑结供养之义。只就第二四偈起塔供养中即成四阶。初一偈正明造诸塔庙。第二偈叙塔之度量。第三偈叙严饰之具。第四偈叙时众设事供养塔也。何者初又见佛子造诸塔庙下一偈正明为舍利故起塔也。宝塔高妙一偈是第二叙塔之度量广狭长短之相。高五千由旬者一由旬四十里四五二十便有三十万里也。复言此塔纵广二千由旬。四二而八便是八万里。从一一塔庙各千幢幡此下一行是第三叙严饰之具也。诸天龙神一偈是第四明时众设事供养塔也。文殊师利诸佛子等此下两行是第三释疑结供养之意。时众疑言。汝上言造诸塔庙严饰国界。若如此者只为严饰国界此则无有供养之意。今两偈释疑言。国界自然殊特妙好非我本心。本不为严饰国界但造塔庙之后荫映国土。自然而好。一偈半法说。下半偈即作譬说。言如天树王其华开敷。故如波利质多罗树但种此树本为得果资身。不为觅花严树。但华敷之时树自然好。无异国界中有塔此国界自然好也

佛放一光就弥勒第二正发问中本有二。一者正问中本有二。一者正问即是长行。而偈此下有八行偈是第二请文殊答。又就此请答中本有二。第一有三行偈先举所见之事正请答。第二从四众欣仰下有五行偈释文殊伏难以结请。又就此两段之中各开为二。正请答中有二者。第一佛放一光有两行偈。先举所见彼此两种瑞相以为请端。第三偈正请答。就请答端中初偈总举见此间瑞相。诸佛神力下一偈举见他土瑞相也。初偈所以举光明者。此意犹如前释瑞相之中光明最显。是故举光明余者可知。诸佛神力下一偈举见他土瑞相。此是释迦力何故言诸佛神力耶。解释者言释迦是诸佛之数。此则明诸佛道同之义。放一净光照无量国此是他方瑞相。何故举光明。此义亦如前释言此光明乃非他方瑞相。但见他方瑞相要由光明。是故举其所由也。我等见此得未曾有佛子文殊愿决众疑前两行偈既举所见事竟。此一偈是第二正请答也

四众欣仰此下有五行是第二释伏难。结请亦有二者。第一有四行先释四种伏难。若不释伏难结请之义终不成也。第二余一行正结请也。四种伏难者弥勒上言佛子文殊愿决众疑。文殊仍作第一伏难言。汝自道四众有疑四众何曾有疑。若有疑者自当发问何劳汝说耶。是故弥勒即用初偈释此伏难。言四众欣仰瞻仁及我。故知四众实有疑。瞻仁欲令仁者答。及我欲令我问那得言四众无疑耶。文殊仍复起第二伏难言。汝今若言四众果有疑者但神通瑞相。此事微细。我今云何专。尔相答。汝但待佛出定自应问佛也。是故弥勒即用第二偈释此伏难言。佛既入定何时当出。但大众即今怀疑抱惑。心意不安。仁者既是智士。曾见久远应即时见答令疑惑得除。云何方复令我待佛出定。我知如来何时当出定耶。是故言佛子时答决疑令喜。有何所以放光动地耶。文殊仍复起第三伏难言。汝若欲令我答者夫瑞相所为实难定判。汝既是补处菩萨。微微下意共释众疑。那得专令我答。此则于理不可。是故弥勒仍用第三偈。复释此伏难言。仁者欲令我下意者亦可微微厝心下意。正言我今不知如来现此瑞相。为当欲为大众说此释迦所得妙法。为当欲为大众受记将来妙果微心下意正自如此。文殊仍复起第四伏难言。若如此者自可得决大众心疑何用我答耶。是故弥勒仍用第四偈复释此伏难言只我此意非是决断之意。但瑞相所表难可定判。云何用我犹预之心答大众。是故言示诸佛土众宝严净。此间瑞相及见诸佛明他方瑞相此非小缘。若是小缘可令我决。既非小缘仁者应答也(然此伏难是光宅法师传谢寺次法师次法师又传江北招法师解既名匠所传后生学士实宜遵奉也)

文殊当知下一偈是第二正结请也。问者言。前言四众龙神瞻仁及我今言瞻察仁者。何故不言及我。解释者言。前欲使我问所以及我。今我问已竟。所以唯瞻仁者也。欲说何等者有两解。一解言正听仁答。如来出定定说何等。第二解言四众瞻察仁者定说何等用后解

是时文殊师利语弥勒菩萨言此下竟品是第五答问序。亦有两段者。第一竟四十三行偈以来正答也。第二从诸人今当知合掌一心待下有两行偈詺为开奖物心结答。又此两段之中各开为二。正答中有二者第一是长行第二是偈颂也。开奖结答中有二者初偈明好事应来即是显一与显远。第二偈明恶事当去即是开三与开近也。不可不专心澍仰冀闻妙说也。今且就长行中大判为四段。第一竟演大法义一往仿佛思惟忖度以答弥勒也。第二从诸善男子我于过去曾见此瑞竟故现斯瑞略引古证今。小复分明略答也。第三从诸善男子如过去无量无边以下广出曾见之事。引古证今事同广答弥勒也。第四从今见此瑞与本无异讫长行分明结答也。所以有此四重说法者。若实论文殊则是往古诸佛龙种如来。今既迹居释迦弟子。那得灼然分别决判。应须次第阶渐先一往思惟忖度。虽复一往思惟忖度但此思惟忖度非是空然。是故第二言我于过去曾见此事。此事未足可以相训。是故第三广出曾见之事。但昔日有瑞相与今日瑞相事同。只昔日佛现瑞相竟仍出禅定后便说法华。以此事同验知今日如来必应说法华。广引既竟时众可以寄意。是故有第四分明结答也。又解为三段。第一思惟忖度第二广略两重引证。第三总结上两段也。今且依前解。就此四段之中各开为二也。第一思惟忖度中有二者。第一言是时文殊师利竟如我惟忖此正是时能思惟忖度也。第二从今佛世尊欲说大法下有五句即出所忖之事。非是空然思惟。然此思惟必有其事故也。曾见中有二者。第一从诸善男子竟今佛现光亦复如是正明曾见也。第二从欲令众生咸得闻知以下明文殊深得曾见之意也。第三广引事同中有二者。第一从诸善男子如过去无量无边以下讫欲知此光所为因缘。明已见事与曾见事同。第二从时有菩萨名曰妙光以下明当见事与曾见事应同。第四分明结答中有二者。第一言今见此瑞与本无异此结已见事同。第二从是故惟忖今日如来当说大乘经此下结当见事应同也。今者第一明思惟忖度自有二。第一是时文殊师利以下正明能思惟忖度。从欲说大法以下第二出所忖之法。虽有五句且作三段。第一句法说中间三句譬说后一句亦法说便成三段也。三句譬说者则为前欲说大法一句作譬亦为后演大法义一句作譬也。今第一句所以言欲说大法者此明文殊思惟忖度一因一果大法也。今此一欲字通冠下四句也。所以言欲说者。文殊言我思惟忖度之时如来出定之后必当略说一因一果大法。是故如来下明因之中先略说开三显一。即与此欲说大法句相应。下明果之中先略说开近显远之义。亦与此欲说大法句相应。故言欲说大法也仍道。第三段显大法义者。此明文殊思惟忖度如来出定之后。非唯略说因果大法而已。亦当广说一因一果大法之义。是故如来下明因中有广说开三显一断疑生信之义。则与此演大法义句相应。下明果中复有广说寿命长远断疑生信。亦与此显大法义句相应故言显大法义。思惟之义意在乎此也。雨大法雨者此下中间三句为前后两句作譬。自分为两意。第一句通为开三显一开近显远作譬。第二两句各别作譬。吹螺一句为开三与开近作譬。击鼓为显一与显远作譬也。所以名作雨大法雨者。但昔三乘人执三因决定别异无有得佛之义。且又昔日二乘小心狭劣。不能广化众生沾被万物。又执三果究竟无有进求之心。此是枯旱之义。如我今日思惟忖度如来出定之后必说大乘因。明三乘人皆成菩提受记得佛。明佛果更有复倍为期。此则是雨大法雨沾润之义也。吹大法螺者外国言吹螺改号。但昔日三乘人执昔日三因三果。自言决定不可移改。明今日如来出定之后必说无有三乘之别三果之殊。此则改昔日三乘号令立今日一因一果之号。是故下经文言开方便门。即是改三乘之号。何以知之。昔日不言三乘是方便。如来下既言开方便门。此则改昔日号令也。击大法鼓者前吹螺改号今严鼓诫兵。夫诫兵之法便万心同契齐率物情。将欲有所为作。表明今日如来应说一因一果。是故下言示真实相。时众不可不欣心澍渴仰欣。形异心同齐竖意志欣闻异唱也。又言前吹螺一句正明改昔三因三果号令。作今一因一果之号令。严鼓诫兵者将欲前进破阵。内合昔日止言断四住地烦恼。今日犹有无明住地烦恼。时应断此无明住地烦恼。故言严鼓诫兵也

诸善男子我于过去曾见此瑞。此下第二自言曾见瑞相之事。然此意小复分明略答。就此曾见中亦有二者。第一正叙曾见。第二从欲令众生咸得闻知竟故现斯瑞以来。此明文殊非唯直曾见而已。亦复深得曾见之意。欲明如来必应说同归之理莫二之教。然则深得佛心妙知圣意也。又释前明引古后明证今也

诸善男子如过去无量。自此下是第三出曾见之事广引事同。此中亦有两段者。第一诸善男子竟欲知此光所为因缘广明曾见事。显已见事同于此曾见事。第二从时有菩萨名曰妙光以下亦广明曾见事。显当见事应同此曾见事也。故第一段名为已见事与曾见事同。第二段名为当见事与曾见事应同也。又就此两段之中。前明已见事同中自有七种。后明当见事应同中自有四也。已见事与曾见事同虽有七种。而分文不成七段宜分为三。或分为四者今不用之后者。第一先明过远最初一佛有二事同。第二将欲取最后一佛更有五事同。故先明比次一万九千九百九十九佛亦同有二事。第三其最后佛以下取最后佛明更有五事同。然好解之事前列诸佛悉具五同。其最后佛亦有七善及三乘教同。但文句平等出耳。然分文虽三终成七同三。言最初佛二事同最后佛有五事同合七事同。七事同者第一演说正法以下明七善义同。第二明三乘教同。第三明今佛与昔佛在俗有王子义同。第四明王子出家义同。第五明现瑞相于此土义同也。第六明现瑞于他土同。第七明疑众同也。今先明第一段初佛中有三。初明劫数时节。第二明通别二号。演说正法以下第三正明二事同。初明七善中有二。演说正法一句是总明七善。第二别明七善中初善中善后善此三种合为一善。名为时节善。初善者序说即是初善也。正说即是中善也。流通说即是后善也。教能生人善故言善。此是缘中说果也。其义深远。此是第二善此是理善也。望之杳然目之为深。行因久到詺之为远。此则是言下之理妙也。其语巧妙此第三善。此即是理上言巧。纯一无杂是第四善。下四善通于理教也。文理真正故言无杂也。具足者是第五善。文理无不圆。即是诸恶莫作诸善奉行故言具足。清白者此是第六善。文理映彻目之为清。此理无染目之为白也。梵行之相者此是第七善。梵名涅槃行者是涅槃家因也。此即是道谛也。相即是标相也。犹如见烟知火见鹤知池。执揽此经知有梵行之因果。此经则为因果作相故言梵行之相也。为求声闻者此下是第二明说三乘教同。昔日月灯明佛说三乘教。今日释迦亦说三乘教也

次复有佛亦名日月灯明。此下第二比次取一万九千九百九十九佛。亦有二事同

其最后佛。此下是第三明最后佛五事同。一者有子同二者王子出家同三者现瑞相于此土中同四者现瑞相于他土同五者疑众同。何者初昔日佛在俗有王子今释迦如来复有罗睺罗。但子数虽不等然则有子义同。是诸王子闻父出家。此下是第二明王子出家义同。昔日王子出家今日罗睺罗亦出家也。是时日月灯明佛说大乘经名无量义。此下是第三明现瑞相于此土义同。上有六种瑞相说无量义同入无量义定同也。天雨四花同也。地六种动同也。四众欢喜义同也。佛放光义同也。如今所见是诸佛土。此一句是第四明现瑞相于他土同。文句虽略义亦总含有六种瑞相也

尔时会中有二十亿菩萨下竟欲知此光所为因缘。是第五明疑众亦同。日月灯明佛亦有疑众。今日大众亦有疑也。时有菩萨名曰妙光自此是广引事同之中。第二明当见事与曾见事应同。就此中自有四种义同即成四段。初明所因人同二说经名同三说经经劫数同四因人流通同也。昔日月灯明佛因妙光说法华。今释迦亦应有因人说法华。是故下明因中对舍利弗说。辨果中对弥勒说也。第二说经名同者昔日月灯明佛从定出所说经名妙法华。今释迦出定后亦应必说法华经也。第三明说经经劫数同者。昔日日月灯明佛说经经六十劫。今释迦说法亦应同劫数。故下经文言如是之间经五十小劫也。第四明因人流通同者。妙光昔日于八十小劫流通法华。今释迦弟子亦应有流通经人下果有药王等流通此经也。问者言日月灯明佛本因妙光说经。是大乘人因其正说经。今药王等乃因其流通经。何关因其说经事。今释迦出定乃因舍利弗及与弥勒。此岂成同耶。解释者言当深得其意。此因非对说之因此乃是凭附之因。因附此人得明此理故言同也。问者又言。何以得知非是对说之因而是凭附因耶。解者又言。若如来虽说此经无有药王等大士传说此自行化人之时。如来则不得说此经。故知是凭附之因也。问者又言。若尔应过去诸佛亦不对妙光以说经。解者又言。此事故宜不对妙光。问者又言。何以得知耶。解者又言。以现检往其理明矣。又就此四段之中各开为三。第一段中有三者第一言时有菩萨名曰妙光此先出所因人名字也。第二有八百弟子叹妙光之德既有眷属显其是可因之人也。第三是时日月灯明佛从三昧起因妙光菩萨此正明因人也

说大乘经名妙法莲华。此下是第二明说经名字应同。就此自有三阶者。第一言说大乘经一句出经下理。第二名妙法莲华此一句正明经名字同。昔日如来出定即说法华今日如来出定亦应说法华也。第三言教菩萨法佛所护念此出所为之意。意为大乘人即说第一句也

六十小劫。此下是第三明于时经劫数同。就中有三阶者。第一言六十小劫不起于座。此两句正明经劫数同。于时佛说法华经六十小劫也。第二从时会听者此下明昔日劫数实久时众谓近也。第三是时众中以下明时众不生懈倦也

日月灯明佛于六十小劫说此经已。自此下是第四明因人流通经同。就中有三者。第一先明日月灯明佛灭度也。第二从佛灭度后妙光菩萨以下正明因妙光持经流通也。第三从日月灯明佛八子皆师妙光此下名为赞叹妙光之德。显其能流通之意。又就此三段之中各复有三也。明佛灭度中有三者。第一从日月灯明佛说此经已竟当入无余涅槃。此先唱欲入涅槃也。第二从时有菩萨名曰德藏以下为补处大士授记。第三从佛授记已便于中夜入无余涅槃正明佛灭度。第二正明因人通经中有三重者。第一从佛灭度后妙光菩萨持妙法莲华经詺为自行也。第二言满八十小劫此一句妙光流通经时经劫数也。第三言为人显说此一句名为化他行也。第三赞叹妙光德中有三者。第一从日月灯明佛八子皆师妙光此下正叹妙光道高。以八子已成佛故言道高。数少故不言广也。第二八百弟子中下叹妙光德广。寄数多故言德广。不道已成佛故不言高也。第三从弥勒当知妙光菩萨岂异人乎以下会通古今也。所以言举八子八百弟子赞叹妙光道高德广者。自有义前举八子正叹妙光道高者。明文殊应答。昔日妙光即今是文殊故也。后举八百弟子中最劣人叹妙光德广者。明弥勒应问。昔日最劣弟子即今是弥勒故。何以知然。大众疑言弥勒已补处大士正应答。文殊非补处大士故正应问。而今云何弥勒反问文殊。文殊虽然以答弥勒时众既有如此疑。故今者释言。昔日日月灯明佛在俗有八子此八子昔日是文殊弟子。文殊教化八子皆成佛道。八子之中最后成佛者名曰燃灯。燃灯佛即是定光。定光佛即是释迦之师。释迦复是弥勒之师。然则文殊即是释迦祖师。若据弥勒曾祖师也。是故文殊应答弥勒应问也。所以复据八百弟子中最下者叹妙光德广。明弥勒应问文殊者但此八百人皆是文殊往日弟子。但弥勒亲自是八百之中最下劣者。今作补处菩萨弥勒往日复是文殊弟子。弟子问师正得其宜也。问者言。何意不得先举八子赞叹妙光德广明弥勒应问。后举八百弟子赞叹妙光道高明文殊应答耶。解释者言不得如此所以出八百弟子。此八百弟子只是文殊昔日时弟子。但此昔日八百弟子中最懈怠下劣者只是今日弥勒。是故言弥勒应问文殊也。所以举八子不得明弥勒应问者。此八王子自是日月灯明佛在俗之时王子。日月灯明佛既灭度之后此八子皆咨禀妙光。是故文殊应答弥勒也。问者又言。汝云昔日月灯明佛未说法华时先现瑞相。于时时众既见瑞相亦复怀疑。于时应有腾疑作问者。亦应有引古证今答者。汝今既云昔日妙光是弘经之人。何不出昔日有问答者耶。解者言昔日实自应有发问之人答问之人。今日所以不出此人者。意即是如来教化道中所宜。若有出古事于今日有益者即便出之。若于今日无益者便不出之不得一类。且自若使昔日答问人是妙光妙光只是文殊。亦应言今日弥勒只是昔日德藏何以故今日既言补处大士弥勒作问。昔日亦应是补处大士德藏作问。而今日弥勒非是昔德藏。故知不出昔日发问人。若尔文殊何必是昔日答问者也

今见此瑞与本无异自此下竟长行是第四分明结答有二者。第一言今见此瑞与本无异此结已见事同也。上曾见事中有七事同。今唯结第五第六彼此二六十二瑞。余者悉不结也。第二从是故惟忖今日如来当说大乘经名妙法莲华。此结上当见事与曾见事应同也。上当见事中有四事同今唯结第二说经名应同。余者悉不结也。若依后三段此是第三总结上二段。今见此瑞与本无异者先结第二引古证今也。是故惟忖下追结第一仿佛思惟忖度也

从尔时文殊师利而说偈言就第一正答中有二。第一长行第二偈颂。自此下正是第二偈颂也。但上长行中本有四段今略不颂。第一思惟忖度亦略不颂第二略引曾见小复分明略答。唯颂第三广引古证今。亦颂第四分明结答。自此下有四十三行偈亦分为二。初有四十一行偈正颂上第三广引事同。第二从我见灯明佛本光瑞如此下有两行偈颂上长行中第四分明结答。但上广引事同中复有二。一者明已见事与曾见事同。二者明当见事与曾见事应同。今此四十一偈亦分为二。初有十八行半偈颂已见事同。第二从天人所奉尊下有二十二行半偈。颂上当见事应同。但上已见事同中凡有七事同。而分文成三段。今颂之为略。犹唯颂第一与第三不颂第二。今十八行半偈且分为二。初有二行颂第一段。佛未出家时下有十六行半颂上第三段也。上第一段中本有三。今两行偈具足颂。上半行颂第一时节劫数。下半行颂第二通别二号中。唯颂别号略不颂通号也

后一行颂第三二事同。初一句颂七善同次三句颂第二三乘教同。上明七善同中有总有别。今世尊演说法一句颂上总句演说正法。略不颂别明也。度无量众生下三句偈略颂上第二三乘教同。度无量众生此一句得合颂上声闻辟支佛乘也。无数亿菩萨下两句颂上菩萨乘也

佛未出家时此下十六行半颂上长行中第三段有五事同。就中有五。初半偈颂上第一有子同。次半偈颂第二王子出家同。次四行偈颂第三现此间瑞相同。次十行偈颂第四现他方瑞相同。次一行半颂第五疑众同也。今云佛未出家时所生八王子。此半偈颂上第一有子同。上其最后佛未出家时有八王子也。见大圣出家此半偈颂上第二王子出家同。上言悉舍王位亦随出家也。时佛说大乘此下有四行偈。颂上第三现此间瑞相同。本有六段今皆颂之。此四行之中初一行颂说无量义经同也。次一行颂入定同也。次半行颂雨华同也。有人解言下诸天龙鬼神犹属雨华。今一家所习不尔。此花本非诸天所雨直是如来神力雨花。亦是如来神力动地然。地动既非地神所作所雨之花宁关诸天所降耶。今言诸天龙鬼神供养人中尊此半偈超颂第五四众欢喜同也。次半偈追颂第四地动同也。佛放眉间光此半偈颂第六放光同也。此光照东方万八千佛土此下十行偈颂上第四现瑞相于他土同。上言如今所见是诸佛土唯有两句。文句虽少义含六种。今此十行偈宜分为二。第一半行先颂瑞相所由。所由是光明第二九行半正颂瑞相。不颂第六唯颂前五种瑞相也。第一半行颂见六道众生也。次有三行颂见诸佛。次有一行颂闻诸佛说法。次有一行颂见二乘人修行也。次有四行颂见菩萨大乘人修行也。今言示一切众生生死业报处此半行颂见他方六道众生也。又见诸佛土。此下三行偈颂见他土诸佛。就此三行偈中则有四义。初一行先叙见他土严具之相。长行所无此中义出也。第二言及见诸天人。此下一行明见他方四众供养他方佛。此亦是长行所无偈中义出也

第三从又见诸如来自然成佛道有半行偈。正颂上见他方诸佛。第四身色如金山下半行誉佛譬。此亦上长行所无也。如净琉璃中下一偈颂上见他方诸佛说法自有二。上半行开譬下半合譬也。一一诸佛土。此下一行偈颂见他方二乘人修行也。或有诸比丘此下有四偈。颂见他方大乘菩萨修行。比丘是出家菩萨。菩萨要行不过六度。此中即明六度。初一偈先明精进与戒二波罗密。次有一行即明檀忍二种也。行施即是檀波罗密忍辱此则是忍波罗密。次一偈即是禅波罗密。次一偈即是波若波罗密也。尔时四部众见日月灯佛此下一行半偈颂上第五疑众同。上疑众者尔时会中有二十亿菩萨乐欲听法也。天人所奉尊适从三昧起此下有二十二行半偈。颂上第二明曾见事显当见事应同。上当见事同中本有四。一者明因人说经同。二者言说经名同。三者言经劫数同。四者明因人流通经同。今此二十二行半偈亦备颂四种。初两行半颂上第一明因人说经应同。次有一句颂上经名应同。次有一行一句颂上经劫数应同。次有十八行半颂上因人流通经应同也。今先有两行半颂上因人说经同。但上长行中本有三重。今者唯颂第三重正明所因人。上言日月灯明佛从三昧起因妙光菩萨不颂出名字与八百弟子也。说是法华经此一句颂上第二说经名同。上本有三今唯颂第二正出经名名妙法莲华。略不颂第一说大乘经第三教菩萨法也。满六十小劫此下一行一句偈颂上第三经劫数同。上本有三今但二句正颂第一正明经劫数同。余三句偈义出略不颂第二时众实久谓近。亦不颂第三时众无懈倦。佛说是法华令众欢喜已。此下十八行半偈颂上第四因人流通经同。上长行中本有三段。一者先明佛灭度二者正明因人流通经同三者如来叹妙光德。今此十八行半偈委悉颂此三段。初有八行半偈正颂上第一佛灭度。次有一行颂上第二正明因人流通经同。次有九行颂上第三赞妙光德也。上佛灭度中本有三段。一者明佛唱灭度二者为德藏受记三者正入灭度。今具足颂。初从佛说是法华下有五行偈。正颂佛唱灭度。上言日月灯佛说此经已当入无余涅槃。次一行半颂第二为德藏受记。次两行颂第三正明灭度。但就前五行中凡五重义。第一从佛说是法华竟诸法实相义已为汝等说下一行半。此明欲入涅槃之意。只由实相义已彰所以唱欲入涅槃也。第二我今于中夜下半行正颂唱欲入涅槃。第三言汝一心精进下一偈诫敕时众。第四言世尊诸子等闻佛入涅槃下一偈明时众被诫敕故悲哀恋慕也。第五言圣主法之王安慰无量众下一偈。向者时众既悲哀恋慕妨乱行道。是以如来止割悲恋也。是德藏菩萨。此下有一行半偈颂上第二为德藏授记。上言时有菩萨名曰德藏正颂此也。佛此夜灭度下两行颂上第三正明灭度。上言佛授记已便于中夜入无余涅槃。但此两行偈即有二意。前半偈正颂佛灭度。下余有一行半明起塔供养。是长行所无也。是妙光法师此下一偈颂上第二正明因人流通经同。上言佛灭度后妙光菩萨持法华经。但上长行中本有三阶今具颂之。今言是妙光法师奉持佛法藏。此半偈明自行正颂上第一言妙光法师先受持法华。即是自行也。八十小劫中此一句正颂上第二劫数。上言满八十小劫也。广宣法华经此一句颂上第三正流通经化他之行。上言为人演说也是诸八王子。自此下有九偈颂上第三赞叹妙光德。但上长行中本有三阶今亦具颂。三行颂第一。五行颂第二。一行颂第三也。今第一是诸八王子下三偈颂上第一举八子赞叹妙光道高。上言日月灯明佛八子皆师妙光也。是妙光法师时有一弟子此下有五行偈。颂上第二举八百弟子以赞妙光德广。上言八百弟子中有一人号曰求名。语道八百。此中略不道八百者。但八百皆是妙光弟子。此中唯出一懈怠者正明其是弥勒也。彼佛灭度后此一行偈颂上第三会通古今。上长行中先会妙光后会弥勒。今此偈中先会弥勒后会妙光也

我见灯明佛本光瑞如此。此下两行偈偈中之第二。颂长行中第四分明结答。但上长行中本有二。一者结已见事同二者结当见事应同。此两行偈亦颂上二段但此两偈齐取上半颂结已见事同。上长行中言今见此瑞与本无异。取两偈各下半颂上第二当见事应同。就上两半中则有二意。初偈上半偈言我见灯明佛本光瑞如此。此詺为以古同今。后偈上半行言今相如本瑞。此则以今同古义也。是诸佛方便者。所以放光现十二相者。诸佛为正说作前方便也。以是知今佛下两偈各下半行颂上结第二当见事应同。上长行言是故惟忖今日如来当说大乘经名妙法莲华。就此两半行中亦成二意。第一言以是知今佛欲说法华经。此詺理上名应同。应同昔日法华。如来后出定说经果名法华。第二言今佛放光明助发实相义此詺为名下理应同。所以言助发实相义者。如来现此相正欲助众生发大乘机。众生大乘机已发如来出定。仍言此经开方便门示真实相。真实者即是理也

诸人今当知。此下两行偈答问序中本有二。此下是第二詺为开奖物心结答。就此中亦有二者。初偈明好事当来即是显一与显远也。后一偈是第二意明恶事当去。疑之与悔第二卷初当解

    方便品第二

自此以下即是经之正宗。上来序说既竟。次辨正宗凡制品目是出经者意。亦可是传佛圣旨述而不作也。若从理立名者应言实相品不应言方便品。只今日此经正显昔日三乘教是方便。方便但三乘教当乎昔日之时。本是实教不名方便。既说今日一乘实相之理。此则形显昔三乘是方便。是故下经文言此经开方便门示真实相。是则说今日因果真实之相。则显昔日因果非是真实。今此品从所显受名名为方便。方便义者是善巧之能。此如来方便智。所说教詺教为门。实相者则是如来实智所说之理。因理为实相。为未说今日真实之理方便门则有闭义。既说今日实相之理则有开昔日方便门义。此品则有两义。一则明今真实二则显昔是方便。问者言。今日应是闭方便门时。何以知之。今日会三归一皆是真实。云何言有方便门可闭耶。解释者言。此则不然。不然之意就外譬显义故。如有此板门于时板门闭而不开人但知有此板门。竟自不知此门内有好金像。若使此人用手开此门门既开时人皆见真金之像。是则开门之手则有两能。一能开门二能示人真像。今此法华经教如手有二能。一则说昔日三乘教是方便。故下经文言佛以方便力示以三乘教。如手能开门。二则说今日长远之理。故下经文言世尊法久后要当说真实。明同归之理寿命长远此则如手指示金像。门者是通人出入为能。昔日三乘教远通行人。得今日一乘之解则是从门入义。只由有昔日教是方便得显出今日是真实。此则是从门出义。故知此品从所显得名故名方便品也

然此品初正明因叹二智仿佛开宗。故今且略述二智凡有五重解释名义。第一覆明体相第二明名有通别第三明用有兴废第四释会五时经。故辨二智不同。第五释名义。第一二智名义者实智方便智也。然实智有二名一言实智二言智慧。方便智亦有二名一言方便智二言权智。方便者有人解言。方者言是方所之称便者言巧。即时所习不然正言此两字只是一句语也。方便者是善巧之能也。此明圣人智有善巧之用故言方便也。又云方者言正便者言巧也。权者是权假暂时之谓。非是久长之义。但此方便智及权智受名不同。今言方便智者此是当体受名则明圣人智有善巧之能也。权智者此从境得名。何以知之正明前境权。借昔三乘等境须臾转成一乘。是故权假不实然智照此权假之境今举境目智故名为权也。又此方便智及权智义势之中互得相成。若举权境即得显圣有善巧之能。若举善巧之智即显成权假之境也。然只是一智但经论所出遂有两名也。智慧者心用鉴照之称实智者是无有虚假之名也。又智慧与实智亦受名不同。智慧者此即当体受名也。实智者此则从境得名。所言智慧当体得名者。则原此心用根本性是鉴照。且又因果通有。何以知之。故如金刚心时此智慧照境已周。若使金刚转成佛果智慧然化智慧亦是鉴照之义。故知智慧之名根本当体得名也。又言实智从境受名者。前境是实。何以知之。今一乘因果之理是天下真实定境。六心以还虽复退为二乘非为永退。会三归一乘故云实也。如来智慧照此实境今举境目智仍呼为实智。故知实智从境受名也。又此智慧及实智二名亦得相成何以知之。若举实智即得显智慧之名。正由境是真实即得显智慧是鉴照之名也。若举智慧之名又得显实智之名。只由我能鉴照故得显真实之境。故知此二名互得相成也。又此四名皆前后相对。何者前言方便智当体受名。今者智慧亦当体受名也。前言权智从境受名。今此实智亦从境受名前方便智权智二义相成。今此智慧与实智二名亦复相成。虽复四名相对则双显二智也

覆明二智体相第二。若论二智体者果报神虑上有照境之用为体。若欲知体相但用境检取二智体。方便智所照之境凡有三三之境。一者三教二者是三机三者三人。照此三三之境当知。此智是权智体。昔日有三人。人有三人。人有三机。三机感三。是故如来之权智既照此三三之境。即说三教。应三机化三人。是故将此三三之境检取此智。当知照此三三之境。是方便智体也。又实智体亦用前境检也。实智所照之境凡有四种。一者是教一。二者是理一。三者是机一。四者是人一。明如来之智照此四一之境。此即是实智。所言教一理。一者今日唱明因无异趣果无别从。然真实之义其理莫二。然所诠之理既一。能诠之教何容是二也。复言机一者。法华座席时众者有感一果之机一也。人一者明昔日声闻缘觉等人今日皆改心成菩萨。下经文言但化诸菩萨无声闻弟子。亦言一人有一机感一教一理。如来用一教说一理。应一机化一人也。是故如来智慧照此四一之境即是实智体也。问者言。实智所照之境乃有四一则长有理一。说权智所照之境便应有四三。今者何故无有三理只有三三也。解释者言。昔日若有三理者便应是实有三。何谓于一佛乘方便说三。故知昔日教下无有三理。下经文言。但以假名字引导于众生。若言三教下实有三理者便应言以实名字引导众生。何谓言但以假名字乎。问者又言。三教本诠于理若三教下无有三理者。此教竟何所诠。若无所诠三理亦应无有能诠三教。解云。应众生实有三机故昔日实有三教实无三理。但昔三教为诠一理。昔日既未得说一实之理。是故假三乘言教远诠今日一实之理。但昔说一因作三因其实是一因。下经文言汝等所行是菩萨道故知无有三理。但有三种言教前明权智即是开方便门。后明实智即是示真实相也

次明二智名义有通有别。第三方便智即有智慧义。此方便智即实智义实智即有方便智义。何以知之。智慧本以鉴照为义。然方便智若不洞鉴三乘人根性者云何得说法化物。故知方便智举体是鉴照即是智慧之义。此方便智亦即是实智义者。实智本以无虚审谛之义。我此方便智亦即是实有。既是实有方便智即是实义。复言实智即是方便智者然方便者以善巧为义。此实智说一因一果之理言天下深妙幽微难知之理。下经文叹实智言诸佛智慧甚深无量。此一因一果是实智所照之境。此境纵望无底即是甚深横论无际。即是无量然深广难知之理。而实智能照此即是善巧之义。即方便问。若尔者虽有二智即今使浑然无分耶。解释者言。今逐强立名取别于通且明方便与智慧别者。夫正理易知曲义难照故。如巧匠之师运斤斧于一木。若使此木圆直易作运斤斧绳墨得成一器。未觉此人巧术之能若使一木卷曲难作。而此人遂能成妙器于时方觉此人有巧术之能。今方便智亦如是。前境权曲非天下真正道理。而此方便智能曲照物机巧说三教。应彼曲情始见此智善巧之能。此善巧义彰智慧义隐也。又实智义强权智义弱者今一教一理一机一人。此四一之境既真实之理如来智称此实理而照无有曲从之义。此则实智义显善巧义隐。又且实智所照理实教亦是实。然权智所照只有三乘教无有三乘理。是则权智所照唯有一实实智义不彰也。然实智所照有教实又有理实。是故实智义显。此皆互没一所短互出一所长也

次明二智用有兴废。第四权智昔兴今废实智今兴昔废。何以知之。昔日鹿苑说三乘别教于时唯是权智用事实智则废。今日王城之说明一因一果实相之理此则实智兴于今日权智废今日。然则互有废兴此是涉用化物有此兴废也。问者言。如来种觉万德常湛。今言二智有兴有废者非唯种觉不明。亦阙常湛之照。解释者言。万德常湛有如来谈。而今言有兴废者此据涉用化物为论。众生昔日小心狭劣不堪闻实相之唱。于时权智说彼三教应彼三机。实智当乎尔时无有施化之功即义称为废。今日时众即堪闻实相之理。实智说此一理称彼一机。然权智于今日无施化之功义称为废也。若就如来三达之智即天眼照未来有大乘机。此即是实智之用。又宿命智照过去世有三乘之机此即是权智之用。若尔有何兴废也。又就如来分身十方说法度人。若便王城实智说法化物亦可十方权智度人。亦可此间权智度人十方实智说法。是纵论三达横语十方。权实二智即无兴废。今据一应始终为义有兴废也

次明众经所明二智不同。第五众经不同凡有五种。一者十二年前有相教所明二智。若照生老病死分段无常境者名为权智。若照刹那无常名为实智也。二者大品经所明二智。若照因缘假有即是权智也。照此假有即空是实智也。三者即是维摩经所明二智者。若知病识药静照物机此则是实智。若便能应病与药令得服行此则是方便智。四者是涅槃经所明二智者。若照金刚已还生死无常苦空之法此则是方便智也。若照涅槃常乐我净真实之法此即是实智也。五者就此法华所明二智。若照三三之境即方便。若照四一之境即实智也。是则十二年前有相二智据亲疏为论。大品经所明二智横照二谛以为二智。涅槃中二智此据纵为论也。维摩明智此据本末为二智。知病识药是本应病与药是末。今法华经所明二智此据始终为义。始则权智说三终则实智说一也

经有三段第一明通别两序已竟。从此以下竟分别功德品中弥勒说偈颂佛长行以来凡有十四品半。是第二正说段。但正说中本有二段。一者明因二者辩果。从此下竟安乐行品有十二品经。是第一詺为开三显一正明因义。第二从踊出品竟弥勒说偈颂佛长行以来有两品半经名开近显远以明果义。前已解言因果两段各有四种且置果中四种。今更明因中四种者。第一从此品初说一长行与偈来詺为略说开三显一动执生疑。第二尔时大众中有诸声闻漏尽阿罗汉下去詺为时众怀疑致请。然则疑心既生请情又至。是故第三如来从汝已殷勤三请下讫授学无学人记品有七品半经正广说开三显一断疑生信。然则大众疑心已遣于三一悟解已生。便应以此一乘之义流传未闻。是故第四从法师品见宝塔品持品安乐行品此四品经明别流通因义。今又就此四段之中第一第二各有二重第三第四各有三别。第一就动执生疑中有二者。第一结经家叙起定说法之相。第二正叹权实二智开三显一。后三段至时当道也。诸佛如来常在三昧悉见诸佛国不以二相。今所以言从三昧安祥而起者。为物轨则。但凡夫无智吐一言陈一声之时。率尔轻心散乱而说。今者如来将欲说法先示入定观理者为令凡夫有所言说先静心虑然后兴意曲辩为此义故言从定而起也

就第二正叹权实二智中自有二。第一诸佛智慧甚深无量以下讫十七行半偈以来詺为因叹二智仿佛开宗。第二舍利弗当知诸佛语无异以下有三行半偈詺为分别略说开三显一之义。所以言因叹二智仿佛开宗者。今日之说反常之教昔言三乘别行各有所趣。言声闻乘异缘觉乘异菩萨乘异言三家不得互通而。今明三乘之行同是一因等是菩萨皆同得佛果。若使顿明无三之教一实之理。执三之徒容生诽谤是故不得顿明须渐渐稍说生动执之端。是故有仿佛开宗直漫言如来有方便智难解之说复有真实智甚深之说。时众既闻有实智甚深方便智难。解相与生疑言。佛昔日说道三乘之教皆是真实而今言犹有实有方便。时众于时执心渐动是故第二三行半偈分明略说言世尊法久后要当说真实。复言佛以方便力示以三乘教众生处处着引之令得出。既分明略说三一之义。时众疑真实之意生执三之情动为此义故。故言仿佛开宗。又就两段之中各开为二。仿佛开宗中有二者。即是长行与偈颂为二也。最后三行半偈分明略说中有二者第一一行半寄诸佛以显一。第二两行偈就释迦以开三。且置偈只就长行中自有二段。第一从品初竟成就一切未曾有法以来詺为寄言以叹二智。第二从舍利弗如来能种种分别巧说诸法下竟长行詺为寄绝言叹二智。非是绝四句故名为绝言。下不及上故名绝言。又名止言叹。又就此二段之中各有二。寄言叹二智有二者。第一将欲叹释迦二智先寄言叹诸佛二智。第二正寄言叹释迦二智。所以尔者为欲况释故。诸佛亦有实智方便智先三后一。何况释迦亦有实智方便智先三后一。谈方便智即说三乘教。语实智即是说一乘教。此两段中各有三文。今就叹诸佛二智有三重。一者正双叹二智二者总释二智三者双结也。所以明因之中对声闻。辩果之内对大士。不告声闻也。所以偏对二人者皆逐缘作论。声闻之中舍利弗聪明第一。菩萨之中弥勒是补处大士。故偏对二人显诸下流也

就正双叹二智中先叹实智后叹方便智也。只就叹实智中自有二句。诸佛智慧一句将欲叹。故先举实智。甚深无量此一句是第二正叹实智。所以言甚深无量者。纵则论甚深横则言无量。三世诸佛皆有此实智故言甚深。横论十方诸佛实智故言无量。望之杳然故言甚深。际不可知故言无量。此是正叹实智也。其智慧门难解难入此是叹方便智。就中有三。其智慧门一句先举权智体。难解难入一句第二正叹也。一切声闻以下第三出不知人也。方便智是实智家门。由方便智说三乘教故实智得通。何以知之。先说三教然后一教得宜故。如即时立门通佛出入仍呼为佛门。无异由方便智故实智得通。是故詺方便智持作实智家门也。今言其者只其实智则言其家门。谁是则言只方便智是。而复言难解难入者第二正叹方便智。言难解难入二乘人不能测此方便智故言难解难入。所以不詺作不可解不可入者。若言不可解不可入者然佛即是能解能入非是不可解。然此理深妙难可得解唯佛能解入。阿谁不能解不能入者故第三则出其人。一切声闻辟支佛只此二乘人等是不能解不能入者也

所以者何。此下是第二总释诸佛二智。此詺举昔诸佛行释二智所以。诸佛实智甚深无量者何。复言其智慧门难解难入者何。以佛曾亲近百千万亿尽行昔日诸佛之行故。得此二智深妙也。只就此释中自有三第一佛曾亲近以下明行本。第二尽行诸佛以下正明行行。第三名称普闻一句结显。第三双结诸佛二智中有二。第一成就甚深未曾有法此则结上实智言诸佛智慧甚深无量也。第二随宜所说意趣难解此结上方便智言其智慧门难解难入也。所以言随宜者此方便智能随物所宜随。声闻人所宜说苦集灭道。亦随缘觉人所宜说十二因缘。亦随菩萨人所宜说六波罗密故言随宜也

舍利弗吾从成佛以来。此下是寄言叹二智之中第二詺为寄言叹释迦权实二智。就中亦有三重。一者单叹释迦方便智。二者单叹实智。三者单结实智也。就第一有二。初正叹方便智第二所以者何以下释也。就正叹中有三第一舍利弗吾从成佛以来明权智时节。第二种种因缘以下正叹权智。第三引导众生以下结显。今者第二正叹权智者即是权智所作。种种因缘者此名释迦权智所说之法。声闻观四谛为因缘。缘觉观十二因缘为因缘。菩萨之人观六度为因缘。故言种种因缘。复言种种譬喻者譬三乘行因时。声闻如兔缘觉如马菩萨如象。譬三乘得果时声闻以譬羊车缘觉以譬鹿车菩萨以譬牛车。故言种种譬喻也。广演言教无数方便者不但说法而已。待处待时种种不同故言广演言教无数方便也

所以者何以下是第二单叹释迦方便智。言所以释迦有此方便智能作是种种因缘譬喻说法者何。正由如来方便知见波罗密皆已具足故。外国言波罗密此言到彼岸。义如来智慧洞鉴物机到彼岸。故有此巧便之智也

舍利弗如来知见广大深远。此是第二单叹释迦实智自有二。第一广大深远作二章门广大一也深远二也。无所不包目之为广超出小圣目之为大。底不可尽目之为深行因久到目之为远。第二言无量无碍此下即释上二章门。先释广大章门有六句。后释深远章门有一句也。今者第一无量无碍昔日言如来只有四无碍今者无量无碍。昔日言如来只有十力今者有无量力。昔日言如来只有四无畏今者有无量无畏。昔日言如来只有八禅定今者有无量禅定。昔日言如来只有八解脱今者言如来有无量解脱。昔日言如来只有三三昧今者言如来有无量三昧。前一无量目总冠六种法上。若准前之时亦应有所以者何言。所以如来有实智广大深远者。何有无量无碍乃至三三昧等。但此六种法释上实智中广大句也。深入无际此一句释上实智中深远句也

成就一切未曾有法此是第三单结释迦实智。正结上如来知见广大深远句也。料简诸佛与释迦二智交互凡有四种不同。何者上诸佛中双叹二智释迦中只叹二智一不同。上诸佛先叹实智后叹方便智释迦中先叹方便后叹实智二不同也。上诸佛举往因释二智释迦中举果地诸功德以释二智三不同。上诸佛双结二智释迦中单结实智四不同。解释者言非是都无所以。所以诸佛双叹二智释迦不双叹者。欲显体一故。双叹诸佛二智将明体虽是一功用异故只叹释迦二智。此是互举一边也。复言诸佛先叹实智后叹方便智。释迦中先叹方便后叹实智者。诸佛先叹实智后叹方便智者。此明本末次第何以故只以有本故有末。释迦先叹方便后叹实智者。此明教化次第所以有本末互有前后者。此则彼此各举一边双明一理。又言诸佛举往因释二智释迦举果头诸功德者。诸佛举往因释二智者。此明胜因必感圆果。释迦举果头诸功德。释二智者。此明圆果必酬胜因此亦互举一边也。复言诸佛双结二智释迦单结实智者。欲明兴废义故谈诸佛二智兴时。故双结二智。今日释迦正废权显实之时即为废权义故。故不结权智为显实义故。故单结实智也。又解上诸佛双结二智。为欲明此二智只是一体照三三之境。今言释迦单结实智者。此逐功用有胜负且欲明圣人怀抱之内。二智之解竟有何胜负。但是逐事故尔。舍利弗如来能种种分别。此下是第二寄绝言叹二智。问言虽复寄言叹二智明此二智非是近情所测拙言可及。且止此唱故下文言唯有诸佛乃能知之。非小圣所及。寄绝言中亦得生大众疑动执之端。时众言如来何故从定出自叹二智甚深。仍罢有何所以。是故言叹方便智为动执之端。叹实智为生疑之端。问者言汝既言绝言何故由道叹耶。解释者言若默住不道绝言时。时众那得知此二智应绝言耶。就此绝言叹中有三种。第一先出所绝之法即是二智。第二正明绝言叹。第三从所以者何释所以绝言之意今者第一先出权智后出实智。从舍利弗如来能种种分别下四句。于三三境中偏就故明权智所作。明如来能说声闻教因缘缘觉教因缘菩萨教因缘。故言种种分别也。巧说诸法者此明如来方便智巧说一乘法持作三乘诸法。故下经文言于一佛乘分别说三。故言巧说也。只说此三乘教称昔日物机。故言辞柔软悦可众心也

舍利弗取要言之此下竟佛悉成就。此于四一境中偏就理一境出实智。若取要言者而论之实智于今日是要。何以知之。今日是显实废权之时也

止舍利弗不须复说。此一句是第二正明绝言叹也。所以者何。自此下竟长行是第三释所以绝言之意。只由说二智人高境深故绝言也。故此第三释绝言中自有二。一者举人高即是得智之人。二者所缘境深。今言所以者何竟乃能究尽。詺为举人高释绝言所以。止舍利弗不须复说权实二智者。何唯有诸佛能知权实二智那得不止也。就举人高中此有二佛所成就。第一希有难解之法先据二智。唯佛与佛以下正明人高。诸法实相此下是释绝言。中第二举境深所以绝言。非唯人高故二智微妙不可说。亦二智所照境深故绝言

又就此二智所照境中有三。第一双开两章门第二双释两章门第三者双结两章门。双开两章门者诸法此两字即是方便智所照境章门也。实相此两字即是实智所照章门。但权智所照境凡有三三之境今唯取照三教也。实智所照境有四一之境今唯取照一理。解释者言。权智所照三三境中要者是三教进行之徒要须藉言教方得入道。故言诸法。三乘教不一故言诸法也。实相者四一之中是理一。等是四一理一最要是故的照也。但的照三教即是开方便门义也。的照理一即示真实相义也。何以知之。下释中举因果释之。当知因果只是理一也

所谓诸法。此下是第二双释上两章门凡有九句。初有五句释上诸法章门。次如是因如是缘下有四句释上实相章门。如是相者表异为义。览观三乘教皆有异相。声闻乘教异缘觉乘教异菩萨乘教异。故言如是相也。如是性。性是不改为义也。但昔日声闻教不可改作缘觉教缘觉教不可改作菩萨教。故言如是性。如是体。体体别为义。声闻行自以四谛声教为体即是遭苦生厌老病死义。缘觉之人即是十二因缘教为体。菩萨即以六度经教为体故言如是体。如是力。声闻教作缘断正使力。缘觉教作缘侵断习气之力。菩萨教作缘断习气尽成佛之力。故言如是力也。如是作者论主言起作是行相。故知作只是行义也。明此三乘教有行义。声闻之行有所为作乃至菩萨行行有所为作。此五句都是释上诸法章门詺为权智境也。如是因此下有四句释上实相章门詺为实智所照之境。所以知是实智所照之境者。下偈颂言如是大果报故也。如是因者以感果为义。如是缘。缘者由义万善能感果即因义。此果由万善得即是缘义。如是果。果以对因为义报以酬答为义。只是一果宜对因詺为果。此果有酬因力义即成报义。此四句正是释上实相章门也

如是本末此下是第三双结两章门。今言如是本末此结权智境章门。本则举最初如是相末则举最后如是作也。究竟等者一因一果。究竟等者此结实智境章门。且更解因缘之义者有人解言。因亲缘疏。所以言因亲者此果是本无而今有是亲义。何以故能令本无今有故。复詺作疏者只同此果二头三手者。不可生。道理中有可生义。汝若言道理中不可生而因力能令生者。二头三手不可生。因力何故不令其生。若因力不能令不可生而得生者。乃可詺因为亲。果既有可生义因于果成疏义。此果本无今有此因于果是亲义。果有可生之理此因于果则成缘义。今光宅法师解不作亲疏之义。正言言因者对果为义缘者只是由藉为义。若据万行望果有对果之义詺之为因。若据果望万行此果则由万行而得于果即是缘义

法华义疏卷第二法华义记卷第三

        光宅寺释法云撰

尔时世尊而说偈言。因叹二智仿佛开宗中有二。长行与偈颂。此下是第二正明偈颂。但且长行中本二。一者寄言以叹二智二者明寄绝言叹二智。今者十七行半偈亦分为二。第一有四行偈正颂上寄言叹二智。第二从如是大果报下有十三行半偈颂寄绝言叹二智。但上长行寄言叹二智中本有二。一者将欲叹释迦二智故先叹诸佛二智。二者正叹释迦二智。此两双中各有三重。第一正叹二智第二释第三结也。今者四行偈颂之为体亦分为二。初两行偈并叠颂诸佛释迦正叹二智。后两行复并叠颂诸佛释迦释二智结二智两重也。又就两偈叠颂诸佛释迦正叹二智中。前偈颂诸佛二智后偈颂释迦二智也。但上叹诸佛二智中先叹实智后叹权智。然先叹实智中有二句。初举智体言诸佛智慧第二句正叹言甚深无量。后叹权智有三。先举智体言其智慧门。第二正叹言难解难入。第三出不知众言一切声闻辟支佛所不能知也。今者世雄不可量一句即得并颂实智权智。各二句。诸佛智慧甚深无量其智慧门难解难入等也。诸佛应同十方此则世义。降四魔伏外道是雄义。权实二智非下人所测故言不可量也。诸天及世人一切众生类无能知佛者下三句颂上权智。下第三句出不知众。上言一切声闻辟支佛所不能知也。且今用此一偈颂前长行凡有四种不同。上长行中别叹实智与方便智。今此偈中合颂权实二智一不同。上当体叹权实二智今此偈中举人叹二智二不同。上明不知人唯系在权智下今此偈中颂出不知人双系二智下三不同。上长行中出不知人唯出声闻缘觉二人。今此偈中广出人天声闻缘觉远及菩萨并出五乘人。都是不知众。四不同。何如此不同耶。解释者言此义亦微有所以有。上长行中所以二智别叹者则明义用异。但此二智只是圣人神解涉用为义。从机曲说未若权智。但此权智应有所出。是故先别叹实智是权家之本。后叹权智是智是本家之末。是故权实互叹此明用有胜负。偈中合颂者。此明二智虽有权实二名照然则体一更无异也。是故维摩经言。十方世界有若干也。其无碍慧无若干也。复言上当体叹二智者。明此经本意故。故当体叹偈中明二智所成人。故举人总叹二智也。复言上出不知人唯系权智下。今此偈中双系二智下者。上宜鄙斥二人智慧狭劣。虽禀昔日权智之教不能究了。为是义故上出不知人偏系权智下。而今偈中双系二智下者。明此二乘非直不解权智之用。实智冥然莫测。是故双系二智下。复言上长行唯出二乘至偈颂中言一切众生类无能知佛者广出五乘人者。此为释物疑情。但今日之教本为斥二乘封执之情。是故长行偏对二乘。但于时时众谓言二智止。是二乘不解。自二乘之外应有解者。是故偈中言非唯二乘不解此权实之理。人天及菩萨亦复不解。如此颂类举可知也

佛力无所畏。此一偈正颂正叹释迦二智。上正叹释迦二智中先叹权智后叹实智。今此一行偈上半行先颂叹释迦实智下半行追颂权智。但上叹释迦实智中先正叹实智后即举力无畏等。今此半偈正得略颂上诸功德句不颂正叹句也。及佛诸余法无能测量者。此半行倒颂上叹释迦权智句。上叹释迦权智中正叹有三重。初吾从成佛以来明权智时节。以种种因缘下正叹。引导众生下显也。今此半偈只颂第二正叹句不颂第一第二句也。今者所以言及佛诸余法者权智在后故言余也。此权智为三根人说之不一故称诸也。又用此一偈复颂长行有三不同。何者长行中先叹释迦权智后叹实智。今此偈中先颂实智后颂权智一不同。上长行中言如来知见广大深远正叹实智后举诸功德同释叹也。今偈中唯颂举诸功德释叹实智句略不颂正叹实智句二不同。上长行中叹释迦二智不出不知众。今偈中言无能测量者三不同。解释者言上长行所以先叹权智后叹实智者。此明释迦出世之意先权后实。偈中所以先颂实智后颂权智者。此明今日实用时。此皆前后互举。迭相映发其义自彰。复言长行中有正叹实智有释。偈中唯颂释句者此明有体一用异之义。上长行语其用异之义。何以知之。智慧鉴照为义。欲明实智所照之境有四一之义。有教一理一机一人一如来智照此四境。故称实智。力无畏等诸功德不詺鉴照。故知长行据其用偈中唯颂诸功德者。此明功德与智慧只是一体。离此力无畏解脱三昧等更无别有智慧。亦离此智慧无别有功德。故知体一据用则有功德智慧之异。置用谈体智慧功德只是一体。此皆前后互举两义双明。复言长行叹释迦二智不出不知人。今偈中言无能测量者此出不知人。亦前后互举若偈中出不知人长行亦应出。长行既不出偈中亦应无。而一有一无此互相映明义也

本从无数佛具足行诸道。此下两行偈叠颂诸佛与释迦释之与结两重。初偈颂诸佛释结二智。后偈颂释迦释结二智。就初偈中本从无数佛具足行诸道。此半偈颂诸佛第二释二智言。所以者何佛曾亲觐百千万亿无数诸佛尽行诸佛无量道法也。甚深微妙法难见难可了。此半偈颂上长行中第三结诸佛二智。此半偈即成两意。甚深微妙法此一句颂上结实智言成就甚深未曾有法也。难见难可了此一句颂上结权智言随宜所说意趣难解也。于无量亿劫此一偈叠颂释迦释之与结两重。此一行则成二意。于无量亿劫行此诸道已。此半行颂释迦释二智。但长行略不出往用。偈中既有映前即成颂释义也。道场得成果。此下半偈正颂上释迦单结实智。上结言成就一切未曾有法。上但道实智此中出得实智之会。只是如来坐道树下成佛。世尊大觉朗然之时得此实智。故言道场得成果我已悉知见也

第二如是大果报。此下十三行半偈颂上第二寄绝言叹二智。但上绝言叹中有三。一者先出所以绝言之法二者正明绝言叹三者释绝言之意。今此十三行半亦有三意。从下倒颂。初如是大果报下一偈先倒颂上长行中第三释绝言之意。第二有十二行即颂上第二正绝言叹。第三有一行半倒颂上第一出所以绝言之法也。但上第三释绝言中有二。一者先叹二智之人高不可说。二者出权实二智境深故不可说。今者亦倒颂。如是大果报半行偈先颂境深也。我及十方佛乃能知是事半行追颂人高也。但上境深中本有三。一者双开两章门二者双释三者双结也。今者不颂第一第三唯颂中间第二双释两章门。上双释中初有五句。释权智境章门。后四句释实智境章门。今者亦倒颂。如是大果报一句先颂释实智境。只得颂果与报略不颂因与缘。今者举果验知有因缘所以言大。此亦释物疑情三乘因亦是因三乘果亦是果。为此义故因大字标异。明此是大乘因果非是小乘因果也。种种性相义此一句追颂权智境。权智境中本有五句。今唯颂性相余三句略而不颂。此句亦倒颂。上言如是相如是性今者先颂性后颂相也。所以言种种者复释物疑情。大乘亦是性亦是相为此义故用种种之名标言。此非大乘性相三乘性相不一故言种种也。我及十方佛乃能知是事。此半行追颂释绝言中第一明人高。上言唯佛与佛乃能究尽也

是法不可示此下有十一行追颂上第二正绝言。上言止舍利弗不须复说今就此十一行中但半行正颂上绝言叹。第二余十行半义出显所以绝言之意。正明声闻不知菩萨不知故也。今此半行有二意是法不可示者正颂上止舍利弗也。言辞相寂灭者颂上不须复说句也。诸余众生类无有能得解以下有十行半是第二义出。今就此十行半中自有三段。第一今此半行总明不知众也。第二半行除有知之人。第三九行半别出不知众也。第二除有知人者正言除诸菩萨众中有信力坚固者。自能得知。然非见知犹是信知。此则引声闻等作大乘。令改狭劣心立菩萨大志也。诸佛弟子众。此下有九行半是第三别出不知之人。凡有三种类人不知此二智。初有四行先明声闻不知也。第二有两偈明缘觉人不知。从辟支佛利智下是也。第三有三行半明菩萨不知。从新发意菩萨下是也。就第一明声闻不知中复有三文。初一行半正明声闻不知。次一行假设明不知。次一行半释疑。疑言纵令皆如舍利弗是一种神解无益于事。今解言假令如余弟子各有所解亦不能知也。就第三明菩萨不知中有二。初两行半明凡夫菩萨不知。次一行明初地以上至六地菩萨不知。此是教中为论故也。又告舍利弗无漏不思议。此中有一行半即追颂绝言中第一出所以绝言之法。上言如来能种种分别。先出权智今此中略不颂也。唯颂上出实智言取要言之无量无边未曾有法佛悉成就句也。但此一行半中初一行正颂下半行引诸佛证成也。此是于善舍寺解。舍利弗当知诸佛语无异。此下三行半偈是第二分明略说开三显一。成物动执生疑之惰。就此三行半中亦有二段。第一有一行半偈就诸佛以显一。第二余有两行偈据释迦以开三也。此二阶各自有三重。就诸佛显一中有三重者。第一言舍利弗当知诸佛语无异。此半偈先会诸佛道同。于佛所说法当生大信力。此半行是第二劝奖诫敕令信也。世尊法久后要当说真实。此半行是第三正就诸佛显一。一理是真实也。就释迦开三中有三重者。第一告诸声闻众及求缘觉乘。此一偈出释迦开三之所为为二乘之人。二乘之人见执重者先斥对此二乘人也。第二佛以方便力示以三乘教。此半行正就释迦开三也。第三众生处处着引之令得出。此半偈释释迦施三之意。只由众生逢境执着处处生染。是故如来设权而诱化也。略说开三显一动执生疑竟也

尔时大众中有诸声闻众自此下竟殷勤三请以来明因中有四段。此下是第二众情怀疑致请段。就此中自有二者。第一从尔时大众中下竟而今不知是义所趣。以还先明经家序大众有疑也。第二从尔时舍利弗知四众心疑自亦未了尽三请以还詺为舍利弗正腾疑致请。佛既道以方便力示以三乘教。昔日不言三乘是方便。而今忽唱三乘是方便。此则与昔日相违。是故舍利弗腾疑致请取决于大圣。又就经家序大众有疑中自有二段。第一从尔时大众中有诸声闻众竟优婆塞优婆夷以还詺为经家序引疑众生也。第二从各作是念下竟而今不知是义所趣正出所疑。所疑者是二智。又就此二段之中各有开为二。经家序引疑众中有二者。第一言千二百人此无学人有疑也。第二言及发声闻辟支佛心竟优婆夷此出学人有疑也。第二出所疑中有二者。第一从各作是念以下竟声闻辟支佛所不能及以来。先出疑。佛上何故称叹二智。此疑从第一叹二智仿佛开宗中生。第二从佛说一解脱义下竟而今不知是义所趣。明大众自疑所得解脱为是究竟。为未究竟此疑从第二分明开三显一段中生也

又就第一疑佛叹二智中有二。第一各作是念今者世尊何故殷勤称叹方便。此疑上释迦叹权智。上释迦叹权智。上言舍利弗吾从成佛以来种种因缘种种譬喻广演言教。亦应疑释迦上叹实智。但文略不出。第二而作是言佛所得法甚深微妙以下疑上叹诸佛二智。此句疑叹诸佛实智。上言告舍利弗诸佛智慧甚深无量也。有所言说意趣难知下此疑上叹诸佛方便智。上言其智慧门难解难入一切声闻所不能知也。今以此句相应也

佛说一解脱义。此下是第二正自疑所得为是究竟。为非究竟此疑者。只由上第二分明开三显一中生。上言佛以方便力示以三乘教就中有二。第一佛说一解脱义下竟到于涅槃先出所疑。第二而今不知是义所趣正明起疑也。今先解三乘人两种果。一者有为果二者无为果。有为果者即是尽智无生智照三界因。尽是尽智不受后有。是无生智。二是无为果。三乘人三界因尽是有余涅槃。三界果尽是无余涅槃。但二种无为只是一时因尽即是果尽时果尽时为因尽时。虽然逐义有便所可作前后。得言因尽故果尽不得言果尽故因尽问者言若言因尽时而果尽者。罗汉何治道断三界因尽之时报身即应亡。解释者言此报身是因余势任运而尽故如用杖转轮。假说此杖即灭而轮犹转。罗汉三界因尽于是时报身余势如轮也。问者言三家解脱一。等不应有三车受别也解释者言。三家解脱所以一等者同取三界因果尽无为。无为既不殊。是故皆詺作一解脱。所以有三车之喻。运因胜负者此据力用有短有长。声闻断三界正使尽取譬羊车。缘觉侵少许习气取譬鹿车菩萨断习都尽取譬牛车。问者又言断惑既有优劣无为亦应不等也。解释者又言引昔作义不言习气受生虽断习气不就习尽处制果。然三家同取三界因果尽处制尽无生智。若语其解脱三家一等。论其功用有广狭之殊长短之别。取譬三车故言佛说一解脱义。解脱是有余无余涅槃即是灭谛也。义者即是道谛举果明因。我昔依佛教修行道谛证得灭谛果。故言佛说一解脱义我等亦得此义到于涅槃。从而今不知是义所趣者第二正明起疑。而今不知我昔日所行道谛为当只趣此解脱果为更有所趣。上来皆是经家述其疑意

尔时舍利弗知四众心疑自亦未了。自此以下讫三请已还是第二明舍利弗腾疑致请。就此请中自有二段。第一从舍利弗知四众心疑自亦未了。此明经家序舍利弗腾疑欲请之意。第二从而白佛言下竟三请以还詺为正请。又就经家序中有二。第一言舍利弗知四众心疑。此是经家序舍利弗欲令腾大众疑意也。第二言自亦未了此明经家叙舍利弗自有疑心也。第二正请中有五重。舍利弗有三请如来有二止。宾主相间即是五重。舍利弗三请者第一举有疑请。第二有利根必信故请。第三有解故请也。就第一疑请中有二。一者长行二者偈颂。又就长行中自有三重。第一疑上叹诸佛二智。第二叠疑众请说。第三疑上叹释迦二智也。今者第一疑诸佛二智即而白佛言。何因何缘称叹诸佛第一方便。此则疑上叹诸佛权智。从甚深微妙难解之法此疑上叹诸佛实智甚深也。从我自昔来未曾从佛闻如是说今者四众咸皆有疑唯愿世尊敷演斯事。此即是第二叠疑众请说也。从世尊何故殷勤称叹甚深微妙难解之法。是第三疑释迦上所叹实智。亦应有疑方便智。但经文略不出。下偈中有故知长行应有。但上经家叙中疑方便智不道实智。互举明义也

尔时舍利弗而说偈言第一举设请段中本有二。长行与偈此下是第二偈颂凡有十一行偈亦分为二。初有六行半偈正颂上长行。第二从于诸声闻众佛说我第一有四行半偈。更直说自疑所得。不颂上长行。有人解言用此四行半偈颂上佛说一解脱义我等亦得此法到于涅槃。文句乃相类意谓不尔。何以知之。上长行中即是经家叙。于时时众有此疑。云何舍利弗颂经家意耶。故知但是直说偈。但六行半颂长行中本有三。一者疑诸佛二智二者叠疑众请说三者疑释迦实智。今者六行半中两行半先颂第三段次一行追颂第一次三行颂第二段也。初有两行半偈先颂第三段释迦二智。今慧日大圣尊久乃说是法。此下一行半偈正颂疑释迦实智也。从道场所得法此一偈义颂疑上权智。疑言何故称叹此智而不说也。无问而自说。此一偈是第二倒颂上第一言何故殷勤称叹诸佛第一方便甚深微妙难解之法。但长行不出诸佛往因。今此一偈上半长出往因。下半偈正颂也。无漏诸罗汉及求涅槃者。此下三行偈是第三追颂上第二叠疑众请说。上言我自昔来未曾从佛闻如是法。今者四众咸皆有疑。故知此三行正颂上。有二初偈举声闻请说。第二其求缘觉者下两偈举缘觉人请说也。于诸声闻众佛说我第一。此下四行半偈是偈中之第二詺为直说偈自疑所得。此四行半自有二。第一于诸声闻众佛说我第一此下一行半偈正明舍利弗自疑所得。为定是因为定是果也。第二从佛口所生子下三行偈正结请说也。尔时佛告舍利弗止止不须复说。此下是第二段。第一止止意言若便广说此二智者。时众相与生惊疑之心为是义故不须复说也

舍利弗重白佛言唯愿说之唯愿说之。此下是第三段。第二有利根必信故请说。此下以三段例皆有二长行与偈为二也。今请意言此会中皆是利根堪闻佛说。云何言惊疑耶

佛复止舍利弗若说是事此下是第四段。第二止止意言我若说权实二智者。时众非直生惊疑之心。亦更生诽谤随坠恶道。云何应说耶

尔时舍利弗重白佛言唯愿说之唯愿说之。此下是第五段第三请有解故请

尔时世尊告舍利弗汝已殷勤三请岂得不说。自此下竟授学无学人记品有七品半经。明因中本经四段。此下是第三广说开三显一断疑生信。上请中有二种疑。一疑如来所以叹二智。二自疑所得之法。今者如来只答第二疑。第二疑自去不须别答也。又此第三即广上品初第一略开三显一。动执生疑段。前又解言。第一第二各开为二。第三第四各开为三。今此叹第三疑中有三重者。即化三根人为三段。第一从汝已殷勤三请以下入第二卷中言我所有福业今世若过世及见佛功德尽回向佛道以还。此詺为法说开三显一。化上根人舍利弗等也。第二从尔时舍利弗白佛言世尊我今无复疑悔亲于佛前得受三菩提记尽受记品以还四品经。詺为譬说开三显一。化中根人迦叶须菩提等四大弟子也。第三从化城品竟授学无学人记品以还三品经。詺为宿世因缘说开三显一同归之理。化下根人富楼那等也。是则上根人闻法说三一之义同归之理。便解中根人再闻三一之义。可悟同归之理。下根人三过闻说方解同归无三差别。但法说中亦有譬说义譬如优昙华也。亦有宿世因缘说义即言我昔曾于二百亿佛所常教化汝也。虽有譬说根本大意为叹法希有故来不可示詺。虽有宿世因缘说此乃是述成上根人得悟。说此往古因缘根本大意非正是因缘也。第二譬说中亦有法说义亦有宿世因缘义。故下言是诸所说教化菩萨。故此则是法说义但文句少不足可以发悟中根之之人。从结父子因缘之中昔日波若座席已言示其金银等。此则是宿世因缘说义但此意非。是正譬中有时众已于正譬得悟。如穷子领解中方有此语非是正宿世因缘说中。宿世因缘说中亦有法说义。即化城品初明先佛之时神通感动之相十方诸梵请转法轮。此则是法说也。又言譬如五百由旬此是譬说。虽有此唱原其根本只为明宿世因缘之义。何以得知。又四大弟子授记品末言我及汝等宿世因缘吾今当说汝等善听。即复为下根人说往古之时已曾大乘化汝。下又言我在十六数曾互为汝说。以此本因缘今说法华经。大意闻此宿世因缘说方得解故宿世因缘说也。所以有三根人差别解有前后者。置教论理者。何容罗汉断三界正使尽得三明六通之人。一向不知同归之理无三之别。且自涅槃经言若人不知一体常住二归者尚不得声闻缘觉菩萨。何况当得无上菩提。若不知佛是常住则四信不成五根不立。且自胜鬘经言三乘初业不愚于法。又言声闻缘觉自知住有余地必当得无上菩提。就理为论何容三乘圣人执三乘决定言别异不解同归耶。若尔所以有声闻缘觉者此人自有知有佛果可求。只自心志弱未能舍头目髓脑发旷济之心。且作声闻缘觉自调自度。如此类例皆是实有。而会中舍利弗是上根富楼那等是下根者。若谈其实行皆行内秘菩萨行外现是声闻。所以有此三种信解悟者皆应同状外凡浅识之徒。执昔日三乘别教或同归之义。是故如来作此三种。初始明法说竟外凡夫中有利根得解。舍利弗示同领解。譬说既竟外凡夫中有中根者得解须菩提等仍示同领解。宿世因缘竟外凡夫中有下根者得悟富楼那等示同领解。若置理而论教者具得罗汉亦有此执。又理教合论作三根差别者但外凡中有两种人。自有一种人易可回转如大品所明轻毛之位。自有一种人实欲进行者。今只就此实欲进行者根性利钝遂有三种。既有三种皆因宿习浓淡。以理惑教有时以教惑理。故言踟蹰理教之间故受悟有前后。利根者执理情多疑教情少。钝根者执教情多疑理情少。中根者迷教惑理正等也。执理情多疑教少者言无生之理是一等观无生智应同。此人执理既是一。如来何故说有三乘别趣。言有三果之别此是疑教也。钝根者执教情多疑理少者言佛教既说有三因三果之异。三乘所观无生之理何必是同。此是执教多疑理少。中根者有时执理惑教言理一教那得言异。有时执教疑理言佛教既有三理何必同。此则教理等执而疑也。夫得道成圣必由见理。是故利根之执理多者则与理相符。是故一闻法说便悟一理无三之别。执教情多疑理少者则与理不相扶。是故三过闻说方悟一乘之理无三之别。理教等执者据在中间再闻得解。但于此理教上生疑者有学人与无学人通有。又有执教疑果者。亦有三种。利根者执果情多疑教情少。钝根执教情多疑果心少。中根之人果教等执也。果者只是断灭涅槃。利根者执果心多疑教少者。自观理智慧分明见习气犹在。知断惑未尽作观未来身尽灭耶。此是执果情多疑教心少。钝根执教多疑果少者。言既说言神明可灭佛语不虚。何敢不信受。此是执教多未知神明之道实灭不耶。此是疑果少。中根人或执果疑教或复执教疑果。但此果上生疑者唯无学人也。虽有此三种疑执开三显一一同。说法既竟同得悟解。但有先后文异也

就第一法说化上根人中自有四段。第一从汝已殷勤三请尽此卷末以来詺为正法说化上根人。第二从第二卷初长行及偈明上根人舍利弗等示同领解也。第三从尔时佛告舍利弗以下明如来述成上根人得解之相也。第四从汝于未来劫以下为上根人授记也。又此四段之中各开为二段。今第一正法说化上根人中有二者。第一从汝已殷勤三请以下竟一百十四行偈以来詺为正法说化上根人。上根人既解同归之理无三差别疑心既除。是故第二汝等舍利弗声闻若菩萨下七行偈略劝奖上根人受行同归之理。又就此两段之中各有二种。正法说中有二者即是长行与偈为二也。第二七行偈劝奖之中有二者。第一有五行半劝上根人行因。第二余有一行半偈劝令慕果。言心生大欢喜自知当作佛等。又就长行中自复有二。第一从汝已殷勤三请竟愿乐欲闻詺为法说缘起。第二从佛告舍利弗如是妙法以下竟长行以来詺为正法说。又就两段之中各有二。缘起中有二者。第一佛许为说同归之理无三之义。第二舍利弗言唯然世尊愿乐欲闻此詺舍利弗奉受旨。今就第一佛许中自有四重。第一正许第二诫敕令谛听。第三简众第四叹应闻众总结诫许也。汝已殷勤三请岂得不说此是第一詺为正许也。汝今谛听以下第二詺为诫敕令谛听。此则令生三慧诫谛听闻说。令生闻慧诫善思令生思慧诫念之令生修慧解也。说此语时会中有五千等礼佛而退此是第三詺为简众。以佛神力堪闻者住不堪闻去自。有四第一正明五千人礼佛而退。第二所以者何不释下堪闻。未得谓得者是有为果尽无生智也。未证谓证者谓无为果尽处也。第三有如此失下结不堪也。第四世尊默然下证不堪也。告舍利弗我今此众是佛许中第四叹众总结诫许也。只就此中自有三。第一告舍利弗下叹住者有机。第二如是增上慢下明去者无机。第三汝今善听下正总结。问者言如来有身口二密终日在坐不睹真容。虽复在中自不闻说法。何假从座而起拂席而去。解释者言。此品中是时众所应亦可是实持是佛神力。将欲褒贬时众为令住者生钦重之心起愿乐之意。贬去者无闻法之缘。是故拂席而去也

舍利弗言唯然世尊愿乐欲闻。缘起中本有二。第一佛许已竟此是第二明舍利弗奉受佛许也。佛告舍利弗如是妙法长行中本有二。一者缘起二者正法说。自此下是第二正法说。就正法说中自有二者。第一广诸佛门第二广释迦门也。今从如是妙法以下第一就诸佛广明开三显一。此则广上品初叹诸佛权实二智。所以言广者但上第一仿佛开宗中直总叹诸佛二智。言诸佛智慧甚深无量其智慧门难解难入。第二分明略说中但明显一。言世尊法久后要当说真实也。既但总叹诸佛二智而已不别明诸佛复。但明显一故称为略。今则广明佛又广明义故称广故。广佛者此中广总出诸佛。及别三世诸佛是则广佛之义深。复言广义者上直叹诸佛二智与显一。此中长有四义合有六义。一者叹法希有二者明不虚妄止物诽谤三者明开三四者明显一五者举五浊释先三后一之意六者简真伪敦信。既备此六义故称广义也

第二广释迦门者广上品初仿佛开宗叹释迦二智。及第二分明略说中开三义也。释迦门中唯有广义无有广佛也。今明广诸佛门中自成四别。第一总明诸佛开三显一第二就总诸佛门离出过去诸佛亦明开三显一。第三就总诸佛门离出未来诸佛亦明开三显一义。第四就总诸佛门离出现在诸佛明开三显一。今先明总诸佛门此中应有六义。一者叹法希有二明不虚妄三明开三。四明显一义。但文句略唯有四义略无出五浊释先三后一之意。至偈中方有同复无简真伪敦信。又略。下释迦门中可知备有六义。但文句略不出耳。今言如是妙法诸佛如来时乃说之如优昙钵华时一现耳此是第一叹法希有。优昙华是外国语此间言灵瑞华。唯有转轮圣王出世有此华故知此华希有。此经如是也。舍利弗汝等当信佛之所说言无虚妄此是第二明不虚止物诽谤。从舍利弗诸佛随宜所说意趣难解是第三明开三。就此开三之中自有三重文句。第一正明诸佛开三第二从所以者何我以无数方便此下是举释迦释诸佛开三。何以故。一释迦是诸佛数故。二本明诸佛开三为成释迦开三故也。第三言唯有诸佛乃能知之此还举诸佛结成诸佛开三之意也。所以者何。诸佛世尊唯以一大事因缘故此下是第四显一。此所以者。何义得释上开三之意。文则属下显一广明四一。先明果一二明人一三明因一四明教一也。明果一者即会昔日三果终成今日一果。明人一者即会昔日三人成今日一菩萨人。明教一者即会昔日三乘别教成今日一教。明因一者即会昔日三乘人所行之行只是一因以对一佛果。是故言汝等所行是菩萨道。此中四一二智中实智照境。四一有同有异义。实智所照境有机一此中无机一。所以有四者就理一中开为二种。因一果一也。然因果皆是理。所以彼处明机一。今此中不明机一者。前明机一此明二智所照境故明也。此中明会三归一若远相缘由亦应会三机为一机。但此三机实是众生自有法故不可会三归一。自余三一是诸佛昔日应三机但以假名字分一为三。今日一乘机熟故可得合三还归于一也。此中教一与实智所照境教一亦不同。何以知之。实智所照教一者直是照法华经教一。今此中言教一者昔日应三机故有三教。三教非是一三教远诠今日一理。故会昔三教终成今一教。此中明人一与实智所照境人不同。何以知之。实智所照境人无别体。今日众生一乘善机发一机所成人以为人一。故总诸菩萨以为一境。此中人一者昔日三乘机一所成边非是一。为三机善所成边是一善理一。故会昔三人终成今日一菩萨人。但今日教一人一名字与实智所照教一人一名字同明义意异也。此中明因一果一与实智所照理一义同而名字异也。今先明果一中自有四重。一者开果一章门。二者更牒果一章门。三者作四句解释果一。四者结果一也。今言所以者何诸佛世尊唯以一大事因缘故出现于世此是第一先开果一章门也。舍利弗云何名诸佛此下是第二显解释更牒果一章门也。诸佛世尊欲令众生开佛知见此下是第三正作四句解果一。开示悟入四句人解此四句互有不同。一家解言初三乘别教为开也。波若教时言示也。说无量义经名悟也。说法华经詺为入也。知见是佛果之名。同取万行作知见家道。此解亦好。今光宅法师解言。知见只是一众生当来佛果。众生从本有此当果。但从昔日以来五浊既强障碍又重不堪闻大乘。不为其说有当果。此当果则有闭义。今日大乘机发五浊不能为障。得闻今日经教说言众生皆当得佛。此则是开义。说言昔日三乘所行之行皆是得一佛果之行。众生闻此语则生闻慧。此则是示义。且又三乘人相与思惟筹量。昔来是方便今一因一果是真实。我等未来皆应得佛深解此理。于时则生思慧詺为悟。相与自知居未极地。更习诸行修无漏治道断无明住地烦恼。于时即生修慧仍詺为入佛知见道也。光宅法师又于善舍寺中解此四句。即会因果之义以明四句。然此四句有渐渐除义。初言开者此最浅故如前略说开三显一渐表寿命长远一果之义。此则是开义也。又如广说开三显一令知寿命长远一果之义。此则是示义也。又如后略明开近显远令知如来寿命长远。此则是悟义也。又如后广说寿命长远分身十方隐显度人复倍为期。时众相与同归之因求一佛之果。此诸行修学即是入义也。舍利弗是为诸佛唯以一大事因缘故出现于世。此是第四结果一也。佛告舍利弗诸佛如来但教化菩萨此是第二明人一也。诸有所作常为一事是第三明因一。明修此因为佛知见故言唯以佛之知见示悟众生也。舍利弗如来但以一佛乘故为众生说法。此下是第四明教一。就此教一中自有二阶。第一正明教一。第二从舍利弗一切十方诸佛法亦如是者引诸佛道同结成也

舍利弗过去诸佛此下是第二明过去诸佛开三显一。此下三佛于六义中唯有二义。只开三显一阙无四义。今先明开三也。第二从是法皆为一佛乘故下明显一。此下三佛于显一中例皆唯有三一。略无因一也。初言是法皆为一佛乘故即是教一也。是诸众生从诸佛闻法究竟此是人一也。皆得一切种智此是果一也略无因一也

舍利弗未来诸佛此下是第三明未来诸佛先三后一。此中亦唯有开三显一二义。今先开三也。第二从是法皆为一佛乘是显一。此中亦唯有三一。今言是法皆为一佛乘故是教一也。是诸众生从诸佛闻法究竟此是人一也。皆得一切种智是果一也亦无因一也

舍利弗现在十方无量百千诸佛。此下是第四广明现在诸佛亦先三后一义。唯有二义。开三与显一为二。此现在佛门证释迦先三后一义显。何以故。今同是现在十方佛尚有先三后一。何况释迦出五浊恶世而当不先三后一耶。就此现在佛门中自有三段。第一从舍利弗竟多所饶益安乐众生此先明现在佛先三后一之意。第二从是诸佛亦以无量无数方便下正明开三显一。第三举人一果一结成也。舍利弗现在十方无量百千诸佛下先明开三也。次第二从是法皆为一佛乘故下是显一。此中亦唯有三一。是法皆为一佛乘故此是教一也。是诸众生从佛闻法究竟此是人一也。皆得一切种智即是果一也。亦无因一也。从弗舍利是诸佛但教化菩萨此是第三更举人一果一结成现在佛所义也

舍利弗我今亦复如是。然长行第二正明法说中本有二。上来广明诸佛门开三显一者即是广上品初长行叹诸佛二智。及前偈中就诸佛显一义竟。此下是第二广明释迦如来开三显一。此则广上品初长行中叹释迦二智偈中据释迦开三之义。就此释迦门中唯有五义。第一明开三第二明显一第三举五浊释先三后一之意第四简真伪敦信第五明不虚妄。略无叹法希有。下偈颂中方有也。以此而准得知。一佛门中应备有六义文句互相映发我今亦复如是此下第一先明开三也。有种种欲者如来开教之始三乘各有所乐也。深心所著者此时遂能行行也。随其本性者明过去宿习不同也

舍利弗如此皆为得一佛乘。此下是第二显一。就中唯有三一略无人一。今言如此皆为得一佛乘此是教一也。一切种智故此一句是果一也。舍利弗十方佛世尚无二乘。何况有三。此明因一。言尚无二乘者言。尚无偏行六度菩萨乘辟支佛乘何况有声闻乘。故知唯是一佛乘即是明因一义也

舍利弗诸佛出于五浊恶世。此下是第三出五浊。释释迦先三后一之意。只为此五浊恶世故不能发初明一。就此明五浊中自有四段。第一总唱五浊二者列五浊之名三者明浊义四者正释结也。今言舍利弗诸佛出于五浊恶世此是第一总唱有五浊也。所谓劫浊烦恼浊此下是第二次第列五浊之名也。如是舍利弗劫浊乱时下第三明浊义。诸佛以方便力于一佛乘下是第四正释先三后一之意也。释五浊义五浊者劫浊烦恼浊众生浊见浊命浊浊者浊乱为义。此五浊大判只应有烦恼浊见浊。十使之中五钝使是烦恼浊。五利使是见浊。此二是浊之正体。余者相从为论也。见浊烦恼浊此是因浊。命浊是果报浊。众生浊是行因。得果人浊劫得名为时节浊。此劫更无别体只以时节中有此四种仍詺劫浊。如此年无食名为饥年年非是饥。劫浊亦尔。言五钝使为烦恼浊。此五钝使纵横竞起惛迷行人谓之为浊。众生由烦恼为因于中乱受生不定。轮回三界往还六道交乱受生。但众生是浊主也。五见为见浊五见以身为本。若身见一生诸见竞起迷真乱正詺之为浊。命浊复是果报浊。成实论言六人六识得相续生名之为命。由有烦恼为因生在三界。牵命感长感短杂乱无穷名为命浊。此五浊既障一乘机大判凡有三种五浊。若上品五浊即是见谛五浊。中品即是思惟五浊。下品即是习气五浊也。此三种五浊皆障一乘机。问者言此三种五浊皆障一乘机。外凡夫具有三种五浊。则应不闻说法华。亦应无大乘机也。思惟五浊亦障一乘机者。七种学人应无一乘机不堪闻说法华。习气五浊复障一乘机者。罗汉有习气亦应无一乘机不堪闻说法华。解释者言。如此颂类皆有其宿习大乘。大乘因缘强者虽有三种五浊不能为障。各宿习大乘。缘弱者虽有习气五浊犹能为障。今者明义正就宿习为论。诸凡夫等虽具有三种五浊。过去大乘善根强者此五浊则不能为障。便有一乘机发堪闻法华。学人无学人亦如是。宿习大乘因缘弱虽复偏行所行断除正使。习气既在由能为障无一乘机发也。问者言。若使皆由宿习大乘缘者何关五浊障耶。解释者言。今借一譬以显障机之义。何者如人恒有僻病。若使年常饮食丰足温暖适意[疊*毛]裘随时。然此僻病恒成就在则不为患。若使此人年常饮食不充衣被乏少致令寒暑得便。昔日僻病于时便显动发。内合亦如是。若善根食强烦恼僻病虽有不发。善根既弱五浊僻病则障一乘机。但障有三种一是对障二者既伏障三者随时障。今言五浊障一乘者詺为随时障。只是随时得便而能为障也

舍利弗若我弟子自谓阿罗汉。此下是第四简真伪敦物信心。所敦之者已是外凡夫也。就此简真伪敦信中自有两段。第一正简真伪第二从除佛灭后以下正明敦物信心。此两段中各自有三重。第一正简真伪有三重者。第一明非真第二明是伪第三出真罗汉形释也。今者第一若我弟子自谓得阿罗汉辟支佛者初此明非真也。又舍利弗以下第二正明此人是伪。何者言非真今者正明是伪。罗汉是增上果而伊实自未得罗汉果自谓言得。此则于增上法中生慢故言增上慢。所以者何。此下是第三出真罗汉例释上伪。若有实得罗汉不信此开三显一同归之法无有是处。当知实得罗汉者在五便中时早已解方便善是同归。而汝上言得罗汉不解同归者。当知此人非真罗汉。除佛灭度后此下是第二正敦物生信亦有三重者。第一正敦物生信第二释敦信之意第三释物疑心也。第一言除佛灭度后佛既灭度前佛已过后佛未出。于此中间若有人只于无佛前世中修行得罗汉。百千时都无有佛为此罗汉说法华道万善同归者。此人容可不解正是敦物令信。言佛若在世可得为汝说同归之理。佛若灭度谁当为汝说此法华同归之法。汝今可及佛在世生信乐之心受持同归之法。此是就教为说。若就理而谈不问有佛无佛皆自然解也。于时物情于中由自不肯信。自言佛虽灭度佛弟子自解法华。于佛灭度后自当为我说此同归之法。是故第二从所以者何以下佛即释此执言。所以劝汝及佛在世信受者何正言佛灭度后恶世多难如是法华有能受持读诵者。是人难得为此义故令汝今日信受也。但物情于中犹未肯信佛。若言灭度后受持此经为我说法甚难得者。我当自入无余涅槃。是故第三若遇余佛以下佛即释此疑言。若遇余佛于此法中便得决了。此意正言若人得罗汉果竟要闻如来说此法华知万善同归然后得入涅槃。若不闻说法华同归终不得入涅槃。若阿罗汉不值今日释迦说法华者于未来世中要值遇余佛。于此法华教中得闻万善同归方得入涅槃。无有中间入涅槃者。物情只闻佛此语仍信受。若如此我等即时信受。何假待余佛方信受。使罗汉当自外凡中有不肯信者相与信受也

舍利弗汝等当一心信解受持佛语。此下是第五明不虚妄止物诽谤之心也。就中有三。第一明劝信。第二诸佛如来下正明不虚。第三无有余乘以下举所信之法结劝也

尔时世尊而说偈言下正法说中本有二。长行与偈颂此下是第二偈颂凡有一百十四行偈。正颂上。上长行中本有二。一者缘起二者正法说。开方便门示真实相。今者一百一十四行偈亦开为二段。初有四行一句偈颂上长行中第一缘起。第二余一百九行三句偈颂上长行中第二正法说也。但上缘起中本有二。一者是佛许为说同归之义。二者舍利弗受佛明旨。今者四行一句唯颂佛许不颂舍利弗受旨也。然上佛许中本有四重。一者正许说二者诫敕三者简众。今皆不颂唯颂第四叹众总结诫许也

今者四行一句分为二。初有三行半偈不颂长行将显叹住者是。故先明去者之非。若无非无以显是。是故先明去者之非。次三句正颂何以得知不颂长行。上简众者佛入涅槃后出经者列于时事耳。云何今佛颂经家语耶。若尔何故相似耶。两处俱出于时事那得不相似耶。于戒有缺漏者若犯一戒名之为缺。具足犯即是漏。漏入生死。瑕疵者。瑕据其外疵据其内。内实犯戒外慎威仪故言护惜也。此众无枝叶。至舍利弗善听三句是第二正颂第四叹众总结诫许也。上本有三。一者叹住者有机二者明去无机三者正总结诫许。今者两句颂第一。舍利弗善听一句颂第三。略不颂第二段也

诸佛所得法自此下有一百九行三句偈。是偈中第二颂上长行中第二正法说。但上正法说中本有二。一者就诸佛门广明开三显一。二者就释迦门中广明开三显一。今此一百九行三句偈亦分为二。初有七十三行一句颂上诸佛门开三显一。从今我亦如是下有三十六行半。颂释迦门开三显一也。但上诸佛中本有四佛。一者总诸佛门开三显一。二者明过去诸佛开三显一。三未来诸佛开三显一。四现在诸佛开三显一。今者七十三行一句亦分为四。初有三十四行三句颂上总诸佛门。第二过去无数劫以下有二十七行半偈。颂上第二过去诸佛门。第三从未来诸世尊下有六行半偈。颂上未来诸佛门。第四从天人所供养以下有四行半偈。颂上第四现在佛门也。上总诸佛门中本有四义。一叹法希有二明不虚妄三明开三四明显一也。今者不颂第一叹法希有。今此偈中长有举五浊释先三后一之意故

就三十四行三句亦分为四。初有十二行一句颂上第三诸佛开三。第二从声闻若菩萨下有十一行偈颂上第四诸佛显一也。第三从若我遇众生尽教以佛道下有九行半偈义颂诸佛。举五浊释先三后一之义是上长行所无。第四从我有方便力下两偈颂上第二诸佛不虚妄。今两句料简。上长行中不虚妄是第二。今此中是第四。文句倒少。欲显六义本无次第意。上长行中有叹法希有今偈中略不颂。上长行中无有举五浊释先三后一之义。今此偈中有文句既互有出没。验知一佛门中应备有六义也。上总诸佛开三中本有三段。初正就诸佛开三。第二举释迦未释诸佛开三。第三还结属诸佛。今者唯显第一诸佛开三略不颂后二段也。上长行中唯开三乘是方便。今此偈广明五乘是方便。今就十二行一句偈中宜分为二。第一有八行三句偈先出四乘教是方便。第二从有佛子心净下有三行半偈别出菩萨大乘教是方便。逐文句起尽。是故宜开为二也。又就八行三句偈出四乘方便中自复有二。初有五行三句偈先出四乘教。第二从我说是方便有三行偈正开是方便。明昔日所以有四乘之教皆是方便。又此两段中各有二。初有四行一句出人天二乘教。次一行半出声闻辟支佛二乘教也。就初四行一句中有四意。第一诸佛所得法下三句明于大乘中离出人天二乘。第二众生心所念下一行明众生根性不同。第三佛悉知是已下一行明随宜说法非一。第四或说修多罗下一行半广出非一之教即是九部经也。从钝根乐小法有一行半是第二出声闻辟支佛二乘教。二乘人未必是钝但贬其狭短故言钝也。问曰上言若人遭苦厌老病死今者何故言贪着于生死。此则前后自相违。或解释言。有三种解。一解言生死有二种。一者三界分段生死。二者是三界外无明住地变易生死。分段之苦交切厌心则显。变易之苦比于分段此苦则微。且自昔日三乘教不说有无明住地之苦。就昔教既不说有此生死之苦。则于是苦无有厌心故言贪着。第二解言故始须陀洹等若论求道之边此则遭苦厌老病死犹有妻子之爱。此则是贪着于生死。此两解随意用之。后又言机中有厌情则有贪也。我说是方便。自此下三行是第二正开言是方便之教。就中且有二者。第一言我说是方便有两偈。先开上声闻缘觉三乘教是方便言昔日是真实今日是方便。第二言我此九部法一偈倒开上人天二乘教亦是方便。故说是人天等经。根本本为大故言入大乘为本以故说是经。有佛子心净。此下三行半偈是第二别出三乘中大乘之人。教中亦有二。初有一行半偈先出三乘中大乘人教。说是大乘教者是昔日三乘中之大乘非今日大乘。第二二行偈正开是方便自有二。初我记如是人下一行半略记成佛。第二佛知彼心行下半行正开是方便。佛知彼心行为说三乘中之大乘也

声闻若菩萨此下十一行偈颂总诸佛门中第四显一。上有四。初是果一。二是人一。三是因一。四是教一。今者略不颂第三因一。唯颂三一亦不次第。今声闻若菩萨下一偈颂第二人一。十方佛土中唯有一乘法此下一行半偈颂第四教一。说佛智慧故此下八行半偈颂第一果一。就此八行半中自开三段。第一从说佛智慧故下有一行三句偈。先明佛未应世时欲为众生说一大乘果。不欲与小乘果。第二从如其所得法定慧力庄严。下有四行三句偈正明出世以来欲与一乘果。第三从舍利弗当知我本立誓愿有两行。明如来本行菩萨道时欲与大乘果。又此三段前一后一不开。只就第二佛出世以来欲与大乘果有四重。第一从如其所得法三句正明佛将欲以大果与众生。第二从自证无上道下一行半偈释佛出世之本意欲与大果。我若惜此大果我是悭贪之人。无奈众生无大果之机。是故先为说三。但时众于中生疑佛为自言欲与众生大果。谁当信佛此语。故第三从若人信归佛下有一行一偈引胜人证。汝言无有信者自有人信三宝者言佛不欺诳者。此等人信佛恒欲与众生大果。时众有生疑言。若使都无有信三宝者。谁当复信佛耶。第四我以相严身一偈用佛。自身功德相好。证佛与大果不虚。若是无威德人容可不实佛。既如此形相云何当出言不实

若我遇众生此下九行半是第三义颂总诸佛门五浊。上长行所无者。就此五浊中自有三段。第一若我遇众生尽教以佛道一偈正明佛为五浊众生故出世不得即说大意。第二六行偈出五浊体

第三从是故舍利弗有两行半。结佛为五浊众生出世说小之意。此三段之中前一后一不开。第二出五浊便成五重。我知此众生两行偈出众生浊。受胎之微形一偈明命浊。入邪见稠林下一偈出见浊。六十二见者我见作本。外道计我即色。是我离色是我。我住色中色住我中。乃至行阴上亦如是。五阴上各有四五。便成二十见。现在有二十见。此可见由因生故。故过去五阴上亦有二十见复感未来种数。故未来世五阴复计二十见。合三世各二十见便成六十见。见虽有六十不出断常二见。何故如此。若使计色即是我者后时便成断见。即是无见也。自余三见皆离色计我便成常见。即是有见也。是知总而论之。是有无二见别而谈之有六十见。若总若别故有六十二见也。深着虚妄法出烦恼浊。于千万亿劫一偈出劫浊。是故舍利弗此下两行半。是第三结诸佛为化五浊众生故施三乘方便之意也

我有方便力示以三乘教。此下两偈颂上第二不虚妄。就中自有二。初一行偈先举释迦同诸佛先三后一不虚妄。第二今此诸大众下一行劝信结不虚妄也

过去无数劫自此下有二十七行半偈。上四佛门中之第二过去佛门。上过去佛门中本有二。一者开三二者显一。今者先有两行偈颂开三也。第二从是诸世尊等有二十五行半。颂过去佛显一。就此第二二十五行半偈中自有二种。第一有二行半颂教一。第二从若有众生类二十三行偈作三重并颂三一。人一因一果一也。三重者初两行明过去佛在世时修行得佛。第二有二十行偈就过去佛灭度后修行得佛。第三一行偈合明佛在世及灭度后供养成佛也。就第一两行过去佛在世时中修行得佛亦有三。若有众生类即是人一。行六度即是因一。成佛道即是果一也。诸佛灭度后已下二十行偈。是第二就佛灭度后修行成佛中凡有四种供养。一一偈明软善供养。第二四行半偈明起塔供养。第三六行半明造像供养。第四八行直明三业供养也。第一若人善软心此一偈未暇作余供养。且先明软善心供养不开。诸佛灭度已有四行半偈。第二起塔供养亦有三一。人即是人一。供养心即是因一。成佛道即是果一。从若人为佛故有六行半偈是第三明造像供养。亦有三一之义。从若人于塔庙下有八行偈。第四直明三业等供养亦得有三一之义也。于诸过去佛现在或灭度下一行偈是第三合明佛在世及灭度修行。亦得有三一之义

未来诸世尊自此下有六行半颂上第三未来佛门。就中自有二。初有两行半偈颂上开三。第二从诸佛本誓愿下四行偈颂上显一。就中有三。初一行颂果一。未来世诸佛虽说百千亿下此一偈颂教一也。诸佛两足尊此下有两行颂因一。知法常无性者知万善法无有三乘性。佛种从缘起者若据佛果望万善此佛果由万善而得仍詺因为缘。故言佛种从缘起也。是法住法位者是万善法住一乘法位故法住法位位。世间相常住者只是世间取相。诸善亦住一乘佛位。又一种解。修此万善在于世间相。常住者常住大乘中。导师方便说者根本只是一因。昔日方便说言有三。故知只是一因。有人曰。用此两偈颂教一意谓不尔。何故知是因一。言佛种从缘起因只是缘也

天人所供养此下四行半偈颂上第四现在佛门。上长行中有三。第一明开三显一义之意。第二正明开三显一。第三结成。今此偈中只颂前二不颂第三结。第一言天人所供养一偈半先颂第一现在诸佛。为三一之义故应出在世也。后三行偈颂第二正明开三显一之义。上长行中先明开三后明显一。今此三行偈中亦分为二。言知第一寂灭一偈先颂显一唯颂教一也。第二知众生诸行有两行倒颂上开三。此两行偈自有二。初一行一句先明现在十方佛洞见三乘人机。第二言以种种因缘下三句正颂开三也

今我亦如是自此下有三十六行半偈颂上释迦门。上长行中本有五义。一者开三二者显一三者举五浊释先三后一之意。第四简真伪敦信。五者明不虚妄。今者不颂第四简真伪敦信。长有叹法希有故。今此三十六行半偈亦分为五别。初一行偈超颂上显一。次有一偈追颂上开三。第三从舍利弗当知下二十七行半偈颂上第三五浊。第四从如三世诸佛说法之仪式下五行半义颂叹法希有。长行所无也。第五从汝等勿有疑我为诸法王下一行半颂上第五不虚妄。今三重料简。但上长行中显一本第二段。今此中先颂显一后颂开三。明互有前后之义。具如上释。上第四是简真伪。敦信此中略不颂。上长行本无有叹法希有。今偈中长出叹法希有则义颂之也。所以长补所阙还成五重。然此释迦门中长行与偈既互有出没。故知一佛之中应备有六义。今且取第一第二第三第五唯除第四叹法希有。用此四段偈若合若离不合不离作十种法说。此即为下火宅中十譬。作本所以不取前四佛门作本者。上明四佛者为成今释迦义。未来非是正主故不取。等是释迦门中复不取叹法希有作本。此中明法说与譬说作本。其自有优昙华譬云何以譬为譬作本。是故不取也。取第一第二此两段宜合为一段。上则帖同诸佛先三后一之意名为化主同下。则为火宅中第一宅主譬作本亦名为总譬作本。又离第三颂五浊。作八段为下火宅中八譬作本。又取第五不虚妄段不合不离。为第十譬作本也。离第三颂五浊。作八种譬本者第一从舍利弗当知我以佛眼观有四行偈。此间詺为佛在法身地见所化众生为五浊所惛。即为火宅中第二长者见火譬作本。火宅中言长者见是大火从四面起下是也。第二从我始坐道场观树亦经行有六行半偈。此间詺为佛应世以大乘化众生不得。此则为下火宅中第三长者救子不得譬作本。火宅中言舍利弗是长者作是思惟我身手有力当以衣裓下是也。第三从寻念过去佛所行方便力下十一行偈。此间詺为佛因三乘化得众生。此则为下火宅中第四长者救子得譬作本。下言尔时长者即作是念此舍已为大火所烧我及诸子若不时出必为火焚我今当设方便下是也。第四舍利弗当知我见佛子等志求佛道者无量千万亿一偈。此间詺为佛见三乘人大乘机发之义。此则为火宅中第五长者见子免难譬作本。下言长者见诸子等安隐得出火宅到无畏处皆于四衢道中露地而坐无复障碍也。第五从咸以恭敬心皆来至佛所曾从诸佛闻方便所说法有一偈。此间詺为三乘人索果。所索者只是三界尽无生智。此理中为论。此则为火宅中超为第七诸子索车譬作本。下言时诸子等各白父言父先所许玩好之具羊车鹿车牛车愿时赐与也。第六我即作是念如来所以出为说佛慧故今正是其时有两行一句偈。此间詺为佛见众生大乘机发故欢喜。此则追为火宅中第六长者见子免难故欢喜譬作本。下言其心泰然欢喜踊跃也。第七于诸菩萨中正直舍方便但说无上道此三句。此间詺为佛为众生说大乘。即是说法华经。此则为下火宅中第八等与大车譬作本。下言舍利弗尔时长者各赐诸子等一大车下是也。第八言菩萨闻是法疑网悉已除千二百罗汉悉亦当作佛。此一偈此间詺为三乘人受行大乘之义。此则为下火宅中第九诸子得大车故欢喜譬作本。下言是时诸子各乘大车得未曾有非本所望也。离颂五浊为火宅八譬作本竟。用此八譬足前化主譬为九譬。第十超取第五不虚妄段。言汝等勿有疑我为诸法王有一行半偈。此间詺为不虚妄。此则为下火宅中第十不虚妄譬作本。下言舍利弗于汝意云何是长者各与诸子珍宝大车宁有虚妄下是也。是故言若合若离不合不离作此十段。为下火宅中十譬作本。远为化城譬作本。亦远论穷子譬作本也

言今我亦如是此一行超颂上显一唯颂教一。我以智慧力下此一偈追颂上开三。此两偈合为一段。上则帖同诸佛先三后一詺为化主同。下则为火宅中若国邑聚落有大长者詺为宅主譬作本。亦名为总譬作本也

第二舍利弗当知此下有二十七行半颂上第三举五浊释先三后一义。既分作八段故舍利弗当知以下四偈是十法说之第二。此间詺为佛见所化众生为五浊所惛。则为下火宅中第二长者见火譬作本。下言长者见是大火从四面起下是今就此十四行偈中自有三段。第一半行明能见第二三行出所见第三半行明起悲愍之心。今言舍利弗当知我以佛眼观此半偈是第一明能见。佛在法身地见所化众生为五浊所惛也。见六道众生下有三行偈。第二出所见。即是五浊见六道众生贫穷无福慧此半偈出众生浊也。入生死崄道下半偈明命浊也。深着于五欲下一行半偏举贪使明烦恼浊也。深入诸邪见下半偈明见浊也。略不出劫浊。劫浊更无别体四浊为时节节是劫浊也。为是众生故而起大悲心此半偈是第三明能见见所见。起悲愍明如来欲化众生也

第三我始坐道场此下六行半偈此间詺为佛以大乘化众生不得。即为下火宅中第三长者救诸子不得譬作本。下言舍利弗是长者作是思惟我身手有力下是也。今就此六行半偈中自有三。第一半行明化众生不得之处。第二半行明化众生不得时节。第三五行半正明化众生不得也。我始坐道场下半行是第一佛以大乘化众生不得之处。观树者一解言树立天下众生。经行者必为此事。亦言念报树四枝覆荫之恩为众生作轨。树木无心犹尚报恩岂况于人乎。于三七日中思惟如是事此半偈是第二明佛以大乘化众生不得之时节也。从我所得智慧下有五行半是第三正明佛以大乘化众生不得。自有三重第一从我所得智慧微妙最第一下半行明佛用大乘拟宜也。第二从众生诸根钝下有三行偈此明佛见众生无大乘机。第二两偈明息化。就第二无机中自有三。众生诸根钝半行明有人天小机。如斯之等类下半行正明无大机。尔时诸梵王下两行证成无机也

只由梵王请故住世。验知无大机也。我即自思惟若但赞佛乘以下两行偈是第三明佛息大乘化。自有二。第一一偈半明增畏其患。若无大乘机但为说大乘者容生诽谤之心入三途。故言没在苦也。第二我宁不说法下半行正明息化

寻念过去佛此下有十一偈是第四此间詺为佛用三乘化得众生。此则为下火宅中第四长者以三车救子得譬作本。下言尔时长者即作是念是舍已为大火所烧下是也。就此文中自有二。第一十一偈正明用三乘化众生得也。第二从久远劫来一偈释物疑也。就前十行中自有四段。第一六行半明佛用三乘拟宜。第二一行见三乘人机。第三一行半即为说三乘教。第四一行三乘人受行也。今言寻念过去佛此下六行半偈是第一开三乘拟宜自有三重。第一寻念过去佛所行方便力一行明觅教拟宜。上半是觅教下半正明拟宜。第二作是思惟时十方佛皆现下四行半明诸佛赞叹。第三舍利弗当知下一行明释迦归命诸佛也。复作是念我出浊恶世如诸佛所说一偈是第二见有三乘机堪受三乘化也。思惟是事已即趣波罗奈下一行半。是第三明佛即为说三乘教正造鹿苑之时。诸法寂灭相者此明万善诸法寂灭无有三乘之相可说。但以方便故说有三乘也。是名转法轮便有涅槃音下一行。是第四三乘人受行但以方便故说有三乘。只得言有涅槃之音无有实涅槃之体也。五人得道八万诸天得圣。是故维摩经言三宝于是现世间也。从久远劫来此下一偈是第二释疑。疑言。释迦如来三达洞照自应解三乘之教。那得方复学诸佛三乘法耶。释言。从久远劫来赞示涅槃法。明又已解三乘教法。但欲为同诸佛故也。又释。时众相与生疑言。若道理中无此三乘佛何故具欲为人说是三乘耶。是故第二有一偈释疑。从久远劫来赞示涅槃法。言常欲示一乘因果法。无大乘众生不堪受也。相传言。此则密明寿量之义。此是前释也

舍利弗当知我见佛子等志求佛道者无量千万亿。此一偈是第五此间詺为佛见三乘人有大乘机发。机发是理故言志求。此则为下火宅中第五长者见子免难譬作本。下言是时长者见诸子等安隐得出火宅下是也

咸以恭敬心皆来至佛所此偈是第六此间詺为三乘人索果。此则超为火宅中第七诸子索车譬作本。下言是时诸子各白父言父先所许珍玩之物下是也

我即作是念如来所以出此下两行一句第七此中詺为佛见三乘人大乘机发故欢喜。追为火宅中第六长者见子免难故欢喜譬作本也。下言其心泰然欢喜踊跃下是也。今两行一句偈自为二。初两偈出欢喜之由第二余一句正明欢喜。初两行出欢喜所由之中自有二。我即作是念如来所以出为说佛慧故是前偈明好事遂故喜也。钝根少智人着相憍慢者不能信是法。是后偈明恶事除故喜。何以知之。此人本时是钝根今者成利根。何以知然。昔日纵使利根废己作钝根。今发广大心故称之为利根人也。此人本时是小乘小智今者成大乘大智。此人本时是着相憍慢者今日非着相憍慢。本时不能信大乘法今日能信大乘法。是故生喜也。今我喜无畏此一句是第二正明欢喜

于诸菩萨中正直舍方便但说无上道。此三句是第八此间詺为佛为众生说大乘。即是说法华经。舍者除昔日方便教去。但说无上道者取今日大乘之教也。此则为下火宅中第八长者等与大车譬作本也。下言是时长者名赐诸子等一大车也。菩萨闻是法疑网皆已除此一偈五浊中之第八。十种法说之是第九。此间詺为三乘人相与舍三乘教得大乘解。为下火宅中第九诸子得大车故欢喜譬作本。下言是时诸子各乘大车得未曾有欢喜踊跃也。颂五浊竟

如三世诸佛此下五行半是颂释迦中第四义颂叹法希有。长行所无者也。不为下譬作本也。今就此五行半中自有三段。第一有一偈先出所叹之法也。即是一乘教。第二从诸佛兴出世有两偈据诸难显叹法希有之相。第三有二行半还据优昙华譬结叹也。又解云。就中有二。初一偈出所叹之法。后四行半正叹法。就叹法中有三。初二偈法说次一偈譬说后一偈半合譬也

汝等勿有疑此下一行半偈。偈中之第五颂上释迦门第五不虚妄。十种法说中复是第十段。此为下火宅中第十不虚妄譬作本也。下言舍利弗于汝意云何是长者各与诸子珍宝大车宁有虚妄下是也

汝等舍利弗声闻若菩萨下但法说化上根人中本有二。上从汝已殷勤三请以来讫于上一百一十四行偈正法说化上根人。上根人相与得解开三显一同归之理无三之别。是故自此下有七行偈。是第二略奖劝上根人。修行取果上正法说中本言有二。长行与偈。今此七行偈奖劝之中亦二者。第一有五行半偈劝奖上根人行因。第二汝等既已知下一行半奖劝上根人慕果。前劝行因即是化他。后劝慕果即是自行。菩萨之谓也。又就此两段之中各有三重。奖劝行因中有三重者。初有两行偈。先出所弘之法即是此经。夫行因之体只是弘经益物自行兼余。是故先出所弘之经。第二复有两行偈正劝奖弘经。即是行因。第三从舍利弗当知下一行半即双结上两段。又就此三段中各有二重。第一出所弘之经中有二者。初一行偈是第一正叹出所弘之经。第二偈释上结成也。当知是妙法诸佛之秘要者此经能令人出生死得涅槃。此即是要义。从本以来未得说此妙法即是秘义也。以五浊恶世一偈即是第二释上秘要之意。只由五浊众生乐着五尘六欲。此辈众生无有求佛道之心不能得说此法华。即是秘要义。第二正劝奖行因中有二者。第一言当来世恶人下一偈诫令行因之时恶人莫为说。第二言有惭愧清净下一偈劝令好人遍为说。第三双结中有二者。第一言舍利弗当知下一偈此则结上第一出所弘之经。第二言其不习学者不能晓了此。此半行即结上第二正明其弘经之方。其不习学者莫为说。此半正结初偈。结后偈时翻取可解。当知学能解了者应为说也。汝等既已知。此下一行半偈是第二奖劝上根人慕果。就中亦有三者。第一有三句偈明上根人得解三一之义。第二言无复诸疑惑一句明上根人等惑除。第三心生大欢喜下半偈正奖劝慕果也

法华义记第三终妙法莲华经义记卷第四

        光宅沙门法云述

    譬喻品第三

此品名目未应在此。何以知之。譬喻之意本为中根人譬说开三显一。但法说开三显一化上根人犹自未竟。云何已是譬喻说耶。所以题品在中者。盖是出经者分卷令调故。割法说之余安置此中。不欲令卷有大小。是故移譬喻品名置第二卷初。若实论品处正从舍利弗白佛言世尊我今无复疑悔以下此处方是譬喻品也。若用此法说四段准下譬说化中根人四段者。亦应具四品。第一正法说之处即应言法说品。无异下化中根人中譬喻品也。若是领解段即应言领解品。无异下化中根人信解品也

若是述诚段即应言述诚品。无异下化中根人有药草品也。若是受记段即应言受记品。无异下化中根人有四大弟子受记品也。今法说四段所以无有如此品者有三义因缘。其第一意正以下类上。下譬说中既有四品今以下类上其义可求。若以上类下下亦应无四品。是故互相映发有无意趣自显。第二义言但法说文句少故不复立四品。第三义亦可是出经者深取佛意止作二十七品。于时时众感悟所宜如脱更立于时众无益。然他方异土亦何啻二十七品也。但法说开三显一化上根中本有四段。从此以下尽偈是第二段明上根舍利弗等领解也。前判法说四段之中。例开为二今此领解段中有二者。第一是经家叙舍利弗得解之相。第二正是舍利弗领解之辞。又就此两段中各开为二。初经家叙中有二者。第一先明经家叙内心欢喜。第二经家叙外形恭敬。从即起合掌下是也

而白佛言以下是第二正领解之辞亦有二者。第一是长行第二是偈颂也。今且就长行中自有三段。第一正明舍利弗自陈得解故欢喜。第二从是我等咎非世尊也下竟思惟取证詺为悔过自责也。第三我从昔来下讫长行结领解也。又就此三段中各开为二。又就各开为二中初重例皆不开。第二重中例复各开为二也。今初段中二者。第一正领解第二从所以者何下举昔日之忧形释今日之喜。昔日既有悔有疑故恒忧。今日疑悔除故所以喜也。就此第二释中例皆开二者。第一举昔日悔第二举昔日疑。所以者何下竟失于如来无量知见。是第一詺为举昔日之悔形释今日之喜。是则显今日得解之相。何以知然。昔日大品座时亲见菩萨受学大乘受记成佛。而我不豫斯例悔不取大可感可伤。无量知见者即是佛果。然此佛果是昔日所不取是所悔之事也。从世尊我常独处下竟而见济度是第二举昔日疑形释今日喜。既实有大乘之法我等同入无生之理。云何如来以小乘度我以大乘度彼。此则以理惑教生此疑心也

第二悔过自责中二者。第一然是我等咎非世尊也正总悔过自责也。第二所以者何以下举别释总悔过之意。昔日恒言我等同入法性云何如来以小乘度我以大乘度彼。常怨世尊无平等心。今日方知我自昔无堪受大乘心。致使如来方便说小也。然此释中例有二者。第一先明悔昔不取大。第二明悔取小也。今者第一悔昔日不取大从所以者何下竟必得大乘而得度脱者也。所因者今据无上佛果望万行。万行是佛果家所因也。复据万行望大乘教大乘教即是万行所因。何以知然。秖由大乘教故生万行由万行故感佛果。今此中言所因者秖詺大乘教作因也。然三乘别教亦次第说。鹿苑说四谛王舍城中说十二因缘后说优婆塞戒经。身子自言我昔日何不待如来说大乘教。于中修行可不得大乘解。而匆匆受三乘小教。此则悔昔日不取大也。然我等不解方便此下是第二悔昔日取小也。我若解如来昔日教是方便者岂复取小秖由未解如来昔日方便权教故仍于中信受。此则悔昔日取小也

第三结领解二者。第一我从昔来下竟每自悔责先结昔日之忧。第二而今从佛下结今日得解故喜例有二者。第一从而今从佛闻所未闻竟快得安隐此詺为恶事去故喜也。第二今日乃知真是佛子下詺为好事来故喜。昔日谓二乘必不成佛不能绍继佛种故非佛子。今既言汝等所行是菩萨道必绍继佛种故言真佛子也

而说偈言向言正领解中有二。第一是长行此下是第二偈颂也。但上长行中本有三段。一正自陈得解二悔过自责三结领解也。今就此二十五行半偈中分为四段。初有十一行半偈颂上长行中第一正自陈得解也。第二从我本着邪见下有五行偈颂上第二悔过自责也。第三从初闻佛所说下有六行半偈颂义出不颂上长行。上长行中直明昔日疑悔形今日喜也。不言今日有新。疑除今此六行半偈正明今日疑除。故知不颂上长行。第四闻佛柔软音下两行半偈颂上长行中第三结领解也。又上长行第一正自陈得解中本有二。初正自陈得解。第二举昔日之忧形释今日之喜。今就十一行半偈中亦分为二。初有两行半颂上第一正领解也。第二从我处于山谷下有九行偈。颂第二举昔日之忧形释今日之喜也。今就第一两行半偈中自有三阶初有三句正颂上领解。上言而白佛言今从世尊闻此法音心怀踊跃得未曾有也。第二疑网皆已除下又有三句明惑灭生解。然惑灭生解必由佛。是故第三佛音甚希有一偈称叹如来以结得解也

我处于山谷此下九行偈颂第二举昔日之忧形释今日之喜。但上长行释中本有二。第一举昔之悔第二举昔疑也。今此九行偈亦分为二。初有六行偈颂上昔之悔第二有三行颂上昔日之疑也。今就初六行颂悔中自有三阶。初一行半偈先出生悔之处正颂悔。第二有三行出昔日所悔之法。第三有一行半结生悔心也。今者第一上直言悔未知在何处时生此疑悔。今偈中既广是故出生疑悔之处。秖在山谷林中宴坐行道于时起疑悔之心生怨叹之意。何以知然。如来昔日唯为诸菩萨受记得佛不言。声闻得佛。由是义故生疑悔之心。然在大众中亦有疑有悔山谷中亦有疑有悔。悔我不求大乘生疑谓言既同入法性云何如来以小乘度我以大乘度彼。法性既同不应有小大异。此则是以理惑教。又如来亲说有三乘教差别法性之理何必是同。此则是以教惑理也。今从多论闻在大众中眼见耳闻菩萨胜事举扬大士德高行远。我既不豫在斯例中。于时唯得起悔恨无暇得起疑惑之意。若在山林静处于时多生疑惑之心也。我等亦佛子同入无漏法下有三行偈。是第二出昔日所悔之法也。自有三意。初偈明生说法利。次一偈明生三十二相等内外功德。后偈明生八十种好等内外功德。我独经行时下有一偈半。是第三举山谷静处及在大众之中结生悔心。此则表静处亦得起悔也。我常于日夜此下三行偈颂上举昔疑形释今日喜。就此三行偈既广自分为三阶。初一偈正颂上昔日有疑也。第二一偈出昔日所疑之事。第三偈明今日得解故昔日疑除也。今者第一以教惑理故言为失也。有时复以理惑教故言为不失也。是故言以理惑教以教惑理。踟蹰理教之间故言为失为不失此之谓也。我常见世尊称叹诸菩萨一偈是第二即出所疑之事。秖由见如来大品教时独称叹菩萨德高行美皆得成佛。为是事故所以有疑也。今闻佛音声一偈是第三明今日得解故昔日疑除即有二意。上半偈明解开三下半偈明解显一。此意即显昔日以理惑教之是以教惑理之非。今无漏难思议之力众生至道场。此语果与昔日以理惑教相应也

我本着邪见此下有五行偈是第二颂上第二悔过自责疑。但上长行中本有二。第一总悔过今者不颂唯颂第二举别释总也。但上释中自有二。第一悔昔不取大今不颂也。第二悔昔取小今者颂之也。上言而我等不解方便随宜所说遇便信受思惟取证。今就此五行偈中自分为三。初有两行偈正颂上悔昔取小。第二从而今乃自觉下有二行偈明今日得解。第三佛于大众中下一行明恶灭也。就第二今日得解中有二。初而今乃自觉非是实灭度此半行明解权。第二若得作佛时下一行半明解显一也

初闻佛所说此下有六行半偈是第三义出不颂上长行。何以得知。长行中明昔日有疑不明今日新疑除。上方便品明权智难测实智甚深

又言佛以方便力示以三乘教。藉此生疑惑之心。但闻上广说开三显一此疑得除。就此六行半偈中自有两段。今初闻佛所说心中不惊疑下一偈先出疑惑之心。第二从佛以种种缘下五行半广明疑除。今就此五行半中自有三阶。初一行偈正总明疑除也。第二佛说过去世无量灭度佛下三行引三世佛皆先三后一。别出除疑之教。第三世尊说实道下一行半偈总结疑除也

闻佛柔软音此下两行半偈是第四颂上长行中第三结领解也。但上长行中本有二。一者结昔之忧今者略不颂也。唯颂第二结今日之喜。但上结今日喜中本有二阶。一者明恶事去故喜二者明好事来故喜。今此两行半偈亦分为二。今初闻佛柔软音下一行半颂上第一恶事去故喜。上言而今从佛闻如是法断诸疑悔也。后偈颂第二言今日乃知真是佛子从佛口生从法化生得佛法分也

尔时舍利弗法说开三显一化上根人中本有四段。此下是第三段明如来述成上根人得解之相。本言四段之中例开为二。此中有二者。第一佛告舍利弗先述古。第二述今从我今还欲令汝忆念本愿下是也

舍利弗汝于未来世此下是第四段。即为上根人授记就中亦有二者。第一尽偈以来正为舍利弗受记。第二从大众见舍利弗得记仍起随喜供养比知欢喜。然舍利弗记有长行与偈颂也。只就长行中有八重。第一记行因第二当得作佛下记得通别二号也。第三国名离垢下记国土第四华光如来亦以三乘教化众生下释物疑也。第五其劫名大宝庄严下记人物第六舍利弗华光佛寿下记寿命长短。第七华光如来过十二小劫下记其后佛第八华光佛灭度之后下记像正二法也。上第四释物疑。疑言华光佛国土纯净所化之人皆是菩萨大士。则菩萨大士初不闻三乘之名。今何故言以三乘法教化众生耶。解释者言华光佛所化实是菩萨大士。所以说三乘者此则遂大士位怀之意。何者菩萨位心应为说四谛者为说四谛。应说十二因缘者为说因缘堪闻六度者为说六度。今华光佛为说三乘法用故言以本愿故说三乘法也

尔时四部众此下是第二明诸天见舍利弗得记故欢喜。所以欢喜者正言心平等。今身子既得记冀我亦在斯例是故欢喜也。就中自有长行与偈也。亦就长行中自有二。第一明大众见舍利弗得受记。第二正明欢喜。就中有三。心大欢喜一句明意业欢喜。各各脱身所著上衣下明身业供养。而作是言下明口业赞叹也。偈中有三三偈半明闻法欢喜。次两行偈明见受记故喜。次一偈明回向也

尔时舍利弗白佛言我今无复疑悔譬喻品应在此初。所以在卷首者意如前述也。但明因中有四段。第一略明开三显一动执生疑。第二怀疑致请。第三广明开三显一断疑生信。第四别流通因也。今者故是第三广说开三显一断疑生信段本有三。即化三根人为三段。法说开三显一化上根人已讫。自此下竟四大弟子受记品是第二段譬说开三显一化中根人。就此譬说化中根人自有四段。即是四品为四段。第一此譬喻品一品正明如来为中根人譬说开三显一同归之理。正化中根人也。第二信解品明中根人领解也。第三药草喻品明如来述成中根人得解之相。第四受记品明如来为中根人受记也。又就此四段之中各开为二。今且就第一正譬说开三显一中有二者。第一先明舍利弗为中根人更请佛譬说也。第二明如来答请即为譬说开三显一之义也。舍利弗所以为中下根人请者凡有二意。一言此中下根人虽复识有利钝然颁类是同。今上既在先得解云何直置其颁类不解同归之义。为此意故请佛为说也。二者如来上既记上根得佛然昔是声闻今成菩萨。菩萨之德必有两心自行则远求佛果化他则广济众生。备此二意是故为中下根人重请佛说也

今就两段之中各开为三。请中有三者。将欲为中根人请佛重说开三显一之义。是故第一先自陈己解正由己解同归之理。是故得菩提之记也。第二即牒出未解之徒。从是诸千二百下是第三结请也。第二明此学人皆未解人亦何啻千二百人。今止举此以为请端也。离我见即是身见也。及有无见者即断常二见也。等者即是见取戒取也。此诸人等闻佛开三显一相与皆以理惑教以教惑理。自疑所得为是为非故言皆堕疑惑也。从善哉世尊愿为四众说其因缘令离疑悔是第三结请

尔时佛告舍利弗自此下是第三答亦有三段者。第一是譬说缘起第二从若国邑聚落以下尽一百行偈以来正是譬说开三显一化中根人。但中根之徒既解同归之理自知必得佛。是故第三从汝舍利弗我此法印以下尽品有六十五行偈即奖劝中根人受行也。又就此三段之中各开为二。缘起中二者。第一竟皆为化菩萨故对舍利弗呵中根凡夫。第二许为譬说同归之理。所以第一先呵者此则发起中根之徒忿击之心令其因忿致启。夫有心识者同归作佛然理唯一致无三差别

上已具明何事不解。就此第一自有三意。以种种因缘下明教一皆为阿耨多罗三貌三菩提耶者明果一。是诸所说皆为化菩萨故者明人一也。若便呵之太过容生羞耻之心。或起退堕之意。由我是佛弟子。是故致此呵啧。是故第二从舍利弗今当复以譬喻更明斯义诸有智者以譬喻得解。此则明佛许为譬说同归之理。虽然人根有利钝之殊解悟有前后之别。汝今尚未解我当更譬说。就此第二自有二。然舍利弗下正许譬说。次诸有智者下叹中根人也。圣人洞见物情是故与夺得时。前呵后许意致如此。第二正譬中有二者。第一是长行第二是百偈重颂也。第三六十五行偈奖劝中根人。有二者。然奖劝之意秖明弘经益物自行化他种同归之因感圆极妙果。是故第一言汝舍利弗我此法印一行偈。先出所弘之经即是是法华。第二从在所游方勿妄宣传尽品有六十四行偈。正奖劝受行弘经益物。但前化上根人中劝令行因复劝慕果。今此卷末唯劝行因不劝慕果。但慕果之心易生行因之意难立。何以知然。如世间人无不贪乐高官重位自在富乐。然此等皆是报果不空来必由因感。及至苦行修道盖不足言。是故唯劝行因意况如此也

舍利弗若国邑聚落自此下尽一百行偈是第二正为中根人譬说开三显一。亦有雨段。如向所明第一是长行。第二是偈颂。今就长行之中自有两段。第一是开譬第二是合譬。今就开譬之中凡开十譬即譬上方便品中十种法说也。十譬者第一从若国邑聚落竟或至三十在此宅中名为宅主。亦詺为总譬总譬诸佛纵论三世横辨十方故言总也。自余九譬唯明释迦。若如此者唯有二譬今总别合数故有十譬也。今者第一旧言宅体今意不然也。此即譬上方便品中今我亦如是安隐众生故下有两行偈。明释迦同诸佛先三后一明化主义也。第二从长者见是大火竟无求出意呼曰长者见火譬。此则譬上方便品中舍利弗当知我以佛眼观有四偈。明佛在法身地。见众生为五浊所昏。第三从舍利弗是长者作是思惟我身手有力竟视父而已詺为长者救子不得譬。此即譬上方便品中我始坐道场六行半偈明佛用大乘化众生不得之意也。第四从尔时长者即作是念此舍已为大火所烧竟诤出火宅。詺为长者用三车救子得譬。此即譬上方便品中寻念过去佛所行方便力有十一行偈。明如来用三乘化得众生。第五从是时长者见诸子等安隐得出竟无复障碍詺为长者见子免难譬。即譬上方便品中第五舍利弗当知我见佛子等志求佛道者。一行偈明如来见众生五浊障除大乘机发。第六从言其心泰然欢喜踊跃二句詺为长者见子出难故欢喜。此即超为方便品中第七作譬。上言我即作是念如来所以出下有两行一句偈。明如来见五浊众生大乘机发故欢喜也。第七从时诸子等各白父言父先所许羊车鹿车牛车愿时赐与詺为诸子索车譬。追为上方便品中第六作譬。上言咸以恭敬心皆来至佛所一偈明三乘人索果回换之意。至下当释。第八从舍利弗尔时长者各赐诸子等一大车以下詺为长者赐大车譬。此即譬上方便品中第八于诸菩萨中正直舍方便但说无上道有三句偈。佛为三乘人说法华记其得佛。第九从是时诸子各乘大车得未曾有非本所望詺为诸子得大车故欢喜譬。即譬上方便品中第九菩萨闻是法疑网皆已除千二百罗汉悉亦当作佛。明三乘人受行大乘之义。第十从舍利弗于汝意云何下明长者先许小车今与大车名不虚妄譬。譬上方便品中第十汝等勿有疑我为诸法王一行半偈。明如来教法不虚妄初始许小终即与大乘有虚妄不虚妄意。至下当释

今就第一宅主譬亦名总譬。明释迦同诸佛先三后一化五浊众生。以类相从凡有六义即为六阶。第一正明宅主同第二明化处同第三明化门同第四明所化人同第五明所救事同第六明受化者同也。何者初明释迦同诸佛为化主即是长者义。第二明化处同者此化主同应在三界。然此三界系属如来即是长者有一大宅义。第三明化门同者然五浊众生。反流尽源之时要藉如来言教。此言教之用能通众生出苦海之宅到妙乐之所。即是长者之宅唯有一门。第四明所化人同者所教化者是五道众生。即是长者宅中有五百人义。第五出所救事同者三界众生备为五浊八苦所煎迫即是长者宅中有火。第六明受化者同者五道众生所可正受化者有三乘根性。三乘根性即是三十子义。无异人虽五百然与长者非尽天性。至于天性相关者有三十人也。今者六义之中唯宅主同是上法说中有。余五义今譬说方有也

先明宅主总明十方诸佛皆化五浊众生同。是一长者义。今就第一宅主义中自有三。一者明长者名位处。二者正出宅主。三者叹其德。又此三段中前一后一各有三意。中间唯一。初段中三者一者先明长者于一国有名。二者明于一邑中有名。三者明长者于一聚落中有名。问者言何不从狭至广今乃从广至狭。解释者言为欲从疏至密是故从广至狭。如人于一国得名然外传易为音响。未若于一门一郡知其虚实。虽复令名播于州郡未若一邻一里知其有德。内合为义者横语十方世界六道四生。纵谈无间以上金刚以还。如来德被有识恩润苍生如长者于国中有德。若但取十方诸佛一应化道所及处如释迦王三千大千等。犹如长者於邑中有德。又的论娑婆南阎浮提如来于中利益如聚落有德也。有大长者此是第二正出宅主也。未必年杇称为长者唯取有德有行之义也。其年衰迈此下是第三叹长者有德自有三重。第一叹长者内德第二叹长者外德第三叹长者眷属也。今者第一其年衰迈此叹长者内德。夫老人必多识悉此明如来三达洞照是事皆知。唯取多识悉往古故以衰迈为譬主。次言财富无量亦有田宅是第二叹长者外德。正明七珍丰盈荫盖孤贫。此明如来外化之德无尽。是故有四摄度人慈悲救物也。夫养命称田安身为宅明如来能生众生功德智慧如田。示物修行之方如宅。是故大涅槃经云立一切众生于五戒十善业此之谓也。及诸僮仆此是第三叹长者眷属。声闻辟支佛狭心短志犹若僮仆也。其家广大此是第二义明长者之宅。宅以安身为义。如来应在三界三界系属如来仍以所化为宅。是故维摩经言众生是菩萨净土。明菩萨所化众生仍以众生为土。今明如来化三界以三界为宅。然则三界弥博故言广大也。唯有一门此是第三义。宅虽广大秖有一门通人出入。今呼佛教为门。但三界众生反流之始会藉如来言教然后出离生死必到菩提。然则五时言教为门。莫二故言一也。多诸人众此下是第四义明长者宅中有五百余人。内合三界之中以类相从凡有五道众生也。堂阁朽故此是第五义明出所救事。明长者宅中有火内合为义者。明三界之中备有五浊八苦。煎逼众生就中有二。将明火起先叙所烧之物正明因薪火传。第二周匝俱时欻然火起句正明火起。今者第一明欲界如堂色无色界如阁也。然三界众生皆为生老病死无常所逼迁故言朽故也。三界众生四大为墙壁但此四大之身皆念念生灭故言颓落也。命如柱根但此命为善根所招。是故念念无常故言腐败也

识如梁栋有心识者呼为众生。是故众生以心识为主。然此心识取缘亦刹那生灭故言倾危也。周匝俱时以下此第二正明火起。周匝俱时者四生之中皆有五浊八苦也。欻然火起者正明火起。外譬为义者正由长者不在致令宅中火起。下偈中言其人近出未久之间。内合如来已曾化此众生令折伏烦恼。于时已作得度因缘但感缘既尽如来余方教化然众生更起三毒烦恼。非本意所期。故言欻然火起也。长者诸子此下第六义明五百人中有与长者天性相关者。有三十子内合明如来所化有三乘根性入三界中也

长者见是大火从四面起此下竟无求出意是第二长者见火譬。此即譬上方便品中第二舍利弗当知我以佛眼观下有四行偈。明如来在法身地见众生为五浊八苦所昏。但上方便品中有三段。第一明能见第二明所见第三起悲愍之心。今此譬中亦作三段譬上三段。第一言长者见明能见。即譬上方便品中舍利当知我以佛眼观是也。是大火从四面起此是第二明所见。即譬上见六道众生贫穷无福慧备明佛见五浊。今明四生众生备有五浊皆起烦恼故言从四面起也。即大惊怖此下是第三阶明长者既见宅中火起烧逼诸子便起惊怖之心。此即譬上方便品譬本之中第三阶为是众生故而起大悲心。明如来既见众生为五浊所昏起悲愍之心。就中有三。第一即大惊怖一句正为大悲作譬。第二而作是念下竟安隐得出明不自为。第三而诸子等下竟怖出所为人今言即大惊怖者悲意忽至因之为惊内合。如来昔日已于二万亿佛所曾教化众生。于时已作得度因。自尔已后更复贪着五尘广起烦恼失昔日之解悲意之事。故言惊也。非唯直失解而已亦恐众生广起烦恼断绝善根成一阐提堕三途弥劫受苦。故言怖也。而作是念我虽能于此所烧之门安隐得出者是第二明怖不自为。上言詺佛教为门今者何故此门被烧耶。解言乃是詺佛教为门不言此教被烧。但教所化众生自是被烧故如彼一门立大学门。云何不言两板双扇读书解义耶。故知一门中人解义读书也。安隐得出者明如来昔日亲藉大乘之教离三界八苦成就种觉故言安隐得出也。而诸子等以下是第三出怖所为人。众生贪染五尘故言乐着终日运役三业无一可记故言戏也。不觉五浊八苦为逼若使觉九十八使是失便怖畏三途之苦。只由不觉故不知不惊怖也

舍利弗是长者作是思惟此下竟视父而已是第三明长者救子不得譬。即譬上方便品中第三我始坐道场下六行半偈。明如来用大乘化众生不得。但上譬本之中有三段。第一言我始坐道场观树亦经行半行偈明如来用大乘化众生不得之处。今者不为作譬也。第二言于三七日中思惟如此事半行。明如来用大乘化众生不得之时节。今者亦不为作譬也。唯为第三正用大乘化众生不得作譬。然此意本非涉言教正明如来之意作大乘化道方法。上第三正化不得中本有三段。第一用大乘拟宜。第二无大乘机。第三息大乘化。今者亦具足为此二段作譬。但譬意既委悉宜开为两段。第一作劝教第二从我当为说怖畏之事下作诫教也。如来在世虽复言满三千形遍六道。大而为论不出诫劝两途。是故出世之始仍言诸恶莫作众善奉行。众善奉行即是大慈劝善诸恶莫作即是大悲诫恶。是故慈欲与乐劝令行善悲能拔苦诫令断恶。故如昔说苦集两谛即是大悲诫恶。次明灭道二理即是大慈劝善。今此譬意亦复如是。就此劝诫之中各有三段皆拟上譬本中三段者。第一先以劝教拟宜。第二即明诸子无有堪受劝之机。第三息劝教也。今明劝教拟宜即譬上方便品中言我所得智慧微妙最第一以大乘拟宜。上唯明智慧今此譬中广明智之与境。故就此拟宜譬中自有二。第一是长者作是思惟我身手有力者先明长者以身手救济。内合明如来思惟法身有应之功。智慧有济拔之力。第二言当以衣裓若以机案从舍出之此正明慈念弥至。欲以衣裓裹子欲以机案擎之。内合如来正用大乘劝教拟宜。衣裓譬大乘因机案譬大乘果。欲明如来既有智慧身手以大乘因与众生。欲以大乘果与众生令出也。复更思惟此是第二明诸子无有堪受劝之机。即譬上方便品中第二阶。众生诸根钝着乐痴所盲如斯之等类云何而可度。此中有二。第一明大教于其人无用。第二正明无大机。今者第一此舍唯有一门而复狭小者。明大乘教之门于时不化得众生出离三界。此教门于其无用。不能容受义称狭小也。问者言门自狭小不能通诸子得出。何关诸子不肯出耶。解释者言。经文自言诸子幼稚未有所识不肯从门出。若有识有知岂应在门内为火所烧。但于时大乘教于众生无用义成狭小也。诸子幼稚下第二正明无机就中有二。第一诸子幼稚者明众生有天人五戒十善小机也。未有所识者此是第二意正明众生无大乘机。故言未有所识。若不举其有小无以显其无大也。上拟宜中第三尔时诸梵王下引证证无大机。今者不为作譬也。恋着戏处此下是第三明长者息劝教。此即譬上方便品中第三阶。我即自思惟若但赞佛乘众生没在苦不能信是法破法不信故坠于三恶道我宁不说法疾入于涅槃。或当堕落为火所烧者明众生既无有求大之心。若强以大乘化已或能转生诽谤。堕落三途故言为火所烧也。我当为说怖畏之事。此舍已烧宜时疾出无令为火之所烧害自此下是第二作大乘诫教。然诫之为义即说苦言迫之。此中有三段。亦譬上法说中三段。第一先用诫教拟宜。第二明诸子无有堪受诫之机。第三明长者息诫敕之教。今言拟宜者。还譬上方便品中第一言我所得智慧微妙最第一。明如来用大乘拟宜众生。此中自有两阶。一者先明长者思惟作诫敕之教。明如来思惟欲为众生说三界之中有五浊八苦生老病死逼之令厌也。第二正明拟宜。问者言。如来种智洞见物情。承机赴感义在一时。方言思惟将不乖种智之明贬三达之照耶。解释者言若论实处本绝言像。今据迹涉形不无此义。若使怪言如来方复思惟作诫劝之教者。亦应怪言有丈六之体亦应疑上于三七日中思惟。丈六三七曾不厝疑。何意忽怪作诫教耶。此意明如来大悲之意不已摄救之心弥至。善始令终常为大乘也。作是念已如所思惟具告诸子。汝等速出此下正明长者用诫教拟宜。内合正明如来用大乘诫教拟宜众生也。父虽怜愍此下是第二明众生无有堪受诫教之机。自有二。第一父虽怜愍善言诱喻标牒上句。第二而诸子等不肯信受。不惊不畏以下正明无大机。即譬上众生诸根钝着乐痴所盲如斯诸等类云何而可度。无有大乘机也。亦不为引证作譬也。但东西走戏视父而已此是第三即息诫敕之教。南北是纵东西为横。若使众生心用与大下道理相附。则如南北之纵只由众生不会真理于生死之中。横理用心譬如东西也。驰骋五尘之中呼之为走。虽复运动三业无善可冀称之为戏。唯有感见丈六之机故言视父。无有感说大乘之机故言而已

尔时长者即作是念此舍已为大火所烧以下竟诤出火宅是第四明长者用三车救子得譬。即譬上方便品中第四寻念过去佛所行方便力十一行明如来用三乘化得众生。但上譬本中本有两段。初有十行偈正明如来用三乘化得众生。第二从久远劫来下一偈释疑。今不为释作譬唯为正用三乘化得众生作譬。但上正用三乘化中本有四段。第一用三乘拟宜。第二见三乘人机。第三为说三乘教。第四便有涅槃音及以阿罗汉法。僧差别名一行明三乘人受行。今此譬中亦具足为上四段。于譬上拟宜中本有三。第一寻念过去佛所行方便力我今所得道亦应说三乘此一行名见教拟宜。第二作是思惟时下四行半明诸佛赞叹。第三舍利弗当知下一行明释迦归命诸佛也。今者唯为第一作譬略不为下二作譬也。今言尔时长者即作是念此舍已为大火所烧下竟得勉斯害。先明长者用三车拟宜。但指用三乘拟宜犹未为说也。我及诸子若不时出必为所焚者凡有两解。传印法师云。我化道所及之人故言我及诸子。今云法师云如来化道有被物之功呼之为父。众生禀教生善即是子义。众生若使遂留住三界断绝善根。无绍继之能即是子死之义。如来化功于此众生断即是父死之义。我及之言其意如此也。就此拟宜中有二。一者从初说我今当说设方便先明不见教。即为方便品中寻念过去佛所行方便力作譬也。二者令诸子等得免斯害者正明拟宜即为方便品中我今所得法亦应说三乘作譬也。父知诸子先心各有下讫情必乐着是第二明长者知诸子等宿好之心。此即譬上方便品中第二复作是念我出浊恶世如诸佛所说我亦随顺行明如来见三乘人机。然此是小乘机那得言先有此机耶。若言二万亿佛所于时已曾受大乘化呼此为先心者。于时众生有大乘之善。若尔者是即先心有大乘之志那得言先心有小乘善机。解释者言。此则与所习感应相应。何者今日感佛之善从原身以来有善以来皆尽感圣。然原身以来诸善皆有习因之力感未来习果。然过去习因之善亦有值小乘教于时生狭心之善。亦曾值大乘教生广心之福自有值小生广。自有值大生狭。然此诸善因皆作习因感未来习果。然未来诸善若有漏善若无漏善若狭心善若广心福皆是习果。又过去若狭心善举体为未来广心善作习因。亦举体为未来狭心善作习因。亦举体为未来无漏善作习因。亦举体为未来有漏善作习因。昔日有广心善亦如此。夫习因习果本是同性相招。虽复广狭之殊漏无漏别至于为善之义其理莫异。是故习因习果互得相关。若据今日大乘善习果望昔日者。是习因此则大乘宗有先心所好。若据今日狭心善望昔日者昔日一切诸善皆是习因。此则今日小乘善宗有先心所好。今言先心正在于此。然因果多途非可一类。若以同性相招即习因习果能致乐受。即是报因报果感见圣人。即是感应因果。有人言未来善感正言曾有之善已生何假圣应。今所习不然。夫感应理微非粗心所见。一念生善能感习果。时非缘不发。是故曾有之善正招习果又傍感圣人为生果之缘。若言未来习果能感圣者。亦应未来乐受能招于大。善感乐果果在未来。亦应善感习果果在未来。未来习果既感圣亦应未来乐受能感于大。若果报无有感大之力亦应习果无有感圣之功。至于此难实觉难通。而苟执未来其理不可。故知报因之力正感乐受傍招于大为乐受之缘。亦何异习因之力正感习果。傍感圣之功为其生果之缘耶。而告之言汝等所可玩好希有难得此下竟皆当与。汝是第三明长者为说三车。即譬上方便品中第三思惟是事已即趣波罗捺诸法寂灭相不可以言宣以方便力故为五比丘说。明造鹿苑说三乘。今就此第三段中自有四阶。第一赞叹三车第二示车处第三劝取三车第四许与三车。不虚而告之言。竟后必忧悔此是第一明长者赞叹三车内合如来赞叹三乘。下合譬言汝等当知此三乘法皆是圣所称叹。如此种种羊鹿牛车今在门外可以游戏此是第二明长者示诸子三车处。内合如来示三乘人果处。三车既在门外然三乘人尽无生智在三界外。若同断三界正使烦恼尽出三界外证尽无生智。故言示三车处也。汝等于此火宅宜速出来此是第三长者劝诸子往取三车。内合明如来劝三乘人修行取尽无生智。下合譬言汝但当勤修精进也。随汝所欲皆当与汝此是第四明长者许与三车不虚。内合明如来语三乘人言。汝等但修无漏治道断三界烦恼尽出三界外。保得尽无生智。下合譬言我今为汝保任此事终不虚也。尔时诸子闻父所说珍玩之物此下是第四段明诸子受行。即譬上方便品中第四便有涅槃音及以阿罗汉法僧差别名。明三乘人受行遂得圣道。今就此第四中自有四阶。第一竟心各勇锐此明众生闻说三乘教。即生外凡夫善根。第二互相推排一句譬众生闻说三乘教。修行登内凡夫位。虽复推排犹自未得出门。何以。内凡夫犹是具缚。修行伏烦恼即是动义。不能断结出生死。即是未动亦有动不动义。第三言竞共驰走一句即譬众生闻说三乘教修行得无漏入无相行。成七种学人。各修无漏断烦恼即是竞也。同观无相之理即是共也。兴心求进即是驰走也。第四言争出火宅一句即譬七种学人修行遂证罗汉果。出三界外得尽无生智。彼此各异证譬如争也。前三句长出上法说所无。后一句只为法说作譬

是时长者见诸子等安稳得出此下竟无复障碍是第五明长者见子出火难譬。譬上方便品中第五舍利弗当知我见佛子等志求佛道者无量千万亿。明如来见诸众生大乘机发。此中亦应具通学人无学人大乘机发。今此文中略明无学人。所以尔者。为欲喻扬无学学人正使未尽。是故贬之为劣阿罗汉辟支佛大力菩萨断正使。已尽。是故褒之为胜。问者言。若尔者无学人必应在前大乘机发。七种学人必应在后大乘机发。解亦应尔。解释者言本不定判无学人必应在前大乘机发学人必应在后。问者所论据人有胜劣学人为劣无学人为胜也。今就此譬中自有两阶。初是时长者见诸子等安稳得出。先明断惑出三界外登无学果也。第二言皆于四衢道下正明大乘机发。四衢道者东西尽彻南北交通。此明四边无障。露地者此明上又无碍。五处无障此表明大乘机发五浊不能为障。下即释言无障。此释四边无障又言无碍此释上又无碍也

其心泰然欢喜踊跃此是第六明长者见子出难故欢喜。即譬上方便品中第七我即作是念下竟今我喜无畏二行一句。明如来见三乘人大乘机本发故欢喜。但上譬本中有二。初两行明致喜所由。今不为作譬。第二言我今喜无畏一句正明欢喜。今正为此作譬。然大乘机发称如来本意。是故其心泰然欢喜踊跃

时诸子等各白父言父先所许珍玩之具羊鹿牛车愿时赐与此是第七诸子索车。譬此即譬上方便品中第六咸以恭敬心皆来至佛所曾从诸佛闻方便所说法一偈。詺为三乘人索果。所索果者是昔日小乘果上机发是第五。索果是第六。佛喜是第七。此明一时之义。只是大乘机发时索昔日所许之果。亦是索果之时即是大乘机发时。时虽无前后义有始终。只得言大乘机发故索果不得言索果故大乘机发也。此譬中先明佛后明索果者。此逐亲疏作义。大乘机发是今日之要。索果本非要也。何以知然。正明大乘机发称如来本心。是故佛喜系机发之后。索果之心索昔日所许小乘之果。此乃是惑倒之心不解方便之意。云何是要。是故索果义系佛喜之后也。今略述索车义凡有四重。述人解不同。第一明三车体相第二覆明索车义。第三明有索无索第四述人解。第一(两问答)夫师习不同意致各异。古来旧义体用通漫。有人解言。索珍宝大车经文自言是时长者各赐诸子等一大车。若不索大云何与大。即时所习意谓不尔。前文自言时诸子等各白父言父先所许三种宝车愿将赐与。若言索大何故求三。故知昔日所许三种小车既言父先所许云何索大。诸子即是三乘人三乘不一故言诸也。三种宝车即是羊鹿牛车即譬昔日阿罗汉辟支佛大力菩萨三学人究竟果。珍宝大车平等种无三种差别即譬今日法华经中为众生受记同得佛果。且自长者昔在门内许时门外。三车赐诸子今避门内之苦出门外。得车故乐既出门外不见有车。是故就父求索。何关索大车。问者言。既不索大何故与大。解释者言。以大化小是故与大。问者言。若使索小与大亦可索大与小。解释者言法相不然。云何苟在无别。三小唯是一大。今者与大由大乘机发。是故会昔三小成今一大。是故今日与大道理可然。又有人解。是言教中索。又有人解。是机中有索。即时所习就情明索意在后途。明三车体相。第二(有九问答)大判三家果地功德凡有二种。一者是有为果。二者无为果。无为果中自有二种。一因尽无为即是三界因断也。二者果尽无为即是三界果亡也。此二种无为本非车体何以知之。此经虽不类然明常欲遣昔日结断无处。以之为果故。二乘车以运载为用今二种无为本无运义。故知非是车体。是则二种无为置而不论。今就有为果中有二种。一者功德二者智慧。但功德智慧此二难明。分别之相现显涅槃义记。今略述其相以立义宗。正取寄境修行即是功德。故如藉缘布施寄境修定。禅定判时卒不辨。前境有好有恶是寄一青境得修四禅。智慧之用则不如是。今者用心照境。识苦集之智非灭道智。是则功德之用寄境修心。智慧之用。用心照境。且又智慧背我而照境。功德向我而修心。今明车体又不取功德。何以故。功德之用无运载故。唯取智慧以为车体。智慧众多复非一条。今据境捡求不出十智。十智者一苦智二集智三灭智四道智。五名字智六法智七比智八他心智九尽智十无生智。虽有十智今核论车体唯取尽智无生智以当车体。其余八智非正车体。虽非正体得为校具。所以言四谛智非正车体者。本言车在门外。若言四谛智是车体者七种学人已具四谛智。故不当车体也。复言名字智非正车体者。知法名字是名字智。非唯七学人已有名字智。凡夫有名字智。故知名字智非车体也。法智者知现在法名为法智。凡夫及七种学人皆知现在法。故知法智复非车体也。本言比知过去未来法名为比智。凡夫及七种学人皆能比知过去未来法。故知比智复非车体也。所以言他心智非车体者。外道五通亦得他心智。故知他心智复非车体也。唯有尽智无生智正是车体。问者言。若尽智无生智车体者是则三无学人唯有尽无生智无有八智。七种学人唯有八智无有尽智无生智。解释者言。无学人罗汉自具十智。但于十种智中唯取尽智无生智。以当车体。其余八智非正车体。若论七种学人亦有尽无生智。但有法不同故。如须陀洹照三途因尽即是尽智。照三途果亡即是无生智。今七种学人犹有三界生云何有此尽智无生智。且自三车本在门外。若便呼七种学人尽智无生智为车体者。则是三车便在门内也。问者又言。若尔七种学人唯有八智不具十智耶。解者言。七种学人缘他因果尽智即是尽智无生智。问者言。若尔七种有尽无生智即是车体。解者言。本言我生已尽我不受后有。今缘他生智我不得无生。何异贫穷人昼夜数他财宝。问者复言。无学果地具有十智。今以何义故唯取尽智无生智以当车体也。解释者言。尽智无生智具二义故得为车体。一者果时有二者缘果起。言果时有者罗汉金刚心时断正使。已尽于时未有极果。只是成无学。时方有此尽智无生智。故果时有也。缘果起者既已成无学。于时因尽是有余涅槃。果尽是无余涅槃。于时缘我三界果亡是无生智。此即缘果起也。是故有缘得而证即是果时有。缘证即是缘果起也。时有何故不为车体。解言。本体缘我生已尽我不受后有。灭智不然。故不为体。问者复言。若我生已尽我不受后有者亦所并言缘我。灭智是我有也。解释者言。此灭谛智有二义故不为车体。一者缘他灭即是缘天下灭谛。二者功用智即是见灭谛时能断结使。未必皆是缘果起。今尽智对成二义。唯缘在于我不缘于他。无学时有非功能用智也。问者言。若尽无生为车体者。今得罗汉时义主常言于时已证得无生智。然罗汉报身是三界内法。若尔即是三界证此二智。是则二智即是三界内法。云何言三车在门外耶。解释者言。证二智时实如来旨不得称此二智是三界内法。何以知然。此二智起时必缘境而生缘三界因尽。即是出三界外心照三界果亡。亦是出三界外意。是故缘境界义别。故知非是三界内法也。问言。界内界外相貌云何。而当高下为异隔碍作谈论。解释者言。夫内外分流未必纵谈胜负横语优劣。直是果报隔绝称之内外也。问者又言。若使得罗汉之日于时已证二无为者。是则尽无生智即非车体。何以知然。车本运载行人到于涅槃。于时既已证得二涅槃。故知二智无车之功也。解释又言。但得罗汉时已得二种涅槃。但入无余时此义旨显。何以知之。只入无余涅槃之时。于时因尽义显果尽义彰。是故二智之功运入义显。若不尔者云何得有果乘之义耶。核明索车义第三有七问答。索以求取为义。车以运载为能。今言所索是车故言索车。昔日断正结尽时出三界外得无为涅槃。既随佛教修行断结正结既尽成无学果。然罗汉辟支有三明之智。用天眼之智诫观未来犹有生死。自觉死后不得便入涅槃。佛昔劝导但修行断三界烦恼。尽时得无生智得入无余涅槃。正言照生因尽是尽智具足。照我生果亡是无生智具足。而今日觉生因未尽尽智未具尚有生果。无生智未具如来言断正使得尽智无生智具足。是何处耶。此即是索义于时即有以理惑教以教惑理。若以理惑教则有索义若以教惑理则无索义。今现见生死未尽云何得入涅槃。生死既未尽佛教何故言断正使尽得入涅槃。今二智究竟是何处耶。此即以理惑教有索义也。然佛是至人诚言无二。既说断正结尽得入涅槃。佛语不虚云何不信。如今所见生死何必是生死耶。便言我生已尽所作已辨。自言二智究竟得入无余。此则以教惑理无索义也。今明索义正取以理惑教。不取以教惑理。是故三无学人并以理惑教皆有索义。昔见道谛思惟是生死因义。两宗余习非生死因。义同无记。此就教为论非是理谈。问三无学人以理惑教。有索义者所索之车并应一种。解言实如来旨。正言佛说一解脱义。解脱齐故三车亦等。问者复言。若说解脱义齐。三车等者不应有羊鹿牛车三种优劣。解者言。因断三界正使尽同得尽智。亦同照三界果亡得无生智。是故三无学人二智一种。亦断三界子果两缚。故解脱义齐也。所以有此羊鹿牛车三种优劣者。声闻止断正使别相枝条。能荷负最劣取譬羊车。缘觉侵断小习知见少广取譬鹿车。菩萨断习净尽知见圆明运用最胜取譬牛车。负重致远横语知见。有胜负之殊。是故有三优劣。问者言。若习非正结何故断使亡耶。解释者言。为妨习知见是故断之也。问者复言。若尔便应习气尽处制尽无生智。解释者言。本断三界因果尽处制此二智。今习气非三界之因。云何习气尽处制二智耶。问言。若不习气尽处制二智者何故断此习耶。解言。犹如前释为欲广集知见何开为二智耶。问者又言。知见即是尽智无生智。然尽智无生智只是知见何故避尽无生名道知见耶。解释复言。夫知见名同知见意异。尽智无生智成无学时具此二智。其有二义具如前说。问者所论是成无学后。为欲广习知见得此知见必须断习得。是故智成功用。云何与尽智无生智同。问者言若阿罗汉犹有生死不得入涅槃者。是则无学行人皆不得入无余涅槃。不应言罗汉心得自在。解释言。从来判此有理有教。若核实理何曾入无余神明不可断灭。就教为论得入涅槃。昔教不言三界外更有生死。是故以教惑理得入涅槃。即是罗汉心得自在义也。明有索无索第四(有一问答)七种学人皆无索车之义。阿罗汉辟支佛大力菩萨三无学皆有索义也。长者本道三车在门外。但出门外三车相与。今七种学人犹在门内云何就门内索车。若使出门外觅车不得。可就父求索。断三界因果未尽云何已索尽无生智。但三无学人以出三界外。于时以理惑教故有索义也。问者言。若无车故索亦应无城可入。既有城可入亦应有车可乘也。解释者言。若以理惑教无车故索。若执教惑理则有城可入。是则城据迥处可以化作。车在门外可以闇说也

舍利弗尔时长者各赐诸子等一大车此下是第八长者赐大车譬。即譬上方便品中第八于诸菩萨中正直舍方便但说无上道。明如来为三乘人说法华。今就此譬中自有两段。第一双开两章门第二从其车高广下即广释上两章门。两章门者初言各赐诸子等。此一句先开长者心平等章门。内合明如来今日平等为三乘人说大乘经。令同得圆极妙果也。次言一大车此三字即是第二所赐物。章门同用圆极妙果与尔时众也。其车高广此下是第二即广释上两章门。今先广释后所赐物章门。第二从而作是念下即追广释前心平等章门。又此广释两章门中各有二阶。今且明广大车门中有二者。第一先广叙大车之相。第二所以者何下即释长者得有此大车之意也。今言其车高广者此即对于昔日止断三界正使。尽处得尽无生智为果。然此果狭而复短。今日明三乘行人皆成菩萨受记得佛。然此佛果超出五百由旬之外即是高义。又傍摄其诸功德智慧即是广也。是德悉圆故言众宝庄校也。周遍总持即譬周匝栏楯也。如来四辩之中的明辞辩。留梵妙响化给四生故言四面悬铃也。轩盖最高而能覆下譬佛果众德之中大慈大悲。此二德高胜而能覆育众生与乐之恩拔苦之术也。又有种种功德庄严此慈悲故云珍奇杂宝而严饰之也。四弘誓如宝绳交珞。若不交珞者容有退坏。内合明圣人虽复有大慈大悲。若无四弘誓任持此慈悲。可有退失之义也。未解者令解未度者令度。此两誓则持大悲拔苦也。未安者令安未涅槃者令得涅槃。此两誓则持大慈与乐也。垂诸华璎者为招集观者无异四摄。摄化众生也。重敷婉筵者即毡蓐之流也。然是车中之物即譬佛果备诸禅定也。丹枕者此是色中之发者也。譬苏定发生无相功德也。标心极果修习故言驾。真无漏如白牛能断无明黑闇故言白也。会二谛之理是真实之法故言肤充也。即体明说净无诸尘染。故言色洁也。又能断除无明巨患故言有大筋力也。心会二谛之理路故言行步平正也。断除生死之苦速到涅槃之乐故言其疾如风也。又言信首以上诸受学弟子故言又多仆从也。所以者何。此下是第二即释长者得有此大车之意。正言财宝无穷七珍皆具。明知如来蕴内德在怀如充。又有化他之德盈外如溢也。而作是念我财物无极以下是第二。即追广释前心平等章门。今此广中亦有两阶者。第一正广心平等。第二所以者何下即释心平等之意也。问者言。此佛果自是一切众生当来妙果。云何言如来用此佛果与众生耶。解言。此实是众生佛果。然要须外缘。若无如来为说行因到果方法者。是则众生不能离此生死远至涅槃。若不尔者云何经中有授记之义耶

是时诸子各乘大车得未曾有非本所望此是第九诸子得大车故欢喜譬。此即譬上方便品中第九菩萨闻是法疑网皆已除千二百罗汉悉亦当作佛。明三乘人受行大乘义也

舍利弗于汝意云何此下是第十不虚妄譬。即譬上方便品中第十汝等勿有疑我为诸法王下半行偈明不虚妄也。今就此譬中自有三段。第一如来先作不虚譬问舍利弗。第二明舍利弗仰答如来明不虚妄。第三如来述舍利弗结成不虚妄也。今明长者昔日本许诸子三种小车令出门外。今平等与诸子珍宝大车。就情论事为有虚妄为无虚妄耶。内合昔日令众生修行断三界烦恼。许与众生三界外尽智无生智。今日遂为众生平等受记同得佛果。如此化方为是虚妄为非虚妄。舍利弗言。此下是第二舍利弗仰答佛明不虚妄。今就此答中自有两段。第一言不也世尊此先总明长者不虚妄也。第二明不虚妄就此第二中自有三。第一明以重夺轻不虚。第二别明称本心不虚。第三明过本所望不虚妄也。就第一中自有三。初若是长者但令诸子得免火难全其躯命非为虚妄一句。正明以重夺轻不虚。第二何以故若全身命下释。夫人所重莫过身命。余外财宝事成赊远。而此长者慈悲令诸子免焚灼之苦。全身与命即已是不虚之重。况复财宝轻物而当相准。内合为义者。化佛若不方便接化众生。或能广起烦恼断灭大乘善根。只由如来方便诱化令大乘智愿善根不断不绝。所重慧命得全。况复轻微小果也。第三况复方便于彼火宅中而拔济之者总结不虚。欲明如来设小乘教。作根本为欲与我等大乘因果。今日既同得大乘之解。此则称如来出世大意。云何虚也。世尊若是长者此下是第二明称本心故不虚。亦有三阶。初若是长者乃至不与最小一车下一句正明称本心故不虚。第二何以故是长者先作是意下释明方便度众生。本不欲与小故。第三以是因缘下总结也。从何况长者自知财富无量欲饶益诸子等与大车是第三明过本所望不虚。所言过本望者故如昔日许施甲人木案。此人后来遂惠玉案。然昔许惠木今忽得玉。今昔相违实是虚妄。无奈今日重宝夺昔轻货。贪宝情重不许相违昔日本许惠三界外尽无生智。今既出三界仍为受记得佛一切种智。岂非过本所望也。佛告舍利弗此下是第三明如来述舍利弗结成不虚也

舍利弗如来亦复如是正譬说。长行中本有两段。第一开譬竟。自此下竟长行是第二是合譬段也。但上开譬之中本有十譬。今此合譬中唯合七譬。略不合第六长者欢喜。略不合第七诸子索车。略不合第九诸子得车故欢喜譬也。所以尔者子既出难父乌得不喜。是故合第五义兼第六。又合第八义兼第九。长者既赐大车诸子乌得不喜。故知合第八义兼第九也。所以不合第七譬者此义于今日不要。何以知然。第七是诸子索车所索之果是昔方便之教。乃更成迷惑之失。云何为要。是故略不合也。今合此七譬而文成六段。何以故然。正由第五第八两譬并作一段合之。是故成六段也。今先合第一宅主譬亦名总譬者。但上譬中本有六义。今此中唯正合第一正明宅主。义兼合余五义也。但上正明宅主义中有三段。一者明长者名位处二者正长者三者叹长者之德。今言如来亦复如是此先合第二出长者言有大长者句也。则为一切世间之父此一句即追合第一明长者名位处。上言国邑聚落三种今此一句得总合也。含灵有识亦是世间。十方世界亦是世间。的论娑婆一化之处亦是世间也。于诸怖畏此下即合第三叹长者之德。上开譬中本有三。一者有内德二者明有外德三者明有眷属。今者但合第一第二略不合第三有眷属也。于诸怖畏以下是第一合如来内德。第二从大慈大悲下竟三菩提二合如来外化之德。又此二中各有二阶。内德中有二阶者。初叹如来断功德备。怖畏等是果无明闇蔽等为因。子果既除是故断功德备也。第二从而悉成就下竟智慧波罗蜜此明叹智慧德圆也。大慈大悲此下第二合如来外化之德。此中有二者。第一明本第二明迹也。今言大慈此正明外化本就中有二。大慈大悲是章门。后两句即释之也。常无懈倦即释大悲也。恒求利益一切众生此即释大慈。是则悲欲拔苦言常无懈倦。慈欲与乐则言恒求利益也。而生三界此下是第二正明垂迹。初众生三界下讫三毒之火先谈大悲之迹拔苦。次教化令得菩提此即语大慈之迹与乐也。义兼余五义者。言而生三界朽故火宅此即是第三火宅义也。又言为度众生此即兼合得第四五百人及第六三十子也。又言生老病死忧悲苦恼之火此即兼合第五宅中之火也。又言教化令得三菩提此即是第三一门也。故言虽正合长者复得义兼余五。是故亦义皆尽

法华经疏卷第四妙法莲华经义记卷第五

        光宅沙门法云撰

    譬喻品之余

见诸众生此下是第二。即合上第二长者见火譬。明如来见众生为五浊所惛也。譬中本有三段。第一是能见第二是所见第三起悲愍之心。今合此三段。见诸众生此一句即合上第一能见。上言长者见。为生老病死此下即合第二所见。上言是大火从四面起但方便品法说中备明五浊。上开譬中止言大火从四面起此语是总。今此合譬中备明八苦。然五浊八苦等皆是烦累之法今合譬中备明八苦者。生老病死即是四苦。五欲财利即是爱别离苦。何以知之。正由五欲财货离必生苦也。贪着追求即是求不得苦。凡有二种。一者物昔属我今日忽失为追求。亦是求不得苦。二者昔来未有今求不得亦是求不得苦也。后受地狱畜生饿鬼之苦此是怨憎会苦。若生天上此下更举前苦明五盛阴苦也。众生没在其中下是第三即合上起悲愍之心。上言即大惊怖乃至无求出意。今此中言虽遭大苦不以为患。若以苦为患便求出苦既不以苦为患。故知无求出意。此中言东西者非上东西但南北为纵东西为横。一切众生皆横理用心喻若东西也。终日自劳然失避苦之方故言驰走也

舍利弗佛见此已此下是第三即合上第三长者救子不得譬。明用大乘化众生不得也。上法说中有三。第一拟宜第二无机第三息化也。但上开譬中有两段。第一据劝教作三重第二据诫教作三重。今此中合譬还作三段但方法不同。第一并叠合诫劝两家拟宜。第二叠合诫劝两家无机。第三并合诫劝两家息化也。今言佛见此已便作是念我为众生之父应拔其苦难者。牒合拟宜有二。此是第一。然拔苦是大悲之力此即先合第二诫教拟宜。上言我当为说怖畏之事乃至具告诸子也。第二与无量无边佛智慧乐令其游戏此是追合劝教拟宜。上言身手有力此明不见劝教。今不合也。当以衣裓若以机案从舍出之。此明正拟宜今正合也。但上言衣裓明大乘因机案譬大乘果。今此合中正合机案也合衣裓也。亦远拟方便品中我所得智慧微妙最一。明如来总用大乘因果拟宜众生也

舍利弗如来复作是念此下是第二。即合上诫劝两家无机。亦有二。第一合言若我但以神力先合诫家无机。上言父虽怜愍善言诱喻也。第二及智慧力舍于方便以下追合劝家无机。就中自有二。此句正合无机。第二所以者何下释无机之意。上言复更思惟是舍唯有一门而复狭小诸子幼稚未有所识也。又见一家解有二重。第一若我但以神力以下竟众生不能以是得度。正并合诫劝两家无机。第二所以者何下并释两家无机之意也。何由能解佛之智慧但此一句即是第三并合诫劝中两家息化。上劝息化言恋着戏处或当堕落为火所烧。上诫息化言但东西走戏视父而已

舍利弗如彼长者虽复身手有力而不用之。此下是第四段即合上第四长者以三车救子得譬。明用三乘化得众生也。今就此合譬中大分为三段。第一先牒三种外譬来。第二帖合第三譬。第三正合第四譬也。今者第一牒三种譬者。初言身手有力而不用之此即牒上第三外譬。次但以殷勤方便下正牒上第四外譬。次然后各与珍宝大车此下牒上第八外譬。言如来亦复如是虽有力无所畏而不用之此即第二帖合上第三外譬也。但以智慧方便下第三正合第四譬也。今四重料简将欲合第四。所以牒第三譬来者。为欲示圣人出世之意。意在大乘。所以复牒第四譬来者。为示如来施权道意。但众生无有堪受大乘之机。然事不获已用三乘化。是故牒第四譬意在于此。所以复牒第八外譬来者。为示善始令终之意。虽复中间施小意存于大。是故牒第八来显与大之意。所以帖合第三者。上已合竟既被牒持。是故帖合第三令属上也。所以不帖合第八者。下文自合何须帖合也。今第三段正合第四救子得譬。但上譬中本有四种。一者用三车拟宜。二者见子有宿好之心。三者为说三车。四者诸子受行。此中亦具合四段。今言但以智慧方便一句此即合第一长者用三车拟宜。上言是时长者即作是念此舍已为大火所烧我及诸子若不时出必为火所焚我今当设方便也。于三界火宅拔济众生此一句是第二合上第二见子有宿好之心。上言父知诸子先心各有所好奇异之物情必乐着为说三乘。此下是第三即合上第三为说三车。但上说三车中有四阶。一者赞叹三车。二者示三车处。三者劝取三车。四者保与不虚。今者亦具足此合四阶。但不次第。先合第二示三车处。第二仍超合第四保与不虚。还合第三劝取三车。第四追合第一赞叹三车也。今言为说三乘此下四行半。先合上第二示三车处。即是示三乘人尽智无生智在三界外。上言如此种种羊车鹿车牛车今在门外可以游戏也。我今为汝保任此事终不虚也一句。此即超合上第四保与三车不虚。即保与三乘人尽智无生智。上言随汝所欲皆当与汝也。从汝等但当勤修精进如来以是方便诱进众生此二句。退还合第三劝取三车。上言汝等于此火宅宜速出来即是劝三乘人修行取三乘果也

复作是言汝等当知此三乘法皆是圣所称叹此下三行半即追合上第一赞叹三车。即是赞叹三乘。上言而告之言汝等所可玩好希有难得汝若不取后必忧悔。罗汉断三界结尽不复为惑所制故言自在也。若有烦恼可系三界。烦恼既亡故言无系也。昔日未得无学之时有依有求。既证无学德之极果故言无所依求也。乘是三乘者罗汉于时尽智无生智此二智为果。所以言乘者。然入无余涅槃之时因尽无生智自运入无余涅槃。是故有果乘之义便得无量安稳快乐者即无余涅槃乐也

舍利弗若有众生内有智性。此下即合上第四段诸子受行。上言尔时诸子闻父所说珍玩之具适其愿故。但上诸子受行中本有四阶。今具足合上四阶但法用不同。上譬中直总就三乘人作四阶。今此中历别就三乘人各作四阶正合。后举外譬帖合。即作三重四阶。正合后帖合也。今先就声闻乘作四阶正合者。初言从佛世尊闻法信受此则合上第一心各勇锐生外凡夫善根也。殷勤精进此一句。即合上第二互相推排生内凡夫善根也。欲速出三界自求涅槃是第三阶。即合上第三竞共驰走声闻乘人。闻佛说法进入无相行。见谛思惟治道断结也。是名声闻乘。是第四阶即合上第四阶诤出火宅得罗汉果也。如彼诸子下即举外譬帖合也

若有众生此下是第二就辟支佛乘又作四阶正合之。初言从佛世尊闻法信受。此即合第一心各勇锐缘觉乘人闻佛说法生外凡夫善根也。殷勤精进此即合第二互相推排生内凡夫善根也。求自然慧此下即合上第三竞共驰走。明中乘人闻佛说法。进入无相行见谛思惟治道断结也。所以言自然者二谛境是自然。今慧从境受名呼慧为自然也。是名辟支佛乘。此即合第四诤出火宅证无学果也。如彼诸子下即举外譬帖合之也

若有众生此下是第三菩萨乘人又作四阶正合之。初言从佛世尊闻法信受。此即合第一阶心各勇锐生外凡夫善根也。殷勤精进此是第二。即合互相推排明菩萨闻佛说法。生内凡夫善根也。求一切智此下第三。即合上竞共驰走菩萨闻佛说法。进入无相行见谛思惟断结也。佛智者即是三乘中佛果也。自然智犹如前释也。无师智者正明断习气尽成无学果。呼无学智为无师智也。是名大乘此是第四。即合上诤出火宅证无学果。如彼诸子下即举外譬帖合也

舍利弗如彼长者见诸子等安稳得出。此下是第五段。即并叠第五第八两譬。所以并合两譬者。既不合第六第七。故两譬相并。正由见大乘机发即为说大乘也。今就此中自分为两段。第一先牒两家外譬来第二正合两譬也。初先牒第五外譬。次从自惟财富下即牒第八外譬也。如来亦复如是下第二正合两譬。今先合第五见子出难譬明大乘机发也。上开譬中本有二。第一先明断惑出三界外登无学果。二者正明大乘机发。今具合两重。如来亦复如是竟出三界苦怖畏崄道。即合上第一见诸子等安稳得出句也。得涅槃乐此即合第二正明大乘机发。上言皆于四衢道中露地而坐无复障碍。今言得涅槃乐。此涅槃乐是大乘善机家果。今举果目因亦可因中说果也。若使理中为论既度二种生死。应是常住涅槃。而今此教未明此理故名复倍上数以为涅槃

如来尔时此下是正合第八长者赐子大车譬。明为说法华经。但上开譬中本有两段。第一双开两章门。第二双广释两章门。但上开譬中逐文句起尽宜合为两段。今此合譬之中有合不合有不次第。宜追开为六段。何者心平等章门一也。一大车章门二也。广一大车三也。释广大车四也。广心平等五也。释广心平等六也。今此中唯不合第六释广心平等。上言所以者何以我此物周给一国犹尚不匮何况诸子。今不合此也。虽合余五阶又不次第。第一先合第四仍势合第五。然后追还合第一第二第三也。今言如来尔时便作是念竟诸佛法藏即合第四释广一大车。上言所以者何是大长者财富无量种种诸藏悉皆充溢也。此义具如上释也。是诸众生皆是我子此下竟而灭度之。即是合上第五广心平等。上言而作是念我财物无极不应以下劣小车与诸子等今此幼童皆是吾子爱无偏党也。是诸众生脱三界者悉与此。即追还合第一心平等章门。上言各赐诸子等。今言悉与。悉与只是平等之义也。诸佛禅定解脱等娱乐之具此即合第二所赐物章门。上言一大车也。皆是一相一种圣所称叹能生净妙第一之乐。此即合第三广一大车。上言其车高广等句也

舍利弗如彼长者初以三车诱引诸子此下是第六段。即合上第十不虚妄譬。但上开譬中本有三段。第一明如来作不虚譬问舍利弗。今不合也。第三明如来述成舍利弗。今而不合也。唯名第二舍利弗答佛正明不虚。今合此譬中宜分为四。第一先更牒上三种譬来第二正合第三释合第四结合也。第一先牒上三种譬者。舍利弗如彼长者牒第一譬。初以三车诱引诸子牒第四譬。然后但与大车以下牒第八譬也。如来亦复如是此下是第二正合。上身子仰答佛明不虚。但上答中本有二。初总答明不虚。第二别答明不虚。今言如来亦复如是无有虚妄。此即合上不也。世尊总明不虚也。初说三乘此下即合上别明不虚。就中本有三种。今次第合之。初说三乘此即合上第一以与重夺轻不虚也。次言引导众生即合第二称本心不虚也。然后但以大乘而度脱之此即合第三与过望不虚也。何以故此下是第三释合也。舍利弗以是因缘此下是第四结合也

而说偈言譬说开三显一化中根人本有四段。但第一正譬说中有两段。第一先明舍利弗请。第二是如来答前言。此两段各有三。佛答中有三具如前述。第一是缘起。第二从若国邑聚落竟百行偈是正譬说。第三汝舍利弗我此法印下六十五行偈奖劝受行也。前又解云此三段中各开为二。缘起有二者。一呵二许也。正譬说中有二者。第一是长行二者偈颂。自此以下有百行偈是第二重颂也。但上长行中本有二。第一开譬第二是合譬也。今就百行偈中亦分为二。第一有六十五行半偈颂上开譬。第二告舍利弗我亦如是下有三十四行半偈颂合譬也。上开譬中本有十譬今唯颂九譬。略不颂第十不虚妄譬。何以故然。旧解言所以不颂第十者。上不虚妄譬本是舍利弗作此不虚妄譬。今者是佛说偈云何用佛说偈颂舍利弗语耶。今一家所习不用此解。凡如此处亦复何限。故如寿量品中佛作医师不虚譬。问弥勒弥勒答佛明不虚。及至下佛还舍弥勒不虚譬。又如分别功德品中佛说长行弥勒偈颂如此。比例实为不少。今所以不颂者。明不虚之意本令物得实解。时众既得信心不虚妄义其意自显。是故略不颂第十不虚譬也。今六十五行半正颂九譬亦开为九段。第一有三十三行偈。颂第一宅主譬亦名总譬者。第二从是时宅主在门外立下有两行偈。颂第二长者见火譬。第三长者闻已惊入火宅有六行偈。颂第三长者救子不得譬。第四尔时长者而作是念诸子如此益我愁恼下有七行半。颂第四长者救子得譬。第五长者见子得出火宅下有三句偈。颂第五见子出难譬。第六坐师子座而自庆言下有四行一句。颂第六长者欢喜譬。第七尔时诸子知父安坐下有三行偈。颂第七诸子索车譬。第八长者大富库藏众多下有七行半偈颂。第八赐大车譬。第九诸子是时欢喜踊跃下有一行半偈。颂第九诸子得车故欢喜譬也。三十三行偈颂第一。两行偈颂第二。六行偈颂第三。七行半偈颂第四。三句偈颂第五。四行一句颂第六。三行偈颂第七。七行半颂第八。一行半颂第九。上宅主总譬中本有六义。今者唯颂四义略不颂第三一门第六三十子也

今三十三行分为四段。初一句颂第一长者。第二有三行一句颂第二一大宅。第三有半行颂第四五百人。第四余有二十九行偈颂第五宅中火起也。上明长者中有三。初若国邑聚落者名位之处。第二有大长者正明长者。第三其年衰迈下叹德也。今言譬如长者此一句唯颂有大长者也。名位处及叹德略不颂也。有一大宅此下三行一句颂大宅。人多用此偈颂国邑聚落此则不然也。正颂其家广大。但譬中直言其家广大。今此第二广叙大宅之相。然文句与上第五叙火相相类。虽类而非。下自别有文句颂火起也。既以三界为宅故大也。三界念念无常故顿弊。色无色界如堂欲界如舍然三界无安故言高危也。命如柱根亦念念无常故言摧朽。心识如梁栋亦念念生灭故言倾斜也。业为基陛既是无明相惑虚构横造故言颓毁也。四大如墙壁皆为无常所坏故言圮坼也。色香味触皆念念无常故言泥涂褫落也。四威仪不周正故言覆苫乱坠也。又言头发牙抓庄严身者也。五识取缘不复相应。亦即体念念生灭故见椽梠差脱也。又言五根也。圣人捷疾智观观此无常之境。故言周障屈曲。屈曲者委悉也。有五百人止住其中。此半行是第三颂上五百人也。鸱枭雕鹫此下有二十九行。是第四颂第五火起也。上言堂阁朽故墙壁颓落乃至周匝俱时欻然火起也。但上长行不的道三界。今偈中委悉。是故别明三界火起。今二十九行偈分为四。初有二十二行偈明宅中火起。即是欲界火起。第二从恶兽毒虫下有三行半偈。明窟穴中火起即是色界火起。第三从蜈蚣蚰蜒下有两行半偈。明虚空中火起即是无色界火起。第四其宅如是甚可怖畏下一行总结火起也。就前三段中各有四阶明义。第四止一不开也。今且就前二十二行明欲界火起中有四阶者。第一有十七行半偈。先叙列所烧众生。第二是朽故宅属于一人下一偈明欲界火起所由。第三于后宅舍忽然火起有两行偈正明火起。第四诸鬼神等扬声大叫有一行半偈总结被烧之相也。又就前十七行半偈中自有三段。初有六行偈先别出五钝使众生。第二从处处皆有下十行偈又别出五利使众生也。第三从夜叉饿鬼下一行半偈总结被烧众生也。就前二阶中各有二。第三不开也。就六行中自有二者。初有五行半偈别出五钝使众生。第二有半行总结五钝使众生也。今五行半明五钝使众生即成五阶。初半行明慢使。二一行半明嗔使。三一行明痴使。四两行明贪使。五二句明疑使也。初鸱枭雕鹫下半行先明慢使众生也。次蚖蛇蝮蝎下有一行半明嗔使众生也。次屎尿臭处下一行明痴使众生。屎尿等以譬五尘。然众生贪着五尘如蜣螂等贪屎尿也。狐狼野干此下两行明贪使众生。然死尸等且譬五尘。众生竞取五尘色声香味触故言咀齰也。更相劫夺横取无道故言践蹋也。斗争龃掣啀喍吠嗥此二句明疑使众生。思因果之理为有为无未判见心如两狗未决也。其舍恐怖变状如是此下半行是第二总结五钝使众生也。处处皆有魑魅魍魉此下十行第二别出五利使众生。亦有二者。初此半行偈先总明五利使众生。第二有九行半别出五利使众生。然前明钝使众生初别后总明。五利使众生初总后别也。夜叉恶鬼此下九行半是第二别出五利使众生。既明五利使即成五阶。初三行明邪见。次两行半明戒取。次一行半明我见。次半行明见取。次两行明断常二见。是边见也。夜叉恶鬼下三行先明邪见众生者谤无因果。然因果即是四谛谤无灭道因果如食啖人肉也。毒虫之属以下明无苦集。就中先一行列出苦集。次一行半正明谤也。孚乳为因即是集谛。产生为果即是苦谛。皆有苦集各不相关故言各自藏护也。夜叉竞来此下一行半是第二正明邪见众生谤无苦集因果也。邪见缚成上品故言恶心转炽也。缘邪论僻义故言斗诤之声也。此必招三涂之苦故言甚可怖畏也也。鸠槃荼鬼此下两行半偈是第二阶明戒取众生。即是持鸡狗鹿戒也。平地小高称为土埵。欲明戒取众生伏三涂因。生人天之中如土埵也。有时厌欲界之苦伏欲界结暂生色界如离地一尺也。有时厌色界之苦即伏色界结暂生无色界如离地二尺也。伏结生色无色界如往然。暂时折伏。非是永伏还复退三途故言反也。此戒取众生非是如理用心故言纵逸。劳而无功故言嬉戏也。捉狗两足扑令失声者有人解言。色界众生谤无色无因无果如捉狗两足。又谤欲界无因无果如以脚加颈一。往乃类核实不然。今明欲界有十使众生下自别有文明色界。那得言是色界耶。今捉狗两足扑令失声者谤无苦集。令因果理绝而不通故言失声也。以脚加颈怖狗自乐者谤无灭道二谛也。又解谤无业烦恼为集故言捉狗两足等也。复谤无苦为果故言以脚加颈等也

有诸鬼其身长大此下一行半明我见众生我大色小故言长大也。既无惭愧故言裸形也。复有诸鬼其咽如针。此半行明见取众生不能自计证成他见是事实余妄语也。复有诸鬼首如牛头此下两行明断常二见众生。牛首有两角譬断常二见必相随也。从夜叉饿鬼诸恶鸟兽下一行半是第三总结被烧众生不开也。色无色界如窗牖窥看上界之明也。是朽故宅属于一人。此一行是第二明欲界火起所由。只由长者暂行不在致令宅中火起。内合明如来昔日已曾化此众生。于时暂得折伏烦恼不起。无异长者在时有火未起。感缘既尽如来更历他方。然此众生遂复更广起烦恼郁然火盛。故云火起所由也。于后舍宅欻然火起此下两行是第三正明欲界火起。即是正颂欻然火起句也。诸鬼神等扬声大叫此下一行半偈是第四总结欲界众生被烧之相也。恶兽毒虫此下三行半偈是第二明色界火起。就中亦有四阶者。初一行先明欲界众生为烦恼八苦所恼。故仍伏欲界结生色界为藏窜孔穴也。第二言薄福德故一句明火起所由也。第三言为火所烧一句正明色界火起也。第四余有两行明色界众生被烧之相也。蜈蚣蚰蜒此下两行偈第三明无色界火起。亦有四阶者。初一行先明色界众生伏色界结。生无色界也。第二言鸠槃荼鬼随取而食。此半行明火起所由。由彼处邪见人教化而取故言随取而食也。第三言又诸饿鬼头上火燃此半行正明无色界火起也。第四饥渴热恼周障闷走此半行明被烧之相也。其宅如是甚可怖畏此下一行是大段第四总结三界火起不开也

是时宅主在门外立此下两行偈颂上第二长者见火譬。譬中本有三段。一者能见二者所见三者起悲哀之心。今此中不颂起悲愍之心。虽不颂悲愍之心。犹成三段。上直言长者见火然不出见处。今此中长出见处以长补所阙终成三段也。三段者。第一半行先出见火之处。第二一句颂能见。第三一行一句颂所见也。今者第一言是时宅主在门外立。先出见火之处。然立是欲行之相。如来在法身地将欲应来三界接化众生。犹如长者欲入门也。闻有人言。此一句是第二即颂上能见。上言长者见今此中言闻此则以闻代见。上譬道见此明如来有照机之智。此中道闻即谈感圣人之机。然感佛出世之机来关圣智。如闻有人言也。汝诸子等此下一句是第三即颂上第二所见。上言是大火从四面起。向言闻有人言闻何所道。正言汝诸子等。先因游戏来入此宅有人解言。从三界外流来入三界中。故言入此宅。今所习不然。昔二万亿佛所已曾受大乘化。即是父子义。故言汝诸子等。先因游戏来入此宅者故如遗教所明。其未度者皆亦已作得度因缘。昔有大乘解之时于时位心皆作出生死意。后起烦恼失大乘解即便成入生死义。来入之义其意如此。稚小者于时大乘解弱故言稚小。只由解弱故失解起烦恼故言无知也

长者闻已此下有六行偈。颂第三救子不得譬。上譬中本有诫劝两段。两段之中各有三阶。即是拟宜．无机．息化。今此中亦备颂上两段。各三阶者但方法不同。法不同者就此六行中分为三段。初言长者闻已已下五行颂两家拟宜。次有二句颂两家无机。次有二句颂两家息化也。长者闻已下此三段各有二。第一一偈先颂劝家拟宜。即是身手有力下是也。二告喻诸子下有四行偈即颂诫家拟宜。即是我当为说怖畏之事下是也。诸子无知下二句是第二。即并颂两家无机。有二者。初言诸子无知一句即劝家无机。上无机中本有二。今不颂第一大乘教于其无用。即是是舍唯有一门而复狭小唯颂有小无大。今此诸子无知一句总颂上有小无大。即是诸子幼稚未有所识也。二虽闻父诲一句即颂诫家无机即是父虽怜愍善言诱喻也。第三两句颂两家息化自有二者。初句即颂劝家息化即是恋着戏处也。二嬉戏不已一句即颂诫家息化。上言东西走戏视父而已也。又解言。不颂劝家三段唯颂诫家二段。前五行颂拟宜后一行颂无机不颂息化。上拟宜中有二。第一思惟救子方法。第二正拟宜。此中亦分为二。初一行颂思惟方法。第二告喻诸子下四行正颂拟宜

是时长者而作是念此下有七行半偈。颂上第四长者以三车救子得譬。但上譬中本有四段。第一以三车拟宜二者见子有宿好之心。三者为说三车四者诸子受行。今此中略不颂第二见子宿好。上言父知诸子先心各有所好奇异之物情必乐着也。今七行半中分为三段颂上三段初三行先颂第一三车拟宜。次三行超颂第三为说三车。次一行半颂第四诸子受行也。今尔时长者而作是念下三行颂第一三车拟宜。即是尔时长者即作是念此舍已为大火所烧下是也。告诸子等此下三行即是超颂第三为说三车。上说三车中本有四阶。今三行具足颂之。一行颂第一三句颂第二。又三句颂第三。半行颂第四也。今告诸子等一行即颂第一赞叹三车。上言而告之言汝等所可玩好希有难得汝若不取后必忧悔也。次羊车鹿车此下三句即颂第二阶示三车处。上言如此种种羊鹿牛车今在门外也。汝等出来又有三句。即颂上第三劝取三车。上言汝等于此火宅宜速出来也。次随意所乐可以游戏。此半行即颂上第四保与不虚。上言随汝所欲皆当与汝也。诸子闻说如此诸车此下一行半颂第四诸子受行。上受行中本有四阶。今唯颂三阶略不颂第二互相推排也。初诸子闻说如此诸车此半行。先颂心各勇锐外凡夫行也。即时奔竞驰走此六字。即颂竞共驰走见谛思惟修道行也。而出下半行二字。即颂诤出火宅得无学果也。又解云。略不颂前二唯颂后二也

长者见子得出火宅此下有三句。即颂第五见子出难譬也。上譬中有二。一者先明断惑出三界得无学果。二者正明大乘机发初二句先颂无学果也。住于四衢一句正颂大乘机发也

坐师子座此下有四行一句颂上第六长者欢喜。今就此四行一句中自有三段。初三句正颂欢喜踊跃也。此诸子等此下三行释致喜所由。由脱难故所以欢喜也。是故诸人我今快乐此半行是第三结欢喜也

尔时诸子知父安坐此下有三行偈。颂第七诸子索车明三乘人索果也。就此三行中自有四阶。半行明索车时。一行正颂索车。一行明颂如来于时许车之辞。半行即结颂索车也。今者尔时诸子知父安坐下此半行。是第一先明索车时只是知父安坐之时。内合明如来见众生大乘机发称如来本意。故言安坐也。皆诣父所此下一行是第二正颂上索车也。如前所许一行是第三即颂如来于时许车之辞也。今正是时下半行是第四即结颂索车也

长者大富此下有七行半颂第八赐大车譬。即是说法华。上譬中本有两段。第一先双开两章门第二双广释两章门。今七行半亦分为二。初有七行先颂上第二广章门。第二余半行追颂开两章门。又此颂广之中唯颂广一大车不颂广心平等。但广大车本有二。一者正广二者释广。今初有一行半颂先颂释广大车即是。所以者何是长者财富无量也庄校严饰。此下五行半即追颂上正广大车。上言其车高广众宝庄校也。以是妙车此下半行是第二即追颂上开两章门。此一句先颂一大车章门也。次等赐诸子一句即追颂心平等章门也

诸子是时欢喜踊跃此下有一行半偈即颂第九诸子得大车故欢喜譬。上言是时诸子各乘大车得未曾有也。略不颂第十不虚也

告舍利弗我亦如是此下有三十四行半偈是第二即颂长行中第二合譬段也。又上合譬中唯合七譬不合第六第七第九也。虽合七譬并合第五与第八譬。故文句成六段。今此中亦颂合七譬文便成七段。但七名虽同意致有异。上长行不合第六第七。今亦不颂。上合第一第二第三第四第十譬。今亦颂之。上并合第五第八譬。今偏颂第八譬。上合第五不合第九。今此中义颂合第九略不颂第五也。今就三十四行半中。亦分为七段。第一有四行颂合第一宅主总譬。第二如来已离三界火宅下有两行颂合第二见火譬。第三而今此处多诸患难下亦有两行颂合第三救子不得譬。第四是以方便为说三乘下有四行颂合第四救子得譬。第五汝等若能信受是语下亦有四行颂合第八赐大车譬。第六得如是乘令诸子等下有三行义颂合第九诸子得车欢喜譬。第七告舍利弗汝诸人等下有十五行半颂合第十不虚妄譬也。四行偈颂合第一。两行偈颂合第二。两行偈颂合第三。四行偈颂合第四。四行偈颂合第八。三行偈义颂合第九。十五行半偈颂合第十。上合第一宅主总譬中唯正合一长者义。义中复得兼合余五义。今此四行偈得颂兼合五义唯略不颂合一门也。今言我亦如是一行先颂合长者上言如来亦复如是也。世间之父一句即颂合则为一切世间之父也。一切众生皆是吾子此一切即得颂合两义。初言一切众生即得颂合五百人也。皆是吾子下三句即得颂合三十子也。三界无安下一句偈即得颂合有一大宅义也。常有生老下此一行即是颂合宅中有火义也

如来已离此下两行即颂合第二见火譬。上言见诸众生为生老病死。但上合譬中且合三种。一者合能见。二者合所见。三者合起悲愍之心。今此两行唯得颂合能见所见不颂合悲愍之心也。虽然犹成三段。何以知然。正犹长出如来见众生之处故也。今言如来已离三界火宅下一行。先出见众生之处。次半行颂合第一能见。次半行颂合第二所见也。今第一一行明见众生之处。如来久绝三界之累故言已离也。怕然在法身之地言寂然间居也。林者无漏法林也。栖神在法身之地。纵任居累碍之表故言安处林野也。然法华经所明法身者不同常住也。解有二种。一云延金刚心久住世者以为法身。又云正明总十方诸佛更互相望。故知无量寿即时在西方教化未来此间。此间望彼彼即是法身。然应身本有形有像。法身本无形像。佛既未来此间于此间即无形无像。即是法身。若来应此间即于应此间是应身。他方望此间即持此间作法身也。今此三界皆是我有此半行是此中第二即颂合上第一能见也。其中众生悉是吾子此半行是此中第三即颂合上第二所见也

而今此处此下有两行即颂合上第三救子不得譬。但上开譬中本有诫劝两段亦各有三。及至合譬之中分为三段。即叠合诫劝拟宜叠合两家无机又叠合两家息化。今此两偈唯颂合诫边。但诫中本有三。今此中略不颂合诫息化。唯颂合诫拟宜与无机。今言而今此处多诸患难唯我一人能为救护此一行正颂合诫拟宜。上言佛见此已便作是念我为众生之父应拔其苦难也。虽复教诏而不信受此一行即颂合上诫无机。上言若我但以神力下是。今言虽复教诏而不信受显无机。若以神力通之无有信受。下即释言于诸欲染贪着深故也

是以方便此下有四行即颂合第四救子得譬。上合第四譬。中本有三段。第一先牒举三种外譬。今者不颂也。第二言如来亦复如是虽有力无所畏而不用之即帖合第三外譬。今者亦不颂也。唯颂第三段正合第四譬。但上合第四譬中本有四段。今此中略不颂合第二于三界火宅拔济众生见机之义。今此四行中有二重。第一三行正颂上合三段。第二一行合三以为一结成上义。此是义出不颂上也。今就三行中初一句颂合第一以三乘拟宜。次一行一句颂合第三为说三乘。次一行半颂合第四诸子受行也。今言以是方便一句是颂合第一用三乘拟宜。上言但以智慧方便也。为说三乘此下一行一句是偈中之第二。即颂合上第三为说三乘。上说三乘中本有四阶。今此一行一句唯得颂合一阶即是示三果处。上言汝速出三界当得三乘声闻辟支佛佛乘示三乘人果处也。自余三阶略不颂合也。是诸子等若心决定此下一行半是偈中之第三即颂合上第四诸子受行。但上合譬中历别。就三乘人各作四阶。今者亦就三乘颂合。但不尽合四阶唯各得颂合三人第四阶。今一行半自有二。初总后别今言是诸子等若心决定。此半行总明三乘人皆得无学果并是决定之义也。下一行别明三乘人得无学果。初言具足三明及六神通此半行即是声闻决定果正颂合上是名声闻乘。即是开譬中诤出火宅也。有得缘觉一句即是颂合上是名辟支佛乘。缘觉无学果即是开譬中诤出火宅也。不退菩萨一句即是颂合上是名菩萨乘。即是得无学果。亦是开譬中诤出火宅也。汝舍利弗我为众生下一行。第二合三以为一结成上义也。此一行是义出不颂上今犹属上也

汝等若能信受是语一切皆当成得佛道。此下有四行即颂合第八赐大车譬。但上正合第八譬中追开作六阶。唯合五阶不合第六阶也。今此四行分作两段。第一此一行偈中得颂合两阶。即是上是诸众生脱三界者悉与诸佛禅定解脱等即是心平等及所赐物等之义也。是乘微妙清净第一下三行颂合上广大车。上言皆是一相一种圣所称叹能生净妙第一之乐也。故此四行唯得颂三阶也

得如是乘令诸佛子下三行即义颂合第九诸子得大车故欢喜譬。上长行中本不合此第九。今者义颂合也。然此三行中初二行正义颂上明行一因得一果故定喜也。第二以是因缘下一行明无异因也。今第一乘是宝乘直至道场者。明如来既为三乘人受记未来得佛。于时时众相与标心买当来佛果之上修习进行。即是乘是宝乘是境界乘也。直至道场者万行皆是至道场。但其金刚心时剩得佛最近修行至金刚。此是直至道场之义也

告舍利弗汝诸人等此下有十五行半偈。并颂合第十不虚妄譬。上合譬中本有四段。第一先牒上三种外譬来第二正合。第三释合。第四结合也。今唯颂第二正合余者悉不颂也。上第二正合不虚妄中自有二。初言如来亦复如是无有虚妄此则总明不虚。今者亦不颂合也。今唯颂合三种别明不虚以重夺轻。不虚称本心。不虚与过望不虚。今就此十五行半偈中大分为三段。初有一行偈是第一先明父子相关以开不虚之端。内合明如来昔日已曾二万亿佛所化此众生。于时众生生大乘解即是子义。然解不孤生生由于佛。如来有生物解之能。即是父义也。第二有十三行半正颂合上三种不虚也。第三余一行即举法王。结明不虚之意也。又此三段前一后一并皆不开。中间一段自有三段别也。初有两行半先略颂合三种不虚。第二有二行将欲广颂合先引证劝信也。第三有九行正广颂上第一略颂合不虚也。今言两行半略颂合者。初一行颂第一。次一行颂第二。次半行颂第三也。今者第一汝等累劫一行即颂合以重夺轻不虚。上合譬言初说三乘只一句也。我虽先说此一行即颂合称本心不虚。上合譬言引导众生亦只一句也。但尽生死者但生死有二种。然分段中苦恼深重。是故三乘方便引汝令离炎灼之苦。唯尽分段生死未尽变易生死。故言但也。复应进断变易成无上道岂应止此灰身灭智。故言而实不灭也。今所应作唯佛智慧此半行即颂合与过望不虚。上合譬言然后但以大乘而脱度之也。若有菩萨此下两行是第二引胜人。证如来不虚劝信。此两行即成二意。初偈正引证。后即出证人之语也。若人小智此下有九行偈是第三。即广上第一略颂合三种不虚也。今此九行自分为三段。初有六行即广上。汝等累劫下一行略明以重夺轻不虚。就此六行中初二行明苦谛。二行明集谛。一行明灭谛。一行明道谛也。第二从是人于何而得解脱下有一行半即广上。我虽先说一偈称本心不虚也。第三从佛说是人未实灭度下有一行半即广上。今所应作唯佛智慧半行明与过所望不虚也。我意不欲令至灭度者此则取上语。其义可求。斯人若未得无上道之时我意。终不只令至昔日灭度也。我为法王于法自在向言十五行半大分为三段。此下一行是第三举法王结明不虚。然不自在人出言多虚。佛是法中之王实不虚也

从汝舍利弗我此法印又前判云正譬说开三显一化中根人中本有两段。第一是舍利弗请其中自有三段已讫也。第二是如来答亦有三段。第一是譬说缘起其中有二。初呵后许也。第二正譬说开三显一其中有二。即是长行与偈亦已讫也。中根之人既解同归之理先三后一之意。故自此下尽品有六十五行偈是第三即奖劝中根人受行。然奖劝之意祗明弘经益物自行化他。种同归之因感圆极妙果也。菩萨万行乃备众德皆修。若的明要者不出自行化他。自行则如说修行化他则弘经益物。兼除老病菩萨之谓也。但慕果之心易生行因之意难立。是故此中单劝慕果。既愿行因贫福自显。此意已具如前述。不复细解。又解所以不劝慕果者与授记品相近故不劝慕果也。此中祗以弘经益人以为行因亦有两段。两段之者第一一行偈先出所弘之经。第二从在所游方下有六十四行偈正示其弘经益物之方也。今第一言我法印者即是所弘之经。印者故如此人名字印此函书送与所与之人。莫与所不与之人。然法华经犹如函书。但经中所明因果犹如书中所表之事也。如来言教题此经名字犹如印也。弘经菩萨如送书人也法印深意其义如此

从在所游方勿妄宣传此下六十四行是第二正示其弘经益物之方奖劝行因之意。此中自有三段。初有半行据总略劝弘经益物。第二若有闻者下有十行偈据别略劝弘经之方。第三若有不信毁谤此经下有五十三行半偈广示弘经方法表行行因之相

今言在所游方勿妄宣传者是第一。然勿妄之言其意难了。今且作四句明之。一言恶人莫为说此亦是勿妄。二者恶人亦为说善人亦为说此亦是勿妄。三者恶人应为说善人莫为说。四者善人应为说恶者莫为说。今不同前三句。何故前三句太甚通漫故。的取第四句正恶人莫为说善人应为说。问者言如来慈父等视如子且又放光普照有识皆蒙。今复言善人应为说恶人莫为说非唯生分别之心。亦违慈父之意。解者言放光普照表慈悲平等。今明善人应为说恶人莫为说。此则示身子弘经益物之方。善人应为说即是劝善恶人莫为说即是诫恶。且又强为恶人说者非唯直生不信之心。亦复增长诽谤之罪。是故涅槃言诸佛圣人不为众生作烦恼因缘。又欲斥彼恶人令改恶行善也

若有闻者此下十行偈是第二据别略劝弘经之方。此第二段望上总则成别。望下广故称略也。今就此十行偈中自有两段。第一有四行先劝善人应为说。第二斯法华经下有六行偈诫令莫为恶人说也。此两段中各有三。今且就前四行善人应为说中自有三种善人。初一行先明不退转人应为说。阿者言无鞞跋致言退。无退之人应为说也。第二若有信受下一行半明过去久种善根之人应为此人说也。第三若人有能下有一行半偈。则明未来世中常值善知识人应为此人说也。此三种人即成三世初明不退之人。即是现在次明久种善根人。即是过去后明常值善知识人。即明过去久种善根人即此人未来世中当得相值。但互举一边为义也。斯法华经此下有六行是第二诫令莫为恶人说。此六行中亦有三种者。初一行先明浅识之人莫为说。第二一切声闻下三行举有信之人。况出不信之人。及取即得不信之人也。第三又舍利弗下两行更出恶人总结莫为说。初偈明我见之人不应说。后偈多爱染之人勿为说。问者言。上言宿习强者虽有三种五浊不能为障。今何故言莫为此人说耶。解释者言。此有二意。一者正为劝奖中根人弘经方法。二者亦为斥即时众中有懈怠之者也

若人不信毁谤此下五十三行半偈是第三广示弘经益物行因之方。今就此五十三行半偈中大分为两段。第一有三十四行半广示恶人莫为说。此即广上第二六行略明恶人莫为说。第二从若有利根以下尽品有十九行偈。广明善人应为说。此则广上第一四行略明善人应为说。为广之意其意如此。今且前明恶人中自有三。第一有四行半偈据行恶因明恶人。第二从其人命终下有二十八行偈据得恶果明恶人。第三佛告舍利弗谤斯经者下二行。第三总结恶人之相也。今且就前四行半明行恶因中自有三种恶因。初一行偈先明谤法之人莫为说。第二一行有疑惑人莫为说。第三两行半谤弘经人莫为说也。今第一一行偈明谤法人。既谤毁此经云何可说。即断一切世间佛种者。今此经说众生有佛种然诸听法之人既毁谤此经不得宣说。故言断佛种也。或复频蹙一行是第二明疑惑之人莫为说也。若佛在世下有两行半第三明谤弘经之人者亦不应为说也。其人命终此下二十八行是第二据得恶果明恶人。即是向者三种行恶因之人得此恶果。就中有二重。初二十二行偈正明恶果报。第二常处地狱下六行偈总结恶果之相也。又就此两段之中各有二别。今且就正明恶果中有二者。初有十二行据正报明恶果。第二若得为人下十行偈据余残报明恶果也。死被瓦石者此是世流布语。正言祗此人死后斩截之相。亦可是此人死后得宿命智见。人取其死尸屠割。于时缘此即生苦受即自知由谤经之罪也

又释此人死时终不好死死必为刀杖所加也。若得为人此下有十行是第二据余残报明得恶果。即是向者是正报者今得残报也。常处地狱此下六行是第二总结恶果之相亦有二者即结上两段。初有两行总结上第一据正报明得恶果也。第二从若得为人下有四行总结上第二据余报名得恶果也。告舍利弗谤斯经者向言三十四行半广示恶人莫为说中本有三。初有四行偈据行恶因明恶人。第二二十八行据得恶果明恶人也。已竟此下两行是第三总结恶人之相也

若有利根此下有十九行是第二广明善人应为说广上。第一四行略明善人应为说也。就中有二。第一有十七行偈正明善人应为说。第二又舍利弗我说是相下有两行总结劝善人应为说也。就前十七行偈中凡有十种乃可为说。今以义相对以为五双。第一双明现在明聪明利智过去则深种功德。此是功德智慧相对也。第二双言俯则慈愍下流仰则恭敬尊长。此是俯仰相对也。第三双言外则舍远恶缘内则奉戒清净。此是内外相对也。第四双言自行则质直柔和化他则清净说法。此是自行化他相对也。第五双言始得专念求经终则纯心顶戴。此是始终相对也。告舍利弗我说是相此下两行是第二总结劝善人应为说

    信解品第四

但解有两种。一者自以智慧明见法相此则法行人呼为见解。二者不自见理凭师谓尔此则是信行人名为信解也。今此品中明四大声闻领开三显一之义信同归莫二之理。从信得解仍詺为信解品。问只有此四人领。更有余人。解释者言但使是中根之徒得解者亦无量。但略举四人为端首耳。譬说开三显一化中根人本有四品即为四段。此一品是第二明中根人领解。又言四段之中各开为二。今此领解中有二者。第一是经家序中根人得解之相第二从而白佛言以下竟品正是中根人领解之辞。又就此两段之中各开为二。经家序中有二者。第一从尔时慧命须菩提下讫欢喜踊跃是经家序中根人内心欢喜。第二列外形恭敬也。就第一明内心欢喜中有三。初列出欢喜人名须菩提等四人。二者明欢喜所由由闻未曾有法故。三者正明欢喜也

第一所以言慧命须菩提者凡有二种解。一者言昔日未解开三显一同归之理。愚痴之人心相续为命。今日既得解权实之宗慧心相续为命。若尔亦应言慧命迦旃延乃至慧命目犍连。所以单道须菩提者此则互举为论。二者须菩提解空第一空慧为命。大品座席之时已为诸菩萨转说般若。以此呼为慧命须菩提。此即从本受名。问者言。从解空得名亦应言论义迦旃延乃至言神通目连耶。解释者言。此亦互举。若必也相兼时亦应言摩诃须菩提。何以故下三人皆有摩诃之名。而须菩提独无。故知此互举两义双明。就第二明欢喜所由中有二。初明闻未曾有法者正由闻譬说开三显一解一义故。二者明得解之资。由为上根人法说开三显一。与舍利弗授记故也

从发希有心下第三正明欢喜也。即从座起讫瞻仰尊颜是第二经家列外形恭敬。第二正领之辞中有二。第一从而白佛言以下尽七十三行半偈正领解上火宅乃至方便品中开三显一之义。第二从世尊大恩以下有十三行偈明此解由佛来。是故叹佛恩深难报以结领解。又就此两段之中各开为二。且置叹佛恩深难报至彼更分

今就第一正领解中有二。第一是长行。第二是偈颂。今就长行之中自有三段。第一先略领解。第二将欲广领解先咨审如来。第三从譬若有人讫长行广领解。又就第一第三各开为二。中间咨审止一不开

略领解中有二者。第一法说领解。第二言无量珍宝不求自得。此明譬说。广领解中有二者。第一是开譬。第二是合譬。今就略领解两段中各有二。第是开譬。第二是合譬。今就略领解两段中各有二。第一法说中二者第一先明昔日不求。第二从我等今于佛前下明今日自得。譬说亦尔。何者昔日大品座席之时我亲为诸菩萨转教说般若。明大乘因如彼说大乘果。如此而我于时于此大乘因亦不求。于大乘果亦不求。而我于时自知大乘因果是好法。只是不求。何以故口言若佛见无为入正位者不能复发菩提心。而今日值法华座席即会三成一。明声闻小行皆成佛果。此则是自得之义。只就第一明昔日不求中自有二。第一列三种不求章门。第二从无所堪任以下释上三章门。三章门者一言居僧之首故不求。二者言年朽迈故不求。三者言自谓已得涅槃故不求。此皆道昔日大品座席时事。所言居僧之首不求者。须菩提等昔日既是上座。作小乘学执教定宗位阶次第。何故尔。若学菩萨不问道俗先受戒者便为大故。我等于时有弟子皆随于我学小乘之法。我忽移心改造非谓众首之人。为此义故于大乘因果不生求心。第二上云年朽迈故不求者。菩萨之怀不惜身命无方益物。我等年时已谢何能为之。前言居僧首者明法腊已大。后复言年已朽迈者明俗年复高。但俗年虽高法腊未必大。今者法腊既大俗年又高。第三自谓已得涅槃不求者。佛昔语道有声闻缘觉菩萨。我于时既得声闻缘觉涅槃以为究竟。又闻佛言。若见无为入正位者不能复发菩提心。即是高原陆地不生莲华之义有此三义。是故不求也。无所堪任此下是第二释上三种不求章门。先释第三自谓已得涅槃章门也。世尊往昔说法既久此下释上第一居僧之首故不求也。说法既久者不言佛坐已久。只立指波若坐席故言久。于大乘因果中不作心故言疲懈。于小乘三三时中故是精进也。又今我等年已朽迈此下释上第二年并朽迈故不求章门也。我等今于佛前闻授声闻菩提记此下是第二明今日自得义也。无量珍宝不求自得此下是第二譬说。就此譬说中亦有二即为上两段作譬。今言无量珍宝不求此六字即为上第一昔日三种不求作譬也。次自得此两字即为上第三明今日自得作譬也

世尊我等今者乐说譬喻以明斯义者长行正领解中本有三。一者略领解竟。此是第二将欲广领解故先咨审如来也

譬若有人自此下讫长行是第三广领解。就此广领解之中亦有二。第一开譬。第二合譬。就开譬之中凡作九譬。领上火宅十譬。亦远领方便品中十譬之本。不尽领十譬。上火宅中本有十譬。此中唯领七譬不领三譬。不领第六父欢喜。亦不领第七诸子索车。亦不领第十不虚也。所以不领第六者只解第五免难譬第六父欢喜之义自彰。所以不领第七者。上诸子索车此即是迷惑之心是故隐而不领。所以不领第十者。上第十是不虚妄。今日既得解何假领上不虚妄。若使领者如似言不解之时。昔日有虚妄今日既无虚妄。是故不领也。上既有十譬今唯领七譬只应有七。所以有九譬者此中第四第五两譬共领上火宅中第四长者救子得譬。此中第六付财物譬不领上开三显一之意。此乃远领大品座席时意。但穷子今日深取佛意则言昔日大品时佛已令我为菩萨转教说般若。但佛于时众中令我说此大乘因果。则始终会令汝得此因果。须菩提今日既得解。是故深取此意也。九譬者第一明父子相失譬。第二明父子相见譬。第三明呼子不得譬。第四明呼子得譬。第五明教作人譬。第六明付财物譬。第七明见子长大譬。第八明付家业譬。第九明得家业故欢喜譬也。今者第一譬若有人下讫无复忧虑詺为父子相失譬。此则领上火宅中第一宅主譬亦名总譬。亦远领方便品中今我亦如是下明释迦同诸佛先三后一化五浊众生之主。第二从佣赁展转下讫我虽年朽犹故贪惜是名父子相见譬。此则领上火宅中第三长者见火譬。亦远领方便品中第二舍利弗当知我以佛眼观下明佛见众生为五浊所惛也。第三从即遣傍人急追将还以下讫往至贫里以求衣食詺为呼子不得譬。此则领上火宅中第三长者救子不得譬。亦远领方便品中我始坐道场下明佛用大乘化众生不得也。第四从尔时长者将欲诱引其子而设方便下讫愍而怪之名呼子得譬。此则领上火宅中第四长者救子得譬。譬本有四阶。今此第四譬先领前两阶三车拟宜见子宿好。亦远领方便品中第四言寻念过去佛所行方便力下。明佛用三乘化得众生亦有四阶。今亦先领前两阶以三乘拟宜及见三乘人机也。第五从又以他日于窗牖中以下讫然其所止犹在本处詺为教作人譬。此则领上火宅中第四救子得譬中后两阶为说三车及诸子受行。亦远领方便品中化得众生中后两阶为说三乘三乘人受行。是故言第四第五共领上一譬。所以尔者。法说之中偏就应身上明故合而不离。今明四大声闻领解深取佛意。就真应二身上明之故宜分为二也。第六尔时长者有疾自知将死不久竟下劣之心亦未能舍名为付财物譬。是则不领上开三显一之意。此远领昔日大品座席之时佛命须菩提为诸菩萨转教说波若之意也。第七从复经少时父知子心渐已通泰以下名为见子长大譬。此则领上火宅中第五见诸子等安稳得出下明见子出难譬。亦远领方便品中第五舍利弗见佛子等志求佛道者一偈。明如来见三乘人有大乘机发。第八从临欲终时而命其子以下名付家业譬。则领上火宅中第八长者赐大车譬。亦远领上方便品中第八于诸菩萨中正直舍方便下。明佛为时众说法华授记得佛。第九从是时穷子闻父此言即大欢喜名为子得家业故欢喜譬。此则领上火宅中第九诸子得大车欢喜譬。亦远领方便品中第九言菩萨闻是法疑网皆已除千二百罗汉悉亦当作佛。明于时时众闻说法华皆授记作佛故得欢喜三乘人受行也

就第一父子相失譬领上宅主譬亦名总譬。譬中本有六义今唯领二义。领第一有大长者化主之义。复领第六三十子义。此二义是要者。亦是方便品释迦同诸佛先三后一化众生之主。今就父子相失譬领上二义不得作二段父子相简为四重。第一明子背父而去。第二明父觅子不得。第三明子还近父。第四明父失子忧念转深。内合四重者。第一先明众生昔日二万亿佛时曾禀大乘。自尔之后失解舍如来流转六道。第二明如来从众生失大乘解之后。恒觅可化之机不得。第三内合众生从失大乘以来。在五戒十善教中。学则有机感佛出世。此则是渐近父义。第四众生既为五浊所惛如来慈恻弥深。是父忧念转深义也。又就此四重之中各有两阶。子离父中有二者。一者明子背父而去。二者明子向国而还。今言譬若有人者只明四大弟子自譬故言若有人。年既幼稚者内合明众生昔日二万亿佛所于时已曾禀受如来大乘化。但于时禀大乘化不久故言幼稚。不道大乘解小。若言解小是幼稚者。下言年既长大便应是解大。故知不名解小是幼稚。后解言只是解小故幼稚。何以知之。只是幼稚故舍父。若不幼稚云何舍父。内明为论众生于二万佛所禀如来大乘化。于时只得外凡夫解。而此解怯弱故言幼稚。舍父逃逝者隐密而去。非公灼故言逃也。逝者言去。内合众生即失大乘解理中密有背佛之义也。问者言。佛明知众生必失此大乘解。于时何故用此大乘化之。解释者言。佛于时实知众生得解之后必失但于时大乘机感佛佛仍为说大乘。若有感不应则有差机之失。既得此解如来更化他方众生遂起烦恼失此大乘解也。问者言。若佛更复教化他方众生。于后复起烦恼失解者。此则是父自离子。何关子舍父也。若是众生远佛然后起烦恼者乃可是子离父。父自往他方众生自失解故是父离子义也。解释者言。取事即然理则不然。何以知之。若是众生有机感佛。佛则住世可化之机亦尽。故佛舍此化彼正由众生感机尽故佛去不得言佛去故感机尽。既是众生感机先尽。此即是子离父义也。问者又言如来既知必失解者。昔日不应用大乘化之。解释者言。实知必失解犹用大乘化者此则为后化之资。后亦有大乘机发之时。佛言我昔日已曾为汝说此大乘。汝等于时不能坚固受持。广起烦恼遂失此解。今复为汝说而尚不坚固受持。时众既闻曾得遂失仍发决定之心。故言前失得为后资。既有资力是故如来为说。问者又言。若言失者今云何还生耶。解释者言。此失非是永断善根成一阐提。只言烦恼五浊既多于时解心不现前名之为失。夫善生必以信心为本。于时虽失大解由有信心。于五戒十善教中修行能令大乘智愿善根不断。是故我昔教汝志愿佛道。汝今悉忘。我今还欲令汝忆念本愿所行道。故若言永断者云何言忆也。问者又言。若言信心犹存者不应名作失。解释者言。乃无大乘之解何妨有小乘之信也。久住他国者大乘教己国。五戒十善经教为他国。失解之后久在五戒十善教中修行。故久住他国也。失解之后备在五道故言至五十岁也。此则释成上久住他国之义。所以言若十二十者此意明未必尽备经五道。亦可失大乘解之后经人道。仍更值如来得大乘解者。故言若十。亦可失大乘之后经畜生道或经人道。仍更值佛得大乘解者故言二十。亦可备经五道然后得大乘解者故言至五十岁也。年既长大者不道解心大。只道失解来久故言长大也。加复穷困者殆尽曰穷。复为寒苦所逼故言困。外譬为论此人年既长大复穷亦困故如即时人。昔日幼小之时率尔一丈一尺以为衣裳一斗一升可为饮食。今日人身既长大正须多衣足多食之时云何犹用昔日幼小之时衣食。充今日长大之躯理自不足。内合为义众生既离经五道。应须多功德智愿善根自资。犹用昔日微解自资者又盖无所利益故言穷困。备经卵胎湿化受生故言四方。虽然恒位心不无觅理故言求衣食也。又解五戒十善教宣辨人天因果以为四方。渐渐游行此下是第二阶明子向国而还。渐渐游行遇向本国者此人于时不作心言是向本国之行。理数尔然故云遇。但背诸国未必远向国未必近故。如始出南刹北道一步此亦是背国。若使涉北万里亦是背国。而归未必近者故如涉北万里。始回南向作意还向。始举一步此亦是向国而归。故知背国未必远向国未必近。但背国虽近有日远义。向国虽远有日近义。内合为义假设过去佛为众生说法。过去佛既灭后中间且作经一劫。释迦方出教化众生。于时背过去佛已经半劫。此是背国日远。若使后半劫去释迦出转近此则是向国而还义。故言渐渐游行遇向本国。其父先来求子不得此下是第二明父觅子不得亦有二阶。第一正明觅子不得。第二明虽失一子之苦不废家业大事。今言其父先来求子不得此是第一阶。正明觅子不得。内合明佛从二万亿佛所大乘化众失解之后。恒觅众生大乘根机都不得矣。中止一城此下是第二阶。明父虽失一子之苦不废家业大事。内合如来于此一方众生无机感可为说法。余方教化终自不废中止一城。城者防非拒难为义。如来教法为城。若言教一坐能使正理恒存。外道即隐故詺教法。为城。教明佛果备有众德故言财宝无量等。其诸仓库。仓者养命库者养身。明如来法身慧命养育众生之义也。多有僮仆者内外凡夫受学弟子如僮仆。八地以上菩萨如臣。七地以下初地以上菩萨如佐。缘觉如吏声闻如民。大乘如象。自余三乘等如马牛羊。出入息利者教。从佛宣名出化功归己如入息利也。商估贾客者商估之徒本买贱求贵。此明诸菩萨从佛受教广利益众生

时贫穷子此下是第三明子渐还近父亦有二阶者。第一明近父缘由。第二正明近父也。时贫穷子下乃至经历国邑以来第一明子得近父之缘由。由游行不已遂得近父。内合为义由众生在五戒十善经教国邑中修行不已。有感佛出世之机也。遂到其父所止之城此是第二阶正明子近父。内合众生正有感佛说法之机也

父每念子此下第四明父既失子来久忧念转深。但众生失解广起烦恼。如来慈悲愍伤其义弥至。就中亦有二阶者。第一明念子之苦。第二明假设作念得子之乐也。从父每念子下竟是以殷勤每忆其子此是第一。明父念失子之苦失解之子违离如来备经六道。故言别离。五十余年。所以言余年者解有二种。一解云。实只自有五道无别有阿修罗道。阿修罗道只摄入鬼神道。鬼神道中最胜者离出詺作阿修罗道。既被出故言余也。一家所习不然。善有三品下品感阿修罗。其多谄曲求道甚难故贬之在鬼神道也。此一段众生既失大乘解。唯如来自知一应以来不向声闻辟支佛等说。故言未曾向人说如此事也。心怀悔恨者悔在于我恨在于子。何以知之。只悔我不坚偿此儿遂令失去也。恨在于子者汝不孤然而要有父母云何都不寻求。天性存父子之义内合为论。悔我昔日二万亿佛所时用大乘化。不能得令登内凡夫信首得立使不退堕。恨者汝众生神解本异乎木石。云何不堪忆我昔大乘之化而流浪生死耶。故言悔恨也。自念老朽者废大乘来久故言老朽也。财物如前解。无有子息者无有委付以弘法绍继之人故言无有子息也。一旦终没财物散失者此明众生既无机缘。如来便舍化他方故言终没。大乘经教于众生无用故义言散失无所委付也。复作是念我若得子委付财物坦然快乐无复忧虑下是第二阶。假设作念得子之乐。内合明得众生有大机发有可化之缘。便称如来大慈悲之意。故言无复忧虑也

尔时穷子佣赁展转此下是第二父子相见譬。此则领上火宅中第二长者见火譬。亦远领方便品中我以佛眼观见六道众生等也。但上譬中唯明长者见子义不道子见父义。内合上单明佛见五浊众生有人天等小机。今此譬中委悉。先明人天小机感佛即是子见父义。后明佛见此机即是父见子义。然感应之义只感时应应时是感。然逐义为便有感故有应。不得先应后感。是故此譬中有两段。第一子见父。第二于师子座见子便识以下明父见子。就此两段中各有四阶。子见父中有四者。第一明见父缘由。第二明见父之处。第三正明见父。第四明子见父生怀畏避之心。言佣赁展转此是见父之缘由。若不佣赁何容得与长者相见。内合众生修五戒十善相资。远得助一乘机发之义也。遇到父舍住立门侧此是第二明见父之处。内合众生五戒十善小机感佛不正如立门侧也。遥见其父踞师子床此下是第三正明见父尊严。五戒十善机来窥佛故言见父也。遥者此机远窥法身地故言遥也。如来处在无畏之座如师子床也。宝机承足者有二种解。一解戒定为脚足。二谛境为宝机。一家言权实二智为脚足。二谛境为宝机如来二智常照二谛境如宝机承足也。外国言婆罗门者高良大姓八地以上如婆罗门。七地以还如刹利也。大乘内凡夫如居士也。问者言既言佛在法身地云何言有内凡夫等围绕。解释者言。此经明法身不同常住经所明法身。今此经言法身者指他方应身为法身。故如佛在无量寿国此间众生机感无量寿来应仍詺无量寿佛为法身也。真珠璎珞者解有二种。一云明诸菩萨备有功德智慧。一云佛果具有功德智慧如真珠璎珞。在辟支如吏声闻如民外凡夫如僮仆。手执白拂者三乘人用智慧手执无生之理拂烦恼尘。此乃是三乘人自拂。何故言侍佛左右即成佛。解释者言。此乃是自拂则由佛教故义言拂佛也。且净名云。众生病故我病众生病愈我病亦愈。故义言拂佛。覆以宝帐者明如来大慈大悲最高而能覆下如宝帐也。垂诸华幡者华幡本招致看者。此譬如来有四摄之德摄化众生也。香水洒地者云法师言。以禅定水洒净戒地。淹烦恼尘正以禅定资戒令止恶义强也。然佛地乃无恶可止但有定故。恒无恶可生故义言淹之也。散众名华者七净为华也。罗列宝物者如来说一乘因果万善同归。明诸功德故言罗列宝物也。教从佛出故言出。化功归佛故言内。前人受教为取。拂授记为与也。穷子见父有大力势此下是子见父中第四阶。明穷子既见长者尊贵。生畏避之心。内合众生唯有五戒十善之机感佛。此小机拟一乘圆教永无堪受之理则有怖畏之心。五戒十善小机不应一乘大教从拟无益故言悔来也。窃作是念此是理中为论非公灼发言故言窃也。若是王王等者。说一乘教佛是王。说三乘教佛为王等也。若是一乘教佛者亦非是五戒十善机相应。只纵复说三乘教佛亦非是五戒十善机所宜。故言非我佣夫作力得物之处也。不如往至贫里肆力有地衣食易得者。人天教为贫里。于此人天教中修行。即肆力者卖也。五戒十善为因感人天果报如衣食易得也。若久住此或见逼迫者内合人天小机扣佛大教。佛或能用大乘教逼小令行。故言逼迫也。非我所为欲令为故言强也。欲背大向小故言疾走。欲去犹未去也

时富长者于师子座见子便识此下是第二父见子此中亦有四阶。第一明见子之处。第二正明见子。第三明见子故欢喜。第四明长者生开畅之心念也。今于狮子座者是第一明见子之处。内合如来在法身无畏之座也。见子便识此是第二阶正明见子。内合明如来见众生便识是我昔日以大乘所化之人。即是领上火宅中云长者见是大火从四面起也。亦是方便品中我以佛眼观见六道众生也。心大欢喜者此是第三阶。明长者既知是儿故欢喜。内合明佛既见此众生小机发。用此善根资益得昔大乘之解。称大慈之意故言欢喜也。即作是念下是第四阶明长者生开畅之念。内合明如来见众生善根机发。必可以委付法化。我常思念此子无由见之者。从二亿佛所众生失大乘解。恒觅众生善机不得故云无由见之。今者始见无机发故言适我愿也。我虽年朽者废大乘化来久故言年朽也。犹故贪惜者虽废化久犹欲用大乘与众生故言贪惜。此四法中第二第四正领上能见。第一第三非正领上也

即遣傍人急追将还以下是第三呼子不得譬。即领火宅中言我身手有力。明长者救子不得譬。远领方便品中我始坐道场下明以大乘化众生不得也。上火宅譬中本有劝诫两段各分为三别。今此中即并领之。既并领时开为三段。第一讫何为见捉名一唤不来。即领上劝拟宜与无机。第二从使者执之逾急下讫闷绝躄地此名为再唤不来。即领上诫拟宜与无机。第三从父遥见之下名为父置儿譬。即并领诫劝两家息化也。是则领开譬中不相应。领合譬中言相应也。又就此三段中各开为二。初段中二者第一领上劝教拟宜。第二穷子惊愕以下明无机。就两段中各自有二重。领劝教拟宜有二者。第一言即遣傍人急追将还。此领上思惟作劝教。即是是长者作是思惟我身手有力。所以言傍人者此就经教为义也。理是正大乘言教是傍。教乃诠于理。然教非即是理故言傍人也

法华经疏卷第五妙法莲华经义记卷第六

        光宅寺沙门法云撰

    信解品之余

第二尔时使者疾走往捉此是领用大乘教拟宜。此则领上火宅中当以衣裓机案从舍出之句也。第二领劝无机有二者。穷子惊愕此是第一明有小乘人天等机。上火宅譬明无机中本有二。第一言此舍唯有一门而复狭小明大教于其无用。今不领此唯领正明无机本有二。初明有小次明无大。今此一句领有小机即是诸子幼稚句大乘教拟。非意所期故言惊愕也。称怨大唤以下第二领无大机即是上未有所识句。我若有大乘机往犯汝大乘教。可得大乘教来见捉。我既无大何为见捉。是故称怨大唤也

使者执之此下是第二名为再呼不来段。上领诫宜与无机。就中亦有二。第一先领诫教拟宜。第二于时穷子以下领无机。又就此二段中各有二重。诫教拟宜中有二者。即是领譬说两段。使者执之逾急此是第一。领上思惟作诫教则是火宅中我当为说怖畏之事。大乘诫教疾故言急也。第二强牵将还正领诫教拟宜。即火宅中如所思惟具告诸子。明于时小机与大教不相从故言强牵也。第二于时穷子自念无罪下是领诫无机。就中亦有二。即是领譬说两段。第一言于时穷子自念无罪而被囚执此必定死此先领无大机。即是火宅中第二正明无大机。不肯信受不惊不畏了无出意下是也。我既无有大机汝强用诫教逼我。或起诽谤断善根慧命也。转更惶怖闷绝躄地此是第二追领有小机。即是火宅中第一有人天小机。父虽怜愍善言诱喻而诸子等乐着嬉戏也。小机不堪受大教如躄地也

父遥见之此下是第三放舍儿譬。则并领两家息化。此则领火宅中劝息化。言或当堕落为火所烧诫息化。言但东西走戏视父而已也。亦远领方便品中我即自思惟下乃至我宁不说法疾入于涅槃句。就此息化中亦有二。第一思惟欲放舍儿内合欲息化。第二从使者语之以下正明放儿内合正明息化。又就此两段中各有二。思惟息化中有二者。第一思惟欲息化。第二从所以者何下释欲息化意。此两段各有二意。一者思惟欲息化。二者先明有小后明无大也。今先明有小父遥者。小机望大教相去殊远故言遥也。将教作使于时欲息化。如而语使言不须此人勿强将来。人天机如面人天等教如冷水。人天等教称会根性。故言洒面令醒悟也。莫复与语者此明无大机。由无大机故勿复与语无大机也。所以者何。此下是第二释上两种欲息化之意。只由有小无大故息化便成两段。志意下劣者此即是有小。此即释上冷水洒面句。自知豪贵为子所难此下释明无大。此即释上莫复与语句也。亦言释上勿强将来句也。审知是昔日二万亿佛大乘所化之子。只自不语诸菩萨道。是失大乘解之子故言不语他人也。使者语之下领息化中本有二段。此下是第二正明息化。就中亦有二。第一言使者语之我今放汝随意所趣此是正息化。佛复不用大乘教拟宜故言放也。即是火宅中劝教息化言恋着戏处或当堕落等。诫教息化言但东西走戏视父而已。即是方便品中我宁不说法疾入于涅槃义也。第二言穷子欢喜此明息化得宜。含有二义。故喜一者少机既不为大教所逼故言欢喜。二从地而起者向被大乘教拟宜之时如躄地。今既不复被大乘教所拟宜故如从地而起。人天教如贫里。其中人天果报如衣食。则是人天小教称会人天小机故喜也

尔时长者将欲诱引其子自此下是第四唤子得譬。此则是第四譬及第五譬共领上第四譬也。今此第四譬领上第四譬中前两段拟宜与见三乘机。就此譬中自有二段。第一明父唤子。第二从既已得之以下明见子受唤也。内合为论。先领佛用三乘教拟宜后见三乘人能受。就此两段中各有四阶。第一父唤子中有四阶者。且就外譬为语。第一先觅可使之人。第二即得可使之人。第三与使之人语。第四使人受命唤之也。今言长者将欲诱引其子而设方便者此是第一觅可使之人。内合明如来觅三乘教。此则领火宅中我今当设方便也。密遣二人形色憔悴无威德者此是第二得可使之人。内合明如来得二乘教在法身之地。于时未说二乘教只是法身地拟宜故言密遣。形色憔悴者以理来名教。若用大乘教诠大乘理名形色晖华。今二乘教不能诠大乘因果之理故言憔悴也。无威德者二乘教不说声闻辟支有三十二相八十种好四无畏等德。故言无威德也。向者言三乘方便今何故言二乘也。解释者言。今止道声闻辟支二人领解故仍道二乘也。汝可诣彼此下是第三与使人语。内合明佛作二乘教方法也。四谛如此十二因缘如彼也。二乘教非正直化物入大乘解义奢故言徐语也。倍与汝直者。二乘教拟宜为说二乘家尽无生智胜天等果故倍直也。将来使作者二乘人若受教应令修行。故言将来使作也。雇汝除粪者二乘人若受教之后望见修治道断九十八使烦恼。如雇汝除粪也。我等二人亦共汝作者言此二乘教有为众生诠理。作修道外缘即是共作义也。时二使人即求穷子此是父唤子中第四阶。正明使人奉命唤子。内合如来正用二乘教拟宜也。此则领火宅中令诸子等得免斯害。亦则领方便品中我今所得法亦应说三乘也

从既已得之此下是第二明见子受唤也。内合众生有二乘机可受二乘之教。此则领火宅中第二父知其子先心各有所好也。亦即是方便品中复作如是念我出浊恶世如诸佛所说我亦随顺行见三乘人机也。就此见子受唤中亦有四阶者。今言既已得之此是第一明众生有堪闻之机。后亦为说必生外凡夫善根。即是心各勇锐义也。具陈上事者此是第二阶。明众生有能堪受之机。后亦为说必生内凡善根。互相推排也。尔时穷子先取其价寻与除粪此是第三阶。见众生有能行之机。后亦为说必生无相行已上见谛思惟治道断结之能即是竞共驰走义也。所以言先取其价者。即是三界外尽无生智。二乘人要先标心三界外有尽无生智。然后只修行断烦恼。即此是取其价义也。其父见子愍而怪之者此是第四阶。明长者起愍伤之念。内合如来见众生只有修行得罗汉果之机。起慈愍之心念其取小不取大意。此是即诤出火宅义亦犹在法身地也

又以他日此下是第五教作人譬。此则领火宅第四譬中后两阶。初如此羊鹿牛车今在门外句。又领诸子闻所说心各勇锐等句。亦远领方便品思惟是事已即趣波罗捺说三乘教乃至便有涅槃音及以阿罗汉法僧差别名。今就此譬中大分为三段。第一从又以他日下讫状有所畏名教作缘由也。第二从语诸作人以下正教作也。第三从汝常作时以下竟犹在本处名为作人就作称可长者意。内合为义则如来将欲说三乘教。先舍法身受应身。此则是教作缘由义也。既受应身然后造鹿苑转三乘教化呴邻等。即是正教作义也。既说三乘教三人受行即是称可长者意也。后两阶正是领上譬。前一阶但四大声闻今深取佛意探明未说教之前舍本现迹。是故名长者教作缘由也。只就第一教作缘由中自有三段。第一从又以他日讫污秽不净明长者见穷子。内合明如来以道眼见众生为五浊所壅。二从即脱璎珞以下即明长者舍贵人服饰。内合明如来舍法身智慧功德相好也。第三从更着粗弊以下讫状有所畏。即明长者受贱人之服。内合明如来示受应身同凡夫之体。作太子之形。又就此三段中各有三阶。第一有三者。一者明见子时。二者明见子之处。三者正明见子之相。又以他日此是第一明长者见子之时。内合佛临说三乘教照机之时。所以言他日者。上已明见者则是领用三乘拟宜之时见机也。此中言见者即是说教时见。欲别此见异于前见故言他日。然两见只是一时义得作前后也。于窗牖中此是第二见子之处。所以不道于户中而道窗牖者。表明如来方便智中见众生。此机非是实智如牖也。遥见子身此是第三正明见子之相。内合明如来正照小乘机。自有二。第一明有善。第二明有恶表明纯善不感圣也。今者第一小乘机无善自资如羸瘦也。无威德故言憔悴也。第二明有恶者备有九十八使故言粪土尘坌污秽不净也。即脱璎珞下是第二明舍贵人服饰。内合舍法身。就中亦有三。此一句是第一先明如来舍种智也。细软上服此一句是第二明如来又除功德也。严身之具此一句是第三明如来又舍相好也。此中明法身即是他方净土分身诸佛以为法身也。更着粗弊此下是第三明如来受应身。亦有三阶。更着粗弊垢腻之衣此一句对第三严身之具示无有相好。悉达太子凡夫之体。尘土坌身是第二对第二除细软上服。右手执持以下是第三明如来示无智慧。此即对第一即脱璎珞句。此明如来示修智慧。用智慧之手执二谛境。断除烦恼示同厌生死。故言状有所畏也

语诸作人此下是第二正教作。就此正教作中有四阶。一者劝令勤作。二者明加汝价。三者赞叹作具。四者安慰作人也。此则领上为说三乘之四阶也。语诸作人汝等勤作者是第一但语不次第。先领第三语作人。汝等勤作者是第一领火宅中第三劝诸子。往取三车汝等宜速出来合譬。又言汝等但当勤修精进句也。后复告言此下是第二非唯直劝作而已。亦复加与汝价此则领上第二示三车处。上言如此种种羊车鹿车牛车今在门外。今此中加汝价者昔但人天果报今加价。只是尽无生智也。诸有所须乃至老弊使人须者相给是第三阶赞叹作具。此则领譬中第一赞叹三车。上言如此种种希有难得。合譬言汝等当知此三乘法皆是圣所称叹也。戒能盛物如瓮器。米如智慧面如禅定盐酢者。以苦酢味无常碱味作无常苦空无我行观智。故言盐酢之属也。老弊使人者本以代手足运动。明罗汉备有六通隐显游方。此六通不及如来神通故言老弊也。此自是罗汉神通何故言佛给。解释者言。则是佛为众生说得罗汉果必得此六通。既由佛说故言相与也。好自安意此下竟言而汝少壮是第四阶。安慰作人。此则领上譬中第四必与不虚。上言随汝所欲皆当与汝。合譬言我今为汝保任此事终不虚也。化彼众生来久故言我年老大。众生善根劣弱故言而汝少壮也

汝常作时此下教作人譬中是第三。明作人就作称长者之意。内合明三乘人受行称佛施三之意。此即领上譬中诸子受行义。上诸子受行有四阶。穷子今者亦具领四。汝常作时下竟如余作人是第一。此则领上心各勇锐句。外凡善也。无有欺怠嗔恨怨言五种之过。如余作人者不如诸新学轻毛位人也。自今以后竟言名之为儿。是第二。此则领譬中第二阶互相推排句。外譬明长者忽尔转客作之人名之为儿。内合此人既修行出彼外凡登此信首。佛呼相似圣人绍系佛种。即是子义也。尔时穷子虽欣此遇此下第三。领上譬中第三竞共驰走句。明入无相行于时修见谛思惟两种治道断烦恼。故言二十年也。过是已后此下是第四阶。此则领上受行譬中第四诤出火宅句。只过见谛思惟二种治道断正使尽成无学果。故言过是已后也。心相体信者是无异之言。若约教为论罗汉无为与佛无为无异也。犹在本处者但有为果功德智慧此处为隔。佛自是大乘家有为果一切种智。彼是小乘位那得与佛共齐。故言犹在本处也

世尊尔时长者有疾自知将死不久此下是第六付财物譬。此譬不领上譬。领昔日大品座席佛命须菩提为菩萨转教说般若。于时命须菩提转教之意。已自为法华作由渐。何以知之。大品之教三乘通教。言欲学声闻辟支者当学波若。此波若本是菩萨法。忽令声闻小道登座宣波若。表欲令声闻作菩萨。今者四大声闻既解同归之义皆是佛道。此即会昔日转教之意。深取佛意探领昔日事也。就此譬中自有二段。第一是父付。第二尔时穷子即受教敕下是子受。就此父付子受之中各有三阶。初段中三阶者一者明付财物时。二者正付财物。三者诫敕也。长者有疾自知将死不久是第一阶。明付财物之时。由有疾故付若无有疾云何付也。内合如来大品座席只用三乘通教。化功为命。于时将废此化功故言有疾。若使化功已废如长者死。于时未废故言有疾也。语穷子言此下是第二正付财物。内合正是佛告须菩提。汝为诸菩萨说波若。若多若少广说为多略说为少。前人来受为取说授前人为与也。我心如是当体此意。宜加用心勿令漏失。是第三诫敕。即大品时敕须菩提为菩萨说波若之方法也

尔时穷子即受教敕此是第二子受。内合于时须菩提受佛敕为菩萨转教说波若。就此子受中亦有三阶者。第一一往受命。第二正明子受财物。第三明子虽受付而无取意也。即受教敕是第一。一往受命内合须菩提于时受佛教也。领知众物此下第二正明子受财物。内合须菩提正登座为诸菩萨转教说波若也。次而无希取一餐之意。此下是第三阶。明子虽受付而无取意。明须菩提于时为诸菩萨说般若明因辨果。而须菩提终日为他说大乘因果。于因果中无有求意。唯为他说大而已。不舍声闻位也

复经少时父知子意渐已通泰成就大志自鄙先心此是第七见子志大譬。此则领上火宅中第五见子出难譬。上言见诸子等安稳得出火宅。方便品中第五我见佛子等志求佛道者见大乘机发义也。就此譬中有三阶第一先明时节。复经少时者转教之后去法华座不远故言少时。只迳说维摩教故言经时也。第二父知子意渐已通泰下正明志大譬。渐已通泰明无五浊。成就大志正明大乘机发。第三自鄙先心者鄙昔日是小机而无希取意。今日之大形昔日之小足可鄙也

临欲终时而命其子此下是第八付家业譬。此则领火宅中第八长者赐诸子珍宝大车。言尔时长者各赐诸子等一大车譬。方便品中于诸菩萨中正直舍方便但说无上道即是。说法华明万善同归明三乘人皆转作菩萨皆成佛道。就此譬中自有四阶。一者付家业之时。二者集于证明之众。三者会父子天性。四者正付家业。临欲终时此一句是第一付家业之时。只称临终故付。内合如来品初说法华时三乘化功势未息。此即如方便品略说开三显一。于时未的道无三。三乘化功有渐废之义。若使说法华究竟明无三之义。三乘化功已废如死。说法华既未周竟。波若势由未尽故名临终也。而命其子并会亲族此下是第二集证明之众。内合明如来放光动地。招集有缘。即是尔时世尊四众围绕义。分身诸佛为亲族。多宝佛塔如国王。十地菩萨如大臣。九地菩萨如刹利。八地已还菩萨如居士。即自宣言此下是第三叙父子天性。内合会通今昔之意。即是今于法华座席唱言。昔日已佛用大乘化汝。今复大乘化也。此实我子者此实是昔日所化大乘之子也。于某城中者即二万亿佛教为某城也。舍吾逃走者昔日佛用大乘化。后众生失大乘解。既失解密有远佛之义。故言舍吾逃走也。既失大解广起烦恼。备经六道故言辛苦五十余年。其本字某我名某甲昔在本城怀忧推觅者。于二万亿佛以来恒觅众生一乘机。故言推觅。今始大机发称本来之意。故言得之也。此实我子者实是菩萨子。迳受大乘化我实其父也。我实迳大乘化也。吾今所有一切财物此下是第四正付家业。内合正说法华经为诸菩萨受记得佛。今吾所有皆是子有者付显一之义。语三乘人言。汝未来得佛果如我无异故言是子有也。先所出内者付开三之义。语言我昔来所说三乘等教悉令众生知是方便。故言是子所知

是时穷子闻父此言即大欢喜此下是第九子欢喜。即领上火宅第九是时诸子各乘大车得未曾有明得车欢喜。亦远领方便品中第九菩萨闻是法疑网皆已除千二百罗汉悉亦当作佛。明三乘人闻说法华得受记作佛故欢喜。我本无心者此四大声闻自道。昔日大品座席时见大因大果。于时都无悕求之心。此举昔不求形释今日自得也

世尊大富长者即是如来我等皆似佛子。自此下是第二合譬。上有九譬今亦具合九譬。但阙略耳。今言大富长者即是如来我等皆似佛子此二句合第一父子相失譬。上譬中本有四段。一者子离父而去。二者父觅子不得。三者子还近父。四者父既失子忧念转深。又此四段中各有两阶。今此两句都得合尽。今言大富长者即是如来。此上句即得合第二第四段也。我等皆似佛子此下句合第一第三段也。上句合两段者上第二父觅子不得中两阶。一者正明觅子不得。二者言不以失一子小事废于家业大功。第四父忧念转深中两阶。一者言失子之苦。二者言设念得子之乐也。我等皆似佛子此下句合第一段第三段者。第一段子离父中两阶。一者背父而去。二者向国而还。第三子近父中两阶。一者近父缘由。二者正明近父也。如来常说我等为子一句即合上第二父子相见譬。上譬中自有二。一者言子见父。二者父见子。子见父中有四阶。今尽不合。一者见父缘由。二者见父处。三者言遥见其父踞师子床正明见父。四者生畏避之心。此四阶尽不合也。唯合第二父见子。但上见子中亦有四阶。今者不合第一第三两阶。总合第二第四两阶。第二言见子便识正见子之义。又合第四阶言我常思念此子无由见之而忽自来甚适我愿。明长者既见子生开畅之念。今者总合两阶故言如来常说我等为子。略不合第一言时富长者于师子座明见子之处。又不合第三言心大欢喜也

世尊我等以三苦故于生死中受诸热恼迷惑无知乐着小法。此三句合上第三唤子不得譬。上譬中本有三。第一领劝拟宜与无机。第二领诫拟宜与无机。第三并领诫劝两家息化。今者唯合前两段不合第三领息化。但上领劝诫拟宜与无机中各有二也。领劝中有二者一领劝教拟宜。其中有二合。皆不合也。二明无机其中亦有二。今者合之。领诫中有二。一者领诫拟宜。其中有二阶。今不合也。二者领诫无机。其中有二。今亦合之。是故今者不合两家拟宜。唯合两家无机。领劝无机中有二者。一明有小。二明无大。领诫无机中有二者。一明无大。二明有小。今者并合两家无大机。亦并合两家有小机。而此合中有所长则为两种。今言我等以三苦故于生死中受诸热恼此是第一。先释所以无大之意。正由五浊障故无大机。三苦者是三界中苦。不道苦苦坏苦行苦也。第二正合迷惑无知此则合领诫劝两家无大。上领劝无大机言称怨大唤我不相犯何为见捉。领诫无大机言于时穷子自念无罪而被囚执此必定死。今言迷惑无知只是无大乘机也。乐着小法此一句合两家有小机。劝中有小言穷子惊愕。诫中小言转更惶怖闷绝躄地。此皆明有小机。今言乐着小法只是有小机故乐着小法也

今日世尊令我等思惟触除诸法戏论之粪下讫勤精进故所得弘多合第四唤子得譬上唤子得譬中有二。一者长者遣人唤子。二者从既已得之以下明见子受唤。今合此两阶。上长者唤子中本有四阶。今唯合第四阶。上第一者言长者将欲诱引其子而设方便先觅可使之人明如来觅方便教。今者不合。二者言密遣二人形色憔悴无威德者得可使之人即是明得方便教。今者亦不合。三者言汝可诣彼以下与使人之语明佛作方便教方法。今者亦不被合。四者言时二使人即求穷子一句正明使人奉命唤子。内合正明如来用三乘教拟宜众生。唯合此第四阶。今日世尊令我等思惟触除诸法戏论之粪此正合时二使人即求穷子也。见子受唤中亦有四阶。今唯合第三阶。一者言既以得之有外凡夫堪闻之机。今者不合。具陈上事。有内外凡夫堪受之机。今者亦不合。第四阶言其父见子愍而怪之。长者见子唯有乐小之志得无学果之机。故起愍伤之心。今者亦不合。唯合第三阶言尔时穷子先取其价寻与除粪有见谛思惟堪行之机。今言我等于中勤加精进得至涅槃一日之价乃至言勤精进故所得弘多正合上第三阶堪行之机也

然世尊先知我等心着弊欲此下讫于此大乘无有志求以来作三句。合上第五教作人譬。上譬中本有三阶。第一教作缘由。第二正教作。第三明作人就作称可长者意。今者合此三段皆尽但阙略而已。先合第一教作缘由本有三段。第一先明长者见子。第二言舍贵人服饰。第三言受贱人服饰即是舍法身受应身。今者唯合第一阶不合后二阶也。但第一阶长者见子中本有三。一言又以他日明见子之时今不合。第二言于窗牖中明见子之处今者亦不合。唯合第三正见子上明见子言遥见子身羸瘦憔悴污秽不净。于时唯有小机不堪为说大故言先知我等深着蔽欲下讫不为分别宝藏之分也

世尊以方便力说如来智慧此则是合上第二正教作。但上教作有四段即领上譬中为说三车四阶。今者不合第一第四唯合第二第三也。上第一言语诸作人汝等勤作勿得懈息即是领火宅中劝取三车今不合也。第二言后复告言咄男子汝常此作勿复余去当加汝价此即是领上示三车处。今者合此第二又得合第三言诸有所须瓮器米面盐酢之属。明长者叹作具领上叹三车也。上第四言好自安意我如汝父勿复忧虑即领上保与不虚今不合也。是故言正教作中有四不合第一与第四。唯合第二与第三。所以言世尊以方便力说如来智慧者。只世尊以方便力说如来智慧家之因持作我等三乘人异果也。我等从佛涅槃一日之价以为大得于此大乘无有志求。即是合教作人譬中第三段作人就作称可长者意。上称可中本有四阶。即是领上诸子受行中四阶。今唯合第四阶。一者言汝常作时下即领心各勇锐义今者不合。第二言自今以后如所生子下领上内凡夫中修行互相推排今者亦不合。第三尔时穷子虽欣此遇下领上竞共驰走见谛思惟治道修行今者亦不合。第四言过是以后心相体信出入无难即领上诤出火宅得罗汉果。今者唯合此第四阶。从佛得涅槃只是昔日罗汉果一日之价以为大得。故如荒年赁作百日只得一千。今日一日作得一千。是为今日歒。昔日百日作得千止与今一日作相歒。当于昔日以自言大有所得。无异昔日得罗汉果有诸功德智慧。由自不敌今日佛果一切功德智慧。故言一日之价也

我等又因如来智慧此下三句合第六付财物譬。上譬中本有二。一者父付二者子受。父付中有三阶今者不合也。子受中又有三阶今具足合之。今言我等又因如来智慧此即合上第一尔时穷子即受教敕也。为诸菩萨开示显说此下即合上第二阶领知众物及诸库藏也。而自于此无有志愿下讫随我等说即合上第三阶而无悕取一餐之意也。而我等不知真是佛子此一句即合上第七见子志大譬。上言复经少时父知子心渐已通泰成就大志自鄙先心有三。今唯合第二。所以言我等不知真是佛子者我等于时有大乘机发。唯如来知。然我等迳竟自不知。举我不知形出如来知。故言不知真是佛子也

今我等方知世尊于佛智慧无所吝惜此下二句合上第八付家业譬。上譬中本有四段。第一付家业时今者不合。第二集证明之众今者亦不合。第三明会父子天性今亦不合。唯合第四正付家业。上正付言今吾所有一切财物皆是子有。但此中有正合有释合也

是故我等说本无心有所悕求今法王大宝自然而至竟长行合上第九诸子得家业故欢喜。上言是时穷子闻父此言即大欢喜等也

重宣其意而说偈言第二正领解之辞中本有二段。第一从而白佛言下讫七十三行半偈。是正领解开三显一同归之义。此解不空来来必有所由。是故第二从世尊大恩以下十三行偈叹佛恩深难报。以结领解行。前又解言。两段之中各开为二。正领中有二者。第一是长行自此下有七十三行半偈。是第二偈颂。但长行正领解中本有三。一者略领解。第二将欲广领解先咨审如来。第三正广领。今者唯颂第一略领解。复颂第三广领解不颂第二咨审如来。今就此七十三行半偈自分为二。初有两行偈颂上第一略领解。第二余有七十一行半偈颂上第三广领解也。又上略领解中本有二。一者法说二者譬说。今两行亦分为二。初一行半颂法说余半行颂譬说。但上法说中本有二段。一者明昔日不求二者明今日自得。此一行半偈不颂不求唯颂自得。上自得言闻未曾有法深自庆幸获大善利也。无量珍宝不求自得此半偈颂上第二譬说。颂上譬说中本有二段。一者言无上宝聚不求为昔日不求作譬。二者言自得为今日自得作譬。今此半行具颂此两阶。初言无量珍宝不求此颂上不求譬。自得两字即颂上今日自得作譬。但言语还与上相似故知颂也

譬如童子此下有七十一行半是第二颂上第三广领解。但上广领解中本有二段。第一开譬第二合譬。今者七十一行半偈亦分为二。初有四十一行偈颂开譬。第二佛亦如是下有三十行半偈颂合譬也。上开譬中本有九譬。今就四十一行偈亦分为九段。初有十三行偈颂第一父子相失譬。第二佣赁展转下有七行半偈颂第二父子相见譬。第三即敕使者下有三行偈颂第三唤子不得譬。第四即以方便下有三行偈颂第四唤子得譬。第五长者于牖下五行半偈颂第五教作儿譬。第六示其金银下有两行偈即颂第六付财物譬。第七父知子心渐已广大下半行偈颂第七见子志大譬。第八欲与财物下有四行半偈颂第八付家业譬。第九子念昔贫志意下劣两行偈颂第九子欢喜也。今更道十三行颂第一。七行半颂第二。三行颂第三。复有三行颂第四。五行偈半颂第五。两行颂第六。半行颂第七。四行半颂第八。两行颂第九也。上第一父子相失譬中本有四。一者子离父二者父觅子三者子还近父四者父忧念转深。今者十三行亦具足颂此四段但不次第复有阙略。今者一行半颂第一。次有六行半颂第二。次有两行半超颂第四。次有两行半追颂第三也。譬如童子幼稚无识一行半先颂第一子离父。但上子离父中本有二段。一者言背父而去。二者言向国而归。今此一行半唯颂背父而去不颂向国而归也。其父忧念此下六行半颂上第二父觅子。上父觅子中本有二阶。一者觅子不得。二者言不以失一子之苦废于家业大事。今者具足颂。言其父忧念四方推求此半行颂觅子不得。上言其父先来求之不得也。求之既疲以下有六行正颂上第二段不失家业大事也。豪贵如是有大力势此下有两行半偈。超颂第四父忧念转深。上本有二阶。一者失子之苦。二者假使作念得子之乐。今不颂假使作念得子之乐。唯颂念失子之苦。上言父每念子与子离别五十余年也。尔时穷子求索衣食此下两行半偈追颂上第三子近父。上子近父亦有二段。一者近父之缘由。二者正明近父。今者亦具足颂初两行颂近父之由。次半行颂正明近父也。上近父缘由言时贫穷子游诸聚落迳历国邑等。从五戒至五戒故言从邑至邑。从十善至十善故言从国至国也。或有所得或无所得者今身修五戒十善迁此身得报名有所得。感生后报者名无所得也。又一解云。成就业感一期名有所得。不成就者感于寄受名无所得也。善法资身恒不足故言羸瘦。非唯无善法亦备有九十八使。故言体生疮癣也。渐次经历到父住城。此半行颂上正明近父。上言遇到其父所止之城也。佣赁展转遂至父舍此下七行半偈颂第二父子相见譬。上譬中本有二段。第一明子见父第二明父见子。今初有六行半颂第一子见父。长者是时下一行颂父见子也。上子见父中本有四阶。一者见父缘由。二者见父处。三者正明见父。四者生畏避之心。今者亦具足颂。初一句颂第一。次一句颂第二。次两行半颂第三。次三行半颂第四也。佣赁展转此一句颂第一见父之缘由也。遂至父舍此一句颂第二见父之处。上言遂至父舍住立门侧。今者唯道父舍不道门侧义自显也。尔时长者于其门内此下两行半颂第三正见父。上言遥见其父踞师子床等。或有计算金银宝物者有广说有略说故言计算。说与前人故言出化功归已故言内。注记券疏者明因辨果。受记之事故故言注记券疏也。穷子见父豪贵尊严以下三行半颂上第四阶生畏避之心。上言穷子见父有大力势即怀恐怖悔来至此也。长者是时此一偈颂上父见子中有四段。今唯颂第一第二。上半行颂第一阶见子处。上言时富长者于师子座也。遥见其子默而识之此半行颂第二正明见子。上言见子便识。略不颂第三心大欢喜。亦略不颂第四开畅之念也

即敕使者此下三行偈颂第三唤子不得譬。上譬中本有三段。第一领劝拟宜与无机。第二领诫拟宜与无机。第三两息化。今此三行亦颂三段。初三句颂第一。次一行一句颂第二。次一行颂第三也。今三句颂第一劝拟宜无机者半行颂劝拟宜。次一句领无机。上拟宜中有二段。一者领作劝教。二者正领拟宜。今此半行唯颂领作劝教。上言即遣傍人急追将还也。不颂正领拟宜上言尔时使者疾走往捉。穷子惊唤此一句颂第二领劝无机。上无机中有二者。一有小二无大。今言穷子惊三字此即颂上有小机。上言穷子惊愕也。唤此一字颂无大机。上言称怨大唤我不相犯何为见捉明无大机也。迷闷躄地此下一行一句颂上第二领诫拟宜与无机。上诫拟宜与无机中有二。一者正明拟宜。二者无机。今不颂领拟宜。唯颂领诫之无机。上无机中有二段。一者无大二者有小。今者先颂有小后颂无大。迷闷躄地此一句颂有小机。上言转更惶怖闷绝躄地也。是人执我必当见杀此一行正颂上无大机。上言于时穷子自念无罪而被囚执此必定死。长者知子愚痴狭劣此一行颂第三并领息化。上息化中本有二。一者欲息化。二者正息化。今不颂第二正息化唯颂第一欲息化。上欲息化中亦有二阶。一者明欲息化。二者释欲息化。上言父遥见之而语使言不须此人勿强将来。以下思惟欲息化。今不颂也。唯颂第二释欲息化之意。上言所以者何父知子志意下劣自知豪贵为子所难也

即以方便此下三行偈颂第四唤子得譬。上譬中有二。第一父唤子第二子受唤。初两行颂第一父唤子。后一行颂子受唤。但上父唤中本有四段。今者尽颂一句颂第一。三句颂第二。次三句颂第三。次一句颂第四也。即以方便此一句颂觅可使之人。即是觅方便教。上言尔时长者将欲诱引其子而设方便也。更遣余人此下三句颂第二得可使之人。即是得方便教。上言密遣二人也。眇目者不正之相。欲明二乘教非是真正之教故名眇目。二乘教不备说威德相好故言无威德也。汝可语之此下三句即颂第三与使人之语即是作方便教方法。上言汝可诣彼徐语穷子此有作处也。倍与汝价此一句即颂第四使人正奉命唤子。正明如来用方便拟宜众生。上言时二使人即求穷子也。穷子闻之此一行颂第二子受唤。上受唤中亦有四阶。今不颂三阶唯颂第三阶。上第一既已得之有堪闻之机。第二具陈上事能受之机。第四其父见子愍而怪之不颂也。上第三阶言尔时穷子先取其价寻与除粪净诸房舍。今唯颂此。言净诸房舍者六尘如房。于此六尘中无染故云净诸房舍也

长者于牖此下有五行半偈颂上第五教作人譬。上譬中本有三段。第一教作缘由。第二正教作。第三作人。就作称可长者之意。初两行颂教作缘由。次两行半颂正教作。后余一行颂作人称可长者意也。上教作缘由中本有三段。一者明长者见子。二者舍贵人服饰。三者着贱人衣服。今此两行只颂第一第三不颂第二舍贵人服饰舍法身之义。初偈颂第一见子后偈颂第三着贱人衣服。但上父见子中本复有三段。今者不颂第一唯颂二阶。上第一句又以他日明见子之时今不颂也。二者言于窗牖中明见子之处。今者初句正颂此第二阶。下有三句颂第三阶正见子也。于是长者着弊垢衣此一偈颂上第三受贱人之服。上受贱人服中自有三阶。今不颂第二。唯颂两阶。上半偈颂上第一明无有相好。下半行颂上第三无智也。方便附近以下有两行半颂上第二正教作。上正教作中本有四段。今具足颂。半行颂第一。一句颂第二。一行一句颂第三。半行颂第四。方便附近语令勤作今此初半行即颂第一阶领第三劝取三车。则是劝精进也。上言语诸作人汝等勤作也。既益汝价此一句即是颂第二领第二示三车处。上言后复告言咄男子汝常此作勿复余去也。并涂足油此一行一句颂上第三叹作具领第一赞叹三车。上言汝等所须瓮器米面今以涂足油以代上老弊使人。老弊使人者只是神通。今涂足油代者外国用涂足油能履水如地饮以代上面食以代上米。是故论文言揣食有二者。一粗二细。饭等名粗饮等名细。荐席以代上瓮器盛物明或如荐席。又以软语若如我子此半行颂上第四领上第四必与不虚。上言好自安意我如汝父即是保与不虚之义。长者有智渐令入出此一行是第三即是颂上第三作人称可长者之意。上称可中本有四段。即领上三乘受行中四段。今唯颂第三段。余者皆不颂也。一者汝常作时无有五种之恶即譬领心各勇锐义。今者不颂也。二者自今已后如所生子领内凡相似圣人。今者亦不颂。唯颂第三尔时穷子虽欣此遇犹故自谓客作贱人由是之故于二十年中常令除粪。见谛思惟治道修行故言二十年。不颂第四过是已后心相体信得阿罗汉果也

示其金银此下两行颂上第六付财物譬。上譬中有二。一者父付二者子受。就父付中有三阶。今者悉不颂也。唯颂子受。子受中又有三。唯颂第二第三不颂第一一往奉命也。示其金银此一行即颂第二正受。上言领知众物也。犹处门外一行即颂第三而无悕取一餐之意下劣之心亦未能舍也

父知子心渐已广大此半行是第七即颂上第七见子志大譬也

欲与财物此下四行半偈是第八即颂第八付家业譬。上譬中本有四段。唯不颂第一临欲终时付家业之时。自余三段皆颂。欲与财物一行颂第二集证明之众。于此大众说是我子此两行半颂第三会父子天性。二十年者人天受道器也。凡我所有一行颂上第四正付家业也

子念昔贫志意下劣此下两行颂上第九诸子欢喜譬也

佛亦如是自此下有三十行半偈是第二。颂上合九譬而成八段。佛亦如是一句颂合第一父子相失譬。次知我乐小法有一句颂合第二父子相见譬。次未曾说言汝等作佛下半行颂合第三呼子不得譬。次而说我等得诸无漏下半行颂合第四唤子得譬。次成就小乘声闻弟子下半行颂合第五教作人譬。次佛敕我等下有十八行半颂合第六付财物譬。次如富长者下有三行并颂合第七第八两譬。次我等今日得未曾有下有七行颂合第九子欢喜譬也。更道八阶。一句颂第一。一句颂第二。半行颂第三。半行颂第四。半行颂第五。十八行半颂第六。三行并颂第七第八。次七行颂第九子欢喜譬也。今言佛亦如是此一句颂合第一父子相失譬。就中本有二句。今只得颂大富长者即是如来。略不颂我等皆似佛子也。知我乐小此一句颂合第二父子相见。上合譬言如来常说我等为子是始终为语。今言知我乐小者当照机时为论也。未曾说言汝等作佛此半行即颂合第三呼子不得譬。上合譬中本有二。无有大机有小机今者唯颂无大机也。上言我等以三苦故于生死中受诸热恼迷惑无知。既无大机故言未曾说言汝等作佛。略不颂乐于小法小机之义也。而说我等得诸无漏此半行即是颂合第四唤子得譬。上得譬中本有二段。一者父唤二者子受唤。就父唤子中自有四段。上合譬中唯合第四阶时二使人即求穷子句。上合譬言世尊令我等思惟蠲除诸法戏论之粪。今者不颂也。子受唤中本有四段唯合第三段尔时穷子先取其价寻与除粪。上合譬文言我等于中勤加精进得至涅槃一日之价。今者只颂此句故言而说我等得诸无漏也。成就小乘声闻弟子半行即是颂合第五教作人譬。前开譬中本有三。第一教作缘由。第二正教作。第三明作人称可长者意。三段上合譬中皆合阙略而已。今者唯颂第三段中第四阶余者不颂。何者上教作缘由中有三。上合譬唯合第三不合余二。上合第三阶言先知我等深着蔽欲下讫不为分别宝藏之分。今者都不颂也。第二正教作譬中有四段。合中唯合第二第三阶。上合文言世尊以方便力说如来智慧。即是合当加汝价亦得合诸有所须。今者亦都不颂也。第三作人称可长者之意中有四段。上唯合第四阶言过是已后心相体信出入无难罗汉果。上合譬文言我等从佛得涅槃一日之价以为大得。今言成就小乘声闻弟子正颂合此也。佛敕我等自此下十八行半颂合第六付财物譬。上开譬中有二。一者父付二者子受。就父付中有三段。上不合今亦不颂。合子受中亦有三段上备合三段。故今此颂合中亦备颂合子受三段。今十八行半偈中一行颂合第一。次五行颂合第二。次十二行半颂合。第三也。初一行言佛敕我等此颂子受。开譬中第一言尔时穷子即受教敕合譬言我等又因如来智慧也。我承佛教为大菩萨下五行颂合第二正转教领知众物金银珍宝也。即是上合譬中言为大菩萨开示宣说也。从如彼穷子下有十二行半偈颂合第三而自于此无有志愿明不求之义。但上有正合有释合。今此十二行半分为二。初十一行半颂正合不求。二言导师见舍一偈颂上释句。就十一行半偈中自有三段。第一言如彼穷子一偈先牒不求外譬。第二言我等虽说佛法宝藏一偈内合不求之义。第三从我等内灭下有九行半偈正颂不求。即广上品初三不求即自成三段。初我等内灭有四行广上第一居僧之首故不求。第二我等长夜有四行偈广上第二自谓已得涅槃故不求。第三言我等虽为诸佛子等一偈半广上第三年朽迈故不求。导师见舍此一行是第二颂上释不求之句。言所以者何佛知我等心乐小法下是也。如富长者此下三行是第七并颂合第七见子志大譬。亦并颂合第八付家业譬。就中自分为二。第一一行半牒四种外譬。第二一行半帖合譬也。如富长者知子志劣此牒第四唤子得譬。以方便力此牒第五教作人譬。柔伏其心此牒第七志大譬。然后乃付一切财宝此牒第八付家业譬。来佛亦如是此一行半是第二帖合四种外譬。初二句帖合第四。知乐小者下二句帖合第五。调伏其心即帖合第七。乃教大智即帖合第八也。我等今日得未曾有此下七行偈是第八颂合第九子欢喜。就中有三。第一一得正明欢喜。第二半行举外譬帖合。第三五行半广明欢喜相也

世尊大恩此下十三行偈是正领解中第二解。从佛来故叹佛恩深难报以结领解前。正领解中有三。即是长行与偈为二。今此中有二者。第一有六行半偈正叹佛恩深难报。第二诸佛希有有六行半叙出佛恩之相。又就此两段之中各有二。初段中二者。初有一行先明佛恩即是开三显一也。从无量亿劫下五行半明无能报者。就此第二自有三。初半行总明无能报者。第二手足供给下四行别明世间供养无能报。第三如斯等事下一行总结无能报也。诸佛希有此下有六行半明叙佛恩之相。亦有二者。第一有两行明身业利益。第二有四行半明口业利益即是权实二智开三显一义也

    药草喻品第五

此品中借三草两木为喻。但从多受名故言药草喻品。第二譬说开三显一化中根人中本有四段。第一譬喻一品正譬说开三显一化中根人。第二信解品是中根人领解。今此药草喻品是第三明如来述成中根人得解之义。第四授记也。但四段之中例开为二正譬说中有二者。第一是舍利弗请。第二如来答。领解有二者。第一经家叙四大声闻得解之相。第二正是四大声闻领解之辞。今此品述成中根人得领解之义中有二者。第一是长行第二是偈颂也。但上四大声闻正领解之辞中本有三段。一者略领解二者将欲广领解先咨审如来。三者广领解。今如来唯述成广领解略不述前二段也。然第三广领解中本有二。第一从譬若有人下入偈尽七十三行半偈作九譬。领如来明开三显一同归之义。第二从世尊大恩以下有十三行偈叹佛恩深难报以结领解。今就此长行亦分为两段即述成向者两段。第一从品初讫若有所说皆不虚也以来。先超述成第二佛恩深难报。第二从于一切法以智方便竟长行。追述成第一正作九譬领如来七意开三显一之义。又就此两段之中各有三段。述成叹佛恩深难报中有三者。第一正述成。第二明说所未尽。第三举法王明如来所言不虚也。何者从品初讫诚如所言此是第一正述成已上叹佛恩深难报。汝上言手足供给头顶礼敬于恒沙劫犹自难报此实自如汝所叹也。但物情起疑见如来述成四大声闻叹佛恩深难报。谓言如来德行深恩体尽如四大声闻浅智所叹。是故第二从如来复有无量无边阿僧祇功德下讫说不能尽詺为出说所未尽。但汝上十三行偈叹佛恩深难报。正叹小分一方所说直言如来有权实之智益物之恩。自汝所不叹者复有无量无边不可说不可数深恩重德无方益物。此即释疑情也。但物情于此第二重中仍复起疑。疑言如来体尽只自有权智无方益物。实智说理度人。佛虽备有众德若以权实往收则不出此两途。云何复言更有无量阿僧祇功德。此则前后自相鉾鍎难可取信。既有此疑是故第三从迦叶当知如来是诸法之王下竟皆不虚也举法王明如来所言不虚。不自在人有所畏惧吐言陈教率多不实。王之为体居宗体极住自在之地。何容有虚唱之敕。欲明如来是法中之王吐言陈教无有虚唱之说

是故有此第三段。但第一正是述成已叹佛恩深难报。后两段释疑也。就此三段之中各有二阶。第一正述叹佛恩深难报有二者。第一从尔时世尊告摩诃迦叶以下竟真实功德此述赞四大声闻。理上之言巧善哉之言甚善甚善。及诸大弟子者即是须菩提大目犍连迦栴延等。第二诚如所言。此则述已言下之理实。前明理上之言巧。后明言下理实。此一双合是第一正述四大声闻以十三行偈叹佛恩深难报也。第二明说所未尽中有二者。第一言如来复有无量无边阿僧祇功德。此正出说所未尽之法。只言自汝十三行偈叹佛恩深难报之外更有无量功德不可说不可数。第二言汝等若于无量亿劫说不能尽此明说不尽。此一双合是第二明已说所未尽。亦是释物疑情。疑如前释也。第三明不虚中有二者。第一从迦叶当知如来是诸法王。此先举法王以为不虚之端。第二言若有所说皆不虚也。此正明不虚此一双合。是第三明不虚亦释疑情疑如前述

从于一切法以智方便以下是第二追述成第一正领解如来开三显一之义。就此第二段中有三者。第一从一切法以智方便竟示诸众生一切智慧将欲述成。先出已上所领之法即是权实二智开三显一之义也。第二从譬如三千大千世界以下讫是故不即为说一切智慧以来将明今日得解。先道四大声闻昔日不解三一之义。执三乘定别迷同归之理。如草木禀乎天泽增长。各不自知得润增长差别之相。此即明昔日不解成今日得解之相。第三从汝等迦叶甚为希有下竟长行。正述成已今日得解开三显一义也。就此三段之中各有二。第一出所领之法中有二者。第一双开两章门。第二双广两章门。两章门者于一切法以智方便而演说之此是权智章门。其所说法皆悉到于一切智地此是实智章门也。今释权智章门义。于一切法者是佛果佛智知一切法即是一切种智万善是一切智家因以智方便而演说之者。此明如来于一切智家因法上以善巧智持作三乘之法。故言以智方便而演说之也。其所说法皆悉到于一切智地者。此是释实智章门。其所说者其权智昔所说万善之法也。此万善理中能感得一切智故言皆悉到于一切智地也

如来观知此下是第二广上两章门。先广权智章门自有二。一者识药。二者知病。今言如来观知一切诸法之所归趣。此是第一明如来识法药之义。即是权智所照之境。亦知一切众生深心所行通达无碍是知病之义。知一切众生深心所行者明如来知三乘人根性所宜。故如声闻根性宜行四谛。缘觉根性宜行十二因缘。菩萨根性宜行六度也。通达者通是无壅义。达是到义。明三乘人根性所宜行必断烦恼无壅。是通义也。明三乘人根性所宜行必到三界外尽无生智。是达义也。无碍者明如来知三乘人根性尽。是无碍也。今者举所宜行通达表明如来知三乘根性尽。故云知一切众生深心所行通达无碍也

又于诸法究尽明了下是第二广上实智章门。就中亦有二。一者识药。二者知病。今言又于诸法诸法究尽明了此是第一识法药之义。此明识实智所照之境。如来实智于一因一果中悉知故言究尽明了也。示诸众生一切智慧此是第二知病。知病之义只知众生有大乘机。即为受记未来皆得佛故言示诸众生一切智慧也。是则识药如前。知病如后。应病与药令得服行

迦叶譬如三千大千世界此下讫是故不即为说一切种智。是第二将欲述已今日得解。先道已昔日不解三一之义。如草木无情禀天泽。增长而不自知增长差别。此中亦有两段者。第一是开譬。第二是合譬。此两段各有二。开譬中有二者。第一譬如三千大千世界以下讫华果敷实以来。詺为禀泽增长譬。第二从虽一地众生下讫各有差别。詺为不自知譬。明三草两木终日禀乎天泽。增长各不自知增长差别之相。内合明四大声闻昔日亲禀受三乘之教。修行而不自知所行只是一乘始终同归得一佛果。又就第一禀泽增长譬中自开为三譬。第一从譬如三千大千以下讫名色各异以来先出能禀。能禀即是草木。第二从密云弥布以下讫其泽普洽以来又出所禀。所禀者是密云。第三卉木丛林及诸药草以下讫华果数实正明禀泽增长也。前明能禀是草木。次明所禀是云雨。后正明禀泽增长也。内合能禀受教者是四大声闻。所禀之者是如来形声利益也。正明禀泽增长者正明四大声闻禀教修行也。就此三譬之中各有二阶。能禀譬中有二者。即是有本有末。但正明草木是其末。此草木应有本。本是土地也。从譬如三千讫山川溪谷土地以来此五种是第一能禀家之本也。第二从所生卉木丛林讫名色各异正出能禀。即是三草二木也。内合为论。能禀家本即是众生过去习因善根。能禀之草木即是今日善习果所成众生。今者欲取草木不取其本。是故下合譬中唯合草木不合其本也。问者言众生有多种自有恶习因所成众生。自有恶报因所成众生。自有善习因所成众生。自有善报因所成众生。今者为取何因所成众生。解释者言。不取两恶因所成众生以为能禀。但两种善因所成众生中唯善习因所成众生为能禀。不取善报因所成众生为能禀也。何以故尔。善报因无有增长之义故不取也。善习因所成众生有增长义是故取为能禀也。问者又言。今取善习因所成众生以为能禀。为当止取善习因有增长义耶。所成众生亦有增长义。解释又言。众生是假名假名无别体以法为体。今习因善是实法。此法成众生。但习因善有增长。众生是假名不当增长。不增长但有名用而已也。问者又言。众生无别体只用习因善为体。习因既增长众生那得不增长。若言众生不增长则不应言以习因为体。解释又言言。我本言假名法无体以习因善为体。若责今众生别增长者便应假名法别有体。云何言以他为体。此中大意片对四大声闻。今涅槃及五乘故借三草二木以譬能禀。草有三种上中下也。木有二种有大木有小木。下经又言大树小树。但草木自有众多今唯取堪为药者。内合众生虽复凡圣众多。止取五乘之人堪修行者为药之用。人乘天乘此二人以譬小药草。声闻缘觉此二人以譬中药草。三乘中菩萨以譬上药草。今大乘中明内凡夫菩萨以譬小树。初地以上菩萨以譬大树。所以人天二乘合譬小草声闻缘觉复合譬中草者。今欲偏片对此人。道其昔日虽禀如来经教不知权实之用同归之理。是故合人天二乘取譬小草如胜鬘所明名为无闻非法众生。此则鄙其昔日不知之义也。复合声闻缘觉者义亦如是也。问者言菩萨等自知如来权实之教同归之义。何故言鄙之。释者言。已如前释但止片对四大声闻缘觉等涅槃及菩萨。若同取闻佛说法增长善根之义。大乘人与小乘人皆有增长。取喻三草二木皆禀天泽增长。若取知与不知之义大意止片四大声闻故涅槃及余人也。问者又言。汝若使菩萨有增长之义以譬二木者。我声闻亦有增长之义以譬药草不言不知之义以譬药草也。解者复言。此品本为述成四大声闻今日得解先道其昔日不解。故以草为譬。道其禀泽不知故。声闻等存不知之边。菩萨存增长之边。第二所禀譬之中有二。一者是所禀家之本。二者正出所禀也

密云弥布遍覆三千大千世界此是第一所禀家之本。本是云也。内合用如来身形及声教譬云。一时等澍其泽普洽此是第二正出所禀。所禀者是雨以譬如来声教所宣之法。即是雨等被众生如天等雨草木。但明此草木同禀天雨生长有升降。如众生同听佛说法增长善根有升降之殊也

卉木丛林此下是第三正明禀泽增长譬亦有二者。第一从卉木丛林下讫各有所受以来名为受润譬。第二从一云所雨下讫华果敷实名为增长譬。前明受润后明增长。内合明众生初始闻佛说法皆欢喜领受。如草木禀天雨一往受润。后明增长者。明众生昔日闻佛说法后相与增长善根。下合譬虽道后生善处以道受乐。此明报因得报果。非不有报因。但今日辨增长之义止取习因习果。明其增长之义。此两譬中各有二阶。受润譬中有二者。第一从卉木丛林及诸药草下讫随上中下以下此牒受润之法。即是三草二木根茎枝叶者喻前所述五种人信戒定慧也。第二言各有所受此一句正明受润之义。内合明众生昔日闻佛说教各各受持。故言各有所受也。第二增长譬中有二阶者。第一言一云所雨先牒增长所由。所由者是云雨。内合众生所以得习善增长者由有如来形声。第二言称其种姓下三句正明增长。此三句亦次第相生。初言称其种性此先举增长之类。喻五乘人根性各有种类而得生长。此正明增长。华果敷实此释成增长之相。若不增长云何言有华果之实也

虽一地所生此下是第二明不自知譬。三草二木终日禀乎天泽不知增长差别之相。明四大声闻昔日亲自禀受如来三乘教执三乘定别。迷同归之理而不自知三乘所行始终只是一乘同趣一果。又就不自知譬中亦有二阶者。第一虽一地所生一雨所润者。先举不自知所由。第二言而诸草木各有差别此正明不自知。虽复有差别之相而不自知。所以有此差别内合四大声闻昔日禀如来三乘别教各得别果。于时三乘自言彼此各异而自不知始终同归俱至极果也

迦叶当知如来亦复如是自此下是第二合譬。但上开譬中本有二。一者是禀泽增长譬。二者不自知譬。今此合譬中亦有二段者。第一从如来亦复如是下竟具足蒙润各得生长合禀泽增长譬。第二从如来说法一相一味以下合不自知譬也。就第一段中有二。第一历别正合。第二举外譬帖合也。历别合者但上禀泽譬本有三。三中各有二。今者合之为体。宜开为五。所以不六者上开能禀譬中有二。一者本二者末。今但合末不合其本。所以成五段。又不次第。今先合云。二合草木。三合雨。四合受润。五合增长。但上草木本是第一。今者在第二。上作次第者先有草木然后兴云注雨则受润增长。今此中则先兴云荫草木然后注雨令草木受润增长也。就合云譬中有二重。一者举佛形合云。二者举如来声教合云。佛形声普周皆譬于云。但第一举如来形合云中自有二阶。第一正举如来形合。第二言如大云起举外譬帖合也。以大音声此下是第二举如来声教合云亦有二重。第一举总合云。第二举别合云。此两段各有二。举总合云二者。第一言以大音声普遍天人阿修罗此正举总声教合云。第二言如彼大云下竟大千国土此举外譬帖合。从于大众中而唱是言以下第二举别声教合云。就此第二亦有二亦有二者。第一正举别声教合。第二奖劝时众来听法也。就第一举别声教合中自有六种别声教。第一从于大众中而唱是言以下先明如来有十号之德。第二从未度者令度下明四弘誓之德。第三从今世后世如实知之此明三达之德。今世即是现在世后世即是过去世。亦是未来世。若据现在追望过去此即后世。若背未来向过去此未来即是后世之义也。第四言我是一切知者此明种智。知一切法故言一切智。此即举境目智也。第五言一切见者此则明五眼之德也。第六言知道者下明有导师之德。开导者开三乘是方便说三乘法只是一乘法故言有导师德也。汝等天人阿修罗此下是第二奖劝来听法也。尔时无数千万亿种下竟来听法此是第二合上草木。上言所生卉木。来至佛所而听法上开譬所无。今日义出也。如来于时观是众生此下是第三合上雨。上言一时等注也。种种无量此下是第四合上受润。此合中自有二。即合上二。上言随上中下。今言种种无量。正合随上中下也。皆令欢喜快得善利即合上各有所受也。是诸众生闻是法已此下是第五即合上增长。上言一云所雨称其种性。今就此合譬中自有二。一者明报果即是是诸众生闻是法已现世安稳后生善处也。亦得闻法此下是第二明得习果也

如彼大云以下是举外譬帖合。但合禀泽譬有二。一者历别正合。此下是第二举五种外譬。帖合如彼大云即帖第一合云譬也。雨于一切此即帖合上雨譬也。卉木丛林即帖合上第二合草木也。如其种性具足蒙润帖合受润也。各得生长此即帖合第五增长譬也

如来说法一相一味此下是第二合不自知譬。就此合中自有五重。一者先出所不知法。二者正合不知。三者形释不知举如来知诸法形释二乘不知。四者举不知外譬帖合。五者还用如来知结合也。今言如来说法一相一味下先出所不知之法自有二。此句作两章门。一相者无为果章门。一味者有为章门。明如来昔日所说三乘之法始终同得一无为一有为之果。故言一相一味也。第二释先释无为章门有三句。所谓解脱相此句正明因果尽处两种无为。下二句别明。离相明因尽灭相明果亡也。究竟至于一切种智者释有为果章门也。其有众生闻如来法此下是第二正合二乘人不自知也。所以者何唯有如来知此众生此下是第三举如来知。形释二乘不知作三阶。第一唯有如来知此众生下正明如来知众生根性。即是知病义。第二念何事下明如来知应根性所须之法。即是识药。何者故如四谛十二因缘等乃至待处待伴种种入道不同也。第三众生住于种种之地下还举众生根性不同。总结如来知病识药也。今者第一知众生种相体性者明如来知三乘种别不同。表相亦异利钝体殊习性非一也。第二明知众生根性所须法者。大论众生心用不出三慧。故举三慧以明所须之法不同。就中自有四阶。初念何事思何事修何事此三句。正明所须境界不同入道各异也。第二云何念云何思云何修此三句。由众生现在修行方法不同也。第三以何法念以何法思以何法修此三句。明现在行家过去因不同也。第四以何法得何法此二句。明现在行家未来果亦不定。若好作文时以何法念得何法。以何法思得何法。以何法修得何法。但文句虽略以义可推也。众生住于种种之地下是第三总结如来知病识药明了无碍也。如彼卉木丛林以下合不自知譬中第四举不知外譬帖合也。如来知是一相此下第五举如来知结合也

汝等迦叶甚为希有此下是第三正述成已今日得解已具足解开三显一。但此文略只道解开权。就此第三段中亦有二者。第一正述其解权第二从所以者何下释也

而说偈言此品有两段即长行与偈为二。自此下有五十四行半偈是第二重颂。但上长行中本有二。一者从品初讫若有所说皆不虚也。先明述成四大声闻叹佛恩深难报今者不颂。所以不颂者。述叹佛恩深难报。此意大悲是正述领解傍及此义。是故略不颂也。唯颂上第二述成正领解而已。但上第二正述成领解之中本有三段。第一从于一切法以智方便竟示诸众生一切智慧将欲述成领解。先出其所领之法。第二从譬如三千大千以下竟是故不即为说以来。名为明昔日不解形今日得解。第三汝等迦叶甚为希有以下正是述成今日领解。就此五十四行半亦为三段。初有四行偈颂上第一出所领之法。第二从迦叶当知譬如大云以下有四十七行偈颂上第二昔不解。第三迦叶当知以诸因缘以下有三行半颂第三正述成领解也。上第一出所领之法本有二。第一有两句开两章门。第二解释章门。今此四行偈亦为二。初两行颂开章门。第二有两行颂第二释章门。就前两偈中初偈颂权智章门。后偈颂实智章门也。今言颇有法王此一偈颂上于一切法以智方便而演说之。即是开方便门。今言破有法王者破二十五有之法王。随众生欲者随三乘根性之欲也。如来尊重此一偈颂上实智章门。上言其所说法皆悉到于一切智地。今言如来尊重智慧深远久默同归之要不务速说也。有智若闻此下两偈颂上第二释两章门。初偈颂释权智后偈颂释实智章门。上释权智中本有两句。初言如来观智一切诸法之所归趣。此是识法知三乘诸法归趣一乘。今者不颂。又言亦知一切众生深心所行通达无碍。此是妙识三乘人根性。今者一行唯颂此也。是故迦叶随力为说此偈颂上释实智。上释实智中本有两句。初又于诸法究尽明了此是识法药义。今者不颂。后言示诸众生一切智慧今者一偈唯颂此句也

迦叶当知此下有四十七行是第二即颂上第二昔日不解。上长行中本有二。一者开譬二者合譬。今就此四十七行中亦分为二。初有十行半颂开譬。第二佛亦如是有三十六行半颂合譬。上开譬本有二。第一禀泽增长譬。第二明不自知譬。今就十行半亦分为二。前有九行半颂禀泽增长。后有一行颂不自知。但上禀泽增长譬中本有三。一者能禀二者所禀三者正明禀泽增长。今就九行半亦分为三。但不次第耳。第一先有四行超颂第二所禀也。第三有两行半还来颂上第一能禀也。第三有三行颂上第三正明禀泽增长也。但上所禀譬中本有云雨为本末。今先有三行颂云也。次其雨普等有一行颂雨也。上雨云譬譬于形声两事。今三行亦分为二。初一行颂颂形云譬。慧云含润下两行颂声云譬。就两行中初行正颂云譬。日光掩蔽此一行是第二义。明含雨云之相自有三意。初言日光掩蔽此一句欲明如来未出之时外道有邪教化人如旱天日光也。今明密云一出日光即隐内合明如来出世之时虽复未说言教。然外道邪教于兹殄灭也。次言地上清凉此是第二意。密云既普上地清凉此明众生睹如来莫不欢喜也。叆叇垂布下两句是第三意。一睹此云似山似石然终不可以手取揽。内合明如来此形有同凡夫之体以智谛求佛身者即法身也。形即不形声即不声也。其雨普等此一行颂雨上言一时等澍其泽普洽也。山川崄谷此下有两行半还颂上第一能禀。上能禀中本有二。一者能禀之本即是土地。今先有半行颂之也。二者正出能禀即是三草二木。今所余两行通颂之也。其云所出此下有三行即颂上正禀泽增长。上正禀泽中本有二。一者受润二者增长。今此三行初一行颂受润后两行颂增长也。上受润中本有二。一者受润所由二者正明受润义。今一行中其云所出半行先颂受润所由也。次有半行正颂上受润也。上增长中本有二。一者正明增长。二者明增长相。今者两行中初一切诸树上中下等有一行正颂上增长也。根茎枝叶一行即颂上增长之相也。如其体相此下有一行第二颂上不自知譬。上譬中本有二。一者不自知所由。二者正明不自知。今此一行通颂之也

佛亦如是此下有三十六行半颂上合譬。今就此三十六行半中亦为两段。初有三十五行颂合禀泽增长譬。一行半颂合不自知譬也。上合譬中分为两段。第一历别合。第二举外譬帖合。今不颂帖合唯颂上历别合。上历别合中仍开为五。先合云次合草木次合雨次合受润次合增长也。今者还依开譬中作三段。复依合譬作次第。今就三十五行初有十三行半颂合所禀。第二有两行颂合能禀。第三有十九行半颂合正禀泽增长。今就十三行半自分为二。第一七行半颂合云譬。第二有六行颂合雨譬。今先颂合云譬。上合中本有二。一者举形合云。二者举声合云也。今七行半中初一行颂举形合。次六行半颂举声合也。上举形合中有二。初正举形合次举外譬帖合也。今佛亦如是下半行颂正合。次半行颂举外譬帖合也。既出于世此下有六行半颂举声合云。上举声合中有二。第一举总声教合。第二举别声教合也。今六行半初一行颂合第一。五行半颂合第二也。上举总声教合中有二。初正举总声合。第二举外譬帖合。今既出于世此一行唯颂正合略不颂帖合也。上举别声教合中有二。初正举别声合。第二劝时众来听。今此五行半中亦有二。初有三行半正颂举别声合。次有两行颂合劝听也。但举别声中佛本有六种德合声。今此三行半中初大圣世尊下有两行颂合十号之德也。次充润一切下有一行半颂合四弘誓之德也。略不颂所余四德也。诸天人众此下两行颂合别声中第二劝来听法也。为大众说此下六行颂合上雨譬。分为四段。初两行正颂合雨譬

我观一切下二行半明心平等。常演说法下一行明无疲厌。充足世间下下半行举外譬帖也。从贵贱上下两行是第二颂合能禀譬也。一切众生闻我法者下十九行半是第三颂合上受润增长。就十九行半中分为二。初十一行颂合受润。后八行半颂合增长。就十一行中自开为五段。初一切众生下半行颂合种种无量句。即是颂合受润众生也。次随力所堪下半行正颂合受润也。次或处人天下七行广举三草二木明受润不同众生。次佛平等说法下一行半明佛心平等而众生受润自异也。次佛以此喻下一行半明是少分喻也。今还就七行广举三草二木。中前四行明三草后三行明二木也。四行明三草者或处人天转轮圣王下一行明人天二乘为小草。知无漏法下两行明声闻缘觉二乘为中草。求世尊处下一行明外凡夫偏行六度菩萨为上草也。三行明二木者有诸佛子下一行半明内凡菩萨为小树。安住神通下一行半明常住以上圣位菩萨为大树也。我雨法雨此下八行半颂合增长分为四段。初一行略颂合第二有一行举外譬帖合也第三有一行半广颂合譬也。第四有五行据五品人颂合也。初一行中自有二。初我雨法雨下三句颂合增长所由。次一句正颂增长也。如彼藂林此下一行是第二举外譬帖合。亦有二。初如彼藂林下三句举增长法体即是称其种姓句也。次一句亦颂增长也。诸佛之法此下有一行半是第三广颂合。初三句正颂合一相一味句。次一句颂合快得善利句。次有二句颂合后生善处句也。声闻缘觉此下有五行广举五品人明增长。但不具足。初声闻缘觉下一行半先出二乘人即中药草也。次若诸菩萨有一行半出小树。即是信首以上菩萨也。次复有住禅得神通下有两行出大树。即是初地以上菩萨也。如是迦叶此下一行半是第二颂合不自知譬也

迦叶当知此下三行半颂长行末第三述成今日之解。上述已解开权略不述解显一。既述开权显实自彰也。今此偈长出显实之义。初有两行半正颂上述开权。次一行长出显实也。但上述开权中本有二。初正述解开权二释。今此两行半唯颂正述句。不颂释句也

法华义记卷第六法华义疏卷第七

        光宅寺沙门法云撰

    授记品第六

此品中为四人授当果之记仍为品目也。若谈受记则义在菩萨。若语授记则义关如来。是则受是取义授是与义也。但记有二种一者能记二者所记。能记即是如来言教正是记体。所记即是菩萨未来佛果及国土名号亦名为记。此是从他得名也。但譬说开三显一化中根人中本有四品即为四段。今此下一品是第四段为中根人授记。前又解言四段中例开为两。今就此授记中有二者。第一正为此四大弟子授记。第二品末一偈即复许为下根之徒说同归之义也

正授记中自有三段。第一先的为大迦叶授记。第二即更为三声闻授记。第三通为五百弟子授记也

尔时大目健连此下第二更为三声闻授记正由已请。是故别为一段。就中自二第一目连等三声闻请记。第二如来为三人各授记即作三阶也

我诸弟子威德具足此下有一行半第三通为五百弟子授记

我及汝等此一行是品中第二段即许为下根人说也

    化城喻品第七

明因中第三广说开三显一中自有三段。即化三根人为三段。自此下竟学无学人记品有三品经。是第三明宿世因缘说开三显一之理化下根人。但上根人中根人中各自有四段。今此化下根人。若准上例应有四段。以义相从只有三义。正有宿世因缘说有授记有领解无有述成。虽有三义只有二段。何以知之。领解入授记中文句既浑直分为二段。第一此化城品正明宿世因缘说化下根人。第二余二品为下根人授记。大意正言。我昔日已曾于大通智胜佛所于时在十六王子数已为汝覆讲说法华今者复为汝说云何三闻不解。是故下经文言我在十六数曾亦为汝说以是本因缘今说法华经。但下根执之徒闻此往因缘相与解悟。就此品中大判为两段。第一从长行初尽偈先明佛智能见往古久远之事。第二从佛告诸比丘下长行初尽偈正明宿世因缘说也。又就此两段之中各有二重。皆有长行与偈为二重。今就前长行明佛智能见古往久远之事中自有三阶。第一先叙出往之事。即是大通智胜佛。第二从诸比丘彼佛灭度以来以下用三千大千世界作墨为往古久远作譬也。第三言我以如来知见力故观彼久远犹若今日正明如来能见久远之事也

而说偈言此下是第二偈颂。上长行中有三。今此七行偈亦分为三。初一偈颂第一也。第二如人以力磨三千大千土以下有四行颂上第二久远之譬也。第三如来无碍智知彼佛灭度以下有两行偈。颂上第三正明如来智能见往事

佛告诸比丘自此下讫品是第二正明宿世因缘说亦有两重者。即是长行与偈为二。就长行之中自有二阶。第一从此下竟住于禅定八万四千劫先明昔日结缘之因由也。第二从是时十六菩萨沙弥知佛入室寂然禅定以下竟长行正明结缘。又就此两阶之中各自有二。结缘之因由中有二者。第一从此以下竟十方诸梵请转法轮以来先明昔日结缘之远由。第二从大通佛受诸梵王请竟入禅定以来明昔日结缘之近由。又就结缘之因由两阶之中各有四阶。今就第一结缘远由有四阶者。第一先明大通智胜佛行道得佛。第二明十六王子请转法轮。第三明大通智胜佛得佛之后神通感动之相。第四明十方诸梵请转法轮。又就此四别之中各自有三异。第一明大通智胜佛行道得佛中有三异者。第一先明大通智胜佛行道佛道难得之相。第二从尔时忉利诸天以下此明大通智胜佛未得佛中间诸天常设供养。第三从诸比丘大通智胜佛过十小劫以下此正明大通智胜佛得佛道。此三异合是远缘。四阶之中第一明大通智胜佛行道得佛也

其佛未出家时此下是第二十六王子请转法轮。就中亦有三重者。第一先明王子为请故来至佛所。第二到已头面礼足以下明既至佛所设三业供养。第三尔时十六王子偈赞佛已劝请世尊转于法轮以下正明王子请佛说法。此三重合是远因由中第二阶明王子请佛说法也

佛告诸比丘此下是第三明大通智胜佛得佛之后神通感动之相。就中亦有三重。第一明佛神通动地。第二从其国中间幽冥之处下明光明普照之相。第三又其国界下明佛光动二相至处远至天宫也

尔时东方此下是第四明十方诸梵请佛转法轮。就中亦有三者。第一先明东方东南方二方诸梵请转小乘法轮。第二从南方乃至下方有七方诸梵请佛转大乘法轮。第三明上方一方诸梵并请转大小二乘法轮。就第一明东方东南方诸梵请中有二。第一先明东方诸梵请。第二东南方诸梵请也。但就一方诸梵中凡有七义。第一先明彼佛光明照相与惊怪。第二明共议此光明所以。第三明诸梵众中有聪明者仍大判光明之意。第四明诸梵等寻光至佛所。第五明诸梵既至佛所故三业致敬。第六正明请佛转法轮。第七明大通智胜佛默然为许之。东南方诸梵七义亦尔。又诸比丘南方此下是第二明七方诸梵请转大乘法轮。亦有二。第一先具明南方诸梵七义。第二西南方以下总据六方帖同南方也。尔时上方此下是第三明上方诸梵并请转大小二乘法轮。唯有六义阙无第七如来默然许之。何以故。尔时已亦请竟佛仍受请说法是故无有默然许之。但第六请说法中两偈前偈请小乘。后偈请大乘法轮也。此四阶之中各有三重合是结缘之远由也

尔时大通智胜如来受十方诸梵天王此下是第二明昔日结缘之近由。就中亦有四阶。第一先明大通智胜佛受诸梵请二乘转法轮。第二明十六王子。于时请佛说法华。第三明大通智胜佛受王子请说法华。第四明大通智胜佛说法华之后仍入禅定避坐作覆讲之由。若不入禅定那得覆讲。又就此四阶之中各有三重。第一受十方诸梵请说二乘法轮中有三重者。第一一往受请。第二即时三转下列出二乘法轮之相。第三从佛于天人大众之中说是法时此下时众有感悟之相也。就第二列出二乘法轮中初出四谛后出十二因缘。此二法轮各有二列四谛。二者初总明三转十二行所谓示劝证也。第二所谓是苦以下别出四谛也。第二列十二因缘二者。初及广说十二因缘下明顺说。第二无明灭故下明逆说也

尔时十六王子皆以童子出家此下是第二明王子于时请佛说法华。就中亦有三重者。第一先明十六王子为请故出家。第二从俱白佛言下正请佛说法华。第三言尔时转轮圣王下明王眷属亦出家也

尔时彼佛受沙弥请此下是第三明大通智胜佛受王子请说法华。亦有三重者。第一正明大通智胜佛受王子请说法华。第二从说此经已下明时众有感悟不同。第三重言佛说是经于八千劫未曾休废明于时说法说法经劫数也

说此经已此下是近因由中第四阶。明如来于时既说法华竟仍入定。只缘佛入定王子覆讲亦有三重者。第一言说此经已即入静室此先明入定之相。第二言住于禅定此正明在定。第三言八万四千劫此明佛在定时经劫数。从品初来至此是长行中第一先明昔日结缘之因由竟

是时十六菩萨知佛入室自此下竟长行是第二正明结缘。就此中自有二者。第一是法说第二是譬说。就第一法说中自有三阶。第一正明昔日结缘。仍道第三今日相值说法华。第二明结缘之后今日相值之前。结括释迦如来始终教化大意。又就此三阶之中各自有四重。第一正明昔日结缘中有四者。第一是时十六菩萨沙弥知佛入室寂然禅定。先明王子得覆讲之意。只由大通智胜佛入室经八万四千劫。于时法座不可令空故。故第二从各升法座以下正明覆讲。第三一一皆度以下明昔日覆讲时听众受悟多少。第四明大通智胜佛过八万四千劫从禅定出赞叹王子也

佛告诸比丘下第二结括始终教化大意。亦有四者。第一从佛告诸比丘是十六菩萨常乐说是妙法华经以下正明昔日结缘之后今日相值前中间常相值遇。第二诸比丘我今语汝以下明昔日覆讲十六王子已现成种觉。第三从尔时所化下会通古今。第四从我灭度后以下此明今日相值而不解者未来世中会得相值。此则明一日结缘历劫不朽之义

诸比丘若如来自知涅槃时到此下是第三阶明今日相值。就此中亦应有四重。文只有三略无第三重。亦可是传者误虽无今日义出。何以知之。下譬中有故在今。玄出四重者。第一从诸比丘竟深入禅定先明众生大乘机发。第二为说法华。第三明以大乘拟宜不得此即是今义出者。第四为说小乘。今先明大乘机发言诸比丘若如来自知涅槃时到者如来说法华时去涅槃经教不赊。大乘机发仍说法华故言涅槃时到。又解言正大乘机发时如来三乘化功将断故言涅槃时到。众又清净者正明大乘机发。若使昔日五浊障大乘机者则不清净。大乘机发五浊不复为障是名清净。信解坚固者昔亦有信不成。使今日大乘机发有大乘之信。今日大乘机发则有大乘之解。解则慧有信有慧有定相资之力。是故大乘机发。了达空法者明昔日无相之法故言了达空法也。便集诸菩萨此下是第二正说大乘。即是说法华。便集诸菩萨者即是。尔时世尊四众团绕之义世间无有二乘而得灭度者即是开方便门。唯一佛乘得灭者即是示真实相也。此下应有第三用大乘拟宜化众生不得。今者玄出应下譬有。下即作懈退譬作本也。比丘当知如来方便之力此下是第四明如来用三乘化得众生。就此第四用小乘化得众生中自有四文。第一言如来方便之力深入众生之性先明三乘拟宜。第二言知其志乐小法深着五欲此明如来见小乘机。为是等故说于涅槃此是第三正为众生说三乘教。第四言是人若闻则便信受此明三乘人受行。问者言。火宅中明大乘化不得然后三乘化得。尔后大乘机发。机发之时为说大乘。今者何故无大乘机为说大经。然后大乘化不得小乘化得耶。解释者言。此意为古今因缘相对。故尔我昔日是十六王子时已知汝有大乘机。即为覆讲说大乘。汝于时已得大乘解为因缘今日大乘机发。时我即为说大乘经汝不可不信也。火宅中作次第者如来出世之始本欲为说大乘经。但于时无有大乘机。我用大乘拟宜化既不得。不可令此众生永沦长苦。是故如来用三乘教化取众生。后大乘机发时方说大乘经也

下譬说中还依本次第。大乘化不得三乘化得。然后大乘机发为说大乘。今者就上法说三段各有四阶。若取若舍若合若离。持作五种法说。上则拟穷子火宅方便品。下则为五种譬作本。五种譬者。一将导譬二懈退譬三设化城譬四知止息譬五将至宝所譬也。法说三段中第二结括释迦如来始终教化大意有四阶。今皆舍而不取。第三今日相值中有四阶。今者皆取。第一正明昔日结因缘中有四阶。有取有舍。不取第一阶明得覆讲之意。亦不取第四阶大通智胜佛从禅定起赞叹王子也。唯取第二言各升法座正覆讲。又取第三阶言一一皆度。于时听覆讲得利益深广者。何以知然。覆讲之主即是道师义。于时得利益。深广即是所将人众义故合此二阶以为一段。上即拟穷子领解中第一父子相失段。远拟火宅中第一宅主总譬。亦远拟方便品中今我亦如是明释迦帖同诸佛作化主同化五浊众生。下为第一将导譬作本也。第三明今日相值中有四阶皆取者。第一言如来自知涅槃时到众又清净下明大乘机。上则拟穷子领解九譬中第七父见子志大譬。亦远拟火宅中第五长者见子免难譬。亦远拟方便品中第五舍利弗当知我见佛子等志求佛道者无量千万亿明时众大乘机发。下则为第四知止息譬作本。第二便集诸菩萨为说。是经上则拟穷子领解中第八付家业譬。亦远拟火宅中第八长者赐大车譬。亦远拟方便品中第八言于诸菩萨中正直舍方便但说无上道即是说法华。下则第五为灭化城将至宝所譬作本。第三言用大乘化不得互出者。上则拟穷子领解中第三唤子不得譬。亦远拟火宅中第三长者救子不得譬。亦远拟方便品中第三我始坐道场佛用大乘化众生不得之义。下则为第三懈退譬作本。第四言如来方便深入众生之性明以三乘化得众生。上则拟穷子领解中第四唤子得譬及第五教作人譬。亦远拟火宅中第四长者用三车救子得义。亦远拟方便品中第四寻念过去佛所行方便力佛用三乘化众生之义。下则为第三设化城譬作本也。是则拟上法说与譬说十段中唯拟第一第三第四及第五第八五段义。不拟余五段义也

譬如五百由旬自此下是第二譬说。此譬说中亦有三段。第一开譬。第二合譬。第三举外譬帖结也。就开譬中自有五譬即譬上五种法说本。第一明将导譬。第二懈退譬。第三设化城譬。第四知止息譬。第五将至宝所譬也

第一将导譬者此为上正明昔日结缘中两阶作譬。与火宅第一宅主总譬相应。上火宅中本有六义。今此譬中以义相从可有四义。略无一门及五百人也。譬如五百由旬者是则依俙似火宅义。欲界如一百色界如二百无色界如三百。七地所断三界余习如四百。八地以上至金刚心所断无明住地烦恼如五百也。崄难恶道旷绝无人怖畏之处是则宅中有火义。是皆生死之地故言崄难恶道。现见生死之中众生余蕴不可秖无。今何故言无人。解释者言。所以言无人者但生死之中逆流去者盖不足言。非不有一两人能逆流者。此不可言以字詺故言无人也。若有多众以下此即是三十子义。即譬上第三阶。言一一皆度下明听众得利益者。有一导师此是长者义。即譬上第二覆讲之主。知众生闻法得解折伏烦恼即是知通义。既失正解更起烦恼即是塞义。于时令众勿没生死远求佛果。即是将导众人欲过此难也

所将人众此下是第二懈退譬。即譬上今日相值中第三互出者大乘拟宜无大乘机。若言中路者五百之中正应断非想一半烦恼。然理实无此。夫论退有两种。一者已涉半路方复退还。二者结契已定方生悔心。今者据后谈义正明于时时众发意欲超越五百由旬。渡两种生死之意。仍失正解无求佛之心。即是退义也。此下皆是理中作语也。就中有二。初一句正明退。第二而白导师言以下释三种因缘故退。一疲极二怖畏三路远。导师多诸方便此下是第三设化城譬。即譬上比丘当知如来方便深入众生之性因三乘化得众生。上譬本中有四今亦譬上四也。第一先明导师用化城拟宜。第二明导师见时人有乐化城之志。第三为设化城。第四明疲极之众即入化城也。今言导师多诸方便此即是上第一用三乘拟宜之义也。而作是念此等可愍下是第二见有乐化城之意。则是上见小乘机之义也。云何舍大珍宝此是无大机而欲退。即是有小乘机之意也

作是念已此下是第三正为设化城。此中自有两段。第一先思惟作化城此是譬本所无说。尽智无生智此二智本出三界外。即是过三百由旬之义也。告众人言此下是第二正为设化城。此中有四句。出上譬本。是广则与火宅中相类也。初言汝等勿怖随汝所欲皆当与汝。此即是保与不虚。下合譬言我今为汝保任此事终不虚句也。莫得退还此是第二。即是勤精进句言汝等于此火宅宜速出来也。今此大城此下是第三。即是示三乘处上言如此羊鹿牛车今在门外可以游戏句也。若人是城中此下是第四即是上赞叹三乘。上言汝等所可玩好希有难得汝若不取后必忧悔也。合譬言汝等当知此三乘法皆是圣所称叹句也。是时疲极之众此下是第四疲极之众入化城即是上诸人受行。此中自有四义。于上譬本则广只与穷子及火宅中相应。初则是外凡夫修行。即是心各勇锐义。是时疲极之众心大欢喜是也。次则明内凡夫修行即是互相推排句。从我等今者下是也。次则明入见谛思惟治道即是竞共驰走义。从于是众人前此五字是也。次明得无学果即是诤出之义。从入化城下是也。自然因尽即是生已度想也。自然果亡即是生安稳想也

尔时导师知此人众此下是第四知止息譬譬上大乘机发。言诸比丘如来自知涅槃时到下是亦远是方便品中我见佛子等。大乘机发之义也

即灭化城此下是第五明将至宝所譬。上便集诸菩萨为说大乘法华。此中言宝处在近即是显实之义。即是上唯一佛乘得灭度耳。亦远是方便品中但说无上道义也。向者大城我所化作者即是上法说中世间无有二乘句明开权之义。亦远是方便品中正直舍方便句也

诸比丘如来亦复如是此下是第二合譬段。此中亦具合上五譬但隐没兼复阙略也。上第一譬中有四义。今此中正合导师一义。复得兼合三义。导师者即是合上导师也。生死烦恼即合上怖畏之处也。险难长远即合上五百由旬火宅也。又言应去应度即是合上若有多众三十子义也

若众生但闻一佛乘者此下合上第二懈退譬也

佛知是心怯弱下劣此下合第三设化城譬。先合第二无大有小。次合第一拟宜次合第三设化城。此中唯合若入是城句也。若众生住于二地。此一句上则合第四受行中生已渡想等二句为二地。下则合第四知止息譬。正由得尽无生二智故则大乘机发也。如来尔时此下即合上第五灭化城将至宝所譬。具合开权显实句先合显实。但是如来方便下合开权也

如彼导师此下是大段第三举外譬帖合。唯帖四譬略不帖第二。今言如彼导师即帖合第一。为止息故下即帖合第三也。既知止息已此即帖合第四也。而告之言此下即帖合第五也

而说偈言此有四十九行半偈。是第二重颂也。上长行本有二。一者结缘之因由。二者正结缘也。今四十九行半亦分为二。初有二十二行半颂上因也。第二是诸沙弥等知佛禅未出下有二十七行颂上正结缘也

但上结缘之因由中本有近远两由。今二十二行半亦分为二种。十二行颂远由。第二无量慧世尊以下有十行半颂近由也。前远由中本有四段。第一明行道得佛。第二明王子请说法。第三明得佛后感动之相。第四明诸梵请说法。今十二行亦颂此。四行颂第一。次第有彼佛十六王子有两行半颂第二。次为觉悟群生有半行颂第三。次有东方诸世界有五行颂第四也。但上第一中本有三。今四行中初一行即颂第一佛道难得也。次诸天神龙王下两行即颂第二诸天供养也。次过十小劫已下一行颂第三正得佛道也。彼佛十六子此下有两行半颂第二王子请说法。上本有三。初有一行颂上第一为请故来至佛所也。次头面礼佛足一句颂上第二致敬也。次而请转法轮下有一行一句即颂上第三正请也。为觉悟群生此下半行颂上第三明感动之相。上本有三。今此半行唯颂第一地动。不颂第二放光及第三二相至处也。东方诸世界此下五行颂上第四十方诸梵请转法轮。上本有三段。第一东方东南方二诸梵请转小乘法轮。第二南方乃至下方七方诸梵请转大乘法轮。第三上方一方诸梵请转大小二乘法轮。今此五行通颂上三段。文句浑杂不可分也

无量慧世尊此下十行半颂上第二近因由。上亦有四段。第一受请说二乘法。第二王子请说大乘法。第三为说法华。第四入定。今此十六行半中初五行颂第一。次有两行颂第二。次有两行半颂第三。次有一行颂第四。但上四段各有三。今五行颂第一。上第一中有三段。今初半行颂第一受请也。为宣种种法下一行半颂第二转法轮之相也。次宣畅是法时下三行颂第三感悟也。时十六王子此下两行颂第二王子请。上有三。今初半行颂第一为请故出家也。后一行半颂第二正请略不颂第三眷属出家也。佛知童子心此下两行半颂第三受请说法华。上有三段今唯颂第一。而有两行半者。先有四行明如来先说三乘法。上言大通智胜受请之后过二万乃说法华。是则未说法华之前应先说三乘次说是法华经如恒河沙偈此半行正颂上第一受请说法华也。彼佛说经已此下一行颂第四入定本有三。今彼佛说经已静室此七字颂第一。入禅定一心一处坐此七字颂第二。八万四千劫五字颂第三也

是诸沙弥等此下有二十七行颂上第二正结缘。上长行中本有二。一者法说二者譬说。今二十七行中初有八行颂第一法说。次譬如险恶道下有十九行颂第二譬说也。上法说中本有三。第一明昔日结缘第二明结括释迦始终教化大意。第三明今日相值。今八行中初三行颂第一昔日结缘。次有四行颂第二结括大意。次一行颂第三今日相值也。但上第一昔日结缘中本有四。今前三行之中初半行颂第一阶得覆述之意。次为无量亿众下一行半颂第二正结缘。次一一沙弥等下有一行颂第三感悟不同。不颂第四大通智胜佛叹王子所说也。彼佛灭度后此下四行颂第二结括大意。上有四段。初一行颂第一常相值也。次是十六沙弥一行颂第二十六王子已成佛也。次尔时闻法者一行超颂第四未来复得相值也。次我在十六数下一行追颂第三会通古今也。次以是本因缘此一行颂第三今日相值。上本有四段。第一明大乘机发。第二明说法华。第三义出以大乘拟宜不得。第四明以小乘化得也。今唯颂第二便集诸菩萨明说法华也

譬如险恶道此下十九行颂譬说也。上本有三段。今此亦有三。初有十一行半颂开譬。次我亦复如是下有六行半颂合譬。次诸佛之导师下一行颂外譬帖合结也。上开譬中有五。今十一行半亦分为五。第一三行颂第一。众人皆疲倦一行颂第二。次导师作是念下五行颂第三。次导师知息已一句颂第四。次集众而告言下两行一句颂第五。第一譬有四义。今虽具足颂四义不次第。第一行颂第二怖畏处。次半颂第三若有多众也。次半行追颂第一五百由旬也。次一行即颂第四导师也。众人皆疲倦此一行颂懈退譬也。本有二。初正明退第二释退意。今者亦有二。初一句颂第一。次三句颂第二也。导师作是念此下五行颂设化城譬。上有四。今不颂第一也。初一行仍颂第二也。次三行颂第三也。次一行颂第四也。上第三段中本有二。第一思惟作化城。第二正设化城。今三行中两行颂第一。次一行颂第二也。导师知息已此一句颂第四譬。集众而告言此下两行一句颂第五譬也。我亦复如是此下六行半颂合譬。初半行颂合第一也。次一行颂合第二也。次一行颂合第三也。次半行颂合第四也。次三行半颂合第五譬也。诸佛之导师此下一行是第三颂帖合结。此中举内合帖结。初一句即帖合第一导师。次一句即帖合化城。次一句即帖合止息也。次一句即帖合至宝所也。唯不合懈退也

    五百弟子授记品第八

宿世因缘说开三显一化下根人有三品经。即分为两段。第一上段化城一品正明宿世因缘化下根人。自此下有两品。是第二为下根人授记。此下根人所以不先领解者解在人后不敢自定。是故如来知其得解仍为授记。但自授记中自含有领解之义。此品亦有富楼那授记。有千二百人授记。亦有五百人授记。亦有总为诸声闻授记。何故记上题五百弟子。解释者言。五百人得授记名号眷属多少悉皆是同复能领解。余者不尔。是故言五百弟子授记品也。此下两品即为二段。前品明无学人授记。第二品明学无学人授记

就此品中自有二。第一先明富楼那蒙授记之事。第二明诸声闻人蒙授记之事。就富楼那事中自有二。第一先明经家叙富楼那得解之相。第二从佛告诸比丘以下正明如来述记富楼那。又就经家叙富楼那得解中有二。第一叙其得解所由。第二正叙其得解之相

第一经家叙富楼那得解所由中有四阶。一者叙解上法说开三显一。第二言又闻授诸大弟子记此明解上譬说开三显一化中根人。第三言复闻宿世因缘之事亲自解上化城中宿世因缘之说。第四言复闻诸佛有大自在神通之力。此叙其闻上化城品初明如来有神通道眼能见久远之事也

得未曾有此下是第二正叙其得解之相亦有四阶。第一先叙得解故内心欢喜。第二从即从座起以下经家叙得解故外形恭敬。第三从而作是念以下经家叙富楼那得解故念佛功德。第四言唯佛世尊能知我等深心本愿。此明经家叙富楼那得解故默感如来。深心本愿者是十六王子时一切智愿也

尔时佛告诸比丘此下是第二正明如来述记富楼那自有二段。即是长行与偈为二也。就长行中自有二。第一记富楼那行因之相。第二过无量阿僧祇劫下记其得果也。第一记其行因相者明富楼那于五佛所护持法藏即成五段。一者先明于释迦所护持法藏。富楼那于时现在众中何故言汝见不。佛意只言汝等但见其形不见其行。故言见不也。第二言汝等勿谓以下明富楼那于过去九十亿佛所能护持法藏。此中意皆发迹也。第三言于诸七佛所护持法藏。第四言于贤劫中诸佛所护持法藏。第五言于未来无量诸佛所护持法藏如此流例皆是行因之义也

过无量阿僧祇劫此下是第二记其得果也

而说偈言下第二正明佛记富楼那中自有二。长行与偈。今是第二偈颂凡有二十一行半偈。解有二种。一解云分为二。初有十四行颂第一记其行因。后有七行半颂第二记得果也。复有一解分为三段。第一先有七行偈不颂上长行。义出泛明诸菩萨示现作声闻影响如来。第二有七行颂上长行中第一行因。第三有七行半颂长行中第二记其得果

今此富楼那此下有七行是第二颂上第一述其行因。但上因之中本有于五佛所护持法藏。今此七行唯得颂二佛所护持法藏。初有五行颂上第二于过去九十亿佛所护持法藏。未来亦供养此下两行颂上第五未来诸佛所护持法藏也

供养诸如来此下有七行半。是偈中之第三。颂上长行中第二正记富楼那得果

尔时千二百阿罗汉此下品中第二明诸声闻授记事。就此中自有二段。第一为诸声闻授记第二尔时五百罗汉于佛前以下明得记人领解也。就正授记中自有二。第一别为授记。第二一行半偈总为诸声闻授记。就第一别授记中有二。即是长行与偈为两。就长行中自有二。第一先为千二百人授记。第二其五百阿罗汉以下为五百人授记也。就初段中有二。一者是千二百人请记。二者言佛知此等下正记千二百人。就请记中有二。一者经家叙。第二正明请记。但千二百人中正举憍陈如为端也。其五百罗汉是第二为五百罗汉授记

而说偈言此下是第二偈颂凡有九行半偈。初有六行偈颂千二百人得记

其五百比丘次第当作佛下有三行半偈颂五百人得记

迦叶汝已知此一行半偈是第二总为诸声闻授记

虽是偈由是长行类也

尔时五百阿罗汉于佛前得授记者明诸声闻授记事中有二。一者正为诸声闻授记。此下是第二明声闻得授记者有五百人领解。就此领解中自有二。即是长行与偈为二也。就长行中自有二。第一略领解。第二广领解。又就此广略两段之中各自有二。略领解中有二者。第一法说。第二今乃知之如无智者以下譬说也。第二广领解亦有二者。即是开譬合譬为两段。就开譬中文取只有五譬义。取应有六阙无第六。今者玄出。何以知之。下合譬中有偈颂中亦有故也。第一詺为系宝珠譬。第二不自觉知譬。第三行他国譬。第四相值譬。第五示宝珠譬。第六得珠欢喜譬。是则文中所无者。第一系宝珠譬者此即领上化城中将导譬。亦远领穷子中父子相失譬。亦领火宅中第一宅主总譬。方便品中今我亦如是下明释迦同诸佛化众生也。第二詺为不自觉知譬者此即领上化城中懈退譬。亦领穷子中唤子不得譬。亦远领火宅中长者救子不得譬。亦远领方便品中如来用大乘化众生不得义也。第三名为行他国譬者。此则领上化城中为设化城譬。亦领穷子中唤子得譬亦教作人譬。亦远领火宅中长者用三车救子得譬。亦远领方便品寻念过去佛下明如来用三乘化得众生也。第四詺为相值譬者。此则领化城中知止息譬远领穷子中见子志大譬火宅中见子免难譬。亦远领方便品我见佛子等志求佛道者下明见众生有大乘机。第五詺为示宝珠譬者。此领上化城中灭化城将至宝所譬。远领穷子中付家业譬。亦远领火宅中长者赐诸子大车譬。亦远领方便品中于诸菩萨中正直舍方便但说无上道说法华经。此中应有第六欢喜譬者。不领化城中则超领穷子火宅及方便品欢喜义也。但化城品中将导譬有四义。今此第一系宝珠亦有四义譬。若有人者则是下根人自譬。则是上譬说中若有多众下明三十子义。至亲友家即是上五百由旬及一宅也。醉酒而卧即是上怖畏之义。是时亲友以下即是领导师义也。内合十六王子。昔日覆讲则是亲友。于时听众即是有入于生死。覆讲之处即家也。醉酒而卧者烦恼自惛醉而卧。有人解言。即来亲友家言亲友与其酒。亲友是十六王子。云何言子与众生烦恼。诸佛圣人不为众生作烦恼因缘。故知入余处饮酒来至亲友家。下言其家甚大富具设诸肴膳。自有人一日恒设[麩-夫+并]果只自无有酒也。官事当行者非是初行内合于时十六王子覆讲缘既尽更为余方便法。故言官事行也。宝珠系其衣里十六王子于时覆讲为众生说大乘。今于时众生相与得解大乘。大乘之理最贵故言无价。此大乘解可珍可重如宝。其理必圆如珠为因之义。不亡名为系。既是外凡不亡坏故言衣里也。其人醉卧都不觉知。此是第二不自觉知譬。此则领懈退譬。内合昔日十六王子既为说大乘得行大乘解王子便往余方。众生遂失大乘解自从失解来都不觉言我有大乘解不知此则无大乘机也。起已游行此下是第三行他国譬。内合众生既无大乘根机唯有小机。从小乘教修行求因觅果。此则领上设化城譬。上譬中本有四重。一者用化城拟宜。二者有堪闻化城之机。三者正为设化城。此三阶今者都不领。唯领第四诸人受行。上受行中自有四阶。今者亦具领四阶。一者言起已游行此则领上是时疲极之众心大欢喜。明外凡夫修行即是心各勇锐闻法信受。二者言到于他国此则领上言我等今者免斯恶道即是内凡夫修行。信道五根立故言他国。三者为衣食故勤力。此则领上于是众人前见谛思惟治道即是竞共驰走。四者言若少有所得便以为足。此则领上入化城生已度想明无学果即诤出火宅义也。于后亲友会遇见之此是第四相值譬。此则领上知止息譬言尔时导师知此人众既得止息。下明大乘机发也。而作是言咄哉丈夫此下是第五示宝珠譬。此则领化城中即灭化城将至宝所譬。亦远领火宅方便品今行大乘因取大乘果。故名贸易所须也。此下应有第六欢喜。文中阙者今且悬出对下合譬也

佛亦如是此下是第二合譬也。从此下竟令发一切智心以来合上第一系珠譬。为菩萨时即合亲友教化我等令发一切智心即合以无价宝珠系其衣里也。而寻废忘不知不觉此则合上第二不自觉知也。既得阿罗汉道此下合第三行他国譬。但上譬中本有四阶。今唯合第四阶言若少所得便以为足句也。一切智愿犹在不失此合上第四相值譬。上言会遇见之也。今者世尊觉悟我等此下合第五示宝珠譬。我今乃知实是菩萨以下悬合第六欢喜上所无者

而说偈言此下十二行半是第二颂上长行。长行中本有二。一者略领解。二者广领解。今十二行半偈亦分为二。初两行半颂略领解。后十行颂广领解也。上略领解中自有二。一者法说二者譬说。初两行颂法说。半行颂譬说。譬如贫穷人此下十行偈颂上第二广领解。上广领解中有开譬合譬为两段。今六行颂开譬。四行颂合譬。上开譬中有五。今六行中具颂六义。初一行三句颂第一譬。时卧不觉知此一句即颂第二譬。是人既已起此下两偈颂第三行他国譬。与珠之亲友半行颂第四相值譬。苦切责之已半偈颂第五示宝珠譬。贫人见此珠一行义颂第六欢喜譬。上长行所无也

我等亦如是此下四行颂合譬。略不颂合第四譬。初一偈颂合第一系宝珠譬。我等无智故半行颂合第二譬。得少涅槃分半行颂合第三譬。今佛觉悟我一偈颂合第五譬。我今从佛闻一偈颂合第六欢喜譬

    授学无学人记品第九

此品受记之中第二为学无学人授记仍为品目也。就此品中自有二段。第一请记。第二佛授记。就请记中自有二。第一阿难罗睺罗二人请记。第二明二千人请授记

佛告阿难汝于来世自此下第二正授记。就授记中亦有二。第一先为阿难罗睺罗受记。第二为二千人受记。就第一中自有二。初为阿难受记。第二为罗睺罗受记。就阿难受记中自有五阶。第一正为受记。第二从尔时会中有新发意者见阿难得记心生疑念。第三从尔时世尊知诸菩萨心之所念下明往因缘释大众疑念。第四阿难面于佛前此下明阿难因闻往昔因缘仍得宿命智。第五说偈赞叹如来也

佛告罗睺罗此下次为罗睺罗受记。自有长行与偈为二也

尔时世尊见学无学人其意柔软。此是第二为二千学无学人受记。就此受记中自有二。第一正为受记。第二学无学人得受记已欢喜叹佛

    法师品第十

此品明受持读诵解说书写五种法师之德故言法师品也。十二品经开三显一以明因义自有四段。第一略说开三显一动执生疑。第二怀疑故致请。第三广明开三显一断疑生信。三段已竟自此以下有四品经。是第四名别流通因义。前又解言。第一第二各开为二。第三第四各开为三。就此第四段中三段者。第一法师品见宝塔品此二品经明受持此经者勋深流通者报重。则明勋深报重。命觅通经之人。第二持品时众既闻勋深报重则能通经者受命通也。第三安乐行品摄退堕之人。何者但时众有小行菩萨亦欲信习流通。见持品末明诸大菩萨于此恶世通经。有摈黜之过身命之危。则言我等既未及大士何能于此恶世流通此经相与退没。为此义故有第三安乐行品。明四种安乐之行摄退堕之人。若欲于恶世中流通经者当修四安乐行。则免危得安离苦得乐。又就此三段中第三各开为二。中间第二受命中文有五别。第一命觅通经人中有二者。即两品为二。第一法师品明释迦自觅通经之人。第二见宝塔品明多宝如来助释迦命觅通经人。又就释迦自命觅通经人中有二。第一从初竟我今获大利偈已来据勋深报重正命觅通经人。第二从药王今告汝下讫品举通经轨则命觅通经人也

又就第一据勋深报重命觅通经人中有二阶。第一据通经弟子以明勋报。第二若复有人受持读诵以下据师以明勋报也。所以知前者为弟子后者为师者此经詺受持读诵等以为五种法师。故前者未能读诵等。只闻经随喜而已故为弟子。后者自能受持等故作师名也。此二阶中各有二。就弟子明勋报有二者。第一就现在世明弟子。第二据佛灭后明弟子。此二阶中例皆有二。就现在世明弟子中自有二者。第一从品初竟一念随喜者先明现世弟子勋相。第二言我皆与受菩提记此明共得报重也

佛告药王又如来灭后此下是第二明佛灭后弟子。就中例有二者。第一先出佛灭后弟子勋相。第二言我亦与受菩提记正明报重也

若有人受持读诵此下是第二据师明勋报。就此有二者。即是长行与偈为二。且就长行中自有二段。第一据别门明师。第二药王若有恶人下据总门明师。所以言别者。一段文中具三义。故一者佛在世师佛灭度后师异。二者上下品师。三者两师各辨勋报也。所以言总者亦具三义反取即得。又就别明师中有二。第一明佛现在世五种法师。第二据佛灭后明法师。就现在世明师中有二。第一明佛现在下品法师。第二明现在世上品。所以名作上下品法师者。读诵少者为下品。读诵多者为上品也。就现在明下品法师中有二阶。第一正出下品法师勋相。第二从若有人问何等众生下明下品法师得报重也

何况尽能读诵者此下是现在世法师中之第二明上品法师亦有二阶。第一总况出上品法师勋深报重。上云只能受一句一偈者。是下品法师也。今尽能受持读诵者即是上品法师。第二言药王当知是人自舍清净业报此则别明上品法师勋深也

若是善男子善女人我灭度后能窃为一人。此下是第二明佛灭度后法师。就中亦有二。第一佛灭度后下品法师。第二亦况出上品。就下品法师中自有二阶。第一正出下品法师相。第二言当知是人则如来使下明勋深也。何况于大众中广为人说此是第二言明佛灭后上品法师。此中应有勋报而无至偈颂中方有也

药王若有恶人下长行中明法师自有二。此下是第二据总门明法师。就中自有二。第一明逆之者得罪。第二明从之者得福也。就第一阶中复有二。初正明逆之者得罪。第二其有读诵以下明法师勋相也。今者第一见受持读诵者不可轻毁。所以谤罪重于佛者正由谤此人。故今法华不通遂断三宝之种故所以罪重也。虽谤如来不能令三宝永断故言罪轻。只取一边不论福田厚薄也。其有读诵下是第二法师勋相。为如来肩所荷担者此人为如来所重。故言荷担。不言如来身荷担也

其所至方此下是第二明从之者得福。亦有二。有正有释即是报深也

而说偈言据师勋报中自有二。第一是长行。此下是第二偈颂。有十五行偈自分为二段。第一有两行偈义出不颂长行直漫奖劝时众受持此经。第二若有能受持此下有十三行偈正颂上长行。但上长行中本有二。一者据别门明师。二者据总门明师。今就此十三偈亦分为二。初有七行颂上第一据别门明师。第二余有六行偈颂上据总门明师。上别门明师中复有二。一者明现在师。二者佛灭后之师。就七行中亦分为二。前有四行颂现在师。后三行颂灭度后师。就现在世师中本有二种。一者下品二者上品。今就四偈中初一偈颂下品法师。后三行颂上品法师。但上明下品法师中自有二阶。一者正出下品法师勋相。二者报重。今一偈中上半颂正出下品法师勋相。下半颂报重也。诸有能受持此下三行颂上现在中上品法师。上本有二阶。一者总况出上品法师勋深。二者别明上品法师勋深。今就此三行中亦复有二。初半偈正颂法师勋深。上言何况尽能受持者也。下余两半颂上别明勋深。吾灭后恶世此下三行颂上第二明佛灭后法师。此中有二种。一者是下品二者是上品。今就三行亦分为二小不次第。初有两行先颂况出上品。上言何况于大众中广为人说。上又阙无勋报今偈中有。此两偈亦有二阶。初半偈颂正况出上品法师。第二从当合掌礼敬下有一行半。义颂报深。长行所无者。若能于后世此下一偈倒颂下品法师。上本又有二阶。一者下品师相。二者明勋相。此一行亦有二。初半偈颂第一下半颂第二

若于一劫中此下六行偈是第二颂上第二据总门明师。中本有二。一者言逆之者则得罪。二者言从之者则获福。今此六行亦分为二。初有两行颂第一逆之者得罪。第二从有人求佛道有四行颂上第二从之者得福也

药王今告汝自此下品中第二段。上来举勋报。命觅通经之人此下是第二段举通经轨则。命取通经之人就此中亦有两段。即长行与偈为二也。就长行之中自有三段。第一从药王今告汝以下竟当知是为增上慢者先赞叹此经。第二从善男子善女人如来灭后欲为众说云何应说以下正明通经轨则。第三从药王我余国遣化人下竟长行奖劝通经之人

就第一叹经中有五重。第一先明格量。第二就人叹。第三就处叹。第四据因为叹。第五据果为叹也。以众经格量乎此经此经为第一者。若明称会物机为第一者。则五时经教皆是称会物机。今不论此处。只言会前开后詺为第一。会前者谈三乘无异路语万善明同归。开后者明万善皆成佛寿命长远。此则开涅槃前路作常住之由渐。然则前后两望二义双明。下即出言已说今说当说。已说者昔来三乘等教。当说者即指涅槃为当说。今说者即是法华有如此义。故称第一也。药王当知如来灭后此下是第二据人为叹。明此经在人则人尊。慈悲覆护如衣覆也。如来位心同归之理此人意无。二无之中故云共宿也。药王在在处处此下是第三据处为叹。明此经在处则处重。药王多有人在家出家此下是第四就因为叹。其有众生求佛道者此下是第五就果为叹。只就此第五自有五重。第一法说叹。第二譬如有人下譬说叹。第三菩萨亦复如是之下合譬叹。第四所以者何下释叹。第五若有菩萨下诫劝时众叹也。二乘教如燥土。说无量义经于时直明万善成佛如湿土。若说法华教决定无有三一时得佛果譬泥也。药王此经开方便门者开三乘是方便。示真实相者示同归之理。是法华经藏者此经明因谈妙果。在此中故言藏也。深者金刚方穷其底故言深也。不可破坏故言固。其理杳然故言幽。行因久到故言远也。得之者少故言无人能到也

若有善男子女人此下是第二正明通经之轨则。就中有三段者。第一先假说问通经之轨。第二入如来室下次第列出通经之轨三种章门。第三别释也。今明第二。此中则以法为通经之轨。下总通经中以药王等诸菩萨则以人为通经之轨。下单举人不无有法。此中单举法不无其人。人法互举。欲令两义双显。如来室者此下第三次第解释通经之轨三种章门也

药王我于余国此下是第三奖劝通经之人就中有五段。第一明如来遣化人为通经之人集听法众。第二方亦遣四部众听其说法通经。第三明若于山林旷野无人民处我亦遣天龙八部听其所说。第四言此人若在殊方异立令通经之人时复得见我身。第五言此人若通经之时有忘失章句者我以神通道力令其不忘

而说偈言举通经轨。命觅通经人。中本自有二。即是长行与偈为二。此下是第二偈颂凡有十八行半偈自分为二。第一有一偈先总劝此则不颂上长行。如人渴须水此下十七行半是第二正颂上长行。但上长行本有三。一者叹经。二者正出通经之轨。三者奖劝使通经。今此十七行半偈亦为三段。初四行颂第一。次四行半颂第二。下余有九行颂第三。上第一叹经中有五种叹。今此四行唯颂第五据果为叹。上自有五重。今此四行中初一行半颂第二譬说。后二行半颂第五诫劝时众。余三重略不颂也。若人说此经此下四行半是第二。即颂第二正出通经轨则。上长行中本有三段。今者不颂第一假问出通经之经法。唯颂后两段。初一行半颂通经之法三种章门。次余有三行颂第三解释。若我灭度后此下九偈颂上第三段。上本有五阶。今亦颂尽但小不次第。初一行半偈颂第二。第二从引导诸众生下有一行半追颂第一第三。从若说法之人下有一行半超颂第四。第四从若忘失章句又有一行半仍颂第五。第五从若人在空闲有三行追颂上第三

    见宝塔品第十一

命觅通经中有两段。第一是法师品明释迦自命通经之人。此品是第二明多宝助命觅通经之人。由多宝如来赞叹释迦言谁能于此广此经。因此得助释迦。此两段各开为二。前释迦自命中有二者。一者举勋报命通经人。第二举通经轨则已命觅通经之人。此二已竟今此品助命觅通经人。中有二段者。即是长行与偈为二。长行中自有二十段。第一经家叙宝塔之相。第二塔中出声赞叹释迦。第三大众起疑。第四大乐说咨问佛。第五佛答宝塔来竟。第六大乐说愿见多宝如来。第七佛答应先集分身诸佛。第八大乐说复欲见分身诸佛。第九释迦放光照诸佛。第十分身诸佛共议欲来。第十一释迦三过变土。第十二分身诸佛来相问于释迦。第十三释迦在空开塔。第十四明大众见多宝佛之相。第十五明大众散华供养。第十六多宝分座与释迦。第十七释迦就座。第十八大众愿在虚空。第十九佛神力接大众在空。第二十正唱慕觅通经人也。初品以来是第一经家叙宝塔之相。从尔时宝塔中出大音声下是第二赞叹释迦。从尔时四众下是第三明时众既见宝塔相与生疑。尔时有菩萨名大乐说下是第四明大乐说既知时众有疑即咨问如来。从尔时佛告大乐说以下是第五明如来答大乐说述宝塔来意。下偈正颂此也。从是时大乐说下第六明大乐说仍发愿欲见多宝如来。从佛告大乐说下第七答大乐说。言汝若欲见多宝如来者应先集十方分身诸佛。下偈中亦颂。此中从大乐说白佛言下第八明大乐说既开佛道欲集分身诸佛仍发愿欲见分身诸佛。从尔时放白毫一光此下是第九明释迦如来放光照十方分身诸佛如来。于时直放光无有言语。但是经家语而已。所以放光集诸分身佛者。此品为欲显发愿通经。告言十方诸佛尚为法来尊重此法。汝等云何不流通此法。且自十方佛在一处欲表明同归之义。又解释第四疑。疑久灭度佛云何得来。今云应不实应显灭不实灭也。尔时十方诸佛各告众菩萨言下。第十明十方诸佛既被光明所照与诸菩萨共议欲来。时娑婆世界即变清净此下是第十一明释迦如来三过变土欲容诸分身佛。于时只是如来神力变土是故经家述之。所以三变者表明破三乘执心也。则其土转广二乘之狭意也。下偈中亦颂此也。是时诸佛皆遣待者此下是第十二明诸佛既集遣使相问于释迦。尔时牟尼佛见所分身佛悉已来集。此下是第十三明释迦如来既得相问欲开宝塔即起在空开塔。即时一切众会此下是第十四经家叙大众既见多宝如来之相。尔时四众等见过去此下是第十五明大众既见多宝如来散华供养说如是言。有人解言于时时众有语但经文略不载。多意谓不尔。此只取上多宝如来赞叹释迦之言也。尔时多宝如来于宝塔中分半座此下是第十六明多宝分座释迦坐。即时是释迦牟尼佛此下是第十七明释迦就坐。所以言多宝佛与释迦共者灭度佛既坐此意表释迦不生而现生。释迦与多宝并坐者。此明双树灭非实灭。尔时大众见二如来此下是第十八明大众既见二如来在空仍复愿在于空。即时释迦以神力此下是第十九明如来即以神力接大众在空。以大音声下竟长行是第二十段正唱慕觅通经之人。下偈亦颂此也

而说偈言一品中有二段即是长行与偈为两。自此下有四十八行偈是第二偈颂。长行本有二十段今唯颂四段。三行半颂第五。三行颂第七。五行半颂第十一。三十六行颂第二十段也。今初有三行半颂上第五。上第五言佛答大乐说明多宝来意又我分身此下有三行颂长行中第七。第七明佛答大乐说言汝若欲见多宝如来今应集诸分身诸佛也。为坐诸佛此下有五行半偈颂长行中第十一。上第十一言时娑婆即变清净明释迦欲容诸分身佛故三过变相。但上是经家述如来神力。今此五行半还是经家说偈也。告诸大众我灭度后此下余有三十六行偈颂长行中第二十。上言以大音声普告大众正命通经之人。就三十六行中自有六段。第一言告诸大众有一行半正颂上长行。第二从其多宝佛有三行略劝时众发愿通经。第三从其有能护此经法者有四行偈。则言若能弘通此经者则是供养如来。第四从诸善男子各谛思惟有十八行广寄诸难奖劝弘经。第五从我为佛道下有三行半释迦自举昔日弘经以劝时众。第六从此经难持若暂持者尽品有六行举果报劝时众弘经也

    持品第十二

此品明五种人受持弘经故言持品也。四品明别流通有三段。上来两品是第一命觅通经人。此品第二明通经者受命通经。有五种人发誓通经以为五段。第一先明药王菩萨及大乐说。颁类有二。一者诸大菩萨自誓通经。第二明众中声闻得记者有五百人自誓通经。第三明学无学人得受记者自誓通经。无学人已断三界果。云何得在净土通经。解言。无学净秽两土实无有生。但为弘经故回相似无漏业寄在三界内生。若论此报实非三界果报。第四段从尔时佛姨母以下明尼众自誓通经。尔时世尊视八十万亿此下竟品是第五明八十万亿诸大菩萨发誓愿弘通经也。虽有五种以类相推应有三段。第一明大行菩萨秽土流通。第二中间三人明声闻人于净土流通。第三最后一人净秽二土悉皆流通此经也

    安乐品第十三

此品中明弘经菩萨具四种行。则能离危得安远苦得乐。是故出经者仍为品目也。前解言。第四段别流通开三显一之义有四品经而判为三段。第一法师品及见宝塔两品经先明通经者勋深受持者报命觅通经之人。第二持品一品则明会福乐善之徒相与佛前发誓受命通经。皆言不爱身命惜无上道。但上持品未通经之时有毁谤之咎身命之忧。是则下品菩萨本欲发誓通经。既见恶世多难便起退转之心罢通经之意。是故此品是第三如来则用安乐行故接下品退堕之人。则言若能具此四行者天魔不能忤。则于恶世中亡身济物没命度人。是则下品之人因此起弘经之心。更起渡人之意也。前又解言此三段前一后一各有二。中间自有五别。今此中有二者。第一文殊问第二如来答也。今且就问中自有二阶。第一先赞上能通经者。第二从世尊以下正作问也

佛告以下是品之第二明如来答。就中自有四段。第一唱四行之数。第二此一者安住下出四行体。第三我灭度后下一行半总劝修此四行。第四临品末二十一行半通明四行得果安乐相也

释四安乐义凡有四阶。第一正出体。第二明智慧功德为行。第三明自行外化为行。第四明其四行之位。第一正出体。四安乐者第一以智慧为体第二以说法为体第三以离过为体第四以慈悲心为行体。第二明智慧功德往判者。第二同是智慧欲智在说故。第二亦是智慧。第三第四同是功德故智慧门中离出说法。功德门中离出慈悲故有四行也。第三自行外化判者第一第三是自行。第四同是外化凡通经之法。不过自行外化。所以有此四行者自行外化各分为二。自行分为二者有两义。故一者第一是照假实二空之解。此是智门第三明离过此是断门所以自行须明二也。第二义者智慧语其照境。自是行善取其离过边。即是止善既有止行之别故分为二。外化所以分为二者。若语慈悲则谈其本若语其说法则论其末。若使但有知说法无有慈悲者是则如无记语。若使但有慈悲无有说法者是则与乐拔苦之行终不能成。故以外化须明此二也。第四明判此四行位始则四念之初未至世第一法也。何意判位。但在此处者。解释者言此之四行本为接外凡夫菩萨不得过深也。今当安住四法此是第一总唱数也

一者安住此下是第二出四安乐行体相即成四段。又就此四行之中文句不同。但解前两行之中各有三段解。后两行之中各有二文也。今且明初行中有三者。第一从此下竟二十三偈以来正解初行体相。第二若有比丘有四行半偈明得果安乐之相也。第三文殊师利是菩萨有一行一句结此初行也。今且就第一正解初体相中行自有二。第一是长行。第二是偈颂也。今且就长行中自有两段。第一有一行许文。先据行作两章门。次明后恶世中能流通此经义。文殊师利云何菩萨下第二正释两章门。不释能流通义也。两章门者行体章门方便章门也。安住菩萨行处是行体章门。此行然解假名实法空为体。今假实二空为解。心所缘之境故言行处也。亲近处是第二章门即是而二空解方便道。次能为众生说是经者。正明始行菩萨佛灭度后于恶世中流通此经。时要须解心安住假实二空及方便道。怨亲平等善恶齐劝者。则能天魔外道不能伤害离危得安离苦得乐也

文殊师利云何菩萨以下是第二正释两章门。先解二空解行处章门。后解两家亲近处章门也。今且就解行处之中自有三段。第一总章门。第二别释两行。第三总结也。今言云何菩萨行处此是第一总章门也。若菩萨此下是第二别解。今就此中自有二。一者先解假名空行处。第二解法空行处也。今解假名空行处有二种。一解云。菩萨住忍辱地柔和善顺此一句明得假名空故口无四过也。而不卒暴第二句得假名空。故身无三不善业也。心亦不惊。第三句明得假名空故意无三不善业也。此三句皆就用以明假名空相。若以此文检假空实自难见。故以下法空行处得知。前是假空也。下明法空行处言又复于法。故知前是假名空也。下偈颂中广颂法空。后复言亦复不见是男是女。故知是假名空也。又解三句解假名空行处。此则就人表假名空相。初句据外恶来时我不起恶也。后句据善境来时我心不惊也。何以知之。闻圣人说无我空之时我心不惊。中间而无卒暴句正据我内心也。若不得假空者则不如此也。又复于法无所行此下三句明法空行处。此句明解法有智。不作实心行境也。而观诸法如实相第二句明解法空智也。亦不行亦不分别是第三句则明得法空之时无有分别彼此之义。昔日未得法空之时作意言我只能行彼不能行此有彼此分别之意。今日既得法空。唯一相无相无彼此之殊也。是名菩萨摩诃萨行处。是第三总结二行处也

从云何名亲近处此下是第二则解两家亲近处。此中有二。第一云何名亲近处提章门。第二正释。中自有二。第一先解释假名空亲近处。第二解释法空亲近处。此则是两家方便道也。今日就解假名空亲近处中自有三段。第一先明所不亲近处。第二明所亲近处。第三总结也。若论方便体者以实法过假名未得真观以来正是方便体。今者且就外缘作方便故如此说也。就解所不亲近处中自有八种。第一先明离力势缘也。菩萨摩诃萨不亲近国王下是第二明离邪见缘。从不亲近诸外道下是也。第三明离恶业缘。从亦不亲近下是也。第四明离小乘缘。从又不亲近求声闻下是也。第五明离爱染之缘。文殊下是也。第六明离无志之缘。五种不男是也。第七明离讥呵之缘。从不独入下是也。第八明离散乱之缘。从乐畜年少下是也。常好坐禅此下是第二正明所亲近处也。文殊下是第三总结也

复次此下是第二明法空亲近处亦有三。第一先明所亲近处。第二正明能亲近体。第三总结也。所亲近处者即是二谛境也。能亲近者是能观之智也。明所亲近中有二。第一明真谛第二但以因缘故有下明俗谛也。就此明真谛之中自有三。第一观一切法空如实相一句正明真谛理。第二从不颠倒以下六句明心行处灭。第三一切言语道断下十一句明言语道断也。但以因缘故有下二句是第二明俗谛也。从常乐观如是法相者是法空中第二明能观智也。是名近处是第三结也

而说偈言此下是第二偈颂。但上长行中本有二。第一先据行作两章门。次明于后恶世中能流通此经。第二正释两章门。不释能流通义也。今此二十三行偈亦分为二。初有一行半偈颂第一举行作两章门。常离国王以下二十一行半颂第二正解释也。第一段有二先作两章门。次明能流通此经。今倒颂一行先颂第二明能流通。次半行追颂第一两章门也。上第二释中先明行处。后明亲近处为二。今此偈中不得依上直判为三段。第一有十三行半先颂假名空亲近处。次有两行半追颂两行处。第三有五行半颂法空亲近处也。上释二亲近处有二。初提章门今不颂之。唯颂第二正释。但假名空亲近处中本有三。第一先明所不亲近处。第二正明所亲近处。第三总结。今不颂第二所亲近处。十三行半偈中初十二行半颂第一所不亲近一行颂第三总结也。但上所不亲近处有八种。今此十二行半唯得通颂之不可分也。是则名为此一行颂总结也。但本论近处。此中何故举行处结耶。解释言。此举行处近处故前行也。此二处者此近处是第二。前行处是第一。故道二也

又复不行此下两行半是第二段则颂上两行处。上本有三。一者提章门。二者正释。第三总结。今不颂第一唯颂后两段。初两行颂正解。次半行颂结也。但上先解假名空行处。次法空行处也。此二行则倒颂。初一行先颂法空行处也。次一行追颂假名空行处也。是则名为此半行颂上第三结也

一切诸法下此五行半第三颂上法空亲近处。上本有三。第一明所亲近处。第二明能亲近。第三结也。今此五行半直分六段。第一有一行半先略颂上第一所亲近处也。第二颠倒分别诸法有无下有一行则举非形是。上长行所无。则明此人不能作法空亲近观也。第三在于闲处下有半行正颂上第二能亲近处。即是上常乐观如是法相也。第四安住不动下半行则广颂所亲近处也。第五者观一切法皆无所有下有一行三句。倒颂上法空行处也。第六有一句则上第三法空亲近处结句也

若有比丘但解初行中有三段。此下有四行半。是第二明得果安乐之相。就中自有二。第一一行半明离危苦。第二菩萨有时入于静室下三行明得安乐也

文殊师利是名菩萨下一行一句是第三结初行也

第二安乐行正以说法为体。然说法本是口业今者正取动口善心为此行体也。前解言初两行中各有二段。今此第二行中有三者。第一先总劝人修此安乐行。第二若口宣说下十一行半偈正明行体相。第三最后我灭度后下五行偈则明得果安乐相也

从又文殊师利如来灭下是第一总劝人。末世通经应住安乐行也

若口宣说以下竟十一行半偈是第二段正解释此行体。今就此第二中自有二。第一是长行第二是偈颂。今且就长行之中自有二将欲明此行体。是故第一先明离恶。第二诸有听者以下正明此行体相。但下第三行亦明离恶。今此中复明离恶与下何殊耶。解释者言。凡有三意初意言。此中所以明离恶者。夫说法必清净化物没命度人。是故将明清净说法先明离诸过恶也。第二意此中先明离恶后正明说法。下第三行发初正明离恶也第三意言下偈颂之中则先颂说法后颂离恶。是故验知正以说法为体也。今且明离恶之中有三段。若口宣说下两句明说法时节。第二不乐说人以下正明离恶。第三善修如是安乐心故一句结句也。就第二离恶中凡离六种。一者言不乐说人此明不说出经人过也。二者言及经典过者此明不谛经文辞句也。三者离言彼通经是此通经之非从亦不轻慢下是也。四者从不说他人好恶长短可言不说他人之短。何故言不说他人之长耶。解释者本言。此中道长者本欲为显其短也。五者从于声闻人下则明不说小乘之过。此中但明不称小乘之名也。若有乐小乘者亦可慢称有名也。六者言亦不生怨嫌之心也

诸有听者下此是第二正明此行体相。此中自有二。一者明默来听者不逆其意也。二者从有所难问下明有咨问不逆其意也

而说偈言此下是第二凡有十一行半偈。今判为两段。初有六行半先颂上长行中第二正明行体。次有五行倒颂上第一离恶也。但上长行第二之中本有二。初明默听后明问难。今此六行半宜分为三段。第一有两行半先明说法之方此是上长行所无也第二若有比丘及比丘尼下有两行则颂上第一默来者听也第三若有难问下有两行即颂上第二难问者除懒堕意此下有五行则颂上第一离恶然上本有三有今此五行之中不颂第一与第三唯颂第二上第二中本有六。今正宜分为二。初有两行半先明离懈怠之恶也。次衣服卧具下有两行半则明离贪欲希望之恶也。我灭度后此下有五行是第三段则明得果安乐之相自有二。初三行明离危苦义也第二智者如是下有两行正明所得安乐相也

法华义记卷第七妙法莲华经义记卷第八

        光宅寺沙门法云撰

    安乐行品之余

次明第三行。此行以离恶为体。有两段者即是长行与偈为两段也。今且就长行之中自有三段。第一正明离恶。第二当于一切众生以下则明修善。若不修善无容离恶也。第三文殊师利以下明得果安乐之相也。今明离恶之中凡离六种恶。一嫉妒也。二谄也。此人实能修善只自所悦人情也。三诳也此人内心无有实行也。四亦勿轻骂学佛道者也。五若比丘比丘尼下五行是不轻小乘学也。六又亦不应戏论诸法有所诤竞也

当于一切众生下是第二明修善自有四种善。于一切众生起大悲想也。二于诸如来下也三于诸菩萨下也。四于一切众生下也

文殊此下是长行中第三则明得果安乐之想也

而说偈言此下六行是第二偈颂也。然上长行之中本有三段。今此六行偈颂亦分为三段。第一有两行即得通颂上第一正明离六种恶也。第二是佛子说法下有三行则通颂上第二修四种善也。第三第三法如是下有一行偈则得颂上第三安乐相也

次解第四安乐行。此行明以慈悲为体。就中亦有两段。即是长行与偈为二也。今且就长行中自有二段。第一明行体。第二文殊师利以下即明得果安乐相。又此两段之中各有二。初段中二者。第一略明大慈也。第二从于非菩萨下广明大悲。不闻即是昔日闻慧不成就。不知即是昔日思慧不成就也。不觉即是昔日修慧不成就。何以知之。下三句即释也。不闻即释上不闻句。昔日若能闻此三乘者则闻义成就。正由昔日不闻是闻义不成也。不信即释上不知句。正由昔不信言于一佛乘分别说三。是故不知同归之理也。不解即释上不觉句。若昔解同归之义者即便觉知无三之义也

文殊此下是第二正明安乐之相亦有二者。第一正明安乐之相。第二即释但初正明安乐相。中自有二。第一先明人爱。第二从诸天下明天护也。是则如来经法在此人怀抱之内是故人天常为法故则爱护人也。所以者此下是第二即释安乐相亦有二者。第一法说。第二譬说。又就此二段中各有二。法说中二者第一先明此经是诸佛所护之秘藏。故第二文殊师利以下据难闻得者明此经应可尊重也。文殊譬如强力转轮圣王以下第二譬说。释安乐相亦有二者。即是两譬即为是两段即为上两种法说作譬也。但初譬自有开合也。文殊如转轮王见诸比丘众下第二譬亦有二者。即开合为两段也。但就合譬之中自三。第一正合第二。文殊师利下即举外譬帖。第三亦从文殊下结合也

而说偈言此下是第二重颂。上长行之中本有二。第一正明行体。第二明安乐相。今此十四行半偈分为二。第一有四行正颂上明行体。第二十行半颂第二安乐相也。上行体中本有二。一者略明大慈。二者广明大悲。今此四行只得通颂不可分也

譬如强力此下十行半是第二即颂第二安乐相。上有二。一者正明安乐。其中本有二。一者人爱二者天护。今者都不颂也。第二即释明安乐之义亦有二。第一是法说。其中有二。一者诸佛密藏。二者据得法之人。今者亦不颂也。唯颂第二譬说。但上两譬各有开有合。今此十行半只宜分为二。第一有四行先牒颂两家外譬。第二如来亦尔下有六行半即牒颂两家内合。初四行之中三行颂第一外譬。如有勇徤下一行即颂第二外譬也。后六行半中初如来亦尔下三行颂第一譬内合。次既知众生得其力已即有三行即颂第二譬内合也。我灭度后但佛答中有四段。此下一行半是第三总结。劝修此四安乐行也

读是经者此下有二十一行半。是佛答中第四段则通明得果安乐之相。然此中正明得三报安乐相。就二十一行半中自有四段。第一有一行先明现报得安乐也。第二不生贫穷下有三行半则明生报得安乐。第三若于梦中以下十六行明得后报安乐。第四一行总结三释也。就第三今据梦里。后报之相中有五种。第一一行半先明听佛说法。第二明自见自身为人说法亦有一行半。第三又见诸佛此下六行半则明得佛受记说法。第四又见自身此下一行半则明行佛果之因。第五诸佛身金色百福相庄严五言偈五行明得佛果也。然就此第五得佛果中则有二意。初一行先牒举前四梦。第二后有四行正明得佛果。第一先牒举四梦者初两句至闻法来则举上第一梦也。为人说此三字即为举上第二梦也。常有是好梦此句则总举第三第四梦也。又梦作国王下四行是第二正明得佛果。若后恶世中此下一行是第四总结三报也

    从地涌出品第十四

此品名未应在此。只应在一问答后。文句少故寄在品初。从后得名故言涌出品也。凡有十四品半经是第二正说。自分为两段。前有十二品经开三显一以明因义。自此下入分别功德品中半品以来有两品半经。是正说中第二段开近显远以辨果义。明因辨果。一段之中各开为四。今此中有四者。第一从此品初竟当精进一心偈以来寿量家别序。第二从尔时世尊说此偈以下竟我从久远来教化是等众略说开近显远动执生疑。第三尔时弥勒等心生疑惑怪未曾有下尽品明大众怀疑致请。第四从寿量品初入分别功德品一品半以来广明寿命长远断疑生信。今就此四段之中前一后一各开为三。中间两段别开为二。今者第一别序中有三者。第一又减两纸许詺为开发序。第二弥勒菩萨以下有一纸余名疑问序。第三佛告弥勒以下名为述劝序。今先就开发序中有二。第一是开发所由。第二佛说是时下正明开发。所以言开发缘由者由他方分身佛侍者菩萨请求流通。佛只言。我娑婆自有菩萨能流通。不须汝等。因此发踊出所由。又就此二段之中各有二阶。就开发缘由有二者。第一先明他方菩萨请求流通第二佛答也

佛说是时娑婆世界此下是第二正明开发。就中亦有二者。第一经家序菩萨踊出之相。第二是菩萨众中有四导师下明踊出菩萨与佛往复问答。今就经家序踊出之相中自有八阶。第一叙列踊出之相。第二是诸菩萨身皆金色以下叙菩萨形相也。第三先尽在此下叙菩萨从来之处也。第四是菩萨闻释迦所说音声从下发来下经家叙踊来所由。由释迦语他方菩萨道不须汝等我娑婆自有菩萨能流通此经。既闻此语所以踊出来。第五一一菩萨下是经家叙踊出菩萨眷属。第六从地出已各诣虚空中下明踊出菩萨既出之后三业供养也。第七是诸菩萨从初踊出下经家叙踊出之时经劫数。第八尔时四众亦以佛神力故下经家叙四众遍见诸菩萨也

是菩萨众中有四导师下正开发叙中本有二。从此下是第二明踊出菩萨与佛问答有四。即成四段可解也

尔时弥勒菩萨此下是第二疑问序。就此疑问序中亦有二。第一明弥勒菩萨自问释迦。第二问他方分身佛下明菩萨自问分身佛。就弥勒问中自有二。第一经家叙弥勒欲问之意。第二正明说偈问。就此十九行半偈正问中自有三段。初一行偈未正问先逆请佛答。第二是从何所来下有十三偈正问。第三余有五行半结请也。第二十三偈正问中有二。第一两偈问踊出菩萨人身。第二十一偈问踊出菩萨师也。就两偈问人身中有二意四文。第一是从何所来一句问其从来处。第二以何因缘集一句问何所以聚在一处同时而出。第三巨身大神通下一行一句赞叹此菩萨结第二问也。第四为从何所来一句结第一问也。一一诸菩萨下十一行第二问此菩萨师为是谁。就中有二者。先有九偈牒菩萨眷属多少。从六万恒河沙至但已无眷属。第二是诸大威德下有两行正问觅踊出菩萨之师也。如是诸菩萨神通大智力此下有五行半偈是正问中第三结请也

尔时释迦佛分身诸佛以下疑问序。中有二。此下是第二问。分身佛下菩萨自问分身。此中即答问为两阶也

第三述劝序中有二。第一释迦告弥勒善哉以下正述弥勒能问。第二劝信劝信中长行偈为二。就长行中自有二。初汝等当共一心下正劝信只言不受外邪名被精进铠。自守善道名发坚固意也。第二出所信之理自有二。初有两句欲明开近显远之义。次有三句欲显三世神通益物也。如来今欲显发者此明开近。明八十年佛非是实佛。宣示诸佛智慧者明显远义。即是复倍上数也。后三句者诸佛自在神通之力此明如来过去神力益物。诸佛师子奋迅之力此明如来现在益物之力。诸佛威猛大势之力此明如来未来益物之力。此中密明此三种义端至寿量中方显此义

尔时世尊以下劝信中第二偈颂有四行便为四意。初偈劝精进。第二偈劝信。第三偈诫莫生疑。第四偈诫一心听也

尔时世尊说此偈已此偈第二略说寿命长远动执生疑。就此段中有二者。即是长行与偈为二。就长行中自有二段。上弥勒问有三阶。初一偈逆请说。第二十三行正问。第三五行半结请也。今唯答第二阶正问。就正问中本有二。第一两行偈问踊出菩萨人身。第二十一行问其师为是谁。今先答第二问。问中本有二。初问眷属多少。第二正问师。今不答第一唯答第二师为是谁。佛今答言。只我是其师也。此诸菩萨皆于是娑婆世界之下以下追答第一问。问其人身上本有二意四文。今不答下二阶。娑婆世界之下答第一问。上问言是从何所来也。阿逸多此下即答上第二问。上问言此诸菩萨以何因缘集在一处同时踊出

而说偈言此下是第二偈颂。但上长行中本有二段。今此八行半颂上二段而文成三段。一行三句颂第一我是其师。次二行三句颂第二答人身。次志念力坚固下四行通颂前两段也。就第二二行三句中有四。与弥勒相应也。依止是世界一句答第一是从何所来也。常行头陀事下一行答第二以何因缘集也。如是诸子等下一行答第三赞叹诸菩萨。在娑婆世界下半行颂答第四为从何所来句也

尔时弥勒等心生疑惑怪未曾有下是第三明大众怀疑致请。就此段中有二者。第一经家叙大众有疑。即白佛言此下是第二正请自有二即是长行与偈为二。就长行之中自有二。第一明疑第二正请。又就此两段中各开为二。明疑中有二者。第一即白佛言世尊如来为太子时下先法说明疑。第二作父少子老譬譬说明疑也。我等虽复信佛随宜所说此下是第二正请。亦有二者。第一弥勒自述已解。第二然诸新发意此下正明为未解者请

而说偈言此下十四行偈颂上正怀疑请来。上本有二。一者明疑二者正请。今就此十四行偈亦分为二。初有十一行偈颂上疑。第二我等从佛闻此下三行颂上正请。但上疑中有二。一者法说明疑。二者譬说明疑。今十一行偈中亦分为二。初有五行颂法说。后余有六行颂譬说。我等从佛闻此下三行是偈中第二即颂上长行中第二正请。但上正请中本有二。一者明弥勒自述已解。第二正为未解者请。今此三行亦分为二。初有半行偈颂第一明弥勒述已解。第二余有两行半颂上第二正为未解者请

    如来寿量品第十五

此品明如来寿命以尘沙为量故言寿量品也。自此下竟入分别功德品半品以来是第四段。广说寿命长远断疑生信。就此第四段中亦有三段者。第一即此一品正广明寿命长远。第二分别功德品初一段长行总为时众授记。第三弥勒说偈颂佛长行示同领解。又就此三段之中增一明义。第一段中有二。第二段中有三。第三段中有四。今且就第一正广说中有二者。第一明缘起第二是正广说。今就缘起中自有三阶一者汝等当信如来诚谛之语下明如来先作三过诫敕。第二尔时菩萨大众下明弥勒等四过奉受如来之命唯愿说之。第三尔时世尊下明如来又重诫敕也

一切世间此下竟品是第二正广说寿命长远。就中自有二。即是长行与偈为二段。今且就长行之中自有二。第一是法说明长远相益物。第二譬如良医以下讫长行是譬说。今且就法说之中应有四段。但文略唯有三段。今玄出第三段。故为四段。何以知此。下譬中及偈中尽有是故得知。长行中应有第三段也。四段名字者第一明释迦如来过去世中神通益物。此即是上述劝序中言诸佛自在神通之力。第二从诸善男子如来见诸众生乐于小法以下明如来现在中神通益物。此则是上诸佛师子奋迅之力。第三应明如来未来世中神通益物。此则是上诸佛威猛大势之力。此是法说中所无者今者玄出应下譬中及偈中有。第四又善男子诸佛如来法皆如是下通三世隐显。明益物不虚妄止物诽谤之心。就此四段中各有三文。今且就明过去世神通益物中有三者。第一明应身成佛寿长久但惑者谓言近。即是开近义也。第二我实成佛以来无量无边下明应家之本身寿命长远之相。即是显远义。第三自从是来下正明过去世中神通益物。就此三段中增一明义。第一有一。第二有二。第三有三也。今者言一切世间皆谓今释迦出释氏宫此下是第一明成佛实久但惑者谓近。此第一段唯一不开也

然善男子此下是第二明应家之本已自成佛以来久远之相。就此第二自有二。第一先法说明寿命长远。第二譬如五百千万亿那由他以下明为寿命长远作譬。就此譬中有三。一者先开长远之譬问弥勒。第二弥勒即答佛是长远。第三佛结合长远之譬也。自从是来我常在此此下是第三正明过去世中神通益物。就此第三段自有三重。第一明过去益物之处。第二于是中间以下明过去益物之名不同。第三若有众生来至我所以下正明益物。又就此三重各有三阶。第一明益之处中有二者。第一言自从是来我常在此娑婆世界此别的出益物之处。第二言亦于余处百千万亿下讫导利众生此下总出余处益物。第二过去益物之名不同中有二阶。一者言于是中间我说然灯佛等。又复言其入于涅槃正出过去益物之名不同。则言然灯定光只是释迦。第二言如是皆以方便分别此则释所以名字不同意。正以方便利益众生。是故有名字不同耳。从诸善男子若有众生来至我所以下第三正明益物。就中有二者。四意合为两双即作二。初明感应相关。后正明形教益物也。今初双中若有众生来至我所此明即是感应之机。我以佛眼观其信等诸根利钝者此明即是照机之智也。第二双者初随所应度处处自说名字不同下先明形益物。此明现生益物。亦复现言当入涅槃。此明现灭利益也。从又以种种方便说下明教益物。初正明说法不同。次能令众生发欢喜心者明得益也

诸善男子如来见诸众生乐于小法以下是第二段明如来现在世神通益物。就此中亦有三阶。第一减四行。先明王宫不生而现生。仍道第二如是我成佛来甚大久远以下明双树不灭而现灭。中间第三诸善男子如来所演经典以下明现生之后应灭之前神通益物。又就此三阶之中各有四重。第一明不生现生中有四者。第一明见众生有感生之机。第二明如来现生。第三明而实不生。第四释所以不生而现生意也

今者诸善男子如来见诸众生乐于小法德薄垢重。此是第一明见众生有感生之机。只由机乐小法德薄垢重。众生感佛出世。从为是人说我小出家得三菩提此第二明如来现生。从然我实成佛以来久远若斯此是第三明而实不生义。从但以方便教化众生令入佛道下此是第四。释所以不生而现生者只为教化众生故也

诸善男子如来所演经典此下是第二明释迦如来现生之后应灭之前中间神通益物。就此中亦有四者。初一行半明教益物。第二或示己身以下明形益物。第三诸所言说下一句结教益物不虚。第四所以者何下通释形教两益物。又就此四阶之中第一第二第四各自有两阶。第三不开也。第一教益有两阶者。第一言如来所演经典皆为度脱众生此总门明教益物。吐言陈教皆是利益于物。第二言或说己身此下二句据别门明教益物。或说己身者说己身为他身。或说他身者即说他身为己身。何者今言或说己身即说己为他。故知我此丈六之体是燃灯如来家之分身。故此身非是我有。或说他身者即说他身为己身。故知宝塔品所明十方分身诸佛皆是我有也。第二形益中有两阶者第一或示己身等两句明事家之身即是正报。第二或示己事等两句明身家之事即是依报也。今者第一或示己身者或示自己身为他身。故如此国土人物八部大众然皆释迦所化众生。法主应是释迦。而法座上者遂是无量寿佛此即示己身为他身。或示他身者即是示他身为己。故如西方国土人物四众皆是无量寿佛所化之众。但法座上应是无量寿佛。而法座上者遂是释迦形容。此则是示他身为己身。皆明变他为己变己为他也。或示己事此下两句是形益中第二明身家之事。或示己事者此则示己事为他事形。故如西方无量寿佛自应有西方天龙八部听法。而彼佛眷属皆是释迦眷属弟子。或示他事者释迦自应有眷属。而眷属皆是无量寿佛眷属。此则是示他事为己事也。诸所言说皆实不虚此是第三别结明教益不虚。唯此第三不开

所以者何自此下是第四通释形教两益。就此释中自有二。一者先释形益。二者不如三界见于三界下释教益。就释形益中自有三阶。一者明如来见众生有感形机。二者明所以见机之意。第三正释形益不虚也。言如来如实知见三界之相此先明如来见三界众生有感形之机相。从无有生死此下有二句是第二阶明如来所以能见机之意。以无人法过患故分为二。前有一句明人家生灭法不可得。后有一句明生灭法家人亦不可得也。无有生死若退若出者是第一如来久已断于生因。云何有生。若必有生可应有死。生既无有云何有死。此就一世为论。若退若出者死即是退生即是出。既无有死云何更生。此两句就隔世为谈也。前一无有句皆冠在四字上也。亦无在世及灭度者此一句明生灭法家人亦不可得。者者只是行人也。非实非虚非如非异此四句是第三阶。正释形益不虚。非实者既应有生灭。云何是实。非虚者为物生灭实有利益云何是虚。非如者如是实际既应有生灭云何是如。非异者生灭得益云何是异也

不如三界此下是第二释教益不虚亦有三阶。第一有二句明如来能见应有感教之机。第二出众生机相不同。第三明说教利益亦异也。第一二句者初不如三界见于三界。此则将明如来见机无异以三界不见机人形如来。次言如斯之事如来明见无有错谬此句正明如来能见机。以诸众生有种种性以下第二出众生机有性有欲有行有忆想。皆是感教机不同。从欲令生诸善根以若干因缘譬喻言辞种种说法以下。是第三正明说教利益亦异也。如是我成佛以来甚大久远就现在世明如来神通益物本有三。此下第三明不灭而现灭亦有四重。第一言如是我成佛以来竟常住不灭此明王宫生非实生。久以成佛以来云何是实生。第二从诸善男子我本行菩萨道时所成就寿命今犹未尽此下明不灭。第三言然今非实灭度而便唱言下竟以是方便教化众生正明现灭。第四所以者何若佛久住于世以下此释所以不灭而现灭之意。只为利益众生。就此释中自有四阶。一者正释所以现灭之意。由众生见如来久住于世不种善根。贪着五尘六欲不能生难遭之想恭敬之心。为此义故所以现灭。第二阶从是故如来以方便说下讫如来难可得见叹佛世难值之意。第三斯众生等闻如是语此下是明现灭得利益之相。第四从是故如来虽不实灭下总结现灭之意也。就此四中第一有二重。第二有三重。第三第四阶不开也。第一有二重者初所以者何下二行明若佛久住。明不生善生恶。第二若见如来常住不灭下明生慢不生敬也。就第二叹佛世难值中三者。初是故如来以方便说下一行正明佛世难值。第二所以者何下一行半举恶人不值佛来释难值义。第三以此事故下结难值也。下二阶不开可解也。明众生见如来久住于世不种善根。此下应有未来神通益物。文句略无今且玄推。作第三未来一段为下譬作本

又善男子诸佛如来法皆如是下法说中本有四。此下是第四明如来通三世隐显益物不虚妄。亦有三段者。第一诸佛如来法皆如是者先会诸佛道同。第二为度众生此一句明诸佛施教意。正明诸佛三世言教皆为度脱众生故。第三言皆实不虚此一句正明不虚也

譬如良医此下是第二譬说也。就中自有二。第一开譬第二合譬也。今先明开譬之中有四即为上法说四段作譬。但文句阙略而已。第一二行半为过去神通益物作譬。第二诸子于后以下二十一行为第二现在神通益物作譬。第三其父闻子以下一行为第三未来神通益物作譬。第四善男子于意云何下一行半为第四通三世益物不虚妄作譬也

就上过去神通益物中本有三。今不为前二阶作譬。唯为第三阶作譬。上第三阶中自有三重。今亦不为前二重作譬。唯为第三重作譬也。何者第一明应成佛实久而惑者谓近。今者不为此作譬也。第二即明真实成佛来久相其中自有二。一者法说二者譬说。明成佛来久自有三阶。一者作譬问弥勒。二者弥勒。答三者如来结答。亦不为作譬故前两阶不为作譬。唯为第三阶明过去世神通益物作譬。上自有三段。第一自从是来先明过去益物之处。其中自有二阶。一别二总。今者亦不为此作譬也。第二出过去时益物之名不同。其中自有二阶者。正明益物之名。二者释所以名字不同利众生故。此二阶今者亦不为作譬。故前重皆两不为作譬也。第三从若有众生来至我所下正明利益。今者有两行许正为此作譬。又上文中本有四意合作二双。今者作四段作譬。譬如良医智慧聪达者为第二照机智作譬。上云我以佛眼观其信等诸根利钝也。明练方药善治众病者超为第四教利益作譬。上云又以种种方便说微妙法令其发欢喜心。今言明练方药者。明如来妙达十二部经文。即是明练方义也。又洞识十二部经下之理即练药也。其人多诸子息若十二十乃至百数者追为第一感机作譬。上言若有众生来至我所也。以有事缘远至余国者为第三形利益作譬。上有二句先云随其所应处处自说名字不同年纪大小。此明现生利益。今不为此作譬也。二言亦复现言当入涅槃此明现灭利益。今言以有事缘远至余国者正为此作譬也

诸子于后饮他毒药此下为上第二段现在神通益物作譬。上本有三段。初先明不生而现生。次中间明神通益物。此明不灭而现灭。今为三阶作譬。第一一行半为第一作譬。第二诸子饮毒以下为第二作譬。第三余失心者以下为第三作譬也。上不生现生中本有四义。第一明见众生有感生之机。第二明如来现生。第三明而实不生。第四释不生而现生意也。今唯为前二阶作譬。今言诸子于后饮他毒药下为第一见感生机作譬。上言如来见诸众生乐于小法德薄垢重。今言诸子于后饮他毒药药发闷乱宛转于地者。明众生昔日已迳受如来正化。弃背之后遇恶知识受邪见教。各饮他毒药广起烦恼业如药发也。后轮转三途如宛转于地也。是时其父还来归家即此为上第二阶现生作譬。上言为是人说言我少出家得三菩提也。不为第三第四作譬也

诸子饮毒或失本心此下为现在中第二明现生之后应灭之前中间神通益物作譬。上本有四段一者明教益。二者明形益。三者结明教益不虚。四者释形教两益。今唯为前三段作譬。不为第四释形教两益作释。今者不次第也。初二行半为第二形益作譬。从父见子等苦恼如是已下追为第一教利益作譬。从其诸子中不失心者下为第三结教利益不虚作譬也。今先为第二形利益作譬。但上本有二阶。第一明或示己身等两句明事家之身。次或示己事等两句明身家之事。此中自有三文。第一诸子饮毒或失本心下明意业欢喜。第二拜跪问讯下明身业致敬。第三我等愚痴下明口业请也今通为上二阶作譬也。父见子等苦恼如是以下倒为第二教利益作譬。但上本有二。初言如来所演经典皆为度脱众生此总用教益。今先为此作譬竟皆悉具足也。然法相有名譬如色也。有体相即如香也。此有义理则如美味也。故如苦集灭道等名为名。三苦为苦业。烦恼为集。三心灭处名为灭。戒定慧等名道。如是等名为体。逼恼故名苦。招集故名集。本有法还无名灭。通物故名道。如是等名为义也。捣筛和合此下即为上教益中第二阶作譬。上言或说己身或说他身是苦是集等即捣也。苦应知等如蓰也。苦我已知等如和合也。其诸子中不失心者此下为上第三结教益不虚作譬。上言诸所言说皆实不虚也

余失心者此下为上现在益物中第三不灭现灭作譬。上本有四阶。第一明王宫生不生。第二明灭不灭。第三明而现灭。第四释所以不灭而现灭之意。今不为前三阶作譬。唯为第四阶作譬也。上释中本自有四。第一见佛在世时不生难遭之想恭敬之心。第二叹佛世难值。第三明现灭有利益仍生恭敬然种善根。第四总结现灭之意。今唯为前三阶作譬不为第四总结作譬也。今第一减三行为第一作譬。从父作是念以下五行余为第二叹佛世难值作譬。第三是时诸子闻父背丧以下四行为第三仍生恭敬生善作譬也。今者增一明义。第一有二。第二譬有三。第三有四也。第一譬有二者初余失心者见其父来下一行半正为见佛在世不生恭敬不生善作譬。第二所以者何下一行余释不生善意也。就第二譬中有三。第一父作是念此子可愍以下二行余正为佛世难值作譬。第二即作是言下二行为方便唱灭作譬。第三言作是教已复至他国下一行正明双林入于涅槃作譬。而诸弟子由未决定生涅槃之想者无异诸子见父至他国犹生未死之想。亦至闻使来方生死想。无异诸弟子见焚身之后分身舍利决定生于涅槃之想。遣使还者相传解言。只用如来灭后八斛四斗舍利为使也。就第三仍生恭敬生善譬中有四者。第一是时诸子闻父背丧下一句总明苦恼。第二而作是念若父在者下一行明忆父在时利益。内合可解。第三今者舍我远丧他国以下一行别明失父故忧恼。第四心遂醒悟下一行余正为生善作譬也

其父闻子悉已得差此下即是第三义为未来世中神通益物作譬。上所无玄出者也。此中亦有三段。第一先明如来见未来世中众生有感佛出世之机也。第二即明如来应生则言寻便来归是也。第三咸使见之此正明未来世中利益之相作譬也

诸善男子于汝意云何以下是第四段。即为上第四明如来三世隐显益物不虚作譬也

佛言我亦如是此下是第二合譬。此中略不合第三譬唯合余三也。今先合第一譬上开譬本有四。我亦如是一句合第一譬如良医智慧聪达也。从成佛以来无量无边以下合第四以有事缘远至余国譬。不合第二第三譬也。上第二言明练方药善治众病第三言其人多诸子息若十二十乃至百数也。为众生故以下合第二现在神通益物譬。譬本有三。今不合第一第二譬。唯合第三譬不灭而现灭也。就此第三譬中自有三。第一明见佛时不生恭敬。第二明佛世难值。第三明现灭仍生恭敬。今唯合第二佛世难值譬。就中自有三阶。第一父作是念以下明佛世难值。第二即作是言下明唱灭。第三作是教已下正明入涅槃也。今唯合第二唱入涅槃阶不合第一第三阶也。亦无有能此下即合上第四益物不虚妄譬也

而说偈言此下有二十五行半。第二偈颂亦分为二。初有二十行半颂上法说。次如医善方便下有五行颂上譬说也。但上法说之中文有二段义作四段。今二十行半亦分为四段。初有两行颂上过去世中益物。次有三行颂上现在世中益物。次有十四行半义颂上未来益物。次一行颂上通三世益物不虚妄也。但上过去中本有三。今不颂第一惑者谓近也。今初一行即颂第二正明成佛来久相。次一行颂第三正明神通益物也。但上第二长远相中有法说譬说。今此一行唯颂法说。次一行颂上第三正明神通益物。上有三。一者明化物处不颂也。二名字不同亦不颂也。唯颂第三正明利益。上本有二。一者感应相关今不颂。唯颂第二正明利益。正明利益中本亦有二。一者形益今不颂也。唯颂教益。但上教益之中本自有二。一者正明教益言又以种种方便说微妙法。今上半行颂此也。二明教称众生言能令众生发欢喜心。今下半行颂也。为度众生故此下三行颂上现在益物。上有三段今不颂第一不生而现生四阶。不颂第二正明神通益物之相四阶。今唯颂第三不灭现灭段也。但上本有四阶。第一明王宫生非实生。第二明灭非实灭。第三明而现唱灭。第四释所以不灭而现灭意。今不颂第一第二唯颂后二阶。为度众生故下两行颂第三现唱灭度。从众见我灭度下一行颂第四释。上本有四今唯颂第三众生见灭度乃至恭敬之心也。众生既信伏此下有十四行半即义颂未来也。今判有四段。初有五行半先明如来未来三过出世。第二一行出未来益人之处。第三七行释疑。第四一行举如来寿命长远结也。第一三过出世者初行两行半。一过出世余国有众生下一行半又明一过出世。从我见诸众生此下一行半复明一过出世也。神通力如是于阿僧祇劫常在灵鹫山下一行第二即出未来益人之处也。众生见劫尽大火所烧时下七行是第三释疑。疑无净土就中自有四。第一两行正明劫尽而净土不灭。第二诸天击天鼓下一行明三宝常在。第三我净土不毁下二行明罪人不见。第四诸有修功德下二行明有福人常见也。我智力如是下一行第四举如来寿命长远结也。汝等有智者此下一行颂上第四不虚也

如医善方便此下五行颂譬说。就中自分为二。初一行颂开譬次四行颂合也。但上有四譬今略不颂第三也。今一行之中初一句颂上第一譬也。为治狂子故下两句即颂上第二譬也。无能说虚妄一句即颂上第四譬不虚也。我亦为世父此下四行颂合譬。亦略不颂合第三也。初半行颂上合第一譬也。为凡夫颠倒下有两行半颂合第二也。每自作是念下一行颂合第四不虚也

    分别功德品第十六

此品中分别闻法华经所得功德多少故为品目。自明果中第四段广明寿命长远。断疑生信自有三段。第一正明长远。第二总受记。第三弥勒说偈以下明示同领解。今此下是第二受记就中自有三段。第一先明经家叙时众闻说寿量得解之相。第二正受记。第三正经家述诸天供养之相也

于时世尊此下是第二正受记就正受记中自有三种受记。第一举增道授因地记。第二举损生授果地记。第三授外凡夫发心记也。但授因地记中凡有六种记即是授六地记也。第一得无生法忍此明住前菩萨闻说法华经佛命长远之相。进得登初地。始出凡界冥会无生。以初得故受无生之名。是故十地经叹初地菩萨言生在佛家。种性无可机嫌。即结言以不动法故。二得闻持陀罗尼门者此明初地菩萨闻说寿量得登二地。陀罗尼者外国之音。此间言总持。三得乐说无碍辨才者此明二地菩萨闻说寿量得登三地。四无量旋陀罗尼此明三地菩萨闻说寿量得登四地。旋陀罗尼者是周遍总持。五能转不退法轮者此明四地菩萨闻说寿量得登五地。五明不退。六能转清净法轮者此明五地菩萨闻说寿量得登六地。六地菩萨有般若波罗蜜光明现在前。如此法门颁类不同者此为复依估。各举一种法门配六地也

复小千国土下此是第二寄损生授果地记。所言果地记者此中皆举果以明损生。此是但人解此损生不同。今且就一家所习。从七地至金刚心凡有九品作损生之义。但烦恼是生因七地以上果报无有期限难可得判。只就断烦恼品数百千万种。今就一种作义。从七地以上至金刚心断烦恼凡作九品。上上．上中．上下也中上．中中．中下也下上．下中．下下也。何者七地所断者作二品上品上中品。八地所断者作二品上下品中上品。九地所断者作二品中中品中下品。十地所断作二品下上品下中品。金刚心所断者作一品下下品。此九品烦恼皆得生故言九生也。若依十地解忍者地地之中各有三忍。今欲消此经文故七地以上各有三忍。六地菩萨闻寿量之说得登七地下忍。即断一品烦恼。所余八品为八生作因故言八生当得菩提。七地下忍菩萨闻说寿量得登七地上忍。于时即断一品烦恼即损二品生。即七生当得菩提。七地上忍菩萨闻说寿量进登八地下忍。于时即断一品烦恼已损三品生。余有六品烦恼即是六生当得菩提。八地下忍菩萨闻说寿量进登八地上忍。于时即断一品已损四品生。余有五品即是五生当得菩提。八地上忍菩萨闻说寿量进登九地下忍。于时即断一品烦恼已损五品生。余有四品即是四生当得菩提。九地下忍菩萨闻说寿量进登九地上忍。于时即断一品已损六品生。余有三品烦恼即是三生当得菩提。九地上忍菩萨闻说寿量进登十地下忍。于时即断一品已损七品生。余有二品烦恼即是二生当得菩提。十地下忍菩萨闻说寿量进登十地上忍。于时即断一品烦恼已损八品生。余有金刚心所断一品烦恼即是一生当得菩提。但文句略故从八生仍超至四生也

复有八世界此下是正授记中第三授外凡夫等记摄退堕人也

佛说是等菩萨得大法利时自此下竟长行是授记段中第三段。此明经家述于时天众设种种供养之相也

尔时弥勒即说偈言此下有十九行偈是第三弥勒说偈颂佛长行。即是领解之义。就此领解中自有四段文句。初有两行是第一先称赞时众得解寿量故欢喜。第二或住不退地有九行颂佛长行正是领解之义。第三雨曼陀罗有七行明弥勒自述于时事不颂上长行。有人言。颂上长行上是出经者述取于时供养之相。佛尔时无言无说。不容用弥勒偈颂经家语。佛名闻十方一行是第四叹佛结领解也。或住不退地此下有九行是第二正颂佛长行。正是领解之意。上佛正授记中本有三。一者授因地记。二者授果地记。三者授外凡等记。今就此九行自分为四段。第一或住不退地下有三行即颂上第一授因地记。第二复有小千界微尘数菩萨下有四行即颂上第二授果地记。第三复有八世界微尘数众生下有一行颂上第三授外凡中发心记。第四言世尊说无量下一行总结授记此不颂上也。雨曼陀罗此下有七行是第三弥勒自述于时事也。佛名闻十方此一行是第四叹佛结领解也

尔时佛告弥勒菩萨摩诃萨自此下十一品半是第三大段流通说。前言流通中有二。从此下竟妙庄严王品十品半是此第一化他流通。第二余有普贤劝发品。是自行流通。前又解言。两流通中各开有三。今且就化他流通有三者。第一从此下竟常不轻品三品半经叹能流通者勋深报重。以命觅通经之人。此即命下方菩萨。但下方诸人未被前命故。第二即是神力品中初五行一文即是下方之徒堪通经者受命。第三从神力品中佛于文殊师利大众前出广长舌下尽妙庄严王品凡有六品半经。正付属文。就此三段中第一第三各开为三。中间不开且明第一段中有三者。第一此半品就因门命觅通经人。第二随喜品举因果命觅通经人。第三法师功德及常不轻此二品单举果命觅通经人。何以得知。此品中明闻经功德。闻经功德即是因。后二品明得六根清净。即是果也。随喜功德品中明格量闻经功德。亦明得人相具足。故得知因果双明。就此三世段中各有二。且明第一段中有二者。第一就佛在世明四品人闻经功德。第二就佛灭度后明五品人闻经功德。今者就第一先明佛在世四品人者即作四段。第一品人中自有长行有偈颂。下三人皆无偈颂。又阿逸多若有闻佛寿命长远此是第二品人也。何况广闻是经此是佛在世第三品人闻经功德也。阿逸多若男子女人闻我寿命长远深心信解则为见佛常在耆阇崛山。是佛在世第四品人闻经功德也

又复如来灭后自此竟品是第二就佛灭后明五品人闻经功德。自有长行与偈为二。就长行五品人中唯初第一品人明闻经直起随喜心不生诽谤而已。此人功德最劣又不格量直有长行又无偈颂。留此第一品人将入随喜功德品中。格量国城布施乃至教化一切众生皆令得四果。由自不如此第一品人闻法华经起随喜心。此义至随喜功德中当更明也。第二何况受持读诵之者斯人则为顶戴如来此是第二品人闻经功德。此不道用头实戴如来行。只言尊重如来无异头顶戴也。第三阿逸多若我灭后闻是经典此下是第三品人闻经功德。第四况复有人能持是经兼行布施下是第四品人闻经功德。第五若人读诵受持是经下是第五品人闻经功德

第二偈颂颂长行不颂第一品人。此下十九行半偈分为四段。第一五行半偈颂上第二品人。若能持此经者此下三行颂上第三品人。若有信解心此下又有三行超颂上第五品人。况复持此经兼持戒此下有八行追颂上第四品人也

    随喜功德品第十七

此品中格量闻法华经生随喜心。所得功德多少仍为品目也。第一命通经人中本有三段。上半品以就因门命觅通经之人已竟此品。是第二双就因果门命觅通经人。下余有法师功德及常不轻二品是第三单就果门。明通经得六根清净之报。以命觅通经。本言三段中例开为二。此品中有二者。第一是弥勒问。第二是如来答。今弥勒所问者即是上分别功德品中明佛灭度后五品人中第一最下品一人。上言又如来灭后有人闻此经而不毁起随喜心。此人既未被格量。今开弥勒问端。是故将此人来此品中格量其功德。弥勒今者正问出此人。又就此两段各有二问。中二者长行与偈为二可解。佛答二者亦以长行与偈为二。但佛答长行中格量五品人功德即成五段。从初下有三十二行半。从初人明五十人展转相教最后第五十人闻法华功德无量。何况最初人功德。第二品人故来诣僧坊功德无量。第三人明于讲处劝人坐听得果报之相。第四品人又在于会外劝他人往听。第五品人能专心听法。复能为他人说法

就初品人中自有六阶。第一先比次取第五十人。第二诫令谛听。第三举五十人问弥勒。第四弥勒答。第五佛会通。第六结答。况此人功德。但止五十人为数。五十人相教不同有三种。一者转胜。二者平等。三者转不如。今就此三中有难有易。转胜者难得。平等者希有。唯有转不如者多。今从多论闻五十人中最后者不如。此人功德已无量无边不可说不可数。何况最初闻经者起随喜之心。此意正答弥勒问。从阿逸多其第五十此下是第二阶将欲取第五十人格量况出最初人。诫弥勒令谛听。从若四百万亿此下是第三阶。作财法二施所得功德问弥勒。明施主用珍宝布施四生众生一一众生与满阎浮提金银珍宝。又教化若干众生皆令得四果。此施主由自不如第五十人闻法华经一偈随喜功德。难者言。四生众生蛇蚖等云何有发白面皱之相。复云何今已乘车乘着璎珞。旧解言。假设此等众生一时变成人然后用珍宝布施。既施之后次复能教化令得四果。所以言如此然由不如闻法华经起一念随喜心。解释言。此人虽顿舍国城复令得四果。此即是世间果报不免生死。今此人既闻法华经所说五百由旬应度佛果妙极应往。此人于时起一念决定一心离此生死求彼佛果。如此功德实广。然菩萨本以自行为端化他为首。发心度五百由旬远求佛果。然化他之心令六道众生离五百险难同得圆极妙果。是故此心深广实。非施国城四果格量也。又闻此法华经植福无此。具六根清净胜妙果报非算可数。问者言昔日三乘中菩萨以自发广化之心起远求之意。若尔今昔何殊耶。解释者言。昔日菩萨止言断除正使及习气仍得究竟。今日方便更明险难远长应去应度。是则昔日自行化他两行不成。今日自行化他两行成就。不可用昔之短狭。类今日之广长也。从弥勒白佛言下是第四也。如来即会此人功德。从佛告弥勒我今分别语汝下是第五也。从阿逸多如是第五十人下是第六佛结答。况此人功德也。又阿逸多若人为是经故往诣僧坊此下是第二人功德。前一人正是格量也。此下四人皆是广出也。若复有人于讲法处坐此下是第三人也。阿逸多若复有人语余人。此下是第四人明在会外闻说法华仍劝往听也。阿逸多汝且观是此下是第五人也

而说偈言此下十八行偈是答中第二。颂上长行中五人。初有九行颂第一人。次有五行超颂第四人也。次有两行追颂第二人也。次有一行颂第三人。次有一行颂上第五人也。但上第一人中本六阶。今九行中不颂第四。今初一行半颂第一先比次取第五十人也。最后人获福此半行颂第二诫令谛听。如是大施主下有五行即颂上第三举财法二施问弥勒也。既不颂第四弥勒答佛故从最后第五十此一行即颂第五如来结会也。如是展转闻此一行即颂上第六结答也。若有劝一人此下五行仍超颂上第四人也。若故诣僧坊此下两行追颂上第二人也。若于讲法处此一行颂上第三人也。何况一心此一行即颂上第五人也

    法师功德品第十八

此品中明受持读诵解说书写五种法师功德。是故经家仍为品目也。此下两品是第三段。单据果门中命觅通经人。就中亦有两段。第一此品正明据果命觅通经之人。第二常不轻品即证此果报不虚也。今且就此品中自有二段。第一先总明闻经得六根清净果报。第二广别出六根清净之相。从善男子善女人父母所生下是眼得八百鼻得八百身得八百。三八二十四合即是二千四百功德也。次耳得千二百舌得千二百意得千二百合即是三千六百。就前合成六千功德。此六千功德皆是举因目果。众生起善不出三业十善。十善有二。一者止善二者行善。今且就止善作论。此十善修习之法皆互相显助。何者故。如持不杀戒为首次修余九善助成。乃至持正见作头余九助成。如是更互相助仍成百善。然此百善便立菩萨之意有四百。何者。自作百善一百也。教人行百善二百也。随喜人行百善三百也。又赞叹人行百善四百善也。然此四百就五种法师上作。但就受持法师亦有四百善。何者。自受持教人受持随喜人受持赞叹人受持各一百。此即是四百善。读经之时亦有四百善也。诵经之时亦有四百善也。解说亦四百书写亦四百。是则四五二十即是二千功德也。然菩萨位心欲令万行皆进。有下品二千。次修中品二千也。次修上品二千也。便成六千功德。此六千功德共得感一根如似五戒共得人身。但欲示自行化他功用显昧配于六根。三根自行化他功用不如。三根自行化他功用胜。是故三根各得八百。三根各千二百也。论云金银无香金刚无味。今云何言金银诸珍闻香悉能知。解释云。但闻藏香即知有金银也。今此持经果报不可思议。如似一切知人六根并用众尘俱知

    常不轻品第十九

此品中明如来昔日为菩萨时为四众说同归之义。记四众得佛常说不轻之言。四众仍号此菩萨为常不轻。是故仍为品目也。单举果命通经人。中有两段。此品是第二。举不轻现得果报证不虚也。今就此品中大判有二段。一者长行二者偈也。今就长行中有五段。第一举是非相形命觅通经人。第二先谈事本也。第三正明本事也。第四叹经。第五因此仍劝人受持也。今言举是非者若有谤此经之人得恶报。如上火宅偈末所述也。若能通经者得六根果报。如上法师功德品所明也。得大势乃往古昔此下是品中第二段先明事本。二万亿威音王佛尔时有一菩萨此下是第三段正明本事也。今就此中自有二。第一先明行善恶二因。第二是比丘临终以下明得善恶二果。今明行因之中善恶相间自有六阶。第一先明常不轻礼拜记人当果行善因也。第二明恶人行因从四众之中是也。第三明此菩萨行善因从如是经历多年下是也。第四又明恶人行恶因从说是语时下是也。第五又明此菩萨行善因从避走远住下是也。第六又明恶人行因从以其常作此语故下是也。是比丘临欲终时以下是第二明得善恶二果。此中自有二。第一先明善人得善果即是常不轻也。第二明恶人得恶果。就此二重中各有二。就第一明得善果中有二者。第一先明得果。第二仍会通古今也。且就明得果之中自有六阶。一者先明具闻威音王所说二十千万亿偈故即得六根报也。第二得是六根清净已下明得更增寿教化众生果报。第三命终之后下明又值日月灯明佛。第四以是因缘下明值云自在王佛。第五得大势是常不轻菩萨下明又值千万亿佛说法华。第六从功德成就当得作佛下明得作佛也。得大势于汝意云何此下是善果中第二会通也。得大势彼时四众此是第二明恶人得恶果。就中亦有二。初作三重明得恶果。第二仍会通也。三重明得恶果者。第一先明不值三宝也。第二从千劫下正明得恶果也。第三从毕是罪已下仍得妙果。是则显菩萨不为众生作烦恼因缘。正由常不轻菩萨为化外缘故也。得大势于汝意云何此下是第二会古今也。得大势当知是法华经此下是长行中第四叹经也。是故诸菩萨此下是第五仍劝人受持也

而说偈言此下有十九行半是品中第二段。重颂长行上长行中有五阶。今不颂第一举是非也。今初一行半先颂第二事本。从是佛灭后此下十四行颂上第三本事也。次有两行颂上第四叹经。次两行颂上第五奖劝也。上第三中本有二。先明行善恶二因。次明得善恶二果。今十四行中四行颂行因。十行颂得果。就上明行因中有六阶。今者唯得颂三种。初三行先颂行善因也。次言诸人闻已半行颂行恶因也。不轻菩萨下半行颂善因也。其罪毕已此下十行颂得果。亦分为二。初有五行颂善果。次有五行颂恶果。上善果中本有二。一者正明善果。二会通。今四行半颂果。半行颂会通。上正明果中本有六。今者唯得颂三。第一第二第三时四部众下明恶人得果。上长行中本有二。第一正明得果。第二会通。今者一行半颂得果。三行半颂会通。上得果中本有三。今者唯颂第四。亿亿万劫下两行颂长行中第四叹经也。是故行者下两行颂长行中第五奖劝受持也

    神力品第二十

此品明如来有八种神力仍为品目也。就化他流通中本有三段。此品中初有五行一字。是第二段堪通经者受命流通不开也。尔时世尊此下有六品半经是第三正明如来以经正付嘱也。前又解言。此三段之中前一后一各有三段。中间不开也。今此中有三者。第一此半品先明付嘱缘起也。第二嘱累一品正明付嘱也。第三有五品经明示物通经轨则也。今且明缘起之中自有两段。第一长行第二偈颂也。就长行之中自有两段。第一先明神力第二因此叹经劝行也。今且明神力之中有二。第一先列所为时众。第二正明神力凡有八种神力。而文成六段。第一先明长舌与放光合为一段也。一时下是第二段又明两种神力。即是謦咳与弹指二神力也。地动下是第三段明第五神力也。欲使六道众生尽发动通经意。其中众生下是第四段。此明第六神力。正明如来神力令大众彻见十方也。即时诸天下是第五段明第七神力也。明诸天唱告使众生供养。所散诸物下是第六段明第八神力表所修诸善感当来佛果也。尔时佛告上行等此下是长行中第二段。因此仍叹经劝行也

而说偈言此下十七行偈是第二段颂上也。亦分为二。第一四行颂上第一先明八种神力也。第二嘱累。是经故下有十三行颂上第二叹经劝行也

    嘱累品第二十一

此品第二正明如来以经付嘱时众因名品目也。此品中大分为三段。第一正明如来以经付嘱。第二明时众即受付嘱。第三明如来示付嘱事毕相也。又此三段中各有三。正付中有三者。第一正明以经付也。第二释付嘱之意。从所以者何是也。第三结付嘱。从汝等亦应下是也。时诸菩萨此下是第二受付嘱。亦有三者。第一先明内心欢喜。第二从益加恭敬下明外形致敬。第三俱发声言下正明受付嘱也。尔时释迦此下是第三段示付嘱事毕之相。亦有三者。第一先唱分身诸佛各随所安也。第二还闭多宝佛塔从多宝下是也。第三明大众欢喜从说是语时下是也

    药王本事品第二十二

此品明药王昔日苦行通经仍为品目名也。此下有五品。是第三段示物通经之轨则。但上明因之中已明轨则。此中复明轨者。但前入如来室等明法等。明法为通经之轨。此中正以药王等以人为轨也。此五品示物通经之轨。今判为三段。第一有药王妙音观音三品正示物通经之轨。第二陀罗尼品即奖劝时众有退没者以说神咒护此通经人。是故不可不弘经也。第三妙庄严王本事品即显通经有利益转父邪见以归正解也。今且就第一段中自有两段。第一此药王品先明苦行通经为物作轨也。第二妙音观音两品明普现色身弘经益物。若明药王苦行者下二人亦然。若明后二人普现色身弘经益物药王亦应尔。是故彼此互举影向相显。但此药王是旧邦菩萨。妙音观音等是他土大士。但妙音是东方菩萨。观音是西土大士。虽复东西两殊同集一处。为欲表同归之理证莫二之说也

今且就此品中大判为四段。第一是宿王华作问也。第二如来答也。第三经家序说此品中得利益。第四明多宝赞叹时众中宿王华能问也。中有三。第一正问药王难行苦行事。第二善哉世尊愿少解说一句请说。第三诸天龙神下出所为徒众也

尔时佛告此下是品中第二段如来答也。今就此答中自有六段。第一先明事本。第二尔时彼佛下明过去佛为此菩萨说法华经。第三一切众生喜见下正明本事苦行流通此经。第四佛告宿王华下即会古今。第五宿王华若有发心下劝通经。第六宿王华譬如下广叹经正明流通也。从尔时佛告宿王华下十一行余是第一明事本。尔时彼佛此下是佛答中第二。明昔日佛为此菩萨说法华经也。是一切众生此下是佛答中第三段正明本事也。今就此中自有四段。第一是一切众生喜见菩萨下明闻经修行。第二从满万二千岁已得现一切色身三昧以下明得现果。第三即作是念以下明知恩念报恩。第四即时入是三昧以下正明报恩供养也。就此第四自有二。第一先明现身供养。第二后身供养。且就现身供养中自分为二。第一即时入是三昧下先明财物供养。第二从三昧起而自念言下正明烧身供养。今且就明烧身供养中自有五阶。第一先明念欲烧身也。第二即服诸香下明服香。第三从满千二百岁下正明烧身。第四其中诸佛以下诸佛叹。第五其身火燃以下明所经时节。从一切众生喜见此下是第二明后身供养。就中自有二。第一先明供养缘起。第二从尔时一切众生喜见下正苦行通经。今且就缘起之中自有九阶。第一先明现生王家也。第二即为父王下为王说本因缘。第三大王我今当还供养此佛下明已语王道欲供养净明德佛。第四白已下明升空而往。第五往至佛所下明至佛所致敬。第六尔时一切下明白佛道。佛那得犹在。今不用此解。只是自庆言我犹故及世尊在世也。第七明日月净明德佛答言涅槃时至也。第八明从又敕下即明净明德佛以法付此菩萨也。第九如是日月净明下明净明德佛下入涅槃也。明缘起竟。尔时一切此下是第二正明后身苦行通经。今就此中自有四段。第一先明见佛灭度生恋慕之心。第二即以海此岸栴檀明焚身供养。第三火灭之后明供养舍利。第四尔时一切下明仍舍臂供养。就此第四段中自有七重。第一从此下告大众欲烧臂。第二作是语已下正明烧臂。第三令无数求声闻众下明时众得益。第四尔时诸菩萨下时众忧恼。第五于时一切众生喜见下明发誓。第六作是誓已下明臂复本。第七当尔之时明感动之相也。佛告宿王华于意云何下佛答有六段。此是第四段会通古今也。宿王若有发心此下是第五仍劝人苦行通经也。宿王华譬如一切川流江河下是第六广叹经正明流通。就中自有两段。第一叹经。第二是故宿王华以下正明流通也。就此两段各有二阶。叹经二者初总叹此经一部。次宿王华若有人闻下别叹。此二阶各有三重。总叹中有三者。第一譬如一切川流下十譬格量叹。第二宿王华此经能救一切下名当体叹。第三若人得闻此法华经下举功用叹也。宿王华若有人闻是药王以下是第二别叹。就中亦有三者。第一从此以下举现在世为叹。第二若如来灭后下举未来世为叹。第三宿王华此菩萨成就如是下总结叹也。第二正明流通中有二者。第一是故宿王华下以此一品付嘱流通。第二宿王汝当以神通下以此一部付嘱正明流通。就中有正有释也

说是药王品时此下是品之第三段。即是经家叙说品得利益也

多宝如来此下是第四段明多宝如来仍赞叹宿王华能问也

    妙音品第二十三

此品中述此菩萨普现色身神力之事仍以此菩萨为品名也。此下两品是示物通经轨则中第二明此二大士普现色身弘经益物。此意已如前述也。今就此品中大分为六段。第一先明如来放光召妙音令来。第二即白净华智佛下明彼菩萨被命发东方来此土。第三尔时华德菩萨白佛下正明妙音普现色身通经之轨。第四说是妙音品时下明东西二处人天有利益。第五尔时妙音菩萨供养释迦下明此菩萨见普现色身既竟仍辞此间佛还东方。第六说是妙音菩萨来往品时下明经家述时众说品有利益也

今第一如来放光召中自有三阶。第一先明此光傍照余国也。第二过是数已下明此光的照此菩萨国也。第三尔时一切净光庄严国下明如来光的照此妙音身也

即白净华下是品中第二段明此妙音受命而来。此中自有五段。第一先明妙音辞佛而来。第二明彼佛仍诫敕此妙音。第三妙音奉受诫敕之旨。第四明此妙音示从彼来相。第五正明妙音发彼而来也。今先有四行许是第一明妙音辞彼佛而来也。尔时净华智佛此下是第二明彼佛诫敕之也。妙音白佛言此下是第三奉如来诫敕之旨也。于是妙音此下是第四段示从彼来相。只就此第四段中自复六阶。第一明现宝莲华于此间也。第二从尔时文殊下文殊问佛此瑞相之意也。第三尔时释迦下明如来答文殊。第四文殊白佛下明文殊仍愿见此妙音。第五尔时释迦下明释迦答道多宝如来自当为汝唤。第六时多宝佛下明多宝佛即为文殊唤此妙音

从于时妙音以下是第五段正明妙音发来至此。就此第五段自有九阶。第一先明妙音与眷属而来。第二所迳诸国以下妙音于路现神力之相。第三菩萨目如广大青莲华叶下明经家叙此人形。第四入七宝台下明妙音乘宝座而来至。第五到已以下明既至此间设供养。第六而白佛言下明妙音传彼佛相问讯。第七世尊我今欲见下明妙音白佛道愿欲见多宝佛。第八尔时释迦下明释迦即为白多宝佛。第九尔时多宝佛下明多宝佛于宝塔中遥命妙音也

尔时华德菩萨白佛此下是品中第三段正明妙音普现色身弘经。此中自有两番问答为二段也。今明初番问答中问唯一也。佛答中自有四阶。第一正答妙音往昔行妙因今日得果。第二华德于汝意云何下仍会通古今。第三华德汝但见妙音菩萨下广明此妙音普现色身弘经。第四华德妙音成就下结答也。尔时华德菩萨白佛此下是第二番问答。明三昧名也

说是妙音菩萨品时此下是品中第四段明东西二国得益即得此三昧也

尔时妙音菩萨供养释迦此下是品中第五段明妙音既说普现色身竟仍辞还国。此中自有三阶。第一先明辞如来也。第二从所迳诸国下明妙音去时于路现神力也。第三既到本国下明至彼恭敬彼佛也

从说是妙音菩萨来往品时下品去第六段明经家叙时众得利益也

    观世音品第二十四

观世音者可有四名。一名观世音正言观世间音声而度脱之也。二名观世音身即是观众生身业而度脱之。三言观世意即是观众生意业而度脱之也。四者名观世业此则通前三种。问曰。若尔何故只詺为观世音耶。解释者言。但行口业则易身意两业行善则难也。且娑婆世界多以音声为佛事。是故从观世音受名也。今就此品中亦有六段。第一先称叹此菩萨也。第二从云何游于娑婆世界此下则正明普现通经也。第三是故汝等应当一心供养以下仍劝人供养此菩萨也。第四无尽意是观世音菩萨有如是自在神力以下结叹此菩萨也。第五尔时持地菩萨即从座起下明持地菩萨寄也。第寄此品末仍叹观世音之德也。第六临品末佛说普门品时以下明说此品时得利益也

今且明第一叹中有二。即问答为二也。今明佛答中自有两段。第一先依名叹。第二从无尽意若有人受持六十二亿下名为格量叹也。依名叹中有四。第一先叹观世音。第二若有众生多于淫欲下叹观世意。第三若有女人设欲求男下叹观世身。第四是故众生皆应受持下结劝受持也。就第一观世音中自有三。第一若有无量百千万亿众生受诸苦恼下总明观世苦声。第二若有受持观世音菩萨名者下别明观世音救七种难。第三无尽意观世音菩萨威神之力下总结叹也。第二救七种难者第一若有持是观世音菩萨名者下一行半救火难。第二若为大水所漂下咸一行救水难。第三若有百千万亿众生下五行半明救风难。此中虽通罗刹未明罗刹也。风本无色正明此风吹起黑色故言黑也。第四若复有人临当被害下咸两行救刀杖难。第五若三千大千下两行半救罗刹难。第六说复有人若有罪下两行救枷锁难。第七若三千大千国土下六行余救盗贼难也。无尽意是观世音菩萨竟巍巍如是是第三总结叹观世音也

若有众生多于淫欲此下是第二叹观世意。就中自有二。第一正叹也。第二从无尽意下竟是故众生常应心念结劝也。若有女人此下是第三叹观世身。就中亦有二。第一正身业礼拜求男得男求女得女。亦第二从无尽意下竟福不唐捐结劝也。是故众生此下是第一依名叹中第四总结叹也。无尽意若有人受持六十二亿此下是第二格量叹。此中亦有四阶。第一佛先作格量功德问无尽意也。第二答佛甚多世尊也。第三佛言若复有人下明如来结会。第四无尽意受持观世音菩萨下总结叹也

无尽意白佛言此下是品中第二段正明普现色身弘经。自有二。第一问第二佛答也。今且明问中自有二意三文。一问言云何游于娑婆此问形也。第二问言云何而为众生说法此问教也。方便之力其事云何此是第三总结前问。形教两法都是方便之力也。佛答中有二。第一正答第二结答也。就正答中凡有十九应以。一一中皆答上两问。现形即答前问形而为说法即答后问教。今初句若众生应以佛身得度者明众生根性。后句例皆如是。经文略无众生也。无尽意是观世音下是第二结答也

是故汝等应当一心供养此下是品中第三段劝人供养观世音自有七阶。第一明如来正劝供养。第二明无尽意即受佛教舍璎珞供养也。第三时观世音菩萨下明观音不受。第四明无尽意请受也。第五尔时佛告下明如来自命观世音令受。第六时观世音下明观世即受。第七分作二分下明此菩萨既受之后仍行回施也

无尽意以下是品之第四总结叹观世音也

尔时持地菩萨此下是品中第五段明持地总叹此观世音之德也

佛说是普门品时此下是品中第六段明经家叙说品得利益也

    陀罗尼品第二十五

此品中明陀罗尼神咒仍为品目也。明示物轨则中本有三。前三品正明以人为通经轨则也。今此一品是第二意则明如来说大神咒奖劝弘经拥护通法大士。今就此品中大判为三段。第一有一番问答先格量通经人功德。第二尔时药王下又有一番问答正明五人说神咒拥护弘经人也。第三说是陀罗尼品下一行明时众得利益也。五人者第一药王第二勇施第三毗沙门天王第四持国天王第五罗刹女

    妙庄严王本事品第二十六

若依药王菩萨本事品者应言净藏净眼品。但此正是往古国王邪见炽盛不信三宝。然净眼二子是大菩萨而应生此家。转王邪见之心得正见之解。从所化受品名故为品目也。今就此品中大判有六段。第一先明事本。第二仍称叹二子有深德美行。第三明云雷音王佛为说法华。第四正明二子化父本事。此是品之来意。第五段仍会通古今。第六段明经家叙说此品时众得利益也

今先明事本国劫名字如来之号也

从有二子此下是第二先称叹二子有深德美行也

尔时复彼佛此下是第三段彼佛为二子说法华经也

时净藏净眼二子此下是第四段正明二子化父之本事。就此中自有三段。第一先明化父缘起。第二于是二子下正明化父。第三时父见子神力如是下明父王朋二子白母往佛所也。第二母告子言下明其母告子导父王邪见。第三净藏二子下明二子生怨叹之念。第四从母告子言下明劝子化父也。于是以下第二正明二子作十八变化父王也。时父见子此下是第三明父王受化。就此中凡有十四阶。第一先明父王与子问答也。第二于是二子下二子与母问答也。第三于是二子下明二子劝父母往佛所也。第四彼时妙庄严王下明王眷属堪受法正化也。第五二子如是下叹二子化父王之德。第六于是妙庄严王下明王及眷属往佛所也。第七尔时彼佛为王说法下此二句明如来为王说法也。第八王大欢悦下明王闻法得利益仍供养。第九时云雷音下明佛为授记也。第十其王即时下明王出家修道也。第十一即升虚空下明王既得解之后述报子恩也。第十二尔时下明如来述此二王子实是善知识也。第十三妙庄严王即从虚空中下明王称叹佛德也。第十四说是语已礼佛而退此两句明辞佛还国也

佛告大众此下是品中第五会通古今也

佛说下是品之第六段。明经家叙说品时得利益也

    普贤劝发品第二十七

此品中明普贤从东方来劝人自发闻经之因。故为品名也。但经有三段。第三段流通中本有二。第一有十品半是化他流通。今此一品是第二自行流通。若不受持者此经于此人则不流通。若自受持者此经于此人则有流通之义也。本言两段之中各有三。今此中有三者。第一先明此菩萨从东方来。是劝发之由也。第二白佛下正明劝发闻经。第三临品末是经家叙说品得利益

今且明初段中自有四阶。第一正明普贤从东方来。第二所迳诸国土下明神通之相。第三又与下明普贤眷属之相也。第四到娑婆下明至佛所致敬也

白佛言此下是品之第二段正明劝发之义。就中宾主相简有四阶。第一普贤先问如来劝发之行。第二佛告智贤下明如来即答劝发之行。第三尔时普贤白佛下正明普贤菩萨奖劝也。第四尔时释迦赞言下明如来述成奖劝。又此四段之中各有三别。初有三者。第一先道为此经故来也。第二唯愿下明请答也。第三从若善男子下正问也。佛告此下是第二佛答明劝发之行也。此中亦有三者。第一总唱有四法之数也。第二一者下别出四法之名也。第三善男子下结答也。尔时普贤此下是第三段普贤正劝人行此四行。就中亦有三者。第一总劝也。第二别劝第三结劝也。是人若行若立下是第二别劝。就中自有四种劝。第一先明灵瑞劝。正言若能受持者我当乘白象护之也。第二从亦复与其下明神咒护。第三若有受持下明佛神力护。若能受持此经者诸佛神力护之。第四若但书写下举果报劝。若能通此经者得好果报也。世尊我今以神通力此下第三结劝明普贤自誓发弘经之志引物之情。即结也。尔时释迦此下是第四如来述其奖劝。就中亦有三者。第一先述其灵瑞及神咒两护劝也。第二当以神力下即述成上佛护劝。第三从普贤若如来下即述成举上果报劝。番取即得也

佛说是普贤劝发品时。此下是品第三段。明经家叙说此品时得利益也

法华义记卷第八毕


法华私记缘起

    No. 1716 [cf. No. 262]

    法华私记缘起

        沙门灌顶述

大法东渐僧史所载。讵有几人不曾听讲。自解佛乘者乎。纵令发悟。复能入定得陀罗尼者不。纵具定慧复帝京弘二法不。纵令盛席谢遣徒众隐居山谷不。纵避世守玄。被征为二国师不。纵帝者所尊。太极对御讲仁王般若不。纵正殿宣扬。为主上三礼不。纵令万乘屈膝。百高座百官称美赞叹弹指喧殿不。纵道俗颙颙。玄悟法华圆意不。纵得经意。能无文字以乐说辩昼夜流泻不。唯我智者具诸功德。幸哉灌顶。昔于建业始听经文。次在江陵奉蒙玄义。晚还台岭仍值鹤林。荆扬往复途将万里。前后补接才闻一遍非但未闻不闻。亦乃闻者未了卷舒。钻仰弥觉坚高。犹恨缘浅不再不三。咨询无地如犊思乳。并复惟念。斯言若坠将来可悲。涅槃明若树若石。今经称若田若里。聿遵圣典书而传之。玄文各十卷。或以经论诚言符此深妙或标诸师异解验彼非圆。后代行者。知甘露门之在兹

    序王

所言妙者。妙名不可思议也。所言法者。十界十如权实之法也。莲华者。譬权实法也。良以妙法难解假喻易彰。况意乃多略。拟前后合成六也。一为莲故。华譬为实施权文云。知第一寂灭以方便力故。虽示种种道其实为佛乘。二华敷譬开权。莲现譬显实。文云。开方便门示真实相。三华落譬废权。莲成譬立实。文云。正直舍方便但说无上道。又莲譬于本华譬于迹。从本垂迹。迹依于本。文云。我实成佛来久远若斯。但教化众生作如是说。我少出家得三菩提。二华敷譬开迹。莲现譬显本文云。一切世间皆谓今始得道。我成佛来无量无边那由他劫。三华落譬废迹。莲成譬立本。文云。诸佛如来法皆如是。为度众生皆实不虚。是以先标妙法次喻莲华。荡化城之执教。废草庵之滞情。开方便之权门。示真实之妙理。会众善之小行。归广大之一乘。上中下根皆与记莂。又发众圣之权巧显本地之幽微。故增道损生位邻大觉。一期化导事理俱圆。莲华之譬意在斯矣。经者。外国称修多罗圣教之都名。有翻无翻事如后释。记者释曰。盖序王者叙经玄意。玄意述于文心。文心莫过迹本。仰观斯旨众义冷然。妙法莲华即叙名也。示真实之妙理叙体也。归广大之一乘叙宗也。荡化城之执教叙用也。一期化圆叙教也。六譬叙迹本也。文略意周矣

    私序王

夫理绝偏圆。寄圆珠而谈理。极非远近。托宝所而论极。极会圆冥事理俱寂。而不寂者良由耽无明酒。虽系珠而不觉。迷涅槃道。路弗远而言长。圣主世尊愍斯倒惑。四华六动开方便之门。三变千踊表真实之地。咸令一切普得见闻。发秘密之奥藏称之为妙。示权实之正轨故号为法。指久远之本果喻之以莲。会不二之圆道譬之以华。声为佛事称之为经。圆诠之初目之为序。序类相从称之为品。众次之首名为第一。释曰谈记是叙名。会冥是叙体。圆珠是叙宗。俱寂是叙用。四华六动是叙教。本迹可知。此妙法莲华经者。本地甚深之奥藏也。文云。是法不可示世间相常住。三世如来之所证得也。文云。是第一寂灭于道场知已。大事因缘出现于世。始见我身令入佛慧。为未入者四十余年。以异方便助显第一义。今正直舍方便但说无上道。所言妙者。褒美不可思议之法也。又妙者十法界十如之法。此法即妙。此妙即法。无二无别故言妙也。又妙者。自行权实之法妙也。故举莲华而况之也。又妙者。即迹而本即本而迹。即非本非迹或为开废(云云)。又妙者。最胜修多罗甘露之门。故言妙也。释曰。妙无别体。体上褒美者叙妙名也。妙即法界法界即妙者叙体也。自行权实者叙宗也。本迹六喻者叙用也。甘露门者叙教也

妙法莲华经玄义卷第一上

        天台智者大师说

  释名第一　辨体第二　明宗第三　论用第四　判教第五

释此五章有通有别。通是同义别是异义。如此五章遍解众经故言同也。释名名异乃至判教教异。故言别也。例众经之初皆安五事则同义也。如是诠异。我闻人异。一时感应异。佛住处所异。若干人听众异。则别义也。又通者共义。别者各义。如此通别专在一部。通则七番共解。别则五重各说。例如利钝须广略二门也。众教通别今所不论。一经通别今当辨

△就通作七番共解。一标章。二引证。三生起。四开合。五料简。六观心。七会异。标章令易忆持起念心故。引证据佛语起信心故。生起使不杂乱起定心故。开合料简会异等起慧心故。观心即闻即行起精进心故。五心立成五根。排五障成五力。乃至入三脱门。略说七重共意如此。广解五章者。一一广起五心五根。令开示悟入佛之知见耳

○初标五章(云云)。标名为四。一立二分别三结四譬。立名者。原圣建名。盖为开深以进始咸令视听。俱得见闻寻途趣远而至于极故。以名名法施设众生。分别者。但法有粗妙若隔历三谛粗法也。圆融三谛妙法也。此妙谛本有。文云。是法住法位世间相常住。唯我知是相十方佛亦然。尚非不退菩萨入证二乘所知。况复人天群萌之类。佛虽知是不务速说。文云。我若赞佛乘众生没在苦。谤法不信故坠于三恶道。所以初教建立融不融。小根并不闻。次教建立不融。大根都不用。次教俱建立以融斥不融。令小根耻不融慕于融。次教俱建立令小根寄融向不融。令大根从不融向于融。虽种种建立施设众生。但随他意语非佛本怀故。言不务速说也。今经正直舍不融但说于融。令一座席同一道味。乃畅如来出世本怀故。建立此经名之为妙。结者。当知华严兼三藏。但方等对般若带。此经无复兼但对带。专是正直无上之道。故称为妙法也。譬莲华者。例有粗妙。云何粗狂华无果。或一华多果。或多华一果。或一华一果。或前果后华。或前华后果初喻外道空修梵行无所克获。次喻凡夫供养父母报在梵天。次喻声闻种种苦行止得涅槃。次喻缘觉一远离行亦得涅槃。次喻须陀洹却后修道。次喻菩萨先籍缘修生后真修。皆是粗华不以为喻。莲华多奇。为莲故华。华实具足可喻即实而权。又华开莲现。可喻即权而实。又华落莲成莲成亦落。可喻非权非实。如是等种种义便故。以莲华喻于妙法也。体者为四。一释字。二引同。三简非。四结正。体字训礼礼法也。各亲其亲各子其子。君臣撙节若无礼者。则非法也。出世法体亦复如是。善恶凡圣菩萨佛。一切不出法性。正指实相以为正体也。故寿量品云。不如三界见于三界。非如非异。若三界人见三界为异。二乘人见三界为如。菩萨人见三界亦如亦异。佛见三界非如非异。双照如异。今取佛所见为实相正体也。金刚藏说佛甚微智辞异意同。其辞曰。空有不二不异不尽。空非断无故言空有。有即是空空即是有。故言不二。非离空有外别有中道。故言不异。遍一切处故言不尽。此亦与龙树意同。中论云。因缘所生法即空即假即中。因缘所生法即空者。此非断无也。即假者不二也。即中者不异也。因缘所生法者。即遍一切处也。今言实相体即权而实。离断无谤也。即实而权离建立谤也。权实即非权实。离异谤也。双照权实遍一切处。离尽谤也。斯乃总二经之双美。申两论之同致。显二家之悬会。明今经之正体也。私谓实相之法。横破凡夫之四执。竖破三圣之证得。破凡夫可解。破圣者。三藏二乘指但空为极。譬颇梨珠一往似真再研便伪。身子云。我等同入法性。失于如来无量知见。空有之旨正破此证也。通教人指但空不但空共为极。譬杂色裹珠光随色变。缘所见之光亡其本体。逐玄黄之色。堕落二乘。大经云。声闻之人但见于空不见不空。菩萨之人非但见空亦见不空。所见既殊不二之旨正破此证也。别教人指不但空为极。迥出二边如云外月弃边取中。如舍空求空。不异之旨正破此证若彼有此无则正法不遍不尽之旨亦破此证也。此等皆非佛甚微智。不与金刚藏意同。非佛证得本有常住。不与方便品同。不遍一切处不与寿量品同。既不会正体摄属何法。但空是化他之实。但不但是自行化他之实。出二边中是自行之权。并他经所说非今体也。今经体者。体化他之权实即是自行之权实。如垢衣内身实是长者。体自行化他之权实。即是自行之权实。如衣内系珠即无价宝也。自行之权即自行之实。如一切世间治生产业。皆与实相不相违背。一色一香无非中道。况自行之实而非实耶。宗者为三。一示。二简。三结。宗者要也。所谓佛自行因果以为宗也。云何为要。无量众善言因则摄。无量证得言果则摄。如提纲维无目而不动。牵衣一角无缕而不来。故言宗要。然诸因果善须明识。尚不取别教因果。况余因果。余因果者。昔三因大异。而三果小同。又三因大同而三果小异。又一因迥出一果不融。因不摄善果不收德。则非佛自行之因。非佛道场证得之果。又简者。诸经明佛往昔所行因果。悉皆被拂咸是方便。非今经之宗要。取意为言因穷久远之实修。果穷久远之实证。如此之因竖高七种方便。横包十法界法。初修此实相之行名为佛因。道场所得名为佛果。但可以智知不可以言具。略举如此因果。以为宗要耳。用者为三。一示。二简。三益。用者力用也。三种权实二智皆是力用。于力用中更分别自行二智。照理理周名为力。二种化他二智鉴机。机遍名为用。秖自行二智。即是化他二智。化他二智。即是自行二智。照理即鉴机鉴机即照理。如萨婆悉达弯祖王弓。满名为力。中七铁鼓贯一铁围山洞地彻水轮名为月。诸方便教力用微弱。如凡人弓箭。何者昔缘禀化他二智照理不遍。生信不深除疑不尽。今缘禀自行二智极佛境界。起法界信增圆妙道。断根本惑损变易生非但生身及生身得忍。两种菩萨俱益法身。法身后心两种菩萨亦俱益。化功广大利润弘深。盖兹经之力用也。教相为三。一根性融不融相。二化道始终不始终相。三师弟远近不远近相。教者圣人被下之言也。相者分别同异也。云何分别。如日初出前照高山。厚殖善根感斯顿说。顿说本不为小。小虽在座如聋如哑。良由小不堪大。亦是大隔于小。此如华严约法被缘。缘得大益名顿教相。约说次第名从牛出乳味相。次照幽谷。浅行偏明当分渐解。此如三藏。三藏本不为大。大虽在座多跢婆和小所不识。此乃小隔于大。大隐于小。约法被缘名渐教相。约说次第名酪味相。次照平地。影临万水逐器方圆随波动静。示一佛土令净秽不同。示现一身巨细各异。一音说法随类各解。恐畏欢喜厌离断疑神力不共故。见有净秽闻有褒贬。嗅有薝卜不薝卜。华有着身不着身。慧有若干不若干。此如净名方等。约法被缘犹是渐教。约说次第生苏味相。复有义。大人蒙其光用婴儿丧其睛明。夜游者伏匿。作务者兴成故。文云。但为菩萨说其实事。而不为我说斯真要。虽三人俱学二乘取证具如大品。若约法被缘犹是渐教。约说次第名熟苏味相。复有义。日光普照高下悉均平。土圭测影不缩不盈。若低头若小音。若散乱若微善皆成佛道。不令有人独得灭度。皆以如来灭度而灭度之。具如今经。若约法被缘名渐圆教。若说次第醍醐味相。当知。华严之譬与涅槃义同。三子三田三马等譬。皆先菩萨次及二乘后则平等凡圣(云云)。问既以五味分别那同称渐。答约渐得明五味耳。又若小不闻大大一向是顿。若大不用小小一向是渐。若以大破小是渐顿并陈。若带小明大是渐顿相资。若会小归大是渐顿泯合故。无量义云。渐顿二法三道四果不合。今时则合即此义也。问云何相资。答小闻于大。耻小而慕大是为顿资小。佛命善吉转教大益菩萨。是为渐资顿。如前分别。但约显露明渐顿五味之相。若论不定义则不然。虽高山顿说不动寂场。而游化鹿苑。虽说四谛生灭。而不妨不生不灭。虽为菩萨说佛境界。而有二乘智断。虽五人证果不妨八万诸天获无生忍。当知。即顿而渐即渐而顿。大经云。或时说深或时说浅。应问即遮应遮即问。一时一说一念之中。备有不定不同旧义。专判一部味味中悉如此。此乃显露不定。秘密不定其义不然。如来于法得最自在。若智若机若时若处。三密四门无妨无碍。此座说顿十方说渐说不定。顿座不闻十方。十方不闻顿座。或十方说顿说不定。此座说渐各各不相知闻。于此是显于彼是密。或为一人说顿。或为多人说渐。说不定。或为一人说渐。为多人说顿。各各不相知互为显密。或一座默十方说。十方默一座说。或俱默俱说。各各不相知互为显密。虽复如此未尽如来于法自在之力。但可智知不可言辨。虽复甚多亦不出渐顿不定秘密。今法华是显露非秘密。是渐顿非渐渐。是合非不合。是醐醍非四味。是定非不定。如此分别此经。与众经相异也。又异者。余教当机益物。不说如来施化之意。此经明佛设教元始巧为众生。作顿渐不定显密种子。中间以顿渐五味。调伏长养而成熟之。又以顿渐五味而度脱之。并脱并熟并种番番不息。大势威猛三世益物。具如信解品中说。与余经异也。又众经咸云。道树师实智始满。起道树始施权智。今经明师之权实在道树前久久已满。诸经明二乘弟子不得入实智。亦不能施权智。今经明弟子入实甚久。亦先解行权。又众经尚不论道树之前师之与弟近近权实。况复远远。今经明道树之前权实长远。补处数世界。不知况其尘数。经云。昔所未曾说今皆当得闻。殷勤称赞良有以也。当知。此经异诸教也

○二引证者。如文殊答问偈云。我见灯明佛本光瑞如此。以是知今佛欲说法华经。何但二万亿大通智胜。及五佛章中三世佛说。皆名法华也。文云。今佛放光明助发实相义。又云。诸法实相义已为汝等说。又云。无量众所尊为说实相印。此亦今古同以实相为体也。文云。佛当雨法雨充足求道者。即是会三归一之法雨。令求佛道因者充足。乃至一切皆会令充足。若开近显远之法雨。令求佛道果者充足。文云。诸求三乘人若有疑悔者。佛当为除断令尽无有余。又云。诸佛法久后要当说真实。即是断三乘五乘七方便九法界等疑。皆令生信。此证经用也。又如来神力品云。以要言之。如来一切所有之法。如来一切自在神力。如来一切秘要之藏。如来一切甚深之事。皆于此经宣示。显说一切法者。权实一切法皆摄也。此证经名。一切自在神力者。内用名自在外用名神力。即证用也。一切秘要之藏者。非器莫授为秘正体为要。多所含容而无积聚名藏。此证体也。一切甚深之事者。实相名甚深。为实相修因名深因。究竟实相名深果。又法师品云。若闻此经。乃是善行菩萨之道深因也。求佛道者。咸于我前闻妙法华经一句。乃至一念随喜。我皆与授记。乃至须臾闻之。即得究竟三菩提深果。此证宗也。所以引二文者。古佛事定举要略以释疑。今佛说竟举要略以付嘱。中间正当机广说故。不引证耳。若引者。开示悟入即其文也。为大事因缘故证名。佛之知见证体。开示悟入证宗。为令众生证用。此异余经证教也。又药王品举十譬叹教。今引其六。大如海高如山。圆如月照如日。自在如梵王极如佛。海是坎德万流归故。同一碱故。法华亦尔。佛所证得万善同归同乘佛乘。江湖川流无此大德。余经亦尔。故法华最大也。山王最高四宝所成故。纯诸天居故法华亦尔。在四味教之顶离四诽谤。开示悟入纯一根一缘同一道味。纯是菩萨无声闻弟子故。月能亏盈故。月渐圆故。法华亦尔。同体权实故。会渐入顿故。灯炬星月与闇共住。譬诸经存二乘道果。与小并立。日能破闇故。法华破化城除草庵故。又日映夺星月令不现故。法华拂迹除方便故。轮王于四域自在。释王于三十三天自在。大梵于三界自在。诸经或于俗谛自在。或于真谛自在。或于中道自在。但是历别自在非大自在。今经三谛圆融最得自在。譬大梵王余经拔众生出生死如五佛子于凡夫第一。或拔众生出涅槃。如菩萨居无学上。今经拔出众生。过方便教菩萨上。即成法王最为第一引诸譬喻明教相最大。例知用宗体名。亦大如海。境智乃至利益亦大如海。教相如山在四味教上。用宗体名境智利益亦复如是。教相亏盈圆满如月。用宗体名境智利益亦复如是。教破化城。用宗体名境智利益亦复如是。教相自在余亦如是。教相王中王余亦如是。非但引文证教余义亦成

○三生起者。能生为生所生为起前后有次第粗细不相违。肇云。名无召物之功。物无应名之实。无名无物名物安在。盖第一义中无相意耳。世谛为言无名无以显法故。初释名。名名于法法即是体。寻名识体。体非宗不会。会体自行已圆。从体起用导利含识。利益既多须分别教相也。神力品中约教次第。一切法本皆佛法。大经云。一切世谛若于如来即是第一义谛。众生颠倒谓非佛法。今明言示之。故言一切法也。欲说此法先以神力骇动。故言一切自在神力。既见变通醒悟渴仰得为说教。教诠实相故言秘密之藏也。禀教修行即有因果。故言甚深之事也。欲分别四义与余经同异。次明教相耳。序品约行次第。初从经卷若善知识。有所闻见即闻名也。闻故推理体显。显体须行。行即因果宗也。行自排惑亦利众生。是用也。分别同异教相也。开示悟入亦约行次第。法本无开闭。今呼为方便门开。此闻名也示真实相体也。自迷得悟悟因也。由因故悟果宗也。悟故深入亦令他入用也。分别同异教也。今之五义依序品扶行次第也

○四开合者。五章共释一经。种种分别令易解故。凡三种开合。谓五种十种譬喻。初释名通论事理。显体专论理。宗用但论事。教相分别事理。释名通说教行。显体非教非行。宗用但行。教相但教。释名通说因果。显体非因非果。宗自因果。用教他因果。教相分别上法耳。释名通论自行化他。体非自非他。宗是自行。用是化他。教相分别自他。释名通论说默。体非说非默。宗默用说。教相分别(云云)。十种者。释名总论三轨。体宗用开对三轨。教相分别三轨。释名总论三道。体宗用开对三道。教相分别三道。乃至第十释名总论三德。体宗用开对三德。教相分别三德(云云)。譬喻者。譬如总名人身。开身则有识命暖。分别诸身贵贱贤愚种种差降。人身譬名识以譬体。命以譬宗暖以譬用。分别譬教相(云云)

○五料简者。若为莲故华。华果必俱。将不堕因中有果耶。答因中有果旧医邪法。已为初教所破。尚非粗权实义。况是妙因妙果。新医真乳法邪。问华以喻权。权是小乘之法。则不应破于草庵。草庵既破何得以华喻权。答小乘是化他之权。是故须破。今明自行之权故以华喻耳。问文。内从火宅至医子。凡七譬悉不明莲华。何以取此为题。答七譬是别。莲华是总。举总摄别故冠篇首也。问一切法皆佛法。何意简权取实为体。答若开权显实诸法皆体。若废权显实如前所用。问何故双用因果为宗。答由因致果果为因所办。若从能办以因为宗。若从所办以果为宗。二义本是相成不得单取。又迹本二文。俱说因果故。问论宗简化他因果。明用俱取自他权实。答宗论自行故须简他。用是益他是故双取。又问用是化他亦不须自行权实。答欲以自利利他故。并宗亦应然。欲自行化他因果。是故应取他也。答化他因果不能致佛菩提。是故不取。并用他权实。亦不能令他至极亦不应取。答他宜须此利是故取也。问宗用俱明智断云何分别。答自行以智德为宗断德为用若化他自行智断俱为宗。化他智断俱为用。问何故五章不四不六。答设作四六亦复生疑。堕无穷问非也。问经经各有异意。那得五义共释众经耶。答若经经别释。但得别不得同。今共论五义得同不失别

○六明观心者。从标章至料简。悉明观心。心如幻焰但有名字名之为心。适言其有不见色质。适言其无复起虑想。不可以有无思度故。故名心为妙。妙心可轨称之为法。心法非因非果能如理观。即办因果是名莲华。由一心成观亦转教余心名之为经。释名竟。心本无名亦无无名。心名不生亦复不灭。心即实相。初观为因观成为果。以观心故恶觉不起。心数尘劳若同若异。皆被化而转。是为观心标五章竟。观心引证者。释论云。一阴名色四阴名名。心但是名也。大经云。能观心性名为上定。上定者第一义定。证心是体。大经云。夫有心者。皆当得三菩提心。是宗也。遗教云。制心一处无事不办。心是用也。释论云。三界无别法唯是一心。作心能地狱心能天堂。心能凡夫心能贤圣。觉观心是语本。以心分别于心。证心是教相也。观心生起者。以心观心由能观心。有所观境以观契境故。从心得解脱故。若一心得解脱。能令一切数皆得解脱故。分别心王心数同起偏起等。即是教相故。观心开合者。心是诸法之本心即总也。别说有三种心烦恼心是三支苦果心是七支。业心是二支苦心即法身是心体。烦恼心即般若。是心宗。业心即解脱。是心用。即开心为三也。分别十二因缘心生。即有六道差降。分别心灭即有四圣高下。是为教相。兼于开合也。观心料简者。问事解已足。何烦观心。答大论云。佛为信行人以树为喻。为法行人以身为喻。今亦如是。为文字人约事解释。为坐禅人作观心解。又论作四句评。有慧无多闻是不知实相。譬如大闇中有目无所见。多闻无智慧亦不知实相。譬如大明中有灯而无照。多闻利智慧是所说应受。无闻无智慧是名人身牛。今使闻慧兼修义观双举。百论有盲跛之譬。牟子有说行之义。华严云。譬如贫穷人日夜数他宝。自无半钱分。偏闻之失也。下文云。未得谓得未证谓证。偏观之失也。何者。视听驰散如风中灯照物不了。但贵耳入口出都不治心。自是陵人增见长非。把刃自伤解牵恶道。由其不习观也。若观心人谓即心而是已则均佛。都不寻经论堕增上慢。此则抱炬自烧。行牵恶道。由不习闻也。若欲免贫穷当勤三观。欲免上慢当闻六即世间。相常住理即也。于诸过去佛。若有闻一句名字即也。深信随喜观行即也。六根清净相似即也。安住实智中分证即也。唯佛与佛究尽实相。究竟即也。修心内观则有法财。正信外闻无复上慢。眼慧明闻具足利益。何得不观解耶

妙法莲华经玄义卷第一上妙法莲华经玄义卷第一下

        天台智者大师说

七会异者。问佛有所说依四悉檀。今解五义与彼会不。答此义今当说。先对五章。次解四悉檀。世界悉檀对释名。名该一部世界亦冠于三。第一义对体最分明。为人对宗。宗论因果为人生善义同。对治对用。用破疑滞。与治病事齐。分别悉檀对教相。教相如后说。问何不次第。答悉檀是佛智慧。对利钝缘则成四种。利人闻世界解第一义。此对释名辨体即足。若钝人未悟。更须为人生善对治破恶。乃入第一义。则具用四也。五重玄义意兼利钝。四悉檀法专为钝者。对义是同次第则异。问论专释大品不涉法华。何得指彼悉檀通此五义。中论通申诸经。何意不用。答释论云。四悉檀摄八万法藏十二部经。法华何得不预耶。中论通申理宜须用。若具引论博而未巧。今取论题申于五章。中字申体。观字申宗。论字申用。缨珞云。破法方便立法方便。利益众生方便。论有研核破执立三宝四谛得四沙门果。故知论字申用。中观理不可思议申妙。观境是权实申法。观智是因果申莲华。观诠申经。论之三字合四悉檀。以对五义通申意显。若更以论申余经者。取偈初句申三藏。次句申通。次句申别。次句申圆。法华又为第四句所申也。岂止两论申此五章。五章通申诸经论也。次解四悉檀为十重

  一释名　二辨相　三释成　四对谛　五起教观　六说默　七用不用　八权实　九开显　十通经

释名者。悉檀天竺语。一云此无翻例。如修多罗多含。一云翻为宗成墨印实成就究竟等莫知孰是。地持菩提分品说。一切行无常一切行苦。一切法无我涅槃寂灭。是名四优檀那。此翻为印。亦翻为宗。印是楷定不可改易。佛菩萨具此法复以传教。此就教释印。如经世智所说有无无二。此法楷定以此传授经。过去寂默诸牟尼尊展转相传。此就行释印也经增上踊出。乃至出第一有最上。众共归仰世间所无。此释宗义。彼明文了义释优檀那诸师何得用宗印。翻四悉檀如此既谬。余翻亦叵信。南岳师例大涅槃梵汉兼称。悉是此言檀是梵语。悉之言遍。檀翻为施。佛以四法遍施众生。故言悉檀也。二辨相者。世界如车。轮辐轴辋和合故。有车无别车也。五众和合故有人。无别人也。若无人者佛是实语人。云何言我见六道众生。当知。有人人者世界故有。非第一义。第一义可是实余不应实。答各各实如如法性等。世界故无第一义故有。人等第一义故无世界故有。有于五阴十二入十八界。一切名相隔别。名为世界。外人迷此世界不达法相。或计无因缘有世界。或计邪因缘有世界。大圣随顺众生所欲乐闻。分别为说正因缘世界法。令得世间正见是名世界悉檀相。二各各为人悉檀者。大圣观人心而为说法。人心各各不同。于一事中或听或不听。如杂业故杂生世间。得杂触杂受。更有破群那经说无人得触无人得受。为二人疑后世不信罪福堕断常中。故作此说。此意傍为破执正是生信增长善根施其善法也。故名各各为人悉檀。三对治悉檀者。有法对治则有实性则无对治者。贪欲多教观不净。嗔恚多教修慈心。愚痴多教观因缘。对治恶病说此法药。遍施众生故。名对治悉檀相也。四第一义悉檀者。有二种。一不可说二可说。不可说者。即是诸佛辟支佛罗汉所得真实法。引偈云。言论尽竟心行亦讫。不生不灭法如涅槃说诸行处名世界。说不行处名第一义。二约可说者。一切实一切不实一切亦实亦不实一切非实非不实。皆名诸法之实相。佛于如是等处处经中。说第一义悉檀相。此亦是一家明四门入实之意故。中论云。为向道人说四句。如快马见鞭影即入正路。若闻四句心生取着。皆是戏论岂第一义耶。私十五番释其相令易解。随说事理闻者适悦是世界。旧善心生是为人。新恶除遣是对治。得悟圣道是第一义。双说假实是世界。论轮辐轴辋故有车。五阴和合故有人。单说假人即为人。论或说有人。或说无人。单说实法即对治。论对治则有实性。则无双非假实即第一义。论言语道断心行亦讫(云云)。因缘和合有善人恶人之异是世界。善缘和合有善人是为人。恶缘和合有恶人是对治。双非善恶是第一义。五阴实法隔历是世界。从善五阴生善五阴是为人。以善五阴破恶五阴是对治。无漏五阴是第一义。善法恶法异是世界。说今善法生后善法是为人。以今善法破今恶法是对治。非善非恶是第一义。问曰。人通善恶何得言生善是为人。答善业为人所乘令生其善。故言为人。问为人生善秖应生善。那复断恶。答为人者生善是旧是正。断恶是傍是新。治中治恶是旧是正。生善是新是傍(云云)。三世隔别是世界来世是为人。现世是对治。非三世是第一义。四善根内外凡隔别是世界。暖顶是为人。总别念处是对治。世第一法近真是第一义。见道修道异是世界。见道是为人。修道是对治。无学道是第一义。非学非无学是世界。见学是为人。修学是对治。无学是第一义。世界悉檀中有为人。为人中有对治。对治中有第一义。第一义中无三悉檀(云云)。一悉檀通有四悉檀。论云。阴入界隔别是世界。因缘和合故有人是为人。正世界破邪世界是对治。闻正世界得悟入是第一义。为人有四者。杂业因缘得杂触杂受是世界。于一事中。或听是为人。或不听是对治。无人得触无人得受是第一义。对治中有四者。佛三种法治人心病。药病异故是世界。治人是为人。对病是对治。实性则无是第一义。第一义中四者。一切实乃至四句是世界。佛支佛心中所得法。岂非理善是为人。一切语论一切见一切着皆可破。一切不能通第一义。能通是对治。言语道断法如涅槃是第一义。又通作者四悉檀不同。通是世界悉檀也。四悉遍化众生通是为人。四悉檀皆破邪通是对治。随闻一种皆能悟道。通是第一义也。别作者。约苦集谛明世界。约道谛能治明为人。约道谛所治明对治。约灭谛明第一义。问依论解相已足。何用多释。答论云。四悉檀摄八万四千法藏。私约十五法分别何咎。三释成者。四悉檀是龙树所说。四随禅经佛所说。今以经成论于义弥明。所谓随乐欲随便宜。随对治随第一义。乐欲从因得名。世界从果立称。释论云。一切善恶欲为其本。净名云。先以欲钩牵后令入佛道。佛经举修因之相。论明得果之相。举随乐欲释成世界悉檀也。随便宜者。随行人所宜之法。各各为人者。是化主鉴机照其可否。论云。于一事中或听或不听。宜听不宜不听。如金师子宜数息。浣衣子宜不净经举行者之堪宜。论明化主之鉴照以释成也。余两种经论名义同(云云)。四对谛者。直对一番四谛如前说。广对四种四谛者。四种四谛一一以四悉檀对之。复总对者。生灭四谛对世界。无生四谛对为人。无量四谛对对治。无作四谛对第一义。五起观教。幽微之理非观不明。契理之观非悉檀不起。修从假入空观时。先观正因缘法。此法内外亲疏隔别。若不殷勤乐欲。则所习不成。必须晓夜精勤欣悦无斁。此即世界悉檀起初观也。若欲观假入空。须识为人便宜。若宜修观。即用择精进喜三觉分起之。若宜修止。则用除舍定三觉分起之。念通两处是为随宜善心则发。若有沉浮之病须用对治悉檀。若心沈时念择进喜治之。若心浮时念舍除定治之。若善用为人善根则厚。若善用对治烦恼则薄。于七觉中随依一觉恍然如失。即依此觉分研修。能发真明见第一义。是为用四悉檀起从假入空观。成一切智发慧眼也。若从空入假观。巧用四悉檀。取道种智法眼亦如是。若修中道第一义观。巧用四悉檀。取一切种智佛眼亦如是。若一心三观巧用亦如是。起教者。大论云。佛常乐默然不乐说法。净名亦论杜口。此经云。不可以言宣。大经云。生生不可说。乃至不生不生不可说。又云亦可得说十因缘法为生作因。亦可得说十因缘者。从无明至有此十成于众生具四根性。能感如来说四种法若十因缘所成众生。有下品乐欲。能生界内事善拙度。破惑析法入空。具此因缘者。如来则转生灭四谛法轮。起三藏教也。若十因缘法所成众生。有中品乐欲。能生界内理善巧度。破惑体法入空。具此因缘者。如来则转无生四谛法轮。起通教也。若十因缘所成众生。有上品乐欲。能生界外事善历别破惑次第入中。具此因缘者。如来则转无量四谛法轮。起别教也。若十因缘所成众生。有上上品乐欲。能生界外理善。一破惑一切破惑圆顿入中。具此因缘者。如来则转无作四谛法轮。起圆教也。复次一一教中。各各有十二部经。亦用悉檀起之。若十因缘法所成众生。乐闻正因缘世界事。如来则为直说阴界入等假实之法。是名修多罗。或四五六七八九言偈重颂世界阴入等事是名祇夜。或直记众生未来事。乃至记鸽雀成佛等。是名和伽罗那。或孤起偈说世界阴入等事。是名伽陀。或无人问自说世界事。是名优陀那。或约世界不善事而结禁戒。是名尼陀那。或以譬喻说世界事。是名阿波陀那。或说本昔世界事。是名伊帝目多伽。或说本昔受生事。是名阇陀伽。或说世界广大事。是名毗佛略。或说世界未曾有事。是名阿浮陀达磨。或问难世界事是名优波提舍。此是世界悉檀。为悦众生故。起十二部经。或作十二种说生众生善或作十二种说破众生恶。或作十二种说令众生悟。是名四悉檀起三藏十二部经。若十因缘法所成众生乐闻空者。直为说五阴十二入十八界无不即空。或四五六七八九言偈重颂阴界入即空。或说能达阴入界即空者便与授记。或孤然说阴界入即空。或无问自说阴界入即空。或说知阴界入即空名为禁戒。或举如幻如化等。喻阴界入即空。或说本昔世间国土即空。或说本生阴界入即空。或说即空广大或说阴入界即空希有或难问阴界入即空。是为随乐欲世界悉檀。起通教十二部经。或作十二种说即空生善。或作十二种说即空破恶。或作十二种说即空令悟理。是为四悉檀起通教十二部经也。若有十因缘法所成众生。乐闻一切世界一切阴界入。及不可说世界。不可说阴界入等事者。如来即直说一切正世界及阴入等。一切翻覆世界及阴入等。一切仰世界及阴入等。一切倒住世界及阴入等。一切秽国一切净国。一切凡国一切圣国。如是等种种世界。不可说世界。种种阴入界。不可说阴入界(云云)。或作四言乃至九言偈重颂。或孤起偈。或能知国土阴入界者。即与记成佛。或能知者即具禁戒或譬喻说。或说昔国土事。或说昔受生事。或说广大事。或说希有事。或说论议事。如是等十二种说悦其乐欲。或生其善或破其恶。或令悟入。是名四悉檀起别教十二部经。若十因缘所成众生。乐闻不可说国土。不可说阴界入。皆是真如实相。即直说一切国土依正即是常寂光。一切阴入即是菩提离是无菩提。一色一香无非中道。离是无别中道。眼耳鼻舌皆是寂静门。离此无别寂静门。或作偈重颂。或作孤起偈。或作无问自说。或知者与记。或知者具戒。或作譬说。或指昔世界。或指本生。或说广大。或说希有。或作论议。是为赴乐欲世界悉檀起圆教十二部经。或作十二种说生妙善。或作十二种说顿破恶。或作十二种说顿会理。是为四悉檀起圆教十二部经。复次用别圆两种四悉檀。说十二部经者。是起华严教也。但用一番四悉檀说十二部经者。是起三藏教也。若用四番四悉檀说十二部经者。是起方等教也。若用三番四悉檀说十二部经者。是起般若教也。若但用一番四悉檀说十二部经者是起法华教也。大论云。四悉檀摄十二部经其义如是。地持云。菩萨入摩得勒伽造不颠倒论。为令正法得久住禅而作论也。菩萨住是禅观众生。于佛去世后。根缘不同作论通经。天亲用两番四悉檀。造地论通华严。舍利弗用初番四悉檀。造毗昙。五百罗汉造毗婆沙通三藏。见有得道意也。诃黎跋摩。亦用初番四悉檀。造成实论通三藏。见空得道意也。迦栴延亦用初番四悉檀。造毗勒论通三藏。见空有得道意也。龙树用四番四悉檀造中论。三番正通大乘。一番傍通三藏。弥勒用二番四悉檀。造地持通华严。无著亦用二番四悉檀。造摄大乘。龙树用三番四悉檀。造大智度通大品。天亲用一番四悉檀通法华。世人传。天亲龙树各作涅槃论。未来此土准例可知。又五通神仙种种诸论。释天善论。大梵出欲论。皆用初番悉檀方便利益意也。书云。文行诚信定礼删诗垂裕得昆。即世界也。官人以德赏延于世。即为人也。叛而伐之刑故无小。即对治也。政在清静道合天心人王无上。即是世间第一义悉檀也。六起圣说圣默者。思益云。佛告诸比丘汝等当行二事。若圣说法若圣默然。圣说如上辨。圣默然者。夫四种四谛并是三乘圣人所证之法。非下凡所知故不可说。假令说之如为盲人设烛。何益无目者乎。故不可说名圣默然。华严中数世界不可说不可说明理极不可说不可说。约无量无作两番四谛不生生不生不生法。明不可说不可说名圣默然。若三藏中。憍陈如比丘。最初获得真实之知见。寂然无声字。身子云。吾闻解脱之中无有言说者。是约生灭四谛生生之法。明不可说不可说。名圣默然。净名杜口。大集无言菩萨。不可智知不可识识。言语道断心行亦讫。不生不灭法如涅槃。此约四番四谛不可说不可说。名圣默然。若大品句句。悉不可得不可得者。不可以身得。不可以心得。不可以口得。此约三番四谛生不生不生生不生不生法。明不可得不可得故。不可说不可说名圣默然。此经明。止止不须说我法妙难思。是法不可示言辞相寂灭。不可以言宣。非思量分别之所能解。此约无作四谛不生不生法。明不可说不可说。故名圣默然。问为乐他故有圣说法。为自乐故名圣默然。默然则不益他。答正为自乐傍亦益他。若人厌文不好言语。为悦是人故圣默然。如律中。为福他故受供。圣则默然。如胁比丘对破马鸣。是故默然如佛。结跏正念身心不动。令无量人得悟道迹。是故默然皆是四悉檀。起此默然利益一切。何谓无益。问论云。四悉檀摄八万四千法藏。其相云何。答贤劫经云。从佛初发心去。乃至分舍利。凡三百五十法门。一一门各有六度。合二千一百度。用是度对破四分烦恼。合成八千四百。约一变为十合八万四千也。若作八万四千法藏名是世界悉檀摄。若作八万四千尘劳门名为人悉檀摄。八万四千三昧。八万四千陀罗尼门。亦如是。若作八万四千对治。八万四千空门对治悉檀摄。若作八万四千诸波罗蜜。八万四千度无极。第一义悉檀摄。又一说。佛地三百五十法门。一一门有十善。合三千五百善。治四分则一万四千。又治六根即八万四千也。七明得用不得用者。夫四悉檀独有如来。究竟具得微妙能用。下地已去得用不同。凡有四句。不得不用。得而不用不得而用。亦得亦用。凡夫外道苦集流转。尚不能知四悉檀名字。谁论其得。既其不得云何能用也。若三藏教二乘殷勤自行者。知苦断集修道证灭入真。亦名为得。不度众生故不能用。假令用者差机不当故净名诃满愿云。不知人根不应说法。无以秽食置于宝器。如富楼那九旬化外道。反被蚩笑。文殊暂往师徒皆伏。此是不知乐欲。不能用世界悉檀也。如身子教二弟子。善根不发更生邪疑。此不能用为人悉檀也如五百罗汉为迦絺那说四谛。都无利益。佛为说不净观。即得破恶。此不能用对治悉檀也。如身子不度福增。大医不治小医拱手。五百皆不度。佛度即得罗汉。此不能用第一义悉檀也。支佛亦然。是名得而不用也。次明三藏教菩萨者。虽知苦集修道止伏结惑。未有灭证。但得三悉檀。虽未得一而能用四。所以者何。如病导师具足船筏。身在此岸而度人彼岸。常以化人为事。自未得度先度人。是为不得而用。通教二乘体门虽巧得而不用。与三藏同也。通教菩萨初心至六地。亦得亦用。用而未巧。七地入假其用则胜也。若别教十住。但得析法体法两种四悉檀。而未能用。十行方能用。十回向进得相似四悉檀。亦能相似用。登地分真得亦分真用。圆教五品弟子未能得用。六根清净相似得用。初住分真得用也。唯佛究竟得究竟用。八明四悉檀权实者。四谛各辨四悉檀者。此通途说耳。释论云。诸经多说三悉檀。不说第一义者。此指三藏。三藏多说因缘生生事相灭色取空。少说第一义。就三藏菩萨。但约三悉檀明四。若就佛即具四。虽尔终是拙度权逗小机也。若通教四谛明四悉檀。体法即真其门则巧故。释论云。今欲说第一义悉檀故。说摩诃般若波罗蜜经。就佛菩萨皆得有四。而约方便真谛以明悉檀。犹属权也。若别教四谛明四悉檀约于中道。此意则深。而犹是历别。别相未融教道是权。此则非妙。今圆教四谛明四悉檀。其相圆融最实之说。故四悉檀是实是妙。若用此权实约五味教者。乳教则有四权四实。酪教但有四权。生苏则有十二权四实。熟苏则有八权四实。涅槃十二权四实。法华四种俱实(云云)。问三藏菩萨虽得四悉檀。望通教但成三悉檀。今通教望别教云何。答有二义。当通是得四。望别但得三。问别教望圆亦尔不。答不例圆别证道同故。并曰三藏通教俱证真谛。亦应俱得四。答三藏真谛虽同。菩萨不断惑故阙一。圆别俱断惑是故俱四。又并三藏通等虽四而三可是权。别教四而不三应非是权。答三藏通教教证俱是权故。但三无四别教教道权证道实。从证则四。从教则权。又并证道有四。教道应三。答若取地前为教道应如所问(云云)。九开权显实者。一切诸法莫不皆妙。一色一香无非中道。众生情隔于妙耳。大悲顺物不与世诤。是故明诸权实不同故。无量义云。四十余年三法四果二道不合。今开方便门示真实相。唯以一大事因缘。但说无上道。开佛知见悉使得入究竟实相。除灭化城即是决粗皆至宝所。即是入妙。若乳教四妙与今妙不殊唯决其四权入今之妙。是故文云。菩萨闻是法疑网皆已除。即此意也。决酪教四权。生苏十二权。熟苏八权。皆得入妙故。文云。千二百罗汉悉亦当作佛。又云。决了声闻法是众经之王。闻已谛思惟得近无上道。方等般若所论妙者。亦与今妙不殊。开权显实其意在此。问曰。决诸权悉檀同成妙第一义为当尔不。答决权入妙自在无碍假令妙第一义不隔于三。三不隔一。一三自在。今且作一种解释也。若决诸权世界悉檀。为妙世界悉檀者。即是对于释名妙也。亦是九法界十如是性相之名。同成佛法界性相。摄一切名也。亦是会天性定父子。更与作字名之为儿我实汝父汝实我子也。若决诸权第一义悉檀。为妙第一义悉檀者。即对经体妙也。即是开佛知见示真实相。引至宝所也。若决诸权为人悉檀。为妙为人悉檀者。即是对宗妙也。如此经云。各赐诸子等一大车也。若决诸权对治悉檀。入妙对治悉檀者。即是对用妙也文云。以此宝珠用贸所须。又云。如此良药今留在此。可用服之勿忧不差。经云。正直舍方便。但说无上道。动执生疑。佛当为除断。令尽无有余。又云。我已得漏尽闻亦除忧恼也。若是分别诸权四悉檀同异。决入此经妙悉檀中。不复见同异。昔所未曾说今皆当得闻。即是妙不同异。即对教相妙也。即如文云。虽示种种道。其实为一乘。虽分别诸同异。为显不同异说无分别法也。十通经者。问今以四悉檀通此经。此经何文明四悉檀耶。答文中处处皆有此意。不能具引。今略引迹本两文。方便品云。知众生诸行深心之所念。过去所习业欲性精进力。及诸根利钝。以种种因缘譬喻亦言辞。随应方便说。此岂非是四悉檀之语耶。欲者即是乐欲。世界悉檀也。性者是智慧性。为人悉檀也。精进力即是破恶。对治悉檀也。诸根利钝即是两人得悟不同。即是第一义悉檀也。又寿量品云。如来明见无有错谬。以诸众生有种种性种种欲种种行种种忆想分别故。欲令生诸善根。以若干因缘譬喻言辞种种说法。所作佛事未曾暂废。种种性者即是为人。种种欲者即是世界。种种行者即是对治。种种忆想分别。即是推理转邪忆想得见第一义。两处明文四义具足。而皆言为众生说法。岂非四悉檀设教之明证也

△第二别解五章。初释名为四。一判通别。二定前后。三出旧。四正解妙法莲华。名异众典别也。俱称为经通也。立此二名。凡约三意。谓教行理。从缘故教别。从说故教通。从能契故行别。从所契故行通。理从名故别。名从理故通。略说竟。夫教本应机。机宜不同故部部别异。金口梵声通是佛说。故通别二名也。约行者泥洹真法宝。众生以种种门入。如五百比丘各说身因。佛言无非正说。三十二菩萨各入不二法门。文殊称善。大论明阿那波那皆是摩诃衍。以不可得故。当知。从行则别所契则同。求那跋摩云。诸论各异端修行理无二(云云)。约理者。理则不二名字非一。智度云。般若是一法佛说种种名。大经云。解脱亦尔多诸名字。如天帝释有千种名。名异故别理一故通。今称妙法之经。即是教之通别。各赐诸子等一大车。乘是宝乘直至道场。即行之通别。或言实相。或言佛知见。大乘家业一地实事。宝所系珠平等大慧等。即是理之通别。约此三义故立两名也。问教主不同设教亦异。云何而言金口梵声名为教通。答此有两义。一当分。二跨节。当分者如三藏佛赴种种缘说种种教。缘异故教别。主一故教通。依此教行。有能契所契种种名理。理无种种。经言。即脱缨珞着弊垢衣。语言勤作勿复余去。并加汝价及涂足油。此则身口行理齐分而说。不得作余解也。通别圆等教行理。当分亦尔。斯义易解而理难融(云云)。二跨节者。何处别有四教主。各各身各各口各各说。秪隐其无量功德庄严之身。现为丈六紫金辉。不说甘恬常乐之味。说于碱酢无常辛辣。弃王者服饰执持粪器。名为方便。若开方便门示真实相。即向身是圆常之身。向法是圆法。向行向理皆即真实。如此通是一音之教。而小大差别。能契有长短所契唯一。极种种名名一究竟。唯一究竟应于众名。作如此论教行理通别者。相则难解理则易明(云云)。二定妙法前后者。若从义便应先明法却论其妙。下文云。我法妙难思。若从名便应先妙次法。如欲美彼称为好人。笃论无人何所称好。必应先人后好。今题从名便故。先妙后法。解释义便故先法后妙。虽复前后亦不相乖(云云)。三出旧解。旧解甚多。略出四家。道场观云。应物说三三非真实。终归其一谓之无上。无上故妙也。引经云。是乘微妙清净第一。于诸世间为无有上。又云。寄言谭于象外。而其体绝精粗。所以称妙。又引经。是法不可示言辞相寂灭。会稽基云。妙者表同之称也。昔三因异趣三果殊别。不得称妙。北地师云。理则非三三教为粗。非三之旨为妙。此意同而辞弱。光宅云云。妙者一乘因果法也。待昔因果各有三粗。今教因果各有三妙。昔因果粗者。因体狭因位下因用短。声闻修四谛。支佛修十二因缘。菩萨修六度。三因差别不得相收。因体是狭。昔第九无碍道中行。名菩萨伏道不断。未出三界故名因位下。第九无碍止伏四住不伏无明。故言用短。是为昔因三义故粗也。昔果粗者。体狭位下用短。有余无余众德不备。故言体狭。位在化城不出变易。故言位下。第九解脱止除四住不破无明。又八十年寿前不过恒沙。后不倍上数。是故用短。是为昔果三义故粗。今因体广位高用长者。会三为一收束万善。故言体广。不止界内无碍道中行。出于界外行菩萨道。故言位高。无碍伏惑不止四住。进伏无明故用长。今因三义妙也。今果三义妙者。体广位高用长。体备万德众善普会。故言体广。位至宝所故言位高。断五住惑神通延寿。利益众生故言用长。今果三义故妙。即是一乘因果之法妙也。今古诸释世以光宅为长。观南方释大乘多承肇什。肇什多附通意。光宅释妙宁得远乎。今先难光宅余者望风(云云)。因体广狭四难者。若谓昔因体狭为粗。指何为昔。若指三藏等可然。若指法华已前皆称为昔。此不应尔。何者。般若说一切法皆摩诃衍。靡不运载。思益明解诸法相。是菩萨遍行。华严入法界不动祇洹。净名一念知一切法是为坐道场。昔因如此无所不收。若为是狭。若言今因体广。那忽言法华明一乘是了。不明佛性是不了。那复言法华明缘因是满。不明了因是不满。那复言前过恒沙后倍上数。犹是无常因。既以无常因那得常果。因果俱无常。此无常人那见佛性。非了义故体不收行一。非满字故体不收教一。非常住故体不收人一。不见佛性故体不收理一。当知。今因狭中之狭。狭则是粗。昔体既广昔还是妙。此一难已知粗妙。薳复具作后难耳。因位高下四难者。般若是无上明咒。无等等明咒。上人应求上法因。教则不下。大论云。菩萨出三界外受法性身。行菩萨行因位则不下。净名叹菩萨德近无等等佛。自在慧十方作魔王者。皆是住不可思议解脱。则因人不下。净名云。虽成佛道转法轮。而行菩萨道。又云。诸佛秘藏无不得入。则见理不下。如是因位四一皆高。云何言粗。若言今因位高者。教那忽是第四时。位那忽住无碍道伏无明。人那忽是生死身非法性身。理那忽无常不见佛性。当知。今因皆无四一其位下而粗。昔因具四一高而妙。因用长短四难者。释论云。处处说破无明三昧。是教用长。是事不知名为无明。佛一切种智知一切法明无明无二。若知无明不可得亦无无明。是为入不二法门。是则行长。又一日行般若。如日照世胜萤火虫。若人入薝卜林不嗅余香。谁复乐二乘功德。座不须礼华不着身。皆是阿惟越类。则人用长。色无边故般若亦无边。受想行识无边故般若亦无边。是则理长。当知。昔教行人理俱长。长故是妙。若谓今因用长。那复言法华是覆相教。教则短。行覆相行则短。覆相不明佛性理则短。四一既阙。今短而粗。昔用既长长则是妙。果体广狭四难者。若昔果体是有余无余。不备众德为狭为粗者。此岂然乎。般若是佛母。十方佛皆护。净名云。未曾闻此实相深经。当知。昔果体备众德也。若谓今果体广应备满了。何故复言亦满不满亦了不了。何故复言佛果无常亦无我乐净等众德缺然。广义安在。若体广者。法身应遍一切处。何故复言寿止八十或七百阿僧祇。灰断入灭去此不至彼耶。若言体广。应备五眼见佛性。当知。今果阙于四一。狭而是粗。将今望昔昔还是妙。果位高下四难者。今果位若高。设教何得在第五教下行那不出无常。人那不出变易。理那不穷秘藏。当知。今果之位阙四一。皆下皆粗。昔果位具四一。皆高皆妙。果用长短四难者。若今果用长。教何不明常住。行何不顿破无明。人何不即是毗卢遮那。理何不即是秘藏。当知。今果无有妙法岂非粗耶(云云)。而复言神通延寿是何神通。若作意神通同彼外道。若无漏神通同彼小乘。若实相神通则非延非不延。能延能不延。能延何止延寿。而不延眼令见佛性。何不延舌说于常住。眼不见性则知非实相神通。非粗何谓。前一难已知粗。后难重来耳。彼作因果六种以判粗妙。又以四一专判妙。今难其粗。皆备四一则昔粗非粗。难其妙全无四一。则今妙非妙。于其一句设四句难。四六二十四耳。用彼矛盾自相击。故不盈不缩应尔许耳

妙法莲华经玄义卷第一下妙法莲华经玄义卷第二上

        天台智者大师说

四正论今意为二。先略用彼名显于妙义。因具三义者。一法界具九法界名体广。九法界即佛法界名位高。十法界即空即假即中名用长。即一而论三即三而论一。非各异亦非横亦非一。故称妙也。果体具三义者。体遍一切处名体广。久已成佛久远。久远名位高。从本垂迹过现未来三世益物名用长。是为因果六义。异于余经是故称妙。又乳经。一种因果广高长。一种因果狭下短。则一粗一妙(云云)。酪经唯一种因果狭下短。但粗无妙。生苏经三种因果狭下短。一种因果广高长。则三粗一妙。熟苏经二种因果狭下短。一种因果广高长。则二粗一妙。醍醐经一种因果广高长。但妙无粗。又醍醐经妙因妙果。与诸经妙因妙果不异。故称为妙也。复次观心释。若观己心不具众生心佛心者。是体狭。具者是体广若己心不等佛心是位下。若等佛心是位高。若己心众生心佛心。不即空即假即中者。是用短。即空即假即中者。是用长。复次于一法界通达十法界。六即位者。亦是体广。亦是位高。亦是用长。初约十法界是显理一。次约五味是约教一。次约观心是约行一。次约六即是约人一。略示妙义竟。广说者。先法次妙。南岳师举三种。谓众生法佛法心法。如经为令众生开示悟入佛之知见。若众生无佛知见。何所论开。当知佛之知见蕴在众生也。又经但以父母所生眼即肉眼。彻见内外弥楼山即天眼。洞见诸色而无染着即慧眼。见色无错谬即法眼。虽未得无漏。而其眼根清净。若此一眼具诸眼用即佛眼。此是今经明众生法妙之文也。大经云。学大乘者。虽有肉眼名为佛眼。耳鼻五根例亦如是。殃掘云。所谓彼眼根。于诸如来常具足无减。修了了分明见。乃至意根亦如是。大品云。六自在王性清净故。又云。一切法趣眼。是趣不过眼尚不可得。何况有趣有非趣。乃至一切法趣意亦如是。此即诸经明众生法妙也。佛法妙者。如经止止不须说我法妙难思。佛法不出权实。是法甚深妙难见难可了。一切众生类无能知佛者。即实智妙也。及佛诸余法亦无能测者。即佛权智妙也。如是二法唯佛与佛。乃能究尽诸法实相。是名佛法妙。心法妙者。如安乐行中。修摄其心观一切法。不动不退。又一念随喜等。普贤观云。我心自空罪福无主。观心无心法不住法。又心纯是法。净名云。观身实相观佛亦然。诸佛解脱当于众生心行中求。华严云。心佛及众生是三无差别。破心微尘出大千经卷。是名心法妙也

△今依三法更广分别。若广众生法。一往通论诸因果及一切法。若广佛法。此则据果。若广心法此则据因。众生法为二。先列法数次解法相。数者经论或明一法摄一切法。谓心是三界无别法。唯是一心作。或明二法摄一切法。所谓名色。一切世间中但有名与色。或明三法摄一切法。谓命识暖。如是等增数。乃至百千。今经用十法摄一切法。所谓。诸法如是相如是性如是体如是力如是作。如是因如是缘如是果如是报。如是本末究竟等。南岳师读此文。皆云如故呼为十如也。天台师云。依义读文凡有三转。一云。是相如是性如。乃至是报如。二云。如是相如是性。乃至如是报。三云。相如是性如是。乃至报如是。若皆称如者。如名不异即空义也。若作如是相如是性者。点空相性名字施设逦迤不同。即假义也。若作相如是者。如于中道实相之是。即中义也。分别令易解故。明空假中。得意为言空即假中。约如明空一空一切空。点如明相一假一切假。就是论中一中一切中。非一二三而一二三。不纵不横名为实相。唯佛与佛究竟此法。是十法摄一切法。若依义便作三意分别。若依读便当依偈文云如是大果报种种性相义(云云)。次判权实者。光宅以前五如是为权属凡夫。次四如是为实属圣人。后一如是总结权实。引偈证云。如是大果报。大故知是实。种种性相故知是权。今恐不尔。大义有三。大多胜。若取大为实者。亦应取多取胜。种种之名岂非多义。若言权属凡夫。凡夫何意无实。若实属圣人。圣人何意无权。如此抑没义不可依。又北地师以前五为权。后五为实。此皆人情耳。今明权实者。以十如是约十法界。谓六道四圣也。皆称法界者。其意有三。十数皆依法界。法界外更无复法。能所合称故言十法界也。二此十种法。分齐不同。因果隔别凡圣有异故加之以界也。三此十皆即法界摄一切法。一切法趣地狱。是趣不过当体即理。更无所依故名法界。乃至佛法界亦复如是。若十数依法界者。能依从所依即入空界也。十界界隔者。即假界也。十数皆法界者。即中界也。欲令易解如此分别。得意为言空即假中。无一二三如前(云云)。此一法界具十如是。十法界具百如是。又一法界具九法界。则有百法界千如是。束为五差。一恶二善三二乘四菩萨五佛。判为二法。前四是权法后一是实法。细论各具权实。且依两义。然此权实不可思议。乃是三世诸佛二智之境。以此为境何法不收。此境发智何智不发。故文云诸法。诸法者是所照境广也。唯佛与佛乃能究尽者。明能照智深穷边尽底也。其智慧门难解难入者。叹境妙也。我所得智慧微妙最第一者。叹智与境相称也。方便品长行略说此法。后开示悟入广说此法。火宅譬喻此法。信解领解此法。长者付子此法。药草述成此法。化城引入此法。如是等种种秖名十如权实法耳。如来洞达究十法底。尽十法边。明识众生种非种。芽未芽熟不熟。可度脱不可度脱。如实知之无有错谬。殃掘摩罗虽是恶人。实相性熟即时得度。四禅比丘虽是善人。恶性相熟即不堪度。当知。众生之法不可思议。虽实而权。虽权而实。实权相即不相妨碍。不可以牛羊眼观视众生。不可以凡夫心评量众生。智如如来乃能评量。何以故。众生法妙故。次解十如是法。初通解后别解。通解者。相以据外。览而可别名为相。性以据内。自分不改名为性。主质名为体。功能为力。构造为作。习因为因。助因为缘。习果为果。报果为报。初相为本。后报为末。所归趣处为究竟等(云云)。若作如义。初后皆空为等。若作性相义。初后相在为等。若作中义。初后皆实相为等。今不依此等三法具足为究竟等。夫究竟者。中乃究竟即是实相为等也。次别解者。取气类相似合为四番。初四趣次人天。次二乘次菩萨佛也。初明四趣十法。如是相者。即是恶相表堕不如意处。譬人未祸否色已彰。相师览别能记凶衰。恶相若起远表泥黎。凡夫不知二乘仿佛知。菩萨知不深佛知尽边。如善相师洞见始终。故言如是相也。如是性者黑。自分性也。纯习黑恶难可改变。如木有火遇缘即发。大经云。有漏之法以有生性故生能生之。此恶有四趣生性。故缘能发之。若泥木像虽有外相。内无生性生不能生。恶性不尔。故言如是性。如是体者。揽彼摧折粗恶色心。以为体质也。复次此世先已摧心。来世摧色。又此世华报亦摧色心。来世果报亦摧色心。故以被摧色心为体也。如是力者。恶功用也。譬如片物。虽未被用。指拟所任言其有用。大经云。作舍取木不取缕线。作布取缕不取泥木。地狱有登刀上剑之用。饿鬼吞铜啖铁之用。畜生强者伏弱。鱼鳞相咀。牵车挽重。皆是恶力用也。如是作者。构造经营运动三业。建创诸恶名之为作。大经第八云。譬如世间为恶行者。名为半人。既行恶行名地狱作也。如是因者。恶习因也。自种相生习续不断。以习发故为恶易成。故名如是因。如是缘者。缘助也。所谓诸恶我我所所有具度。皆能助成习业。如水能润种故用报因为缘也。如是果者。习果也。如多欲人受地狱身。见苦具谓为欲境。便起染爱。谓此为习果也。如是报者。报果也。如多欲人在地狱中。趣欲境时即受铜柱铁床之苦。故名如是报也。本末究竟等者。即有三义。本空末亦空故言等。又恶果报在本相性中。此末与本等本相性在恶果报中。此本与末等。若先无后事相师不应预记。若后无先事相师不应追记。当知。初后相在此假事论等。中实理心与佛果不异。一色一香无非中道。此约理论等。以是义故。故言本末究竟等。三义具足故言等也。次辨人天界十法者。但就善乐为语。异于四趣相。表清升性是白法。体是安乐色心。力是堪任善器。作是造止行二善。因是白业。缘是善我我所所有具度。果是任运酬善心生报是自然受乐。等者如前说(云云)。次辨二乘法界十法者。约真无漏相表涅槃。性是非白非黑法。体是五分法身。力能动能出堪任道器。作是精进勤策。因是无漏正智。缘是行行助道。果是四果。二乘既不生是故无报。何故发真是果而不论报。无漏法起酬于习因。得是习果无漏损生。非牵生法故无后报。三果有报者残思未断。或七生或一往来。或色界生非无漏报也。是故唯九不十。若依大乘。此无漏犹名有漏。大经云。福德庄严者有为有漏。是声闻僧既非无漏。不损别惑犹受变易之生。则无漏为因无明为缘。生变易土即有报也。次明菩萨佛界十法者。此更细开有三种菩萨(云云)。若六度菩萨。约福德论相性体力。善业为因烦恼为缘。三十四心断结为果。佛则无报菩萨即具十也。若通教菩萨。约无漏论相性六地之前残思受报。六地思尽不受后身。誓扶习生非实业报故。唯九无十。若别教菩萨。约修中道行次第观而论十法。此人虽断通惑自知有生。则具十法(云云)。夫生变易则三种不同。一全未断别惑生变易者。即是三藏二乘。及通教三乘是也。类如分段博地凡夫不伏见思者(云云)。二伏别惑生变易者。即是别教三十心人。习于中道伏而未断。类如分段小乘方便道也(云云)。三者断别惑生变易者。如初地初住断惑是也。类如初果虽断见谛犹有七生。彼亦如是。若未断伏生者。用方便行真无漏为因无明为缘。若伏断者。顺道法爱为因。无明为缘生变易土(云云)。佛界十法者。皆约中道分别也。净名云。一切众生皆菩提相。不可复得。此即缘因为佛相。性以据内者。智愿犹在不失。智即了因为佛性。自性清净心即是正因为佛体。此即三轨也(云云)。力者。初发菩提心。超二乘上名为力。作者四弘誓愿要期也。因即智慧庄严也。缘即福德庄严也。果即一念相应大觉。朗然无上菩提为习果也。报即大般涅槃果。果断德禅定三昧一切具足。是报果也。本末等者。即相性三谛与究竟三谛不异。故言等也。空谛等者。元初众生如。乃至佛如皆等也。俗谛等者。众生未发心。佛记当作佛。佛既已成佛。说佛本生事。即是初后相在假等也。中等者。凡圣皆实相也。就佛界亦九亦十。通途为语从地地皆有万行。福德为因无明为缘。习果报果分得十法。无不具足。此经云。得无量无漏清净之果报。法王法中久修梵行。始于今日得其果报。又云。久修业所得。大经云。我今所献食愿得无上报。仁王云。三贤十圣住果报。摄大乘云。因缘生死有后生死。皆是分论果报。果报即是生灭何者。无明分尽是故论灭。真明转盛是故言生。又残无明在是故言生。一分惑除是故言灭。大论云。一人能耘一人能种万行资成如种。智慧破惑如耘。增道损生意在于此。四十一地皆有十法也。若就妙觉亦九亦十。何者中道智慧乃是损生。生既未尽。故有诸地生灭不同。妙觉损生义足。最后那得论报。故云。唯佛一人居净土三十生尽等大觉。无后有生死烦恼尽故。智德已圆无复习果。不受后身故无报果。又约现生后论九论十(云云)。若按涅槃经文。愿得无上报者。即明佛界报无上也。佛报既言无上。佛相性等九法悉皆无上。何者六道相性全表五住。二乘相性表破四住全表无明。菩萨相性表次第破五住。佛相性表一切种智净若虚空。不为五住所染故。佛十法最为无上(云云)。复次六趣相表生死苦。二乘相表涅槃乐。佛界相表非生死非涅槃。中道常乐我净故。言佛界最是无上。复次四道表恶。人天表善。二乘表无漏善。菩萨佛表非漏非无漏善。故佛界最为无上。复次六道表诸有因缘生法。二乘表即空。菩萨表即假。佛表即空即假即中。故佛界最为无上。复次四趣但表恶不能表善。人天相但表善。亦不能表恶。二乘但表无漏不兼善恶。佛相兼表一切相。若解佛相即遍解一切相。是故佛界最为无上。故贤圣集云。地狱中阴但见地狱。不能知上趣。若天中阴能知天及下。其相表之不名正遍知佛相表正遍知也。佛智既遍知诸相。而经教应遍说之。若用此法历五味教者。乳教说菩萨界佛界两性相。或入即假等。或入即中等。入中乃是无上。而带一方便未全无上。酪教但明二乘相性。得入析空等。尚不明入即空等。况复余耶。故非无上。生苏明四种相性或入析空等。或入即空等。或入即假等。或入即中等。唯佛相性得入即空即假即中。而带三方便故非无上。熟苏明三种相性。或入即空。或入即假。或入即中。唯佛性相得入即空即假即中。而带二方便故非无上。此法华经明九种性相。皆入即空即假即中。汝实我子我实汝父。一色一味纯是佛法更无余法故。知佛界最为无上。复次余经所明九性相。不得入佛性相即空即假即中者。此经皆开方便普令得入。又按其相性。即是即空即假即中不论引入。是故如来殷勤称叹此法华经最为无上。意在此也。复次百界千法纵横甚多。以经论偈结之令其易解。中论偈云。因缘所生法我说即是空。亦名为假名亦名中道义。六道相性即是因缘所生法也。二乘及通教菩萨等相性。是我说即是空。六度别教菩萨相性是亦名为假名。佛界相性是亦名中道义。结要虽少摄得前多义。则可见(云云)。又涅槃偈云。诸行无常是生灭法。生灭灭已寂灭为乐。六道相性即是诸行。二乘通教相性即是无常。别教菩萨相性即是生灭灭已。佛界相性即是寂灭为乐。又生灭灭已寂灭为乐。即是别教相性。即于生灭仍是寂灭不待灭已方称为乐。是为圆教佛界相性(云云)。又七佛通戒偈云。诸恶莫作众善奉行。自净其意是诸佛教。四趣相性即是诸恶。人天相性即是众善。自净其意。即有析体净意是二乘相性。入假净意是菩萨相性。入中净意是佛界相性(云云)。若能解十相性。与众经论律合者。即通达三藏通别。识一切法无有障碍。广明众生法相竟。二广明佛法者。佛岂有别法。秖百界千如是佛境界。唯佛与佛究竟斯理。如函大盖亦随大。以无边佛智。照广大佛境。到其源底。名随自意法也。若照九(法界)性相。本末纤芥不遗。名随他意法。从二法本垂十界迹。或示己身或示他身。或说自意语。或说他意语。自意他意不可思议。己身他身微妙寂绝。皆非权非实。而能应于九界之权。一界之实。而于佛法无所损减。诸佛之法岂不妙耶。是事可知无劳广说。至方便品中当更明之。三广释心法者。前所明法岂得异心。但众生法太广佛法太高。于初学为难。然心佛及众生是三无差别者。但自观己心则为易。涅槃云一切众生具足三定。上定者谓佛性也。能观心性名为上定。上能兼下即摄得众生法也。华严云。游心法界如虚空。则知诸佛之境界。法界即中也。虚空即空也。心佛即假也。三种具即佛境界也。是为观心仍具佛法。又游心法界者。观根尘相对一念心起。于十界中必属一界若属一界即具百界千法。于一念中悉皆备足。此心幻师于一日夜。常造种种众生种种五阴种种国土。所谓地狱假实国土。乃至佛界假实国土。行人当自选择何道可从。又如虚空者。观心自生心不须藉缘。藉缘有心。心无生力。心无生力。缘亦无生。心缘各无合云何有。合尚叵得离则不生。尚无一生况有百界千法耶。以心空故从心所生一切皆空。此空亦空。若空非空点空设假。假亦非假。无假无空毕竟清净。又复佛境界者。上等佛法下等众生法。又心法者。心佛及众生是三无差别。是名心法也。问一念心云何含受百界千法耶。答借三种为譬。如止观中说(云云)

△二明妙者。一通释。二别释。通又为二。一相待。二绝待。此经唯论二妙。更无非绝非待之文。若更作者。绝何惑显何理。故不更论也。光宅用法华之妙。待前诸教皆粗。巨有所妨已如前难(云云)。今待粗妙者。待半字为粗。明满字为妙。亦是常无常大小相待为粗妙也。净名云。说法不有亦不无。以因缘故诸法生。即是明满字也。始坐佛树力降魔。得甘露灭觉道成。即提昔之半待出于满也。般若云。于阎浮提见第二法轮转。亦是对鹿苑为第一。待般若为第二也。涅槃云。昔于波罗柰初转法轮。今于尸城复转法轮。众经皆共以鹿苑为半为小为粗。待此明满大妙其义是同。今法华明。昔于波罗柰转四谛法轮五众之生灭。今复转最妙无上之法轮。此亦待鹿苑为粗法华为妙。妙义皆同待粗亦等。文义在此也。问齐方等来满理无殊者。悉应称妙。答今亦不克教定时。那忽云齐方等耶。纵令尔者别有所以。何者利根菩萨。于彼入妙与法华不异。钝根菩萨及二乘人。犹带方便诸味调伏。方等带生苏论妙以待粗。般若带熟苏论妙以待粗。今经无二味方便。纯真醍醐论妙以待粗。此妙彼妙妙义无殊。但以带方便不带方便为异耳。复次三藏但半字生灭门。不能通满理。故名为粗。满字是不生不灭门。能通满理故名妙。能通满理。复有二种。一带方便通满理。二直显满理。方等般若带方便通满理。今经直显满理。故中论云。为钝根弟子说因缘生灭相。为利根弟子说因缘不生不灭相(云云)。中论偈(云云)。若不即空为通真方便。是故言粗。若能即空是通中方便。通中方便。若带即空即假通中者粗。不带空假直通中者妙(云云)。问乳至醍醐同称为满。是譬云何。答今以譬解譬。如官有三航及以私船。从于此岸度人彼岸。乳教如大中两航共度人彼岸。酪教如私船度人中洲。生苏如四种小航与私船。度人于中洲。两航度人于彼岸。熟苏如三航一航中洲二航彼岸。醍醐如大航度人彼岸。三航同是官物。故俱称为满。私船非官物。是故言半。官物之中二航小所容盖寡。大航壮丽容载倍多。独称为妙。智者以譬喻得解。其譬义如是(云云)。二绝待明妙者为四。一随情三假法起。若入真谛待对即绝故。身子云。吾闻解脱之中无有言说。此三藏经中绝待意也。二若随理三假。一切世间皆如幻化。即事而真无有一事而非真者。更待何物为不真耶。望彼三藏绝还不绝。即事而真乃是绝待。此通教绝待也。三别教。若起望即真之绝还是世谛。何者非大涅槃。犹是生死世谛绝还有待。若入别教中道待则绝矣。四圆教。若起说无分别法。即边而中无非佛法。亡泯清净岂更佛法待于佛法。如来法界故出法界外。无复有法可相形比。待谁为粗形谁得妙。无所可待亦无所绝。不知何名强言为绝。大经云。大名不可称量不可思议故名为大。譬如虚空不因小空。名为大也。涅槃亦尔。不因小相名大涅槃。妙亦如是。妙名不可思议。不因于粗而名为妙。若谓定有法界广大独绝者。此则大有所有何谓为绝。今法界清净。非见闻觉知不可说示。文云。止止不须说我法妙难思。止止不须说即是绝言。我法妙难思即是绝思。又云。是法不可示言辞相寂灭。亦是绝叹之文。不可以待示不可以绝示。灭待灭绝故言寂灭。又云。一切诸法常寂灭相终归于空。此空亦空则无复待绝。中论云。若法为待成。是法还成待。今则无因待亦无所成。法华首云。既得无生忍亦不生无生。无生即无生是名绝待。降此已外若更作者。绝何物显何理。流浪无穷则堕戏论。乃是迷情分别。绝待不绝。非绝非待待于亦待亦绝。言语相逐永无绝矣。何者言语从觉观生。心虑不息语何由绝。如痴犬逐块。徒自疲劳块终不绝。若能妙悟寰中息觉观风。心水澄清言思皆绝。如黠师子放块逐人。块本既除块则绝矣。妙悟之时洞知法界外无法而论绝者。约有门明绝也。是绝亦绝约空门明绝也。如快马见鞭影无不得入。是名绝待妙也。用是两妙妙上三法。众生之法亦具二妙称之为妙。佛法心法亦具二妙称之为妙。若将上四种绝待约五味经者。乳教两绝。酪教一绝。生苏四绝。熟苏三绝。此经但有一绝。若开权绝者。无不入一妙绝也。问何意以绝释妙。答秖唤妙为绝。绝是妙之异名。如世人称绝能耳。又妙是能绝粗是所绝。此妙有绝粗之功。故举绝以名妙。如迹中先施方便之教。大教不得起。今大教若起方便教绝。将所绝以名于妙耳。又迹中大教既起。本地大教不得兴。今本地教兴迹中大教即绝。绝于迹大功由本大。将绝迹之大名于本大。故言绝也。又本大教若兴。观心之妙不得起。今入观缘寂言语道断本教即绝。绝由于观。将此绝名名于观妙。为显此义故以绝为妙。今将迹之绝妙妙上众生法。将本地之绝妙妙上佛法。将观心之绝妙妙上心法。前四绝横约四教。今三绝竖约圆教(云云)

△别释妙者为三。若鹿苑三粗鹫头一妙。皆迹中之说。约迹开十重论妙。此妙有迹有本。本据元初。元初本妙十重论妙。迹本俱是教。依教作观观复有十重论妙。迹中有众生法妙佛法妙心法妙。各十重合三十重。此与众经论妙有同有异。本中三十妙。与众经一向异。此六十重一一复有待妙绝妙。则有一百二十重。若破粗显妙。即用上相待妙。若开粗显妙。即用上绝待妙(云云)。迹中十妙者。一境妙。二智妙。三行妙。四位妙。五三法妙。六感应妙。七神通妙。八说法妙。九眷属妙。十功德利益妙。释十妙为五番。一标章。二引证。三生起。四广解。五结权实

○标章者。云何境妙。谓十如因缘四谛三谛二谛一谛等。是诸佛所师故称境妙。智妙者。所谓二十智。四菩提智。下中上上上。七权实五三智一如实智。以境妙故智亦随妙。以法常故诸佛亦常。函盖相称境智。不可思议。故称智妙。行妙者。谓增数行。次第五行。不次第五行。智导行故故言行妙。位妙者。谓三草位二木位一实位。妙行所契故言位妙。三法妙者。谓总三法。纵三法横三法。不纵不横三法。类通三法。皆秘密藏故称为妙。感应妙者。谓四句感应。三十六句感应。二十五感应。别圆感应。水不上升月不下降。一月一时普现众水。诸佛不来众生不往。慈善根力见如此事。故名感应妙。神通妙者。谓报通修通。作意通体法通。无记化化通。无谋之权称缘转变。若远若近若种若熟若脱。皆为一乘故言神通妙。说法妙者。谓说十二部法。小部法大部法。逗缘法所诠法。圆妙法如理圆说。咸令众生开示悟入佛之知见。故言说法妙。眷属妙者。谓业眷属神通眷属愿眷属应眷属法门眷属。如阴云笼月。群臣豪族前后围绕。故言眷属妙。利益妙者。谓果益因益。空益假益。中益变易益。犹如大海能受龙雨。故名利益妙

○二引证者。但引迹文尚不引本文。况引余经耶。文云诸法如是相等。唯佛与佛乃能究尽诸法实相实相是佛智慧门。门即境也。又云。甚深微妙法难见难可了。我及十方佛乃能知是相。即境妙也。我所得智慧微妙最第一。又以此妙慧求无上道。无漏不思议甚深微妙法。唯我知是相(云云)。即智妙也。本从无数佛具足行诸道。行此诸道已道场得成果。又云。合掌以敬心欲闻具足道。又诸法从本来常自寂灭相。佛子行道已来世得作佛。即行妙。天雨四华表住行向地。开示悟入亦是位义。乘是宝乘游于四方。四方是因位。直至道场是果位。是名位妙。佛自住大乘。如其所得法。定慧力庄严。大乘即真性。定即资成。慧即观照。是为三法妙。我于三七日中思惟如是事。又我以佛眼观见六道众生。又一切众生皆是吾子。又遥见其父踞师子床。即感应妙也。今佛世尊入于三昧。是不可思议现希有事。神通妙也。如来能种种分别巧说诸法。言辞柔软悦可众心。身子云。闻佛柔软音深远甚微妙。又其所说法皆悉到于一切智地。又但说无上道。又已今当说最为难信难解。即说法妙。但教化菩萨无声闻弟子。即眷属妙。现在未来若闻一句一偈。皆与三菩提记。又须臾闻者。即得究竟三菩提。又若以小乘化我即堕悭贪。此事为不可。又终不令一人独得灭度。皆以如来灭度而灭度之。即利益妙也

○三生起者。实相之境非佛天人所作。本自有之非适今也。故最居初。迷理故起惑。解理故生智。智为行本。因于智目起于行足。目足及境三法为乘。乘于是乘入清凉池。登于诸位位何所住。住于三法秘密藏中。住是法已寂而常照。照十法界机机来必应。若赴机垂应先用身轮。神通骇发见变通已堪任受道。即以口轮宣示开导。既沾法雨禀教受道。成法眷属。眷属行行拔生死本。开佛知见得大利益。前五约自因果具足。后五约他能所具足。法虽无量十义意圆。自他始终皆悉究竟也

妙法莲华经玄义卷第二上妙法莲华经玄义卷第二下

        天台智者大师说

○四广释境又为二。一释诸境。二论诸境同异。释境为六。一十如境。二因缘境。三四谛境。四二谛境。五三谛境。六一谛境。然众经赴缘明境甚众。岂可具载。略举六种。六种次第者。十如是此经所说故在初。次十二因缘三世轮回。本来具有。如来出世分别巧示。四谛名兴从广至略。次辨二谛。二谛语通别显中道。次明三谛。三谛犹带方便。直显真实。次明一谛。一谛犹有名相。次明无谛。始从无明终至实际。略用六种足。一明十如境。已如前说(云云)。二释因缘境。又为四。一正释。二判粗妙。三开粗显妙。四观心正释。又为四。一明思议生灭十二因缘。二明思议不生不灭十二因缘。三明不思议生灭十二因缘。四明不思议不生不灭十二因缘。思议两种因缘为利钝两缘辨界内法论也。中(论云)为钝根弟子说十二因缘生灭相。此简异外道。外道邪谓。诸法从自在天生。或言世性。或言微尘。或言父母。或言无因。种种邪推不当道理。此正因缘不同邪计。唯是过去无明。颠倒心中造作诸行。能出今世六道苦果好恶不同。正法念云。画人分布五彩图一切形。端正丑陋不可称计。原其根本。从画手出六道差别。非自在等作。悉从一念无明心出。无明与上品恶行业。合即起地狱因缘。如画出黑色。无明与中品恶行业。合起畜生道因缘。如画出赤色。无明与下品恶行。合起鬼道因缘。如画青色无明与下品善行。合即起修罗因缘。如画黄色。无明与中品善行。合即起人因缘。如画白色。无明与上品善行。合即起天因缘。如画上上白色。当知。无明与诸行。合故即有六道名色六入触受爱取有生老病死等。随上中下差别不同。人天诸趣苦乐万品。以生归死死已还生。三世盘回车轮旋火。故经言。有河洄澓没众生无明所盲不能出。经又称。为十二牵连更相拘带。亦名十二重城。亦名十二棘园。此十二因缘。新新生灭念念不住。故名生灭十二因缘也。料简者。缨珞第四云。无明缘行生十二。乃至生缘老死亦生十二。是则一百二十因缘。初是痴乃至老死亦是痴。不觉故痴。初亦不觉至老死亦不觉。痴故生痴故死。若能觉因缘因缘即不行。痴不行故则将来生死尽名为黠。黠即随道。又十二缘起十二缘生为同为异。此同是一切有为法故无异亦有差别。因是缘起。果是缘生。则二缘起五缘生。三缘起二缘生。又无明是缘起。行是缘生。乃至生是缘起。老死是缘生。又四句。缘起非缘生。未来二支法是也。缘生非缘起。过去二支。现在阿罗汉最后死阴是也。缘起缘生者。除过去现在罗汉死五阴。诸余过去现在法是也。非缘起非缘生者。无为法是也。法身经说。诸无明决定生行。不相离常相随逐。是名缘起非缘生。若无明不决定生行。或时相离不相随是名缘生非缘起。乃至老死亦如是。尊者和须蜜说。因是缘起。从因生法是缘生。和合是缘起。从和合生是缘生。十二因缘支。二是过去则止常。二是未来则止断。现在则显中道。推现三因则说未来二果。推现在五果。则说过去二因。三世皆有十二支。为推因果故作如是说。十二时者。无明是过去诸结时。行是过去诸行时。识者相续心及眷属时。名色者。已受生相续。未生四种色根六入未具。一歌逻罗。二阿浮陀。三卑尸。四伽那。五波罗奢诃。如是等时名名色。六入已生四种色根具足六入。此诸根未能为触作所依。是时名六入。此诸根已能为触作所依。未别苦乐不能避危害。捉火触毒把刃不净。是时名触。能分别苦乐避危害等。能生贪爱不起淫欲。于一切物不生染着。是时名受。具上三受是时名爱。以贪境故四方追求。是时名取。追求之时起身口意。是时名有。如现在识在于未来。是时名生。如现在名色六入触受。于未来是时名老死。一刹那十二缘者。若以贪心杀生。彼相应愚是无明。相应思是行。相应心是识。起有作业必有名色。起有作业必有六入。彼相应触是触。彼相应受是受。贪即是爱。彼相应缠是取。彼身口作业是有。如此诸法生是生。此诸法变是老。此诸法坏是死。问何不说病为支。答一切时一切处尽有者立支。自有人从生无病。如薄拘罗。生来不识头痛况余病。是故不立。问忧悲是支不。答非也。以终显始耳。如老死必忧悲。问无明有因不。老死有果不。若有应是支。若无则堕无因无果法。答有而非支。无明有因谓不正思惟。老死有果谓忧悲。又无明有因谓老死。老死有果谓无明。现在爱取是过去无明。现在名色六入触受。此四若在未来名老死。如说受缘爱。当知。说老死缘无明也。犹如车轮更互相因也。欲界胎生者。具十二支。色界者十一无名色也。无色界有十除名色六入。又言具有。色界初生诸根。未猛利时是名名色。无色界虽无色而有名。当知。悉具十二支也。问无明行与取有何异。答过现新故。已与果未与果等异。二思议不生不灭十二者。此以巧破拙。中论云。为利根弟子说十二不生不灭。痴如虚空。乃至老死如虚空。无明如幻化不可得故。乃至老死如幻化不可得。金光明云。无明体相本自不有。妄想因缘和合而有。不善思惟心行所造。如幻师在四衢道。幻作种种象马缨珞人物等。痴谓真实智知非真。无明幻出六道依正。当知。本自不有无明所为。如知藤本非蛇。则怖心不生。不生故不灭。是名思议不生不灭十二因缘相也。三不思议生灭因缘者。破小明大。为利钝两缘说界外法也。华严云。心如工画师作种种五阴。一切世间中莫不从心造。画师即无明心也。一切世间即是十法界。假实国土等也。诸论明心出一切法不同。或言阿黎耶是真识出一切法。或言阿黎耶是无没识。无记无明出一切法。若定执性实。堕冥初生觉从觉生我心过。尚不成界内思议因缘。岂得成界外不思议因缘。惑既非不思议境。翻惑之解岂得成不思议智。破此如止观中说。今明无明之心。不自不他不共不无因。四句皆不可思议。若有四悉檀因缘。亦可得说。如四句求梦不可得。而说梦中见一切事。四句求无明不可得。而从无明出界内外一切法。出界内十二因缘如前说。出界外十二因缘者。如宝性论云。罗汉支佛空智。于如来身本所不见。二乘虽有无常等四对治。依如来法身复是颠倒。颠倒故即是无明。住无漏界中有四种障。谓缘相生坏。缘者。谓无明住地与行作缘也。相者。无明共行为因也。生者。谓无明住地共无漏业因。生三种意生身也。坏者。三种意生身缘不可思议变易死也。还如界内十二因缘从无明至老死也。缘者即无明支也。相者行支也。生者即名色等五支也。爱取有三支例前可知也。坏即生死支也。此十二支数同界内义意大异。彼论云。三种意生身。未得离无明垢。未得究竟无为净。无明细戏论未永灭。未得究竟无为我。无明细戏论集因无漏业生。意阴未永灭未得无为乐。烦恼染业染生染。未究竟灭未证甘露究竟常。以缘烦恼道故不得大净。以相业道故不得八自在我。以生苦道故不得大乐。以坏老死故不得不变易常者。由不思议生灭十二因缘也。是为界外不思议生灭十二因缘相(云云)。不思议不生不灭十二因缘者。为利根人即事显理也。大经云。十二因缘名为佛性者。无明爱取既是烦恼。烦恼道即是菩提。菩提通达无复烦恼。烦恼既无即究竟净。了因佛性也。行有是业道即是解脱。解脱自在缘因佛性也。名色老死是苦道。苦即法身。法身无苦无乐是名大乐。不生不死是常。正因佛性故。言无明与爱是二中间即是中道。无明是过去。爱是现在。若边若中无非佛性。并是常乐我净。无明不生亦复不灭。是名不思议不生不灭十二因缘也。二判粗妙者。因缘之境不当粗妙。取之浅深致有差降耳。若从无明生诸行乃至老死。从三生二从二生七。从七生三。更互因缘烦恼业因缘业苦因缘无常生灭。中论判此教钝根法。涅槃称殷勤半字。此经但离虚妄名为解脱。故知此境则粗。若无明体相本自不有。妄想因缘和合而有境。既如幻智亦叵得。经言。若有一法过于涅槃。我亦说如幻如化。中论明教利根。涅槃称长者教毗伽罗论。大品名为如实巧度。此经名小树。斯境则巧。若无明是缘从缘生相。从相有生从生故坏。灭缘故净除相故我。尽生则乐无坏故常。中论云。因缘生法亦名为假名。大品称十二缘独菩萨法。涅槃称因灭无明则得炽燃。此经则是大树而得增长。比前为妙。方后为粗。若言无明三道即是三德。不须断三德更求三德。中论云。因缘所生法亦名中道义。大品说。十二因缘是为坐道场。涅槃云。无明与爱是二中间即是中道。此经佛种从缘起。是故说一乘。亦名最实事。岂非妙耶。前三是权故为粗。后一是实。故为妙用此粗妙历五味教者乳。教具二种因缘。一粗一妙。酪教一粗。生苏三粗一妙。熟苏二粗一妙。法华但说一妙。是名待粗因缘明妙因缘也。三开粗显妙者。如经我法妙难思。前三皆是佛法。岂有思议之粗。异不思议之妙。无离文字说解脱义。秖体思议即不思议。譬如长者引盆器米面。给与穷子成穷子物。若定天性穷子。非复客作人。盆器还家安是他物。如来于不思议方便说粗。何得保粗异妙。今决了声闻法。是诸经之王。即是开两因缘即论于妙。又大经云。为诸声闻开发慧眼者。昔慧眼但见于空不见不空。今开慧眼即见不空。不空即见佛性。故云慧眼见故而不了了。佛以佛眼见则了了。此即决菩萨慧眼开第三因缘即绝待论于妙。四观心者。观一念无明即是明。大经云。无明明者。即毕竟空。空慧照无明。无明即净。譬如有人觉知有贼。贼无能为。既不为无明所染。即是烦恼道净。烦恼净故则无业。无业故无缚。无缚故是自在我。我既自在不为业缚。谁受是名色。触受无受则无苦。既无苦阴谁复迁灭。即是常德。一念之心既具十二因缘。观此因缘恒作常乐我净之观。其心念念住秘密藏中。恒作此观名托圣胎。观行纯熟胎分成就。若破无明名出圣胎(云云)。三明四谛境为四。一明四谛。二判粗妙。三开粗显妙。四观心。初又二。一出他解。二四番四谛。有师解。胜鬘无边圣谛。对二乘有余彰佛究竟。二乘是有作四圣谛。作者有量四圣谛也。无作四圣谛者。无量四圣谛也。作无作就行。量无量就法。二乘观谛得法不尽。更有所作故名有作。得法不尽则有限量。经言。因他知知是有作行也。因他知非一切知。不知无量法也。故言有作有量。无作无量者。佛知无穷尽。更无所作故名无作。自力知一切知者。无作行也。一切者是无量法也。如此释者。虽唱四名但成二义。非今所用。四种四谛者。一生灭。二无生灭。三无量。四无作。其义出涅槃圣行品。约偏圆事理分四种之殊。所言生灭者。迷真重故从事受名。然苦集是一法。分因果成两道。灭亦然。杂心偈云。诸行果性是说苦谛。因性说集谛。一切有漏法究竟灭说灭谛。一切无漏行说道谛。大经云。阴入重檐逼迫系缚是苦谛。见爱烦恼能招来果是集谛。戒定慧无常苦空。能除苦本是道谛。二十五有子果缚断是灭谛。遗教云。集真是因更无别因。灭苦之道即是真道。此皆明生灭四圣谛相也。次第者。从粗至细苦相粗故先说。灭虽非真因灭会真。灭相粗亦先说。又举世苦果令厌世集。灭能会出世果令其欣道。作如此次第也。圣者对破邪法。故言正圣也。谛者有三解(云云)。谓自性不虚故称为谛。又见此四得不颠倒觉。故称为谛。又能以此法显示于他故名为谛。大经凡夫有苦无谛。声闻缘觉有苦有苦谛。当知凡夫不见圣理不得智不能说。但苦无谛声闻具三义故称为谛。此释与经合也。无生者迷真轻故。从理得名。苦无逼迫相集无和合相。道不二相灭无生相。又习应苦空三亦如是。又无生者生名集道。集道即空。空故不生集道。集道不生则无苦灭。即事而真。非灭后真。大经云。诸菩萨等解苦无苦。是故无苦而有真谛。三亦如是。是故名为无生四圣谛。圣谛义如前说。无量者迷中重故从事得名。苦有无量相。十法界果不同故。集有无量相。五住烦恼不同故。道有无量相。恒沙佛法不同。故灭有无量相。诸波罗蜜不同。故大经。云知诸阴苦名为中智。分别诸阴有无量相非诸声闻缘觉所知。我于彼经竟不说之。三亦如是。是名无量四圣谛。无作者。迷中轻故从理得名。以迷理故菩提是烦恼名集谛。涅槃是生死名苦谛。以能解故烦恼即菩提名道谛。生死即涅槃名灭谛。即事而中。无思无念无谁造作故名无作。大经云。世谛即是第一义谛。有善方便随顺众生说有二谛。出世人知即第一义谛。一实谛者无虚妄无颠倒。常乐我净等。是故名为无作四圣谛。然胜鬘说无作四谛中。别取一灭谛是佛所究竟。是常是谛是依。三是无常非谛非依。何者三入有为相中故无常。无常则虚妄故非谛。无常则不安故非依。灭谛离有为故是常。非虚妄故是谛。第一安隐故是依。故名第一义谛。亦名不思议也。达摩郁多罗难此义。然经说佛菩提道三义故常。一惑尽故常。二不从烦恼生故常。三解满故常。如众流归海。那云道谛无常。答胜鬘作此说者。前苦灭谛非坏法灭。无始无作等过恒沙佛法成就。说如来法身不离烦恼藏。说苦谛隐名如来藏。显名为法身。二乘空智于四不颠倒境界不见不知。今欲显说。说一是常是实是依有对治除障身显故明三非常非实一是常是实耳。今难若尔一谛显是无作谛。三谛未显非无作谛。一是了义三非了义。当知。胜鬘所说说于次第。从浅至深历别未融。乃是无量四谛中之无作。非是发心毕竟二不别之无作。涅槃云。有谛有实。当知四种皆称谛称实称常也。二判粗妙者。大小乘论谛不出此四。或教行证不融者为粗。教融行证未融亦粗。俱融者则妙。若约五味者。乳教两种二乘并不闻。以大隔小则一粗一妙。酪教一种。大乘所不用。以小隔大根败聋哑是故为粗。生苏教四种。一破三二不入二一虽入一教不融。故三粗一妙。熟苏教三种。一破二一入一一不入一一虽入一教不融。故二粗一妙醍醐教但一种四谛。唯妙无粗。是为待粗明妙(云云)。三开粗显妙者。先叙诸经意。大品止明三种四谛。文云。色即是空非色灭空。无生意也。一切法趣色是趣不过无量意也。色尚不可得。何况有趣有不趣。无作意也。中论偈亦有三意。后两品明小乘观法。即生灭意也。无量义明一中出无量。是从无作开出三种四谛也。法华明无量入一。是会三种四谛。归无作一种四谛也。涅槃圣行追分别众经故。具说四种四谛也。德王品追泯众经。俱寂四种四谛。文云。生生不可说。生不生不可说。不生生不可说。不生不生不可说。经释初句云。云何生生不可说。生生故生。生生故不生。故不可说。若依文但举生不生释生生。此之生生即生不生。那可偏作生生而说。佛为利根人举一而例诸。若取意者。生生即生不生。亦即不生生。亦即不生不生。那可偏作生生一句而说。若得此意。下三句例皆如此。问佛何故作偏释耶。答为利根故。亦是有因缘故宜须如此。时众如快马见鞭影不俟彻骨耳。如此追泯何说而不寂耶。或三种可说为粗。一可说为妙。或三不可说为粗。一不可说为妙。或四皆可说为粗。四皆不可说为妙。或四可说有粗有妙。或四不可说有粗有妙。或四可说皆非粗非妙。或四不可说皆非粗非妙。如是等种种皆决了入妙。开权显实四皆不可说。是位高。四皆可说是体广。四亦可说亦不可说。是用长。四非可说非不可说。是非高非广非长非短非一非异同称为妙也。观心可知不复记也。四明二谛。又为四。一略述诸意。二明二谛。三判粗妙。四开粗显妙。夫二谛者。名出众经而其理难晓。世间纷纭由来硕诤。妙胜定经云。佛昔与文殊。共诤二谛俱堕地狱。至迦叶佛时共质所疑。二圣因地尚不能了。况即人情强生去取。问释迦值迦叶。即是二生菩萨。云何始解二谛。尔前复不应堕恶道。答尔前语宽。何必齐二生之前始恶道出。又二生菩萨将邻补处。补处位多别圆永无此理。通教见地已免恶道亦无堕落应是三藏菩萨。至二生时犹未断惑。始解二谛此义无咎。尔前堕恶道亦有其义。问三藏菩萨有堕落。余三教无者。金光明经那云十地犹有虎狼师子等怖耶。答为恶友杀则堕地狱。为恶象杀不堕地狱。然圆教肉身于一生中。有超登十地之义。此则烦恼已破无地狱业。犹有肉身未免恶兽。余教肉身一生之中。不登十地。唯作行解以烦恼为虎狼作行解者。于理则通于事不去(云云)。然执者不同。庄严旻据佛果出二谛外。为中论师所核。如此佛智照何理破何惑。若无别理可照不应出外。若出外而无别照者。藉何得出。进不成三退不成二(云云)。梁世成论执世谛不同。或言。世谛名用体皆有。或但名用而无于体。或但有名而无体用(云云)。陈世中论破立不同。或破古来二十三家明二谛义。自立二谛义。或破他竟约四假明二谛。古今异执各引证据自保一文不信余说。今谓不尔。夫经论异说悉是如来善权方便。知根知欲种种不同。略有三异。谓随情情智智等。随情说者。情性不同。说随情异。如毗婆沙明。世第一法有无量种。际真尚尔况复余耶。如顺盲情种种示乳。盲闻异说而诤白色岂即乳耶。众师不达此意。各执一文自起见诤。互相是非信一不信一。浩浩乱哉。莫知孰是。若二十三说及能破者。有经文证。皆判是随情二谛意耳。无文证者悉是邪。谓同彼外道非二谛摄也。随情智者情谓二谛二皆是俗。若悟谛理乃可为真。真则唯一。如五百比丘各说身因。身因乃多正理唯一。经云。世人心所见名为世谛。出世人心所见名第一义谛。如此说者即随情智二谛也。随智者。圣人悟理非但见真。亦能了俗如眼除膜见色见空。又如入禅者。出观之时身心虚豁。似轻云霭空。已不同散心。何况悟真而不了俗。毗昙云。小云发障大云发障。无漏逾深世智转净故。经言。凡人行世间不知世间相。如来行世间明了世间相。此是随智二谛也。若解此三意。将寻经论。虽说种种于一一谛皆备三意也。二正明二谛者。取意存略。但点法性为真谛。无明十二因缘为俗谛。于义即足。但人心粗浅不觉其深妙。更须开拓则论七种二谛。一一二谛更开三种。合二十一二谛也。若用初番二谛破一切邪谓执着皆尽如劫火烧不留遗芥。况铺后诸谛迥出文外。非复世情图度。所言七种二谛者。一者实有为俗。实有灭为真。二者幻有为俗。即幻有空为真。三者幻有为俗。即幻有空不空共为真。四者幻有为俗。幻有即空不空。一切法趣空不空为真。五者幻有幻有即空皆名为俗。不有不空为真。六者幻有幻有即空皆名为俗。不有不空一切法趣不有不空为真。七者幻有幻有即空皆为俗。一切法趣有趣空趣不有不空为真实有二谛者。阴入界等皆是实法。实法所成森罗万品。故名为俗。方便修道灭此俗已乃得会真。大品云。空色色空。以灭俗故谓为空色。不灭色故谓为色空。病中无药文字中无菩提。皆是此意。是为实有二谛相也。约此亦有随情情智智等三义。推之可知。幻有空二谛者。斥前意也。何者实有时无真。灭有时无俗二谛义不成。若明幻有者。幻有是俗幻有不可得即俗而真。大品云。即色是空即空是色。空色相即二谛义成。是名幻有无二谛也。约此亦有随情情智智等三义(云云)。随智小当分别。何者实有随智照真与此不异。随智照俗不同。何者通人入观巧复局。照俗亦巧如百川会海。其味不别复局。还源江河则异。俗是事法照异非疑。真是理法不可不同。秖就通人出假。亦人人不同可以意得。例三藏出假亦应如是(云云)。幻有空不空二谛者。俗不异前。真则三种不同。一俗随三真即成三种二谛。其相云何。如大品明非漏非无漏初人谓非漏是非俗。非无漏是遣着。何者行人缘无漏生着。如缘灭生使。破其着心还入无漏。此是一番二谛也。次人闻非漏非无漏。谓非二边别显中理。中理为真。又是一番二谛。又人闻非有漏非无漏。即知双非正显中道。中道法界力用广大。与虚空等。一切法趣非有漏非无漏。又是一番二谛也。大经云。声闻之人但见于空不见不空。智者见空及与不空。即是此意。二乘谓着此空。破着空故故言不空。空着若破但是见空。不见不空也。利人谓不空。是妙有故言不空利。利人闻不空。谓是如来藏。一切法趣如来藏。还约空不空。即有三种二谛也。复次约一切法趣非漏非无漏。显三种异者初人闻一切法趣非漏非无漏者。谓诸法不离空。周行十方界还是瓶处。如又人闻趣知此中理须一切行来趣发之。又人闻一切趣即非漏非无漏。具一切法也。是故说此一俗随三真转。或对单真或对复真。或对不思议真。无量形势婉转赴机。出没利物。一一皆有随情情智智等三义。若随智证俗。随智转智证偏真。即成通二谛智证不空真。即成别入通二谛智证一切趣不空真。即成圆入通二谛。三人入智不同复局照俗亦异(云云)。何故三人同闻二谛。而取解各异者。此是不共般若与二乘共说。则浅深之殊耳。大品云。有菩萨初发心与萨婆若相应。有菩萨初发心如游戏神通净佛国土。有菩萨初发心即坐道场为如佛。即此意也幻有无为俗。不有不无为真者。有无二故为俗。中道不有不无不二为真。二乘闻此真俗俱皆不解。故如哑如聋。大经云。我与弥勒共论世谛。五百声闻谓说真谛。即此意也。约此亦有随情情智智等(云云)。圆入别二谛者。俗与别同。真谛则异。别人谓不空但理而已。欲显此理须缘修方便。故言一切法趣不空。圆人闻不空理。即知具一切佛法。无有缺减故言一切趣不空也。约此亦有随情等(云云)。圆教二谛者。直说不思议二谛也。真即是俗。俗即是真。如如意珠。珠以譬真用以譬俗。即珠是用即用是珠。不二而二分真俗耳。约此亦有随情智等(云云)。身子云。佛以种种缘譬喻巧言说。其心安如海我闻疑网断。即其义焉。问真俗应相对。云何不同耶。答此应四句俗异真同真异俗同。真俗异相对。真俗同相对。三藏与通真同而俗异。二入通真异而俗同。别真俗皆异而相对。圆入别俗同真异。圆真俗不异而相对。不同而同。若不相入当分真俗即相对(云云)。七种二谛广说如前。略说者。界内相即不相即。界外相即不相即四种二谛也。别接通五也。圆接通六也。圆接别七也。问何不接三藏。答三藏是界内不相即。小乘取证根败之士故不论接。余六是摩诃衍门。若欲前进亦可得去。是故被接。问若不接亦不会。答接义非会义。未会之前不论被接。三判粗妙者。实有二谛半字法门引钝根人。蠲除戏论之粪。二谛义不成此法为粗。如幻二谛。满字法门为教利根。诸法实相三人共得。比前为妙。同见但空方后则粗。以别入通能见不空是则为妙。教谭理不融是故为粗。以圆入通为妙。妙不异后。带通方便是故为粗。别二谛不带通方便。是故为妙。教谭理不融。是故为粗。圆入别理融为妙。带别方便为粗。唯圆二谛正直无上道。是故为妙。次约随情智判粗妙者。且约三藏初闻随情二谛。执实语为虚语起语见故。生死浩然无佛法气分。若能勤修念处发四善根。是时随情二谛皆名为俗。发得无漏所照二谛皆名为真。从四果人以无漏智所照真俗。皆名随智二谛。随情则粗随智则妙譬如转乳始得成酪。既成酪已。心相体信入出无难。即得随情情智智等说通别入通圆入通令其耻小慕大。自悲败种渴仰上乘。是时如转酪为生苏。心渐通泰即为随情情智智等说别圆入别。明不共般若命领家业金银珍宝出入取与。皆使令知。既知是已。即如转生苏为熟苏。诸佛法久后要当说真宝即随情情智智等说圆二谛。如转熟苏为醍醐。是则六种二谛调熟众生。虽成四味是故为粗。醍醐一味是则为妙。又束判粗妙。前二教虽有随智等。一向是随情说他意语故。故名为粗。别入通去。虽有随情等。一向束为情智说自他意语故亦粗亦妙。圆二谛虽有随情等。一向是随智说佛自意语故。故称为妙。问前二二谛一向是随情。应非见谛亦不得道。答不得中道故称随情。诸佛如来不空说法。虽非中道第一义悉檀。不失三悉檀益。大槩判之皆属随情为粗耳。若以七种二谛历五味教者。乳教有别圆入别圆三种二谛二粗一妙。酪教但实有二谛纯粗。生苏具七种二谛。六粗一妙。熟苏六种。五粗一妙。法华但有一圆二谛。无六方便唯妙不粗。题标为妙意在于此。是为相待判粗妙也。四开粗显妙者。三世如来本令众生开佛知见。得无生忍。大事因缘出现于世。法华论云。莲华出水义不可尽。出离小乘泥浊水故。入如来大众中。坐如诸菩萨坐莲华上。闻说无上清净智慧者。必非坐华叶也。乃是诸菩萨闻说一圆道。证一圆果处华王界。同舍那佛坐莲华台耳。佛意如此。始见我身初闻一实已入华台。为未入者从顿开渐更以异方便助显第一义。说诸二谛或单或复。或不可思议种种不同。皆为华台而作方便。但如来常寂而化周法界。实不分别先谋后动施此汲引慈善根力。令诸众生从此得入有人言。始自鹿苑皆是法华弄引。今言不尔。且近说寂灭道场已来。悉为法华弄引。所以光照他土现佛。悉为顿开渐文殊引先佛亦为顿开渐。如此弄引犹恨其近。从大通智胜已来而为众生。作法华方便。当知。不止近在寂场。又此犹近。从本成佛已来。而为众生作华台方便。又复犹近。从本行菩萨道时。而为众生作华台方便。文云。我本立誓愿。普令一切众亦同得此道。当知。弄引岂止今耶。本来所化入华台者。自是一边。其未入者如上方便不息。中间亦如是。若从华严方等般若等经。或别入通圆入通。圆入别等入华台者。与本入者无异。复自是一边。其未入者四味调熟。皆于此经得入华台。诸教之中或住三味二味一味。或全生者皆决粗令妙悉入华台。三藏保果。难破已破难开已开况易破易开。悉随情仍本当门显实即入华台。文云。七宝大车。其数无量。各赐诸子(云云)。此即开权显实。诸粗皆妙绝待妙也。若如上说。法华总括众经。而事极于此。佛出世之本意诸教法之指归。人不见此理谓是因缘事相。轻慢不止舌烂口中。若得其旨深。见七种二十一种无量教门。意气博远更相间入。绣淡精微横周竖穷。悉归会法华。二万灯明迦叶等。古佛设教妙极于此。有经云。弥勒当来亦妙极于此。释迦仰同三世亦妙极于此。涅槃赎命重宝重抵掌耳。观此妙旨宏壮包笼。寻者须旷其意。莫以人情局彼太虚也。摄大乘明十胜相义。咸谓深极。使地论翻宗。今试以十妙比之。彼有所漏。且用理妙比依止胜相明不思议因缘四句破执。岂留黎耶庵摩罗为依止耶。四悉檀施设。不止立无明他生一句。彼直是一道明义。不见开合众经顿渐为物。约教约行随情随智。大包佛化深括始终。因缘一境已广于依止。更用四四谛七二谛五三谛一谛等比者。彼无准拟。迹中十妙已有所漏。本中十妙群经所无。何况彼论。又观心十妙即得行用。不如贫人数果头宝。当知。十妙法门鳞沓重积。可胜言哉。天竺大论尚非其类。真丹人师何劳及语。此非夸耀法相然耳。思自见之无俟辞费也。五明三谛者。众经备有其义。而名出缨珞仁王。谓有谛无谛中道第一义谛。今经亦有其义。寿量云。非如非异即中道。如即真异即俗。问若此经无四种因缘等名那用其义答五住二死名出胜鬘涅槃。不应用其义。若不用五住则不破无明。若不用二死则非常住。又三佛名出楞伽。余经应无三佛义。众经皆是佛说。名乃不同义不可壅(云云)。今明三谛为三。一明三谛。二判粗妙。三开粗显妙。却前两种二谛。以不明中道故。就五种二谛得论中道。即有五种三谛。约别入通点非有漏非无漏三谛义成。有漏是俗无漏是真。非有漏非无漏是中。当教论中但异空而已。中无功用不备诸法。圆入通三谛者。二谛不异前。点非漏非无漏具一切法。与前中异也。别三谛者。开彼俗为两谛。对真为中中理而已(云云)。圆入别三谛者。二谛不异前。点真中道具足佛法也。圆三谛者。非但中道具足佛法。真俗亦然。三谛圆融一三三一。如止观中说(云云)。二判粗妙者。别圆入通带通方便。故为粗。别不带通为妙。圆入别带别方便为粗。圆不带方便最妙。约五味教者。乳教说三种三谛。二粗一妙。酪教但粗无妙。生苏熟苏皆具五种三谛。四粗一妙。此经唯一种三谛。即相待妙也。三开粗显妙。决前诸粗入一妙三谛。无所可待是为绝待妙也。六明一谛者。大经云。所言二谛其实是。一方便说二。如醉未吐见日月转谓有转日及不转日。醒人但见不转不见于转。转二为粗不转为妙。三藏全是转二。同彼醉人。诸大乘经带转二说不转一。今经正直舍方便但说无上道。不转一实是故为妙。地持明地相明义说相似法。地实明义说真实法。又教门方便即教道明义。说所证法即证道明义。今借用之。诸佛法久后要当说真实。即地实义。道场所得法即是证道明义。是故妙也。执着此实。实语是虚语。生语见故。故名为粗。融通无著是故言妙。开粗显妙可解(云云)。诸谛不可说者。诸法从本来常自寂灭相。那得诸谛纷纭相碍。一谛尚无诸谛安有。一一皆不可说。可说为粗不可说为妙。不可说亦不可说是妙。是妙亦妙言语道断故。若通作不可说者。生生不可说。乃至不生不生不可说。前不可说为粗。不生不生不可说为妙。若粗异妙相待不融。粗妙不二即绝待妙也(云云)。约五味教者。乳教一粗无谛一妙无谛。酪教一粗无谛。生苏三粗无谛一妙无谛。熟苏二粗无谛一妙无谛。此经但一妙无谛。开粗如前(云云)。问何故。大小通论无谛。答释论云。不破圣人心中所得涅槃。为未得者执涅槃生戏论。如缘无生使故破言无谛也。问若尔小乘得与不得俱皆被破。大乘得与不得亦俱应破。答不例小乘犹有别惑可除别理可显故。虽得须破。中道不尔。得云何破。问若尔中道唯应有一实谛。不应言无谛也。答为未得者执中生惑故须无谛。实得者有戏论者无(云云)

妙法莲华经玄义卷第二下妙法莲华经玄义卷第三上

        天台智者大师说

二诸境开合者。先用十如为首。何者此经命章绝言称叹十如。今更说五境。云何同异耶。十二因缘与十如开合者。名异故言开。义同故言合无明支合如是性。行支合如是相。识名色六入触受合如是体。爱合如是缘。取合如是力作。有合如是因。生老死合如是果报等(云云)。又总合者。如是相合行有两支。如是性合无明爱取三支。如是体合识名色乃至老死七支。如是力还是烦恼道。三支无明爱取能生业力。如是作还是行有二支。能为苦作业也。如是因还是行有二支。为七苦作因也。如是缘还是无明爱取三支能润业取苦也。如是果还是行有之习果也。如是报还是行有之业。招名色等报。此两番通用思议十二因缘。合六道十如是。次用不思议十二因缘。合四圣十如者。无明支转即变为明。明即了因。成圣人如是性。恶行支转即变为善行。善行即缘因。成圣人如是相。识名色等苦道转即法身。成圣人如是体。爱取二支转成圣人菩提心。即是如是力。有支含果变成六度行。即成圣人如是作亦转成圣人如是因。此有支转有二种正道。转成如是因。助道转成圣人如是缘老死支。转成法性常住。成圣人如是果报(云云)。又总作者。体力作三法秖是烦恼业。苦变成法身菩提心六度行等。勤习三法在内成性。在外成相。正意成体誓愿深远成力。立行成作牵果成因。相助成缘克发成果报(云云)。若细分四圣节节有异。今取大槩故通释耳。经云。一切智愿犹在不失。二乘亦得作通释也。四种四谛合十如者。生灭无生两种苦集。是六道十如。如是相如是性是集。如是体是苦。如是作力因缘又是集。如是果报又是苦(云云)。生灭无生两种道灭。是析体二乘及通菩萨十如。如是相性即是道。如是体即是灭。如是力作因缘皆是道。如是果报又是灭。无量无作两种苦集。即是四圣界外果报十如。集谛即是界外如是相性力作因缘也。苦谛即是界外如是体果报等(云云)。无量无作两种道灭。即是四圣界外涅槃十如道谛即是涅槃性相力作因缘等。亦是般若解脱也。灭谛即是涅槃体果报等。亦成常住法身也(云云)。四种四谛合四种十二因缘者。生灭无生两苦集。即是两种思议十二因缘。生灭无生两种道灭。即是两种思议十二因缘。无明灭乃至老死灭也。无量无作两苦集。即是两不思议十二因缘也。无量无作两道灭。即是两不思议十二因缘。无明灭乃至老死灭此可解。七种二谛合十如者。藏通别圆入通凡四俗。皆是六道十如也。藏通两真是二乘十如也。别圆入别两俗有边。是六道十如。无边是二乘十如。圆俗此通九法界十如。别入通圆入通。别圆入别圆。凡五种真皆是佛法界十如也。七种二谛合四种十二因缘者。藏通别圆入通凡四俗。即是思议两种十二因缘。藏通两真即是思议十二因缘。无明灭乃至老死灭也。别圆入别两俗有边。是思议十二因缘。无边是思议无明灭乃至老死灭。圆俗即通界内外四种十二因缘也。别入通圆入通。别圆入别圆。凡五种真即是界外不思议十二因缘。无明灭乃至老死灭也。七种二谛合四种四谛者。实有二谛即生灭四谛也。幻有二谛即无生四谛也。别入通圆入通两俗。还是无生苦集也。别入通真是无量道灭也。圆入通真是无作道灭也。别俗圆入别俗。此是无量苦集。圆俗是无作苦集。别真是无量道灭。圆入别真圆真。是无作道灭也。五种三谛合十如者。别入通圆入通两俗。是六道十如。别俗圆入别俗有边。是六道十如。无边是二乘十如圆俗意通九界(云云)。五种真谛皆是二乘菩萨等十如。五种中谛皆是佛界十如也。五种三谛合四种十二因缘者。别入通圆入通两俗。是六道思议十二因缘。别圆入别两俗有边。是思议六道十二因缘生。无边是思议十二因缘灭。圆俗义通(云云)。今且用是四种十二因缘五种真谛。即是思议十二因缘灭。亦即是不思议十二因缘生。五种中谛即是不思议十二因缘灭。五种三谛合四种四谛者。别入通圆入通两俗。即无生苦集也。别俗圆入别俗圆俗通是无生之苦集。亦是无生之道灭。亦是无量之苦集也。别入通圆入通两真。本取但空边。是无生道灭也。别真圆入别真。即是无生之道灭。于无量是苦集。圆真于无生是道灭。于无量无作是苦集。别入通中是无量道灭。圆入通中是无作道灭。别中是无量道灭。圆入别中是无作道灭。圆中正是无作道灭。五种三谛合七种二谛者。简前两二谛不被合也。次二种二谛二俗。即是五种三谛家五种俗。二真空边即是五种三谛家真。不空边即是五种三谛家中。后三种二谛三俗。空边即是五种三谛家真。有边即是五种三谛家俗。三真即是五种三谛家中又作一种说。如后简前二谛不被合后五俗有真有俗。后五真有真有中。一实谛合十如者。一一法界皆具十界。简却九界但与佛法界同也。简三种十二因缘。但与一种十二因缘灭同。简三种四谛。但与一实四谛。同简七种二谛。但与五真谛有同不同。简五种三谛。但与五中谛同(云云)。言无谛不可说者。合十如如名不异。即是空寂言辞相。寂灭不可说示。即是十种皆如义也。诸无明灭。乃至老死灭其义甚深。甚深即无谛同也。生生不可说。乃至不生不生不可说。即与无谛同也。七种真谛皆不可说。最初真谛不可说者。如身子云。吾闻解脱之中无有言说。况后六耶。非生死非涅槃。既非二边亦无中道。即五种中谛与无谛同也。一实名虚空。虚空无一。云何有实。即无谛同也。无谛自无所存。平等大慧无若干也。虽无若干若干无量。舒之充满法界。不知从何而来。无量无若干收之莫知所有。不知从何而去。不来不去即是法佛(云云)。复次七种二谛。赴缘开合转转相入一一又各有随情随情智随智等。余五义例亦应有。今不具载。何者佛以一音演说法众生随类各得解。自思之。问诸境理既融会。何意纷葩更相拘入耶。答如来观知十界性相。有成熟者未成熟者。大机未熟不令起谤。小机若熟不令失时。随其所宜应单应复。偏圆相入而成熟之。闻即得益。华严虽具鉴十界。两界熟故别圆二种而成熟之。三藏亦鉴十界。二乘性相熟故。用生灭而成熟之。方等亦鉴十界。四界熟故用四种相入而成熟之。般若亦鉴十界。亦四界熟故。用三种相入而成熟之。法华亦鉴十界一性相熟。但一圆谛而成熟之。若无善巧方便出没调熟。云何境智而得融妙耶。譬如画师尚能淡入五彩作种种像。况佛法王于法自在。而不能种种间入调伏众生耶。问上明六境等。此经听可无名有其义不。答十如名义已备于前四种十二因缘者。化城品明生灭十二缘。譬喻品。但离虚妄。是不生十二缘。方便品云佛种从缘起。是界外无量无作两种十二缘。四四谛者。譬喻品。诸苦所因贪欲为本。是生灭四谛。药草喻品。了达空法。是无生四谛。又云无上道。及方便品。但说无上道如来灭度等。是界外无量无作两种四谛也。十如差别。是世谛。唯佛与佛乃能究尽诸法实相。即真谛也。安乐行云亦不分别有为无为实不实法。有是俗谛无是真谛。亦不分别是遮二边显中道。寿量云非如非异。非异非俗。非如非真。三谛义也。方便品云更以异方便助显第一义。是一实谛也。又云唯此一事实也。若言说无分别法。又诸法寂灭相不可以言宣。是无谛义也

○第二智妙者。至理玄微非智莫显。智能知所非境不融。境既融妙智亦称之。其犹影响矣故次境说智。智即为二。初总论诸智。二对境论智。总智为六。一数二类三相四照五判六开。数者。一世智。二五停心四念处智。三四善根智。四四果智。五支佛智。六六度智。七体法声闻智。八体法支佛智。九体法菩萨入真方便智。十体法菩萨出假智。十一别教十信智。十二三十心智。十三十地智。十四三藏佛智。十五通教佛智。十六别教佛智。十七圆教五品弟子智。十八六根清净智。十九初住至等觉智。二十妙觉智。二类者。世智无道邪计妄执。心行理外不信不入故为一。五停心四念处。已入初贤佛法气分。俱是外凡故为一。四善根同是内凡故为一。四果同见真故为一。支佛别相观能侵习故为一。六度缘理智弱缘事智强故为一。通教方便声闻体法智胜故为一。支佛又小胜故为一。通教菩萨入真方便智。四门遍学故为一。通教出假菩萨智正缘俗故为一。别教十信智。先知中道胜前劣后故为一。别教三十心俱是内凡故为一。十地同是圣智故为一。三藏佛是师位名胜三乘弟子故为一。通教佛智断惑照机胜故为一。别教佛智又胜故为一。圆教五品弟子同具烦恼性。能知如来秘密之藏故为一。六根清净智邻真故为一。初住至等觉同破无明故为一。妙觉佛智无上最尊故为一。如是等随其类分相似者。或离或合判为二十(云云)。三辨相者。天竺世智极至非想。此间所宗要在忠孝五行。六艺天文地理。医方卜相兵法货法。草木千种皆识。禽兽万品知名。又涂左割右等无憎爱。获根本定发五神通。停河在耳变释为羊。纳吐风云扪摸日月。法是世间法。定是不动定。慧是不动。出邀名利增见爱。世心所知故名世智也。五停四念者。有定故言停。有慧故言观。观能翻邪定能制乱。数息治散不净治贪。滋治嗔因缘治痴。念佛治障道。念处是观苦谛上。四智治于四倒四倒不起。由此四观初翻四倒。未入圣理故言外凡智也。暖法缘四谛境生智。伏烦恼智更增。成十六观智。如火钻上下相依生火烧薪。以有智知有境。能生暖智令有萎悴。如夏时聚华。为[卄/積]华生暖气还自萎悴。又依阴观阴。发智火还烧阴。如两竹相摩生火还烧竹林。尊者瞿沙说。求解脱智火暖最在初。如火以烟在初为相。无漏智火亦以暖法在先为相。如日明相在初为相。是故名暖。于正法毗尼中生信爱敬。正法者缘道谛。信毗尼者缘灭谛。信暖能缘四谛。云何言二。答此二最胜应先说。又正法是三谛。毗尼是灭谛。如佛为满宿我有四句法。当为汝说欲知不。当恣汝意。四句即四谛也。所有布施持戒尽向解脱。是其意趣。色界定起是其依。于自地前生善根。是相似因缘于四真谛顶是其功用果。自地相似后生善根是依果。色界五阴是其报。涅槃决定因。及不断善根是其利。十六行是其行。是缘生是修慧。色界系三三昧三根随所说相应众多心是退。暖有三种。谓下下下中下上。顶有三。中下中中中上。忍有二种。上下上中。世第一有一种谓上上。此四善根以三言之。暖是下。顶是中。忍世第一是上。复有说者。暖有二。谓下下下中。顶有三。谓下上中下中中。忍有三。谓中上上下上中。世第一法有一。谓上上。亦以三言之。暖是下下。顶是下中。忍是中上。世第一是上上。瞿沙云。暖有下三。顶有六。下下乃至中上。忍有八。下下乃至上中。世第一但上上。以三言之。暖法一种谓下。顶法二种。谓下中。忍有三种。谓下中上。世第一有一种谓上。暖有二舍。一离界地。二退时。退时舍堕地狱作五无间。而不断善根。顶亦如是。忍唯一舍不堕地狱(云云)。顶法者。色界善根。有动不动住不住。有难不难断不断退不退。就动乃至退者有二。下者是暖上是顶。彼不动乃至不退者为二。下者是忍。上者是世第一法。复有说者。应言下顶。所以者何。在暖法顶故名顶在忍法下故名下。复有说者。如山顶之道人不久住。若无难必过此到彼。若遇难即便退还。行者住顶不久。若无难必到忍。有难退还暖犹如山顶故名顶。云何为观于佛法僧生下小信。小信者。此法不久停故言下小。此信缘佛生小信。是缘道谛。缘法生下小信。是缘灭谛。问应能缘四谛。云何言缘二谛。答道灭胜故。清净无过是妙是离。能生信处。为生受化者信乐心故。若世尊说苦集是可信敬者。则无受化者。此烦恼恶行邪见颠倒。云何可敬信。我常为此逼迫。受化者于道灭生欣乐。是故说二也。复有说者。信佛僧是缘道。信法是缘三谛。则尽信四谛也。问住顶亦信阴亦信宝亦信谛。何故但说信三宝。答三宝是生信敬处。但随行者意。于阴生悦适。是名为暖。于宝生悦适是名为顶。于谛生悦适。是名为忍。问何故顶退不说暖退。答顶既退亦应说暖退。行者在顶时。多烦恼业留难烦恼等作是念。若行者到忍。我复于谁身中当作果报。若离欲界时亦念。行者出欲界。我复于谁身中生果报。离非想非非想处时亦念。行者离彼欲已更不受身。我复于谁身中生于果报。于此三时多诸留难。留难退故大忧恼。如人见宝藏大喜欲取即失。住顶法者自念。不久当得于忍永断恶道。获大重利犹如圣人。而忽退失故大忧恼。是故言顶退也。若能亲近善友。从其闻随顺方便法。内心正观信佛菩提。信善说法信僧清净功德。是说信宝说色无常。乃至说识无常。是说信阴。知有苦集灭道。是说信谛。若如是即住顶。若不如是即顶退。忍法观者。正观欲界苦色无色界苦。欲界行集色无色界行集。欲界行灭色无色界行灭。断欲界行道断色无色界行道。如是三十二心是名下忍。行者后时渐渐减损行及缘。复更正观欲界苦色无色界苦。乃至观断欲界行道。除观断色无色界行道。从是中名中忍。复更正观欲界苦。观色无色界苦。乃至观色无色界行灭。除灭一切道。复正观欲界苦色无色界苦。乃至观欲界行灭。除色无色界行灭。复正观欲界苦。乃至观色无色界行集。除灭一切灭。复正观欲界苦。乃至观欲界行集。除色无色界行集。复正观欲界色无色苦。除一切集。复正观欲界苦。除色无色界苦。复正观欲界常相续不断不远离。如是观时深生厌患。复更减损。但作二心观于一行。如似苦法忍。忍法智。如是正观是名中忍。复以一心观欲界苦。是名上忍。复次生世第一法。世第一法后次生苦法忍。譬如人欲从己国适他国。多财产不能持去。以物易钱。犹嫌钱易金。嫌金易多价宝。往适他国。行者乃至渐舍相续不离。生于上忍。上忍后生第一法。第一法后生苦忍。问世第一法有三品不。答一人无多人有。身子上目连中余皆下。就佛支佛声闻为三品。世第一法者此心心数法。于余法为最为胜。为长为尊。为上为妙亦分亦都。分者胜世间法不胜见谛。见谛眷属不相离。慧力偏多故。熏禅不与凡夫同生一处故。尽智时一切善根。永离一切诸垢障故。三三昧乃至恶贱无漏。何况有漏。不应都胜。分胜彼暖顶忍法。亦应言第一。应言分胜。胜暖顶忍一切凡夫所得禅。无量解脱除入也。或言都胜。非谓一切事业中胜。但以能开圣道门故。彼见谛等不能开圣道门。以世第一法开圣道门。彼见谛等法得修见谛等法。得修者。皆是世第一法功用。是世第一法名。义者最胜义。是第一义。得妙果是第一义。如高幢顶更无有上。是第一义。问前诸义有差别邪。答此皆叹说上妙之义。亦有差别。于不净安般名最。于闻慧名胜。于思慧名长。于暖为尊。于顶为上。于忍为妙。又依未至为最。依初禅为胜。中间为长。二禅为尊。三禅为上。四禅为妙。如是种种说。此依毗婆沙释。欲委知向彼寻。初果八忍八智三果重虑缘真。九无碍九解脱智。支佛用总相别相。如约三世明苦集。分别十二因缘。即别相相也。六度缘理智弱伏而未断。事智强能舍身命财无所遗顾。声闻能发真成圣。犹论我衣我钵互论强弱(云云)。通教声闻。总相一门达俗即真。通教缘觉能于一门。总相别相达俗即真。通教菩萨能于四门。总相别相俗达即真。又能遍四门出假。教化众生。十信信果头真如实相。为求此理起十信心。十住正习入空傍习假中。十行正习假傍习中。十回向正习中。初地证中。二地已上重虑于中。三藏佛一时用三十四心。八忍八智。九无碍九解脱断正习尽。通佛坐道场。一念相应慧。断余残习气。别教佛用金刚后心。断一品无明。究竟尽成佛。或言。断时是等觉。佛无所断。但证得圆满菩提具足耳。圆五品不断五欲而净诸根。具烦恼性能知如来秘密之藏。六根净位获相似中道智。初住获如来一身无量身。入法流海中行任运流注。后位可解不复记。四明智照境者。若由智照境由境发智。四句皆堕性中如别记(云云)。若四悉檀因缘立境智。但有名字(云云)。问智能照境。境亦能照智不。答若作不思议释。更互相照义亦无妨。仁王般若云。说智及智处皆名为般若。譬镜面互相照。亦如大地一能生种种芽。芽亦生地一。且置斯义。世智照六道十如。五停心智去至体法。凡七智照二乘十如。六度及通教出假菩萨智两属。上求照菩萨十如。下化照六道十如。四十心智亦两属。上求照菩萨十如。下化照六道十如。十地智两属。次第照照菩萨十如。不次第照照佛十如。五品去凡四智。皆照佛界十如。总略如此细捒(云云)。二十智照四种十二因缘境者。世智五停四念四果乃至支佛六度三藏佛。凡七智。照思议生灭十二因缘境。通教三乘入真方便智。出假智佛智凡五智。照思议不生不灭十二因缘境。别教十信三十心。十地佛凡四智。照不思议生灭十二因缘境。其中不无别意。且从大判圆教四智。照不思议不生不灭十二因缘境。二十智照四种四谛者。前三藏等七智。照生灭四谛境。次通教五智。照无生灭四谛境。次别教四智。照无量四谛境。次圆教四智照无作四谛境。次二十智照二谛者。前七智是照析空之二谛。次五智是照体空之二谛。次八智照显中之二谛。其间别圆相入者。可以意得(云云)。次明二十智照三谛者。前七智照无中之二谛。是因缘所生法皆属俗摄。次五智照含中之二谛。即空一句皆属真谛摄也。次别圆八智照显中之二谛。即是假名亦名中道。二句皆属中道谛摄也。次二十智照一实谛者。此须引释论明四悉檀。皆名为实。世界故实。乃至第一义故实。当知实语亦通四谛生灭故实。无生灭故实。无量故实。无作故实。前三藏七智照生灭之实。次通教五智照无生灭之实。次别教四智照无量之实。次圆教四智照无作之实。前后诸实(云云)。次二十智无谛无照者。无谛无别理。若于四种四谛得悟。不复见谛与不谛。故无谛亦通也。前七智照生灭之无谛。生生不可说故。次五智照无生灭之无谛。生不生不可说故。次四智照无量之无谛。不生生不可说故。次四智照无作之无谛。不生不生不可说故。前无谛是权。后无谛是实。此就言教。若就妙悟。同于圣人心中所照者。则不见有权实故。非权非实空拳诳小儿。诱度于一切方便说权。方便说实。会理之时。无复权实故。称非权非实为妙也。五明粗妙者。前十二番智是粗。后八番智为妙。何者。藏通等佛自是无常。亦不说常。彼二乘菩萨何得闻常信常修常。是故为粗。别教十信初已闻常信修于常。尚胜彼佛。何况余耶。是故为妙。常途云法华不明常者。秖是三藏意耳。今明十信知中已过牟尼。则八番为妙也。又别教四智三粗一妙。圆教四智悉皆称妙。何者地人云。中道乃是果头能显初心学者仰信此理。如藕丝悬山故。说信行皆非圆意也。故十信智为粗。十住正修空傍修假中。十行正修假傍修中。十回向始正修中。此中但理不具诸法。是故皆粗。登地智破无明见中道。证则为妙。类如通藏两种俱得道。而三藏门拙。今别教亦尔。教门皆权而证是妙(云云)。圆教四智皆妙者。如法相说如说而信如理而行。始论五品终竟妙觉。实而非权。是故皆妙。是名待粗智说妙智也。又约知见明粗妙者。知与见云何。然分别有四。不知不见。知非见。见非知亦知亦见。先约三藏释后约圆释。中间例可解。凡夫不闻故不知。不证故不见。五停四念至世第一法。闻故名知。未证故非见。辟支佛不闻故非知。自然证故是见。四果闻故亦是知。证故亦是见。传传判粗妙可解。约圆教释者。七方便不闻故不知。未证故不见。五品六根闻故知。未证故不见。发宿习者名见不从闻故不知。禀教证入者亦知亦见。此节节传为粗妙。究竟而论。前来二十种智。略而言之。不出权实二智。如经如来方便知见。波罗蜜皆悉具足。即总束得前来诸权智也。如来知见广大深远即是总束前来实智也。方便既其具足何所不该。知见既其广大深远。何所不摄。境渊无边智水莫测。唯佛与佛乃能究尽。如此知见即是眼智。眼即五眼具足。智即三智一心。一切种智知于实。两智知于权。佛眼见于实。四眼见于权。此知即是见。此见即是知。对前诸智。诸智是粗。此之知见名之为妙也。若得知见中意不复论五眼。迷者未了。更约眼明粗妙。如肉眼盲闭何由见色。徒闻人说起种种想。终非真见。欲令眼开应须治膜。那得闭眼执诤何益耶。闭眼想则粗。眼开见则妙。天眼未开不见障外为粗。修禅定愿智之力能发得净色。彻障内外明闇无隔。慧眼未开常行死迳。假令情想亦复非实故为粗。无漏豁发故称为妙。谛理明了故称妙。法眼未开差机说法。如身子僻教满愿秽器名为粗。破障通无知。分别药病名之为妙。佛眼不开不见实相。故文云。二乘之人及新发心者。不退菩萨所不能知故。四眼皆粗。除诸菩萨众信力坚固者。以信得入相似佛眼。能开真佛知见乃名为妙。诸教多说四眼。或带四眼说佛眼。是故为粗。今经独说佛眼。是故为妙。是为待粗为妙也。六明开粗显妙者。前十六番智。若不决了但是粗智。若得决了。悉成妙智。何者。如妙庄严王先是外道。世智闻法华经。便得决了。以邪相入正相。于诸见不动而修三十七品。不舍八邪而入八正。即是决于世智得入妙智。或与五品齐。或与相似齐。或与分得齐。节节有入义细作(云云)。若五停方便智。乃至通教佛等智。若不决了即是粗智。今开权显实。汝等所行是菩萨道来入妙位。须一一将十二番智来入圆妙四智。或入五品相似分得等智(云云)。又决了别教历别之智入于妙智。当体即是某位。进入是某位细捒(云云)。十六粗智皆成妙智。无粗可待。即是绝待智妙也。复次开粗眼为妙眼者。余经虽说为五眼。五眼不融是故为粗。今经决了四眼令入佛眼。文云。父母所生眼遂得清净。学大乘者。虽有肉眼名为佛眼。即是决了肉眼名为佛眼也。净名云。世孰有真天眼者。有佛世尊。不以二相见诸佛国。此即是决了天眼。即是佛眼也。愿得如世尊慧眼第一净。即是决了慧眼能得入妙。决法眼入妙者。边际智满是也。四眼融入佛眼。寂而常照故。文云。决了声闻法。是诸经之王。五眼具足成菩提。开佛知见故称为妙。问佛眼开乃名为妙。六根虽净云何为妙。答佛眼虽未开。已能圆学圆信。如迦陵频伽鸟。虽在[穀-禾+卵]中音声已胜诸鸟。即是假名相似等妙。若开即是分妙究竟妙(云云)。二对境明智又二。一对五境。二展转相照对境。初应对十如境。此既一经之意处处说之。可解故不复释。次对四种十二因缘明智者。大经云。十二因缘有四种观。下智观故得声闻菩提。中智观故得缘觉菩提。上智观故得菩萨菩提。上上智观故得佛菩提。何者。十二因缘本是一境。缘解不同开成四种。今以四教意释之。三藏具有三人。而皆以析智观界内十二因缘事为初门。然析智浅弱。三人之中声闻最劣。以劣人标浅法。故名下智。通教亦有三人。同以体智观界内十二因缘理。体法虽深望藏为巧。望别未巧。三人之中缘觉是中。以中人名通法故言中智。别教佛与菩萨。俱知界外十二因缘事。次第菩萨比佛。犹未是上。比于通藏则是上法。故以上智当名也。圆教佛与菩萨。俱观界外十二因缘理。初心即事而中。此法最胜故。以佛当名故。言上上智观也。以四教释四观。于义允合(云云)。所言下智观者。观受由触触由入。入由名色。名色由识。识由行。行由无明。无明颠倒不善思惟。致不善行。感四趣识名色等。若善思惟致善行。感人天识名色等。观此无明念念无常前后不住。所生善恶迁变速朽。所受名色衰损代谢。烦恼业苦更互因缘。都无暂停。过去二因现在五果。现在三因未来二果。三世回复犹若车轮。痴惑之本既无常苦空无我。则无明灭。无明灭故诸行灭。乃至老死灭。若不然火是则无烟。是名子缚断。无子则无果。灭智灰身离二十五有。是名果缚断则是下智观十二因缘。得声闻菩提也。中智者。观受由触乃至行由无明。无明秖是一念痴心。心无形质但有名字。内外中间求字不得。是字不住亦不不住。犹如幻化虚诳眼目。无明体相本自不有。妄想因缘和合而生。无所有故假名无明。不善思惟心行所造。以不达无明如幻化故。起善不善思惟。则有善不善行。受善不善名色触受。今达无明如幻故。则诸行亦如化。从幻生识名色等。皆如幻。爱取有生三世轮转。幻化迁改都无真实。有智之人不应于中而生爱恚。无明既不可得。则无明不生。不生则不灭。诸行老死亦不生不灭。不生故则非新。不灭故则非故。非故者无故可毕。非新者无新可造。无新者子缚断。无故者果缚断。是名中智观十二因缘得缘觉菩提。上智观者。观受由触。乃至行由无明。无明秖是痴一念心。心痴故派出烦恼。由烦恼派出诸业。由业派出诸苦。观此烦恼种别不同。不同故业不同。业不同故苦不同。诸行若干名色各异。种种三道无量无边。分别不滥。知因此烦恼起此业得此苦。不关彼业及彼烦恼。如是三道覆障三德。破障方便亦复无量。无明若破显出般若。业破显出解脱。识名色破显出法身。爱取有老死亦复如是。自既解已复能化他。于一切种知一切法。起道种智导利众生。是名上智观十二因缘也。上上智观者。观受由触。乃至行由无明。知十二支三道即是三德。岂可断破三德更求三德。则坏诸法相。烦恼道即般若。当知烦恼不闇般若即烦恼。般若不明烦恼既不闇。何须更断。般若不明何所能破。闇本非闇不须于明。如耆婆执毒成药。岂可舍此取彼。业道即是解脱者。当知业道非缚。解脱即业者脱非自在。业非缚故何所可离。脱非自在何所可得。如神通人岂避此就彼耶。苦道即法身者。当知苦非生死法身即生死。法身非乐苦非生死。何所可忧。法身非乐何所可喜。如彼虚空无得无失。不忻不戚。如是观者。三道不异三德。三德不异三道。亦于三道具一切佛法。何者。三道即三德。三德是大涅槃。名秘密藏。此即具佛果。深观十二因缘即是坐道场。此即具佛因。佛因佛果皆悉具足余例可知。是名上上智观十二因缘得佛菩提。约此应判粗妙。开粗显妙意可解故不委记耳。又四智照四境。境若不转。其智则粗。四境转成妙境。粗智即成妙智。仍是待绝之意(云云)。二对四种四谛明智者。大经云。知圣谛智则有二种。中智上智。中智者声闻缘觉。上智者诸佛菩萨。若依此文束于体析合称为中。束大乘利钝。合称为上。今若约根缘利钝内外事理。开即成四。声闻根钝缘四谛事。即生灭四谛智。缘觉根利缘四谛理。即无生四谛智。菩萨智浅缘不思议事。即无量四谛智。诸佛智深缘不思议理。即无作四谛智也。此乃大经之一文。又云。凡夫有苦无谛。声闻有苦有苦谛。凡夫不见苦理故言无谛。声闻能见无常苦空故言有谛。即是生灭四谛智也。又云。菩萨之人解苦无苦而有真谛。即是体苦非苦故言无苦。即事而真故言有谛。乃是摩诃衍门无生四谛智也。又云。知诸阴是苦。知诸入为门。亦名为苦。知诸界为分亦名为性。亦名为知。是名中智。依前说者即属声闻也。分别诸苦诸入界等有无量相。我于彼经竟不说之。是名上智。受想行识亦复如是。非诸声闻缘觉境界。此则异前两意。既称上智。又非二乘境界。岂非别教菩萨观恒沙佛法如来藏理耶。是为无量四谛智。又云。如来非苦非集。非灭非道非谛是实。虚空非苦非谛是实。非苦者非虚妄生死。非谛者非二乘涅槃。是实者即是实相中道佛性也。又云。有苦有苦因。有苦尽有苦对。如来非苦乃至非对。是故为实。如此明义既异上三番。岂非无作四谛智耶。例此一谛为四。余三亦应尔。谓有集有集果。有集尽有集对。有尽有尽因。有尽障有尽障相。有对有对果。有对障有对障相。如来非此四四十六种。但是于实(云云)。如是等智观于四谛。谛既未融智谛皆粗。独有非苦非对有实为妙。若谛圆智亦随圆。皆是如来非苦非谛。是实之妙智也。此即待绝两意(云云)

妙法莲华经玄义卷第三上妙法莲华经玄义卷第三下

        天台智者大师说

三对二谛境明智者。权实二智也。上真俗二谛既开七种。今权实二智亦为七番。内外相即不相即四也。三相接合七也。若对上数之。析法权实二智。体法二智。体法含中二智。体法显中二智。别二智。别含圆二智。圆二智。上七番各开随情随情智随智。合二十一种谛。今七番二智。亦各开三种。谓化他权实。自行化他权实。自行权实。合二十一权实也。若析法权实二智者照森罗分别为权智。尽森罗分别为实智。说此二智逗种种缘。作种种说。随种种欲种种宜。种种治种种悟。各随堪任当缘分别。虽复种种悉为析法权实所摄。故有化他二智。化他二智随缘之说。皆束为权智。若内自证得若权若实。俱是实证束为实智。内外相望共为二智。故有自行化他权实二智也。就自证权实。唯独明了余人不见。更判权实故有自行二智也。今更约三藏重分别之。此佛化二乘人。多用化他实智。二乘禀此化他之实。修成自行之实。故佛印迦叶云。我之与汝俱坐解脱床。即此义也。若化菩萨多用化他权智。其禀化他之权。修学得成自行之权。佛亦印言。我亦如汝(云云)。此三种二智。若望体法二智。悉皆是权。故龙树破云。岂有不净心中修菩提道。犹如毒器不任贮食。食则杀人。此正破析法意也。故皆是权(云云)。体法权实二智者。体森罗之色。即是于空即色是权智。即空是实智。大品云。即色是空非色灭空。正是此义。为缘说二。缘别不同。说亦种种。虽复异说。悉为化他权实所摄。故有化他二智。化他二智既是随情皆束为权。内证权实既是自证。悉名为实。以自之实对他之权。故有自行化他二智也。就自证得又分权实。故有自行二智也。此三二智望含中二智。复皆名权。何者。无中道故(云云)。体法含中权实二智者。体色即空不空照色是权智。空不空是实智

说此二智赴无量缘。随情异说。虽复无量悉是含中二智所摄。故有化他二智。化他二智本是逗机。皆名为权。自证二智皆名为实。于自证二智更分权实。故有自行二智。此三二智望显中二智。悉皆是权。何者。带于空真及教道方便故。又体法显中权实二智者。体色即空不空。一切法趣空不空了色是权智。空不空一切法。趣空不空是实智。为缘说二。缘既无量说亦无量。无量之说悉为显中二智所摄。故有化他二智。化他二智既是随缘。悉名为权。自证二智既是证得。悉名为实。以自望他故。有自行化他二智。就自证二智更分权实。此三二智望别权实二智。悉皆是权。何者。带即空及教道方便故。别权实二智者。体色即空不空。色空俱是权智。不空是实智。以此二智随百千缘种种分别。分别虽多悉为次第二智所摄。故有化他二智。化他二智悉是为缘。皆名为权。自证二智既是证得。悉名为实。以自对他故。有自他二智。就自证权实自分二智故。有自行二智。此三二智望别含圆二智。悉复是权。何者。以次第故。带教道故。别含圆权实二智者。色空不空一切法趣不空。色空名权智。一切法趣不空为实智。以此二智随百千缘种种分别。分别虽多悉为别含圆二智所摄。故有化他二智。化他二智既是为缘。悉皆是权。自证二智既是证得。悉名为实。自他相望共为二智。就自证得更分权实。故有自行二智。此三二智望圆二智。悉复是权。何者。带次第及教道故。圆权实二智者。即色是空不空。一切法趣色趣空趣不空。一切法趣色趣空是权智。一切法趣不空是实智。如此实智即是权智。权智即实智无二无别。为化众生种种随缘。随欲随宜。随治随悟。虽种种说。悉为圆二智所摄。故有化他二智。化他二智既是随情。悉复是权自证二。智悉名为实。就自证中更分二智。故有三种不同也。此之二智。不带析法等十八种二智方便。唯有真权真实名佛权实。如经如来知见广大深远。方便波罗蜜皆悉具足。独称为妙。待前为粗。又从析法二智。至显中二智。凡十二种二智。待前皆名为粗。显中为妙。何以故。此妙不异后妙故。又从次第二智。凡九种二智待前为粗。不次第为妙。又前十八种二智皆粗。唯不次第三种为妙。又不次第二种为粗。一种为妙。又历五味教者。乳教具三种九种二智。酪教一种三种二智。生苏四种十二种二智。熟苏具三种九种二智。此经但二种三种二智。若酪教中权实皆粗。醍醐教中权实皆妙。余三味中权实有粗有妙。可以意推。若不作如上释诸智者。经论异说。意则难解。何者。华严解初住心云。三世诸佛不知初住智。世人释云。如实智佛自不知佛如实智。亦不知初住如实智。此释自谓于理为通。其实不允。若藏通等佛不论如实智。云何于自如实智不知耶。别教初住不得如实智。云何言不知。若得前来诸智意者。三世三藏佛不知圆教初住智。此则事理二释俱无滞也。此中义兼二种。一分别二十一种权实。二待粗论妙。如上说。若开粗显妙者。诸方便谛既融成妙谛。对谛立智悉非复粗。如贱人舍王若过者。舍则庄严。如众流入海同一碱味。开诸粗智即是妙智也。二智多有所关。须商略类通。今对七种二谛。明二十一种权实。以为章门。若得此意。约因缘境亦应如此。谓析因缘智。体因缘智。含中因缘智。显中因缘智。次第因缘智。带次第因缘智。不次第因缘智。一一各有化他自行化他自行等三种分别。合有二十一种。分别粗妙。判五味多少论待绝等。四谛三谛一谛等。亦应如是当自思之。何烦具记也。问随情谛及化他智。何意无量。随智谛及自行智。何意不多。答秖约一人未得道时。见心横起邪执无穷。何况多人种种各异。为是义故随情则多。智见于理理唯一种。不得有异(云云)。夫二谛差别已如上说

说此七权实二十一权实。颇用世人所执义不。颇同世人所说语不。颇用诸论所立义不。既不从世人。亦不从文疏。特是推大小乘经。作此释耳。若破若立皆是法华之意。若巧拙相形。以通经二智破三藏经二智。乃至次第不次第相形。以圆经二智破别经二智。方便诸经明智既粗。通经之论岂得为妙。经论既尔。弘经论人何劳击射。任其所说自有所堕。若作生灭解权实者。堕在初番。若作不生不灭解者。堕第二番。乃至第七番亦可知。又纵广引经论庄严己义者。亦不得出初番随情二谛化他权实。况出初番第二第三权实。尚不出初番三种权实。况第七番三种权实。若但以初番二智。破一切世间情执略尽。假令得入化城。秖是自行实智。尚不得化他之权。何况能得后番诸智。若寻二十一种二智。凡破几外见凡破几权经论。复显几是立几权经论。然后方称妙权妙实。世人全不识一两种权实之意。而情中即计为智。若是智者破何惑见何理。未见理未破惑生死浩然。非情何谓。今若待前诸粗智。而明妙智者。法华破待之意也。若其会者。一切权经论所明谛理。皆成妙理无非智地。会一切权经论所明二智。无非妙智悉是大车。如此破会深广。莫以中论相比。可熟思之(云云)。四对三谛明智者。上明五三谛竟。今更分别。夫三智照十法界。束十为三。谓有漏无漏。非有漏非无漏。三法相入分别有五。初谓非漏非无漏入无漏。对漏无漏为三法。二谓一切法入无漏。对漏无漏为三法。三谓漏无漏非漏非无漏为三法。四谓一切法趣非漏非无漏。对漏无漏为三法。五谓一切法趣漏趣无漏趣非漏非无漏。为三法。更说五境竟。对此五境明五三智者。谓一切智．道种智．一切种智。三智相入五种不同。一中智入空智对道智为三。次如来藏智入空智对道智为三。次中智对两为三智。次如来藏智入中智对两智为三智。次圆三智。是为五差。中智入空智分别为三智者。初依无漏发一切智。次依有漏发道种智。后深观无漏之空。知空亦空发一切种智。然初心不知空空。次虽得空亦不空空。后能深观于空空于前空但二空。名同二境亦合故言相入。今若分别以无漏空为一切智。有漏空为道种智。中道空为一切种智。世人采经论意云。六地断惑与罗汉齐。七地修方便道。八地道观双流。破无明成佛。即此意也。如来藏智入空智分别三智者。依漏无漏发一切智道种智。不异前而后不因别境。更修中智。但深观空能见不空。不空即如来藏。藏与空合故言相入。以深观空见不空故。发一切种智。前中道智但显别理。理之与智不具诸法。藏理藏智具一切法。故异于前。以藏智对两智为三智也。大经云。声闻之人但见于空不见不空。智者见空及与不空。大品云。一切智是声闻智。道种智是菩萨智。一切种智是佛智。即此意也。中智对两成三智者。各缘一境各发一智。次第深浅不相滥入。故地持云。种性菩萨。发心欲除二障。有佛无佛决定能次第断诸烦恼。即此意也。如来藏智入中智为三智者。两智不异前。一切种智小异何者。前明中境直中理而已。欲显此理应修万行。显理之智故名一切种智耳。今如来藏理含一切法。非直显理之智。名一切种智。与前为异用此智对前为三智也。故地论师云。缘修显真修。真修发时不须缘修。前两智即是缘修。后智发时即是真修。真修具一切法不须余也。即是此义(云云)。圆三智者。有漏即是因缘生法。即空即假即中。无漏亦即假即中。非漏非无漏亦即空即假。一法即三法。三法即一法。一智即三智。三智即一智。智即是境境即是智。融通无碍。如此三智岂同于前。释论云。三智一心中得。无前无后。为向人说令易解故。作三智名说耳。即是此意(云云)。若欲显智要须观成。泛论观智俱通因果。别则观因智果。例如佛性通于因果。别则因名佛性。果名涅槃。今就别义以观为因。成于智果。如璎珞云。从假入空名二谛观。从空入假名平等观。二观为方便道。得入中道第一义谛观。今用从假入空观为因。得成于果。名一切智。用从空入假观为因。得成道种智果。用中观为因。得成一切种智果也。上明于智略有五种。今以观成亦应五种。细作可知。修观义如止观(云云)。言粗妙者。藏通两佛虽有一切种智之名。更无别理不破别惑。此智不成故不用也。中入空智者。虽说中道因于通门而成两智。后照中道无广大用。因于拙教果又不融。是故为粗。次如来藏入空智者。教果理虽融。因是通门亦名为粗。中对二智者。虽不因通而三智别异。果教未融是故为粗。如来藏入中者。在果虽融因是别门。此因亦粗。圆三智者。因圆果圆。因妙果妙。谛妙智妙。正直舍方便。但说无上道。是故为妙智也。若历五味教者。乳教有三种三智。酪教一种三智。生苏具五种三智。熟苏亦具五种三智。粗妙可知。法华但一种三智。此是法华破意即相待妙也。开粗明妙者。世智无道法。尚以邪相入正相。治生产业皆与实相不相违背。低头举手开粗显妙。悉成佛道。何况三乘出世之智。故大经云。声闻缘觉亦实亦虚。断烦恼故名之为实。非常住故名之为虚。凡夫未断烦恼无实唯虚。尚开粗入妙即是大乘。何况二乘之智。二乘之智根败心死。尚得还生。何况道种之智。如此开时一切都妙。无非实相。七宝大车其数无量。此是法华会意。即绝待妙也。五对一谛明智者。即是如实智也。释论云。诸水入海同一碱味。诸智入如实智。失本名字。故知如实智总摄一切智。纯照一境故。总众水俱成一碱也。若待十智为粗。如实智为妙。若待诸实智。诸实智名粗。中道如实智名妙。若开粗显妙者。非但诸实智为妙。十智亦名妙(云云)。无谛无说者。既言无谛亦复无智。若历诸处明无谛者。余方便无谛无智为粗。中道无谛无智为妙。若以杜口绝言无谛无智者。亦无粗无妙。无待无绝。历一切法皆无粗无妙也。二展转相照者。六番之智传照前诸境。思议因缘下智中智。照六道十如性相等。下中二智观十二因缘灭者。照二乘十如性相等。上智照菩萨性相本末等。上上智照佛法界性相本末等。四种四谛智照十法界者。生灭无生等苦集智。照六道十如相性。生灭无生道灭智。即是照二乘十如相性。无量无作苦集智。照菩萨界性相等。无量无作道灭智。照佛法界相性本末等。四种四谛智照四十二因缘者。生灭无生苦集智。照思议两十二因缘也。生灭无生灭两道灭智。是照两思议十二因缘灭也。无量无作两苦集智。照不思议两十二因缘也。无量无作道灭智。照不思议两十二因缘灭也。七种二智照十法界者。生灭无生灭两权智。及入通等二合四权智。照六道性相。生灭无生灭两实智。照二乘性相等。别权圆入别权有边。是照六道性相。无边是照二乘性相。圆权则通照九界性相。别入通实空边。是二乘性相。不空边是菩萨性相。圆入通实空边。是二乘性相。不空边是照佛界相性。别实是照菩萨性相。圆入别实圆实俱照佛法界相性也。七种二智照四种因缘者。前四权是照思议两十二缘。别权圆入别权有边。是照两思议十二缘。无边是照两十二缘灭。圆权则通(云云)。别入通实空边。是照思议十二缘灭。不空边是照不思议十二缘。圆入通实空边同上不空边是照不思议十二缘灭。别实照不思议两十二缘灭。圆实照两不思议十二缘灭等。前四种权智。是照生灭无生灭两苦集。又三权智照无量无作苦集。二实智是照思议两道灭。又五实智是照不思议两道灭。五种三智照十法界者。五种道种智。照六道性相本末等。五种一切智。照二乘菩萨性相本末等。五种一切种智。照佛法界十如相性等。又五种三智照四种十二因缘者。五种有智。照思议两十二缘。五种一切智。照两思议十二缘灭。又是照不思议十二缘。五一切种智。是照两不思议十二缘灭。五种三智。照四种四谛者。五道种智。照生灭无生两苦集五种一切智。照生灭无生两道灭。亦是照无量无作两苦集。五种一切种智。是照无量无作两道灭。五种三智照七种二谛者。五道种智。是照四种俗谛。五种一切智。是照两种真谛。亦是照别圆入别圆三种俗谛。五种一切种智。是照五种真谛。一如实智。是照佛界十如性相。又是照不思议十二因缘。又是照无作四谛。又是照五种真谛。又是照五种中道第一义谛。无谛无说与十相性如合。与不思议十二缘灭合。与四种不生不生合。与真谛无言说合。与中道非生死非涅槃合。如此等诸智传传照谛。谛若融智即融。智谛融名之为妙。如此等皆是方便说言称妙不妙。见理之时无复权实非权非实。亦无妙与不妙。是故称妙也。七种二谛五种三谛。更相间入。余诸境亦有此意。七种二智五种三智。既相间入者。余诸智亦有此意。例自可作(云云)

○第三行妙者为二。一通途增数行。二约教增数行。夫行名进趣非智不前。智解导行非境不正。智目行足到清凉池。而解是行本行能成智。故行满而智圆。智能显理理穷则智息。如此相须者则非妙行。妙行者。一行一切行。如经本从无数佛具足行诸道。又云。无量诸佛所。而行深妙道。又云。尽行诸佛所有道法。既具复深又尽具。即是广深即是高尽即究竟。此之妙行与前境智。一而论三三而论一。前境说如法相。法相亦具三名秘密藏。前智是如法相解。解亦具三。如面上三目。今行是所行。如所说行亦具三。名伊字三点。若三若一。皆无缺减故称妙行耳。前对境明智。今亦应对智明行。若直对一种智增数明行。则行若尘沙说不可尽。况对诸智各导众行。则浩若虚空得意亡言。不复可说。释论云。菩萨行般若时。以一法为行摄一切行。或无量一法为行摄一切行。或二法为行摄一切行。或无量二法为行摄一切行。乃至十法百法千万亿法为行摄一切行。或无量十法百千万亿法为行摄一切行。行虽众多以智为本。智如导主行若商人。智如利针行如长线。智御行牛车则安隐。能有所至。用此增数诸行。为前十如谛智所导。乃至一实谛智所导。若得此意。以正智导众行入正境中。此义唯可悬知不可载记(云云)。二约教增数者。若三藏增数明行。如阿含中。佛告比丘当修一行。我证汝等四沙门果。谓心不放逸。若能护心不放逸。行广演广布。则所作已办能得涅槃。又告比丘当修一行。谓他物莫取。比丘白佛我已知已。佛言汝云何知。比丘白佛。他物谓色声香味触法。佛言善哉。若能不取此六。即所作已办能得涅槃。所言广演广布者。以不放逸心历一切法。谓三界六尘皆不放逸。得至涅槃。增二数明行者。阿含云。阿练若比丘。当修二法为行。谓修止修观。若修止时即能休息诸恶。戒律威仪诸行禁戒悉皆不失成诸功德。若修观时即能观苦。如实知之。观苦集苦尽苦出要。如实知之。得尽漏不受后有。怛萨阿竭亦如是修。增三数明行者。谓戒定慧。此三是出世梯蹬佛法轨仪。戒经云。诸恶莫作诸善奉行。自净其意是诸佛教。诸恶即七支。过罪轻重非违。五部律广明其相。如是等恶戒所防止。诸善者善三业若散若静。前后方便支林功德。悉是清升故称为善。自净其意者。即是破诸邪倒。了知世间出世间因果正助法门。能消除心垢净诸瑕秽。岂过于慧。佛法旷海此三摄尽。若得此意。四五六七乃至百千万亿法为行。摄一切行亦如是。是名下智导行也。通教增数行者。不定部帙判通教。但取三乘共学法门。指此为通耳。今且引释论增数。以示其相。论云。菩萨行般若时。虽知诸法一相。亦能知一切法种种相。虽知诸法种种相。亦能知一切法一相。云何观一切法一相。所谓观一切法无相。如四大各各不相离。地中有水火风。但地多以地为名。水火风亦如是。今观无此异相。若火中有三大。三大应并热。若三大在火中。二大遂不热则不名火。若三大并热则三大舍自性。皆名为火。无复三大。若言有三大而细不可知。此与无何异。若粗可得则知有细。若无粗细亦无。如是则火中诸相不可得。一切法相亦不可得。是故一切法皆一相。此以一相破异相。复以无相破一相。无相亦自灭。如前火木然诸薪已亦复自烧。是为观一切法一相一相无相。如是无量一切法悉皆一相。一相无相。或二法为行摄一切行。乃至百法千万亿法为行。摄一切行。可以意推不复繁记。别教增数行者。如善财入法界中说。于一善知识所。各闻一法为行。或如幻三昧。或投岩赴火。算砂相黡。发菩提心等。种种一行皆云佛法如海。我唯知此一法门余非所知。乃至一百一十善知识。一一法门皆如是。是一一行皆破无明入深境界。若二法三法百千万亿等法。亦应如是(云云)。圆教增数行者。如文殊问经明菩萨修一行三昧。当于静室结跏趺坐。系缘法界一念法界。一切无明颠倒。永寂如空。此之一行即是一切无碍。人一道出生死。一切诸法中皆以等观入。解慧心寂然三界无伦匹。此乃一行摄一切行。增二法为行摄一切行。所谓止观。增三法为行摄一切行。谓闻思修。戒定慧。增四法为行摄一切行。谓四念处。增五法为行摄一切行。谓五门禅。增六法为行摄一切行。谓六波罗蜜。增七法为行摄一切行。谓七善法。增八法为行摄一切行。谓八正道。增九法为行摄一切行。谓九种大禅。增十数为行摄一切行。谓十境界。或十观成乘等。增百数千万亿数阿僧祇不可说法门为行。岂可具载。若得其意例可解。然增数明行为行不同。须判粗妙。若三藏增数诸行。以生灭智导。但期出苦止息化城。是故为粗。通教增数诸行。体智虽巧但导出苦。灰断是同。别教增数诸行智导则远。自浅阶深而诸行隔别。事理不融。是故为粗。圆教增数诸行。行融智圆。是故为妙。今经属圆增数。如观经云。于三七日一心精进。此就一法论行妙。若行若坐思惟此经。此就二法论行妙。若闻是经思惟修习善行菩萨道。此就三法论行妙。四安乐行此就四法论行妙。五品弟子此就五法论行妙。六根清净此就六法论行妙。如是等待粗论妙也。开粗论妙者。低头举手积土弄砂。皆成佛道。虽说种种法其实为一乘。诸行皆妙无粗可待。待即绝矣。复次约五数明行妙者。又为二。先明别五行。次明圆五行。别者。如涅槃云。五种之行。谓圣行梵行天行婴儿行病行。圣行有三戒定慧。如经菩萨若闻大涅槃。闻已生信作是思惟。诸佛世尊有无上道。有大正法大众正行。从此立行。若闻大涅槃即是信果。亦是信灭。有无上道已去。是信显果之行。无上道是信慧。有大正法是信定。大众正行是信戒。是名信因信道。自伤己身及诸众生。破戒造罪。失人天乐及涅槃乐。即是知集。往来生死受恶道报。即是知苦。苦集与戒定慧相违即无道。无道故不得涅槃则无灭。菩萨欲拔苦集而起大悲。兴两誓愿。欲与道灭而起大慈。兴两誓愿。发誓愿已。次则修行思惟在家逼迫犹如牢狱。不得尽寿净修梵行。出家闲旷犹若虚空。即弃家舍欲。白四羯磨持性重戒。息世讥嫌等无差别。不为爱见罗刹毁戒浮囊。如止观中说。因是持戒具足根本业清净戒。前后眷属余清净戒。非诸恶觉觉清净戒。护持正念念清净戒。回向具足无上道戒。根本者。十善性。戒众戒根本。为无漏心持故言清净。前后眷属余清净戒者。偷兰遮等是前眷属。十三等是后眷属。余者非律藏所出。絓诸经所制者。如方等二十四戒之流。名为余戒也。此两支属律仪作法受得之戒也。后三支非作法是得法。得法时乃发斯戒也。非诸恶觉觉清净戒者。即定共也。尸罗不清净三昧不现前。以戒净故事障除发得未来。性障除发得根本。灭恶觉观。名定共戒也。护持正念念清净戒者。即四念处。观理正念虽未发真。由相似念能发真道。成道共戒。故名正念念清净戒。复次定共戒依定心发。属止善义。道共戒依分别心发。属行善义。动不动俱是毗尼。何者戒论防止得定共心。不复起恶。得道共发真。永无过罪故俱是戒也。回向具足无上道戒者。即是菩萨于诸戒中。具四弘六度。发愿要心回向菩提。故名大乘戒。弘誓如前说。六度者。厌恶出家舍于所爱即是檀。纤毫不犯拒逆罗刹即是尸。能检节身心安忍打骂名生忍。耐八风寒热贪恚等名法忍。爱见不能损即是羼提。守护于戒犯心不起。即是精进。决志持戒不为狐疑所诳。专心不动名为禅。明识因果。知戒是正顺解脱之本。出生一切三乘圣人。非六十二见鸡狗等戒。名为般若。又别发愿要制己心。宁以此身卧于热铁。不以破戒受他床席。十二誓愿自制其心。又更发愿。愿一切众生得护持禁戒。得清净戒。善戒。不缺戒。不析戒。大乘戒。不退戒。随顺戒。毕竟戒。具足诸波罗蜜戒。以此十愿防护众生。菩萨一持戒心。若干愿行以庄严戒。诸余行心亦应如是。然护他十戒从自行五支中出。从根本眷属两支出禁戒清净戒善戒。何者。篇聚作法即是禁戒。禁戒若发无作乃名清净。清净即止善。而言善戒即是行善也。从非恶觉觉清净戒。开出不缺戒。何者。虽防护七支妄念数起。致有缺漏。若发未来禅事行不缺。得根本禅性行不缺。从护持正念念清净戒。开出不析戒。即道共戒也。灭色入空是析法。道共今体法入空。故名不析。又内有道共则戒品牢固。不可破析也。从回向具足无上道戒。开出大乘不退随顺毕竟具足波罗蜜戒。言大乘者。菩萨持性重讥嫌。等无差别。自求佛道性重则急。为化众生讥嫌则急。小乘自调性重则急。不度他故讥嫌则宽。菩萨具持两种。故名大乘戒。不退者。行于非道善巧方便。淫舍酒家非法之处。辄以度人。而于禁戒无有退失。如医疗病不为病所污。故名不退。随顺者。随物机宜随顺道理。故名随顺戒。毕竟者。竖究竟无上之法也。具足波罗蜜者。横一切圆满无法不备也。大论亦明十种戒。不破不缺不穿不杂四种。即是大经根本支中禁戒。清净戒。善戒。不缺戒。论随道戒。即是大经护持正念支中不析戒也。论无著戒。即是大经回向支中不退戒。论智所赞戒。即是大经大乘戒论自在戒。即是大经自在戒。论随定戒。即是大经随顺戒。论具足戒。即是大经波罗蜜戒。大经明毕竟论言随定。此大同小异于义无失。涅槃欲辨菩萨次第圣行。故具列诸戒浅深始终具足善能护持。即入初不动地。不动不退不堕不散。是名戒圣行。戒圣行既从始浅以至于深。今仍判其粗妙。禁净善三戒属律仪。律仪通摄众故。定尊卑位次绪虽有菩萨佛等。不别立众故戒法是同。但以佛菩提心为异耳。故知律仪等三戒三藏摄。不缺是定共。根本禅是事。亦属三藏摄。是故为粗。不析戒是体法。道共即通教摄。大乘不退等别教摄。亦兼于通。通有出假随机顺理于道不退。然依真谛不及别人。别人为妙也。随顺毕竟具足等圆教摄。不起灭定现诸威仪。不舍道法现凡夫事。故名随顺。唯佛一人具净戒。余人皆名污戒者。故名毕竟戒。戒是法界具一切佛法众生法。到尸彼岸。故名具足波罗蜜戒。净名云。其能如是是名奉律。是名善解。此经云。我等长夜持佛净戒。法王法中久修梵行。始于今日得其果报。又罗睺罗密行。唯我能知之。岂非待前诸戒皆粗。唯圆为妙也。复次持初戒如乳。中间如三味。后戒如醍醐。醍醐为妙(云云)。开粗显妙者。他云。梵网是菩萨戒。今问。是何等菩萨戒。彼若答言。是藏通等菩萨戒者。应别有菩萨众。众既不别戒何得异。又若别明菩萨戒。何等别是缘觉戒。今明三藏三乘无别众。不得别有菩萨缘觉之戒也。若作别圆菩萨解者可然。何者。三乘共众外别有菩萨故别有戒。问三乘众外。别有菩萨戒者。缘觉戒云何。答三乘众外无别缘觉。此说犹是待粗之戒耳。开粗者。毗尼学者。即大乘学式叉。式叉即是大乘第一义。光非青非黄非赤白。三归五戒十善二百五十。皆是摩诃衍。岂有粗戒隔于妙戒。戒既即妙人亦复然。汝实我子即此义也。是名绝待妙戒

玄义卷三下终妙法莲华经玄义卷第四上

        天台智者大师说

定圣行者略为三。一世间禅。二出世禅。三上上禅。世禅复二。一根本味禅隐没有垢无记。二根本净禅不隐没无垢有记。根本者。世出世法之根本也。大品云。诸佛成道转法轮入涅槃。悉在禅中。若能深观根本。出生胜妙上定。故称根本也。隐没者。闇证无观慧也。有垢者。地地生爱味也。无记者。境界不分明也。此有三品。谓禅也等也空也。即十二门禅也。初修方便。当善简风喘明识正息。安徐记数莫令增减。若数微细善解转缘调停得所。当证前方便法。或粗细住。皆有持身法起。进得欲界定或未到定。八触发动。五支成就是发初禅。大论云。已得离淫火则获清凉定。如人大热闷入冷池则乐(云云)。若欲进上离下者。凡夫依六行观。佛弟子多修八圣种行者。于初禅觉观支中。厌离觉观。以初禅为苦粗障。二法动乱定心故苦。从二法生喜乐故粗。二法翳上定故障。二禅异此名胜妙出。总而言之。一知过不受着。二诃责。三析破得离初禅。是修二禅相。善巧攀厌则内外皎然。与喜俱发四支成就故。论云。是故除觉观得入一识处。内心清净故定生得喜乐(云云)。二禅中既离觉观。不得作方便。出定时修习厌下进上。亦有六行。如弃初禅方法(云云)。尔时泯然不依内外。与乐俱发五支成就。故论云由爱故有苦。失喜则生忧。离苦乐身安。舍念及方便(云云)。欲厌下进上亦有六行如前(云云)。善修故心豁开明。出入息断。与舍俱发空明寂静四支成就。若能知乐患见不动大安。忧喜先已除。苦乐今亦断(云云)。行人既内证四禅。欲外修福德。应学四等。此有通修别修。通修者。大论云。是慈在色界四禅中间得修。此语则通。别修者。初禅有觉观分别。修悲则易。喜支修喜易。乐支修慈易。一心支修舍易。复次初禅修悲易。二禅修喜易。三禅修慈易。四禅修舍易。此则修四无量定之处所也。复次修时缘前人离苦得乐。欢喜平等之相而入定。发时内得喜乐平等之法。外见前人离苦得乐。或内得外不见。或外见内不得。分别邪正(云云)。行人欲出色笼。修四空定。灭色存心。心心相依故名四空。方便者。须诃色是苦本。饥渴寒热色为苦聚。赞空为净妙。离诸逼迫过一切色与空定相应。不苦不乐倍更增长。于深定中唯见虚空。无诸色相心无分散。复次得空定故出过色界。故名过一切色相。空法持心种种诸色不得起。故名灭有对相。已得空定。决定能舍色法不忆恋。故名不念种种色相(云云)。诃下攀上皆有方便。委在禅门(云云)。根本味禅竟。根本净禅不隐没无垢有记。与上相违。此又三品。谓六妙门。十六特胜。通明等也。涅槃是妙。此六能通故言六妙门。此三法为三根性。慧性多为说六妙门。此一一门。于欲界中即能发无漏。若定性多为说十六特胜。故下地不发无漏。上地禅满乃能得悟。定慧性等为说通明。通明观慧深细。从下至上皆能发无漏。此是随机之说。若作对治则复别途(云云)。若广明修习则摄一切诸禅。今但次第相生一辙竖意。修此六门修证合论则有十二法。佛言游止三四。出生十二。即此修数证数。乃至修净证净。修数者。行人初调和气息不涩不滑。安详徐数从一至十。摄心在数不令驰散。是名修数。与数相应者。觉心任运从一至十。不加功力心自住数。息微心细是名证数。若患数粗当放数修随。乃至净亦各如是。然观有三义。一慧观观真。二得解观即假想观。三实观此中初用实观。后用慧观。修实观者。于定心中以心眼谛观此身。细微入出息相如空中风。皮肉筋骨三十六物。如芭蕉不实。内外不净甚可厌恶。复观定中喜乐等受。悉有破坏之相。是苦非乐。又观定中心识无常。刹那不住无可着处。复观定中善恶等法。悉属因缘皆无自性。如是观时能破四倒。不得人我定何所依。是名修观如是修时。觉息出入遍诸毛孔。心眼开明。彻见身内三十六物。及诸虫户。内外不净众苦逼迫刹那变易。一切诸法悉见无自性。心生悲喜无所依倚。得四念处破四颠倒。是名与观相应。不能具记(云云)。佛坐树下内思安般。一数二随等。正是此禅。十六特胜者。释名(云云)。此从因缘得名。修相者。知息入知息出者。此代数息调息。绵细一心随息入时。知从鼻至脐。出时知从脐至鼻。随照不乱。知风喘气。为粗知息为细。入粗即调令细。如守门人。知入知出。恶遮好进涩滑轻重。冷暖久近难易皆知。知息为命所依。一息不还即便命尽。觉息与命危脆无常。不生爱慢。知息非我即不生见。若知息长短对欲界定。知息遍身对未到地。除诸身行对初禅觉观支。受喜对喜支。受乐对乐支。受诸心行对一心支。心作喜即喜俱禅。心作摄即二禅一心支。心作解脱即三禅乐。观无常即四禅不动观出散即空处。观离欲即识处。观灭即对无所有处。观弃舍对非想非非想处。观弃舍时。即便获得三乘涅槃。若横论观慧。即对四念处(云云)。通明禅者。行者观息色心三事无分别。谛观出入息。入无积聚出无分散。来无所经去无履涉。如空中风性无所有。息本依身身本不有。先世妄想招今四大。围于虚空假名为身。头等六分三十六物。四微一一非身。观身由心心由缘起。生灭迅速。不见住处相貌。但有名字。名字亦空。如是观息色心。不得三性别异。既不得三事。即不得一切法。此是修相。证者。内证真谛空如观解次第通达此身色息分明。亦知世间天文地理与身相应。能具三界禅定。能知非想有细烦恼。破惑发真得三乘涅槃。悉在禅门。世间禅竟。二明出世间禅者。即有四种。谓观练熏修。观者。谓九想。八背舍。八胜处。十一切处通称观禅。行人为破淫火。必须增想纯熟。随所观时与定相应。想定持心心无分散。能除世间贪爱。破六种欲。有人着赤白黄黑等色。或着相貌端严。或着威仪姿态。或着语言娇媚。或着细滑肌体。或着可意之人。此六欲渊沉没行者。能修九想除此六贼。死想破威仪言语两欲。胀想坏想啖想。破形貌欲。血涂想青瘀想脓烂想。破色欲。骨想烧想。破细滑欲。九想通除所著人欲。又啖想散想除着意人。此九既除于欲。亦薄嗔痴。九十八使山动。虽是不净初门能成大事。如海中尸依之得度(云云)。八背舍名(云云)。背净洁五欲舍离着心。故名背舍。修者行人。持戒清净发大誓愿。欲成大事。端身正心谛观足大指。想如大豆黑胀趼起。此想成时。更进如狸豆大。更如一指大。更如鸡卵大。次二指三四五指。次观跌底踵踝[跳-兆+尃]膝髀臗。悉见膖胀。次观右脚亦如是。复当想大小便道。腰脊腹背胸胁。悉见肿胀。又观右胛臂肘腕掌五指。又头颔等。从足至头从头至足。循身观察唯见肿胀。心生厌恶。复当观坏脓烂。大小便道虫脓流出。臭剧死狗。己身既尔。观所爱人亦复如是。内破见我外破贪爱。久住观察除世贪爱。次除却皮肉谛观白骨。见骨色相异。谓青黄白鸽。如是骨相亦复无我。得此观时名欲界定。次观骨青时。见此大地东西南北。悉皆青相。黄白鸽色亦复如是。此是未到之相。又观骨人眉间出光。光中见佛。是初背舍成相。如是次第。乃至八背舍发相。具如禅门(云云)。八胜处者。初两胜处位在初禅。三四两胜处位在二禅。后四胜处位在四禅。三禅乐多心钝。故不立也。前背舍缘中多少不得自在。是故胜处更深细观察少多好丑悉使胜知胜见。如快马能破阵。亦能自制其马(云云)。十一切处者。以八色两心更相淡入。广普遍满转变无碍。具如禅门(云云)。练禅者。即九次第定也。上来虽得八禅。入则有间。今欲纯熟。令从初浅极至后深。次第而入。中间无有垢滓间秽。令不次第者次第。故名次第。亦是无漏练于有漏。除诸间穬故名练禅。亦是均调诸禅。令定慧齐平无间也。阿毗昙明熏练。但言以无漏熏四禅今以无漏通练八地。即是次第入无间三昧也。熏禅者。即师子奋迅三昧也。前是次第无间入。今亦是次第无间入。亦能次第无间出。除粗间及法爱味尘。犹如师子能却能进奋诸尘土。行者入出此法。能遍熏诸禅。悉令通利转变自在。如熏皮熟随意作物。修禅者。超越三昧也。近远超入近远超出。近远超住。是禅功德最深故名顶禅。于诸法门自在出入(云云)。又九次第定。善入八背舍。奋迅善出八背舍。超越善住八背舍。善入出住百千三昧。即此意也。譬如画师五彩相淡。出无量色。如世间果。但以四大出一切五阴。定法亦尔。但以观练熏修。出生一切神通变化。无种不备。大经云。菩萨住禅得堪忍地。地能持能生一一禅中。皆有慈悲誓愿道品六度诸行无不具足。何者。若于戒定中。明观慧即共念处。单论观是性念处。通取戒定等境智文字等是缘念处。又不净观破净颠倒。是身念处。观诸禅中心受苦乐。三世内外受不可得。破乐颠倒。是受念处。观诸禅心以有心故造作善恶。无心则无作者。破我颠倒。是法念处。观心生灭前后际断。破常颠倒。是心念处。复次八背舍观四念处。九次第定练四念处。奋迅熏四念处。超越修四念处。二乘为自灭度修此五禅。成四枯念处。不名堪忍地。菩萨为化众生深观念处。慈悲誓愿荷负众生。成四荣念处。是摩诃衍名堪忍地也。问无色无身云何具四念处。答毗昙云。无色有道共戒。戒是无作色。以无漏缘通故。此戒色随无漏至无色也。成论人云。色是无教法不至无色。舍利弗毗昙云。无色有色。当知。小乘明义即有两意。大经云。无色界色。非诸声闻所知。若尔四念处通无色。亦复何妨。问诸禅中但得明念处。尚无正勤云何具道品。答约位为言。念处无后品修行为义。念处具道品也。大论云。初修善有漏五阴于有为法中得正忆念。即念处智慧也。四种精进即是正勤。定心中修名如意足。五善根生名为根。根增长名为力。分别道用名为七觉。安稳道中行名八正道。初善有漏中已能具此。何须见道方有八正。若念处既具三十七品者。暖顶等例然。观禅既尔。练熏修等亦然。然菩萨于一一禅中。随所入法门。慈悲众生如父母得食不忘其子愍伤痴闇。不从内自求乐从他外求。耽荒五欲求苦得怖失忧。诸欲无乐为此起悲。夫欲患如是何能去之。得禅定乐则不为所欺。是故起慈有四弘誓也。又诸禅中修六度者。众生缚着世间。生活业务不能暂舍。菩萨弃之一心入禅。是名檀。若不持戒禅定不发。又入禅时杂念不起。任运无恶是尸。拘检身口捍劳忍苦。制外尘不着。抑内入不起。是为忍。初中后夜系念相续。行住坐卧心常在定。间念不生是名精进。一心在定不乱不味名为定。若一心在定。能知世间生灭法相。深识邪伪名般若。一切众行皆于禅中具足。一一禅中能生诸功德。慈悲荷负。是故得名堪忍之地。三出世间上上禅者。即九种大禅。如地持所释。今不具论。自性禅者。即是观心实性名为上定。一切诸法颇有不由心者。心摄一切如如意珠。此九大禅皆是法界。一切趣禅造境即真。一色一香无非中道。二乘尚不知其名。况证其定。前根本旧禅如乳。练禅如酪。熏禅如生苏。修禅如熟苏。九大禅如醍醐。醍醐为妙也。复次根本禅。爱味心中修即成乳。自度心中修即成酪。慈悲心中修即成生苏。慈悲次第心中修即成熟苏。实相心中修即成醍醐。余四味亦如是。若不以实相心修。皆名为粗。若开粗显妙者。阿那波那即是摩诃衍。法界实相摄持诸法。离此之外更无别妙。故知诸佛成道转法轮入涅槃。皆在四禅。四禅中见实相。名禅波罗蜜。何况余定耶。此即绝待妙义。定圣行竟。慧圣行者。谓四种四谛慧(云云)。生灭四谛慧者。还观九想背舍依正两报。膖胀烂坏不净之色是逼迫相。现相三苦相。是苦谛慧以不起迷着依正。作恩爱奴运动身口。起三品十恶业。感三途等生。生长相转相二十五有相。又知世间因果不净过患。深愧厌耻终不杀他活己。夺彼闰身。耽湎不净隐曲求直。离合怨亲间构荣辱。内谄外佞引纳无度。纵毒伤道邪僻失真。不为不净作十恶业。惭愧羞鄙行三品十善。感三善道生。亦是生长相转相二十五有相。是名集谛慧。观依正不净破净颠倒。观诸受即三苦破乐颠倒。观诸行和合破我颠倒。观诸心生灭破常颠倒。别相总相善巧正勤。如意根力觉道向涅槃门。慈悲誓愿六度诸行等。即大乘相。亦是戒定慧相。亦是能除相。是名道谛慧。倒不起则业不起。业不起即因不起。因不起故果不起。是名寂灭相。亦二十五有灭相。亦名除相。是为生灭四谛慧。无生四谛慧者。观不净色色性自空。非色灭空。如镜中像无有真实。洞达五受阴空无所有。解苦无苦而有真谛。是苦谛慧。知集由心心如幻化。所起之集亦如幻化。一切爱见与虚空等。是名集谛慧。道本治集所治既如幻化。能治亦如幻化。是名道谛慧。法若有生亦可有灭。法本不生今则不灭。若有一法过涅槃者。我亦说如幻化。是名灭谛慧。虽知五阴众生如虚空。而誓度如空之众生。虽知集无所有。而断诸妄想。如与空共斗。虽知道不二相。而勤于空中种树虽无众生得灭度者。而灭度无量众生。约此即事而真。论道品六度等(云云)。是名无生四谛慧。无量四谛慧者。大经云。佛说四谛若摄法尽。则不应言所不说者。如十方土。摄法不尽应有五谛。佛言四谛摄尽。无第五谛。但苦有无量相。集灭道等皆有无量相。我于彼经竟不说之。若是空者空尚无空。云何无量。当知出假分别之慧也。此慧遍知十法界假实差别。名苦谛慧。遍知五住烦恼不同。名集谛慧。遍解半满正助等行。名道谛慧。解半满十六门诸灭门不同。是灭谛慧。二乘但服四谛药。治见思病自出生死。于分别则闲。菩萨作大医王。须解诊种种脉识种种病。精种种药得种种差。约此起种种慈悲。行种种行诸度道品。成种种众生。净种种佛土。广说如止观(云云)。是名无量四谛慧。无作四谛慧者。解惑因缘而成四也。大经云。宝珠在体谓呼失去。忧愁啼哭但见其体及疮。不见宝珠及镜。唯有忧悲无复欢喜。此迷道灭而起苦集。若解疮体即是宝珠。则喜不哭。因灭无明。即得炽然三菩提灯。此解悟因缘即是道灭。道灭即苦集。苦集即道灭。若尔则四非四。四既非四无量亦非无量。无量既非无量则假非假。假非假故则空非空。何但即空非空。亦即假非假。双亡正入。即寂照双流。大品云。一切种智即寂灭相。种种行类相貌皆知。名一切种智。寂灭相即是双遮双亡行类相貌皆知。即是双流双照。无心亡照任运寂知。故名不可思议。即无作四谛慧。大经云。无苦无谛有实。无集道灭无谛有实。实即中道如来虚空佛性。如此观时。无缘慈悲拔二边苦。与中道乐。修色非净非不净。即空即假即中。非枯非荣中间论灭。一切道品无不具足。遍舍十法界依正名檀。中道道共到尸彼岸名戒。住寂灭忍二边不动名忍。二边不间名牢强精进。入王三昧住首楞严名禅。实相般若名智慧。无谋巧用名方便。八自在我名力。无记化化禅名愿。三智一心中得名智。一波罗蜜具十。亦具一切佛法。一行无量行。无量行一行。是如来行。是名无作四谛慧。修此慧时。即得住于无所畏地。即初欢喜地。离五怖畏。谓不活畏。恶名畏。死畏。恶道畏。大众威德畏。大经云。不畏贪欲恚痴。此内无三毒外离八风。则无恶名畏。若言不畏地狱等。即无恶道畏。若言不畏沙门婆罗门。即无大众畏。见中道则无二死畏。实相智慧常命立。无不活畏。得入此地具二十五三昧。破二十五有。显二十五有我性。我性即实性。实性即佛性。开佛之知见发真中道。断无明惑显真应二身。缘感即应百佛世界。现十法界身。入三世佛智地。能自利利他。真实大庆名欢喜地也。此地具足四德。破二十五有烦恼名净。破二十五有业名我。不受二十五有报名乐。无二十五有生死名常。常乐我净。名为佛性显。即此意也地持说离五怖畏者。修无我智我想不生。云何当有我爱众具爱。是离不活畏。不于他人有所求欲。常饶益一切众生。是离恶名畏。于我见我想心不生。是离死畏。此身命终。于未来世必与佛菩萨共会。是离恶道畏。观于世间无与等者。况复过上是离大众畏。十地经亦同。十地论解云。是中第一依身。第二依口。第三第四依身。第五依意。活者依身所用众具能资于生。名资生。生为活也。此就因中说果。菩萨无此畏。复次名字言说皆依口失护名。不为利养心不悕望他人恭敬故名无恶名。第五依意可解。三四依身。爱善道憎恶道。无爱憎身故无恶道畏。亦不爱憎身故无死畏。私谓。不畏贪欲等。无作集坏。不畏恶道。此名无作苦坏。不畏大众。此是无作道立无不活无死畏。此是见性得常。无作灭立。复次破二十五有。有能含果。有破故集谛坏。果破故苦谛坏。得二十五三昧者。道谛立。见二十五有我性。我性即佛性灭谛立。破二十五有则无烦恼是净德。破二十五有果故无苦是常德。得二十五三昧是乐。见二十五我性是我。四德宛然矣。今释二十五三昧名。依四悉檀意。一随时趣立。如人多子各立一名。使兄弟不滥。二十五三昧亦复如是。各举一名令世谛不乱。岂可定执也。二随其义便。各从所以而立一名也。三随事对当。各有主治从对得名也。四理实无名而依理立字。虽有四意多用对治。约理以立二十五三昧也。通释二十五。各为四意。一出诸有过患。二明本法功德。三结行成三昧。四慈悲破有一一皆尔。地狱有用无垢三昧破者。地狱是重垢报处。报因则是垢。谓恶业垢见思垢。尘沙垢无明垢(其一)。菩萨先见此过。为破诸垢。修前来所明根本戒。破恶业垢。修前来所明背舍等定。伏见思垢。修前来所明生灭无生灭慧。破见思垢。修前来所明无量慧。破尘沙垢。修前来所明无作慧。破无明垢(其二)。破见思垢故。真谛三昧成。破恶业垢尘沙垢故。俗谛三昧成。破无明垢故中道王三昧成(其三)。菩萨自破地狱诸垢时。句句皆有慈悲誓愿。冥熏法界。彼地狱有。若有机缘关于慈悲。以王三昧力。法性不动而能应之。如婆薮调达。示所宜身说所宜法。彼地狱中若有善机。以持戒中慈悲应之。令离苦得乐。有入空机。以生无生慧等慈悲应之。令得真谛。有入假之机。以无量慧慈悲应之。令得俗谛。有入中机。以无作慧慈悲应之。令得王三昧。先自无垢今令他无垢故。此三昧名无垢也(下去例如此。不复委记也)。畜生有。用不退三昧破者。畜生无惭愧退失善道。则是恶业故退见思故退。尘沙故退。无明故退。菩萨为破诸退。修前持戒破恶业退。修于禅定伏见思退。修生无生慧破见思退。修无量慧破尘沙退。修无作慧破无明退。见思破故得位不退。真谛三昧成。恶业尘沙破故得行不退。俗谛三昧成。无明破故得念不退。中道三昧成。本修诸行皆有慈悲誓愿。冥熏法界彼畜生中。若有机缘关于慈悲。以王三昧力。不动法性而往应之。宜示何身宜说何法。为龙为象鵽鸟大鹫。若有善机。以戒定慈悲应之。令出苦得乐。有入空机。以生无生慧慈悲应之。令出有得无。真谛三昧成。有入假机。以无量慧慈悲应之。令免空得假。俗谛三昧成。有入中机。以无作慧慈悲应之。令出边入中。王三昧成。菩萨自既不退令他不退。故名不退三昧也。饿鬼有。用心乐三昧破者。此有常奖饥渴恶业苦。见思烦恼苦。客尘闇障苦。无明根本苦。菩萨为破诸苦。修前持戒破恶业苦。修定伏见思苦。修生无生慧破见思苦。修无量慧破尘沙苦。修无作慧破无明苦。破见思苦。无为心乐三昧成。破恶业尘沙苦。多闻分别乐三昧成。破无明苦。常乐三昧成以本行慈悲冥熏法界彼饿鬼道。若有机缘与慈悲相关。王三昧力不动法性而往应之。示所宜身说所宜法。若有善机。以持戒慈悲应之。手出香乳施令饱满。有入空机。以生无生慈悲应之。令到无为岸。有入假机。以无量慈悲应之。令游戏于五道有入中机。以无作慈悲应之。令净于三毒根。成佛道无疑。菩萨自既得乐。又令他得乐。是故名为心乐三昧也。阿修罗有。用欢喜三昧者修罗多猜疑怖畏。则有恶业疑怖。见思疑怖。尘沙疑怖。无明疑怖。菩萨为破是诸疑怖。而修诸行。修持于戒破恶业疑怖。修诸禅定伏见思怖。修生无生慧破见思怖。修无量慧破尘沙怖。修无作慧破无明怖。见思破故空法喜三昧成。恶业尘沙破故。一切众生喜见三昧成。无明破故。喜王三昧成。以本诸行慈悲誓愿。冥熏法界彼修罗中。若有机缘关于慈悲。以王三昧力。不动法性而往应之。示所宜身说所宜法。有善机者。应以持戒身。慈悲令离恶业怖。有入空机应以生无生慈悲令离见思怖。有入假机。应以无量慈悲令离无知怖。有入中机。应以无作慈悲令离无明怖。自证三喜令他无复三怖。是故名欢喜三昧。此前悉用对治立名也。弗婆提有。用日光三昧破者日朝出于东。随便为名耳。日譬智光能照除迷惑。东天下人。有恶业闇。见思闇。尘沙闇。无明闇。菩萨为照此诸闇故。修前戒光破恶业闇。修禅定流光伏见思闇。修一切智光破见思闇。修道种智光破尘沙闇。修一切种智光破无明闇。破见思闇故。一切智日光三昧成。破尘沙闇故。道种智日光三昧成。无明闇破故。一切种智日光三昧成。以本行慈悲誓愿。冥熏法界彼弗婆提。若有机缘。关于慈悲王三昧力。不动法性而往应之。示身说法。若有事善机以持戒慈悲应之。令免恶业闇。有入空机。以生无生慈悲应之。令免见思闇。有入假机。以无量慈悲应之。令免无知闇。有入中机。以无作慈悲应之。令免无明闇。自既破闇亦令他破闇。故称日光三昧也。瞿耶尼有。用月光三昧破者。月夕初现于西。亦随便立名。月亦照闇例同日光(云云)。郁单越。用热焰三昧破者。北方是阴地冰结难销。自非热焰赫照终不融冶。北天下人。冰执无我难可化度。若非智火慧焰。无我所心终不得度。彼无我所乃是妄计。犹有自性人我法我真如我。菩萨为破诸我。修生灭无生灭慧。破性人我。修无量慧破法我。修无作慧破真如我。得人空成真谛智焰。得法空成俗谛智焰。得真如空成中道智焰。以本慈悲冥熏法界彼郁单越。若有机缘关于慈悲。以王三昧力。不动法性而往应之。示身说法。有善机。应以戒慈悲令免妄计无我。有入空机。应以生无生慈悲令免性我。有入假机。应以无量慈悲令免法我。有入中机。以无作慈悲应之令免真如我。自破妄我令他破妄我。故名热焰三昧也。阎浮提有。用如幻三昧破者南。天下果报杂杂寿命。等不定犹如幻化。此则从心幻出业。幻出见思幻出无知幻出无明。菩萨为破诸幻。从于持戒幻出无作。破结业幻。从于禅定幻出背舍。从生无生慧幻出无漏。从无量慧幻出有漏。从无作慧幻出非漏非无漏。见思幻破真谛幻成。无知幻破俗谛幻成。无明幻破中道幻成。故经言。如来是大幻师彼阎浮提。有诸机缘关于誓愿。以本慈悲随感应之。自破诸幻成他诸幻。是故名为如幻三昧。余如上说。四天王有用不动三昧破者。此天守护国土游行世界。则有果报。动见思尘沙无明等动。菩萨修诸行。破诸动成三昧誓愿熏机缘感。以本慈悲令他破四动。成三不动。是故名不动三昧。委悉如上说。三十三天有。用难伏三昧者。此是地居之顶。即是果报难伏。见思尘沙无明等难伏。菩萨修诸行出其上。破诸难伏自成三昧誓愿熏他。若有机缘。以本慈悲令他得证。是故三昧名为难伏。余如上说。焰摩天有。用悦意三昧破者。此天处空无刀杖战斗。以之为悦。此是果报中悦。而未有不动业悦。亦无无漏道种智中智等悦。菩萨为破诸不悦。而修诸行。自成三谛悦意三昧。誓熏法界。有机缘者。以本慈悲令他意悦。是故三昧名为悦意。余如上说。兜率陀天有。用青色三昧破者。真谛三藏云。此天果报乐青。宫殿服玩等一切皆青。菩萨为破诸青。修第一义非青黄赤白。而见青黄赤白。第一义非戒定慧。而戒定慧。以戒破果报青。以生无生慧破见思青。非真见真非假见假非中见中。亦复如是。三青障破自成三谛三青三昧乃至感应成他三昧。例上可解。黄色三昧破化乐天有。赤色三昧破他化自在天有。白色三昧破初禅有。皆是果报白等。例青色三昧。大意可解。白色三昧者。初禅离五欲为白。未离觉观故是黑。见思尘沙无明等黑。破此诸黑修诸行白。自成三昧。又成他三昧。如上说。种种三昧破梵王有者。梵王主领大千界。种类既多。即是果报种种。未见种种空。种种假种种中。破此种种修种种行。自成种种亦成他种种。如上说。二禅用双三昧者。二禅独有内净喜两支。余支与余禅共。此即果报双。而未见双空双假双中。例如上说。三禅用雷音三昧者。此禅乐最深。如冰鱼蛰虫。是果报着乐。又着空乐假乐中乐。为惊骇诸乐。修诸雷音之行。余如上说。四禅用注雨三昧者。四禅如大地具种种种子。若不得雨芽不得生。一切善根在四禅中。谓业种三谛种。修诸行雨自生三昧慈悲应机生他三昧(云云)。无想天有。用如虚空三昧者。外道非空妄计涅槃。谓果报非空。三谛皆非虚无修诸空净之行。自成成他(云云)。阿那含天。用照镜三昧。此圣无漏天。虽得净色但是报。净色未究尽色空如镜未极明。未知色假如镜未有影。未知色中如未达镜圆。余如上说。空处用无碍三昧者。此定得出色笼。即果报无碍。未是空假中等无碍。余如上说。识处用常三昧者。此定谓识相续不断为常。此乃定报。非三无为常化用常常乐常。例如上(云云)。不用处以乐三昧破者。此处如痴。痴故是苦乃至无明苦。例如上(云云)。非想非非想。用我三昧破者。顶天谓是涅槃果报。犹有细烦恼不自在乃至无明不自在。修行破之。得真我随俗我常乐我。例如上(云云)。此二十五皆称三昧者。调直定也。真谛以空无漏为调直。出假以称机为调直。中道遮二边为调直。故皆具三谛。则通称三昧。又称王者。空假调直未得为王。所以二乘入空菩萨出假。不名法王。中道调直故得称王。一一三昧皆有中道。悉称为王。大经云。是二十五三昧名诸三昧王。即其位高义若入是三昧。一切三昧悉入其中。即其体广义。应二十五有机即其用长也。无畏地中。具得二十五三昧种种力用。须弥入芥不伤树木。毛孔纳海不娆龟鱼。虽处地狱身心无苦。变通出没不动而远。即其妙义。盖乃慧圣行成。能有是力也。问三昧破有。乃是涅槃之文。何得释此。答第三云。破有法王出现于世。随众生欲而为说法。四意明文宛然具足。又涅槃明菩萨破有。此经明法王破有。弥显其义也。明圣行竟。二梵行者。梵者净也。无二边爱见证得名之为净。以此净法与拔众生。即是无缘慈悲喜舍也。菩萨以大涅槃心。修于圣行得无畏地。具二十五三昧无方大用。尔时慈悲是真梵行。非余梵天所修四无量心。亦非三藏通教。众生缘法缘等慈悲也。以今慈悲喜舍。熏修众行无不成办。大经云。若有人问。谁是一切诸善根本。当言慈是。慈既是行本故言梵行。若依圆语亦如大经慈即如来。慈即佛性。慈若不具佛十力四无所畏三十二相者。是声闻慈。若具足者是如来慈。是慈即是大法聚。是慈即是大涅槃。慈力弘深具一切福德庄严。故名梵行。三天行者。第一义天。天然之理。此语道前由理成行。此语道中由行理显。此语道后今约由理成行。故言天行。菩萨虽入初地。初地不应住。以有所得故。修上十地慧十重发真修慧。由理成行名为天行。天行即智慧庄严。上求佛道故。有圣行天行。下化众生故。有梵行病行婴儿行也。四婴儿行者。若福慧转增实相弥显。虽不作意利益众生。任运能有冥显两益。天行力有冥益。梵行力有显益。众生虽有小善之机。无菩萨开发不得生长。慈善根力如礠石吸铁。和光利行。能令众生得见菩萨。同其始学。渐修五戒十善人天果报杨叶之行。又示二百五十戒。观练熏修四谛十二因缘三十七品。同二乘婴儿行。又示同习六度三阿僧祇。百劫种相好柔伏烦恼。六度菩萨小善之行。又示同即色是空无生无灭。通教小善之行。又示同别教历别次第。相似中道小善之行。皆是慈心之力。俯同群小提引成就。从慈心与乐起婴儿行。大经云。能说大字。所谓婆和。此即六度小行。而求作佛故言大字。又云。不见昼夜亲疏等相。即同通教菩萨即色是空意也。又云。不能造作大小诸事。大事即五逆。小事即二乘心。此即同别教。别教非生死故无五逆。非涅槃故无小乘心又云。杨树黄叶即同人天五戒十善婴儿。又云。非道为道以能生道。微因缘故即同二乘婴儿也。慈善根力能出假化物。同小善方便引入佛慧。作圆教婴儿也。经云。不能起住来去语言。如经(云云)。又判粗妙。开粗显妙例可解(云云)。五病行者。此从无缘大悲起。若始生小善必有病行。今同生善边名婴儿行。同烦恼边名为病行。以众生病则大悲熏心。是故我病。或游戏地狱。或作畜生形。化身作饿鬼等。悉是同恶业病如调达等。又示有父母妻子。金锵马麦寒风索衣热病求乳。此示人天有结业。生老病死之病。又示道场三十四心断结。示同二乘见思之病。方便附近语令勤作。三藏通教菩萨亦如是。又同别教寂灭道场。初断尘沙无明之病。是故菩萨悉同彼病。遍于法界利益众生。次第五行竟。问圣行证三地。梵行证两地。天行病行婴儿行。何不证地。答圣梵两行名修因。故论证地。天行正是所证。病儿两行从果起应。故不论证耳。又有义。经显别义从地前各入证。经显圆义登地同一证。又地前非不修圆。登地非无有别。互显令易解故不烦文。地前别者戒行从浅至深证不动地。定行从浅至深证堪忍地慧行从浅至深。证无畏地。地上去并同者。岂有三地条然永别。秖登地时不为二边所动。名不动地。上持佛法下荷众生。名堪忍地。于生死涅槃俱得自在。名无畏地。无畏地从我德立名。堪忍地从乐德立名。不动地从常德立名。净德通三处。登地之日四德俱成。则无增减。盖化道宜然。例如朝三暮四之意耳。从登地去地地有自行。地地有自证。自行秖是修天行。自证秖是证天行。故不别说天行证也。若地前化他名梵行。慈悲喜是化他之事。行一子地是其证。舍心是化他之理。行空平等是其证。此二地亦不条然。登地慈悲故言一子。慈悲与体同。故言空平等耳。地地有悲同恶名病行。地地有慈同善名婴儿行。证道是同故不别说。佛地功德。仰信而已。岂可闇心定分别耶。略答如此(云云)

妙法莲华经玄义卷第四上妙法莲华经玄义卷第四下

        天台智者大师说

圆五行者。大经云。复有一行是如来行。所谓大乘大般涅槃。此大乘是圆因。涅槃是圆果。举此标如来行。非余六度通别等行。前虽名大乘不能圆运。前虽名涅槃过茶可说。乃是菩萨之行。不得名为如来一行。若圆行者。圆具十法界。一运一切运。乃名大乘即是乘于佛乘。故名如来行。如大论云。从初发心常观涅槃行道。亦如大品云。从初发心行生修乃至坐道场亦行生修。毕竟发心二不别。皆如来行意也。此经明安乐行者。安乐名涅槃即是圆果。行即圆因与涅槃义同。故称如来行。入室着衣坐座。悉称如来者。此就人为语。涅槃就法为语。即人论法如来即涅槃。即法论人涅槃即如来。二经义同也。涅槃列一行名。而广解次第五行。法华标安乐行广解圆意。今依法华释圆五行。五行在一心中。具足无缺名如来行。文云。如来庄严而自庄严即圆圣行。如来室即圆梵行。如来座即圆天行。如来衣有二种。柔和即圆婴儿行。忍辱即圆病行。此五种行。即一实相行。一不作五。五不作一。非共非离不可思议。名一五行。云何庄严名圣行。文云持佛净戒。佛戒即圆戒也。又云深达罪福相遍照于十方。即罪即福而见实相。乃名深达。以实相心离十恼乱等。皆是圆戒。佛自住大乘。如其所得法定慧力庄严。即是佛之定慧庄严。故名佛圣行也。云何如来室名梵行。无缘慈悲能为法界依止。如磁石普吸莫不归趣。又以弘誓神通智慧引之。令得住是法中故。以如来室为梵行。云何如来座为天行。第一义天实相妙理。诸佛所师。一切如来同所栖息。文云。观一切法空。不动不退亦不分别上中下法有为无为。实不实法故。如来座即天行。云何如来衣婴儿行病行。遮喧遮静故名忍辱。双照二谛复名柔和。文云。能为下劣忍于斯事。即脱璎珞着弊垢衣。即同病行。方便附近即同婴儿行。又复观十法界寂灭。即如来座名天行。拔九法界性相故起悲。与一法界乐故起慈。即是梵行。柔和照善性相即同婴儿。照恶性相即同病行。又照善性相即戒。寂照即定慧。即是圣行。当知。一心照十法界。即具圆五行。又一心五行即是三谛三昧。圣行即真谛三昧。梵婴病即俗谛三昧。天行即中道王三昧。又圆三三昧。圆破二十五有即空故。破二十五恶业见思等。即假故。破二十五无知。即中故。破二十五无明。即一而三。即三而一。一空一切空。一假一切假。一中一切中。故名如来行。又如来室冥熏法界。慈善根力不动真际。和光尘垢以病行慈悲应之。示种种身如聋如哑。说种种法如狂如痴。有生善机。以婴儿行慈悲应之。婆和木牛杨叶。有入空机。以圣行慈悲应之。执持粪器状有所畏有入假机。以梵行慈悲应之。慈善根力见如是事。踞师子床宝几承足。商估贾人乃遍他国。出入息利无处不有。有入中机。以天行慈悲应之。如快马见鞭影。行大直道无留难故。无前无后不并不别。说无分别法。诸法从本来常自寂灭相。圆应众机如阿修罗琴。若渐引入圆。如前所说。若顿引入圆如今所说入圆等证更无差别。为显别圆初入之门。慈善根力令渐顿人见如此说(云云)。又圆五行。即是四种十二因缘智行。不思议识名色等清净即戒圣行。行有等清净即定圣行。无明爱等清净即慧圣行。十二支寂灭。又无前三种十二缘即天行。能同前三种十二因缘灭。即婴儿行。同前十二因缘生即病行。又是四种四谛智行。无作之道即戒定慧圣行。无作之灭即天行。慈悲拔苦拔四种苦与四种乐即梵行。直悲即病行。直慈即婴儿行。又是七种二谛智行。圆真方便即是圣行。圆真之理即是天行。悲七俗慈七善即梵行。同七俗即病行。同七真即婴儿行。又是五种三谛智行。俗谛中善是戒圣行。真谛中禅是定圣行。真谛慧即慧圣行。中谛是天行。拔五俗苦与五真中乐是梵行。同五俗是病行。同五真中是婴儿行。又是一实谛智行。一实谛有道共戒定慧即圣行。一实境即天行。同体慈悲合说即梵行。各说即病行婴儿行。观心圆五行者。上来圆行不可远求。即心而是。一切诸法中悉有安乐性。即观心性名为上定。心性即空即假即中。五行三谛一切佛法。即心而具。初心如此行如来行。应以如来供养而供养之。随方向礼至处起塔。已有全身舍利故初心尚尔。况似解耶。况入住耶。地持云。从自性禅发一切禅。一切禅。有三种。一现法乐禅。即实相空慧中三昧也。二出生一切种性三摩跋提。二乘背舍除入等。即真三昧也。三利益众生禅。即俗三昧也。当知。五行三谛于一切禅中。皆悉成就。即初住分位。入此位时无非佛法。是为圆心之行。岂与前五行次第意同。当知。次第为粗。一行一切行为妙。即相待意也。若开粗显妙。无粗可待。即绝待行妙意也。问法华开粗粗皆入妙。涅槃何意。更明次第五行耶。答法华为佛世人破权入实。无复有粗教意整足。涅槃为末代凡夫。见思病重定执一实诽谤方便。虽服甘露不能即事而真。伤命早夭。故扶戒定慧显大涅槃。得法华意者。于涅槃不用次第行也

○第四明位妙者。谛理既融智圆无隔。导行成妙三义已显。体宗用足。更明位妙者。行之所阶也。但位有权实布在经论。若成论毗昙判位。言不涉大。地摄等论判位。别叙一途义不兼括。方等诸经明位。璎珞已判浅深。般若诸经明位。仁王盛谈高下而未彰粗妙。今经位名不彰。而意兼小大粗判权实。然梵文不尽度本经必有。今药草喻品但明六位。文云。转轮圣王释梵诸王。是小药草。知无漏法能得涅槃。独处山林得缘觉证。是中药草。求世尊处我当作佛行精进定。是上药草。又诸佛子专心佛道。常行慈悲。自知作佛决定无疑。是名小树。安住神通转不退轮。度无量亿百千众生。是名大树。追取长行中一地所生一雨所润。及后文云今当为汝说最实事。以为第六位也。前三义是藏中位。小树是通位。大树是别位。最实事是圆位也。小草位者。人天乘也。轮王是人主位。释梵是天主位。皆约报果明位果义。既有优劣。当知。修因必有浅深。人位因者。即是秉持五戒。略为四品。下品为铁轮王。王一天下。中品为铜轮王。王二天下。上品为银轮王。王三天下。上上品为金轮王。王四天下。皆是散心持戒。兼以慈心劝他。为福故报为人主。飞行皇帝四方归德。神宝自然应也。天乘位者。修十善道任运淳熟。通是天因。加修禅定进升上界。三界天果高下不同。修因必深浅异也。正法念云。六万山绕须弥。须弥四埵有持鬘天。有十住处各千由旬。北四余各二。南名白摩尼。能十拍手顷受三归依。不杂余心者。生此天受乐。转轮王十六倍不及一诸乐具悉从山河流出。二名峻崖。昔于河济造立桥船。度持戒人兼济余人。不作众恶。果报可知。西方一名果命。昔于饥世。守持净戒净身口意。种殖果树行者食之。安乐充满。二名白功德。昔以华鬘散佛上及塔上。东方一名一切喜。昔以华供养持戒人供佛。自力致财买华。果报可知。二名行道。昔见大火起焚烧众生。以水灭之。果报(云云)。北方四者。一名爱欲。二名爱境界。三名意动。四名游戏林。初者见他亲友相破。和合诤讼得生此天。次昔说法会。次昔以净信心供养众僧扫塔。净信上田。次昔持信心施僧衣。施一果直。为作衣价。爱乐随喜。次迦留波陀天。此言象迹。亦有十处。一名行莲华。昔持戒熏心受三自归。称南无佛。所有蜂声尚胜余天。况复余果报耶。次名胜蜂。欢喜。昔信心持戒。有慈悲利益众生。华香伎乐供养佛塔。三名妙声。昔施佛宝盖。四名香乐。昔信心持戒香涂佛塔。五名风行。昔信心持戒。施僧扇得清凉。六天香风悉来熏之。皆倍倍增。香风尚尔况念香风随念皆得。六名散华欢喜。昔见持戒人。说戒时施澡瓶。或道路中盛满净水。施人澡瓶。七名普观。昔于持戒人以善熏心。于破戒人病不求恩惠。悲心施安心不疲厌。供养病人。八名常欢喜。昔见犯法者应死。以财赎命令其得脱。九名香药。昔于持戒信三宝。大福田中施末香涂香。净心供养。如法得财施已随喜。十名均头。昔见人得罪于王。鬘发受戮救令得脱。第三天名常恣意。十住处一名欢喜峰。昔救护神树。及夜叉所依树。有树即乐失树即苦。二名优钵罗色。昔净信持戒供养三宝。造优钵罗华池故。三名分陀利。昔造此华池四名彩地。昔信净心为僧染治袈裟。杂色染治法服故。五名质多罗。此翻杂地。昔以种种食。施持戒不犯戒等人故。六名山顶。昔修造屋遮风寒。令人受用故。七名摩偷。此翻美地。昔持戒悲心质直不恼人。食施道行沙门婆罗门。或一日或多日。或不息故。八名欲境。昔持戒。若邪见人病。施其所安故。九名清凉。昔见临终渴病人。以石蜜浆或冷水。施病人故。十名常游戏。昔为坐禅人作房舍图画。作死尸观故。第四名箜篌天有十住处。一名楗陀罗。昔以园林甘蔗庵罗等果林施僧故。二名应声。昔为邪见人说一偈法。令其心净信佛故。三名喜乐。昔施人美饮或清美水。或覆泉井不令虫蚁入。行人饮之无苦恼故。四名掬水。昔见病苦者临终。咽喉忽忽出声施其浆水财物赎彼命。五名白身。昔涂饰治补佛塔僧舍。亦教人治补故。六名共游戏。昔信心持戒。同法义和合共故。七名乐游戏。昔持戒化众生。令心净信欢喜戒施故。八名共游。昔法会听法。佐助经营深心随喜故。九名化生。昔见饥馑者没溺者。而救护之。十名正行。昔见亡破抄掠救令得脱。示崄处正道。次日行天绕须弥山住于宫殿。外道说为日曜及星宿。略说三十六亿。昔持七戒令得增上果。风轮所持。此日行等大天与二大天。谓提头赖吒毗沙门。游四天下游戏空中。受五欲乐如意自娱。日行绕须弥山。随在何方山有影现。人说为夜。风轮持北方星轮转不没。外道见辰星不没。谓其能持一切世间国土。不知风力所为也。不杀戒生四天处。不杀不盗生三十三天加不淫生焰摩天。加不口四过生兜率天。又加世间戒。复信奉佛七戒。生化乐他化两天。所持戒转胜。天身福命转胜。又随心持戒思心胜者。其福转胜。三十三天者。一名住善法堂天。昔持七戒坚固无嫌。施四果病人。父母入灭定人。慈悲喜舍与怖畏寿命。生善法堂天。作释迦提婆姓憍尸迦。名能天主。有九十九那由他天女为眷属。心无嫉妒。善法堂广五百由旬。第三名清净天。焰摩天王名牟修楼陀。身长五由旬。百千帝释和合所不及。第四兜率陀。此云分别意宫。其王名删斗率陀。第五涅摩地。此云自在。亦名不憍乐。第六名婆罗尼蜜。此云他化自在。色无色不复书。小药草竟。中药草位者。即二乘也。此就习果判位。旧云。成论探明大乘解菩萨义此则不然。论主自云。今正自明三藏中实义。实义者空是。人师岂可诬论主耶。此即空门明二十七贤圣断伏之位。阿毗昙有门明七贤七圣断伏之位委在两论。今略出有门中草之位。初明七贤。次明七圣位。七贤者。一五停心。二别相念处。三总相念处。四暖法。五顶法。六忍法。七世第一法。通称贤者。邻圣曰贤。能以似解伏见。因似发真故言邻圣。又天魔外道爱见流转。不识四谛。此七位人明识四谛。大经云。我昔与汝等不见四真谛(云云)。见四谛者。识属爱四谛。识属见四谛。皆能明了。若解四谛则所见真正。无有邪曲故是贤人相也。一初贤位者。谓学五停心观成。破五障道。即是初贤位。所以者何。若定邪聚众生。不识三宝四谛。贪染生死。若人归依三宝解四真谛。发心欲离生死求涅槃乐。五种障道烦恼散动。妨观四谛。今修五观成就。障破道明行解相称。故名初贤。二别相念处位者。以五障既除观慧谛当能观四谛。而正以苦谛为初门。作四念处观破四颠倒。若慧解脱根性人。但修性四念处观。破性执四倒。若俱解脱人。修共四念处观。破事理四倒若无疑解脱根性人。修性共缘三种四念处。破一切事理文字等四颠倒。善巧方便于念处中有四种精进修四种定生五善法。破五种恶分别道用安隐而行。能观四谛成别相四念处位也。三总相四念处者。前已别相念慧破四颠倒。今深细观慧总破四倒。或境总观。总境别观总境总观别。或总二阴三阴四阴五阴。皆名总相观是中亦巧方便。能生正勤如意七觉八道疾入后法。故名总相念处位也。四暖法位者。以别总念处观故。能发似解。十六谛观得佛法气分。譬如钻火烟起。亦如春阳暖发。以慧钻境发相似解。解即喻暖。又如春夏积集华草。自有暖生。以四谛慧集众善法。善法熏积慧解得起。故名暖也。即是内凡初位。佛弟子有外道则无。是名暖法位。五顶法者。似解转增得四如意定。十六谛观转更分明。在暖之上。如登山顶观瞩四方悉皆明了故名顶法。六忍法位者。亦是似解增长。五种善法增进成根。于四谛中堪忍乐欲。故名忍法位。下中二忍皆名忍位。七世第一法位者。即是上忍一刹那。于凡夫所得最胜善根。名为世间第一法也。上智妙中已略说竟。七圣位者。一随信行。二随法行。三信解。四见得。五身证。六时解脱罗汉。七不时解脱罗汉。通名圣者正也。苦忍明发舍凡性入圣性。真智见理故名圣人。一随信行位者。是钝根人入见道之名也非自智力。凭他生解。是人在方便道。先虽有信以未习真。信不名行。行以进趣为义。从得苦忍真明。十五刹那进趣见真故。名随信行位也。二随法行位者。即是利根入道之名也。利者。自以智力见理断结。在方便道能自用观。观四真谛法但未发真。不名为行。因世第一法发苦忍真明。十五刹那进趣见真。故名随法行位也。三明信解位者。即是信行人。入修道转名信解人也。钝根凭信进发真解。故名信解。是人证果有三。谓三果(云云)。证初果者。第十六道比智相应。即证须陀洹。须陀洹。此翻修习无漏。成论明犹是见道。数人明证果即入修道。用此明修习无漏义便。若见道所断略言三结尽。广说八十八使尽。七生在终不至八(云云)。次明证二果即有二种。一向二果。向者从初果心后。更修十六谛观。七菩提行现前。即此世无漏断烦恼。一品无碍。断欲界一品烦恼乃至断五品。皆是于向。亦名胜进须陀洹。约此论家家也。二果者。若断六品尽。证欲界第六品解脱。即是斯陀含果也。天竺云薄。薄欲界烦恼也。次明证阿那含。亦有二。一向二果。向者若断欲界七品乃至八品。皆名为向。亦名胜进斯陀含。约此说一种子也。果者九无碍断欲界。若证第九解脱。即名阿那含果也。天竺云不还。不还生欲界也。复次须陀洹。有三种。一行中须陀洹即是向也。二住果正是须陀洹也。三胜进须陀洹亦名家家。即是斯陀含向也。斯陀含。但有二种一住果二胜进。胜进亦名一种子。即阿那含向也。阿那含亦二种。一住果。二胜进。胜进那含断五上分结。谓色无色染等。即阿罗汉向也。罗汉但有一。谓住果也。复次超果者。凡夫时断欲界六品乃至八品尽。来入见道。发苦忍真明十五心中。是斯陀含向。十六心即证斯陀含果也。若凡夫时。先断二界九品尽。乃至无所有处尽。后入见谛十五心。名阿那含行第十六心即证那含果。此名超越人证后二果也。是信解虽是动根性不同谓退护思住进也。若证阿那含。各复有五及七种般八种般。五种般者。中般生般行般不行般上流般也。七种者。开中般为三种也。八种般者。五如前。更有现般无色般不定般(云云)。四明见得位者。法行人转入修道。名为见得是利根人。自以智勋见法得理。故名见得。是人在思惟道。次第证三果超越二果。亦如信解中分别。但以利根。不藉闻法不假众具。自能见法得理为异也。见得但是不动根性。若证阿那含果。亦有五种七种八种般不同也。五明身证位者。还是信解见到二人。入思惟道用无漏智。断上下分结。发四禅四无色定。即是用共念处。修八背舍八胜处十一切处。入九次第定三空。事性两障先已断尽。又断非想事障。灭缘理诸心心数法。入灭尽定。得此定故名身证阿那含也。何者入灭定似涅槃法。安置身内息三界一切劳务。身证想受灭故名身证也。若约初果解身证者。但以先于凡夫用等智断结得四禅四无色定。后得见谛第十六心证那含果。即修共念处还从欲界修背舍胜处一切处。入九次第定身证也。是阿那含有二种。一住果但是阿那含也。二带果行向。即是胜进阿那含也。亦是罗汉向摄。释论云。那含有十一种。五种正是阿那含。六种阿罗汉向摄。此身证者。即是胜进为罗汉向摄。五种七种般皆有上流般八种般。但有现般无色般也。毗昙分别那含。有一万二千九百六十种(云云)。六明时解脱罗汉者。是信行钝根待时及众缘具。方得解脱故名时解脱罗汉。罗汉此无翻。名含三义。杀贼不生应供也。位居无学。罗汉有五种。随信行生退法思法护法住法升进法也。得尽智无学等见也。若用金刚三昧。于非想九品惑尽。次一刹那。证非想第九解脱成尽智。次一刹那得无学等见也。或彼时退故不说得无生智。此五种阿罗汉。是信种性根钝。因中修道必假衣食床具处。所说法及人随顺。善根增进不能一切时所欲进也。是五种各有二种。不得灭尽定。但是慧解脱。得灭尽定即是俱解脱。若不得灭尽定。是人因中偏修性念处。若得灭尽定。是人因中修性共也。证果时三明八解。一时俱得。故名俱解脱也。七不时解脱罗汉者。即是法行利根。名不动法阿罗汉也。此人因中修道。能一切时随所欲进修善业。不待众具。故名不时解脱。是人不为烦恼所动。故名不动。不动是不退义。成就三智。谓尽智无生智无学等见。能用重空三昧。击圣善法以定舍定。故言能击。是不动罗汉亦有二种。一不得灭尽定。但名慧解脱。二得灭尽定。即是俱解脱。若闻佛说三藏教门。修缘念处即发四辩。名无疑解脱。是名波罗蜜声闻。能究竟具足一切罗汉功德也。名沙门那。沙门那者沙门果也。二明辟支佛位者。此翻缘觉。此人宿世福厚神根猛利。能观集谛以为初门。大论称独觉因缘觉。若出无佛世自然悟道。此即独觉。若出佛世闻十二因缘法。禀此得道。故名因缘觉。独觉生无佛世。有小有大。若本在学人今生佛后。七生既满不受八生。自然成道不名为佛。亦非罗汉。名小辟支迦罗。论其道力。不及舍利弗等大罗汉。二者大辟支迦罗。二百劫中作功德身。得三十二相分。或三十一三十二十九。乃至一相。福力增长智慧利。于总相别相能知能入。久修集定常乐独处。故名大辟支迦罗也。若就因缘论小大者。亦应如是分别。此人根利不须制果。能断正使又加侵习。譬如身壮直到所在。不中止息故不制果。是名中草位竟。上草位者。即是三藏菩萨位也。此菩萨从初发菩提心。起慈悲誓愿观察四谛。以道谛为初门。行六波罗蜜。从初释迦至罽那尸弃佛时。名第一阿僧祇劫。常离女人身。亦不自知当作佛不作佛。准望二乘位。应在五停心别相总相念处位中。以慈悲心行六度行也。从罽那尸弃佛。至然灯佛时。名第二阿僧祇劫。尔时虽自知作佛。而口不说。准望此位应在暖法位中。即是性地顺忍。初心之位既有证法之信。必知作佛而用暖解。修行六度心未分明。故口不向他说也。从然灯佛至毗婆尸佛时。名第三阿僧祇劫。是时内心了了自知作佛。口自发言无所畏难。准此位应在顶法位中。修行六度四谛解明。如登山顶。了见四方。故口向他说也。若过三僧祇劫。种三十二相业者。准此是下忍之位。用此忍智行六度成百福德。用百福成一相因。于下忍之位。人中佛出世时得种也。若坐道场时。位在中忍上忍。从上忍一刹那入真。三十四心断结。得阿耨三菩提则名为佛。尔前则是三藏菩萨上草之位也。小树位者。即是通教明三乘之人。同以无言说道断烦恼。入第一义谛。体法观慧不异。但智力强弱之殊。烦恼习有尽不尽为异耳。先明三乘共十地位。次简名别义通(云云)。一干慧地者。三乘之初。同名干慧。即是体法。五停心别相总相四念处。观事相不异三藏。此三阶法门。体阴入界如幻如化。总破见爱八倒。名身念处。受心法亦如是。住是观中修正勤如意根力觉道。虽未得暖法相似理水。而总相智慧深利。故称干慧位也。二性地位者。得过干慧得暖已能增进初中后心入顶法乃至世第一法。皆名性地。性地中无生方便解慧善巧。转胜于前。得相似无漏性水。故言性地也。三八人地位者。即是三乘信行法行。二人体见假以发真断惑。在无间三昧中。八忍具足。智少一分。故名八人位也。四见地位者。即是三乘同见第一义。无生四谛之理。同断见惑八十八使尽也。五薄地位者。体爱假即真。发六品无碍。断欲界六品证第六解脱。欲界烦恼薄也。六离欲地位者。即是三乘之人。体爱假即真。断欲界五下分结尽。离欲界烦恼也。七已办地位者。即是三乘之人。体色无色爱即真。发真无漏。断五上分结。七十二品尽也。断三界事惑究竟。故言已办地。八辟支佛地位者。缘觉菩萨发真无漏。功德力大故能侵除习气也。九菩萨地位者。从空入假道观双流。深观二谛进断习气色心无知。得法眼道种智。游戏神通。净佛国土。成就众生。学佛十力四无所畏。断习气将尽也。齐此名小树位也。十佛地者。大功德力资智慧。一念相应慧观真谛究竟。习亦究竟。如劫火烧木无复炭灰。如象渡河到于边底。虽菩萨佛名异二乘。通俱观无生体法。同是无学得二涅槃。共归灰断证果处一。故称为通也。二简名别义通。更为二。初就三乘共位中。菩萨别立忍名而义通。二用别教名。名别义通。通义已如前说。别立者。别为菩萨立伏忍柔顺忍无生忍之名也。干慧地三人同伏见惑。而菩萨更加伏忍之名者。菩萨信因缘即空。而于无生四谛降伏其心。起四弘誓愿。虽知众生如虚空。而发心度一切众生。是菩萨欲度众生如欲度虚空。故金刚般若云。菩萨如是降伏其心。所谓。灭度无量众生。实无众生得灭度者次三誓愿降伏其心亦如是。是为菩萨在干慧地。修停心别相总相念处观时异于二乘。故别称伏忍。复次三乘人同发善有漏五阴生相似解。皆伏见惑顺第一义。而菩萨独受柔顺忍名者。菩萨非但伏结顺理。又能为一切众生伏心。遍行六度。一切事中福慧皆令究竟。如三藏菩萨于中忍中。三僧祇行六度不惜身命。今菩萨亦如是。以空无相愿调伏诸根。为众生故满足六度。故名顺忍也。复次三乘人同发真无漏。若智若断同名无生。而菩萨独受无生法忍名者。以其见谛理断结使不生取证之心。故别受无生法忍之名也。何者。若生取证之心即堕二乘地。不得入菩萨第九地。复次三乘同得神通。而二乘不能用成就众生净佛国土。故不受游戏之名。菩萨能尔。故别受游戏神通名也。阿那含虽断五下分结。而不能舍深禅定来生欲界。和光利物不同其尘。菩萨能如此。故别受离欲清净之名。所以三乘之人同观二谛。用与不同。若二乘虽观二谛。一向体假入空。用真断结至无学果。菩萨亦观二谛。始从干慧终至见地。多用从假入空。得一切智慧眼多用真也。从薄地学游戏神通。多修从空入假观。得道种智法眼多用俗也。从辟支佛地。学二观双照入菩萨地。自然流入萨婆若海。是则无功用心修种智佛眼佛地圆明。成一切种智。佛眼同照二谛究竟也。故大论云。声闻法中名干慧地。于菩萨即是伏忍。声闻法名性地。于菩萨法中名柔顺忍。声闻法名八人地。于菩萨名无生忍道。声闻法名见地。于菩萨法是无生法忍果。声闻名薄地。于菩萨法名为游戏五神通。声闻法名离欲地。于菩萨法名为离欲清净阿罗汉地。于声闻法即是佛地。何者。三藏佛三十四心发真。断三界结尽与罗汉齐。故名佛地。于菩萨法中犹名无生忍。故大品云。阿罗汉若智若断。是菩萨无生法忍。辟支佛地亦如是。九地过辟支佛入菩萨位。菩萨位者九地十地。是则十地菩萨。当知为如佛齐此习气未尽。过菩萨地则入佛地。用誓扶余习生阎浮提。八相成道。五相如三藏不殊。唯六成道树下。得一念相应慧。与无生四谛理相应。断一切烦恼习尽。具足大慈悲十力四无畏十八不共法一切功德。名之为佛。七转法轮。权智开三藏生灭四谛法轮。实智说摩诃衍无生四谛法轮。通教三乘人也。八入涅槃相者。双树入无余涅槃。薪尽火灭留舍利。为一切天人福田也。是为通教共位。别为菩萨立此名位也。二用别名。名者。即是取别教之名。准望通教菩萨位也。别名者。即是十信三十心十地之名也。铁轮位于通义。即是干慧地伏忍也。三十心即望性地柔顺忍也。八人地见地。即是初欢喜地得无生法忍也。故大品云。须陀洹若智若断。皆是菩萨无生忍也。薄地向果。向即是离垢地。果即是明地也。故大品云。斯陀含智断。是菩萨无生法忍也离欲地向果。向即焰地果即难胜地。故大品云。阿那含智断。是菩萨无生法忍。已办地向果。向是现前地。果是远行地。大品云。阿罗汉智断。是菩萨无生法忍。辟支佛地。即是第八不动地侵习气也。大品云。辟支佛地智断。是菩萨无生法忍。菩萨地即是善慧地。十地当知如佛地。佛地如前说。此佛与三藏佛亦同亦异。同八十年同入真灰断也。异者。三藏因伏果断。通佛因果俱断。三藏一日三时照机。通佛即俗而真。照不须入也。是则用别名辨位。名异义同。犹属通教位也问初地至七地对果。出何经论。答经论非不对当。但高下不同。人师对之异。或用见地止对初地。如今所用。或向初取三地并对初地。仁王明四地并对初地。此难定判。但通教见地。本是无间之道。不出观证须陀。洹。岂得初地断见乃至三地。或云四地耶若断别惑不共二乘。此义有之。又或言六地断结齐罗汉。或云七地此难定执。前后两果经论对皆不定。中间可以意得。今以义推不可定执也。问从七地八地观常住破无明者。是何地位。答此则非通亦复非别。何者。通教始终不明观常。何得中间而破无明。别教初心即知常住。初地已能破无明。云何八地始破无明。此乃别接通意耳。问大论三处。明初焰约别圆。皆取发真为初焰。通教何意取干慧为初焰。答别圆各逗一种根性。故用发真为初焰。通教为逗多种根性。所谓别圆入通故。含容取干慧耳。若钝者八人见地是初焰。利者于干慧即能断结。故是初焰。问利人应无十地。答备有以根利故。故不制位耳。问别圆无利人耶。答虽有利钝。以根性纯故但作一说。宜如此也。大树位者。别教位也。此为三。一出经论不同。二总明位。三别明位。此别教名义理惑智断皆别。此正约因缘假名恒沙佛法如来藏理常住涅槃无量四谛。而论位次。无量四谛凡有四种。有无量四谛不伏破尘沙。亦不伏破无明。有无量四谛傍伏破尘沙不伏破无明。有无量四谛正伏破尘沙。亦伏无明。有无量四谛正伏破尘沙。亦伏破无明。云何无量不伏破尘沙。不伏破无明。若三藏伏道有十六谛观。明障真之惑有无量种。此乃伏于见思何关尘沙。例如外道分别世智。非伏见思。云何无量是傍伏破。若通教七地出假。分别药病。此助灭界内非正伏破。云何无量正伏破尘沙。此是别教分别内外四谛有无量种。即是伏破尘沙亦伏无明。乃有破无明义。今从事得名伏无明者。为便也。云何无量伏破无明。若圆教三谛。俱照法界事理无不明了。破自地无明伏上地无明。别教无量四谛非前二非后一。正就恒沙佛法当名。然实通缘诸四谛次第为论。不无傍正。初心缘诸无量发心誓愿。初正以生灭四谛。伏通见思。傍修三种。次正以无生破通见思。傍修两种。次正以无量破内外尘沙。次正用无作伏无明。次正用无作破无明。既有如此无量阶差。是故经论名数断伏高下。对诸法门多有不同。若华严明四十一地。谓三十心十地佛地。璎珞明五十二位。仁王明五十一位。新金光明经但出十地佛果。胜天王般若。明十四忍。大品但明十地。涅槃明五行十功德。约义配位。似开三十心十地佛地。而文不出名。又十地论。摄大乘论。地持论。十住毗婆沙论。大智度论。并释菩萨地位。而多少出没不同(云云)。又断伏高下亦异。对诸法门行位亦复殊别。所以然者。既明界内界外生法两身菩萨行位。如来方便用四悉檀。化界内众生随机利益。岂得定说。不广寻经论。如无目诤日。今若明位数。须依缨珞仁王。若明断伏高下。须依大品三观。若对法门须依涅槃。用众经意。共成初心观教两门使分明耳。诸圣上位非凡能测。岂可妄说。粗知大意者。为破行人增上慢心。又为销经文引物悕向。不可偏执诤竞是非也。今判位名数。依缨珞仁王者。华严顿教多明圆断四十一地。不出十信之名。诸大乘经多明诸法门。不正辨位。前四时般若多明菩萨观行法门意。亦不正辨位。今谓缨珞五十二位名义整足。恐是结诸大乘方等别圆之位。仁王般若明五十一位。恐是结成前四时般若别圆之位也。法华但开权显实显一圆位。涅槃大意亦明别圆两位。而不摘出名目(云云)。断伏高下依大品三观者。于次第义便也。对观行法门依涅槃五行者。正是末代入道所宜也。何者。别教明观行有二种。一者不共二乘说。如华严十地论。地持九种戒定慧。及摄大乘论等是也二者共二乘说。如方等大品中论释论是也。今涅槃五行从凡至极。故是末代行用为要也。二总明菩萨位者。即约三经。一约缨珞明位数者。经有七位。谓十信十住十行十回向十地等觉妙觉地也。初十信心即是外凡。亦是别教干慧地。亦名伏忍位也。十住即是习种性。此去尽三十心皆解行位。悉是别教内凡。亦是性地。亦名柔顺忍位。约别教义推应如暖法也。十行即是性种性。别教义推应如顶法。十回向道种性。别教义推应如忍法世第一法。问今明别教何用四善根名。答别教十地既对四果。今以方便拟四善根何咎。又通教通于通别真似两解。作此比决于义分明也。十地即是圣种性。此皆入别教四果圣位。悉断无明别见思惑。等觉位即是等觉性。若望菩萨名等觉佛。若望佛地。名金刚心菩萨。亦名无垢地菩萨也。妙觉地即是妙觉性。即是究竟佛菩提果。大涅槃之果果也。二约大品及三观合位。明断伏高下者。大品菩萨欲具道慧。当学般若。即此十信习从假入空观。伏爱见论。欲入十住位。若得十住即断界内见思也。欲以道慧具足道种慧。当学般若。此即修从空入假十行也。欲以道种慧具足一切智。当学般若。此即修中道正观。入十回向位也。欲以一切智具足一切种智。当学般若。此即是证中道观。入十地也。欲以一切种智断烦恼习。当学般若。此即等觉地也。无明烦恼习尽。名之为佛即妙觉地也。三约涅槃明圣行合位者。初戒圣行定圣行。即是十信位也。生灭无生灭四真谛慧圣行。即是十住位。无量四圣谛慧即是十行位。修一实谛无作四圣谛。即是十回向位。次若发真见一实谛。证无作四圣谛。即是圣行满住无畏地。得二十五三昧。能破二十五有。名欢喜地。五行具足。次后说十功德者。恐表住大涅槃十地之功德也。过此明佛眼了了是妙觉地也。三别解七位余本寻。大树位竟也

妙法莲华经玄义卷第四下(终)妙法莲华经玄义卷第五上

        天台智者大师说

明最实位者。即圆教位也。此为十意。一简名义。二明位数。三明断伏。四明功用。五明粗妙。六明位兴。七明位废。八开粗显妙。九引经。十妙位始终。一简名义者。若圆别不同自有十意。下辨体中说。今约通别圆三句料简。一名通义圆。二名别义圆。三名义俱圆。名通义圆者。下文云。我等今日真阿罗汉。普于其中应受供养。又云。我等今日真是声闻。以佛道声令一切闻。此名与通藏同而义异。何者。彼但杀四住之贼。无明尚在。此不生义偏。故天女曰。结习未尽华则着身。今杀通别两惑。得如来灭度。故杀贼义圆。又彼是分段不生界外犹生。宝性论云。二乘于无漏界生三种意阴。今则分段变易二俱不生。不生义圆。彼是界内应供。非界外应供。净名曰。其供汝者不名福田。则应供义偏。今则普于其中应受供养。则应供义圆。彼但小乘从他闻四谛声。则声偏闻偏。今能令一切法界闻一实四谛佛道之声。使一切闻则声闻义圆。故知依义不依语。从圆判位也。名别义圆者如五十二位名与别同。而初中后位圆融妙实。随自意语。非是教道方便。依义不依语应从圆判位也。名义俱圆者。文云。开示悟入皆是佛之知见。佛一切种智知佛眼见。此之知见无有缺减。又入如来室坐如来座。以如来庄严。此则名义俱圆。判于圆位也。二明位数者又为三。一明数。二引证多少。三料简数者。人解不同。有言。顿悟即佛无复位次之殊。引思益云。如此学者。不从一地至一地。又有师言。顿悟初心即究竟圆极。而有四十二位者。是化钝根方便。立浅深之名耳。引楞伽云。初地即二地。二地即三地。寂灭真如有何次位。又有师言。初顿悟至十住即是十地。而说有十行十回向十地者。此是重说耳。今谓诸解悉是偏取。然平等法界。尚不论悟与不悟。孰辨浅深。既得论悟与不悟。何妨论于浅深。究竟大乘。无过华严大集大品法华涅槃。虽明法界平等无说无示。而菩萨行位终自炳然。又有人言。平等法界定无次位。今例难此语。真谛有分别耶。真谛无分别耶。见真之者。判七贤七圣二十七贤圣等。今实相平等。虽无次位见实相者。判次位何咎。大论云。譬如入海有始入者。到中者至彼岸者。若见真判位。如江河深浅。若实相判位。如入海深浅。故普贤观云。大乘因者诸法实相。大乘果者亦诸法实相。论诸次位非徒臆说。随顺契经。以四悉檀明位无妨。还约七种以明阶位。谓十信十住十行十回向十地等觉妙觉。今于十信之前。更明五品之位(云云)。若人宿殖深厚。或值善知识。或从经卷圆闻妙理。谓一法一切法。一切法一法。非一非一切。不可思议。如前所说。起圆信解。信一心中具十法界。如一微尘有大千经卷。欲开此心而修圆行。圆行者。一行一切行。略言为十。谓识一念平等具足不可思议。伤己昏沉慈及一切。又知此心常寂常照。用寂照心破一切法。即空即假即中。又识一心诸心若通若塞。能于此心具足道品。向菩提路。又解此心正助之法。又识己心及凡圣心。又安心不动不堕不退不散。虽识一心无量功德。不生染着。十心成就。举要言之。其心念念悉与诸波罗蜜相应。是名圆教初随喜品位。行者圆信始生善须将养。若涉事纷动令道芽破败。唯得内修理观。外则受持读诵大乘经典。闻有助观之力。内外相藉圆信转明。十心坚固。金刚般若云。一日三时以恒河沙身布施。不如受持一句功德。初品观智如目。次品读诵如日。日有光故目见种种色。论云。于实名了因。于余名生因。福不趣菩提。二能趣菩提。闻有巨益意在于此。是名第二品位。行者内观转强外资又着。圆解在怀弘誓熏动。更加说法如实演布。安乐行云。但以大乘法答。设以方便随宜终令悟大。净名云。说法净则智慧净。毗昙云。说法解脱听法解脱。说法开导是前人得道全因缘。化功归己。十心则三倍转明。是名第三品位。上来前熟观心未遑涉事。今正观稍明。即傍兼利物。能以少施与虚空法界等。使一切法趣檀。檀为法界。大品云。菩萨少施。超过声闻辟支佛上当学般若。即此意也。余五亦如是。事相虽少运怀甚大。此则理观为正事行为傍。故言兼行布施。事福资理则十心弥盛。是名第四品位。行人圆观稍熟。理事欲融。涉事不妨理。在理不隔事。故具行六度。若布施时无二边取着。十法界依正一舍一切舍。财身及命无畏等施。若持戒时。性重讥嫌等无差别。五部重轻无所触犯。若行忍时。生法寂灭荷负安耐。若行精进。身心俱净。无间无退。若行禅时。游入诸禅静散无妨。若修慧时权实二智究了通达。乃至世智。治生产业。皆与实相不相违背。具足解释佛之知见。而于正观如火益薪。此是第五品位。如此五品圆信功德。东西八方不可为喻。虽是初心。而胜声闻无学功德。具如经说。若欲比决取解。类如三藏家别总四念处位。义推如通教干慧地位。亦如伏忍位。义推亦得是别教十信位(云云)。私谓五品位。是圆家方便。初欲令易解准小望大。如三藏之五停心。初品圆信法界。上信诸佛下信众生。皆起随喜是圆家慈。停心遍对治法界上嫉妒。第二品读诵大乘文字。文字是法身气命。读诵明利是圆家数息。停心遍治法界上觉观。说法品能自净心亦净他心。是圆家因缘停心。遍治法界上自他痴。痴去故诸行去。乃至老死去。兼行六度品。是圆家不净停心。六蔽初名贪欲。若舍贪欲欲因欲果皆舍。舍故无复报身。非净非不净也。正行六度品。是圆家念佛停心。正行六度时即事而理。理不妨道事妨于道。即事而理。无障可论。大意如此(云云)。一明十信位者。初以圆闻能起圆信。修于圆行善巧增益。令此圆行五倍深明。因此圆行得入圆位。以善修平等法界即入信心。善修慈愍即入念心。善修寂照即入进心。善修破法即入慧心。善修通塞即入定心。善修道品即入不退心。善修正助即入回向心。善修凡圣位即入护法心。善修不动即入戒心。善修无著即入愿心。是名入十信位。缨珞云。一信有十十信有百。百法为一切法之根本也。是名圆教铁轮十信位。即是六根清净。圆教似解。暖顶忍世第一法。普贤观明无生忍。前有十境界即此位也。入此信心能破界内见思尽。又破界外尘沙无知。能伏无明住地之惑。仁王般若云。十善菩萨发大心。长别三界苦轮海。亦此位也。此位经经出之不同。华严法慧菩萨。答正念天子。明菩萨观十种梵行空。学十种智力入初住。十种梵行空即一实谛。亦无作之灭谛。学十种智力即观无作之道谛。即十信位也。若大品云。譬如入海先见平相。亦是是乘从三界中出也。仁王般若普贤观。如前引。下文入如来室座衣等。即是修四安乐行。行处近处。涅槃云。复有一行是如来行。所谓大乘。大论云。菩萨从初发心。即观涅槃行道。若观涅槃行道。生相似解即是一行如来行也(云云)。二明十住位者。以从相似十信。能入十住真中智也。初发心住发时。三种心发。一缘因善心发。二了因慧心发。三正因理心发。即是前境智行妙三种开发也。住者住三德涅槃也。缘因心发。即是住不可思议解脱首楞严定。慧心发即是住摩诃般若毕竟之空。正因心发。即是住实相法身中道第一义。举要言之。即是住三德一切佛法也。又住清净圆满菩提心。无缘慈悲无作誓愿。普覆法界。又住一念中。成就一切万行诸波罗蜜。又住一切种智。圆断法界见思无明。又住得佛眼。圆见十法界三谛之法。又住圆入一切法门。所谓二十五三昧冥益众生。又成就菩萨圆满业。能显一切神通。谓三轮不思议化。弥满法界显益众生。又能成就开权显实。入一乘道。又能严净一切佛土。能起三业供养一切十方佛。得圆满陀罗尼。受持一切佛法。如云持雨。又住能从一地具足一切诸地功德。心心寂灭自然流入萨婆若海。华严云。初住菩萨所有功德。三世诸佛叹不能尽。若具足说。凡人闻迷乱心发狂。私谓初住成就十德。应是十信中十法。转似为真一住具十。细意寻之对当相应。何者。十信百法为一切法本。岂不得作此释耶。初住既尔。三观现前无功用心。断法界无量品无明。不可称计。一往大分。略为十品智断。即是十住故。仁王云。入理般若名为住。即是十番进发无漏。同见中道佛性第一义理。以不住法从浅至深。住佛三德及一切佛法。故名十住位。此位诸经出处不同。华严云。初发心时便成正觉。了达诸法真实之性。所有闻法不由他悟。是菩萨成就十种智力。究竟离虚妄。无染如虚空。清净妙法身湛然应一切。当知。即是发真无漏。断无明初品也。净名云。一念知一切法。是为坐道场。成就一切智故。亦是入不二法门。得无生忍也。大品明。从初发心即坐道场。转法轮度众生。当知。此菩萨为如佛。亦是阿字门。所谓一切法初不生也。即是今经为令众生开佛知见。亦是龙女于刹那顷。发菩提心成等正觉。即是涅槃明。发心毕竟二不别。如是二心前心难。此诸大乘悉明圆初发心住位也。乃至第十住(云云)。三明十行位者。即是从十住后。实相真明不可思议。更十番智断破十品无明。一行一切行。念念进趣流入平等法界海诸波罗蜜。任运生长自行化他。功德与虚空等。故名十行位也。十回向位者。即是十行之后无功用道。不可思议真明。念念开发一切法界。愿行事理自然和融。回入平等法界海。更证十番智断。破十品无明。故名回向也。十地位者。即是无漏真明入无功用道。犹如大地。能生一切佛法。荷负法界众生。普入三世佛地。又证十番智断。破十品无明。故名十地位也。等觉地者。观达无始无明源底。边际智满毕竟清净。断最后穷源微细无明。登中道山顶与无明父母别。是名有所断者。名有上士也。七明妙觉地者。究竟解脱无上佛智故。言无所断者。名无上士。此即三德不纵不横。究竟后心大涅槃也。一切大理大誓愿大。庄严大智断大遍知大道大用大权实大利益大无住大。即是前十观成乘。圆极竟在于佛。过茶无字可说(云云)。故卢舍那佛名为净满。一切皆满也。二次引众经。明位数多少者。大涅槃云。月爱三昧。从初一日至十五日。光色渐渐增长。又从十六日至三十日。光色渐渐损减。光色增长。譬十五智德摩诃般若。光色渐减。譬十五断德无累解脱。三十心为三智断。十地为十智断。等觉妙觉。各为一智断。合十五智断。月体譬法身。大经云。月性常圆实无增减。因须弥山故有亏盈。不增而增白月渐着。不减而减黑月稍无。法身亦尔。实无智断。因无明故约如论智。如实不智约如论断。如实不断。虽无智而智。般若渐渐明。虽无断而断。解脱渐渐离。举月为喻。知是圆教智断位也。大经云。从初安置诸子。秘密之藏三德涅槃。然后我当于此秘藏而般涅槃。此即最后智断也。问何得知月喻譬位耶。答仁王明十四忍。三十心为三般若。十地为十般若。等觉为一般若。十四般若在菩萨心中。皆名为忍。转至佛心名之为智。此与十五日明智位同。胜天王明十四般若位。正用十四日月为譬。故作此释也。大品明四十二字门语等字等。南岳师云。此是诸佛密语。何必不表四十二位。诸学人执释论云无此解多疑不用。但论本文千卷。什师作九倍略之。何必无此解耶。今谓此解深应冥会。何者。经云。初阿后茶中有四十。初阿字门具四十一字。后茶亦尔。华严云。从初一地具足一切诸地功德。此义即同。经云。若闻阿字门则解一切义。所谓诸法初不生故。此岂非圆教初住初得无生法忍。过茶无字可说。岂非妙觉无上无过。广乘品明一切法皆是摩诃衍竟。即说四十二字门。岂非圆教菩萨从初发心。得诸法实相。具一切佛法。故名阿字。至妙觉地穷一切法底。故名茶字。此义其数与圆位甚自分明。又四十二字后。即说菩萨十地。此是显别教方便之次位也。又次十地之后说三乘共十地。此显通教方便位也。经文次比三义宛然。今取四十二字以证圆位也。此经分别功德品明初心五品弟子之位。文甚分明。法师功德品。明六根清净相。方便品云。诸佛为一大事因缘故。出现于世。为令众生开佛知见四句。南岳师解云。开佛知见是十住位。示佛知见是十行位。悟佛知见是十回向位。入佛知见是十地等觉位。皆言佛知者。得一切种智也。皆言佛见者。悉得佛眼也。又经云。是为诸佛一大事因缘者。同入一乘诸法实相也。又云。唯佛与佛乃能究尽诸法实相者。即是妙觉位也。又譬喻品。诸子门外索车。长者各赐等一大车。是时诸子乘是宝乘游于四方。嬉戏快乐。自在无碍直至道场。言四方者。即譬开示悟入四十位也。直至道场。即是究尽实相妙觉位也。序品中。天雨四华。表此四十因位也。如上所引众经为证。及引今文明四十二位炳然。皆是无次位之次位。达于实相增道损生。论次位耳。三料简者。问无明覆佛性中道。止作四十二品断耶。答无明虽无所有。不有而有。不无阶品。一往大分为四十二品。然其品数无量无边。大论云。无明品类其数甚多。是故处处说破无明三昧。又云。法爱难尽。处处重说般若也。此诸圆位不可思议。若专对法门寻者失意。多别解别执。则乖圆融之道。如此等位莫以凡情局取。不以凡心能宣。华严云。诸地不可说。何况以示人。且置是事。若大乘忏悔发初随喜圆信之心。获一旋陀罗尼。已不可向人说。虽种种分别亦不可解。况后诸位二乘尚不闻其名。岂凡人能说。此语有意。大师自说己证也。又且置是事。声闻学四念处发得暖法。亦不可向外凡说尽。设种种解亦不能知。又置是事。如人坐禅初发五支。不可为未证者说。设方便说彼亦不解。又置是事。斲轮人不能以其术授其子。况诸深法而可说耶。末代学者。多执经论方便断伏诤斗(云云)。如水性冷不饮安知。此乃诸佛赴缘不思议。语随机增减位数不同。尔未证得空诤何为。普愿法界众生归僧。息诤论入大和合海。又以四句料简圆位。或开初合后。或开后合初。或初后俱开。或初后俱合。如大经明三十三天。不死甘露将臣共服。此譬诸位。开前为三十心。合十地为一。等觉为一。譬三十二臣喻于因位。妙觉为主譬于果位。君之与臣同服甘露。因之与果俱证常乐。若不以圆位释之。此文难会。是为开初合后以明圆位也若十四般若。合三十心为三般若。开十地为十般若。就等觉为十四般若。皆是因位。转入萨婆若即是果位。是为合前开后以明圆位。若四十二字门。即是初后俱开。以明圆位。若天雨四华表开示悟入。游于四方者。此即前后俱合。诸经开合不同。皆是悉檀方便。而圆位宛然矣。三明圆位断伏者。五品已圆解一实四谛。其心念念与法界诸波罗蜜相应。遍体无邪曲偏等倒。圆伏枝客根本惑。故名伏忍。诸教初心无此气分。大经云。学大乘者。虽有肉眼名为佛眼。[穀-禾+卵]中鸣胜诸鸟。例如小乘伏暖。佛法则有外道则无。今此伏忍。圆教则有三教则无。十信之位伏道转强。发得似解。破界内见思界内界外无知尘沙。如经文云得三陀罗尼。但名似道未是真道。旋陀罗尼是旋假入真。百千旋陀罗尼是旋真入俗。法音方便正是伏道。未得入中。如缨珞从假入空观。虽断见思但离虚妄。名为解脱。其实未得一切解脱。当知。六根虽净。圆教暖顶四善根。柔顺忍伏道位耳。若入初住得真法音陀罗尼。正破无明始名断道。见佛性常住第一义理。名圆教无生忍。十行十回向十地等觉。皆破无明。同是无生忍位。妙觉断道已周究竟成就。名为寂灭忍。若约位别判伏顺二忍。但伏不断。例如无碍道。妙觉一忍断而不伏。例如解脱道。无生一忍亦伏亦断。亦无碍亦解脱。若论通义。妙觉寂灭忍亦名无生忍。大经云。涅言不生槃言不灭。不生不灭名大涅槃。亦名伏忍。仁王云。从初发心至金刚顶。皆名伏忍。伏是贤义。普贤菩萨居众伏之顶。伏忍既通顺忍可解。伏顺既其通上。寂灭无生亦应通下。思益云。一切众生即灭尽定。净名云。一切众生皆如也。如即无生忍。又就事为无生。就理为寂灭。又分证为寂灭。让果为无生。若约因果亦有通别。通者。一切众生即大涅槃。即是约因论果。佛性者名之为因。此即约果论因。大经云。是果非因名大涅槃。是因非果名为佛性。了见佛性乃是于佛。故亦得是因(云云)。等觉望妙觉为因望菩萨为果。自下已去。亦因亦因因。亦果亦果果。约分别义者。伏顺二忍未是真因。无生一忍未是真果。从十住去名真因。妙觉名真果。云何伏顺非真因。例如小乘方便之位。不名修道。见谛已去约真修道。此义可知。今顺忍中断除见思。如水上油虚妄易吹。无明是同体之惑。如水内乳。唯登住已去菩萨鹅王。能唼无明乳清法性水。从此已去乃判真因。复次别教。判三地或四地断见尽。六地或七地断思尽。此不应尔。何者。无明见思同体之惑。何得前后断耶。当是别教附傍小乘方便说耳。若见先尽。则实理无复有障。云何十地见不了了。地持云。第九离一切见清净净禅。第九是等觉地。入离见禅乃成大菩提果。若见先断。等觉复何所离。若思前尽。后地应无果报及诸禅定。何者。华严明阿僧祇香云华云。不可思议充塞法界者。此是菩萨胜妙果报所感五尘。呼此为欲界思惑。一切菩萨。皆入出无量百千三昧禅定心尘之法。呼此为色无色界思惑。若七地思尽。上地应绝六尘。何故复言三贤十圣住果报。若住果报思不前尽。今明。如此见思通至上地。至佛方尽。故云唯佛一人居净土。唯佛一人能尽源。是故伏断如前分别(云云)。问界内必先断见。次思后无知。界外何意不尔。答界内为三途苦重。先断见次思后及无知。界外苦轻。故先枝后本。又思无知不障偏真。为见真理故先除见。界外尘沙是体上惑。远能障理。先却远障次除近障(云云)。复次三藏中。后身菩萨及超果二乘。见思同断亦先断思(云云)。不超果者。前后断耳。通教亦有超不超二义。别教前后断。圆教同断。前后之问但见一途耳(云云)。四明功用者。若分字解义。功论自进用论益物。合字解者。正语化他。五品之位。理虽未显观慧已圆。具烦恼性能知如来秘密之藏。堪为世间作初依止。依止此人犹如如来。当知。不久诣于道树近三菩提。一切世间皆应向礼。一切贤圣皆乐见之。若六根似解圆观转明。长别苦海。能以一妙音遍满三千界。随意之所至。一切天龙皆向其处听法。其人有所说法。能令大众欢喜。犹是第一依止。涅槃标四依。义通圆别。人师多约别判地前通名初依。登地至三地断见尽。名须陀洹。至五地侵思名斯陀含。是第二依。至七地思尽名阿那含。是第三依。八地至十地。欲色心三习尽。名阿罗汉。是第四依。若推圆望别。应约十住明三依。对住前为四依。若始终判者。五品六根为初依。十住为二依。十行十回向为三依。十地等觉为四依。从初住已上总论功用。若竖功未深横用不广。竖功若深横用必广。譬如诸树。根深则枝阔华叶亦多。初住竖破一分无明。获一分二十五三昧。显一分我性。论其实处不可思议。依于教门横则百佛世界。分身散影作十法界像。利祐众生。如是住住竖入倍倍转深。无明渐渐尽。三昧转转增。我性分分显横用稍稍广。千佛界万佛界恒沙佛界。不可说不可说佛界。遍如是界八相成道。教化众生。况余九法界身耶诸行诸地亦复如是。论其满足。唯佛与佛乃能究尽无明之源。故经言。如佛心中无无明。唯佛法王住究竟王三昧。毗卢遮那法身。横周法界竖极菩提。大功圆满胜用具足(云云)。五通诸位论粗妙者。小草止免四趣。不动不出中草虽复动出。智不穷源恩不及物。上草虽能兼济灭色为拙。小树虽巧功齐界内。故其位皆粗。大树实事同缘中道。皆破无明俱有界外功用。故此位为妙。而别教从方便门。曲迳纡回所因处拙。其位亦粗。圆教直门是故为妙。又三藏菩萨全不断惑。望圆教五品有齐有劣。同不断惑是故言齐。五品圆解常住。彼全不闻常住。是故为劣。若三藏佛位断见思尽。望六根清净位有齐有劣。同除四住此处为齐。若伏无明三藏则劣。佛尚为劣二乘可知。当知。三草蒙笼生用浅短。故其位皆粗。若干慧地性地。望五品位有齐有劣。例前(云云)。若八人六地见思尽。七地修方便。至佛断习尽。望圆教似解有齐有劣。例前可解当知。小树之位。未有干云婆娑之能。是故皆粗。若别教十信望五品位。有齐有劣。同未断惑是故为齐。十信历别五品圆解。此则为优。别教十住断通见思。十行破尘沙。十回向伏无明。秖与圆家十信位齐优劣(云云)。若登地破无明。秖与圆家初住齐。何者。若十地十品破无明。圆家十住亦十品破无明。设开十地为三十品。秖是圆家十住三十品齐。若与为论。圆家不开十住。合取三十心为三十品。与别家十地三十品等者。则十地与圆家十回向齐。若夺而为论。别家佛地与圆家初行齐。与而为论。别家佛地与圆家初地齐。故知。别教权说判佛则高。望实为言其佛犹下。譬如边方未静授官则高。定爵论勋。置官则下。别教权说虽高而粗。圆教实说虽低而妙。此譬可解。以我之因为汝之果。别位则粗。当知。大树虽巨围。要因于地方渐生长。是知圆位从初至后。皆是实说。实伏实断俱皆称妙(云云)。大论云。譬如有树名曰好坚。在地百岁。一出即长百丈。盖众树顶。此譬圆位也。六明位兴者。问权位皆粗。佛何意说耶。答为诸众生好乐不同。生善缘不同。知过改恶不同。当说取悟不同。是故如来种种诸说。皆有利益。若随界内好乐。说前两教位。若随界外好乐。说后两教位。生界内事善。说三藏位。生界内理善说通教位。生界外事善。说别教位。生界外理善。说圆教位。破界内事恶。说三藏位。破界内理恶。说通教位。破尘沙事恶。说别教位。破无明理恶。说圆教位。缘事入真说三藏位。缘理入真说通教位。从事入中说别教位。缘理见中说圆教位。为是义故诸位得兴。阶差高下无量矣。七明位废者。理本无位位为缘兴。缘既迭兴位亦迭谢。非是法华始复废也。须识诸破立意。不得妄破妄立。何者。元夫如来立三藏位。权生事善。事善既生济用若足。便须废也。通别位亦如是。此是如来破立之意。若毗昙婆沙中明菩萨义。龙树往往破之。谓其失佛方便。是故须破。申佛方便是故须立。此是龙树破立意。若常途大乘师。全不整理三藏。此则失佛方便。常途小乘师。探取经义释所弘之论。辨菩萨义。毗婆沙自说菩萨义。而不肯用取大乘经解三藏空有二门岂应相会。此有二过。一埋佛方便。二彰论主不解菩萨义。是故须破。纵令引经释大乘义。是何等大乘。若作通教大乘者。三乘同入真谛。至佛亦然。那得八地观中道破无明。作通义不成。是故须破。若作别教大乘义者。始从初心与二乘异。那得六地将罗汉齐。作别义不成。是故须破。又别是方便执权谤实。是故须破。往者人往义定。今窥见其过。是故须破申佛方便复应须立。即是今时破立之意。而圆教起自一师超三权。即一实境智。行位不与前同。若文理有会夷涂共游。失旨乖辙请从良导。先叙此意。次明废位也。若佛赴机兴废破立者。如无量义经云。无量法者从一法生所谓二道三法四果。二道者即顿渐也。三法者。即三乘也。四果者四位也。此无量法从一法生。何者。二道既是顿渐。顿即大道。日照高山且置未论。今明渐道之初即三藏教。教云。求佛当三阿僧祇劫修六度行。百劫种相乃可得佛。欲令生事善。故作是说。欲求佛者改恶从善。善立教废。即便破曰。岂有菩萨不断结惑。而得菩提。毒器不任贮食。此教即废行位皆废。本望果行因。无果可望。佛智佛位俱废。若约二乘辨废者。本令事行调心。从拙度见真。见真已教意即足。是故析教废。为此诸义故言废藏立通。元禀通教不学三藏者。不于此人论废立通之意为生理善。体法断惑从巧度入真教意即足。智者见空复应见不空。那得恒住于空。通教则废菩萨行智悉废。佛智位亦废(云云)。二乘但教废。余者(云云)。此通教通通通别。共般若意如上说。不共般若意。则有不废(云云)。故知。成论地论师秖见共般若意。不见不共意。中论师得不共意失共意。通教既具两意。于通菩萨及方便声闻。即是废义。住果声闻未是废义。不共菩萨则不废义(云云)。若别起时生界外事善。若破无知尘沙。事善既成教意即足。复须破此随他意语。是故别教教废。地前行位悉废。地上位及佛位皆废高归下。是故废别立圆。圆八番位皆是实位。故不须废。大经云。一切江河悉有回曲。一切丛林必有树木。诸教随情故有回曲。三草二木是佛方便。故非真实宜须废位。金沙大河直入西海。金银之树悉是宝林。非曲是直是故不废。昔从顿出渐渐不合顿。引渐入顿处处须废。今已会顿顿何须废。文云始见我身(云云)。是故一教不废。又云。但说无上道。此道不废。昔于一佛乘分别说三。三乘不合。欲令三合一处处须废。今会三归一同乘一乘。是故一行不废。昔四果隔别。谓罗汉辟支佛。菩萨习果。方便佛果。又四佛为四果。欲合此果处处须废。今草庵已破化城又灭。同至宝所。是故一果不废。若从是义三废一不废。然三教有废有不废。何者。从得道夜至泥洹夜。所说四阿含经。结为声闻藏。初教何曾废。成前人事善逗后人事善。故有废有不废。通教成前逗后亦如是。别教成前逗后亦如是。圆教有立有不立。初照高山已自是立。于三藏者不立。文云。始见我身入如来慧。即是前立。学小者今入佛慧。即是后立。中间可知。诸行智有废有不废。诸果位有废有不废。若历诸味。乳味有两教。一教行位亦废亦不废。一教行位不废。酪教行位有废有不废。生苏四教。三教行位有废有不废。一教行位不废。熟苏三教。两教行位有废有不废。一教行位不废。法华三教行位皆废。一教行位不废。但说无上道。同乘一宝乘俱直至道场。故三义皆不废。无量义云。二道三法四果不合。至法华皆合。故不论废。成道已来四十余年未显真实。法华始显真实相。传云。佛年七十二岁。说法华经(云云)。又教废行位不废。行位废教不废。俱废俱不废。云何教废行位不废。住果声闻犹在草庵。行位不废而教废也。云何行位废教不废。利根密益不待废教。早休行位者是也。云何俱废。三藏菩萨是也。云何俱不废。逗后缘者是也。通教别教例此可解(云云)。若就施权。三教行位立一不立。若就废权。三教行位废而一不废。若就利根一立三不立。若就钝根三立一不立。若就转钝为利。一立三不立。利钝合论亦立亦不立。亦废亦不废。若就平等法界。非立非不立。非废非不废。又废教更闻教。自有废教不更闻教。自有不废教更闻教。自有不废教不更闻教。云何废教更闻教者。如废六度事善。更闻亡三理善。云何废教不更闻教。如住果二乘废教已入灭。云何不废教更闻教。如逗次第学者。方等中并闻小大名者。云何不废不更闻。未废教而密入者。又废智更修智。不废智更修智。废智不修智。不废智不修智。云何废智更修智。三藏菩萨。废己智更修无生智。云何不废智更修智。住果声闻。不废己智薳复游观学无生智。实不用巧智断结也。又次第习者是也。云何不废智不修智。亦是住果声闻。生灭度想不肯修大也。如四弟子领解云我昔身体疲懈。但念空无相愿。于菩萨法都无愿乐之心者是也。及更逗后缘者是也。云何废智不修智。废三藏智菩萨退。为诸恶者是也。亦是废智已密入顿中。不修方便智是也。又废位更入位。废位不入位。不废不更入。不废而入。云何废位更入位。三藏菩萨废不断惑位入断惑位。云何废位不更入位。谓废位密悟顿者。不入次第位也。云何不废位不更入位。谓住果二乘是也。云何不废位而更入位。谓逗后缘者。亦是未废密悟。而入上位也。通教别教智位料简。亦应如此(云云)。问废更修可有益。废不更修有何益。答自有废修得益。自有诃废。闻虽不修而有耻小鄙劣。折其取证之心亦是有益。又齐其断结谓言无益。回心入大即是得益(云云)。八开粗位显妙位者。若破三显一相待之意可得如前。即三是一绝待之意。义则不尔。何者昔权蕴实如华含莲。开权显实如华开莲现。离此华已无别更莲。离此粗已无别更妙。何须破粗往妙。但开权位即显妙位也。开生死粗心者。明凡夫有反复。易发菩提心。生死即涅槃无二无别。即粗是妙也。若始从凡夫。发析体别圆四心者。亦是四位初心。皆是因缘所生心。即此因缘即空即假即中。与圆初心无二无别。诸初心是乳显妙。即是置毒乳中。即能杀人。杀有奢促。若按位而妙。即成假名妙。若进入方便成相似妙。若进入理即成分真妙(云云)。若开六度权位行者檀即因缘生法。即空即假即中。开檀得见佛性。乃至般若亦复如是。亦名置毒乳中即能杀人。按位即假名妙。若进方便成相似妙。若进入理成分真妙(云云)。方便声闻未入位者。开权显实亦如是。三藏断结位。若未开权永无反复。如焦种无芽。今开析空即假即中。如置毒酪中亦能杀人。按粗即妙是相似位。若进入随位判妙也。次开通教二乘菩萨亦如是。出假菩萨位者。决了此假假即是中。如置毒生苏而能杀人。按粗即妙是相似位。若进入随位判妙。若开别教十信位者同前。若开十住者同二乘(云云)。若开十行位者。同通教出假菩萨。若开十回向伏无明位。即此而中。是名置毒熟苏即能杀人。按粗即妙是相似位。若进入随位判妙。若登地之位不决了者。秖是拙度之位。今决此权令得显实。即是置毒醍醐而杀于人。按粗即妙。是十住位。若进入随位判妙。若决诸权或按位妙。或进入妙。无粗可待同成一妙。其义已显。今更譬说。譬如小国大臣来朝大国失本位次。虽预行伍。限外空官若大国小臣。心膂凭寄爵乃未高。他所敬贵。诸教诸位决粗入妙。虽得入流。欲比圆教八妙。犹是从钝中来。圆教发心虽未入位。能知如来秘密之藏。即唤作佛。初心尚然何况后位乎(云云)。九引涅槃五譬成四教位。若不将四教释譬。譬不可解。若非五譬判四教位。取信为难。若信经文则位义易晓解诸位意彼譬冷然。彼此相须可谓兼美者也。彼文云。凡夫如乳。须陀洹如酪。斯陀含如生苏。阿那含如熟苏。阿罗汉支佛佛如醍醐。此譬三藏五位。何者。凡夫全生未能除惑。菩萨亦尔。但得如乳。须陀洹破见革凡成圣。如乳变为酪。斯陀含侵六品思。故如生苏。阿那含欲界思尽。故如熟苏。阿罗汉支佛佛。皆断三界见思尽。故同称醍醐。故释论云。声闻经中称阿罗汉地为佛地。故共为一味也。问此经以三藏菩萨为上草。彼经云何以菩萨为乳味。答经取化他边强喻之上草。此中自证力弱。同凡夫为乳味(云云)。三十二云。凡夫如杂血乳。须陀洹斯陀含如净乳。阿那含如酪。阿罗汉如生苏。支佛菩萨如熟苏。佛如醍醐。此譬通教五位也。凡夫不断惑乳犹杂血。二果侵思未多。同初果如乳。三果欲思已尽故如酪。四果见思俱尽如生苏。支佛智利侵习小胜声闻。故共菩萨如熟苏。十地名佛地即是醍醐。前以菩萨同凡味。故知是三藏。今以菩萨同支佛。故知是通。若不作通释譬义。何由可解(云云)

妙法莲华经玄义卷第五上妙法莲华经玄义卷第五下

        天台智者大师说

第九卷。凡夫佛性。如牛新生血乳未别。声闻佛性如清净乳。支佛如酪。菩萨如生熟苏。佛如醍醐。此譬别教五位

乳譬无明血譬四住。凡夫具此故言杂血。十住已断四住之血。与二乘齐。故言声闻如乳。十住后心理明智利。类支佛侵习故言如酪。十行破尘沙如生苏。十回向破界外尘沙如熟苏。故言菩萨如生熟苏。登地破无明显佛性。得一身无量身。百佛世界八相作佛。故言佛如醍醐。二十五云。雪山有草名为忍辱。牛若食者即得醍醐。牛喻凡夫草喻八正。能修八正即见佛性。名得醍醐。此譬圆教。行大直道观一切众生即涅槃相。不复可灭。圆信圆行不由历别。于一生中即入初住。得见佛性。如牛食忍草。不历四味卓出醍醐。故知圆教意也。忍草譬境妙。牛譬智妙。食者譬行妙。出醍醐譬位妙。此圆意也。牛食余草血乳转变。历四味已方成醍醐。余方便教境智行位皆粗意也。前四譬即有四处明醍醐。四教明佛智各异。俱既称佛。同指佛智以为醍醐。藏通二佛不明中道。但取果头佛二谛智为醍醐。别教登地破无明。即能作佛。以中道理智为醍醐。圆教初住得中道智。亦称为醍醐。缨珞云。顿悟世尊。即此初住智为醍醐也。前两醍醐是权非实。故有教而无人。别教醍醐名权理实。圆教醍醐名理俱实。以是义故。前三位五味皆粗。圆教一味皆妙。第二十七卷云。譬如有人置毒乳中。则能杀人。乃至醍醐亦能杀人。此譬两用。一通约渐顿明不定教。处处皆得见佛性也。二约行不定。行人心行譬之如乳。实相智譬之以毒。毒有殒命之能。此智有破无明之力。久远劫来。说实相毒置于凡夫心乳毒慧开发不可为定。或于初味发。或于后味发。不得次第往判。故言置毒乳中。乃至醍醐遍五味中。悉有杀义。若众生始于凡地。得闻华严即便见理入佛慧者。此是血乳杀人。若先得十住今华严得悟。即是酪中杀人。十行悟者是生苏杀人。十回向悟者。是熟苏杀人。诸地更悟是醍醐中杀人。若过去。先是圆教中假名相似之位。今闻华严得悟者。亦是乳中杀人。亦是酪生熟等苏中杀人。若先是诸住诸行等位。今更闻华严得增道损生。即是于醍醐中杀人(云云)。若历三藏教中。凡夫及方便位。及菩萨位。闻三藏教。于中即能密见中道。即是乳中杀人。若四果位密见中道。即是酪中杀人。显露教中无此事也。若通教中。凡夫及三乘方便位。若闻通教密见佛性。即是乳中杀人。若入位者秘密而去。即是酪中杀人。若菩萨道种智中去。即是生苏杀人。九地中去。即是熟苏杀人。十地中去即是醍醐中杀人。通教声闻但有秘密中杀人。无显露不定杀也。若历别教中。十信闻教去。即是乳中杀人。三十心中去。即是酪杀人。生苏熟苏等杀人。登地去。即是醍醐杀人也。若圆教中发。始闻经即破无明见佛性。是乳中杀人。六根清净去。是酪生熟苏等杀人。若初住去是醍醐杀人。若有行人。历诸教四譬五味。过已方得入圆教醍醐中杀人者。此是破三显一相形待为妙。若置毒乳中。味味悉杀人者。此是开权显实。于一切法中即见中道。故文云。汝等所行是菩萨道。不须更改途易辙而求真实。即粗见妙故以置毒为喻。诸经悉有秘密置毒之妙。而未有显露历味入妙。亦无显露决粗即妙。至此法华方有二意。同乘宝乘皆开佛知见。显露事彰。是故独称为妙。其意在此。次第入妙开粗即妙。各有两意。按位开入。有增进开入。若言决了声闻法是诸经之王。闻已谛思惟得近无上道。即是按位显妙。增道损生即是升进入妙。故法华独称妙也。十明妙位始终者。真如法中无诠次。无一地二地。法性平等常自寂然。岂应分别初后始终。良由平等大慧观于法界无有若干。能破若干无明。显出无若干智慧。约此智慧无始而始。即是初阿。无终而终即是后茶。无中而论中。即是四十心。虽复差别则无差别。故名不思议位也。如下文云。声闻缘觉如竹林。新发不退菩萨等。皆不能知。除诸菩萨众信力坚固者。声闻缘觉所不能知。此简三藏通教两种二乘也。三藏菩萨缘真不及声闻。声闻尚不知此菩萨那得知。通教菩萨入真之智。与二乘不殊二乘不知彼菩萨亦不知。今标二乘不知。两处菩萨亦不能测。发心不知。即指别教十信。不退不能知。即指别教三十心。十住位不退。十行行不退。十回向念不退。此三不退皆不能知。三藏中不退。尚不及二乘。通教中不退止等二乘。二乘不知岂重举菩萨。今标发心不退者。则拟别教中人也。信力者是假名位。坚固者是铁轮位。如此等位闻经即解。故得为妙似位之始也。初开佛知见。乘是宝乘游于东方。即是真位之始也。三方是中位直至道场。过茶无字可说。即是终位也。如此诸位乘何等乘。乘有三种。谓教行证。若言是乘从三界出。到萨婆若中住。住有二义。一取证故住。即通教意也。二所乘极故住。即别圆意也。初心凭教所诠。信教立行得出三界。无明未破未有所证。故不见真。但乘教乘来至此耳。我圆教中其谁是耶。谓五品弟子。能善发大心。长别三界苦轮海。即其人也。教乘既息证乘未及。以似解慧进修众行。则以行为乘。从方便三界中出。到初住萨婆若中住。我圆教中其谁是耶。谓十信心六根净者。即其人也。初住乃至等觉更增道损生者。此以证为乘。从因缘三界。乃至无后三界中出到妙觉中。过茶无字可说。故言到萨婆若中住。前来诸乘犹有上法。不得称住茶无上法。是故言住。住无住处即妙位之终。复次别教十住破见思。是行三百由旬。十行破尘沙为四百。十回向伏无明为五百。十地断无明。此分见中道即为宝所也。圆教六根清净时。是行四百。破无明入初住。是行五百。二乘闻经破无明惑。开佛知见得记作佛者。即是决了诸粗位。过五百由旬来入初住。即是妙位之始得于证乘游于东方也若至本门中增道损生。更乘证乘游于南方。是进入十行位也。西方是进入十回向。北方是进入十地也。又如文云。说是如来寿命长远时。六百八十万亿那由他恒河沙人。得无生法忍。即是十住。复千倍菩萨。得闻持陀罗尼即十行。复有一世界微尘数菩萨。得乐说辩才即十回向。复有一世界微尘数。得旋陀罗尼即初地。三千大千微尘。得不退即二地。二千国土微尘。能转清净法轮即三地。小千国土微尘。八生当得菩提即四地。七生当得即五地。六生当得即六地。五生当得即七地。四生当得即八地。三生当得即九地二生当得即十地。一生当得即等觉。过此一生即是过茶无字。即是妙觉地妙位之终也。将前列位中。引法华经文。入此中共作一科者。即不烦也

○第五三法妙者。斯乃妙位所住之法也。言三法者即三轨也。轨名轨范。还是三法可轨范耳。此即七意。一总明三轨。二历别明三轨。三判粗妙。四开粗显妙。五明始终。六类三法。七悉檀料简。一总明三轨者。一真性轨。二观照轨。三资成轨。名虽有三秖是一大乘法也。经曰。十方谛求更无余乘。唯一佛乘。一佛乘即具三法。亦名第一义谛。亦名第一义空。亦名如来藏。此三不定三三而论一。一不定一一而论三。不可思议。不并不别伊字天目。故大经云。佛性者。亦一非一。非一非非一。亦一者。一切众生悉一乘故。此语第一义谛。非一者。如是数法故。此语如来藏。非一非非一数非数法不决定故。此语第一义空。而皆称亦者郑重也。秖是一法亦名三耳。故不可单取不可复取。不纵不横而三而一。前明诸谛。若开若合若粗若妙等。已是真性轨相也。前明诸智若开若合若粗若妙。是观照轨相也。前明诸行。若开若合若粗若妙。已是资成轨相也。前明诸位。秖是修此三法所证之果耳。若然何以重说。重说有三义。一者前境智行。是因中所乘之三轨。今明乘是大乘。已至道场证果所住之三轨也。二者前作境智等名别说。今作法名合说。三者前直尔散说不论本末。今远论其本即是性德三轨。亦名如来之藏极论其末即是修德三轨。亦名秘密藏。本末含藏一切诸法。从性德之三法。起名字之三法。因名字之三法。修观行之三法。因观行之三法。发相似之三法。乃至分证之三法。究竟之三法。自成三法化他三法。为是义故宜应重说也。私谓一句即三句。三句即一句。名圆佛乘。记中既从如来藏一句出诸方便。此乃别判例应通开。非一者数法故。指此为如来藏。开出三藏中三乘事相方便。非一非非一不决定故。指此一句为第一义空。开出通教三人即事而真。亦一者。一切众生悉一乘故。指此一句为第一义谛。开出别教独菩萨乘。此诸方便悉从圆出。故经言。于一佛乘分别说三。即此义也。二历别明三法者。先须识如来开合方便。然后乃解总揽三法为一大乘也。佛从何法开诸权乘。如大经明佛性非一。如是数法说三乘故。当知。诸乘数法为如来藏所摄。佛于此藏。开出声闻缘觉。及诸菩萨通别等乘。何者。诸乘既是方便如来藏。又是事从事出方便故。言诸权为如来藏摄耳。又依经故。大经云。声闻僧者名有为僧。又云。六波罗蜜福德庄严。又云。声闻之人定力多故不见佛性当知。定力即是福德。福德秖是有为。胜鬘称为有漏。例如界内见思未破为有起作。故名有为。取理不当故名有漏。非智慧法故名福德。今以下望上亦应如是。二乘未破变易犹是有为。无明未脱故言有漏。非中道智故名福德以是故知。方便诸乘悉为资成所摄。皆从大乘一句偏出。非究竟法故。云于一佛乘分别说三。即此意也。亦是于一佛乘分别说五。亦是分别说七。亦是分别说九。若依此释。如来藏句。开出种种方便诸权乘法也。次历四教各论三法者。三藏中以无为智慧名观照轨。正为乘体助道成乘具。名资成轨。正助之乘断惑入真。真是真性轨。教来诠此故以教为乘也。缘觉亦尔。菩萨以无常观为观照。功德肥为资成。坐道场断结见真为真性。此教诠真乘是教乘从三界中出。到萨婆若中住。言教已尽故无教乘。真不能运故证非乘故。有索车之意(云云)。二通教。以真性轨为乘体。何以故。即色是空事中有理。此理即真。故为乘体。以即空慧为观照。众行为资成。此教诠真乘是教乘。从三界出到萨婆若中住。菩萨出三界已。用行为乘。净佛国土教化众生。乃至道场乃可名住。亦是有教无人。无谁住者。亦是教谢证寂。无复运义。亦有索车之意(云云)。三明别教三法者。以缘修观照为乘体。诸行是资成。以此二法为缘修智慧。慧能破惑显理。理不能破惑。理若破惑。一切众生悉具理性。何故不破。若得此慧则能破惑。故用智为乘体。故大经云。无为无漏名菩萨僧。即是一地二地。乃至十地智慧。名智慧庄严。以此智慧运通十地。故为乘体。然摄大乘明三种乘。理乘随乘得乘。理者。即是道前真如。随者即是观真如。慧随顺于境。得者一切行愿熏习。熏无分别智。契无分别境。与真如相应。此三意一往乃同于三轨。而前后未融。何者九识是道后真如。真如无事。智行根本种子。皆在梨耶识中熏习成就。得无分别智光成真实性。是则理乘本有。随得今有道后真如。方能化物。此岂非纵义。若三乘悉为黎耶所摄。又是横义。又滥冥初生觉。既纵既横与真伊相乖。元夫如来初出便欲说实。为不堪者。先以无常遣倒。次用空净荡着。次用历别起心。然后方明常乐我净。龙树作论申佛此意。以不可得空洗荡封着习应一切法空。是名与般若相应。此空岂不空于无明。无明若空种子安在。净诸法已点空说法。结四句相。此语虚玄亦无住着。如病除已乃可进食。食亦消化那得发头。据阿黎耶出一切法。本之见慢全自未降。封此新文若长冰添水。故知。彼论非逗末代重着众生。乃是界外一途法门耳。又阿黎耶。若具一切法者。那得不具道后真如。若言具者。那言真如非第八识。恐此犹是方便。从如来藏中开出耳。若执方便巨妨真实。若是实者。执之又成语见多含儿苏恐将夭命(云云)。若能善解破立之意。于诸经论净无滞着也。四明圆教三法者。以真性轨为乘体。不伪名真不改名性。即正因常住。诸佛所师谓此法也。一切众生亦悉一乘。众生即涅槃相。不可复灭。涅槃即生死无灭不生。故大品云。是乘不动不出。即此乘也。观照者。秖点真性寂而常照。便是观照。即是第一义空。资成者。秖点真性法界。含藏诸行无量众具。即如来藏三法不一异。如点如意珠中论光论宝。光宝不与珠一不与珠异。不纵不横三法亦如是。亦一亦非一。亦非一非非一。不可思议之三法也。若迷此三法即成三障。一者界内界外尘沙。障如来藏。二者通别见思障第一义空。三者根本无明障第一义理。若即尘沙障达无量法门者。即资成轨得显。若即见思障达第一义空者。观照轨得显。若即无明障达第一义谛者。真性轨得显。真性轨得显名为法身。观照得显名为般若。资成得显名为解脱。此两即是定慧庄严。庄严法身。法身是乘体。定慧是众具。下文云。其车高广众宝庄校。是名圆教行人所乘之乘。到萨婆若。过茶无字可说。无字可说。亦应无乘可运。若自行运毕乘义则休。若权化未毕运他不休故文云。佛自住大乘。如其所得法。定慧力庄严。以此度众生。即其义也。譬如御者运车达到。犹名为车。果乘亦尔。犹名为运。复次何必一向以运义释乘。若取真性不动不出。则非运非不运。若取观照资成能动能出。则名为运。秖动出即不动出。即不动出是动出。即用而论体。动出是不动出。即体而论用。即不动出是动出。体用不二而二耳。例如转不转。皆阿鞞跋致。动不动皆是毗尼。以是义故发趣不发趣皆名为乘也(云云)。三明粗妙者。三藏于有为福德。论三法为乘。四念处是闻慧。乘于教乘到四善根。四善根乘于行乘到见谛。见谛乘于证乘到无学。既是权法出三界外以真为证。证则不运不见实乘。呜呼自责。欲问世尊为失为不失。即此意也。半字渐引非究竟义。是故三法皆粗也。通教即空慧三法为乘巧。余意大同。干慧地乘于教乘。性地乘于行乘。八人见地乘于证乘。此亦偏说是故为粗。别教以资成资于观照。观照开于真性。三法为乘。十信乘教。十住乘行。十地乘证。到妙觉萨婆若中住。缘修成即谢。唯真修在。若尔资成在前。观照居次。真性在后。此三竖别纵非大乘。此三并异横非大乘。是方便法。是故为粗也。圆教点实相。为第一义空。名空为纵。第一义空即是实相。实相不纵此空岂纵。点实相为如来藏。名之为横。如来藏即实相。实相不横此藏岂横。故不可以纵思。不可以横思。故名不可思议法。即是妙也。秖点空藏为实相。空纵藏横实相那不纵横。秖点空为如来藏。空既不横藏那得横点如来藏为空。藏既不纵空那得纵点实相为空藏。实相非纵非横。空藏亦非纵非横。宛转相即不可思议。故名为妙。秖点如来藏为广点第一义空为高。故言其车高广。如来藏即实相。故其车非广。第一义空即实相。故其车非高。秖实相是空那得非高。秖实相是如来藏那得非广。又点实相为如来藏。故言众宝庄校。又多仆从而侍卫之。点实相为第一义空。故言有大白牛。肥壮多力行步平正。其疾如风。智慧无染名为白。能破惑故名多力。中道慧名平正。入无功用故其疾如风。不思议三法共成大车。岂有纵横并别之异。如是教乘不纵不横。五品所乘到于似解。如是行乘不纵不横。似解所乘到于十住。如是证乘不纵不横。十住所乘到于妙觉萨婆若中住故名妙乘。又云是乘微妙清净第一。故瓦官建讲。人梦听者驾乘阗门而出。彼处建讲。人梦黄衣满路以相则之邪正明矣。若将此粗妙等乘约五味者。乳教一粗一妙。酪教一粗。生苏三粗一妙。熟苏二粗一妙。众经悉带纵横方便。说不纵不横之真实。故言为粗。今经正直舍方便。故加之以妙(云云)。四开粗显妙者。约大经三句也经言。佛性亦一者。一切众生悉一乘故。此是不动不出之一乘。故具足三法不纵不横。夫有心者皆备此理。而其家大小都无知者。是故为粗。今示众生诸觉宝藏。耘除草秽开显藏金。一切无碍人一道出生死。十方谛求更无余乘。唯一佛乘。是故为妙。经言。佛性亦非一非非一。数非数法不决定故。若执缘修智慧定能显理。慧自非理则照用不明。不见佛性。是故为粗。今开定执之慧即不决定慧。即慧而理即理而慧。不执着数。定三定一不着非数。非三非一。如此乃名无著妙慧。能破一切定相及不定相。亦无能破所破。如轮王能破能安。如日除闇生物。如医除膜养珠。即是大乘不纵不横之妙慧也。经言。佛性亦非一说三乘故。即是三乘五乘七乘等。诸方便乘。若住诸乘但是事善。及以偏真通入处近。是故为粗。今若决了诸乘。即是如来藏。藏名佛性。从人天善乃至别乘。皆不动本法即是于妙。当知。三句摄一切法。无非佛性。悉皆是妙无粗可待即绝待妙也。五明始终者。不取五品教乘为始。乃取凡地一念之心。具十法界十种相性。为三法之始。何者。十种相性秖是三轨。如是体即真性轨。如是性性以据内。即是观照轨。如是相者。相以据外即是福德是资成轨。力者是了因是观照轨。作者是万行精勤即是资成。因者是习因属观照。缘者是报因属资成。果者是习果属观照。报者是习报属资成。本末等者。空等即观照。假等即资成。中等即真性。直就一界十如论于三轨。今但明凡心一念即皆具十法界。一一界悉有烦恼性相恶业性相苦道性相。若有无明烦恼性相。即是智慧观照性相。何者。以迷明故起无明。若解无明即是于明。大经云。无明转即变为明。净名云。无明即是明。当知。不离无明而有于明。如冰是水。如水是冰。又凡夫心一念即具十界。悉有恶业性相。秖恶性相即善性相。由恶有善离恶无善。翻于诸恶即善资成。如竹中有火性。未即是火事。故有而不烧。遇缘事成即能烧物。恶即善性未即是事。遇缘成事即能翻恶。如竹有火。火出还烧竹。恶中有善。善成还破恶。故即恶性相是善性相也。凡夫一念。皆有十界识名色等。苦道性相。迷此苦道生死浩然。此是迷法身为苦道。不离苦道别有法身。如迷南为北无别南也。若悟生死即是法身。故云苦道性相即是法身性相也。夫有心者。皆有三道性相。即是三轨性相。故净名云烦恼之俦为如来种。此之谓也。若言如是力如是作者。菩提心发也。即是真性等萌动。如是因者。即是观照萌动。如是缘者。即是资成萌动。如是果者。由观照萌动成习因。感得般若习果满也。如是报者。由资成萌动为缘因。感得解脱报果满也。果报满故法身亦满是为三德究竟满。名秘密藏。本末等者。性德三轨冥伏不纵不横。修德三轨彰显不纵不横。冥伏如等数等妙等。彰显如等数等妙等。故言等也。亦是空等假等中等(云云)。六类通三法者。前以三轨之法。从始以至终。即是竖通无碍。今欲横通诸法悉使无碍。类通诸三法。何者。赴缘名异得意义同。粗通十条余者可领。三道三识三佛性三般若三菩提三大乘三身三涅槃三宝三德。诸三法无量止用十者。举其大要明始终耳。三道轮回生死本法。故为初。若欲逆生死流。须解三识。知三佛性。起三智慧。发三菩提心。行三大乘。证三身。成三涅槃。是三宝利益一切。化缘尽入于三德。住秘密藏(云云)。一类通三道者。真性轨即苦道。观照轨即烦恼道。资成轨即业道。苦道即真性者。下文云。世间相常住。岂不即彼生死而是法身耶烦恼即观照。观照本照惑。无惑则无照。一切法空是也。文云。诸法从本来常自寂灭相即烦恼是观照也。照如薪生火。文云。于诸过去佛。若有闻一句。皆已成佛道。又云。深达罪福相遍照于十方。即是闻于体达烦恼之妙句也。资成即业道者。恶是善资无恶亦无善文云。恶鬼入其心。骂詈毁辱我。我等念佛故。皆当忍是事。恶不来加不得用念。用念由于恶加(云云)。又威音王佛所。着法之众闻不轻言。骂詈打拍。由恶业故还值不轻。不轻教化皆得不退。又提婆达多是善知识。岂非恶即资成。三轨即三道是为理性。行于非道通达佛道。五品观行行于非道。通达佛道。六根清净相似。行于非道通达佛道。十住去即分真。行于非道通达佛道。妙觉究竟。行于非道通达佛道(云云)。二类通三识者。庵摩罗识即真性轨。阿黎耶识即观照轨。阿陀那识即资成轨。若地人明阿黎耶。是真常净识摄。大乘人云。是无记无明随眠之识。亦名无没识。九识乃名净识互诤(云云)。今例近况远。如一人心复何定。为善则善识。为恶即恶识。不为善恶即无记识。此三识何容顿同水火。秖背善为恶背恶为善。背善恶为无记。秖是一人三心耳。三识亦应如是。若阿黎耶中。有生死种子。熏习增长即成分别识。若阿黎耶中有智慧种子。闻熏习增长。即转依成道后真如名为净识。若异此两识。秖是阿黎耶识。此亦一法论三。三中论一耳。摄论云。如金土染净。染譬六识。金譬净识。土譬黎耶识。明文在兹何劳苦诤。下文譬如有人至亲友家醉酒而卧。岂非阿黎耶识。世间狂惑分别之识起。已游行以求衣食。岂非阿陀那识。闻熏种子稍起增长。会遇亲友示以衣珠。岂非庵摩罗识。庵摩罗识名无分别智光。若黎耶中。有此智种子。即理性无分别智光。五品观行无分别智光。六根清净相似无分别智光。初住去分真无分别智光。妙觉究竟无分别智光。粗妙(云云)。三类通三佛性者。真性轨即是正因性。观照轨即是了因性。资成轨即是缘因性。故下文云。汝实我子我实汝父。即正因性。又云我昔教汝无上道。故一切智愿犹在不失。智即了因性。愿即缘因性。又云。我不敢轻于汝等。汝等皆当作佛。即正因性。是时四众以读诵众经。即了因性。修诸功德即缘因性。又云。长者诸子若十二十乃至三十。此即三种佛性。又云。种种性相义。我已悉知见。既言种种性。即有三种佛性也。若知三轨即三佛性。是名理佛性。五品观行见佛性。六根相似见佛性。十住至等觉分真见佛性。妙觉究竟见佛性。是故称妙(云云)。四类通三般若者。真性是实相般若。观照是观照般若。资成是文字般若。具如上释境智行三妙之相。故下文云。止止不须说我法妙难思。又云。是法不可示言辞相寂灭。即实相般若。我及十方佛乃能知是相。唯佛与佛乃能究尽。又云。我所得智慧微妙最第一。即观照般若。又云。我常知众生行道不行道。随应所可度为说种种法。若干言辞随宜方便。即是文字般若。又云。如来知见广大深远广大深远即实相般若。如来知见称广大深远即观照般若。若言方便知见皆已具足。即文字般若。故知三轨亦三般若之异名耳。若三智在三心属三人。是则为粗。三智在一心中。不纵不横是则理妙。五品观行三般若六根净相似三般若。四十心分真三般若。妙觉究竟三般若也。五类通三菩提者。真性轨即实相菩提。观照轨即实智菩提。资成轨方便菩提。故下文云。我先不言汝等皆得阿耨三菩提。非实非虚非如非异。不如三界见于三界。即实相菩提。我成道已来甚大久远。即实智菩提。我说少出家近伽耶城得三菩提。即方便菩提。若就弟子明三菩提者。若我遇众生尽教以佛道。即实相菩提。安住实智中。我定当作佛。又云。佛子行道已。来世得作佛。乘是宝乘直至道场。即是修成实智菩提。授八相记即方便菩提。不一异者名之为如。不决了名粗。决了名为妙。一切众生理性菩提。五品名字菩提。六根相似菩提。四十一位分真菩提。妙觉究竟菩提(云云)。六类通三大乘者。真性即理乘。观照即随乘。资成即得乘。故下文云。佛自住大乘。如其所得法定慧力庄严。住大乘即理乘。定慧庄严即随乘。所得法即得乘。佛自住大乘是理乘。于道场知已是随乘。导师方便说是得乘。又舍利弗。以本愿故说三乘法。是得乘随乘。又是乘微妙清净第一是理乘。于一佛乘是理乘。分别说三是得乘随乘。不纵不横妙开粗妙。历七位(云云)。五品名字乘。六根相似乘。四十一位分真乘。妙觉究竟乘(云云)。七类通三身者。真性轨即法身。观照即报身。资成即应身。若新金光明云。依于法身得有报身。依于报身得有应身。此即如前所明。依于境妙得有智妙。依于智妙得有行妙。彼文云。佛真法身犹如虚空。应物现形如水中月。报身即天月。此文云。佛自住大乘。即是实相之身。犹如虚空。定慧力庄严慧如天月。定如水月。又云。唯佛与佛乃能究尽诸法实相。即是法身。我所得智慧微妙最第一即是报身。名称普闻。即是应身。又非生现生等。是应身也。或示己身即法身报身。或示他身即报应。我以相严身。光明照十方。为说实相印。实相印即法身。照十方即应身。相严身即报身。又深达罪福相遍照于十方。即报身。微妙净法身。即法身。具相三十二。即应身。三轨名异义。即三身。故普贤观云。佛三种身从方等生。法界性论云。水银和真金能涂诸色像。功德和法身处处应现往。若此三身不纵不横。妙决了三身入法身妙。历七位妙(云云)。八类通三涅槃者。地人言。但有性净方便净。实相名为性净涅槃。修因所成为方便净涅槃。今以理性为性净涅槃。修因所成为圆净涅槃。此则义便。薪尽火灭为方便净涅槃。此文便若将修因所成。为方便涅槃者。以薪尽火灭为何等涅槃。故知应有三涅槃。三涅槃即是三轨。文云。是法不可示言辞相寂灭。又云。诸法从本来常自寂灭相。是性净涅槃。又云。皆以如来灭度而灭度之。即圆净涅槃。又云。我成佛已来甚大久远。久修业所得。慧光照无量。亦是圆净涅槃。数数唱生处处现灭。于此夜灭度如薪尽火灭。岂非方便净涅槃。大经题称大般涅槃。翻为大灭度。大者其性广博即据性净。度者到于彼岸智慧满足。即据圆净。灭者烦恼永尽断德成就。即据方便净。此三涅槃即是三轨也。九类通一体三宝者。真性即法宝。观照即佛宝。资成即僧宝。故法性不动名不觉。佛智契理故佛名为觉。事和理和故僧名和合。思益云。知觉名为佛。知离名为法。知无名为僧。此是一体三宝。故下文云。佛自在大乘佛是佛宝。大乘是法宝。如其所得法以此度众生。即是与理和。复与众生和。即是僧宝。世间相常住名法宝。于道场知已名佛宝。导师方便说。上与理和下与众生和名僧宝。一体三宝。非一之一不三之三。此之三一不纵不横。称之为妙。历七位(云云)。十类通三德者。大经三德共成大涅槃。此经三轨共成大乘。彼明法身德此云实相。彼云佛性者亦一。一切众生悉一乘故。亦是指实相为一乘。彼处明般若德。此经明其智慧门难解难入。我所得智慧微妙最第一。乃至决了声闻法。是诸经之王。皆是般若。彼经明解脱德。此经明数数示现现生现灭。随所调伏众生之处自既无累令他解脱。乃至收取万善事中功德。悉得证果。岂非解脱。二经义合。碌碌之徒随名异解。譬闻天帝不识憍尸。唯知涅槃佛性之文。不见双树有一乘之旨。彼文亲说佛性亦一。一即一乘而人云。此乃涅槃一乘是佛性。法华一乘非佛性。若言法华不明佛性者。涅槃不应遥指云八千声闻。于法华中得受记莂。如秋收冬藏。见如来性更无所作。而人云。涅槃有遥指之文。此中无佛性之语。今据此文。种种性相义而我皆已见。既言种种。何独简于佛性耶。又世间相常住。于道场知已导师方便说。岂非佛性之文耶。论云佛性水常不轻知众生有佛性。又涅槃三德为秘密藏。安置诸子秘密藏中。我亦不久当入其中。此即自他俱入秘密。此经云。佛自住大乘。以此度众生。终不以小乘济度诸众生。悉以如来灭度而灭度之。如是自他俱入如来灭度。灭度秖是涅槃。涅槃秖是秘藏。释论云。法华为秘藏。两经文义宛宛恒同。何故诸人苟欲抗异。若文义舛隔。作同想无罪。今文义本合。离之何福。但涅槃以佛性为宗。非不明一乘义。今经以一乘为宗。非不明佛性义。赴机异说其义常通也若三德纵横即是粗。不纵横即是妙。历七位(云云)。七悉檀料简者。问十种三法及余一切。皆是三轨者。唯应三轨。何意异说。答众生机宜不同。应随机设逗。悉檀方便引接耳。随俗故异。称便宜故异。逐对治故异。令人入道故异。朝三暮四抚众狙而皆悦。苦涂水洗养婴儿以适时。善巧赴机故方圆任物。譬千车而同辙。岂守一而疑诸。今通用四悉檀。历十法论妙不妙。具说三轨共成大乘。大乘之中。备有三法及一切法。不相混乱。即是世界悉檀。资成资发智慧以生善。故是为人悉檀。观照破惑诸恶灭。故是对治悉檀。真性实理为第一义悉檀。一段众生宜以大乘名说得四利益也。备说三德为大涅槃。虽三点上下而无纵。表里而无横。一不相混三不相离。即世界悉檀。善利殃衅不干。故得挺然累表是故解脱即为人悉檀。般若如金刚随所拟皆碎。即是对治悉檀。法身即第一义也。一段众生闻三德名。即获四利矣。举初举后中间例然。次明妙不妙。论云。三悉檀是世谛。心所行处可破可坏。第一义悉檀。是心不行处。诸佛圣人心所得法。不可破坏。即是真谛。若然者。比四悉檀为二谛所摄。更有中道复云何摄。若不摄中但是藏通之意。此悉檀为粗。今言俗有真无。是隔异法。便是三悉檀心所行处。可破可坏。中道第一义非有非无。有无不二则无隔异。无异即真谛。前三悉檀所通止至化城。化城非实故可破可坏。可坏为粗。今中道无异。又通至宝所。无能过无能灭。故不可坏称之为妙。若余经说中道第一义悉檀。与此经不殊。但余经带阿罗汉所得。为第一义悉檀。故不称妙。此经正直舍方便。但有圆实四悉檀。是故为妙。若不决三悉檀入第一义。是复为粗。若决一一悉檀。皆有第一义者。是则为妙。五品弟子假名四悉檀。六根净相似四悉檀。初住至等觉分真四悉檀。妙觉究竟四悉檀。是故称妙。此五番明妙。从因至果以辨自行妙。半如意珠竟妙法莲华经玄义卷第六上

        天台智者大师说

○第六明感应妙者。上来四妙名为圆因。三法秘藏名为圆果。境妙究竟显名毗卢遮那。智妙究竟满名卢舍那。行妙究竟满名释迦牟尼。三佛不一异不纵横。故名妙果。释论云。稽首智度无子佛者。果地圆极非复因位。故称无子。果智寂照有感必彰。故明感应妙也。即为六。一释感应名。二明相。三明同异。四明相对。五明粗妙。六明观心释名又三。一释名。二四悉檀帖解。三料简释名者。正法华云。无数世界广说经法。世尊所为感应如是。今故用为名。而经中机语缘语。并是感之异目。悉语众生。且从机释义则易见。缘感例可解。机有三义。一者机是微义。故易云。机者动之微。吉之先现。又阿含云。众生有善法之机。圣人来应也。众生有将生之善。此善微微将动。而得为机。若将生善为机。此结为促。今明可生之善。此语则宽。如弩有可发之机。故射者发之。发之则箭动。不发则不前。众生有可生之善。故圣应则善生。不应则不生。故言机者微也。二者古注楞伽经云。机是关义。何者。众生有善有恶。关圣慈悲。故机是关义也。三者机是宜义。如欲拔无明之苦。正宜于悲。欲与法性之乐。正宜于慈。故机是宜义也。次明应者。亦为三义。一者应是赴义。既言机有可生之理。机微将动圣人赴之。其善得生。故用赴而释应。二者应是对义。如人交关。更相主对。若一欲卖一不欲买。则不相主对。若卖买两和。则贸易交决贵贱无悔。今以众生譬买。如来譬卖。就机以论关。就应以论对。故以对释应也。三者应是应义。既言机是于宜。宜何等法应以慈悲之法。是善恶所宜。悲则宜救苦。慈则宜与乐。随以何法应其所宜。故以应释应也。二明四悉檀帖释者。机应各有三义。即四悉檀意也。若微以释机赴以释应者。是赴乐欲之心也。何但心善可生。名之为欲。如草木无心。亦称可生欲生将生。故知赴此善生。是随乐欲即世界悉檀。明机应也。若关以释机对以释应。更相对当。以悲对其苦机。以慈对其善机者。即是随对治悉檀。以明机应也。次以宜释机。以应释应者。即是为人第一义也。宜以如此等法。与其机感相宜。宜生事善。即为人悉檀。宜生理善即是第一义悉檀也。三料简者。问何意于理善称第一义悉檀耶。答理善明生理闇必灭。终不理恶灭方始理善生。故于理善称第一义悉檀也。若事善生。事恶未必去。事恶去事善未必生。事是隔别对治悉檀。正是药病相对。故不于中开第一义悉檀。其意在此。问众生机圣人应。为一为异。若一则非机应。若异何相交关而论机应。答不一不异。理论则同如是故不异。事论有机应是故不一。譬如父子天性相关。骨肉遗体异则不可。若同者。父即子。子即父。同又不可。秖不一不异而论父子也。众生理性与佛不殊。是故不异。而众生隐如来显。是故不一。不一不异而论机应也。又同是非事非理故不异。众生得事圣人得理。又圣人得事凡夫有理。故论异(云云)。问为用法身应。为用应身应。若应身应。应身无本何能应。若用法身应。应则非法。答至论诸法非去来今。非应非不应而能有应。亦可言法应。亦可言应应。法应则冥益。应应则显益。分别冥显有四义。如后说(云云)。第二明机应相者。约善恶明机相。约慈悲论应相。若善恶为机为单为共解者不同。或言单恶为机。引经云。我为断一切众生疮疣重病。又云。如有七子。然于病者心则偏重。如来亦尔。于诸众生非不平等。然于罪者心则偏重。又云。如来不为无为众生而住于世。又无记是无明。终属恶摄。此即单以恶为机。或单以善为机。引大经云。我观众生。不观老少中年贫富贵贱。有善心者即便慈念。此则单善为机。或云。善恶不得独为机。何者。如金刚后心即是佛。众善普会善无过此。此何得为机耶。虽云佛佛相念。此是通语而无拔无与。故知单善不得为机。单恶不得为机者。如阐提极恶不能感佛。大经云。唯有一发不能升身。即是性德理善。此是通机终不成感也。或取善恶相带为机者。从阐提起改悔心。上至等觉。皆有善恶相带。故得为机。是故约此善恶明其相也(云云)。次约慈悲以明应相者。或单以慈为应。经云。慈善根力象见师子。广说如涅槃(云云)。或单以悲为应。如请观音。或游戏地狱大悲代受苦。或合用慈悲为应。何者。良以悲心熏于智慧。能拔他苦。慈心熏于禅定能与他乐。下文云。定慧力庄严。以此度众生。论云。水银和真金。能涂诸色像。功德和法身。处处应现往。岂是水银真金单能涂色像耶。当知。慈悲合论应也。问众生善恶有三世。何世为机。圣法亦有三世。何世为应。过去已谢现在不住。未来未至。悉不得为机亦不得为应。云何论机应耶。答若就至理穷核三世。皆不可得。故无机亦无应。故经言。非谓菩提有去来今。但以世俗文字数故。说有三世。以四悉檀力随顺众生说。或用过去善为机。故言。我等宿福庆今得值世尊。又如五方便人。过去习方便者。发真则易不习则难。是故以过去善为机。或可以现在善为机。故言。即生此念时佛于空中现。或可以未来善为机。未生善法为令生故。又如无漏无习因而能感佛也。故大论云。譬如莲华在水。有已生始生未生者若不得日光翳死不疑。众生三世善。若不值佛无由得成(云云)。恶亦如是。或以过去之罪今悉忏悔。现造众恶今亦忏悔。未来之罪断相续心遮未来故名之为救。何者。过去造恶障现善不得起。为除此恶是故请佛。又现在果。苦报逼迫众生而求救护。又未来之恶与时相值。遮令不起。故通用三世恶为机。应亦如是。或用过去慈悲为应。故云。我本立誓愿欲令得此法。或用现在慈悲为应者。一切天人修罗。皆应至此为听法故。未度令度也。又用未来为应者。即是寿量中未来世益物也。亦如安乐行品中云。我得三菩提时引之令得住是法中。若通论三世善恶皆为机。别论但取未来善恶。为正机也。何者。过去已谢现在已定。秖为拔未来恶生未来善耳。问若未来为正机者。四正勤意云何。答此已属通意。今更别答者。秖为过去恶遮未来善。故勤断过去恶。秖为过去善不增长。增长者即是未来善也。是故四正勤中。言虽过去意实未来(云云)。问未来未有。佛云何照。答如来智鉴能如是知。非下地所知仰信而已。何可分别。问为是众生自能感。由佛故感。如来自能应。由众生故应。答此应作四句。自他共无因。破是性义悉不可无此四句。故则无性无性故。但以世间名字。四悉檀中而论感应能所等而能应属佛。所应属众生。能感属众生所感属佛。若更翻叠作诸语言。世谛名字则乱不可分别。虽作如此名字。是字不住。是字无所有故。如梦如幻(云云)。问既善恶俱为机者。谁无善恶。此皆应得益耶。答如世病者。延医而有差不差。机亦如是。有熟不熟则应有远有近。三明机感不同者。即为三意。一就四句论不同。二就三十六句论不同。三就十法界论不同。但众生根性百千。诸佛巧应无量。随其种种得度不同故。文云。名色各异种类若干。如上中下根茎叶等。随其种性各得生长。即是机应不同意也。今略言为四。一者冥机冥应。二者冥机显应。三者显机显应。四者显机冥应。其相云何。若过去善修三业现在未运身口。藉往善力名此为冥机也。虽不现见灵应而密为法身所益。不见不闻而觉而知。是名为冥益也。二冥机显益者。过去殖善而冥机已成。便得值佛闻法。现前获利是为显益。如佛初出世。最初得度之人。现在何尝修行。诸佛照其宿机自往度之。即其义也。三显机显应者。现在身口精勤不懈。而能感降。如须达长跪佛往祇洹。月盖曲躬圣居门阃。如即行人道场礼忏能感灵瑞。即是显机显应也。四者显机冥应者。如人虽一世勤苦。现善浓积而不显感。冥有其利。此是显机冥益。若解四意。一切低头举手福不虚弃。终日无感终日无悔。若见喜杀寿长好施贫乏。不生邪见。若不解此者。谓其徒功丧计忧悔失理。释论云。今我疾苦皆由过去。今生修福报在将来。正念无僻。得此四意也。二就三十六句论机应不同者。前冥显互论略举四句。若具足辨者。用四机为根本。所谓冥机显机亦冥亦显机。非冥非显机。冥是过去显是现在。冥显是过现。非冥非显是未来。如佛为阐提说法(云云)。于一句中复为四句。所谓冥机冥应冥机显应。冥机亦冥亦显应。冥机非冥非显应。余三机亦如是。四四即成十六句。机既召应。应亦有十六句。一机而感四应。一应而赴四机。机应各为十六。合成三十二句。就前根本四句。便是三十六句机应也。三就十法界论机应不同者。秖约一人身业机具三十六。约三业即有一百八机。约三世三业。则有三百二十四。一界既尔。十法界即有三千二百四十机应不同。就自行既尔。化他亦然。合则六千四百八十机应。此就历别十法界。如此若就十法界交互则增九倍。都六万四千八百机应也。四明机应相对者。即有四意。一明诸有苦乐。与三昧慈悲相对。二者机关等相对。三者三十六句相对。四者别圆相对。诸三昧相对者。诸机乃多不出二十五有。诸应乃多不出二十五三昧。地狱有有善恶之机关无垢三昧慈悲之应。论其恶者。即有黑业恶见思恶尘沙恶无明恶。论善则有白业善即空善即假善即中善是名地狱机也。无垢三昧慈悲为应者。初修无垢三昧。观地狱界。因缘观慈悲。即空观慈悲。即假观慈悲。即中观慈悲。以因缘观时。悲拔地狱黑业苦。以因缘观时。慈与白业乐。以即空观时悲拔见思苦。以即空观时。慈与无漏乐。以即假观时。悲拔尘沙苦。以即假观时。慈与道种智乐。以即中观时。悲拔无明苦。以即中观时。慈与法性乐。是为地狱有善恶之机。以关无垢三昧。慈悲之应拔苦与乐。相对义也。二者机关相对者。地狱界中黑业之恶。有微义有关义有宜义。如此三机。即关无垢三昧时。慈悲有赴义有对义有应义。地狱白业。亦有六义相对。即空见思尘沙无明等。善恶皆具六义相对(云云)。三者三十六句。相对者地狱黑白业。具有冥机冥应。冥机显应。显机显应。显机冥应即关无垢三昧慈悲。冥显四应赴于地狱。见思即空。尘沙种智无明中道等。皆具四机四应相对(云云)。又地狱有冥显三十六机。即对无垢三昧三十六应(云云)。四者别圆相对者。若地狱有历别之机。三昧应即历别。若有圆普之机。三昧应亦圆普。若历别机起三昧别应。一有业谢。余有业未必谢。三恶思尽。余有思未必尽。地狱道种智明。余有未必明。地狱佛性了了。余有未必了了。若作圆机圆应者。地狱自在业未究竟。余有亦未究竟。一有见思未尽。余有亦未尽。一有道种未明。余有亦未明。一有佛性未了了。余有亦未了了。一有了了。余有亦了了。乃至一有业自在。余有业亦自在。分别地狱机应相对如上说。余二十四有机应相对。例亦如是。问颇有善机恶应。恶机善应。偏机圆应。圆机偏应不。答无方适时亦有此义。净名云。或时现风火照令知无常。即恶应于善也。妙庄严信受邪恶。三菩萨应为妻子。即善应于恶。圆机偏应者。一切智愿犹在不失。不失即圆机。教声闻法即偏应也。偏机圆应者。先引三车后与一大。领解云。无上宝聚不求自得。即其义也。拔乐与苦例此可知(云云)。第五明粗妙者。即为三意。一明机之粗妙。二明应之粗妙。三明开粗显妙。一机粗妙者。如乐间地狱。此乐因微善故。立世毗昙云。人养六畜饮饴温清者。在热地狱得冷间。寒地狱得温间。若从此义。乐间得论十法界机。阿鼻无乐间则无事善。云何具十。然阿鼻有性善不断故。又近世虽无事善远劫或有。恶强善弱冥伏未发。若遇因缘发亦何定。是故阿鼻得具十机。即判粗妙。九界机为粗。佛界机为妙。粗机召方便应。此机有熟未熟方便应有浅有深。机熟者被应。未熟者未应。应浅深者。如从无间得之于间。出地狱至畜生。出畜生至鬼出三恶至人天。出人天至二乘等。悉是机之生熟应之浅深。悉属粗机摄。妙机召究竟妙应。妙机亦有生熟。妙应亦有浅深。如慈童女在于地狱。代人受罪即得生天。此乃妙机浅熟近在乎天耳。其余例可知。二明应有粗妙者。圣人慈悲誓愿。愿持于行如物有胶。任运与机相着。故慈善根力手出师子。若无誓愿。虽观苦乐不能拔与。以慈力故随机粗妙。先熟先应后熟后应。三藏通教等圣。亦得有应。但是作意神通。譬如图写经纪乃成核论无本。何者。灰身灭智无常住本。约何起应若别接通。别惑未断亦不得应。纵令赴物皆名粗应也。若别圆两教。初心伏惑未能有应。初地初住三观现前。证二十五三昧。法身清净。无染如虚空湛然应一切。无思无念随机即对。如一月不降百水不升。而随河短长任器规矩。无前无后一时普现。此是不思议妙应也。又如明镜表里清澈。一像千像无所简择。不须功力任运像似。是名妙应。此是相待论感应妙也。三开粗显妙者。若九界机粗。一界机妙。未得法身应粗。得法身应妙者。诸大乘经华严等。明粗妙相隔二乘不闻不解如哑如聋无量义经明粗妙。从一理出生无量粗妙。机应一理为妙。生出无量为粗。此则从妙出粗隔而未合。今经无量还为一。此则开权显实。秖粗是妙。何者。本显一理作诸方便。方便即是真实。故云凡有所作唯为一事。未曾暂废。譬如三草二木。秖是一地所生。即是同源机一。一雨所润即是同受应一。愚者未解。谓草木四微永非是地。智者了达四微生秖是地变。四微灭秖是地还。岂有草木而非于地耶。此即开权而显实。决了声闻法是诸经之王。九法界机皆佛界机。四圣之应。无非妙应也。第六明观心(云云)。

○第七明神通妙者。此为四意。一明次第。二名数。三同异。四粗妙。来意者。前论机应。止是辨其可生可赴之相。若正论化用益他。即是三轮不思议化。谓身轮口轮他心轮。普门品但有二文。而兼得三意。游于娑婆世界。即是身轮而为说法即是口轮。如见莲华大知池水深。若见说法大则知智慧大。故两轮兼示他心轮也。又化他多示两轮。示心轮少。从多但二故无心轮。经言。其见闻者。悉皆得度也。示身轮者。即是示药树王身如意珠王身。示口轮者。即是示毒鼓天鼓。此是慈悲熏于身口。则有二身示现二鼓宣扬。若示心轮。即是示随自意随他意等也。亦是同于病行婴儿行。上辨机感相关。而妙理难显。应须神通发动现于瑞相。密表乎理。世人以蜘蛛挂则喜事来。[鴰-口+(幻-ㄠ)]鹊鸣则行人至。小尚有征大焉无瑞以近表远亦应如是。二名数者。诸经所出名数不同今且依六种。谓天眼天耳他心宿命如意身通无漏等也。此六皆称神通者。如璎珞云。神名天心通名慧性。天心者天然之心也。慧性者通达无碍也。毗昙亦云障通无知若去。即发慧性也。当知。天然慧性与六法相应。即能转变自在。故名神通。地持力品云。神谓难测知。通谓无壅碍。此解与璎珞同。天心即是难测知义。慧性即是无壅碍义。然此六法修无前后。证无次第。用亦任时。故众经列次不同也。释论云。幻术事是虚诳法。法于草木诳惑人眼。物实不变。神通不尔。实得变法。使物实变。如地有成水之理。水有成地之义。若金银得火则融。水遇寒则结。火寒是融结法。结则实结融则实融。若得天然慧性。则实能如此。变用自在。所变水火令他实得受用。而非其果报。但是神通一时所作耳。三明神通不同者。鬼道报得通。人能服药亦得通。外道因根本禅亦发通。诸天报得通。二乘依背舍胜处一切处。修十四变化发得神通。六度菩萨因禅得五通。坐道场时能得六通。通教菩萨因禅得五通。依体法慧得无漏通。别教地前依禅发五通。登地发正无漏通。任运常照。不以二相见诸佛土。圆教通者。依今经及普贤观。以鼻舌两根。以为六数。菩萨处胎经同。他心宿命入意根摄。然经文明鼻通。最委悉。取其互用无壅舌根取四辩无碍。能以一妙音遍满三千界。而不取知味。知味是报法。经云。诸根通利智慧明了也。六根皆智慧即互用意也。今云。六根之通不因事禅而发。此乃中道之真。真自有通。任运成就不须作意。故名无记化化禅。不别作意故名无记。任运常明如阿修罗琴。化复能化故言化化。中道真通任运如此。与余通异。论其修习皆缘实相常住之理。文云。得是常眼根清净。既言是常即本性清净常性无垢染。毗昙婆沙云。六入殊胜本自尔故。鸯掘云。所谓彼眼根。于诸如来常具足无减修。了了分明见。乃至耳鼻舌身意。皆于诸如来常具足无减修。了了分明闻知等也。彼者于佛为自。于众生为彼。众生谓为无常。于如来是常也。减修者。依禅而修名为减修。依实相修名无减修。不见佛性名不了了见。若见佛性名了了见。又见实相理名了了。识法界事名分明也。见有二种。一相似见。二分真见。相似者如六根清净中辨论其真见。如华严所明。佛眼耳鼻舌身意也。此经中亦明真身通相。所谓普现色身。示一切众生所喜见身。即是外身通也。现身如琉璃。十方诸佛悉于身中现。即是内现身通也。眼耳鼻舌等内外示现。亦例如此。是则圆教神通异于前辨(云云)。问若以六根为六通者。云何功德有增减。答大论四十云。鼻舌身同称觉眼称见耳称闻意称知。三识所知为一。三识所知为别。而三识助道法多。故别说。三识不尔故合说。又三识但知世间事。故合说。三识亦知世间亦知出世间故别说。又三识但无记法。三识或缘善恶无记等。又三识能生三业因缘。故别说也。若例此义三根种种义强。故有千二百功德。三根力弱故但八百功德者。盖一途别说。非经圆意。正法华功德正等等千。今经显六根互用。将三根足二百向三根而互用耳。自在无碍。能等如正法华说。能缩如身眼鼻之八百。能盈如耳舌意千二百。经云。若能持是经功德则无量。如虚空无边。其福不可限。互用之意彰矣。四明粗妙者。若言神通度物。非但变己身同其正报。亦变己国土同其依报。如缨珞云。起一切国土应。起一切众生应也。若应同正报者。即是示为十法界像也。若应同依报者。即是同十界所依处也。若应同四恶趣者。用观恶业慈悲熏无记化化禅。应作地狱等形质。黑发缠身猴猿鹿马。大鹫鵽鸟修罗等像。各各皆见同其事业。若应人天身者。是用观善业中慈悲熏无记化化禅。作善道身。如后身菩萨。正慧托胎堕地七步。盥洗手足杨枝自净。纳妃生子厌世出家。乃至天像亦复如是。各各皆见同其事业。若应作三藏二乘者。是用析空慈悲熏无记化化禅。起老比丘像。共僧布萨律仪规矩。各各皆见同其事业。若应通教者。是用即空慈悲熏无记化化禅。作体法应。观无生习应苦空等。悉不可得。各各皆见同其事业。若应别教者。是用即假即中慈悲熏无记化化禅。起渐顿应。示修恒沙佛法。各各皆见同其事业。若应圆教者。是用即中慈悲熏无记化化禅。起圆顿应。示修一中无量无量中一。皆各各见同其事业。如是应同正报。不可称计。可以意知不可以言尽(云云)。若得此意。往望渐顿五味教中。用神通者。乳教所用神力若多若少。但表两意。一粗一妙。三藏用神力若多若少。但为一粗。方等用神力若多若少。三粗一妙。般若用神力若多若少。二粗一妙。此经神力若多若少。唯为一妙。所以序品中瑞相有十。咸皆表妙也。地皆严净表理妙。放眉间光表智妙。入于三昧表行妙。天雨四华表位妙。栴檀香风表乘妙。四众咸有疑表机。见万八千土表应。此二明感应妙也。地六种动表神通妙。天鼓自鸣及而为说法。表说法妙。天龙大众欢喜。表眷属妙。又见佛子修种种行表利益妙。此用神变若少若多。俱表妙也。文云。今佛入于三昧。是不可思议现希有事。现希有事是妙神通也。若应同依报者有两意。若国土苦乐由于众生。非佛所作。佛但应同而已。若作折伏摄受者。佛鉴机缘或作苦国。或作乐国。苦乐由佛不关众生。今且释初意。大论云。有国土纯声闻僧。或国土纯菩萨僧。或菩萨声闻共为僧。或净或秽。何故差别。皆由乘戒缓急。若戒缓乘亦急亦缓者。即是秽土以声闻菩萨共为僧。以戒缓故五浊土秽。乘亦缓故是开三乘。乘亦急故是显一乘。娑婆是也。戒急乘亦缓亦急者净土也。戒急故土无五浊。乘亦缓故开三乘。亦急故显一安养是也。乘缓戒急者。即是净土纯声闻为僧。此可知也。戒缓乘急即是秽国。纯菩萨为僧此亦可知。净秽差别。悉由众生高下苦乐。不关佛也。若作伏摄义者。国由于佛不关众生。佛以观恶慈悲与无记化化禅合。起于秽国。折伏摄受四趣众生也。以善业慈悲与无记化化禅合。折伏摄受两趣众生也。佛以折空六度等慈悲与无记化化禅合。或起于秽国或起净国。折伏摄受声闻菩萨两界众生也。佛以体空慈悲与无记化化禅合。或起净国或起秽国。折伏摄受通教声闻菩萨两界众生也。佛以历别慈悲与无记化化禅合。或起秽国净国。折伏摄受别界菩萨众生也。佛以即中慈悲与无记化化禅合。或起净国或起秽国。折伏摄受圆界菩萨众生也。如是种种为国不同。皆由如来神力转变。今将此依正转变待三教。作意神通悉名为粗。譬如图画。尽思竭力终不似真。名之为粗。若明镜写容任运相似。名之为妙。方便神通譬如粗画。中道任运即对即应。譬于净镜。故为妙也。就无记化化禅。所作神变自论粗妙。若为九界众生用方便神力作净作秽若广若狭。悉名为粗。若为佛法界众生。用真实神力作净作秽若广若狭。悉名为妙。如经放眉间光照万八千土。及三变土田。比余经神力何足为多。但为开发大事。故言妙也。又约五味论粗妙者。乳教一粗一妙。酪教一粗。生苏三粗一妙。熟苏二粗一妙。法华一妙。又诸经妙同粗异。粗有二种。一难转粗。二易转粗。易转者。于诸经中已得为妙。难转者。今于法华无复两粗。但有一妙。唯一大佛事因缘。曾无他事。假同九界神通。众生自谓他事。于佛常是佛事。客作自谓贱人。长者审知是子。此即相待神通妙也。又诸经诸粗神通隔妙神通者。今经皆开权显实。同妙神通。是名绝待明妙神通。此略记不周悉也

○第八说法妙者。诸法不可示言辞相寂灭。有因缘故亦可说示前药珠二身。先以定动。今毒天二鼓后以慧拔。演说一乘无三差别。皆悉到于一切智地。其所说法皆实不虚。是故次说法妙。即为六意。一释法名。二分大小。三对缘同异。四判所诠。五明粗妙。六明观心。释法名者。三世佛法虽多无量。十二部经收罄无不尽。先出达摩郁多罗有七种分别。体一。相二。制名三。定名四。差别五。相摄六。料简七。体一者。经以名味章句为体。经无不然故体一也。相二者。长行直说有作偈赞颂两种相别。何者。以人情喜乐不同。有好质言有好美语故。相别有二也。制名三者。修多罗祇夜伽陀三部。就字句为名。不就所表。授记等八部不就所表。又不就字句从事立称。方广一部名从所表。何者。修多罗等三部。直说法相可即名以显所表。如苦集灭道依名即显所表。故就名以为名也。授记等经所表之法。不可但以言说要寄事方乃得显。如授记经从事为名。止明行因得果道理。理托事彰。事以言辨。如法华中与声闻授记。彰一切皆当得成佛。寄授记以彰所显故名授记经。无问自说经者。圣人说法皆待请问。然亦为众生作不请之师。故无问自说。又佛法难知人无能问。若不自说众则不知为说不说。又复不知为说何法。故无问自说。乃所以彰所说甚深唯证。是以寄无问自说。以彰所显也。因缘经者。欲明戒法必因犯彰过。过相彰现方得立制。此亦托因缘以明所显也。譬喻经者。法相微隐。要假近以喻远。故以言借况寄况以彰理也。本事本生经者。本事说他事。本生说自生。因现事以说往事。托本生以彰所表。名本事经。托本生以彰所行。名本生经也。未曾有经者。说希奇事。由来未有者未曾有也。示法有大力有大利益。托未曾有事以彰所表也。论义经者。诸部中言义隐覆。往复分别得明所显。寄论义以明理也。故授记等八经从事立称。方广一部从所表为名者。方广之理。虽以名说而妙出名言。虽寄事以彰。然不可如事而取。故不就名不就事。就所表以为名也。定名有四。修多罗名线经。经体是名字。而名从况喻祇夜偈陀当体为名。授记无问自说论义等三经。体事合目。自余从事也。差别者。修多罗有九种。经云。从如是至奉行一切名修多罗。是则修多罗名通而体总。皆名为经。故名通。就文字经体分为十二部。故体总也。第二就总修多罗中。随事分出十一部。即对十一部余直说法相者。是别相修多罗。三者论义经。解释十一部经。是则十一部为经本。当知。论所解释前十一部。皆是修多罗。又杂心中修多罗品。亦对论以经为修多罗。又如婆修槃驮解提婆百论。论为经本。亦名论为修多罗。又经云。除修多罗。余四句偈以为偈经。即对四句偈经余长行说者。是修多罗。又云。祇夜名偈颂修多罗。即对祇夜颂偈。所颂即是修多罗也。又如分别三藏。以敷置理教为修多罗。对别毗尼阿毗昙也。又如经说。从佛出十二部经。从十二部经出修多罗。对十二别教以通教为修多罗。是九中初二偈亦是也。偈陀者有四种。如言法华有阿閦婆等偈。涅槃二万五千偈。是则偈经。复是通总。若四句为偈。一字一句得名为经。非一字一句皆名为偈。但以圣言巧妙章句成就数句为偈。故通得名偈。二除修多罗余四句为偈。三偈中重颂者名祇夜。当知。不重颂偈名为偈经。四如修多罗通总。随事克分别为异部。以直说为修多罗。当知。偈中亦随事克分。若授记因缘等。别为异部。以不随事。直尔偈说名为偈经。祇夜者名为重颂。颂有三种。一颂意。二颂事。三颂言。颂意者。颂圣意所念法相及事。若颂心所念法相。则名偈陀经。若颂心所念授记等事。则随事别为异经颂事谓授记等事。亦随所颂事别为异经。颂言者。若颂随事之言随事别为异经。若颂直说修多罗者。名为重颂祇夜经也。授记者果为心期名记。圣言说与名授。授记有二种若与诸菩萨授佛记莂。是大乘中授记。若记近因近果。是小乘中记也。无问自说有二种。一理深意远人无能问。二非不可问。但听者宜闻。佛为不请之师。不请之师不待问自说也。方广有二种。一语广。二理广。相摄者。就修多罗中出十一部。若偈与直说相对言之。修多罗中得出九部。但无二偈。偈陀中得出十部。但无直说修多罗也。祇夜中得出九部。无修多罗亦无偈经也。料简有无(云云)。释法名者。上起教中已说。今标名互有不同。翻译多异。今依大智论。标名者。一修多罗。此云法本。亦云契经。亦线经。二祇夜此云重颂。以偈颂修多罗也。三和伽罗那。此云授记。四伽陀此云不重颂。亦略言偈耳。四句为颂。如此间诗颂也。五优陀那。此云无问自说。六尼陀那。此云因缘。七阿波陀那。此云譬喻。八伊帝目多伽。此云如是语。亦云本事。九阇陀伽。此云本生。十毗佛略。此云方广。十一阿浮陀达摩。此云未曾有。十二优波提舍。此云论议。部者部别各有类从也。经者。外国云修多罗。此云线经。线能贯穿经能经纬。言能持法如线如经然。阿毗昙杂心中说修多罗五义者。乃是彼论师解义非翻名也。世俗亦对纬名经。而训经为常。如物经亘始终。始终时别而物无改异。不改异故名之为常。修多罗者。诸经中直说者。谓四阿含及二百五十戒。出三藏外。诸摩诃衍经直说者。皆名修多罗也。祇夜者。诸经中偈。四五七九言句少多不定。重颂上者皆名祇夜也。和伽罗那者。说三乘六趣九道劫数。当得作佛。若后尔所岁。当得声闻支佛。后尔所岁当受六趣报。皆名授记。夫授记法面门放五色光。从上二牙出照三恶道。下二牙出照人天。光中演说无常无我安隐涅槃。遇光闻法者。三途中身心安乐。人中癃残者差。六欲天厌患欲乐。色天厌禅乐。光照十方遍作佛事。还绕七匝从佛足下入。是记地狱道。[跳-兆+尃]入髀入脐入胸入口入肩间入顶入者。是记佛道。论不见记修罗光。当是开鬼道出修罗。从容在于髀脐之间耳。伽陀者。一切四言五言七九等偈。不重颂者。皆名伽陀也。优陀那者。有法佛必应说。而无有问者。佛略开问端。如佛在舍婆提毗舍佉堂上。阴地经行自说优陀那。所谓无我无我所。是事善哉。是名优陀那。又如般若中。诸天子赞须菩提所说。善哉善哉。希有世尊。难有世尊。是名优陀那。乃至佛灭后诸弟子。抄集要偈。诸无常偈作无常品。乃至婆罗门品。皆名优陀那也。尼陀那者。说诸佛本起因缘。佛何因缘说此事。修多罗中有人问。故为说是事。毗尼中有人。犯是事故结是戒。一切佛语缘起事。皆名尼陀那。阿波陀那者。与世间相似柔软浅语。如中阿含长譬喻。长阿含大譬喻。亿耳二十亿耳譬喻等。无量譬喻皆名阿波陀那。伊帝目多伽有二种。一者结句。言我先许说者。今已说竟。二者更有经名一目多伽。有人言因多伽目多伽。名出三藏及摩诃衍。何等是。如净饭王强逼千释令出家。佛选堪得道者五百人将往舍婆提。令离亲属。身子目连教化。初中后夜专精不睡。以夜为长后得道还本国。从迦毗罗婆林五十里。入城乞食。觉道路为长。时有师子来礼佛足。为三因缘说偈(云云)。说此三事本因缘。故名一目多伽也。阇陀伽者。说菩萨本曾为师子。受猕猴寄。攫胁肉贸猴子。于病世作赤目鱼。施诸病者。或作飞鸟救于泫溺。如是等无量本生多有所济。皆名阇陀伽也。毗佛略者。所谓摩诃衍般若经。六波罗蜜经华首法华佛本起因缘云法云大云。如是等无量诸经。为得阿耨三菩提故。说此毗佛略也。阿浮陀达摩者如佛现种种神力。众生怪未曾有。放光动地种种异相。皆名阿浮陀达摩也优波提舍者。答诸问者。释其所以广说诸义。如是等问答解义。皆名优波提舍也。佛自说论义经。迦栴延所解。乃至像法凡夫人如法说者。亦名优波提舍经也。二明分法大小者。此经指九部为入大之本。则九部是小三部是大。盖别语耳。通而为言。小亦有记莂六道因果。又阿含中。亦授弥勒当作佛记。岂非授记经。亦有自唱善哉无问而说。声闻经中。以法空为大空。故成论中云。正欲明三藏中实义。实义者空。是阿毗昙所不申。而成论申于空。空即广经。当知。小乘通具十二部也。故涅槃云。先虽得闻十二部经。但闻名字不闻其义。今因涅槃得闻其义。又云。先虽得闻十二部经。我意犹谓故不如是大涅槃经。大品亦云。魔作比丘为菩萨说声闻十二部经。有经言。大小乘各具十二部。若信六部通大小乘。不信六部互不相通。按此者。即是大小俱有十二部也。但是小乘中说。非大乘之义。故别让三存九。何者。小乘灰断无如意珠身。故无广经。假令以法空为广说之文。小乘根钝说必假缘。无天鼓任鸣。少无问自说。虽有授记记作佛少。又涅槃第七云。九部中不明佛性。是人无罪。例此而言。十二部中不明佛性。是人有罪。有人言。大乘九部除因缘譬喻论义。大乘人根利不假此三。斯亦别论通语大乘。何得无此三经耶。有经言。小乘但让广经一部。有十一部。无方广者。大乘说如来是常。一切众生皆有佛性。正理为方包富为广。又理融无二亦名为等。声闻中所无但十一部耳。若言小乘定有九。不应复有十一部。既取十一亦通有十二。为缘别说。或让三或让一。以判大小乘(云云)

妙法莲华经玄义卷第六上(终)妙法莲华经玄义卷第六下

        天台智者大师说

三明对缘有异者。缘即是十因缘法所成众生。而此众生皆有十界根性熟者先感。佛知成熟未成熟者。应不失时。若众生解脱缘未熟不可全弃。对此机缘。止作人天乘说。不作修多罗等名。故天竺外典无十二部名。亦无其意。此间儒道亦无斯名。意义皆阙。若法身为王示十善道。亦不滥用此名。故地持中。说种性菩萨能自熟。又能熟他有二乘种性。及佛种性者。随法熟之。无种性者。以善趣熟。善趣熟者即是其义。种性熟者如下说。若深观行者妙得其意。以邪相入正相。用无碍辩。约邪经外典。作十二部义。胡为不得而非正对缘说也。次约十因缘所成众生有小乘根性。对此机说通则十二。别则或九或十一(云云)。若对十因缘所成众生有菩萨机者。不作别说。但明十二部经。今总论如来对四缘说十二部法。有两种四教不同。一者就隐显共论四教。隐即秘密教。显即顿渐不定教。秘密既隐非世流布。此置而不论。若对四法界众生。通说十二部。别说或九部或十一部。名渐法说也。若对两法界众生。通说十二部。此说顿法也。或对四法界。或对两法界。或作别说或但通说。此说不定法也。二者直就显露渐教中。更明四教者。即是三藏通别圆也。三藏教直对三法界别说或九或十一。通教对四法界。通说十二部法也。别教对两法界通说十二部法。圆教对一法界。通说十二部法。前以无记化化禅。与诸慈悲合。示现身轮。或为国师道士儒林之宗父母兄弟。乃至猴猿鹿马。同事利益不可称说。今口轮说者。例如前用诸慈悲。熏无记化化禅种种不同。百千万法不可说。不可说故龙宫象负。渧海研山。八万四千法藏不可穷尽。虽复无崖。以十二部往收罄无不尽也。四明所诠者。若委论其意。出四教义中今略引诠意若说人天乘。诠界内思议之俗。永不诠真。若为渐教人别说九部十一部。乃至通十二部者。初正诠思议之俗谛。傍诠思议之真谛。中正诠思议之真谛。傍诠思议之俗谛。后正诠不思议之真谛。傍诠不思议之俗谛也。乃至双诠不思议之真俗(云云)。若说顿十二部者。正诠不思议之真。傍诠不思议之俗。若说不定者。此则不可定判其诠。若约渐中四教明诠者。三藏正诠思议真。傍诠思议俗。若为三藏菩萨者。正诠思议俗。傍诠思议真。若通教二乘正诠思议真。傍诠思议俗。若为通教初心菩萨同二乘。若为后心菩萨正诠于俗。傍诠于真。若为别教初心。正诠界内之真俗。傍诠界外之真俗。若为中心正诠界外之真俗。傍诠界内之真俗。若为后心双诠界内外之真俗。若为圆教初中后心。圆诠界外不思议之真俗(云云)。五明粗妙者。即为五。一约理。二约言。三约所诠。四约众经。五正约此经。一就理妙者。一切诸法无非中道。无离文字而说解脱。文字性离即是解脱。一切所说即理而妙。譬如龙雨雨而处处不同。或水或火或刀杖理亦如是。理具情乖顺耳。乖故为粗理顺为妙。二约言辞者。如佛得道夜至泥洹夕。常说般若。常说中道。而一音演法随类异解。一音巧说是则为妙。异类殊解自有粗妙。三就所诠者。若对六道众生说人天乘者。此诠有为。能诠所诠俱粗。若对钝根三藏五门。诠于生灭四谛理。此则能诠所诠俱粗。若通教体法五门。比于三藏析门。体门能诠虽巧。而所诠犹是真谛。所诠亦粗。若别教五门能诠为粗。所诠中道为妙。若圆教五门能诠所诠。俱皆是妙也。四就众经者。华严诠别诠圆。三藏诠偏。方等四种诠。般若三种诠。法华唯一诠。又诸经诠妙与法华不异。而带粗诠粗诠不得合妙。是故为粗。法华不尔。佛平等说如一味雨。正直舍方便但说无上道纯是一诠。又云。昔毁呰声闻。而佛实以大乘教化。又云。汝等所行是菩萨道。此则融粗令妙。如此两意异于众经。是故言妙。譬如良医能变毒为药。二乘根败不能反复。名之为毒。今经得记即是变毒为药。故论云余经非秘密。法华为秘密也。复有本地圆说诸经所无。在后当广明(云云)。五正就此经。明妙十二部者。如修多罗名直说。今经直说中道佛之智慧。不说六道二乘菩萨等法。唯说佛法。故直说为妙祇夜妙者。重颂长行中道之说耳。故知。祇夜亦妙。伽陀者。如龙女献珠喜见说偈孤然特起。此偈明于刹那顷便成正觉。称叹于佛成菩提事。喜见孤起叹佛容颜甚奇妙。故知。孤起伽陀妙也。本事妙者。即是二万佛所教无上道。不教余事。即是本事妙也。本生妙者。明十六王子生身生为王子。法身生为佛子。即是本生妙也。因缘者。结缘覆讲大乘。系珠不论小乘人天等缘。是名因缘妙也。未曾有妙者。天华地动二眉间光。三变土田等。是不可思议未曾有事妙也譬喻妙者。经题以法譬为名。譬于开三显一。何曾譬于余事。即譬喻妙也。优波提舍妙者。身子问佛。佛答诸佛智慧门。龙女智积问答论法华事。智积云。我见释迦经无量劫。方成菩提。不信此女须臾成佛。此执别疑圆。龙女云佛自证知。以圆珠献佛。此以圆答别。此即提舍妙也。无问妙者。如文云。无问而自说。称叹所行道。从三昧安详而起。告舍利弗说佛智慧。又宿世因缘吾今当说。即是无问妙也。授记妙者。授三根佛记。皆安住实智中。为天人所敬。即授记妙也。方广妙者。其车高广智慧深远等。即是方广妙也。当知。此经从初直说。乃至优波提舍十二意足。而皆是妙。此即待粗明说法妙也。开粗显妙者。昔十二十一九部不说实者。今无别实异昔不实。昔但言广不明理广。今开言广即理广也。开昔之异显今之同。即是绝待明说法妙也。第六欠观心(云云)

○第九眷属妙者。就此为五。一明来意。二明眷属。三明粗妙。四明法门五辨观心。所言次第者。若无说而已。说必被缘。缘即受道人也。已受道故即成眷属。譬如父母遗体揽此成身得为天性。天性亲爱故名眷。更相臣顺故名属。行者亦尔。受戒之时。说此戒法授于前人。前人听闻即得发戒。师弟所由生也。禅亦如是。授安心法如教修行。即得发定。是为我师我是弟子。慧亦如是。说诸法门转入人心由法成亲。亲故则信。信故则顺。是名眷属也。他土余根皆利。随所用尘起之。令他得益。此土耳根利故偏用声尘。故二万佛时教无上道。十六王子覆讲法华。从是已来恒为眷属。世世与师俱生。或人天眷属。或三乘眷属。或一乘眷属。故身子云。今日乃知真是佛子。昔教五人得真无漏名佛子。菩萨不发真名为外人。于法华发大乘解。自称昔日非真佛子。今说一实之道。从闻悟解法身得生。从佛口生。是闻慧中法身生。从法化生是思慧中法身生。得佛法分。是修慧中法身生。二慧成就是真佛子。定于天性得成眷属。故次说法之后。而明眷属妙也。二明眷属者。又为五种。一明理性眷属。二明业生眷属。三明愿生眷属。四明神通生眷属。五明应生眷属。一理性眷属者。众生如佛如一如无二如理性相关。任运是子。故云我亦如是。众圣中尊世间之父。一切众生皆是吾子。此是理性。不关结缘不结缘。皆是佛子也。二业生眷属者。但众生理论皆子。而饮他毒药。有失心者不失心者。不失心者拜跪问讯。求索救护。与药即服。故于大通覆讲说妙法华。得结大乘父子。其失心者。虽与良药而不肯服。流浪生死逃逝他国。即起方便。或作三藏结缘。说生灭之法。或作通教结缘。说无生之法。或作别教结缘。说不生生恒沙佛法。或作圆教结缘。说不生不生一实相法。若信若谤因倒因起。如喜根虽谤后要得度。结缘已后。以二十五三昧。为二十五有说三谛法。而成熟之。或于中间得度。或于今未度。虽复得度未度皆是眷属。今三藏佛。于分段国出家成道。往日三藏之缘。或得度或未得度。得度之者灰身灭智。不复论生缘。未度者来牵分段。昔殷重信顺今为亲识受道。昔泛泛信顺。今为疏外受道。昔时拒谤今为怨家受道。甘露初降先得服尝。早断分段得出生死。如大象捍群俱证解脱。如五佛子之流。虽是异姓。则是法亲内眷属也。若不得道。虽是宗族名外眷属。佛于其人则无利益。若入灭度不复更生。此人缘尽传付后佛也。三愿眷属者。先世结缘虽未断苦。愿生内眷属中。或怨家等。因之受道。若得道者成法内眷属。不得者成法外眷属。若佛灭度此人无益。传付后佛也。四神通眷属者。若先世值佛发真见谛。生犹未尽。或在上界或在他方今佛分段作佛。或以愿力。或以通力来生下界。或为亲中怨辅佛行化。断余残惑而出三界。若残惑未尽值佛入灭亦自能断。或待后佛(云云)。三藏不说界外生。今以大乘意望之。昔值佛得度。三界生尽受变易身。缘牵分段非是业生。但是愿通。愿通云何异。约自报力名神通。约教名誓愿。神通生者本受报处。犹有报身。以身通力分形来此。若愿生者报处无身。愿力下生耳。三藏不说断结。誓愿受生死身不约此教论愿。通教则有誓扶余习而生分段。依通明愿于义为便。此等未得法身。故全无应生眷属。三藏眷属竟。往昔结无生缘者。或已得道。或未得道。佛于分段作佛未得道者当处即有业生。上界向下即有愿通两生。分别愿通如前说。横从他土来者。即有愿通。竖从方便来者亦有愿通。通教未得法身。故无应生眷属也。往昔曾结别教缘者。中间同事说法。种种教诏成熟未熟。佛今在分段作佛。未得道者当处即有业生。上界向下得有愿通。横从他方得有愿通。竖从方便来亦有愿通。竖从实报来者得有应生。无明先破已得法身之本。能起应入生死。此则异前(云云)。往昔结圆教缘者。中间调熟。或得道或未得道。今于分段作佛。先缘牵来差别不同。若未得道当处有一。上界向下有二。他方横来有二。方便来亦二。实报来有一。例如前(云云)。问法身惑除理显。何故受生。答应身受生其意有三。一为熟他。二为自熟。三为本缘。一熟他者。秖为业生善根微弱。不能自发。诸菩萨等。先虽得度愍彼迷闇。慈力起应入二十五有。而作师导引诸实行令向佛所。若得真道成内眷属。同于应生。若得似道同于愿通。不得真似令增进胜业。皆使利益无有唐捐。如华严中说佛初托胎。法身菩萨皆侍卫下生。如阴云笼月。散降余胎。为亲中怨引诸业者。当知。诸眷属非生死人。摩耶是千佛之母。净饭是千佛之父。罗睺罗千佛之子。诸声闻等悉内秘外现。示众有三毒实自净佛土。诸亲族等。皆是大权法身上地。岂有凡夫能怀那罗延菩萨耶。复次外道怨恶抗拒诽谤。当知。皆是法身所为。何者。转轮小善出世无怨。岂有无上法王怨仇满路。若于佛起恶恶道受罪。何得灼然生生相恼。龙象蹴踏非驴所堪。调达是宾伽罗菩萨。先世大善知识。阿阇世是不动菩萨。萨遮尼犍是大方便菩萨。波旬是住不思议解脱。故华严列众明诸天龙鬼神悉住不可思议法门。如是等若亲中怨好恶逆顺。皆是法身。先是法内眷属。今作应生眷属。若亲中怨好恶逆顺。未得法身。先虽结缘为犹在法外。同称愿业等眷属。诸余经典非不明此权利益众咸谓是实内实外实好实恶实逆实顺。故经云。未曾向人说如此事。今经佛自开近权显远实。开诸眷属迹权显本实。故文云。今当为汝说最实事。是名应生眷属熟他故来也。二为自成来者。法身菩萨进道无定。或从生身进道。或从法身进道。故下涌出菩萨云。我亦自欲得此真净大法。分别功德品中。明增道损生即其义也。三为本缘所牵。本从此佛初发道心。亦从此佛住不退地。佛尚自入分段。施作佛事。有缘之者何得不来。犹如百川应须朝海。缘牵应生亦复如是。若别说者。业生在分段。愿生通生在方便。应生在寂光。通论一处具有四种如实报已得法身。能起应作四种眷属。就圆结缘者。虽未断惑。自有三种眷属。就得道者即是四也。别眷属亦四可知。通藏结缘三种可知。虽无应来之应。得论感应之应就所应得名四义宛足。问下方涌出妙音东来。如大经中召请十方诸大菩萨。集娑罗林大师子吼。于四眷属此是何等。答是神通来非神通生。是应来非应生。是大誓愿相关非愿生。是因缘相召。如下方闻声妙音见光。是诸佛大事业来非业生。业生者不能业来。业来非是业生。愿通生者不能愿通来。愿通来者亦能愿通生。亦能应来。应来亦能应生(云云)。三明粗妙者。若三藏根性眷属。此性下劣。昔结此缘缘亦浅小。中间以法成熟成熟盖少。若来生佛国。作内外眷属业愿通等。乃至应来影响三藏佛者。皆粗眷属也。通别根性乃至内外虽巧别有异。准例可知。皆粗眷属也。此经说诸众生悉是吾子。非客作人。论其理性无非是子。是名理性眷属妙。往昔覆讲结缘系珠。二万亿佛教无上道。经云。若我遇众生尽教以佛道。若众生无佛性者。教以佛道。过则属佛。若众生皆有佛性。迷惑不受教。过属众生。一切有心皆当作佛。阐提不断心犹有反复。作佛何难。二乘灰灭。灭智则心尽。灰身则色尽。色心俱败。其于五欲无所复堪。而能世世遇之尽教佛道。此则中间成熟妙。今于法华普得作佛。此希有事。最上医王变毒为药。能治败种无心成佛。此则内外眷属妙。譬如临阵争勋前锋。第一佛说诸教收罗众生。而灰心二乘处处不入。于法华忽然得入。故涅槃遥指八千声闻得授记莂。如秋收冬藏。更无所作。若法华不悟佛性。涅槃不应遥指。若众生本无佛性。往昔结缘不应教以佛道。原始要终佛性义明。可以意得。今问华严师顿极之教。说一切众生有佛性不。若其有者二乘何不闻经授记作佛。那忽如聋如哑。若言二乘本有佛性。而匆匆取小如阉本根。本根已败为可治为不可治。若可治何故不治。若不可治。那得复言一切众生皆有佛性。故知。华严所不能治。是方便之说。法华能治。是如实之说。能治难治此处则妙。所谓结缘妙成熟妙业生妙愿生妙应生妙内眷属妙外眷属妙能受妙道影响妙事是故称妙。若将此意约五味者。乳教有别圆两眷属。一粗一妙。酪教但一粗。生苏三粗一妙。熟苏二粗一妙。法华无粗但妙。是名相待明眷属妙也。又开粗显妙者。诸经明粗眷属。皆不见佛性。今法华定天性审父子。非复客作。故常不轻深得此意。知一切众生正因不灭。不敢轻慢。于诸过去佛现在若灭后。若有闻一句。皆得成佛道。即了因不灭。低头举手皆成佛道。即缘因不灭也。一切众生无不具此三德。即是开粗显妙。绝待明眷属妙也。四明法门眷属者。此如普现菩萨问净名居士。父母妻子亲戚眷属吏民知识。悉为是谁。奴婢僮仆象马车乘。皆在何所。净名答云。方便为父智度为母。一切众导。师无不由此生。法喜为妻慈悲为女。善心诚实男。毕竟空寂舍。弟子众尘劳随意之所转。道品善知识由是成正觉。此法门以为眷属。若尔者。法门不同深浅有异。若三藏法门。观真为实观假为权。以此二智满即名为佛。佛即导师。慈悲六道即是女。令他善顺真谛名为男。得此法时喜名此为妻。此心中修诸波罗蜜道品等。即是善知识也。若通教中法门眷属者。观诸法如幻如化。体达即空为实。分别四门同异为权。于此二智生解名导师。慈爱众生为女。令生善直心为男。行六度道品为知识。是为通教中法门眷属(云云)。若别教法门恒沙眷属。真俗合为权智是父。中实理为母。无量慈善无量道品诸波罗蜜通达无滞。道种智分明观机识药。即是别教中眷属。故无量义云。诸佛法王父。经教夫人母。和合出生诸菩萨子。十住毗婆沙云。般舟三昧父大悲无生母。一切诸如来从此二法生。宝性论云。大乘信为子。般若以为母。禅胎大悲为乳母。诸佛如实子。阐提谤大乘障。外道横计身中有我障。声闻怖畏生死障。支佛背舍利益众生障。菩萨修四法为对治。修信修般若。修虚空定首楞严定修大悲。得清净法界。到彼岸见如来性。生如来家是佛子也。既道见如来性生如来家。当知。用如来为父也。无量法门不可说不可说。皆能生佛子(云云)。若圆教法门明眷属。自行三谛一谛为实。化他一谛三谛为权。随情一谛三谛为权。随智三谛一谛为实。从此不思议生解。一心具万行之善为男。无缘大慈为女。开佛知见生喜。为妻非净非垢等中道道品六波罗蜜。为善知识。如是等实相圆极法门。以为眷属。初住之中便成正觉。能八相化物。即是导师。前来诸法。门既粗。生诸导师亦粗。今法门眷属既妙。所生导师亦妙也。用此意历五味教者。乳教一粗一妙。酪教但有一粗。生苏有三粗一妙。熟苏有二粗一妙。法华但有一妙。待粗意竟。诸经妙者自妙。粗者自粗。今经非但妙者为妙。亦无复有粗。絓是前来诸粗。悉皆决了。为一平等大慧妙法门也。绝待意竟。五观心眷属者。即为六。一爱心。二见心。四则四教也。爱心眷属者。无明为父痴爱为母。出生烦恼之子孙。以贪着忆想。欲得心中法门。魔鬼便入如媚女思想。邪媚媚之。行人亦尔。忆想偏邪邪物得入。以鬼力故。或生权解或生实解。邪解生故鬼导师生。起鬼慈善着邪法喜。行邪六度道品。得邪辩心明口利说诸法门。即爱心眷属也。邪相既利发得四见。见心推画作诸法门。心所见处为实。同他为权。心起爱为女。心分别为男。如是心中修六度为道品。是名见心眷属。何者。此之见爱不识己心苦集。妄谓道灭。不知字与非字。如虫食木偶得法门之名。有名无义。岂非爱见耶。若能观心识爱见心。皆是因缘生法。无常生灭即有四番观心眷属。如中论偈云。因缘生法即空即假即中。仍于四观各明眷属。准前可知。判五观心为粗。后一观心为妙。又决粗论妙。人尚不自识己爱见心。是因缘生。何能识因缘心即空即假。尚不识空假。何能魔界即佛界。于见不动修三十七品耶。今观爱即是法性。观见不动修三十七品魔界见界即是佛界于非字中而能知字。行于非道通达佛道。于一切法无不是妙明事眷属伏听学文字人。明法门眷属伏行教人。明观心眷属伏观心坐禅人。三种法门并过其闻见(云云)

○第十功德利益者。秖功德利益一而无异。若分别者。自益名功德。益他名利益(云云)。此为四。一利益来意。二正说中利益三流通中利益。四观心中利益。一利益来意者。诸佛所为未尝空过。释论云。佛入王三昧。前放光度前者。后放光度后者。譬如网鱼前获后获。见光闻法皆不唐捐。净名云。法宝普照而雨甘露。即身口两益也。华严思益并云放光破悭破嗔破痴等。具如彼说。今经四大弟子。领佛开三显一之益。佛言如来复有无量功德。汝等说不能尽。譬如大云起于世间。譬形益也。兴雷耀电譬神通益也。其雨普等譬说法益也。而诸草木各得生长。即是四种眷属皆沾七益。故次明利益妙也。二正说利益又为三。先论远益。次论近益。三论当文益。远益者。即大通佛所十六王子。助化宣扬。双击毒天二鼓。善生有浅深惑死有奢促。始人天善终至大树浅益也。始初心最实。终后心最实深益也。始破不善终破尘沙。奢死也。始破无明终亦破无明。促死也。死之奢促是毒鼓之力。善生浅深天鼓之力。故文云。破有法王出现于世。随众生欲而为说法。即二鼓之文义也。破有义如前说。说法益义今当说。略为七益。一二十五有果报益。亦名地上清凉益。二二十五有因华开敷益。亦名小草益。三真谛三昧析法益。亦名中草益。四俗谛三昧五通益。亦名上草益。五真谛三昧体法益。亦名小树益。六俗谛三昧六通益。亦名大树益。七中道王三昧益。亦名最实事益。若二十五有因果益。堪为业生眷属。若真谛三昧体析益。堪为愿生眷属。若俗谛三昧五通六通益。堪为神通眷属。若中道王三昧益。堪为应生眷属。私谓应有四双八益。直是开前合后故言七益。若开后合前亦是七益。前后俱开即是八益。所谓中道次第益。中道不次第益。若前后俱合。则是六益(云云)。已略说七益竟。今更广开为十益。一果益。二因益。三声闻益。四缘觉益。五六度益。六通益。七别益。八圆益。九变易益。十实报益。果益者。即二十五有果报益也。有八大地狱。谓阿鼻想黑绳众合叫唤大叫唤焦热大焦热。一一各有十六小狱为眷属。合一百三十六所。此正地狱。在地下二万由旬。其傍地狱或在地上。或在铁围山间。傍轻正重。重者遍历百三十六。中者不遍。下者复减。其中众生常为热苦所逼。不可具说。闻者惊怖。四解脱经。称为火涂初入初出。两时可化。其中罪人。宿世善根可发关宜。而为圣人赴对应之。或蒙光照或注雨灭火。或调达婆薮开示说法。热闷苏醒身体清凉。获冥显两益诸苦得息。八寒冰。谓阿波波等。亦有百三十六所。乃至得冥显两益。温暖适身。是为地狱果上得清凉益也。畜生者。略有三种。水陆空。陆有三品。重者土内不见光明。中者山林。轻者人所畜养。强者伏弱饮血啖肉。怖畏百端。四解脱经称为血涂。其中众生。先世善根可发关宜。圣人赴对应之。得无所畏获冥显两益。是为畜生果。上清凉益也。饿鬼者。或居海渚。或在人间山林中。或似人形或似兽形。重者饥火节焰。不闻浆水之名。中者伺求荡涤脓血粪秽。轻者时薄一饱。加以刀杖驱逼。塞海填河。四解脱称为刀涂。其中众生。先世善根可发关宜。圣人赴对应之。手出香乳施令饱满。获冥显两益。是为饿鬼果上清凉益也。阿修罗者。或居半须弥岩窟。或大海边或大海底。与诸天为憾恒怀怖畏。雷鸣谓为天鼓。龙雨变成刀剑。此中众生。先世善根可发关宜。圣人赴对应之。软言调伏获冥显两益。是为阿修罗果上清凉益也。四天下人虽果报胜劣。俱有生老病死。同是轻报泥犁。其中众生。先世善根可发关宜。圣人赴对应之。令所离得离所求得求。获冥显两益也。六欲天者。地天别有修罗斗战之难通有五衰死相苦等地狱。其中诸天。先世善根可发关宜。圣人赴对应之。令获冥显两益也。四禅梵王无想那含等色天。虽无下界诸苦。而为色所笼。若命尽时不乐入禅。风触吹身唯除眼识。余皆有苦。其中诸天。先世善根可发关宜。圣人赴对应之。令获冥显两益也。四空诸天。虽无欲色界等苦。如疮如痈如痴如箭入体。成就细烦恼。其中诸天。先世善根可发关宜圣人赴对应之。令获冥显两益。此清凉益合而言之。盖由凡圣慈善根力。别而言之。本由菩萨初观二十五有所防之恶。而起于悲。观二十五能防之善。而起于慈。以此慈悲熏王三昧。不舍众生赴对关宜。令得利益。大经明二十五三昧。破二十五有者。十番之一意略如此也。二番二十五有修因益者。夫自他因果各随义便。互举一边说之则易。前果报益。处所时节不同。不得一身备论诸益。从多人多处易显。若明因益。一人之心起无量业。其义易显。故约一人明二十五有因益也。云何因益。四因坏益。二十一因成益。或一因坏益。一因成益。二十三亦成亦坏益。若无戒自制纵其身口。作四趣业名地狱人。若舍恶持戒名见天人。但禁戒严峻遇缘动退。则恶业还兴。或四重五逆焚毁塔寺。此心生时恶起戒没。是业熟成必堕恶道。欲离此心成就戒善。此有可发关宜之机。感无垢三昧赴对应之。恶心豁破地狱因息。得冥显两益(云云)。今人虽入道场忏悔。恶心不转则恶业不坏。恶业不坏。得绳不断罪不得灭也。若悭贪謟媚邀射名闻。内无实德欲人称美。此恶起戒伏堕于鬼中。若无惭愧负债不还。无恭敬心。憍慢嗔忿贪婪饕餮。此恶起戒伏堕畜生道。若嫉贤妒能为胜他故。而修福力。蛆毒恶心方便坠陷。惊怖于他。是恶起戒伏。堕阿修罗业。欲离此三恶心。成就戒善。善有可发关宜之机。圣用赴对应之。恶心豁破戒善完具。此名四趣因坏。人天因成。获冥显两益。此约人道修因作此释耳。若约诸趣。欲出地狱入畜。欲出畜入鬼。欲出鬼入修罗。欲出修罗入人道。皆传传有因。因成业转。此例可知(云云)。若坚持五戒。兼行仁义。孝顺父母信敬惭愧。即是人业。人业有四品。上中下下下。若就果报。阎浮提为下下。若就入道。郁单越为下下。或时善心歇末恶念唯强。善有可成恶有可灭。关宜之机圣用赴对应之。四恶趣坏四品善成。获冥显两益(云云)。若修持十善任运无间。善心成熟即天业。故云纯。恶心无善念间者。即恶道业果时纯苦。故善恶相间起即人业。人中果报苦乐相间。故十善任运成是天业。天中果报自然故。若修十善兼起护法心。即四天王业。若修十善兼慈化人。是三十三天业。若修十善。其心细妙任运成熟。行住坐卧不恼众生。善巧纯续是焰摩业。若修十善兼修禅定摄心。粗住细住者是兜率业。欲界定是化乐业。未到定破事障。是他化业。四禅是色界业。兼于慈悲喜舍。心数法中得定。是梵王业。灭心修无心定是无想业。问无想是邪见天。云何为机感。答大集云。菩萨调伏众生多种。或邪或正。行于非道通达佛道(云云)。若旧云。圣人以两片无漏。夹熏一片有漏。练成无漏。今言九次第定。熏修有漏成无漏。是那含业。四空定是无色界业。如是等二十一有。患自地之苦粗。欲修出要。所求不得所舍不离。尔时即名可发关宜之机。感二十一三昧慈悲之力破其修因。令所离得去所求得成。拔苦与乐冥显两益。此如经文云。小草小根小茎小枝小叶。而得生长。是此益也。合而言之。盖由凡圣慈善根力。别而言之。本由菩萨初持二百五十戒。修根本等禅。于一一能防。善法之中皆起慈悲慈悲本誓熏王三昧不舍众生。赴对关宜。各得利益。大经云。二十五三昧破二十五有者。十番之二意。略如此(云云)。三番声闻利益者。若人厌患生死。以死受生以生归死。劳累精神轮转无际。贪欲自蔽[犛-未+牙]牛爱尾。不得解脱。故言若人遭苦厌老病死。为说涅槃尽诸苦际。既厌心内决志求出离。为是事故修声闻道。若持戒时。爱见罗刹毁损浮囊令戒不净。戒不净故三昧不现前。既无戒定无漏不发。是故一心修戒定慧。有可发关宜之机。感无垢等四三昧力加之。令四趣业不起。使戒清净。苦均修定慧。慧若有定慧不狂。定若有慧定不愚。名之为贤。贤名邻圣。修此定慧。一心精进如救头然。愿乐禅慧如渴思饮。而为二十一有漏业之所扰乱。若得诸三昧力加之。定发观明四善根成就。伏道纯熟。一刹那转即便发真。成须陀洹破二十五有。见谛烦恼八十八使。是为二十五三昧通加。令断见谛惑而复兼除四思。故云第十六心即入修道。是其义也。次入修道。若是超人一时用十三昧力加之。破五下分思惟惑。若钝人随其分分断思惑。则分分用三昧加之。尽三界惑。究竟真谛三昧益也。此中草利益。合而言之。盖由凡圣慈善根力。别而言之。由本慈悲。初观十法界中析空灭色之善。因起弘誓熏王三昧不舍众生致有中草利益。大经明二十五三昧破二十五有者十番之三意略如此。四番缘觉利益者。若人宿善深利。在无佛世厌患生死。乐独善寂观深因缘。文云。曾供养佛志求胜法为说缘觉。此人大福可发关宜。圣人赴对应之。使其华飞钏动获冥显两益。悟支佛道。此犹属中草利益也。五番六度菩萨。观于四谛行六度行。若行檀时。人从乞头索眼国城妻子。心或转动。檀度不成。自知是恶。欲成檀善。可发关宜之机。蒙三昧力伏其悭蔽。是破饿鬼有。蔽心既去欢喜布施。如饮甘露。知有为法危脆无常。是蒙心乐三昧冥显之益也。尸罗若成是伏毁戒蔽破地狱有。是无垢三昧益也。忍成伏嗔蔽破畜生有。不退三昧益也。禅成是伏乱蔽破人有。是四三昧益也。精进成伏懈怠蔽。破修罗有。欢喜三昧益也。慧成伏愚痴蔽。破天有十七三昧益也。六蔽是六道业。具出菩萨戒本。以伏六道业故。不为诸蔽所恼。得五神通游于六道。成六度行。此即上草益也。通应如前。别而论之。由本观十法界事中善恶。而起弘誓熏三三昧不舍众生(云云)。六番通人益者。此是三乘共学人也。若干慧地性地八人见地。即是用二十五三昧益。从薄地去至十地。用二十一三昧加破思惑。又侵除无知。是名小树益也。总别慈悲例前可知(云云)。七番别人益者。此是次第心中。系缘法界一念法界入十住。得真谛三昧益。入十行十回向。得俗谛三昧益。入十地得中谛三昧益。此即大树之益。总别慈悲例前(云云)。八番圆人益者。此是修三谛一实之理。一念法界系缘法界。若历缘对境。举足下足。无非道场。其心念念与诸波罗蜜相应。修四三昧观十种境可发关宜。圣人赴对应之。豁然开悟。或似或真得冥显两益。此是圆用二十五三昧。圆加破二十五有。显出我性。得究竟实事之益也。九番变易益者。此是方便有余土人益也。前八番中凡有四处。或九处。谓声闻缘觉。通教菩萨。别教三十心。圆教似解。止破见思未除无明。无明润无漏受方便生。故下文云。我于余国作佛。更有异名。而于彼土求佛智慧。得闻是经。即是彼土入一乘也。胜鬘云。三人生变易土。谓大力罗汉辟支佛菩萨等。楞伽云。三种意生身者。一安乐法意生身。此欲拟二乘人。入涅槃安乐意也。二三昧意生身。此拟通教出假化物。用神通三昧意也。三自性意生身。此拟别教修中道自性意也。通言意者。安乐作空意。三昧作假意。自性作中意。别圆似解犹未发真。皆名作意。故论云。是时过意地。住在智业中。若发真可是智业。未发真犹在意地。是人生彼析法者钝。体法者利。别人已习假又小利。圆人先即中最利。既有利钝之殊。于彼修学。即有次第不次第两益。又是次第不次第用二十五三昧两应也。是为九人生方便国。始于彼土。见诸有我性得最实益。若分别而言。谓方便土在三界外。若即事而真不必在远。下文云。若能深心信解。则为见佛常在耆阇崛山。共大菩萨声闻众僧围绕说法。即方便土意也。十番实报土益者。即实报土人益也。八番中有两人生方便土。又二人悉破无明见实相者方得生彼。但无明重数甚多。虽三贤十圣住于实报。报未尽犹有残惑。更用王三昧。四十一番益之。至于妙觉。竖穷横遍不生不灭。不生不灭无明永尽。智慧圆足。故言不生不灭。又机感满足利益究竟。故言不生不灭。若分别为言。谓实报在方便之外。若即事而真此亦不远。文云。观见娑婆琉璃为地坦然平正。诸台楼观众宝所成。纯诸菩萨咸处其中。即实报土意也。若粗妙机若别圆应。若净秽土若浅深益。不出十番。包括法界利益略周。大意可见不俟繁文。是为大通佛所。毒鼓损生闻有远近。死有奢促。天鼓增道闻有远近。故令益有深浅。致有业通愿应诸眷属利益也。问初番已破二十五有得益竟。则无有可破。更无益可论。何须至十番耶。答初破二十五果报苦。获果报益。次破二十五因苦。获修因益。次破二十五有见思苦。得真三昧益。次破二十五空。令出二十五有假。得俗三昧益。次破二十五有有空二边。显于中道王三昧益。次破方便有余土。出二十五假。得俗王两三昧益。次破实报土。但深显王三昧益三谛未了了者益意不息。故有十番其义如是。问三谛独在极地。亦得通凡。答如大品云。众生色受想行识。又云。无等等色受想行识。仁王云。法性色法性受想行识。大经云。因灭是色获得常色。受想行识亦复如是。是则从凡至圣。皆悉是有即俗谛也。净名云。众生如。弥勒如贤圣如。一如无二如。大品云。色空受想行识空。若有一法过涅槃者。亦如幻如化。此则凡圣皆空即真谛也。大经云。二十五有有我不耶。答言有我我即佛性。佛性即中道。因缘生法一色一香无不中道。此则从凡至圣。悉皆是中道第一义谛。问远论利益经语还多。第一云。从久远劫来。赞示涅槃道。生死苦永尽。我常如是说。第二云。我昔于二万亿佛所教无上道。第三云。宿世因缘吾今当说。定据何文耶。答第一文直云从久远劫来。久远之言。信实杳漫而未显本地。或据中间。第二直云昔曾二万亿佛所。未判劫数久近难明。将后文准望似如近近。今论远益取第三文。以三千界墨。东过千界。乃下一点。点与不点尽抹为尘。一尘一劫复过是数无量无边百千万亿阿僧祇劫。用此明文望二万亿佛所。始为昨日。从是已来为结大乘之首。彼佛八千劫说经。十六王子八万四千劫覆讲。彼之经论文广时深。于时听众或可当座已悟。或可中间化得。或可近来化得。咸至宝所。受法性身为应生眷属。内秘外现共熟众生。而作佛事。净名曰。虽成道转法轮。而行菩萨道。是此意也。于时听众未得真实益。若相似益隔生不忘。名字观行益隔生则忘。或有不忘。忘者若值善知识宿善还生。若值恶友则失本心。是故中间种种涂熨。或多以大乘熟。或多以小乘熟。生方便者。虽说种种道。其实为一乘。亦复皆令得至宝所。受法性身。而于彼国被第九番十番真实利益。如千世界微尘菩萨即其流也。斯等已究竟于前名久远利益。其中众生于今有住声闻地者。更近论利益。如后说(云云)

妙法莲华经玄义卷第六下妙法莲华经玄义卷第七上

        天台智者大师说

二近利益者。起于寂灭道场。始成正觉即转法轮。击于毒鼓天鼓。利益众生。齐至法华已前。益亦浅深死亦奢促。何者。教本逗缘。缘略为四。教亦有四。教主亦四。皆称法王具王三昧。自破二十五有。七益众生例如前说。又大小乘经。明佛入王三昧。放光说法善恶诸趣果苦得益者。如阿含中说。见佛光明蒙佛手触。六道苦患悉得除愈。又大品云。放光照地狱众生。苦恼即除。生齐第六天。苦除是果益。生天是因益。大品称为华叶之益也。又佛放光幽闇之处皆大明。各作是念。此中云何忽生众生。此亦是果益。此因果益。四教主佛。通能此益。别论益者。则是浅深不同。谓声闻断正缘觉侵习。同名中草。菩萨伏惑兼度众生。故经云。求世尊处我当作佛。行精进定。是名上草益。盖三藏教主慈善根力。利益之相也。经云。若诸菩萨智慧坚固。了达三界求最上乘。即三人同观无生。非但有前析智之益。别有巧度。即是体真。是为小树增长益。盖通教主利益之相。经云。复有住禅得神通力。闻诸法空心大欢喜。住禅者住九种大禅。心大欢喜者登欢喜地。度无数亿百千众生。是名大树增长。非但有前因果析体之益。而别有分别道种智。乃至一切种智益。盖别教主利益之相。经云。今当为汝说最实事。不啻如前之益。乃有即破无明显出佛性。究竟实益。盖圆教主利益之相。复次前三教益劣不兼胜。胜则兼劣可解(云云)。又历五味者。乳教但因果大树实事四益。而不明三草一木。以大乘经不入二乘人手。如聋如哑故。酪教但有三草等四益。生苏备有七益。熟苏无析法三草。而有体法等七益。醍醐但有实事益。前诸益皆粗。今益则妙。近从寂灭讫至法华。为生身菩萨。但得八番之益。不得第九第十益也。又有得义者。即是菩萨从法性身来入分段。作愿通应生等眷属。进破无明断除残品。即得明第九第十番益也。始从寂灭终至法华。略言十益也。问法身菩萨。闻应身佛说法。应身中益。亦令法身得益耶。答譬如磨镜镜转明色像亦明。又问应身闻法益。法身亦益者。应身现病法身亦病耶。答此病若实者。应病法亦病。秖为应病非实。非实故应身无病。法身亦无病。又若应身现病少。当知法身益亦少。若能应身现病广。法身益亦广也。今作诸句料简。自有果益因不益。因益果不益。俱益。俱不益。此即现事可解。自有坏益成益。亦坏亦成益。不坏不成益。不坏不成益是清凉益。四趣因是坏益。非想因是成益。中间是亦成亦坏益(云云)。自有因益即果益。果益即因益。此变易因移果易意也。自有因益非增道。果益非损生。得是因果益。不得是因果益。分段报因果也。自有因益是增道果益是损生。不得是因果益。得是因果益。习因习果也。自有真益非俗益二乘也。俗益非真益六度菩萨也。自有先俗益后真益六度菩萨也。自有先真益后俗益。通菩萨也。自有真俗益非中益。中益非真俗益别也。自有真益即俗益。亦即中道益圆也。三当文利益。就今经备有七益。虽复差别即无差别。譬如芽茎枝叶生长不同。而是一地所生。七益诚复浅深无非实相。故言差别无差别也。诸经差别粗益。同入此经无差妙益。或进入诸妙益。或按位成妙益进入益者。本是地上清凉。今则进发大乘解心明净。或进观行妙相似分真中。本是人天因益。今进入相似分真。本是小乘学无学益。今进破无明分真妙益。譬如回声入角转小为大也。通别进益例此可知。按位益者。本是粗果。地上清凉即成理妙之益。按于粗因之益。即是观行妙益。按粗学无学益。即是相似妙益。开粗即妙不须进入。通别例此可知。进入妙益。即是待粗益明妙益。按位益即是绝待妙益(云云)。诸粗益判眷属者。果因二益。堪为业生眷属。中上二草小树等。堪为愿通眷属。大树见性已去。皆应生眷属摄(云云)。进入按位者。理妙假名观行妙。堪为业生眷属。相似妙堪为愿通眷属。分真堪为应生眷属。是名此经利益之相也(云云)。三明流通利益者为三。一出师。二出法。三出益。弘经行人具通凡圣。若法身菩萨誓愿庄严。令此土他土下土上土。得权实七益九益十益。化功归己还资法身。增道损生也。生身菩萨。亦能此土他土弘经。令他得权实七益。化功归己增道损生。而不能上土利益也。凡夫之师亦能此土弘经。令他得权实七益。化功归己增益品位。故无量义云。有病导师。在于此岸而成就船筏。渡人彼岸。即其义也。问凡夫但能为凡夫弘经。使凡夫得益。亦能令圣人得益耶。答圣有二种。一小乘圣。二大乘圣。如经云。若有实得阿罗汉生灭度想。若遇余佛便得决了。南岳师云。初依名余佛。无明未破名之为余。能知如来秘密之藏。深觉圆理名之为佛。佛灭后实得罗汉者。于权实未了。若遇初依即能决了。成相似益。成进入分真益。此文往证凡夫之师。得为小乘圣人弘经得益也。经云。六根清净人说法。十方诸佛皆乐见之。皆向其处说法。一切天龙闻其所说。皆大欢喜。此亦是凡夫师。为大圣说法之明文也。二出法者。通经方法明出圣言。文云。若众生不信受者。当于余深法中示教利喜。余者带方便也。深者明中道也。带方便明中道者。即别教也。若但方便不明中道。即通藏等教也。经文许用别助圆。而例推亦应用通助圆。又文云。更以异方便助显第一义。岂隔藏通耶。但菩萨已得实慧。亦得权意。不以实滥权。亦不谓权是实。但为弘实而众生不信。须为实施权。以浅助深无虚妄也。此则双用权实而弘经也。安乐行云。若有难问。不以小乘法答。但以大乘而为解说。令得一切种智。此则但令用实弘经也。又云。随宜为说。此亦不隔于权也。今时人弘法。或一向用大。或一向用小。皆不得佛意。善弘经者。用与适时。口虽说权而内心不违实法。但使众生得权实七益。于弘经畅矣。三出益者。然流通利益。不待第三流通段。方明利益。秖正说文中。已指未来弘经之利。譬喻品后授记品末法师品中。皆明弘经功德利益。能于如来灭后。闻一句偈者。亦与受三菩提记。况弘宣者。窃为一人说者。功德尚多。况处众广说者。展转至第五十人。随喜功德尚非二乘境界。况最初会中闻随喜者。常不轻流通一句尚得六根清净。况具足流通者。初品弟子弘经功德。无量亿劫行五波罗蜜。不得为喻。况第五品十方虚空。宁有边表。五品弘经尚叵穷尽皆云。入如来室着如来衣坐如来座。如来之法皆非数量。况八万大士千界微尘菩萨。而当可说耶。而当可知耶。唯除如来无能尽知者也。凡师弘经令凡七益。经云。此经是阎浮提人病之良药。若闻是经不老不死者。于老死中识老死实相。老死是果报法。识实相即得清凉理妙益也。亦果报益也。能持此经故。生安乐土处莲华中。不为贪欲所恼。亦是离十恼乱。是善行菩萨道。亦名名字益。亦是观行妙。亦是修因妙。得陀罗尼。能旋假入空。即是下中上药草等益。亦是小树益。得百千旋陀罗尼。即大树益。得法音方便陀罗尼。是相似实益。若有须臾闻。即得究竟三菩提。即是真实益。复次如人穿凿高原见干土。是下中上药草益。见泥是小树大树益。得水是最实益。后五百岁尚获此益。况复今时弘经利他。宁无七益耶。第四观心者。小乘明心起未动身口。不名为业。大乘明刹那造罪殃坠无间。无间是大苦报处。刹那促起业处。促心暂起重业已成。况九法界而不具足。若能净心诸业即净。净心观者。谓观诸心悉是因缘生法。即空即假即中。一心三观。以是观故知心非心。心但有名。知法非法。法无有我。知名无名。即是我等。知法无法即涅槃等。此解起时。于我我所如云如幻。即是地上清凉益。信敬惭愧诸善心生。于空假中意而有勇。即是因益。念念与即空相应。是中上草小树等益。念念与即假相应是大树益。念念与即中相应。是最实事益。于一念益心。七种分别(云云)。夫一向无生观人。但信心益。不信外佛威加益。此堕自性痴。又一向信外佛加。不内心求益。此堕他性痴。共痴无因痴亦可解。自性痴人眼见世间。牵重不前者傍力助进。云何不信罪垢重者。佛威建立。令观慧得益耶。又汝从何处。得是无生内观耶。从师耶从经耶。从自悟耶。师与经即是汝之外缘。若自悟者。必被冥加汝不知恩。如树木不识日月风雨等恩。又三事汝不知外加。一不信教。二不自行求外加。三不教人。直是汝之不信。非无外益也。经曰。非内非外。而内而外。而内故诸佛解脱。于心中求。而外故诸佛护念。云何不信外益耶(云云)。他共无因痴例可解。即假故无自性。即空故无他性。即中故无共性。双照故无无因性(云云)。第五结成权实者。光宅云。照三三之境为权。照四一之境为实。今不用此解。既以大乘果为大理。何不用小乘果为小理。彼救云。小果非真。故不以其果为理。若尔权教及权行人。何尝是实。既立权教行人。何不立权理。又权若无理。俗不应称谛。既言俗谛权不应止三也。实有四者。夫因果是二法。云何以二法为理一耶。经云。观一切法如实相。不行不分别。云何分别因果为理一。若尔便无实相则魔所说。故不用彼释。今明照十粗之境为权。照十妙之境为实。十粗者即前九法界。三因缘等诸粗谛智。乃至粗利益。皆称权也。照十妙者。即是理妙乃至利益妙。妙故为实。复次为十妙故。开出十粗。如为莲故华。意在于莲。而莲隐不现。于余深法示教利喜。余法有实而实不显。文云。如来方便意趣难解也。又华开莲现。譬开十粗显十妙。则无复十粗。唯一大事不可思议境界。乃至利益。肇师云。始从佛国终法供养。皆明不可思议。今亦例尔。既开粗已始终皆妙。又约五味者。乳味则有为十妙明十粗。开十粗显十妙。则成一权一实。若就四悉檀则有六权二实。若约四门则十二权四实也。若约三藏一向是权。化城杨叶。还就三藏约化他为权。就自行为实。约四悉檀三权一实。约四门十二权四实。若方等既备有四教故。三十种权一十种实。若约四悉檀。十四权二实。对四门五十六权八实。若约摩诃般若。既废三藏但用三教。通别二十种为权。一十种圆为实。若约悉檀十权二实。若历四门四十权八实。若至法华前来一向皆废。但说一实。实中非无方便。但是实相方便同称为实。今约悉檀者。未悟之前三权。悟即一实。若历四门十二权四实。名数一往同三藏。而意有天悬而地殊。彼教十二权四实。一向是权。法华一向是实。料简异方等般若(云云)。故云。但说无上道示真实相。此之谓也。若约涅槃。涅槃备释四教。亦是三十权一十实。一往似同方等。而意迥异彼。则二入实二不入实。今涅槃四俱入实。因中则有三权一实在果则四实而无权。若约四悉檀。十四权二实。历四门五十六权八实。若更约三因门。五十六权。若果门四实但是实。仍其本因故说四耳。是则四门入实。约果四实十二权。法华义齐也。故知。诸教虽同有权实。权实不同。或一向实。或一向权。或权实相兼。皆是称当机情。缘理未融。今总就教判权实。若约三藏通别。三教是权。圆教为实。又诸教权实未融为权。既融开权显实为实。今法华是一圆故为实。又开权故为实。若就圆教为语。照前三教三十粗为权。照十妙为实。若就开权圆融为语。决于三十粗皆成妙。但称为实。是故称妙。若取悟理者。理即非权非实。不见一法。空拳诳小儿。说权说实。是则为粗。理则非权非实。是故为妙也

○第二约本明十妙者为二。先释本迹。二明十妙。释本迹为六。本者理本即是实相。一究竟道。迹者除诸法实相。其余种种皆名为迹。又理之与事皆名为本。说理说事皆名教迹也。又理事之教皆名为本。禀教修行名为迹。如人依处则有行迹。寻迹得处也。又行能证体体为本。依体起用用为迹。又实得体用名为本。权施体用名为迹。又今日所显者为本。先来已说者为迹。约此六义以明本迹也。一约理事明本迹者。从无住本立一切法。无住之理。即是本时实相真谛也。一切法。即是本时森罗俗谛也。由实相真本垂于俗迹。寻于俗迹即显真本。本迹虽殊不思议一也。故文云。观一切法空如实相。但以因缘有从颠倒生(云云)。二理教明本迹者。即是本时所照二谛。俱不可说。故皆名本也。昔佛方便说之。即是二谛之教。教名为迹。若无二谛之本。则无二种之教。若无教迹岂显谛本。本迹虽殊不思议一。文云。是法不可示。言辞相寂灭。以方便力故。为五比丘说。三约教行为本迹者。最初禀昔佛之教以为本。则有修因致果之行。由教诠理而得起行。由行会教而得显理。本迹虽殊不思议一也。文云。诸法从本来常自寂灭相。佛子行道已来世得作佛(云云)。四约体用明本迹者。由昔最初修行契理。证于法身为本。初得法身本故即体。起应身之用。由于应身得显法身。本迹虽殊不思议一。文云。吾从成佛已来甚大久远若斯。但以方便教化众生。作如此说。五约实权明本迹者。实者最初久远实得法应二身。皆名为本。中间数数唱生唱灭。种种权施法应二身。故名为迹。非初得法应之本。则无中间法应之迹。由迹显本。本迹虽殊不思议一也。文云。是我方便诸佛亦然。六约今已论本迹者。前来诸教已说事理。乃至权实者皆是迹也。今经所说久远事理乃至权实者。皆名为本。非今所明久远之本。无以垂于已说之迹。非已说迹。岂显今本。本迹虽殊不思议一也。文云。诸佛法久后要当说真实。若约已今论本迹者。指已为迹。摄得释迦寂灭道场已来十粗十妙。悉名为迹。指今为本。总远摄最初本时诸粗诸妙。皆名为本。若约权实明本迹者。指权为迹。别摄得中间种种异名佛。十粗十妙皆名为权。指实为本摄得最初十粗十妙。悉名为实。若约体用明本迹者。指用为迹。摄得最初感应神通说法眷属利益等五妙。指体为本。摄得最初三法妙也。若约教行为本迹者。指行为迹。摄得最初行妙位妙。指教为本。摄得最初本时智妙。若理教为本迹者。指理为本。摄得本初之境妙指教为迹。摄得本时之师教妙。兼得本师十妙。若理事为本迹者。指事为迹。摄得本时诸粗境。指理为本。摄得本时诸妙境。最初之本为本。但本而非迹。最后已说但迹而非本。中间亦迹亦本。若无本时之本。不能垂得中间最后之迹。若无已说之迹。不能显得今说之本。本迹虽殊不思议一也

△二明本十妙者。一本因妙。二本果妙。三本国土妙。四本感应妙。五本神通妙。六本说法妙。七本眷属妙。八本涅槃妙。九本寿命妙。十本利益妙。释此十妙又为十重。一略释十意。二生起次第。三明本迹开合。四引文证成。五广解。六三世料简。七论粗妙。八结成权实。九利益。十观心

○一略释者。本因妙者。本初发菩提心。行菩萨道所修因也。若十六王子在大通佛时。弘经结缘。皆是中间所作非本因也。若娑婆为墨。东行千界方下一点。点不点等尽抹为尘。一尘一劫。复过于是百千万亿那由他劫。弥勒补处。以出假种智直数世界。尚不能知。况数其尘宁当得尽。特是如来巧喻。显其长远之相。况以世智巧历算数耶。文云。我以佛眼观彼久远。犹若今也。唯佛能知如此久远皆是迹因。非本因也。若留中间之因。于后难信。是故法华拂迹除疑。权而非实。我本行菩萨道时不在中间。过是已前所行道者。名之为本。即是本因妙也。二明本果妙者。本初所行圆妙之因。契得究竟常乐我净。乃是本果。不取寂灭道场舍那成佛。为本果也。尚不取中间之果以为本果。况舍那始成。云何是本。但取成佛已来甚大久远。初证之果名本果妙也。三本国土者。本既成果必有依国。今既迹在同居。或在三土中间。亦有四土。本佛亦应有土复居何处。文云。自从是来。我常在此娑婆世界。说法教化。按此文者。实非今日迹中娑婆。亦非中间权迹处所。乃是本之娑婆。即本土妙也。四本感应者。既已成果。即有本时所证二十五三昧。慈悲誓愿机感相关。能即寂而照。故言本感应也。五本神通者。亦是昔时所得。无记化化禅。与本因时诸慈悲合。施化所作神通。骇动最初可度众生。故言本神通也。六本说法者。即是往昔。初坐道场始成正觉。初转法轮四辩所说之法。名本说法也。七本眷属者。本时说法所被之人也。如下方住者。弥勒不识即本之眷属也。八本涅槃者。本时所证断德涅槃。亦是本时。应处同居方便二土。有缘既度。唱言入灭即本涅槃也。九本寿命者。既唱入灭。则有长短远近寿命也。十本利益者。本业愿通应等眷属。八番十番饶益者是也

○二生起者此十种义赴缘直说。散在经文。今欲编次故须生起。所以本因居初者。必由因而致果。果成故有国。极果居国即有照机。机动则施化。施化则有神通。神通竟次为说法。说法所被即成眷属。眷属已度缘尽涅槃。涅槃故则论寿命长短。长短之寿所作利益。乃至佛灭度后。正像等益义。乃无量。止作十条收束始终。复成次第也

○三迹本同异者。迹中因开而果合。合习果报果为三法妙也。本中因合而果开。开习果出报果。明本国土妙也。作此同异者。依于义便互有去取。迹中委悉明境智行位。本文语略通束为因妙得意知是开合耳。果妙者。即是迹中三轨妙也。感应神通说法眷属名同上也。本开涅槃寿命妙者。久远诸佛如灯明迦叶佛等。皆于法华即入涅槃。义推本佛必是净土净机。又往事已成故开出涅槃等妙也。迹中无此二义者。释迦虽于法华唱言涅槃。而未灭度。此事方在涅槃。故迹中不辨利益同上也

○四引文证者。不远索他经。亦不通引部内。但就本门证成十义也。然先佛法华。如恒河沙阿閦婆偈。今佛灵山八年说法。胡本中事复应何穷。真丹边鄙止闻大意。人见七卷谓为小经。胡文浩博何所不辨。今就数纸之内。十证宛然。文云。我本行菩萨道时。所成寿命今犹未尽者。即是本之行因妙也。文云。我实成佛已来。无量无边亿那由他。又云。我实成佛已来。久远若斯。但以方便教化众生。作如此说。即是本果妙也。文云。我于娑婆世界。得三菩提已。教化示导是诸菩萨。又云。自从是来。我常在此娑婆世界说法教化。亦于余处导利众生。此之国土非复今时娑婆。即本国土妙也。文云。若有众生来至我所。我以佛眼。观其信等诸根利钝。此即本时照机之智。是感应妙也。文云。如来秘密神通之力。又中间文云。或示己身或示他身。或示己事或示他事。即是垂形十界作种种像。验本亦然。是本神通妙也。文云。是诸菩萨悉是我所化。令发大道心。今皆住不退修学我道法。又中间或说己事。或说他事。验本亦然。即本说法妙。文云。此诸菩萨身皆金色。下方空中住。此等是我子。我从久远来。教化是等众。即本眷属妙也。文云。又复言其入于涅槃。如是皆以方便分别。又云。今非实灭。而便唱言当取灭度。往缘既讫而唱入灭。中间既唱涅槃。例本亦有涅槃。即本涅槃妙。文云。处处自说名字不同年纪大小。年即寿命。大小即长短常无常也。中间既尔本寿亦然。即本寿命妙也。文云。又以方便说微妙法。能令众生发欢喜心。即中间利益。又云。闻佛说寿命劫数长远如是。无量无边阿僧祇众生得大饶益。即迹中之益。迹与中间既尔。例本亦然。即是本利益妙也。十据在经非人造也

○五广释者。夫非本无以垂迹。若能解迹则亦知本。为未解者更重分别。但本极法身微妙深远。佛若不说。弥勒尚闇何况下地。何况凡夫。虽然父母之年不可不知。如来功德何容不识。今略依经旨。仿佛推寻本因妙者。经言。我本行菩萨道时。所成寿命者。慧命即本时智妙也。我本行者。行是进趣即本行妙也。菩萨道时者。菩萨是因人。复显位妙也。一句文证成三妙。三妙即本时因妙。非迹因也。迹因多种。或言昔为陶师。值先释迦佛三事供养。藉草然灯石蜜浆。发口得记。父母名字弟子侍人。皆如先佛。即是初阿僧祇发心。既不明断惑。知是三藏行因之相也。或言昔为摩纳。值然灯佛五华奉散。布发掩泥跃身虚空。得无生忍。佛与受记号释迦文。大品亦云。华严城内得记。义与此同。并云断惑。故知通佛行因之相也。或言昔为宝海梵志。删提岚国。宝藏佛所行大精进。十方佛送华供养。既为宝藏佛父。又是弥陀之师。称其功德不可思议。故知是别圆行因之相。以三义故知此诸因悉是迹因。一近故。二浅深不同故。三被拂故。今世已前。本来已后。中间行行悉是方便。故知是迹因也。若执迹因为本因者。斯不知迹亦不识本。如不识天月。但观池月。若光若桂若轮。准下知上。光譬智妙桂譬行妙轮譬位妙。若识迹中三妙。拂迹显本即知本地因妙。如拨影指天。云何临盆而不仰汉。呜呼聋騃若为论道耶。若得斯意。迹本非本本迹非迹。本迹虽殊不思议一也。问经称本行菩萨道时者。应是初住得真道时也。中间应是诸地增道损生。今之寂场应是妙觉。妙觉显本应指昔初住。此一途为允。答文义不可。文云。尽行诸佛所有道法。又云。具足行诸道。悉具足因乃是本因。初住不得称悉具。故非所指本因也。又中间之果。悉拂是权。况今寂场之果。何得为实又中间之果尚被拂者。中间之因宁实因也。故尔问非也。二明本果妙者。经言我成佛已来甚大久远。我者即真性轨。佛者觉义即观照轨。已来者。乘如实道来成正觉。即是起应资成轨也。如此三轨成来已久。即本果妙也。本果圆满久在于昔。非今迹成。迹成又非一种。或言道树草座。三十四心见思俱断。朗然大悟。觉知世间出世间一切诸法。名之为佛。唯有此佛无十方佛。三世佛者悉是他佛。非我分身。此即三藏佛果相也。或言道树天衣为座。以一念相应慧。断余残习气而得成佛。大品中说共般若时。十方有千佛现。问难人皆字须菩提。释提桓因等亦是他佛。非我分身。此即通佛果成相也。或言寂灭道场。七宝华为座身称华台。千叶上一一菩萨。复有百亿菩萨。如是则有千百亿菩萨。十方放白毫及分身光。白毫入华台菩萨顶。分身光入华叶菩萨顶。此名受法王职位。穷得诸佛法底。而得成佛。华台名报佛。华叶上名应佛。报应但是相关而已。不得相即。此是别佛果成相也。或言道场以虚空为座。一成一切成。毗卢遮那遍一切处。舍那释迦成亦遍一切处。三佛具足无有缺减。三佛相即无有一异。法华八方一一方。各四百万亿那由他国土。安置释迦悉是遮那。普贤观云。释迦牟尼名毗卢遮那此即圆佛果成相也。有三义故。知此诸果皆是迹。果一今世始成。故二浅深不同。故三拂中间。故若是本果何得今日始成。本果一果一切果。何得前后差别不同。自从今世之前。本成之后。百千万亿行因得果。唱生唱灭悉是中间。拂为方便。寂灭树王何得非迹。若执迹果为本果者。斯不知迹亦不识本。从本垂迹如月现水。拂迹显本如拨影指天。当拨始成之果皆迹果。指久成之果是本果也。如此解者。中间果疑飒然皆尽。长远之信其义明焉。迹本非本本迹非迹。迹本虽殊不思议一也。三本国土妙者。经云。自从是来。我常在此娑婆世界。说法教化。亦于余处导利众生。娑婆者。即本时同居土也。余处者。即本时三土也。此指本时真应所栖之土。非迹中土也。迹中明土又非一途。或言统此三千百亿日月者。同居秽土也。或言西方有土。名曰无胜。其土所有庄严之事。犹如安养者。同居净土也。或言华王世界莲华藏海者。此实报土也。或言其佛住处。名常寂光者。即究竟土也。寂光理通如镜如器。诸土别异如像如饭。业力所隔感见不同。净名云。我佛土净而汝不见。此乃众生感见差别。不关佛土也。若言今此三界皆是我有。诸土净秽调伏摄受。皆佛所为。譬如百姓居土土非其有。如父立舍父去舍存。如来亦尔。为众生故而取佛土。化讫入灭佛去土存。此乃佛土不关众生也。复次三变土田者。或是变同居之秽。令见同居之净。或见方便有余净。例如寿量云。若有深信解者。见佛常在耆阇崛山。共大菩萨声闻众僧者是也。或见实报净。例如见娑婆国土皆绀琉璃纯诸菩萨。即其义也。或见寂光等也。法华三昧之力使见不同耳。有三义故。得知诸土。悉迹土也。一今佛所栖故。二前后修立故。三中间所拂故。若是本土非今佛所栖。今佛所栖即迹土也。若是本土一土一切土。不应前后修立深浅不同。今土已前本土已后。皆名中间。中间悉称方便。况今之土宁得非迹。从本垂迹执迹为本者。此不知迹亦不识本。今拂迹指本。本时所栖四土者。是本国土妙也。迹本非本本迹非迹。非迹非本即不思议一也。四本感应妙者。经云。若有众生来至我所。我以佛眼。观其信等诸根利钝。众生来至者感扣法身也。我以佛眼观者。慈悲往应也。诸根利钝者。十法界冥显欣厌不同也。此指本时。证二十五三昧感应非迹中感应也。迹应多种。或言一日三时。入定观可度机。此三藏佛。照分段秽国九法界机。析空感应也。或言即俗而真不须入出。任运能知。此通佛照分段净国九法界机。体空感应也。或言用王三昧。历别照十法界机。此别佛照方便有余土。次第感应也。或言王三昧。一时照十法界机。此圆佛照十法界寂光土机。圆感应也。有三义故。知诸感应迹而非本。始成故不同故被拂故。寂场树下始偏圆满。故知是迹。或前修后学深浅不同。故知是权。中间已来拂皆方便。宁非迹耶。从本出迹岂可执迹为本。拂迹显本宜舍迹指本。本迹迹本不思议一(云云)。复次或本感粗迹感妙。或本感妙迹感粗。俱妙俱粗。应亦如是。又本感广迹感狭。或迹感广本感狭。俱狭俱广。应亦如是。但取今昔判本迹。不约粗妙广狭也(云云)。五本神通妙者。经言。如来秘密神通之力。又云。或示己身他身。示己事他事。示己身己事者。圆神通也。示他身他事者。偏神通也。秘密者妙也。若偏若圆皆是妙也。此指本时神通。非迹神通也。迹通多种。或言依背舍除入。十四变化获得六通。过外道胜二乘。此乃三藏佛通也。或言依体法无漏慧。获得六通。胜依背舍者。此通佛神力也。或言束前六通为五。依中道发无漏通。此六是别佛通也。或言中道无记化化禅。具六通一切变化。不起灭定现诸威仪。语默不相妨。动寂无二理。又如今经中六瑞变土等。皆是圆佛通也。以三义故。推诸神通迹而非本。始获近修拂疑等。如上说。又四句料简亦如上。然从本垂迹迹则非本。拂迹显本宜弃迹指本。本迹迹本不思议一也。六本说法妙者。经言。此等我所化令发大道心。今皆住不退。我所化者。正是说法。令发大道心者。简非小说也。此指本时简说非迹说也。迹说多种。若依涅槃。明初后两味从牛而出。若以义推。中间三味亦应从牛而出。何者凡犊啖凡草。但能出乳。不啖忍草故不出四味。良犊调善不高不湿。酒糟麦[麩-夫+戈]五味圆满。具足在牛。但听饮啖随[穀-禾+牛]而出。若啖凡草[穀-禾+牛]即出乳。啖下忍草[穀-禾+牛]即出酪。啖中忍草[穀-禾+牛]出生苏。啖上忍草[穀-禾+牛]出熟苏。啖上上忍草[穀-禾+牛]出醍醐。若牛出五味譬渐法也。牛出醍醐譬顿法也。牛出三味譬不定法也。佛亦如是。偏圆满足在佛心中。听机扣击说则不同。善趣机击出人天法轮。析法机击出二乘法轮。体法机击出巧度法轮。历别机击出渐次法轮。圆顿机击出无作法轮。又两机击出第四第五味。又一机击出第二味。又四机击出四味。除第一味。又三机击出三味。除第一第二味。又一机击出第五味除四味。复次三藏道场所得法。如乳在牛。起道场即说乳法轮。通佛道场所得法。如酪在牛。起道场即说酪法轮。别佛道场所得法。如五味俱在牛。道场起说次第五味法轮。圆佛道场所得法。如醍醐在牛。道场起即说醍醐法轮。问大经云。如食乳糜更无所须。应是乳法轮。答乳有多种。粗牛出乳乳则为害。善犊之乳是乳最良。问乳既多种醍醐不一。答经以罗汉支佛为醍醐。故知优劣。此中大有义宜熟思之。例三义往推。上诸说法迹而非本。始满始说中间被拂。中间满中间说。尚皆方便。况今满今说宁非迹耶。执迹则俱失拂迹则俱解。非迹非本不思议一也。复次已说为迹今说为本。已本今迹俱迹俱本(云云)。或实本权迹四句(云云)。体用乃至事理四句(云云)。

妙法莲华经玄义卷第七上妙法莲华经玄义卷第七下

        天台智者大师说

○七本眷属妙者。经云。此诸菩萨下方空中住。此等是我子。我则是父。下方者下名为底。大品有诸法底三昧。释论云。智度大道佛穷底。当知。此诸菩萨邻佛穷智度底。虚空者。法性虚空之寂光也。从本时寂光空中出今时寂光空中。今时寂光空中者。不识本时者。故言我经游诸国。乃不识一人地涌。千界皆是本时应眷属也。所以无三者。时节既久权转为实。但一无三。或可举一例知有三也。从本垂迹迹中始成佛。时亦有业愿通应。中间所化亦有四种。文殊观音调达等。或称为师或称弟子。于惑者未了。若拂中间无非是迹。则迹本可解。若执迹疑本。二义俱失(云云)。问迹本相望千界尘则少。增道数则多。本迹法身浅深异耶。答法身先满无增无减。约化缘广狭耳。问若尔初住二住化缘多少。法身亦应无浅深。答菩萨位未穷。约实证判浅深。佛位已满但约权化。有四句论广狭(云云)。问明因果等。皆约迹佛指本。明眷属而召本到迹何耶。答因果等法幽微难晓。故约此指彼。眷属是人。召证为易。或可将本人示迹人。或将迹法显本法互现意耳。八本涅槃妙者。经又复言。其入于涅槃。非实灭度。而便唱言当取灭度。非实灭度者。常住本寂也。唱言灭度者。调伏众生也。悉本时涅槃非迹涅槃。迹者大经明声光所集。始诸弟子终于蝮虿。无边身菩萨弟子之位。身量无边。岂有大师倚卧背痛。此乃生身示病示灭。法身无疾常存不变。或取析空因灭果亡。明有余无余涅槃。或取体法空因灭果亡。明有余无余涅槃。生身迹灭者。如阿含中。结业之身父母所生。弃国捐王六年苦行。三十四心断结成道。八十二岁老比丘身。诣纯陀舍持钵乞食。食檀耳羹食讫说法。果报寿命中夜而尽。入无余涅槃。以火阇毗收取舍利者。此三藏涅槃相。若释论云。六地菩萨见思已尽。七地去誓扶余习。受生死身。乃至上生下降。一念相应慧断习成佛。可度众生缘尽息化。入无余涅槃。此通佛涅槃相也。若地人云。缘修显真修菩提。果满成大涅槃。亦称为方便净涅槃。大经云。因灭是色获得常色。受想行识亦复如是。是名色解脱。受想行识解脱。乃是分段变易因尽。获常住有余涅槃。两处阴果身尽。获常住无余涅槃。此与前异。是别佛涅槃相也。大经云。大般涅槃常住不变。能建种种示现调伏众生。如首楞严广说。名大涅槃常乐我净。此与前异。即圆涅槃相也。经曰。今日座中无央数众。各见不同。或见如来入涅槃。或见如来住世一劫减一劫。或见如来住世无量劫。或见丈六身。或见小身大身。或见报身坐莲华藏世界海。为百千亿释迦牟尼佛。说心地法门。或见法身同于虚空。无有分别。无相无碍遍同法界虚空。或见此处娑罗树林。悉是土砂草木石壁。或见此处金银七宝清净庄严。或见此处三世诸佛所游之处。或见此处即是不可思议。诸佛境界真实法体。此明佛身依正各有四相。即前四涅槃相也。大经与此经义同。大经以常住为宗。迦叶初问长寿。佛答中处处多显未来常住。少明先成寿命。为法华已说故。彼经虽一两处说。不可判为近成短命。今经正明发迹显本。无量寿命为宗。少说未来常住。虽一两处少说。不可判为无常。二经互举。利根知本常未来亦常。解未来长寿。亦解本来长寿。其义是同。又此经数数现生现灭者。生非实生灭非实灭。常住义显。又二万灯明迦叶。皆不说涅槃。秖于法华明本常未来常。弥见法华明常义显(云云)。以三义故知诸涅槃迹而非本。今始入故入复出故。拂中间故。此迹涅槃皆从本垂。云何执迹。谓言是本。是不识迹本也。若拂迹显本。则二义不迷。非迹非本不思议一也。九本寿命妙者。上因妙中以智慧为命。此则非长非短。由非长非短之慧命。能为长短。此中正明长短寿命。经处处自说名字不同年纪大小。年纪者是寿命也。大小者长短也。经中间处处年纪大小者。约迹而悬指本也。迹不同者。三藏佛父母生身。八十二尽。身灰智灭毕竟不生。通教佛誓愿之身。化缘若讫亦归灰断。灭已不生。此两佛但齐业齐缘。不得非长非短之慧命。不能作长作短大小之寿命也。别教登地破无明。得如来一身无量身。一身湛然安住。无量身百界作佛。亦示九界身。得论年纪大小。大即大乘常寿。小即小乘无常之寿也圆教登住时亦如是。此等皆因中菩萨。非常非无常。能作常无常大小之寿。况后心乎。况妙觉乎。如此等寿三义。皆迹中因果之寿。此寿皆从本地因果圆满而垂此迹。迹既如此况复本也。经我本行菩萨道时。所成寿命今犹未尽。指于本因。因寿尚未尽。况本果寿。若执迹则不知本。今拂迹则识本。亦识不思议一也。十释本利益妙者。文云。皆令得欢喜。欢喜即利益相。若迹中三乘共十地别十地。开权显实按位妙入位妙。如是等益。乃至闻寿命增道损生。皆是迹中益也。乃至中间权实之益。亦是迹益。以迹望本。本亦应有偏圆利益。所以下方菩萨皆住虚空者。皆居寂光本益也。故本本以垂迹。借迹以知本不复具记也

○第六约三世料简者。文云。如来自在神通之力。如来大势威猛之力。如来师子奋迅之力。即是三世益物之文。若过去最初所证权实之法。名为本也。从本证已后方便化他。开三显一发迹显本者。还指最初为本。中间示现发迹显本。亦指最初为本。今日发迹显本。亦指最初为本。未来发本显迹。亦指最初为本。三世乃殊。毗卢遮那一本不异。如百千枝叶同趣一根(云云)。问现见无量佛。悉是释迦分身。为当犹有余佛。余佛复有分身不。答普贤观云。东方有佛名曰善德。彼佛亦有分身诸佛。若尔亦有诸佛。诸佛亦有分身。又神力品云。弹指謦欬是二音声遍至十方诸佛世界。彼佛四众遥伸供养。所散诸物从十方来。譬如雪聚遍覆此间诸佛之上。故知有诸佛。诸佛亦有分身也。问三世诸佛皆有分身者。云何复言多宝如来全身不散如入禅定。若全身不散。云何复言游于十方。证法华经二意云何通。答释论解念佛中云。多宝无人请说法。便入涅槃。后化佛身及七宝塔。证法华经。若从论释。乃是化作全身。非无分身也。师云。若言不得说法。那告四众我灭后起一大塔。非都不说法。应是不说法华。故发大誓愿。不碎生身之骨。全身不散出证圆经。如入禅定者。表于不灭出证常经。表于不偏不偏不灭圆常义。显口唱真净大法真是常。略举二德我乐可知。钝者读文犹自不觉也。问三世诸佛皆显本者。最初实成若为显本。答不必皆显本。今作有义者。最初妙觉指初住为本。若初住被加作妙觉。亦指初住为本。初住之前。竖无所指横有体用。即指体岂非本耶。又发愿故说寿长远如文(云云)。又解。最初之佛虽无长远已今权实等。本迹之可显而有体用教行理教事理等本迹之可显(云云)。若作无义。若最初始成佛。既始得本。未论垂迹无久迹可发。无久本可显(云云)。若久成佛如释迦之例。以东方为譬。若久此者。即以四方为譬。又久者十方为譬。若近此者。则减东方为譬。若都无者则无所譬(云云)问若实初成。无久本可显。云何经言是我方便诸佛亦然。答虽无长久之本。若须用方便者。佛有延促劫智。能演七日为无量劫义(云云)。问佛若有久成始成。有发迹不发迹。亦应有开三显一不开三不显一耶。答若菩萨声闻共为僧者。则有开三显一。若纯菩萨为僧者。何须开显耶。问若不开三显一。五佛章云何。答同是声闻菩萨共为僧。出五浊世可如此。出净土佛则不然。问破十粗显十妙。则无明惑尽一实理彰。今更破迹妙为粗显本为妙。破何惑显何理。答无明重数甚多。实相海深无量。如此破显无咎。又问若尔还以妙破妙。所破之妙妙而更粗。亦应还以粗破粗。所破之粗例更是妙。所破四住例亦应妙。答就顿明义。秖四住即是于妙。况破四住智。宁非妙耶。又问若尔但有顿义。应无渐义。答若分渐顿。渐之能所俱粗。顿之能所俱妙(云云)。问中间有偏圆权实。而同称是权者。亦应同称为偏耶。答通义则尔别义不然偏圆约法法则已定。故偏非圆圆非偏。权实约教。迹中施设同皆是假故就假论权耳。问既有带粗妙。复有不带粗妙。亦应有带妙粗不带妙粗。答此应四句。带粗妙。即别教也。不带粗妙即圆教也。带妙粗即通教也。不带妙粗即三藏也。又带粗妙如通。不带粗妙如圆。亦带粗亦不带粗如别。非带非不带如圆接别。如圆别接通。又约五味。粗不带妙如酪。妙不带粗如醍醐。亦带粗亦不带粗如生熟苏。非带粗非不带粗如乳(云云)。问二粗既不同。那忽同呼为粗。答事有浅深故为二。俱非妙理故同是粗。问应带方便实。不带方便实。答例问亦应有带二一不带二一。答例。通论本迹秖是权实。别论高下宜用本迹。横论真伪宜用权实。本迹约身约位。权实约智约教(云云)。问本地十妙约六重本迹。摄属何耶。答非已今非中间。乃是体用教行理。教等共论十妙也

○第七判粗妙者。若迹中已得十粗为粗。十妙为妙。未开十粗为粗开十成妙。具如前说。迹中若待粗妙若开粗妙。此妙不异本妙。而言始得始得为粗。本中先成若粗若妙。若开粗妙亦不异迹妙。而是先得先得称妙。又迹中事理始得为粗。本中事理先得为妙。迹中理。教教行体用权实等亦如是。又若未发迹显本者。但解迹中事理之粗妙。终不能解本中之事粗。况解本中之理妙。弥勒尚不达。何况余人。若发迹中之事理。即显本中之事理。亦知由本中之事理。能垂迹中之事理。迹既由本则本妙迹粗既有本迹之殊。故言粗妙。妙理则非迹非本。不思议一也。理教教行体用权实已今等亦如是

○第八明权实者。照迹中十粗之境为权。照迹中十妙之境为实。乃至中间三世所照。十粗之境为权。十妙之境为实。若权若实悉皆是迹。迹故称权。如是中间无量无量不可说节节权实。余经尚无中间一番之权。况一番之实。尚无中间一番权实。况无量番。尚无中间权实。况有本地权实。中间权实皆名为权。本初照十粗十妙皆名为实。迹权本实俱不思议。不思议即是法性。法性之理非古非今。非本非迹非权非实。但约此法性论本迹权实粗妙耳。但以世俗文字有去来今。非谓菩提有去来今也。复次分别权实则有三种。谓自行化他自行化他。具如境妙中说。本地自行所契权实二智。名佛自行权实。从本已来乃至鹿苑。种种方便随他意语。说此二智回转无方。名佛化他权实二智。化他虽有二种皆名为权。自行虽二种皆名为实。是名自行化他合说权实。复次迹中约实施权。意在于实而实意难测。何者。化城是权而人作实解。是不识权亦不知实。若废权显实。意在于权权则易测。何者。既知化城一事是佛权施。则遍达恒沙佛法。远通久劫方便。故华严中明。为阿鞞跋致多明事数。即其义也。若开权显实者。达事法已权意即息。亦不离权远求于实。权即是实无复别权。故言开权显实也。迹中既有三意。如此迹由本垂。本亦如是。本迹虽殊不思议一也(云云)

○第九利益者。前明生身益。次明法身益。生身两处得益。迹门会三归一开权显实。生身菩萨得利益者。于十妙中得五妙益。何者。境妙则通一切具有。乘妙则别究竟在佛。感应神通说法。皆是果上之益。若未证果不论此益。若于六即位中得四即益。理即究竟即例如前。但得名字即中。智行位眷属功德乃至分真即中。智行位眷属功德。如身子得记。四众天龙欢喜说偈云。大智舍利弗。今得受尊记。我等亦如是悉当得作佛。即是生身菩萨。闻迹门说法得益之。相也。发本显迹说佛寿长远。观佛三昧得大增长。从此亦有生身菩萨。得十妙中之五益。六即中之四益。损生增道(云云)。从二住去至一生在。皆是法身得五益。何以故。应生闻本地功德。观佛三昧转更深广。不可称量。不比前来迹中之益。何者。佛境转深功德亦大。故分别功德品云。佛说希有法。昔所未曾闻。世尊有大力。寿命不可量。说得法利者。欢喜充遍身。或住不退地。或得陀罗尼。即是生法二身得益之相。若论实道得益两处不殊。而权智事用不得相比。喻如慧解脱俱解脱。无漏不二而功德优劣。前迹门得道止齐无生法忍。本门得道齐余一生在。以尘为数。多小深浅岂同于前。当拣彼文。从发心处即是六根净位。乃至一生在。即是最后分真(云云)。又流通利益者。前流通迹门。是诸发誓菩萨及诸罗汉。得授记者。此土他土弘经。论其功德观文。但明冥利。不说显益。今说本门。付嘱一切诸佛所有之法。兼得迹门法也。秘奥之藏。即是本迹中实相也。一切甚深之事。即是本迹中因果也。如此等法。付嘱千世界微尘菩萨。法身地弘经。何但如生身此土他土弘经耶。十法界身游诸国土。则有冥显两益也。疑者云。法身常有佛何须菩萨弘。但弘之在人待时待伴。如佛虽在世。而文殊入龙宫。法身处虽有佛复须外缘。故佛付嘱吐舌摩顶。种种相貌殷勤付嘱。令弘此法得无量微妙功德。其有闻者。妙益不可称数。故文云。若有闻佛说寿量。一切皆欢喜。得无量无漏功德之果报。即此意也

○十观心者。本妙长远岂可观心。虽不即是亦不离心。何者。佛如众生如一如无二如。佛既观心得此本妙。迹用广大不可称说。我如如佛如。亦当观心出此大利。亦愿我如速如佛如。故文云。闻佛寿无量。深心须臾信。其福过于彼。愿我于未来长寿度众生。如今日世尊。诸释中之王道场师子吼。说法无所畏。我等于未来一切所尊敬。坐于道场时说寿亦如是。此即观心本妙。得六即利益之相(云云)

△问大妙云何。答此应三双六句分别(云云)。文云。佛自住大乘。又云。如是大果报。又云。有大车而题称为妙。如涅槃云。大般涅槃微妙经典。而题称为大。即妙是大即大是妙也。大品云。色非深非妙。乃至识非深非妙。此是大破妙。此文云。一切法空寂。无漏无为无大无小。此是妙破大。如大阿罗汉。此大犹修于妙。如灭止妙离。此妙犹更修大(云云)。问若大妙一等。余经俱应称妙。答余经通论。约理大妙不殊。而别带方便。此经不带方便。故别称妙。小乘得入发迹显本。故别称妙。问大小俱称妙。大小俱明常。一往斥之(云云)。小乘灭止妙离名同理异。不得是常。并云不得是妙。答妙名不可思议。小乘真谛亡言绝虑。通得是不思议。通名为妙耳。次当纵之。亦得以三无为称常而常异。又并既俱称常。亦俱会一。答会诸见同入真而会异。又并俱无常俱粗俱不会耶。例通而义异。云何大乘无常。大乘非但无无常。亦无于常。以无于常。故言无常。云何大乘是粗。夫有言说即名为粗。云何大乘不会耶。一切诸法皆是佛法。更何所会(云云)

△次释莲华者为四意。一定法譬。二引旧释。三出经论。四正解释。定法譬者。权实难显借喻莲华。譬于妙法。又七喻文多。故以譬标题。又解云。莲华非譬当体。得名类如。劫初万物无名。圣人观理准则作名。如蛛罗引丝。仿之结网。蓬飞独运依而造车。浮槎泛流而立舟。鸟迹成文而写字。皆法理而制事耳。今莲华之称非是假喻。乃是法华法门。法华法门清净。因果微妙。名此法门为莲华。即是法华三昧当体之名。非譬喻也。余经多自释名。此经无解。或是其文未度耳。而此两释皆有道理。今融二意。问莲华定是法华三昧之莲华。定是华草之莲华。答定是法莲华。法莲华难解故草华为喻。利根即名解理。不假譬喻。但作法华之解。中下未悟。须譬乃知。以易解之莲华。喻难解之莲华。故有三周说法。逗上中下根。约上根是法名。约中下是譬名。三根合论双标法譬。如此解者与谁为诤耶。今且依法譬为释也。二引旧解。睿师序云。未敷名屈摩罗。将落名迦摩罗。处中盛时名分陀利。远师云。分陀利伽是莲华开喻。然体逐时迁名随色变。故有三名也。大经亦云。人中莲华分陀利华。二名并题者。应有通别之异。今取莲华是通。分陀利是别称。道朗云。鲜白色或翻为赤色。或翻为最香。如此皆是开盛之义。举分陀利则兼之矣。问梵本举别此方用通何也。答外国有三时名。此方则无。但举通名通自兼别。他解莲华有十六义。莲华从缘生。譬佛性从缘起。莲华能生梵王。譬从缘生佛。莲华生必在淤泥。譬解起生死。莲华是瑞见者欢喜。譬见者成佛。莲华从微之着。譬一礼一念皆得作佛。莲华必俱譬因果亦俱。华必莲譬因必作佛。莲华譬引入莲华世界。莲华是佛所践。譬众圣托生此十譬秖是今家。譬行妙中片意耳。莲华生淤泥淤泥不染。譬一在三中三不染一。莲华三时异。譬开三秖是一莲华有开有合。譬对缘有隐有显。莲华于诸华最胜。譬诸说中第一。华开实显譬巧说理显。莲华有三时异。譬权实适时。此六譬秖是今家说法妙中片意耳。如光宅云。余华华果不俱。譬余经偏明因果。此莲华华果必俱。譬此经双辨因果。弟子门明因师门明果。故借莲华为喻。今谓此解语略而义偏。若迹门师弟各有因果。文云。我尽行诸佛所有道法。道场得成果。即师之因果。会三归一即弟子因。得记作佛即弟子果。本门云。我本行菩萨道时即师因。我得佛已来甚大久远。即师果。我昔教其初发心。即弟子因。今皆住不退悉当得成佛。即弟子果。彼义偏略故不用。且助成其语。如四微色法。不当华之与莲。而约微论华论莲。今实相之理不当本迹因果。而约理明于本迹因果耳。又如四微不当开之与合。而约微论开合。实相不当权实。而约实相论开权显实发迹显本耳。三引经论者。法华论列十七名。一无量义。二最胜。三大方等。四教菩萨法。五佛所护念。六诸佛秘藏。七一切佛藏。八一切佛密字。九生一切佛。十一切佛道场。十一一切佛所转法轮。十二一切佛坚固舍利。十三诸佛大巧方便。十四说一乘。十五第一义住。十六妙法莲华。十七法门摄无量名字句身。频婆罗阿閦婆等。余名悉不解释。唯列十七名。次解莲华。有二义。一出水义。不可尽出离小乘泥浊水故。复有义莲华出泥水。喻诸声闻入如来大众中坐。如诸菩萨坐莲华上。闻说无上智慧清净境界。证如来密藏故。二华开者。众生于大乘中。心怯弱不能生信故。开示如来净妙法身。令生信心故。今解论意。若言令众生见净妙法身者。此以妙因开发为莲华也。若言入如来大众坐莲华上者。此以妙报国土为莲华也。何者。卢舍那佛处莲华藏海。共大菩萨。皆非生死人。若声闻得入于此。即妙报国土为莲华也。彼论望今意。乃是行位两妙耳。大集云。怜愍为茎。智慧叶。三昧为须。解脱敷。菩萨蜂王食甘露。我今敬礼佛莲华。又以戒定慧陀罗尼为缨珞。庄严菩萨。今解经。当是菩萨揽四法成假名人。如蜂在华。复以前四法自资。如蜂食华也。四正释者。若依大集行法因果为莲华。菩萨处上即是因华。礼佛莲华即是果华。若依法华论。以依报国土为莲华。复由菩萨修莲华行。报得莲华国土。当知。依正因果。悉是莲华之法。何须譬显。为钝根人不解法性莲华故。举世华为譬。亦应何妨。然经文两处。说优昙钵华时一现耳。此华若生轮王应出。若说此经。即授佛记法王王世也。此灵瑞华似莲华。故以为喻。若从此意即是借喻。喻于妙法。夫喻有少喻遍喻。如涅槃(云云)。但少喻以月喻面。不得求其眉目。雪出况象。不可觅其尾牙。今法华三昧无以为喻。喻此莲华耳。夫华有多种已如前说。唯此莲华华果俱。多可譬因含万行果圆万德。故以为譬。又余华粗喻九法界十如是因果。此华妙喻佛法界十如因果。又以此华喻佛法界迹本两门。各有三喻。喻迹者。一华生必有于莲。为莲而华。莲不可见。此譬约实明权意在于实。无能知者。文云。我意难可测。无能发问者。又云。随宜所说意趣难解。二华开故莲现。而须华养莲。譬权中有实而不能知。今开权显实意须于权。广识恒沙佛法者。秖为成实使深识佛知见耳。三华落莲成。即喻废三显一。唯一佛乘直至道场。菩萨有行见不了了。但如华开。诸佛以不行故见则了了。譬如华落莲成。此三譬迹门。从初方便引入大乘。终竟圆满也。又三譬譬本门者。一华必有莲譬迹必有本迹含于本。意虽在本佛旨难知。弥勒不识。二华开莲现。譬开迹显本。意在于迹。能令菩萨识佛方便。既识迹已还识于本。增道损生。三华落莲成。譬废迹显本。既识本已不复迷迹。但于法身修道圆满上地也。此三譬譬本门始从初开终至本地。二门六譬各有所拟。初重约佛界十如施出九界十如。次重开九界十如显佛界十如。三重废九界十如成佛界十如。三譬摄得迹门始终尽。若得此意。十二因缘四谛三谛等智行位。乃至功德利益。亦用此譬。譬之(云云)。第四重约本佛界十如。施出迹中佛界十如。第五重开迹中佛界十如。显出本中佛界十如。第六重废迹中佛界十如。成本中佛界十如。始终圆满开合具足。是为少分以莲华为譬也。多分喻者。释论解师子吼义。从深山谷种生长。身力手足爪牙头尾。震吼等譬。譬师子吼法门。亦如大经明波利质多树黄嘴疱果等。遍喻行人。今亦如是。从初种子乃至莲成。喻于妙法也。譬如石莲乌皮在外白肉在内。四微为质。卷荷欲生微细众具。开华布须莲实房成。初后不异莲华。始终十义具足。譬佛界众生。始自无明终至佛果十如。是法无有缺减。总譬竟。譬如石莲。黑则叵染硬则叵坏。不方不圆不生不灭。劫初无种故不生。今不异初故不灭。是名莲子相。一切众生自性清净心。亦复如是。不为客尘所染。生死重积。而心性不住不动不生不灭。即是佛界。如是相净名曰一切众生即菩提相。即其义也。譬如莲子虽复乌皮淤泥之中。白肉不改。一切众生了因智慧。亦复如是。五住淤泥生死果报。一切智愿犹在不失。是名佛界如是性。故言烦恼即菩提。又诸法不生般若生。即其义也。譬如莲子在淤泥中。而四微不朽是名莲子体。一切众生正因佛性。亦复如是。常乐我净不动不坏。名佛界如是体。大经言。是味真正停留在山。草木丛林不能覆灭。即其义也。譬如莲子为皮壳所笼为泥所没。而卷荷在心。而有生长以气。一切众生心亦如是。虽为苦果所缚集惑所沈。而能于中发菩提心。甚大雄猛。如师子乳如师子筋弦。是名佛界如是力。经言。若发菩提心动无边生死。破无始有轮。阎浮人未见果。而能勇猛发心也。譬如莲子虽复微小乌皮之内。具有根茎华叶须台众具顿足。是名莲子如是作。一切众生初发菩提心。亦复如是。明解决定慈悲誓愿。上求下化誓取成就。志不疲退。是名佛界如是作。华首经言。一切诸功德皆在初心中。即其义也譬如莲子根依淤泥而华处虚空。风日照动昼夜增长。荣耀顿足。一切众生亦复如是。从无明际发菩提心。修菩萨行出离生死。入法性中因行成就。值于佛日被神通风。其心念念入萨婆若海。此名佛界如是因。经言。于无量劫所作功德。不如五茎莲华。上然灯佛得功德多。此是真因成就。即其义也。譬如莲华须蕊围绕在华内莲外。此名莲华如是缘。菩萨亦如是。于真因中具足万行六波罗蜜一行一切行。资助于因。如须在华内。若得果时众行休息。如须在莲外。是名佛界如是缘经言。尽行诸佛所有道法。即其义也。譬如莲华华成结莲而华叶零落。台子成实。此名莲子如是果。菩萨亦如是。真因所感。无上菩提大果圆满。究竟成实。是名佛界如是果。故经言。佛子行道已来世得作佛。即其义也。譬如莲实房台包绕。此名莲子如是报。菩萨亦如是。大果圆满无上报足。习果之果依于报果。如实依台。经言。如是大果报久修业所得。即其义也。譬如泥莲四微。处空莲四微。初后不异。此名莲子本末等。一切众生亦如是。本有四德隐名如来藏。修成四德显名为法身。性德修德常乐我净。一而无二。是名佛界十如本末究竟等。经言。众生如佛如一如无二如。即其义也。是用莲华譬十如境竟。次用莲华譬十二因缘者。乌皮淤泥水草重覆。通如上说也。即是无明支种子。能生力即是行支。内有卷荷华须备具。即是识名色六入触受支。含润爱取有支。团圆盘屈不能得出。即是老死支。若能芽锋萌动。钻乌皮破即是无明灭。不复在乌皮内生。即是诸行灭。出[穀-禾+卵]壳外即是老死灭。此略譬四种十二因缘也。次用莲华譬四谛者。乌皮譬界内苦。白肉譬界内集。泥譬界外集。水譬界外苦。道灭可知。此通譬四种四谛也。次用莲华譬二谛者。莲藕茎叶等譬俗。莲藕茎孔空譬真。此通譬七种二谛也。次用莲华譬三谛者真俗如前。四微拟常乐我净。譬中道第一义谛。此通譬五种三谛也。四微无生无灭譬一实谛。劫初无生今时无灭。譬无谛无说也。用莲华譬境妙竟。次更譬九妙者。内有生性譬智妙。卷荷生性譬空智妙。须叶生性譬假智妙。莲台四微生性譬中智妙。此三生性譬一心三智妙也。莲子虽小备有根茎华叶。譬行妙。茎即慈悲。叶即智慧。须即三昧。开敷即解脱。又叶以譬三慈者。覆水青叶譬众生缘慈。覆水黄叶譬法缘慈。倚叶譬无缘慈。倚荷若出莲生不久。无缘慈成得记不久。又根华子叶利益人蜂即檀。香气即尸。生泥不辱即忍。增长即精进。柔湿即禅。不污即慧。齐此譬行妙也。莲譬理即位。芽钻皮粗住位。芽出皮细住位。钻泥欲定位。齐泥未到位。出泥在水四禅位。禅定如水能洗欲尘。处水增长譬无色位。齐此譬观行莲华位。出水譬破见思。相似莲华十信位。处空含而欲敷。譬十住位。须台可识譬十行位。随日开回譬十回向位。敷舒成就荷负蜂蝶。譬十地位。须叶零落台子独在。譬休息众行。妙觉圆满果上无事。真常湛然此皆譬位妙也。莲有四微譬真性轨。莲房内虚茎藕中空。譬观照轨。台房围绕譬资成轨。此譬三法乘妙也。莲成处空影临清水。譬显机显应。影临浊水譬冥机冥应。影临风浪之水。譬亦冥亦显机应。大经云。闇中树影夜影临水。譬非冥非显机应。此等譬感应妙也。若风摇莲华。东昂西倒向南映北。下风则合上风则开者。即譬东涌西没中涌边没等。此譬地动瑞。日暮华合譬入定瑞。日出华开譬说法瑞。远望则红近望则白。赤华青叶相映辉赫。譬放光瑞。流芳遍野譬栴檀风瑞。蕊粖飘扬譬天雨华瑞。风雨飘洒翻珠相棠。譬天鼓自然鸣瑞。此等皆譬神通妙也。华合未开。譬隐一乘分别说三。华叶正开譬会三归一但说一乘。华落莲存譬绝教冥理。若知如来常不说法。乃名多闻。此等譬说法妙也。从一藕边更生一华。展转复生无量莲华。譬业生眷属妙。从一莲房堕子。在泥更生莲华。展转复生无量莲华。譬神通眷属妙。掘移彼藕。采彼莲子种于此池。莲华炽盛譬愿生眷属妙。彼池飞来如游丝薄雾。入于此池莲华炽盛。譬应生眷属妙。鱼鳖噞喁其下。蜂蝶翔集其上。譬众生果报清凉之妙益。见者欢喜譬于因益。采用其叶譬三草益。采用其华譬妙小树益。采用其莲譬妙大树益。采用其藕譬妙实事益。此等譬功德利益。如是等譬及余无量譬喻以譬迹中十妙(云云)。次譬本者。譬如一池莲华始熟。熟已堕落。投于泥水方复生长乃至成熟。如是展转更生熟。岁月既积。遂遍大池华田布满。佛亦如是。本初修因证果已竟。为众生故更起方便在生死中。示初发心复示究竟。数数生灭无数百千。本地垂应俯同凡俗。更修五行。乌莲更生茎叶。譬更修圣行。莲子四微稍稍增长。譬更修天行。荷叶始生譬更修梵行。莲子堕泥。譬同诸恶更修病行。莲芽始萌。譬同小善更修婴儿行。如是三世益物不可称计。遍满法界。无非分身垂迹开迹废迹等益(云云)。若非莲华。何由遍喻上来诸法法譬双辨故称妙法莲华也

妙法莲华经玄义卷第七下妙法莲华经玄义卷第八上

        天台智者大师说

第二释通名者。经一字也。具存胡音。应云萨达磨分陀利修多罗。萨达磨。此翻妙法。分陀利。此翻莲华。已如上释。修多罗。或云修单兰。或云修妒路。彼方楚夏。此土翻译不同。或言无翻。或言有翻。释此为五。一明无翻。二明有翻。三和融有无。四历法明经。五观心明经。言无翻者。彼语多含此语单浅不可以单翻复应留本音。而言经者。开善云非正翻也。但以此代彼耳。此间圣说为经。贤说子史。彼圣称经菩萨称论。既不可翻宜以此代彼。故称经也。既不可翻而含五义。一法本亦云出生。二云微发亦云显示。三云涌泉。四云绳墨。五云结鬘。今秖作五义不可翻。今于一中作三。三五十五义。一教本二行本三义本。今广释之。言法本者。一切皆不可说。以四悉檀因缘则有言说。世界悉檀。说则为教本为人。对治则为行本。第一义悉檀则为义本。所言教本者。金口所说一言为本。泒出无量言教。若通若别当时被物。闻即得道故。经言。一一修多罗。复有无量修多罗。以为眷属。若后人不解。菩萨以佛教为本。作通论别论。申通别经。令佛意不壅寻者得道。良由其论有本故也。诸外道等虽有所说。不与修多罗合。戏论无本不能得道。经是行本者。示人无诤法。导达通塞开明眼目。救治人病。如教修行则起通别诸行。从此至彼入清凉池。至甘露地泥洹真法宝。众生从种种门入。故知经是行本。经是义本者。寻一句诠于一义。寻无量句诠无量义。或寻一句诠于无量义。寻无量句诠于一义。若通若别寻诠会入。故经是义本。束此三种为法门者。教本即是闻慧。行本即是思慧。义本是修慧。见真法本之义尚已多含。故不可翻也。或言出生例此可知。二含微发者。佛以四悉檀说。言辞巧妙次第诠量初中后善圆满具足。如大海水渐渐转深。闻教之者。初闻世界悉檀。次第领受。分别法相微有解生。渐渐增长明练通达。又遍读诸异论广知智者意。多闻强识以至成佛。就此即约教论微发。初闻为人。对治即能起行。始人天小行。次戒定慧入无漏行。见道修道遂证无学。从小入大终于妙觉。是约行论微发。初闻第一义悉檀。展转增广入于闻思。暖顶世第一。次入见谛得真第一义。次入修道至无学。从小入大见似真中道。起自毫末终成合抱也。束此三发为法门者。依小乘即三种解脱发。依大乘初住中。有教发是般若。行发即如来藏。理发是实相微发已自多含。故不可翻也。三含涌泉者。从譬为名也。佛以四悉檀说法。文义无尽法流不绝。若闻世界说一句。解无量句。月四月至岁。如风于空中自在无障碍。说初心解已如涌泉。何况后心何况如来。犹如石泉流润遍益也。若闻为人对治。起无量行恒沙佛法种种法门。一行无量行入善境界。登八正直道。若闻第一义理若虚空。虚空之法不可格量。遍一切处。是名义涌泉。束此为法门者。教泉是法无碍辩。行泉即辞无碍辩。义泉即义无碍辩。乐说通三处。涌泉已自多含。故不可翻也。四含绳墨者。佛以四悉檀说。初闻世界裁爱见之邪教。不为邪风倒惑。得入正辙。即教绳墨也。若闻为人对治。远离非道。入好正济道品之路。即行绳墨也。若闻第一义裁爱见此岸。得至彼岸。不保生死亦不住无为。即义绳墨。束此为法门者。教裁邪即是正语。行裁邪即正业正精进正念正定等。义裁邪即正见正思惟等。绳墨已自多含。故不可翻。五含结鬘者。结教行理如结华鬘令不零落。世界悉檀结佛言教不零落。为人对治结众行不零落。第一义结义理不零落。束此为法门者。结教成口无失。结行即身无失。结义即意无失亦是三种共智慧行。亦是三陀罗尼教不零落。是闻持陀罗尼。行不零落行陀罗尼。义不零落即总持陀罗尼。若作严身释者。即是约教名智慧庄严。约行名福德庄严。约义即是所庄严。所庄严即是法身。为定慧庄严也。一切众生皆有法身。法身体素天龙之所忽劣。若修学定慧庄严法身。则一切见敬也。旧云。经含五义。今则经含十五义。岂可单汉翻胡。名含之释如此(云云)。训者训常。今释其训。天魔外道不能改坏。名为教常。真正无杂无能踰过。名为行常。湛然不动决无异趣。名为理常。又训法者。法可轨行可轨理可轨。今直释训已含六义。况胡言重复而可单翻耶。二言有翻者。亦为五。一翻为经。经由为义。由圣人心口故。今亦随而释之。谓教由行由理由。一切修多罗。一切通别论。一切疏记等。皆由圣人心口是名教由。一切契理行。一切相似行。一切信行法行。皆由圣人心口。故以行为由。一切世间义。一切出世义。一切方便义。一切究竟义。皆由圣人心口。故以义为由。教由世界。行由为人对治。义由第一义悉檀。又言经者纬义。如世绢经。以纬织之龙凤文章成。佛以世界悉檀说经。菩萨以世界纬织。经纬合故贤圣文章成。又约行论经纬。慧行为经行行为纬。经纬合故八正文章成。又约理论经纬者。诠真为经诠俗为纬。经纬合故二谛文章成。二翻为契者。契缘契事契义。世界说是契缘。随宜说是契生善。随对治说是契破恶。是为契事。随第一义说。是契义。三翻法本者。即教行理本如前释(云云)。四翻线者。线贯持教。行理令不零落。严身等义如前释。又线能缝义。缝教使章句次第。堪可说法。如支佛不值十二部线。不能说法。世智辩聪亦不得经线。正语不成。又线能缝行。依经则行正。违经则行邪。又缝理者。理所不印。堕六十二邪。理所印者。会一究竟道也。五翻善语教。亦是善行教。亦是善理教。世界悉檀说即善语教。为人对治即善行教。第一义说即善理教。是名修多罗有五种翻也。三和融有无者。昔佛法初度胡汉未明。言无翻者。乃是河西群学所传。晚人承用加以此代彼。今传译焕烂方言稍通。岂苟执无翻。犹以多含为解。若多含者。何局五耶。若有翻者。以何为正义。宁种种。翻那得多。若翻修多罗为经者。修多罗有九。谓通别修多罗藏等。何不见周正十二部中经部。三藏中有经藏耶。若翻为契法本等者。亦应改正十二部中有契部。法本部线部善语教部。三藏中应有线等藏。彼诸处皆不从此翻。何独通修多罗耶。释论云。般若尊重智慧轻薄。何得用轻翻重。若尔即是无翻家证。夫实相尊重不可说。遂得作胡言而说。何不得作汉语而翻。若不可翻亦不可说。此即有翻家证旧云。涅槃含三德不可用灭度为翻。又梁武云。灭度小乘法。不可用翻大涅槃。此未必尔。经言。有涅槃大涅槃。亦应有灭度大灭度。此经云。如来灭度岂非大灭度。既以小灭度翻小涅槃。何得不以大灭度翻大涅槃。若谓灭度偏不含三德者。今作含释。灭者即解脱。解脱必有其人。人即法身。法身不直身。必有灵智。灵智即般若。又大即法身。灭即解脱。度即般若。但标灭度含三宛然。何得无翻耶。若执一言则彼彼相是非。不达佛意已如上说。今和融有无虚豁义趣。若言无翻名含五义。于一一义更含三义。弥见其美。若作有翻于一一翻。亦具三义。转益旨深。任彼有无何所乖诤。大经云。我终不与世间共诤。世智说有我亦说有。世智说无我亦说无。如此通融于二家。无失而有理存焉。复次圆义无方处处通入。乃如上说。若正翻名。世谛不得混滥。今且据一名以为正翻。亦不使二家有怨。何者。从古及今译胡为汉。皆题为经。若余翻是正。何不改作契线。若传译佥然。则经正明矣。若等是无翻。何不标微发涌泉等。今正用经。于多含义强。含三法本三微发三涌泉。诸绳墨结鬘等义。亦含契线善语教。训法训常等。无不摄在经一字中。余句亦如是。诸大小乘教。皆以经为通名故。不用余句也。四历法明经者。若以经为正翻。何法是经。旧用三种。一用声为经。如佛在世金口演说。但有声音诠辩。听者得道。故以声为经。大品云。从善知识所闻也。二用色为经。若佛在世可以声为经。今佛去世纸墨传持。应用色为经。大品云从经卷中闻三用法为经内。自思惟心与法合不由他教亦非纸墨但。心晓悟即法为经。故云。修我法者。证乃自知(云云)。三尘为经。施于此土。耳识利者。能于声尘分别取悟。则声是其经于余非经。若意识利者。自能研心思惟取决。法是其经于余非经。眼识利者。文字诠量而得道理。色是其经于余非经。此方用三尘而已。余三识钝。鼻臭纸墨则无所知。身触经卷亦不能解。舌啖文字宁别是非。若他土亦用六尘。亦偏用一尘。如净名曰。以一食施于一切。于食等者于法亦等。于法等者于食亦等。此即偏用舌根所对为经。或有国土以天衣触身即得道。此偏用触为经。或见佛光明得道。此偏用色为经。或寂灭无言观心得道。此偏用意为经。如众香土以香为佛事。此偏用香为经。他方六根识利。六尘得为经。此土三根识钝。鼻不及驴狗鹿等。云何于香味触等。能得通达。问根利故于尘是经。钝者尘则非经耶。答六尘是法界。体自是经。非根利取方乃是经。何者。大品云。一切法趣色。是趣不过此色。能诠一切法。如黑墨色。一画诠一。二画诠二。三画诠三。竖一画则诠王。足右画则诠丑。足左画则诠田。出上诠由。出下诠申。如是回转诠不可尽。或一字诠无量法无量字共诠一法。无量字诠无量法。一字诠一法。于一黑墨小小回转。诠量大异。左回诠恶右回诠善。上点诠无漏下点诠有漏。杀活与夺毁誉苦乐。皆在墨中。更无一法出此墨外。略而言之。黑墨诠无量教无量行无量理。黑墨亦是教本行本理本。黑墨从初一点至无量点。从点至字从字至句。从句至偈。从偈至卷。从卷至部。又从点一字句中。初立小行后着大行。又从点字中初见浅理后到深理。是名黑色教行义三种微发又从黑色涌出点。出字句偈不可穷尽。涌出诸行无尽。涌出义无尽。是名黑色具三涌泉。又约黑色裁教行义邪。又约黑色结教行义鬘。又以严身。又色是由。由色故缚有六道生死。由色故脱有四种圣人。又色训法。法色故能成教行理。又色是常。色教不可破。色行不可改。色理不可动。又色不可翻。色义多含故。又色可翻名色为经。故见色经时知色爱见。知色因缘生法。知色即空即假即中。色即法界。总含诸法。法界文字文字即空。无点无字无句无偈。句偈文字毕竟不可得。是名知字非字非字亦字。墨色是经。为法本者若于墨字生嗔。断他寿命。若于墨字起爱而作盗淫。乃至于墨起痴。而生邪见。当知。墨字是四趣本。若于墨字生慈生舍。乃至生正见者。当知。墨字是人天本。若知墨字是果报无记。无记是苦谛。于报色生染即是集谛。知字因缘所成苦空无我是道谛。既知字非字不生字倒。诸烦恼灭即灭谛。知字四谛。知字四谛能生暖顶。若向若果贤圣解脱。当知。墨字是声闻本。若于字不了名无明。于字起爱恚是诸行。分别字好丑是识。识于字名名色。字涉于眼名六入。字尘对根名为触。纳领染着即是受。缠绵不舍是爱。竭力推求是取。取则成业名为有。有能牵果是名生老病死。苦轮不息。是则十二因缘本。若能知字非字。无明即灭不至于行。乃至不至老死。无明灭则老死灭。当知。此字是辟支佛本。若知字即空非灭。已空字性本空。空中无爱恚。乃至无邪正。字不可得。知字者谁。云何众生妄生取舍起慈悲誓愿行六度。济众生入如实际。亦无众生得灭度者。当知。此字是菩萨本。若知字非字。非字非非字。无二边倒名净。净则无业名我。我则无苦名乐。无苦则无生死名常。何以故。字是俗谛。非字是真谛。非字非非字是一实谛。一谛即三谛。三谛即一谛。是名境本。若知墨字从纸笔。心手和合而成。一一字推不得一字。一一点推亦不得字。则无所不得心手即不得能。无能无所知能所谁。是一切智本。字虽非字非字而字。从心故有点。从点有字。从字有句从句有偈。从偈有行从行有卷。从卷有帙从帙有部。从部有藏从藏有种种分别。是道种智本。虽非字非非字。而双照字非字。是为一切种智本。雪山为八字舍所爱身。是为行本。我解一句乃至半句。得见佛性入大涅槃。即是位本。我得三菩提。皆由闻经及称善哉。字即乘本。若忘失句逗还令通利。与其三昧及陀罗尼。即感应本。依文学通即神通本。依字故得语即说法本。说字教他即眷属本。勤学此字禄在其中。即利益本。如此解字手不执卷。常读是经。口无言声遍诵众典。佛不说法恒闻梵音。心不思惟普照法界。如此学问岂不大哉。当知。黑字是诸法本。青黄赤白亦复如是。非字非非字。双照字非字。不可说非不可说。不可见非不可见。何所简择何所不简择。何所摄何所不摄。何所弃何所不弃。是则俱是。非则悉非。能于黑色通达一切。非于一切非通达一切。是通达一切。非非非是一切法邪。一切法正。若于黑色不如是解。则不知字与非字。黄白赤青有对无对。皆不能知。若于黑色通达。知余色亦如是。此即法华经意。以色为经也。声尘亦如是。或一声诠一法(云云)。耳根利者。即解声爱见因缘。即空即假即中。知唇舌牙齿皆不可得。声即非声。非声亦声。非声非非声。声为教行义本种种等义。皆如上说。即是通达声经。香味触等亦复如是。文云。一切世间治生产业。皆与实相不相违背。即此意也。外入皆经。周遍法界者。内入亦如是。内外入亦如是。经云。非内观得解脱。亦不离内观(云云)。是则一尘达一切尘。不见一尘一切尘。通达一尘一切尘。于一识分别一切识亦不见一识一切识。而通达一识一切识。自在无碍平等大慧。何者是经何者非经。若欲细作。于一一尘识例可解。有翻无翻以三义织之。后用三观结之(云云)。历诸教分别经者。若言理绝文字。文字是世俗。寄字诠理理可是经。文字非经。六尘等皆是经诠。非正经也。此即三藏中经耳。若无离文字说解脱义。文字性离即是解脱。六尘即实相无二无别。如上所说者。圆教中经也。带三方便作此说者。方等中经也。带二方便如此说者。般若中经也。带一方便作如此说者。华严中经也。五明观心经者。皆类上为四也。一类无翻者。心含善恶诸心数等。当知。此心诸法之都何可定判。若恶是心。心不含善及诸心数。若善是心。心不含恶及诸心数。不知何以目心。以略代总。故知略心能含万法。况不含五义耶。华严云。一微尘中有三千大千世界经卷。即其义也。心是法本者。释论云。一切世间中无不从心造。无心无思觉。无思觉无言语。当知。心即语本。心是行本者。大集云。心行大行遍行。心是思数。思数属行阴。诸行由思心而立。故心为行本。心是理本者。若无心理与谁含。以初心研理恍恍将悟。稍入相似则证真实。是为理本。心含微发者。初刹那心微微而有。次心若存若亡。次渐增长后则决定。畅心而发口。是语微发。初心习行行犹微弱。次少树立。后成大行即行微发。初观心不见心理。更修仿佛。乃至相似真实即理微发。心含涌泉者。心具诸法障故不流。如土石压泉。去壅涌溜。若不观心心闇不明。所说不长。若观心明彻则宣辩无方。流溢难尽。岂非语涌泉。若不观心行则有间。以观心故念念相续。翻六蔽成六度。六度摄一切行。是行涌泉。若能观心如利钁斲地。磐石沙卤理水清澄滔滔无竭即义涌泉。心含结鬘者。观念不谬得一闻持。穿文无失。观心得定共力。穿行无失。观心得道共力。穿义无失。又观心得定慧严显法身。此皆可解。又心是绳墨若观心得正语离邪倒说。观心正则勉邪行。心无见着则入正理。事行如绳理行如墨。弹爱见木成正法器也。是为心经多含。略示十五义(云云)。二类有翻明观者。心即是由。三义由心。一切语言由觉观心。一切诸行由于思心。一切义理由于慧心。经云。诸佛解脱。当于众生心行中求。心是经纬以觉为经。以观为纬织成言语。又慧行心为经。行行心为纬。织成众行。心竖缘理为经。心横缘理为纬织成义理(云云)。又观境为经观智为纬。观察回转织成一切文章。又心即是契观慧契境是契缘。契乐欲心为契教。契便宜对治心为契行。契第一义心契理心为法本。心为线者如前(云云)。心为善语教者。法之与语俱通善恶。今以善法善语定之。心之与观亦通善恶。今以善心善观定之。即是善语教。善行善理故。心具三义。心是可轨者。若无观则无规矩。以观正心王心王正故。心数亦正。行理亦尔。心王契理数亦契理。故名可轨也。心常者。心性常定犹如虚空。谁能破者。又恶觉不能坏善觉。邪行不干正行。邪理不坏正理。故心名常。随诸事释。一一向心为观。观慧弥成于事无乖。如火益薪事理无失。即文字无文字。不舍文字而别作观也。三类和融有无明观者。可解(云云)。四类历法为观者。若小乘明恶中无善。善中无恶。事理亦然。此则恶心非经。则无多含之义。隘路不受二人并行。若大乘观心者。观恶心非恶心。亦即恶而善。亦即非恶非善。观善心非善心。亦即善而恶。亦非善非恶。观一心即三心。以此三心历一切心。历一切法。何心何法而不一三。一切法趣此心。一切心趣此法。如此观心为一切语本行本理本。有翻五义无翻五义。一一于心解释无滞。遍一切心无不是经。大意可领。不俟多记也

△第二显体者。前释名总说文义浩漫。今顿点要理正显经体。直辨真性。真性非无二轨。欲令易解是故直说。后显宗用。非无初轨偏举当名耳。体者。一部之指归。众义之都会也。非但会之至难。亦乃说之不易文云。是法不可示言辞相寂灭。大经云。不生不生不可说。又云。有因缘故亦可得说。今略开七条。一正显经体。二广简伪。三一法异名。四入体之门。五遍为众经体。六遍为诸行体。七遍一切法体。正显体。更明四意。一出旧解。二论体意。三正明体。四引文证。北地师用一乘为体。此语奢漫未为简要。一乘语通滥于权实。若权一乘都非经意。若实一乘义该三轨。显体不明故不用。又有解言。真谛为体。此亦通滥。小大皆明真谛。小乘真谛故不俟言。大乘真谛亦复多种。今以何等真谛为体故不用。又有解言。一乘因果为体。今亦不用。何者一乘语通已如前说。又因果二法犹未免事。云何是体。事无理印则同魔经。云何可用。有人解乘体通因果。果以万德为体因以万善为体。引十二门论云。诸佛大人所乘。文殊观音等所乘。又引此经。佛自住大乘即果也。诸子乘是宝乘。是因乘也。又引普贤观大乘因果皆是实相。私问因果之乘为变为不变。若变谁是能通。谁是所通。若不变因果。则并皆无此理。若别有法通因果。当知。因果非果者经体也。十二门论云。大人佛不行故名乘。岂应以不行证因果乘也。法华佛自住大乘者。此乃乘理以御人。非住果德也。普贤观明因果。皆指实相。云可将实相证于因果耶。今皆不用。有人明因乘。以般若为本。五度为末果。乘以萨婆若为本。余为末。又因乘狭果乘广。又般若相应心是一体乘。不相应心是异体乘。又无所得相应行是近乘。低头举手有所得是远乘。又六度有世出世杂是远乘。三十七品但出世名近乘。又四句度与品悉无得。又度与品俱有得。又度杂品不杂。又品杂度不杂(云云)。私谓。般若为乘本者。于今经是白牛非经体也。萨婆若为乘本者。于今经是道场所成果。亦非乘体。因乘狭者是纵义。果乘广者是横义。悉非今经乘体。般若相应心无所得近远等。于今经悉是庄校傧从。都非乘体。那忽于皮毛枝叶而兴诤论耶。喧怒如此谁能别之。有人引释论。以六度为乘体。方便运出生死。慈悲运取众生。于今经般若是牛。五度是庄挍。方便是傧从。慈悲是轩亦非乘体。中边分别论云。乘有五。一乘本谓真如佛性。三乘行谓福慧。三乘摄谓慈悲。四乘障谓烦恼。是烦恼障行解等是智障。五乘果谓佛果也。唯识论云。乘是出载义。由真如佛性出福慧等行。由此行出佛果。由佛果载出众生。摄大乘论乘有三。一乘因谓真如佛性。二乘缘谓万行。三乘果谓佛果也。法华论明乘体。谓如来平等法身。又云。如来大般涅槃。此两文似如隐显耳。发心低头举手等名乘缘。十二门论明乘本。谓诸法实相乘主。谓般若乘助。谓一切行资成乘至。至萨婆若。此五论明乘体同而庄挍小异。于今经明乘体。正是实相不取庄挍也。若取庄挍者。则非佛所乘乘也。二论体意者。何意须用此体。释论云。诸小乘经。若有无常无我涅槃三印印之。即是佛说。修之得道。无三法印即是魔说。大乘经但有一法印。谓诸法实相名了义经能得大道。若无实相印是魔所说。故身子云。世尊说实道。波旬无此事。何故小三大一。小乘明生死与涅槃异。生死以无常为初印。无我为后印。二印印说生死。涅槃但用一寂灭印。是故须三。大乘生死即涅槃。涅槃即生死。不二不异。净名曰。一切众生常寂灭相。即大涅槃。又云。本自不生今则无灭。本不生者。则非无常无我相。今则无灭者。则非小寂灭相。唯是一实相。实相故言常寂灭相即大涅槃。但用一印也。此大小印印半满经。外道不能杂。天魔不能破。如世文符得印可信。当知。诸经毕定须得实相之印。乃得名为了义大乘也。三正显体者。即一实相印也。三轨之中取真性轨。十法界中取佛法界。佛界十如是中取如是体。四种十二因缘中取不思议不生不灭。十二支中取苦道即是法身。四种四谛中取无作四谛。于无作中唯取灭谛。七种二谛中取五种二谛。五二谛中唯取真谛。五三谛中取五中道第一义谛。诸一谛中取中道一实谛。诸无谛中取中道无谛也。若得此意。就智妙中简乃至十妙。一一简出正体。例可知也。若譬喻明义。如梁柱纲纪一屋。非梁非柱即屋内之空。柱梁譬以因果。非梁非柱譬以实相。实相为体非梁柱也。屋若无空无所容受。因果无实相无所成立。释论云。若以无此空一切无所作。又譬如日月纲天。公臣辅主日月可二。太虚空天不可二也。臣将可多主不可多也。为此义故。须简出正体。如三轨成乘。不纵不横不即不离。显示义便。须简观照等。唯指真性当名。正意分明三轨既然。余法例尔(云云)。四引证者。序品云。今佛放光明助显实相义。又云。诸法实相义已为汝等说。方便品云。唯佛与佛乃能究尽诸法实相。偈中云。诸佛法久后要当说真实。又云。我以相严身为说实相印。身子领解云。世尊说实道波旬无此事。又云。安住实智中我定当作佛。法师品云。开方便门示真实相。安乐行云。观诸法如实相。寿量云。如来如实知见。普贤观云。昔于灵山广说一实之道。又云。观于一实境界故。知诸佛为大事因缘。出现于世。秖令众生开佛知见。见此一实。非因非果之理耳。经文在兹可为明证也

○二广简伪者。夫正体玄绝一往难知。又邪小之名乱于正大。譬如鱼目混杂明珠。故须简伪。即为六意。一就凡简。二就外简。三就小简。四就偏简。五就譬简。六就悟简。一就凡简者。释论云。世典亦称实者。乃是护国治家称实也。外道亦称实者。邪智僻解谓为实也。小乘称实者。厌苦苏息。以偏真为实也。如是等但有实名。而无其义。何者世间妖幻道术亦称为实。多是鬼神魅法。此法入心迷醉狂乱。自炫善好谓胜真实。立异动众示奇特相。或髑髅盛屎。约多人前张口大咽。或生鱼臭肉增状餔食。或裸形弊服夸傲规矩。或直来直去不问不答。种种谲诡詃诱无智。令信染惑着。着已求脱叵得。内则病害其身。外则诛家灭族。祸延亲里现受众苦。后受地狱长夜之苦。生生障道无解脱期。此乃世间现见何实可论。钝使爱论摄。若周孔经籍。治法礼法兵法医法。天文地理八卦五行。世间坟典孝以治家忠以治国。各亲其亲各子其子。敬上爱下仁义揖让。安于百姓霸立社稷。若失此法强者陵弱。天下焦遑民无聊生。鸟不暇栖兽不暇伏。若依此法。天下太平牛马内向。当知。此法乃是爱民治国。而称为实。金光明云。释提桓因种种胜论。即其义也。盖十善意耳。修十善上符天心。诸天欢喜求天然报。此法为胜。故言胜论耳。又大梵天王说出欲论。即是修定出欲淤泥。亦是爱论摄耳。世又方术服药长生。练形易色飞仙隐形者。称此药方秘要真实。此亦爱论钝使摄耳。二就外简者。即是外道典籍也。若服药求知聪利明达。推寻道理。称此药方为胜为实者。药力薄知不能鉴远。触药则失药歇则失。亦非实也。若此间庄老无为无欲。天真虚静息诸夸企。弃圣绝智等。直是虚无其抱。尚不出单四见外。何关圣法。纵令出单四见外。尚堕复四见中。见网中行非解脱道。若外国论力。受梨昌募。撰五百明难。其一云。瞿昙为一究竟道。为众多究竟道。佛言。但一究竟道。论力云。云何诸师各各说究竟道。佛指鹿头。汝识其不。论力言识。究竟道中其为第一。佛言。若其得究竟道。云何自舍其道。为我弟子耶。论力即悟叹佛法中独一究竟道。又如长爪云。一切论可破。一切语可转。观诸法实相。于久不得一法入心。释论云。长爪执亦有亦无见。又云。亦计不可说见。如斯流类。百千万种虚妄戏论。为惑流转。见网浩然邪智澜漫。触境生着。或时襵揲有无为有。无有无无为无。有非有非无为有。无非有非无为无。百千番牒悉皆见倒。生死诸边非真实也。大经云。被无明枷系生死柱。绕二十五有不能得脱。即此义也。三就小简者。声闻法中亦云离有离无名圣中道。大集云。拘邻如沙门。最初获得真实之知见。然小乘不运大悲不济众生。功德力薄不求作佛。不深穷实相。则智慧劣弱。虽云离有离无名圣中道。乃以断常二见为二边。真谛为中道。真无漏慧名为见。证涅槃法名为知。虽断见思除灭分段。而住草庵。非究竟理。对前生死有边。即是涅槃无边。二俱可破可坏。非真实道。故不名实相也。四就偏简者。诸大乘经。共二乘人带方便说者。名字既同义须分别。如摩诃衍中云。三乘之人。同以无言说道断烦恼。中论云。诸法实相三人共得者。二乘之人虽共禀无言说道。自求出苦无大悲心。得空则止。钝根菩萨亦尔。利根菩萨大悲为物。深求实相。共实相者智如萤火。是故非实。不共实相智如日光。是故为实。大经云。第一义空名为智慧。二乘但空空无智慧。菩萨得不但空即中道慧。此慧寂而常照。二乘但得其寂。不得寂照故非实相。菩萨得寂又得寂照。即是实相。见不空者复有多种。一见不空次第断结。从浅至深。此乃相似之实非正实也。二见不空具一切法。初阿字门则解一切义。即中即假即空不一不异。无三无一二乘但一即。别教但二即。圆具三即。三即真实相也。释论云。何等是实相。谓菩萨入于一相。知无量相。知无量相。又入一相。二乘但入一相。不能知无量相。别教虽入一相。又入无量相。不能更入一相。利根菩萨即空故入一相。即假故知无量相。即中故更入一相。如此菩萨深求智度大海。一心即三。是真实相体也。华严不共二乘。但约菩萨三智次第。得亦非正实。不次第得者是正实也。若方等中四人得三智。三人为虚一人为实。大品三慧说三智属三人。前二不深求浅而非实。后一人深求一心三智。是故是实。此经汝实我子无复四三之人。十方谛求更无余乘。但一实相智。决了声闻法。但说无上道纯是一实体也

妙法莲华经玄义卷第八上妙法莲华经玄义卷第八下

        天台智者大师说

大经云。一实谛者则无有二。无有二故名一实谛。又一实谛名无虚伪。又一实谛无有颠倒。又一实谛非魔所说。又一实谛名常乐我净。常乐我净无空假中之异。异则为二。二故非一实谛。一实谛即空即假即中无异无二。故名一实谛。若有三异则为虚伪。虚伪之法不名一实谛。无三异故即一实谛。若异即是颠倒未破。非一实谛。无三异故无颠倒。无颠倒故名一实谛。异者不名一乘。三法不异具足圆满。名为一乘。是乘高广众宝庄挍。故名一实谛。魔虽不证别异空假。而能说别异空假。若空假中不异者。魔不能说。魔不能说名一实谛。若空假中异者名颠倒。不异者名不颠倒。不颠倒故无烦恼。无烦恼故名为净。无烦恼则无业。无业故名为我。无业故无报。无报故名乐。无报则无生死。无生死则名常。常乐我净名一实谛。一实谛者即是实相。实相者即经之正体也。如是实相即空假中。即空故破一切凡夫爱论。破一切外道见论。即假故破三藏四门小实。破三人共见小实。即中故破次第偏实。无复诸颠倒小偏等。因果四谛之法。亦无小偏等三宝之名。唯有实相因果。四谛三宝宛然具足。亦具诸方便因果四谛三宝。何以故。实相是法界海故。唯此三谛即是真实相也。又开次第之实。即是圆实证道是同故。又开三人共得实。深求即到底故。又开三藏之实。决了声闻法。又开诸见论实。于见不动而修道品故。又开诸爱论实。魔界即佛界故。行于非道通达佛道。一切诸法中悉有安乐性。即绝待明实是经体也。正譬简者。今借三喻正显伪真。兼明开合破会等意。一譬三兽渡河。同入于水。三兽有强弱河水有底岸。兔马力弱。虽济彼岸浮浅不深。又不到底。大象力强俱得底岸。三兽喻三人水喻即空。底喻不空。二乘智少不能深求。喻如兔马。菩萨智深喻如大象。水软喻空。同见于空不见不空。底喻实相菩萨独到。智者见空及与不空。到又二种。小象但到底泥。大象深到实土。别智虽见不空。历别非实。圆见不空穷显真实。如是喻者。非但简破兔马二乘非实。亦简小象不空非实。乃取大象不空。为此经体也。此约空中共为真谛。作如此简也。二譬颇梨如意两珠。相似形类欲同。而颇梨但空。不能雨宝。如意珠亦空亦雨宝。颇梨无宝以喻偏空。如意能雨以喻中道。此就有无合为俗简伪显真。今经体同如意也。又但约一如意珠为譬者得珠。不知力用。唯珠而已。智者得之多有所获。二乘得空证空休息。菩萨得空。方便利益普度一切。此就含中真谛。简其得失也。今经如智者得如意珠。以为经体。三譬如黄石中金。愚夫无识视之谓石。掷在粪秽都不顾录。估客得之融出其金。保重而已。金匠得之。造作种种钗钏镮铛。仙客得之练为金丹。飞天入地扪摸日月。变通自在。野人喻一切凡夫。虽具实相不知修习。估客喻二乘。但断烦恼矿保即空金。更无所为。金匠喻别教菩萨。善巧方便知空非空。出假化物庄严佛土。成就众生。仙客喻圆教菩萨。即事而真。初发心时便成正觉。得一身无量身。普应一切。今经但取金丹实相。以为经体也。就同而为喻。从初至后同是于金。凡夫圆教俱是实相也。就异为喻者。初石异金。次金异器。器异丹。丹色净彻类若清油。柔软妙好岂同环钏。状乖色别故不一种。此就与夺破会简其得失。引此三喻者。前喻根性。根性有浅深。浅得其空深得其假。又得其中。次喻三情。初情但出苦。不志求佛道。见真即息。次情历别不能圆修。后者广大遍法界求。第三喻三方便。二乘方便少守金而住。别教方便弱。止能严饰营生。圆教方便深。故能吞云纳汉。今明此经实相之体。如大象得底。坚不可坏以譬体妙。圆珠普雨譬其用妙。巧智成仙譬其宗妙。如此三譬即是三德。不纵不横名为大乘。于大乘中别指真性。以为经体。六就悟简者。夫法相真正诚如上说。行未会理岂得名谛。徒劳四说逐悟生迷。闻粖谓软闻雪谓冷。闻贝谓硬闻鹄谓动。终不能见乳之真色。情闇夜游何能到谛。叫唤求食无有饱理。执己为实余是妄语。此有彼无是非互起。更益流动云何名谛。若欲见谛惭愧有羞。苦到忏悔。机感诸佛禅慧开发。观心明净信解虚融。尔时犹名闇中见杌。仿佛不明。人木虫尘尚不了了。若能安忍法爱不生。无明豁破如明镜不动净水无波。鱼石色像任运自明。清净心常一如是尊妙人。则能见般若。金錍抉眼。一指二指三指分明。尔时见色言有亦是。言无亦是。云何有是的的之色。与眼相应。谛谛之理与智相称。名之为有。云何为无。无复坚冷软动之相。名之为无。论云。一切实一切非实。亦实亦不实。非实非不实。如是皆名诸法之实相。如舍利弗安住实智中。我定当作佛。为天人所敬。尔时乃可谓永尽灭无余。是名真实见体。故涅槃云。八千声闻。于法华中见如来性。如秋收冬藏更无所作。约理明无所作。此是究竟之理也。约教无所作。闻此教已更不他闻也。约行无所作者。修此行已更不改辙。如是等种种无所作义(云云)。略而言之。随智妙悟得见经体也。当以随智妙悟意。历诸谛境中。节节有随情智情智种种分别。简余情想。唯取随智明见经体也

○三一法异名者更为四。一出异名。二解释。三譬显。四约四随。一出异名者。实相之体秖是一法。佛说种种名。亦名妙有真善。妙色实际毕竟空。如如涅槃虚空佛性。如来藏中实理心。非有非无中道第一义谛。微妙寂灭等。无量异名悉是实相之别号。实相亦是诸名之异号耳。惑者迷滞执名异解。经云。无智疑悔则为永失。小乘论师专于名相而起诤竞。非法毁人。世代仿敩为法怨仇。大乘学者亦复如是。学妙有者自称至极。闻毕竟空而生诽谤。不受其法不耐其人。学毕竟空者。自类朋聚。引正向己。推邪与他。皆不识天主千名。闻释提桓因而喜。闻舍脂夫而恚。恭敬帝释慢辱拘翼。将恐其福不补其失。实相亦尔。同是一法岂可谤一信一耶。二解释者。小乘名体由来易简。置而不论。今所分别。但约别圆八门。更为四句。一名义体同。二名义体异。三名义同而体异。四名义异而体同。初句者。妙有为名。真善妙色为义。实际为体次以毕竟空为名。如如为义涅槃为体。次以虚空佛性为名。如来藏为义。中实理心为体。次以非有非无中道为名。第一义谛为义。微妙寂灭为体。如是等名字。所以理趣虽殊而同用一门。意无有别。故言名义体同也。第二句名义体异者。如妙有是名。毕竟空是义。如来藏为体。又空是名。如来藏为义。中道是体。又如来藏为名。中道为义。妙有为体。又中道是名。妙有为义空为体。如是等四门更互不同。三种皆别。故言名义体异也。第三句名义同而体异者。如妙有为名。妙色为义。毕竟空为体。是则二同一别。故言名义同而体异。又空为名。如如为义妙有为体。此亦二同一别。余两门亦如是。故言名义同而体异也。第四句名义异而体同者。如妙有等名名不同。真善色等义义有异。而同归一体更无二趣。故言名义异而体同。三门亦如是。前三句名义皆不融。初句寻一名得一义得一体。当门圆融不关余事。第二句寻异名识异义异体。体义名最不融。此易可知。第三句体既不融。名义虽同终成不合。皆是别门明义。不得意者诤从此起。或小陵大或大夺小。何者。小乘欲断生死。闻毕竟不但空。顺其情欲。谓是但空。执此起诤。又小乘欲断生死故非有。破执涅槃病故非无闻中道非有非无。扶其小情谓是已典非有非无。故于二门多起诤竞。若闻中实理心与小相乖。则不起诤。何者。二乘玩空。而今闻有二乘灰身灭智。今闻心智与彼情乖。故不执作诤也。是以小陵盗大故诤。大夺小者。大乘学者。见共三乘人空门非空非有门。名同二乘不见深意。即推属诳相不真宗。但取妙有亦空亦有两门。引是圆常之法。输二不输二。此诤少可。若知空是不但。非有非无是遮二边者。则四门俱夺。而小苦诤于二门。又大乘四门名义不融。门门各诤自相吞噬况尔。小乘。野干陵夺师子。宁当不啖尔乎。三句生诤非今经体也。第四句名义异而体同。体有众义功用甚多。四门随缘种种异称。以体融故圆应众名。法体既同。异名异义而不诤也。其相云何。今当略说。无量义云。无量义者从一法生。其一法者。所谓实相。实相之相无相不相。不相无相名为实相。此从不可破坏真实得名。又此实相诸佛得法。故称妙有。妙有虽不可见诸佛能见。故称真善妙色。实相非二边之有。故名毕竟空。空理湛然非一非异。故名如如实相寂灭。故名涅槃。觉了不改故名虚空。佛性多所含受。故名如来藏。寂照灵知故名中实理心。不依于有亦不附无。故名中道。最上无过故名第一义谛。如是等种种异名。俱名实相。种种所以。俱是实相功能。其体既圆名义无隔。盖是经之正体也。复次诸法既是实相之异名。而实相当体。又实相亦是诸法之异名。而诸法当体。妙有不可破坏故名实相。诸佛能见故名真善妙色。不杂余物名毕竟空。无二无别故名如如。觉了不变故名佛性。含备诸法故名如来藏。寂灭灵知故名中实理心。遮离诸边故名中道。无上无过名第一义谛。随以一法当体。随用立称。例此可知。大经云解脱之法多诸名字。百句解脱秖一解脱。大论云。若如法观佛般若与涅槃是三则一相。其实无有异。若得此意。知种种名皆名实相。亦名般若亦名解脱。三法亦是诸法名。诸法亦是三法体(云云)。三譬显者。譬如一人名金师。能锻金其体黄。譬初句法也。譬如一人名青。而能作漆其身白净。又一人名乌。能研朱其身则紫。如是等无量百千。名技身异。譬第二句。譬如百人同姓同名。同解一技而其身各异。譬第三句。譬如一人遭乱家祸。处处换姓处处变名。如张仪范蠡之类。涉多官职身备众位。若从多技得名书画金铁等师。若从文官儒林中散。若从武官熊渠次飞。随处换名譬名异。随技得称譬义异。而体是一更非异人。经言王家力士一人当千。此人未必力敌于千。直以种种技艺能胜千故。故称当千。工遍众技无技不通。仕具众位无官不历。是不可坏人。妙技术人。有体气人无过患人。遍通达人能破敌人。上族姓人富财技人。多知人中庶信直人。顶盖人。譬第四句法也。譬显冷然。故知前三句属别意。后一句属圆意也。四约四随者。问实相一法。何故名义纷然。答随彼根机。种种差别赴欲赴宜。赴治赴悟。例如世人学数则舍大。修衍则弃小。习空则恶有。善地则弹中。既不欲闻闻之不悦。无心信受不灭烦恼。不发道心。各于己典偏习成性。得作未来闻法根缘。如来于时以佛眼观其信等诸根。以若干言辞随应方便。而为说法。为有根性说妙有真善妙色。不违不逆。信戒忍进荡除空见即能悟入。契于实相。为空根性说毕竟空如如涅槃等。谛听谛受以善攻恶。无相最上。为亦空亦有根性。说虚空佛性如来藏中实理心。欣然起善离非心净。为非空非有根性者。即说非有非无中道。遮于二边。不来不去不断不常不一不异等。欲得听闻。欣如渴饮。信乐修习众善发生。执见皆祛无恶不尽。第一义理豁然明发。随此四根故四门异说。说异故名异。功别故义异。悟理不殊体终是一。故求那跋摩云。诸论各异端。修行理无二。偏执有是非。达者无违诤。故四随殊唱。是一实之异名耳

○第四明入实相门者。夫实相幽微其理渊奥。如登绝壑必假飞梯。欲契真源要因教行。故以教行为门。下文云。以佛教门出三界苦。佛子行道已来。世得作佛。门名能通。此之谓也。略为四意。一略示门相。二示入门观。三示粗妙。四示开显。示门相者。夫佛法不可宣示。赴缘说者。必以四句诠理。能通行人入真实地。大论云。于如是法说第一义悉檀。所谓一切实一切不实。一切亦实亦不实。一切非实非不实。如是皆名诸法之实相。实相尚非是一那得言四。当知。四是入实相门耳。又云。四门入清凉池。是门无碍。非唯利者得入。钝者亦入。非唯定者。散心专志精进者亦得入。又云。般若有四种相。所谓有相无相。乃至非有非无相。般若尚非一相云何四相。当知亦是入般若门也。又云。般若波罗蜜。譬如大火焰四边不可取。邪见火烧故。若不触火温身熟食。若触火者火则烧身。身既被烧温食无用。四门本通般若。除烦恼办大事。若取著者则成邪见。烧于法身。法身既烧四门通何等。若不触火门则能通也。若以佛教为门者。教略为四(云云)。若于一教以四句诠理。即是四门。四四合为十六门。若以行为门者。禀教修观因思得入。即以行为门。藉教发真则以教为门。若初闻教如快马见鞭影。即入正路者。不须修观。若初修观。如夜见电光即得见道者。不更须教。并是往昔善根习熟。今于教门得通名为信行。于观门得通名法行。若闻不即悟应须修观。于观悟者转成法行。若修观不悟更须听法。听法得悟转名信行。教即为观门。观即为教门。闻教而观观教而闻。教观相资则通入成门。教观合论则有三十二门此语其大数耳。细寻于门实有无量。五百身因三十二不二门。善财游法界值无量知识。说无量教门无量观行。如喜见城千二百门。实相法城岂唯一辙。经云。说种种法门宣示于佛道。今且约四教。明十六门相。三藏四门者。初明有门。谓生死法本非世性微尘父母所作。乃是无明正因缘法。出生诸行。烦恼业苦三道。悉皆是有。一切有为无常苦空无我。能发得暖顶世第一法。发真无漏因用真修道。此则道谛亦是有。子果既断。得有余无余涅槃。故大集云。甚深之理不可说。第一实义无声字。陈如比丘。于诸法获得真实之知见。此则因灭会真真亦是有。此是诸阿毗昙论之所申。见有得道即有门也。二空门者。即是彼教析正因缘。无明老死苦集二谛。三假浮虚破假实。悉入空平等发真无漏。因空见真空。即第一义之门也。故须菩提。在石室观生灭无常。入空因空得道见佛法身。恐此是成实论之所申也。三明有空门者。即是彼教明正因缘生灭。亦有亦空。若禀此教。能破偏执有无之见。见因缘有空发真无漏。因有无见真有无。即是第一义之门也。此是迦旃延。因门入道故作昆勒论。还申此门也。四非有非无门者。即是彼教明正因缘生灭。非有非无之理。若禀此教。能破有无边邪执见。见因缘非有非无。发真无漏。因非有非无。见真非有非无。即第一义之门也。恶口车匿因此入道。未见论来。有人言。犊子阿毗昙申此意。彼论明我在第五不可说藏中。我非三世故非有我。非无为故非无我。此恐未可定用也。二明通教四门相者。此是摩诃衍门。通通通别不可偏取。今约通通论四门者。上三藏四门。皆灭色入空。如析实人头等六分。求人不得故名为空。通教四门。皆即色是空如观镜像。六分即空。不待析尽为空。大论云。佛告比丘。观空即叠。观叠即空。此是体门异析门也。三藏观生空得道。三藏观生空得道。已又更观法空生法。二境不融。今通门生空即法空。法空即生空。无二无别。大品云。色性如我性我性如色性。此二皆如幻化。有人言。三藏破计实性。约实法求我不得。但是观性空。大乘明相自性是空。不须捡已为空。此乃一往之言。大品云。常性空无不性空时。晓了诸法如幻化水月镜像岂止相空而已。秖约此幻化即判四门。论云。一切实一切不实。一切亦实亦不实。一切非实非不实。佛于此四句广说第一义悉檀。一切实为有门者。若业若果善恶等法。乃至涅槃皆幻化。譬镜中像。虽无实性而有幻化头等六分为有门也。诸法既如幻化。幻化本自无实。无实故空。乃至涅槃亦如幻化。如镜中像假有形色求不可得。是为空门。诸法既如幻故名为有。幻不可得故名为空。如镜中像见而不可见。不可见而见。是亦空亦有门。幻有尚不可得。况复幻空而当可得。即是两舍为门。是通教即空之四门也。若三乘共禀而根性不同。各于四句入第一义。故此四句皆名为门。故青目注论云。诸法实相有三种。今是三乘人同入此门。见第一义者。是即空之一种也。三明别教四门者。若用中论偈。亦名为假名也。而辨四门者。即如大论四句。亦是此四句意。所言别者。下异藏通有七义故别。上异圆教。又历别入中故言别。此意正出大经。但多散说。今约乳等喻。即显别四门也。文云。佛性如乳有酪。石中有金力士额珠。即是有门。若明石无金性乳无酪性。众生佛性犹如虚空。大般涅槃空。迦毗罗城空。即是空门。又云。佛性亦有亦无。云何为有。一切众生悉皆有故。云何为无。从善方便而得见故。又譬乳中亦有酪性。亦无酪性。即是亦有亦无门也。若明佛性即是中道双非两遣。又譬乳中非有酪性。非无酪性。即是非空非有门。别教菩萨。禀此四门之教。因见佛性住大涅槃。故此四句。即是别教之四门。一往用拟别门经文。或时为圆门。此义在下料简(云云)。圆教四门相者。此门明入佛性第一义。一往与别门名义是同。细寻意趣别有多途。分别同异在下委论(云云)。二示入门观即为二。先略示入门处。二略示入门观。略示入门处者。能通教门大为十六。所通之理但是偏圆两真。前八门同入偏真。后八门同入圆真。何故偏真理一门八耶。三藏四门纡回隘陋。名为拙度。通教四门是摩诃衍。宽直巧度。门有巧拙之殊。能通为八真理无二。所通唯一。譬如州城开四面门。四面偏门以譬三藏。四面直门以譬通教。偏直既殊能通为八。使君是一。所通不二也。别教四门偏而未融。圆四门圆而且融。偏圆既殊能通为八。圆真不二所通唯一。譬如帝城开四面门。四面偏门以譬别教。四面直门以譬圆教。偏直既殊能通为八。帝尊不二所通唯一(云云)。问小乘一种四门。摩诃衍何故三种四门。答小乘浅近一生断结。喻如小家。大乘深远通处则长。譬如大家须千门万户也。三四何足为多耶。问摩诃衍门。那得三人见真。答此门正意通大。傍通于小。譬如王国有通门别门。别门通朝士。通门通朝市。不可以民庶登践。谓为民门。摩诃衍通门亦如是。正通实相傍通真谛。故三乘灰断兼由此门。不可以兼通偏真。而名小乘门也。二略示入门观者。先明三藏有门观。彼有门中具于信法信行。闻说即悟。此心疾利得道。方法难可示人。且约法行观门。即为十意。一识所观境。二真正发心。三遵修定慧。四能破法遍。五善知通知塞。六善用道品。七善用对治。八善知次位。九善能安忍。十者法爱不生。阿毗昙中具此十意。其文间散。论师设欲行道。不知依何而修。如惑岐路莫识所从。今撮其要意。通冠始终。则识有门入道之观也。一明所观境者。即是识正无明因缘生一切法也。若谓世间苦乐之法。从毗纽天生。或言从世性生微尘生。皆邪因缘生。若言自然法尔无谁作者。此无因缘生。无因缘生。是破因不破果。邪因缘亦是破正因果。是等悉非正因缘境。所不应观。数存邻虚论破邻虚。此与邪无相滥。殆非正因缘境。何者。邻虚有无未免二见。犹是无明颠倒。倒故是集。集故感粗细等色。无明颠倒既其不实。所感苦果报。那得定计有无。故大论云。色若粗若细总而观之。无常无我。无我故无主。若粗若细若因若缘。若苦若集若依若正。皆无常无主。悉是无明颠倒所作。如阿毗昙门广说。是名识正因缘所观之境。不同外道邪无因缘也。二发心真正者。既识无明颠倒流转行识乃至老死如旋火轮。欲休息结业正求涅槃。发二乘心出离见爱。不要名利但破诸有。不增长苦集。唯志无余。其心清净不杂不伪。此心真正名正发心。不同外道天魔也。三遵修定慧者。行人既誓求出有依波罗提木叉住修道。但罪障纷驰心不得安。道何由克。为修四念处。学五停心破五种障。五停事观即是定。定生念处即慧。慧定均停故名安心。又定慧调适故名停心。若无定慧若单定慧。若不均调定慧。皆不名贤人。如世间贤人智德具足。智则靡所不闲。德则美行无缺。许由巢父乃可称贤。若多智寡德名狂人。多德寡智名痴人。狂痴皆非贤也。贤名贤能亦名贤善。善故有德能故有智。智德具足故称贤人。行者亦尔。修四念处慧学五停心定。定慧具足。云何数息具足定慧制诸觉散。从一至十知息及数。无常生灭念念不停。又若观不净。当深厌秽恶。能观所观无常生灭。速朽虚诳诳诸众生。厌观起恚须慈定相应。见他得乐。亦知此定及彼乐相无常生灭因缘。观时横观四生。悉是因缘生法。竖观三界亦是因缘生法。从缘生者悉是无常无我。诸障起者应须念佛亦如是。是名五停具修定慧。有定故不狂。有慧故不愚。依此安心为众行基址。发生暖顶入苦忍真明。邻圣为贤义在于此。不同外道不知钻摇浆犹难得。况复酪苏等也。四破法遍成见有得道。其安心定慧。若五停心后。修共念处时。带不净等遍破诸法。事理悉成。若五停心后。单修性念处时。一向理观以无常之慧。遍破诸见。破见之观。如中论下两品所明也。佛初转法轮不说余法。但明无常。遍破一切外道。若有若无。乃至非有非无。神及世间常无常等。六十二见。使得清净。今阿毗昙师受他破云。无常是小乘。常是大乘。常得破无常。无常不得破常。若得前意此不应然。未得道前执心所计。常无常亦常亦无常。非常非无常等。法尘对意根而生诸见。见从缘生。从缘生者悉是无常。云何外道有常乐我净。如是四倒悉用无常破之。故五百比丘语达兜言。但修无常可以得道。可以得通。如六群比丘为他说法。纯说无常。当知。见无深浅悉为无常。所破不同旧医纯用乳药也。五知通塞者。前虽遍破诸见之过。未见其德。过即是塞德即是通。若有见中八十八使。乃至非有非无。不可说见中八十八使。悉从缘生名之为塞。塞故须破。复识其通者。所谓有见中道灭。乃至非有非无不可说见中。道灭如是。道灭从因缘生名之为通。通何须破。若不识诸见。谓是事实余妄语。执见成业爱润感果。岂非塞耶。能于诸见。一一皆知无常颠倒。不生计着。不执则无业。无业则无果。如是达者则有道灭。岂不名通。不同外道如虫食木是虫不知是字非字也。六善修道品者。岂唯识此通塞而已。当修道品进诸法门。谓观此有见乃至不可说见。皆依于色污秽不净。即身念处。若受有受。乃至受不可说受。皆依三受。受即是苦名受念处。观于诸见所起想行。悉是无我。名法念处。观诸见之心。念念无常名心念处。观此四观名有为法中得正忆念。得是念故四倒则伏。是名念处。勤修四观名四正勤。定心中修名四如意。五善根生故名五根。五根增长遮诸恶法。故名五力。定慧调停名七觉分。安隐道中行名八正道。今非约位道品。但就通修论三十七耳。若一停心门。作三十七品。余停心亦如是。阿毗昙道谛中。应广分别(云云)。此三十七品是行道法。将至涅槃城有三门。所谓苦下二行为空解脱门。集道各四。苦下有二。是无作解脱门。灭下有四是无相解脱门。若涅槃门开即得入也。故佛于须跋陀罗经中。决定师子吼。唯我法中有八正道。外道法中尚无一道。何况八道耶。七善修对治者。若利人即入。若不入者当修助道。故论云。十二禅等悉是助开门法。正慧既弱遮障得起。修助道为援。论云。贪欲起教修不净背舍等。缘中不自在。当教胜处。缘中不广普当教一切处。若少福德当教无量心。若欲出色当教四空。如是等悉是助道。助开门法不同外道于根本禅起爱见慢也。八善识次位者。虽修如此正助等法。不得即言我是圣人。叨滥真似不识贤圣。今明识真似阶差。自知非圣。增上之慢则不得生。不同外道戒取见取计生死法以为涅槃也。九善修安忍。别相念处力弱。未甚通泰。转修总相念处。或总一总二乃至总四。是时应须安忍。使谛观成就。转入暖法似道烟生。大经云。暖虽有漏有为。还能破坏有漏有为。我弟子有外道则无。又若安忍即成顶法。顶法成名忍。到傍边如其不忍。则退还此边。故云顶法退为五逆。暖法退为阐提。是故此中。善须安忍内外诸障。不同外道。不能安忍细微遮法也。十法爱不生者。上来既得四善根生。若起法爱。虽不退为五逆阐提。而不得入见谛。是则三番缩观。进成上忍世第一法。发苦忍真明。十六刹那得成初果。或成超果。或重用观断五下五上。得成无学。若利人用观节节得入。若钝用观具来至十。阿毗昙中。虽复广解不出十意。五百阿罗汉作毗婆沙。正申有门得道。云何而言是调心方便。四门调适俱能得道。若生取着俱不得道。若但云见有得道见空不得道。云何异于外人。故大论云。若不得般若方便。则堕有无。今以十法为方便直入真门。永异外道也。是为有门入真之观也。余空门亦空亦有门。非空非有门。入真之观始终方便比于有门。各各不同。然俱会偏真断三界惑。更无异也。其三门准有例应十观。大同小异可以意得。今不能烦记(云云)。次明通教有门观者。例为十意。列名(云云)。体解诸法皆如幻化。三人发心。虽同亦有小异(云云)。中论师云。此中是大乘声闻。今言非也。经云。欲得声闻缘觉。当学般若。论云。声闻及缘觉解脱涅槃道。皆从般若得。经论不云是件人师谬耳。虽知定慧不可得。而安心二法。以幻化之慧遍破四见。六十二见及一切诸法。知幻化中苦集名为塞。知幻化中道灭名为通。以不可得心修三十七品。以无所治学诸对治。识干慧地乃至佛地。幻化之慧。不为外魔所动内障所退。诸法不生而般若生。亦不爱着即得入真。若智若断无生法忍。比前为巧准作可知。不复委记。余三门十意大同小异。可以意得。亦不烦记文也。次明别教有门观。即为十意(云云)。一观境者。超出凡夫四见四门外。亦非二乘四门法。亦非通教四门法。诸四门法为境。不名实相。非生死涅槃如来藏者。乃名为妙有有真实法。如此妙有。为一切法而作依持。从是妙有出生诸法。是为所观之境也。二明发心者。菩萨深观实相妙有。不为生死所迁。金藏草秽额珠斗没。贫穷孤露甚可愍伤。菩萨为此起大慈悲四弘誓愿。思益有三十二大悲。华严云。不为一人一国一界微尘人。乃为法界众生发菩提心。如是发心有大势力。如师子吼。既发心已安心进行。如前所说种种定慧。如是时中。宜应修如是定。如是时中。宜应修如是慧。定爱慧策安心修道。依止二法不余依止。是为安心法也。还以妙有之慧遍破生死一切诸见。六十二等功德黑闇。皆悉不受。遍破涅槃沈空取证。犹如大树不宿怨鸟。于一一法中明识通塞。如雪山中备有毒草亦有药王。菩萨须知。如此心起。即是六道苦集名为塞。如是心起。即是二乘道灭名为通。又如是心起。是二乘苦集名为塞。如是心起。是菩萨道灭名为通。如是心起。名为菩萨苦集。如是心起名佛道灭。于苦集中。能知非道通达佛道。能知佛道。起于壅塞了了无滞。是为识通塞。善修道品者。夫三十七品。是菩萨宝炬陀罗尼。破倒念处勤行定心。五善根生能排五恶。定慧调适安隐道中行。离十相故名空三昧。亦不见空相。名无相三昧。不作愿求名无作三昧。是行道法近涅槃门。若修诸法对治之门。所谓常无常恒非恒。安非安为无为。断不断涅槃非涅槃。增上非增上。常乐观察诸对治门。助开实相也。从初十信十住十行十回向十地等觉妙觉圣位深浅。悉知无谬。终不谓我叨极上位。内忍善恶两觉。违从二贼外忍八风。以忍力故不为倾动。设证相似之法法爱不起。不堕菩萨顶生名法爱。无是爱故即入菩萨位。破无明秽草。显出妙有金藏得见佛性。入于实相。是为有门修入实观也。余空门亦空亦有门非空非有门。入实之观例亦为十。诸门方便虽各不同。俱会圆真理无差二三门观法准有可知。不复委记(云云)

妙法莲华经玄义卷第八下妙法莲华经玄义卷第九上

        天台智者大师说

次明圆门入实观者。先简圆门。次明圆观。上三藏门。灭实色通真。不得意多诤。体门即幻色通真。示人无诤法。别门体灭生死色。次第灭法性色。通中不得意多诤。圆门即生死色是法性色。即法性色而通中。示人无诤法故。文云无上道。又云而行深妙道。即此义也。上两门不通中。不俟分别。别圆两种俱通中。论其同异略为十。一融不融。二即法不即法。三明佛智非佛智。四明次行不次行。五明断断惑不断断惑。六明实位不实位。七果纵果不纵。八圆诠不圆诠。九约难问。十约譬喻。寻此十意明识八门同异也。一明融不融者。别教四门。所据决定妙有善色。不关于空据毕竟空。不关于有。乃至非空非有门亦如是。四门历别当分各通。不得意者。作定相取似同性实。殆滥冥初生觉(云云)。前三藏有门。已破外道邪计先尽。次空等三门破邪则少。又通巧四门破三藏之拙。又别教之门破通门之近。已不与二乘共。何况外道冥觉。而滥妙有。妙有依如来藏分判四门。何得同彼尼犍性实。如周璞郑璞名同质异。贵贱天悬。今时学地论人反道还俗。窃以此义偷安庄老。金石相糅。遂令邪正混淆。盲暝之徒不别泾渭。若得诸四门意。精简真伪偷盗不生。然别门虽作定说。如是诤论。诸佛境界二乘不知。岂同外道耶。圆门虚融微妙不可定执。说有不隔无约有而论无。说无不隔有约无而论有。有无不二无决定相。假寄于有以为言端。而此有门亦即三门。一门无量门无量门一门。非一非四。四一一四此即圆门相也。复次更约破会。明融不融相。若破外道邪见不破二乘邪曲。亦不破大乘方便。又会不圆者。如净名中。会凡夫反复声闻无也。会尘劳之俦为如来种。无为入正位。不能反复。生死恶人烦恼恶法而皆被会。二乘善法四果圣人。而不被会。又般若中。明二乘所行念处道品。皆摩诃衍。贪欲无明见爱等。皆摩诃衍。善恶之法。悉皆被会。亦不会恶人及二乘人等。不辨其作佛。此即别门摄也。若圆破者。从别教已去皆是方便。故迦叶自破云。自此之前我等皆名邪见人也。既言邪见之人。即无圆正道法。则人法俱被破也。别教人法尚尔。何况草庵人法。二乘尚尔。何况凡夫人法。是则圆破无所固留。圆会者。会诸凡夫着法之众。汝等皆当作佛。我不敢轻于汝等。五逆调达亦与受记。龙畜等亦与受记。况二乘菩萨等。世间治生产业。皆与实相不相违背。即会一切恶法也。汝等所行是菩萨道。析法二乘尚被会。况通况别。汝是我子我则是父。无有人法而不被会。俱皆融妙。此即圆门摄也。复次更约经文前后。明圆不圆相。若先明不融门。此说地前。后明不融门而言证融。此说向后。或先明证融门。此说向后。后明不融门。此说地前者。此皆别门摄。若先明融门证亦融。此说信后后明证不融。此说住前。或先明证不融。此说住前后明证融。此说信后者。此皆属圆门摄(云云)。二即法不即法者。若说有为门。此有非生死有。出生死外。别论真善妙有。空门者出二乘真外。别论毕竟空。乃至非有非无门亦如是。是为别四门相。若有为门即生死之有。是实相之有。一切法趣有。有即法界。出法界外更无法可论。生死即涅槃涅槃即生死。无二无别。举有为门端耳。实具一切法圆通无碍。是名有门。三门亦如是。此即生死之法。是圆四门相也。复次即法有遍不遍。判圆别相例前分别(云云)。约五住遍不遍。复次即法不即法或前或后。判别圆相如前分别(云云)。三约佛智非佛智者。若有为门。分别一切智了达空法。分别道种智。照恒沙佛法差别不同者。是菩萨智即别四门相也。若有为门。分别一切种智。五眼具足圆照法界正遍知者。即诸佛之智是圆四门相也。复次别门说圆智。圆门说别智。或前或后。分别别圆相例如前(云云)。复次别门证圆智。圆门证别智。或前或后分别别圆。如前分别(云云)。四约次第不次第者。若以有为门依门修行。渐次阶差从微至着。不能一行中即无量行。乃至非空非有门亦如是。是别四门相。若以有为门一切法趣有门依门修行。亦一切行趣有行。一行无量行名为遍行。乃至非空非有门亦如是。是圆四门相。复次别门圆行圆门别行。或前或后分别别圆。例如前(云云)。五约断断不断断者。夫至理虚无。无明体性本自不有。何须智慧解惑。既无安用圆别。涅槃云。谁有智慧谁有烦恼。净名曰。淫怒痴性即是解脱。又不断痴爱起于明脱。此则不论断不断。大经云。闇时无明明时无闇。有智慧时则无烦恼。此用智慧断烦恼也。若别有门。多就定分割截。渐次断除五住。即是思议智断也。乃至三门亦如是。是为别四门相。若圆有门解惑不二。多明不断断。五住皆不思议。即是不思议断。乃至三门亦如是。是为圆四门相。复次圆门说断。别门说不断断。或前或后判别圆相者。例如前说(云云)。六约实位非实位者。若有门明断界内见思。判三十心位。断界外见思无明。判十地位。等觉后心断无明尽。妙觉常果累外无事。此乃他家之因将为己家之果。皆方便非实位也。后三门大同小异。皆是别四门相。若有门从初发意。三观一心断界内惑。圆伏界外无明。判十信位进发真智。圆断界外见思无明判四十心位等觉后心。无明永尽妙觉累外。此是究竟真实之位。乃至三门亦如是。是名圆四门相。复次别门说实位。圆门说不实位。别门证实位。圆门证不实位。或前或后皆如前分别(云云)。七约果纵果不纵者。若有为门。从门证果三德纵横。言法身本有。般若修成解脱始满。不但果德纵成因亦局限。如地人云。初地具足檀波罗蜜。于余非为不修。随力随分檀满初地不通上地。余法分有而不具足者。是义有余三门亦如是。是为别四门相。若有为门。从门证果。三德具足不纵不横。亦因如是一法门。具足一切法门。通至佛地。华严云。从初一地具足诸地功德。大品云。初阿字具足四十一字功德。三门亦如是。是为圆四门相。复次别门说果不纵。圆门说果纵。或前或后判圆别相。例前(云云)。八约圆诠不圆诠者。若有为门门不圆融。或融一或融二门。前章偏弄引。门中章诠述不融不即菩萨智。乃至偏譬喻等。门后还结不融不即等三门亦如是。是为别四门相。若有为门一门即三门。门前圆弄引。门中诠述融即佛智。乃至圆譬喻等。门后结成融即等。三门亦如是。是为圆四门相。复次别门诠圆圆门诠别。或前或后。分别别圆之相。例前(云云)。九约问答者。若有门明义未辨圆别须寻问答核征。自见圆别指趣。三门亦如是(云云)。十约譬喻者。诸门前后。或举金银宝物为譬或举如意日月为譬。或用别合或用圆合。圆别之相自显(云云)。今以十意玄览众经。圆别两门朗然明矣。复约五味分别少多。乳教两种四门。酪教一种四门。生苏四种四门。熟苏三种四门。此经一种四门(云云)。今经十义者。观一切法空如实相。决了声闻法是诸经之王。开方便门。此是融凡小大之人法也。一切世间治生产业。皆与实相不相违背。即客作者是长者子。此是即法之义也开示悟入佛之知见。今所应作唯佛智慧。即佛慧也。着如来衣座室等。即不次第行也。不断五欲而净诸根。又过五百由旬。即不断断义也。五品六根净乘宝乘游四方。即实位也。佛自住大乘定慧力庄严。以此度众生。即果不纵也。合掌以敬心欲闻具足道。即今佛文前圆诠也。诸法实相义已为汝等说。即古佛文后圆诠也。智积龙女问答显圆也。轮王顶珠其车高广。皆圆喻也。十意既足圆门明矣。融门四相今当说。若言佛之智慧微妙第一。又云。我以如来智慧观彼久远。犹若今也智知妙法有门也。一切法空常寂灭相。终归于空空门也。诸法常无性佛种从缘起。即亦空亦有门也。非如非异非虚非实。双非两舍即非空非有门也。四相标门十意简别。故知此经明圆四门也(云云)。二明入实观者。上已知四圆门。今依有门修观。观则为十(云云)。对前十二思议之门。名不思议境。不思议境即是一实四谛。谓生死苦谛不可思议。即空即假即中。即空故方便净。即假故圆净。即中故性净。三净一心中得名大涅槃。净名曰。一切众生即大涅槃。故名不可思议四谛也。不可复灭。此即生死之苦谛。是无作之灭。亦是集道也。烦恼集谛不可思议。即空即假即中。即空故名一切智。即假故名道种智。即中故一切种智。三智一心中得名大般若。净名曰。一切众生即菩提相。不可复得。此即烦恼之集而是无作道谛。亦是苦灭。故名不思议一实四谛也。亦是真善妙色。何者。生死即空故名真。生死即假故名善。生死即中故名妙。此名有门不可思议境也。二发真正心者。一切众生即大涅槃。云何颠倒以乐为苦。即起大悲兴两誓愿。令未度者度。令未断者断。一切烦恼即是菩提。云何愚闇以道为非道。即起大慈兴两誓愿。令未知者知未得者得。无缘慈悲清净誓愿。慈善根力。任运吸取一切众生也。三安心者。既体解成就发心具足。岂可临池观鱼。不肯结网。裹粮束脚安坐不行。修行之要不出定慧。譬如阴阳调适万物秀实。雨旱不节焦烂岂生。若两轮均平是乘能运。二翼具足堪任飞升。体生死即涅槃名为定。达烦恼即菩提名为慧。于一心中巧修定慧。具足一切行也。四破法遍者。以此妙慧。如金刚斧所拟皆碎。如无翳日所临皆朗。若生死即涅槃者。分段变易若谛皆破。若烦恼即菩提者。四住五住集谛皆破。虽复能破亦不有所破。何者。生死即涅槃故无所破也。五识通塞者。如主兵宝取舍得宜。强者绥之弱者抚之。知生死过患名为塞。即涅槃名为通。烦恼恼乱名为塞。即是菩提名为通。始从外道四见乃至圆教。四门皆识通塞。节节执着即是塞。节节亡妙名为通。若不识诸法夷崄。非但行法不前。亦亡去重宝也。六善识道品者。观生死即涅槃。十界生死色阴。皆非净非不净。乃至识阴非常非不常。能破八颠倒。即法性四念处。念处中具道品三解脱及一切法。又知涅槃即生死。显四枯树。知生死即涅槃。显四荣树。知生死涅槃不二。即一实谛。非枯非荣住大涅槃也。七善修对治者。若正道多障应须助道。观生死即涅槃。治报障也。观烦恼即菩提。治业障烦恼障也。八善知次位者。生死之法本即涅槃。理涅槃也。解知生死即涅槃。名字涅槃也。勤观生死即涅槃。观行涅槃也。善根功德生。即相似涅槃也。真实慧起。即分真涅槃也。尽生死底。即究竟涅槃也。观烦恼即菩提亦如是。九善安忍者。能安内外强软遮障。不坏观心。若观生死即涅槃。不为阴入境病患业魔禅二乘菩萨等境所动坏也。若观烦恼即菩提。不为诸见增上慢境。所动坏也。十无法爱者。既过障难道根成立诸功德生。观生死即涅槃。故诸禅三昧功德生。观烦恼即菩提故。诸陀罗尼无畏不共诸般若生。观生死涅槃不二。故法身实相生。相似功德顺理而生。喜起顺道法爱生名爱法。不上不退名为顶堕。此爱若起即当疾灭。爱若灭已破无明。开佛知见证实相体。观生死即涅槃。故证得解脱。烦恼即菩提故证得般若。此二不二证得法身。一身无量身。无上宝聚如意圆珠。众法具足。是名有门入实证得经体。余三门亦如是。是十种观经文具足。是法不可示言辞相寂灭。诸余众生类无有能得解。又我法妙难思。即不思议境。于一切众生中起大慈心。于非菩萨中起大悲心。我得三菩提时。以神通力智慧力引之。令得住是法中。即正发心也。佛自住大乘。如其所得法定慧力庄严。即是安于二法。自成成他也。破有法王即是破法遍也。又如日月光明能除诸幽瞑。斯人行世间。能破众生闇。即破法遍也。有一导师将导众人明了心决定在崄济众难善知通塞也。净藏净眼。善修三十七品诸波罗蜜。即是两意也。增道损生游于四方。即是识次位也。安住不动如须弥顶。着如来衣。即安忍也。虽闻是诸声听之而不着。其意等六根。皆言清净若此。又云。真净大法即无法爱也。是十种观散在经文。而人不知。今撮聚十数入有门为观。乃至三门小异大同。十观入实亦复如是。复次此十观意非但独出今经。大小乘经论备有其意。如摩黎山纯出栴檀。固非外道四韦陀典。及此间庄老之所载也。世人咸共讲读。而对文不知。若欲学道全无方便悲夫。徒知[穀-禾+牛]捋不解钻摇。若识十意。于小乘四门俱用入真。于大乘四门俱用入实。既入实已如食乳糜。更无所须。半如意珠全如意珠。布施一切。虽有此施不见有人轻生重道。勤心修习不受不用。徒施何益。我则悔焉。虽无所益作毒鼓因。欲具知之委如止观(云云)。三明诸门粗妙者为二。一就能所判粗妙。二约诸门判粗妙。能所为四句。门名能通理是所通。自有能通粗所通亦粗。能通妙所通粗。能通粗所通妙。能通妙所通亦妙。三藏四门扶事浅近。故能通为粗。但诠偏真所通亦粗通教四门。大乘体法如实巧度能通为妙三乘偏证所通为粗。别教四门。教道方便能通为粗。诠入圆真所通为妙圆教四门。证道实说能通为妙。即事而圆所通亦妙也。又自有带粗能所。生苏教是也。不带粗能所乳教是也。自有带粗所不带粗能。熟苏教是也。自有带粗能不带粗所。圆接通接别是也。涅槃中诸门亦是也。问经云。唯有一门而复狭小。为粗故称一小。为妙故称一小。答此义当通用。不可局在一门。何者如三藏四门赴机异说故言四。同是佛教故言一门门方便异故言四。同向涅槃故言一。所通从能通故言四。能通会所通故言一。文字中无菩提是约教论狭小。譬如隘路不受二人并行。即约行论狭小。教行两门取真难契。即约理论狭小(云云)。通教亦如是。逗缘别说故为四。同是佛教故言一。观法不同故有四。俱向无生故为一。所随于能故为四。能随于所故为一。通教即事而真。文字中有菩提。善恶俱观皆不可得。即是并行。不约此义论狭小但教观取真理难当。故名理为狭小(云云)。别教四门亦如是。为四机说故有四。同是佛教故言一。入实观异故言四。俱向一实故言一。所随于能故言四。能会于所故言一。不即生死是涅槃教狭小。不即烦恼是菩提故行狭小。教行取理难当名理论狭小。圆教四门亦如是。逗四种机故言四。皆是佛说故言一。入实观异故言四。四观向实故言一。将门名理故言四。以理应门故言一。此教即生死是涅槃。教不狭小。烦恼即菩提行不狭小。而此教观取理难当。名理为狭小。若依经文唯有一门。而复狭小者。正语教行之门。取理不当故言狭小也。今拓开一句处处不同。岂可定执守一文耶。若得此意粗妙自明(云云)。二约诸门判粗妙者。先明三藏四门皆是能通执着四门俱皆壅碍。成坏粗妙更无优劣。此则不可偏判。若从法为语有则附俗入道则拙。空则傍真入道则巧。故释论云。为钝根人说生空。为利根说法空。即其义也。亦有亦无门。望前为巧望后是拙。非有非无门则是巧也。大论云。半有半无者。名为钝人。是约四门法判粗妙也。今约根性便宜。若宜有门有门成三门坏。若宜无门无门成三门坏。乃至第四门亦如是。若就一门皆得四悉檀者。皆名为成。失四悉檀者皆名为坏。还就一门赴欲为得乖情为失。当宜为得不当宜为失。治病为得不治病为失。见第一义为得。不见第一义为失。传有成坏。约此得论粗妙也。又约十观判粗妙者。观因缘境正为得。境邪僻为失。发真正心为得不尔为失。安心得所为得。安心不调为失。破法遍为得不遍为失。知通塞为得。不知通塞为失。乃至顺道法爱不生为得。顺道法爱生为失。若一门十法成就。则此门为妙。余门为粗。若余门十法成就。此门不成就则此为粗。余门为妙(云云)。通四门粗妙者。通理唯一。一不可说。有何形比粗妙可论。就赴机说门不无优劣。判四门深浅。如三藏中说。又约一一门。若说会四悉檀机名之为妙。若乖四机名之为粗。若于一一门十观修行。句句得所名之为妙。句句失所名之为粗。粗故四边火所烧。不得入清凉池。异此者名之为妙也。别四门粗妙者。若论法相有门附事故为粗。空门傍理故为妙。空门单理故为粗。亦空亦有门两通故为妙。亦空亦有两存故为粗。非空非有门两舍故为妙。若约根缘则不如是。有门称欲故为妙。三门不称欲故为粗有门是宜故为妙。三门非宜故为粗。有门对恶故为妙。三门非对故为粗。有门见第一义故为妙。三门不见第一义故为粗。余三门亦如是。又识有门真善妙色之境者。名镇头迦。不识境故名迦罗迦。正发心故名镇头迦。不正发心名迦罗迦。安心定慧名镇头迦。不安二法名迦罗迦。破诸法遍名镇头迦。破法不遍名迦罗迦。善识通塞名镇头迦。不识通塞名迦罗迦。修三十七品名镇头迦。不修道品名迦罗迦。善解对治名镇头迦。不善对治名迦罗迦。善知次位名镇头迦。不识次位名迦罗迦。安忍不动名镇头迦。不能安忍名迦罗迦。无顺道爱名镇头迦。顺道爱起名迦罗迦。迦罗迦果则有九分。镇头迦果才有一分。若十观成就。则十分镇头十观皆妙。若九分迦罗迦罗则粗。一分镇头镇头则妙。叠华千斤不如真金一两。故约此判粗妙也。有门既尔余三门亦如是。圆教四门者。则皆妙无粗。何者。有门为法界摄一切法。不可思议即是一切法。况复三门。空门即是法界。摄一切法况复三门。余二亦如是。法相平等无复优劣。若尔则无四门之异。但因顺根机赴缘四说。如四指指一月。月一指四。何者。此由众生世世习此四门。因以成性。昔四门中推理。欲翻无明即成慧根性。昔四门中修善。欲翻恶业即成福德根性。福慧因缘感今名色触受。各于本习而起爱取。是为十法成圆性众生欲乐不同。宜治有异。佛智明鉴照机无差。以世界悉檀赴四性欲。说此四门。以为人悉檀生四善。以对治悉檀治其四执。以第一义悉檀令四人见理。无此四缘佛不说法。缘既不一略言其四。皆是正直舍方便。但说无上道。门相圆融四门皆妙。此就教门更判粗妙。何者。若不得四悉檀意。诸论诤竞谁能融通。如地论有南北二道。加复摄大乘兴。各自谓真互相排斥。令堕负处。若不得意四门俱失。但圆门融净教尚虚玄。销释经论何竞不息。若欲入道何门不通。悟理之时岂应存四。修行之时岂应有塞。但四塞有轻重。别教门隔。悟者无乖未悟成诤。其执大重。譬如钝马痛手乃去。圆门虚玄未悟之时。其执则轻。譬如快马见鞭影即去。如此轻执。若未得第一义益。不失三悉檀利。故论云。是四悉檀皆实不虚。何者。世界故实。乃至见第一故实。虽俱是实实有深浅。亦俱是虚。何者。如有门说世界悉檀。于乐欲是实。于余则虚。有门生善为实。于余则虚。有门破恶为实。于余则虚。有门见第一义为实于余则虚。乃至三门亦如是。有门三悉檀。于世界故实。于第一义则虚。一悉檀于第一义故实。于世界则虚。实故为妙虚故为粗广作(云云)。若以此粗妙约五味者。乳教有八门四粗四妙。所通俱妙也。酪教四门为粗。理亦是粗。生苏则十六门。十二门是粗。四门是妙。两所通为粗两所通为妙。熟苏有十二门八门是粗四门是妙。一理为粗一理为妙。法华四门为妙。一理亦妙。诸声闻人前来门理俱粗至此法华门理融妙。菩萨不定。或于方等般若门理融妙。极钝者同二乘也。涅槃有十六门。十二门粗。四门为妙。所通俱妙。何者。前来诸门粗妙各通。犹存权理。涅槃不尔。一切诸法中悉有安乐性。是诸众生皆有佛性。无复权理。但一妙理。而更存粗门为妙理。方便皆明入实。如梵志问云。因无常故果云何常。佛反质答(云云)。故知。如百川总海诸门会实。实理要急是故须融。接引钝根存粗方便。法华折伏破权门理。如金沙大河无复回曲。涅槃摄受更许权门。各为因缘存废有异。然金沙百川归海不别(云云)。四开粗门显妙门者。问中论先明摩诃衍门。后明二乘门。今何意先明小门。后明大门。答中论为时人见成病。先以大荡。后示入真之门。今经无复见病。但住草庵。须开方便门示圆实相故。先列小门次明大门。开破适时各有其美。若法华后教不俟更开。法华前教。或门理已入妙者。更何所开。或门理虽妙而人未妙。门理妙者亦不须开。若门若理。若人未妙者。今当开。谓开一切爱见。烦恼即是菩提。故云观一切法空如实相。开一切生死即是涅槃。故云世间相常住。开一切凡人即是妙人。故云一切众生皆是吾子。开一切爱见言教即是佛法。故云若说俗间经书治生产业。皆与实相不相违背。开一切众生即是妙理。故云为令众生开佛知见。示悟入等亦复如是。开一切小乘法即是妙法。故云决了声闻法是诸经之王。开一切声闻教故云佛昔于菩萨前毁訾声闻。然佛实以大乘而见教化。开一切声闻行即是妙行。故云汝等所行是菩萨道开一切声闻。理即是妙理。故云开方便门示。真实相。开诸菩萨未被妙者今皆得圆。故云菩萨闻是法疑网悉已除。别教有一种菩萨。三藏亦一种菩萨。通教一种菩萨。未决了者。今皆开显。若门若理无不入妙。是名开权显实决粗令妙也(云云)

○第五实相为诸经作体更为五。一今经之体种种异名。二诸经体种种异名。三傍正料简。四此彼料简。五粗妙开粗显妙。一此经体名前后同异者。序品云。今佛放光明助发实相义。又云。诸法实相义已为汝等说。方便品广说中云。诸佛一大事因缘。开佛知见无上道实相印等。譬喻中。以大车譬一大乘。信解中名付家业。药草中名一切智地最实事。化城中名实所。授记中名系珠。法师中名秘密藏。宝塔中名平等大慧。安乐行中名实相。寿量中名非如非异。神力品中秘要之藏。妙音中名普现色身三昧。观音中名普门。劝发中名殖众德本。如是等异名不同。其义亦异。理极真实以实为相。故名实相。灵知寂照名佛知见。三世诸佛唯用此自行化他。故言大事因缘。虚通名道。正定诸法名实相印。运载名乘成办佛事名家业。一切所依故名智地。诸法之元故名宝所。圆妙难思故言宝珠。无所积聚而含众法名秘藏。秘要通达无碍。名平等大慧。遮于二边名非如非异。妙色自在故言普现三昧。入实之由故名普门。诸法由生故言德本。如是名义差别。体即实相已如上说(云云)。二诸经之体种种异名者。问释论云。无实相印是魔所说。今谈实相可用为体。余经不尔应是魔说。答不然。诸经异名。或真善妙色或毕竟空。或如来藏或中道等。种种异名不可具载。皆是实相别称。悉是正印各称第一。由实印故也。若失此意则非佛法。故言众经体同也。三傍正料简者。众经半满小大之殊体有傍正。正即实相傍即偏真。偏真或时含实相。实相或时带偏真。而通称实相。故中论云实相三人共得。共得者即偏真也。大经云。声闻之人但见于空。空即傍也。智者见空及与不空。不空即正也。此经云。我等昔日同入法性。法性即傍也。今日安住实智中。实智中即正也。小乘三法印此傍也。通教带傍明正也。别圆但明于正。不复论傍。若约五味乳唯论正。酪唯论傍。生苏熟苏傍正相兼带。醍醐唯正。又正实相多诸名字。约名字中复论傍正。胜鬘自性清净为正。余名为傍。华严以法身为正。般若以一切种智为正。涅槃以佛性为正。此经以实相一乘为正。余名为傍。此则非傍非正论傍正。傍正悉是经体(云云)。四就彼此料简。上约别圆二法异名料简。今更通就小大四句料简。或名义体与此经同或名义体与此经异。或名义与此经同而体异。或名义与此经异而体同。三藏中若名体为实相者。此名义与此经同而体异。若不名为实相者。此名义体与此经异。唯论两句无有两句。通教名实相为体者。此名义同而体异。若不作此名。则名义体俱异。若通门远通中道者。则名义体同。名义异而体同。别教望圆经四句如一法异名中分别(云云)。历五味者。乳教两种名义同。两种名义异而体同。酪教如前(云云)。生苏熟苏中如前(云云)。涅槃中四种名义异名义同。而皆体同。一佛性则无差别(云云)。五粗妙者。正实相中傍正异名者。此乃异名异义。其体本同。此无粗妙。但傍为粗傍含正正带傍。一往亦为粗但正为妙也。藏通名同义同而体别。一向是粗。别名义或同或异。教门异为粗。体同为妙。名义同名义异。而体同为妙。历五味中粗妙可知也。开粗者即开于傍也。或开傍教即正教。佛昔于菩萨前毁訾声闻。然佛实以大乘而见教化。或开傍行即正行。汝等所行是菩萨道。或开傍人即正人。客作人一日之价。即长者子也。或开傍体即正体。开方便门示真实相。后见此贫人示以所系珠。深观傍理即正理也。一切皆妙无粗可待。即经之正意也

○第六诸行体此为四。一诸行同异。二依经修行。三粗妙。四开粗。行同异者。夫禀教立行不出信法。钝者因闻得解从解立行。故名信行。利者自推得解。从解立行故名法行。二行通四教。三藏信法以傍实相为体。通教信法以傍含正为体。别教信法以正为体。圆信法亦用正为体。若横论行。即是诸波罗蜜慈悲喜舍等。当教论体。若横竖诸行。有体则本立而道生。若体有行体则藉行而显也。重明圆竖。行。五品六根以相似正为体。初住至等觉。皆用真正为体。横行者如大品云。一切法皆是摩诃衍。以不可得不可得故。即正实相也。此文云。不得诸法若有若无等。赐诸子各一大车。即其义也。儒童见然灯佛得无生忍。行有真体。金刚般若云。无住相布施。如人有目见种种色。亦其义也。竖行有体其车则高。横行有体其车即广。高广大运行步平正其疾如风(云云)。二依经修行者。前信法两行意通时宽。或经劫数。譬如长围。若依诸经别明行法。克日制时喻如苦攻。若随事行。行行则无体。若随理行行。令此空慧与行相应。能破无量障道罪。能得无生忍者。此行有体。诸经别行乃多。略言其四。谓常行行常坐行。半行半坐行。非行非坐行。诸行各有事相方法。勤身苦策。悉用实相正观为体。念念无间清净如空。具论观意如止观中说。然小乘戒藏不许忏重。修多罗藏使犯重人念佛身。佛身者念空也。亦备有常行等方法。而以偏空为体。通教亦明常行等方法。而用即空为体。别行历别圆行虚融。而俱用正实相为体。以此四行历五味。论方法之体义推可知。三粗妙者。藏通信法真似横竖诸行。以傍实相为体。体行俱粗别信法真似横竖诸行。虽依别门用正实相为体。因无常故而果是常。行粗体妙。圆信法真似横竖。依圆门正体体行俱妙。历五味明粗妙可知(云云)。依诸经方法常行等行。以傍为体。体行俱粗。以正为体则行粗体妙。体行俱妙。例前可知。历五味亦可解(云云)。四开粗者。开三藏信法两行。亦是决了声闻法。是诸经之王。闻已谛思惟得近无上道。闻即信行。思惟即法行。皆近无上道者即大乘无相行近于真也。开横行者。低头举手歌咏散心。皆已成佛道。三藏最浅尚被开即妙。况通别等可以意得。开依小乘常行等方法者。小小微善无一不成佛。可以意得(云云)

妙法莲华经玄义卷第九上妙法莲华经玄义卷第九下

        天台智者大师说

○第七遍为一切法体者。观经云。毗卢遮那遍一切处。一切不出四谛。大经云。佛所不说如十方土。所说者如爪上土。迦叶云。已说是四谛。其未说者应有五谛。佛言无也。但言是四谛有无量相耳。若然广开即成四种四谛。具如境妙中说。当知苦集世间善恶因果。道灭出世一切因果。悉用实相为体。净名曰。从无住本立一切法。此之谓乎。然所依之体体妙无异。能依之法法有粗妙。诸法相待分别可知。历五味分别粗妙亦可知。开粗显妙亦可知(云云)。略说经体竟

△大章第三明宗。宗者修行之喉衿。显体之要蹊。如梁柱持屋。结网纲维提维则目动。梁安则桷存。释宗为五。一简宗体。二正明宗。三众经同异。四明粗妙。五结因果。简宗体者。有人言。宗即是体体即是宗。今所不用。何者。宗致既是因果。因果即二体。非因非果体即不二。体若是二体即非体。体若不二体即非宗。宗若不二宗即非宗。宗若是二宗即非体。云何而言体即是宗。宗即是体。又柱梁是屋之纲维。屋空是梁柱所取。不应以梁柱是屋空。屋空是梁柱。宗体若一其过如是。又宗体异者。则二法孤调。宗非显体之宗。体非宗家之体。宗非显体之宗。宗则邪倒无印。体非宗家之体。则体狭不周。离法性外别有因果。宗体若异其过如是。今言不异而异。约非因非果而论因果。故有宗体之别耳。释论云。若离诸法实相皆名魔事。普贤观云。大乘因者诸法实相。大乘果者亦诸法实相。即其义也。当知实相体通而非因果。行始辨因。行终论果。而复偏圆有别者。譬如铜体非始非终。拟铸为像即名像始。治莹悉毕即名像终。此譬圆因果。若拟器皿。及其成就。器皿始终。譬偏因果也。发七方便心。谓偏因证有余无余名偏果。开佛知见名圆因。究竟妙觉名圆果。若识此喻。不即不离宗义明矣。例如正因佛性。非因非果而言是因。非果名佛性。是果非因名大涅槃。又佛性非当非本。而言本自有之。一切众生即涅槃相。不可复灭。又言。一切众生悉有佛性。而实未有三十二相。未来当得金刚之身。以其非当是故言本。以其非本是故言当。宗体之义亦复如是。远师以一乘为宗所。谓妙法引文云。是乘微妙为无有上。私谓。为破三故一待粗非妙因而不该始末。龙师云。但以果为宗。妙法者是如来灵智体也。众粗斯尽为妙。动静轨物为法。法既真妙借莲华譬之。所以果智为宗也。私谓。果不孤立。云何弃其因。又乖文也。慧观序云。会三归一乘之始也。慧觉成满乘之盛也。灭影澄神乘之终也。什师叹云。若非深入经藏。岂能作如此说。印师云。诸法实相是一乘妙境。用境智为宗。境无三伪故称实相也。今谓加境而阙果肿不益肥。光宅用一乘因果为宗。前段为因后段为果。私谓。二文各有因果。若互存互没则害经文。有人。用权实二智为宗。私谓。用权应明三是经宗。三是今经所弃云何取所弃为宗。又师云此名妙法莲华。即以名为宗。妙法是佛所得。根本真实法性。此性不异惑染。不与惑同故称妙。即宗为名耳。此是地师所用。据八识是极果。今摄大乘破之。谓是生死根本。有师云。常住为宗。但未极上是覆相明常。私谓。都非经意。常若被覆宗何所显。常不被覆常则非宗。有师云。是显了明常与涅槃为广略耳。私谓。常为宗者。常无因果。常亦无宗(云云)。有言。万善为宗。但使是善皆得作佛。私谓。若作佛即是果。何不取果为宗。有言。万善中取无漏为宗。私谓。太局又滥小涅槃。有人言。若禀斯异说各蒙益者。众释无可为非。闻而不悟。众师无可为是。一师之意唯贵在悟。宜以悟为经宗。大经云。若有定相是生死法是魔王相。佛法无定相。是故如来非道说道道说非道。当知唯悟是从。私谓。若悟为宗。乃是果证非谓行因。问南指北方隅料乱。又定以悟为宗是为定定。何谓不定说者。甚多不能具出也。二正明宗者。此经始从序品讫安乐行品。破废方便开显真实。佛之知见。亦明弟子实因实果。亦明师门权因权果。文义虽广撮其枢要。为成弟子实因。因正果傍。故于前段明迹因迹果也。从涌出品讫劝发品。发迹显本。废方便之近寿明长远之实果。亦明弟子实因实果。亦明师门权因权果。而显师之实果。果正因傍。故于后段明本因本果。合前因果共为经宗。意在于此。所以经分二文。论本论迹。双题法譬举莲举华。师弟权实总在其间也。三众经因果同异者。谓迹因果或同或异。本因果永异迹因果者。实相通印诸体。何经不约此论因果。大品明非因。非果实相为体。而但因为宗般若遣荡正是因意。故云菩萨心中名般若。在佛心中名萨婆若。文中亦说菩萨无生无灭因。获不断不常萨婆若果。睿师序云。启玄章以不住为始。归三慧以无得为终。终始因果也。文中亦说一切种智佛果。为成般若因。因正果傍无量义宣说摩诃般若。历劫修行故知彼经用因为宗也。净名用佛国因果两义为宗。宝积具问因果佛备答因果。故知双用因果为宗也。华严圆顿之教解宗不同。或言用因为宗。据题言华严。是万行庄饰修因之义。文中多说四十地行相。故用因为宗。又云。果为宗。据题云大方广佛。佛是极果之名。华严是定慧万善庄严佛身。非庄严因。文中多说舍那法身之事。即用果为宗也。又解云。因果合为宗。如言佛即是果华严即是因。文中具说法身亦说诸地。俱用因果为宗。诸经对缘不同。故明宗互异耳。般若通对三人傍真因果。此义则异。别对菩萨复有利钝。为钝明因此义亦异。利人因者此义则同净名佛国义兼。若三种佛国因果此义则异。一种佛国因果者则同。华严亦对两缘钝异利同。如前分别。又将此意历五味因果。例可知。是为众经因果。与迹门同异之相也。二本门因果永异众经者。若三藏菩萨。始行实因果无权因果。乃至明佛道树始成。非久远本迹。通教菩萨亦始行因。神通变化而论本迹。非久远本迹也。大品说菩萨有本迹。二乘则无。说佛始得生法二身本迹。不说久远。净名不说声闻有本迹。但明菩萨住不思议之本迹。说佛有净土。螺髻所见亦非久远。华严说舍那释迦为本迹。菩萨亦有本迹。声闻尚不闻不解。云何自有本迹。今经发声闻有本。本有因果。示为二乘迹中因果。发佛之迹。王宫生身生道树法身生。乃至中间生法二身。悉皆是迹。但取最初先得真应名之为本。故师弟本因本果。与余经永异。今经迹中师弟因果。与众经有同有异。本中师弟因果众经所无。正以此之因果为经妙宗也。四粗妙者。若半字之因道树遍果。此宗则粗。大品所明三乘共因果。亦如是不共之因。虽云菩萨一日行般若。如日照闇。发心即游戏神通。而犹带粗因。圆因不得独显。虽说法身无来无去。犹带粗果。圆果不得独显。故名为粗。方等中虽弹偏因果。高原陆地不生莲华。不辨偏得入圆圆不彰显是亦为粗。华严前照高山。说一圆因。究竟后身说一圆果。又带别因果。所带处粗。今经声闻受记。菩萨疑除同开佛知见。俱入一圆因。发迹显本同悟实果。因圆果实不带方便。永异余经。故称为妙也。开粗者。昔缘根钝。未堪闻赞佛乘因果。用方便因果引接近情。五味调熟心渐通泰。决了粗因同成妙因。决诸粗果同成妙果。故低头举手着法之众。皆成佛道。更无非佛道因。佛道既成。那得犹有非佛之果。散善微因今皆开。决悉是圆因。何况二乘行。何况菩萨行。无不皆是妙因果也。五结成者。即为二。一结因果。二四句料简。夫经说因果。正为通益生法行人。若开权显实正令七种方便生身未入者入。傍令生法二身已入者进。若说寿量长远。傍令生身未入者入。正令生法已入者进。神力品云。如来所有一切甚深之事者。非因非果是甚深之理。因果是甚深之事。从七种方便初得入圆。登铜轮位名之为因。乃至余有一生在。若转一生即得妙觉。名之为果。从于二住。至于等觉中间。名为亦因亦因因。亦果亦果果。用无碍道伏一分无明。名之为因。用解脱道断一分无明。名之为果。约此解脱复修无碍。故云因因。从此无碍复得解脱。故言果果。复次初十住为因。十行为果。十行为因回向为果。十向为因。十地为果。十地为因等觉为果。等觉为因妙觉为果。妙觉唯果唯解脱。不得名因名无碍。初住唯因唯无碍。不得名果名解脱。何者。初住见真以真为因。住前相似非是真因。若取性德为初因者。弹指散华是缘因种。随闻一句是了因种。凡有心者是正因种。此乃远论性德三因种子。非是真实开发。故不取为因也。二四句料简者。问若言初住入理。名为圆因圆果何得文云渐渐修学得成佛道。答应作两种四句料简。自有渐圆自有圆渐。自有渐渐自有圆圆。渐圆者。此约理外七种方便。同开佛知见始见圆理。见圆理者。良由理外七种方便渐入圆因。故言渐圆。渐圆三句(云云)。圆渐者。初入此圆同观三谛。见实相理初后无殊。然而事中修行未能尽备。复须研习。据初入圆故名为圆。进修上行复名为渐。渐渐者从二住去至等觉。此是圆家渐渐。非理外渐渐。圆圆者至妙觉亦名渐圆。亦名圆圆。圆理先圆今复事圆。故言圆圆。复次圆渐如初住。渐渐如二住已去至三十心。渐圆如初地已去。圆圆即妙觉也。三十心虽同有贤圣之义。义称为贤。伏多断少故。十地去名为圣。伏少断多故。又十住名贤圣。二十心是圣贤。十地等觉是圣。妙觉是圣圣。今借喻初月。匡郭已圆光用未备。此譬圆渐。从二日至十四日。其明渐进此譬渐渐。至十五日此譬渐圆。又譬圆圆。夫月无亏盈。亦约月辨亏盈理无圆渐。亦约理判圆渐耳。此经之宗利益巨大。始自圆渐终竟圆圆。大乘因果增长具足(云云)。问既称圆渐复称圆别。乃至通藏亦应尔耶。答此义出四教章中。其意云何。三藏三藏可解。别者谛缘度也。通者真谛也。圆者无学办也。通通者同无生也。三藏者道谛中戒定慧也。别者正习尽不尽也。化他不化他出假不出假之别也。圆者同证真也。别别者别上别下也。三藏者修无量道谛中戒定慧也。通者四门俱契中也。圆者五住尽也。圆圆者融也。别者四门异也。通者四门相摄也。藏者圆道谛圆戒定慧也。此义既通。亦应渐圆渐圆四句皆得也。结因果皆成也。然后判粗妙开粗妙悉得也

△大章第四明用者。用是如来之妙能。此经之胜用。如来以权实二智为妙能。此经以断疑生信为胜用。秖二智能断疑生信。生信断疑由于二智。约人约法左右互论耳。前明宗就宗体分别。使宗体不滥。今论于用就宗用分别。使宗用不滥。何者。宗亦有用用亦有宗。宗用非用用。用用非宗用。用宗非宗宗。宗宗非用宗。宗用者因果是宗。因果各有断伏为用。用有宗者慈悲为用宗。断疑生信为用用。若论于宗且置断伏。但论因果仐明于用。但论断疑生信。且置慈悲。若得此意。则知权实二智。能断疑生信。是今经之大用。其义明矣。论用开为五。一明力用。二明同异。三明历别。四对四悉檀。五悉檀同异。一正明用者。诸经不纯明佛智慧。不发佛自应迹。不正破废二乘果。不断生身菩萨之近疑。起其远信不显本地。增法身菩萨大念佛之道。损界外之生。如此力用众经所无。今经具之。所以命章。不论二乘菩萨等智。纯显佛之微妙智慧。不开众生九法界知见。纯开众生佛之知见。余经但道佛所变化是迹。不道佛身自是迹。今经自道佛身是迹。其余变化宁得非迹。今经正破废化城二乘之果。况其因行耶。又破禀方便教菩萨执迹为极。今皆发废悉称是权迹。及中间诸疑悉断。起于深远不思议信又显本地真实功德。令法身菩萨得大利益。始自初阿终邻后茶。抹十方那由他土为尘数增道菩萨不能令尽。盖由如来雨权实二智一味之雨。普等四方俱下者。一切诸四门俱破也。充足求于具足道者。断其深疑起其大信。令入一圆因。控摩诃衍车游于四方。直至道场。大用大力妙能妙益。犹自未尽。复次此力能破二乘之果。二乘怖畏生死入空取证生安隐想。生已度想堕三无为坑。若死若死等苦。已如败种更不还生。智医拱手方药无用。至如涅槃能治阐提。此则为易。阐提心智不灭。夫有心者皆当作佛。非定死人治则不难。二乘灰身灭智。灰身则色非常住。灭智则心虑已尽。焦芽败种。复在高原陆地。既聋且哑永无反复。诸教主所弃。诸经方药不行。今则本佛智大妙法药。良色身不灰如净琉璃。内外色像悉于中现令心智不灭。开示悟入佛之知见。令客作贱人付菩提家业。高原陆地授佛莲华。其耳一时听十法界声。其舌随一切类演佛音声令一切闻。能以一根遍为众用。即是今经之力用也。上已说佛智力竟。今更重说。如汉末三分。曹公智略当时第一。复劣杨修三十五里。此真丹人智不及外国。外道智如芥比山。一切世人外道智。不及舍利弗智十六分一。二乘智如萤火虫。菩萨智如日光。通菩萨智。如鸿鹄势不及远。别菩萨智如金翅鸟。从一须弥至一须弥别菩萨智如爪上土。比佛智慧如十方土。当知佛之智慧。至融至即至顿至实不可思议。不纵不横圆妙无比。喻不可尽。问答余经不纯说。今经独纯说之。此佛实智力大也。譬如十小牛。乃至一龙十龙。一力士十力士。不如五通人。外五通不如一罗汉。一切罗汉不如一目连。目连不如一身子。身子不如菩萨。菩萨不如别菩萨。别菩萨不如圆菩萨。圆菩萨不如佛。佛迹甚大化复作化。化化无尽无谋而当如修罗琴。一切贤圣无能测者。佛权力既如此。余诸义例可知不复记。二明同异者。问实相体因果宗既通众经。权实二智复云何。答名虽通用力大差别。藏通以二智断四住之疑。生偏真之信。净名虽弹斥二乘及偏行菩萨。亦是界内断疑生信。不能令小乘及方便菩萨。断大疑生大信。大品通意。亦是界内疑断信生。别意虽在界外。亦未断近疑生远信。华严正意。断界外疑生于圆信。亦未断近生远。故权实二名虽复通用。而力大异。今经用佛菩提二智。断七种方便最大无明。同入圆因。破执近迹之情生本地深信。乃至等觉亦令断疑生信。如是胜用岂同众经耶。三别释为两。一别释迹门。二别释本门

  释迹门为十　　一破三显一
  二废三显一　　三开三显一
  四会三显一　　五住一显一
  六住三显一　　七住非
  三非一显一　　八覆三显一
  九住三用一　　十住一用三

此意通历十妙。一一妙中皆具十意。义推可解(云云)。今就别说者。破三显一。正破三情而显一智何者。昔若初赞佛乘众生没在苦。既不堪闻大。寻念过去佛所行方便力。亦应说三乘。说三乘已齐教封三情。不更愿好者。今破三执显于佛智。故言诸佛法久后要当说真实也。废三显一者。此正废教。虽破其情若不废教。树想还生执教生惑。是故废教。正直舍方便但说无上道。十方佛土中唯有一乘法。无二亦无三。开三显一者。正就于理傍得约教。约教者。昔教明三人入真。今教明三人得佛也。正约理者。秖是二乘真空自有实相。昔方便不深不能妙见。今开此空即是实相。故言决了声闻法。是诸经之王。开方便门示真实相。大经云。为诸声闻开发慧眼。会三显一者。正就于行。大品会宗云。四念处四禅等。皆是摩诃衍。但会其法未会其人。此经人法行俱会。故云汝等所行是菩萨道。渐渐修学悉当成佛。低头举手皆成佛道(云云)。住一显一者。此就佛本意。本以实智化物。佛平等说如一味雨。佛自住大乘。如其所得法定慧力庄严。以此度众生。若以小乘化我则堕悭贪。是事为不可。故知从得道夜常说中道。常说大乘而众生罪故。故使如来以毒涂乳着弊垢衣。方便婆和引令向大。故言虽说种种道其实为一乘(云云)。住三显一者。此就佛权智方便化物。寻念过去佛所行方便力。我今亦如是。即趣波罗柰。以方便力故为五比丘说。过去诸佛亦住三乘而显一乘。今佛亦尔。故言更以异方便助显第一义。又昔于菩萨前毁訾声闻。然佛实以大乘而得度脱。住非三非一显一者。或约理或约事。约理者是法住法位世间相常住。是法不可示。知法常无性佛种从缘起。无性即非三非一。从缘起。即是三缘显一。令会非三非一。约事者即是人天乘。此乘非三亦复非一。常以此乘引入于大。低头举手皆成佛道。若我遇众生尽教以佛道。覆三显一者。此就权巧多端。前权前度但除其病。不除其法。法不除故拟化后缘。若破此法后何所用。机息则覆机兴则用。何但佛尔。入实菩萨亦然。若有不信此法。于余深法中示教利喜(云云)。住三用一者。此就法身。妙应眷属前住三显一。是师门。今住三用一是弟子门。如富楼那等实是法身。现作声闻示住于三。而常显一。饶益同梵行者。住一用三者。此就本誓。如华光作佛愿。说三乘而非恶世。今佛亦于宝藏佛所。愿于恶世说此三乘(云云)。但权实大用包括法界。岂止十意而已。为显十妙之用故略言十耳

破三显一是用智妙　废三显一是用说法妙　开三显一是用境妙　会三显一是用行妙　住一显一是用乘妙　住三显一是用感应妙　住非三非一显一是用神通妙　覆三显一是用位妙　住三用一是用眷属妙　住一用三是用利益妙

将十用对当十妙。文义相拣大意可解(云云)。二本门力用例为十意。若扶文便。应言开近显远。若取义便应言本迹。秖呼近为迹远为本。名异义同。所言十者

  一破迹显本　　二废迹显本
  三开迹显本　　四会迹显本
  五住本显本　　六住迹显本
  七住非迹非本显本　　八覆迹显本
  九住迹用本　　十住本用迹

通就本门一一妙中。皆具十意。若别论者破迹显本。亦就破情。序品方便宝塔三文。已动执生疑。如文殊答弥勒云。昔八王子师事妙光。妙光先居补处。而王子成佛号曰然灯。弟子今又成佛。号曰释迦。妙光翻为弟子。字曰文殊。动迹执生此疑何由可决。今言非是补处淹缓。亦非弟子超越。良由释迦成道已久。昔示弟子今示作师耳。拂此迹疑显于本智。故言破迹显本也。方便品云。我从久远劫来赞示涅槃道。生死苦永尽。我常如是说。当知。生死久已永尽。非是中间始入涅槃。宝塔涌现证示灭不灭。即迹而常分身皆集。八方不可称数。分身既多。当知成佛久矣。如荷积满池之喻推三品文。已是破迹之渐。所以下方涌出。非寂灭道场受化。亦非他方分身所受化。此两处人。弥勒皆识。而今不识所以惊疑。破此近情显本长远。故文云。一切世间皆谓。我释迦牟尼出释氏宫。去伽耶城不远得三菩提。然我实成佛来。无量百千万亿那由他劫。直举世界问弥勒。弥勒不知其数。何况世界中尘而当可数。此是破近执谓生其远智也。废迹显本者。亦就说法。昔为五浊障重不得远说本地。但示迹中近成。今障除机动。须废道树王城迹中之说。皆是方便执近之心既断。封近之教亦息。文云。自从是来我常在此娑婆世界。说法教化。亦于余处百千万亿那由他阿僧祇国。导利众生。即是废一期之迹教。显久远之本说也开迹显本者。此亦就法亦就理。秖文殊所述。然灯佛及久远来。赞示涅槃道。及分身诸佛。如此迹说。以是显本之意。惑者未悟玄旨。今若显本。亦不迥就余途还开近迹。示其本要耳。就理者。但深观方便之迹本理即显。文云。我实成佛已来久远若斯。但以方便教化众生。令入佛道。若入佛道即于迹得本也。会迹显本者。此则就行。寻迹中诸行。或从此佛行行得记。或从彼佛行行得记。或示己身他身。随机应现长短大小。诸迹悉从本垂。若结会古今。还结迹而显本耳。本迹虽殊不思议一。文云。诸善男子。于是中间。我说然灯佛等。又复言其入于涅槃。如此皆是方便分别。即会迹显本意也。住本显本。此就佛本意。即如下方菩萨于空中住。法身佛为法身菩萨说法。法身修道纯说一乘。文云。娑婆世界纯以黄金。为地。人天充满。又云。人众见烧尽我净土不毁。能如是深观是为深信解相。常住此本恒显于本。文云。我成佛已来甚大久远。寿命无量阿僧祇劫。常住不灭。岂非住本显本也。住迹显本者。此就迹意。即是释迦住生身而显一。由显一故古佛塔涌。塔涌故召请分身。分身集故幕觅弘经。下方出现幕觅弘经。下方出现弥勒疑问。问故说寿长远。动执遣疑。是为住迹显本也。文云。我以佛眼观其信等诸根。乃至种种方便说微妙法。能令众生发欢喜心也。住非迹非本而显本者。此约绝言冥会。即是非本非迹而能本迹。昔非迹而垂迹。今非本而显本。文云。非实非虚非如非异。如斯之事如来明见也。覆迹显本者。亦约机应多端。若执迹障本故覆令不执。更对后机还须用迹。故有师子奋迅之力。文云。以若干言辞因缘譬喻种种说法。所作佛事未曾暂废。住迹用本者。上来住迹显本者。直是迹中随机方便显本地理。今言住迹用本者。即是中间迹至道树。数数生灭他身他事者。皆用本地实因实果。种种本法为诸众生而作佛事。故言住迹用本。此就师为解。若约弟子者。即是本时妙应眷属。住于权迹垂形九道。而用本法利益众生。文云。然我今非实灭度。而便唱言当取灭度如来以是方便教化众生。此是住迹而用本时灭度。而示灭度也。住本用迹者。即是本地不动而迹周法界。非生现生非灭现灭。常用此迹利润众生。此义据师。若据弟子者。即是法身菩萨。以不住法住于本地无谋之权。迹用无尽。文云。又善男子。诸佛如来法皆如是。为度众生皆实不虚。佛散赴众缘文小不次。今题来证义。引于寿量文尽。破迹显本会迹显本。别用因妙。开迹显本是别论用本果妙。住本显本是别用本国土妙。废迹显本别论是用本说法妙。住非迹非本别论是用本感应妙。覆迹显本别论是用本神通妙。住迹用本别论是用本寿命妙。亦是用本眷属妙。住本用迹别论是用本涅槃妙。亦是本利益妙(云云)。四结成悉檀者。权实二智十用不同。即是一音演说随类各解。迹中破废。令七种方便开佛知见。本中破废恒沙菩萨断疑增道。皆是四悉檀意成熟众生。今束此十用为四悉檀。先束迹门。次束本门。迹又为二。先别束次通束。别者开三显一。住三用一会三归一。此三条属为人悉檀。何者本习此三。今还约三修一。不改途易辙。秖深观此三一理自显。三中有一。不须取舍。故开三显一属为人悉檀。住三用一亦如是。秖就此三而修一道。如富楼那但住声闻。而自饶益亦能饶益同梵行者。即是不改三法能生一解。皆属为人悉檀也。破三废三覆三。此三属对治。其封三疑一斥破其情。废于权教密覆权法。令执病心除入一实道。安住实智中也住三显一住一用三两种。属世界悉檀。何者世界以乐欲为本。若众生欲得三乘之道。不欲闻一实之化故。佛自住一同彼说三。又三乘缘异。如世界隔别。故名世界悉檀也。住三显一亦是世界。何者佛随人法住于方便。调熟显一。故属世界悉檀也。住一显一住非三非一显一。此属第一义悉檀也。通明四悉檀者。秖破三显一得有四种益。何者君子乐闻过。小人恶闻愆。欲知过必改。即为破执除病欢喜奉行。即是世界也。若执住三不能进道。破三从一觉悟心生。善法增进是名为人也。执三是病说一为乐。是名对治也。若闻破三得见理名第一义也。余九种例尔。故知佛之善巧称合机缘。皆令得益。四悉檀之力也(云云)。二结本门十用。为四悉檀者。亦有别通二意。住迹显本住本用迹。此属世界悉檀。亦名随乐欲。释如前。开迹显本会迹显本住迹用本。属为人悉檀。不改途更修。还约本法修显本也。释如前。破迹废迹覆迹属对治。住本显本住非本非迹显本。属第一义。释如前。次通约一科。结四悉檀亦如前。余九例亦尔具解(云云)。五悉檀同异者。余经亦用四悉檀。破三显一破迹显本等。而与此有异即为两。一迹门明异。二本门明异。迹门异者。三藏中亦用四悉檀破废等意。但为有余无余涅槃(云云)。大品中共般若。亦用四悉檀破立废等意。但悟真理未能久圆(云云)。方等中亦破三显一。于菩萨人有一分同。二乘人不得入实故。十弟子被净名诃。堕八邪不入众数。此是破斥之语。称叹不思议大乘之道。皆用四悉檀意而二乘不悟也。此经用四悉檀意。二乘而得断疑除执。入佛正道受记作佛。故知此经用四悉檀巧妙。文云。言辞柔软悦可众心。身子领解云佛以种种缘譬喻巧言说。其心安如海。我闻疑网断安住实智中。即其义也。问法华显一还藉先破。无前调熟今亦不解。答今日得悟由昔弹诃。但功属此经。名非彼得。譬如百人共围一贼。而攻围之力实赖众人。能擒贼者。得勋不属百人(云云)。此经开权显实。四悉檀大用最为雄猛(云云)。发迹显本四悉檀。永异众经。何者迹中力用已出诸教。本中十用诸经无一。况当有十。迹中悉檀已出诸经。本中悉檀诸经无一。何况有四。可以意推无烦多记也

妙法莲华经玄义卷第九下妙法莲华经玄义卷第十上

        天台智者大师说

大章第五释教相者。若弘余经不明教相。于义无伤。若弘法华不明教者。文义有阙。但圣意幽隐教法弥难。前代诸师或祖承名匠。或思出神衿。虽阡陌纵横莫知孰是。然义不双立理无两存。若深有所以。复与修多罗合者。录而用之。无文无义不可信受。南岳大师心有所证。又勘同经论。聿遵佛语。天台师述而从用。略明教为五。一大意。二出异。三明难。四去取。五判教。大意者。佛于无名相中。假名相说。说余经典。各赴缘取益。至如华严初逗圆别之机。高山先照。直明次第不次第。修行住上地上之功德。不辨如来说顿之意。若说四阿含。增一明人天因果。中明真寂深义。杂明诸禅定长破外道。而通说无常知苦断集证灭修道。不明如来曲巧施小之意。若诸方等折小弹偏叹大褒圆。慈悲行愿事理殊绝。不明并对诃赞之意。若般若论通则三人同入。论别则菩萨独进。广历阴入尽净虚融。亦不明共别之意。若涅槃在后。略斥三修。粗点五味。亦不委说如来置教原始结要之终。凡此诸经皆是逗会他意。令他得益。不谭佛意意趣何之。今经不尔。絓是法门网目。大小观法十力无畏。种种规矩皆所不论。为前经已说故。但论如来布教之元始。中间取与渐顿适时。大事因缘究竟终讫。说教之纲格大化之筌罤。其宿殖淳厚者。初即顿与直明菩萨位行功德。言不涉小。文云。始见我身闻我所说。即皆信受入如来慧。其不堪者。隐其无量神德。以贫所乐法方便附近。语令勤作。文云。我若赞佛乘众生没在苦。如此之人。应以此法渐入佛慧。既得道已。宜须弹斥。即如方等以大破小。文云。苦切责之已。示以所系珠。若宜兼通半满洮汰。如大品遣荡相着。会其宗途文云。将导众人欲过崄道。过此难已。定之以子父。付之以家业拂之以权迹。显之以实本。当知此经唯论如来设教大纲。不委微细纲目。譬如算者初下后除。纪定大数不存斗斛。故无量义云。无量义者。从一法生。则于一佛乘分别说三。此譬下算。若收无量以入一。会三而归大者。此譬除算唯记大数焉。如是等意皆法身地。寂而常照。非始道树逗大逗小。佛智照机其来久矣。文云。唯以一大事因缘出现于世。此照大久矣。文云。殷勤称叹方便。此照小久矣。文云。诸佛法久后要当说真实。此照会小归大久矣。信解品云。踞师子床见子。便识此语初鉴大机久矣。于窗牖中遥见其子者。此鉴小机久矣。密遣二人方便附近。语令勤作。此鉴须开三久矣。心相体信入出无难。此鉴调斥久矣。领知众物。此鉴洮汰久矣。后付家业。此鉴教行等久矣。当知佛意深远。弥勒不识所为因缘。况下地二乘凡夫等耶。文云。唯我知是相十方佛亦然。又已今当说。最为难信难解。前经是已说随他意。彼不明此意。故易信易解。无量义是今说。亦是随他意亦易信易解。涅槃是当说。先已闻故亦易信易解。将说此教。疑请重叠具如迹本二文。受请说时秖是说于教意。教意是佛意。佛意即是佛智。佛智至深。是故三止四请。如此艰难比于余经。余经则易。若始坐道场。梵王初请直言请法。亦无疑网往复殷勤说诸方等。观文可知。说大品时犹酬梵请。唯华严中请金刚藏。可为连类。而人师偏着。谓加于法华。言小乘致请不及菩萨。此见一边耳。身子腾众心云。佛口所生子合掌瞻仰待。求佛诸菩萨。大数有八万。欲闻具足道。何独是一小乘。又弥勒阖众求决文殊。与解脱月金刚藏。若为有异。又本门中菩萨。请佛说于佛法。岂比菩萨请菩萨说菩萨法耶。若就此意有加于彼。若彼列众十方云集。皆是卢舍那佛。宿世知识。此经云集地涌菩萨。皆从释尊发心。是我所化。此一往则齐而不无疏密。又彼明十方佛说华严。被加者。同名法慧金刚藏等。不言彼佛是舍那分身。今明三变土田。一方各四百万亿那由他土。满中诸佛悉是释尊分身。此意异彼。彼以华严为胜。薳复出一两句。非故兴毁。若较其优劣恐成失旨。但此法华开权显本。前后二文疑多请倍。不比余经。秖为深论佛教妙说圣心。近会圆因远申本果。所以疑请不已。若能精知教相。则识如来权实二智也。教意甚深其略如是

○二出异解者。即为十意。所谓南三北七。南北地通用三种教相。一顿二渐三不定。华严为化菩萨。如日照高山名为顿教。三藏为化小乘。先教半字。故名有相教。十二年后为大乘人。说五时般若乃至常住。名无相教。此等俱为渐教也。别有一经非顿渐摄。而明佛性常住。胜鬘光明等是也。此名偏方不定教。此之三意通途共用也。一者虎丘山岌师。述顿与不定不殊前旧。渐更为三十二年前。明三藏见有得道。名有相教。十二年后齐至法华。明见空得道名无相教。最后双林明一切众生佛性。阐提作佛。明常住教也。二者宗爱法师。顿与不定同前。就渐更判四时教。即庄严旻师所用三时不异前。更于无相后常住之前。指法华会三归一。万善悉向菩提。名同归教也。三者定林柔次二师。及道场观法师。明顿与不定同前。更判渐为五时教。即开善光宅所用也。四时不异前。更约无相之后同归之前。指净名思益诸方等经。为褒贬抑扬教。四者北地师亦作五时教。而取提谓波利为人天教。合净名般若为无相教。余三不异南方。五者菩提流支明半满教。十二年前皆是半字教。十二年后皆是满字教。六者佛驮三藏。学士光统。所辨四宗判教。一因缘宗。指毗昙六因四缘。二假名宗。指成论三假。三诳相宗。指大品三论。四常宗。指涅槃华严等常住佛性本有湛然也七者有师开五宗教。四义不异前。更指华严为法界宗。即护身自轨大乘所用也。八者有人称光统云。四宗有所不收。更开六宗。指法华万善同归。诸佛法久后要当说真实。名为真宗。大集染净俱融。法界圆普名为圆宗。余四宗如前。即是耆阇凛师所用。九者北地禅师。明二种大乘教。一有相大乘。二无相大乘。有相者。如华严璎珞大品等。说阶级十地功德行相也。无相者。如楞伽思益真法无诠次。一切众生即涅槃相也。十者北地禅师。非四宗五宗六宗二相半满等教。但一佛乘无二亦无三。一音说法随类异解诸佛常行一乘众生见三。但是一音教也。出异解。竟

○三明难者。先难南地五时其义不成。余四时三时例坏也。若言十二年前名有相教者。成实论师自诬己论。论云。我今正欲明三藏中实义。实义者所谓空。是空非无相耶。三藏非十二年前耶。又阿含中说。是老死谁老死二皆邪见。无是老死即法空。无谁老死即生空。三藏经中自说二空。二空岂非无相。又释论云。三藏中明法空为大空。摩诃衍中明十方空为大空。即以法空为大空。即大无相。又成道六年。即说殃掘摩罗经。明空最切。此非无相谁是无相耶(云云)。又大论云。从得道夜至泥洹夜。常说般若。般若即空慧也。复次十二年前名有相教。为得道为不得道。若得道则乖成论。论师云。有相四谛。是调心方便实不得道。须见空平乃能得道。既言有相那忽得道。若不得道用此教为。又拘邻如五人。最初于佛法寂然无声字。获真实知见。最初之言。岂非十二年前得道耶。又若得道教同无相。若不得道教同邪说。又若得道得何等道。若见空得道还同无相。若不见空得道。亦同九十五种。非得佛道。有相之教具有二过(云云)。二难十二年后名无相教。明空荡相未明佛性常住。犹是无常。八十年佛亦不会三归一。亦无弹诃褒贬者。此不可解。若言无相何意不荡无常。犹有无常何。谓无相。若言不明佛性法身常住者。共般若。可非佛性法身常等。不共般若云何非佛性耶。大经云。佛性有五种名。亦名首楞严。亦名般若。般若乃是佛性之异名。何得言非。彼即救言。经称佛性亦名般若者。是三德之般若。何关无相之般若。若尔者。涅槃第八何意云如我先于摩诃般若中。说我与无我其性不二。不二之性即是实性。实性之性即是佛性。如此遥指明文灼然。何意言非。又涅槃佛性。秖是法性常住不可变易。般若明实相实际。不来不去即是佛无生法。无生法即是佛。二义何异。故知法性实相即是正因佛性。般若观照即是了因佛性。五度功德资发般若。即是缘因佛性。此三般若。与涅槃三佛性复何异耶。金刚般若论云。福不趣菩提。二能趣菩提。于余名生因于实名了因。实相了因能趣菩提。岂非佛性。但名异义同如前分别。何得闻释提婆那民。谓非帝释。其谬类此。若言无常八十年佛说。非佛性常住者。涅槃亦云。八十年佛背痛有疾。于娑罗入灭那忽谭常辨性(云云)。释论云。佛有生身法身。生身同人法。有寒热病患马麦乞乳。法性身佛光明无边。色像无边。尊特之身犹如虚空。为法性身菩萨说法。听法之众尚非生死身。何况佛耶。释论云。又生身佛寿则有量。法身佛寿则无量。岂可以无常八十年加于法身耶。小乘中云法身尚其不灭。如均提沙弥忧恼。佛问汝和尚戒身灭不。答言不。乃至解脱知见灭不。答言不。何况般若法身而言无常。若言般若无会三者。何故问住品云。诸天子今未发三菩提心者。应当发。若入声闻正位。是人不能发三菩提心。何以故。与生死作障隔故。是人若发三菩提心者。我亦随喜。所以者何。上人应求上法。我终不断其功德。若声闻不求上法。何所随喜。既随喜上法即是会三。若言般若无弹诃者。大品云。二乘智慧犹如萤火。菩萨一日学智慧。如日照四天下。又十三卷云。譬如狗不从大家求食。反从作务者索。当来世善男女人弃深般若。而攀枝叶。取声闻辟支佛所应行经。又云。见像观迹皆名不黠。岂有弹诃更剧于此。谓无褒贬耶。若言般若是第二时教。引诸天子白佛云见第二法轮转者。何经不见第二。而独言般若。净名云。始坐道树力降魔。得甘露灭觉道成。乃至说法不有亦不无。两说相对亦应是第二法轮转。法华亦云。昔于波罗柰转四谛法轮。今复更转最上之法轮。涅槃又云。昔于波罗柰初转法轮。八万天人得须陀洹果。今于此间拘尸那城。转法轮时。八十万亿人得不退转。经经皆有此旨。亦应并是第二。何独般若耶。若言十二年后明无相者。何得二夜常说般若。故知。无相之过亦甚众多(云云)。次难褒贬教是第三时。虽七百阿僧祇。犹是无常不明常住。直是弹诃褒扬而已。今问说般若时。诸大弟子皆转教说法。虽不悕取。咸以具知菩萨法门。何得被诃茫然不识是何言。不知以何答。故知褒贬不应在般若之后。非第三时也。又弥勒等亦被屈折。何但声闻。若言七百阿僧祇者。此亦不然。其文自说佛身无为不堕诸数。金刚之体何疾何恼。为度众生现斯事耳。文辨金刚而人判七百。涅槃亦辨金刚那忽常住。又云。观身实相观佛亦然。又不思议解脱有三种。真性实慧方便即是三佛性义。且复尘劳之俦是如来种。岂非正因佛性。不断痴爱起诸明脱。明即了因性脱即缘因性。三义宛然。判是无常。涅槃三种佛性何得是常耶。次难第四时同归教。正是收束万善入于一乘。不明佛性神通延寿。前过恒沙后倍上数。亦不明常。此不应尔。法华明一种性相一地所生。其所说法皆悉到于一切智地。命章即云开示悟入佛之知见。华严明佛智慧。犹带菩萨智慧。菩萨智慧如爪上土。如来智慧如十方土。法华纯说佛之智慧。如十方土。而非常者华严爪上土。云何明常住。又华严始坐道场初成正觉。成佛太近。法华明成佛久远。中间今日皆是迹耳。迹中所说而言是常。本地之教岂不明常。又无量义经云。说华严海空历劫修行。未曾宣说如是甚深无量义经。甚深无量义经已自甚深。甚深之经为法华弄引。岂不明常。若言常住语少者。如天子一语可非敕耶。文云。世间相常住。又云。无量阿僧祇劫。寿命无量常住不灭。伽耶城寿命及数数示现等。是应佛寿命阿僧祇。寿命无量者是报佛寿命。常住不灭者。是法佛寿命也。三佛宛然常住义足。法华论云。示现三种菩提。一者应化佛菩提。随所应见而为示现。谓出释氏宫去伽耶城不远。坐道场得三菩提也。二报佛菩提。谓十地满足得常涅槃。文云。我实成佛已来无量无边。百千万亿那由他劫也。三法佛菩提。谓如来藏性净涅槃。常清净不变。文云。如来如实知见三界之相。不如三界见于三界。谓众生界即涅槃界。不离众生界即如来藏。又云。我不敢轻于汝等。汝等皆当作佛。即正因佛性。又云。为令众生开佛知见。即了因佛性。又云。佛种从缘起。即缘因佛性。法华论亦明三种佛性。论云。唯佛如来证大菩提。究竟满足一切智慧。故名大。言我不敢轻于汝等汝等皆当作佛者。示诸众生皆有佛性也。经论明据云何言无。又涅槃云。是经出世。如彼果实。多所利益安乐一切。能令众生见如来性。如法华中八千声闻得受记莂成大果实。如秋收冬藏更无所作。若八千声闻。于法华中不见佛性。涅槃不应悬指。明文信验何劳苟执。又涅槃二十五云。究竟毕竟者。一切众生所得一乘。一乘者名为佛性。以是义故我说一切众生悉有佛性。一切众生悉有一乘故。今经是一乘之教。与涅槃玄会。且涅槃犹带三乘得道。此经纯一无杂。涅槃更不发迹。此经显本义彰。处处唱生处处现灭。未来常住三世益物。人众见烧我土不毁。岂是神通延寿有灭尽耶。破神通延寿义(云云)。难第五时教。双林常住。众生佛性阐提作佛者。问成论师依二谛解义。第五时教为二谛摄不。若二谛摄与诸教同。前教二谛犹是无常。双林二谛何得是常。若双林不出二谛。能照别理破别惑得是常者。前教所明二谛。亦照别理破别惑。那忽无常。众生佛性阐提作佛。例如此难。故知明理不异前时。据何为常住耶。难顿教者例此可解。实既是同据何为顿。权虽别异不应从事判大小。则大颠倒(云云)。次难偏方不定教。谓非次第别为一缘。如金光胜鬘楞伽殃掘之流也。问殃掘之经六年所说。列次第众委悉余经。弹斥明常分明余教。释梵四王及十弟子。乃至文殊皆被诃斥。同闻宛然应入次第。而今判作偏方。净名亦是弹诃。那得引为次第。又净名所诃事在往昔。追述前语以辞不堪。当知。十二年前已应被诃。与殃掘同。若殃掘偏方则净名非次。若谓殃掘明常别为一缘者。净名云。尘劳之俦是如来种。何得是次第之说(云云)。次难其依涅槃五味判五时教。用从牛出乳。譬三藏十二年前有相教。从乳出酪。譬十二年后般若无相教。从酪出生苏。譬方等褒贬教。从生苏出熟苏。譬万善同归法华教。从熟苏出醍醐。譬涅槃常住教。此现见乖文义理颠倒相生。殊不次第。何者经云。从牛出乳。譬初从佛出十二部经。云何以十二部。对于九部有相教耶。一者有相教无十二部。二者有相教非佛初说。故不应以此为对(云云)。彼即救云。小乘亦有十二部。引文证云。雪山忍草牛若食者。即出醍醐。更有异草牛若食者。不出醍醐。故知大小通有十二部。但有佛性无佛性之异耳。今问纵令通有十二部者。何故不取明佛性之十二部为乳教耶。大经第七云。九部不明佛性。是人无罪。如言大海唯有七宝。无有八宝。是人无罪。例此而言。若十二部无佛性者。是人得罪。既言具十二部何意不明佛性。即堕得罪之句。岂会无罪十二部耶。若言从十二部出修多罗。修多罗对无相般若教者。修多罗则通一切有相无相。五时皆名修多罗。何以独对无相般若。解云般若中有直说义。复是第二时。故以对之。若言直说应是修多罗者。般若中有譬说因缘说授记说论义说。那得独是直说耶。般若兼具众说。以修多罗为名者。余经亦直说。何不对修多罗。若言第二时者。何经非第二时。已如前难。从修多罗出方等经。用对褒贬净名等教者。净名不应在大品之后。已如前破(云云)。从方等出般若。用对法华者。经文自云般若。而曲辨为法华。回经文就义。最为无意。涅槃云。八千声闻于法华受记。不道般若受记。那得唤法华为般若。乖文失旨不成次第也。从般若出大涅槃。彼即解云。从法华出大涅槃。此亦不会经文。譬如很子又似[仁-二+戾]羊(云云)。五时之失其过如是。其四时三时无劳更难。南方教相不可复依也。今更难用三时义家云。十二年后讫至法华。同名无相教者。法华会三般若亦应归一。若不尔者。云何同是无相。四时亦例尔。次难北地五时义。若言提谓说五戒十善者。彼经但明五戒。不明十善。唯是人教则非天教。纵以此为人天教者。诸经皆明戒善。亦应是人天教耶。又彼经云。五戒为诸佛之母。欲求佛道读是经欲求阿罗汉读是经。又云。欲得不死地。当佩长生之符。服不死之药。持长乐之印长生符者即三乘法是。长乐印者即泥洹道是。云何独言是人天教耶。又云。五戒天地之根众灵之源。天持之和阴阳。地持之万物生。万物之母万神之父。大道之元泥洹之本。又四事本五阴六衰本。四事即四大。四事本净五阴本净。六衰本净。如此等意。穷元极妙之说。云何独是人天教耶。又提谓长者。得不起法忍。三百人得信忍二百人得须陀洹。四天王得柔顺法忍。龙王得信根。阿须轮众皆发无上正真道意。观此得道岂是人天教耶。复次释论结集法藏。初从波罗奈至泥洹夕。凡所说小乘法。结为三法藏。从初生至双树。凡说大乘结为摩诃衍藏。奈苑之前不预小乘摄。何者尔时未有僧宝。故不应用提谓为初教也。若言提谓是秘密教。一音异解者。不应在显露之初。余四时同南家已如前破(云云)。次难流支半满义。从初鹿苑三藏皆明半义。从般若已去讫至涅槃。皆明满者此不应然。从得道夜常说般若。鹿苑已来何曾不满。如提谓时。无量天人得无生忍。成道六年已说殃掘摩罗。涅槃云。我初成道恒沙菩萨来问是义。如汝无异。当知鹿苑不应纯半。从般若已去诸经皆满者。释论云。般若非秘密教。以付阿难。法华是秘密教付诸菩萨。若同是满教。何得一秘一不秘。又若皆是满应同会三。又若同是满。生熟二苏应同是醍醐。醍醐应同是生熟苏。能譬之味既差别不同。所譬之法岂并是满(云云)。次难四宗者。谓因缘宗。指阿毗昙六因四缘。若尔成论亦明三因四缘。一切诸法皆为因缘所成。因缘语通。何独在毗昙。又因缘宗异假名宗。故成论云。见有四谛是调心法。不能得道。既立因缘宗得何等道。若得小乘道。则与假名宗同。何须别立。若得大乘道即与圆常等同。何须别立。今别以为宗。应别判一道(云云)。次难假名宗者。指成实论。观三假浮虚。乃是世谛事法。非彼论宗。彼论见空得道。应用空为宗。又释论。明三藏中空门。无假名门。若指彼义应用彼宗。既别立名则非见空得道(云云)。次难不真宗。此指大品十喻。为不真诳相者。龙树弹方广云。取佛十喻。说一切如幻如化无生无灭。失般若意。与外道同。云何拾他被弹之义。立不真经。若谓文明幻化。不辨佛性常住为不真者。此则不然。经明佛性常住。已如前说。何但此经明幻化耶。华严亦云。如化忍如梦忍。心如工幻师等种种譬喻。涅槃亦云。诸法如幻化。佛于中不着。絓是诸经皆明幻化。亦应是不真宗。若诸经幻化非不真宗。何独大品苦为诳相。又难常宗指于涅槃。涅槃之经何但明常。亦明非常非无常。能常能无常双用。具足八术。云何单取常用为宗。何不取无常用为宗。单轮只翼不能飞运(云云)。彼云。诳相不真宗即是通教。常宗秖是真宗。即是通宗者。宗则通真不真。不真何意没宗而用教。真宗何意无教而立宗。宗若无教何得知真。真宗若没宗有教。则同名通教。若俱没教留宗则同名通宗。若俱安教则同名通宗教。若留不真真。则名通不真宗教通真宗教。通不真宗可为三乘通修。通真宗亦应三乘通修也。若言此通是融通之通者。通教亦是通真之真也。此则两名混同义无别也。彼引楞伽经云。说通教童蒙。宗通教菩萨。故以真宗为通宗也。若尔是则因缘假名不真。皆是童蒙不应悉立宗也。覆却并决。四宗名义甚不便也。次难五宗者。难四宗如前。若言华严为法界宗。异大涅槃。涅槃非法界但名常宗。大经云。大般涅槃是诸佛法界。若为劣谢华严耶。若常非法界法界非常。法界非常应有生灭。常非法界摄法不尽。此皆不可然也。大品云。不见一法出法性外者。法性即是法界。又云。一切法趣色是趣不过。岂非法界之说。而独言华严是法界。异于涅槃大品耶。次难六宗者。四宗如前难。今问真常两宗。真常若同。何故开两真常。若异俱非妙法。何者真若非常真则生灭。常若非真常则虚伪。又真若非常。与前三宗何异。若常非真即有破坏法。次难圆宗。若言大集染净圆融。异于涅槃华严者。此亦不然。大品云。即色是空非色灭空。释论解云。色是生死空是涅槃。生死际涅槃际一而无二。此岂非染净俱融。又云。一切趣色欲。趣嗔趣痴诸见等。岂非俱融之相。净名云。一切尘劳是如来种。不断痴爱起诸明脱。行于非道通达佛道。此圆融何异大集(云云)。此六宗五宗。皆倚傍四宗而开。但四宗无文。或言出顶王经。经云。初说因缘诸法空。次教诸子一乘常住法。诸法空者。不应是假名宗也。一乘常住者。不应是通教诳相也。或言经不度也。四宗既尔。五宗六宗约四开立。皆难信用也。次难有相无相大乘教者。相无相不应单说。何者。本约真论俗还约俗论真。一切智人以无为法而有差别。华严虽论十地何曾不约法身。楞伽思益。虽复论空何曾不说无生忍。若纯用有相相则无体。教何所诠亦不得道。若纯用无相。无相真寂绝言离相。言语道断心行处灭。则非复是教云何可说。若言是教教即是相。何谓无相。大品须菩提问云。若诸法毕竟无所有。云何说有一地乃至十地。佛答云。以诸法毕竟无所有故。则有菩萨初地至十地。若诸法有决定性者。则无一地乃至十地。故知二种大乘别说乖经(云云)。次难一音教者。但言一大乘无三差别者。秖是实智不见权智。若但大乘者。法华何故云我若赞佛乘。众生没在苦破法不信故坠于三恶道。寻时思方便诸佛皆欢喜。故知非独一大乘教。若纯是一乘。亦应纯长者身。既有垢衣之体。亦有大小教异。那得混判一音失于方便。若言佛常说一乘。众生见三者。此则众生能化佛是所化。佛既是能化。应能说三乘。何得用一乘。若言法华纯一可尔。华严五天往反。亦为钝根菩萨开别方便。况余经耶。故知一音之教但有一大车。无有仆从方便侍卫。但有智慧波罗蜜。无方便波罗蜜(云云)

○四研详去取者。核实故言研。核权故言详。适法相故言去取。若五时明教。得五味方便之文。而失一道真实之意。虽得其文配对失旨。其文通用其对宜休。若言十二年前明有相教。此得小乘一门而失三门。何者。三藏有四门得道。或见有得道如阿毗昙。或见空得道如成实。或见亦有亦空得道。如昆勒。或见非空非有得道。如车匿。故知泥洹真法宝。众生各以种种门入。若欲举一标四。应总言三藏。若欲广明备立四种。何意偏存有相失没三耶。疑误后生空有成诤。若三藏中菩萨。须广学四门通诸方便。后得佛时名正遍知。若但标有相之教。唯得见有得道。一门声闻全失三门入泥洹路。则于小乘义阙。若但有相秖偏知一门。不解三门非正遍知。于菩萨义阙。其阙则众故须弃。其得则寡唯存一。若十二年后明无相。无相者此得共般若。失不共般若。共般若有四门。如幻如化即有门。幻化即无是空门。幻化有而不有。是亦空亦有门。双非幻化即非空非有门。若言般若无相者。秖得共般若一空门。全失三门。亦失七门。尚不是因中正遍知。况果上正遍知。其失则去其得则取(云云)。若言第三时。抑挫声闻褒扬菩萨。此得斥小一种声闻。全失七种声闻。得显大一意。全不得折挫诸偏菩萨。褒扬极圆菩萨。亦不得折挫诸权菩萨。褒扬于实菩萨。又不识偏圆权实四门。所得处少不得处多。若言第四时同归之教。唯得万善同归一乘之名。不得万善同归一乘之所。所者即佛性。同归常住等也。秖得会三归一。不得会五归一。不得会七归一。唯得归于一不得归佛性常住。有如此等失(云云)。第五时。若依二谛论常住。则非常住。若不依二谛无所间然。彼虽明常。全失非常非无常。双用常无常。唯得四术之一。永失七术。复不得其正体(云云)。四时教三时教无文可依。无实可据。进退无所可取(云云)。北地五时亦无文据。又失实意。其间去取类前可知。半满教得实意失方便意。四宗教失五味方便意。又失实意。五宗六宗例如此。二种大乘教权实乖离。父母乖离。导师云何得生。权若离实无实相印。是魔所说。实若离权不可说示。一音教得实失权。鳏夫寡妇不成生活。永无子孙。众家解教种种不同。皆是当世之师。各各自谓有于深致。时既流播义亦添。杂晚贤情执苟诤纷纭。所以上来研难。次论去取。略知大意(云云)。若除其病如上所说。若不除法。用之则异。云何用异。有相则具用四门。无相则用共不共。八门褒贬则用贬小褒大。贬偏褒圆。贬权褒实。同归则用同归一乘常住佛性。究竟圆趣。常住则用非常非无常。双用常无常。二鸟俱游。八术具足。用五味则次第如文在下当说。用提谓波利。亦不止是人天之乘。用半满则有五句。满开满立半。破半明满。带半明满。废半明满。用因缘假名。则为三藏两门耳。用诳相是通教一门耳。用真秖是常。常秖是真。法界不独在华严。圆宗不偏指大集。用有相无相者。约有相明无相。约无相明有相。二不相离。用一音者。有慧方便解。有方便慧解。设取其名用义永异(云云)

○五判教相者。即为六。一举大纲。二引三文证。三五味半满相成。四明合不合。五通别料简。六增数明教。一大纲三种。一顿二渐三不定。此三名同旧义异也(云云)。今释此三教各作二解。一约教门解。二约观门解。教门为信行人。又成闻义。观门为法行人。又成慧义。闻慧具足。如人有目。日光明照见种种色。具如释论偈(云云)。先约教者。若华严七处八会之说。譬如日出先照高山。净名中唯嗅薝卜。大品中说不共般若。法华云但说无上道。又始见我身闻我所说。即皆信受入如来慧。若遇众生尽教佛道。涅槃二十七云。雪山有草名为忍辱。牛若食者即得醍醐。又云。我初成佛。恒沙菩萨来问是义。如汝无异。诸大乘经。如此意义类例皆名顿教相也。非顿教部也。二渐教相者。如涅槃十三云。从佛出十二部经。从十二部经出修多罗。从修多罗出方等经。从方等经出般若。从般若出涅槃。如此等意即是渐教相也。又始自人天二乘菩萨佛道。亦是渐也。又中间次第入亦是渐(云云)。三不定教者。此无别法。但约顿渐其义自明。今依大经二十七云。置毒乳中乳即杀人。酪苏醍醐亦能杀人。此谓过去佛所。尝闻大乘实相之教。譬之以毒。今值释迦声教。其毒即发结惑人死。若如提谓波利。但闻五戒不起法忍。三百人得信忍。四天王得柔顺忍。皆服长乐之药。佩长生之符。住于戒中见诸佛母。即是乳中杀人也酪中杀人者。如智度论云。教有二种。一显露教。二秘密教。显露者。初转法轮。五比丘及八万诸天得法眼净。若秘密教。无量菩萨得无生法忍。此是毒至于酪。而能杀人也。生苏中杀人者。有诸菩萨。于方等大乘教得见佛性。住大涅槃。即其义也。熟苏杀人者。有诸菩萨。于摩诃般若教得见佛性。即其义也醍醐杀人者。如涅槃教中。钝根声闻开发慧眼。得见佛性。乃至钝根缘觉。菩萨七种方便皆入究竟涅槃。即其义也。是名不定教相也。非不定部。二约观门明义者。一圆顿观。从初发心即观实相。修四种三昧行八正道。即于道场开佛知见得无生忍。如牛食忍草即得醍醐。其意具在止观(云云)。二渐次观。从初发心为圆极故。修阿那波那十二门禅。即是根本之行。故云凡夫如杂血乳。次修六妙门十六特胜。观练熏修等。乃至道品四谛观等。即是声闻法。如清净乳行也。次修十二缘观即是缘觉如酪行也。次修四弘誓愿六波罗蜜。通藏菩萨所行事理之法。皆如生苏行也。次修别教菩萨所行之行。皆如熟苏。故云菩萨如熟苏也。次修自性禅入一切禅。乃至清净净禅。此诸法门。能见佛性住大涅槃。真应具足故名醍醐行也。若的就菩萨位辨五味义。如上行妙中辨。亦如次第禅门说也。是名渐次观也。不定观者。从过去佛深种善根。今修证十二门。豁然开悟得无生忍即是毒在乳中。即能杀人也。若坐证不净观九想十想背舍胜处。有作四圣谛观等。因此禅定豁然。心开意解。得无生忍。即是毒至酪中杀人也。若有人发四私誓愿。修于六度。体假入空无生四谛观。豁然悟解得无生忍。即是毒至生苏杀人也。若人修行六度。修从空出假。修无量四谛观。豁然心悟得无生忍。是毒至熟苏而杀人也。若有坐禅。修中道自性等禅正观。学无作四圣谛行法华般舟等四种三昧。豁然心悟得无生忍。即是醍醐行中杀人也。今辨信法两行明于佛法。各作三意。历前诸教。无有一科而不异诸法师也。若欲修禅学道历前诸观。为法行人。说安心法。无有一科与世间禅师同也。是名略点教观大意。大该佛法。二引三文证者。所谓方便品无量义经信解品也。方便品云。我始坐道场。观树亦经行。于三七日中。思惟如此事。我所得智慧。微妙最第一。众生诸根钝。云何而可度。我宁不说法。疾入于涅槃。寻念过去佛所行方便力。我今所得道。亦应说三乘我始坐道场。即是明顿。何者从兜率下。法身眷属。如阴云笼月共降母胎。胎若虚空常说妙法。乃至寂灭道场。始成正觉。为诸菩萨纯说大乘。如日初出前照高山。此明释迦最初顿说也。序品云。佛放眉间光。遍照东方万八千土。睹圣主师子演说经法。微妙第一教诸菩萨。次云。若人遭苦。为说涅槃尽诸苦际。即是现在佛先顿后渐。又文殊释疑引昔佛亦尔。文云。又见诸如来自然成佛道。世尊在大众敷演深法义。次即云。一一诸佛土声闻众无数。即是古佛先顿后渐。又下方涌出菩萨问讯佛。答云。如是如是众生易度。始见我身闻我所说。即皆信受入如来慧。除先修习学小乘者。如是之人。我今亦令得闻是经入于佛慧。即是释迦初顿后渐。如此等初顿。未必纯教法身菩萨。亦有凡夫大根性者。即有两义。当体圆顿得悟者。即是醍醐。初心之人。虽闻大教始入十信。最是初味。初能生后复是于乳。何者虽言是顿。或乘戒俱急。或戒缓乘急。如此业生。无由自致。必须应生引入七处八会。大机扣佛。譬忍辱草。圆应顿说譬出醍醐。又顿教最初始入内凡。仍呼为乳。呼为乳者。意不在淡。以初故本故。如牛新生血变为乳。纯净在身。犊子若[口*數]。牛即出乳。佛亦如是。始坐道场新成正觉。无明等血转变为明。八万法藏十二部经。具在法身。大机犊子先感得乳。乳为众味之初。譬顿在众教之首。故以华严为乳耳。三教分别即名顿教。亦即醍醐五味分别即名乳教。又约行者。大机禀顿即破无明。得无生忍行如醍醐。又虽禀此顿未能悟入。始初立行。故其行如乳。若望小根性人行。又如乳。何者大教拟小如聋如哑。非己智分。行在凡地全生如乳。以此义故顿教在初。亦名醍醐亦名为乳。其意可见也。次开渐者。佛本以大乘拟度众生。其不堪者寻思方便。趣波罗柰。于一乘道分别说三。即是开三藏教也。非但释迦隐其无量神德作斯渐化。过现诸佛亦复如是如前所引。当知初顿之后。次开于渐。故涅槃云。从佛出十二部经。从十二部出修多罗。正与此义相应。譬如从牛出乳从乳出酪。其譬不违渐机。于顿教未转全生如乳。三藏中转革凡成圣。喻变乳为酪。即是次第相生。为第二时教。不取浓淡优劣为喻也。方便品文齐于此

妙法莲华经玄义卷第十上妙法莲华经玄义卷第十下

        天台智者大师说

次引无量义为证者。文云。我以佛眼观一切法。不可宣说。所以者何。诸众生性欲不同。性欲不同种种说法。文辞是一而义别异。义异故众生解异。解异故得法得果得道亦异。初说四谛为求声闻人。而八亿诸天来下听法。发菩提心。中于处处说甚深十二因缘。为求支佛人。次说方等十二部经。摩诃般若。华严海空。宣说菩萨历劫修行。而百千比丘无量众生。发菩提心。或住声闻。万亿人天得须陀洹至阿罗汉。住辟支佛。佛眼观一切法。即是顿法在前。四谛十二缘即是次渐。若依此文说三藏竟。次说方等十二部经。所以次小说大者。佛本授大。众生不堪抽大出小令断结成圣。虽有此益。非佛本怀。次说方等维摩思益殃掘摩罗。弹诃小乘保果之僻。讥刺三藏断灭之非。故身子善吉。齐教专小初不曾闻大乘威德。或茫然弃钵。或怖畏却华。不知是何言。不知以何答。然方等弹斥教。在三藏之后。被诃之时。应在十二年前。何以得知。皆追述昔诃验是前事何者前已禀教得道。证于无学。荷佛恩深心相体信。不复恚怒。自昔至今恣殃掘之讥。任净名之折。得为耻小慕大之益。喻如烹酪作生苏。即此义也。按无量义。得知方等是三藏之后。为第三时教也。按无量义经云。次说摩诃般若华严海。空历劫修行者。此是方等之后。而明大品。大品或说无常无我。或说于空。或说不生不灭。皆历色心至一切种智。句句回转明修行法。即是历劫修行之意也。又云。百千比丘万亿人天。得须陀洹及阿罗汉。住辟支佛者。验是共般若也。而言华严海空者。若作寂灭道场之华严。此非次第。今依法性论云。钝根菩萨三处入法界。初则般若。次则法华后则涅槃。因般若入法界。即是华严海空。又华严时节长。昔小机未入如聋如哑。今闻般若即能得入。即其义焉。大品通三乘人可得有四果。华严隔小故无此义。故方等之后次说般若。为第四时教也。复言熟苏味者。命令转教领知众物。心渐通泰。自知萤火不及日光。敬伏之情倍更转熟。如从生苏转成熟苏也。又解。般若之后明华严海空者。即是圆顿法华教也。何者初成道时。纯说圆顿。为不解者大机未浓。以三藏方等般若。洮汰淳熟根利障除。堪闻圆顿。即说法华开佛知见。得入法界。与华严齐。法性论中入者是也。故下文云。始见我身入如来慧。今闻是经入于佛慧。初后佛慧圆顿义齐。故次般若之后说华严海空。齐法华也。亦第五时教也。复言醍醐者。是众味之后也。涅槃称为醍醐。此经名大王膳。故知二经俱是醍醐。又灯明佛说法华经竟。即于中夜唱入涅槃。彼佛一化。初说华严后说法华。迦叶佛时亦复如是。悉不明涅槃。皆以法华为后教后味。今佛熟前番人。以法华为醍醐。更熟后段人。重将般若洮汰方入涅槃。复以涅槃为后教后味。譬如田家。先种先熟先收。晚种后熟后收。法华八千声闻。无量损生菩萨。即是前熟果实。于法华中收更无所作。若五千自起人天被移。皆是后熟涅槃中收。为此义故。故云从摩诃般若出大涅槃。即后番次第也。按无量义云。摩诃般若次华严海空。即前番法华中次第也。问何意知钝者于法华不入。更用般若洮汰。答释论云。须菩提何故更问菩萨毕定不毕定。答云。须菩提于法华中。闻诸菩萨受记作佛。今于般若中。更问毕定不毕定。当知法华之后更明般若也。三引信解品。四大声闻领教证次第者。文云。其父先来求子不得。中止一城其家大富多有僮仆臣佐吏民。亦甚众多。时贫穷子。遇到父舍疾走而去。即遣傍人急追将还。穷子惊愕称怨大唤。无罪囚执此必定死。父语使言。不须此人勿强将来。此领何义领初成佛寂灭道场。法身大士四十一地眷属围绕。说圆顿教门。于时以大拟子机生闷绝。当知。佛日初出顿教先开。譬如从牛必先出乳。尔时长者将欲诱引其子。而以方便。密遣二人形色憔悴无威德者。汝可诣彼徐语穷子。雇汝除粪。即脱缨珞着垢腻衣。以方便故得近其子。此领何义。此领次顿之后。隐舍那威德相。好作老比丘像。说三藏之教。二十年中常令除粪得一日之价。即是从十二部后出修多罗。于时见思已断无漏心净。譬如从乳出酪也。又经过是已后。心相体信出入无难。然其所止故在本处。此领何义。明三藏之后次说方等已得道果心相体信。闻大名入住小名出。苦言弹诃名无难。又进宅内名入。入见群臣豪族大功德力。闻宝炬陀罗尼。见不思议解脱神变故名入也。出者止宿草庵。二乘境界名出也。心相体信者。得罗汉已闻骂不嗔。内心惭愧。不敢以声闻支佛法化人。心渐淳熟如从酪出生苏。是名从修多罗出方等经。即第三时教也。是时长者有疾。自知将死不久。语穷子言。我今多有金银珍宝仓库。盈溢其中。多少所应取与。穷子受敕领知众物。而无悕取一餐之意。然其所止故在本处。此领何义。从方等后次说般若。般若观慧即是家业。历于名色乃至种智即是众物。善吉等转教即是领知。但为菩萨说自不行证。故无怖取。即是从方等经出摩诃般若。因是得识大士法门。灭破无知。譬从生苏出熟苏。是为第四时教也。复经少时。父知子意渐已通泰。临欲终时。而命其子并会亲族。即自宣言。此实我子我实其父。今吾所有皆是子有。付以家业穷子欢喜。得未曾有。此领何义。即是般若之后次说法华。先以领知库藏诸物。后不须说但付业而已。譬前转教皆知法门。不须重演观法。直破草庵赐一大车。授作佛记。岂非明见佛性住大涅槃。故言从摩诃般若出大涅槃。是时无明破中道理显。其心皎洁如清醍醐。即是从于熟苏转出醍醐。为第五时教也。此五味教。调熟一段渐机众生。如身子等大德声闻。于法华中得受记莂。见如来性成大果实。如秋收冬藏。更无所作。不生不生名大涅槃。即是前番。从摩诃般若出妙法华。为未熟者更论般若入于涅槃而见佛性。即是后番。又从般若出大涅槃也。然二经教意起尽是同。如法华三周说法。断奠声闻咸归一实。后开近显远明菩萨事。涅槃亦尔。先胜三修断奠声闻入秘密藏。后三十六问明菩萨事也。又涅槃临灭更扶三藏。诫约将来。使末代钝根不于佛法起断灭见。广开常宗破此颠倒。令佛法久住。如此等事其意则别。第五醍醐佛性味同也。三约五味半满相成者。若直论五味犹同南师但得方便。若直半满犹同北师但得其实。今明五味不离半满。半满不离五味。五味有半满则有慧方便解。半满有五味有方便慧解。权实俱游如鸟二翼。虽复俱游行藏得所。若华严顿满大乘家业。但明一实不须方便。唯满不半。于渐成乳。三藏客作但是方便。唯半不满。于渐成酪。若方等弹诃则半满相对。以满斥半。于渐成生苏。若大品领教带半论满。半则通为三乘。满则独为菩萨。于渐成熟苏。若法华付财废半明满。若无半字方便调熟钝根。则亦无满字开佛知见于渐成醍醐。如来殷勤称叹方便者。半有成满之功。意在此也。四大声闻领解。无上宝聚不求自得。安住实智中者。皆由半满相成意在此也。四明合不合者。半满五味既通约诸经。诸经不同。今当辨其开合。若华严正隔小明大。于彼初分永无声闻。后分则有。虽复在坐如聋如哑。非其境界。尔时尚未有半。何所论合。次开三乘引接小机。令断见思。则以小隔大既不论满。何所可合。故无量义云。三法四果二道不一。不一即不合也。若方等教。或半满双明。或半满相对。或以满弹半禀半闻满。虽知耻小犹未入大。故云止宿草庵。下劣之心犹未能改。则半满不合。般若以满洮练于半。命领家业。明半方便通入无生。半字法门皆是摩诃衍。是合其法。而不悕取一餐之物。即是未合其人。是故半满不合。若至法华。觉悟化城云非真实。汝等所行是菩萨道。即是合法。汝实我子即是合人。人法俱合。自鹿苑开权。历诸经教来至法华。始得合实。故无量义云。四十余年未显真实。若于法华未合。于涅槃得合。法性论明中下二根入法界者。即是得合菩萨也。若论声闻。一秘密合。二显露合。秘密合者。初为提谓说五戒法。已有密悟无生忍者。况修多罗方等般若。岂无密悟。此则不论。若就显露。未入位声闻。亦随处得合。例如般若三百比丘得记者是也。若住果声闻决至法华。敦信令合。若住果不合。是增上慢未入位。五千简众起去。到涅槃中。方复得合。总就诸教通作四句。华严三藏非合非不合。方等般若一向不合法华一向合。涅槃亦合亦不合。何者。涅槃为末代更开诸权。引后代钝根。故言亦不合。问菩萨因法华入法界。与华严合。不见因华严入一乘与法华合。答华严入法界。即是入一乘(云云)。五料简者为三意。一约通别。二益不益。三约诸教通别者。夫五味半满论别。别有齐限。论通通于初后。若华严顿乳别但在初。通则至后。故无量义云。次说般若历劫修行华严海空。法华会入佛慧。即是通至二经。又像法决疑经云。今日坐中无央数众。各见不同。或见如来入涅槃。或见如来住世一劫。若减一劫若无量劫。或见如来丈六之身。或见小身或见大身。或见报身莲华藏世界海。为千百亿释迦牟尼佛说心地法门。或见法身同于虚空无有分别。无相无碍遍同法界。或见此处山林地土沙。或见七宝或见此处乃是三世诸佛所行之处。或见此处即是不可思议诸佛境界真实之法。夫日初出先照高山。日若垂没。亦应余辉峻岭。故莲华藏海通至涅槃之后。况前教耶。若修多罗半酪之教。别论在第二时。通论亦至于后。何者。迦留陀夷。于法华中面得授记后入聚落被害。作结戒缘起。又如身子法华请主。后入灭。均提持三衣至佛问(云云)。岂非三藏至后耶。释论云。从初鹿苑至涅槃夜。所说戒定慧。结为修妒路等藏。当知。三藏通至于后。若方等教半满相对。是生苏教。别论是第三时。通论亦至于后。何者。陀罗尼云。先于王舍城授诸声闻记。今复于舍卫国只陀林中。复授声闻记。昔于波罗柰授声闻记。身子云。世尊不虚所言真实。故能第二第三。授我等记。故知方等至法华后。般若带半论满。是熟苏教。别论在第四时。通论亦至初后。何者。从得道夜。至泥洹夜。常说般若。又释论云。须菩提问毕定不毕定。当知。般若亦至后。若涅槃醍醐满教。别论在第五时。通论亦至于初。何者。释论云。从初发心常观涅槃行道。前来诸教。岂无发心菩萨观涅槃耶。大经云。我坐道场菩提树下。初成正觉。尔时无量阿僧祇恒沙世界诸菩萨。亦曾问我是甚深义。然其所问句义功德。亦皆如是等无有异。如是问者。则能利益无量众生。此则通至于前。若法华显露边论。不见在前。秘密边论理无障碍。故身子云。我昔从佛闻如是法。见诸菩萨受记作佛。岂非证昔通记之文。问涅槃追说四。方等正开四。别教复有四。若为分别。答涅槃当四通入佛性。别教次第后见佛性。方等保证二不见性(云云)。二就益不益料简者。若华严为乳三藏为酪。此则方便味浓大乘味薄。释此为三。一取用益为论。如贵药非病治。贱药是病宜。贵药非宜。徒服无益。初说华严于初心未深益于渐机亦未转。于二缘如乳。若渐机禀三藏。能断见思三毒稍尽。即转凡成圣。如变乳为酪。不可以用益谓贱胜不用益谓贵劣。华严亦如是。于小如乳。于大如醍醐。少分譬喻不可全求也。二如良医有一秘方。具十二药三种最贵。善占病相盈缩所宜。终不乖候谬有所治。佛亦如是。圆方妙治具十二部。无问广记最为甚深。菩萨智利具足全服。二乘病重以九为剂。此若不缩于病无益。于不缩为乳。于缩为酪。此取相生次第为譬。不取浓淡浅深。三约行人心者。脱华严时。凡夫见思不转。故言如乳。说三藏时断见思惑。故言如酪。至方等时被挫耻伏。不言真极故如生苏。至般若时。领教识法如熟苏。至法华时破无明。开佛知见。受记作佛心已清净。故言如醍醐。行人心生教亦未转。行人心熟教亦随熟。问为一人禀五味。为五人耶。答自有一人禀一味。如华严中纯一根性。即得醍醐。不历五味也。大经云。雪山有草。牛若食者。即得醍醐。自有一人历五味。如小乘根性。于顿如乳三藏如酪。乃至醍醐方乃究竟。如大经云。从牛出乳。乃至苏出醍醐。自有利根菩萨。未入位声闻。或于三藏中见性。是历二味。自有方等中见性。是历三味。般若中见性。是历四味如三百比丘。大经云。置毒乳中。遍五味中悉能杀人。即此意也。三历诸教料简者。如大经云。凡夫如乳声闻如酪。菩萨如生熟苏。佛如醍醐。今释此譬。总喻半满五时。凡夫无治道全生如乳。声闻发真通皆如酪。通教菩萨及二乘如生苏。别教如熟苏。圆教如醍醐。今当教各判五味。大经云。凡夫如乳。须陀洹如酪。斯陀含如生苏。阿那含如熟苏。阿罗汉支佛佛如醍醐。有超果者即得醍醐。或有味味入者。此即三藏教中三意也。当通教中五味者。大经三十二云。凡夫佛性如杂血乳。血者即是无明行等。一切烦恼。乳者即善五阴。是故我说从诸烦恼及善五阴。得三菩提。如众生身。皆从精血而得成就。佛性亦尔。须陀洹斯陀含。断少烦恼如真乳。阿那含如酪。阿罗汉如生苏。支佛至十地菩萨如熟苏。佛如醍醐。超果不定(云云)。当别教自明五味者。第九云。众生如牛新生血乳未别。声闻缘觉如酪。菩萨之人如生熟苏。诸佛世尊犹如醍醐。具有超果不定(云云)。当圆教但一味。大经云。雪山有草。名曰忍辱。牛若食者即得醍醐。正直纯一。故不论五味。若无差别中作差别者。约名字即乃至究竟即。判五味相生也。从佛出十二部。即是出乳。新医用乳也。可约四善根就发中为五味也。六增数明教者。先约迹次约本。夫教本逗机机既不一。教迹众多何但半满五时。当知无量种教。今且增一至八。初约一法明开合者。十方佛土中唯有一乘法。于此法不解全生如乳。若欲开者开圆出别教一乘也。若于别不解亦全生如乳。又开通一乘也。若于通不解亦全生如乳。又开三藏一乘也。虽开为四。皆名一大乘法。俱求佛果也。若于三藏一乘得解即变乳成酪乃至入本一乘也(云云)。若于四一乘不解又更于三藏开出声闻支佛教。若断结证果心渐通泰者。即却二乘唯言大乘求佛。渐以般若洮汰令心调熟。即废方便一乘唯圆实一乘。故云。如我本誓愿。今者已满足。化一切众生。皆令入佛道。若以小乘化。我则堕悭贪。是事为不可。是故始从一而开一。终从一而归一。若约二法论开合者。约半满两教。初明华严之满。若众生无机次约满开半。次方等对半明满。次般若带半明满。次法华舍半明满始。则从满开半。终则废半归满(云云)。次约三法论开合者。即是于一佛乘方便说三。既知息已灭却化城。亦是约三善。声闻为下善(云云)。次约四法论开合者。即是四教约圆开别约别开通。次开三藏。如是次第会来合圆(云云)。又四法论开合者。约四门。本是圆四门众生不解开出别四门。乃至通三藏四门。利者得传传入。钝者五味调入。次约五法论开合者。即是五味。从初十二部开修多罗。乃至涅槃教教论五味。从初五味开诸五味。细细渐合还归圆满五味。次约六法论开合者。即是四教大乘六度。七觉分八正道也。初开圆出别乃至三藏。如是缩合还一圆道(云云)。次约七法论开合者。谓四教二乘并人天乘。若上向合圆别。不者下向合人天。令七数足开合(云云)。次约八法论开合者。约前八法开合(云云)。若得开合之意。自在说之。二约本门明教开合者。借迹知本本亦复如是。复次本门中明或示己身或示他身。或说己法或说他法。己身是佛法界像。他身是九法界像。己法是圆顿佛之知见。降此已下皆是他法。虽示种种形欲令度脱。故虽说种种道。其实为一乘。此即开合意也。如是开合半满五味。宛然无失。次第之意弥复分明。非次第意。自然可解。不定之教弥为易见矣。从一开一者。十方佛土中唯有一乘法。众生不解全生如乳。从此圆一乘开出别一乘。众生又不解。亦全生如乳。又开出体法一乘。众生又不解。亦全生如乳。又开出析法一乘。众生即解。是则转乳为酪。次入体法。即转酪为生苏。次入别一乘。即转生苏为熟苏。次转入圆一乘。如转熟苏为醍醐。是中备有顿渐不定(云云)。此是从一以开一。从一以归一也。次从二以开二者。元本是如来藏。如来藏中。备有半满不思议之二。众生不解全生如乳。又开出带半之满。又不解全生如乳。又开出破半之满。众生不解亦全生如乳。又单说半众生解转乳为酪。次说破半之满。转酪为生苏。次说带半之满。众生为一熟苏。次纯说不思议之满。众生如醍醐。此中具有顿渐不定。即从二开二。从二归二。从三归三。本是即空即假即中之三。众生不解即开次第之三。又不解。即开体真之三。又不解。即开析法之三。利人从析空之三。入体空之三。从体入次从次入即。钝者住析三。故用即空三调之。即生苏。又用次三调为熟苏。今方得入即空即假即中。此约三法论开合也。四法开合者。未是圆四门。众生不解。开别四门。乃至三藏四门。传传令入如前。约五法论开合者。约五味准前(云云)。乃至八亦如是

○记者私录异同。有人引释论会宗品。举十大经云经大云经法华经。般若最大。又大明品云。诸余善法入般若中。谓法华经亦是善法也第百卷云。法华是秘密般若非秘密。为不明二乘作佛故。又云。般若法华是异名耳。此三种云何通。有人会云。众圣以无心契无相。如众流纳海。若其化物以无相为宗。如空总包。般若盛明此二。故于十经最大。又般若明第一义悉檀。是故最大。又九十品。前六十品明实慧。无尽品去明方便二慧。是三世佛法身父母。是故最大善。众经明此二皆摄入般若中。问众经明此二。亦应般若摄入众经中。答大品最初专明此二。余经不尔。古来称般若是得道经。故知大也。今谓还是论语专大义。何谓会通。会通者。有共般若不共般若。不共般若最大。余经若明不共。其义正等(云云)。他会通法华明二乘作佛。是秘密。般若不明二乘作佛。故非秘密。秘密则深般若则浅。何者。般若明菩萨是佛因。于义易解故非秘密。二乘作佛与昔教反。于义难解。故是秘密。论云。如用药为药其事易。用毒为药其事难(云云)。然密显通大小。释论第四云。显示教明罗汉断惑清净。菩萨不断惑不清净。故菩萨在后列。若秘密法。明菩萨得六神通。断一切烦恼超二乘上。当知显示浅秘密深。今般若法华。皆明菩萨得无生忍。具六神通并秘密。并深并大。就秘密更论秘不秘。般若不明二乘作佛。阙此一条故言不秘耳。问般若未开权。应是秘密。法华开权应是显示。答若取开权如所问。今取浅易为显示耳。问若尔未了者。云何言大。答据二慧为深大。不明二乘作佛为未了。问既言深大。何不说二乘是方便令得作佛。此义未了亦何大乎。答非独自释。睿师亦云。般若照也。法华实也。论穷理尽性明万行。则实不如照。取大明真化。解本无三。则照不如实。是故叹深则般若之功重。美实则法华之用高也。问虽引睿师如攀枯求力。不觉人杌俱倒。释犹未了。今谓不共般若。何时不明二乘作佛。与法华平等大慧。更复何殊耶。众经论明教非一。若摩得勒伽有二藏。声闻藏菩萨藏。又诸经有三藏。二如上加杂藏。分十一部经是声闻藏。方广部是菩萨藏。合十二部是杂藏。又有四藏更开佛藏。菩萨处胎经八藏。谓胎化藏。中阴藏。摩诃衍方等藏。戒律藏。十住藏。杂藏。金刚藏。佛藏。彼诸藏云何会通。通二藏者。其一通声闻。其二通菩萨藏。通三藏者。初通声闻藏次通杂。其一通菩萨藏。通四藏者。一一相通。通八藏者。八藏降神已来。四教从转法轮已来。时节节有异。今以转法轮来八教通之。若胎化藏中阴藏。未为阿难说时。即是秘密教。为阿难说时即是不定教。摩诃衍方等藏即顿教。戒律藏去五藏。即渐教中之次第戒律藏。即三藏教。十住藏即方等教。杂藏即通教。金刚藏即别教。佛藏即圆教。然佛意难测。一往相望作此会通(云云)。问四教名义出何经。答长阿含行品。佛在圆弥城北尸舍婆村。说四大教者。从佛闻从和合众多比丘闻。从一比丘闻。是名四大教月灯三昧经第六。明四种修多罗。谓诸行诃责烦恼清净。私释会之。诸行是因缘生法。即三藏义也。诃责是体知过罪。即通教义也。烦恼者。不入巨海不得宝珠。若无烦恼则无智慧。即别教义也。清净者既举一净当名。任运有我常乐等。即圆教也。又一一教具四修多罗。诸行即集谛。诸行果即苦谛。诸行对治对治烦恼。即道谛。诸行清净即灭谛。此三藏中具四修多罗也。又诃责诸行即集谛。诃责诸有即苦谛。诃责烦恼对治即道谛。诃责清净即灭谛。此通教中具四修多罗。又烦恼诸行是集谛。烦恼诸有是苦谛。烦恼行被诃责即道谛。烦恼清净即灭谛。此别教中具四修多罗。又涅槃即生死苦谛清净也。菩提即烦恼集谛清净也。烦恼即菩提。道谛清净也。生死即涅槃。灭谛清净也。此圆教中四修多罗。彼经复明四论四法四境界四门四断烦恼智四苦四集四道。皆与四教相应。具如彼应知。地论第七地云。一念心具十波罗蜜四摄三十七品四家。释四家云。般若家谛家舍烦恼家苦清净家。私释者。约苦谛为初门。修道品令苦清净者。即三藏义也。舍烦恼家者。即无相体达为舍。如色是空。以空舍无相论修道品者。此即通教义也。般若家者。般若智照诸法。明了恒沙法门。皆悉通达而修道品。此即别教义也。谛家者。谛即实相之理。即是圆教。约实相而修道品也。具如彼说(云云)。达摩郁多罗。释教迹义云。教者谓佛被下之言。迹谓踪迹。亦应迹化迹。言圣人布教各有归从。然诸家判教非一。一云释迦一代不出顿渐。渐有七阶五时世共同传。无不言是。又云。五时之言那可得定。但双林已前是有余不了。涅槃之唱以之为了。又言佛一音报万众生。大小并受。何可以顿渐往定判无顿渐今验之经论。皆是穿凿耳。何者。人云佛教不出顿渐。而实顿渐摄教不尽。如四阿含经五部戒律。教未穷深未得名顿。说亘始终复不与大次第为渐。是则顿渐不摄。何得云佛教不出顿渐也。然不无顿不得全破。何者凡论顿渐。盖随所为。若就如来实大小并陈。时无前后。但所为之人悟解不同。自有顿受或从渐入。随所闻结集何得言无顿也。但不可定其时节比其浅深耳。人言渐教中有七阶五时。言佛初成道。为提谓波利说五戒十善人天教门。然佛随众生宜闻便说。何得唯局初时为二人说五戒也。又五戒经中。二长者得不起法忍。三百人得信忍。二百人得须陀洹果。普曜经中。佛为二长者授记。号密成如来。若尔言初为二人说人天教门义。何依据。又二长者见佛闻法礼佛而去。竟不向鹿苑。初说五戒时未化陈如。与谁接次而名为渐。人言第二时十二年中。说三乘别教。若尔过十二年。有宜闻四谛因缘六度。岂可不说。若说是则三乘别教。不止在十二年中。若不说。是一段在后宜闻者。佛岂可不化也。定无此理。经言为声闻说四谛。乃至说六度。不止十二年。盖一代中随宜闻者。即说耳。如四阿含经五部律。是为声闻说。乃讫于圣灭即是其事。故增一经。说释迦十二年中略说戒。后瑕玼起乃广制。长阿含游行经说。乃至涅槃。何得言小乘悉十二年中也。人言第三时。三十年中说空宗般若维摩思益。依何经文知三十年也。言四十年后。说法华一乘。法华经中弥勒言。佛成道来始过四十余年。然不可言法华定在大品经后。何故。大智论云。须菩提于法华中。闻说举手低头皆得作佛。是以今问退义。若尔大品与法华前后何定也。然大品法华及涅槃。三教浅深难可辄言。何者。涅槃佛性亦名般若。亦名一乘。一乘是法华之宗。般若是大品所说。即是明性。复有何未了乎。大品中说第一义空。与涅槃经明空无异。皆云色空乃至大涅槃亦空。又大品说涅槃非化。维摩说佛身离五非常。与涅槃明常说涅槃不空。有何异而自生分别。言维摩偏詺明常。大品一向说空也。人以阿难等诸声闻。在大品会。复经法华会。终至涅槃会。故知大品法华涅槃。应有浅深。义不必尔。何者。如阿难迦叶经法华会。若未闻说常。涅槃会中二人不在。何由得有常解流通涅槃。复次舍利弗在佛涅槃前七日灭度。大目连为执杖外道所打。亦在佛前涅槃。皆不在双林之会。岂可不得常解乎。即知法华中已悟常。竟不假更闻。又舍利弗等诸声闻。皆是如来影响。如法华经说。知众乐小法而畏于大智。是故诸菩萨作声闻缘觉。涅槃亦云。我法最长子。是名大迦叶。阿难多闻士。能断一切疑。自然能解了是常与无常。故知影响之人在大则大。在小则小。何可就其人以定阶渐也。又若从法华后入涅槃者。法华经中已明王宫非始久来成道。何由涅槃中。方引道树始成执实为疑。故知为一段众生。最后闻常者涅槃经。闻法华者。不假闻涅槃也。又涅槃经有大利益。如法华中八千声闻。得受记莂成大果实。若以法华得记。证涅槃之益。即是理同教无深浅明矣。又法华优波提舍中。明法华经理圆教。极无所缺少。龙树于大智论中。叹法华最为甚深。何故余经皆付阿难。唯法华但付菩萨。是知法华究竟满足。弗须致疑。复应当知诸大乘经指归不殊。但随宜为异耳。如华严无量义法华。皆三昧名。般若是大智慧。维摩说不思议解脱。是解脱。大涅槃是究竟灭。文殊问菩提是满足道。悉是佛法法无优劣。于中明果皆是佛果。明因皆是地行。明理皆是法性。所为皆是菩萨。指归不当有异人。何为强作优劣。若尔诞公云。双树已前指法华经悉不了。岂非诬誷也。人情既尔经论云何摩得勒伽说十二部经。唯方广部是菩萨藏。十一部是声闻藏。又佛为声闻菩萨。说出苦道。诸集经者以为菩萨所说为菩萨藏。以为声闻所说为声闻藏。龙树于大智论中。亦云。大迦叶与阿难。在香山撰集三藏。为声闻藏。文殊与阿难集摩诃衍经。为菩萨藏。涅槃亦云。十一部经为二乘所持。方等部为菩萨所持。是以依按经论略唯二种。声闻藏及菩萨藏也。然教必对人人别各二。声闻藏中有决定声闻。及退菩提心声闻。菩萨藏中有顿悟大士。有渐入菩萨。声闻藏中决定声闻者。久习别异善根。小心狭劣成就小性。一向乐小佛为说小。毕竟作证不能趣大。言退菩提心声闻者。是人尝于先佛及诸菩萨所。发菩提心。但经生历死忘失本念。遂生小心志愿于小。佛为说小终令趣大。然决定声闻一向住小。退菩提心声闻后能趣大。虽有去有住而受小时一。故对此二人所说。为声闻藏。菩萨藏中有能顿悟者。如华严等经所为众生。不由小来一往入大。故名为顿。从渐入者。即向退菩提心声闻后能入大。大从小来故称为渐。虽有顿渐不同。然受大处一。故对此二人所说。为菩萨藏也。然此二藏随所为随所说。声闻藏中有菩萨为影响。然非所为。不可从菩萨名作大乘经。菩萨藏中亦有声闻人。非正所为宗。不说声闻法。故不可名为小乘法。拟人定法各目不同。是以要而摄之略唯二也。问佛为三乘人说三种教。何以故。判藏唯有其二。答佛为求三乘人。说三乘法。然闻因缘者即是声闻。辟支佛出无佛世。但现神通默无所说。故结集经者。集为二藏也。依经判教厥致云尔。今之四教与达摩二藏。会通云何。彼自云要而摄之。略唯二种。今开分之判为四教耳。声闻藏即三藏教也。菩萨藏即通别圆教也。为决定声闻说三藏教。为退大声闻说通教。为渐悟菩萨说别教。为顿悟菩萨说圆教。非唯名数易融。而义意玄合。今古符契一无二焉。唯文略而义广。教一而蔽诸。若申隐以使显。须多作论义。如捕猎川泽饶结筌罤。岂渔猎者好博耶。不得已而博耳。师云。我以五章略谭玄义。非能申文外之妙。特是粗述所怀。常恨言不能畅意。况复记能尽言。虽然。若能寻七义。次通十妙。研别体七余五。钩琐相承。宛宛如绣。引经印定。句句环合。非直包诸名教。该乎半满而已矣。又即事成观。凿凡夫之干土。见圣法之水泥。圆通之道。于斯通矣。遍朗之朗于兹明矣。此备于前。今更消文于后也

妙法莲华经玄义卷第十下


法华文句记

    No. 1719 [cf. Nos. 262, 1718]

法华文句记卷第一(上)

        唐天台沙门湛然述

    释序品初

言文句者。文谓文字一部始终。故云。文即是字为二所依。句谓句读义通长短。故云。名诠自性句诠差别。此亦不论色行等体今但以句而分其文。故云文句。古之章疏。或单题疏。或单题章。章谓章藻。诗云。彼都人士出言成章。亦云章段。分段解释成若干章。疏者。通意之辞。亦记也。又疏音即疏通疏条疏镂也。今并不云者意如向说。题下注中六难意者。此用下文法说叹法希有中。诸佛兴出世悬远值遇难。正使出于世说是法复难。无量无数劫闻是法亦难。能听是法者斯人亦复难。章安于经闻法能听二难之中。义开为四。谓传译等合成六难。然闻法中正在时会及以阿难。义通像末。故藉传译则可得闻。佛出已难出仍不值。故经多劫闻者尚难。况修行开悟说记流通。于中初二约主约味。三四叹教叹行。五六自幸省己。故初二在佛三四属师。五六斥己。故三双中一一皆悉先通次别。且初二中出世犹通。通一代故。次说则别。别在今经。次三四中初传译师通一切教。次教诏师别我所承。次五六中闻讲仍通与他共故。一遍记别唯属己故。故三双中从宽向狭。是故后后狭于前前。故自佛出来。乃至闻于自悟者说一遍记故。故记佛乘最为甚难。言主味者。主兴不易。复经四味方演此经。故知初二诚为不易。言叹教者。传译不易经涉山海。虽至此土民主道合。国无诸难方可传故。言叹行者。禀承南岳证不由他。宿植所资妙悟斯发。言自省者。自幸得闻谦已辄记。故玄序云。江陵禀受玄旨。建业方听经文。补接才成一遍而已。况二十七听六十九治。始末四十余年乃成第七修补复难于传译前加结集难。合为八难。以结集时亦假王臣大众和合。若魔若外令不得便。添谓添破古师及引经论。谓斥非以显是。削谓削其繁长及成文体。使文约而义丰。破古不全我已。加彼异见故但云添。削乃唯在于已。初记繁芿故须云削。故玄序云。或以经论诚言符此深妙。或标诸师异解。验彼非圆。留赠后贤者。玄文序云。斯文若坠将来可悲。涅槃云若树若石。斯经称若田若里。后代行者知甘露门之在兹共期佛慧者。自非灵岳亲承道场契悟。搜一代教旨显五味宗极。将何以为后贤佛慧之基址耶。故佛慧之言。须开三教果头之权实。发四味兼带之大小。则人理教行之有归。开示悟入之无异。方是今经之佛慧耳

问。诸经中圆与此何别。而必须云开方是佛慧

答。圆实不异但未开显初心之人谓圆隔偏。须闻开显诸法实相。若已入实但论增进。权人至此一向须开。委释等者。别解题名方七八卷。以初名中总三法故。三法始末亘一部故。何者。一部之中莫过本迹。本地总别超过诸说。迹中三一功高一期。故一中之三永殊前教。即三之一不与他同。即迹而本寿量方谭即本之迹具在今说。且如迹中体非因果。依之以辨因果因果取体方有胜用。如是三法并由开显。若不先了能开之妙。将何以明所开之粗。故对迹辨本理须分判。所以释题不可率尔。题下别释理非容易。以由释题大义委悉。故至经文但粗分章段。题名文句良由于此。故但分文句。则大理不彰。唯谭玄旨则迷于起尽。若相带以说则彼此无归。故使消释。凡至大义并指玄文。名体宗用三。一总别寄行约教。故知全迷玄文大旨。而欲以文句消经。固蔽理观深微。而但以事相释义。言弘斯典者远矣。今问弘经者为名利壅己。为大悲益他。自行暗于妙宗。何殊无目而导。彼此俱迷自他咸没。又妙法之唱非唯正宗。二十八品俱名妙故。故品品之内咸具体等。句句之下通结妙名。教行人理彼此相摄。使妙旨不失稍似弘通。衣座室诫思之自克。然遍列事难不可恒尔。今随义便广略适时。故方便安乐寿量普门。并是本迹之根源斯经之枢楗。必须委简余则随宜。序者下。一部大名已指前释。一品别号此下略申。睿公亦有二十八品生起次第。今家随释准意可知。然品品初通有四意。谓释名来意释妨释文。释名必须因缘等四。来意释妨。或有或无。或释名中即带来意。有妨须释何例然耶。又释名与义更互有无。故释名一种。或于义前别释。或带名以释义。纵于义前别释。还将别以贯义。名义若显则一品可从。故使品品全同部旨。如是释者。方镜于迷途徒自云云。此彼淆混。若得此意至下易知。今初释名云训庠序等者。先释字训。次释字义。然释训中复似从义。庠谓安庠。学舍养宫并非今意。尔雅云。东西墙谓之序。别内外也。此可借用以释别序。如由别序。方异诸经。通序异外亦可兼用。所以初用字训正从别序。故云阶位等也。兼用安庠。即非忽卒越次意也。亦二序共有。若对辨者必先证信后发起故。必先发起后证信故。必先二序后方正故。二序各有前后亦尔。故光宅生起非全失理。但阙表报是故斥之。故阶位之言义兼通别。问答之语不关于通。先瑞后问次第故尔。弥勒文殊即宾主也。若问若答皆庠序故。伏疑伏难宾主存焉。经家下从字义释。三义分二。次通二别。二序之中通复冠别。二序俱首通最得名以冠于下。冠即是首。故云冠首。是则二十七品方名为经。以序从正通名经也。故云妙法莲华经序品。言由述者。瑞疑由也。问答述也。文中不以疑念对由述者。亦可两兼。谓发语宣疑亦可云述。集众亦可以为远由。疏故且置。言哢引者。以譬显也。讲哢家之引故名哢引。亦可正哢亦得名引。如歌引舞序义可知。故正说如哢二序如引。故引亦歌也。谓谭述也。亦引发义。古人章疏以胤音之便。作胤释。又迷章草以哢为呼。以胤为彻。鱼鲁之谬自古有之。彻字则成两重之误。具此三义者。品兼通别故须具三。品者。序名在别。品义则通下去诸品以通从别。不复更释。故但释别以置于通。此中先翻名次释义。后明立品所以。所言义者释品字义。非品题义。故字义则通题名从别。言义类同者。诸品咸然。聚者是谁故出其人。初泛指他经。如心地品佛自唱也。如大论者。即论所述大品一部。结集之家本唯三品。一序。二魔事。三嘱累。言译人者。亦指大品本唯三品。什公伪秦弘始五年四月二十三日译讫。乃依四意以类加之。成九十品。谓人义法事。人如楼那义如观空法。如三假事如魔事。亦如大经纯陀哀叹等。又非译者但补助译人。即谢公加也。准知诸经非佛自唱及以集者并译人添也。次正出今经。如药王品云。佛告宿王华。若有人闻是药王菩萨本事品。能随喜赞善者等。又云。宿王华以此药王菩萨本事品。嘱累于汝。乃至云若有女人持是品者。尽是女身后不复受。妙音品末集经家云。说是妙音来往品时。四万二千天子得无生法忍。普门品末经家亦云。佛说是普门品时。八万四千众生。皆发无等等阿耨菩提。乃至陀罗尼严王劝发品末皆然。故云等。译人未闻者今经所无。若无集家之言。及无佛自唱语似属译人。以文中诸品先足。当知并是集者所置。信无译人明矣。故今经自余诸品。多是结集者所置。以无闻品益故。故品后无结耳。以通从别应具四释。以通序中句句皆存因缘等四。别序时或阙于一两。故释序字阙于四义。若二序相对义立亦可。二序不同世界也。别序发起欣慕即为人也。通序证信除疑对治也。二序序正第一义也。约教等三具如释三段中是也。若别约通序者。五义不同世界也。通皆除疑对治也。通皆生信为人也。通皆序正第一义也。余三及别序准此可知。佛赴缘下欲分节经文。先辨分文有无得失。于中四。先泛引诸经论。次古讲者之失。三明品非章段。四泛示分节。初文者全非分文。次古失者。古来讲者多无分节。至安公来经无大小。始分三段。谓序正流通。殆者危也。非今正意亦几也(几巨依切近也)西京赋云。人生几亡。言起尽者章之始末也。若分节已大小各有总别起尽。三又佛说下意明立品。但从义类不从文相。故贯散二相不可立品。亦非分节。四增一下经论亦有分节之例。况末代弘经须识宾主。故小乘三藏各有所开。增一序云。阿难说经无量数。今且总略为一聚。我今分之为三分。契经一分。律二分。阿毗昙经为三分。契经今当为四段。初名增一二名中。三名曰长多璎珞。杂经在后为四分。乃以四含名为四段。故今承此借为分节。律开五部者。佛灭度后一百年间鞠多持法。所化众生不相是非。但为一部不毗尼藏。即八十诵。一百年后鞠多有五弟子。各执一见不能均融齐一。遂分一藏以为五异。如析金杖不失金用。今分文亦尔。虽分为多段知大旨本一。以所分对本故云及也。阿毗昙开六足者。文中自引阿含六度。非六足论。如增一云。菩萨发起大乘法。如来说此种种法。人尊说六度无极。布施持戒忍精进禅智慧力如月初。逮度无极睹诸法。佛说种种不出此六。亦似分章意也。若六足论全非今意。如云。一集异门足一万八千偈舍利弗造。二法蕴足有六千偈。大目连造(此二论唐三藏译)三施设足一万八千偈。迦多演尼子造。唐三藏将来未译。此三论佛在世造。四识身足有七千偈。提婆设摩造。即佛灭后百年。五品类足佛灭后三百年。世友造。六界身足有六千偈。三百年末亦世友造。迦多演尼子造发智论。以前六义少如足发智义多如身。则足前而身后分义不便。况此六论并唐三藏将来。隋时未有不合指之。况无分节之相。中破云。前之三论既在佛世。如何却与佛灭后论为足。未必全然以身摄足耳。又成论云如六足阿毗昙说者。指六足阿毗昙论。故不对发智为身。谓根性等者略列揵度。揵度西音此云法聚。以分一部为八聚故。谓业使智定根大见杂。文云根性道定者。根性是根。道即是智。但略举三余如向列。大论问。八揵度谁造。六分阿毗昙从何处出。答佛在无失。灭后百年阿输柯王会诸论师。因生别部有利根者尽读三藏。欲解佛经作八揵度。后诸弟子为后代人。不能全解作略阿毗昙。其初造者即迦旃延。天亲下次引今论有七功德五示现等。以例分章。七功德者。论云。此法门初第一品明七种功德成就。一者序成就。二者众成就。三者从为诸菩萨说大乘经去。欲说时至成就。若说无量义经。即欲说法华时至也。四从说是经去。名所说法随顺威仪住成就。以入定故名威仪住。五从放光去。名依止说因成就。由放光故见他土说。六从弥勒疑念去。名大众欲闻法现前成就。由问故答。故云欲闻。七从文殊答问去。名答问成就。论云。于序成就。又有二种。一者一切法门中胜谓如是等。验知论主全许一部。为法门中胜。方指如是等为一切法门中胜。一切法门即一代教。不然如何消释一切之言。既一代教中最为其上。具如药王品中叹教文也。下六成就各有分节。五示现者。论亦云五分。一叹法胜妙分。二从吾从成佛去。叹法师功德分。三从尔时众中去。智众定疑分。四从佛告舍利弗去。定记分。五从舍利弗诸佛出五浊去。断疑分。河西下正明分节。河西如本传。江等瑶即吴兴小山寺(具如别传)光宅转细者。如东安法师(唐东阳永安寺旷法师)讲三论及法华等诸经。并着章疏。贞观十三年正月十五日入灭。反屈三指即第三果人也。着法华疏四卷。初云。自梁陈已来解释法华。唯以光宅独擅其美。后诸学者一概雷同。云师虽往文藉仍存。吾钻仰积年。唯见文句纷繁章段重叠。寻其文义未详旨趣。今对云义以研法实。大师专破良有以也。故知云公望前转繁。今家处中无彼二失。但存大旨不事繁碎。重雰下章安斥古。雰者。猛雪重雾也。能翳太虚之清气。使三光隐而失曜。故碎乱分文失经之大道。三轨隐而靡用。津者。济渡处也。若细分碎段非求经旨者所宜。如在歧道有问路者。不答问者所之。而广谭逵经故非问者之要。昙鸾北齐人。斥云。细科经文如烟云等为疾风所扬。扬者。风飞也。隐翳太虚。杂砺等者。准彼应作条例字。谓科条如尘。或是转其言借势用语。非全同彼故。砂石精者曰砥(音止)粗者曰砺。杂尘随扬同其烟翳。言若过等者。以此望古进退俱失。是则昙鸾亦未全许碎擘经文。庐山龙两解。前云身方便等者。意云。自宝塔已前说权说实。亦以法华前权为言方便。至法华为言真实也。从宝塔下古佛现全身。今佛集分身。古身命今身。今身诣古身。二身俱处塔表法今古同身方便也。寿量久成尘点尚倍。中间被拂伽耶非真。身真实也。道理必然。偏立成失。前可无身后岂无说。但依权实本迹。任运俱收身说。若但语身说则本迹事昏。但谭本迹乃身说自显。故寿量中云。或说己身。或说他身。故身说具足。方便已下说必有身。何须致惑。第二释中玄文广破。以今二门各有因果故也。齐中兴印者。中兴寺名(具如别传)玄畅以迹门流通中达多持品。及将本门寿量后流通中神力等。共为果分。果在本门又分护持。护持即是流通异名故不可也。又有师去。此师意以正宗为体。但在迹正。不知却以本门之正反为流通。而云受持功德。迹与昔教容可有同。本与前经一向永异。翻将永异混乱流通。故不可用。有师四段。但合二三为正。甚符经文。但阙立本迹二门。各有三段意耳。其名既阙义恐不周。光宅二十四段者。具在彼疏云云者。象气之分散。如云在天非可卒量也。意言下未说者尚多如云。下去皆尔。已下有列光宅分文者。多分与今大同小异。兰菊者。章安破计也。佛赴机说当时称会。后代分节寄兹显理。固执成诤进退俱非。纵有异同彼彼兰菊。仍许得意者为言。纵不全违圣心终是人之情见。若粗得通用不须苦诤。恐失四益。易云。其臭如兰者。古人一向以气为臭。天台者。章安对古故别云也。天台之名具如止观记。今记等者。虽复两存。且用初意。故云从前。问一经云何等者。问意既存两释。问后何妨。所以二释之中不专后释者。以本正前立流通故。且一往耳。答中云华严处处集众等者。处会具如释签所引。每一会处皆先序次正。以住处庄严义当于序。言集众者。如妙严品名号品光明觉品及一一会。皆先集众。意明一经具多别序。阿含篇篇如是者。此明一经多通序也。彼四阿含各合多小经。以为一部。每一小经不出一纸半纸。唯长阿含游行经文独有两卷。又有大本经自为一卷。一一经首皆安五义。既以阿含而为通号。故以部内小经为篇。大品前后付嘱者。明一经内有多流通。故第二卷中有累教品。为前付嘱。第二十七有嘱累品。为后付嘱。准彼三经二序何妨。言不安五义者。释伏难。难云。若尔何不同彼阿含。今本门亦安如是等耶。释意者。虽申今经本门非首。然须更释阿含之妨。阿含多通序本门亦应然。然阿含兼别经是故非次首。亦得安五事。今经同一经故但别无通。是故但以华严为例。故阿含缘起各别。今经缘起不殊。是故本门不安五义。迹门但单流通者。以迹望本以本例迹。本门非首但安别序。迹门非后但单流通。故但有劝持无嘱累也。故从法师至安乐行。凡有五品。明弘经福深以劝流通。若本门中先以灭后五品去三品半。为劝持流通。从神力去凡有八品。明嘱累流通。迹门之后经既未竟。非流通次未须付嘱。言云尔者。如后消文。言帖释者。但今通途消经尚异诸见。况法华部又异诸经。故一一句四意消释。仍恐后来不达四意。预为四重消释四意。言得意者。至消文时或四释不备。但存一二余者比知。次释四意所以中。初问意者。若略但一广应无量。既非广略二途不成。匪者非也。何故唯作此四释耶。答中一文具有二意。一者总明四义所以。二明四中一一所以。两义咸得以为处中。一者唯四不多不少。次因缘下明一一不失不差故。一虽处中仍须至四。四摄义足故不须过。假使过此摄在四义。故四及一并名处中。如十妙等。一一妙中亦具四意。十亦入四犹名处中。今秖须此四。故得名中。故初意云广则等也。若无初意尚不殊外计。况因缘语通通于一化。始自地狱终乎佛界。中间顿渐若教若味。故须知今大事四悉非余感应。开显四悉一道无外。久远四悉诸经所无。观心四悉一观遍收。人理等四准说可见。以此四悉通于始末。约教等三亦须遍述。意则可知。若无次意不辨偏小。故以四八简开废等。望昔部教今方真实。一切能诠无复异称。故须明之以彰妙典。无第三意谁知迥出。一期教中所谭身土。中间今日无非迹施。指彼大通犹如信宿。先愚密教复迷迹身。至此方袪守株尚昧。无第四意将何以辨能诠教功。将何以为久成行本。故一一句入心成观。故云。观与经合非数他宝。方知止观一部是法华三昧之筌罤。若得此意方会经旨。总斯四义方可略显一部旨归。故云略则意不周。当知二三尚略一何能逮。处中至四令义易了。故一一句得斯四义。则使句句咸异诸教。则法华之义诚为不难。故云易了。次因缘下明一一别释。于中初是因缘。次若十方下是约教。次若应机下是本迹。次若寻下是观心。初因缘者。初文正释。始从如是终至而去。无非真实感应道交。故知今经感应妙也。法华已前小及钝根一向无机。理是而迷故名虽近。机生未契故云不见。慈亘始末名善根力。事理不同故名为远。无谋而会故云自通。故尔前感应妙道未交。诸部异同教主优劣。被物渐顿施设不同。一一无非感应意也。虽通名感应显益未周。虽通名四悉浅深差别。若兼若独盈缩不驯。来至法华方成一味。言无机者。反以昔无而释今有。慈善根下正明今感故有今应举远而通明时不差。无缘慈遍何择远近。但无机谓远有感必通。诸佛不来众生不往。机应相称故曰道交。慈善根力者相通事别。其事略如止观第六记引大经十四梵行品。诸佛神变皆慈为本。故一切法皆由慈立。故经云。若有人问谁是一切法之根本。当言慈是。故以感应摄一切法。次夫众生下。疑问意者。既云四义乃曰处中。秖因缘一义尚机众。应众其义更广何名处中。义似过四故云更也。所言众者。即五乘九界等也。次大经下答意者。四尚处中一广何爽。故事广义中亦名处中。故引大经。门虽无量神通摄尽。神通即是应之异名。对感即名感应故也。然神通之名义兼大小。感应之称唯局在大。大中通于地住已上。今此正当极果用也。故神通之称一名摄诸。尚得名略。义非广略岂不处中。能应既然所应准此。故设应虽众不过于慈。求脱虽多讵出于感。故感应二字处中明矣。次若十方下约教中先举广出妨。次今论下释出处中。初出妨者。感应二名虽即处中。通论化事。十方六尘教法弥广。是则约教处中不成。次释者。今论娑婆唯禀声教。虽有显密若开若废。望彼诸土亦名处中。是则令前声教感应处中更明。则甘露门开者。则言乃表唯声益。故实相为甘露。诸教为其门。门无开闭理非通塞。此土入者不假余尘。由之通理故曰门开。言依教者。应云声教。但是言略。虽有灭后色经。乃至名句行蕴所摄。净名香饭及以法行思惟悟等。并以金口声教为本。不少不多故云明矣。约本迹者。亦先举广辨妨。次从须置指下。释出处中。次故肇下引肇证成。初文者。应机举前因缘。设教举前约教。机多教异其迹必广。当知本迹不名处中。若准门开之言。则唯圆处中已如前说。今将本望迹中间今日。声教感应开已复施。废竟还设故云权实。一代尚广况实成后。中间施化对机差别。言浅深者。权实理定浅深义通。故重言之。次明处中者。前以声教望于感应。故将娑婆而对十方。则娑婆声教处中义足。今欲论一本故却对多迹。迹多虽广如指一月众影自归。岂以能指四指有四。令所指一月非一。故置迹寻本处中明矣。次引肇者。但借其言不用其事。肇用融公九辙。九辙未当引者如何。故彼本迹无生辙云。多宝不灭释迦不生。多宝本也。释迦迹也。本不灭迹不生。不生不灭本迹虽殊。不思议一。岂得以多宝之本。垂于释迦之迹。若借彼显今。以久为本望今为迹。本迹虽殊不思议一也。次明观心者。亦先举广辨失。次但观下正明处中。初寻迹等言语前三意。有解无行何益自他。迹遍十方故名为广。本指最初故名为高。徒寻他果之高广。何益己因之该深。若以信行为乘。及知常住远寿。寻他高广有何不可。但设教显本本令契理。故不契理名数他宝。华严经偈具如止观记及释签。但观心故。达己心之高深见己本也。以理摄故。达己心之该广见己迹也。一念心起彻实相底。故名为高。具足诸法故名为广。又即权而实故名为高。即实而权故名为广。若非此观但感前三应。则教下须开果权须废。故教被会名为有穷。权观须改机非妙感。是故机成亲能有感。观成入位己利非他。是故观心具上三意。况入位有本垂迹设教。三义具足何得不用。故观心处中。虽则四意展转相生。以前前为广后后为中。但存当分皆名中故。故此四意从事名殊。应以后后转入前前。总而论之不逾感应。但初名感应者。且舍通从别。以无下三粗妙莫辨。是故四悉浅深未分。故得声教方辨感应权实不等。会归圆极教之功也。虽知圆极并在今经犹覆久成而迷其本。若拂迹应咸由本垂。开迹中感应。即本地感应本迹秖是一妙高广。虽知高广机成由观观成有感真感应也故知感应通贯下三。况复一一展转相摄。理虽相摄事必甄分。三引证者。初证感应。又云下证教相。寿量下证本迹。譬喻下证观心。初文先引。若人天下释。初言因缘者。即感应之别名。名异义同故得为证。但因缘名通不局能所。故止观第一云。或因于圣缘于凡。或因于凡缘于圣。纵无强弱亦可互为。何者。从机则机亲而应疏。从应则应亲而机疏。故使更互受名不同。但感应之名不可互立。大事因缘虽在迹门。据理应须双指本迹。但佛出世正为显实。故且从迹。又复让下本迹故也。释中先举非。次实相下显是。初举非中所以不简三教菩萨。唯斥人天小乘者。具如玄文。从难从要下去例然。言不成机感者。非今经之广博实相因缘故也。次显是中。既以实相一大对简小理。其义即足。故不暇开等兼等简之。既得云大亦应云深。言佛指此为事者。理不名事。但佛欲以此理化人。故名为事。能化所化故云因缘。次证教中初正引。次当知下结教意。三大经下重引。初正引者。种种之言义兼一代。若在他部意未必然。佛道者。别指今教。故自此已前意归于此。次结意者。微谓诸教初心人天小善。着谓诸教果德。权实微着皆为独显。故云筌蹄。种种之言及以微着。必须八教方显四味为醍醐筌蹄是故筌蹄并譬能通。权教权部并为一实鱼免而施设也。或作蹄。苍颉篇云。取免具也。庄子云。得免忘蹄。作此蹄字。今时俗依之。说文作罤。若言蹄是足者。能诠不成。若言蹄是迹者。其义亦疏。寻迹得免义岂尔耶。今须从义以罤为正。次引大经者。引彼大经重证今部。则以一实为第一义。粗软须指四味权实。引证本迹中三。初约师次约弟子。三结。初文又二。初正引本文。次方便下引迹文。以迹中此文密示本意故也。若显露说即迹中本迹。下文显已通得引用。弟子者。亦是举资密显于师。弟子尚非实小验知师非近成。利根纵其已知。须待弥勒扣发。见本眷属闻说不疑。言云云者。广在下文。兼斥古今诸师。尚不知师之本迹因果特出诸教。况弟子耶。又弟子之本诸经容有。如文殊观音等也。师之久本出自今经。证观心中先引。次当知下结意。初文者。事论秖是信身子说。义当见佛。汝所说者。必从佛闻。能闻之人必是声闻菩萨故也。故闻汝说即是见佛等也。次结意者。所闻是法。于能观心即名为佛。义当见佛。心所即是弟子等也。即于己心识三宝一体其理宛足。具如闻说已下文是。注云云者。将向观义。对闻说已下文唯在一念。又若具足应约因缘约教本迹。以明观心。则有三观对境因缘。诸教理观三宝境本观迹。及施开等思之可见。示相者。唯约今经示四种相。虽始自如是终乎而去。皆用四意。但文势起尽用与不同。如释通序则句句须四。通贯正宗及流通故。若释正宗则本迹各三。义通四种。若释流通还须具四。通收正宗。又正宗中迹门既阙久远本迹。所以借用体用本迹。则四名不阙。又序中约教须观文势。或须以五时分别。则教在其中。或须以诸教分别。则将时以判。正中约教则一向明开。本中约教则不从教判。但点远本远妙自彰。若解斯文则一部经心如观指掌。四意消释无劳再思。故今且寄三段大文。通示其相。既了通已还将此意委悉别消。初因缘中未暇历品。且示三段即种熟脱。然种等三亦须约于序等三法。以辨因缘。若唯序等。则无阶降过未因果。若唯种等闻无所从。以种等三于序等三。所从得益不同故也。且如序中通序在灭后。别序通过现。若佛在世别序五中节节益异。如说无量义。密得种等三益不同。故睹定见光觉动蒙华。乃至问答亦有种等三益可知。正中本迹诸品不同。故通别序至佛灭后。被流通人劝持诵说。亦有种等。况正宗耶。故寄此两三方晓因缘。初约种等者。须寄教相方分有无。故诸教因缘长短不等。如三藏人三祇百劫。秖云自修六度肥功德身。相好庄严。与物结缘为种熟脱。通教初心自行近从七地留惑润生。与物结缘云初下种。两教入灭无未来化。但成佛时而熟脱之。教权理权非今经意。别教初地尚能具之。何况果满。别教虽具教终是权。况复能有本因远种。今经本迹二门施化并异他经。此文四节良有以也。故四节中唯初二节。名本眷属。初第一节。虽脱在现。具腾本种故名本眷属。今不云是本者。以同在今始脱故也。本种近脱者。以弥勒不识发疑故来偏得本名。然现脱者若未得佛智。犹未能知种。今出其意耳。于中为二。初明种等三。次明序等三。初文四。初正明因缘。次虽未下释疑。三其间下约三世九世。以释因缘。四何以故下。引证三世九世因缘。初文即是四节示相。初之一节本因果种。果后方熟王城乃脱

次复次下本因果种果后近熟。适过世脱。指地踊者。故知地踊云本眷属者。乃是本种近世始脱。既弥勒不识非极近也。次中间种昔教熟今日脱

次复次下今日种未来熟未来脱。此四节者且取大概。本因本果讫至中间近世今日。竖深横广何但四节。乃至未来永永不绝。若不尔者。现果无因现因无果。还同灰断化无始终。故知节节重重无极。而终以佛乘三段为本。而以人天三教助显。虽未下释疑也。今明因缘准文次第。且合在迹。探约本地中间者。正兼本迹示一部相。取后文意取化仪意。次约三世九世者。具如止观第一记引华严璎珞。故知尽未来际三世九世种熟脱三。是则念念三密念念三九。念念三段念念逆顺。念念身土。一一不同一一入实。四引本文证者。证三世也。若有三世即有九世。九秖是三故且通证大体三世。念念三世准例可知。神通属过去。通义其实通于三世。对余二别故。师子是现威猛是未。为令知佛化缘远故。还引本文。举远摄近以证四节。以如是下约序等三。初文先通指二序。故云序分通无可表故。众见下别指别序为生正之由。故云众见希有。颙颙者仰也。佛乘机下正宗。三非但下正明正宗为流通之本。三段既其俱生种等。则知字字句句会会味味。世世念念常为众生。作一佛乘种熟脱也。此文且从今部大判。如今释迦说此经时。通五别五无非因缘。即证信之因缘发起之因缘。又通五和合之因缘。别五次第之因缘。故从序至正于得脱者。故云开示悟入。降此之外余皆种熟。故未脱者益在流通。故云远沾妙道。并是此经之感应。言后五百岁者。若准毗尼母论。直列五百云。第一百年解脱坚固。第二百年禅定坚固。第三百年持戒坚固。第四百年多闻坚固。第五百年布施坚固。言后五百最后百耳。有人云。准大集有五五百。第一乃至第四同前。唯第五五百云斗诤坚固。言后五百者。最后五百也。若单论五百犹在正法。虽出论文其理稍壅。然五五百且从一往。末法之初冥利不无。且据大教可流行时。故云五百。故序等三莫非感应。又示教相者。教家之相故云教相。五味分别为显醍醐。通论圣言被下。俱名为教。今教别有显实之功。故名为相。又别约三段示醍醐相。故名为相。故于三段各简偏小。此且通作一种三段。让下本迹。是故未分二种三段

问。若尔。与向因缘三段何别

答。前直寄三时对感应人。以明种等。今委辨所说用浅深法。故略约四教以简三段。究而言之。还是因缘妙三段耳。况观心本迹咸属因缘。委简教相具如玄文。先约相待以判粗。次约绝待以辨妙

问。通序五义别序华地。此等是事。何得三段俱名示教

答。通论皆是正说前相。别论唯问答是教。且从通说无不表教。故文简云非为人天作序等也。二乘三藏也。即空。通也。独菩萨别也。正直等者。开权教也。正及流通准此可见。萤光者。大品云。菩萨一日行般若。如日照世胜萤火虫。此斥三藏。故指灯炬以譬通教。灯如二乘。炬如菩萨。虽同般若不无明晦。道种智是别。如星月者。地前如星登地如月。故星虽有明光不及远。令远见故。凡智虽照不及圣明。其心远故。月不及日带教道故。亦应更明三智三谛次不次等。以显教相。于此非急。杨叶等者。大经婴儿行品意也。今文略出人天者。然婴儿在小义通诸教。且从极小故指人天。但彼经喻从顿向渐。初云不能起住来去语言。圆婴儿也。大字者藏也不知苦乐等通也。下作大小等别也。啼哭等人天也。经既通以小善为婴儿。故圆因位亦名婴儿。经云。半字者。谓九部。满字者。谓毗伽罗论。此云字本。河西云。世间文字之根本。虽是外论而无邪法。将非菩萨之所造作。故譬衍门十二部经。古人唯知衍门一大。今则不然。简共别后唯以圆门而为满也依义不依语斯之谓矣

法华文句记卷第一(上)法华文句记卷一(中)

        唐天台沙门湛然述

次示本迹者为二。先法次譬。初法为五。先指本因所禀。次但佛下指本果所说。三中间行化四今日所说。五未来所说。自从本因所禀莫非真实三段虽俱真实本不可多。故下三文咸同一本因果真实三段教相。此中正简久本真实。是故云也。然以本因所禀亦是彼佛迹说恐无穷。故但在今佛因果为本据理非不禀余佛化。因缘约教既指今佛。故明本迹。且废于他故指今经寿量为释迦本。不得更指前佛所说。前佛复有前佛。故云无穷。唯指一佛则无斯过。降兹一本余皆是迹

问。恐堕无穷唯论释迦。今欲论诸佛展转禀教。终有一佛在初无教。无教为本有何无穷。若许有穷堕无因过

答。拂迹求本本求所说。以获实利。纵有最初不同今初。何益行解耶

问。若许有最初无教。何须禀今佛之教

答。无教之时则内熏自悟。有教之日何得守迷。如百迷盲俱不知路。一迷先达以教余迷。余迷守愚不受先教。谁之过欤。且验释迦一化得益难思况复尔前益难称纪。宁不禀教。然终成无益之论。不可以此为穷。以无益于禀教者。故又十方世界亦有嗅香觉触瞪视而得悟者。岂以声教求其初耶。师子奋迅未来永永者。奋迅具二义。左右如现前却。如未故下疏文云释此句者。应具二解即现未也。今存后解故云未来。前存前解故云现在。譬大树者。总譬前三节为拂游中本迹故也。言云云者。以易解故不复合喻。次示观心相者。先总次别。总中有二重。一约修行。二约法门。行谓所行法即所用。行必先戒次定后慧。用必先以慧择后方定戒。定为戒本故戒复居后。又观心者。如玄文中。或约行相。或约法门。或从观境。故销文例之。亦对三分。义当观心。次别意者。三分各三。初戒三者方便如序。白四如正结竟如流通。言前方便者。单白已前皆方便也。定三分者。二十五方便为序。入观坐仪为正。行住历缘为流通。亦可以习学为序。自行为正。教他为流通。余二悉尔。次更约善入出住等。此依经列。若从三分则入序住正出为流通。慧三亦尔。从文从义次第不同。三分应云空序中正假为流通。言而退者。经末但云而去。去秖是退。但准望等者。尽令用四其辞则难。但令不失旨。如共辙碱会碱字恐误。秖应单作。或恐如流入海一同碱味文体语倒。故知不必皆用四意。又观心一文除安乐行中修摄其心等余皆义立。又本门虽本但寿量一文。正明本迹余亦义立。又前迹门准部有故。是故义立。后本门中除寿量已。理合有故是故义立。又观心文序及流通准望正宗理须义立。于正宗中唯安乐行理定须故余皆义立。迹门正说既云开会。若迷观境开权显实。及本门中增念佛观增道损生。及流通中随喜不轻三昧所依诸行所托。一切不成以观心名通于观等中间三即结缘。当机通用观故。影响发起化功。若成成分证观。所以观心一文人谓最宽。于理甚要。况今大师且为成于初心学者。始从如是以至而去。睹异文识一观亦识昔经文同观异及文观俱异。亦识当教文观俱同兼等开等准例可识。是故必须观心以释。又因缘释随其义势。须分今昔。先释序中先对辨通别。次正释通序。初文又二。先分二文。次正辨异中云通序通诸教者。亦可云通序通诸部别序别一部。亦可云通序通诸经别序别一教。今经部教唯在一教。故且以教对经言之。又通序名通而体别别序事别而义通。义通故通有别序。体别故别在今经。故知今经通别俱别别在佛乘。以如是等不关诸经。方可得名正家之序。正名序家之正。故一家相承三段可识故释如是竟一部炳然。不然岂有送客之序而叙游山。禅祖碑文而谭律颂。故须摩顶至足皆是一身。岂以通途之言能消通别二序。若不异者发起徒施。于中先标离合。云或五六七者。五者如文。合佛及处。六则离佛及处。七则离我与闻。初通序元起由阿泥楼逗。令阿难问佛。具如止观第六记。次略解五义。谓法体等者。略释意显故先明之。下广释中纵有兼释。但旁通耳。初云所闻之法体者。下文四释虽通指一部。别在正宗流通。亦可兼于别序。则怀疑答问及无量义。通名闻故。雨华动地从所表说。通皆表闻。故始末一经为所闻体。云闻持和合等者。因缘会也。通论五义无非因缘。如前通辨四意中说。又下总结五义云皆因缘也。今且从别约时义强。独标和合。闻持之言唯在阿难。和合之语义通两向。由机会故闻持和合。次第相生者。且约一往。若闻如是等及化主居初。亦可通用。次又如是下广释。先释如是。初因缘中世界即是欢喜。故云不诤。诸佛皆然未足别显。若约今经先施次开。方名不诤。事在约教故今未论。今引诸佛以异显同。亦世界义。举时方者。如是可信良有时方。即说如是得益时处。方则崛山犹通于昔。时显别味令处非通。即生实信。方是今经为人悉也。阿沤者。阿无沤有。一切外经以二字为首。以其所计此二为本。部内所明不出所计。故立如是对破外人不如不是故。准下约教外典全无。故云破恶。百论云。外曰。汝指何为善法耶。内曰恶止善作。外曰。汝经有过初不吉故。我经不尔。初后皆吉。内曰。凡一切法有于三种。谓自他共。以汝吉法无自等故。故我先破有无自生及他共等。故计有无为自他等。名之为恶。故我经先止

若尔。中论具破四句。彼何不破自然

答。计自然者有无中摄。亦有自然有无不摄。且从一途故中论云。从因缘生尚不可。况无因缘。自然易破故但况之。但四计义通。若唯破外尚未离小。安会今经。且引论文成破恶义。若依今经尚破兼带之恶。何独外耶。第一义中且通指道边。未分深浅。故知凡四悉文。非不己破诸教浅深。意在且明欢喜等四。故更须教分判异同。又释序中前之三悉多分约事。第一义中或已入实。或且通方。又前三悉望圆实边。名之为事。于前三教或亦在理。若正宗中咸随本文。此四悉檀文在大论。初明说经缘起中。总有二十三

复次于中先问。有何因缘而说是经。答中云第一义故。乃别指衍门为第一义。因即释出前之三悉。且指三藏论云。四悉檀摄八万四千法藏。故今通用。具如玄文以开十门。又净名前玄总有十卷。因为晋王着净名疏。别制略玄。乃离前玄分为三部。别立题目。谓四教六卷。四悉两卷。三观两卷。彼两卷中文甚委悉。言甚广者。一须大师所说。二谓所摄意多。况今经如是。须历八教以明四悉。方显今经唯一如是第一义悉。故云甚广。又诸家异释动即三四纸来。多在因缘而第一义尚少。况复约教本迹等耶。约教中初经称者。在付法藏中。此付法藏亦名付法藏经。于中为三。初通解。次别责。三且依下正释。初文又四。初通举三世佛经为本。次引昔佛八教。三引今佛教同。四举今经表异。初三世者。先举过现例当。正用过未例现。或正引过以准今。故指先佛八教。言八教者。将藏等四入顿等四。则四味中如是各异。况顿渐中秘密不定。四教通塞一一不同。先了不同如是不一。方识法华如是不异。施及开废准例可知。一切诸佛垂于五浊。无不皆然故云亦尔。余如玄文。次诸经下举今经表异者。又二。先法次喻。法华超乎一期教表。若将今教以对昔教教既差别部又不同。兼但对带权实远近具知进否方晓今经。如是既然他皆准此。安得以诸师一匙。而开于八教众户。攒于古师众释不出因缘一意。故云一匙。况一两师宁开八教。况约教等三信古今冥寞。又佛阿难下立法别责。又四。初立法通者。若二文不异为如。二如下所诠为是。八教皆然。次今阿难下举今经阿难以责。今经于八为属何耶。若非超八之如是。安为此经之所闻。三不可以下结责。故云不可以渐等。略举渐偏。理须具明秘密不定。及简顿部。诸师既不知八教异今。故二文传诠不如不是。四传诠下结过。此义等者。劝勉也。若得今意不劳再详。其理自审。三且依下正释。又三。初约渐教者。避繁文故寄渐明四。次若顿下释顿等三。三敷八教下结责古师。初文又二。初约传诠相对以释。次若动下直约所诠观谛以释。于所闻时具能所故。亦是以理结略前释。是故四释皆以如为名。又前以文契理名之曰如。乃指所诠称文为是。此以智如境为如。如通二真。故前两教俗对偏真。后之两教俗对中真。两文各二随义消之。故前约传诠一一文中。皆约谛与文字。故能诠既同。验知所诠理当。故所传所诠皆所闻体。故初二教皆以文字为俗。所诠为真但有即不即异。乃辨二教传诠不同。后二教皆以能诠对所诠三谛以说。亦即不即异。以四例四亦应可见。若不尔者。岂以阿难传佛无诠之教。故彼文理相称之法。是我所传。故下方云闻等也。言云云者。应更以是对向四文。及以渐中具教多少。准前可知。次顿等三者。言顿与圆同。且从少分。以彼兼别今且从胜。故云圆同。应更云顿中别教与渐中别同。不云渐教有同异者。渐既离四。举圆即摄诸部中圆。三教即是诸部中异。故但更对余之三教。不定中云更互者。并约渐顿四教说之。深浅相望故云前后。秘密不传者。降佛已还非所述故。尚非阿难能受。岂弘教者所量。又阿难非不传秘。赴机之密非所传耳。故秘密所用全是显教。是故传秘秖名传显。三敷八教下结责者。华严云。张佛教网亘法界海。漉天人鱼。置涅槃岸。故知佛教不出于八。所诠无外故云法界。教网既亘于法界。涅槃必遍于偏圆。岸唯果地一如。教必权实本迹。天人机具众教。漉至究竟涅槃。故诸师偏释不可独张。比窃读者。尚云天台唯藏等四。一何昧哉。一何昧哉。是故须知消经方轨。顿等是此宗判教之大纲。藏等是一家释义之纲目。若消诸教但用藏等。其文稍通。若释法华无顿等八。举止失措。故又举喻责云。接四箭等。故大经迦叶菩萨问云云。何智者观念念灭。佛言。譬如四人皆善射术。聚在一处各射一方。念言。我等四箭俱射俱堕。复有人念及其未堕。我能一时以手接取。佛言。捷疾鬼复速是人。如是飞行鬼四天王日月神坚疾天展转疾前。无常过此。今借接四以喻八教未敢称当。况古一两如驴鳖耶。若深得是意入文自融。言云云者。应举八教以合譬意。况若不识开权拂近。徒知八教经旨未分。所以今文多不云开者。以玄文具故。又开显圆与兼带圆。二理无殊。故云顿与圆同等。故不定秘密义各含四。显之与密定与不定。相对论故。次约本迹者。文虽未至证信义通已如前说。又为五。初通举十方三世。次通举三世。三独举释尊。四正约传诠。五更明示迹。初二既通一本难定。故且约下唯指释迦。次又阿难下约于传诠师弟相望义立本迹。又师弟下显阿难本。故五文中正用第三第四。显今如是。初云横竖者。十方为横三世名竖。十方诸佛各自有竖。非今文意。故且约下的出今佛。过去一本余皆属迹。师弟中亦指久本。余属迹中本迹而已。重明者。欲述本地亦为师弟故也。故云非始今日。当知空王时亦非阿难本也。次观心者。前之三释并是所观故云观前也。悉檀是前因缘。教是前约教。迹是前本迹。等取三释各具诸义。本虽久远。圆顿虽实。第一义虽理。望观属事故咸成境。故对三为观便成四释。于中又三。初通立观相。次引文证成。三约文显四。初文言即通者。具足应云缘生即空。即指前三皆缘生故。况前缘生境通三谛。从即空边且判属通。应知空观通于一切。空假成别者。地前从别证道必同。亦通亦别者。凡通圣别故也。凡通前教圣局证中故。空假仍通中方别故。地前空假通于所非及以所照。登地别在能非能照真实故也。此是别家对他通别。若唯别教与前永殊非通非别者。无非法界故。双非辨别与前复殊。此中既以因缘教迹而为观境。不可复以藏通观观。是故但寄通别四句。寄约教义暂分别之。又为成四句。故借别教离为两句。故第四句即是今经之妙观也。次下文云去。引譬喻品证成观相。三信则下更约观心成因缘等。而释经文。一心即具感应等四。信机见应者。于一心中能信如机觉心如应言浅深者。义当判教。信实相心不同于权。实相之深不同余浅。又信下约观论本。则妙教为迹所诠为本。见实相本即见经中师资之本。以主及伴俱得实故。以龙陀久成从所证为本。言龙陀佛者。真谛云。须菩提是东方青龙陀佛。有引大宝积云。舍利弗成佛号金龙陀。未检。指此则知一切声闻咸然。故见空生身子之迹。则识一切声闻之本。又闻经下乃以观心。释成观心。能觉之心名佛。即此觉心名慧。亦即觉心通数具足。即此觉心与弘誓俱。名慈心净。约心下结。次若释下判同异。先明去取。次当知下正判。所言他者。即他部也。于前四味唯除鹿苑显露无圆。所言同者。但云今圆同彼圆故。应云兼带复成异也。又言异者。彼无久本。诸经亦有体用等本迹。名同体异。从体异边故云异也。应知。亦可通用四释。但知诸经无久远本义则可矣。云云者。此之四释对于部教关涉处多。故因缘等四望于前经。各有施开兼带等别。故所传亦别。次释我闻中三。初辨互异。次今例下准例如是。三大论下正释。初因缘中先明世界。初引论释。云耳根不坏等者。先举根尘。根即清净四大。处者尘也。非余阙缘故云可闻。虽复可闻须发意识。故云欲闻更藉诸缘。故下总云众缘和合。但除空缘也。次问答中有人不许灭后色经。唯云名句属于行蕴。若其全不许见。经初尽合改闻。当知皆先眼耳所得。次方流入想行。若使一字一声眼耳二识不俱。则名句文皆不成就。和合之言不可欺也。所言主者。总举识心。即世流布。仍藉阿难愿力及以如来宿誓。灭后众生有机。方乃能令和合成闻。故且以我是众缘主。众缘和合我方能闻。故云我闻。文举缘具故但云闻。因缘和合即世界也。无学飞腾说偈者。佛初入灭。诸阿罗汉皆说偈云。已度凡夫恩爱河。老病死家已破裂。见身箧中有四蛇。今入无余般涅槃。诸在林中者又说偈言。佛已寂灭入涅槃。诸灭结众皆随去。世界如是空无智。痴瞑道增智灯灭。于是飞腾各说偈言。咄哉诸有苦。轮转如水月。不坚如芭蕉。亦如幻影响。如来大雄猛。功德超三界。犹为无常风。漂流而不住。佛话(户夬切)文殊结集者。大论云。文殊结集诸大乘经。亦皆先称如是等五。经论二文并生恋慕之善。诸阿罗汉恋慕之极。故皆随去。佛指阔二寸。三疑者。前众疑已下文是。若此三佛皆应自说。并不合云闻。是故云闻三疑皆遣。遣疑即破恶故也。第一义中无我无闻者。如陈如云第一义谛无声字等。古来下通斥旧也。于因缘中前三尚自不周。况第一义况约教等三耶。凡夫三种我者。见我即利使中我。慢我者。虽通一切利钝凡夫。然诸凡夫皆于己身以立宰主虽非外计并属见思。若学人所伏唯属钝使虽无见我思惟未尽。故云二种。世名我者。世流布一凡圣共有。但圣无前二。今亦不暇辨见修相。付在余文。十住婆沙四句称我者。即有等四句。故彼第一卷地相品问云。云何为无我。而说偈言。总有八行半偈。最后云是故我非我。亦我。亦无我。非我非无我。我所非我所。亦我亦我所。非我非我所。是皆为邪论。故离四句方名无我。今但云无我乃是即我无我。不云析破故在通教

问。论释别地何判属通

答。登地已去诸观具足。但云即空义在通摄。况复地前义当通教。引大经者。经云。阿难多闻士自然能解了是常与无常常无常义同我无我故也。不二登地双照地前。照与分别名异义同。圆教极故义兼权实以胜摄劣。故望一代。五味既别所闻不同。正法念中三阿难者。与集法传三人大同

问。正法念与阿含二经并小。如何证四以传四教

答。小中一人既分四种。今演小令大以大拟小何不传四。况复名通义圆。于理无失。小在三藏。通乘共故亦名为杂。况通菩萨利钝复杂。云云者。一人四德以用对教及开显等。义如常说。空王等者。于佛亦是迹中本迹。若于阿难或未是实本。主尚晦迹弟子未彰。故亦不云空王劫数。言云云者。应具对上因缘等四。以明我观。亦应须寄因缘等四。辨次不次。此文已当约教观心。心境相对因缘观也。真妙望余本迹观也。以心观心观心观也。释闻因缘不分四悉。但通结云因缘。若欲分者初是世界。旧解下为人。报恩下对治。此文下第一义。初问。次大论下答中言集法者。然结集之言通有三处。谓一千七百五百。一千正当最初结集。七百即是佛灭百年。因于跋阇擅行十事。舍那迦那白于七百。七百乃往毗舍离国。重结毗尼举跋阇过。言五百者。四百年后。因迦昵吒王请僧供养论道不同。因此五百往王舍城。更集三藏。今此从初广如诸文。展转从他自他别故。闻不闻异。未闻者乐欲。已得闻者生喜。并世界也。三昧是善及能闻力。新旧两闻因闻善生。言佛觉者。秖是佛加。觉力如佛故名佛觉三昧。已证非从佛闻故云自能。用本愿力为持佛法生后代善。故旧解理当判属为人。报恩经者。第六佛求其为侍者。许已。仍求四愿。一不受故衣。二不受别请。三不同诸比丘。须见即见。四二十年中佛所说法重为我说。佛粗示言端阿难皆解。智速根利强持力故。又密说者。辨异觉力及重说故。己知他不知。名之为密。又大经佛告文殊。阿难事佛二十年。具足八种不可思议。一不受别请。二不受故衣。三不非时见佛。四见一切女人不生欲心。五持一切法不曾再问。唯除问于释种被杀。六知佛所入定。七知至佛所者受益不同。八悉能了知佛秘密法。胎经者。举初况后也。胎相尚闻况后诸经。面如净满月者。出育王经。此中亦用前之四名。及大经四句。然大经显圆。今乃义开竖约四教。随名便故不复次第。亦应具消四闻。所以令顺教意。本迹末云云者。一本事高难量。二本理深难思。三本迹化莫测。具如释如是中。观心中不闻。不闻下云云者。应具用上四。且对次第分属四人。具如昔经我闻故也。若依今文用妙观故。妙观下注云云者。开粗显妙以明绝待。次释一时。初引肇意者。启初开也。运合宜也。嘉善也。佛化大运必称物机。故云善会。称机秖是因缘和合。称机欢喜故云世界。此中世界即属此经。不同余文异余时故。引大论文明生世善治世恶。明二悉者。寄示相耳。复是论中释一时文。故且引之。然此直云时彼方两解。若云迦罗即是实时。若云三摩耶即是假时。论问。天竺释时凡几种。答凡有两称(别者如向)迦罗二字以浅易故。三摩耶三字重难说故。若除邪见不说二字。即是假时。若内弟子依时食护明相。即用实时。当知秖是一时二别。故声难易耳。是故外人计时为实。而说偈云。时来众生熟。时去则催促。时能觉悟人。是故时。为因。故须破邪说三摩耶。故今文中以实时示内生善。假时破外断恶。第一义下云云者。道合之言正当嘉会。所发善根言通意别。须约教味以判偏圆。则四味三教权人理等。虽有道合仍须开显。故下约教仍存四别。此下中等亦如大经四因缘智。今经之言亦略开等。本时自行唯与圆合。化他不定亦有八教。言前诸者指向四教皆在迹中。观心下应注云云。文无者阙。此之粗妙各有观与境合。名为一时。相即观者。今经观也。若将此观约前三文。例说可知。次释佛字因缘中。亦秖应释觉。而但云时处等者。明觉之感应时及处耳。非其时处不感佛兴。时处异故当世界也。劫初劫尽是极长极短极苦极乐之时。余三天下富寿无我。非感佛缘。多病是减极。三小灾起谓刀疾饥。疾居其中故略云病。俱舍云。刀疾饥如次七日月年。止长寿时乐重举劫初短寿时。苦重举劫尽东天下去举不兴处。也并由寿定乐定保乐保常。不成机缘故不感佛此仍。且约人中处耳。若论天上小乘亦有得小果者如梵王得三果等。若准华严四天王及化乐天并无色处并不感佛。余经非无但除难处。言富寿者东名胜身胜南洲。故富寿亦尔西名牛货。以牛为货故云多牛羊也。北名俱卢此云胜处亦云胜生。于四洲中有情处货皆最胜故。南名赡部从树为名。于南洲中但举初后中间亦有六四二万。且云八万是减初也。百年是方极故。后减之初则弥勒也。今减方极则释迦也。未见果等。明感佛缘。虽略云地亦应云时。离车等者。大经二十六云。佛为离车说不放逸。离车云。我等自知是放逸人。何以故。若不放逸如来世尊应生我国。何故弃我出摩竭提。时婆罗门子名曰无胜。语离车言。频婆大王已获大利。佛出其国犹如大池。生大莲华。华虽在水水不能染。佛亦如是虽生彼国世法不染。汝迷五欲不知亲近。名放逸人。非佛出彼名为放逸(无胜者阿逸多)汝耽五欲。纵生汝国。汝亦不见。故此时处亦据多分。舍卫三亿非关苦乐。摩竭提者。此云不害。劫初已来无刑杀故。至阿阇世截指为刑。后自啮指痛复息此刑。佛当生其地故吉兆预彰。所以先置不害之名。日若不出等者。大论文也。日喻佛兴。池喻摩竭。华喻物机。佛若不出已未二善皆悉不成。未者下种。已者熟脱。然合喻中且约世间有漏善法。故举刹利等况出世善。故轻系地狱尚因佛出。乃有一念厌恶之因。后方得离。况复人天。故论云。若持五戒释迦文佛在汝家中。四姓举二且从胜说。对治中断有顶种。即断三界恶故。故名破恶

问。为人但至有顶对治何故破三界恶

答。真谛事理。于中道理。俱名为事。若前二教不得用此以为破恶。以让理故。今此圆教故得用之。言三乘者。即摄三教。以菩萨乘摄别教故。言余不能感者。约八相化。必出世机方能感佛。示九道身虽是感佛。不名佛化。故非感佛。善断之言在无漏智。种谓能生。垂尽非想复堕三恶。名为还生。一去不来故名为永。第一义中既云法性。烦恼即菩提。故云无动。生死即涅槃。故云无出。佛无苦集已住法性。虽无动出不动而动动法性山。示断生因故名为动。不出而出出生死海。化九道生故名为出。此前皆谓实动实出。至此方知非生而生无动而动。则前二教及别地前但属三悉。引入今经第一义故。约教中先释。次故经云下引证。前明因缘说感应相。今既约教约四极果初成之相故并云觉。又自觉觉满则据于初。觉他通于初后。西云佛陀。此云觉者知者。对迷名知对愚说觉。名同对别并属自觉。故约四谛。即以自觉而能觉他。故云亦也。总相别相者。总谓无非无常别即观四念处。谓三界系及四圣谛。此别莫不皆观无常。老比丘者。从后异故。以通教佛亦可云老。而云带者辨异前教。如阿含云佛临涅槃如老比丘诣纯陀舍。三十四心者。八忍八智断见。九无碍九解脱断思。断伏不同。具如止观第三第六记。具在婆沙俱舍及诸阿含。此教求作余释不得一念相应断余残习。作三十四心释终无其理。具如大品第十地。别佛具如璎珞及诸大乘五十二位。初地断无明者是。圆佛具如华严初住断无明者是。然小乘中立二无知。染污无知无明为体。不染无知劣慧为体。谓味势熟德数时量耳。然四佛皆云自觉觉他者。秖是当教自行满位。觉智不同化境宽狭。是则遍搜大小乘教。唯有此四成道之相。具如玄文因果两妙。他释但有自觉等三。既无四教各具三义。如何分别大小教主。与而言之不出二教。若云坐莲华藏。或云三世诸佛皆色究竟成无上道。并别佛相。若隐前三相从胜而说。非谓太虚名为圆佛。别佛既云单论即是隐前二相。如目连不穷其声等。若法华已前三佛离明。隔偏小故。来至此经从劣辨胜即三而一。他迷一家所明四佛者。以弃旧译经论故也。如四阶成道。三乘共位。璎珞贤圣。华严融门。此四成道不可孱齐。以由设迹不同隐实覆本。故开权显本方知不殊。又诸教中各有五人说经。如大论云。佛及声闻天仙化人。及华严中加诸菩萨。又有众生器世。而皆以佛为教主也。然准大论下四印定。即名佛说。又华严中刹说尘说菩萨被加。亦无印述。余三佛力通得名经。故大论中所破并能通具四教。若得实意。方知四佛体同用殊。讲华严者。皆云我佛。读唯识者。不许他经。故至今经乃知指昔。唯佛究尽斯言有在。次引经者。像法决疑中通佛云大身小身者。以云带老比丘故。约本迹中初寄本中体用。故云本一迹三。中间下次明迹中应化胜劣。他受用报皆在迹也。但生灭之言多在应化。唯本地四佛皆本者准例而言。则迹中体用俱迹。本地体用俱本。具如玄文本因果妙等料简中说。观心中觉秖是智六即判之。有本无云云者。或是脱落。应先辨藏通至别圆中。方乃得云偏圆二觉。然次第中亦可摄得藏通二佛。或略之耳。若望前三境智因缘佛也。藏等四观四教佛也。中望空假本迹佛也。己心即是观心佛也。次释住中全用大论。恐他不晓故初标云能住所住。若但身土但成世界。心法相依方成三悉。他人唯许身依于土。乃成佛心无所依法。忍土者。悲华第五云。何因缘故名曰娑婆。是诸众生忍受三毒及诸烦恼故也。能所异故名为世界。故大论云。住者四仪住世(今文世界)。复有三种。一者天住谓欲天。今云十善。二者梵住即色天。今云四禅。但名异耳(今文为人)。三者净住即三果已去。今云三三昧者论云。入三三昧即得初果。三三昧为对治者。以为三明近对治门。具如止观第七记。论又云。布施持戒善心为天住。四无量心为梵住(前从果此修因)。三三昧为圣住。圣住秖是净住耳。论又有四住。天梵圣佛。更加佛住即今文中首楞严是。故今四住收论文尽。若以教收四教并有前四悉义。四佛并为第一义天。但前二佛不得云用首楞严耳

问。若尔。今释佛住何以三悉但约欲色及以三果。能住所住俱非佛耶

答。一从通以趣别。二将胜以摄劣。言从通者。从广之狭。言从胜者。佛依王城必摄欲色及以三果。有人斥云。今释住王城何以引于天梵等住。此人不曾读大智论。此是彼论释住正文。论具二意如向所述。若秖以色身住土以释住名。则大菩萨神无方所。便无所住。况复佛耶。故普贤观。常寂光土是佛住处。岂王城耶。故下约教皆以涅槃而为所住。次约教中涅槃皆是所住之法。并约第一义也。释前二佛皆云有余无余者。巧拙虽殊所灭不异。后两秘藏证道亦一。前三佛下判粗妙者。别教证道虽妙。从教道故判粗。言能所者。若约理判如向所说。若约事判秖是依正他受用土。故判为粗。若约中理虽俱秘藏亦是从教。今经是圆复须开显。故名妙住。本迹中言三藏佛应涅槃者。应字平声。若据灰断即应入灭。入灭本也。由慈悲故所以住世。秖名住世以为垂迹。此佛报生无别理本。通佛扶习此从因说。以六七地入空为本。以誓扶习利他为迹。果同三藏故从因说。别圆同云熏法性者。教证小殊。然皆因时起四弘誓冥熏法性。但明法性即离不同。智断虽殊法性无别。当知下。总判前文以明本迹。本迹莫不皆由慈悲。前四俱迹故须更云本佛住也。以慈悲下判。既开迹已岂别有本。次约观中以智为佛。智住无常及空假中。前直相对故四观不同。次约住意故云以无住法住于境中。故无住之言通于四教。粗智谓住于理实无。若在圆中便成绝待。王城者。准西域记。此城崇山四周以为外郭。东西长南北狭。周一百五十里。子城三十里宫城北门是调达放醉象处。东北是身子逢马胜得初果处。东北十四五里至鹫峰山。是说法华等经处。斑足缘亦出仁王。论中又有异释。论问。如王舍城迦毗罗波罗奈。并有王舍。何故此城独得名耶。答有人云。是摩伽陀国王子一头两面四譬。时人以为不祥。裂其身首弃之旷野。有罗刹女名曰阇罗。拾取合之而乳养之。后大成人能兼诸国。乃取诸王八万人(下去同今疏文)楞伽又云。昔有王游猎。马惊入险乃绝居人。共[牛*孛]师子居而行丑行。生息长大名曰斑足。后绍王位领七亿众。食肉余习非肉不餐。后乃食人所生皆是罗刹。余与今文大同。四非常偈者。秖是四无常偈。具如止观第七卷记。言得空平等即是初地者。彼既共教小即初果。大即干慧或在见地。别即欢喜。与大经梵行意同。若尔。何故闻无常而悟大耶。答已闻般若复闻非常。恐其吝国。正助合行因得大益。此约斑足缘异故属世界。千王取血等。虽失小国迭知大国。生善属为人也。百姓排舍以免烧恶。即对治也。斑足得道第一义也。注云云者。大论与诸经所出既多不可尽具。虽多不出四悉。约教中四见。然辨土横竖具在净名疏。即如下文纯诸菩萨等。例知者。以娑罗例王城也。本迹观心在后者。后与山文合明观心。后文仍略俱不出本迹。若例上下应云本住王三昧三德之城。迹居忍土之王城耳。梁武等者。字应作睢。其鸟似鹰。云似鸱者。或恐误乐而不淫哀而不伤。雌雄各居欲交俱鸣交已各去故以之类皇妃也。诗云。关关睢鸠在河之洲。窈窕淑女君子好述。今江东人呼为鹗。好在江洲。梁武意谓睢形近鹫。故引之耳。此属世界也。又解山峰下为人。睹者生悦故也。又云去对治。能藏恶故亦当治恶。又解去第一义。三乘圣居是第一义。次辨五峰及后问答。但是第一义中释疑及分别山相。非四悉摄。又增一三十一云。佛在灵鹫告诸比丘。久远同名灵鹫。更有别名汝等知不。亦名广普山负重山仙人窟山。恒有罗汉菩萨得道。及神通诸仙所居。有五百辟支佛住。如来欲下先令净居天子来此告令令此土净。却后二年佛现此间。支佛闻已烧身入灭。何以故。世无二佛国无二王。一佛境界无二尊号。此山高下亦复不等。四十七云。俱留孙佛四日四夜行至山顶。那舍佛三日三夜。迦叶佛二日二夜。释迦牟尼须臾至顶。并以罗阅只人行也。时渐末山渐下故。文阙本迹。应云本住三德大涅槃山。迹居灵鹫。又本迹各有灵鹫。寿量云。常在灵鹫山本也。约观中先解王舍中。初立观境。言心王造舍者。识阴为王。造业诸心必有心所。今欲消王。且以善恶心王以对无记之舍。故云王造。若析下四观。此示观解异于他经。应如止观十乘十境。下去皆尔故注云云。后两重云若观。即后二教观也。亦须分别相别不同。具如止观不可即具。约山作观亦先立观境。正当观阴。具如止观第五去文。别圆观中既云山即法性正因法身余之二德准诸文说。故知此观不同他见。所以又约山为观者。山城虽殊同是依报。是故约之以观正报。又诸观境不出五阴。今此山等约阴便故。以诸文中直云境智。自住其中等者。以大经及此经意共为自他。定慧力庄严即自住其中。以此度众生即安置诸子。云云者。亦应于此以辨二观同异之相。方便正修简境及心。并对前二以辨权实等。乃至四观亦须开显等也。次释中字。既在山城之中。因缘等四具如彼释。今但消中字义耳。欲更说之。先约所表以具四悉。常好中道赴欲也。升中天中日降为人也。中夜灭对治也。说中道第一义也。诸教皆有中道。但有有体无体之殊。本迹者。观圆理本中也。示离断常迹中也。今经是开显之中。若约观者。即空即中具二中也

法华文句记卷第一(中)法华文句记卷第一(下)

        唐天台沙门湛然述

释列众中初辨次第。言多尔者。亦有经中菩萨后列各有所表。如华严经。不列声闻纯无杂故。旧解者。多是光宅。与大论意同故无别破。但总结云似两解耳。注云云者。事似因缘须具四悉。义似约教复须论八。事即身也。故云亲疏。义即谛理故云涅槃等。形服异故即世界。亲者生善疏者破恶。不亲不疏即第一义。于有义中既以三谛。以谛对教则四可识。于藏等四辨渐等四。其义可知。又两二义并欣涅槃。及四菩萨并不欣不着故皆居中。唯诣实理兼能利人。故居中求宗超彼凡圣。若以入中为菩萨。即指别教地上圆教始终。注家云。声闻学疏敦之于内。菩萨道亲忘之于外。此但得事而失义。似迹而迷本。况复观心因缘耶约本迹中此经列众超出群经。故人天二乘能引之人本非下地。所引之众堪通别记。语通意兼。故云内秘皆大萨埵。既能迹引二边判非凡小。故云萨埵。菩萨滥本故且不论。应知亦且约体用论也。观解后云云者。亦应更约因缘明观诸教开显及本迹观。释列声闻。准法华论以八义故。先列声闻。一为显亲闻后不谤故。二摄不定性回心入大故。三除尊贵慢非究竟故。四常随佛故。五形仪同故。六令内眷舍欲故。七令菩萨敬故。八令众生信故。然论中八义唯第二一半独属今经。以不定性此土得故。仍少一半。若定性者彼土得故。未来得故。余之七义论众前后。通诸经故。以第二义入余七中。使七一一皆有第二。方令八义全在今经。若依今意更有三义。欲别记故。别开权故先显本故。故令余义永殊昔教。故论文意诸经多尔。所以通释。今使诸教虽共复殊。方等先列以四义故欲斥夺故。欲密引故。令体信故。令味变故。般若亦四。欲洮汰故。欲委业故。密引进故。成熟酥故。故知论文通前二味。如向各四。又异前后。论又云。先僧次尼亦有八义。一男尊女卑。二入道先后。三师弟不同。四传法能不。五结集进退。六同住得不。七多少推让。八得叹有无。此八全通前之三味。多在酪教。若准同是声闻仍少第二意也。于今别中唯除委业。准义仍有。以同比丘闻转教故也。故委业时非全无分。自余诸义并同比丘。于五味中渐教当众其义不异。次出旧解云大小名闻者。意云。名即己名闻即他闻。所以名大故闻大名小故闻小。今但依文故破其无据。言依文者。但约所列多少以明所识多少。前列万二千又云众所知识。后云二千又无知识。纵以名闻用释知识。后文全无何小之有况复大小一向无凭。初释类中先通释五字。次释论下别释四义。比丘合故。初通释中五字通收诸有德者。所与之徒既标于大。岂唯异于下众而已。于比丘中其例复多。四门三脱析体通智辨空之例。秖得且云高誉德行何可具论。今云如贵类之班辈也。次别释四义者。初释论下别释与字。初文即因缘释。若于此七为四悉者。时处世界。戒是为人。心见对治。道脱第一义。若准前三。在昔教者则七义唯三。道脱等俱属对治意也。圆教七一俱属圆四。约教虽别究竟唯圆。虽七而同故七名一。一即共也。四教不同通在五味。具如诸经不可遍述。且准叹德在三藏教者。同感佛时。同鹿苑处。同别脱戒。同一切智心。同无漏正见。同三十七道。同有余脱。为同闻人。入通序时已得记者。全成圆人七一故也。同妙感应时。同见妙依处。同得究竟戒。同证种智心。同无作正见。同圆实道品。同不思议脱。得授记已即同菩萨。安得复以声闻叹德岂结集者谬抑德耶。故知在四味时随味而变。经家从本列在声闻。故依本叹。若不仍本焉知声闻有权有实。实者得记知有所从。闻法华时大小别故。故约教判须通始终。故三教七。或本是三。或是转入。初约三藏一七一者。生灭同故。通教二者。分利钝故。利兼圆别。应云三七。且通总说同为一例别云为无量者。自行化他横竖皆四门。门门四悉入者不同。圆教一者。发心毕竟二不别故。说者应于四教细明乃至教味先判后开。若未下一句约本迹释。亦约体用论本迹耳。别无声闻但云藏通。若通含别亦可论之。是则略也。又时处二事且约教论。故云三藏中时处且一。若从元初得道时处。或多人共处。略如今文。或多人多处。或一人多处。如阿含中多时处也

问。至此那得二种声闻

答。亦从初说。具如玄文。广历诸味难转易转。又有不历析法元是通人(云云)。直明两意下欲明开显。先更辨异。所言异者。且置七同。更于藏通七中辨异。则三异四同。何者。时处等四不可不同。如所会所依所禀所证。若心等三安能不别。别修别见别行故也。此仍一往。亦可戒法从别各各得故。解脱从人各各证故。是则五别二同。又若从人亦可俱别。今释共义不合论之。义分三四乃成旁耳。是故且从七同以说。别教同异准说可知。次若至下正明开显。法华论者。明被开者有权有实。未开具四开已唯一。今加佛道据新入者。论中四者。决定增上退大应化。论自释云。后二与记前两不记。根钝未熟故。且约此会。即经中云生灭度想。决定性也。若彼得闻论中未说。天亲岂可迷经文耶。经云。而于彼土得闻是经。论且一往据现说耳。是故今师但除上慢。即五千起去者是。虽从座去仍判于涅槃中。若四依边得闻。故上慢者亦非不闻。已闻略开及在后故。但不可云此会得记。种熟脱三始终无废。故准今文。远近相望四种俱得。今云住果兼于决定及退菩提。住果变异故分二教。是故二种总立住果。又佛道者。准经义立。若尔佛道应化各有别圆

问。应化与佛道何别

答。应化约垂迹全语旧圣。佛道约利他语新记者。又应化从身佛道从说。佛道有令他之言。且云利他。应化有发起之义。且云垂迹。既以声闻为名。在昔则无应化佛道之称。在今则无住果决定之名。增上慢中岂无应化。四摄同事安隔此耶。况复论中决定上慢同云未熟。不可上慢亦根败也。他云。未者不也。应人未死名为不死。下种未生名为不生。故上慢决定二俱可发是决定义。又此中引论似本迹释。应化本也。余三迹也。化为余三无异途也。唯阙观心即前两教七一境也。后二教七一观也。又时处戒境也。心见等观也。声闻义浩然者。贵人非论。然用教者云大乘声闻。未为通晓。今云应化从本以说。据众全在小乘中也。言浩然者。藏通八门门门四种。门门各有佛道应化。迹在前教复同前数。据本复应地住。地住及行向地。上慢所滥复同前数。他无约教今昔本迹权实开合等释。但云住果及方便等。是故贵云以证涅槃者。言云云者。具如向辨。释大者。前以共释与。阿难共彼万二千者。非直共人应共人七。七中并大故云与大。与既四释不同。大义理须准彼。又前与字义兼时等。今释大字。唯在具七之人复兼多胜。又释与字义兼能所。今释大字唯在于所。此从阿难指他为大。此中初引论文。大品在小心未转故。次今师意亦具三文。以一一文皆兼论中三义故也。以此三义通兼四悉。大即世界。多即为人对治。胜即第一义也。应具明三念与外人异。及以三念对大多胜之所以也。还将三念以对四悉。具如止观第十记。四韦陀者。如下第五经疏及止观第十记。次约教中牒前初释判属三藏。准前文故但云所敬等。前从今明下应义通偏圆。以前文中且对外释故云三藏。次大者下约后三教。初明多义但是约事。后三不可更加其数。但约所知以释其多。故前通释大多胜三。各具三义。故此后后渐优于前。约别圆者昔则从初。今从得记。别存教道。言大力罗汉者。罗汉中大。即无疑解脱也。次本迹中初述本三。次迹来下述迹中三。初明本大。次本得下明本胜。次先已下明本多。咨嗟者。谋事也。谋而方嗟非辄尔故。言胜幢者。借大品文。言超诸外道者。准理应云超诸偏小。但所超虽近能超则远。于理亦成。次迹中初示爱见即在乳味。故此五味通万二千。若权若实皆经历故。今从权者故云迹也。久矣下云云者。各有久本随本长短。中间设化今日亦在释尊诸味。观心中先直对三。次虽约中具大多胜。亦应更约空假各三。言一心一切心者。心境俱心各摄一切。一切不出三千故也。具如止观第五文。若非三千摄则不遍。若非圆心不摄三千。故三千总别咸空假中。一文既然他皆准此。故向五味义通上下。文寄此中。释比丘引肇公者。在净名疏。什及四子并在伪秦。故曰秦言。肇有四义。一净命乞士。二破烦恼。三能持戒。四怖魔。什公分之。一始三终。具二魔怖者。终中前二为怖魔因。引论者阙能持戒。破恶秖是破烦恼耳。故但三义而次第不同。及通初心令魔怖等。故破恶之言。且在身口非不断惑。既并在初令什义坏。岂以持戒破惑必在于终。又复肇公但翻其名而云名含。不云初后。今之学者安令魔怖耶。五系者。具如止观第五记。一田等者。田即农也。应云在家四种如法。更加工也。涅槃宝梁下明经义略虽复不具三义四义。破恶为本。今明此三义应通初后者。义当约教兼斥肇什。今非但以论文通后。复通诸教。况论但成因缘一释。若于此中立四悉者。怖魔即世界。乞士即为人。破恶即对治出界即第一义。依经家等者。义必通初证信必后。向释乞士中以求释乞。乃以离邪历境求定等。为三藏教者。未能于境即理故也。故至通教方云求真破障理等也。别教言八魔十魔者。破恶既深释魔须远。具如止观第八记。圆教中非不破八破十。但以实相为正破恶属旁。怖魔亦然。本迹中此诸比丘深浅莫测。故未可定判其位。迹示五味者。若不约五味非今经比丘。桎梏者。上质音足械也下古沃反。手械也。二谛如桎梏。大慧如解缚运念为无住望境为无著。故不着境智出二死家。乞士怖魔准释可见。云云者。中观既然。空假及以次不次等对教可见。众者。以一万二千事法和故。若作四悉者。初是世界众和合故。佛常下为人。生物善故。释论下对治。简恶人故。此中下第一义。在真实故。言事和等者。僧界法等俱属事故。法和者。如前七共同真理故。九十人三明者。中含二十九文同。舍利子问佛。五百比丘中几三明几俱解脱几慧解脱。佛答如文。三明者。即无疑解脱。具如止观第七记净命具如止观第四记。五方便者。四念处及四善根。五停非正观法故。苦法忍去者。世第一后有十六刹那。第一心去即名真实。偏圆五味者。五味不出偏圆。偏圆不出四教。言今正是等者。当证信时已获记故。引诸众生下云云者。具如玄文七二谛中委约五味。以明教意出其相状次约观中云若异等者。以依今经成观法故。若不依中道慧命观行。故名破十戒僧。不解究竟波罗蜜相。一心十戒诠量之律。名愚痴僧。五品六根名惭愧僧。初住已去名真实僧。亦合注云云。历前二谛十戒等及约四教。遍作观相。二明数中直尔举数。即是因缘。亦可于中义立四悉。数异世界也闻数生善即为人也。破恶入真准例可见不论约教者。教别数同故无异释。若随数生解即是教殊

问。凡诸列众及得道者。何故其数必全无缺耶

答。大论释大数五千分中云。若过若减皆存大数。本迹中云本是等者。问凡言迹者。皆先有本。岂万二千元皆是大权

若尔则唯有能引而无所引

答。理实如然。但欲均用四义故云皆有。然本不同事须分别。若已入圆位。能引之人成于发起影响二众。灼然本是菩萨。降斯已外曾发大心。亦名菩萨。元住小者。则是大经未曾发心。尚名菩萨。此中具有退大应化及元住小。退大住小得记之后并堪为同闻

问。三周授记人数不多。其不在会令为转说。此等又非同闻众限。何故此中云万二千

答。三周之中正数虽少。如舍利弗得记之时。四众八部即其流也。故三周中亦有应化与实行者。同时得记。故论中云。退大应化二种与记。即其意也。如菩萨众但列八万。分别功德记数盖多。故知大小二众列同闻众。不可望得记者也。约观中界入一一各十界者。正当妙境。诸文但寄能观观耳。山城虽约阴为所观。亦未结成不思议境。又将数入理数即成境。境观相对俱名法门。又境据假边且存其数。空中尚无其数安有。然必约假以立空中。观亦如是。明位中亦从初说犹名罗汉。准后皆成大菩萨也。即约教中圆位人也。于中先翻名者义当因缘。次揽因缘以成初教。初因缘中初明有翻中。阿跋经能所双标。应谓能应之智。真即所应之理。以智应理之人故云应真。次瑞应经虽似双标意指能证。真是所证。证真之人故曰真人。三义如后释。次无翻中三。初从果释。或言下从因。三若论下判名所从。初云后世田者。世秖是有。具如止观第六记。九十八使者。八十八上加十思惟。若作四悉者。初明有翻即世界也。于无翻中通因是为人。所从是对治。从果是第一义。约教中言不贼者。犹从二乘得名故也。若于圆别尚名为贼。是故须杀。不生于生者。取无为证生于界外。不生是生故不令生。供彼所应名为供应。如阿含中佛至阿兰若语比丘等。具如上观第四记。复应更分前之两教能杀法异。后之二教不贼亦殊。皆叹初地初住德者。前有翻家以三为名。次无翻家以三为义。义即是德。故约教中以三为德。若准入位不定。具足应云地住已上降佛已还。即约别圆叹本据复。次约本迹中二重。初约小三义。次约大三德。前寄迹名以申本迹。次约本名以通至迹。欲明名通义别故也。若约体用释者。前释从用以明体。后释从体以立用。又前释三义以通昔。后释三德而唯今。若久远本迹四俱是迹。今兼二重是故大小俱立本名。义势无尽故注云云。所以本是平等大慧无破不破。方能示迹诸教不生。本证解脱无贼不贼。方能示迹诸味杀贼。本得法身非应不应。方能示迹为应供耳。观心中先直以三德对三观释。以三德是境义可通观。次历观以对释名中三义。故一一观皆具杀贼等三。前本迹中则先对释名。次对三德。今先对德。次对三名。于中先空次中。中又二。先释三义。次引经证以指供养。叹名字观行位人功德深也。引方等文。具如止观第二记。下文云等者。法师品云。佛告药王。若有恶人以不善心。毁呰在家出家读诵法华经者。其罪甚重。具如下文。八风者。利衰毁誉称讥苦乐。四违四顺。佛尚久离无明违顺。况人间耶。失好时者。若生忧苦失道合时。大损下云云者。所以引方等及此经者。此二即是名字观行不生等故。乃至一切观行之文皆应引之。但于此中观行位便故。此中引法华论等者。彼论乃约一十六句。俱有三门。一上上起门以后释前故。二总别门以皆是阿罗汉一句名总。下诸句释上故下名别。今先准论用总别门。不用论文诸句。但依妙经五句以释。仍合五句以为三德。三摄取事门。论中具列一十六句。以释对事。论文但是将十六句以释五句。不云经阙。故十六句今文不用。从初别故。是故总约昔教叹也。三漏者。一欲漏。谓欲界一切烦恼除无明。二有漏。谓上两界一切烦恼除无明。三无明漏。谓三界无明。引二论一律者。成论约失利义通因果。律专在因毗昙唯果。以失利故因果俱失。良由下重释三失明失所以。初释失利由于业因。即成论意也。次造诸下释因招果即生死苦。因即律文。果即毗昙。次亡身下重释三句。由上三过失于三德。堕生死故亡法身。造业故失慧命。失道故丧重宝。意云。经中诸漏一句即是烦恼。失道等三相由而有。同名漏故所以引之。漏相如何。故于此下广辨见思。下诸句下皆破古人以释三德不当。亦应可见。烦恼下释次句。初句约因果相对。此句一向在因。使等者。使即九十八也。通为能使。堕落生死以为所使。流即四流。谓欲有见无明。扼名同流。缠即十缠。俱舍云。缠八无惭愧嫉悭并悔眠及掉举昏沉。或十加忿覆盖谓五盖。逮得者。逮及也。正为除惑故功德云及。言智断功德者。由前杀贼成断功德断必具智功成己利。由己利故故堪应供。次尽诸有结等者。举因果俱除明心得自在。罗汉但应结尽等者。有尽者非今所叹。故云但是因中说果。有谓报在二十五有生处。尽在不久者。纵如迦叶待后佛出。亦不名久。若罗汉皆以边际定力持此报身入变易者。佛身何故入涅槃耶。若言佛身权示。彼教何文云权示耶。一切罗汉若至法华无不回心。何故除四大罗汉十六罗汉。余皆入灭。肉身菩萨得无生者。应皆不灭。心自在句释于上句。二脱必漏尽因尽必果亡。慧脱虽退此生必得。俱解脱人必有慧故。故云具足。故以烦恼为贼生死为生。所以古人不了斯旨。故致谬也。故知句五德三法秖是一。依论总别释竟。次若依论用上上起门者。论意以初句释罗汉句竟。乃至以第五句释第四句。余不复释。准此乃以下下展转释上。故得名为上上起门。是则五句望罗汉句。亦成总别及上上起。本迹中初明五句是本三德。次迹示下指二乘五句三德是迹。初还依古为不生德。故本住秘藏示罗汉三德。涅槃是总以对不生。即初二句。烦恼字是烦恼尽句。漏流字是诸漏尽句。不复下释上二句。明离二边即本不生。法身下释本己利。上二句虽总举涅槃。今明涅槃是己之利。故须别述。此中二句上句明修下句明性。修性相对。智断对法身修三德也。实相两字性法身也。功德两字性二德也。本利修性具足示具二乘三德。得王下明本迹四五二句亦依古师为杀贼德。破有即第四句。我性即第五句。由烦恼贼破故也。王三昧者。玄文释二十五三昧各具四义。一诸有过患。二本法功德。三结行成。四慈悲破有。本地功德久已成就。本三德也。过患即是贼等三也。本三具足即结行成。本时应供是破有也。今却用古义者以无大失故也。故知已尽亦是不生尽结义通杀贼。八自在我亦名八神变。具如止观记及释签中。约观心中亦具五句。初是初德二句。能观下次德一句。正观下第三德二句。虽有烦恼等者。重释第三德中二句也。初释初句。不断下释次句。如无烦恼结尽也。而入涅槃自在也。约名字观行俱得名为如无烦恼入涅槃也。列名中初总为五。初现数。次立名意。三证立意。四消释意。五用义意。引证中多引阿含者。如增一中列四众名。各有偏好以引同类。一一四释下云云者。即因缘等四不复更列。然诸圣因缘多寄初教。以是感应之始故也。故诸圣初因并在外道。为破外故。在释种中为调伏故。为导为主而将引之。是故具明入胎立行眷属师友。若逆若顺能化所化。纵有始终计不转者。亦为后来得破之由。显诸圣者迹不徒设。一一无非感应故也。故四悉义一一应知。故彼增一比丘中列百人。有立斋建福。有营建房舍。有能调伏外道。有善供给疾病。有游行教化。有息事端拱。有好着好衣。有弊外无耻。有食无厌足。有语言粗犷。尼中列五十人。如拘昙弥尼头陀苦行。耶输陀罗降伏外道。俗中二众亦各有偏好。但诸圣因缘今文则略大论具存。事迹虽别皆是大权。陈如中初是世界。愿去为人。行去对治。太子去第一义。此第一义仍在昔教。但以教简进否无在。随事转释令顺四悉。下去皆然。其先事火者。虽事火者多。非初得道火不成德。故初得道得照烧名。破暗因灭物灭果亡。初虽未亡后必亡故。如人堕岩。无知乃是知无者。梵音倒耳。所知之无即真谛也。故引二谛中真也。次引二经一论者。本际秖是所知真谛。愿者出因果经。即佛为菩萨时本愿先度。次又迦叶下即是己愿。夫巨夜下为陈如兴类也。生死如世夜。日出故令觉。日光者。诸大罗汉及诸菩萨。故明星日光并破己身之大暗也。入山学道等者。中含五十六罗摩经云。佛在鹿母堂。告诸比丘。有二种求。一者圣求。二非圣求。圣求者。安隐涅槃。我为童子时年始十九。往阿罗罗迦摩罗所。问言。依汝法行梵行可不。答言。无不可。云何此法自知证。仙言。我度识处得无所有处。即往远离处修证得已。更往仙所述己所得。仙问。汝已证无所有处耶。我之所得汝亦得耶。即共领众。又自念此法不趣智慧不趣涅槃。宁可更求安隐处耶。是故更往郁陀罗罗摩子所云。我欲于汝法中学。彼答无不可。问曰。知自证耶。答我度无所有处得非相定。我久证得。便修得之。乃至领众等。复念言。此法不至涅槃。即往象头山鞞罗梵志村尼连禅河边。誓不起即得无上安隐涅槃。道品成就四智具足。次念谁应先度。念已宁可先度二仙。空中云。二仙已终经于七日。我亦自知。念曰。应度郁陀罗罗摩子。天又告言。终来二七。我亦自知。因复念曰。昔五人侍我劳苦。念已观于五人在波罗奈。念已便往。五人遥见自相约敕。沙门多求好食粳粮及[麥*酋]酥蜜。麻油涂身。今复来至。汝等但坐。预留一座莫请令坐。及至到已。语曰。卿欲坐者便坐。五人破制于中求水者敷座者。坐已先教二人。三人持食来六人共啖。次教三人。二人持食来六人共啖。而便语之。有二种行。一着五欲。二着苦行。离此二边是名中道。次为五人说譬喻。次为说四谛。五人得无漏。多论说佛为三二人说法。去住不等者。由三是父亲二是母亲。欲彰乞食事办故也。及知说法不空。准婆沙中日初分为二人。则六人共食。日后分为三人。则五人共食。以佛性离非时食故。尔时未为弟子制非时食。经三月教化。或云四月。余如论文。云三父亲者。谓马星摩男拘利。余是母亲。初见佛道相等者。初见在陈如为后人前相。应云。佛如鼓机缘如椎法轮如声。初闻者。五人俱初。陈如初悟故云初闻。香道品也。昔机如身法轮如香。初悟名服。甘露灭理也。法流即初果。登真即见谛。分别功德论云。佛最长子即陈如也。最小子者即须跋也。今未受化是故不论。约教中应辨教殊但明观异。从观判教理易分故。故委以观而分别之。况万二千陈如居首。无生乃是诸观之宗。欲令闻名识行例人知心。故大师叹古章疏云。恨不见其面。但恨不见其人。今见其文则见其心矣。今如是等虽不见人。乃见其智。初三藏教人不了像虚。故用阿含盲为譬也。初总立譬境智。次头等下譬境因果。如六分和合成身。如和合成业。业托父母如形对像生。像必不实由谓实故。令后阴起。盲如无生智。不见如不取。三若开眼下明生不生。于中初由取因故果生。次若闭眼下喻不取因故果不生。镜是助因得果。复由执心缘之。方助于因而生于果。下文准此。于中二。先总次别。初总标不生。次不见下总列因果不生。次故阿含下别中三科为二。初观阴。次入界。初观阴中二。先明阴生为境。次若能下无生观智。初又三。法喻合。法中义带总别二境。谓因计色净余四皆净。乐等亦尔。是则五阴皆净常等即总境也。此中想行应云乃至受。识应云乃至想行。文且一往。次观中三。初正明用观。次既知下明观成破惑。三如是下准因破果。初文又三。法喻合。应知镜譬若不对盲本在衍门。亦可通用。具如止观第五记。初法中二。释结。释二。先别。次又能下总。悉皆无常等。知色中少无我字。是为下结。如盲下譬。是为下合。次既知下明观成破见。此中即破二十身见。次如是下准因破果中有法喻合。次观入界中先双标入界。次正释。释中先更寄此便明因缘。故知前阴即念处观属四谛也。于中亦先大海以喻境生。次云何下以苦种喻观不生。初境中先约入次以界例。初约入中先约眼色二入广明。次耳鼻下举十入例。初约眼色中具列十二因缘。初无明中喻文在阿含中。五疱者。手足及头。例中少五尘。次观中二。初入。次以界例。入中二。先明眼色。次以十入例。初眼色中三。初略明不生。次云何苦下反以生释。三若知下正明用观。初略观中乃以臭种用喻因缘。既以贪恚念欲为苦种牙即无明。又以取尘善恶为臭汁蝇蛆是行。此二不生故十不生。阿若最初下结。如文。通教观中以境即故不先立境。亦先阴次入界。阴中亦先总次又观下别。总谓总以镜像喻五。别谓五喻各别譬五。并先喻次合。初总中先约色阴。次以四例。亦如于巾求兔叵得。人之与镜皆云幻者。因缘各从因缘生故。实因实缘和合所生尚自如幻。况幻因缘所生非幻。如巾如药于兔名实。兔于巾药名之为幻。镜像亦然。况今先见因缘如幻像非幻耶。细推具如止观第五。今且略辨令知观别。故不广论。今亦具有二空。次观根尘下观界入。亦更寄界入以明因缘。故云无明等。于中又二。先推根尘无明。次烦恼下推三世即十一支。各有喻合。初喻中云根尘聚落者。文在大经二十一。复以机关释成根尘和合义也。经云。譬如有王以四毒蛇盛之一箧。令人养饴瞻视卧起。若令一蛇生嗔恚者。我当准法戮之都市。其人闻已舍箧逃走。王时复遣五旃陀罗拔刀随之。密遣一人诈为亲友。而语之言。汝可来还。其人不信投一聚落。都不见人求物不得。即便坐地。闻空中声。今夜当有六大贼来。其人惶怖复舍之去。乃至路值一河截流而去(云云)。合云。蛇若害人不堕恶道。无三学力必为五阴旃陀罗害。若不识爱为诈亲诳。观于六人犹如空聚群贼住于六尘六入。欲舍复治烦恼驶流。应以道品船筏运手动足过分段河。十住未免唯佛究竟。经文本喻三乘始终。今喻通教声闻观法。言机关者。机谓机微可发之义。关谓关节假人而动。故凡结身口皆由意动而成作业。既云聚空即本空也。言云云者。界文乃略。具足如前三藏教明。一往且然。若委修观非此可了。次别观中亦先喻境智。若欲下起行也。初中先立境智。次青下明境体量。三皆于下结意。初立中先境。次观。境中初云镜喻法界者。通以迷悟事理始末自他同依一法界也。真如在迷能生九界。即指果佛为佛法界。故总云十。是故别人覆理无明为九界因。故下文中自行化他皆须断九。九尽方名缘了具足。足故正因方乃究显。次体量者。此中但以青等八法喻十界者。或离或合随便为言。故合二乘及以人天。复略修罗仍开菩萨。亦可初地为佛法界。诸文开合随义准知。又青黄等别人初心与藏不别。故得借用正法念喻。但加长短等耳。言皆于镜中者。不出法界。法界不出迷悟。迷悟不出于心。次起行又五。先示自行化他分齐。以别教中无性德九。故自他断别修缘了。而严本有常住法身。次依于下依境起行。亦指但理为九界覆。而为所依。法界秖是法性。复是迷悟所依。于中亦应云。从无住本立一切法。无明覆理能覆所覆俱名无住。但即不即异而分教殊。今背迷成悟专缘理性。而破九界。三次第下明因灭。四若无下明果灭。五生亦下总结因果双明不生。即界内外二生不生。俱不生也。化物横辨文阙不论。次圆观者。先喻。次合。喻中言观镜者。一法界也。团圆者。理境智也。观即是智。团圆是境。次不观下明观相。背即无明面即智明。镜十界因。形十界缘。像十界果。又镜明性十界。像生修十界。故形像修性皆具十界。并不出于法性理镜。见明形像修性本如。镜内外一离于三教分别情想。总以不二无分别智。依理通泯心境明暗。故云不观。观境不殊。理无明暗故云非背等。约修得说故云不取等。次但观下结意中。但是总略出其观相。不谋而照但观团圆。无始终故故无际畔。本有故无始。常住故无终。明暗如前。无一异者。双非像无像也。不取下合也。初不取者。泯前十界。善恶六界也。以六对小故云邪正。以菩萨佛用对于小。故云大小。一切并泯故皆云无。不复分别若性若修。但缘下泯前心境。以法性实相即是三谛三观。一切佛法之大都。若泯若照无非法性。法性之体离泯照故全泯照是。观烦恼下。明观体秖观三道。生即苦道。三道即是三德。于中初总明立观。从阴入界即法身去教用观法。本观理是不观染除。染体自虚本虚名灭。故妙体灭不立除名。障体即德不待转除。故云生即无生。次解脱即业等结成无生。次是三下复疏总结。次况变易等者。以重况轻。界内重障尚即妙德。况界外轻耶。今仍约底下三道。若具论者。应约诸三法也。此中圆观不同藏别先境次观者。若法若喻皆不二故。语虽似通观境别故。所以释陈如中教相约观。其义广者以最初故。若闻阿字解一切义。下去诸圣虽随事别。论其观行不出无生。如头陀抖擞乃至密行。亦何出于智断无生。故下去文准此可知。言云云者。应具须十乘十境及方便等。全指止观一部文也。故止观破遍中亦以无生为首。故今略示大纲。若于阿若权实始终不迷。欲以圆观消今经中五佛三周本迹流通。无非无生之大体也。则能兼识一代观境。故于名下略指方隅。秖如世人为子立号。尚有所表。况诸圣者岂应徒然。若不然者。则唐设无生之名。永无无生之旨。大小混滥权实杳冥。此一既然余例准此。本迹中初约五味正示本迹。此中阿字显遍八教。次众生下劝物思齐。则五时功毕。次非本下明不思议体用功毕。故下文下引开迹证。种种之言亦不出五时八教。又随本长短凡经几度。为五时八教示不生来。引阿含者。引迹证本。寄迹中本迹示其尊卑。本地高下非此可悉故。杂含三十一佛在舍卫。夜暗天小雨时告阿难言。汝以盖覆灯随佛后行。阿难受教至一处。世尊微笑。阿难白佛。佛言。非无因缘。汝今持盖随我而行。我见梵王持盖灯随陈如后。帝释持盖灯随迦叶后。乃至毗沙门天王持盖灯随劫宾那后。所以偏于通序中如是乃至诸圣弟子。具四释者。以如是通指一部我闻能闻一部。时处教主必无异途。咸是斯经之大略。况诸弟子在大在小。若显若晦为主为伴。示讷示辩有屈有申。厌外欣内背大向小。引小入大会偏归圆。自因之果。皆为众生作种熟脱去来今益。所历既多时处不一。良由机缘生熟未等。今既咸会。以昔望今令成今教人法俱美。故用四释令了机应从外至内。后入法华本迹两门先后悟入。皆藉引导影响发起。随闻一句若人若法。皆成化仪悉可为观。故于一人遍须众释。况令后代闻名起行。禀教识体思迹睹本。寻其因缘广照始末。若得此意于一人所。于经一句。可以为上求境。可以识下化机。可以晓圣者化仪。可以了凡众禀益。可以达名义同异。可以知行等理殊。可以知随闻成观。可以解迹本人法。可以信化事长远。可以仰圣恩难报。可以知众生难化。可以知会理至难。他不见者谓为繁芿。况得今意。凡闻诸经一法一事一人一行。则解十方三世佛事。唯除净土余尘施化。况复亦以比丘思之。故知诸土诸佛用教现身虽复不同。然思修之门其理无别

法华文句记卷第一(下)法华文句记卷第二(上)

        唐天台沙门湛然述

迦叶缘起传中最广。岂可具书。迦叶是姓故云氏也。负图者。如此方河图。十二游经云。佛成道第三年始度五人。第四年化大迦叶及三兄弟。第五年化目连身子。聚落多人所居。但胜人当名。畏胜王者民物不合胜王耳。三舍者舍此已下是也。后时佛语等者增一云。佛在迦兰陀与五百比丘俱。时迦叶乞食前至佛所。却坐一面。佛言。汝年老长大志衰根弊。可舍乞食及十二头陀。亦可受请并受长衣。迦叶曰。我不从佛教。若如来不成佛。我作辟支佛。辟支佛法尽寿行兰若行。佛言。善哉善哉。多所饶益。若迦叶行头行在世者。我法久住增益人天。三恶道灭成三乘道。十住婆沙。十二头陀一一各具十种功德。广在第十四卷十二头陀品中增一四十六在增十一文中。树下露坐合之为一。故知法相不可一准。大论四十九。说无生忍为十二头陀。属通非藏。故今约教极在涅槃。有无同异具如止观第四记。四神三昧者。四神足定也。由四神足有此四用。无形者。能隐没故。无量意者。知他心故。清净积者。能变秽故。不退者。能入恶故。言四定者。此是必定定得诸禅及以无漏。能善简择戒法具足。由是诸事得无退转。文陀竭王者。顶生王也。天人咸等者。增一云。迦叶闻天人称为佛师。起鸣佛足云。佛是我师我是弟子。又迦叶下如别译阿含第二十云。佛在迦兰陀迦叶共阿难。入城乞食。阿难云。日时未至。且往比丘尼精舍。迦叶如言。诸尼遥见来欢喜敷坐具竟。迦叶即为尼说法。时偷罗难陀心不甘乐。即私云。长老迦叶在阿难前说法。如贩针儿至针师门求欲卖针。终不可售。迦叶亦尔。在阿难前而说于法。迦叶天耳遥闻语阿难言。何足可怪。迦叶于比丘尼前作师子吼。从座而起即还所止。今文从迦叶语尼言去文。即迦叶师子吼文也。又别译阿含乞食法。从家至家不足便止有云。至七家不足便止。四大弟子者。迦叶。宾头卢。罗云。军屠钵汉。文列七大。若并本族大及诸天恋慕为慈悲大。合为九大。若以此为四悉者。姓及舍受即世界。三行大即为人。闻名睹行皆生善。故第四印可即是对治。以佛印可息疑怪故。位与慈悲即第一义。见理入位故。集法持法并入位之功。集法中引肇公者。明集法功多。又文中位大者。不独论无学位也。以德高望重所掌职大。云云者。因缘纵多并为四悉摄尽。次约教中先约事境。次且约下乃约谛观以分教别。事境中云离五怖者。王贼水火恶子。二是衣等者。从初次第以数对之。但文中阙次第乞。下之三教并以初事为境。说者须委解。十二头陀各作八十八使三十七品等。头陀既尔况余劣行。忝预道流闻此胜法。而不自省心行耶。相似相续者。念念生灭迷谓相续。凡夫不了妄谓为常。三受俱苦适意之受。其实苦也。动非自在动故无我。通教者。事境指前。但约行相以辨谛观。亦应可见。别教法身为所依者。期心法身修二德故。文后云云者。不委明横竖位位抖擞。别位横竖自他门户不可卒备故也。圆教既云住处即二。验知即是本有三德。修得亦然。一即一切等者。不出三德。一即一切行衣也。一切即一慧食也。非一非一切身处也。云云者。未明行相且对头陀。约本迹中云舍法爱者。既云与如来同得。即舍真似两爱也。乃至随在何地。地地离爱。故论久本本地三德。迹示五味头陀事中衣等。凡释本迹大旨。如前明数中辨。观下云云者。亦不暇具述诸观次第。圆头陀者。正当不生不生之三德也。故下三人复对三德。其理宛同。刹者。应云刹摩。此云田。即一佛所王土也。今名刹柱者。表田域故。故诸经中多云表刹。若欲明四悉者。初是世界族姓住处不同故。毗婆尸下为人也。共立刹柱以为善因。佛作下是对治。见佛即能除恶故也。佛即语云下第一义。能于小乘见真理故。佛作十神变者。文中一往且列十事。然律论文不专此十。又文中虽列事未委悉。增一瑞应广明其事。今略出之使文可见。增一云。佛入迦叶窟毒龙放火等。佛收毒龙住于钵内。至迦叶所迦叶请住。三月供养。时至请食。佛言。前去。便往阎浮树取阎浮果。乃至云。沙门虽神不如我道真。次往东弗婆提。取毗梨勒果。次往瞿耶尼。取呵梨勒果。次往郁单越。取自然粳粮(皆如前云沙门等)又于阎浮提。取呵摩勒果。欲作大祀。五百弟子欲破薪斧举不下。迦叶问佛。佛言。欲得下耶。斧即下。下又不举(如前)。欲然火火不然。欲灭火火不灭(如前)。迦叶念欲大祀。必有诸王贵人来。瞿昙端正。若人见者令我失利。若明日不来我则大幸。佛知已且往北方取粳粮。瞿耶尼取乳汁。往阿耨池食暮还石窟中。迦叶问。昨何不来。佛言。我知汝心我不来。具为说前事。又因四天王来听法夜有光明。明日问佛佛具为说。次帝释梵王来亦尔。迦叶问能令我祖父来听法不。佛便令来(云云)。恒水卒长。迦叶恐佛为水所溺。使弟子往看。水不没足在水上行(如前)佛言。汝是盲人目无所睹。如是神变固云道真。佛云。汝能水上行不。今方共水上行(云云)。汝若不舍邪见。令汝长劫受苦。闻已头面礼佛求悔。乃告弟子合随所宜。我师世尊。语弟子言。我见降龙时已有心归佛。乃至五百弟子皆闻善来得成沙门果。并以术具投之于水。随流而下。二弟复有五百弟子。见火具下(云云)。亦皆善来以成沙门。佛欲至迦毗罗卫。问佛。何以至彼。佛言。一切诸佛俱有五事。一转法轮。二为父说法。三为母说法。四当导凡夫立菩萨行。五授菩萨记。是以至彼为父说法。父王因令千释出家。以自围绕。约教者。亦应具列四教解三人行德。而列五味者味摄教故。约本迹中以三人对三德者。圆德必一人具三。但一人偏从所表一德为名。既是共表体同性一故也。观中亦尔。初得中道次遮边倒。后照边谛。故知三德即不思议圆无生也。释舍利子引生经等。亦具四悉。初是世界以明宿世及胎中故。难陀下生善。以令国人生信及见頞鞞能生善故。调达下对治。能治调达及度差故。中含下第一义。叹与佛等故。昔者等者。彼经五卷。出第一卷。今更略出令文可见。彼释着我所中云。昔无数劫甥舅俱为官御织师。见藏中好物便生贪心。即共议云。吾等织作勤苦。具知藏物好丑。宁可共取用解贫乏。后人定间盗得无赀。监觉白王(下如疏文)后时复来。甥语舅言。舅年衰弱恐为守者所得。令从地窟却入。如他人见我力强壮便能济舅。果如甥言。甥知不济恐明人识。辄截头留身而去。王令弃尸(如疏)王令微伺伺之不密。甥因教童儿执火舞戏猥闹投火。伺者不觉(如疏)王复出女严饰玑珠。安置房舍于大水边(如疏)王先教女(如疏)女执其衣。其曰。用执衣为。汝执我手。其甥凶黠先备死人(如疏)王曰如此方便无双当奈之何。女妊娠十月生男端正。使乳母抱周遍国界。令有鸣者捉之。终日不获。甥为饼师住炉下。小儿啼哭。饼师与饼而鸣。乳母白王。王云。何不缚来。乳母曰。儿饥饼师与饼不意是贼。王又令如近儿者捉来。甥又沽醇酒唤乳母及伺者饮。伺者大醉盗儿而去(如疏)前后各二百五十骑。甥在中央不下。王因往入骑中捉之云。汝是前盗不。前后捉汝何不得耶。稽首答曰。乞此余命。王曰。卿聪黠天下无双。随卿所愿(如疏)兼则相不祥者。在道以相则之。所则之相凡属己者。皆悉不祥。师事沙然梵志等者。增一云。舍利子与目连二人求道无克。乃问师。师云。我自历年求道无克为道无耶。他日师疾。舍利弗在头。目连在脚。命欲终时乃笑。二人俱问笑意(如疏)二人笔受(如疏)由是发誓。若得甘露必与共尝。中含第二至宁可尽者。彼七车喻经云。舍利子见满慈子(如疏)彼第二七法品中。广述缘起。言生处安居者。经云生地即本生处也。生处诸比丘白佛。称说满慈子等(如疏)白晢(音析)光悦也。若析音美色也。二义俱通。戒净等者。准净名疏云。戒净者正语业命。心净者正精进念定。见净者正见正思惟。断疑净者是见道。知道非道净者亦名分别净。道迹知见净者亦名行净。此二是修道。道迹智断净亦名涅槃净。即无学道。至约教中方分教别。后二须用同体见思。此以有余称无余者。七净始从事戒终至智断。皆是有余。报终入灭方证无余。七净乃是无余之门。若即以七净为无余者。故知乃以有余称无余耳。无余必假七净。方至。故云离七亦无。拘萨罗者。舍卫。婆鸡帝者。地名。未知里数。作师子吼者。杂含舍利子师子吼经中。佛说一句义三问身子三不能答。佛少开已入于静室。舍利子集诸比丘。语言。佛未示我事端即不能答。我于七日七夜演其法而不能穷。佛命目连往祇洹唤身子等者。佛在阿耨达泉五百比丘俱。阿难侍佛坐金莲华。七宝为茎。五百皆集。时龙王云。此众空缺不见舍利弗。愿佛遣一比丘唤。时舍利弗在祇洹补故衣(五纳只是杂色)舍利弗曰。汝先去至彼我即来。目连云。汝神力可胜我耶。乃令前去。目连曰。若不时去吾捉汝臂。将向彼泉。舍利弗言。目连试弄我。舍利弗即解衣带着地。语目连言。汝能举此衣带不。然后捉吾臂将去。于时目连念。舍利弗轻弄于我。目连曰。此必有意事不徒然。申手取带不动一毫。尽其神力亦不能动。舍利弗取带系阎浮树枝令举。时阎浮提地一切皆动。舍利弗言。目连尚能动阎浮提地。何况此带。今当系余天下。乃至三天下皆能动之如动轻衣。次系须弥山小千中千大千。皆能动之。是时天地大动。唯佛座及阿耨达池不动。龙王问佛。何故地动。佛答(如疏)龙王曰。谁神力胜。佛言。舍利弗胜。龙王曰。前何故云目连神通第一。佛言。目连能住一劫。舍利弗住多劫。他云边际定者。秖此定耳。舍利弗入三昧目连不知名。舍利弗复作是念。目连动于大地。蠕动死者无数我躬闻佛说如来座者不可移动。今以此带系之。目连复举所以不动。今云他方佛座脚小异耳。目连自念。不于神力有退乎。欲往佛所而问其事。目连舍至世尊所。遥见舍利弗在佛前坐。又念。佛弟子中我神力第一。然今不如舍利弗耶。便往问佛。将无不失神力耶。我前发今在后到。佛言。汝神力不退。但舍利弗所入汝不识耳。龙王闻此甚大欢喜。诸比丘私论。佛弟子中目连神力第一。今不如舍利弗。便于目连起轻薄心。佛告目连。汝现神力。目连礼佛即于佛前。往东方七恒沙界。佛名奇光。往钵缘上行。彼众见谓虫示彼佛。彼佛云。西方七恒沙界(云云)。彼佛令现神力莫令诸比丘起轻想。乃至令钵囊盛五百等着梵天。一足蹋梵天一足蹋须弥。说偈声满祇园。诸比丘闻不知所在。问佛。佛言。在彼界(云云)。诸比丘白佛。令目连归(云云)。彼比丘欲来。佛令将来。佛为说六界法令还目连送归(云云)。如般若中说者。彼经富楼那说破菩提见。故是通意。诸贤圣自说己法等者。此中释通教。因引般若共菩萨行必破菩提法轮等见。方名菩萨。故引诸大乘经中凡诸菩萨自说己证。皆为利生或对佛述解。非如凡夫自谓己见而称己能。故云妄有所说。释目连中。吉占等者。父名吉占。其父初生时相者占之言吉。因以为名。目伽略兮度五字。并是西音。故论第十释如来语密中。引目连寻声。彼佛告云。目伽路子度何故来此。目连乃答言等。乃是彼佛称此五字而命目连。即是二土音轻重耳。文中路字者误作略字。子字误作兮字。同名者多者。如中含三十五云。有算数目连。善知算法。彼经佛在舍卫鹿母堂。算数目连中后仿佯。至佛所问讯。却坐白佛。愿有所问。佛言。恣汝所问。乃至云。我以算法存命。归佛出家存本俗业故云也。瞿墨善知法相目连不一。故别标大。见贵与取重文语从异其义一也。皆以德行重之耳。舍利弗才高而智明。目揵连族豪而神爽。爽亦明也。艺谓六艺。略如释签。然西方智艺有殊此土。以有得禅者故。故四韦陀所摄甚广。此中因缘亦具四悉。初是世界。释论去为人。外道下对治。涅槃下第一义。左面弟子者。所以以身子目连为转法轮左右弟子者。通因定生即定慧一双。以此二法为一切法之根本。亦是福慧一双。悲多现通亦是悲智一双。成破法轮准此可知。簸峨者。倾侧貌也。有作[跳-兆+叵][跳-兆+我]有作[跳-兆+叵][跳-兆+我]。并不见所出。准文选江海赋云。阳侯砐硪以岸起。砐字(五合切)今作簸者。扇动意耳。难陀等者。增一二十八云。佛在给孤独园。帝释白佛。如来在世应行五事。母在三十三天须行说法。佛默然受(云云)。于是便往(云云)。龙嗔放火大风阎浮提洞然。阿难白佛云何有此大烟火耶。佛具答。迦叶那律等各起白佛。欲降此龙。佛皆言。此龙力暴难可化度。卿可安坐。目连白佛。佛亦止之。又问。汝云何降。答言。先以极大身恐怯。次以极小身钻啮。然后以常身降之。佛言。善哉。汝能堪任。佛复诫言。固心勿乱恐为所娆。目连礼佛足至山上。现十四头绕山十四匝。龙见恐怖自相谓言。我今试降为胜我不。二龙即以尾掷大海水不至忉利。目连以尾掷水水至梵宫。并洒二龙。二龙知劣极大嗔恚。雷电霹雳放大火焰。目连自念。夫龙斗者皆以烟火霹雳。设我亦尔。阎浮叨利悉皆被害。乃化为小形(云云)。二龙伏退。念言。四生龙中无出家者。此龙威力乃尔。身毛皆竖。尊者知龙心伏。乃复常身于龙眼睫上行。二龙于是始知非龙。叹曰。甚奇甚奇。白目连曰。何为相恼。何所诫耶。目连曰。汝昨有念云此秃沙门恒飞我上耶。龙曰。如是。目连曰。须弥山者是诸天路。非汝居处。龙曰。愿恕其过。从今已去愿为弟子。目连曰。汝莫归我归我所归。龙曰。我归如来。目连将二龙至舍卫。目连曰。世尊今为无量大众说法。莫作汝形。龙曰。如是。乃作端正人佛为说法为优婆塞。时波斯匿王来问烟火事(云云)。佛具答(云云)王见二龙不起。二龙嗔复念。国中人民于我无恶(云云)二龙便于匿王宫上现大霹雳等。尊者变为优昙华。龙嗔复雨大山。复变为饼食。龙倍嗔而雨刀剑复变为好衣。龙更嗔复变为七宝。匿王不知。便云。阎浮有德不过于我。宫内常有如是等物。当作轮王乎。龙又自念。何无势力一至如斯。念已始复知是目连之力。见已便去。王得七宝饭等不敢自受。将至佛所以事白佛。佛令供养目连。王得目连力。王问。何故尔耶。佛具答。王方知(云云)。调达引五百等者。增一四十七云。佛在拘留园。时提婆达兜三白佛欲出家。佛再不许。便作是言。此沙门怀嫉妒心。我今宜自剃头修梵行。何用是沙门为。有一比丘名修陀。头陀乞食。达兜往彼头面礼足。愿教威仪。比丘便教次从学通。此比丘教云。当知心意识轻重。知已复知四大轻重。知已当修自在三昧。次修勇猛三昧。次修心意三昧。次修自识三昧。如是不久便得神足。依言修习名称远闻。至三十三天。采优钵罗华上太子膝上(云云)广受供养欲破僧行舍罗等。具如止观第一记。时舍利弗目连自相谓曰。试共往彼听说何等。彼见欢喜谓来归之。一切诸人咸有此念。语舍利弗。汝能为诸比丘说法不。我今背痛便累足而卧。舍利弗为说法已。目连将诸比丘去(云云)后因造逆(云云)为火所烧遂入阿鼻。阿难问佛当生何处。佛答(云云)。杂含二十九等者。彼文甚广。又增一四十四亦云。佛在给孤独。阿难问佛。如毗婆尸佛弟子几时生瑕秽。佛言。初八万四千年。后八十七六三二十至十二。次第对七佛。帝释与修罗战。具如止观第五记。佛梵声深远如止观第一记。佛求侍者。如止观第六记。约教中十四变化者。具如释签。故以十四变化释四禅耳。此乃一切罗汉并得。次观等四俱解脱人方乃具之。以具观禅必得灭受想定。次十一切欲令神通广普故耳。练熏修如止观第九及法界次第中。十一切具如法界次第。事禅具如玄文及次第禅门。十八变如止观第十记。又有人云。十八变者谓震动等。今为颂曰。震动及炽然。流布与示现。转变及来往。卷舒众像身。往同趣隐显。自在并制他施辨与忆念。施安及放光。又有人云。身上出火等。依空起慧者。空即谛境。依境生智通属智性。故云以空慧心。次第等者。三谛功用通名神通。初地已去别名感应。三谛次第故云深入。独菩萨法故且云过于二乘。其实超于两教三乘。言不以二相等者。不二即实相。见土即神通。依理而见故云不二相见也言云云者。令分别之。前二修得后二发得。藏依事禅通依真理。别地前助圆任运发。前二名通名化。后二名密名应。前二调伏物后二见物机。前二可破坏。后二不可坏前二在教道。后二在证道。前二身通唯现在。后二通三世。前二圣位方修通。后二凡位俱修通。前二随依皆可修。后二必须有胜依。愿得通应在前文因缘释中。然亦可以四愿表教。今文中初教从事通教从真。后二在理故从容在此。言云云者。更有多缘皆在愿得。亦有不愿任缘得者。即如那律箭挑灯缘。引令入极云云者。分别五味如前。观心中欻有等者。三观意也。实相是中境。无有无心契中境。故云通至。次释旃延中。初因缘具四悉者。初是世界。增一去为人。与外道论对治及第一义。断见及世典各有破邪及得道故也。言文饰者。善赞咏故。言扇绳者。若作肩乘二字并误。以其生时父已去世。此儿碍母不得再嫁。如扇系绳。亦可言好肩好肩胛故。言思胜者。思是慧数。论义功强得思胜名。所引长含十重问答者。借彼迦叶童女比丘破弊宿文。以之为例。计断者计死后神灭。故以不灭为难。若计常者反增其计。故应别以念念不住破之。第一重中言今之日月等者。初反质答者。如今日月为自立耶。为为他耶。若为他者为天为人。秖缘天人他故。故有明日。若无他世应唯今日。若无明日亦无昨日。以今日即是昨之明日。言析薪者。具缘有火如有神。缘谢无火如无神。岂析无神之身而能见神。如析阙缘之本。而欲见火者远矣。言贝声者。人身是色为眼所见。神则非色云何可见。如贝可见声不可见。若欲于可见中求不可见者。须更具缘缘既阙已更反转求。终无得理。神亦如是。缘具在身缘阙神去。至第八番无理可难。但云执久拒而固违。第九答中两商人者。正邪二见。鬼如汝师。汝师虽僻亦假称智。故诈为人像说邪干正。以邪涅槃而云安乐。故云前路丰米草也。旧米草者。世正见也。新米草者。出世正见。人是能乘行者。牛是所乘之智。信邪师鬼言如汝弃旧。尚失人天况复涅槃。故云人牛皆死为邪所啖。坏世出世故云皆啖。次一商者。世正见人得出世正见方弃人天有漏诸法。我说正见汝何不弃。辞理既穷固拒亦息。又世典者。增一第八云。佛在释翅尼拘留园与五百人俱。集普义堂。时世典婆罗门往释种所。作如是言。诸君颇有人能与我论不。诸释言。此中二人正觉众中无黠无闻。言语丑拙不别去就。若与论者当供与千两纯金。世典心念。此国中人多诸虚伪。设得胜者何足为奇。或得我便乃为愚者所伏。思是事已。乃云。我不论。语已便去。道逢槃特。世典念言。我今当往问彼人义。便往问曰。汝字何等(如疏)迦旃延天耳遥闻。作槃特形而语之曰。汝若言我但有神足不堪论者。吾当报汝向义。更引喻汝汝字何等。世典曰。梵天。又问。丈夫乎。答丈夫。又问。人乎。答是人。又问。人亦丈夫岂非繁重。盲与无目此义不同。世典曰。何名为盲答犹如不见。今世后世生者灭者。善业恶业不如实知。永无所睹称之曰盲。云何无目。答即是无有如上智眼。世典曰(如疏)又问。五阴有缘生无缘生。答有非无缘。又问。五阴何缘。答爱为缘。又问。何者是爱。答生是。又问。何者是生。答爱是生(如疏)世典闻已得果。命终槃特报诸释令办薪而阇维之。为起偷婆。又长含中外道诸计甚广。如云不得手障形不得两臂中间食。二人中间食。二刀中间食。二杵中间食。二家中间食。又云。先言义者不得食。不得两器食。一餐一咽至七餐止。更益不过三度。或一日一食二日。或至七日一食。食米食菜牛粪鹿粪树根华果等。自落者食。或草衣树衣毛衣皮衣莎衣留鬓留须等。当举一足常坐座(今世已有)常蹲卧棘卧粪卧瓜。三日一浴一夜三浴。如是等于我法中名不净法。如是等略须识之。比有执专坐者。未契大道。言专坐者。以不卧为功。不以不行为德。岂有居暗室。乃四仪同凡。睹来众则端拱若圣。君子之行尚阙。菩萨之道永亏。自任胸襟无教可准。使后辈不鉴者许之尚之。睹行动者。轻若刍芥佛犹四仪动作。岂未学者过之。夫道在心不在事法。由己非由人。既不能缩德露疵且显晦均等。约教释中皆云破断常者。凡云论者。以破邪为先。故各于当宗以立能破。依总持四辩者。且以俗谛三昧而为总持。四辩者。具如法界次第。以药逗病破断常者。入爱见假先破断常故。又破断常有二种义。一以诸观共破界内见惑断常。则四教皆以见惑为境。具如止观第十。二者展转长短不同。则三教皆破界内见惑。唯有别教先破界内断常。次破空有断常。后破空假断常。圆教一念破三断常。观心论义中言往复者。智研境为往。境发智为复。数观数发数往数复。释阿[少/兔]楼驮中。种姓等广在贤劫等经。大论亦广释。姓刹利也。若言瞿昙者。具如下述。若作四悉者。初是世界。仁贤劫下为人。那律下对治。佛广下第一义。言无猎者。免非猎得故云也。具如后文。稗饭虽轻以尽所有及田胜故。故得胜报。亦可于此广明施相。但于此中非急。始民主至善思者。善思生懿摩并及四铁轮。合八万四千二百一十王。具如律中。言草创者。草亦初也。如布衣初遇。汝当解王衣者。令脱王服被瞿昙衣。使随师姓。此方古俗皆从师为姓。如竺道生本不姓竺。但事竺法汰为弟子耳。自安公来令同一释种。译十诵律乃见其文。律云。四河入海无复河名。四姓出家同一释种。四子被猜者。是次母之子为长母所猜。贤愚经者彼经具列宿昔施食遇兔等缘。略如今文。眠是眼食者。如止观第四记。佛与八百为作衣者。佛在舍卫。那律语阿难言。倩诸比丘作三衣。我衣坏。阿难房房语诸比丘。又往娑罗逻岩中俱萨罗梵音不同

诸比丘如言。佛见阿难问言。汝作何事。阿难具答。佛言。汝何不倩佛。佛与诸比丘为舒张截割。诸比丘缝一日即成。因说迦絺那(云云)。约教中两重者。初重论发。次重论修。四教通论发者。意明修成。虽少不等大体不殊。肉眼虽失天眼复成望后故论次第不次第。具如止观第五记。亦应明开显等。此中正明天眼兼明四眼耳。观心中不云慧眼者。阙耳。应云观因缘定心。即天眼空心即慧眼。释劫宾那中。初是世界。是比丘下为人。中夜下对治。豁然下第一义。祷星等者。尔雅云。天驷房。注云。龙为天马。故房四星谓之天驷星也。即东方七宿中第四宿也若准西方宿复不定。具如止观第十记约教中皆云栖者。依如来所证处。以释宿也。则当教明佛分齐不同。释憍梵中初文含四悉故不分之。至后自结。翻牛齝者。过去世时曾作比丘。过他粟田摘看生熟。后五百岁作牛偿之。今得无学尚有余习。结四悉名在中间总释前后文也。故又云去。重释前四悉意也。次佛灭去重更别释第一义也。水说偈者。论云。憍梵般提稽首礼。妙众第一大德僧。闻佛灭度我随去。如大象去象子随。约教中皆着示者。若作垂示义兼本迹。若作教示正当约教。约观心中正用丈夫牛王。而通取白牛引驾。释离婆多因缘中。初是世界。假和合去为人对治。增一去。第一义。故且约争尸一缘秖具二悉。若依争尸缘自具四悉者。假和合世界也。易度即为人。问人即对治。闻说即第一义。二鬼争尸缘在止观第七记。引增一重证第一义耳。有口失缘在金藏经。约教中还寄争尸。以为义本。别教云非己有等者。凡别教中立佛界者。有其三意。一者以理性为佛界。二者以果头为佛界。三者以初地去分名佛界。今言十界皆非己者。指初地去分佛界耳。若指果头应云九界非己有耳。圆教中非我非他者。非真非缘复非共离。又非己有不同前两。非他有不同别教。前约教则寄假合。今本迹观心并约星宿。皆随便耳。见佛如星般舟中意。观心下云云者。应广引般舟三昧(云云)释毕陵伽广明慢缘。在止观第二记。若约此为四悉者。五百世世界也。忏悔具二悉。引增一即第一义。观心后云云者。三观总别俱是第一义。所破之惑俱得是粗说等也。释薄拘罗因缘中。初文是世界。年一百六十去生善。身乐去是对治。故增一云。寿命等是第一义。昔施呵梨勒者。过去毗婆尸佛时。以呵梨勒施一头痛比丘。自是已来而常无病。言持一戒四戒庄严者。少分优婆塞受时俱五期心多少。增一云。佛语优迦尼。夫食者长善灭恶可以食之。若长恶灭善则不可食。持戒破戒亦复如是。多毁犯下云云者。应分别之。如云。若破一戒当堕地狱。若持一戒得生人中。再三问能持不者。令三自归。故持一戒得名少分。乃至满分。报恩第六。五戒不许五种贩卖。一畜生直卖者得。二弓箭。三沽酒。四压油。五五大染色。罽宾已来麻中无虫处听。流沙诸国染多杀生。秦地染青亦多杀虫。前四皆云不贩者得。藏中有一卷五戒经。分为五品。甚是持五戒者所要。塔犹有是力者二义。一者舍利之力。二者护塔神力。本迹中大寂定者。秖是大般涅槃。长寿去寄迹事以立本德。本住真常迹现长寿。本居极乐迹示无病。本八自在迹居不夭。本住圆净迹示闲静。释俱絺罗因缘中。虽对身子为成舅德且从舅说。族姓即世界。见姊即为人。弃家至堕负对治。即低头去并属第一义。中含五十八。舍利子与俱絺罗论有多番。初舍利子问。云何不善。云何不善根。俱絺罗答。身是不善贪等是不善根。问何者是智慧。答四谛是。问何者是识。知色声香味触法者是。问识何所依。答依寿。问寿何所依。答不别有依。依寿有燸如因油有灯。更有多番。释难陀因缘文甚略。亦云放牛者。大论云。频婆娑罗王请佛及比丘僧。三月安居。语放牛人令近处住。令日日送乳酪酥等。终竟三月。王甚惭之令其见佛。其乃与诸同辈议云。曾闻一切智人即净饭王子。彼生在王宫颇知放牛事不。乃入竹园端坐问佛。佛为说十一事等。具如止观第二记。因发心出家成无学果。从本为名故云放牛。言善欢喜者。从初慕道为名。欢喜中胜故云善也。欣乐是善喜之别名耳。若以此义立四悉者。翻名即世界。十万释即为人。佛说放牛事即对治。得果即第一义。约教中云欢喜住者。住无欢喜之名。但约别地。证道既同故借地以名住。释孙陀罗难陀因缘中。初是世界。四月下为人。妇即下对治。云云者。文略。义当后时得道是第一义。弥沙塞者彼律乃是跋难陀。且以名同释之。俱端正故。地狱天堂已后文。广如止观第二记。本迹观心如前者。如前难陀中释。富楼那因缘中初是世界。是人去为人增一下第一义。欲还本去对治。叹满者重举第一义。须菩提中初文世界。常修下为人。空是最胜行即业也。现报复胜故云善吉。住无诤去对治。佛忉利下即第一义。观心中列四句者。虽通诸观于修空行。其义更便。言法身者。且顺前第一义中意。非独此中必云法身。释阿难因缘中。初是世界。中含下为人。自誓下对治。育王下第一义。宗社者。具如止观第四记。本迹中约欢喜地以释本住。地即住也。约观中相似乃至相应者。亦可通取名字。言云云者。具述观相。释罗睺罗因缘中。约往世今世及祖王欢喜。并世界也。诸能破障边多是为人。诸所破障边多是对治。后得道是第一义。准杂宝藏经。罗云是佛得道夜生。以罗云六年在胎。若佛十九出家。乃成二十四得道。若三十成道乃成二十五出家。不同见别不须和会。乃至诸释起谤及息谤等。具在彼经事不可具。未曾有经复甚委悉。宝女等者。瞿毗罗云。我常与耶输进止共俱未曾有过。言宝女者。是天种不孕。佛不出家当为轮王。天送宝女以为侍者。或云。是罗刹女。如天帝释亦妻修罗女。大论十九云。耶输陀罗菩萨出家时自觉有娠。菩萨六年苦行。故怀妊亦六年。乃令诸释有疑。因佛还国。罗云以一器百味饮食及欢喜丸。以上于佛。佛变五百罗汉与佛不殊。罗云送食直至佛所。诸比丘空钵而坐。章安云。宝女能生千子。法显传云。王妃生肉团如瓜。瓜有千[柬*瓜][柬*瓜]生一子有千子。此与大论文复小异。而佛索令出家者。未曾有经佛令目连从瞿姨索。瞿姨不肯。空声告曰。汝遇定光佛世买华之时。愿为他妻好丑不离。所有尽舍唯留父母。今何以惜子

问。文中何故不云瞿姨。但云耶输

答。昔时瞿姨是今日耶输。今日瞿姨乃是天女。故罗云以沙弥之年者。中含第三云。佛乞食讫至温泉罗云住处。罗云为敷坐具汲水洗足。佛取水器泻留少水。问罗云。见不。答见。佛言。我说彼道少亦复如是。次令水尽。次令器覆。皆答佛。佛言。彼道尽。彼道覆。皆语罗云。当作是意不得戏笑妄语。而说偈言。人狂一往谓妄语是。不畏后世无恶不作。说是颂已。问罗云曰。如人照镜欲见其面见净不净。如是罗云。将己身业观于彼净及以不净善不善已作当作。皆当受善恶果报。乃至口意亦复如是。一一观察。四大罗汉名。如前。佛敕云。吾法灭尽然后涅槃。准宝云经第七佛记十六罗汉令持佛法。至后佛出方得入灭。彼经一一皆列住处人名众数等。故诸圣者皆于佛前。各发誓言。我等以神力故。弘护是经不般涅槃。宾头卢罗云在十六数。却不云迦叶。本迹中云八种障等者。意云。本住无障迹示十障。障涅槃者。谓生死障使不得入涅槃故。即前文中初八番是。一种障生死者。障使不得至于生死。即第九是。次被佛敕不得涅槃。故障无余即第十是。又前八文障义小异。一二三兼六年在胎。为胎等障故云覆障。第四谓宿世常障故云覆障。第五为疑所障故云障。第六约父不许为父所障故云障。余准可知。观心例前者具如诸文。今应云即假故障涅槃。即空故障生死。即中故障非生死非涅槃。乃至三惑。能障三观所障之惑。有思议不思议等

法华文句记卷第二(上)法华文句记卷第二(中)

        唐天台沙门湛然述

次释少知识众中。非但不叹又不列名。以少人知。而云圣与凡等者。释少知识所以。凡不测圣故云绝交。非圣全不交凡名之为绝。如以凡望凡交者方识。况以凡望圣理合绝交。交好既绝。岂以识之多少言耶。特以等者。今圣为引凡发彼同类。机缘不等随类接之。故现少识之迹。以接隐德之徒。故不以凡夫能知能识。而判所知所识位高下也。故言不可以多少之迹失其本。故不可以多人知识为本高。以少人知识为本下。又不可多知识者为有实本。少知识者为无实本。故知多识少识俱迹而别有理本。若久本者自有实成。若欲此中辨四悉者。多少异故世界。随顺物机为人。藏名隐德对治。高下莫测第一义。三藏十八种学人等者。具如止观第六记。通教学无学位两节判者。前约二乘后约菩萨。又前约三乘共位。后约独菩萨位。约别圆中亦两节判者。前云功用无功用。即约地住前后。次具不具即等觉妙觉。初入无功用亦得名为无学。但是分得故更约具足。引阿含意者。为开第三句义端故也。外人所以作此问者。汝云罗汉既云无学。何故更须随逐世尊。若尔下假问征起。答中即成第四句也。凡言学者。为进断故。如七反一来不还皆不复学。若历果进者义属前句。况已所已断不复更断亦当第四句也。更加双非即五句也。两教声闻悉皆如此。四教例者。通教更约菩萨者。前两句如前。后两句者学无学当地住故。无学学者无学在佛不可更学。还应退取六地为无学。出假名为学若准罗汉佛亦住于善法。为无学学。别圆后位唯不得令佛更有所学。则阙第三句。准通可知。并以凡位为第五句。则后三教并有两节。皆成五句。本迹中云居满字学无学者。别圆两教皆取未足位。其中不妨亦有古佛。即是第二节无学人也。又满字者。满通三教简二从圆。众生应以半字学无学。庄严双树者。初从半字引入圆满。即鹿苑示枯方等示荣。尔时已是庄严不二。始行执迹而暗其本。来至法华涅槃方始显说。即大经中举因六人。既见佛性同于如来。二而不二故云庄严。观心中已立学无学二句。应更立二句。不缘而缘名无学学。常如是观名学无学。对未修者成第五句。亦可约理为第五句。亦得三观各为五句。思之可见。约观为数中云界如互论。即具二千者。百界千如但成一千。即十界百界界界十如。复应更以百如千界。又名一千。且如十如初后相在则十如为百。用对十界岂非千界。此且一往论其单数。若百如中之千界界界十界。百界中之千如如如十如。何但界如各一千耶。是则重重无尽不可数知。将何以为二千定数。故云不可思议。诸境皆然且随便说。故云二千。因缘约教中并但列数。于义即足不须别求。故前二文直列而已。若欲义立闻数欢喜生善破恶入真。诸教用观对数解异。即其意也。举迹下本迹也。举迹等者。即此迹法是本法也。本自有迹故云本迹。非迹无以显本。此迹即是本家之迹。非本无以垂迹。故二千迹中之迹。即二千本中之迹。上下悉然释妨。如前多知识中。列尼众中破旧解云。又复无文等者。比丘众末结云。如是众所知识故可云多。学无学文末无此结故。故望前多得云少耳。尼众二文前无众所知识之言。后无可望以之为少。故云无文。义不可者。比丘众约叹德不叹德。列名不列名及数多少。并有结无结。以判多识少识。今尼众中但标二众主名。二人之后但云六千及亦与眷属俱。并无结列。岂有六千为他所识直云眷属不为他识耶。尚不例上藏名隐德。岂得云少。大小者。旧呼大小名闻等。已如前破。又复耶输此翻名闻。岂得却以为无名闻(云云)二尼并阙约教者。准例合有。亦应约僧具有四教五味

问。大爱道之名何故用智度以消本耶。复非佛母何以引佛母释之

答。以有智故方能爱道。既爱大道智度亦大。况凡女人皆能生子。故借净名法门之母。令生己心导师之子。数无约教大意如前。观解数中以六根为六千者。虽借下文法师功德品文。今此并是义通初后。若的属尼众并是圣位六根。已于三周得记故。正用华严十种六根。表本法门者。兼本迹义也。耶输中以子标母者。凡以子标父母。或以父母标子。皆有德业为他所识者可以相显。比丘皆然。或云无翻者。非独耶输。一切未翻者多具有翻无翻。例修多罗等。佛妻者果中说因也。则出家之时已舍耶输。故有佛号时无复妻也。观解以表三夫人者。鹿野不生故表空。耶输有生故表假。复居三观之中。昙姨位大表中明矣。上当分下合明本迹观心。于中先明来意。次正释。初又二。初总次别。初二句总明者。当分两字皆去声呼。所以共明本迹观心者。以因缘不可合释。约教理应互通。今欲主伴共论。本迹观心便故。然菩萨杂众各有本迹观心不共明者。形服疏故。无始终故。非物重故。非经别为故。又因缘教相不别明者。从本垂迹秖是感应。感应所为不过教相。故但本迹自摄余两

若尔上文已有此两何须重明

答。由化缘不同莫非益物。因缘相关须共设迹。或一人关多人多人关一人。或一人关一多人关多。故使始终亲疏主伴显密共成一化。又诸圣观行能观所观。一刹那顷含纳一期。事理权实人法主伴隐显善恶。无不为此心观摄之。是故须约王所以明。次显善权下别述来意。初句明本迹来意。次句明观心来意。权中之最故名为善。无一圣者不顺机缘故云曲巧。无一心所不成妙观故云精微。随机故曲诱进故巧。无杂故精理极故微。从夫首楞严去。先总释本迹为三。先叙垂迹总论利物之道。次今且下明主伴同怀化方。三以此下总结三昧之功。初文明本迹所依。本地所依。首楞本也。示现迹也。称适者。明垂迹意。靡所者。明垂迹相。诸大小教明诸罗汉但得四智。直被弹斥洮汰而已。不明化意。尔时谁云生阴未尽梵行未立所作未办。仍有变易。故知但约界内明尽。若开显已本是大权。所以先外次小传引入圆。故非首楞之本。无以垂于化迹。故云靡所不为。次明主伴化方者。为六初主伴降神。次若三十二下明师资诞质。三若皇皇下明共禀世道。四若法下明能所生熟。即指鹿苑小乘。五共辅下更熟未熟。即指方等般若。六次闻法华下。明主伴功毕。初又二。初主也。次法身下伴也。次文又二。初师也。次诸大下资也。第三文亦二。初师示禀世道。次诸大士下次示受邪化。第四文亦二。初知所化尚生。次若所下鉴所化机熟。第五文又二。初方等。次般若。第六又二。初正明功毕。次法王下重述半满以显化功。分文竟次略释之。言近论者。且舍中间以述伽耶。圣后者圣皇之后。后亦德政故法身等者。亦有古佛且云菩萨。主既降神伴亦在迹。金姿者。金色美容也。大士者。大论称菩萨为大士。亦曰开士。士谓士夫凡人之通称。以大开简别故曰大等。如世云仁士志士等。亦以仁等简之。今人中发大心者名大。开是发之异名。引物不同故诸相各异。空室者须菩提。生时室内一切皆空。表解空故。雨宝者。楼那。寄辨通梦者。舍利弗。太子等者。初同后异。欲夺先与故为皇等。处其极尊而为先导。如因果经云。佛将降此阎浮时。有九十九亿众。弃斯大众及忘四天下。故云舍国。弃金轮位故曰捐王。示习世定故云学道。诸大士等亦示受邪化故云请业。过其所习故曰兼通。却摄彼众故曰宗匠。如身子十六声振五天。与目连共师沙然梵志。未经旬月沙然徒众尽以付之。大法欲启先为开辟如陈如等。知所化既生能化犹与。分庭抗礼如迦叶等。抗者。易云。知进而不知退知得而不知亡。亦对也。未肯为臣故分庭不退。崇我道真者。具如迦叶缘中机熟可化故云易染等。诸大士各掌一职。智慧身子。神通目连。辩才迦旃延。三昧富楼那。更度未度者。虽师徒受化化道未休。度兼二义。若全未受化则方等中更令入小。若诸菩萨但令尽无明。言重熟已熟者。大小两熟位既未终。理须进入。释慕大中云不知者。秖此不知之言即大机冥发。下云机情二索。即此意也。含挟等者。谓般若中通教二乘。故彼部中通教真中具大小故。名之为含。大带于小故名为挟。从始至终通大小故。出内等者。明领业也。自他之法皆令知故。出内具如下疏中说。出内两字江南多分去声呼之。非无所以。若人之出入出字可从入声。人之所运可从去声。内字南北二音义同。但恐滥内外故从南音。共谓通教

若尔。何不付藏

答。先已得之。别即别圆。偏圆具如玄文分别。被加为奉命所说名领知。名说为领无别领也。犹住小果名无希取。转成熟酥名未顿舍。望后极教故名为虽。被加领法其心不惊。名为通泰。故渐已之言通昔。通泰唯在熟酥。次闻法华明至第五时。具如信解中广说。显真遗体故会天性。天性定故父子义成。昔结大缘名为真体。得受记莂父子义成。定昔二万佛所。方乃堪为记莂孤调涅槃故云独灭。尚无一人独灭岂留多人。法王下更述一代化意。初用下借半满枯荣以成化事。释上方便权巧之言。大化功毕故曰身子等。不待涅槃故云息化赎命如释签。若此释者。方释法华经众。总别两重消释本迹。尚恐失旨。直尔一句翻名而已。何异诸教声闻众耶。唱灭等者。正由功毕唱灭言兴。故唱灭之缘正在斯典。二万灯明等者。准文殊答问引往所见。皆无后教。当知即于法华讫化。若东方所见具见法华涅槃。是则引同今佛故也。若迦叶出世其土犹净理同往见。虽涅槃有无不同。并于此经显实。为学等者。男如宝积善德等。女如月上无垢施等。道谓出家二众。俗即在家二众。发起等四皆悉有之。乃至良贱人畜亲疏恭慢嗔喜凡圣。其相非一故注云云。次总明观者。总别大旨委如前说。以二十心所共辅心王而缘善境。如初起观不离王数。通数犹通通至善所。以此大善历缘对境。其善转深如至今经故此善数无别心体。还秖转其恶数而生。故从外入小从小入大。自始归终方名善极。善行虽多不出此十。故云十心为本。转既极已。还同心王无善无恶。如诸弟子得授记已。分同法王故云立也。又渐转者。如诸声闻。若顿转者。如顿菩萨无非实相。使王成究竟法王子成法王真子。咸堪补处转化余生。是故于中先取善心。然今所列并准旧译。新云。信及不放逸。轻安舍惭愧。二根及不害。勤唯遍善心。初三句一字列。后四字结。若欲对旧名略辨同异者。新云信谓于三宝所忍许故也与旧名义同。新云不放逸者。谓修诸善专注为性。旧名为念。念谓忆持。名异义同。新云轻安者。谓轻利安适堪任为性。旧名为喜。喜悦安快。亦名异义同。新名为舍。谓离沉掉。与旧名义同。新云惭愧。旧云猗觉。名义俱异。新云二根谓无贪无嗔。旧云定慧。名义亦别而道理大同。以无此二定慧方成。定慧亦深浅不同。二根非无优劣。新云不害。谓无损恼为性。旧名为戒名异义同。新云勤旧名进。名义大同其名义全不同者。译人意别不须和会。今此贵在从名入观。故善王善数共导诸恶以成妙善。故通心所辅王亦然。以数对人随其行相。亦应可解。十人既尔以十望诸。乃至无数不出心所。何但一万二千。乃至未受化来。以恶心所摄之亦尽。何但善及通耶。十人各备等者。寄本迹以明观心。本乃已成法王迹示善通心所。以示入道不同故也。言一一心中皆有王数者。既二论不同。今言相扶即是同时。亦应更云次第相生。非但同时异时。亦乃诸数互有。信具诸数从信为名。余九亦然。从强而说故受别名。十通心所准此可知。是故展转相扶攻恶。若一心改余者相从。若相扶转尽同入实境。无非真王非王非数。故知随人何者偏强。强为观境弱者随去。妙得此意。四仪三业修观有托。况复能观须辨异同。言共攻者。通心善心即能攻也。言不行等者。指余恶等。能攻属智故云行般若也。引普贤观者。能所尽故。故心无心法不住法。计有能观名为我心。有我心故能所不亡。我所若空罪福无主。无心无数名正观者。故云若不尽者观则不讫。故至妙觉方名为讫。所言尽者。因心所尽果心无尽。犹如五阴因果名同而其体永别。通引诸经意云。众生不度等者。借事证理。若所观之心众生不转。则能观王数师弟不息。云云者。广明王数能观所观。讫与不讫成不成相。正觉之名又通诸地等。次列菩萨众者。大论第四先问。何名菩提萨埵。答一切诸佛法戒定及智慧。能利益一切是名为菩提。其心不可动能忍成道事。不断亦不破是名为萨埵。应约三教以释答文。对小成四。菩萨为出家等者。论有二问。初问声闻经中有四众。无菩萨者何。答有二种道。谓声闻菩萨。四众是声闻道故声闻经无菩萨众。次问具如今文答云。通虽如此别则不然。具如今文。论问。若尔。衍经何不独列菩萨。此问意者小乘教中菩萨非正。但列声闻及以四众。菩萨入在四众中摄。衍中声闻非正。亦应但列菩萨四众摄在菩萨中耶。论答云。是乘广大诸乘皆入。如恒河中不受大海。大海即能受于恒河。论答意者实如所问。但为摄取渐令归大如恒入海。彼存方便。若依今文先识诸部共别有无。方识今经列众之意。非关列众离合。能辨大小偏圆。如金刚经唯列小数及金光明大小俱无。岂可能判大小别耶故知先以教定以教辨人。则百无一失。故今等者。言通意别。若具存等者。先辨存略。菩提下正释名。先约上求。又成下约化他。摩诃比前亦大等三。具有四教道知用三。故云多种。具如玄等及止观中。一一四弘即其始也。一一利生即其用也。一一道品即其行也。一一法门即所知也。四弘若别四三必殊。及简五味。方是今经圆妙菩萨也。如释论下至醍醐也。寄五味名以辨四教菩萨。论又云。凡称善法皆名为萨。善法体相名之为埵。故知菩萨自利利他皆是善法及善体相。即是四种阿耨菩提之道。一切贤圣之所称叹。是为四种菩提之萨埵也。又论云。通论三种皆称菩提。所谓三乘。前二乘人虽称菩提非佛功德。故不名萨埵。凡为杂血调成三祇百劫净乳。引大品三文证四味者。且以三教义摄四味。况今五味皆判菩萨。故以酪对通。二酥对别。醍醐对圆。以诸菩萨历此四味入不定故。义当三观。即三藏菩萨转入通时。义当于酪。据时并在方等已前。转入别时在二味者。以二味中皆有菩萨不思议事。引净名者。已入实者于二味中心称脱理。八千受屈。示同钝根及二乘人弹斥洮汰。方并入别。准玄文意。即离二味以对通别。进退盈缩并有二意。故入实者皆自立身如彼座像。座高四万二千由旬。身亦称之。借本迹中意以助约教。菩萨疑除等者。并证四菩萨中权者须开。故至今经方除三菩萨疑。方是善行菩萨之道。又涅槃等者。然二经同味咸息希望。是故引同言略有者。今昔合指。本迹者为三。先明本迹莫测。次所以下明施迹意。三然其下正示本拂迹。初文中云或齐法王者。如文殊本是龙。种上尊王佛。余并准知。散影垂容等者。同前声闻总明本迹。次施迹意中有法譬合。譬中云槌砧者。化主为槌。辅者为砧。乃至互为皆为成器。本以古质为淳朴。今以未治为淳朴。令其成器。故名为器。淳朴不一故名为诸。观中名破为成观后云云者。五住对三次与不次。观亦如是思之可知。同谋下云云者。应合喻云。今开秘藏不涉权下。故证信之人皆非率尔。故今文列不必在多。列众虽尔。本门得道数倍诸经。即先得无生增道者是。故知复是随要列耳。此明数中已当因缘。虽即不明约教本迹。因缘之人既预密谋。必是圆人及有远本。八正即八万者。既是无作道品八正。无不观彼百界千如。十善既为所观。八正即是能观。能所相从各有八万次明位中初是因缘。次应四种下约教。初文中云无上道如境妙中者。六境初四菩提是也。境咸妙道之所趣。以所显能故须指境。若辨四悉者。三不退异世界也。入位功德生善也。必治无明对治也。证一分真第一义也下去准知。不能具记。具此名跋致者。阿者无也。跋致者退也。第三祇时横得三不退故。离五障时三义俱得。即是第三僧祇通至百劫。通是三不退也。至此名为上忍故也。次通教位引六心者。通教地前无位可论。借别位名以通其位。即指别教七信已上。入干慧也。故云初地至六地方名位不退。或指地前假立七贤。即以忍位为第六心。依小乘位虽云忍位名位不退。望菩萨乘犹名为退。次别教中许地论师故不破。圆位者。诸教圆位不过华严。余文虽有位义不彰。或略举初住阙后诸位。初住既尔行向岂殊。岂得同其地前伏惑。然又华严住后兼别。或便一向作次第解。或以一向作圆顿解。一何误哉。具三不退者。若先以不次寄次第说者。则七信名位不退。八信已去名行不退。初住已去名念不退。今从初住已具三德名三不退。故云具也。般若是位离二死故。解脱是行诸行具故。法身名念证实境故。彼经第七贤首品中广明其相。卷初帝释问法慧云。初住成就几法几功德藏。法慧答云。此处甚深难信难知难说难解难通难分别。然承佛力具足演说。仍先较量云。供养十方阿僧祇众生乐具。经于千劫复令证支佛。百千亿分不及其一。又云欲知十方世界一即多多即一一念无量念等。望法华中施四百万亿阿僧祇世界六趣四生。乃至令得无学不如初随喜人。彼经仍易彼是圣位。故云十方等。望此第五十人一念功德。方显圆位不可思议。此经为难。既俱是圆初后不二。亦何彼此。尚非初住者。此诸菩萨皆是一生补处。尚是古佛况复初住自新译来但以瑜伽唯识之位。掩蔽华严圆常之说。谁知唯识等文但明别位后代谁肯见兹同异。又复有人全毁唯识论之权宗此则全迷方便之路。不识迹者迹居诸经之首。来至法华经初。验知可是浅位人耶。既失其本理迷其迹。况从部判部妙人尊。诸师既不晓于五时。安知菩萨本迹。故云所叹既谬等。以藏叹通尚已成失。以偏叹圆过莫大矣。还成增减两谤者。秖此一谬义招二失。经无三教苦欲增之。抑圆成偏减岂过此。三观即三不退者。空位假行中念。一心者。还约妙三一观悉具。云云者。委释次第不次第相。及以一念须约六即。极有眉眼者纵而夺之。虽有眉眼大体全无。从核论下夺也。无趣向者。此现德等何教无之。虽云法报不简圆别。傥分圆别为初为后。乃至诸句为横为竖。故总破云无宗体也。若有宗体故证位人依经立位。位之所依名为位本。本即是体位即是宗。况复今经特出诸教诸位之上。准教叹德意则可知。故始自不退终于度生。先定体宗方可叹德

问。此经何以竖叹十地别教位耶

答。一者寄本。二者证同。三者顺论。云何七地等者。古人所判云七地恐起二乘心者。此似通位。是故难其不成别义。难圆亦尔。若言七地始入无功用道。此是别教教道明义。故不成圆。言进退等者。斥进不成圆退非通别。今文横竖者。竖叹赴情意本在圆。先正释。次料简。然初竖中初文虽借离二之名。须异璎珞二为方便。还依一念具三不退。以为初地。圆离三垢圆发三智。圆明圆转一念供养。圆植德本为佛圆叹。具圆三慈不二佛慧下去准知。若不开等觉则四句同叹十地。今从开说故后三句叹于等觉。文云二句者。指第十一十二句。为十地内外德者耳。但不从初即具。故似别耳。次横叹中初句亦云过二边者。竖尚俱圆。况此横叹离二边耶。但约非竖而竖如前所说。过二边者。粗惑前去。又从胜说从中立名。下去诸句准此应知。阿字者今师承用。具如止观第五记。问答者。初问中初句立宗。三藏下纵许。声闻下立例。迹为下立难。立宗意者断惑也。地住已上皆约圆教断位叹德。三藏菩萨始终不断。容不彼叹。于断惑中尚叹二乘。迹为通别断惑菩萨。何得不叹。而横竖二叹悉唯叹圆。答意者。义通本迹意唯在圆。竖文似叹于别依部唯叹于圆。借迹消文经意从本。故准叹声闻从迹。亦应菩萨四教俱叹。但欲知圆旨故亡迹以存本及去初而取后。次问可见。答中为三。初正答。次旧云下引别位为例。八地位既未极旧释尚具德不疑。何妨圆人诸位位位具足诸德。三法华论去引证。论云。彼菩萨德十三句二文摄取。应知一者上支下支门。二者摄取事门。初上支下。支谓总相别相。应知初至不退转是总余者是别。彼论云。不退有十种示现具如今引。但除初总句犹有十二句。乃以供养植德二句。合为第四示现。名称度生二句合为第十示现。故但成十示现。皆以不退为名。故知圆释句句互通。一一示现具十示现。具一切诸句。何但十示现十二句耶。此与四十二字门意同。又经云。以慈修身句中论文具修身心二业经文所以略修心者慈即是心。心熏于身故不别说。乃至依我空法空不退。故知地住俱证二空。所以竖释文虽别对意非别者。一者以有次文横释是约竖论横。二者依论句句义意以对诸地。如初地云不堕二边三观具足。自利利他有无双照。若福若智不离一心。内因外缘何尝不具。初地既尔后去悉然。即此地中横竖具足。为对次第权借地名。为显唯圆彼须横释。故论中。摄取事门即当竖释。是故今文具用论中二门解释。但今文中准论。于何等境界下剩何等二字。论但云。何等境界中应作所作故。论自释云。地清净者。八地已上三地无相行寂静清净。今文意以彼论三何等言。一一皆属诸地。清净即诸地惑断。方便即诸地进趣。境界即诸地所依。应作等即诸地功用。论云。方便者。有四种

一者摄取妙法方便。任持妙法以乐说力为人说故。即初四句随义思之

二者摄取善知识方便。以依善知识应作所作故。即第五六七八句随句思之

三者摄取众生方便以不舍众生故。即第九一句也

四者摄取智方便。以教化众生令入彼智故。即后四句

既诸句各对。复云何等。何等者。辨别之辞。今亦互通。一一方便通约十地。顺诸经论及璎珞中。初地已上入法流水。念念趣故入证道也。论中复有摄取事。示现诸境地等。于经非要故不更述。言八地者。虽不同璎珞诸经非无。复是别中教道异义去取俱得。今且依璎珞。于论既非大违。且依一家承用。言何等境界者。利物处也。次约观心者。此中前文叙古破旧。义当因缘。今文二释义当教观。虽阙本迹德随于人。故不重明。三观无殊随事名异。若尔亦是诸句展转互具。以得不退一心三观。方得乃至度生一心三观。乃至以得度生一心三观。故方得乃至不退转一心三观中间诸句准此可知。当知百句秖是一句。故初住去位位圆融。句别义同不须曲释。小乘之中佛为身子。开一句义端。身子尚说无穷尽况此圆菩萨德欲分张之令楷定耶。况复观门即是其德。观融德妙何可疑耶。故应约诸句自在说之。有人问。何故此中文殊居首。答序中既能释于弥勒之疑。乃是一经发起之首。况二万佛所咸为众启疑。是故列在八万之首。法门等者。依此名义例应四释。而今少者。一者准例可知。又菩萨事迹或隐或显或真或俗或主或伴。不同声闻事迹显著。虽非显著必具诸教。而今开显义必在圆。况复如前约诸声闻总别广释。因已具知菩萨本迹。本迹既尔因缘教观准类可知。故不委述菩萨总别。今初文殊中引五文者。初三辨名思益举说明行。悲华论愿益物。初大经者从德立名。即以见性立妙德名。此准第十七阇王悔后发愿文也。次二经但举梵音不同耳。思益明如说而观。观谓不起法非法想。观即行也。即言行相称而得妙名。悲华因取妙土。益物事广所化位高。高广愿行一切皆妙。名为妙德。菩萨利生迹因何定。于此文中亦可义立四悉释者。即以妙德若名若体无非四悉。取土即世界。说法即为人。立行即对治。佛记等即第一义。此是圆人复当约教。从北方去即本迹也。又如楞严经过去无量阿僧祇劫。有佛号龙种上尊王。亦文殊是。观音中作四悉者。名即世界。思益即为人。称名即对治。宝藏佛去即第一义。又思益见得菩提亦第一义。下文指普门品。注云云者。亦阙约教及以本迹教。即圆人本是古佛。观心中释初二字。与下不殊。但第三字与下稍别。下约事释以所被为音。此约能观以所宣为音。由观故设教。故云观是语本。次大势至者。思益约行。悲华约愿。思益约威势以释势。正当字义。取大千者。以世释势。势力取世不违其志。以志大故。故佛记之。志取世故亦名世志。若作四悉者。思益世界。悲华为人对治。宝藏佛去第一义也。亦阙约教本迹例前拟后可知。文阙常精进。如大宝积经云。是菩萨为一众生经无量劫随逐不舍。犹不受化无一念弃舍。以身心俱进故。义通四悉。教迹观心准例可知。不休息者。与常精进义意略同。欲辨别者无间趣入名为精进。长时无废名不休息。是故观解名为不住。故释不休息亦约长时。但得记与利生不同耳。教迹准知。释宝掌者。先释掌。次令释下释宝。掌谓身分。既被上铠身分坚固。以其固掌法身之分。尚出无上出世之宝。况复世宝。故此两宝必具四悉。于中云不志二乘者。简法宝滥。通慧心者。从实起通。通是慧性故云通慧。约教本迹等(云云)。释药王中。三缘从后医王义当于药。前二虽别是则佛世灭后。皆立行生善。火净者。从烧身立名。文中且以世治表出世治(云云)。欠七菩萨未检经。跋陀婆罗中。初句是世界。次思益下第一义。此菩萨名在般舟经中。亦名贤护。善即贤也。善巧将护令其不退。弥勒中初句是世界。思益是为人。贤愚是对治。悲华第一义。又云去。应合在因缘中。贤愚等者。彼经第九。佛在迦兰陀。阿难忽然思惟弥勒世尊。往昔云何发此慈悲之心。得是妙益。从禅定起而白佛。佛言。过去久远此阎浮提有一大王。名摩诃波罗婆。主五百小国。与群臣出猎。王所乘象欲心炽盛。因见象师调象。而便发心今为补处。又经亦有末济跛兔缘。而立慈称。以本愿力熏见苦生慈。前悲华中乃以拔苦而释与乐。故圆拔与而无别体(云云)。云云者。约教本迹观心乃至迹门发起众等。释导师中文舍四悉。导师是舍婆提国人。是白衣居士。令入正道释导字。不求恩报释师德。以亡怀故方应师位。具名之外但列数者。因缘观等具如前意。但名不可尽陈。故但标大数。总而言之。但由国人旧多知识者。则先列之。证信为易。一代教中诸大菩萨宿缘获记。多在悲华第二卷中。经云。有菩萨名曰寂意。白佛言。诸佛皆有净土。如来何故取此秽土。佛言。本愿故取。我于过去恒河沙阿僧祇劫。世界名删提岚。劫名善。轮王名无诤念。主四天下。王有千子。有一大臣。名曰宝海梵志。唯有一子三十二相八十种好。常有诸天而来供养。国为作号名曰宝藏。出家成道亦名宝藏。说法度人其数无量。其王千子各各供养经于三月。过三月已欲为授记。先入三昧现十方佛土。集诸菩萨。先授宝海。十方世界众生宝海教化者。一时成佛。次授轮王千子。授第一子云。汝观六道起大悲心。断诸烦恼令住安乐。今当字汝为观世音。阿弥陀佛般涅槃后。二恒阿僧祇劫于夜初分正法灭时。于夜后分。其土转名一切珍宝之所成就。所有庄严胜安乐界。于一念顷便成正觉。号一切功德山王。寿九十六亿那由他百千万亿劫。第二太子名大势志(如疏)第三名文殊(如疏)第四名普贤。在东方十恒沙世界微尘世界。名不瞬。乃至第九名阿閦。如是次第授千太子。中有愿取五浊成佛者。以大悲故其土名娑婆。何以故。是诸众生忍于三毒及诸烦恼。能忍斯恶故名忍土。是千人中唯除一人。余并于贤劫而得成佛

法华文句卷第二(中)法华文句记卷第二(下)

        唐天台沙门湛然述

次列杂众者。旧云凡等者。如八龙多是八地菩萨。乃至华严中并得不思议解脱。此中有道者。如阇王所将岂独俗众。五道者。无地狱即乘戒俱缓。二界者。无无色即戒急乘缓。八番者。欲天色天龙干紧修迦人。具如下列。方等列地狱者。具如释签第四戒缓乘急。中阴花无色者。中阴上卷分身品。定化王菩萨白佛言。快说斯义晓了众生闻法易悟。复有难悟者。或在有对。或在无对。或可见。或不可见。前有对有可见不可见故。可见有对如前。不可见有对如臭毛鬼所至闻气。不可见无对即余鬼神。或在有色。或在无色。或在非有想非无想。有色即欲色二界。无色即下三空处。虽复难化佛或至彼或摄到此。此经无者或略等耳。故云不可一例。又准乘戒细论具如净名疏。旧云人是土主者。意指八番中阇王众也。今亦不用。故引无量义破之。岂有鬼神等必须外客耶。言未详者。虽望无量义人不必在后。或恐有意。鬼神重出者。即紧干修。机杂者。亦应更云诸机不同。析与体杂偏与圆杂(云云)。此是约教释者。二乘即两教二乘。菩萨即三教菩萨。三教皆有出假智故。佛道既云一摄一切唯得是圆。二乘菩萨并是从初。佛道即是元初修圆者。不从渐来。三十三天。及三光四天王者。俱舍云。妙高层有四相去各十千。旁出十六千八四二千量。坚首及持鬘恒憍。大王众。如次居四级亦住余七山。妙高顶八万三十三天居四角有四峰。金刚首所住。中宫名善现。周万逾缮那外四苑庄严。众车粗杂喜。若作四悉者。住处得名世界。能施为人。思义对治。天主第一义。约教者。阿含证三藏般若证通。别圆者。华严经帝释在第二地。故知两教并得首楞严定明矣。过贤劫等者具如般若。云云者。得记义当三教菩萨。本迹中云共服甘露者。大经第六四依品云。如三十三天有妙甘露不死之药。譬初住已上理同也。名月等本迹并出正法华。本必有教。观解意者。三谛即第一义天。谛即是境。境生于智智如子也。云云者。境别智别生子不同。居四宝山者。秖是须弥。正法念云。四级各有十住处具如玄文。广二十四万里者。未知所出。若俱舍依妙高半腹而住。有四级。颂云。旁出十六千八四二千量。向上一一各半减故。东提头等者。名在金光明第二四天王品。尔时提头赖吒天王。毗留勒叉天王。毗留博叉天王。毗沙门天王。始自东方终于北方。第三鬼神品列二十八部。不令等者。迹防四树。四树既表于四德。以迹表本本护四德双树。虽复四枯四荣。然非枯非荣之理。亦不出于常乐我净。故护八树是护四德。护四德者有其二义。一者不许偏取。偏取成邪。二者不许全取。全取成执。须知其理谓非枯荣。今言枝叶者。以一德中皆具四德。若偏取一名不知具德名取枝叶等。故外教中并有其名。是故文云枝干喻常等。正显一德各具四德。护八爱见者。一一谛下各一爱见。四种四谛各随其教除其爱见。故四王各领不令脑人如各护见爱不令取境。若从后说王即王三昧也。当教教主亦可皆王。各破爱见。他化五欲下云云者。应具明欲天身量寿命。俱舍云。赡部洲人量三肘半四肘。东西北洲人倍倍增如次。欲天俱卢舍四分一一增。色天逾缮那初四增半半。此上增倍倍唯无云减三。人间五十年下天一昼夜。承斯寿五百上五倍倍增。色无昼夜殊。劫数等身量。无色初二万后后二二增。少光上下天大全半为劫。若论高下于一一天。如去下量去上亦然。别译阿含第六。广明诸梵来下。第八第十一广明诸天赞佛。诸天若来并同人形。第四云。梵王来礼佛佛入火光三昧不能得前。因往瞿伽离门唤之。瞿伽离问。谁唤。答梵王。又问。佛记汝得阿那含耶。答如是。又问。阿那含名为不来。汝何以来。梵王言。如是之人不应与语。故知一同人法。还有违情而诫伽离。例有教门等者。既为一代请法轮主。请大则大。请小则小。本迹者。本住清净一实妙境。观除惑秽并得名净。又文中从释诸天来唯帝释具四释。三光四王自在等色天。虽有因缘并阙约教者。然诸天常随世尊处处闻法。亦应随诸教味以判浅深及开显等。如引身子得记之流。但弘教事薄举例而已。故八龙下多然。唯紧有教。以义便耳。无量法门下云云者。从多头故且以假观为首。即是一假一切假。若通说者。一空一切空一中一切中亦多头也。长阿含等者彼经具明池出四大河如疏。阿者无耨达者患。无彼三患故也。本住法华三昧者。实道所证一切皆名法华三昧。今且以华释华耳。四紧者。杂心云。是畜生道摄。紧那一角。乾闼无角。身相略同。今言奏四教等者。既历五味。皆有紧等。当知所奏亦偏圆别。来至今经独显实谛。如大树紧那罗经中。大树紧那罗王与无量紧及无量干无量诸天。奏八万四千净妙乐音。来至佛所。弦歌一动声震大千。须弥山王踊没低昂。一切声闻皆从座起犹如舞戏。天冠菩萨问迦叶言。少欲知足头陀第一。乃于今日犹如小儿。迦叶答言。非本心也。故知彼经属方等部以大斥小。紧那奏于别圆之乐。故使声闻不能自安。故至法华理合纯妙。十宝山者。华严具列。已如止观第五记。若俱舍中先列七山并妙高八。论云。苏迷卢处中次逾健达罗等。于大洲等外有铁轮围山。前七金所成苏迷卢四宝。并雪香山合十山也。既云为天奏乐天。亦诸机不同。歌咏十力者。既云不起灭定。即初住已上也。故迹中弦管亦应歌于四教。各有十力。若大树经中于香山南请佛供养。佛受供已记其当得作佛。号功德王。理应法身记也。若在初住八相之记。犹在迹中。今经所将不及大树经中多者。以闻实经不易故也。又今经龙王举八。紧等各四者。有所表故。八拟八正诸教各有八正故也。紧既四教大旨可知。余者俗乐以俗表真。四干对教随义释出。幢谓缘幢即竽木也。倒谓掷倒等。四修亦云无天者。无天德故。佛地论属天种。正法念鬼畜种。大权示现往缘何定。准阿含等四修次第住于海底。各二万由旬。言畜天等种者。并据元祖。五系系魔外道者。具如止观第五记。五住者。他解秖是界内见思。若尔与四住何别。他云。三界见为见一处住地。欲思为欲爱。色思为色爱。无色思为无色爱。三界无明为无明住地。然依五性宗中以见疑无明等种子为无明住地。今意不尔。五住为二死作因。即以三界通惑为四住。更加别惑为第五住。故别惑中总含内外无知及以障中无明故也。望唯识等但加种子为异耳。正本者正法华耳。水精入身者。或是有情。或是非情。若是非情义同湿生而兼胎藏。如阿含经有女人向火暖气入身有孕。父疑责女。乃至达王。王欲罪之。女云。何有此无道之王欲治无罪之人。请王试验。王知无罪乃纳为妃。具如止观第四记。色心本净者。对迹丑嫉也。本住色净故般若净。般若净即心净。此云障持者。谓能障持。世云常持者无凭。日蚀者。若全不许俗有计者。然依历数亦可预算知之何耶。以器世间法尔与人阴阳理合。故人身中五行与天地数合。故亏盈之法须应历数。岂妨正业耶。言种种邪说者。然日月照四天下。四天下亦阴阳不同。不可亏盈则令一切王等尽皆衰耶。水旱灾变亦复如是。故知虽一分与阴阳理合。而一分须依众生业力。故凡诸依土皆顺正报。如华藏土。必顺报佛及诸菩萨。依正自在。方便亦然。怖日月时等者。大论十一云。罗睺欲啖月时。月天子怖疾走诉佛而说偈言。大智精进佛世尊。我今归命稽首礼。是罗睺罗恼乱我。愿佛怜愍见救护。佛为罗睺而说偈言。月能照暗而清凉。是虚空中大灯明。其色白净有千光。汝莫吞月疾放去。尔时婆雉见罗睺汗出放月。以偈问曰。汝罗睺罗何故战栗。犹如病怖不安乃尔。罗睺答曰。我若不放月头破作七分。设得生活不安隐。以故我今放此月。昔为婆罗门等者。如俱舍云。欲天俱卢舍四分一一增。至第六天但一俱卢舍半。既云身长八万四千由旬。尚可得于色天第一。以色究竟天寿一万六千劫。身长一万六千逾缮那。应是变身能为八万四千。好斗战等者。此四修罗与帝释战时。次第布军具如今列。长含十八南洲有金刚山。中有修罗宫。所治有六千由旬。栏楯行树等。然一日一夜三时受苦。苦具自来入其宫中。属四恶趣者良有以也。别译阿含第三。广明修罗与帝释共战。须者往检。若约教者亦可随名立义。今为作之。初五系者初教菩萨具足五住故。次广肩者通教三乘通观稍广故。次净心者别教菩萨初知真净故。次云障持者。圆教菩萨障惑持理故。本观云云者。略不暇论。亦可云。本住第一义天迹示无天。能观即空故无三界之人天。即假故无方便土之义天。即中故无实报土之义天。一心三观常住寂光非人非天之人天。四迦中云已住处有宫等者。长含十八云。大海北面有大树名究罗睒摩罗。围七由旬高百由旬。枝叶五十由旬。树东有卵生龙宫。又有卵生金翅鸟宫。南胎西湿北化。各有其龙鸟之宫。并有七重行树众鸟和鸣。取龙之时翅搏海水。卵生搏开二百由旬。胎四百湿八百化一千六百。胎卵湿化如是次第。啖一二三四龙。如是恶道住处。欲比西方安乐世界。故知福易而戒难。戒易而乘难。以不来者众故。又如阿含云。香山有象名善住。常住树下有六牙。牙上有池等。与普贤象相貌几同。一树一象其数八千。善住为王余皆眷属。或持盖扇瓶。或作倡妓乐。或为王洗等(云云)。其如犹是恶道何。嗷(五刀切)嘇(思刀切)啖嘇物也。啖(徒滥切)金刚山者。此洲之南。将烧宝山者。火欲至余金山。若约教者。初云胜群辈者。过诸外道故。次云大身者。亦大乘始故。次大满者。出假足故。如意者。如理满故。次列人众。韦提希者。亦云思胜。言未生怨者。母怀之日已常有恶心于瓶沙王。未生已恶故因为名。无指者。初生相者云凶。王令升楼扑之不死。但损一指故为名也。八法者。或八邪或八风或八倒。普超经者。第三决疑品云。佛因为阇王破计定有杀父之罪。广说三世三心叵得。令住法界。阇王闻已得柔顺忍。说法华时者。据得柔顺在法华前故。在法华为清净众。至涅槃时身疮始发悔得初果。故知为引逆罪者耳。此乃全作大权释。故引迦叶为例。若作实行者。在法华会虽云清净未见获益。准理应云障未除机未动。至涅槃时障欲除机已动。故闻佛记领解欢喜。次说偈赞佛。故第十七云。父王无辜横加逆害。乃至心生悔热遍体生疮。世无良医治身心者。不信六臣六师之言。禀受家兄耆婆之教。闻佛说法获记发愿。当知二处并是迹为。于其本地有何逆顺。又如有婆罗门名曰不害。以杀无量诸众生故。故名央掘。以见佛故发菩提心。又波罗奈有长者子。名阿逸多。杀父害母杀阿罗汉焚烧僧坊。后欲出家。诸比丘不度自发菩提心。并是其例观心者。害贪爱母等。如止观记引楞伽。言行于非道等者。逆即是顺非道即道。又道以通达为义。所觉之理能通观智。从因至果。故名为道。乃至九界心皆名非道。何况逆心耶。有人问。法华一乘低头举手皆成佛道。何得阇王重罪不灭。但须依向机动障除四句等。判时熟前后。化缘随机不须此问。次问可知。答中虽引无量义准理更应引分别功德。以四天下乃至大千尘数得道。其内岂无人众类耶。故知但略。一句开为四句至如净名疏者。彼以七义解释四句。一明乘戒值佛不同。二信法二行不同。三大小乘别。四根性渐顿。五应迹。六观心。七化他。初云乘戒者。有乘则值佛。无乘则不来。信法者。坐禅听学讲说皆得值佛。但随所习大小耳。渐顿者。大小皆有渐顿故也。应迹者。已得二十五三昧应二十五有。引实行者来至佛所。观心者。但随观行以判见佛。化他者。见与不见皆约利他。大权现迹略如今文。若得等者。以此四句能辨自他值佛时处。得道奢促诸经例众多少有无。以验己身当来生处如印不差。揣心自责于经序。岂不怀惭于正宗。次释别序(入第三卷文句)别序者望通得名。且约当教相望为言。佛及弟子经前经后二文可知。又若从如来最后遗嘱。则通序唯通别序唯别。若如来出世来至今经对昔辨者。此之别序意别而兼通。通叙昔故唯在今经。通序文通而意别。别在今故诸经通尔。若直就昔论通别者。通序文通而义通。部含诸教故。亦有义通而意别。别在诸味故。别序文别而义别不关他部故。如持钵合盖事在当经。亦有义别而意通。通诸教故。又亦可通序文通而义别。随部对教多少别故。别序文别而义通。通叙部内教多少故。为欲遍通通别故尔。二序相对其名自分。于今经中言通叙昔者。说法则重叙出生。放光则渐顿俱照。唯有华地专表斯典意密未宣。入定乃义兼开合。众喜则悦动殊昔约昔异今。疑念乃双缘过现犹预于当。答问则广叙三同通收一代。经意既远序亦异常。是故他经直尔发起。尔时者。欲现六瑞时也。古人云众集时者。不体言旨。凡云尔时皆指前事之末后事之始。此指现六瑞之前。欲说无量义经时众初围绕。若云众集时者。不可云众集时众绕。如方便品初。即指文殊答问竟时。不可云佛从三昧起时。从三昧起。如云尔后尔乃等。皆是尔时之后。若集众竟可云尔乃说无量义。故知别论即是欲说无量义时。通论可指佛未定起之时。初则四众围绕乃至雨华地动。故云是时天雨等也。所以重云是时天雨者。别指入定后时也。此虽小事其例实多。事还不轻故令遍识。翻覆者。结前逆顺也。从前向后名顺。翻覆向前名逆。言生起者。从前向后则前生而后起从后向前则后生而前起。即答生由于问起。亦可云答起由于问生。乃至集众亦尔。虽许其逆顺意斥其无旨。故云未显。其旨者何。谓表四一。一经所显不出四故。此亦以光宅义而破光宅。若依今家应表十一。直是等者。斥其消文。逆顺但得因缘中世界一意。余三全。无故云尚自不明。况二三四即约教等三。今明下于四悉中直对四一者。表四一当同。故知一家始末得旨。人一是世界。多人和合至今同故。理一是第一义。此名最顺六瑞一一无不表中。行一是为人。修行之来为生物善。构疑兴念令众行成。教一是对治。由答问故疑除教兴。问答即是除疑教也。此且一往论其大旨。然集众等各具四一。有此表彰方可生起。逆顺有由。若不尔者。何大乘经不集众放光雨华动地。但无生于大疑请答不必妙德。答问不引三同。今虽未正说。但因疑请问答而后知。则使华地之前既说定异常。说定之前众不孤集。虽曾闻无量义。既定不散知向闻未卒。故知华地之后定起所说不轻。以前后准中应华地亦异。由是闻法表一乘人。人由现瑞表一乘理。为显斯理生疑问答。教行斯在人理宛然。又由瑞中说开经表合教。入合定表中行。放中光表中理。雨中华表中位。中地动中惑除总成人一。良有以也。故天表第一义天。地表实相之地。虽并有表兆而时众莫测。故纵闻开经尚不知开本表于合。况复能知定理等耶。故待文殊引往。方知化道不殊。故知生疑本为立行。疑决行称引古教同。乃知今佛方说教一。而令时会成一乘人。如是乃可为今经由渐。作显实先萌。若不尔者。徒云释序表法华意终自未彰。如此犹是因缘释耳。约教中应明施开废会。方显序中所表。而云非藏等者。且约废权故并云非。先废后开理数然耳。故历教简三尚未名一。若开显已无非经王。又开已唯圆故云非也。故预辨能开不论藏等。五味四味义亦如然。如此释者仍属迹门。约本迹下表本门者。须至寿量亦可预表。故知此序显表迹四密表本四。久成不逾此四故也。久近虽殊四一理等。观心可解云云者。以皆表一理观易彰。然须略知以示云尔。一心三谛理一也。一心三观行一也。作是观者人一也。能诠观境教一也。又常观三德能所皆四。法身理也。般若教也。解脱行也。和合三法成假名人。即观行如来也。约六即位位位四一。于念念中念念四一。一色一香无非四一如此观行真法华之三昧也。心境互发即因缘观之四一也。不同三教即约教观之四一也。久远已得即本地观之四一也。向因破光宅以立四一耳。总释五章竟。次众集下正别解。初释威仪中先引论者。论文有四成就。一围绕。二前后。三供养。四尊重赞叹。经文阙前后应云围绕前后。涉公云。虽是论文不顺经义。涉公犹疑译者故也。然今家多依论文。但一两处不全用耳。论以四释三不须此斥。如惟忖五句以八句释之。叹罗汉德五句以十五句释之。如难解难入加难悟等释之。故加之无咎。曾寻彼疏三二卷来。可畏处多于兹息矣。四威仪中简余三仪。欲有所闻异非时住。故云如法。况必待此经方云如法。若通论者。当部当机围绕住者。咸皆如法。正释中先斥古直云比丘等四。有云。天龙等四梵魔等四。大小客旧虽有此列。不判凡圣逆顺权实说默。今昔微着共别兼独。施开本迹都无旨归。今所列四乃遍诸四收向十双。凡圣乃至本迹不滥。又涉公云。天台立影响等众。有义无文未可依信。若尔有义无文而不依信。应当有文无义则可依耶。今谓有文有义常人用之。无文有义智人用之。有文无义暗者用之。无文无义迷者用之。故经云。依义不依语即此意也。故外小权迹望内大实本。并有名无义。故佛斥迦叶。汝昔但闻涅槃之名。未闻其义。法师自立声闻菩萨二圣众龙神人主二凡众。今问此四为复有于天台四不。若其无者何关法华。尚无当机得益之人。况发起等。无则未可。若其有者。有文有义。何谓无文。故今经列众必具此四。即其文也。义须必有发起等四。即其义也。有文有义甚可依承。法师所立无义有文。反当斯责。况复四义仍遍诸经。在今须云发起本迹约教因缘。此四次第者。机虽可发必藉先导。导机既发影响扶疏。三利全无结缘众也。若言无文。文殊弥勒岂非发起。三周获记岂非当机。除发起外诸大菩萨岂非影响。除当机众如起去等岂非结缘。况杂众中虽无击动亦能引导。通名发起。虽非镇严亦能辅佐通名影响。净名云。而生五道以现其自。并其所引四众义足。初释发起中有法喻合。初法者先明内德击扬下外用也。应物施设故名为权。顺宜制立故名为谋。有权之谋故云权谋。实智内融无谋而当。故云智鉴。鉴其宿善可生可成。故名知机。逗会无舛故名知时。击扬之言义当发起。用以释名。发机令起故云发起。初文释发。成办下释起。亦可前四字正释次四字功能。动亦起也。又剖之令开故名为发。因击扬者启之而动。故名为起。义兼能所通及自他。又击平等之大慈。发时众之一善。扬不二之大慧。动禀益之三业。又击大会之宿因。发当机之妙益。扬如来之大教。动时众之固执。又扣佛大悲故名击。咨启圣旨故名扬。令闻所未闻故名发动。使闻者果遂。故云成办。遂必获悟故云利益。次举喻者。大权象王躄法身树。至起应地。演一乘之实唱饱妙行之机缘。次所谓下合中云发起五序。咸益物机。故知集必不孤大权作命。由集故瑞乃至问答。等者等取正说。序意既彰正说垂启。故序中发起元期正宗。验知此序未通于本。虽冠经首本由别故。而两处发起俱在逸多。然迹事非远可寄文殊。久本难裁故唯托佛。释当机者亦有法譬合。初法者由有发起当机可成。当者当也。下字去声宿往也。植种也。德众善也。众善之本故云德本。以善有本故得成机。大权作用利圣益凡。如来三达说称宿种。故初成道护其没苦。方等般若虑彼机生。故至此经先略次广。三周容预摄无不该。乃至本门位登无垢。不差毫末称其往因。中我可发故曰当机。今据释众。当机二字并属所化。而须机应合论。理合义兼能所。今且从所以应所化。宿植下先释机字。缘合下次释当字。次喻中如痈者。譬有机也。欲溃者。譬可发也。为佛大圣及发起众不谋而捺。烦惑分破机缘分熟。智德分成法身分显。不起下合也。不合往机但合现发。现发即成现机故也。故不起于从一以出无量之座。即时闻于收无量以归一之说。咸登初住故曰得道。此约克体论当机也。通收乃摄六根五品。次释影响众者。然化主形声必资伴以影响。方令发起击动事遂。如响之应声影之随形。亦法譬合。初法者。初两句明影响之本。次隐其下明能辅之迹。所辅唯一故云法王。而能辅者。示因示渐示始示终。众圣之威仪也。示因故古佛隐极而现修行。示渐故法身潜圆以现偏小。此皆匡辅释迦法王。匡正也谥法曰。贞心大度曰匡。辅者毗助也。贞心助主知物机有在。让正化之功故云影响。次喻者。如星晦独照之用。但建辅月之功。显德冥扶故云虽无为作而有巨益。大论问。诸比丘何故常随世尊。答如病差随医显医功也。此举实行者。尚有影响之仪。况法身古佛垂形助化。故知四众如轻病者差。八部如重病者差。轻重俱有权实影响。次释结缘者。结谓结构立机之始。缘即缘助能成其终。则为未来修得三德之先萌也。无前三益故云结缘。即此众会前三之余。故此一缘兼具二义。谓助现助当于中先对前三辨无。力无下简异发起。德非下简异影响。而过下明非当机。凡发起众皆具二义。一者引至会所。二者扣佛成机。而法身菩萨具斯二用。故云之能。而结缘者阙其胜利。故曰力无。镇谓镇重。即内德也。严谓庄严。即外仪也。内德既高外仪必整。严饰化事光荣主用。故结缘者于其所无。故云力无等也。又镇以肃之。严以伏之。既肃既伏化道可行。故云之用。此结缘者自益尚薄。安肃伏他故云德非也。覆漏等者。覆字入声。无闻慧故如器现覆。阙思慧故如器已漏。无修慧故如器污杂。如器虽仰而全以污杂。故为用者弃。故总结云三慧不生。现世等者。现虽得闻而不名慧。闻慧尚无思修安有。此即通取六根五品。别则五千起去之流。故起去者虽无三慧。然纳种在性得为系珠。故知亦无观行位中世界益也。故云无四悉益。准此分位四悉俱得名为当机。故五品已来世界益也。六根已来为人对治益也。初住已去第一义益。是故下文随喜品末尚成当机。一句一偈结缘众耳。然闻略说则有过于一句一偈。是则不论闻之多少。但未入品俱名结缘。故五品前无复三慧四悉益也。无闻故无世界。无思故无为人。无修故无对治。无证故无第一义。故第一义有通有别。通于五品别在初住。故得度之言亦有通别。即是第一义之通别也。是则虽复四悉义通。终成结缘位别。但作下正示结缘众相。比丘下结数为十六者。若据文殊弥勒但在比丘众中。诸尼虽无请法之文。下文亦有请记之相。但俗二众虽无正文准例合有。既至会所必为权者之所引导。二众既尔八部亦然。今从总相但云四众。故知但云比丘等四。所摄未周。云无文者深成不达。次此是下次约三教者。兼论昔教。五味传引准上可知。本迹可解者。若且约体用则本住尊极。或深位法身。迹为四教一十六众。观心明位取五品为结缘者。且约观行为言。故以名字观行而为结缘。以当机中初住即入影响故也。应知初住具有二义。若旧入者唯名影响。乃至闻经超入后位意亦如是。若新入者得是当机亦是影响及以发起。即如发誓弘经之徒。言云云者。分别此四为成观行高下不同。至此位时并堪为此四众故也。五千起去尚得结缘。故知不专名字五品。故约观行从容而释。围绕初文具有四悉文不彰灼。准上言之。净居天下即世界。化为人像即为人。人以为楷即对治礼已听法即第一义。表四门去约教。若直就当教论众。自有诸教中佛。今从围绕圆极义边。乃表三教四门机动。动故见理。无量义时仍是偏小预表当闻圆四门也。今昔相望四教义足。故但云例。故知昔教非无四门当教机动。但小钝未融至此方名大机动也。若本圆人至此增进亦名为动。但不别而别得四门名。约观解者。三教观行犹如行旋。皆成圆观犹如念佛。又观秖是念以观转故。故云增也。若观下寄观以论本迹。若约体用及久近者。本住非动非不动之法身。迹示诸教机动绕佛。释供养者。犹在彼众为闻无量义经。众集之时而修供养。故释尔时不得云众集时也。彼经所列凡诸来者咸持供具。有引华严经诸供养云从十方来。亦未全然。若大庄严所献供养此例似尔。若国人所置并凡力所为

若尔何故并云天厨等耶

答。从胜而说赞以天名。故知影响发起二众供具必异。当机结缘复应料简。诸位不同供具亦别。上位尚非二乘所识。何止天供。俨然不散者。说经才竟即入彼定。当时放光天便雨华地即六动。时众睹此便生疑念。乃至问答。由此迁延俨然不散。同座复说故名为仍。须全指彼故云不得有异。文虽广略事无别途。问于三业中二业事毕意业如何。答专注之言言通事别。若以始终专注由此而生疑念。则意未休。若且以身口赞叹供养。则一期事毕。意具斯二不可一向。释现相序者。于中三先示文。次破古中先叙古。次今谓下略破。然亦许其文仍破其义。义即表报。言表报者。瑞是能表。表即报也。云未彰者光宅虽即彼此同六。皆云三双全无所表。故知动静之言太浅。上下之语既彰。况内怀欢喜非唯睹光。是故今不存其立称。况度人观理何教无之。所以吉相预报令知当善。故先示奇特警悟物情。名为表报。但众既未了知决在文殊。文殊决已知定起所说。不出一多相即。从因至果感应道交。故以三双而先表报。既列教首教须殊常。上下等言事则易了。何须文殊靳固弥勒殷勤耶。三今明下正释中三。初略列释。次此六下辨二名同异。三略明下以瑞对妙。初文者。六中除说法余五同时。虽复异同共显一致。然于六中虽前二后二正为时众。以中二为表。正在因果故也。所以华表真因地兼分果。说且显露从多定乃密意从处。圆机当发圆应照之。故知六瑞并异诸经。不同光宅。次明同异中先引文明同。人情分别去辨异。虽以异为相表报为瑞。异瑞之相本报妙理。从同义强复有文据。故顺人情未为尽理。玄者。黑色义同幽也。颐即深也。说之等者。诸佛出世本为佛乘。四十余年抑之在怀。圆音将兴虑不尊重。又复以瑞而抬掣之。令钦渴信生疑去解明。表报十妙者。若准前文秖应表报四一而已。以四一文略顺光宅。若准令文广则无量略则但十。极略秖可云表一乘。今虽云略乃成处中。又十妙者。此经既以妙报释瑞。妙义既十六之所表。道理应然。故近则表迹。远表于本。具如玄文开合者是。若且表迹亦如玄文引经六瑞。言感应中已说者。恐文误也。玄文列在神通妙中。言更道者。为辨异故。故更说之。今具录玄神通妙文对今辨别。以各有所以故也。玄文云。地皆严净表理妙。放眉间光表智妙。入于三昧表行妙。天雨四华表位妙。栴檀香风表乘妙。四众有疑表机妙。见八千土表应妙。供表感应妙也。地动表神通妙。天鼓表说法妙。众喜表眷属妙。修行表利益妙。玄文通收香风地净彼此六瑞。故遍取之。今文不列他土文者。此土自足故也。凡诸取文皆有通别。况香风地净但是开合。至下释文更有料简。又他土中上圣下凡义同感应。人法复与说法义同。唯始终中终同应息。菩萨行行复同因果。故行行文宽总摄于渐。凡所表语意并含弘。是故下文多番释之。古来诸释都无此意。光等徒施浪疑虚答。状若炫耀时众何殊精魅外通。故一家释瑞必有所表。是则大事大人作大感动。大机大益显于大理。须大眷属以辅大会。俱感大时大运成熟。自非灵山共禀此世亲承。焉能契之曷有测之。释说法瑞中复更分经为四。初列所说法体。次列体上之名。三明菩萨所依。四明佛之所护。初文者。先略引经释。次今将下以十妙。捒经等者。且将迹妙十中五来。捒字色喻反。谓庄捒也。既引彼经以此庄之。令成今妙。以彼善戒但从自行因果。故无余五。法大境也。通是教法别以十二部中毗佛略部。是方等理心解智也。净严行也。净应具七即始终行也。时位也。亦始终位也。具足是三法妙也。由因有果能岂无所。故但有前五必兼后五。况复且以因果名同。义理犹别。兼独开等思之可知(云云)。况复三祇义涉三藏。数有大小故使之然

问。以十妙拣经。乃成粗妙不别

答。从名同边可对十妙。若从序表实如所问。故须别释以对序文。次列体上之名者。先破古。涉法师云。论采诸经名有十七。慈恩广释乃为过分。今先破生观。于中先述彼所立。次若尔下今文难者。般若净名无相非序。安得以无量无相为序。次救意者。五时相生次第别故。虽俱无相前后有殊。二经之后方无量义。无量义后方是法华。故唯无量为法华序。余二远故序义不成。若尔下更难者。始自华严后后教起以至法华。此则通途前经生后乃成次第。展转为序别义不成。若诸经不然。岂独无量义为法华别序耶。次基师所立不殊生观。破准前说。次印师者。印受于龙龙受于远。所计既等破立一同。言无相善有成佛义者。意云。十二年前是有相教非成佛因。指无相善有成佛义。意云。至法华中一切无不皆成佛道。所言义者。谓可成也。故以成佛义为一乘经序。又云等者若尔。方等般若亦明无相。亦应以方等般若为法华序。印师防此伏难。故更述无量义与大品对辨。大品无相犹说有三无三。无量义中无相不说三之有无。故大品无相非法华中无量义经。无量义经未翻译故。此有三失。一者错解无量义云不说有三无三失。二者谓无量义未翻译失。三者妄破古师以大品为无量义失。然初失者。彼无量义既说二三从无相出。何名不说有无之异。次今谓下今文破也。但破第二余二可知。故具叙经来翻译年代。注无量义经序云。此无量义经虽法华首载其名目。而中夏未睹。每临讲肆。未尝不废谭而叹。忽有武当山惠表比丘。自伪帝姚秦略从子。略是苌子。因为晋军何澹之所得。养为假子。俄放出家勤苦求道。以齐建元三年。至广州朝廷寺。遇昙摩伽陀耶舍。欲传此经。表乃致请仅得一本。仍还武当。永明三年九月十八日始传于世。经既已来等者。笑印师也。次破光宅中亦先依彼立。彼立意者。以同归与法华仍有二异。一者同归非无二无三。二者同归非破三与一。虽有二异由同归故。可成此二。故以万善同归为无二三等序。若言下先破初句。问无量义中同归万善。何异法华所无二三。两处若同破则俱破归则俱归。二三下结难。次若言下破其次句。前举其无量义难其法华。今举其法华难其无量义。此难意者。前破语存略。破三正是破二破三。故今牒言破二破三。但加与一异于上句。故先将破以难同归。故云何不破万。次破二下双牒两难。初难唯正无序。破即是无故破二三。是无二三。文中语略。亦应更言若破二三即是破万。既其破万是则无序。若以低头举手为万善者。二三尚无万善何有。若其俱无序义安在。次取经下即纵难也。若言二经俱归俱破但此经举破彼经举归。今亦破云不成异也。既云互举归必有破破必有归。互举一边岂得为异。次异意下结难也。凡言序者。须与正殊。殊又表同方可为序。异同既混序义如何。刘虬下破注家也。亦先依其所立。次若含下破其不赀。与其无相自语相违。故将其不赀难其无相。寻诸下总览破之。先总破。次若言下去取也。破序不成为去。判属方便为取。初判印先对彼无相。况立有相判入三藏。次若言无相下。正判印师。次若言下破注家此二既然。余例可见。故诸家所释不出三教。故指权教通名为他。次若法华论下今文消论。既云法华是无量义异名。故知无量义亦是法华异名。则序中立名于理无咎。前说无量义经以为法华序竟。更依论意即是先说法华异名还入法华之妙定

若尔。前已说竟今何重说

答。前所说经灼然成序。重牒其名义兼于正。故使论引今为异名。名义两兼序正双得。次大品下引证序中立名无失。故大品经序品云。释迦牟尼佛今既现在。为诸菩萨说般若波罗蜜经。金光明经序品云。是金光明诸经之王。涅槃纯陀品中纯陀自叙云。我今所有智慧微浅。何能思惟如来涅槃之义。古经此文元属序品。谢公治定乃加纯陀哀叹品名。又云下重引者。异名同名俱序中唱。今案下依经重释无量义名。以证成序。先列经文以辨今意

次复次下以无量义。对普贤观以破旧师。初文先出能生。次所谓下所生。今释下解释中有法譬合。初先释上无相

问。经中亦以无相释之。与他何别而苦破他

答。不同他也。旧以所生无量为无相。经以能生一实为无相。从实生诸诸名无量。无量是相何名无相。故经云。言无量者从一法生。故不同旧所生无相。注者直云含法不赀。但得所生失于能生。经从能生于所以题目。人师将能为所以释题。故云从此实相生无量法。故今更释能生。故知能生中道实相。与今经实相不别。二法者下更释所生无量。虽曰所生义兼于能。从多名所。顿谓等者。即顿部中具有渐顿能生所生。亦指所生故云顿中一切法也。渐谓等者次举三味。此三味中亦有能所。例顿可知(云云)。三道等者。此中三四亦具能所。圆菩萨及佛以为能生。三菩萨二二乘以为所生。故此三四摄法亦遍。例如渐顿亦具能所。是则凡一实理皆诸教流出。无量义中述其意耳。故三乘中二乘含四菩萨兼三。若作三四义通四教如向所对。若作三四并是所生。则菩萨及佛但在三教。从教判权。玄文复以四佛为四果者。则圆佛为一而生权三。能所相对故云四佛。是则菩萨名通于义无失。故于独一生于兼一。思之可见。此等下更结所生以示能生。能生义处法华别名。所生无量为法华序。故序中一名义兼两向。然应知从一以出无量。虽举能出通皆属序。若无量入一虽涉所生通皆属正。故义处一法亦成两向。出生之义处属序。收会之义处属正。即从一义处已下两句文。是其两意。故佛入义处义兼二途。譬者序如下从一出多。正如除从多归一。故知昔教赴机益物如用钱市物。而皆未知其大数。从一下合喻。如此等者。结前能所以成两解。能生不违论。所生不违经。但依两解经论理存。消释既尔得意者何。即所生为能生方是异名。能生家之所生。此乃成序。若也专能何殊生等及昔一圆。若专论所何异注者及昔三教。是故各存还成双失。所以今家能所相从二义俱立。若专序者。则法华已前非但未论会多归一。亦未曾说从一出多。故无量义唯今经序

复次下以前后二文。对破古者。此非正破。于余文中光宅等师云。法华经不明常住。今因明无量义序异。便救法华经正常。无量义经在法华前。普贤观经在法华后。序结并常中何容别。何故乃云神通延寿是无常耶。故引彼经偈云。如来清净妙法身等。岂非常耶。言百非者。彼偈略列三十四非。以之为式。诸非准知。此明法身性离诸非。故总举百。然绝四离百之语犹通浅深。节节比之。今应从深观经四波罗蜜者。经云。释迦牟尼名毗卢遮那。遍一切处。其佛住处名常寂光。常波罗蜜所摄成处。我波罗蜜所安立处。净波罗蜜灭有相处。乐波罗蜜不住身心相处。既以此四成身成土。尔前理合身常土常。故大师追括五时。悉皆有结具如玄文。他难下他难今家。序中能生已明常住。则序已是正正何所说。今反质之云。序正俱常于理何失。又例去他人滥引云。例如净名序中说常。正不明常即是无常。故将法华以例彼经。应当法华序常正应无常。他云净名序常正无常者。彼净名经弟子品中呵阿难云。金刚之体当有何疾。乃至佛身无为不堕诸数。古人判弟子品菩萨品。并属序故。又取通序叹菩萨德。深信坚固犹若金刚。今亦反难意者。若以法华例于净名。亦应以涅槃例于净名。则涅槃序常正无常也。故知秖可以净名例于涅槃。序正俱常。汝自不了净名宗体。谓正无常而为例耳。当知净名亦序正并常。故问疾品中明第一义空。空即常也不二法门正明中道常也。不思议品明常家之用。观众生佛道以空假显中。香积佛品明香饭体常。菩萨行去复宗明常。故知正宗始末俱常。今论下结难

若尔。诸部何别

答。言序正俱常从极理说。若须辨异五时自分。具如玄文第一卷辨

若尔。序正何别

答。各有其致。且论今经序中虽常未明会所。正中须以会所乃常。常外无余序正仍别。余经例之各有其致

法华文句说卷第二(下)法华文句记卷第三(上)

        唐天台沙门湛然述

教菩萨法明因人所依。此去仍带异名以释。故加之以处。处为能生之一法。一法秖是究竟相。故云谛理。谛理乃与法华不殊。故灯明佛叹法华经。亦云教菩萨法佛所护念。故得引下普令等文。以之为证。证义处也。所以经名在序。但云无量义耳。以兼正故。教菩萨法加于处也。取下三昧来通释之。使两处义齐俱序并正。嘉祥云。此有二义。一者实相名为无量。二者实相所生名为无量。今谓无量之名可名所生。实相之称应申能生。虽立能所俱名无量则未可也。若对异名能生之法。名为实相。斯则可矣。直尔释序意都不然。经自释云。无量义者从一法生。生即所生一法。能生即实相也。古来匠者。如何得以能生释耶。故论云。此是如来欲说法时至成就。既云欲说非即全同。若其全同即是已说。故论存序。乃云欲说。意兼于正则为异名。论其二途今释准彼。亦顺下文三昧为叹。若所入三昧唯依所生列名。秖应但云无量。故知经名文在所生。意兼能出。所入三昧义必双含。所以前消论云。欲说此经先入此定。今从经所表边。复以义处叹之。及引文证全在此经。佛护念者。果人所护。既是能生无量义处。复是佛所证得。岂佛所证而非实相。故引自住而以为证。昔未说故名之为护约法约机皆护念故。从虽欲下明护念意。佛意本欲唯说能生。故说无量义时机仍未发。隐而不说。故云护念。故无量义下一护念言亦成两向。但彼经文虽云从一出多。未云从多归一。犹是覆相名为护念。若不尔者。则已说法华。何名为序。以未说故。故云虽欲开示等也。以未说故护。未畅故念。言久默者。自昔至今。斯要等意思之可知。若唯从所生非专佛护。在昔通说无时不然。故法华论云。莲华二义。一者出水。二者开敷。彼如出水此若开敷。所以仍名为莲故华。但有未开当开之别。释入定者。先举所入之定。次明能入身心。初文中三。先结入意。次非禅下释结意。三疑者下释疑。初结意者且约彼经彼定。而相成者理则可见。次释结意者又二。初明定慧之用。互有相资各有力用。次明相即即定慧体。初相成者。先说后定且从序说。先定后说如下释疑。佛居果位必无先后。为顺化仪现有先后。究而论之其体相即。次立疑者且依序问。凡诸化仪。皆先定后说。此中何以先说后定。答中先顺问答佛之常仪。次申定意。欲明一定义分两途。次说此下述为序意。今时何故先说后定。常仪说已即应众散。更入此定肃其现众。众既不散得为今序。次何者下述为正意。以一定中义兼二意。意虽复二。时众但见无量义后即便入定。不知所入为是何定。不知定后为说何法。故结集者复符佛旨述所说经。但云无量。述所入定即加其处。若从义处以出无量显成序意。若收无量以入义处。密成正宗。虽加义处众亦莫知。言若作次第等者。亦顺化仪辨定先后。即以不次第而论次第。于佛内照岂可分张。若明文等者。谓如来当时不先示定体。故使弥勒勤勤置问。乃是经家于别序中。且覆别以从通

问。如大通智胜说后所入。为是何定

答。文虽通云静室入定。岂妙法后入余定耶

问。今佛何不准大通智胜。亦先说后定。是则皆用说前开定。为说后合定作序耶

答。彼佛让王子结缘。今佛但罗云通化。结缘义同通化何妨。故使今佛序定兼正。即成先定后说也。智定相成前后何在。若尔彼佛前定岂不含两。准有疑念彼此皆然。弥勒等者。殷勤指四伏疑。靳固指四伏难。皆累至四故曰殷勤等。靳字(居觐切)牢也。二定并得为序。故云其义转明。身心下明所依身心。先明不动所以。以得所缘实相故。令身心不动。次云身之等者。释上身心所依处也。故知身心不动亦由义处。故本源理性俱名为处。对彼身心假施二称。如来实证色心体一。即此色心是三德故。欲说本有理妙常经。先以色心不动表之。又身之与心俱表示迹。今以迹表本故云虚空常寂。次引大通入法华定证身心也。故此定体名异理同。若分所入相同时别。上二句证身。下二句证心。身若下重譬身心称理故也。非常住法身。不可以金刚喻。非本有理定。不可以虚空比。无量义下结此身心功归义处。称为下释疑。疑云。定若依处应唯称处。何得复存无量名耶。此定下释也。言无量者。所照得名。所照者何。即所生是。亦非异时故云而照。无量即处存亦何妨。若作等者。向且存异名定体身心不动。若将此相以表序者。以此不动等正表序后当说一实。今指不动不分别时。如义处也。上句释身下句释心。是则却对定前身心动运分别。如无量也。先开后合序义灼然。次更问答释疑。先问可见。次答意者。若准常仪说已便散。何足为奇。今说已入定知后不徒然。后若不徒然。前定体应别。故众集说定皆表当闻。故令时众肃有所待。肃字息六切。尔雅云。肃肃翼翼恭也。翼翼恭恭心有所得

问。彼经末云受持而去。今何故云不散有待

答。彼结集家语通经者。恭承严旨闻必流通。故云而去。今据此经无集众文。说已入定定起即告。告前所集不散何疑。故华严等经皆悉先以声光集众。虽入开定等者。开定之言仍前序意。未尽其旨故立虽言。意既在合定体岂违。常定尚未曾云从一出多。况谁曾云从多归一。即开表合故与常殊。文殊引古既云皆有此事。故知一定二义不疑。故云何以证今。岂可以等者。古人不立说定为瑞。故通斥之。乃集经者大权所置。故非凡下之所测量。释四华者。先出旧人及经论明华名不定。又大般若亦云适意大适意柔软大柔软。然诸教不同文多列四。若云公所感。言如云母。此乃一时征应而已。约所表中斥旧云狭而不当者。于中先斥其狭。次斥不当。初斥狭者。今教教十六岂比旧耶。故责云收三藏十六不尽者。唯四故也况直云十六为何教一十六耶。故应历教简一十六。亦可责云。为是发起十六乃至结缘十六耶。故云况四十八。故知语比丘等四。虽含发起等。而无理显之。若标发起等四。摄比丘等四。况声闻菩萨及以杂类。类中一一无不皆具发起等也。因古述四。故须对比丘等言之。夫华下释不当者。此华密报现得妙因当趣妙果。古直云四表比丘等。故招今难所雨者华华应表因。四众已得何须更表。此责古人不知雨华表现妙因异昔因也。若表四众唯希新果何须雨华。此责古人不知散佛。表妙果在当异昔果也。今昔因果粗妙永乖。混同一称今昔无从。又生公亦云。表四果不实。此乃用于三藏菩萨斥小之文。则知四果不实。尚未解通教。何能显法华。次今言下正释。先举昔偏因对今圆因。昔圆因不别故但斥三教(云云)。三藏中但云二乘者。不可接故。应如玄文云昔三因大异等。佛因者。秖是圆因。四轮因者。即初住已上。铜银金琉。止观第一记具引璎珞。玄文复以四句判位。开前合后如三十三天等。开后合前如十四般若。俱开如四十二字。俱合如天雨四华。次下文去。引今经诸文。并是位义

问。答中意者。借别显圆。言借别者圆非无位。借于次第高下。以显不次平等耳。此之借义请后学在心。以此宗学者或时亦迷璎珞四轮是借别义。若论圆位六即亦足。何须更列四十二耶。以分真位长故。借别位分其品秩。譬虚空体一而飞者浅深(云云)。故止观第六末云。或借高成下等。玄文尚用名通义圆。况名别义圆耶。次问者。既借别位别有贤圣圆亦有不

答。指玄义者。具如玄第九卷。非无贤圣但高下不同。又四念处中亦四句分别。若定判者即住前属贤。若四句判。但是义立更互得名。住是贤位又去圣远。故名贤圣。别地名圣圆行向人去此地近。故名圣贤。于今圆文行向是圣复更入地。故云圣圣。若不相望当教名定。若言去复历教破旧者。虽曰一因应识因体。四教菩萨各望其佛。并是一因而一因异。故玄文第十从一开一从一归一。既不辩异通教何疑。故通教云。三因大同同故一也。故云不出通教。若言四众同是菩萨因者。从初发心不共小故。法华意如前者。具如四轮乃至开显。释普佛世界等者。初破古者。以六表六其义可然。直云三乘但破三藏。三乘因果义未周悉。故以藏通两三及别横竖。比之方显圆经六番破也。涉法师云。地神令动此见甚薄。约别破中云纵横者。且如止观第三所引。今释下正释也。初文似约教。清净行经似因缘。初文释中云磐礴者。即坚大貌也。即七方便人未破大无明。来至此会始破无明。无明难动犹如大石。是故云也。又前非不破据难破者。至今皆破。故云磐礴。若准长含多缘地动亦可为表。经云。有六缘地动。谓入胎出胎出家成道。法轮入灭。小教虽即不云所表。既在八相中之后六。即初地初住位之功用也。故此位居六番之首。四轮但因故从因立名。六动兼果从果立名。又极果分果俱得名果。故名为果。破古对今则具四教。又妙觉者虽未即入。到在不久。始末兼举故云从果。本迹后言云云者。应引本文我本行菩萨道时。即本四轮也。我成佛已来本六番也。本初实成亦以此瑞用表六番。故显教中。文殊引他佛之昔事。同我佛之今序。密意正表昔佛必有于今。今佛岂无于昔。昔成已久故非一反。观行释中初句总标。次正释中初约动为表。次约六为表。初文者。言虽兼六正语于动。皆表当破无明。名为动难动地即能表也。净未净根即所表也。次东等二六者。俱约六数表也。表净六根约观解故。故得通约观行相似分真等位。皆净六根。于中初六者。事东踊等。具如中阴等经。今入观心义复符会。言表根者。眼鼻已表于东西。耳舌理对于南北中央心也。四方身也。身具四根心遍缘四。故以心对身而为踊没。谓中踊边没边踊中没。可表六及十二入也。复有六动者。义兼十八。于其六中前三是形后三是声。形实声虚。六根亦似三形三声。此六事释新旧不同。新云动踊震击吼爆。今且用旧。摇扬不安名动。自下升高名起。[嶙-山+土]垄凹凸名踊。六方出没亦名踊。隐隐有声名震。砰磕发响名吼。令物觉悟名觉。新云击如打搏爆若火声。经论略标多云震动。即形声三各标一也。大经云。纯陀去后未久之间。其地忽然六种震动。又各有三者。以表一根各有根识境三。初文表六中表虽更互破必同时。净十八界者。次辨所表皆破无明。故知秖是见阴界入皆常住耳。云云者。应具述所表以成观心。但略存数并阙心境辨妙相状次不次等。亦可根根皆修三观如十八动。此中但约能动之相。所动唯秖一地而已。如根虽六以心破故。一切俱破。释大众心喜中。先因缘者。昔教奚尝不睹雨华等相。今欣跃殊常。理应甘露方降。时众虽无测者必知机成不久。机感相应何疑不释。问如文。答中通明异常故也。引大经证如文。次若言下约教。虽具列四对昔四喜不同。于今纯一实喜无复差别人天等四皆云动者。权为实动故也

问。实理无动今那言动

答。动即发也。圆机当成名动实相。以余四动当趣实故。文无本迹观心。若作本迹者。本住不动三昧。迹以地动表发。义立观心动者。如二十五三昧中破四天王空假中动。释毫光者。初文总标放光。释中初释白毫。次释放光。初文但有二释。初双标二释。应机标因缘。设教标约教。破惑下明二事意也。现光本表斯二。具二方除疑惑。白毫中初是因缘

复次下约教。初文四悉者。初文世界。其毫下为人。放光下对治。光照下第一义。四皆此经。次约教中具斥三教二乘即当前两教也。虽有菩萨同见二谛耳

复次下明放光。具为四释因缘中三。初放。次收。三收放意。初应具四悉文相不显。但可通令见得四益。大品一一相各放者。以身轮表般若遍也。大经面门者。面门口也。表佛口密说于秘藏。今经定中眉间表意随机各现皆具三密四悉益也。虽一代来三轮施化。当当之益莫若言教。临灭之际面门放光。表此言教流至来世。今且通论放光。若别论者。准诸文说。不照无色义同集众。次收光者。初引育王。多是因缘释。此中现在一文是章安私意。从足入去并经文也。各表记其当界。所以他经授作佛记。皆兼诸界。唯此法华专表佛记。言当界者。但明诸界各有死此生彼及大小果位。以下表下等部属方等。故对多缘。而今经等者。定起必收收必肉髻。略耳者。以至佛从定起必须收光。以所表事办须敛众心令入一实。是故合有收光。但是文略。又解下次收放意。可见。亦是一途非究尽故耳。以现在正令会三归一为正。未来当得为旁。若文六下约教中。先正释。次明光表。表中先破旧者。旧明虽横照一万八千。土至尼吒皆此土瑞。今意不然。放光一瑞义通二土。言由人者。不能全破。次旧下旧解但约一方表满不满。若照下破也。既许实照十方。何得独以东方而为所表。有人云。眉者。放光处也。眉者。媚也。若人无眉则无媚也。所言放者。一者不制唯照大千。二者作意发动则照一万八千。亦云表一乘。此不知佛无谋而作。以作意放释诸佛之功用。今明去正解。次若就下本迹中。表四位增长者。四方表四集表增长。言增长者。从信入住。乃至等觉。故下文云余一生在。次观解中云此等境界者。即十八界各百界千如。蕴在十八。佛慧未开。故以光照表开。开即别在初住。文云去。引十界机皆开十八界也。言分文属此土等者。始从尔时终至周遍。并属此土第六瑞文。他土初瑞但从下至至尼吒天。今文以此放光之文。通兼彼此。故其文势亦含长短。若短取者如向所列。若长取者须至尼吒。还将此第六而为他总。若为他总亦有长短。准望应知。次明下正明他土六瑞为二。先略次广。初略中为四。初标。次一见下列章。即当正解释也。三既有下生起六瑞。四若此下对此以明瑞之所表。次列文中但云上下不云感应者。以感应义通三双故。不同此土前之二双并在于应。故第三双得云感应。又彼土瑞至第三双生起中。云行始必终者。但互举耳。明菩萨有始而必终如来已终而有始。又人法双中虽人通鹿苑之未。法唯乳味之初。然法必有人人必对法。故且对辨。又上下双中虽上说被下。而被物未显。即虽未显始末由之。故得对之以论上下。况凡诸取对皆是一往。是故更须求其始终。初双中六趣者。广解章门非此中意。乃至离合以为四生五道七识住等。如论广释(云云)。言总报者。瑞虽有六以光为本。光表觉智。光照此彼。先表二觉。次表三同。于三同中二。先总。次别。先总明道同。同相如何不出三同。既今同仍隐但成二耳。若所见中亦见授声闻记。说寿长远。则如来都无所作化仪不成。虽然纵见记小长寿。此众亦疑。不知此土声闻为合记不。既教踊出其寿若何。等是未知。故并隐之以生疑问。文殊广答具述三同。众机略知定后之相。故知通序文通而释契别理。由四释故。别序文别而义妙由五时故。所以答事才讫定起于斯。事符于答知文殊见极。从尽见下别者。即三同也。次广说中初文先出他土。次当知下引彼例此结始终同。起塔之相虽表二经。法华之相犹未明了。是故但成具于已当二同。此土三同当仍未起。言二土出世意同者。同五浊故故施等不殊。开权即是法华之相。息化即是涅槃之征。非顿等者。法华一乘非顿渐摄。于一开出乃顿渐生。是故今云非顿而顿。非渐而渐。准此可知。起七宝塔者。二经味同。隐者未说。十二因缘经云。八人应起塔。谓佛菩萨支佛四果轮王。佛八露槃。余之七人次第减一。此土既尔他应准知。故今所见须皆佛塔也。当知下引彼例此。总结前文。言从一出无量者。始从华严至般若来皆从一法开出。至般若时顿渐已竟。而人不知法华出顿渐外。请观竟字。法华但是收无量以归一。次更约因缘释者。文中自有通别二释。初云通者。通于渐顿遍于四时。四时之中各有感应。对今无非今教之因缘也。故知因缘有其多种。自行化他自他相对。文从自行故云昔善今教等也。次别说下正明现在之因缘也。亦可此三展转相生。由发心因缘故信解。由信解故行行。若别说者。别指般若中三教为种种也。故云三藏之后。以般若部是菩萨行故。又就下以般若中三教。教教皆有四门及四悉等。故云复有无量相貌。言五百者。明共门中种种广故。五百虽是三藏有门。约所证同且证于共。来至般若并成通人。冥得别益。今且从显故得引同。仍旧乃成种种故也。不共易知但例而已。共不共名出在大论。既云藏后。理应通指方等般若。唯云般若者。以方等三同般若三小同鹿苑。故不别指。他人于此离为三门。谓因缘门。信解门。相貌门。今谓言辞虽尔义理不然。因缘谓感应差别。信解谓能感不同。相貌谓信后行异。有此不同皆云种种。虽复殊途不逾二味。感应则互有疏密。故云因缘。能感则内怀纳受。故云信解。修行则身口外彰。故云相貌。外相仪貌故云相貌

问。行一解异如何行别

答。睹外识内故名不同。言彼明此相者。彼谓彼土。彼所现相故云此相。虽复种种。同至法华无复余相。但未见法华座席以入灭表之故但云一因一缘等。言一因等者。亦是彼土法华已前得云种种。既会入实同一因缘相貌等也。此是感应等相

问。光中所照一时横见。何得乃云先顿后渐乃至会归耶。又于见中可无纯顿唯渐等耶

答。实如所问。时众但知因光得见。大术在于世尊。见者非其境界。然令见意本为证同。所放光明为成一实。事殊理绝者非光所沾。远近既俱令其见闻。过未亦何隔于视听。故使十方始末皎若目前。安以凡情测量圣境。何独化主佛力令见。同闻众中及以集经者。时有古佛晦迹其间。智鉴当时述斯横竖。加令见者圣凡一等。故知但依文次经意宛然。次尔时下释疑念序。初云但成一疑者。本疑六瑞。自力不任方思答者。再思有在仰托文殊。文殊念兴有决疑地。故第二念于兹自亡。既已得人何须再念。故第三念于时复息。及至发问初疑尚存。故云一疑

问。经称文殊是法王子者。此诸菩萨。何人不是法王之子

答。有二义故。一于王子中德推文殊。二诸经中文殊并为菩萨众首。次释初念中初因缘释。云神变内外者。此明表异须此别释。若通释者。如大宝积经一切诸法皆名神变。具如止观第一记引。神名下释名兼辨相。首楞下明所依法。法王下功用也。亦是问由。次若夫下即约教也。亦是更释功用及以问由。又此问由虽由不测神变。正由自决故利他机发故应赴。因缘和合而设斯问。令知弥勒不识所以。故须诸位展转比决。散者苦行外道及诸凡夫。定者得禅外道及信者习定。圣者三藏中除身子外诸声闻也。此就极处亦不知者。凡若夫之言明其意通。故下节节不知于上。若极位者则一切下位而皆不知也。故菩萨补处及以尊极。此之三位。若存教道应通四教展转互比。文中且然。今最居极故补处极不知尊极。又弥勒去义当本迹。隐本智明迹同暗讷。若作观心释者。智照灵通六即随变。初文因缘义对四悉。其义宛然。内外异故见闻欢喜。六瑞外彰物睹生善。依理变通遍调一切。法王理极故无过上。若将下偈显大众疑念同弥勒有三者。此诸大众共睹六瑞。自入位来遍历多会。久知文殊神用莫测。故至弥勒兴念之时。众亦精诚专注妙德。故使弥勒发问之际。先观大众方宣固疑。审知文殊是决疑地。旧解可知。准今问答意引偈既云三念不专弥勒。但处一事任运发问居先。言问答者。文殊最能何独弥勒。应云物机在于问者答者。故以四释而消其文。即因缘等也。初问答下是因缘。如文殊推堪问疾于无垢施。仍为所诃故云在无。又法门下约教。四教不出权实故也。又迹下本迹也。又名下观心也。初因缘中其文虽狭。若义立者亦具四悉。问答随乐即世界也。赴众所欣为人也。咸释众疑对治也。位行齐等第一义也。次发问序者。颂初先料简偈文有无。先何意下问。次龙树下答。论文十义今但列六。前五即初五文也。六使后人于经生信。七易夺言词转势说法。八示义无尽。九明至人有无方之说。十如今文第六文是。总论即因缘释也。初二世界。三五为人。第四第一义。又为下第六对治。能除后来疑故。余阙四文。第六同为人。第七同对治。八九同第一义。故略不论。正释中先述古。次观文下且总非之。说法下释出显是。于中先明非缩。次明非盈。初文准义在初二句中。故非缩也。于中先立。但举放光动地之末。则知说法入定之本。若无定慧安能现变。次他不见下责。今反下引答以难。又问下核出问处。今指下答也。前长行但总问放光若执唯光是问。余不问者应当非瑞。则雨华动地尚不成瑞。何独说法及入定耶。放光既在此土瑞终。仍居他土六瑞之首。故总举一光通收二六。况若更下别问导师两字义自兼之。次明非盈者。风地二瑞并有所依。所依是瑞能依岂非。故于今文明非盈也。于中亦先述非。次破中初一句略斥。次风本下破为二。先明风有香尚得为瑞。况复风地本为显华。虽各立瑞名而共成华德。正法华中但直云香。不云风也。故知风若无香不成瑞也。夫天华下明香本属华。华香如檀故云檀风。若香风非瑞华亦非瑞。地净准知。于中为四。先总明有香等。次此表下释出所以言因运至果者。明华香入风如道风德香熏一切也。三金光明下引证。四故以下结成。以果上二事显因功也。由华有香非独风尔。由香风故其地必净。言二事者。谓功德法身。功德因也。法身果也。由至果故成就二义。一至果二果净由因至果故令果净。次二句地动瑞。次一行众喜。虽不依前次第六瑞宛足。次初三行下言验此等者。前长行中光瑞乃居此土第六。乘此即明他土六瑞。他土六瑞无光不见。故须判为他土总瑞。恐人不了至此点出故云验此。故偈中此土光瑞云大光普照。前已明竟。至他土瑞首重云眉间光明等者。重牒总瑞文耳。涉公都不立二土六瑞。但云此初行中上半译是。下半译非。应云佛在大众入于三昧。三昧大事。而不云放光。下文自有。今谓此文自是他土总瑞。故知自未晓于经旨。徒加译者之非。既为他土总瑞。所以不别分之。但戴在六趣之始。即初一行颂总瑞也。次颂别瑞初颂六趣中云六是能趣人者四趣。及天虽即非人。通指宰主。乃遍六趣。于中初二句略举上下。诸世界下具列依正因果。初诸世界者。指万八千。非但见能趣有情。亦睹所趣诸有。非但见果报好丑。亦知业缘善恶。故见六趣但是取机之所。又睹下云圣主师子等者。圣即是主故云圣主。有人云。圣中之主。谓于外道支佛罗汉法身菩萨诸圣中主。今谓华严十方世界主伴之主。非关二乘外道。但是诸菩萨伴中之主。圣主如师子故云也。师子具如大经大论师子法门。又师子吼者。名决定说。前两教主非师子吼。说非决定不谭真实第一义故。虽云兼别最初纯大故云第一。前之两教犹杂烦恼。故非清净。赴机未遍不名柔软。并诠中道故云深妙。称理当机故云乐闻。有云。如来胸中大种所起。故名清净。无卒暴故名曰柔软。此以欲色凡夫报质。释佛梵声。一何苦哉。各于世界者。一者以万八千为各。二者主伴不同为各。信知须判为华严教。前之两教及中三昧无此事故。二教八门名为种种。无三乘事名为佛法。若人下颂四谛等者。他人不作华严消文。遭苦已前鹿苑之始。岂有各于世界之文。以小乘中无十方佛故。顿后渐初唯有鹿苑三藏三乘。初乘四谛乃至佛子三相宛然。如何不以五时消文。文中先出能厌之行。厌不遍故未得名尽。双厌因果。至说涅槃。方乃厌尽在文分明者。苦含因果即苦集谛。厌老病死即道谛。为说涅槃即灭谛。亦可为说之言兼于道谛。涅槃之道即道谛也。所证灭理即灭谛也。又遭苦是总标厌老病死是知苦。知苦故断集为说涅槃是知灭。知灭故修道。难陀持戒具如止观第四记。支佛但说得果之由及以所求法胜。若例声闻须明行相(云云)。若有佛子下是开六度大乘者。修种种行及无上慧诸教共有。今初形凡小亦得种种及无上名。不杂凡小通得名净。非毕竟净者。且约三藏六度言之。药中无病名为净耳。若欲于此辨四悉者。三乘行异世界也。缘觉为人声闻对治。菩萨第一义。况复各各皆具四悉。三乘约教准例可知。本迹观心亦应可解。下去诸度随文略消。又声闻等者。且约当教一途而说。应知通教三乘。并以界内灭谛为初门。别教菩萨以界外道谛为初门。圆人以界外灭谛为初门。此中明因光暂见不合广求法相。但略堪表同于理即足。若论修行方可广辨。以下三十一行半广明二味。故判此文唯三藏也。结前开后者。结前中言见闻及事者。据渐顿教皆云演说及为说等。即是闻也。又见佛子等。即是见也。见中种种多皆事也。大纲略足故云若斯。同者略之谓千亿事。言开后者。续后而说故云今当。及千亿事文中置之。今应两牵。亦可前四句结前。如是下二句开后。兰菊之言斯有在也。此下三十一行半。分文但云菩萨修行。既居鹿苑之后。又在涅槃之前。准下释般若须兼二酥。以法华相未决了故。从容释之。虽约二酥教多在三。如前分别故。诸度约教别圆之前多不云教。含二意一尔后释义。准部通四令识眉目。以长行中具云方等般若故也。总问中经云恒沙者。阿耨达池四面各出一河。东银牛口出殑伽河。南金象口出信度河。西琉璃马口出缚刍河。北颇胝迦师子口出徙多河。各绕池一匝流入四海。于中殑伽沙细而多。外人所计以为福河。入洗灭罪。佛亦顺俗故常指之。又佛说法多近此河。故以为喻。此下六度但略指大体。若依二味具出其相。具如止观第二第七记所引

问。既云方等般若。亦应具有两教二乘。何得总问唯求佛道

答。实如所问。但避繁文。还同鹿苑故略不说。驷马者。四匹共乘故云驷也。侠字胡帖反。豪也。文殊下经云往诣等者。表往非余故指佛所。所问尊极云无上道。所弃不轻故云乐土。身心俱离故云剃除。如是消释世所共有。凡诸解说贵在教宗。显理之精息其繁芿。五王经者。此是一卷小经。经云。昔有五王邻国无竞互为亲友。有一大王名曰普安。习菩萨行。以余四王邪见炽盛。普安愍之呼来殿上。七日七夜娱乐受乐。四王曰。国事众多请退还家。大王自送并命左右而随送之。至于半道而问之言。各何所乐。一云。愿春阳之日游戏原野。一云。愿常作王种种严饰。人民侍从道路倾目。一云。愿得好妇儿端正无双。一云。愿父母常在多有兄弟。美食音乐共相娱乐。各各说已。回白大王。王何所愿。答我先说卿所愿不长。若乐春游冬先雕朽。若乐为王福尽相伐。若乐妇儿一朝疾病受苦无量。若乐父母常在等。一旦有事为他所执。四王又问大王如何所乐。答言。我所乐者。不生不灭不苦不乐。不饥不渴不寒不热。存亡自在。四王问曰。如此之乐何处有耶。何处有师。大王曰。吾师号佛。近在祇洹。诸王欢喜各诣佛所。却坐一面白佛自责。佛说八苦。王及侍从百千万人得须陀洹舍国入道。大相略同。既云问无上道非关小果。且据舍土出家事同。故今引之。光中所见亦可八苦以为助行。诸教共之故舍国事同。观行须别以分诸教。又如长含有四轮王。分于一国雇人剃头。既云诸王机亦不一。下去又见等亦通诸机故也

法华文句记卷第三(上)法华文句记卷第三(中)

        唐天台沙门湛然述

经云被法服者。如璎珞经云。若天龙八部斗争。念此袈裟生慈悲心。意令比丘安可不忍。亦令俗众生慕乐故。龙得一缕牛角一触等(云云)。彼王所慕与此大同。此中只合明所见意以序表正。诸度行相功德及袈裟等。但是寄此泛明之耳。然必须辨行体显教以分味殊。生忍等者。文中两解。初通以三句用释三忍。次一一句别对三忍。应须附文释出所以。若分三忍对四教者。生忍苦忍别在初教。通为四境。何人不须具此二耶。别在地前。求佛道者。此中虽无但准例说。次文即以诵经为第一义者。若不求佛忍不关诵。故以诵经同求佛道。第一义忍通亦在三。别唯圆别。故令三句诸教不同。如别译阿含。佛在舍卫有一梵志来至佛所。种种骂佛种种恼佛。佛告梵志。如汝以种种饮食上王。及遗亲族。彼不受者为复属谁。梵志曰。此属于我。佛言。此亦如是。我既不受还属于汝。故此不受亦是生忍。故此生忍别属三藏在阿含故。通于通教理不受故。况复通用诸教共之。其名既通须释相状。次进中实相亦可通四别二。窳者。如瓜在穴病也。禅中云通途皆有根本修者。诸教皆修故也。若达根本。即成出世及出世上上。具如止观禅境中明。今文语略但云出世上上及以根本。根本即三藏。出世即通教。上上即别圆。又四教皆以根本为境。故释前行通涉诸教。于前行中云离欲者。通教也。又根本下藏通两教也。此两皆修根本背舍等故。然应须知观行犹别以辨两教。别离二乘且从难说。中道离欲中义通圆别。从圆受名。重释深修者。由深修故离欲不同。则根本中亦应传传为深故也。此中根本乃至二乘具六已来。亦具藏通二教意也。别教五通如文。亦可让于初地已上。圆教初后皆六通者。但约理圆无漏失故义立六通。若从实说。初地初住分得无漏通耳。安禅等者。前通释中通深浅故。今上上禅别在别圆。释般若化他中。云定慧具足者。别人利物横具诸教乃至圆教。今从极说故展转比。乃至地住方乃具足。是故文中初从色定亦名为等。等故具足。有漏尚等况复余耶。背舍等名等不等者。约无漏事禅以判。既云厌背故多属慧。九定名定从名判耳。无间入故。十一切处前八属慧后二属定。又前八在色色界之中。亦自得等已如前说。前是因缘。又二乘下约教判。二乘即前两教也。菩萨及佛即四教义足。空观去约观判也。破魔等者。四佛各有四降魔相。具如止观第八及记。若对教者。亦空二假别中圆则具教观二义故也。乃至地住各有破于八魔十魔。八魔十魔具如止观第八及记。究竟破尽故名一切。击梵等者。即真妙梵音之所转也。既降魔已应转法轮。文从实说但云初住。通论四佛各各能转。乃至真妙亦通四佛。次约不次第云随见而问者

问。向明所见可非随见

答。并是随见但二途不同。从不次边最为随见。尚许一见具经五时。何妨睹行次与不次。三藏后等者。此则全是彼佛所说。且如见人见行不妨见说。舍禅者。第四禅也。亦可别圆忘怀之舍。忘彼禅故名之为舍。悲禅者。婆沙云。初禅修悲易。二禅修喜易。三禅修慈易。四禅修舍易。此中悲禅既云化他。岂独初禅。故婆沙中尚有通别。况大教耶。故一一禅皆应云慈乃至喜舍。华严思益等者。华严具二。思益具四。故思益第二卷初。网明菩萨放光遍照十方阿僧祇国。一切烦恼一切疾病遇光安乐。烦恼病苦并云一切。乃至佛自放六度光。触者蒙益。故皆具四。以初地例佛亦应无妨。故得引之。第一云。佛告思益梵天。能教众生一切智心是名布施。不舍菩提心名持戒。不见心相生灭名忍。求心不可得名进。除身心粗名禅。离诸戏论名慧。岂非三藏六度耶。第二云。我说布施名为涅槃。愚谓大富。入诸法实相故。持戒是涅槃不作不起故。忍是涅槃念念灭故。进是涅槃无所取故。禅是涅槃不贪着故。慧是涅槃不得相故。又云。布施平等即萨婆若。乃至般若即萨婆若。又云。布施不施不悭。乃至般若不智不愚。此等岂非并是通教六度相耶。第四云。能达一切法无所舍名檀。达一切法无所漏失名尸。达一切法无所伤损名忍。达一切法平等名禅。达一切法无有起相名慧。岂非别圆六度相耶。华严具如止观第七记引。又如地持六度各九。此并蒙光得益之相。以佛道名通悲禅不局。初地初住及通七地俱皆得入。故作通释。四相既分五时可辨。是故不假诸余繁论。未尝睡眠具如止观第四。然彼是方便此中正修。亦通四教。若小乘中如那律。具如止观第四记。此中在大以求佛道。故引般舟以为行仪。般舟翻佛立。此举除睡中最。以九十日常行故也。准部又通通诸教故。无缺乃至究竟但此十戒名出大论。亦通诸教。具如止观玄文。今十始终悉是菩萨。故皆求佛道。生法两忍者。合前二忍为生忍。第一义为法忍。初半能忍人。次半所忍境。下半用忍意。意即兼于生法故也。故知生忍之名名通义别。三藏中生灭事忍为生忍。衍门中生忍法忍永异三藏。力者。阿含云。力有六种。小儿啼为力。女人嗔为力。国王憍为力。罗汉进为力。诸佛悲为力。比丘忍为力。离诸等者。五盖具如止观第四卷(云云)。初一行半明所离。次半行明离意。以诸教禅皆离五盖。意在佛道。如宝积经。迦叶云。有四法急走舍离百由旬外。一利养。二恶友。三恶众。四同住多戏笑或嗔斗等。又云。若有打截大千众生。若有恶心恼发菩提心人。此过过是。痴眷属者。具如般舟须离痴人及乡里等。望前亦有方便正修之别。四事者。前之三行正具四事。初行二事谓饮食汤药。次行衣服次行卧具房舍。诸教之中或复桥梁义井园林浴池。今无桥等。肴葅也。膳美食也。不知何事嘉祥及涉法师皆以肴为肉。纵有一分字义通肉。何须置余专用于肉。使后代少识者疑之。应云。非谷而食曰肴。若作[月*肴]者啖也。说文曰。膳者具食也。秖云从肉作训啖。谁即名为啖肉。或云。是肉未制之前。斯言更谬。大乘顿制一切断肉。何论楞伽前后制耶。况复并是光中所见。岂一万八千咸同未施断肉之制。犹以[月*肴]肉供佛僧耶。经名衣等者。如此土迦叶袈裟直十万两金。光中所见或当有此。次释般若第三行中。云言语道断者。心不着故必离言说。言语道断泯前初行不可说而说。心行处灭泯前次行不可观而观。虽复双泯而说而照。故云说不可说观不可观。此语复通衍中诸教。故不局此。消此三行文有五释。初直消经文。次释三行全在方等。而言六者。五随般若故也。第三释三行全同般若。盛谭等是初行意。寂灭等是次行意。清净等是第三行意。以从名便同称般若。第四释以三行具对三味。第五复同般若

问。若尔此第五释与第三何别

答。第三直以不说而说等。与般若相同。故且对之。此中因第四释中以第三行。对于法华者。良由妙慧二字。仍云见人不见座席。故却将初后二行。归于中间一行。不观而观正同般若。即与不见法华席同。等是不见故未消法华。皆云或者。意在于斯

问。前分文独在方等。今释具对三味耶

答。一者方等具足四教。摄法多故。二者唯未见法华座席。是故于法华前。从容说之而兼般若。然又诸教六度别者。皆由般若。是故具论。所以若说若观及言语道断。诸教有故故须具论(云云)。况所见难量故详之至五。收罗既广不出于斯。两意从人者。第四第五意中。正指第三行也。冷然下云云者。如向略申。上文但云种种因缘信解相貌。未分三味四教之别。释者谁知三行含于二味。又诸经论六之与十。离合不同。具如止观第七记。又璎珞十度各各具三。义通诸意故下卷云。施有三。谓财法无畏。尸有三。谓自性受法利生。忍有三。谓苦行外恶第一义。进有三。谓起大誓心方便进趣。劝化众生。禅定有三。谓乱想不起生诸功德。利益众生慧有三。谓照有照无照中。愿有三。谓自行神通外化。方便有三。谓进趣向果。巧会有无不舍不受。力有三。谓报得修得变化。智有三。谓无想智一切种智变化智。以佛舍利者。略如长行。新云宰睹波。此云高显。方坟者。义立谓安置身骨处也。见有灭度之相。则知佛已涅槃。虽见入于涅槃不知尔前所说。而时众不决未测见由。故不同古畏妨寿量。又复尔前已见二酥。大小理足应不重说。是故怀疑。诸天龙神等者。塔藏身界故供者福大。不同殿堂形貌安处。故长阿含云。佛临涅槃。有梵摩比丘。佛前立执扇扇佛。佛言。却勿在吾前。阿难思念。此比丘常侍佛供给无厌。今者末后须其给使。乃令遣却何因缘耶。佛告阿难。今俱尸城十二由旬天神侧塞。嫌此比丘当佛前立。今者末后诸天神等。皆欲供养。而此比丘有大威德光明映蔽。使我不得亲近礼敬。是故令却。阿难白佛。何因缘故有是身光。佛言。毗婆尸佛时以欢喜心手执火炬。照彼佛塔。使其身体光明乃尔。上至二十八天身光不及。火照既尔余皆准知。故知舍利所住之处其功不轻。慢之生罪罪莫大矣。如斯等例经文甚多何可具列。并非今正意。经云。天树王者。即忉利天波利质多罗树。具如释签引大经文。结文意者。正供舍利旁严国界。若直尔严国何须起塔。白毫为本者。此约道理。白毫表中为诸法本不必最初。及由光见以之为本。如他土瑞六趣居首。岂为瑞本。所以他土以佛为本。若论总别仍同因光。言佛为本者。下凡依佛。佛之人法由佛始终始必归终

问。他土六瑞容可因光。此土但云佛放一光。见此国界何曾关五

答。因光见处一切皆妙。当知光是殊妙之本。况复诸瑞并中为本。光即中也。他六皆中由光亦尔。次行者。初二句叹光本。初中初一句二字举光本。本即神力智慧。言诸佛者。举诸显一。正指释迦。次二字正叹。尔前不然故云希有。由二事故其光乃净。下之二句叹光体用。于中初句叹光体。次句叹用。所照国也。过万八千方云无量故前立数且从所表。况复诸方所照亦尔。故云无量。第三行中。初二句重举所照而叹过常。次二句举见称号。以请答。云见此者。二土瑞也。与一化异故云未曾。既殊凡谄未曾不虚。诸佛子等疑事不轻。故重启之。非专为己故云众也。言构难者。构者架也。累也。频至于四故云累等。弥勒节节设问。文殊皆构而拒之。此三意者。初意明事大意远。次意将护发起影响二众。第三意将护当机结缘二众。虽复初二共成第三。故弥勒三意并托机缘。故云妨闻机在仁者及以阖众。是故托众翻其三意。而请必答。靳亦固也。广雅云。强辕也。兕者。音似。似牛而一角。似牛非牛故云疑兕。今忧怀不决故云忧兕。阖字胡腊反。闭也。汉书云。阖众不廌一人者。阖尽也。当知今会尽众疑也。初拒中云众未曾疑者。且据不发言者。以质弥勒。次待佛定起者。佛若定起其疑自决。言时答者。催促之词。令其即答。钊师招音。作刘字者误。钊师有弟子行深。从支遁买山。答问为四。初开章。次生起。三惟忖下所以。四广解。生起中云罔像者。亦可云仿像。未实貌也。仿佛二字古作仿佛。上敷往切。下方物切。上相似也。下不审也。若准此义。上字正当惟忖答也。惟忖答上此土瑞者。欲说等五句。既对六瑞。即是以五忖此六瑞略。曾既云放斯光已即说大法。他土六瑞以光为总。因光先睹圣主演说。故知答他土问也。广曾具述灯明六瑞及光所照。如今所见。乃至定起说经。即是双答二土问也。双问意在问于定后故云双答。惟忖下当因缘释。然文下本迹也。据未广述似同未知。既云今昔。昔即广曾但未彰言先示惟忖。故先五句酬序六疑破古中先叙次。今明下破。先去取云其法说不用者。仍存其譬不用法者。本门太早故也

问。至此尚破太早。何以通序本迹释耶

答。通序通于本迹。别序唯在迹门故释通序。泛用本门非通序中广开寿量。乃至别序虽有本迹之言。或时且用体用本迹

问。若尔譬本譬法法既不用。何以用譬

答。秖缘光宅法譬分张。法则本迹俱谭。譬唯迹门显实。去法存譬良有以也。傥若全取仍须责云譬本譬法。如何三譬唯譬得记。改小破惑二法。乃以本迹双论用譬除法。良由斯也。然论有八句。一欲说大法。二欲雨大法雨。三欲击大法鼓。四欲建大法幢。五欲然大法炬。六欲吹大法蠡。七欲不断大法鼓。八欲演大法义今但依五句。以初句为总。下四为别。他以八句四对释之。而云一破恶进善对。二开权显实对。三得智证真对。四说法利生对。仍云寻释来由。唯有五句成两对半。有破恶生善说法利生。开权一句。余者则阙。仍不次第。读者应知。今谓论文八句释经五句。是知不断幢炬释法鼓耳。不断明鼓体相。续幢是法鼓标帜。炬明法鼓破暗。以喻释喻道理。如然今依五句总别释之。然通序冠首乍可从容。别由藉异无涉远本。文殊答迹尚自惟忖略广方决。乃酬问旨。何得率尔示远本耶。若释五句作显本者。略曾广曾并须知远。光中横见应发近迹。光中横见尚隐当同。但以起塔密表入实。岂容于此便见远成及以塔踊并分身耶。惟忖既未关于远本。故略广唯谭于近迹。释后既虚等者。释显远既虚释开三亦谬。开三秖应如今总别。不须以对广略二文。若不尔者徒称权实。正释中先直述大意。次正释三横竖下结意。正释中。先释。次结惟忖。初文又二。先对五瑞。次别释。大圣忖量不徒涉虑。此初惟忖乃为略广二答之基。故弥勒思瑞以设疑文殊附疑以忖度是故内惟昔佛正前之六瑞。忖量今佛瑞后之三周。故略广时方显内忖。此即一经之骨目也。初中三先对五瑞。次欲说下。一一解释悉令表正。三如是下结示有无。秖为释中以瑞表当。故论八句皆云欲也。释中初句答说法瑞者。明昔说无量义经表欲迹门入实。两时无量义义既不殊。验知今日出生之后。收入何疑。法之大者岂过于此。次句答雨华瑞者。惟昔雨华时已表当说圆因四位。故四而非果。忖今天华而四雨了时会之一因。一因必四位为所阶。四雨以义天为能表。第三句答众喜瑞者。忖今同昔众见瑞喜。冥表必行行依理教。故喜心内动圆障冥坏。改昔权人成今妙众。人必禀教行理咸然。第四句答地动瑞者。忖今同昔见地动时。已表当破六番无明。故普佛世界六种震动。动虽形声二别。且以大鼓忖之。故知诫兵必破边强之大贼。地动则除中理之无明。故二乘昔来都无斯理。序中冥利时众未知。第五句答放光瑞者。忖今同昔睹光已表开显道同。故以一光俱照彼此。此表释迦彼表四佛。故知迹门不得同本

问。大法法义二句何殊

答。大法表此土开显。法义表彼此道同。此照于彼彼同于此故云演也。并一代所无信答问有在。言兼具者。验知四瑞在定定不可无。阙此至略耳者。略谓极略。一往略曾似如略于惟忖。义则不然。以略曾中既有过去诸佛之言。但是望广名为略耳。非望惟忖。是故惟忖但忖量过现。无曾见之言。故更略也。故此略言有其二意。一者言略无曾见故。二者阙略阙入定故。次别解中复为总别。总者。以下四句皆是大法。故知下四为成初句。所言别者。即以雨等别彼大法。令入住等对四位故。故名为别。即以光宅三喻而从今法。故释五句并托喻从法。先以华瑞举于横别以示竖总。以初句中义含四位故也。故次以雨等以离前总出四句故。准此下四当位自具从始至末。文中且从对竖以说。故以雨华用表四位。如吹法蠡通表改于四位。而别在于十行。击鼓亦通表四番破惑。而别在十向。演说既通云横广竖深。竖深即如位位竖入。遍通诸位而别在十地。故初雨雨乃至法义一一遍于迹门广说。但于众生得益不同。须从竖释束横从竖。故入住者且名法雨。乃至入地且名法义。是故迹门通名雨雨乃至法义。故下广释句句皆云为令众生。所入又有超次不同。今且从次并言今之与昔等也。如初明雨雨但表入住。即不云今昔。从信入住何所论改。非不改信非改真位。不得改名。故始入住不须云改。故知二乘钝根菩萨昔法华前。未破无明。今初入住但得名开。是故略开。利根深益在第二句。故第二句容有昔时利钝菩萨及二乘人。先密入住并于今经始入住者。并进入行俱名改号。若显若密至今不同。三四两句准第二句。故知改名亦通于后。诫兵亦然。证位虽尔亦有今昔闻经薄益入品入信。略如向明当机结缘。具如玄文利益妙说。故知尔前亦可义通开等四名。横阔竖深者。前之三句非不深广。今至地位最得其名。次惟昔下总结。横竖释竟者。若总别相对以总为横以别为竖。若于别释。初句双显横竖二释。下之三句文正明竖。位位兼横。涉法师云论释此文略无奇功。难可具依。是故今文亦不全用。经善男子者。涉法师云。离五不男。岂法华中众但离不男。才堪为受声闻无作。一缘之中少分而已。今言此名大小通共。至今应云开七方便为善。堪闻独妙名男。男子即丈夫。具如大经。大经仍含三教佛性。具如玄文所引云。须陀洹人佛性如净乳等。岂小教中有佛性耶。故知大经于法华之后。开方便教遍立佛性之名。名通义别。故男子之称通在五时。诸教义别次释略曾初言小分明者。且从言说阶渐而言意则不然。向云惟忖还忖广略。故知略曾更述惟忖。答中但略举光瑞。光照他方义当他土。总而言之并答此土。况他土之文元为成此。故知惟忖且此略曾且彼。所以分于彼此者。以惟忖中有今佛之言。略曾中有过去之语。以今表此以过表彼

若尔广曾亦置过去之言。何以双表

答。广中具述三同。可以三同显此。复有过去之语。而以过去表他

若尔判答之中无过去语。何以双判

答。今见此瑞与本无异本表过也。今日如来即显此也。双述过现故表双判。言曾见者。即是见广。但言中痒序略广渐增。为答之方宾主仪耳。欲令等者。欲令之言谭教意也。闻即闻慧。知即思慧。即开显之闻思。故云难信。既有二慧必入修慧。岂佛说法独令唯二。但以知释修未可全当。故但云思。亦信法者。即圆二行。闻即信行如随喜法师品等。知即法行如安乐行等。岂二行者全无修慧。如三周授记及本门功德等。并一往分别耳。乃至云。若闻是经思惟修习等。故经文中其例不少。以一部文凡论入法不出二行故也。二慧二行得入诸位。故欲令之言意通初后。云收无量以归一者。指说大法意也。义当于总。次云改三乘者。指法蠡十行。次云六番指击鼓十向。次云诸佛等。指演义十地。次云开等却指法雨十住。故知略曾还述惟忖。瑞表所为故云欲令。一切世间等者。若不通指诸位并开佛知见。岂得云一切等耶。如下文云。一切世间多怨难信。难信之珠四十余年方乃信解。次广曾者。还广上二。言横竖者。被此相望为横。今昔相望为竖。通号者。应身皆具十。故名为通。法身望应亦得义立。吾今此身即是法身。故知应号即法号也。然释法号须从法立。具如止观第二记。又诸经中或时通列三号。即十中初三。故净名云。若我分别此三句义穷劫不尽。准三望七亦应可知。应号无尽况法身耶。别号不定如楞伽经。佛告大慧。我于此娑婆有三僧祇百千名号。亦如华严此四天下十千名号。十方各一世界各十千名号。乃至十方尽虚空界种种不同。此佛既然诸佛皆尔。佛号既然佛身说法亦复如是。十号功德如育王经香口比丘(云云)

若尔今之一佛尚名字不同。何以言今名与他同耶。又释别名作定慧自他释者。何佛无此自他定慧。独云灯明与释迦同

答。应佛得名随缘各别。其义纵具不及灯明。如楞严中坚意问寿。佛令往东方过三万二千佛土。有佛名照明庄严自在王。坚意往问竟。白佛已。阿难云。如我解佛所说彼佛是释迦异名。故照明之言正与日月灯明义同。涉法师云。日破暗月作明。日成热月清凉。日开众华合青华。月合众华开青华。灯于密室能破暗。如彼智能破惑。然全无合喻况复亦无三同之见。依今合之。方在今教。方可依前定慧自他。故云随缘称别义则不殊。次说法同中即五时同也。如华严四谛品云。文殊告诸菩萨。四圣谛此娑婆及十方世界。一一各有四百万亿十千名号。大集亦尔。故知诸大四经多为辨异。唯有今经特为显同。非但今佛与他佛法同。亦乃己他皆入一味。故下文云。因缘譬喻皆至种智。是故诸经不出异意。大乘七善者。既云通大小乘。论中又以闻思修三。而为三时。成论又以少年中年老年所说为三。不同今人今人老者所说非善。又亦以三乘为三故云通也。今文以三段为三。其言仍通其义则别。时节既尔余六准知。今经应云圆乘七善。八音者。一极好。二柔软。三和适。四尊慧。五不女。六不误。七深远。八不竭。诸教悉有从所宣异。判教不同。从所依异判佛差别。来至今教理无二途。界内外等者。别圆两教摄彼二处。总名满字故名圆满。师云者。指南岳也。又初去重出异解。金光明者。如金光明最胜王经第四云。此经希有难量。初中后善其义究竟。虽不云其语巧妙等。以余文例可以意知。部虽方等义圆极故可以证今。前心者。谓住前。中心者。谓登住。后心者即妙觉。理犹未显名不思议。分证定慧名为庄严。惑究竟尽名为不坏。此三如来。凡有所说皆同一善。初心尚云不可思议。况复中后所说皆善。是故亦与说法同中时节同也。故但立三时余皆善也。有人云。初句总六句别。故离七为十。初离三故四义深。五语巧。六无杂。七具足。八清净。九鲜白。十梵行。须为分其大小。渐中不明方等般若者。但以六波罗蜜拟之。但是文略。既云答上种种修行。应具如上。顿渐既同横竖不别。故知因光横见。非但生弥勒问异之疑端。亦为文殊答同之先兆。又非但二圣问答之冥符。元是如来化道之玄旨。故主伴相与密设一途。使惬物机宜闻皆契辙

问。前问中以菩萨为三藏大乘。三藏之后方云种种。即指二酥。今何以将菩萨六度答种种耶

答。凡诸问答及偈颂长行皆有广略。此文望上应为三意。一者上广今略。故今渐初但举二乘。二者上离今合。故上菩萨别开二酥。别明诸教。三者上旁正具举则通列三乘。今直论正且语二乘

问。观文语势令得菩提属菩萨句。何以离分对味不同

答。有二种。一者义意。施前诸味本为佛乘故。将令得以对元意。二者答意。问既具腾初后答亦委述始终。不可唯守略文令阙大旨。故随问势从义离开。况此问答随见而辨。信非二圣虚构言端。方荷今文释者之巧。引过去无量劫远事与东方万八千孱同。验旧消文未成答问。成一切种智者。五佛章中皆云为令乃至种智故知同也。所以定起引同还同光中所见。故五佛章种种之言不出四味。昔同下云云者。令更分别三同相状。今佛正在于定故以法华为当。古佛已说法华故以三皆在昔。所以古佛六瑞及以尔前四味。而为与今今同已同。唯说法华名为当同。古师不以六瑞而为今同。具如下破。初引至互举者。文殊巧说为避繁文。故文殊见时皆具五味。言指前者。以中后指前初一佛也。二万之渐指最初及后。最后之顿指二万及初。而不引二万之前等者。且引同皆为顿开渐。过去既尔。验知他土不过万八千者。以过此外不同故也。若云无量何妨照同。若依现数则中间不同尚亦不照。况万八千外。虽然犹是一往。光但令见一万八千。答但引于过去二万。足得表道同足可释疑念。故定起所引十方三世。何但如向所见所引

问。若尔何以将数而为所表

答。凡有表者皆约现数。忽至三万岂无表耶。以自在法门无尽故也。况正为所表。且至一万八千。二万灯明观释还表二万。如前二千即二万也。如菩萨八万准说可知。若具以二万为表即表权实满也。姓颇罗堕等者。真谛译也。婆罗门中之一姓也。本行集翻重幢。重字平声。一切诸佛皆不在余二贱姓故。尚尊贵时则在刹利。尚多闻时在婆罗门。又浊难伏时则在刹利。清易调时在婆罗门

问。三同判文姓何为异

答。姓属祖父名从己德。纵使姓异未足为乖。若作义同不无其理。尊贵多闻义同名别。如会名中岂以今古同名释迦。言能仁者。亦根利捷疾不违物情。故得国人从之如市。所言不二咸满众心。故云满语。故满语等秖是能仁。王子一八亦复如是

若尔十方诸佛谁非利根等耶

答。本引令同何须求异。况今但以三同例之。名同乃是从便来耳。如五佛引同。十方无不从顿开渐。无不令至一切种智。此八子名作四对释者。但得观心余三全无。经云各领四天下者。有言。金轮必不值佛。此亦不然。诸皆不例。言发大乘意者。秖是四弘誓。此诸声闻大通佛所。先已曾发何况被会更有小名。然发心者虽华严十种。不出四弘。具如止观第一卷广明。今未发迹等者。亦应云开权。言发本者。从示迹说

问。集经者在发本后。何故仍云声闻耶

答。此约文殊答问之时犹是声闻

若尔经首不应犹名声闻

答。从昔列之具如序释。故解释者。先须顺经现文次第。且叹其小。复更约教及以本迹。探取文意准今以说

问。此云发本与发迹何殊

答。大同小异。发者开也。若迹覆本开其能覆。名为发迹。迹既发已即见其本。约所开边乃名发本。以覆本故。迹名能覆本名所覆。约所除边名为发迹。约所见边名为发本。下文者。具如五百受记中说。则知一切头角声闻咸是菩萨。昔明至则有者。释疑也。恐疑昔与今今同中应一切同。何以今具五序昔但二耶。初是现相。从弥勒当知下怀疑。从时有菩萨下便论说经。所以古唯二者。有二意故。先征竟。次既言下释中二。先明文无义有。次又若下明隐昔显今。从要答二理兼者略。若具引三序以答弥勒之问。还成文殊引往为答。有何不可。但文殊鉴物知此时众情在于己。故弥勒云。四众欣仰瞻仁及我。是以隐昔日之三而但述二。令知问答之后即说法华。巧申己见以惬众情。适时之宜何以加也。又若下第二意。秖缘不叙昔答。故以垂辞具腾始末。始说法华终尽灭后。乃至结会方结述云。今见此瑞与本无异等。乃至偈云。我见灯明佛。本光瑞如此。以是知今佛。欲说法华经等。但利物乘机何劳费辞。故隐问答但述己见

若尔何妨述众

答。据无量前无众围绕等言。且云无众。而云说大乘经教菩萨法。所教菩萨及二十亿岂非众耶。况二兼三余何须述

若尔何不述问

答。问必有答相从须阙。初所因人中先述不同以征起。次述瑶师谬解。言因托者。是流通之人即指妙光。言非直者。非如今佛适从定起正说之初直告身子。彼佛下。次明妙光非彼佛定起对告之人。如今下。明身子但堪对告。非堪流通故云未必。次因托下明彼佛流通属在妙光。故云莫若。次如今下引今流通之人。同彼妙光。莫无也。若如也。此佛弘宣无如文殊。不可匹类。故云无如。次今佛下明今佛既其不叹身子。往佛所以不叹对告。故知今昔俱叹弘通之人。故云何必。何必者。是不叹之辞。文殊下重引所叹流通人耳。次又旧下复述古师。而以药王为所因者。许而不用。此师见下法师品初。云尔时世尊因药王菩萨告八万大士。即以药王为所因人。若引药王以例妙光。稍似可尔。没却身子深不可也。但云文有所因之言。亦是对告之限。且云可尔。言引往小不类者。若引往灯明正说之初对告之人。以证今药王故不类也。例同身子此则类也。所言小者。犹同文殊故也。或言下又引古师。言不便者。释疑之时如来在定。定起因机非因文殊。定起唯云告舍利弗。何得将在定释疑之人。用对定起对告人耶。今明下斥旧所释不当。故总云不尔。经云尔时灯明佛从三昧起因妙光菩萨。而作下责旧。文云因其说经。何得云因其流通此乃下责二师。公谓彰灼。抗谓拒抗。二处皆是定起对告。告即所告。乃以妙光为流通。药王为对告。违经抗佛何关释经。昔因下引诸事同非唯一途。云迹门竟等者。非谓迹门全竟。但是譬说周竟。便云告舍利弗无智人中等。今古下结斥。言更若为胜者。前释难云。昔已发迹云是菩萨。今未发迹云是声闻。众事既齐故所因亦等。而近下斥引药王。而近弃正说之初。远取流通之首。是时下说法名同中经中。所叹与无量义辞句不殊。若释此中教菩萨法等。依前序义者。非正宗意。若作异名与今不别。故无重叙。行后无境者。方等般若种种行后。不见法华涅槃之会。但见起塔供养之事。故云无境。是故今文下答出法华之会。即行后事也。六十小劫如食顷者。六十与五十。食顷与半日数似少异。皆即长而短故云同也。生公云。岂实然乎。表重法心志故寄时云耳。若云寄时。应言如六十小劫。何得直云六十小劫谓如食顷。故但情谓非实短也。信六十小劫经文非虚。闻法之志加以佛威。一坐经时忘其久耳。注家初引净名促劫为日演日为劫者。乃是佛促以为食顷。此则违经谓如之言。犹不如于重法之志。但言寄时与经背耳。引奢促已。乃云况玄匠真一之门。何为不以历劫为数刻耶。虽复况释理竟未彰。今谓且如世人苦则以短为长乐则以长为短。此亦情谓之长短也。有云。受佛法食美未饱故。此喻稍通。有人于此立以四句。如中论破。此亦不然。必非听者于中修观。乃是佛力及听者忘时。故知中论观法但被末代钝根者耳。经梵魔等者。梵即色主亦三界主。魔为欲主。沙门此云勤息。勤息恶故。婆罗门者。此云净行。外道中出家云净行种也。古人滥以此释四众者。若摄众足。何以更云及天人等。所列不同并趣举耳。此中先举欲色二主。四姓举胜六道标善。并且从胜。略余恶道者。皆取入佛法易者耳。古昔既尔今佛亦然。迦叶佛下云云者。应明佛兴土有净秽涅槃进不以例灯明。是故迦叶以土净故。法华唱灭即入灭也。今佛等者。长行末云。即时释迦牟尼佛以神通力。接诸大众皆在虚空。以大音声普告大众。谁能于此娑婆国土。广说此经今正是时。如来不久当般涅槃。但今佛虽唱而未即灭。故云不久。信解亦云。将死不久以在秽土须说赎命为捃拾故。扶律说常令久住故。兼权明实助发实故。带实用权显权力故。过常未常始末一故。色身常身无生灭故。虽此不同唱灭事等。授记同中先正述征问。昔事下答。若说下明隐昔意。文殊巧谭不发迹者。明所隐意意待定起。一代所说非无圆融。未记二乘化道不畅。今方始遂推功有归。岂可文殊匆卒尽理。故隐所见待佛定起。说记德藏时众不惊。故云诸经皆尔。执教者未惊。下云云者。应叙一代记不记意。如华严法界何所不含。隔彼声闻使如聋哑。后分虽有授记事乖。鹿苑初闻一向唯小。五等尚昧般若犹生。虽楞伽方等有记小之言。楞伽乃密对菩萨。方等为斥夺声闻。故一代教文彰灼唯此。请搜检大藏方验有所归。故将护执权教者。谓声闻永住涅槃。而隐昔记小之言。从后以菩萨立号。或恐闻者惊疑惮教。或恐拂席以亡后闻。此前未惊等文处处说故。故不重论。释疑意者。弥勒虽在八百之数。多游弃习名曰求名。虽藉宿因补释迦处。岂若妙德诸教盛谭。况曾为师释疑非谬。言密开寿量者。预击时众密发疑端。岂有伽耶适成而已师为弟子。两时弟子何者为尊。二处之师谁为实说。既师弟无定实本迹难凭。终须克核令理有归。密生其端本门方密。九代祖师者。若论八子皆师妙光。则八子皆以妙光而为父师。既云八子展转授记。虽同师妙光应先记长子。余者次第展转为师。故得妙光居八代之首。八子最后名曰然灯。然灯既为释迦之师。是故妙光为九代祖。生非生等者。既师弟更互当知师弟生实非生。尔前曾灭灭亦非灭。必久曾证非生非灭常住理故。迹示生灭故云非等。又迹难测故故生非生。本理妙故故灭非灭。本迹虽殊不思议一。是故须以非生非灭之师弟。预密表之。问弥勒等者。昔八十劫承禀妙光。虽不通利安得不闻。今为补处宿智颇忘。何故而今犹生疑问。答意者。此依权道不从实行。实行虽即曾闻。何妨今仍犹豫。然忆昔曾闻法华会中得记等事。亦应忆昔曾见法华会前端相释疑。故知实位补处辅应化佛。示历五味亦且从权。是故文中从权以释。次分明判中先腾意。次正释。先腾意者。惟忖既忖量今昔。当知惟忖见已分明。故云不谬。为答之法先微后着。故至明判显向非疑。故云皆决定也。皆言表诸即初后皆决。岂文殊大圣先思后当耶。次当说下正释中。当说等者。当说合经。定用开经以之为表。开为合瑞理决无疑。名妙法等者。华必有莲如因定克果。故知当入妙因。定用天华四雨为表。教菩萨等者。自此已前众机仍隔。此会之始根性欲纯。睹瑞欣然当入行理。定用人喜以之为表。佛所护念等者。所护之理中地无动。欲念敷弘令当入果。入果见理理是所护。故用地动为其表也。兼总入定等者。四瑞总由中定而成。说法虽即不专由定。说是慧性全定为体。故开定合定总摄教行人理故也。有人下述古。正是现瑞时问。故得以瑞为今。谢方名己。云何在定华地炳然。众喜充怀毫光溢目。古人称己殊不体文。唯说法适休。况众犹未散故从多瑞皆名为今。故引文云。今见此瑞今何所隔瑞无不通降此属当故云当说。前昔同下注云云者。正指此中。故作等者。六瑞为今具兼二义。一有文证。故文云今见此瑞。二者推理。无量义经事讫众存犹入其定。又云。尔时世尊放眉间光。尔时者当尔时也。若谓华止地静为已同者。如来亦应已从定起。偈中不颂惟忖略曾者。偈望长行广略之意。各有其方。为解义故为摄持故。互存互没尚不失旨。况为答之法容与阶渐。长行既宾主礼足。偈颂但存于大纲。已有广曾明判。故不俟略及惟忖。于广至中间者举前举后中可比知。表无问自说者。方便品初从三昧起。告舍利弗。广叹略叹。此土他土。寄言绝言。若境若智。此乃一经之根本五时之要津。此事不轻故须先表。即十二部中之一也。现诸等者。都指四行故名为总。其中六瑞文相犹别。初一行颂说法。次一行颂入定。次二句颂雨华。但加天鼓以助妙因。次半行颂众喜。次半行颂地动。次一句颂放光。不能细分但且云总。以兼天鼓。天龙供养非灼然云喜。故且云总。良由此也。颂他土中。初颂六趣中三行为四。初半行重明总瑞。次一句正举六趣故云一切。次一句中总明生死因果及处。生死两字总标也。业明生死之因报明生死之果。处即二十五有故亦与此同也。次一行明所依土前长行文及问答中皆不云光色。至此方云者前岂应无。次一行明诸趣供养虽云供养意表机成。当知前亦非无也

问。既云庄严则是净土。既云道同那列净土

答。净由光照元具六道。净土则无恶道之名。故知非但色净由光。亦乃众宝具足。各供则指万八千土。可知下云云者。四机既遍于诸趣。四佛遍赴于物机。是故四教各有真道。一坐任运三十四念一念相应不加功力。二处妙觉本得自然。他不见之大小混乱。次例如下引例以释自然。但举小喻大。七生等者意同前问。若言真道自然三教入真何以听法。由答中如流得风。故引小为例。如七生闻法尚灭至一生二生。况诸菩萨。应具辨三果家家一来。以例地住真道位也。今光中所见应皆果佛义可通因。既有本迹四句不同。岂无一土本下迹高本高迹下及以俱下。本迹俱高理数然也。故自然之称其例实多。若云法报须约别圆故注云云。言将法约人者。但云深法不语菩萨。约法须之。第四三行者。其中既云不颂圆觉。则初行颂声闻竟应云二行颂六度。但云一行恐误。又颂施忍等于四度。亦恐误也。第二行中进戒二度。第三行中施忍二度。秖应等余禅慧二度耳。若作初二行颂声闻。则初一行直明见人。次一行明所修行。以云有诸比丘故也。但诸文中多不以进戒表于声闻。然亦不以比丘为菩萨。前发问偈中。但云又见菩萨而作比丘耳。次一行明菩萨乘。即唯指三藏。言将人约法。但云声闻不云四谛。约人须之。第五二行云颂上种种相貌。又云略无起塔者。具如上文以对六度。又如以般若三行对三味是也。亦可从或有诸比丘去。至说法求佛道四行。总颂菩萨即六度义足。以第三行是禅第四行是智。即如长行亦于菩萨乘中兼于二酥。故云六波罗蜜。从令得去为法华意。亦秖是进退取之耳。若依向分即是六度含于多种。以当酪及二酥菩萨也。次尔时下一行半。云追颂者随颂也。若准玄文用此追字。皆云退耳。如云涅槃追分别诸经。即退向前也。今此但以退后为随。天人下初两行二句颂因人同者。经云从三昧起。即赞妙光赞后方始说经。故知正是对告。故不可依古作流通解之。况复但云证知不云流通也。嘱累如遗教者。彼经初云。我灭度后当珍敬波罗提木叉。如暗遇明如贫得宝(云云)。是汝大师。若我在世无异此也。一一文初皆云汝等比丘。有悲如涅槃者。涕泣盈目遍体血现。如波罗奢华。此即恭法慕人之志也。有慰喻亦如遗教者。彼经末云。汝等比丘勿怀悲恼。若我住世一劫一劫会亦应灭。会而不离终不可得。自利利人法皆具足。若我久住更无所益。例如今佛付弥勒云云者。如云一称南无佛皆得值弥勒等。后弥勒初成道时语言。释迦牟尼种种呵责无奈汝何。教植来缘今得植我。即弥勒受付之文也。我见下四偈不同旧释以为结成。须颂上文判答意者。若作结成之言则剩。判答之文又阙。岂得不将颂判答耶。颂上当说大乘经者。亦应云名妙法莲华。颂云佛当雨法雨等。颂上教菩萨法。故知上之六句。但明欲说之由。诫众令生渴慕耳。颂云诸求三乘人等。颂上佛所护念。是佛所护故为断疑。与上文相泯合。何得不颂上耶。若作断伏疑释者。文复妙同。断第一意者。妙瑞本表报于法同。断第二意者。瑞同法必实相。断第三意者。至此会者咸无异求。断第四意者三疑得除。功在于佛。事穷等者。事穷谓名等三也。理尽谓所显之体。事理合一何所复疑

法华文句记卷第三(中)法华文句记卷第三(下)

        唐天台沙门湛然述

    释方便品

正法华题称善权品。及至释文皆云善权方便。当知法护亦以善权而释方便。善是巧之异名耳。文自分二。初略中自二。初正释中文自为三。初一从字训后二从意义。又初二从昔教后一属今经。虽有三释。并以三教而为方便。但有能通非能通及以即不即异。致成三释。然须略谭三种大旨。方可消文。然于三中初约能用三教得名。法是所用用是能用。虽法之与用俱通四教。但有方圆差会之殊。故方便之称从权立名。权不即实故对昔辨成体外权非今品意。文中举圆即属真实。相对来耳。故知在昔不应以秘妙释方便也。乃是秘而不说名为方便。况圆于昔乃是兼带之圆。是故遍圆咸非今意。次第二释权属能通三教。亦得名为方便。然虽不即。以能为圆作远诠故。所诠之圆亦带能诠为方便故。故知并非今品意也。前释不云三为能者。权实逗会各致其极故。方法不同。至第三释方乃三权即是一实。指此即实之权。方名今经方便。次消文者。初约法用中为五。先法次举譬。三明用权意。四引证。五此义下结非。初又三。先释训。方者法也者。说文云。法术也。正当今文。尔雅云。则也。即法家之则。又云。正也。今亦如是。其法正故方可逗机。虽未开显不得不正。次法有下释义。虽俱法用以偏望圆。偏差圆会。会虽胜差然会非差。用显非妙。三三权下释相又二。初释法方圆。以对规矩而分偏圆。用显非妙。三方一圆者。虽即四教俱名法用。正以偏法名为方便。次若智下释用差会。所以俱置法用言者。各契机耳。非俱会圆故并云逗。又法用者。法名虽通用既适时。未为纯一。为以何法逗何等机。故以四法赴机差会不等。权实相待是非。俱非如前释法意既未融逗物未畅规矩仍别。且云善用。诣谓所趣正是用也。智诣不同用法不等。次譬意者。正譬法用不同。有二重法譬。于中置却圆中方法之名。且借秘妙之号。故隔偏之圆亦有体内方便。故名秘妙。秘妙之名似同第三。然其意则别。何者。第三乃以开显为妙。此中乃以独圆为妙。故此文中四俱方法。前之三教唯名方法。非秘无妙。后之圆教是秘是妙。故后教中得秘妙名。非关开显。故用偏法。如以一指偏目一方。若用圆法。如以五指遍示诸方。三明用权意者。尔前未合即以权法。名为随欲。四引证者。应以三权为引出之法。文寄小说故云三界。况所离不同三界无别。若于如来方便本一。此意未宣故属昔教。虽是体外方便。于理无非体内。而众生未知。准佛意说故云称叹方便。以未开故非今品意。次第二约能诠者。若理教相望。四教各论无非能诠。今以三望一三为一实作诠。故三名能诠。是则前之三教教行人理悉为能诠。于中为七。初直立三教为门。此从义释非关字训。次门名下释门义。如世之门本为能通。三皆入实故名为门。三方便下明门意。众生不了元是所通。依其所执得成弄引。但不善曲者以引为弄。四真实下明门用。虽非即所得入由兹五从能下明得名。权实尚隔由物机差。故前之二释。于显露边及别地前。非今品意。六引证意者。明彼昔门但云能通。于今须开故云开方便门。非谓于彼已明开门。七此义下结非。第三释者。即今品意。但前二释于昔但得名偏名门。秘而不说。今开其偏门。即圆所也。故云秘妙。显露彰灼故云真秘。又为六。初直立者。于昔成秘彼秘被开。于今成妙。次妙达下释功用者。达即是开用妙之便。以开秘方。妙外无法故云即是。三点内下约人教以示相者。众生身中有昔种缘。名为衣珠。自退已来于彼醉客。偏门尚无偏门之名。何况圆所。若不开之。三权未显如衣覆珠。今经开之。与果智一。作人亦尔思之可知。四如斯下结名。方法及门即是秘妙。故云如斯。五如经下引证。六故以下结名显是。次料简中三。初约自他三语。寄前初释以简于三。故初被开即第三也。次约能所寄第二释。以简三文。故第二被开亦即第三。三约四句共简三释。初释者。自有三文。简初文者。三教一向名他名权权隔实故。释次文者。以三教之他与圆自对辨。释第三文者。三俱体内无非真实。但名为自自外无他。三语亦然。次约能所者。亦自有三文。并将能所两字以简能所是非。释初文者。且指三教。但是法用尚非能通。况是所通。是故三教非能非所。故三方便悉皆为粗。释次意者。门是三教得是能通。不云三教即是圆故。故非所通。既其不即故犹是粗。释第三文者。亦开前二。非能非所及以能通并开成所。所中善巧名为方便。故妙。方便异于方法及能通门。故知下结斥。先结名体若同若异。虽俱名方便有此三异。岂但闻名便解其义。故三释皆有方便之言。二非今品。故云义异。世人下总斥世人。岂大师带偏情有阿党耶。其如理何其如文何。其如行何。其如证何。生公天真独秀。尚云从昔题品。若从昔题何故称叹。若称叹昔岂非毁今。若以昔叹今又失于昔。则使体内之权全阙。体外之用又亏。乃成内外俱亡安得叹佛权智。五佛开显便滥初施。三周善巧仍为徒设。若言品虽题昔品内在今。县额牓州惑乱行者。又初释中。既以随他等三通后二释。次释复以门通初后。理应亦以妙通前二。文无者略。但注云云。应云初释方便是秘而非妙。次释方便秘堪入妙。后释方便秘即是妙。此乃从佛内解以说。今成显露故阙不论。三约四句中初问意者。正本既云善权。当知权是方便异名。欲约异名料简同异故先问起。答中四先标列。次释三三句下判。四故正法华下引证。释中相破一对分为两句。相修相即各为一句。合四句也。他文或以此为三句。或为六句。随其法相立意不同。句法常定。今立三对已乃开为四句者。欲以四句用对三释。以前三句属初二释。若但为三句。以前二句判属前二。有何不可。但相破中文相别故。又准相破相修亦可分为两句。四句属前亦无大失。名句随时不可一准。言相破者。权与方便今昔并有二名。于昔则偏圆二名相破。于今则偏圆名体相即。此对初释故云相破。在今则三教并妙亦名为权亦名方便。在昔则三种并粗亦名为权亦名方便。故将昔二互破昔二。以成二句。即二酥三教对彼圆教。故昔教中三于圆教人。俱成秘妙及以同体。故云四种皆是秘妙及同体也。故相破言但从于名不从于体。今从名释其体常定。言相修者。亦并在昔二名互立。但是三教二名互修圆教二名。是故异前相破句也。虽昔圆人亦见四种俱是秘妙。然于彼教不得显说相即之言。故但依向于昔对论。故相修者。亦对三教以辨一圆。何者。若舍三修圆还同破句。若即三是圆乃同后句。不破不即从权入实。故得修名。若于尔前二味三教。利根菩萨有显露得。两教二乘唯秘密得。由得入故即称为门。言相即者。即秖是开。故相破属初释。相修者属第二释。相即是第三释。言云云者。更以四句约味比决。若开若判具如余文。准说可见。下复广明故不重说。三判可见。四证者。正本名即今乃体即。三权三方便即一权一方便故。次释方便者。亦应言方便即权。举彼释今故不繁耳。当知体外方便即体内之权。名虽更互名。下之体既开。体上之名本实。由昔分于体外体内。则令二处名下体殊。故知今经方便即是正法华善权。正法华善权是今经方便无二无别。低头等者。尚开人天况复三教。若被开已一体无殊。前已三重总贯八门。下第五门虽结权实寄彼便明三番释品。正意须以三种释品通贯八门。思之不谬乃可解释。况一一门十双之中。双双须解三番解释。一部之内一代教中不出八门十双故也。次广解中先破古为四。先述五时教非。次述半满等非。三复有下述杂释非。四又有下述附傍非。如是四失皆称权实权即方便。不知将何以释今品。初五时非者。皆先叙次破。先叙初时。次今谓下破者。大论破无常但是对治。对治属事事即无实。但成小宗方便。纵有第一义悉尚非行门三悉方便。岂符今教第一义中权巧方便耶。次破十二年后为般若者。今不暇破其在方等前。但破权实不出通教故云即空。引论意者。虽空有相即望实成想。尚非般若中实无实则无同体方便。岂成此经方便品耶

问。般若三教俱念想耶

答。通别俱约未证实者。故文但云照假有空。空未实故故破云想。心境未融故观名想。故有想观非今方便。次叙净名意者。以方等中自行内照空有二境。如云修学三三昧不以三三昧为证等。纳海入芥名为变动。意谓以此权实过前般若。今谓下破者有二。一者对前。前教岂无内照外变。二者当部内实对外还名为二。亦非净名入不二门。既非不二则非圆教二谛相即。岂是今经权实不二之方便耶。亦不知他人指何为二及以不二。故非所用。次今谓下破其申法华以三三四一者。具如下显实中明。况虽分权实而未出前教。以不云相即之权故也。故知权实尚隔何殊偏小。次叙其判涅槃者。昔妙觉方常。今谓下破。汝虽许涅槃明常。而判在妙觉。何者。道前道后照真照俗。俱有常与无常。云何定以金刚前后判经部耶。部中得益岂皆妙觉。量谓数量及以体量。以彼俗境是有量法如境而照。是权智也。此用摄论理量破之。故今文意若明常住。众生理性尚实尚常。岂等觉后方乃常耶。此五时下总结也。故彼五时权实莫异。并非今意。次乃至下约半满等。破半满等宗。具如玄文第十。五时既倾半满诸宗不攻而败。三复有下破杂释中四。先别叙。次如是下总破。三权尔下别破。四各不下结非。于别破中云处所者。谓智所托。处尔之与假皆暂时之言。故知还约暂时处也。化城草庵等即其相也。法门者。智所用法随物机宜指三乘故是法门也。言智能者。能施之智进否有则。故于鹿苑设三乘也。锤伫伪反。亦可锤伫违及。随物轻重前却均平。故是智之巧能也。四结非中言不包含者。权实自住不相即故。况约处约法但云三车。故使智能不逾于此。文不收于四教行理。故云不包。义仍未摄开三人法。故云不融。欲消今品具如四句。何法不收何法不融。四叙附傍五时非者。义势多是嘉祥旧立。故今上下三两处破之。令知得失。如其无失何以归心。其失乃是归心之前。破之则是光其后也。于中有三。初略立。次初二下略判。三此诸下约谛教智三重三转。先述其立。初文意者。彼以初重二慧为本。故但云一权一实。意以权是凡夫实是二乘。谓二乘实破凡夫权。而迷凡夫未有权名。此亦未可此附鹿苑非也。次空有等者。意以双离向来空有。而以观空不证为权。涉有无染为实。故以观空非空观有非有以显中道。此乃附般若非也。不知般若之中中道非一故也。次云空有内静者。意云。息向空有权实为实。以此外用为权。非但内静双非。复能外用双照。前虽双非但同内静。此亦不知二教共有。此附方等非也。次更以此双非双照在金刚前。仍为无常。在金刚后方是于常。此乃非其内静外照。此附涅槃非也。此师虽见涅槃五时。不语法华真实。况亦除于乳味。总论虽五唯附四时。次述其略判意者。初直立二慧令信有故。故但直举权实。次生解者。元立二智意本离着。故离二边方解立意。第三意者。离内二着方成自行。复能不着变用益他。第四意者。非唯益他自他俱权。论其实意本在极果。故指金刚后心为实。然今明五佛非不在果。及以本门久远之果。理则不然。尚开凡夫即是真实。况金刚前仍判为权。权若唯在金刚之前。则佛永无权智。将何以消今品名善权耶。况都不判四重权实。为权为实。况都不语法华。全非今意。是故不用。向已通辨故云略也。次述三转者。具历谛等。所言三转者。于向四重除第四果。以前三为三。于中又为四。初略对三转。次何故下明转所以。三又如下引证。四又渐下述意。初又二。初正约谛。次教智例。初言谛者即二谛也。权实为本故先约谛以判于境。境即真俗。于中先标。次对二谛。二谛语同深浅各别。且判初重一实一权。但名二谛。以此二谛为信本故。即是转凡而成小圣。次重意者。转前二谛俱名为俗。双非前二乃名为真。此真但是离着而已。第三重者。先牒前。空有为二者。牒前空有为俗。双非不二者。牒前双非为真。即此真俗复转成俗。故云二不二俱俗。非二非不二为真。第四果重是三转外既双非理极。但有因果相望权实是故不云。次例教智者。明此所诠以为所观。既有三转。能诠能观岂无三耶。次明所以中。言为人者。三重二谛皆逗物机。机即是人人有三种。此不指四悉中为人也。所以始终不出二谛。且约随机又名为人。引证者。常依之言不逾此三。故但对之。重与佛教所依。证前约谛意也。次又佛教去重引总意为证。即证前约教。教中所述不出此三。故云三门。教即门也。次又渐下约佛化意。总述前之谛教智三。化意能所不出此三。初令凡夫舍有入空。即初制小也。次破二乘空着。故空有双舍。意云小菩萨也。虽舍空有应未见中。古释菩萨。但以次位而分大小。不论知中不知中等。次或者下中边并亡即大菩萨。或指八地初地十地等觉。次此为下更以五乘判向化意。意云。佛世化意不出五乘。于三重前以凡夫为人天。人天生信破有入空以为二乘。次又为下约三假判。此似次第修中之人。先破三假。此中一番但加三假。余无异也。秖是分别向之五乘。最初破有必具三假。故初以三假为俗。诸意并同。然诸番中虽不云假初重俗谛理须是假。又前诸番不云初重。元为修中但是文略。故破假修中多是中论师意。第三重应云非三假空有为二非空。非有为不二。二不二为俗。非二非不二为真。准前可知。故不重说。今详下但总略破之。又为五。先略非。次经云下引文正示。三又初下结非示过。四如天亲下引例。五当知下结示。初文者。附旁用他五时之意。隐五时名潜为己释。今以一一时中横论权实体用多少。意明如来难思巧用。巧用不立但成渐次。是故云非。后约三转又除果地。意欲拟为智谛离着。以因显果。不意亦成渐次之非。次引文正示者。今用五时八教相入。方成一实。一一时中横竖间杂。唯至法华谛智纯一。仍辨使成方便之相。故方便初即叹五佛智谛方便。是故品题须依圆顿。经云皆得睹见汝乃至果方常。经令舍于方便。汝乃却更用之。大经自指法华为极。汝乃唯指金刚后心。应开诸教汝乃废之。次示过中云信解化果者。即前四重始终渐入。次何关下正示其非。故嘉祥又云。身之与乘各作四句。乘四句者。一三为方便一为真实。令舍三取一。禀教之徒虽复舍三而封一实。粗惑虽去细惑寻生。今问至法华会若已舍三。复于何处而封一实。若未至法华。尔前复无舍三之教。声闻之人于法华前。见修久破。至此何等细惑寻生。封实为是何等惑摄。岂有细惑由闻法生。次云为对破故明三与一皆为方便。今问。不审三一俱是方便。为在法华经前。为已至法华会耶。尔前尚迷三是方便。何曾云一亦是方便。故此品初但云昔日方便示三。的无三一俱名方便。对破之语为在何会。三云。禀教之人乃识三一俱是方便。更封两非而为理极。今问。三周何周是禀两非之文。尔前二乘尚无前二。况双非耶。若菩萨人处处得入何须法华。三又以三一为二。两非为不二。二不二皆方便。非二非不二为真实。破亦准前征人及处。四者二与不二及以两非仍属四句。未免名言并称方便。诸法寂灭不可言宣。乃是真实。今问。三昧起告三周显本为说不说。寂灭义遍何但法华。教下之理本自无言。况大不可说先为五人。况今广明五佛开权辨教权实。权实既显谁复封言。言封三者。迷教迷情。今约部判教。消方便名须有指归。岂徒遣语。以语逐语迷终未祛。虽千万破终不可尽。身之四句准此可知。况此品初题为方便。应用方便以释今品。乃作实释殊违品目。故知嘉祥身沾妙化义已灌神。旧章先行理须委破。识此大旨师资可成。准此一途余亦可了。亦如三种法轮殊乖承禀。大师称为顿乳。其以根本为名。大师以三味为枝条。其亦以醍醐为归本。今问。凡言根本。即曰能生能生始成。后摄归本本却非始。二言相乖。枝本不立摄亦无当。况根本两分摄归方一。一为根本二则名枝。是则根本本来是枝。应须会初而从于后。故开华严枝别。以入法华本圆。况华严别圆俱成近迹。根义复坏法华本成。又言三味是枝末者。鹿苑可尔二酥如何。若二酥圆别是枝。华严岂可成本。若尔。乃成会本归本。或即会枝归枝。若法华不关华严。则令二本永异。何得名为会末归本。况法华部内无入华严之文。但有入佛知见。况涅槃终极五味明文。本师所师旧章须改。若依旧立师资不成。伏膺之说靡施。顶戴之言奚寄。四引二文为例者。即是今经体内方便之流类也。大乘方便经十种方便未捡。五当知下结示斥非。言如空若海也。总包诸经色流。咸归今经空海。今明下正释为二先通。次别。初文三。先列。次释。三若一切法下。以四摄法辩法功用。释中四句皆先标次引文释。初句者既引文云诸法等者。以有言故且从有说。有言不出千如百界。第二句者。频引五文皆证入实。且以入证对说为实。初文是被机之意。次文是诸法之本。次文是化仪之宗。次文是本行之源。次文是亡教之理。诸文皆以入证为实。故知有说无说无不皆以真实为本。第三句中引证意者。诸法权也。实相实也。实即次句。权即初句。合彼二句共为第三。以初二门无别法故。例如下引例。假想故虚治欲故实。秖此一观是实是虚。何妨一法亦权亦实。第四句者。引文即指中理。虚实理等二谛难思。双非此谛以显妙中。亦不异于前之三门。四门理同故皆云一切。三若一切下辨功用。又二。初正辨句摄法功用。次直列下明其句意。初文者。秖此四句尚互摄互破。权则俱权乃至俱是非权非实。况复余法不摄破耶。况四句外无复有法。如此方成今经破立。岂与诸师破立同耶。当知诸师既不识于诸权诸实。纵说诸实既未分判。实义不成。况彼彼相望互推迷实。是故并为初句所破。故云无不是权。初句尚尔况复三耶。故诸师权实并得权之少分耳。言如来所说者。举果况凡佛有所说尚皆是权岂末世泛谭自言真实。不思圣化唯荐凡躯。第二句者实即究竟。佛说之权尚须入实。况余权实而不入耶。故知一切唯有一实。言巢窟者。说文云。鸟居木曰巢。兽居穴曰窟。保者。住着也。消通大旨须称佛心。直守一隅如保巢窟。三四二句准说可知。是故今文句句皆遍。若摄令可识。秖是三智照三谛境被三种机。机遍法遍理遍事遍。皆云一切所以可知。以一空一切空故一切皆实。一假一切假故一切皆权。三四二句秖是中智双照双非。内由三德三身具足。故使外用横竖显密。为成今经破立之意。以对昔故须为四句。通论大纲法相虽尔。别论今品唯在第三。亦权一半名方便品。以对自证实智说之。是故须云第三半句。仍须摄彼余三及半入此一半。方可得名今方便品。若专四句各摄一切尚非通方。何况诸师遍计权教。故云不得一向。直列下次明句意者。如向所释虽复略引略释相状。仍成直列以辩句相。未及融通以论玄旨。若破若立尚已无遗。不偏一句不滞一隅。故云尚自如此。况以大旨而遥观之。非局一方故云玄览。方谓一人一行。所谓一理一教。随立随摄随破随亡。取舍自在故云旷荡。升出暗滞故云高明。又穷远教曰遥观。察深理为玄览用横周为旷荡。指竖彻为高明。显一家消通故云若此。若作悬字意亦可见。他不见此将何以释方便品耶。况论旨趣耶者。为破古失。且以教相权实破立开施出没盈缩行藏。若行解兼论自他合说。览向文以论其旨。撮向事以论其趣。须晓四句秖一法性。法性秖是真如实相如如涅槃。以法性体不违诸法。不受诸法不住诸法不入诸法。故一一名字一一心法。一一句偈一一因果。一一凡圣一一依正。乃至十双无非法界。自在无碍其义可成。具如不二十门所说。若本若末体理无殊。说而不说不说而说。照性非远自在无穷。虽复无穷不出四句。四句无句无句而句。句句遍收十方佛法。但法华前教教四句句句未畅。来至此会一味无殊(云云)。具如药草喻中差即无差无差即差。次开章别释者。已知诸法互融遍入。举实即实中有权。方指此权名方便品。举权即是不思议权。此权有实。方以此权名方便品。举亦权亦实则各有所归。此乃相即之两亦摄三之两亦。故名方便品。故用即真实之方便。为方便品。举非权非实则秖是方便之理。理收三句皆方便品

问。若尔。句句皆遍皆方便品。何必第三

答。一者名便具权实故。二者义便所摄遍故。余句义便而名不便。余三虽有权义权名。不如第三即名即具。用此即实而权为今品也。故下十双。双双皆具权实之名。皆取即实而权为方便品。况初三总释皆冠十文八门故也。若不尔者。非方便之事理乃至悉檀。非列方便中法相之名。乃至非今经之本迹十义十义无二本迹似殊。本迹虽殊不思议一。十义相别实相一如。为众生故列释生起乃至。本迹。事理乃至悉檀不同。得意忘言言说解脱。若见此意常默常说言行无违。还以此旨而为观境。使彼观境昭然可观。诸释所无良由于此。如此解释尚恐有漏。况复诸家单浅只独。纵多列法相大小难分。虽判教时法华未显。若以法华与余同味。三说所无其言何在。然此八中前七迹门第八本门。本虽未至权实理遍。故下文云。是我方便诸佛亦然。故方便之名通于本迹。此既玄释不同消文。是故不同光宅判句。又此八门次第意者。若不列名无以解释。若不生起迷于诠次。解释正示十文相状。引证为防不信者故。结归为明品元意故。分别为令释品有归。判释令知粗妙有在。如是方显品之深旨。又预辩本迹令识本地权实自他。方显大途久近之化。于列名中一一须安权实之称。如云事理权实乃至悉檀权实。即是事权理实。乃至悉檀三权一实。复以三种释品分之。乃成今经之方便也。故论云。自此已下示现此经因果相故。故十双中初五从因至果。后五果家胜用。况一部文亦可本迹而分因果。故知因中若无前四。则因义浅狭。若无后五。则果用粗近。于中教是圣化。且以受者得名。不同世人以教为因佛智为果。亦不同他三四等也。余如下结权实中。生起后云云者。应于章章述生起相。细寻可见。又复文标能化义须对所。故后五双。唯体用中一只对所。余四并从能对得名。又此亦与十妙义同。若不尔者。谁知方便须具十法。谁知十法义遍一经。若无十法乃成经文不诠因果及以能所。是故十双皆穷至要。方是今经之十双也。若尔。一经始终皆名方便。并指前教以为所开。方乃可云此经方便。故知序中证信发起方便。譬喻秖是比况方便。因缘秖是往昔方便。本门秖是久远方便。流通秖是诸佛菩萨通法方便。由是方便故名真实。若得此意如观掌果。法华一部方寸可知。一代教门刹那便识。因果自他共成一法。十方三世无怀异求。以十法乘而观察之。法华三昧投足有地。无上佛果修途可期。有眼诸贤请垂观之

法华文句记卷第三(下)法华文句记卷第四(上)

        唐天台沙门湛然述

次正解释者。初释事理中。先释。次所以。释中先释理云理是真如至为实者。理实何在。在心意识。故理无所存遍在于事。故事名权。故俱舍云。集起名心。思量名意。了别名识。在彼一向全无即理。若大乘中八识名心。七识名意。六识名识。彼教为迷又无即理。故偏小教有漏之法。全无性净。即常住理知之者寡。故知有漏虽缘净等。同属于事。具如事理不二门明。故所以中云非理无以立事。事有显理之功。故称叹方便。谁肯以三界有漏心等。以为如来之所称叹方便品耶。若不尔者。为令众生其义安在。世间相言如何消释。释理教中。先正释。次非教下明所以。初释理中先略释。次引例。初云总前事理者。合前理惑也。故知无明法性乃至界外一切诸法皆是所诠。此心意识名之与体。具足一切界外法故。谁知法华之教。以此等法。而为所诠。若不尔者。邪见严王恶逆调达从何而得。次举例者。此即举解以例于迷。解理之时真俗俱谛解由迷得。故于迷中且名事理。由诠此理而得成教。以理望教教名为权。理在于迷迷亦名实。故权实之名非一处得。果教谭此能诠亦权。故知其教秖诠其理。是故如来称叹此教。自非今经谁肯叹此诠迷之教。为方便品。若不尔者。从三昧起所叹者何。次教行中行有深浅者。谓圆渐也。圆渐者何。谓七方便。还指渐渐即是圆渐。故教定行移行权教实。故言教无进趣。况教诠实相。实相之理无复浅深

问。若无浅深。应当无复诠行教耶

答。教有二种。诠理之教无二。表行之教自分。秖缘行有差殊。致诠行教小别。又能诠教亦无进趣。所诠之行自阶差耳。若不尔者。如来方便波罗蜜等何所证耶。次缚脱者。行名犹通仍兼违顺。故以缚脱而甄权实。名为缚脱。又通昔者。诸经地前尚自违理。未开权故。此经弹指无非佛因。以显实故。谁知此经佛以恶行。亦得名为善巧方便。死尸之譬遍通一切。具如修性不二门明。因果中三。初正释。次无果下所以。三二观下释成。释成中云二观为方便者。且约法示相借权例显。一一重中通摄诸教。岂可定局别二观耶。如体用渐顿开合通别中。亦有诸教体用等法。从体起用。从顿开渐。从渐合顿等。次体用者。还指初住为随分果。此果即有百界之用。言立一切法者。前事理中即以染缘为一切法。此中即是净缘诸法。具如染净不二门明。次渐顿中。一者自他俱有渐顿。二者化他起用义兼权实。并体内权为此利他权实法。故须明开合。开合者。渐自不合者。藏通两教不废小故。亦不合顿者。三教菩萨不入实故。次通别者。前渐顿门渐中虽有半教。半在渐初今半通后。悉檀即是判前体用乃至通别。准前以释。次当用下结示方法。言四句者。相破等四。具如前释。四引证中二。先引。次彼论下结叹。初又二。先经次论经中先引一部。次引一品。引一部者为欲略示方便遍故。具如前判。引一品者正示克体。指文处故具如后列。初引一部者又先简意。次正引文。初简意者简通从别。十双一一具诸教味。若有不明事理乃至悉檀者。信非佛教。且从相待故简通从别。次正引者。初事理中云不如三界者。谓不同也。始自二乘并异三界。未足辨今。今从上句非如非异来成此文。故与方便教事理不同。理教中理云寂灭者。真俗二理不可说故。次教中举五比丘者。从渐初说。亦应须云。若无性者为说人天。乃至修罗为下品善。乃至为说无作四谛。故知从理俱不可说。从事大小俱可得说。证教行者。若闻证教善行证行。汝等下二文并皆证行。应广约此经。以明善行作佛之相。种种之言义含教行。以有今昔因缘故也。次但离下证缚脱者但离等者。小中离妄名为解脱。即以虚妄名之为缚。小虽解脱非一切脱。小脱于大仍名为缚。故云未得。此证大小俱有缚脱。唯今名脱。尽行下证因果。尽行因也。道场果也。须约此中明本迹果别。故注云云。佛眼体也。见六道用也。始见顿也。学小渐也。注云云者。五时不同会令入顿。穷子开也。付财合也。化城通也。宝所别也。种种四悉也。次别引一品者。先结前生后。诸佛下正引。须一一释令义合十双。及与此经意会(云云)。初引诸佛等二句者。上句明佛智所知。故云甚深。即是理也。下句引门门即教也。所诠既妙故云难解。所知所诠其理无别。一切等者事理俱境。境即理也。智即能知望于能诠。悉名为理。同是所诠故也。此正用门字故难解字。更分属下声闻不知。于大名缚。此举不知正显能知。故能知名脱。次所以下释上难知。证教行者以能知者属在于佛。良由禀教有行故也。以亲近佛必闻教故。名称普闻必行备故。次成就下证体用者。成就甚深即体具也。随宜所说即是用也。应知文中略随宜字。次吾从下证因果者。正取成字以证得果之因。亦是有因之果。种种下证渐顿者。种种证渐令离证顿也。所以者何下。证开合者。方便证开具足证合。且约自行论合。自行既具利他必然。诸佛大事下证利益者。大事从别别必会通。取要言下证四悉者。取无量无边之言。以证三悉。止止不须说为证第一义。正指不可说理。如是相性等证字者。十界为事实相为理。若取究竟等者。空中等为理。假等为事。若将此文对下权实等。皆约体内论之。当部已开故也。言佛佛皆尔者。诸佛显实皆举五佛以为事同。次引论中与论小别。但有八双阙开合缚脱。利益即是通别开别出通为利物故。缚脱与因果小异。故不别对。论释诸佛智慧甚深。为证甚深。有五者。今约所证故判属理。虽离为五不出于证。义谓义味。佛智得证有实义故。实体谓所证之理。内证谓自行契境。依止谓正明所依之理。无上谓叹所证之理。至果之时过于三五七九乘等。论自转释无上甚深。云大菩提者。论以大字以释无上。非引菩提证无上也。以第三自有证甚深故。向约当品亦以上句证理下句证教。言阿含者。此云无比法。即言教也。前五证理而能起教。名为理教。今理通因论文在果。门是教智名智慧门。此中缚脱一双论文中无。今若立者难解难入。仍加难见难觉难知。于难解上。云一切声闻辟支佛所不能知此正是解脱意也。脱须对缚即与缚脱意同。论文合在阿含义中。论于阿含义更开八示现。即初从佛曾亲近去。为受持读诵甚深。二百千万亿那由他佛所修菩提。为修行甚深。三从勇猛精进为果行甚深。四名称普闻为第四增长功德甚深。今合论四文以为教行权实。论成就下为第五快妙事心甚深。论意趣下为第六无上甚深。论以随宜说法为第七八甚深。今合论三共为体用权实。论以二乘不知。为第八住持甚深。经既无文今无所对。论从此后复立如来四种功德。因果权实是一者初住成就。渐顿权实是第二教化成就。此中阙一开合权实。余与论不同亦不须和会。以论文增句今但直对。如前引当品文。故今更消现文。从证教行中亲近必修行。精进必增长。若不精进增长安有名称普闻。故二成行并由闻教。次证体用中事即是用。无上及入即得体也。既云成就信用从体。次证因果中云说如来功德成就者。功德属因成就在果。经云成佛已来。验知果由因克。次证渐顿中。云教化说法者。教化通摄一切化仪。兼于逆顺。说法唯在口轮。局于顺化。当知三轮皆云成就不独施顿。次证利益中以自证释利。以利他释益。自证实故。故云成就不可思议。随他权故。故云言语。前云说法通于自他。此云言语唯在于他。次证四悉中言可化者。四悉并从有机为名。故云可化。前云教化通种熟脱。此中可化多在熟脱。今言不可化者。相对来耳。即无四悉机者也。证事理中云成就诸佛能知法身之体。此指果地法身为理。以随众生名之为事。亦是法身妙境事理且足。今意通凡论文局果。果由凡克故义亦同。此与佛经及菩萨论文理雅合。故云与修多罗等合也。五结成三种权实者。结成头数也。故以权实共为其数。若施若会法无增减。若无此文则使前释权实未分。且列十名略释而已。故今对教乃分权实。文自为三。初结成三种中又二。先通后别。束通成别。通中又二。先通中通。次通中别。初通通中。初标至亦如是者。标中虽云四教皆十。乃成四教各二十也。或三十或百六十。言二十者。即自十他十故也。以自通他无别法故。还以自十通利于他。是故文中但列十耳。或三十所以着或言者。表不定故。故自他一或无本数。指自他故。今仍分为自他一对者。一依教故。以大经中有此自他一重二谛。二依理故。既摄单自他而为自他合。失彼单名自为一对。或但一十以自中合权为实之十实。对于他中合实为权之十权。总合方成十双权实。若二十者犹并存于自他十双故尔。当知四教或八十或百二十或百六十。揽兹共成一不思议权实。谓体内权以对于实。若不尔者非法华也。次又当教下别释中。云四种为自行者。前云通者。十十皆通自他等故。今云别者。十中分于四二四故。故知直尔分十以为自他。不对诸教教教皆然。又亦可以前五为自。后五为他相对为自他也。恐一教内自他犹通自他相对。今为分十以成三义。则一向成别故尔。是故四教唯有四十各具自他。故知今经唯属圆中化他自行化他乃得名方便也。次别结中云若通若别者。指前当教通别故也。今总以四教共对自他。则三教为他唯圆为自。故云别也。前通别名自之与他义涉余教。别束通别。自则唯在今品。是圆家方便施开等也(云云)。次结成四句者。结向别结自他以成四句

问。前立四句一一遍摄。今何以分权实各明相对为句。一切不成

答。虽借彼四句用申今意。乃分四教离今对句者。有其三意。一者对论第三虽收一切教尽未可得为今品首题。二者开竟还同前文圆融一切。三者今第三句既收教尽。但以此第三句中权实相即。则任运收得余之三句。借彼一切者良有以也。若以四句并通诸教。思之说之。三结成三种释品者。即初文中法用等三。故将此三各历五味以结品名。故知前释略依当分对教为言。故一家显妙。必存五味方成妙故。故一一释遍于五时。则令法用及门来至法华。并开令成同体法用大车之门。前二并成第三义也。初约法用又三。初直明五时。次如来下明五时意。三故释下结成释品名。初直明又二。初明出世施权之意。次正明五时。初文又二。初明入实本意。道场所得实也。修道得故权也。故引摄大乘双证二文。即理量是。次佛虽下明施权意。为接小故及钝根故。轸者。车行迹也。初行之始故云发也。次五时中言置是事者。置独说也。故至华严兼说于别。部中论主虽是圆教。准五时意以别助圆。下二亦尔。此约前四时三种法用不能至实。故但成于初义释品。若至法华纵名法用。亦成秘妙之法用也。即可以用释今经品。则方外之名昔日通四。今无复三。次约门中四。初亦直立五时。次从始至终下明五时意。三释品云下结成释品。四前一下与前章辨异。初文亦先明出世施权之意。次正明五时。初文明自证望说以为权实。故云自证亦不可说。次乳教中不云兼别直言别者。从门义故。所以前释法用通四。今唯在三故今约五味释门皆从能通。所以乳一酪一。生酥中三。熟酥中二。醍醐置之。四辨异者。与前法用虽同明五时。此明能通至于所通故得辨异。前一番等者。初约方法中。明如来能知能用方便。法是能知用是能用。众生不知是佛方便。今并开之令众生知。此一番明令众生从顺方便者。谓从门顺实故也而亦不知方便即是所顺之实。今亦开之。又前之二章并有机应二意。但前多从应说。故且云如来。后多从机说。故云行者。故殷勤称叹之言。并从佛得

复次下第三约秘妙释者。以妙故即。为欲通前四时以圆为即。三为不即故更对不即以释于即。于中又四。亦初明化意。次历五味。三上两下对上辨异。四上释下以结品名。初化意者。大旨同前。五味可见。言辨异者。虽同五味所对别故。虽诸味中有即不即。于佛常即众生自离。又凡五味释但得名判。若成今品复须更开。此虽准前三义释品则前二义。至第五味已成开竟。虽第三属开。今复通前。前四亦云非今所用。于今亦成所待之粗。圆及所入方是真实。后释虽复更对五时。但知醍醐无非秘妙开之与判咸在其中。六明分别照谛者又二。先明来意。次若通下正明照谛。初文意者。前自他等既并云权实。但从智为名。今辨所照故重明之。前明用智非不照境。欲令易解故重明所照。次正明为三。初通释者。名通而教别。若束四为二者。每一教中皆以四为二。如自中权实束为一实。他中权实束为一权。故但成二。次若当分下别释。法别而教别。准前可知。此中准前别结中文。秖应以事理等四为自证。今云悉檀。文恐误也。悉檀属后自他故也。次又三藏下即总束四。明前是教别而法有总别。今是教总而法别。此又三重。初中以三藏为他。次以二教为他。三以三教为他。而终以圆为自。由他不定自他随之。亦进退不定故。初重中以通别为自他。仍是别相自他。以由他唯三藏故也。次重既以通藏为他。故但以别为自他。第三重既以三并为他自他无复别体。秖得将三兴圆相对言之。故云束三教等也。然初重中通别两教各两向者。通有不共故同别。别约共义故同藏。别从教道故是他有证道故同自约诸经者

问。今约诸经还列五味与前何别

答。前以五时历法用等三。但成五时各有法用等三。令知法华三重俱妙。故以五味历于诸经。以部对部而辨粗妙。则前六门并须五味。使一切教无非方法等三。不无粗妙各别。及以一切俱妙。况将诸经十双遍历五味。门户别故不须此责。如玄义中科科五味。若无此五则今一科一句部不异前。故处处明之。于中初明五时具教多少

次复次下重以多少而明自他。结成释品。初文者。今正明教味故委悉于前。令知领解具腾五味。初乳为五。初半满。次约时。三约法。四约人。人中又辨生法不同。五引今经以判味相。四味亦尔。但酪等三味并皆阙人。文含义具。酪中应云约人但是二乘菩萨不用。方等应云约人且对大小斥遍入圆。般若应云约人带小明大。引小而归大。法华约人广在后明。即从此实我子已下文是。言未曾说者。通论教等前并未开。别而论之教行理三前或已会。若开人者前教所无。故以前教所无而为品目。故知非同体方便。无以施开等也。次以多少判者。前既委明人时法等。以论五时来意不同。此更略收前时法等。唯约于人。大小利钝无不入实。其人若入余无不归。故重明之。文云下引证以结品名。云云者。应更复释。前诸方便并非今意。意不殊前故不重明。次本迹者。未是品意。以本迹中俱有方便。故寄明之。方便名同远近永异。虽即永异不逾十双。以本实得亦何出于自他因果。故我本行菩萨道时。及我实成即是理事乃至因果。成佛已来即是体用乃至悉檀。于中师弟二文各二。并先明自他等三。次结成四句。初师中二文者。初文本迹各有权实。次束本为实束迹为权。则迹中粗妙望本俱粗。本中粗妙望迹俱妙。故今唯指久成名之为自。故久成中非无化他。所以中间今日纵有废三。亦名为他。世人不见而但以法身为本。何教无之。但弊不知父母之年。故显实成为本。次束但一久成之外。皆名为他。故自他中但束本迹。得权实名。三结成四句。言结成四句者。对之应言本中权实皆实。迹中权实俱权。以本中实望迹中权。名第三句。不思议一本迹俱得双非故也。云云者。令如向对之。次弟子迹本相对各有权实。亦从本迹而立二名。若通论者。本及中间乃至今日。节节无不具有四句。亦具四句。云云者。如前师中但以弟子为异。故云亦具。虽师弟俱四。若于师弟委判本迹。则本中四句皆本。迹中四句皆迹。若以本迹之名作四句者。应云本迹俱本迹本俱迹。本迹各有本迹。俱不思议。思之可见。复应但以二句判之。即初两句是。具如玄文本门十妙。乃至多少广狭准知。次若从佛迹下结成释品也。师弟从本垂迹据化本意。既俱得称为方便品。况师弟引入圆因。而不称方便品耶。有人问云。今方便品以何为体。他答。有人云。以后得智为体。引唯识说后五波罗蜜皆后得智。我今以根本智为体。今谓所言体者。为取所依为用当体。若取所依即权而实为体。若取当体即实而权为体。此之二义根本后得奚尝暂分。况唯说五则后得无体。况分本迹唯一久成而为根本。余皆后得。次正释经文。言或至偈后者。第九疏云。准南岳意但至偈后为正。若依北师偈后四信以闻经故。判属正说。此分无失故两存之。若不等者。述寄言意。虽复等者。述绝言意。诸佛二智如前说。云云者。具如三种及以十双。今叹诸佛及以释迦。为下五佛弄引。诸佛兼四佛故也。上光照至于此者。俱有五时。正表五佛二智不殊。此彼相望故名为横。今古相望故名为竖。此表释迦他表四佛。即表五佛道同故也。当尔之时者。五瑞等时也。佛常下问。此有下答。答具四悉。古今异故有出入故。即世界也。言必前入无量义等者。此准作序意也。但一定之中义兼两向。俱成世界。为人中云履历等者。履历即历事对境。法缘即内缘真理。出入称理方生物善。即为人也。定治散恶须先入定。即对治也。约自他益俱得实相。即第一义。并云哀者愍之别名。愍物之方。必四悉故。此不思议大感应之四悉也。故四法并名安详而起。言安此者。内安四法方起化他。有人问。此中告身子与大品何别。今答何但大品。始自四含终至此经。自舍利弗出家已来。处处有告各各不同。四含中或为发起生灭法轮故告。方等斥故告。般若加故告。今经开故告。本论云。告身子不告余声闻者。智慧深故。不告诸菩萨者有五。一为声闻所作事故。二回向大菩提故。三令无怯弱故。四为发余人善思念故。五令不起所作已办心故当知五意兼异他经。前显露教不云声闻得入佛智。十种如玄义中者。玄文第九释用中。本迹各十。迹中十者。谓废会开覆破三显一。住三显一。住三用一。住一用二。住一显一。住非三非一显一。若本中十但以本替一。以迹替三说之可也。故先告之以动群辈。此乃经家等者。故知告舍利弗四字全属经家。应知经家从省。若告舍利弗下更着舍利弗者。繁也。言论与今义相应者。引此论文亦具四悉。初文世界动不动异故。如实智下为人为生物善从观起故。现如来下对治力能除恶故。如来下第一义不离定故。故文自释云第一义。又以四悉总释自在。若尔。四悉总释前二谓自在无忤。此二各具四悉也。加趺等者。文在婆沙。今更具录。第二十二杂犍度中问。一切威仪尽堪修行。何独结加。或有说者。是过去恒沙诸佛行法。后代行之。今初文是。有云。令人恭敬非世俗仪故。今第二文是。又云。能发三菩提心故。今第四文是。又云。能破魔军故今第三半文是。又云。可人天意不与外共。今第三半文是。今为成四悉。所以合论第四第五。为一对治。论对治居第一义后。私谓去。私判前文云具四悉意者。令如向点出兼释出四意

问。余经等亦是论文。论云。何名系念在前

答。系在面上。故云在前。论中初有眉间亦然。又云。无始已来。男女相视起于欲想。多在面故。又云。眼等五根能生欲心。说之可知。今文分在前在面以为两释。义立故也。初在前文作所表释。即四悉意。次约在面义立四释。即四教意。初有背有向即世界。观寂定生即为人背生死恶即对治。寂灭有理即第一义。次约教中不净观成灼然初教。与空相应岂非通教。为分别故岂非别教。实相即是圆教意也

问。面唯四根何得云六

答。面具五根。四并有身。若缘现量色等境时。意又居上。故俱舍云。有身根九事。十事有余根。言九事者。即能造四大地水火风。及以所造色香味触。并身根一故云九事。言十事者。余眼等根皆具十事。如眼根上有能造四及所造四。眼及身根故成十也。眼等觉触即身根性。非三种化他者。非三教中权实也。前已多重释品。且约一种以三属化他为权。圆为自行属实。故前文释自他等三。约谛释中作三节释。第三节释三俱属化他。深高横度者。于中法譬合以此例后。今释实既周穷横竖。下释权理应深极。下当释权预述其相。故注云云。其智慧门者。其乃指前实果因智。若智慧即门门是权也。若智慧之门智即果也。盖是等者。此中须以十地为道前。妙觉为道中。证后为道后。故知文意在因之位。除真如外凡有修入。皆属于权。唯以果位真如究满。为清凉池。此约自行因果相望以释。即释品中第五重也。若通余九此则不然。岂以道前而无实耶。即初四双中实也。岂有道后而无权耶即后五双中权也。难解难入等者。略叹道前因位始末。次从不谋而了去。即于因中仍指事用为权也。以此因权并是真因。即知此权由证实理。文中从用从因别叹。十住始解者。解是开之异名。故将名以对位。论中此前更有三句。谓难见难觉难知。今谓此是难解方便。亦可以对闻思修三。法身本意者若望十方无时不应。今准此方未设化前。乃至久远未结缘来。于此段众生并名在法身。无有欲以小化之义。故云拟之。无机等者。此从结缘已后为言。其时犹宽。从华严下今世设化。今大机至不知者。大机击于大应。故云启发。应言欲发何以云启。由大瑞已彰。故且云启。次重释门中光宅等者。以五停等名小乘方便。若论化意散心弹指尚得是门。何独小乘方便非门。光宅之意未必全然。不可全夺。故云与夺。先明夺者未能入大。为佛所破。既不能知门义不成。所言与者。三教并是能通之门。二乘亦得能中少分。既未能入犹失于能。尚未成能永不识所。言最浅者。小乘已浅复是方便故也。云云者。此与仍夺。应广分能所识不识等。如前以门释方便也。今解去广立四句。欲以初句破光宅。故泛举第二第四。以无佛智为门。入方便智故可义立。若论今经唯在第三。光宅但得初句少分。况复诸门。光宅之解乃至一观者。空分体析。析是空中少分。十二门者。应分别十二门。各有门中方便之相。于三四门既有进否。会堕在一。一门者。多指有门。以有门中用七方便故也。第四句者。先已入中故云双照。若开显中即是今经从体起用。区区者。屈曲貌。此须开拓者。开论一句如向诸教各有诸门。云云者。十六门中为是何门。若圆四门具如止观第五圆教观门。及教智行理。故论唯云阿含言教为门。今家乃以智为智门。意云。初住佛智为门入佛果智。故住至地并名为难以难叹入令得入故。故若得门无功用道必入佛慧。无所疑也。故上说圆因称方便品。因即门也。是则开示悟入皆名智慧门也。所以者何下。至诸佛二智不同光宅释者。一者文初有所以者何。验知释上。二者下释迦文初自云吾从成佛已来。方是释迦自叹二智。今释诸佛云所以者何者。双冠二智。何故实智甚深。良由外值佛多故。云亲近等。近佛必禀承至要。纯厚必由尽行。勇猛精进即释权智者。诸行不出勇猛精进。今于权智上加勇猛精进者。有二意一者期心有在。二者身心俱勤。二智并由精进。然今但以行道法边以属实智。约名称边以属权智。恐未尽理故复加勇猛。用释权智。又用实智深广以例权智。权智亦具横竖故也。故须勇猛精进一句用拟竖深。故不得以精进释实智也。又难入门者若其退从分证八相。亦堕诸佛之数者。乃以教行为门。从行入证证不容易。故门难入。入已即能恩沾百界。故曰无疆

问。百界有限何谓无疆

答。界虽有限益物不穷。分证尚尔。况论十方究竟果佛。以果验因岂有不尽行道法。不勇猛精进。而能令二智横竖深广耶。次结二智中以成就为结实。随宜为结权者。实必成就权必利他。故实智云到彼岸底。权智云称机适会。又实智中称理故到岸。甚深故究竟。并随时为言耳。随情等者。法华已前不了义故。故云难解。即指今教咸皆入实。故云易知。若尔。由入者不当故云难解耳。若至今经更无不当。但借昔之难解。以释今教之易知。引摄大乘者。今文显了但依文判。如记二乘逼增上慢。实得必信灭想犹闻。大通结缘化城无实。如来久成之尘数。过于昨日之墨点。持一四句偈功不可量。闻寿命长远获无边果报。岂此文下更有义立。令二乘人不得记等耶。令佛寿量短促等耶。故四意趣中平等意趣秖云诸佛咸然。不可以他佛替此。亦不可以别时意趣释记声闻。意乐意趣释迹本长远。纵使用者。秖可云尔前不乐且逗灭想宜近之徒。若全以意趣消此经文。此经全成不了义说。并须以义判文故也。故前诸经随何部意文义兼含。如真如真谛无生无灭。地前地上法身化身。咸须义定方了文旨以部含教共不可依言。须从义判乃称部意。言有时者。非其听次别咨决时。故知自行不专于实。利物何独唯权。以自行化他俱有权实故也。所以成就中云甚深。随宜中云难解。甚深岂独于实。难解不专于权。故但以成就对自。随宜对他则任运自他悉具二智。言云云者。亦可前句结自行之实。后句结化他之权。以自行故权实俱实。以化他故权实俱权。以初释结文但在自行权实故也。虽云适会正语功成。故云云意中更须别对。具足如前四句中说。自行权实尚开四句。况对化他。化他理须具四故也。所以叹实叹权及释权实中。权并从因者。以释前果权之所由。以果从因得故也。及至结中言随宜等者。须义兼于因果以因权用权俱名权故。以用权中复通因果故也。至释迦章叹释权实皆悉从果。至双结中权指因者双结叹释二文故也。次斥旧三意中。旧师亦有许所以者何下。释诸佛二智等。但释释迦章分文前却。旧以舍利弗下尽属权。次舍利弗下尽属实。故使不同也。初开合者。今家诸佛亦权实各叹。以释迦二智岂不同耶。诸佛二智岂不异耶。故知后之二意亦不同古。释迦亦先实次权故也。言但依文者。依今分文。言又汝云者。责三不同也。以五佛章门共显一化。故得本迹开合自他不别。何得五佛互辨在无。然非无此理但不须违文。文顺义当何须别途。故注云云。譬喻者。且分小衍故云芭蕉及如幻等。此譬观俗故且立之。若譬真谛及十六门各立事理。广如止观四门料简各立事譬。言依诸论者恐误。应云本论。本论略举渐中初后。故云乳及醍醐。仍阙云乳譬十二部经。玄文亦以乳对于小。言悉到事理边者。应云边底或阙或略事边理底故也。如来知见如前者。如向释知见波罗蜜。如此下释疑。恐疑释结实智而置深广之言。谓为实智言说可及。故今释曰。约实体边实非横竖。斥彼摄法不周故云横。斥彼照理不极故云竖。究而言之并非横竖。寄言者正破疑也。说有横竖理必不然。无限故非横。无极故非竖。如函大等者。用不二智称不二理。无量无碍者。如彼生数。生无量故慈等无量。故此无量犹名若干。故以若干而叹于权。权名便故。以无限故名为无碍。今且从自能入边说。故以能入称无量等。非但至梁代等者。自梁朝来。皆以此句以为结实。实无碍智无复若干。那云无量。故知无量用表不一。云云者。同教实智皆无若干。岂圆实智更有若干。无量下释若干等。故四无量定在权智。既云四等及以四辩。验非实智。即是无缘四无量心在运应物。八音四辩力无所畏。略如法界次第及止观第七记。大论广释此中文略。但举乐说以说前三。文仍略法但云一辞一义而已。就此复略不云又与一切相即说故。既云比于通别。理合四教相望比决力无畏等。禅尽禅之实相等者

问。实相之禅与楞严何别

答。不同。何者。于根本禅达即实相。名为达禅。首楞严定本性健相。经解脱者。亦穷八脱之源。三昧者禅定解脱。至初住时破二十五有。已得名为王三昧也。况合果地不得王三昧耶。故下结云深入无际。故知禅等皆无际也。若以根本三三昧等。而释此中法华变成婆沙俱舍。故释经者先知部类为属何时。时中为在何会何教。然可判释法相浅深

问。既云权智那云实相

答。自行之权全指圆因。揽因成果故云成就。即向无量皆实相故。皆果德故。以无量法得理故也。故能横竖横竖不二。郑重者。汉书云。皇天所以郑重。频降命也。今文前以诸佛对释迦。乃成六重权实何故由中又两重耶。故此述云表殷勤也。一代所无故殷勤以表之。然西方重闻以表不轻。此土根别闻重则慢。故文为故以息此见。言辞等举实者

问。既言悦可众心。赴物应是举权。那云举实

答。众心乃以得实为悦。故更引二文证之。前叹中等者。此明权实前后。欲明今佛化仪始末不同。古师以今佛望诸佛而为同异。异则成失。今辨异者望他仍同。又举等者。前分为实则独为一句。今重释者则冠下二文。皆云取要。取要不过权实故也。单明一事者。举偏显非。故不偏指若权若实。故云悉也。止者下正绝言叹者。古非可见。今意者文但二义。初叹。次设下止。此取义便。若从文便则应先释止。次释叹。所以从义者。以从释叹言兼二字。指止为叹。故云止叹。次释一向以释止意。虽云恐伤善根。正以止生钦慕。故不解者。指后五千预分两瑞。知佛言音妙赴众心。应于二义离为三意。一以此理妙叵说故止。二欲说妙理止而叹之。三将护物机似止未说。以初一文离二故也。故不同印以下自有略说开其疑请之端。故其解未当。观师仍似今之后意。而不知常情何过必须止之。次释叹意中云两意者。初是修得。修得之言通于境智行位自他。局在于果。次境界者通于凡圣始终逆顺。局在于佛次就佛成就下于初意中。复以横竖二意。释果人法横竖理穷。第一释初意中云成就对不成就者。以果对因。因即因人。自他相对即是横也。故知因人皆未成就。须对教味委悉简他。经第一等三句亦尔。今云成就对不成就。乃至难解对不难解者。中略二句故云乃至。应云第一对不第一。希有对不希有。以降此外皆非第一希有故。圆中极果他所无也说者委消。不成就等四法对果。兼辨因及诸权故也。唯佛去明竖深者。前句既以成就等言。对他为横今有究尽之言。故对因明竖

法华文句记卷第四(上)法华文句记卷第四(中)

        唐天台沙门湛然述

次诸法下释甚深境界者。此是法华之理本。诸教之端首。释义之关键。众生之依止。发心之凭仗。权谋之用体迷悟之根源。果德之理本。一化之周穷。五时之终卒。得此十义以消诸异坦然无误。所以先叹能依之智。即五佛之权实。权实何依。所谓妙境。境不称智尚非佛智。况无境可论直云对等。何能晓此难思妙智是以广破诸师。次广建立。玄及止观以此为主。一家用义大括包富者莫不由此。恐后辈犹亡其所归。故殷勤烦重。亲见寻斯教者。犹昧故耳。故须思之故须思之。若迷此意诸教之蹊径任运失趣。一化之条流于兹枯竭。光宅云。三三者。谓人教因。昔无果义故三乘各三。一理非虚故。言实相者。应云非虚故实非相为相。故名实相。四一之中偏举理者。准光宅意既同旧人。不立理一。但云理是四一之本。故四俱名一。此不及今文云四中之一。此去讫北师并是光宅释也。菩萨以六度为体者。光宅亦立三祇菩萨。以为三乘之中菩萨。即今文三藏菩萨也。近代以来此义全弃。五百所集须归五天若但会退大自归佛道不关此者。何但定性永灭。亦乃菩萨空谈。云云者。应明支佛声闻以谛缘为体。实境有四一以四广其一理者。因缘等四判为实境。故以此等广谈理一。畅师但约佛上。唯立一实而无三权。对十力者非无此理。望今四释佛乘一释尚自未周。以无究竟空假中等故也。于中相是总举十力之相。次是别对性等体为根本。最后云总者。约前八力释处非处即以本末总收前九。上来诸释非不一途者。诸释可见。望今家释各得十界十如中之少分。故云一途。光宅虽似自得四圣而但立九。又分擗九五权四实。北瑶二师虽具立十而不分判。但在三乘又无一实。然攒众释既许三乘及以一乘。三一俱有性相等十。何为不语六道十耶。四圣是事从因至果。六道亦事亦应例然。因果既同十义宁阙。四圣是能照六道是所照。十界是所照佛乘是能照。故佛智照十界十如三谛具足。究竟等言其理宛尔。何故诸佛各据一途。使佛境智不具足耶。今师不能细斥。但总破光宅云文理不通等也。理谓道理。文即现文。初文可见。次破理中先以十中四五对难。因果者。因缘是。因果报是果。若实下约人对破且依四五。若依今文应约十界以论有无。次义不下结破。文云诸法。须收十界界界十如。实相是界如之体。若唯一但四。体外尚遗九五。况复十十皆如。今欲正解。先引大论即达磨所用。引论意者但泛为类例。非的同也。论既云一一法各有九种。故知光宅不应以四五别判。诸师不应以三一各据。故知但依十界十法则诸家咸坏。况复四释冠绝古今。如此消文方契经旨。诸师分擗理趣在何。此达磨郁多罗是杂心论主。婆沙有法救论师。是杂心论主所承。从师为名。既依大论不别分张。今一一句中皆云即是法华中如是相等。纵不委细免上诸非。次今明下正解中。先述标章。次正释中文为三意。初列章。次引圣言为证。三正释。引证文中初二文可见。次引离合中云止止不须说等者。以此十法随自随他。唯佛决了故云我法妙难思。但引合文义兼于离。既云难思方能遍逗故须离也。引约位中云唯佛与佛等者。三德极理非七方便所知故也。虽复不知诸位法尔。故分此十所属不同。三正释者。初十界中为十。先标列。次法虽下界如摄法。三如地狱下示相。四故毗昙下以小例大。五当知下以理准例知有界如。六若照下判。言自位者。虽明十界界界各十。且照当界以九为权。以一为实。故须结云一中无量。一界具十一一十如。若自若他若因若果在一心故。故云无量中一一中无量。不可以一说。不可以多说。不可以权说。不可以实说。因果善恶空有大小。凡圣渐顿开合心法依正。一多自在。一切诸法悉皆如是。是知谭法界者未穷斯妙。致使惑果事而迷因理。七若照六道下兼破光宅。光宅既无十界。今且依彼破之。纵依十界各具十如。当分历历思议境耳。况复光宅但在四圣四五不同。八所以下结位。先重立境云一中无量。凡夫绝理等者。自鄙无分故云绝理。随想异见故云情迷。既绝且迷徒具何益。二乘等者。即二教二乘。三道即是舍而不观。避空求空反资小脱。菩萨等者。藏通照六别照次第。故云不周。皆迷己界不达佛界。不了了言尚该十地。故今应指别地及因。横竖具足者。一中无量为横无量即一为竖。多一相即故云具足。九唯独下引证结意如文。十上玄义下指广。具如玄文境妙末云。舒之则充满法界。不知从何而来。收之则莫知所在。不知从何而去。及释法中广释十界十如也。次约佛界为四。初正释。次此具下称叹。三例亦下例释。四如来下举果结斥

问。此中佛界与前十中佛界何别

答。前则在迷在因通悟通果。今乃唯果不通因迷。故一一法皆用双非。非相非假非不相非空。虽出双非意存三谛。下九准知乃至本末究竟等也。如是方名究竟佛乘。是故皆以大车文结。此则于今品文。是佛果家之诸法实相。于彼譬说。即至道场之庄严大车。于彼宿世。即极果佛之开权实渚。于彼本门。即久成佛之所契妙法。若正宗可识岂迷流通一句一偈之言弥可信也。三德三轨之说皎若目前。若得此意广演于八年。不出乎一念。经五十小劫讵动于刹那。例知一代逗机居于心性。十方佛事宛然瞩目。法界根性览而易通。随宜所说咸指藏理。结斥中以眼为喻者。且以小乘慧眼见空。与而为论云得一眼。初住菩萨乃至等觉犹有无明。今且斥方便教菩萨未见中者。并如夜视。次释离合中为四。初正释。次离开下举境称叹。三凡夫下斥。四为此下结。初文为三即三语也。随自方在今经细寻可见。四约但中二先正释十如。次初位下重释究竟等。初文者。相性体三与前佛界不无小异。前明已成佛果。故以修性对论而具十法。今明位涉圣凡。分对十法。十法位别故云约位。以初三唯理位定在凡。力在五品。作在六根。因缘即是初住已上修得缘了。果报即是极果菩提涅槃。菩提果也。涅槃报也。是故初三且在通列十界。界界三德同在理性。故十界之言亦唯在理。若不尔者。何故云若研此十界等耶。故理性三德其文在斯。然诸文中多约修性相对辩者。为成教相故也。读者悉之。今见此文应贯诸说。若研至如是果报者。初之三法既俱在性在因。合名为正。故力已下属修属果。所以观行位去研此性境。有除粗惑之力。及有似行之作。若入分真对彼性三。合名为正乃以具助名为因缘。至究竟位菩提名果。涅槃名报。虽分对始末。乃是一佛法界因果之位。故不同古人以权实擗判。初三等者。初谓相等因中三法。后即报中果地三法。故知三德即是三谛。故云初后至究竟等。初位下重释究竟为二。谓释结。释中三。先重释三德本末不二。结成绝叹之境。次重释究竟等成于不二三释不思议。初释三德者。恶即三恶善即三善。贤谓小贤。圣谓小圣。小谓小中贤圣。大谓大中诸位。重释究竟等者。又三。初约惑中先立境。次若迷下约于迷悟。对辩三谛。三又权实下约人约教。所以四释者。明理摄遍约十界释。明自证极约佛界释。明佛化用约离合释。明三德遍约诸位释。若望止观互用宽狭。今具四释则此宽彼狭。此但正报不语三千。则此狭彼宽名目虽然理必齐等。因必具果正必有依。然本论中释此十如。理穷教极。今述论旨使与一家义意冥会。论云成就不可说尽也实相者。谓如来藏法身之体不变故。佛智具足知此实体。经云如是相等者。论云何等法云何法。何似法何相法。何体法。何等法者。谓三乘法。云何法者。起种种事说。何似法者。依三门得清净故。何相法者。三种之义一相法故。何体法者。唯一佛乘无异故也。今谓初句先明十如通三乘法。次句者。所谓三乘教差别故。次句者。即三乘人依教契实。次句者。开三乘相无他相故。次句者。开三乘体唯一实故。论又云。何等法者。有为无为法。云何法者。因缘非因缘法。何似法者。常无常法。何相法者。生等三相。即不生等三相法故。何体法者。谓五阴非五阴。今谓此番离开三乘。展转别释归实相体。初句者。以声闻无为对六道法是有为故。次句者。以支佛对余非因缘故。次句者。以菩萨法对余八界悉无常故。次句者。总以三乘对余六界皆三相故。次句者。十界五阴皆实体故。论又云。何似法者。无常有为因缘法。何相法者。谓可见相等法故也。何体法者。谓五阴法能取可取。是苦集体。又五阴者。是道谛体。今谓此一番释以上二句。总合在于第三句中。仍撮第三入第四中。谓三乘法皆可见故。又撮第四入第五中。成初苦集。复指苦集全是定慧。故云。又五阴者。是道谛体。故知六道三乘望实犹是苦集。论又云复有依说。何等法者。谓名字句身故。云何法者。依如来说法故。何似法者。能教可化众生故。何相法者。依音声取彼法故。何体法者。假名体法相故。今谓此一番释。还依五句欲以教法通说前故。初句者。具诠十界权实法故。次句者。所依皆实无余教故。次句者。明权实根缘受不同故。次句者。明诸根缘会大化故。次句者。明能化所化能诠所诠皆假施设以望所诠唯证实故。信知论文不可辄判。故用今意方应妙旨。况论四释即是今家四释故也。初释既以三乘体相皆一体相。即佛界释也。次释既以三乘对六道释即十界释也。次释既约苦集对道。此外无余即约位释。次释即约能诠教释。由教权实故有施会即离合释。故知一家大义并与论旨冥符。是则现文一十八句。乃成一十八重释十如也。论文丰富而人莫知。今从总论故且四重释耳。三若就下释不思议者。前境虽已成不思议。其名仍通。故今更对思议辩之。令识前四释真不思议。先略出体相。次引事类况。三举理况结。初文先略出。次诸经下指广。初文先法。次譬。初文先释名也。出心数法故不可思。过言语道故不可议。次不能行等出体也。体非因果及非能趣。行者因也。到者果也。此体不当因之与果。若其属能则不关体。次举譬譬中三。谓法喻合。初法者。观色是常故不败坏。常必具四。四秖是心不异亦尔。譬类中二重。初以明暗喻不思议与惑同体。故指月光全明是暗。次又日出时下譬转暗为明。云常在者。秖是暗无暗性举暗是明。迷悟亦尔。理性无殊。因位之明与无明杂体不可别。故云共合。入分真位破一分暗。所破之暗体变为明。岂有所破移在异方。无所趣故故云常在。岂智明发仍存先暗。云常在耶。虽云常在终须破尽。究竟永净方名常在。生死与道合下合也。次指广如文。就事况者。四不思议中阙释佛者。世易信故。教多说故。故以佛在四中之一。三类尚尔。何况佛耶。云如阿含者。如增一十八云。舍利弗说。界生不知如来寿命。佛言。有四不思议非小乘所知。云何为四。如文。因释世界不可思议。引经为证。言阿含云一士夫者。杂含亦云。佛在舍卫。有多比丘在食堂上。思惟世间。佛知其念。诣食堂上告诸比丘。汝等思惟世间。非义非饶益不顺涅槃。汝当思惟作四圣谛。此是有义有饶益正向涅槃。如过去世时有一士夫。在王舍城俱絺池侧。不正思惟。见无数四兵入藕丝孔中。见已作是念。狂耶失性耶。世间无是狂而今见之。时去城不远有大会。士夫往问如是之事。大会皆谓是士夫狂。失性故尔。彼见佛问。佛言。非狂是实。彼池不远有天与阿修罗共战。修罗兵败入中藏耳。是故比丘莫思惟世间。非汝所及。释龙中兼明有天亦能出雨。即龙类也。五道下郤释众生。论云。五道各有自尔力故。婆沙杂揵度中云。若因祭祀唯鬼神得

问。为胜为劣

答。非胜非劣。若胜天人应得。若劣地狱应得。以其道有自尔力故。准斯诚教。可证世人设六道者不可尽得。此是梁武见江东人多好淫祀。故以相似佛法权宜替之。论云。如人不能离地四指于须臾间。为能飞空高下自在。前寄雨一事者。明余道不能。如善住龙王以比智力。知帝释欲与修罗战。脊骨便鸣。若帝释欲入园时。脊上自然有香象现。此畜生道中不思议摄。如鬼能变食等。又云。诸土各有自尔力。如释签。言此有三异者。以此颂二智文。望前初章叹诸佛二智文具三异。初句颂实智中。但有二异。下三句叹权智中。又有一异初异应云双只。次异中云开合者。上长行中人法俱开故诸佛中并二智各明叹释结故云开。今但云世雄故云合。人必兼法故云人总也。言法别者。被物时异故有权实。此别仍合无叹等三。故第三异。云二乘及一切众生者。同是不知之人尚未足异。应云上人法并举。故云其智慧门法也。一切声闻等人也。今但出人又是有无异也。亦是双只异也。又上文不分四佛。但云诸佛。故今前行但云世雄。即当诸佛。后行但云佛力不云吾今。以前文中释迦权智具有力无是等。知是颂释迦也。又前文有诸佛字。则可分为四佛。今但云世雄似非诸佛。然以义分以世雄句有世字故。可属三世。世必有方故知是颂诸佛。后行直云佛灼然可属释迦。言佛力无畏是权智者。前长行中指于因权。此中既云功德。功德之言亦多在因。余法等者。前力无畏但是自行从因之权。是故余法为化他权。此之化他非指权法名为化他。但对自因名化他耳。但举初后者。仍先举后二却举初二。故先云大果报。次云性相义也。义字等者。义谓义理。秖一究竟之言。有空假中义理故也。大与种种等者。具如玄文破光宅中。彼云大故知是实种种故知是实。今文意云。权实互有。岂果报唯大性相唯种种耶。又释妙中大妙相望以为六句。六度至发心者。断即成佛故也。如意珠具如止观及记。无漏不思议者。当知此不思议之无漏。故无漏名同应思义别。云生出四种解释。已如上者指上四番释十如也。此下偈文对者是也。逮得涅槃指六度者。以望二乘此生即得。故云逮得。逮者及也。又今欲废小菩萨为旁。故旁云及也。当入灭耳。若不尔者。今准他人上之三句。正明二乘。脱缚即是已得涅槃。云何更云逮得涅槃。由闻三伪一真。是诸声闻但闻三乘皆是方便。方便即伪。又闻要当说真实。所以疑其实未曾闻说唯一实。偏举二乘者。世人若问若三俱会何故此中叙疑但二。亦应反问。若菩萨无疑。何故下文云菩萨疑除。若云疑通三人会唯有二。菩萨何过而不会之。经云疑除作不会释。此乃破经何名释经。一解脱者。昔教三人同一解脱。方等般若中虽闻胜脱。今从初说。有云。已得三德中之一脱。此不然也。释三请者。瑶师龙师非无眉目故不全破。但不及今师。以望三周抑令三请。此则释文所表俱有深致。凡一家破义皆恐累后学。于经有过强复破之。不同世人任其胸臆。又偈后三行半云动执生疑。至尔时众中下但云腾疑致请者

问。准品初开章云。初略开三显一。次尔时已下动执生疑。及到此中何故乃以略开三文。为动执生疑。尔时已下文为腾疑请者何耶

答。但动执生疑之言。言兼两向。何者。若在尔时大众中下。意明由前略开动其旧执生其新疑。若在三偈半文。意明此之略开动彼旧执。令生新疑。故复名长行之文。为腾疑致请。执既被动因兹有疑。今先腾疑后方致请。是故此文两向用之。非参错也。若以此文为腾疑致请。则应更开章云略开三为二。先长行并十七行半偈叹二智。次三行半正略开显动执生疑。文云执动疑生者。由前略开动其执故执动。由前生其疑故疑生。疑既生已。今但致请。是故章首但云腾疑致请得益之者悟有浅深。所引之人获记差别。约能引权众辩益不同已知显益欲知冥利。须辩待时。尔时下次明二止。初止意者恐怀疑故。次舍利弗腾宿根利。是故更请。次佛止之护上慢故。次舍利弗述慧益多。牒疑更请。一次正广开三中三。先分章示相。次义四分别。三依文正释。初文四。初引经标章。次举品分周。三亦名下三周异名。四引例。例如大品三根者。第二十一方便品云。须菩提白佛言。如佛所说若广若略。诸菩萨等云何求耶。佛言。如是如是。乃至一切种智如是相。菩萨摩诃萨学是略摄般若波罗蜜。则知一切法广略相。世尊。是利根菩萨亦入耶。佛言。利根中根定心散心并入是门。是门无碍。亦如三种发心不同。以十义料简者。自古此文多有纷诤。今为评判及以自立因为十门。然此十门虽泛拾破。一家置章不无次第。初欲明所被之人。先明能益之法。故先辩三周通别同异。次辩所被权实有无故。次明第二。于实行中得入之人。三周不同由惑厚薄。虽现惑厚薄须知由宿根。虽已成根根须在悟。既得悟已必知领解。若有领解理须与记。得记之者悟有浅深。所引之人获记得否。能引之众须益有无。已识显益欲知冥利。故辩待时。初门自立。文初中云若我遇众生等。是因缘说者。昔曾结缘即是昔因。中间相遇处处皆以佛道成熟。今日五时咸资佛道。即始终赴物也根利未须述大通事。若谓此文属说法者。虽在譬说文初。分文仍属法说文后。既在譬说题内。故且用之。不然则取次文用之。长者惊入是因缘者。昔因今缘是感应义。长者是应所闻是机。惊入即是赴机故也。故知应赴即是今之一化故也。答意者。许各具三根。法说自被法说中三。余二亦尔。但说三根摄九即足。从正略旁者。上根中上根为正。中下是旁。亦应云具论有三且言上耳。若逗上根上三俱被。但上根为多为正。中下是略是旁。中中上下下中中上亦复如是。第二义中光宅有实为权所引。则成定有实行。引权意令有实。开善定执引权意令无实。今云有无且约实行。权应暂有何须论之。开善指四念处为初业故。故云外凡。今言有者。谁论初业能知常耶。岂以初知令今无耶。如大通佛所谁不知之。亦言于今有住声闻地。言宁有者甚不可也。法华之前所执者谁。经明等者。正为光宅所破。既云宁执小果。权者何所引耶。今先总斥二家乖经失义。乖经者。光宅也。今经二文得记故无。未记则有。又在昔故有于今则无。故今引文约开约记破其定有。若望后无计有则失。失义者破开善。若定无已下文是。既有入城必有实行。权何所引者复以光宅结破开善。故今立实有与光宅言同其意则别今虽云无亦与开善不同。从得记后说故。若定有者下破执定有。恐计三周后犹有声闻。若定无者。破定计无。如序品初因光横见文殊引往。方便品初千二百人法说周竟。尚自不悟仍待譬说。宿世文中于今有住声闻地者。又举不知之人。云舍利弗辟支佛等。乃至流通处处有之。云何言无。又云无者。破住果者定计永灭。非谓本无。若言下今文泛难。今许实有为权所引。仍恐他以三藏佛例。此义不例下今文申之。佛居果头则无实行。声闻不尔是故有之。三藏佛言出自今教。故知不是他人难也。何处者。佛必三身圆满。故称此佛为权。若言三十四心。此乃教权似实古今学者此佛尚不敢为权。谁知寂场不实。今明下正解。先立理。次引论。初略立。次云若从等者。实智尚无阿鼻。岂见定有声闻。若说时未至有义非谬。故长者佛眼始终皆无。以法眼观中途须有。作人亦约未得记前。次引论者为五。一正引论。二若依下以今经望论义立五种。三若从下判。四若得下结意。五复次下判大。引论如文。次今家依经望论。但加佛道一种。三判中云若从决定至宝所者。约大虽无准小仍有。退菩提心仍属有者。由在小教。今谭其初故云退大。实者既尔下明应化也。所引回心能化本大。若增上慢二途不摄。本非商议。五复次下更判大乘有无者。先判。次结意。指应化为无第四第五并名大故。故论中则无大乘之名。但云应化。若从下正指佛道。此用今家所立之名。而以发迹释义。仍除开三得记已。即名生身得忍菩萨故也。故取发迹者。知有实本亦得名为大乘声闻。是则从隐德故无从发迹则有。所以得大乘声闻名者。彰言发迹仍示声闻。故得名也。不同他释于大乘中自立声闻。从今开三下定文正意。须为二人。为退大者与论不别。今取决定意似少殊。论据在座得记。今据通途被开。其不在座展转为说。或在界外亦得闻之。或佛灭后敦逼令信。此经通说直云与记。论云退大。且依一途。如诸声闻于法华前。谁知退大。方等等席。咸称灭种。准今经意既彼此闻经。必彼此与记。一开之后无所间然。回与未回以分二义。当知论涉有余之说。无以经意雷同。第三惑有厚薄者。古师以回惑释惑。今师以烦惑释惑故与旧不同。于中先列古释。重观所证故云游观。由游观故知一理同。及其下明其惑由。由闻教异。将必下正明互疑生惑。教本诠理能诠既三所诠宁一。所诠若一能诠岂三。踟蹰下明其惑相。虽复回遑未辩得失。以理下判其得失。以理惑教有顺理之得。以教惑理有违理之失。上根等者。乃以小中理教得失。而判入大三周不同。故上根执一理情多。理名近大。故闻无三而顺一理。所以前悟。教惑理者三闻方知一理无差。所以因斯成下根悟。中根二情力等故悟居中。今谓下破。先总破彼理教互惑而为三根。若以互惑为三根者。不可未闻三周预生回惑。次三人下具破二意。一者大小永不相关。二破在小不应惑大。此别破二意。初中又二。先且定之故云何等。若回遑下正破又二。先约小破。疑属见惑初果尚非。何得互疑名三根耶。次若回遑大乘者下约大破也。大小既别。安得于大理教互疑。次意者用今经意。若大小理教更互惑者。汝于何处闻斥三耶。方等虽斥般若虽加。并未曾云三是方便。故知尔前大小未惑。岂出入观三一踟蹰。既预下纵难尔前已曾理教回惑。当知已曾动执生疑。若已生疑略开三时已应领解。何得闻略。仍云四众咸皆有疑。言今日者闻略开时。进退下结非。次今明下正释。先判正意。次约四句以判三根。三约三品以明入住。初文者。先总明根惑并异于他。小乘根定回惑又除。安得还就小乘辩惑。他纵以小而惑于大。他又不立别惑之名。故小回惑不成厚薄

问。诸声闻人尔前无断别惑之文。何故今约以论厚薄

答。显教虽无准理合有。故被洮汰义当断伏。由根不等断伏亦殊。致有三根前后不一。次约四句中先列。次以四句别对四人。根惑并由过去熏习。致令悟有三周不同。所以三判者初释收机令尽。故第四句摄结缘众。后两释不定者。三根已定但句法至四。将四判三故从容进退。第二释中应以中间二句为中。文云为中下者。或剩下字。或下根字别为下句。三约三品惑者。又二。先释。次例。初释者。即二位皆有三重。今且明三周始入初住有三不同。惑尽不等故使尔耳。例如下以小例大。十六刹那皆名无漏。至第十五犹受向名。故三品尽方入初住。尔乃获记。第四转根不转根者。亦先述古。次若尔下破者。虽有转名闻时俱上。三根不成。若转下破转义不成。亦无三根。三周悟时俱名为上。将何以辩三周三根。余未悟者不名为转。次例意者。先立事。次难。若二俱利及利钝仍存。不名为转。身子一闻等。具如止观第六记。次夫众生下正解中。初正解。次料简。初文先引现为类。现既为缘所转。验往亦然。先世下明宿生先转三根已成。故使三根前后悟入。次譬者。刀如根木如惑。执者如机。佛令其斫。受教如闻法运斫如用观。木断如证曾磨如转遇磨不同故有利钝。此中闻悟似是信行非不兼法。由于往世信法回转相资不同。信法等相具如止观。此一坐中应无六十四番。问意者。未入住前称为三根。即此三根入住已后犹名三不。答意可见。次问意者。住前名缘初住名真。未证二住亦名缘修。住前缘修既有差降。第二住前亦差降耶。答意者。位同理同不应更别。住前未证容有不同。然圆住前亦名缘者。唯有此中及四念处。仍望别教义立其名。五明悟不悟者。初今文自立。先引经立妨。次若言下出妨。三然经下辩别。故云义未必然。故昔三根不同三周。三周三乘各三成九。今经下今家因此须辩支佛有无。先征起牒妨。已知三根遍在三乘。今经何文云支佛悟。次支佛下释妨。言中根者。依前三乘。云随根者。以声闻中亦三根故。故身子下证无别支佛。既明二乘得悟三根不同。菩萨亦应遍在三周。何者是耶。故出旧师明菩萨悟许有三根。而咸于法说。并不至于中下二周。言域怀者。域谓限域期心分齐。言近果者。彼指共位。谓离二乘即求作佛。佛果仍与二乘位同。故云近果。今闻佛果过于五百。纵有远近之疑。不同小故易悟。三根下古判三时同在法说。今明下破。初周之前指法说初及略说中。初周。三乘菩萨居首。然不并在初

若尔下引证。何得分别功德品及流通中。如妙音品等。犹有始悟无生忍者。旧云下古救意云。初周先悟已成法身。今言下重破。六百八十亿等岂可先是法身仍云得无生忍耶。无生忍后方名增道。次问者。既不许菩萨唯在初周。二乘亦应至寿量耶。答意者人不局初名不通后

问。既于三周已得无生。即是法身何以不许古师释耶

答。古师意者。元是菩萨。初周闻法得成法身。至寿量中增道损生。今云声闻至后虽通是菩萨。或有未得无生忍者。不名增道故但云无生。今师前难古人者。本是菩萨尚有至彼方得无生。如初释惟忖中。先得十住等自是一途。岂令菩萨尽先于法说得无生耶。故知二乘根性获记者。亦有至后方得无生忍。故不可一概。当知一切皆通初后。但三周后无小名耳。第六领解有无者。虽不云旧古有此计。故今引破。今明下先破缘觉。次辩菩萨。初文中四。初立理。次身子下引事。三又四众下意有。四信解下义有

法华文句记卷第四(中)法华文句记卷第四(下)

        唐天台沙门湛然述

次菩萨中二。先总述意。次又其意下别出所以。其意有三。初明无。次意或有或无。易故则无故云处处有文。准理合有故云梵文等也。三明有中。云菩萨位行等者。菩萨实位极至妙觉。仍异于别故名为深。新入实者犹非所及。故名为绝。始从权来。故名为新。昔权位下故名为小。说寿量等者。据理迹中具合有领。新小自不敢耳。故下总领颂云。佛说希有法昔所未曾闻。世尊有大力寿命不可量。无数诸佛子闻世尊分别说得法利者。乃至。或无碍乐说。余有一生在等。即是补处总为领解。八相易领故声闻领之。法身记难非浅所领。言更求何物云云者。应更责问者。汝唯知声闻别领。而不见菩萨通领耶。故此三释其义犹通。初意通指三教菩萨。通皆求佛。虽是权人执易转故。第二三意虽云处处有文。及小菩萨等。故应分别。小在三权悟大语略。故注云云良由于此。第七得记不得记者。亦是古计。先征起。次正释中缘觉如前入声闻数。故但对菩萨亦为三。初文即具用向领解有无中初意。义兼第二。若同初二即同第三。即是初文并用前三义也。有记即有领解故也。言如前云云者。一者如前领解。第二中少梵文或有。但云随要。第二意者义同前第三。但前文通今具通别。龙女别。法师通。既彰灼记。何妨领解。第三意者据近远别。近非所欣远记亦在分别功德。言寿量者。重闻于寿量故得记也。望前第三但所对别。前对小菩萨此小乘人。次问意者。何不直云过若干劫得妙觉法身。但云初住八相。此是一家教意正文。而人多不悟。答意有二。一者明须八相。二者后与法身。以后形前知是初住。且横指法身本也。故知二乘两处得益。且与八相记者。更令与物结净土因。菩萨已于多劫利物随熟随脱。不假八相浅近之记。二乘不尔。是故须之第八悟有浅深者。此无古师。于中又四。初略明所以。辨有浅深有明晦故。次初开下释浅深意。既云初闻法说已入佛慧。佛慧之语住中不专一品故也。或唯初住或二三四乃至十地。三节增进理实如然。如释惟忖中云先入今入。故今入之言该于四节。即三周寿量也。但先入者显密不同。恐不了前意故重云耳。三如听下举凡况圣举粗况细。若再闻无益初亦徒闻。四节加功理应增进。或至一生良由此也。四单复下引事。如寒得衣重重渐胜。厚薄者释单复也

问。若尔。何故前云此真位人无复浅深

答。一往同位实无浅深。细论明晦及明升入。既登后位理有增进。第九明权实得益者为六。初出旧解。言一云者。旧应多释。其一违文故且云一。次今明下正释。言邻圆者。圆谓圆满。近于满位邻妙觉也。言际极者。显邻圆耳。三所以下明得益由。国文云下引证。言化功者。影响迹时已有化益。前后增道即是深利。权人处处得益深故。五故一音下立理。不必并须待至寿量。故云一音。又密益者宜闻长远。时处不同显密各异。故注云云。六又我下正证影响得益之文。若于己无益何谓欲得。第十明待时不待时者。初正释中先大判。次若就下就三周及本。委论待等。三周之中自论密者。如法说时密闻大车及大通事而得益者。即不待时。中周密闻准说可见

问。三周及本有密说者。玄文那云法华唯显

答。言显密者。尔前遍圆互不相知。今至此经同入一圆。虽密而显纯一味故。但于一座有待不待。但知彰灼授记二乘。显露分明说长远寿。于兹一座无不闻知。故名为显

问。云非显非密者。谓决定性。于前四时既无密益。不至法华复无显得。二处无益名失时不

答。余经等者。谓前四时既云永灭。诸声闻等不知变易故。净名中迦叶自叙云。皆应号泣声震三千。于此大乘已如败种。准彼经判败种岂生。来至法华咸受佛记

若尔。佛于尔时何不即记。而使稽滞来至法华。显密不同如前已释。若将永灭权论用释开会实经。经既已生论何能灭。但以灭者于彼得闻。余经不说。况通经论。故失显密亦非失时。但弘教者曲将释此。是释者过非论咎也。五千起去等者。无四时之密益失此会之显功。此化失时彼土非冀故应失时

答云。灭后益者是也

问。经云。佛灭度后实得罗汉。容可得益。上慢不实应非此收

答。敦逼实者诚如所言。既通许遇余佛。亦何隔于上慢。如其不发待后佛时

问。佛若大慈。何不令其无谤生信

答。是盲者过非日月咎。法界众生未益者众。况此五千已蒙下种。灭后时远当当不遗。问身子初周为三根请者。此下杂料简不关十门。言为四众三根者。初周普请佛亦普说。余未悟者还为普请。既普请普说云何言佛各为说耶。此引三抑俟其三周。佛既权抑预表身子权能预谋。何以不各各请之。而三周之首通为三根。譬周之初通为中下。故诸天领解文后云。尔时舍利弗白佛言。我今无复疑悔。是诸千二百等。故知是为中根请也。乃至文云。愿为四众说其因缘。即为下根请也。答意可知。然身子设使预知在三。终须普请

若尔初周普请何故佛但作法说耶。何故譬说复更请耶。譬说已双为中下。何故复作宿世说耶

答。初周普请说亦普说。闻者未悟自在物机。中下尚昧是故重为中下普请。佛亦普为中下譬说。故千二百中四人之外属下根者。故佛鉴机不须更请。便即许云。宿世因缘吾今当说

若尔。亦未申难。若通被三根那云三抑俟其三请以表三周

答。鉴物机情理须预照。及至为说何择下中。故法说时已益中下。乃令中下再三便悟。云云者。岂有法说中下不闻岂有初请专为极利。广责旧见不晓大猷

问者。将法譬二对于宿世似如三世。若许三世当现如何。

答。中言无文者。一往语耳。如说法中当为汝说。若将昔三以望今一。则今为昔当。此约纵无方之辩以答无方之问。得作此说。若不尔者。但得依常立法譬名。既云无方触途皆转。如譬说中大车望小大亦是当。如法说中望三为昔。一亦成现。今云譬是现者。譬是现事且云现耳。准后望前者法譬在于宿世之后。故以宿世为过去也。准知法譬合同当现

问。旧以五浊障大者。旧师计也。四句料简今家破之。言如前者。指上玄文。五浊有除不除。大机有动不动。不得一向云障于大。亦可云如后。即后释五浊中。具历五味四四句是。有人下复引他解。断见惑竟有无明在。故所证真与此无明。共为大障。无明举修惑也。即不发心初果故引法华论证。言无烦恼者已断见故。有染慢者有修惑也。未知常住即是大障。若博地不执未有所证未曾断见。二痴合明无明惑强。故云独障。意云。五浊之中众生劫命不全为障。为障者见修两浊。若尔下他难也。意云。若二人无明若共若独俱能障者。此之无明若定能障即定须破。若闻法已破不妨闻法。何障之有。若未闻法无明先破。则闻法时无明已去。复不名障。此是三论师意。不问无明为障所以。直以自他等责障有无

答。至为通者。闻法故破破由闻法。言无前后者。未闻法破为前。闻法已破为后。前名自破后名他破。自他无破无因不可。次虽不前后等者。虽非自他因缘故破。以因缘故亦前亦后。亦前故暗灭。亦后故明生。今从破说故无前后。今从立说无明定障。又亦应云虽无前后闻法定破。次更料简知与不知。初引两经皆云知。何以此经三周说竟犹云不知。然虽云知文意少别。彼属方等应具二意。一者对诸菩萨。云二乘人元发大心后终归大。二以不愚等一往斥之。具如止观第三文末。彼漫引之以为难辞。云何三根之后等者。法师品后叚长行文中云。若声闻人闻是经惊疑怖畏当知是为增上慢者。此以上慢惊疑而显不知。但三根之后皆悉应知。何故犹云惊疑怖畏。初疑谓三周之初动执生疑。后悟谓三周领解解后无疑。何故此后尚自惊疑。答中二意。初通明知。次凡有下分门别释。初文意者。此经亦云知者。责于问者何以专引不知之文。故此经与记处处云知。次引今文正答云知。三根之后有不知者敦逼之辞。诸不愚等来至法华皆悉已知。假使更有不知之人判成上慢。既非上慢道理皆知灭想尚知何况余耶。次分门释者。初明知者。声闻于彼亦不云知。佛于彼经为诸菩萨说其元意。故云知耳。此即答前两经之问。昔曾发大故云前知。中间退大次明不知。今至法华被会方知。若佛在世三根得记。佛灭度后无不知者。又身子下重引此经以证不知。初句是身子叙千二百不知。我今下法说之初自叙不知。此是三周之前不知之文。非关三周后也。又大通下此当三周之后亦有不知之文。何者。既云说是经时。十六沙弥皆悉信受。声闻众中亦有信解。其余众生千万亿众皆生疑惑。即是彼佛在世亦有不知之人。然亦不得云永不知。即是王子为其覆讲。此十六子义当余佛。佛虽在世四依弘经理亦不失。当知且对闻佛说时。云不知耳。若执下次为和会。于中先总非。次正会。初不许偏执者。如前二文。或初后知而中间不知。或初不知后必得知。生灭度想尚于彼知。况在佛世暂时不知。安得固执而生矛盾。矛盾具如止观记。论者下抑挫凡情。恐成巨损。言余事者。修行趣果有饶益者方可论之。声闻等者且顺大经诤论之文。故大经皆云不解我意。然彼经中二十三双俱云不解者。以对昔教故责迷者二俱不解。若识化意则二俱名解。在昔须云不成执者望今成过。在今须云必成。望后逗小成过。以大小教开与不开并通三世。若唯引不成以证定性。既俱有过安偏引耶。双引各执尚违教旨。迷实执权其过非小。亡权执实斯愆犹薄。既申实教须云定成。人不见之徒援权典用证实教。今试下正存今教而为融会。先正融会。虽有二初大初为定。岂从中间取小情执小灭为规。故大教定成不须为诤。一义既尔。二十二双请为观之。若佛世尊俱留有妨之文。何成三达五眼。故依此判诤论自消。纵二十三内小部不同。灼然易殄。次若得此意下于念处中以分权实。故知但点二种初业。其滞自消。何须复以一初作妨。况若闻法华无复疑悔。知与不知二门无壅。故权实二人知不知别。有人言下引古略立利钝二人。及至解释离为四句。纯以权人示知不知。故不应理。今不取下总破。故准今意。具明权实。是故不用纯权四句。若委论者约实行对权。各为四句故注云云。文且略立。权者先知实者不知。寄小初业生灭想者。现世不知。知者现得悟者是也。即初二句也。第三句者。初不知后知。第四句者即方等中被斥者机未发故非知。以被斥故非不知。权人同实示知不知论其内心无时不知。故不用旧于义自显。更广约诸教何位何时显密权实知不知等。望旧虽尔。今家于实。秖是初则不知。后方得知。因此重料简缘觉。问可知。答中引经云从知者

问。此佛亦有闻法缘觉。何不令其闻佛说法如方等般若中二乘之人耶

答。未断惑者可令闻法。已断惑者自谓独觉。以是应知世无二佛

问。缘觉在小住亦何妨

答。元为法灭无师独悟。既有佛兴复不禀教。去则不与禀教为妨。是故不同方等元是禀教之人

问。徙向何处

答。向无佛兴处。纵在此界亦是佛教所不及处。如有德王兴岂彗星不没

若尔。其得神通岂不知耶

答。为护物机不护缘觉。知亦何爽。愿生至十四生者。以愿简其任运生数而值佛者。若愿生者生数未满若后在天愿尚牵来。具如眷属妙中。是故此人即名声闻。言十四生者。人天各七但总立七。或二十八。具如止观第六记。明极钝者至十四耳。故生未满即成无学。二三果者。如一来人及五含中后之三人。知佛出世尚有从天下来亲近佛等。若上流者纵至无色及无色般。并有起欲界化来见佛者。若不见佛亦可容得有余般时。亦名独觉。故云二果三果例然。今云例然者。以从愿故。况复二果欲人天生。愿亦易牵。变化缘觉者。义准声闻亦具四种。今文列一义已含三。所化兼二故也。许文为三。三文各二。则以三文各二字是。如初文中初是顺。次岂得下许。次文。初是诫。吾当下许。第三文。初是简。汝今下许。大经四善法者。德王品释十功德中云一者亲近善友。二者听闻正法。三者思惟其义。四者如说修行。唯此四法是涅槃因。若言苦行是涅槃因。无有是处。后之三句即三慧也。故佛诫之是涅槃近因缘也。五千在座至简众者。或当过去有谤法缘。或机未熟闻必生谤。故佛知时神力令去。又如说璎珞经时。五千菩萨尚从座起去。彼譬喻品因佛说法身功德。座中有五千菩萨从座起去。目连问佛。此诸正士修菩萨道。已入如来正法之藏。行过三乘。何故闻说三身不受而退。佛言。善男子。闻说是者沸血流面。何以故。是无数劫恒生诽谤。是辈过去恒沙佛所。修行六度起于着想。有悔心故有退转故。当更经历勤苦之难。千佛过去犹未得度。是人虽修菩萨之道。欲得成佛终不可得。如人欲于虚空造室。终不可成。今谓此乃三藏菩提之心机未合时。若闻三身理合生谤。通在衍门生谤义少。故知今人虽欲发心。不简偏圆不解誓境。未来闻法何能免谤

问。前云三止抑待三根。今何故云由五千在座

答。三请已后五千必去。秖一三止用当二义。于理无妨。有时一法当无量缘。秖此二事何足生疑。五浊障多者。五浊加多表具见修。复加执慢故根名深。障罪是根而或未深故加执慢方乃名深。枝叶细末者。若实得果如根本大材任为器用。但计枝叶谓为堪任。而轻根本。谓等谓过名增上慢。执方便之方便者。小乘四果已是方便。更于暖顶执为真极。应知上慢不全无法。但以浅位自谓增上。而慢他人名增上慢。四请者。以受旨文义当一请。并前为四。毒鼓者。大经云。譬如有人以毒涂鼓。于大众中击令出声闻者皆死。鼓者。平等法身。毒者。无缘慈悲。打者。发起众也。闻者。当机众也。死者。无明破也。今世惑破近死正当当机人也。来世惑破远死。此五千等虽非当机。如来何不强为其说作久远因。如喜根等即远益人。具如止观第八记。答中云华严末席者。此且一往寄结集说。旧经三十七云。时舍利弗祇园林出。不见如来自在庄严变化及师子吼妙功德等。不见诸大菩萨眷属。亦无智眼能见觉知及生意念。亦不乐说不能赞叹。以声闻人出三界故。此即如聋如哑之文。于彼末会即当渐初。然亦寄于娑婆一期设化渐教。以说用通今意。应知华严尽未来际。即是此经常在灵山。何殊十方更互主伴。至第三十八入佛境界品。文殊从善住阁出。与诸天龙等至如来所头面礼足。设供养已辞游南方。时舍利弗承如来力。见文殊师利从祇洹出。而作是念。今与俱行。时舍利弗有六千弟子。从自房出礼佛足已。至文殊所。此六千等皆新出家。已曾亲近过去诸佛。皆是文殊之所化度。舍利弗为诸比丘广赞文殊。文殊语诸比丘。汝等善能成就十种大心。则得佛地况菩萨地。自古共云华严时长。若尔。乃是结集后教。至般若来方可得云令诸比丘成十大心。此乃义当转教时也。结此等意入华严中。故云时长。当知以法界论之无非华严。以佛慧言之无非法华。道理虽尔。若约次第部类不便。则鹿苑诸教皆应结取。但是大小不同机见不等。故令教主说亦不一。验舍利弗已有六千弟子。故似方等般若教时。何但鹿苑耶。今文复云未破小执。即似鹿苑之始。准下释信解品中长者之文。但是机见着脱前从。今亦且寄渐教大末小初为释今诸佛至简遣者。以无密教同席益故。今欲灭化城废草庵。乃是一化之等体。此尚于小起增上慢。况能大益耶。故大此人正宜令去。若去住俱谤等者。闻略不谤闻广必谤。故云去则有益。故毒鼓二义谤及不谤。前闻略说已成不谤毒鼓之因。何须更加成谤因耶。二因无别加谤堕苦。不作谤因或于涅槃得当机益。若加谤者多失近利。故任其去以存近益。喜根慈故令远得益与其乐种。如来悲故护令不谤拔其当苦。次问可见。答中非当机等者。若唯以五千而为结缘。余当机者。则五品已上并属当机。然准望前文释四众中。当机乃在初住已上。堪为影响。则六根五品并为结缘。但是结缘义宽欲收起去之类纵以五品为当机者。此等亦得为结缘也。已如上说者如上待时中说。即如来灭后持弘经人得益故也。昔大通佛时等者。具如上文释结缘众。亦将此文而证结缘。经尔许时方乃得度。如来灭后弘经人边得当机益。犹为太近。故知彼十六子众岂无至今仍有未度者耶。不见三世久远之益而以现难。深不可也。此是大圣见机之说。灭后弘经实可为例。说大经时万五千亿人等者。师子吼菩萨言。如佛所说。一切众生能信如是大涅槃经不可思议。世尊。是大众中有八万五千亿人。于是经中不生信心。故能信者不可思议。疏文欠八字。疏意云。既云是大众中。又云不生信心。故知已为结缘众也。故五千虽去已闻略说。不久者意亦指于弘经人益。金光明等者。第七云。一者深信大乘方等。二者毁訾不生信乐。不生信乐者亦得结缘。故引为例。正广释中为二。先示广以开略。次示广列章相。初文又二。初对略开章。次上句下略示广所以。次六者下正示广相。于中又四。初列六章次生起六章。亦名章意。三于五章下示五佛有无。四又六下明六章大体。生起宛然大体随时。以此六义共成开显之大旨。言略而不阙等者。五佛互略互存无阙。诣谓所至。共成一化何假繁列。如三世佛但各二章。岂非极略故六章中开显二章略而无阙。令权诣实。而略却四章令文不繁。前后无在云云者。令说无在之意。六章之要莫若开显。前后互无在余四章。但义存六共成一意。应须具说大体以辩不次之理(云云)。今但下总佛章中所以但四无二者。四正二旁。当知五六成就三四。是故略指。又前四中三四为正。初二助成。故三世章各但三四。释迦化主五浊施三。故复加之。但阙叹法一段文耳。总而言之必须具六。为避繁文故须互指。四十余年者。菩提流支法界性论云。佛成道后四十二年说法华经。久久稀疏者。尔前非无指独显说。故曰稀疏。如华严佛慧隔小带偏。经历三昧今乃独畅。此有二意。一者久乃说之。二者是时乃说之。虽列人已堪等三意在指时故也

问。方等般若虽有带对亦说佛慧。何名稀疏

答。此约二乘钝菩萨说。初于华严而不闻。次于鹿苑而入证。后于二味而不取。今始得闻则成稀也。诸利菩萨何尝不闻。但以增进为今经益耳。若约本门非此中叹

问。若尔。华严与二酥一概佛慧。何但华严已说佛慧

答。二酥非无。但华严虽兼佛慧稍纯。从纯得名。优昙华者。新云邬昙钵罗。翻为瑞应。金轮王出大海减少。金轮路现此华乃生。作金轮王之先兆也。调熟者。亦有通别。通则二字通于二味。别则调谓调斥如方等也。熟谓成熟。即加说也。醍醐下云云者。广约三味明不说所以。如上诸文故不重列。灵下云云者。须说灵即灵通以通一切。随义便故灵寺在后。从名便故灵应在前。有此观故必获佛记。亦名为瑞。有此观故后方得果。故名为华。三观成已真因方现。三千为表实可兼之。此理下理教行人。言反乖者。以反以乖释顺释正。由昔乖反故今反乖。昔逆即顺何反乖耶。皆云至者。实之极也。若至今经无过上故。故皆云至。还指等者。释劝信意。何故劝信。欲明昔粗即妙。恐物生疑故预劝诫。言四种者。秖上所列此理已下四文是也。故客作言下不云人等。但云四种。以客作之言而含于四。故总贯之。所以昔为客作之四今成长者子四。更无所改全成妙四。故云汝等所行等。信无等者。佛世尚乃以人显法。末代安可法妙人粗。若云大权。必无以善而滥于恶。神纵异迹并越二途。世云勤学不如择师。故云汝等当信佛之所说。初明佛道至难知也者。施权意也。以诸教中无施名故。今欲明开故先叙所开。即所施是。故玄文云。为实施权意在于实。开权显实意在于权。当知以实为权权名隐实。开权显实。实外无余。潜之与显利在物情。常住本源未尝增减。故未开之前非但不说显实之名。都无施权之语。故说宜权之言。即须显实故也。故知此是法华之宗致。实教之源由。释义之旨归。众行之府藏。若不体之徒施徒运。每至此意皆勤勤者。恐斯宗学者失经旨故。所以者何下应释诸佛。云我以等者。以我释彼也。借此者。既将自权而释于彼。故借字亦子夜反。去声称之。意正引彼证此。故且以此释彼。意亦明于道同。彼此皆悉施开故也。是法等者。若结开权。是法两字指向演说诸法是也。标人法中云举无分别法者。将向是法为显实法。故云法也。唯有诸佛举人也。即是向法故云能知。除诸等者。若尔法华之外皆魔事耶。不然但前教中权魔亦说之。唯此一实魔永不测。故云除耳。故惑阿难时亦说中道。但除其魔而开其法。非五七九等者。以三五等皆是方便故皆云非。三藏三乘加人天五也。加通教二乘七也。但会二乘何二乘耶。以共二乘与婆沙中二乘永别。般若不与彼二乘共故今问之。若三藏三乘不须会者。婆沙四阶即是究竟圆常果不。若秖归此果即是大品共佛。以不为是璎珞妙觉位不。为是华严遮那果不。加通别菩萨九也。若义分行向乃成十一。此等皆是被会之异。合彼异故。故名为一。一体收异故名为大。大即今经圆妙一乘。位与华严圆位同也。仪式者。秖以开合之相为威仪法式。今开三者。开三在昔。而言今者。指今一化。从一乘开故云今耳。如释论等者。文初适云诸佛大事。今文复云何名诸佛大事等者。佛所尊重故数言之。故引为例。云云者。论更有文。亦云如王好施所生太子名数数与等。次正明显实中古以此四显实。今以开示等四并为理一。旧师所无。但说者受者并于理上立因果耳。此师于此立因果门以释开等。犹不及光宅于别序中以本迹门而释四句。别序虽序迹门仍居一部之首。岂法说初更分因果。又正是因门者。且从弟子因说。言果门者。且从师之远果。其实具有委如玄文。若尔去反征古师。本门既移来此迹门理合向前。不可本迹重张。复令本门剩长。若其双标本迹品内之义混和。岂有双标于斯至下别生缘起。况释四一不及光宅。下方等者。举本别由以责古释。塔现证前兼为起后。故宝塔踊为本远由。地踊菩萨为本近由。二由未来安得辩本。次叙光宅今亦不用下破也。初作因果相违破三慧在因故也。又三慧下但约于因以多种三慧即是纵难。纵用三慧须简三教。三教三慧尚未入于当教圣位。况圆圣位。故复纵云。若圆三慧此位亦未开佛知见。故前两教及别地前无佛知见。若作余三等者。结难也。初句结非佛知见。若作下自违命章。云云者。应须广辩不可用意。将教及理明不用意。以破地师。先述次破。初述中言第五恒等者。彼依大经第六四依品云。善男子。若有众生于一恒河沙诸如来所发菩提心。然后乃能于恶世中不谤是经爱乐是经。不能为人分别演说。二恒正解信乐受持。亦不能广说。三恒受持书写虽为他说不解深义。四恒广说。十六分中解一分义。五恒八分六恒十二分。七恒十四分。八恒十六分。具足解释尽其义趣。所谓如来常恒不变(一一句如初句)经文一恒之前。又有一熙连河未能信受。都成九段。以熙连河近俱尸城小于恒河。言发心者。有云。值一佛发一愿下一砂。纵值多佛不发愿者。亦不下砂。纵有发心不见佛者。亦不下砂。见一佛纵发多愿亦秖下一砂。一发心见多佛亦秖下一砂。如是积数至八恒等。以明入位初易后难故也。初之一增即得八分。此后但能二二增者。如至太尉易丞相则难。言十六分者。如世间秤十六两为斤。故大论中佛语鍱腹外道。汝若出家比舍利弗智。十六分中不及其一。西方校量多用此意。古人五恒判在贤位。以六七八用对初地已上至十地。以对十二十四十六分。当知古意云多发心。在方便教。实教其心无多发故。来对今教不可多发而分开等。复约贤圣立位不同

问。彼多发心皆云于涅槃经得若干分解。如何判之为方便教

答。涅槃之名既通所缘生解亦异。纵非前之两教。但成别教教道。以此而言教相难辩。况古师对位自消彼经。若见思断位不成别义。不可通位消圆开等。若同体见思尽非六地。故知现在能信如来甚深智慧甚深境界。理不容易。华严融通极顿说者尚失旨归。法华唯显一乘。不可会之成渐。又有仙慧开善治城。各有判释。皆非今意。章安云。三十心是初依五恒也。初地已去是第二依皆师位也。意以初依具烦恼性为弟子位。章安亦自约彼经判位。若判开等此亦不然。何者。令判四依须约四教。并不可以此判于开等。四依通凡开等唯圣。圣复约圆。故下结云不与经会。引经等者。大经对地前为闻见。即别教地安得证通。登地眼见即佛眼也。故六地思尽全在通教。古来但知以地释地。而全不辩地之所在。注云云者。广立理教以破古师。略如向述。难此同前者。难同光宅用三慧也。且破三慧故云同前。亦应更云。五浊先除安指今教。若今教除浊应始成声闻。若始除浊为是何佛知见显耶。秽除理显难亦如之。次有人去。两师皆以法华为入。令法华成极却失前三。佛之知见并今经。开等岂可分属余教。则成余教有佛知见。乃言别教三乘别故。即指鹿苑。二师皆以通教三乘。而为般若。言抑扬者。以净名中抑挫声闻褒扬菩萨。此甚不晓彼经亦有抑挫菩萨不独褒扬。故今家八字判尽经理。谓折小弹偏叹大褒圆。裂亦擗也。亦分帛也。四句不可分也。有人云。三十等者。通无地前三十心位。故名挟别。但云初地六地乃至十地。名为旁通。未见法华奇异者。经之难思非凡所测。准圣叹择师资可知。今依义附文略。有十双。以辩异相。与二乘近记开如来远本。随喜叹第五十人。闻益至一生补处。释迦指五逆调达为本师。文殊以八岁龙女为所化。凡闻一句咸与授记。守护经名功不可量。闻品受持永辞女质。若闻读诵不老不死。五种法师现获相似。四安乐行梦入铜轮。若恼乱者头破七分。有供养者福过十号。况已今当说一代所绝。叹其教法七喻称扬。从地涌出阿逸多不识一人。东方莲华龙尊王未知相本。况迹化举三千墨点。本成喻五百微尘。本迹事希诸教不说。如斯等文准经仍有。且依向指非奇何谓。有人引华严等者。他人意者。却责诸师。地前有四十心位。何不用释开佛知见。而但用地前三十位耶。破有二失。一者谬用华严十信。二者贤位非佛知见。言华严不明十信者。古人亦以华严住前修十梵行空。即入初住。将十梵行空对十信位。今文破者经无信名。故云无也。摄大乘等位。具知释签所引。恐是十地论剩七字。有人去。破用论四智者。彼师所引云总别一时。欲释四句令无前后。不意却成高下不当。今为二破。一者但云四智一时。而不分位别。二者四智在果开等通因。由斯不当故今不用。且准止观引论四智。以彼因果各有总别。若唯指果四智位高。今且直以果智责之。四智者。谓道慧道种慧一切智一切种智。此四在果一体具足。若开等四竖中论横。故须四位别对四智。纵因果相对各有总别。但成因果何名开等。有人言非。空等者。意以双非理显为开。不出空有。分明指理能空能有。故名为示。见此空有不离于理。方乃是悟。复了此理不二而二。方乃云入。此人下破意者。空有之言是约二谛。虽作四重秖是空有二理而已。失理浅深迷空有体。但列空有徒分四重故无中体徒用双非。不出二乘恐涉通教。有人云。达三谛等者。虽标三谛不辩融即。任运分张。别人初心何尝不达三谛之理。名达为开不名开也。至十行位分明见假。至回向位观无一异。若入初地方顺法流。如此何能免于别义。亦未能辩开等别相。非是初心毕竟不别。故非佛界。次有人去。用总别相以释知见。此人不知论云一切智。是声闻智不应以此为知。一切种智居二智后。属别佛智。不应以此为圆佛见。又古人见一切之言。便以为总。以有种言乃判为别。此亦不见大论圆文。论云。为令易解分属三人。况彼分三大小因果条然永别。如何将释圆佛知见。有人解尽智等者。尽无生名出自三藏。无生之语稍通于三。约清净之言并判属通佛。如上等者。都不见于法华大意。总如玄文。大意方了。略如今疏释方便品。至此仅知佛知见义

法华文句记卷第四(下)法华文句记卷第五(上)

        唐天台沙门湛然述

法华论云去。引论释也。论有三文。初约三乘。意令二乘与菩萨乘同得同有。于中先引论。次论言下解释论意。云次第者。与令解释次第不违。准论文意初以无上为开。论文又云。佛知见者。如来能证如实知彼义故。经文既云为令众生。若唯佛证何以乃云为令众生。故非今释义不可通。第二句示同有无上。初论文但云二乘与佛法身同等。故此释中言三乘者。不独菩萨。故以菩萨合二乘释即是三乘法身同佛。第三句者令知无上。即是悟也。第四句者证无上故。名为不退。证秖是得即入初住。论意以前三句共令得入初住位也。初开者指所知见为无上。次示此境同有次令悟同有。次令入此境故云不退。既先约二乘与菩萨同证。故知经意先在二乘。是故论文不简定性。况论云未熟即当熟也。当非不故不得云无。次约菩萨者。验知菩萨与二须会。若不须会何故别立一释同二乘耶。释初句中论无别释。今云如前者。与二乘人同得耳。钝同二乘良有以也。故知尔前非无上也。释示中云菩萨有疑令知如实。故知尔前挟疑非实。疑通会别理不应然。若不被会岂知如实。况知如实仍须修行。释悟中云未发心令发菩提心。若不发心不名菩萨。故知尔前得菩萨名未发圆心。释入中云已发心者令入法故。故未发者或指藏通。已发之言多指别教。别教知中虽似已发。不入证道故须令入。佛知见言正简于权。当知三教菩萨有疑未发。未入真常。所以论文现令菩萨开示悟入。而苦不许公违论文。第三约凡夫释中论亦不释开句。今亦指同初文。故知凡夫与三乘同。第二句虽释。其言全与初二乘中第二句同。至第三句方异前二释。故知凡夫与三乘人同。有法身佛性。故下二句凡夫与三乘别者。以外道计常故。一切众生未知菩提故。既为凡夫别一番释。故知不得深位释之故释悟句云令觉悟。入句令入菩提。当知凡夫不知不觉有无上法。亦未曾发菩提之心。而皆云与三乘同也故知三番人异义同。是故初句皆可义同。次释菩萨第二句中。云令知如实。如实秖是法身异名。此亦言异义同。第三句对二乘不知。故云令知。对菩萨已曾发心。令更发心。对凡夫令异外道。亦令外道悟故。此则义异意同。第四句中对二乘退大云不退。对菩萨已发未入故。云入法对凡夫未曾发故。直云大道。当知秖是一佛知见。为令此等人异开同。故知举三乘及以凡夫。收机罄尽。咸曰众生。凡收六界三乘对实即十法界释。若约所趣。唯一佛界即佛界释。三番义遍即约位释。佛界对九复成离合。况论释四句与今位等四释义同。论句句释者。论三释中句句别释。今于初释乃离为四。即成三番各有四释。但举二乘以例余故。亦是举难况易。二乘难故。今初释者先属对论文。初以证不退为四位释者。即论第四句。既云不退。即开示悟入皆念不退。次明佛所证得为四智释。即第一句。论云。除一切智更无余事。次以同义即第二句。论云。二乘法身平等更无差别。若无观心云何知同。次以不知究竟处者。即第三句。处是所通二乘不知。今为令知。知即是门。门为能通。故作四门释也。二乘既然菩萨凡夫例皆如此。是则三类皆须圆教。教门以为能通。入观修智方能到位。知见佛境。若作余释。为令之说徒施。佛之知见何在。故一家释义依经顺论契行得理。佛出世意岂不然乎。今释佛意宁可乖耶。若深张地位凡夫非冀。若除二障方明开者。则示等三皆在佛地。此教尚非地前之分。何益凡小者耶。言云云者。应须委明横竖释意。以申横竖用论文故。故论三释中一一竖释。今一一释中句句横竖。令论四句亦成横竖。虽有横竖意在不二。次今释下今文正释。先略对古今。次若无量下明用今意。引文释成以论废立。初意者。今古相对即略中广。初言广者。语少意含。既显实已须知诸法无不皆实。若今十妙乃名处中。但其名中而义则广。消显实文似如难用。故且和旧以存四一。即极略也。次用今意者。广则心尘行法人理无非一实。于解释门太成通漫。秖可览照故云可知。若作下述今十妙。虽不消句对义非无。故先引经对十令见

问。何故经文不依十妙。却杂乱耶

答。理智等六经已次第。但后四文虽似前后不无深致。何者。若有感应即有眷属。眷属取悟通以发之。见通获益良由说法。依玄次第自是一途。六不可越经文灼然。初云非思量等对理一者。所思故也。唯有诸佛等对智一者。能知故也。唯以等文义既具三。理须分别。文虽具三语意在于一大家事。事即因果故云义便。乃为行一。又智能照境方达境大。故大名智。以事为行。有其二意。自行化他俱名事故。今化他故是佛出世之大事也。应知初分别释用前分字解意。次逐义便用前总释。前虽二释总释易见。故今用之。次知见者下。意取经文从欲令去为位一。文中但云知见者。以经文一一句中皆云知见。即能知见已属智行。所见谛理已属理一。虽不分于知见浅深。乃以开等对位各别。故属位一。次又取结文对三法一。重取前文揽意而说。故云又也。又取诸句下出现之言。为感应一。四句皆同随义故别。无非感应。余四可知。经文等者。明废立意。虽消文不用义理非无。是故三中存而用略。从若略下欲用旧略。复论去取简义存数故也于中先简。次存。初废果立理。旧以四句同是果一。虽以果为理名不别彰故须破之而别立理故依道理无理属魔。既句句中皆云知见。故所知见岂非理一。次废因立行者。行之始终即是因果。但点行一即收二义。虽废果称乃在行终。但加理一为教等本故。使理名通开等四义顺故也。次人一下存其二也。次正释者。先明来意云且从略。对十等说故名为略。十等仍存故云且也。先释理一自为四义。今又为三。先标列。次正释。三所以下结要归宗。正释中初约四位者。即眼智所阶。于中分八以出文相。初标如文。次谛境下以所依能用显于所涉。同述来意。然此四一准下消文皆有两向。并从一边。左右互摄以别四一。故四相望尚各具四。况两向耶。何者。如所知为理则能知属智。能禀是人能诠是教。今文具二故且从理。故云理一。今显此理。理不独显以智门观三。历所涉位共方显理。乃是却将人教行三。历位取理观心人也。四门教也。四智行也。三种相由破惑入位阶于至理。若尔后三相成亦应可尔。是故今初举所依谛不能自显。智是能用。由之见理故云乃能。三二智下简能用进否。二智四眼否也。种智佛眼进也。虽体相即显胜须分。四经云下。约位引文释其所以。众生义兼佛果唯极。极果知见令物即得。故异前经。五三教下约教判意。古今诸师释佛知见。约为众生其理不显。自非今见委出妙境众生心佛一体无差。岂知众生有佛知见。故约教判其理宛然。于中先出能知见人。又分得下明众生开。局于初住方名开也。六故寄下结意。并是证佛知见位也。七如瑞下明所表。定慧之后寻雨四华。可表同归经于四位。华皆散佛至果不虚。又散大众乘位之人。八开者下正释中二。初正释。次然圆道下融通。初释开中二。初略对。次何者下正释。于中又五。初明位障。通惑谓见思。别惑谓无明。通别两惑同在一念。念体即是。是体非理。是事非是。是非一如同体为障。二惑叵分故云难可了知。次初心下明依障之位者。随喜之前初心圆信。名字位也。圆受五品位也。圆伏六根位也。将此凡心即为伏断。故云能也。伏通信受信必在初。不同世人初心即佛。三内加下明加行除障。有法譬合。由此行故得入初住。合云缘修者。即指住前

问。若入初住方名开者。当知此经凡夫绝分。何故不许他从高位。何故论文云为凡夫

答。四释之中约智约位。唯圣方开。约观约门乃通名字。况为令之语令凡入圣。结缘之益准此可知。所以四释方显今意。不妨高位不弃凡夫。四引证除位。入理之言义通深浅。从初立称故且云住。五住于下结所表以立名。次释示中三。先明破障体显。次明显体具德。三结位名。准义亦应如入十住。一者文略。二者已入无功用道。下去亦然。次释悟中四。先明障除行成。次事理下明体德遍收。三引证。四结名。次释入中五。略无障除准上合有。但连牒前文。故但云体。次自在下叹体德也。三自在流入下叹行满也。四引证。五结位。于释悟入并引摄大乘者。借别成圆。故释悟中云理量不二。释入中云理量自在。当知别中无此事也。若尔前释住中引仁王。云入理名住者。准例借别。亦可十住如理十行如量。量即理故名住。理即量故名行。融通者。为借别故。故须融通。于中为四。初正融通。即无复浅深。次但如理下明浅深所以。三引证中先引。次释。四举譬中有开有合。先开中云朔望者。朔明也。谓月初明。望谓相望。即圆满时日月相望。月非朔望寄于朔望。则有亏盈。合文可见。言云云者。须引大经月爱喻也。次约四智中初辩异者。秖是圆位能契之智。言不如者。不同也简异于遍。彼般若中通三教故。故名为通。今不依之。唯一圆道故云不如。如字平呼。次正释者。先约位中已略明行相。此中重明但直述而已。有释有结释中二。初正释。次又道慧下重以摄大乘意消之。令可见故。初文者。慧因智果各通总别。因果之上各加种者。故得别名。各加一切故受果称。初言道者。故受因称。慧之与智一往且然。若依诸经未必全尔。具如止观第三记。次此亦下结文意。亦是融通。言结意者。既属圆智故理量相即。非因果总别而因果总别。前文虽有如理等言非文正意。今释四智正应用之。但须融通耳。如彼俗境数量如于实理契之。各云如者各称境也。然一一位各具二智不二双入。且寄四位四名便故。不别而别初后理同。次约门者。门既是教理应先列。今在此者各有其意。若专释此四。则先教次观后方智位。此中释理四皆能诠。于四法中亲者先列。具如下文逆顺生起。以亲先故。故先位智次及教观。于位智中位为所涉智为能证。则所亲能疏故先位次智。于教观中非教不观。故教前观后。于中亦先正释。次融通。初云横者。初心所禀教法具四。以法相望无复优劣。故名为横。应知位智多约于竖。约观乃成非横非竖。通论并是约非横竖。以论横竖。观门亦有浅深故也。教四相望似亦浅深。于中初释。次能通下以理摄教。摄即融也。故门门中皆通智位。从浅至深以历有等。皆通于观以至于住。故门成横。虽对开等但明有等义同开等。非对深浅约位开等。又一一门中皆云一切者。本显互通互具故也。犹恐不了。故下更以理性融之。次观心释。且语大略以消开等。委论观法具如止观。观本无障不须融通。所以前之三释初不述理。故一一释文后融通。并是附理。理是文义正意故也。观亲依理。是故初论三谛之理。是为下结归也。结于三观以归开等。次所以下逆顺生起者。初明所由于能。次明能显于所。总而言之。结撮四释以归理二。既知四释并释开等。应知开等一一四重。况复四文亲疏互摄能所映显。此乃教行人三寄理以辩。理既如是余三例然。故知今家似借论文。而冥符论旨。昔方便教等者。别初地已去以分四义。即初地为开。从二至六为示七八为悟第十为入。而带地前非佛知见。故别知见不可即为众生开之。既依别义。亦可通取三贤十地次第对之。或准古师。如前诸释判八恒中后四恒是故别知见信经劫数。颇到故也。通教见地开。薄地示。离欲悟。已办入。三藏教中若约二乘准通教说。若约菩萨。则初只为开二只为示。第三为悟百劫为入。若兼圣位则以第三百劫为悟。三十四心断结为入。此之二教始终不明佛知见也。以当教不说是故云无不可将婆沙四阶般若三共璎珞次第。能消法华佛之知见。故知知见开示等名。名可通用。佛之一字唯局此经。若其欲以佛义通用。则以当教发心皆求当教佛果。故使开等亦得云佛。而须简部简教而已。释人一中言但化菩萨者。据佛意说。穷子自谓准次第论。今从开说故云人一。教行准知。行一中光宅为教一者。约今判文与光宅不同。非立名也光宅立名多同旧师。为圆故诸即是一事者。所作名诸一是所为。一秖是圆即是一家之诸诸无不一故也。亦可等者。两向释也。约教主者。诸有所作常为六字。以明说意。意在所为故云一。一家之事故云事。却指所作为事。故云教化。若就行下牒约行释。准前初意。若准前文既以智为行。至今释行应具指四智。若不尔者用是行为。教指四门此亦如是。能禀之人还修前观。下二准此。释理具列良由此也。然四句下今家一一两向释之。若论义有两向。且依今文。古亦无妨。约经文势所归须依今释。文势虽尔。若以义兼皆具四义。从但以下释教一。于中先正明教一。次自别教下明教一中所无。先示正释。次破三师。破中光宅尚亦知无四阶菩萨。但光宅指昔不明。故玄文有破。此云偏行尚该通别。但由光宅犹尚不语通乘是权。故须破之。况今复以菩萨而为第三。其第二师同于光宅。亦知废偏菩萨。但列三名望于光宅。颠倒异耳。若作下通破二师。亦但成破三藏菩萨。未涉通别故未全当。第三师同于嘉祥。嘉祥尚然。故并不知三乘共位。及璎珞等次第行者。是方便菩萨。若不尔者。何故大璎珞第九。三道品中慧品中慧眼菩萨问佛云。云何三乘。佛言。菩萨乘者。复有三种。谓菩萨大乘菩萨支佛菩萨声闻。支佛亦三。谓支佛大乘支佛支佛支佛声闻。声闻亦三。谓声闻大乘声闻支佛声闻声闻。故知菩萨三者别菩萨也。如大经中释别五味。亦寄三乘判菩萨位。支佛三者通三乘也。声闻三者三藏三乘。又第八云。慧眼菩萨曰。复有定意名无尽门。超过三乘成菩萨号。既超三乘乃是超前三种三乘。不可独云超第三乘。经又不云超二三乘。岂非圆教菩萨乘耶。若尔下破中有四。先破所存三藏菩萨。尚存三藏必存通别。次何处下破其列名。三若依下纵难。四若如下结难。今言下正释中无有余乘等者。既云无有余乘。又云若二若三。当知无余之外复无二三。言余乘者。指华严中别教乘也。既识三味鹿苑可知。即同方等所对中小。故今文中但况出鹿苑。故云况三藏三耶。若不作此释如何能显经部之妙异他经耶。他既不以教部消经。故知教部妙义难显。三世佛章各明教行者。文中各云是法皆为一佛乘故。是教一文也。是诸众生下即行一文也。后总论者。下三世佛章末总云。舍利弗是诸佛但教化菩萨人一也。欲以已下理一也。居三世后名之为总。若当章等者。众生即人一。种智所知即理一。然约种智之众生方名行一。故此各明不及下合。又诸佛章中文已具故。为避繁文。故三世中二别二含。璎珞十三九世者恐误。文在十一。彼经净居天子问佛。今有过去诸佛及十方佛。我亦不疑。云何有未来诸佛耶。佛言。汝为问过去三世。为问未来三世现在三世。天子曰。不问过现。唯问未来。佛言。有二因缘有未来佛。一者过去诸佛以慈悲心。入未来世。二者未来菩萨成佛。今文依彼佛答天子文也。皆悉当世前后相望。自有三世。故佛以三种三世。以问天子。故知即有九世义也。若华严经更加三世说平等句。合为十句

问。华严何故更说平等

答。一者华严法相至十。令数圆故。二者欲明三世难思。令理满故。故须第十。又华严明非但九世及以平等。而云十种三世。故知前九一一三世。以彼欲明九三秖是九世。九世秖是三世三世秖是刹那。刹那刹那皆尽过未。此乃长短相摄。今未论之。且约三九相望以论。为引同故。三世若同十方即同。则尘刹皆同。读者但云刹说众生说。而不思刹及众生皆为能说所被者谁。良由不思众生刹性。若得此意彼此互明。两则指上两则指下者。五佛章门皆须具六。总佛章中但有其四阙第五六。释迦章中唯阙第一。中间三世佛但各有二。两指总佛即初二意。两指释迦即后二意。然三世章显实皆云是法。及释迦章如此两字。并指权是实故名显实。何者。在昔施权尚无权名。何况有实。故今开权。权即是实。故云是法皆为佛乘。故知述其施权意在开也。过去佛章于显实中。言兼得人一者。亦应兼理。以上兼字贯之于下。以兼非正。故上文云不及总文显也。未现亦然。现在佛章从初即是开权显实。经舍利弗是诸佛下即当总文。故前料简中云。三世佛章各明教行。后总明人理。准此应先开章云先别次总。所以不先开者。下总文中既无开权之总。唯有显实一文。故对三世各有权实。总别不便故也。故合在现佛章中共成文足。故云文具也。若尔。何不秖合著现佛章中为四一文。而用为总耶。以经文初自云舍利弗是诸佛等。故知是总。经知诸众生至方便力而为说法。即感应相对也。知诸众生去感也。种种因缘去应也。经种种欲等者。但诸众生过现未来根欲性三为感佛机。经中唯有欲性二种。若有此二必有于根。故加根对释。深心所著即是根者。宿种难转随习不舍。名为所著。在方便教故习者名著。何者。根以能生为义。由过习种成于现欲。欲以取境为能以能取于五乘教故。习欲成性故性望欲性名未来。未来望今名为本性。上已说至施权者。据理先明隐实之权即是所开。既已明开即知曾施无不真实。但恐不了所施之意。故先明其意。次释五浊。故初文云秖为五浊等故。故云于一佛乘等。尚无带二等者。欲明施权先以实况。今一实中尚无般若带二方等带三。况有鹿苑单三单五。纵加人天仍属鹿苑。有人云。单五三藏单三通教。此不应理通无别部。已在般若方等中明。有疏本云。无二者。无别教及别入通之二。无三者。无通教及别圆入通之三。后文自有此释不须安此。今且依此。若无下文此释无妨。别圆入通亦在方等般若中明。秖缘彼有通别。故有相入之文。然单论之与相入不无小异。故不依之。如是者体相也者。浊体及相不可具颁。但略云如是。经虽不具疏文略述。于中先明其体。故云劫浊无别体等。还指释文共为体相。下所引文是也。云悭贪等。即见修二浊。又不善之言通于见修。唯有命浊经文不释。既有众生等三命必有故劫是长时等者。至八十也。劫者时也。诸释甚广于今非要故但略论。言短时者。如俱舍中立三极少。谓色名时。色极少者。即极微是。论云。极微微金水。兔羊牛隙尘。虮虱麦指节后后增七倍。二十四指肘。四肘为弓量。五百俱卢舍。此八緰缮那。名极少者。即一字是。论云。一字为名者为名极少。二字为名亦名名身。三字已去为多名身。四字为句四句为偈等。时极少者。即一刹那。论云。百二十刹那为怛刹那量。腊缚此六十。此三十须臾。此三十昼夜。三十昼夜月。十二月为年。众生浊至假名者。见慢是因果报是果。由见慢故招生死果。揽因成果故云揽见慢等也。果上又起见慢二浊。见慢秖是略举见修二道之体。次相中先释劫相。云四浊等者。空成坏三而无劫浊。于住劫中准悲华经八万至三万亦未有浊。至二万岁为五浊始。广明劫义浅近易知。出经论文不繁具录。仅须知耳。四浊增聚故小劫名浊。此总标也。由四浊聚小三灾起。次嗔恚下明小灾由由烦恼盛。次三灾起下明由三小故。四浊增。烦恼倍隆明由劫浊烦恼隆炽。次诸见下明由劫烦恼故。见浊炽盛。次粗弊下明由前三故。众生浊。粗弊色心恶五阴也。揽此恶阴成恶众生。众生假名也。故云恶名秽称。表质示德曰名。美响外彰曰称。今揽粗恶为质恶响外彰。是故唯表恶名秽称。摧年去由四浊故命浊。积年成寿年摧寿减。年寿相逼故曰命浊。众浊下总结。如水下举譬。由奔故昏昏秖是浊。总譬劫浊。劫浊在故余四即浊。故以风等譬余四浊。故风波等以譬见慢。鱼龙者。以譬众生。无憀赖者。众生不安正是浊相。由三浊故令命短促。如由风鼓令水奔昏。龙鱼不泰。时使之然者。重以劫浊结也。如劫初等者。更出四浊在劫浊时。亦是有浊之由虽复四浊同在浊时。四与浊时更互相浊光音等者。且寄火后。火灾但坏初禅故也故初成时此天初下。即第二禅初天故初下人间身有光明。犹能飞行。无男女根无所食啖。如是乃至林藤地肤至粳米等。男女根生。具如阿泥楼驮中说。俱舍劫章中明。地是恶缘从缘而说。故云使然。如忉利等者。亦是举例更显地生欲恶故也。帝释城外有四园苑。谓众车粗杂喜。诸天欲战从粗涩园出诸战具。须车出车苑。若欢喜园入中生喜。欲界生欲亦复如是。次烦恼去。复于总中以辩四别。先明烦恼具列五钝。各举一喻可以思知。虺蚖应用下字。挠字。说文挠扰也。嚣此非所用。应作嚚。次见浊者下释见浊。但别举二见余依大品十六知见等。二见摄诸见尽。况复十六及六十二耶。无人谓有人身见也。有道谓无道邪见也。又应反此句云。无道谓有道戒取也。所通非胜即见取也。偏执有无即边见也。十六知见具如法界次第。六十二见有三不同。若作三世五阴各计四句。谓过去如去等。现在常无常等。未来边无边等。并断常二为六十二。秖是有无二见属边见邪见所摄。若色大我小等四以四历五阴。三世六十并有无二。此但身边所摄。若本劫本见等六十二。则断常边邪戒取等摄。若作五阴各计我所。一一我所各各有三。谓璎珞僮仆窟宅等四阴十二并我十三。五阴互论即六十五。此但在我及以我所。若婆沙使揵度中历十二入十八界。一一有六十五。乃至无色亦然。无色界中但随义减色。总此诸见遍一切处及一切法。故云罗网及稠林等。次众生浊中二。释结。释中二重法譬。两法谓前明假名。次明流转。譬中二处俱譬假名。以二处法俱假名故。次命浊中三。法譬合。次第者。生起前后耳。料简中初问者今文假设。今经由浊故不得说大。且先施小即浊唯障大。若障于大说华严时。何以不障。然五浊中劫自属时。不可令佛不生减劫。若生减劫即大小不障。命随报法亦不可除。佛亦示生短寿故也。指烦恼见名未除浊。如华严中许有凡众闻华严经。是故五浊不障于大

既不障大。何不渐初即说佛乘而设小耶。而兼带耶

答。四句分别者。以根对土障俱不障。但轻重不同。以土对根利钝以成四句。初一句用答华严后一句答渐初不说大意。中间两句明土别耳。即初后俱不障大。但由利钝初后不同。根钝障重故初说小。云浊能障。故约四句皆不障大。故障大之问一往云耳

问。五浊障小不者。既不障大为障小不。前文虽云小能治浊故不障小。对向四句俱不障大。则是大小一切不障。何以五浊得名为障。故对小更问若障小者。应一切不闻。若不障者应一切俱闻。何故初转。但为五人

答。中亦开四句。至第四句方乃为障。但是对根根钝成障。旧计直云五浊并为大小障者。其理大违。故初为五人及身子等属初句也。今举央掘盘特为二句者。则一切声闻除此二例。并上根摄

问。前第四句以身子为遮重。何故此中以身子为遮轻

答。望大故重望小故轻。问自有等者。初四句答华严问。因答出身子闻法华经。后之四句唯小义当鹿苑。为欲简出诸部大乘。是故更问。两处不摄。为根利钝为障不障。答中云此就四教者。以方等般若中闻大小者是也。既其于彼不能得入。待至二酥望前为钝。但以待时名为钝耳。望前虽钝于此得入自判利钝。于四门中以后后门胜前前故。故四门中以第四门移着前者。欲对四根胜者居首。当知此中大小与前两四句中大小不殊。初四句中中间二句。别在净土今皆此土。言云云者。一一根意对一一门说其所以

问。前何故云根钝遮重不闻于小。此中乃云闻于有门

答。在前不入于今方入。大小根性熟时不同。故知不问有障无障悉皆得入。但以障之轻重用对根之利钝及时不同耳。若都不闻大小者。不问有障无障此土无机。今世未熟非四句收。四门不摄。此中正用大论二十四释十力中文。至第四力云。世尊以是智力。善知众生上中下根。若信进等五及根遮等四。论唯约小今通大乘。故知障与不障。贵在有根有乘种耳。障由破戒具如乘戒四句分别。以对五时四教三品。诸门分别注云云者。良由此也。细推之言恐遗落耳。问五浊一往等者。准初两重四句则大小俱不为障。今从大根有障初不闻法华者为问。即初四句中第四句人也。前三不障唯第四障。言非尽理故云一往。答中意者具用前文第四句意。初障重也。次若闻下根钝也。佛尚未说。旧医说于常我等名。顺其计谓无常等名。能治于浊。故唯障大而不障小。如一种机缘五浊未除不堪闻大。至鹿苑中以小治浊后方闻大。所以见若不除不堪闻常。计阴为德即四念处所治者是。騃亦痴也。故责旧医专用邪常。为不知乳。不识药也。不知病等不识病也。不知开等不知授药法也。不晓此三无客医之术。二常不同如乳好恶。见惑轻重名曰根源。先断后用故曰开遮。饵者。食也。食时异故。唯计常乐之名故云不知好恶。说我增于邪习故云不识根源。不了说常时异。故云不解开遮。故经云。若佛世尊先说常者。受化之徒。当言此法同彼外道。故云若但赞等。两医具如止观第三记

法华文句记卷第五(上)法华文句记卷第五(中)

        唐天台沙门湛然述

次约五浊论四悉中。劫命对世界者。劫命秖是依正二报即世界也。众生即是所为之人。见是能计见者。与众生同。由此二故有所为机。则见灭善生。烦恼是对治者。如五停中具治三毒。正用小乘能治浊。故属第三悉。亦准论意以第一义用对衍门。此四悉门通酬五浊障大不障小之问也。以四悉文所被多故着料简门首。从若论因果下。更以多门分别五浊。初是因果门也。二因谓烦恼及见。余三是果义兼依正。次一人下人法门。人谓众生。法即余四。与生相对故皆成法。并是生家之所计。四法下法时门。应云四法一时文阙略也。时即劫也。余四属法。若对时说生亦属法。二报障下三障门。二报者。即众生命。二烦恼者。见亦通得名烦恼故。业在其间者。烦恼润业业能招报。故云其间。众生下中论三假门。相待可知者。即劫烦恼见也。劫即长短相待。烦恼违顺等相待。见即有无等相待。若通论者。各具三假。依正二报莫不皆从三假而成。今从分别且别说也。故别对之。众生下大论三假施设门。众生和合受众生名。命等并是众生计法。又有所计假名对众生名。故云名通两处。委释具如止观第五记。烦恼下凡圣门。烦恼在凡者。谓诸凡夫定有故耳。然见必在凡烦恼通圣。如具缚圣者及罗汉向。言三通者。劫减有佛劫增唯凡。又减则有佛增通余圣。又增与减各通有无。以大小乘不同故也。岂华藏净满待劫减耶。常在灵山此之谓也。众生之名具通凡圣。命有凡圣报命不同。命短下长短门。一劫之中数数生故。故长短别。此乃约人及以欲天见佛处说。若论初禅即劫命等。二禅已去劫短命长。乃至无色准说可知。三通长短者。烦恼在凡故长。在圣故短。诸见在余凡夫故长。在利根外道故短亦可在余凡夫故短。在钝根外道故长。亦可在小故短。一生断故在大故长留惑润生入生死故。又见前尽为短烦恼后尽为长。今分别浊入生死者。不名为浊众生准说。劫但下带不带门。命是不相应行法。须带阴法论长短时。余并属法非不带时。非亲带故但在于法。劫通下内外门。大劫害器故名为外。小劫害人故名为内。或可四浊聚时时通内外。三小下害不害门。物即外器。大劫起时人已上生。随三不同生三禅处。小劫下五道三界门。准应别论三五相参。故合明之。通色如前。言命通者。亦应云余四通于三界五道。命通具如俱舍中明。五道寿别人间五十年等。亦应云通于四生。四生各有长短故也。劫是下共别门。次小劫下通别门。从八万下释大小劫。言正三毒者。他方净土如阿閦国。亦有女人无邪欲故。举一准余诸可例识。广历诸土分别不同。故注云云。敦真者。敦实得者故斥言非。上慢亦然。终无实得而不信者。嗣亦继也。身尚无量者。小乘教中不说更有界外生处。有计变易在界内者。亦名生处。大乘教中既其变易生处多故。故云无量。此述逼意。言中但云名增上慢。意指罗汉。若实得者岂有不发大心者耶。乃以大乘密而斥之。若谓究竟应变易尽。若未尽者何以不信。值遇余佛者。初文以有余土佛。名为余佛。罗汉受先世身者。酬先业故名先世身。烦恼果故。故须必灭。若烦恼所惑能不灭者。有于因果不同之过。纵云边际定力持令不灭。今问边定为大为少。若其小者小无变易之名。亦无永常之说。若言大者。大边除名唯在等觉。岂得记之后即等觉耶。若大入小定显大无定用。有引罗云等此不应尔。但佛灭后诸阿罗汉隐显不同。皆随机缘。况本大菩萨。此是大论龙树菩萨假施此问。欲准大教具委答之故也。故答文中云不生三界。况论还引法华证之。故知博地之言无教可准。余国之义出自他人。故古人云。学不师安义不中难。故此法华非兹不了。又若变易不出界者。而生五道之言。却入生死之说惊入火宅之喻。非涅槃一日之文。便为虚构。南岳下三释并是南岳释也。次释中云罗汉若修念佛三昧等者。若言念十方佛则已发大心。若唯念释尊乃因小感大。亦是机发使之然耳。然小乘之中诸部不同。亦有信有十方佛者。即小乘人修第四禅边际定力。见十方佛等。念佛观成感佛为说。第三举凡夫者举凡夫况圣耳。是故罗汉必无不闻之理。瑶师意云。实得罗汉无不信者。不须余佛遇余佛者。则指凡夫。南岳岂不知凡夫于佛灭后能生信耶。故值余佛必指罗汉。故净名云。凡夫有反复而声闻无也。故知声闻难回而须商议。凡夫易受何须引例。有人云至必然者。意破瑶师。立不信者义亦不然。执心牢固必在昔教。不应证今灭后之文。此师又引身子于法华初闻略开之文以证灭后罗汉不受之语。意云值佛罗汉尚疑是魔。况佛灭后宁肯信受。今则不然。佛预敦逼无不信者。故于灭后执经权说。义容可尔。云云者。应广明罗汉及以凡夫信不信意。以破此师及以瑶师。此直是异解等九字。恐须作白字书之。指前两师亦非全失。但未全顺经意故耳。不能全破故云异解若论瑶师见违经文。经云罗汉遇余佛生信而云不须。经意云除佛灭后者。欲显四依通经功能。而瑶不以四依。为余佛。谓罗汉三根闻与不闻。并不假从四依边闻者深不可也。又以凡夫为况者。此则可尔。但须云遇四依耳。后师意云。凡夫易罗汉难。此亦违经决了之语。故云不用此义。次释偈颂。上慢等三四众通有者。又凡夫上慢有五不同。谓四善根及以四果。通义易知且后别说从多分故。故经云比丘等四有此三失。于三别中仍从拂席者说。故云也。藏玼等者。释三失也。藏玼扬德释上慢。不能自省释我慢。无惭人者释不信。若自见过无此三失。虽未证果且名有羞。于戒等者。戒名通十即大论大经不缺不破等十。验知三失尚无不缺。况道共等。故云缺等。律仪有三。谓不缺不穿不破兼不杂。若依大论。即不缺第三。若依大经则不缺居首。名同义异各有其意。具如释义。今且依大经以不缺等三。并定共道共即六戒也。故知六中若无后二。尚名为漏。况道共定共判在三藏四果。今且近论无道定也。故三失之人尚无暖法。况有四果。瑕是玉之内病故云内起。玼是玉之外病故云外动。外病名缺内病名漏。小中小者。四果已小四禅更小智已极小。况加上慢。糟糠者。若依世禅以得无漏。如糟出酒。从文入理如糠出米。既无无漏反计世禅。如弃酒存糟。不得真理反封文字。如弃米存糠。是五千有者。以有显无有失无得。言封文者。亦应更云执禅为实。如糟无酒。文中两释初释为正。后释乃兼实行声闻。起去之徒亦于现在。未有大机是故而退。如有糟糠而无酒米。枝叶者无入道材

问。机器何别

答。虽并从譬各有一意。机论可发器语堪任。得人天身通名为器。由怀三失故器成非。宿种又微无机可发。二义俱阙佛威令去。凡有三异者。先列。次释。初云上有叹法希有者。上诸佛章六段之中但无后二故有叹法文云。如是妙法诸佛如来时乃说之。而无五浊之文。颂中无叹法也。先后者。上先叹法如向所引。言不虚者。次文方云。汝等当信佛之所说言不虚妄。及以开显。上劝信与不虚合者。上云。汝等当信佛之所说言不虚也。今隔不虚者今颂中劝信在前不虚在后。中隔五浊文也。故前四今五由离劝信为二故也。应云劝信不虚中为五浊所隔。章安更云。上以释迦方便用释诸佛施权者。上释诸佛开权文云。我以无数方便种种因缘譬喻言辞。演说诸法。偈中如文。修道得于诸权法者。自行因满所感权法。正当自行体内权也。即此法体亦不可说。以方便故为众生说成化他权。即照九界已下文是。故知立一开权之言。于今乃成二意。一者腾昔施权。二为显实之所。不指所开无由说实。况指权是权知非究竟。既显实已权全是实。照九界机说七方便者。九是所被教不出七。说七被九渐令入实。人法七九故立总言。九界从自分立名。方便从进趣为称。又九界从物机立名。方便从化主受称。总举不同故云七九。言不可定判者。七九之中随何等机。闻何等法遇机便逗。故云不定。现起等者。念必对境故云现起。种种之言不出七九。过去下释欲性也。欲秖是念。故知秖是先以希望释念。次以欣乐释欲。故知念则且语内心。欲论对境生想。今但约慕乐通从欲为名。不假对念辩别。故但以欲对性二世判之

问。前云过去名根未来名性。今何故云过去名性

答。各有其意。性必不改故从现至未从过至今。二处并得性名故尔。亦可现在名根生未来故。然根性乃可互举。乐欲必居现在。欲名虽不从过亦可以现望当。以名互故故重释云。或可习欲以成性成性生习欲。上句现欲成未性下句过性成现欲。云云者。或可过欲成现性现性成未欲。或可过欲成过性现欲成未性。是则欲名虽通过未仍从现说。故知欲念之名定居现在。七方便至云云者。具如止观随自意观观恶中。云通途善恶者是。钝根下至施权意。此是长文。今不云长者。但偈与长行不同。随事要者则辩同异。或可略明意则可知。我设下三行颂理者。文多云说。如何云理。如云未曾说说时未至随顺说等。亦是以能显所。准前诸例略亦可知。今文正取佛慧为理之行。声闻兼得缘觉者。声闻数中有值佛缘觉故也。又三藏声闻必兼当教缘觉。又菩萨既兼藏通。二乘必具两教。菩萨不云别者。前以净心为别教竟。既以声闻菩萨共为义立。乃至一句皆悉成佛。又诫言无疑。当知此是极圣诚说。而不肯信。大经云。一切二乘未来必定归于大般涅槃。如流入海。又菩萨与二乘合明。当知三乘悉皆被会。牒假名三教等者。三教是假名故也。教本一实故三是假。为物假设三藏等权。今既显实重举所除以示佛慧。即上句所列者是。无二是无通教中半满相对之二者。通真含二故也。由阙别教故更引上余乘来此释成。语假则通论三教。言余及以二三。且云相入。以有余皆假故得相入无余无复相入之名。以纯一故。此指乳及二酥三味文尽。初一行半举内心。经云。如我昔所愿今者已满足者

问。佛初立誓誓度一切。今众生尚多。愿云何满

答。且从一期总而言之。但令众生得入佛乘。即名愿满。是故经云。如我无异。若我遇众生等者。明浊不障大。遇者尽令入于佛道。无智不受故云障大。众生者。文中三释。初释对他得名次释从自立称后释即是功能新译恐滥称为有情。虽简无情三义都失。十种生死短中言梵行少语者。欲界诸地法尔多语。以有言语皆由觉观。以少语故知觉观少。烦恼渐薄故云短也。方者。犹如方物动静定故。于此死已定生天上。三角者。角者聚也。即善恶无记。在生死中遍为此三。诸律论文多以聚名角。阙释紫者。即修罗也。种类多故谓天鬼畜如紫间色。又轮回者。如见实三昧经云。从地狱来声嘶匆急数数战栗。梦见大火沸镬等也。从畜来者。暗钝懈怠多食性怯。謇讷所为多似诸虫畜等。从鬼来者。发黄常饥悭贪等也。余趣比知。经具广说。我知下别明五浊。前开章云别明五浊障三。五浊望三必不能障。为三所治是所治障。故云障耳。亦是有浊故无三有三故无浊故云障耳。受胎微形。初文即约观心者。但随便耳。但云从心即名观心。其实此中仍带事释。由此一念最微心故令增长也。次受胎下全约事释。略如止观第四记引入胎经。有人具立受胎章门于此非要。今意但在显于五浊义须施权。列名而已足明浊意。何徒于此广建长章。使迷途者乃谓法华亦明五浊与婆沙不别。如世人云。法华亦明三乘其失如之。受阴身者。或恐秖是入胎经耳。总有三十八七日以论增长。若俱舍等文但列五位云。最初羯剌蓝。次生頞部昙。从此生闭尸。闭尸生羯男。次钵罗奢佉。或云下如大品中说者。即约二十身见。如去等具如前引。长时等者。今文具二义故劫得浊名。前初文中但有第二义。后料简中方有初义

过去佛章。初二行正施三也。名施为开。初一行略颂上三一。文中以教人理三兼得行者具有二意。一者通兼。既有余三岂无于行。二者别兼。即以佛道二字兼之。所趣是理能趣是行。初一行半总约五乘中。乃以人行兼教一者。既有人行必有所禀即是教也。此中以七方便为异方便者。以藏人不同衍门故成永异。余文多用。今通用者未同圆来。并名为异。若有下二行开菩萨乘中。进退两释者亦有二义。五乘之称但在鹿苑。七方便名通于三味。六度之行不局一教。故可通三。以三藏为本故云兼通别也。何者下释出三教六度行相。非相非无相次第行者。双非即是所斯故也。亦应次第出于三谛行相。然以相无相共论。即三谛也。又入地三谛无复论开。然菩萨乘中亦云于昔闻教已成教一者。若菩萨不开。何须引昔令成教一。故凡云昔者。皆具二意。一者在昔闻权。二者昔已曾开。今正语昔闻权者。昔开已竟皆成佛道。初义准化仪说。次意准开竟说。下去诸乘一一皆然。往佛亦尔。二乘文中有人理行。不云兼教者。秖是文略。前菩萨文亦以三兼一。诸佛灭后供养舍利者。若以现拟过如增一中。佛因手擎舍利广称叹已。令于四衢而起偷婆。佛言。四人应起塔。轮王罗汉支佛如来。后分云。轮王无级。罗汉四级。支佛五级。如来十三级。阿难问佛。何故尔耶。佛言轮王自行化他常住十善。罗汉不受后有。支佛无师自悟。如来众德具足。世人上未逮于初果。岂肯下等轮王。灭后起塔不知进否。动即皆至三五七九。近代所立纵云方坟。而出檐者还成一级。暗者虽昧岂非冥滥初果耶。有方坟边云作功德塔者。其义又失。使愚者唯礼我师。或复对高礼下。况复邻接尊卑不成。不便之意不可具论。纵死者冥冥。显生者碌碌。况今舍利之言局在于佛。供佛舍利福属人天。开久远因方名佛道。况今凡质生福事难。善者从之不应习俗。地师言童真地者。地立童真名者。但古人云。住为能住地为所依。故以住名而名于地。从住为名早已太远。为尚深故加之以地。故今谓下责云乖文者。文中但云童子故也。言竖狭者。横收小善竖成佛因。则横竖无违。非深非浅而深而浅。若以童真为释唯竖无横。况竖深无当弃广乖文。是知竖狭二俱有过。登地下且破唯深之失。仍略弃横之愆。今以下正释。收于童雉以显横广。指微即着以辩竖深。着在于微深即非深。微即是着浅亦非浅。指微即着缘因义成。即着之观非此可辩。下去例尔。故入地成佛如修罗渡海。此准璎珞故云入地。凡夫之人一毫之善径成佛因。如人渡大海。从佛分明下重立理以斥二失。若如下重牒失以斥失。又例上下亦名乖文。若恐童子事微不称佛道。散心一唱如何消融。合掌举手皆应理释。故知但尚佛道不识开权。殆不摄二乘者。殆几也。几近也。应云全不摄。何但几耶。若在童真尚不摄六地。况复小道。论深下结其竖狭。定广下结竖狭失。次问答。答中意言三佛性者。过去微善愿智所制。咸趣菩提。火焰向空理数咸灭。水流趣海法尔无停。但由愿智未资便封果报。故待今开方是缘因。若据化意何待此开。苟顺凡情立以近称。今开近执法界本如。岂由凡情局彼流焰。关中虽立善不受报。而不明善体本融。但众生无始唯流妄我。凡所修习未尝不俱。不受报言为从谁立。若约已发心者。乃由愿行所引。何关善不受耶。未发心来随生纳福。此善岂制令不受耶。故知不受之言善体无力。应知曾酬者其因已谢。未酬者毫善不亡。若曾发心如水寄海。酬局因者如果酬华故今于彼未酬之因。开其局情及曾趣向权乘道者。以一实观一大弘愿体之道之。若不然者徒云说开。若不观者则应善体自至菩提。何须更修菩提行愿

问。若尔。何故本论云童子戏沙等。谓发菩提心行菩萨行者。所作善根能证菩提。非诸凡夫及决定声闻未发心者之所能得

答。此乃从开说之非语本善。故知定性及现未发。纵有宿善如恒河沙。终无自成菩提之理。故云非其能得。若未开顷则往已成非。今若被开则宿作成已故。知善体本妙随执者心。是故开心宿善咸遂。次大经下释出缘因所以。三十二文具列四句。旧云阐提无者定无善性。唯有恶境界性恶五阴耳。善根人有了因性。俱有正因。俱无果性。河西云。阐提有恶阴性。善人有善阴性。俱有无记。俱无同前。兴皇三解。一约理解。理非善恶有彼二用。即指二人各有善恶一种用故。俱有俱无者。互得有无一边故也。余二解不要章安云。此释涅槃河中七种众生。应云阐提常没善人常出。俱有者。俱在河中。俱无者。俱不至岸。亦以果性为俱无也。又约三谛释。阐提唯有世谛因恶。善人唯有真谛因善。俱有世谛果身。俱无中道因果。于诸释中虽复少别。善人一句其旨大同。其不同者。今不暇释。具如止观第五记。故今引同者。证缘因善

问。上释三乘并以果成为理一句。今人天乘何以佛道而为缘因

答。所开不同。前开两教二乘及以通别菩萨。并有所证之理。故开小理以成大理。今开人天小善。已成缘因大善。且据能趣善体未深。若从所趣边说此则并有所赀。此论开权皆约案位。若从进入何独住前缘因而已。此中但从往事以说。人事既其已定不可存法去人。是故开为缘因。岂非如贫得宝。经云七宝等者。佛地论中无玟瑰。仍云琉璃与珠体别。珠即赤珠也。今兼琉璃但成七宝。离即成八。玻璃多红色。砗磲青白色。码瑙或白或青。木櫁者。字林云。香木切。韵作榓。玉篇云。其树似槐而香。有人云。斫经五年始有香气。造像为天业者。如佛升忉利以神足力制诸弟子等。具如止观第一记。若准冥祥记。此土总有一十八处造像应验。如吴中石像等。又有吴兴太守吴佩女所感像等。又如宋卫军临康王在荆州于城内筑堂三间。其壁多有画菩萨像。至衡阳文王代镇江陵。废为卧堂。悉皆泥涂干则堕落。画状新净了无污损。再涂犹然。王不信敬亦谓偶然。又更浓泥而彻见炳然。王复更毁故壁悉更缮改。后王疹疾每若闭眼辄见诸像森然满目。于是方废居此。此或是造者心重。或是毁者尤害。以轻望重以毁望成。当知散心微善不失。理无违顺心有是非。优婆塞戒经等者。此中文意正开其善不论其罪。因明用胶便释之耳。今亦因此依彼略明。故彼经广明五戒持破之相。又云。若不持戒名垢优婆塞臭优婆塞旃陀罗优婆塞。若持杀戒者乃至蚁子。若持戒酒乃至露珠。于五戒上加不沽酒。是名六重。今出家在家云持酒戒。犹以酒和食。一人凡饮几露珠耶。尚不及优婆塞戒。安能期佛道耶。于五戒上更有众多失意之罪。今文未尽。又有失意。谓不供养师僧不瞻病。空发遣乞者。不起迎逆四众长宿。见破戒者云彼不如我。六斋日不受八戒。四十里内有讲不听。受僧招提卧具床座。疑水有虫而饮。崄难独行。独宿尼寺。为财命故打拍奴婢及以外人。于路见比丘沙弥不得前行。僧中行食不得偏与本师好者。及过分与。路行见病不瞻不视。不嘱授令治。持如是戒者名净。名香名分陀利优婆塞。又制优婆塞。令种种供养三宝形像塔庙。画像不得杂乳胶鸡子。供养像时昼夜不异。不得酥油涂像身及乳洗。不得造半身像。像身不具。应密藏之。应劝人治。治已当出供养。又见毁像如全无异。以四天下宝供养。不如直以种种功德赞叹尊像。志心供养二福无别。供养法者志心信乐。受持读诵解说书写。如法而行及劝人行。种种书十二部经。供养经如供养佛。唯除洗浴名供养法。供养僧者。应当供养发菩提心。受持戒者出家之人。四向四果。名供养僧。今经小善尚为佛因。况复长时志心供养。此等虽属在家优婆塞。及有少许非文正意。然制罪令持。持即人天之善。并可开为缘因然亦并是出家行者之要。堪为常规。是故便录。今经欲收无始微善咸趣菩提。若已发心随有毫善莫非缘因。戒经立像前不得坐。云云者。更有多缘。若王难等随时斟酌。又造像功德经有十一功德。一者世世眼目清洁。二者生处无恶。三者常生贵家。四者身如紫磨金色。五者丰饶珍玩。六者生贤善家。七者生得为王。八者作金轮王。九者生梵天寿命一劫。十者不堕恶道。十一者后生还能敬重三宝。当知岂是欲界人天善根。经铅者。有云。锡也。今谓铅青锡白铅软锡坚并名青金。造像功德经云。若人临终发言造像。乃至如麦[麩-夫+廣]能除三世八十亿劫生死之罪。庙者貌也。古云支提。新云制多。翻灵庙者应作庙字。玉篇及白虎通并云尊貌所居。露盘为铜钹者。长安亦无此音。或声转耳。或是当时有人传之。章安随便书耳。经云呗者。或云呗匿。此云赞诵。西方本有。此土案梁宣验记云。陈思王。姓曹名植。字子建。魏武帝第四子。十岁善文艺。私制转七声。植曾游渔山。于岩谷间。闻诵经声。远谷流美。乃效之而制其声。如贤愚经铃声比丘缘等。音乐供养者。有出家内众音乐自随。云供养者。自思已行与何心俱。虽有此文必须裁择。梵网诚制何待固言。秖恐供养心微增己放逸。长他贪慢。敬想难成。故别译阿含第五。佛在迦兰陀城。有一妓主名曰长发。而白佛言。我昔曾于老妓人边闻如是说。于妓场上施设种种戏笑之事。令百千人而来睹者。是人命终生光音天。如是所说为虚为实。佛告之曰。止止。莫作是问。妓主复问。如是再三。佛悉不答。尔时如来语妓主言。尔时无数百千人来睹妓者。诸人本是三毒所缠。复更造作放逸之事。岂不增其贪嗔痴耶。譬如有人为毛绳所缚。以水浇之愈增其急。本为三毒所缚。更作妓乐。当增炽然三毒之火。终后生天无有是处。作是语者是邪见人。邪见之果生于地狱。佛说是时妓主悲泣。佛言。为是缘故三请不说。妓主云。我不为闻佛说故悲。但愍诸妓人长夜作如是说。有人至此引诸经。华香音乐供养者。即得不退。如不退法轮经。佛告阿难。以一华供养佛及佛塔。亦得不退。及业报差别经礼拜得至大涅槃等者。彼是已为实因者。今文开粗即实。故与今文不例。有人引大论小因大果者。不例亦尔。度我可施众生者。若论度我应在物机。施谓施设。今释迦因闻十方诸佛慰喻。乃称南谟。答于诸佛。故知释迦不请诸佛度也。五戒经至施佛者。准佛亦无惊怖之理。依下譬中长者闻已惊入火宅。法身思机义当惊怖。喜称南谟佛者。即酬顺中释南无诸佛。五戒经释归命者(云云)。那先经等者。彼经云。那先小时有故旧。为边小国王。善能问难。有多问答亦可兼释小疑。那先云。诸沙门说世间火不如地狱火热。王曰。持小石置世间火至暮不销。取大石置泥犁火中。即销者恶人死在泥犁。百千万岁何以不销。那先问。水中鱼蛟以石为食不。王言。如是。那先云。石消不。王云销。那先言。腹中子消不。王言。不销。那先言。何以不销。王言。福德使然。那先言。在地狱中恶业未尽是故不销。亦如狼食骨骨销子不销。又问。佛有相好不。答有。王言。佛父母有不。答无。王言。佛亦无人生皆似父母故。那先言。王见莲华不。答言见。又问。生淤泥不。答生淤泥。那先云。岂以莲华生淤泥似淤泥耶。佛亦如是。王又问。一人死生罽宾。一人死生泥犁。谁先到。那先言。如两鸟共飞从彼来此。一止高树一止下树。两鸟飞谁影先至地。王言。俱至地。王言。善哉善哉。余文虽非疏正意。因便知之。亦增智破邪以显念佛。胎经报恩经华林会等者。经云。第一会度九十六亿人。第二会度九十四亿人。第三会度九十二亿人。并是初教得果人也。于彼佛所至第五时亦悉被会。若例上等者。上六度文后结三教为此三句。今了因智亦复如是。皆开偏小以成于实。又双非之言始自三藏菩萨。亦异凡小。乃至别教地前并须开之。然亦须知开之所以。若心粗境妙但开其心。如以相心持法华经。若闻法华一句一偈等。若境粗心妙境已随转不须论开。若俱粗者须心境俱开。亦可但开其心境无不转。道理必须知善体性。方乃名开。总而言之心境并开尚开久远四恶粗智。况人天智。若不开之则佛之知见永埋四恶。长没人天。问答意者。开彼过去微善。正击现在执心。已为过佛之所开竟。所以于佛灭后闻一句经。云与记者举没况深。并是预开其心令成心境俱妙。若佛灭后闻是经不信者尚付后佛。法华会中为开其心。经意正云。三世皆开我岂不然。未来佛两行颂教一者。经文既云虽说及是故说。知是教一。初一行中初三句。云虽说百千亿等者指七方便一切权说。同成了因。其实为佛乘一句明说权意。诸佛下一行明说一之由。由知无性而修净缘。令得成就能演此乘。知法常无性等者。一实理上性相二空。无性性空即无四性。既云实相无自性等。故知即是理性性空。性空既尔相空准知。无性亦无即是相空。故知经中一无性言具二无性。即是无性性无相性也。本自有之。故曰常无知者照也。具如止观第五不思议境中。一念三千非自他等。既无四性。一念亦无。即是性空。既无一念。无念亦无。即是相空。即是不思议之二空也。若不了今家依于智论中论等。准理准义。缘于心性。立此二空诸无可准。非用法相者之所逮也。故于实道须闲修性。若本自二空即是性德。若推检入空即是修得。推而不成须修万行正助合行。行中具足一切诸行。方名缘因。闻斯义已方乃名开

问。世间因缘可以四句了生无生。今性本净非关缘起。何须以此四句推之

答。世缘起法亦本无生。但由情计谓之为生。理性亦尔。由谓自他等故须推之。二空不显。尚须更约续待推检。况因缘耶。自有传说此义者来。少有晓此性相三假

问。今文何故不立斯观

答。经从利根者开。佛种等者。注家云。无空有性名曰无性。堪绍继菩提名为种。如此释者此从修得。未识性种。嘉祥云无性者但云无自性。又以三义而释佛种。谓一乘教菩提心如来藏。教及发心但是种缘。虽即云藏不云空与不空及行理。故不知因中为在何因成种成性。故于正缘了中须识性种。所谓三道。次知类种即弹指等。然应知缘起通于染净。理非染净缘起宛然。此净缘起即是说由。明由净缘从因至果及不思议感应之理。故以此说为其种缘。他云。为由行者善根力故。如来识上文义相生。具如前文释闻。中破于中初云中道下立本无性为本性德。故知今种即性家之种。是故还立无性为本。为欲更明性家缘起。以种言之。种者生义。即前十界界如理性俱性并种。具如前释。迷此下双明染净二种缘起先染次净。染中由无明故为法性缘。由迷之缘而起九界。界界三千事缘起也。即是性种从迷缘故。起于众生。即是真如随于染缘。解此下明净缘起。即闻一乘教。起一乘行。行通因果能成正觉。欲起等者。成正觉已能为他说。故说一乘在教一也。即果佛种从净缘起。众生佛种从说缘起。若也通途为染净者。亦可十界展转互论。今明佛乘。须以九界皆名为染。又无性等者以缘资了正明缘了功能相成。对正虽然。若论行体。一一无不三因具足。即修得也。种果既成故云得起。一起一切起者。显果乘相。依正主伴乃至酬因一尘一行一时俱起。起者成也。如此下结果乘成相。修性一合无复分张。即是理性三因开发。通名三性。自此已去不可改故。此为销经直从开说。具明修相。委在止观十法成乘。境中具兼修性性种。正行为了。助开为缘。二十五法为前方便。辩下九法明鉴修发。教行正助所诸是理。理一即是所住法位世间相常。若不尔者。依境修习委心无地。故知修性俱有自他。先推性中无明为他。依此起行方推行他。以此两他共推一自。若推性者袪滞达理。若推修者离着行成。以性本亡泯于修始。是则两照同明双惑俱遣。如是方了染净缘起。无始无本咸归一如。且从净缘有所说边。故云教一。故五佛言殊大理不别。若不尔者。岂因缘事引四佛同。理一中云是法等者。初是法者正示理一。世人悉谓理性本净。理若本净何用修之。若本不净修亦不成。今云理净非已净也。众生下释住法位。众生正觉重出是法。法不出如皆如为位。众生理是佛已证是。故名为住。如位一故故名为位。染净之法皆名是法。染谓众生净即正觉。众生正觉是能住法。染净一如是所住位。分局定限故名为位。位无二称同立一如。不出真如故唯局此。此局即通遍一切故。局之极也。通之盛也。如世王位为人所住。位亦性也。不可改故。如人王性始终不改。布衣登极相殊性一。世间相常住者。相可表帜位可久居。众生正觉相位无二。显迷即理理即常住。佛已契常众生理是。故正觉众生相位常住。染净相位既同一。如是故相位其理须等。佛依世间修成极理。验知世间本有斯理。故云常住

问。位可一如相云何等

答。位据理性决不可改。相约随缘缘有染净。缘虽染净同名缘起。如清浊波湿性不异。同以湿性为波。故皆以如为相。同以波为湿性。故皆以如为位。所以相与常住其名虽同。染净既分如位须辩。况世间之称亦通染净因果故也。今且从悟显迷以净显染。则净悟得于常事。迷染但名常理。又世间之名通收依正。常住之称不碍二途。故云理一。若不了此徒云开权。如何显实。故今问之。被开之法唯信佛说。为亦改迷。虽复四法咸以人摄。得意忘言说不可尽。又释下单约生释世间相常。向释虽然事理通总。未的示其理境所在。故以阴入对正因说。九界阴入位本常住

法华文句记卷第五(中)法华文句记卷第五(下)

        唐天台沙门湛然述

次然此下以正阴入。对修缘了。三因六法不即不离。言正因等者。互举一边。应云阴入与性正因不即不离。复与修得缘了不即不离。正因与六法理是故不离。但理故不即。缘了与六亦复如是

问。文中何故作偏说耶

答。以易显故。正本不离今加不即。缘了不即今加不离。故须各具方名尽理。此用大经摸象之喻。喻文具如止观第三记引。言六法者五阴神我。是故此六亦名正因。同属苦故亦名缘了。兼惑业故。此中须有通别二对。别者。六中行及神我是缘因种余数及色是了因种。识是正因种。若通对者具如今文。六法性德正因与六法修得缘了。不即不离。是故修六性六一体无殊。当知阴入秖是常住。若将此文与止观中对通别者。彼对大经三德四德各有其意。道场等者。果理先成故言久畅。且望寂场四十余年为久畅耳。物情障重者。除三味中圆余皆障重。云云者。历部约味细分别之。上文有四者。准上但三。一出世意。二开权。三显实。今既云四。当知上文亦可为四。应云第四。总以人一理一。结上三世。可不如上。理合文别故今云四。又有二不同。一者上先开权次显实。今先显实次开权。二者上文实中但有教行。今此理教或理行也。不同无妨故不别云。指上本下者。下譬品文用此为本。譬必有法故云本下。文义交加者。此中指下至下指此。故云寻疏等也。章安预点使无眩乱。眩乱在钝利者何忧然诸师分譬与法参互宿世舛隔。欲为譬本取定莫从。故先叙非后方正释。初师五譬者。一长者譬即若国邑下文是。法说即指今我亦如是已下文。是二思济譬即长者作是思惟已下文是。法说即指我以佛眼观已下文是。三权诱譬即尔时长者即作是念已下文是。法说即指我始坐道场已下文是。四平等譬即尔时长者各赐已下文是。法说即指我见佛子等志求已下文是。五不虚譬即舍利弗于汝意已下文是。法说即指汝等勿有疑已下文是。若于今家初是总譬。总譬有六。岂独一长者故不用之。第二思济于今家是救子不得者。但是别譬中用大拟宜譬耳。故知但云思济其理不尽。故用大救子中三。拟宜无机息化。不应独云思济故也。第三譬去今家从我以去。于别譬中。离为六意。彼但有三。譬本不足故亦不用。瑶师尽以五佛章用为显实。言四章者。合初章在释迦章中。而以权实合为一章。以五浊章为不得说一。又以敦逼文为不得者。并不应文故不用也。而云譬中但三。则阙第三不得者者以譬中无此文。故凡者不一也。文中所列乃以开权为第一。开权即显实。应对第二等赐文也此则譬本及譬太为疏略。然长行中五佛章门诸佛犹总又阙五浊。三佛准例其文更略。释迦化主文相稍委。故但取释迦离为四章。瑶师赊漫是故不用。次畅龙二师并立六譬。其言似殊其意不别。二师并皆不立总譬。无可以对方便略颂。于别譬中文广颂略。于中六义仍先分为四。细分更多。故知二师并与譬品义不相当。以第三第四秖是今家第二寝大施小耳。又不虚文合叹法希有。而不述其意。是故不用。次光宅十譬意者。初立总譬与今文同。但下九譬望今即是广颂六义若望今文。下之九譬秖应合为四譬。于中第二四行是今见火义耳次我始下第三六行半。及第四十一行明三乘化得。是今寝大施小意耳。次我见下第五去。总有五文六行。是今显实意耳。次汝等下第十一文是今不虚文耳。今家细开稍似光宅。然与信解宿世不同。故不细开。有人去。此是他人将今家义。仍参光宅。故将此意以难光宅。等是细开何不作十九句。以光宅十譬。对今总六别四。总别各开合有十八句。加光宅一句成十九句。何者光宅第一即今家总譬。应离为六。光宅但合为一。第二见火去。今家别中离为四譬。光宅为九。一见火今离为三。光宅但一。三我始等即今文别四中第二寝大施小光宅离为二文是也。光宅第五已下至第九。总五段文今家合为一等赐譬。即别四譬中第三譬也。故光宅第五我见佛子等。及第六咸以恭敬心二文。即今文别四中第三等赐。离为四文中初文是也。第七我即已下。即今文四别譬中。第三四文中第二文是。第八于诸菩萨中下。即今文四别譬中第三四文中第三文是。第九菩萨闻是下。即今文四别譬中第三四文中第四文是。第十不虚即今文别四中第四一文。又离为三。谓叹法希有并本不虚及下立敦信文也。此乃别中离成十二。光宅更开今文四别譬中。第三四文中初文为免难索车二文。今已极细但为十八。若于别十二中第六。更开为二则有四失。良由此也。既开为二则成十三并总中六合成十九。何以不名为十九句耶。今虽十八不名十八句者。但在法譬宿世信解无此义故。欲令通有复合为五。或总别二。章段既少上下易同故今文中三种分文光宅定十无此盈缩。进不成十九退不成五。总别广略又不相当。况开大机以为两段。法中有妨故不合开。然望余师光宅最胜。若以至六义之内者。若立此六则摄十九入此六中。何以不但云为六义耶何者。依前总六却合为一。于别四中但离第二以为二段。则为五章。对前总一即成六义。若全依今文但成五义。他且依彼而为问辞。又十譬至参差等者。开为十譬。法譬二处尚自参差。况与信解等文合耶。故法说下出参差相。又光宅句数与今细开似同。而章目未稳。故亦不用。下结云四失者。一前后。二大小。三有无。四引文。今初前后不同失者。若于今别细开中。第五离为五六。并第七文为父喜者。对于法说索车父喜前后回互。言法说中索车在前者。先云舍利弗当知我见佛子等至求佛道者等。二行即索车在前。即光宅第六文是。次二行一句中最后一句。方云今我喜无畏。即父喜在后也。譬说中父喜在前者。先云尔时长者见诸子等安隐得出等。索车在后者。次文方云时诸子等各白父言等。若光宅十譬中合于五六二段。同为一索车譬本。及免难譬本不云欢喜譬本。则无此失。言虽欲会通者。纵欲曲通。云由喜故索由索故喜。亦未稳便故云迂回。又大小下于大小中复为三失。言法说中大机动者。即大小不对。今我喜无畏更进用下句云于诸菩萨中。故知此是见大机动故喜。若云见诸子等安隐得出故知是见小机免火宅难故喜。次因果不对者。法说中意云由昔不信。故云舍利弗当知乃至今我喜无畏。故知是大因。譬中云见诸子等得出火宅。故知是小果。法说中大障将倾者。尔后即云菩萨闻是法疑网皆已除。去除不远。譬说中云安隐得出。故云小果有此三失过由光宅五六七文。故作譬本未为稳便。言又有无异者。破其十中第六为下索车譬本。法说文中无索车语。至譬说中由根非利。所以方有故不得用为索车譬本况法说。中但云我见佛子等志求佛道者。非关二乘索小车也。四若引下为引文失。岂得滥用来至之言。便为小乘索车譬本。此从合为四别譬责。故别譬第三复合为一等赐文也。纵开此为四。第一名为大乘机动。为后索车譬本。但不得云索小车耳。故前约大小破中云。譬说叙小果。秖云叙小而情求于大。即名机动。故云殊不体文旨。故知其文自是大机将动。然有无者下今文自辩同异有六。初有无中云长行有真伪者。简伪敦信文也。言偈中无者。此且一往顺旧以偈末七行。为法说流通。若依今意以此七行为敦信文。则阙此有无一意。颂中有叹法者。从诸佛兴出等四难文是。长行中全无。次第中云长行先开三后显一者。长行中初云舍利弗我今亦复如是。知诸众生有种种欲等。岂非施三。次文云。如此皆为得一佛乘。即显一也。颂中初总颂中二行初行显实次行施权。故先云安隐及示佛道。次文乃云我以智慧力知众生性欲。若取别譬文。先五浊中更开为三。初能见眼亦当显实。次所见火及寝大施小皆属权也。若论别譬大意。亦先权后实。若取总颂。则前行显实次行施权。开合中云初合而不开者。若得二偈但为总譬作本。故云合而不开。若以二偈离六总亦有别。且从合说。故对下譬亦复更分。五浊文离为四譬本者。恐文误。应云三譬本。即别四譬中初文复离为三。即能见所见惊入。对下譬文仍有四也。彼以第四广明见火。合在第二文也。故知但三。次明取舍中。云四段经文为六譬本者。四段者。别四也。六譬者。离五浊为三。并下三段即是六也。叹法非六譬本者。于四别中离第四段。出叹法敦信。非下六譬本也。次总别中初开三显一者。即初二行总颂也。本迹者。且约迹中论本迹耳。即法身为本起应为迹。即此初章离为三意。能见之眼为本。第三大悲为迹。第二所见乃为诸佛垂迹之由耳。云云者。须广约迹本久近今昔体用等。以简同异。具如玄文六重本迹及前序中已略简竟。今谓下正示义宗。宗旨别故。故云正是等也。前直法说下欲破诸师立譬不能尽理。故先腾三周理同。次若作下辩古譬之失。故云若作三六十譬。于三周不合也。如前所列瑶三畅龙各六。光宅有十。然今文非不立于三六等数。但分节盈缩与他不同。言于三周不合者。法譬不合已略如上。于宿世文秖可分为二譬三譬。故多不可。言四人信解乖离者。若对信解秖可总六别四。若对他五三六及今十八。则乖张离分。具如前破光宅十譬。故破古已自立三等。今立三者如下文云。又一时三譬。若为五者。如总一别四。若为六者。如总别各六。若为十者。即总六别四。亦可为十一。即总一别十。亦可为十六。即总六别十。亦可十八。如前十八句也。但本下承上。不相应耳。若欲通于上下不差。但依三节销文。若应四处但为三譬四譬。若但在法譬。则略六广六。安隐至住处者。佛既已证。亦令众生住于此处。而今众生尚住三界不安隐处。扣佛大悲致令惊入。言种种法门即对不种种者。亦是从佛本意以说。如来本以一门利物事不获已。施种种门。施权之意本在显实。故云宣示于佛道。佛道唯实。以权对实引权入实。故云相对。相对秖是感应意耳。本末相承等者。本法说也。末譬等也。云云者。如下所引。言广颂上六义中分为四者。若于别四第四分三名为六义。若第四为一第一为三但名六譬。若言六义不应譬文。但可颂上故但云六义。若为譬本则合四五六。但为一不虚。此中有敦信。敦信即简伪。故知上文不得云无。是则别六广于总六。故今但合六义为四。若更子派开者。若欲更分。如前别中为十二句。为对上诸广文故开。为对下诸略文故合。旧以最后七行为法说流通。今文不用者。若望譬及宿世文后。虽似流通。而非流通。所以人见当来世言。言似流通。故旧例之将为得意。文意不尔。譬喻品末但为身子为三周请主。自已得悟。复为中根重请譬说。既酬请已故以此法而略付之。究而论之。但是示其信谤罪福

若尔。何不待第三周后。一时付之。譬后既付前法说后何不付之

答。至三周末自有流通广付菩萨。岂独身子。如下文中尚不偏付他方菩萨。岂独身子。法说周末身子初领。自行始成未宜利物。然大旨在佛不须苦论。用颂叹法敦信者。然上文料简有无中。云颂中无真伪者。即无敦信也。今此中用颂叹法敦信者。但是通方敦劝凡夫。使其生信。故云叹法敦信。以无专敦声闻之语。故前云无耳。今但颂数名体三也者。此中从六道已去。颂上五浊。此五即数六必五故。此贫穷等即是出体。以此五法即名浊故。亦无别名。举下证上等者。此引长者在门外文。入即起应外即法身。复云佛眼。故所见机即佛法界。若根下思无大机。方入鹿苑。鹿苑之初既云圆照乃至一乘。故知华严佛慧无别。不可于此强生分别。佛眼下云云者。应广分别此之五眼次及不次。而辩体用。故观色等用于四眼。从本为名仍名佛眼。贫穷等为众生浊者。贫故由无福。痴故由无慧。痴贫众生聚在一处。故名浊也。入生死为命浊者。于生死中又加崄道。崄道之中命易断故。即短寿处而犹相续。为命浊也。五欲为烦恼浊者。名体最显。不求大势佛等为劫浊者。劫中无佛故名为浊。四浊生此亦无所求。劫若有佛虽浊能破。入邪为见浊名体亦。显六十二多故名为诸。或云诸见是即受者。由此见故则有三受。见家之受故云见即是受。三受皆苦。以此苦受欲舍苦者。无有是处。五道源来者。五道因也。从一至一故名为趣。衰秖是贼能损耗故。毗昙地狱初生念者。一切地狱初生之时。皆有三念。知此处是地狱。由某因故生从某处而来。此文似不足义已具三。又云者。亦婆沙文也。五道各有自尔法者。具如前释不思议中。解脱达分者。涅槃名解脱。所修善根不住生死名之为达。声闻三生支佛百劫解脱之分。名解脱分。得正决定者。初果也。婆沙云。云何得禅即根本禅。云何决定即是无漏。以无漏心修诸禅定。得入初果。即此禅定而得解脱。解脱是初果即决定也。天中至所须即得云云者。应明诸天自然报相。一切依报悉是化有。及山河流出其实报得。约受报时说名为自然。地狱至中间可知者。过去人中有顺后业。其业未满。至地狱中。遇缘能起如是等心。业即成就。于地狱中无有身口现行故也。唯在轻报非无间也。广简可知故今不论。中阴倒悬者。俱舍云。天首上三横地狱头归下。此约人中天在人上。旁生及鬼同在此洲。故非上下。狱在此下故头归下。从狱生人理合首上。鬼畜亦然。天来生人其首必下。他皆例此。初将罪人至阎王所等者。有情非情并是共业所感。而为心变。初皆正语等者。初至地狱如本有语。后时但作波波等声。不复可辩。劫初时等者。诸教相中畜生能言。皆此时也。后生云祖父者。从初受名。二者后生亦是后生之祖父也。前是因缘等者。从引阿含下即观心解。前因缘中亦可具有四悉意也。五道不同即世界也。人是所为。恶是所破。天是第一义也。后似观心者。从心判义义当观心。六道不同。略如止观第二记。诸论及以小乘诸经分别甚广不要不列。我始坐等者。准下引小云疏意指华严也。故地论云。佛成道后第二七日说华严也。世讲说者嗔法华经应佛所说。或责地论失于圆宗。今问。此之二七日与法华中三七何别。纵赊促不同及所说各异。秖是机别显密有殊。说时既然身相亦尔。当知法华报佛所说。如论云。一者报佛菩提如经我成佛来等也。应佛菩提则指伽耶。古德皆云。伽耶既非彼长何独是乎。即成法佛说也。地论既云二七日。乃表应佛说之。岂报佛成及以说法必第二七耶。理而言之。彼此无别。机见不一大小分途。小见三七停留。大睹始终无改。故二七之言知非尽理。若云不起道树而游鹿苑此即迹中圆佛成相。复准部意义兼于别。小机所睹弊服宛然。今此正当小化之首。道场在摩竭提国西南。去尼连河不远。西域记云。菩提树所周匝累甎。崇峻崄固。东西长南北狭。周五百余步。正中有金刚座。此即迹中化佛之道场也。观心释树者。托事见理佛岂不然。何佛不作因缘观耶。今在小也。若约华严为最初者。皆须约于圆别以判。经行者。此亦是观解。若但事解秖是渐初。故且附观约法相说。故云道品等。事释经行具如律文威仪经等。具如止观第二记始坐等者。文具四释。初云假时等。即世界得道即为人。感恩报德即对治。欲以大拟即第一义。若作约教。应为四佛十二因缘。又以因缘释树。如婆沙中无明为根等。具如止观第二记。应细释出以对今文。即无漏与实相俱得为林。三十七品是行道法者。道品即定慧均等名行道法。况复七科皆是所行。即是以定慧足。履实相地。理摄诸法故云一切。初安此地故云得道。欲令他行先自表之。庶令下效。树地下征起未曾有经下答。经云于三七等者。且以三乘而为三根。以初成道通思根故。具如前云思度二仙文也小云疏意。众生机自未堪法华不必居后。故引后文彼佛初成即说法华。以今例之谓为有据。亦如方便品中。若但赞佛乘而众生不堪。方始允同诸佛而施权化。故云后于王城。若推下章安通释。二处不殊不可全非。故但云若推。今须辩别。何者。若以佛慧为法华。则始终俱有。若以会归为法华。则终有始无。故知彼佛在菩提树。初说佛慧为法华耳。而小云未晓斯旨。便以初成显说会归者不然。故准今意文理俱通。若密说者非所辩也。恶生王者。哥利王也。佛誓者。害佛之时佛发大愿。我若得道应先度之。甘露者真谛也。问何故初为五人等者。答中六文。问虽涉五意正问人。故皆以人答。次轮王下举三事问。答中善业轮王因。名誉业陈如因称赞业佛因。故云尼吒。有顶者非想也。为显佛声。彼无耳识非声不及。色界唯。无香味二识。余悉行故。虽有四悉意。总而言之。秖是为显宿报不同。致令声及远近不等。若依下约教。两尼吒下并注云云者。应明尼吒百亿尼吒十方尼吒及遍法界。以分四教初文藏也。百亿即是衍初通教。十方法界即是别圆。一成一切成故。十方尘刹起四威仪。互为主伴。初转法轮等四处定者声既分四。处亦应然。大神变者。非谓小小偏对一机。如化迦叶帝献方石之徒。其处必定。又除转法轮等者。渐初则定。此初化邪其处必定。通论一代故可不定。旧云思理教等者。即以三七用对大乘理教行三。并无机不受。又云劝诫者。亦此师也。即如譬及信解大乘二门各有拟宜无机息化。用对此三亦应可尔。瑶意者亦云化物之仪。思而表深。何必事深令大圣思而后行。表佛初三周说等者。此与因果经意大同。四分律萨婆多皆云六七。兴起行经等七七日。五分八七。大论五十七。地论等并二七。机见不同不须和会。今是终穷极教故且依之。观心释中。且约四观以示化仪。即四教观以最后云析法故也。诸梵虽请大者

问。如何得知梵王请大

答。据佛酬云若但赞佛乘等。今欲至始终得度者。若不先小则大小俱失。若先用小则终必大益。诸法寂灭等者

问。此中三释义有何别

答。然初一说以权实相对。即实不可说说属于权。三权是数故一实非数。次生灭不生灭相对。即不生灭不可言宣。此小衍相对也。亦是事理相对。故向三乘之言通指衍教故也。此约实理权教对辩。第三即是偏真之理。对偏四门。偏真之理亦不可宣。是则大小两理俱不可说。方便为物俱可得说。虽俱可说佛意在大。众生于实并非其宜。故思方便非生灭说。受行悟入者。机会即受。随闻观转即暖法去名之为行。若准有宗时节虽促。不妨具历内外凡位。至世第一名之为悟。若得初果名之为入。转佛等者。此有二义。若约跨节通四如来诸法具足。随扣而赴。凡有所说无非化他。对自证说。若以圆自对三教他。此即约法亦名为他。今从当分约渐初说。此佛内证故云心中。证有权实权法利物。故名为他。涅槃音者。由弟子受行烦恼断处涅槃名生。故名为音。音者声教。众教之始故云起自于此。三宝于是现世间者。亦约渐始。且在小乘未论一体。从久远劫来者。久远之言准下宿世。乃指大通之后。以小熟故。故以一文释其二疑。上文兼有其意者。三乘行人皆是佛子也。上诸佛章亦云有佛子心净等。并指昔教闻方便时。已名佛子。然于昔教未可彰言。我即下一行亦指种智等。以能显所。所即理也。更就下重分文中云。大乘机发亦名索果

问。前文何以斥光宅。云法说文中无索车耶

答。光宅若云情索于大。则为无失。若用为下索小譬本。是故须破。破其引文亦复如是。此应有四句者

问。前文已约四句对根。此中何须更说四耶

答。前初对乳酪各为四句。简其大小为障不同。复以四句释出二酥。通对诸教四根闻法。进否异同。故前初重唯第四句在法华中。余文多在前之四味。今第五时乃对开三独一为大。言即发者。但不起当座且名为即。从彼座来非不经时。但不跨味故名为即。索有三意者。二索既云在机在情。机中但云有感果义。情中既云密求而已。故前二在昔。发言唯今。昔言虽即通于四味。此指二酥并闻大时。是故得有二索之言。又二索言有通有别。通则俱通二味。机则冥在于内。情则内动于中。二味咸然故云通也。别则二索别对二味。在方等中闻不思议。虽斥为非冥有大利。被斥不谤义当于索。故知不谤理在有求。在熟酥时为大洮诱。虽无希取转教情亲。纵不彰言索义渐切。虽二不同机遥情近。得不得者。为独菩萨亦利声闻。情中进退义当于索。是则情带于机稍切于昔。故至般若别受情名。至领解时以得显失。故云欲以问世尊为失为不失。请索虽即唯在今教。及至启言机情必具。从强属口机情亦殊。在昔但潜伏居怀。于今乃助彰于口。三索咸扣于至圣。赴亦自分于显密。时熟既会内因具也。闻略说故外缘足也。因缘具故发言于兹

问。昔出宅等者。举譬品以显今。彼云诸子诣父愿赐我等三种宝车。今何得言机等索实。答意者。未出闻许出已不见所许之车。唯见许人。是故从人索昔所许。所许不与必有异途。故索昔在今。元求异意。今问鹿苑出宅唯保小果。何曾索车

答。若在法说。至鹿苑时义当出宅。复经二味二索在怀。但譬短含长义至法华之始。故譬中诸子诣父索车。乃与之仍赐于大。故彼譬意兼含二酥。信解譬长方开体命。故譬品文义含三索。当知岂与光宅为俦。咸以等者。他人意云。约机论到耻小慕大者。般若方等也。故今破之。机身俱到般若方等。况复法华三业俱领。且释请义故云机情。到必三业不可偏也。今行与等者。随便记之。且受八相故云行与。又记大唯在分别功德。此中且小故云行与。昔真等者。昔真指理昔成指果。昔罗汉等。既皆是实。并得真成。今三乘俱斥则二义并失。故云竟知何在。又三乘同学一道等者。此即重述通三乘疑。既同一理证真不殊。真虽不殊。菩萨于昔已曾得记。若已得记。何故而今并斥为方便。若俱方便昔不应别。故云何意有别。故疑今昔。若二若三若理若行。既并方便失木实证。何得不疑。前文多处通斥三教。此中但斥藏通二者。一者三乘同证真谛。二者此两教证俱权。若更约别者。当教论中自有真实。既带方便初后行殊。通皆闻斥是亦生疑。如是妙法者。具如释签中故云秖是权实法耳。次如三世者下引同中。文具两解。前约为实施权。后约开权显实。又初文约教三权一实。次又约理故有权有实为权。权实不二为实。此第二释秖是显前实教之理。即是权实不二。经云悬远等者。若准此劫六四二万。望下梵天百八十劫空无有佛。仍未为远。弥勒佛后第十五减。九百九十五佛次第出兴。应无此说。夫方便可是权假者。意明前教可是权施。据佛本怀虽非虚妄。以实望假故云权假。施已复废终归真实。今已说实故劝勿疑。旧从去更叙旧解。前虽略破非无一途。故复引之令知同异。若乐着诸欲至互简非耳者。凡小俱舍方堪授记

    释譬喻品

有人于此立来意。云大凡无譬应有譬成小。有云。佛法多门门门有譬。此则可尔。云先总者。总释两字通冠四释。若今若昔以因缘等皆有别故。品初虽兼第一周文释题且依第二周意。故云中下之流未达等也。初总为三。先字训。次释训。三来意。次释训中托此下释譬字。寄浅下释喻字。玉篇云。以类比况谓之譬。开晓令悟谓之喻。既两字双题应有小别。具如释训。故以比况晓训时众。此谓界内人中车宅。彼谓界外佛事迷悟。浅深可知。彼但佛乘深义唯一。故迷之与悟唯小对圆。树扇风月唯圆教理。前广下明来意者。亦是结前生后。初句结前。中下下生后。故知机虽无已。还待不已悲智中机当生。更动树举扇使风月意彰。然法说实相。何隐何显。如长风靡息空月常悬。但中下之徒大机未启。蔽情犹壅谓月隐风停。逗兹二途须举扇动树。因缘等四大旨咸然。故以二字总冠诸释。次别释者。初因缘中并以世四法喻一实四法。初世界中直云世法者。以世冠三故也。闻譬生喜名世界也。所以下三皆云世法。但生等别得下三名。是故下三皆由闻譬而生喜等。因于曾有世间父子。今闻譬说我佛真子。声闻与佛天性不殊。唯在今经故未曾有。所以密遣之日尚无佣作之心。领财之时岂生己物之念。特由天性相关。遂荷领知之泽。尔前忧悔至此方除。譬说之时乃名真子。今始得悟踊跃弥加。此指闻譬生于实喜。即信解初欢喜之文。故大小两乘皆名欢喜。次为人中云世生法者。即资具也。故云珍玩。出世生法即三乘法。生善中最岂过于此。故昔三车妙珍玩摄。汝等所行是菩萨道。世灭法者。宅内众灾可免离也。出世灭法者。谓惑断也。无漏述昔除忧指今。拔苦本在等与大车。除恶之极莫若于此。昔破见思通论于今。莫非除恶。世不生灭者。即大车也。父之本有故不生至处不坏故不灭。出世不生不灭者。性德本有故不生。修得果常故不灭。以信解中闻譬欢喜等。是故四悉俱譬父子。然前之三悉似寄施权。第一义悉方约开显。当知三悉即第一义之弄引也。故引先心各好及以火宅免难。若开显已无非大车。又四悉各一法一譬。法中或取法说身子领解之文。并且助成其语耳。若直销两字何足题品。故结云一音巧喻。此则遮那始终一音。一音唯实巧喻兼权。权引归实故不同旧纯用一音。故譬义含因缘等四。若不尔者。如何销于小车大车火宅父舍。中下得益者

问。下根未悟何以云益

答。法譬通被中下自迷。故下根闻法譬中根闻法说。虽未显悟非无冥益。故至譬及宿世获悟。故约教等三咸须约譬。譬既三车一车今昔相对。法亦若权若实并列偏圆。若不尔者。开何所开。本许三车索而不与。及至为说等赐大车。当知其车本为三一。为物方便权立三名。出宅废权破三唯一。四教譬中初三藏云菩萨驾牛等者。此菩萨从初至后皆化他故。最得其名。通教譬云三人同畏等者。三藏二乘理亦应尔。为对始终一向利他。是故彼二且云自济。此教缘觉自他兼益胜于声闻。故云并驰并顾。悲劣菩萨故有并言。自行故驰兼他乃顾。菩萨自行既满。唯以利物为怀。是故但云全群而出别教中初斥两教三乘俱近。次菩萨去正释。对前所列句句并决。约大象说故云边底。三大品下证。对前二教二乘简也。通教菩萨对通二乘。断证既同略无形斥。故知是别菩萨斥两二乘。故以萤对日为别作譬也。准义简譬。秖应于牛车以简菩萨。以由证经幸有三乘俱异之譬。两教三乘譬外又有独菩萨譬如大象。及以萤日用斥二乘。又始见去圆教中先指华严及为未入下明今经意。二处化事皆不须譬。即华严利根及法华上周。次如今下明二处理等。虽即化仪前后而始终理一。始即华严今谓法华。秖缘慧如是故理等。故云无二无异

问。无异无二此两何别

答。重以不异复于不二。以无异故方名不二。上根利智至不须譬者。重牒二处显上周中得悟者。为辩异故。秖为下明今有中下故须譬喻。然华严中非无譬喻。但彼入道不正由兹。如今昙华为成法说。言动执等者。上根一处。中根二处或云五处。广中有长行偈颂并法说领述二文。下根三处或云十一处于前五处更加譬中领述各有长行偈颂。乃至下根二十二番开权显实。具如化城品末列。由未悟故迷于法说权实岐道。我昔与彼同居无学。彼蒙记述我独未沾。初闻略说已怀进退。为是极果为何方便。为永在小为当成大。重闻五佛疑仍未除。故须更以车譬诱之。故云圆譬。世云天台抑华严者。乃由不善他宗故耳。既判佛慧二经不殊。但部望部不无小别。既不可指鹿苑为始。复云闻我余义不成。涉公云。法华华严广略别也。此嗅瞻卜之流芳。而未穷余香之奥旨。以不能尽思于斯宗故也。广略虽尔兼带如何。显本未彰记小非例。乃至下文十义同异。踟蹰者。犹预之象。岐道者。尔雅云。二达曰岐。本迹观心云云者。并须约譬本迹具如莲华三譬玄文第七。若欲进寄初成设教岂无一三。故千枝万叶同宗一根。乃至五百三千尘点可以意知。观心譬者。空如白牛。假如具度。中如车体。乃至幻空幻假幻中。次分文解释者。置譬且释前品之余。初领解中云置譬说之前等者。有云。为譬作序。则应难云信解药草授记。亦应安化城品内为化城作序。长行领与解至各陈者。长行三业各标释结。标结二文并具三业。而不分领解。但于释中以身业为领口意为解。初今从世尊下领也。从所以者何我昔从佛下解也。偈各陈者。三段各二。至下偈中一一点出。一幸者。谓一业遇喜。今三业俱喜乃成三幸。我今身已近佛。况更闻法。闻法即是口喜。得解即是意喜。又昔但机情。机情居内名为一幸。今由口请三业并欣。故云三喜。过意所谋故云幸也。故下文云。非先所望而今自得。抃者抚手舞也。心口之喜畅至于形。由二动形故三俱动。文云下引证者。正证三喜也。文虽且列意口二喜有二必三。理数应尔。内外异故即世界也。又此四文应约前品。而今后三约信解者。开显义同彼此通用意同时异亦应无爽。弃贫受富者。开三藏珍玩也。得真善利生善中极。忧悔双遣等者。开二味也。永除忧疑故除恶穷也。我念昔在方等时被斥故忧。至般若时住小故悔。方等被斥故疑般若不取故难。浊为外障小为内障。又被弹不受名为外障。蒙加不取名为内障。今则无此三双之失。故云大朗。住一实第一义也。次约教中初文通途简昔喜体。故先叙昔小。次今言下简异。即简无显有也。若若下正释既世间之喜久已除之。藏通二喜久已得之。若二空教道复非所拟。历三教简良有以也。非今所明故唯圆喜。湫小水也。如凡无润无出世智故也。圆教中初位次人。初住名欢喜者义立耳。既三法开发与初地不殊。亦名欢喜。身子至欢喜者。未敢定判故或二途。超入即行或向或地。设不超者。亦入初住名欢喜也。注家直云。疑虑外除喜心内发。不觉足之蹈之。故云踊跃。故须教分方辩优劣。故阿罗汉无三界喜。言踊跃者。为别惑所熏妙法外被。观心不记云云者。应云一心三观六即之喜。次释外仪中。此是经家事释可解。他纵有表但云表合不知能所。为是何智而合何理。今表异诸部文中尚略。广简如释方便品。此中亦简向佛。令知是实故也。合掌向佛何教所无。而今表唯佛果。知昔向非实今开既实向表非常。序中瑞报亦复如是。瞻仰尊颜等者。向虽合掌表不二之实。无可表于内心已解。故向而复瞻。委睹尊颜以表于解。知是佛非余如非权唯实。故知非但外仪睹佛。亦乃意无异思。表睹他实境而自开知见。意解去分于身意以对领解。既云互举二业并具领解权实故也。亦约所表以分身意。故以合掌表身瞻仰表意。昔身远佛如二掌表权。今身见佛合掌表实。故云即权而实意亦昔未解实今以念而表之。故云解实即是权。故云互举。白佛下言口领者。对彼经家。今以自陈而为口领。领必具三非独口也。故标等三各具三也。标中三者。既云白佛应唯在口。云何言三。然言领者。必先彰于口。口述所得岂专一途。是故具述所从所闻。而生欢喜三业具也。次释中先释身云。若日照高山密有闻义者

问。密通鹿苑及以二酥。何故独云高山先照

答。此对小乘显聋哑故。部唯大故显一向无。且云密耳。鹿苑有密准例可知。受记指方等者。有指阿含授弥勒记。阿含未曾明佛知见。何失之有。我尝独处思过所者。所即山林。亦应云行等思过仪也。作是念下思过心也。今思昔日处仪及心无非是失。故云思过。同入下出其过相。处等有过由计法性

问。纵使昔入小乘法性。为有何过

答。但由谓与菩萨同入。而对三教以辩己失。疑佛有偏所以成过。以由不知小法性外。别有妙理菩萨得之故也。故三藏中声闻至佛无别法性。佛印迦叶当教论同。即此义也。通教三人俱坐解脱。中论实相三乘共得。是则三乘通教法性。亦与三藏法性不殊。诸声闻人虽在力等密成通人。未合彰言云小入大。故今所论且在三藏。述初遇頞鞞及闻舅论义得法性也非关闻妙始入圆常。次由我迷权等者。述过由也。由迷权故谓法性同。何关所惑理一教三。由惑实故指权为实。何关世尊偏授菩萨。所以者何下。引待自责。次所因二义下。正释所因。初标二义。若知所证不实。则应待说实因。若知已在方便。则解即实之权。初照下释若尔。匆匆之言非但鹿苑亦指二酥。此二味中亦有初得小果故也。然依文中二酥并在两楹之间。若鹿苑初证。亦可以二酥释停。但二酥机杂故以初后释对释停。以彼乳中圆说佛因我自不对。过不属他。经言必以大乘者。语通诸教意则不然。虽但发大乘心则不死。今则简别意唯在圆。应知所因不出因果及以愿行。行即六度愿谓四弘故佛地论中通因三种。一应得因。谓菩提心。即四弘也。二加行因。谓诸波罗蜜。六亦摄诸。三圆满因。即指佛果。通取果者。果为因所期故亦名因。克体而论。唯在前二。成就菩提即是果也。从佛结身喜者。具如前释。断诸疑悔等者。通则通指二酥睹菩萨事时。别则唯在略说斥为方便时。又通言诸者。方等胜境非一。般若法相该通。凡有见闻莫非生疑之境。由境生疑由疑故悔今闻法说悔失二待。复由广说疑悔悉除。由昔绝分二义俱关。今日乃知真是等者。初约三句结成三文。文已分明上下有序。复以三成佛法有分。分即初住分真位也不须从佛口下对于三慧。文无从生三慧通漫。故云文尽理彰。此即道理之理故也。言更用四悉者。更却向前销诸领文。初标三喜为世界者。踊跃即欢喜也。所以者何下。以释身口喜文为为人者。三业相望身口且从生善说也。亦应从破恶说以为对治。不及意喜破恶义强。若尔。意喜亦是最能生善。故且一往。次我从下以释意喜为对治者。克责除疑即破恶义。次以成文为第一义者。真佛子者。由入理故成第一义也。更约喜心为四悉者。虽复标三及以三业领之与解。总而言之不出于喜。故单从喜以论四益。动悦世界也未曾有者。明所得喜即为人也。动觉观明破昔喜即对治也。动于形明别理显即第一义。云云者。令依此文释四悉相。又通论者。既悦相异常心形俱动。异常故世界。动悦故为人。除疑故对治。入理故第一义

法华文句记卷第五(下)法华文句记卷第六(上)

        唐天台沙门湛然述

次偈文者。上云偈文领解各陈。前长行中以身为领以意为解。全似各陈。而言合者。领中合解解中合领。故云合耳。今言各者。三业各有领之与解。虽似合明。但一一业中自分领解。故名各耳。略须分节后可依文。既分为三即标释结。初通标者。我闻标口欢喜标心。言兼佛者。兼从佛也。即是兼标身也。既是总标且以我闻是法音下领也。心怀大欢喜解也。次释三业。初一行半颂身领解中。初一行身领也。次半行身解也。次我处下十一行明口领解。于中又二。初九行明身远。次二行明入法性。初又二。初八行明口领。次一行明口解。以领解昔口之过。入法性中二。初一行半明口领。次半行明口解。以领解昔口之得故。次而今下九行半意领解中。初八行意领。次一行半意解。后二行半通结中。初一行半结领。次一行结解。领谓外领佛说。解即内受佛意。所以长行中合偈颂离者。共为一意故也。又总此九行半意领解文。颂上心得妙解。且依前文同以解为名。然须于中更曲细分。亦可为八。初二行领昔非实。次一行正颂闻于初周妙解。即颂方便中显实。三一行却颂上法说周初略说之时。而生疑悔。四一行颂上诸佛章门。种种领上开权。譬喻颂上昙华。五佛说下一行颂过去佛章门。六现在下一行颂现未佛章门。七如今下一行颂上释迦章门。八世尊下一行半悔过自责。验知初疑过在于我。前身领中。经云金色三十二乃至十八不共等者。并如止观第七。今文属圆比说可见。又八十种好。准大经文佛好无量。此应色中唯八十者。世间众生事八十神。故佛具之以生尊敬。今经文意总言叙昔失耳。然八十好各具四悉以利于他。不必全为八十神也。故一一好无非好海。今闻开权正领昔失。不思议好。具如下调达中。言我尝于日夜等者。若诸圣者还以昏晓而为昏夜。于此思惟。何足可述。是故此中应从所表。释有二重并约昔教。机中任运冥有此疑。未得彰灼有此说也。若生死中有即大乘意。若生死中无即小乘意。既得小已。不知此证为在何许。尝犹曾也。昔曾机中有此疑来。此乃以藏对衍而为中外。若今获悟此疑必遣。又生死下次以生死涅槃俱名为夜。得闻中理名之为日。此乃别圆以对藏通冥生疑也。后闻开显此疑方除。此于方等般若并闻故也。然疏文语少应更云中道实理为日。在昔于大闻此中理。虽对已证冥生犹预。未证此中如日仍隐适闻略开尚有此疑。况在昔居小。今闻五佛广显实权。方二疑俱遣如日出也。又世人等者。意譬声闻历诸座席。或诃或被或喜或忧。来至法华备经艰苦。自行利物无不闻知。但谓非已所任自他少别。故与诸味草创者殊。故知始自微贱具历文武。历浅阶深知物可否。如香积菩萨更学双流。故草创者少谙众行。然又两途互为胜劣。不可一向。言五味淘汰者。通指五味以为淘汰。非独般若。经云无漏难思议等者。昔谓无漏但至无余。今乃方知至实道场。解魔非魔等者。昔闻异本谓佛为魔。今方知本愚觉所误是佛。故云也。经云佛以种种缘等者。前以释迦开权释诸佛显实云。我以无数方便种种因缘譬喻言辞等。乃至三世佛章。一一皆云。亦以乃至是法皆为一佛乘故。结中云结成者。又可为二。初一行半颂结。次一行颂成。初结中三。初三句结佛音声。即口喜。次三句结意喜。还以闻佛用兼于身。故有欢喜疑除。所证所成感报作用。述成上三意者。见佛述身喜。闻法述口喜。悟解述意意。昔尚曾教大。何但今日得身近耶。虽复中迷曾闻非谬。则显今日重闻之缘。中途教小尚不为小。今还得闻信由昔教。验今意解准昔不虚。然见佛等三通有三领。言见佛缘者。由昔大见。乃为今日得实之缘。实方名见故也。言忧悔闻法缘者。自中忘来由取于小。又闻两酥至略说来。凡忧悔者皆由昔小故也。言不虚者。昔元闻大信今不虚。次引十住以释无上。次引璎珞以释道者。且借别名以显圆义。义圆名别一切皆然。他无此意不可滥用。此七无上文列两重。初重者。前一为果后六在因。于六因中初二六和。次二福智。次二证行。虽分三二。互相与力。是故六因并名无上。望果行因故果先因后。言六和者。初受持无上即身口意。以有三和故自利益彼。大乘六和摄诸法尽。二障秖是烦恼所知。此之二障。若别论者。在别地前。无知唯是界外尘沙。若通上下。无知即摄内外无知及以无明。故知但是开合异耳。行无上中秖语圣梵无余三者。天是所证。病儿果用。修二证一有斯二能。是故但二不列余三。次重者更从果立。即以六因从果立称。寻名委释以出经旨。下既结云。如是种种明无上道。故道义无量随何教成。故云今经圆无上道也。即是无上家之道。名无上道。一一无上皆具诸道之无上也。昔虽大化等者。界内无明亦未曾破故。云惑暗。若初心圆修纵未破见思。所闻一句纳种在识永劫不失。以暗望明暗尚非谬真悟宁虚。况悟真者有次有超。具如前说。故惑暗者。指六根已前。六根虽即未破无明。似位不退且名不暗。若得大解下征问。记有四意下答须记意。此之四记具在三周。中周四中但除第二意中中字。故至下周但三无四。又此四中初意具有下之三意。又初四对昔二三唯今。又初四唯自二三约他。又第三通当现。初一唯现在第二唯未来第四唯过去。嘉祥十意繁而不会。今粗点示令知繁略。一证解不虚。二令无疑悔。此二属述成何须更云记。三引物生信属今第三。四令身子慕果。此属章初叹五佛二智。为欲开权兼令慕极。今此但是授八相记。初住自得不须云慕。五为引八部故。正引同类八部乃旁。此同今文第二旁意。昔未记二乘。故二乘根性永绝斯望。而今记之。旁引八部故云须记。六为引物往生与今意同。七显经秘密。秘密属理记小属事。又记属显露不名秘密。此属昔教。八欲成大乘。此属初意。九和会大小。云如昔诃弥勒得认等。和会是开权别名。由开权故方可与记。十为引有缘。亦第三意。十意数多义少。仍阙今文第四意也。元发大心皆期记莂。故知十义繁而不足。彼疏诸文斯例甚众。余不可叙。正授记中行因等十经文各二。时节中有世有数。行因中有供佛修行。得果中有通号别号。国净中有国名国净。说法中有三乘一乘。经文虽无一乘之言。既酬愿说三说一为正。旁正兼具。劫名中有标有解。众数中有人有行。寿量中有佛寿人寿。单论成佛后寿。故除王子。补处中有依有正。法住中有正有像。于圆净中先立名其土下相也。无高下曰平不偏曰正。安隐下土用。琉璃下重明胜相。说法中准今释迦故云亦以。舍利下明说三意。土净唯一酬愿说三。即施即废

问。何处愿说

答。准大悲空藏经。于六十劫行菩萨道。因婆罗门乞眼退时。愿成佛日开三乘法

问。既得记已何故更经若干劫耶

答。若记菩萨但通途云得无生等。今记声闻须约劫国。应佛成处须有机缘。此诸声闻昔未曾有净土之行。蒙记已后与物结缘。物机不同致劫多少。龙女虽畜以乘急故。先习方便。若据权迹此复别论。又诸声闻时不同者。为逗物宜随机长短。机缘不等初住何殊。世人睹声闻受记。则嫌劫数长远。见龙女作佛。乃疑时节短促。或疑少过获罪太广。或思小善招功自多。或讥佛说回或不定。或责菩萨示迹参差。或闻胜行多劫疑教门虚构。闻诸佛神变谓世术相兼。或疑六十小劫以为半日。或迷一刹那经无量劫。如是邪言不可知数。乃由邪见种强宿熏力弱。端拱守弊空谈是非。但信教仰理何须臆度。赴缘益物非世所知。当知是人岂了初住得八相记。十方作佛种种示现。虽种种示现与法身记殊。若不为物修净土行。成佛之处为谁取土。颂中经云十力等者。即指佛果方名为力。初住分得名为功德。所言等者。非唯供佛兼净土行。或可由得十力功德分故。成初住记。若引大论菩萨有十种力分者。此明入住菩萨具足十力因耳。经云各各脱衣等者。此中通语四众八部出家二众。言上衣者。即大衣也。若论三衣俱不可舍。以西方法多但三衣。如大品中三百比丘闻般若已。皆以僧伽梨而用供养。论中或云。亡相为法。或云。当日更得。若通说之以兼俗故。或如大论经云而自回转者。表闻身子得记法性自然而转。因果依正自他悉转。经言最大法轮者。最是今经圆中开也。大是人等四种妙也。或境等十或佛等三。妙法之轮名妙法轮。此略对初后不述中间方等般若。具如玄文。华严十事名转法轮。此乃通方。又云。圆音不当大小众生自殊。此乃却贬妙法何名称叹。何谓弘经。后四行半自述者。但列三名。于中应分初一行自述。次二行半随喜。三一行回向。应须对文细述其意。五悔之中无余三者。已预记莂无罪可悔。已获分记故无劝请。已有所至略无发愿。若望极果唯除忏悔余四非无五悔具如止观第七记。如身子等者。于前四文但述三段者。法先共闻不假重述。但见身子领解等三。我今同闻亦应共得。并是权者。秖缘实行未熟权行同生。故四十余年不显真实。才闻五佛妙理豁然。即破无明寻堪与记。实病既愈权疾亦痊。岂一代化功全任实行。未愈下云云者。应广叙诸土示疾及愈

○获记下云云者。亦应腾于此及下周四段。皆约譬及因缘。后文在法师品中。云云者。宿世文后四众欢喜指法师中初段长行。初出人类中具列四众三乘人已云。如是等类咸于佛前。闻妙法华经一句一偈。一念随喜。亦当欢喜文也。今新运大悲等者。初周本为自疑。此中一向利物新运大悲。此即更须修净土行。是菩萨行之基也。准此释前意则可见。有人下古人意云。身子法譬二周之初。各有一疑故云新旧。以千二百初周未疑。故止有新。今谓等者。上根初闻略说动执生疑。蒙五佛章便获大悟。中根执重。略说之时与上同疑。法说未悟其疑犹存。岂非中根疑多于上。故身子自叙云。我今无复疑悔。是诸千二百等。述同辈有惑。云何却云身子疑多

问。凡夫亦有一听便悟。已闻略广五佛开权。及闻身子领述得记。龙鬼尚能引例。中下何顿犹迷

答。此有二义。一者久执。二者入位。解即破执执破入住。凡夫无此或当易领。声闻之人以二义故。虽闻未证。于执久中根性不同。故分三品。经闻所未闻等者。闻身子四段。昔教所无。准五佛章门我非佛知见。验昔所得知无真实。今昔真实同异不分。故云疑惑。为四众普请等者

问。前法说中亦前三后一闻既不悟。今还请于前三后一。与前何别

答。言因缘者。即是前三后一始末根由。故云因缘。四佛章略释迦稍广。虽以五浊用释于权。始末未明。故使中根于兹不晓。譬说委明轮回之相。具列三车出宅之由。兼示索三与一之意。广叙等赐等子等心。此乃方酬因缘之请。此中四众于前四中。非但当机结缘二众。发言领解即是发起影响二众。怼怨恨也。开譬者。准大经喻可云遍喻。通界内外及大小乘等。亦可云非喻。世间无此火宅始终及救火者。必以车运。先与后夺先三后一。然譬与合互有广略。若譬略合广。先摄合文来对譬竟。至合更须委悉消之。若譬广合略。世尊岂可徒施悠言。须委消譬合但略对。总譬中云一门者。上云种种对不种种。即一门也。上举所施对佛道说。佛道即是一门种种即是施权。今出所显唯云一门。亦是各出其能。以能对所其意不别。思之可见。名如宾等者。行在我已名从他传。实行则亲权行则疏。行亲名远遍于三土。行疏名近唯在同居。方便实报迭为远近。虽复亲疏更互相显名行相称他无谬传。所以行高则名远。名厚必行亲。故以处表之验名行不滥。封强等者。封谓所统之限域。强即所封之界神。小曰邦大曰国。又云。天子建国故以最远处为国。宰为宰主。有主所治为邑。邑内各居名为聚落。故邑与聚落等降渐狭。不用旧释者。唯以虚空对于三千同居之土。阙于方便实报二土。是故不用。次引论意者。泛论同异。凡云立譬取舍不同。论则因果并论今且单语果报。且譬长者果佛故也。修因之义非今所论。于极果中仍以依显正。极果说成必遍三土。土体虽即横竖相带二而不二。今从土用唯约竖论。故宽狭不等。以显居遍从本垂迹等者。今日之前从寂光本垂三土迹。至法华会摄三土迹。归寂光本。行所契理本也。名所及处迹也。理遍三土化境必周。终无行劣而名广也。即体用相称故云无宾主之异。即名行身土皆相称也。如旧所解不取二土。乃以慈悲被处为国。则令同居与邑不别。故不知慈悲所彼广狭。而为国也。则全失于实报方便。彪虎文也。炳明也。即文彩分明可畏之相。洋溢者。内满外充也。内满故行周外充故名布。三皇者。伏羲神农黄帝。五帝者。少昊颛顼高辛唐虞。彼唯刹利等二。且借此以类彼。黄者中也。帝者。德象天地。此土诸姓谁不承之。一往且以非其中途偏僻别得者。为其本裔。裔者衣末也。有本可承故也。有云。苗裔者。草之初生曰苗。即得姓之始也。承嗣不杂如苗初裔后也。左貂右插者。貂者。说文云。似鼠。徐广车服注云。即侍中冠左貂右蝉。如蝉之清高饮露不食。又云。右插者。簪也。左辅右弼。丞相也。盐梅阿衡者。释丞相也。如殷高宗聘传说。具如止观第七记。阿倚也。倚寄也衡平也。铜陵等者。如邓通汉文帝梦堕井为通所接。乃召通至。占者云。不免饿死。帝乃令人于蜀铜山铸钱供之岂饿死耶。后哀帝登位被告私铸因在囹圄饿死也。有人云。秖是文帝时为他所嫉。后遂饿死。一往且借初富为言。如晋书云。石崇有金谷在洛阳东。尔延进也。亦导也。谓威以肃物不厉而成。严洁如霜。隆高也。高而且重不令而行。智则坐计帷帐折冲万里。犹如武库何器而无。用之则行舍之则藏。白圭者。纤上玉也。说文云瑞玉也。上圆下方。白虎通云。玉之洁者也。式瞻仰也。一人者。孝经云。天子也。出世长者。十文具足。佛从下姓也。功成下位也。法财下富也。十力下威也。一心下智也。早成下耆也。三业下行也。具佛下礼也。十方下敬也。七种下归也。若以果望因应云圆教自等觉来。以其实因发心毕竟二不别故。故此十德皆从极果。若从当分果分权实。则权三实一十德名同。名下之体当教辩异。故使实际三谛不同。乃至所归多少亦别。所以长者名通今须从别。以别冠通即跨节也。观心十者。观心下姓也。三惑下位也。三谛下富也。正观下威也。中道下智也。久积下耆也。此观下行也。历缘下礼也。能如下敬也。天龙下归也。此之十德不出境智行三。虽未入位如王子胎。故名观行如来十德。若对出世还随其教观别果别。准教望观因果自分。即以三观对于四教。具览德相以叹于观。使后学者修因具足。以观十德成果十德。以能一心具照三法。即是观心十德具足。故引佛子等文以为观心之证。如止观中具成威仪等。又此十德即十法成乘。次第合之甚有深致。何者。实相即是正境故。缘理起誓故名住忍。由心安理称理含藏。除三谛惑得破遍名。中道双照无塞不通无作道品过七方便。助使三业于理无过。对境无失由依真位。信解既深故能安忍。不生法爱方感下供。三教十法展转释出。令成今经观心十法。如此十观不但横在观行位中。初心至后十观具足。故此十德义复竖深。复与横竖十乘泯合。况复十德帖经义足。分略周赡者。部分谋略故有周赡大度通见。赀者。说文云。赀财也。所以须立三长者者。长者之号本用世道。以譬出世出世之由莫不须观。故知直语出世观心。不分权教及以远本。仍是存略。此中已成因缘约教观心三释。略则十八等者。释能托之智。门虽略广不出所入之宅。言略广者。一境一空。亦可境境具一十八。故云无量。如以一色一心皆具十八。如色对根根内色外及内外俱。此空亦空故云空空。若得此意乃至无法有法准说可知。但从总说空十八有。名十八空。故云略耳。于十八中广略多少。具如止观第五记。及法界次第大论广明。若论下举福慧以释田宅。多有田宅者。一宅一门其门尚多。况家富宅广。一宅多门理合无量。门谓出宅之路。入宅路门不可一故。田谓养命之方。对命田不可狭。又复遍该权实。故曰多门。若依四观同观则车门宅门不异。僮仆至具足者。僮仆名具如止观第七记。夫僮仆者资于身命。故知并是一实定慧之余助也。所资无阙故云具足。用与权变故云和光等。穴穴者。剩也。亦位外散官也。众生居圣位之外故云穴穴。于余教观尚无所属。况复能属极圣位耶。皆宅者。宅居也。不出三界久而居之。故云宅也。世无不然。故云皆也。如来诱物统而家之。统主也。家亦居也。有人以第八识为家。等是随迷何不总八。而言第八耶。道场观意理为智通。理既是一门岂容二。出必由门故无异路。光宅以教为门。宅者。三界也。九十者。文语从略。即九十六也。九十六者。众路也。若欲出宅唯有一门。九十六道虽各谓道真。如交横驰走。故九十六道经云。唯有一道是正余者悉邪有人引多论云。六师各有十五弟子并本师六。即九十六也。准九十六道经。无此说也。彼论自是一途。岂可六师必定各秖十五弟子。九十六中有邪有正。具如止观第三记。今明去破二家也。于中为五。先破二师。若单理下先难道场。理是所通若以所为能。则能通是所更何所通。门义不成。故云何门之谓。单教下次破光宅。若不为所立能得能者。众终不至所。然理不容多。门岂唯一。今言一者。具如后释。宅既所栖唯应立一。尚云多有。况能通门。即净名中不二之门有八千也。今理教相望不可单论。次今取下定其门相。即取理家之教为门。理既是一教不容二。且总为一。秖此一句双破二家。则取所家之能。故从能有至。虽不正破道场用智。智望于教同是能取。教能既废智能亦然。但智必依教而观于境。义已兼于能所。又不可云得智者也。虽然现违经文。经云教门。而观师云理智。故亦与光宅同坏。三文云下引证。教是能诠涅槃是所。并异二师。四门又二下分别解释。释中二。先简大小虽同有能所大小天隔。是故须辩权实二能。若识二能则二所有在。若识实所权之能所俱成实能。善分判已后方论会五若宅下设难。且以今昔相待为难。宅是所出车是所入。宅门是所出之路。车门是所入之路。既二路不同出入各异。是故宅门非车门也。故今难云。若车宅门一。何故出宅仍未得车。若绝待者今应征云。若大车门非宅门者。索时亦应别有出路。何故还从所出索大。长者亦秖于此与大

又问。得宅门已未得车门。住在何处

答。大小异途。是故云别。开小即大同异如何。故今申之斥则车宅永殊。开则二门不异。宅与车一二门何殊。是故三乘具有二义。承教出宅不见小车。中间已经二味调熟。乃从父索先所许车。既索须与开彼小门无非大教。门下小理终无别途。绝理无二粗妙体一。法住法位世间相常。三界尚如何别之有。若不先异何所论同。没苦之人于今咸会。安隐对不安隐法者。如来已住安隐涅槃。对彼五浊不安之法。机感相遇故名为对。不安隐处亦复如是。墙壁譬四大者。应通三界无非减损无色虽无四大造色。定果所为皆是墙壁。三界皆以意识维持。若约诸宗。无色非全无四大色。雅合其宜。欲令下观解者。前则通于三界己他。故属于事。此观己身即观心义。有人至此。具以依正二报合喻有何不可。且如成坏各二十中。已无有情如何释浊。烧义稍隔故不用之。故今文但约三界正报因果。以正摄依其义自足。欻然等者。若唯约小乘无始相续。乃成本有。念念生灭乃是今无。今附大乘性理本无。无明故有故云本无今有。故无明之言含于粗细。今指粗是细岂可余途。然本无之言人之常说。斯为至难。故大经云。本无今有本有今无。三世有法无有是处。今虽引一句与三句相关。故须略辩识其大旨。然此一偈四处出之。古人名为涅槃四柱。亦云四出偈。故知释不当理。涅槃室倾。言四出者。谓第九十五二十五二十六。大理虽同对文小别。第九释菩萨品明差别无差别义。第十五释梵行品。明得即无得无得即得。二十五师子吼品。释有不定有无不定无。二十六破定性明无性。古来解释随情不同。成论师云。金刚心前无常。常则本有今无。无常则本无今有。又云。本有烦恼今无般若。如此有无并在于昔。故在金刚前。后三世有法无有是处。地论师云。常法体用本有今无。章安难云。本隐今显亦应显已复没。三藏云。众生无始而有终涅槃无终而有始。今难之。无始之法方乃无终。无终之法必须无始。若烦恼有终是可坏法。可坏之法义必有始。有始有终皆从缘生。何得涅槃而言有始。有始必终全同烦恼。应言烦恼无始体即菩提。是故无终。菩提无始即烦恼是。涅槃生死亦可准知。今即约大是故且云本无今有。其实本有即生死之涅槃。以从迷故而今无也。理净本无从迷今有。故云本无今有。小宗若云本无今有从缘生故。故云无明。观诸师意与涅槃理都不相当。章安五解。初约三谛。次约常无常。三约三智。四约四悉。五约四门。今文正与第二义同。本无今有常即无常。云云。单准小宗。秖应准下偈初释久故义。而云三界无始为久。非今所造称故。今开妙教须附妙宗。故释欻然云本无今有。但依章安第二释意。文义则合。故知且用无常一边。即常一边义当且覆。又他人至此广列八苦四生义章。非文正意但知而已。无此机是五百人者。诸子语通三十指别。故知前通五道。今在结缘。无此之言却指前列。是则语五百。唯有正因。论三十别在缘了。文中列者以此五百是生机处故。或小乘摄等者。值佛世不值佛世不同故耳。皆云十者。文中合说云或十二十乃至三十。意云三乘各十而已。皆云内有智性者。智必具十。望大品十一智无如实智耳。言十智者。谓世智他心智苦集灭道智法比智尽无生智。略如玄文智妙中说。广如俱舍智品中明。彼文总为六门解释。一有漏无漏。二展转相摄。三与三三昧相应。四与根相应。五明缘境多少等。如此十智三藏三乘始末俱修。故三乘人乘之出宅。非今正意。不暇广云。身受等者。倒所依也。从此下倒相也。略如止观第七文及记。准经论次立。此前须立五停心位。俱舍云。入修要二门。不净观数息。贪寻增上者如次第应修。为通治四贪且辩观骨锁。广至海复略名初习业位。除足至头半名为已熟修。系心在眉间名超作意位。所言贪者。显色形色供奉妙触。望大论六阙人相音声恣态。数息等者。阿那此云遣来。般那此云遣去。秖是息出入耳。八苦者。倒果也。大经十二云。所言苦者。逼迫为义。言逼迫者。三苦八苦。言三苦者。依三受生。苦受生苦苦生在欲界。苦等三途故云苦苦。三界已苦欲界复苦。故云苦苦。乐受生坏苦。乐坏时苦等于三途。故云坏苦。处中苦者。名为行苦通至无色。俱舍云。如以一睫毛置掌人不觉。若置眼睛上为损极不安。凡夫如手掌不觉行苦睫。故大经云。于下苦中横生乐想。别论虽尔通遍三界。各具三苦。言八苦者。即生等是。生苦有五。一生苦即初受胎时。二至终。三增长。四出胎。五种类。老有二种。念念终身。又有二种。增长灭坏。病苦者。一四大不调。即有二种。谓身病心病。死苦者。有三。一业报。二恶对。三时节代谢。复有二种。病死外缘云云。爱别离者。舍所爱故。即是坏苦。怨憎会者。即是苦心。苦心领于苦境故也。求不得者。还约爱离怨会以说。五盛阴者。经释前七是五盛阴。迦叶难言。是义不然。如佛昔说一切众生皆求于色。色若是苦不应求色。佛言。苦有三种。即三受是。虽求不得不苦如前。若知去起念处观。俱舍云。修五停已。次修念处。谓以止观自相共相修身受心法。自相别修也。一切有为皆无常相。一切有漏皆是苦相及一切法空相。除此三外自余一切皆法念处摄。一一各有三缘。谓自他俱总成十二。从粗至细。言总相者。或总二三四。此总仍别唯法念总。具如玄文四句分别。四生者。胎卵湿化。具如俱舍第八世品明。论云。于中有四生有情。谓卵等。人旁生具四。地狱及诸天。中有唯化生鬼通胎化二。即大惊怖至有苦者。长者大悲小应与其退大之心。同时而起。无乐有苦之言义兼大小。昔曾闻大义如有乐。退大流转亡其观解。慈念无乐。唯有其苦苦故宜悲。大小应法须释出之。我虽至之义者。虽出而入故成慈悲。次虽是下却释虽字。于中先通释大意。次别释所境之门。初文者。长者先已安隐得出虽安而惊。虽出须入方知如来恒住大悲。安处涅槃而不离三界。故以安隐得出释惊怖也。生见子有大志。如久已安隐由退堕苦。更起小悲如始惊怖。安隐不久故名为虽。而众生下释惊怖由。由未与父同安隐故。如来下明入火由由小悲也。子已堕苦。从子苦处以释安隐。故云不为八苦四倒等也。故佛智之言虽通本实。且分权迹而为正教。故下释门从诠小释。次经言下别明门义以释疑也。先重举经。次今问下别释。初立疑。救云下他人虽救救仍未通。恐烧教有过。乃避教烧人。人犹被烧何须是教。如门下他人立喻。今问纵使不烧。从人得名人定烧不。人若定烧何殊九十。况经云以佛教门出三界苦。人何曾烧。若尔。二俱不烧则有二失。一者俱常。此未明常。二者违经。经云所烧之门安隐得出。令无此妨。从又问下重难意者。重立烧家难也。若不许烧教应常住。今欲正解。今解去正释。有譬有合。意明小教既非色即中道法界。此教安得不名无常。然小理不灭大教抑之。小教无常义同被烧。犹如门楗。理非无常犹如门空。烧与安隐二义俱成。若依古人。人既被烧不得名为安隐得出。立门本意令其不烧。唯烧无出门义不成。大经下引证。经以十仙前因义同能诠。以因望果亦可借用。如因小证大小无无常大岂无常。若小下此更将小通对衍门。言文字即解脱等者。大小色教并皆是常。但有即不即殊。乃成烧不烧别。随宜故不即。顺理故无烧。今皆开显即烧无烧。若就下更以权实二智对释。从施权边故云权从所烧。同体之权本自常住。纵从覆说权为所烧。仍须分别。则三教权中唯三藏权生灭名烧。余二少别。故先作下引证。佛元欲用实智凡案。事不获已施于无常。无常即是所烧权智。有人云。约不信者名为所烧。佛昔从出故云安隐。虽是一途不及今文。经云。若不时出必为所焚。故得出之言非独长者。被烧之语岂唯不信。故知教法生灭名为所烧。非由众生不信故灭。宅以浊故被烧。教门何浊之有。但声教不住义同生灭生灭云烧故须分判。乐着等者。先分字释。嬉游乐也。游名遍乐。故譬见惑遍于三界。戏虽亦乐随处非遍。于三界中所系别故。又耽湎去合字解者。此两字义通名乐故。故以两字俱通见修。以着爱见俱丧道故。爱见是集集必招苦。具苦集故必无道灭

法华文句记卷第六(上)法华文句记卷第六(中)

        唐天台沙门湛然述

不觉不知下约于四谛。释此四句。但初举文。应具列四句。但是文略。于中为三。初约凡释。次约位释。三约三世。初文又三。谓标释结。初文者。都不言下标苦也。火者。三界五浊八苦也。不解火下标集也。火本能烧如集招苦。既不知下标失道也。既不畏伤故云不惊。伤即失也。不虑断下标失灭也。无道谛身慧命亦断。众生下释前四句。阴必是苦释前有苦。既全不觉即不识苦。不知去释前集也。四倒三毒释前有集。既全不知故不识集。三毒修惑四倒见惑。既不下释失道灭。由不知苦集。故道灭俱失。不识惑者。不识集也。既不识集不忧虑苦。惑侵法身失道谛也。必损慧命失灭谛也。如是下结。以不闻下次寄位释者。于中先以初二句二重顺释。次以后两句反释。初文先以二句对于闻思。应云不觉闻思不知修慧。但是文略。次以两句进约圣位。次反释者应云无见谛故不惊。无思惟故不怖。文中反释。故云见谛故惊悟等也。此明四谛观成见思两惑究竟尽也。以惑尽故四谛全显。初得见谛迷悟创分。如久迷初正故云惊悟。复更厌怖迷途方尽。次约三世者。不云过去及以集者现观未苦由于现集。又观现苦由过去集。如因缘中名为轮回。虽论三世正观现苦。以断现集。今当苦息。故知不觉现苦。即苦集俱迷。由此能招未来世苦。既迷苦集理无道灭。举二世苦以摄三世。具如引文。亦秖以苦而摄于集。然前三释。虽复约凡约位等三。总而言之。并是迷谛。以迷谛故八苦逼身。五识等者。逼近也。浊在五识名之为近。以切己故名为逼身。同时意识俱受苦境。非初刹那未分别时。又秖此五识体是异熟八苦故也。近岂过此。故此同时安能厌患。故此心王心所不能以此意识成观。唯能分别以成三受。三受义成故云切己。逼甚故切。故一一苦皆由五识以对于境。次至第六而重分别。复立苦因何能生厌。亦云去出他释。昔结大乘名之为种。功德即是法身家之智慧。即以此智为体。为苦所逼。大理智乘俱遭苦集。不觉不知名为火逼。今谓下但约浊名不须对大。既流转已小尚不知。故总诸义共成五浊。不觉等四为众生浊者。四句秖是迷于四谛。以迷谛故众生即浊。次火来等为命浊者。苦盛寿促令命成浊。心不厌等为劫浊者。由不厌苦常在三界。必遇三小名为劫浊。云云者。意斥旧师。不须将此对大说也。以五浊故。正当广上所见之火。故上但云从四面起。长者作是下先释能施身手。次释所施衣裓。能所俱废故云不得。初文为十。先标。次引合譬。三依三昧下明二义所依。四智断下明二义功能。五此之下明二义之门。六劝即下以四悉释。七如来下明用二义意。八故知下结归。九故上文下引证。十前叹下重指前证。前四可知。五此之等者。则以因果相对。劝是智家之门。诫是断家之门。故云从二门入。今于劝门中复言诫者。门体理合互具故也。各一义便故且别说。六四悉中云此二悉檀为第一义作方便者。二悉是修得智断。第一义即是性德法身。方便品初以法身智断取物不得。是故息化。问何不云世界悉檀。各二门不同随乐各别。又闻二欢喜皆世界也。故此佛乘生善灭恶。遍生八门。圆别四门各二各四。故此二门摄一切法。余如文。释所施中。文又为三。先出所依三藏。次出旧解。三今取下正释。初虽依三藏。但辩物相未明法门。次旧解中。初师云大乘因果。理何不可。但阙施化之相故不用之。次师既云出阿含经。不应用小而释于大。纵云大乘何异四阶。有言裓者。行袂袂袖也。今不用之。岂以救火袖盛子耶。次正解中亦取下合譬。佛自释义。岂同世情。于中为五。先引下文。次神力下正释。身手指前释衣裓等。三如来下明用三意。四衣裓下明立名意。前三可知。言名略义玄者。知见二故名略。摄一切法故义玄。如衣裓一足故略。盛多故玄。四无所畏。略如法界次第及止观第七记。智论广释。通言无畏者。十力内充外用无怯。名为无畏。佛自诚言。我是一切知者见者。无有一切沙门及婆罗门。若天魔梵及以余众。言如来不知。乃至无有如微畏相。用对四谛者。尽苦道即苦谛。说障道即集谛。一切智即道谛。漏尽即灭谛。四种四谛即四四无畏。今须在圆。遍一切四离二为四。二俱依谛谛为所依。故名为安。次十力中通言力者。诸佛所得内实智用了了分明。无能胜者无能坏者。故名为力。无畏与力内外之别。一一遍摄故名为横。十力依理故名为竖。则十处明谛岂不大安。无畏与力虽有内外。今皆约用故内外具足。五三七下结施化意。言而众生不堪者。此正施大。不堪之言取意说也。唯有一门至狭小者。于中二。先指上类同。次分门解释。初言义如上说者。如上车门。此中亦是宣一佛乘之车门也。若已出宅门未入车门者。取难当故名为狭小。初言别者。别约三义分字释也。于中先正释。教理下释所以。初正释者。一既是理门又属教。小即无机。以无行故不入理教。故名狭小。言不容断常七方便者。应云断常及七方便。于实不入义言不容。言众生不能以此理教自通者。但守方便行也。言通释者。理教行三。一一通明一门狭小。以不入故不得至果。初约理者。唯一法界故云无杂。由一理故遍通一切。令至此理故云能通。由子不入故云难知。约教者。唯约圆理对教以明。出入秖是理教故耳。云凡夫不知出者。则不及二乘已从宅门小教而出。不知入者不知车门。两教二乘但从门出。故云少知昔教未诠永不知入。菩萨虽自知出等者。通菩萨也。三藏菩萨虽有出教。三祇百劫并未出故。又通教菩萨约钝根者。未知入处与二乘同。故云亦也。夺七方便者。前与言之犹云知出。犹未入实名不知入。若夺说者出亦不知。何者。而不自知上中下性故不知出。与而言之。通别衍门犹可知入。然带教道故夺说者。别教地前皆不知故。尚不自知上中下性。况一地雨。从不知权边云皆不知。故别教地前虽知中道。教道仍权。据教道论乃至入地。入地必证故废不论。次上文云下引文也。七方便人皆悉未入佛乘故也。不能以教等者。方便之言必用通实。若佛未开皆不能以己教通极。言将谭者。尔前未斥不云无机。略开方说故云将谭。约行可知。幼稚无识者。旧师若云人天之善为幼稚者。此乃大善未生何名幼稚。依今为正。恋着等者。前明善弱故未有所识。今明恶强游戏被烧。因时者。初退大时。果时者。受八苦时。退大已后着爱见因。依正即是爱见果也。欲界着依上界着正。故云禅定等。对治之相至小乘也者。今大乘诫门名对治者。不同小乘无常等也。故引大品四念处等。皆摩诃衍。观不净等能所俱忘皆不可得

问。若尔。但是观理何名对治

答。修对治。时能所皆空。今此亦尔。约施大化复令离浊。于佛正是摩诃衍相。是故得名大乘治相。既着下大之所治。宜应用大以舍恶故。若久等者。久住见思大小俱失。不惊至如上者。如上释不觉等文。广约凡夫及三世是也。背明等者。东西譬苦集也。若明见苦集东西向明。以不知苦故而起于集。如日东而西走。不识集故而招于苦。如日西而东驰。驰走义一故经云戏。死如往生如还。还已复往。生死不绝。无彼变易二土之寿如速疾也。又从苦起集如往。从集受苦如还。一苦一集一生一死。是故名为驰走还往。虽用大拟等者闻而不受视父而已。如虽见父怖畏逃走。失闻见利故云而已。已者息也。又机扣于应。故名为视。机生不受故云而已。大乘下至父命断者。并以大乘为父子命者。虽大救未得种不可亡。所以虽欲小化。为存大命不废化功。前云切己者。初退大时适起五浊。如初逼身大善容在。若久不出流转五浊。名必为所焚。即大小俱失。此语起小应时。故云若不时出。大乘善根理实无断。意令速出以必死逼之。若久不出义同于死。故云死义。上文于所烧至若不时出等。问意者。得出与俱焚内外义别。二文相反其义如何。次前得出下答意者。法应不同二义各别。从文从理二意不同。若准前文文既寄小。还从小教所烧门出。则还且约五分法身。若义兼于理则法通二种。若法应相对。理须常住法身已出。今论应身物机受化。则机应俱济故云时出。不受化则机息应谢。灰断入灭义当俱焚。焚故义当子父命断。以此拟宜而催逼之

问。前云得出是法身者。大之与小法并无烧。何须言出

答。秖以无烧名之为出。然则法应并皆无烧。应本同物从物云烧。从理则法应无坏从事则物烧佛出。今说俱烧意在同出。故云若不等也。有云。感应俱时。今谓但得俱出之理。而失俱烧之义。故以俱烧要令同出。从如子先下明有小机。故接以小。开一为三故名为各。又知至小强者。大退故弱小强二义。一者厌苦。二者是治。六心中退者。准璎珞意。身子于十住中第六心退。恐是尔前见思俱断。至六心时见犹未尽。六心尚退。叹三车者。有人问。何以车三使二城一城有车无。俱譬方便而数不同。他答有余。今更为答。凡立譬者各从一边。不可执一而疑异途。故一二三但是离合。为对三周信解等异。是故别耳。皆譬方便其义不殊。车则通举方便故三。使则从难别对故二。城是二三之处故一。当知城亦从人故二。故云息处说二。车亦从难但二。使亦义兼菩萨。此三俱有人理教行。城若说化故亦无。车依造作故还有。使约权同故亦有。权乃非实故亦无。权实相对俱通四句。从权化故俱有。从实义故俱无。俱通权实故有无。同约一理故双废。劝示证者。示应居初。随经次第先劝后示。亦应无失。证中皆与之言正当已证亦令他证故名为与。言前偈本略者。譬本但云是名转法轮等也。广明至六句者贤合为四见修为二。贤所以合者。四念法同故为一。暖顶同退故为一。忍不出观故为一。世第一无上故自为一。见修道异故各为一。广如俱舍贤圣品中。此须略明。三十二谛者。上下各有十六行相。上下合论故三十二。具如俱舍释签略明。与苦法忍不别者。世第一心同此刹那。即入苦忍同观苦谛。应云四中随观一行。与苦忍同故总举之。驰走入见道十五心者。世第一后十六刹那皆是无漏。有云。十六心仍在见道。部别不同。便有涅槃音者。此约初转为言。观心中用大乘观者。凡附文作观多分在圆。令一一文不违所习非数他故。初至所愿者。心望观境名之为愿。心未称境故非适愿。境至勇者。境多观少非勇进者。境研心者。还以心思妙境。而研于心。数数为之心观乃利。心境相研者。向令以境研心。前又以心观境。故名互相。心王等者。创心修观莫不以第六王数为发观之始。纵使观境圆融不二。其如粗惑尚未先落。故皆仍属第六王数。乃至未净六根已来。未离王数。此是见思家之王数故也。若欲约教。即有四教贤圣位别。驰走不同今在三藏。上法说中先明等者。上释迦章颂显实中。有六行偈。先约四一即是消文。次约索车即是譬本。谓初两行从我见佛子等。即是闻前诸方便教三菩萨也。次我即作是念下二行一句。明障除佛喜。言今我喜无畏者。即障除故喜。今先明免难后明索车者。前后既殊。光宅直将大机以对免难。所以破之。此明经文前后不同。非谓障除有前后也。以诸声闻皆浊先除大机今发。苦具足等者。由法譬文免难与机前后回互。承此不同释出四句。先释两句余两指上。今两句者以前两句。但经文互互义不成。欲令成互对华严等名同义异。初句虽引四大声闻。通指罗汉义及三周。次句所引凡夫理通初后。于次句中义兼华严法华教者。异前初句。余之两句云如上者。指上颂释迦章。偈中四一消文末。四句料简中。初二二句与此大同。仍有少别是故更释。彼初句云在三藏时。未云大品末等。次句但云法华中诸凡夫。不云华严中人。其言虽阙大旨是同。言余二如上者。即第三第四句也。彼云障即除机即发。如无量义中得小果者即座闻大。障未除机未发。如五千起去。唯第四句非法华中人。若大机下更重示向经文回互。若大机等者。如向引方便品文。但彼品文文有前后。非谓彼品先大机发后障除也。若先障除者。如向引云今譬中已下文是。四谛同会见谛者。阿含经中亦有四衢譬四谛下惑尽。次明索车义。云作十难者。古人立难不许菩萨有索车义。会二归一。近代拾用何足为怪。故今叙破令有索会。先述。次破。初二可见。第三云所化是凡夫未出三界。不应有索。能化位在三十三心。不可于兹更云有索。若入佛果。佛果无二。佛从谁索。第四明先断正使。习无知在理不合索。断尽成佛。佛复无索。第五引今经文。以证菩萨。第六云从大品等者。古以般若在方等前。故云大品已来。先引妨云法华已前皆方便者。先定付穷子下设难也。二乘领业皆菩萨法。若是方便所付之财。何以乃云皆是我有。若付财下重征也。若所付财是真实者。菩萨于彼先得此财。已成真实。岂至法华更索真实。第七意者。方便品云。一切声闻辟支佛所不能知。故小名方便是故须索。佛子大乘者。偈云。佛子行道已来世得作佛。作佛是实实不须索。下三可见。古今所计不出此十。次破中云私总别驳之者。私破也。驳谓斑驳不纯之状。亦杂也。破彼如驳正释如纯。所言总者。通立菩萨有索车义。则十义皆破。索是求请至名求索者。引前三业皆有索文。有法喻合法意者。三乘之人成居未足皆未善行。来至此经咸须有索。喻中三句次第以对三法。凡居下合中初明索意。索义兼三。及引文证具腾始末。由索故许由许故与。许与有文何得无索。初明请中请既弥勒居先。许岂独酬身子。况身子普请恩沾自他。故云愿为四众。四众岂独二乘。佛许非专小众。故但通云当为说等。许文可见。故知三周通语三乘。法说竟身子欢喜。即第二卷初。譬说竟迦叶欢喜。如信解初云闻世尊授舍利弗记发希有心欢喜踊跃。宿世竟楼那欢喜。如五百记初云复闻宿世因缘之事心净踊跃。次别驳者。先破第一云齐三藏明菩萨不断惑者。前云菩萨未至许处。以不断惑。故不与二乘同至许果之处。故不索者。唯三藏中明菩萨不断。故判云齐。言依法华有四句者。谓准今经须作四句摄机方尽。若无四句恐人谓机发独在无障之人。故第二句即三藏菩萨。若独二乘二乘何曾障未除耶。逐要且列机发二句破旧不索。若不索者何以机发。然机不动亦有障除。第三句也。未发且指法华已前。若至法华除五千外无不发者。破第二义者。彼师意云。索但在小。诸大乘经并无菩萨索小乘果。今经菩萨岂应索小。故今破云入涅槃既同。何得不索者乃以通教破之。汝云菩萨不索小果。通三乘人得理既同。俱被斥云悉是方便。欲更求实理须俱索。通教尚索况三藏耶。破第三者。彼文云。所化三祇百劫至补处来。犹是凡夫道理无索。此贬太甚。岂三祇百劫一向同凡。文仍不破。但破其能化三十三心思仍未尽。故不应索。至佛复无索车之义。但总判云属三藏耳。故菩提树下三十二心。犹名菩萨。时节既促索义不成。此则可尔。言思未尽此不应然。故以见惑凡夫况之。惑障全在大机尚发。况三十三心。言佛不索道理如然。彼亦不知因不至果。至三十三心必无实行。可中此佛实是三祇至果但断见修而已。还同罗汉。如云世间有六罗汉。罗汉安得不索车耶。秖由彼不知权。故且难之。其教既权进退有妨。破第四意中。亦先牒难云菩萨未断习乃至断尽等者。此以第三文为例。前第三文若菩萨进断习气无知。理合成佛索义不成。此三乘下正判属通。教既未实菩萨须索。次以具缚况之。破第五意者。彼以三乘之中菩萨为唯一。次被会下破。纵许菩萨伏断不同。望二乘人亦名唯一。应知唯一语通待二不局。彼以所待二外秖一唯一。不知四教当教菩萨俱名唯一。故三唯一仍须索车。当知前三是待二唯一。圆教唯一方是绝待。如三藏唯一之外。犹有三教。通别可知。夜光明月珠也。破第六意者。彼谓般若至法华来。一概真实。汝不下以共不共责之。共不共文出自大论。不共菩萨容可不索。彼有圆故。又不共兼别。别尚须索况共菩萨。故汝不知所付之财兼共不共。而一向云真实不索。又若云般若中菩萨真实不索。今反难之。二乘于彼被付真实。即同菩萨何须更索。况汝自云至法华来。皆是真实。以汝不知三味异故。破第七中牒难竟。次破中引本门文者。彼本门文既大小己他俱是方便。望彼本文圆尚方便况复偏耶。今迹中三教皆是方便。况方便品初云佛以方便力示以三乘教。何时独云唯示二乘。三俱方便是故俱索。破第八者。亦先叙难。次汝不闻下破。亦应更引前三周初十义之中有领文来。破第九者已如前破。破第十云犹是前义者。不出三藏。破亦如前。世人明义多分不受四教之言。今但破云四阶及以三乘共位与华严中菩萨不同。若复不受。请送婆沙俱舍及大品经。却还天竺。自有行息等者。大小别故小乘息索。菩萨未息教权故索。又菩萨下更以义破。索是求请别名。岂有不求而得。归其诡累者。诡诈也。累重叠也。十义多是诈累藏通。故一三九十全是三藏。第四五六博附通教。余之三意义含藏通。彼由不见璎珞位行尚属权施。非是发心二不别故。若是实者。与华严经普贤行愿同耶异耶。故一家立义别尚须索。况复藏通由彼立菩萨不断。及以断惑未穷并不须索。二乘断惑是故须索。此则全迷断惑菩萨亦须索车。况障未除大机动人。今当下离为四句。断与不断有索不索。况十六句遍。约五时。初许古人堕在一句。若至十六句令无索成索。全令堕非无句可得。于中先列四句

问。初句与古人菩萨不索何别

答。今别有意判在三藏故也。彼谓一切菩萨不断。故俱不索。或断未尽是故不索。又引经论偶成通藏。以彼不知别圆义故。若本知者何事不立。故今初且离为四句。用对四教次历五味。故初句中望后三句。名同古师其意永殊。一往对句且立根本名不索耳。以三藏菩萨始终不断。纵被斥时亦无可索。一往虽然犹未尽理。所以更开为十六句。又根本句中第二句为通教者。三乘俱断故俱索车。第三句者。约未破无明名为不断。是故须索。登地已断是故不索。此则永异古今诸师。况第四句无非法界。更何断索。故第四句方名不索。前三句中初虽不索。终卒须索。故三句中俱名为索。利者先索钝者今索以须开故应须必索。圆教尚不当于不索。何索之有。故不同古所立十义。次更随味具教多少准例说之。故法华前三教菩萨一切容索。两教二乘约时前后。显密不同。更约五味良有以也。宏纲大统者。且立四句以对五味。未细分故。言一一句者。如前四句。一一意者。若直对句秖是四教句复离四。故句亦名意。意者秖是教中句也。如云乳味两意等也。故知障除秖是惑断机动理合索车。准此中句。若从根本四中初句为首。应先从障未除机未动。离为四句。应云未除未发已除未发。亦除亦未除未发。非除非未除未发。未发非宗故不用之。初文且以除等对动。似是从根本中第二句上开出。既云一一句各开为四。秖是皆以文中四句。列诸教上。是则四教各以除等对动为句。以明索车。宗在动故。故一一教中皆以除等对动为言。故文但列四句为式。仍将此句历五味简。令知四味中诸机未纯。故有当教后教不同。依今经意。虽有诸教障除不除。机动必唯圆教故也

问。前之三教当教论发。还对当教除不除等。此则可见。若并望于圆机论发。则菩萨通前二乘不定。圆教如何论断等四。云何更动

答。应将初住以对住前。而论四句。一切凡夫不断五品名断。初心修观虽即法性。须作意断且立断名。六根即为第三句也。以第四句是圆本句。须归初住。是故尔耳。故法华前教句教未融。来至法华。唯有四除以对一发。故至法华无不索者。口索既尔机情可知。是则味味无有不索。但机情冥密故不论之。所以且对显教诸味。以成诸句。索之与断其义众多。如何乃以一言辄判。故云斯宗不见等。次明体数不同者。旧三师中初一全非次师似当然第三师今不全许者。其理未显。并由不说佛菩萨乘离合初后同异。所以须会不会。所以下破古。先通非之。次别引教。初引昔三。三既在昔验一在今。次华严下皆引证四。即能所具列。初云说。次云出说约教法。出约行仪。初三从应。第二从机。当知定有四法故也。地论等者。地论在别。尚列四观观于十善。当知诸法咸通四观。璎珞三乘即前三教。三各开三即别教之乘也。平等即是圆教乘也。今约教下重以教门判向三四。但云三四未言优劣。故须教判。若三乘对真论同异者。即判初家。判三四九属别圆者。更须约行方分别圆。应知藏通大意亦尔。虽引前经具足四教。妙部未显。复须历味方辩今经。正法华中亦先云象马羊。后乃各赐大白象车。同一梵文谁非谁是。有人问云。出不见车是故即索。此未立城应须索城。今为答之。城约有譬见何须索

问。车城俱方便有无义必同。何故有无异致令索不等

答。车由斥方便失实故须索。城若非真实亦同车处无

问。若尔应俱索何故索不同

答。车但说方便求实故有索。城云宝处近是故不须索

问。方便略开三未实故有索。已闻五佛章。何故譬中索

答。中根迷法说故说车虚譬。有无宛然齐智者无斯难。有人问。三车容可有上下。一城何得有出入。答车亦无文说有下。城亦不曾说有出。车被斥虚义同下。城闻说化义同出。彼此从譬咸义立皆已入证并须开。大车宝所既无殊。两处妙理何差别。世人下明大车体者。应如玄文显体中辩。此为破古略辩异同。上虽明数及索不索。若不辩体。将何以明解行之本。已下诸师章安所引。故出今释云天台师。初光宅庄严虽并云高广。而据果计因对昔未绝。故光宅指果此有五失。一者因乘无体乘何而出。二者名滥小乘果尚须索。三者以用为体能所不分。四者待昔无绝开权不成。五者摄法不遍以隔凡下。别无尽智之语。况复圆耶。别圆虽有无生之名语同意别。断证永乖是故不用。况以今待昔方为高广。当知当体无高广也。庄严在因果必无体。况行是具度亦非所严。上求下化四教皆然。况唯知语其高广不解始终不二。旧师不取功德意斥庄严。欲同光宅又不云果。智属白牛体亦不成。过准前说。又一师取福慧者。总破前三引无漏根力等属慧。禅定解脱等属福。岂但慧耶者。正斥第三。福慧已非车体。复谬引昔文证今。深不可也。过失云云又取有解者。似符光宅。空解无动故不取者。意谓运义不成。不意运都无体。尽无生智即有解者。从所尽所无立名故也。又一师分对小乘。大乘但取实慧方便。运动如前。私谓下章安通斥。牙等虽象通别不同。通则无非象身。别则身非耳等。准譬破义意亦可知。故亡体者通别俱迷。至赐车中点出者。高广为体永异诸古。次辩小车并运不运。兼辩因果及索不索者。因便明之令识所开。既先索小先须识小。言八智通因果者。亦应云通漏无漏。如他心智即以法类道及俗智所成故也。何者。若他心智缘他无漏心。须以法类道他心智知。若他心智缘他有漏心。须以世俗他心智知。若果地他心智即果地他心世俗智知。若因人他心智即因地他心世俗智知。自余六智若初果人断见六智灼然属因。若二三果。及以非想余一品来。所有六智亦属于因。最后一品方乃属果。若依去古人引教。破前一向用果。然但下古人正释。要因下释妨有旁正故。若内下更立妨。然果下释妨。果无自克由因至故。故使此果得名好运。中道不达表非好运。从后为名故名好运。乘秖是车车本动运运因至果得好运名。既可并颁理须双立。若乘下古人乘向所释。立索车妨。旧云下释妨。释却成妨。旧释意云机索可解者。机蕴于内可发名索。机虽有索但冥在心。情未犹豫故使不述。虽情动于中未彰于口。秖由情故以天眼观。进退生疑情从佛索。若寻下今家破旧。有文义二妨。于第二妨中有四相违。第一与当文灭想相违。二又佛下与须见余佛决了相违。三又初下与下不见上相违。四又罗汉下与修因时未见果相违。初二可见。第三引例。又与摄大乘违者。诸论天眼下不见上。必无二乘见于界外。今言下正释。言昔日者昔住小教。既其被斥情有所望。准此判意情通二味。因斥旧解情索理违。故今为立情索之义。若单论情取意为语。以机生故所以情动。故机情索通遍二酥。别分二味。索求至之实者。若是方便昔实何在。机在大乘等者。释求实意。至口索时大机已发。情求昔实意在今真。此则机实而情假。又情下重申假以扣实。故情实而口假。故机情时未彰于口。口索之日必具机情。六度通教例尔者。向明两教二乘既然。故知两教菩萨亦尔。何者。昔五百八千俱被弹斥。般若淘汰受益事同。既见身子腾疑。佛释理应沾已。默然在座伫圣申通。有两章两广两释者。此依未次。疏列稍似难见。准文次第两章并标。广释间出

法华文句记卷第六(中)法华文句记卷第六(下)

        唐天台沙门湛然述

一等子下标两章门。言子等故则心等者。先明子等者。无非子故故心必等。其心若等其子必等。心即心性故佛性等。由皆是子故心无偏。财法复多是故心等。车等者。初明等意所赐不二。是故云等。但点所习无非妙乘。秖缘性同赐义则等。而言下却以子等释车等疑。既云车等何以各赐。昔习不同诸位不一。至此所说无非一乘。何以故。若一人不遍不名子等。且云本习应遍诸法。一物不与不名赐等。所谓色心逆顺依正行理因果自他解惑小大慧福。故知等赐秖是开彼三乘六道。无非一如。故一一如无不遍摄遍具遍入。一切众生谁无四方道场之分。谁不理有大车具度。待时待缘是故尔耳。故至今日方云各赐。言横周等者。法界三谛并非横竖。虽无横竖法界从遍。言横则便。三谛名异。言竖则便。不二互显思之可见。言四辩者。谓法义辞说。七辩大同。法谓一切法之名字分别无滞。分别三乘不坏法性。义谓诸法之义了了通达。知一切义皆入实相。辞即言说名字庄严随其所应能令得解。一切众生殊方异类。多少广狭诸道男女。三世九世诸教诸门闻者悉解。乐说谓能于一字说一切字。于一语中说一切语。于一法中说一切法。随所说者无不真实。十二八万随根所乐。而为说之。四无量者。四谛为境。二苦二乐故也。本是不思议之梵行也。故大经云。慈若有无非有非无如是之慈。名如来慈。故三谛慈摄四遍也。四弘四摄并依境判。方异余经。四弘具如止观第一第五。此之四弘即是前来四无量也。四摄略如止观第七记。神通七觉并以无缘而为所依。如止观第七无作道谛中明。綩绣衣也。綖者天子覆冠衣。前后垂者是也。非此中意。此应作筵即铺席也。观练熏修如法界次第具出名相。止观禅境玄文定圣行中。皆为实相故修。至果禅中胜用无尽。丹枕云支昂者。即车外枕。车住须支支之恐昂。故云支昂。支持也。昂举也。譬动静相即者。车行枕闲车息枕用。用时常静闲时常动。实体与用亦复如是。自因之果法性无动。所以如风不移寂然而到。万行无作众智莫观。此则三德俱不二也。以三即一故使尔耳。车内枕者。智首行身三珠如枕。所息得理法理而然。赤光等者。无他法间名无分别。以光譬智故云智光。朱正紫间故以赤表无杂之光。南山注经音云。西方无木枕。皆以赤皮内着绵毛。用倚卧也。赤而且光白牛为三。先明功能。次白是下辩体德。三又四念下论行相。初文者。修得般若能导假中。三教谛缘无不至极。故云到也。此名通有须体简之。次体德中云白为色本。本体无垢故云本净。修称于性故云相应。体具等者。显圆智也。惑体本净约性论修。名为不染。此即内充而外洁也。又四念下即是约境以释行相。念即是智处即是境。四观观处处观一合。如全白是身。即此观境善满恶尽。可譬正勤。由此成故。复令欲念思惟一心成无记通。化化不绝任运常然。去住自在故云称意。余法例如道品说之

问。此中大车等赐诸子。诸子得已始至初住。乃至犹在名字观行。如何纯以果义释之

答。以证示人人行差别。明因等众举事示理。故但示云汝等所行是菩萨道。心佛众生三无差别。是故理赐。行位等赐即果赐也。果理在行方可云赐。岂可理果与众生耶。仆从者。准对三德。应车体中分正及缘对牛为了。此则义当修二性一。一复具三高广不二。此中仆从与偈傧从言异意同。傧者进也。导也。侍卫者供左右也。仆者下品也。今习大乘者自量己心。与此经文所列同异。若一句即是为是何句。一句即足何须诸句。岂佛谬说强骋文词。烦列车仪炫惑迦叶。此大罗汉久为僧首。四十余年不受真化。才闻方便通叹二智。略开显已。动执生疑情方犹豫。殷勤三请。广闻五佛十番开权。又睹身子三业领解八部引例。四众酬恩。如来述成分明与记。经斯重叠宿种未开。才闻大车便堪记莂。故知此乘观法具足。仍存翦略粗点十观。若广张行相何由可备。不别解释即悟无生。望上称中比下仍利。若此车譬一句徒设。则显佛有绮语之辜。或举集人添糅之咎。及责译者混杂之愆。若属对有由则行仪可轨。岂学大观顿尔全弃。既失大检小径莫从。大小咸亡恐随邪济。乘坏驴乘为向何方。譬果地福慧圆满者。行理穷也。福成行也。慧趣理也。自行德备是故内充。化他德具是故外溢。遍一切法故财无量。皆具二德故云种种。列二藏者。行称理故理藉行故。更互相收方堪等赐。一切下引证二藏。如其不了阴入理藏。徒自虔修诸度行藏。言一切趣者。文在大品发趣品中。趣谓趣入。即一切法入一法中。一法既然诸法皆尔。行理具摄一切法也。一切法趣文相开合。如止观第二引。自行此行理下。次释充溢。先直约行理。次实智下能导能照即是修得三德意也。果极利物故名充溢。虽有二释佛智不殊。广等心中亦二。但以心释子故云心耳。文具三义乃名心等。一者财富。二者皆子。三者无偏。是故心等。亦应更云所以心等由皆子故。财富无量自行满也。皆子无偏化缘熟也。若富下反以不等用释于等。由财子互阙令心不等。应知非子及财不等。寄在昔教。故昔偏教教主化机二义并阙。如两教教主贫法财。故不得云富。不知常住不得皆子。纵当教名子收机不遍。故亦非子则成有偏。互阙非等并阙可知。别教教道虽云皆子。两义尚无。证道自同分等无缺。下释子等例之可知。是故今经一实之外更无余法一切众生皆是吾子。缘因尚收于散善。了种通摄于一句。正乃不弃无间。方称一切之说。是故玄文明利益中。则序正流通未来永永。严王调达不轻龙女以义准知。况应以之言何简于四趣。随宜之教靡择于顺违。此等赐之大体也。故知子等心等之言。岂独四大声闻而已。所以诸法皆藏咸子无偏。今七宝下释三义也。先明财多。言教行者。机应相对。且从现文益者说也。次各各下明是子无偏。言各各者。由俱子故。不差别者。由无偏故。各赐等一秖是开权。次释各义故引身子等。本习不同故各皆同入实故等。又方等般若者。约法已开自在根力。其根钝者于二味初。得方便教中之益者。于彼得益诸位诸法种种不同。故皆以实当位开之。所以者下释子等中。言两等者。应但云子。两者恐误。文举财等况于子等。且以处等而况子等。子本一家今周一国。何况子也。言一国者。寂光土也。遍益法界理亦不穷。况同居士结缘人耶。此举广处以况略人。次释下正明子等。复以非子况之。言非子者。且贬正因不同缘了。故抑言非。等阴无偏况结缘子。故约无缘慈对本有理。无非吾子。寄化仪说。且以昔世未结缘者。而为非子。如来常给子自不归。无缘通覆故云周给。人天善恶与法界同。故父果车是子理车。但开其情假名等赐。众生无尽车亦不穷。不穷故不匮。不匮故无偏。望迷为开悟本非闭。无缘尚度者。缘了之子是先结缘者而熟脱之。正因之子未结缘者。为其下种。故云尚度。故以种者况先结缘释不虚中初佛问者。本但许三而今与一。非虚妄不。欲令身子领实。故以虚妄问之。答初免难不虚释中。经云若全身命者。具举身命况而拔济之。意云全于小乘五分法身入空慧命。则为已得昔来所玩。况于火宅方便济苦本在大耶

问。经文即以拔济。况于身命。拔济正应以大况小身命。何故疏文不用拔济。而云命重身轻。乃以小乘五分为身。用况大乘实慧为命。何以小身对大命耶

答。此乃借义互说。小中自以无漏慧为命。大乘自有平等法身。具足应以大小身命以为对况。免八苦下结向命重身轻意也。当知借于小命为大命。初用小济存五分身。已得珍玩。况常于火宅方便教小本在于大。而今获大。岂虚妄耶。小乘五分法身具如俱舍云云。况二万亿佛下指昔因也。经中但以今世火宅况之。疏中加于昔大以释。从圆因成去指今果也。不乖本意者。此述长者本意。若小若大俱有本心。大本为本小本非本。许小不与尚无所乖。况更与大宁乖本意。如许少财与少非妄。况与大位得过于昔。宁非本心。信知如来本非小化。所以财但免于分段之贫。位则超于二死之贱。一义兼备何乖之有。但小非究竟不须更与。故云不与耳。本知无三至本心者。明不与意。昔非本意故今不与。经云方便令出。疏云令不堕恶者。令不堕故方便令出。方便令出故令不堕恶。则一意也。结前等者。双释两结皆安似者。文似偏结理必兼具。二轮别故所对不同。故借二轮以消二结。自体者。实报土也。此是摄大乘师从因。立名谓有为缘集即同居因。无为缘集即方便因。自体缘集即实报因。亦云法界缘集。今疏前二仍旧从果立名。后一依彼从因立称。皆是妙色妙心报处者。既云一切世间之父。故知三土皆是证道色心报处。寂光既遍遮那亦等。诸身既与法身量同。诸土亦与寂光不异。如像如饭如镜如器方之可知。一切众生无不具此。果报未满全局在迷。迷故阴质局彼太虚。满故即与法界等量。应三土者从化事说。故云处等。于诸怖畏等者。且约界内因果而言。以对诸子是所畏故。故云永尽。所离同粗能离理极。故云无量知见等。有人以初地离五怖畏。用释此中都不相关。上不及诸佛下过于离界。望诸释义其例若斯但譬中惊怖在前等者。前云即大惊怖而作是念等。次云恋着。即是重释所见。今合不觉在前者。先云众生没在其中等。即是略后便明广也。拔苦等在后者。次此文后方云我为众生之父应拔其苦难等。应拔其苦至慈之力者。大悲且从拔浊大慈与其大乐。故慈从化意悲从用小。上譬有劝诫等者。释譬及法有无之意。即是旁正相即。即是其体本同。况此二文既是二悉。当知劝善本令断恶。断恶本令劝善

问。二体既同。何须立二先辩互无复更相即

答。门别故二体同故。即虽复劝即是诫。但是劝家之诫。诫即是劝。但是诫家之劝。故两门各存不妨体一

问。若尔。一门废之理亦何爽

答。若善达二门。一门亦足。但一门若废则二义俱亏。况表父殷勤先劝又诫。或时各逗机宜不同。化时不别共成一事。我生已尽等者。无学四智罗汉皆具。或慧解脱未得无生。今以无依是初后二智。无求是中间二智。后有即是所依处故。若生已尽未来无依。中间二智尽三界因。名已办等。故云无求。上有真似等四位者。贤合为二。及圣位二。今依前外凡。亦但闻慧为一。思修为一。辟支是法行人者。一往且对声闻凭教。所以支佛自思为法。然支佛必自证。声闻具信法。信法具如止观第五记引婆沙等文。闻法少者。支佛或闻教堕在声闻者亦是因信但云闻少。此门至非佛等者。大论云。有一道人问佛。大德。十二因缘佛作耶。佛言。我不作。又问。余人作耶。佛言。亦非余人作。有佛无佛本性有之。夫答问有四。此即决定答也。若其广出三藏谛缘。具如俱舍婆沙。玄文略出。但合等者。以此四中二正二旁。当知由免难故。索车由等赐故欢喜。门有三义者。三门之中出别是门入者义立。从一色心入一色心。门以经游为义。但未出名入。从一入一义言为入。实非外来。若作出者。须兼三藏。今立通教所诠。以此两教。所诠同故。言若别义者。依别理人。言所诠者。意显独教门义不成。经虽云教必须对理。故知别教虽诠别理。亦非车门。但对通藏而立别名。由缘别理故名为别。次第之初与藏通人咸出火宅。据出宅同仍可名通。初证又同两教涅槃。故亦可云得涅槃乐。三德具如玄文三法及止观第三显体中说。此释小异于前者。前云意不在三。今云本欲与大。虽复小殊名异义同。有一大宅者。有人云。且指一方三界。故云一。他人广列利钝章门。三界无始为久者

问。若从因说或当无始。若从依报初禅已下贤劫近成。云何无始

答。众生无始具三界因。惑种不亡故云无始。故依报处坏而复成。第四禅去及无色界。虽无灾坏因果相成。皆是无始无常故也。然终不如约正报释其理便也。念念相续等者。相续故高无常故危。意识纲维者。统御一身其犹梁栋树立一屋。圮坼者。上下毁裂。褫脱衣貌也。因缘观心两释者。如云头殿腹堂即观心也。如云色堂欲舍等。即因缘也。命根已下文并观心也。八鸟譬八憍者。但慢与憍能所别耳。诸教亦以七慢释慢。此中所释亦与俱舍大同。其意稍别。今略比之。盛壮憍如我慢。与俱舍名义并同。壮故我强。姓憍如大慢。俱舍云。于他胜谓己胜。如世寡姓尚未谢于崔卢。如枭尚食于母。况贵姓耶。富憍如过慢俱舍云。于他胜谓己等。如世贫者。尚不下于石崇况实富耶。自在憍如邪慢。俱舍云。于有德中谓己有德。如薄祐者。尚无屈于有德。况有自在者。寿命憍如增上慢。俱舍云。未得谓得。寿高计常。如少尚未肯尊老。况实寿高。聪明憍如憍慢。俱舍云。于他等谓己等。于等而轻。如力虽劣尚欲轻彼。况实齐耶。行善憍如不如慢。俱舍云。于多分胜谓己少劣。德业天隔。谓稍下于高踪况少劣者。色憍如憍慢。俱舍云。色不如他亦谓己等。陋者自得未肯劣于潘安。况美姿貌。略对且尔如名不同。此中直尔有此八事。故憍慢者。未必全有。自爱为贪去更以三毒例释同异。故四思惟并有二名。所从得名不定故也。虫名兽状鬼体神形虽即非要。与使为譬亦可略知。蚖即黑蛇也。故汉书云。玄蚖。蝮者。尔雅云。虺长三寸大如指。江南谓虺为蝮。有牙毒。鼻上有针。蜈蚣者。蝍蛆也。有人云。能制蛇。若伏蛇者。多是赤足者。此语有损不思来报。守宫者。蝘蜒是。有云。在舍为守宫在泽为蝘蜒。[鼬-由+虫]似鼠。若兽名作狖似猿。若作狖字。玉篇云。似狸亦啖鼠。天若雨于树倒悬。尾有两岐以塞两鼻。狸字说文从豸。鼷者。说文云。小鼠。玉篇云。有毒螫人及兽至尽不痛。即甘口鼠也。咀秖是嚼。搏击打也。撮搏取也。亦拍亦抚也。爱心贪等者。寄此与钝使对辩。诸见在后鬼神中明。亦可是钝中利也。若从钝说道理亦是钝中道理。推求去释也。如此土儒宗亦计天命气等。并钝使摄。欲比西方道理天隔。一云去。重更全作钝使释也。摣者。释名云。叉也。谓五指俱取也。掣牵也。亦云向前摣向后掣。啀喍者。喍字亦作龇。聚唇露齿也。嗥吠者。出声大吼也。经魑魅者。物之精也。通俗文云。山泽之怪谓之魑也。西京赋云。山神虎形曰魑。宅神猪头人形曰魅。魍魉者。木石变怪。玉篇云。水神。孚乳者。玉篇云。伏卵曰孚。通俗文云。卵化曰孚。广雅云。孚亦生也。乳者养也。故鸟生曰孚。兽生曰乳。言自类等者。即同类因得等流果。以子似父故以喻之。俱舍云。同类因相似。自部地前生。即五部九地。但约过去以现在为因。广如彼文。鸠槃茶者。可畏鬼也。蹲虚坐也。踞实坐也。次捉狗等者。有此一释故曰一云。狗足如因捉之如谤。捉足扑之如令绝声。故云令其失声。因果法尔不由执无。却由捉扑所以有声。如由计故所以有生。以脚加颈者。声不绝故。复以狗脚加于狗颈。谤无苦因之上。复更拨无苦果如脚加颈。望必绝声。声岂不甚。拨因尚生拨果弥甚。集本得果下释上句。捉狗两足岂能绝声。徒谤无因果何能免果。集无得苦下。释下句。如加颈时欲令绝声。由加声大。又谤无苦因者。秖指非因计因。即是谤也。本是世因今谓出世。即当谤无两因故也。观解者。前约事释。多在断见故云拨无等。今约观释。义通常见及以邪正。以佛弟子亦有修六行观者。故今用之。若外人修多在计常。或计四禅乃至非想为常故也。凡云观解须顺内故。又云作不净等。此意亦以出声为失。由观故生如由扑故声。今不得起者。复以绝声为失释也。故云不起。竖入等者。如六十二见虽有众释。多约三世。过去来今从今入未。故名为竖。横遍等者。如二十身见一阴四句。四句相望无复优劣。故名为横。不修善法为此纵恣。所以不修非拨无也。虽不拨无亦名无惭。言见取者。非果计果。非想非是涅槃之果。计之为常。无色唯心名为咽细。三界寿极名为命危。计之为常名为保寿。保寿正当计果义也。非想下重释计失。首如等者。根本之我如牛。世以牛力为大自在。计我亦尔。于中复计我之有无。如生二角。为身是我等者。以我与身更互有无为身是我者。执所为我。为我是身者。以能为所。身即是所我即是能。如以五阴计一阴为我。余皆我所。谓僮仆璎珞窟宅。若计常者身非是我。身断我常。若计断者身断我断。或俱常断。具如止观第五记引阿含本劫本见末劫末见。然其所计能所虽殊。计有义等。或时等者。是诸外道于一身中前后计转。所计之极。极至非想。以所计为头。彼地断常更互起计。如发篷乱。计常等者。互相是非。强者伏弱。弱者从强。皆破他从己如相残害。计此我者。有断有常即边见也。夜叉等者。初二句总结欲者。未分利钝。亦是下更别语利钝意。亦指初二句。即上句利下句钝。并是有漏下释第三句。有漏之心皆无道味之食故。饥以由饥。故生死速疾故云急。经四向者。见惑虽多不出四句。利钝并有饥急之义。经文且从利使以释。窥看者。私窃也。看不正者。由隔窗牖。故见空而偏。空无偏正由彼窗窥。理无是非计者成过。故云滞着心多不会正理。故知邪正谁不各谓仰慕至道。此二句通结二使。次下二句收广结非。是朽故宅等者。上文云。今此三界皆是我有。此从化主统而言之。为生取土。言朽故者。从生以说。故前后文国城家等随其义势。或优或劣无不属生。咸归长者。一色一香一切皆然。长者下释下二句。内合至舍应者。合此二句。若以十六王子为常教者。应云王子舍应。今从果说故云如来。又舍应不孤由大蒋故。故知非但舍应之后起浊。亦乃由浊起故舍应。故知前诸起浊救火大化拟宜等文。意皆探取大通后文。准此中意随根上下三周不同。究其根源莫不皆尔。故得通用。寿量者。助成近义。实成既远中间数成。成即是出。且约一期故不云多。又覆本故不可云多。火起之势者。此中势相皆应须作见修两释。应知通论势有二种。一者势分。二者威势。势分通至非想威势烧无不坏。今当界二势亦复如是。宅宽舍狭三界为宅。五阴为舍。若且指欲界准例可知。由浊倒故身命无常。故作无常消此文也。被烧相中分为三义。初二句属见。次一句属修。次三句明不出所以。专由于见故重云槃茶。又初二句通列。故云鬼神等。等取虫兽。次一行别列故更云鸠槃茶等。初二句中下句正明烧相。故云大叫。次一行中下二句明愚不知出。正由不出故烧。烧故不出。故总属烧相。哭泣为扬声者。此以十二支后愁叹忧恼。来释此文。此是古人释哭泣等通遍三界。今不用旧释者。但在欲界人中南洲有礼度处。余所不摄。戒取本不计断若。因拟果故。色界火起所烧类中。亦初二句钝使。次二句利使。然火势中文略。不分利钝应须义说。故欲界中亦不分利钝。今色界亦尔。次明相中方具利钝。即相夺等也。既于禅中起诸见惑。带见修禅或禅。已见起或禅见俱发。若禅已见或可见存。或复俱失。所计异者。具如本劫本见等也。言默然者。此准大乘一一禅中各立默然。如初禅中默然第六。乃至四禅默然第五。以着默故失于无漏。依余经论道以着禅。而为默然。或以一心支而为默然。欲界贪未来定已断者。性障未除名伏为断耳。故恶兽啖时方乃名尽。欲界至如猛焰等者烟焰上升以烟过焰。故用譬色。又焰猛烟微如色轻欲重。身等遍于二界四倒。故云四面等也。亦通下亦可双譬二四。故四大皮肉在身四边。如四面咸苦故云克塞。蜈蚣下明空中事者。前云藏穴以譬色界。今乃出穴故譬无色。言空中者非谓虚空。既以舍内譬欲入穴譬色。今以穴外空地为空。以譬无色。色界如穴。厌下如烧欣上如出穴。若尔嗔通三界者。前欲界中以蜈蚣譬嗔。此中例之不别分出。既云蜈蚣复是无色。故譬彼嗔。色界之中虽无蜈蚣而云毒虫。即兼蜈蚣。如色界利云毗舍阇。即兼诸鬼故知嗔通三界。小乘中云上界无恚非尽理也。然诸烦恼轻重虽殊尚至等觉。岂隔无色。但名同体异理须分别。今所烧类略无鬼神。若得等者。若无色定起寻即生着。故名为随。既离下缘定计非想。故云又诸饿鬼头上火然。非想亦有八苦者。文已列七阙爱别离。应云失定时苦。名爱别离。但文中七苦初之四苦。约彼定体生彼细想。刹那不住名为念念。病死可知。次有二苦以对修说修上失下通得名离。次五盛阴复约定果。前四第八在果故也若因若果皆约彼定。故得言之。不处第一空座者。第一义空为智理合与悲同体。今言不住无悲之智。恒居有智之悲。故云不处。故知无缘慈悲方可与智同体。旧云等者。佛岂不知而待他告。又云等者。岂有物机还却语佛云汝子耶。纵感应相关以生望佛为他人者。有何不可。然消经文闻有等言。却如以下语上故不用也。今云去正释。凡云汝者。可施于师。师即法也。他义及上二理俱成

问。真如法界可是佛师。观机三昧纵名为法。秖是照俗如何名师

答。观者属智。智即是佛也。依三昧起照故得是师。虽云观机照体是法。如佛眼观等故有此眼。方能观机义之如遣。又云下约大悲者。他义更亲汝义稍切。以无缘慈望于应身。故无缘慈告于应身。令起化物。云云者。对上辩异出观疏意。但令法正喻且分成。问子本等者。答中两解妙得事理。初事答者。虽未曾出义似先出。虽即非入义似后入。由出未出故入似入。又下约理解者本净故出。无明故入亦从义立。非出非入而言出入。约事解中即退大后。以着五欲而为游戏。约理解中即以戏论。而为游戏。言戏论者。即三界见思。见思即理故出。理即见思故入。如净名中尚以小证而为戏论。故云。若言我当见苦断集证灭修道。是则戏论非求法也。故实相外皆名戏论。故事理二解并于大通佛时。虽发大心未破无明。是故具于事理二义。大善下释退之由及以乐着。昔结缘浅名为未着。退后流转唯有无明。故名无知。即此释意亦具二释。思之可见。四行半颂上我当等。是诫门拟宜应更略分。初一行正明拟宜。次一句总立所烧。即是见思。次一句总明烧势。次两句略明烧相也。次一行半广明所烧。文中杂列见思二类。不复次第。次一行况结。于中初二句举所况。次二句正况。由无定慧是故饥渴。已可怖畏。况复更为浊火所烧。如得上界有漏定时。无无漏定已为小火之所梵烧。况坠下欲大火所烧。即指饥渴以为此苦。是故应求大乘永离。诸子下三句不受即是无机。亦是稚小无知故也。文中略故但云无知。经云犹故乐著者。既无大志复不习小。已无大小复着三界。次第三一句正息化者。见思不已故息大化。若见思不已。尚有大机。如来于时亦不吝大。但缘大小俱失唯有见思。故于二途且令出浊先施小耳。前三行颂拟宜者。初一行明拟宜意。次一行用小之由。由着见思故唯施小。次半行用小之意。若不用小则大小并亡。故云将为火害。害故丧身。丧身故失命。次半行正思用小。劝转中经云妙宝者。仍属方便。如灭止妙离。阿含云妙中之妙等。若妙宝是大。何故皆诣父所索车。示转中经云在门外者。如示四谛令知出世。故重劝中云汝等出来。劝其行相。应须观谛而得出宅。次证转中。经文意者。吾善造车以给一切。验知自必不乏于车。引自无谬证赐不虚。故知以己所用之车。劝其令得。举己例彼。故云在外。经言四衢者。即四谛也。前不许作四浊解者。准此中意。初在门外者。初子犹在内是故父立。今子既出是故安坐。又大机未会。是故云立。小化已周是故安坐。故知立者冥利坐者显益。经云而自庆言等者。得所化机是故庆快。二万亿佛所教其大缘。是故云生。中间小熟是故云育经此多时数数成熟。将养不易故云甚难。大微故愚小起浊由无知。由因招果故云入宅。经多诸下二句述其所起见思之火。经大火下述其被烧火势。经而此下合其见思。经我已下明欢喜之由。经是故下结欢喜意。知父下三行索车者。初二句明索车时。验知上文是父坐也。次二行正索。次二句结索。于正索中。初一行正索。次一行述许。等赐中云上文至合有五文者。无合释等心。颂中合复无广等心。既有等车必知心等。行具一切法名藏者。但约含藏为义。六根具一切法名库者。藏宽库狭。亦可互论云云。但约盛贮诸库不同。如根各异虽异各具。故于诸根具一切行。以行历根。即是根行皆具诸法。即藏深库近。如行远根浅。虽有远近皆具诸法。约根论行无复差别。自非一家依经述释章疏之例。岂可闻此以根以行为藏为库。各备诸法。经大车中意者。因果所有总名众宝。约教修得义之如造。性修不同权宜名造。行多子多故车非一。是故所造诸而复大。又须示方知子修名造。以性泯修造还本有即车体也。庄校下即具度也。初一行如前释。经云真珠等者。出幰盖相慈门非一。犹如网孔。一一孔中皆一真珠。如众慈门并称于实。前文但云垂诸华缨。秖是直令见者欣悦。今云处处垂下。乃明众机遍悦。经云众彩等者。上句明垂化之处。设应不同。下句明摄物之宜。无所阙少。经云柔软者。前直云重敷今加叹柔软。又以贵[疊*毛]而覆其上。诸禅自在故云柔软。以妙冠粗如细覆上。茵者。说又云。车中重席。具足事禅有异凡小。故云鲜白净洁。得车欢喜中云横游等者。诸法在于一行一法权实具足。故虽合一四相宛然。四门至四十一位。具如法说理一四释中。位门二释其义已具。余二已如前说。准上释意本无横竖义分四相。今亦如是。本无横竖寄于门位。而论横竖。亦可谛是约智。前从能照今从所依。望前唯阙观心一种。究竟四德即道场也。九种世间者。秖是九界耳。七望于九但除四趣离开菩萨。以子义通故。世间从九。结缘义局故方便唯七。经云一切众生皆吾子者。如大经中一切众生无不皆至大般涅槃。子义在因涅槃在果。大乘宗要。莫逾此二。皆悉云有。安顺权教云一分无。经云无慧心者通语无实。众苦下于中初二句总标。次二句释。次二句结。经云寂然等者。在王三昧用智。即是安处故也。经云不退菩萨者。不退义通。亦兼三藏云云。长行不合索及欢喜者。以免难兼索。以等赐兼喜故也。合中但合后二不合前二者。于四段中。又是免难索车为旁。赐大欢喜是正。我虽下第三一行半文又二。初一行明障除。次半行遂本心。若人小智下第二七行。具足四谛。初二行苦谛。次二行集谛。次一行灭谛。次半行正明道谛。次一行半明此四谛脱非究竟。于苦谛中初一句标说苦由由小智故。但有世智唯堪说小次一句明以集重故须明苦谛。次一句重指苦由。次一句正明说苦。众生心喜去一行明称本习。于中初二句明机。次二句明应。应中言无异者。如遗教云实苦不可令乐。次明集谛中。初一行正明集谛。次半行显集谛能治。次半行明集过患。次明灭谛中。初半行明灭集功能次半行得名。次明脱非究竟中。初半行重举得脱。次是人下二句征也。观谛得脱为是何脱。次但离下。释离界系但明小脱。次其实下释离下。三偈释者。初一行半以无上道法斥。次一行半出佛本心。明恶数者。今文但云说不说耳。有人分此云。先列恶因。次列恶果。恶因十四。一憍慢。二懈怠。三计我。四浅识。五着欲。六不解。七不信。八嚬蹙。九疑惑。十诽谤。十一轻善。十二憎善。十三嫉善。十四恨善。次恶果中先释。次舍利弗下二行结。初又二。初明由谤堕恶。次如斯下明由堕恶故。不得值佛。初文又三。初地狱者广叙非时。如此分文非不一意。而无所以。次畜生中言断佛种者。正当破坏缘了二因。故前文则断一切世间佛种。此经遍开六道佛种。若谤此经义当断也

问。谤经生罪非经为罪缘

答。罪福由心经乃缘助。其犹四大损益斯成。然从佛元意唯为生福。是迷者过非路咎也。三三贱人。次文又三。初明不值佛。次复入恶道。三复得为人

法华文句记卷第六(下)法华文句记卷第七(上)

        唐天台沙门湛然述

    释信解品

有人以信解相对为四句。钝根正见信而不解。利根邪见解而不信。利根正见有信有解。钝根邪见无信无解。初二二句依何得名。若第三句当此品者。若约小乘得作此说。不合释此。若法执中见等。声闻领时合入七地。云何犹在初信心耶。有人以通大地信数慧数为信解体。今问。体是何义指心所耶。如此心所圣位摄耶。凡位摄耶。若圣位者大小圣耶。小非今意大深浅耶。况今闻实而领解耶。故信解今经已入初住。则非小乘心所所摄。举一例诸余皆准此。有人云对前七异不成异也。一所从异。今谓不然。三根闻略悉生疑动执。但信解前后何得云身子从疑。此中从执有疑必执有执必疑。况疑执名通而须简小。小乘疑执见道已除。安隔二酥仍须互立。二广略异者。此亦不尔。但文异义同。故身子云。将非魔等及述五佛。言略意广岂名略耶。三远近异。此亦不尔。文义俱同。非但此文述道树前。身子述本着邪见时。亦过道树故无异也。四通别异者。此亦不尔。文异意同。身子既云我等不预。又云我等同入法性。又云若我等待说所因。又云我等不解方便。叙失之文四度云等。岂有述得别在一身。此虽列四僧首又局。是则身子通及一切。迦叶别在四人

若尔初周何不多记声闻

答。四众八部即其人也。第五不论。六欢喜异者。此亦不然。若言身子独有先忧后喜。前置等言则忧通一切。故知喜虽前后忧无等降。七云一四不同。不尔之意亦如向破。有引婆沙云。身子上目连中余皆下者。其语似同彼小今实。文意永异不可雷同。正法华名信乐品。其义虽通乐不及解。今明领解何以云乐。今未释品名。便引古人判品意者。释题失所由失文意。于中初通列三时。云一往等者。以此品内具领始末。退大之后更以小起。以为一往。中间为随逐最后为毕竟。古人但得三时之名。不了其意。今为五时。加于探领法身之化。尚恐不了四圣之情。但作一往等名。焉消此品。故须引破方识正理。总有六师。僧那者。此云弘誓。次私谓下破。初总斥者。书云。剉丝盈箧不可织为绮绶。玉屑满匣不可琢为圭璋。诸解碎乱不堪依准。夫一往下别破。仍先标初后略出大旨。中间例知。次正别破中。初两句纵而破之。乃许第二第三一往。故以其一往而破初师及第五师。次若法华下复以第五师一往。对第二一往。而为例并。次又二乘下以第三师一往。破第一师一往。于中先并破。次若一破一不破下立例。次又父子下单破初师毕竟。遥见其父。即名相见。名毕竟者。华严教时已应得记。则法华无用。若后毕竟下倒并。若后是者前无复用。若无复用昔日闻大结缘不成。又若第二三四师所立毕竟皆在法华。意则可尔。一往随逐近远难依。第五师一往既同前破。随逐毕竟非释法华。岂有现在一化。必令至于金刚。第四师章安无破但是略耳。其云一往在于转教。则转教已前向非一往。为何所名。以得悟为毕竟。五品六根复非一往及以随逐。为名何等。然诸师毕竟皆不破者。前四及第五多分皆至法华。云至佛果。纵有小失而无大过。但不可定以金刚心为毕竟耳。今师意者。一往等言待至下根论宿世时方可商度。以人天乘及以说大在往昔故。往昔已后皆名随逐。如何二三四师。以今世三味而为随逐。故不用之。次私谓下破本迹者。若指此为迹。应当已是本门动执。若预说后品乃是此中成显本竟。后文无用故不可也。今释品者下。今意且论中根信解。故先以三周之初十义中五。而判其意。夫根有利钝。即前转根。不转根感有厚薄。即前惑有厚薄。说有法譬。即前通别。悟有前后。即前悟不悟及悟有浅深。余意非正。以是义故。所以三根前后领解。何须于此立一往等。豌豆者。若作剜刀剜字耳。二乘之人于法华前。如生豌豆钻刺不入。但念空无相愿者。是其当教入无漏门故常思之。欢喜踊跃等者。文中虽以信等四字。用对信解以为为人。此善必藉初欢喜也。况理善生破恶获证。圆融四悉一时俱得。即分证之第一义也。余之三悉当位为名相从云分。故此四悉发必俱时。但以信解对为人便。且别言之。此乃通中之别耳。此中何故四悉俱实。以从闻法得解故也。不同前文列众带小三悉在事。第一义悉仍须教分。五时之终方辩今意。次禀小下约教释。此欲约位以释信解。应具列四教。但总标云禀小大教。小即三藏大须指圆。且略中二以大小教无不皆立二行二道。故先明小。次准小下以大望之。乃分两字以属二道。破疑故信进入名解。信通二道解唯在修。故云修道名解。若准此意但应初住以为见道。初见理故。初住加功名为修道。依理修故。文中不云二住已去。但云进入即从初住必有增进。故诸声闻闻法已后多入修道。今从闻法增进边说。故云信解。亦如十六心名为修道。若昔密入至此灼然全成修道。从显露说信解同时。次文云下且通证入位。不分信解。近领火宅等者。闻譬解已必解于法。岂有悟后而更迷前。是故皆须法譬双领。慧命二释者。前是因缘。次诸慧下约教。三一对辩从事行异。故属因缘。佛命转教属约教者。此有二意。属熟酥教已名约教。至熟酥时冥成别人。复名约教。亦应具对五味四教。思之可知。三弟子下释疑。非全不转多少论耳。新名具寿具不及慧。寿岂过命。譬喻四番者。长行偈颂各有总别。亦可各有开譬合譬。二途四番各有开显。然前释胜则应后文二十二番。心发至意也者。准此但以闻譬信生入位。即初住去不论见修。例身子等者。发希有心心领解也。即从座起身领解也。而白佛言口领解也。应注云云。令如向对。具如身子领偈。文无者略。述僧首等三不求者。述昔失也。初失者。执小腊则大法全阙。不弃小由未识开三。自固则小执未移。护彼乃迷于大轨。第二失者。一生断证。是故自鄙年高。败种未袪。不任之见仍在。第三失者。昔迷义旨徒计正位之功。由斯固情大心难发。高原下引譬自斥。先譬次合。已有得故所以不求。经云但念等者。亦可具依俱舍。出十六行以为所思。十六行对三空。如止观第七记。或指至为僧首不求者。由居僧首。故于小大诸座久闻。无量珍宝者。昔般若领教谓为菩萨。岂图于今全蒙等赐。咨发下云云者。应如世礼欲有所决。须先咨发。譬文为五。始自相失。即结缘已后。终至等赐。即闻譬之时。若合四五秖成四段。故光宅十譬不应今文。故前文云。于四人乖离。离破光宅乖斥余师。余师虽不离为十譬。对当文相又亦乖张。具如前斥。西方等者。弥陀释迦二佛既殊。岂令弥陀隐珍玩服。乃使释迦着弊垢衣。状当释迦无珍服可隐。弥陀唯胜妙之形。况宿昔缘别化道不同。结缘如生成熟如养。生养缘异父子不成。珍弊分途着脱殊隔。消经事阙调熟义乖。当部之文永无斯旨。舍那着脱等者。迷于舍那不动而往。弥陀着弊诸教无文。若论平等意趣。彼此奚尝自矜。纵他为我身还成我化。我立他像乃助他缘。人不见之。化缘便乱。故知夫结缘者。并约应身。如云我昔曾于二万亿等。况十六王子从始至今。机感相成任运分解。是故不可以彼弥陀为此变换。非结缘已界等者。本结大缘寂光为土。期心所契法界为机。退大已来机土全失。今流五道望本为他。方便有余尚非己界。况复五道流转者耶。今穷子所居现处五浊。且以所住望本为他。自尔已来常在三界。故云久住。此缘至长大者。机中稍厚且与著名。仍未复初但云三十。缘既下以苦为机。故知犹在小化前也。到而不识故名为遇。是昔曾见故名为本。苦为机者。既失大小唯有生死。于生死中有机可发。冥扣妙应大悲之城。大应尚疏机且对苦。一念失子苦等者。以念子苦思种种门。念令得乐复思一门。虽复双念二俱未克。今忽得之从本志说。当宣佛道且云一门。子既下释上两意。初弃大善而入生死。故云不当。前释譬中门有入义良由此也。故动父忧释初意也。离种种诱父意。元以圆门通之。当有得义预动父喜释第二意也。初譬如至领耳者。第三经初述领不及意在此也。十界七善进退等中。菩萨最难。以兼三故故别语之。菩萨尚然佛界永绝。解心无力至长大者。昔修观行虽观理即。未入似解不能除浊。故云无力。义之如幼。退大已后名字全迷。义如厚重。内熏如加故名为被。大仍未遂但可先小。大善当遂名稍欲着。此探后说也。逃逝等者。佛岂舍物隔故不见。义当于逃。言生死五欲以为他者。既大涅槃方成自国。故且以五道流转为他。或十至五十者。自退大来升沈不定。故着或言。幼有二义至耽述不返者。初标二义。则不下结成。次譬下合譬中云结缘已后。一句总合通贯下二。次大解下合初义。尚有下合次义。由发大已来三惑全在义之如痴。解心虽薄冥资远渍。密益不轻以缘微故。挫言残福。自尔已后未坠三恶。名未遭苦。但保世乐故未复初。次今习下反上二义。初文反前初义。既微向道有断惑义。义似免痴。遭苦下反前次义。纳种在内故曰冥熏。复被中间外缘击之自尔微发。复由遭苦为助发缘。故善恶两途冥显熏被。此二为机者。若宿无大缘及中间小熟。借使遭苦机感不成。秖由大小两业冥熏成机感佛。佛居本国义当向国。若以人天等者。若无大种单人天善无感佛义。不独为人天垂八相故。若有出世机缘诸佛菩萨尚入恶道。况人天耶。在三界下明诸子等大善未熟。纵生人天亦未感佛。今佛下以有斥无具指四见。明机成感佛。及佛出机成。若通论机虽通十界。终于十界取出世机。今从别置通用消此品。是故下文东南方梵云。一百八十劫空过无有佛乃至上方云。于无量亿劫空过无有佛。大通出世乘光而来。当知中间皆蒙冥被。于中求正道等者。以计常等而为正道。种种苦行以为助道。虽思惟邪理堪为正机。然由久远大种熏被。大经云谛观四方者。大经三十如恒河中七种众生。第一人者入水即没。譬一阐提。第二人者出已复没。有信故出不修故没。第三人者出已不没。即内凡人。第四人者入已没。没已出。出已住。遍观四方。身重故没有力故出。习浮故住不知出处。机遍观四方。譬于四果观于四谛。第五人者入已没没已出。出已住住已观方。观方已行。怖故即去。譬支佛也。第六人者入已即去浅处即住。何以故。观贼近远故譬菩萨也。不住生死故去。安心故住浅处。第七人者即至彼岸。外道得度皆由观谛。与观方义同。是故暂引。本国如上者。上以佛已界为本余皆属他。下文下问下城舍与上国何别。一切下欲辩同异重释出国。一切佛法与上佛界语异意同。城舍亦尔。断德还须具足佛法。大悲亦从断德而成。此二咸收一切佛法。但约取机以国望城以城比舍。义立疏密。但由一切佛法义宽。断德御恶似狭。大悲对子更近。同是长者实慧所依。同是应身权智所托。起应之前机先扣此。故云至国城等止国城等。中止一城等者。且以一方一类而为一子。故次合云不为一处。处必在人秖是同居。人类未熟且止方便不废化仪。娑婆指彼以为余方。若准余方之言。应指十方国土设十界化。具如妙音。娑婆既然。他方准此。此中仍存思此同居得子便故。且语有余。若云垂形六道事则不便。流转之后岂不然耶。今机既亲须从胜说

若尔。何不云在实报土耶

答。理非不然。实报义对发大心时。故退大后思同居机。复消中字义便故也。旧云下叙旧。今谓下破。今取下正释。还于有余国中涅槃名国中之城。亦住此涅槃之中。名之为止。又依此涅槃而为所居。故名为家

问。向答问云以此城为断德。以下含为慈悲。何以至此。云城是有余家亦依此涅槃

答。国城家舍虽宽狭异。并是所依有余不逾断德。今家对珍宝故云实境。下舍对子机。故云慈悲。故知云无缘慈悲。必须等于实相。故二舍义一随所对耳。上句既云求子不得。即依自受用土一实慈悲。求子不得。故今止于自他中间住于方便。还用本所依慈悲而思于子。故国为居民。城元安主。家本养性。为未入圆者。即七方便民垂形方便。住彼有余思求圆机。是故居彼化事无废。思同居机其义文成。家既是舍。于彼有余运无缘慈。故云处此。所以止于无缘慈家。起于胜劣偏圆两应。然彼秖应但用胜应。言胜劣者。胜兼两处。劣唯鹿园。小机若起理当赴之。始末双明故云胜劣。既云五人彼土生者。皆为菩萨。故八六等至彼土时不须小化。渐趣圆实岂仍滞偏。习方便者多迷其教。止观第七判八六等教道须废。法华开显方堪此闻。菩萨机成所应何别。五人即是四果支佛。从本立名。云须陀洹乃至支佛。断尽乃云断通惑者。或取三藏二乘及通三乘。为断通惑者。此亦可尔。三藏五人自摄通五。通教菩萨先名菩萨。不可更云至彼皆是菩萨。当知全指两教二乘兼通菩萨。若以四人例通菩萨名皆为菩萨。有何不可。但彼对胜应其义不成。但两教二乘彼尚回心。通教菩萨岂应守旧。若准改观通别菩萨并须发心。故云训令修学。不云别者以此五人证同故也。若也通论方便人数。则应云九。藏二通三别三圆一不得云五。今且对小故云五耳。大富至无量者。土虽有余亲所依家。不违实相。言无量者。具足六度。大富总称财宝是别。虽分财宝般若导五无不成实。况一切行皆成珍贵。故云无量。金银等者。等及余宝即余助行道品故也。宝不出七可譬七科。是故七科六度收尽。故大集中三十七品以为菩萨宝炬总持。其贵如宝其明如炬。破暗中最。具一切法名为总持。言大乘者。应云圆乘。文从便耳。言禅生百八者。达禅实相故也。自资等者。智定各有自他故也。具如前释。僮仆等者。方便波罗蜜约自行权满。屈曲去明利他权用。并僮仆之功也。如布衣所使共至贵位同成体内权也。事理不二故俱云称。就位等者。向通约方便但云僮仆。从位别判摄藏通别。望实望正义当贱役。通论亦可收得人天。以异方便即此意也。别圆十地者。仍存教道故立别名。以无两重十地故也。向僮仆中已有别三十心。今臣佐位是圆四一心也。兼收别教十地而已。率土下释臣位等深浅之意。所收既多名为率土。虽同佛家不无等级。初通皆圣故。虽得下即是十住得入圣位。同王所居真实土境。而位最下故也。始从十行终至如臣。并是圆渐故须圆释。次一心三观至二乘之法者。次明僮仆臣佐吏民所乘。所乘不出诸观故也。随教用观即当所乘。然此境智虽即随教。同为圆人所用驱策。虽通因果不同历位别别当分。故此因果并是圆家之所用也。无数者。以此诸法不出权实。臣佐吏民所用实也。僮仆等所用权也。此亦一体权实也。并皆长者之所有故。非但下结摄前释不出教观。教观多故教教四门门门有观。虽复无量被物无余。入出两字文中四释。初三自行后一自他。于自三中初以双非为入双照为出。次番者。出入相对本相即故。出入之名亦更互得。故此智体出入互照。此之两释约三谛说。次无量去约二谛说。二三开合具如玄文。第四还用向之三二。自利化他。故知此皆圣位自他义含意富。故须众释。此是观谛复唯在实。对权义立有何不可。但以二对不二二已摄权。故不劳也。行于非道者。理通三土。法性之外皆名非道。从法性出益三土生。功归于佛故云归己。此但功归法性佛道。商估等者。应作贾字。谓居卖曰贾。通物曰商。若作价字非文正意。非但佛自化物无边。亦令菩萨化境周遍。菩萨化利犹资佛本。往来诸国具如诸经十方菩萨来往受益。华严大集即其例也。如世间下譬向二释。令他如菩萨亦自如二身。初内合等者。初通谭大意。次观下明邪慧所观。云观察五阴等者。还以邪观观阴断常。以此邪慧冥资于正。成见佛由。苦境为机者。牒向邪慧助正成机。然外道苦因应招苦果。故云苦境。由带正种熏邪慧心。故得成机感佛正慧。涅槃通半满者。名同体异并现所居。化物名殊佛境无别。故子所到二义双成。机熟若证证父所证。名到父城。此乃小机先扣大应义立穷子已到父城。故使城名涅槃。大小双得。故以半满共收物机。机既不同收亦先后。父母念子等者。前虽机渐扣圣。今明圣渐收机。化道之仪且云忧念。未曾向人等者。文约两意以申此义。先方便。次此土。初方便者。彼方便中非但唯有地前住前。亦有垂迹登地登住。即臣佐等岂全不知穷子机性。但约穷子说时未至。主伴相与覆实未宜。权从物机故云不说。以由界内五人断通惑者。未堪影灼闻如是言。故云不向臣佐等说。以为臣佐意在僮仆故也。于中指小故云不向。所以在长者心无非己子。从机异故立以小名。渐渐诱之方成臣佐。故知法身本自悬鉴。又应世已来下第二意者。进明此土昔教显露未说。对此蔽彼故云不说。是则前立胜应之义。义兼两处。劣应之语逗彼偏机故不说之言通及四味。四味之内具足臣佐及僮仆等。既非下释第二意中小乘人也。如聋哑等。指华严席。或华着等指方等也。不逮之言兼于般若。而无希取即其事也。华着即身子。弃钵即空生。故知不说之言。何关法身菩萨。心怀下却释远由。远由即是不说之缘。良由昔结大时未入相似。省己斥彼故云不勤。由此退大失中途调熟。故云无训。背自向他故云逃走。逃走三义。一机息应谢。二背自向他。三居不得所即五道也。故使如来无缘而忆。恨子下专斥于子。非但悔应早息亦乃恨子机生致令疏我正法亲他六尘。内合等者。为论免难须净六根。准理退者多在五品位前。为对不退位。且以五品为退位耳。文释悔恨分对自他。准意亦可并对彼此。化期等者。约后意释。即应世来至法华前。故云老朽。亦不约此等者。不约应化声闻故也。胤者嗣也。继也。若身子受决至不断者。验知授记为引物机。权实皆然故云后来众生等也。更修净土与物结缘。身子成时开权显实。则佛种不断于彼方。机缘成熟于其土。其中亦有种在释迦。脱归身子。故须此会彰灼发言。若身子无可化下。反以无释有。若身子自无成佛之机。则身子所化安得成耶。故以此显今令有寄也。经言终没者指涅槃时也。复作下第二意者。前明失苦本显得乐。故着我若之言。以现说当举生领熟。总譬具论始末权实。故得双辩胜劣两应及以劣应化道始终。故譬本中前一行实后一行权。况开六义权实相对。法譬至互举者。感应道交不前不后。但随文便互举一边。先出不同。次就佛下约生佛互论。如止观明感应意中先凡圣相望互为因缘。次感应道交自他破已。方乃名为不思议发。今取文便者。今此虽有三文。且依二文消便。非即二文使见有前后。故别譬之初还从退大之后在五浊时。故有三文也。见父之由至展转者。由厌苦等。见修二性俱有厌义。修推理弱见生夺钝。诸见互兴皆能推理。佣赁之法以力易财。本起邪见还希脱苦。虽复邪求冥资正道。故使世间厌苦遂成出世善机。世易出世故云佣赁。从一至一故云展转。言善根者。犹是可生之义故有转至之理。故云以此乃至父舍。不期而会故名为遇。不意因于世法。忽感出世慈悲。又不意世间邪推而生正见感佛。又不意小善之内。冥入大乘圆门。大小二机双扣此舍者。大机未熟正见而遥。小感稍亲门侧而近。所以从退从末义当双扣。从本从大独在于圆。从近而谭偏机先遂。见父之处即门侧者。前则大小双扣处乃独指门侧者。以小亲故。言二观为方便者二边俱有得见之义。故总借证之。二边并偏偏真最僻。正见有二至为遥者。于正见中。又分此二。近即华严中诸菩萨众。远即二乘。二俱未合但在门侧。文中二释。先机次应俱名为遥。踞师子床作所表释者。事师子座亦无师子之形。但有所表。故大论云。佛为人中师子故佛所坐名师子座。佛之所说名师子吼。诸声闻人述佛所说。尚得名为作师子吼。部虽兼别从胜从本。故曰圆报。此乃取机之本。故此下去皆须圆释。宝几等者。一几承于二足。定慧所依无殊。从定名谛从慧名境。具如止观第三。故合云无生定慧依真如境。即定慧力庄严法身。从所名能故云无生定慧。言依真如境者。托境成观故名为依。果体起用复名为依。又从因说因性有修故名为依。旧云下出古释。稍似别义非今所用。准例易知故不须破。次旧云此经下古有四失。一法身非常。二他方为此。三以应为法。四对面违教。今谓去破中言父子等者。父子譬机应先譬后法。着脱譬体用先法后譬。二俱不成着脱义异。前文已破。从又不容下更破他方自有三节。此师亦以他方为弥陀。若以尊特为弥陀者。此有三失。大小两机并在今佛。乃成见垢衣为扣此。见璎珞为扣彼。结缘亦尔。又往昔大小两缘俱在释迦。今尊特垢衣俱在弥陀者。更成可笑。故第三重立难难之。往缘大小定在今佛。岂应今日双应他方。又何得大应在彼小应在此。平等意趣义亦未成。具如前破。今明下正释。此则续前应世已来释耳。故知胜应在华严也。今经下破非常住。古人皆云。涅槃明常华严法界法华不明者。不晓部类兼但对带。垢衣乃是叙昔之说。在昔尚无垢衣之言。何有常住。所说法相至无别者。今经意在结会始终。设论法相如彼圆说。今非全无文相存略。华严部内不出四十二位。依正自在近善知识。今经明位。具如四华。开示悟入。知识具如观音妙音药王严王。依正具如分别功德宝塔神力。但广略少异举一例诸。故下疏文十义辩异。且如十方之言。何所不摄。实相之理无事不收。岂迷广略而失大体。总如玄文十妙引诸文证。即其相也。人不见之妄生去取。故此经空无所有等言诸法实相之说。见佛常在等人。此土不毁等事。堂阁种种庄严。众生种种游乐。乃至迹门因果诸相。多以华严文消。算数孔目藏在此典。行头取与散在诸经。大本若亡徒论小利。居士至即三十心者。中止中以民为十住。臣为十地。今居士是民以文狭故不分臣等。亦圆四十一位也。真珠至法身者。并究竟戒楞严定一切种慧法音陀罗尼庄严圆因四十一地。地是所阶身是能阶。四是能严身是所严。若用远因亦以初心圆戒定等。以严性德。若从因说亦四十一位之所服也至果同皆严极法身。言价直者。有贵贱故如诸位也。吏民者等。向列围绕不云吏民。今明侍立则与僮仆共列。故知立名随义不可一定元譬事理何得守株。故前以吏民在实。今此吏民权摄。故在同异二门。跨节为同当分为异。是则同为同体异为异体。异约施权同约开显。秖一吏民义当两属。内与等者。释向同字。同从内同得名外同为显于内。喻如下喻向二义。犹如良吏内应主意。外用驱使。亦如要臣于内则为国股肱。于外则民之主长。臣体无别所对不同

问。此中虽是华严座席。胜应相状与前中止义意大同。何故前以僮仆为别教贤位吏民为圆教圣位耶

答。言虽少别意亦不殊。随其言势逐便消之前僮仆之外有臣等四。故别分之。此中但云吏民僮仆共为一位。以为所使。又此中意断别惑者。即入地住非驱使人。又此与中止虽即同是他受用报。此既示入忍界为菩提场为诸教之始。故加之以破尘白拂。覆之以慈悲宝帐。前叙长者所居所有。今明穷子所见所有。所有既同广略转用。侍立下云云者。此中既为中道方便。并宜地前以释吏民。中正二旁民主异故。准部应明次及不次。乃至两教教主不同。各有侍立拂尘相异。垂诸华旛者。四摄现通利下为垂。虽华旛并垂。而华严于旛。如通有四摄见者生喜。又虽旛华俱动得名处殊。旛寄翻转华约端美。神通下化令物欣悦。运此二者必上等无缘。故并悬之于帐。用称于体如遍覆佛上。香水等者。若约自行如第二释。若不洒以香水于地。则帐旛华为尘所坌。故以智香水洒实相地。除三惑尘。则如来长者慈等俱净。若约初释香水洒于菩萨心地。既从利他修因以释。故知七净须从菩萨行因以释。名虽同小此即圆教。故举三聚及楞严等。若依方便随教义别。今依圆心皆由此七布于诸地。自行行此令他修此。是故文中并依圆释。罗列等者华表因严宝表果德。因果万德皆严实理。故使布列皆在于地。地非华宝而布列华宝。理非因果而修证因果。出内如前释云云者。指前四重。但前唯在果今或通因。相海者。全指华严如来相海品。及以随好光明品中明毗卢遮那具足十莲华藏世界海微尘数相。一一皆以妙相庄严。故云须作舍那释之。四见父畏避者。父子相见虽譬感应道交不可思议。然约化事渐教以论。若云父先见子是如来鉴机。道理如此。今云子先见父相及处等。非即已见。并是约机应具述始末受化元由。或是王王等者。既云见父畏避。即在顿渐教初。若据顿渐之前。未有畏魔之虑。约渐机对大论畏避等。故曰未曾见闻等也。从略开已下以后验前。验昔可中。初与于大过于身子闻略说时。故云有过今日

复次下重释意者。小机尔时岂知二身。故是述于机中不受。犹如穷子见王王等

问。法是报师师弟义别。如何齐等

答。此是等师之子如法报相称。诸经多名经王等者。重约教释。诸经有明法身义者。即名经王。智契于法相称名等。故约机中对法对智。名王王等。即诸部大乘与小相对。世人不了见诸大乘皆称经王。乃谓法华与诸教等。今谓乳及二酥皆谭法报。虽俱称王非诸经王。纵有经云诸经之王。不云已今当说最为第一。兼但对带其义可知。肆者放也。泄也。申也。次时富下见子譬者。然诸声闻向施子见父譬。巧喻领小遇大而机中不受。今设父见子譬。妙喻领佛见机。而不谋恒了。见子处者。如来不起空座欢喜适愿。故但约化仪言父见子。岂以佛眼必待子见后父见耶。今机来称慈者。大小并得名为来称。彼明拔苦等者。譬品也。亦应云前譬如来与慈惊其堕苦。此譬诸子领受荷佛与乐。如来拔苦本在与乐。子领乐已知拔苦。二处义同随文互出即作是念至不得者。此亦述于退大已来。既入五尘大法非治。寻谋用小小又来遂。今机渐来方施小化。言取小者。非谓往时已得于小。亦非今世渐初之小。是故往日不名机来。谁论付财。亦无欢喜故但云昔见欲与等也。今日至有所付者。见小机至知大非遥。是故喜其是付财地。我常下却释向来退大已后。顿渐之前无时不思大小二化。虽大小并失以流转对悲。故使今时付财有在。今有可度机生等者

问。机生由佛那云自来

答。虽机生由佛感亦由生。且寄世长者叹子自来。昔机不生望今可发。应叹机发称为自来。若机尚生追犹不至。安能自来。我虽下探说后期。傥一期报谢无付故惜。如唱灭度法皆随灭垂灭尚惜。故名为虽。即遣旁人等者。从此方领施顿渐化。故知尔前譬顿渐前若大若小。但方便品至并领者。意云。文虽增减意必俱存。方便既为上根。是故不须别说。譬说既为中品故须离总出别。合及颂中虽复阙略。以譬为正余并互兼。今既领譬应须遍述。言但方便品总诫劝等者。恐寻者纷纭。更重疏出。方便品文释迦章中。但云寝大施小虽不云劝诫之别。语意在劝。故云于三七日中思惟如是事等。即大拟也。众生诸根钝即无机也。如斯之等类即息化也。即趣波罗奈等即施小也。虽不云诫义含二门。火宅开劝出诫者。故从法说于劝开诫。释各三者。劝门中三。初云长者作是思惟等。拟宜也。复更思惟是舍等。即无机也。或当堕落等。即放舍也。诫门三者。初云我当为说等。即拟宜也。父虽怜愍等。即无机也。东西驰走等。即放舍也。长行合劝不合诫者。劝中有三。初云如来复作是念若我但以等。即拟宜也。所以者何是诸众生未免等。即不受也。如彼长者虽复等。即息化也。言息化文广者。先牒前后三譬。次方以三合正明息化。初如彼长者。牒初不得一譬。正帖息化。次但以殷勤下牒施小。然后各与下牒等赐。此两旁合息化。次如来亦复下一十六字。始正合息化故云广也。偈中但诫者。亦具有三。初方宜救济下四行半。颂拟宜。次诸子无知下三句。颂不受。嬉戏一句颂息化。已下属用车文也。此颂譬文则具有三。但颂合中亦但合诫。有一行长颂仍进退二释。初释亦具有三。虽复教诏一句拟宜。而不信受一句无机。于诸欲染二句息化。又云。或可下二句亦颂无机。依第二释故云不颂息化。即遣旁人下出并领也。然义则有六。文但有五。先劝诫各二。谓拟宜无机。次劝诫合一。即二门息化

法华文句记卷第七(上)法华文句记卷第七(中)

        唐天台沙门湛然述

次遣旁人者。约教约人。约教则理教相望。约人则师弟相望。人必指教教必待人。二释方周不可偏显。初约教者。理即法身智即报身。由智故说智为能遣。智虽能遣所依者理。能遣如臣所依如王。所遣者教故理正教旁。故报望教报亦名正。然报由理成理亲报疏。故二正中从亲以说。又旁人者下约人释者。贤首品后十住品在忉利天。十慧菩萨法慧为首余之九慧各以偈赞。次法慧菩萨广说十住。次夜摩天自在品有十林菩萨。九林亦各以偈赞已。功德林广说十行。次升兜率品有十幢菩萨。九幢亦各以偈赞已。次金刚幢广说十向。次升他化品有三十六藏菩萨。金刚藏为首。有菩萨名解脱月请说十地。是四菩萨说此位时。并云佛力故说。故名所遣。次释疾走中亦约人教。先约教中但以显露为疾。若以菩萨下重述约人。菩萨自有神通又被佛加故名为疾。乖心等者。乖必不识惊必愕然。如睹不意乖心不识。此教于彼亦复如是。称怨大唤者。经但云怨而不云苦。疏文释中即以大唤为苦痛。所以具有二义者。逢怨必苦故以大唤拟之。义理合然。若令烦恼即菩提者。即是令其不断烦恼。烦恼不断必招苦报。岂有生死即涅槃耶。是故称怨大唤义当因果。文意两申。自念无罪等者。自省未能同物入恶起贪欲等。今若为之名为罪行。菩萨必入生死牢狱。故云囚执。无大方便者。无入假智令起贪欲入生死。名失慧命。必堕下二释。堕三途苦则大小咸失。溺无明地地须义兼界内界外。约人为使者者。取机之法须同类身。净名等者。遣化菩萨往取香饭。彼菩萨见问化菩萨。化菩萨答以彼菩萨闻说秽土佛及菩萨能此劳谦。彼闻欲来成双流行。彼佛诫曰。摄身香等。彼来于此亦令此土未发心者发心。已发心者修行。故令摄胜从劣现同类也。普贤入此等者。普贤菩萨身量无边音声无边色像无边。欲来此国。乃以自在神通之力促身令小。阎浮提人三障重故。以智慧力化乘白象。亦为不宜见于胜应者故。菩萨胜报亦不可令二乘见之

问。若尔。经何不云汝勿令见威德之身。而但云勿强将来耶

答。身若同类诱之必来。汝身犹胜必令彼惧。故告使言不须强以胜身化之。故云勿强。勿强之言释成前句。私谓下此中虽无思惟之言。譬文诫劝并有此语。劝门拟宜云作是思惟我身手有力。诫门拟宜云如所思惟具告诸子。故私引之。须即生善故云不须。即息劝善。强即诫恶故云勿强。即息诫恶。宜以至如而也者。观其秖宜闻生灭教。取灰断理说有理之教。故云理水。面者以向释之。有背生死向涅槃机。故名为面。非谓洒彼涅槃名面。莫复与语语秖是教。不语他人至菩萨也者。此中一往但云昔小。然法华前诸大乘经不说二乘是菩萨者。将护二乘岂关菩萨。覆实护权故云覆护。亦是覆阴将护不彰其实。故法华前一实之外皆名随他。且隐四味之言。通云小乘教耳。以昔二味犹有小教定无小乘作佛之语。故乳及二酥并对小机。云不说耳。乃由弹斥加说得二味名。即是息化至从地而起者。此中二释。两地不同二起无别。故息一大化离二种地。赞大坠苦故有前释用小取得故有次释。次释中云无明地者。若云卧地则譬二无明。若言而起。则且从界内。故知不解大小具二无明。并名为卧。今逗小法先治界内。故且云起。于四谛中至衣食者。宜趣所对之境。故云往至。小仍在机故以欲释求。下句方云长者将欲故也。境摄法狭故云贫里。欲趣小果还须正助。故云衣食。又以他日下取意领法身地者。言中且云在道树前。意则俱指渐顿教前。以云致难尊特。故知通至顿前。问四大弟子等者。答中意者。既闻譬已具领二周。入大不虚故自推云若始等也。纳法既重必有此知。约化仪说从容进退。故先齐后探耳。岂有自获小来方五十载。具睹菩萨难思境界。遍闻诸法一切融通。非全不知。然未测本源省己绝分。今蒙法譬分染圆常。推知如来往日先照。故下佛叹甚为希有。故以二味所睹。验先见非真。脱大小相者。相为大相海好为小相海。全隐无量相好海身。故譬云脱。相好难量喻之于海。密遣二人者。于中先释二人。次初拟下方释密遣。人是所遣密是遣意。初文先明但二之意。故对菩萨且通指二人。次约法下约法约人以分二也。次释密遣者。先对旁人以辩异。即之与密显覆异耳。今明密遣者。覆实名密用小为遣。覆满明半准例可知。即是分字解也。亦是从大施小故云遣。小不测大故云密。然半满字不同古释。今须在圆。具如玄文。约人准知。形者下次释形色。亦具二意。初直约小教。百劫所种虽在小论。不在二乘。故二乘教无好形色。又说无常名为憔悴。次约人下隐本为密现迹为遣。具如下文富楼那中

问。若准下文唯发满愿及阿难等迹。为诸声闻亦有本耶

答。入大乘论云。不但罗云独是菩萨。如诸童子阿难难陀及调达等。皆是不退菩萨

若尔。唯权无实

答。以权引实。岂此等外。悉是权耶。此亦义当本迹释也。若释无威德者。随于形色以释。大教等者。前大教疾故云即遣。将护小志故云徐语。倍与等者。于中二释。初以戒善谛缘相对为一倍。戒善在欲谛缘出界。又外道下漏无漏相对为一倍。亦是内外二治不同。名为一倍。六行非永断故且云伏耳。略如止观第六记。穷子若许等者。对彼不许故须云若。化仪容与苟顺物情。故云也。不论净佛国土者。净佛土义略如净名佛国品中横十七句竖十三句。广如华严回向中说。涅槃大集智论等文。并皆具明。小乘无此但令除粪。故得记已。方乃造修与物结缘非关行具。二乘至先取者。先问价直。故云先取。非谓已领故云慕果。其父见子等者

问。若愍而怪者。何故密遣教其取果

答。旁追不来事须密遣。虽教除粪非父永怀。欲有彰言委付。故先愍而怪之。齐此是领法譬至其文竟者。此是寝大施小二处并有前段文竟。自此文后法说但有开权。譬说唯有等赐。并阙中间二味。若论探领法譬二处虽无正文。但指法譬能见之眼。即法身也。故齐教领且领渐初。以所禀小。名为齐教。别有探领故云又以。于中先总述来意。次列章。文开四段。云拟宜等者。意云。佛在法身预知我有大小四意。故云拟宜等也。次释又字。先释字。次释义。次释他日者。释他日两字。于中先离释两字。次齐教下约齐探二领合判两字。初离释中其义则总。以未分于齐教探领。次合判中其义则分别。自他等三为教探故。初文释他为二。先释次判。先释者。约二乘人以小望大为他。次判者。向约二乘虽以大为他。未知此大元用何身。今故判之即法身也。次释日者。于法身地以用权实。实自权他。二乘法中无法身之智。故名为他。若从下判。若从法身用于权智望二乘人。亦名为他。此他须指佛之权智。次合字释者。于中三释。即依大经随他语等及化他等语。有为法式。仍对齐教探领二时。文为三。初释三相。次若从下判今所属。三今从下用今意结。初又二。初约化他即指齐教。次约自行及以自他即指探领。言齐教者。即法譬二文但至鹿苑。依教所以故云齐教。所言探者谓过探也。探向道树寂场之前。初齐教者。既属初义先约机说。是故齐教但领化身。即非化身时为他日。次从若就去探领者。又为二。初正明二义。次此之下结也。初文者。虽是法身既以自行对他。故以化他权实俱他。所以二乘昔亦不测其旨。此中自行之语似于自他。以对自辩他俱有权实。故双言之。次自他中自之与他各单语权实者。准理合双。此中语似自行。为对化他成自他也。所以自行亦指化他为他。自他亦指化他为他。故知探中皆指法身时权。二乘于彼虽禀小化。同体之权二乘不晓。于佛二自皆指同体法身时权。虽有两意他日皆成。次结中云若有若无等者。结于法身权智所照。若有机若无机也。言可否者。明法身用智逗物称机为不可称机为否。时至为可。待时为否。虽有有无可否。皆是权智权机得他日名。次判中云若从等者。判向齐探。探领自他者自是第二自行他是第三自他。应重云自方显第三义也。并是对法身为他故非二乘事也。虽有两意者。齐探两中俱有他义。故云俱成。齐中则以法身照机为他。探中二义则以如来自行之中。皆权为他。他即二乘所用。虽有二乘所用及非二乘所用。两意不同皆得他名。今依下属对文意。今依二乘所领即齐教探领也。又逐他日者探及齐教二处三他。故二乘领己望佛。又领如来用他。言探领者。亦应云齐教。但是文略。是故二领皆指法身之取机也。但从义别二他不同窗牖者。说文云。在屋曰窗。在墙曰牖。非户故偏明处仍彼。今亦如是。非中故偏不遍故狭。故法身地观无大机。唯见偏狭先熟故也。乃由子隔窗牖之外。何关长者偏视之非。况是长者欲取偏机。于圆仍远故名为遥。脱妙至之具者。如前已释。生忍法忍等者。忍有情恼名为生忍。忍无情恼名为法忍。谓寒热风雨等属法故也。左手等者。小中权实。状有所畏者。状似也。权以实也。具如释签引成论文。又有寒风等者。大论第九佛有恼。谓六年苦行。孙陀利谤。金锵。马麦。琉璃杀释。乞食空钵旃遮女谤。调达推山。寒风索衣。加双树背痛为十。若依兴起行经。但有七缘。无孙陀利谤及乞食不得。大论直列。兴起行经委悉释之。次语诸作。人下譬四念处去。即对位也。今但略对无复行相。七觉在八正前。婆沙中具有料简。略如止观第七记。不云五停者。停心但是对治除障。令堪修观故。从念处正修以说。虽云约位须兼相生。方堪消此。故下文云勤修念处等。生空如来等者。此教作法所有生法不涉大乘。即阿含中是老死谁老死。故生法二空并属正道。具如止观第三记。无常等为助者。若谛观中云无常者。乃是正观。今以二空望于事中对治无常。但得名助。况复更以一期念念。以之为助。如大经中大乘治门。乃至用常何但无常。近指暖等四位者。外道求理在此位前。故名为远。应云念处等四。但是随便为言耳。此文等者。以世第一是五力位无五过也。下忍十六刹那下至世第一法位者。忍应上下各十六行。乃成三十二观。今文且以四谛言之。于三十二渐减缘行。二十四周减行。七周减缘。乃至最后。唯留一行。观一刹那入世第一。略如玄文释签略引俱舍文也。阿含至子义未成者。既阿含中亦明不断结惑菩萨。而大论斥权非谓全无。论云迦旃延造者。从所造论及所计者说。岂以会二还归阿含。法华准旧十二年前。一何可笑。若得初果至大乘者意云。从见道后不发大心。还令小乘道中断结。故云由是之故。若准大论。至初果已名之为死。不任复发。大师从容于止观中。进退二释所以初果亦名死等故。可发心二十年者。文存七释。初一合数为二十。次六释但立二名。如断见为一断思为一。初文者。见断与伏无复前后。即以八忍通伏八智通断修道九九通为一九。故但总立九无碍九解脱。五上分者。谓掉举慢无明色染无色染。五下分者。谓身见戒取疑贪嗔。五上分中色染无色染一向唯上。掉慢等三虽复通下。不能牵下故云上分。言下分者。贪虽通上不是唯上。嗔一唯下不通于上。余三遍摄一切见惑。虽复通上而能牵下。故名为下。故俱舍云。由二不超欲。由三复还下。纵断贪等至无所有。由身见等还来欲界。广如俱舍。言犹于二乘法中断思惑者。前见道中不发。犹令断尽残思。言共断余结者。或在外道中断少思惑。更依权行断令无余。第四领付譬者。是第四五合为一段。则使鹿苑文后不入方等之文。大章虽尔。细开仍有免难等文。以应一代五时之说。今犹存开标领及付领谓领业。指方等般若中。付即付财在法华中。譬文开为等赐四章。即今文中初二后二者是。即免难索车等赐欢喜。以方等般若为索车者。彼二周文免难之后。即云索车。但索车文促既不对二味。故以口索对之。今以二味为索亦秖且对机情索名虽同不无少别。况前索文义非局口。今言索者。不局机情。亦是方便品显实四意者。上方便偈颂释迦章显实文中长行。但云如是皆为得一佛乘一切种智故。颂譬本中开则为四意。初从舍利弗当知我见佛子等下二行。明大机动。为今索车譬本。二从我即作是念下二行一句明佛欢喜。为今免难譬本。三于诸菩萨中正直舍方便下三句。正是显实。为今等赐譬本。四从菩萨闻是法下一行。明受行悟入。为今得车欢喜譬本。由心相体信下生起四譬。次内合下预合向来生起四譬文也。即是始从方等终至法华。譬中秖是一等赐耳。若开十譬不应信解。良由此也。又前诱引壁至思尽中。言诱引者密遣二人也。言出宅等者。出宅与思尽两终义同。法身与道树远近不等。今领亦二者。今至领等赐中总合前文两个始终。为一始终故云远近始终。是则齐教为近始。探领为远始。二终但共为一。望诱引等中终则极于等赐。故云始四味终付财。既以四味为始。验知探领至寂场前。次何者下释也。释出共为一始终相即五味也。旁人譬牛者

问。前以旁人即华严中四大菩萨。大经中云从牛出乳。譬从佛出十二部经。今何得以牛譬菩萨为旁人耶

答。佛加菩萨与佛不别。虽主伴异俱是能说。所说义当俱从牛出。褒扬也。贬挫也。既领知至岂不乐哉者。据无希取未名欣欲。既已领知增后慕乐。机近付财故云脱更。机已冥会故云乐哉。判天性者。理性同故。定父子者。会结缘故。二乘在昔天性父子二义俱迷。至法说时开其知见。是会天性。天性若会父子义成。示其中迷故名为会。中根尚昧至譬说已。方定所生。是故四人今方信悟。菩萨疑除者。故法说中为令一切岂独二乘。譬中等赐非唯根败。但由领者力未及他。故使词中不涉余众。己正他旁未遑余及。己难他易故且从难。又己别在今他通昔教。故且从别。己死他生且从初活。他从昔显己唯今显。故且从今。见此多意余则可知。是从般若至第五味者

问。前会三云说法华。今还引大经云出涅槃。云何得同

答。一家明义多处说之。无烦广辩。欲重论者更述大猷。判味同时而有部异。约理名别咸归常住。约机彼称捃拾。约法彼存三权。论意彼带律仪。语证彼兼小果。受益彼无广记。说时长短永殊。谭常过未不同。论譬大阵余党。现瑞表彰各别。破执难易不同。领解近远迹乖。述成被根不等。用治生死不同。付嘱有下有此。得十六意准此略知。事异意同不可失旨。失斯同异讲授殊难。岂唯两经。余亦不易。今初相者。若不互释相义不成。然子体父以大而比小。父体子以小而无违。始终而论子未体父。故见尊特睹而不受。见身既尔诸例可知。由此见尊特身者。如净名中譬如须弥山王显于大海。安处众宝师子之座。蔽于一切诸来大众。药师中巍巍堂堂如星中之月。大集中集二界中间。诸方等经是例非一。乃至闻说大法见大神通。睹大菩萨难思大事等。皆由已得阿罗汉果。斥夺不疑故云由此。金即别教等者

问。大品有圆。何故但云不出通别

答。一者但语通别理已摄余二。论能诠教必须具四。金且从理故云不出此二。兼复二乘至此多成通别。亦且言之。通别仓库准此可知。其中多少至广略相者。第二十一方便品云。须菩提白佛。如佛所说若广若略。诸菩萨云何求耶。佛言。如是如是。若菩萨摩诃萨学是广摄般若。则知一切法广略相。又说般若时前后二周。即广略相。又二乘下重释意者。密示知同。故云体意。言体法空者。实理无二。此有三者。初一正是般若中意。次一据理者于般若时。密明不二而二乘不知。谓在般若意通法华。第三就今意者。于佛即是付财二乘自谓加说。故般若中云。岂声闻人敢有所说。有所说者皆是佛力。由机未转且言被加。宜加用心等者。述佛元意不出此二。显在菩萨密被二乘。然领上四时皆具二意。一述佛化意。二已纳密机。是则我身领佛二义。是故名领。若至法华佛意亦尽。机显非密。问何时名少时。答中分二。先约二经中间。次约无量义时。初文即是情口二索两楹之际。般若非一故其间时宽。总名少时望后逼故。随领一时一会咸有思量。失不失者。失则于己无分。不失复未同菩萨。踟蹰之际即机欲发时。正发乃在三请时也次约无量义者。去法华极近时极少也。既闻从一出多义必收多归一。四味之终故云渐已。机无隔异故云通泰。发在须臾故名为即。二正付业者。前云付财。今云付业。财从所营业即造作。皆是菩萨修得三因之作业也。名异义同故得互举。灵山八载者。菩提流支法界论云。佛成道后四十二年说法华经。北人者。诸文所指。多是相州北道地论师也。古弘地论相州自分南北二道所计不同南计法性生一切法。北计黎耶生一切法。宗党既别释义不同。岂地论令尔耶。若尔下双破二家。言迹门说法者。秖是三周。彼解云下地论师救。今谓下重破。自古不知开近显远永异诸经。谓迹说竟无可证也。若云言不叠安即向法师品后。方便品前何以不着。若云佛定已起不得说者。经家何事不先着耶。若得迹门竟。何不更待本迹后耶。睿公生起便为无用。一家次第道理冷然。依萨云者。如下多宝品中所引。若三请之时佛未说经。何得经云佛说无央数偈时。故知无数之言即宝塔已前经也。既言无央数偈。岂唯三卷半经。况地涌赞偈之文其数甚多。古传法华西方犹广。准此文也。今明等者。意云虽非亲生。既迹中同业非无相关。故是父之流例义当伯叔当知今日影响在昔不无高下。是则昔示高位如伯。示下位者如叔。并是父族故云亲族。并会字贯下。国王至是王者。前约昔教诸部为诸王。言兴废者。委论兴废具如玄文第九卷明。今欲略论对部说者。则华严二兴二废。乃至法华一兴三废。今乃废诸小王唯立一主。是故法华名王中王。次有此经下约此经会教。以今经中部无余教。部即部中尊极为王。教即部内教主为王。既教分大小王亦尊卑。国界宽狭民有多少。资产各异所出不同。故部内教通别二辙。别则当界施恩通乃须归大国。故知部教俱须会通。故前云部后乃云教。在昔未会。如一国内二三小王各理苍品未归大国。故方便教主王名不无。但兼部中圆极主弱。若会已后同沾一化。民无二主国无二王。自尔已前或归不归。不归仍是小王被辅不获已而统之。小王本无背长良由民心未归。民若归从王本一统。以此会法义可比知。无量义中先已收集者。虽云从一出多密拟多皆属一。故云收集。又乃由先说一出于多。方可定起收多归一。故知尔前当机益物。虽于一施三而三掩其一。欲说收入故预谭开。彼云下引彼无量义经示相。如何得知收集诸经。彼经既云诸经无量皆从一出。故指前经以为无量。四谛因缘即鹿苑也。方等般若次第宛然。言华严者。具有二义。已在玄文。弥勒等者。昔教既偏圆未融人亦权实不一。今教已会补处岂多。补处既然余下准此。民归王顺如向所论。初地等者。为会偏教故不云圆。某城者。王本亦秖云居一城。遁义通逃隐。今逃即是隐。今我至一切所有者。所付般若有共不共不出因果。因为万行果为万德。行即谛缘十八空等。德谓十力四无所畏不共法等。具如广乘无非衍也。此我之德既云子有。当知汝等并有如来因果之藏。故加说之即是领口。又般若中数见放光。睹难思身即令领身。般若方便即是领意。故知知之与见并是所有。所以法华但总说云佛之知见。而今忽闻等者。以他准己既法譬俱解。必知定同身子得记。嘉祥至此更却结前。都为五双十只。一从旁人指华严为顿。从水洒去至法华为渐。即渐顿一双。今问适作三种法轮。今但判为二教。则自言相反归顿不成。如何以舍方便唯佛乘会万善显久本之教。而为渐耶。二从洒面去为世间。从除粪去至法华为出世。世出世一双。今谓诸子不禀人天之乘。故知人天非渐教始。若以除粪去为出世者。未审鹿苑之后说戒善耶。况将十二年首讫至法华。同立出世之言。安显法华之别。三就出世中大小一双。未审方等般若有小乘不。三味之大同为一判。如何能显妙法之能。四就大中自他一双。即指付财为化他。领业为自行。未审诸部般若有自行不。声闻在昔谓为菩萨。佛化元意正付令知。况领业之时本在自利。自尔已后未改小途。五从二使来是密领业是显显密一双。若微密为密则法华为密。若以显密为密。今此声闻自鹿苑来。皆禀显教何名为密。尔前得记乃名为密。至此方索验非尔前。况三种与五双理自相反(云云)。若以五只同在法华。如向所破。若从广之狭以最后一只为法华者。全不云开还同昔大致令后学对数而已。不求教旨用教何耶。贵在得意者。譬中已委故不更论。似有二义者。由结缘不坏虽大小俱似。虽贬曰似子义不亡。次子既下举正因况。若论正因不似亦子。况复似耶。既曾结缘谁非真子。据曾逃走父且贬之。由位浅迷深斥之云似。云云者。如上分别

问。初释品云信解入真等者。真是修位即初住已去。品初又云年既朽迈。小尚非似位。今那云似

答。意者。若据子逃父后大小俱非似位。何况真耶。仍指结缘之时。于今稍得名似。而但合见子便识者。上见父有四。谓由处相避。见子亦四。谓处识喜适。今见子便识一句。即含前来八文。文虽前后意必同时。岂非子见父时。即父见子见故便识。虽复逃走机在不久。故父亦喜。故知一文即摄于八。我等以三苦故等者。譬中劝诫两门。先各论拟宜无机。后合论二门息化。今三双合领。初从上初下先腾前三意。旁追即劝中二意。再追即诫门二意。放舍即二门息化。言三苦者。由三苦故五浊加重。所以二门并无大机。但堪小化。五浊逼故即是三苦。无明覆故即是无知。今合下正合二门无机者。何为见捉即劝门无机。自念无罪即诫门无机。不云二门拟宜者。即以二门无机兼之。次乐着小法者合有小志者。即二门息化。言不合放舍者。舍即是息。但上譬文息化有四。一思惟息化。二释息化。三正息化。四息化得宜。上初思惟又二。一知大弱。二知小强。今言有小志者。即第二文也。言不合放舍者。不合第三正息化也。是则但合初文第二。即摄下三及初第一。故上文正放舍云我今放汝随意所趣。已知有小志故。于大放舍。上有齐教探领今合二意者。上二文各四。小拟宜知先心。叹三车。适所愿。今齐教中但合第三具陈上事。即叹三车也。及第四先取其价即适愿也。阙第一第二文也。此二任运兼得余二。思之可知。上有四文。今但三者。阙适愿一。余三次第对拟宜等。具指齐教文也。教作即是探领文也。合付家业譬。上有由有付者。上由有远近即小果为远体业为近。今但合近上有命有受。今但合受者不合命也。既有于受必知已命。而自等者。兼得余二。上付业有四者。一时节。二命子聚众为证。三结会父子。四正付家业。今既付与仍兼上三。须出其意。上开譬有四相失等者。此四标文文似四章。但成三段。乃略追诱下释具有。造立舍宅者。有余之土非寂光自然。现胜应身非法身本有。于彼更运依空慈悲。故云造立。经云顿止一城者。顿谓顿乏。示迹之相义同于之。又顿止即不行也。秖于此中求觅子机。超颂第四忧念等者。但颂子背父去。即失子之苦而无得子之乐。失苦得乐俱在父怀。是故失时已怀于乐。必知后时还来故也。远鉴机缘未若于佛。经云夙夜者。有人云。自行为夜利他为夙。此不应尔。夙早也。谓晨起。夜暮也。谓黄昏。夙即化。初夜即化末。大化始末准说可知。若丈六佛常说无常。化欲终时节节唱灭。若言自行为夜。不可自行亦云死时将至。有无善上等者。虽复时缘无所得善。未能断结。故此体上仍有见思。法身是师是王等者。此文合在次文畏避段中。若准上文秖应法身如王。加着师者重加一譬耳。报应是长者者。秖应云报如王等。兼语应身者报是胜应故也。以长者如王王等。故便言之。私谓以广显略等者。如华严中广明身相国土行愿。本欲以此广佛知见显实相体。故云以广显略。授决者。华严前文无授记语。入法界品旁论授记。亦得名为授记故也。弘誓及行者。彼最委悉。又誓为券者。誓许利他有如券约。随修随偿如疏随还。讫至菩提偿之方毕。又华严中菩萨行愿多明事数。名算计也。上旁人追文有三者。初唤为劝门二义。次唤为诫门二义。次是人下第三二行颂无机。即放舍。无机者。重牒二门无机。以无机故方乃息化。故云释放舍也。初三行颂顾作至教作譬者顾作即上齐教。教作即上探领。齐教文意自道树来。以取小机义为顾作。探领文意法身地时无时不愍。何尝不教岂待顾耶。故云教作。油涂足等者。有人云。外国下湿使作之人。足多龟坼。故以油涂。此语甚鄙。于今经中坼譬河等。何油涂之。上受命有四。今但颂三者。初如文。第三是第四大机将动也。但阙第二而无希取。初二十年等者。上文具引此中二十年。已辩异竟。今言转教者前云住二乘位中转教。今以别惑见思名二十也。合譬中佛亦如是。合相失者。上相失有四。知我乐小合父子相见。上相见文有二。先子见父又四。父见子亦四。今复应知若单以佛亦如是一句。合父子相失意仍未显。次知我乐小一句合父子相见意亦未显。何者。上句借下句成。知乐小故义当相失。次下句借上句成。佛知乐小故得相见。乐小由退大所以相失。退大由乐小所以相见。故二句相成摄八句也。知乐小句义当便识。未曾至其意者。秖一追唤即具二义。故云总也。上文譬中齐教探领各有四段。拟宜有机欢车适愿既但说于成就无漏。小乘教中无漏之言通于诸果。言成就者。唯在后位故亦总摄二四文也。上合有二相信委业。今不合体信者。验知相信为旁委业为正。言委业者。委即是命。今初一行长颂受命领知上颂所无者。上颂譬中全无命知。但有受命中三耳。初一行标断德者。以云内灭。内即惑体。三界惑尽故云内灭。故属断德也。次标智德者。既云若闻。闻教属智。故云智德。以小智具故不欣大智。此二并举失显过。次所以者何下六行双释智断者。初二行释断。次一行半释智。次一行半重释断。次一行重释智。故知初二行明自住小断。次一行半明失大智。次一行半重释小断。次一行释失大智。分得大乘习果也者。得初住时破一品无明名为习果。言牛头者。华严云。出离垢山。若用涂身火不能烧。十恩文者。文中自对室衣座三。初室有三恩。初一是通遍被之恩。次二是别拔与之恩。通被是四弘之始。别被是填愿中终。则发心后起行之来。自成道前处处蒙益。蒙益之相不出与拔。与拔之泽知何可报。所以难报者。初以自行之真令我修习。自禀教后退大轮回。慈悲不离处处与拔。次衣恩有四者。我受教已大小并忘。处处调停知我机遂。即于此界顿渐道成。虽先正为大机兼亦忧我善种。故于顿后便垂小化。弹斥淘汰锤砧锻炼。贬之以贫事草庵。诱之以富豪家业。宿萌稍剖尚未敷荣。长远之恩何由可报。是故四中初以人天。次及三味。如来座恩有三者。至法华时始获妙益。兼能利物化道初成难报之恩。良有以也。所以第八是授记恩。九十令我能利物恩。所以室得衣故。有覆育之恩。室有座故成与拔之用。座假衣室令自他行成。衣假座室今初后理显。是故三义合成大恩。此始终恩将何以报。注家但云物不答施于天地。子不谢生于父母。以感报斯亡。今意正论荷恩难报。何得以亡报释之。况复秖缘令我报亡。斯恩巨报。故不得直以亡报释之。凡言亡者。治彼不亡。今非领亡但领难报。二时既别且释荷恩

法华文句记卷第七(中)法华文句记卷第七(下)

        唐天台沙门湛然述

    释药草喻品

法华论以七譬立七对治。一颠倒功德增上慢烦恼炽然。求人天果报说火宅治。声闻人与如来乘等。说穷子治。大乘上慢人谓无二乘。说云雨譬治。实无涅槃生涅槃想。说化城治。不求大乘以虚妄解脱。为第一义。说系珠治。有大乘人取非大乘。说髻珠治。无功德人不取第一乘。说医师治。若但依此七各有对治。则为法作譬说譬领解。佛以譬述等理似不成。应知论意。火宅则不指大车边穷。子正用领付之意。云雨令开权二乘故。化城以宝所引之。余则可知。他若云今品唯出生者。全达经旨。况复论文从于能润以雨为名。经从所润故云药草。药草则二乘不无。一雨则述其归大。嘉祥云。草木有二。一不知同。二不知异。若有瑞草即能知同以喻迦叶。此则但从迦叶所领可尔。若从佛述岂可余之药草悉云不知。又亦不知三草二木是瑞非瑞。是故须云今昔方显瑞之是非。今谓至此法华。何得更有非瑞之草。应云是诸草木虽元一地所生一味一泽。而不自知。忽蒙开显。莫非祥瑞。乃使弹指合掌通成妙因。生无生慧咸成种智。然文中四悉且从迦叶。领述边说。于中先总征起。次土地下别释四悉以酬向征。初世界中二。先譬次合。譬中土地约今。草木兼昔。故云通皆有用。药草在今。药之草故。名为药草。所生等者。若从如来所述义边。无非是药。故云通皆有用。若从能领中草为名。则秖应云中草品耳。故云药草用强。有漏下合。先合昔。次无漏下合今。于中先合次引证。三述其下结意。初文者

问。若从佛述应云草木及以地雨。今品既是述成之文。如何但指声闻中草云四大弟子等耶

答。实如所问。言通意别故云药草。言别意通且指声闻。佛意虽通述其得解别在迦叶。述其不及及以复宗。若别若通皆成药草。地雨复是述其领实。故不别说。佛赞下证者。经告摩诃迦叶者。迦叶居僧之首故别告之。故知信解虽具列四人空生居首。然自陈之唱属在迦叶。故今别告。又言及诸大弟子。信知得悟不专四人。述其等者。悟必通该领述从别。佛双述善哉及迦叶领通名药草。并与欢喜意同。及领兼述同名世界。故可从通。次文二。先譬次合。譬中云丛有等者譬昔。各有积习故名为丛育养也。日久者。经二万亿犹在方便。今始开显故曰一蒙云雨。此下次喻今。云雨如下释。言扶蔬者。扶谓扶助尔雅云。林有草木曰蔬。以昔助今堪可与记。言暐晔者明盛貌也。一蒙云雨使草木敷荣。无始性德如地。发大乘心如种。发二乘心如草木芽茎。今入初住如同成佛乘芽茎等。内具十力名力。力有胜能为用。对于芽茎故具名内。小果得记如芽丰等。譬诸下合昔。今得下合今。先合次证后结意。初文者既开显已自利兼物。从于自他受益得名。名为为人。次对治第一义中二。譬合。譬中亦初譬昔。今蒙下譬今。言四大等者。世药三品俱非药王。下治四大中益五藏上可还年。言风冷者。略标二大。昔除四住病。但养五分身。还真理年驻变易色。今荫以无缘慈云。洒以无私法雨。使其远种获益无偏。使无常微草乃成常住药王。自行兼人悉除三惑。故云遍治。当知自他并成常身佛大仙也。次譬诸无漏四字合昔。从闻经不合今。亦合证结意。言嘉着等者。嘉善也。着漏也。称字去声。善始令终名为嘉着。闻契理故曰称微。且寄二乘领解以说。故皆云无漏。此并成于佛乘。四悉言是对治第一义者。从遍治边即对治义。从成仙边即第一义。余约教等三不记云云者。草木即是三教。地雨即是圆教。即为约教。若本迹者。本住智地曾施云雨。迹为草木引彼增长。观心具如玄文利益妙后。又约药为观者。如止观第十。四药治见备述权实。思亦例然。旧师虽云述佛恩深。无十恩意述亦不遍。古师亦不以教作而为探领。纵立探领。此亦秖如下文南岳所判。权功德耳。师云者。正指南岳二乘虽复自领己界。既云善说。即是具领一代权实。今佛委悉述其所领。十三偈下文将古所引还破古人。迦叶虽自领佛恩深。其如佛述善说如来真实功德。岂独二乘法耶。教作譬是佛权功德者。亦斥古人述不周遍。教作人譬是权法中少分而已。具如前释他日即是二他义也。他即是权。应云此实我子岂独教作人耶。今言下今师释也。始天性等者。天性即指大通佛所。如十恩中初恩意也。中间下具如已下九恩意也。天性犹通结缘从别。自微等者。自从也。从小之大至第十恩故云诸也。岂止一代教耶。双述等者。两处谓方便火宅也。以信解中双领两处。今亦双述二处所领。若不尔者。徒述何益。善说下述其具领如来权实教法。此约因缘释也。故不同他引论破无小也。又华严云去。遍述所领即约教也。前释尚总此释则别。总别义一本即观心大意同前。领所不及者。举迦叶之不及显余类之有分。又出迦叶之不及。示迦叶之遍领。又示迦叶之遍领。则知一摄一切。于中先列。次所以者何下释。释意者。若但述二乘秖应从中草题品。于所领外更述不及。令知如向所例意也。又说不能尽之言。寄之以明不尽。佛说不尽况迦叶耶。此中先叙佛意。佛意既遍验领有穷。次那忽下责其齐教通贯诸句。不道下正述不及退进等者。以二乘位望上为进。望下为退。十界各各自有因果不由次第。故名为横。一人渐起亦得为竖。今取杂起及具有边。但得为横。又以多人次第相望。及法浅深亦得为竖。人人各住亦得为横。七方便竖者。若七人各七先后相望。七人各一大小相望。七人传入七人入实俱得名竖又三世名亦横亦竖者。世世遍于十方十界亦名为横。如是品类皆从诸味八教调熟。方于今日与迦叶等。或同或别。未闻遍领故佛示之。夫山川至不及者。此非横非竖不及。如下诸文结差无差无差即差。差即无差不当横竖。无差即差而横而竖。今从无差名非横竖。从而差边如前横等。初山川下具对诸法。皆与理等同以一地。而总贯之。初有人以地譬赖耶常住其理不成。对五阴世间以明一实差无差等。无非实相故总言地。次草木下约五乘七善习因。对于一实明差无差等。次一云下至初三末一。约五时教对今一实。明差无差等。先喻。次如来下合。生公以云喻法。注家以云喻应。奈何道中天真而谢俗子。笃论其理何道俗哉。如龙兴下譬佛身中能被法体。总譬是为下总合。更无进退横竖等也。虽具横竖及亦横竖对于一实。任运施设论非横竖。约开显说。结差无差则开前一切皆成无差。次不及下明佛斥不及意。二乘初闻始入初住。且自述己所入之法。佛欲委述所不领者。其法尚多。二乘若闻亦成遍领。具如前说。言未穷者。极指后地竖入边说。若欲遍述未暇穷终。所以迦叶述己者是。初是因缘释。又初悟下约教。若迦叶领己即摄一切。以圆对偏即遍领教也。迦叶所证即初阿也。既即后荼遍领无别。又权行下本迹。唯阙观心。具如玄文释法中说。若依今领者。即空故差即无差。即假故无差即差。即中故非差非不差。横竖例知。广述成中二段。初文具述三草二木差无差等。即是广释领所不及。既责迦叶领所不及。所以下文仍叹迦叶者。明其虽复有领不及。纵领诸意不出权实复接引之。故结叹云汝等能知如来功德。劝信者。此不及等既唯如来能知。故举法王以劝迦叶所不及者。弥须信受。若依此领已是能知。为下大云譬本者。大云普覆于一切。大雨普润于三千。受益既实能被不虚。于一切等者。非智无以说。非教无以诠。欲知智在说观教而知智。今从述教故先教也。若方便品初。欲引五佛所说。则先叹二智。既是相成前后互举。一切法等者

问。何故前文领不及中七。方便是竖。今那云横

答。约人故竖。约法故横。又人法各有横之与竖。具如前说。不可定判。故更以横对实亦名为竖。若言不尔下释此横竖。初释竖中云。若言一切法不是七方便以对一实为竖者。如二万亿佛所初发大心。即是一切法实中间流转或复发心。不出七法。故七法是横对一实为竖。又十法界下释横也。一人身中尚具于十。况不具七。一人既尔多人亦然。一趣既尔余趣亦然。故七法是横。如来身中若十若七。一念洞照横竖无遗。此法虽多等者。七摄权尽一切逗机不出七故。为人天等者。明佛能照。是故能说此中既别列二乘。故三藏事度即菩萨。通无生名通于三乘。述其开三者。具叙七善而云三者。三从出世但开菩萨。加于人天义须通七。究竟等者。此明诸权皆归实相。是故三教教智未会不名为一。又非明示此法从于无住本立。故不得云究竟不二。今言不二者始终一也。其性等者。广博之一故名为切。切字(七计切七结切)并通。训众也。共显不二是一家之切。名一切智。寂而常照者。智所依地能生诸智。故名智地。此从境说。若智即地能所不二。故智亦得名无住本。是故亦得名智为地。正显能立。立亦生也。故此智地能生诸法。故双名智地为无住本。云何等者。斥古师也。降此之外余解不当。暗而复寱迷深故也于无明夜寱解圣言。何能当理。例大品下引证智地。故先翻名。实相是体智即是用。若智家之地即指实相。一切皆大。由智显地由乘至极。亦是从始至终依地至极。大事大乘皆须简于庄严白牛。余二等者。但是不一皆名为二。此约至开权显实也者。以渐顿中不出七方便故。故渐顿中有权咸开。如来下至释教也者。权教咸成实教者。良由以不二智而同照之。知所归趣至各有归趣者。能有所趣故。故名所趣。戒善下明七方便法皆有远近者。当位名近趣极名远。当位名权趣极名实。权药所治故名权病。关中唯远是亦不然。善无自性远近在人。于中先举戒善近在人天。言作缘者。从远得名故云若作。念处下言福德者。大经意也。经云声闻者。福德庄严有为有漏。亦由在法华后。故说开相可严法身。念处兼于两教二乘。今且在于三藏声闻。中越三人故云乃至。六度通别一一善根皆有二趣。如来善知

问。别趣已远如何亦二

答。十二品惑及以我之果。为他之因。岂非近耶。又近远者近从物情。远有三意。一者善体。二从本期。三从佛意。佛意又二。一者顺机。二者从体。唯有如来善知体性。体性之语还通二途。接近令远体性俱存。此于权中取意实释。即是今经权实正意。又戒善下重释者。单从药边释。七方便名为识药。深心所行名为知病。能知即是识药故也。言二种者。所执兼细惑。依正唯粗惑故。障人天者。且从近说。着所执者以四倒等。各对诸乘。然粗惑亦非全不障乘。但不执理障乘义弱。着所执者。非无十恶失人天乘。随其浅深皆名计故。故以计等随义对之。一智遍照等者应非但照一切而已。须于一药一病见一切药一切病。下文既云一切法者。即是十界。故一药一病皆具十界。知诸法尽名知病者。寄药显病。知一切深心等者。若无识药不知深心。寄病显药。若干者。若如也。如彼法体法体本空。故若干无若干。又如下举心法尘。譬差无差。初二句明法相。约心所缘法尘以辨。次心有下辨别。次心不下辨即。次无数下辨即相。权实下合譬。真法本无。由心有数名法为数。全心是法全法是心。不能具合但令述之。故注云云。譬如下第二譬说。文为二。初譬后复宗称叹者。准前初开云。初述开显。次结叹。于初文中自分为三。谓法譬合。今至譬中又云先譬次复宗者。以由汝等迦叶以下文具二义。亦名结前开显。即如前所开。亦名复宗称叹。如后所开。言复宗者。此中大意本述迦叶于中广叹如来二智。似如唯叹如来不关述成。故后文云。汝等迦叶甚为希有。此则更复前宗以述迦叶。此中以述迦叶为宗。故云复宗。以叹如来是叹迦叶。故云称叹。三草二木下述譬释差无差。次若观下辨譬差无差所以。若观草木之末派。则有差别。内合方便下合权智。实智下合实智。差别下云云者。皆应细说。以差无差用对一实。及以七五。植种由如来智地。物情自谓之差别。敷荣由如来法雨。法不由情而能差。众生所受亦是智地。地亦是法但植种时。智地义兼众生心地。故初心名地。释差别譬者

问。土地与下一地何别。而此中譬差下譬无差

答。用譬各别。下譬实理今譬报阴。故不同也。此中先破旧者。习因报果二义不同。故知古人不应以山川等而譬习因。习因必须增长故也。故此下文三草二木各有增长。即习因也。今文正释但以山川等。用譬众生五阴二种世间假实不同。故今引下二文。俱证人天等报果义也。又更下别譬者。前通为五乘五阴作譬。今各譬五乘五阴。如山虽高峻亦有洿隆等五相者。洿字(乌花切)若依今义应作窊字。凹也亦应作洼深也。隆高也。谓山川溪谷土地一一相中复有五相。如地虽平亦有高下似山等也。川者穿也。水大能穿通者曰川。潘岳关中记曰。水有八川。谓泾渭灞浐澧滈涝潏(音决)滈(音浩)当知通水之处俱名川也。溪者穷渎。源出于山故云穷也。谷者水注于溪。又泉之通川者曰谷。何妨此等皆有五相。故以譬于五乘五阴。山川依世界下云云者。细合阴入习因法性三法。展转相依之相。应云习因开为缘了。与彼阴入不即不离。阴习与正法性不即不离。六文宛然者。责于古人不立第六为习因增长义也。所言六者。一土地。二草木。乃至六增长。故知初义但当山川。未关种子增长二义也。又次等如此至前后耶者。古师以今家第六安置第一。是故责云抄着前后。又以最后土地及最初三千为总。而以溪谷等为别间之。故云间糅经文。治病力用胜者。若分药草二字。则以小草偏受草名。余通名药。即指无漏。且从所述二乘人说。是中草故。故称下草治病力弱。上草同凡治病亦劣。从发大心故亦名药。二木复从覆阴为功。故知通题别在中草。通论皆药。但略木字耳。具如品初分别可见。质干法体也。覆荫慈悲也。器用利物也。喻二菩萨者。通别菩萨望两教二乘及三藏菩萨。且云大耳。然通菩萨若望三藏。弘誓之境虽无优劣。以通菩萨。一者衍门通圆二通于别。故云广也。七善秖是七方便耳。若从修习。当体为名。方便进趣功能立称。密云即三密者。凡云三密必约应化。自受用报平等法身。何所论密。覆荫譬佛慈悲等者。荫广则质大。荫狭则质微。质微则利近质大则利远。远密近疏赴物各异随其用智化境不同。不雨下云云者。因将云等以譬三密。便引云色不同。电师名异有雷之由雨缘不等。今以云譬应身。雷譬名称。雷譬放光雨譬说法。长行无雷电。颂中具有。电必有雷雷必有云。云必霔雨。今不取无电无雷之雨无雨之云为譬。须以此意合身云等。应色非一。且泛举五以应五乘。佛为教主譬如电师。众生机缘亦如电师。感应相扣犹电师斗。随机有感应之以光。又四大斗亦譬机应。言五事无雨者。总以无五乘机用释有机。以无机故法雨不降。凡引事譬皆有近远。此中不须用华严中六天四域。秖借阿含意为譬耳。又杂含云。风云天作是念。我今欲以神力游戏。作是念时风云即起。电天雷天晴寒热天亦复如是

问。此六譬者本譬差别。何以密云一雨为无差别譬

答。下文云雨秖是此中云雨譬耳。但今从所雨得差别名

若尔。与草木何别

答。草木唯从草木立名。云雨乃从所显为能。是故不同。八音四辨如法界次第。应分教别今从极说。普洽等者。虽说五乘本被一实。岂受润时离实地耶。信戒等者。五乘皆藉此之四法。唯有人乘阙于定慧。以心所当之。明其草木随分至两因者。习因增长以成报因。故习因增长即报因增长。具如止观第八记。略述诸论习报因等。但彼明发相此辨修习。彼六蔽度此七方便。以此为异耳。华果敷实至二果者。华如习果果如报果。此隔字为对。应言华敷果实亦有华而未敷果而未实。亦可譬二因也。今取已敷已实者也。故至果时依正明了。道前心地至智地者。此道前后之名名有通别。道后定在果后道前通至凡夫。故方便品中亦以等觉已前为道前。此中须以博地凡夫无戒善者为道前。以五乘为道中。所以道前道后真如之理等皆是地。地体无别。然皆能生。故知众生道前心地。奚尝不有能生性耶。而不能生不能成者。必假道后极果智地。令生令成。发心已后究竟已前皆假智地而成熟之。开发道中者。且以初望后五乘居中。非谓五乘即有真如。五种善根即五乘也。并约如来化意边说。故云终是一音。言终是者。终无定五故云也。被物虽五化意唯一。从权宜边须名四味。合譬次第者。此中但明合中相生。准理亦应明譬相生。譬相生者。由有五阴众生。故有五乘草木。有五乘种子。故密云应世。应必说法说必有润。润必增长。云云者。应以差别对润同说差无差等。章门者。十号如止观第二记略释。四弘者。肇云。发僧那于始心。终大悲以赴难。本业璎珞具对四谛。然彼属别。今须在圆。知道等三不护者。常与智俱。六种法门始自十号终至三业。诸教所明一切果地神用法门。此六摄足故略举之。况此六门一一互摄。此六次第者。由具十号故有四弘。故云未度令度等。虽用四弘。若无三达照机不遍。三智具足方乃名达智必有眼。三法既以定慧为因。而获眼智两果。故有智必有眼。如此五料无不三业随智慧行。故略举六科以示能应。佛自称此以显能注。即是十法界至差别者。虽通十界四趣无增长义也。于时者。观机时也。言若论者。且置华严故。利钝之言通三四味十界故也。通别圆云云者。应须此三迭明利钝。然初句云声闻观生灭菩萨观不生灭。已是通。竟下又具列通等三者。但重举对别圆耳。即以声闻遍收藏教。为进下云云者。须约三教菩萨求佛者傅明进怠。随其至无增减之失者。称五乘机故无增减如人机授以十善为增。天机授以五戒为减。如是乃至菩萨展转相望亦然。报因至习果者。前文但云华果敷实以譬二果。今合中乃以华合报果果合习果。若不依此合即准前文。或别有意。如说般若方等明地狱众者。大品中如来放光照诸地狱。具如释签所引。说方等经亦如释签。此中引三恶者。经中但云善处今取恶道者。一者为欲摄十界故。二者三恶有七善机。今云亦者取意释耳。生身菩萨且指地前。然准权教地前不可一生。故须依实教以说。后生净满界者。舍那彼音。此指实报土为净满界也。菩萨乘出内无利智者。且指三藏菩萨。问下现文都有八重问答。意欲如问而不别云。但注云云者。约义仍有八中初者但应以出世方乃名乘。何故须列人天乘耶。故广列诸意以辨随宜逗物之相。又人天等者。准此亦应云菩萨亦断亦不断。但是文略。次云二乘亦断亦不断者。二乘虽断断仍未尽。故云亦断亦不断。余悉可见。以此为例取诸经意自在作问。乃至具历四教七方便为问。此并一家依义假说问答耳。次大论去更引文设问。出离合之式通前诸意。大论即于五乘为五善根。故得对于藏等为问。人天下答。于五乘中合二乘开佛菩萨为二也。此以五善望五乘说。四藏合凡开圣者。将四藏以望五乘。是故四藏合人天在二乘中开二乘为两。佛菩萨为两。若以五乘望四藏。即是俱开人天二乘各二。仍合佛菩萨为一。既云为缘不同所以亦得为三乘。但是凡圣俱合耳。但以名狭摄法不周明类不显。故不得但以二乘为摄。若直论乘何法不得。具准上意思之可知。雨于一切帖合六章门者。六章正出注雨相故。一相者至一地也者。真如秖是一实相耳。七相秖是七方便。以实相对七相是故云相。即行相也。七教秖是七方便教。以教对教是故云教。所谓下双释者。初双标理教也。次众生下先释性对理德之相。初总举。解脱下列结。此性三德虽有三相秖是一相。如来下释一味由佛说故。此性可修。性本无名具足诸名。故无说而说。说即成教依教修习。方名修三。比读此教者不知修性。如何消释此中疏文。敬请读者行者思之照之。此三相下重指性三以为修境。缘生下重举修相。故名为行。行即因也。终则下举果地三。三智满故从智为名。即是智三行三性三。开合多少准望可知。有时下举分文不同。解脱下广释相味。先相次味。初释相中性德秖是本有三道。解脱相者。即于业道。是解脱德。离相者。即于烦恼是般若德。寂灭相者。即于苦道是法身德。无生死等。寄修以释。唯有下结故云实相。一相下转释一相。即无住本立一切法。理则性德缘了。事则修得三因。迷则三道流转。悟则果中胜用。如是四重并由迷中实相而立。此无住本具如释签第七已释。故无明实相俱名无住。今以无相对于差别。专指实相名无住本。无住即本名无住本。随缘不变理在于斯。起住二门义准可识。染净二类具在十门。一味下约教释者。上相但云无生死耳。约后乃云无二死者。教在分别故也。前相但云离相者无涅槃相。此教乃云得中道智慧。乃至离于二边着也。前相但云无相亦无相。今教中云二边因果灭者。应云通别二惑内外二死灭也。今对中道中道从理。故此因果名离二边。此二涅槃永殊小典。小典二灭必不同时。此中二灭更无前后。句句例作差无差者。既句句约教。教亦须显差无差等。故应具如前一相中。即无住本至即是无差别文是也。故今对教明差无差。若不尔者。徒开浪会虚说漫行。空列一乘之名。终无一乘之旨。禀权教者尚须识权。对此终穷安得昧实。忽都未闻性恶之名。安能信有性德之行。究竟等者。前总释中已略明竟。今于广释理教双结所归。能诠所诠咸资果智。故究竟之言通论理教。具有三法而但云种智者。从智取境故也。七种等者。亦有人言。此中诸句何意节节皆云五乘七善。太烦重耶。今请离此释外与今经合者。无有是处。故知不以七善简之无由显实。第二等者前六科显能知之人法。今减辨所知之人法。故举此十摄诸法尽。又前乃唯约于能今则约能论所。故种等四三慧所取。所取四法不出因果。因果之体体唯实性。一一对辨他经十法。三道是三德种者。即性种也。有生性故故名为种。生时此种纯变为修。修性一如无复别体。言相对者。且从当体敌对相翻。即事理因果迷悟缚脱等始终理一。故名为性。波水之义准望可知。波是水种岂可不信。若就类者。类谓类例即修德也。众生无始恒居三道。于中谁无一毫种类。夫有心者法身种者。合彼性三为一法身。对修方合约性恒开。此三从别一一各异

问。若尔。般若解脱有于种类及以对论。法身类种与对论种为同为异

答。理一义异。言理一者。秖缘理一是故性修相对离合。言义异者。对生死边名为相对。理体本净名为种类。又闻能观智名为了种。闻所缘理名为正种。即是理净与事净为类。诸种差别等者。须约诸教诸界广说。不可具述。唯是理体一三德种如来能知。若约教者。别教唯有种类之种。而无相对。于中法身类种仍别。始终常净。唯不从覆故得种名。藏通两教全无此义。但约当教其名非无。因时三学为五分种。达分即为二解脱种。念处即为般若种也。隐显并别具如止观第三记。故三教教道之有差。本在圆实之无差相体性三既通始末。所以须约十界十如释者。向释种字。既以相对及种类释。今此三法亦应例之。又前种中不云十界取极下界。类中自云世智等也。故此十界不出一念。如彼广释十如中明又前释种不约十界者。欲明三德义便故也。此相等三亦是三德。已有种义不须依前约界则便。故十界中有佛与凡论差无差。或对三谛。次约三法。即是三慧。于三重中皆初云念者。念所取境。思修亦然。境即所闻所思所修。皆言何者。指所取境。所念等者。教下所诠。向之四法随教则有思修不同。对界为境多少增减。观体巧拙随义应知。为差无差以权对实。初言用者。有取境慧方有所取。举事显慧故曰用也。所言体者。即当体也。境中举事事是所取。念等居先取所取事。今先言云何。指能念体思修亦然。故知即是三慧当体。此体即是能闻能思能修。故云记录所闻等法。言因缘者。谓以何之言须所闻教。念等即是能闻等也。不由能取令殊而为别相。乃由所闻法异分五乘七善。能所和合即闻思修之因缘也。言取境闻法为因缘者所取能取并名为因。闻法为缘生慧即是所生法也。又取境者。取境必须闻法为因。且先标之。故三境为因闻法为缘。即初虽有闻等。更须闻法以为良缘。故云因缘。应知三慧境体。及以因缘。虽三而二。重释因缘者。合向境体。体即是智境必从体得名。体必由境立称。重云因缘者。既加闻法防自他计。及立更互因缘故也。三义具足方乃成慧及成所为。如此三乘等者。五除人天以人天乘未名慧故

问。前云十界。此中何以但云三乘

答。广略虽殊其理一也。但种通乘局合大开小。故但三乘。又种等四必遍十界。于中起慧必唯三乘。三乘通于四界故也。五乘之因等者。慧必唯三因果通五。离七准释可以意得。不云四起者。且从升出。生公具约诸度等法辨闻思修。然六度未能分于三乘。六则通漫三则摄六。是约一法者。故四意中前三约所辨能。此约能论所。所中无差即一法故。故前三意如来并有一法无差。但且约所以对能知。无差别下云云者。秖是如前差无差等。而为分别。一中无量者。意云。是一家之无量耳。一一德中皆可为缘分别无量。如云多诸名字等。无量中一准此可知。何者去对小辨别。何者。以二乘人亦有二既离着入寂。名同体异重对释之。常寂灭等更以无差结二乘差。终归于空准例可见。郑重抵掌者。抵吴也。吴手于掌表勤勤也。向已释竟。今复释者。此事不易故重勤勤。佛世尚然。何况末代。斥旧云至若佛等者。古人以此释下寿量。失旨逾甚。今复以此释常住教。故云苦经。不生不灭而云夹断。故言苦佛。经佛无苦加之者过。故云苦佛等耳。光宅有余未足辨异。然光宅诸文皆破三祇菩萨。不知何事至此即以小乘有余之名消毕竟空。有人去他难光宅。诸古尚有不许斯释。何况今师经文下今师正解。前对二乘重释者良有以也。龙印去引旧诸释以责光宅。一往且尔。然亦不知旧第一义空与小何异。随三悉者。亦以一实为第一义。对权为三。即昔日随欲顺权机也。次复宗释疑者。虽未之言许为俦类。得受记已即分真佛。自鹿苑后具领权实。至醍醐时领业不虚当知前叹释迦。本欲称叹迦叶所领。言释疑者。恐此时众闻佛述其领所不及。不晓佛旨。而谓迦叶所领不当。故述己权实以叹迦叶能知如来随宜说法。虽自领已实兼一切

问。何不释探疑耶

答。齐教显露虚实易辨。故佛且约齐教述叹

若尔。探最可疑。何独齐教

答。虽难而易。时众闻说如来二智。知佛法身恒思大小。秖恐领教未必尽善。故佛以二教二智述其齐教无差谬也。又齐教述尚自不虚。验知探领亦应非谬。释述意者。向适斥其所领不及。岂至此中即云所领甚为希有。故知前文但是如来自述能知。何关迦叶。故今释云。世尊虽即自述理当迦叶一切皆领。迦叶既其始末自领。而亦经涉五时权实。义舍一切故亦堪叹甚为希有。然章安重释但作述前品一十三偈叹佛恩深。即是当界能知随宜。当界事理遍收一切

问。此中述前叹佛恩深与古人。何别

答。古人直云恩深不辨恩之近远。故前以十三偈具领始末。今佛具述方名述成。此是章安之助见。依大师意自成深致岂有等者。即指迦叶等以为一机。指此娑婆以为一方。余机不领故云说不能尽。迦叶等四于前品未。但云如来大恩。如来遥鉴迦叶既能教探二领。岂不能知初四弘恩。乃至最后令我化他。十方仪式亦不出此。故今此中长行偈颂通遍述之。则三草二木一地一雨尽述迦叶始末之解。身心法财者。身得受记心获法财。已证第一义一实空座。若依此义佛本遍述迦叶始末。时众不解故须除疑。是故释云迦叶能知。若寻此意。何得以四伏难与此同言。耶。若不尔者。大恩之言何所主耶。述恩不周翻成背义。若也出生还应自鄙。何以佛叹能信能受。次颂中不颂略但颂广者。广摄略故次有智下约权智者

问。既云有智若闻。此必属机云何属佛

答。若非有智人说。云何能令有智人信。自此之前皆名邪者。迦叶等四未闻譬前。义当邪见见未正故。故别大经迦叶童子自述为例。彼亦未闻涅槃已前。自称邪见。应身至含润者。凡说法之言乃对应身。故胜劣应皆是色身口业宣辨。新经乃以他受用报而为遮那。尚非自报岂不说耶。若言体即十身俱即。何独应耶。乍可云三身即一说默无殊。安弃丈六偏尊相海。如空为华华外无空。能具等者。故知说昔偏小典藉。不降开显十二部中佛性圆常之雨故云不含润。前二味中虽说不受虽有不遍义非含润须扇多佛不说法者。此以全不说为不含大论文也。多宝不说义如下文。九十八使。初断见爱得真谛益。而云地上清凉者。六根净位亦且除之。百谷语通至百善也者。五乘各以百善为本。言能生者。从果以说。若从因说乃是百善生于五乘。大小乘因岂过十善。故以十善更互庄严。若不能修互严因者。今所不论

若尔人乘无百

答。酒防意地通说非无。甘蔗等者。既举二物应有属对。今试对之。甘蔗质一可以譬定。蒲萄形多可以譬慧。慧约所破定约所缘。且分多一。既出下三行颂十号者。文略义合。出世即无上士及佛于于也。为说即正遍知明行足。世尊即第十号。于天人中即调御丈夫及天人师。如来即第一号。来善去善兼于善逝。又出于世即世间解。充润下四弘者。充润众生即初弘誓。皆令离苦即第二誓。皆令离于因果苦故得安隐乐即第三誓。及涅槃乐即第四誓。五乘咸有世间之乐。皆令得于第一之乐。劝听受中又更为二。初二行先叹佛。次为大众下能说人尊。故所说法妙。七善无不皆归一乘。故劝听受。此举无差以释于差。佛平等说等者。有爱憎故则有彼此。不于佛机者爱余机者憎。贵贱上下约位。持戒毁戒约行。利根钝根约习。亦须具历五乘七善。展转说之。有人去次释三草二木者。古师不同。但于大草二木不定以名合故。小中二草经自结名必无违诤。仍不知有二种二乘。是故初师具列五位。第二三师但列三位。以二草意同三皆未称。然三草下今释。先总非云师心反佛违经者无禀承故即师心。佛意不尔即反佛。违经者。经明受润不同以对五乘差别。如何三位并同在一教。别受润中进退两解者。初正消经文。次以木例草准义以释。草既有三木亦应例。人见大草中云求世尊。谓义亦通后。见小树中云专心佛道谓通初后。见大树中云度无量亿。谓通前二。便作一种历位解释。以近代来弃旧经论诸教菩萨。此为消释之大患也。故今别释冥顺经文。上草为六度者。既云行精进定。于六度中精进为最。故大论云。施戒忍世间常法。欲修定慧必须精进。况复通进遍入五中。为是义故举进摄六。故不可二木唯在三秖。小树中经既云常行慈悲自知作佛。六度菩萨第三僧祇方乃定知。故不及通但过二地必知作佛。故与前异乃从胜标。大树中既云转不退轮。别人初地能转法轮。是念不退。藏通至果方转法轮。岂得名为如是菩萨。故知在别。次义立三木通三菩萨。令识通方故更释之。故正法华初例则云三木二草。以小草为悠悠药。以上草为上尊药。颂文乃云三药二木。是故今文通别二解。释增长中。二乘增长二解不同。并今师意。前释得小乘尽生死。方名最后。次释大乘中。方名后身。大小两种并名增长。增长皆由值佛。众生自谓当分增长。今准佛意莫非地雨故令当分远有增长。所以至此方知合一。无后之言且任小教。权名为无非永无也。若得法身等觉一转当入妙觉。乃云最后。论云。罗汉发心已后边际定力。令分段身延至变易。不复改报成无上果者。此多属通义。以通菩萨过二乘地。惑润生身或不经生而成正觉。岂华王佛果而用二乘边际定身。故应问言此定与彼首楞严定同耶异耶。诸论皆云舍分段身而入变易。天亲论主意未必然。但恐论释义不正耳。故知最后增长之言。大小各别。无人有教深可为规

问。若尔余之三位皆应两释。一者三位若不值佛各不增长。若得值佛当位增长。二者于法华前住四位身被佛调熟。若至法华得入一实。方名增长

答。然五位中二乘执强谓为最后。故须二释。余三已有彰灼明文。上下文意一切皆尔

问。二乘同云住最后身必须见佛。缘觉不然者何

答。虽生佛后元因佛世。思之可见。增长后云云者。具述大小今昔之意。五位虽即自谓增长。萌动之初莫非地雨。说虽地雨居后长必始在初毫。今始示于地雨初后耳。亦应委说通别增长之意。问一云一雨与一音同异者。问意以一地一雨与一音教。为同为异。答意者。今一云一雨别譬开显。彼一音之教通于因果及以偏圆。于中先分因果次辨偏圆。先因果别。别意虽尔。亦随诸教二种云雨以譬诸教因果随分一音。今从究竟云雨以问。答中别申二种一音。言下地者。或指圆教六根。或指别教地前。若指初住已上等觉已前。岂可全无随类一音。次辨偏圆中先出旧非。次正解中三。先圆次偏。后明自报。先圆中引大论者。破上三师。所言报者。即酬答也。如此一音亦通下地。但不关六根。次婆沙去引偏拟圆。类例欲同。然其秖是三藏教佛之一音耳。若不尔者。能以婆沙释华严不。五百罗汉有七菩萨见解以不。瑜伽尚别同异永乖。迦叶当知者。开譬颂初已云汝等迦叶及当知等。故颂文后不更复宗重称叹者。良由此也。隋朝笈多所译。名添品法华者。自余诸文全依妙本。彼见正本偈后。更有一长行偈颂。乃重译之。添此文后。又移嘱累安劝发后。自余先译并无所改。重译言辞多似正本。其所添者初长行中。先以日月譬用叹佛智(此与前文重故什师不译)次明五趣中有三乘。于三乘中而说平等(亦与前文似重)次迦叶问。何故施此三乘教耶。佛以瓦器譬之。所盛不同非关泥异。迦叶又问彼种种解出三界外为一为二三耶。佛答。若觉体等无复二三(此亦同于第一经中灭度想者也)次因此后佛为迦叶说生盲喻。初不见色譬诸凡夫。次以眼开譬于二乘。次天眼开譬大乘也。偈重颂耳。故知无此添文大旨无阙若其有者述成又剩。什公不译意不烦文。南山云。笈多辄移嘱累品也。准此亦应云移品法华

法华文句记卷第七(下)法华文句记卷第八之一

        唐天台沙门湛然述

    释授记品

注家云。业似先违心符后顺。既拂殊音之异。宁爽一味之果哉。故与记也。今云。事似先违。心机本顺。然诸菩萨岂无先违后顺之人。故知今记声闻须除通释。释此品题。先翻译。次料简。于中初诸经下先引经问中。初文总举问意。次净名下别引三经。初引净名者。弥勒得记既为补处。必生兜率为彼天主。彼诸天子预来修敬。弥勒因为说得记由。由不退位。广为天子说不退行。即不退因也。乃被呵云。众生诸法贤圣与弥勒如同记同。何独弥勒。况如无生灭何以得记。次思益云者。以记虚假愿不闻名。大品亦尔。答中为八。初通答。次约二谛。三约四悉。四若通途下正明今经。五他经下对于他经以辨有无。六元诸佛下广约四悉。七授记下判能所异名。八中根下来意。初文言此见须破等者。意云有见须破愿记须与。岂可专引净名等耶。若约今经须具五意。一破方便教所得近记。二破始记者生染着心。三为显衍门记无记相四为未合记者息希望心。五为宜闻破着得益者故。衍门破小义兼三教四门记相云云。次二谛者。四教并然。何得以真难俗。三四悉者。略同二谛广如下释。何得以一难三。四正约今经有五。一通别。二三因。三迟速。四师弟。五悬记。应言现未但是文略。然此五意须约今经以简他经。或迟如声闻或速如龙女。五对他经辨有无者。又二。初明今有。次璎珞下辨无明有。又诸经为对菩萨。多授法身究竟果记。今此品中秖记八相。如前后说。璎珞八记者。今经已众无不知者。故前四句中。今经唯有第三句。纯显露故。于中不必在第七地。如不轻中一句通记。故他经记深。后四句中。初句虽云远处不觉。化道同故亦非不觉。故今经有第三句义同初三二句也。故知诸经实义未畅。言未得无著行及以七地者。无著之言应约通判。别圆教中初入地住已名无著。或在别教约教道耳。入无功用方无著故据空观成秖合在通。言七地者。在于通教。以过二乘堪与记故。然论文中先列四种声闻。则退大应化与记。增上决定不与。有人救云。决定亦记。此亦不然。他计决定即是定性永不发心。须指经文虽生灭想。彼土得闻。彼义自坏何须别求。但以灭想者作凡夫释。曲会经文令成己义。又宝性论秖云声闻出界根钝不云根败。言根败者。迦叶于方等即是其人。若至法华败根还复。若入灭者出界方生。生公云。会理无累岂容有国。虽曰无土而无不土。无身无名而身名逾有。故国土名号应物而然。引之不足耳。若得今意但云八相诱物。斯言蔽诸。法华论云。二乘有佛性法身故与记。非修行具足。论言未足者。据极果耳。岂可不修净土行耶。据斯灼然更须供佛。若缘觉人入声闻数。即同声闻。出无佛世同决定性。六从元诸下广约四悉。总有十重以成四悉。世界中二者。初约机应相对。次单约物机。虽义云单终成机应。机感相称如欢喜也。为人中二者。初文改小入大已生己善。时众下众愿者。又有利他之善。四对治者。初破菩萨退为小恶。次破欲发小心之恶。次正破小恶。次破将欲证小之恶。第三已证第四已入贤位。故异第二。若对菩萨击彼小人。余经亦有。今明记小复引小人。故唯今经。第一义二者。先正释。次释疑。疑文可见。然众生下释者。为成第一义意。前之三悉不必无生。又第一义中唯约自记者。前之三悉或兼自他。如对治中一向对他。为人中初一兼自他。后一唯他。初世界中若将化主以对所记。亦唯在他虽有此十。亦且约记二乘以说。佛记一句及菩萨记等。此中未论。初迦叶颂中初四行行因。次半行得果。次六行国净。次半行佛寿。次一行正像次半行总结无劫国名。言三人记各有行因至数量如文者。但旃延中无劫国名。余文并同。次须菩提中长行可见。偈中初一行诫听。次二行行因。次一行得果。次六行半国净。次半行佛寿。次一行正像阙劫国名旃延中长行如文偈中初一行诫听。次二行行因。此三句得果。次三行一句国净。阙佛寿正像。目连长行如文。偈中初四行半行因。次一行半得果兼国名。次半行佛寿。次二行半国净。次一行正像

    释化城喻品

因缘释中为四。初约喻释名。次以法合。三苏息下说化意。四权假下总结。初文者以大涅槃非化作。故不专御敌理性即故。具众德故。次合中初总标。权智下合神力所为。以权下合无而欻有。用教下合化。防思下合城。教无实故。故名为欻。言非敌譬见思者。非宽敌急见逼思遥见亲碍故。思不障果。三说意者。苏息施小引入显大故。二酥名引醍醐方入是教道故。故而言下郤释城也。权假去结意者。辨异实故。于此四中立四悉者。若通方义立从于权智。若从机说无而欲见。见已生喜即世界益。得入苏息即为人益。防非御敌即对治益。而言灭度第一义益。若从能引权立此城即世界化。为生小善即为人化。且除见思即对治化。终引入大即第一义化。次约教中三藏菩萨。全未发足。是故不论。通教菩萨虽同至城。入而能出不同小故。元出界故一脚入城。以大悲故。不证有余故。一脚不入。三界机缘名之为子。久发心者义之如妻。通教以二乘为恶道。别教以生死为险阻。至涅槃而不入。故名径过。不极之言对小以说圆教。言化者在昔则斥夺。但云不堪。亦未曾云涅槃是化故至今教动执开权。方云是化乃至显实化。乃成真即宝渚故。故知藏通谓极非化。别教非极非化。圆教非极是化。亦可是极是化。亦可是极非化。与藏通教言同意别。今是等者。亦从破计故且云化。若开显已无非真实。本迹观心不记者可比知。故应云本住三德涅槃之城。迹入化城。若从化主迹示说化。问此等品者此人附正法华。设此问也。正法华名往古品。问者潜改云宿世品。故答中不违问者以顺正经可消今部。又上根下约三时释。言探取等者。其文虽在法说述成。述成正为引起中根故。释譬喻幼稚等文。皆引用之若从下自约当品。别论三时者。二经俱具。正经从初不及今经处中之说。并不云宝所者。如药草中不云地雨。若信解譬喻题通意别。别在实故药草化城题别意别。问化城等可知。答中意者。此中文促无复二味。但叙城后即向宝所。准此文意说化即是开权。开权即是显实。显实秖是说化。故前约教中是圆教也。故应知是开显之圆。又领解下释妨。以陈如记后方领故也。若记后领具领闻法及以授记。或文少等通有诸意。如今下云云者。应出前渐后顿之相。具如文中古今二同。次偈七行颂前三义。初一行颂所见事。次四行颂譬久远。三二行颂结今昔。经云其佛等者。一切八相垂迹之处。皆先破魔准说法华。亦应先渐。复云破魔似同秽土。若准寿长复非秽土。故知同居净秽其相盖多。故成道等不可全同此土三藏。故知不可若引此土小教以消彼文

问。时诸梵天雨众天华。其华如山树座犹下。其相如何

答。不思议事彼此不碍。列十方梵文。正本中先四方次四维次上下。此则并是随译者意。不知梵本次第如何。然正本列数与此多异。相应下云云者。皆据诸梵请法偈文亦与大小半满意同。然彼佛说法亦约五味。故依古难当谓示劝证云云者。应略辨三转之相。示者。谓此是苦乃至此是道。劝者。谓苦应知集应断灭应证道应修。证者。苦我已知不复更知。乃至道我已修不复更修。示谓示其相状。劝谓劝其令修。证谓引己证彼。大论俱舍诸文委释。若以大小经论转法轮义同异之相。尽着此中纸数盈百。尚不可尽。意令知彼先小后大同此土耳。故不多述。今辨诸门略示同异。于中为四。初约所对。次为声闻下约所为。三何故下明三转意。四问下料简。初文二。先对四法次对三道。以四法中义类同故。第三意中云为众生有三种根者。声闻乘中自有此三。故于鹿苑取悟不同。大论婆沙亦云三根。上根闻初转。中下准知。问初为等者。既云声闻自有三根。五人并是声闻根性。既具三根。复有诸天何意无三。为生下答。人天通有三义故也。谓慧根道闻等不同是三慧。悟有前后。即三根。见修无学即三道。色无色般义准亦有。但非因转法轮得耳。次释十二行者。为二。先双标两门教十二者下释。释中又六。先略释。次又教下判能所。三十二下判轮非轮。四若作下判教行。五教轮下判名体宽狭。六或通下判通别。初文中云十二行者。四谛各用示等为教。一转各生眼等为行。言能所者。四皆佛说故云能。度入彼心故云所。言是轮非轮者。轮以摧碾为义。唯教无行岂能摧惑。若不摧惑亦无轮名。佛知机知时亦不无行而徒转也。今言非者。教从化生行从受者。是故行轮从受者。得功归化主故。从佛得以未尽理故重释之。若作二轮教行相循共能摧惑。况复教行俱由佛转。是故教行俱得名轮但眼智等无别体故。还指忍等故。眼等行约于谛教。而成十六。故三根人闻三转教。各生眼等。成四十八。宽狭中云教轮等者。是化他智但属一权。则能转唯一所转十二。则能转名狭体宽。所转名宽体狭。行法轮者。教是能诠行是所诠。故行随教并有十二。虽俱十二宽狭则异。教定十二行生眼等。若以示等生于眼等数同名异。次辨通别中所言或者不定辞也。或三人各闻三转。或一人前后闻三。初虽别简。今就下正释。初转法轮得见谛解。三乘之人方有十二。所不下简不能转者。又为二。初略示其人。次有解下因兹通辨大小通别。初文二。先正示人。次夫转下明不能转意。初文云沙门谓佛法出家者。不因佛说尚不知名。岂能转耶故法轮名唯从佛得。沙门尚尔况余众耶。有云。外道中出家者名沙门。若尔。何故云尚不能知当知以正况邪。有解至之意者。今师有时作此解也。因此通辨非初转也。于中四。先明一代卷舒。次小乘下辨一代体。三十二下辨名体同异。四又三人下辨通别。初文者且从谛体以论卷舒。从无舒四卷四归无。卷舒秖是开合意耳。具如玄文七重二谛中说。言大小者。且约小衍释出体耳。委悉应约五味四教。以明开显。具如玄文及以止观辨体中说。三明名体中。云十二因缘是别相者。一者总离而为三世。二者别离因二果五因三果二。具如玄文及俱舍等。四明通别为三。先约因缘。次约四谛。三约六度。初文又二。初对三人。次无生下明卷舒。初三人下通别可见。相生传传灭者。舒则传生卷则传灭。具如玄文以辨兴废。次约四谛。但以二乘对菩萨者。但是文略。亦应先明离合。次对三乘四教后明卷舒。三约六度中四。先明通小。次明通凡。三若尔下释疑。释中但云二乘不云凡夫者。二乘犹有分得故也。四阿毗昙下引小证通。宝云经三乘毗尼者。引事证通云云者应具明所以脱子果两缚者。叙初显后俱解脱云云者。应释三脱相对三念处。具如止观第十卷。乃显俱解脱人具足事定名深妙耳。诸根等者。文有二释。意者初释即相似位。次释云入佛境界者。即初住位。具如华严十种六根下文颂中。云分别真实法者。分别故始自色心终至种智皆不出实相。故云真实。八万四千劫下云云者。须得具明时节之意。诸佛奚尝不与定俱。但由物机在十六子结缘齐限故。尔许时具如次文所述者是。正法华云。入定经三十万劫。不知法护所以所译其数顿乖。逢值有三种者。前二可知。第三既云但论遇小中间之言。自望元初结小缘者耳。第三类人未曾闻大。便即流转。此人即以初闻小时为初结缘。复于中间唯习于小。今遇王子初且闻小。人见释迦一代教中一分声闻未发心者。便即判云。永灭无发。是则不知如来长远之化。次问答。答中约四悉说。文少不次。先对治。次为人。次乐欲。次第一义

问。此经何文赴其乐短

答。龙女是法师品中。虽无时节计应非远。小乘教中尚乃秖云六十百劫出界。但经八六四二虽大小有殊。犹在权教。故实教中六根五品一世可期。乃至金光明经一生十地。故南岳用普贤观意云。六根极迟不出三生。虽四悉赴机随好长短。论其自行终无端拱。准论即是众生意乐意趣意乐。正当四悉之初。仍少余三。若指他佛为平等者。终不及以四悉意也

问。法华实教秖应实说。何故劫数犹短说长

答。言权实者。论所行法时节。乃是诱进疲夫应知权教一向说长。如婆沙三秖及诸大乘经无量劫。此则定不可短。虽实教中有长有短。若依实道定短为正。如常不轻轻毁之众。秖经四千亿佛。皆悉得度。岂有必经多尘劫耶。虽然长短在机理岂尔耶。既长短约人。但不笃自勤。何须论他时长短耶。三乘通教有余国者。一家明义以土对教。具如止观及净名疏。并有用教横竖二对。横论土体与教相当。竖论约土用教多少。则二乘人于彼有余。已成通人故云通教有余国也。亦有于此已成通人。谓从鹿苑至方等部。重入通教成无生人。亦非更用此教断惑。教道者化道也。教为化道故云教道。众又清净至立也者。化道欲毕由众机熟。熟谓智断二德具足。故清净言表烦恼尽故云断德。正解属智智必照谛。故云了达。诸禅之言义通智断界内惑尽也。四不坏信者。俱舍二十五云。证净有四种。谓佛法僧戒。见三得法戒。见道兼佛僧。法谓三谛。全菩萨独觉道。信戒二为体。四皆唯无漏。论云经说有四证净。谓佛等四。四是所证见三谛时。得法界二。见道谛时兼得佛僧。广如论文。此全从小释也。此以鹿苑对涅槃时。次释中唯清净一句在小信解去。具腾渐中二味教也。前释应方便譬喻品意。次释应信解品意。若世无二乘等者。问意者准理世无一人合永入灭会必归大。何用施三。答意可见。世言入者。但自谓耳。经文既云无有二乘而得灭度。岂可必立定性者耶。若中间至第二譬也者。此两中间各有二意。若为菩提者。须已入不退位。或是初心不必尽退。若住声闻者。或是初小。或是中途二类。俱须设化城譬问此中等者。问化城品但云始终随逐。何故无信解中相失及譬品惊入等耶。若其无者彼无随逐。又亦应与中上永乖。何得以此而例于彼。答中意者用譬方法不同故也。文不合用非意阙也。故云而其意则通。所言通者相失相见。既是中根得悟已后领于今日未有大小化前名为背父。及明见父不识之咎。譬中云惊入者。我虽背父而父不舍。恒思我机机生之初。故有惊入之义。若论机应结缘已后。奚尝不随如今文耶。此中既云中间相遇。乃至今日相见得度。故知中间不无相失惊入。当知随逐由惊入。惊入故相见。相见由相失。各举一边大旨无别。次问者既云随逐。不云失等。今既得益那无不虚。答中意云开显已多取信为易故。不假用不虚譬也。又上为中下未悟。今此迹事已周。二十二番者。准下疏文。问五处开权何异。答中具列五文处所。故知此前但有四处。四处则有二十二番。五佛章为一处。长行偈颂各五即十番也。譬喻中开譬合譬。各有长行偈颂。故有四番。信解中领上开合。各有长行偈颂。又有四番。药草喻中亦有开合。各有长行偈颂。又有四番。三四并十即二十二略开。但是动执生疑。非正开显。颂中虽有略颂等文。但属释迦章中共为一意。法说虽有领解述成。非正开显。药草疏中虽云先智次教总为开合。若各立者则成多番。有何不可。是故且依疏文为定释五百由旬中先出他解。基师中先述。次破云今谓非别非通者。七地断习非正别义。八地断无明又非通义。正似别接通耳。论云。初地见道二地去入修道者。应知地前是伏别惑。登地是断同体见思。若不尔者。岂有大乘回向而齐小乘上忍。十住已断界内惑尽故。璎珞云。七心不退何处暖位名不退耶。十行遍入十方世界顶法仍退何能遍游忍无出观之文。安能法界回向。璎珞初地三观现前。如何初地始入见道。请将四十心位。一一以消凡文。伏断义殊功用天隔。论中破外破小。本令入正入大焉。存定性而令永灭。小乘自谓住果。大判终无不生。故知灭后彼土得闻不可复依不闻之论。论宗既无开权之说。永灭乃是蔽实之文。有定不定秖可用申斥夺之经。废偏废小权实之路永隔。具消此意诸教自显。有家云流来等者。依摄大乘师立七种生死。仍少有后无后。复合反出流来故但云四。具如止观第七及记。彼文破云割二死于荒外等。今文乃成割于四种。故须更问等。是以生死为譬。何故合反出流来。又无余二中间即是方便生死。有人难者难向摄师。夫因果相当准教。以立因果之称。具如胜鬘。彼以五因对于二果。四住即是分段之因。无明即是变易因也。汝于分段果上既更立流来。于变易果中更开中间。亦应四住无明各更别立。具如止观中破。次引大论二文者。证生死但二言肉身者。四住未尽通名肉身。言法身者且通界外两土。俱称变易及法性身者是也。此证二死非论常身。此大论正文当代大乘师。岂过于龙树。云阿罗汉须舍分段方入变易。有人云下。此师所计似通教义。故云二国中间难过。以六地与二乘齐。至此多堕二乘地。故难者下他人难向所立义也。汝以四百喻于七地。故须六地对于三百。三百又以二乘功齐。既与二乘共行三百。至此去住不同。何名共行。故下难云不应得齐。言六十劫等者。声闻极久六十劫。支佛极久百劫。二乘于佛道纡回者。明二乘人与行菩萨道别。且取证故。今谓下破云非通非别者破其难者。二十二大僧祇故非通。六地齐二乘故非别。二十二僧祇请检大论。此亦似别接通义也。有人言下别义不成。不应七住已上为五百。如大经八万劫到等者。具如止观第七记具引大经三文。此师意以发菩提心处是七住已上言如三根等者。此师意以三周得记为三根人。以同至大经发菩提心处。言五种人者。指前大经四果支佛。此五种人发心同三周人度于五百。此取下破前所引。明八万与三周不同。当知此师全迷次位。亦全不识八万之言。亦不解二乘得记之位。亦不了于界内外教。若挫若引其意各别。故须善识。难云去今文难意。经云。为二乘人立于化城。故云二地岂是度三乘。而云菩萨至六地时等耶。三乘之人不尽住城。纵入城已亦不皆至八六四二发心方出。次若五人去纵难。纵有此义。如涅槃中二乘人必至界外方度五百者。义不尽然。故云大经一意耳。言一意者。经存教道被钝根者。岂可悉然耶。又经虽三文但是一义。故云一意。然大经意令其弊远逼令现发。岂可一向待界外耶。此中下今家略解。此化城意元为此世先权后实之人。若五人下明此五人。若于界外经于长时。皆自能进非此中意。若法华前密进之人。为自进者亦非此中意。准今经意待废方进。故不闻妙经。自度自进者。亦失化城意。即是失今经意也。今经意者出在外界。亦须闻经。况此界耶。有人云。三界为三等者。具如止观中破。破其二乘不待开权。而自显实。名为辄行四百五百。凡夫等者。今家杂列过二障灭二见。离水火免二狱。越二边超自他。并至五百。大品下此立通义。令知非实既是通义。故合二乘共为一百。论文以二乘为四百故。若至法华更须开之以为五百。五百须过。具如正解中说。次引大品辨非故来。彼大品中明通菩萨过二乘地。既未彰言此城是化。故知彼部兼权显实。若云化城即须引进。若引进者须记二乘。既未记二乘。是故彼部城仍是实。既未论下今文设征。既未云城是化。即未开权。若未开权应亦无实。何故般若已明实慧。实慧即是实所故也。答意者。显实语通开权局此十义。别中行因六百劫者。恐文误。应云六十劫百劫。声闻六十支佛百劫。余者可见。火宅三车今为二百者。今文假立难也。何故譬品三车须废化城。但云二百须进意。以二百但是二乘。三根下答。先答三车者。三乘根性俱为火烧。俱求出宅以喻三车。次佛道下答二百。言佛道者指圆果也。故藏通二乘去佛果远。是故须过二乘二百方至佛果。言佛乘非障者。藏通菩萨亦名佛乘。尔前皆进故云非障。又三藏菩萨若据断惑劣于二乘。三百须离岂二百耶。但此菩萨已发大心。虽未断惑且名佛乘。人见佛乘便为一概。若尔。牟尼说法蕴应已摄九会。五百阿罗汉应是四菩萨。世品应说莲华藏海。贤圣品应说四十二位。定品应是楞严三昧。智品应是诸陀罗尼。若法若众既其不同。化主化事安能不别。如是别相无量无边不可具举。菩萨求此乘故。亦且名为摩诃萨耳。何故下更难。何故界内凡夫开为三百。界外圣人但为三百。此问意者离分段界内应短。迷佛道界外应长。如何却短。此引下答可见。若尔下更难若也。今经是了义者。何故实少而言多实多而言少。佛道下答界内虽少以有堕苦而难行。界外虽多已住法性而易进。约行论难易非约地近远。故所说者真了义也。问二百是二乘难等者。问意宝所总有五百由旬。凡夫二乘俱须过之。不云须过菩萨。菩萨应当非是难耶。菩萨下以菩萨重征。若菩萨非难。何故云愿赐我等三种宝车。若俱须车则三人俱为三百所障。既得出已应同二乘。二百是障云云者。先以通教答此难意。凡夫须出界故三百是难。二乘须发心故二百是难。菩萨已发心虽难而可度。菩萨在凡时。同凡离三百不共二乘证。不忧二百难。若别教菩萨初亦同凡夫。本期于五百。圆人初发心即名至宝所。大论下引论辨别是通教意。当知共二乘同至于四百。今经独在圆。一切权已废。废已一切开。无非菩萨道。是故七方便皆过于五百。故大论通义三乘所息处同皆名四百。菩萨至此位能入界化物故。初发足处。复名为一百。此经下明圆异通。五百之内位在菩萨名菩萨道。过五百者名为果道开权显实。藏通菩萨是菩萨道故。云即入佛道。云云者。应更明诸教佛道不同。然后开权论入不入。今依下方是正释。亲奉圣音尚云难知。虽曰难知不出此三二险难至言恶道也者。导师意本令度五百。以三藏人自行旷绝。三百生疲。导师立化一旷绝等者。入城多是三藏二乘。且云无人。据理通于通教二乘。有人之言通指衍教。圆别二教非旷有人。故有依无依俱行旷路。即藏通二乘有一导师。至六根净者。即十种六根。初住分得。即十六子初结缘时。若诸方佛今日已前或可亦在初住已上。今八方作佛唯在极果。故释慧明云三智五眼三明十力。经云慧文云智。随语便耳。然明慧等亦通初住真因分成以是故知通指今昔并名导师。俱六根净故。下释中多种导师。并共在此所。将人众等者。上立难云。何不立相失惊入。今虽无其言似有其义。以所将之言其意尚宽。与所将共即入义也。故云别譬广颂等。第二白导师言至结缘之导师者。此四导师。第一通因果。第二唯在因。三四唯在果。言通途者。通他人故。言结缘者。局我师故。言权智者。取施小时。言实智者。取开权时。四从时异人秖是一并是王子。从始至今。言白结缘者。初退已后小机欲生。名之为白。示城之日通往及今。虽有余三必须通途常相随逐。感于法身者。大机已灭小机当生。故未见应佛。冥感法身非冥非显应耳。作化说化者。前虽云化作一城。乃是意轮。故知说化即口轮也。非意无以说。说必身轮。身轮但据示为丈六。先须意轮不谋而运。故知三轮未尝暂离。汝等勿怖等者。义含三转文不次第者。且明化城具三转义。何必次第。前至宝所者。初今文正释义。在衍门约共菩萨。次一说下他人异解。若尔下今文判此。三乘中仍取菩萨。似同别教从假入空。若引胜鬘但是通途论退大者。故亦应云别义不成。且一往耳。何者。别中更无作二乘文。然大经中亦借二乘以别别位。故且言之。又说云下他人释。大品下今师引大品净名。判向一师云别接通耳者。但入化城竟通也。然后前进者。别接也。大品中明三种菩萨。皆云初发即是被接。若二乘人显无此事。净名亦尔与而言之。似别接通耳。又二乘人闻菩萨不思议法。仍取小果。秖于此座即被弹诃。及加说大。故知从此密蒙被接。若准玄文至般若时。冥成别人。故显露接。唯是菩萨。二乘密得无处不通。若言至般若时成别人者。仍是次第之密。非不次第。不次第密处处显实。岂但别耶。但于今佛等者。释出其意。亦如今人等者。非文正意对退大等。一往言之。具足应如从今现在已下文是。言今现在等者。指佛未开权前也。故知末代一时得闻。闻而生信。事须宿种。如涅槃中意者。即十仙等至法华中。化道已足故于涅槃显露教中。取小果者。皆知真实。大经三文者。然此三文其言小别其意大同。若至菩提心。必至菩提涅槃。初一是因后二是果。果中既是智断二德。故初发心菩萨可指初住分得智断。然经三文皆云八六四二。岂可因果同经尔许时耶。此且一往故菩提涅槃。并通因果。若教仍权但至初住。纵至极果其教亦权。岂必八六等方至极果耶。则与一生八地生身得忍为妨。然过五百三义者。先列三意。次菩提心下释成三意。菩提心即初住菩提。行者即从初住起行。二文并在因。即大经初文也。得佛道者。即二三两文。即是极位菩提涅槃。然须依理使宝所义通。此亦何必以极果为宝所。虽有二意应从初说。良由宝渚菩提涅槃其名既通。故得两释。故从圆义。从初发心三义具足。下文云下至得佛道也者。引今文证三义也。何故下问二乘。下答一往从果故。佛度五百免难大机发者。以文狭故。准譬品可知。大经下正判但至初住也。此取钝根者。有二义。一者五中前三人钝以住果故。二者五人大乘根钝以教权故。故云若如三藏中至岂须八万与十千耶。验知八万等其教是权。未至界外者。尚于此生法华即发。岂定界外必尔许耶。云云者。释出教权须废所以。当知诸教长远之位。多是教道。岂有出界闻胜应说。必须更经八六四二。虽尔若不释此开权妙经。岂可专辄泛有此说。今根浅者便生疑谤。佛世尚经四十余年不显真实。若除佛灭后。及首楞严谤亦成种。但非故恼成种何疑。渐入佛慧者。此中文狭。秖云灭化即至宝所不云城中经诸味者准信解品文。理必须有。旧问者先立妨。次车何故下列三问答中先答有无者初约譬。次理教下约法。先譬者今问车城二譬并出三界宅。与三百俱譬三界。可由对车使三界与涅槃有隔。可由对城使三界望涅槃即迥。次约法者。城在界外如何执教。即令理有长者说车。不应唯理教何必无。然所譬之处。是同安得车隔城迥。长者既其露地而坐。车亦应迥。其路既经三百由旬。城亦应隔。若言其路旷绝名为迥者。门宅俱烧何隔之有。既难法喻无可为凭。何以有无不同而为答耶。今约法寄喻方为通之。昔覆实明权权隐于实。故云车隔。今彰灼说云城是化。故云迥地。岂有执教取理令一理是有执理取教令三教成无。若尔车城俱有理教。咸是有无。次车三下答三一中亦先约譬。次约理教。先譬中云息处所乐三一不同者。车可非息处。城可非所乐。车既皆云运载息其东西驰走。城云快得安隐令其乐于中止。次约法中尽无生智不异等者。并是通义失藏三乘及别菩萨尽无生智不名为理。习尽不尽不名为教。知见得否亦复如是。如何初立理教。乃以智习释之。况正当三藏二乘。唯以通教答义故不可也。应知通教三人各证无生。故三三人同坐解脱床故。一是则人理相望人三理一。三藏人理相望亦然。但菩萨与二乘不得同坐解脱床耳。次三家下答动静者。城岂无造立之日。及须能通之路车可无作讫之时。及以所至之极。故知果。城为因车之所至。果车践城路之能通。故使索车即是求城。灭城即是等赐二义无别。何足辨殊。故释仍阙先譬文也。难云云者。意令准望余文难之。略如向辨。顺此注意故略论之。次今明下正解初斥有无。从三车下斥三一。问城与二使下。破动静破初文中言约众生心为有者。一者本有。二者中途。今约中途故二并有。又亦可云元发大心。故无中以小接谓有。次约佛智先立句。次释亦应更须翻倒说之。实智所明说城为化故。亦无权智所明。为子造车故亦有。云云者。应须具明多种有无。约能设教故俱有。约所证理故俱无。覆实故有。开权故无。施权故有。废权故无。俱是造作故有。俱是化他故无。故知法华非但化城亦是化车。皆逐便耳。化城正意为退大者。更与上问对论同异。故今文云。前路犹远今欲退还。上两周未有此语。但云没苦及以所烧。此亦一往亦可退大者。利通上二周元小者。钝应在第三三车通今昔等者。昔指三味今谓法华。故二教中俱有三车。但昔正用今述昔耳。又应以体外体内之名以简今昔。言化城等者。亦应更云化城唯在今。言教意者。若不于今经以说教意。不可辄云小果是化。正施小时。云是实故。故云未道是化。至今经中初设之时。即云化作者。以是声闻大机动时。得说教意云城是化。故知化城在昔对人亦三。三车在昔对理亦一。问化为三车等者。问意者。车城二果俱在涅槃。城有化名。车岂非化。忽若许化同异云何。答中一往二轮虽复小异。论其施化大旨仍同。今从便易通且从化说宜从教。又亦应云譬如幻士为幻人说。车亦名化而于中道说二涅槃城亦是教。故知不可从譬互执。又约声色者。亦暂约喻车亦通色说城。是教如前云云。问城与等者问也。使能下答也。亦且一往城亦教故。故下所列因缘四谛还是城家能诠教也。城既有教城还是动。何故唯静教通因果者。能诠因果故也。车城唯为果作譬也。故知俱教并果。何须别途教通有为无为等者。亦约能诠有为无为耳。车城在果约无为故意亦如向令无各计。故更于权智广破定计五处。明开权中云虽各于教行人理及知不知。且随文相一往而说。故一一文皆须并具四一明如来知不知等也。今为汝等作大导师。为合多诸人众者。此以能将。显于所将。说二涅槃者下。此中三释。具如前文约烦恼生死及智初文约惑。次文约二乘是约智也。后文约生死。言中道下云云者。二死中间名为中道。当知亦可作空有二边共不共真俗权实大小等说之。如文下云云者。令引文耳。上懈退中三。今略不颂第一中路。又不颂第三不能复进。文阙。重空三昧者。大论云。无相无相乃至无愿无愿。观心释化亦须约圆。颂合譬中。经云为一切导师。文云合五百者。即导师譬。五百由旬从所行说。上颂开中不颂中路者。亦是文略。应云亦不颂不进。今颂合中路。又无余二。不纵不横具如止观第二第三及玄文三法

法华文句记卷第八法华文句记卷第八之二

        唐天台沙门湛然述

    释五百弟子受记品

先标五百故须作受字。五百是数等非要。上二周下问也。次上为下答也。亦具四悉。初文世界三品异故。又上来下对治除嫌恶故。又默念下为人生大善故。又权实下第一义理非言念故。上来何意下但是释疑非四悉数。我等于佛下述领不及。上中根闻譬。具领五时及法身地。中止方便见胜应身。如来犹斥领所不及。我今闻此虽欲领会。岂能逾于四大弟子。当知所领之外不及处多。是故亦云所不能宣。然闻迦叶身子具领。如来委述非全昧旨。但仰佛法高深。未敢逾于先悟耳。助宣我法等者。若以本望迹。岂不曾于过去佛所。或助单半单满等。而必须满中相带及开等耶。对于今佛出五浊世。宜引开权废会等化。是故皆从同类以说。如文殊引往光照东方。岂无余途引同例耳。自舍至方便也者。若据除佛之言。补处亦应不测。既其不测本迹难量。何但曾于过去诸佛。亦可本与过去佛齐。就过去佛本复难量。或当亦是过去佛师。何但齐耶。言七方便者。且以偏圆相对论耳。故知远本冥寞良难。若尔。此是迹中本耳。六波罗蜜互相收摄。具如止观第二记。大品富楼那品六度互严。在文可解云云者。经文相状对义分明。又如诸文所列五时。纯是善道者。于中亦有差品不同。若无女人必无恶道。或时有女人亦无恶道。如阿閦佛国。虽有女人而无女事。无量寿国二种俱无。不同之相不可具列。但以乘戒各有三品。互相交络。略可准知。月藏第九法食等者。法食闻法也。如安养界下品生人。在莲华中。常闻弥陀观音说法。法喜食者。闻法欢喜。正闻属法食。闻已为喜食。禅食者。谓以禅法自资不须段食。或可法即是喜。月藏第五十善各十功德。亦与净名十善是菩萨净土意同。故一一文末皆云后作佛等。彼第五经信敬品云。戒清净平等所谓十善业道休息。休息杀生获十功德。何等为十。一者于诸众生得无所畏。二者于诸众生得大慈心。三者断恶习业。四者少病决断。五者长命。六者非人所护。七者无诸恶梦。八者无怨。九者不畏恶道。十者命终生善道。若能以此息杀善根。回向菩提必到菩提。成无上智。到菩提时彼离诸害仗。长寿众生来生其土。下九并十。从若能已下去并同。故菩萨因时行于不杀为净土因。而自不杀教他不杀等。四法具足。后成佛时十类众生同生其土。故净名云。十善是菩萨净土。菩萨成佛时命不中夭等众生来生其土。故智论中菩萨行于一行。皆具四法方成净因。身子示嗔等。具如止观第二所引。文中正意语示为凡夫外道。故云三毒邪见。但兼出于示小乘习。示通二义故更言之。云云者。令具引事列行。兼诸圣者各有偏示。陈如等者

问。若其居首别记。何不初周记耶

答。大小缘别两初不同。引物希向。二意各异。垂迹之法不可一准。譬说有二至显实者。皆云领法譬者。故前开譬本中。直作开权显实。则应三周及信解五百领解文也。三节开文意在于此。言譬如有人即二乘人者。二乘机耳。小机当起尔时犹大。醉有二义与前堕落中二义意同。初是幼稚譬着五欲。但如法师常不轻等。或一句结缘。次是善弱或五品初未入相似。故云弱耳。以由结缘厚薄不同。遂名无明以为轻重。故云醉有二种。当知贫人本来先醉。如蒙肴膳受已而卧。三教助道犹如肴膳。更以异方便助显第一义也。肴膳食已便消如方便教非究竟益。往在大通佛所。未结大缘已前历诸味中。并闻三教。及至法华虽闻圆顿。但成结缘如系珠也。无价至真如智宝也者。此是约教乃以了因而为系珠。教中诠理故云真如。教是智用故云智宝。约受化者。教能生智亦名为智。宝有二义。俱是智家之宝。系其衣里者。初结缘时具足二衣。具惭愧故。有信乐故。方能结缘退大堕恶则无外衣。若约现无信乐乃似内衣亦无。且据当时所系内种仍存与本信俱。义如内衣犹在。但是衣弊非全无衣。故亲友示还示衣里。即是示本惭信时也。据此而言无衣系身理亦无失。起已游行至求于小乘衣食者。应更求于宝衣天馔。而但求于才蔽身之衣。劣充躯之食者。由向他国故也。文中二释他义皆成。若论有求今日稍切。故云厌苦等。若魔佛相望等者。今日初得小乘之他。且从大小以说。故知若往他国求济。非但衣食不充。亦迷所系之宝。示珠之友居本土故。劝贸譬得记作佛意者。珠虽价直无数众宝。必须贸易方有济用。了因内解虽复究竟。必以种易现。以昔一解一切解。而贸一行一切行。珠体不竭贸亦无穷。故须更听更修方显宝之功用。如华严中得摩尼珠。十种莹治方能雨宝。解行相称方堪佛记。从是已后则具有寂灭忍衣。首楞严食自行化他无量众宝。无功用位彼此不穷。三周皆有此意者。若以系珠望上二周。法说但在佛树者。初坐道树思用大时。以法说时未论往古。且据现文。若譬周中在二万亿佛。彼亦未论尘点界故。然上中二周岂不亦有于大通佛所曾系珠耶。如探领中尚领法身。岂止道树。且约现文耳。但由根利闻便信解。不假指昔。是故末论故前文中以发轸学小为中间故。不唯在道树时也。某年等言。亦唯在秽不通二周。无量佛宝者。宝由贸得故。亦可云得佛之宝。即利他也

    释受学无学人记品

因缘初文应具四悉。学无学别即世界。见道位即为人。修道位即对治。无学位即第一义。又得记即第一义。约教者。三教如文。研如来藏去圆教。又如通序中释若约观心者。六即之中究竟即为无学位。余四名为学。理即非学非无学。又六即者。通皆非学非无学。分真已去而学而无学。云云者。如向略举。二人在上数中者。在多知识中列。今之得记何为在此。答中总论得记。在千二百中。仍是下根中之上流耳。虽有多人所识意为引下根故也。若尔不答上问。问意何不同上周。今答中但云下中之上。如何称问。然非上者为引实故。四悉檀故

法华文句记卷第八之二法华文句记卷第八之三

        唐天台沙门湛然述

    释法师品

释此品者为二。先总释。次别释。初文二。先释五法师。次减数释。初又二。初出经论以辨离合有无。次判通别以结品名。初中二。初依今经判五。次大论下出异释名。对今以辨离合有无。乃至如下减数以释。故若多若小俱名法师。初五法师者。未有一文着一二等言。古今共立称为五种法师故。经论所立多少不同。所以此品但通名法师。天王般若云。受持此经有十种法。一书写。二供养。三流传。四谛听。五自读。六忆持。七广说。八诵。九思惟。十修行。十中第一是今文第五。第四第六是今文第一。第五是第二第八是第三。第七是第四。流传摄在广说文中。余三并摄在忆持文中。彼经忆秖是受。大论中分受持为二。则应不得单云忆持。此别论下判通别以结品名。于中先分自他以别师位。言大经分九品等者。元是别义。且借以证五种法师。九品秖是熙连并八恒。第四恒广说。于十六分中解一分义。云前四无解者。三恒并熙连。五恒八分。六恒十二分。七恒十四分。八恒具足尽解其义。故须应从能解一分义去。能为他说即是师位。次通论下舍别从通。自他俱得受此品名。从通义边无有一句不任为师。次减数释又四。谓四三二一。并是展转束多入少。无非法师。云如后者。具如安乐行品初释四行是也。四既指彼。此应用四以结品名。文无者略。已有前后中例可知。若欲知者。秖是先判通别。次从通四以结品名。束四为三。又为三意。初三业。次三门。三三法。一一皆先释。次判通别以结品名。次束三为二。谓自行化他。云不复记者。准前可解。亦是先释。次判通别。以结品名。以此自他既遍前三。故知自他亦有通别。别论各别通论互通。自他皆互堪任故也。今通从化他。故名法师品。次束二为一者。谓如来行具一切行者。此依大经圣行品文。复有一行是如来行。所谓大乘大般涅槃。涅槃秖是三德秘藏。故今却以室衣座三。以释三德。三德秖是一大涅槃。此大涅槃遍一切处。遍一切法总名为一。先释。次指广。初释中为二。初通次别。通者。一行通具室等三法。别对为二。先对。次料简。初文为九。于中并以三法对诸法故。初对善恶及荡相也。次又慈忍下福慧。智慧是目等者。亦应云目足备者。必有所依。所依具二故也。三又慈悲下对斥偏邪。亦先释。次引净名证。胜于偏邪勇修于圆。四又慈悲下破四魔。亦先释。释中并须约于界外圆释。次引证空也。云云者。释出其意。五又慈悲下明具二严。仍为二释秖是翻倒前释。准后望前前应云慈忍也。六慈忍故下约譬破立等。具二例前。七又慈悲故何所下约体用。用即离过。八出三谛下约名。不同次第三谛。慈室包含忍衣三昧。九经言下引经。无相是座。次指广云不可尽。云云者。具如玄文明圆五行摄一切行。亦如止观十乘十境横竖遍收。及破遍中横竖法门。乃至四种三昧收一切行。一切行秖是一行故为九文释之。次问下料简。初问者。准初释品应云五种。准后减数应云一法。何故但以衣座室三而对诸法。答者。准事显理须具三法。况依当文应具三法。乃为众说。故具事理二三。方可说法。故先事解。次事理合。三单约理。事解如文。合释中言三门者。初二属事。后一属理。事理并是所迷之境。初约苦果者。故用慈悲门苦须拔故。次约结业者。故用忍门依理离故。三约谛境故用空门善住空故。第三单约理者。理即谛理故约三谛。即向第三具三谛故。言云云者。应以多种三法对释此三。令成圆融通畅自在。乃识此文摄教遍相。故下总约教云。凡多种释品者皆约圆教。次法者下别释。法师二字通贯上来一切诸释。以上诸法是师法故。故今释名亦约二种乃至五种。若自等因缘释者。初自他不同即世界。即自轨训人也。自行成就即生善化他除恶即对治。自他俱得名法师者。第一义也。凡多种下约教如向多种不可余释洽润也。外凡去今文正释

若尔与旧何别

答。今明为自他故。异声闻故。自行无有忧摈辱故。利他无鄙力劣弱故唯有退没一分似旧。故云未必。言外凡至不虑危苦者。外凡五品欣弘通之福。声闻一向绝利物心。闻诸大士被众摈弃。自顾观力未深。若不依之。内污净观外招讥议。失利人之道。故佛为说四安乐行。令无是患。远彼十恼故云不虑。且证且助者。宝塔证经故来。分身助开故集。由证由助因慕流通。又示通经方轨者。着衣等三具如后说。因告等者。本托药王因兹告余。此流通。初先告八万大士者。大论云。法华是秘密付诸菩萨。如今下文召于下方。尚待本眷验余未堪。总别记者。总与七百。别与劫国等。絓　乎卦切挫也

预也。乃至一念等者。明乘此念必得菩提。远因不亡藉兹而发。不同余善是故简之。究而论之。必须尽行诸佛道法。二乘记已尚经劫数。然晓其经旨与具足何殊。但自行化他令始未耳。闻一句一偈者。通论但云闻极少法。举经功深。部内随取一句一偈。别论但今义合权实本迹十妙四一之流。功福皆尔。然义通大小。故下引增一集云。如四谛之流。及下引四安乐行等。今亦准之。言皆与授记者。必由此经成菩提故。虽无劫国当得理同。此中容用别时意趣。是故应须以闻约行广明供养。宣通益他内观具足。具如止观。岂可端拱唯仰初心。中上亦然者。若不尔者。岂可上周唯在一人。中周四人得记者耶。说寄在此事乃通彼。故云亦然。见实三昧经等者。第四云。先记八部。次第五卷空天品空行诸天见诸八部供养得记。即便供养悉皆得记。同名火持。次三十三天授记品中。有八亿忉利诸天。见前诸天供养获记。亦皆化为诸供养具。同时得记名因陀罗幢。说如幻法。次夜摩天品。有四亿夜摩。亦见诸天供养获记。亦以化事及以说偈。供养佛已同时得记。同名净智。言拘翼者。彼经无恐误。观心者。以一实观贯其所诵。故名为一。无一句偈不入实者。云云者。应明一观之相。乃至大师诵经观法。还约诵持以成观相细思。劝发四意者。一诸佛护念。二植众德本。三入正定聚。四发救一切众生之心。下文亦以四法对开示悟入。虽是迹要。若显本已即成本要。具如下辨。喜心有二者。横竖二释。又二。先正释。次融通。初自二。初竖论随喜为三。初即权而实。次即于下双非。双非虽不异于向实。更能解实即双非故。初于一念者。非唯经于一念时须。指一心法名为一念。信佛知见者。于初心中深信妙理。此理是已佛知见境。境非权实故曰双非。以理望闻。闻浅理深。故名为竖。此即初随喜位相也。三又能下于向双非复更双照。事理圆融即名秘藏。具烦恼下虽未入品。亦可通证。具烦恼性能知故也。烦恼望藏。藏深惑浅故亦名竖。次又若闻下横论随喜者。还秖指向不二权实。故云若闻等。四法横论以释随喜。谓一心。二法。三说。四人。初言心者。即以一心望于余心。名之为横。此中一心无复余心。故下文云。即横而竖。及一切法者。以一切心望一切法。亦名为横。一心一法皆横缘故。法纯是心。心纯是法。故下结云。横即是竖。此中自云皆是佛法。佛法理合横竖不二。若欲下次约说者。能广分别一一心法。月四月至岁者。虽引意根之文。非即六根净位。今且约观。虽未下约人可见。引大经者。此初一念正当少闻多解。亦名少解多闻。故且举之。以斥多闻不知义者。后当更说者。在第六经。初云上下品师者。但约凡位以判。十种供养者。一华二香。三璎珞。四末香。五涂香。六烧香。七旛盖。八衣服。九妓乐。十合掌。音乐如前料简。次药王至是人自舍清净者。悲愿牵故。仍是业生未有通应。愿兼于业。具如玄文眷属中说。如释论有慧无闻等者。此偈及四法师偈。具如止观第一记。故知亦许为弘法故。于内教中广习异义。以助正教。世有习俗典而云助正。反沦至理。当知是人等者。如王使传命。若赴主心故得名使。得所遣名。初经是下释如来能遣。能遣是教。次今日下释所遣。所遣是人。行如来事下释所遣事。先约自行释事。佛无他事唯专照理。次今日下我今唯行如来之事。真如是理照即名事。一如智下约化他释。如来利物由境智合。还说此理以为化事。故知大悲还依如理照如说如。名如来事。今日下依此利他名行佛事。佛则平等恶不干逼等者

若尔供佛无福何须供佛。毁佛无罪何须制罪

答。实。是但为成校量故。向云不论福田浓瘠。若从田论凡瘠圣浓。故应毁供重于凡也。譬如至俱薄者。亦约初心易成坏说。若约田说义例可知。如八福田看病第一。人多厌故看者福增。此乃约心难易故也。若约田就事。岂一病人比于大圣及妙法耶。如济匹夫与献主天隔。匹夫恩不自蔽。主泽沾及万民。四悉适宜不可一准。然约此经功高理绝。得作此说。余经不然。为如来肩等者。佛得权实及非权实。我亦得之乃称佛得。是则义当在佛肩背。亦是用佛权实等法。名在肩背。亦是众生常在肩背。日用不知。余经不然故须说之。若不尔者。岂持经者尽为如来肩背荷担。是故此文须废事释。若迷今文权实施开。纵作权实之名消之。亦未会此妙旨。经云应持天宝等者。先举人中上供。次以天宝况之。尚以天宝奉献。故云应持。况人中上供。有人云。西方举胜皆云天也。若尔前云人中上供即是天供。何重言之。第二长行初叹所持法等者。前约能持即举利他信毁以取人。此明所持则举人处因果以叹法。于中先列五章。次明生起。故知人法处三。互相光显方成因感果。有师下述他解。经叹法华至阙一节者破也。但立过未以为所校。即以法华为现为能。此师阙于所校中。今故云一节。云云者。依下今文释出现节也。今初等者。此正释中。先列三时在法华外。次大品下明三时不及法华。故以法华人法永异众经。若不尔者。破欲贬挫法华之妙。毁在其中何成弘赞。嘉祥犹然。况复余者。大品等带具如玄文节节明五味者是也。若不尔者。安知从昔未曾显说。秘密之藏不妄与人。多怨嫉等。当锋者。法华在前如大阵难破。涅槃在后如余党不难。初当先锋斯为不易。此经具说至亦即是秘密藏者。初是开权。亦即是下显实。权即是实故云亦即。如来至怨嫉者。思宿恶为怨。忌现善曰嫉。故障未除者为怨。不喜闻者名嫉。今通论者。迹门以二乘钝根菩萨为怨嫉。五千起去未足可嫌。本门以菩萨中乐近成者。而为怨嫉。阖众不识何得为怪。今仍在迹意则可见。理在难化者。明此理者意在令知众生难化。四信等三力者。文中二释共显一意。初对三德。次对三法。故四信为行始。四弘为能导。大智为能开。故此四信须约圆乘。谓一体三宝一念十戒。方为圆门四弘之首。故次文云。信则信理。理即法身。若有法身。即有理性一体三宝。志愿是立行者。四弘大誓立一切行。法身约所信。诸行约所引。众善之根即般若是。故所信中具足四法。既对三德从胜立名。若不尔者。安为此界他方佛之所念。初心栖此等者。此用所表如前荷负。若不尔者。色身共宿乃至摩不净头。于理何益。生处得道转法轮入涅槃等处。具如止观第七化身八相。此四相处尚应起塔。况复五师及此经所在。即是法身四处皆应起塔。况经着塔中。则为已有法身全身舍利。故引论证生法二身各有全碎。云云者。令释出四相。生身全碎如释迦多宝。法身二者。诸方便教法身碎也。法华一实法身全也。四教五时委简可见。故知诸经全碎相半。唯此法华法身全身更无余法。皆入实故。注家云。向以人为鱼兔。故与丈六齐功。今以词为筌罤故与舍利等妙。若其不简词之粗妙。还与色身齐功。此经何殊阿含婆沙。故知注家不晓持者与法佛共宿。不知所持与法身界齐。故十七名中名坚固舍利。碎身身界不受坚固之名。巧度者。如止观第六记释巧拙二度。彼大论文通以衍门为巧。今别以一实为巧。则有二种者。先列二文。今言下简取初意。又望下释近当体。前约偏为远。以圆为近。次今以下消文正意。以一如实智为因。趣于近远二菩提果。故因明近果。道前真如至为了因者。此以修得对彼正因。正中缘了同成正因。修中正因同成缘了。约真之缘了亦曰即真之缘了并可云真如缘了。全性为修即此义也。唯有此法世法不染。魔不能坏二乘不能灭。皆即是故。此乃以博地为道前。发心已后为道中。于道中位分之为二。初住已前为缘。登住已去为了。一位分二故名为亦。妙觉证后名为道后。与前小异对文别故。譬中必须教观二重。方尽其理。教观相循共显其妙。教观若偏二俱无力。初约观中初总明观。言虽通诸意且在圆。依通观下历教明观。祈体理同故略三藏。法华论等者。水如佛性。取之不同故云次第。即诸教观相浅深不同。须了其旨故云当知。约教中二。亦先总明三藏教门下。别约四味。今论渐初故初出三藏。华严后明前约观中。已寄四教。故今更约味以显部妙。若止观中复约四教。理亦如然。玄文一切皆先四教。次引华严者证获水同也。次有人。去五家四解。三家并约五时以释。然取时不尽及不次第。于渐教中初家弃初及三。次家弃初二及第四。第三家虽以大品在净名后。亦弃前教并违五时。生公与注者。全于法华中判。亦未全当。尚为他破故云去佛远近等也。乃以前三师同用五时为一解。生注二家同于法华为一解。今师许此破意是故录之。此师意欲判前五师四解。即前三后二两例破之。故前三以诸经去佛远。于法华后皆以佛果而为清水。故知三师去佛远也。一解近者。后二师约法华论远近。始自干土终讫清水。并在法华。若元依实教道理然也。若以实对权理不全尔。寻经下今师和会。以前三师指于前教无清水故。又用五时皆有小失。其后二解但于法华中以论近远。失于开权。法华已前是所开故。今师二义约教约味。约教即对前渐教中三教为粗。故须更唯约法华中圆以释。约味则对前四味中未转者为粗。至第五味教虽已转。或行未入。故须于第五味作远近释。是故二释阙一不可。问余经等者。他问前二释中初释也。因向他人判前三师释则诸教去佛远。准答文中具答远近。亦应具问远近二意。约纯菩萨及二乘人。准化元意。本求佛果于昔未开。权机未转故云未决。次问般若何故远者。古来亦许般若能生阿耨菩提。何故亦与诸经同远。答意者。大旨同前。然分二义。先约共菩萨同于二乘。未开权边名去佛远。次夫般若去。重顺问答。般若非去佛远能生法佛。何远之有。以具权实二慧故也。故举譬云。如病人等。病人者。共般若中新发心菩萨也。两健者二慧也。由此二慧令至菩提。故云遍能远去。言最胜者。意在不共同于法华。故且云胜。故云法华开权不异般若显实。故开权与显实左右异名。法华还开般若中权。入般若实也。故言不异及以异名。所以通论。则不共般若与法华种智何殊。据带不带开未开别。不无同异。诸师全顺今义。故但直录而无所破。菩萨下合譬。文既约法华为言。故可依前以为二释。释开方便门中。所以先广引料简者。此迹门之大旨。此旨若倾将何流通。于中先出光宅。次私破云是破非开者。由光宅云废除昔教。不云即是。故开义不成。又由光宅语昔别指鹿苑。故知消释言不容易。由除之一字便为臧否。嘉祥亦云。开二种之方便示二种之真实。昔不云二是方便。故门闭。今云二种是方便。故方便门开。今开义善成。二乃违教。经云佛以方便力示以三乘教。何尝但二。今文尚五七皆开。何但三耶。然此乃是未改时文。乃令后德混用。河西云。直名三为方便者。意云。昔谓为实无入实之期。故其门尚闭。今称为方便有进实之望。故其门名开。还引方便品初云佛以方便力示以三乘教。故章安许之。故古人立义采用实难。有人下言十二八万者。秖是十二部八万藏耳。私谓至非开义者。印禀龙龙从远。印既用教身两种方便。故知破其窃龙印之义。及将破义以解开门。何能异于光宅义耶。故略破之。虽用教身且免会二。问方便当体等者。私假设斯问欲出后答。私答中初正出二门。次此二下释二门中各有开闭。初云当体者。未有所通约体外说。且以当教可入称门。若云为实相门者。约能通至实相以说引算砂观海者。算砂如释签第四。观海者。即新经六十七云。有城名楼阁。中有船师名婆陀罗。集诸商人。为说一切海法门。此二门各有开闭者。能通当体法体不别。从今昔说。故昔闭今开。实相亦尔。于中先明当体。次明能通。二义各对真实以说。以实相亦有当体能通二义故也。初当体中虽亦名门。于实犹闭故须明开。然但说三为方便。即须说一为真实相对论之故耳。二者下次释能通。即为实作门。准佛本意俱是能通。据物机缘所解有二。诸钝菩萨亦有能知三教能通。但法华前机未会。是故在昔俱闭于今并开。故亦与实对辨。岂能通方便开。实相犹闭方便仍闭真实得开。此释同河西实相亦二者。向但直对方便故今委论。同于方便故云亦也。虚通者释实当体为门。无碍名虚无壅曰通。故得全体成能通门。含受一切无所隔碍。得名为门。遍一切处无非门故。是则约实无通而通。故云不二及以法界。法界即门名法界门。不同算砂当体门也。二能通方便作门者。使方便至实故名能通。若非实相之力方便无由得开。故知秖一实理从二得名。由虚通故令他所归。如赦体遍原罪无不释。刘虬意者。初句正明真实为方便作门。次句明三方便为真实作门。言非三去明二门互开。故刘虬非不与私释称会。但语略意沈经旨难显。有人云。他人立三章门。互为方便互得为门。若望注家其词甚繁其理混乱。虽然多言少实不如守一。于中先列。次如以下释。此是释方便品中。附五时家三转意也。但加更互为门为异。唯释初章余二但列。初章意者权为情壅。今既开权故云通也。实本无三为物故三。故云起也。乃至下余二例者。于中先例。次但不得下说文意通塞。若欲叙出第二例者。如以三一为非三非一之门。由达三一通至双非。即以三一为双非门。由双非故起于三一。故非三非一为三一门。第三准例亦应可见。次通塞者。若能通能起可互论门。但不得以一为权以三为实。用胜鬘文非今意也。下二章亦然。但得更互为门。次私破中但破初章。余二亦例于初章中但破三为一门。未破一为三门。初文两重。初破门义。次以非因破。初门义者。初句定中。但定三通一句。破其门义。但以不通遮之任自非门。亦应更云。若其通者昔何不通。使至今耶。昔不通者于昔非门。若开下至今即开。开已非三何得以三为一作门。显他不知体内体外。是故须破。准佛本意元为通一。故未开时本来是门。彼未云开而言是门。是故须破。故知三为一门尚自不可。一为三门何俟别破

若尔经何故云开方便门

答。若从今意门虽未开。有可开义亦得名门。如本是门闭时岂非。但名闭门开已无三。何妨从昔以三为门。又三非佛因者。破意同前。若未开者别尚非因。若其开已散心尚是。次例破余二。准初应知。云云者。若委破初章次半谓实为权门及下二章。烦碎义薄不能具述。他既破己依今乃可更立二句。破他既坏立义自成。具如前释。问方便等者。今设此问为欲开其四句义端。故今师前文自有二句。为更得作余二句不。此有下答。具有四句。后之二句理无别趣。但寄名义申释句相。于中先指前二。次列后二句。三如名下次引例释。先列名义。由方便下即以例释。义是名下之旨。故得更互为门。于中先释方便。次实相下但以例释。先例次中论序下引证。实名实义更互为门。实者义也。中者名也。故寄中名以显中义即是名为义门。文但举一边。亦应更云亦由实义能应中名。以名非实不立故举实以引之。问得以三显三等者。方便真实秖是三一。方便真实既为四句。三一亦例有后两耶。此亦下答。云二如前者。三为一门如以三显一。一为三门如以一显三。以三显三去释后二句。前之二句既以三一。望于权实名义相显。若后二句前虽名义相对义立。今不得用名义以释。但以法体相对释之。于中为三。先对释。次三一既不下正判结。三以因缘下修性相显。初又二。标释。初文但标一句略不标以一显一句。言昔下释中具含二句又二。先示非。次破此下正释。先示非者寄开显说。破今昔异。于中初举非相。此尚不得三一互通。况能以三通三以一显一。故一下结非。言一非三一等者。以其三一既不相即。若不开者相显不成。故一非三家之一。三非一家之三。次破此下依今经正释。先引于一佛乘分别说三。证即一之三。次引汝等所行是菩萨道证即三之一。即为一施三之一三。乃是开三显一之三一。前句腾昔故云分别说三。次句显今故云是菩萨道。昔教未说故三一尚隔。不云相显三是一三一是三一。由今说已一外无三。此三为一家之三。即是以昔一外之三。全成一家之三。故云以三显三。既开成一三外无一。还是三家之一。即是以昔三外之一。全成即三之一。故云以一显一。故知由体外之三。显即一之三由三外之一显即三之一。次三一既不下。判结。欲开下文因缘三一。故先判之。言三一既不相异者。判向开显全属因缘。言因缘者。秖是感应化仪。亦名修得。三以因缘下修性合辨。自性者。即是性德。故性德三一。虽复本有非修非作。乃由因缘即三而一。能显性德即三之一。又由性德即三而一。能成因缘即三之一。亦由因缘即一之三。方显性德一中之三。复由性德一中之三。能施因缘即一之三。是则因缘即三之一。显自性即三之一。名以一显一。以因缘即一而三。显自性即一而三。名以三显三。以性显缘准说可知。下结文中三一互出者。以互显不互耳。以三显三秖是以三显一。以一显一。秖是以一显三。虽因释妨妙尽根源。寻一家教门。若迷斯旨徒费心神。引十五处明门者。虽列头数亦复不知何者须开。何者已开门相如何。如其不判徒列何益。准今文意十五。门内但是方便悉皆须开。具如随文解释者。是于中有违今所释者。亦应破之。如引方便品智慧为门。此是同体权智岂得云为实作门。次种种门此是权门。而但云大乘教耶。次唯有一门下不专在教。所烧之门三界限域者。岂可但云从限域出。次车在门外言三界者。破亦同前。小教为门未判烧等。在门外立分为二释。云正习尽但在通意。门侧若大应已得大。犹在门外亦如前者。与前两释并不相应。门内如前者。意与前在门外同。前在二死门外。今不可在二死之内。开甘露门云大小者。是十方梵请文。或当如此。不知今在何处大小教耶。今文意者。本为开门不为数门。本为解门不为知数。若数而简之简已开之数亦何咎。昔说一切世间下。更引意根释开显意。为开古人所数诸门。资生于昔尚非方便。于今显已悉是真实。况复三乘五乘等耶。若门若非门者。非门谓小乘理教色香资生等。是门谓别教二观为方便。从初说故有门非门。于今一切无非通途。劝修者住于三法仍劝不懈怠心然后说者。故知此是观行位中初二位耳。故劝弘圆经以利于他化功归己至相似位。任运妙音遍满三千。不待劝也于中三法相望名各具三。初标慈悲。次若就下明一中具三。修如来下标柔和。次若就下明一中具三若就能坐下无标直明般若中三。虽复各具秖是一三。三尚非三。岂离为九。是则菩萨常观涅槃。故劝弘经者而常观之。愿弘经者观而弘之。不观能弘之心。焉晓所弘之理。故佛令入我室着我衣坐我座。若无三法何谓弘经。安乐行下引下品文同。有是利故劝弘者依方法也。上文下引上文释成。五事者。如前利益中列第一遣化人等五是也

法华文句记卷第八之三法华文句记卷第八之四

        唐天台沙门湛然述

    释见宝塔品

此中四度云见宝塔。下文云四番即四悉也。初世界中翻名有无三世不同。睹必欢喜故是世界。言经云佛三种身者。借普贤观经也。既结此经故可证同。当佛亦然者。未来有说法华经处。此塔还现彼佛亦坐。本论亦云此经为三身菩提故。此经已说师弟因果。故古佛证集分身佛。彼华严经加四菩萨说菩萨因果。能加但是迹佛主伴。故不假集佛。但云十方互为主伴。仍不云伴是佛分身。但云眷属而已。文中诸品皆云集诸菩萨。注家云。道非存亡古今一揆。然则裂地踊塔。以表双林不灭。更延接影微显丈六非生。故云见宝塔品。今谓古佛塔今佛坐。则表古今实道不生。未必预表双林不灭。一往观之。谓今现佛入古灭佛之塔。表灭不灭。今谓不然。古佛塔现示灭而不灭。释迦入塔示生而不生。不生不灭故并坐表之。集分身召本属。乃显舍那非成。岂唯丈六示灭他人问云。大众见塔为根为识。为塔令见。广约譬类以破自他。此深不晓经之大旨。三周之后纵有凡夫。咸殊凡见。然中论观法被末代钝根。佛世当机何劳设此。消经观行理合如然。凡诸释经若无通见。致令后学不闲宗途。今正为证经旁论所表。有人问召古佛集分身。身何故多塔何故一。今为答之证经义足。故宝塔不多合多宝愿。故分身不一。假令证经须集多塔。塔岂不多。既能应现十方信知塔亦非一。故分身是化塔亦宜权。今从所表今佛一身而集多身。密表迹用之非一。古佛多塔但示一塔。显表实理之不二。况从地在空及诸校饰。悉非徒尔。明显此事者。三世诸佛转法轮等。皆至法华出世事说。故今经文加四支征。璎珞下为人者。以校量福为生善也。善吉问等者。第九供养舍利品云。佛因善吉问供养全碎生法同耶别耶。佛广校量云如供养一佛舍利起塔满一四天下。不如供养生身。由色身有舍利故。又起塔满大千供养色身不如供养法身。由法身有色身故。当知见色不及闻经。以由闻经有法身故。故经偏圆即法身全碎功德不等。顶王等者。曾检大乘顶王经及方等顶王经各一卷。并未见此。难意者。教与舍利时同益同何得不等。答意者。舍利时等亦生身之力。北地师下破谬斥非。义当破恶即对治也。云说经竟者。意云正经已毕。地师去表身不二。以称理故属第一义也。释论下证地师非。师言南岳也。虽云三身意将法报以斥地师。无来者不合东来。无出者不应踊出。巍巍者。不应塔内。应身者不应唯此。若即此等者。如南岳所述三身胜相。若其直云多宝是法佛者必不可也。尚非应身岂具三身。故知多宝是法身者。未尽经旨。秖是表示等者。秖以释迦等事表理可也。故知非直来证乃表经常。故多宝表法及具三身。多宝久灭今出证经生不生也。往昔灭度犹现全身灭非灭也。既非生灭常住不移可表法身。释迦入塔二身相称。如智称境故可表报。分身表应文理自成。如境智相冥故能起应。三佛至而不一异者。能表三中各三故不一。所表三中皆一故不异。又能表中三相别故不一。法体同故不异。又所表中亦以体同故不异。以身别故不一。又化道别故不一。共成此故不异。总而言之。即三而一故不异。即一而三故不一。见宝塔下云云者。于前四文明示四相。以消四文。略如前释。四皆属圆。从塔出为两去。次约教本迹。初双标两义。次释出两意。释中又四。初正释。次若塔从地下。辨同异。三若塔来下判显密。四今取下释妨。初文又二。先明塔出证前起后。次明在空以表二意。故二文皆以证前当约教。起后当本迹。初证前中二。先约真实。次约大慧。以此二是多宝证词。初文三。初示三周无非圆实。次辨广略等。三示流通。初如文。次文者。先略次广。初文者。既重述证秖可从略。故但云真实。况处中及广皆约所非。所非必多能非唯一。故三周中虽或四一若十若多不出实相。次处中中言八不者。具如止观第六记引中论文。中论显理故八不叹佛。塔证中经亦八不叹实。故塔踊事复表八不。以义同故。故云塔从地等。又证下示证流通亦是真实

问。何不证序

答。二段既实其序岂虚

若尔何不待至安乐行末踊出初耶

答。以法师中具明人法方轨。现未师弟因果及以处所。天龙作护化人集听。足辨弘经故。多宝出证。证已命觅弘通之人。故引达多往以证今佛益。而劝流通。举持品人以证弘者。而劝流通。虽尔未有始行弘通之法。故重举安乐行耳。故安乐行未关踊出。次约大慧者。真实者。通虽四一别在所显。故先叹大慧。次叹所说所显之法。大慧秖是种智前已具释。今但更与不共般若辨同异耳。于中先问。次释论下答。三如一下譬。彼般若及此大慧俱能入故。妙法之言一分通智。四当知下结二文意同。次起后明本者。对迹明本可云本迹。于中为二。先明所起之由。由塔出故请开。由塔开故。见佛。由见佛故请加。由得加故在空。由在空故命众。由命众故声彻。由声彻故众至。由众至故生疑。由生疑故得说。言明玄等者。略举经题玄收一部。故云佛欲以此妙法等也。久远下明能起所表。表于本地三世益也。久灭今出故云神通。现益在说故云音声。誓愿不休故尽未来。以此起彼故名为开

问。经中但云大慧真实。有说处证闻说故出。那云证前及起后耶

答。文无理有。从此中出寻叹真实。故知证前。如明起由即是起后。次在空中亦初约教。七方便人见理圆也。次修得下本迹也。亦先叙迹。次若发下明本观心释中既云依经修观。当知经经皆可修习。柰何章疏都不涉言。故此宗徒行解无废。消文理观二义无亏。冀怀道者尊之尚之。每睹斯旨恨已所未沾盘桓经思顶戴永永。于中三。初明三身各有能表及以所表。初明以观为因得法身果。得法身时不独法身故云境智必会。如塔下能表。境智下报身。如释迦下能表。以大报下应身。如分身下能表。次由多宝下总举能表。当知约观持经。方具三身。三普贤下引证。得三种身。皆是方等大乘教也。次有人下出旧分文。此下应云十六品。前从弥勒问来。但有十品。此是庐山龙意。太早云云者。应叙上下文相分齐。以证此师分文太早。如破光宅惟忖之例。此且据本迹之名以破。然准此师意言约身者。以多宝为本释迦为迹。前约说者。释迦自说三周开权及以流通。今所以从名破者。以此师不知今经显远诸经所无。方望一代及前迹门。乃受本名。何须于此即云本迹。若预密表意则可然。于此分文故成太早。七宝为塔者。即七觉七圣财。七圣财谓闻信戒定进舍惭。随其教位明七深浅。既是佛塔之七又证实经。并用无作七觉七财。于无作中尚须性德。何况修得。七觉圣财俱修得故。虽分宝别。七宝即塔能所不别。然塔是所依严是能依。高五百等者。既塔所表须皆圆释。竖即因中望果。万行一行一切行。酬因果中万德一德一切德。从始至终名之为竖。当位具足名之为横。凡一切行历缘对境谛缘度等。无不庄严从因至果。若横若竖皆须有体。方可名为万善庄严。地者止住第一义空者。然体无明即第一义空。故无明无所破亦无所住。故第一义空即无能住。无能住故地既无破而破。空亦无住而住。种种等者。定慧无多对暗散说。又定慧遍摄。故亦云多。具如止观摄法中说。无量慈悲室者。以龛为室故云龛室。重云亦是者。重释室也。室亦名舍。幢亦旛类。如大长者中说。垂宝等者。从因至果。果德皆籍因中万行。由庄严故即能下化。如严复垂。四面等者。即无作四谛也。由四谛四方道风。吹四面四德之香。充而且遍。即是天然四德之理。假修德以远布。平等有二者。法等者。大慧所观理也。同得者。皆用因理以至果也。若所观理与众生异不名大慧。如是如是等者。一如法相者。叹佛所说称于实故。二如根性者。至第五时不差机故。先答第二问中

问。初云地踊。此云东方者何耶

答。东述本缘。踊申昔愿。若所表者。方始表开。地踊表显。告比丘等者。验具四众非不说法。当是多宝者

问。十方世界岂无一佛不得开显。不开显者。皆应发愿。何独多宝。若不发愿佛道不同。若发愿者皆合听经。又诸佛化皆预照机。岂成佛竟不得开显。方始发愿

答。同与不同开与不开。有愿无愿皆是随缘。若宜有愿皆悉尽来。何虑不集。后方发愿亦是鉴物。三变净土由背舍等者

问。佛有楞严三昧之力。何以仍用小乘事禅。又表破三惑。复非所治

答。是定圣行揽因成果。果地事用无爽于理。即楞严中具诸三昧。非昔因时见禅法界。岂背舍等变过三千。然化佛事宜附小名。故大论中亦是准小。故云欲得自在修胜处。欲得广普修一切处。若但小用唯于三千。又初一变下表破三惑者。既楞严中即理之事。不妨一一皆破三惑。况今三昧直论功用。破惑乃是所表而已。表前破已表后更破。如僧中与欲者。不必全同僧中法事故云如耳。多宝愿力须诸佛集。复令时会知分身多。故此诸佛为开塔集。集又不至但遣侍者。传问讯等状如与欲。故诸侍者但申问讯。无说欲辞。大集若干诸佛与欲者。于欲色二界大空亭中。广集十方一切诸佛。二十一云。南方有佛名曰金藏。彼诸菩萨见光明已。问于彼佛。彼佛答云。北方世界有佛。名释迦牟尼。欲为大众说法破大憍慢。遣使从我索欲。我今与之。余方亦尔。各令一大菩萨与十恒沙诸菩萨等来此偈赞。亦无别欲词。大品亦千佛同说。今已开权。次欲显远。使诸佛道同。故令诸佛与欲。有人问。众俱在空分身何故犹处于地。今答。时众已闻迹门开权。初入寂光之土。故以居空表之。分身示迹各有所化之土。故居地以表之。又释迦不久显本。亦先居空以表之。各有其致不须疑也。尔时释迦下亦约所表。为开权者。多宝本为证经故来。应令众见。佛身表实。塔开表权。故开塔表开权。见佛表显实。有人于此立本迹者不然。本文在下

问。凡云本迹本应胜迹。望下本门则释迦显本。舍那犹迹何以迹胜而本劣耶

答。此义不然。舍那是迹中之迹。自望本时遮那为本。释迦开已望迹成妙。舍那迹妙。迹妙犹粗。具如玄文本门十妙。经见二至加趺坐者。法华论云。为显三身为成大事。八万二万者。八万在法师品初。二万在持品之首。偈中第二八行半颂分身佛集者。上文有七今颂甚略仍不次第。初三行颂第二应集。义兼大乐说欲见及以请集。次一行颂土净。次四行半颂诸佛同来。明难持中经云八万四千皆不及者。八万之名不必全大。具如止观第一记引俱舍报恩等经。乃至十二部亦通大小。具如玄文说法妙中。但令他得小六神通。亦未为难若立有顶。此约不得通者为况。故知圆经暂读暂说。诚为不易。若有能持则持佛身者。体宗用三。衣座室三。即三身故

    释提婆达多品

注四释中唯无观心。初因缘中但通语感应。故云生时等也

问。恶人出世何名感应

答。令无量人不敢造恶。天热者。从事说耳

问。何无四悉

答。义立非无。见者喜其己身不作。即世界。不作善生。即为人也。不作恶边。即对治也。无障果事。即第一义。因行下约教。理顺即圆教。事逆即三教。唯圆教意逆即是顺。自余三教逆顺定故。本迹中言同众生病者。大经云提婆达多必不破僧。报恩经云。若有人言提婆达多实是恶人入阿鼻狱者。无有是处。大云经云。提婆达多不可思议。所修行业同于如来。诸新旧章皆云什译元无此品。并准齐宋录云。上定林寺释法献于于阗国。得梵本来。瓦官寺沙门释法意。齐永明八年十二月译讫。仍自别行。至梁初有满法师讲经百遍。于寺烧身。乃以此品置持品前。亦未行天下。至梁末有西天竺国沙门拘罗那陀。此云真谛。重译此品置宝塔后。今谓若准正法华。西晋时译已有此品。则梵本不无。若观所译全似什公文体。若准嘉祥三义度量。一者外国相传。流沙已来多无此品。恐什公未见。今谓什公亲游五竺。岂独流沙。二者什公译经多好存略。如智度百论之流。此亦不然。西方好广但略其重。岂可全除正文一品。三云。宝塔命人持品应命。以提婆间者。全成剩经。何以安此。今文不云真谛重译。复云南岳私安。若必真谛重译不虚。何妨本译江东未有。以此验之。乃成三人俱契经理。望嘉祥三义。全不可依。涉法师云。不合安此。授记调达应安授学无学记品中。后智积后应安神力品内。今谓若尔。于阗应将两握经来。法意乃有补接之过。若尔何不学无学记。无学将入千二百中。学人自为一品况提婆达多不云得果那忽安置学无学中。两存两没者。文云。此经是五年译之东安法师云。七年三月十六日译讫。慧远经序同或云。弘始十年二月译竟不同之事未可追寻。竺法护太康元年八月十一日译讫。为十一卷名正法华。亦云八卷出聂道真录。此两存本也。次有沙门支道根。晋咸康元年译为五卷。名方等法华。外国沙门支强梁接。魏甘露元年七月于交州译。彼沙门释道敷笔受为六卷。名法华三昧。出姚录魏录武丘道亮云。有五本。四如前。更有萨云分陀利本。既存于世乃成三存。睿开九辙者。什译才毕睿便讲之。开为九辙。时人呼为九辙法师。一者昏圣相扣辙即序品是。次有七辙即是正宗。一者涉教归真辙为上根人二者兴。类潜彰辙为中根人。三者述穷通昔辙中根领解。四者彰因进悟辙为下根人。即化城授记五赞扬行李辙。即法师品为如来使。六本迹无生辙。即多宝品。多宝不灭释迦不生。多宝为本释迦为迹。本既不灭迹岂有生。本迹虽殊不思议一。七举因征果辙。即踊出寿量品。弥勒举因征果佛举寿量因果所由。八称扬远济辙。即随喜去讫经属流通也。名目甚美而宗体不显。睿公又有二十八品生起。甚有眉目于今无妨。但品旨未彰。而不的语远本。但云因果。何成发迹。四渎者。江河准济。意云。天下大同。提婆达多至为五逆者。俱舍云。杀父杀母杀阿罗汉破和合僧出佛身血。今初云破僧。略如前目连缘中及止观第一记。出血者。如佛在阿耨达泉告舍利弗。往昔世于罗悦只。有长者名须檀。财富七珍子名须摩提。父命终后其异母弟名修耶舍。须摩提设计不与彼财分者。唯当杀之。便语弟言。诣耆阇崛山有所论说。弟即可之。即执弟手将至悬崖。推弟崖底以石堆之。即便命终。佛告舍利弗。尔时长者今大王是。须摩提者即我身是。异母弟者即调达是。以是因缘无数千劫入饿鬼中。入堆山地狱。以残缘故我于耆阇崛山经行。提婆达多于高崖。举石长三丈阔丈六。以掷我头耆阇崛山神名鞞罗。以手接石。小片迸堕伤佛母指。出于佛血。出兴起行经。教阿阇世放醉象等。具如释签第三。余文可见。具列在诸经论。俱舍业品云。五并业障。摄约处人除北。约人除扇搋。四身一语业。三杀一虚诳一杀生加行。无间一劫熟。随罪增苦增。入比丘分二。以为所破僧。言若作等者。如文。调达但有破出杀三逆。兼放象毒爪二杀方便。正兼方便且云五耳论有同类五逆。谓污母无学尼。杀住定菩萨及有学圣者。杀有学圣者。杀罗汉同类。夺僧和合缘。是破僧同类。破坏窣睹波是出血同类。不以放象毒爪为同类者。彼是方便非同类故。入大乘论问。彼提婆达多世世为佛怨。云何而言是大菩萨。论答云。若是怨者云何而得世世相值。如二人行东西各去步步转远。岂得为伴。此五逆缘当因缘释。若作下本迹者。前题注中又并略述竟。此品下别明来意者。验嘉祥三意。全无所以。可以意知下云云者。应重叙文殊是游方大士。十方弘经。乃至入海唯常宣说妙法华经。乃至一切大乘诸经。文殊皆为发起之众。度义等者。大论始从十五终二十一。广释六度。一一度中皆存众释。今攒其大略。文相显著者。分为四类。亦非一处次第列之。若欲委知寻论本文。诸家取舍广立义门。杂引大小不任证据。不知何者是释迦所行具足。令一家立教则体相可识。迹示四相本行唯圆。初三藏中二。一略释次分别。初又二。先直明六相。次束十善以为六度。以此六度属世法故。且以世间十善而用对之。次分别者。引善戒经自开三种。文中先明对治即所治也。次相生者。约行次第。果报中云具者。谓诸根具足。色谓端正力属精进。若言下六各十者。名出地持华严。月藏下属圆教者。于中先责世心。次令依第一义。以成波罗蜜者。谓但取初心一念具足。则一色一香无非十度。华严下借彼教道深位。以证圆人初心。验知华严存于教道。别义明矣。若圆极说岂至七地方具十耶。故地持中念念具十。六之与十开合不同。具如止观第七记。若念念具十。何行何念而不具十。一行一切行斯之谓也。经中以持般若校量。过舍恒沙身者。乃以实行对事舍说耳。若六皆法界此则不然。故不可以三事皆空。及以次第出生诸行而比之也。又此六度上下诸文非不略释。观其文意随事各别。若序中横见。但是现相发弥勒疑。文殊引古。种种之言为引同耳。过去佛章为开五乘。菩萨之文六度甚略。药草喻中三菩萨位不语行相。意在辨于差与无差。分别功德略举五度。为校量本亦非正意故。无行法。唯此中经文虽略列。而正明行因趣果之相。故释者委列使一切行会入一乘。三十二相者。诸教所列修得不同。多在教道。若实道者。但是发得不须各修。如下龙女叹佛偈中。自非深达安能具相。具如止观第一见相发菩提心中已略辨之。今文虽即具对四相。意在发得。故次文云。实相是圆教相本。虽修发不等相体多同。今文多在大论兼在诸经。法界次第具列名竟。今与彼文仍有同异。今剩有二相。又足跟直踝不现。项光万字青发。此五相法界次第中无。法界次第中有丈光喉中津液。此二相今文则无。八十种好文亦不同。秖是经论译异。非胎卵湿化之化生者。不同界内四生中之化生。如诸天化生仍在父膝等生况同四趣中耶。今此忽然而有。如药王中云。于净德王家忽然化生。亦称湿卵等者。但以莲华在湿未剖如湿如卵。含在华内义之如胎。大宝积云。菩萨成就八法。于诸佛前莲华化生。一者乃至失命不说他过。二者化人令归三宝。三者安置一切于菩提心。四者梵行不染。五者造佛形像安华座上。六者能除众生忧恼。七者于贡高人常自谦下。八者不恼他人。此一经虽尔以诸经论随宜说耳。假使一切经论所列。生莲华缘并为今文闻品功德之所超过。故华生虽同本缘各别。云云者。亦可释妨非今文意。尔时文殊下第三寻来。有人问序中在座。今云何海来者。今为答之。岂以凡情而度圣境。不起此会于海化物。义亦何辜。亦何在序一期益讫。去时岂要白知。来时大利方生与众自海而至。若例地踊菩萨赞词此经甚略。或当彼有广文具有出会之语。而传至此者略耳

问。三千之外各四百万亿无复大海。文殊何故仍云海来

答。事释未爽况不思议。今三义通之。一者既移天人及变大海从所移处来应无远弊。二者海众纵移而龙宫不动。龙谓不动而所居已变。从变而不变处来。有何不可三者。无缘者被徙。有缘者今来。此不思议山海宛然令众不见。但是变见非谓改体文殊。既不起而往。其土亦即秽而净。故净名云移。置他土都不使人有往来相此中乃使有往来相。而本不移。故知应有机者则土变众移而尚来。其无缘者土复众来而不至。所以理虽无动化事成规故使所见不同来往时异。菩萨化仪尚尔。岂佛设变同凡

问。不起而往。何故云来

答。示彼此众知经功力。识禀教益故须云来。不往而往不来而来。皆为利物何须此难。故知他土未必见来。彼不见来此不见去。不来不去而移事灼然。如净名足指按地。是时大众自见坐宝莲华。而土秽如故。经中文殊所叹龙女。不出弘誓定慧诸行。智慧下是慧深入等是定。慈念等是誓。功德下行也。下去诸文有此流例。准此应知。正示圆果中。云龙女作佛者

问。为不舍分段即成佛耶。若不即身成佛此龙女成佛。及胎经偈云何通耶

答。今龙女文从权而说。以证圆经成佛速疾。若实行不疾权行徒引。是则权实义等理不徒然故胎经偈从实得说。若实得者从六根净得无生忍。应物所好容起神变。现身成佛及证圆经。既证无生岂不能知本无舍受何妨舍此往彼。余教凡位至此会中。进断无明亦复如是。凡如此例必须权实不二。以释疑妨。言权巧者不必一向唯作权释。秖云龙女已得无生。则约体用而论权巧。非谓专约本迹为权巧也。故权实二义经力俱成。他人释此。或云七地十地等者。不能显经力用故也

    释持品

有本云劝持。义须俱存。随题皆得不及从初。故文为两段。若欲于此立四悉者。双释似世界。二万似为人。八十似对治。佛意似第一义。故佛意言双指两段。尼请记中。应开此文为四。先二尼各有请及记。三诸尼领解。四诸尼发誓。经云姨母者。本行集云。释种善觉生于八女。时净饭王兄弟四人。各纳二女。净饭王妃。即摩耶爱道。摩耶生已七日命终生忉利天。爱道是姨。故云姨母。次问答。答中云为引始行及开安乐行者。始行见诸大德。尚不能此土弘经。况我等耶。是故须下安乐行品为始行之轨。岂得下方未出预云踊出所行。若尔。品初文殊应问踊出菩萨。当行何行而但云于后恶世等耶忽闻踊出时众应问踊出是谁。次偈颂者是孤起偈诸菩萨等请护弘经。即是自述弘经方轨。以由佛于法师品中说方轨竟。宝塔慕觅用方轨人。达多引往用方轨者。释迦即是禀方轨众。故云以身为床坐等持品即是恶世方轨。安乐行是始行方轨。故云住忍辱地等。具如后品。若不尔者则弘经无轨。无轨弘经斯无是处。如赤身入阵自损不虚。被铠之言应不徒设。初十七行被忍衣文三。初一行总论时节以明着衣。有诸下九行别明所忍之境。三我等下七行。明着衣意初如文。次文三。初一行通明邪人。即俗众也。次一行明道门增上慢者。三七行明僣圣增上慢者。故此三中初者可忍。次者过前第三最甚。以后后者转难识故。初二如文。第三文中言宝云经第六阿兰若等者恐误。文在第五。先释名者。阿无也。兰若名诤。文中云事有事故诤。今依经先出正行次方辨邪。初文云住阿兰若者。不与世诤。不近不远便于乞食。有树阴多华果足净水。无难事不险阻易登陟。独无侣诵所闻(云云)。有王大臣长者等来寻诣之。作是言。善来善来。若至住处应唤令坐。若不坐勿独自坐。若不就鄙座。应种种安慰为其说法若不乐广说。应为略说等(云云)。若不尔者。非兰若行。凡居兰若为调烦恼。自举篾他非无诤行。未知端拱意在何之。轻倨师友傲慢王臣。况令无识者谓圣。使有眼者寒心。罗云之行永乖。空生之德安在。但由心无内实。专以身营外虚。笃论其道诸无所云。审如宾头卢知七年失国。及稠禅师进否为王。故起居适时安得一向。十住婆沙明兰若比丘乃至具五十法。方堪止住。乃至十二头陀各具十法。不然则且寻师进道。何遽守愚。不应式者。出家离世割爱募道。应以五分而为正则。尚违小乘之式。而反轻于大教者。尤害之甚。若以此名而均于大。则圆乘三学二脱可以自规。方应出家兰若之式。虽说至得活等者。谓着其所说不勤行之。专思自活。如斯等辈名相似三学。矫三学贼三学诈三学。而欲轻于通经者。故令弘者当着忍衣专弘正法。有戒之人具增三学。方名增戒。守一不行信知戒减。戒尚不行安行定慧。是故须历五分勘之。三明衣意中。文引中阿含第五黑齿比丘诉佛者。准彼中含第三。明人有五去文相应也。彼经舍利子相应品水喻经云。佛在给孤独。舍利子告诸比丘。我说五阴恼有五缘。云何为五。即以五喻喻于三业。更检第五经。人有五者秖是三业。单善为三。俱善为一。俱恶为一。若更作双善为三句。即成八句。恶边定无单双者。单善即是双恶双善即是单恶。故不得有恶边句也。经中不作余三句者。或举五知八。或是随机。有文中初云身恶口意善者恐误。准合喻中秖有单善。但应云身善口意恶。口善身意恶。意善身口恶。故初喻云纳衣等者。此是身善口意不善。以合文云念用身净弃于口意。口善中喻者。披草避热身相不善掬水不称。即意不善。水得到口且名曰善。文云若掬若手者。秖是手掬耳。切韵释掬者。手取也。亦有单作匊。虽身口俱丑。但为止渴故名意善。若欲喻三双善者。准单思之。喻三俱善者。池既宽凉入则身善。不匊口善止渴意善。婆沙第八云。念骂是一语等者。论第十杂揵度智品中问曰。行时得骂。云何观察名句身等。令恚心不生。答曰。或有说者。阿拘卢奢秦言骂。拘卢奢秦言唤声。我今不应念其阿字。若有阿字是名为骂。若无阿字即是唤声。当知西方有三合声。阿与拘卢奢合方成名句。乃名为骂。彼方此方卑陋称赞斯例甚多。如云尸罗羼提。于此未为端正之辞。彼方乃是二波罗蜜。又观此骂字等者。此方亦有颠倒即成赞骂如见客去。命云去早。即名为留。若云早去即名发遣。发遣是骂。留即是赞。如正食遇客若云来早。即是骂也。若云早来即是赞也。世人执览定有前后。共为赞骂。妄情聚积言声本无。又骂是一界少分等者。屈曲意思行蕴法处。法界少分所摄。此借婆沙文为所观境。乃用四句三假观之。以声对于根识及空推无自性。成就性相方名即空。又骂既是声。声界有八有执受无执受大种为因。各有有情名非有情名可意不可意。有情身中所发音声。名有执受。众生语声有诠表故。拍手等声非诠表故。风林河等名为执受。无执受中有情名者。所谓化人语声。虽无执受能诠表故。余例思知。今此骂声既是有执受有情名不可意声。但是八中之一。然由计其初后。而成名句。若言声界是骂。八方是骂。今犹无七云何名骂。况复一中念念不住。声入少分色阴少分。骂少等者。观我既是所骂之境。若骂色时即不骂心。骂心之时即不骂色。形显受等准此可知。成就自彼等者。彼自揽声以成名句。而谓是骂。我观因缘念念不住。此观因缘也。又骂是一字去。观相续也。又能骂去。对推相待。用空者。通教也。故知借彼婆沙因缘之境。一一推之便成即空。语略意广。具如止观入空无生观中已说。十七云凡圣俱有三受者。恐文误。文在第十。文云。亦有畏惧者过于异生及以圣者。以有畏故即具三受。亦云五受。五受即忧喜苦乐舍。又有五受全是三受。谓未得乐受已得乐受。已生苦受未生苦受不苦不乐受。但圣人不以心受。故有凡圣之别。亦是借彼婆沙分别。四圣为圣六道为凡。十界不同以成别义。今经去即圆教也。念佛者。观受为法界。故云是念法佛等也。由能观别得诸教名。所观五受其相不别故持经者应观三受。故云能受诸恶行等。铠者甲也

法华文句记卷第八之四法华文句记卷第九(上)

        唐天台沙门湛然述

    释安乐行品

今古释品。皆有生起十缘五缘等。及明来意三意五意。今则不尔。但随品文势逐义释之。不必一概。故至释此品。应委腾前四品之意。谓法师下三。通以法师室衣座三。为流通之轨。故释前三品题及以消文。咸依此三明品元意。若随文相别生起不同文起尽耳。以法师品是流通之始。是故具列三法为轨。况流通者演布正说。故令说者依三建志。方能光显所弘之典。令物慕仰法可弘通。冥资显益是如来使。若不尔者。何故世尊命弘经人。量其功用堪掌任者。故使此土他土上方下方。进否异辙。若己自行不长物信。如热病者而货冷药。是故不可率尔传经。故三周开显若法若喻不逾三德。若修若性准而则之。性德不当开与不开。修德随时转名赴物。在今同异无非一乘。一乘者。佛性也。具如大经佛性三种即是秘藏。故流通之首还约此藏以之为轨。所以法师名室衣座。以于敷弘义便故也。宝塔品中若从塔说。塔踊在空座也处处证经室也。众宝庄严衣也。若从释迦在空座也。入塔衣也。命弘室也。又以三佛表于三身亦此三耳。多宝衣也。释迦座也。分身室也。若从三变所表说者。初变表破见思座也。次变表破无知室也。后变表破无明衣也。故命弘者令依三法弘此妙三。若调达中身为床座。若非深达此三。安能轻生重法。故相好之身必有法报。法身衣也。报身座也。应身室也。若从因行五波罗蜜衣也。般若波罗蜜座也。慈悲喜舍室也。况师弟成道具足三身。至持品偈文。彰灼三法而弘此经。此安乐品虽为始行。亦以三德而用题品。以一品内无非三德及三德行。于中为五。先以三义总释。次明四行来意。三明四行次第。四明四行体异。五正解释。初文二。初标列。次释。释中先略次广。略中初依事释者。二业安乐进于弘经口业之行。若附文中二。先附法师。次附今品。初文皆约三德三轨故也。法身若有三德之行。故使所严法身安也。故玄文云。法身体素天龙之所忽劣故具三法共导弘经之行

问。若尔。与涅槃何别

答。妙法秖是一心三德。本来不别。彼寄示灭名涅槃耳。附今品文即进为行。秖由自进。是故弘经。法门者。引诸经论所列三门。释成此意。即不动等于中列释。释中一一皆先出行相。次明所离。三结意。初不动者正是中道。引文并表不动故也。五受者。经云。行亦不受。乃至不受亦不受。彼经在衍为破三藏家不受凡夫之五受。故下广释。通从外道等四句及以绝言。绝言亦舍故五不受。乃至圆教四门及绝。若尔。未证实来俱名为受。若着圆门五受尚名为受。体教入理理无所受。方名不受。次广释中初广事释中。因果对辨。秖是展转释此安乐行三。令识极地三耳。大品等者。且借彼经如实巧度以对小耳。彼衍门中三教皆是因果俱乐。克体论之。应须更简。乐名既同但以偏圆而用判之。通教三乘因果俱偏。别教菩萨因偏果圆。圆教菩萨因果俱圆。故以俱乐并圆为今品名。所引大经菩萨犹通絓是下结品文意。必用七方便简。方应今经。次广附文中。广附上品释成今品。以今品四行。不出三业止观及慈悲故。于中为三。先立能趣及所趣境。次行有下释能趣行。三问答料简。于能趣行中为十。初列三行。次止行者下解释。三总此下结对境行。四境称下结归品名。五大论下引证。观境即因果也六因时下判位。七因名下判因果名异。八又因下判因果名异。以辨化用。云三业等者三业三密三轮并三德异名。意密即般若。口密即解脱。身密即法身。九如此下总结。十此行下引同会异。总有二重。初总次别。别自分三。总别皆悉名异义同。总而言之等者。总不异者如来涅槃人法名殊。大理不别。人即法故。别不异者。此中离为忍衣等三。彼经离为法身等三。此明下释于两处不异之相。故引彼经宝树等三及以五行。初三譬法身等三。三喻具如玄文及释签所引。即大经第十文也。依此座等以对三德。亦应可见。又五行中亦与衣等同者。圣行座也。天行衣也。余三室也。梵行室因。病儿室果。应知今品具斯十意。正在于因因中正被五品之人。或至六根。是故品题从行为目。即安乐家之行也。三料简中先问。次答。文意者。虽复旁正两处互有。今且分折摄以对二悉。然彼此皆四则有无无疑。一子地者。大经云圣行住三地。戒圣行住堪忍地。定圣行住不动地。慧圣行住无所畏地。梵行成住二地。慈悲喜成住一子地。舍成住空平等地。今且引慈悲一子。而反质。持弓执箭未是通途。故云何曾无摄受。五地同在初欢喜地。此地无种不为。普现色身随宜益物。故折摄两门收一切教。或出或没不应偏难。今云同者。同味同理同因同果。广法门至不记也者。准望前解。又应更以种种三法通释此文。具如十种三法。准例可知。若以此义为四悉者。三法异即世界。解脱即为人。般若即对治。法身第一义。二释并云皆四悉故。次此品下释来意。又二。先明深行不须。次若初依下。正明始行须者故来。初文明不须之人。云若二万八十亿等者。持品初二万菩萨眷属俱。皆于佛前发誓弘经。有经本云八千亿。应云八十亿。即持品中诸尼索记佛与记已。诸尼说偈赞佛已。尔时世尊视八十亿诸菩萨等。佛称赞已。是诸菩萨念佛告敕。当如佛教等。深识下正明不须之行。具对四行以论不须。初深识权实。故不须初行。以初行中令不与二乘共住等。恐滥受权法故。广知者。明不须第二行。以第二行中令不说渐法之过。令不倚圆蔑偏。偏秖是渐又达下明不须第三行。以第三行中令将护二乘。及令不以圆诃别。神力下明不须第四行。以第四行中令后得神通。方令入实若初依下始行之人。无此四故。以四行防护兼堪自进。故云欲修圆行。欲利他故。故云入浊弘经。为浊下明无此四故。自他俱失。为是下正结来意。言若初依始心者。五品六根并属初依。始心即在五品初心。故初品中虽非说法之位。随力弘经须此四行。至第三品正当说法。以资自行。说即是弘。理须此品以为方法。三此安乐下行次第中四。先明不次第。次今且下寄于前品。以明次第不同之相。三若约下约行次第。四虽作下约行无次。具如智者释四行文。四行既是三业止观。及以弘誓。俱行俱运止观同时。况一一行摄一切行。况前初品衣座室三无三差别。故无次第。四明行体者先出古释。初师初云假实者。何教无之。未显今行。说法离过虽似一途。而无慈悲止观之相。第四慈悲而滥向三行。基师所释不及前师。龙师初行稍近今意。南岳所释若望天台。仍未委悉。故今师释云止观等者。前三皆有慈悲止观。且初身业又三。先明有所离故不堕。次有止行故下具三方轨。三止行离下具足三德。于中先明具德。次明相生。余口下例者。三业俱有慈悲。誓愿亦具止观。故四行例同。故知还用前品为今行相。若不尔者。非善弘经。五正释者。释行处近处中。先三古师。次章安破者。以初家行浅近深。即初两家。于中次家二释。初释因果别。后释通因果。故破初家及次家初释云十地有行非独初心。次破后家者。瑶师以七住已上为行。七住已前为近。故引净名等觉极深亦名为近。若两行去总判三家互失。言两行者。行近两处俱得名行。所以俱浅俱深。并皆有过。言前品者。指持品中能忍违从。即深行也。何关此中。言七方便者。权行所行不涉今品。然行名下立理破也。得名虽别二义相假。一一行中皆习近。故俱通深浅。不可并深俱浅及互深浅。然今品文始行正当并浅。而永异古师。以通俱深异七方便。浅名虽通其意则别。下去约位义通于深。以深摄浅故也。又行近下引义以破。既是法师品中衣座室三。理无浅深。又忍辱下约行以破。若尔下征起释疑。诣理下正判。言诣理者。以经云住忍辱地故也。附事者。离十恼乱等。事中下文亦观空等。如引义中寂灭忍与毕竟空。岂容深浅。但对事说得忍衣名。约理以说得空座名。故附事必依理。从理必经事。不应圆行事理条然。亦如二谛必真俗相即。各说一边非无所诣。约行准说

问。既对衣座何不对室

答。室通二行亘于始终。二行虽殊慈悲义等

问。标云慈悲熏止观导三业。下释但见止观三业。而无慈悲者何

答。誓愿不孤通前遍导。况皆有为说咸是慈悲

问。初身业文但云行近。何名为身

答。行近二文。但广略异。故离十恼乱。正当于身。约近论近灼然在身。当知住忍亦身住也。忍地即是阴实相也。一十八空还观界入

若是口意二文止观明着身何无耶

答。口意别明身中合举。既近处三皆云助观。助前止观。其言虽单即是双助止观故也。今约三法下正释行处。即从忍地至亦不行不分别文也。约三法增数以为三重。初约一法又二。初标一法即缘谛也。直缘一谛而立三行。但云一法者。以能从所但受一名。一谛为一切下明一理功能。理既能为一切所归。故能依三行功亦如之。于中又五。初列功能有三即所归作本无分别也。故三为行缘于一处。次一切所归者下释三行也。三无三行下对处结名。四如此下明与前品三法义合。五是名下总结。释中自三。初又二。先消经次结名。消经意者。所住之地谓实理也。次众行去。明能住行即依理起行。此即下结名。云行不行者。理虽无行依理而行。行得理息即名不行。能住是行人得理故。能行胜行。行即不行故云行于不行之行也。次释第二行者。亦先消经。次结名。消经者。亦指前一地为一切本。本谓忍地。住一地故具柔和等三。初如万物下总牒前一地立第二行。初句譬说。众行下合譬。若得下正明能生之功。于中别消三句。此即约理方有能柔乃至在惊能安。无量下德释功德所由。地无所生。指前实理而生功德即柔和等。即不下正结行名。依理不行而行于行也。释第三行者。亦先消经。次即是下结行名。言遍无分别者。行与不行性相无二。见诸法实名不分别。无不分别名亦不行不分别。三无三下对处结名。以得实处故。使其行有一三相。四如此下与前品义合者。初句总标。休息下对前三句。休息即行不行。随生即不行行。遍无即非行非不行。五是名下总结。可知。故知一法即三法。三法为本故先明之。次约二法者。即以生法二忍消文。于中为四。初标。次二忍下会异名。即二空是。三二空下辨异。于中初标。次何者下释异相。真俗假实通于三教。今意在圆何但异二乘耶。且随难辨故暂对之。言真俗假实明二空者。真谛即法空俗谛即生空。俗假真实。故玄文云。世谛破性真谛破假假破即相空。性破即性空。故真俗不二二空俱时。为对所破以分真俗。即不思议之真俗也。通中亦有此之二空。名同义异。俱时不殊须善斟酌。三若更开者下。明开合也。若开为四忍。柔和两字为伏忍。善顺两字为顺忍。又复下为无生忍。亦不下即寂灭忍。若为五忍。即离顺忍中善字。余同四忍。若为六忍。即离伏忍中和字。余同五忍。若更开为四十二忍。但于无生寂灭二忍中出。若对住前随前四五六忍。增减可知。义皆通后。若言一地具四十一。则地地四十一忍。亦地地有伏顺等。合则依前为四为二。二复为一同立忍名。地地无非伏顺无生寂灭。四今且下正释。仍离二空以为四忍。则经中诸句皆具二空四忍。于中为十。初标。次列名。三此四忍下举别异圆。四今圆下出今圆意辨异于别。五大经下引证。六若约下约无浅深以明四忍。七闻生死下消经。八行此下以三法结。九二空下结名。十是名下总结。初二如文。三举别教中。即以二忍判彼四忍。即伏顺在地前。故云生忍。无生在地上。寂灭在极果。故从初地依法得忍。通名法忍。四今圆中圆位诸忍俱无浅深。五引证不二明文在兹。六约无浅深立四忍者。若借别名圆。且以伏顺为住前。无生为登住。寂灭为妙觉。暂离对当行理必融。故云皆见中理。应如今文以初伏忍。亦通金刚。寂灭无生亦通于下。七正消经中。所以不消住忍辱地等者。向立圆四忍。皆由住忍辱地。故且置之。又不消法忍。但略消生忍者。但生忍义深法忍可识。于生忍中又不消柔和善顺者。即不卒心不惊去。是柔和等德。既了不卒暴等前则准知故知四忍并依理者。为显圆故。于略释中初之二句。释而不卒暴。次闻佛下释心亦不惊。此句既融余句可见。故云闻生死涅槃乃至非难非易。则知其心常住忍地。八以三法结。亦是行不行等三行也。九十可见。第三约三法又八。初直标三法次三法下示三法相。三住忍下正消经文。初句总柔和下别。别中言忍见爱等。此真谛空由依中理。且据空边故云见爱。若从理说即同体见思。四此则下结名。五行亦为三下。结成三行三法。六是为下总结。七出异解。八彼明下约教通斥。不融下云云者。应具明圆相以显今经。若不然者非安乐之行。次云何名近处下。释近处。为对离边应约去声。近远两字若对所近。应并上声。今明能行对所离法。故皆去声。于中为四。初标。次远十下列三门。三上直下示三来意。四就初有下正释三处。列中三学皆云助者。始行弘经须此助故。三学能助助于正行

问。非远非近即是正行。云何言助

答。此是观行初心之则。附此三学名所附为助。助法弘通故云助耳。皆云附者非全正体附近而已。又如初门但是随要略引于十。戒亦未周。次门且云修摄其心。定亦未周。第三似正圆慧慧亦不周。何者。若正立圆戒须指梵网。无非具足。若圆定慧须十法成乘。具辨诸境。一往且明十八空耳。三示来意者。对上行处以辨广略而为异也。今欲重明故说之也

问。何故所助通名观耶

答。委论修行具如止观。若泛尔通论则举观摄止。故弘经行者须专修妙观用三为助。方称圣旨。当知行处即正行。近处即助行。正助合行三行兼理。故非远近对事设观。以助照理之正观也

问。若正助合行。何故向云助真似耶

答。正助合行可入真似。若正一向在于真位。何名发心二不别耶。言非持刀仗等者。今明圆行对所辱境。处中而说。不同凡夫刀仗自防。亦非二乘弃舍不观。虽复正行须远其事。以十八空观其能所。岂同凡小若弃若防。皆云广上等者。文虽前后行必同时。说虽广略法体无二。故用前略以对今广。不同古德分擗经文。四正释中初释约远论近中。豪势者。恐人恃附失正道故。初似小益久则大损。邪人法者。恐人染习迷于正理。正观未成切须防断。在家事梵名为梵志。出家外道通名尼干。路伽耶等者。注家云。前如此土礼义名教。后如此土庄老玄书。伽耶陀亦云韦陀。近凶戏者。恐散逸故。那罗此云力。即是捔力戏。亦是设筋力戏也。近旃陀罗令人无慈。近二乘人令人远菩提故。西方不杂故云或来。既未受大无妨小志。故云随宜。欲想杀害菩提心故。欲想如止观第八记。不男坏乱菩提志故。五不男者。谓生剧姤变半。生谓胎中或初生时。剧谓截等。姤谓因他。变谓根变。半谓半月余即不能。广如论释。危害难处不合入故。讥嫌增他不善心故。畜养妨人正修业故。如是十法诸教皆然。但离二乘诸教小异。今弘圆经须属圆人。此当因缘约教两释。但阙本迹。若欲立者本离十种二边境界。迹示离此十种恼耳。观心十种云云者。令比类说之。应作总别二种。总者无非法界。何所可离。何所不离。非离非不离而论离耳。还同非远非近而论近。初心虽了一切本无。而须数数近于远离。别者远离三教教主豪势。二边之行即是邪行。二边人者即名邪人。二观神通名为凶戏。三惑尤害杀三智命。偏空灭想名二乘众。偏观真俗名为欲想。乃至尚离上地法爱。灭色住空名为不男。方便观智皆害圆极。一切俗境名为讥嫌。远离魔外名不畜养。一一皆以所离为境。皆以三观为近。皆以三惑为远。近近处者。大论问。菩萨云何自静等。论答云。如病将身等。具如止观第四记。三意云云者。如向所列定心定处定门也。列竟即应广释广简。心谓能期之心。处谓五缘中处。门谓五事调心未暇广论。故二十五方便随要列二。如是三法皆令亲近。此约对前远以说近。近此近法故云近近。非远非近而论近者。初开三章作境智释。又观下全约观释。初文三。标门。列章。解释。解释者。初观字标智。中间一切法三字标境。后空字文中不释。但是结成智境。若单论下明境智意。智即方便品初五佛智慧。境即方便品初十如实境。但下空字随位判之。但此属弘经之行。彼属五佛所显。又单论等者。今正明观。何以举一切法耶。举所显能故空显于观。一切法家之空观也。次别释者。如实相三字别释境也。二边三谛者。二边对中中必三谛。三而不三名无一异。三谛如实对七辨异。故云实耳。实即无相遍相一切。故云实相。不颠倒者。别释智也。具如方便品初今不多说。境为观中诸句所观。但能观观部内尚少。故于此中其文稍广。无八颠倒者无于常无常等各四。即表中道。然常等之名名兼界外。以变易中非但独有无常等倒。望于双非仍有出假常等四倒。若不立双非。义则不尔。具如止观第七文。以双树表之。诸法即中故无二死。倒即生因无因必无果。故大论中喻如堕岩虽未至地即名已死。不退者契寂灭理入萨婆若。以从圆故因立果名。不转者。必定不为凡小所转。尚乃不为三菩萨转。况复凡小。须约六即以论不转。下去准知。如虚空者。先立譬也。不为二边转故。故观者叵得但有名字。次中道下合也。但有名字即性空。名字亦无即相空。此即所得二空观体。无所有下出二空相。无所有。即性空相。一切言语道断。即绝言思为相空相。性空中云无自等者。应约真妄互论自他及以共等。今真如理正当无因。而云无无因者。无彼外人无因故也。具足二空故不生不出。出者退也。今是观行三不退也。言惑智等不生者。具足应云行位因果等。但是文略。今略明者。惑智及理体本不生。惑智称理。故俱不生释不出中。言如来治者。全体即是故无可出。不起者。以入理故方便理教一切皆寂。无名者。重牒前无所有等。诠所不能诠理非名故。无相者。相所不能相。又云十境所不相也。无所有者。重叹观体。无量者。非界入阴诸数法故。无边者。非如偏小分限法故。无碍者。遍入诸法故。无障者。无能遮止故。虽复多句。秖是能观无相无作与境合耳。对十八句立十八观。对一切法名一切空。三但以下结者。初总结诸句莫非因缘。上直明下明结束意。上多明双非。且云中观照于中境。岂有中观不照二边。今此重明照于二边。用结诸文以显中观不思议体。言理性毕竟清净者。重牒中境是双照境。故云如上所说。于中为三。初约初句以明双照二边境也。中体无作二边从缘。以无作观照缘解惑。又因缘下重释者。即以初句而为空边。照于缘生。缘生故空。空名涅槃。即以次句而为有边。故云颠倒。倒亦从缘。且从倒边故名颠倒。用前中。观无偏而照。言意显者。胜以因缘一句义开两境。然初文不释颠倒者。颠倒即是说由。故不别释。今从故说下不别释者。故说即是妙教。教必被机。不必须云颠倒故也。常乐之言无别他释。故总在后示因缘颠倒三谛。以明观法。即常乐三观故也。三又但下又合前二句。同为三谛之境。凡从因缘生颠倒之法。皆妙境体。由本有境说上诸观。亦由第二说用观故。故有第三结说结观。又于结中三重释者。由于上来诸境也。初释由颠倒故说。次释由二边故说。第三释由不思议故说。虽三释不同。共显一致。虽显一致不无亲疏。初说从机故云颠倒。从机语通次说渐亲。由二边故中本无说。第三全约不思议三谛体说。虽有亲疏观法无别。同观三谛一实之境。故常乐一句无所离合。所以前后共成一意。次又观下通上下文。全作观释。于中又二。初作观体观相以释。次凡有十九句下。作十八空总别以释。初云观一切法空如实相。云标观体者。实相是所观。以所显能观方有体。次不颠倒下释观相。云九句者。对下十八单复不同故但九耳。复故但九。一不颠倒等。二不退等。三如虚空等。四一切语言等五不生等。六无名等。七无量等。八但以等。九常乐等。略出三句示复句相。令余准知。此中九句讫常乐观也。下十八空唯至无障。次引释论释如虚空等。更释不生等句。以由如虚空故。三世不摄。初如虚空者总标也。无入是不生。不从于现以入未故。无出是不出。不从于现以出过故。无住相是不起。即现在不住。摄大乘意引与大论同。复引大论四十三者。存异释耳。次约总别作十八空者。于前体相。亦可以为总体别体总相别相。今总别者。于前九句除后二句。以余七句离为十七。进取如实相句。合为十八。以前七中。初之三句二二为句。第四句单。第五六句三三为句。第七一句四句为句。故使句法盈缩不同。此十八空从所得名。能空秖是一大空耳。大无大相即圆空也。故次文云中道正慧。即是能空。故句句中皆有能空及以所空。能空即是如不无断等也。所空即是颠倒乃至碍障等也。如云颠倒。颠倒是内。内颠倒空故名为不。下去准知。于空空中先立能所者。余句所无。以此句中能所名同。是故别显。余文相别是故不论。于中虽复所空名空。望能空智犹名为有。此中甚略。委释相状及以离合。具如止观第五记。若晓妙境及圆十观。方了此中十八观境。若不尔者。彼止观文乃成徒设。故彼正当安乐行人之观法也。故知始行须达彼意。方可弘经。若具不惬为利为名为众为胜。复肯同于二乘道不。大乘进退审自思之。所以勤勤于弘经者。愿共沾斯大利故耳。故彼境境结成大车。故彼观观皆依实相。四十余年秘要之教。教已难睹。所诠行理何由可晓。自非四依弘法之力。末学迷滞安遇斯文。遇而不求何异日月于盲者耶何异雷霆于聋者乎。但今文中观法未周。属在彼部。文虽不委品相略周。今粗点之使缘心有在。何者。实相妙境也。慈悲发心也。止观安心也。一切破遍也。十八道品也。亦不分别通塞也。离十恼乱助道也。梦中所见表后三也。通括四行十观略周。通论又以四行助十。若四若十并涉因果。四总十别。若总若别。俱通横竖。四行事仪且在于始。十法导理无不克终。岂涅槃行独在于始。又此十八名在大品。大论委释。经通三教论释复含。但简二乘而不细辨通别菩萨。是故读者弥须置心。故须对经一一圆释。偈中等者。义异故开。意同故合。故前行近以广显略。上行近至次第者。上文行三虽有三释。应取第三离为三谛。释以三重释各遍消故。不同于近中三也。但得云各。言复不次第者。非但不次亦乃通总。颂中多是近处文。故应入下至颂事远近者。约远论近也。亦应云颂双标行近。亦是颂人空行处者。前行处中第二作二空消文。于二空中离十恼乱。亦当生空柔和善顺。言即兼者。近中远近亦同生空法空。还于远近修空修观故耳。又远近等三亦秖约前行三而已。准偈标结俱双故也。常离国王等者。乃至官长准例可知。非直弘法他皆准此。作此谤比丘等者。世谤者言。既比丘作此。为佛听耶。佛法尔耶。韦陀者。具如止观第十记。所以不许亲韦陀者。或恐人疑。比丘教彼言佛法若斯。又复外道常思佛过。若亲近此或谓比丘须彼。则佛法不如于彼。故诫内众勿亲近外法。乃至六谛二十五谛等。具如止观第十记。乃至赞咏准此可知。初为跋耆子说阿毗昙者。故知别有阿毗昙藏。是佛自说。人不见者。诤计云云。或谓是十二部中论义部者。不然。言相续解脱经者。是佛自说故且名经。当佛灭后阿难所结集者。名修多罗。五百集者初名解脱。后广集法相乃名为论。欲相者。颂中虽无欲相之言。以长行有故今略释。俱舍云。六受欲交抱执手笑视淫。今依旧名目。须轮者。修罗耳。如中阿含云。有一异学问簿拘罗云。汝于正法中已八十年颇曾行欲事不。簿拘罗言。莫作是语。更有别事。何不问耶。异学又问。汝于八十年起欲想不。答不应作如是问。我八十年未曾起欲想。尚未曾起一念贡高。未曾受居士衣。未曾割截衣。未曾倩他作衣。未曾用针缝衣。未曾受请。未曾从大家乞食。未曾倚壁。未曾视女人面。未曾入尼房。未曾与尼相问讯。乃至道路亦不共语。八十年坐。故知衣食等欲想。一切尚无。况复染欲想耶。弘法之徒观斯龟镜。世人笑他滥大乘者。以为合杂。在小检者亦可思详。况今弘经息讥为本。云云。八精进等者。具如止观第二记。又复不行上中等者。约废权说。故前三教名上中下。或指三乘或三菩萨。不倚圆等者。佛尚以异方便及余深法。用助正道。后学顺教岂可固违。习实尚微而蔑偏小。须顺佛旨将护物机

问。偏圆与权实何别

答。通则不别。别论小异。偏圆约教权实约法。法即教下所诠通于理智行等

问。佛世观机恐物堕苦。先以小接次以偏引。末代弘法岂必然耶

答。今云助者。举况而已。恐倚圆蔑偏。然弘经者随其行位。若始行者具如今文不以小答。若深位人始未弘法。必以生灭等三。方能显于圆顿。具如止观诸文皆先渐后顿。面誉等者。如对二人偏誉一人。其不誉者义当对毁。然好誉者必当善毁。令他怀此。故须并息。又面誉如对毁。故智者息之

问。经赞小善安遮面誉

答。好面誉者未必赞善。赞通隐显制面防喻。故安乐行人自护防彼。亦不得约张说赵长等者。寄张家长说赵家长。故令赵家谓说张长。而讥已短。谓见赵行忏。云张人勤。岂不令赵谓以张勤而讥己怠。似善法骂故不应为。若向张说赵短。复令张人谓向赵人而说我短。故大论云。自赞自毁赞他毁他。如是四法智者不为。何以故。自赞者是贡幻人。自毁者是妖惑人。赞他者是谄佞人毁他者是谗贼人。智者应以四悉筹量而护自他。若叹二乘等者对大叹小。令失大故。若毁二乘。或令二乘大小俱失。此约始行二乘人也。亦是习小助大之人。如涅槃中二乘是也。不生怨嫌心者。怨字去声。损己则怨。违情曰嫌。若作平声者。伤己未重心。积大仇。安乐行者尚去顺己之喜。况构无怨之恨。大集云。过去世时有罗刹王。于俱留孙佛法中出家。发菩提心。诵持大小乘法聚。各八万四千。由意嫌头陀比丘。云不诵经典犹如株杌。由此堕狱受大苦恼。从狱出已受罗刹身。于贤劫末楼至佛所。方脱罗刹身。常人尚尔况安乐行为弘大典。将护小行。又怨怪嫌责怨深嫌浅。浅深俱舍方称正行。此口安乐行中所言心者。为制口故。观诸法空等者。心已住于毕竟空理。牒前行法。故必不执大而轻于小。但随顺法相复顺物情。尚不令顺法而违物情。况令违法而复背机。故从若不见去但答大法。随义而答有三者。三种语也。智者语即可答。王者语愚者语即不可答。不应以圆行呵别者。经虽但云学佛道者。以藏通菩萨虽亦求佛与小共故。犹属小摄。既云求短。以权有短是故尔耳。比丘下云诃通者。四众通有三乘故也。去道甚远。复云别者。以通教中复有别机。沈空下却释通也。岂踊出菩萨补处尚皆不识一人。云何令修此等行耶。况人未出预说行耶。况复出已赴命弘持。不见更令有修行处。经又亦不应戏论诸法。此中不须引中论观法品见论爱论彼乃通属三界之惑。亦不须引净名见苦断集。是则戏论。此乃别斥小乘果人。又不应引大论若言非有非无。是戏论法及第四句名戏论谤等。今制嘲谑之论妨安乐行耳。故知释义须望本经。弃浅从深未为当理。止观二行各有四者。此中初二行颂止四。次三行颂观四。初止四者。初一行颂第一离嫉谄。次一句颂第二离轻骂。三一句颂第四离诤竞。四半行颂第三离恼乱。次三行颂观四者。初一行颂第一大悲。次一行颂第三大师。三二句颂第二慈父。四二句颂第四等说。但其皆曾发心者。以皆曾发偏小之心。入实不遥通成大机。即慈境也。此悲境摄一切三界内者者。文中既不云出家。则知是界内流转之徒。经虽但云非菩萨以大例小验知亦不发小。准前大小俱是慈境故也。应知与乐拔苦随举一边。故各释妨令通大旨。经云不闻不知等者。据理而言。偏亦应有不问不信等。圆亦应有不闻不知等

问。云何得知前三是权后三是实

答。准正发誓文。但牒后三而为是经。经以神通等者。二力秖是福智二严深观如来室衣。共为大善寂力者。不起即衣现仪即室。言八万等者。秖是小乘八万而已。如俱舍云。牟尼说法。蕴数有八十千。未关于大。第五随功者。始自七贤终。至罗汉并有定慧分故。城即涅槃者。即第四果也。得有漏者贤位法也。六合譬中次第合六。初合初而诸下合第二。如来下合第三。其有下合第四。于四下合第五。而不下合第六。合与珠中。经云见贤圣等者。太集云。知苦坏阴魔。断集离烦恼魔。证灭离死魔。修道坏天子魔。今不云天子魔者。以小乘多断三魔。未坏天子魔故。然有坏义。经云有大等者。如来见此小乘贤圣。已除界内因果。名与阴战。至般若后名大功勋。故三毒等且在小中。尔后时长通云欢喜。烦恼障中初又三。即贪等三毒。次十六行云一切者准下释一切。始自十信终至妙觉。故知三惑但在欲界粗三毒耳。以十信具除三界惑故。下去犹有见思等三。故云一切。以一切言通收三惑俱转故也。安乐既是如来之行。故弘经者预表果成。故知弘功其力不小

问。何以至此即叹教耶

答。此在迹门流通之末。前已明佛去世后弘经功深。古佛证经今佛成道。二万八十万亿此土他方宣通之益不可测量。人获妙功良由法实。故流通末重辨所通。所通者何。三周开显。故举轮王威伏兵众获勋。勋有大小故所赐不同。此四行后复结成者。显四行功成。能行此行兼弘经力化功归己果相先彰。故使大士刹那梦逾亿世。表一生弘教功超累劫。初十信中既云慈悲。又云正见及以无痴。慈悲是弘誓似发。正见无痴是界内真成。即无见修二惑故也。住中既云见佛。表自当得八相。即分真无生忍位也。见身处中表入实也。欢喜以表入欢喜住。发心见中与初地等。故亦云喜。得三总持具三不退。佛知者得记之由。下去得记可知。修习云行者。前非无行不别而别。至此最得行名故也。证诸者。诸言正表断三十品。言无垢者。初住已得。为顺大经且从初地。若云入金刚定。义当等觉。合在第十地中。此中明信等五根乃至八正者。释佛道也。所行之道不逾七科。随要略明信后四科耳

法华文句记卷第九(上)法华文句记卷第九(中)

        唐天台沙门湛然述

    释踊出品

先以四悉通释。于世界中初明命赴之由。次如来下正明命赴。师严等者。二义互明。道在师故道尊。师有道故师严。师严故命不可违。道尊故有命必赴。由师具二故鞠躬只奉。次正明命赴。所言命者。一由宝塔品末云佛欲以此妙法华经付属有在。此命犹通。二由下文他方菩萨八恒沙众请他土弘经。佛止之曰我娑婆世界自有六万恒河沙众。即别命也。故经家叙之。诸菩萨闻释迦牟尼佛所发音声从下发来。四方奔踊者奔疾也。恭之至也。自在升此故是世界下。三共成初感应也。三世下为人者。有法喻合。初法者。自本成来三世益物。故此三世皆属过去。今佛自当现在益物。菩萨弘经且在于当。慧利既广非心所测。举月譬者。一月本也。万影迹也。但使有水应之不倦。岂可以三世思之。若不拨影安知天月。明诸菩萨实本难测。冥显如来迹不可量。召过等者。若不开迹降佛已还无能知者。今欲显本先出本属。具有二世善根增长。故召本人示现人令现人生现善。使本人弘现经。令当人生当善。虚空等为对治者。约所表也。虚空理也。本迹事也。事有本迹理无早晚。惑者迷理而暗本迹。故执近迹以失远本。本迹尚迷况不思议一。故本之弟子居下虚空。本地之师经久虚空。今之师弟在今虚空。久空今空下空上空虽则体一。然本弟子元知近迹。今之弟子犹迷远本。破执近故召昔示今。今弟子因疑致请闻说方破。破执近恶故云对治。寂场去第一义者。寂场舍那示始成故父少。寂光菩萨行久着故儿老。譬乐力者父何以少子何以老。准下父子譬意父久先服种智还年之药。父老而若少。子亦久禀常住不死之方。子少而若老。虽各有服饵之功。而父子久定。此之四悉虽通释今文。并意兼后品。然初一悉文在今品。第二意兼后品。三四二悉探用后品。皆是助后以成显远。善生恶破见本故也。故知世界即是三悉之由。故踊出品专在世界。文云下引证。总证四悉。即四悉因缘故集。流通叚下云云者。应具述诸品如下委论。又二十八品唯有十一品半。本迹流通十六品半。以经力大举法举人。引今引往。东方西方。若显若秘。总身别身。或逆或顺。往佛今佛自微自着。现益当益畜益人益男益女益。亲益疏益事益理益等。称之不已故耳。又半品四信之文。去取不定况本迹二处流通意别。故注云云。故本门流通永异诸部。他方菩萨闻通经福大者。已闻迹门说流通竟。以募胜福而欲流通。如来止之者。上广募弘经。今他方请弘。何故不许。故以三义释之。初所任别故无二世利则无世界益。二他方于此无臣益者。即无为人。第三二义迹疑不破。即无对治。远本不显无第一义

问。诸佛菩萨共熟未熟。有何彼此。分身散影普遍十方。而言己任及废彼耶

答。诸佛菩萨实无彼此。但机有在无无始法尔故以第二义显初义云结缘事浅。初从此佛菩萨结缘。还于此佛菩萨成熟。平等意趣义如前云。由此二义须召下方。故一召下方亦成三义。是故止彼无三义者无四悉益。召下三义即具四益。初子弘父法有世界益。次以缘下缘深利多有为人益。三又得下近疑破故有对治益。远本显故有第一义益。此是召本弘经之益。于前四悉。但在世界为人。断疑即是本由此中未述。住处下释本处也。先出土名。次以四德释之。三是为下结名。本有四德为所依。修得四德为能依。能所并有能依之身。依于能所所依之土。二义齐等方是毗卢遮那身土之相。若云尘刹重重相入重重相有重重事等重重说等为未了者。以事显理。若不了此一旨谁晓十方法界唯有一佛。亦许他佛。若许他佛他亦身土重重互现互入互融。当知秖是约一论遍。四以不下释住意。五下方下释下方也。法性之渊底释下也。玄宗之极地释方也。玄理之宗故名玄宗。宗谓宗致取果所期。此诸菩萨分到所期。且云极地。又地裂者地覆本属如迹隐本。今开迹显本故裂地表之。然诸菩萨于此已前亦曾有迹。虽但显本于理未彰。但弟子被覆义当覆师。弟子若显师无不显。故显弟子义当显师言在下不属此空中不属彼者。在下空故不属此界。住于空故不属彼界。以彼表无。以此表有。以空表中。出此不在上者非上界也。不在此下者。此界在上空之下。此即是下。故云此下。复以上界表无。此界表有。空亦表中。故上下二空俱表中理。理即寂光。来之由者下。至皆如上说者。从闻命下四句故来。是结释品四悉意也。亦是止他方召下方三义故云如上。若依法门者。此五字应合著六万非多下。非多已上仍属因缘。亦不须移。一即一道等者。既云法门须通因果。事则从多至少法门从少至多者。义当依理起行故也。增至六度既结为六万成圆观行。行依妙境故度成万度实无万。六中各万秖是一万无别万也。六全是万无别六也。一一度行无非法界。界无界相。秖一刹那即一道也。一六既然二三四五准此可见。是则六中无不一多一切具足。当知一道至五眼来。一眼一谛皆具一万。无非三观观法界也。皆云善者不通迷故。多不多空也。一不一假也。双非双照中也。言云云者。应须具论妙境妙观。具如上下不复更云。是彼菩萨之行德也。就初三业供养至遍见者。此乃感应道交。于五十劫令如半日。此明如来不可思议延促之事。显于如来自在之力。则显无机虽借虽隐而亦不能于长见短于狭见广。镜岂惜妍。由形故耳。有人云。听法之志而忘其长。或云。长短斯亡长短斯在。此并得感而失应。何以抑于如来神力耶。借(子夜切)拜绕下更释感应。初释三业供养为机。五十劫下释感应相。初释即长而短。四众下释即狭而广。于长短中又为四。初略示次如来下明非长而长。三解者下约解惑判即是赴机。四斯为下明现长短意。初文者。即八自在中之一也。次文者。佛眼观之长短不二。四眼观之不无长短。故赴长短机令见不一。第三文者。解惑俱机故使菩萨即短而见长。执者即长而见短。如万像森罗。凡夫谓异。二乘为如。如来见之。非如非异。而如而异。既云令诸大众谓如半日。即促彼长令其见短故云隐长。广狭亦尔。如有漏报法尚乃盲者在明而无见。蝙蝠于夜而能视。故知明暗在眼非境尔也。况机应相召今昔之力

问。既云惑者何名妙机

答。菩萨已破无明称之为解。大众仍居贤位名之为惑。机中辩位故云解惑。四斯为等者现此非长非短之长短及非广非狭之广狭。明成佛既久化迹必多。所以为下非本非迹之远本及非少非多之广迹。而为先兆也故知开竟尚达非远非近之远本。况复近迹。若未开显尚昧近迹。况非远非近之远本。以未知久本而为惑者。斯理必然。及至开显咸知本无长短远近斯存。故名不思议一。故先现之密表非本非迹之本迹。四众遍见下明广狭中。亦先略示。次夫肉眼下释。肉天二眼任其自力所见不遥。今忽见远知非己力。即知如来现此神变。必说妙法。次雨猛华盛譬见应也龙大池深譬知真也。见应下合譬也。见诸菩萨应相既多。必并证得弥法界真。秖向见短之人而见于广。广若是机短岂专应。既见即狭之广。理亦方见即短之长。密表当破无明故且抑其一分。陈问偈中亦颂前二初一行颂前如来安乐。初二句正颂安乐。次二句虽云教化亦属安乐耳。次一行颂第二意。易度下言云云者。令出颂中二句之意。但举四人云欲拟者。比拟也。亦对也。如华严下引同也。四十位下言云云者。明彼此佛慧既同人法相望亦等。但彼迹此本彼兼此独。乃至如后十义不同。本迹虽殊彼此俱四。咸为导首故得例之。虽有加与不加及名不等。为知不是彼法慧等。薄须涂熨者。犹如婴儿为病服药。暂须断乳权以毒涂。药势歇已洗乳令服。初乳后乳乳体不殊。中间为病进否权设。亦如痈疮热气正盛。且须冷熨热休息冷。初身后身其体不异。为热暂熨热退如初。此入彼入二处不异。但根钝者入时未至。如痈如婴尚须涂熨。以酪等三暂时调熟故云薄耳。言十意者。虽佛慧不殊化缘生熟。显晦仍别。是故略须述其异同。不可事异令佛慧殊。岂佛慧同令教一概。二酥时异佛慧必同。况复犹是一佛所化。应须了知异本非异。于中先列次释。列中第三语互。准下释中此应题云横竖广略。至下释中二处各别。次释中初始见今见者。华严始见经文自云始成正觉。后文秖是广明因果之相依正通同。所以一经之内三处明文。即世主品初名号品初。十定品初。皆云于菩提场始成正觉。以成始故见者成初。今即法华乃于王城开佛知见。能见所见境智何殊。二日照下开合不开合者。华严望小且名不开。犹带于渐故名不合。于彼不入为今今入。更开于小。三味调之今经方合。言五味者。兼论初后耳。况彼不合者今亦合之。故知彼经开亦不遍逗机未足。合亦不周尚存权迹。应知彼开亦是此开。然亦此合何殊彼合。一佛化事同异宛然。但彼无小机在初名顿。自开小后名渐归顿。开合虽殊二顿不别。三竖广横略者。华严且约入法界边。及从初住终至十地名为竖入。经四十二位故名为广。且约不用六方便边。故名横略。方便对实故名为横。若准广论行愿佛身佛土。相好名字身土四句主伴十方。亦是横广。然自在大竖中论横。故云横略。此述一化遍历五味。味味诸教教教相望。故名横广。从初至后处处得入。故名竖广。本迹二门无不入实。又名竖广。又亦应言若本若迹。皆论久远。三世益物永永不穷。亦名竖广。三世化中八教相入。故名横广。况复放光横叙他土诸菩萨行。答问竖叙过去化仪。三周三节说领述记。复得名为横广竖广。并是如来巧顺物宜称适当会。当知此广何殊彼广。况彼竖广义含横广。故显密不同说时未至。凡有施设语不同耳。第四本一迹多等者。唯华严但以一台为迹中本。本非久远故使千叶成迹中迹。但台望千叶以之为本。纵令十方互为主伴。十方亦复不离一尘。一尘秖在此台此叶。当知秖是迹中依正。是故迹多与众经共。所以法华迹说与众经同。华严但与迹中分同。然已广叙依正融通。何事不明久远之本。若论本门与众经异。华严即被法华本异。华严虽有久远行因。但是今日一番之因。尚未曾云中间一番之果。况有中间数数成佛。当知此异则异于彼。故云本独。若言不异伽耶尚是华严宁非。开则俱开不思议一。此乃以法华之远本。异华严之近迹。故知教门不得不异。第五被加等者。华严多是加菩萨说。乃至文殊普贤及入法界。尚是菩萨自说不见佛印之文。法华除叙文殊释疑及流通中。有诸菩萨发誓弘通。皆是佛述及以对佛便为有印。故本迹正经皆佛自说。虽加不加皆成佛慧。化仪施设时处不同。印与不印其理一也。须知同异以显化由。第六言不变土者。净秽不同常自差别。今云变者。秽为施权变表显实。秽属五浊元在小机。机会权开土变为表。故显本已纯诸菩萨。净土不毁而众见烧。又彼则种种世界不同。净不妨秽。此则宝树华果游乐。秽不妨净。况常寂光土端丑斯亡。寂光所对咸有净秽。虽变不变佛慧何殊。岂由初后变不变殊。令佛慧异。若也不信不毁之说。乃固执于见烧之文。而以华严形斥法华。如人毁訾其身称赞手臂。故知约迹言变不变。净秽难思体同名异。第七多处不多处者。七处八会与二处三会虽多少不同。所说何别。岂多少异令佛慧殊。若以同一报土亦非多处。此中横对四土处却成多。还以彼多对此寂光。多亦即一。彼此体一佛慧不殊。第八斥夺者。亦可更云彼如聋如哑。故有斥夺。皆与佛记故无斥夺。又有小须改故余经斥夺。彼经无小故当部无斥。又别教权说此权易转。故不须斥。小乘难转故须斥夺转。九直显实等者虽有别教以易开故。故且云直。须决了者小难开故。故须云开。十利钝根者。据次第调熟名为钝根。今无不开岂得钝钝。若据兼别彼仍一钝此乃钝利。故约五味判诸利钝。良由此也。一往且从会于钝者。故云钝耳。所以至此机同感同故佛慧同。约化仪说故须辩异。若识理同等者

问。一切诸经乃至草木理无不等。何独法华

答。教之同异具如玄文。虽一切理同说在今教。今所叹者叹能诠教。故诸教中无。旧云等者。先出古释。次今以下十文并之。方知二部了满同等。云云者。乃至应以多重并决而破古师。与问硕异者。先问何故。问家随喜能问人。即指诸菩萨能问诸佛。闻已信行者。即指诸菩萨所化之人闻菩萨说已而能信行。我等随喜者。随喜能问发起大利。随喜菩萨所化之人。如来述叹。但云汝等能于如来发随喜心。何故与上问语乖耶。硕者大也。然能问下答。可见。此亦密表寿量者。今叹菩萨尚是古佛。密表今佛非今成也。若非今成必有远本。求得彰灼故云密表。乃须委相密表之意。故注云云。已如向辩。下结云此约四悉等者。须示此下悉檀四文及意。初是世界。次三又字是余三悉。此约弥勒不识边无四悉益。由问故识识即四益。初文尔时弥勒及八万大士者。恐文误。准经文云八千恒沙。初中初约来者。次约去处。若来下结上二事。所以今见皆不识者。此有二义。一约权教。虽于十方横竖游履。教权时浅不测本人。二约实道。虽居补处。犹在迹中。岂可云知。若实位高为众发迹。应须发起。约十方界去来异故。识不识别。以不识故无世界益。后不知前是为人者。前进之人有所证善。弥勒不知彼之内善。自善不生故无为人。虽先进位深岂过补处。虽云末学无垢位成。如何得以前后判之。亦用前二义通之可见。所化异故属对治者。夫化物者本治物病。弥勒不知真应。无彼利物之道。即不识病无对治也。然智人知智蛇自识蛇。岂补处之人不识其真应。亦具二义。虽同补处久近不等。故知近者不测远者。密开寿量是第一义者。即此一部最极之理。岂非第一。生云。以其悟性非十住所见。故弥勒不识一人。然弥勒位在补处。何以判为十住。又不知生以弥勒证何十住。有人云。弥勒何不直问长寿如涅槃中问长寿耶。今答。此都不晓。今谓伽耶近成。不知过去长寿。由见地踊不识。因疑眷属所由。佛答其由须论长寿。故眷属现岂徒然哉。故知地踊为生疑故现。如来为显长故召之。故远近二由皆为说远。迦叶童子已于此中闻长寿竟。于彼但问长寿之因。故彼经云云何得长寿。即问因也。已闻过去为显未来。故问长因以生佛答。此难彼易理数如然。云云者。令点出四悉。释之如向。请答师主下。云云者。释出请意。抑待弥勒云云者。答问之益不在于我。故不为答。抑待释迦答弥勒问。故云待弥勒耳。何者。弥勒所问事迹不轻。释尊一代未曾显说。因兹答问广显长寿。此一代玄秘在佛自开。汝自当闻我不应答。师子奋迅等者。此中二释。前诸所释用义不同。良由此也。从前释弥勒不知。乃至此中云十方者。多指八方总云十方耳。又私谓至此点四德云云者。须述四德对三世意。此之四德非前非后。随德流类有三世用。故以四德对于三世。不别而别。思之可见。一切万德对用皆然。况四既非四三亦非三。若欲略对三四名相者。神通是菩萨游戏故名为乐。益尽来世故得是常。余二易见三行颂三世者。前师子等以明三世。文中亦无三世之语。但以义势同三世耳。今颂亦尔。直以佛无不实语等一偈半文。而用通之。语既不虚。必知三世益亦真实。双答双释者双答从来及以师主。下方空中。引大论云有底散者。底者下也。散者空也。此但消名。若出体状即约教释者是也。文初云四后云约教。即四教足。非想是有漏底。空是真谛底。边际智是俗谛底。皆以极释也。是则初一是藏。次一是通。次一是别。今经是圆。以中为底。于四释中但云释底不云散者。底即散故不复别释。云云者。应简真中。教门各二故底不同。今是开显圆中道底。从不依止等者。居止下空并不依于上下人天。言人天是二边者。约所表释。人多滞着表有边。天住净福表空边。居此空中以表中道。初五行半等者。又二。初四行答师弟。次一行半答处所。于中又二。初半行正答处。次一行叹菩萨德。下三颂双释者。于中又二初二行半颂释师弟。次半行颂释处所。经不云处但云久远教化之者。前正答中已云处竟。故但以时而释处也。过去久远于何处化化令入实。即空中也。言云云者。应消经文两问双释之意。略如向辩。白佛下准下文此应先开为二。初腾疑次请答。执远疑近者

问。弥勒既不知其数不识一人。云何得知久植善根

答。秖由不知不识。并由佛叹住处德业既多又深。岂近成佛之所化耶。结请中经但举难信者托物不信拒而击佛。令必有答。色美等者。以色等为喻者。总在年少为言耳。指百岁等者先略合譬。次叙淮北诸师用譬释譬者。先释譬。次合。释譬言子不服药者。且据不现劣应之身。而云不服。仍以胜表本故云百岁。既云若佛及佛则显弥勒不知。次如来下今合譬。今师用之故无非斥。合文仍略。言如来横服垂应药者。智契深理。由竖服于真谛之药。处处益物。乃由横服垂应之药。真谛药者。假即空故。权即实故。自行冥故。垂应药者。空即假故。实即权故。化他起故。如是初心由横竖不二之妙药也。此之三药无前无后。真谛药者。以治病故。垂应药者。以还年故。不二药者。以延寿故。以还年故虽老而少。现不二身故云本地。九次第定是善入者。从禅至禅无间入故。奋迅是善出者。从禅至禅皆经散心。以散名出。超越是善住者。虽经起散住禅宛然。毕法性为善入者。毕者穷也。穷法性故。首楞严者能现威仪故。王三昧者。如王安国故。此中约教藏通同者。所证同故。据因为善习等者。自浅阶深故云次第。言云云者。善出善住皆应从果立名。因皆善习如向分别。此中不论本迹者。既是本中弟子未须论迹。信者即增道下云云者。未来禀权多疑远本。应须委约诸方便教明不信者。消今文意。今文并约久成明信。而论增道。增道必损生。具如后品

    释寿量品

初文所以不明四悉为因缘释者。即前品未得四悉益者。今此答竟即是四益。此中为二。初引古通释。次正释品。初文又四。初明诸师异解。次前代下纵诸师以破光宅。三鹬蚌下今四句释。四问下问答料简。初睿师叙意者。举分身以释寿量。而以理况事。并举不足以释足意。明寿而非寿方名为寿。身而不身乃可为身。并由得理能现身寿。故云然则等也。所以初句寿得理故。方非长而长。次句身得理故。乃异而无异。寿既数而非数。身亦分无所分。以理性非量故不可以数求法。身非形故无得以身取。分身既以法身为身。寿量亦以常寿作寿。故便引普贤多宝而为兴类。普贤居菩萨极位。尚名为贤。可表伽耶成亦非成。多宝灭度甚久而出证经预表双林灭亦非灭。今谓以非寿释寿。理实如然。但似不答所问。弥勒问踊出菩萨从谁发心等。意疑伽耶成来未久。如何所化身相难思。本既不疑长寿。何须以非长而长为答。但先以长为答显所化多。长寿之由其唯法报。是故今以三身释之。法华论意亦复如是。河西与睿意同词劣。意云。应身本是法身。法身真化分而不分。故云不异。无生无灭故云理一。故以多宝灭而非灭。用释释迦量即无量。故云与太虚齐等。若尔。引多宝现不云密表。应当多宝现即是释迦长寿。何须更名寿量品耶。况但是法身而失报应。若言释迦量即无量。秖可显未来长寿。与大经同。如何得知过去寿量耶。故今先知寿无量劫。然始方云不思议一。道场观意。以法华为乘始。以涅槃为乘终。终始隔部所以木可。等是隔部何不以华严为乘始。若以会归为乘始者。教行人理一切皆会。会已无始亦复无终。若迹门为乘始者。又不全然。若但乘始。何故法说中明佛智等。譬喻说中明至道场。因缘说中云至宝所。所以初释惟初中五句意云。今之与昔或已入住行向地等。入复增进。唯有一分钝根声闻。于此终开仍入初住。岂名乘始。若初住名始弹指如何。故不依此能判经部。若涅槃澄神为乘终者。说大经时十仙诸外道。并初发心。复无量人退菩提心。又法华之始则在物机。涅槃澄神约于教主。由法华教主久成。故涅槃澄神不灭。又灭影为息迹。则法华犹迹。澄神为本非今经本。应知今经以久远实成为本。中间今日示成为迹。若依他释本迹二门俱属乘始。若不释本直于迹中明始终者。具如玄文乘妙中说。注家先举非存亡出修夭为非寿量。用释寿量。次明寿量意。然释两字仍似颠倒。存亡之数是量。修夭之限是寿。一期曰寿。寿内之数曰量故也。次法身下明意者。重举向非寿非量之体。非形牒非寿。非年牒非量。此违论文使大士下正明说寿量意。意令菩萨修践极照。令知如来远寿之体。是大士智之所游。所游既深故云践极。达彼非寿故名为照。不以两字贯下百年。期颐者。期要也。颐养也。百岁之人不知衣食。要假孝子而扶养之。今佛不然故云不以。生公意者。虽亦明无长无短长短恒存。故与上三家其意稍别。仍阙注家说寿意也。于中初明伽耶色。身形寿不实。用为法身无寿之表。然则下以形例寿。万形一致。显身分而不分。古今为一。明寿量即非量。古亦今也下。明今古不二。当不思议一。然准今文先须辩长。后方明一。言古亦今者。明本佛古不异伽耶之今。今亦古者。明伽耶今不殊本佛之古。无时不有下。重释形寿。无时不有。释寿也。无处不在。释形也。无时不有非独今日。无处不在岂专伽耶。若有时下明形寿在物应非有无。次是以下秖指近成即久成也。故云伽耶是也。次伽耶是者下。转释也。虽指其是谓近非近。伽耶既非下。明短既非短长亦非长。次长短下。真俗相对以释长短。真乃长短斯尽。俗则长短恒存。生公意云。一身之处三身备矣。近成之果与远果同。故八十之寿即无量寿。道理虽然须先各判。方可融通。验前诸师偏得片意。并以法身为极皆违论文。论文但指过去报寿为长。何得用法身非寿以释。法身非寿诸教常谈。但未曾说久成远寿。故知尚不及于注家践极及以生公长短恒存。然不云恒存之长诸经未说。当知消当文非无一意。释远趣出自一家。故说佛慧彼此悉同。若论远寿一向须异。前代下却存诸释。诸释皆不以寿量为无常。光宅乃以寿量为延寿。若约今师三身四句。望诸师意并无可存。又惑下引古师难。次今为下通难。先略破古人次正释。先引事云鹬蚌相扼等者。引春秋事。具如止观第五记。但用事不同。彼但借相扼之言。此正用乘弊之意。我乘下正释今如强秦。使常无常家如燕赵也。及金光明者。彼第一卷寿量品云。相信菩萨自思惟言。何缘释迦寿命短促。方八十年。如佛所说二因长寿。一者不杀。二者施食。佛无量劫具足十善。云何短促。思是事时。其室自然广博严事。因见如来希有瑞相。乃感四佛为其说偈。偈云。诸水滴山斤地尘。空界可知其数。无有能知如来寿者。品文具有此义者。即此品后文具三身义。还揽此三分为四句。是故应知今品题意迹中指本。本具三身故不偏执常与无常。今正应以本地之长。用开迹短晓长本已。方达本理无复长短。故借迹中三身四句。对本以释。当知本迹俱具四句。本四俱本迹四俱迹。问若寿量等者。涅槃亦云。惟佛与佛其寿无量。无量故常。明常既同经应不别。经部虽异二常何殊。答中为二。先反质令同。次分别辩异。初反质者一乘既同俱常何咎。大经云一切众生悉一乘故。其部虽异常理何殊。若部异常殊。亦应部殊乘别。云云者。虽如向述。亦应更立名异义同。而为多并。分别答者。先涅槃。次胜鬘。初涅槃者。明常虽同广略稍别。亦应结云岂广略别。令常不同。次文云为一明一者。三外之一自为一机。非会三一故但云一。部属方等对斥偏三。未至法华不应云会。云云者。亦应更云带不带异一乘何殊。亦应具约五时明会不会一乘共别。次问近成是方便等者。今师假设。先引华严大经以定。次若尔法华下引法华。于华严大经为妨。法华若兴皆开成远。则法华中无复方便。何故本后不轻却近。当知下结难。若尔会三下。以迹例本。本门开已更近。亦应迹门会已不会。应知此中文略。须先结云迹门会已无更不会所以本门远已无更不远。纵不轻中更明近迹。不可长寿更令短促。次若尔下重以迹例本。以定道同。故一切诸佛悉皆尔也。若尔下难诸佛寿同。何独释迦长寿可叹。若独下结难。若独释迦寿长。则有佛道不同之过。故云前诸义坏。答意者舍异从同。一切诸佛悉皆如此。故云亦然。意在同显实本。不必长短悉齐。又诸菩萨下引证。且引愿长岂即全等。此即下结同。亦不偏言者明常寿等。显往时异长短不同。望未来常一向平等。故诸佛显本各有远近。若论寿体无得复云一近一远。故诸菩萨闻长寿已。亦愿未来说报身寿如今释迦。但开迹已无复近远。故知下明本迹体用。体用即法应相望。若应迹相望不无近远。约近迹应望本初应。得有近远。故对缘长短无别长短。所以不云报身长者。欲以法身亡其长短。又欲显于诸佛道同。其实开三佛道可同。事成久近不可同也。以是方可破他诸师。故云诸师不可师也

问。既云远成真实近成方便者。亦可云近成真实远成方便不

答。若初住中本下迹高被物说远。即其事也。故诸菩萨发愿利物。随四悉益亦可说长

问。若尔那知释迦不是初住

答。今显实已不复隐本。故知非也。是则初住说长为权。开权说近为实。既有本下迹高。亦有本近迹远。用此高下开诸经中长短俱常。既了诸经长短俱常。自晓今经久远之本。唯云常者尚未可依。验知诸师计无常者不可依也。问义推等者。如向所说。法华明常道理实尔。据文不如涅槃常显。故今经明常似无文据。答意者。诠教也宗旨也。糟糠及桥并能诠教。能诠虽异失旨如糠。问桥具如止观第十。此且通途以斥执者。又教本下别明化意。前虽通斥今别明四悉。宜长宜短被物不同。即因缘也。又文下以部望部据多少论。非全无文。即约教也。若随多弃少等者。忽若俱少则二经俱弃非魔何谓。具如涅槃第七邪正品中。不知法身常住皆名魔说。又此经处处明法身者。略如向引。但名异义同。人便迷名而失其旨。若但随名尚是魔说。况多少耶。亦如玄文同体异名中说。即是实相宝渚非如非异。平等大慧等。问既明法身等者。若明法身无三德者。当知则非常住法身。答文可见。论文亦云成就三身。三身即是三德故也。次正释品名为二。先通。次别。初中先释如来。次释寿量。初云通号者。且指如来一名。余九非无初号最显。具如下释。具通三身并具十号。略如止观第二记。次释寿量。诠量也者。寿家之量故曰诠量。故释量字诠量十方三世三佛等。故云也。次今正下结归品意。乃指今之本佛何故尔耶。以如来名通寿量亦尔。不可局故。故须且通。题名虽通意则局本。故结归也

问。法报是本应身属迹。何以乃言本地三佛

答。若其未开法报非迹。若显远已本迹各三。次如来下别释。亦先释如来。先置广从略。所言广者。如四身十身三十三身无量身等。从义既广。今从略名以消品目。所言二三者。二即真应三即法等。不云化者。化应一往其体大同

问。华严十身此但二三。身数既少摄义不周。是则此经身义不足

答。义有通别通义可尔。别则不然。彼通云身故云十身卢舍那也。别释如来故不应云业报佛国土佛等。若欲通收彼经十身。应开为四。则以化身摄于业报。智即报身虚空属法。余皆化摄。故知此经亦立多身。则妙音观音三十三身十法界身。或己或他即其事也。况今释品如来之名。故但可二三。诸教定故消名便故复释本迹方在今品。故知今品即是本地二三如来。初二如来者。先借论文如实之名。次释此名以成真应。又二。先真。次应。真即法报二身合明。故举境智和合以释真身。乘是下释也。既但以如智契境。故属真身。论中秖一如字释中境智各双言之者。秖是能如如于所如。所如如于能如。此用金光明意也。若单论下明境智和合。成因取果阙一不可。次道觉下结成真身。因果满故。故云义成。所以真身云成。应身云生。以如实下明应。又二。先以报为本。前释真身。乘实道三字属因。今因成果全属果用。用本所证契境之智。乘于果上利物权道。即实而权故云实道。故以方便生于三界。次来生下正明应身。亦借成论小名以显圆义。善简名义理则可归。次明三如来中。但离二为三。于中又三。先出三如来义通本迹。次又法华下。别显本地三如来也。三论云下引经论证。初文又三。先出正释。次法身下翻名。三是三如来下融通。初又二。先借大论立义。次如者下解释。论文一句三身具足。初以如之一字。名为法身。指所如之境。还指所证为来。故云不动而至。此即如非因果而通因果。来字在果不通于因。次报身如来。又三。先正释。次从理下结得名。三故论云下结示论文。初文者。专约报身解其二字。但初如字义与前异。前如法二字属所。今如之一字属能。法通境智。智谓能如。境即所如。智还乘于所如之境。得成于果。故云乘于真实之道。次智称去释今如字所以也虽即智如于境。然如从境立名。故云从理名如等。次引论者。如能称于法相故也。解即属智称境而解。即能如也。以解满故名之曰来。准此法身亦应引论文。云如法相也。但是文略

法华文句记卷第九(中)法华文句记卷第九(下)

        唐天台沙门湛然述

三明应身。又四。先正释。次引证。三明应相。四引论同。初文者。先明应由。由智称境示能说身。说即应也。自报无说故言以如如境智合。但云以如不云法如者。法既属于境智。用此境智能起应故。以解属智别对报身。应非无智且以称机用拟于说。故他受用亦得名报。亦得名应。若胜若劣俱名应故。故知大师善用论文妙至于此。次翻名中具三身也。近代翻译法报不分三二莫辩。自古经论许有三身。若言毗卢与舍那不别。则法身即是报身。若即是者。一切众生无不圆满。若法身有说众生亦然。若果满方说满从报立。若言不离三身俱然。何独法报。生佛无二岂唯三身。故存三身法定不说。报通二义应化定说。若其相即俱说俱不说。若但从理非说非不说。事理相对无说即说。即说无说。情通妙契诤计咸失。沃焦者。旧华严经名号品中。及十住婆沙中所列。大海有石其名曰焦。万流沃之至石皆竭。所以大海水不增长。众生流转犹如焦石。五欲沃之而无厌足。唯佛能度是故云也。前二身名一切常定。故应身名十方各有不可说佛刹微尘名号。故彼品中新经云释迦如来亦名毗卢遮那。旧经云亦名卢舍那。旧经意明应身异名。故总彼二经三名具足其体本一。但新经意以毗卢为舍那。旧经直举他受用报义复何失。三融通中四。先略示意。次引教。三修性。四引论。初如文。引教中三。先引经。次总结。三问答释妨。引经中二。先引大经者。意明三德秖是三身。三身具如诸文所释。引梵网等三结经者。以义大旨与三经同。而义意撮要。若华严中十方台叶互为主伴。此梵网经唯一台叶。故天台戒疏判云。华台华叶本迹之殊。所以华台华叶本迹定者。被缘虽别道理恒同。所结既同能结岂别。像法决疑意亦同于所结故也。普贤观云。准上可知。结与释妨文相可知。若但下约修性纵横不纵不横。以判圆别者。即是约教。于中先别。次圆。后以藏通况之。言修纵性横者。非圆妙也。性德之名名通别教。别教虽有性德之语。三皆在性而不互融。故成别义。若三皆在修前后而得。道理成纵。具如止观第三及记。故知今经不说纵横。若性若修三皆圆妙(云云)。又法华下明本迹也。先正示同异。尔前非不明圆三佛。但与法华迹门义同。非今品之三如来也。故云永异

问。论中但指报为久远。应指伽耶法非今昔。如何三佛悉指于本

答。论虽互指。理必咸通。岂昔有报而无余二。岂今但应而无法报。以中间今日悉具三身。但自实成望于中间今日所现身处。通属应化故且对之。又法身虽即不当今昔。约修相望还分近远。下释寿量可以准知。故今日中间节节具三。次引论如文。次释寿量两字。即向三如来之寿量也。故释寿量中各具足三义。于中先略释寿。次广释量。此是寿家之量。故广释量即是广寿。初释寿中先释字义。次真如下即以字义而通三身。次释量字。于中为七。初明义通。随三如来自无定故。以成三句用释三身

次复次下更专以四句消前三身。三一身即是下。融通三身。四随缘下赴机不定。五此品下。约身以判。六复次下。判于本迹。七问答释疑。初立三句者。即是前二三如来之寿量也。既但开合之殊。今但从三为便。于中三。先释字。次对身。三立句。次法身下。即以三句释三身也。初法身为四。初略标。次有佛下释出所以。三文云下引证。四盖是下结归。初如文。次释所以中又二。初正出法身所以。次不论下简异二身。又二。先身。次寿。初简身者。不论相应简非报身。与不相续。简非应身。与字引下句耳。不论两字贯下二句。次简寿中亦无有量。简非应寿。及无量。简非报寿。亦无两字贯下二句。故以及字引之。故华严云。法界非有量亦复非无量。牟尼已超越有量及无量。彼但迹中约体用论。体必双非迹能双用。此乃约用明体故云超越。若直引此以证久本。良未可也。以彼不云已成寿故。文云下三引证。两句并双非报应。诠量报身中亦四。初标。次以如如下正释。三文云下。引证。四此是下结。正释中二。初正释。次境既下释出所以。先正释中二。先正明。智契于境故有报身。次境发下借义释名。由冥故发发方名报。是故得有难思之寿。次所以中二。先法次譬。函境也。盖智也。由相称故有含藏用。所藏之物方任外资。引文者。初句证报体。次句证报因。次句证报用。次句证报力。三诠量应身中亦四。初略标。次应身下释所以。三文云下引证。四此是下结。次所以中三。先明功能。次缘长下应用。三云云下明应即体。引证中初二句证应相。次二句证应用

复次下约四句中二。初正释四句。次四句下四句料简。初正释中先正释。次总破古。初正释者。依身次第不依句次第。故初法身为第四句。报身即第二句。以金刚前未名报故。即第一句是有量也。而未名佛。且云无常。其实更须分别同异。金刚至凡节节异故。应身即第三句。言通途者。欲以四句收一切故。故以第一句自金刚来。通及凡夫。故非佛之言所摄该广。况复凡夫亦得以为三身之本。故入初句。次破旧中云两谤者。品中明常不以常解。名为减谤。品无无常用无常释。名为增谤。次四句料简中又二。先结前生后。次正解。于中文自分二。初言别者。三身别释。分句属人所属楷定故也。释报身中先定句。次释疑。于中先明法报义等同第四句。次但取下明对句意。凡夫共者。今文释佛。但三身之外。皆属凡收。故文尚以金刚之前。不属三身并入凡例。言别教者。三身别别各对句故。故是别教分别之相。次通途下通释也。各具四句。三身互冥故云圆释。三身各四故云通途。于中初通标。次一一通释。初法身四句中。云双破凡圣八倒者。凡四圣四中理任运常双破故。然亦须简八倒体状。如前十八空中说也。第三句言无常者。无彼常故。第四句者指寂为法身。两亦而照。次报身四句中皆须约智。初双非者。境既双非智必称境。第二句中云出过二乘故者。小智但有计无常故

问。此中双照与向何别

答。向以寂即法身寂而常照。此中约双照之智故得为别

问。法身是境境何能照

答。相照四句具如玄文。应身四中非报身故非常。非生死故非无常。两存者双具前两。凡夫四句中先明用句所以。今明如来何得通凡。为咸四句既一句对凡。今既通释望佛非无。况复性德三身具足诸句。言性德无名字者。未有修故明无果佛四句故也。但约理三以立四句。第三融通者。一身即三不同他释三身定计。是故身句皆悉互通。名通义通理通法通通而恒别方释妨也。第四随缘中三。先示相。次引经。三所以下释出所以。即约教判也。言若诸菩萨未登地住。云同前者。同二乘也。与夺者。以他受用亦名应故。地上见者是他受用。但以报应二名而论与夺。大经下更举大经三譬。以证三身。五此品下约身以文义判品。令知久成。又三。初正出本报。何以故下释出所以。上冥法本下契物机。三以此下结成本报。六复次如是下。广约本迹示今品意。于中又四。初正明本地三身为本。即正示也。次诸经下与诸部以辩异。三非本下明本迹之由四本迹虽殊不思议一。于中又五。初正明本迹体性。性即实相。实相非久。谁论其本。实相非近谁论其迹。实不思议故名为一。次正斥肇师。言寂场者。若以睿师九辙中。仍寄多宝表本。而肇公指释迦本迹。须云寂场。三复次下更举近中多种本迹。通斥诸师。四今摄下。别示久本近迹。明不思议。五如此下结异。初二如文。第三文三。谓标释结。释中又二。初别约三谛以论本迹

复次此三下。总约三谛三一不异。以论本迹。且约次不次以论总别。若别若总俱不思议。但据设应之相用法不同。致成总别。皆依本时即总而别。乃能用于即别而总。总别不二适时言殊。然于别中出别相者。从真起应。但以神通通名为应。俗则但指俗谛三昧。以之为本。随方便教得作此说。未知下总结。四别示中三。先正简示。次示本。迹相显。三本迹下示不思议。初简中言三番四番者。三番三谛也。四番加一心。若本若迹皆摄褺者。摄属褺持。褺字亦重叠也。三四重褺同在本迹故也。若本若迹皆有如是四三本迹。在本在迹随时别故。简中间本迹为迹。本地本迹为本。他人不见今经本迹。但知从胜专求法身。如此法本与众经共胜翻成劣。若得久本则近迹不失。若但云法身。则尚失中间。况复远本。从个下明本迹相显。从于本地本迹之本。垂于中间今日本迹之迹。如是本迹久近相显。方知本是迹家之本。迹是本家之迹。三本迹不思议者。即是约理。五结异。如文。七料简中先问意者。胜方名异。诸经所明法相此经尚少。应劣诸经。何得反能超异诸说。次答中二文。皆云种种。不出因果及以自他。文有譬合。前文云业。即能行之行。宝即所行之法。位即所阶之果。方便教中行因获果。故云种种。若无法身常住之寿。因果无归。故知诸经诸行不同。皆入今经常住之命。此常住命一体三身遍收一切。此约自行。次大经下更约自他。具如法门下双合。海中之要下结出胜意为三。谓法譬斥。斥云非异是何。法性法身。智即报身。应即应身。故法性海中要岂过此。故应皆以三身合喉等四。然诸经中岂无三身。但为兼带及未明远。是故此经永异诸教。若不尔者。诸检诸经。何经明佛久远之本。同此经耶。何以苦贬久成之德。为释疑耶。此若释疑方便亦是释现相疑。方便释疑则序品为正。方可此中踊出为正。况他并判以为流通。然论中自列十种无上。一种子无上指澍雨譬。二行无上指大通事。三增长力无上指化城譬。四令解无上指系珠譬。五净土无上指多宝现。六说无上指髻珠譬。七化生无上指踊出菩萨。八成道无上指寿量三菩提。九涅槃无上指医子。十胜妙力无上指下诸品为余残修多罗。当知论意指分别品去。为余残修多罗。即正经之残流通分也。望今所判唯差半品。若以功德而言。可俱属流通。今从记领判属正耳。并异诸经故云无上

若尔。雨譬已前岂非无上

答。雨譬已述譬及领解。方便品已判甚深。甚深秖是无上异名。况方便品已。是譬本。若以方便去八品为正。犹得迹门中正。若以十三品为正。复杂迹门流通。故知取迹流通为正。弃本正为流通。深不可也。具如别记。故知本地三身。即诸经诸身之喉。如衣之襟诸根之目。如屐之蒵。蒵字从草出风俗通故知今明本迹。不与诸经诸师同也。此品文句疏文稍繁。前后难见故前录出。但依此开。开显文二。先诫信。次正答。又二。长行偈颂。长行二。谓法譬。初法说为二。一三世益物。二总结不虚。初三世为二。初过去为二。初从如来秘密下。出执近之谓。二从然善男下破近显远。初文又三。初出所迷之法。二出能迷之众。三出迷远之谓。次破近显远。又二。初显远二益物所宜。初又二。法说譬说。譬说又三。初举譬问。二答。三合。次益物所宜中又三。初益物处。二拂迹上疑。三若有众生下。正明益物所宜。于中又二。一感应。二施化。于中又二。先明形声益。次得益欢喜。先形声又二。先形。次声。形益又二。一非生现生。二非灭现灭。声益如文。得益欢喜如文。次从诸善男子如来见下。现在益物。又二。先机感。次应化。于中又二。一非生现生。次非灭现灭。初文又二。一现生。次现生利益。现生又二。一现生。二非生。第二现生利益中二。先形声。次不虚。不虚又二。先不虚。次释不虚又二。初照理不虚。次从以诸下明称机不虚。于中又二。先机感。次施化。次明非灭现灭。又二。一非灭现灭。二现灭利益。初又二。初本实不灭。于中又二。初明果位常住。次举因况果。二从然今下。迹中唱灭。次现灭利益又二。初不灭有损。二从以方便下。唱灭有益。初又二。初不灭有损。次广释。次有益中二。先叹佛难值。次释如文。第二总结不虚为三。先明诸佛出世必先施三。次明皆为化物。三皆非虚妄。次譬中二。开合。开譬为二。一良医譬三世。二治子譬不虚。初文又三。一医远行譬过去二还已复去譬现在。三寻来譬未来。过去又二。初发近显远。二化益所宜。今但化益。上化益又三。一处所。二拂迹。三正化。今但正化。上正化又二。一机感。二正应化。今具譬之。今就初文为二。初如有良医超譬应化。从多诸子息追譬机感。次正应化(已上譬文勘上法文)此文有三诫。三请至郑重者。请中既云如是三白已复言者。当知至四。佛于三请之后。又云汝等谛听。即第四诫也。并前迹门诫许及三请。即五诫七请。郑重如前释。昔七方便至诚谛者。言七方便权者。且寄昔权。若对果门权实俱是随他意也。以圆人中亦有无生忍者。易闻远故置而不论故此自他随用别故。具如玄文。法说中未来语少者。但指常住不灭四字。为未来文也。譬说偈中文多者。长行譬说中从其父闻子已下文是。其文尚少。偈法说中从我见诸众生下。十行半文故云多也。一身即三身等者。文中二解各有其意。初释约三身法体法尔相即。次释约今昔相望。以今法体望昔故也。亦可前释通诸味后释斥他经。唯在今经故也。即秘密家之神通。故还约三身以释。故知神通力言随于诸教教主故也。故广约诸味简已。更约今昔简之。方显本地三身神通。若释小乘及以渐教。则不得以此中三身释之。引大品者。此经举一切世间皆谓近成。唯列天人修罗不云三恶者。然计近者。亦多在此三故引为例。前虽有二乘之名从初以说。若被开已俱成菩萨。故今但从开边以说。彼大品意云胜出者。但胜出小。小在此三亦不须三恶。故暂引同。从此法身地至长远之说者。法忍菩萨尚自须闻。当知寿量非说不知。然得无生者。亦闻应即法身。但不闻久成而已。言自应等者。但不同界内经历五味跨涉本迹。七请五诫方乃得闻。以见一分法身。理合得闻长远。故前文云。地住已上得闻常故。但常与余时异。故更论之。破近显远略有十意。如玄义云云者。玄文第九明用中。有十门不同。彼具列释兼与迹门十意。以辩同异。今但略举破废二门。注家云。无始之寿晦而未彰者。此不应尔。何者。此中正明久远之长。以破伽耶近成之短。彰灼显著何晦之有。又言。何佛不然此亦不尔。久近不同长短别故。言直下尘被点之界者。此中经文不云下点。但兼彼迹文成其语耳。僧传云。准罗什旧经。无一尘一劫四字。有斋高僧昙副。诵经感梦云少一句。后果得之。若金光明云。一切海水可知滴数。无有能知如来之寿。此亦明未来之寿。非过去也。若引证此殊不不相关。益物处者。此之娑婆即本应身所居之土。今日迹居不移于本。但今昔时异。见烧者谓近照本者达远。故经云。我土不毁常在灵山。岂离伽耶别求常寂。非寂光外别有娑婆。于是中间等者。先正释。次或有下出古。三今谓下破古。正释中初总立能拂。次疑因下示所拂事。先标。次昔教下释出所疑。次今拂下正示拂相。正由经文先举事竟。结云皆是方便。即名为拂。昔于诸教虽见不同而生于疑。乃不知是果后方便等。及如是示差别意。即说值然灯等及在然灯之世。入涅槃也。次古释者。又有人云。说然灯者。说他为我为平等意趣。经文但云我说他身。何须改云说我为我。今释意云。是释迦菩萨入灭。不得云是然灯涅槃。亦非释迦尔时于然灯世已曾成佛。而般涅槃。不可二佛一时兴故。是故但以得记弘法寿终为果。佛眼等者。既对佛眼举于两应。故他受用亦应摄也。人天及以法眼皆云华报者。非无近果让佛报故。其土既尔身岂不然。信等诸根者。既为如来本地佛眼所观。穷其久远照其根源。故此五根。须约本地中间缘了。复经渐顿大小及人天乘。名同体别通。得名为信等五根。以人天乘通名缘因故也。此乃望彼遍开通成缘了。于中先约渐顿判。次约大小人天以判。小即渐初。渐中利钝但云藏通者。渐通具四以别圆同入华严中顿教摄也。是故且以渐中界内巧拙。对于利钝通在方等般若二味。又以小对人天辩利钝者。且以优劣相望故耳。但人天乘遍在一切大小教中。十界至二因也者。应云十法界中亦有恶法。而言不用者。以十法界是生善机处。故不取恶。但十界中展转相望。有五乘七善及圆实等种。是故圣人更立方便传传引出。良由有机机宜不同。不可顿出

问。若尔。佛果既极如何亦得名生机处

答。此中论机及辩利钝故。佛法界未是佛果故。彼玄文十界交互以论机缘。则果佛机通在十界故也。若直宜以佛界度者。则是佛界有佛界机若未宜佛界则渐于菩萨界。而成熟之。乃至地狱即至地狱方回心者是也。具如释签亦如观音妙音现身不同。自说名字等者。既对十界。或但论四圣以辩胜负。及应胜劣。当知此中且对佛界胜劣应耳。所以频论者。恐仍谓法身说法故也横论即十方者。昔十方也。约竖处所至然灯佛等者。以释迦望昔值然灯名儒童时。非取他然灯以望我也。若取他佛非我竖也。若指然灯佛身则可引类而已。故云如今等也。言生法者。如下所释胜劣各有生法二身。次约横中云亦如华严十号等者。名号品云。如来于此四天下。现种种身。种种名。种种食。种种形。种种相。种种修短。种种寿命。种种处。种种根。种种生。种种业。令诸众生各别知见。又于十方各有十千名号令诸众生各别知见。既云如来于此四天下等。故不得将他佛以望我也。竖中亦然。又诸经下明佛有三身自互相望名字不同。初通标或说去。举三身相望亦得是横。法身佛去乃至般若首楞严者。于法身中又有异名不同。般若是智楞严是定。不思议定慧并法身之异名。具如止观释名中。以大经佛性有五名也。但举法身余二仍略。以横望故即得以佛望佛。如前竖望秖得以佛望往菩萨身耳。今既已成可得横望。或说寿二万至可知者。此借他佛以显释迦。如彼诸佛故皆云如也。纵横可知者。释迦弥勒即纵也。对现十方即横也。若自身今望往日寿即竖也。望自身寿即横也。如玄义云云者。彼玄文寿命妙中。具明迹中四佛寿命及以本中大小不同。优劣相望及以彼此而论横竖。然不以优劣判本迹。但以久近判本迹耳。令辩同异故注云云。或三身相望者。于一教中自以三身而有优劣。用为大小则义通别圆。次或三身各别皆为小者。此乃别圆相望圆大别小故也。例三点云云者。秖是并别及非。纵横即譬别圆。具如止观第三。古师六释皆为纵横。今师三释不纵不横。若更于纵横判大小者。小乘三德为小。别教三德为大。亦复现言当入涅槃。此指开迹竟文者。若开迹竟。得言双林是示灭度为益物故。以今准昔亦复如是。师子奋迅等者。奋迅之名及十功德。通于本迹乃至初住。今须简之此是久成现作现在。有十德者。前九可见。如第十云具上十善。即如四观观其十善。圆即上上十善也。十善秖是三业故云身三等。故四三业节节不同。故上上者至果名为师子奋迅中第十功德。秖是三业随。智慧行及三密等。故佛果地亦以师子三昧。奋他尘垢。若论诸佛世世皆然余九准此。云云者。委释十相辩中间今日世世皆有。现在迹化由本功德。如来见下乃至乐小法者者。以久近相圣为小。佛以本地佛眼见之。未宜远说。以乐近说为乐小耳。华严至人耳者。先引经。此是十地品初金刚藏止解脱月辞也。案彼经下今文判也。故知彼经以未至回向。为不久行。此但次第行耳。若普贤行初发心住已圆证竟。岂至地前云不久行。而不为说。若言寄次而论不次。何故初住不亦且次第耶。故寄次之言须有典据。故彼以不久行为乐小者也。今文乃以乐近成为乐小。但引因类本非即本文。若云对小乘为乐小者。地前住前及藏通菩萨尚不被小。况彼经十地。况今经本门。师云者。引南岳说同为证。今当下大师于下通约教道。始自弊欲终至别教通名乐小。德薄垢重者。其人未有实教二因故也。言下文云诸子幼稚者。指下医子譬文。尚未堪闻圆。况开远耶。见思未除者。且消譬中幼稚之言。定未知远。次问者若前四味但乐近成为乐小者。华严顿部诸味中圆。及以因门云何亦为乐小法者。答中四义。三在因门第四在果门故乐小之名尚通弊欲。何况小耶。故今果门别在乐近。故前三人中前之二人。自退大后着爱着见。此人尚不乐于小乘。况圆乘耶。次一是着三方便教。尚不堪闻圆。况复闻远所对别故。故对果门以乐近为乐小。故知果门圆人贤位犹有乐近成者。若果门之后一切开已。初心亦闻况贤位耶。末代未曾发心。亦闻况发心耶

问。末代咸闻佛世安简

答。佛世当机故简末代结缘故闻。若得此意凡诸法相所对不同。何须问言圆不应乐小。前明利钝至两应者。前明两机通渐顿教。总判利钝。故今总以两应言之。劣应至法身生者。二应之相。经文各有生法二身生相。当知两处相望不可以乘栴檀楼阁。滥同贯日之精。不可以种智圆明。同正习俱尽。复以十方七步不同。而表胜劣。故知两处皆无久成。但以至作如是说者。未开但说云生。开已方云非生。今述昔垂方便。对今开已之言。故总云耳。余经至非生者。一往且从小乘以说。如佛问均提。汝和尚戒身灭不。乃至知见身灭不。皆答云不佛印许之。既许不灭故云不破。若大乘中亦非不破。又虽以大破小。但大小相夺大小仍存。终无以远而夺于近。故云尚不等也。故今经望寂场遮那之体既是迹成故云正破。未及委论四教。且约两处成相。即晓藏通二身是劣应耳。别圆二身是胜应也。文中虽云两应各有生法二身。然劣应之上五分法身义同生身。胜应之上虽云生身。义同于法。言值然灯至说他身者。以然灯佛身为他身者。若准此意他身之言应存两释。示即必在于我说则兼于自他。如今之说弥陀。亦成我事及弥陀事缘相关故。如一众会或集十方或集一方。或往十方或往一方。示现依报者。非直现土。土尘皆说具如华严。上过去至世界之益者。一往且以得欢喜边名为世界。岂过去世无余三耶。故云似也。今明皆不虚者。今现在文皆具四悉。俱至本门故也。故知过去还须具三。大论四悉檀并实者。彼论通以第一义。为衍门法相。以三悉为三藏故。各有其实。笃论下彼大论意克判虚实。一在衍门故实。三在三藏故虚。言缘中者。如向随缘不定。机在于小小即名实。如三藏人于此四悉。则三实一虚。通别二人则三虚一实。圆乘则一切俱实。凡夫则一切俱虚。若以下借此虚实判二门者。以此二门对于渐顿二种众生。未曾当机为虚当机为实。且置四悉而以因果相对辩虚实者。于中先以七方便人对二门判。次以实人对二门判。若方便教二门俱虚。因门开竟望于果门。则一实一虚。本门显竟则二种俱实。故知迹实于本犹虚。约圆顿下若本圆人望于二门。亦秖一虚。虽云更不别得非无增道益也。若于昔教曾密显远对此二门。亦名二实。准前亦应云更不别得。不无二门增道之益。若五十起去。对此二门犹名俱虚。又前教密开不来至此。亦名俱实。于踊出众非虚非实。亦名为实自欲得故。于灭相者此虚彼实。于有退者现虚当实。影响发起。亦非实非虚有虚有实。于迷教者一切俱虚。问意者昔是昔教今谓二门。今昔本迹俱名入实。以昔望今为二虚者。应当今日二门实相胜昔实耶。实本无二今昔岂殊。答意者且以迹答。本准可知。教门前后入实无殊。初指华严次指二味坏草庵入即指法华。入时在人非理别也。次例者以小例大。此乃以横例竖。若还以竖例竖。应云鹿苑入小与二味中入小不殊。此则入大入小无处不有。五味从次第相生。钝小从显露以说。此中六句者明今日应身即是久成法身。不思议一故云照理等。故本迹者寄事以说。如实知见等者。论云。如来知见三界相者。谓众生界即涅槃界。不离众生界有如来藏故也。无有生死等者。论云。常恒清净不变义故。亦无在世等者。论云。如来藏真如之体。与众生界不即不离故。非实等四者。论云。离四种相以四种相是无常故。当知论意诸句皆圆。是故诸句皆云与众生界不即不离。故今并作圆常中道佛性释之。不作此释尚不能见昔教中实况开显实况久远实。故此须指本智照境。不见斯旨徒消本门。言六句者。初如来去。二亦无在世去。三非实非虚。四非如非异。五不如三界去。六如斯去。于中初明句意者。如来明见应云法界。何以但云三界相等。为令众生知垂迹处无非法界。法身常住故云如实。感法身者。机击法身令起二应。故名为感。不可单以法身为应。如实下正解。解中初第一句。若准下句中云无二死。应云无二种三界之因相也。直云三界者。能知见者名之为智。所知见如如即中境。中境不出三界故也。于所见中既通凡圣。今以如来知见皆实。余所知见望佛皆虚。而犹有因。佛如实见故云无因。离三界已无别理故。无生死去。即无二死果也起集下结上无二死家之因果耳。故有五住集名退。有二死果名出。而云无常果现者。二死望中二俱无常。别指二土以为二死。通论金刚已前尚名无常故也。亦无在世及灭度者者。亦是双非二边因果。此之二句及两双非故云此四。故前从如实知灭度者。约如理所离。次二句者。共显中体。后之二句约能见说。若双非等者。此之四句并成双非。此双非言若彼结之。即成遍句。其言虽显恐与权教双非相滥。是故重释双非结句。若属一边并在权教。例如下出结句相。以余结句结今双非。令成偏句则非圆实。故历诸句次第结之。结初句云非生非死等者。以生为生死边。以死为涅槃边。是生是死乃是双照。若结为生成生死边。非生非死乃是双非。若结为死但成涅槃。退出亦然。下二准此。若雨结已复更双非方显中道。故云今皆非之。今经中直尔双非显中。不偏结句故唯圆极。如此之流者。此例尚多即乃至已下文是。如单复具足处处虽有双非之言。以句结之各有所属。故一切见唯结成有。二乘诸句唯结成无。此有此无但成别俗。非此有无秖成别中。今明圆理故须细辩。经云如来如实知见。傥以二乘等释。则有毁佛之辜。然此结句唯在一家。判诸经论一切句法。以辩文义宗趣不同。净名疏中因释迦旃延章。旃延但云苦义空义无我等义。义在三藏。净名结成通义。呵云。空无所起是苦义等。当知空无所起是无苦无乐。但结归于苦。既云无起。复云是苦。故但成通。若云空无所起双非空有结成乐义。即成别意。别以出假为乐故也。若更双非别教苦乐。方成实中。如是广出。况复单复具足亦遍诸教。如四教四门。门门四门门门四悉。一一悉中复有四悉。即成门悉各有具足。故别具足更须非之。圆门起见尚堕有句。安得更成复具等耶故知若见非见若门若悉。皆须以法方能定句。终无以句能定法体。故释义者。不观句下法体所归。如何能辩法句浅深。如何能消今经双非。若以法定随举一句。即成实理。不如下释第五句不如三界者。如者同也。不同余人见于三界述佛见也。佛必权实二智具足。必不同彼二种三界所见二边因果之因。不如二种至之相者。秖是二死及以五住。应知三界名通通界内外。若界外立三界名者。以外准内故也。中理未穷通名见惑。通三界也变易土中胜妙五尘名欲界思。不思议法尘名上界思。净名疏中委出其相。次唯佛一人下释第六句。如斯已下文也。既总云如斯。览前所照通成一见。故皆重牒前五实句。共明权实二智之相。故前实智唯照实境。今加权智随物见权。明非见而见等。即二智不二。故云如众生见示二死身随他意等。次文牒前初句如实知见三界之相等虽如实见亦于众生见处而见。具五眼故。如实知见下。牒前无有生死等。次亦无下牒前亦无在世等。次无实下牒前非实等。次无三世下。牒前非如等。次同于下牒前不如三界等。皆以如来明见以为权智。一一释之。如来下牒前不如三界已下文也。如来虽即自如实见。物机不同所见各别。故佛亦以随类而见而垂应之。以诸下明机感中。初明机相即四悉机。欲令下明应相以逗四机。一一悉中能所皆足。自为四别。既云种种故对渐顿以释。所以玄文中十门解释。一一门中具足诸教。此依圆教消经而已。性即为人者。先正释。次释疑。初正释中凡言为人。所为必拟生其宿善。宿善不改今方可生。故性属生善。次习欲下释疑者。先立疑。释云下释。释中先正释。次举例三性欲下结同。如因下举例者。如大经云。善男子。一切众生身与烦恼俱无先后。虽无先后要因烦恼。而得有身。终不因身而有烦恼。性欲亦然虽无先后。必因习欲方乃成性。结同者。今虽性前欲后。终须欲义居先故云习欲成性。世界名欲此准禅经。具如止观第一云。禅经从因故云乐欲。大论从果故云世界。次释行中。善生恶灭俱得名行。故于行中以分二悉。广如玄文料简。行起宿善治破现恶(云云)。次释忆想中更为四。初得名所以。明第一义而通于初。且以相似解起。对治粗惑未入真道。慧名为想。次渐顿众生下。明四悉次第。由三悉故第一义来。于诸内外凡位亦得名第一义也。但想慧名须在因位。如五品前修行五悔。初入随喜。尚乃得名为第一义。况入内凡位耶。又随喜前获少定心。尚亦得名入第一义。况入初品。三随其下明入真之缘。四乃至下。明忆想通后至金刚心

问。应云初住。何以云地

答。从渐顿来。且寄地位。欲令下至若干因缘譬喻者。此用五佛章中施权之言。皆云种种因缘等。以申今文。本迹俱有渐顿之化。如为懈怠等者。举小对大。如俱舍论释忍位中。始从下忍三十二观。乃至上忍留一行相。入世第一。但所留行二义不同利名见行。钝名爱行。利人又二。着我多者留无我行。着我所者留于空行。钝人又二。着我慢多者留无常行。懈怠多者留于苦行。今文且举钝中二人。复诸论师诸计不同。不能具述。通教中云亦如是者。观门虽巧谛观次第不殊三藏。然约四门四悉二空三假。与藏不同且约大同亦名种种。顿中别圆。虽三十二及入不二种种行类。亦何出于各四门耶。无有虚出至昔虚为实故者。为字去声。禀权出界名为虚出。三乘无不皆出三界。人天无不为出三途。并名为虚。如来本为一实施权。无有毫差而皆入实。寄此四字者。常住不灭也。既其不灭益至未来。旧人下先举旧计。云前过恒沙等者。古师见经中有所成寿命之言。谓为果寿。乃指前文过于尘界。为前过恒沙。以非恒沙可能喻故。乃用世界以之为喻。于今未尽为后倍上数。又古人见复倍之言。便为有限。况复不知是实因寿。而云神通。经中云复。他云后者。章疏之言。从此已后复倍上数。如是并为神通延寿。意言。今虽未尽必有尽时。经举因况果者。明本行菩萨道时。所感因寿尚自未尽。况果寿耶。古人不晓判属无常。故知以不尽之因寿。况不尽之果寿。明因果俱常。古释反令因果无常。云何弃所况等者。彼见能况有所成之言。便为所况之果。但经文中前已明果。何重言之。言纵令者指初住位分得常寿。岂有初住真变易寿。便同分段有无常耶。若言尽者。何当尽耶。何名分常分但对佛及以后地。准行证文自应知之。譬如下举太子禄以为况者。犹是分况。对□人财言不尽耳。捩字(里结切)谓抝捩也。抝字(鸟饱切)不顺之貌。谓弃于常而取无常

法华文句记卷第九(下)法华文句记卷第十(上)

        唐天台沙门湛然述

    释寿量品之余

迹中唱灭通约三身。又二。初总立。如净名下释。释中初明三身非灭唱灭。次明三身常住不灭。三明三身不生不灭。以不灭故唱灭非灭。以不生不灭故名为非灭。总而言之显于不灭。初文自三。初明法身为六。初借净名文以立义者

问。此中法身。那引净名迦旃延中通教义耶

答。彼旃延章。总有五句。初之四句名藏义通。后之一句名通四教。义局衍门。结归之文既通圆别。故前四句现结成通。不关圆别。彼之一句虽结成通。仍通圆别。今从通义故得成圆。若得此意诸句可明。故略引之。法本不生故无可灭。是寂灭义。云唱灭者。此唱寂灭。是灭生之灭非即生之灭。即生之灭是不灭故。当知此灭名为不灭。法身常住无灭不灭。今言寂灭义当唱灭。何者下释唱灭意。为不了者而云寂灭。若了寂灭还指于生。若全指于生于懈怠者。无利故须唱灭。三若言下。以璎珞中寂照帖释。然彼经中以照寂为等觉。以寂照为妙觉。彼约别教教道。以说故。分二句以对二位。今借别教极果之名。以通初后而释圆教不灭而灭。四夫法身下。释唱灭义。由唱灭故智生惑灭。此约事理相对论也。若迷心等者。一往观语似同报身。其意则别。此中正明所灭之惑为法身体。体有生灭良由于智。故寄能显以彰所显。五灭惑下。次判圆别。别教尚属无常之灭。以十住中同于小乘。灭三界惑方生出假俗智之解。入中亦然。今约圆教故唱寂灭。此之等者。虽别圆不同并名生灭。虽俱生灭悉约理性。六若无等者。明唱灭之缘。意云。从迷从解故云迷解。克论但以解为唱缘。别圆俱是从迷生解故也。次约报身亦六。先标。次谁有下。正释惑智本无生灭。以为报身无生灭体。三此总下结报身体。明即是智暗即无明。体性全是故无相除。既无相除。即不灭也。四众生下唱灭之由。五有烦恼下明唱灭之相。所以更互得灭名者。从事故灭。六岂非下结唱灭也。三应身者。亦先标。次应是下明不灭。三但为下明唱灭。次又法身下明三身不灭中。初法身不灭中言当体者。不望余身。以余二身须望法耳。若将体望用。用却成灭。次约报身不灭者为二。先牒前说不灭即是。报称于法。法既不灭报亦不灭。次以理下约事理相对以释。先约理无灭。次就有下约事有灭。从约理边即是不灭。初约理中。云为到故等者。于其惑智四句检责。还约体检惑尚不灭。智体无破。此用大经师子吼难。难言。若毗婆舍那破烦恼者。何故复修奢摩他耶。佛反质云。若言智慧能破烦恼为到故破。为不到能破。若到故破。凡夫能破。若不到破初念应破。若初念不破。后亦不破。若到不到破者。是义不然。如是推求谁有智慧能破烦恼。言共独者。佛言。如一盲人不能见色。虽伴众盲亦不能见。慧定共别准说可知此即报智不能灭惑。次就有智慧等者。复更约事而定判之。智能灭惑智不名灭。三约应身明不灭者。亦望法报。报约于法故前法身但云当体。今此应身利物不断亦是不灭。故云常然应明不绝者。三身相称故也。法报遍故应体亦遍。机自在无应法恒尔。若不尔者。虽释圆常还同生灭。言众生不尽即不灭度者。灭度之时生实未尽。其义何耶。应反质云。验生未尽则不灭度。故唱灭度为不生于难遭想者。非为生尽故知应身常在不灭。何独法耶。若不了者法报亦灭。何独应耶。三明三身不生不灭者。法身同前不当生灭。报身者智自了智无能灭者。智属于能既不生灭。岂能令惑若生若灭。应身者。相续故不生相续故不灭。三身但云不生灭者。不字贯下灭字即不生不灭。逐语便故但云不生灭耳。云云者。释出三身不生灭意。以互融故。此因应身非灭唱灭一句之文。广开三身有灭不灭不生不灭。若不尔者。生灭则定。何名三身不即不离。若得此意遍一代教。但闻一句唱灭之言。即识一切灭不灭义。具身多少灭不灭异。方达本地本不生灭。方达中间今日化道有灭不灭。以本地化中间今日一切迹教。不出三身四句故也。释不灭有损中为二。初释唱由。次以四悉帖释损益。此中且寄应佛以释。由此众生至二善损而不生者。由不唱灭懈怠之徒。真中二善俱不生长。见思已生尚自不断。别惑未生安能令断惑不断。故唯能损于真中二善。已生未生等具如止观第七记中料简。次若依至第一义者。以四悉檀帖释唱灭。是故唱灭有四悉益。由唱灭故善生恶灭。故分四悉以对善恶。第一义灭未生等者。第一义悉能见中道。能破无明。是故无明名未生恶。对治灭已生恶者。凡对治言皆治现恶。世界生未生善者。乐欲在初期心远故。如闻法生喜则细善当生。又世界是阴入阴入若转。法身则显。是故法身名未生善。又乐欲时善根未生。亦由此生名生未生。为人生已生善者。真谛望中名已生善。纵使未生望中乃远从近名已。又世界灭已生恶者。从近更释。但除现计此则可知。对治灭未生者。治道长故。如禅五阴下释向世界。如修禅时为灭欲恶。故色阴起能灭欲阴。以界望界名为世界。故欲界阴名已生恶。准此无色除色。空除三界中灭变易。于当位阴皆名已生。修上灭下名灭已生对治治未文无重释。但治名虽同通至等觉。大经优婆塞众中云。常无常乐无乐等。常乐观察如是诸对治门。既是净无垢称王之所用治故不近也。既约三身论灭不灭。故四悉感应亦须深明。多番释者。良由此也。第二广释中为二。初现灭由。二见闻下通约三身以明损益。初文须唱灭者。有损无益由常在故。前虽明唱由仍未知所以。次通约三身中。初别明损益。即约三佛一一正示。初仍总标。次便谓下初约法身者。法身本无寂灭之名。为上慢者。计如不殊须唱寂灭。具如前释云云。又闻下即约报身。前自谓如此自谓智。二谓俱是大乘上慢。然二上慢不无深浅。谓如乃成大无惭人。谓智犹知须智照惑。以不了故不解即名。凡云即者。以显于离。如冰不离水理须融冰。义同于离方乃显即又言离者为成于即。若不离者众生即佛。何须修道。为不识离直云即者。故须唱灭。等觉一品尚唯佛智之所能断。岂以博地谓即是耶。应身如前后文。次若唱言下。别约报身明益由。又二。初唱。次益。初文先寄法身以辩须智。次经云下举教立妨。次引譬释妨。然明时无暗。验知暗时无明。故以智慧断烦恼暗。汝今下以理责之。当知下结意也。应身可见故略。众生下总于三佛皆生敬者。以报智处中既有智慧。上冥下契。若得见一必具足三。故生恭敬。医有十种者。通收邪正贯彼偏圆。前之三种亦称医者。佛未出时一切外道皆自谓出家。各自领众。故大经云。王之土境清夷闲静。真是出家住止之处。第三医中云差已生者。虽断事惑还堕三途。具如本劫等见各计四禅等。断惑不同故。阿含云。良医有四。一善知病相。二知病因起。三善知方治。四毕竟不发。然此医知病不出界内。知病因起不出依正。方治不逾生灭无常。不发秖是住二涅槃。望今但成第四五医。若以四名义通诸教则一一教随义各别。乃至圆教于理无妨。直引证此深违经旨。尚不能同通教二乘。安譬本门数数生灭。若释大经晓八术者。但对小外对此仍疏。第六医不能治必死者。所证同故。第七别教但地前耳。后之三医初云不能令平复者。但自入未深。未能令他见本法身。无明本有义之如损。令还得见方名为复。第九虽乃得云后心以第八医但在十信。第九理须初住已上至金刚心。第十究竟名过本者。对前名复故此云过。以第九医始从初住终至等觉已名复故。何者。法身本有今令证本。故名为复。若尔妙觉复毕何名为过。以对性得无功用故。故修名过。若尔初住已上亦名分过。何独妙觉。言残惑在且名为复。又让极地究竟名过。又七客医中初二拙度初断乳故。故无巧术三四有术。用而不遍。第三不云二乘人者。所治同故。五六虽遍所益不多。后七等者。对极简小。有术下对因显果。故以三达五眼为八。前六并无以让佛故。故云无耳。五六二客亦分得故。若离八倒为八术者。前四有分。以初二客医亦得无常等故。故云如用辛苦等。故大经中总为六味。苦为酢味无常碱味。无我苦味乐为甜味。我为辛味常为淡味。彼世间中有三种味。谓无常苦无我。烦恼为薪智慧为火。以是因缘成涅槃食。令诸弟子悉皆甘嗜。但无常苦无我三味在小。故云世间。今文云辛恐字误。应云苦酢碱故。有术远来。即七客中唯指第七。以彼经中唯以如来对彼外道为新旧故。故知新医三达五眼具足。能用无常等八。所以先令断乳用无常等。后还服乳方用常等。今从后说但云服乳。若取因人亦可通于第五六客。又通论者。通别菩萨转教声闻。皆能说常。然八术者。经中举譬有八复次治八种病。今此且明八数而已。三达者。三明居极。故得达名。略如止观记。十二至方药者。文方也。理药也。药通行理但且云理。下释色香为三三昧及以三德故也。三三昧行三德理也。无量义云。医王大医王者第八九医通得名王。唯第十医独名大王。多诸下至菩萨之子凡有三者。且置二乘先别指菩萨者通以未发心者为第一二乘。仍摄在第二例中者。以取退大二乘故耳。于菩萨中更为三者。修性三因有离合故。一就一切众生。即大经中未发心名为菩萨是也。虽十心中别对三因。此即性三合成正因

问。何不指善恶心所。共为正因

答。善属发心恶复别属。通则摄别。别不摄通。故知通心与王同时而起。必具三因。但名为正。未有世出世善根故也。准下缘因言微修行。当知随闻一句一弹指善并缘因收。准引证云其中众生悉是吾子。则人天善根仍属正摄。引证缘因云三十子。则二乘善根亦在缘摄。若准今日被开人天亦在缘数。据大隔小二乘非缘。今据退大让得记者入初住位。名为了故。观行相似并入缘收。为让前后以正从旁。故发心已后讫至住前。皆名为缘。且将正因但在十通互入为百。结缘即是会发心者。已有了因。但以十信相入为百数者。通皆得成住前善根。故十信心彼彼相入方得成百。以三乘善根皆成相似。仍收五品并入其中。得记之后显成分真。故使缘正今日闻经。即以十信之百。入于初住为分真百。从佛口生。今日闻教得佛法分。入初住也。此亦有三因至了因佛子者。对前缘正应但云了。又云亦者。前二各三故今亦三。从强受名并束三从一。所以束者。众生无始非不具三。以在迷故从理立名。故理中三皆为迷摄。从缘从了准例可知。还将等者。摄前入后。既摄通入信故摄信入住。改似为真。故亦但百。转冰为水其义可知。修性三因玄文止观俱有此意。唯此文中文相显著。为欲望昔闻经力大。故束性三俱为正因。缘了各合俱名为一。故知诸文约修以说。缘了各三。或但论理性始终具三。如云三道三德三佛性等。具如修性不二门说。九门共成方了此旨。若得此意圆教行理骨目自成。皮肤毛彩出在众典。故知此经是纪定大纲之教。不可以纲目释之。若得此意则一家教旨。大理可通。欲习观门修行有地。闻众怪说情虑坦然。睹诸权经投心不谬。融通名相豁矣。无疑法数增减离合可见。与夺他释令归大途。以前三教无此事故。宛转于地者。望出世法故且云地譬上形益者。文中阙略。应云上有二。先非生现生。次非灭现灭。生中分二。言受邪师等者。但非出世皆名为邪。自迹中相遇已后便信邪外。以信邪厚薄不同。致有失与不失。并云失三乘者。以迹中相遇施化不同。具如迹中大小二初成熟咸一。不失心者。唱生而成熟之。失心者。唱灭付待后期。故唱生灭非实生灭。善强下重释唱生。唱灭之缘。言强弱者。于未断间去宿种遥。现难发者名恶强耳。善强准此。遥见者者。障已五分故与佛五分成遥。譬上声益中。云二谛者。应云三谛。二通三别且舍别从通。即顿中二谛也。譬劝诫者。如三周中大拟宜也。药草名通好义不局。故使渐顿俱名经方。无非好等。从佛出修多罗者。准五味相生云从十二部出修多罗乃至涅槃。从人从时相生以说。应知五味并从佛出。今置顿从渐故也。色香等者。渐顿通皆具戒定慧。戒粗定细香不可见。香可遥知味到方知。如慧到理方名为得。此戒定慧即八正道者。语业命戒也。正定定也。余者慧也。今文从别且属无作。文虽且别其义则通。既是药草之色香。药草既通色香宁局。今云见佛性。及对三德者。从初而说。初被顿故意在一实。但三德之名尚通外计。况偏小耶。具如止观大小六义及以圆三。说三乘空等者。次举渐中所服之法。虽具戒等及以三德。必假空等方能行故。故一一三昧具戒定慧故。顿中戒等于渐中机。如药未捣不任服用。虽捣未筛如着空相。虽筛未合犹计所作。故三具足服可治疾。空假中三准此可知。虽被渐顿本在实乘。具如止观释道品后圆三空中具一切法。即其事也。故举共别二相以摄顿渐。次第一心准例可识。拟宜等者。经云当设方便。当即拟也。留经教者。如付法藏。或取涅槃中等者。他云。或取大声或用神通等如佛涅槃后金棺自游出入四门等。令一切人知佛已灭。舍利经卷意亦如然。虽众释不同非无一理。终不及以四依为使。如鞠多者。鞠多是灭后四依。具如止观第五记。如遗教下明佛灭后得度不同。正在当来还见释迦。亦有等者。非独释迦。故引普贤观经见多宝等。因忏所见与值何殊。其父闻子得差者。得差之言不全惑断。但有三乘机及堪会者。不论断与不断皆名得差。常在灵山为报土者。若准余国指有余土者。报土须指他受用也。据常在之言。即属自受用土。若准颂文宝庄严言。则非自土即本时他也。如华严中多明他受用耳。即上余国义也者。指上我于余国文也。此且指于报土之外。通则亦遍十方若净若秽。诸有修功德等者。即指缘了具足者也。经云则皆见我身实报土也。经云或时为此众等者。亦初地初住也。经云久乃见佛者。即指五浊重者。经云我智力如是。总结大势力也

    释分别功德品

此品具有授记领解流通。分别属记。从初以说故云分别。二世者。地踊过去灵山现在。言功德者出所判也。此文等者。若据闻经功德。但属余残。今准当得之言。复同授记。论法力有五。五中引前三文。证今品意。余二旁来。法者。由法而成名为法力证者。六百八十万亿乃至一生。信者八世界也。供养者。说是菩萨得大法利时。于虚空中雨天华等。乃至读诵持等非不是行。且以真因法成名为法力。释增道损生。光宅意以从初至中千明行进。为功德门。八生至一生约损生为智慧门。八界为外凡未有进损。夫授记下光宅释出向来三意。于中先总以通别判之。通在因果总名授记。故通取三文。发心因也。克终果也。故发心等通皆克果。次下八界下释出三意次第。所以回经文者。从浅至深故尔。即外凡入内凡为发心门。次从内凡入初地以至六地。为增道门。从小千去为损生门。损生门中乃以七地已上至第十地。位位各断上下二品。等觉一品合为九品。即以八生对前八品。次法华论者。论云。弥勒品中四种门。一证。二信。三供养。并在今品。四闻法指随喜品。初文具如今文。次信者八世界等。今谓论前深后浅等者。今家评之。论以无生忍为初地。八生至一生为地前。故云前深后浅。光宅亦以初地为无生忍。但以八生乃至一生为金刚心。为异故成前浅后深。二家相违自古不判。夫无生下今师欲释先历四教定其位次。方知二释并不称经。故结云皆圣教明文不可参滥。光宅未当信不在疑。论主天亲岂应徒尔。但恐译者曲会私情。如摄论识分八九。及婆沙一十六字。并进退在人何关圣旨。况光宅释直尔云地。不判教相。虽分惑品义无所归。又净名下至通途之意不可定用者。须废通从别。不可以无等等有无生之义。释今无生。以今无生定在初住。不可见金刚顶有伏忍之名。判为八界。以伏位定在住前故也。故通途之名不可别对。今于无生已去。明增损门。不可分隔。应知增道非无损生。损生定有增道。安可分于六地前后二文定耶。复不可以无生在初地去。况将八生去却向地前。故知二家并失经之大旨。从即光宅去。将今家所用而判光宅。以属三义。地前三初地成别。初地至六地成通。七地已上成别接通。通不断无明故非通。别教初地即断无明。故非别。故至七地无明者许属别接。仍须正云九品别惑。故被接者上根七地。即破一品二品。况复无文品分上下。义涉三文故云游漾。初云光宅以发心为内凡三十者。已如前列。前云住三十心。今云为者。为秖是作。秖是内凡作初地耳。余二意可见。论文既以地前地上相对。则一向专判别义。今分三者。秖合有二。加经家叙耳。佛语圆妙者。指本迹二门故得道实。故上文下释本迹二门也。故仁王十善菩萨者。此明十信。信信通皆具足十善。非谓专以人天不杀盗等。用对十信。既云长别三界苦轮。诸经信位。有云长别三界苦海者。不可将判住行向位。当知须是断惑十信。自非今家准法华文。判以法师功德六根互用。为十信位而为内凡。于十信前以分别功德末如来灭后已下文。立五品位为外凡。宁判十信断三界苦。仁王经意何由可消。若不然者。如何可判华严初住为圣位耶。若判华严十梵行文。以十信心功齐极位。复成太过。初住属圣十信如何非内凡耶。此与地前伏惑初地见道永不相关。是故今以圆意消文。各更引经而为证据。故六即判位理不可亡。十行不思议假。且对闻持。乐说及旋对位释之。使与位相应。若论去对破光宅及以论文。初双标二门。不如下破。但破损生门耳。亦应更破二家增道。何者。论以地前为损生。则无增道。光宅以七地已上。为损生安得无增道。况光宅但云八品损生。语因而失果。论家但在分段。则俱失界外变易因果。从但约下即是今意。但约智断相对以明增损。约法身下释向增损。月喻准知。故他不了见有减生之言。判为损生。见有闻持等言。判属增道。故今但从破无明去。每一位中皆一增损。故云不同。言八番者。且寄从八生说之。以破古计。具足应从无生已去。言世及念等以跨多位及以八位不可即云四十二念等。故寄后位谭之。经文虽略据位必八。文中一往虽从地判。然超越人增损无定。故云八世等。具足应如文中属对。此则正破因生果生。今文处处不违论文。唯留余残修多罗半品入正。及此授记一向不用故知凡有去取。并不徒然。然诸论文无生忍文多在初地。唯华严起信彰灼明文十住八相。言数倍者。非谓一倍。一往语耳。捃拾指涅槃文。涅槃自指八千声闻于法华中得授记莂。如秋收冬藏更无所作。故知大获须在法华。故大经中得道众者。如梵行品末云。摩伽国无量人发菩提心。至陈如品末。十千菩萨得一生实相。五万菩萨二生法界。二万五千菩萨得毕竟智。三万五千菩萨悟第一义。四万五千菩萨得虚空三昧。五万五千菩萨得不退忍。亦名法忍。六万五千菩萨得陀罗尼。七万五千菩萨得师子吼三昧。八万五千菩萨得平等三昧。发菩提心及二乘心。各云无量恒沙。二万亿人现转女身。前八节文始自一生终至平等。并非地前。虽深虽多。若比今经四天下尘及大千尘。盖不足言。今经正宗三周及以本门得益。并不与诸经同也。况流通中自药王下六品。品品之中皆有结得道者。皆过八万。劝发品中大千界尘人。具普贤道。故知捃拾今经之余。虽然尔前诸味之权文。为今经之方便。尔后涅槃捃拾此机。乃至扶律明一乘常住。得此经旨一毫行一句法。无非法界。十方佛法起平等见。而常分别诸佛化仪。方称斯经一乘之旨。应思我等为何所依方称此经弘宣之相。上迹门菩萨等者。准上开章此中正当领解段也。前分别门即是第二授记段也。所以迹门虽记二乘。佛旨未周收机未尽。故诸菩萨未陈领解。今以供养而表领解。故迹门中诸天领解。亦申供养。诸声闻人久修自行。但直领解而无供养。闻本门已与诸菩萨。同申供养重表领解。以闻本后薄修行愿。俱成菩萨同献供养。随其位行以供表之。故云次第及番番等。别立品目。是故文中以陈供养。作所表释。南师从此为流通者。意以四信信解功德。亦属流通。不须必到灭后五品。文殊等者。如迹门后文殊入海教化通经。岂必在于佛灭后耶。故进退二途并可承用。准此文意。三周之后文殊方始入海教化。义亦未失。但菩萨事迹不可思议。勿以凡情而商度之。已如前说。况准迹门无领记后犹属正者。故依南方初品果者。且以五品对于相似一往说耳。分果远果仍须指后。如上说者指授记文。云何四信者。问意两兼。一问云何但立四数。二问云何四俱名信。略解去释也。四人通名为信。则二义俱成。摄五成四不须至五。又名从初得故俱名信。略解三人者。去通从别则受别名。广及观成必有略故。故略通三人唯除初信。初无解故。广说二人除略解者。广局第三不通前二。观成一人复除广解不通余三。除信一事余不通四。唯信解四名为四信。若一念信解未有下三。乃是初信最局。略具初信广具初二观必具三。故后渐宽。但后后者胜于前前。故成后局。一念信解者。即是本门立行之首。故文稍委。于中分十令文可见。初总标其大纲。次谓随下明信解之力。三又信下明信解相状。四亦是下以事释成。五无所有下以三谛意结。六如门下举譬。七举六根合譬。八无疑下释名。九若坐下加行。十如是下判位。欲令文旨可见。且分为十。总而言之秖是信成。初总标可见。次文者。闻于长远开通无碍。信一切法皆是佛法。又信如来化功长远。是人能知本迹妙理是佛本证。若但秖信事中远寿。何能令此诸菩萨等增道损生至于极位。故信解本地难思境智。信心初转自在无碍。方名为力。尚能增进以至一生。况信力耶。挂者。户卦切碍也。亦作诖相状者。自晓己心应此相者。方曰信成。释成者。谓能达九界非道。纯佛法界妙道之用。结者。能信所信若本若迹无非三谛。举譬。[巾*畫]　呼陌切快也

从中裂帛声耳。合譬者。因于闻寿通达一切。凡有所对无非佛法。释名可知加行者令信增进。前是信行此是法行。二行虽殊所信不二。判位者。显观境弥深实位弥丁。答意者。五得般若名波罗蜜。何故除之仍得复名波罗蜜。此翻度岸。若得般若方云度耳。问中先答。次结示。先答意者。如别教人各自于五。而尽其边亦得名度。故且以次第之五。为校量本。然般若名通此中则局故以本门正慧校此第权五。故今般若即是深信解相为能校量

问。次第中自有般若。还同所校何以除之

答。竖中空假般若可为所校。中证不殊名等体等。故阙之耳。言戒施边者。边谓边表。期心出假名为尽边。故十向后心名假边际。第三位行不退者。文判四信得十信。故初信至七信为位不退。八信已去为行不退七心不退者。即是别教七住。见思俱除名位不退。故举信位望住为下。今云初住惑恐字误应云初信。故文云圆顺信解自内而熏等也。或恐剩字。有本无此住字但云初心。若以五品在十信前故圆初信即不退也。有人云。闻长远寿即是般若。不可般若还校般若。今问。六度之中那得有长寿般若。是故应知于信心中。信于本地圆门妙智。尚不与迹门圆观六根位同。岂与别教五度同耶。况复藏通六度行耶。尚不与三教第六度同。况与前三前五度同。大品云有菩萨等者。意明别教菩萨退但有魔不退无魔。圆教初心魔不得便。况不退位。若初住去分破八魔。故得云无。以能即魔为法界故。唱楞严名魔尚被缚。况修观者。况自证者魔能退耶。当知圆人五品之初魔已远避。经云愿我于未来等者。既云起誓。但是闻寿愿当同之

问。近成者无长可说。何得皆言亦如是耶

答。言如是者。谓说常寿。若得常寿尽未来世必当过此。何但如是。今从实成来故且举尔许。具在玄文过减不同。经云深心等者。此于本地圆门仍具五法。方乃断疑。一者闻远生信。二者深心。三者直心。四者多闻心。五者为他说。有人。于此广引诸文以释多闻。于此非要。何者。先闻远本。次入深心及以直心。生于多闻。方是此中多闻义也。深谓穷理不二。直谓始终一揆。以此而观一一句义无非多闻。第四观成中云想成相起者。理具此相依理起想故此想成便见此相。从初习观但得想名。观行浅故仍顺想故又顺理故理相乃现。余教修观观违于理。纵有气分不顺中理。方便观成尚犹名想。况未成耶。又见此相虽未真证。以观力故暂见二土。若三惑分灭方永与相应。乃不名想。准前释四悉中。等觉第一义尚通名想。有余土大小共者。藏通二乘断通惑者。仍本为名准彼而见。纯诸菩萨为报土者。亦他受用。但依此想渐深渐成。入初住位任运遍见。应用无方

问。称理起想。何须土想。但观一念妙理即足

答。二教初心皆灭阴入。况复土耶。别教初心亦且破阴后心能见帝网之土。唯圆即观一念三千三谛具足。是则一心一切心。一身一切身。一土一切土。一念俱观若身心土若空假中。更无前后。故观成时一心见一切心。一身见一切身。一土见一切土。十方诸佛身中现故。故于自心常寂光中。遍见十方一切身土。若唯观他遮那之土。必迷自境。若了心境自即他故。他即自故。不了此境自尚成他。况观他耶。观土既尔。身佛心然。故闻长寿须了宗旨。故知想名名同体异。故本门闻寿益倍余经。良由所闻异常故也。次释灭后五品中。初云后随喜品校量初品者。此是深见。作法师往名在三不在五者。师从利他故除初二。准法师品读诵亦得通名法师。但此中文意且资理是故尔耳。指经文至不须安生身舍利者。大教所诠是法身实相。经所住处中有法身舍利。复是起塔。经文能诠如塔能盛故也。问若尔。等者。若不须事塔及色身骨。亦应不须持事戒。乃至不须供养事僧耶。答意者有二。一违问答。即指初品未能入事。故且依理以为舍利。以经为塔。次顺问答。即能持得初二篇也。若尔。此亦但成违问答也。何者。持初二篇但成初二品耳。故不应以能持下篇三品为难。诸修圆行者请观斯文。若初二品人初心念念常在四种三昧。容于下三众法少违。至下三品止作二持众别两行纤毫不犯。具如止观持戒清净中。尚事理双美方堪向道。况入道者令事亏耶。若未专于四种三昧。五篇七聚菩萨重轻不可微犯。方称一期教门大旨。何以故。出家菩萨具足坚持毗尼篇聚。大乘教意一切皆然。但护篇聚于彼梵网八万律仪。未为持相。但此土器劣且以小检助成大仪。仍晓开遮轻重缘体制缘渐顿舍义有无。坐次分流忏法天隔。复有七众同否大小共别。方于自行量己品位。去取适时。或慕大节而昧存亡。有据小文而迷观道。若得今意先以理教定。次以位行验。若不尔者。鸟鼠人也。安论品位乎。敬请受佛遗言少分恭禀。经阿提目多伽。有人云。此云龙舐华。其草形如大麻。赤华青叶。子堪为油亦堪为香。已趣道场至处也者。既对行近并通浅深。故亦可为观行行近。第五品齐第四信者。以初二品当初信解。第三品当第二信。故二处判三慧。将二信及此三品共在闻慧位也

问。何故现在唯四信灭后立五品

答。其义既齐四五无别。但是灭后加读诵位。为第二品耳

法华文句记卷第十(上)法华文句记卷第十(中)

        唐天台沙门湛然述

    释随喜功德品

释品题中。四重结名。亦四悉意但不次第。理须消释使义相当。然下诸品并是流通本迹二门。所以此中虽于对治中双消二意。义亦通于余之三悉。以随喜品文既校量灭后五品之初。义当现在四信之首。并由闻长寿增益品秩。故须双述今昔二门。下法师功德品。正当现在四信之位及随喜后位。所以不复双存两释。由分别中及随喜中已具释竟。又是称扬五种法师功用。能入六根同于现在四信之位。不轻已下既总云法华。岂独在迹

若尔。尔前诸文亦云法华。亦应具二

答。后未说故。初世界中文先略释名。次广释。三总结。以初贯后故先释名。初文先随次喜。初释随中事理秖是权实异名了此权实即非权实故。无二无别即随顺开权显实之事理也。次广释释喜中言己人者。还是迹中事理之力。理有事故。故能庆人。事有理故。故能自庆。又不二而二。故庆己他。二而不二故了非己他。次闻深下再释中。亦先释随具权实功德。次庆己有智慧下。又再释喜具悲智功德。虽曰庆己正为利他。虽曰庆人正为显己。故云有智及有慈悲。以自闻经复能教他。故悲智具足方乃名喜。况闻经之始行愿俱时。故一句一偈自他俱益。今此初心专立自行。亦以愿力而庆彼耳。权实下结前两意共立品名。权实结随智断结喜。慈悲即化他。化他属解脱。解脱即属断。且以自他事理庆喜故属世界。又顺理下对治中约本门者。亦先释次结品。初释中先随次喜。随中先正释。次即广下结成观相。融通事理。三结成。初文先理。次事。先理者。若信长远。信必依理。理与迹中妙理不殊。但指在久本功归实证。理深时远故云深远。言信顺者。于理闻久岂敢窃疑。故无一毫疑于久理。次顺事者。秖是如来自从本成利物之相。迹中但有横论化仪。本中须加久远竖相。故以化久为竖。化广为横。中间节节遍十方故。该亘秖是横竖遍耳。观相者。非理无以能化。非化无以显理。即施迹近事见远本理。亦是本迹虽殊不思议一。虽一而本迹宛然。故云不二而二

问。别与二同异云何

答。有二。通约本迹别对多境。以本迹中各有不同之相故也。次虽二下却覆收入。若本若迹。皆以三千方显称理之妙事也。三如此下结者。秖是收束向来事理不二而二等。同名一随。如来下释喜。先寄时约人以斥迹权。故四十余年及七方便。非至今经不会方便。无以显本。望彼不闻故庆我得闻。次庆我下正释喜。三以凡夫心下。明喜心相。由闻故知因知生见。唯佛知佛久远之寿。唯佛见佛久证实理。闻佛闻显与佛不殊。入观行位。如此下结观相。亦是横竖不二意也。究竟法界义通横竖。应云深广。但是言略。广无涯等者。通叹横竖。无可与彼无等同者。故重云无等等。亦应结云是名为喜。文无者略。佛今下结成品名。除事理疑故名对治。第五十人下释为人中四。初重牒人相即是牒位。次初但有下牒随。次但有下牒喜。三未有下双牒随喜叙意校量。四谁闻下结劝也于校量中又三。初明行薄。随中但理未有权用。喜中但己未能益他。次所获下双明随喜功大。三如来下正引经校量。即举下文四百万亿。故云巧喻。喻第五十人。是故况云何况最初。此是初品故云何况第五品耶。此是圆位之始故。云何况后心。后心者。指极位也。四结劝中二。初引经意以劝。如来下结经劝意以立品名。令进理入位。能生理善即为人也。景者大也。亦慕也。上来下第一义中上来。即指法师至持品及分别功德中四信五品。时众下恐人谬解者。不测初心功德之大。而推功上位蔑此初心。故今示彼行浅功深。以显经力。忽闻下举好坚迦陵以譬初心。圣言亲赞使推功疑除。故举释然以拟第一义。好坚迦陵具如止观第一第七记。希有下结成立品。外道下约教展转比决。先斥外道诸偏小等。小虽居极。未及随喜圆位初初。别人知中。言门拙者。以于地前闻但中名。未即观故。佛今举阿等者。正明圆位。初后不二故诸教所无

问。初阿在初住何以证初品

答。名别义通。若以此对四十二位则不可通初。若对六即理即尚是。况复初品。今从圆行以明不二。故通用之。问答中先问可见。答中此法者。展转闻法故。彼人者。大品云。若声闻人能发心者。我亦随喜。亦应更问。彼兼此独云何得同。答不从所兼不共不别。恐混名同辩别故来。况彼是引进之语。此判初心实功。故彼无发心之理。此明随理已成。是故名同其事永别。前品以校量四人者。分别功德品末于后四人。经文节节自校量讫。唯初品文未有校量。故生此品。故前品末疏云。今具列五品校量四品。后随喜品校量初品。乘机者。由佛知机隐之未说。故使弥勒乘机扣佛。广校初文方知后四功大。时众益广故曰乘机。南方者。江南也。言胜劣平者。意谓后后渐胜为胜。后后相似为平。后后渐弱为劣。乃以渐劣况出平胜。劣中最后第五十人功德尚多。况平况胜至第五十耶。文虽未破理不全然。但依渐劣以后况初。何用平胜。平乃初后相似。胜又后胜于前。并非校量之限。今正解者。以因古人非五十位解。伤文失理故今助之。暂寄教门以立人数。但约六众不列式叉者。亦一往对数且暂除之。岂有式叉不闻经耶。意亦不必从于有门。以大比丘而为初会中人。此中虽复累人及门并行至四十八。意明教教及一一人随从一门一行。皆可从于法会人闻。所以二解者。初约三教义当昔教有五十人至今闻圆。二者至今复成五十。即是闻经皆被开显。全成四人。故圆举数无可以辩。且寄数法以一七而止。如七世等七中从大故四十九。皆是师弟等者。展转教故。言最后一人无教他者。且约一期校量为言。言大七等者。此方数法黄帝所立。有二不同。下数十万为亿。上数亿亿为亿。七数亦然。故以七七而为大七。于小乃成四十九也。并最后人即成五十。此亦一往合其数耳。正义如前破古师中。今谓不尔已下文是。经四生者。有人于此广约俱舍婆沙及诸经论。出四生义章。非今文要。但可略知六趣。略如第一卷及止观第一记。四生者。谓胎卵湿化。又显识论中又立四生。一触生者。因交会故。二嗅生者。雄有欲心嗅雌者根门。即便有孕。三沙生者。如雌雀以欲心坋沙。因即有孕。四者声生。如雌孔雀以欲心故闻雄者鸣。便即有孕。此四但摄胎卵二生。湿化但染香处不须此相。与世间乐拔果苦者。且与四事及以七宝。故云世乐。令果身安故云拔果。令得罗汉故云拔生死苦。此是梵福者。此人教他令得圣果。自未得圣但名梵福。若得圣果方名为圣。今更广之者。此用大论文也。福中大者莫先于梵。故论释百福庄严相中。以梵福为一福。有此校量。今经令得四果者。亦梵福也。于中复更校量出闻经福。令以众圣福之初用校最后闻经之益。故闻妙经随喜。初心尚过后圣。何况初圣。故知世人目视如意而争求水精。已遇日光而谋灯烛。萨埵大萨埵者。以三菩萨展转相望。一往且以大小言之。故方便极位菩萨犹尚不及第五十人。何况但教他得二乘耶。言圣福者。望上属福故也。然华严中以初住校量。其事仍易今初随喜位校量圣福。自非大圣严旨安能信斯希奇。故知但从事判云此品行旁不轻行正。故此一部无得以旁言之。并是法华之正辙也。此中功德对五十人。章安但直标数而已。不指经文今略对之。每两功德结为一句

  一处及利根　　智慧不喑哑
  口香舌无病　　口无病不垢
  不黑亦不黄　　不疏不缺落
  亦不差不曲　　唇不垂不褰
  不缩不粗涩　　不疮亦不胗
  不缺亦不坏　　不呙亦不厚
  不大及不[利/黑]　　不黑无可恶
  不匾不曲戾　　不黑亦不狭
  不长及不窳　　不曲无不喜
  唇好及好舌　　好牙及好齿
  鼻修及高直　　面圆满眉高
  眉长并额广　　平正人相具
  见佛及闻法

前是相似功德等者。指分别功德品中云灭后五品。大师有时依普贤观。判五品位在六根内。故云相似。若指四信正当相似。此中校量初品。复是第五十八。初法会闻容是初品。第五十八必在随喜位初人也。然品题随喜不的局初。通该五十人也。修行下云云者。广应明行相。此五十德或一人具足。或一人各一。随其功力不可必具。颂中颂前随喜中五。不颂问答。准可知故。颂闻经中少不次第。对之可知

    释法师功德品

先释品名。次释功德增减。即法师之功德也。初释品题中亦约四悉。故下结云。备斯四意。初文世界。次行者下为人。次明识下对治。次似解下第一义。初世界中先指前品。共此释名故法师二字全指前品。亦以五种为法师故。故云如上

问。此品既云是随喜果。法师之名何以指前

答。弟子通初后。法师唯二三义亦兼后二。或全未入品。何者。若以五品入六根中。五师但为六根因耳。纵以五品在六根外。五师不云修于观行。但以诵说名通。且通第二三品。说复该于四五。故且一往似通。若具约位简之。一向未入凡位。以法师名彼品释广。故须指彼以消今名。法师之称既通。不隔四信五品。故指彼文用申品目。功德者下辩异也。初指初品之初。指第五十人。今谓五品之上指此六根。同名功德高下永别。法师之功德故云法师功德。内外庄严等者。两重解之。初正约六根。次又从下更进寄真位。即此相似至初住时普现色身。乃至极位节节皆以初功为本。五相亦然者。入真位时六根皆有内外二严。见闻十界而为外化。余三准知色等亦然。又若以相似普现色身为言。则可通于似位也。次读诵下例余师者。此五法师皆生似解。此且须置真位普现色身。退取似位为今功德。五师五品真似不同。故名世界

问。书写何以净六根耶

答。同资正解。四品加然者。明发不定。始自随喜终至正行。皆发六根。何必过五方入相似。言加然者。以初望后初尚得入。后四加前。相似既尔等者。以分真中根净倍前。以真望似故云倍也。次为人者。应勤思修四种三昧。令速入后信。信信相望故名为倍。次对治中深识圆闻如前校量。名为大势。方能除于执权迹疑。第一义中云似解初初者。依普贤观。随喜已当似解之首。第五十人复在随喜之初。故云初初。过二乘之极极者。罗汉已极无极又极。纵是无疑亦不能及初随喜人。百千万倍。如前校量。指始等者。以随喜始显妙觉终。凡夫发心尚与妙觉毕竟不二。况今五品后望六根耶。六根功德下正释六根功德增减。先略出二家。次总结斥。先光宅中文无别破。所立未当。何者。五种法师各得六根。如何五师共为六千。故一师四百。若有三品。虽成一千二百。那成一师六千功德。况三品人耶。故下结破根不依文。况但言十善是散善耳。此土三根强弱。引大论文全不应此。此文眼鼻身八百耳舌意一千二百。论中眼耳意三用强。故不相当。又有师以光宅数为三品者。今经但有八百千二。如何更立一千。若分六根为三。则二二分对全无此理。诸师下总斥。未会今经六根增减及功德等。不合诸教者。法华之外如下所列。三经一论。何者。六根所对对三千尘。此尘之外见闻四圣。故知经力助内观解发相似分真。普熏诸根。故有如是见闻等用。又有人引俱舍等所辩界内六尘。用释此中六尘。但得片义非文正意。故不用也。且六根中根耳鼻三。不假至者。还依不至可见对眼。可闻对耳。有气对鼻。舌身二根须到了者。依至变现故舌则以变说为功。身则以现像为用。而皆以十界为量。不关小乘根尘对境。故不须云色二十二声八种等。若不尔者。三千本非凡夫肉眼肉耳之所见闻。何故而言见闻三千。若复更释天人等因所惑六尘。弥非今意。大品去。正引三经一论破前两师。次今经下正释。初引经论者。又二。初正引。次略结今经具足以斥。正引中初引大品。明六根般若。岂非分别功德中校量正慧。尘净慧等故无差降。此未云数且言等净。若六根下破前次师。先破。次若一下反征。云云者应更多并。引正法华中。亦先引根等。不论下亦同前破。次引论文意亦明等。经力不应令根胜劣。虽未等者。虽未入地功如入地。次引大经明互用相。既等既互理岂应偏。次正释为四。初明一经之内具前四文。次正解。三若论下辩增减。四相似下判位。次又二。先约弘经方轨明等有一千。次约理境等千二百。初欲正释。更斥光宅。今依安乐行以明三业。正当法师依于弘经方轨。故令获得六根清净。不同光宅直云十善及以五种法师。共为合数。今明数足竟。方云五种法师悉具六千。故今先约安乐行三业十善。次明一界十如。对化他边及衣等三。已有六十方成圆行。此中三业即是六根。故不更对六根。三业功成即六根净。五种下明一一师皆净六根

次复次一心下。约理境以对行中。亦是互用相似位上释也。故云一根通具六尘。若从因释但是观行理具六尘。若论下明增减相。先明增减也。清净牒前般若。庄严中有盈缩等。等庄严者。牒前正经。阙于牒论。秖是凡力等圣明肉眼等耳。若言千二下次辩盈缩。即在今经。秖于向等而论盈缩。若言清净更牒前般若。六根互用。牒前大经。亦可不可思议牒前引论。若偏下结斥。相似下判位中。云四轮者。璎珞经中具列六论今且用四若依五十二位。唯璎珞经始于整足。故今借之以成圆义。但断不断异。铁轮仍在四轮位前。即十信。第三心者恐误。应云第二。信通进别故寄明之。若始末明位。略如菩萨戒疏及玄文位妙止观次位中。具位修观入位行相。今文但明法师功德。故置不云。此下经文六根六章。准华严经六根各十十义。亦与此中文同。但真似别耳。是则五十俱通真似。又五与十但离合异。然小乘不以。鼻舌为通。于意离三未为了说。诸大乘经亦有六通。不云六根者。秖是旁小而复斥小。今经华严方成了义。况复与小修发不同。所依各别。尚不同别况复余耶。初眼根中未论修发真天眼等。直以肉眼能见大千。故云父母所生。若论其用已过天眼。有漏天。眼下无见上。梵王所见虽遍大千。至边乃为风轮所隔。六根净者则不如是。故今应云相似佛眼。乃至相似五眼。故亦应云见于二乘及佛菩萨等。以准耳鼻必合有故。见大千内外为天眼者。且约见于粗细色边。见业因缘为法眼者。以天眼力所不见故。见业见净者。业有差别净无差别。双见二境即表中智。又能圆伏故是佛眼。大经云等者。此是别引肉眼能有佛眼之用。以证父母所生等也。佛眼故下是重牒前破光宅四文。及今所立并略盈缩等文。显成正释。眼根清净是牒前般若。具五是牒前论文。庄严是牒前正经等。亦应云互具五根以牒涅槃。文无者略。下去五根。一一皆尔。但此具竟下去并略。但注云云。或出一两经而已。至下更引无令失意。又下五根一一二释。先约能见闻等。次约所见闻等。故重云也。耳根可见。以于鼻根最委悉故。故于鼻根更辩互用。准例余根亦应如是。但是文略。若舌根中准答问意。亦应须先知味法界。方乃令其味变为美。况六根俱净岂可舌根劣耶。身根中云无谬假也。无著空也。俱照名中。意根中云月四月等。作所表释。以通前五皆不二故。若存事释唯第六根。所以六根所对不须委论。然随喜品校量初品。分别功德直明四信及以五品。今法师功德但明相似六根功德。不轻品中明弘经人现生后报六根清净。神力嘱累果人自明弘经力用。以劝流通。乐王妙音观音明分真人弘经功能。故知但依今经判位自显。余依论判自是一途。下去可见。故随喜品已下。不劳委释物像相貌。但略示文相以显传弘。则流通之功其义自了

    释常不轻菩萨品

此品既前正引昔。当知不轻已有五品。可以证因。后获六根可以证果。故云引证。嘉祥具对今经上诸品文。以为七别。一者以上二品对今为三品功德。随喜下法师中今为上也。二者对上二品为三世功德。随喜现法师当今品过。三者对法师功德明果。今品辩因。四明众生唯一乘故。五者上明佛记今明菩萨。六者上明劝福今明灭罪。七者引事以证六根。言三品者。随喜容下。法师及此俱净六根。岂分中上。况此尚有先谤堕狱。言三世者。随喜乃指佛灭度后。法师现籍五种功成。不轻虽往明现生后。言因果者。俱净六根。岂分二别。言一乘者通于一部。岂唯此耶。唯对分别功德分佛菩萨记。此则可尔。言罪福者。今谤获罪。信者得福。上文生谤岂无罪耶。随喜中与陀罗尼菩萨共生一处。利根智慧岂唯福耶。言灭罪者。生谤堕狱此乃生罪。临终根净岂唯灭罪。法师中报阴现转。何罪不灭。言引事以证六根净者。何不云弘宣一句。必净六根。为章所引不思本文。诸如此例不可具引。故略述之以生发见。故今更以六义说之。于中初一亦望今经前品。余五皆以法华望前。一者上全弘经文。今略弘经意。故不读诵但宣不经。二者小典生信尚未为二因。今经或毁感六根清净。三者诸经但明顺化弘教。此品礼俗逆化通理。四者余经所表权实尚隔。此品表闻莫非四一。五者诸经所表迹尚不周。此品兼表本迹二相。六者诸经上慢永言堕苦。此品即能信伏随从。嘉祥七义非不一见。未有远致。得此中意诸例可从。问为不轻谬有所记。见者悉云皆当作佛。为复末代弘者迷津。法华论云。此菩萨知众生有佛性不敢轻之。二论俱是天亲而立性不同者。岂其相违。但申经文使各得教旨。若令一人著论。则使诸说咸同。不可所释大乘尽用对法小义。故知彼论自申方等。所以迦叶自悲败种。至法华会败种还生。天亲即以其论申之。若弃如来显实之文。而滞菩萨弘权之教。偏执之愆莫大。谬申之过可知。今文品初具足四一。以解贯四。于中先列。次释。释中云法华论等者。论许此菩萨知一切众生悉有佛性。故凡见者皆往礼之。此四众中岂无灭种而妄说之若其有者论文不说则过在天亲。若唯识说正乃过在不轻。及在于佛。而不先责不轻之过。犹却以为弘经之人。岂有误宣误记之失。令现生后净六根耶。正因通亘等者。性德通于迷悟因果。故缘了云种子本有。还约性德以明二因。以对新熏成修得故。此三为因转因成果。果中菩提及以涅槃。名为果性果果性也。若对性辩修。秖是修得缘了至果名为菩提涅槃。了秖是智。智名菩提。缘秖是断。断名涅槃。亦可以性三因至果之时。了名三种菩提。缘名三种涅槃。若云众生具有因果性者。则五佛性皆在众生遍一切处。但住因之日果性名因。在果之时揽因名果。名虽互得其法恒如。初是因缘等者。初内怀不轻之解等五文是也。后是圆教者。约教也。从见实三昧去是也。对偏成四对味则五。以余教中必无众生即佛之言。前既因缘应具四悉。于五文中初二世界。后三余三。具如序中亦以四一而对四悉。云云者。三教对辩今唯在圆。我昔随喜获现生后者。重明来意。故后文云。临欲终时具闻威音王佛说法华经。得六根净更增寿命。即现报也。命终之后复值二千亿佛。同号日月灯明即生报也。以是因缘复值二千亿佛。同号云自在灯王。复值千万亿佛即后报也。于现报中获六根净。是故弘经其功不浅。说此三益意在流通。昔时不轻三报宛尔。今日岂得不流通耶。有人云。欲显安乐行威势无比。我为不轻行安乐行。今谓安乐行者始行弘经。故与不轻其仪十别。何者。彼则安处法座随问为说。此乃远见四众故往礼拜。彼则有所难问。方乃为答。此乃瓦行打掷犹强宣之。彼则常好坐禅在空闲处。此乃不专读诵入众申通。彼则深爱法者不为多说。此乃被虚妄谤仍强称扬。彼则初问云何读说此经。此乃但云流通作佛一句。彼则初修理观观十八空。此乃但怀一句作佛之解。彼则化佛亲说诠虚空身。此乃虚空身说诠于化事。彼则梦中远表当获大果。此乃口宣当得佛因之教。彼则约解髻喻开二乘权。此乃约结缘表一乘之实。彼则以顺化故存于轨仪。此乃以逆化故亡于恒迹。彼则列胜行法以取于人。此乃偏引往人以通胜法。事本本事者。通举往昔威音王佛。为不轻事之本。名为事本。于中别以最初威音佛时不轻之事。故云本事。得正说之宏宗等者。先标两句。名常下释此二句。先释初句。次不轻深敬下释次句。宏宽大也。宗尊高也。本迹二文四一三性。正说大宗不过实相。实相秖是常住佛性。此指宗极之宗。非宗体之宗。一代虽说或兼或带或纯小教。或杂助门或抑或覆。文宽事广。教教不同味味意别。不轻但宣二十四字。有标有释具述因果。因既三性果即三德。况以四一兼益自他。直指二因以为不轻所宣之法。故云宏宗。显实之宗不出四一。四一一一秖是三故。故今还依四一消文。于中先释四一宏宗。次引文判位。三随喜下明随喜意。四敬人下结随喜意。初文中二。先表迹门显实。次表本门开近。前明法师随喜。示佛灭后闻弘经者所说之益。此引过去弘者闻者俱获大功。若弘若闻皆双及本迹。岂独直云作佛而已。故须皆约二门释之。方称不轻所宣。乃会威音所演。可与五品之理合。后得六根而有归。具闻之言全表本迹。况法华之号不专一门。先表迹中云名常不轻是人一等者。应委将文相用消四一。令合此文旨。虽上慢者为之立名。已是菩萨行愿所感。故使铭者冥会其事。从乃至远见表本四一者。只是以远而表于远。乃至不轻自有本地之四一也。故使未堪显本。乃以远住表之。迹中显实尚以迹四。而强毒之。况复本实能即受耶。迹显而本密。故知四一是经宏宗。次引证判位中云不专等者。显不读诵故以不轻为专。而云但礼。以入位之法不独五种法师。或自或他若信若法。或冥或显或广或略。故秖宣一句。功莫大焉。故今文判属随喜位。为六根之亲因。有人云。不专是杂。今谓但显不杂。不专对专。有人问。何故礼俗。今为答之。菩萨化缘法无一准。唯利是务故设斯仪。见众生理与果理等。故礼生礼佛其源不殊。此自行也。欲令众生生慕果愿。果愿者何。我等但理彼尚故礼。况证果理而不尊高。又云。汝等皆行菩萨道当得作佛。岂非击我令修圆因。此约现在顺从者也。亦信行也。亦法行也。夫益有冥显显近冥远。远如胜意现虽不受。声纳于怀。由谤骂之辜。堕于恶道。闻顺从之力。还遇不轻。乃至今日还令会入。以是义故上慢尚成远因。闻信宁无现益。故毁谤者成毒鼓因。广略准知。自行庄严化功归己。自他熏莹故净六根。有人此中引大经中礼知法者。及净名中比丘礼俗。此义不然。涅槃常仪显敬法之志。从彼请益故忘情礼下。净名闻法已获重恩。故忘犯设敬不存恒则。若大乘正义出俗恒则。亦无令道而礼于俗。不轻立行咸异于斯。不为宣通大小非教。有人云。菩萨不作是礼即是有犯。今谓有犯须准科条。梵网无文小乃无制。又云。菩萨于性罪必获。于遮罪有越。今谓于遮必越越名持不。越不名持破非菩萨。忘犯济物贵在物安。若也物安何简遮性。今礼四众济众何辜。故大小二乘咸遮礼俗。礼尚不受济义不成。三随喜下约人约法明随喜意者。必具三因。安乐是总三因是别。故云皆一实相。又云皆有三因。读诵下别释三因。不轻深敬下释流通之妙益句也。于中初正约三四。以示流通。如此下结成。初文者。若得三法弘经之轨。则自他咸济。当知三法虽顺前品。其实即是此品三因。故复亦对四安乐行。四安乐行准前可知。不受四一者。应将骂等委消不受四一之相。本地亦然。文但略对经而已。不轻以大而强下云云者。为唱令闻故也。应释强毒以作当来闻法之相。具如经文后时得益者也。意业净下云云者。应释三业对三力相。复应更对衣座室等。神通室也。说辩座也。善寂衣也。广对一切准此可见。毁者等者。即生随从尚犹堕苦。是则击信毁之二鼓。为生后之两因

问。若因谤堕苦。菩萨何故为作苦因

答。其无善因不谤亦堕。因谤堕恶必由得益。如人倒地还从地起。故以正谤接于邪堕。务当勤习五种行者。五种法师行也。偈文但云初十五行半颂果报。后四行劝持。准此颂文应云不颂双指。唯颂双开双劝二文。初双开中。长行文二。事本本事。今一行半总颂事本。阙劫国等。次颂本事。长行有三。今初一行半颂双标二人。次二行半明得失。初一行半得。次半行失。次半行重明得。次其罪下十行明信毁果报及结会古今。乃至定谓等者。此乃不专判于邪外。佛权实教执皆名著。牛皮等如止观第五记。以着心着无著教。如牛皮等向日加坚。亡失正法犹如损体。故禀方便教者。于外凡位并未免谤。故有不受不轻圆实之言

    释如来神力品

释品名者。如来上寿量品释。神力者。神在于内即体宗也。力名干用即是用也。佛说本迹口轮力用已竟于前。今复身轮现此胜用。令众流通本迹之教。故云体深力大。此字下别明来意。自此下总名来意。初所对众中言一切指他方旧住指本化者。应非四众八部也。故一切者。即从及诸已下文是。十神力者。前五正明现在流通本迹。后五总表未来不已。又前五中初一令众总信本迹。次四即是现在四一。第二表二门理一。智家之境故云智境。第三表二门教畅。即是教一。第四表二门入实。即是人一。第五表二门破惑。即是行一。第六门中既指五千被移失心三类人者。如此三例即是灭后得益之人。所言机者。机义当总。总于未来四一故也。即是得于四一之益。下去四相别表未来四一。文自结名但各述其要。令成一也。所以四但云一不言本迹者。在未来故。尚未入实谁论其本。若见实者亦见其本。故总结云表现表将。将犹当也。初五文中一一皆有迹本流通三相。初文先标。今经下叙前迹说开显。内秘下叙前开迹显本。明三世下明中间用。福德人下初神力意。第二文者先标今神用所表。上白毫下叙于迹门神用表同。境智合故初见一理。今本门下牒向表意。由见远理故使增道损生至于邻极。分身等者。此相既同各于其土。利益亦尔。第三文者。先标名辩意述相。四十余下正述表迹。欲以下明表本意。言具二者。事即本迹付他令通于未来世。第四文者。初标名辩意。随喜下表迹益。随喜圆道下表本益。随喜诸菩萨下表流通益。此一下流通功能。第五文者虽不分本迹。一文兼诸下五可知。结要有四句者。本迹二门各有宗用。二门之体两处不殊。名冠此三而总于三。一部之要岂过于此。故总揽之以成流通。八自在者。如止观记。经中要说等者叙今意也。道场释上甚深事者。事是因果。今道场是果。果必有因。以菩提释藏者。菩提是能契之智。必有所照之境。境即秘藏。以能显所也。以转法轮释一切法者。有所转法。法必有名。以涅槃释力用者。满理释权疑。唱灭释近疑。宗虽近远同名因果。不复别判。阿含者。借小证大。彼则从事今借证理。开小即大故可为证。颂文初颂十神力中。但有五者阙后五也。前五现见逐要存之。前后二五现未异耳。举现例未。是故略之。嘱累下二行总颂四法者。但云嘱累至得边际具含四义。四义皆是无边际故。能持下别颂者。初一偈半中言一切法者。不出能化能证所化故也。无二乘故。不兼带故。其法秘妙。令我下二偈颂神力者。既云欢喜。即是用畅。次一偈颂秘要者。名同易见。于诸法下颂深事者。教化诸菩萨毕竟住一乘。乘是因果。后一偈半颂总结者。总结四法。言若能持持四法也

法华文句记卷第十(中)法华文句记卷第十(下)

        唐天台沙门湛然述

    释嘱累品

释此品先辩他人判品前后。次今文正释。初文者。慈恩安国并令移之于劝发后。若在此中有八相违十不可也。余虽管见颇有禀承。每于听筵忝蒙慈训。垂示救旨深有所凭。近见秀公法华圆镜。广立难势不越先规。今攒旧闻兼资后见。总别救之亦八不可。初总救者。出塔已后凡述多宝。皆云塔中不云见佛。若移在后无出塔处。一不可也。分身散后凡有所述。唯论佛塔不涉分身。若移在后佛无散处。二不可也。嘱累文中佛散土秽。已下经文言不涉净。若移在后无复秽处。三不可也。会本居地因塔升空。佛散出塔后文在地。若移在后无还地处。四不可也。嘱累品后经既未尽。但述众喜不云而去。若移在后须加而去。五不可也。劝发品后无复余文。经既已终则云而去。若移在后须除而去。六不可也。本迹二门佛事既毕。须有所付。是有嘱累。若移在后法无所归。七不可也。嘱累已后明乘乘人。弘经本事事须嘱累。若移在后师弟参杂。八不可也。次别救者。具述元破一一救之。一云众本相违者。准正法华及以隋朝崛多三藏添品法华中。此品并皆在于经末。救曰。正妙二本译人既异。所见各别。若令尽同此不可也。言添品者。准南山内典录云。崛多擅移嘱累着后。崛多既其擅改。法护未可为凭。正本既其居先。添品不名擅改。南山既斥添品。义当二本俱非。何者。罗什生虽龟兹遍游五竺。岂独不见梵本法华。久居长安岂不曾见法护所译。而再译不用者。当知法护非堪指南。若堪指南何不文义咸依正本。若嫌后译文义浇薄。则随朝所译弥薄于前。今依什译理可准凭。故睿公云。梵音错者正之以天竺。秦言谬者正之以字义。不可译者即而书之。岂什公与四子顿尔无识辄。移一品安置经中。若不测旨归应仰之而已。何得以凡见斗尺量度大海虚空耶。二云经论相违者。法华论云。修行力有五。第五护法力中云如普贤劝发品及后品。后品即指嘱累品也。救曰。论亦人译。擅指何疑。况论虽西来。译时既在正法华后。秖是译者顺正法华故。正经在西晋时译。论在后魏时译。如隋笈多见正法华药草喻后有一长行偈颂。及嘱累在后。便以正经添于品内。及移嘱累在劝发后。余无所云。遂使后人云添品法华。故知译者不妨随见。妙正二本同一梵文。乍可信罗什而寝于法护。安得释妙本专以论为凭。秀云。言后品者。是普贤观经。以同是普贤发起令依经修观。又言后品者。既其不出名目。则似经度不尽。若不尔者。何不云及嘱累品但言后耶。此亦是一见。然准天台判为结经。不云在劝发品后。三诸教相违云。一切诸经并在经末。如何此经独在于斯。救曰。例同诸经违妨更甚。即如大品中间有累教品。经末复有嘱累品。不可一切皆两处安。如大宝积四十九会。会会皆有付嘱之文。岂令诸经一切皆尔。如金刚经问名问持。乃在经中不可一切悉令居中。法华开权显本授声闻记。岂令一切悉皆显实。不类之例其数不一。四云二事乖角者。分身若还此土复秽。准妙音被诫故知土秽。嘱累中亦令多宝还归。观音不应施宝分二。分二即多宝未还。遣去既同不应乖角。救曰。秖由未还故宝分二。是故但云一分奉多宝佛塔。而不云奉多宝佛。故知事毕者去。有缘者住。于理何伤。若多宝在分身不合散者。经文但云塔可如故。如故秖是依初还闭。令初身散。即云各还本土。故知虽即令其塔还。听余经故。塔闭而在。如塔未开时。但云多宝于宝塔中出大音声。又云四众闻宝塔中所出音声。大乐说云。于其塔中发是音声。又佛告大乐说。是宝塔中有如来等。故塔未开。大众但云多宝如来于宝塔中。次塔开已。大众皆云见二如来在宝塔中。若塔闭后如药王品末云。多宝如来于宝塔中。妙音至此但上释迦璎珞以申问讯。次方问云。此久灭度多宝如来。在宝塔中来听法不。仍对释迦申彼佛问云。安隐堪忍久住不。当知塔闭住而未去。又云。唯愿世尊示我令见。岂二佛并坐。乃云请见。又多宝佛于宝塔中告妙音言。秖云汝为供养释迦等不云分身。岂分身瞩目而不供养。又妙音欲还但云供养释迦及多宝塔已。不云见佛到彼见净华宿王。但云供养释迦及多宝塔。亦不云见多宝如来及以分身。又文殊来时即云。头面敬礼二世尊足。嘱累之后全无此文。故塔已闭分身已散。若分身在观音施宝。理应供养不应但二五二命不齐者。何故分身多宝二俱唱散。去留不等。若云但令塔闭云如故者。何故正本云还本土。救曰。二命纵同所缘各别。宝塔为听经故来。分身为开塔故集。塔既已闭分身须散。经尚未毕故塔未还。分身既散土合复常。故前文云。为诸佛当来坐故。各净八方。况正法华云可还本土。自是法护所译不正。岂判什本令从正经。若正经为正不应重译但云如故。若欲依正经何不讲正本。遍观正本处处相违。及以妄误前后非一。故不须以正经为准

又问。释迦出塔塔何须闭。塔闭分身何必须散

答。多宝本愿但云以塔听经。若以我身示四众者。令集分身。当知分身开塔故集。释迦亦为开塔住空。住空故开塔。塔开故命坐。嘱累故出塔。出塔故塔闭。塔闭故分身事讫。事讫故须散。故塔开闭分身聚散各有因缘。何须难言二命不齐。六塔无还处者。分身诸佛令去咸归。多宝佛塔迄至经末更无还处。若品在后即唱竟。时还救曰。经毕自还何须求处。至劝发后一切大众作礼而去。作礼虽不通于宝塔。而去遍该一切。多宝本愿听经故来。经若终后何虑不去。但虑塔无归去之文。不忧土无复秽之语。若土后复秽。何得亦无人天来时。七云净秽不同者。妙音被诫复非净土。故知分身久已还国者。分身集日。那令侍者皆诸灵山。信诸山并无而犹有灵鹫。文殊海出亦云灵山忽有华现。故妙音来还依旧诫。救曰。经文炳然而读者不见。经云。移诸天人置于他土。唯留此会众。故知土净为安诸佛。灵山旧众不移可然。准文殊来时。即云指灵鹫山住虚空中。妙音至时不云住虚空中。故知净时处空复秽在地。今分身既散故一切皆秽。而没却复秽之理。苦执灵鹫独秽。妙音被诫具云诫土。不独云山。故云莫轻彼国土等。故文殊妙音二人来时。其理不等。欲令一例此理难齐。八云众喜乖情者。嘱累品令分身还。而塔不去。若非经末云嘱累者。阿修罗等欢喜太早。既非闻法欢喜。乃是见客佛去以生欢慰深可怪也。救曰。至此欢喜而嫌太早。三周之末各有欢喜。更早于此何不怪耶。说寿量竟分别功德中云闻佛寿无量一切皆欢喜。今本迹俱毕复闻随喜事少功多。又闻法师听持深效。又闻不轻能化所化现益后益。明弘经法无定常仪。又见释尊现十神力。授四结要。三摩付嘱三反领受大事功毕。岂得不喜而云太早耶。当知是人讫至经末。亦未欢喜何能弘经令他喜耶。言喜客佛去者。移在后文更加塔去而生欢喜。复弥可怪。验此一切皆以凡情测圣。徒攒笔语举一蔽诸。又云。但是先施神力。故见净土。此土本秽恐妙音见本土秽相。而生讥毁。故佛诫之。非妙音至分身己还。而土唯秽。如虽净土犹见灵山。变不唯净兼见秽故。上见下故。救曰。灵山是佛自留故令大众俱见。如来自云净土。曲释云不唯净。佛言皆令清净。乃云本秽仍在。若言上能见下于净见秽。何不妙音于秽见净。复能见秽。其心净故故佛土净。若犹见于秽则知妙音心不净故。而佛尚诫之。妙音见秽尚生讥毁。岂得名为上能见下耶。下生下想非上人也。尚生讥毁。岂上人耶。次涉法师更加二难。总成十难。故云十不可。先破总叙。次翻二难。先破叙者彼先叙云。什公安嘱累品在神力品后。自是已来皆共信受。并云。移着此中善得经意。若在后者所列诸妨。略如向述。而云以义判文。正应安此。唯我唐代慈恩法师。不许斯义。法师又云。妙音被诫若是秽者。文殊海来何有灵山。秖云唯留此会不云唯留灵山。当知内外俱净。但是仍旧而说。又云。分身即是释迦。若多宝全身亦与一分。释迦分身唯与一分。若受多分者便是释迦长受利养。修六和敬讵应然耶。故但与一分。又云。若嘱累在此如来起立不云更坐。分身佛去不应立送。受观音施不应立受。又云。大众皆喜唯少奉行不应安此。又云。神力去秽未必全除。要若全除并之何处。何处净土容此秽生救曰。正本法华自西晋至唐都不行用。此妙法经后秦译讫。四海盛传天下仰止。况流行之处必藉冥加。冥加已遂安可议耶。况复受持应验无量。普贤尚授以句逗。而不责移品。况复尔后名僧继踵硕学如林。共许嘱累安着此中。岂至唐朝所见乖昔。然此经以常住佛性为咽喉。以一乘妙行为眼目。以再生败种为心腑。以显本远寿为其命而却以唯识灭种死其心。以婆沙菩萨掩其眼。以寿量为释疑断其命。以常住不遍割其喉。以三界八狱为大科。形斯为小。以一乘四德为小义。无可会归。据斯以论诸例可识。言仍旧说者。妙音未曾于此生慢。若土犹净满中诸佛释迦及塔众又在空。神力所现十方通达。何须仍旧枉诫妙音。彼佛现见高下不平。而掩佛智能言土犹净。而言释迦不长受利。顺六和敬者。乃是令圣效凡。若言分身即是释迦。释迦开塔亦即分身。何须更集。若据应迹各别。为是分身恐释迦偏多而不受。为是观音恐诸佛多受而不与。若观音不与乃表观音施偏。何关六和少欲。若分身不受应先施而后让。何故但分为二分耶。故知令分二分表现表当。其义已圆分身已去。其理善成何须此难。若言不应立送分身。及立受施纵品移在后。免斯过者。受观音施容可尚坐。摩顶之际仍立唱散。经后正当立送之咎。徒设谑并嘲调尊仪。于此妙经未成弘赞。若且顺凡情释迦与分身齐肩。坐送便成疏阙。故立送客正当其仪。况立送立受何教所制。云送受不成。又云。已有众喜唯少奉行不合安此。秖缘少奉行故不应在后。又云。何处净土容此秽生者。何不问劫烧担草不同灰烬。毛孔。纳海身不随波。凡此诸释并任己心。不顺经文其例若是。次别破第九第十者。第九佛无就座难云。开塔蒙命释迦入坐。闭塔还出亦宜复座。岂得立说下诸经耶。如涅槃经如来现卧还从卧起。如茶毗时从金棺起上升梵宫。梵宫下已还复本座。此亦应尔何事不然。翻曰。若摩顶已理须复座。若言无文令佛常立者。如文殊答问竟。无入海文。何故至此忽云海来。又云于海常说法华。常说之言应常在海。若本在海序不应列。何得复为弥勒释疑。又说经竟。佛但令众各散。元无更坐之文。佛应立送天龙八部。何但独送多宝分身。立送分身其仪稍顺。立送八部尊卑倍乖。又何不责云诸分身佛但令侍者赍华。以宣问讯。及云彼某甲佛与欲开此宝塔。即云尔时释迦见分身集与欲开塔。不见侍者至会说欲。欲应不成。法师与彼虽则稍亲。党理不党亲古可依也。又何不责。教门皆云达多世世造恶。今忽说为佛师。复云与师记莂。颠倒不可具言。何不责龙女成佛太速。何不责声闻成佛太迟。第十众无命坐。难云。佛处高远众人请接。今既还处地亦应命下敕令复坐。何容久立不赐安居。故知嘱累定居经后。翻曰。凡假他力必须请加。若任自力不求他援。处空非己力所及。故请佛神通还本。任自力所能。故不待佛命。况本缘佛入塔故请在空。今佛从座起岂可安坐。故云益加恭敬曲躬低头。佛既复座说法时众理应复座。无文之论义准应知。又众若不起不坐。应仍在空。何故普门品中无尽意云从座而起。陀罗尼品初药王从座而起故知不可见略却就座等文。移品向后。又品题有嘱累之说。令向后者。品内有嘱累之义。亦应皆移。然嘱累品题虽云嘱累。品内但通云我于无量阿僧祇。修习难得阿耨三菩提法。付嘱汝等故神力品题虽云神力。品内云为嘱累是经故。乃以如来四法嘱累上行等也。故应先移嘱累次移神力着嘱累后。又嘱累品初云。现大神力。神力品内有嘱累之言。是故二品俱移向后。若俱移向后不可两品重张。不可两品前后。若有前后。还失最后。若言经文次第。不轻已后即合劝持。何事以神力而间杂之。宝塔慕觅宣。弘之人。秖应次以持品续之。何得许以调达品间。若其品次不依罗什。理须一切并依正经。今经声闻一万二千。正经但有一千二百。叹声闻德。乃有一十一句。叹菩萨德则有二十八句。与妙经及论复不相关。何不咎论违正法华。而嫌妙经违论。又正经列名之中。云光世音光观声同。便即书之。后代何不依光释义。宝掌菩萨离开为二。更加宝印首也。掌已是手复加头首离为二人。自在天子以大梵冠首。亦云三万天子俱。即是回梵文大梵字不尽。别序中不云说大乘经名无量义。直云说斯经已升座三昧。又阙无量义处三昧。不知尔前为说何经为入何定。何不责妙经增加无量义耶。又放光但云上至三十三天。法护何事抑佛光明。妙经云八百弟子。正经云十八人中。凡云如恒河沙。一切皆云如江河砂。序品既尔。正宗之中错不可数。何不依之而独引嘱累。是故正经并未可依。纵是什公所移。应见梵文深旨。若也漫移何不安余品后。而必着此中。使无如上诸妨。更移着后生诸妨耶。故使流行之处。众圣冥加。次正释品中亦具四悉。初世界中约得名以释品。得名事别即世界。又累者连及也。字应单作后人加口者。意言口嘱。即义立也。言烦尔者。尔汝也。谓累汝后代。如带累也。左传云。相时而动无累后人。此是如来适时而化。示有谦词。又令于三世传法不绝。三世不同亦世界也。次为人者。此是后世宣布生善。次对治者。令后世受者使不失故。治其失恶故名对治。次第一义者。令后代人奉旨入住。入住即证真也。初两字并在能付。次两字皆在所付。三嘱在能付累在所付。次正付嘱中释三摩者。先约所表释。所付不轻须以浅表深。故身口心三付方表殷勤。次约四悉者。即具事理。经言现大神力者。如来向现十种神力。已表当现四一益竟。而今复云现神力者。正表身口心三付故也。从座而起以如来一手。一时遍摩故名为大。有人引大经中内有弟子解甚深义。不为利养不生诤竞。外有清净檀越。佛法久住。若不尔者法不久住。此是彼经最后诫劝道俗弘通。亦捃拾之遗嘱耳。不同今经乃是一期宣畅。他方欲散。现十神力嘱累十方。佛亲摩顶菩萨三受。表法勤勤。佛之智慧等者。取觉照边属一切智见毕竟空。如来智慧为道种智者。即取从因至果得道种名。道种从权。具如第一卷中。悉以能契之行名为权也。于如来室至如是。明三智者。即依座室三各具三智。秖是三一相即。三一互融。故一中具三。以此三事弘经益他。令他各得果地三智之用。故知室若无二弘誓不普。衣若无二法身不满。座若无二惑破不周。如是施主下。结能施意。应云如是施主三法无阙自他不空。是施主故有大慈悲。自既入室令他入室无悭吝故。自既着衣令地着衣。无所畏故。自既坐座。令他坐座。亦可云无悭吝。故施此三法。无所畏故。说此三法。若施若说皆具慈悲。即入室三法也。汝等等者。汝等当学如来。以此三法而流通之。以此三三应施一切。故经云。汝等即是众生之大施主。此明经之功用必具三三。况复所弘三三之法。方名令他得于所弘。世尊敕者。具奉行之。他人于此辩凡夫悭。引成论云。悭有五种。住处护他物称赞法悭。法悭七报。一生生常盲。二生生愚痴。三生怨家中。四受胎或死。五为诸佛怨。六善人远离。七无恶不造。若消此文都不相关。且言如来若以小乘化。我则堕悭贪。劝弘法者舍凡夫悭。此消可尔。若直以此证。令佛同凡。深不可也

    释药王品

释品引观经释名即世界也。此文去。具以今经而成四悉。若推下明得名前后。非四悉意。竭其神力者。用神通力三昧供养也。尽其形命者。用其报法即烧臂也。庶令弟子等者。上人行之令下效故。此则自他二义具足。诸佛下云云者。令述有无。不轻乃至方便品来岂独佛耶。下品亦有佛者。云雷音王佛宝威德上王佛等。况释迦化主始末恒在。况复应以佛身度等。然应须云上品有菩萨佛事为正。下品有佛菩萨事为正。通途论之。从化主说。一切皆以佛为正也。药王至流通义便者。佛嘱累已大事功毕。随物偏好故乘乘不同。真如实相是所乘之体。一乘因果是所乘之事。苦行等是乘乘之缘。随物机宜故使弘者随缘不等。故所乘体皆妙法也。以依一实立因果故。乘于所乘以利物故。故曰乘乘。问为三者。初一利他。次一自行。游化亦苦行。苦行亦利他。已下去文如妙音等。皆不出自他。自行皆不出智断福慧。利他皆不出三昧神通。通问游者。游必具足十法界身。并如妙音观音。但别举苦行以逗所宜。故请答之言意在苦行。有佛声闻者文略。具如经列。有菩萨及菩萨寿等。经即时入是三昧者。普现三昧理无出入。表用三昧之力故云入耳。经以神通力愿者。明不以世火还依所得三昧起利他愿。以智观火焚难思境。故使光明起斯照彼。佛亦以逗物故赞。真法供养等者。先总举能观所观。次及观相。当是之言正显真法。所以烧身名真法者由内观故。所观者何。即此生身。由惑因故惑斯惑果。皆用之言显因果俱荡。又观若身若火等者。于中先明法空。次谁烧下辩生空。初法空者。既即实相实相无烧。身火能所安得有烧有能所耶。次生空者。非但身等皆是实相。身等宰主一切皆无。故名为谁。烧者。能烧火也。然者。所然身也。身火并是能供事也。佛法即是所供田也。宰主即是能观观者。身火能所观境也。境智不二能所斯亡。以不二观观不二境。成不二行会不二空。作是观时苦为法界。见闻者益故曰乘乘。若不尔者。成无益苦行。佛有诚诫实可先思。所以投岩无招外行之论。赴火不为内众之讥。良由内有理观外晓期心。故胜热息善财之疑。尼干生严炽之解。笃论其道行方有克。心正行正智邪事邪。行不可废智不可亡。后学之徒无失法利。有人问云。律制烧身得兰。烧指得吉。此中赞烧其事如何。今为答之。大小开制教法不同。小制结过大制令烧。故梵网中若不烧者。非出家菩萨。岂独令俗而不制道。故知顺小行易不烧何难。从大诚难烧乃不易。世以不持为大则大小俱倾。信此土机缘。咸迷大小。不知先小后大依何夏次。先大后小何心而受。先小后大开小乘遮。不先大后小。遮菩萨开不。一界之内两众如何。一身之中二体同异。大乘于小取益从何。小诵于大招损谁测。勤勤甄别用为来种。所乘之乘皆妙法故。以依一实立因果故。乘其所乘以利物故。但自揣己德历境观心。与心相应当顺开制。今药王久证。并出开制之方。重法亡怀起神通之愿。为轨凡下思之可知。经以旃檀为[卄/積]者。他人疑云。何得旃檀而为[卄/積]耶

答。此土大爱道入涅槃后犹用旃檀阇维。况彼净土何足为难。然净秽并陈非世有也。皆圣力故。经云七万二千岁等者

问。烧身但经千二百岁。烧臂何故时长

答。前为自行身尽入灭。今为弘法令物会三。故云令无数等。既言无数声闻发菩提心。故知喜见于佛灭后。不令此等住于小果。此土亦然。经云金色之身者。前已得普现。即八相金色。故知此中须在极果。能生等者。如父母必以四护护子。今发心由法为生。始终随逐为养。令满极果为成。能应法界为荣。虽四不同以法为本。又此四法即四悉檀。次第对之亦应可见。此即始终对四悉也。然前三教各得四益。今对圆说例上可知

问。初开章云叹能持人。何故向云不如一偈。又云法是佛师等耶

答。前叹有法之人。今叹在人之法。言初叹体。次叹用者。非宗体之体。非宗用之用。通指一部为体。部内体宗用三。共有如是拔与等用。十宝山者。具如止观第五记。引华严经。或一或二者。俱舍云。前七金所成苏迷卢四宝。金或兼余故云一二。诸经说权智等者。权不即实致令教法皆非自在。诸机不融故教主别尔。诸经明实智等者。并是权外之实故破疑不遍尚不及此经说施权意。已破诸疑故云即实而权。况复今经本为显实有疑皆断。故云即权而实。所以权实之语非独今经相即之言出自于此。不收于小是故异也。文云学无学等者。指三教菩萨为发菩萨心者。今经为彼之父能生彼故。昔谓非子至此方知。余经要因功用者。但取发心毕竟不别不同三教要因功用。如别教地前为方便也。如风下云云者。初住已入无功用位。应具简车体及具度等。释如风所以。至入初住无功用道。经云五百岁者。大集经中有五五百。具如前文。经云若有女人等者。此中秖云得闻是经如说修行。即净土因不须更指观经等也

问。如何修行

答。既云如说修行。即依经立行具如分别功德品中直观此土。四土具足。故此佛身即三身也。故此大众即一切众。以惑未断故。故安乐行是同居净土行之气分也。故不离同居秽见同居净

问。同居类多何必极乐

答。教说多故。由物机故。是摄生故。令专注故。宿缘厚故。约多分故。下分兜率其例不同。但在机感

    释妙音菩萨品

此品初具三释。初文因缘。次昔得下约教。次此品下本迹。唯无观心。因缘甚略。且义立者。音乐世界。自随为人。奉钵对治。道器第一义。观音有问得名之由。此中无者。此从自行下从利他。又如常不轻中亦有本事。即名以显本事。始从内解终至利他。同在一名之内。虽自他不同。准观音名下。有普门之名此亦应尔。同得普现色身三昧。若尔。药王下五一切皆然。药王又在献咒之初。净德又指妙音身。是故五品法门定无优劣。但随机便乘乘不同。况普门居中理通上下。以人对法理亦感均。单消其名义亦无舛。不可从名异而蔽其法门。当卑其地去劝成机缘。明普现意。若不以鬼畜为鬼畜。但卑己心之地。则自壅妙法之流。大人相等者为四。先正略释。是不思议相海故名为大。次遍体下寄于所现展转校量。三此相下大小对并。四问答下释疑。初二可见。三对并中二。先寄小表大。故以应迹之相因顺于师长之毫光因果相召照之必来。言本弟子者。照非无缘本曾关涉。名昔为本未必久本。白毫下次明大中实因所感。照之令弘开显之经。此乃因胜果胜。令弘胜教是故放之。释疑中二重问答。初问答能放光疑。次问答所召众疑。初疑意者。约不思议相海。总立用问约事校量。答中云他经所明等者。召他属事宜且从他。故附方便教云有优劣。又约应身现相宜附他经。令弘实教故复从大。大复从因而为所表。故云放光令弘此法。况显本已尚无近迹。岂存小耶。何故召东说西者。问意者。十方菩萨岂皆无缘。何故放光但召东方妙音竟。次说西方观世音。答中从表。于中四。初辩能表。次未发心下正明所表。三一菩萨下举例。四圣不下结用表意。初文三。先明能表之光。次明光所照意。三东是下举能表意。次未发下出所表中。但举始终任运摄照。三举例者。妙意既尔诸来悉然。但以照东表始为便。若召南至北四维准知。圣不繁文。理合十方咸至。如华严大集诸部般若。光及所召尚通十方。故此但以一方为表。准下观音初释尔时。亦以妙音对辩。此中既预以说西对问。故可预以西方对明。云欲说西方菩萨事。先召东方菩萨等。叙福之由者。既值多佛亦是慧由。但是文略。正叙福慧中经云悉。又云甚深。故是圆慧。三昧属定对慧名福。尚异三教岂同世有。又此十六并是法华三昧异名耳。随义说之今称法华三昧之相。佛诫至而规此耳者。肃延进也妙音高位岂可待勖。至此见秽宁生劣想。但佛寄诫妙音而规其所将。规谓规模。夫佛至诸佛道同者。先正叙同次结同。初文自三初云约座为诫者。依空亡相。身是有相理为妙空。一尘之身咸与理等。况丈六之质生劣想耶。次夫师等者。佛及弟子身俱劣者。俱隐寂忍而耐其拙。夫依报等者应住无缘安其秽土。此佛下结同者。一切应身化仪示迹说法之处。皆具此三。诫众而为弘经之轨。故此佛弘经亦敕三意。以例于彼。化仪不出佛身化境国土故也。受旨中三力者。菩萨不无推功化主。如来先诫令菩萨自运。菩萨推者往彼实难。何况往复应须利他。故知往来皆如来力。然又如来加于可加。菩萨有分但未至极。故以极三加于分三。令用弘经宗要衣座室耳。故知皆如来力起于神通。种种庄严方能利物。是则如来以中空故。能以慈悲加诸菩萨。具足庄严故随机利益。言庄严者。因中万行。此会者彼土也。若文殊位下等者。妙音辞彼佛时云及见文殊。岂可远来求见下位。文殊位高见华应识。何以问佛以何因缘等。答中二义。并文殊位高或同是补处。一位之中分始中终。或同是古佛则无高下。同位居始未谢不知。忝者辱也。岂一事不知成屈辱耶。又大众无敢问者。文殊虽高为欲发起示为不知。上品云初得等者。上药王品云。过去名一切众生喜见菩萨。于日月净明德佛法中。得现一切色身三昧。后重生其国。于净德王家。忽然化生。白其父言。我先已得解一切语言陀罗尼。既云转身得一切语言。即似转身方得。若云我先已得。即似指先所得色身三昧。即此三昧亦名语言陀罗尼。故云犹是色法。犹是之言表与前同。故此语言与色身但是身口之异。岂可现身不能说法。但从事别其理必同。故作异名消文最便。此则圆门三昧陀罗尼。必是体同名异。三昧从定陀罗尼从慧。即不思议之定慧故得互用。准下释中三轮具足。又舌下判三昧与陀罗尼。秖是真位六根耳

    释普门品

初不云因缘等。此通别解。具足三释唯阙观心。十双中智断下云云者。但次第标释。不暇先列。人法并云有多种。各注云云者。并是示为一实并七方便。及以人法。前后问答。前问如文。后问答者。云何而为众生说法等是也。福能转寿者。罗汉尚能回福为寿。况普门示现以不思议福。转成种智。即福智不二名之为转。方例九双。如珠雨宝者。所转若成不思议福。不同下位。如意珠者。珠具多德。具如止观第五。凿井等者。如华严云。若有世界初成时。众生所须资生具。菩萨尔时为工匠。终不造作杀生器。初略如释签中初释尔时注其四者。四悉耳。若消文意令会四悉。说东方菩萨等者

问。何以前云召今言说

答。前文初召。须云召今是说竟。故云说。故品后云。说是品时。二处皆有初闻名时。即世界也。皆有随应为说即为人也。皆有答问得三昧由。即除疑也。皆有闻品得益不同。即得道也。经云偏袒者此土谢过而肉袒。彼国兴敬而偏服。盖二土风俗不同耳。先释无尽意名。于中初释无尽。先引三经。次总结成三观。初引大品空大集假净名中。大品明空则无尽。大集八十无尽门既多门不同。即是假也。净名夫无尽者。无有尽与不尽。双非故中也。次释意中亦先约三观。次结。初空观中虽并引境智正在和合皆无自性。智随境空。无尽家之意名为空意。次又意下约假者。世出世是境。智随于境境多智多。次约中心者。以能观心性中故。所观亦中。此约智照境说。此约下结。二处结文并云观智者。咸约能立问答。俱云慧庄严者。问答已是二庄严竟今释其意。云问答名庄严者。定慧二严之中慧庄严也。况二菩萨名及以佛名。俱从慧立。多苦苦一人等四句。一一句中有苦皆救咸可持名。以有五只十双普故。故念念咸益。圆菩萨皆然但随缘耳。经云观世音菩萨即时等者。有人以观世音三字着下句上。兴皇着上句末。于下句上又足观世音三字。二俱不然。依下句头亦不须足。有人问。何以同念有脱不脱。答同念是显机得脱有冥显。由过现缘差受益有等级。若其机感厚定业亦能转。若过现缘浅微苦亦无征。亦有人云。三灾有大小。大谓火水风。小即命身财。大次第有二。一从小至大时义可然。又从急至缓此未必尔。火不尽急风不并缓。小亦有二。一从重至轻。二从难至易。此或应尔。事益具如谢敷等观音应验记。说别答中三业机者。七难是口机。以称名故。三毒是意机。令常念故。二求是身机。常礼拜故。火难者。有人引仁王经七火不同。一鬼火。二龙火。三霹雳火。四山神火。五人火。六树火。七贼火。人火者。恶业发时身自出火。树火者。如久旱时诸木自出火。及至释水。则无七相。况复七相无所表对。故不用也。今文俱三。火名虽同浅深各异。若不尔者。云何显观音力大念者功深。入大乘下引论格量。六十二亿等者。有云。菩萨无殊欲令偏重观音故也。有云。佛法二门。谓等不等。不等如礼诸佛教说功异。平等者。得福无殊。今问若平等者。佛既无偏无不平等。何故不等。以佛不可有等级故。故等不等秖是被缘。虽是被缘亦未申难。故须依今偏圆以释。非但菩萨诸教不一。亦乃一教设迹不同。此约境判。若心境相对四句分别。今此乃是两俱句边。持六十二亿心境俱劣。受持观音心境俱胜。此即定教当教而观。若二交互句并境随心转

问。何故法华论中。乃以持六十二亿恒沙佛名。为校量耶

答有云论误。今云不尔。今先出论文次略消释。论云。受持观音名与六十二亿恒沙诸佛名彼福平等者。有二种义。一信力故。二毕竟知故。信力复二。一者求我如观音毕竟信故。二生恭敬心如彼功德。我亦得故。二毕竟知者。决定知法界故。法界者名为法性。初地菩萨能证入一切诸佛平等身故。平等身者。谓真如法身。是故受持观音。与六十二亿恒沙诸佛功德无差。今谓以此验知。须依圆释。何者。于二义中信力约事毕竟约理。事理相资方成所念。如信力二中。既云求我身如观音。即指化身。又音观音功德我亦得之。乃指报身。愿齐报应方乃成念。但念果德者。何必识理。故次义云知法界等。次引证位即是初地。且引分证令人识之。故知若念观音三身。须却以念佛校之。若以念法身论之。纵引十方诸佛其功亦等。何但六十二耶。所以论文虽似举经。乃是增句释义。亦如方便初加难解难知。欲说大法乃增三句。而为申释。三十三身十九说法云云者。应具指离合。结说少故但十九。如八部四众但结一说。结别开总者。前三十三身是别。故结云成就如是功德。即以此句复为开下总句之首。故下总云种种形等也

问。此经会三。何故云应以三乘等耶

答。形异法一。故妙音品云。种种变化说是经典。人不见之谓说三乘者谬矣

问。何以妙音中四乘居后。观音中三乘在初。又无菩萨

答。总而言之。无非菩萨于须别现者秖是文略。又三十三身随感即应。亦何前后。但二文互显。别文广意狭至云云者。离开多句故云文广。意唯现文故云意狭。总答文狭者。但十二字。言意广者。既云种种何所不该。闻品功德云持地者。宝云经云。菩萨有十法名持地三昧。如世间地。一者广大。二众生依。三无好恶。四受大雨。五生草木。六种子所依。七生众宝。八生众药。九风不动。十师子吼亦不能惊。菩萨亦尔。经一一合。今谓以八教判。方应今经。闻品功德下云云者。应对诸经及以今部。辩其得益共别不同。以判教相兼带等异。教若唯小显露终无结得大益。密得大益教不可传。教虽不传须辨其旨。若如方等般若之流。以部共故闻益亦共。则具显密及以不定。互相知者名为不定。互不相知名为秘密。是则部内或品似大。益有大小。或品似小益亦大小。或兼大小益亦大小。皆以向来三义消之。不能具指诸经品相。思之思之。今经唯大大中唯圆无密偏小。故闻品益始终无偏。虽于圆中亦有发心不退及无生等。不与偏小共也。约部判益良由于此。故严王品虽云法眼名同体异。定非初果。须判为六根清净法眼位耳。即七信已上。若闻法华令得初果。则法华一部文义俱坏。初一是横释等者。结前三重释无等等。以成大车。佛界一念望理名横。佛心望理二义均等。故名为横。次约初心缘毕竟理。初后相望为竖。第三意者。心之与理冥符一体。俱不可说。谁论横竖。初释唯佛心即空也。次释通一切假也。第三明前二俱不可得中也。文后偈颂什公不译。近代皆云梵本中有。此亦未测什公深意。续僧传中云。偈是阇那掘多所译。今从旧本故无所释。还着本人。具如止观第八记

    释陀罗尼品

总持下二番云其四者。并是四悉。初约翻名。次诸师下约释义。三恶世下总揽二重。以明来意。初又二。先正约四悉。次对诸经开遮以明四悉。初文者。善恶异故。即世界。次一番具二悉故。注其二三者。能持善边即为人。能遮恶边即对治。中善即第一义故秖遮持二字四悉具足。生云。近识受持心薄故敦之以咒术。注云幽显挟赞故曰陀罗尼。观生公去注远矣。本为弘经者护难。岂唯敦逼咒术。全滥矫俗。如药王献六十二亿佛之所说。勇施恒河等佛之所说。况护国四王罗刹七女皆为护法请佛印许。如何谓为咒术敦之耶。然咒之为义本不合翻。如劝发中云。菩萨得闻。当知普贤神通之力。岂同术耶。若全不可翻竺法护何故翻之。若其不晓不翻之意。移品何疑。大明等三者。通论秖是般若。般若总摄故名为咒。总用总持总破总安俱得名咒。别对三教思之可见。如此通别复名为通。今别在今经护法故也。他经随事禳灾增益摄召不同。彼文亦各别有观法。所以新译并名真言及以明者。古人见秘密不译。例如此土禁咒等法。便以咒名往翻。今言皆是如来难思秘密真言种子。注云云者。令说其意如向略知。从诸师下说咒义者。初文者。王名异故息恶生善。次文者。即以相应谓为生善。虽有治罪之言正令顺教。第三文者。密治即对治也。第四文三。先明咒意。次引事释成。三咒亦如是下重牒结前。具足四法成第一义。以密具四为称理也。初病愈世界。罪除对治。生善为人。道合第一义。三恶世下来意可知。故知此与生公永异。注家云赞。未损大仪终不及护

    释严王品

因缘出他经未检。此文亦有四悉。初是世界。又庄严下为人。此王下治诸根之恶即对治。生虽下即第一义。初文者。晷音轨。日月运行也。刻谓漏刻。喀喀吐声也。不进之貌。意云。一餐不进长途妨于万里。十日为旬但唯九饭。复阻高志。白毫东照照妙音也。一欲示弘经之利。以勖受法弟子。二示结会不虚。故经云。净德夫人者今佛前光照庄严相菩萨是妙音也。神咒护经者。且从后说。准前亦应云苦行。神咒护法弘经现身说法双规师弟。所以蒙照东至者。知有来往之勋故也。欲来先云欲见药王等。华德复为妙音所将及以此土发起之众。药王乃为总持之主。共成二子之化。兼为结会古今令时会并识。了宿因不失信化迹功深。知权谋叵测。仰远种难亡。说四圣之前缘者。前缘不同得圣前却。便分能所方乃改邪。又利物多端邪正异辙。所化既熟能化弃邪。今从示迹及从后说。故设化之时。一凡三圣。若准佛云为欲引导妙庄严王及一切众生故。说是法华经。王宫八万四千皆任受持。二子四万二千俱至佛所。则王及能化一切悉权。从本为言四俱大圣。如胜鬘受化有称归心。元为国人先迷后悟。化道之轨理数而然。今从迹说受化得记。四圣名生。生虽未获者。虽阙生知化时非久。臻至也。是故预彰入道之兆。例如空生等空故无诤德号预呈。余经指此为十波罗蜜者。未曾有经收六度四等为十度耳。亦不的对道品中节节有三昧者。七科之中唯念处属慧正勤属进。余五科内皆有定名。复别列名者。当知随用立名。其理不异。先白母者。父邪母正。故先白母。共设化方。若据其本母子元知。今约化仪机熟应发。槌砧相扣物器方成。是故云白。若附世情则母慈先白。利他之本慈复居先。父王已信宫中又熟。父王一人何足可化。秖缘宫内未熟。所以王亦待时。能化两重远鉴机理。推功化主结会古今。经云譬一眼龟者。约事秖是譬难值耳。若作所乘凡龟鱼之眼两向看之。既云一眼所见非正。在生死海而又邪见。何可值于佛法浮木实谛之孔。善知识者。具如止观第四记。华严亦云。如父母导师医船等。闻品益中法眼净者。有云。初果也。岂王夫人及与八万。皆持此经皆当作佛。而闻品者得小果耶。名同义殊善须斟酌。已如前说。注者亦云所见清净。不云小乘初果位也

    释普贤品

三悉者初世界。悲华下为人。我行下对治。若从胜他为名乃是贤于一切。名为普贤。言即三悉至解释也者。既以翻名发愿义当三悉。故云复是及以又是行愿。又行愿下。亦却指三悉。并是行愿。即是以三悉判行愿也。未立第一义者。由释贤故让圣方名第一义。故悲华愿兼于行。我行而兼于愿。由来下次约教也。为四。先古人释判属三藏。由来者。由从也。谓古从来作此释耳。以普贤名通义别。亦应云通于通别。文无者略。故知三教释于普贤并谬。次今明去即从圆释也。三若十信下更对前位。况破通别。四今论下重释

问。华严云。普贤菩萨依于如如。不依佛土。今何故云从东方来

答。此据应迹所从。彼明所证自体。既云等觉。犹有一分报土身在。经从极理初住即证一分如如。正当圆教。所以伏通断偏断极之伏方名普贤。伏通在初故云伏始。是贤非普故非顶非周。故邻初下约初住位。十住之初故非后极。十地但断四十品尽。非断伏极知非普贤义也。四重约位正判。先正判。次引释论以证圆极。论引大经文也。具四悉云云者。不预列耳。即其四文是。随去等者。去动秖是表来去也。随者。非先积而后雨。非先畜而后奏。故以龙雨譬之。此是心力法力。众生力应化力。不思议力之所致也。略用二力者。威德神通前已具列自在等四。以表四德。今略无自在及以名闻。但二兼二故也。经文既云与无数等。各现二力者。当知所随皆法身也。主伴并具四德。故云各也。此文既在流通之末。故愿闻之言。双请正宗及流通也。别列四句文中二解。正宗。流通。初又二。即迹本也。迹又二。先约开权显实。次约开示悟入。初文初句法身二三般若。第四解脱。二德庄严法身。是故后三约于初句。于初句中远恶下八字。即四悉也。次约开等中经典四句回互者。以从开等次第故也。唯三唯四者。四秖是四安乐行三秖是三德及座衣室三。前文释衣等三。皆通两句各有能所。今从一边则以空座为般若。所覆为法身。能覆为解脱。此中正定。合在法身德中。前对开显中即合正定。入般若中。以此一句。两句得名故也。浪作余解者。设若有人不许此解。则为不许自行化他。则为不许开示悟入。则为不许室衣座三。则为不许方轨弘经。若言非是不许但是无文。若谓经无即是不许逐要重说。若不尔者。将何以揽今经正宗。至此为重说耶。经初存其开等四句而为四释。今至此经末。又示开等还须四释。故知始末并是此经体宗用也。是则序正流通无非妙法。教内法中云三番者。即读诵思惟三七日也。有人至此亦引文云。行有五法一三七见。二七七见。三一生见。四二生见。五三生见。又云。应有六法。一严道场。二净身。三六时。四启请。五读诵。六思惟甚深空法。作是观时能灭百千万亿阿僧祇重罪。若尔。何以解释一经。都无启心投想之地。至此乃引普贤观经。况今自云读诵书写者。欲修习是法华经。于三七日中一心精进。我当乘象至其人前。故知若修行若解说。请依今师方有所至。所以非玄文无以导。非止观无以达。非此疏无以持。非一家无以进。若不尔者。用是教为。用讲宣为。故东京安国寺尼慧忍置法华道场。今天下仿效而迷其本。不知此尼依凭有在。而亲感普贤。然虽有置道场处。多分师心。况今讲者而欲轻略斯教。良由不知教旨故也。适与江淮四十余僧往礼台山。因见不空三藏门人含光。奉敕在山修造。云与不空三藏亲游天竺。彼有僧问曰。大唐有天台教迹。最堪简邪正晓偏圆。可能译之将至此土耶。岂非中国失法求之四维。而此方少有识者。如鲁人耳。故厚德向道者莫不仰之。敬愿学者行者随力称赞。应知自行兼人并异他典。若说若听境智存焉。若冥若显种熟可期。并由弘经者有方故也。若直尔讲说。是弘经者。何须衣座室三之诫。如来所遣岂可聊尔。余省躬揣见自觉多惭。迫以众缘强复疏出。纵有立破为树圆乘。使同志者开佛知见。终无偏党而顺臆度冀诸览者悉鉴愚诚一句染神咸资彼岸。思惟修习永用舟航。随喜见闻恒为主伴。若取若舍经耳成缘。或顺或违终因斯脱。愿解脱之日依报正报常宣妙经。一刹一尘无非利物。唯愿诸佛冥熏加被。一切菩萨密借威灵。在在未说皆为劝请。凡有说处亲承供养。一句一偈增进菩提。一色一香永无退转

法华文句记卷第十(下)


法华玄论

    No. 1720 [cf. No. 262]

法华玄论卷第一

        胡吉藏撰

玄义有六重。一弘经方法二大意三释名四立宗五决疑六随文释义

第一明弘经方法有七意。初释法师义

论曰。法师品云于我灭后欲说此经当安住三事。所谓入如来室着如来衣坐如来座。如来室者慈悲心是。如来衣者柔和忍辱心是。如来座者诸法空是。慈悲有荫覆之功喻之如来室。和忍有障蔽之用譬之如来衣。空理可以安心目之为座。然此三门则为次第。大悲拔苦大慈与乐。盖是种觉之洪基弘道之本意。欲说妙法宜先建此心。是故第一明入如来室。既于恶世欲弘善道要多留难宜应忍之。是故第二明着如来衣。虽慈悲外覆和忍内安。若无空观虚明二行不成何由悟物。是故第三明坐如来座。内具斯行外勤说法则道无不隆人无不利。故令住三事弘法华经。次束此三门以为二义。慈忍为福德空观为智慧。福慧兼习大道可弘。谓福慧法师。是以经云具二庄严能问能答。所言法师具问答者弘道之人必敷经说论。经论之中有问答。巧申菩萨之难为能问。妙显如来之通为能答。巧申外人之难为能问。妙显论主之通为能答。摧破九十六种外道为能问。妙显诸佛如来正法为能答。又能破三乘异执为能问。巧显一乘同归为能答。能问能答佛教宣流故名大法师也。又慈忍为行空慧为解。解行双备说必利人谓解行法师。自有行而无解。有解而无行无解无行。有解有行。前三始为弟子后一方是法师也。又经云兼除老病死菩萨之谓也。譬如胜怨乃可为勇。具慈忍故则能利他。心修空观名为自行。俱济之德名为雄勇法师。又以慈忍故不滞涅槃由空观故不着生死。以无所染谓无著法师。又以慈忍故越二乘地。具空观故越凡夫境。非凡夫行非贤圣行名道行法师。又经云菩萨住二谛中为众生故说法。为著有者说空为滞空者说有。以慈忍故安住世谛。具空观故住第一义谛。依二谛说法所言不虚谓诚谛法师又如论云。了四悉檀善识佛意。于十二部经八万法藏不相违背。以慈忍故依三悉檀具空观故识第一义。入佛法中无所执着不相违背谓无诤法师。又即此经文又见佛子定慧具足。以无量喻为众讲法。以慈忍故名为禅定具空观故秤为智慧。定慧圆备名具足法师。又如经言。安住二法魔不能坏。知诸法空及不舍众生谓难坏法师

又如论云。以空观故名为菩萨。具大悲故名摩诃萨。谓菩萨摩诃萨法师以有如是种种利益。宜住三行弘法华经。次会此二门圆成一旨。虽行慈忍常毕竟空。虽毕竟空常行慈忍。慈忍不妨毕竟空毕竟空不妨慈忍。指慈忍为毕竟空指毕竟空为慈忍。故地经云悲慧合修行则其事也。得此观成空有无碍。空有无碍名无碍观。得无碍观有无碍通及无碍辩。以无碍观故心无碍。得无碍通故身无碍。得无碍辩故口无碍。以三业无碍故得六根清净。备六千功德谓根净法师。若但修十善何能。便有此用。故以三事修心六根无碍耳

次泯于一句以归无句。慈忍为空有空观为有空。空有故不有有空故不空。不空不有名为中道。所以论云远离二边名为中道谓中道法师。又前明二句则二谛观。后明无句谓中道观。虽二谛而常中道虽中道而常二谛。二谛不碍中道中道不妨二谛。是故论云因缘所生法我说则是空。亦为是假名亦是中道义。则其事也。此之三观名诸三昧王。内具三观外说法者名说法中王。谓诸王法师也。又二谛为二中道为不二。经云不着不二法以无一二故。如此卷之则不留一豪。舒之则弥纶法界。虽舒而不有虽卷而不无。瞻之在前忽焉后。仰之弥高钻之弥固。若幻若化如忽如恍。欲见斯意可寻华严。华严云无量劫一念一念无量劫。无来无积聚而现诸劫事。一切施为皆此类也。谓无碍法师

问。何故但举三喻以劝弘经

答。夫说法人必具三事。一入讲堂二着法服三登高座。外形既尔内心亦然。若无慈悲不入讲堂不修和忍便无法服。心若滞有不登高座阙此三德安可弘经

问。何故三事并秤如来

答。入室但有覆己佛室普欲荫他。是故慈悲名如来室。既欲普化群生则遍忍污辱。以此自严无丑不覆。是故和忍称如来衣。空理虚通可导群有。踞此敷弘无缘不盖。是以空解为如来座。次就安乐行品明弘经方法。经云菩萨摩诃萨安住四法。能于后世说法华经。四行不同后当广说。一智慧行二离憍慢行。三无嫉妒行。四慈悲行。安住四行身心快乐故名安乐行。智慧行者具足二慧。观一切法空如实相亦不行不分别谓实慧也。而知诸法从因缘生谓方便慧也。此二慧是菩萨之妙悟利人天之明术。夫欲自行化他必须正解。故先明二慧。虽有智慧恐恃解凌物美己恶人。宜应离之。是故第二明无憍慢行。虽不举我凌他犹恐忌他胜己则是弘经之巨患伤大士之本怀。是故第三明离嫉妒行。初具二慧为明解。次无两过为高行。行解内成故慈悲外被。是故第四辨慈悲行。备此四行则德无不立化无不隆。欲弘大道具应习之

问。前明三德后辨四行。末世钝根云何能习

答。从初发意必须渐学。若乖此行便非法师

次明失义

问。有所得说法有何过耶

答。此经云是法不可示言辞相寂灭。若有法可说乃说非法非说法也法不可闻。若有所闻乃闻非法非闻法也

问。法不可说何故劝说法华

答。法不可言而遂言。于无言者盖是无名相中假名相说。欲因假言令悟无言耳。故净名云其说法者无说无示。其听法者无闻无得。当建此心然后说法也。正观论云离空欲问问不成问。离空欲答答不成答。有所问答悉须依空。况求离苦寂灭相者。论明依空即是斯经不可示法。斯乃经论明轨宜可依之。又佛藏经中广彰其失。今略示一文以为鉴针。彼云若以刀轮害阎浮提众生其失犹小。若以有所得说大乘者罪过于此矣

问。有所得说法何故有是罪耶

答。断阎浮提人命者即有二义。一者但杀肉身。二者所害犹少。若有所得说法者一害诸佛法身。二遍毁正教。所以然者。生死肉身以爱着为本。诸佛法身从无住而生。是故杀生过轻。而说有所得罪重也

问。佛藏所说乃是一方之言何得遍用

答。非一经意然而众教皆尔。如涅槃云有所得者是魔眷属。夫论魔者欲灭佛法有所得说佛法故名为魔。又像法决疑经云。我灭度后诸恶比丘如文存义。作决定执破灭我法。是人名为三世佛怨。又涅槃辨诤论云。若人于中生疑心者犹能摧坏无量烦恼。若决定解是名执着。如是执着能断善根故。弘法之人宜虚其心实其照矣。论弘经难义

问。现见受持读诵讲说书写者遍满世间云何。现塔品云假使有人手把虚空。而以游行未足为难。暂读此经是乃为难耶

答。此经反三之始归一之初。外国多小乘学小执已成难可移改。故能信者难也

问。何以知外国学小乘者多

答。释论云。佛灭度后有五百部。闻大乘法说毕竟空。如刀伤心。故知皆小乘学。又龙树传云。读小乘已周寻大乘。不得遇沙门于岩下。方乃闻之。又论主呵言。是迦旃延诸弟子辈不读不诵摩诃衍经。闻大乘法心不信受。又如昙无谶三往外国寻涅槃经犹不得尽。又朱仕行欲将大品至汉地。诸小乘学人皆不许之。然后求烧经为誓始得来耳。又如睿法师喻疑论云。天竺三十六国皆小乘学不信方等。故知学小者多信大者寡

问。天竺乃多学小乘震旦皆信方等。何难之有耶

答。大品云是波若从南方转至北方。是中四众当行之。肇公云北天之运数其然也。震旦之望于天竺即是北方。但世界遐广一方之信未足秤多。又考而言之终日弘宣终日不信。何以知之。灵坟踊现分身普集盛开二身。而讲者但谓证法华人不知开迹显本。云何信耶。又分身明其不实寿量定其非数。逸多不见其始。补处莫侧其终。而犹谓无常。遂同灰尽。可谓穷子反走于宅中。独老掩目于道上。谁肯信哉。又法师品云。令升寂灭之床吐无言之教。虽复破三心不染一。而封言之徒随名存相。虽复舍三心复滞一。何由能信

问。心无所得乃是偏空义耳。大经呵云汝等勿谓如来唯修诸法本性空寂。故知空者空耳。盖是二乘所见。又大品三论可得明空。法华开权显实。涅槃明常住佛性何得明空。将非田夫哑盐旧医用乳

答。法花盛开三轨以空为高座。广明四模以空为安乐。子不信之即事为验。又大经云佛性者名第一义空。佛性是三世诸佛之根本也。又云迦毗罗城空大般涅槃空。大涅槃是诸佛之极果也。又花数云如来觉诸法如幻如虚空。菩萨清凉月游于毕竟空。此明佛菩萨所悟皆空。又云游心法界如虚空。是人乃知佛行处。此明以了空故入佛境界。斯乃方等之格言至人之妙悟。子不受之。故知深信者寡。今言空者不见空与不空。如是五句皆无所得。不知何以目之。强名空耳。大经所呵者呵二乘断见。释论所斥外道邪空耳。可谓乳色虽同甘毒为异。子未别之。不应相浑也。又今明无所得义。若有空可得是有所得。何名无得。乃至有无得可得犹是有得何名无得。又今以无所得故无所不得。不动等觉建立诸法。说斯为空耳。若以凡夫所解空之与有。亦有亦空非有非空。皆是戏论不应用此。以讲佛经一乘义后当广说也。又佛说教者令心同教不令教同心。心以存相为根教以无得为主。若心同教教既无得即心无所得乃名说教。若教同心心既存相即教成住着。但迷倒心终不弘教。故呵迦旃延云无以生灭心行说实相法。若以生灭心说实相实相成生灭。若实相心说生灭则生灭成实相。故闻说生灭皆入实相门。但弘经之人多以教同心。不能令心同教。故信者难。此岂虚哉。又弘经者必多留难。喜生退心故信者难得也

问。何故尔耶

答。既弘正道必损非道。故非道政之如服良药必动诸病。故病来政身然后疾乃得消。盖是数之然也

问。谁力故令留难退耶

答。大品云佛力也。今明理而言之还是经力。以弘道力能攘非道。故是经力也

问。子虽广引众经诚如所说。但法华正明会三归一显实开权。云何乃明空义

答。十二门论云。摩诃衍者是十方三世诸佛甚深法藏。为大功德利根者。说摩诃衍者名为大乘。大乘凡有六义。一出二乘之上故名为大。二诸佛大人之所乘故故名为大。三观世音弥勒等大士之所乘故名为大。四诸佛最大是乘能至故名为大。五能灭众生大苦与大利益故名为大。六能尽诸法边底故名为大。大分深义所谓空也。若通达是空则通达大乘。具足六波罗蜜无所障碍。论明大乘是十方三世诸佛甚深法藏。空复是法藏中之甚深。故知空者是深中之穷深。大中之极大。是以法华盛开三轨以空为高座。广明四行以空为安乐。岂非菩埵之明训道场之玄范耶

难曰。夫会三归一者正会有中诸行。以归一佛乘。云何乃说空耶。将非指南为北以晓迷徒。论虽有诚言犹未鉴意。请为会通令无豪滞

答。若领龙树玄文已解会三妙旨。子既未悟。今当重明。夫会三归一者本令二乘趣佛道。必由鉴乎实相。实相本亡言息虑。不知何以目之强名为空。以见空相故心无所依。心无所依故能动能出。乃名为乘。若不见空相则情有。情有所依所依则名有所得。若有所得不动不出。虽复终身举手历劫低头无得佛义。是故归一要悟空岂不勉哉

次明翻译缘起

此经凡有二本。一正法华经。晋长安竺昙摩罗刹此言法护之所译出。二妙法莲华经。晋鸠摩罗什此云童寿。于伪秦弘始五年四月二十三日。于长安逍遥园译出大品。后于草堂寺译出此经二十七品。此二本有今古文质广略之异。而大意同矣。复有大悲莲华经。广明慈悲之德。异上二经。是昙无谶所出。其中复有华首华严诸华经不一也。然晋有前后昔在江右名为西晋得五十二年。此经犹在外国。自元王渡江左称为东晋。至晋安帝义熙中此经始度。然宋得六十年。齐得二十三年。梁得四十四年。合二百二十九年。从梁至今五十年将三百年矣

次明讲经缘起

法华既有新旧两本讲者亦应二人焉。名僧传云。讲经之始起竺法护。护公既亲译斯经理应敷阐。自护公之后释安竺汰之流唯讲旧本而已。及罗什至长安翻新法华竟道融讲之开为九辙。时人呼为九辙法师。九辙之文今所未见。讲新法花始乎融也。自融已后昙影道生之流染翰著述者非复一焉。次乎齐代有清信优婆塞刘虬。与十许名僧依傍安林壹远之例什肇融垣之流。撰录众师之长秤为注法华也。爰至梁始三大法师硕学当时名高一代。大集数论遍释众经。但开善以涅槃腾誉。庄严以十地胜鬘擅名。光宅法华当时独步。但光宅受经于中兴寺印法师。印本寿春人俗姓朱氏。少游彭城从昙度受论。次从匡山惠龙受学法华。而印讲斯经自少至老凡得二百五十遍。春秋六十六。永明元年卒。光宅云法师息慈之岁随印在钟山下定林寺听法华经。下讲竟住寺后石涧中累石为高座及以听众。于是自登石座霞述所闻。印未知之密听其所说。一言靡遗。年至三十于妙音寺开法华净名二经题。机辨纵横道俗叹伏。由是已来法华誉显

余流遁禹川疏记零落。因于讲次略撰所闻目为评解。敢秤传训。盖是以备漏失正自坏之路耳

序其评意略有五焉。一依大乘论以通方等。盖是释经之弘轨通教之本宗也。大乘论者凡有二种。一通解大乘。谓中百十二门地持摄大乘论等。二别释一部。谓大智度论地论金刚波若论法华论等。具解通别二论者始鉴大乘旨趣可讲大乘经也。小乘论者亦有二焉。一通释三藏。谓八干度婆娑成论等。二别释一教如胁比丘造四阿含论以别释四阿含教也。十八部婆娑别释十八部律如善见之流。舍利弗毗昙别释佛九分毗昙藏也。具解通别二论可讲小乘经矣。故马鸣龙树造大乘论以通大乘。法胜诃梨着小乘论以解三藏。斯则朱紫异贯泾渭分流。而宗习数论以通方等。进无弘经之功退有伤论之失

问。数论是弘经之长宁有乖伤之过

答。通三藏之长如跋摩之序。障方等之失现法华之文。故言安住四行演说斯经不得亲近小乘三藏学者。经有诚诫可不慎哉

问。安知成论但解小乘

答。诃梨自秤正论三藏宁非小乘必言斯实亦通方等者过在门人。非跋摩之咎也。又罗什翻成论竟命僧睿讲之。睿序云。地水火风假也色香味触实也。而精巧有余明实不足。此三藏中之实耳。非方等之谓。序末又述什公语。秦人谓成实论所明灭谛与方等均致。什叹曰。秦人之无深识何以乃至于此乎。吾每疑其普信大乘。当知悟不由中迷可识矣。成论所明灭谛比于方等。其犹龙烛之于萤耀夜光之于鱼目。未足喻其愚也

问。以论通教过彰于前。用数弘经复有何失

答。释论解四缘义。有人问欲学四缘应学毗昙。云何乃学波若。龙树答言毗昙初学似如可解。转久推求则成邪见。以此详之过逾于前。此评得失之一也。妙法莲华经者盖是群圣喉衿方等之秘奥。其文巧妙其义深远。考经推论可谓教圆理满。究竟无余之说。自古爰今受持读诵者则尤累灭于内。嘉瑞陈于外者不可称言也。而人秉五时之规矩格无方之圣化。妄谓此经犹为半字明因未圆辨果不足。五时既尔四宗亦然。废五四之妄谈明究竟之圆旨。进有称叹之福。退无诽谤之罪。评得失之二也。外云自见不明自强不胜。内辨长守一见丧其无方。偏用只文失其圆旨。故广集异论捃采众师。择善而从有能必录。至如慧基以空为乘本会无量义经。道生解寿量明常符法华之论。如斯之例皆可用也。如言昔有遍行六度之人。今教辨四车之说。又云未免二种生死已度五百由旬。斯皆经论无文。即事鉾楯皆所弃之。此评得失之三也。大智度论释无作品。明巧说波若凡有十门。最后名为分别深浅难易。深浅难易者如深水难度。若巧分散则深者为浅。而度则易也。而好事君子广生细章略示大意。则昏彼清实翳其弘旨。或至前而进诵后至后而退诵前。进无益于文理退有劳于说听。今删其繁重正于乖阙使昏明殊镜。冀有过半之功。评得失之四也。书云华言不信信言不华。经云深悟者爱义浅识者好文。如见后章辨果谓初段明因。欲因果相对。又文始现六瑞于此土。亦现六瑞于他方。欲以二六文成双。斯皆巧言在余而义势不足。文具详之。今观龙树之释大品天亲之解华严。唯使文显理彰竟无斯意。故圣轨须依凡模宜弃。评得失之五也

次明所弘之经。此经有十种不可思议。一者化主不可思议。诸余经典之所无有。如见宝塔品说十方诸佛并皆云集。一一方四百万亿那由他恒河沙诸佛如来遍满其中。又多宝踊出谓过去佛集分身佛会。谓现在佛集十方菩萨来会谓未来佛集。略而言之十方三世并会鹫山。自此以外未有如斯之盛集也。二徒众不可思议者。十方世界一一方四百万亿那由他诸佛侍者遍满其中。又下方千世界尘数菩萨从地踊出遍满十方虚空。如是等众不可称计。虽复始莲华藏终跋提河亦未有如斯之众谓徒众不思议也。三教门不可思议者。诸余经典之所无有。如华严大波若等各十万偈尚已为多。释论云法华无量无边如大海水。又大通智胜佛说是华法经如恒河沙偈。威音王佛说此法华经二十千万亿那由他偈。斯则教门不可思议也。四时节不可思议日月灯明佛说此法华经六十小劫妙光菩萨于八十小劫说法华经。大通智胜佛于八千劫说法华经。十六沙弥于八万四千劫说法华经。释迦佛说此经时踊出菩萨问讯诸佛。如是时闻经五十小劫说法华经。时节何可秤计故名时节不可思议也。五者利益不可思议。如分别功德品初有十二种利益。始自无量恒河沙菩萨悟无生忍。终到八佛世界尘数众生发菩提心。诸余经教悟道者亦未有如斯之例。故利益不可思议也。六者国土不可思议。如释迦牟尼欲容受分身诸佛故。各变八方六万亿那由他国皆成净土。又神力品云于时十方世界通为一佛国土。说余经时或有变土或不变土或变一土或变一会。未有如斯庄严事也。故国土不可思议也。七神力不可思议。如释迦及十方佛一时现七种神力满百千岁。诸余经典虽现神力或但一佛或但一时亦未有如斯之事。故神力不可思议也。八功德不可思议。如第五十人展转闻经一念随喜者。胜布施四百万亿阿僧祇世界六趣众生一切乐具及令得阿罗汉道。况受持读诵解脱福不可量。故功德不可思议也。九者结束始终融会权实。一化教门焕然可领。诸余经典直说而已。谓教门不可思议也。十者开近显远融会真应。无方大用三世益物。余教不明此经独有。谓身不思议也。以有如是十种难思事。持说之人累灭于内瑞获于外。僧弼广载岂徒然哉

○第二序说经意

问。佛以何因缘故说是妙法莲华经。诸佛不以无事及少因缘而自发言。譬如须弥山王不以无事及少因缘而动。今有何等大因缘说是经耶

答。诸佛住三事示现说十二部经。三事示现即是三轮。一他心轮二神通轮三说法轮。既住三事说十二部经。当知亦住三事说法华也

问。以何义故住于三事说此经耶

答。三事示现即是如来三业利物。他心轮谓意业利物。神通轮谓身业利物。说法轮谓口业利物

问。此经何处明三轮耶

答。如入无量义处三昧谓他心轮也。放光动地雨华现土者谓神通轮也。从三昧起广说法华经终竟一经谓说法轮也。又总论教门凡有二种。一者正果谓如来身。二者依果即国土等。若现诸佛依正二果谓神通轮。若说诸佛依正二果谓说法轮。应机而示此二谓他心轮。故寿量品云。或说己身或说他身谓说法轮也。或示己事或示他事谓神通轮也。序品之中盛明斯义也。又他心轮谓知病识药。现通说法谓应病授药。又应生福德为之现通应生智慧为之说法。又现通则发起信心说法则生物智慧。佛法大海信为能入智为能度则佛法具矣。又神通轮冥密利物说法轮显现益缘。圣化虽多无离显密。又神通轮方便发起说法轮开宗授法。又神通轮拔苦与乐说法轮灭惑生解。又神通轮显佛功德业说法轮显佛智慧业。又神通轮济三恶道令其离苦。说法轮劝三善道令其进行。又说法轮显波若德神通轮显法身德如大经四相品说。以有如是种种义故住三事也

问。昔用三轮与今何异耶

答。譬喻品云。是时长者作是思惟。当以衣裓若以机案从舍出之。作是思惟谓他心轮。当以衣裓谓神通轮。若以机案谓说法轮。合譬中云。如来复作是念。若但以神通力及智慧力即其事也。但成道初时即欲以三轮化物令入一乘。而根缘未堪今始得用故与昔不同也

问。三轮有何次第

答。三轮之中他心为本。谓知病识药然后乃现神通说法轮应病授药也。以他心为本。是以如来前入三昧次现神通。然后起定说法也

问。初品之中具几轮耶

答。就佛为论初品入定现瑞但有二轮。而弥勒之问文殊之答亦是说法轮也。从方便品起定说法竟于一经谓说法轮。其中有现通等事属神通轮

问。六通之中三轮是何等通耶

答。就六通义三是示现。三非示现。他心通即他心轮。如意通谓神通轮。漏尽通谓说法轮

问。余三通何以不名示现

答。他心等三能令众生即事信验。故名示现。天眼等三则不能尔。故不名示现也。此通释一经而正拟初品也

复次欲说诸佛三种净义故说是经。一者五戒十善以净三途。二者说四谛十二因缘以净三界。三者说方等一乘以净二乘。具此三净令诸众生得出三界内外火宅故说是经也

复次欲明三引法门故说是经。一者如来出世之始竟法华之前。引九十六种邪见及在家众生。归五乘正法。二者引五乘之异同归一乘。即法华初段意也。三引一乘之因归法身之果。此经后段意也。此之三引无教不收无理不摄。今具明三引究竟法故说是经也

复次欲明权实二智相资成故说是经。所以然者非权无以辨实。非实无以明权。由实起权由权显实。由权显实故权资于实。由实起权故实资于权。三世诸佛智用虽多不出斯二。但迷宗之徒或执权而丧实。或守实而亡权。今欲开显权实二智相资成故说是经也

复次欲说根本法轮故说是经。根本法轮者谓三世诸佛出世。为一大事因缘即说一乘之道。但根缘未堪故于一说三。即以一乘为本三乘教为末。但大缘既熟堪受一乘。今欲还说根本法轮故说此经也

问。佛初成道欲以一乘化物不得。华严教明初成道为诸菩萨亦说一乘。二经何异

答。教异释不同。若如南方五时之说北方四宗之论。皆云华严为圆满之教法华为未了之说。今总难之。明初成道一乘化众生不得。今说法华即是一乘化众生得。若言今说法华义犹未了者。则佛初成道欲以一乘化物不得者。此应发始即用不了义化物也。若佛初成道即欲以不了义化物者。此即乖父子恩情伤诸佛本意。若言初成道是了义化物。今说法华亦是不了义者。初成道可是一乘化物不得。今说法华应非一乘化物得也

又问。以何义故而法华经义未了耶。救曰凡论满教谓因圆果极。此经未明常住故果未满。满字具明缘正二因。此经但明缘因成佛未明正因。故因未满

答。此经明众生有佛性即是正因。假万行为一乘即是缘因。故因义具足。开近迹是无常显妙本为常住。故果义究竟。此义后当说之。故不应言此经明义犹未了也。又佛种种因缘称叹法华令人信受。若言教称半字理犹未圆者。则使闻经之徒不生崇仰。便于法华起轻劣心。上失光阐之福下招误物之罪。譬喻品未为之寄心也。今所释者华严之与法华同明一因一果。教满理圆无余究竟。但善巧方便起缘不同。领其大要凡十四种。一者华严谓始说一乘法华终明一乘。始终乃异一乘无别。二者华严直说一乘。始无所会终无所开。法华对三明一。始辨开一为三终明会三归一。三者华严为发始学大缘说法华为二种缘说。一者为前小后大缘说。二者为发始学大缘说也。四者华严为福德大利根人说。法华为薄福钝根人说。如初本学大中途弃大留小。后还舍小从大故名钝根也。五者华严谓平道教。法华初则斥夺迷执然后方平道说也

问。云何斥夺迷执后方平道说耶

答。初斥三病为说一乘。三病若消一乘亦废。然后始知寂灭之道三一二夷适缘不同大小双用也。六者华严但明一乘实慧法华具三一权实二慧。故开方便门示真实相

问。若尔华严应无二慧

答。照一乘为实慧鉴三乘为权。华严教门但明一乘故唯有慧。就一乘中自开二慧。或约动静双用。或就空有二行。亦得具二慧也。七者华严是舍那迹本身说。法华是释迦本迹身说也。八者华严加诸菩萨说。法华如来自说。九者华严但对菩萨说。法华杂对二乘菩萨说。十者华严竖论一乘开五十二位。法华横论一乘不开阶级

问。何故尔耶

答。适化不同非可一类。但华严之缘本信一乘故于一乘中历位增进。故问阶级不同。法华之缘本末信一乘破其三病。始得信一乘故未得次第历位登升也。又信一乘得发菩提心。修菩萨行学菩萨道入华严法门故。法华不须更问阶位也。十一者明华严广明一因一果。法华则略明一因一果。十二者华严净土中说。法华秽土说。现塔中虽复变土令净。而华严本是净土非变而成净。法华秽土中说也。十三者华严七处八会说。法华一处一会说。十四者华严一佛说法华分身等十方佛多宝等三世佛共说。此举七卷对彼五帙作此判了。非就法华大本论之也。释论云法华如大海水何所不明耶

问。以何故明法华对华严耶

答。此经领解中广序长者尊豪七珍具足眷属围绕诸人侍卫。此皆指华严初成时为诸菩萨说大法事也。是故引华严以类法华。此义现信解品也。晚见法华论释寿量品具三身一法身二报身三化身具有华严之意。以众经皆说报身即是舍那故也。寿量义当广说也

复次欲示中道离二边相故说是经。言二边者据昔五乘有二种边一者人天乘为世间边自余三乘为出世间边禀教之徒。谓世间乘异出世乘。出世乘异世间乘故名二边。至法华教明一豪之善皆入一乘。无复世出世异乘故名中道。又昔言有异大之小异小之大复名二边。法华教起会兹大小。同入一乘无复大小异乘。故名中道也

复次欲断二乘及菩萨疑故说是经。如言菩萨闻是法疑网皆已除。千二百阿罗汉悉亦当作佛也

问。二乘菩萨有何等疑

答。二乘之人有二种疑。一者旧疑如身子云。三乘同入法性云何见诸菩萨受记作佛。二乘不作佛欲以问世尊。为先为不先未说法华有此疑也。又云初闻佛所说心中大惊疑此新疑也。菩萨之人亦有二疑。一者始行之人昔日虽闻修菩萨行得成佛道。未知为定成佛为退作二乘。此旧疑也。今闻法华明无三有一心复生疑。若无三乘佛昔何故说有三耶。今欲断声闻菩萨二种疑故说是经也。晚见论释三请文明声闻菩萨皆有旧疑。现索章义说与今文符会

复次欲明一切众生皆有佛性故说是经

问。以何义故。今说一乘乃言明佛性耶

答。乘若有三可有三性。既唯有一乘则唯有一性。如毗婆娑云一切众生有三乘性。随成一乘则余二非数缘灭。法华明一乘义则不然。故唯有一乘唯有一性

问。此经但明一乘云何已辨佛性

答。中论云。虽复勤精进修行菩提道若先非佛性云何得成佛。长行释云如铁无金性虽复锻炼终不成金。若法华未辨佛性但缘用成佛义者。既无佛性则无成佛理亦如师子吼品广难无性成佛义。以理推之必明佛性

问。理推可尔有何文证

答。此经始未多有佛性之文。方便品云开佛知见既得清净即是一文。佛知见者谓佛性之异名。众生本有知见为烦恼覆故不清净。法华教起为开众生有佛知见。此即是佛性义。若无佛性者教何所开耶

问。若此经已明佛性涅槃何须复说

答。若已了悟者不须涅槃也

问。何以知至法华即了悟不须涅槃耶

答。大经菩萨品云。如法华经中八千声闻得受记莂成大果宝。如秋收冬藏更无所作。故知至法华时即知佛性已得了悟也。又过去二万日月灯明佛说法华竟便入涅槃。故知闻法华经已究竟悟。不须说涅槃也。又迦叶佛时虽有涅槃而不说之。故知法华是了义教。又寿量品云诸子有二。一不先心二者先心。不先心者其法华时并皆得道。余先心者待后唱灭方得领解也。晚见法花论明佛性义有七文。今略引二。初释方便品唯佛与佛究竟诸法实相。诸法实相者谓如来藏法身之体不变故。佛性亦名如来藏。故云隐名如来藏显名为法身。大经云我者即是如来藏义。次第二文释法师品。云知佛性水不违得成三菩提。此序方便品意竟

复次欲结束融会。释迦一化始终凡有七门。今三乘人未得悟者皆得领解故说是经。一者序叹中道法身门。谓如来法身无一切累具一切德。无一切累不可为有。具一切德不可为无。非有非无即是中道法身。是故经云如来于诸怖畏衰恼忧患无明闇弊永尽无余。此谓无一切累也。而悉成就无量知见力无所畏等此具一切德。所以明此二者。良以无患故能救物患。有一切德故济物无德。是以将明起化故前叹化本也。二者大悲门谓如来在法身地见二种众生起大悲心。一者昔曾受佛化而先观招苦。二者未经高道受三界煮烧。此二众生具一切患无一切德。故有佛所无无佛所有。为此众生起大悲心也。三者垂应门。既起大悲心故应入生死。为度物起八相成道。是故经云而生三界朽故火宅即其事也。四者实化不得门。既起大悲心为物成道。而初成道时即欲以大悲拔其有累大慈济其无德。但圣虽能授而凡不能受故息于实化也。五者权化得门。虽一乘化之不从。而大悲不舍欲渐引诸子故于一说三。谓权诱门也。六者实化得门。小执将倾大机欲动故会三归一。谓实化得门也。七者不虚门。许三与一似若相乖。以深见物机故无虚妄。谓不虚门也。束此七义可为六双。初一是自门后六化他门。自他一双也。前二是法身后五为应迹。本迹一双也。复五之中初一节非但释迦具斯七事。亦是舍那化即是释迦化。二佛一双也。复四之中初一顿化不得后三渐化得子。谓顿渐一双也。后三之中初一说三后二明一。三一一双也。后二之中初正明一次融会。一切诸佛教皆同然。三一不虚谓教及会教一双也。此释譬喻意果方便品末也

复次欲说如来十种大恩。今已悟之人心得坚明未解之者因此改执故说此经也。一者释迦过去初发心时结四弘誓愿欲普济六道。法华之缘已入斯愿是为第一通弘誓思。二者过去世时曾为此缘已说大法。而此众生曾高大化是为第二别结缘恩也。三者此无量众生罪重钝根背化起惑流浪六趣。菩萨随入生死方便诱化。乃至今种五乘种子。自从背化已后讫未成道之前。经无数劫随逐化之。是为第三随逐化恩。四者释迦虽久已成佛为此众生大机将熟起故更示成道。是故经云中止一城乃至脱珍御服着垢腻衣。谓隐本示迹恩。五者初成道时种种思惟方便救济。或欲现通或欲说法或劝或诫。同入一乘。但佛慧甚深众生根钝。虽有欲化之功而无从救之理。是为第五思济恩。六者子虽舍父父不舍子。故隐穷深佛慧至道而开极浅人天之乐。谓隐深说浅恩。故文云冷水洒面令得醒悟。谓成道已后鹿苑之前说人天教也。七者五戒十善暂息三途。次虚指二乘令出五趣。谓权诱恩也。八者虽以小乘摄化。而密欲以大法教之。故说波若付财之教。但根钝之徒犹未悟解。是为第八密化恩也。九者从波若已后法华之前中间说诸方等。现菩萨神变或说大士法门。种种方鼓动其情。令稍鄙小心欣慕大道。谓陶练小心恩。故文云复经小时即其事也。第十小志遂移大机将动为说法华。会父子天性。今二乘之人令入一道。现在受记未来作佛。是为第十毕竟恩也

问。何以知具十恩耶

答信解品云世尊大恩无量亿劫谁能报者。故总序释迦从初发意至于此会

始终屈曲积劫崎岖。有斯十种恩也。此序信解品意兼身子等领解文也。晚见论云。欲显佛乘与二乘异故说穷子譬喻。佛乘如长者尊豪。二乘如穷子鄙贱。此欲令已解者于大小坚明未悟者改三信一。与今释符会也

复次欲说所化人功德及能化人功德故说此经。所化人功德者如密云弥布其泽普洽。三草二木随分受润。虽随分受润而不觉知。能觉知者是为希有。如来慈身普覆法界等润五乘众生随分受益而不觉知。若能觉知亦为希有也

问。云何不觉知耶

答。有二种不知。一不知同二不知异。不知同者不知如来若形若教为开一道。不知异者不知五乘众生随根成异。如草木不知一云一雨谓不知同。不自知上中下差别谓不知异。今迦叶之流能知同异。今欲引叹中根之人述成其所领解故说此经。二者叹能化功德。今未解者开悟已晓者进德故说是经。故经云如来复有无量功德。汝等若于无量亿劫说不能尽也

问。如来复有何等功德说不可尽

答。上信解品云过去结缘今日相会。盖是一方之化未穷无方之迹。无方迹者。慈身法雨等益十方遍利三世。岂止此会三根人耶。又上两周之说及二领解皆明昔说三不说一。今说一不说三似若偏私。是故今明如来常等现身常等说法犹如云雨。但三缘自闻三一缘自闻一耳。故大经云常行一乘众生见三。以释成上二周教意故说此品也。又上信解品明昔始结缘终于今会。随逐根情崎岖屈曲。有若难心何能利物。是故今明如来若形若教犹如云雨。虽顺物崎岖无心屈曲也。又有人疑若大慈平等何故众生有得闻法有不闻法。如以威德力令五千之徒从座而去。是故释云天泽无私不在无根非佛大慈不平等也。此释药草喻品。晚见论破大乘人。自谓言无声闻明法雨普润。随根得果不应言无。此证上能化功德也。二示种子无上义。种子无上者如言汝等所行是菩萨道。明迦叶等曾发菩提心中忘斯意。今还发心行菩提道必当作佛。故是种子无上。此证上第一所化人功德义也

复次佛法有二种。一显示法二秘密法。显示法者谓三乘教明三种因得三种果故名显示。秘密法者谓三乘人皆得作佛。如释论第百卷云。法华明阿罗汉受记作佛故名秘密法。昔来已说显示法竟。今欲说秘密法故说此经

问。何故三乘行因得果名显示。三乘同作佛名秘密耶

答。显示法者方便教也。明三乘人各自行因皆得成果。此事易解。如外三种子各生三牙。其相易明故名显示。秘密法谓甚深法。明无三乘唯有一乘故名秘密

问。若尔者三因三果此是秘密。何以故实无三乘。覆相说言有三种乘。应是秘密。而道理唯有一乘无有三乘。应是显示。以非覆相说故也

答。若以了义为显示不了义为秘密者如后所判。今以浅近为显示甚深为秘密如前所明。此义后当广说也

问。何故授二乘说作佛耶

答。唯有一乘无有余乘。唯有一佛性无有余性。以皆有佛性故皆应作佛也。晚见论释受记文

问。声闻人为实成佛故与授记。不实成佛故与授记。若实成佛者菩萨何故积劫修行。若不实成佛将非如来虚妄授记

答。授声闻记者得决定心。非成就法故。如来依平等法说于一乘。平等法者以如来法身与声闻法身无异。故与授记。非即具足功德故与授记。菩萨具足功故与授记。依此论明佛性名为法身。故知二乘有佛性故与其授记也

问。若尔一切众生皆有佛性皆应授记作佛

答。不然佛性有二种。一正因二缘因。一切众生虽有正因无有行解等善故无缘因。无缘因故不得作佛。今二乘人内有正因外闻法华经生信解等善。即缘因缘正具足故得授记。二者授二乘记。即是说法华经法华经正明一因一果。今明二乘人已改二执发菩提心。今为授记令二乘人现世行因未来作佛。以发心行行即是一因。未来作佛即是一果。又其人即是菩萨复是人一。说此一教名为教一。故授二乘记。具说四一即是说法华经也。三者畅佛本心故授二乘记。何者明如来初成道时即欲开示悟入诸佛知见。但初成道时根性未堪。今如得记则畅佛本心。同大经心喜之义。四者授二乘记令诸菩萨不复退转。所以然者有二乘道可有退路竟无此理。何所退耶。又二乘是不作佛人今当作佛。菩萨本是成佛之人云何欲退耶。五者授二乘记。一切未发二乘心者皆不复发。所以然者以证二乘尚自舍之。我等未得云何欲求。以有斯益故授声闻记也。六者授二乘记故一切未改二乘执者。因此而改伊是罗汉。既得授记我亦无学宁不作佛。遂改小心欣求大道。故信解品因身子得记自序余解即其事也。七者授二乘记欲证一乘之旨不虚无三之言是实。所以尔者上来虽唱三权一实。若二乘人不得记者此言空设。今二乘之人受记作佛。故知一乘是实三权不虚也。八者授二乘记即是说净土法门。谓化主净国土净教门净徒众净也。所以具四净者以悟一乘改其三执故其心净。其心净故国土净。以此净悟悟一切众生。即是教门及徒众净也。以身子心净故佛说四净之教也。九者以时众闻二乘得记于净土作佛故化往生。以有此益故授二乘记也。十者欲证二乘所解是实故授其记。夫得记者必由实解故也。以有如此十种义故所以授二乘记。总释诸授记品竟

复次欲说诸佛二种法故记是经也。一说现在法二说过去法。上来二周已说释迦一期出世始终方便利益众生竟。今说释迦过去利益众生法门。故说是经也

问。何因缘故有二种说耶

答。众生有三种。一者上根二者中根三者下根。上中二根直闻现在说法已得了悟。今欲为下根众生令得受道故说过去始末法门也。二者为释疑故来。有人云应学二乘。所以然者。始行菩萨虽闻此经不得佛记。二乘闻经便得受决。若尔但学声闻不必须行菩萨道。是故释云。此等声闻于无量劫久行大行。但中忘斯意故作二乘。非作二乘即得授记。即是总释三根人得悟一乘因缘也。法华论云。决定声闻不得记。退菩提心声闻方得记。与此义相应。三者声闻唯有二种。一本学小乘二退大为小。譬喻品为本学小乘人。今欲为退大之人故说是经

问。何以知然

答。譬喻品火宅之中本有三十子。即三乘根性欲求出宅为说三乘。故知为本乘人也。化城所明本欲求佛中途懈退为说小乘。故知二譬为二人也。此就文讫。而义实通也。四者欲广叹如来智慧明久远。今二乘人心生欣慕改迷悟入故说是经。所以富楼那云复闻如来神通之力即其事也。五者欲显法华是古佛法。三世诸佛必皆说之。故云世尊法久后要当说真实

问。以何因缘故一切诸佛皆说涅槃耶

答。一乘是佛因缘。无有诸佛不说佛乘。但说一乘自有二种。一者直说一乘。谓一因一果。如华严之□流二者先说三乘后说一乘。即法华也。此二虽殊一乘无异。是故一切诸佛皆说法花涅槃教起但为斥无常病故常乐。若众生无有无常之病即不须明常乐。是故佛或说涅槃或有不说也

问。云法华文未说佛性之因法身之果。云何不须涅槃耶

答。不须说也。所以然者昔有五乘故有五性。今唯有一佛乘即唯有一佛性。故利根之人即知有佛性也。昔有五乘即五乘之果是无常。今唯一佛即佛果是常。故亦不须别说法身常也。但为释迦出于恶世间。一乘因果未悟故更广说涅槃耳。六者说过去事示生死长远。今二乘人深起厌心。汝于过去本求佛道。经尔时劫退住小乘。一何可愍。我已成佛汝应欣慕。二乘闻之遂发心求佛也。七者说宿世之事。下根闻之因得领解。说系珠之譬晓诸未悟。八者三说既周。广发权行之迹正令诸小行知菩萨难可思议。改志求佛也。以有如是八种义故说化城品也

复次欲说如实功德智慧故说此经

问。云何名为如实福慧耶

答。如实福慧者从实理生。以一乘是实故能生如实慧。实慧者。上三周说法生三乘信解授记作佛。今欲说如实功德。如实功德者谓受持读诵书写解说。如说修行生如实福难可格量。既信如实法得无过之福。毁如实法则获莫大之罪。今欲示众生如实罪福故说是经也。二者诸佛说法有二种门。一直说门二称叹门。上三周说法名直说门。今叹经力经用名称叹门。三者复有二门。一者一乘体门二者一乘功用门。乘体门者上已说竟。今欲说乘功用门故说是经。乘用门者谓能生福慧也。四者复有二门。一生慧门二生信门。上三周说已生慧门。余未信者今预经功德令生信心谓生信门。五者复有二门。一自行门二化他门。上来三周说法令三根人悟解故是自行门。今传化未闻谓化他门也。六者复有二门。一受恩门二报恩门。上来悟解是受恩门。今得悟之人传示未悟。助佛扬化谓报恩门。七者复有二门。一正说门二流通门。上来是正说门。今示弘经之方。谓流通门释此法师品兼释诸品。明功德事流通门也

复次欲显如来身方便身真实。故说此经

问。何等是身方便身真实耶

答。以法身为真实。迹身为方便。但本迹二身凡有四种。一者生灭为迹身。无生灭为本身。如多宝虽灭不灭。显释迦虽生不生。不生不灭名为本身。不生示生不灭示灭名为迹身也。二者明本一而迹多。如集十方诸分身佛。欲明释迦为本诸佛为迹。所以然者诸佛平指为迹。各以己身为本。当知释迦之与诸佛皆是迹耳。非释迦非诸佛乃为统一之本。故明本一而迹多也。三者举释迦及分身者。此就一佛明本迹义。如一佛法身为本而垂一切迹。四者以为多宝与释迦并坐者。欲表十方诸佛同一法身。皆同一法身故垂一切迹。摄大乘论明二种平等。一别平等。如一佛法身为本垂一切迹。二通平等。谓十方诸佛同一法身由来。或但执别先通或但执通先别皆非论意也。晚见法华论明多宝以现者示平等。故多宝如来已入涅槃复示现身。此显自身他身佛性法身平等。证四义中第四义及第一义也

问。若此品具明四种本迹义者寿量品复何所明耶

答。佛开本迹凡有二门。一神通轮门二说法轮门。神通轮开本迹者。从见塔品至涌出品现十一种神通以开本迹。一者涌出塔表佛犹存之义。二者住空表隐显无有滞碍。三者出声。或谓直是塔而已未足以表犹存之义。故须出声也。四者虽复有声密恐无形非是佛声。故开塔令身在其中矣。五分座同坐者。欲等生灭义往之等。今明双树之灭是迹而非真。今之等往明王宫之生权而非实也。六者集佛明本一而迹多。七者变土。迹身既非实身迹土亦非实土。释迦及化佛是迹身。别有统一之本。净秽二土皆是迹土非法身所栖。法身别处中道第一义土。八者接众在空表虚心乃见法身。九者发调达之迹以表丈六为权。调达非恶示恶。类释迦不生现生。十者显龙女成佛。昔女身不能现身成佛。今遂能成佛者。昔明如来身非常住今始明佛身是常。十一明下方菩萨地覆不现地裂方显。昔教覆故未显法身。今教始开故得明也。此十一种皆是神通门。以开本迹也。二从弥勒之问释迦之答。就说法轮以开本迹也

问。初段开三显一辨教之权实。何故但就说法轮。今就神通轮耶

答。教之权实但是说法。轮身之本迹属神通轮是故后门就神通轮。故下文云汝今谛听如来秘密神通之力。又云神通力如是于阿僧祇劫也。又如大经开法身密广明神通。开波若密广明说法。今亦然矣。又前现通即是密开本迹。后说法身即是显开本迹。要前密开后方得显开也。又密开本迹生物之信。显开本迹生物之解

问。辨本迹身何故具就二轮及显密耶

答。以果德甚深绝因位境界宜就二义也。又前开三显一中亦有显密。广说为显略说为密。又前现塔虽表法身是常。未辨为始证法身。为久证法身。故寿量广明近远之义。明无量劫来久证法身。又前开三显一中亦有总别。初总明诸佛二智次别明二智。今开近显远亦具总别二义。见塔品总明诸佛本迹。寿量别明释迦二身。又前直明法身后品广释疑难。又前但明法身未辨三世益物之用。后品广明益物义也。又诸佛随俗凡有二种。一者身二者命。前明法身常住后明寿同太虚。又前明无生灭后辨无始终。无始终者逸多不见其始。补处岂测其终也。此总序宝塔品及寿量品竟。晚见论明三身具足岂非辨常之明据耶

复次欲说菩萨要行故说是经

问。何故说菩萨行菩萨行有几种耶

答。菩萨有四种要行如前说也

问。何因缘故明菩萨行

答。上以三周开权显实破三乘执即是发菩提心。发菩提心竟应修菩萨行。如华严善财童子。于一一知识所皆云。我已先发菩提之心。而未知云何修菩萨行学菩萨道。故次发心即是明修行也。二者说菩萨行即是说法华经。法华经正明一乘。一乘即是菩萨行。故就菩萨行明一乘。故此经云教菩萨法佛所护念也。三者上来自说及证说即竟。欲示弘经模轨。模轨即是四行。故说菩萨行也。四者为封言之徒闻上开权显实明一辨三。便谓有三一有开有合。是故今明菩萨行诸法实相。无上中下非一非三非开非合。三一开合皆是方便化物。故说菩萨行。五者有人欲求佛道畏惮生死。多诸患难故退菩提心息诸断行。今为此人故明菩萨有四行令身心安乐。其人闻已坚固不退。故说菩萨行。六者欲发起如来寿命之果。故说菩萨行。下品明如来有不可思议之果。所谓生灭自在无碍。如此妙果必由妙因。是故今明菩萨行。即是妙因也。安乐行品竟

复次欲广说诸菩萨智慧功德宣通此法拥护众生故说是经。如说药王妙音观音乃至普贤等功德智慧等

问。何因缘故说诸菩萨功德智慧耶

答。一乘有二种。一者诸佛大人之所乘故名为大乘。二者诸大菩萨之所乘故故名为大乘。如十二门论所辨。上说如来寿及佛知见等是诸佛大人能乘所乘。今欲明诸大菩萨之所乘故故名大乘也。二者说诸菩萨功德智慧不可思议。令二乘人深生愧耻弃彼所宗。则未发二乘心者不复发心故说菩萨行。三者凡夫二乘已发菩提心者修菩萨行。已修菩萨行者宜解行增进故说菩萨行。四者净名经云。或以诸佛而化佛事或以菩萨而作佛事。佛事不同受悟多种。上来明佛作佛事竟。今欲明菩萨而作佛事故说诸菩萨行也。五者欲叹此经功力故说诸菩萨行。诸大菩萨有不可思议功德智慧者皆由法华之所成就。若欲得如此功德者当行法华经也。六者欲开秘密藏故说此经。声闻法中说诸菩萨乃至一生补处菩萨犹是凡夫未断烦恼。今明大乘法中诸菩萨得无生忍。烦恼清净具六神通。出一切声闻辟支佛上。令种种方便分形六道。利益众生故说菩萨行。七者欲为利益未来一切众生。令得受持妙法华经。使无留难。佛虽去世诸大菩萨常在世间利益一切。欲求请护无愿不从故说菩萨行。此总释药王等诸品也。晚见论云。欲明护众生诸难力者故说观音陀罗尼等品。示现功德力故说妙庄严王品。依过去功德彼童子有如是力故护法身。故说普贤菩萨品。此释与今略同。如是等观诸品中意故说妙法华经也。释论第百卷云。法华经无量无边如大海水。以文无量义亦无量。故知说法华经因经亦复无量。今但略说也

问。何故不次第论二十八品耶

答。释经文流通次第说之。今但序其宗要耳

问。依何论作说耶

答。大智度论云。观诸品中意故明说波若因缘。今还依论意故作此释。释论是解经之模轨。欲释大乘经者必须影之也

法华玄论卷第一法华玄论卷第二

        胡吉藏撰

第三释名

具存梵本应云萨达磨分陀利修多罗。竺法护公翻为正法莲华。罗什改正为妙余依旧经。远公双用二说。加以多名谓真法好法等也

评曰。什公改正为妙者必应有深致。今当试论之。正以对邪受称妙以形粗得名。以九十六术为邪五乘之法为正。斯则正名劣也。五乘虽正犹未妙极。唯有一乘最为无上。则妙名为胜。故改前翻用后译也。颂曰是乘微妙清净第一胜二乘也。于诸世间为无有上出人天乘也。故对彼粗乘以佛乘为妙矣

问。妙有几种

答。略明二义一相待妙二绝待妙。相待妙者待粗说妙。绝待妙者非粗非妙不知何以字之。故强名为妙

问。何故立斯二妙

答。至人善巧一往对粗说妙。封执名者谓道乃非粗理应是妙。是故次云待粗说妙未是好妙。所以然者虽复绝粗犹未绝妙。若非粗非妙粗妙两绝乃名为妙也。绝待之目起自于斯。观公经序云。寄花宣微而道玄像表。称之为妙而体绝精粗。颂曰是法不可示言辞相寂灭。二乘所以息虑补处所以绝望。唯佛与佛乃能究尽

评曰。观公冥同今意也。难曰。详此释者唯明果妙。乘通因果者不应偏执。答以理言之唯果妙耳。因乘未极则非妙也。但因学果行故随分说妙耳。有人但以因乘为妙者未究妙源也

次明二妙一开三显一以明妙。二开近显远以辨妙。此是一经之宗领。故就此以明妙即释第二法字也。就二中初总论十对次别详因果。此义若成则名为妙。如其不成便非妙也

总论十对者

问。此言妙者。佛果为是常故言妙。为未是常故言妙

答。光宅云公言。犹是无常。所以然者教有五时。唯第五涅槃是常住教。四时皆无常。法华是第四时教。是故佛身犹是无常。又此经自说无常如下文言。复倍上数虽复称久终自有限。故知无常。又药草品云终归于空。终归于空者既是无常终入无余也

问。既是无常为是了义为不了义

答。此经明一乘了义辨无常不了。故亦了亦不了也

评曰。此经开方便门示真实相。开二种方便示二种真实。二方便者谓乘方便身方便。二真实者谓乘真实身真实。若尔前开三乘是方便一乘是真实。既是实说名为了义。后开身方便身真实。云何未是实说为不了义。若同是方便真实。以后为不了义则前亦应然。又同是方便真实。以前为了以后为不了。亦应以后为了以前为不了也。又同是方便真实。以前为了以后为不了。则前分是满教后分为半教。前分为深后分为浅。有颠倒过也。今所明者依佛口说。初段明乘之权实后段明身之权实。乘之权实谓究竟乘。身之权实名究竟身。若言乘权实为究竟身权实不究竟。是人但信初分经不信后分经。故信不具足。大经云于十二部中唯信六部不信六部。斯言验矣

第二明因果义。旧云初开三显一以明因。次开近显远以辨果。依旧判者因亦满亦半。果则唯半不满。明会三归一故一乘究竟为因满。但明缘因未辨正因。故因不满。明果虽有近远之异皆是无常故唯半不满也

评曰。此释二失。一者云初段明因后章辨果。是义不然。昔明因三果三今辨因一果一。何得开三显一但明因耶。若今日明一唯是因者则昔明三乘事亦应然。又明今一佛果乘究竟。明昔三因三果皆不究竟。正引物果一。云何乃明因耶。此义文中已说。二者若言初段明因了后章辨果未了。即因胜而果劣因深而果浅。是义不然。又因异声闻果同罗汉。所以然者会三归一故因异声闻。犹是无常故果同阿罗汉。又以今一因感无常之果。亦应以昔二因招常住之报。不可以三乘因得常住果者。亦不可以一乘因得无常果。又因满果半则因非果因果非因果。故非因果义也。今所明者对破二失以明二得。初段开三显一。一者通因果。故昔则有因三果三。今则有因一果一也。二者此经辨究竟之因圆满之果。会三归一之因。因名满因。开近显远之果。果名圜果。故因名果因果名因果也。又因具二因故因满。一者正因谓佛性。二者缘因即万善如前说也。果具二果一迹身果二法身果也

第三辨三德。初段经明权实二智即是般若。后段辨本迹名为法身。此二无累称为解脱。是故斯经三德斯备故名为常

问。大经可有三德此经云何亦明三德耶

答。此经明一佛乘因一佛乘果。一佛乘因因具万行。一佛乘果果具三德。二乘之因因不具万行。二乘之果果不备三德。若果不备三德则果不异二乘。因不具万行因不异二乘耳。岂可然乎

问。何以知初段明般若后段辨法身

答。般若是口密法身是身密。如四相品说。前明智之权实故是般若。后辨身之本迹故宜明法身。解脱者斯二无累即解脱也

第四对二缘。初辨智之权实对声闻说。今明身之本迹对菩萨说。对声闻说。身子为小中之极。大小交接故反小以归大。对菩萨说弥勒为因行之极。与法身相邻故反因无常令证果常。若法身犹是无常。则因果同位。因人复何所学耶。又因亦无常果亦无常。则因位之人能测果德。慈氏复何所疑耶。今所明者前对小人说大令小归大。今对无常人说常令无常人证常。又小劣而大胜故说大。以引小令小慕大。无常劣而常胜故。说常以引无常。令无常者以慕常。故有二教二缘两段差别。若法身无常者教无引缘之能。缘无欣教之理也

第五明双治。初段明一乘。异昔三乘。故以三为病一为药以一斥三。后章明今常。异昔无常。常为药无常为病以常斥无常。故有今昔药病相治也。若后段犹明无常者。但有前治无后治也。则前病得消后痾不遣也

问。明果亦异昔也。昔明八十或七百僧祇。今云复倍上数。岂非异耶

答。虽言复倍终是无常。但短长为异耳。若终是无常终无后治也。若言昔是短无常今是长无常。终是无常者。亦应昔日粗三今日妙三。终有三也。若三一相对昔三合不三。亦应常无常相对昔无常今不无常也

第六举二地。对两生死。前会三归一则免于二地。人天乘入一乘故离凡夫地。声闻缘觉入一乘故离二乘地。离凡圣二地故发菩提心。渐渐修行入十信十住十行十回向十地乃至等觉。此则因义圆满也。果若犹是无常则未免二死。若未免二死则未度五百由旬。若已度五百则已免无常。又若果未免二死则果未圆。若果未圆则十地因亦不满。辨因之义亦不成也。今所明者。初段令一切众生离凡夫二乘之地发菩提心。乃至修行菩萨行至乎等觉。后章明果永除五住。具倾二死故果义圆。以因满果圆斯经究竟

第七明二妙。初段明一妙后段明常妙。初段明一妙者以道无有二故名为一。如华严云。一切无畏人一道出生死。但一道有二种。一者无九十六种之异故言一。二者无五乘之异故言一。无此二种故言一道。以不一故则便乖道。名之为粗。道无二故称之为妙。故初段正示一切众生一道清净也。第二段示一道是常者。虽知一道清净但未知一道为常无常。故次明一道是常。以道是常所以为妙。如来是证一道之人。以道常故诸佛亦常。以道妙故体道之人亦妙。以道一故体道之人亦一。故十方诸佛同一法身。所以然者。非道既是无常。道亦无常者。道与非道竟何异耶。若如由来说者。但有一妙无有常妙。妙义不足故不名妙法华也。又一道是常故一可称妙。由来明一犹是无常。故一亦非妙。若尔非但无常妙。亦无一妙。既无二妙但有二粗。今明唯一正道。随义说之。以至极无二故名为一。体非生灭所以是常也

第八明三引。释迦一化始终凡有三引。法华之前谓引邪归正。佛未出世有二种邪法。一者九十六术出家外道。二者一切世俗在家众生。此二种虽异并非佛法故名为邪。如来出世引此二邪归五乘正法。此二种人中有无闻非法者。以人天善根而成熟之。有三乘根性者以三乘法而化度之。故引此二邪归五乘之正。二者引异归同。法华之前虽免二邪仍执五异。是故引于五异归乎一乘。即初段意也。第三引因归果。五乘虽入一乘犹是因位。故引因归果令证法身。如声闻领解明十信之始。弥勒疑除辨十地之终。引此始终二因归如来究竟法身之果。此三引无教不收无义不尽。非止局释迦乃贯通诸佛。已以三引究竟故名圆满之经。即是了义常住。又三引究竟。是故下品明多人得道。自法华之前但有初引未有二引。故得道者少也。若后段犹明无常。但有二引无有三引。又但有引声闻无有引菩萨。以声闻不信一今令入一。故引声闻。菩萨与佛同是无常。云何引菩萨耶。又亦不得引声闻。所以然者。诸佛及弟子声闻缘觉众皆是无常身。云何得引之。又佛若无常令二乘人而起退心不复求佛。又三乘犹是无常名为半字。大经云为声闻说半字。此经正教菩萨。云何说半字耶

问。三引究竟何故复说涅槃

答。诸子有二种一不失心二者失心。不失心子闻三引究竟皆得领悟。余失心子闻三引不悟。故方便唱灭为说涅槃方得受道也。若尔涅槃最为钝根人说

问。涅槃为钝根人说者应浅耶

答。教非浅也。但于缘悟故转势说之。如犹是一药。不失心者前服失心者后服。犹是一正道。利者前悟钝者后悟。涅槃法华更无异也

问。涅槃为最钝根人说者何得经云为人中象王迦叶说耶

答。须识二缘。一历教不悟缘。从见佛初生乃至闻法华不悟者名历教不悟缘。此是最钝根人。至涅槃方悟也。二者前已得悟今至涅槃更复进悟。如迦叶等大利根人。为此人故说涅槃也。又有根缘不闻前教直闻涅槃。即具足识如来究竟因果名大利根人

问。历闻前教得悟何故是钝。直闻涅槃领解云何为利

答。历闻诸教从小至大从浅入深。故为钝。直闻究竟而悟名为利根也

第九辨三轮义。初段开三显一谓教权实名说法轮。次章辨开近显远名神通轮。说法轮谓始终一切教。一切教虽多不出权实。五乘即权教一乘即实教。昔则开一为五今收五归一也。神通轮谓始终一切身一切身虽多不出本迹身。始生终灭前凡后圣名为迹身。无始无终不生不灭名为本身。昔则以本垂迹故隐本为显迹。今则以迹显本废迹而明本也。他心轮者通贯二教二身也

问。法华之前亦有三轮义不

答亦有三轮。但说法轮未开教之权实。神通轮未开身之本迹。今始俱开故与昔异也

第十明二说。一者直说。二释疑成前说。直说者初段明无九十六种之邪异。亦无五乘之正异。三世诸佛唯有一道也。第二段成前说者。道虽无二若犹是无常。还同九十六种道。亦还同五乘之道。不名一道。今明九十六道自是无常道。今明一道是常道。五乘之道谓无常道一乘之道方是常道。故举常道成前一道也

次别明因妙义。旧云此经但明缘因成佛未明佛性正因。故因亦未妙。评曰。前已略说。此事不轻今当广说。此经对粗言妙形三辨一。昔有三乘则有三性。今唯一乘则唯一性。盖是数之然也。若乘一而性三盖是数不然也。今请难之。若乘一而性三者性既有三。则众生或有成佛或有不成。所以然者有于三性无有一性。是故或成或不成。若尔者何得经云一豪之善皆成佛耶。又若今无一乘性而成佛者。昔应无三乘性而成三乘也。又昔有三性有成三之理。今无一性无成一理。又无一乘性而成一者。等无三性何不成三。又至法华虽明一乘犹有三性者。则乘一而性三。若乘一而性三。则昔乘三而性一。不可乘三性一岂得乘一性三。又乘一性三即事相违。智人不信。譬如唯成一味复云乳有五性。乳有五性者岂唯成一味。若成一味云何复说性五。微识盐梅少异木石。不说此言言尚不成。义何犹立。若言今教无有三乘性。异昔有三性者。亦应今教有一性。异昔无一性。盖亦是数然也。若言今明无三性复明无一性者。既无三性不成三乘。若无一性何犹成一。若言佛不说有一乘性复不明无性。但覆相说一乘成佛者。此无成佛因缘。何由得成佛。夫论成佛者必有其义。众生有作佛理可成佛耳。不明有理无理何由成耶。譬如不论黄石有金无金而忽令人炉冶。事所未闻

问。此经下云人天两足尊知法常无性。既言无性岂得说一乘性耶

答。此明破性执耳。又破外道及小乘人因中有性义。若如大经佛性之性岂得言无耶。又难曰。既其无性亦无别佛种异三乘种。今遂有别种异五乘种。何故无别性异三性耶。若言万行为种无有性者。此之万行既无有性何必成佛。又一行无佛万行亦无佛。万行既成佛者一行亦无何不成耶。龙树云泥中无瓶而出瓶者。指端无车马饮食何不出耶。又若言恐昔我执未除故不说佛性者。何不畏今不得成佛而说有性。不应观前则怯望后便勇。以众事推之必知。应明佛性又应说佛性。所以然者。佛性是佛乘本。由有佛性故假缘显之。而但明缘因不说本性。则舍本攀条为不黠也。又天亲释金刚般若已明佛性。况法华而不说。又成道五年说如来藏经明有佛性。况法华未明。若言此非次第教故不应引之。可言金刚般若复是无方说耶。若言天亲等不足信者。五时是慧观所制。四宗是光统著述。何由则受。逆圣顺凡良所未喻。若言无文佛性之说故不用者。涅槃华严无梨耶之文则涅槃华严应未明八识。故不可即就一经令备一切教。则唯有一部八方何施。以有佛性故修行成佛。是故为妙。若无佛性则不成佛故非妙也

次别论寿量。旧云从大品至法华皆无常。汝以何义证法华常耶

评曰。今以三证。一法华前经证。婆数作金刚般若论云。三相异体故离彼三相是如来。此明生住灭三相与法身异体。离彼三相是如来一法身。则知金刚般若已明常义。况法华在后而是无常。若法华在后而是无常者。则般若为胜法华劣也。大品常啼品云。诸佛色身有来去法身无来去。则明法身是常。况法华耶。小品经分明辨法身不可迁灭与大品同意。第三净名经云佛身无漏诸满已尽。佛身无为不随诸数。此二句具足解如来常身

问。此二云何具辨法身

答。佛身无漏者子结断也。佛身无为不堕诸数者果缚断也。子果既断岂非常耶。又佛身无漏故异凡夫身。佛身无为异二乘无常身。是故佛身常恒无有变易。又佛身无漏五住皆倾。佛身无为二死俱离。此异菩萨身。菩萨从初发意至金刚已还。一念无明未断犹名诸漏无常。苦报犹在不名无为。佛已离之故是常也。又佛身无漏不可为有。佛身无为不可言无。非有非无即是中道法身故名为常。若是二边则名无常也。又佛身无漏即是解脱。佛身无为谓法身般若。但点虽有三不出得离以具三德。是故名常。又佛身无漏名之为空。佛身无为名为不空。故大涅槃具空不空义。即是常也。净名尚辨法身是常。况法华耶。又净名云诸仁者此身无常当乐佛身。既言此身无常当乐佛身。佛身犹是无常与己身同何所乐哉

问。净名序说明常耳。而未是经正宗也

答。此是愚人问也。领是净名所说皆是净名经宗。云何言非正宗耶。故肇师云。始自净土终讫供养其文虽殊不思议一也。又既非经宗即与宗相害云何说耶。又净名有二处四会。二处者一庵园处二方丈处。四会者佛国品庵园初会。方便品方丈初会。问疾以去方丈重会。菩萨行品以去庵园重会。若尔方便品是室内说之云何言非经正宗耶。又若净名经序与正说相违。则余一切经悉应然也。又子夏之序诗元凯之序传皆应乖正经也。次引法华文证三说三领解以明之。方便品明一种说。一广辨教之权实二略明身之本迹。如云唯有一乘法谓实教也。方便说三乘谓权教也。我始坐道场谓迹身也。从久远劫来赞示涅槃法谓本身也。身子还领二事。初文领解教之权实。次云如今者世尊从生及出家得道转法轮。亦以方便说。此领身本迹也。既言从生出家是方便迹身者。则不生不灭为实身也。既以生灭为迹身。迹身是无常无生灭为本身。本身则常斯一说一领也。次譬喻品明三车为权教一车为实教。如来已离因果诸患具一切德。谓法身也。而生三界朽故火宅谓迹身也。又云是时长者在门外立谓法身也。惊入火宅谓迹身也。迹身在三界八相成道故有生灭。本身出三界外故是无生灭也。信解品还领二事。一使谓实教也二使谓权教也。长者严饰谓本身也。脱珍御服着弊垢衣垂迹身也

问。此明本迹诚如所言。云何用此证常无常

答。今请问。长者眷属围绕为是法身为是应身。若是法身云何而有眷属围绕。出内取与复云何言中止一城。是释迦应身者脱珍御服着弊垢衣复喻何身耶。今所明者长者严饰即舍那身。出内取与谓舍那教。若尔舍那形教蕴在法华之中。法华教岂不说常耶。复云何言是半字耶。若法华是无常半字教者。舍那佛教义亦应然

问。此中何处有法身常文

答。中止一城既是应身。中止之前即是法身。故以法身垂舍那之迹。则法身是常也

问。释迦教中何处有三身文

答。像法决疑经云或见我身为舍那。为百千释迦围绕。或见我身满虚空即法身。或见丈六即应身也

问。但应领解二身。何故此经领解三身耶

答。此经领解一化始终故具领三身。三身别自有科。第三周亦具二事。教权实易知。如云我于余国作佛更有异名。此即明身之本迹也。领解中略而不陈例上可解

问。若尔三周具明形教寿量。何繁说耶

答。二周教广身略后周身广教略也。又初周举二身为成二教。后周举二教为成二身。次就二涅槃证即是。略释涅槃义就大小涅槃凡有三异。一者本性寂灭非本性寂灭异。二断三界内外惑异。三者具众德不具众德异。本性寂灭非本性寂灭异者。方便品云我设是方便说诸尽苦道示之以涅槃。是亦非真灭。此明昔方便涅槃也。诸法从本来常自寂灭相。佛子行道已来世得作佛。此明今教真实涅槃

问。此二涅槃有何异耶

答。文中已明竟也。但有人谓此为一乘文非涅槃也。今明不然。经文正对小涅槃明大涅槃。小涅槃为方便大涅槃为真实。故前句明非真实后句明真灭

问。此二涅槃云何开权实耶

答。如经自说小乘人灭烦恼故名小涅槃。大乘中云诸法从本来常自寂灭相故名大涅槃也

问。灭烦恼何故名小。本来寂灭云何名大

答。小乘不知烦恼及身本自不生今亦无灭。故见有烦恼生今欲灭之。是生灭观故名为小。大乘人知烦恼本自不生今亦无灭。以无生灭观故名大涅槃也

问。以何亦证小乘人不知本不生今不灭耶

答。即前文为明据义可知也。又释论云。大乘空门者。谓一切法自性空自相空。小乘空门者即折法明空。摄大乘论云小乘人不知诸法性空。故不得法无我真如也。又净名经云。佛为增上慢人说断三毒名为涅槃。若无增上慢佛说三毒即是涅槃。三毒即是涅槃者。三毒本不生今不灭。岂非即是涅槃耶。又法华论释二乘与一乘有无义。明无有二乘涅槃唯有如来大涅槃。故知此经辨涅槃与小乘异。若尔身岂同昔耶。第二明小乘涅槃与大乘涅槃异者。譬喻品小乘人但离虚妄名为解脱。其实未得一切解脱。三界子果名为虚妄。二乘脱之名得解脱。一切解脱者三界内外一切子果并皆离之名一切解脱。故大小涅槃短长义异也

问。小乘灭三界子缚名有余。灭三界果缚名无余。大乘复云何

答。灭三界内外一切子缚尽名有余。灭三界内外一切果缚尽名无余

问。小乘先得有余后入无余。大乘云何

答。即一时也。障佛无明既断无常苦报即净。故二涅槃一时也。出摄大乘论也。第三明大小涅槃异者小乘涅槃不具众德。大乘涅槃具足众德。如信解品云我等长夜修习空法。得脱三界苦恼之患。小乘涅槃无身无智故名为空。唯有法无人故名为空。大涅槃者具足身智及以人法。故信解品云无漏无为诸法之王。此文含一切义。无漏故谓解脱德。无为故具法身般若德。无漏无为即是法也。诸法之王即是人。故知如来之身无漏无为即是涅槃人法具足。信解品未具释此义也。又譬喻品明如来涅槃异二乘涅槃。义如云。皆以如来灭度而灭度之。不令有人独得灭度。此明大小二灭异。即是果果异也。又云是诸众生脱三界者。悉与诸佛禅定解脱娱乐之具。此明佛众德异。二乘德即果义异

问。大经何故先明果后辨果果。法华文前明果果后辨果耶

答。摄大乘论明佛二果与法华同。而两经异者。法华为小乘人保灭为正。欲以大灭代小灭。如以大车代小车。故先明大灭。小乘人不以余德为贵后明余德也。大经云欲叹涅槃故铭涅槃是果中之果居最后也。又此二实无前后。但约义分之耳

问。举二涅槃异欲何所明耶

答。欲例显二身异也。大小二涅槃既异。大小二法身亦异。小乘五分法身是生灭无常身。大乘法身谓无生灭常身也。若此经明法身犹是无常者。亦应此经明涅槃不异小乘也

问。此经明涅槃与昔不异。何以知然。此经明佛既是无常终入无余与小乘同也。又初品云佛此夜灭度如薪尽火灭。故知与小乘不异

评曰。此是大事宜请详定。前引方便品及譬喻品。佛口自说大小二涅槃为异。何故违反佛语而言不异。如此即是无信人也。又难曰。若大小二乘同一涅槃则因异而果同。是事不然。又大小乘本期在果。在果既同何须因异。今所明者二因异故二果亦异。无复异因终归一因。无复异果终归一果

问。此经云佛此夜灭度如薪尽火灭。此是小乘灰断涅槃。云何言是大乘涅槃耶

答。言薪尽火灭者感以为薪应以为火。故感尽而应息耳

问。何以知然

答。寿量品云以方便力故说有灭不灭。岂同二乘灰身灭智云如薪尽火灭耶。又感尽应必灭。盖是数之然也。大经云诸佛法尔有为亦然

问。有人云诸法从本来常自寂灭相。此明一乘寂灭三乘之相。汝今何故以配涅槃耶

答。此是人情义耳非佛义也。佛经前偈明非真灭后偈辨真灭。云何将配一乘义耶。若以此文明一乘无三相者。前文应云三乘非真灭。不应言涅槃非真灭也

问。今正明三乘一乘云何乃解涅槃耶

答。正以涅槃异故分三乘一乘异耳。良由一乘涅槃是真灭三乘涅槃非真灭。故一乘是真乘三乘非真乘耳。若不以涅槃异以简三一者。复用何物简耶。讲经者多迷此处希熟观文也。复有人言诸法从本来常自寂灭相者。初段开三显一。未得说言宝所涅槃。故且用大品实相涅槃故云本来寂灭耳

评曰。是亦不然。若摄大乘及地论正明自性清净为大乘涅槃。即是今文本来寂灭相也。彼论既释究竟涅槃。则知法华辨圆极真灭

问。众人何故皆暗而子独明乎

答。初释以五时局。后解将二段判。不细寻文故失其妙旨也。次引关河旧说以证常无常义。昔竺法护翻旧法华犹未见判其宗旨。自罗什所译新本长安僧睿法师亲对翻之。其法华序云。以寿无量永劫未足以明其久。分身无数万形不足以异其体。然则寿量定其非数。分身明其不实。普贤显其无来。多宝证其不灭

评曰。睿公亲承罗什制斯序者。即明常其明证。盖是法华宗本不得不依之矣。次河西道朗对翻涅槃。其人亦者法华统略明说法华经凡有五意。第四意云。为明法身真化不异存没理一如多宝品说。而群生不解为显此义故说斯经。又云多宝塔现明法身常存。寿量品明与大虚齐量

评曰。道朗着涅槃疏世盛行之。其所解法华理非谬说。明常之旨还符睿公。道场慧观云。同往之三会便归一乘之始也。灭影澄神乘之终也。灭影谓息迹澄神则明本。故迹无常而本常

评曰。还同睿公义也。次注法华云。非存亡之数曰寿。出修夭之限称量。明法身非形年所摄。使大士修践极之照。不以伽耶而成佛百年为期颐也

评曰。注释犹是明常而意极清玄也。何者既云非存非亡。即是不生不灭不修不夭非常无常。与涅槃经明法身绝百非不异也。次竺道生云。夫色身佛者应现而有无有实形也。形既不实岂有寿哉。然则万形同致古今为一。古亦今也。今亦古也。无时不有无处不在。若有时不有有处不在者。于众生然耳。佛不尔也。是以极决长寿云伽耶是也。伽耶是者非复伽耶。伽耶既非彼长何独是乎。长短斯亡长短斯存焉

评曰。道朗僧睿但明常义耳。生公注经明非常非无常义也。常无常皆是斥病对治悉檀耳。第一义悉檀即是法身。法身岂常无常等五句可取耶

问。药草喻品云究竟涅槃常寂灭相终归于空。岂非终入无余舍无常身智耶

评曰。光宅此言不识文意也。若云此经明涅槃空即是灭身智者。涅槃云大涅槃空可得然耶。又若身智终无常者与二乘竟复何异耶。今明药草品分明有二究竟凡举两果。一者初文云究竟至于一切种智。此举智果究竟。显二乘人智不究竟也。二者云究竟涅槃常寂灭相。终归于空。此举断究竟。显二乘人断不究竟既明两义。是以前后开二文也。以后明断究竟故。所以涅槃空无诸相

问。何以知举果及果果耶

答。譬喻品合大车亦举二果皆以如来灭度。灭度谓果果也。诸佛定慧谓果也。佛德虽多莫出斯二也。又龙法师为法华之宗。其人云。大涅槃空无诸相。又云空无烦恼。与今意同也。印法师云终归常住第一义空。忠法师云终归第一义空智慧也。又有人云佛果无累故空。注经云空有同尽乃名为空

评曰。前法师皆云常住空无相。或注经意迥越前判。谓空有俱绝故名为空也

问。既言寿量岂是常耶

答。若尔称无量寿应是常也。阿弥陀经云无量寿既非常者。今明寿量岂无常耶。今明有四句。一者实有量叹美长远故言无量。如阿弥陀经。二者实无量欲明量齐大虚故言寿量。即此经也。金光明亦尔。三者实无量而言无量。如大经云唯佛睹佛其寿无量。四者有量而言有量。如言释迦寿八十也

问。若此经明常何用涅槃耶

答。前已说竟。法华已明一乘胜鬘复何用明一耶。大品明空解诸般若复何用明耶。又若尔者第三时但有维摩明抑扬。思益应无用耶

问。二经明常者有何异耶

答。此经直明二义。一者教权实二者身真应。略开斯二众便解了。大经广明四德三点缘正二因。故与此经语异意同也

问。汝虽种种门说佛是常。此就道理明是常耳。而此经文佛口自说无常。不应违经明是常耶。如经云复倍上数终有限极。故终是无常也

答。此经明久已成佛。斯久已证常。证常之时尚非补处所知。今言复倍上数者证常已后。此岂可知。穷学不知则唯佛睹佛其寿无量。是故常也。又复倍上数者欲叙佛无始终义也。前明久已成佛而逸多不见其初。明无始义。今言复倍上数弥勒不见其后。明无终义

问曰。何故明无始终

答。见宝塔品亦因事密表不生灭。今假微尘譬明无始终。以身无生灭异凡夫二乘之身。寿无始终异凡夫二乘之寿。以凡夫二乘之身为生灭所迁。寿则有始成终尽一期所坏。故如来身不生灭寿无始终也。又肇法师涅槃论正明此二义。六趣无以摄其生。力负无以化其体。谓无生灭也。随之不得其踪。迎之罔眺其首明无始终。肇公不见涅槃华严。还采法华般若以作斯论。故与经意符也

问。此但经明成佛久耳。云何是无始终耶

答。今请详经意。若但明成佛久者于缘竟有何益耶。所以然者。始成之与久成皆是无常。今开久成竟有何利。今深取佛意者。昔明始于伽耶终乎双树。故是无常之寿。补处不见其初穷学不知其后。唯佛睹佛其寿无量。考斯文旨岂不允哉。三省愈彰再思已决也。故法华论云。复倍上数者示现如来常命。方便显多数过上数不可知故也。余见此文悲喜交至也

又问若以近成为方便以久成为实说者。法华明久成此实说。华严辨始成正觉便是方便。未可然矣。又大经云我闻半偈超弥勒九劫先得成佛。今请问之。超九劫者为是实说为是权教。若是实说者则法华为方便。又若超九劫为实说者诸小乘经论明超九劫。若尔三藏为实教法华是权经。若言法华明久为实。大经明超九劫为权者。则法华为实涅槃为权。又法华已开近云何涅槃更覆远耶。若近远两经回互者。三一之教义亦应然

又问若法华开近显远。明久已成佛为本近成为迹者。何故常不轻品更覆远明近隐本辨迹耶

不应一经之内前后相违。若一经之中本迹或覆或开。则三一或会或不会也。又若此经为明久已成佛实说者。则初开三显一诸佛共同。开近显远则释迦独有也。若言此义为例者。下分别功德品诸菩萨皆发愿。愿我于未来说寿亦如是。岂得言释迦独有开近显远而余佛无耶。以此众事详之。但知是寄无始终以显法身常义。有始终者皆是应迹。以此义通上诸经无一豪滞也。此义难明。本迹义及寿量品文更广论之。又设以复倍上数之言证无常者。经有二文前文明寿命无量阿僧祇劫常住不灭。后明复倍之言。若以后说为无常者。何故不以前证为常

问。何故前后相违耶

答。后文举因说果。明行菩萨道时所得寿命于今未尽。况得佛寿命而可尽耶。如在太子之位资财犹尚未竭。况登天子之位俸禄可尽耶

问。云何因中寿命不可尽耶

答。从十信至十地位。行既深则寿亦无量。况法身之龄而可竭尽耶。又必是无常而说是常者。此依道理则应获福无边。以佛说教本为显理故也。若是常住而言无常得无量罪。如释论云实无十方佛敬言有者则得福也。实有十方佛而言无者则获大罪也。今明是经究竟法身。百非不非百是不是与大经及华严不异。尚不可言常岂可言是无常耶。故名果妙。以此因果妙故名为妙法。次释莲华义。有人言外国名分陀利。此间翻为莲华。莲华有四色简三取一。谓白莲华名分陀利。白者诸色中本亦是喻白净平等慧

问。何故佛眼喻青莲华

答。青者喻佛眼色取相似为喻。白者诸色之本明一乘是三乘之本。故取白不取三

评曰。不然莲华者盖是通名。分陀利此为别称。何以知然。睿师序云诸华之中莲华最胜。而华未敷名屈摩罗。敷而将落名迦摩罗。处中盛时名分陀利。远法师云分陀利伽是莲华开发时名。然此华体以时迁名随形变。初出未开名屈摩蓝。衰落之时名为摩赖。当开发盛美色香具足时名分陀利伽。大经十六卷解十号云。人中莲华分陀利华。二名并出。应有通别之异。又列四华最后云分陀利华。河西道朗云鲜白色。又余处翻为赤色最香莲华。今明莲华是众华中之胜分陀利。又是莲华中之美所以云分陀利华也。又大经偈问云何处浊世不污如莲华。下菩萨品具举四华答。故知莲华是通名分陀利为别称也。今以通名为翻故云莲华也。若未开但因而无果。若已落但果而无因。今取正开因果分明。华譬因实喻果华譬教实喻理

问。何故梵本举其别称谓分陀利。此间存其通名称为莲华

答。分陀利必是莲华。今取分陀利之莲华非异莲华也。又外国此华有三时异名。此间无有三时异翻。故存其通称故含得别也

问。以何义故取莲华喻此经耶

答。略明十六种义。一明此华众华中最第一。释论云陆生中须漫那华为第一。水生中青莲华为第一。以喻此经众经中最为第一。故下云诸佛已说今说当说。而此法华最为深妙

问曰。已说即是法华之前谓般若等。当说即是法华之后谓涅槃等。何因缘故言法华最为难信解也

答。诸大乘经显道乃当无异。但法华已前大小分流法华已后会三又竟。但此经是反三之始归一之初。故最为难解称为第一也。二明此华由种而生喻一乘从缘而起。故下偈云佛种从缘起是故说一乘。三明此华开合有时。开则为昼合则为夜。以喻一乘隐显有时。大缘未熟故隐缘熟故显。四明此华能为瑞相。喻见法华必知众生皆得成佛。五明此华有三时之异终不离一华。以喻于一佛乘分别说三虽说三乘终归一乘。六明此华从微至着。以喻此经明众生一礼之福一念之功渐渐成佛。七明大梵王众生之祖从此华生。喻十方三世诸佛根本法身由此经有也。八明此华为人天之所爱敬。喻此经众圣之所尊重。九明此华虽生淤泥泥不能染污以喻一乘虽在三乘污泥污泥不能染污。十明此华生必在淤泥。喻一乘之人必起自生死。十一明此华开而现实。喻此经言巧而理显也。十二明此华不生而已生则华实俱含。喻此经不说而已说则因果双辨

问曰。若华实俱含将非因中有果因果并耶

答。莲华未是果故非一时。离莲华无果亦非前后也。十三者明此华必生于果。余华不尔或生不生。喻一乘之因必当作佛三乘之因或作或不作。十四者明此华为诸佛之所践玩众圣之所托生。喻此经诸佛护念教菩萨法也。十五明未敷之时而莲实不现。喻佛初出世说法明有三乘一乘莲实未现。华开实方现开方便门一乘真实方现。故此华有开未开。喻三乘之权一乘之实也。十六者佛初成正觉。故莲华藏世界说一乘法门。今为二乘人说于一乘。令二乘人同入法界共在莲华藏土。故借莲华以表此义

问。莲华但是譬名亦得是法说也

答。大集经偈云。慈悲为茎智慧为叶三昧为须解脱为敷。菩萨蜂王采甘露味。是故敬礼妙法莲华。若观此意具以众德为莲华也

问。莲华有几种

答。释论云有三种。一人中莲华十余叶也。二天中莲华百叶。三菩萨净土中华有千叶或无量叶。取其最胜为喻。即举菩萨华也。借近以况远者取即目华也。晚见法华论明此大乘修多罗有十七种名。显示甚深功德。应知一名无量义经者成就字义故。以此法门说彼甚深妙境界法故。甚深妙境界者诸佛如来最胜境界法故。二名最胜修多罗者三藏中最胜妙藏成就故。三名大方广者无量大乘门随众生根住持成就故。四名教菩萨法者为教化根熟菩萨随器法成就故。五者名佛所护念者依佛如来有此法故。六名一切诸佛秘密法者此法甚深如来知故。七名一切佛藏者如来功德三昧之藏在此经故。八名一切诸佛密处者根未熟众生非法器不与故。九名能生一切诸佛者闻此法门能成佛菩提故。十名一切诸佛道场者。闻此法门能成阿耨三菩提。非余修多罗故。十一名一切诸佛所转法轮者。此法门能破一切诸障故。十二名一切说佛坚固舍利。谓如来真如法身于此修多罗不坏故。十三名一切诸佛大巧方便经者。依此法门成大菩提已。为众生说天人声闻辟支佛等法故。十四名说一乘经者。此法门显示如来阿耨三菩提究竟之体。二乘非究竟故。十五名第一义住者。此法门即是如来法身究竟住处故。十六名妙法莲华经者。有二种义何等为二。一者出水义不可尽出离小乘泥浊水故。复有义莲华出泥水喻诸声闻入如来大众中坐。如诸菩萨坐莲华上。闻说无上智慧清净境界证如来密藏故。二华开者众生于大乘中心怯弱不能生信故。开示如来净妙法身令生信心故。十七名法门者摄成就故。摄成就者。摄取无量名句字身频婆罗阿閦婆等偈故也

第四辨经宗旨

问。此经以何为宗耶

答。说者甚众。略陈所见有十三家

第一远师云此经以一乘为宗。一乘之法所谓妙法。如譬喻品云是乘微妙清净第一于诸世间为无有上。评曰。未见远师序本。相传云尔然。寻经始终虽明一乘而一乘具有因果。何得但用于因不取于果。此则得在于因失在于果。又且果门已备可得称妙。因行未圆何得称妙。以果妙故可得为宗。因既不妙岂得为宗也

第二龙师云此经但以果为宗。彼云妙法者如来灵智体也。陶练滓累众粗斯尽故云妙也。动静轨物故云法也。法既真妙难以言辨。故借莲华为譬。所以果智为宗也

评曰。光宅受经于印印禀承于龙。龙为法华之匠。然此释以文义两推实符会经致。何以知之。开宗之始广说之初皆叹佛慧。故云为说佛慧故诸佛出于世。又云我所得智慧微妙最第一。故知一经始终皆明佛慧也。以理推者三乘智慧犹未圆满。唯佛智慧乃称究竟。既欲引三趣一宜令皆学佛慧。则以佛慧为宗也。然此慧照无不圆。累无不尽。称之为妙。体可轨模名之为法。唯此一慧为实余二非真称为一也。虚通自在纵任无碍目之为乘。详此释意应无间然矣。但既有妙果必有妙因。考经始终因果斯备。若偏以果为宗即得在于果失在于因。义亦未允也

第三宋道场慧观法师序云。此经以妙一为名真慧为体。妙一为名者。三乘异流是即非真。终期会归其乘唯一。其乘唯一谓之妙法。颂曰是乘微妙清净第一。于诸世间为无有上。真慧为体者。释迦玄音始唱赞佛慧甚深。多宝叹善则称平等大慧。颂曰为说佛慧故诸佛出于世。唯此一事实余二则非真。其序又云。会三归一乘之始也。此明三乘同入一乘始得信解。故名为始也。觉慧成满乘之盛也。此明佛果成满谓乘之盛。灭影澄神乘之终也。此明息迹归本。明法身常恒。谓乘终也。慧观作序竟以示罗什。什叹曰。善男子自不深入经藏。岂能作如是说

评曰。寻观此释名体具足因果圆满。始终两举本迹双明。文旨允契如什所叹也

第四中兴寺印师云。此经亦以一乘实慧为体。下开宗中叹云。佛智甚深即是实慧。又云唯佛与佛乃能究尽诸法实相。诸法实相即是一乘妙境。故境智为经宗。所以然者非实境无以生实慧。非实慧无以照实境也。所以铭一乘。为实相境者体无三伪故称实相也

评曰。印受经于龙龙明佛慧为宗。而印加之以境。故以境智为宗。然经非无境智。但又阙因果方之于观亦未尽美矣

第五光宅法师受学印公之经而不用印公之释。云此经以一乘因果为宗故经有两段。初开三显一以明因。后开近显远以辨果也

评曰。光宅所明盛传于世末学推之。又既有因果之文应符经旨。今以文义推寻意犹未允。何者后明开近显远可得是果。前辨开三显一非专明因。所以然者。昔日明三则有因三果三。今日辨一则有因一果一。开昔因三果三皆是方便。显今因一果一并为真实。何得开三显一以辨因耶。又因果乃圆本迹未足如前评也

第六师云。此经既开权显实。则宜以二智为宗。开三即是明权显一所谓辨实。以下开近显远义亦例然。开近谓权显远为实。未详作者

评曰。权实二慧总贯一经。诚如所说。考斯权实唯是果智。终以果为宗。同前评矣。又若以权实为宗则应具以三一为体。今不可以三一为体。何得以权实为宗。又初段开权显实宜名权实二智。后章开近显远宜称本迹二身。若皆用权实则身智相浑也

第七师云既名妙法即以妙法莲华为宗。妙法者即是佛所得根本真实法性也。此法性不受惑染。不与惑同名之为净。以是净故称为妙也。故用此为题即以为宗。莲华者如前引大集经。取众德为华不用世间莲华也

评曰。寻此师学集出此方。谓第八识自性清净亦名性净涅槃以为妙法。既云是佛所得还是果义同前评也。又摄大乘论阿僧伽菩萨所造及十八空论婆薮所造皆云八识是妄识。谓是生死之根。先代地论师用为佛性。谓是真极。昔般若未度远师已悟真空。涅槃不尽生公照知佛性。诸地论师有惭先见之明矣。又此经所兴不正明八识。八识之义别付余解说耳

第八师云此经以常住为宗。所以然者。大论佛教所宗在常。是故此经以常为宗。但教门未极止。是覆相明常耳

第九师云此经以显了明常故以常住为宗。如下文云。常住不灭但与涅槃明常广略为异耳

评曰。此二师虽有覆显为异而明常义同。然非无有常住之文。但常义是开近显远之意。非一经始末之说也。又释论云。法华经是秘密法。明罗汉授记作佛。非正明常义也。覆相之与显了至寿量品自具详之

第十师云以万善为体。但使是善善必无朽皆当作佛也

评曰。万善为体犹是因义为宗。得在于初章失在于后段。复同前评也

第十一师云万善为体。此大通漫。此经既明一乘但取乘之饰具。宜用一乘为体。乘饰具者如下云。其车高广乃至驾以白牛。但取无漏大乘简除有漏之法也

评曰。寻此释用一乘为体。与初师不同。初师总明一乘。今但取无漏明义。既局非所用也

第十二长安僧睿法师法华序云。寻经幽旨恢廓宏邃所该甚远。岂但说实归本毕殊途而已哉。乃大明觉理囊括古今。寿量定其非数分身明其不实。普贤显其无来多宝明其不灭。此乃丧功于本无忘期于二地也

评曰。睿公亲承罗什。是传译之宗。制斯一序。故自冠绝众师。与光宅一门数条硕异。初开三显一以明因。睿公总云说实归本。说实归本者一乘一因名为真实。非但初段正明于因。此一义不同也。光宅云次章明果犹是数量。睿公云寿量定其非数。非数者常恒不变无有限数。二不同也。光宅云此经未明常唯一法身而垂万迹。睿公云分身明其不实。不实者释迦之与分身皆是应迹。非是实身则显法身为实。三不同也。普贤无来多宝不灭。乃至丧功于本无忘期于二地。此皆辨忘名绝相无住无得不因不果非始非终不一不二乃至非常非无常。显诸法实相不可言宣。四不同也。与光宅四异将慧观。三同既其共禀什公。一车无二辙矣

十三刘蚪集注采安林壹远什肇融恒八师之说。其序大意云。教凝于三一之表果玄于丈六之外。无名无相者此经之旨归。自非道越三空智通十地者孰能辨。名于无名厝说于无说者哉

评曰。寻注意与睿观等大同同辨无依无得忘言忘相之说也

问。已闻异说未见今宗。为异众师为同诸匠耶

答。若以悟而言禀斯异说各蒙益者。则众师释无可为非。若闻而不悟则众师无可为是。一师之意唯贵在于悟耳。宜以悟为经宗无论同异也

问。符经须录背文宜弃。何故朱紫共贯之清浊尚混流。唯悟为宗未详可领

答。假设符经闻而不悟于缘非药则应弃之。如其释背佛经。闻而受道则成甘露理应须录。故甘毒无定唯悟为宗。晚见摄大乘论与一师大致符会。菩萨于一切法无有定教无有定身。唯利益为定也

问。若于缘取悟无不契道。论中何故显正破邪

答。为缘不悟是故破邪。如其契道无非正说也

问。唯悟之言乃应会道。未知此说出在何文耶

答。斯乃众圣之本怀经论之宗领。非但会理亦有诚文。故大经云。一切诸法无有定相。若有定相是生死相是魔王相非佛法相。以无定相是故如来非道说道道说非道。常说非常非常说常。法若有定是应说是非应说非。而是非反论真伪互说者。故知法无定相唯悟是从。又诤论中云。我诸弟子闻是说已不解我意。虽领正言乃成邪说。又中论云。一切实一切非实。亦实亦不实。非实非非实。了者于四句皆是佛法。不了者四句皆是魔法。又释论云。不得般若方便力故学阿毗昙门堕有见中。学空门堕无见中。学昆勒门堕空有见中。学非有非无堕愚痴论。得般若方便学此四句不堕四见。又文殊问经云。十八及本二皆从大乘出。无是亦无非我说未来起斯二十部。皆是如来赴缘方便。闻皆得道故无非大乘。又大集经云。虽有五部皆不妨如来法界及大般涅槃。又求那三藏师偈云。诸论各异端修行理无二。偏执有是非达者无违诤也。以此而推用悟为宗。斯判宜允。此非但欲通一教乃总贯众经也

问。若唯悟为宗子前何故评其得失耶

答。若领先通无俟今问。如其未晓更为折之。大判前言凡有三辙。一者于缘并悟则众释无非。二者闻悉失迷则异说无是。三者自有于此即悟于彼生迷。则此说成正彼言为邪。故法无定相。显在于兹唯悟是宗事彰今说也

问。若约缘悟为正缘迷是邪此言通漫。自有是佛口说非佛口说。然佛说中有了义经不了义经。若尔者则应有正说邪说。今就文而判何释符经耶

答。如前所评得失已彰

问。前明得失自是旧宗。今欲安心愿闻异说

答。夫欲安神好异者。盖是入道之巨累通教之尤毒。今当为子陈之失心。有所安则情有所寄。情有所寄则名有所得。有所得者则有所缚。有所缚者盖是众累之府藏万苦之林苑。子欲安神事招斯过。又云愿闻异说。若云求异则异更有异。使异异无穷。古语云真言归于竞。辨宗逾出于好异。可谓去城逾远岐路逾多。乖之弥至失之弥甚。必欲会虚宗契玄寂者。宜自同于前冥异于后。内视不己见外听不我闻。虚其心实其照者。即是闻所未闻。未曾有法如此。法者称为法华。法华大宗其意在此

问。若心有所依既称有所缚。情无所寄还复染无。其犹逃峰趣壑俱不免于患难。故下经云。若有若无见具足六十二

答。诚如所问。前为借无以出有。有病既息无亦不留。释论云如霜雹草死草死而雹消。若能远离二边乃称妙悟也

问。有无双离乃可二见不生。今明非有非无即堕愚痴论也

答。子初关滞有次辙染无。今虽两是病消双非疾起。可谓众生处处着斯言验矣。若能远离二边不着中道。萧焉无寄理自玄会。返本之道着乎兹矣

问。虽云众生处处着复云引之令得出。请示玄宗令虚心无寄

答。经言是法不可示言辞相寂灭。今当示不可示。子宜闻无所闻。此经以实相正法为宗。明因辨果。开权显实皆是无名相中假名相说为其用也

问。何以知实相正法为宗

答。如前所引。是法不可示即是实相也。又过去二万亿日月灯明佛云。诸法实相义已为汝等说。又云诸法寂灭相不可以言宣。又云诸法从本来常自寂灭相文处甚多非可具举。又夫欲辨宗须观经题。题云妙法者即是正法。正法者如华严云。正法性远离一切语言道一切趣非趣。皆悉寂灭相。正法绝于名相故乃名为妙。若四句所及何妙之有耶

问。若非因非果亦应非正非邪非虚非实。何故名为实相正法耶

答。实如所问。非邪非正非实非虚不知何以目之。为欲出处众生于无名相中假名相说。故强名正法耳。故大经云低罗婆夷实不食油强名食油。皆有类也

问。若言非因非果非虚非实者。斯乃真谛四亡。复何开一乘妙旨

答。既言非因非果亦非俗非真非缘非观。故释论解般若云。因是一边果是一边。离是二边名为中道。又云缘是一边观是一边。离是二边乃名中道。肇公涅槃论云。法无有无之相故无数于外。圣无有无之智故无心于内。于外无数于内无心。彼已寂灭乃名涅槃。岂是真谛

问。云何因果为用耶

答。正法实非因果。为众生开因果法门。故名为用。权实亦尔。但今明因果异旧因果。所言因者具足二因。一者佛性二者缘因。以众生有佛性故修万行方得成佛也。所言果者亦具二果。一无德不圆。二无累不尽。此义现法华论后当说之。故言正法为体因果为用也

法华玄论卷第二(终)法华玄论卷第三

        胡吉藏撰

问。释论解问乘品云。列十种大经所谓云经大云经华手经法华经等。是摩诃波若经于中最为深大。又论第百卷云。法华是秘密法明阿罗汉受记作佛。波若非秘密法不明二乘作佛。又论释毕定品云。须菩提闻法华经明一切众生皆作佛。又闻波若经中有退。是故今问佛。是菩萨为毕定为不毕定。又释论大明品云。诸余善法入波若中。论云诸余善法谓法华经。又云法华是波若果名。是五处论文有三相违。初文列般若胜而法华等劣。第二文般若浅法华深。余三不别浅深。此三相违云何会通耶

答。依五时之说四宗之论。言此相害鉾楯不可会通

问。云何尔耶

答。众师并云般若浅而法华深。决定无有言般若胜而法华劣。故知不可通也

问。既与旧说相违今云何融会耶

答。须广详旧论意乃明所以然者。此虽数句之文乃网罗佛教。不可轻言宜谛详究

问。旧说云何

答。宋道场寺惠观法师着涅槃序明教有二种。一顿教即华严之流。二渐教谓五时之说。后人更加其一复有无方教也。三大法师并皆用之。爰至北土还影五教制于四宗。今依大乘经论详其得失。释论云佛法有二种一者大乘藏二者小乘三藏。又云佛法有二道一者声闻道二菩提萨埵道。前约法分两后就人开二。又释论云佛灭后迦叶与阿难结集三藏。文殊弥勒亦与阿难结集摩诃衍藏。大经云字有二种。一半字二满字。为声闻说半字为菩萨说满字。又云诸大众凡有二种。一求小乘二求大乘。昔于波罗捺为声闻转小法轮。今始于此拘尸那城为诸菩萨转大法轮。又法华云昔于波罗捺转生灭小轮。今至鹫山转无生灭大轮。又法华明二种教。一教声闻二教菩萨。教声闻者如雇之除粪。教菩萨者如付穷子财。从付财已去皆是教菩萨。又唯有草庵及以大宅。唯有中道化城及以宝所。又摄大乘论明声闻法菩萨法。声闻法但断惑障。菩萨法断惑智二障。又地论明二藏与释论同。又净名云菩萨法藏所摄。则知有声闻法藏所摄。又中论云声闻法入第一义道。摩诃衍入第一义道。又一切经初皆列二众。一小乘众二大乘众。如是等处处经论但明大小二乘。故唯有二种法轮不应立三教也。又以理推之众生根有二种。一堪受佛道二不堪受大道。堪受大道为说佛乘名为大乘。不堪受者为说小乘。故知但应有二不应立三也。又三教之言无的明据不可用也

次明亦无渐教。旧云波若是三乘通教凡引四文。初云欲得声闻地者。当学波若乃至欲得菩萨地者。当学般若。又云是波若中广说三乘之教。又云二乘智断是菩萨无生法忍。又云欲住须陀洹者亦不应离是忍。故知波若是三乘通教

评曰。论序说波若因缘意云。于三藏中但为声闻说法未说菩萨行。今欲为弥勒等广说菩萨行故说波若。不言今欲通说三乘人行故说波若。即知波若非三乘通教。又论云波若不属二乘但属菩萨。若波若是三乘通教者则应通属三乘。不应但属菩萨。又论云在菩萨心中名波若。在声闻心中名道品。又云在菩萨心中名陀罗尼。在二乘心中名为道品。若波若是三乘通教则在三乘心通名波若。不应有别名也。又难曰。若三乘通学波若波若是三乘通教者。涅槃经云三乘之人同观中道。下智观故得声闻菩提。乃至上智观故得诸佛菩提。亦应是三乘通教。若言盖是涅槃一枝之义不足以证大宗者。劝学品劝三乘学波若亦是一句之言。不足以证其通致。又云波若出生三乘。故是三乘通教者。大经云即是声闻藏出生诸声闻。即是因缘藏出生缘觉。应是三乘通教。又胜鬘经明大地出四宝藏。摄受正法能生五乘。亦应是三乘通教

问。此非难也。涅槃胜鬘明一乘佛性。波若不然。故不得为例

答。若涅槃正明佛性。复有同明三乘观中道者。波若正明教菩萨法亦劝三乘同学波若。此义应齐云何非例。又引释论辨十种大经明波若最胜。既胜法华岂浅涅槃等耶

问。波若未明常故知浅也

答。经题中以引文竟今当更说。摄大乘论引波若云。乘有三种因乘缘乘果乘。果乘者谓常乐我净。若尔波若以明四德云何非常。但人不解经意谓言无常耳

问。龙树何故不依此释耶

答。论主亦明无为波若。又云常住波若非无此意

问。波若非三乘通教者何故劝三乘人通学波若耶

答。今当为子述之。从波若至涅槃皆是教菩萨法。但教菩萨法凡有二种。一显教二亦显亦密。如法华涅槃显教菩萨。故明三乘人皆是菩萨波若亦显亦密显教菩萨密教二乘。显教菩萨者令菩萨修学波若成佛道也。密教二乘者劝二乘学波若。亦令二乘成佛道也。如付财中说密示大法以为己任。故付穷子财。穷子根钝不知不觉。谓学波若得证三乘。若言学波若成三乘者。犹穷子之气类耳

问。经及释论亲明学波若成二乘。云何作此释耶

答。学波若成二乘者此终是不识波若是菩萨法证二乘耳。若必识波若是菩萨法即学波若不证二乘

问。何以知然

答。若学波若证二乘者即在二乘心应名真波若。何故论云在二乘心不名波若。又何得初劝二乘学于波若。后证二乘果而不名波若耶。希求味之贤留心此意也。又学波若成二乘者。此是波若少许气分耳。何以知之。释论云二乘证空比菩萨空。譬如毛孔空比十方空。又摄大乘论云。二乘但得人空不得法空。故知二乘但得波若少许气分

问。若如后意者即以此言证波若。是三乘通教既得少许气分。岂非通耶

答。若得少分便说波若是三乘通教者。大经云如人得食亦名涅槃。二乘断三界惑岂不得涅槃少分耶。故不应以少分之言证三乘通教。又小波若云。此经为大乘者说为最上乘者说。故知波若不通教三乘

问。前言波若密教二乘。又何所据耶

答。法华信解品云。而昔于菩萨前毁訾声闻乐小法者。然佛实以大乘教化。故知波若密说一乘。此亦得即是显说一乘。但穷子钝根不觉知耳。以此推之不应言波若是三乘通教。又摄大乘论云。波若密说一乘。所以然者。一切法皆是真如。三乘不离真如。即说一乘义。但二乘人不觉知耳。又说一切处求人不可得。若无有人云何分别此是声闻人此缘觉人此菩萨人耶。以无我同故当知即是密说一乘也。又三乘人同断惑障。以断惑障。故即是同一乘也。又古旧义云。波若已会法但未会人。会法者一切法皆入诸法实相中。皆入摩诃衍中亦皆入波若中。故云若有实语摄一切善法者。当知波若是也。故知波若已会诸行。诸行皆入大乘。但二乘根缘未熟未堪开会。故言未会人耳。以密会法竟。当知已是说一乘但未会人。故二乘人不觉知也。次言净名是抑扬法轮。叹凡夫有反覆。毁声闻为败根

评曰。是亦不然。论主释波若魔事品云。譬如痴犬不从大家求食。从作务者索。犬者声闻人也。大家者云大乘教也。作务者小乘经也。净名虽挫之以败根。未及波若抑之以痴犬。抑扬之言亦为谬说也。又法华云。而昔于菩萨前毁訾声闻乐小法者。然佛实以大乘教化。此即指波若为抑扬。非以净名为褒贬也。又净名具呵大小何故言抑小扬大

问曰。虽具呵大小而终叹大乘。故是抑小扬大

难曰。终为扬大何故呵大小。既云大则非专扬大。此义如释名中广说。第四法华为一乘教乃应无疑而义亦未善。论解波若毕定品须菩提闻法华经明一切作佛。又闻波若有退。是故今问为毕定为不毕定。若尔不应法华偏明一乘。波若都无此说。又论云法华是波若异名。不应法华明一乘教波若未明也

问。若无五时者宁有五味相生譬耶

答。五味与五时义不相应。乃欲证成反为自害。五时中以波若为第二时。五味中波若为第四。虽欲曲会云波若即是法华平等大慧。此乃回文就义非所以也。大经云如我前于摩诃波若中说我无我无有二相。可是平等大慧引法华耶。此出人情深非文义也。又摄大乘论明乘有三。初二乘次大乘三一乘。一乘最胜何不言三时耶

又五相略经明教有三种。第一鹿野为声闻说四谛。第二为大根说诸法离自性不生不灭。此亦有上有余不了义说起诤论处。第三为求一切乘者。说诸法离自性不生不灭。无上无余非诤论处。此经一卷与摄大乘论相应。何故不依经说三时耶。又无量义经且明三时。初为声闻说四谛。而八亿诸天来下听法发菩提心。次说甚深十二因缘。为求辟支佛人。无量众生发菩提心住声闻地。次说方等十二部摩诃波若华严海空。宣说菩萨历劫修行。依此则有三时。今复说无量义亦是四时。复说法华则为五时。涅槃为六时。初说人天乘应为七时。何不立七时。不应偏立四宗定执五教也。又释论云佛于鹿园说法无量菩萨得无生法忍。无量菩萨得一生补处现身作佛。岂可言鹿园但小乘耶。又大经云我初成道亦有菩萨已曾问我是甚深义。即初后皆说涅槃不应言涅槃是渐而华严是顿。又像法决疑经云或有见我入于涅槃。或有我是报佛为百千释迦之所围绕。若尔不应言华严是初成道时顿说至涅槃时不说。是故渐顿不成也。又释论有二种法轮。一显示法轮二秘密法轮。显示者如鹿园说小法五人及八万天得道是也。秘密法轮者于鹿园说大法。无量人发菩提心。乃至现身成佛如向所引也。如鹿园有此二事。以判显密者。一切处皆例然。如在祇洹身子等见释迦说法。诸菩萨见祇洹舍那说法徒众充满法界说法界法门。二乘不闻不见皆其类也。又以四句总贯众经。一始说小终说大。如鹿园先说小后明大乘。二初大后小。初成道说华严教。鹿园已去说小教。三始终俱大。如初后皆说涅槃。四始终俱小。如释论云从初转法轮至大涅槃集作阿含。以显密二教及四句不同。岂可局在五时限以三教。但知如来随缘说法教无定也

问。如是等经皆属无方教摄故无过也

答。无方之言经论无据不应立之。又不应立无方教。所以然者。如以大品为第二时。诸余波若皆属第二时者。以涅槃为第五时。诸余常经皆属第五时。但应以类摄经。不应以无方收教。若言相生者为次第。不相生者为无方者。安知八部波若并皆相生耶。又五时是相生之言捡既不成。况有不相成为无方教。又龙树天亲俱以类而分大小。呵梨法胜以例而开三藏。不应立无方教也

问。北地诸地论师明四宗五宗等说。是事云何

答。此皆影四五时教故作是说耳。五时既不成四宗自废。又菩提留支此云道希。其亲翻地论但明半满。留支是地论之宗。即知半满有本。而依四宗无根。而辄信深不测其所以也

问。子虽广弹三教及斥五时。引前论五文云何会通。龙树传云。智慧日已颓。斯人令再耀。世昏寝已久。斯人悟令觉。外国为之立庙宗之如佛。楞伽经云。有大德比丘名龙树菩萨住初欢喜地。为人说大乘。摩耶经云七百年中有一比丘名曰龙树。灭邪见幢燃正法炬。以经传而推之理非谬说。若斯言可领则如白日朗其胸衿。甘露流其四体。如其未晓即寄心靡托。冥若夜游。请为通之使无毫滞

答。文异常规义乖旧格。虽欲会通正恐未可即心。今当为子粗陈纲要。第一文云波若于十种经中最大者。然捡众经之极以实相为宗。统群圣之心用妙惠为主。夫万化非无宗而宗之者。无相虚宗非无契而契之者无心。故圣人以无心之妙惠契彼无相之虚宗。内外并冥缘智俱寂。岂容名数于其间哉。斯二穷得一之原尽重玄之妙。理无不统教无不摄。如空之含万像若海之纳百川。波若盛明斯意论称最大岂虚构哉

问。子明大之有以今用何文证之

答。四悉檀摄十二部经八万法藏。前三悉檀犹可破可坏。第一义悉檀不可破不可坏。最上无过者此经正明第一义悉檀故。云故说第一义悉檀故说是经。即知波若盛明实相证初境大义也。又云前三悉檀皆归第一义。即知八万法藏为显第一义。波若既正明第一义。即摄八万法藏。故知最大也。二者龙树开九十章以明二惠。六十六品明实惠。从无尽品竟经辨方便惠此二惠是十方三世诸佛法身父母。如净名云智度菩萨母方便以为父。一切众导师无不由是生。此证第二智大义也。以此二义即于一切经中最大。岂但十经耶。盖是论主略言十耳

问。众经且明斯二。岂独波若将非论主一时揄扬耶

答。波若专明此二余经不尔。又众经明此二者皆摄入波若中。故前云诸余善法者谓法华皆入波若中也。盖是论主理实言之非随情称叹

问。余经明此二摄属波若者。亦应波若明此二摄属余经。即余经为大非独波若

答。已如前判波若专明此二。又波若初说此二余经无此两义。故不得称波若也。古有大品师谓波若为得道经。此言符论最大之旨。以一切得道皆由波若故波若最大。此通上第一文也。第二文明法华是秘密法明二乘作佛。波若非秘密法不明二乘作佛。故波若浅而法华深者。诸讲论师虽诵此言多不体其意旨。故异释纷然。或赞杨波若抑破法华。或悬信师说不详文意。今断如是种种异说以龙树论文为正。论云波若非秘密法不明二乘受记作佛故也。而法华是秘密法明阿罗汉受记作佛故也。正据二乘作佛不作佛故辨秘密非秘密也

问。波若不明二乘作佛。何故是显示教。法华明二乘作佛。何故是秘密教耶

答。前已释竟。今当广述。波若但明菩萨是佛因故作佛。二乘非佛因故不作佛。此义于昔易解故名显示。法华经明二乘作佛与昔教相违。于昔难解故名秘密。论主云如用药为药其事即易。用毒为药其事即难。波若明菩萨作佛如用药为药。不明二乘作佛如不用毒为药。法华经明二乘作佛如用毒为药。其义即难解所以为秘也

问。秘密与显示为深为浅为大为小

答。总论此二义即有两途。一者小乘为显示大乘为秘密。如论第四卷云。佛法有二种一显示二秘密。显示教中明阿罗汉断烦恼清净。诸菩萨未断烦恼未清净。即菩萨不及阿罗汉。故烈罗汉在前而菩萨居后。秘密法中明诸菩萨得六神通断一切烦恼。智慧清净超出二乘之上。此文正约小乘浅易为显示。大乘甚深为秘密。若尔者则波若之与法华皆明菩萨得无生忍具六神通。并属秘密甚深教摄。即指三藏教为显示也。二者以明义犹浅为显示。明义甚深为秘密。如第百卷说。波若但明菩萨作佛者。波若已明佛乘是实未明二乘作佛者。未开二乘是方便。约此一义有劣法华。故名波若为浅。法华即明佛乘是实复开二乘为权。故法华为深也。此同就大乘中自有浅深。故分显秘二教

问。波若未开权显实应是秘密。法华已开权显实应属显示。何故不尔耶

答。若以未了为秘以了为显者则如所问。但今以浅易为显示甚深为秘密。故以波若为显示。法华为秘密。说经因缘中已明此义竟

问。若波若明义未了故称显示者。前何故言波若于一切大乘经最为深大耶

答。各有其义。所言深大者据前二义也。后云未了者就未明二乘作佛也

问。若法华胜明义已了波若劣明义未了者。何初言波若胜明义已了。法华劣明义未了耶

答。不例也。初辨波若广明实相等二义故胜。法华不专明二义故法华劣耳。不言波若明义已了法华明义未了。以判胜劣。若是法华胜波若劣者正就了不了判也

问。汝为自作此判。为义有所求耶

答。理数自然何繁今问。作此释竟复见关中僧睿小品经序。盛判二经优劣将余意同。睿公言波若照也法华实也。论其穷理尽性夷明万行则实不如照。取其大明真化解本无三则照不如实。是故叹照则波若之功重。美实即法华之用高。考关中此文深见论意妙得经旨也

第三毕定品云。须菩提闻法华经辨不退。复闻波若中有退。是故问佛。是菩萨为毕定为不毕定。佛答皆毕定。毕定者初心后心一切菩萨皆不退。是故毕定也。此论意明波若与法华无有优劣。以波若法华同明一切众生毕定作佛。是故二经无优劣。既无优劣则二经同名秘密也

问。此文与第二文相违云何会通

答。论主云波若非一时一会说。以此言推者则前分明退者在法华之前。后分不退者在法华之后也。故两言不相违也。又五不思议中佛最不可思议。如大经云。或见佛今夜入灭。或十五日后方始问讯。或一年后方取涅槃。像法决疑经云。或见今日双树泥洹。或见应生出家。或见为舍那处莲华藏。或见佛身满于虚空。若尔者不可定波若前而法华后法华前而波若后。故适时而闻随机而见也。第五法华是波若异名者。论云波若不属二乘但属菩萨。即波若是教菩萨法法华明一乘。亦明教菩萨法佛所护念。是故波若法华异名也。又要从二慧父母乃生诸佛。波若既明此二者则法华明作佛亦同波若。即波若法华不异但开权一边异波若耳

问。以波若望法华既具三义。可得将波若望涅槃亦具三义以不

答。亦具三义。例此可知。一者波若正明境智二义涅槃不正明此义。例法华可知。以二义故波若胜而涅槃劣也

问。何以知然

答。论列十种大经云波若最大。十种经中有大云经。大云经明佛性常住等。故知波若胜涅槃劣也。二者波若未明众生有佛性。例如未明二乘作佛。故波若劣而涅槃胜也。三者二经无异。波若既与法华同明二乘作佛亦同明佛性。故二经齐也。又波若唯教菩萨则涅槃亦然是故无异

问。波若后分明义与法华同。明不退何处有同明佛性与涅槃齐耶

答。波若文既明一切菩萨不退。即知皆有佛性。又既与法华齐。法华经中说佛性即是波若明有佛性也。此略举三文以论同异耳不可以局余义

问。波若与净名法华同异云何

答。净名及波若初分并已显佛乘是实。但未开二乘是权此处无异。今略明四义不同也。一者波若广说菩萨行如释论云。今欲为弥勒等广说菩萨行也。净名略明菩萨二种要行。一净佛国土二成就众生。如佛国土品说净土行。从方便品去破三种人明成就众生。方便品破凡夫见。故说生死过患也。叹法身功德令凡夫人入菩萨法门。次破二乘见明菩萨法门如弟子品说。三破菩萨大乘见如菩萨品说。凡夫着生死。生死是凡夫烦恼。二乘滞涅槃。涅槃是二乘烦恼。菩萨着佛道。佛道是大乘烦恼。故破此三种人皆悟不凡不圣不小不大不二法门。然后以权实二智适化。无方随缘益物。净名大致为如此也

问。净名经何故明成就众生净佛国土耶

答。释论云。菩萨得无生忍已后无有余事。唯成就众生净佛国土。净名既得无生故今行斯二事。又适化不同不须问也。净名破三种人令入菩萨法门。此三种人即是五乘人。破凡夫谓人天乘也。次破声闻即二乘人。破菩萨即大乘人。破五乘人令入菩萨法门。与法华会五乘归一何异答显实与法华同未开权与法华异

问。云何显实同。云何未开权异

答。破三种人显菩萨法门甚深微妙无碍无方。法华亦明菩萨法门甚深微妙究竟真实。是故同也。但虽破三种人明其是有所得。未明五乘皆是方便。是故异法华也。又三异一同。三异者一者未开三是方便。二未会三归一。三未废三立一也。一同者净名呵大小乘法华亦破三乘异执故言同也

问。二种破义有异不应言同。净名破其有所得义。法华破其执五乘异义。何得言同

答。此义即两经有异。但法华破执。破执必是有所得。今取同是有所得。是故被破。所以言同也

问。但净名显实与法华同。波若显实亦与法华同

答。一切大乘经明道无异。即显实皆同。但波若净名之时二乘根缘未熟故未得开权。至法华时二乘根缘始熟故方得开权耳。不可言未开权故亦未显实。波若净名辨菩萨无碍之道究竟无余。法华辨菩萨行复何能过此耶

问。以何文波若净名已显实耶

答。法华信解品云一切诸佛所有秘藏。但为菩萨演其实事。而不为我说斯真要。岂非指波若为秘藏真实法耶

问。净名波若未明三界外事。如未辨五百由旬。显实云何无异

答。若以五百由旬为界外者。大品明四百由旬宁非界外耶。又华严涅槃诸大乘经无有分明文辨三界内外事。但胜鬘分明说耳。可言华严涅槃未明界外事耶

问。法华明罗汉受记作佛。即是明界外事。净名大品亦尔耶

答。释论解大品往生品。云菩萨从一佛土至一佛土。至一佛土者此是出三界外净土。云何言不明界外事耶。又明菩萨舍肉身受法性生身。二乘亦尔。岂非明界外事耶。又大品净名未明界外事者。为未得开权故。若分明说界外事。则辨罗汉生处。便是开权。此时根缘未堪故不说。但直明三界外净土菩萨往生。则菩萨利根悬得领解。二乘根钝故不知界外更受生身。又难若言净名大品未明二乘作佛亦未显实者。华严云大药王树根不生二处。谓深水火坑。既言二乘不生菩提心。若尔华严应未显实也。又华严法界品明二乘未入法界。法华已明入一乘。然一乘法界是异名耳。岂可言华严未明二乘作佛。故显实亦未足耶

问。何故华严未明二乘作佛耶

答。华严多是初成道时。二乘根缘未熟故说其未得成佛。如净名大品之时二乘根缘未熟故未开权。诸菩萨道缘已熟故已显实也。不可言未开权故亦不显实矣。二者大品令二乘人口自说菩萨行密教二乘。净名经令菩萨人说菩萨行密教二乘。密教二乘不出自他两门。故二经为异。三者密教二乘复有二门。一佛自密教即大品付财也。二菩萨密教谓净名等也。四者密教二乘者。二乘有二病。一者住着空有。故大经云二乘人名有所得。波若多破其住着之心。辨无住无得。睿师释论序云。知滞有之为患故波若为之照即其事也。二者二乘人不能知无方无碍之用。净名等经正辨菩萨无方无碍之用。菩萨体无碍法。故心有无碍慧身有无碍通。口具无碍辩以密斥二乘。令悄鄙小心欣慕大智。此皆大判耳

问。大品法华涅槃华严四经同明因果。因果何异

答。大品因果者释论云。佛于三藏中为诸声闻说种种法未说菩萨行。今欲为诸菩萨说菩萨行故说波若。中论云先于声闻法中说生灭十二因缘。次为菩萨说无生灭十二因缘。以二论详之。三藏望波若即是开生灭无生灭二种义。以菩萨行无生灭因故得不断不常果。无生灭因即是波若。不断不常果即是萨婆若。故经云以不住法住波若中。以无所舍行檀等六度。不生故具足三十七品等。所以睿师云。启彰玄门以不住为始。妙归三慧无得为终。不住为始谓行不住因。无得为终即是得无所得果。适化当时即便取悟也。波若因果大宗若斯。法华因果者此经正开权显实。故辨因明果。可谓融会今昔结束始终。总序释迦一化之大意也。一期出世教门虽多不出权实二智真应两身。初则开权显实。明三乘为方便一乘为真实。故破昔三因三果。明今日一因一果。以因无别感唯有一因。果无异酬唯有一果。时众虽知唯有一因无有异因。唯有一果无有异果。未知一果为同昔果。为异昔果。是故次辨开近显远。近谓如来应迹。远即常住法身。但昔方便说近以覆远。今开近显远。近远既彰则本迹义显。本迹义显故成一果义。果义既成一因始立。是故此经正明一因一果。法华之会闻便领悟也。次明涅槃辨因果者。依寿量品明诸子有二种。一不失心二失心。不失心子闻波若法华皆得领解。余失心子不肯服药。保执昔无常教。是以如来唱灭。因此广破无常病逗以常药。正以佛性为因涅槃为果

问。此经正明常无常今昔开覆。何故以佛性为因涅槃为果耶

答。为释成常无常意故明佛性为因涅槃为果。如来之身所以常者良由本有佛性。见佛性故。所以为常故纯陀品云。未见佛性名为无常。见佛性故常恒无变。故佛性之因涅槃之果更无有异。隐名佛性显名涅槃。亦隐名如来藏显则成法身。又隐则为因显则为果。然佛性未曾隐显。约众生不了故名为隐。若得了悟自为显也

问。佛性为因涅槃为果为释成常无常义。三宝一体异体复释何义耶

答。亦释成常无常义及因果义。昔三宝异体。是故无常。今三宝一体。所以常住。故长寿品末云。如汝父母各各异。故知是故无常。以三宝不异所以常住也。以三宝一体故果义则成。果义既成因义便显。所以复是释成因果

问。然作此释者与旧何异

答。涅槃明常者此是对治悉且。非究竟说。大经云诸优婆塞常乐观察诸对治门。谓常无常乃至我无我。昔破邪常故说无常。今斥无常是故说常。然如来身未曾常与无常。常无常方便用具足。三宝未曾一体异体。一体异体方便具足。涅槃正宗大意如此。其中一化教门有未了者并皆融会。故涅槃亦名开秘密藏经也

问。法华中三根声闻皆得领悟。何故三修沙门至涅槃时犹执苦无常耶

答。以是义故开失心子不失心子。不失心是利根人。闻初段开三显一后章开近显远。皆得领悟。余失心子闻而不解。故至涅槃方得悟也

问。身子等昔有二执。一执三乘异二执佛无常。闻法华教二执皆除即便领悟。失心子至涅槃时犹具二执。则涅槃教起应破三乘异执复破无常执也

答。事如所问。明佛常住即破无常执。明同一佛性破三乘异执。二病既消即便领解

问。法华破二执有二段经文。涅槃破二执复云何耶

答。法华离破故开二门。涅槃合破但有一段。何以知之。开宗即辨常便说佛性。故知合破也。以根性不同取悟非一。法华离破未解至涅槃合说便解。又法华广明一乘广破异执。略明常义略破无常执。涅槃广破无常执略破异执。以取悟不同故广略互显。华严明因果者前已释竟。此经但为菩萨广开舍那能化所化二种因果法门。皆是无方无碍。任道平正无所斥夺究竟圆满。望前诸教谓根本法轮。所以明根本法轮者。三世诸佛出世唯应为菩萨直说。究竟之因圆满之果。菩萨行此因故直趣佛果。故名根本法轮。但为众生薄福钝根不堪受此法。是故方便息于大化种种杂说。或前小后大或始三终一或先无常后常。皆是释迦屈曲为缘。故深隐说法。若任道而言唯应有华严教也

问。四经同明因果。何故涅槃具明缘正两因缘正两果。缘因即因与因因。缘果即果与果果等五性之义。而余经不明此耶

答。受悟不同故圣教非一。如华严开世心十地等因及依正二果。而余教不作此说。故知逗缘不同也

问。何故余经不逗缘说此法耶

答。大品法华是合明义。涅槃是开明义。所以合明义者。大品直明无所住因无所得果。破众生有所得心即便了悟。不须别开缘正因果也。法华直破异因异果明一因一果。众生即得了悟。亦不开缘正因果。大经为钝根众生闻上合说未悟故。广开缘正两因两果始得领解也。以根缘宜。闻合以取悟则为之合。应闻开以受道故为之开也

问。就大品法华华严亦有缘正文以不

答。傍有此义。释论解方便品云。波若为种子是正因。五度等为水是缘因。能生菩提果树。又大品已有明佛性义。亦有缘正因义也。法华中明众生有佛性即正因。万行等是缘因。华严中正法性起文云。微尘中有一经卷。经卷中广说一切事。此即是众生身中有佛性。破微尘出经卷。即是除烦恼见佛性也。佛性既是正因。诸菩萨修行三十心十地等即是缘因也

问。若皆有缘正二因者。云何有四经之异

答。但众经皆有傍正二义。波若广破有所得明无依无得为正宗。佛性一乘为其傍义。法华广明一因一果为其正宗。无所得及佛性为其傍义。涅槃广明佛性常住。为斥无常之病为其正宗。一乘及无所得为其傍义。又众经逗缘不同互相开避。波若已广明无所得实相故法华不明之。未广说一乘因果。故广明之。法华已明一乘因果故涅槃不广明之。未广明佛性常住。故广说之。又唯是一道三义说之。无境不照义故名波若。真极无二义称为妙法华。常恒不变义目为涅槃。又在菩萨心故名波若。在佛心故名萨波若。具在佛菩萨心故名一乘又须领。众经显道无异而作异名说之。如大品作波若之名。不作一乘及佛性之目。法华作一乘之名。不作波若佛性之称。乃至涅槃亦然

问。何以知然

答。法华无佛性文。而天亲释法华论有七处明佛性。故知一乘是佛性异名。谓论主知名虽异而体是同。故就法华中明有佛性义浅识之流迷名丧实。闻名异故谓实亦异。便言一乘非是佛性。又释论云若如法观佛波若及涅槃。是三即一相其实无有异。故知波若是涅槃异名佛性别称。但随诸众生力为之立异字。如将息病人以一种食作诸异味。又随义说譬喻之一金作诸异器。以此推之不得局以五时限之四教也。譬喻义后当广说之也

法华玄论卷第三法华玄论卷第四

        胡吉藏撰

初明一乘义即释会三归一义

问。经云十方佛土中唯有一乘法无二亦无三。云何名为无二无三耶

答。有人言无二者无声闻缘觉二。无三者无偏行六度菩萨乘。又昔三乘皆是方便。今教别有一大车。异昔三也

问。何以知然

答。经云佛以方便力示以三乘教。既以三为方便即以一为真实。即会昔三乘归今一实也。又云愿赐我等三种宝车。昔既索三今便赐一。故索所不与与所不索。即知别有大车异昔三小。以文理推之即有四车也

评曰。三车诤论纷纶由来久矣。了之即一部可通。迷之即七轴皆壅。今以八文征之。方见此释为谬。第一文云如来但以一佛乘故为众生说法。无有余乘若二若三。此文次第列三乘也。但以一佛乘者谓佛乘为第一也。无有余乘若二若三者。无有缘觉为第二。声闻为第三。以此文详之即唯有三车。即执四为谬矣

问。经常列三乘不作此之次第。今何以说三

次云唯一是实余二非真者。唯一佛乘欲引导众生故方便说三。考实而言唯一佛乘是实。余二非真。是故说三说二犹一意耳。请设近喻以况远旨。如父手中唯有一果欲引诸子说一果为三果。考实而论唯有一果无二果。是故二文无相违也。以三二既明会义可领。晚见法华论。释十方佛土中尚无二乘何况有三。与今意同。论云此是遮义。是遮者明无二乘涅槃。唯佛究竟无上菩提。有大涅槃耳。此但明无有二乘唯有佛乘。不言无偏行六度菩萨乘。故光宅失旨也

次论四句

问。会三归一．破三归一．开三显一．废三立一有何异耶

答。会三归一者有会教会行会缘。言会教者昔开三乘五乘之教并为显一道。所表之道既一能表之教亦复无二。故一切教皆名大乘教也。会行者汝等所行是菩萨道。如来昔说有三行者。为趣一道故令修三行。所期之道无二。能趣之行岂三耶。所言会人者如来出世本为教菩萨。不教余人。三人所行既是菩萨道。能行之人皆成菩萨也。故文云但为教菩萨无声闻弟子。但会教正是一时。会行及人远令至佛也

问。会有几种

答。自有融会称会。自有会归称会。若会归称会如向所明也。融会称会者。既会三归一竟。缘即疑云。三若归一何故说三。是故释言。昔以方便故说三。今以如实故说一。此是融会今昔三一之义亦名会也。若是会归之义正就三行也。融会之义宜就教门。所以然者。若会三因同归作佛。如此之义会行为正不用教门。作佛故教非会归也。若取设教之意。为显一乘此名会归之会也。破三归一者昔说三乘本为表一。而众生遂保执三不受一教。故须破其执情名破三归一也。是故文云今为汝等说实。汝所得非灭也

问。但破执情亦破教耶

答。三教于佛恒是一教。故大经云。常行一乘众生见三。若尔于佛即不破也。但破众生执教生迷不破教也。开三显一者开昔三是方便。显今一是真实。废三立一者昔为不堪闻一故权说三教耳。今大缘已熟堪闻一教。即宜废昔三立今一教也。方便品云正直舍方便即是废义也

次论乘体

问。何以为乘体

答。乘通因果。果乘以万德为体。因乘以万行为体

问。何以知通因果耶

答。后当广说。今略取二文。十二门论以六义释乘。诸佛大人之所乘故故名为大。谓果乘也。观世音等之所乘故故名为大。谓因乘也。此经云佛自住大乘如其所得法。以此度众生。为果乘也。是诸子等乘是宝车直至道场。谓因乘也。法华论具明乘通因果。后当出之。唯识论亦然也

问。释论云六度为乘体。云何乘通因果耶

答。此说因乘耳。广乘品中具明万德万行也

问。因乘之中云何本末

答。六度虽是大乘体要须波若正观。由波若正观万行方成。即波若为本余行为未。此就乘体中自开本末

问。同是无得六度皆是正体。有何本末

答。若六度同是无得者。要须波若方成无得。故波若为本五度为末。大品云鸟集须弥同一金色。虽同金色而须弥为本。要由须弥色乃同耳

问。因中之乘以波若为主。果地万德用何为宗耶

答。论云因中名波若果中名萨婆若。即果乘以萨婆若为主也。是故此经始末皆叹佛慧。如云为说佛慧故诸佛出于世。乃至多宝所叹平等大慧。即其事也。摄大乘论亦言智慧为乘体也。此是不二二开本末耳。因缘无碍一一行摄一切行。皆得为因乘本。一一德摄一切德皆果乘本也

问。法华具明因乘果乘。何者为正

答。辨宗之中以说斯义明正法。为乘者此乘非因非果始是正也。今就方便用者以果乘为正。所以然者果是妙极因未妙极。经题秤为妙法故宜以果乘为正也。以标此妙极之果令三乘人及一切众生皆修妙因。趣此妙极之果。然后始得明因乘耳。若发趾即明因乘为正者。竟末标所期知何所趣耶。如人先知宝所然后修行趣之耳。以此而推果为正也。此义文已广明寻之自见。后见法华论释尚无二何况三耶。明无有二乘涅槃唯有如来大涅槃名为佛果。故知二乘亦取果乘为正。大乘亦取果乘为正。是以论但举涅槃也

问。乘有广狭义不

答。五乘相望自辨广狭今不明之也。就一乘中自论广狭者。果乘无累不尽无德不圆故称广也。因行不尔故称为狭。就因中自论者。初地得百法明门故狭。二地得千法明门故广。如是可知也

问。云何一体乘异体乘耶

答。与波若相应无依无得不二观现前。如一念品说。菩萨一念具万行。此是一体乘。未得此观现前名异体乘。然从初发心则学不二观。故从初发心时是一体乘。则一念具足万行。故云发心毕竟二不别。但约此观明晦故开一体异体耳。约位明者得无生忍为一体乘。未得无生忍者为异体乘

问。何以然

答。大品云但燃灯佛以得无生忍即不离六度等无得万行

问。云何是近乘远乘

答。以波若心所起。如不住法住波若中。无所舍具足檀等六度。不生故具足道品。亦如广乘品列一切德行。后皆结言无所得故。如此之乘名为近乘。若说低头举手皆成佛者。此是有所得善名为远乘。何以知然。法华云是乘微妙清净第一。于诸世间为无有上。此岂是人天有所得善耶。今菩萨所行从初发心即行无所得观。此是近乘无有远乘。但就无所得中自有明晦故分近远耳

问。释论解无生品中云。有近道远道。近道者谓三十七品。远道者谓六波罗蜜。然道品与六度俱皆是乘。何故分近远耶

答。数论师地论师法华等师无有此义。故不释也。今明此义可有四列。一者六度道品是无所得故俱近。二俱是有所得故俱远。三无所得六度为近。有所得道品为远。四无得道品为近。有得六度为远。今明六度为远道品为近者。为释无生品经文。经文云有世间六度出世间六度。道品但明出世。不明世间。论主解此一义故明六度为远道品为近

问。六度何故远道品何故近

答。六度杂有世出世故远。道品纯是出世间故近

问。六度何故杂道品何故不杂耶

答。六度中明通浅深。如布施持戒忍辱等通于浅深。可得有杂义。道品中明定慧。定慧深于施戒。就此一义故六度为远道品为近

问。此义约大小乘分近远以不

答。若就大小乘一往分者。道品是小乘行故为远。六度正是乘体故为近。若就菩萨具一切行。皆是无得。悉是正行。六度道品俱是近乘也

次论运出义

问。运出明乘者。因乘果乘何者为正耶

答。就因门正明运出。释论云是乘从三界中出至佛果。即住变成萨婆若。故因乘为正也。若以能运出众生者。即佛乘为正。唯佛能具运出一切众生。而因乘不及果也

问。云何是自运运他

答。就运出为义者。言因乘者有自运运他。果乘但有运他之义。佛即已出无劳更运。若纵任自在明运者果德具有此运也

次论乘具

问。世间乘有能乘之人及所乘之法及乘行具。一乘亦有此不耶

答。有也。大品云是乘及所乘因法释论云六度正是乘体。慈悲与方便此二为大乘挟具。所以然者。以有慈悲故能广运众生。有巧方便故能出生死。又有慈悲故不随二乘地。有方便故不随凡夫地。出此二地故能至佛也。故此二种名乘行具也。犹属一乘摄。但义分之故成二也。小乘法中无此行具也。次中边分别论明乘有五。一乘本谓真如佛性。二乘行即福慧等。三乘摄谓慈悲心。引一切众生悉共出生死。四乘障谓烦恼障及智障。三界内烦恼名烦恼障。余障一切行解名为智障。五者乘果即佛果也。唯识论解乘有三体六义。三体同前。一自性二空所显真如是也。二随流随顺自性流。福慧十地等法是也。三至果即随流所出无上菩提。及一切不共法也。六义者一体是如如空出离四谤。二者因谓福慧三者摄摄一切众生四境界了真俗修二谛。五障即皮肉心三障。六果谓无上菩提。此六义次第者正以真如为根本。以有如此故起福慧二行。起福慧二行故能摄一切众生。摄一切众生由照真俗迷境。故成惑则失乘理见境故能除惑。除惑故得佛果也

问。乘是何义

答。彼论释云。乘是显载义由真如佛性故出福慧等行。由福慧等行故出佛果。佛果载出众生。摄大乘论有三。谓乘因乘缘乘得。乘因者谓真如佛性。第一义空为乘因。乘缘谓万行。乘得即佛果也

问。真如佛性云何为乘体也

答。唯有真如佛性为真实。修万行为欲显此佛性。佛性显故名为法身。此三要相须。以佛性是本故名为因。虽有因复须缘因。因缘具故得果。今不违此说也。法华论亦明三种。一乘体。谓如来平等法身即是佛性为乘体。又云佛乘者谓如来大般涅槃。此即明佛果为乘体。此隐显为异实无两也。又释汝等所行是菩萨道。及低头举手之善发菩提心修菩萨行。即是了因乃为乘缘也。此犹是三种佛性义耳。乘缘谓引出佛性即了因也。乘体谓因佛性。乘果谓果佛性。不说果果性者。果果性还属果门。不说境界性者属因门故也。又广说有五。略即唯三也。又望于十二门论乘具四事。一者乘本。谓诸法实相。由实相生波若故实相为本。即是乘境义。二者乘主。由波若故万行得成故波若为主。即智慧。三者乘助。除波若外余一切行资成波若。四者乘果乘此乘故得萨婆若也。又此经明乘有三事。一车二牛三宾从。车通因果万德万行。牛亦通因果。中道正观离断常之垢为白。由此观故引万行出生死如牛。此即波若导众行义也

问。波若即是车云何复喻牛耶

答。一法二义分之。导引如牛运义名车。余行但有资成运出。唯有车义而无引导之能故无牛义也。此是因地牛义也。果地牛者内德则取真慧为牛。外用宜取六通无垢为白牛。驾之而游五道运众生也。宾从者果德为车。则因为宾从因行为车。则界外众行为车界。内行为宾从。如索车中释之。又大品明乘具五事。一者乘出即是乘始。谓从三界出。二者乘终到萨婆若。三者乘住谓万行无所住为住。四所乘法即六度。五能乘之人谓菩萨也

问。诸大乘经所明及中百大乘论等所辨此可信受。如唯识摄大乘及法华论等必可信耶

答。此论同是婆薮所造。付法藏中天亲有其人。是故可信。又观其义意。与大乘经论语言虽异而意不相违。是故可信也

问。三论学者恒弹破有所得义。云何今并用众家异说耶

答。兴皇大师制释论序云。领括群妙申众家之美。使异执冰销同归一致。以此旨详之。无执不破无义不摄。巧用无非甘露拙服皆成毒药。若专守破斥之言斯人未体三论意也

问。云何巧用云何拙服

答。若能心无所得言无所住。如空中种树虚里织罗。如幻如化。随病随人者。设行产业之事无非大般涅槃。并应正法波若名巧服矣。与此相违即名拙服。此意已如辨宗中释之。又龙树出世制作大意者。要先破洗一切有所得病。令毕竟无遗。莫问大乘小乘内道外道。有文作义及无文构造。凡心有一豪依得言有一句定相。皆悉洗之令毕竟净。然不净既去净亦无留也。如是五句令言穷虑息。然后始得于无名相中强名相说。虽强名相说说不动无说。故宝积叹云。能善巧分别诸法相。于第一义而不动。又经云善哉世尊。不动真际为诸法立处。若能于一切义皆如此用之。始是龙树大乘论耳。不尔者还同旧执。若留一豪心住著者。退无损于烦恼进不弘于佛法也。又破洗一切有所得大小病然后于一一义中宜用四悉檀贯之。今[堂-土+((口@〡)/┴)]略举一意。十二部经八万法藏皆是随顺俗。故有此言说。若不随俗则一无言无不言。故有所言皆随俗说。谓世界悉檀。十二部八万法藏言并相违。或三或一或无常或常。或佛出二谛外或二谛内。或三世有或一世有。如大经三十余诤论门。无智之者各执一意互相是非。现世起诤论增长烦恼。乃至断善根堕坠恶趣。似僧地狱正拟斯人。欲勉斯过者须用第二悉檀。所以八万法藏及尘沙法门并相违者。此是如来各各为人悉檀。故不相违背。如大经云。以此众生非一根性。非一善友非一国土。是故如来不得一向定说。以此义观之。于一切法门无所违诤。不起烦恼勉于似僧也。第三名为对治悉檀。如来所以说各各为人。说八万法藏及尘沙法门。皆为对治众生烦恼故也。如大经云。譬如大地诸山药草能为众生病之良药。我法亦尔能令众生烦恼病药。是故一切教门无有定性。但令病息。病息故无非药。病不息无是药也。既为息病病息药废。不应复执着之也。第四名为第一义悉檀者。前来三门皆是为众生故有如此方便。若论正道即不曾有一言。况有八万耶。尚非有言况是无言耶。故过一切言语灭一切戏论。如大炎四边不可触。以烧手故。用此四门可通贯一切义及文。以得此四门故一切经可构。一切病可治。不得四门一句经不可寻。一烦恼不可破也

问。何故就一乘义中释此意耶

答。一乘是三世诸佛正宗。就此中释之也。又如此了悟方是能动能出。故是乘耳。若作一句定执不动不出。何名乘耶。大经云。若有定相是生死相是魔王相。非佛法相。是故一切诸法无定无相

问曰。恒作无定相破定相者。如此即是定相

答。破定言无定耳。云何复更执无定耶

问。若都无所执者即是执乃不执于执。而执于无执故还是执也

答。今言无执者以执无故。言无执耳既言不执于执。岂执无执耶

问。执无复无无执即是断见人也

答。断一切见故名断见此可然也。大品云断一切见故名摩诃萨。正恐诸见不能断耳。又若有诸见可言断见耳。诸见本不有何所断耶。经云动心是魔网不动即法印

次论动出

问。大品云是乘能动能出是何位耶

答。论云动是顺忍出为无生忍。一者地前为顺忍登地为无生忍。二六地为顺忍七地为无生忍。若凡夫为三界者则地前为顺忍。发地入圣位出三界也。此则初地为出地前为动。若六地犹受肉身名为三界。即七地舍肉身出三界。故六地为动。七地为出。然二义之中先义为正也

问。小乘动出其义云何耶

答。准前可知。苦忍前名动苦忍名出。二者三果未勉三界为动。无学断三界惑尽为出。又有余名动无余名出。但就人而明者。小乘人唯有心出无有身出。异大乘也

次论乘障

问。乘以何物为障

答。释论既以六度为大乘体。六[卄/幣]即是障也。若取乘出生死义即着生死以为障。若取乘广大义即以狭劣以为障。若以出世六度无所得故能出。即以有所得六度为障。六[卄/幣]即是别障有所得即是通障也

次论二慧

问。空有二慧何者正是乘耶

答。旧有二释。一云空解为正乘有解为相从。例如十地空解为能生之本。有解为地上所生。次释云地义如前。若乘取运义即两解俱能运。今所明以中道正观为乘体也。中道正观非空非有。方能出有无二见故云空有并是乘方便用也。地义亦尔

次论始终真似义

问。何等为乘始乘终真乘似乘

答。有人言三十心是乘正位。有人言登地是乘正位。有人言八地是乘正位。有人言初得方便失正体。第二得正体失方便。第三得并观及乘体失不并及乘方便。故具有三义。三十心为方便。登地为正体。八地为并乘。七地为不并乘也。评曰。最后释者虽得经文。而义犹未善。今当序之。问乘品云是乘无始无终。不出三界。亦不住萨婆若。如经广明。若欲令乘出者。是人欲令无生法忍出。欲令真谛法出。然实际无生实际不出者。乘亦无出。以乘无出故无始无终。不因不果。如此之乘乃名出耳

问。若无能出所出能运所运。即无有乘。云何释大乘义耶

答。良由得此正悟不见能出所出。乃名为出。可谓无所出而出。出而无所出。若有能出所出能运所运者。即是有所得无有出义也

问。云何是出无所出耶

答。经云不动法故。不动法者非乘。是常住名为不动。亦不言真谛。空故不动。又非乘不去故不动。此明乘出宛然而无所出。故名不动也。既无出而出亦无始而始无终而终。无始而始始自初心。无终而终终于十地。此是因门分其始终。就此始终复开二位。地前三十心此观未具成名为似乘。登地已上得此观现前。故名真乘。故论云地前名顺忍。登地名无生忍。即是真似义

次论并不并

问。有人言初地并。有人言七地并。有人言八地并。是事云何

评曰。各偏有执皆为失旨。所以然者经论具有三种并义。如仁王经及摄大乘论等云初地并。大品发趣品释七地名等定慧地。即七地并。仁经等及地经云八地并。以具有三文宜并用也

问。此三相违不应合用

答。不相违。言初地并者从初发心便学并观。至于地前犹是凡夫故不得并。登地名圣故云并也。又地前名顺忍登地名无生忍。是故初地并也。言七地并者此就地位。自分之初地至六地名顺忍。七地名无生忍。顺忍虽并并劣故不名并。七地并胜故称为并

问。何以知然

答。初地望前名无生忍。若望七地名为顺忍。若将初地望地前即初地为并。若形于七地则初地未并

问。何故七地得名并六地不名并耶

答。七地是功用道满故名为并六地功用。未圆故未得称并。又且六地为波若七地为方便。以七地具二慧故得称并。六地虽有波若未具方便故非并也。复言八地并者此据功用无功用判并不并。所以然者。七地虽并犹有功用。八地任运成就无复功用。是故八地得并七地非并也。故融会三经不相违背也

次论二经

问。法华胜鬘俱明一乘。一乘何异

答。他云胜鬘了义法华未了义。今明法华既是明佛性法身即不应有了不了释也。但大乘是同略明三异。一者法华对破三执会归一乘。若胜鬘不对三缘。但为七岁已上学一乘缘。辨出生收入之义。出生者犹如大地出四种宝藏。正法出生五乘也。收入者正法出五乘。五乘归正法。此之出入舒卷皆是平道。因缘法门无所斥夺。与法华异法华先斥三病故明一乘。然后始得非三非一三一具足耳。二者法华但明二乘未究竟佛乘已圆满。不广释其因缘。胜鬘则开五住地之因。辨二生死之果。释二乘未圆佛果已满。是故两经异

问。依此义即是了未了

答。自有须释而悟。自有不须释而悟。岂得用此判了不了耶。若一经之中皆具明一切义者。即有一教唯有一缘。何名多部。三者胜鬘具明正法出生五乘数五乘归正法。法华但明会三乘归一乘开一乘为三乘。不正会人天归一乘开一乘为三乘为人天乘

问。何故两经不同

答。法华正为三乘保执自谓究竟。更不求佛。故须辨三乘会开之义。人天二乘无自保究竟之执。故不辨会开也。胜鬘通明正法有出生一切方便用。数一切方便归正法。故通明五乘有开会也

问。法华亦有会人天归一乘不

答。亦有此义低头举手皆成佛道即其事也

问。三乘既是权说。实无三者人天乘亦是权也

答。有例不例。若言三十三天常乐我净。如杨叶之金亦是权。亦须破及会也。不例者道实无三。方便说三是究竟故三是权。而不无行生死人天之因得人天果报。故人天非权也。昔又不说人天是究竟。故人天乘非权也

问。三不及一在三既权。二劣于三二亦应权也

答。胜劣乃通权实义异故不例也。人天乘得人天实报。二乘人不得究竟报故不例也

次论三假

问。乘具三假不

答。释论云五阴法是法假人是受假。人法之名是名假。所乘之法及以行具谓法假。能乘之人是受假。能乘所乘及乘具皆有名字是名假也

问。乘是因成．相续．待．三假中何假耶

答。由来四释今不具足。一释云若论因成假者宜两望之。若望以法成人人即是假。万善成人即是实法。若望总众善为一乘。一乘则是假万行为实

问。相续假云何

答。有二释。初云一念实法生而即灭。尚自不固何能运出。必须相续方有运义。如智断惑如明除闇。次释云若解断惑必须两念。排他为难故也。今善体能运一念有力。如一念智即能知境。一念善即能感乐不假相续也

今又问。若一念无力多念方有力者。一糸不能制象多糸则能制。一渧不能满多集则能满。百论破外道盛有此说。览之自见。又问云一不能多遂能者。一沙无油一盲不见。多集则能耶

答。他云盲沙分分无力。緌渧分分有力。故非问也。今明百论中外道亦有此释。如论破之

次论相续假

问。两念相续者。前念灭故后起续。前不灭故后起续。前若灭者后何所续。不灭则常何劳后续。具如论破。又问实法则灭前。而两相续则转变。今请问之。如乳变为酪复有乳灭义者。为是一乳耶为二乳。若一乳者实法灭则无。复乳何所变。若言变者复何得灭耶。若一体者灭则不得变。变则不得灭。若一灭一变则成二乳也

问曰。只是一乳而乳两义。举体实灭举体转变

难曰。实法灭者但是乳义灭而乳体亦灭耶。若但义灭则乳体不灭。则乳义无常而体应是常。若言体义皆灭则无复体义。复何所转。欲见此意中论广明。以此推之则无相续。既无相续则无至佛理。有何一乘。当知有所得义无有乘义

次问一念力能运者。此一念为即灭为不灭。若生而即灭何能运耶。若不灭即常复何所运耶。若亦灭亦不灭者。既是一念云何具两法耶。问今释云何

答。此病若销自见经意也

次论四一

问。旧云有四一义。谓一教一因一果一人。此事云何

答。此亦无失欲广论之。有无量一。谓教一理一人一法一机一境一智一。如前释名说也

问。诸一有何次第

答。如来见有一机故前有机一。说一教故次有教一。众生禀悟一教名为人一。次行一因故有因一。复得一果故名果一也

次序权实二智义论权实名

问。此经既言开权显实。以何义故名权实义耶

答。有人言权是权尔之名。实是审实为义。有人言实名智慧权名方便。方便是善巧之名。智慧是解知之义

评曰。今具详之请问。初说若妙以待粗为名。粗以形妙受称。若尔实以待权得名。权以形实为称。若权实不相待释名者。粗妙亦应然也。又难曰。若权是权尔之义以权释权。亦应实是实尔为义以实释实耶。若尔者则应苦以苦义乐以乐义。不应别有余释也

次问智慧与方便二名。然二智俱是巧妙。何故方便独受善巧之名耶。旧释云通则皆例别则不齐方便。于无三中说三善巧义彰。实智于一上说一巧义不显。故与其智慧之目也

难曰。于一上说一不与巧名。于一上说一不应与其妙称。而下文叹实智则云甚深微妙。此则实智正是微妙善巧也

又问若实智没其功名当其妙称。权智应没其妙名当其巧称。若尔实智妙而无巧。无巧应是拙。权智巧而非妙。非妙应是粗

今所释义依诸大乘经论略有四种。一依名释。谓权是权巧实为审谛。二相资释。权是实权实是权实。实不碍权权不碍实。虽实而权虽权而实。故权得以实为义。实得以权为义也。三显道释。权以不权为义。实以不实为义。故云一切有无法了达非有无。亦一切权实法了达非权实。四无方释。华严云一中解无量无量中解一。若尔一权得有无量义。无量法得是一权义也

问。非权非实为是真谛为是智耶

答。肇师云惑者睹减照谓之实。见变动谓之权。既言惑者谓之权实。则知圣心未曾权实。此正语圣心非关真谛。次别论权义。有人言权是譬名。如称锤名权。将此诠量诸物轻重。前之则轻却之则重处中则平。此譬佛智照察根缘有三乘差别。有人言权是假义。故假三车于门外。有人言权是权尔一时之用。故云权化城于中道。有人言权是耳尔。谓随宜说法名之为权也

评曰。具此四义可合用之。如来之智实有照缘。不差如称诠量轻重也。如经云我初得道时空拳度一切。又云实无三车假设三车。实无有城权作化城故假也。三乘谓一时之说。若久后则说真实。如经云。世尊法久后要当说真实。故是权尔义也。必有随机宜则宜尔之义

问。权与方便何异耶

答。通犹一耳。但权宜当一时之目。据三乘义。方便是善巧通于一三。如巧说一乘亦名方便。故方便名通于一三也

问。权亦应有二。一者实权。如菩萨权巧。二者方便权。如说三乘

答。例也

问。方便与权既有二种。实亦有二不

答。亦有二种。一者权实。昔说三乘为实者权作此实耳。二者非权实者今教明佛乘实也

次论二智体义。众师皆云二智以心为体也

详曰。今请问之。心为解惑体者。心与惑为一为异。若一断惑则应断心。心若不断惑亦不断。又若一而断惑留心。何不断心而留惑耶。若惑断心不断。则心与惑异。若异者惑便非心。心是识虑惑应非情。又惑若异心。惑自是惑心。应不惑。若尔自是智知。心终不知。如此求心竟不可得。是则无心以何为二智体。即是故论云。如身见五种求之不可得。烦恼于垢心五种求亦不得

问。今明二智以何为体耶

答。正由谓情言。心与惑一异故无有二智。诸佛菩萨了此心惑不见一异。既无一异则非心非惑。不智不愚亦不权不实。如是五句皆不可得。但于不二而二。为众生故开于二智。故二智以不二为体也

次论四种二智

问。有人言照空为实鉴有为权。此波若教二智也。内静鉴为实外动用为权。净名教二智也。照一为实照三为权谓法华二智也。照常住为实鉴无常为权。谓涅槃二智也

评曰。不然。照空为实鉴有为权。盖是契中道之妙观。离断常之要术。法身之父母菩萨之本行。从波若已上涅槃已还。乃至华严诸方等教皆通用之。不得偏属大品。次动静分二智者。一切方等教辨菩萨行。皆以内静鉴为实。外动用为权。贯通众经亦非属净名也

问。何以知静动分二智通诸经耶

答。一切菩萨皆有自行化他。今内静鉴为实是自行。外动用为权是化他义。故知通一切教也

问。何以知鉴空为实照有为权。亦通贯众经耶

答。净名云智度菩萨母方便以为父。一切众导师无不由是生。智度即是波若方便即权义。龙树释大品分为二道。一波若道二方便道。若尔净名二慧即是大品二慧。而净名既云一切众导师无不由是生。即知此二慧贯通众经也

问。前明空有分二智。后以动静明权实。皆通贯众经有何异耶

答。约菩萨一人义论两种二慧取其鉴空照有义多是自行。具如前也。若明动静义则具自行化他则如后也。次云照三为权鉴一为实。此偏约法华。是亦不然。波若后分已明与法华齐。若尔则大品亦有此义。不应偏系法华也

又问设云法华以照三为权。鉴一为实者。此三一为并是世谛。为通二谛耶。旧解云。照四种一为实。谓因一果一教一人一皆是世谛也。照三种三为权。谓机三教三人三。无有理三亦是俗谛也

评曰。不然。四一但是俗谛则一乘义局。一乘之中若境若智俗之与真皆入一乘。云何但取世谛耶

问。乘是万行故境非乘也

答。十二门论初唱略明大乘。次后云大分深义所谓空也。若通达空则具万行。若然者空为乘本。云何不取为乘耶。今所明者照一乘中。若境智空有皆属一乘。三乘亦尔。依经详之。不如旧说也

次论空有二智。有人言照空有二境审实不虚。故名实智。观空不证涉有无著名为方便

问。此出何文

答。大品云菩萨于空不着故不证空。即知不证空是方便也。又云菩萨以方便力故为众生受五欲。而无所染。故知涉有不着亦是方便

问。若以二照为实两巧为权。二照应无两巧两巧应无二照

答。二照两巧更无别体。虽照而巧故名方便。虽巧而照目之为实。如释论第百卷云。譬如金为妙物。物不离金金不离物。但妙物义如方便。全义如实慧也

问。本以二谛境发生二慧。今照二境为实慧。则二谛境应俱发实慧耶

答。正如此也。二谛发其巧照。义名实慧发其照巧义名方便也

问。古有此释不

答。什师注问疾品云。观空不证涉有无著皆名方便。似此义也。有人言双照空有皆名为实。涉有化人动用之义名为方便。此肇公释也。其序云。观减照谓之实。见变动谓之权。虽是惑者之情正用此分二智。减照者同照二谛。静鉴之义故名实也。有人言观空为实。鉴有为权。此处处有文。须真天子经广出。又净名问疾品缚解章四句论之

问。云何释经四句耶

答。异解纷纶。今以上定林寺镜师净名玄论释之。镜师云观空之心不能严土者。此是慧无方便故缚也。观空之心即能严土者。此是慧有方便故解也。若严土之心不能观空者。此方便无慧故缚也。严土之心即能观空者。方便有慧故解也。什公大意与此似同。有人言二慧互相资。方便照有而能资空。故能观空而不取证。二乘无有中行愿资。故入空便证。是知方便资空而不证空也。空慧导有令入有不着。若无空观导有则涉有取着。如凡夫也

问。方便资空令不证。既是巧者实慧导有令不着亦是巧。则二慧俱名方便亦并名实矣

答。通皆例。然但不著有则易。不证空则难。方便能令不证空。故与其巧名。譬如四河合流同注海口。非大力龙莫自能变。三解脱俱流注涅槃海。非方便大力莫能不证。以方便大力有变无之巧不堕二乘。故与其巧名也

问。方便大力能变无令不堕二乘。故名巧者实慧大力能令不堕凡夫地。亦应是巧也

答。已如前释。离圣则难。勉凡则易。故方便力大实慧力小。又实慧但是六地方便据七地。又实慧如母方便如父有又实慧三乘共。方便独在菩萨。又方便必有实。实不必有方便。又如什公答王稚远问。方便与智同是慧性。但智浅而方便深。了实相名实慧。不证实际名方便也

问。如是四说何者为实

答。佛经有种种之说。随人随义用之不得定执。如须真天子波若经下卷明二慧有三十许异可寻之也。又今略示诸异。经自有但就空分二慧。如观空为实慧知空亦复空。故不证空名方便慧。自有但就有中分二慧。如净名经。以身不疾为实。身疾为方便。又云观身苦空无我为实。处生死化物为方便也。自有空有分二慧如前释。自有福慧分二慧以慧为实。以福为权自有就自他分二慧。自行为实化他为权。自有大乘为实小乘为权。皆可随文用之各有旨也

次释法华四种二智义

有人言法华但有二种二智。一者照三乘为权照一乘为实。二者照近为权照寿量佛复倍上数为实。今明此经要具四种二智。一者初段中有三种二智。后开近显远中复有一种二智。故成四种。初段明三种二智者。初三一二智。二乘人欲入菩萨法。要先须识三乘是权一乘为实。以破彼迷权实无明。此二智是反三之始。归一之初。故先须辨之。二者空有二智既改三信一。则须学菩萨空有二慧。观空不证离二乘地。涉有无著出凡夫境。故生在佛家种姓尊贵。又空有二慧是法身父母。欲求大觉者岂不学之。三者即此空有二慧是菩萨自行耳。复应化度众生。故以内静为实外动用为权。故有第三动静二慧也

问。此三种二慧有何次第

答。初二慧令生信。次二慧令生解。信解是自行。第三明化他要具此三。二乘之人方成菩萨也。又初二慧为信。次二慧为解。第三二慧即是行。一切菩萨要先有信心。次有解后有行。今寄五十二位明之。前十信次十住。十住即是十解。以解故起十行。行解成就任运趣菩萨道。可名回向。回向既顺无生流则登平真悟。故名十地。以三种二智配此位者。初二智为信即是十信。次二智为解即是十住。第三二智即是十行。解行既成则能向菩萨道。是故有十回向。回向既顺无生流故登十地。无阶级阶级论之故作此判。若阶级无阶级者一念具三种二智也

问。何故先解后行

答。解行未始相离。但随义理强弱故前后分之。但解之易故有前。行之则难故居后也。次就此经后段明一种二智者。此经后段辨本迹常无常二智。识本是无生灭无始终为实智。识始终生灭等用谓权智。故初段具三种二智第二段常无常二智。故此经具四种二智也。晚见论分明广说法身是常化身无常。则四种二智便成五时权实皆坏矣

问。何故次前三种二智后辨常无常二智耶

答。前三种二智谓菩萨解行即是因义。始于十信终至等觉。后常无常二智即是果位称妙觉地。故因果二门要具四种二智也。次论三种二谛辨二智义。自摄岭相承有三种二谛。一以有为世谛空为真谛。次以空有皆俗非空非有为真。三者二不二为俗非二非不二为真。二谛既有三转约谛发智亦具三矣。初照有为俗照空为真。次照空有为俗照非空非有为真。三者照二不二为俗照非二非不二为真

问。何故用三种二谛耶

答。略明六义是故说之。一者谓各各为人悉檀。自有闻初得道自有闻后受悟。是已根性不同二谛非一。二者为释如来常依二谛说法。若言如来常依二谛说法者。若说空说有应依二谛。今说非空非有乃至非二非不二。应不依二谛。是故释云二谛三门说。此三门皆依二谛也。若说有为俗说空为真。依初门二谛说法。乃至说二不二为俗。非二非不二为真。依后门二谛说法也。三者为释佛教不同。经辨二谛虽多不出三也。如经云菩萨住二谛中为众生说法。释论云为著有众生说空。为着空者说有。此说初门二谛也。又云若有若无皆是世谛。故说非第一义。华严云一切有无法了达非有无。如此等经是第二重二谛也。又华严云不着不二法以无一二故。此第三重二谛也。用此三门于一切经无所违诤。是故说此三种二谛。四者欲渐引众生示阶级方便。无始已来有此形心及以外物等。谓是实有。是故诸佛出世而为说之。此是世俗实耳非圣实也。若诸法本性空者乃名真谛。故中论云凡夫颠倒为有。于世人是实名为谛。诸贤圣真知颠倒性空。于圣人是实名为谛也。而众生便谓有非实谛空是真实。则舍有取空。是故云空之与有此是二边皆是俗谛。非空非有中道之法乃为真谛。或者虽舍二边复滞中道。是故第三次明远离二边不着中道乃是真谛。二边中道皆俗谛耳。五者为五乘众生说此三种二谛。初为引凡夫令舍有入空。故明有是俗空为真。次为引二乘人欲令悟中道。故说空有皆俗中道为真。三为菩萨令中偏俱舍故。若偏若中并皆是俗。非中非偏此乃为真。所以然者。菩萨之人谓凡夫二乘滞于二边。而菩萨心游中道。为破此见故明远离二边不着中道也。第六即世学者明三假有为世谛三假空为真谛。唯有此义但初门意耳。是故引之明三假空有皆俗非空有为真。彼即云我自有二谛。复有非真俗为中道。是故今云二谛与中道亦是俗谛耳。非二非不二乃为真也

法华玄论卷第四法华玄论卷第五

        胡吉藏撰

开方便门示真实相

问。云何开方便门示真实相耶

答。开二种方便示二种真实。二种方便者一教方便二身方便。二种真实者一教真实二身真实

问。何故唯开此二相耶

答。三世诸佛唯有形之与教。于此二中有权有实。故须开示。开示此二则十二部经八万法藏焕然可了。所言开方便门示真实者。有人言昔在鹿苑人机犹杂。盛说三乘未明一理。尔时以权隐于真实。故一乘之理为权教所闭。今王城赴感乃应大机显于真实。真实既显则废除昔教。昔教被废故方便门开。一理既彰则真实相显。故云开方便门示真实相。此光宅解也

评曰。以三覆一显一除三非无此义。但经云开方便门不云除方便门。此非解也。如世人开门非是除门。详经文旨正是开覆非关废立

有人言直詺三为方便即是开方便门。所以然者昔不言三是方便故方便门闭。今詺三为方便故方便门开也。示真实相者既詺三为方便。即示一为真实。此河西道朗释也

评曰。得经旨也。所以然者。昔说三乘是真实即以真实闭于方便。故方便门不开。今明三乘是方便故方便门开。此乃是废于三实开三方便。故云开方便门

问。此亦是废立云何言非

答。此乃废三实立三是方便耳。前明废除三方便是故异也。又开义在前废义在后。要先开三是方便然后始得废之。不尔无因缘故不得废也

问。方便当体是门为是通实相故为门耶

答。具有二义。一者法门秤门则方便当体是门。如华严中诸善知识种种法门。或弄砂或相戏等皆法门也。今亦尔。如来有二种门。一方便门二者真实门。但此二门各有开闭。昔不言三是方便故方便扉掩。今说三是方便故方便门开。昔不说一是真实故真实门闭。今说一是真实故真实门开也。二者此方便法门复通实相。故三乘方便为一乘门。实相亦有二义故名门。一者当体虚通故名为门。如净名不二法门华严法界法门等。二者能通方便故为方便作门

有人言通相之功乃由乎一极。故一为方便之门。级引之功显彰于三故三为真实之相。言非三则方便之门得开。悟唯一则真实之相可示。此注解也

评曰。文似不然但意不失旨。所以然者。既由一通三岂非一为三门。说三为通一则三为一门。但一为三门此从实赴权谓出门也。说三通一从权入实谓入门也。门既有二相亦应宜然。说三表一故三为一相。说实令识权故一为三相。以理详之具此意也。但注经偏用一为三门三为一相。意犹未圆。若如前用义无失也。但上来三种皆一往方言。未究环中之极。若具论者可有三义。一者以三为方便。一为真实。二者三一皆方便。非三一为真实。三者明三一为二。非三一为不二。二不二皆为权。非二非不二为实。此之三种互得为门。如以三为一门。此以权通实。若以一为三门以实赴权。乃至二不二亦尔。既互得为门。亦互得为相。但不得互为权实耳

问。方便实相既互得为门。亦得实相为实相门乃至方便为方便门不

答。具有四句。一者方便为实相门。二实相为方便门。此二如前。三实相为实相门。四方便为方便门。如名为义门义为名门。由方便名显方便义故名为义门。由方便义显方便名故义为名门。实相亦尔。中论序云实不名不悟。故寄中以宣之。即其事也

问。今得以三显三以一显一以不

答。亦有四句。一者以三显一。二以一显三。三者以三显三。四以一显一。初两句如前。以三显三以一显一者言。昔三异今一此三在一外。今一异昔三此一在三外。故一非三一三非一三。如此一三皆是执见。今破此病故云于一佛乘分别说三。故三是一三。汝等所行是菩萨道。故一是三一。以三是一三。三岂异一。一是三一。一岂异三。故名三一因缘之义。以今因缘三一显自性三一。亦以自性三一显因缘三一。故云以三显三以一显一

问。云何名方便复有几门耶

答。方便品初具详方便得失事现彼文。今当说门义。此经始终略有十五门。方便品有二门。譬喻品有六门。信解品有三门。化城品有二门。法师品有一门。普门品有一门。合十五门也。方便品二门者。第一云其智慧门难解难入。故权智为实智门也。生法师云言教为门。言教为门者说实智。言教即是实智门也。法华论如生公释。次云以种种法门宣示于佛道。此用大乘教为门也。譬喻品六门者。一云其家广大唯有一门。还以大乘教为门也。二云于此所烧之门安稳得出者。此约三界限域为门。如詺家为门也。三者云唯有一门而复狭小。还以大乘教为门也。四者如是三车今在门外。还以三界为门也。五云以佛教门出三界苦。此用小乘教为门。六云尔时长者在门外立。依大乘义此即是用二死之限域为门。小乘义明佛出一切烦恼外。故三界正使及习气无知三藏佛皆断已尽。故在门外立也。又信解品三门者一云遇到父舍住立门侧。此以大乘理教为门。二云犹在门外止宿草庵。亦通大乘理教为门。三云尔时长者于其门内。亦通以大乘理教为门也。化城品二门者。一梵王请佛愿开甘露门。通大小教为门也。二云重门高楼阁用小乘三空之解为门也。法师品一门者即是开方便门示真实相。文中已辨。普门品为一门者以大乘为门也。此门有二种。一神通普二说法普。此之二轮皆是菩萨虚通无碍故名为门。又此二普令众生悟入故名为门

问。开方便门示真实相云何。是能开所开能示所示能闭所闭耶

答。昔权说三乘教不言三是方便。即三方便闭。佛权智为能闭。三方便门为所闭。今实智说三是方便则三方便门开。佛实智为能开。方便门为所开也。能示所示者。虽开三是方便门。则示一乘为真实。实智即是能示。一乘即是所示。故实智有二能。一能开二能示也。如人手能开门又示门内之物。是门内之物即是所示手是能示也

问。云何今昔门非门也

答。望昔三佛有二义。一就教为言。直道三乘不言三是方便复为实相作门。此是佛自闭义。二者就佛本为通一说三教。三于佛即是一乘门。就缘为论亦有二义。因三悟一故三于缘是门。不悟一者三于缘非门也

问。为是智示为教示耶

答。智说教示也开亦尔也

问。云何是当体门从他门耶

答。如权智能通实智实智为所通。从所通为名故言其智慧门。智慧即是实智。门即是权智。詺此权智为实智家门。例如三解脱门从所通为名。解脱是所通涅槃之果。三空能通行人得涅槃故名解脱门也。又世人言佛门人门等皆从所通为门也。当体得名者方便当体虚通故名为门。实相亦尔。如言竹门板门也。当门体是竹板故以当体得名也

问。此经有十五门凡有几城

答。五城也。信解品四城化城品一城。信解品四城者初即中止一城。即譬于一方垂应作佛。作佛为城也。二者于某城中舍吾逃走。譬背大乘之化。以大化为城也。三者昔在本城怀忧推觅。譬佛于法身地觅众生大机不得。即佛法身为城也。四者时贫穷子到父住城。即大机已动詺大乘理教为城也。五者化城品云化作一城。即二乘在三界外可以止息。喻之如城也

问。既有五城凡有几宅

答。凡有八宅。就火宅中凡有六宅。约义明之。初云有一大宅。二云其宅朽故。三是时宅主。四云是朽故宅属于一人。五云长者诸子在此宅中。六云焚烧舍宅。七化城品云庄严舍宅。八安乐行品云赐以田宅。初两序三界相貌。次两明属佛。后二明众生在中更起烦恼受于八苦。后二譬小乘人诸子功德。下当说之

次论三说义。论曰广开三显一断疑生信为三根人三周说。初法说次譬说后宿世因缘说。故三周说也

问。云何为三根人三周说耶

答。旧经师云初周为上根人说。次周为中根人说。后周为下根人说

评曰。直作此名于文未善。若三说各为三根三根各闻一说。则皆是上根何名三品。设云上根闻一说中根闻二说下根闻三说者。则不应言法说为上根譬说为中根宿世为下根。今所明者初周说通为三根。而上根一闻即解。次周说通为中下。而中根再闻方悟。宿世因缘说但为下根。下根三闻始了故。释论明身子一闻即证初果。目连再说方证见谛。下根理应三也

问。何以知然

答。初三请中三根皆疑。故知初说为三根人。次譬喻品身子具腾中下根人疑悔请佛释之。故知譬说通中下根人也。又具三周说于义乃备。若但法无譬义势未尽。若但譬无法意亦不圆。故须初周法说次周譬喻。法譬虽圆但明现在未辨宿世修因。次有第三说也。又一乘之道入有多门。自有乐闻法说从法说门入。自有乐闻譬喻从譬喻门入。即前二周也。自有俱乐法譬则双说两门。即第三周。故化城已前谓法说门。化城之后即譬喻门。自有于此三门皆不得悟。皆不为说。如五千之徒也

问。此与三根有何异耶

答。此不明为三根故有三说。但所乐各异故教门不同。又三周说者欲示中道相。故若一说二说则太少。若过三说则太多。今欲示中道相不多不少故但三说。又释论云诸佛语法事不过三。今依佛规矩故但三说也。又三执难改一乘难信故须三说。又示上尊大法下愍众生殷勤至三

问。若尔一切诸经并应三说

答。下文云。诸佛已说今说当说。此法华经最为难信难解故须三说。又初说令下种次说令生长后说得成熟。又初说生闻慧次说生思慧后说生修慧

问。文无此意何故强生穿凿耶

答。佛意深远非为一事。如释论解一句文凡数十复次也

次明次第

问。三说有何次第耶

答。法说为譬说之本。故在第一。譬还借事以喻前法故在第二。宿世因缘明法譬始终故在第三

次明通别。一一周皆有三说。如法说中云如优昙华即是譬说。我昔二万亿佛所教化即是宿世因缘说也。譬喻中三说者譬说之前云我先不言皆是化菩萨耶。即是法说也。又明三十子及长者为父。岂非宿世已结缘耶。宿世因缘说亦具三。化城之前是法说。化城后是譬说。故知一一说中皆是具三。但今大判云尔。又从多为论故开三说也

次明开合。束三周为二意。初周名引证例同说。后二周名直说。初引证例同说者。广引四佛为证明释迦例同。后二周不复引证例同。直说譬喻及宿世因缘也。以破三明一此事反情。一往难信。故先须广引诸佛为证。然后明释迦例同。引证例同既竟。后二周但须直说。又初周谓人广法略。人广者明五佛也。法略者但一周说也。次后二周法广人略。法广者二周说也。人略者但明释迦一佛也。下释迦教门为作譬本。故知譬说但明释迦教门也。宿世因缘亦但明释迦结缘不明余佛。师与弟子故是释迦教门也。又初周名别说谓别明五佛教门。后二周名通说。谓譬喻得通贯五佛。化城亦然。又初二周名说现在。次一周名说过去法也。又初二周明说果后一周辨说因

次明多少

问。唯有三说更有余说耶

答。大判三说耳曲论说义即多。初三周佛自说。次三根人领解复有三说。合六说也。佛三周说三长行三偈颂为六说。领解亦尔。略而言之有十二说也。就佛初周说中长行明五佛教。后偈又颂五佛合成十说也。第二周长行譬说及合譬二说偈亦然。复成四说。第三周有长行与偈为二说。各有法譬为四说。合前为十八说也。若足前略开三显一各有长行与偈成二十说也。上根人领解长行与偈为二说。中根人长行与偈。复二说各有法譬为四说。足前为六说。下根领解长行与偈。复二说各有法譬为四说。合十说。师与弟子合明开三显一之义。略明三十说也。其中说义不止于此也

次明惑障

问。以何惑障三根人不解一乘耶

答。通而为言二乘断常障一乘中道。就别明之有二种惑。一者断见二者无明。断见者二乘证空谓为妙极。无明者不识如来三一权实。然断见与无明犹是一体。但约义分之耳。保执空义名为断见。不识权实名为无明亦由无明。是故保执也。此惑非九十八使。所以然者罗汉已断九十八使。而犹不识权实。故知属无明烦恼也。晚见法华论云。无烦恼人有于染慢故。不知一乘及法身常住。此染慢即是无明也。但约此惑三品不同。下根则重中根为次上根则轻。故开三品也

问。发轸即学二乘如婆沙论释论等。云缘觉极迟则为百劫。极速则为四世。声闻极迟六十劫。极速三世。小乘既障大者。习小时久应是钝根。习小时近应为利根。二者之间应是中根

答。是义须进退论之。若二乘心是惑而能障大乘者。应如所问。则久劫行二乘行则起惑长。此执难破。应是下根习二乘行近者起惑时小。此执易倾。应是上根。二者之间应中根。但身子行小行既久。其根则利故名上根。习小时近名为下根。二者之间秤为中根也。又身子穷小之原于大易悟。余人不尔。故身子名为利根也。又二乘有被会为菩萨道。则二乘行久者于菩萨则行深也。有人言有四句一惑轻而利根也。二惑重而利根。三惑轻根钝。四惑重根钝。若惑轻利根初闻即悟。若中下两人再闻即悟。第四人者三闻方悟。此义至下五浊中当广释也

次明转根

问。上中下三根有增进义不

答。有人言。初周法说上根闻即悟。中根转为上根下根进为中根。第二周说中根同上根得悟。下根转为上根。第三周说下根同上根得悟也。有人言约三乘判上中下根。菩萨为上根缘觉为中根声闻为下根。就声闻中自有上中下根。约此三根。故有三周之说。虽复得悟犹有利钝之殊。如刀斫物一斫断者为上。二斫断者为中。三斫断者为下。虽复俱断而有利钝之别。虽前后得悟亦有利钝之殊也

评曰。后说者得经旨。何以知然。上根人得悟时中下未悟。云何已转根耶

问。今有转根义不

答。毗昙是小乘尚有转根。大乘义无有定性。云何不转耶。值恶缘故转利为钝。值善缘故转钝为利也

次明大小

问。三周说法菩萨于何时得悟

答。一往判菩萨为上根。缘觉为中根。声闻为下根。若尔菩萨及缘觉皆胜声闻。故闻初周并悟也。次更论者利根缘觉胜声闻可得名上根。释论云钝根缘觉不及身子。若尔可得同下根三周说乃悟耳。菩萨不定初心久行并是菩萨。今通论菩萨根有等声闻三品者。应三周并悟。利根菩萨与身子同品者。闻初周即悟。中下二品亦尔也。但菩萨执异迷轻又无自保究竟之惑。故利钝菩萨闻初周皆悟。何以知之。下身子得记中人天八部知皆受记。故凡夫人虽复根钝而惑轻。身子虽复根利而惑重。故同是初周得悟也

问。菩萨何故无领解耶

答。有人言菩萨亦有领解但法华经多不尽度耳。故方便品云。菩萨闻是法疑网皆已除即其证也。有人言声闻有执异之病又有自保之惑故正破之。所以有领解耳。菩萨无自保之病。设有谓大异小谓小异大。明菩萨自作佛二乘不作佛。一闻法华即得领悟。但破三归一正为二乘。傍为菩萨故不述菩萨领解也

问。声闻闻经既得记。菩萨闻经何故不得受记

答。以解领之言例记可知也。但提婆达多品授龙女记。随喜品云闻法华经一句一偈皆与受记。下寿量品中自有菩萨得记也

次会二经

问。胜鬘经云三乘初业不愚于法。自知当得觉。云何此经明三根罗汉初则生疑后便得悟

答。旧经师云有事有理。言其理者三乘初业已知作佛。实无始疑之与终悟。但符同凡夫引初业之前外凡夫人。令其信于一乘。必当作佛。故示始疑终悟耳。教中为论明二乘得果已后在游观心中。推理既一教不应三教。若定三理宁得一。故终日迥遑安心莫寄。故瑶法师云。踟蹰理教之间疑为失为不失。若以理惑教此有得义。若以教惑理此有失义。是故踟蹰生得失之疑。然根有三种。若上根利根智以理惑教情多以教惑理情少。故初闻法说符顺其心则便领悟。如身子之流。以理惑教情少以教惑理情多。虽闻法譬二说乖其本心。故三闻方悟如满愿之流矣。若中根人处利钝之间。理教相惑其心正等。闻法说未悟闻譬说便解如善吉之流

评曰。若理中已知同归。教中犹有迷悟者。则胜鬘是实说法华为权教也。若尔法华明一亦未了。不应取胜鬘意解五百由旬也。又大经云罗汉二万劫至发心处。亦是不了之说。所以然者。初业已知同归何因缘故经二万劫始发心耶。若尔涅槃应是未了。若大经是了胜鬘便应未了。又初业已知同归岂应复证罗汉。夫论证者谓为究竟故证耳。既知非极岂应证耶。又依法华论明证性法身与胜鬘不异。不应作了不了及理教释之。有人言三乘初业者。此是三乘人初信大乘故名为初业。此解于胜鬘法华两经无妨。胜鬘据初信大乘故自知作佛。法华约三乘未信一乘故所以生疑。有人言胜鬘云三乘初业不愚于法。自知者此据利根悬悟之人闻三即领一。禀小即悟大也。法华云罗汉犹疑者。此据钝根人闻三守三禀小住小。故二经不违也

问。利根莫过身子。复有何利根人而悬悟耶

答。法华中明身子等三根。此多是内秘菩萨行。外现是声闻引小行耳

问。何以知闻小悬悟大耶

答。义有四句。一者闻三悟三。二者闻一悟一。此二易明。三者闻一悟三。如闻大涅槃教。而成罗汉。四者闻三悟一即初业是也

问。法华经文有闻一悟三不

答。妙庄严王本事品云。八万四千人远尘离垢得法眼净。此义乃应通大小。而诸经中多以为小乘也。有人言胜鬘为方便之人。故自知作佛。法华据实行之人故不自知也。二经亦不相违。有人言此事不可思量解释。如大智论释毕定品云。五不思议中佛最不可思议。声闻作佛不作佛唯佛能解。论者正可论其余事。得佛时乃了。龙树既秤得佛明乃了。凡夫岂可欲专决耶。后当更论此义也

次明缘觉无领解义

问。法华座何故无缘觉领解耶。又法华正会三乘何故无缘觉众耶

答。经师种种异说皆不分明。今略解释之使易了也。佛为三根人开三乘。中根人鄙声闻从师复惮佛道长远。是以其人出无佛世成辟支佛。故法华座中无缘觉也

问。若尔何故余经复明有缘觉耶

答。总论缘觉凡有四种。一者本乘缘觉。谓本发缘觉心后得缘觉果。但此人有多经劫。而释论及余论略举有二。一极迟百劫。百劫者此是大辟支。俱舍论秤犀角喻百劫也。二极速四世。中间则多小不定。此二种人成缘觉果决定不值佛。故华严云菩萨从兜率天下放光照之。若觉知者则舍寿入无余。不觉者徙量他方无佛世界。大经譬之彗星义亦如是。中论云若佛不出世佛法已灭尽。诸辟支佛智从于远离生。若尔者法华之座何由有缘觉耶

问。大小缘觉未得果时见佛以不。如四世得果自三世已来得值佛不。乃至百劫未满所作是问

答。或值佛或不值佛此无定也。二者非本乘缘觉。其人本是声闻于佛法中证得初果。初果人但十四生满值佛则成罗汉。不值佛成辟支。如此之人或有值佛义。以其成辟支竟。而佛便出世故有值佛义也

问。华严云放光照之令灭及移他方。云何得值佛耶

答。此人本愿见佛与前人异。故不例也

问。但初果不值佛成缘觉。二果三果不值佛亦成缘觉耶

答。俱舍论云。二果不值佛法亦成缘觉。而不出三果文。但得那含竟值佛成罗汉脱。不值佛亦有成缘觉义。但此义既少故经论不出之耳

问。大辟支根既利。何故说法不能令人得燸法乃至圣果耶

答。辟支出无佛世时。此是正法已尽乃至亦无末法。此时众生根钝故无得燸法义耳。非辟支不能令其得道。辟支能化必利而所化必钝。声闻能化所化即通也。三者俱舍论复有部行缘觉。其人自有徒众部傥。如佛有弟子眷属故名部行。此人行行不必具满百劫。亦可六十劫。如身子时节故也

问。此人值佛不

答。亦不值佛也。四者变化缘觉以众生应见此人在佛世而悟故佛世有之也

问。迦叶是何等根性耶

答。此是本乘缘觉人。非七生须陀洹人也

问。本乘缘觉有无量人。始自四世终讫百劫是何人耶

答。迦叶智劣身子。即应是六十劫已下人也

问。小乘义忍法已前犹有退。三乘根性未定有三乘相作义。忍法已去即三根已定无相作义。迦叶今住何位而值佛耶

答。今须进退论之。若大辟支与佛齐。佛入道有二说。一云从燸法已入观。至尽无生方出。辟支亦尔。二释云佛从不净观已去至尽无生方出。大辟支亦然。迦叶是大辟支应胜身子。而不及身子。故知非大辟支。既非大辟支不得用前二说也。迦叶劣身子复胜七生满人。即是中根辟文。可得住燸顶二善根。不值佛而成缘觉也

问。缘觉住二善成声闻。为退根性为不退根性耶

答。燸顶既退堕恶道何不得退根性耶。俱舍论云缘觉住二善根时但闻佛教。依教得道转名声闻耳。实非退中根作下根也。今谓可具二人。一者退中根作下根。故缘觉成声闻。二者迦叶之流不值佛即成缘觉。值佛即事佛为师也。为弟子故名声闻耳。根性如故。此是不转中根为下根也。复有不转根义如七生人。不值佛成缘觉。实非退根义。迦叶缘觉成声闻。岂有退根义耶

问。法华明会三乘者会何缘觉人耶

答。正会无佛世缘觉以初开此三乘故后会之

问。无佛世缘觉何处有会耶

答。其人入涅槃生余净土中。为说法华方得会耳

问。若尔法华但会二乘人耳。应不会三

答。众中有求缘觉人。为此人故亦须会三。又为二人皆得会三。不必为三人会三也

问。何故唯有声闻领解无缘觉领解耶

答。本乘缘觉不在座故不得领解。因人行浅故未得同三根声闻领解受记。是故不说也。变化缘觉不须明其领解也。又法华会所无也

问。大辟支百劫行行闻法华一说即悟如身子耶

答曰。此义不定应当分别。若取三乘利钝而判。身子不及大缘觉一闻既悟。缘觉胜身子即闻略说便解也。而不例者。此中三根声闻久劫习大乘。故今始得缘觉。虽利不习大乘者则未得悟也。又三根人皆是方便人故闻经得悟。实行百劫缘觉义即不尔

问。法华三根人悟为皆是权行亦是实行

答。皆是权行

问。不发余人迹云何皆是权行

答。摄大乘论云。身子等得受记者。是化人为欲引未定声闻。直趣佛道。已定之者令其练根

问。云何名定未定声闻

答。小乘义忍法之前三乘未定。忍法则定也。又余经云须菩提本是青龙陀佛。又经云是阿维颜。阿维颜者十地顶人也。又大经明迦栴延及薄拘罗皆云显发如来。方便密教来至佛所故知皆权行也。晚见法华论明十种人与旧判不同。今通会之论。譬喻品从火宅文已去竟寿量品良医辟。总明十人

论曰。自此已下为七种具足烦恼性众生。说七种譬喻对治七种增上慢。应知也。又为三种无烦恼人三昧解脱等染慢。应知何等七种具足烦恼性人。一者求势力人。二求声闻解脱人。三求大乘人。四有定人。五无定人。六集功德人。七无功德人。七种增上慢者。一者颠倒求功德增上慢。以世间诸烦恼炽燃而以天人为妙境界果报为对治此。故说火宅譬喻。第二声闻人一向增上慢。谓我乘与如来乘无差别。如是颠倒妄取为对治此。故说穷子譬喻。三者大乘人一向增上慢。谓无别声闻辟支佛乘。颠倒妄执为对治此。故说云雨譬。四者实无而有增上慢人。以有世间三昧三摩跋提实无涅槃。而生涅槃想。为对治此故说化城譬。五者散乱实无有定。过去有大乘善根而不觉知。彼不求大乘于狡劣心中虚妄解以为第一乘。对治此故说系宝珠譬。六者集功德人说大乘法。而取非大乘。对治此故说王髻中明珠譬。七者无功德人于第一乘不集诸善根。说第一义不取为第一。为对治此故说医师譬。论又释云。第一人以世间种种善根三昧功德方便令入涅槃故。第二人以三为一令入大乘故。第三人者令知种种乘诸佛如来平等说法。随众生善根种子生牙故。第四人者方便令入涅槃城故。涅槃城者诸禅三昧城。过此城已入大涅槃城故。第五人者示现过去善根令忆念教令入三昧故。第六人者说大乘法。此法门同十地行满。诸佛如来密与授记故。第七人者根未熟为令熟。故示现涅槃果。为此等义如来说七种譬喻。次为三种无烦恼人染慢颠倒信故。一者信种种乘。二者信世间涅槃异。三者信彼此身异。为对治此三种染说三种平等法。一者乘平等与声闻授记。唯有大乘无二乘故。二者世间涅槃平等。以多宝如来已入涅槃示现世间涅槃平等故。三者身平等。多宝如来已入涅槃复示现身。自身他身法身平等无差别故。是无烦恼人染慢见彼此身所作差别。以不知彼此佛性法身平等故。论文显易见。若未解者今更叙释之。论意从譬喻文已去竟寿量中医譬凡有七譬但撮此七譬为七种有烦恼人说

问。说火宅旧云为中根声闻人说。云何言为凡夫着五欲妙境界者说耶

答。论意与从来亦不相违。火宅譬可含二义。一者广明火宅众苦炽燃。以此引出诸子者。此为凡夫说也。若出宅以后索车赐车赐车不虚等。此为声闻未解者说之。合而言之说火宅令出凡夫地。唐捐三车后等赐大车。令出二乘地。亦得一人始终具此二义。亦得为二人说此二譬。论但举其一故为凡。从来旧亦但为明其一。故为圣早日著文疏已两兼之。可得双用也

问。第二穷子譬乃是中根人领解。云何言此譬为对治谓二乘与佛乘平等说之耶

答。亦二兼也。若望中根领解则如旧判。若取中根是权行人。助佛开秘密藏者。则如论判譬喻品初已具明此二义也。论但举为凡由来。但明为圣。今可两而用之

问。说穷子譬云何明大小乘异耶

答。大乘豪贵譬如长者。小乘鄙劣如贫穷除粪之人。著文疏已明此义也

问。第三人云何言无小乘

答。此是弹执无声闻义。执无声闻者言。一向都无声闻。论破此故说云雨譬。明随根不同三草二木。何故无声闻人耶

问。第四化城譬为下根声闻说之。云何乃言为增上慢人得世俗禅定。谓得涅槃破此人。故说化城譬耶

答。两兼如前释

问。说化城云何破此执耶

答。此人得世俗禅定。如释论云此人得四禅时谓得四果。今破此病故言二乘真证涅槃尚是化作。非是实有汝所得者岂是实耶。又前说小乘真涅槃。以破其无而谓有。次作化城譬令进至实所。余三人论文显不须简之。次明三种无烦恼人。即是罗汉有三种执。一执乘异不知同一乘。为破此病故说一乘。次执世间涅槃异执。世间涅槃异者。谓生身是。世间非是涅槃灭身是涅槃。为破此病明多宝入涅槃即此身是涅槃非灭身也。三执彼此身异。彼此身异者不知十方佛同一法身。为破此病故说多宝佛入涅槃复现自身他身。同一佛性法身无有差别。即是显十方佛同一法身义也

问。前作三周判经今论为十人者将不相违

答。论但通明为十人。七人是有烦恼人三人是无烦恼人。而不失三周意。三周亦不失为十人意。即可得两而用之

问。依论七譬破七病者方便品复破何病耶

答。依论三种无烦恼人中。第一谓乘异病。方便品正破此义。故论下文云。方便品有五分正为破二明一也。次论大事因缘义有六重。初解开示悟入。有人言开者略开三显一。示者广开三显一。悟者略开近显远。入者广开近显远。以经四章故有四义

评曰。不然。佛于初段即开示悟入。不应二章方乃具四。有人言初句据理余三约解。凡论众生所以不知作佛者。良由五浊八苦障。其心用五浊用若强能障当果之理。理不得显即是闭义。如来出世说此经教而众生开除五浊障累。佛果知见即显。故名为开言清净者五浊在心当果之理不显。即有秽累之义。今五浊既不能为障即当果之理既显然。故名清净也。后三约解者。以其虽有当果知见不能自知。今欲令其得知生闻惠之解。故名示佛知见。复令得思惠解名悟佛知见。后令进得修惠解名入佛知见

评曰。开示悟入次第相生何故。初明其理后三明解若。以三惠故分三者地前及登地有四十位。何不为四耶。又设明理及三惠义亦不然。理既未明佛性及法身。三惠亦不得佛性法身之解。终未是佛知见也。有人言初说三乘别教为开。次说三乘通教为示。第三说抑扬教为悟。第四说法华教为。入有人言三乘通教始说大乘为开。抑扬教为示。说无量义为悟。说法华为入

评曰。教义前具评之。不应作此二释也。又法华经中自有开示悟入。云何乃引前诸教耶。例如华严中自有五十二位。及此经自有三根领解。不应引经外之文也。有人言开示悟入者。现瑞中四华正表今四事。从信方等破诸旧恶得到十住。十住始开佛知见如雨白华。次到十行分别诸法相貌即是示佛知见。如大白华。次入十回向事理不二即是悟佛知见。如小赤华。次知十地自然能通到般若海。谓入佛知见如大赤华也。故下明乘是宝车游于四方。即是游心四位中也。有人言三十心是开。初地至六地为示。七地至九地为悟。十地为入也

评曰。寻华严缨络仁王摄大乘论十七地论五凡夫论等。皆有五十二位。则地前有四十心。初即是十信。十信僧祇行行始乃得之。此二释何故不明十信但取三十心十地耶。又大集分明辨四十心。三十如前。次有四等六度。复为十心不应不取也。又此经正明三根人皆得信解。信解即十信。何故不取耶。有人言道惠初得见理。则是开佛知见。二者道种惠能分别诸法。谓示佛知见。三者一切智谓悟佛知见。四者一切种智谓入佛知见。以智唯有四故亦明四位也

评曰。释论一切智一切种智虽有总别为异一时得之。道惠种惠异说不同。然例佛智者。犹是实惠方便惠亦有一时得义。开示悟入似有深浅不同故不应同四智也。又四智位高开示悟入通于深浅。义非例。有人言约因缘义判之。谓因缘所生法知法是因缘而成名开佛知见。我说即是空。谓知因缘法是空名示佛知见也。亦为是假名谓识空不空皆是假名秤为悟也。亦是中道义即是入义也

评曰。四义横论耳。又四义之中初二后一正明诸法假名说。是教门亦非今意也。有人言约理四句论之非空非有为中道即是开。非空非有而能生空有即是示。知空有不二即是悟。了空有不二而二即入也。有人言初观三谛之理为开。三谛者有谛无谛中道第一义谛。渐渐分明为示。不见三谛一异为悟。见中道任运顺为入

评曰。此三义同前也。有人言正观中道一切种智没前三智之名。正观此理初观为开如十住。次观为示如十行。次观为悟如十回向。后观为入如十地也。故约一中道观有四品。故有四位不同也

评曰。此义不明。十信如前评也。今依法华论释四句有四义。一者无上义除一切智更无余事。如经欲开佛知见令众生始得清净故出现于世。二者同义。声闻辟支佛法身平等故。如经欲示众生佛知见故出现于世。法身平等者。佛性身更无差别故。三者不知义。谓二乘人不知究竟唯一佛乘故。如经欲悟佛知见出现于世。四者为令证不退转地示现。与无量智业故。如经欲令入佛知见故出现于世。详论意四门即次第。初开佛智为无上。次示三乘同有佛性法身。上虽明佛智无上但恐独佛有故。第二明三乘同有。虽三乘同有而二乘不知。示其令知。虽知而未得不退故。第四明令得不退为入也。又二番释云。开如上说。示者诸菩萨有疑者令知如实修行故。悟者未发菩提心令发心故。入者已发菩提心令入法故。第三番释云。悟者令外道众生生觉悟故。入者令二乘人天入大菩提故也

第二释知见

问。云何名佛知见

答。此是波若佛性之异名。正法涅槃之别目。未曾因果亦非实权。百是不能是百非不能非。不知何以目之。强名佛知见也。所以叹美为佛知见者。为对二乘不知见故也。所以明无二乘知见唯佛见者。唯佛知见是实道。自非佛知见者皆非实也。欲显实道故明实知见也。以无照而无不照故名为知。知之分明犹如眼见故秤为见。又知谓一切智即如来总相智也。见谓一切种智谓别相智。此之二智摄佛智尽故略明知见。又知即是尽智。二种生死五住烦恼皆悉清净故名为尽智。见者即是无生智。因果患累毕竟不生故名见也。二乘之人亦无此二智今始得开也

次第三辨因果

问。为辨众生有佛知见。为办佛果地知见耶

答。具二义。一者明佛果知见。如前叹佛一智令二乘之人改其小心求佛大道。二者明众生有佛知见。但昔未说故名为开。今始得说所以名为开也。晚见论释开示悟入具有二义。初义云佛知见者。如来能证如实知彼义故。第二义云示三乘人同一佛性故。前明佛证即果地佛法身。后明三乘同佛性即众生有佛性义

第四辨二因

问。开众生佛知见为辨缘因成佛。为正因成佛耶

答。由来云但明万善缘因成佛耳。前已评竟。今更责之。既但明缘因未辨佛性。云何成佛。如乳无酪性不成酪。若乳无酪性而成酪者。水无酪性何不成耶。今明佛知见即是佛性。以有佛性复修行万善。因缘具足乃得成佛也。论明四义中第二义明佛性即是正因。第三令二乘知第四令不退行皆是因缘也。又初一是果佛性。后三是因。因中有缘正五性具足也。又初番四义就果性及性门释开示悟入。后二番皆就了因门释示悟与入也

第五明开覆。凡有四句一者但覆不开。众生烦恼覆一乘佛性也。二但开不覆。谓法华教正开一乘佛性也。三亦开亦覆。即昔五乘是也。为欲开一故说五乘名开。昔说五乘未得彰言辨一故五乘覆一也。四非开非覆即是正道寂灭相也

第六辨因缘

问。何故名为大事因缘。因缘有何义

答。具有二义。一者众生本有佛知见名之为因。外假佛说一乘教显众生本有知见之义故名缘。因缘具足故名为开。若众生无佛知见虽有教门何所开耶。虽有知见无佛教者何由得开。故佛教为能开。佛知见为所开也。二者因缘即是所以。三世诸佛何所以故出现于世。正为大事因缘开示悟入诸佛知见。故出现于世也

次明五浊义初序大意。所言明五浊者为释前三后一之义也。若言三世诸佛皆为一大事因缘出现于世者。何故不发轸即说一乘。而前说三乘后明一乘耶。为释此疑故云众生五浊障不堪闻一。是以先三后一过在众生。非佛咎也。为此义故又明五浊也。晚见论云为释疑故来。有人疑佛何时说此种种方便法耶。是故释云。为五浊恶世故说三乘。此意正以劫浊为端故偏言时耳。以恶世中即有恶众生。乃至烦恼见等也

次论名五浊者。若通而为言凡是众生有此五皆名为浊。所以然者。有众生即众生浊。有时即劫浊。有生死涅槃凡圣等见皆名见浊。有所得生心动念劳役观心皆烦恼浊。未得法身慧命即是今浊。以有此五皆不得一乘净观障翳正道。岂非浊耶。要须洗之观心乃净。故波若云众生不生故波若生耳。若众生生者则波若不生。余四亦尔。欲得一乘实观生者须了五无生也

问。若如此而论者则皆是五浊应无净秽土异耶

答。如向所明皆是秽土无净土也。故仁王云三贤十圣住果报唯佛一人居净土

问。若尔五浊既障一乘。凡有此五皆障一乘不

答。唯佛居净土。唯佛所乘者为一乘耳。故凡有此五皆无一乘也

问。经何故复云五浊名秽土无五浊为净土耶

答。此就秽中开净秽浊中开净浊耳。所言五者烦恼与见此正是浊。此二所成众生名众生浊。即此众生连持之命名为命浊。此四种时谓劫浊也。若无前二后三不名为浊也。因果分者烦恼与见谓因浊。余三果浊。人法分者众生为人浊。余四为法浊。时法分者劫为时浊。余四法浊。三障分者众生命时为报障烦恼与见即烦恼障。而业含其中也。但五浊通轻重三障但是重。谓障圣道及圣道方便故立三障名也

问。三障五浊见思辨何异耶

答。见思正取惑性。品数相番五浊。及三障则通惑非惑。皆是障又不论品数相障也

问。摄大乘论明三浊与今何异耶

答。三浊即是烦恼业苦此义通三界内外及净秽二土。今明五浊但是界内唯据秽土也。三假摄五浊者众生为因成。命谓色心连待不断是相续假。相待可知也。又大乘三假者众生为受假。余四为法假。此二皆有名谓名假也。次二别论之。烦恼与见开为二者。烦恼名通诸见语别。又见谓五利烦恼谓五钝。又属爱名烦恼属见名为见。又烦恼据在家众生。见谓九十六种外道。又六十二见名为见。余皆属烦恼。众生者会众法而成为宰一之主故名众生也。即一世论也。处处受生故名众生三世论也。前通凡圣后但凡也。命与劫异者劫时长命时短。劫但时命以法带时。劫通内外命但据内。又三小劫但害众生不损外物。三大劫但损外物不害众生。三小劫但在人中。三大劫通二界。此皆短狭。若是命通三界通于五道。又劫名共浊命各各有谓不共浊故异也。然取小劫为劫浊。大劫时通也

问。几时名小劫

答。八万岁至十岁为一劫。如是八十返为大劫也

问。但烦恼与见成余三种故二种名浊。当余三种亦名浊耶

答。余三亦自是浊。如短命恶时恶人。此皆是苦果能令起烦恼及见故是浊也。然于是相带不无强弱也

次论障义

问。五浊障大乘以不

答。障大乘也

问。若尔何故凡夫具五浊而闻大乘。罗汉无五浊而不闻耶

答。可具四句。一者障重机弱谓凡夫不闻大乘也。二障重机强谓凡夫闻大乘也。具五浊故障重。有大机故机强。机强故虽有五浊不能为障也。三障轻机弱谓罗汉不闻大乘。无五浊故障轻。无大机故不闻一乘也。四障轻机强谓罗汉得闻一乘也

问。五浊但障大亦障小

答。俱障大小也

问。何以知五浊障三乘耶

答。有时佛不出世说三乘。故知五浊障三乘也

问。障小昔既得说小障大昔何不说大也

答。昔小机熟故虽有五不能为障。大机未熟故障大也

问。但由机熟则闻。不熟则不闻。则五浊不名为障也

答。五浊必是障法。但机熟故不能为障耳。如地必是障法。但物欲生时地不能障耳

问。障重则不应有机强。机强则不应障重

答。实尔也。凡夫具五浊而遂闻一乘者。此是机强而五浊有时废不常现前故障弱也。前作此判者取其有五为重无五为轻也

问。得言重品障小乘轻品障大乘不耶

答。就罗汉一人始终亦有此义。而罗汉断钝利皆尽无有重品。而不识权实即是无明证于断空即是诸见。此二即是二浊。以此成众生谓众生浊。不离于时即是劫浊。色心连持名为命浊。若尔罗汉具五轻浊也

问。何以知五浊为重不识权实为轻耶

答。罗汉断五浊尽而犹不识权实。则知重品虽去轻品犹存也

问。就凡夫可得作此判不

答。不必尔。如凡夫具有五浊而复不识权实。则具轻重俱障一乘。但大机既强此二不能为障也。又约大小乘各有四句。小乘四句者。一根利障轻如身子等。二根利障重如鸯掘摩罗等。三根钝障。轻如蛇奴等。四根钝障重如凡夫不得圣道者也。大乘四句。一根利障轻多生他方佛土闻大乘。二根利障重三根钝障轻。此二多值佛初成道说华严得了悟也。四根钝障重者为此人初说三藏。乃至终闻法华也。此大略判耳

问。五浊得论别障以不

答。后偈云贫穷无福慧。而有五浊。见浊正是无明。障慧余皆障福德也

法华玄论卷第五法华玄论卷第六

        胡吉藏撰

论罗汉知一乘不知一乘义

问。得罗汉意即自知一乘。为得说法华方乃知耶。又方便品以简真伪章二文相违。初云若实得罗汉不信此法无有是处。若不信此增上慢人。非阿罗汉。此明罗汉必信一乘。次文云除佛灭后现前无佛。明佛灭后罗汉亦有不信一乘。是以二文互相鉾楯。云何会通

答。此义前已论之。后当广说。既为一经之难今略云其相也。有人言一切得道并知得归常住。若知同归常住皆是菩萨。无有二乘成圣。故大经云不知常住尚不得二乘菩提说后无上道。若尔前章明罗汉。此名据权行之人。后明不信者此据六心之前有实行声闻。故不信了。有人言一切道要得会空。不必须知同归常住。故亦有知者亦有不知者。利根则知钝根不知。前文据知者后文据不知。有人言前说就理为论。三乘初业不愚于法故。凡是罗汉皆知同归。闻经则信。后就教中为论。罗汉禀小乘教成圣不知同归。例如大经云。十住菩萨如来不说。不知佛性。今亦然也。有人言是真罗汉则知。后据末世凡夫故是不知耳。所以然者。凡夫具足三毒闻经尚信。况末世罗汉而不信耶。有人言此为时座今其专听速决疑心。若不信受则抱疑永世以传。后佛来令促乘可以决言

评曰。盖是一经之大宗不可存于异释。然众师厝意不同皆言二文相违。故异释纷纶耳。今明二文不相违也。前明是真罗汉者闻经必信。若闻经不信者此非罗汉也。后文佛更简之。若真罗汉闻经必信。颇有罗汉不信一乘以不。是故释云亦有此义。即佛灭度后现前无佛复。无传经之人及所传之法。阙此三义则罗汉亦有不信义也。若佛虽灭度有传经人及所传之法罗汉闻之则便信受也

问。佛灭度后无人法故罗汉无所信者。何故信耶

答。佛自更释之。若值余佛则能决了。若尔者前后二文无相鉾楯。不应异释纷然也。晚见法华论亦不明二文相违。除佛灭后现前无佛者。论明云何如来不成不堪说法人。为断此疑如经。除佛灭度后现前无佛故也。论意明。如来在世说一乘必然令罗汉信受。故不成不堪说法人。明除佛灭后无复佛者则有罗汉不信耳

问。依此释者则罗汉闻法华经始知作佛。不闻则不知作佛以不

答曰。如是

问。何以为证

答。即向释文为证也。又前身子云而今乃自觉非是实灭度。则知尔前皆未觉也。及三请之中一切二乘皆生疑惑。若自知作佛何所疑耶。法华教起复何所为耶。又下化城品分明说之。我灭度后复有弟子不闻是经不知不觉菩萨所行。而于自功德生灭度想入涅槃。我于余国作佛为说是经方得神契部知作佛也。又释论解毕定品亦作此说。明罗汉生三界外净土得闻法华经修行求佛。故知二乘不闻法华不知同归也。又二乘自知作佛者何得云为诸声闻说妙法华经

问。大经云不知常住不得二乘菩提。今云何言得二乘菩提不知常住

答。大经复云为诸声闻开发慧眼。说秘密藏。如其已知则慧明已发。云何更开。又二乘已知则无复八倒。何所斥耶

问。不知常住不得二乘菩提云何偏耶

答。此呵啧二乘保执昔教。汝不改无常不信常住者。亦不得二乘菩提故作此呵耳。又此是欲时会令信常住故。又若不知常住不得二乘菩提。若不知常住亦不得三归五戒。若尔者涅槃之前无佛弟子皆是俗人也。而经但云不识常住归戒不具足耳。非不随分得之。二乘亦尔。随分断三界惑成罗汉耳

问。既断三界惑尽云何不同归耶

答。外道亦断三宫惑尽可言惑尽即知一乘耶。二乘之人但胜凡夫一阶。不应全闭菩萨也。又难曰。断惑要论知同归常住者。外道断亦应然也

问。外道伏惑实不断也

答。伏惑断惑此诸部异之。佛陀人云伏惑萨卫人断惑。不应偏用。又大经亲。言外道断惑不言伏。又释论摄大乘论皆言外道断惑不应言伏。又毗婆娑云以迦旃延子为三明六通大阿罗汉。及五百评解者亦是罗汉。龙树呵云。汝于八揵度中处处有失。况名解大乘义耶。诸罗汉答云。乘闻大乘心都不信。若罗汉闻大乘为有失复云何不闻而自知耶。又佛灭度后五百部闻大乘法毕竟空如刀伤心。况闻常而即信。彼云何能知常耶。又化城品云大通智胜佛说法华经。十六菩萨即便信受。声闻众中或有信受成不信者。然罗汉值佛闻法华经尚有信者及未信者。云何不闻而自知耶

问。若二乘不自知作佛者。何得胜鬘云三乘初业不愚于法自知当觉当得耶。又优婆塞经十四品说自知应得菩提。而且取小乘果。十三品中正明受戒得三道果。以知之甚易行之甚难。故虽知一乘而取证罗汉

答。此义前已说竟。利根者得知钝根不知。又过去久习大乘者闻小乘教得道即悟大乘。如此人即知。不尔者不知。又实行者不知权行者知。此义索车中广说。晚见法华论开示悟入作四义释之。第三义名为不知。不知者以一切声闻辟支佛不知彼真实处故。不知真实处者不知毕竟唯一佛乘故。此文分明释二乘人不知一乘也。第二义明三乘同有佛性法身即是常住。二乘人既不知一乘。不知常住佛性。不应云得道者。恶须牒解常住。此证上不知常义也

问。凡夫人常知作佛。罗汉是圣人何故不知作佛耶

答。法华疏云。三种无烦恼人而有染慢颠倒信故。一者信种种乘。二者信世间涅槃异。三者信彼此身异。为对治此三种病故说三旗平等。一者乘平等。与声闻授记唯有大乘无有二乘也。二者世间涅槃平等。以多宝如来入涅槃是世间涅槃平等故也。三者身平等。多宝如来已入涅槃复示现身。自身他身法身平等无差别故。是无烦恼染慢人见彼此身所作差别。不知彼此佛性法身平等故。论释三义中初明罗汉不知一乘。后明罗汉不可知佛性常住。所以不知者。虽无界内烦恼而有染慢。染慢即是无明。此是智障。是故不知也

问。若尔者凡夫能知一乘常住者应无无明耶

答。凡夫但是信佛语名为知耳。此未足是证。罗汉破此无明即能决定知异凡夫也。又佛种种方便度脱众生。闻知以悟则为说知。闻不知以悟则为说不知

问。说知不知有何义耶

答。佛为七岁已上学大乘人说。二乘人尚自知作佛汝云何不信大乘耶。又化城求二乘人作如是说。已证罗汉者自知作佛。汝云何欲证罗汉不求佛耶

问。说罗汉不知者何义耶

答。此依小乘教令证小乘果。若说自知成佛岂求小乘耶。譬本义八重第一序来意。有此文来者凡有二义。一者颂上长行二者为下譬本。所以为譬本者利根已解中根未解。故复以譬还辨前法。是以先法为后譬本也

问。后譬文长何故但譬此中法也

答。此文虽[打-丁+豆]总序释迦一化始终。故得为后譬本。第二定譬多少。古旧开为五譬。一长者譬。二思济譬。三权诱譬。四平等譬。五不虚譬

评曰。初实总譬非独长者。思济者思惟救济。此是一乘化不得义了。犹少见火譬不用此释也。光宅云十譬。一总二见火三救子不得四救子得五见子免难六诸子索车七见子免难欢喜八等赐大车九得车欢喜第十不虚譬。此中十法为后十譬作本也

评曰。十譬起即光宅。众师所无。今以四义评之。一者若以句断有九句不应十也。若以义分唯有六义。一总二见火三二乘化不得四三乘化得五还说一乘六不虚自余细句皆是枝流。收摄属此六义也。今进不取句退不依义。故十譬非也。二者若六十譬则法譬颠倒。法说之中索车在前父喜居后。譬说之中父喜在前索车居后。虽欲会通终成迂曲。至后自显也。三者大小相违之。先法说中见大机动故喜。譬说中见小机免难故喜。法说明其大因譬说序其小果。法说大障将倾。譬说小难已离。义势即乘小应相主也。四者有无异。法说中序上根易悟故无索车。譬说明中根犹惑故有索车。若尔恭敬之言用为索车之本。殊不体文意。此四义品下文自显也。今依六譬无此四先也。第三明有无者。长行有五。一开三。二显一。三五偈。四真伪。五不虚。今偈六。五但长行。有真伪偈则无也。偈有欲法长行则无。属显意也。余者皆同也。第四明次第。长行先开三后显一。偈先显一后开三。余者同也。第五明开合。开三显一为总譬本合而不开。次离五浊文为四譬之本开而不合。不虚一章还为不虚譬不开不合也。第六明取舍。四段经文为六譬之本取而不舍。叹法一章非六譬本舍而不取也。第七论总别。初开三显一总序释迦一化教门也。从五浊去皆属别譬。第八明本迹。总叙佛教总含本迹也。从五浊去别明本迹。五浊一章正明居法身之本。见众生有苦无乐起大悲心。起从一乘化不得去。皆属以本垂迹八相成道。始坐道场终讫今日说法华教也。索车义释有二重(一明索二释车)。初门十句论名也。第一论曰。文中无索字但有赐言。长行明愿时赐与偈中云愿赐我等三种宝车。虽无索字言但愿时赐与即是索也。然索有二种。一者许故索。如偈云愿赐我等三种宝车。如前所许诸子出来。此索先所许也。二者未许而索。如世人乞索名索。然索前所许可名为索。未许称索宜作求名

问。此文唯有索许。亦索未许耶

答。具有二义。一者索许名索。谓三乘人索果义也。若以求索名索。大机既动扣佛说于一佛乘。故有未许名索也。此就言许及言未许故作斯判。若言意合论者皆是许也。言许于三是故索三。意许于一所以索一。亦是显密二许。显密二索。显许其三密欲与一。言显索三机密索一也

问。此二索云何解惑耶

答。求一为解索三为惑。不知无三假说三就父索三。故是惑也。大机扣佛以求于一故是解也

第二辨大意。先总叙三譬次明索车。总序三譬者。一索车二赐车三得车欢喜。此三属大乘化得故合为一段也。可拟上三处。一者拟方便品末三事。索车拟上我见佛子等发大机也。赐车拟上于诸菩萨中正直舍方便。但说无上道也。得车欢喜拟上菩萨闻是法疑网皆已除。千二百罗汉悉亦当作佛也。二者拟譬喻品三事。索车拟身子腾学无学人疑悔也。赐车拟佛詶请说法也。得车欢喜拟信解品中中根人领解也。三者还譬上方便品三事。索车拟三请中大众执动疑生也。赐车拟佛詶请广说也。得车欢喜拟身子领解也

问。但应拟中下根人云何更拟三根人耶

答。三请中通明大众皆疑悔非独身子。故得拟之。又今虽别为中下根人说譬。但佛就一一周中总序一化大意。遍为一切乃至为末代世众生令识一三权实义也。次别序索车大意者。上一乘化不得故虚指门外明有三车引出诸子。诸子并承权出宅。有智之者不执父言。悬领父意知权有实无则无所索。无智之子执父之言不领父意。未鉴权有实无。是故有索。佛以此喻令执三之徒因此而改未信一乘。藉斯而信故前身子请云。善哉世尊愿为四众说其因缘。今说索譬即说因缘詶其请也

第三明索人

问。为是三人索三。为是二人索三耶

答。旧经师云。三人索三车也。何以知然。下文云尔时诸子各白父言。愿赐我等三种宝车。故知三人索三。又所以索三者。实无三乘但昔于一佛乘方便说三。以是方便所以索也

评曰。今以十义推之不应有三人索三也。一者本以三车譬于三果。故云今此三车皆在门外。二乘人出门外至许车处觅果不得。可言索果。菩萨之人未至许车处觅佛果不得。何有索佛果耶。二者设云六地菩萨出三界外。乃不索佛果。亦同二乘索尽无生智。故菩萨三人亦有索者。是义不然。寻大小乘经无菩萨索。小乘中明二种菩萨。一者所化菩萨。始自发心终至补处。皆是凡夫。无出三界之义。则无有索。故弥勒观经优婆离白佛。是阿逸多未断三毒命终当生何处。故知始行终心皆是凡夫。不得出门外索也。二者能化释迦菩萨。三十四心成道三十三心犹是菩萨。三十四心是佛。三十三心是菩萨。而见谛已倾思惟未尽。此时未出三界故无索。三十四心见思俱断结习皆亡。尔时出于三界。便是佛果亦无索也。又小乘法中尚无出三界菩萨。何得言菩萨出三界而索耶。又三十四心成道无出观义岂有索耶。又本就佛索果。释迦菩萨就谁索耶。又大乘经中明有十地。至第六地时断三界正使尽。岂不知有七地而就佛觅究竟果耶。三者若救云都无三藏中佛。道理而权言有。即是昔有今无。菩萨何故不索耶。若无菩萨索者三藏中明。佛菩萨皆应是究竟实有也

答曰。原索意者本为昔有今无。是故索耳。若今昔俱有者必不索也。寻大小乘经始终皆明佛乘是有。如初教明佛乘是有。至法华亦明佛乘是有。以始终明佛乘是有故不索也。后见法华论亦明唯有佛乘无有二乘。凡有二义。一者云无有二乘涅槃唯有大乘涅槃。名为佛乘。前已答竟。二者总序方便品有五分。明义但为破二明一。若尔不言无有佛乘。菩萨何所索耶。法华前后文无有言佛乘是方便。但言二乘是方便。故二乘人索菩萨不索

问。今昔佛乘是有者亦应今昔明佛乘是究竟

答。佛乘是有斯义究竟。但就有之中说尽不尽故有究竟不究竟耳。但昔教说佛乘不具足。今教明佛乘具足。释论云佛于三藏中不具说佛功德略有三义。一者有无不具足如三藏中不说十八不共法等。唯大乘说之。二者说不尽故不具足。如三藏中说十力。不言尽智遍智而言尽智遍智者。此是诸论义师说耳。三者于一科中半说半不说故不具足。如三藏中唯明三眼。大乘经中具说五眼

问。何以知三藏中不说五眼

答。杂心论及舍利弗毗昙皆云唯有三眼。肉眼天眼惠眼也

问。昔说佛既不具足。即是方便。道理唯有具足无不具足。昔有此不具佛今无此不具足佛。即是昔有今无。菩萨应索不具足车

答。权实有二种。一者有无论权实。二者具足不具足论权实。有无论权实者无二而说二。故二乘是权。有一而说一故佛乘是实。二者具足不具足论权实者。昔说佛乘未尽为权。今说佛乘尽为实。索车之义者正就三乘有无义有索。不就佛乘具足不具足明索义也。又反责曰。若言昔不具足故今索者。依汝义法华中明佛果义犹是无常。即是果车不具足。若尔至涅槃时应有索无常果车也。法华但为缘因未明正因。则因车不具足。至涅槃时亦应索前不具足因车也。而涅槃时无有索。法华不具足车者。当知至法华时亦不索尔前不具足佛果也。四者譬中云三车门外者此总相说耳。依昔义者二车在三界正使门外。佛果在习气无知门外。二乘人以正使限域为门。佛以无知习气限域为门。昔说二乘人尽无生智在三界正使门外。今二乘人断正使尽而不见车。是故索耳。昔说佛果在习气无知门外。今菩萨断正使尽习气无知则尽则便成佛亦无索也。大乘菩萨有正使无知习气二门。今出正使未出习气无知门。遂索果者二乘有见谛门。复有思惟门。今出见谛惑门亦应有索。声闻既不尔。菩萨何犹然。进退往论大小穷捡。菩萨之人无有索也。五者经明三乘是方便可言索三。又云唯此一事实余二则非真。又云世间无有二乘唯一佛乘。以此推之唯索二乘不索佛乘。六者若言昔明三乘皆是方便者。从大品已上乃至法华之前明佛乘皆是方便。若佛乘是方便六度等因亦是方便。若尔者付穷子财之珍宝库藏皆是方便说耳。应非真实也。若付财之宝遂是夜光非鱼目者。则大品明佛乘已是真实不名方便

问。付财之宝即是委属家业珍宝者。说波若时已应是说法华也

答。于他为难于今是通。故方便品云为此诸佛子说是大乘经。既称说是经者当知波若之时已是说法华也。但教菩萨故作波若名。未教二乘不作法华称耳。此义已如前说也。七者方便品初偈文叙昔说二乘。复明二乘是方便。叙昔说大乘不明大乘是方便。但明为此诸佛子说是大乘经。则知佛乘非是方便。菩萨不应索佛大乘也。八者既有三人索者何故无菩萨领解耶。但明二乘领解不明菩萨领解。故知无菩萨索也

问。若以无菩萨领解谓无菩萨索者。亦无缘觉果人领解应无缘觉索

答。无缘觉领解此有其义。以缘觉果人出无佛世也。又法华座中所无故不叙其领解。菩萨有座何义故不明领解耶。九者下合赐车云。见诸众生出三界若得涅槃乐。是故赐以大乘。若尔二乘人得涅槃故与大乘。菩萨云何已证涅槃耶。既但赐二乘当知但二乘人索。用此一文可断得失也。十者诸子安座故就父索。二乘人果满息求不复修行。故名安座。可得有索未出门。菩萨本知车非正使门外。出门菩萨故自知之。则始终二人俱有前进之义。无安座之理。是以菩萨无索车义也。又合赐车云。不令有人独得灭度。皆以如来灭度而灭度之。独取灭度可有二义。一者昔日菩萨受记作佛故。菩萨独得如来灭度。二乘人昔不得作佛。故不得灭度。今日令二乘人亦得如来灭度。故名等赐。二者昔二乘人独取小乘灭度。今令同得大乘涅槃。以此二文推无菩萨索。既言菩萨独得如来灭度。菩萨何由更索。又昔二乘人独取小乘灭度。故今以大车赐之。菩萨不尔。云何赐菩萨耶。即以此文破四车义也。若三乘皆索则失独得灭度之言也。夫论独者此是偏谓此人得彼人不得故名为独。若三乘皆索何有独耶。今所明者但二乘人索菩萨不索。如上十推

问。若尔者唯应索二。何得文云愿赐我等三种宝车

答。昔说三乘是实今遂云有一无二。昔有三之言竟何所在。以今无征昔有。亦以昔有难今无。故名为索也。经师不体此言故谓三人索。致成异说。今观其言甚易见耳

问。经文题三车名。就文索之故云羊车鹿车牛车愿时赐与。云何背文但言二乘人索菩萨不索耶。又并曰若二乘人索三者应二乘人乘三车。二乘人实不乘三。二乘人亦不索三。又并曰若二乘人索菩萨车者。菩萨之人应索二乘车也。文义往推进退穷捡。幸宜依旧无俟斯通

答。若领解前通无俟后问。盖是腾昔三以征今一耳。昔本道三今遂云唯此一事实余二则非真。若尔昔日明有羊鹿牛车为何所在。腾三征一文义焕然。下诸难并不通自去。宜改旧迷以从新悟也

问。何以证知二乘索三车耶

答。本为二乘人开三乘耳。初以一乘化之不得。故于一佛乘分别说三。谓三乘化得今明无三唯一。故二乘人索觅三也。又此经始终正为二乘人说。故二乘人索三。今当具烈三周文证之。方便品云告诸声闻众及求缘觉乘佛以方便力示以三乘教。既但告二乘人明方便说三不告菩萨。故知三乘教为二乘人也。次三请初但明二乘人执动生疑不明菩萨。故知二乘疑无三有一也。三者十方佛劝释迦云。少智乐小法不自信作佛。是故以方便分别说诸果。不明为菩萨分别说三也。故知为二乘人分别说三也。诸果者谓三乘果也。次第二周文。身子腾学无学人皆堕疑悔。请佛重说。不明菩萨疑悔请佛重说。故知第二周说但为二乘人。云我今还欲令汝忆念本愿所行道。故为诸声闻说大乘经名妙法莲华经。不明为菩萨说。第三周文云。若如来自知涅槃时到众又清净为说此经。世间无有二乘而得灭度。唯一佛乘得灭度耳。又云唯有一佛乘息处故说二。以此三周文证。故知开一为三。但为二乘人。今会三归一。亦为二乘。若尔索三之义亦二乘人索

问。二乘人出门外但不见二车。亦不见三

答。出正使近门无有二车。是故不见。未出无知习气远门亦不见一大车。二车无故不见。大车有而未见也

又问亦得近远二门俱不见三以不

答。若言于一说三实无三者。近远二门俱不见三。若就三中自论虚实如云唯此一事实余二则非真耳。出近门不见二出远门见有一也。又近远二门俱不见二以无二。故近远二门俱见有一。一是实有故。出远门得一出近门知有一。此据菩萨也

问。罗汉出界外故索缘觉亦然不

答。当法华座唯有罗汉无缘觉果。故唯是一人索三耳。非二乘果人索三也

问。若是一人者何得文云诸子就父觅车。既云诸子则知三乘人也

答。下合譬中云若见无量亿千众生。以佛教门出三界苦得涅槃乐。便赐大车。此约罗汉非一故有诸子耳。又虽无缘觉悬为缘觉果人。作索车譬合缘觉因人领解亦义无失也。又即以此文证无菩萨索车义。但罗汉一人即得索三。岂须三人方索三耶

第四明时节

问。何时索果耶

答。旧云得罗汉已后法华之前此时有索。昔佛为三乘人说若能断三界烦恼即得尽无生智。三乘人即依教修行断三界惑成无学果。此无学人并具三明之解。有未来生死智通。在闲暇心中思惟量度遂见未来犹有生死因果。生死因未尽未有尽智。生死果未倾未有无生智。若尔佛云何言断惑尽故有尽智。果亡故有无生智耶。故就佛索觅尽无生二智也

评曰。寻第二周譬说意正在索车。若斯言可领众譬自明。今请问之。若得罗汉即索二智者。此时已应执动疑生。若尔法华唯开三显一。便为无用。故何者。开三显一本为动执生疑。未说之前疑执已动。何烦复用前略说耶。又难若未说法华已生疑者。身子得果竟已应云我今自于智疑惑不能了。为是究竟法为是所行道。岂待说法华方有此唱。又领解中云初闻佛所说心中大惊疑。若前已执动何事今闻而始惊疑耶

问。若说法华之前未动执生疑者。何得身子云欲以问世尊为失为不失

答。文已释之。此文不明理中无三教有三。但保执昔教谓永失大乘。复见如来诸胜功德而帐帙迟回或恐不失。是故致有此难耳。若实见未来生死因果者。必知修行作佛。何事嗟伤耶。即以此文破子所说。又依汝此义净名次法华。而诸声闻于是净名经自云。我等何为永绝其根。于此大乘已如败种。又云高原陆地不生莲华。何得云尔前声闻以理疑教以教惑理。踟蹰理教之间。既踟蹰理教之间复何得云永绝其根已如败种。自成鉾楯不可会通。又问罗汉得果竟即索者。依汝义从初教至法华之前未明三界外事。云何尔者。已见未来界外生死不尽耶。若言深解故见界外事者。何不深解即知三权一实耶。又阿罗汉见未来生死不尽者。此是理中说。为是教中说。若理中说三乘初业已知当得作佛生死未亡。不待证无学方始知也。若教中说者。法华之前大乘教尚未明三界外事。云何三藏教中得罗汉。后即见未来生死不尽耶。今所明者昔日未索今始索也。何以知之。前救子得譬属昔三乘化得义。索车譬属今一乘化得也。故以知约今明索昔不索也

问。何故昔不索今明索耶

答。昔教明实有三。复而自谓实得于三。是故不索。今教明无三时会。闻无有三即便生疑是故索三。如父母以空卷诳子。云谓手实有物子谓实有。子便止啼。复知空卷方就父索也

问。文云诸子出宅则就父索也。云何言昔不索今索耶。若尔今始出宅昔应未出

答。若出门即索亦应出三界竟即知无三有一。今捡法华三周文但明罗汉闻法华经始知无三。未闻之时不知无三。何者身子领解云我悉除邪见于空法得证。尔时心自谓得至于灭度。而今乃自觉非是实灭度。此文分明云法华之前自谓实得三。闻今教始知无三也。第二周文云是诸千二百心自在者是学无学人亦各自以离我见及有无见等谓得涅槃。化城中云于是众人前入化城。生已度想生安稳想。故知三根之人未闻法华自谓究竟。不知无三。云何言得果毕即知无三而索三耶

问。譬中明出宅即便索车。如向所引至法华时方索。斯则法譬相反云何会通

答。须得譬意。意不论索之久近。但作痴子无知不领父意不识权实有无故就父索用此晓于时会令改三执耳。是故法譬言不相违。后见法华论释三请文明。有三种义。一者决定义。二者疑义。三者依何事疑。决定者有声闻方便证得深法。作决定心得涅槃证。此明尔前证得涅槃生决定究竟心。不疑为究竟为不究竟。若尔前已疑者疑名犹豫。不得称为决定。以论推之则知尔前犹未索。闻今教生疑方乃索耳

问曰。汝引法华论证尔前不索者。我亦引法华论证知有菩萨索。论释三请中惊怖文云有五种惊怖。一者损惊怖。如二乘人取小为实谤无大乘。二者多事惊怖。以大乘人生如是心。我无量无边劫行菩萨行。生惊怖意起取异乘心。三者颠倒惊怖。分别我我所见身不善故。四悔惊怖。如身子云我不应证如是小乘。五诳惊怖。增上慢比丘作如是言。云何如来诳于我。观此五惊怖第二有菩萨惊故有菩萨索。第四身子悔故尔前已索。将非汝解与论相违耶

答。若以惊怖为索者。诸大乘经皆云闻大乘法惊疑怖畏。法华应是索也

问。即以此言相难。既以疑为索者诸大乘经皆明闻大乘惊疑。皆应是索也

答。须谛论文语意。论云菩萨惊怖起取异乘心。故若以此文为索佛乘者。菩萨正应觅昔日佛乘耳。何得起取异乘心耶。今释论此文者。正言大乘甚深二乘之人闻之生谤。如五义中第一。菩萨闻大乘甚深。唯佛能究竟解了余人不解。如上发心已上不退已还皆不能了佛智。菩萨闻此言欲退取二乘。故言起取异乘心。故非是索菩萨乘也。身子之悔前文已通

第五明有索无索

注经云。修空离有则空有同尽。若实在门外唯见一极。则众求自亡何有索情。今欲辨三乘初业之所期将显终成之所会。故假设时与之。言以彰等赐之义耳

评曰。注依胜鬘意释故无索义。此得在于彼经失在于此教。此教既明有索不应言假设也。基公云无别有索。但大机扣佛义同于索。所以然者。大机既发反望昔则无有三乘故言索三耳

评曰。基公得在于求一失在于索三。所以然者。实有机动求一。复有情中索三。偏执一机失三情索。故非所用也

第六明大小

有人言索一大车非索三也。何以故者。父既赐大则知索大。若不索大何由赐大。有人言文云愿赐我等三种宝车。不应背文言索一也

评曰。偏执二文俱失圆意。考其旨归具索一二也。以大机既动是故求一。情执于三所以索三。机情合论则三一俱索

第七会二经

问。依胜鬘初业已知无三此则无索。就此经无学犹惑于教是故有索。云何会通

答。旧云胜鬘是了义教理实言之。是故无有索也。此经就教所以有索

评曰。此义已如方便品广释二经同异。今更叙之。若胜鬘是理说此经据教者。亦不同旧释明三乘人保昔教。谓有究竟是故无索。今教无三故就佛索三耳

第八三根索不索义。旧云但中根人索利钝二人不索

问。何以知二根不索耶

答。化城云。生已度想生安稳想。执教作解是故不索

评曰。不然。寻三根人皆有索也身子疑云我今自于知疑惑不能了。为是究竟法为是所行道。即是上根索也。第二周中有索车譬。验中根人必有索也。上中二人既索即知下根亦索

问。下根人何故无索文耶

答。身子譬喻品初总腾中下根皆有疑悔。故即中下根人有索文也。又以义推之昔三根皆保执。昔教自谓究竟。故并无索。闻今教无三究竟故皆有索。则义可知也

问。三周文皆明三根人有疑执。云何是索耶

答。若不用疑执为索者。复取何文为三根人索耶。又鹿园已后法华之前何经中说三乘情索耶。今明但法华时三根有疑故有索。尔前无疑故不索也

问。若三根人皆有索何故第二周有索车余文无耶

答。上根人索三。佛于方便品中直为法说便悟。不须作索车譬。中根人未悟为作索车譬便了。下根闻索车譬不悟更待化城譬乃解。若皆作一譬何名逗三缘耶。复何名三周说异耶

问。若以疑为索者。凡圣一切人疑应一切人皆索。而今出门不见有三可索三。门内未见有无云何索耶

答。门内人及门外人并执昔教俱有三究竟果。今闻无三故内外人俱索三

问。门外人索云何异

答。门内人索于当三。门外人索于现三。是故异也

问。文但云出门外索。不云门内索。何故违经耶

答。佛说譬喻欲令易解。令寄门外人索三通晓时会疑悔也。又反责曰。若但门外人索者。亦但赐门外人车不赐门内人车。但应无学受记作佛。学人应不得记。无学人所行是菩萨道。学人所行应非菩萨道。今赐车之譬虽赐无学实通赐一切人。亦虽无学人索实通一切人索也。经师不究竟其始终故不识譬意耳

问。若以疑为索者方便品云。菩萨闻是法疑网皆已除。若尔菩萨应有索也

答。菩萨疑与二乘疑异。二乘昔谓究竟今闻无究竟。是故以昔疑今。所以有索。菩萨不昔自谓究竟今闻无究竟。是故生疑。所以菩萨无索也。但以始行之人疑昔何故说三。今何故说一。今昔三一相违。故生疑耳

问。菩萨疑昔明有三今明无三。即是菩萨索耶

答。领上一有二无。此疑又息。二乘索三终为索二。菩萨疑三亦为疑二也。佛乘始终皆是有。故不疑不索也

问。菩萨亦有索佛乘以不

答。昔明三乘俱有。今忽言二乘无者。昔虽言佛乘是有。今亦可无脱。有此疑非正意也

问。二乘人亦索佛乘不

答。亦有此义例如菩萨昔明有二。今还无二者佛乘亦尔也。此皆是傍义非索车之大宗

问。子出门自见无车。得罗汉出三界亦应自见无三

答。旧说正尔今请问之。若自见无三亦应自见有一。何所索耶。今明若审知无三亦不索。若昔有三亦不索。但昔许有今遂言无。今昔有无合说。是故有索耳

第九次明四句。旧云有四句一索而机不发。即是鹿园已后无学人及六住菩萨也。二发而不索。法华座席七种学人五住大士及凡夫是也。三亦发亦索。谓今教时无学人是也。四不发不索。即法华前七种学人五住菩萨及凡夫是也

评曰。破此义如前。今开四句。一者机发而不索。谓菩萨闻一乘领悟。是故机发无自保之执。是故不索。二者索而不发。如二乘人闻法华经不领悟者是也。如求二乘昔有自保之执。是故今索而无大机所以不悟

问。既无大机何由闻耶

答。但有闻机无有悟机故云无也

问。何以知有此句

答。化城品云声闻众中或有信解或不信解即其事也。三亦发亦索。如三根之流。四不发不索。即法华之前及化城品云。我灭度后复有弟子。不闻是经不知不觉菩萨所行。自于所得功德生灭度想也。复有四句。一者权而非实。谓二乘也。二者实而非权。今日一乘也。三亦权亦实。昔日三中之大是也。非无佛乘道故实。但昔说之未尽故权。四非权非实。即是诸法寂灭相。不可以言宣泯上三句也。复有四句。一合大而离小。合大者佛菩萨同名佛乘也。离小者声闻缘觉乘也。二离大而合小。大品中明三智义。佛为一切种智。菩萨为道种智。故佛菩萨开二智也。合小者二乘人总名一切智也。三大小俱合者。直名大小二乘亦是摩诃衍藏及三藏也。四俱开者如三乘共十地。八地即是二乘因果。九地与十地为大乘因果也。生死河中七人亦是俱开之义也

第十广会今教

问。何故车三使二

答。旧云车为三乘人设譬故三。但二乘领解故使二

评曰。若为三乘人设三车譬者。二乘人闻二事领解。有二使之譬者菩萨何故无领解。不作大使之譬。又譬喻品乃为中根声闻耳。菩萨何得在中根数耶。今所明者通别二义释之。一者通而为论皆平等也。三乘所乘既有三车。化于三人亦有三使。三人止息便有三城。大经云声闻之人以小涅槃而般涅槃。乃至云菩萨之人以大涅槃而般涅槃。故知亦有三城也。别而为论车有三者。前以一乘化诸子不得。故于一佛乘分别说三。方便信解化城并明于一佛乘分别说三。故知说三之义皆为二乘人也。既为二乘人于一说三。二乘人便领解。知三中之一是实。余二非真。故但明二使无有三使也

问。初成道时实有三乘根性。故云长者诸子若十二十或至三十。若尔三乘教为三根人。何得于一说三为二乘人耶

答。前已通竟。今亦二条释两品意。长者宅中有三十子者。此约二乘人始终具三乘根性耳。但成道时唯有二乘根性而无大机。是以一乘化之不得。故于一说三为二乘人也

问。何以知二乘人始终具三乘根性耶

答。文云若十二十或至三十。若以定有三乘根性何事称或耶。以初有二性后方有一机故称或至也。此望方便品意也。二者初一乘化不得后以三乘化得者。此约总别为论。明长者本有三十子。佛初出世时已有三乘根性。若但以一乘化三乘根性者。有三种机唯有一教无从化理。是故息一乘之化于一佛乘分别说三化得三人

问。何以知然

答。譬喻品云。若我但以神力及智慧力为诸众生赞如来知见力无所畏者。众生不能以是得度。文既有但以之言。故知一乘化三人不得。故于一说三。化得三人故有三子求三车也

问。初成道时有三根性。一乘化二乘机不得化。菩萨应得。何故言我宁不说法疾入于涅槃

答。此据前义耳。始终乃有三机。当时无有大机。以大化不得故欲入灭。又但用一化三进。无得益之功。退有起谤之罪。故欲入灭此据后义也

问。何以知然

答。以一乘化不得。即趣鹿园为声闻说法。故知初无大机唯有小机

问。昔于何处说三乘耶

答。鹿园之时但说声闻乘。故云昔于波罗奈转四谛法轮也。但佛教主即有佛授弥勒记。亦是说佛乘也

问。缘觉乘说何时耶

答。大通智胜佛说四谛时即说十二因缘。释迦亦例此也。又大经云于王城为迦叶具足演说十二因缘也。无量义经云先为声闻说四谛。中为缘觉说十二因缘。后为菩萨说六度。以此文推之前说四谛后说因缘也

问。门外何故无车。由旬外有化城耶

答。义例可有三句。一者约昔教城车俱有。昔说有三车亦说有一城。二者据今教城车俱无。三者无车有城。欲明实故无三车。亦权有故有化城也。俱有示两权俱无据两实。一有一无即一权一实也

问。何以知然

答。众生惮佛道长远为止息。故权说化城。故知序昔即明权义。约今说十方佛土无有三乘。时会问无故就佛索。故知车无据今实也。又化城譬属三乘化得。故是序昔权。索车譬属大乘化得故是今实也

问。何故唐捐三车而化一城耶

答。车在宅外诸子在内。举眼不见故唐捐门外不假化作也。城在迥绝。道中众人疲极不复堪去。是以导师化作大城。众人遥见便劝励之。已望见城何为不去。故须化作城也

问。诸子为求门外车而出宅。亦得众人本为趣化城而进路以不

答。二譬意别非一例也。三车本意为求三乘作譬。化城本意为求佛道作譬。但中途懈退故权设化城也

问。何故车多城一。车动城静

答。车三约智优劣城一据涅槃无二。城为止息故静。车明游戏快乐故动。皆是互举并不相违

问。二使何故不言化作。亦不唐捐

答。使是佛教。此不可无故不得言化。又教据被缘亦不得唐捐

问。四种权实云何同异

答。三车与一车此并是教所表理。三车为权一车为实也。一使谓一乘教。二使谓二乘教。教通因果也。此文三使皆是门内说之。三车一车皆是门外之事也。二使为权一使为实也。若大宅与草庵者。草庵者小乘理教也。大宅者大乘理教也。此二通因果也。若化城谓小乘果。宝所谓大乘果也

问。唯是一法何故多种说之

答。体虽是一随义说四也。纵任自在欢喜快乐故名为车。所说教门随佛运用。如使能示语。众生如人也。大乘正法无患不障。如舍虚通无碍为一。众德可珍远涉乃得如宝所也。小乘四义可以意求也

次明所索车四重。一因果。二福惠。三空有。四为无为。旧解三车但是果非因。大车二释。光宅云果地究竟尽无生二智为体。远出由旬之外。对昔近故为高。具含万德。对昔狭义为广。庄严云大车是因。总万行为体。虽总万行略明二法为主。一者菩提大愿上求佛道为高。下度众生为广。二者空慧不离。初后得菩提为高。照穷法性为广

评曰。三车为果不远文义。文云今此三车皆在门外。义者三界内未免生老病死之火。三界外则永免之。以斯弘文义可然也。大车互执因果文义俱伤。今当具说。若言大车但是果者。下何得云乘是宝车直至道场耶。故一不可也。又诸子索车父则赐车。诸子得车各乘之。今但是果者乃是悬许。竟未父赐子遂不得。何所乘耶。昔许其三实不得三。今许其一又未得一。若尔三一两车并许而未赐。二不可也。救曰。正说同归三教记三乘作佛。使其标心在果而修行取之故云乘。是大车而前进耳。难曰。昔于一说三。三非究竟故门外无车。今会三归一。一乘是实故子得大车。更非别法。即捐昔三乘同运向佛为大车体。此岂标寿量果。而子竟不得耶。三不可也。又赐大车是当果记者。前许三车亦应是三乘记耳。四不可也。又出二死之外故高者出二死之外应常。若此教明佛犹是无常。此教明佛未出二死。未出二死则不名高。若云在二死之顶故未常者。则在二死之顶犹应未出。如三有顶犹未出有山顶犹未离山。二死顶犹未离二死也。又问二死摄无常为尽不尽。若尽既出二死则出无常岂非常耶。若不尽应有六百非五百也。又反难曰。若出而未常不常。而未出不可常而未出。岂得出而未常。又出二死而非常。未出二死应是常。未出既非常出则应常。五不可也。又若言未出二死者。亦应未应五百由旬。故出则害。义不出远文。进退无取。不可救。六不可也。又问昔二车但出正使外。故下昔佛出习气无知外。何故下耶。故通一未充释三不足。七不可也

次评曰。庄严义是亦不然。若言大车但是因者。下合中何因缘故举果德合耶。文云皆以如来灭度而灭度之。又云悉与诸佛禅定解脱名赐大车耶。又难曰。若乘唯因非果行亦唯因非果。大经云复有一行是如来行。谓大乘大般涅槃。不应言车但是因。又昔三车是三果。今大车何非大果。理数然。无劳惑也。又此经云妙法然唯是果德乃是妙极。若尔则果车为妙极。因车未极。例因乘未极果乘乃极。何故不取极乘为乘。而取不极乘为乘耶。又因有乘果无乘。则因车果无车。则长者自无车以何赐之。若云此经但取进趣乘。不取果德乘者亦不然。要先应明果德妙乘。用此应物然后令乘因行以求果乘耳。则知果乘为上宗。云何不取耶

问。若众释皆非。谓示今意

答。以文义推之具有四句。一但果车非因车。如三车皆在门外。二但因车非果车。如大品是乘德从三界出到萨婆若。论释云到。萨婆若边则反不复名乘。例如在菩萨心中名波若。在佛心中反名萨婆若也。三亦因亦果车。具如此经二文。诸子所乘即是因车。如来所乘即是果车。因果更无有二。在菩萨心名因。在佛心名之为果。因则总万行庄严为大车。果则万德修饰为大车

问。诸子出宅具赐因果二车不

答。交赐其界外因车。为授佛记悬赐果车也

问。诸子得果车不

答。摄大乘论云。菩萨必得佛故亦名为佛乘。此是因中说果也

问。此经有文以不

答。处处皆有文。信解品云如彼穷子得无量宝。又云无上宝聚不求自得也。总束可有四句。一者因人乘因车。如云汝等所行是菩萨道。二者因人乘果车。如菩萨必得佛故名佛乘。佛乘即因中说果也。三果人乘果车。如万德所成人为能乘。万德为所乘。四果人乘因车。如文殊云昔为能仁师今为弟子化也

问。云何名赐因车

答。文中有说二乘所行是菩萨道。即指小行以为大车令信解故云乘。故身子自述云。昔来蒙佛教不失于大乘

问。大车具因果二车。三乘亦有因果二车不

答。就譬但果无因。就义亦有如诸子闻父许车之言。此则是教。竞共驰走谓如教修行。如教修行即因车也

问。大乘因车位长。何故但取界外

答。今正为二乘人作譬。无学人出界外。令其从界外更复进趣。故是界外车也

问。文中复有界内车不

答。就譬亦复得作之。下明大车复有宾从。无学所行既是界外车。从七凡已上七种学人皆是宾从。既说汝等所行是菩萨道。亦是界内大乘因车也。约义论之故通有也。第四句非因非果车。即是诸法寂灭相。不可以言宣以因果言说

问。何故明非因果耶

答。如来说因果皆为开非因非果正法。故收上三句唯是因果二句。然因果是因缘义故。因名果因果称因果。虽有二句是因果一句。因果则不果果因则非因。非因非果名为无句。亦由非因果故有因果。以无句为一句。次开一句为二句。二句为三句。三句或四句。如此开合皆是如来无名相中强名相说。不相应定生执着也

问。文云有车有宾从云云何是耶

答。前已略说。今更广明。总云大车者具通因果收摄始终。但有一乘无宾从也。今开车与宾从者。约大乘五位论之。一者果地万德为车。即果人登果车因人皆宾从也。二者三界内外判者。七地得无生忍出三界为登车。六地皆宾从也。释论解能动能出云无生忍为出。出者出三界也。三者约真似判。登地真解为登车。三十心似解为宾从。四者三十心具解行。行地为登车。十信等始入为宾从。五者十信及三十心皆登车。举手低头之善为宾从也。依小乘明者。无学人出三界为登车。七种学人及凡夫皆宾从。余例可知也

问。大品经何故但明大乘不辨宾从

答。约此可有四句。一者法华明因乘短。大品因乘长。何者法华赐门外诸子。大车不通门内。故门内宾从门外诸子。大车不通门内。故门内从门外为登车。以乘短故有宾从也。大品明是乘从三界出至萨婆若。摄内外皆为大乘。大乘则长。无复宾从。若以果德为车。因中宾从。则二经俱有也。二者约因果为论。法华乘长。大品则短。法华明诸子及佛皆乘大车。大车通因果故长。大品云是乘至萨婆若。则变不名为乘。乘义则短也。三者俱长。大品明萨婆若摄一切善法。又云从念处至十力等皆为大乘。此则通因果始终故长。法华亦尔。低头之善及果地众德皆为一乘也。四者俱短。大品有所得善不动不出不名为乘。无所得善方名为乘。法华云是乘清净微妙第一。于诸世间为无有上。取无得众行为乘。约此义二俱有宾从也

次辨功德智慧

旧云三车俱取智慧为体不舍功德。功德与凡夫共有。大车亦然。但取如来尽无生二智为体

评曰。不然下合大小二车具取福慧。小车文云。乘是三乘以无漏根力觉道禅定解脱三昧等而自娱乐。岂可但取智慧耶。合大车云悉与诸佛禅定解脱名为等赐。岂但是智慧耶

问。小车具取福慧者。亦得具取漏无漏耶

答。但取无漏智慧。故文云自在不系无所依求。又称门外者是无漏也。大车既通始终义可知也

次辨空有。旧云空有二解但取有解。空解无动是故不取。又尽无生智也。但是有智也

评曰。不然。于小乘断结为宗正是空解。应以空解为正。故下文云但念空无相无作之法。此是果德空解也。我等长夜修习空法得尽三界苦恼之患。故二乘之人正证空法应以空慧为车。云何乃取有智耶。今所明空有二智皆是小车体也。大车亦以实慧方便慧为车之体

次辨为无为。旧解三车正譬有为所以然者。车取运动故是车。无为无动故非车。大车亦尔

评曰。着譬大过不寻经也。寻大小二车具有二文。合小车云。欲速出三界自求涅槃。如彼诸子为求羊车出于火宅。合鹿车亦举有为无为合之。则知三车具是有为无为

问。具有为无为二文以何为正

答。若取三车优劣义分别以智为正。三乘智有优劣。同入无余无优劣。二乘断正使尽亦无优劣。故知正取有为为正以分三车也。若取根本所求者。二乘人本为求涅槃则无为为正也。所以然者二乘畏老病死本求涅槃。故以涅槃正譬车也。设使断结亦为涅槃。下穷子云。先取涅槃之价寻与除粪。又三学次第亦为求灭修戒。修戒为求定。得定为发慧慧断结证于涅槃。故知涅槃为正。又方便品说云钝根乐小法贪着于生死。为是说涅槃也

问。文中何故合羊车而取涅槃。合余二车举智慧耶

答。一者互举也。二者若并云求涅槃者。则三车无异。今欲辨三车异义故后二举智也

问。若尔可言声闻正求涅槃余二乘不尔耶

答。义实尔也。若三乘人皆为求涅槃为正者。但宜取涅槃行声闻行便足。但缘觉人鄙声闻从师而智便钝。故求自然慧欲得利根。菩萨复鄙缘觉智钝不能化物。故求佛智也

问。大车云何具为无为耶

答。下云皆以如来灭度而灭度之。是无为文。又云是诸众生脱三界者悉与诸佛禅定智慧等。是有为也。又此文若指法身众德者。皆是无为。皆以如来灭度而灭度之谓果果也。悉与诸佛禅定等谓果德也

问。何故大车并以无为众德为正耶

答。二乘之人本谓身智无常。三德不备。今大车还复无常者。云何得引二乘耶。以常住万德令二乘人欣求之耳。若尔因中大车则是有为万行。果德大车则常住万德。常住万德一体但约义异。故众德庄严也

问。车但取运动义有为有动无为无动。云何是车

答。肇师云。逾寂逾动何失动耶。若由来所辨常定之义不复能动耳。又车但取欢娱快乐自在无寻。不皆取动义为喻。又小车义具为无为二文。有为众德无动而动。无为众德动而无动。是有二文幸应双用。大乘中因乘不动而动。果乘动而不动。又应身众德不动而动。故驾之而游五道。法身众德动而不动也

法华玄论卷第六法华玄论卷第七

        胡吉藏撰

    信解品譬喻义

光宅师为九譬。一者父子相失。二者父子相见。三者唤子不得。四者唤子得。五者教作人。六者付财。七者知子志大。八者委家业。九者得家业欢喜

评曰。此譬难明。备含众意不可就文说之。今当广序其相有十四条。此喻可领上品自明也

第一定譬多少。若就义意始终论之便有十恩即成十数。如前释也。二者就文及教意凡有八譬。一者父子相失。二者父子相见。三唤子不得。四冷水洒面。五唤子得。六付财密化。七陶练小心。八委家业也。然此八譬总摄一化始终略尽也。父子相失譬者。昔曾禀大教而背化流浪五趣子失父也。从背化已后求其大乘善机不得父失子也。父子相见譬者从背化已后大机应发。当悟一乘子见父也。见子机发堪受大化父见子也。唤子不得譬者初成道时大机未动不堪受一乘化也。冷水洒面譬者初成道时但堪受人天教。为瞽龙及提谓等说三归五戒也。唤子得譬者趣鹿苑为说出世二乘教也。付财密化譬者。大机远动命说波若辨菩萨行。密排其小执潜开其大心也。陶练小心譬者。文云复经少时。即是从波若已后诸方等经广说菩萨行门。具现大士神变。令稍鄙小情欣慕大道。如净名等经迦叶自叹也。第八委家业譬者。心渐通泰小心遂移。为说一乘入佛知见也。故始终委具此八。但冷水洒面。唤子不得譬中通明之也。陶练小心经文既少。属家业摄故但六譬也。今以文义详之进宜应八辟。退有六譬。不应开为九也

问。何故无教作人譬耶

答。教作人犹是唤子得耳。即是鹿苑时事更无别教。故不应开为二也

问。若教作人譬属小乘化得故合为一者。付财譬属大乘化亦应不别开为一也

答。付财譬进未及一乘退复非三藏。既是别教复是别时。宜开为一也。唤子得与教作人无有二教。亦无二时不应开为两也

问。知子大志譬。得家业欢喜譬。何故不取耶

答。此并属一乘化得中之枝流故不应开也。又责曰若知子大志及得家业遂开为二譬者。唤子得中亦有知其小志。何不开耶。故应观其义类。不可随取片文也

第二明领前不领前

问。经师皆言后譬一一领前如前次第。是事云何

评曰。是事不然。若依前次第但有前次第失后次第。若都不依前不名领解。以文义而详具二意也。一者就今譬自有次第者。子自序始终但有三时。一幼稚时。二失父时。三还归乡时。此三摄譬尽矣。初学大乘谓幼稚时。背化起惑名失父时。变迷从悟为归乡时也。就第三归乡时中复有三时。一者去家远时如向国。二者去家近时如至城。三者至父舍时。初喻悟理犹奢。次悟稍近。三与理交接也。于第三时中复三时。一初见父不识时。二不受父教时。三堪渐诱引时。第一喻后得悟理如见父。初无大机如不识父。次喻以无大机不受大化。三喻既有小机堪受小化。第三时中复有三时。一受雇除粪时。二领受财物时。三知是父子时。初喻禀二乘教时。次喻闻大乘教时。三喻闻法华时。摄大乘论云乘有三种。一者二乘二者大乘三者一乘。与此三符会也。若别开此三时则成十譬。一幼稚譬。二失父譬。三游行还归乡譬。四至城譬。五至舍譬。六不识父譬。七不受父。教譬。八佣作譬。九领受财物譬。十知是父子譬。次就父序譬意凡有九种。一生子幼稚譬。二失子譬。三觅子不得譬。四不废家业譬。五见子便识譬。六唤子不得譬。七雇子除粪譬。八者付财譬。九会天性譬。此九即是次第宿世始为说大乘为生子幼稚也。背化起惑名父失子遍求。大乘善根未成谓觅子不得子。虽善根未成而诸菩萨道缘已熟。不可背化名不废家业。见其大机当发识其曾受大化名见子便识。初未堪实化名唤子不得。但堪权诱如雇除粪。大机远动故命说大法如付财。道缘已成须会天性也

问。初明八譬次明六譬次明十譬后明九譬。以何因缘有四种释耶

答。皆有义也。初就一化始终具有八譬。次就正譬但有其六。后据子自序始终故有十譬。次就文意但有九。前二父子合论。后二父子各辨。以经意多含非片言可尽。如释论摄大乘论等。释一经文多有复次。又身子闻说一偈知其千义。目连止了五百。故一句之中具含多义也。若领上者父子相失领上总譬。总譬虽有六义而不出能化所化。故明父子相失即领总譬也。又见火譬中明父子相失。如云汝诸子等先因游戏来入此宅。即是子失父义。子既失父即是父失子也。若尔父子相失。可兼领二譬意也。父子相见譬头上见火譬。但上明见火正是法身地见。故云是时长者在门外立。方便品亦然。故云我以佛眼观见六道众生。谓法身地见也。今云父子相见者可就本迹二处明之。一者未垂迹时在法身地。众生大机动扣于法身名子见父。佛于法身地见大机动名父见子。若尔从其父先来求子不得此中即含子见父父见子义也。二者就迹中而言。初成道时见其大机当发名父见子。中止一城踞师子座尔时始明父子相见。若尔父子相失及父子相见二譬相带领上见火譬也。唤子不得领上救子不得。唤子得领上救子得。委家业领上等赐大车也。冷水洒面领初成道时说人天教。付财领佛说波若教。此二譬来者。在昔闻犹未悟。因今悟昔不领上六譬也。不领不虚譬者。既领一化大宗方悟。佛屈曲恩深崎岖德重乃患惭之不足。岂敢疑佛虚哉。又如此而悟即是总领不虚旨也

第三明三化。三化者初一往化。二随遂化。三毕竟化。此三化摄八譬也。一往化者过去为说大乘也。二随遂化者从背化已后流浪五趣。菩萨随入生死而教化之。三毕竟化者从父子相见如悟一乘受记作佛得不退转谓毕竟化也。又初说人天乘为一往化为说二乘。乃至法华之前四十余年随遂不舍谓随遂化也。三说法华得记作佛谓毕竟化也。又初说二乘权诱为一往化。众生遂保执而住不更进求。如来终不舍之。或令自说大法。或闻他说大谓随遂化。至法华时方得了悟为毕竟化。又初说大乘波若教名一往化。从波若已后历闻诸方等经为随遂化。终悟一乘成大果实如秋收冬藏为毕竟化。又今唯为说法华为一往化。从此已后乃至十地常教化之为随遂化。至金刚心等觉地时。化令得妙觉地圆满谓毕竟化也。又结僧那于始心名一往化。于其中间种种化之为随遂化。得佛方息为毕竟化也

问。何故须立三化

答。初明父子相失。后忽然相见似无因缘。是故须立三化也

第四明三世。八譬中初父子相失是过去世事也。从见大机当发一生。应悟法华记作佛。始于顿止一城竟第八譬。皆是现在时事也

第五明本迹。一往八譬皆是迹中事耳。如来久已成佛昔示同沙弥为说大乘。乃至今日中止一城亦是方便成佛。是以八譬皆为迹也。但父子相见都有二本二迹。一者法身见诸菩萨大机已成。故示为舍那以化之。中止一城家业不废即其事也。二者舍那成道时见诸子唯有小机无有大机。故垂为释迦以化之。脱珍御服着弊垢衣即其事也

问。若尔法身地具照二机。双垂两迹

答。亦得如此。但今欲明二佛传论本迹化大小二缘。故作此判也

第六明因果。就本而言皆是果化。就迹辨者过去结缘。示沙弥之迹。但因而非果也。从中止一城谓果迹。此二中间或因或果也

第七明化得不得。若以悟一乘受记为得者。七譬皆是唤子不得。唯第八为得也。若就大乘化为得不得者。过去为沙弥时为说大乘即是化得。从背化已后为不得。至法华悟一乘为得。如譬喻品云。我昔教汝志愿佛道此是大乘化得也。而汝今悉忘此为不得。我今令汝忆念本愿。为诸声闻说法华经为化得也

第八明二教。从顿止一城即序长者豪贵自在眷属宗侍等。此领华严初成佛时舍那教闻化诸菩萨也。脱珍御服着弊垢衣即是舍那之本。垂释迦之迹。遍化二乘。竟第八譬皆是领释迦教也

第九明世出世。冷水洒面说人天教为世间法从化子得皆出世教也

十第明大小。唤子得譬鹿苑之教为小乘化。从付财竟委家业皆大乘化也。此中无有三乘通教义。何以知之。教作人时但说二乘法名三藏教。从般若已去即付大乘法财。不复教二乘人作。故唯是大乘教也。若言波若是三乘通教者。付财之时应有通教三乘人作

第十一明自他。般若教明自教般若已后明化教。自教者令声闻人口自说大因大果。即以此法教之。可谓以彼口自言以教其心也。从波若已后历闻诸方等经闻他说大。令其得悟故云他教也

第十二明显密。从波若至法华之前谓显教菩萨密教二乘。如付财之说密示大法以为已任。法华教名显教二乘也

第十三明迷悟。自父子相失竟陶练小心。二乘皆不知是佛子为迷也。至法华时始得悟也。故下文云。我今得道得果于无漏法得清净眼。尔前皆无眼也。第十四广上说。上有二章第一五譬广上昔迷。第二最后譬广上今悟

问。以何义故有此十四义耶

答。此譬领释迦一期始终教意尽。故作此十四条也

  药草喻品　五乘义　一音义

五乘义者。前序经一雨一云大意者。教虽万差终表一道。所表之道无二。能表之教亦一。但随五种根情故有五乘教异。既随物说五则五乘皆权。五乘既权则以不五为实。以对破五病故以不五为实也。然五既不实则不五亦权。故凡涉名言皆非究竟。但为渐诱众生故开五不五。至道寂寥何五不五耶

问。若五乘皆是权者。前何故言二乘是权佛乘是实。故云唯此一事实余二则非真

答。义门各异。前就三乘判有无以明权实。正欲斥二乘病故明佛乘实有二乘伪无。所以然者。二乘人谓二乘及佛乘俱是实有。故作此斥之以二乘是无故索。菩萨乘是有故不索。今明无五者就正道望之。是法不可示何曾有五与不五。言五不五者并随物说之。皆是权也

问。道实非五不五。五不五皆是权者何因缘故不索五耶

答。若识道非五不五而说五不五。皆是权者。此人不索不识如此权实者。亦有索五义也

次论名义

问。不应有五乘但应为二。人天为世间乘余三为出世间乘。又应为二乘。佛为实乘余四是权乘。佛为第一义乘余四乘皆世俗乘。如胜鬘说。又佛为果乘余四为因乘也。又应为三乘。人天乘为下乘。二乘为中乘。佛乘为上乘。又人天乘是出三途乘。二乘是出三界乘。佛乘出五百由旬乘。又人天名为不断烦恼乘。二乘名断烦恼乘。佛乘非断非不断乘。不同凡夫故非不断。不同二乘故非断。如净名云。不断烦恼亦不与俱烦恼。本不有故无可与之俱。今不无故无所断也。此法华前大乘教及法华亦有此义三藏中无此说也。又凡夫名不断乘。佛名为断乘。二乘亦断亦不断。望凡夫故断少分比佛故未断也。通今昔也。又人天名凡夫乘。二乘名圣乘。佛名非凡非圣乘。又凡夫为有乘二乘为空乘佛乘为中道乘。大乘教意也。又凡夫为着生死乘。二乘为着涅槃乘。佛名无所著乘。亦大乘教意也。又应为四乘。如胜鬘四种重檐四百亿类洲四大宝藏。故皆大乘教意以大乘教别有大地。能持四藏也。今何因缘故不二不三不四。而立五乘耶

答。实具上来诸义即以此义摄五乘也。而今明五者此是如来渐舍法门故立五也。今采华严性起品意以序五乘大意。如经云。三恶道苦谓恶道民苦。阎罗王苦则恶道王苦。是以三途中皆是苦聚。欲舍此苦当修五戒。五戒因缘则得人身故说五戒为人乘也。但人中钝根短寿乐少苦多。欲离斯事当修十善。十善因缘则招天报名为天乘。次云三界皆苦无常破坏。如烧铁丸无可乐处。为脱此苦说声闻乘。但声闻之人从他闻法。居弟子位。外无相好内智不深。独静山间无师自悟福德利根名辟支佛。为说缘觉令舍声闻乘。缘觉之人虽无师自悟而智犹未圆。经结习不断独善自身慈悲心薄。唯有佛乘最为无上。众德斯备结习永亡。自利已满广能度他。故说佛乘令舍缘觉。然昔欲示渐舍法门故说五乘。禀教之徒不解佛意。遂保三乘皆是究竟也

问。为五人说五为一人说五

答。具二义也。如恒河中七人具七。一人具七

问。今昔说五云何异

答。昔说五乘二乘明未极。三已究竟。今说五者如华严说渐舍法门

问。上云华严叙昔意云何言今说五耶

答。今教叙昔教所表意也

次论开合同异

问。论明五善胜鬘辨四藏。法华三草二木。云何同异

答。五善者人天为二善。二乘为一善。佛菩萨为二善。以人天五戒十善优劣不同故开为二。二乘利钝根为异。而智断义齐故合为一。佛与菩萨万行万德因果升降。宜开为两。五善则开大合小。五乘则开小合大。四藏则合凡开圣。五乘则凡圣俱开也。此皆随缘不同不须曲会也。三草二木者有人言。人天为小草二乘为中草。外凡为大草内凡为小树。初地至十地为大树。有人言内凡为大草。初地至七地皆为小树。八地为大树

评曰。位义难明。今以合譬为正。合二草譬如前判也。合大草云求世尊处我当作佛。行精进定是名大草。既称佛道必应从外凡十信位至内凡三十心。此四十心皆是大草。所以然者。未得无生植根犹浅。宜与草名。又既以二乘为中草。则地前四十心皆属菩萨。故云名大草也。初地至六地名为小树。七地已上名为大树

问。何以知然

答。释论判无生有两位。一初地二七地。晚见法华论亦云初地无生七地无生。无生既两树亦例然

问。此经云何证七地为大树耶

答。释论云位居七地得无生忍具六神通。此经云得神通力转不退轮。故相会也

问。何以知初地如小树

答。论既云初地得无上。此经云又诸佛子决定无疑。无疑即是断道。以地前烦恼未断不得称为无疑。又初果人拟菩萨初地。初果既断疑。今初地亦尔。又地论云。初地名决定位。此四处文皆相扶也。次论三草二木位次第义。人天为世间故譬之小草。二乘为出世故譬之中草。此从世至出世也。十信已上回向已还。此四十心即是大乘名为大草。此从小入大也。登地已上六地已还名为小树。此从凡夫至圣也。七地已上十地已还名为大树。此即从浅至深。斯则总摄凡圣收罗大小。故有三草二木之譬也

一音义

问。经明一云一雨随根受润。与一音说法随类异解此有何异

答。有同有异。异者云雨来意。如说经因缘中辨之。今略举二意。一者取无心而能普益。二者欲显同一正道随根成异也。一音者欲明如来三密不可思议。凡夫二乘不能测度。所以然者。下位之人但以一音令缘同闻一。不能以一音令万类异闻。唯佛能尔故名口密不可思议也

问。上来所明一音与一雨义异。云何复是同耶

答。一云一雨同明一教。但得随根成异。一音亦为显一道。随类万差。此无异也

问。云何名为一音耶

答。有人言。唯一法身。法身不二故名为一。从一法身出音。以法身为名故云一音也

评曰。大品释相好。云以一音报众声。不明法身故非解也。有人言一时中并出众音。故云一音也

评曰。经但云一音不云众音并出。亦非所用。有人言身为天竺之身。音为天竺之音。故云一音

评曰。佛能随咄一音非局天竺。又有人言五音之中随用一音

评曰。佛既托一方之迹受一土之音。五音义通亦非所用也。今所明者此义多含略明四种。一者依药草品明一大云普覆。一大雨遍洽。喻一乘大法音。故名一音。但大缘悟大故称于大。小缘悟小小不称为大。故一音之名主一大乘音也

问。云何小不称大

答。如说大般涅槃。而道成罗汉。维摩经广辨净佛国土。而取证小乘。如是等皆是小缘。闻大而不称大。故一音之名正主于大也

问。此经何故一音遍主大耶

答。欲显唯有一乘无有五乘。故一音主大乘也

问。何以知一音遍主大耶

答。经云一大云一大雨。故知主一大乘音也。二者如净名所辨。明如来一音说法而万类异解

问。此据何一音耶

答。既云佛以一音说法即是佛音。佛音者一梵音

问。何故主一梵音

答。就一方化迹托形天竺报得梵音。是以一音主梵音也

问。此言何所出耶

答。毗婆娑中作此说也。佛于鹿园以一梵音演说四谛。五人则闻人语说四谛。八万天则闻天语说四谛。地夜叉闻夜叉语说四谛。故唱告之。如是展转闻至于梵世。故知一音主梵音也

问。为是梵天音故名梵音。如报得天眼故名天眼耶

答。不尔。此是八种音中清净最妙音名为梵音。非梵天音也。故释论云佛生人中受人法故是人音。又若是梵天音者人则不闻。故知非也

问。释论云小乘法中无不可思议。如六十劫说法华经谓如食顷。云何三藏中明以一音说法随类解耶

答。小乘虽无六十劫说法华经。不可思议有余五不可思议。谓佛力龙力等。今一音说法即是明佛不可思议也。次言一音者不必但局梵音。如来随吐一音能令异类各闻。故名一音也。又一音者人闻即人音天闻则天音。非人非天也。以是天人音故名为多。以非人非天故名一音。乃至声闻闻小菩萨闻大。而音非大非小故名为一也

问。人闻则人音天闻则天音。而音非人非天者。亦应一缘闻则音一多缘闻则音多。而音非一非多也

答曰。然也

问。若尔音缘闻则音。非音缘闻则非音

答曰。亦然也。是故经云。同在一座有人闻佛说法。有人见佛默然。如肇师云。心生于有心像出于有像。即其事也

问。若尔前何故言一音耶

答。正为下位之人不能以一音令万类异解。叹佛能尔。故明一音也

问。云何但说一音令万类异闻

答。华严前后略明三事。一者明佛能出众生数等音。余人不能尔。唯佛独能故佛不思议。二者佛能于一音中并出众生数等音。故一切众生各有所闻。此明余人不能于一音中出一切音佛能尔也。三者一音说法。能令一切各有所闻。亦不分一音以为多音。余不能尔唯佛独能若尔者具三种义。不可局之。以一此三。皆是显佛口密不思议事。口密既三身亦如是

问。华严性起品云。大梵天王以少方便大千众生皆见己身亦不分身。若尔余人亦能何故唯佛耶

答。彼唯局大千如来普周法界。彼则有心所作。如来无心化物。又菩萨眼入三昧。耳出正受。观眼无生说空非有。彼不能尔。何由及佛

问。此四种辨一音。今昔明之以何为正

答。通皆具也。但有唯一乘音。正在今教。余三通今昔也

问。佛有二种光一常光。初生至灭常自有之。即丈光相。二非常光。随时示现。一音说法令万类异解。为是常音为是示现

答。八十种好中云以一音报众声。若尔此是佛常音也

问。一音说法有几事耶

答。依净名经略明三种。一者佛随吐一音万类异解。六道众生皆谓佛各同其语也。二者但说一法随义普行。好施者闻施好戒者闻戒各蒙利益。三者明说事是同而欣忧兼发。此有二事如说一苦法生四种心。有人闻苦生怖畏有人闻苦欲脱之。故生欢喜。有人闻苦心生厌离有人闻苦实知是苦断于疑心也。二者闻四种法生四种心。如闻三涂苦则怖。闻人天妙乐则喜。闻不净则厌离。闻因果则断疑。两义中前意正也

授记品　明授记义　论曰十种因缘为二乘授记。如前说

问。若此经明授记者何故净名广破授记。又思益经云。愿我生生不闻授记名字。大品云。若住阿鞞跋致及授记皆是戏论。今何因缘故明授记耶

答。不相违也。菩萨之人言有记可授有人能受。则是人法之见。为破此病故言无记。二乘之人谓不得记但菩萨得记。为二乘人故明授记。此是各各为人门也。又有二谛。为世谛故明有记。为第一义门故说无记。二言皆实也。又经明无记者此辨记无所记。今明记者此是无所记故名为记。般若明无所得即是得。以是得无所得也。但授记有二种三种四种六种九种十种

二种者有八种二。初明通别二。所言通记者。如法师品说。若佛在世及灭度后闻法华经一偈一句。一念随喜皆与授记。所以然者。唯有一乘无有余乘。故无异路必得作佛。二者别记谓。于佛前别授劫数之记。如三周说法三根人得授记也。第二二种者。一正因门授记。二缘因门授记。正因门授记者如常不轻菩萨说。四众皆当作佛。然此四众未有信一乘心。但身中有佛性必当作佛。法华论释常不轻品。一切众生实有佛性故当作佛也。明缘因授记者。如法师品。以信法华即是缘因。所以但明此二。佛性者然果。得生唯有二种。一正因二缘因。如乳有酪性要具二因。乳为正因。燸等法为缘因。众生有佛性亦具二因。一者众生是正因。二者假信解等法以为缘因。是以法华但明二因也。摄大乘论詺缘因为引出因。即是了因也。缘正二因授记广狭者正因则广。善恶等一切众生皆有佛性故正因义广也。缘因但取有信解心方乃得佛记故狭也。三者迟速二种。大经云。若有众生宜闻速记则授之以速。宜闻迟记则授之以迟

问。此迟速为是实记为是权记

答。具二义也。一者实记。以佛见其积行已久成佛不奢故以速记。照其积行未久成佛犹奢故与迟记。二者权记。见此众生闻佛道长远久受勤苦生退没心为授速记。闻速记故精进勇猛修行趣佛。如人知去家不远力步而进也。二者有人闻速记则谓佛道易得。便起轻心生于懈怠。为此人故与其迟记令贵佛道使勤精进

问。实记可有实益虚记应无实益

答。如来实记亦有实益虚记亦有实益。以皆益故皆是实也。四者约授记人凡有二种。一佛授记二菩萨授记。如常不轻菩萨授四众记

问。常不轻既是菩萨云何乃授佛记

答。菩萨不得授劫数成佛之记得授通记。以一切众生皆有佛性。又无有余乘唯一佛乘。然道理推之得授佛记。乃至凡夫知有佛性一乘者亦得授他记也

问。何故授劫数起唯是佛耶

答。成佛事大。非是佛果无以授之又成佛必须佛授所以然者。成佛必须见佛性明了法身显现。十地已还见佛性未明法身未现。故不得授见性明了法身显现记也

问。如十地菩萨知他未来一劫乃至十劫成佛。何故不得授其记汝过十劫当成佛耶

答。虽知成佛久近亦不得授之。但成佛事大。必前佛后佛相传须佛授也。五者二世授记。自有佛在世为其授记。自有悬授佛灭度后人记。如化城品云我灭度后复有弟子。生在余国闻法华经得成佛道也。六者今昔二种。昔但授菩萨作佛记。未授声闻记。今亦授菩萨亦记二乘。七者善恶二种授记等。不记调达恶人今始记之。八者男女现成佛不现成佛记。昔明女人不得现身成佛。今记现身成佛如龙女等

次明三种授记。释论云。有人自知得记他人不知。有他知得记而自不知。有自他俱知也。真谛三藏翻摄大乘明三种授记。一当得记。从外凡至十回向当得佛。二加行记。初地至七地增众行。三圆满记。八地至佛地。又有三种一时节记。三十四阿僧祇劫。二修行记。谓修十度。三究竟记。至于万德。初又有三。一远因记。外凡至十行去佛远。二近因记。十回向已上去佛近。三至得记。初地已上得法身理也。次修行记亦三。一下道种谓十信。二成就即三十心。三解脱初地已上也。次究竟记有四。一化主二处所三大众四说法也。三藏又出中阿含及萨婆多义。明凡欲至佛要三僧祇行行。初僧祇行行犹退为小乘。曰不定位。次二僧祇行行不退曰定位。三僧祇断见思惑堪受记。今未详此释。与释论及旧出小乘义不相应也次明四种授记。出首楞严经及释论犹未见经本。可更看经文拣之。及释论有四。一未发心授记。二发心授记。三不现前授记。亦名密授记。四现前授记。未发心授记有二种。一者昔是具缚众生都未预五乘善所摄。而佛悬记其未来成三乘果。如释论记鸽鸟事。未来生八万大劫犹受鸽身。后过无数劫乃舍鸽身方得人身。发心行行得辟支佛也

问。记此鸽有何益耶

答。于鸽无益。身子等因此知佛智不可思议令多人发心。身子悔取小道。但为益人不为利鸽。二者依首楞严经意言。其人过去久已发心行行。但在轻毛位随风东西。未可是詺故云未发心。又此人过去已曾发心。但现在未值缘。故云未得发心。此人从外凡至退位已来。又依璎珞经六心中人也。依法华是系宝珠人。以其失大解故今为此人授记。名未发心授记也。二者发心授记。如过去久发心乃至现在发心。故名发心。首楞严意。判此人位不退也。依璎珞经是七心已上人也。第三不现前授记者。唯他人知而自不知。故名不现前也

问。自既不知何用授记

答。其人若自闻授记则生懈怠。今欲断他疑令生欢喜故为他记

问。他有何疑

答。他见其积行既久又崇仰之。而不见得记。今闻得记则他闻发心也。第四现前授记即是无生忍也。南方旧云。第三人位从初地至六地。第四人位七地也。以两义证之。一者首楞严经明第三人行六度。六度即六地。第四人得无生忍。故知是七地也。二者诸经及释论云。儒童菩萨得七地无生忍。值燃灯佛方与授记。未值燃灯佛之前犹未得记。故知第四人是七地。北方论师云。第一人是外凡前人。即十信之前也。第二人是外凡即十信菩萨也。第三人三贤菩萨即恐闻记生谤。故不现前授记。第四位登初地闻不生谤现前授记也

评曰。皆有二义取六地未得无生忍。故未得无生记作佛则如前释也。取登地得无生则如后判。释论云初地无生七地无生故也

问。若用前释者。可言六地犹恐懈怠不现前授记耶

答。不取此义但明六地未得无生忍。故未得无生记。所以不现前授六地菩萨无生记作佛耳。若恐懈怠者依后释也。又摄大乘论六地名有相地。亦得约此义为懈怠也

问。授声闻记亦有四不

答。就法华明亦具四也。常不轻授四众记。谓未发心而授也。以四众未发菩提心故。又化城品云我灭度后复有弟子。不闻是经。于自功德生灭度想入于涅槃。我于余土作佛为说是经故发心作佛。是名未发心授记。即用此文。又是不现前授记也。发心授记者约迹言之。三根声闻并发菩提心信解一乘。故与授记。现前授记者。第四卷云是千二百罗汉我今现前次第与授记也

次明五种声闻得记不得记义。一者退大学小声闻如身子之流。二者发轸学小声闻。三者以佛道声令一切闻。四内秘菩萨行外现为声闻。五增上慢声闻。增上慢声闻中复有二种。一者得四禅时谓得四果。如释论出之。得初禅时谓得初果。乃至得四禅时谓得第四果。二者不必得禅但偏修厌观。三毒不起谓得罗汉也。次明得记不得记者。若退大为小声闻约位判者。是六心以下人。但是未发心授记也。若发轸学小声闻亦是未发心授记也。但此二人优劣不同。初人已曾发心。但发心未成就故名未发心。第二人都未发心也。若第三以佛道声令一切闻。此位既通从初发心至佛皆是声闻也。若取中根人领解自称以佛道声令一切闻者。此正就位不退义判。属发心授记也。内秘菩萨行。此位亦通从位不退已上皆能有此事。而取登地。去此人有是现前得记也。增上慢声闻有三种人。一者亦得闻经亦得授记。如常不轻菩萨为增上慢声闻说法华经及为授记。此是未发心授记也。二者不得闻经不得授记。如释论所出得四禅者。此人命终堕无间狱也。三者得仿佛闻而不得授记。则五千之徒得闻略说而不得记也

问。此三增上慢声闻位行云何优劣

答。值常不轻菩萨者初谤后信。初谤故千劫堕无间狱。后信故得入菩萨位。如经文所列五千人。直明起去不明是谤。取其不谤义则胜不闻法义则劣。初人闻经故胜谤故劣也。又初人闻经不闻经皆谤。次人闻经则谤。不闻则不谤故初人劣。第二人胜。又初人多是实行人。五千多是变化人。第三人临命终时生邪见谤无圣道。此人非但谤小亦谤大。前二人但谤大不谤小。据此义则前二人为胜后人为劣也。又第三人但堕一劫无间。初人千劫受苦。则初人为劣后人为胜。晚见论明四种声闻。一决定声闻。二增上慢声闻。三退菩提心声闻。四应化声闻。决定声闻者即是本学小乘行得证四果故名决定声闻。增上慢者不得四果妄谓言得。此二是小乘中得不得二也。退大为小及应化为小。此二就大乘中明得失故有二也。此四摄一切声闻皆尽。与上五种不相违。但广略为异耳。论明得记不得记者。退菩提心及应化人此二得记。决定声闻及增上慢此二根未熟故不与授记

问。此释与前相违

答。不相违也。论意解三根人得记者。皆是退大及应化人得记耳。此中无实行人得现前记也

问。无实行人得记者。常不轻菩萨与四众授记。是何等人

答。论云方便令其发心故。此是与实行人授记

问。若尔前云何实行人不得记

答。前明不得如此中三根人现前授劫数之记耳。非无通记以同有佛性而得记者。皆得与一切众生授记也。三根人就缘因门授记。常不轻就正因门授记。义各有异也

问。叵有为实行人授劫数记耶

答。有利益者则为授之。义亦得也。论明五种授记。一者身子迦叶名号不同。又为众所知识故与记别。二者富楼那等五百人及千二百人等同一名。故俱时与记。三者学无学等俱同一名非众所识。故一时与记。四者与提婆达多记者。示如来无怨恶心故。五者与比丘尼及龙女记者。明女人在家出家修菩萨行皆证佛果故。论直明法华经始终与五种人授记不同耳。次横论授记者。随一人具得二种授记。如三根声闻发菩提心故是发心授记。面从佛受为现前受记也。增上慢声闻即是未发菩提心得授记。是未发心授记。面从常不轻闻经是现前记。如是例义可解也

次明四种记摄法

问。授记何故不多不少但立四耶

答。据位论之摄授记尽。未发心授记从具缚凡夫至六心退位也。发心授记从七心已上至三十心也。不现前初地至六地也。现前七地至十地也。又未发心外凡前人也。发心始入外凡位也。不现前内凡三十心也。现前登地至十地摄位既周。故但明四种也。又作二种双摄之也。一者发心未发心一双摄授记尽。自有未发心与记。自有已发心与记。未发心与记如鸽鸟。已发心与记从发心已上至十地皆摄也。二者现前不现前一双。自有不现前而与记。已虽无益能利益他。自有现前而与记。或可自益而他不益或自他得益。此摄记亦尽也

次明九种授记。即是授九道记谓三乘及六道也

次明十种授记。如华严离世间品说

次明诸四句。有前发心后得记。后发心前得记。前发心前得记。后发心后得记。又前发心后成佛。后发心前成佛。如释迦弥勒等易解也。次法华中大小四句交络。一者小乘无胜劣大乘有胜劣。如五百人皆罗汉故小无胜劣。五百人转次授记成佛前后大有胜劣也。二者小有胜劣大无胜劣。如二千学无学人是也。二千有学及无学故有胜劣。同时成佛故无胜劣也。三者小劣大胜。如阿难得初果而先成佛者。小胜大劣如罗云得罗汉后成佛。此四释五百弟子及学无学授记品尽也。又四句。一者同是无学得记有前后。如三根罗汉等。二者同是无学同时得记。如五百罗汉。三者学无学不同而同时得记。如二千人。四者有举无学不同。得记前后亦不同。如阿难罗云等。此四句总摄三周也

次简大小

问。大小乘经俱有九部。何故小乘九部无授记大乘九部有授记耶

答。授记正明作佛。作佛是大乘正宗。故大乘九部明之。小乘授记非小乘正宗。故小乘九部不说。所以法华中明九部但为趣涅槃也

问。外国名和伽罗此云授记。何故成论同用此名而云解义经耶

答。成论师会二名云解授记义故名解义。引彼论文从明入明等四句。即是解授记义也。今明不然。以授记非小乘正宗故。小乘论不作授记名说。何以知之。大涅槃解授记经引阿逸多作佛事。故知尔也

问。授记是一义耳。何故十二部中以授记为一经耶

答。授记虽是一义以其作佛事大。又授九道记亦是大事故可为一部也

问。为能记名记所记名记。为能所合明记

答。授记经者正取文言为经。故以能记之言为记也。又本记前人作佛又取所记名记。如目连记。两等三能所合目易知也

次释化城义

问。三车化城既同是权。二品来意有何异耶

答。索车中已明。余未尽者更序其相。但声闻有二种。一发轸学小。二者退大为小。三车为发轸学小人令出三界当得三乘。若化城譬者。为退大为小人本求佛乘。惮佛道长远欲退受人天之乐。故于中路为止息说二涅槃也。然通而为论二文皆含两义。取其正意则如向说也

问。方便品明何义

答。乃具含二义。而正取初意是以三周说法可为二例。初二周说法正为发轸学小声闻。二周领解亦然。第三周说法正为退大学小声闻。领解亦然

问。前应为退大取小人说。何故前为发轸学小人耶

答。学小之人执病既强。故先须斥之故初为也

问。身子皆是退大取小人。故云三万亿佛所修学大乘。则知先为退大取小人也

答。身子是权行人。为引发轸学小实行之人故先对身子也。如摄大乘论云。身子化人既得授记。令未定入二乘正位者改小乘行。已入正位者令其练根学菩萨道也

问。前明五种声闻今何故但明二种

答。虽有五种声闻但法华教起正为二人。以发轸学小令改小而信大。退大为小亦令还学本大。故但为二人也。权行人乃是欲诱引此二种人。故不须为也。以佛道声令一切闻即是前二人得悟。能以佛道声令一切闻。为之已竟。亦不须为也。增上慢者惮教不受。如五千之徒。此未可为也

问。此之二人得悟有深浅不

答。初人但得信佛语耳。第二人随位浅深也

问。化城与三车何异

答。直言三车则通今昔。若言化城但是今教。昔未言化也

问。就譬而言有何异耶

答。作三车者此举说法轮为譬。若是化城以神通轮为譬。何以知之。长者虚指门外说有三车。故知是说法轮譬也。化城则明导师以神通力化作大城。则以通轮为譬也。又三车以声为譬。化城则举色为譬。诸子但耳闻车而眼不见。故举声譬。众人眼见城故举色譬也。但城譬之中非无有声。如导师抚慰乃至集众告言皆是声也。车譬之中非无有色。如长者指门外示彼三车即是色也。但城据眼见车就耳闻。如前正意

问。既举二轮为譬者有二轮事不

答。二譬皆是佛说。但是说法轮。无有现通事。故非神通也

问。三车及化城何异

答。前已释之。未尽者更说约此别为四句。一者实而非权。谓一大车。二者权而非实。即二使及化城也。三者亦权亦实。谓三车也。于一说三故为权也。余二非真唯一为实故名实也。四非权非实者前。虽有三句唯成权实二句。权实是因缘义。故权实则不实。实权则非权。直唱权实。宛然而未曾权实即第四句也。又若约五乘者人天乘非一乘。故非实非三乘。故非权为第四句

问。二使与城何殊

答。前已释之。未尽者更序之。一者使就人为譬。人能指示是非如教能诠理邪正。城以法为譬但明止息耳。二者使人动而城静使动喻说教被缘。城静取安隐无患也。三者使人喻教。一城譬理。四者使人有二即四谛十二缘城则唯一两智不殊。二涅槃无异也

问。二乘二智有异。云何无异。又入无余无异。有余有异。云何无异耶

答。可两望之。取其同得二智。同得二涅槃。故言无异。此可譬一城也。取其二智不同有余差别。则譬二教深浅。如两车粗妙也。五者二使但在因中。入城登车皆据果地。六者二使譬教门通诠因果。城车则但在果门。七者二教诠为无为。而但体是有为。城车通为无为也。八者城则是无。使则是有。实无小乘究竟果故云无。化作无教是佛说而不无佛教故言有也

问。既实无究竟果而权明有者。亦实无小乘教亦权说有小乘教。此义应齐。何故不例

答。非无佛之言教。为会小教归一大教故。云我此九部法随须众生说。入大乘为本故教有也。究竟之果既无不可会归一果。如不可从化城归宝所也

问。若果是无不可会者。智断无。应不可会。何得云汝等所行是菩萨道

答。可细寻其旨也。此智断可两望之。若言智断究竟此则无故不可会。而有此不究竟之智断。宜会归一乘。故云汝等所行是菩萨道也。论释云汝等所行是菩萨道。谓前菩提心退已还发前所修。善根不灭同后得果故。此意明取菩提心善根故是菩萨道耳。二乘智断皆是菩萨道之远缘。人天善根亦尔也

问。何故不言汝等所行是菩萨果

答。二乘正谓是果而非道。今斥其病故云是道非果。道者因义也。汝等所行若因若果皆是菩萨家道耳

问。菩萨有果如信解中云我今得道得果。大品云有法是菩萨道。无法是菩萨果。何故不言汝等所行是菩萨果耶

答。约此义亦得也。但今言道者取菩萨若果若道望佛并为因。皆悉是道故言是菩萨道耳

法华玄论卷第七法华玄论卷第八

        胡吉藏撰

论曰。转法轮具四义。一轮二转三方四降敌。轮者大乘以无生灭观为体。小乘以生灭观为体。大乘无生观为轮。略具十义。一唯圣王有余人则无。唯无所得圣王有此无生灭观。有所得人则无。二自然成就不由工匠。佛菩萨了诸法本自不生今亦无灭。得无生观非破生灭故有无生也。方便品云。诸法从本来常自寂灭相。三辐辋具足。无生观圆则众行皆备。四自在王前导。以无生观常居众行之首。五余人不能坏。天魔外道不能坏。六能摧怨敌。得无生观能破一切生心动念。七停空不堕。得无生观常在实相虚空不复退转。八圆而无际。得无生观离断常诸边。九上下回转。得无生观能于生无生不相妨碍。如法身无生无处不生。以无生故诸趣门闭。即是上回无处不生而生五道。谓下转也。十速疾得无生观心无所碍。一念遍知。所言轮者转轮为义。前佛得如实悟授于后佛。众生不尽轮无息时。故云轮转也。又轮者谓具足义。此无生观无德不含。如波若说一念具万行。又轮者圆正义。无生实观圆正不偏也

问。何故名法轮复名梵轮耶

答。可轨名法清净名梵。十住论云此轮能除众生三毒使得清净。故云梵轮。婆娑云梵音说故名为梵轮

释论文已具足。次论位但一无生中道正观。约明昧不同开为四位。初地至三地名信无生。四地至六地名顺无生。七地至九地谓真无生。十地至佛地谓寂灭无生。即喻四转轮王也。又地前亦具四位。外凡十信信无生。次十住谓解无生。十行因无生起行。十回向明解行具足顺无生流。后四名似轮。前四名真轮。似中内外凡。真中并不并如一乘中释

问。何故地前至佛皆无生观

答。般若云菩萨初发心皆学无所得。以无所得故能从一位至一位耳。有所得是魔眷属无道无果。是故皆学无生

问。云何名无生观

答。于一切生死涅槃缘之与观不生心动念。故名无生。是故经云。动心是魔网。不动为法印也

次释转义。既以无生为轮即以无转为转也。净名云三转法轮于大千其轮本来常清净。像法决疑经云。鹿园不说鹄树无言。善吉云我无所论乃至不说一字。大经云若知如来常不说法是则名为具足多闻。此皆无转而转。故言无所言。但转有二种。一者他转二者自转。此二种开三种成佛。一者法身成佛。谓坐无生观道场将满不二念。若假诸佛为作因缘故。无生观轮于心中转名为他转。二者应身成佛。谓十地行满坐于道场无师自悟名为自转也。此二皆是大乘。三藏所无。次明三僧祇劫行满三十四心成佛。亦无师自悟得眼智明觉此三藏成佛。成佛虽多不出此三。若以本迹而言初一为本。后二为迹。大小为论初二大乘后一三藏。权实而言三藏辨权大乘有权有实。法身为实成迹身为权成也

次就应身成佛复有自他。婆娑云佛在菩提树下转自身法轮。谓自得无漏慧行四谛境。于鹿园为他身转法轮。谓陈如等有应发之慧须佛言教为其扣发名为他转。但自转之义就初成道。此义则短。从尔已后皆属他转。故他转时长。小乘既尔大乘亦同也

次明方义。转必有方所即是转境义。若尔小乘生灭观照四谛境。故轮于四方转。大乘明无生灭观于一实谛方转也

问。云何尔耶

答。小乘以苦集为相生。灭道为还灭。境即生灭观亦复然。故生灭境发生灭观。生灭观照生灭境。所以言生灭之轮四方转也。大乘则明不苦不集故不生。不道不灭故无灭。故名一谛。以无生灭一谛发不生灭一观。无生灭一观照无生灭一境。故云无生灭轮于一谛方转也。然转轮既是无转而转。境生亦无生而生。无转而转虽转不照。无生而生虽生不发也。次明小乘之轮于四方转。大乘亦尔。但小乘于有量四方转。大乘于无量四方转

问。小乘有量故有生灭。大乘无量亦有生灭。量无量乃异。生灭观应同耶

答。亦不同也。大乘明苦者如大经云。解苦无苦为苦谛。又云五阴洞达空无所起。是苦义法本不生。今则无灭是寂灭义。岂同小乘逼恼为苦。已有还无称为灭耶

次明降怨即辨轮用。小乘于四谛方转降四谛下怨。正观之轮于一实谛方转降生灭断常怨也。又小乘轮于有量四谛转降有量四谛下惑。大乘轮于无量四谛方转降无量四谛下惑也

次明权实。以内照四谛为实智。外说教为权智者。佛自转法轮则转之与轮皆是实智。若为众生转法轮者则所转之轮为实智。能转之教为权智也

次明教智两轮

问。大经云诸佛世尊凡有所说皆悉为转法轮也。此用何物为转云何为轮耶

答。可具二义。一者佛教为能转。众生智为所转之轮。以诸佛说法皆能生物智慧故。以佛教为能转。众生之智为所转之轮也。二者以教为所转之轮。以佛智为能转也。所以然者佛二智能说二谛。二谛之教为所转之轮也

问。前云教为能转。众生二智为所转之轮。与后相违云何会通耶

答。佛为众生转法轮要须具二种能所。一者以二智说二轮。则二智为能转。二谛教为所转之轮。二者二谛教复能发生众生二智。则二谛教为能转。众生二智为所转之轮也。初则智能谛所。次则谛能智所也

问。就佛自转亦有能所不耶

答。佛二谛能发生佛二智。则二谛为能转佛智为所转之轮。合前则有三种能所也

问。教云何名轮

答。教有摧邪显正之能亦名轮也。以智为轮通自他。以教为轮但为他也

问。智教为轮出何文耶

答。大经云。凡有所说皆名为转法轮此教也。净名云得无生忍转不退轮。以智为轮也。十住论具出二解。一云十二种行为轮。十二种行谓眼智明觉此用智为轮。二云分别三乘之法名转法轮。用教为轮也

次明三轮义。一为声闻转四谛此则三转谓示劝证也。为缘觉明再转。谓十二因缘相生及以还灭也。为菩萨说六度轮。但明一转。不三说六度。亦不言有生灭二也

问。何以知然耶

答。法华经文自作此判。四谛则言三转。十二因缘则言生灭。六度直说而已也

问。何故尔耶

答。示声闻根钝故三转。示缘觉中根故再转。示菩萨上根故一转也。次明通方义者。声闻既三转。余二亦然互例也。又通者三乘人同观十二因缘。故得通为三乘人转十二因缘法轮。但就十二因缘教可分二位。为二乘人说生灭十二因缘故名为二转。为菩萨说无生灭一中道正观名为一转。故中论云。前于声闻法中说生灭十二因缘。次为菩萨说无生灭十二因缘。生灭十二者即是相生及还灭也。为菩萨说无生灭十二者。十二本不生今亦不灭也。次明四谛通别者。为二乘人说有量圣谛。为菩萨说无量圣谛

问。何文明为缘觉人说四谛耶

答。十二相生即苦集。还灭即灭道。义可知。又释论往生品云。菩萨若证四谛成辟支佛。即共文也。次明六度通别者。通得为三乘人说六度。大品发趣品云。阿罗汉辟支佛诸佛因六波罗蜜到彼岸。摄大乘论云。凡夫二乘皆有六。但六不同菩萨耳

问。若三乘皆六者。亦应但名波罗蜜不

答。二乘人行此行到涅槃彼岸。亦称波罗蜜。但不能到佛道彼岸故。比菩萨非波罗蜜耳。又释论明小乘人具有六度。以佛毗昙即是波若。定即禅戒为尸罗。道品中精进即毗梨耶。能忍呵骂即忍。有布施即是檀也

问。六度即是四谛不

答。六弊相生为苦集。六行能灭即道谛。所灭之无谓灭谛。亦得具四谛也。次明别释声闻三转义

问。何故明三转耶

答。三世十方诸佛法语不过三。鹿园之时此是初转法轮。示诸佛法所以三说也。二者为众生有三根故三说。释论第百卷云。受法者有三种利根一闻即悟。中根二闻方解钝根三说始悟。婆娑亦作此判也

问。为五比丘三说四谛。此中云何有三根耶

答。此中有八万天及五人。何故无三根耶。三者发生三慧。是故三转初转生闻慧。次转生思慧。三转生修慧四者初转生未知欲知根。次转生知根。三说生知已根。五者初说生见道。次说生修道。后说生无学道

问。鹿园三说生何物耶

答。但生未知欲知根。但生见道而具生三慧。至见道时是修慧位也

问。何以然耶

答。以五人及八万天皆得初道故也。又第一说利根人生见道。中下未悟。皆在见道前。第二说利根人至修道。中根人在见道。下根人未入见谛。第三说上根人得无学道。中根人得修道。下根人得见道也。三慧亦尔。利根人闻一说得闻慧。则二人未得。第二说利根人得思慧。中根人得闻慧。第三说利根人得修慧。中根人得思慧。下根人得闻慧也

问。何以知然耶

答。婆娑云。陈如一人得初道。时四人住四善根也。但三转有二种。一者四谛三转如前。二者一谛三转。谓是苦。苦应知苦我已知。集等亦尔也。次明十二行义。开为二意一就四谛法轮明十二。次约十六谛法轮明之转四谛法轮明十二者。有教十二有行十二。教十二者即示劝证。四谛成十二教。十二行者三转皆生眼智明觉。若教十二为能转。行十二为所转。十二行是轮。十二教非轮也。若明二轮义者。十二谛是教法轮。十二行是行法轮。若是教法轮则能转。唯是一权智。所转则有十二教也。若是行法轮。能转之教有十二。所转之行亦十二也

问。此教行为就一人为就多人

答。教通一人多人。自有一人具禀示劝证三。自有三根人禀三各得悟。若就见谛道论十二行者。要是三人。利根人闻示转即生眼智明觉。故得见谛。中下亦尔。以三人合举故言十二行也

问。何故约见谛明十二行耶

答。此就鹿园。明陈如及八万诸天得法眼净故作此说也。又约小乘义。见谛道正是法轮。小乘旧义云。牟尼说见道疾。故名法轮。瞿沙亦尔。故云或复说八支转至于他心。八支犹是八正道。八正道即是见道。然瞿沙解转与杂心不异。但杂心明转与轮皆是见谛解。就两义分之。取见谛无漏解。有摧破义故名为轮。此解速疾说之为转。瞿沙明佛自悟八正至五人心中故名转也

问。何以知三转生三道耶

答。释迦初转但明得见谛解。故就见谛道。大通智胜初转时皆得罗汉。罗汉必经三道。故知就三道明三转也。萨波多明唯见道名法轮。僧祇部明诸佛凡有所说皆名转法轮。释论云。但初说名转法轮。后去因初亦名转法轮也

次明四十八法轮者。如一人得眼智明觉。开此四心则成十六心。谓苦法忍为眼。苦法智为智。比忍为明。比智为觉。与三谛皆尔。故成十六。三根人各得十六故成四十八行也。次明转十六谛法轮。亦应有示劝证。则成四十八教法轮。三根人各得十六心。故是四十八行法轮也。此非是苦忍十六心。乃是苦无常十六心也。一人三人具得四十八教。若是行轮四十八者但约三人也

问。四谛十六谛何异耶

答。略广为异耳。又为利根人但略说四谛。为钝根人广开十六。又四谛为章门。十六为解义。又广说为十六。为易持故但说四也

问。前明四十八行。后复明四十八行。云何异耶

答。若转四谛法明四十八行。必是约见谛也。何者以见谛十六心约三根各得十六故。故成四十八。思惟不必备观四谛。又作九无碍九解脱断惑。不明十六心故不得作四十八也。若转十六谛法轮者。此通见思。以见思皆得作十六谛观。故成十六行。但前十六唯就见谛故别。后十六即通也。次明以四句束之。一开教开行。谓十六谛十六行也。二合教合行。谓十二教十二行。三合教开行三转十二教为合教约三根四十八开行也。四合行开教。约一人具闻三转十二教。故名开教。但生一眼智明觉为合行也

问。今明小乘与数论明小乘何异耶

答。存言虽同其心则异。如净名序小乘法轮云三转法轮于大千。其轮本来常清净。若尔者虽复开之与合境之与行皆是因缘。假名之转。因缘转此是无转而转无所转。故云其轮本来常清净。乃至境无所境开无所开。如此乃得名转法轮。亦乃得名法眼净也。若有所转此是转颠倒。不名转法轮。若有所见乃名颠倒见耳。不名得法眼净也。华严性起品序。小乘法轮无所转无所还名转法轮

问。无转而转。为是大乘中说。为是小乘中说耶

答。大乘中序佛说小乘转法轮意如此也。若不如此悟者是人不得大乘意。亦不得三藏意也。次别明大乘转法轮有四句。初转四谛轮。次转二谛轮。次一谛轮。次无谛法轮。小乘但有三转而大乘具有四转。此四转皆是舒卷明义。舒之从无谛为一谛。一谛为二谛。二谛为四谛卷之则合四为二谛。二谛归一谛。一谛归无谛。四转法轮者。一中道佛性。法华亦然。约此开四谛。迷之则成苦集。悟之则成灭道。迷之成苦集者。如随其流处六味不同。一切诸业烦恼即集谛。生死苦恼即苦谛。悟之即有十信乃至等觉地名为道谛。如来地一谛一依寂灭涅槃名灭谛也。次合此四谛唯成二谛。三谛入有为相。灭谛入无为相。唯有常无常二谛。亦是空不空二谛。无常即是可空。涅槃名为不空。故云空不空二谛也。次合二谛唯成一谛。有为虚妄不名为谛。常住真实故名为谛。如大经七义释之。次泯一谛以归无谛。如经云所言空者不见空与不空。不见空者不见有为生死空也。不见不空者亦不见涅槃不空。又生死是空。而今通言不见空不空者。涅槃为不空。亦不见有不有。若尔即不见生死空不空。亦不见涅槃有不有。故非空非有非生死非涅槃。即是无谛。又大经十三卷云。鹿园唱小而无言。双林大音而不说。呵文殊谓转斥时会有闻。即如此相始名转大法轮。故前云若知如来常不说法。是名菩萨具足多闻。次双泯大小。以生灭为小轮。以无生灭为大轮。此是无生灭生灭生灭无生灭故。非生灭非无生灭。非大非小不转不还。故云其轮本来常清净也。佛如斯而转竟无所转。缘如斯而悟竟无所悟。无所转始为妙转。无所悟始名妙悟。故肇公云。玄道在乎绝域。故不得而得之。大音匿于希声故不闻而闻之矣

五百由旬义。论曰。佛法虽复深旷而大要不出生死涅槃迷悟二[跳-兆+(轍-車)]也。诸师盛引五百由旬广证诸义。故须评其得失。此义若成众证皆立。斯义若坏众证皆谬矣。有人言生死有四种。一流来生死。二变易生死。三中间生死。四分段生死。今但明三种生死以譬五百不说流来。流来是有识之初。今明反原之始故不说也。三百谓分段生死。四百是七地。中间生死五百是。八地已上变易生死也

评曰。此释五义为失。一者四种生死经论无据。胜鬘云因五果二。果二者一分段二变易。因五者谓五住地。离二生死别立流来生死及中间生死。应离五住外别立烦恼。离漏无漏业别更立业也。二者法华明五百。而不增为六百减成四百者。经明二种生死亦不可增减。若二生死遂有增减则五百义亦同然。三者释论云。菩萨有二种身一肉身二法性生身。肉身则分段生死。法身谓变易生死。若二生死外别有生死。应离二身外别更有身也。四者论又云阿罗汉舍三界肉身受法性生身。故罗汉唯有二身。则但有二生死。离二之外无别生死也。五者若以四百为七地则三百为六地。若尔二乘断惑便与六地齐功。若二乘断惑齐六地者无有是处。二乘极久唯六十劫或百劫。菩萨至六地时二十二大僧祇劫。略据一文详之则菩萨求佛道而迂回。二乘望大觉为直路。而众经呵斥二乘便成妄说。又大智论云。二乘去佛道迂回。不如直往菩萨。以经论详之不应作此说也。此义至有声闻无声闻中当广论之。有人言但有二种生死。如胜鬘所说。但此中三百喻三界。四百喻七地。二国中间难可过度。五百喻八地已上

评曰。经明七地难可过度。就菩萨法中自论难易。云何用此以化二乘人耶。又若以四百喻七地。则应三百喻六地。则二乘还与六地齐功。有人言断见谛惑为一百。断五下分结为二百。断五上分结为三百。断恒沙烦恼为四百。断无明为五百

评曰。不然。初果倾三界见谛。已度三百一半。不应言一百。又未断欲界思惟。未度一百。若过若不及也。又经说三界为火宅。二乘出火宅。即是度三百。不应有此解也。四百为恒沙。五百为无明。还配地位者同前评也。有人言。三界为三百。七住及二乘为四百。七地已上为五百

评曰。三界为三百则如前判也。后二还以配地过同于前。有人言如大经云。须陀洹八万劫到乃至辟支佛人十千劫到。到者至于菩提心处。如三根人领解。即是发菩提心。以五种人来至菩提心处故言广五百也。此取极钝根人故云八万劫到耳。若利根人不必须多劫。释迦一期出世得四果者。闻法华皆发心即名至也

评曰。是义不然。经明度三百由旬立二乘地。岂是度五人耶

问。五人并发菩提心名度五百。如初果经八万劫发菩提心。是超二乘地名度五百

评曰。此乃是大经明五人发心离于五位。今非此中意。所以然者上来皆明权实之义。今譬亦明权实。度三百立化城此是权。度五百至宝所名为实。故废化城进宝所。若明度五人者皆是进宝所譬。失立化城譬意故此非解也。次总评。上来诸释皆非经意。所以然者。此经三周说权实。有法譬有合譬。此五百由旬亦有合譬。诸经师不观合譬文不解合譬意。故引余处经意以释此文。故皆僻谬也。次出今譬意今所释者。三界为三百。声闻地为四百。缘觉地为五百也

问。以何义故作此释耶

答。今以二义作如此判。一者三百为凡夫地。二百为二乘地。此二障于佛道。欲求佛道须免斯二障。故释论云。菩萨退有二事。一贪三界二乐二乘。今免二退故得入菩萨位进至宝所。又三界名有见地。二乘名空见地。空有二见伤菩萨中道正观。今欲修菩萨行求于佛道。应离此二地也。又三百以生死为障。二百以涅槃为障。地论云。菩萨度五道复净涅槃。以五道与涅槃皆是障故。又华严云。大药树王不生二处。一者深水二者火坑。火坑深水即是二乘及邪见凡夫。此二不能生菩提心大药树王根。是故菩萨须离此二地也。又三界是二乘牢狱。二乘地是菩萨牢狱。故二乘欲出三界。菩萨欲出二乘地也。又三界凡夫多修福德而无智慧。二乘之人多有智慧而无福德。以二轮不具无由至佛。故须离之方登大觉也。又行有三种。一者凡夫不能自行。亦不能化他行。二者二乘但能自行。而不能化他行。则行不具足。菩萨修自行故出凡夫地。修化他行故离二乘地也。又摄大乘及地持论明障。有二种。一惑障。二智障。脱三界烦恼但离惑障。未离智障。若出二百便离二障也。又生死有二种一分段二变易。若凡夫受分段。二乘受变易。离凡夫故不受分段。离二乘故不受变易。又生死因缘凡有二种。一有漏业因四取为缘。二无漏业因无明为缘。凡夫有有漏业及四住烦恼。二乘有无漏业有无明烦恼。今度此五百则断此因缘故生死永尽也

问。若如后三义还同旧释耶

答。旧不数二乘为二百。岂同旧耶

次引证

问。此释出何处文耶

答。释论解大品闻持品云。菩萨度四百由旬则去佛道不远。论云三百喻三界。四百喻二乘地。菩萨度此二地知必作佛。但大品合二乘为一百。法华开为二百。虽开合不同意无异也

问。大品已明此譬者与法华何异耶

答。大品但明菩萨度凡圣二地。未明二乘为权。犹阙化城之意也

问。既未辨化城亦应未明宝所耶

答。大品已明显实相。故辨宝所。犹未开权故不明化城也

问。大品可用此喻法华何必同耶

答。下合化城譬中佛自作此说也。如经云佛知是心怯弱下劣。为止息故说二涅槃。此合度三百由旬譬也。若众生住于二地。如来尔时即便为说。汝所住地近于佛慧。此合度二百由旬譬也。文既分明无劳惑也。而经师都不见此文。横引余事以释故失经旨也。又不以二地为二百。复以何文合二百耶。又责旧经师曰。譬说之中明一化城今合譬文何故乃明二地。不应一二相违。今明开合皆有其旨。所以合者略明六义。一同出三界。二同得尽无生智。三同断正使尽。四同得余无余二涅槃。五望波若三慧品同得一切智。六同名小乘。以六义同故合二乘为一化城也。而开为二地者略明十义。一行因久近如百劫六十劫等。二者根有利钝。三从师与独悟。四声闻无大悲。缘觉有小悲。如鹿犀之喻。现释论也。五声闻不必有相好。缘觉必有。但小多不定。六声闻观法略谓四谛。缘觉观法广谓十二因缘。七声闻说法则令人悟于圣道。缘觉不能令至燸法。及得贤圣事。出大经。八罗汉必在佛世。缘觉不定也。九声闻或顿证四果或复渐证。缘觉必顿证如三藏佛。十缘觉现通多说法少。声闻不定。以具十义故开为二地。是故三百譬三界二百喻二地也

问。譬喻品何故合三界为一宅。开教门为三乘。今何故开一宅为三百。合三乘为二百耶

答。前明同为苦火所烧。故合为一宅。求出者有三根人不同。故教门开为三乘也。今明佛道长远。三界及二乘地是大恶之道要。须度之然后得佛。是故开一宅为三界。三乘中但二乘地是障佛乘非障。故但明二百也

问。何故以凡夫地为三百。小乘地为二百耶

答。盖引进之言。明汝所度已多。汝所住地近于佛慧。唯二百在耳。当怒力精进。宝所不遥也。以理言之则所度犹少未度犹多。二乘发心始入十信。方经五十二位三十三僧祇劫方至佛耳。尔前极长百劫修行故所度犹少也

问。若所度已多是引进之。言则此经未成了义耶

答。深有旨也。明佛道虽长。若能度凡夫地及离二乘地者后进修行不复为难。故名为近佛。如万里之行唯五百里多难。若过此道则前进为易也。次论恶道

问。何故说五百由旬皆是恶道耶

答。上诸义即明恶道竟。贪着三界及深二乘。能害菩萨法身惠命故言恶道。二者佛及弟子已四处开权显实呵责二乘。钝根闻之犹未领悟。方便品云。小智乐小法不自信作佛。是故以方便分别说诸果。次身子章云。我昔于空法得证。而今乃自觉非是实灭度。譬喻品云。唯有一大车。唐捐门。外实无三车。信解品云。佛乘如大豪富长者小乘之人如。眇目痤陋无威德者。乃至贫穷下贱除粪之人四处。虽种种呵斥二乘称叹大道。钝根声闻犹故保执。是以今说恶道譬喻明三界二乘皆是恶道。汝今云何欲乐住耶。又昔于大通佛所已欲度五百由旬。今积行弥劫云何退住恶道。譬如父母呵子云乃不长进何为退缩。又凡夫以三途为地狱。二乘以三界为地狱。菩萨以二乘为地狱。故大经云。今我怖畏二乘道果。如惜命者怖畏舍身。汝今云何乐住地狱。又本畏生老病死。求涅槃乐。三界及二乘地未免生死之苦。故名恶道云何欲住。又此凡圣二地未免四魔。故名恶道。三界具四魔二乘具三魔。烦恼未断故有烦恼魔。方便受身故有阴魔。无常所切即是死魔。明此二地未免四魔。但前进不可住也。又华严性起品明即事而言四乘皆苦。为三途苦说人天乘。为三界苦说声闻乘。为声闻根钝少福有徒师之苦。说缘觉乘为缘觉福慧未圆结习不断之苦。故说佛乘以有四苦名为恶道。本欲厌苦今未脱之云何欲住耶

问。若二乘地是恶道者何故文云度三百由旬。说二种涅槃耶

答。此则是开权显实义。昔说恶道为涅槃。欲引出三界。今指涅槃为恶道令离二乘不相违也。又有三句。一恶而非善。谓三百也。二善而非恶。谓度五百也。三亦恶亦善。中间二百能度三界故为善。以是佛道巨患故名为恶。故经云。求二乘者名为不善。既称不善岂非恶道耶

问。会二行皆为菩萨。云何名恶道耶。故不应以二乘地喻二百也

答。亦会人天善入一乘。云何以三界为恶道耶

问。三界烦恼可得为恶道。善是清升云何为恶耶

答。三界烦恼心所起善。皆是不动不出非是乘义。二乘心所起善亦不动不出。亦非乘义

问。云何凡圣二善俱不动不出耶

答。凡夫善不能出分段。二乘善不能动出变易。又有二种阐提。一凡夫阐提。二圣人阐提。凡夫不信出三界者名凡夫阐提。二乘不信一乘名圣人阐提。破凡夫阐提始生小信。破二乘阐提始生菩萨十信也。因此转悟方入菩萨道

次论至宝所义

问。若以三界及二乘为五百者。度三界及二乘地应至佛道。此譬以宝所喻佛道故也

答。三界及二乘是佛道巨难。若能度之必至佛道。故大经有三处文。明二乘至义。一云至菩提心。二云至菩提。三云至大涅槃。然二乘经尔所劫。但应至菩提心耳。而言至大涅槃及菩提。以至菩提心必至佛道及涅槃故也

问。五人云何至菩提心必至佛道耶

答。五人发菩提心时必是双厌之。人既登圣位故必不作凡夫。今复发菩提心则厌二乘道。是故此人不起凡夫行。亦不起二乘行。所以至佛道也

问。大经何故举三文耶

答。要须三文义乃圆足。至菩提心谓至因。至菩提及涅槃名至果。果中有菩提智果及涅槃断果。所以说二。今欲具说始终总摄因果故有三文也。又度五百由旬至佛者譬意具三。一恶道二好路三宝所。合譬亦三。一发菩提心谓度恶道。二行菩萨行如平坦好路。三得佛道如至宝所也

问。譬无此意云何穿凿耶

答。理数应然岂可度二乘地便得佛耶。又下偈中具足明之。今为汝说实汝所得非灭。此明度五百恶道也。为佛一切智。当发大精进谓行菩萨行。即好路也。汝证一切智十力等佛法。谓得佛道也。又度五百即至佛者。三百为分段生死。二百属变易生死。度于二种生死必得至佛也

次论多少

问。何故度五百不多不少耶

答。如前十义及恶道中说。又唯有五乘故但度五百。人天乘是三百。二乘是二百。故佛乘度此五百。以声闻乘度三百缘觉乘度四百佛乘度五百故。不得多少。此明一人始终度五百。亦得五人度五百。如大经一人具七。七人具七也

问。释迦舍那教门明度云何耶

答。舍那直说一乘明顿度法门。直令菩萨度于五百也。释迦初三后一具渐顿义。昔已令诸子度三百。今复令度二百谓渐度。若为始发心菩萨说法华经即令顿度也

问。昔亦明顿度不耶

答。昔为菩萨亦令顿度五百。如大品四百之喻。但未明三百为化城耳

问。昔未明三百为化城。亦应未明五百恶道

答。二乘是佛道大患。是故已说是恶道。但二乘根缘未熟故。不得明化城也

问。昔度今度何异

答。昔但令菩萨度五百。令二乘度三百。今教令菩萨度五百。明二乘人已度三百。但令更度二百耳

问。法华叵有菩萨不度五百而修行耶

答。亦有此义。如位不退菩萨已过凡夫行及二乘行。此人已度五百恶道但修菩萨行。入平坦好路进至佛果宝所也。若就二生死为五百者。唯佛度五百耳

问。若尔无有菩萨得离二乘地者耶

答。胜鬘经云。声闻缘觉大力菩萨皆共在不可思议变易生死中。就此而论菩萨与二乘。共在生死中不得相离也

问。叵有菩萨与二乘不共在生死以不耶

答。摄大乘论明七种生死。界内通名分段即三种生死。界外有四种生死。谓方便生死即变易是也。二因缘生死。三有有生死。四无有生死。后三生死唯菩萨受生。二乘在变易生死内。故菩萨与二乘有共生死义。复有不共义如彼论广说也。安乐行义八重第一来意。然此品虽是法华之一章。实通辨菩萨之要行。夫欲自行化人弘道利物者皆须依之

问。何因缘故说四行耶

答。上品末菩萨声闻皆云弘经多难。弘经多难或生退没妨自行化他。故说四行。身心安乐自行化人则无所废。又大判位行略有三种。一发菩提心。二行菩萨行。三得佛果。上三周说法即是发菩提心。今此一品即明行菩萨行。宝塔已去明佛果也。又上三周明开三显一之义。谓智慧门。次叹法美人明流通。谓功德门。物情便谓有三有一有福有慧。是故此品泯寂斯念。劝菩萨观诸法如实相。不有不无不二不一。而不失三一方便。自行化他虽有三一。三一只是无三无一。为是因缘故说此四行。如说经大意释也第二明四行名不同。光宅云。一空慧行。二说法行。三离过行。四慈悲行。但初行中辨空慧。后三不明。故初名空慧行也。第二行中广明说法。第三行中亦有说法。说法义略故第二名说法行。第三行中广明离过。余行文少故第三名离过行。第四广辨慈悲故名慈悲行。第三亦有慈悲。慈悲文略不名慈悲行也。生公及注经列四行名。第一空寂行。第二离憍慢行。三离嫉妒行。四者慈悲行。生公不以说法别为一行者。下偈云。安住四法然后说法华经。此明内住四法外说法华。故不以说法为一行也。今用生公所说也

问。观第二行文实是明说法。不应言离憍慢行也

答。由初行有解。次行无慢。内具此二故外无是非。方能说法耳。次明四行体。光宅以假实二空为初行体

评曰。假实二慧此犹小乘论意耳。正可通彼阿含不应用释。方等如前评之。有人言假实二空似解为体

评曰。二空失已如前义。似解义又不可。下位高人皆通用四行。偏据似解而弃真明非可用也。有人言初行以忍辱为体也

评曰。不然初文具明空有解行。忍辱是有行之一枝亦非所用也。今所明者初行正是二慧为体。何以知然。夫欲说法要须正解二慧。是菩萨妙悟不同凡夫二乘。故以二慧为体。故文云观诸法如实相空无所有。谓实慧也。但从颠倒因缘生谓方便慧也。第二行体者光宅云。说法行用言辩为体。有人言用权智为体。今依生公及注经用离慢为体。上明二慧已有能说之功。但恐内恃明解外相是非。故明离慢为体也。第三光宅云离过行即以离过为体。龙公云。不说他人好恶长短。印师云离七支恶。复有人言离慢为体。今依生公以离嫉妒为体。憍慢则贵已卑人。嫉妒则恶人胜已。斯二是弘法之大患。伤菩萨之本怀。故说离之也。第四慈悲行。经有明文。众师更无异说。但慈悲有三。一众生缘见有众生。二法缘不见有众生而见有法。三无缘。此三异者亦得三人具三一人具三三人具三者。外道有众生缘。二乘法缘。菩萨无缘也。一人具三者。始行为众生缘。中行为法缘。上行为无缘。今品所明者既发趾标生法二空。则以无缘为正宗也

问。既言无缘则应不缘众生。何名为慈悲耶

答。缘众生如实相故名无缘。无缘者不复起众生见及法见。如实相而识众生故名无缘也。第四释四行名。初行处近处。此二种是所行之处。举所目能从境为称也。中间二行离过受名。第四慈悲当体为目。通称安乐者。安住四行故身心乐也。又行此四行身安心乐。又外缘不动为安。内心适悦为乐。又安为离苦乐名得乐也。又身安心安身乐心乐也。初义为正也。第五明开合。龙师云初一是身业。次一口业。后二为意业。此皆大判耳。有人言初二主智慧。初一为空智。次一为有智。后二主功德。初一为止善。后一为行善也。今所明可为四双。一者初一为解。后三为行。解中具空有二解。行中有离得二行。中二为离行。后一为得行也。又初一为智慧智慧中有空智有智。后三为功德。功德中有止有行。中二为止。后一为行也。又初一后一为得。中二为离。又前三为自行。后一为化他。化他拔苦与乐。自行中初一为生解。后二为灭惑也。第六明次第。夫有苦者皆由乖理。若具二慧则是得理。得理者无复苦恼身心安乐。是以第一先明二慧。虽复有解恐恃解[怡-台+夌]他。或忌人胜己。故明不憍不嫉。初具二慧又具两行。则自德成立。然后以慈悲被人故次第也。第七明位。始自发心终于十地皆行四行。但地前似而未真。登地唯真不似。真位之中有并不并。就并之中有功用无功用。如前释也。但四行就一大体论之必是齐品。但习学不同。或功德已深智慧犹浅。或自行已胜化他犹劣。不定也。第八明同异

问。法师品明三事。入慈悲室着忍辱衣坐于空座。与今何异

答。彼前明于有行以有资空。今前辨于空解以空导有。以空导有空宛然而有。以有资空有宛然而空。但字不累书故前后说耳。又前明化他后辨自行。今前明自行后辨化他。以菩萨先人后己故。前化他而后自行。然要须自免方能济人。故前自行后化他也。次释法师义。法师义者已如弘经方法中释竟。未尽今当略说。依此有五种法师。一受持二读三诵四解说五书写。释论解灭诤品云。以信力故受。念力故持。或看文或口受故言为读。常得不忘故为诵。宣传未闻故言为他说。圣人经书直说难解故解义。此即有六种法师。望今文互有广略。今文合受持为一。为他说与解义复为一。足书写为一也。释论解无作品。明说波若有十种。十种皆是就说法中开耳。通称法师者。法是可轨义。五人上弘此法。下为人作师。故云法师。通自行化他也。又法师者此五人以法为师。此自行法师。又法师者法乃尊妙。要由人弘。人有弘法之功名人为法师。如云当作心师不师于心。今亦如此。以弘法故为法作师。此化他法师也。次明位。若例四依应起自内凡通乎十地。是其人位。但于初依自有师资之别。此自明依止之位。今就弘化分之。外凡已上皆法师位也。次约阶品。如涅槃四依品明有九人。初人于熙连河沙佛所发心。亦得不谤未能信乐。次一恒河沙佛所发心。得信乐而未能受持读诵。二恒河沙佛所发心。能受持读诵未能为人说。三恒河沙佛所发心能为人说而不解义。四恒河沙人十六分中解一分义。五恒沙人十六分中解八分义。六恒沙人十六分中解十二分义。七恒沙人解十四分义。八恒河沙人具解十六分义。此九品人前四人既无解。是弟子位非师也。后五品人既有解义属法师位也。此五人合为四依人。即初依人。又通而为论三十心位俱皆是法师也。十地菩萨念念化人皆是法师。自有优劣。如九地得十种四无碍为大法师也

问。三业云何摄五种法师耶

答。论云信力故受。念力故持。此是意业。然初非不藉身口业也。书写是身业。而要假意业。亦得有口业也。余三皆具三业也

问。此五得相离以不

答。受持是意业。得离读诵等四。若是读诵等四要须受持。所以然者由信心故方有读诵等耳

问。亦有无信而读诵。此应离受持也

答。今不论此也

问。经中何故先明受持。读诵解说书写以为次第耶

答。信为初门故前说受持。以信力故能读诵故。能读诵竟方解义。解义故为他说使法流通故书之也

问。此五几是功德几是智慧耶

答。皆通福慧。但余四属功德。强解说正是智慧也

问。受持具信念二力。余四具几力耶

答。解说是慧力。亦是精进力定力也。读诵正是精进力亦是慧力。但遂强弱耳

问。此五几自行化他耶

答。解说通自他。但化他强自行弱。四通自他自行强化他弱也

问。何故但明此五耶

答。略举五耳。大品及此经劝发品复有正忆念及修集。皆摄入今三业中故也

问。受持意业可得化他人不

答。由意业信故能化他人亦有化他义也

问。此五云何深浅耶

答。依经次第明深浅者。直信之则易故在前。以有信故能读。读故能诵。诵故能解说。解说故云书写即是从浅至深也

次论佛道近远义释高原求水譬。论曰此虽一句经文但寻味之者喜生。抑扬涅槃以四重五逆谤法阐提皆一类而科之。波若云不谛读诵受持故成魔事。今具述异闻详其得失。敢希生善庶望免咎。有人言初教如高原干土。大品如湿土。法华譬泥。佛果如水。有人言维摩思益如干土。无量义经如湿土。法华如泥土。佛果如水。有人言大品如干土。无量义经如湿土。法华如泥。佛果如水。此三皆执五时说者也。生公云。渴乏求水者。受持法华求悟佛道。欲得之如至渴乏须水也。于彼高原穿凿求之者。一乘于三乘为难得。故于法华求解如求高原水也。受持读诵为穿凿。未能如闻而解犹为未闻。如见干土。若能解者方乃为闻。如遂至泥知去水不远也。注经云。生死渴乏须寂灭之水也。高原水者一乘理妙。求理于法华如求水也。犹见干土者。受持书写以穿凿之初为未闻。未解去道尚远如见干土也。次读诵以譬施功不已。闻已解故曰见湿土与泥。注经犹采生公意。但小加修饰耳

评曰。此譬唯有二意。一譬去佛道远。二譬去佛道近。不应纭纭有余释也。又初三师明法华之前诸教去佛道远。法华教去佛道近。后二释但就法华中自论远近。未能如闻解为远。能如闻解为近。今捡经始终皆失旨也。寻长行合譬及偈文具有二义。一举余经对法华以明近远。二就法华自论近远。偈云如是等诸人不闻法华经去佛道甚远。若闻是深经近于佛智慧。此举余经对法华以明近远也。长行云。若未闻未解未能修习去佛道远。与此相违去佛道近。此文具二义。若据未闻为去佛道远。此举余经以对法华。若就未解为远能解为近。此据法华自论近远。是以众师偏用一文俱失经旨也

问。举余经对法华明近远相云何耶

答。法华之前未开三为方便一乘为真实。遂使求佛之人犹有踌躇。大小之望取佛之心未决定。故去佛道远也。法华明有一无三永息退心求佛意决。故去佛道近也

问。何以知就开权显实义明近远耶

答。下偈云。若闻是深经决了声闻法。决了声闻法者知其是三权一乘为实也。又长行云开方便门示真实相。即释近远之意故知尔也

问。法华之前即是波若。可云波若去佛道远耶

答。前已释此义竟。今重论之。一者据波若未开权义边。即始行菩萨犹有进退之望。或言进为菩萨。或谓退作二乘永不成佛。故波若于其人去佛道远。若闻法华无三有一。直进不回。则法华于其人去佛道近也。二者声闻不觉。波若密化二乘令趣佛道。如不觉付财。犹言波若有三乘教。故保执二乘。波若于其人去佛道远。闻法华开权明有一无三。改二乘执信受一乘。则法华于其人去佛道近也

问。约大小二人判二经近远。以理言之波若法华云何优劣耶

答。波若正明实慧方便慧。此二是十方三世诸佛法身父母。求佛者要修学波若如前已说。又求佛道者皆具烦恼。如老病人寝卧床席不能起居。波若方便二健人各扶一掖能至佛道。故求佛之人须学波若。又三界二乘是佛道巨患。以实慧故不着三界。以方便故不证二乘。离此大恶能至佛道。故求佛之人要学波若。又波若显诸实相。实相是大乘本。由实相故有波若。以波若心修万行。万行皆是无所得。如此万行能动能出名为大乘。若尔波若经乃明一乘之本。故波若最胜。此即是本中之本。所以然者。一乘为三乘本。实相复为一乘本。波若常明实相。即波若经为本中本也

问。实相亦是三乘本。云何言是一乘本

答。二乘人不能知本性空。故诸法本性空唯是大乘根本。非二乘本也

问。波若未开权。则波若为劣。法华为胜不耶

答。法华但明开权之义异波若耳。若显实之义终归波若。所以然者。开权即改二乘心。改二乘心即发菩提心。若发菩提心竟即修行学菩萨道。要须詑二慧之胎方成如来法身之子耳。故知波若为胜。又佛始终常用波若化物。初显教菩萨波若。密教二乘波若。此从大品至法华前也。次至法华显教二乘波若。亦显教菩萨波若。以显教二乘波若故波若亦名法华耳。非波若外别有法华也。至涅槃明波若即是四种佛性。大品云。因名波若果名萨婆若。涅槃云。因名观智果谓菩提。菩提无累即是果果。观智与境界更无别体。所观义即境。能观义即智。发观义为境。能照义为智。故波若即是四性。当知唯一波若。是故最大。又地前四十心名相似波若。登地去至佛名真波若。故知波若竖通于五十二位。即波若最大也

问。波若是何物法如此最大耶

答。波若是诸佛菩萨观心。是故一切教皆明此法。一切佛菩萨无不修行。又波若有三种。一所行即实相境。谓实相波若。二能行之观。名观照波若。三为众生说即文字波若。所行境即佛菩萨所行处。能行之心即佛菩萨观。此二为自德。文字波若即是教门化他德。此三摄一切佛菩萨能行所行自行化他义无不尽。虽有千经万论终显此法。以一切教皆入波若中故波若最大。龙树岂是虚言者哉

问。若尔法华应劣耶

答。法华是波若异名。但明上来诸义不及波若。故名为劣。非但法华不及一切大乘经。皆不及波若。如论列十种大经而波若最大

问。此语难信。今重请释。为波若明义已了。余大乘经明义未了。故判胜劣以不耶

答曰。不也。但波若专明上来诸义。余经不尔。据此义故称波若最胜耳

问。前言就法华中自论去佛道远近义云何

答。大意如生公。注经释云。今更须领此意。若闻法华生三慧者即去佛道近。虽闻不生三慧则去佛道远。故文云。若得闻解思惟修习去佛道近。闻解谓闻慧。思惟谓思慧。修习谓修慧也。就三慧中自论近远。闻慧为远余二为近。如是可知也

问。但应如生公及注经释之。所以然者。唯一高原就中求水有近有远。唯一法华教中求佛生三慧为近。不生三慧为远。若以法华前教为远法华为近者。乃是异原何名一原耶

答。法华波若同是一大乘藏。亦得同为一原。又依生公解有前诸妨故可得两而存之也

法华玄论卷第八法华玄论卷第九

        胡吉藏撰

    宝塔品密开本迹义

河西道朗云。上来开三显一明法华体竟。从此去辨果门。谓法身常住理非存没。注解云道非存亡古今一揆。然则裂地诵塔以表双林非灭。交莚接向微显丈六非真。生公意亦同矣。印法师云。上来明三乘之教为权。一乘之言为实。自此以下至神力品。明形权身实。王宫非生双树非灭。此品始开其端。又亦证上所说至当之极。亦督时会宣通上之所说也。光宅云此品证上所说不虚。命觅弘经人也

评曰。初三师但为开后。光宅唯为成前。印公则两而兼之谓结前开后。考经始终印释为长矣

问。云何证前云何开后耶

答。成前者证上所说不虚。上三周说明一乘体竟。法师品明受持乃至书写生无边之福。谓一乘用。体用既周宜证说。又三周说明慧。五法师明福。福慧既圆故须证也。又三周辨所通之法。五法师明能通之人。人法既圆须证说也

问。证有几种

答。一切证说凡有二种。一人证二瑞相证。多宝浮空分身向集即人证。灵塔涌现谓瑞相证。华严中诸菩萨说法竟亦有二证。十方菩萨来谓人证。雨华动地为相证。今佛说经竟。还以佛依正二果为证成也

问。何故须证耶

答。一乘难信。恐释迦化偏。故古佛证显诸佛道同非释迦偏化也。又既说穷理之法必感非常之瑞。瑞中之大者莫过三世佛集。时会见之则未信者信已信坚明。又多宝涌现及十方佛集。共叹经福重。命人弘宣则始心终行莫不受旨。如是等义故证前也。开后者上来开三显一明教权实已竟。今次显如来身方便身真实。从现塔至寿量略明三义。一者明多宝灭既不灭。则知释迦生亦非生。欲显不生不灭为实身。生灭为方便。则开身方便门显身真实义。二者集分身开本一迹多。既互相为分身。则知彼此皆是迹。彼此皆是迹必有统一之本。故本一而迹多。迹多故开身方便门。本一故显身真实也。三者命觅弘经之人。因此则有持品。乃至他方菩萨奉命弘经。如来便得止其宣持。显下方菩萨广开寿量久已证常也

问。何故但明此三

答。显身是常必具三义。一者体无生灭。二唯一法身。三本来是有。备此三门常义乃圆矣。此据理释之。又虽有三义束而成两。体无生灭唯一法身。则常义已。现但未知为始证常为久证常。故说寿量明久已成佛也

问。但明现塔证所说不虚。唯应如光宅所明。云何用此开于本迹

答。下偈云多宝如来及与我身。所集化佛当知此意者。夫圣人言近而意远不可齐事。而求之佛恐寻言失旨。故唱当知此意以惊悟之耳。若意唯存受持弘宣者。则已显之于言。岂曰此意难知。复何烦唱言当知此意也。又若现塔但为证前说者。何烦放光集佛开塔并坐。意在何耶。故知皆为开本迹耳

问。此乃是多宝本愿。开我塔必须集分身佛。亦非表本迹义也

答。若不詑多宝愿。何由得集分身佛明本迹义耶。当知此意显于兹矣。又多宝实有此愿所以然者。诸佛各有誓愿。如身子成佛愿于净土而说三乘。多宝本愿因此塔以开本迹。以惑者皆谓。居在塔者必是身已灭亡。故寄塔以表法身常住也

问。若尔一切佛皆得以塔涌开于本迹。何止多宝耶

答。实如所问。但多宝即以此事为愿故开本迹也。又所以明多宝愿者。以塔现故寄古佛以明法身常。以本愿故集化身以显本一。以事约而理周。盖是至人之善巧也。又示多宝因果愿行皆悉益物。明塔现谓果益物。举本愿谓因利缘。又涌塔赞叹谓。行益物称于本愿谓愿利缘。又多宝塔涌现则古佛降莚。以本愿故化身云集。时会奉睹则起奇特心。尊敬法华广植诸善。有斯大益故称本愿也

问。何以之证涌塔是密开本迹耶

答。初但寻法华文义已显。后见华严法界品四十一卷。善知识中有安住长者。得不灭度法门。见过去诸佛皆不灭度。开栴檀佛塔户即得三昧智。过去佛不灭。即法华开塔不灭宜为符契。论舍利有无义

问。首楞严经云本愿力故现法。尽三昧力故示碎身舍利。大品即释此经云。如来碎金刚身作末舍利。此二经明有舍利。新金光明云。假使水蛭虫口中生白齿。如来身舍利毕竟不可得。乃至鼠登兔角梯食月除修罗。如来身舍利毕竟不可得。此经无舍利。有无相违云何领会耶

答。有无之言既是佛说。理无违背。初明有者据佛迹身。后明无者就法身也。又前明有者示同凡夫二乘。故明此身从业报起故有舍利。后明无者不同凡夫二乘。明如来之身是幻化。身非实业报生无身骨也。又大经云。吾今此身即是法身。非是血肉之所成立。若不二而二故开二身。法身无舍利应身有舍利。二而不二。即此身名为法身。故无舍利也

问。大经金刚身品云。虽不常住非念念灭。此是何身。若是法身即应常住。若是应身应念念灭。云何而言虽不常住非念念灭耶

答。以此问二身义者难可会通。今所明者以四义通之。一者明如来身者即是中道。非念念灭故非无常。亦非常住故非是常。非常非无常即中道身也。又非常故不同虚空。下云常法无知犹如虚空。如来有知。是故非常。非念念灭不同有为。故如来身非为无为也。又同众生故非是常住。异众生故非念念灭。故如来之身不可思议也。又存不为有故非常住。亡不为无故非念念灭。故如来之身非有非无也

问。小乘明舍利是金刚。与大乘何异

答。小乘谓骨是金刚。肉非金刚以伤出血故。大乘明一切坚满故皆是金刚。无有能伤佛身肉者也

问。世间金刚以羊角碎之。舍利金刚可得尔耶

答。不也。唯有如来入金刚三昧。出世间道力能破此身耳。世间之物无能坏者

问。全身碎身何所表耶

答。此事适缘。但多宝全身欲表法身常恒。释迦碎质示应身灭度也

次论塔表义

问。多宝佛开本迹二身。塔何所表耶

答。就事中明依正二果。如前说也。言所表者塔表成人之万德。佛表万德所成人

问。涌出表何义耶

答。略明二义。一表能化隐显适缘。缘感则显缘谢则隐。如日喻品明山障故隐无障故显。此经云。时我及众僧俱出灵鹫山即缘感故出。是诸众生类过阿僧祇劫不闻三宝名。无感故隐。与大经不异。不应云彼经明常住此教无常也。二者所化众生佛性涅槃本自有之。如塔在地下裂地而出。涅槃本有。烦恼覆故不见。烦恼地裂则便显现。如生公之说也。论集化佛

问。何故放光通照十方。然后化佛乃集

答。不光照而忽集即是当时化作。而十方无有实佛便不得显迹多本一义也。又若不放光照即无因缘。故佛不得集。今会集佛必有因缘也

问。何不集余十方佛。而集释迦分身耶

答。集余佛者不得显释迦是应迹也。又欲显二种本迹。以多宝并坐显十方诸佛如来同共一法身。又集释迦分身故显一佛自有本迹

问。集分身佛为显释迦之与化佛皆是迹。为偏显释迦是迹耶

答。通具二义。别则正显释迦为迹。所以然者。自昔已来执二乘为实教。丈六为真身。上已明二乘非实教。今次显丈六非真身。净土中不必有此二执。故偏显释迦也

问。云何以化佛显释迦为迹耶

答。上已说之今当更解寻本迹义者必本妙而迹粗。而今乃以释迦之粗为本。净土之妙为迹者。则知释迦非复本矣。释迦既非复本则丈六非真身也。又一事之中得双显二义。以释迦指净土为化迹。则净土佛非实身。释迦之粗必非妙身。则知释迦亦为迹矣。是以二身皆悉是迹。然后始知法身妙极为化之本也。论变土义

问。何故不但一集佛一变土。而三集三变耶

答。就事言之一集一变则昧不觉土旷佛多。今令觉知佛多土旷。故三集三变也。又诸佛常用三事如三试等。又有所表者。以心垢土秽心净故土净。三根众生心垢应净故三变土也

问。是何等心垢耶

答。谓丈六为实身生灭为至极。此二乘曲见即是垢也

问。何故唯留此会移诸天人置于他方耶

答。此会之众有三因缘。一者久积净心应见净土。二积见佛因缘应见多佛。三应闻本迹皆得领悟。如分别功德品十二种利益。故留此会也。其余人天无三因缘故移之也

问。何故不即令在座不见净土。如华严入法界品广明净土。二乘不见耶

答。亦是显有因缘者故住。无因缘者故移之。若不移之则此义不显也。华严欲显二乘不能见故留之在会。若移之者或言二乘能见菩萨事也

问。今亦应留人天令在会不见

答。华严中二乘人初不见。后承佛力故见。今此人天都无见义。故移之欲显四净义。一化主净。二土净。三教净。四徒众净。不移人天者则众不净也

问。明土净既变土令净。何不变众令净耶。如净名会一切大众悉皆得见坐宝莲华

答。此众罪垢何由得然。维摩之会此是应悟者耳

问。寿量品云吾净土不毁。今何故三变而成净土耶

答。净土多门下明异质同处义。故净土不毁。秽土被烧。今明同质同处义。故三变而成净。同质者一净质。一处者无两质共处也

问。何故尔耶

答。今表众生心垢应变而成净故土变。又表佛身既非复实身。则正果变故依果亦变。以依果既变表正果将变也。下时众谓佛无常国土磨灭。故明常在灵鹫山净土不毁。明义不同故有变不变也。又有四句。一土净人净。如化佛将一菩萨来净土中也。二者土净人杂。如娑婆土净而会有五乘之众。三土杂人杂。四土杂人净。此已如身子章明也

问。将一菩萨及在树下居狮子座皆何所表耶

答。世界悉檀法应如是同来影向。座以安身树以覆体。遣使问讯故将一侍者。若有所表者法身不二。故侍者唯一

问。若尔下云地涌既有多众。应表法身是多不耶

答。下方明众多者显久已成佛。故所化众多也。树以立为义。今明开宝塔树立法身也。昔惧物起谤故不得显寿长远。今道缘既发故喜无畏。所以居树师子座也

问。此品多宝三过发言。有何益耶

答。初明塔涌。欲表非是孤坟有灵觉故发声也。次开塔竟复发声者。前虽发声犹未见形。恐前所发者非是佛声。故现形表口自发声。最后发声者。多宝不灭虽彰释迦不生未显。故携之并坐欲显释迦不生故复发声也。次论提婆达多品

有人疑此品都应非次第。或非佛说。今明不然。定是次第亦是佛说。晚见论云。为调达受记显如来无怨心。故当知是佛说也。次宝塔品后者密开本迹。有二种。一者就佛事而开本迹。即是宝塔现分身集也。二举例密开本迹。即此品是也。调达迹身恶而本非恶者。释迦迹示生灭本实不生灭也。又此经云开方便门示真实义。非但开一种方便门。通开一切方便门示一切真实义。从经初来至宝塔品明约善开方便门显真实义。今就恶明开方便门云真实义。一切三世十方佛菩萨不出善恶违顺二方便。如释迦等为善方便用。调达为恶方便用者。不言昔是方便。故方便门闭。今开是方便门。故方便门开恶既是方便。善即是真实也。如此善恶皆欲引众生归善。故若违若顺皆顺也。又大品云有威仪非威仪。非威仪即变常合道。摄大乘论中明菩萨作。具足十恶五逆

问。菩萨作十恶五逆为实作为变化作耶

答。具二作也。一者化杀。如金刚神杀童子。二者实杀。如杀五百婆罗门。所以须实杀者。摄大乘论云。菩萨更无余方便度之。唯应有杀可以度之。故行杀等事也。又束此二方便归非善非恶不可示也。而能善能恶即妙法华用也。又以三种方便。一者凡夫方便。二者二乘方便。三者大乘方便。调达为重恶谓凡夫方便。富楼那等现声闻为二乘方便。释迦为佛方便。上来已开二方便门。今次开凡夫方便门故说此品。又发三迹。初发多宝灭迹明不灭。次发释迦生迹明不生。后发调达恶迹明非恶。又难曰。言释迦昔无常今无常。亦应调达昔恶今犹恶也。若昔说调达恶今发迹故明非恶者。释迦亦然矣。又昔记调达当成辟支佛。今开调达久为大行。则昔方便示小而实是大者。当知释迦实常示现无常耳。又说此品者为欲成叹经劝人弘宣故来。上品已明往古多宝佛自来俱共说法华。明福深功重劝人弘宣。今释迦复引调达为证。明调达过去世为我说法华经。故今得成佛。是故法华功用难思议。应须受持。提婆达多此言天热。提婆言天达多名热。初生之时天人心热。以其将造逆罪故。斛饭王之子阿难之兄。从所说之人为名。故以目品也

问。昔明调达造三逆罪。其事云何

答。释论云。佛初成道度结发梵志千人。后还本国。诸弟子虽得道迹而苦行。来久容色燋悴不光显。世尊父王即敕国中豪贵子等应尽资之身并令出家。调达于时入道而无信心。但欲学通不欲求佛道。得通已后遂便失之。求徒众佛不许之。于是遂造逆罪。初则破僧。以犯戒人不得破僧。故知前未犯余罪而前破僧破。僧已后次推岩厌佛。金刚神以杵掷石。石破伤佛大指出血。故次出佛身血。华色比丘尼得罗汉果见其伤佛指而呵责之。调达以拳打比丘尼。尼眼出血死。故次杀罗汉。具三逆罗。次第如是也。此中释调达造逆次第。与律中明不异也。论本迹义释寿量信解等品

问曰。信解品云。长者居师子座眷属围绕。乃至脱珍御服着弊垢衣。此约何义明于本迹耶

答。有人言严饰上服譬法身。着弊垢衣喻隐本垂迹

评曰。今以四义推之非法身也。一者大士。入法身之境形不可以像测。心不可以智知。今明眷属宗待则形有方所。罗列宝物譬阐扬道教。既是言像之域知非法身。二者旧经师云。中止一城譬垂迹作佛不废家业化诸高行。若是法身斯言失矣。三者唤子不得远领方便品一乘化物不从。上既显迹今何犹领本。四者唤子不得近领譬喻求子不得。前既是门内长者今云何喻城外法身。以此详之义可知矣。复有人言长者处师子座喻寿量之本。着弊垢衣譬从本垂迹

评曰。虽有新通犹滞故难。旧明中止一城既是应迹作佛。今处师子座云何乃喻寿量本耶。请更研辨之。求子不得而家业不废。家业不废正是迹身化物。非本地导缘。又此譬忍土成圣。不可遥指他方。又今明。即世垂应复非前世作佛。进退往论竟是何身。今所明者凡有三身。一法身二舍那身。三释迦身。其父先来求子不得。譬法身觅大机不得也。中止一城家业不废。譬舍那身初成道时。二乘大机虽复未热。而菩萨道缘已成故初登正觉化诸高行。如文广说之。宗亲侍卫乃至罗列宝物者。皆指华严为诸菩萨说大法也。脱珍御服着垢弊衣者。隐舍那之本示释迦迹化于二乘也。此三身即是次第。前明法身。法身次垂舍那之迹化诸大行。舍那次示释迦之化引于二乘

问。何以知有三身

答。即以前推义可知也。又梵网云我今卢舍那方座莲华台谓舍那身。周匠千华上复现千释迦谓释迦身。必知有法身。此同信解品意也。又摄大乘论明三身。一法身二应身三化身。法身唯佛见。应身应菩萨。化身化二乘。与法华信解全同。又像法决疑经具明三身。上已引竟。亦同信解。又华严性起品譬如日出前照高山次及中下。如来出世前化菩萨。次化二乘。与信解相符。又大经日喻品明。日有三时冬日最短。喻二乘所见。春日处中譬大士所睹。夏日最长喻明唯佛睹佛其寿无量。亦有三身之义与前大同

问。未开近显远。云何已领三身

答。上三周佛已略开三身。三根声闻亦略领本迹。如释名中辨之。又法华之前已明本迹。如净名佛身无为无漏之说。大品去来无去来之文。但昔闻未悟。今因法华始知领解。故作此述。之如昔闻大品付财不悟。今因此教方复领解。又昔在华严座有类盲聋。今悟一乘方得净眼。故见舍那。又化菩萨名舍那。今成菩萨云何不见。又以理言之此等皆为权行。又是化人为欲调伏众生。显发密教恐实行之流闻后长远乖其本情。故豫领本迹二身。逆闻寿量故托领解密助阐扬。例如初品弥勒之疑文殊之决。明古佛说之于前释迦将敷之于后。逆杜疑谤之萌豫开一乘之旨。论寿量佛义

问。信解品明三身者。寿量品论何等佛耶

答。有人言是金刚心耳。犹未成佛但任持三昧故延之使长。为广度物也。故下文云。神通力如是于阿僧祇劫

评曰。经言久已成佛而言未成佛。公于我前违反我语。如来三诫恐时会惊疑。岂徒然哉。又昔尚明已登大觉。今言犹未成圣则昔胜今劣。岂可然

问。若非后圣则应凝然常住。下云复倍上数犹是无常。故知应未成也

难曰。若未常住则未度五百何故闻度五百而即信。明已成而未受。又难若度五百而未常。亦应未度五百即是常。若未度非常。则已度是常矣。又经言佛度五百。而言未度者。昔明佛度三百。亦应未度。若昔言广三百佛实度者。今亦应实度五百也。若顺经故遂度五百。则已免三相。何事非常。今所释者。寿量品亦具则三身。法华论云。王宫现生伽耶成佛名为化佛。久已成佛乃至复倍上数故名为报佛。如实知见三界之相。无有生死若退若出。明法身佛。但三身不同。若法华论明三身者。以佛性为法身。修行显佛性为报身。化众生义为化身。若摄大乘论所明。隐名如来藏。显名为法身。则此二皆名法身。就应身中自开为二。化菩萨名报身。化二乘名化身。或云化地上名报身。化地前名化身。地论法华论是菩提留支所出。摄大乘是真谛三藏所翻。此三部皆天亲之所述作。而明义有异者。或当译人不体其意。今欲融会者。众经及论或二身或三身或四身。今总束为四句。一合本合迹。如金光明但辨一本一迹也。故云佛真法身犹如虚空。应物现形如水中月。二开本开迹。如五凡夫论明有四佛。开本为二身。一法身二报身。法身即佛性。报身谓修因满显出佛性。开迹为二身。化菩萨名舍那。化二乘名释迦也。三开本合迹。如地论法华论所明。开本谓二身。谓佛性是法身。佛性显为报身。四开迹合本。如摄大乘论所明。合佛性及佛性显皆名法身。开迹为二。化菩萨名舍那。化二乘名释迦。此皆经论随义说之。悉不相违。众师不体其意故起诤论耳

问。常无常云何

答。亦四句。开本合迹即是开常合无常。合本开迹合常开无常。本迹俱开即常无常俱开。常有法报二身无常有应化两佛。本迹俱合即常无常俱合也

问。经说云何

答。华严梵网像法决疑大涅槃及法华信解品。此等诸文皆明法身常应化身无常。与摄大乘论同。法华寿量品可具二义。寿命无量劫久修业所得。此是报佛。即名常乐法身也。纯化菩萨名为舍那者。如化千世界微尘菩萨无有凡夫二乘。此可名舍那。无常身也。若化二乘及三乘杂众名释迦。化佛也。捡众经与诸论皆不相违也

问。三身有几名耶

答。经论列名不同。或法身舍那身释迦身。又名法身报身化身。又名法身应身化身。又名佛所见身菩萨所见身二乘凡夫所见身

问。此等名字出何文耶

答。初出梵网经。次出像法决疑金刚波若论。次出摄大乘论说。次出涅槃日喻品。三时短长之异如佛菩萨二乘所见不同。经说异名意犹一也

问。何故但明三身。不多不小耶

答。若就法华论明三身者。佛性隐显为二身。化他为化身。二身为自德。一身化他德。又约摄大乘论明三身义。员不得多小。法身为自德余二身化他德。化他中自有二。一者化菩萨身总名舍那身。二者化二乘身名释迦身。所化虽多不出大小也。又化净土缘为舍那。化秽土缘为释迦。化处虽多净秽摄尽。又纯化菩萨为舍那。杂化三乘为释迦。所化虽多不出斯二也。又华台世界为舍那。华叶国土为释迦。又本为舍那迹为释迦。能化虽多摄唯本迹。又酬因义名舍那。舍那名报佛。化物既名释迦。释迦化佛。又初成道为舍那。成道已后为释迦

问。何故尔耶

答。初成道时大缘已热堪受大化。故现舍那在前化之。小乘未热待后方化。又化时长为舍那化时短为释迦

问。云何尔耶

答。经师皆言华严是顿教。唯初成道说之故化时短也。后从鹿苑至双林皆是渐教。故渐教时长。今请难之。华严七处八会。初一会可言初成道说之。七会六处云何亦是初成道说耶。又第八会入法界品在祇洹说之。初成道时未有祇洹。亦无声闻。云何第八会在祇洹说之。又列五百声闻耶。今所明者。释迦化短舍那化长。可具五义。一者释迦化身住世八十。舍那报身寿命无量。二者释迦秽土劫火所烧。舍那净土三灾不毁。三者释迦但化杂缘。杂缘寿短。舍那纯化高行。高行寿长。四者释迦说教小。舍那说教多。五者释迦劫短。舍那劫长。如云忍土劫短弥勒劫长。此出华严文五事推之。则释迦化短舍那化长。以舍那化长故从初成道乃至释迦涅槃而舍那不灭。若尔岂但初成道说华严耶。此是不二。二开二身不同。又随二缘故见两佛为异也。像法决疑言。或见我涅槃或见我为报佛为百千释迦之所围绕。则知释迦涅槃时舍那犹存也

问。大经云。我初成道时已有菩萨曾问此义。当知初成道时即是释迦云何以长者喻舍那

答。二佛有一义有异义。一义者如华严名号说。或名释迦或名舍那。两佛异义者。如梵网本迹不同。又华严中二乘但见释迦不见舍那。又如像法决疑。明二佛为异也

问。既具有一异义。何故偏以长者喻舍那耶

答。已如前说。穷子所见着弊垢衣。正就隐本垂迹。故偏就二佛异义论之。若是一佛则失斯意也

问。若以长者喻舍那者。付财之时见长者豪贵。二乘之人应见舍那不耶

答。譬意不同不可一例。初就隐本显迹故分二佛之异。付财之时欲以大法密教二乘。不明本迹。不得为例

问。付财长者不喻舍那譬何等佛耶

答。还譬释迦。所以然者。本以菩萨所见名舍那。付财时二乘未悟。犹是释迦也

问。若是释迦与着弊垢衣长者何异

答。前譬释迦说小乘教。今譬释迦说大乘教是故异也

问。何初成道时喻舍那。今喻释迦耶

答。垂释迦迹有渐化之义。初说人天乘次说二乘后说大乘。若初成道具足说大法者名舍那。故初譬舍那后喻释迦也

问。前云化二乘为释迦。化菩萨名舍那。若尔释迦不应化菩萨。何得波若已上至法华皆明化菩萨耶

答。前云化二乘名释迦。化菩萨名舍那者。此一义耳。又杂化三乘为释迦。纯化菩萨名舍那。故无过也

问。唯是一长者何故三种喻耶。初明长者豪贵等此喻舍那。次明长者着弊垢衣喻释迦偏化二乘。后明长者付财喻说大乘法耶

答。此三皆有其义。初明化菩萨故喻舍那。次偏明化二乘故喻小乘佛。付财之时正明说大乘义故喻大乘中释迦也

问。大乘中释迦何故非舍那耶

答。纯化菩萨为舍那耳。大乘佛有三乘杂众。复是对小明大故犹是释迦也。又示唯是一长者随缘所见。如唯一佛。或见舍那或见。为释迦或见二佛异。或见犹是一佛或见是应身或见为法身。二乘之人昔并未悟今方解了耳。是故此文或作二佛异譬或作同譬也

问。前文明法身不说法。何故释论云法身亦说法耶

答。释论明。法身者望华台舍那丈六释迦为法身耳。若望究竟法身犹属迹身。何以知然。经云隐名如来藏。显名法身。唯佛能见十地不睹。释论所明犹化菩萨。则菩萨见之故知属应身

问。法身佛何故不说法耶

答。唯有二缘。一菩萨则报身化之。二声闻则应身化之。法身唯佛能见故不说法也。又法身名相斯绝岂有音声说法。说法之事皆是应身

问。法身既不化物何为法身用

答。法身为化物之本故有大用。又三身为二德。法身是自行德。余二是化物德。要具自德后能化物也

问。依像法决疑及摄大乘论。何故法身不名报耶

答。法身不生不灭本自有之如经言。隐名如来藏。显则名法身。法身岂修因所得耶。故知法身非报。今示行因得果果起酬因故名为报也

问。化身亦修因得。何故非报耶

答。通义亦然。但化身从报身起故非正酬因义。报身正酬因义故名报也。又化身既为化二乘。此身既劣非是胜报。故不名报身也

问。报佛定是常为无常耶

答。前已论之。今当更说。地论师云。报身是常。所以然者。法身即是本有佛性。报佛为修因所得。佛性显故名报身。即是始有。亦是性净方便净义。若据此明报身。报身是常者此不违法华论。地论金刚波若论等宜用之。若云舍那是报佛而言舍那常者。五义不可。一者像法决疑经云。或见我为报身为千万释迦之所围绕。则舍那为报身。既云为千万释迦围绕。岂是常身耶。二者菩萨戒经明。我今卢舍那方坐莲华台。周匝千华上复现千释迦。常无方所岂偏在华台。三者华严经盛明。舍那坐道场菩提树下成佛眷属围绕。云何是常身耶。四者法华经明。长者尊豪宗亲侍卫。然后脱珍御服着弊垢衣。示释迦形。云何长者实是常身。五摄大乘论化菩萨故示报身。化二乘故示化身。法身佛不化云何以化菩萨身为常身耶

问。云何通耶

答。有二种报佛。法华论明报佛是常。摄论及众经明报佛是无常。故不应偏用

问。余二身但是无常。亦得是常耶

答。义有通别。通而为论三身皆常。法身无始终不生灭故常。以有法身常化菩萨而无息时故应身亦常。化二乘亦无息时故化身亦常。但于此缘息彼缘不息故言灭而实不灭也。如华严云。譬如大火遍烧诸草。此处草尽故言火灭。彼处草不尽故言不灭也

问。报身何故一化身则多。如舍那唯一释迦则多耶

答。通则例也。而今舍那唯一释迦则多者。略明三义。一者据本迹分之。舍那为本故不二。释迦是迹故不一。如菩萨戒经说也。二者欲显根本一义示唯有一道。故云一切无畏人一道出生死。所体之道既一。体道之人亦一。故唯一化主一国土一教门一菩萨众。根本为论唯有四种一也。如法华云十方佛土中唯有一乘法。即是一化主一土一教一缘也。但为众生不堪受道故开四异。以不堪道故作多道说之。或大小乘道或三乘道或四道。谓三乘道福乐道。或五乘道。以五道既不一故化主亦不一。故有多释迦多国土多教门多徒众。为此义故舍那唯一释迦则多也。三者舍那是报佛。报则无二。所以然者。示因有差别果无差别。因有差别故有十信乃至等觉五十一位不同。示果无差别唯得舍那。故报佛不二也。又唯有一道行一道故唯得一。报佛不二也。化则从缘不定。故有多释迦

问。为横论三身为竖论三身耶

答。具二义。一者横论以法身为本。应彼二缘故有二身。二者竖论即是传。望从法身垂舍那之迹。次从舍那之本复起释迦之应。如梵网云我今卢舍那示现千释迦。亦如法华脱珍御服着弊垢衣也

问。经有种种说。或言虚空法身。或言实相法身。或言感应法身。或言法性生身。或言功德法身。有何等异耶

答。言其大网则弥纶太虚故言虚空法身。语其妙则无相无为。故云实相法身。辨其能应则无感不形。故云感应法身。说其生则本之法性。故云法性生身。明其体则众德所成。故云功德法身。约其义异故有众名不同。考而论之一法身也

问。从法性生故名法性生身者。释论云二乘人及法身菩萨亦是法性生身。与佛何异耶

答。佛照穷法性故名真法性生身。菩萨二乘随分受秤也

问。直就佛法性身中自得论真应不耶

答。得也。妙穷法性即是法身。若隐法性身菩萨所见。如前引释论法身佛者。此是法性身中应身也。次明本迹四句。遍通众经异说。一者开而不合。开本迹二身。法身无生灭。应身有生灭。法身寿无量。应身寿有量也。二者合而不开。昔说此身近成。今说此身久成。同指一身更无有二。又昔指久为近。今指近为久。更无有二也

问。云何是指近为久耶

答。涌出云。我于伽耶城尔乃化度之。岂非则近指伽耶以为久远。既指伽耶为久。亦指久为伽耶。生公正用此意云。极决彼长寿则伽耶是也。伽耶是者非复伽耶。伽耶既非彼长何独是乎。欲显不长不短长短斯亡。然后久近适化也。又大经迦叶频难。现见此身无常。如来还答此身是常。又云吾今此身即是法身。非血肉之所成立。净名云。佛身者即法身也。如此等经皆是合而不开。三者亦合亦开。明法身无生灭迹身有生灭。岂非开二身耶。即生者不生。不生者生。多宝释迦即是其事。岂非合耶。四者本迹是因缘义。不可一故不合。不可异故不开也

问。何故明四句耶

答。如来法身言辞寂灭。为欲出处众生故开本迹二身。所以有第一句。而众生闻说二。多依起二见。谓法身自无生灭。应身自是生灭。欲泯其二见故云。只生者不生。不生者何处别有二身耶。故有第二句也。或者闻二身不二便作一解。一则不得二。闻二便作二解。二则不得一。为破此碍心故明虽一而二。虽二而一。一不碍二。二不碍一。故有第三亦开亦合句也。迷情复谓舍定一定二。便取亦一亦二。今欲双斥两病。故明因缘本迹不可一异。由本有迹由迹有本。非本无以垂迹。非迹无以显本。故说第四非开非合不一不二义也

问。开此四句意何所在耶

答。欲令因四悟不四之身耳。次论近远开覆义

问。为是破近明远。为是开近显远。为是覆近开远。为是废近立远耶

答。具四义。一者破近明远。故文云一切世间天人阿修罗皆谓。释迦始成正觉。然我成佛甚大久远。此破近明寿远也。二开近显远。明开方便门显真实义。昔明近远是方便。今明远是实说。此二皆佛方便非众生横执也。三者覆近开远。如二鸟双游不相舍离。但昔覆远以开近。今则覆近开远也。四者废近立远。如废三立一也

问。四义之中初一是缘迷。后三明佛教。昔自说近云何言缘。谓佛近耶

答。以是义故文中明秘密神通之力。昔日说近而密为开远。言虽在近昔在于远。乃至今日言虽在远意为开不近不远无始无终。而惑者闻近遂守近不能悟远。乃至闻远不能悟不远不近。故名迷也。又虽闻非近非远不能悟近远双游。皆失佛旨也。又昔说近者此是因缘远近。义近远无碍。昔以远为近。今以近为远。以不远近为近远。近远为不近远。如来是无碍之人。故有无碍之身无碍之说。以众生乖道不能有无碍之悟。故皆失佛旨。又如来非近非远。昔能结为近用。乃至非远非近。今结为远用。昔结以为近用。故此近于佛。欲开非近非远而众生执近乃覆非近非远也。近义既尔远义亦然。若能悟如此近远义者。方识一化始终意也

问。开近显远开无常显常。开短显长何异

答。有人言开无常显常。但在涅槃余二通两教。今明三事互通。但开近显远明久已成佛。开无常显常者。此通久近。何以知之。证常有二种。一者久已证常。二今始证常。是故通也。开短显长此复通上二义也

次论三世义。旧云寿量品正明三世益物。既是三世益物。故皆是无常

评曰。今品但明三世益物。未究此章之美。下文亦无多人得道。今依法华论具明三身。可有三义。一者法身无始终即是无三世义。二者修因得果以为报佛。此有始无终义。以修因满初证法身故名为始。证法身已后无复生灭。所以无终。三化身有始有终。就化身中自开二身。化菩萨名舍那。如化千世界麻数菩萨。无凡夫二乘等众是也。次化二乘名释迦。如生王宫伽耶成佛是也。亦如信解品菩萨所见二乘所睹两身不同也

问。法身无始终化身有始终。此义易明。云何报身有始无终。无终云何有始耶

答。此经云。寿命无量劫久修业所得。则知初发菩提心。中修菩萨行。后得法身。故知有始。既证法身无复生灭。故无有终。此须解大经纯陀难及佛举本有今无偈释之。方见此义意耳。若就此中释之于文义为繁

问。此中有三世益物义不耶

答。从初证法身已来。垂迹化物竟王宫之前名过去世。托生王宫乃至双林灭度谓现在世。自尔已后为未来世。此皆是迹身有三世。本身无三世义由来。但明有三世唯明成迹身。三身之中但得其一

问。明报身何故言复倍上数耶

答。初证法身已不可知。证法身已复倍上数者此明不可知。不可知如华严不可说不可说。此显无复有终义耳

问。本迹义中云。逸多不见其始。补处不测其终。此明无始终。今何言有始无终耶

答。前就法身义释之。以因位之人不知其始终。故是无始终。所以是法身常义。今据报身故有始无终。又初证法身二义。一初证义故有始。二者同法身义者故无始无终也。又此是以报身显法身。初得报身因位人尚不见其始终。况法身而可知耶

问。作此释者应是地论及旧义耳

答。法华论有此文不应违也。但今读论与旧意不同。旧义但如前释之。今所明者义起有由。正为二乘人谓释迦王宫始生双林终灭。如大经云。是名二乘邪曲之见。今为破此病故云。久已成佛非始伽耶。复倍上数非终双树。为破始终故言无始终耳。然如来岂是始终无始终等四句可取耶

问。等是破始终明无始终。何故无终则长而言复倍。无始则短但云补处不知

答。斯言亦有深旨。二义之中正取无终。所以然者证常有二。一者久证二者始证。此二但得明常。唯无终义是常。有终义非常。正取无终显常。斥二乘无常。故言复倍。所以无终则长无始则短也。若法身无始无终此义无长短也。但自摄岭相传有二河之说。一者菩萨在佛性河中行。二者佛在佛河中行。菩萨在佛性河中行者。此欲显三世无三世义。所以然者。菩萨犹是无常未免三世之法。故就三世中修行。欲显中道佛性非三世法。是故菩萨三世欲显无三世义也。如来已离三世法。今作三世者此是无三世。为众生故作三世方便。故佛河中明无三世义也。今此中明三世益物者。皆是佛河中行无三世三世益物。过去则不灭而灭。现在不生而生。未来不至而至。既不灭而灭。虽灭不灭。不生而生虽生不起。如此三世宛然而无起动。无三世三世即是三世无三世。然无三世三世岂是三世。三世无三世岂是无三世。故非三世非无三世而三世无三世。虽三世无三世而非三世无三世。所以如来之身不可思议绝凡夫二乘境界也。次挋论三世无碍义。三不一一不三。不三不一得为三一。故华严经云。现在为过去过去为现在。过去名现在过去。现在名过去现在。未来名现在未来。故三世皆是因缘。以过去是现在过去过去得为现在。以现在是过去现在现在得为过去。未来亦尔。又三世得为一世一世得为三世。此是一三名为三一。三一得为不三一。如现在现在为未来。未来为现在。又云过去劫摄现在劫。现在劫摄未来劫。长劫摄短劫。短劫摄长劫。有佛劫摄无佛劫。无佛劫摄有佛劫。乃至一劫摄一切劫。一切劫摄一劫。以有因缘无碍故得如此也。若有定性何犹能尔。即此经说灭为不灭不灭为灭。不生为生生为不生。故多宝灭而不灭。并释迦生而不生。此皆三世自在无碍之义也

问。一世云何得是三世。三世云何得是一世。三世时节相碍云何得尔耶

答。华严云。无量劫一念一念无量劫。无来无积聚而现诸劫事。以法无定性故。菩萨得诸法实相所以能如此也

问。此犹未明请示其相

答。无量劫亦是正道。一念亦是正道。正道既不异。无量劫一念岂异哉。复何失一念无量劫。亦非无量劫聚来。一念亦尔。无量劫一念事恒不失也。肇云如动而静似去来相。可以神会不可以事求也

次论三根义

问。何故明三根义耶

答。能化之佛有三世益物。所化众生有于三根。故文云其人多诸子息。若十二十乃至百数

问。此三根与譬喻品三根何异

答。彼明三乘为三根。此中直取利钝判三根。何以知然。文云诸子之中有失心者则是钝根。不失心者即是利根

问。约何物论利钝耶

答。就三世分者。若过去久习无所得观。观强而烦恼弱者。于过去值释迦得了悟名为上根。二者于过去习无所得观。观弱而烦恼小强。故值恶知识流浪五趣。乃至渐习善根。今日释迦出世从初生至闻说法华皆得领悟名为中根也。若过去习善弱而烦恼强。亦流浪五趣。然后稍习善根感释迦出世。从初生乃至法华历闻诸教不悟。至涅槃唱灭方得悟解。如此之人名为下根也。然譬喻但明后之二人。就前法说中明过去久已成佛。导利众生如千世界涌出菩萨等。皆是释迦过去化得之名上根人也

问。何故从初生至法华悟为中根。至涅槃解复为下根人耶

答。初成道时开一为三。至法华之前求子犹未得。从法华始会三归一觅子始得。故一化之终尽在法华。故有无量世界尘数人皆得悟道。所以至此时结束为一根也。于法华中复未得了悟。如来更复唱灭至涅槃方得领解。故名为下根人义也

问。三世益物化三根人不耶

答。过去益物上根人。现在益物为中下根人。三根众生于二世皆领悟也。所以文中正明二世益物。不正明未来益物者。为化三根人尽也。若未来益物者更余缘耳

次论净土义

问。经云余众生见烧尽吾净土不毁。是何净土耶

答。罗什云是异质同处义。净秽二质同在一处。谓秽在净处净在秽处。故云同在一处

问。何由得尔耶

答。净秽粗妙不同故不相碍。如首真天子身不碍于地。又如无间地狱虽百千共处亦不为妨。又如提胡不碍粗器。况净秽二质而相妨耶。故烧秽不烧净。如欲界火不能烧净居天身。况净土耶

问。既有净土何故无有净火能烧耶

答。秽土有三灾净土无三灾也

问。秽土为三灾所烧可是无常。净土既无三灾云何得坏耶

答。第四禅勉三灾而有始起终灭。故无常。复有念念无常。净土亦具斯二也

问。秽土有劫数净土亦然。何故不同有三灾耶

答。劫直是时节。名三灾。必为过患故秽土有。净土无。如五浊例也。生法师释净土不毁云。夫佛之不在者良以众生秽恶故也。以秽故不在无秽必在。无秽故寄七宝以明之者。明无土砂之秽耳。虽有宝土之净比于无形亦何异秽质耶。以理论之乃是无土义。既寄土言无故云净土。无土之净岂非法身所托。至于秽土被烧者自众生罪报。亦何伤于无不净乎。是以众生见烧。净土不毁也

评曰。佛或开三身。或名为本迹二身。以身例土亦有三土及与二土。法身栖中道第一义土。如璎珞所辨。又如仁王云三贤十圣住果报。唯佛一人居净土。又摄大乘论明。真如即是佛所住土也。晚见法华论亦明真如常住为土也。二舍那报身化诸菩萨处于净土。故有四净。化主净国土净徒众净教门净。此四皆由菩萨心器净故有此四净。故舍那化菩萨也。三者释迦化二乘即是秽土。谓二乘人天心器不净。故感四种不净也。若合三身为本迹二身者。法身托本土余二托迹土也。若然者什公以土沙为秽。宝玉为净。明异质同处者此是迹身净土耳。生公着七珍论此是法身无净土论。今请评之。若言法身不托土沙之秽。复不在宝玉之净。故云无土者如前所判也。若取法身栖形实相中道之法。亦无此土者是义不然。详生公意但是无宝玉之土也。非无中道之土也。若尔生公得法身土则失迹土。什公得于迹土失于本土。若二师各明一义者无所失。以今文具明三身。则具明三土。以昔未开三身今始开之。三土亦然也

问。经云一质异见。是何物一质耶。如人见水如鬼见火。此为是水质而见火。火质而见水。为非水非火而见水火耶

答。净名华严初已广明此义难解。今略决之。但一质多种。今具详之。若以一实相为一质。以失实相故有六道异见。如大经云。是一味药随其流处有六种差别。则其事也。如人见水则有三尘。知见于火但有色触。皆是倒心所感。故成水火二见也。如人见恒河为水。鬼见为火。净秽亦尔。皆是众生二业不同故有二见。实无如此净秽也

问。此得是一中道土质净秽二缘故见二不耶

答。是矣。亦名为土亦名实相也。二者就迹中论一质二见者。身子见释迦土秽。梵王见释迦土净。身子见为人土。梵王见为天土。而释迦净土非如此人天土。故释迦土如宝庄严土。而人天缘自见人天二土。故名一质二见也

问。身子自见秽。梵王自见净。何开一质二见

答。经说身子自云我见释迦土秽。梵王云我见释迦土净。佛复云我此土净而汝不见。三种皆云释迦土。故知二缘见释迦土是天人土。而释迦土非天人土也。三者云一质二见者。于一净质见秽。于秽质见净。故云一质二见也

问。前明一质二见可然。后于净质见秽。秽被烧净烧不耶

答。以恶业故于净见秽。而净实非秽。恶业故见不净者而烧。而净实不烧也

问。净质坏者秽亦坏不耶

答。秽随坏也。何以知然。净质属净业所起。于净寄见秽耳。以净坏故则秽缘无所见。如鬼本于恒河水见火。恒河水竭鬼则不见火也

问。于秽质见净复云何耶

答。例此可知也

问。像法决疑经云。或见此土为土沙。或见此土为七宝。或见纯黄金等。此土定是何物质耶

答。此是随业所见。可得是异质同处。此明报土也。又得是明应土义。根缘应见秽。以得悟示之以秽。乃至净等亦尔。故不相碍也

次论净秽土教门义。凡有四句。一者前说一后说三。如舍那前为菩萨说一乘竟。后隐舍那之本垂释迦之迹说于三乘。如长者脱珍御服着弊垢衣也。二者前说三乘后明一乘。即是释迦前说三后明一。明一此即是隐释迦之教显舍那之教。息释迦之迹显舍那之本。此二句要相成。初明以本垂迹。次明以迹显本。初脱珍御服着垢弊衣。次脱垢弊衣着珍御服也。三者始终常说一乘。如释论云七宝世界纯诸菩萨。乃至不闻二乘名字。四者但说二乘不说大乘。如释论云黄金世界纯罗汉白银土皆求缘觉也

问。经文云。世尊法久后要当说真实纯罗汉皆辟支佛。此中云何得说一乘

答。不必一期出世要前说三后说一乘。但诸佛久后必说真实。以无有毕竟住二乘永不作佛故也。复有四句。一者但说一乘不说三乘。二但说三乘不说一乘。三者亦说三亦说一。即释迦教。初三后一是也。四不说三不说一。如无言世界不说三一也。又有四句。一者土净而乘一。如七宝世界但化菩萨。二土秽乘三。如五浊刹。三土净乘三。如身子成佛及中下根人净土成佛有三乘教。四土秽乘一。未见别文。阿输阇国七岁已上皆学大乘亦其事也。次明四句。一者为三缘说三乘。二为一缘说一乘。此事易明。三为三缘说一。可具二义。一者本是三乘缘会归一乘。二者命三乘缘说于大法。四者为一乘缘说三乘。令一乘缘识三。是权知一为实。如胜鬘。七岁为学大乘者说三乘。二者为一乘缘说三。令传化余三乘缘也。缘悟复有四句。闻一悟一。闻三悟三。闻三悟一。闻一悟三。前已说之也

法华玄论卷第九法华玄论卷第十

        胡吉藏撰

    论分别功德品生数义

问曰。经言八生乃至一生。据何义此说

答。注经云。体寿量之深玄。神凝绝崖之境。岂感生数差别不同。由强心不一发机处异。故此品位不同以示学人耳。色想既虚灭定可修。入解心开然后乃会。故言八生也。四生者四等意发因此而悟故言四生。三生者居宗化物必资三达故云三生。二生者空有两冥法门不二故曰二生。一生者微妙之根尽乎一极故曰一生也

评曰。寿量虽绝形言悟者必有明珠。既许十地阶渐。何妨以生升降。经既诚言不应曲释。窃谓不尔后当具陈。光宅云此中约惑品论之。以无明住地惑分九品。能为九生作因。从七地至金刚为五位。一七地。二八地。三九地。四十地。五金刚。于前四位所治各开为二品。金刚为一品。合成九品。一品为一生则是九生。若居六地之前望金刚位具余九生。今住六地闻经得入七地以断其一。但余八品。故云余八生当得菩提。亦应次此至七六五生。但今对上八数而取其半。故云四生。如是次第除损称一生。三二一皆遂四天下数而除之。故云四生乃至一生。故下偈颂中复有四三二。如是四天下微尘数菩萨随数生成佛即此义也。十地中忍余金刚是一生当得。则四生者是八地终入九地。准向品可知

评曰。今请详断惑之法。何故七八九十此之四地各断二品惑。金刚独断一品惑耶。寻经论明地断惑。未见此法亦非所用也。印师释。十二位中初三种是从初地通至七地。旋陀罗尼是八地。转不退轮为九地。转清净法轮为十地。又其八生者从初地至六地。其四生者是七地终心。三生是八地。二生为九地。一生为十地。亦约惑以明生数。谓四住地惑名为四生。习气为第五生。三无知即三品为三生。都是八分为八生。故对其次第位如向叙也

评曰。印师释则是二周明十地得益义。从初三位至清净法轮此一周明十地得益也。从八生至一生复一周明十地得益。但前据所得后约所离。故有两周而意无异。今谓于文为繁。所以然者。十地得益既无异。但列一便足。何繁再陈耶。譬如已说小乘得法眼净为一位。后说远尘离垢复为一位者。义则繁矣。有人言。初发心即是外凡。十信菩萨铁轮之位此从外凡闻经入十信。次从十信闻经进入十住。十住即是无生法忍。故云入理三昧名为住。生功德名为地。次十住闻经进入十行。十行闻十方佛说一切教能持。即是闻持陀罗尼。十行闻经进至十回向。乐说之辨。回向者能回事向道。次从十回向进入初地。入初地故能无碍。以无碍行故百法明门旋转名旋陀罗尼。次不退是二地。清净为一地。八生为四地。此中言生者了法实相无生。故能发生。此即是正观开发故名生耳。非是身数得佛近远故名生也

问。既言正观开发名生。云何有生数耶。此望佛地正观犹有八过。开发生故云八生也。四生者从四地起至八地。三生者九地。二生者十地。一生者等觉地。此中得悟不定。故从四地至八地不必一一次第也

评曰。此释似次第。但未详此意。何故初三地不言生。从四地去而言生耶。若从真观开发为生者。则始于初地终竟法云皆应尔也。又经论幸有生数之说文。何不依耶。今捡经论有二种生。净名经云一生得菩提。释论明三生菩提。此据应身成佛生数多少之义。如弥勒亦是三生。亦是一生。三生者即是人间。次生天上。后下生作佛。一生者据最后生。或云取生天为一生。下生作佛乃示佛身耳。次云生者仁王经云。三十生功德地地三生。初见此说谓。是疑经不足为证。后见地论云。一一地皆有入住满三分。又见摄大乘论亦同地论说也。又云一地三僧祇劫。入分一僧祇劫。住满亦尔。以此推之则地地中有三生也。但前据应身后说实行。今用此二文以通上说者。若就应身成佛而言八生者。即八过受生。乃至一生而得菩提。如弥勒一生得佛也。次据实行通者。十地既有三十生。今言八生得佛者。则二十二生已满。唯余八生。此人已是八地入分。乃至一生者此是十地住分。余有满分一生在耳。故仁王解。十地菩萨云二十九生永已度也

问。至十地满则犹是十地。云何言便得佛

答。十地满坐道场故得成佛也

问。据后义云何断惑耶

答。摄大乘论云。地地中上中下三品惑。即以入住满三分治之。故名断也

问。摄大乘论既言。一地经三僧祇劫行行。云何一闻经从八生即至四生耶

答。彼论明地地三僧祇劫。此据其极久者耳。复有超生义则不定。如释迦之超弥勒等也。又此经但明八生得佛乃至四生得佛耳。不云何从八生经得至四生也

问。请示其相云何

答。一僧祇劫修行方得入分者。今闻经力故或可减一僧祇劫。其义不定可以意知也

问。就生义通何得从八生乃至四生耶

答。如本是八生人应得菩提。今闻经力故超四生便得佛。如释迦之超弥勒义。例可知也

问。弥勒一生得佛。既是十地位者。八生得佛复是何位人耶

答。亦是十地。但十地去佛犹远。其中劫数犹长。可得有八生。如摄大乘论说。但闻经力故则超于劫数速至佛耳。晚见法华论云。八生一生得菩提者此说初地。为菩提者此八生得入初地。乃至一生得入初地。初地离分段故云菩提。非佛菩提也

论得道多少义

问自鹿园已上双树已还未有得道。如法华之会何故尔耶请为宣释

答。略就二义明之。一者此经明三引义。一化始终唯有三引。至于法华三引究竟。一者鹿园已后法华之前。引九十六种外道及余一切在家众生。皆入五乘之教谓引邪归正。二者引五乘之异同归一乘。即是法华初段。三者引一乘之因入如来法身果。谓第二段。此三引摄一切教。以是义故豫是应悟之徒皆于此经得道也

问。此之三引引何等人耶

答。皆是宿世曾经禀教。但释迦见其道缘应热。为之出世。所以初之一引邪归正。乃至最后引因得果。故有八生乃至证佛者也

问。三引为一人耶三人耶

答。具有二义。言一人者宿世曾经禀教。但失父流浪生死。或在家而爱五欲。或堕外道而起诸见。为拔爱见故引邪归五乘。二者虽于生死中不起爱见。而于五乘复起爱见。为拔五乘中爱见故说乘因。此遂得信悟发菩提心名为因位也。信心已成次为说果德。有无方大用令其历位修因求此果德。是故第三引因归果也。此人于三引中破三种烦恼。故初引破生死中烦恼。第二破涅槃中烦恼。又初引破邪法中烦恼。次引破正法中烦恼。又初凡夫烦恼。次破二乘烦恼。又初引破有见。次破空见。如是等皆是破二边烦恼。然后得中道正信。发菩提心。第三引广说如来寂然法身无方妙用。破其中道微细烦恼。今从十信入十住。从十住入十行。从十行入十回向。从十回向入十地。乃至八生一生得佛。皆是破中道烦恼除一乘之惑也。此皆是约三乘人始终。故开此三引。次引菩萨者。法华之前已发心求佛。闻第二会三归一无复二乘。则求佛之心坚固。所以云菩萨闻是法疑网皆已除。闻第三引历位登升取无上道也。此约始行菩萨有此三也。次明于法华之前已得悟无生者。受记作佛如前云。有佛子心净。乃至我记如是人来世得作佛。闻法华二引更复进行。故有得闻持乐说乃至八生一生。此略举三人以示大要。不可曲尽也。以此经具明三引故得道多也。二者诸佛化物唯有二门。一形二教。各二。一者方便二者真实。昔未开二方便显二真实。故得道少。今开两权显于两实。故得道者皆在法华

问曰。得道要是见空。云何闻说寿量而得道耶

答。以此责执。无常佛者辞理俱屈。明佛犹是无常。云何见无常而得道耶。又无常犹未了义。云何闻未了义而得已了之解耶。又是无常尚不能令凡夫欣慕二乘改执。岂能令菩萨速证菩提。又佛若是无常者。已信一乘则退起三执。复何犹进得菩提。是故不应得道者。多今所明者此经称为妙法莲华。妙法者是即法身。未曾常与无常。言穷虑绝。且为众生故长短适缘。虽示长短而不动法身。虽不动法身而长短化物。是以经云。善哉世尊。不动真际为诸法立处。如此本迹无有障碍。不可思议。但果地有本迹二身。因中名权实二慧。如来既说两身。菩萨便悟二慧。是以时会皆得道也

问。云何得无生乃至发菩提心耶

答。文已明之。今示一势。既说。寂灭之身故闻者不复生心动念。故名无生忍。本虽垂迹实无所垂。虽无所垂而无所不垂。时会即同纠。虽闻而无所闻。虽无所闻而无所不闻。故名闻持陀罗尼。昔日示短今日现长皆是适缘。故名乐说。短长自在故名无碍。为物陈之称为辩才。时会得于此悟名乐说无碍辩才。昔指长为短今指短为长。即以长短为非长短。非长短为长短。纵任循环自在无碍。菩萨随分得悟名旋陀罗尼。如此之身纵任自在不可破坏。菩萨随分得解名不退轮也。此身出一切凡夫二乘菩萨之上毕竟清净。菩萨随分悟解名清净轮。为如此身发心求佛名菩提心也

次随喜义

问。随喜有几种耶

答。随喜有二种。一通随喜谓若见若闻若觉若知他所作福。皆随而欢喜谓通随喜。二者别随喜者。且据闻法华经随而欢喜。故名别随喜。论大小随喜

问。大小乘随喜有何异

答。随喜正是菩萨法门。故菩萨五悔中有随喜义。但小乘随分有之耳。又小乘明喜义局唯随喜三世佛及弟子善根耳。无有随喜十方三世佛也。大乘明随喜三世十方佛及弟子善根故广也。又小乘但有随喜迹身功德。不知法身常恒。故无随喜法身功德也。又小乘随喜功德不回向萨婆若。大乘用随喜功德趣一切智也。又小乘随喜是有漏心。非是理中观行。大乘随喜通漏无漏。始行人随喜是有漏。深行随喜即是波若正观。无得无依。故是无漏。又小乘随喜生身菩萨功德。无有随喜法身功德。以小乘法中不说菩萨得法身。故论自他随喜

问。随喜是自行。化他门

答。正是化他门。所以然者。菩萨本为教化众生令作福德。而众生能作者菩萨欢喜。故是化他门。若自欲除嫉妒烦恼求福德故起随喜。是自行门也

论二经随喜

问。法华明随喜与大品明随喜何异

答。大品正说无得随喜。随喜即是波若。故论主云。佛欲令须菩提就随喜门说波若。故明随喜

问。云何就随喜说波若耶

答。知能随喜之心。及所随喜之福无得无依。不能不所。非二非不二。如此欢喜心即是波若。又以波若心随喜故随喜即是波若

问。前境福德为所。菩萨之心为能。有此能所可名随喜。今云不能不所云何名随喜

答。论主云此中应用波若及伛和。以波若故知能所未曾能所。以伛和故虽未曾能所而能所宛然。能所不动无能所。无能所不动能所而不失能所。无能所如镜中像非像非不像。欲言其像像非真有。欲言非像事像既形。非二非不二亦尔。以波若故非二。方便力故非不二。故言非二非不二也

问。法华明随喜云何耶

答。波若但取无所得随喜。法华通明得无得随喜。何以知之。直明一因一果能信受不逆。即是随喜。不开得无得二也

问。大品何故开得无得。而法华不开耶

答。波若为破有得住着。故明无得随喜。有所得不动不出不能至佛。故非波若也。法华合取者。此叙诸佛出世大意。说一切教皆为开一正道。故低头举手之善皆入一乘也。又五乘人谓四乘善根不作佛。佛乘善根方作佛。为破此病故明一切善皆作佛也

问。若一切善法作佛者。一切善皆能动出耶

答。一切善亦能动出。所以然者。由有所得善相资故然后生无所得善。有所得善是无所得远缘。以此言之亦有动出之义也

问。若尔与大品相违

答。波若明不动不出者。但取近缘不取远缘。何以知之。动为顺忍出为无生忍。有所得非此二忍耳。亦得是二忍之前远缘也

问。二经得相成不

答。正相成也。大品虽明无所得善。要须藉有得为远缘。法华虽明得无得皆入一乘。若欲出三界至佛道。要须无得也。又大品虽用无所得。要须识三乘是权一乘为实。故求佛之心乃得坚固。法华虽知一乘为实三乘为权。要须破有所得心。学无所得观。方能动出以成佛道也

问。所随喜福能随喜心云何同异

答。凡有四句。一所随喜福劣。能随喜心胜。如二乘有所得人作福。菩萨无所得心随喜也。二所随喜福胜。能随喜心劣。如诸佛菩萨所作福有得人随喜之。三者俱胜。同是无得。四者俱劣。同是有得。若随喜法华者则法华唯胜不劣。能随喜通胜劣。随人位行深浅而随喜也

论同异

问。随喜与四等喜．七觉中喜．五受喜．四禅喜何异

答。四等中喜谓庆前人脱苦得乐。随喜门通随一切圣凡所作功德而喜。此义不同。但四等要是定心。今通定散。又四等中喜但据脱苦果故喜。今通随喜因果也。七觉中喜是无漏随喜门。通漏无漏禅杖中喜是定心。但是喜受。今通也。五受中喜是果报。今是因门。彼是自悦今是庆他。彼是无记今是善法也

问。前人自作福今随喜之。有何益耶

答。释论云。如人卖香有人买香。复有人在边亦得闻香。随喜亦尔。不动身口亦得福也

论惑障

问。随喜破何等惑

答。直言随喜正破嫉妒。若法华明随喜亦破嫉妒。又破不信一乘寿量义也。波若中随喜即是波若。此破有所得心也

六千功德义

有人言一切善法不出十善。始自不杀及不邪见。持一不杀戒以不盗等九事庄严之。则一一善皆具十善。十善便成百善。此百善有自行化他赞叹随喜。故成四百。将此四百配五种法师。五种法师各有四百。合成二千善。此二千善各有上中下三品。便成六千。但三根用强故有千二百。三根用弱故有八百也

评曰。此释意具五种法师乃具六千耳。一一法师无六千也。而经云。若读诵乃至书写者。不必要具五师方有六千。能读能解如说修行亦得六千。但此义难明未可专释也。注经云。始乎十善一善具十善即成百善。复约自行化他叹人美法即成四百。各有三品成千二百。眼等三根助道用弱。但得中下二品故唯八百。意等三根于通化用强。具于三品。故得千二百也

评曰。注意不必具五法师。则勉前妨也。有人言。例如百福庄严。百福者就十善之中有行十止十。合成二十。各有五品如大经云。下．中．上．上中．上上。故成百善名为百福。今亦尔。十善为十。约自行化他叹人美法故成四十。约五法师故成二百。行善二百止善亦二百。故成四百。止行各有五品。故成二千。约三业明之。一业二千故成六千。既有六根应一根各一千便成六千。但用有强弱故有千二百及八百耳。有人言。如上法师品中三事。慈悲心为室。柔和忍辱为衣。诸法空为座。此三事各有二千。故成六千。如以慈悲心行十善。一善还以十善庄严。故成百善。自行化他等四故成四百。约五种法师便成二千。慈悲心既尔。忍辱与空亦然。故成六千。有人言。依仁王经明十信菩萨。一一信具十成百。自行化他等四有四百。约五法师成二千。据上慈悲等三事为六千也

问。何故不六根功德等耶

答。如前云。三根用强三根用弱。故多少不同。三根用强者意根为五法师之本故强。舌亦具五法师。由舌故能读能说。又由他舌故能授之令得受持书写。故备五法师矣

问。眼耳云何强弱

答。生盲之人不得书读二事。而能诵说受持乃至得道。生聋之人不可示语都无五种法师。故耳强眼弱也

问。身等三根有何功德而得八百

答。互相资持故余根得用即是功德

问。何位行菩萨得六千功德耶

答。下云未得无漏法性身。而有此功德用。当知是八地以下人也。有人言。十信菩萨有此用也。法华论云是地前人也

问。云何名六根净耶

答。如文所明。有此胜用故名为净。又此经明权实二智真应两身。皆是无碍之法。菩萨悟无碍之法。故今得无碍。故名六根净也

问。云何权实真应无碍

答。如前说。长为短用。短为长用。长短为非长短用。非长短为长短用。此是如来究竟自在无碍之身。即有究竟自在无方之大用。始行之人得分此悟。故六根自在也

问。诸部皆云。香到鼻方知。云何此经言遥闻香耶

答。有人言。道理则到根方知。今假经力则遥闻也

问。若道理色可见声可闻。今假经力则应闻色见声耶。若色不可闻声不可见者。到者不可遥闻遥者不可到知也

答。明中色定可见。闇中色不可见者。何故人眼昼则见夜不见。穴鸟夜见而昼不见乎。若言眼有光故夜能见者。昼何不见耶。又如弱水不升毛而升铁。金刚破余物而水银所坏。谁定强弱耶。故知诸法无有定性随意而转。到不到亦然也。又今约事释者。菩萨分得二智。以实智故知六根六尘空无所有。如华严中明眼入三昧耳。出正受观眼无生。无自性说空寂灭无所有。以权智故有六根之用。约权智能知香义。故说鼻遥闻香也。非鼻根能遥闻。余亦例然也

论观音与妙音菩萨同异

问。观音妙音弘经何异

答。有同有异。同者并以神通应感弘道利人也。又同明菩萨位行门。以菩萨为佛事也。又同就人门说法华也。同是他方大士。来影向释迦共利物弘道也。所言异者略明十一义。一者名题不同。妙音但有人名。观音人法两举也。妙音从能受名。观音能所合目。观是能观之智。世音为所观之境也。又妙音以德益物。观音用名为佛事。妙音品不释妙音之名。观音品辨观音之号也。二者所对人异。说妙音对华德文殊。说观音对无尽意持地也。三者来义有异。妙音东土而来。观音西方而至。妙音被召而方至臻。观音不召而来。妙音有来有去。观音不明来去。妙音则后集。观音则前来也。四者语默异。妙音则语谓圣说法。观音默谓圣默然。五者动静异。妙音现神通。谓不动动方便。观音不现神通。动不动善巧。六者因果异。妙音品明其往因说现所得果。观音但明现德不说往因。七者略广异。妙音现身说法则广。故有六道之身。观音则略。故无地狱饿鬼之身也。八者有无异。说妙音无挌量。说观音则有挌量。说妙音无供养。说观音则有供养。九者利益异。说妙音则利益多。故他方此土得益。说观音但利益此土。说妙音利益则深。故有得法华三昧及无生忍。说观音利益则浅。但云发菩提心。十者妙音不明绍尊。观音叙其补处。十一者不明妙音已成正觉。观音则是往古如来

论观音普门义。就观音略有二十条义。一者人法一双。二者本迹一双。三者三轮一双。四者名德一双。五者内外一双。六者智慧功德一双。七者智断一双。八者显密一双。九者慈悲一双。十者二身一双。十一者权实一双。十二者三业一双。十三明三德。十四者浅深。十五明二德。十六神通示现。十七力无畏。十八四等四摄。十九解行。二十悲慧一双。所言人法观音则弘道利益之人。普门谓所弘利物之法。非法无以成人。非人无以秉法。人法实无前后。但道不孤运。弘之由人故前明人后辨法也。又此下诸品以菩萨为佛事故先显人也

问。此品何故人法双题

答。为下无尽意之二问。先问人次问法。是故先题人次题法也。就此人法因缘无碍。指人为法指法为人。说此人法为开正道。不人不法即是妙法莲华也。二者言本迹者。观音即是法身。以居法身之地观物根缘也。普门谓应身。法身地照缘故垂应救拔。如华严云。金翅鸟王上升虚空。以清净眼观大海龙应命尽者。即以两翅搏水令两辟。而撮取之。菩萨以法身智眼观法界虚空。见众生应得度者。以实慧方便二翅搏生死海。而度脱之。如云非本以无垂迹。非迹无以显本。本迹虽殊不思议一。因此本迹为开不本不迹正法莲华也。次辨三轮者观音谓他心轮。观察法界众生心可度不可度等。普门即神通轮。说法轮观察既竟或为说法。或为现通。现通生其功德。说法生其智慧。现通灭其苦果。说法生其乐因。现通发其信心。说法生其慧解。亦得互用。又现通多为钝根。说法多为利根。现通多为在家众生。说法多为出家众生。如前说也。四者名德一双。观音谓三种名。普门谓三密德。三名者。一观世音生众生口业善。二观世意生众生意业善。三观世身生众生身业善也。普门三密德者。一知他心普。二说法普。三神通普。三名谓生众生三善。则生善义周也。三密德则应物善尽也。下二问答正明三名三德。摄十方诸佛菩萨名德皆尽。所以受持功德多也。又观音谓大悲心。普门明大悲事。悲者前则无际。后则无穷。亦无中间。所以前无际者。无始来有众生则有菩萨悲。故此悲与前际等。后则无边者。众生若尽悲心乃息。以众生不尽故悲心不息也

问。后际无尽可然。无始来则有众生者。亦应无始来有观音耶

答。众生无始今悲此无始。故无始有悲也。净名云。从痴有爱则我病生。所以悲心拔痴爱。既其无始。悲心亦无始。故无始亦有悲也。普门谓悲事者。虽有悲心若无悲事则是假相悲。以无实益故非实悲也。今悲心既通悲事亦普遍。拔三世十方之苦。悲事普也。又题名释名一双。观世音者谓标菩萨名。并叹菩萨名用。谓众生起于三业免脱众难。普门者则是释免难。菩萨所以能拔难者。良由有三普故也

问。云何用三普耶

答。众生三业向感。菩萨于一一业中随用三轮。或应通或说法等也。五者内外一双。观世音谓菩萨内德。潜眸密照。即知病识药。普门谓菩萨外德。种种方便充满十方。救度众生应病授药也。六者智慧功德一双者。观世音即是智慧。谓知根欲性。普门即是功德救度众生也。七者智断一双。观音即是菩萨智慧谓之智德。普门即是断德。大经云。随所调伏众生之处名为解脱。今亦尔。遍度众生令一切解脱。乃是断德。不如二乘之人自无烦恼名为解脱也。八者显密一双。初问答释观音名。明显感密应。显感者谓众生三业兴感。密应者观音不现身。不说法而令得解脱也。普门即是密感显应。显应观察其心现身说法。密感者不明众生三业兴感。但有应以言。谓根缘真发故。即为现身说法也。然显密感应具通四句。可以意知也。初章明密应。后章明显应。应章虽多不出显密。今经正明感应。故四句之中但明期二也。非但此品明期义。乃总摄一切众经应感义也。九者慈悲一双。观音即是大悲。谓拔七难三毒等苦。令其得脱。普门即是大慈。说法现身令其得果。十者二身一双。观音是药树王身。根茎枝叶华果皆能愈病。普门谓如意珠王身。能与一切乐。二身义出十地论释文无心能灭物苦。如药树王无心而与物乐如意珠王也。十一者谓二智一双。观音即是实智。普门即从实智起方便智益物也。十二者三业。观音谓菩萨意业。普门谓身业口业。十三者三德。观音谓波若德。以观察即是智慧智慧名为波若。普门谓现一切身。即是法身。为调伏一切众生令得解脱。即是解脱也。十四者二益一双。观音谓众生与世间乐拔世间苦。故有七难及无男女难等。即是世间获益。普门现一切身说一切法令其得度。即是出世间益也。十五者释二德。观音即是明菩萨字义门。普门即是实德门。字义门者。释论云菩萨字有无量义。今释观音字有无量功德义。故是字义门。普门明三密实德。故是实德门也。十六者神通示现。观音六通中他心宿命天眼天耳。普门者谓如意通漏尽通。漏尽通即是说法也。观音名虽摄四通而文正主天耳通也。示现者可具二句。一者神通非示现。谓天眼天耳宿命也。二者亦示现亦神通。谓他心如意及漏尽。故六通中三是示现。三非示现。所以大品云三事示现。下文即云普门示现。今普门即是三事示现。观音既是天耳故不名示现。即是示现不示现一双。十七者观音是十力。十力是内照故。普门谓四无畏。四无畏外用故也。十八者观音即是四等。谓慈心欲与乐。悲心欲拔苦。喜心庆脱苦得乐。舍心修于平等。普门即是四摄。摄取众生。应以布施摄者即以布施摄之。余亦如是也。十九即是解行一双。观音谓智慧智慧解也。普门救度。救度谓行也。二十者悲慧一双。华严云观音说大悲经光明之行。悲者欲救也。光明之行是智慧能救也。世间父母见子受苦欲救。而无智不能救拔。世医有智慧能救。无悲心故不欲救。菩萨有悲故欲救。有智慧故能拔也。又始行菩萨欲救而无道力故不能救。二乘有道力能救。无悲故不欲拔也。观音悲慧合行。悲故欲救智慧故能拔也

次论观音名。观音可具二义。一者智境合题二者应感双举。观谓能观之智。世音即所观之境。故名境智也。观即是观察赴应。世音即是众生机感。故名应感也

问。境智为名具几智耶

答。正是实方便智耳。知世间音声即不有有不闻闻义。既了世间音不有有。即知有不有。若识不闻闻。即知闻不闻。以识不有有不闻闻义。名为实方便。若知有不有名为方便实。不有有岂是有。有不有岂是不有。故非有亦非不有。非实非方便。名为中道观。故观音之名具三观。世谛观．真谛观．非真俗中道观也

问。今文但言观世音耳。何处有三观

答。观音受记经出观音所解具三观音也。又论云。因缘所生法。即是空。即是中道者。明世间音声即是因缘即空即中道。故具得三观也。所言世音者。世有三种。一者众生世间。二者五阴世间。三者国土世间。众生世间者谓之五阴十二入十八界众法中生故云众生。五阴世间。谓能成众生之法。即是色之与心。三国土世间即是色法为体。谓国土风俗。今菩萨正观众生世间。但五阴能成众生。国土是众生所托。不得相离。故总名世间也。世音者世间语通。音是世间中之别。子夏毛诗序云。以声成文谓之音。寻大小经论明音与声不异。杂心界品云。声有三种。一因受四大声。谓有情物声。二因不受四大声。谓外物如钟铃等声。三因俱声。如人吹管等声。此则但解声不明音。故知音与声不异也。成实论云。如人欲听钟铃等声则以耳就铃。此品云即时观其音声。化城品云迦陵频伽声。如是等皆明音不异声。普者上明观其声未必周普。故今明普门。普以周普为义。但普有二种。一心普二事普。凡夫二乘俱无二普。始行菩萨心虽周普而事不普。观音心事俱普。大悲欲普拔众众苦。大慈欲普与物乐。谓心普也。外现一切身说一切声。谓事普也。门者以心事二普为法门。故云门。又令众生悟入能通正道。故名为门

问。观世音有几名

答。古经云光世音。今云观世音也。未详方言。故为此号耳。若欲释者光犹是智慧如大经云光明者即是智慧智慧即是观也。又菩萨智慧光明照于世间故云光也。华严云。观音菩萨说大悲经光明之行。大悲即是功德光明谓智慧。则知光世音不失此意也。罗什注净名经明有三名。观世音观世意观世身。什今所以作此释者。见普门品具释三名。故有三号耳

问。何故立三名耶

答。立此三名则遍察众生事尽。众生唯有三业。菩萨具观其三业。故立三名也。又随众生好乐不同。又众生或口不能言。或身不能礼。故具说三名。又众生忌讳不同。故备三名

问。何故具观三业

答。欲遍生三业善。故若口称名乃至身礼拜者。皆为观音所照。必得脱苦也

问。众生三业兴感。三业具几业耶

答。口业称名具三业。发声即口业。动舌即身业。经意则意业。身礼拜但身意二业。意存念唯意业也

问。菩萨观者但意业能观。身口二业亦能观耶

答。菩萨三业无碍皆能观也

问。观是智慧。意地可能观耳。身口云何能观耶

答。阿修罗琴无心尚能应物出声。天宝无情随诸天意而走使。况菩萨身口光明不能观物耶

问。既有三名何故今但称观世音

答。此越举一名也。二者众生称名具动三业。今欲遍生三业善故偏名观音也。三者娑婆以音声为佛事。四称名得自行化他。余但自行。五者称名便易。若遭难之时身礼意念为难。六者直称名尚脱苦。何况意念身礼拜耶。如妙药但得闻能治病。况意念身触耶。七者弘猛海惠经明。观音过去世值空王观世音佛发愿。愿未来名观世音。余二名无有愿也。则观音名有二。一行二愿。行者观名救苦。愿者过去发愿也。论脱难不脱难

问。称菩萨名何故有脱苦不脱苦耶

答。至心则脱。不至心故不脱

问。菩萨自应救之何须至心

答。以至心故则罪灭。菩萨方得应之耳。故须至心。二者罪轻则脱苦。罪重则不脱苦。三者习因有厚薄。薄者脱苦厚者不脱苦。四者业有定不定。定者不脱不定者脱

问。不定者可称名。定者应不用称名

答。今虽无益作后世因也。五者有密益显益。则脱苦者谓显益。则不脱者谓密益。六者有利益者脱苦。无利益者不令脱也

问。称观世音复有以神力杀害众生以不

答。如前明以利益为定。余悉不定。若尔者或令脱火。或令不脱。或故烧杀之也。今称名而不脱死苦者。此事难知也

    二种次第义释妙庄严等品

三世诸佛唯有二种次第。一根缘次第。二随义次第。随义次第者如先说苦谛次说集谛也。根缘次第者如先说苦谛后说十善等。非四谛之次但随根缘也。佛说法具此二种次第。而多就根缘次第。诸菩萨造论亦具二种次第。但弟子欲解佛语多依义门次第。择集佛语次第释之

问。二次第何者为正

答。以根缘次第为正。所以然者。佛及弟子说经造论。唯令人悟而教无有定

问。叵有定义以不

答。如前云。唯以悟人故教则不定。如大经云。三十余事诤论门皆是如来就根缘说。以此众生非一国土一种根性一善知识。是故如来不作一说。但令取悟耳。若尔者前说法身寿量。后则明诸菩萨。又前说陀罗尼咒。后说妙庄严王本事。根缘次第。不必辨咒居第一。妙庄严王为第二。故非义次第。此通释二十八品经及八万四千法藏也

问。直闻妙庄严王本事。云何悟道耶

答。佛见根缘说必得道。无论事理及以古今。设不见机虽说妙道于缘无益

问。上说妙音来往得悟无生。今闻往古事复得净眼。然大小二悟要见空然后得道。今说有事云何成圣

答。虽质小疑实壮哉大问。成论人云。见空得道。数人云见有成圣。诤论纷然由来久矣。今明如数论等四句皆不得道。何以知之。释论解波若度中云。不得波若方便力故学阿毗昙堕有见中。学空门堕空见。学有无门堕亦空亦有见中。学非有非无门堕愚痴论。故知四句皆不得道也。若得波若方便学此四句。不堕四见。若尔者善巧学四句四句皆得道。不善巧学四句四句皆不得道。又即此明菩萨往来而得道者。即是善巧方便学有故得道

问。云何善巧

答。菩萨来者此是不来相来。虽来不来。悟解此来即生二慧。是以得道

问。见有得道为作有解故得道。为作空解故得道

答。已如前说。作有解即有见。作空解即空见。如是四空皆不得道。识有是空。有虽有而不有。因此得入道。有终非道乃是道门耳。空等亦然

正像义　此义总释诸受记中法住久近

问。释迦佛法住世凡得几年

答。正法千年像法千年末法万年。出祇洹精舍碑善见毗婆沙中亦有此说。但度女人出家。损正法五百年。有人言都失五百年。正法但五百像法千年。故摩耶经但明千五百耳。中论文亦尔。有人言损正法五百流入像法。便有千五百年。有人言修八敬故正法还复千年

问。何故三时复但言像法

答。但言像正者摄末法入像也。言末法者开像为二。谓像及末也

问。何以知像即末耶

答。十二门论云。末世众生薄福钝根。即名像为末也

问。云何为像正

答。此具多义。一者佛在世为正。佛灭后为像。二者未有异部为正。有异部为像。则百十六年后方为像法耳。三者得道多为正。得道少为像。故释迦前五百年得道多。不得道少。后五百年得道少不得者多。四者破正法未破正法分像正。大经邪正品云。我灭后七百年中是魔波旬渐当破坏我之正法。则六百年未破为正。七百年破为像。五者诸恶法起未起分像正。像法决疑经云。千一百年诸恶法起名像。若千年内恶法未起为正。然千年内虽有恶法起。犹未盛故属正法也。恶盛为像。六者二千年皆属正法。万年转衰微为像法。七者诸菩萨见如来法无有灭。常见诸佛。则万二千乃至一切时皆是正法。二乘人见佛法有兴衰。故有像正耳

问。何故释迦正法但得千年耶

答。过去释迦佛正法千年住世。而释迦本作陶师因发愿。愿我作佛为释迦。令我正法亦千年住世。以是事故正法但千年

问。佛灭度以来凡得几年

答。至今已得一千五百九十六年

问。经何故云正法千年住世。复何故千年外别有佛法

答。此不相违。所以然者。佛法有二种。一正得二正教。正得者得道人也。正教者佛正法教也。言千年佛法灭者此就正得为言耳。千年内有得道人多。千年外得道人少。故名佛法灭也。正教法者乃至万年住世也

问。佛法灭时有几因缘

答。有七因缘如思益经广说

问。有三大劫三小劫。法华经中身子正法住世三十二小劫。像法亦三十二小劫。何故但言小劫非大劫耶

答。应是小劫。所以然者。大劫则无复世界。岂有佛法住耶。而今云三十二劫者此是小劫耳

问。三大劫通净秽土。三小劫但是秽土。若尔身子成佛时皆是净土。云何有小劫起耶

答。外国名劫波。此云分别时节。今但有时节久近。如小劫起尽之数故名小劫耳。实无小劫起也

问。小劫时节云何

答。从八万四千岁渐减。至十岁名一小劫

问。一大劫唯有八十小劫耳。常不轻品中云。彼佛正法住世如四天下微尘劫耶

答。大劫有长短不同。短大劫者但有八十小劫耳。长大劫者其事不定。如娑婆一劫比西方为一日一夜。如是乃有百万阿僧祇品。如华严广说。以此推之无所疑也

论佛入涅槃。释此经诸佛入灭事。诸佛有六事故入涅槃。一为所应成就。众生已竟故入涅槃。二者令二乘人舍小涅槃令归大涅槃故。所以然者。如来舍此身归法身者。二乘之人亦应舍此身求佛法身也。三者为除众生轻慢心故。浅识之流取信耳目。谓如来身有生老病死。与己身同。于如来身起轻劣想。是故今明。佛有二身。一反化身舍之入灭。此与人同。二者法身。无生老病死。此与物异。四者为令众生生渴仰心。若恒见不灭必生厌薄。示现舍灭故生渴仰心。五者令众生勤加精进悟世非常。诸佛有三种力胜一切人。一父母生身力胜一切人天。二神通力胜一切人。三解脱力胜一切人。虽有三力为无常所灭。故知无常其力最大。因此悟世勤修道。六者为已勤修道者速令成就。是故现灭也

法华玄论卷第十(终)


法华玄赞义决

    No. 1724 [cf. Nos. 262, 1723]

法华玄赞义决

        淄州大云寺苾刍慧沼撰

问。菩萨有二。谓顿渐悟。疏有二释。何者为长

答。据其证理名顿悟。得圣回心名渐悟胜。未得圣者理未悟故。若以信悟而名渐悟。有定姓大乘人。曾未闻大。创即闻小。虽不趣求闻而信解。岂名渐悟耶。若此信解不名渐悟故未得圣。即回心者亦非渐悟。若尔彼类定生时等生数无多。何非渐悟。此亦不然。若趣小果已定生等。若回趣大生数不定

问。既定生时即无多生又不造业。如何不定谁言不造业。论说有支非摄二位。以憎背有故。若许造业何非有支

答。有二解。一释据无漏者非有支摄。所以杂集云。道谛摄非有漏者不尔如何感十王果。诸论皆说六波罗蜜。咸感彼故。设无相行亦感彼果故。无著般若论云。一遍故若不感有漏如何言遍。又正二。不能正感。于此位造感有业故。缘起经云内法异生。若放逸者三种无明为缘。若不放逸不说无明为缘。又说。诸圣有学不造感后有业。不言非圣亦不造业。又云若无苦无苦下。无明诸行不生二位。既容现行何不造业。加行顿伏据满位说。以此故知回心行经多生故成顿悟。又杂集论第十三云。于此生中决定堪能通达谛理。是名通达顺决择分。即此位中不定种姓者。为欲回向最胜菩提及诸独觉为求无师自证菩提转趣余生。是名余生顺决择分。既云转趣余生明生不定。又复法师本意不说若定生等。虽后回心必取圣果。下引善勇猛。般若云未入正性离生者据不受变易者。既不受变易明即趣大非小圣果。言定生时等假叙他。尔今又助释设是凡夫未求于小即求大乘。但不定姓亦名渐悟。以必不能一往趣故。必中退故。若云不闻说一乘即可有退。闻说一乘即必不退。舍利弗等曾亦闻说妙法一乘。如何有退。以此故知但有小姓必退取小。得圣方回始成不退故名渐悟。设有种种界。虽有小姓容有不退。终是彼类以有一分小乘种子成渐悟法亦名渐悟。是不定姓故

问。既为断疑说斯妙法。何故闻已复更疑生

答。疑有新旧。旧疑不得作佛故未回心。说昔非真皆当作佛。初闻佛所说。心中大惊疑。将非魔作佛恼乱我心耶。乃至我闻疑网断故为断疑。言谓已定生即此生时及一生顺决择分等者。杂集十三云。未具资粮补特伽罗已具。未具资粮补特伽罗。已具资粮补特伽罗。乃至云如是三种补特伽罗由成就顺解脱分顺决择分各三品故。约能引生顺决择分及谛现观。如其次第未定已定即此生时。于谛增上法净信胜解相是顺解脱分。即于此法谛密法忍相是顺决择分。如其次第信增上故慧增上故。此中三品顺决择分者除世第一法。由世第一法性唯一刹那必不相续。即此生时定入现观。非前位故。前文意显资粮加行二位之中各有三品。如其次第未定已定即此生时。然加行位分为三品。未定已定即此生时在暖顶忍。除世第一法。世第一法唯一刹那必不相续不可分之。然云即此生时定入现观者。此据刹那生说。前解脱分言即此生时约一期生说。又解俱约一期生说。以世第一法云即此生时。既除世第一法明约一期虽增上忍亦一刹那犹隔世第一法。非即此刹那生。无间入见故。又复通分暖顶忍三。为三时故就顺决择分复有六种。一随顺顺决择分。二胜进。三通达。四余转。五一生。六一坐。最初所起缘谛境行下品善根。名随顺顺决择分。即此善根转成中品。名胜进顺决择分。望前下品为增胜故。即此善根增至上品。于此生中决定堪能通达谛理。名通达顺决择分。此前三种在暖顶忍位。若约小乘。可得如次配未定已定即此生时。若大乘者。中忍满位方名即此生时。若在下忍及中忍位未满之时犹多生故。若二乘位。虽即此生可有回趣。名余转顺决择分。若余转者生生即不定。以求独觉无上菩提更于多生修胜行故。若在大乘顺决择分者。必不回心趣余下乘。况一生等以第七住升名不退。此决择分在回向修。以此准之。若顺解脱过第七住未定已定皆不余转。余转及前言故从下中顺解脱分顺决择分有可退义者。据二乘位说。若于此生定能通达。是名一生顺决择分。前言通达。约二乘位功能而说。然不定性即不决定。余转决择唯不定姓。一生顺决择分据决定姓。各趣自乘。或亦通有不定姓者。据不回心即一生入非不定姓皆见道前即能回心。一坐之中亦通不定姓。在中上忍。前文已除世第一法。唯一刹那故。三种练磨心断四处障者。无性摄论第六云。已说所知相入所知相。云何应见多闻熏习所依非阿赖耶识所摄。此意密说本无漏种而为所依云非阿赖耶摄

次问。谁能悟入问能入人。谓大乘多闻熏习相续已。得奉事无量诸佛出现于世已。得一向决定胜解已。善积集诸善根故。善备福智资粮。菩萨此答能入人据起现行多闻熏习二资粮备。何处能入。此问所入法及能入位。谓即于彼有见似法似义意。言大乘法相等所生起胜解行地等似法义等即所入法所生胜解行地见道修道究竟道中

答。能入位。于此四位随闻胜解故。如理通达故。治一切障故离一切障故。如次四道能入差别。论云。由何能入由善根力所任持故。谓三种相练磨心故。即四处故。解法义境。止观恒常殷重加行无放逸故者。释云。由何能入者。此问入因。谓由何因即由善根力所任持故。虽有善根力而心或退屈故。说三种相练磨心故。三练磨者。无量诸世界无量人一生有情刹那刹那证觉无上正等菩提。是为第一。由此意乐能行施等。我已获得如是意乐。我由此小用功力修习施等当得圆满。是为第二。若有成就诸有障善。于命终时即便可爱一切自体圆满而生。我有妙善无障碍善。云何尔时不当获得一切圆满。是为第三。释云。无量诸世界等者显示初练引他例己。令心增盛无有退屈。由此意乐者显示第二。若成就等者显示第三。广如彼释。论云由离声闻独觉作意断作意故。由于大乘诸疑离以能永断异慧疑故。由离所闻所思法中我我所执断法执故。由于现前现住安立一切相中无所作意无所分别断分别故。释云。断作意故者。断除二乘分别作意此意释云所以离声闻等作意。以能断故。不起趣执二乘心故。释云。以能永断异慧疑故者。谓于大乘甚深广大不起异慧颠倒及疑。此意释云。由于大乘诸疑离者。以断疑故。言诸疑者。即于佛说显密三藏种种不同而起疑惑名为诸疑。言离疑者。以能永断故。断法执者。谓于所闻所思法中。能永断除我我所执。谓我能闻我能思。觉所听文所思义。如是执着一切皆无。于其胜义证现观故。此意释云何无此执。以于胜义证得现观断除法执。据不执所闻思云断法执。法执既无。我执亦断。不起我能闻思等觉。第四亦是离诸法执。言七地四菩萨行者。七地。一种性地。即种姓住未发心位。二胜解行地。即胜解行住发心已去在于地前。三增上意乐地即极喜住在初地。四正行地。即增上戒住。增上心住觉分相应增上慧住。谛分相应增上慧住。缘起相应增上慧住。有加行有功用无相住。总此六住名正行地。如次离垢乃至远行。五决定地。即无加行无功用住。在第八地。有三种决定。一种性决定。二发心决定。三不虚行决定。此第八地堕在第三决定故云决定行地。即无碍解住。在第九地。七例究竟地。即最上成满菩萨住。及如来住。在第十地及于佛地。第十地因究竟佛地。果究竟故。四行者。一菩提分法行。二神通行。三波罗蜜多行。四成就有情行。因起有二。一通二别。通者贯余教故。别属一经故。通有多义。有为一因起说诸法。即无量义经云。法无量者。以诸众生性欲无量故。其所说法亦复无量。此但说生为起说因。又一因者。法华经云。为是众生故而起大悲心。此即说佛由大悲故起说于经有为二因。即总前二故。二十唯识云。展转增上力。二识成决定。又有二因。法华经颂云。种种因缘以无量喻照明佛法开悟众生。此即为法为人二种因也。又有三因。即般若经云何住云何修云何降伏其心。虽唯约发趣大乘为向据实。三乘俱然。简余二乘云趣大乘。即是三因。一令发心。二令修行。三令断障。即是如次令捡道故。成就道故。不失道故。此约修行次第而说。又有四因。即法华第三云。未度者令度。未解者令解。未安者令安。未涅槃者令得涅槃。即为令众生未离苦者使令离苦。未得乐者便令得乐。未能发心断恶修善令使发心断恶修善。未得果者令便得果。此依弘愿化生次第又有五因。即思益经第二云。若人能于如来所说文字言说章句通达随顺。乃至云能知如来以何言说法以随宜说。以何方便说以何法门说。以何大悲说。梵天。若菩萨能知如来以是五力说是菩萨能作佛事。以何说法即说三世世出世间生死涅槃蕴处界等。即谈法体。以何随宜说即随机宜。或净说不净。我说无我等。或显了说。或隐密说。以何方便者。或为令离苦。或为令得乐。示教利喜等于无言说法而方便说。以何法门者。谓于一法诸门说故。以何大悲者。起彼四因。初二四所说。第三通能所说。第五能起因即为三例。初二四而为所说。第三由有方便故能起说。第五由有大悲故能为物起于方便说彼彼法。大悲者有三十二。如言诸法无我。而诸众生不信不解。如来于此而起大悲等。即随彼生于境不解。迷没生死不能出离故起大悲。随彼不悟悲心起说。即众生为能感。如来大悲即所感。略即二缘。开即有五。广即无量。亦同瑜伽摄释分说。次至当辨。又有六因。准无著菩萨般若论释。须菩提问意有六。佛为答彼亦即六意。论云。何故上座须菩提问也。答有六因缘。为断疑故。为起信故为入深法故。为不退转故为生喜故。为正法久住故。即若有疑者得断疑故。若已断疑故。有乐福德而心未成就诸菩萨等闻多福德于般若经起信解故。已成就心者入甚深义故。已得不轻浅者由贪受持修行有多功德不复退转故。已得顺摄及净心者于法自入及见生欢喜故。能令未来大乘教久住者故准配法华上下思之。又有八因准法华第一文殊师利答成就文八大义。因是准义配文。若准瑜伽八十一摄释分。释经轨则。先解经体释文义法等起释难次第释义中有多。第四依处及总标中等起并是发起所因。彼论云如上所说若事若时若补特伽罗故。诸佛世尊流布圣教。是故说彼名为依处事依处有三。一根本事依处有六。一善趣二恶趣三退随四升进五生死六涅槃生死。即前四涅槃即余无余等。于中三对二。得方便事依处有十二即十二行。一欲行二离欲行三善行四不善行五苦行六非苦行七顺退分行八顺进分行九杂染污行十清净行十一自利义行十二利他义行。于中六对三。依悲愍他事有五。一令离欲即是为说生死过患。二示现即为显示四种道理。谓法尔因缘证成作用四道理也。三教道即未发心者教授令使发心修诸正行。四赞励者见退屈者赞劝令进。五庆喜者见能进修而不退屈随生庆喜。时依处即三世补特伽罗依处。即二十七种补特伽罗亦摄思益经如来五力事依处中根本依处及时依处。是彼以何说法摄得方便依处。即彼以何随宜说法以何方便以何法门摄。或大悲及以何方便摄。悲愍依处即离欲等。约方便能起此五。即大悲补特伽罗依处亦大悲摄。瑜伽约能悲所悲别开。思益据起悲之因亦大悲摄。故彼经云如言诸法无我而诸众生不信不解。如来于此而起大悲。此显诸佛申慈悲故。为诸有情依善恶趣。乃至自他利行随其所应令知过失功德厌欣修断及以获证故令离欲示教赞喜等。于经文中随义思配。恐烦不述。别者准智度论随经中说。皆为起意意因请等。比类皆然故。今更辨经起意中总有十门。别有五十二。一为显于一而说此经有四种。一一为显一乘故说此经。故第二云今此经中唯说一乘等。二为显世尊平等大慧故。多宝赞云能以平等大慧等。三为显真如体唯一相故说此经。故第三云如来知是一相一味等。前三令悟。四为一切色身三昧故。喜见菩萨等得现一切色身三昧。更有多一。略举此四。此一略明因令修二。为显二有七。一为显教理二胜故说此经。故下文云诸佛智慧甚深无量其智慧门难解难入。论释云谓证甚深及教甚深又莲华二义亦此门摄令欲闻故。二为显因果两门故。本论云自此以下明因果相令欣修故。第三为显权实两乘下文但以一佛乘故为众生说法。无有余乘若二若三。又云唯此一事实。余二即非真等令取舍故。第四显真化两身。寿量品云。众皆谓我出释氏宫。我实成佛已来无量阿僧祇等。令知真化。第五显损益两行。故不轻品云。其供养之者如向所说。其诽谤者如前所说等。令妨修故。第六显劝舍秽生净。如药王菩萨本事品等。令远恶近善故。第七令厌下欣上。如第八云。当生忉利天等。令离怖畏当亲近故。三为显三有七。一显三宝故。下文云。又见彼土现在诸佛。及闻诸佛所说经法。并见彼诸比丘等。又第二云。若有能信汝所说。即见于我及比丘僧并诸菩萨等。论云。佛及弟子差别示现三宝故。令起信乐故。第二显三乘差别。谓比丘等四众及见菩萨种种因缘而求佛道等故。论云复乘差别令知胜劣。第三显世尊三轮化故。入定者显记心轮。放光等题神境轮。说法者显教诫轮。令知胜人起尊重故。第四显悟知三性。下文云。诸佛两足尊知法常无性。佛种从缘起。是故说一乘是法住等。令悟三性达所知故。第五显三胜行。下文云。入如来室着如来衣坐如来座等。为显胜行令修学故。第六显三种平等。一授声闻当得作佛记。二多宝佛涅槃涅槃起。三现一佛摄一切佛。故论云为除三种染无烦恼三昧见等染慢说三平等。三种染慢者。一信种种乘异。二信世间涅槃异。三信彼此身异。令证真理摄自他故。第七显佛三菩提。下经皆谓如来出释氏宫显化身。我实成佛已来久远显报身。如来如实知见三界等显法身故论。云八者示现成大菩提无上者示现三种佛菩提等。令识真化而求证故。四为显四有七。一显如来有四种说因论亦云四种成就。一往成就即种种方便。二教化成就即种种知见。三功德毕竟成就。即种种念观。四说成就即种种言辞。令知二胜起渴仰故。二显开示悟入四种之事。令欣果行因故。三显四菩提行。下云于菩萨法游戏神通净佛国土成就众生。令修胜行故。四显四安乐行。即安乐行品。一正身行。二正语行。三意离诸恶自利行。四心修诸善利他行全弘法利生学是除非故。五显如来四种胜力。涌出品云。如来今欲显发宣示诸佛智慧之力诸佛自在神通之力诸佛师子奋迅之力诸佛威猛大势之力。令知所说胜故。六显如来四种一切。神力品云。如来一切所有之法。如来一切自在之力。如来一切秘密之藏。如来一切甚深之事。四一切者令知能诠教胜故。七显成就四法末代得闻此经。普贤品云。一为诸佛护念。二殖众德本。三入正定聚。四发救一切众生之心。令知胜法难闻必修胜行方得闻故五为明五有七。一显智慧甚深故。论释云。智慧有五甚深。一义。二体。三内证。四依止。五无上甚深。令生忻证。二显教门有五种难故。论牒经云。其智慧门难见难觉难知难解难入。令生推求愿欲闻故。三为显五浊。下云所谓劫浊等。令生厌离显佛大悲故。四显五劣不为说一。方便品云。钝根乐小法贪着于生死。于诸无量佛不行深妙道。众共所恼乱。为是说涅槃。令舍劣人故。五显五德为说一乘。下云有佛子心净柔软亦利根无量诸佛所而行深妙道。令学胜人故。六明五乘令知根性。一雨所润而各生长。论云为一向求大乘者增上慢云无别乘。令知种种乘异故。说雨喻令识根机随宜化故。七显五缘方说一实。化城品云。自知涅槃时到。众又清净信解坚固。了达空法深入禅定。令知法难闻要根熟故。六为显六有六。一示现六动。令众警悟故。二现六趣。令众厌怖故。下文云。尽见彼土六趣众生。三现行六度。劝令修学。如下颂说。四明与六记。论云一未闻令闻。二说。三依何义。四令住。五依法。六遮。配文可知。显正逗机令取舍故。五显庄严六根。劝令持读。如法师功德品广说。应知令持经故。六明六种授记。令知当果地起决定学心故。谓别记。同记。后记。无怨恶记。通行记。具因记。广如论辨。七为显七有四。一显世尊具七成就。有种种言辞。令生问求。一种种成就。二语言成就。三相。四堪。五无量种。六觉体。七随顺众生修行说成就。配经可知。令知胜人具德辨故。二显七种众生起七种慢。令知过失故。三为治此说七譬喻令断障染。如论具辨。四题持经具七德。令行法故。法师品则为如来衣之所覆。又为他方现在诸佛言所护念。有大信力及志愿力诸善根力。与如来共宿。如来手摩。令知持经成胜人行显经妙故。八为显八有四。一为愿教具八甚深。论云一读诵。二修行。三果行。四增长功德心。五快妙事。六无上甚深。七入甚深。八不共声闻辟支佛所作住持甚深。配文可知。令知差别胜小教故。二为令离八邪然。下文云薄德少福人等。又云不求大势佛等。又云我本着邪见等。令知邪正故。三令修八正。下文云世尊知我心拔邪说涅槃。令知胜用得出世乐故。四令离八难。提婆品云不生地狱等。令知胜利得世善果故。九显九部经为趣大说。令舍权故。故下文云我此九部法随顺众生说。入大乘为本。以故说是经。令知方便半满教故。十为显十有五。一显文殊得宿命智成就十事如现在前。如论具辨。并配文显。显师资胜故。二显教法有十胜妙。下文云演说正法初善中善等。令生忻习。三显大乘有十无上。令知经胜等。如文具辨并及配文。四显十义故说一乘。知摄大乘论及庄严论。令知大乘有四秘密故。五显此经有十殊胜。一举事明难胜。略举六行显此为难。如见宝塔品说。二喻类难思胜。略举十喻明于此经如药王菩萨品云。譬如一切川流江河诸水之中海为第一等。三证听二众胜。明证则多宝塔诵欲开化佛皆来。此为证明胜。龙宫地下上诸支提。普贤妙音傍归宝塔。又声闻菩萨具德者云趋四众龙天居尊者雾集。为听众胜。四能除八难胜。成实论说四轮能摧八难。于此经中小闻生信即能总除。如提婆达多品说。五生天值佛胜。如普贤品说。六得住净土胜。暂闻一品即往净方。如药王品说。七不退菩提胜。一闻生信不退菩提。如分别功德品说。八为世福田胜。持经四句堪受人天胜妙供养。一劫赞佛福虽无边一赞持经福更过彼。如法师品说。九获福难思胜。持读此经功德无限。如药王品及分别功德品说。十速得成佛胜。如提婆及不轻品说。具如行仪所说。略举大纲。明此十门。恐繁故止。前来五十二缘。此经因起。颂曰。初四三各七五七六有六七八四九一十有五应知。吉藏法师略陈十义。一说菩萨道。二受梵王请。三显三世佛权实二智四说三净。五说三摄法门。六说三种法门。七为断疑。八说中道。九增念佛三昧十为三世众生如实分别罪福二门。今略叙彼一为说菩萨道故说此经

问。始自华严之会终竟法华前。集诸大乘经已。说菩萨行。今何因缘故复更说即

答。有二菩萨。一直往。二迂回。今为回小入大菩萨故说是经

问。何以得知。华严等为直往。今为回小入大者说

答。涌出品云。是诸众生始见我身。即寂灭道场见卢舍那闻我所说。谓华严教。除先修习学小乘者。则知前未为如是人等。我亦令得闻是经入佛慧。故知今为回小之人

问。何故先为直往。后为回小

答。修行久近别故。二为受梵王等请故说此经

问。昔般若等教已明受请。与今何异

答。请有二时酬亦两种。初请一说根本法轮故。今受请与昔为异。如方便品及智度论初卷说之。三者欲明三世诸佛权实二智相资成故说于此经。非实无以显权非权无以显实。实有起权之功。权有资实之用故。下文云。于一佛乘分别说三。即从实起权。我设是方便令得入佛慧。则以权通实。禀教之徒或执权亡实。昔执三乘人不能悟入一乘之道。或执实亡权者闻法华一乘谓无三乘。说破可知。四欲说三净法门故。众生本性未曾垢净。于众生颠倒故成垢净垢重不可顿拔故。佛菩萨渐渐出之以开三净。一以五戒十善净三途。二说二乘以净三界。后明一乘以净三乘。以三途为重苦。三界为中苦。变易生死为下苦。故说三净。五为说三摄法门总谈圣教。有此三门。一摄邪归正门。二摄异归同门。三摄因归果门。摄邪归正门者。释迦未出凡有二邪一在家外道起爱众生。二出家外道起见众生。并乖正道故称为邪。方便品以诸欲因缘坠堕三恶道。即起爱之流入邪见稠林诸见外道。如来出世摄彼二邪归五乘之正。此二之中有无闻非法。以人天成就。三乘性者三法摄故。摄彼二邪归乎五正。二摄异归同者。若悬悟一道者不须更说为钝根流。虽舍二邪更五乘异。摄前五异同归一乘。三摄因归异者。离摄五归一但是因行。欲令修因证极果故。说称如来真应两身为摄因归果门。六欲说三种法门。一根本法轮。二枝末法轮。三摄末归本法轮。佛初成道为诸菩萨说华严等根本法轮。薄福钝根不堪闻故说二乘教为枝末法轮。四十余年说三陶练。今此法华方会归一。即摄末归本

问。何处有文

答。信解品云。遥见长者踞师子床罗列宝物。即指华严为根本教。唤子不得遣二人脱宝服执粪器着弊衣宿草庵假称子。为枝末教。为会亲族集付家财。摄末归本。七为除声闻菩萨疑故说于此经。如新疏辨。虽少有别略不明也。八为欲说中道法故。故说此经

问。何以得知

答。二周说法。初皆放眉间白毫。上不以顶。下不以足放眉间者表二周说皆中道也。初周明一道清净即一乘也。第二周明一法身清净真实身也

问。何故明中道

答。昔说五乘。为显教五。禀教之徒闻昔五乘作五异解堕在诸边。禀人天教者在生死边。求二乘者堕涅槃边。学大乘者着大乘边。今破此诸边令心无著。九为增念佛三昧故说此经。自昔未明真实身方便身故。凡夫二乘始行。菩萨未识佛故不解礼念。但有所得心礼念。即礼念有所得心。何曾礼念于佛。故佛非彼师彼非佛子。今开身方便身真实。方解礼念

问。昔云何不解礼念

答。昔执虽多不出三种。一者不识本一迹多。二不识本无生灭应有生死。三不识释迦久证法身非迦耶始得。为此三病故示三种教门。一明释迦净土诸佛应身不二。故知应身不二迹身不一。二者开塔同坐。显多宝灭而不灭。则知释迦虽生不生。不生不灭名为法身。方便唱灭。称为迹用故。王宫生而不起。双林灭而不失。迹虽生灭宛然而法身未曾起谢。三者过去久成未来不灭称为法身。然灯授记。伽耶成道因为方便

问。释迦识法身法身有久近不

答。法身无久近。以法身无久近则悟亦无久近。所以然者。悟本于法身。法身既无久近则知悟之亦无久近。既知久远悟而无久。当知今近悟亦无近。何故但明此三。答初则法身不二迹身不一。未知不二之身为生灭。为无生灭故。次明法身无生灭应身有生灭。虽知生灭法应有异。未知释迦为姓证法身为久证故。次明其久近。一切诸佛皆具前二。释迦具三

问。既明念佛如何为念

答。大品经云。以无忆故此显除分别不见。佛为所念生为能念。如真理体而为礼念。如安乐品及寿量品明。十欲为未来十方众生如实分别损益。罪福二种业报者如行仪说。十义亲疏邪正思之。经得名门疏中云依顺体义处中因出世报者。依宗轮疏云各有四种谓教理行果略有三。且教有三者。一无义言。如四吠陀论。婆罗门诵之。音声清雅甚自可重。但寻其义都无理趣。如彼论云。我已饮甘露成就不复死等。二邪妄言。如九十五种外道。亦说因果但明邪僻故名邪妄。三如法言者。如佛所说因果道理说苦集是世间因果。灭道为出世因果。道理相称不乖僻故名如法言。理有三者。一增益义。如诸外道。于无我法横计我法等。二损减义。如诸邪见及断见等。三顺体义。如佛教法有则说有。无则说无离断常见故名顺体。行有三者。一顺世因。如在于俗事君忠事父孝等二邪僻因者。谓妄计诸邪戒禁等。三处中因者。如佛法门离苦乐边离邪求等。果有三者。一谄诈果。如曲从命以取荣禄等。二虚妄果者。如诸外道妄计无想以为涅槃等。三世出果者。如佛教法能令众生出于生死证得涅槃等。由依教理行果有邪正故立如是名。令舍邪归正。又为得四清净故明四总名。一教清净。二义清净。三方便清净。四所得清净。如次立彼。教即初中后善等。理即离彼增益损减等。行离苦乐等。果非世间众苦所依识惑所染。故名清净。又为依诠悟理依理起行由行得果。若无能诠无由悟理。若不悟理有邪分别故造诸恶行。有邪分别故造诸恶行故感诸苦果。今依教正能显正理。既证正理能起正行。由正行故能得胜果。故依于四以立其名。又由教故生于闻慧。依理生思。依行生修。因此得果故。摄大乘云。闻等熏习无果生非道理。又有二类。一依人法。二依法喻。或单或双。绮互不定。何故如此。依人名者。令知修六和敬故。依法名者。令知了义不了义墨法文法等故。依法喻者。为钝根故。广略明故从处从事。皆法中收法名宽故。准于上义。法教立名虽有众多不出于此。且如摄论谈其名者总有十种。颂云法．补特伽罗．法．义．略广．性。不净．净究竟名所行差别。初法名者谓色受等。补特伽罗者谓天授等世间名随信行等圣教名。后法名者谓契经等。义名者谓此所诠杀害于父母等。略名者谓一切法无我等。广名者谓色无我等。性名者谓阿等诸字是词句因故。不净名者谓诸异生为诸烦恼垢所染故。净名者谓诸贤圣垢永断故。究竟名者谓总所缘即般若波罗蜜多及十地等以总略义为所缘故。此有五对。一法人对。二教义对。三略广对。此三如次。四染净对第八九名。五分别非分别对。亦得名因果对。第七第十字为余因故分别名第十为显究竟理故名无分别。于中第二八九从人名。所余从法名。然今辨教即是第三契经等名。瑜伽八十一名有十二。颂曰假．实．同．异．类．随德．及假说．同．非同所了显．不显．广．略一。假立名者。于内假立我有情等。于外假立瓶盆等名。实事名者。谓于眼等色等诸根义中立眼等名。同类相应名者。谓有情色受大种等名。异类相应名。谓佛授德友等名。随德名者。谓质碍名色领纳名受等。假说名者。谓呼贫名富等。同所了名者。谓共所解与此相违是非同了显名者。谓义易了。不显名者。谓义难了。如达难弭荼咒等。略名者谓一字名。广名者谓多字名。此中六对。一随诠假实对。二同类异类对。三称体虚设对。四共非共了对。五诠义难易对。亦云诠事题密对。六能诠略广对。虽十二名不出人法。文显可知。若辨教名。随其所应义准可通。通论诸教立名不同。总开六例一依六释通别。二教理行果通别。三人法通别。四法喻通别。五三宝通别。六赞毁通别。或合为二。所谓人法。于前六中据其通别复有多类。如依六释。或唯有一。或通二三四五六等。或无唯一必滞二释。如涅槃经体既通能诠所诠。即有持业及依主释。或通三释。如成唯识论．大乘阿毗达摩杂集论等。有通依主．持业．有财。如正法念经等即通持业．依主．邻近。余可准知。或可无有具六释者。若依教理行果四名通别。通即有十五。别即有四。二二各有六三三合有四四四合有一。遗教无量义大忍辱涅槃经。如次教理行果四单名也。二二合者。如解深密经等教理合。大方广菩萨十地经教行合。称赞佛功德经等教果合如信力入印经理行合。如来入一切佛境界经理果合。如来求佛本业经行果合。余可准知。法人单合。皆易可知。人喻名如菩萨璎珞本业。人法喻合如胜鬘师子吼一乘大方便经。三宝单合者。阿閦佛经四分戒经说无垢称经三宝如次。如来功德庄严经佛法合名。佛大僧大经佛僧合名。菩萨戒经法僧合名。阿难问佛吉凶经三宝合名已上总是立名不同。广如唯识论钞叙。恐繁且略

然学之者应先叙通名后叙此经。此经名中分之为二。初依疏辨。后述异名。述异名中初解妙法。后辨喻。初解妙法者。南岳思禅师云有十妙。一境妙。二智三行。四住。五三法。六感应七神通八说法。九眷属。十功德利益妙。境即十如。智即能缘本后二智。智所导为行。行所历名位。位所依为三法。依法以应物机为感应。随能感而为现通名神通。应感者而演教为说法。因随佛化闻法能悟为眷属。以法授生为利机随入为益名功德利益妙。何以得知有斯十妙准下文知。方便品言唯佛与佛乃能究尽。诸法实相等即境妙。我所得智慧等即智妙。具足行诸道等即行妙。乘是宝乘因位直至道场果位即位妙。佛自住大乘如其所得法定慧力庄严等即三法妙。我以佛眼观皆是五子惊入火宅见父居床等为应感妙。今佛世尊入于三昧雨华动地放光远耀等为神通妙。所可说法初中后善言辞柔软。其所说法皆悉到于一切智地。但说无上道等为说法妙。教化诸菩萨无声闻弟子为眷属妙。声闻闻法得记佛前末世随闻所得福利皆为利益妙。生起次第。准义说之。上解妙法。次解喻者华有众多。何故独举莲华为喻。答吉藏法师云。略有三义。一者离喻二合喻。三者通喻。言离喻者。一明此华不有而已。有则华实俱合。此经不说而已。说则因果双举故。以莲华喻于因果故。论云示现因果相等。二者由华开而实现。由言发而理显故。以莲华喻于教理故。下云其义深远其语巧妙等。三者华未开而实未现。华开则实方现。未开方便门则真实相未显。开方便门则真实相方显。华开喻方便门开实现譬真实相显也。故下云开方便门显真实相。二合喻者。略有十义。一华从种生。喻一乘必有种起。故下云佛种从缘起等。二者此华从微至着。喻佛乘渐渐增长。故云渐渐积功德等。三者此华增长满足出浊泥水。喻佛位国出离生死。故下云如来已离三界火宅。寂然闲居安处林野等。四者此华虽出泥水而不舍泥水。喻佛虽出四流之外而不舍三界之中。故下云在门外立闻有人言惊入火宅方宜救济。五者此华妙洁第一。喻于佛乘五乘第一。故下云是乘微妙清净第一。于诸世间为无有上等。六者此华凡圣叹爱。佛乘亦尔。世出世间称叹爱敬。故下云佛所悦可一切众生所应称赞供养礼拜。七者此华台叶具足。喻于佛乘万德皆圆故下云无量亿千诸力解脱禅定智慧及佛余法。八者此华佛菩萨坐。此经亦尔为佛菩萨而住其中。故下云佛自住大乘如其所得法。定慧力庄严以此度众生。九者此华开合有时。喻此一乘隐显有时。昔隐今显。故下云所以未曾说。说时未至故。今正是其时。决定说大乘。十者此华劫初成时梵王坐上为众生父。是经亦尔故下云如大梵王一切世间之父。此经亦尔。为一切世间之父。为一切贤圣等父余处复说智度菩萨母以方便为父等。三通喻者。大集经云。慈悲为根茎。智慧为华叶。三昧为须台解脱为敷实。菩萨为蜂王。涅槃为甘露。是故我顶礼妙法莲华经。复有释云。所言妙者妙名不可思议也。法者十如权实之称。莲华者喻权实法也。良以妙法难解。从近喻远也

次意乃多略拟前后合成六喻。一为莲故华。喻为实故权。故下云知第一寂灭。以方便力故。虽示种种道其实为佛乘等。二华敷喻开权。莲现喻显实。下文开方便门显真实相等。三华落喻废权。莲成喻立实。下文正直舍方便但说无上道。四又莲喻本。华喻于迹。从本垂迹。迹依于本。下文云劫浊乱时乃至云是故诸佛如来以方便力于一佛乘分别说三等。五者华敷喻开迹。莲现喻显本。下云汝等谛听如来说秘密神通之力。乃至我成佛来复过是数等。六华落喻废迹。莲成喻立本。下文云诸佛如来法皆如是。为度众生皆实不虚等。是以先标妙法。次喻莲华荡化城之执教。废草庵之滞情。开方便之权门。示真实之妙理。会万善之小行。归广大之一乘。上中下根皆与授记。又发众圣之权行。显本地之幽微。故增道损四生作邻．大觉一期化道事理现俱圆。莲华之喻意在斯也。品有无中云五失三不易者。弥天释道安云。译胡为秦有五失本三不易也。一者梵言尽倒(有云书倒更勘)而使从秦。一失本也。二者梵经尚质。秦人好文。传可众心非文不合。二失本也。三者梵文委悉。至于叹咏丁宁反覆或四不嫌其烦。而今裁斥。三失本也。四者梵有义说只似乱辞。寻说向语亦无以异。或一千或五百刊而不存。四失本也。五者事已合成。将更傍及反胜前辞。已乃后说而悉除。此五失本也。然智迳三达之心覆面所演圣必因时时俗有异而删雅古以适于今一不易也。愚智天隔。圣人叵阶。乃欲以千代之上微言传使合百王之下末俗。二不易也。阿难出经去佛未远。尊者大迦叶令五百六通迭察迭书。今离千年而近意量截。彼阿罗汉乃兢兢若此。此生死人而平平若是。岂将不知法者之猛乎。斯三不易也。涉兹五失迳三不易。译梵为秦。讵可不慎乎明经品得名中有二。初释品名不同。后明得名。名不同者。正法华经云光瑞品．方便品．应时品．信乐品．药草品．授声闻决品．往古品．授五百弟子决品．授阿难罗云决品．药王如来品．七宝塔品(提婆达多品入宝塔品内)劝悦品．安行品．他地涌出品．如来现寿品．行福事品．劝明品．叹法师品．常被轻慢品．如来神足行品．药王菩萨品．妙吼菩萨品．光世音普门品．总持品．净复净王品．乐普贤品(末云佛说此品时如恒河沙亿百千菩萨众皆悉总持即尽之也)．属累品。释品废立中。属累若在药王品前。乃有八违有为十证属累令在药王品前。令还妙故证。但云化佛使还本土。多宝佛塔未遣还故。二不言佛赞证。药王品中但云塔赞。三妙音开敬证。涌出遍礼分身。妙音但礼二佛四秽土非净证。化佛未去。此犹令净。妙音来日何为被呵。五问佛来不证。云多宝如来来听法不。既不见多宝。明塔已闭。六欲见多宝证。若未闭塔。二佛同坐。自应观见。何须请见。七请见唯闻证。既唯闻声。不言见佛。明知已闭。八敬塔非佛证。二佛同坐。应礼二尊。何故但言礼多宝塔。九二分不齐证。化佛若是未还。何以不齐奉施。十无别分身证。若药王品下犹有化佛。何无文证。以此十证属累不令在后。应广如彼说敬寻斯说理奥文通。然义有千途。今者翻归旧辙上德。既以十证属累令有于先。若尔有十不可。是故属累还令经末。一令还如故证不可。非言如故但令塔闭不遣还国。正法华云。多宝世尊七宝讲堂佛之塔庙还复故处迹不可言。经本有别唯一佛说又不同。小见闻异故。二不言佛赞证不可。药王菩萨本事品云。多宝如来在七宝塔中。赞言善哉善哉虽开宝塔佛无在中。今言多宝在宝塔中。赞言善哉。不言塔赞。云非佛赞证不可言。三妙音关敬证不可。以下方涌出遍礼分身妙音不礼即证已去。亦应文殊不礼分身已去提婆达多品亦云。至二世尊所修敬已毕往智积所。不言遍礼。岂化佛去故为不可。四秽土非净证不可。若以妙音被诫土还秽者。亦应化佛使往灵山出应非净。若云虽云诸山据本相说谈土实净。妙音见秽类亦如是。若云虽变净土灵山尚存故不为例者。灵山非秽变净犹存。既土石山如何得在。故言在者据初时说。如文殊从海涌出。犹言诣耆阇崛山。时会并以升空诣山欲何所为。故虽诣空宝塔据本尚言诣山处地遣使持华诣山。故知据本非净土内可有耆山。下文云。时我及众僧。俱出灵鹫山。亦据本处说。若云经云唯留此会众亦留人山者不尔。众令闻法本为可留山不闻经留之何益。故云秽土非净证不可。五问佛来不证不可。何者文殊请见妙音。释迦如来云多宝如来可为汝等而现其事。时多宝佛告妙音言。善男子来。文殊师利欲得相见来承佛召。如何假问。问者为传佛言故经云净华智佛问讯世尊。又问多宝如来来听法不。非妙音自问故为不可。六欲见多宝证不可。若云二佛同坐即令俱见。何须请佛。我今欲见多宝佛者。菩萨下人如来上果加被令见。可得睹尊。若未加被即不得见。希望佛加故请欲见。且妙音将至。文殊尚请佛加。妙音既现处因得见。要须佛力故虽同坐请已方见。非是请见即证塔闭故为不可。七请见唯闻证不可。若以请见经但称云赞不说见身。即明不见多宝。亦文殊请见妙音。经不赞妙音来至。文殊得见。文殊亦应真不睹妙音。若已请见来即得见何须说者。妙音请见当即见。何要文中说得见故为不可。八敬塔非佛证不可。何者若以妙音敬塔不云敬佛。即证塔闭。亦应普贤来日不言敬塔。塔亦应无。不得言塔比时已去。文无遣塔之处。虽不敬塔不妨塔有。不言敬佛何妨见佛。又如塔开之后一切总在虚空。文殊海会云诣灵山。岂可不知佛在宝塔。以本山故言诣山。以本在塔故云敬塔非不诣空及亲礼佛。又如俗云谨书足下。未必安于脚膝下。但是敬辞。此亦应尔。又准正法华。观音奉璎。一分奉释迦牟尼。一分奉多宝如来。不言奉塔。明塔未闭妙音得见。今言唯闭故为不可。九二分不齐证不可。若以多宝但为二分。不奉化佛。明无化佛。亦应龙女但奉释迦多宝亦应以去。又文殊不礼多宝多宝不无。观音不奉分身。何得即云以去。礼敬齐故。故为不可。十无别分身证不可。设下经文不说化佛。何废措在。如药王品下不言声闻。声闻岂即非有。若以普贤品中说有。即证现有声闻。唯正法华等属累既在经末。明知化佛亦有。文义须说可即说之。文义不须。何为强说。故不可。分判本文中。一说方便品下八品为正宗。一说乃至不轻菩萨品为正宗。虽有二释意取初释。何以故。下文言。今此经中唯说一乘。又云开方便门。即是显昔权。显真实相。即是今说实。又方便品既是根本正明权实。所说之乘譬喻化城。重说前义。三根获说。已下即赞叹劝行。说法既周。即智积请去。为明流通显经力势。化广速成。非是会权显于一实。又论释告鹙子所由为诸声闻所作事故。欲令声闻回趣大故。又摄大乘说为引摄一类及任持所余说二乘无令舍不趣。岂说报法不令起化成应佛已不起化故。应不令修佛恩德故。故知不为舍于化身唯说法报故。又复三佛俱是菩提无上故故第一说善余明方便品下乃至不轻品为经正宗。云方便品下十九品明经体后八品明流通序明兴教之由体明即坐之益者。若以得记为益。即说方便已下八品为正宗。若以得证皆名为益。应遵法师善乃至普贤。何故但至不轻。准此即有太宽狭失。余准前判。得失可知。有释七成就中。序成就有二。一显法门中胜。二自在功德成就。云以法门中最胜故配序成就文。自在功德故配余六种。此释正违论。论文自分七成就已云。又序成就者。即各别牒解释。以其二义别属城山。何得自在属下六成不得云。论言显此法胜举属经文。功德成就既不结配明属余六。以法胜言双显前二。以能诠教及所诠功德俱名法故。法名宽故。解如是我闻。皆云阿难亲从佛闻者

问。如佛成道二十年后阿难方始出家。云何诸经皆言我闻

答。佛重为说。何以得知。菩萨处胎经具广分别。佛历问所说不闻之者阿难言不闻佛敕听为说。阿难得佛觉三昧。悉能受持故也

问。若尔何故智度论云。阿难将升高座说经之时。向佛涅槃方而说偈言。佛初转法轮尔时我不见。如是展转闻。昔于波罗奈为五比丘众转四谛法轮

答。智度论文随他余部故作是说。又释佛初在彼为五人说。后更重为阿难再说。云展转闻

问。若尔入大乘论云。阿难持法不尽明。二十年前皆悉不持又引中阿含说。释提桓因语郁多罗言。尊者我得他心观阎浮提一切众生。无有尽能受持佛法。唯除尊者。余不能了。以是因缘当知阿难非悉能持。又首楞严经中佛为净日藏天子说。阿难所持小不足言。不受持者乃有无量。乃至广云复满十方微尘世界皆如阿难不能尽持。亦复如是

答。据佛未加未重为说故作说又解。首楞严经据佛所悟未说之法云不能总持。如言未说如林中叶等。又若此处所说之法阿难能持。于余十方诸净土说阿难不持

问。若阿难陀非大菩萨余不能持说。既是菩萨化作声闻何不能持

答在因位故。据显相身在此界故。于余处说云不能持。在此界中若宝无能云何。阿含云唯除尊者余不能了。郁多罗者亦声闻故。又违处胎云悉能持不尔相违故作此通。诸文无过。言诸漏已尽释名者。俱舍云稽留有情久住生死。或令流转于生死中。从有顶天至无间狱。由彼相续于六疮门。泄过无穷故名为漏。世亲菩萨述经部云。若善释者于诸境界流注相续泄过不绝故名为漏。若准大乘杂集第六云。令心连注流散不绝故名为漏。此复云何依外门流注故立欲漏。依内门流注故立有漏。依彼二所依门流注故无明漏。令心连注流散不绝是漏义。解云。于境泄过立以漏名。但得小乘之糟粕。失大乘之淳粹。出漏体中。有云瑜伽六十四无明漏唯取恶见所依无明为无明漏。故彼论云。略由五相立助解脱欲无明漏。一有想论门生起无明。二无想论门生起无明。三非有想非无想论门生起无明。四由断见论门生起无明。五由现法涅槃论门生起无明。以此文证。唯取分别。又但取见所依无明者不尔。此且依欲界三求门说。不有唯言不尔。上略无明非漏故。如疏释。大乘尽理故。瑜伽八十九云。诸欲界系一切烦恼唯除无明说名欲漏。诸色无色二界所系一切烦恼唯除无明说名有漏。于彼三界所有无智总摄为一立无明漏。若一切有俱舍颂云。欲烦恼并缠除痴名欲漏。有漏上二界唯烦恼除痴无记同内门定地故合一。无明诸有本故别为一漏。然缠中除惛沉掉举。婆沙云。彼界缠小不自在故准品类足论及经部宗。即加此二。然准二宗。三界烦恼三漏摄尽。经中复云无复烦恼者。二释如疏。非前三漏摄。或不尽更言无复余。有释言。前之三漏摄取不尽故。更言无复烦恼。深为大妄。尽诸有结者。有言。非是九结。相应宗云。九唯欲界现缠故应取五上下分结。今谓不尔。准八十九云。依九种事能和合故建立九结。一依在家品可爱有情非有情数一切境界贪爱缠事。二即依可恶一切境界嗔恚缠事。三依自有情数憍慢缠事。若四五六依恶说法诸出家品三种邪僻胜解缠事。谓依听闻不正法故。依不如理邪思惟故。依非方便所摄修故。如是差别即为三三种。七依于善说法律无胜解缠事。八依出家品智贫穷事。九依在家品财贫穷事。如次起九。后二据因。以出家品悭吝法故。当知贫穷智。在家品悭财故当贫穷财。此据多分欲界所生。不说唯言准杂集第六云爱结者谓三界贪爱结所系故慢结者即七慢。无明结者三界无智等。大同有部。中边论第一文亦通说不言唯欲故。又八十四云。于五种事能和合故说为结。第五趣向事能生五趣。于诸趣中能和合故名趣向事。既言诸趣不简上二界。明许通三界三见二取。各合为结者。且俱舍云。物取等故。即彼三见有十八物。二取亦然故名物等。三等所取一等能取等故名取等。所取能取有差别故。何缘缠中取愱悭二。答不善性自在起故。八缠可尔。十缠中忿覆亦具二义。应言数现行故。又二能为贫贱因故遍显劝忏随烦恼故恼乱出家在家部故。故准疏解。文为尽理。若取五上下分结者。准八十四云。望色无色欲界名为下分。望其修道见道为下分。由约此二下分差别。准此即应五下分结准分别或。无俱生爱不成有结。阙润生故。违余文故。此既约多分。九结亦应尔。略举二三。余文异解多有乖失。准此可知。列阿修罗众中。有人引阿含经云。光音天入海精流海内遂成一卵。迳八千岁生女修罗。身如须弥。千头小一水触女身生毗摩质多。其形四倍大母。九头八脚千手小一。纳香山乾闼婆女生舍脂者。此是经中谈外道义。不尔。欲天尚无精秽。岂光音天而有精流。有释。说法时至成就中。言大乘经通名。无量义已下别名。然其别名不唯解无量义。亦通一切诸大乘经者。其义未可。且解总别。理即可然。以大乘经一切大乘经通名。此即极成。无量已下别名。然亦通一切大乘。此即未可。论解时成举说无量义。若通一切何名时成。或说余经未说此法华故。以此故知。十七名者但解一无量义。又复论云。此修多罗有十七名。若通一切何须说此。又自解云。此时所说一部教义但得三名。如华严等但名方广。又云。余十四名所诠之义。无量义经中不具故。无量义不得余名。但得三名。尔何得云十七名通一切大乘经。又复论云。此大乘修多罗有十七名。若无量义名不具足。何得云此有十七名。见六趣中。有说。阎罗王。准华严经则别立趣。华严经云。令诸众生离阎罗王趣枷栙等苦。又言令诸众生离地狱畜生饿鬼及阎罗王四恶趣苦。以此文证故别立趣。若准伽论第二。劫初成满已。有一有情起增上杂染业生那落迦中作静息王。既言生彼。故知彼摄。今谓不尔。若许彼趣摄。应受彼趣苦。若受彼趣苦。何能治罚彼趣有情。故二十唯识云。何缘不许狱率等类是实有情。不应理故。且彼不应那落迦摄。不受如彼所受苦故。乃至应自不能忍受铁地炎热猛焰恒烧燃苦。云何于彼能逼害他等。以此故知非彼趣摄。然华严云及阎罗王四恶趣苦者。以王臣别开为一趣。据实鬼趣如修罗趣于天别开。瑜伽论云。生那落迦中作静息王者。判彼趣故。又应云生那落迦作静息王所判有情不尔。便违二十唯识及余经论是鬼趣故

问。大义内成就中。论释有八。如文具列。然未知开权显实。对中论云示二种密境界为顿悟人为渐悟者

答。准义虽通然意约渐悟。何以故。本为声闻所作事故。欲令闻知难信法故。若据顿悟示密境界。即是令取清净义竟。何须复说。故对声闻令舍昔权。示声闻密境界令取今宝。示菩萨密境界。上虽总示令欣。未别令修理智令修证二果故。有得智观理对文

问。有云为说二种密境界者。谓吹大法螺击大法鼓。其义如何

答。彼说非理。非理者何。论云大法鼓二句示现。若取法螺即大法鼓一句示现。何得云二。若云取大法鼓并彼法螺云二句示现者。不断大法鼓。复明何义。若云彼论所牒经与此别。若尔论文自释别经。何须引释此法华经。况复大乘无别部释。一佛说无有二经只应从论八。云何得自意量度。有释。阿含八种甚深亦通释智慧。义虽可尔然释论文八种甚深通释二者。违于论说。如文可知

问。论云已生惊怖者令断惊怖。为利益二种人故。下文复云四悔惊怖者。谓大德舍利弗等我不应证如是小乘法自止。即此悔心名为惊怖。应即先惊怖。云何释云不说无惊说即有惊。

答。以有论云谓若为说谓大德舍利弗等我不应证等故云说即有惊。又如疑心既有新旧。此悔亦尔。为欲断改悔因更悔起。又先悔修小。今者为说方悔不早修大故释无妨。今更一释或可疏本有误应云二。一说即有惊。二不说即无惊。以舍利弗云闻说未闻断疑悔故。此释有过。不顺经论故

又问。惊怖有五如怪惊怖。恐更有谤密令退席。损及颠倒何不退席

答。闻之不谤故可在座。增上起谤故令退席

问。损惊怖者。闻而不谤故不令退。何故论云谓有闻声取以为实谤无大乘

答。谓闻声执实谤无大乘者。据昔凡夫创闻小教执为究竟。谓无大乘。未曾闻说大乘。起谤此损减谤。遂依修小将为究竟。我究竟取如是涅槃。今闻大乘既信不谤。但揣无分不能进修。既闻唯一。便谓无有声闻得灭返道。疑生故名为损。故下文云。若我弟子实得阿罗汉辟支佛不信是经无有是处

问。既不为说定性二乘为在座不

答。辟支佛果此会定无。经但说有求缘觉故。定性声闻虽不生为有亦无妨。令成不愚法故。又设闻虽信既不回心。又损惊怖无亦何爽

问。难云二子趣于牛羊鹿称出宅。太子趣于牛应当亦出宅

答。二乘或苦尽羊鹿称出宅。初劫或犹行不得称出宅

问。地前菩萨或苦在不得称出宅。初地已上或苦在亦应非出宅

答。分别二障。初地断得离分段称出宅

问。若尔初地受变易得离分段名出宅。变易八地受前七未离非出宅

答。前七有能离分段。虽非变易称出宅

若尔三果有能离分段。初三果人称出宅

答。初地菩萨力有能悲心不受称出宅。前三果人离不定非是故留非出宅

若尔前三未能回向大不受变易非出宅。出宅回心受变易能离分段称出宅

答。据回心者。既受变易得名出宅

若尔初三果人岂得名为出三界苦具足三明及六神通等。下第二云。若心决定具足三明及六神通。有得缘觉不退菩萨。长行又云。见诸众生以佛教门出三界苦

答。此等诸文据决定说。有学回心及受变易俱不定故不障名出。若不如是应不索车。若未索车如何与记。若云在宅亦得索车行记得车即应有学乘车出宅。若尔即便有学胜无学。宅内得车故。若云有学未名得车说无学故者。云何无学得记即名索车与车。有学得记不名索车与车。若云或苦在故不得名索车与车。七地已前亦尔思之

问。释遮中。准论云。无二乘者无二乘涅槃。为但无涅槃。为行果等亦复非有

答。有云。能诠之智证所证理。既无二涅槃。明亦无二智。二智既无故亦无二行。行因教起。亦无别教故说一雨等。如实义者则不如是。但无二理。一真如故。唯大涅槃故。上下诸文但云法身无差别故。又云何体法若唯一乘体故。一乘体者。谓诸佛如来平等法身。声闻辟支佛非彼平等法身之体。以因果行观不同故。既云以因果行观不同。明智行等别。又前云彼三乘法但有名字章句说非有实义。以彼实义不可说故。又理无为体一无别智行等为差别实一方便别故

问。既云实得阿罗汉不信此法。无有是处。何得有损惊怖

答。今言实得据回心者。故第二云。我等今者真是佛子。又云真阿罗汉。明苦未回非真佛子非真罗汉。不定既尔。定性亦然。故名自谓非真二圣。若尔得名增上慢。得世间定谓得无漏名增上慢。但得小解脱未得全解脱。又未得法身而自谓言与如来等同坐解脱床等。虽无烦恼是所知障。虽不障彼而得名慢。若不如是。初时未信后方能信。各无有是处。增上慢亦尔。除佛灭度后在毕化得故。虽作是释不如前解。前损惊怖。设不回心。闻亦不谤。顺此文故

问。何经云我知此众生未曾修善本。此经本对退菩提人。前云今此会中如我等比百千万亿世世已曾从佛受化。第二卷云。我曾于二万亿佛所为无上道故常教化汝等故

答。为二解。一云且据非退。创据小者云未修善。一云设曾修大。非增上品未成定位云未修善根。非全不修

问。为据今生通说多世

答。通说多世说世所化。岂得云我遇说。设余佛化亦云为我。不唯今生。闻即得圣证于小果。极疾三生。如鹙子等经六十劫。岂唯今生创教于小

若尔何故第二卷云初闻佛法遇便信受

答。言初闻亦通语耳。未必定今

若尔何故云我本着邪见为诸梵志师世尊知我心拔邪说涅槃

答。且据今生不唯今闻即得悟小。又释此据化者实即不尔。我以佛眼观。佛有五眼云佛眼观。此之五眼略以五门分别。一出体。二释名。三得人。四废立。五相摄。第一出体者。且肉天眼诸宗说异广如余辨。繁不具述。但依大乘自宗所说。有以眼识种子名眼。故二十唯识云。识从自种生。似境相而转为成内外处。佛说彼为十。有以色种名为眼根。观所缘缘论云。识上色功能名五根。应理功能与境色无始互为缘。有说能感眼根业种名为眼根。成唯识云。有避如前所说过难明附彼执复转。救言。识中业种名五色根。上之三说皆不正义。对法五蕴瑜伽等说。肉眼体性以四大种所造净色而为眼根。于中三说。一云种子。一云现行。一云通二。此说为正。故五蕴论云。眼根云何。谓四大所造眼识所依。以色为境故通种现。天眼根体以定所起四大所造净色为性。是通果故。故无著菩萨般若论云。谓色摄故。色摄复二。谓法果修果。法果即肉。修果即天。法是总名。即能感业肉是此果。虽知总称肉独得名。如说色处。修谓是定因修所起名为修果。愚法二眼俱慧为性。缘真缘俗二境别故。故无著菩萨般若论云。第一义谛摄世谛摄。又第一义智力故。世智不颠倒转故。是一慧约取境用分。佛眼即前四眼为性。智度论云。譬如四河流至于海总名天地故。前四眼在佛身中即名佛眼。若准无著菩萨般若论说。然佛后智名为佛眼。论云一切种一切应智摄。又云一切应智中一切种无功用智说名佛眼智度说中据总出体。般若论中各别出体。又般若论中。前四据因佛眼约果不尔。佛果岂有业感异熟眼根。又佛后智岂由本智方不倒转。任运起故。或同智论。总名佛眼。以智强故总名为智。若尔何故云一切种应智中一切种无功用智。准此即是偏取后智名为佛眼。故前解胜

二释名者。一总二别。总名眼者。梵语云般遮斫刍。般遮此云五。斫刍者此言行尽。谓如戒行种种诸物悉能见尽故云行尽。傍从于此翻名为眼。非是正翻。梵语名眼。眼照瞩义。五者是数带数释也。释别名者。肉谓业异熟色。肉即是眼。持业为名。自在光洁神用名天。天名虽通欲色无色意说色天。天之眼故依士为目。或即定果光洁名天。天即眼持业释也。此释有滥。又与智度论说有相违。彼云天有天眼故非即眼。照了名慧。慧即是眼。亦持业释。法即是境。缘法之眼名为法眼。虽慧等缘通名为法。余各各别缘。此能通缘。又缘教法此独名法眼。佛名如常。佛之眼名佛眼。依主释也

三得人者。欲色二界有情之内。若其天眼。欲界六天及以三洲除北拘卢得四静虑根本定者能起天眼。以许得通故。二乘有慧眼。照生空理故。虽亦得法眼以小劣故不说彼成。菩萨有法眼。以有种智故。能缘一切故。佛有佛眼。相显可知。又成后后必得前前。胜得兼劣。劣不成后故。成前前不必定能成于后后故。智度论云。天有天眼。二乘有慧眼。菩萨有法眼

问。若佛有法眼即得名佛眼。菩萨有法眼应名菩萨眼

答。佛眼唯佛有。从佛以立名。法不唯菩萨。从境名法眼。余者准知

问。法不唯菩萨不名菩萨眼。天眼不唯天何得名天眼。又天眼不唯天而得名天眼。肉眼不唯人应得名人眼

答。肉通余趣报。不名唯人眼。天唯属彼法。是故名天眼

问。法通于佛有不名菩萨眼。天通诸众成何独唯天眼

答。佛等亦天号通故名天眼。人虽起彼天属天名天眼。又名字假立何假苦求。设作多通终还有难。且各据义以立其名

四废立者。何故唯立五眼不增减耶

答。一切诸法略有二种。一色法。二非色法。色法之中有其二种。一显现近色。二隐覆远色。知显近色故立肉眼。知隐远色故立天眼。或色根中定散果别。散业果眼立为内眼。定所起眼立为天眼。胜劣不同故分二种。故无著论云。谓法果修果此为五眼。粗境界故是初色摄。非色法中有理事境。为了理境立其慧眼。为了事境立其法眼。又虽一智本后智殊故立为二。故无著论第一义谛摄世谛摄。又以果对因总立佛眼。故智论之前之四眼若至佛果总名佛眼。或据得人分五种。思准可悉

废立虽尔云何次第

答。以其劣胜引生次第。于色之中肉眼最劣。唯见显露。天眼次胜。通见隐显故次肉说。于非色中由了真谛俗智不例。又了俗由证真故说为后故慧先法后。前因后果故次佛眼。故无著论云。此为五眼。粗境界故是初色。据第一义智力故世智不颠倒转。是故第一义摄在先

五相摄者。准瑜伽论说。眼有三。华严经中眼有十。列名相摄。皆如疏辨。若瑜伽第三立一至十一与此相摄。恐繁不述欲广之者可寻彼文

问。经云菩萨闻是法疑网皆已除。千二百罗汉悉亦当作佛者。菩萨二疑中今除何者

答。二俱除。他知自得作佛。亦不疑他不得作佛。何以得知。答唯论释喻。第三为破一向求大乘执无二乘故说两喻

问。菩萨除知得作佛何无授记

答。声闻久来学小。虽信自得作佛恐未决定。令得决定之心故与记别。菩萨先不学小。但恐彼退闻说一乘知无别小。即住大决定故不假记。又亦与记别

前云无一不成佛。即总与记何不别记

答。以略故宜闻异故

问。既云千二百罗汉悉亦当作佛。为自知当作佛为不知耶。若自知者千二百人应同鹙子一时与记。何故说化城已方生解心始与授记

答。有二解。一云知得但未趣向。以乐少故。闻说化城方解舍小。始与授记。二云未知但是佛说彼当作佛。闻第三周方始领悟

问。何故菩萨闻即疑除知得作佛。千二百人自未能知。但是佛说

答。利钝异故。鹙子利根一闻尚解。菩萨更胜故即疑除。千二百钝根故未能解

问。准分别功德品云。若闻寿量一品功德于无一菩提退者。无有是处。舍利弗等过去曾闻妙法华经。如大通会等。何故并退

答。二解。一云究竟退者终无是处。设退还发故。二云据利胜者。或据领悟者。说九净者。显扬第三云。一尸罗净。善住尸罗。乃至于小罗中见大怖畏受学学处。二心净。依戒净故住四静虑。三见净。依心净故得漏尽智。现观诸谛。四度疑净。依见净故于佛法僧无惑无疑。五道非道智见净。依度疑净故得妙智见。知佛所说道能出离外道所说不能尽苦。六行智见净。依道非道智见净亦得净妙智见智。出离道有上中下。谓苦迟通行所摄等。七行断智见净者。依行智见净得妙智。谓我应断下中之行及为发起上妙圣行。八无余寂灭净。依行断智见净证得无余。诸漏永尽。九国土净。谓诸佛共有无上功德器。示现能不可思议国土庄严。极净佛思。极净菩萨思。及思眷属

问。火宅譬喻舍利弗请为千二百人即皆无学。何故论释云为有学具足烦恼性众生

答。有二解。一云谈本说权本为凡夫。今以喻显故言为具足烦恼性。即谈昔意故不相违。二云准声闻请。正为无学傍备有学。据傍云凡夫。无学文显。论略不释。不尔。此经宗明一乘。如何药草品云令知乘异。说种种乘故。约内有学声闻令趣于大。文显可知。故具不引

问。羊鹿车体正取何法

答。准疏家释。取二乘无学解脱道后世间定心虚指。此为种智之车。引子令出此世间心。实不能了一切法故出门不得。可须臾修义言索车。故论云第一人者与世间种种善根三昧功德令其游戏。后令入大涅槃故

若尔云何下合喻云乘。是三乘以无漏根力觉道禅定等而自娱乐

答。彼是此乘庄严具故。又无漏身中所有诸法亦名无漏

若尔牛车亦应如是

答。彼究竟故。是实德故。此虚指故。非究竟故

若尔有漏岂名出宅

答。出分段故名为出宅。又释即指无学果位所得无漏生智为羊鹿车。下言自在无系无所依求无漏根等故

若尔如何出门索车以得知故

答。以指此智假为种智。此不能了一切法故。当更修故。义云索车

若尔如何名为世间

答。缘俗俗事故。以劣智故名为世间。若尔对车说城应取真理。云何论云涅槃城者诸禅三昧城。涅槃既取禅三昧城。菩提何故取后世间智。又复二乘无漏后得不能起通了知诸法。何名令戏故前说善

问。门外索车为三乘人。并悉索车为唯二乘

答。有二解。一云通三乘索。文无简故。旧德说故说诸子故。二云唯二乘索非菩萨。何以故。宅喻分段。得出分段名为出宅。二乘出宅得无学果。菩萨出宅在于初地。二乘无学未得种智当能修学名为索车。初地已上得种智车故不须索。若以修学即名索车。十地皆修故。恒常索。若尔即应菩萨无不上车何得说言者乘车游戏。又论云为令入不退地示与无量智业。初地已上即得智业。虽知修学经不云索说游戏故。二乘出宅未得种智。未至初地可能修学义名索车。又论云其第一人与世间种种善根三昧功德令其游戏。后令入大涅槃城。以与人天世善。未得其真可须言索。菩萨不指羊鹿。初地已上得真。所以菩萨不索。或有说云。初机虚指故车须索。或云宅内闻三。门外见一。不知谁知一。是故须索等皆非实说

问。既菩萨不索车得名出宅坐不

答。称出宅坐。但约二乘学究竟故。离障尽故。心止息故。建立果故。菩萨之人学未究竟故。未离障尽故。不建立果故。心不息故。不得说云露地而坐。若虽分别名露地坐。前三果人亦应如是。若谓有学亦名出坐。云何下合喻中云以佛教门出三界苦怖畏崄道得涅槃乐。又释菩萨亦得称坐。虽不止息及以不制果。然以智安处亦得名坐。能伏惑故出分段故名出三界。露地无妨。若尔三果亦应如是许亦无失。取舍任意

问。三车门外出此车体有多不同。古解即是涅槃。今说即取后得正智。取涅槃而为车体。经论明文。经合云欲速出三界自求涅槃。如彼诸子为求羊车出于火宅。论云后入涅槃故取后智而为三车。复何文据

答。亦经论明文。羊鹿说为后智。论云第一人者以此世间种种善根三昧功德方便令戏。后令入涅槃故。既云种种善根三昧功德。明非涅槃。合牛车云求一切智佛智自然智无师智如来知见愍念安乐等。明非涅槃

问。俱有城文如何取正

答。取智为正

若尔前文如何会释

答。涅槃相故名为涅槃。又求羊鹿为涅槃故。不以涅槃合于羊鹿

若尔他亦释云。知见性故三昧性故名知见等。理实涅槃。此复何爽

答曰。违多文故。合鹿车云乐独善寂深知诸法因缘。合牛车云愍念安乐度脱天人。又云。我以无漏根力等而自娱乐。又云我有如是七宝大车其数无量。应当等心各各与之。不宜差别。若是涅槃岂云无数各与之。若云真如虽一然说七种。或十如等。据能证说云有无量及各各等。此即何过者不然。说智为车。理为宝所此有何违。总说为理。若唯取理即阙菩提。今者取智。智断具足说复前第一云究竟令得一切种智。又论令入不退地亦与无量智业故。又经云。如其所得法定慧力庄严。又云。佛种从缘起。又云。乘此宝乘直至道场。又云。乘是宝车游于四方。又说根力等诸功德法故。又云。我今为汝造作此车。故理喻宝所。先有非作有为修生说造作等。不可说言化城。虽理亦说造作。彼但造名无实体故。牛车同彼子应舍之。若取实理不说造作广有多证。繁不具引故以宝取喻理。车喻智胜

问。穷子譬喻对治一向增上慢。我乘与如来乘等无差别。若言我乘与如来乘无差别。即是与如来相好。乃是摄论说。声闻作佛令得同佛。自体意乐之义何须对治

答。有二解。一云许自小乘与如来等说。如穷子以对治之。我与佛等。亦应当得此之意乐。即非对治。一云定性之人修不作佛故。但令得同体意乐。不定之人当应作佛许与佛等障不回心故。说对治所望有别故不相违

问。四大声闻说喻领解。即为无学。论何故云为有学说

答。喻昔在因迷执为等。今悟喻昔云为有学。又自既解说喻晓余云为有学。斯亦何失。不尔。四人岂自对治

问。授记声闻为总不定亦有余耶

答。准论中解通为不定及变化者。故论云二种声闻如来与记。谓应化声闻。退已还发菩提心者

问。谁为不定谁变化

答。论不定判。准经文中。满慈一人说为变化。余多不定。皆说曾发大菩提心故

问。若许实声闻有回心作佛。云何维摩经云我等声闻犹如败种无所复用。入大乘论及菩提资粮论并不许此法华经中有实声闻。悉变化故。犹如种未必不生故。此意无惑。更不受生云何修行得三祇劫

答。彼皆据赞大乘胜。可彼小乘不令求趣。不定之人终归大故。令有大性速趣大故。不尔经论岂可相违。准此诸文。法华会时。四种声闻初俱在会。三止之后。增上退席。不说真圣亦退席故。闻经令成不愚法故。论释记中不为授记不障在座。或可无定性。论云有损惊怖故。不为记故。根未熟故。故不在座。取舍任意

问。化城以何为体

答。如疏释。又助释云。无学后心世间三昧说为化城。如二车体。以根本智不作解。故后得智作涅槃想解将为究竟。经化作故。论云第四人者方便令入涅槃城故。涅槃城者诸禅三昧城故

若尔云何能息诸苦

答。离障碍故。出三界故。如二车故。彼既得云出宅。此何不能息苦

若尔二车如何不得所说化城即言得入

答。不能了知一切法故。非种智故。故不得车。何以故。以未离智障故。如何得化城。以三界苦息故。得于解脱故。惑障已离故

若尔如何名为涅槃

答。假名涅槃故。第二云但离虚妄名为解脱。其实未得一切解脱。又云。尔时心自谓得至于涅槃。如增上慢自谓得果。其实不得。此亦如是

若尔无学岂不得有余耶

答。如彼无漏智隐而不彰。但说世间智。名之为车。此亦如是。虽有有余非究竟故。隐而不彰。令取大故。所以论云令入涅槃城故。涅槃城者诸禅三昧城故。若即指有余云何名诸禅三昧城。故又胜鬘经云。得四智及涅槃者去涅槃界近。明非实涅槃。云去近故。若是涅槃即云已得。云何名近。成唯识论第十卷云。不说无学有涅槃者。彼有两释。一云或约不定姓。得无学已即回向大。不说彼得。正与此同。若定性人羊鹿二车即彼生智。所说化城即二涅槃。彼究竟故。非暂息故。不趣大故。不同不定

问。如求三车将为势力说火宅喻令其生厌不令更求别说三车而为对治。既有定人。实无涅槃而有增上慢。以有世间三昧三摩跋提实无涅槃而生涅槃想。对治此说化城譬喻。应知既有学执世间三昧以为涅槃。实非涅槃。名增上慢。今即为说世间三昧名为化城。应如火宅令厌不取。如何得云第四人者方便令入涅槃城。故若是取世间三昧名为涅槃。岂不增彼执耶。又不知化求入彼城。既说为化。如何勤求后方向大

答。正为无学谈其昔事。权令得息求欲暂息为趣空所令趣向大。今更余义对治有学。不定之人堪能向大。有定之者执彼无学所得涅槃。将为究竟。作意欣趣。今佛为说彼非实灭犹如化城。所以昔日说为涅槃者。是我方便令退且入假涅槃城使得息疲。过此城后。令入大涅槃城珍宝处故。令有学知舍此求大故。为对治说作化城。而为对治非。是即今第四人者说作化城更便求入应如文释。与理不违。愚见若斯。更悕妙释

问。十无上正为何说

答。正为声闻不定性者故。论云示现种子无上故说雨譬喻。汝等所行是菩萨道者。谓发菩提心退已还发前所修行善根不灭同彼后得果故。意说二乘身中有菩萨种子。但能还修皆得作佛已发心者令坚固故。未发心者令闻无上亦发心故。既云退已还发心前所修行善根不灭同后得果故。明为不定

若尔何故十种无上不皆在正宗

答。非独为显一乘之理。并赞劝持。故通二分略叙大纲。余不繁述

问。此十无上有何次第

答。以义准之。令劝发心须冯因力说其曾种大因。令顺修行。当得佛果。故说种子无上。即为明说汝等所行是善菩萨道。明昔发心善根不灭。今闻佛法。还同为因。后得果故。既有胜因。须长时修无上之因。方能得果故。说大通智胜如来垂得菩提犹经十劫。显果胜上修无上因。次说修行无上。修行无上者要行大行。云何中间授之于小。但为昔日曾发大心。中间是大不能顿发。权施方便令息苦已。后进于大故说增长功德力无上。何知昔日曾发大心。说系珠譬令其领解。故次说令解无上。既知昔日久修大因。但为怖大。所以中退。今能忆念解悟修行。如诸菩萨当得净土。故次说清净国土。无上解悟既增上堪闻解脱教。故次说说无上闻无上教积劫行因皆成胜人。故次说教化众生。无上胜因既积。当得胜果。不同二乘。故次说成大菩提无上得果。虽复证灭而能现身利生。法报身虽常存。化身应物不定。虽灭不灭。虽生不生。故次说涅槃无上。所说既胜获益无边。起信供养闻法持赞。得无边福。现于神力。举他胜行及人法为证。复由久行因能化能受。圣者远至格白闻经。如来摩顶。殷勤三叹。明斯胜事。欲使通流。故次流故次说胜妙力无上。诸宗解释。异说无穷。经论出没多门。于中知见无量。略因讲次。聊述少分。多未欲呈于广闻。但为备时须尔

法华玄赞义决(终)


法华义疏

    No. 1721 [cf. No. 262]

法华义疏卷第一

    序品第一

将欲入文前明三义。一部类不同。二品次差别。三科经分齐。部类不同者略为七例。一者一会之经用为一部如十地等经。二者多会共为一部如华严之类。三者经之初分用为一部如六卷泥洹经。四者具足二分以为一部如大般涅槃。五者略本以为一部如小品经等。六者广本以为一部如大品之流。七者一品以为一部如观世音之例。今此法华于七种中是具足本。若依梵文应是略说有六千偈也。二论品次差别者又开五义。一生起次第。二明具义多小。三论品前后。四明品有无。五别释序品。生起次第者大明次第凡有二门。一根缘次第。谓适机而说。二义理次第。依义次相生。然佛说经虽具有二门多依根缘次第。弟子造论又具二门多依义理次第。今二十八品相生次第者。夫至人说法必有由籍故初明序品由序已竟正宗宜开。将显一乘为真实故。前开三乘为方便故次明方便品。上根之徒闻前法说即便领悟。中根之者未能忘言会法。可以虚心待譬故。次明譬喻品禀前法说餐后譬喻。又同领解故有信解品。印其所解为实重兴譬述成故有药草喻品。领解于前述成于后当果可期堪为授记故有授记品。自前已来中上根人皆已受悟。下根之流犹未领解故说过去结缘之始现在化城之喻故有化城喻品。下根之人闻上二周之说及后宿世因缘便得领解堪与授记故有五百弟子受记品。显名之众既解密行之流又悟故有授学无学人记品。三说已周三根齐悟复欲以斯法异世同闻故叹法美人令弘大道故有法师品。欲证前三说不虚复欲开法身果德故有见宝塔品。法师宝塔虽叹人证法未若亲由达多自致成佛。举此证验劝物弘经故有提婆达多品。上来三品美人赞法以劝弘经。菩萨声闻受命宣持故有持品。既于恶世欲弘善道多诸苦难。故辨弘经之方令安住四行身心快乐故有安乐行品。四行因成妙果宜显。仍有涌出菩萨开远寿之缘故有涌出品。开发之缘已彰寿量正宗宜显次明寿量品。闻说寿量得十二种益今广分别之故有分别功德品。从初以来竟分别功德品明二权二实。多逆耳违心。若能随喜其福无量故有随喜品。弟子随喜福已无边法师宣持六根清净故有法师功德品。虽唱五种法师获六千功德今引过去亲证显得不虚兼明上品功德故有常不轻菩萨品。自前诸品叹法美人其义已显。十方诸佛见二世众生信持此经心生欢喜。现七种神力故有神力品。大明流通凡有二分。一者赞叹二者付嘱。赞叹竟前今次付属故有嘱累品。药王禀经亲蒙利益舍身命财报恩供养以为受命宣通模轨。今说此本缘利益时会故有药王本事品。药王虽报恩供养犹未辨宣通此法。故召彼妙音明分身六趣为物弘经故有妙音菩萨品。众生虽欲持经多诸留难必须普示诸门大悲救拔故次辨观世音品。已明观世音之人救难次说神咒之法护持故有陀罗尼品。为物弘经盖是众生真善知识故次说妙庄严王本事品。修行一乘即是行普贤行。是故普贤远方来奖劝发起故有普贤菩萨劝发品也。次第二明具义多少门者。品虽二十八得名有三。一者以一义得名二者以二义受称三者以三义为目。一义得名者略明四种。一者从法受名如方便品等。二者从譬为目如譬喻品等。三者从人受称如提婆达多品等。四从事为目如涌出品等。二义立名者或人法双举如观世音普门品等。或能所合为目如见宝塔品等。三义立名者如五百弟子受记品。五百是数名。弟子是其人称。受记是其法目

问。品名为是佛说为是集经者安为后人所制

答。具有三义。一者若经文内标于品名如云闻是药王本事品功德无量盖是佛说。二者若标于品名置在文初盖是集法藏人取佛语意故制品名。三者如大品等九十章经无有品名悉是后人所制故。睿法师大品序述什公语云。大品经但有三品。谓序品魔事品阿鞞跋致品。以品非佛说故略去其二唯留序品。故知非佛说后人制之也。第三论品前后者诸经嘱累品多在经末。至如此经安神力品后者依于梵本及法华论。又即此秦地新翻法华并安嘱累品在于经末。今明罗什善解秦言妙得经旨。安嘱累品在神力品后必有深致。所以然者若嘱累品在经末者则至说经竟始令分身各还本国。若尔至说经竟犹是净土。妙音来时何事被诫于此国土勿生下劣想耶。又下方大士既普礼分身。东土上人不应独接足多宝。观音奉珠又不应但为二分。以此推之知嘱累品不在经末。安神力品后者大明一乘凡有二种。一诸佛所乘二菩萨所乘。故十二门论云诸佛大人之所乘故名为大。又观音弥勒诸大士等之所乘故故名为大。自从经初至神力品明诸佛所乘之法。分身诸佛为开寿量故来。远寿既彰各归本国则土还复秽。此一章义讫所以付属。从药王品竟普贤劝发品明菩萨之所乘。因果两乘既圆众便散席。为此因缘故安嘱累品在药王品前。又嘱累一品既明付属。药王等品即是受命弘经。以此推之不应在经后也。第四论品有无者罗什翻经但有二十七品。后更有提婆达多品者释道慧宋齐录云。上定林寺释法献于于阗国得此一品。瓦官寺沙门释法意以齐永明八年十二月译出为提婆达多品经。未安法华内。梁末有西天竺优禅尼国人名婆罗末陀此云真谛。又翻出此品始安见宝塔品后也

问。竺法护翻正法华经见宝塔品后有提婆达事。罗什何故不翻译之

答。事又难明今且以三义往释。一者外国传云。流沙以西多有此品流沙以东多无此品。所以然者小乘之流皆谓。诸方等经并是调达所作。是以诸国或有阙之。罗什既在龟兹国不见此品故不翻之。二者罗什译经观察机情每多存略。若具翻智度论则十倍于此。恐难寻求故略为百卷也。如翻百论无益此土故但存略有五十偈。故正法华经凡有十卷删彼烦文略为七轴。三者见宝塔品命持而持品应命言势相接。而忽间以提婆达多则文似非。次恐末世多惑所以删之也。第五别释序品。序者渐也。假时托处动地雨华为正说由渐故名为序。又序者次也。初明缘起后辨正经盖是义之次第。又言序者谓祥序也。经首列事祥序可观之也。又言序者舒也。欲显事义舒广故云序也。品者外国名跋渠此称为品。品云品别。以二十八章明义各异故称为别。二者品类。以其明义各有部类故也。第三明章段不同

问。寻天竺之与震旦着笔之与口传。敷经讲论者不出二种。一者科章门二者直解释。如天亲解涅槃有七分。龙树释般若无章门。盖是天竺论师开不开之二类也。河西制涅槃疏开为五门道融讲新法华类为九辙。至如集解净名之说撰注法华之文但拆其玄微。又不豫科起尽。盖是震旦诸师开不开两义也。今所释者其义云何

答。夫适化无方陶诱非一。考圣心以息患为主统教意以开道为宗。若因开以取悟则圣教为之开。若由合而受道则圣教为之合。如其两晓并为甘露必也。双迷俱成毒药。若然者岂可偏守一迳。以应壅九逵者哉

问。有人言经无大小例开三段。序正流通。是事云何

答。领向圆通之论开道息患之言足知众途是非。宁问三段之得失耶。必苟执三章过则多矣。而郡生因初分以取悟则初分为正。籍后章以受道则后章非傍。何得言初后是非正经中段乃为宗极。将非秉执规矩局释大方耶

问。初段入定放光雨华动地将为正说之由渐何名为正经

答。论云泥洹法宝入有多门经称受悟不同。佛事非一或籍音声以改凡或由默然以成圣。或因光明以出俗或假香饭以入道。故三业无非利缘六尘皆为佛事。斯乃先圣流于圆化而像末缠乎隘文未可然也。河西道朗开此经为五门。所言五门者。一从如是我闻竟序品序法华必转之相。二从方便品至法师品明法华体无二之法。三从宝塔品竟寿量品明法华常住法身之果。四从分别功德品至嘱累品明修行法华所生功德。五从药王本事品讫经明流通法华之方轨也。龙光法师开此经为二段。从初品竟安乐行品十三品是开三显一。次从涌出品以下十四品是开近显远。于两段中各开序正流通三段合成六段也。印法师开此经凡为四段。序品为序。从方便品竟安乐行品十二品开三显一明乘方便乘真实。从涌出品至分别功德品弥勒说偈以前两品半开近显远明身方便身真实。从分别功德品竟经是流通分也。彼虽云安乐行品前是因分。然见宝塔品下有三品又是果宗之由渐。必须两向望之。何者由见宝塔品多宝助命觅通经之人。故方有持品及安乐行品流通于因故嘱因分。次有涌出菩萨正为寿量之方序。由前命故出。则前三品又有成说寿量之义。故须两向论之也

问。众师所说何者诣宗

答。若皆能开道适会根缘。众说之中无非正宗也。但推文考义三段最长。宜须用之

问。初辨三段有失。今何故用耶

答。义门有二。一通二别。通而为论。禀三皆悟则三皆正说。今就别而为言故宜开三段。若具领通别意者理则无伤

问。立于三段有何义耶

答。略明十义。一者圣人说法必有诠序。深理化凡须惊耳目。率尔而说不起敬情。故在经初须置序也。既静心信仰宜开宗授法。故次有正说也。群生不穷大悲无限。欲以传训故末继流通。二者为对外道故明三分。外道云。但初有吉中后无吉。以初吉故中后又吉。佛法不尔。开为三分。而三分皆吉。故经言上语又善中语又善后语又善。三者大智度论云。诸佛有三时利益。一为菩萨时则过去世益物。二得佛时即现在世益物。三灭度后未来世益物。序正谓现在益物。流通即是未来益物也。四者序说发其信心。正说生其智慧。故大论云。佛法大海信为能入智为能度。此二则是自行。次令流通所谓化他也。五者又有二人。福慧深厚者值佛闻法故明序正。福慧劣者但值经卷必须流通。故智度论常啼品云。福慧厚者面从昙无竭闻说般若。福慧薄者但值金牒般若。即其事也。六者光阐如来正法凡有二种。一者燃灯二者传灯。燃灯即是序正。传灯所谓流通也。七者三世诸佛凡有二种。一受前佛付嘱。二付嘱后佛。序正即是受前佛付嘱。流通谓付嘱后佛也。八者唯有三分。一者前方便即是序说。二者经体所谓正说。三者经用明流通说也。九者又有三说。一说之由渐。二者正说。三者称叹称叹即是流通也。十者根性有上中下。如来说法又具三时也。初之一品名为序说。从方便品去至分别功德品半格量偈来凡十五品半名为正说。从格量偈后尽经十一品半名为流通分也

问。序分既名序品。正与流通何故不名正说品流通品耶

答。序品文少又明义无杂故但名序品。正说文长而明义广故废通名从别义受称。流通又然。就此三段各开两章。序开二者一证信序二发起序。证信令未来众生于经生信。发起假诸灵异发起正经利于现在。以化沾两世故双明二序也。正说二者。始从方便终竟法师品明乘方便乘真实。次从见宝塔竟分别功德格量以来明身方便身真实。所以开此二者。乘谓所乘之法。身谓能乘之人。具此二门乘义乃足

问。身方便身真实云何是人

答。法华论释寿量明于三佛。而金光明经辨于三佛云三身品。故知三身即是三佛。佛即是人也

问。乘权乘实以一乘为实余二为权。身义云何

答。三身之中又得法身为实应化为权

问。以法身为实赴感为应。但立一真一应者。乘又得尔不

答。以大乘为实小乘为权。又得一权一实。但约今昔不同凡有三义。一者双说。二者双覆。三者双开。言双说者。初成正觉寂灭道场为诸菩萨双明二义。如信解品。辨于长者喻真实身。罗列宝物喻真实乘。即其证也。次双覆者。脱珍御服着弊垢衣。以身方便覆身真实。隐于傍使更遣余人。即是以乘方便覆乘真实。谓双覆也。三双开者。明昔三乘是方便。今一乘为真实。辨昔身是方便今身为真实。谓双开也。然乘之与身更无二体。即一正观随宜说之。运用自在故名为乘。体可执模故名为法。以法为身故称法身。流通二者。始从格量偈竟神力品谓赞叹流通。次从嘱累品竟于劝发品明付嘱流通。所以明此二者。将欲付嘱使物弘宣。必须赞法功深美人德重。物欣此利然后受命弘经。故前明赞叹后辨付嘱。今就释证信序文凡有二意。一总释二别释。总释之中略为六门。一序原由门。三世诸佛说十二部经皆有六事。但要待侍者发问然后命使安之。如集法藏经云。侍者阿难凡发四问。一问以谁为师。二问依何行道。三问云何与恶人共住。四问佛经初安何等语。如来答云。戒能训诲可以为师。四念处破倒依此行道。梵法默然伏彼恶人。一切经初皆标六事

问。何故但问四事不多不少

答。初明正行。次明正解。次辨除障修行之缘。然此三门必依圣教。此四摄事既周。故不得多少也。二定多少门者。诸旧经师但明五事。此释伤义无文故不用也。今明凡有六事。一如是谓所闻之法。二我闻谓能闻之人。三一时谓闻法有时。四辨佛即是教主。五明闻法之处。六明与众共闻。具此六门义乃圆足。又如天亲灯论偈云。前三明弟子。后三证师说。一切修多罗法门皆如是。故知六事出自诚文。前三明弟子者。如是谓弟子之信。次句是弟子称我。第三句明闻法有时。从佛住以去既标于佛。故知后三句证师说也。三序来意门者。立此六事凡有三意。一为生信。如是即是信也。下之五句为生信故。智度论云。说时方人令生信故。时谓一时。方即住处。人谓阿难与佛及同闻众。故此三事摄前五门。以有时方人故所传可信。二者立此六事为简外道。外道经初皆标阿伛二字。如来教首六事贯。初三者为欲异论。弟子造论归敬三宝。如来之经六事在初也。四者有无门者。当佛说经时具有六体。但未立文将入泥洹命使安之。结集法藏始标经首也。五具不具门者。余经具足六事。但金光明经略无同闻。至后当说也。六前后门者。诸经多云如是我闻。以信是入佛法之初故前标如是。欲证成信义故次云我闻。如温室经云我闻如是。此前标能信之人。然后始得于经生信也

问。佛说经时云何有六事

答。以物有信心方乃说法。故知有如是佛说经时。即有侍者闻法时节教主住处同闻。故知实有六事也。次别释六事即为六门。如是者注法华云。如是感应之端也。如以顺机受名。是以无非立称。众生以无非为感。如来以顺机为应。传经人以名教出于感应故云如是。又注无量义经云。至人说法但为显如。唯如为是故云如是也。瑶公云。如是者将传所闻之言于未闻。良由可信。今明所传之言言必至极也。善当其理不失机会名为如是也。昙诜云。如是者无毁无誉之言也。真谛三藏云。如是者离五种谤故云如是。言五种谤者。一如言此经因果决定是有名增益谤。二如言此经因果决定是无名损减谤。三如言此经因果又有又无名相违谤。四如言此经因果非有无名愚痴谤。五如言此经因果非不有非不无名戏论谤。离此五种谤故名为如是也。光宅云。如是者将传所闻前题举一部也。如是一部经我亲从佛闻。即为我闻作哢胤也。梁武云。如是者如斯之言是佛所说故云如是也。有人言。如是者有三种。一就佛二就理三就阿难。言就佛者。三世诸佛所说不异故名之为如。以同说故名之为是。诸佛同说是故可信也。言就理者。诸法实相古今不异故名为如。如理而说故名为是。既是理之言不增不减决定可信故称如是也。言就阿难释者。以阿难望佛教所传不异本故曰如也。望理者即有所说无非曰是也。有人言。如是者文如理是。两物相似曰如。一物无非曰是。以文能诠于理相似曰如。理则至当无非称是也。今云如是者智度论

问。云。一切经初何故称如是

答。佛法大海信为能入智为能度。如是者即是信也。以信故言如是。若不信即言不如是。所以佛经初标如是也

问。如之与是何异

答。如名如实不虚。是谓至当无非为义。以信佛法如实不虚非邪是正故。故信称如是也

问。如是为据信体为因信相

答。如是名为信相非信体也。以外发言称此事如是。即表内心有诚信。故论云。如是者是信相也

问。如是为据能信为因所信

答。论云。佛法大海信为能入。即知佛法为所入。故知是据能信也。若言此事如是。则此事属于所信。则如是言具含能所

问。如是为是通信为是别信

答。信佛法之正即不信外道之邪。盖是分邪正之始。树众德之基。属通信也。然经有大小教有权实。信大之信非信小之信。即是别信也

问。为明阿难信为明余人信

答。有信心者即入佛法。盖是通劝一切信受。非局在阿难也

问。何人能信一乘

答。有六种人不能生信。一者起爱众生深着世乐不能信受。二者起见之流自是非他又不生信。三者求二乘之人执鱼目为真珠投夜光而按釰。故外国大小乘人分河饮水。故说一乘不生信受。四者谓法华教犹是无常。闻说常住不生信受。五者谓于此经覆相明常。闻显了说常不生信受。六者谓此经显了明常执成常见。闻说寂灭之道非常非无常又不生信。故见塔品云。手把虚空不足为难。信受书持乃称不易。斯言验矣。今若离上过失心无所依。乃能信受也。我闻者。如是一句谓所生信果。此下五事谓能生信因。以阿难见三讥嫌具八功德。亲侍如来二十余载。传于佛语物必信之。故是生信因也

问。阿难是佛得道夜半生。年二十五方乃侍佛。则知前二十五年所说阿难不闻。后二十五年所说悉皆得闻。后二十五年凡有三类。一者得闻。如闻法华经等。二者不闻。如涅槃经等。三者亦闻不闻。如净名一经。凡有四会。庵园二会阿难得闻。毗耶两集阿难不闻。以何义故一代之经皆称我闻耶

答。今引二经据本迹通之。一涅槃经据本而释。阿难多闻士。自然能解了是常及无常。既自然解亦自然得闻。二依报恩经据迹而解。佛重而说方乃得闻

问。阿难依何德何三昧能持佛经

答。释道安云。十二游经云。阿难得佛意三昧之所传也。金刚华经云。阿难得法性觉三昧之所传也

问。实是耳闻。何故称我闻

答。凡有七义故称我闻。一者佛命令称我闻。今顺佛敕故云我闻也。二者集法藏时迦叶问阿难。佛在何处最初说法。阿难以答僧众称如是我闻。三者以人传法证信故称我闻。所以云说时方人令生信也。四者阿难闻佛所说发生三慧自在称我故云我闻。五者阿难听佛所说。无散乱心如不覆器。无忘失心如不漏器。无颠倒心如不臭器。初是定力。次是持力。后是智慧力。具此三种自在得称为我故言我闻。六者耳别我通。立通废别故言我闻。七者我本耳末。立本废末故称我闻

问。云何闻为以人闻为根为识为尘闻耶

答。因缘故闻。因缘闻即无所闻。故中论云。因缘所生法则是寂灭性。故闻宛然而不闻。亦不闻宛然而闻。以闻宛然不闻故不坏假名而说实相。以不闻宛然而闻故不动真际建立诸法。又闻宛然而不闻故是闻不闻。不闻宛然而闻故则是不闻闻。不闻闻岂是闻。闻不闻岂是不闻。故非闻非不闻名为中道。而闻而不闻称为假名。故论云。亦为是假名亦是中道义。然中假即是因缘。故中称假中。假称中假。中假非假。假中非中。故非中非假。言辞相寂灭。非谓变转前法方称寂灭。即因缘之闻本来寂灭。故此经云。诸法从本来常自寂灭相也

问。作此闻得何利耶

答。此经正明大事因缘。谓开佛知见。佛知见者所谓四智。如来智佛智自然智无师智。以知闻无所闻则生如来智。无所闻而闻则生佛智。斯二任运现前名自然智。此三不从师得谓无师智。闻既生四智。诸有所作皆须精识因缘并生四智入佛知见也。一时者。谓说经有时故可信也。今略明四义。一者佛五十年说法盖是多时。今对彼多时明此经是一时之说故云一时也。二者一谓一部经也。盖是说一部经时故云一时也。三者众生心行可一之时。即是一乘机发说一乘教时故云一时

问。一切经皆云一时。可言并说一乘耶

答。此经云。诸有所作皆为一事。故知说一切教为开一道皆称一时。四者机教符会无差异时故名一时

问。为是假时为是实时

答。正观论云。诸佛或说我。或说于无我。诸法实相中无我无非我。又应云诸佛或说假或说于非假诸法实相中非假非非假

问。云何说假及非假耶

答。化内弟子为结戒故明非假时。通化道俗辨假名时。如论广说也。佛者第四标教主也。所以标佛者凡有五义。一者阿难答迦叶问。迦叶问云。佛在何处最初说法。故标佛也。二者若不标佛直明五事。则不知此经为是魔说为是佛说为内道说为外道说。今欲别邪正内外故标于佛。三者佛法有五人说。一佛说二弟子说三诸天说四仙人说五化人说。今欲明此经是佛所说非余人说故标佛也。四者以后代众生闻是佛说则深起敬信故标佛也。五者为欲成经是故标佛。凡是佛说亦须标佛。弟子之说又须标佛。如维摩胜鬘等经皆标于佛。若不标佛则不成经也。佛有三义。一者自觉异彼凡夫。二者觉他异彼二乘。三者觉道圆满异彼菩萨。若依由来所判明三种佛。悉非觉义。一者若言此经辨佛犹是无常。但是觉于无常未是悟诸法实。故不名为觉。二者若言此经是覆相明常。既称隐覆则犹是未觉。不名为佛。三者若言此经辨佛定是常住。则是常见犹名无明。故不名为觉。今言觉者。觉悟诸法非常非无常亦复非是四句内外。穷了法实故名为觉

问。此经何处有斯文耶

答。寿量品云。如来如实知见三界之相。无有生死若退若出。又无在世及灭度者。非实非虚非如非异。六无四非即其事也。外国名佛以为天鼓。贼欲来时天鼓则鸣。贼欲去时天鼓亦鸣。天鼓鸣时诸天心勇。天鼓鸣时修罗惧怖。众生烦恼应来佛则为说法。众生烦恼应去佛则为说法。佛说法时弟子心勇。佛说法时诸魔惧怖。天鼓无心能为四事。如来虽说亦复无心。是故詺佛以为天鼓也。又如来虽觉实无所悟。喻天鼓虽鸣实无心也。住者今取能住为住故住义属佛。住有二种。一者身住二者心住。身住亦有四。一化处住。十方诸佛各有国土。二异俗住。三世诸佛多栖止伽蓝。三未舍寿分住。佛未答魔王启请寿命无量。由答启请则唯留八十余皆舍之。杂心云。舍第五寿分者。百年之寿二十为一分故有五分。佛答魔王启请舍二十年唯留八十。故云舍第五寿分。法华去涅槃近。应是舍寿分住也。四者威仪住。谓行住坐卧悉名为住也。二就内德论住亦有四种。一者天住。谓住布施持戒等。二者梵住。谓住四无量心。三者圣住。谓住空无相无愿三昧。四者佛住。谓住十力等果地众德。如来具此内外八住。此即是无住而住住无所住。例如文殊不来而来来无所来也。亦如涅槃师子吼辨住沙罗林说。王舍城者第五明住处。说必有处故可信也。异彼外道或言空中授与或言赤鸟[衛-韋+含]来皆无根本。就住处有二。一者明通处。二者明别处。至人形无定方。岂有其常处。但为成信义故须委曲题之。又欲喧静兼化故山城两举。国名摩伽陀此云不害。人虽犯罪无刑杀诛故称不害也。城名王舍。小国即国为城。如毗耶离国亦名毗耶离城。今是大国所以国城为异。具足外国语应云罗悦只摩诃伽罗。罗悦只此翻为王舍。摩诃言大。伽罗云城。十六大国及六大城中而此城最大故称王舍大城。智度论云。佛灭度后阿阇世王以人民减少舍本大城更造一小城。于诸城中犹尚为大。况本王舍城耶。善见毗婆沙云。其城纵广三百由旬。有八亿万户。其属王舍城者有八万聚落也

问。六大城皆有诸王之舍。何故此城独称王舍耶

答。智度论有三解。一云昔摩诃陀王生子。一头两面四臂。时人为不祥裂其身首弃之旷野。罗刹女鬼名利监。合其身首以乳养之。后成大人力能并兼诸国。取一万八千王置此五山。以大力治阎浮提。此意明多王在此城故名王舍城。余二解如论文。更有人言。有王失于正道。千国共废置此五山。退思补过后还共治国。故名此城以为王舍也。真谛三藏引律毗婆沙云。凡转轮王出世相承卜居住此五山。故独名此城以为王舍。又律毗娑沙解云。昔有四天王共攒乳海觅得甘露未分于此五山起舍守之。七日后方乃分是故名为王舍。故前谓人王起舍后即天王起舍。依仁王经云。班足王收得一千王置五山内。亦从多王作名。余城无此众事故独名此城以为王舍城。五山周匝如城。而于中起舍。两事合举名王舍城也

问。若两事合举名王舍城者。不应复有山城二处

答。得王舍城名则两事合说。但王于五山之内别更起城。故有山城二处也。耆阇崛山者此云鹫头山也。然此五山峰各有所像。今之一山似鹫头故以名鹫。佛灭度后阿育王见其山顶似鹫。使人凿作两翅两足及尾故全如鹫鸟。出陆蹬地理记。城山相去凡十五里

问。佛大慈既普。何故多住王舍城说法耶

答。法华论有二义。一欲因处表教。一切城中此城最大。一切山中此山最胜。表法华经众经中胜。二者示现自在功德成就故。言此偏举王舍城为喻。如王于世间自在。显此经是众经之王。以一乘摄一切乘一切乘归一乘故也。释论六种义。一云报法身恩故。如来既本于摩伽陀国成道。为报此恩故多住也。二者彼处地广民多。受化弥广故多住也。三者彼处多聪明大智人。身子迦叶之流长爪六师之例。欲降制之故多住也。四者彼国有龙王兄弟二人。以时降雨国无荒年。出家之人资身既立。则练神亦易故多住也。五者此处多精舍。平地有竹林。伽蓝五山有五精舍。余国既少故多住也。六者此处灵华瑞草闲静清洁。实是众圣之所栖游神仙之所窟宅故多住也。与大比丘众下第六次列同闻众。今就此章略以六门分别。一者来意门。二者定众数门。三者权实门。四者有无门。五者次第门。六者具不具门。来意门者略有十义。一为成阿难闻。以阿难共胜人闻故传经可信。二者为显佛德。以佛为胜众围绕则佛德益尊。既尊其人必受其法。三者为欲开发正经。如因身子三请故得开乘权乘实。由弥勒三请故得开身权身实。四者助佛扬化。如佛三周说法华。诸圣弟子自序领解亦三周而说。弥勒领解称叹其事亦然。五者为欲供养恭敬尊重赞叹于佛。如后文说。六者欲发誓弘经。如持品及神力品说。七者欲引导众生来至佛所。八者欲听佛说法进求深悟。九者为证经故来。如分身佛集。十者为作教门故来。如说妙音观音。即以菩萨而为佛事。是故来也。第二定众数门者。此经始末凡有二会。前集有二十三众。后会有其六众。合为二十九众。言二十三众者。僧众有二尼众亦尔。及菩萨众圣众有五也。凡众有十八。欲界天有十众。三光天子．四王．帝释．自在．大自在也。色界二众尸弃及光明大梵。合十二众。次杂类有其六众。在文易知也。后集六众者。谓宝塔品多宝众．集分身众．集提婆达多品龙宫众．集涌出品下方众集．妙音众集．普贤众集也。第三权实门者。有人言。同开众皆是实行听经之众。有人言。皆是权行影向证经之人。今明此事难知。若皆是实行则失影向之人。若皆是影向则无禀教之众。故须两义双辨。以其为王为主多是权行若是眷属多是实行故。非小非大作小方便引小眷属令同归一乘。乃至非圣非凡作凡方便引凡眷属令共入不二。故华严云。诸菩萨等皆是卢舍那佛宿世善友。涅槃论云。明大众云集多是不思议神通变示分。即其事也。法华论释众有四行。一声闻行。即如此品列诸声闻等。二菩萨行。又如此品列诸菩萨等。三不定行。如善守菩萨示现作四众八部等。四定行。出家人形仪一向定。以此推之知大众具有权实也。第四有无门者。龙树云。小乘经初无菩萨众。大乘经首具大小两众。然斯言未尽。诸大乘经凡有四句。一但有菩萨众无声闻众。如华严七会。二但在声闻众无菩萨众。如金刚般若。三具有二众。即如此经。四俱无二众。如金光明经

问。金光明何故俱无二众耶

答。释迦于时独在鹫山三昧正受。未有众集故无同闻。信想感梦明旦始与大众来至佛所也。第五次第门者。就列众内大开三别。一前列声闻众。二列菩萨众。三列凡夫众

问。若依大数应先列菩萨次列声闻后列凡夫。若从小数应先列凡夫次列声闻后列菩萨。今何故先列声闻次列菩萨后列凡夫耶

答。如华严法界品及五浊经等。前列菩萨后列声闻。此则依其内德从胜至劣以为次第。今前列声闻后列菩萨者。此中列众次第要以外仪具足。声闻心具智断形备法仪。心形两胜是故前列。菩萨心虽会道形无定方或道或俗。此则心胜形劣故在第二。凡夫心形两劣所以居第三。此则是约外仪从胜至劣以为次第也。第六具不具门者。依仁王经。有变化众有缘觉众有无色界众。依陀罗尼经有地狱众。今会所无。依此经后文。具四众八部众及转轮王众。今无轮王。八部之中略无二部。谓夜叉摩睺罗伽众。四众中略无优婆塞优婆夷众也。就列声闻众为二。初僧次尼。何由先僧后尼者。义有七门。一男尊女卑故前僧后尼。二僧前入道尼后入道。三僧为师尼为弟子。四僧传持法藏。故二十五人皆是僧也。尼则不能。五僧能结集大小二藏。尼则不能。六僧与佛同住。尼与佛异住。七僧众多尼众少。就列僧众有二。一前列显名众。二列密行众。初既云众所知识。故知是显名众。次不云众所知识而同得授记成佛。故是密行众。以适化多方故。圣人或显或密。又初纯是无学众故在先。次杂学无学故居后。亦前众数多后众数少故也。就无学众开文为六。一标通号。二唱数。三辨位。四叹德。五列名。六总结。与大比丘众者标通号也。出家未受具戒莫问圣凡通沙弥。具戒以上凡之与圣通名比丘。今言大者。就比丘内有其大小。凡夫三果名小比丘。罗汉之人名大比丘。又罗汉有二种。钝根罗汉名之为小。利根罗汉称之为大。所言大者。智度论云。一切众中最大故。大障碍断故。天王等大人恭敬故。真谛三藏云。大有三种。一者胜大。犹如大王胜一切人故名为大。此诸罗汉于学无学中最胜故名为大。二者形量大。譬如山海以形量大故名大山及以大海。此诸罗汉功德智慧穷高极广故名为大。三者数多故名大。犹如大军以兵众多故称之为大。此诸罗汉数一万二千故名大也。若依此经可有二义。大比丘者标章门也。下之五段释章门也。一者万二千人谓数大也。二者皆是阿罗汉即位大也。三者诸漏已尽谓德大也。四者其名曰谓名大也。五者众所知识谓知识大也。比丘者名为乞士。上从如来乞法以练神。下就俗人乞食以资身。故名乞士。世之乞人但乞衣食不乞于法。不为比丘。又虽复乞食亦异世人之乞。退无积畜之累进有福物之功。故自利利他异于世间乞求之人也。余怖魔破恶净命。如智度论中广说也。万二千人俱下第二唱数。即是释上众义也。四人以上至万二千人以还悉名为众。所以唱多数者。有二种义。一者阿难若与小人共闻不足可信。以共多人同闻方乃可信。二者少众围绕佛德未尊。多众所敬方显德重也。皆是阿罗汉下第三明位。虽唱大比丘未知是何位人。故须明位也。又即以位释大。由位是无学故称大比丘也。阿罗汉是外国语。以三义训之。一者杀贼。以智慧刃杀烦恼贼。此约离因患就现在论也。二者不生。以烦恼糠脱故后世田中更不复生。此约离果患就未来论也。三者应供。具足智断应受供养。法华论凡有十五义释应供。今略举大意。谓内应真理故外应供养。杂心翻罗汉以为无著。故经翻阿罗呵亦云无著。故云如来无所著。至真等正觉也。诸漏已尽下第四叹德。上罗汉明位。今次明行。即位行一双也。二者上虽有多人若无胜德。不足引之为证信及显佛德尊。以有胜德故成上二义。三者皆阿罗汉此标罗汉名也。漏尽以下释罗汉名。即标释一双也。就叹德内以六门释之。一上下门。二总别门。三得离门。四三人门。五三德门。六四智门。上下门者。上下互相释。云何名罗汉。以诸漏已尽故。云何言诸漏已尽。以无复烦恼故。此用下释上。次以上释下。如以无复烦恼逮得已利。尽诸有结故心得自在也。二总别门者。罗汉为总。下四句为别也。三得离门者。叹菩萨以自行化他为主。美声闻宜用得离为宗。此中四句两双明得离也。初双据现在离因患而论得离。次双约未来离果患而论得离也。诸漏已尽此叹离也

问。得离之中何故前叹其离后叹其得

答。凡有二义。一就本意。二约义前后。本意者。声闻之人所以出家修道者。正畏老病死故断贪嗔痴。以贪欲心致病。嗔恚致老。愚痴致死故。法华雇于穷子。正令除粪。盖是小乘之大宗也。二义前后者。小乘之人正欣涅槃无为安乐。但要前断烦恼方得涅槃。故前离后得也。故信解品云。先取其价然后除粪。即其证也。所言诸漏已尽者。略说三漏。欲界烦恼除无明名欲漏。上二界烦恼除无明名有漏。三界无明名无明漏

问。何故诸经不言四流四取乃至十使等尽。而偏言漏尽耶

答。三漏数约义周。又用无明为本。兼以过失彰名。故偏说之。异部人说有四漏。加见漏也。又说七漏者。见漏思惟漏此二是漏体。受漏与念漏此二是就漏因说漏。余根等三种就漏缘说漏也。阿毗昙人以烦恼为漏体。苦集二聚含有于漏故名漏。成论人以失理取相心名漏。心有于漏故名有漏也。无复烦恼者

问。三漏具摄百八烦恼。何因缘故更说无复烦恼耶

答。依智度论。叹离之中凡有二种。诸漏已尽别叹离也。无复烦恼总叹离也。三漏是诸科之一故称为别扼。流结缚缠垢总称烦恼故名总离。谓总别一双也。依法华论。诸漏已尽谓标章门。无复烦恼释章门也。以无复烦恼故诸漏已尽。谓标释一双也。依成论意。以取相失理之心名之为漏。即是根本。十使烦恼名之为枝条。诸漏已尽谓断除根本。无复烦恼则枝条亦亡。谓本末双说也。依毗昙意。得尽智故名为漏尽。得无生智故名无复烦恼。又直依文释者。以诸漏已尽则不复能令心烦。不能令心恼故言无复烦恼也。逮得己利第二叹所得也。烦恼既尽即得数灭涅槃也。涅槃之果但属罗汉不属下三果。故名己利。故鞞婆沙云。解脱之名通学无学。涅槃之称偏在无学。法华论意亦同然。证涅槃故名为己利。又世间之财五家共有不名己利。出世之宝但属行人故名己利。又菩萨修行但为济他。二乘习德但为自己。故名己利也。尽诸有结者。第二双明得离也。有谓三有。结即是感未来三有之结也。以尽感三有之结。结尽故三有亦尽。故云尽诸有结。智度论云。结名九结。谓贪嗔疑慢无明此五钝使以为五结。身见邪见边见此三见以为见结。戒取见取以为取结。合五利为二结也。以十缠中悭嫉二缠以为九结

问。何故偏举悭嫉

答。杂心云。此二但是不善。又是独头而生故偏取之。婆沙云。为帝释修罗故偏取悭嫉入于九结。帝释悭甘露饭嫉修罗美女。修罗悭美女嫉帝释甘露饭也。故说悭嫉入九结中也。心得自在者第二明得也。以不为现在烦恼所使。又不为感未来三有结所使。心得自在。又逮得己利明无为功德。心得自在谓有为功德。故二离而有今后不同。两得则有为无为异。从初以来合是得离二门释竟。四就三人门释者。初三句正释罗汉人德也。尽诸有结者简异学人也。心得自在简异凡夫人。此三人即是次第也。五就三德释者。初之两句释于杀贼。逮得己利释于应供。后之两句释于不生也。六就四智门释者。初两句释我生已尽。逮得已利释梵行已立智。尽诸有结释不受后有。心得自在释所作已辨智

问。此之四句属何智耶

答。婆沙云。我生已尽属尽智。余三属无生智。又解我生已尽是苦智。梵行已立是道智。所作已辨是灭智。不受后有是集智也。其名曰下第五列名。前虽叹德未识其名故须列名也。众经列名凡有二种。一者依德行优劣以为次第。如净名经弟子品说。以命遣使问疾必须智慧辨才故。依德行优劣明次第也。二者此中二十一人皆是序其出家得道前后以为次第也。故十二游经云。初成道第二年为五人说法。第三年化迦叶兄弟三人。第五年度身子目连。以陈如最初得道故最初列也。分别功德论云。佛法最大者谓陈如。最小者谓须跋也

问。何故此经就得道前后明次第耶

答。昔开一为三起自其人。今会三归一亦对之也。以其禀偏化之初故。为今斥夺之本。阿若憍陈如者。此名有本有末。憍陈如者此云火器。是其本姓从姓以立名也。阿若者后得道时加此名也。阿之言无。若之言智。以悟无而生智故名阿若盖是道俗双举。名姓合题

问。余人皆悟无而生智。何故众人不名阿若

答。其人最初得道。悟无在前故受斯目。众人后时得道。更受异名。无量寿经云。尊者了本际即其人也。余处又翻阿若名为初智。阿之言初。若之言智也

问。谁立此名

答。经云净居天见其初得道故呼为阿若也。摩诃迦叶者。文殊问经翻为大龟。摩伽陀国之大姓也。从姓立名。别名必钵罗者。在必钵罗树下生故名必钵罗童子。其家父母祈祷天神。有梵天下降托以生之。如余经广说也。十八部论疏云。具足应云迦叶波。迦叶此云光。波此云饮。合而言之故云饮光。饮是其姓。上古仙人名为饮光。以此仙人身有光明能饮诸光令不复现。今此迦叶是饮光仙人种。即以饮光为姓。从姓立名称饮光也。又此罗汉亦自有饮光事。其人身有金色光明。以阎浮檀金在水底而金光彻出水上。转轮圣王出世时夜叉等取此金。将来人间博易。故人间有此金。此金在人间人间诸金不复现。此金犹不及迦叶金色。是故亦名饮光也。优楼频螺迦叶者。此下三人则是兄弟。非大迦叶流。优楼频螺者此云木苽林或云优楼频螺聚落者。林处即有五百家。故翻经者两事互举也。在此林中修道故以为名。前出经云上时迦叶也。伽耶迦叶者伽耶者城名。此云铁杖城也。在城处修道故以为名。前出经云象头迦叶也。彼处有象头山。从山为名也。以彼处有城故两出耳。那提者河名也。前出经云江迦叶。舍利弗者。具足应云舍利弗罗。舍利言身。弗罗言子。略于罗字但言弗也。名舍利弗有二因缘。一从过去誓愿立名。释迦过去作瓦师。值释迦佛发愿。愿未来作佛名释迦。弟子名舍利弗。故从本愿立名也。二者从母立名。以母眼似舍利鸟眼故名母为舍利。其母于众女人中聪明第一。以世人贵重其母故呼为舍利子。此世人为作名也。古经名鹙鹭子。鹙鹭子犹取鸟名也。或言舍利鸟似于鹙鹭也。父名提舍。逐父为名故名优婆提舍。优婆者逐也。提舍者星名也。又经云佛初见二人来。令改提舍之名。可复本字为舍利弗。以过去本愿名舍利弗。故令改今世之名也。目连亦尔。目连者姓大目连也。是其母姓。此云赞诵亦云莱茯根。字俱律陀。父母无儿祷俱律陀树神因生是子。故以树为名也。真谛三藏云。应言勿伽罗。勿伽者此言胡豆。即绿色豆。罗此云受。合而为言应言受胡豆。盖是其姓。上古有仙人名勿伽罗。不食一切物唯食此豆故名受胡豆。其是仙人种故以为名也。迦旃延者旧翻为肩乘。此两字误也应云扇绳。其父早亡。母恋之不嫁。如绳系扇故名扇绳。三藏云。上古有仙人名柯罗。此云思胜。此仙人具足闻思胜于余人故云思胜。其是仙人种故名思胜。注法华经云。姓迦旃延是其门徒中之长故称为大。今谓应如注释。智度论云。有婆罗门道人姓迦旃延。不应亦有扇绳之喻用以为名。但迦旃延既是其姓。扇绳即是其名也。阿菟楼驮者翻为如意亦云无贫。以过去一食施辟支佛。十五劫中天上人中受于福乐。最后得罗汉常得如意无有贫穷。是甘露饭王之子也。劫宾那者此云房宿。在僧房而宿。佛见其道缘将发。化为老比丘与之共宿。因之以得道。故以名焉。又云以祈祷房宿星生此子故以为名。又言劫宾那者国名。以从国受称也。憍梵婆提者此云牛齝。无量寿经云。尊者牛王过去世曾作比丘。于他粟田边摘一茎粟。观其生熟数粒堕地。五百世作牛偿之。今值释迦得道。足甲似牛食后犹齝。因以为名也。佛恐凡夫笑之得罪。徙置忉利天上尸利沙树下。即舍利弗上足弟子。解律并于优婆离。佛灭度后于天上般涅槃也。离婆多者此云假和合。如释论二鬼食人事也。亦云离越也。无量寿经云尊者大号也。毕陵伽波蹉此云余习亦云恶口。佛在世时此人除佛已下一切比丘皆称乡汝。乃至骂恒河水神。佛因诫之。自今已后。勿作乡汝之言。向尊长忆佛语故遂便改之。其五百世作波罗门故有此慢习也。又释姓毕陵伽名婆蹉也。薄拘罗者此云善容。持一不杀戒得五不死报。一釜煮不死。二熬盘不焦。三水不溺。四鱼腹不烂。五刀刃不伤。经云出家以来八十岁。眼不视女人面。不入尼寺。亦不为女人说于一偈。阿育王历诸塔供养多有布施。至薄拘罗塔闻其在世少欲知足不为女人说一偈。乃以一钱施之塔遂不受。阿育王言是真少欲乃至不受一钱也。摩诃俱絺罗者此云大膝。身子舅长爪梵志是也。难陀者此云欢喜或云是牧牛。难陀待阿由村人方乃得道。或言犹是释种。释种有十万人出家。难陀为其一人也。性最轻薄而聪明。音声绝妙也。孙陀罗难陀者此是佛弟难陀。是大爱道所生。身长一丈五尺二寸。佛到迦毗罗城二日即度之。孙陀罗者此云端正亦云柔软。欲异前者故以妇标名焉。富楼那者翻之为满。王舍城婆罗门儿。其祖父母将其所生父母。江边祠天乞子。设华香供养梵天。及诵诸咒。母夜梦见。有人以器盛满杂宝持授与之。其安置腹前而宝器忽然入腹。觉后向夫述之。夫答妇云。必是梵天与汝儿。此儿后当宝器具足一切能知。因此遂生儿。太聪明遍学世伎术。出家后得罗汉。佛说法时能诵持之善解其义伏诸外道。从梦宝器及所知二事作名故称为满也。弥多罗者此云慈行。四韦陀中有此品名。其母诵之。从所诵立名故名慈行。尼者翻为女。天竺名女为尼。名男为那。但名富楼那者多故以母名标之。大意者云。满者盖是慈行女之子也。旧云富楼那不异上。弥多罗此云善知识也。余处或云满愿子也。须菩提者此云空生以是生时诸物皆空相师云。此儿必解空第一。故名空生。亦云善吉。舍卫国有长者名拘留。无儿乞天神得之。后长大请佛出家。因随佛往祇洹精舍作比丘。阿难者此云欢喜。一者形容端正见者欢喜。二者佛得道夜生。谓欢喜日生名欢喜。三者过去发愿愿名欢喜。支道林云博门。又云无染着。其人初果具足烦恼见天龙女不起染心。故云无染也。是斛饭王之子也。罗睺罗者此云覆障。以六年在胎为胎所障故云覆障。三藏云。本是阿修罗名。此阿修罗能以手障月。若具翻之应云障月佛子。所以作此名者是借喻为目。佛自说。我正法如月。此儿障月。欲出家学道有儿则成障也。虽复是障而如来能舍之。佛自说。过去世罗睺罗数数为道作障。我亦数数能舍之。又名宫生。佛出家后而耶输有身。诸释种诘之。耶输云。乞待生子后当证验。生子已后耶输燃大火聚抱子而立誓曰。若非佛子当母子俱烧。遂投火聚便灭而母子无他。诸释种曰。真是宫生。佛到迦毗罗城七日即度之为道。如是众所知识下第六总结。大阿罗汉者。法华论云。到彼岸故名大阿罗汉。杂心称为波罗蜜声闻。犹是一义耳。众所知识者。法华论明二种众。一者人王天王大众所知识。二者声闻菩萨佛圣众所知识。知其内德识其外形。又远众则知。近众则识。有知而不识等四句。复有学无学二千人下。此第二列密行众。六段之中但有位之与数。三果为学。罗汉为无学。并是会理之心。有进求之与满足故云学无学。此既是密行人。多是大权。宜约菩萨明学无学。初地以上七地以还有功用道名之为学。八地以上无功用道称为无学。故大品明菩萨有学无学地。即其事也。又解前是大罗汉。此二千人德业未充非众所仰。故别说也。摩诃婆阇婆提下第二列尼众。对于僧众亦开为二。初列大名闻众二列小名闻众。摩诃婆阇婆提者此云大爱道。耶输多罗者此云名声。别有经云。是揵挞婆女。揵挞婆生男为乐神。生女为玉女诸女中有名声也。此二人有前后者。俗礼姨妻尊卑。内律则婆阇入道为前。耶输在后也

问。未曾有经须太拏经及瑞应经皆云。罗睺罗是瞿夷之子。至如法华所辨。是耶输之儿。经云耶输是第二夫人。瞿夷是第一夫人。故十二游经云。太子有三夫人。第一名瞿夷。第二名耶维。耶维即耶输陀罗也。第三名鹿野。三夫人各领二万采女。故太子有六万采女。何故二说不同

答。罗睺罗实是第二夫人儿。瞿夷是其大母。余经举其大母。今经举所生母故不相违。瞿夷此云明女。大智度论云。瞿毗陀是宝玉女故不孕子。瞿毗陀谓瞿夷。即其证也。又经云佛有三子。一善星。二优婆摩那。三罗睺罗。即三夫人所生。而复瞿夷不生子者。取前大母所养为名也。注经云。诸尼之中举姨妻二人者。岂唯标亲以兼疏。乃因名以托旨。净名经云。智度菩萨母。方便以为父。法喜以为妻。欲明虚己修度则从生之义显。灭累体法则伉俪之业成。寻言求意。可不触像而置心哉

菩萨摩诃萨者第二列菩萨众。所以列菩萨众者凡有三义。一者欲证阿难闻经可信。阿难若共小乘人。闻大法未足可信。今共大人而闻大法则可信也。二者佛为小众围绕其德未重。为大人羽翼佛德始尊。三者欲显是大乘经。以声闻经初无菩萨众故也。就文有六。一标通号。二唱数。三明位。四叹德。五列名。六总结。具足应云菩提萨埵。菩提云道。是无上正遍知果道也。萨埵云众生。为求果道故名道众生也。旧名道士。其言最胜。而即世学张李之道本名治头及鬼卒。后盗取佛法道士之名也

问。三乘人皆有菩提。何故初二不名道众生

答。欲显三乘优劣义故。小乘道劣。从声教立名故云声闻。中乘小胜。从义立名故云缘觉。然十二缘是法义也。大乘为胜。从果德立名。又初二非是中道。故不与其道称。后是中道。故与其道名。摩诃萨埵者。摩诃云大。十地论云大有三种。愿大行大度众生大。萨埵云众生则大众生也

问。何故声闻缘觉但有一名。菩萨具于两称

答。二乘但能超凡故但立一名。大士德踰凡圣故有其两称。言菩萨者异彼凡夫。以凡夫不求于道故非道众生。摩诃萨者。简异二乘亦求于小道。今明求于大道故名大众生。摄大乘论疏三义释之。具般若故名菩萨。具大悲故名摩诃萨。具实慧故名菩萨。具方便慧故名摩诃萨。具智慧故名菩萨。具福德故名摩诃萨。此即内得中道正观故。依德立中道名也。八万人下第二唱数。上虽标通号未知凡有几人。故次明数也。皆于菩提不退转者第三明位。上虽明其数但有菩萨略广二位。略说则十四贤圣。广说则五十一位。十四贤圣者。外凡与内凡三贤并十地也。广说五十一位者。十信十住十行十回向十地等觉地也。妙觉地属佛地。非菩萨地摄也。今未知是何位人故。次明是不退转位人也。然经文直言于无上菩提不退转。但旧明有三种不退。一位不退。二行不退。三念不退。释三不退不同凡有四说。一云十住前六心假解未立退菩提心为二乘。七心以上假解已立名为菩萨。独成性地此免位退。二者行退。初地至六地此中诸人习行有时不进名为行退。七地则无此行退也。第七一地或起爱习犹有功用名为念退。八地已上入无功用道永无三退故名不退转也。二云外凡六心名为位退。七心已上称位不退。余二不异前释也。三云习种性名位不退。道种性解行纯熟谓行不退。初地已上得无生忍不复生心动念名念不退也。四有人言有四种不退。十信十住是信不退。十行是位不退。十回向是行不退。十地是念不退。今谓经论不同难可详会。本业璎珞经云。十住第六住犹退作五逆。况复二乘。而十信第六信名为不退心。则知六信以上便是不退。地持论云。种性菩萨或进或退。则与本业大意略同。然多是外凡第六心免位退也。所以知然者。十信中前五则是五根未立。第六称不退心。五根既立故后得不退。则知六心以上无有退也。又经云。十信菩萨十千劫行道。摄大乘论明一阿僧祇劫修行。而舍利弗六十劫行道六心中退中者。此则是仰学六信犹未登六信也。而璎珞经云六住退者。龙树释此语云。欲怖地前菩萨令速入初地故云退耳。其实不退。今经云不退转者。法华论云。盖是八地已上不退位人也

问。析罗汉经云。七地不退。故阿鞞跋致明七地事。般舟三昧明八地事。首楞严三昧明十地事。今云何言八地不退

答。七地得无生忍名不退。八地得无功用故名不退。故第八名不动地也

问。不退与不转何异

答。释弥勒所问经论云。得内分功德为不退。得外分功德为不转。又云得智慧为不退。得功德为不转。又云得般若为不退。得方便为不转也。法华论意云。八地无功用不为功用所动。复不为上地所动。自然而行故名不退也。皆得陀罗尼下第四叹德。所以明叹德者。上明位今辨行。位行双举。依法华论。上总明不退。今别释不退也。依智度论云。上标菩萨摩诃萨名。今明具此德故名菩萨。即以德释名也。又欲简秘密显示两教。显示教谓小乘教。明菩萨犹是凡夫。今叹菩萨得无生忍具六神通烦恼清净。谓秘密大乘教也。又叹菩萨令寻经之人舍小信大也。就叹德文开为四别。一叹现德。二叹往因。三叹实体。四叹美名誉。初谓因果两美。后则体名俱叹。略摄菩萨德也。叹现德中。前叹自行后叹化他

问。何故前叹陀罗尼

答。有二义。一者陀罗尼是能持。下诸德是所持。故前叹其本后是叹其末也。故净名云。总持为园苑。即是其证。二者小乘法中不说陀罗尼。今叹大乘菩萨。故前叹总持

问。小乘法中何故不说总持

答。小乘人畏生死苦速欲证涅槃。不欲广修诸行。是故不说。菩萨既遍度众生备修诸行。欲令终身不失历劫逾明。故佛为说此法也。总持二义。一持善令不失。二持恶使不生

问。以何为持体

答。智度论云。或说念或说定或说慧。今明即一正观随义异名。忆持不失能照法实名为般若。故论云。在声闻心名道品。在菩萨心名陀罗尼

问。此中明何等持

答。法华论云。是闻持陀罗尼。然法身菩萨应具闻义等持。今略说初一耳。乐说辨才下第二次叹化他。上是能持。今明所持。以内含总持之德外有悟物之辨。然菩萨具四无碍。今辨化他德故略举最后乐说辨。又持举其初。辨题其后。互文现意也。言乐说者凡有二义。一者菩萨自得胜法乐为物说。譬如父母得于胜事乐欲与子。二者知众生欲乐而为说法。以备此二也。所言辨者有其通别。若对境辨了者四皆称辨。若在眼为明。在耳为聪。在心为智。在口为辨。此别辨也。速疾应机名辨。言含文义名才。转不退转法轮者。初明闻法不忘。次明内知机欲外有无方之语。备此二能方为物说法。今正明所说之法。即三句次第也。无生正观体可楷模。故名为法。流演圆通不系于一人。故称为轮。又无生正观无累不摧。亦是轮义。一得不丧名为不退。自我至彼故称为转

问。此叹何位人

答。依法华论。初明不退转叹于八地。皆得总持乐说之辨叹于九地。以九地菩萨得胜进陀罗尼及十种四无碍智。堕大法师位。转不退轮叹于十地。唯佛能转法轮。十地菩萨既受佛位。当知如佛亦能转也。供养无量百千诸佛下第二次叹往因。以现德由于往因故。叹往因释成现德。以果着因微故。前叹现果次叹往因。亦有二句。初明供养于佛者。佛是众生真善知识。上诸功德由佛而有故明供养于佛。供养者或财法二种。或身口敬叹总名供养也。于诸佛所殖众德本者。八万四千诸波罗蜜名为众德。以此众德作菩提根故称为本。大士奉教修行目之为殖。又众德者佛果德也。修行众德之本。同净名经大智本行皆悉成就也。常为诸佛之所称叹者。上明行由佛成。今辨道与佛会。若修行有所得善。则行与佛乖非菩提根。故为佛所呵。今修行无所得善。则道与佛会。故为佛所叹也。而言常叹者。以菩萨常习无著之观。不令一念有得间心故。常为佛所叹。法华论云。以断疑故为佛所叹也。以慈修身下第三次叹实体。亦有二句。初叹身次叹心。大士既自植德本。今欲令众生同种善根故为物受身。所以叹身也。凡夫二乘由结业所薰故身受三界。菩萨以无缘大慈故能垂形六道。故肇公云。法身无生而无处不生。以无生故诸趣门闭。无处不生而生五道也。善入佛慧下第二叹心。又前是叹功德。今叹于智慧。智度论云。七住菩萨定慧平等得无生忍名入佛眼地。但由犹是功用未称为善入。今叹八地无功用心名为善入也。通达大智者。经论之中多说慧门鉴空智门照有。上入佛照空之慧。即是以般若心入萨婆若。今通达大智以菩萨方便入佛一切种智。故以菩萨二慧为能入。如来二智为所入。然二慧二智更无两体。以明昧不同故开因果之异。所以云在菩萨心名为波若。在佛心中变名萨波若也

问。法华论云。通达大智者即是照空之智。云何鉴于有耶

答。已如前释。经中多说照空为慧。照有为智。论今以照空为智。照有为慧。复有此一种义也。亦得智门具照空有。故波若三慧品云。知一切法一相故名一切智。又云知种种相故名一切种智。在智具照空有。慧义亦然。到于彼岸者。前叹能照之二慧。此叹所照之两境。以穷了真俗之原称到于彼岸。故大品云。到有为无为彼岸。即其事也。又前叹能了佛之慧。佛慧者谓了菩提果。今叹到彼岸。了佛大涅槃之德也。又前叹观无不明。今叹累无不寂即是寂灭之岸。如下文云本来寂灭。即涅槃也。名称普闻者第四次叹名誉。亦有二句。以德充于内故名流于外也。能度无数百千众生者。德树名流故度物功立。此中四对称叹皆有两句。又并是钩锁相生。可细寻其文旨也。法华论以四方便摄此诸句。一者摄取妙法方便。谓初得闻持陀罗尼。次得乐说辨才。后为人转法轮总此三句名摄取妙法方便也。二者摄取善知识方便者。谓供养诸佛种诸善根常为诸佛之所护念。由依止善知识故得种诸善根。故为佛所护念。名摄取善知识方便也。三者摄取众生方便。谓不舍众生故。即是以慈修身故不舍众生。四者摄取智方便。教化众生令入佛般若智。即是善入佛慧竟于后文。名摄取智方便。此四方便即是次第。可细寻之也。其名曰下第五列名。上虽总叹其德。犹未别出人名。故次明列名也

问。此中列十八人名。何故文殊在初

答。日月灯明佛因妙光菩萨以说法华经。释迦牟尼佛因文殊师利以说法华经。既有开教之功故列在初也

问。云何因文殊说此经耶

答。由文殊释时众之疑辨古佛说之于前释迦敷之于后。预杜疑谤之萌。逆开信解之渐。然后释迦始得起定说法。故言因文殊以说法华经也

问。何故不因余菩萨而因文殊耶

答。由文殊故得开乘权乘实。故因文殊开前分经也。由文殊是燃灯之师燃灯复是释迦之师。因此覆远之言。得说身权身实。则开后分经也。下文当具明之。又河西道朗云。文殊是游方菩萨。十方法会多为开发之端。故偏因文殊也。又文殊是北方欢喜世界欢喜藏摩尼宝积佛。今犹现在闻此佛名者能灭四重等罪。今示为菩萨影向释迦。有此功德故在初列之。又文殊具三世佛。过去世为龙种尊佛。现在世为摩尼宝积佛。复当来作佛。是故初列也

问。大品亦在王舍城说。何故以跋陀菩萨在初耶

答。跋陀是王舍城旧人。大品佛自开经。故客旧为次第。法华因他开经。故以文殊为初首也

问。大品何故佛自开。此经因他而开

答。大品显教菩萨作佛。其义易解。以菩萨无自保之执。又菩萨利根故也。此经显教声闻。声闻有自保之执又是钝根故因文殊以开经也。文殊此言妙德。以了了见于佛性故。德无不圆累无不尽称妙德也。观世音菩萨者下品自广释也。大势至者所经之处世界振动恶道休息也。常精进者。以众生常有诸苦。是故大士恒须济拔。故言常精进也。不休息者上以进求为名。今从离过受称。如救头燃不可暂休息也。宝掌者掌出众宝惠施无竭也。药王者。过去世以药救病。因以为名。但菩萨有二种身。一如意珠王身。能与一切乐。依此立名故云宝掌也。二药树王身。见闻之者无不苦灭。依此立名称药王也。勇施者。大士了毕竟空。舍身命财不生怯弱。故云勇施也。宝月者。以慧明凉气清人三毒热恼。其珍如月也。月光者。慧能破闇如月之光也。满月者。德无不圆照无不普也。大力者。约事而言。能动大千为大力。据理言之。有得烦恼能令三界纷纶二乘迷倒。其力最大。菩萨能摧此大恶名大力也。无量力者。约事能举十方为无量力。据理者无相之力不以有量为名也。越三界者。慧踰生灭道跨三有也。跋陀婆罗者此云贤守。邻极亚圣曰贤。弘道能固称守也。宝积者。财法二宝积累兼充也。弥勒者此云慈氏也。过去值弥勒佛发愿名弥勒也。出一切智光仙人经。弥勒昔作一切智光仙人。值慈氏佛说慈心三昧经。故曰慈也。华严经云。初得慈心三昧故名慈也。导师者。以法引物妙达正邪。如海导师善示夷崄也

问。庄周尚云。至人无心神人无功圣人无名。法身菩萨形不可以像恻。心不可以智知。何故乃为立名耶

答。涅槃经云。低罗婆夷实不食油强名食油。涅槃亦尔。无名相中强名相说。涅槃是所体之法。今既无名强立名。体道之人亦无名强立名。此是一往之言耳。犹未足简于内外。然至人非名非无名。能名能无名。虽能名能无名。不动非名非无名相。故天女之诘身子。汝虽知解脱无名。而未悟名即解脱。今亦然也。如是等下第六结句也

问。菩萨数多。何故但标十八

答。虽明十八。摄无不周。但贤守等是在家大士。文殊等是出家菩萨。又弥勒等当成佛菩萨。观音等是已成佛菩萨。又弥勒是此土观音是他方。又贤守等是王舍城旧人。宝积等是毗耶离客众。以此四双总摄八万也。尔时释提桓因下第三列凡众。然上明声闻菩萨。必是圣众。今既不入大小两圣故迹示凡夫。故说为凡众。然诸佛降生有诸同行各散身六道。佛说法时皆引其眷属同入一乘。故就主而言多是方便也。就文为二。一列幽众二列显众。幽众道胜有大势力故前列。显众道劣无势力故后立也。即是从胜至劣。如上声闻胜菩萨僧众以胜尼也。前客众后是旧众也。就幽众之内凡有六众。如文所辨。六趣之中但无地狱众。由苦重故不来。陀罗尼经明有地狱众。别有因缘。如彼文释。三界之中无无色界众者凡有二义。一者大小乘经多说无色界无形不能来听法。二者设微细之形以无因缘故则不来也

问。但大乘明无色界有细色形。小乘亦有此言不

答。阿含经云。无色界天见身子涅槃泪下如雨。则知小乘亦明有色。但从多为论言无色耳。八部之中无夜叉及摩睺罗伽者。以略故尔也。初列天众为二。前列欲界天众。次色界天众。然上来列众多从胜至劣。今从劣至胜者可有二义。一者显小乘意。欲界天有初入圣道。色界天不能。即是从胜至劣。二者欲天是佛檀越。为地住天以去佛近故前说之。释提桓因者。具足外国语应云释迦提桓因陀罗。释迦为能提桓为天因陀罗为主。以其在善法堂治化称会天心故。称为能天主。而云三十三天者。三十二为臣。四厢各八臣故三十二也。而一天为主故三十三天。大智度论云。三藏中明释提桓因得须陀洹果。摩诃衍中说为法身菩萨也。又释提桓因姓。憍尸迦名。本是摩伽陀国旧人故初列之。复有名月天子者。注解云帝释辅臣也。有人云月天子即月天也。普香天子者谓星天也。宝光天子者谓日天子也。既是三光故后列之。出正法华经。复有经云。观世音名宝意。作日天子。大势至名宝吉祥。作月天子。虚空藏名宝光。作星天子也。四大天王下。长阿含经世记四天王品云。须弥山东千由旬有提头赖吒天王城名贤上。纵广六千由旬。其城七重众宝严饰。须弥山南千由旬有毗留勒叉天王城名善见。须弥山西千由旬有毗楼博叉天王城名周罗善见。须弥山北千由旬有毗沙门天王城。有三名。一名可畏二名天敬三名众归。纵广六千由旬。又智度论云。东方天王名提头赖吒。此名治国主。领揵挞婆及毗舍阇二部鬼神。护弗婆提人不令侵害也。南方天王名毗留离。此名增长主。领鸠槃荼及薜荔多。护阎浮提人不令侵害也。西方天王名毗留博叉。此云杂语主。领一切龙及富单那。护瞿耶尼人不令侵害也。北方天王名毗沙门。此云多闻主。领夜叉及诸罗刹。护郁旦越人不令侵害。故名护世四天王也。自在天子下注解云。自在天子即是帝释主兵大臣也。大自在天子者。是摩醯首罗即帝释师也。今谓上列欲界初二天。帝释为主三光四镇为臣。今列欲界化自在他化自在后二天也。何故不列炎摩天兜率天者。以先后列者中间可知故不列也。娑婆世界主下第二次列色界天众。娑婆世界此云杂恶亦云杂会。大梵天王名尸弃者。有人言。大梵天王即初禅梵王。尸弃即二禅梵王。光明大梵即三禅梵王。言等者第四禅也。光宅所用是也。有人言。娑婆世界主者摩醯首罗第四禅梵王也。尸弃者三禅梵王也。光明者二禅梵王也。等者初禅梵王也。今依智度论第一卷云。娑婆世界主梵天王名尸弃。娑婆世界主。此举处以显其为主也。大梵天王出其位也。尸弃者标其名也。新金光明亦作此释。尸弃者此云火。有人言。此梵天王入火光定。顶有火光故言火也。有人言。余梵天皆为火灾所烧。独此天火灾不烧故云火也。又翻为顶髻。有人言。顶上有火如髻故云顶髻也。长阿含云。尸弃是初禅梵王。亦名鸠摩罗伽此云童子天。此天颜如童子故以名焉。手擎鸡持铃捉赤幡骑孔雀也

问。十地经云摩醯千世界主。今云何言初禅梵王为三千世界主

答。有四种梵王。一者经云。百亿日月百亿梵王百亿非想此是下品梵王也。二者智度论云。梵王千世界主。长阿含亦然。此是次品也。三者九地菩萨作梵天王领二千世界。此是上品也。四者领三千大千世界。此是上上品也。魔王转轮王亦有二种。大集经云。有魔王领三千世界。大品云。化作转轮王亦领三千世界。故不可一途而判也

问。尸弃是大千之王。在何处中间禅住耶

答。百亿中间禅。今在中央住也。例如佛大千中央住也。光明大梵者二禅梵天也。故二禅称光音少光无量光也。略举初二等后二也。有八龙王下第二次列龙众。然龙是畜生劣于余道。次天列者凡有四义。一其力最大故五不思议中龙为其一也。二正法念经云。恶龙助修罗善龙助天。今是善龙故次天列也。婆沙云。天将阿修罗斗时。前令龙与之斗。故知龙助天。三调适阴阳于人有恩故次天列之。四护持千佛经藏次天列也。外书说文云。龙是有鳞虫中之长。能小能大能幽能明。春则升天冬则入渊。广雅云。有鳞者为蛟龙。有翼者为飞龙。有角者为虬龙。无角者为螭龙。佛法中明有四生龙。一者卵生金翅鸟能食卵生龙二者胎生金翅鸟能食胎卵二龙。三者湿生金翅鸟能食三龙。四者化生金翅鸟具能食四生龙也。难陀此云欢喜。跋难陀此云贤欢喜。此二龙王是兄弟。常令风不摇条雨不破块。见者欢喜故云欢喜。又是王舍城旧住故初列之。娑伽罗者。有人言从国立名。住在娑伽罗国。此国近仙人而住。王触忤仙人。仙人咒此国令成海。此龙居住其中。从本国立名也。有人言娑伽罗海名也。和修吉此云多头。则九头龙是水生龙也。德叉迦此云多舌。居在地上也。阿那婆达多此云无热。一者从池作名。此池在香山顶阎浮提北天齐星下。其水清凉故称无热。池内有五柱堂龙在其中也。智度论云是七住菩萨。华严云于大云阴覆离苦法门而得自在。又言无热者。一切诸龙有三种苦。一者风吹热沙着身身肉烂坏。二者风吹宝冠衣服悉皆散失龙身露现。心生热恼。三者诸龙眷属娱乐之时。金翅鸟入其宫内取眷属去。心生热恼。又经云。诸龙食好香饭变成虾蟆。又身有逆鳞土石入其身内。又作欲时龙身露现如两蛇相结。此龙无此诸苦也。摩那斯者此云慈心。华严经云。将欲降雨先。七日兴云待营作事竟。然后乃注雨。即慈心证也。亦云悦意。沤钵罗者从莲华池作名也。有四紧那罗者

问。紧那罗何道摄

答。杂心云是畜生道摄

问。常列八部在揵挞婆后。今何故在先

答。揵挞婆是鬼神道摄。紧那罗既是畜生故在彼后。今以其奏法乐故在初列之。紧那罗此云疑神亦云人非人。其形似人而头有一角。疑者云人耶非人耶。遂以为名。紧那罗王名为屯仑摩。弹琴叹佛乃至迦叶不能自安也。言法者奏四谛法也。妙法者奏十二因缘法也。大法者奏六度法也。持法者总持上三法。即是奏陀罗尼曲也。揵挞婆此云香阴。以其清虚食香。又身唯恒出香故名香阴。大智度论云。揵挞婆王名童笼摩此云树。居在地上十宝山中。诸天欲作乐时。身有异相即飞上天。与紧那罗番休上下。初言乐者无声之乐也。次是有声之乐。次是无声乐中之胜。次是有声乐中之胜也

问。揵挞婆属何道摄

答。一云属鬼道。一云阿修罗道也。阿修罗者此云无酒。或云过去持一不饮酒戒报得此身。或云集诸华酿海为酒而不成故云无酒。毗婆沙云。阿之言无。修罗云端正。谓无端正。以男丑女好故也。释道安道行经胡音云须罗此云质谅。以其多谄曲故为立此名。令其质直诚信也。谅即信也。婆薮传云非天。亦言非善戏乐。诸天以善法戏乐。其多作不善戏乐也。婆稚者此言缚。其人是修罗中前峰。与帝释斗时被缚因誓得脱故以为名也。又翻为最胜

问。修罗何故常与帝释战

答。婆沙云。修罗有美女而无好食。诸天有好食而无美女。互相憎嫉故恒斗战也。佉罗骞太者此云广肩甲。又云宝锦又云欲锦也。毗摩质多罗者此云响高。以其于大水中出大音声自唱言我是毗摩质多罗故云响高。亦云种种疑。又云穴居者最是海下住也。故修罗有二处住。一者地上众相山中其力最劣。次在须弥山北入海一万二千由旬有罗睺阿修罗王。领无量阿修罗众。次罗睺下复一万二千由旬有修罗名勇健。勇健下一万二千由旬有修罗名美鬘美鬘下一万二千由旬有修罗名毗摩质多。故称穴居也。阿含经云。光音天入海水。精流水内遂成一卵。经八千岁生女修罗。身若须弥千头少一。水触女身生毗摩质多。形四倍大母。九头八脚千手少一。纳香山揵挞婆女生舍脂也。罗睺者此言覆障又云吸气。正法念经云。修罗有鬼有畜。罗睺是师子种。婆沙云伽陀经云有鬼有畜有天

问。何故修罗手障月

答。婆沙云。月是帝释军前峰。故以手障之而欲食月。正法念经云。日月放光障修罗眼。令不见天众故以手障之。迦楼罗者此云金翅鸟以其翅头即有金色故以为名。海龙王经翻为凤凰。大威德迦楼罗王者。食龙之时有大威德故以为名也。大身者。经云两翅相去三百三十六万里也。阎浮提只容其一足。大满者。余鸟食龙多不饱足。此鸟恒饱满故云大满。如意者。此鸟颈下有如意珠。或言不可动也。有人言。食三生龙者名大满。具能食四生龙势力自在故称如意也。韦提希子下第二明显旧众。韦提希翻为思惟亦云四维。阿阇世者此云未生怨。以母标之者。尔时以害父竟故不标父也。又言掷之于地遂折其指故名折指。阿含经云。世王忏悔竟犹堕拍掬地狱。后从地狱出成辟支佛。涅槃经云。阿阇世王不值耆婆。来月七日当堕地狱。而忏悔竟不复堕。又经云。忏悔竟得柔顺忍。所以大小乘经不同者。以小乘经力劣故重罪微薄犹堕轻地狱。大乘经力胜重罪都灭所以不堕。又阇王害父身疮未发故来听法华。至涅槃时身疮发者。涅槃经既唱当灭五逆之罪。阇王是权行。欲显正教能灭罪邪教不能灭罪。为众生作灭罪良伴故至彼发也。此经不明灭罪用。故身疮不发而明功德胜用。一毫之善皆得成佛。世王虽作五逆不断善根亦当成佛。为众生作成佛良伴。为此义故来听法

问。涅槃经明阇王忏悔得无根信。余经云得柔顺忍。柔顺忍二处。一十回向心二六地。云何会通

答。涅槃据其迹明是罪人故但得信心。若言得柔顺忍者。众便谓实犯罪人则不灭。他经据本故得顺忍。又浅深随缘也。各礼佛足退坐一面者。智度论云。俗人是客来至佛所。是故听坐。声闻菩萨位居弟子。是故侍立。亦可大众集竟。今总结众集仪则故云礼佛而坐也

法华义疏卷第一

永仁癸已无射上旬投广隆寺众徒之净财雕义疏第一卷之印板窃以汉帝梦于金人余一千岁日域传于上乘至七百年而终未闻三论真宗开板何况一乘法华义疏哉爰素庆虽生扶桑之边方幸遇昙华之妙典斯疏若不流通弘经恐亦壅塞因兹赑屃欲终一部大功劝化开阐法华宗旨庶几沾妙道于像末万年之空捶法灯于龙华三会之晓荡四生妄执觉八不正观矣

            都干缘沙门　素庆谨志法华义疏卷第二

        胡吉藏撰

    序品之二

尔时世尊四众围绕下此第二明开发序亦有六章。一众集序。二说经序。三入定序。四现瑞序。五疑问序。六答问序。及前证信序合十二序也。由众集故说经。说经故入定。由入定故现瑞。由不了瑞故生疑。以有疑故须答。由此六事开发正宗故名开发序。所以后文云。今佛放光明助发实相义也。问此六云何得开法华。答由大众云集即是教所为缘故得说教。故众集为序。将明收三归一。先明从一生三。故说无量义为序。由佛入一道清净三昧。表说清净一道。故入定为序。将说究竟之乘。先现究竟之相。故现瑞为序。由现瑞发动疑问。得请文殊答。故疑问是序。由文殊答问。佛方得起定说经。故答问是序也。六事为三。初一是教所为缘中。三是能化之教。后二是菩萨发教也。中三即以三事为法华相。初一是口业明多从一生。表法华收多归一。次一是意业表佛入一道三昧后起定说一乘道。次一是身业表佛说一乘相。又表众生闻经成佛。尔时世尊者标化主。四众围绕者法华论云。从此讫尊重赞叹犹是结众集。名为威仪如法住成就。明上大众天龙云集。威仪者即前后围绕乃至尊重赞叹也。今明若望前通序即属第六同闻众摄。若望后即是开发正经序摄。所以然者。由四众云集兴三业供养。即是渴仰欲闻。是故如来为说法也。四众者有人言。天有二众谓魔众梵众。举欲色天之大者也。人有二众沙门婆罗门。智度论云。智慧人开为二分。在家曰婆罗门。出家目为沙门。佛既是天人师故举此四众也。顗禅师云。一影向众谓在座默然。二发教众谓发起佛教。如身子之与弥勒。三当机众正禀教领悟。四结缘众闻即未解但结远因缘。今谓就此经文有二种四众。一者圣有二种谓声闻菩萨。凡有二众即客旧两众。以为四也。就后文列者。出家及在家各有二众也。围绕者释论云。大众围绕则使佛德益尊。既尊其人必受其道故明围绕。其犹诸梵之围绕梵王忉利之围绕帝释。檀林师子义亦类然也。天华香等名之为供。资养于佛目之为养。谦逊畏难为恭。推其智德为敬。一切众生中无如佛者曰尊。恃怙之心过于天地覆载名重。美其实德为赞。赞犹未足又称扬之曰叹。虽有四句不出三业。初二为身业。次一为意业。赞叹是口业。此皆是无量义经中事。彼经云以天香等供养。大庄严王菩萨合手恭敬尊重。如说七言偈叹佛谓赞叹也。集经者略采彼经意。以开发此教也。为诸菩萨说大乘经下第二说经序。此章来有二义。一者望前谓具三事。尔时世尊即是化主。四众以下明禀教之人。说无量义经谓教门也。教主如良医。禀教人喻病者。教门譬良药具此三事则生死有边。不具此三则回流无际。如四百观论中说。真法及说者听者难得故如是则生死非有边无边。又上明三业供养则生物之福。今说大乘经生其智慧。福慧具足而佛道可成。二者望后即六序中第二名说经序也。由说无量义经方得说于法华。是故说经名之为序。为诸菩萨者此明教所为人也

问。上云四众围绕。今云何偏为菩萨

答。今言为诸菩萨者。密欲显唯有菩萨无有二乘为法华序也。说大乘经者明能被之教也。龙树十二门论以六义释于大乘。一出二乘之上故名为大。二诸佛最大是乘能至故名为大。三诸佛大人之所乘故故名为大。四灭众生大苦与大利乐故名为大。五观音弥勒等之所乘故故名为大。六能尽诸法边底故故名为大。依地持论七义释大。一者法大谓大乘经。二发心大。因大乘经发菩提心。三解行大。即道种性菩萨解行成就。四净心大。即初地菩萨也。五众具大。有福德智慧二种具足。六者时大。谓三阿僧祇劫行行。七者果大。谓大菩提果。故云大乘经也。名无量义者。大乘是其通名。无量义是其别称。所以标大乘者。密欲显唯有于大乘无有小乘为法华序也。无量义者解释不同。印法师云。此经辨无量万善也。以现在行无量万善故来世成佛。问若说万善成佛与法华何异。彼答云此中但覆相明万善成佛。不言万善之外无别三乘义。此但是显实未开权也。故与法华为异。称之为序也。基法师解云。无量义者所谓空也。若是有法即有分限名为有量。空义深广称为无量。问若尔与第二时大品教何异。彼答云前教明空为三乘行本。不得为法华序。此中明空为大乘行本。故得为法华序。是故为异也。名僧传云。基公听竺道生讲善于法华。虽有二判无以取决。次注无量义经云。其无量义经虽法华首载。而中夏未睹其说。每临讲肆未尝不废谈而钦见于斯文。忽有武当山比丘慧表。生自羌曹。伪帝姚略从子。国破之日为晋军河澹之所得。数岁聪黠。澹之字曰螟蛉。养为假子。俄放出家。便勤苦求道。南北游寻不择夷崄。以齐建元三年复访奇[狂-王+復]秘。远至岭南于广州朝亭寺遇中天竺沙门昙摩伽陀耶舍。手能隶书口解齐音言。欲传此经未知其所授。慧表便殷勤致请。心形相俱到。淹历旬月仅得一本。仍还嵩北高入武当山。以今永明三年九月十八日顶载出山。见授弘通奉觌真文。欣敬兼诚咏歌不足。手舞莫宣遂便注解云。正以空为无量义。基览经本便谓解与经符。而印师执固不移。云明空无量义经者别是余时说耳。非法华前辨无量义经也。法华前无量义经正明万善成佛。不来此土。乃至光宅法师犹存印师之解也。今以五义证此无量义经是法华前无量义经。一者处同。同在王舍城鹫山所说故。二者众数大同。谓万二千声闻八万菩萨故。三者时节同。法华云成道以来四十余年说之。无量义经亦云我成道以来四十余年未说实相法。四者义同。虽未彰言明开三显一。而旨趣密开一乘也。五者翻经之人中天竺沙门自云是法华前说。宜应用之也。今明无量义者凡有二种。一者实相之体不可限量谓体无量。二者从实相一法出一切教谓用无量。此之体用并有深所以故称为义

问。何以知无相一法广生诸教

答。如彼经说。始从华严之会终竟法华之前集。若大若小世间出世间一切诸教皆从无相一法所出生也。非但无相一法生一切教。亦从无相一法生一切身。故有凡圣有情无情一切诸身皆从无相一法出生也

问。云何无相一法生一切教一切身耶

答。无相一法即是法身。由法身故示一切身说一切教也。教菩萨法者。即说无相一法生一切法以教根熟菩萨也。菩萨修于此法则行与佛相应。故为佛所护念。遮凡夫二乘外恶为护。令生中道正观为念

问。今说法华何故前说无量义经

答。法华者会一切乘同入一乘。今将明收入之义故前辨出生。以从一法生一切法故一切法还归一法。所以将辨收入前明出生。是故前说出生为收入之序也

问。何故将明收入前说出生耶

答。由四十余年封执三教。忽闻归一心即惊疑。是故先明一切诸教本从一生。宁不归一耶

问。但一切教从一生是故归一。亦一切众生从一生以归一耶

答。彼经明一切众生失一道清净故成种种道。诸佛无缘大悲欲令众生归于一道。是故从一道出无量教耳

问。若尔与法华何异

答。彼经直明众生失一道成种种道。亦直明诸佛为失一道众生故说从一道出一切教。正明缘之与教并从一道生。而方言未明缘教并归一也

问。缘教并归一道。何者为正意

答。缘为正也。以一道本性清净而众生虚妄失于一道故成六道。今还欲令悟一道故说从一法出一切教耳。若不明众生本失一道者。虽说一切教从一法出。终不能令归一道也。此义是法华会三归一之正意。又是令一切众生作佛之正意。若不先明此意。法华不得说一切众生皆作佛也。二者法华明于一乘。今将辨一乘故先明乘本。乘本者即是实相。要由悟于实相发生波若。由波若故行无不成累无不尽。故能出三界至萨波若。乘义方成。故十二门论云。大分深义所谓空也。若通达是义则通达大乘。具足六波罗蜜无所障碍。若不悟于实相。虽复广修万善。皆是有所得颠倒不动不出。即乘义不成也。三者无量义经密显于一密破于三。法华显明于一显破于三。良以三执难倾一乘难信。今示说法华由渐。故前密后显也

问。云何名为密显义耶

答。既从一生多。既密显一为多本故即多必归一。故即是显唯有一乘无有三乘。四者彼经说。如水是一约井泉不同。法水是一约众生得道为异。然法既一得道不应有异。今动彼疑情使闻后于一说三会三归一即便信解。五者大明佛化凡有四门。一者一会一说。此例甚多。二者多会多说。如华严七处八会。三者多会一说。释论云。波若非一时一会说。故前得悟者已去。后来者更复为说。以会有前后故名多会。而波若无异故云一说也。四者一会多说者。如说净名前说普集经。又即如此经将说法华前说无量义经也。此之四事皆是适缘所宜。不应责其所由也。六者法华既开会三一。似如相说。恐闻之起着故前说无量义明于无相。大庄严王问佛。行何等法速得菩提。佛答行无相一法疾得菩提。如涅槃经有所得是二乘无所得为菩萨。亦如今。于一一句中不作字相。不作闻相。以无相故得无上菩提。故将说法华而前说无量义

问。大品等是法华前说已明无相。何故说无量义明无相耶

答。无量义明无相复明一法。有似法华故前说之。佛说是经已下第三入定序有四句。初结前生后明入定时节也。结跏趺坐者明入定之缘也

问。坐法不同。何故结跏趺坐耶

答。作此坐者不同俗人。又异外道。外道等常立或翘足。以身既不端心则不正。结跏趺坐是诸佛常坐之法。作此坐者身端而心正也。将欲静心故先端身。又作此坐取道则易。魔生怖心故跏趺坐也。入于无量义处三昧第三句正明入定

问。诸佛未曾出入。何因缘故入三昧

答。须识此中三种说法华经。一者说无量义明直说一道清净名说法华。二者佛入一道清净三昧说法华。三者现瑞即相说法华。今入定正有二意。一入三昧现瑞使时众疑。待文殊决疑方得起定。二入无量义定者。表佛语默常住一道清净也。若泛依诸经例者略明十义。一者根缘所宜。谓出入适缘动静应物。二者为欲现瑞。是故入定则显定为瑞本。若不入定则瑞无所由。又不入定而现瑞者。或恐非佛现瑞。为是义故须入定也。三者夫欲赴缘说法。必须审法察机。今将演一乘故入定也。四者欲令众生尊人重法故。以法相微妙佛欲说之尚须入定。故知此法不可思议也。五者六师等谓一切时常有智慧。佛破此执故明诸法因缘成。由定发慧故静极则鉴明也。六者示佛定圆慧满。入定故显佛定圆。起定说法彰佛慧满。若不入定则定门不显。若不说法则慧义不彰也。七者为末世模轨。佛欲说法尚入定静心。况复余人散心欲说法耶。故须皆学佛慧也。八者欲示聪明人相。能善思惟能善说法也。九者入定现瑞生后三问答所由。便得略开古佛已说法华使时众闻不生疑怖。十者三密利物。谓意密入定。身密放光。口密说法也。又即寂而用为出。即用而寂为入。此是寂用无碍故有出入之名也。论云。入三昧者。明离一切障随自在力。此力有二。一者随顺众生对治摄取觉菩提分。此是无上菩提谓良药也。二者为对治无量世来坚执烦恼。即三乘执病也。即亦令知病识药义也。三昧者此云正心行处。又云调直定也

问。何故不入法华三昧乃入无量义定耶

答。有人言。既是法华序分。未是正经故不入也。有人言。若入法华三昧者。弥勒等即能测知。今欲令不能忖度。是故不入法华三昧也。今明此经大宗凡有二门。一者于一佛乘分别说三。谓从本起末。二会三归一。则摄末归本。上无量义经明出生义。即显法华从本起末。今还入无量义处定者。即显此经明摄末归本。此二既是经之始终故为开发序也。又上说无量义经。谓从一生多即是说一法。今入无量义处定。还入一法。则出入皆是一道清净。显法华亦尔故为法华序

问。何故语默皆住一耶

答。显唯有一道更无有二。故若语若默皆住一也。又佛敕弟子常行二事。一圣说法二圣默然。圣说法者从实相观出说实相法也。圣默然者说实相竟还入实相观也。故动静语默皆应实相。实相即一道清净。上说无量义经谓圣说法。今还入此定谓圣默然也

问。前云无量义经。今何故复名三昧

答。照而常寂名定。寂而常照名慧。慧发于外名经。静极于内称定。身心不动者结上二义也。以身不动结上身端。以心不动结上心静。至人体实相而有身心。虽身不身身不动也。虽心不心心不动也。故身同枯木心若死灰。又身心不动显佛起定未期生后疑问。是时天雨曼陀罗华下第四现瑞序

问。即应说法何故须现瑞

答。此是相说法华。雨华动地表所化成佛相。放光表能化说法华相也。又既说奇特之法必感非常之瑞。盖是理数之然也。又率尔而说不生尊敬。须惊耳目方乃渴仰。又现瑞发其信心。说法生其悟解。又现瑞令其种福。说法使其植慧。又即是衣裓机案二种出子。衣裓以譬神通。机案喻之说法也。佛初成道既不得用。今将去世始得用之

问。瑞有几种

答。光宅云。前现六瑞于此土。次现六瑞于他方。合十二瑞也。现六瑞于此土者。一说法。二入定。三雨华。四动地。五众欢喜。六放光。束此六瑞以为三双。说经是趣机作教。入定是静鉴前理。此动静一双也。上即天雨四华。下即地六种动。上下一双也。时会内心欢喜。如来外放光明。内外一双也。今谓六句之中三句非瑞。何以知然。释论云。佛入王三昧现七种瑞相不数入定。故知入定非瑞。时众睹瑞欢喜。如大品时众睹动地瑞心生和悦。故知众喜亦非瑞也。说经乃是赴缘之教亦不名瑞。若说经是瑞。弥勒何故不问说经意也。入定等亦同此责。今明六种之中但三是瑞。谓雨华动地及放光也。智度论云。佛入王三昧现七种瑞。今入无量义三昧现三种瑞

问。何故但现三瑞耶

答。今明尽理之法故有穷大之瑞。言其大者不出三种。天为其瑞地为其瑞。佛为天地之主复示征祥。其犹恶之大者即天为其灾地示其祸神现其怪也。又表三世诸佛同说一乘三根众生咸归不二。故现三瑞也

问。书云明主以孝慈训世即赤乌翔而老人现。仁德育物即醴泉涌嘉禾生。一角兽出即天下太平。治得人心连李生。故德充于内瑞发于外。今此三瑞各何所表耶

答。欲表声闻四众同归一乘。故天雨四华。人天六趣并皆成佛故地六种动。此二成佛必籍说法华。故放光表之。又天雨四华表四乘众生并皆作佛。地六种动表六趣众生同悟不二。此二成佛皆由说法华。故光瑞表之。又天雨四华表上天众生应悟一乘。地六种动表下地含识同阶不二。上天下地同悉悟者。并由佛说法华。故光瑞表之。又天雨华表说一乘使天灵欢喜。下地振动表敷不二即地祇踊跃。喜跃所由皆藉于佛。故放光表之也。就文为四。第一雨华动地瑞。第二明时众睹瑞欢喜。第三佛放光瑞。第四时众睹光瑞。此即雨感雨应为二双也。前明雨华次明地动。是时者雨华时也。正是四众闻经悟一乘时。天雨者雨华处也。据事而言。既说非常之法致感诸天供养。故文殊偈云。天雨曼陀华天鼓自然鸣诸天龙鬼神供养人中尊。约理而谈者。天者净也。四众封执之心既净故得闻经成佛。曼陀罗华者正明所雨四华名字。但雨四华者正表四众成佛。前二华表出家二众成佛。后二华表在家二众成佛。又昔不明四乘成佛。今并会归佛乘。故但雨四华。亦前二是白华。表声闻缘觉无漏善成佛。后二赤华。表人天有漏善亦成佛。四华之内皆前雨小后雨大者。表修行从小以至大自浅以入深也。曼陀罗华者。河西道朗云天华名也。中国亦有之。其色似赤而黄。如青而紫。如绿而红。曼殊沙华者亦天华名也。其色鲜白。无白能为喻。注经云如意华。随诸天意出生故以为名也。大曼陀罗华者大如意华。此出正法华经也。道行翻云成意华也。曼殊沙华者是圆华也。次是大圆华也。光宅云。初二赤圆华大赤圆华。后二白圆华大白圆华。散佛及大众者。据事而言。供养于佛及众也。约所表者。明大众行因必得成佛也。普佛世界六种震动者第二明动地瑞。从天至地即为次第也。约所表义者。此经虽会四乘同归一极。而教宗所起正为声闻缘觉。傍及人天二乘。故前雨四华表声闻四众入于佛乘。后及人天六趣同归不二。故譬喻品云为诸声闻说大乘经名妙法莲华。不正言为人天说。即其证也。普佛世界者释迦所王之土皆动故云普也。故下文云而此世界六种震动。亦可十方佛土皆动名之为普。故文殊偈云一切诸佛土即时大震动。又大品云其土最在边是释迦所度因缘边。今明普义是可度因缘普也。六种动者谓二种六也。一六时动。谓降胎．初生．出家．成道．说法并入涅槃。今是六中之一。谓转大法轮故大动也。又六种动一动二起三踊四震五觉六吼也。摇扬不安为动。鳞垄凹凸为踊。自下升高为起。隐隐有声为震。碎磕发向为吼。令众生觉悟为觉。一一各三为十八相动。大品就踊中开为六。即动等各六。便六六三十六。今文略举震与动也。尔时会中下第二睹瑞欢喜也。文为二。前明睹瑞之人。初辨四众者。上四华正表四众悟入一乘。故今明四众睹瑞欢喜。及诸天龙者。上地六种动表人天六趣普皆成佛。故今列六道之众欢喜也。不列菩萨睹瑞欢喜者。自昔以来已说菩萨作佛故无瑞表之。所以不明菩萨欢喜。昔未会四乘成佛故有瑞表之。所以言四乘之人睹瑞欢喜也。人非人者。八部鬼神本悉非人而变作人形来听说法。故云人非人也。是诸大众下正明欢喜。合掌表形无异用。一心明意无他缘。夫喜敬交集实合渴仰之情。异瑞并兴疑有非常之说也。尔时佛放眉间光此下第三次现光瑞

问。雨华动地放光何故不合为一类。而前明两瑞后明睹瑞。今复现光瑞后明睹瑞耶

答。瑞虽有三义门唯二。前之二瑞表于所化。故明所化睹于二瑞。今辨放光即能化之瑞。故前明光瑞后辨睹瑞。又前二是依果瑞后是正果瑞。又前是意业现瑞后是身业现瑞。今欲分二瑞不同两见亦异故。不一处同辨也。依法华论生起者。初入定现瑞。大众睹瑞渴仰欲闻法故佛放光。故有此章来也。尔时者放光时也。佛者放光人也。眉间者放光处也。下不以足上不以顶眉间放光者。表一乘是中道法也。白毫者表理显明称白。教无纤隐为毫。智度论出小乘人解白毫相云。舒之即长五尺。卷之即如旋螺。观佛三昧经云。为太子时长五尺。树下时长一丈四尺五寸。成道时一丈五尺。舒之表里有清彻白净光明。置之便失净光。而卷缩在两眉之间。经或言右旋宛转如日正中。或言如天白宝。光明者正放光也。表平等大慧智炬将晖故身光前曜。光有二义。一能显物。喻此经显一乘之理。二能灭闇。表此经能灭二乘之惑。照于东方下光所照处也。唯照一方不照九方者。唯有一乘无有余乘也。于十方中但照东方者。东方为诸方之本。表一乘为三乘之本故。昔从一说三。今收三归一也。万八千世界者。表说一乘之果已满如万。一乘之因未圆如八千。又表一乘真实故义即具足如万。三乘是方便未具足故如八千。又释世界有定数者。此明感应相同也。众生之感既其不遍。诸佛之应亦不普也。靡不周遍者。乘有十义十相表之一有最上义。以头表之。二有中道义。以眉间表之。三有显明义。以白表之。四有无纤翳义。以毫表之。五有破闇义。以光表之。六有不二义。以一方表之。七有根本义。以东方表之。八有果乘具足义。以万表之。九有因乘未具足义。以八千表之。十说因果理尽义。以周遍表之。下至阿鼻地狱上至阿迦尼吒天者。上辨横照显诸佛事。今明竖照显众生事。照地狱明苦之可愍。照有顶显乐亦无常。既是苦无常。令厌众生事悟入佛事也。于此世界悉见彼土下。第四明时众睹光瑞。凡有七句。一见六趣。二见化主。三闻教门。四见四众。五见菩萨。六见涅槃。七见起塔

问。佛何故令众见此七事

答。七事是他方诸佛一化始终究竟法门。今欲将彼显此释迦说于法华亦辨一化始终究竟。由佛光照见他方一化始终之事。即表由释迦说法华经故得显一化始终究竟也

问。云何七事摄一化始终耶

答。如大品经云。诸法无所有。如是有诸法。无所有者。一切诸法本性寂灭。如是有者。诸法虽无所有于众生颠倒成有故有六趣生死。既无所有于众生成有。今欲令其悟有无所有。故第二次明有佛出世。既有化主即说教门。既有所禀之教故便有禀教之人。如禀三乘之教后皆成菩萨。既并成菩萨。即一化事竟便般涅槃。为利物故次明起塔。故云七事明一化始终究竟也。一方之佛既具此七事。十方三世佛义亦同然。故现彼土之事为此土说经之相也。然义虽有七不过二事。初一是众生事。后六是诸佛事。然诸佛事既有六。众生事亦有六。即六趣也。故离成十二事也。所以法华论云烦恼差别清净差别。烦恼差别故有六趣。清净差别故有诸佛六事。今前见六趣众生者。明众生是七事之本。故先见之。又逐文势相接。上光明前横照诸佛土。次竖照众生事。今续此文故前明见众生也。又见彼土现在诸佛下第二见化主也。及闻诸佛所说经法下第三闻教门也。并见彼诸下第四见禀教人也。修行得道者。虽有四众不出因果。修三学之行为因。得四果之道为果也。又见彼诸菩萨下。第五见禀一乘教人成菩萨也。菩萨无边略以三门总摄一切。种种因缘者。过去习因为因。外值善友为缘。而内因不同外缘非一。故云种种。即因缘门摄菩萨也。种种信解者。始名为信终称为解。又钝根名信利根名解。上既明入道各有由藉。故今明入道有始终利钝。故以信解门摄菩萨也。种种相貌者。菩萨修行必有相貌。表彰身口之行外彰为相意业之行显明称貌。故以相貌门摄菩萨也。行菩萨道者。总上三事名行菩萨道。法华论云以四摄法摄取众生名行菩萨道。又见诸佛般涅槃者。第六见般涅槃。般之云入。即入涅槃也。又见诸佛般涅槃后。第七起塔尔时弥勒菩萨下第五疑问序。所以疑问者。既睹奇特之瑞知说非常之法。但未测所由故生疑问也

问。涅槃大品皆亦现瑞。何故不辨瑞之因缘

答。适化不同非一方也。又大品皆是出定现瑞。佛既将说非久故众所不疑。若如仁王之与此经并是定内现瑞。佛既三昧正受。恐起定未由。是以推瑞意也

问。此经佛何故入定现瑞不起定耶

答。三执难倾一乘难信。故入定现瑞发其疑端。然后令弥勒发问文殊解释。明古佛说之于前释迦敷之于后。开信解之渐塞疑谤之情。释迦方得起定说法也。就文为二。一疑念二发问。初明弥勒疑。次辨大众疑。弥勒疑内凡有三句。第一疑佛何故现瑞。就中初牒次疑。今者世尊现神变相此句牒也。阴阳不测为神。改常之事为变。有所表彰称相。以何因缘者正生疑也。今佛世尊入于三昧者。第二访觅释疑之人。此疑从佛入三昧生。亦前牒后疑。今佛世尊入于三昧者。佛既三昧正受。恐起定未由。故不得咨佛也。是不可思议者。此现瑞甚深非心能所思非口能所议。故自不能解也。现希有事者。旷世所无故言希有。以其希有必须知之。此三句牒欲问他之所由也。今当问谁者。正访觅质疑之人也。将扣智慧之门。谁堪郢匠之选也。复作是念下第三得释疑之人也。以得释疑之人故第二疑即断也。亦有二句。初序叹文殊有堪决疑之德。我当问下正明问

问。何故问文殊

答。既明佛果一乘。唯佛能了。佛既入定不得问佛。文殊是过去佛。能达佛事。是故问之。二者如观音等亦是古佛但问文殊者。以弥勒与文殊等昔同在灯明佛所故得问之。三者问文殊得开发二分经。文殊引灯明佛现瑞等事得开发乘权乘实经。文殊为燃灯之师得开身权身实经。以下将开近显远。今先叙以近覆远也。又前辨灯明佛事略是开三显一。后明文殊略开近显远。文殊昔是师。今方便为弟子。即显释迦是燃灯弟子亦是方便为师也。尔时四部众下第二时众生疑也。弥勒道高知有释疑之人。余众德劣但有疑佛瑞相。不知释疑之人也。尔时弥勒下第二正发问也。前序问意次发言正问。正问为二。前正问次请答。正问为二。前长行略问次偈颂广问。长行之中复开为二。一者合问初二瑞。二者问后光瑞。以前二瑞并是外瑞又是依果又是意业所现故云神通之相。所以总为一问也。放光是内瑞又是正果又是身业故复为一。就光瑞中前明现瑞。悉见下明睹瑞也。于是弥勒下第二明偈颂广问也

问。何故诸经有长行与偈

答。长行与偈略明十体五例。言十体者。龙树十地毗婆沙云。一者随国法不同。如震旦有序铭之文天竺有散华贯华之说也。二者好乐为异。彼论云。或有乐长行。或有乐偈颂。或有乐杂说庄严章句者。所好各不同。我随而不舍。三者取悟非一。或有闻长行不了闻偈便悟。或各闻俱迷。或合闻方解。故双明之。四者示根有利钝。利根之人一闻即悟。钝根不了再说方解。五者欲表诸佛尊重正法。殷勤之至一言之中而覆再说也。六者使后人于经生信。寻长行不解或恐经谬。见后偈同前方知自惑。七者欲易夺言辞转势说法。其犹将息病人故回变食味也。八者示义味无量故。长行已明其一而偈颂复显其二。九者表至人内有无碍之智外有无方之说故。能卷舒自在散束适缘也。十者明众集前后故有长行与偈。如涅槃所辨

问。如余经偈与长行不必皆备。何故此经贯华散华一一相主

答。适化所宜。已如前说。但此经正反二乘之初明一乘之始。难信难解故殷勤再说。又余大乘经化于菩萨。菩萨利根但须一说。此经偏为二乘。二乘根钝故须重明也。五例者。一者广略四句。长行广而偈略。为易持故。长行略而偈广。为解义故。长行与偈俱广俱略。为钝根人重说故。及为后来众故。二者有无四句。长行有而偈无。长行无而偈有。长行与偈俱有俱无也

问。有无即是广略。云何复更辨耶

答。有无异广略也。如长行略而偈中广。自有长行全无而偈方有也。三者离合四句。长行合而偈离。长行离而偈合。长行与偈俱合俱离也。四者前后四句。长行明义在前。偈明之在后。长行明义在后。而偈辨之在前。长行与偈俱前俱后也。五者质文四句。长行质而偈文。长行文而偈质。俱文俱质。欲以文质相间使听者心悦也。后五例者乃是易夺言辞转势说法也。用前十体及后五例贯通众部。非直法华也偈有二种。一首卢偈凡三十二字。盖是外国数经之法。数经之法者。莫问长行与偈但具三十二字便名一首卢也。二结句偈要以四句备足然后为偈。莫问四言乃至七言必须四句。故涅槃经云。四句为偈是名句世。句世者世间流布以四句为偈也。句世有二种。一伽陀。谓孤起偈亦名不等颂。二路伽。谓颂长行偈。有人言外国称祇夜或名偈夜。今略彼夜字直称为偈。此间翻为句也颂也。有人言偈是此间语。以其明义竭尽故称为偈也。就文凡有五十四偈。开为二别。前有四偈合颂长行三瑞并及睹瑞。次有五十偈颂光瑞及以睹瑞。所以开为二颂者。初三现瑞于此土。次一现瑞于他方。故开为二颂

问。何故现瑞于此土及现他方耶

答。欲表释迦为此土众生说一乘法故现瑞于此土。三执难倾一乘难信受。恐此土众生不信。今欲将彼显此故现瑞于他方。初是正说瑞。次是证说瑞也。就现瑞于此土为二。第一颂现瑞。第二颂睹瑞。颂现瑞为三。一颂光瑞。二颂雨华。三颂动地

问。长行何故前明雨华动地后放光明。今何故前颂放光后颂雨华动地

答。偈与长行各示一义。长行从所化以至能化。雨华动地正表所化众生成佛。故前明雨华动地。所化成佛必由能化说经。故次辨放光。偈文从能化以至所化。要由能化说经所化方得成佛。故前颂放光后颂雨华动地。又与文势相接。弥勒问中最后问光。故逐近前颂光也。栴檀香风者。雨华表生一乘之解。香风表灭二乘之惑。天华淹其秽。香风灭其臭。故外地严净也。表一乘解生二乘惑灭内心严净也。眉间光明下第二颂现瑞于他方也

问。前已问光。今何故复问光耶

答。长行直明一光通照彼此。弥勒今欲开之故明二光。前明光照此土。今颂光照他方。约照此彼故分成二光。故下偈云佛放一光我及众会见此国界种种殊妙。即此土光也。又云放一净光照无量国。谓他土光也

问。何故此土具有三瑞他方但有光瑞

答。释迦一期出世众生道缘应熟。故为说一乘。故有能化所化之瑞。他方国土众生非释迦所化故无三瑞。但欲将彼显此放光照之。故唯有光瑞。就文亦有二。前颂光瑞次颂睹瑞。皆如金色者。他方虽有七事同为明道无二。将彼之一色显此说一乘也。又彼此道同故得此光照彼将彼证此也。从阿鼻狱上至有顶。前颂横照诸佛事。今颂竖照众生事。长行云阿迦尼吒今称有顶者。楼炭经云。阿迦尼吒在有色之顶也。诸世界中下第二颂睹瑞。长行有七事。今但颂五。颂教门兼颂四众。颂起塔兼颂涅槃。颂余五事。弥勒开为三门。初颂众生化主教门三事。第二结前生后。第三颂菩萨起塔二事。所以颂前三事者。六道是所化。诸佛为化主。次颂于教门。所化是病人。化主为良医。教门为妙药。此三事必相成故须一类颂也。又六道即是能感。化主教门即是形声两应。能感不出六趣。能应莫离形声也。又六趣为听者。诸佛为说者。教门为真法。得此三事故生死有边。故但颂三也。诸世界中者器世界也。六道众生者众生世间也。此是依正一双也。生死所趣善恶业缘者因也。受报好丑者果也。即是因果一双也。于此悉见者。上明能照之光及所照之事。悉是所见。大众是能见。谓能所一双也。以见众生事讫故。将悉见结之。又睹诸佛圣主师子。第二颂化主。中论云圣有三种。一外道五通。二辟支罗汉。三法身菩萨。佛于三圣中最大故称圣主。既是三圣之主。复为六道之师。于凡圣自在无畏故称师子。演说经典下第三颂教门。就文为二。初颂一乘根本法轮。次颂三乘支末法轮。东方诸佛既有此二教。将彼显此。明释迦说法华之前亦有此二。故华严为根本法轮。次说三乘谓支末之教。颂根本法轮有三别。初明一方佛说一乘。次辨处异法同例一切佛。三明说教之意。即总明一切佛也。演说经典者能诠一乘之教也。微妙第一者所诠一乘之理也。其声清净出柔软音者。叹能宣教之声也。能拂尘垢为清净。随顺根缘名柔软。此是声之用也。又佛音不浊曰清。佛语不闹为净。佛语至和为柔。离刚为软。教诸菩萨者教所被缘。根本法轮不杂三乘故但称菩萨也。说于一乘要具四事。即上能诠之文．所诠之理．能宣之声．所化菩萨也。梵音深妙者。第二处异说同。前叹佛声清软。谓教称于缘。今明众所乐闻。明机称于教。各于世界者明其处弥异也。讲说正法者明其道弥同也。种种因缘下第三明说教意也。上半序佛说教。说教有二。一法二喻。下半明佛说教意。佛说教意亦有二种。一者上弘二者下利。据佛而言者。教能显理如灯照明。理是所诠称为佛法。开悟众生者谓下利也。一切众生悉有佛性。以无明为扉邪疑为关故不悟佛性。诸佛析邪疑关。开无明扉令见佛性故称悟也。若人遭苦下第二明三乘教。即支末法轮。东方诸佛为小根性不堪受一故于一说三。即显释迦法华之前亦尔也。一乘法轮有三句。今三乘法轮亦三句也。旧经师云。以前三句总明教。后三句别明教。盖是不识本末二轮失教旨也。然虽是一章经实是大事。若法华中有华严即成甚深经。若依四时释者。即成浅近教也。文殊师利下第二结前生后。三句结前。三句生后

问。何故不依长行七句次第问之而结前生后耶

答。弥勒欲显他方佛法华之前有其三事。一者有六道众生。二者有诸佛出世。三者说本末法轮。将彼显此明释迦法华之前亦具三事。一有所化众生。二有释迦出世。三说华严之本教三乘之末轮。以三句结前。即显上法华前事。三句生后。显他方佛从法华去已后事。法华之前有本末二轮。法华以去乃至涅槃皆收末归本一乘法轮也。若不结前生后。即不得显法华前后二时教门。今当略说者。上是事广而言略。事广者谓六道化主教门三事也。言略者偈颂少也。今是事略而言广。事略谓菩萨起塔二事也。言广者偈多也。盖是对上以明广略。次直就后以明广略者。所见菩萨及起塔事多。今但略说。盖是对见广明说略故称略也。故前文云及千亿事如是众多。即是事多。今当略说所谓言略也。我见彼土下第三次颂菩萨及起塔二事。初事为二。一总颂二别颂。总颂如文。就别颂菩萨中略以三门摄之。东方菩萨虽复无穷不出三种。一者六度次第行菩萨。二者三业利益行菩萨。三者六度无方行菩萨。初颂上种种因缘。次颂上种种相貌。后门颂上种种信解

问。何故唯颂菩萨耶

答。欲明东方诸佛说三乘之后唯说一乘。将彼显此释迦说三乘之后亦说一乘。既说一乘即是但教菩萨。故法华经名教菩萨法佛所护念。至此以来凡颂三种菩萨。上云教诸菩萨无数亿万。谓根本法轮菩萨。次若有佛子修种种行。此是支末法轮三乘中菩萨。今谓摄末归本一乘菩萨

问。三种菩萨云何广狭

答。前二轮中但有直往菩萨。摄末归本具直往回小入大二菩萨也

问。已知。但颂菩萨何故明于六度

答。菩萨所行不出六度。六度即是因乘之体。故智度论云六波罗蜜名为乘体。今欲令菩萨乘是宝车直至道场。是故明六度行也。就檀度为二。初明外施次明内施。外易内难故从易至难。外施为二。初明一切施。次明妙物施。初一行三句正明施行。欢喜布施此明施位。故地前十行初名欢喜行。初地行檀名欢喜地。故知是明位也

问。云何欢喜施耶

答。犹如慈父与子之物心生欢喜。菩萨亦尔。又如世人知火必烧舍。逆出财物舍虽被烧而物不失宅主欢喜。知身必灭以财布施心喜亦然也。回向佛道者。上明施行今明转行。转行者。回此施善向于佛道故名转行

问。何故须回向耶

答。净名经云回向为大利。若向三有二乘。得利即少。今回此善向于佛道。其利即大故须回向。又回此善向一切众生亦名大利。善若向已其福即少。回善与他他既无边其利亦大。又回此善向于实相亦名大利。所以然者。不向实相则成住着不动不出。不名为乘。其利则少。若知布施即是实相。实相无边施符实相之理。福亦无边。回向虽多要须此三也。愿得是乘者。上明施行今辨发愿。施行如车。愿如御者

问。何故云愿得是乘三界第一

答。颂他土一乘之愿。作此方菩萨行一乘之相也。即是将彼显此密说一乘。或有菩萨下第二明妙物施

问。上明施车。今何故更明施车

答。将彼显此明一乘之相也。亦名最后施。如须太挐太子。施物已穷最后唯余自所乘车。有人乞之菩萨亦舍。轩饰者大夫车曰轩(居言反)又覆车为轩(居晚反)今既言轩饰。必知覆车物也。复见菩萨下第二内施。亦开为二。初明轻施次辨重施。所以明内施者。前通别两施外财已尽。唯有自身及与妻子。故明身肉及妻子施。言身肉者但以肉施如尸毗王。但以身施如长寿王。昔有王。国破身隐穷林。有人来乞。以身施之令送敌国。又见菩萨下次明重施。如光明王千头布施提婆菩萨以眼布施摩诃萨埵以身布施。欣乐施与者。如人以瓦器换得宝瓶心生欣乐。舍此肉身得于法身义亦如是

问。何故无内外施耶

答。经中或但明内外施摄一切施。或明三施。一内二外三亦内外。内外者如菩萨吐其所食施与饿鬼

问。金刚波若明三种檀。今是何檀

答。彼以檀行摄于六度。初一为资生檀。次两名无畏檀。后三名为法檀。今既别有六度。但是资生檀也

问。以何为施体

答。毗昙无贪相应思及起身口业用为檀体。有人言。诸心数内别有舍数名为檀体。有人言。施心财物及以受者因缘和合名为施体。文殊师利下第二明戒。前是在家菩萨。今是出家菩萨。前辨行善今明息恶。昔有五王。相问各陈所好。一好园林华果。一好妇女美色。一好军马兵甲。一好田猎游戏。有一大王。次第为说过患。华果即有雕零枯折。妇女即有恩爱别离。军有斗战相杀。田猎乖伤慈悲。不如厌老病死求常乐涅槃。四王闻之皆诣佛所出家修道。明菩萨有三种戒。一息一切恶谓摄律仪戒。二修一切善谓摄善法戒。三度一切众生谓度众生戒。此文既是菩萨出家。必具受三戒。而未行余二。正明是摄律仪也

问。三戒以何为体

答。有人言。初戒以止恶为体。后二以行善为体。今明不尔。若后二以行善为体。初受戒时未修行度人。即应但受得一戒。菩萨之戒便不具足。今明三戒并以止恶为体。初戒止息威仪之恶。次止不行善之恶。后止不度人之恶。故初受戒时具得三戒。但后时修行善法及度众生耳

问。何故但明三戒

答。息一切恶戒后得累无不尽果。行一切善戒后得法身德无不圆。度众生戒亦令他得此二。故持于三戒自他俱证法身

问。戒以何为体

答。毗昙以色为体。成论非色非心为体。譬喻僧祇明离思无报因离受无报果。故以心为戒体。今明大乘适缘所宜无有定执。若有定执即成诤论趣向阐提。或见菩萨下此明忍度。持戒即自不造恶。忍行忍他打骂。忍有三种。一他不饶益忍。二安受苦忍。三法思惟忍。今云独处闲静。远离五欲抑制六情。是安受苦忍及法思惟忍也。又见菩萨下颂精进行。精进有三。一弘誓精进。出生大愿故。二集善精进。自修诸善故。三利益众生精进。度众生故。今是前二精进也。又见离欲下两行颂于禅定行。禅有三种。一现法乐禅。内心寂静故。二出生功德禅。生四等五通故。三利益众生禅。度众生故。今文未明度于众生。但是前二禅也。初偈明修禅得果。次偈明动静不二。小乘但明修四禅方能发通。大乘明一切禅定皆能发通。经或云菩萨得于五通或得六通。凡有二义。言得五者。一始行菩萨但得五通。二法身菩萨得于六通。又菩萨烦恼已尽。形凡夫未已尽故言得六。余有习气。比佛未尽故言得五通。次偈明动静不二者。即静能动故。心安禅定运身合掌口赞法王。故净名云不起灭定而现诸威仪也。秦人有识梵书者云。外国名安禅此翻为合掌。故此彼双举。乃属慧行所收非禅门摄也。今谓不必尔。若此彼双说。即文成烦重。假令欲成偈者。正应云恭敬合掌耳。不应一事两陈也。复见菩萨下第六颂于慧行。慧有三种。初第一义慧。次知五明世谛慧。三度众生慧。今文意乃应具明于三而未辨度物。又见佛子下第二明三业利益行。有人言。犹属波若度摄。但前明上问诸佛。今辨下利众生。六度之中广其初后略其中间也。有人言。前明波若竟。今辨方便波罗蜜。何以知之。如大品发趣品云。第七地名等定慧地。第七地即属方便。今文定慧具足。即是定慧平等。故知属方便也。今依前说。谓三业利益行。即颂上种种相貌。以身口外彰为相。意业内亦显为貌。初有两偈明圣说法。即口业利益物。次有一偈明圣默然。即是意业利益物。次有一偈处林放光。身业拔济。又此三业利三品人。初利菩萨谓上品。次益天龙谓中品。后济地狱谓下品。又初二大慈与乐。后一大悲拔苦。又初二上利人天。后一下济恶趣。定慧具足者。寂照圆满。即内具说法之德。以无量喻者。内既寂照圆满。外有无碍辨才。欣乐说法教诸菩萨者。欣已所得乐益同行也。破魔兵众而击法鼓者。上利益正人。今破于邪众。魔谓四魔。兵众即是十军也。菩萨说法令人得道。破烦恼魔得法身故破于阴魔。得道及法身二事故破死魔。得不动三昧故破天魔。十军者。欲心是初军。乃至自高蔑人为十。以教为桴。以理为鼓。以言宣之为击。又见佛子未尝睡眠下。第三明六度无方行。颂上种种信解。言无方者凡有二义。一者适缘所宜前后无定。二者根性非一自行不同故也。明六度即六。初有一行明精进行。精进是众德之本。菩萨闻此之事故发始即行也。成实论云身心昏重曰睡。摄心离觉名眠。毗昙云别有睡眠数。睡着前境为睡。身心昏昧略缘境界曰眠。大乘以一切住着昏闇皆名睡眠。菩萨心无染著名未尝睡眠。不动而游行故曰经行也。念念常习无生正观故名精进也

问。上辨精进与今何异

答。上明勤策今辨离过。上明静坐今说经行。又见具戒下第二明戒行。精进遍策众行。戒为万德之基。此中防凡夫二乘及有所得恶故名为戒。持于性重故言具戒。不犯讥嫌称威仪无阙。于戒有三。一清净义如珠。二圆正无阙故如珠。三戒可宝重故如珠

问。上明戒度与此何异

答。上明难舍能舍故舍居家。今明难持能持威仪无阙。又出家为始持戒为终。又上别据国王。今遍通一切。又见佛子住忍辱力下第三明忍度。此中明菩萨忍辱者。以见有众生为可耻辱。知众生毕竟无生名为无生忍。法忍亦尔。阿含经云有六种力。小儿以啼为力。欲有所索要必先啼。女人以嗔为力。欲有所索要必前嗔。国王以憍豪为力。罗汉以精进为力。诸佛以大悲为力。比丘以忍辱为力。增上慢人恶骂捶打者。蜜破小也。以保执小乘自谓究竟名增上慢。马鞭木名之为捶

问。上忍与今何异

答。上明抑制内情谓安苦忍。今明外缘不动谓他不饶益忍。上别据比丘。今遍通道俗。上栖止林泉。今通住山邑。又见菩萨下次明禅度。离诸戏笑者离散乱缘也。及痴眷属者众生未可度也。此二句明身离也。一心除乱者谓心离也。亿千万岁下修禅定意。此中明禅者如净名云。不于三界现身意。是大士禅。以达身心本来四绝故。不见身意。不为身意所动乱也。与上禅度异者。上明修禅得果。今但辨习静因行。上辨利智见理。今明钝根凭师。或见菩萨下第五明檀度。涅槃经云。若起二乘心无布施。是破戒邪见。若以凡夫心见有三事。亦破戒邪见。今了三事宛然而常寂灭乃超凡圣。是持戒正见施也。开为五别。一明药食施。二明衣服施。三明卧具施。四明园林施。五一偈总结施意。言肴膳者。肉食为肴。细劈肉也。菜食总名餗(速音)此经未制断肉。故明菩萨施肉。涅槃四相品去已断肉。至大众问品纯陀持诸肴膳来者。为纯陀从哀叹品还家不闻四相品制故。尔大众问品云所食无异者。同化成菜食也。名衣上服价直千万者。迦叶袈裟直十万两金。以施佛。只域奉佛染摩羯簸衣亦堪十万两金。佛敕阿难割截作袈裟耳。与上檀度异者。前明布施四生。今明供养三宝。上具明内外二施。今但辨财檀。或有菩萨说寂灭法下第六明般若度。凡有三人。初明说寂灭法。即是此经一乘妙法。故方便品云诸法从本来常自寂灭相。种种教诏者。如昙无竭菩萨以六百万亿法门为常啼说之。又如净名三阶辨于不二。一者诸菩萨历泯诸二明于不二。未辨不二无言。二者文殊虽明不二无言。而犹言于不二。三者净名辨不二无言。而能无言于不二。故云种种教诏。第二偈明观法行。以一切法本性无二。即是显唯有一乘也。第三偈明无著行。无著者。前明显一今破着三。又前明不二。今明亦不着不二。故华严云。不着不二法。以无一二故。又合三人为二。初明说波若人。次两行明行般若人。说中不出三阶。如入不二法门。行中不出二观。一不二观二无著观。上是圣说法今是圣默。然上明波若直明问佛能持。今具此三种

问。经云十度。与六度云何同异

答。经在二文。一者方便伴前三度。次以三度伴后三度。以愿伴精进。以力伴禅。以智伴慧。通称度者。一是时度谓三阿僧祇劫满。二果度谓得菩提果。三清净度谓穷实相。一一度有四句。一是施非度。初二僧祇劫行施也。二是度非施。第三僧祇余行也。三亦施亦度。第三僧祇劫施行也。四非施非度。初二僧祇劫余行也。文殊师利下第二颂起塔菩萨

问。何故前后二段并言菩萨

答。欲显从法华以去竟涅槃皆是摄末归本无五乘之异故皆是菩萨也

问。何故前明菩萨今辨涅槃

答。有三义。一欲明菩萨行因得涅槃果。二欲显法华是究竟教说究竟教既毕便入涅槃。三者说法华竟便入涅槃。令时众生恋慕闻后一乘即便信受

问。何故有二章菩萨

答。初明佛在世时修行菩萨。今明佛灭度后修行菩萨。略举二门总摄一切行。就七行偈开为二别。初一行明供养舍利者。如释迦入涅槃后。从娑罗双树举佛尸。于天冠寺七日供养佛全身。待迦叶来七日后方阇维之。供养碎身方乃起塔供养也。又供养舍利有二种。一者直供养不起塔。以七宝函盛之如供养佛身。二起塔供养也。次有六行明起塔庙

问。凡夫俗人亦起塔。与今何异

答。大士知塔是因缘成即寂灭性。虽复运用实无起作。即具四智也。六行之中开为二别。初有四行正明起塔。次有二行释疑。初为四。第一一行正明起塔。次一行序塔形量。纵广者纵(音居松反)广(居朗反)次有一偈明塔庄严。次有一偈明供养塔。菩萨起塔凡有二义。一供养舍利。二利益众生也。上三行明供养舍利。今一行明天龙供养。即利众生也。次释疑者。上明庄严国界。若尔起塔乃是为庄严国界非供养法身。故今明正为供养舍利尊重法身。而国界自然殊特妙好也。如天树王者譬喻释也。华开本为结实。而树自然庄严。起塔本为供养佛身。国土自然华丽也。又释树开华无心令人爱乐。而人自然爱乐。起塔无心庄严国土。而国土自然庄严也。又释此譬直释上殊特妙好一句文耳。树王开华即端严可爱。国土有塔亦殊特妙好也。佛放一光下第二大段请答。文为二。第一睹瑞生疑故请。二忖瑞未了故请。所以有此二者。一往见闻不了是故致请。第二意地忖量复未能解是故重请。以有斯二义故分两请。初一见闻不了该通大众。二忖量未解专据弥勒。以大众未能忖量。弥勒以仿佛其相但事犹未决是故请也。以有二人故分两请也。又所以开此二义者。初自下凡终于补处。睹瑞生疑及忖量未了。方知瑞为非常表所说必大。即惊骇物情使生难遭之想。令后闻道之流望岸即信也。就初文中复闻三意。初有三偈正标所疑事致请。次一偈腾众意请。第三一偈催答请。初文两偈半标所疑之事。半偈正请也。上现三瑞今偏标光者。为光中所见事多。又光是瑞中之本故也

问。何故牒二光耶

答。欲显三瑞有其通别。雨华动地但现此土。放光一瑞该通彼此

问。雨华动地偏现此方有异义不

答。据文而言。雨华止及此会。故云而散佛上及诸大众。动地即云而此世界六种震动。放光即通照彼此。若然华瑞最局。动地次。放光偏广

问。何故有此三品耶

答。今说法华正令此会四众悟道。故华止雨一会。傍及释迦所王娑婆人天六道。亦令悟道故一世界六种震动。欲将彼显此故光照他方

问。何故此文偏叹一光

答。凡有二义。一欲叹佛神通希有。即是叹于佛乘令四乘之人欣慕。二者欲表说一乘故叹一光也。四众欣仰下第二腾众意请。以众意瞻仁及我故。我今问愿仁答之。下云何所饶益。责放光何所下利。今疑何故放斯光明。问放光何所上弘。佛子时答下第三作利益请。以疑是解津释便得益故请时答也。佛坐道场下第二弥勒忖瑞请。若弥勒都不知者。即与凡夫二乘及下位菩萨更无有异。今既是补处。忖量应说大法。但未知说何物大法故请答之。文亦开三。初明忖瑞所表应说大法。次明忖能表之瑞非为小缘。三明未敢决之重请答也。佛坐道场所得妙法者谓一乘果也。为当授记明一乘因也。又佛坐道场明显一也。为当授记为破三也

问。弥勒忖量与现瑞相符以不

答。正相符也。放光表说平等大慧果。故今明佛坐道场所得妙法也。雨华动地表所化成佛。故今明授记。三周中授三根人记。法师品通授一切凡夫记也。然放光正表说道场所得果法。光宅不应言初分经明因。失光瑞意也。能表瑞中初现佛依果及见诸佛。此明正果。能表之瑞明佛依正两果。即表正说佛果。非明因之义。故所表因果一双。能表依正两种。第三结请中三句重腾众意。一句定于瑞宗。光宅云。文殊有四种伏难以遮请。慈氏释四难以申疑情。今谓此四伏难意浅文迂。宜应废也。弥勒道劣尚可鉴众疑。文殊德高何容不达。弥勒自疑兼腾众惑。正是会理。何繁难通。若此文是释难者。下身子请云时为如实说。亦应是释难也。彼既不尔。今何由然也。尔时文殊师利下第六答问序。前明将彼显此。今明文殊以古证今。将彼显此者。释迦之放光弥勒之偈颂。将他方七事以显此土应说一乘。文殊将古以证今说者。明古佛说之前释迦顺同于后

问。何故将彼显此。以古证今

答。将彼显地。欲显十方诸佛道同。引古证今。明三世佛法无异。所以辨十方佛道同三世法不异者。以小情难改大法难信故也

问。何故释迦放光弥勒疑问文殊答耶

答。云释迦现瑞谓现在佛也。弥勒疑问谓当来佛也。文殊答问谓过去佛也。三圣同会灵山共开发一乘道也。三佛次第者。要现在佛现瑞表说究竟果乘。弥勒是当来因位之人。犹未达果乘事。故当来佛疑问。必须古佛方达古事。故过去佛释疑也。虽有三佛但有二事。现在佛现瑞就神通轮门。弥勒之问文殊之答就说法轮门。即是衣裓机案以出诸子也。又初是佛方便。正明欲说教。后二是菩萨方便。为发起教也。又释迦是和上。文殊为阿阇梨。弥勒为教授师。此三是二世众生菩萨戒师。共弘一乘之道以利物也。又此三师过去共就灯明佛学法华经。今欲报佛法恩故共开一乘也。就文为二。第一正答。第二两偈开奖物心明佛后自说。诸人今当知下是也。初又二前长行后偈颂。长行为四。一谦让门答。二引事略答。三广引古证今。四分明结答。此答并是从微至着次第相释也。弥勒既高而推文殊。文殊必须谦让。虽言自惟忖而知未有事证。故引过去事答但总引过去事。未知的是何佛。故别出灯明。将引古证今。今何必同古。故第四分明结答也。所言谦让门答者。文殊迹居因位智犹未满。今欲以下测高故须谦让。又弥勒怀疑文殊惟忖。即知所表事大增众敬心。又大人之法示不自高斥矜慢之徒故虽解而让。文殊师利者标能答之主也。语弥勒者对质疑之人也。及诸大士者弥勒以下八万之流也。善男子等者声闻四众天龙八部也。如我惟忖下正明谦让也。惟谓思惟忖名寻忖。如伏惟伏度之例也。今佛世尊下出所惟忖之事也。旧云初后二句皆一法说也。中间三句即为譬。欲说大法者。初段经开三显一也。演大法义者。后段经开近显远也。又欲说大法者。初段略开三显一。后说段略开近显远。演大法义者。初广开三显一。后广开近显远也。雨大法雨者三句譬说也。亦有二义。吹螺以改号。譬说改三乘之号。击鼓诫兵使其齐一。譬明一实之理改三乘之号。即开方便门。明一实之理即显真实之义。后段改近之号显远之理也。雨大法雨者。润二乘枯槁即生长一乘之解。通上二段也。今明谨依经文合此五句为三。初句明大法体。次三句明大法用。后一句明大法义。但明此三者。凡说法要具三。一教体二教用三教所表理。故但明三也。明大法体者。谓佛欲说乘方便乘真实身方便身真实之大法也。雨大法雨者明大法用也。三譬有四用。雨譬有能生能灭二用。螺鼓有远闻欢喜二用。所言大雨者。小乘之法教即未圆理非究竟。其由种植待于灌洒常苦不足。大乘之法教无不圆理无不极。其由时雨普降无不沾洽普皆如愿。此皆对小以明大。故言雨大法雨。雨有二义。一者能灭二者能生。言能生者。时雨未降地虽有种而不得生也。已生之牙而不增长。非但不长亦乃枯椊。法雨既降未发大心即便发心。即回小入大之人是也。已发心者即得增长。直往之人是也。已增长者即便成就。八生一生当得佛者也。又应退者而不堕落即菩萨疑网皆已除也。言能灭者。譬如大雨能灭四种。一淹尘土。二灭诸毒。三除热气。四止恶风。法雨亦尔。一能灭凡夫二乘有所得恶觉观尘土。二能灭凡夫二乘有所得爱见诸毒。三除凡夫二乘有所得邪师等热气。四止凡夫二乘有所得邪教恶风。次大法螺击大法鼓者。上叹大法有能生能灭之用。今叹大法有远闻称机之能。外国以螺鼓为俗乐凡有二义。一者欢适。欢适有二义。一畅十方佛心。如今我喜无畏。二称悦根性。如三根声闻及弥勒十二种人得益欢喜。二螺鼓远闻之义。显大法有广被之能。如三会说。初令灵山一会闻法。次净土会闻。次十方通达无碍十方得闻。乃至未来得闻。演大法义者第三明大法义

问。上明大法与今何异

答。上明教法今明理法。教法但称为法。教所表理即称为义

问。何以知然

答。如法无碍义无碍。即是明于教理。又如涅槃经释七善。知法者知十二部经。知义者知十二部经所表之义

问。云何名法云何名义

答。大乘之教能诠二权二实之文名之为教。所诠二权二实之理深有所以目之为义。又二权二实并皆是教。非权非实非一非二寂灭之道微妙甚深。故名之为义。盖是一经之大宗也。故下文云究竟涅槃常寂灭相终归于空。与大涅槃更无有异。故知法华是究竟教也。诸善男子下第二举事略答。时众疑云。何以知欲说大法。故今释云。于过去世曾见此事。故知欲说大法。以惧其不信故指事答之。又犹是释谦让义。文殊虽复明达。不言其现知但推往事以答其问。即是释谦让也。又前用现智知当说法。今用宿命智知当说法就文为二。一者引古证今。二者将今类古。是故当知下引今类古。咸得闻知者。闻谓闻教。知谓知理。难信之法者。若言低头举手皆成佛者。何难信之有耶。假令罗汉作佛亦非难信。今明一切世间心行有所得。闻无所得即乖反其心。故多有恐难信。言无所得者。尚未曾一。云何守三。以心不染三一故名难信也。又讲法华。人闻未曾有三一。便谓是真谛非是一乘。亦言一乘便云万善。故起有无二见名有所得也。若能离此诸见名无所得。即信解一乘。诸善男子下第三广引过去事释答。释答者。上虽引过去事未知的是何佛。故今别出其事。上即是总标为章门。今广引即释章门。就文亦二。第一明过去佛说法华前事。第二明说法华已去事。所以分此二事者。上明东方现在诸佛。弥勒开为二事。今文殊引过去佛亦有二事。欲显释迦亦有斯二事也。此二章中各开两别。初文二者。一明初佛二辨一切佛。初文有三。一时节二化主三教门。地持论明劫有二种。一日月岁数不可数名小阿僧祇劫。菩萨能超之。二大劫不可数名大阿僧祇劫。菩萨不能超之

问。何故不引近事而乃明久劫耶

答。欲显一乘是古旧法令物信解之也。又此时中释迦文殊弥勒共在其中。余时不必同处也。佛名日月灯明第二化主。就文为二。前明别号次辨通号。别号明诸佛迹异。通号显诸佛法身本同。又别号显诸佛应迹优劣。通号明诸佛众德齐等。名日月灯明者。注经解云。圣人无名借义以立称。仁者见谓之仁。智者见谓之智。上根因之以得明如日。中根因之以得明如月。下根因之以得明如灯。三根资之以得明故言日月灯明。有人言。日阳而动以喻方便慧。月阴而静喻于实慧。以二慧益物如世间灯明。又日月喻定慧。以定慧为灯明。有人言。此佛出世身光如日月。常照世间为世灯明。次明十号者经说不同。通即称号。号令天下显化他之义。别即称名。名以定体。即是自行。又通别皆称为号并称为名。故言号日月灯明。名为如来应供也

问。号以何为体

答。号是名字。依成实论名号是音声性法入摄。毗昙别有非色非心名字句。与声和合故有名号。若此十种为至人立号。即以至人为体。若依于极德以立十号。以福慧为体

问。云何为十耶

答。经论不同。璎珞经云。一如来乃至第十佛世尊。以佛世尊合为一号。智度论云。第十是佛也。世尊是十数外总号也。成实论云。具上九号名为世尊。演说正法下第三辨教门。就文为二。初明一乘教。次辨三乘教。如上将彼显此法华之前有二种教。将古证今法华之前亦有二教

问。何故三世诸佛将说法华明二种教耶

答。法华既会三归一。必须前明于一说三。如三世诸佛欲说法华说无量义经。入无量义定欲显出生收入之义设教之始终也。演说正法者。演一乘之法名为正法。弥勒叙东方佛法轮已广明。今但略说法也。次明七善者。良由具七善故名为正法。故举七善释正法也。七善通大小乘。今明大乘七善也。如涅槃名字功德品以七善叹涅槃经。今亦以七善叹根本法轮也。数七善不同。有人言。合初开后故名为七。合初三总名为时善。第二义善。第三语善。第四纯一无杂。第五具足。第六清净调柔。第七梵行之相。此是成论文意也。有人言开初合后。开初三为三时善。第四义。第五语。第六纯一无杂。第七具足。清白梵行之相还属纯一无杂所摄。此是智度论及注经所释意也。三时善者。成论三善品云。少年说法为初善。中年说法为中善。老年说法为后善。又言初舍罪。中舍福。后一切舍。智度论云。赞叹檀度为初善。次叹尸罗为中善。是二波罗蜜所得果报若生诸佛前及作人天名为后善。又说声闻为初善。缘觉为中善。菩萨为后善。依宝箧经声闻菩萨各有三善。声闻三者。初即从他闻法。中即如说修行。后即得圣正见。又初即见苦断集。中即修道。后即证灭。菩萨三善。初即发菩提心。中即不念二乘。后即回向一切智。又初行施等六度。中破悭等六弊。后回向一切智。依文释者。谓根本法轮一部之内序正流通为三善也。以大乘一部具此三也。若望教始终者。初即根本法轮。中即支末法轮。后即摄末归本法轮。其义深远其语巧妙者。自有语虽巧妙而义浅近。自有义虽深远言即粗拙。自有俱无也俱有。佛法竖不得其底。谓绝四句为深。横不见其边。越百非称远。又心行灭故为深。言语断故为远。正是根本法轮义如此也。注云探赜不可究曰深。绵邈不可及曰远。其语巧妙者。言能称机曰巧。语能显理云妙。注云方圆无所差曰巧。幽求不可睹曰妙。纯一无杂者根本法轮。纯明一道清净不杂说五乘之法也。智度论云。离三毒垢故云纯一。但说正法不杂非法故名无杂。亦是清净也。成论云独法。独法者佛有此法。又独行佛教得道耳。具足者根本法轮教圆理满也。又通明者佛法无短缺也。智度论云。八圣道分六波罗蜜备故名为具足也。清白者。上明纯一正法不杂非法。即明教体也。今明根本法轮教能令离凡夫二乘烦恼垢故名清净。谓教用也。梵行之相者。梵名涅槃。即根本法轮大涅槃也。行即万行。到大涅槃也。若依小乘名小涅槃。行谓八正。修于八正能到涅槃。而此八正为涅槃家相。故云梵行之相。又梵名涅槃。行涅槃行为梵行。行义显彰为相。教是梵行之缘。缘中说果故云梵行之相。又释教能诠梵行。即是梵行家相也。为求声闻者第二明三乘教。古佛之缘亦有不堪受一。故于一说三。依毗昙宗。三乘行行乃异。而同见四谛以成三乘果。依成论宗。三乘同见一灭谛以成三乘果。言缘觉观因缘者。此是因时习观悟道远缘耳。依大乘三乘同观实相。故正观论云。得实相者有三种。但根有利钝。见空浅深故开三也。今文云说应四谛法者。机教相称故言应也。次复有佛下第二明余一切佛也

问。何故具列二万佛耶

答。欲引过去多佛为证使闻一乘信受也。文有四句合为两双。初明道名俗姓同也。日月灯明道名也。姓颇罗堕俗姓也。真谛三藏云。翻为利根仙人。六姓波罗门中一姓也。又翻为辨才。又翻为满。满正也。余亲闻天竺僧云尔满也。弥勒当知下明十号之人七善之法。人法一双同也。又道名俗姓十号此三句明人同。七善是法同也。所以明诸事同者。同体一极之道。引古例今欲显今佛欲说一极之道也。其最后佛下第二正明法华已去事。就文亦二。第一明法华事。第二明涅槃事。法华事有二。前明序说。次明正说。序说为六。一众集序。二说经序。三入定序。四现瑞序。五疑问序。六答问序

问。过去诸佛皆说法华。何故偏引最后灯明佛耶

答。凡有二义。一者释迦文殊弥勒三圣于时皆在灯明佛之坐。而三圣复共闻经。今欲令弥勒自证验之故引灯明佛。余过去佛三人不必在坐故不引之。二者八王子中第八王子即燃灯佛。亦在灯明之坐。而释迦既从燃灯受记。此即是以近覆远。今欲开近显远。故须引燃灯事来也。若引余佛第八燃灯不必在坐故不引之

问。何故初引八王子耶

答。八王子即是法华之缘。如大通智胜佛十六王子请说法华也。就文有二。初列八王子之数。是八王子下次叹其德。前叹在俗治化之德。是诸王子下叹出家德。亦随出家者前明身离也。发大乘意次明心离也。初明菩提心也。常修梵行者行菩萨道也。已于千万佛所者。前叹现德今美往因也。是时日月灯明佛下第二说经序。佛说是经已下第三入定序。是时天雨下第四现瑞序。现瑞序为四。一雨花动地瑞。二睹瑞。三放光瑞如今所见。是诸佛土下第四睹光瑞。亦应具列七事。而例上可知也。弥勒当知下第五疑问序。时有菩萨名曰妙光下第六答问序。有人言。灯明因妙光说法华。释迦因药王说法华。今谓不尔。灯明因妙光说释迦因文殊说。以文殊引古证今释时众之疑。如来方得起定说法。故知因文殊也

问。今但云时有菩萨名曰妙光。何以知是答问序耶

答。上明如今所见是诸佛土。古见与今见既同。当知昔答与今答无异。故直标其人略答辞也。又古人今人更无异人。即今答古答犹是一答。但标其人即答可知矣。今发问既是弥勒。将今例古。昔问应是德藏菩萨也

问。何故复云八百弟子

答。欲述弥勒本缘也。以往昔与文殊既为师资故。今世还须问答也。是时日月灯明下第二正说法华也。上来至此凡有三同。从初至所可说法初中后善。谓曾见与曾见同。从其最后佛至八百弟子明曾见与现见同。从此文去竟后明曾见与当见同。六十小劫不起于座者。智度论云。小乘法中无不可思议事。唯大乘法中有之。如六十小劫说法华经谓如食顷

问。文殊何故引此语来耶

答。有二。一者此事不可思议。小教所无唯大乘中有。欲令大众闻佛说法华经起奇特想也。二者欲显法华义富文广。故须长时说之。亦是叹法华以发物敬信也

问。实是六十小劫。云何能令如食顷耶

答。长若定长不可促长令短。短若定短不可延短使长。以长短无有定性。因短故长长名短长。由长故短短名长短。以长名短长故长可为短。以短名长短短可为长。所以然者。以道既无二即长短不二。不二即长短无碍。可得促长为短也

问。虽有此言其相犹难显。云何示之

答。如一夕之眠梦经百年之事。而百年之长宛然一夕之短如故。即其事也。注经云。维摩能申七日以为一劫。促一劫以为七日。况玄匠开真一之门。何为不能长劫为短时耶。但或言借义以标名。未必是神通之实事耳。世有重一言而贱千金惜寸影而遗尺璧者。虽复俄顷之谈。实过累劫之宴。若依唯识者。长短以心为体。故长短无定。如世有称意人共语者不觉夜长等也。故知身心不动足知一日为千载矣。日月灯明佛下第二明法华后事。就文为六。一唱灭。二授记。三正灭。四妙光弘宣。五匠成八子。六述弥勒本缘。所以唱灭者。欲明此经辨二实二权理已究竟。所应度者皆已度讫故唱灭也

问。灯明佛说此经竟即取灭度。释迦何故更说涅槃

答。有人言。灯明佛说法华竟亦说涅槃。但文隐一边故言不说耳。今明不尔。注经云。朝说经竟夜即入灭。故知不说涅槃。又迦叶佛时虽有涅槃以人根利不须说之。灯明亦尔。释迦出于恶世。利根闻法华已悟故涅槃指法华云。八千声闻得授记别成大果实。如秋收冬藏更无所作。故知法华明义已圆利根早悟。但钝根未解故更说涅槃也。时有菩萨名曰德藏第二明授记。大众既闻涅槃咸生恋慕。今欲止彼哀情故次明授记。前佛虽谢后佛续兴不须哀也

问。华严经云。欲令众生生欢喜善故现王宫生。欲令众生生恋慕善示双林灭。今云何止恋慕之情耶

答。唱灭生其恋慕之善。止哀息其乱道之恶。前后义异无相违也。号曰净身者。累无不尽为净。德无不圆称身。广说十号则举此土之名。略说三号即存彼国之称。如来为人。应供为断。正遍知为智。人具智断在义略圆故但三也。佛授记已下第三正灭。言无余涅槃者凡有三义。一约小乘明余无余。烦恼尽为有余。望后犹有余身智在。约后别前名前以为有余涅槃。身智尽竟望后更无余身智在故曰无余。二就大乘说余无余。五住因尽为有余。二生死果尽为无余。若小乘前得有余后得无余。大乘一时而得。但举佛果望于二患。无因患边说为有余。无果患边说为无余。又依摄大乘七卷金光明意。前得法身究竟名无余。应化两身非究竟为有余。三身品又云。三身合论即是无住处涅槃。应化二身不住涅槃。法身亦不般涅槃。不般涅槃者。法身本来常寂灭故不入涅槃。即是法身不住生死名无住处涅槃也。三者明大小乘合辨余无余。以小乘为有余。大乘明无余。如胜鬘经说。生死有二。有为无为涅槃亦有二。有余无余。凡夫生死名曰有为。圣人生死名曰无为。除分段生死名有余。以前望后余有生死在。余有涅槃在故名有余。无有生死之处所得涅槃名曰无余。望后无余生死故。又亦无其余涅槃故名无余也。所言入者凡有三种。一就实论入。入由证也。以证于三德涅槃故名为入。二就应辨入。迹身在为有余。灭迹已归无余。即舍有入无名之为入。三真应合名入。谓息应归真。三种入中今是第三入也。佛灭度后下第四妙光弘经。以昔有弘经之能。用显今有释疑之德。前明授记谓未来有佛。今辨妙光现在有师。以两世有人可凭有法可觉。哀情方止故辨妙光弘经。又上明于佛有缘者闻灯明说法华。今于菩萨有缘者闻妙光之说。又欲辨燃灯远缘开后寿量之义。故须明文殊弘法。日月灯明佛八子下第五明匠成八子。初文列八子。为说法华之缘开释迦初分经也。今明八子意在燃灯。以开释迦远寿之义开后分经也。所以然者。燃灯授释迦记妙光化八子。即知文殊是释迦九世之祖师也。此即是以近覆远。而文殊今遂为释迦弟子。即欲显释迦为文殊之师。故知久已成佛。便是开近显远之义也。又后分经既开近显远。今前牒以近覆远也。八百弟子中有一人者第六明弥勒本缘也。自上已来答弥勒问明释迦说法华经事竟。今此文别释疑。疑云弥勒既是补处。云何问文殊。是故今明过去本是师资所以今有问答。文殊望弥勒是第十世师也。今见此瑞下第四分明结詶其问。虽有四门不出标释结。初标欲说大法。次再引古证今。谓释欲说大法。今结欲说大法也。尔时文殊师利下第二偈颂。弥勒说偈不言大众者。欲显文殊明见往事巧释众疑益于大众故言大众。弥勒不尔故不言大众。又显事分明是公灼之说故称大众也。弥勒为宾既有长行与偈。文殊为主事亦同然。四十三偈颂长行者。长行四门。一谦让门。二略引往事答门。此二犹未分明。今略不颂也。但颂第三广引过去事答门第四分明答门。长行就初门为二。一明法华前事。二明法华已去事。今颂此二即二也。法华前事又二。一明初佛。二辨余一切佛。今合颂之凡有四句。初半行明时节。半行明化主。一句辨教门。三句序徒众。化主良医也。教门良药也。徒众服药病愈也。摄事既周。但明三事也。佛未出家时下第二颂法华已去事。长行有二。一明法华事。二明涅槃。今还颂此二也。长行序有六。今但颂五。初一行颂众集序。次一行颂说经序。次一行颂入定序。天雨曼陀华下颂现瑞序。长行为四。一雨华动地。二时众睹瑞。三现光瑞。四睹光瑞。盖是两感两应。以相着也。今偈中转势颂之。三瑞并是能化事故为一类。二睹瑞是所化事复为一类。故以能所为一类也。一行颂雨华瑞。半行颂动地瑞。一行半颂放光瑞。诸天龙鬼神供养人中尊者。长行直明雨华。今释雨华所由。谓诸天供养佛也

问。既是诸天供养。云何是佛现瑞

答。以佛神力及说法华之力。能感诸天供养也。又见诸佛土下此颂睹光瑞也。长行前明睹雨华动地瑞。后明睹光瑞。今偈文转势颂之。前逐近颂睹光瑞。次颂见雨华动地瑞。颂睹光瑞为六。一行偈颂见国土。一行颂见人物。一行半颂见化主。半行颂闻教门。二行颂见声闻。三行颂见菩萨。此六即次第。要前有国土故初明见国土。有国土故有人物。有人物故有化主。有化主故说教门。前禀小教故有声闻。后禀大教故成菩萨。颂化主中半行叹佛德。一行美佛形。尔时四部众下一行颂睹雨华动地瑞。各各自相问下半行颂第五疑问序。以昔答今。答更无有异人故略无答问序也。天人所奉尊下四行颂正说法华也。赞妙光菩萨者。以妙光善决众疑。逆杜谤情预开信解。即是世间眼也。一切所归信者。前叹决疑之能即开发法华。今叹持法证法预明佛灭后弘经之德也。持谓解语。证谓解义。具斯二德可以弘经也。以妙光既于佛灭后弘经。令物信受故叹斯两事也。佛说是法华下。此第二颂涅槃事。长行有六。一唱灭。二授记。三正灭。四弘宣。五匠成八子。六述弥勒本缘。今还颂此六也。长行略明唱灭。偈文广释之。即长行为章门偈解释也。此中有四。初二行唱灭。次一行诫劝。一行时众悲哀。一行安慰。初二行为二。初一行半明唱灭意。次半行正唱灭。初有二意。令众欢喜已谓利物毕。半行诸法实相义。明说教周。为此二事故宜应取灭。次半行正唱灭如文。是德藏菩萨下一行半颂授记。初三句明堪授记之德。次三句正明授记。亦是偈释长行。佛此夜灭度下二行颂第三正灭。二行为三。半行明正灭。半行明在家人起塔以生福。一行明出家人修道以生慧。即辨灭度之利益。前明唱灭生恋慕之善。今明正灭生福慧之益。如薪尽火灭者。依小乘义。以身为薪。智慧为火。故智慧依于身身尽智便灭。又以烦恼为薪。以身为火。佛烦恼既尽身永不生故异凡夫灭也。就大乘释者。薪喻于感。火喻于应。众生感尽诸佛应息故。是妙光法师下一行颂第四弘经。是诸八王子下三行颂匠成八子。是妙光法师下六行颂弥勒本缘。开之为三。两行半颂弥勒之失。两行半颂弥勒之得。一行颂结会古今。我见灯明佛下二行颂第四分明结答。半行明将古类今。半行将今类古。半行释古佛现瑞意。半行释今佛放光意也。诸人今当知下两行第二大段开奖物心。初行明好事应来。即是一乘解生。次行明恶事应去。即三乘惑灭。佛说一乘而有生解灭恶之两益也。又一乘解生遂致成佛。谓德无不圆。三乘惑断即累无不尽。斯二事最大宜豫欣也。合掌一心待者。令住二仪待佛后说。合掌住身正威仪。谓身无别用。一心住心正威仪。谓意无他缘。充足求道者。昔说小乘教犹未圆理犹未满。故生解不足。今与此相违名为充足。充足者证得法身果也。次偈上半牒三乘人疑。下半明佛为除断也

法华义疏卷第二法华义疏卷第三

        胡吉藏撰

    方便品第二之一

有四重门。一来意门。二释名门。三同异门。四通别门

问。此经玄音始唱叹佛智甚深。多宝赞善称大慧平等。故文虽七轴宗归一乘。今以何义初明方便

答。将欲显一乘为真实。必须前明三乘为方便。若不前明三乘为方便。即不得显一乘为真实。故此经云。开方便门示真实相也。注经云。既唱拟一之端。宜前辨分三之意。并其证也。释名门者。外国称伛和拘舍罗。伛和称为方便。拘舍罗名为胜智。谓方便胜智也。但方便之名有离有合。所言离者凡有三义。一者就理教释之。理正曰方。言巧称便。即是其义深远其语巧妙。文义合举故云方便。此释通于大小。不专据三乘。二者众生所缘之域为方。如来适化之法称便。盖欲因病授药。籍方施便。机教两举故名方便。此亦通于大小。非专据于三乘。三者履崄得安称方。禀教获利称便。五浊之崄非三乘则不安。故云履崄得安。禀三乘教则便获利。故以教为方以益为便。教益双举故云方便。此亦通于大小。非专据三乘。次合释者凡有三义。一者方便是善巧之名。善巧者智用也。理实无三。以方便力是故说三。故名善巧

问。无三说三。云何名善巧

答。由无三说三众生遂得实益。故名善巧

问。既得实益应名为实。云何乃言方便

答。就益而言亦得称实。今望理实无三假名说三。据理望教故名方便。二者说于三乘为令众生悟入一乘。故此三乘为趣一乘之由渐。故名方便。如下文云我设是方便令得入佛慧又云我此九部法入大乘为本。故说三乘为一乘之方便也。三者合前二义圆成一旨。所以无三说三者。欲令因三悟不三。是以二言合成一意也

问。三乘方便有几种

答。凡有三种。一身方便。如现作二乘及垢衣长者树王之佛。二口方便则无三说三。谓虚指门外明有三车。三意方便则二思惟也。一思惟寻念过去佛。二思惟我出浊恶世。此则上同古佛下顺众生。二种因缘起方便智。谓意方便也。同异门者

问。旧亦明三乘为方便一乘为真实。与今何异

答。今序经始终凡有四意。一以三乘为方便以一乘为真实。所以立此义者。昔禀教之人执三为实。不知三是方便。为欲行之故明三是方便一为真实。令舍三以入一乘也。二者禀教之徒虽复舍三遂封一实。粗惑虽去细染寻生。为对彼故明三之与一皆是方便非三非一乃称为实。三者禀教之流乃识二是方便。更封两非为理极。是故今明三一为二。非三非一名为不二。二与不二皆是方便非二非不二乃是为真实。四者二与不二乃至非二非不二犹是四句未免名言。并称方便。诸法寂灭相不可以言宣乃为真实也。乘方便乘真实既有四阶。身方便身真实亦有四句也。一以短为方便长为真实。二者以长短并为方便非长非短为真实。三者长短为二非长非短为不二。二与不二并是方便非二非不二乃名真实。四者二与不二非二非不二犹是四句未离名言。并名方便。如来法身四句斯忘百非皆绝乃称真实。故寿量品释法身云。非实非虚非如非异。具足十不。如彼文说之。通别门者。据别而言。正以三乘为方便。就通论之。方便是善巧为义。善巧通今昔也。今欲融会三一之所由。称叹诸佛之善巧。所以然者。昔辨三教今说一乘。前后相违义成鉾楯。则物不生信故会释云。所以昔三今一者。盖是深照物机善巧施教。故不相违也。故方便是三一之总名。今昔之通称。是以命初题方便品。但此义难明。今以四句显之。一者昔开今覆谓昔开三今覆三。二者昔覆今开谓昔覆一今开一。三者今昔俱覆昔覆一今覆三。四者今昔俱开昔开三今开一。所以有此四句者。皆是如来知机识法善巧为缘。无相违背。故悉名方便。所以方便通今昔也。次举无方便四句对显之。一者昔缘执三覆佛一。不知说三为开一。二者今缘执一覆佛三。不知虽一不失三。三者执自性三覆佛因缘之一三。四者执自性一覆佛因缘之三一。如此昔执皆是无方便。故无方便亦通今昔也

问。何文明方便通今昔耶

答。下三请文云诸佛第一方便。夫三乘是方便不名第一。一乘是第一不名方便。今言第一方便。则知是诸佛善巧智名第一方便。有此巧智故能说一三也

问。亦得云一乘名方便故言方便品以不

答。亦得尔也。故胜鬘经云一乘大方便。即是诸佛大善巧。胜鬘明一乘而题称一乘大方便。法华开宗之首亦宜用一乘为方便也

问。何故用一乘为方便耶

答。如百论依空舍福。而论文云用无相舍福。释言以是方便则能舍福。若舍有而滞空不名为方便。舍有不着空故名为方便。智度论云。破常而着无常名无方便无常。破常不着无常名有方便无常。又云破二不着一是名为法忍。今亦尔。为破二乘故明于一亦不令着一。故此一名方便。所以然者。生死以取相为源。入道用无著为本。故下文云。我以无数方便引导众生令离诸着

问。胜鬘大品及此经皆明方便有何异耶

答。凡有四句。一合乘合慧。如胜鬘合五乘为一乘。故云合乘。若权若实总名大方便。故名合慧。二开乘开慧。如法华云。照一为权照一为实。三开乘合慧。亦如此经序昔二今一。故名开乘。此之三一皆是如来知机识法善巧方便。故名合慧。四合乘开慧。如大品总说一切乘皆入大乘。如会宗品云。若佛法菩萨法二乘法皆入摩诃衍。故名合乘也。就大乘中自开空有二慧故名开慧

问。大品已明一切法皆入大乘。与法华何异

答。大品已会于法但未会人。会法者。欲明大乘无法不摄。故大品云。若有实语摄一切善法者波若是也。未会人者。但二乘人至大品时大机未熟故未会人。法华则人法俱会。会人故同名菩萨。会法名为一乘。又摄大乘论云有二种会。一显会二密会。密会者如大品明。一切诸法皆入大乘。显会者如法华会人也。又有二会。一理会二教会。理会者如大品明。一切诸法皆入实相。实相既无二。岂有三乘异耶。七卷金光明经云。法界无二故乘无有三。但未会三教故不名教会。法华理教俱会

问。三乘是方便亦得名为实不

答。凡有四句。一者于昔为实于今为权。谓对今一以望昔三是也。二者今昔俱实。昔以三为实今以一为实。三者三一俱权。望正道为论。未曾三一。三一皆为开道名为道门。故皆权也。四者今实昔权。今以一为实。于昔为非实义名为权

问。人天乘亦是方便以不

答。若说三十三天常乐我净。指黄叶为真金亦是方便。若直说五戒十善感人天身。不名方便。次开文句者。从此品去至分别功德品格量偈以来十五品半经名为正说。大开为二凡有十种。一者从初品至法师品凡有九品。明乘方便乘真实。次从宝塔品竟后有六品半经。明身方便身真实。昔日三乘谓乘方便也。今明一乘谓乘真实也。昔日生灭之身谓身方便也。今无生灭身谓身真实也。所以双开此二者。释迦一化凡有三时。一者双说。二者双覆。三者双开。言双说者。佛初成道华严之会为诸大士说究竟法明圆满身。故长者居师子坐罗列宝物。即是其事。故说双说。但小器未堪故鹿苑之会隐一明三覆本开迹。是以长者止于傍使更遣余人。脱珍御服着弊垢衣。即是其事。谓双覆也。至法华之会俱开二权双示两实。谓双开也。初之双说谓根本法轮。次之双覆谓支末之教。后之双开谓收末归本。此之三门非但释迦一化。总摄一切诸佛教门。法华结会终始具足三门。但对昔双覆故言双开耳。二者大明佛化凡有三门。法华之前摄一切邪归五乘之正。谓摄邪归正门。此经初分会五乘之异同归一道。谓摄异归同门。此经后分明法身之果。谓引因趣果门。此之三门无教不收无人不化。斯经对昔但有二门。若结会终始具三门也。如玄义序之。三者大明佛事凡有三轮。一知他心。二现神力。三说教门。此之三轮无佛事而不收无群生而不化。但初分经会五乘之教归于一乘。谓说法轮后分之经明延促自在修短适化。则神通轮。故前文云说佛智慧故诸佛出于世。后章经云如来秘密神通之力。则其证也。四者大明佛德凡有三种。一者法身。二者波若。三者解脱。以正法为身故曰法身。无境不照名为波若。无累不尽故称解脱。所以佛德但明三者。法身波若无德不圆。解脱一门无累不尽。但德无不圆复开为二。一者法身。二者智慧。如世间人有身有智。又法身为体。智慧为用。又内智无不照为波若。外感无不应功由法身也。又为对生死但有于三。以对生死报障故说法身。对生死业障故说解脱。对烦恼障明于波若。又总十二因缘不出三道。谓苦道业道及烦恼道。如来登中道第一义山顶。与无明父母别。故永免三道具于三德。又对二乘三德未圆。明如来三德圆。又有法身明如来身业。有于波若辨如来口业。辨于解脱显如来意业。如四相品说。今此经亦具明三德所以称妙。以凡夫二乘不具三德故名为粗。但初分经明于波若。后分之说辨于法身。斯二无累即是解脱

问。后分明法身其文可见。初分云何辨于波若

答。如前云。释迦玄音始唱叹佛智甚深。多宝称善赞大慧平等。即是其事

问。何处有明解脱德耶

答。譬喻品云。二乘但离虚妄名为解脱。其实未得一切解脱。但离虚妄名为解脱者。但免三界分段及见思之惑。若具断五住备倾二死名一切解脱。正用此法简异二乘。令舍保三归于一极。五者总谈大小诸教不出因果法门。但大乘因果凡有二门。一通因通果。二别因别果。通因通果者。通明十方三世诸佛同行不二之因同得一极之果。初分经文正明斯法。谓通因通果。次明别因别果者。别明释迦久已成佛过去行长远之因未来证不灭常住之果。后段经意正明斯法。谓别因别果也。六者总明诸佛。不出权实二智真应两身。照三乘之智为权。鉴一乘之智为实。初分之经正说斯二智。王宫现生伽耶成道为应身也。无始无终非生非灭为真身也后段之经盛谈斯义故辨于二身。七者此经秤妙法者。即是一乘。故譬喻品云。是乘微妙清净第一。于诸世间为无有上。但乘有二种。一所乘之法。二能乘之人具。能乘所乘则乘义始圆。初分辨所乘之法。即是法妙。次现塔以去明能乘之人。谓人妙也。何以知然。如方便品云。佛自住大乘如其所得法定慧力庄严以此度众生。则所乘之法也。见塔以去正释如来常无常义。故辨能乘之人。如此人法更无二体。则一正观两义说之。统御之义为人。可轨之义为法。然正观未曾人法。为众生故强称人法也。八者总论众生迷倒凡有二种。一者迷因。二者迷果。初分之经破于迷因。后分之经斥于迷果。所言迷因者。昔于一佛乘分别说三。则指大因为小果。封教之徒遂执小果以为究竟。不知小果则是大因。故是迷因。今明汝等所行是菩萨道。还指小果为彼大因。破其自保究竟之执。故是破迷因也。后分之经斥迷果者。如来之身实无生灭。凡夫二乘谓是生灭无常。故破彼迷情辨法身常住。所以斥迷果也

问。昔说大因为小果今还指小果为大因者。亦得昔说法身为生灭今还指生灭为法身耶

答。斯义不类。昔覆相说如来身有为生灭。今开方便门显真实义。故辨生灭为应迹。无生灭为法身。但封教之流执迹迷本故开真应两身。而小果大因更无二法。与此非类也。九者总收惑倒凡有二种。一者自倒。二者他倒。初分之经斥于自倒。后分之经破于他倒自倒者。二乘之人实非究竟以颠倒故自谓究竟。故身子云。我今自于智疑惑不能了。为是究竟法为是所行道。则其事也。后分之经破于他倒者。如来果德于二乘为他。自惑己身既入无余。谓如来身亦同灰断。故是他倒。今二段之经双破两倒。初段之经显二乘非究竟除其自倒。后段之经明法身常住破其他倒。既自他倒除则一切惑尽。便改小志发于大心。又初段经破其自倒。令二乘人知彼涅槃非是常住。则破其常倒。后段经文破其他倒。显如来常身破其无常之倒。二倒既除则应期悟道

问。初分经破常倒。备破四倒不

答。具破也。二乘之人自谓彼涅槃为常则有乐净。虽无人我而有法我亦有我倒。故知初经具破常等四倒。后分经备破二乘人。谓佛是无常苦空无我不净。亦具破四倒。此经始终既具破八倒。则是说涅槃竟。所应悟者并皆得道。灯明佛不须说涅槃。意在于斯。但释迦为钝根之人未悟。更广说法华后为说涅槃之教耳

问。前文何处破常倒耶

答。譬喻品云。但尽生死其实未灭。既称未灭。岂是常耶。后破无常者。其文易显

问。二乘俱迷因果自他两倒。是何惑耶也

答。其人四住已倾。但有无明故生斯谬。十者大明说法凡有二门。一者直说。二相成说。初分之经名为直说。直说者。明理无二极唯一道清净。故称为妙。是故文云。唯有一门而复挟小。所言一者。无九十六种之别。亦无五乘之异。唯有一道清净故名为一。至妙虚通秤之为门。不容凡夫爱见之心故名为挟。亦不受二乘断常之见。秤之为小。初分之经正明一道清净。斥凡夫爱见二乘断常。故名直说。后分之经称相成说者。前虽言一道清净。未知此一为是无常为是常住。若是无常犹同九十六种。还同四乘之异。乃是粗法不名为妙。以一道清净常恒不变故超前两异。故名为妙。然所体之法既其是常。能证之人亦是常住。故涅槃云。诸佛所归所谓法也。以法常故诸佛亦常。仍以后常成前独一。妙义始彰故为相成说也。此之十义皆是大判为言。其前章非无后意。后章非无前意。但一往示其起尽从多为论。故作此分之

问。开为二段如上十门。如其不开云何识教

答。经名妙法莲华者。始终皆辨中道不二正观故名为妙。无得无依无所染着故云莲华。凡夫著有二乘滞空菩萨着中道。如是一之与三常无常乃至一毫取着皆是粗法。不名为妙。并为染累非是莲华。今但令得一正观则具一切佛法。正观微妙故名妙法。至人用此为身名为法身。诸佛以此为性故名佛性。独一自在名为一乘。无境不照称为波若。无累不寂名为涅槃。故云波若是一法。佛说种种名随诸众生类为之立异字。故学者但须观心清净。是以文云。大事因缘出现于世。谓开佛知见。佛知见者则正观也。虽有十义今且依乘方便乘真实身方便身真实以开二段文也

问。初段明乘真实者。为正明因为正明果

答。初段略说广说及后证说并叹佛慧。则正明果乘义也。所以然者凡有二义。一者果乘德无不圆累无不尽故称为妙。可喻莲华。莲华者以其台叶具足如德无不圆。清净无染如累无不尽。故云是乘微妙清净第一。故以果乘为正。因乘德犹未圆累未尽故不得称妙。阙斯两义故不得喻如莲华也。二者初分之经正明二乘果是方便。故明一佛乘为真实。则令舍小果求大乘果。故明果乘为正也。既明一佛果乘。则以二乘之果摄属因乘。令彼修于佛因以求佛果也。就前后二段各开四别。初文四者。第一略开三显一动执生疑。第二执动疑生申疑致请。第三广开三显一断疑生信。第四辨流通。所以有此四段者。今日时众宜大机已动。应开一乘之说。但执三来久未得广明。且略开三显一以动执生疑也。禀教之流忽闻非常之说。故执动疑生申疑致请。执动有可除之义。疑生有可解之理。既其有请故受请广说。破彼三执断其一疑生于信解。此一周说竟。欲远被未来。故次辨流通。示文处者。从此品初尽长行与偈第一段也。从尔时大众中竟身子三请第二文也。从尔时世尊告舍利弗竟授学无学人记品七品半第三文也。法师一品第四文也。就初文为二。第一因叹二智仿佛开宗。第二分明略说。所以前仿佛开宗后分明略说者。正言一实之理。不可直说。三执不可顿排。今欲悟物以断疑。故叹佛二智非二乘所知。叹佛二智则仿佛显实。明二乘不知则仿佛开权。前章既以仿佛故后稍渐分明。但未得广陈所以略说。就初段又二。第一长行第二偈颂。长行有二。初寄言叹二智。二止言加叹二智。初又二。一叹诸佛二智。二叹释迦二智。初叹诸佛二智又二。前经家序佛从定起及出对扬之人。次正叹二智。尔时世尊者。佛入三昧所作事讫。今是说法时至故从定起也。三业而言。入定意业利益。放光是身业利益。今欲明口业利益故从定起也。安祥者示大人之相。欲明大法故先示大人相。又安祥者动寂无碍也。故论云。显如来定力自在无人惊动故称安祥。告舍利弗者出对扬之人也

问。何故不告菩萨也

答。声闻自保究竟。今欲斥之是故告也。菩萨无有此患故不告菩萨

问。何故不告缘觉

答。法华之会无缘觉果人。虽有缘觉因人。不及利根声闻故不告也

问。此经开宗告身子。与大品何异

答。大品密告以密令小人而学大也。此经显告。显令声闻修菩萨道故显告也

问。若尔何得智度论云。大品非秘密法华为秘密

答。大品不明二乘作佛但明菩萨作佛。其义易解。如用药为药。故不名秘密。法华明二乘作佛。望昔为难解。如用毒作药。故称秘密

问。此经就谁为难易

答。大品望昔教阿难易解。以菩萨是大人还明大人作佛。故阿难解之。所以大品付嘱阿难。法华明二乘作佛异于昔教。于声闻难解。故法华不付嘱阿难。所以告声闻者。依法华论意凡有五义。一令声闻人修行大因。二令取大果。三令声闻人修行大因与于大果心不怯弱。四者为欲令余人善思念故明。佛对小心尚令作佛。余人岂不求作佛耶。五者令声闻人不起所作已办心。故前令取大果。今令弃小果

问。何故不告余声闻独告身子

答。身子根缘先熟最初领悟。又是逐佛转法轮大将。又今说平等第一智慧。宜对智慧之人。又根缘所宜故也。诸佛智慧甚深无量者。第二正叹诸佛二智也。无有人请而佛自说者有二义。一者示如来大悲纯至机动则说不待他请。肇公云。真友不待请。如慈母之赴婴儿。二者欲显理深玄无人能问。故自说也。如下偈云。道场所得法无能发问者也。所言智慧者经说不同。或但一果智谓如实智。以因中惑犹未尽所照未真实。果地惑无不净故智无不实也。或开二智照空为一切智。鉴有为一切种智。此从所照二谛为名。以法莫离于真俗故智唯开于二也。或开三智。如此经嘱累品说。佛智．如来智．自然智。佛智一切种智也。如来智即一切智也。自然智则无功用智。上之二智任运而知。不须作意故称自然。又云四智。如譬喻品说。前三同于上。第四称无师智。无师智者。上三智不从师得也。此四智是经之正宗故称诸佛智慧也。就文为三。初双标。次双释。后双结。诸佛智慧者标佛实智也。甚深无量者叹佛实智。然凡夫二乘及以菩萨不能测量佛智源底故名甚深。亦不能测量佛智边岸故称无量。如无量寿经云。如来智慧海。深广无崖底。二乘非所测唯佛独明了。法华论明甚深有五种。一义甚深。谓佛果德有无量义。二体甚深。谓平等法身无有差别。三内证甚深。谓佛证于法身与法身相应名内证也。四依止甚深。十方佛同依止法身故。五无上甚深。无上菩提是佛所证。果德要具此五也。又甚深者四句莫得其底故曰甚深。百非不测其边故曰无量

问。应但言深。何故云甚深

答。深中之甚故云甚深。然如来妙观未曾愚智。为对二乘之愚强叹为智。亦非深浅量与无量。为对二乘之流不能测量故云无量。故华严云。法界非有量亦复非无量。牟尼悉超越有量及无量也。又偏叹佛二智者。意欲明唯佛智究竟余智未究竟。此是显究竟以密斥二乘非究竟也。论又云。为诸大众生尊重心毕竟欲闻如来说故。所以叹佛智也。又说法有二门。一叹药门二授药门。今略说是叹药门。后广说是授药门

问。佛德无穷。何故偏叹智慧

答。一乘以万德为体。于万德之内慧为其主。故偏叹慧也。其智慧门。第二标权智叹权智也。其智慧者则牒上智慧也。门者权智。说一切教为通佛智。故以一切教为佛智慧门。故正取一切教为门。如药草喻品云。于一切法以智方便而演说之。其所说法皆悉到于一切智地。则其证也。又教能通生观解。为解为门。然教能生实解。与实解为门。亦令识权与权解为门。难解难入者。始不能知为难解。终不能悟为难入。一切声闻辟支佛所不能知者。出不解之人也。上叹佛智甚深。为欲显一也。其智慧门难解难入乃至二乘不能知。为欲斥二乘也。二乘所以不能知者。如来于一说三。为令因三通一。故三为一门。二乘遂住于三。不能因三以悟一。是故不能知三也二乘既不解三。又不入一则住在门外。故下偈云在门外立

问。上既明难解难入。何故但言不能知耶

答。二乘尚不能知说三以表一。何况能因三以入一耶。所以者何下此第二双释诸佛二智也。所以实智甚深无量权智难解难入者。以行因既积故果深妙难解难入也。亦应对二乘。所以不解者。殖因既近果智便钝故不能解也。此文二句。初句明值佛既多。次句明修行久积。修行久积中二句次第。初句正明修一切行。次句明虽复修行而精勤勇猛。前句明所策之行。次句则是能策之勤。名称普闻者。德树于内故名流于外。又所以知备修众行及精勤勇猛者。以修行诸行时名称普闻故证知尔也。又依摄大乘论明四种修者。供养无量百千诸佛者。值佛既多经时必久。谓长时修也。尽行诸佛无量道法者。无一行而不修。谓无余修也。勇猛者。修行之时心不悠悠至到勇猛。谓尊重修也。精进者。念念善法相续不令余念间之。谓无间修。前是顿方便

今是常方便也。此之四修则是内德。以内德既备故外名普闻。成就甚深下第三双结二智。前结实智。随宜所说次结权智。所以复须结者。以义有三门。谓标释结方乃具足故也。舍利弗吾从成佛以来下。依法华论。上来明妙法功德门。谓如来所证妙法甚深难解难入。今叹如来法师功德。以佛成就诸功德故能化众生。二者上叹诸佛二智。今第二叹释迦二智也。所以前明诸佛后辨释迦者。示悟物以渐也。前辨诸佛开宗。后明释迦随顺则使执三之流不生疑谤。就文亦三。一叹权智。二叹实智。三重叹权智

问。今叹释迦二智与上何异

答。凡有三义。一者上略叹二智。今广叹众德。初略后广为解义故。二智是一乘之主。故初略叹二智。果乘无德不备。故后广赞众德。二者叹诸佛明从实起权。叹释迦以权通实。三者叹诸佛举因释果。叹释迦举果释果。吾从成佛已来者叹权智也。前叹权智凡有二义。一如上释诸佛从实起权今从权起实。二者遂文势相接。上略明权智辨难解难入。故今广释权智明难解难入之意也。吾从成佛已来者。此言成道凡有二义。一者王宫现生伽耶成道。从此已来施方便。二者依下经文。明久已成佛。从此已来施于方便。此明用权智之时节也。种种因缘者第二正明用权智也。因缘谓三乘人所度因缘也。明其入道不同由籍各异故云种种也。种种譬喻者凡有二义。一者为三乘人各说譬喻。如智度论云。佛于三藏中为诸声闻说种种譬喻。但不说揵闼婆城喻。乃至为诸菩萨广说十种喻等也。三藏中所以不说揵闼婆城喻者。为三藏不说一切法本性空。干城喻辨能成之因所成之果本无所有。故三藏中不说也。而成实论亦有此喻者。引菩萨藏中譬就小乘法中释耳。二者三乘人合喻。如三鸟出网三兽度河也。广演言教者。上喻今法也。无数方便者。上之法譬皆是善巧故名方便。又上法譬皆是口业。今明身业现神通意业密化。谓无数方便也。法华论云。方便者从生睹率天乃至现大般涅槃故也。又云无数方便示现外道邪法显其过失。示现正法功德。又有四种方便。一令入诸善法。二令断疑。三令入增上胜智。四者依四摄法摄取众生。明八相是正方便。今是示邪方便也。引导众生令离诸著者。此明用权意也。所以用无数方便者。为令众生离着故也。以众生染着三界。欲令离之故说三乘。不言实有三乘究竟。汝还遂保执三乘究竟。故不解佛意。故上云难解难入也。又我设方便本令离着。今遂保执三乘。此则是着于无著。故不识佛意也。法华论云著有四种。一着界则着三界。二者着地谓从着初禅乃至非非想及灭尽定。三者着分谓在家分出家分。在家分者谓着己同类作种种业及邪见故。着出家分者著名闻利养种种烦恼诸觉故也。四者着乘谓着小乘及大乘也。所以者何下释权智也。以内德既圆故外用善巧能利物也。舍利弗如来知见下第二叹实智也。上以方便标知见故是权智。今直称知见广大深远名为实智。初句标知见下以四义叹之。照无不遍称广。超二乘之表为大。竖不见其底曰深。横莫究其边称远。无量无碍。旧云四等为无量。四辨为无碍。今依法华论说无障无碍。上标知见次以二门叹之。一广大深远叹智无不圆。二无障无碍叹累无不尽。力无所畏者。从品初至此文虽有诸佛及以释迦但是叹智慧义也。从此文下具叹一切诸德。非独智慧甚深一切诸德亦甚深无量。所以具叹一切德者有二种义。一者以众德为乘。今欲赞叹一乘故备叹一切诸德。二者惑者闻叹佛智甚深谓余德不尔。故称叹余德皆是甚深非二乘所知也。十力是佛内德故初叹之。以知根识药故说十力。以内了十境故外说无惧。故次显无畏。力无畏者叹佛智慧。禅定解脱三昧叹佛功德。禅谓四禅。定谓四无色定。解脱则八解脱。三昧则是空无相无愿。此之四门则是次第。初得四禅次得四空定。具足八禅次得八解。以得八解之定故能证三空门也。然此中诸科皆是一体随义分之。功德积聚故名为禅。敛摄不散称之为定。万累都夷故名解脱。其心正直故云三昧。深入无际者。上别列八科诸德。今总叹之。于一一德佛皆穷其边底。余人不知其际畔故云无际。成就一切未曾有法者。上正叹八科德犹未尽。故今总结叹也。舍利弗如来能种种分别下第三次重叹权智也。接上文生。上明成就一切未曾有法。以内德既圆故外巧说法。外巧说法有二种。一者巧说法。二巧称机。言辞柔软。上叹四无碍智。今赞五种音声。与上叹权智异者。前明说权意。谓令离诸著令其不着小则是舍小。今赞佛巧说之德。令其欣大也。舍利弗取要言之下。如来非但有巧说一能。取要言之具一切希有胜用也。止舍利弗下第二寄止言如叹二智也。上虽称叹甚深无量。犹涉名言未穷称叹之美。至人之智心行已断言语又灭。叹所不能叹。乃穷叹美之极。故寄止言叹名加叹二智也。又止言者则卷束上文归无名相也。上开诸佛二智释迦权实。美实智为甚深。叹权智为难解。此皆是无名相中假名相说耳。然诸法实相未曾有诸佛之与释迦深与不深权之与实。故波若云。诸法非深非妙乃至非智非愚非权非实也。又止言者欲令大众于法起尊重心生后三请故。又欲令五千之徒离法座故。又依法华论云。示法器众生心已满足故。此意明大利根菩萨闻上所说已得了悟不须更说故止言。依此意略说一周正为菩萨。以菩萨利根闻略说则便领解。声闻根钝未能了悟。是故三请闻广说方解。故略说通为大小二乘。而菩萨前解广说偏为声闻。古亦有此一释。就文为两。一标止言。二释止言。初如文。所以者何下第二释止言为二。初明法妙众生不解故不可言。次明唯佛能解故不须言。不言之意唯此两也

问。由来云此经照三乘为方便。照一乘为实智。体终是有法。何得名绝言耶

答。他云一乘之智绝三乘之言也。难曰。虽绝三乘之言犹有一乘之言。何名绝言。又若一乘绝三乘之言名绝言者。三乘亦绝一乘之言。应是绝言。若三一不得互绝。亦应牛马不得互无也。今所明者此中正叹佛智。故下文云。我所得智慧微妙最第一。又云是法不可示。言辞相寂灭。故如来之智非有非无不三不一离人离法绝观绝缘。一切名言所不能及故名绝言。大品云。佛初成道常乐默然不乐说法。所以不说者。肇师云言之者失其真。知之者反其愚。有之者乖其性。无之者伤其躯。以是义故不可言也。唯佛与佛下第二明唯佛解故不须言。释论云。若两佛相对则无所言。则其事也。诸法实相者法华论云。谓如来藏法身之体不变故此亦名实相亦名佛性正法。正观之异名也。所谓诸法如是相者。前标实相谓一相门。此下十事标差别相门。所以明此二门者。明诸法不出差别无差别二境诸佛之智亦不出差别无差别二智。知无差别名一切智。则如来智。照于差别名一切种智。则是佛智。今既叹佛智故举境显之

问。何以得知差别无差别二义耶

答。后偈文具显两义。如是大果报种种性相义谓差别门也。是法不可示言辞相寂灭此无差别门也。今言差别无差别者。差别宛然而无差别。故云不坏假名而说实相。虽无差别而宛然差别。故云不动真际建立诸法。如此了悟唯是佛能故叹佛智也

问。前句云唯佛与佛乃能究尽诸法实相。今称所谓相性。还是释前实相。云何言前是无差别后是差别耶

答。前标实相后明性相者。欲明差别无差别故举差别释无差别也

问。此文十句明何法耶

答。通而言之。即明一切法皆具十门。故智度论显一切法皆有九种。与此大同。法华论略明五法。通一切法。今依后偈文。且就佛因果明于十法。故偈云如是大果报种种性相义。故知约佛因果。明性相义也。佛因果。通具万行万德。今且寄波若因果显之。如是相如是性者。波若以无著为相。无著之相体不可改。故称为性。波若以正观为体也。波若有断惑之功故名为力。波若有照境之用故称为作。从习无所得观生故称为因。则四缘中因缘也。由实相境发实相智名之为缘。则四缘中缘缘义也。如是果如是报者。有人言一体义异耳。遂因力为果。詶因义为报。依毗昙义。果通报别。有为无为皆称为果。报但有为果。通有漏无漏。报但有漏。果通三性。报但无记。依涅槃经云。无漏之法但从因生更不作因名之为果。有漏之法更能生果称之为报。摄大乘论云。生义名果。熟义名报。共用为果。独用为报。今且依佛因果义释者。波若为因。萨婆若为果。五度为因。福德庄严为报。又佛德詶因为果。更起应用义为报。又法身为果。报身为报。故涅槃云。涅槃无因而体是果。则是法身本有修因所得故称为报。如是本末者。波若为因名本。萨婆若为果名末。亦得云由萨婆若故说波若故萨婆若为本波若为末。故智度论云。波若为佛生因。佛为波若说因。十地经云。如是十地义诸佛之根本。则十地为本。佛为其末。又言如是十地义从佛智慧出。则佛为本。十地为末也。究竟等者。摄上因果归于非因非果不二之理。故药草喻品云。究竟涅槃常寂灭相终归于空。偈文为二。初颂寄言叹二智。次颂止言加叹二智。长行寄言叹二智为二。初叹诸佛次叹释迦。今偈转势颂之开为二别。初二偈颂叹佛二智。次两偈释叹二智。初两偈开为四双释之。一者初偈叹诸佛二智。次偈叹释迦二智。二者初偈总叹佛德。次偈别叹佛德。故偈云佛力无所畏。此明佛实智。及佛诸余法谓佛权智。以权智唯为化他故名余法。三者初偈叹至人故云世雄不可量。次偈叹极德谓佛力无所畏也。四者初偈欢无差别智。谓内外并冥缘观俱寂。次偈叹差别智明于境智。如十力照十境等。本从无数佛下第二两偈举因释果。二偈为二。初偈举诸佛因以释诸佛果。次偈举释迦因以释释迦果。又初偈举因释果明果深妙众生不解。次偈举因释果明唯佛能解。又初偈正辨于佛所行因故果义甚深。次偈明行因得果故果义微妙。如是大果报下。第二颂上止言加叹二智。长行前标止言次释止言。今但颂释止言。长行释止言为二。前明众生不解。次辨唯佛解。今还颂此二有十三偈半。开为四章。初一行偈颂唯佛能解章门。次一偈半颂众生不解章门。三有九行半释众生不解章门。次一行半释唯佛能解章门。长行前明众生不解后明唯佛能解。今偈欲接前偈文故前明唯佛能解。上半标所解之法。下半出能解之人也。如是大果报者颂十事中果报二句也。性相颂因中二句也。果中有法报二身。因中有外相内性也。是法不可示下。第二明众生不解。上半出所不解之法。下半明不解之人。而言是法不可示者。则上大果报之法言辞相寂灭故不可示也。上明无名相中假名相说。故开因果二。然开因果二为欲令悟非因非果不二。故云寂灭。下半明不解之人也。除诸菩萨众信力坚固者。此半行偈为欲释疑及斥二乘也。言释疑者。前偈明唯佛能解。次偈云除佛已还一切众生悉不能解众生何由悟佛智耶。是故释云。除诸菩萨信力坚固能信解耳。至佛之时乃名证解。此如涅槃经云十地菩萨名闻见佛性。唯佛得名眼见佛性佛性则是诸佛智慧。故涅槃云。佛性者名第一义空。第一义空名为智慧也。言斥二乘者。既言唯菩萨能信。则显二乘不能信也。欲令二乘改不信以得信也。诸佛弟子众下第三逐近前释众生不解章门。就文为三。第一明声闻人不解。二明缘觉不解。三明菩萨不解。三圣尚不解。何况六趣。故自忘言。又最初偈以明六趣不解故。今但辨三乘不解。合而言之。三乘六趣九道众生并不能知佛智也。所以然者。如来之智非圣非凡绝缘绝观。故圣凡众生不能解也。就声闻不解开为三章。初明钝根声闻不解。次明利根声闻不解。三明利钝共思量亦不解也。初其力所不堪者有二种义。一者对前菩萨能信解。今总序利钝一切声闻不能信解。故云其力所不堪。二者欲明钝根声闻不能解于佛智。故云不堪。次两段如文易知。辟支佛利智下第二明缘觉不解。声闻具举利钝。缘觉但举利者。智度论云。钝根缘觉不及舍利弗等。故不须举之。新发意菩萨下第三明菩萨不解。就文为二。初明始行。菩萨不解如文。不退诸菩萨下第二明不退已上菩萨不解。亦得开为二人。初明小乘人不解。小乘之内有声闻缘觉。次明大乘人不解。大乘之中有初心之与终行。并上六道合十人也

问。二乘及菩萨何故不解也

答。前已释之。今当更说二乘所以不解者。以断常有所得心岂解诸佛不断不常无所得正观也

问。二乘亦有不断不常。云何言皆是断常

答。二乘乃无凡夫外道断常。若望诸佛菩萨裁起心则堕断常。故中论云。若有所受法则堕于断常也。言菩萨不解者。直云因人不知果其言易信。今明如涅槃云。十住菩萨有所住故见不了了。诸佛如来无所住故见则了了。又告舍利弗无漏不思议第四释唯佛能解章门。无漏不思议者。上明二乘无漏者。犹是成实毗昙无漏。今总上二乘及菩萨皆名有漏。以有所得心未净故。今无此诸漏故云无漏。不思议者。心行断故不可思。言语灭故不可议。以佛智慧不思议故凡圣大小所不能解。则释上义也。下半偈明唯总别二佛所能解也

舍利弗当知下第二大段分明略说。对前仿佛故云分明。形后广文称为略说。此文接上来者。上明九道众生不解佛智十方佛能解。恐二乘人自绝不生信受。故今略明权实二智令其生信。故有此文来也。就文为二。初就诸佛以显一。次约释迦以开三。二章各三。初章三者。第一半行标诸佛说同。次半行劝信。后半行正显实。诸佛语无异者。以理既不二。教表于理故教亦无异。又佛恐时众疑昔三今一语有差别。是故今明佛语无异。又昔说于三非是真实可有回异。今一乘既是真实则语无回异也。当生大信力者。昔信三乘名为小信。今信一乘名为大信也。要当说真实者。诸佛说法适缘不同。或始终俱小或初后并大。或始小终大或初大后小。究竟而言。在于后时必定说大。以无有永住四乘必当成佛。是故在后要说一乘。斯事则决定故言要当也。次约释迦以开三者。初一偈明所对之人。次半行正开权。后半行释开权意。言处处著者则三界处。以众生着三界处故假说三乘引之令出。盖是为出三界故明三乘。不言道理有三说于三也。又有此文来者。时众疑云。道理既无三。何故说三。则释云为众生处处着引之令得出故说三也。尔时大众中下第二大段执动疑生申疑致请。就文为二。第一明生疑。第二明请说。初文有二。前明疑众如文。各作是念下第二明众疑。就众疑为三。一牒今二腾昔三今昔互相疑。何故殷勤称叹方便者。上佛具叹权实今偏疑方便者。正用方便破二乘执三乘是实故也。又欲前明开方便门后示真实相。故前疑方便也。又逐近生疑。上偈文最后云佛以方便力示以三乘教。今接此文故前疑方便也。而作是言者此牒上内证实智也。有所言说者牒上智慧门难解也。此二句牒上所不解之法。一切声闻辟支佛者牒上不解之人。佛说一解脱者第二牒昔也。昔说三乘同断烦恼得有余一解脱同灭身智得无余一解脱也。而今不知是义所趣者第三正明今生疑。疑有三。一疑教二疑人三自疑。疑教者今昔互相疑也。昔说三乘所得同。今说大小乘优劣异。昔说三乘所得同大小俱真实。今说大小优劣异大实小是权。未知昔非而今是。为今非而昔是。为今昔俱非。为今昔并是。故云而今不知是义所趣。二疑人者。所说之教既相违。能说之人应是魔也。三自疑者疑所得法。如身子云。我今自于智疑惑不能了。为是究竟法为是所行道也

问。上具动三乘之执生三乘之疑。故佛以方便力示以三乘教。下文云菩萨闻是法疑网皆已除。今何故唯二乘生疑不明菩萨疑

答。以此文责光宅。既明别有偏行六度菩萨。足二乘为三者。何故不明菩萨疑耶。若言略故不说者。菩萨正为偏执之大。何故略大而存小耶。又下三周中皆明三根声闻得悟。不明菩萨受解。以此推之。知无偏行六度之人也。今所明者。二乘人昔有自保究竟之执。忽闻三非究竟是故生疑。所以此中列之。菩萨之人无有此执。是故今文不列菩萨疑也

问。若尔何故云菩萨闻是法疑网皆已除耶

答。下明菩萨疑者。玄意中已释此义。非是自执究竟闻非究竟是故生疑。但疑如来昔何故说三今何故说一。以菩萨疑与二乘疑异。闻上略说疑心已除。故此中不列。又上偈中唯告二人。一者声闻二求缘觉众。故但二人生疑尔时舍利弗下第二身子腾疑致请

问。现瑞何故弥勒生疑。正说之中身子腾请

答。现瑞通表说一经因果之义唯佛能了。故穷学未知。所以疑也。正说中偏对身子。是执异之端故生疑致请也

问。何故须请耶

答。法华论明有三种义。一者欲令大众推觅甚深佛境界故。二者欲大众生尊重心毕竟欲闻故。三者欲令增上慢人离席而去故也。然始终为论。有三止三请。言三止者。第一叹法深妙通明九道众生不解唯佛能解故止。九道者六道及三乘人也。第二明凡夫人天惊疑故止。第三明增上慢二乘人诽谤故止。此谓人天乘及声闻缘觉四种众生闻说一乘不能信受。所以然者。人天起爱二乘起见。爱见障隔正观故不信一乘。又人天着生死乐二乘着涅槃乐。皆是保于小乐不堪受佛乐故须止也。又人天滞有二乘着空。二见在心不堪受中道法。是故止也

问。上何故明九道众生不解故须止。今但明四乘不解故须止耶

答。上叹佛智甚深。除佛以下九道众生悉不能测量佛智。是故须止。今将说一乘。四乘众生不能信受。是故须止。言三请者。第一有疑故请。第二明大众过去世种善根闻即不生疑故请说。第三明大众现在有堪闻之德闻必信受是故致请。然既有三请三止则应不说。但初止在于请前故唯有二止。詶第三请则便说也。三请二止则为五段。就初请文凡有二别。初辨生疑。次明正请。生疑之中前明众疑次自疑如文。而白佛言下申疑致请则为二别。长行与偈。长行中前申疑次请决。就申疑中前申自疑后申众疑。申自疑中前疑今次疑昔

问。何故称为第一方便

答。唯佛独有善巧。十地已下虽有化物之能未穷善巧之极。余人所无故称第一。又佛乘为第一。昔说三乘为令悟一。则与第一为方便故名第一也

问。前明疑中何故初明众疑后序自疑。今申疑中前自疑后腾众疑耶

答。上明欲示先人后己。今辨要先自解缚然后解他人。今者四众下第二腾众疑也。唯愿世尊下第二请决为二。初正请。世尊下腾所请事。正以甚深是故请耳。若是浅近我亦知之。不请说也。就偈文为二。初八行颂生疑。次颂请决。初文又二。前三行半牒所疑事。次四行半正明生疑。慧日大圣尊者。请说之中皆有三叹三请。初文明慧日大圣尊者。叹佛有堪决疑之德。日有二义。一能灭无明之闇。二能显一实之理也。此众会中凡有三圣。一五通诸仙谓下圣也。二诸罗汉等谓中圣也。三法身菩萨谓大圣也。佛于三圣中最大故言大圣尊。若非大圣无以能决三圣之疑也。如象没泥要须象拔之。久乃说是法者。上叹决疑人。今叹法为希有也。自说得如是下正牒所疑事也。初牒自说自叹二种章门。次释二章门。自说得如是等三句牒自说章门也。不可思议法者牒自叹章门也。道场所得法下释二章门也。初有五句。释自说章门。次有三句。释自叹章门。初半行偈明佛自说实智。我意难可测下明佛自说权智。无问而自说者。此句结成上义也。以初从定起时无人能问佛权实二智故佛自说也。自叹三句中初句明自叹因。下两句明自叹果。佛初从定起自说所得权实二智。自叹所行因果。身子欲为大众释佛自说自叹之意。明佛初从定起时无人能问无人能叹是故如来自说自叹也。无漏诸罗汉下第二次辨生疑。又开两别。初颂众疑次颂自疑。颂众疑内又开三别。初一行颂声闻众疑。次半行颂缘觉众疑诸天龙鬼神下颂凡夫众疑。此三众则为次第。声闻众中有罗汉人故前颂之。缘觉但有出家因人。是故第二。天龙既劣前二众故后列之。于诸声闻众下第二颂自疑。若望昔教则是究竟法。望今则是所行道。佛口所生子下第二颂请决。亦开为二。初一行明声闻缘觉二众别请。时为如实说者。昔说既其不实请今如实为说。诸天龙鬼神下第二合明三众乐闻请说也。欲闻具足道者。昔说二乘既为半字名不具足。今请说一乘满字教门称为具足。尔时佛告舍利弗下此第一止也

问。但应一止。何故再称止止

答。智度论云。喜之至也重称善哉。今止之极也再言止止。又二乘人不解故一止也。人天乘不解故一止。又悟理者将理惑教故一止。未悟理者将教惑理故一止。又依文判者。佛自释云。以天之与人皆当惊疑故重言止也

问。惊疑有几种

答。法华论云。总一经始终有五种。一者损惊怖。谓小乘人执小乘涅槃究竟谤大乘涅槃。以损于大名损惊怖。二多事惊怖。大乘人闻佛道时长行广起取小乘果心也。三颠倒惊怖。则是外道计有我我所。闻此经人法二无我生惊怖心。四者悔惊怖。如身子悔证小乘果。则此悔心名为惊怖。五者诳惊怖。谓增上慢人作是念云。何佛诳惑我等耶。名诳惊怖。此五摄大小凡圣内外事尽也。舍利弗下第二请说。前长行次偈。长行前正请。所以者何下释请。重言唯愿说者。还答上重言止也。二乘能信故称一唯愿。人天堪受又称唯愿。又已悟者因理识教称一唯愿。未悟者藉教悟理又称一唯愿。人天例此可知。所以者何下举过去世久殖善根以释请也。就偈文为二。初句正叹。下三句正请。言法王者。于今昔权实自在无碍故称为王。唯说愿勿虑下正请也。初句标请。下两句释请。佛复止舍利弗下第二止请也。前长行次偈。长行前标止。但有一止者。意正主增上慢比丘不能信受故但有一止也。若说是事下释止。前显凡夫三善道惊疑故止。次辨增上慢四众将坠大坑故止。虽举二人意在增上慢也。大坑有三。第一谤法邪见坑。二谤法业坑。此二为因。三无间地狱坑。此一为果。如来将说。是故将坠。如其正说必当正坠。偈颂为二。初句标止。三句释止。偈再言止止者。一止止天人。一止止增上慢。又一止明法妙。一止为钝根。三句释止为二。初明法妙二句明钝根。尔时舍利弗下第三请。前长行次偈。长行前标请。次释请。重言唯愿者。佛为天人惊疑及增上慢起谤故重止者。今为二人故应说之。一者如我能解故应为说。二者自我之外诸余大众亦能信解故唯愿说之。今此会中下释请。前明如我者。身子上根应前得悟也。等比者。身子以外等取中下根人及凡夫比。例亦能信也。世世已曾从佛受化者。释上如我等比能信解也。过去因浅尚受佛化。况现在因深必堪信解也。又不信者少顺教者多。以多言之故应说也。又如来具有口密及以神通。以口密言之则同坐不闻。以神通辨之宜令避席。进退而言不得不说也。偈分为二。初句称叹第二正请。无上两足尊者。既为两足之尊。必应为天人说。如其不说何名两足尊耶。愿说第一法者第二正请。就文为二。第一标请第二释请。言愿说第一法者标请也。佛乘于三乘之内为第一也。我为佛长子第二颂上释请。就文开为二。初二行颂上身子与大众堪能信解。第二一行半明身子大众渴仰欲闻。就初文又三。半行颂身子亲能信解。又半行以颂大众亦能信解。一行举古况今释身子大众能信解义。长行举世世受化故请。偈举世世化物释请。我等千二百下第二明身子与大众渴仰欲闻。亦开三别。初半行双牒两众。次半行重请说。后半行明乐闻法故生大欢喜。闻说一乘并皆成佛。故三根声闻及分别功德诸大士皆明大喜。尔时世尊告舍利弗下大段第三有此文来者。今此以六双序之。一者上明略说为利根菩萨。今广说通为三乘人。谓所为人利钝一双也。二者上略开三显一动执生疑。今广开三显一断疑生信。谓广略一双也。三者上总动执生疑。今别说断疑生信。谓总别一双也。所言总动执生疑者。总动三根人执并令生疑。所言别断疑生信者。别为三根人三周说法令三疑断三解生。动执生疑则易故但有一说。断疑生信则难故有三周说也。四者上就称叹门说。今就授法门说。良医治病要具二门。一叹药门二授药门。诸佛说法亦有二门。初赞叹一乘门。今正说一乘门。谓叹授一双也。五者上密显一密开三。谓密说门。今明显开三显明一。谓显说门。则显密一双也。六者总判诸佛说法仪式凡有三门。一但自说。如大品经。现瑞众集既竟无有人问而佛自说。二者一向因他说。如涅槃等经。现瑞众集已竟要待他问然后乃说。三者亦自说亦因他说。如十地等经。初自说十地名后因他请广说十地义。此经亦尔。初明自说今是因他说。谓自他一双也

问。初何故自说后何故因他说

答。十地论云。初若不自说不知为说不说。故要须自说。后欲令大众殷勤三请。故因他说。又欲示法深妙无能问者。是故自说。如身子云。道场所得法无能发问者。我意难可测亦无能问者。故十二部中用无问自说经以开宗也。后因他说者。欲令大众尊人重法故待请方说。就此大章开为三段。第一法说第二譬说第三亦法亦譬说。所以有此三说者。法为譬本故前明法说。未解法说故举喻显之。故次明譬说。各闻法譬犹未得解。具辨二门方乃取悟。故化城之前名为法说。化城之后称为譬说。又示诸佛内有无碍之智外有无方之辨能于一义作种种说。所说虽多不出法之与譬及亦法亦譬。又众生悟入不同故适化多种。或有乐从法说门入。或有乐从譬说门入。或有乐具从二门入。又初说生大乘闻慧。次说生于思慧。后说生于修慧。又初说上根人得悟。次说中根人得悟。后说下根人得悟。所以然者。上根人一闻则解。中根人再说方悟。下根人三说始解也

问。以何惑障三根不解

答。此非九十八使。何以知之。罗汉之人四住惑倾而犹未解一实。故知非九十八使也。五住之中正是无明住地。二障之中为智障惑。就此惑中开为三品。轻品之惑障于上根。次品之惑障于中根。重品之惑障于下根

问。此惑云何障三根耶

答。由有此惑迷于权实。故不识三乘是权一乘为实。亦迷一乘本有二乘本无。故名障三根也。三说义中别自有科。如彼广说。就法说中开为四段。第一从此文去竟方便品正明法说。第二譬喻品初一长行一偈明上根人领解。第三从尔时佛告舍利弗竟为诸声闻说大乘经名妙法莲华经佛所护念明如来述成。第四从舍利弗汝于未来世竟尽回向佛道明授上根人记。就初又二。第一正为上根人法说。第二从汝等舍利弗声闻及菩萨下劝弘经。初正说令发菩提心。劝弘经令其修菩萨行。如华严善财童子诣善知识所皆明二事。一云发菩提心。二修菩萨行。此经称教菩萨法亦具二事。初法说令改小信大。谓发菩提心。后明既得如实悟。还令如实说令修菩萨行。又初说灭其小执生于大解。谓智慧门。后令弘经则是修慈悲。谓福德门。此经令二乘人具修大乘福慧。故名教菩萨法。就初为二。一长行二偈颂。长行为二。一缘起二正说。缘起有三。初许说诫听。二简不净众。三叹净众。初有三句。初句明不得不说。以请既会理称机。佛若不说则乖理失机。故云岂得不说。汝今谛听下第二诫听也。谛听令生闻慧。善思令生思慧。念之令生修慧。又谛听令离散乱心如不覆器。善思令其悟解如不臭器。念之令其忆持如不漏器。吾当为汝下第三许为说也。说此语时下第二简不净众也。就文亦三。第一句正明罪人退席。所以者何。下第二释起去所由凡有二义。一者罪根深重。二者有增上慢。又有二义。一者大乘中有失。二者小乘中有失。所言罪者。定执小乘谓为究竟乖大乘理。故称为罪。故涅槃经云。求二乘者名为不善。所言根者凡有二义。一者过去修习小乘故称为根。二者因此执小遂生谤大故名为根。所言深重者。为释疑故来。若封执小乘遂障隔大者。三根声闻亦执小乘应隔于大。何故五千独去而三根住耶。是故释云。五千罪根深重十方诸佛不能拔济。是故退席。三根之人虽习小乘罪根轻浅故独住也。及增上慢者。第二上明执小有障大之失。此明于小乘内自复有失。实未得小乘道果。谓得小乘道果故名为失。又罪根深重者。明过去世失。以于过去障他听说大乘。是故现在不闻正法。及增上慢谓现在之失。于现在世值释迦佛修习小乘。未得小果谓得小果。复谓此果以为究竟。不受大法故名为失。又以此失简诸余声闻。诸余声闻但有执小之失。无有未得小果谓得小果。是故余人在坐五千退席。未得道谛谓得道谛。未证灭谛谓证灭谛。故言未得谓得未证谓证。则释上增上慢义。有如此失者。总结上二失也。世尊默然而不制止者。第三句以住即有二损故佛不制之。一者闻则起谤堕恶道。二者未来当作障隔大乘因缘。尔时佛告舍利弗下第三叹净众。文有四句。一叹净众。二毁不净众。三诫听。四者受旨。智度论云。枝叶不堪为用。如五千人无法器用虽能闻一乘不能发菩提心修菩萨行绍佛业。是故无用。贞实堪有柱梁之用。如净众是法器闻经堪有绍佛业用。舍利弗如是下毁不净众。上明住则有二损。今明去有两益。一现在无起谤法之罪。未来不招苦报。二者闻上略说作未来信解因也。复诫听者有二义。一者五千起席大众扰动故重令谛听。二者既是净器堪闻法故令谛听也。次受旨如文易知

问。五千之徒既不堪闻法华。何故不从定起则以神力令其起去

答。初从定起则以神力令其起去。便不得闻于略说作未来得度因缘。若闻于广说则起诽谤现在无益。以佛明见三世故有遣不遣也。又初叹佛二智身子未请。无因缘故不得遣之。今待请后许说。宜须简众方始得遣也

问。若佛知住起谤故不为说者。释论明喜根胜意二人。胜意执小喜根悟大。遂为胜意说大乘。而胜意便诽谤堕大地狱。未来因此毕苦果而得解脱。今何不为说耶

答。去住俱起诽谤者则应为说。如喜根知胜意闻说与不说终自起谤。故为其说法作未来得度因缘也。今去则有益。住则有损。故遣令去也。以理言之可有三句。一闻而起谤故不为说。如五千之徒。二闻必起谤而为说。如常不轻也。三知其起谤亦说亦不说。如五千是也。初为生未来善故令其闻略开三显一。畏其现在谤故不为广说也

问。闻略说何故不起谤

答。有三种人。一者上根菩萨闻略说则解。二中根则声闻人闻略说生疑。疑是解津堪闻广说。三下根谓五千之徒闻略说冥然不解。闻广说则起疑谤。又有三品人。一俱不闻广略谓下品人也。二闻略不闻广谓中品人也。三广略俱闻谓上品人也

问。如华严五百声闻。虽复在座不见不闻。今何不尔耶

答。适缘不同可得两经互现。而今明众起去者。欲证佛语不虚。上既言皆当惊疑及增上慢人将坠于大坑。故今明五千之徒则其人也。二者欲增住众敬心。明预闻之徒殖因已久宜应欣庆。又罪重之人不堪闻法。则是叹法深妙。然此众可具二义。一者或是实行之人。二者是化众。如涅槃现童子及金刚神也

问。何因缘故同禀小乘教有得闻法华信解有不闻耶

答。可具四句。一者始习学大乘终亦闻大乘。此人悬信。二者始习大乘中志斯意。故初为其说小。小心稍改故终为说大。此人闻法华亦信。三者本学大乘而后闻说大乘便退取小。如大品六十菩萨成罗汉。又至涅槃经虽闻有佛性而犹成罗汉。以此例之。闻法华亦有成罗汉者。如此之人闻大亦信也。四者有始学小乘而终闻说大。此人多不生信。以其习小乘日久。若闻大乘乖其本心故不生信也。佛告舍利弗如是妙法下。前第一明缘起。则是净器。今第二正说明授妙法也。非净器无以受妙法。非妙法无以授净器。故此二种必须相称。就正说文凡有四门。初辨一乘真实门。二明二乘方便门。三示得失门。四劝信受奉持门。所以明此四门者。灵山之会大机已熟应闻大法。故辨一乘真实门。既示今一乘为真实。宜开昔三为方便。故辨三乘方便门。初门明今一乘真实。后门序昔三为方便。盖是明一化始终理无不极。若能信一实三权则是得非失。如其不信则是失非得。故有第三得失门也。得失之理既彰。次劝舍失从得信受奉持。故有第四劝信门也。又有此四门者。一乘真实门谓根本法轮。诸佛出世但为明一大事因缘。谓一道清净则根本法轮也。但众生薄福钝根不堪受一道。是故于一佛乘方便说三。谓支末法轮。既从一起三还欲令籍三通一。若能知三为归一则是得非失。如其保三不受一是失而非得。故得失门明收末归本法轮。既序始终一化三轮事周。然后始得劝物信受。故有第四劝信门也。就一乘真实门又开三别。一释迦自说一乘真实门亦云自开宗门。二引诸佛证释门。三明释迦顺同门。所以有此三门者。释迦当今教主故前自开宗。恐物不信故引诸佛为证。证明事竟然后始得顺同也。就初章之内又开三门。一赞叹门二不虚门三显教意门。所以有此三门者。赞叹令生信解。不虚抑其诽谤开解杜惑。缘由既竟故正明显教意也。初文二句一法二譬。如是妙法者。此显一部之旨归。则是先明一乘真实。题以示之也。妙有二种。一者体妙。谓非一非三言忘虑绝。二者用妙。非三非一。不知何以美之。为对昔三强叹为一。故注法华经云。非三非一尽相为妙。非大非小通物为法也。盖是什肇旧宗。非今新释也。时乃说之者。叹法希逢增敬信之情也。远而言之。如后文说亿亿万劫至不可议诸佛世尊时说是经。近而言之。释迦一化四十余年之所未说今始说之。故知希有。如优昙钵华时一现耳者。此譬上时乃说之言也。河西道朗云。此言灵瑞华又云空起华。天竺有树而无其华。若轮王出世此华则现。明众生若应闻一乘教成法轮王者。诸佛世尊乃说是经。故灵瑞华为轮王之相。法华为成佛之征。舍利弗汝等当信下第二明不虚门。将明昔三今一则言似相违。恐物不信。是故今明佛语不虚劝物信受。舍利弗诸佛随宜下第三明显教意门。上之二句乃是缘由。今此一章始明正说。就显教意复开二别。一明众生不解教意门。二明唯佛能解教意门。随宜所说意趣难解者。此标二章门也。初标随宜所说门。次标意趣难解门。诸佛说法随二种说。一随现实说。二随机宜说。说一乘者谓随理实说也。说三乘者谓随机宜说也。理实无三而说三者。随机宜说也。意趣难解者。上明随宜所说教。今明教所表理也。言三意若三斯不名难解。良由言三意不三。言近而意远。是故意趣难解。又意若住不三亦不名难解。今言不三者。明其非是三。非谓是非三。斯则心无所寄乃契玄宗。故名难解。所以者何下释上二门也初。释随宜门。次释意趣难解门也。我以无数方便者。或邪或正或顺或违悉是善巧故名方便。又悉令悟入一道清净示种种化。为一道作缘由阶渐。故名方便。种种因缘者。所以示邪正不同违顺等化者。是良由众生根性非一入道各有由籍故也。故云种种因缘也。譬喻言辞演说诸法者。上明无数方便总明八相成道之正。及示九十六术之邪。或作调达善星之违。或示阿难罗云之顺。故总明一切善巧。今别明说法一事。说法之内不出二门。一者种种譬喻。二者种种言辞。从无数方便至种种说法。总摄释迦一切教也。是法非思量分别之所能解者。此释意趣难解章门也。如来说一切教为令众生悟入一道。故下文云。于一切法以智方便而演说之。其所说法皆悉到于一切智地。禀三乘教者思量分别于三。终不解三教意也。又五乘以五心分别。终不解言五意不五。故言非思量分别之所能解。又有所得心名思量分别。故摄大乘论云。分别是菩萨烦恼也。唯有诸佛乃能知之者。上来明众生不解教意门。此第二明唯佛能解门。亦初标唯佛能解。所以者何下释诸佛能解。释意云。诸佛唯为一大事故出现世。是故说一切教皆为显一也。舍利弗云何名诸佛下。前举一大事以释教意。今次传释一大事。将欲释之故提起为章门也。次明开示悟入四句释章门也。释此四门不同。今略明三义。一者依旧解云。初开佛知见谓明道理。次后三句悟前道理发生三慧。故有示悟入也。二就法华论释之。所言开者明无上义。唯除如来一切智能更无余事。故言开佛知见。令众生知得清净故。如来知见者。谓如来能证如实义故。如寿量品云。如来如实知见三界之相。无有生死若退若出。亦无在世及灭度者。非实非虚非如非异。此则如来法界也。所言示者明同义。谓声闻辟支佛及佛法身平等。法身平等者。三乘佛性法身更无差别故。所言悟者明不知义。以二乘人不知究竟唯一佛乘故。今欲令知故言悟。所言入者。为令证不退转地示现与无量智业。故详论此意四门则为次第。初明开佛知见则叹佛知见为无上。虽叹佛知见为无上。或谓独佛有此知见二乘所无。是故第二次明三乘人同有佛性法身。但佛悟佛性故名法身。二乘犹隐故称佛性。虽三乘人同有佛性法身。但二乘人不知唯有一乘无有二乘。今欲令知故次说悟佛知见。既知唯一佛性无有二乘则证不退转。故次说入佛知见。论又两番释后三句。所言示者。为诸菩萨有疑心者令知如实修行故。又复入者。未发菩提心者令发心故。已发心者令入大法故。又复入者。令舍声闻果入大菩提故。又复悟者。令外道众生生觉悟故。此释意与前异者。前四句并约化声闻。今意明化菩萨及外道。此经正化声闻。次化菩萨并及外道。化此三人则总收一切令同归佛乘也。今次依智度论及涅槃经言。虽有四句不出二门。初之二句明能化门。后之二句明所化门。能化门中有大开之与曲示。所化门中有始悟之与终入。故此四门无义不摄。所言开者。众生佛性名佛知见。佛性亦名一乘。涅槃经言。毕竟有二种。一者庄严毕竟。二者究竟毕竟。庄严毕竟者谓六波罗蜜。究竟毕竟者一切众生所得一乘。一乘者名为佛性。以是义故我说一切众生悉有佛性一切众生悉有一乘。以无明覆故不能得见。为众生故说佛性名之为开。既为众生说则是为众生开。所以开佛性者。令众生除无明烦恼。使得清净开佛性。则是德无不圆。使得清净谓累无不尽。所言示者。曲示五性差别之义。故名为示。如涅槃云。掘出金藏故普示众生诸觉宝藏故名示也。所言悟者。大开曲示二门既竟。今次知有佛性名之为悟。修行证之故称为入。知有佛性谓十信以上也。证入佛性谓妙觉地已还也。举始及终位无不摄。次结章如文

问。已知开示悟入。云何名诸佛知见

答。上已略明。今次广述。盖是波若异名正观别目。今依此经则是四智。一者一切智。二一切种智。三自然智。四无师智。言一切智者。知六道众生本来寂灭一切众生本来是佛也。言一切种智者。虽知本来寂灭。于众生常不寂灭。故于道未始二于缘未始一。于道未始二故六道常法身。于缘未始一故法身常六道。六道常法身名为一切智。法身常六道名为一切种智。任运知此二法名为自然智。此三不从师得称无师智。此之四智为三世诸佛心。一切众生宜应恒以此四为观行。则是初心佛也。诸佛如来但教化菩萨事者。上明唯为一道故出世。今明唯教一人也

问。诸佛教化五乘众生。云何唯教菩萨一人耶

答。虽说五教为显一理。虽教五人亦为成一人。是为言托于五意在于一。又所求之道既一求道之人亦一。故言但教菩萨也。诸有所作常为一事者。上明说于一理为教一人。据口业也。今明诸有所作者。谓动静四仪及以三业一切所作皆为显一理。悉为教一人也。如来但以一佛乘故为众生说法无有余乘若二若三者。所以有此文来者。为释成上三句义也。良由道理唯一道理无三。是故诸佛唯为一事故出世。唯为教一人。乃至诸有所作皆为显一事也。此文有二句。第一句明道理唯有一故诸佛依于一理但说一乘。故云但以一佛乘为众生说法也。无有余乘若二若三者。上明道理唯有一佛乘。今明道理无有余乘。余乘者则缘觉声闻乘也。缘觉乘为第二。声闻乘为第三。故言无有余乘若二若三

问。何故知然

答。数之次第谓一二三。上既言但以一佛乘。是故今明无有第二乘第三乘。此是从上数以至下。故为次第。所以前明佛乘有者。为欲释成上唯有一事故。前明唯有一也。文相历然不应更有异释。有人言。若二者声闻缘觉二乘也。若三者谓三乘之中大乘也。有人言。若二者大小二乘也。有人言。若二者人天乘也。若三者谓三乘也。此悉非解不须破之。一切十方诸佛法亦如是者。所以有此文来者。上明唯有一乘无有余乘若二若三。时众谓释迦独作此判则不信受。是故今引十方诸佛为证。非独我明唯有一乘无有余乘。十方诸佛亦如是说也。过去诸佛下第二引证门说。就文为二。初别引三世诸佛为证。次总引三世诸佛为证。一一门皆具三句。一化主二教门三禀教人。此三则是良医妙药及以病人。又化主则佛宝。教门为法宝。禀教人则是僧宝。就教中有二句。初总序一切教也。法华论云。因缘者谓三乘法。三乘法但有名字无有实义也。譬喻者。如从牛出乳。乳喻小乘。从乳出醍醐。醍醐喻大乘也。是法皆为一佛乘故。第二句明教所表理也。禀教人亦二句。始则闻五乘等教。终则得于一切种智。舍利弗是诸佛但教化菩萨。上别明三世诸佛教意。今总明三世诸佛教意。所以有此文来者。上释迦开宗门明但为教一人唯为显一理。三世佛教门未作此说。故今明之也。舍利弗我今亦复如是下。此第三明顺同门。以三世诸佛既作此说。释迦顺而同之亦作此说。以理既无二故诸佛道同。若不信释迦之言则违三世佛教。罪之太也。若信释迦之言则信三世佛说。则福之深也。为明劝信故辨顺同也。就文为两。初明显一次明破二。显一之中初明教门次辨教所表理。知诸众生有种种欲者。五乘欲乐不同也。深心所著者。习五乘欲深。是故着于五乘也。随其本性者。习欲既深则便成性。性不可改随而说之。以种种因缘者。上明知机今明顺机说教也。舍利弗如此皆为得一佛乘者。上明教门今谓教所表理也。十方世界中尚无二乘何况有三者。上明有一今明无二也。二乘不知唯有一。是故明有一。不知无有二。是故今破二。又欲发后方便说三。是故先明道理无三也。但此经破二凡有三门。一者用一破二。如前云唯有一佛乘无有余乘若二若三。后偈亦云唯有一事实余二则非真。是为以一破二。二者以二破三。则如今文。尚无二乘何况有三。二乘者缘觉也。三乘者声闻也。缘觉为胜于理尚无。声闻为劣岂当得有。此意明至理尚不可有二何况有三耶。又作此破者。法华之会乃通为三乘而正破声闻。故譬喻品云。为诸声闻说大乘经。是以今举无缘觉之胜指斥声闻之劣。此名以二破三也。三者以三破二。明于一佛乘方便说三三既是权二岂是实耶。前之二门以无斥有。后之一门以权破实。舍利弗诸佛出于世下第二明三乘方便门。所以有此文来者有近远二义。所言远者。上之三门既明一乘是真实。则宜辨昔三为方便。盖明今昔始终权实两教意也。次明近相生者。从前以一破二及借二破三。时众疑云。道理唯一尚无有二何况有三者。如来是体理之人。初出世则应宣说唯有一理无有三乘。何因缘故道理有一而不说一。无有三乘而说三耶。岂非无而言有有而言无欺诳我耶。是故释云。虽道理有一无三。但为汝等五浊障深不堪受一。是故诸佛方便说三。过在众生咎非诸佛也。令二乘人深自悔责归仰如来。二者为释成上道理唯一。以由五浊故方便说三。故知道理唯一也。就文为三。初总标诸佛出五浊世。次别列五浊名。三者释。劫浊者谓恶时也

问。何故先明劫浊

答。法华论云。正为释疑。疑云诸佛于何时中说三乘是方便。为断彼疑诸佛出五浊恶世。谓劫浊等。故初明劫浊也。又劫浊通。于劫浊中分五浊耳。若以法辨时。应言浊劫。今以时目法故云劫浊耳。次烦恼浊者。成前劫浊及众生浊也。次众生浊后明见浊者。众生必起烦恼不必起见。欲明前是在家起爱众生今是出家起见外道。故明见浊。故下偈中皆先明爱后辨见。具起爱见者去三小劫近。是短命众生。故后辨命浊。经列此五则次第也。烦恼与见正是浊体。此二成众生故名众生浊。故经云心垢故众生垢也

问。五浊与三障何异

答。三障障碍圣道及圣道方便。此义则重。故有三障者不得入于圣道。五浊则通。故诸佛为五浊众生说三乘教

问。既有业障。云何无业浊

答。如毗尼母经云亦说业浊。没于见浊属烦恼浊摄。今明则众生浊是业浊也。所以然者。既有爱见烦恼则起身口意三种恶业。故名业浊。何以知然。若但意地有诸烦恼不起身口业者。非恶众生。不名众生浊也。故知众生浊则是业浊

问。五浊俱障一三。何故说三不说一

答。一深三浅。虽有五浊得说三乘。然有四句。一者有五浊障一乘。则昔声闻人不堪闻一乘是也。二者五浊不障一乘。谓凡夫人有五浊得闻一乘教是也

问。同有五浊。何故有得闻一乘不得闻一乘

答。虽同五浊。但有一乘机则闻。无则不闻。三者无五浊得闻一乘。则法华会声闻是也。四者无五浊不闻一乘。谓不闻法华声闻是也

问。同无五浊。何故有闻不闻

答。虽同无五浊。但有一乘机则闻。无则不闻

问。有一乘机则闻无则不闻。云何五浊障一乘不障一乘耶

答。五浊必障一乘。但一乘机强五浊障弱。是故得闻

问。三根声闻大通智胜佛所已闻一乘则有一乘机。得阿罗汉后何故不闻法华

答。虽有一乘机。但三执既强一乘机弱。要待闻诸方等经陶练其心方堪闻法华也

问。云何名浊

答。浊是不净义。譬如浊水不能见物。众生心浊不能知见一乘理故名浊也(萨遮尼健经有十二浊。一示现劫浊。二示现时浊。三示现众生浊。四示现烦恼浊。五示现命浊。六示现三乘差别浊。七示现不净国土浊。八示现难化众生浊。九示现说种种烦恼浊。十示现外道乱浊。十一示现魔浊。十二示现魔业浊)

劫浊乱时者。释五浊义。而起三乘教。五浊之中偏言劫浊乱时者。以近三小劫时众生烦恼并皆增盛故言劫浊乱时。众生垢重悭贪嫉妒者。出垢重事也。贪是三毒中一毒。悭嫉是十缠中二缠。所以别举此三者凡有二义。一者此三既重但在欲界故偏说重也。二者悭贪是贫穷业。嫉妒是下贱因。贫穷业中惜自物故悭。引取他物故为贪。下贱业中忌他外财为嫉。忌他内正报为妒。贫穷下贱之因尚不得人天乘。何况佛乘。以佛乘是富贵乘故也。于五乘中最上故为贵。具足万德故为富。故下文云豪贵如是有大势力。大富长者即是如来。成就诸不善根者。上别明一使两缠。即是在家众生。谓烦恼浊。即譬喻品云毒虫也。今总明二不善根及诸缠垢。即出家外道。谓见浊。譬喻品中恶鬼也。故诸佛于一佛乘分别说三者。上明五浊增盛不堪受一。故今明方便说三也。若我弟子自谓者。第三示得失门。上来明道理唯一。次明五浊方便有三。权实有无皎然可信。如其不信即是恶人。故次明得失。然能被之教不出实之与权。禀教之人亦唯有得之与失。斯事摄一化事竟矣。就文为二。前明失次明得。得失各有二人合成四人也。失中二人者。第一是未得小乘谓已得小乘不信法华。第二已得小乘果而小乘果非究竟自谓究竟。不追求大。亦名为失。初是凡失后是圣失。此二总摄一切失事尽也。若我弟子自谓阿罗汉等者。上明一乘是真实三乘是方便。今失此二意。盖明执小是实迷三是权也。此明未得小乘究竟果谓得小乘究竟果。此叙小乘中之失。即五千之徒是也。不闻不知诸佛如来但教化菩萨者。此文辨不知同归一乘即迷于一乘真实也。是叙大乘中之失也。不闻者不闻教也。不知者不知理也。上五千人不闻广说一乘真实。故云不闻不知也。此非佛弟子下。前两句牒谓情。今此文判得失也。五千之徒未得小乘究竟谓得究竟。保执小乘则小乘不摄。而不闻不知但教化菩萨。此人迷大则大乘不摄。故非佛弟子。以非佛弟子明非内凡夫。下明非七圣人也。又舍利弗下第二明圣失也。亦有三句。初句明已得罗汉自保究竟执三乘教不识权也。不进求下。第二明不识一乘真实也。当知此辈下。第三句判得失也。罗汉望大乘。实非究竟自谓究竟。自谓究竟故不进求佛道。当知亦是增上慢人也

问。今明增上慢与前增上慢有何异

答。上已释竟。今更明异者。初人有二种增上慢。一者未得小究竟谓得小究竟。是小乘增上慢。二者保此妄情复不进求大乘。谓大乘增上慢也。后人已得小果。但小果望大乘。非究竟谓究竟。但有大中增上慢。无小中慢也

问。何以得知有两人耶

答。后文明人异于前人。是故知二人异也。又前文判凡失。非佛弟子非阿罗汉辟支佛。故知是凡夫失也。后文判失直云是增上慢也。其既是罗汉。不得非佛弟子及非罗汉。但自谓究竟不志求佛。故与其增上慢名也

问。此的是何物人耶

答。通说一切自谓究竟罗汉。而正主三根声闻是也。故舍利弗云。尔时心自谓得至于灭度。乃至迦叶中根亦作此执。现信解品及化城品也

问。凡夫人未得罗汉自谓究竟。圣人实得罗汉亦自谓究竟。两人何异

答。两人未闻法华。自谓略同。若闻法华则五千凡夫不生信受。圣人则生信。故文云若实得罗汉若不信此法无有是处也。所以者何下第二举得释失即明得也。亦有二人。初明佛在世罗汉为得。次明佛灭度后罗汉为得。初佛在世罗汉得者凡有二义。一者斥凡。二者击圣。言斥凡者。明若实得罗汉闻一乘必信受。则知第一人不信法华非罗汉也。故是举得以斥初失。言击圣者。明实得罗汉必信此法如其不信便非罗汉。即用此文击第二实得罗汉人。令舍小果进求大道也。除佛灭度后现前无佛者。第二明佛灭度后罗汉得。前亦是闻法华罗汉得。今是不闻法华罗汉得也。此文为释疑故来。疑者云。叵有罗汉亦不闻不知但教化菩萨事以不。又有阿罗汉不信权实以不。因前二文生此二疑也。是故释云。佛在世罗汉闻法华必信。唯除灭度后现前无佛。此之罗汉不信一乘。故法华论云。亦为释疑。疑云从佛闻法起谤心。云何佛不成不堪说法人。为断此疑。除佛灭度后现前无佛故起谤耳。所以者何。释上罗汉不信一乘义也。以佛灭度后法华经难闻难解。阿罗汉作佛此人难得。智度论云。法华明罗汉作佛义最甚深。罗汉作佛唯佛能解。论者正可论其余事。龙树尚云不解。故知唯佛能解。所以此人难得。以不值人法两缘故。此罗汉不信一乘。涅槃现病品云。如佛所说阿罗汉一切皆当至涅槃。如此甚深。佛行处凡夫下愚不能知。故罗汉作佛最为难解。唯佛知之。故称难得也。若遇余佛于此法中便得决了者。此文亦为释疑故来。疑者云。此罗汉既不得值法华及解义人。何时当信一乘耶。是故释云。此罗汉生三界外净土中。更遇余佛闻法华经方得决了。决了者知三一有无及权实也

问。佛灭度后罗汉不值解义人直闻法华经亦得信解不

答。此事难明。设使遇经不值解义人者亦不得了了分明解也。是故文云若遇余佛方乃决了。舍利弗下第四劝信奉持门。所以有此文来者凡有三义。一者释疑。疑云初说三乘后说一乘则成妄语。云何可信。为释此疑故劝信。二者上示一乘真实三乘方便及显得失。今次明劝信。即令舍失从得信受奉持。三者近接上生。若遇余佛便得决了文生。终无有毕竟永住罗汉。必须闻法华经后当作佛。汝等大众及今值佛复得闻经。早须信受也

问。上已明劝信。与今何异

答。上直明劝信。今明法之权实人之真伪既竟。劝物信解受持。故与上为异

法华义疏卷第三

永仁甲午姑洗尽日因中观宗师之劝化雕法华义疏之第三庶几比丘尼正禅藤氏娘幽仪乘此宝车直到净刹乃至四恩三有利润无穷而已

      都干缘沙门　　素庆　谨志法华义疏卷第四

        胡吉藏撰

    方便品之二

比丘比丘尼有怀下。第二偈颂有一百一十四行分为二。初四行颂缘起。次一百一十行颂正说。上缘起有三。今略不颂许说诫听也。颂第二毁不净众。颂第三叹于净众。但颂此二凡有两义。一者欲证佛及身子止及请说。以颂不净众显佛止请不虚。次颂净众明身子请之不谬也。二者颂不净众。诫未来众生勿佛执小乘障于大法。次颂于净众。为劝一切众生习行大乘也。初一行摄四众为三过。出家二众同有增上慢过。所以然者。出家二众专心道果。多获禅定。故得四禅时谓得四果名增上慢。有人言。慢中之增慢之上名增上慢。今谓增上是增胜之法。未得增胜之法谓得增胜之法。恃此自高名增上慢

问。与邪慢何异

答。真谛三藏云。都未得圣法而恃怙邪法。以起慢名为邪慢。若得小许法如得四禅等谓是究竟名增上慢

问。何故名为有怀

答。注经云。若无心而进德者然后会理耳。有怀于增上之道。所以为慢也。有怀者谓心有所怀。则是有所得也。优婆塞我慢者。其人亦是未得谓得。但既是丈夫守志不移故言我慢。注经云。虽知无我而以无我为我亦慢也。此意谓我能解无我故名我慢也。优婆夷不信者。然四众通是不信大乘。就不信中更开三。出家二众则有增上慢故不信。优婆塞既是丈夫。自谓雄干决断守志。我从来已信道理罗汉究竟。今何容改志。故称我慢。次既是女人。更无余义直称不信。注经云。虽信非有之言。而以非有为信。是曰不信。肇公云。言其非有者。明其非是有。非谓是非有。但女子遂执非有故名不信。如是下明众数也。不自见其过者。夫有过而能知过。此谓智人也。今有封言之过而不自知。谓愚人也。于戒有缺漏者。上明无小乘究竟解而谓有解。今一句明无小乘究竟行而谓有究竟行。又上未得小乘究竟果而谓已得究竟果。又不受大。以不能防此二恶故名于戒有缺漏。以破此戒故名为缺。而信心漏出故称为漏。又戒是堤塘。防遮烦恼之水。戒既缺漏烦恼便出也。护惜其瑕疵者。此为释疑故来。疑云既无行解又不自见其过。佛大慈心何不示之而令其离席。是故释云。不自见过护惜瑕疵不可化也。玉内之病为瑕。喻意地无解谓有解。玉外病为疵。喻身口无行谓有行。又过去罪根深重为瑕。现在有增上慢如疵也。又内心执小不舍为瑕。外闻说大不受为疵。覆短为护。吝非为惜也。众中之糟糠者。此文释疑故来。此五千人入佛法中何所得耶。是故释云。五千人失中道真味但得断常之糟耳。三乘之名如米外之糠。一乘之理如糠内之米。但得三乘之名不知三乘之义故云糠也。又净众堪用譬同酒米。罪人不堪用喻如糟糠也。佛威德故去者。注经云。风起则尘沙自飞。日出则黑白自别。此谓非遣而为遣也。斯人鲜福德者。上长行明有罪根。今颂显其无福也。前偈明其执小故去。今辨其不堪受大乘。此众无枝叶者第二颂净众也。舍利弗善听下第二颂上正说。上有四门。初一乘真实门。次三乘方便门。三得失门。四劝信门。今偈颂转势说法亦有四门。初颂一乘真实门。二颂三乘方便门。三明赞叹门。四明劝信门。所以有此四门者。初明一乘真实。次明三乘方便。此二明一化始终故。第三赞叹。以赞叹竟劝物信受。初一乘真实门有三。一释迦自说门。二引证门。三顺同门。今颂此三则为三段也。上长行释迦自说门有三。一称叹门二不虚门三显教意门。今偈转势颂之亦开三门。一显教意门二释疑门三劝信门。初正明说教。大意明为归一乘。二明时众疑。若但为归一乘者。何故不前说于一而前说三耶。为释此疑明前三后一所以。故次辨释疑门。教意既彰前后又显。故第三劝信。初门又二。一明说昔教意。则颂上长行随宜所说意趣难解。二明今教意。颂上长行为一大事因缘故出现于世。就初门又二。第一明昔说小乘教意。二明昔说大乘教意。初门有二。第一明昔说小乘教。即颂上长行随宜所说意趣难解。次颂昔说教所表意。即颂上唯有诸佛乃能知之。初门又二。第一叙昔说人天教。第二叙昔说二乘教。初中有三门。第一偈颂叹佛权智有巧说之功。第二偈颂叹佛智内照根性。佛悉知是已下第三有四偈正明佛说教。所以昔教但有此三门者。初叹佛权智谓良医也。次知根性谓识病也。后说教授药也。初偈云诸佛所得法谓实智也。无量方便力谓权智也。次内具此二外能为物说法也。第二偈上三句知现在性欲。下一句明照过去业因。以现欲由于往业故次颂之。次四偈为二。初一偈总明赴缘说教教称于缘。次三偈别明教门。前总后别。为解义故。别明说教中初一行半明九部经谓教法也。次一行半明涅槃果法也。小乘法中说九部之教。令得涅槃之果。则是次第。又九部通于四乘。果法但明二乘教也。昔说虽多不出斯二。又九部谓人天教。次说涅槃谓二乘教。然经论不同凡有四句。一大小俱广。大乘具足十二。小乘随分十二。所以但明十二者。以十二是一数之圆。又治众生十二缘病故也。二大小俱略。同明九部。所以但明九部者。亦是一数之圆。又为九道众生故说九部。小乘约法浅故除三。以小乘法浅狭故无方广。授佛记非小乘之宗。又小乘人无补佛处义故除授记。小乘法浅有人能问故除无问自说。又大士能为众生作不请之友故有无问自说。小乘不能济物要待请方说故无无问自说。大乘约人根利故除三。大乘人根利直说则解。不须因缘及以譬喻。亦不假论义。故略以此三部也。第三句小广而大略。如地持论说。菩萨藏名方广经。声闻藏谓十一部。此意明大乘十二。为明方广之理。从所诠之理为名故十二部悉名方广。小乘十二部不为明方广之理。故存其十一部名。没方广之称也。第四句大广小略。显大乘是满字故具足十二部小乘是半字故唯有九部。则如今文说。正是法华宗也。十二部通以言教为体。故涅槃经明知法知义。知法者知十二部经法。故知是教也。次开为二者。虽有十二部不出长行与偈也。亦得开三。修多罗．祇夜．伽陀。此三就教制名。则以教为此三部体。余之九部从别事受名亦不离此三也。修多罗者。成论及智度论明直说语言为修多罗。谓别相修多罗也。涅槃经从如是至奉行。谓通相修多罗也。三藏中修多罗竖长横狭。竖长故摄于十二。横狭故但一藏也。十二部中修多罗横阔竖短。不摄十一故竖短。摄三藏故为横阔也。伽陀者第二部。谓不等偈也

问。诸经论列十二部第二云祇夜。今何故乃明伽陀

答。欲明佛说法无定故改于常规。以昔说九部为明小。今明九部乃为通大。欲显不定之义故乱说也。又今合此九部为五双。初长行与偈一双。诸佛或为众生直说修多罗。或命初则偈说故名伽陀。以经并标或字。则知修多罗未必在前伽陀不必在后。本事本生此第二自他一双。本事说他过去世事。如药王本事品等。说自过去世事为本生。未曾有因缘。此明善恶事一双。未曾有谓善事。如青牛行钵白狗听经大地震动诸天身量。因缘谓起罪本末事。而说名因缘经。譬喻祇夜法喻一双。具足应云路伽祇夜伽陀祇夜。上存别略通。今存通略别。优婆提舍称为论义。则是能论。上八部四双名为所论。谓能论所论一双也

问。大小俱称方广有何异耶

答。大是具足方广。小是随分方广。又大乘理正曰方。义富称广。文诠方广之理名为方广经。小乘语正曰方。文多称广也。钝根乐小法下一行半明小乘果法。又前明九部谓人天教。今明二乘教。人天虽异不出九部。二乘虽异同求涅槃。故人天教中前舒人天机次明九部教。今亦前叙二乘机次明叙二乘教

问。既云乐小法。何故复言贪着于生死

答。现在机缘乐于小法。过去久远贪着生死。又约机乐于小法。据情则贪着生死也。又乐小法则是贪于生死。以小涅槃则是大乘生死故。为是说涅槃第二明小乘教也。我设是方便下。上明昔二种教。今明二种教意。前逐近明说小乘教意。明昔说涅槃法者意令得入佛慧故也。决定说大乘者。昔日言说于小意在于大。教不称意不名决定。今言意俱显称为决定。又大品等经显教菩萨密化二乘。于菩萨是决定。于二乘未得决定。今显教菩萨显教二乘故名决定。又大乘是决定法。如涅槃经师子吼者名决定说。谓诸众生悉有佛性。今亦决定说于众生悉有一乘也。以道理无有余性唯有佛性故。说佛性名决定说。一乘亦尔。我此九部法下第二明说九部教法意。上半明随宜说教法。下半明说教意说九部。为令悟入大乘。与解大乘为本意。故言入大乘为本。有佛子心净下。上明昔说小乘教意。今第二明昔说大乘教意。若五乘论之。上说四乘今辨第五大乘教也。若作三教次第者。一人天为下教。次二乘为中教。今大乘为上教。文正作此意。一一文中皆先明机次辨教。观文即现也。有人言。上明昔说小乘是方便。今明昔日三乘中大乘亦是方便。将欲会三乘归一乘故。前明小乘今辨大乘也。今谓不然。前明小乘。而文辨小乘为方便。若昔大乘是方便者。亦应前列大乘次明大乘为方便。而文不尔。直明昔日大乘。不言是方便。故知昔小乘是方便。昔大非方便也。又为偏行六度菩萨说大乘。可是方便耳。而文云佛子无量诸佛所行深妙道。非则是假名偏行之人。则知是真实大乘也。又中论云。前为声闻说生灭十二因缘。次为已习行有大心堪受深妙法者说十二因缘不生不灭。若尔此大小应并是方便。而中论明前说小是方便后说大是真实。今文亦尔也。

问。但应明昔小是方便。何故今文明昔大乘耶

答。此文双序如来大小二藏。从华严已来至灵山已前大小二乘一切诸教。所以双序二教者。序小乘教意。明回小入大菩萨钝根昔未得悟今方领解。序大乘教意。叹直往菩萨从华严以来至灵山之前大机早就利根早悟。此乃是数以叹菩萨之先达嗟声闻之后悟耳。非关昔大为方便也

问。何以知然

答。以二文为证。一者涌出品云。是诸众生始见我身闻我所说即便得入如来之慧。此明直往菩萨早悟佛慧也。次云除先修习学小乘者如是等人我今亦令得闻是经入于佛慧。此明回小入大菩萨晚方悟也。二者则此经文明声闻晚习大乘晚闻大乘晚得授记晚生欢喜。既是真实教者。菩萨早习大乘早闻大乘早得授记早生欢喜亦是真实教也。若今文明菩萨早闻大乘早得授记。是方便者。华严等经悉是方便。则是谤法之甚也

问。若昔大乘明菩萨授记作佛。既是真实教者。声闻藉波若等经调柔其心然后始得悟入法华。则知波若为法华方便。岂是真实教

答。波若显教菩萨密化二乘。二乘之人藉菩萨真实教调柔其心故得入于法华。斯乃是假他先达而得后进。岂可言先达之教是方便说耶

问。此大乘亦得是方便不

答。望道未曾大小。赴大小缘故无名相中假名相说故大小俱是方便。非但大小俱是方便。亦三一俱是方便。但今大小相对。小乘是未了故是方便。大乘已了称为真实也。就此文为二。第一叹菩萨福德利根有七种早义。即显声闻薄福钝根有七种晚义。第二结昔说大乘意。有佛子心净。第一叹菩萨现在早有堪闻之德。则显声闻晚有堪闻之义。离凡夫二乘有所得心故称净也。柔软者。有无所得信心顺从诸佛不违大乘。如湿牛皮易可屈折。利根者。信为其始慧为其终。略举五根之初后。又是大乘法海信为能入智为能度故举此二也。无量诸佛所下。第二叹菩萨早习大因值佛既多修行亦积。则显声闻修大乘因晚也。为是诸佛子下。第三叹早为菩萨说大乘。即显晚为声闻说大乘也。而云说是大乘经者。是大乘经即法华也。昔为直往菩萨早说法华竟。故涌出品云。是诸众生始见我身闻我所说即入佛慧。佛慧则法华平等大慧。但昔作华严波若之名耳。今为回小入大之人作法华之说。故知大乘显道义同。故云波若是一法佛说种种名随诸众生力为之立异字。智度论又云。法华经者是波若异名。则明证也。我记如是人来世成佛道者。第四叹早与菩萨授记。即显声闻晚得记也。以深心念佛。第五叹菩萨早修正解故早得佛记。则显二乘之晚修正解故晚得佛记。以深心念佛者。了悟如来无生灭身也。如华严经云。一切法不生一切法不灭。若能如是解诸佛常现前。又大品云。云何名念佛。谓无忆故是为念佛。此则内外并冥缘观俱寂为真念佛也。修持净戒故者。第六叹菩萨早修正行故早得佛记。不持不犯离凡夫二乘有所得戒故名净戒。然行解更无二体。则一正观义分。离惑为解。离过为行。此等闻得佛下。第七叹菩萨早生欢喜。用斥声闻后得记方喜。世间三禅之乐名遍身乐。犹是小喜。今蒙佛记即得佛乐故名大喜。悟此身心本性寂灭名为遍身。佛知彼心行下。第二结昔说大教意。佛初成道知菩萨福德利根。故早为说大乘也。声闻若菩萨下。第二显今教意。则是颂上唯以一大事因缘故出现于世。长行有三种意。一明为大事故出世。二但为教菩萨。三明十方佛土唯有一无二。释成前之二事。今文转势颂之。亦开三别。初明但为教一人。次明道理有一无二。后辨佛出世大意。所以前明唯教一人者。为对昔二教各赴二缘故。今明二缘同禀一教。昔声闻大机未熟故为之说小。菩萨大机早熟故为之说大。是以二教各赴二缘。今至灵山之会声闻菩萨大机并熟。是故二缘同闻一教并皆成佛。为此因缘故前明但教一人也。无疑者。昔说三乘即声闻无进道菩萨有退路。今明有一无三。则声闻有进道菩萨无退路。故云无疑也。十方佛土中。第二明道理有一无二也。良由道理唯有一乘无有二乘。是故声闻菩萨闻法华一偈并皆成佛。即以今文释成上意也。除佛方便说者。疑者云。既有一无二。昔何故说有二乘。是故释云。上据理故无二。唯除方便说有二耳。但以假名字者。疑者既闻除方便说有二。或谓有二乘微毫法体。是故释云。毕竟无有二乘法体。但假名字说耳。引导诸众生者。疑者云。既无法体。何用说此虚名。是故释云。为欲导示众生引出火宅。因此空名获于实利故名善巧。如经云。我初得成佛时空拳度一切也。说佛智慧故下。第三明佛出世大意。以道理有大无小。诸佛是体理之人。以道理有大故唯为大事故出世。道理无小故不为小故出世。是故接前道理后明出世大意也。就文为二。第一先明诸佛唯为大事故出世不为小事。第二引证释成。初文又二。前开两章门。次释两章门。前一偈标唯为大事出世章门。次半行明不为小事出章门。前偈上半标为大事故出世。下半举真伪释成。以唯一事实余二则非真。是故诸佛但为一事故出世

问。上言无二无三。今何故乃云二非真耶

答。前明无二谓无缘觉。无三明无声闻。则是今文二非真实。但上明其俱无。今明方便说有但非真实有耳。终不以小乘下此半行标不为小事出世章门。亦得唯此一事实。释上为大事故出世章门。余二则非真。释成不为小事出世章门。以余二非真故。终不以小乘度物也。佛自住大乘下第二释两章门也。初一行释佛为大事出世章门。以佛自住大乘。还以佛所得法度物也

问。定慧则是大乘。云何言庄严大乘

答。一寂一照以别严总。亦是以法严人。而云力者。以能度物故称力。又但明定慧者。累无不寂为定。德无不圆为慧。又累无不寂为定则涅槃果果。境无不照为菩提果。此二总摄果乘故明之也。自证无上道下。第二释上不为小事故出世章门。若自住大乘平等之法以小度物便有二过。一乖大乘平等。二则堕悭贪之失。自贪于大不与物故名悭贪。一不可平等之理。二不可诸佛之心。故云此事为不可。若人信归佛下。第二证成上为大不为小。故出世凡有三证。一引他证。二引自证。三引昔证。引他证者。谓信心归依佛之人知如来言不欺诳。自住真法以伪乘与物故名为欺。用此诱他称之为诳。佛自住真乘还以与物故不欺诳。亦无贪嫉意者。所以外言欺诳。良由内心贪嫉。自贪真乘嫉妒众生故与伪法。所以欺诳。佛无贪嫉故不欺诳也。断诸法中恶者。非但无有贪嫉。悉断一切诸法中恶。以内有恶触处生畏。以佛无诸恶故于十方独无所畏。我以相严身下。第二引自为证凡有四句。一以我有此相好之身。则知内无贪嫉外无欺诳。二我尚以身光照世间。则知身益物故内无贪嫉外不欺诳。三明为无量众所尊仰。故非贪嫉欺诳之人。四明为人说于实相印定诸法。则知自住大乘亦令他住大乘也。又前偈明佛无恶。此偈辨佛有善。并释成佛自住大乘与物大乘。舍利弗当知下。第三引昔誓愿证。初偈引佛昔愿。第二偈明昔愿满。明初发心时尚愿令一切人悉皆成佛。况今得佛而自住于大与物小耶

问。如来初发心时愿一切成佛。今并未成佛。云何称愿已满耶

答。灵山一会回小入大菩萨同入一乘。自尔已前令直往菩萨授记作佛。一期出世唯此二人普令作佛。则是一期愿满。如上引涌出品文证之。正意者。法华之前但得为菩萨一人说佛乘。则佛愿未满。今并为五乘六道众生并令成佛。故佛愿满。又为人说一乘即是畅佛意。亦名为满也。若我遇众生下第二释疑门。此文来意有近有远。所言远者。上来一章皆明所说诸教为表一乘并令众生普成佛。若尔如来何不为一切人皆说一耶。二者近从上本誓愿生。昔既发愿令一切成佛。今满本愿。初出世时何故说三不即说一。今方说一耶。为释此意故有此章来也。就文有四。初明不得普为一切说于一乘。二释不得说一所以。三明既不得说一故方便说三。四明虽复说三终为显一。若我遇众生尽教以佛道者。此上半牒难情。假设遇众生便说于一也。下半明有损无益。凡有三过。一者机小教大有错乱之失。二者钝根迷教惑理之过。三者不信有诽谤之咎。我知此众生下第二释不得说一所以。不得说一凡有二义。一知众生无有善本。二知众生有诸恶根。则用二义释无智错乱等三失。无善本者。未曾修行无所得善为菩提本。故此众生不信解一。坚着于五欲下第二明众生有于恶根。就文为二。初明有爱恶。次明有见恶。所以偏明有爱见者。此二总摄一切诸烦恼故。又在家人多起爱出家外道多起诸见。又众魔乐生死故起爱。外道着诸见故起见。又爱是旧行烦恼。见是新起之惑。一切众生虽并成就三界爱见。而爱多现行。若值邪师方乃起见。又爱烦恼名为一失。诸外道等以有爱惑而于其中更复起见。是为失中更复起失。为此因缘明爱见也。就明爱内开为二章。一辨爱因二明爱果。坚着于五欲者。起爱之处。出所爱事也。痴爱故生恼者。所以爱五欲者。由痴故起爱也。如涅槃云诳故生贪。如净名云从痴有爱则我病生。恼者。明从爱因生于现恼。所谓以爱因缘令身心恼。或自恼恼他故也。故痴是爱因。恼为爱果。以诸欲因缘下。上明生恼谓现报也。从此以下明生后二报也。就文为二。初辨通报次明别报。初半行明得生报。下半明后报也。既语轮回。则三报相续也。受胎之微形下。第二别明受报谓人报也。所以偏明人报者。佛生人中多化人故也。人报具于八苦。上半略明生苦。以生苦为八苦之初。下半总明众苦也。世世常增长者。细论胎内时分不同。为世世增长。又大期为一世。生生常如此。即从今生生后世是增长义也

问。众生托胎何故有男女不同

答。父精多母精少则成男。母精多父精少则成女。父母等精者则成黄门二根也。入邪见稠林下第二明起见。就文亦二。初明见因次明见果。入邪见稠林者。此中有一见二见乃至六十二见。言一见者。总名外道诸见为一邪见。邪见众多譬如密林。故云稠林也。若有若无等者此明二见也。智度论云。爱多者著有故起有见。见多者着无故起无见。又云四见多者著有。邪见多者着无也。依止此诸见具足六十二者。明六十二见。大品譬如我见摄六十二见。则我见为六十二见本。大品又云一异为本。此经以有无为本。此三不相违也。由计有我故生诸见。则我为其本。以有我故计我与阴一我与阴异。故以一异为本。我与阴一则阴灭我灭。便起断见。我与阴异则阴灭我存。故起于常见。断常则是有无。故以有无为本。有无谓边见。为六十二见本。我为边见之本也。六十二见者。大品佛母品开十四难为六十二。十四难者。神及世间常无常等四。神及世间边无边等四。死后如去不如去等四。合为十二。及身与神一。身与神异合为十四。常无常内约五阴作之。一阴具常无常四句。故成二十。边无边亦约五阴。故成二十。如去不如去亦成二十。合为六十。一异为本合为六十二。又释即色是我。离色有我。我住色中。色住我中。一阴有四。五阴二十。约三世为六十。断常为本合六十二。十六为即阴。四十六为离阴。又释一阴上计有无二种。五阴便成十见。三世为三十。凡夫五阴有三十见。圣人五阴亦三十。合有六十。涅槃非三世摄。但计涅槃有无二合成六十二见也

问。五见摄六十二见不

答。我见为六十二见本。邪见拨无。而六十二计有故不摄邪见。见取以六十二见为第一。戒取谓六十二见为道。则四见非六十二摄。而六十二见属边见也。深着虚妄法者。前明从爱起见。今从见更生于爱。虚妄法者谓诸见也。深着此见故名爱也。又佛初出世不能顿拔此见则说一乘故名深着。又既以此见为好。则为是于见上更生见。谓见取见也。我慢自矜高者。恃此诸见举我自高也。即显诸外道佛初出世不受一乘之道故也。谄曲心不实者。上来从正使生正使。今从正使生于缠垢。谄即六垢之一也。杂心云从见生谄垢。以起见必是利根人。方能谄曲。钝人不能也。上明我慢不受佛化。今明谄曲化彼门徒。于千万亿劫第二明见所得果。以爱为受生之本故下招六趣。见乖于正理故上隔三尊。是以二文明爱见果异也。如是人难度者。总此爱见众生难可以一乘法度之

问。此叙何处爱见众生

答。佛初出世有此爱见众生。故不得说一乘也。是故舍利弗下第三明不得说一故方便说三也。说诸尽苦道谓道谛也。示之以涅槃即灭谛。略举出世因果

问。上云起邪见众生千万劫不闻佛名字亦不闻正法。今云何得为说涅槃耶

答。住此邪见则不得闻。但此邪见众生过去曾习小乘有小根性。中途起于邪见。以小机将发邪见正倾故得为说小教。我虽说涅槃下。第四明虽复说三终为显一也。初句开方便门故云非真灭也。诸法从本来下。有人言。涅槃有三种。初教以灰断无为为寂灭。般若教以四谛平等为寂灭。此经明宝所俗外涅槃为寂灭也。今是辨因之时未得明言说宝所之灭。且用大品经灭以斥彼事断无为。有人言。万善之法本来寂灭无三乘之相故云寂灭。今明此二都非释也。今文正简大小二涅槃也。小乘之灭非是真灭。大涅槃灭方是真灭。所以然者。小乘前有因果二患。故灭之以得无为。则是断常二见。故大品云。若法前有今无。诸佛菩萨则有过罪。今对小乘非真灭故明因果两患本来寂灭。则是大涅槃灭也

问。今明一乘何故乃辨大小二涅槃异耶

答。良由今果异昔果故。得今因异昔因耳。又昔小灭非真灭今大灭是真灭。方得劝舍小灭以求大灭。盖正是一乘之大宗也

问。大小二涅槃有几种异

答。此经始末凡有三异。一小乘灭狭。但灭四住及分段生死。大乘具灭五住及二死。此经现譬喻品末。故彼云。但离虚妄名为解脱。其实未得一切解脱。二者小乘前有烦恼及以身智。然后灭之故非本来寂灭。大乘明烦恼及以身智本性寂灭不复更灭。故大品云。若法前有后无。诸佛则有过罪。二乘前有今无。则是过罪之人。故涅槃云。若以声闻言无布施。是则名为破戒邪见。则其证也。三者二乘但见于空不见不空。即但见于灭不见不灭。大乘明见空及与不空。则是具见于灭及与不灭。故譬喻品云。皆以如来灭度而灭度之。则是灭义。又云悉与诸佛禅定智慧。谓不灭义也。故法华论云。正以大涅槃为一乘也

问。大品等经已明本来寂灭。何故声闻不得悟耶

答。大品虽明本来寂灭。未开小灭非真灭。是故声闻不得悟也。今明小灭非直灭。则开方便门。本来寂灭相。谓显真实义。是故声闻方得悟也。我有方便力下第三劝信门。初偈重牒所信之法。第二偈正明劝信也。初偈上半寄释迦以明权。下半就诸佛以显一。第二偈上半诫令除疑。下半劝信佛语。过去无数劫下第二颂引证门。颂三世佛则为三段。上长行一一佛皆有三门。一化主二教门三徒众。今还颂此三也。上半乃举多劫多佛者。良以一劫一佛未足为证。故举多劫多佛生众生信心。下半明诸佛化仪不同而同说一乘之道也。如是诸世尊下第二颂上教门。上长行略但有一周明教门。今偈颂广开为二周。第一就法说门明教意。第二就神通门明教意。二门各三。初门三者。一行明说教。半行明教意。半行明益缘。又诸大圣主下。第二一行半就神通门明教意也。亦开三别。一行辨知机。一句现通。一句明现通意。更以异方便者。有人言。上明三乘方便。今明人天乘异上三乘故名异方便。有人言。上明小乘方便。今明大乘异上之小故云异方便。今谓不尔。前文明说法为方便。今文不云说法。乃是神通。神通异上说法名异方便。以说法现通略摄过去诸佛教门事尽。直明若说法若现通皆为显一乘也

问。云何现通

答。如昔灭火伏龙令外道心醉。今放光现瑞使内侍发请。则其事也。故序品云。今相如本瑞是诸佛方便。今佛放光明助发实相义。即此文之意也

问。前明说法方便与神通方便何异

答。今文现通开发正说之由渐故名方便。前明说法门以无三说三故名方便。第一义者一实之道。理极莫过为第一。深有所以称为义也。若有众生类下第三颂长行禀教之众。就文为三。第一明于过去世佛现在时修行得益。第二明于过去佛灭后修行得益。第三双明二世修行得益也。教门不出说法现通二种。修行不出三时不同。此意欲摄过去能化所化事尽也。上长行初明闻法终得种智。今此偈颂前明修行终皆成佛。初则是六度行也。以六度是成佛之本故初说之也。种种修福德者四乘之行也。诸佛灭度已下第二明佛灭度后修行成佛。就文为五。第一明见佛涅槃起恋慕心故得成佛。二明供养舍利。三明起塔。四明造像。五明三业供养故得成佛。此五则成次第。初见佛涅槃心生恋慕。涅槃已后为供养舍利。供养已后次明起塔。欲表代尊像故须造像。造像竟次辨三业供养也。言若人善软心者谓恋慕心也。又则是信心。随顺诸佛不违教门故名善软也。诸佛灭度已下第二明供养舍利。起万亿种塔下第三明起塔。外国名塔婆或名偷婆或名数斗婆。此云方坟亦名冢也。增一阿含云。有四事得梵福。一无塔处立塔。二和合圣众。三修治破寺。四佛初成道请转法轮。梵福者。四天下众生至六欲天不及一梵天福也。庙者貌也。寺塔供养对之如神在有状貌也。木樒者。形似白檀微有香气。长安亲见之。若人为佛故下第四明造像。优婆塞经不许用胶。有释云。不许用皮胶。得用木胶。有释云。开遮有异意也。若人于塔庙下第五明三业供养。于诸过去佛下第三合明二世修行成佛。闻是法者。则是闻上来所说法皆得成佛也

问。低头举手善云何成佛

答。昔竺道生着善不受报论。明一毫之善并皆成佛不受生死之报。今见璎珞经亦有此意成论师云。一念善有习报两因。报因则感于人天。习因牵性相生作佛。今明此义并成难解。经云有所得善不动不出。凡夫习因之善既有所得。云何得成佛耶。则以此言还责生法师也。今明善因有受报不受报义。有所得善受有所得报。无所得善受无所得报。谓受报义也。有所得善不受无所得报。无所得善不受有所得报。谓不受报义。故大品云。有所得善不动不出。无所得善能动能出。即是证也

问。人天善根既是有所得。云何此经明皆成佛耶

答。人天善根盖是得佛之远缘。故云成佛耳。大品明其近不取其远。故无所得善能动能出。有所得善不动不出。此经近远通说故并云成佛

问。人天善根云何远成佛耶

答。人天善根有二种。一者习因二者报因。报因则感人天身。以有习因值佛菩萨。闻说大乘生一念无所得信。此无所得信是佛道种子。藉前有所得生后无所得。故智度论云。有所得者是无所得初门。故云是远缘

问。此习报二因与成论师解何异

答。彼明一念善具二因。今明有所得善前后相生义自是习因感报之义是报因。此之习报并是不成佛。故法华论释。童子聚沙为佛塔皆已成佛者。要是发菩提心方得成佛。非谓凡夫善根及决定声闻善根得成佛也。中论云。虽复勤精进修行菩提道。若前非佛性终不得成佛也

问。既是有所得善根。云何能生无所得耶

答。有所得若决定性者不能生无所得。良由诸法无决定性故。值佛菩萨悟此有所得本无所有便生无所得也

问。无所得亦有习报二因不

答。亦有二因。习无所得生无所得亦是习因。行无所得因感无所得报称为报因。故大品云。报得无生法忍报得六波罗蜜

问。何故云皆已成佛道耶

答。佛照过去众生修行善根已得成佛也

问。今明过去佛教意。与前偈明释迦自开宗辨。教意何异

答。上正明二乘众生并皆成佛。今通明五乘众生并皆成佛。以破昔谓行五乘之因别得五乘之果。是故今明因无异感果无别詶故并皆成佛。所以前明二乘成佛后明五乘成佛者凡有二义。一者此教之兴正为二乘。傍及人天。故前明也。二者举人天乘破二乘保执义。佛言我以佛眼见过去。人天一念善根尚并已成佛竟。故知无有灰身灭智同于大虚毕竟永住二乘不成佛也。未来世诸佛下第二颂上未来世诸佛。就文凡有二周。第一略颂上三事。第二广释未来诸佛教意。二门各三。初门三者。半行颂化主。一行半颂教意。半行颂禀教得益也。诸佛本誓愿下第二广颂未来教意。亦开三门。初一行辨本愿。愿为明一。次一行辨说法。为明一。次两行就诸佛所证。为明一。初二偈如文也。诸佛两足尊者第三举所证明一。上过去佛门通说有得无得一切诸善并皆趣成佛。今文但示根本无所得善方乃成佛。则释成上义也。两足尊者。或以戒定为二足。或以权实为二足。或以福慧为二足。或以解行为二足。此皆内德之二足也。外形以天人为二足。佛是天人二足之尊也。知法常无性者。知一切法无自性也。而言常者。非是破性故言无性。性本常无故云常无性也。佛种从缘起者。种子有三。一以一乘教为种子。故譬喻品云断佛种故。则是破教也。二以菩提心为种子。故华严云下佛种子于众生田生正觉牙。三以如来藏佛性为种子。今初偈正以菩提心为种子。上明无性。今辨因缘。佛种者则是无所得菩提心为佛种子也。此菩提心假缘而起。起则发也。是故说一乘者。以菩提心假缘而起故。佛为说一乘令发菩提心。一乘教则是发菩提心缘也。又明唯有一乘无有二乘。则菩提心唯有进无有退路也。是法住法位者。上明菩提心为种子。今明本有佛性以为佛种。若无佛性。虽说一乘教及发菩提心。终不得成佛。是故须明佛性也。凡有三句。初半偈正叙佛性。谓法住法位。法住法位是佛性异名。亦是一乘别称也。世间相常住者。世间众生本有佛性故佛性常住。故寿量品云。如来如实知见三界之相。无有生死乃至非实非虚。则是如来藏法身常住也。于道场知已者。第二句明知佛性。谓坐道场时始见佛性也。导师方便说者。第三句明说佛性。然佛性绝四句超百非实不可说。但无名相中为众生故假名相说。故云方便。此异上三乘方便。亦异神通方便。故此经有多种方便也。天人所供养下第三颂现在佛门。凡有二周。一行半略颂上三事。一行颂化主。一句颂所化。一句颂教门。知第一寂灭下。第二三偈广颂上三事。初一行明三种法轮。知第一寂灭谓根本法轮。以方便力故谓枝末法轮。则从本起末。其实为佛乘谓摄末归本法轮。知众生诸行者。第二两偈广明枝末法轮。今我亦如是下。第三两行偈明释迦顺同门。两偈为二。初偈顺同诸佛明摄末归本法轮。第二偈顺同诸佛明从本起末法轮。摄末归本谓摄用归体。从本起末谓从体起用。此二虽略摄教事周。安稳众生故者。凡夫滞有住在三界火宅。二乘着空未免五百由旬恶道。悉非安稳。故中论云。浅智见诸法若有若无等。是则不能见灭见安稳法。今说中道一乘令离凡夫二乘有无二见。故名安稳。以种种法门。出安稳之方令入于佛道置安稳之处也。第二偈中上半知机。第三句说教。第四句得益。舍利弗当知下。自上已来颂一乘真实门竟。今是大段第二颂三乘方便门。上长行文略总辨诸佛出五浊世方便说三。今文广释之。明释迦出五浊世。一期所化凡有四门。第一居法身之地见五浊众生有苦无乐故起大悲心。第二悲心内充以本垂迹。初成道时欲说一乘拔物极苦与其极乐。但圣虽能授物物不能受。是故息一化。第三既不堪受一化故。于一佛乘方便说三调柔其心。第四明会三归一。此之四门皆起五浊。故是释上五浊章门。初见五浊故起大悲心。以有五浊不堪受一化。由有五浊故方便说三。五浊障消故后为说一。是故四章皆起五浊也

问。何因缘故但明四章耶

答。释迦出五浊世。一期始终唯有此四门。譬如父母见子病苦初深生愍恻。二者则欲以妙药授之令子病顿差。但子病重不堪服药也。三者既不堪授妙药权以粗药治子重病。四者重病既除还堪授妙药病便除差。父除子身病唯此四门不得增减。佛治众生心病亦唯此四不得增减。是故一期出世但明四门也。非但释迦一期出世备此四门。一切诸佛亦不出此四门。然此四门则为后火宅四譬为本。初门为生后长者见火譬。第二门生后救子不得譬。第三门生后三车救子得譬。第四门生后等赐大车譬。然前后法譬其文相主。唯有此四不应更复生于异释。若言有十譬本六譬本。并不与文相应。末世既不见佛意。唯依佛为师不应生穿凿也

问。后譬既有六。今云何但有四耶

答。前长行明五浊但有一章。今偈转势说法遂有四门。此品法说有四。后品譬说明六。亦是转势说法。若言后说还同前者。三周之经是一周意。盖是讲经师大失也。至譬喻品当广说之

问。此之四门具几种身

答。具三身也。初明居法身之地见物有苦无乐起大悲心。次初成道时为诸菩萨说华严教。则卢舍那身。第三门为诸声闻说三乘教。谓释迦身也。初谓佛所见身。次是菩萨所见身。后是二乘所见身。又初是法身。次是应身。后是化身。第四门闻一乘了悟始终教意。具有三身。故法华论释寿量品具明于三身

问。此之四门具几种教

答。此之四门具足三教。如来居法身之地照五浊众生一期始终根性应具堪闻三种教门。次以本垂迹为众生故说三种教。初成道时为诸菩萨说根本法轮。第二门不堪受根本法轮故从本起末明枝末法轮。第三门会三归一故明摄末归本法轮

问。既有三种法轮。亦得明三身不

答。亦得尔也。初为诸菩萨现卢舍那身则根本身。次明二乘不堪见此身故隐本垂迹起枝末身。故信解品云脱珍御服着弊垢衣。第三既立一废三。亦息迹归本。则应云脱弊垢衣还着珍御服也。故教既有三身亦如是。就此四门各有三段合成十二章经也。初门三者。第一明能见。二明所见。三起悲心。我以佛眼观者明能见也。五眼有二门。一就应身论五眼。佛托父母身故有肉眼。次在道树下得于四眼。以有远见故有天眼。照三乘根性故有法眼。照于实相故有慧眼。照佛境界故有佛眼。次就法身论五眼者。照五种境界故有五眼。照障内境名为肉眼。照障外境名为天眼。余三如上

问。若约五境论五眼者。今照六道应是天眼。何故名为佛眼耶

答。五眼有二门。一者因中名四眼。果地名佛眼。谓人有肉眼。天有天眼。声闻慧眼。菩萨法眼。佛有佛眼。故四眼入佛眼中悉名佛眼。今是因果相对故言佛眼见众生不名天眼也。佛眼中约境论其五用故。有五眼者见六道众生则属天眼也。又佛眼无所不知无所不见亦见六道众生也

问。五眼得名凡有几种

答。肉慧两眼就体得名。以肉为眼故名肉眼。以慧为眼故名慧眼也。法眼则从境立名。以其见法名为法眼。天眼佛眼得名不定。所以然者。天眼得名凡有三种。一从人立称。又从义得目。诸佛菩萨名为净天。生在人中报得眼根彻见大千世界。从彼净天以立其名故名天眼。二者就趣得名。始从四王上至非想通是天趣。生彼天中报得眼根能远照瞩故名天眼。三者从因受名。如地持说。一切禅定于三住中名为天住。依此天住修得净眼。从因得名故云天眼。佛眼得名凡有二种。一从人得名。佛是人名。人有此眼故名佛眼。二佛名觉。则此觉能照故名为佛眼

问。五眼以何为体

答。若据法身以智为体。智有五用故名五眼。若就应身天肉既是报名。则以色法为体。余三以智为体。若言天眼通。依毗昙义亦以智为体

问。五眼与华严十眼云何相摄耶

答。言十眼者。一是肉眼见一切色。二是天眼见诸众生死此生彼。三是慧眼见诸众生根性差别。四法眼见诸法真实之相。谓见诸法第一义相。五是佛眼见佛十力。六是智眼分别了知一切种法。七是明眼谓见一切诸佛光明。八出生死眼见涅槃法。九是无碍眼见一切法无有障碍。十是普眼谓见法界平等法门。初一是前肉眼亦兼天眼。见粗细远近是天眼故。第二天眼是前天眼。第三慧眼．第五佛眼．第六智眼．第七明眼．第八出生死眼．第九无碍眼。此之六种是前法眼。第四法眼是前慧眼。见真谛故。第十普眼是前佛眼。普见平等真法界故也。见六道众生者第二明所见。就所见内为二。初总明见六道。次别明见有无也

问。大品云五眼不见众生。今云何言见

答。净名经云。有佛世尊得真天眼。悉见诸佛国不以二相。不以二相者。见宛然而无所见。虽无所见而无所不见。故见不见不二。大品明见无所见。此经明不见而见。故不相违

问。既见六道。与六道见何异

答。佛见不六而六。知六无所六。六道作六六而见。故寿量品云不如三界见于三界。华严云。随顺众生故普入诸世间。智慧常寂然不同世所见也。又众生有二。一颠倒性众生。二因缘假名众生。大品明不见者。道理之中毕竟无性实众生故不见。此经明因缘众生故佛眼见。故前文具二义。人天两足尊知法常无性即是不见性义。佛种从缘起谓见因缘义也。又中论云。诸法无决定性。佛有无量方便。或说一切实不实等四句。亦应云法无决定性随众生故或说见不见等四句。故论云。诸佛或说我。或说于无我。诸法实相中非我非无我。亦应云诸佛或说见或说于不见诸法实相中非见非不见。贫穷无福慧下第二别明见有无。初明见无谓无福无慧也。然虽行有所得福慧。望道言之。终是无福慧耳。故大品云有所得者无道无果。入生死崄道下此明见有也。上见无福无慧有二种无。今见苦果苦因二种有也。初明见苦果。亦乘上文以无福慧资粮故入生死崄道致令众生苦果相续也。深着于五欲者此明见苦因也。又前入生死崄道行苦因得苦果。今于苦果上更造苦因。苦因有二。初爱次见。深着于五欲者正是爱也。三界烦恼通名为欲。以染着性。故成论云罗汉断三界欲也。言深著者。以有所得见五欲决定有实。然后着之。所以为深也。如牦牛爱尾者。牦牛以痴故爱尾。众生以痴故起爱。又由爱尾故为人所得而遂害之。故爱尾是害身之具。众生爱五欲故备受众苦。故龙树传云。欲为祸本。众恶之原。败德危身皆由此起。吾若得脱誓当出家也。以贪爱自蔽者。上明由痴起爱。今明爱功用也。爱有二力。一感生死苦。二迷境障智。前明入生死崄道。谓感生死苦。今明迷境障智。以爱覆心所以障慧。盲瞑无所见。谓迷境也。不求大势佛者。深着五欲谓病人也。大势佛者佛有大势力能断众生爱病。谓良医也。断苦法者谓平等大慧则良药也。众生以爱覆心盲无所见。不知贪爱是病。又不识佛为良医法为妙药也。深入诸邪见下第二明见因。以苦欲舍苦者。如诸外道计三界苦为涅槃。檀提婆罗门指腹为涅槃。则计欲界苦为涅槃。阿罗罗外道计无想为涅槃。即计色界苦以为舍苦。郁头监弗计非想为涅槃。则以无色苦而欲舍生死苦也。即是释上邪见义也。此是通邪见。于五见内非乐净见乐净。是独头见取也

问。计生死为涅槃。为迷生死为迷涅槃耶

答。正迷生死为涅槃。如迷机为人。为是众生故下第三明起悲也。远悲者。愍其无福慧二善有苦因果两恶。近悲者。悲诸外道计非道为道道为非道也。我始坐道场下。第二以众生有五浊故初成道时一乘化不得也。上既大悲内充。今明方便外救。但圣人虽能救物不能受。就文亦三。第一明不得说一乘。第二诸天劝请。第三违请。初文又三。半行明思惟处。次半行明思惟时。后一行半正明思惟事也。我始坐道场者。摩竭提界寂灭道场初成正觉也。观树亦经行者。有人言。因名以表意。树者欲树立众生于大乘善根也。行者欲表如来必行树立之事也。有人言。如来在此树下成道。念于树恩故观树也。行者向为取道故坐。今得道竟是故经行。即欲行善利物报树恩也。解云此解出经。有人言。此是随从世法。即世界悉檀也。世人思惟凡有二种。一观物思惟。二经行思惟。今随从世法亦作此二。注经云。树以静为体。行以动为相。欲发思惟之兆决语默之机也。于三七日中者第二明思惟时也。弥沙塞律云三昧七日。此与十地论同

彼论问云。本为利物成道。何故七日思惟不说

答。云显示自受大法乐故。显已法乐为令众生于如来所增长爱敬心故。复舍如是妙乐悲愍众生为说法故。此则初七日不说第二七日方始说法。此经明过三七日方说。律中及萨婆多传过六七四十二日方说。十二由经成道竟第二年方度五人。则一年不说。智度论云五十七日不说法。或可则是五十七日。或是五十个七日。计近一年。与十二由经相应。适缘见闻。不须会也。萨婆多论云。何故六七四十二日不说。一者梵天未来请故。又陈如等善根未熟故。又前自安身然后始说故。又令众生生尊重故。今明如来久知应说不说。但为示法深妙众生钝根随从世法故。示三思而后说耳。七是一数之穷。三思是俗之常法。故有三七之言也

问。七日云何是一数之穷

答。内外之法七日改异。胎内七日则变。揣食之身七日不食便死故也。思惟如是事下第三明思惟事。有人言。初七日思惟佛智微妙。二七日思惟众生钝根。三七日思惟不可以妙慧授钝根也。有人言。初七日欲法说一乘无机即止。二七日思惟欲譬说一乘无机即止。三七日欲宿世因缘说一乘无机即止。以觅下中上三机悟一乘不得故三七日也。又云初七日以劝门说大乘不得。二七日诫门说大乘不得。三七日诫劝合说不得也。今明如上辨。随从世法故有三七之言。我所得智慧者。今文直出所思惟之三事。一佛慧微妙。二众生钝根。三不可以妙慧授钝根。佛慧微妙者。非愚非智绝观绝缘故称微妙也。众生诸根钝者明慧根钝也。着乐痴所盲者。非直钝根。复有二失。一者着乐所谓爱也。二愚痴谓无明也。毗婆沙云。譬如人缚其手足以物覆眼安蕀林中不能得出。众生为爱所缚无明所覆故不能出生死稠林。如斯之等类下第三不可以妙慧授钝根也。尔时诸梵王下第二诸天请说。就文亦三。初一行半明能请之人。次一句明请之仪则。后一句正明请。智度论云。诸天仪法不同。净居天劝令出家。四天王奉钵。梵王请转法轮

问。佛为众生故出世自应说法。何事待请耶

答。论云佛虽不须请而令请者获福。七卷金光明云。请佛转法轮能灭谤十二部经罪。又先请后说诸佛法尔。又不请而说则外道讥呵。又外道多事梵天。梵天既请则外道心伏。又若不请而说则应答十四难。以待请方说故不答也

问。何故诸天请不明人请耶

答。天胜人故明天请。又人不能请。天有智慧知佛成道故明天请。又佛山林独处成道。此中无人故人不请也

问。大通智胜佛何故十六王子先请后方梵王请。今何故但明天请不明王子请耶

答。注法华云。前佛出好世绍父业浓。今释迦佛出恶世子绍义薄也。我即自思惟下第三明违请息化。就文亦三。第一明假设欲说一乘。第二明无益有损。三明息化

问。上思惟与今思惟何异

答。上明不可以妙慧授钝根。今思惟假设受梵王请强说一乘者则有损无益也。众生没在苦下第二明无益有损。我宁不说法下第三明违请息化。初以本垂迹说于一乘为欲利物。今说一乘则无益有损。故舍应归真名入涅槃。则无所损也。寻念过去佛下大段第三明初成道时众生既不堪受一乘故于一佛乘分别说三

问。佛为自说三乘。待请说耶

答。依智度论云。梵王初请说法。如来云佛法甚深众生钝根违请不说。次梵王陈众生有上中下根重请说法。佛受其重请故说三乘。就文亦三。第一明照众生根性。二正说三乘教。三禀教得益。则生后三车化子得譬也。初文有三。第一明顺同过去诸佛故说三乘。第二受现在十方诸佛劝故说三乘。第三受劝即随顺五浊众生故说三乘。前二上同诸佛。后一下顺众生。即是三因缘故说三乘也。若取詶梵王请则有四缘也。初偈为二。上半思惟古佛。下半明释迦顺同古佛道法一乘化众生不得故于一乘说三。释迦信而好古宜顺同之。作是思惟时下第二十方诸佛劝说三乘也。就文为二。第一称叹。第二奖劝。初文为三。半行明十方诸佛现身。所以现身者。释迦于一说三合理称机。则数感诸佛应现身。次半行安慰赞叹。安慰者。隐其实德以贫所乐法度众生。此是忍苦之事。今随从世法故须安慰。次称叹者。设三乘方便合理称机。斯可叹也。次一行正出叹辞。事如文也。我等亦皆得下第二明诸佛自叙。则是奖劝。就文为三。第一明现在诸佛上同过去佛方便说三。第二偈明现在诸佛下顺根性是故说三。第三半行明说三之意。舍利弗当知下第三明释迦欢喜受劝。就文为二。初一偈明欢喜詶上诸佛称叹。次偈明受劝詶上诸佛奖劝也。南无者归命也救我也。归命者以命归投十方诸佛也。诸佛奖劝说于三乘。则延众生慧命。便是延释迦命。是故释迦以命归投诸佛。诸佛劝说三乘。既是救济众生。即是救济释迦。故称救我也。复作如是念我出浊恶世下第三顺五浊众生故说三也。我即自思惟者。二章经始末有四思惟。不说一乘有二思惟。如前释之。说于三乘亦二思惟。所以有二思惟者。随顺世法再思方决也。又初思惟同古佛行。次思惟顺今佛。又初思惟上同诸佛。后思惟下顺根性。而言浊恶世者。虽有十方佛劝。若出好世亦不说三。今自省释迦。出于恶世故宜受劝说三也。思惟是事已下第二正说小乘。文有七句。前明欲说三乘时。谓再思已决宜应说三。即趣波罗捺第二明说三乘处。波罗捺此云鹿林。昔在王以林施鹿故云鹿林。毗婆沙云仙人园。昔有仙人在此处住。因以为名。又翻为绕河城。城有水绕。今谓波罗捺是其通处。鹿林是其别处。迦毗罗国正是天竺之中央。诸国皆在四方也。波罗捺在迦毗罗之西相去九百六十里。佛转法轮处在波罗捺之北相去二十里。树名香净

问。何故住此处初说法耶

答。众生待时待处以得悟故圣人化之耳。处无定也。今明有二因缘故住彼处。一者毗婆沙云有五处定。谓生处．出家处．成道处．说法处．灭度处。三世诸佛常于此处说法故云处定

问。何以知处定

答。佛未出世有转轮王。将兵众欲从此道过。而兵众即住不行。空中云此是古佛说法处王须避之。故知处定。二者五人退不还国。畏净饭王诛之。进不给侍太子。谓佛无道。故顿止鹿林。毗婆沙云三人计苦行得道。二人计受乐得道。二人见佛苦行。便谓佛无道故往鹿园。三人二年供养佛。后见佛食乳麋。复谓佛受乐故无道。亦舍佛往鹿园。佛受请竟则自念云。甘露门开谁应先闻。自念阿罗罗郁头蓝弗聪明利根应前得道。诸天报云。一仙命终已七日。一仙昨夜命终。佛复念云谁应得闻。则知前五人应次受道。故往彼化之也。诸法寂灭相下第三句将辨三乘之权故。前明方便之本。方便之本即是佛所得法。故非观非缘不三不一。名不可以言宣也。以方便力故下第四句明从实起权。非三非一权说三也。为五比丘说者第五句明所为人也。言五人者。一陈如二十力迦叶三頞鞞四跋提五摩男拘利。言比丘者。说法竟方有比丘。五人据其初比丘语其后

问。何故前为五人说法耶

答。经出不同。一云迦叶佛时有同学九人。四人利根前得道。五人钝根自誓释迦出世要先得道。又经云释迦过去于饥馑世作大鱼身自誓云。前食我肉者当先度之。五人前来食之故前度也。又经云过去世有六人。五人取稻华供养佛。一人云待之稻熟供养。故五人前悟须跋后悟也。是名转法轮下第六句结说教名字。若据自他而言。佛初成道自转法轮谓初自转也。今为他说法则他转之初也。便有涅槃音下第七句结教旨归也。虽转四谛宗归一灭。故大乘有四谛与一谛。小乘亦明四谛一谛。说三乘法要具上来七章也。及以阿罗汉下第三明禀教得益。就文为二。初明得益。次释疑。前明转四谛法轮。今辨三宝现世。阿罗汉者佛宝也。律云佛为五人说法。五人唤佛为罗汉也

问。陈如初得道。余四人住在何位

答。婆沙云。四人住燸等四善根。至夏初方得道

问。八万天得道是何天耶

答。正法念经云是炎摩天子

问。智度论云八万天子得无生法忍。余经云得法眼净。此事云何

答。小乘法眼净即是小乘无生法忍也。从始坐道场至此文。皆是引转法轮经事来也。从久远劫来下第二释疑密开寿量。明释迦久解于一说三非受诸佛劝始能说涅槃。又明从久远以来有此方便利物非今新制。汝勿疑之。欲以劝信故作是说。从上来明方便事竟。故豫制物疑也。舍利弗当知下第四明说一乘教。就文为三。初见大乘机发。二正为说一乘。三闻一乘得悟解。前说三乘亦唯此三意。此三即生下等赐大车譬。第一机发生后索车譬。第二为说一乘生后等赐大车譬。第三闻教悟解生后得车欢喜譬。初章又有四。第一两偈明见大机发。第二一偈念欲兴教。第三一偈举无机之失显有机之得。第四一句见有机发故欢喜也。我见佛子等者。大机既发有绍继之能为佛子义也。机发者非一故云千万亿也。咸以恭敬心者。据事而论。既到佛所听法。必尊人而重法也。就根缘而言。必有舍小崇大之理故云恭敬心。皆来至佛所者。即事而言。灵山之会也。理中机发扣圣名来也。曾从诸佛闻方便所说法者。序过去曾禀方便之教也。昔不知是方便。今教起始名之为方便。所以辨昔方便者。良以昔闻三乘柔伏其心为入大乘之方便也。我则作是念。第二既照大乘机发念欲兴教也。舍利弗当知下第三明无机之失也。凡有四失。一者以不知因三悟一故名钝根。如守指忘月。二者乐二乘法称为小智。则但得人无我故也。三封执小教名为着相。四保小究竟不信一乘名为憍慢。如此之人已离法席。汝等住者内有实德不同彼人。今我喜无畏下第四见有机故欢喜无畏。说一乘法畅于佛心故名为喜。如涅槃经云心喜说真谛。故知众生必能信受无谤法之畏。于诸菩萨中下第二正明说一乘也。指三乘人名为菩萨。正直舍方便者废权教。显露废权名为正直。昔在鹿园之会正立于权。未得明舍。亦是意舍言不舍。至付财之时但是密舍。未得称于正直。又昔执三是实为邪。今遂舍之为正。三乘望佛道迂回称曲。今废三乘则直至佛道故云直也。但说无上道者明立实也。昔废实立权。今废权立实也。菩萨闻是法下第三闻一乘悟解也。菩萨称疑除罗汉云作佛者。互现文。又昔不明罗汉作佛。故今明罗汉作佛。昔已说菩萨作佛。故今不明作佛。但菩萨昔谓有三。今闻无三所以生疑。今知昔说三是方便今说一是真实故二说不相违。故疑除。又菩萨昔有旧疑。未知为进成佛道为退作二乘。今知有一无二。故但进不退故旧疑除也。如三世诸佛下第三大段次明赞叹法。初段颂一乘真实门。次颂三乘方便门。于三乘方便门内广序释迦一期出世始终之事既已显然。显实开权皆法华经内之说。叹法令物信受故须称叹。凡有六叹。初一行作合诸佛仪式。叹诸佛皆先三后一释迦亦尔。又诸佛皆有根本枝末收末归本。释迦亦尔。故名如诸佛仪式也。次半行叹佛难值。俗圣易逢故云千年一圣。诸佛难值故劫数遥永。所以然者。众生福少罪多故不见佛。设有余功德多无见佛善根。故佛于其人为难值也。下半明佛则易值叹法华难说。所以然者。有人值佛四十余年而不闻说一乘。则知一乘难闻佛易值。所以然者。众生多有凡夫二乘善根。少修中道正观种子。故不感佛说一乘也。次半行明汝等无量劫来闻之则难。如从大通智胜佛所至今方能得闻。次半行明闻之则易专心听受生信为难譬如优昙华下明听之则易闻解欢喜此则为难。闻解欢喜者。以闻法悟解内心欢喜外发言称叹。三世诸佛同行此道今欢喜称叹。称合圣心。即是法供养三世佛。如此之人过优昙华也。轮王出世有优昙华。而闻法华作法轮王故云过也。长行举此华叹法。今举此华叹人也。汝等勿有疑下第四大段明劝信也。称叹既竟故劝除疑信受也。汝等舍利弗下大段第二示上根人弘经方法。上一周说竟。今劝传示未闻。又身子得悟则成菩萨。故应弘道利人。又上明说法则是燃灯。今明弘经令传灯也。又法说一周亦得别开三段。初简众谓缘起。次明正说。今是流通。就文为二。初四行通示弘经方法。次三行示得失。就初又二。前一行叹所弘之经。次三行正明弘经方法。昔不说故称之为秘。所言秘者盖是称叹之辞。如世秘方千金不传。今亦尔也。所言要者宗归一也。又正明作佛也。次三行弘经方法为三。初二行诫令非器莫传。次一行劝令是器宜授。初二偈中前偈诫令勿为起爱人说。次偈诫令勿为起见人说也。初是凡夫见小乐而忘大乐人。次是保执小乘人。必逆拒大法。有惭愧清净者。第二劝是器应授。亦有二人。惭愧是始行人。起于爱见及凡夫二乘心即改悔惭愧也。清净者久行人也。久习大乘无所得正观。无复爱见及凡夫二乘之垢。故云清净。如上云有佛子心净是矣。舍利弗当知下第二示得失。初一行半举不习学之失。次一行半叹身子习学之得。诸佛法如是者。要先权后实。此示所学之摸轨。次半行明不学此经则不知之。诸佛世之师者。身子初闻略说谓佛是魔。闻后广说方知是世大师。此半行明识人之邪正。次一句叹领法之权实。下句无疑总结决了人法也。次半行明二疑既除欣成一极

法华义疏卷第四

永仁甲午仲吕初三为造板毕功先妣得果也爰沙弥道尊水叔孝未终十三忌景将满风树悲几许千万愁绪在谁乌呼担劫石不磷之恩遇浮木未朽之幸仍刊义疏第四盛流行无穷乃至有顶阿鼻济度无边而已

都干缘沙门　素庆谨志法华义疏卷五

        胡吉藏撰

    譬喻品第三

所以有此品来者。斯经文虽七轴。宗归平等大慧。但入此大慧有种种门。或从法说门入。或从譬说门入。或从亦法亦譬门入。若因此三门悟入大慧则三种是门。若因此三门不得悟入则三种非门。故涅槃经云。或有服甘露寿命得长存。或有服甘露伤命而早夭。无碍智甘露所谓大乘典。如是大乘典亦名杂毒药。但上根之人闻法说已解无待譬喻。故涅槃经云。乃为利根人说大乘九部经略于譬喻。即其事也。中根之徒未能忘言领法故闻法说不解。而能虚心待譬故为说譬喻。又随风俗演教不同。震旦言多约法天竺语多引譬类。昔张骞寻河源至大月氏国。见天竺使来而问之曰。彼土风俗其事云何。使答曰彼国斗则乘象言多引譬类。佛出天竺随彼风俗故立譬喻也

问。譬与喻何异耶

答。经论之中或称为譬或称为喻。故知譬喻是眼目异名。亦得有异义者譬者类也喻者晓也。假借近事以况远理晓诸未悟谓之譬喻。注经云譬以标事言心喻以言心及事也。但经论之内有四句不同。一假近喻远如此经云。大富长者即是如来。二假远喻近如涅槃经云。譬如涅槃非有非无罪亦如是非有非无。三以近喻近如中论云。国无鋀石譬之如金。四者以远喻远如大品明。云何如实际谓如法性以法性喻实际也

问。第二周譬喻说既名譬喻品。初周就法说应名法说品。初周既别题方便品今复受何名耶

答。通而为论互现皆得。但上就别以题名今据通以标目。所言别者法说语通方便名别故从别为称。今言譬喻其语则通故从通为目。斯则法喻双举通别互题也

问。大经云喻有八种今是明何譬耶

答。若前品是法今譬上法者则先法后譬谓后喻也。若就此品而言未有法说前明于譬是前喻也。又今火宅喻是遍喻也。八种喻中可含三也。但法譬二名其义不定。人多谓譬但为事法定是理。此实不然。大经云譬如涅槃则涅槃为譬喻如金刚则金刚为譬。故知法譬之名义无定也。以不定故可得法以为譬譬以为法以譬为法则法非定法以法为譬则譬非定譬当知非法非譬强名法譬。故因此法譬为令众生了悟正道非法非譬。故上文言是法不可示言辞相寂灭。寄言题品令悟无言故云譬喻品也。立品名应从尔时舍利弗白佛言我今无复疑悔文安之。而卷初身子领解如来述成及与授记此之三章未是譬喻。而忽在此立品名者。有人言上根人领解望下立信解品应别立品名。但文少不足别题故寄譬喻品初说也今明身子要由解前法说方能请后譬喻。故后譬由前领法所以立譬喻品在领解之初也。尔时舍利弗下此是法说中第二大段上根人领解。所以得领解者以教是缘教故言教称缘。缘是教缘故言缘称教教称缘故应病授药。缘称教故如法服行。是故上根即便领悟也

问。何故众经得道不阵领悟此教受解而自叙耶

答。为是义故众教不同。若须一类何名多部。又法华之前大小分流法华之后三一已会。此经既是大小交际反三之始归一之初。以义难明故。须述解。又小乘之人而信大法虽言已解容有僻谬。今欲自陈请佛印定故须述解也。又自陈领解即是重敷一乘。使守迷之徒因此得晓。又若上根人不序领悟则中下之流便谓无人得解教便虚设则望崖而退。为欲诲引迷情故须述解也。又佛上自说则是大人化小人。今身子陈悟则是小人化小人。又上父化于子今是子化子。以义兼二化故取信不难。又是大人禀大教而悟大小人禀小教而悟小。此皆称其理分不足述解。今忽小人悟大盖是教所希闻故须述解。若不述解容言小人终不悟大。无得佛理则还同昔经。则今教空设也。又自述领解击彼迷徒令守隅之人专情自策。伊既已解我何犹迷。为是因缘故须自述也。又上品末佛示弘经之方劝上根人秉解传化。今既述解则从佛前命也。就文为二初长行次偈颂。长行又两初经家序其喜敬次发言自述领解。前有二句。一者内心欢喜。二者外形致敬。内心欢喜者欢喜从信解而发故示于喜貌以表信解。身子欢喜凡有二义。一有所除故喜二有所得故喜。有所除故喜有二义。一者昔旧疑悔除二今新疑悔除。此二忧除是故欢喜。有所得故喜亦有二义。一者闻上法说得未曾有解故喜。二者闻上总记豫欣得记是故欢喜。此二是喜中之极故称踊跃注经云疑虑外除喜心内发不觉舞蹈。是故踊跃也

问。成实论云无忧无喜罗汉功德。今经何故云罗汉欢喜耶

答。有人言罗汉实无喜为欲引物是故示喜。有人言本就六心判声闻缘觉。罗汉由是外凡岂无忧喜此据理释也。若就教释此即无也。成论云忧喜要从想分别生。罗汉断正使尽无复执惑岂有忧喜耶。而经言有者此义说庆悦之心为喜。例如义说无漏观智为任放乐也。今明小乘内说罗汉无忧喜就大乘论之则有喜也。例如凡夫五欲不能动迦叶菩萨音乐则不能自安也。即起合掌第二外形致敬。将欲自陈领解仰瞻如来请为印定。是故避席表其敬诚也。又上即是意业欢喜今谓身业致敬也。瞻仰尊颜者以仰瞻尊颜思候可言之时也。而白佛言下第二发言自叙领解。候得其机乃敢发言也。又上是身心喜敬今则口述领解也。就文为三初标喜二释喜三结喜。标中二句一标得喜之由二正明得喜。闻此法音者即方便品同归一音。谓得解之由也。心怀踊跃第二正明喜也。既闻所未闻故称得未曾有也。所者何下第二释喜。以喜义未彰故宜释所以。就文为二。初序昔迷故致忧二明今解故喜。初文复开为二。一序昔悔二明昔疑。以失大故悔取小故疑。疑悔既生则内心不悦故须明此二也。然取小既疑失大亦尔。失大既悔亦悔取小此义互通也。我昔从佛闻如是法者总叙昔日闻法也。见诸菩萨授记作佛者别明所闻事也。又向序闻法此叙见人。一会之中备有人法故具陈也。然见诸菩萨受记作佛可通大小。大乘中论波若已上竟法华之前皆明授菩萨记。然三藏中亦有此说。释论云中本末阿含经。记弥勒作佛。明土净人华神德无量。身子见此便起悔心也。而我等不预斯事甚自感伤者哀伤己等不预胜流也。失于如来无量知见者既失偶于同朋。又丧果于无量何苦如之所以伤叹也。世尊我常独处下第二明旧疑即谓佛赐偏也。失于大果由佛授小故妄咎于佛。我常独处山林树下者前明在会见闻之时此叙独处思惟之日也。每作是念下正出所疑也。同入法性者法性即是实相。三乘得道莫不由之。中论观法品云得实相者有三种谓三乘人。大经云观中道者有三种皆是其事故言同入法性也

问。身子何处闻法性而悟耶

答。身子入法性有三时。一者初遇頞鞞即闻空法。故云息心达本源故名为沙门。本源者即法性也。以闻此言得法眼净所以入也。二者身子得初果已后闻佛与长爪论义责不忍之见堕粗细两负明诸法空。身子闻于此言便成罗汉又是同入法性也。三者从得罗汉已后历闻大品及方等众经皆明三乘同入法性。故始末言之凡有三时同闻法性。云何如来以小乘法而见济度者同入法性明所证是同。以小乘法而见济度明所得为异。实由见法性有浅深。而谓佛授有大小不自省过。而疑佛赐偏也。是我等咎非世尊也下第二明昔疑悔既除今得解欢喜也。就文为两。初标章门次释章门。向不审思妄咎于佛。今三复寻究失在于我。故云是我等咎非世尊也。所以者何下释章门也凡有二句。初明不待说大故失于大。次明自取于小是故证小。此二并是自失非佛过也。若我等待说所因者。待谓当待之待。所因者谓学地六度等诸行。六度等诸行并是成极果之因故谓诸行为所因也。若我当待斯说者如来必用大乘以济我苦海而勉累缚。故云若待说所因则成三菩提必以大乘而得度脱也

问。何以知然耶

答。上文云诸人今当知合掌一心待待后佛起定说法也。又经云待处待时待人必是后时事也。然我等不解方便随宜所说下此第二明自取于小。明由我不解故自取小则咎在己过非佛

问。方便随宜此有何异

答。方便者显法非真实。随宜者随前人机宜。人法不同是以两出也。又方便与随宜二事各别。方便者阶渐为义如七方便之流。谓教有大小而匠者说法自有阶渐。说小应先明大宜后为化宜尔即名随宜。我若解者便应弃先之小待后之大。由我不知便谓小为理极故信受取证。失大之过所以在己也

问。五人是初闻佛法身子何得称初闻耶

答。此言初闻者不云身子在众人之初。但身子本学外道初从頞鞞始闻佛道即证初果鬓发堕落便成沙门

问。成论云取衣时有烦恼取衣已无烦恼。身子大利根人何故不即成罗汉而证初果耶

答。婆沙云波罗蜜声闻必前证初果后成罗汉。法如是故。有人言身子博学多闻于世俗智慧胜于入道智慧劣。故不及取衣时有烦恼取衣已无烦恼人也。我从昔来下第三结欢喜也。将结喜故重牒昔忧也。我从昔来终日竟夜并牒上二处文也。牒前在会腾后独思。明无时不尔故云我从昔来也。于日则终于夜又竟每自克责岂有悦时也。而今从佛闻所未闻者此正明今喜也

问。但应明喜何故前辨忧也

答。身子喜从忧除故喜生。昔既疑悔所以生忧。今疑悔除故欢喜也。又据益物言者前序迷忧示我同物。今悟故喜引物同我。又此二事并为引物。身子于声闻中最为第一。取小失大既生疑悔。诸余罗汉道劣身子宁得保小不欣大耶

问。疑悔通今昔不

答。疑通今昔悔但据昔。昔失大故悔今明不失大则无悔也。疑通今昔者昔以教理相疑。理既唯一教不应三。今疑者今昔两教相疑也。昔教说三今何由辨一。如三请中说也。身意泰然快得安稳者忧悔塞心所以不泰疑摇其虑故不安稳也。此文具含二喜。一旧疑悔除故喜。二今疑悔除故喜也。真是佛子者明佛子有二门。一者小乘有五佛子谓四果及缘觉。二者大小合明五佛子谓四果及法身菩萨。今云真是佛子者对小乘五种佛子并非真子。今悟解一乘堪绍继佛种始为真佛子。胜鬘经别有真子章如彼释也。从佛口生者上对小乘之伪总明今大乘为真子。此下别约三慧以释真子也。从佛教生闻慧解故云从佛口生。从法化生者从理法生思慧解也。得佛法分者生修慧解也。故毗昙云闻慧一向从教生修慧一向理生。思慧或时从理或时从教。依今文思修二慧并从理生也。智度论云外书明婆罗门从梵天口生于四姓众生中最胜。今随俗叹从佛口生。佛是真梵天从佛口生为最胜也。从法化生者亦是借譬叹也。如诸天等从父母膝上忽然化生。于四生内为最胜。今从极法而化生乃是胜也。得佛法分者此亦简叹也。入佛法有二人。一贪名利谓取财分二悟解佛法名取法分。今对昔者取小乘分不名取于佛法。若取大乘名取佛法。如下文云。不失如来知见宝藏之分即其事也。第二偈颂颂上标释结即为三也。颂标喜为二。初一行半正颂欢喜次一行称叹于佛。就初有三。初一句颂得喜所由。次半行正颂欢喜也。疑网皆已除下释欢喜意也。喜有二事。一疑除故喜。二有所得故喜也。不失于大乘者解昔所得即是大乘。昔说大因为小果名于一说三。今悟小果即是大因故不失于大乘也。又前一句明疑网除。此半行明悔息。疑悔已除故欢喜也。佛音甚希有下第二称叹于佛以解由佛得故叹佛也。上半叹佛能除三界内众生忧恼。我以得漏尽者自序身子无复三界烦惑所恼。但有失大之忧取小之恼。今闻佛教亦得除也。又上半叹昔教有能除之功。下半行辨今教有遣惑之用也。我处于山谷下第二颂上释欢喜义也。从此章去序身子三时忧除故喜。一者序得道后疑悔除故喜。二者序是初得道时执见除故喜。三颂从今闻法华教疑除故喜。此三收摄始终一教意尽矣。前二即是昔旧疑悔从初得道竟法华之前也。次新疑从闻法华始生也

问。此三颂何处耶

答。旧经师一向望长行以释偈都失偈意也。今明偈颂者意乃大同。但偈望长行多是转势说法也。欲颂前者初一颂上疑悔文也。次一颂上初闻佛法遇便信受文也。第三颂上而今从佛闻所未闻未曾有法以去文也。就初文为三。第一颂上失大故悔。第二颂悔后生疑为失大乘为不失大。第三明疑悔除。初又二。第一明独处思惟生悔。第二明在会见闻故生悔。与上长行翻者亦是转势说法欲明闻不止乎一会思不止乎一时。是以互其前后以表之也。我处于山谷下半行颂悔处也。若坐若经行下半行颂悔时也。呜呼深自责正出悔辞即是悔体。呜呼深自责者总标自伤自叹之辞。自作自误故云自欺也。我等亦佛子下别出自伤之事也。同入无漏法者颂长行同入法性之言也。无漏者法性无为无漏也。又长行明法性举其境今明无漏。举其智。非智则不境非境则不智。以互共相成故前后两说也。不能于未来下上明其现同今伤其当果异。此半行明失化他果也。金色三十二下此二行明失自德果也。又上是口密德今是身意两密德。两偈为异者初偈举佛小乘生法二身次偈举佛大乘生法二身。何以知然。智度论云小乘中生身不说八十种好法身中不说十八不共法。今以小大为类明身子俱失也。又初举三十二相为外十力为内。略叹佛内外二德。次偈举八十种好为外十八不共法为内广叹内外德也。以广略为类故二偈不同也。同共一法中而不得此事者或言同一佛法中或言同一法性中。故言同共一法中也。所以举同者明悔之甚也。若所行有异所得殊者则不悔也。良以所入是同所得为异。是故悔耳。此颂长行中失于如来无量知见也

问。长行明见诸菩萨受记作佛是故生悔。此明事中生悔也。次明同入法性云何如来以小乘法而见济度。此明于理生疑。今偈颂明同入法性而失佛果德。此据理中生悔。何故尔耶

答。理事俱得生于疑悔但偈长行互现文耳。我独经行时下此颂长行中在会见闻故悔接前偈来者上明失于德果。今明失名闻果。前辨三密故是德果。今云名闻满十方谓名闻果。又前辨失上弘之德故云不能于未来演说无上道。今辨失下利之能故云广饶益众生。是故异也

问。既言我独经行时云何复言见佛在大众

答。有人言此举上之独行就下之在会总明两处失诸胜德耳。有人言身子不在佛会但遥见佛在会故自伤耳。自惟失此利我为自欺诳者从呜呼深自责云何而自欺标自伤章门也。我等亦佛子下释自伤章门也。今半行结自伤也。我常于日夜下自上已来皆颂昔悔。此二行偈第二颂于悔后生疑。两偈为二。初偈独处生疑。次偈在会生疑。上悔有独处之与在会二时。今疑亦然。又独处生疑疑丧果德。在会生疑疑失因行。疑事虽多不出斯二也

问。身子既见理同而教异为是已知同归故名同。为未知同归故名同

答。摇法师注云。已见同归之理。但以理疑教以教疑理互推所以生疑。顺理而推教不应三。就教而言理不应一。故回惶理教之间。众师并同此说。今谓不然。若身子利根悬知理教同异者亦应悬鉴理教权实知理为实识教是权。权实何故难知同异而言易识。又问既已知理一教三者未说法华执根已动。略说之言更动何执耶。又若已知理一教三者下何故云初闻佛所说心中大惊疑。若尔唯有旧惊更无新怖。摇公云初闻佛所说心中大惊疑者初闻三请前说定知理一以教惑理此疑即断更后惊疑。佛昔何故违理说三。由有以理惑教之疑从正说文去第二疑即断难。曰是亦不然。三请之文始是执动疑生实未断也。又新疑之文总明三一相违今昔鉾楯。亦不偏主以理惑教也。今所释者盖是知法性空理同耳。非知一乘理同也。大品及此文自分明。以体法性同故三乘果异。是故以理惑教以教惑理。自教而观应是永失自理而观应由不失。故怅怏迟回意由未决故云为失为不失。第二偈见佛赞扬菩萨由有窥窬之望。未知为永住声闻亦成菩萨。故言以是于日夜筹量如此事也。今闻佛音声下自上已来都是序二疑二悔故忧。此一行偈闻今教疑悔得除故信解。上半领开方便门下半领显真实义。以领此二义故疑悔便息也。无漏难思议令众至道场者三乘无漏就教而言各住三果。考而论之并归成佛也。说三至三可是思议。今说三乘无漏乃令同归道场故不可思议也。我本着邪见为诸梵志师者第二颂初得道时执心除故喜

问。何故不先颂初得道执见除耶

答。得道以后见闻胜事。疑失佛果所以生忧今知不失。是故欢喜。所以先颂也。初得道未有失果之忧则无今日之喜。故不前颂。但后之疑悔由初保执。故举执情释上疑悔所由也。就文为三。初序执见二明悟解三述解所由。初半行身子自叙。我本着邪见者。身子本仕外道删阇夜为弟子也。为诸梵志师者。删阇夜去世以二百五十人门徒付嘱身子。为诸梵志师也。世尊知我心此下半行序佛授其小法也。智度论云。頞鞞初将入王舍城乞食时。佛语之云。汝今日若见非常之人勿广说法。即是世尊知其心也。拔邪说涅槃者。頞鞞说偈云。诸法因缘生是法缘及尽我师大圣主是义如是说。此偈明三谛。诸法因缘生谓苦谛。是法缘谓集谛。及尽谓灭谛。虽有三谛正为明灭谛涅槃。故云拔邪说涅槃也。我悉除邪见下此一行陈昔悟小乘也。上半明身子断邪见得初果时。下半明身子闻长爪论义得罗汉时。故邪中有二时。正中亦二时也。而今乃自觉非是实灭度者。上来序执迷。今陈得悟也。若得作佛时下前半行领识迷。即领开方便门。今领显真实义。既知昔灭之未极即知当极之有在。故言是时乃可谓永尽灭无余也。佛于大众中者第三一行称叹佛。即序得悟之由也。初闻佛所说下第三颂新疑除故喜。前二并是昔旧疑悔除故喜。就文有三。初一偈述新疑。第二明疑除。第三身子自悔过。初闻佛所说者谓初闻略开三显一动执生疑所说也。心中大惊疑者于开宗之始执动生疑也。将非魔作佛者心既生疑。尔时意中密谓佛是魔。所以然者。魔之为性有而言无无而言有一而言三三而言一。故似魔之妄谈也。恼乱我心耶者上半是教乱下半是明形乱也

问。新疑与旧疑何异

答。旧疑但就正生疑。新疑邪正合生疑。旧疑就正生疑者。昔理教俱是佛法。而用理教互相疑故是正中生疑也。今邪正合生疑者。身子谓昔教是佛说今教魔说。故名邪正合生疑。断昔疑故即识大乘为实小乘为权。断今疑故即知一乘是正说非是邪说。故前章简一乘是实而非权故异于小乘。此章简一乘是正说而非邪说。以除此二疑即一切疑断一乘义圆也。佛以种种缘者第二明疑除。就文为二。初四偈正辨疑除。次一偈结于邪正。四偈为三。初一行领长行自开宗说。次两行领长行引证门说。后一行领上顺同门说。初半偈正领佛说教。下半辨于疑除也。其心安如海者。夫虚危假诳必心神睒烁。而今安定惔静。即知非魔。安者如山之安如海之旷。心神既同山海。则知非魔故疑断也。身子闻初自开宗说便以领悟。次两偈引证如文也。如今者世尊下第三领顺同门

问。但应言释迦亦开三显一。何故乃举初生出家得道说法耶

答。所以远言此四事者。寻迹由来自古至今始终皆是一佛。故知非魔惑乱也。又身子非但悟解三乘方便一乘真实。亦知从初生说法皆是方便。所以然者。道理唯一而方便说三。亦道理无生而方便说生。出家得道义亦类然也

问。未说寿量。云何以领真应耶

答。据迹而言。身子利根闻一知二。既解教之权实即领身之真应。若就本择者。身子既是大权助佛扬化。前以广领教之权实。令时众舍三悟一。今略开身之真应。亦令时众不执迹迷本也。世尊说实道下第二结于邪正。所以结正者。为令时众识一乘是佛说非魔说也。上半明佛有实魔无实。即判有无也。下半结于是非也。我堕疑网故者。第三此半偈身子引过归已自悔责也。闻佛柔软音。此第三颂长行结欢喜也。就文为三。初三句叹佛。次三句明欢喜。后一偈明自庆。三句叹佛者。初两句叹能宣之声。后一句明所说之法。三句明欢喜者。初一句正明欢喜。次两句举得离以释欢喜。后一偈明自庆者。初两句明作佛谓生物之福。后两句明说法生物之慧也。尔时佛告舍利弗下第三大段明如来述成。述成其领解不谬也。又将欲为其授记。恐时众疑云若行大因可得大果身子既修小行遂得作佛将非因小而果大。欲断此疑故述其往行明修因既积便得大果无所疑也。又身子本是小学今遂悟大者。此亦可疑。所以然者。诸大乘经皆令怖畏二乘之人遂得授记作佛者。堕于二乘地何所畏耶。是故释云。身子久修佛慧故得悟解耳。若实证小乘则难悟大道。故释论云。罗汉生净土根钝于佛道迂回稽留。不如直往菩萨。故诸大乘经令怖畏二乘也。就文为二。初明于大众中宣说者。昔教权诱事等私言。今开密藏义如公灼。是以告众。又授记有四种。今将欲现前授记使自他俱知故告大众也。又身子昔行大乘因现在悟大未来成佛。亦令大众现在修因未来作佛故告众也。我昔曾于二万亿佛所者第二述其往因也。就文明身子始终凡有三时。一过去学大乘时。二中途取小时。三今还为说大乘时。明过去学大乘时者。明于二万亿佛所修学大也。汝亦长夜随我受学者。上明教被缘。今明缘受教。世间有一夕之眠称为短夜。则有一日之觉称为短日。亦有无明昏寝称为长夜。朗然大悟称为长日。我以方便引导汝故生我法中者。前明于二万亿佛所而教化之。今释身子得就释迦佛法受学之义也。舍利弗下上明身子本学大时。今第二辨中途弃大取小时。初句明弃大。而便自谓下辨取小。智度论云。身子由施眼故不能度布施河。故弃大取小也。我今还欲下此第三明今为说大时。初忆念本愿谓菩提心。所行道故谓菩萨行。欲令声闻续菩提心还修菩萨行故说法华也。法华称教菩萨法者。令声闻人发大心修大行也

问。说法华通为五乘。何故言偏教声闻耶

答。三周说法正为声闻傍及四乘。故智度论云。法华经是秘密教。明阿罗汉授记作佛。所以然者。声闻人不知一有三无三权一实。今正对之故偏为也。汝于未来世下第四大段为身子授记

问。何因缘故为声闻授记

答。略明六义。一者证其所述信解是实。解若不实则不得记。由解实故得记也。故下文云我今无复疑悔亲于佛前得三菩提记。二者受记之言即是重明会三归一。以声闻作佛得知佛乘是实。佛乘既实则声闻为权。三者用此引物。明有信心故便得受记者。欲得受记宜生信心。四者欲令身子欣果行因。五者下文天龙八部乃至中下根人皆藉得记之言以为成信旨归。故与受记。六者发物往生净土之志。既于净土成佛并愿随从往生也

问。身子引何人生净土耶

答。身子是七众依止八部大师。师既于净土作佛。眷属悉愿往生。但身子引物凡有三时。初从外道引入佛法。二从小乘引入大乘。三从秽土引令趣净土也

问。授声闻记与菩萨何异

答。法华论云。授声闻记者令声闻得决定心。非谓声闻成就法性故。以如来法身与声闻法身无异故与授记。非即具足修行功德故。菩萨具足功德是故得记。就文为二。初明授上根人记。二明大众欢喜供养称叹。初又二。前长行次偈颂。长行为二。前辨行因后辨得果。行因者谓三世行因也。前长行初明二万亿佛。所谓过去修因也。次云我今还欲令汝忆念本愿下明现在修因也。今文明未来修因也。就文为二。初明修因时节。二正辨修因。涅槃经云。有旃陀罗一发心于此贤劫成佛。而身子云无量劫成佛者。就教则久近适时。约悟无生亦久近随意。以悟无生不见久近相异。亦不见成不成异。故经云。无量劫一念。一念无量劫。无来无积聚而现诸劫事。则知了久近不二亦未曾久近。如大品云。生死道长众生性多。菩萨应如是正忆念。生死边如虚空众生性边亦如虚空。是中无生死往来亦无解脱者。故久近非久近也。供养若干下第二正明修因。初明供养佛以植福。奉持正法以修慧。具足菩萨总结行成。当得作佛下第二明得果凡有八果。一化主果。二国土果。三教门果。四时节果。五眷属果。六寿命果。七绍继果。八住持果也。号曰华光者。或可从时事以立名。如智论释往生品明三百比丘脱衣上佛举手为相得成佛时名为大相。又千天子见佛土庄严而发净心得记之时名庄严王佛。又释舌相品云。十万亿人见十方菩萨来以华供养而发心得记。故劫名华积。佛号觉华。如此皆因时事以立佛名。身子闻法华经最初领悟故。得佛时名为华光。华即法华。光谓信解。境智合目故号华光也

问。三根声闻悉悟法华。应并名华光耶

答。身子最初得悟故受华光之名。例同阿若憍陈如最初悟无而生智慧余人后悟别受异名也

问。诸经授记何故但授应身记不授法身记

答。授应身记即是授法身记。修因既满便证法身。方能以本垂迹。托净秽国土成佛化人。但法身犹如虚空无所不在。引物不便故不授法身记。应身有国土徒众化主教门。引物义便故记之也。国名离垢下第二明国土果也。然土未曾净秽。由众生心净秽故土有净秽耳。身子昔日无凡夫秽心。今悟一乘后离二乘之垢。既离凡圣二垢故得佛之时土名离垢。然心亦不曾垢净。约迷故称垢。约悟故称净。其土平正下。上标土名今出土体。文又二。前总明土体。次别明地处庄严。总明土体中又二。前明土体。次辨人物。离高下故称平。非尖邪故名正。无秽恶名清净。有众宝为严饰也。安稳下明人物也。离刀兵劫故为安稳。离饥饿劫故为丰乐。离疾病劫故为炽盛。琉璃为地者别明地庄严也。有八交道者别明道庄严也。此文从广至狭凡有三句也。初总明土。次别明地。后别明道。华光如来亦以三乘教化下第三明教门果也。以本愿故说三乘者此为释疑。方便品云。诸佛出五浊恶世故说三乘。身子今出于净土。何故亦说三乘。所以释云。彼佛出时虽非恶世以本愿故说三乘法。是则释迦出秽土故说三乘。身子以本愿故说三乘。各有其所以也

问。身子何故本愿说三乘

答。身子于三乘中得悟一乘。还学释迦故施此化也

问。于净土说三化三乘众生不

答。可具二义。一者被三缘故说三教。众生往昔曾居秽土。备萦众苦故厌之愿灭厌之愿灭而性不可回。虽生净国称其本性为说三乘。如厌释迦之秽国生弥勒之净土秽心虽改三性不移故弥勒出于净土亦说三乘。二者身子之土虽无三缘但为菩萨传化余方故说三乘之教也。虽有二义以后义为正。故下但列菩萨无三乘众也。其劫名大宝庄严下第四明时节果。释迦名贤劫。贤者善也。此劫内有千佛善人出世。从化主立名故称贤劫。今从所化菩萨受称故名大宝。不以珠碧为珍。但用贤哲为宝。彼诸菩萨下第五明眷属果。初标菩萨数。若欲行时下叹菩萨德。如是菩萨充满其国者总结菩萨众也。舍利弗华光佛寿下第六寿命果。除为王子未作佛时者。如释迦佛若道俗合论则年八十若论佛寿但有五十。今亦然也

问。何故秽土佛寿短人寿长净土佛寿长人寿短耶

答。佛寿长短无有定相。但秽土感佛业弱故佛寿短。感生死业强故人寿长。净土感佛业强故佛寿长。感生死业弱故人寿短。华光如来过十二小劫下第七明绍继果。此劝悦往生者心也。华光虽没而坚满续兴则佛佛相次。岂可不愿往生耶。号曰华足安行者。宝华承足安祥而行也。其佛国土亦复如是者。虽有异佛兴世而净土不改。亦是悦往生者之心也。是华光佛灭度之后下第八明住持果。大论佛法凡有四时。一佛在世时。二佛虽去世法仪未改谓正法时。三佛去世久道化讹替谓像法时。四转复微末谓末法时。今但举初二摄末属像也

问。既是净土何故有小劫起耶

答。今但论时节小大。非三灾之小劫。就偈颂为二。初正颂授记。第二释授记意。就初为三。第一总标授记二释三结。总标如文。供养无数佛下释授记也。初一行颂上行因。次八行颂得果。得果中初半行颂时节果。一行半颂世界果。二行颂眷属果。一行颂化主果。一行颂寿命果。二行颂住持果。华光佛所为下半行第三总结也。其两足圣尊下第二释授记之意。所以授记者。令其自庆欣果行因也。不颂上教门及绍继二果。偈与长行广略互现。尔时四部众下第二明大众欢喜悟解

问。此中四众八部并是凡夫。上中下根为属何摄耶

答。望经始终谓上品也。身子初领解既是上根。彼前得悟故亦是上根

问。既是上根闻方便品何不即解见今授记方得悟耶

答。闻方便品已仿佛玄宗。睹今授记验理必尔。授身子记意在于斯

问。凡夫初闻尚能领解。中下罗汉云何未悟

答。二乘自谓究竟。其病则重故由未得解。凡夫无有斯疾故初闻即悟。三毒轻重则圣胜于凡。若信一乘难易则凡胜于圣。又此中凡圣多是权行影向。共弘道利人。自陈领悟用引物也。就文为二。初总明大众欢喜供养。次别明诸天供养称叹。初文四句。第一明四众八部列欢喜之人。见舍利弗下第二明欢喜之缘。心大欢喜下第三正明欢喜。凡有二义。一者闻未曾有法心得悟解现生欢喜。二者见身子得记想已亦得预生欢喜。各各脱身下第四供养。信解之生本由佛说。仰感法慧故献财上佛。比丘脱衣上佛者。大品三百比丘脱衣上佛。论云十二年前未制戒故不犯衣戒。今法华时成道四十余年以制衣戒。既闻一乘悟解得正法戒。衣是息世讥嫌戒故舍衣无罪。外国比丘但被袈裟内无别衣。今以衣施佛则是舍三衣中一二也。露身但闻法踊跃。不以此事为羞耳。释提桓因下第二别明诸天供养称叹。前明财供养次辨法供养。衣住虚空中者表心离有也。而自回转者亦不停空表心离空也。既不染空有便解入一乘。又昔协异解于理为背。今信理同则转背成向。内心既转外物亦回。又身既舞踊外物回转。而作是言下第二明法供养。前长行次偈。偈为二。初三行半明闻法欢喜。次三行预欣得记故欢喜。初领方便品。次领身子得记。盖是一周之始终故领此二也。又初是闻法欢喜则籍法为缘。后是见人得记故喜。谓假人为缘。悟道之由唯有人法二缘。二文各四。初文四者。第一偈明昔小为粗。第二偈叹今大为妙。第三偈叹今教为希有。第四半偈正明领解欢喜也。五众之生灭者古经为立阴。释道安云。应云五阴。非是立也。罗什后翻皆云五众。以五法和聚义称五众。又一一阴法各众多故云众也。杂心云积聚是阴义。即是罗什意也。生灭者通目四谛也。苦为所生。集为能生。斯则五阴生也。灭则是五阴灭。道为能灭。故生目苦集。灭据灭道。言约义周巧说之谓也

问。何故不言界入生灭

答。界入含无为。不得并云生灭也。今复转无上下第二对昔小叹今大也。问何故大品．思益．涅槃．法华皆举昔教叹耶。答众经并是举小对大叹。故知诸大乘经显道无二。不得作五时四宗之释也

问。云何举小叹大耶

答。昔明五众既是生灭。今明五众则不生不灭。不生故非苦集。不灭故非灭道。故名一实谛即无生灭观也。二乘既是四谛名生灭观

问。何以知此经明五众不生不灭

答。前文既明昔教说五众是生灭。即知今教明五众不生不灭。故方便品云诸法从本来常自寂灭相。又中论云。为声闻人说十二因缘是生灭。为菩萨说十二因缘不生不灭。故大小二乘有生灭无生灭二观义也

问。无量四圣谛亦有生灭。何得言小乘作生灭观也

答。菩萨了无量四圣谛亦本来不生不灭故无明体性本自不有妄想因缘和合而生。既言妄想因缘而生。有集为能生苦为所生。此即是无生灭生灭。虽生灭不生灭也。故与二乘不同。又言五众生灭者。小乘人言五众无常苦空无我。今略举无常故云生灭。又云有观为生空观为灭故云生灭。又二乘未得有余有烦恼生。得有余则烦恼灭。未入无余则身智生。入无余则身智灭。今明烦恼之与身智本自不生。今亦无灭。故智度论第十九复次云。昔说五众是生灭无常。今欲就异门说五众不生不灭非常非无常

问。何故闻一乘及受记而言五众生灭耶

答。此领开方便门显真实义。昔明五众生灭者此是方便说耳。今明五众不生不灭者乃是真实说耳。以昔见五众是生灭故守小迷大。今知本不生灭则改二执

问。诸大乘经亦明五众是生灭。故经云诸行无常是生灭法。何得言五众生灭是小乘耶

答。智度论明四悉檀通十二部经八万法藏。言五众生灭者为对治悉檀耳。若第一义悉檀即说五众不生不灭。若悟第一义悉檀则生实观。实观即是妙慧。妙慧即是妙法。妙法即是一乘。是故说五众不生不灭也。大智舍利弗下第二明预欣得记欢喜。亦开为四。初半偈牒舍利弗已得记。第二一偈自陈己当得记。第三半偈述得解相。佛道叵思议领显真实义。方便随宜说解开方便门。次一偈明发愿修行。此四段为两双。初二段已得当得一双。后二段明解行一双也。尔时舍利弗下第二大段正明譬说。亦开为四。从此竟品正明譬说。第二信解品中根人领悟。第三药草喻品如来述成。第四授记品明为其授记。所以有四段者中。根之人闻上法说未解。更转势说法故举譬喻晓之。既闻前法说复禀后譬喻即得信解。故有第二信解品。以所解是实故如来举药草喻述成。领解于前述成于后。心得决了行与佛相应。则当果可期故为授记。初文又二。第一身子请说。第二佛受请为说。就初又三。第一自陈己解。第二腾众未解。第三请佛为说。所以须自陈己解者凡有二义。一者若不自陈己解则为物之意不彰。容谓假他而实自未悟则上授记不成陈解亦谬。故须自述己解。二者欲为他请法。须得彼意。若未有解请容落漠也

问。中根之徒自有疑悔。何不自请假他请耶

答。既无先悟之能。又非对扬之主。虽复未解待他质疑也。自陈己解有二句。我今无复疑悔者领方便品也。亲于佛前得授记者领上得记文也。举始括终故标此二也。又我今无复疑悔此明惑灭。亲于佛前得记明解生斯二为要所以述也。又无复疑悔正序得解。亲于佛前得记证解是实故得记耳

问。直云得记便足。何故云亲于佛前

答。授记有二种。一不现前得记由未有解。二亲于佛前得记必有解也。是诸千二百下第二腾众未悟。就文为三。初牒昔二腾今三今昔互相疑。牒昔有二。初牒无学人二执。二明学无学人二执。初标无学人二执者。一离老病死谓离果患也。究竟涅槃者执无余也。学无学人二执者离诸见谓因患尽也。谓得涅槃者执有余也。所以二文不同者。无学人必离果患。若离因患可通学无学人。前列人别故所离亦别。后列人通故所离亦通

问。实断九十八使。何故但离诸见耶

答。无学之人可具断九十八使。而今举离诸见者学无学人皆断之也。我见为众见之本故偏说之。故大品云。譬如我见摄六十二见。有无见即是断常谓边见也。等者等取余三见也。又等取三见及余钝使也。而今于世尊前下第二腾今也。皆堕疑惑者第三正生疑也。小大互决今昔相征故成疑也。昔明已离两患无复可离得二涅槃无复更得。今云由应更离方复更得。今昔相违故堕疑悔也。善哉世尊下第三正请。所以请者。身子是遂佛转法轮将军。有未解者常为请说。又既已得悟即成菩萨。菩萨以济物为怀。须为物请。又既同是声闻。昔俱禀偏化而自已得解余人未解。愍其同朋故须为请。又方便品末佛劝弘经。今为众请即是受旨。又上授记明身子行因未来得佛。今为众请即是行因也。所言愿说因缘者。因缘谓三一之所以也。有何所以故说三。有何所以故说一。辨此因缘释疑除悔故名为善哉。就佛受请说中复开为三。第一缘起。第二从若国邑至下偈云以是因缘十方谛求名为正说。第三从告舍利弗汝诸人等劝其弘经。此三亦得是子章序正流通也。初缘起中复开为二。第一腾前法。第二许后譬。腾前法者良以后譬还喻前法故也。前说虽多略腾二种要句而示悟之。二要句者所谓教一及缘一也。教一者前明众教虽多所表无二。次缘一者以教无异表则缘无异人。故云皆教菩萨也。以教无异表缘无异人。则果无异詶因无异感。略陈二门则备收一切。若尔久应以领。云何复疑．然舍利弗下第二许说后譬。然者虽然也。虽前已说而由未解。当用后譬以晓悟之。又言然者然许。虽前已说然许其今由未悟解更用譬喻以明上二义以晓悟之．诸有智者以譬喻得解者。明其未能忘言以悟旨而能虚心以待譬。以望上根为愚人。望下根为智者。又望上根为愚人。比退席为智者。又腾前为指斥。许说名敦喻。指斥者。我前已说他人已悟。汝何事致迷。用此击之令生愤砺。敦喻者令其重欣慕道发其领解．舍利弗若国邑下第二正说。复开为二。一者长行二者偈颂。长行为二。第一受请正说。第二最后以是因缘结詶身子之请。就正说又二。一开譬二合譬。就开譬中光宅法云法师为十譬。于文义多违。今依古旧开为六譬。一总譬。二见火譬。三救子不得譬。四三车救子得譬。五等赐大车譬。六不虚譬。所以有此六譬者。总譬虽有六义而以化主为正。叹如来德无不圜累无不尽。德无不圜故解救患之方。累无不尽故能济物之累。此为化物之本故先明之。父既德圆累尽。见子有累无德起大悲心。故有第二见火譬。虽大悲内充复须方便外救。故初成道时即欲拔其有累济其无德。但父虽能授子未堪受。故有一乘化不得譬。虽大志未成小机已动故于一说三。应时即悟故有三乘化子得譬。虽复说三终为归一。是以还说实化之。故有等赐大车譬。许三与一似若妄谈。但赐过所求。又本意与一故非虚也。故有第六不虚譬。就此六譬合成五双。初一为总。后五为别。谓总别一双。圣人说法前多总说后则别说。故前总后别。就别中又开为二。初见火譬明内起悲心。即是悬知机。后之四譬应缘说教。谓机教一双。就后教中复开为二。初之一譬顿化不得。后之三譬明渐化得子。谓顿渐一双。就后渐中又开为二。初之一譬为说三乘教。后之两譬明一乘教。谓三一一双。就一乘中又开为二。初之一譬正明说教。后不虚譬名为会教。谓教及会教一双

问。此六譬从方便品何文生耶

答。有人言皆从方便品文生。今明不必尔也。此经有三周不同者。为根性各异宜转势说法故有三说不同也。若一一皆如上说者。则文成烦重言非巧妙。又后不异前。闻前既惑禀后亦迷。则圣说无益也。今明唯中间四譬大格从方便品四段文生。初总譬及后不虚譬皆是今品义说。所言四譬从前生者。见火譬从前我以佛眼观见六道众生文生也。彼文明佛居法身地见众生有苦无乐起大悲心。今文明长者在门外见火起烧宅即大惊怖。二文义同故今文从上生也。次长者救子不得譬从上佛初成道一乘化众生不得文生。第三长者三车引子得譬从上三乘化众生得文生。第四等赐大车譬从方便品为说一乘文生。释迦一期出五浊世始法身地见机终竟灵山之会说一乘法。唯有四章不得多少。是故今明始从见火终竟等赐大车亦唯四譬不得增减。是故四譬从四法生

问。若尔但有四譬。何故有初总譬及后不虚譬也

答。虽有初总譬还不离上四义。但欲总明能化之德所化过患故有总譬。又示解义之方前总后别。又将明化物先叹佛有化物之德。故说总譬耳。所以有第六不虚譬者。此譬亦无别体。还是料简上前三后一之义耳。为此因缘故开六譬也。就总譬中更开六譬。一化主譬。二化处譬。三教门譬。四所化人譬。五化意譬。六根性譬。十方三世诸佛出世施化皆有此六。释迦出五浊世亦明此六也。就此六中化主教门是能化事。余之四种是所化事

问。第一何故前明化主耶

答。虽有六义然化主为正。故合譬中正合化主。所以前明化主者。以将欲化物故前叹如来有化物之德。又令物欣此德如法受化也。就明化主凡有五句。一明处大。二辨位德重。三序年高。四叹巨富。五美多有眷属。凡为大人必具此五。此五皆是叹长者之德也。若国邑聚落者明处大也。若者杂心云若其事也。又若者．如也。如其事而说之。国邑聚落者正譬化处也。但化处有四。一国二邑三聚四落。所王之处有封疆墟域谓国也。邑者古人呼县为邑。内村伍为聚。外墟畔为落。今将释论解发趣品明一佛王化凡有四处。初谓一佛世界。二明一世界海。三明世界种。四一世界所度之分。一佛世界者。百亿日月等名一大千。如是十方各一恒沙大千名一佛世界也。一世界海者。如是一佛世界数如十方恒沙名一世界海。如是佛世界海数如十方恒沙名一世界种也。如是世界种十方无量名一世界所度之分。总此四种合是一佛王化之域国是其大处。喻一世界分域也。邑为其次拟世界种也。落是墟畔之远拟世界海也。聚是村伍之近拟一世界也。明长者在四处者穷长者之美也。一家之大亦称长者。于家之外未必皆大。若于四处为大可谓美之极。明佛亦然义可知也

问。凡有名闻要从近至远。今何故从远至近耶

答。有二义。一者欲验长者之德使名实不虚。明此长者非但远国揄扬乃至近邑称叹。故从远至近验长者实德。如来亦尔。寄此四处定佛名德。二者欲显佛虽王化四处今欲明一处之化。故从远以至近。以此一方根缘感佛故也。有大长者下第二次明位德重。世之长者凡有三种。一有德长者。二年高长者。三巨富长者。有德长者．略明三义。一者有智二者有德三者清洁无瑕。以具此三义故居物之宗称为长者。如来亦尔。一则照理周穷谓之波若。如长者有智。二众德斯备所谓法身。如长者有德。三万累永尽所谓解脱。如长者无瑕。三德既圆居在物表称为世尊也。其年衰迈者第三句辨年高。即是耆年长者。前明其位德重。此譬于年高。以德重年高为物所敬。佛亦如是。一备众德二寿命无穷。以具此二义为物所尊也。此据法身为譬。以法身寿不可尽。二者借老人以譬应身。老人生途以穷余命无几。譬如来此身最后无复余生。故释论云。我生胎分尽。是最末后身。我以得解脱。当复度众生。三者取废化来久作譬。昔为菩萨时教化诸子。诸子违教经于劫数。菩萨废化已久故名为老。故信解品云自念老朽无有子息。四者借最后应付子财为譬故称老年。五者．老人在世既久。多所闻见讽诵今古。以譬如来具一切智者。六者其年衰迈。衰迈之人不久住世。譬如来非是安住三界之人。七者行行来久。譬老人之年积也。财富无量者第四叹巨富。即是大富长者。世之财宝能离苦得乐。法宝亦能离生死苦得大涅槃乐。福慧具足为财富。出用不穷名无量。又众德圆满为财富。异于因住称无量。多有田宅。智断具足能生物善为田。慈悲覆阴称之为宅。又养命曰田。安身为宅。法宝亦然。能养物慧命若田。安物法身如宅。能安养者无穷故云多也。及诸僮仆下第五明长者眷属。旧云喻所化众生也。学功微浅为僮。德行未高如仆。今谓下明五百人是通论所化。三十子是别论所化。则所化事尽。今不复喻之。但取譬神通以为僮仆。如后老弊使人也。世富长者凡有三种。一内多珍宝。二外多田宅。三多诸僮仆。备此三种乃称大富。佛亦如是。一内备自德如多珍宝。二外能生物之善及慈悲覆阴譬多田宅。三有神通运用譬僮仆屈曲顺从。其家广大者第二明化处。上国邑聚落举处以叹人。故长者为四处所崇仰。今举人以明处。辨长者于一宅内有训导之能。又上明四处通辨佛在净秽诸土化物。今明其家广大别序三界过患秽土之化也。三界弥旷名为广大。六道所栖称之为家。唯有一门者第三序教门也。九十六种所说之教并不能出离生死故名异门。唯依佛教方能出苦称一门也。此对外道为异故铭佛教为一。此通喻大小乘教。总称一佛教也。多诸人众者第四明所化人也。三界含识品类滋繁故云多诸人众。一百譬天。二百譬人。乃至五百通取三途。修罗或开或合故称乃至

问。成论及智度论明有六道。萨婆多部唯明五道。云何会之耶

答。有论师云。取其生报则修罗属鬼神故明五道。取其受报即与天相似故分六道也

问。明五百便足。何故复明一百二百耶

答。人天堪受化故所以别说也。止住其中者五道众生乐居不舍故云止住。亦则是四十居止。八大地狱与饿鬼畜生为十。四天下六欲天复为十。欲界合二十。色界有十六处。无色四处合四十也。堂阁朽故下第五明化意。就文为二。初序宅相二明火起。序宅相为二。初总明三界无常。次别明三界无常。旧云一重屋曰堂。二重以上称阁。欲界在下喻堂。色无色界居上喻阁。今明公集之舍为堂。舍而重累称阁。三界果报是众生共有。而同聚其中譬之如堂。三界果报高下升沉如舍重累喻之如阁。无常衰谢义言朽故。墙壁颓落者第二别明三界无常也。前明色法无常。外都援为墙。内别障为壁。外四大成三界形域如墙。成内身四大如壁。色法衰谢义同颓落也。柱根腐败者。舍之所以立为柱之所驻。果法所以存以命根之所持。既以阴身为舍。宜用命根为柱。命根势稍穷报身将坏。其由柱根腐败堂舍将倒。梁栋倾危者。身之维持寄在心识。屋之纲纪要由梁栋。柱根摧朽故梁栋倾危。命根欲穷则心识将落

问。何故但明三法无常耶

答。有为之法凡有三聚。一色二心三非色非心。墙壁颓落谓色法无常。梁栋倾危谓心法无常。柱根腐败谓非色非心法无常。色法既粗无常相显故在初说之。心法微细无常相微故在后说。非色非心命根能连持色心故在中间说也。周匝俱时欻然火起下第二明火起烧宅。所言火者谓众苦也

问。常有三界则常有众苦。亦应常有火宅常有火燃。何故前明火宅后辨火灾耶。

答。此譬可具通别二义。一者通序三界并皆转变具受众灾。若尔既常有火宅亦常有火灾。此二实是一时。但说成前后耳。前明舍宅序其无常。后辨火灾明具众苦。苦与无常是物所患故偏说之。二者别譬此会三根众生。昔日禀化苦有暂息之义。佛既去世还起烦恼。以烦恼故受诸苦果。故前明火宅后辨火起。又已受阴身之苦譬如舍宅。新更起惑招苦名为火起。后之一义通二人也

问。何以知此譬具通别二义耶

答。列五百人复明三十子。五百人通譬五道众生。三十子别明昔曾禀化也。所以具明通别二种众生者。以具化二人故也。一者别化中下根人令识三一权实。二者通为一切众生令知三界过患也。又此经令一切众生离凡夫地复离二乘地。以说三界过患故令物不贪三界。谓离凡夫地。后明诸子出门求车不得及等赐大车。令知二乘是空卷一乘是真实。令离二乘地。以是因缘故具化二人也。周匝俱时者。众苦譬火。无处不有义同周匝。三界俱苦说为一时。出于横造故云欻然也。焚烧舍宅者。烦恼为火烧心善根。众苦为火焚身乐受也。长者诸子若十二十或至三十下第六辨三乘根性也

问。五百人已摄三乘根性。今何故重辨乎

答。前明五百通辨五道众生。明有人天乘根性未必具三乘根性。今别明三十子。虽是五道所摄但别有三乘根性故别说之。昔曾禀教生善。善从佛生詺善为子。以善目人。人受子名也。旧云十譬声闻。二十譬缘觉。三十譬菩萨。声闻德少故数少。菩萨德多故数多。又云十子易得如声闻根性易得。乃至三十子难得譬菩萨根性难得。今并不同此二义。以十譬菩萨。二十譬缘觉。三十譬声闻。求大乘者少如一十。求缘觉稍多如二十。求声闻者转多如三十。此释出华严经贤首品。又即如此经三根人。上根得解者少如身子一人。中根稍多如四大声闻。下根转多乃至五百也

问。何故无有一乘根性耶

答。三乘中大乘即是一乘根性。又此中正明三乘机发。一乘机发在后故今不说也

问。子有定数。何故言或至三十耶

答。凡有三义。一者或开声闻缘觉为二乘。或合为一小乘。以开合不定所以言或。例如上一百二百乃至五百。修罗或开或合故有乃至之。言二者就昔三乘根性不定。如大品。六十菩萨退为罗汉。迦叶本是缘觉根性值佛故成声闻。声闻之人若不值佛即成缘觉。以不定故所以言或。三者昔虽有三乘根性终并成菩萨。故复云或也。长者见是大火下第二明见火譬。此譬所以来者。上叹佛德无不圆累无不尽。今见子累无不圆德无不尽故起大悲心也

问。见何等子起大悲耶

答。具见通别二子起大悲心。一者通见五道众生无乐有苦。二者别见三十子昔曾禀化应得离苦而背化起惑更受煮烧。故起悲也。前方便品法说有三。一能见二所见三起悲。今转势说法亦开为三。第一明长者见火即大惊怖。二自序己之已出。第三伤子之未离。初有三句。一能见二所见三惊怖也。是长者见是者。将欲救难故前明见。即譬如来居法身地以佛眼见众生无乐有苦也。是大火下第二明所见。普烧三界故称大火也。四面起者即是生老病死。涅槃经取譬四山。今譬之四面。生为东面。老为南面。病为西面。死为北面。即大惊怖者第三明惊怖。别据三十子而言者。昔经受化不应致火。故惊。迷着苦境恐慧命将尽成一阐提。所以怖也。通就六道众生释者。一往怛愕曰惊。定知是可畏之事称怖。譬慈心一往与乐称惊。次起悲心拔苦为怖也。而作是念下第二自序长者己之已出。所以自序之己出者。意在子之未免也。所烧之门者明所出处也。此詺三界限域为门。故后文云今此三车皆在门外。即其证也

问。此与前唯有一门何异

答。前取佛教通人出于三界悟入理故名为门。如后文云以佛教门出三界苦。今将所烧之言简异前门。故知詺三界以之为门。如世人总举一宅名之为门或称一家或言一户。今亦然也。以八苦为能烧。三界为所烧。故云所烧之门也。安稳得出者。昔日行道营出之时无有倾坠。故云安稳得出。是以经云。吾独反其本原自免而特出。又智度论云。三乘出法各异。如三人在狱自有穿穴踰墙壁怖畏而出非安稳出。谓二乘出也。菩萨破三界狱杀诸狱率与众生共出名安稳出也。而诸子等下第三伤子之未免。乐著者贪着五欲乐也。嬉戏者贪着五欲无所克获也。不觉不知者。前乐着即是贪爱。不觉不知所谓无明故。痴爱是生死本也。不觉舍之垂崩谓不觉无常也。不觉火起谓不觉众苦也。一往初不悟称不觉。始终不悟称不知。背失宿善为不惊。将殒慧命为不怖。又初不畏无常苦为不惊。始终不畏称不怖也。火来逼身苦痛切己者。上为未受苦众生作譬。今为受苦众生设譬。老病死苦烧身为逼身。贪嗔痴烧心为切己。又遭外苦为逼身。受内苦为切己。外苦者谓寒热打骂。内苦者谓四大不调百一病恼也。心不厌患无求出意者。总序二种众生无有厌生死苦求欲出三界也。是长者作是思惟下第三救子不得譬。譬上一乘化众生不得也。初总譬叹佛有乐无苦。次见火譬序众生有苦无乐。今第三欲拔众生之苦同佛无苦与众生之乐同佛有乐。但圣人虽能授物不能受故有此譬来也。又为释疑故来。一乘既是真实。佛初出世何不即说。是故释云。佛初成道即欲为说。但圣虽能授物不堪受。故咎在众生过非佛也。据身而言。上见火譬在法身地见众生有苦无乐。今以本垂迹欲拔苦与乐也。据悲心悲事明者。上见火譬明大悲内充。今明旋还赴救即悲事也。凡夫二乘虽有悲心而无悲事故名少悲。今有悲心兼有悲事故名大悲也。以小悲故名假相悲。以大悲故名真实悲。上方便品有三。初明佛慧甚深众生根钝故不说法。二梵王劝请。三明假使欲说则有损无益故违请息化。今转势说法开为二章。第一作大乘劝门化众生不得譬。第二作大乘诫门化众生不得譬。劝门者谓叹法身功德也。诫门者谓说生死过患也。又劝门即是大慈与乐也。诫门谓大悲拔苦也。所以唯明二门者。佛则有乐无苦。众生则无乐有苦。此既总摄圣凡故但明斯二也。就劝门内有二思惟开为两别。第一思惟明佛能授大乘。第二思惟明物不能受。此与方便品二思惟异者。方便品初思惟不可以妙慧授与钝根。第二思惟假使强授有损无益。以转势不同故法譬为异。经师不应谓后譬必同前法也。是长者作是思惟者总标思惟也。我身手有力者出所思惟事也。极智之体名为法身。即智之用称之为手。能济惑反本名为有力

问。何故身手有力

答。欲明佛初成道则能说一乘也。当以衣裓若以机案从舍出之者。长者思惟身手有力故能用衣裓及以机案从舍出子。如其无力则不能尔也。譬如来内有法身智手外能现通说法从三界舍引出众生。此即譬三轮也。作是思惟身手有力谓他心轮也。当以衣裓谓神通轮也。若以机案谓说法轮也。故下合喻云当以神力及智慧力。即其事也

问。何故前用神通后明说法

答三世诸佛化物之宜要前现通然后说法。是故此经序品之内明三轮前后。初入无量义定即他心轮。如身手有力雨华动地放光现土即神通轮谓衣裓也。从三昧起乃至一经竟即说法轮谓机案也。明乘权乘实是所乘之法。譬如机也。辨身权身实是能乘之人。喻之案也。又二段经文各有衣裓机案。初章经现通为衣裓。一乘因如机。一乘果如案。后章经亦有衣裓机案。多宝涌出二品是现通谓衣裓。说长寿之因如机。说长寿之果如案也。又以二事配经两段者。初明乘权乘实譬如机案。即说法轮。后辨身权身实短长适化。谓神通轮。譬如衣裓。衣裓者衣衿也。救子之苦出父衿裓故前以衣衿为喻也。机案者父足所履为机。父身之所凭为案也。复更思惟下。第二前思惟明圣能授。此思惟辨物不能受。又开三别。一思惟理妙。二思惟钝根。三思惟不可以妙理授与钝根。初思惟理妙者。外譬长者思惟门有三事一明唯有一门。二者明门复穷狭。三思惟门之极少。内合唯有一门者唯一至理也。至理无二故称为一。极妙虚通目之为门。不容凡夫爱见故称为狭。不受二乘断常目之为小。又不容凡夫二乘断常故称为狭。亦不受有所得大乘菩萨目为小也。此约人以释狭小义也。又至理不容言语则言语道断称之为狭。不容心行则心行处灭目之为小。又横绝百非故称为狭。坚超四句目之为小也。诸子幼稚未有所识恋着戏处下第二思惟子有三义。一者幼稚。二未有所识。三恋着戏处。对上门亦有三义也。善根微弱为幼稚。未能识法身功德生死过患名未有所识。缠绵五欲名恋着戏处。合此三句为二。初句明有善。后二句明有恶。善有二义。初发心为幼。观解微弱称稚也。恶有二义者。未有所识名之为痴。恋着戏处名之为爱。谓具痴爱也。或当堕落为火所烧者第三思惟明不得化也。门具三义子亦具三义。若裹之以衣裓擎之以机案。非唯不得子出。翻更令子堕落为火所烧。内合亦尔。至理微妙众生钝根。若以妙理授于钝根则不能悟解。非但不出生死。反生诽谤也

问。佛知钝根定谤大法。何故称或当堕落耶

答。据初成道时大机未熟。是故起谤。至灵山之会改于小执则能信受。以根性不定故称或也

问。今文辨唯有一门而复狭小。与前文唯有一门有何异耶

答。有人言。初总以大小教为一门。后但以大乘教为一门。有人言。今文辨一门亦具大小教。唯有一门与上义同。而复狭小别明大乘门也。如直是一门已难得出。况复狭小耶。直是佛法已难信解。况复大乘岂易了耶。今谓此二释并成难解。衣裓机案既已譬教。云何复以一门喻教。复何得以衣裓机案之教从佛教门而出子耶。今明如前释之。此中用理为门。以衣裓机案为教也。门既狭小不可以衣裓机案从门出子。理既微妙不可现通说法令物悟理也

问。长者身手有力。何故不提子出耶

答。身手譬内智照机。衣裓机案譬现通说法外用。但得以外用化物。不得用内智化物也。我当为说怖畏之事下第二明诫门说大乘化物不得也。就譬而言。以衣裓机案出子不得。今直说怖畏之事令子速出。前说法身功德既不信受。今说生死过患令出三界也

问。诫劝二门何故前劝后诫也

答。劝门为本。诫门为末。诸佛出世本为开佛知见。但众生不解故后方辨生死过患也。又佛慧难解生死过患易知。故前说所难。后陈所易。此句总标欲说怖畏之事也。此舍已烧宜时疾出者正明怖畏之事也。以有阴身。则以为老病死火烧身。三毒火烧心也。故言此舍以为大火所烧也。无令为火之所烧害者。上虽明二火已烧。但烧而未害。今恐为二火所害故诫之。若恣此二火则烧灭善根害法身断慧命也。如所思惟具告诸子者。前句辨内心思惟。此明假设为说怖畏也。父虽怜愍善言诱喻者。此明无机不受诫门说也。怜其无乐愍其有苦。诱之以法譬之以事。怜愍据内心。善言诱喻约外言说法也。而诸子等乐着嬉戏者。明诸子乐着生死五欲乐也。不肯信受者。不信生死是无常苦也瑞应经云。设当为说万物无常天下皆苦。正言似反。谁肯信者。劳苦我尔。不如早取泥洹也。不惊不畏者。初不畏生死为不惊。终不怖故为不畏也。亦复不知何者是火者。不识老病死为烧身火三毒为烧心火也。何者是舍云何为失者。不知三界为通舍五阴为别舍。不知由妄想之失故起身心二火即妄想是二火之根。但东西走戏者。旧云南北为纵。东西是横。明诸子横理用心也。今谓夫立宅则东西无门。但开门向南。以东西无门则背理走戏故无出义。若背北向南则背惑向理便有出义。故不云南北走戏也。又若南北走者。父在门外子便有从父之理。父便有化子之义。非谓无机也。游心爱见故称为走。无所克获名为戏也。视父而已者。初虽不信但会有向理之分故云视父。未能行修故称而已。尔时长者下第四三车救子得譬。所以有此譬来者。既一乘化之不从。无容舍而不救。故于一佛乘分别说三。则从实起权亦是隐实显权。又上即是衣裓机案以有物出子不得。今虚指门外以无物出子得也。然如来所得法无虚无实。以无虚无实故能说虚实并实。不得云无实无虚故虚实并虚也。有物者道理唯有一乘也。无物者道理无二乘也。又衣裓机案以父物救子不得。谓一乘是如来所行。涅槃经云。复有一行。是如来行。所谓大乘大涅槃。今明三车是子物。救子得。三车是众生所乘故名子物。释论及摄大乘论云。佛乘是自乘。二乘是他乘。即此经云佛自住大乘。故知二乘是子所住也。若就身而言者。见火譬谓法身也。救子不得譬谓舍那报身也。三车引子譬即释迦化身也。此譬上三乘化众生得也。上文有三。一念欲起三乘之化。二说三乘教。三明得益。今转势说法开文有四。一知子宿好譬。二为说三车譬。三诸子信受出宅譬。四见子免难欢喜譬。初文又有三。一明不出为损。二欲设出方。三知子宿好。此舍已为大火所烧者。三界之舍正为身心二火所烧。我及诸子若不时出必为所焚者。上直明烧。今明为火所害。即不出为损也

问。子不出。可为火害。父前已出。云何被烧耶

答。有人言。如来若不以三乘化之令出宅者。众生善根不生无绍佛种。如子被烧。如来化工于是亦绝。若父被火害。有人言。众生病故菩萨亦病。众生烧故如来亦烧。今谓此经始末正叹父已免烧。子未离火。与净名经来意为异。故此二释未可全依。今文意在明子而言父者。此据因时为论耳。我昔亦在宅中。若不时出则为火害。以时出故免火宅也。子亦应尔。时出则免。不时出则不免。时者。如来本在三界。但以机发应出之日应时即出故得免火。众生机发之时而不出还复受苦也。我今当设方便下第二欲设出方。即是知病识药。无三说三故名方便也。父知诸子先心各有所好下第三正知子宿好。先心者过去各有行愿也。所好者现在欲乐也。种种珍玩琦异之物情必乐著者。三乘于惑者为珍玩。望一乘为琦异。又三乘是出世之法。异于世法故名琦异也。而告之言下第二正为说三车譬。文有四句。一称叹三车。二示车处。三劝令速出。四保与不虚。此并譬趣鹿苑说三乘教也。汝等所可玩好希有难得者。三乘圣果并是出世间法。世间所无故称希有难得也。汝若不取后必忧悔者。圣虽为说恐物不能信行。故发后悔之言也。机发值佛而不修道取圣果者后必忧悔也。如此种种下第二示车处。种种者注经云。种种在三乘之前。即人天乘也。有人言。就一一车中复有三明六通十智八解。故言种种。羊车鹿车牛车者。菩萨化世。声闻从师。并居人间之类故。如牛羊。缘觉进不化世退不从师。喻之如鹿。以表山林之流。又释羊之为兽其性迟钝。譬于声闻。鹿性捷疾譬于缘觉。牛力强壮引重之远。譬于菩萨。又解羊形小譬小乘。鹿形处中譬中乘。牛形大譬菩萨乘也

问。为约三智明三车优劣。为约三断耶

答。有人言。具约智断优劣。声闻但断正使。缘觉断小习。菩萨结习俱倾。今谓中乘断习经论无文。但取智有优劣譬三车不同耳。今在门外者。门者宅也。立此三车同止生死外。所以然者。三果虽异惑尽义同。故同在门外。又三乘人所得法谓数灭无为及尽无生二智。注经云。六法为圣果体。谓无漏五阴及数灭无为。并在生死外也。然罗汉报身实在界内。以人从法。亦得名罗汉为出界外。以法从人。人在界内亦得云罗汉在三界内也。若身法各分则内外两属。初果所得无漏则非三界所系法例此可知也。可以游戏者明用车意也。疑者云。若是因乘可有运出三界用。今已出三界。何用乘为是。故释云可以游戏。游戏者适悦也。生死往来驰骋五道践涉艰辛。圣果望之故言游戏也。汝等于此下第三劝速出。令三乘人勤精进速断烦恼得出三界。实是出去而言出来者。以内望外为去。以外观内为来也。随汝所欲下第四明保与不虚。尔时诸子下第三诸子受化譬。即譬上便有阿罗汉法僧差别名。三乘人得益也。适其愿故者。既知机而说教。必称机故云适其愿也。心各勇锐者。前明教称机。今明机信教。既起信心即欲修行义言勇锐也。勇者募进也。锐者利也。互相推排者。前既有信心。今明殷勤精进也。竞共驰走者。上既明精进。此正明观四谛理也。观苦断集如竞共驰走。证灭修道譬诤出火宅。有人言。心各勇锐此明外凡夫位。即七方便中前三方便闻思慧位也。互相推排谓内凡夫位。即四善根即修慧位也。竞共驰走三果学人位也。诤出火宅无学位也。故凡有内外圣有学无学也。是时长者下第四父见子免难欢喜譬也。安稳得出者。见诸子修行之时无有退转得出三界分段生死。皆于四衢道中者。增一阿含云。四谛譬四衢。断四谛下惑尽通达四谛。如路之四达为衢。露地者。既断四谛下正使尽亦无盖缠故称露地也。而坐者。因中修行如驰走。得果究竟为安坐。又驰骋生死称行。今得圣果为坐也。无复障碍者。三障斯亡无复累之能碍故云无障碍也。又于四衢露地而坐。欲显三界外无三车可登故也。又向在三界舍。今已出舍名为露地。下偈中空地亦尔。其心泰然欢喜踊跃者。上明见子免难。今辨父心欢喜。以初见在火宅故忧。今见出火宅故喜。如众生病故菩萨病众生病[口*愈]菩萨病[口*愈]也

问。方便品云今我喜无畏。与此文明喜何异耶

答。方便品明说小不称佛意故忧见大机发称佛意故喜。此文明见在火宅故忧见出火宅得小果故喜也

法华义疏卷第五

永仁甲午蕤宾下旬印板讫功孝行作福沙弥道尊希受爪上人命[利-禾+垂]得髻中明珠岂谁不尊重恭敬哉而义疏刻錭盖檀越合力四恩法界平等施回矣

        都干缘沙门　　　素庆谨志法华义疏卷第六

        胡吉藏撰

    譬喻品之二

时诸子等各白父言下此第五等赐大车譬。就文为三。一索车二赐车三得车欢喜。索车者大乘机发也。赐车者为说一乘也。得车欢喜者闻一乘悟解也。义唯有此三不得多少。譬上方便品说一乘也。索车是一经大宗。今略释之。有人言。昔得罗汉后出游观心以天眼照见未来犹有生死。则烦恼未尽未有尽智。犹有生死无无生智。佛何故说罗汉有尽无生智耶。以就佛索觅尽无生智故言索车。车者即是尽无生智也。今谓不然。昔既见有生死未尽。即知三乘非是究竟。亦应即知一乘是究竟。云何复有索也。又三藏教内明罗汉。云何已得知三界外事也。若小乘已明三界外事。与大乘复有何异耶。今所明者索车之譬但就今辨。非昔教存也。但索车譬凡有二门。一者无索假设索譬。二约疑情明有索也。言无索而假设索譬者凡有二义。一者欲显三乘是方便。二欲显一乘是真实。显三乘是方便明道理无三。显一乘是真实亦道理有一。盖是一经大宗故假设索车譬也。欲显三乘是方便者。前明长者辨无有三乘虚指门外无三说三。此就父明三乘是方便也。门外若实有三车。子出门外便见有三则不索三也。以其索三故知门外无有三车。验父前言理实无三方便说三。此寄子索三以显三是方便也

问。何故寄父子并显三乘是方便耶

答。此教所兴正为破执三乘是实。故宜明三乘是方便。即是开方便门。然后始得显真实义。故寄父子明三乘是方便也。所言寄索车譬显一乘是真实者。下明等赐即是有一。将明一有宜辨三无。三无不彰则一有不显。故寄索三以显无三。如其有三则不索三。以其索三故知无三。在三既无一有便显。故方得赐一也。盖是经之正意。不须异释也。所言就疑情明有索者。然迷悟二门俱无有索。昔既执三则见有车证得小果便不索车。今若领悟知有一无三亦不索三。而今言有索者。约彼疑情言有索耳。佛昔说有三。今教明无三。惑者将今无三征觅昔有三故言索耳

问。为三人索三。为二人索三

答。据出门而索三者。但是罗汉辟支二人索三耳。小乘明菩萨从初发心乃至补处未断烦恼犹是凡夫。故在门内不得言出门外索车。大乘菩萨出三界外自知未至佛果亦不索车。又三车譬三乘果。罗汉辟支至二果处觅果不得故索果也。无有菩萨至佛果处觅佛果不得。故无菩萨索佛果车也

问。若尔但二人索但应索二。何得索三耶

答。一人二人俱得索三无所疑也

问。若尔言二人索者。何得文云诸子索耶

答。盖是总相称为诸子。非是门外三人名为诸子。故后合譬释云。若见无量亿千众生出三界苦得涅槃乐。此但明二乘人出三界得涅槃乐。不说菩萨。则知不必皆是三子索也

问。颇有菩萨亦有索车不

答。若据门外无菩萨索。若通论门内约疑情者。昔说有三今说无三。菩萨以无征有亦有索也

问。既其索三。云何赐一

答。既以疑情故索。疑是解津。若有解津则大机已动扣佛说一。即是索一故后赐一也。尔时长者各赐诸子此第二明赐车也。索所不与者。无三可赴索也。与所不索者。有一以赐机也。就文为二。初标等赐大车二章门。次释二章门。标二章门者。一标等赐章门。二标大车章门。所与之人非一故云各赐也。等一者。昔三机偏发以大车赐菩萨不赐二乘。故若偏赐。今三病既消大机并发。等与大车。对昔与偏故今明等赐。故下文云。不令有人独得灭度皆以如来灭度而灭度之。即其证也。不令有人独得灭度者。不令菩萨独得大涅槃也。皆以如来灭度而灭度者。亦令二乘证大涅槃也。大车下第二标大车章门。即是出所赐车也。其车高广下第二释二章门也。前释大车章门。次释等赐章门。释大车章门有三。初释大车。次释白牛。后释傧从。初又二。前释大次释车体。其车高广者释大义也。出二种生死表为高。备万德称为广。又出二死为高即是大涅槃果果义。备万德菩提果义。下还将二果合之。又出二生死则累无不尽。备于众德即德无不圆。累无不尽不可为有。德无不圆不可为无。非有非无故名中道。中道之法称为一乘也。故云广高。此对二众但出分段之近故名为下不具万德目之为狭也。若就因车释者。略举愿行。愿则上求佛道为高。下度众生为广。行趣无上菩提为高。遍学诸道为广也。众宝庄校者第二释车体。前总释次别释。虽标高广恐非众宝所成。是故次明众宝庄校。即是万德为果车体。若据因车。万行相资成其运用也。周匝栏楯下第二次别释车。前总标后别释。为解义故。就别释车又开为二。前释车外庄严。次释车内庄严。释车外庄严叹大乘化他德。释车内庄严明于内德。果德无穷不出斯二。叹外德中略举五门。一叹总持。二叹四辨。三叹四等。四叹四弘。五叹四摄。初一是能持。后四为所持。栏楯以譬总持。持内物不失为栏。遮外物不侵如楯。总持亦然。持众德令不失。遮众恶令不生。普持众德遍遮众过义言周匝。此既是众德之本。又是小乘所无故在初说之。同上叹于菩萨也。四面悬铃者次叹四辨。总持为众德之本。是故在初。四辨为化物之要故次说之。车之有铃动而声发。大乘化运四辨畅音。又释但取乐说辨。如铃之声用化四生故言四面。故前叹菩萨德中初明得陀罗尼次明得乐说辨才。今之二句还同上也。张设轩盖者次叹四等。四辨外被要由四等内充。故次叹也。轩之为用必高出而下覆。慈悲亦然。高出二乘下覆六道。虽曰覆车实覆车中之人也。亦以珍奇杂宝而严饰之者。明向慈悲为众德所成故体是真实。不同外道二乘假想慈悲也。宝绳绞络者次叹四弘。轩不施络则飘。鼓飞扬。是以安绳而遐持令不动。由此四弘御于四等尽未来际不舍四生。又复防持令无爱见之过也。垂诸华璎者次叹四摄。虽有四弘誓愿复须四摄之行。华璎垂下悦于来众。四摄府顺仰归若林也。重敷綩綖者第二明车内庄严。譬内德也。綩綖柔软为车之缛。可以适体譬禅定柔软可以安身。以定有八重故言重敷。又百千三昧故云重也。綩綖者外国精绢也名槃缩绣。富贵者重而敷之。以譬三昧非一。安置丹枕。有人言。车之前后两横木名为车枕。依此两枕竖四楗施厢壁也。信为万善之基。戒为众德之本。大乘德行犹藉二法犹车两枕也。今谓此非车枕。何以知之。既敷缛竟后方安枕。此乃是欲卧之枕非车枕也。又下偈明茵缛之上敷以白叠。则以叠代枕故知是承首之枕也

问。何故车内安枕

答。此既明内德。则有息化之义如卧之像。故涅槃云。入大涅槃深禅定窟。众不见故名入涅槃。今于缛上更安枕。譬于禅定内入般涅槃也。又佛有时间乃至八万劫入深三昧。亦是息化故是欲卧之像

问。何故名为丹枕耶

答。丹是赤色中之盛。由深定故多所发生。其功显灼如丹色也。又释古人合神丹为枕。令得长灵之寿。譬入涅槃则常乐我净也。驾以白牛者第二释御车之牛。竺道生法师用净名经意释此文云。六通无垢名为白牛。故云象马五通驰。今明万德与平等大慧其义不同。万德但有运而无导。故但车非牛。平等大慧亦运亦导。故具车牛两义。五度对波若其义亦然。大白牛车者谓平等大慧也。肤色充洁者。种智圆满为肤充。清净无染为色洁。形体姝好者。无有相貌为形体。寂灭微妙为姝好。有大筋力者。上明慧体今明慧用也。照用之深能断大惑普载之重适道之远而无疲极。具此四义为大筋力。行步平正者。游乎中道行无偏邪也。其疾如风者。不疾而速感无不应也。又一念遍知一切法亦是其疾如风用大乘之化入于五道为驾。与之如游也。又多仆从而侍卫之者第三明傧从也。既以佛果万德为车。则以佛为登车人。从教修行者崇侍如林。故下偈云。佛所悦可一切众生所应称赞供养礼拜。即傧从之义也。若据因车。此文既明无学之位。已得出宅。此始登车。自学人已下皆为傧从。所以者何下第二释等赐章门。就文为二。第一前明有大车之所以。次明等赐。今前释有车之所以将明赐车故前释有车之所以。而作是念下明等赐也。初明不应不等。今此幼童下明应等赐也。初明同是子故应等赐。爱无偏傥下平等爱故宜等赐也。我有如是七宝大车下。前二句明心等。今此章辨财多也。其数无量者。车则不二乘者不一。以乘者不一故言无量也。所以者何下举多况少也。周给一国者。国谓众生也。假使十方众生一时机发并与佛乘而佛乘犹不可匮。匮者竭尽也。故大品云。十方三世佛皆学波若。而波若不可尽。波若则一乘也。何况诸子者。明今会堪闻而悟者。盖不足言故也。是时诸子下第三得车欢喜譬

问。大车既譬果乘。诸子是因。云何得乘果车

答。解从佛得。随分皆会。故云各乘耳。又因必得果。故云得车也。所期是小而遂获大。赐踰意表名非本所望也。舍利弗下第六明不虚譬。所以有此譬来者。从上许赐文生。众伏疑云。始则许三终遂不与。似若虚言。初不许一后遂赐一。复如妄说。今欲融会许赐断彼疑心故有此章来也。就文为三。初反质二奉答三称叹。反质者。谓佛虚妄本出声闻。今令其自称不虚则不虚事实。故释论云。佛反质身子令身子口自称不及菩萨则审大小优劣之异。今亦然也。又身子既已领悟则知三一迹返而旨符。故寄之融会息众疑也。舍利弗言不也者此第二奉詶。不也者不虚妄也

问。何故许而不与与而不许

答。所以许者。称彼根缘得出火宅故须许也。理毕竟无三又非佛本意。云何可与。故终不与也。与而不许者。若遂许其大。不称根情无由出宅。故始不许也。终遂与者。大机既动称佛本心。道理有一。是故与也。就文有二。初明昔无三说三非虚妄。第二就今与一明无虚妄。佛但略反质今不虚妄。而身子广答具明今昔不虚妄。又举昔况今。昔无三说三尚不虚妄。况今有一与一岂虚妄也。二文各有一释一况。初明一释者。长者但令诸子出于火难得全法身慧命。都不与车亦非虚妄。所以然者。既得法身慧命即是可保重义。故非虚也

问。此据何义明不虚耶

答。约得二种实益故不虚。一者实出三界。二者实全身命。故不虚也

问。何故复言若全身命便为已得玩好之具

答。上虽言得二种实益是故不虚。而不得车。应是虚妄。所以释云。若全身命即已得玩好故亦不虚也。何况方便于彼火宅而拔济者第二况也。上明直令诸子得出火难全其躯命尚已非虚。况方便说有三车令得免难而有虚耶。前据实益故已是不虚。况长者心实岂是虚耶。世尊若是长者下第二明今不虚妄也。亦有二阶。初释次况。初释中为三。一标不虚。二何以故下释不虚。三以是因缘下结不虚。大意明长者言虽许三令得出宅意不与三遂长者本心是实故无虚也。何况长者下第二举况也。前明本意不欲与小。假令都不与最小已非虚妄。何况本意欲与于大今遂与之岂虚妄也。佛告舍利弗下第三称叹也。一善哉叹解昔三不虚。一善哉叹其今一不虚也。如来亦复如是下第二合譬。合上六譬即成六章。今先总序合譬之大意略有四义。一者譬中显者即不合之。二者譬中不具足者合更足之。三者譬中一途次第合譬即复示一途。谓转势说法。四者依譬文而正合之。合此中六譬意者。合第一总譬明佛有极乐无极苦。合第二见火譬叙众生有极苦无极乐。合第三救子不得譬明初成道时即欲拔众生极苦与其极乐但未堪故息化。合第四救子得譬且拔其重苦与其小乐。合第五等赐大车譬拔其轻苦与其大乐。合第六不虚譬明前许小乐后与大乐义不相违。上总譬有六义。今正合化主。兼合余五以化主为本。然后起化故须正合之。一切世间者合上国邑聚落也。世间有二种。今正取众生世间也。之父者合上长者也。于诸怖畏下合上财富无量也。就文为二。一叹所离二叹所得。所离．即是空义。所得谓不空义。以空义无一切累故法身不有。有一切德故法身不无。不有不无谓中道也。又无一切累谓解脱也。有一切德即法身波若也。又无一切累谓果果也。具一切德即果义也又良由无患故能救患。将明救患故前序无患。良由有德故能济无德。将明济于无德故前叹有德也。就离过中前明离果患。即二种生死果也。无明闇蔽下离因患也。则二生死因。但无明为本故偏说之。永尽无余者双结无因果患也。而悉成就下第二叹所得也。就文亦二。初叹自德次叹化他德。初有四双。一者无量知见知一切法为知。知之分明譬如眼见。则知见一双也。力为其内无畏为外。内外一双也。有大神力谓神通轮也。及智慧力谓说法轮也。即现通说法一双也。具足方便智慧波罗蜜者第四明权实二智皆究竟也。大慈大悲下第二叹化他德。就文为二。初叹化他之本。次叹化他之迹。大慈大悲者普欲拔苦遍欲与乐。即广大心也。常无懈惓即常心也。恒求善事者谓第一心也。欲以第一法与众生。又慈悲即拔苦与乐。恒求善事灭恶生善也。而生三界下第二叹化他迹。本中有二本。谓大慈大悲。迹中亦有二迹。初明大悲拔苦迹。教化令得下大慈与乐迹。此中既明应身生三界。则知法身无有生灭。即显生无生二身也。不应谓此经未明常住也

问。云何合上财富无量等耶

答。无量知见等四双合之也。总叹得离则是智断。合上田业也。大慈大悲合上宅也。有大神力合僮仆义也。无因果两患则合其年衰迈。最后身义也。次傍合余五义者。而生三界朽故火宅合化处也。为度众生合五百人三十子也。生老病死合上化意也。教化下合教门也。见诸众生下合上第二见火譬也。上有三。初见火惊怖。二自序已出。三伤子未离。今但合见火及伤子未离二章义耳。所以但合此二义者。合上总譬叹佛有乐无苦。今合见火譬序众生有苦无乐。欲以能化所化有无相对故也。合二即为二意。初明见众生受苦合上见火。又四。第一见众生现受众苦。第二见众生生受众苦。第三见后受众苦。第四总结三世苦也。前三世苦中一一皆有三苦。现世三苦者。一生老病死忧悲苦恼。此通是内身之苦。故经文结为一苦

问。忧悲苦恼属何苦耶

答。并属死苦所摄。十地经云。死别离时愚人贪着心热名忧。发声啼哭为悲。五根相对为苦。意根相对为忧。苦转深为恼。稻芉经言。追戚往事言声哀戚名为忧。追思相续名为悲。苦事逼身名为苦。烦恼缠缚故名恼也。亦以五欲财利故受种种苦。第二明于外财五欲生苦也。又以贪着追求故现受众苦者第三苦也。此与上异者。上明贪着财轻。今辨追求事重。同是外物生苦。以贪有轻重为二也。后受地狱下第二明生报。则三途为三苦也。若生天上者第三辨后报三苦。谓贫穷困苦爱别离苦怨憎会苦此三通人天。故正法念经说天亦有贫穷

问。何以判此为三报

答。凡贪着五欲必生三途。从三途方得生人天耳。如是等下第四总结众苦也

问。此九种苦云何配八苦耶

答。初现苦中生老病死即四苦也。五欲财利二种苦属求不得苦。三途属怨憎会苦。贫穷困苦亦属求不得苦。次爱别离苦怨憎会苦如文说之。后总结诸苦是五盛阴苦也。众生没在其中欢喜游戏。第二合上伤子未离也。没在其中者。众苦如海。众生没在苦海内也。欢喜游戏谓于苦果上更起贪着。则是重造苦因也。合上而诸子等于火宅内乐着嬉戏。不觉不知者。前明贪爱今辨愚痴。即痴爱也。于此三界火宅东西驰走者。自上已来见众生受苦果造苦因。今见其轮回不息也。虽遭大苦不以为患者。上欢喜游戏明不觉苦众生不厌于苦。今明遭苦众生亦不厌苦。则合上火来逼身苦痛切已也。舍利弗佛见此已合第三救子不得譬。上有诫劝二门。大乘化众生不得。今文总合二门。开之为二。初总合诫劝二门。二总明无机息化。所以约慈悲合诫劝者。合总譬叹佛有乐无苦。合见火譬序众生有苦无乐。合今第三譬明佛拔众生苦与众生乐。是以三章文势相接也。舍利弗如来复作是念下第二合无机息化。文有二句。初明假设欲救。次明物不能受。初有三句。前句明欲与实乐。神力合上衣裓。智慧力合上机案也。舍于方便者第二句明隐权也。为诸众生下第三句欲说实也。众生不能以是得度下第二明物不能受。前明有身苦故不能解佛慧。而为三界火宅所烧。有心苦故不能解佛慧也。如彼长者下第四合三车救子得譬。上有四章。一知子宿好譬。二为说三车譬。三诸子信受譬。四明父见子免难欢喜。今具合之。上知子宿好有三。一明不出为损。二欲设出方便。三知子宿好。今并不合之。直序一化始终三种法轮。初明隐实谓隐根本法轮。次明起权谓枝末法轮。三明用权意即收末归本。合中但合初二句。下别有合等赐大车。故此中不合。直明隐实起权生下说三乘之义也。为说三乘下第二合正说三乘。就文为四。初诫令勿乐生死。次劝令速出三界。三明保与不虚。第四称叹三乘。此四即是次第相生。合上四譬者初合第二示车处。第二合第三劝速令出。第三合第四保与不虚。第四合第一称叹三车。所以法譬不同者。转势说法故也。汝等速出三界下第二劝速出。我今为汝保任下第三保与不虚也。以是方便诱进众生者。疑者云。既称保与不虚后遂不得。即成虚妄。是故释云。言保与者盖是方便诱进众生耳。复作是言下第四称叹三乘自在。无系者。凡夫为烦恼业苦三种所系令得脱之故云无系。无所依求者。心无所著名为无依。四智满足称无求也。若有众生内有智性下第三合上三乘信受出宅譬。上譬中总明三乘出宅。今别合之则成三段也。内有智性者则是内因也。从佛世尊闻法信受者明外缘也。信受者因缘具足故云闻法信受也。殷勤精进者。前明信受今辨修行也。欲速出三界自求涅槃者明修行意也。修行有二意。一者欲出三界谓知苦断集。二自求涅槃谓证灭修道也。是名声闻乘者总结小乘名也。如彼诸子者举譬帖之。此中正取涅槃以譬车。以声闻人正为求涅槃故修道也。有人言。从初闻法信受举外凡合也。殷勤精进明内凡也。欲速出三界明真圣也。是名声闻乘辨无学。若有众生下次合辟支佛乘。略不明内因。言求自然慧者。中乘人不正求涅槃。若求涅槃即与声闻无异。故今举求自然慧以合鹿车。欲异声闻故也。乐独善寂者俱舍论明缘觉有二种。一部行缘觉。谓有部党眷属。是小缘觉。二犀角喻缘觉。则是独觉名大缘觉。其人独静山间。即是今文乐独善寂也。深知诸法因缘。此出所知之境。谓异声闻但知四谛也。若有众生下次合大车譬也。求一切智谓空智也。佛智者一切种智谓有智也。一切智或时通于二乘。如波若三慧品说。二乘名一切智。若是一切种智但在于佛。故以佛名标一切种智也。自然智者总明二种智任运能知空有二境。即是无功用智也。无师智者前之三智并不从师得故云无师智。此释意出摄大乘论也。如来知见力无所畏者。上直明四智。今更辨四智。谓知见及力无所畏两双也。佛乘虽具众德以智为其宗。故广明智也。愍念安乐下。前举智慧门即是自德。今举功德门谓化他德。大悲称愍。大慈为念。双标二门也。安乐与利益异者。与乐果为安乐。与善因为利益。释大慈德也。度脱一切者释大悲德。度苦脱集。对上大慈亦有二意也。是名大乘者总结功德智慧自行化他为大乘体也。菩萨求此乘故名为摩诃萨者。上明法大今辨人大。以求大果法故名大人。从果法立名也。如彼长者下合上第四见子免难譬。但文转势与上不同。宜开二别。初双标二譬。次双合二譬。此二是小终大始。义相关故双牒合之。出三界成无学为小终也。一乘机发赐大乘为大始也。如来亦复如是下双合两譬。初合见子免难。如来尔时下第五合等赐大车。上有三章。一索车二赐车三得车欢喜。今不合初后但合等赐。以上见子免难则是见大机发故今明等赐义。譬中明索车不辨机发。今明机发不辨索车。互现文。上等赐大车有二。初开二章门。次释二章门。今合释等赐及大车二义。则是譬开而法说合。盖是转势不同。互现明义也。就文为二。初就大涅槃合等赐与大车。次就众德合等赐与大车。就初五句。第一句明多有法宝。是诸众生下第二句明皆是吾子。等与大乘下第三句正明等赐。不令有人独得灭度下第四句明不应不等。皆以如来灭度而灭度之下第五句正明等赐。皆以之言即是合等赐。如来灭度合彼大车。所以前举大涅槃合大车者。二乘正宗小灭故。今用大灭以代小灭故又上见灭小苦故与其小灭。今灭大苦名如来灭度．也。是诸众生下第二举众德以合大车。悉与之言合等赐也。诸佛禅定合大车也。前即是果果合大车。今用果义合于大车。果果谓累无不尽。果谓德无不圆。斯二既圆总收众义。故略举以合大车。又上是灭大苦。今是与大乐。皆是一相一种者。显彰为相。种别为种。今明外无三乘异相故云一相。内无三乘异体故云一种。如彼长者下合第六不虚譬。初牒前譬次合之。但不尽能受者。明佛非不能授但众生不尽能受。此据昔三乘众生。唯菩萨能受大。二乘人不能受大。是故于一佛乘分别说三也。以是因缘下此文有二义故来。一者近接不尽能受文生。以不能尽受一乘故于一佛乘分别说三。二者远詶上身子请。上请愿说其因缘。今说六譬始终因缘已竟。故结詶之也。就偈凡有百六十五行还颂前二段。第一颂上正云詶请说。第二以是因缘十方谛求颂上第二结詶身子请。初文亦二。前颂开譬次颂合譬。上譬说有六。今但颂五。不虚譬是身子领解。今不颂之。颂余五譬即为五段。初三十三行颂总譬。次三行颂见火譬。次五行颂救子不得譬。次十二行半颂救子得譬。次十二行颂等赐大车譬。上总譬有六义。今不颂一门及三十子。但颂化主化处五百人及化意。颂此四义转势说法。宜开文为六。一明宅主。二序宅相。三明宅中之人。四辨宅有毒害。五明宅有火灾。六总结宅过患。宅主者所谓佛也。宅相者三界无常无我不净也。宅中人者五道众生也。宅有毒害者三界烦恼能害法身慧命也。宅有火灾者三界诸苦烧众生也。总结过患者具上诸恶。则三界是大过患。令物厌之而求出也

问。何故不颂一门及三十子耶

答。三十子是求出之人。一门者出火宅之处。今此六义皆序三界过患。明众生沦没其中。故不颂之也。回一门及三十子置后见火譬及救子不得譬兼颂之所以然者。佛合六譬大开二章。合总譬明三界过患义。合后五譬并明出离义。以义类相从故开此二也。．譬如长者下此第一明宅主颂上化主也。长行明化主为正。故须广说。长行既广故偈即略之也。有一大宅第二序宅相。则颂上第二化处。所言有一大宅者。上明化处有四。谓国邑聚落。今且就一方三界为言故言一也。三界是众生所居。佛为化主。有属佛义故言有也。大宅者．即上其家广大义也。其宅久故广序宅相。长行既略偈则广之。三界是无常朽败之物。称为久故。一时无常故言顿蔽。蔽由败也。堂舍高危。上总序宅相今别明也。就文为三。第一作三界无常譬。第二作三界无我譬。第三作三界不净譬。下别有火起。以譬苦故不明苦譬。堂者如上释之。六道众生共聚三界之内故称为堂。前名为阁今转称舍者凡有二义。上辨三界升沉不同故称为阁。今明为物所栖目之为舍。二者三界转回升坠不定。或生上界或在下界。故不专守定名也。三界之法重累故称为高。而六道果报非安稳法故云危也。又天堂与地狱相对门。故高处必危。如智度论云譬群羊肥者前死也。柱根摧朽者。上总明三界无常。今别明无常也。柱根持一舍之本。命根持一身之主。故大品云。如人命根在故余根在。命根若灭余根尽灭。是故前辨命根。念念损灭为摧朽也。梁栋倾斜者此明心法无常如前释也。以识无定形生灭如幻为倾斜也。基陛颓毁者以三种业为三界基陛。如大品云。罪业因缘故三恶道中生。福业因缘故欲界人天中生。无动业因缘故色无色界中生。故知三业为三界基陛。行业渐尽为颓毁也。墙壁圮坼者。柱根辨非色非心无常。梁栋明心法无常。今明色法无常。前二无常相隐故略说之。色法无常相显宜广明也外四大如墙。内四大如壁。四大性相违反如圮坼。圮者毁也。坼者裂也。埿涂陀落者。埿涂者四微也。毗昙则四微与四大常俱故四大造四微。成论则四微成四大。如埿涂成于墙壁。今谓四微亦无常故称陀落。又细无常如圮坼。粗无常如褫落。褫者颓褫。落者坠落。覆苫乱坠者。盖屋之物或瓦或茅。今正以茅覆舍故称苫也。众生以薄皮裹于一身。如脆茅盖于一舍。乱坠者聊乱坠落也。即皮缓面皱齿疏形竭之貌也。椽梠差脱者。意根为栋。身根为梠。眼等四根为椽椽之所依。上即钉之着栋。下又协之在梠。二根为主四根依附有像之也。差脱者诸根为用互相资持。乃至其衰朽资持之力微弱。义言差脱。故经言。少年去死远生近。故六根皆明。老年去生远死近。故六根皆闇也。周障屈曲者。上来明五阴六根皆是无常谓无常观也。今序宅敧侧不正之貌明无我观也。喻如老病死将至四支百体不得自在。如舍敧侧不得周正。以显无我也。杂秽充遍者第三明不净观也。有人言。从有一大宅至而复顿弊总序三界无常也。从堂舍高危以下别序五阴四大无常也。堂舍者总明五阴是众生所栖。是故经云五阴舍宅观悉空寂。柱根以下别明五阴无常也。色阴中地大能持故为柱。柱分分不实如摧朽也。识阴为一身之主是梁栋。识无定主如幻为倾科。行阴是一身之本为基陛。一起一灭为颓毁。乱想周障取像而不实为墙壁圮坼。三受互起不住如埿涂褫落。此序五阴无常竟。覆苫乱坠下别明四大无常也。风大能倾覆为覆苫乱坠。椽梠不能相持。似坚而非坚。譬地大之不实也。周障屈曲。如火大遍在一形之中随身老壮火有强弱不得自在也。杂秽充遍者。六根脓血渧唾不净譬水大也。有五百人止住其中第三明宅中人。则五道众生止住无常无我不净舍内。明可伤之甚也。鸱枭雕鹫下第四明宅内有恶物。经无别合义既难明。今略以五门释之。一来意门。二摄法门。三次第门。四同异门。五约人门。来意门者。以宅中有此毒害故宅不可居三界内。有爱见烦恼能害众生法身慧命。宜起厌离疾求出也。二摄法门者。毒害虽多不出二种。一者显现有形之物谓怪鸟毒虫。二者幽隐无形之物谓夜叉恶鬼。为害之极唯在斯二。有形虫鸟譬三毒缘事烦恼。无形鬼神譬迷理诸见。害法身慧命唯有理事两惑也。三次第门者

问。何故前明有形虫鸟后辨无形鬼神耶

答。就譬而言。有形显现毒害义彰。是故前辨。无形鬼神为害不显。所以后说。就理而明者。有形鸟兽譬在家起爱众生。无形鬼神譬出家起见外道。故前有在家起爱。后方有出家起见也

问。何以知然

答。此譬之兴还譬方便品五浊文耳。方便品中两处皆前明起爱后辨起见。初文云深着于五欲痴爱故生恼谓起爱也。入邪见稠林若有若无等谓起见也。后文云深着于五欲如牦牛爱尾谓起爱也。深入于邪见以苦欲舍苦谓起见也。方便品既前明于爱后辨于见。盖是法说明爱见前后。今此品中还譬上义。故前明怪鸟毒虫以譬于爱。夜叉恶鬼譬彼见也。是以此文不依断惑前后亦不依起惑次第。以此释文焕然可明也。第四同异门者

问。虫鸟鬼神与五百人等有何异耶

答。然诸法本性寂灭未曾生死之与涅槃。亦未曾有众生及与诸佛。但于颠倒妄情故有众生。约此众生便有五事。一者取其果报升沉故名三界。此三界同是无常不净。所栖之义如彼舍形。能栖三界之人数有五道名五百人。即此五百人起三毒烦恼名为毒虫。若起诸见称为恶鬼。具此爱见便感苦果烧恼身心故名火灾。故三界内有此五事也。次明则约此众生具足五义名出三界人。一者则此众生值佛菩萨闻说三乘教种三乘种子名三十子。渐次修行成三乘圣人故名罗汉辟支及以菩萨。即此三乘人若闻法华同悟一乘并名菩萨。即此菩萨修行满足故名为佛。然三界内五事谓生死河满涅槃河倾。三界外五事即生死河倾涅槃河满。然本对生死故有涅槃。生死既倾即涅槃亦净。故非生死亦非涅槃则本性寂灭。谓二河俱倾。如华严云生死非杂乱涅槃非寂静也。然非生死非涅槃故能示生死涅槃二种方便。谓二河俱满也。第五门明人不同者。略说此经譬意。明迷悟不同有四种人以为次第。一者在家起爱众生不知厌生死亦不知出。二者出家外道知厌老病迷于出路而不知出处。三者二乘之人知厌知出。但是曲出故于佛道迂回稽留。又住半路不更进求。四者菩萨之人知厌知出名为直出。故乘是宝车直至道场。今毒虫恶鬼则是前二人也。今昔两人即是后二人也。亦得一人具四四人具四。如恒河中七种众生自有七人具七一人具七也。就文为三。一者明毒虫。二辨恶鬼。三总结过患。初文又二。前别明毒虫二总结过患。就初文又开三双。第一明上有怪鸟下有毒虫则上下一双。二明所迷之不净能迷蜣螂。能所一双。三明贪兽食啖悭狗诤夺。悭贪一双

问。初何故前明怪鸟后明毒虫

答。据譬而言。宅有二事不可栖止。一者上有怪鸟。二者下有毒虫。即从上至下自外至内。为此义故前明怪鸟后辨毒虫。有人言。怪鸟以譬慢使。如鸟飞翔高举。譬众生起慢陵他举自高。慢非三毒之初又非五钝之首。但示起无定相故前明慢。又此经正斥增上慢人故前明也。有人言。既称怪鸟。取其发声为譬。然此诸鸟或哢怪声或吐和音。怪声即譬恶口两舌。和音以况妄言绮语也。今谓理实难明。但斯一宅内上有怪鸟下有毒虫。以此为譬者。上在怪鸟譬上二界爱使也。是故经云色染无色染。以爱为生死之本故命初说之。又诸外道皆言上二界是极乐涅槃。而贪着禅味。今偏破之故先明上二界爱也。蚖蛇蝮蝎此第二明下有毒虫以譬嗔使。爱唯在上不在下。譬同诸鸟。嗔唯在下不在于上。喻彼毒虫。盖是一往开七使门。毗昙释之于文相似也。蚖蛇备有两音。而形长一尺许世人呼为蛇师。重嗔如蚖蛇蝮蝎。轻嗔如蜈蚣蚰蜓。守宫者淫妒之譬也。古人取此虫缄置箱内以真朱食之令赤。若王行不在刺取血题内人臂。有私情者血沉入皮内。可以守宫人故以为名也。诸恶虫辈者总结众邪。万妒从嗔使支流生也。交横驰走者。众使乱起如交横。起必疾利如驰走。屎尿臭处者第二双也。初明所惑之法。谓欲界五欲犹如屎尿。上二界虽无外欲而有内欲故称流溢。皆为智人所恶名为不净。蜣螂诸虫而集其上者此明能迷之使。谓凡夫痴迷而乐着不舍。如蜣螂无识而集其上。此举爱以显痴也。前明爱嗔各在上下。故如彼虫鸟。今明三界悉是有漏不净无明烦恼通并迷之。故前明其别今说于通即是次第也。狐狼野干者第三明悭贪一双也

问。初明怪鸟喻爱毒虫譬嗔蜣螂譬痴。即是三毒具足。何故更说悭贪

答。贪爱是生死之本。宜开为二。轻者为上界之爱。重品为欲界之贪。初以明上界之爱。今次辨欲界之贪也

问。何故前说上界之爱次则辨欲界贪耶

答。就譬而言。上有怪鸟下有毒虫。明舍之可怖不可栖止。故前明上界之爱。下界之嗔为过患义甚。故前说爱次则说嗔。今欲广序悭贪过重故在后明之。故方便品云劫浊乱时众生垢重悭贪嫉妒。今为化欲界之人故广彰欲界过患。故在后说之。就文为二前明贪过次辨悭失。狼兽多贪。是以经云贪狼于财色。狐兽亦贪而性多疑。是故经云狐疑。即借此兽以喻疑也。今正辨贪而明疑者。又多贪之人欲求名利前生疑心。为得与不得。是故就贪使则明有疑。野干亦贪而性复谄曲以贪求之人多好谄曲。是以明贪而复辨谄。咀嚼者正辨贪相。乃备贪五尘而贪味为主故偏说之。践蹋者贪无道理饕餐无厌义同践蹋也。[齒*齊]啮者六根起贪取境深重如[齒*齊]啮也。死尸者所贪五欲不净臭秽譬彼死尸也。骨肉狼籍者贪取积聚其事众多如狼籍也。由是群狗下第二明从贪起悭。悭者非一譬同群狗也。竞来搏撮者。悭心保吝义同搏撮。又多得名利处如骨肉狼籍竞于名利义同搏撮也。贪无饱厌如饥羸。惧不称意如慞惶。触境皆贪四方引取如处处求食也。斗诤摣掣者。前明从贪起悭。今辨因悭贪更起嗔使。贪性引取悭则吝保。二义相反。境不顺心则起嗔诤故言斗诤。竞牵向己故曰摣掣。啀喍嗥吠者。斗诤起于身业。今明起于口业。从悭贪二使故起身口两嗔也。此并序群狗之事。非前三兽譬也。其舍恐怖变状如是下第二半行总结其过患。其舍者三界舍也。恐怖者烦恼能害法身慧命可怖畏也。变状者变怪之壮貌也。心本清净起诸烦恼乖伤至理能感苦报如变怪也

问。何故此文不明疑使也

答。此正譬在家起爱众生。但明有于三毒。未是推获求理故不明疑使。疑使在后说之。事中之疑非使性摄故不说也．处处皆有下第二譬出家外道起迷理之使。如方便品已生起之。又前明天魔乐生死。今明外道着诸见。就文为二。初明疑使次明见使。要前生疑然后起见。故杂心云无知故犹预犹预故邪见。上已明无知今次明犹预。故初辨疑。疑通三界故云处处皆有也。魑魅魍魉者正明疑使。借魍魉魑魅之名喻疑之不决也。张平子西京赋注解云。山神为魑。虎形也。宅神为魅猪头人形身有尾。木石夭怪为魍魉。春秋第十卷云。铸鼎像物故有百兽之形。使人入山川不逢魑魅魍魉。注云魑是山神兽形。魅为怪物。魍魉者水神。夜叉恶鬼下第二明见使。就文为五。第一明邪见。第二明戒取。第三明身见。第四明见取。第五明边见也

问。五见门何故初说邪见耶

答。据譬而言。舍内有食人之鬼最可怖畏。邪见拨无因果能断善根。诸见中重故前说之。又杂心云犹预故邪见。则从疑生邪见。谓相生次第也。就文为三。初半行明拨善根邪见。一行半明拨恶邪见。后一行双结二种邪见也。夜叉恶鬼者释论云。帝释城有九百九十九门。门有六青衣夜叉。然夜叉有三。地住空住天住。释论举天住者耳。什师翻为轻捷。又云贵人亦名能啖也。食啖人肉者。上辨能拨之邪见。此明所拨之善法。人肉是肉中之贵。善法为众法之尊。欲明为过之甚故前明拨无善法也。毒虫之属下第二明拨不善邪见也。初一行明所拨之不善。上半辨不善之因。次一句明不善之因生不善之果。第三句明因果詶生各有理分也。孚乳者。鸟所生者名孚。兽所生者为乳。亦是卵者为孚。胎者为乳也。夜叉竞来下第二半行明能拨之邪见。起邪见者非一故言竞来也。然正食其子譬邪见正拨果也。食之既饱下第三一行总结邪见过也。至拨不善则邪见都成九品备足善根永断故云饱也。以九品备足邪见强盛故云转炽。因邪见起邪说如斗诤之声。邪见执无与有见相反义如斗诤。宣之于口称为恶声。邪见．能断善根得无间报如甚可怖畏也。鸠槃荼鬼下第二次明戒取。次邪见明戒取。邪见拨无因果。戒取立有因果。欲以有无相对故相次也。亦欲显外道执于有无悉乖至极故次说之．鸠槃荼鬼此云冬瓜鬼。形似冬瓜也。戒取有二种。有善法恶法。若执诸见为道是恶法戒取。故成论云。持牛戒若成则为牛。不成则堕地狱。非此中用也。今此中明执三界有漏善法以之为道名为戒取。依毗昙义。虽执善法为戒取。并属不善摄。故除身边二见余见悉不善。能持善戒得欲界人天升出四趣。如土埵少高于地。但欲界非安稳法譬蹲踞也。或时离地一尺二尺者。此执修禅绝欲以之为道名为戒取。计四禅为道如离地一尺。计四空为道如离地二尺。攀上为往。厌下为返。又生上为往。退下为返。周历三界为游行。乖至理为纵逸。不能克获圣道为嬉戏也。捉狗两足者此明戒取过。前明邪见拨无因果其过既重如食人及食诸鸟兽今明戒取立有因果其过即轻但如恐怖舍内之狗。故有此譬来也。计四禅四空为道乖损上二界因。如捉狗两足。以上二界因是有漏。望无漏圣道是下法。如狗是下贱兽也。计有漏非道为道乖损有漏。喻如扑狗。乖违事彰如狗声扬于外。故云失声。既迷有漏之因亦迷有漏之果。如以脚加颈。计有漏为圣道不拨于因果。如怖狗不死。作此执计谓为得理。故称自乐也。复有诸鬼其身长大下第三次明我见。次戒取后说我见者。就譬而言。初鬼俱害人兽其过最重故初说之。次鬼不害人兽但怖于狗故在第二。今此一鬼都不损人兽。可怖畏义微故在第三。邪见拨因果其过最重故在第一。戒取立有因果但乖有漏法故居第二。身见不妨行施戒。复是隐没无记法。比于戒取其过则轻故居第三也

问。如成论义明身见是不善。毗昙义明身见是隐没无记。此二云何得失耶

答。俱舍评之云。我见有二种。一者生得我见。谓随生三界地一切众生皆起我见心名为生得我。如此之我则是隐没无记。若如外道邪执之我名为不善也。其身长大者。若据多人者。三界众生皆有我为长。五道众生悉有我称之为大。若如僧佉等计我遍三界五道称为长大。计我之人谓为得理心无惭愧称为裸形。无明心中计我目之为黑。无有无我正观故名为瘦。一切凡夫常有我心故言常住其中。怀我在心。宣之于口故言发声。为我修福义如求食也。又此鬼恒欲食于人兽。如计我常拨于无我故名求食。复有诸鬼其咽如针下第四次明见取。但见取有二。一者独头二者足上。言独头者无乐净计乐净也。言足上者于我见上执是非也。如云自见是实以余妄语。今此文明执己见为是不受他见如细咽之鬼不受饮食也。复有诸鬼首如牛头下第五明边见。断常从身见生。如牛二角共在一头。而言牛者牛羊等愚痴。就譬而言可有三句。一者牛二者头三者头上有角。如由痴故计我由我故起断常也。或食人肉或复啖狗者。上明边见体。今明边见用。乖善法因果如食人肉。违恶法因果譬之啖狗也。又乖灭道为食人肉。伤苦集如啖狗也。头发蓬乱者。上略明从身见生断常二见。今广明从断常生六十二见。故方便品云入邪见稠林若有若无等依止此诸见具足六十二。断常为众见之本。如头。从断常生六十二见无有絟绪。如发蓬乱也。残害凶险者。上明六十二见体。今明其用。诸见多所乖伤如残害凶险。无有定慧饮食。故言饥渴所逼也。又此鬼亦常食人兽。如计断常者恒欲破于中道宣诸见于口。其义显彰如叫唤。心行断常义如驰走也。夜叉饿鬼下第三一行半总结过患。初句牒迷理之使。次句牒迷事烦恼。起爱见二使众生并无定慧饮食如饥急。又常欲乖伤名饥渴。但有欲出之心而不修出之行。如此爱见众生受诸苦时亦有厌苦四向希心求出离义。如窥看窗牖。窗牖谓无苦处。而不正求出但窥之而已。如是诸难恐畏无量者。患累烦恼非可具列故言如是诸难恐畏无量。是朽故宅下第五次明火起。就文为二。初明火起之缘。二正明火起

问。何因缘故有火起譬耶

答。长行已释。今更作一意序之。前明舍形谓三界果报。次明恶鬼毒虫谓于三界中起爱见烦恼。以有烦恼故感苦报。但感后苦有二因缘。一起烦恼二远离善师即佛去世也。起惑是感苦之因故前明之。佛告是感苦之缘故后说之。是以经文前明烦恼后辨佛去世也。佛应生三界。三界属佛。以佛能化三界故属佛。不属九十六师故云一人。其人近出者。上明应生今示应灭。转现他方故云近出也。未久之间者。如来示现生灭俄顷之时故云未久。又未久尚已起惑招苦。况去圣久耶。于后舍宅欻然火起者第二正明火起。就文为三。第一明欲界火起。二明色界火起。三明无色界火起。故不文云。三界无安犹如火宅。常有生老病死忧患。如是等火炽燃不息也。于后者谓佛灭后也。又是众生背化以后。此明火起时也。欻然者从颠倒妄想而生。示火起无根本也。火起者正明起惑招苦也。四生众生同有生老病死故云四面也。一时者虽复同有犹恐未必一时故复说一时也。其炎俱炽者如来灭后众生背化同起染累俱受重苦也。栋梁椽柱者出被烧之身心也。爆声者谓老苦。震裂者谓病苦也。摧折崩倒者谓神逝形离即死苦。诸鬼神等扬声大叫者此序遭苦人。诸鬼神则出家外道等起见流。十地论云。外道见老病死生大厌心。如鬼神见火扬声大叫。雕鹫诸鸟下此一行序爱见众生同不知出苦处。上句明在家起爱众生见老病死亦生怖畏不知出处也。次句序出家外道亦不知出处也。恶兽毒虫藏窜孔穴者第二明色界火起。初一句明在家众生厌欲界苦修于四禅求生色界。故言藏窜孔穴。此经始末有三种喻。一者取上界高出于下故举阁为喻。二者取凡夫出离盖不足言。如一尺二尺。三者今取避火之义喻同孔穴。毗舍阇鬼者此云狂鬼。譬起见外道。亦厌欲界苦求生色界故云亦住其中。薄福德故为火所逼者。虽生色界亦未免于患。所以不免苦者由薄福德故也。欲界苦重如烧。上界苦轻故言逼也。共相残害者明色界众生已受苦果更起惑因。爱多者著有。见多者着无。有无互起更相吞灭义言残害。有害无如饮血。无害有如食肉也。野干之属并已前死者。生上界时欲界重贪前已断也。故十地云。如梵天王欲界烦恼不现前也。诸大恶兽竞来食啖者。欲界恶虽灭而上界烦恼续起。起则势夺前恶故言竞啖也。臭烟熢[火*孛]者。烟为火气。因众苦生诸恶业故以苦为火。恶业喻烟。遍色界四禅之内称四面充塞也。华严经以邪觉观为烟。此是说诸烦恼本也。邪思惟亦通四禅。如四面充塞。蜈蚣蚰蜓下第三明无色界火起。就文为二。初明三空火起。次辨非想被烧。虽生四禅未免无常。复求生三空故言诤走出穴。此一行序在家众生生无色界也

问。依毗昙义上界无嗔。何得言蜈蚣蚰蜓譬生无色界众生有嗔耶

答。义有多门。不得全依数判也。鸠槃茶鬼随取而食者。此半行明起见外道生于无色界。外道多执无见拨其所计因果皆无。故言随取而食。应具如色界说。今略举造苦因义耳。又释此转譬明义。虽生三空由未免火故言随取而食。鬼喻火也。又诸饿鬼头上火燃下第二明非想火起。虽生三空由未免苦故求生非想。是三有之顶称之为头。亦为无常众苦所逼故言火燃。虽生非想之极终无出世定慧如饥渴热恼。又饥渴常欲饮食。计非想凡夫恒欲片破正涅槃法也。初在宅被烧故诤入穴。穴内被烧复走出穴。穴外复不免火更无去处故言周章闷走。如本在欲界。受苦故求生色界。色界复不免苦故求生无色界。无色界复不免苦则无避苦处。如周章闷走也。其宅如是下第六总结过患也。是时宅主下第二三行颂见火譬。长行有三。一见火惊怖。二明父之已出。三序子之未离。今转势亦三。一明在门外立。二众生有机扣佛。三长者惊入火宅

问。何故在门外耶

答。方便品云佛眼见六道众生。前长行云长者见是大火。并未明见之处所故今释二处之文。明佛居法身地故见如长者在门外立故闻。所言立者将行之貌也。以将入宅救子所以言立。又言立者不行之像。譬佛待机方入生死度物而不他行也。又言立者诸子背化流转生死。如来众德久已成立。又言立者不安之貌。圣人虽复息迹世外。恒欲府入生死未曾暂安也。闻有人言者第二明众生有机扣佛也。众生应悟之机。昔化缘发来扣于佛。如闻告而后知。长行称见今言闻者。上据圣智。照达分明譬同眼见。今喻众生善根将发。但善根将发其义微隐故如闻也。汝诸子等述所闻事也。昔曾受化应在四流之外。中途起惑还入三界之中也。稚小无知欢娱乐著者。初发道心为稚。善根微弱为小。有无明烦恼为无知。爱于五欲称乐着也。长者闻已下第三明应入斥生死欲救济也。上二章并序法身。第三始辨应迹。告喻诸子下五行颂第三救子不得譬。前本有诫劝二门。今但颂诫门所以然者。欲明三譬义势相承。颂前总譬广明生死过患。颂见火譬明诸子背化起惑贪着生死因缘。今颂救子不得正为子说生死过患。是故但颂诫门也。就文为二。初颂救子。次明无机不受父化。初文又二。前一行半略说生死过患。毒蛇蚖蝮下二行半广说生死过患。毒蛇蚖蝮释上毒虫。及诸夜叉释上恶鬼。鸠槃荼鬼下重明鬼虫者。初鬼虫为过之甚故前列之。后毒害少轻故复重列也。此苦难处况复大火者。烦恼之苦以恼于心尚不可受。况老病死苦而可受耶。又释人天苦已不可受。况复三涂苦耶。诸子无知下第二颂无机也。是时长者下颂第四三车救子得譬。上有四。一知子宿好。二正说三车。三诸子信受。四父欢喜。今具颂之。初三行颂第一。上文有三。一不出为损。二欲设出方。三知子宿好。今转势为二。前两行半明无大机。次半行明有小机。以无大机而有小机。是故息大而授小法也。益我愁恼者。初在法身地见众生在生死受苦已起大悲。次以本垂迹用大乘化之不得。悲心转深故云益也今此舍宅者别出可悲之事。恋着生死不受大化。盖是舍乐取苦。将为烦恼烧灭善根故可悲也。即便思惟下第二欲设小化。即显有小机也。告诸子等下颂第二正设三车譬。上有四譬。今具颂之。一行颂称叹三车。次三句颂示车处。次一句颂劝速出取车。次一行颂保与不虚。造作此车者。本无三乘为物权设故言造作也。又由佛得三故言佛造作也。诸子闻说下颂第三诸子信受出宅。此文有三。初半行颂闻慧。六字颂学地。而出已下十字颂无学位。所以但颂三者。初闻教二修行三出宅也。长者见子下第四颂上父见子免难欢喜。就文为三。初一行半标欢喜。次二行半举忧愁释喜。后一行结欢喜。至此以来已三过列恶鬼毒虫及以大火。第一总譬中别明三界有此过患。第二救子不得譬中别明为子说生死过患而不信受。今此中别为明不出之忧得出之喜。故复列也。生育甚难者。令发菩提心为生教修菩萨行为育也。此中述子三时。一生育时谓过去世本学大乘时。从稚小下第二失大乘行教入三界时。我已救之第三得小乘果时也。尔时诸子下十二行颂第五等赐大车譬。上有三。一索车二赐车三得车欢喜。今具颂之。索车有四。半行明索时。知父安坐者此譬始终明父有三时。一者门外立时譬居法身地欲垂应迹。二惊入火宅时正应入生死。三安坐时则是施权救子。营为已息意悦心安谓安坐时也。皆诣父所下第二一行正颂索车譬。此譬始终明子凡有五时。一游戏入宅时。此时背一乘化入三界时。二明竞共驰走出宅时。此是禀三乘教出三界时。三子安坐时。谓得小果究竟时也。四皆诣父所谓背小向大即大机发时。后第五乘是宝车直至道场时也。如前所许下第三一行腾昔所许。为许故索。故腾许而索也。今正是时下第四半行结成索意。长者大富下第二颂赐车。长行前明等赐后辨大车。今七行前颂大车。后半行。颂等赐。盖是转势说法也。以众宝物造诸大车者。说如来万德作大乘之名。故言以众宝物造诸大车

问。三是方便可名造作一乘真实云何亦称造作耶

答。前明无三为物说三故言造作。是以前云吾为汝等造作此车。今明实有众德作大乘之名故言造作。故二造义异也。又据理而明者。道门未曾三一。说三说一皆是方便。即是无名相中强名相说故俱名造作。此并就果车释之。若就因车释者明造用也。藉前三乘善根之宝以成今日唯有一乘之解。故言以众宝物而造作之。又一乘之解非已能得。得由圣授义名为造作。上妙细[疊*毛]者以[疊*毛]覆缛。其用有二。一以遮垢二以严饰。一乘之义亦备二义。一者禅定垢过多生染着。真解能亡。有遮垢之义。二者定由慧成。有严饰之义也。有大白牛下颂上牛也。多诸傧从者颂上傧从。以是妙车下第二颂等赐也。诸子是时下颂第三得车欢喜。游于四方者。若据化他以释四方者。既得平等之解方修大行普化四生。如游四方。畅远求佛之志。如嬉戏快乐。大乘不为偏小所局。如自在无碍也。若据自行明四方者。二乘既得悟解则入十住心。十住心为东方。次进至十行为南方。从十行至十回向为西方。从十回向至十地为北方。从十地至妙觉地为直至道场也。告舍利弗下第二十八行颂合譬。长行具合六譬。偈颂合五略不虚譬。上合总譬正合化主兼余五义。今转势明义开为四别。一行颂化主。一行颂所化。一行颂化处。一行颂化意也。如来已离下第二颂合见火譬。上长行合见火譬有二。初合见众生受苦。次合见众生不觉苦。今文转势开为二别。初偈叹佛得离则是明能见。次偈序众生辨其所见。所以叹佛得离者。接上化意文生。化意既序众生之过明有苦无乐。故今叹佛德明无苦有乐也。又良由无苦故能见物苦。良由有乐能见无乐也。上半叹佛无苦。下半叹佛有乐。无生死暄动故称寂然闲居。智德森繁喻之如林。萧然放旷譬之如野。如来居之恬惔故言安处。今此三界下第二一行颂所见。三界果报属于众生而言我有者。正以众生是子。子之所有莫非父有也。其中众生悉是吾子者。上明国土世间属佛。今明众生世间是佛子也

问。众生云何是佛子耶

答。昔光宅学士和阇梨云。凡夫识能更生识。所生之识则是己儿。故名为子。得无漏意识不复生识也。成论师云。众生从无明识窟流来。为佛所爱念故名为子。今明子有二义。一者众生与佛同源。谓众生本性清净。佛亦尔也。故涅槃经云。皆是一味。随其流处有六种味。二者诸佛伤此众生无六道谓六道。以慈念之故称为子也。而今此处下颂第三合一乘化不得。上长行双举诫劝二门合之。今转势但开为二。初一偈一句明为说大。三句颂无机不受。能为救护者能用大化救而护之也。虽复教诏者。前句叹佛能救护。今正明救护也。而不信受下三句明无机不受。下半释不受之义。以其贪着小乐故不受大乐。以是方便下颂合第四三乘化得譬。上合譬有四。一明起权意二说教三得益四父喜。今但颂二。初一行半颂说三乘。次一行半颂得益。以是方便者。接上言势仍发下语故言以是方便也。令诸众生知三界苦者。一行明说三乘之意。初半偈令知苦谛。次半行示于道谛。此明四谛之始终也。又说于三乘示得失耳。非实有三也。知三界苦者三界苦是实苦也。出世间道者大乘因为道也。此意明说三令知苦是实。令修大乘因耳。非为小果也。是诸子等下一行半颂得益。具明三乘得益。汝舍利弗下颂合第五等赐大车譬。上长行双牒二譬而双合之。今转势开为三别。初两偈合等赐。次三偈合大车。后二偈合得车欢喜。以此譬喻说一佛乘者总明五譬意。为欲说一佛乘。即是等赐义也。第二偈明劝信。虽复等赐恐未必受。是故劝信。上半正劝。信信受是语者则上譬喻之语也。一切皆当得成佛道者略标旨归令作如斯信也。是乘微妙下三行颂大车也。三偈为二。初二偈叹乘。次一偈出乘体。前二偈又开为二。初偈就法叹乘。第二偈就人叹乘。第一就法叹乘中。上半对声闻缘觉二乘叹佛乘也。是乘微妙者德无不圆也。清净者累无不尽也。以德无不圆累无不尽故超出二乘称为第一。于诸世间下半行对人天乘叹佛乘也。人天乘为世间乘故名有上乘。佛乘是出世间乘故名无上也。佛所悦可下第二就人门叹亦为二。初一句明佛所称叹次三句明除佛以下九道众生并应称叹也。又前明所乘法。佛所悦可明能乘人。一切众生下明傧从人。要具此三乘义乃足。无量亿千下一行第二出乘体亦有二义。初三句就佛实慧以为乘体。次一句明佛权智以为乘体也

得如是乘下第三两偈颂得车欢喜。举缘觉中子上与菩萨下及声闻同得不二之解。解无迂回故言直至也

以是因缘下此一偈是第二大段颂上长行以是因缘当知诸佛方便力故于一佛乘分别说三。说事既竟故颂前结詶请之言也

告舍利弗下此是颂长行第三大段劝弘经也。就文为二。第一令识法之权实。第二示人之是非。识法权实者。令知今昔大小二法权实义也。示人之是非者。令今是器须授非器莫传。夫欲弘经要复备达斯二义。故开此两章。就初示法权实为三。第一寄父子恩情以显大小权实。第二引菩萨为证明大小权实。第三明佛是法王释今昔权实之意。初寄父子恩情明权实者。夫为父子恩情必无相欺之道。故所说权实宜应信之。就文为二。前两偈定于父子。后一偈半正示权实。初又开二。前偈定于父子。后偈出慈父之恩。后一偈半亦二。初偈明昔教非实。次半行辨佛智为实也。但尽生死者但尽分段一重生死也

若有菩萨下第二有十一偈。引菩萨为证明大小权实。上定父子即是对声闻人明权实。但声闻薄福钝根未必能解权实教意。菩萨福德利根能解之。故就菩萨明权实也。就文为二。初偈正明菩萨来法华座听真实法。第二段明菩萨能解权实。就第二段复开为二。第一一行明菩萨解人权实。第二九偈明菩萨解法权实。则是释成人权实义。初一偈上半明人权。下半辨人实。若人小智下明法权实。就文为二。第一明昔四谛是权法。第二偏对昔灭谛之权明今灭谛为实。初文明四谛则为四段。苦谛文有四句。半偈明根缘。半偈为说教。半偈明得益。半偈结谛名。明集谛有二段。初偈明根缘。次偈明说教。而言方便说道者。此非道谛之道。乃是道说之道也。然十烦恼为集。但说贪者凡有二义。一者列十使贪为其初。二者一切众生皆贪乐故也。次一偈明说灭谛教。半偈灭因患。半偈灭果患。次半偈明于道谛。此中四谛从广至略。苦谛备四段。集谛但二章。灭谛有一偈。道谛但半行也。离诸苦缚下第二段偏就灭谛以明权实。然有量四谛为权。无量四谛为实。但灭谛是大小二乘果法之正宗。故偏简其权实也。就文为二。初约有余论大小权实。次约无余论大小权实。初半行牒昔有余解脱。第二偈释昔日有余解脱。言但离虚妄者。四住烦恼是凡夫所起。能感分段虚妄生死故称虚妄。小乘但离此虚妄故假名为解脱耳。其实未得一切解脱者。未具断五住故不名一切解脱也。佛说是人未实灭度者第二明今昔无余权实也。昔但灭分段生死称为灭。此非实灭也。斯人未得无上道故者昔未实灭也。得无上道者灭二生死果方乃实灭耳此文明昔小涅槃但灭四住但灭分段大乘则具断五住备倾二生死。不应谓此经未明常。亦不应言覆相常也。我意不欲令至灭度者。非但二乘未至极灭。亦是佛意不许二乘令至极灭也

问。胜鬘经云有作无作有量无量四谛。云何同异

答。作无作约行分别。量无量当法分别。据小乘所观。望后由有无量谛观可以修作。将后别前故名有作。据大乘所观。望后更无余观可所作故名无作。量无量者有三种义。一短长明量无量。短故名有量。长故名无量。二浅深明量无量。浅名有量。深名无量。如毗昙明苦是性有。成实明苦是虚假。拆假故空。此二浅故名有量。大乘明苦是梦幻本来寂灭则是佛性。此义甚深故名无量。三粗细明量无量。总相粗观名有量。别相细观名无量。故涅槃经言。分别是苦有无量相。非诸声闻缘觉所知。我于彼经竟不说之也。我为法王下第三举法王释疑。前对声闻菩萨明小权大实。其义已彰。今释前权后实之意。良以于法自在适时而说也。汝舍利弗下。上来示法权实竟。今第二诫劝之令识人是器非器也。就文为二。初略明诫劝。次广明诫劝。初又二。前略标诫劝二门。次释二门。初一行标劝门。次半行标诫门。我此法印者。以理为印。谓文与理相应则应信受。文乖此理则不应信。理印有二。一体印。谓三一并绝长短斯亡。即是实相名之为印。故方便品云为说实相印。二者用印。谓一有三无三权一实。通言印者。印定诸法不可移改。又释以文为印。将文定理。谓理与此文相应者乃为实理故名法印也。勿妄宣传者非器若传则有损无益。故方等如甘露亦名为毒药。若有闻者下双释二门。前四偈释劝门。随喜顶受者。随顺此经而生欢喜及顶戴受持也。此人知一有三无则不复退故名阿鞞也。斯法华经下释诫门也。闻三住三不能因三悟一故名浅识。次举二乘以信得入者。则是显经理深不可妄传也

问。二乘何故以信得入此经耶

答。若以低头举手等善为此经宗者。圣人岂不解耶。则知意不在此。今明二乘断常之心不能深悟不断常法。但得仰信而已。又舍利弗下第二广明诫劝。又开为二。初广明诫。次广明劝。广明诫中凡有十人开为二意。初明不应为五人说。次显五人之过。不应为五人说者。初偈明三人。一憍慢人如五千之徒。二懈怠人自保究竟不进求佛。三计我见人即是外道。谓保执有我不信寂灭。第二偈明二人。一凡夫浅识。谓博学世俗经书不信至极。即起见人。二深着五欲着小乐而忘大乐。不应为此五人说也。初三是小乘人。后二是凡夫人。若人不信下第二明五种人过。就文为二。初明五种人因。次明五种人果。五种人因者。第一是诽谤人谓口业过。第二嚬蹙人谓嚬眉蹙面即身业过。第三疑惑人谓意业过。第四毁法人。第五谤持法人。初文云则断一切世间佛种者。法华理教。一切世间由之成佛。谓作佛种也。心既不信口复谤之故佛种便绝。其人命终下第二明五种人得果者凡有三义。一者上来皆言莫为说之。亦似若无慈。何名菩萨。是故释言。闻必起谤。无益有损故不说之。不说之意即是慈也。二者．说果诫因。明谤而致苦可不慎哉。三者谤既有重罪。信必有深福。即是明劝信也。就文为二。初正明得苦果。次结诫劝。就初文凡有二周。明其苦报各有三品。初周三品者。上品地狱次品畜生下品人间受苦。即是从重至轻也。入阿鼻狱者。阿鼻者无间也。苦道相续无乐间之故名无间。又一人多人身俱遍满八万由旬间无空处故言无间。又起谤法华业直入地狱。无余业间之故言无间。经云须弥山下有一百三十六地狱。大地狱有八。一等活。二黑绳。三合会。四叫唤。五大叫唤。六燋热。七大燋热。八阿鼻此八大地狱一一复有十六小地狱以为眷属。谓八寒冰。八炎火。八炎火者。一炭坑。二沸屎。三烧林。四釰林。五刃道。六铁刺林。七碱河。八铜镬。八寒冰者。一阿浮陀少有孔。二尼罗浮陀无孔。三阿罗罗。四阿婆婆。五喉喉此寒战声。六优钵罗(狱壁青色)七波头摩(狱壁黄色)八摩诃波头摩。合一百三十六也。毗婆沙云。阎浮提地广七千由旬。阿鼻地狱广八万由旬。在阎浮提下。但阎浮提上小下大故得容之

问。何故谤经入无间耶

答。一乘是极乐之法。谤于至理违彼极乐故招极苦报也。以理是常乐。谤于常乐故招常苦报。但罪是虚妄故终有出期也

问。佛何故说法华令物受斯苦也

答。夫罪福从于理生。顺理则万恶永消。违理则众苦并集。佛说法华示人罪福耳。非说法华令物起罪也。具足一劫者此小劫也。从地狱出下第二明余报堕于畜生。然从阿鼻出必应遍历一百三十六地狱然后乃至畜生耳。初半偈总明堕畜生也。若狗野干下第二别明堕畜生也。略举四种。第一谤于极法及以尊人故堕下贱兽中。[乞*頁](古[阿-可+害]切又窟音)三苍云。头无发也。黮(睹咸切)三苍云。重睹色黑貌。若作骆驼下。谤平等大慧之经故受愚痴畜生报也。有作野干又无一目者。佛有权实二教。彼执权而破实故得无一目报。得打掷报者。信经之善符理利他。谤则乖理损他。损他故还得他损报。故有打掷等也。于此死已更受蟒身者。谤法毁人之时心生嗔恚故受蟒身也。其形长大者。嗔大法故受大苦身。不耐闻法故聋。愚痴谤故騃。不受行法故无足。多令众生不信故为诸小虫所食。若得为人下第三明余报。智度论云。谤法人非悭贪业故不生饿鬼中。愚痴谤故得闇钝报。亦谤智慧经故得闇钝报。憍慢心谤故得矬报。谤微妙法故得丑陋报。谤开方便门法故得癵躄报。谤正直经故得背伛报。贫穷下贱为人所使者。经备万德称为富贵。谤富贵经故得贫穷报。乘于一乘自在无系。谤自在法得不自在报。故为人所使。此经能破凡夫二乘菩萨之病。谤无病经得多病报。若修医道者。谤顺理法得违法报。常处地狱下第二周重明三品罪。以生在人中谤法余业。续更毁经故复堕地狱。亦有三品。初生地狱。在余恶道下明堕畜生也。若得为人下明生人道也。深着我见者。自上已来明受三品苦报。此文辨以乖至理故增长诸惑。则具三障也。深着我见谓愚痴也。次明嗔恚。淫欲下辨贪也。告舍利弗下第二总结。以理备众德。谤圆理之经具招一切苦说之不尽。岂虚言哉

问。不信法华入地狱信者作佛者。今有五逆破戒人信法华得作佛不。持戒不信法华堕地狱不

答。五逆人不定。若值善友如阇王得灭罪作佛。不尔者虽信此经不免地狱。持戒人不信此经亦入地狱也。若有利根下第二广释劝义。亦开为二。初明为十人说。第二总结。别明十人则为十段。故亦得开为五双。初过现一双。现在利根过去值佛。第二出处一双。出则慈悲四生。处则独静山泽。第三内外一双。外则舍恶近善友。内则持戒清净。第四自他一双。自则质直无嗔。他则为众说法。第五始终一双。始则一心求法。终则顶受修行。第二结劝如文

问。第三双云舍恶近善。是何等善人

答。如常啼品。能说大乘无所得法。又能示众生是非道。即是众生之善友也

问。既为一切智四方求法。复云何不受余经一偈。云何成一切智耶

答。如大品云。虽遍学诸道而不取证。以遍学诸道故成一切智。而不取证如不受余经一偈也

问。涅槃经云一切经书咒术皆是佛法。今云何不念外道典籍耶

答。涅槃今欲收一切法皆入佛法破诸外道。自言有法今令始行之人专心道门故。不念外道典籍也

问。取此中十人正意明为何等人说耶

答。大意取解行人耳。有解则堪相对。悟有行则是道心。若闻实说则能如说修行也

法华义疏卷第六法华义疏卷第七

        胡吉藏撰

    信解品第四

信解义六门分别。一来意门。二释名门。三出体门。四信解相门。五信解位门。六同异门。来意门者。为中根人说法凡有四章。初正说已竟今是第二中根领解也

问。方便品云。若实得阿罗汉不信此法无有是处。若尔闻初法说即应领悟。何待譬喻方信解耶

答。经言必信者。盖据始终为言耳。不言初法说即能信解。又中根之人初闻法说虚心已信。但由未解故至譬喻方得分明。所以今文与方便品不相违也。二释名门者。然信解之名有离有合。所言离者凡有三义。一者疑除称信执破名解。疑是犹预之名。信是决定旨。声闻犹预权实踟蹰一三。此疑既息故称为信。即信三是权信一为实也。执破名解者。解是了悟为义。执是迷执之名。既执三为实有则封一为实无。此执既除是故称解。解者解三是无悟一为有。此释出注法华经。故彼云不疑所譬曰信遂悔封言称解也。二者信起于不信解生于不解。不信者不信三权一实。此心遂改是故生信。信者信三为权信一为实。虽复信三为权未解所以权。虽信一为实未悟所以实。今遂悟所以权遂解所以实。故名为解。此即信在其初解在其后。故智度论云信为能入智为能度。即其证也。然初信非无有解但解浅故名信。后解非无有前信信深故名解。三者信破邪见解破无明。故涅槃经云有信无慧则长无明有慧无信则长邪见。今有信故破邪见有解故破无明。则二法相资也。但此义难明。今更以四句释之。一信而不解虽复虚心信受而未能解。谓钝根正见人也。二者解而不信谓利根邪见人也。三亦信亦解谓正见利根人也。即四大声闻也四不信不解谓钝根邪见人也。次合释信解者略有二义。一者上有所对二下有所形。上有所对者解有二种。一者见解二者信解。凭师义少见理情多如诸菩萨。故譬喻品云若有菩萨于是众中能一心听诸佛实法是名见解。若凭师义多见理情少。故前文云其余声闻信佛语故得入此经非己智分则是信解。今对于菩萨见解故目声闻为信解也。二下有所形者信是决定为义虽。因佛得解解心坚明谓理必尔。不同凡夫悠悠之解故云信解。三出体门者依阿毗昙信解有二体。信是善大地中信数。解是通大地中慧数。依成实论信之与解并以心为体。然心上有信解之用故义说为二。今明若见有心与数异体及以一体皆是一异执见。非信解体。后门当具释之。第四信解相门者旧云信解义多不出四句。谓权实有无。以三乘为权一乘为实。道理唯一无有三乘。今明盖是一往封执言未是虚心妙悟。若必执一乘是实三乘为权舍三而取一者还是取舍有所得心耳。涅槃经云有所得者名为二乘。犹未领悟何名信解。又若有所得则无道无果。下文何得云我今得道得果耶。又若言三是定无谓一为实有。犹是有无二见。如方便品云若有若无等具足六十二。既具诸见即便有爱见。爱见即是烦恼烦恼故业业故受苦。如此之人如服甘露还成毒药。是即旧病不除新惑更起故非信解相。今言信解者可寻经本宗。方便品云诸法从本来常自寂灭相。何一何三亦非权非实但倒情既重不可顿阶。故方便诱引渐令开悟。故前说五戒十善以止三途之恶。次说三乘之圣令舍三界之凡。乃至欲息三乘之粗故明一乘为妙。如此皆是对治悉檀。以榍出榍用轻倒除重倒耳。智度论云譬如执事比丘举手唱言众皆寂静。是为以声遮声非求声也。说善止恶非留于善。乃至说一除三宁存于一。若能三一两舍权实并除心无所依乃名信解。故方便品云我以无数方便引导众生令离诸着即其证也。第五明信解位者声闻回小入大。始得入菩萨十信之位。故前文云汝舍利弗以信力故得入此经即其证也。又真谛三藏云十七地论文亦作此判。又理数应尔。学小乘犹未信大。今破小执而信大者则知始学十信也

问。声闻回小入大得入十信位者。为入十信初心为十信满足耶

答。但入十信初心故涅槃经云。须陀洹人八万劫到乃至辟支佛人十千劫到。所言到者至十住初心。故知回小入大未具十信也。真谛三藏云阐提有二。一凡夫二者二乘。凡夫阐提不信三一二乘阐提信三不信一。今闻法华破三始得入菩萨十信位。所言十信者信进念定慧五根为五。第六不退心第七回向心。第八戒心第九护心第十愿心

问。回小入大至十信是何信耶

答。但得初信心耳。何以知然。如前引罗汉二万劫十信始满。故知但是初心

问。直往菩萨十信与回小入大十信何异

答。互有优劣。直往菩萨十信方便用强波若用弱。以诸菩萨多修众行济度众生故方便用强。不欲专心修于空观断除烦恼故波若观弱。二乘专修空观以断烦恼故波若观强。今回小入大始学行行度物故方便用弱

问。罗汉回小入大既在十信。为在界外受生为在界内受生

答。界外受生如释论及胜鬘经。皆云罗汉三界外受反易生。直往十信菩萨则在界内受生

问。若尔直往十信则劣回小十信则胜。何得前云回小之人在初心耶

答。已如前互有强弱释之。回小之人偏修空观断除烦恼故在界外受生直往之人不专观空断结故在界内受生。而涉有化人慈悲深淳则回小之人所不能及故直往为胜

问。二乘断结受生是菩萨何位

答。依法华论释分别功德品。地前菩萨界内受生。登地已上界外受生。依智度论七地菩萨肉身中得无生忍。舍肉身即受三界外法性生身。依真谛三藏释摄大乘论意自十行第六心去则三界外受生。经论不同难可详定也。第六同异门者凡有七异。一略广异。身子述解则略中根陈悟则广。二远近异。身子近序现在迦叶远陈往昔。然身子序现在但从鹿园已去至于法华。迦叶自华严已去竟一乘之说。三通别异。身子别序自身迦叶通陈一切众也。四有无异。上无譬说今则有之。五少多异。上但序三教今具述五乘。六欢喜异。身子昔忧今喜迦叶昔不怀忧。但今非意所求忽得大珍故生欢喜也

问。何故尔耶

答。盖是互现不同又示身子利根能推理同教异。故昔忧今喜中根之人但保执小教谓为至极。故昔不怀忧也。七约人异。上根领解唯有一人。中根领解则有四人。下根领解其数无量也

问。毗婆沙言一切声闻开为三品。上根唯一人以身子独六十劫修行故。中根亦一人谓目连也。余一切声闻并属下根。今何故中根有四人耶

答。目连乃是声闻之中根悟入大乘。未必胜于迦叶。故入中根之数也。品开为二。初经家序其得解之相。第二发言自述领解。就初又有四别。一辨得解之人二明所闻之法三内心欢喜四外形致敬。初人法一双后喜敬一双也。四人之中初明善吉者。或可当时起席善吉在初故尔。或可善吉有转教之工故在初列也

问。净名经四大声闻与今何异

答。彼经明身子之慧目连之定善吉空解迦叶有行。以此四人为大声闻。此经明身子利根独拔众人之外非四大声闻所摄。乃以善吉解空旃延达有迦叶头陀目连禅定也

问。度佛境界经明八大声闻是何人耶

答。未见经说。意谓十弟子中四大声闻即为四人。又三藏法师云迦旃延解修多罗藏。优波离解毗尼藏。富留那解阿毗昙藏。阿难总持三藏。合八大人也。从佛所闻下第二明所闻之法即是得解之缘。但得解之缘凡有二种。一以法为缘二以人为缘。即授身子记是也。以法为缘现生欢喜。以人为缘预欣得记故喜也。发希有心下第三内心欢喜正是领解也。即从坐起下第四明外形致敬。偏袒右肩者未起之时正被袈裟。外国依律不着障[月*皆]及偏袒衣著者得突吉罗罪。今言偏袒者直是露于右肩更无内衣也。而白佛言下第二发言自述领解就文为二。初正述领解次叹佛恩深难报。以解由佛得故叹佛恩又良由领解方识佛恩故叹佛恩深以成领解。初文又二。前长行次偈颂。长行为三。谓法譬合。以类相从开之为二。初法说略述领解次譬说以下广述领解。前略后广为解义故。就初又二。第一序昔迷第二述今悟。序昔迷又二。初明执小故不求大。二明闻大亦不求大。所以但明此二者盖是具迷大小二种教也。佛说小本欲令悟大。如举指本为示月。今逐执小不求大守指而忘月。盖是迷小教也。二者昔亲闻大法令其舍小悟大。而遂乐小不欣于大复是迷于大法。自灵山之前唯此二病故具序之也。我等居僧之首者四因缘故不求无上菩提。一者居僧之首但是诲授于他非自进求之时也。二年已朽迈者意志衰毕不堪自进业也。三自谓已得涅槃者谓所得究竟不更修因也。四无所堪任者沉寂空理不能更须修行。如四河合流同注海口非大力龙莫能自返。三解脱俱流注涅槃海。声闻小力不能自出故云无所堪任。亦如净名经云犹如败种不任生牙。具此四义故不进求菩提也。世尊往昔说法既久第二明闻大不求于大。前迷小教后迷大乘者以佛初说小后说大故也。就文为三。初明欣小不乐大。次解释之也。后结也。说法既久者说大乘法久也。身体疲懈者心不乐大。故不能忘惓所以疲懈也。但念三空者厌此报身欲入空以忘之也。于菩萨法下上明乐小今不欣大。游戏神通者大士现变不难喻之如戏。又现通度物可以自娱故名为戏。又如通非真实故称为戏也。净佛国土成就众生者起愿为净土兴行为成就众生也。心不喜乐者前明住小不求于大。今明非但不求亲闻大法亦不一念好乐。所以者何下第二释不乐大也。就文为二。初明昔不乐大。又今我等下明今不乐大。于佛教化菩萨下第三结不求大。我等今于佛前下第二明今了悟序得解欢喜。闻授声闻记者明得解缘也。上虽闻法譬二说义犹未决。闻授声闻记方审一乘。又法譬二说为令声闻作佛故授二乘记。是此经之正宗故偏举之。智度论云法华经授二乘记作佛即其证也。心甚欢喜正明欢喜也。不谓于今忽然得闻者释欢喜义则简异身子。身子以昔忧故今喜。迦叶本无心悕求非意而获大宝故喜也。深自庆幸者前明欢喜今自庆也。获大善利者即佛道也。世尊我等今者乐说譬喻以明斯义下第二广序领解也。又开为三。初请乐说二正说譬第三合譬。上来法说略序释迦一期大小二教事犹未尽。今举喻广述无量事及始终法门。方得显迷悟之情及叹佛功德也。以明斯义者譬文虽长但明得失义。初二章为失后章为得。设譬明此二义。譬若有人下第二开譬。今以三门释譬喻义。一来意门二少多门三领解门。来意门者依法华论说火宅譬破于凡夫。明穷子譬斥二乘人执。所以前破凡夫次须斥二乘者示次第法门破病阶渐也。声闻人谓三乘所得涅槃法同三乘并是三无学人亦无异。故今明二乘所得法如彼草庵。如来所得法犹如大宅。二乘之人犹如穷子。如来之人如大富长者。是故迦叶自说大小具明优劣。令诸学小乘人舍小入大故说此譬喻也。二者令诸菩萨知大乘尊胜小乘鄙劣。决定住大不退取小故说此譬。又令禀佛教人具识释迦一化始终法门。知权实前后浅深显密等教。故说此喻也。第二定譬少多门者释此喻不同。今宜开为十一。初为父子喻。二中途相失喻。三子渐还乡喻。四父子相见喻。五唤子不得喻。六冷水洒面喻。七诱引还家喻。八付财密化喻。九陶练小心喻。十委嘱家业喻。初为父子喻者释迦于过去世时为其说大乘法名之为父。其曾禀大化故称为子。故下文云此是我子我之所生也。中途相失喻者观心微弱烦恼强盛为惑所牵流浪生死子失父也。如来觅其大乘善根成就不得谓父失子也。子渐还乡譬者法种众苦乐求涅槃故苦极有反源之义。故积习善根渐有趣向大理故名子渐还乡譬。父子相见譬者于一形之内大乘善根成就。有悟入大义名子见父。见其一形之内大乘善根成就名父见子。唤子不得譬者初成道时大机未熟不堪受大化故名唤子不得。冷水洒面喻者初成道时大乘善根未熟但有人天善根成就。故为说人天之教如冷水洒面即便醒[酉*吾]故名冷水洒面譬。诱引还家譬者前于道树下说人天教。盖是世间生死乘譬向他家。次趣鹿园说于二乘是出世法令从世间归于出世。出世之法是长者家。故名诱引还家譬。付财密化譬者小志渐移大机远动故命说大法密诲小心故名付财密化譬。陶练小心譬者从波若以后法华之前诸方等教毁訾声闻赞扬菩萨。令稍鄙小心渐欣大道名陶练小心譬。委嘱家业譬者小执既除大机成就故为说一乘令绍继佛业故名委属家业喻也。第三颂解门者此之十譬还领解譬喻品六譬。初为父子譬领上总譬中长者及三十子也。中途相失譬领上见火譬中汝诸子等先因游戏来入此宅也。子渐还乡譬还领见火譬中闻有人言汝诸子等先因游戏来入此宅。盖是众生有机扣佛故佛应入生死有机感佛即是子渐还乡。佛应入生死如父知子应反故中止一城。父子相见譬还领见火譬。众生有机感佛如子见父。佛应入生死如父见子。今三譬同领上见火譬。但大格相拟不可一一全同。今唤子不得譬领上救子不得譬。冷水洒面譬领上三车譬中如此种种之言也。上文云如此种种羊车鹿车牛车即是。三乘三车之前明种种者谓三乘之前说人天乘也。盖是注经旧解勿得疑之也。诱引还家譬领上三车中羊鹿二车化子得譬。领上二车故今还明二使人也。付财密化陶练小心二譬领上三车中大车。以三车中大车正明大乘法即是法华之前诸大乘。是故二譬还领之。委嘱家业譬领上等赐大车譬。所以不领第六不虚譬者既得领解即知佛不虚故不领不虚譬也。然旧经师一向以后譬必须同前。盖是失经旨趣。所以然者佛及弟子共显发密教调伏众生故转势说法。故佛说六譬于前弟子明十譬于后。乃大格相领而形势各异。宜用后十譬次第为正。领前六为傍例如譬喻品及方便品大意乃同而转变即异也。譬如有人者第一初为父子譬也。此文明父子凡有四番。初番就子明三譬。次父就文明三譬。次父就子明二义。次番约父明二义。初文就子明三譬者一初为子时譬。二中途失父譬。三子渐还乡譬。后就父亦明三义。譬如有人者即此会三根声闻也。有人即譬子义。昔佛为菩萨时如行而说众生如说而行。同共一行义如父子。幼稚者此明小义子通大小故别序幼稚。受化始尔为幼观解微弱称稚也。舍父逃逝者第二中途相失譬。由受化始尔观解微弱不能自固遂为惑所牵所以失父。佛能说教表理以佛。为父迷教惑理不能感佛为失父也。但失父有二。一根本失如涅槃经云。随其流处六味不同失佛性故六道差别。由此失故诸佛菩萨说大乘正教令反失从得。但众生惑强观弱复惑教迷理。是为失中复更失也。前是任运失后是学教失

问。后失有始前失何时耶

答。前失有始无始二俱有过。故智度论云深水火坑俱能害人有始无始俱害正观。华严经云有始无始是无记问佛不答之。又经云有一比丘问佛。十二因缘自作他作无明自起是有始义。名为自作他作者更从他起是无始义。佛种种因缘而呵啧之。如人为毒箭所中但须请医拔之不应求毒箭所以。如此一句是学者致迷之处故略述之。逃逝者迷教惑理是隐密之事而众生不知不觉故名为逃。背理向惑所以称逝。久住他国者以大乘理为自国背理起惑惑即是他国也。违理积时为久执惑不舍为住也。或十二十至五十岁者释上久住之义也。十谓天趣二十谓人趣五十即余三趣。初失观起惑犹轻故生天。惑势渐重故生人。惑势转重遂至三途。而言或者不定之辞不必备经或可遍历。又言或者如下五十余年。余年既拟修罗今或还例之也。年既长大者以去大化久故称长大。加复穷困者背化转久。新善不生为穷旧善稍尽称困。穷子之名显在斯句。驰骋四方以求衣食者第三子渐还乡譬。衣食者人天乐也。四方者四生也。又四方者除地狱畜生余四趣也。无处不求为驰骋也

问。众生既背理起惑具受众苦。善根何由生耶

善根有三义故生。一者法种众苦而乐求涅槃故苦极而求离。二者众生曾禀大化而善根种子不可朽灭。三者诸佛菩萨有三种化。初一往化即昔为说大乘。二随遂化众生背化起惑流浪生死。诸佛菩萨随入生死而化度之。三毕竟化令得成佛然后乃舍。今是三化之中随遂化故得生善根也。渐渐游行遇向本国。本国者即大乘理也。法华三昧经云反源尽欲室令人归古乡。古乡名无为无为故号清净室。佛答婆罗门云波若郡本际县超入城绝句里萨波若树．下止。背恶向善善理不可顿修为渐渐。当此时唯有人天善望大化难至亦是渐渐。人天善非是本善失其所居为游行。人天善虽非本善而善力冥资大机故言遇向。释论云有所得善者是无所得初门即其事也。前即舍父之始宜名为背。今是归本之初故云向也

问。若渐渐游行犹是人天善者。人天善犹是五十余年则犹住他国。何名游行遇向本国也

答。经既称渐渐非但有人天善根。亦有发大心行大行义。就初为言故云世间善也。其父先来求子不得此就父明三义。一为父时二中途失子时三中止一城时。其父者即初为父时也。对上第一初为子时也。先来求子不得者对上第二子失于父。由子失父故父觅子大乘善根成就不得。中止一城者第三对上子渐还乡也。就譬而言父子天性感应道交。子既渐还本国父则中止一城以待子也。就理而明三根声闻道缘应熟。如来居法身地照彼机缘故垂应成佛也。中止者据身而言。此文始终具有三身。前言求子不得即是法身谓前时也。今是舍那身初成道时化诸菩萨未化二乘名中止时。后脱珍御服着弊垢衣为释迦佛化彼二乘谓后时也。如人趣道未至所期而中道止息。就声闻领解为譬如来出世为化诸子。大机已熟故但化菩萨未至化二乘处。故云中止。亦得昔化今化二楹之间故云中止也。垂应居一方作佛故言一城。又垂应为显一道故名为一。防于邪非以称城也。其家大富者就迹而言。昔菩萨时共为父子而子背父流浪生死贫穷困苦。而父失子行满成佛众德圆具如大富也。此文大意对子贫穷叹父巨富故无物不备也。就文为三。一叹化主二明徒众三辨教门。即是真法说者及以听人略拟初成道时华严之会有三事也。若取上中止一城拟于化处则是摩竭提界寂灭道场也。大富者佛地众德也。十力无畏其体可珍义同七宝。众德中养慧命者如仓安法身者如库。又法宝无能窥窬亦如仓库。圆满义如盈出用义如溢。多有僮仆者第二明徒众。初成道时所化非一故言多有。外凡如僮仆内凡如吏民。登地已上能助佛扬化为臣佐也。此时未有声闻不得举二乘合之。象马车乘下第三明教门也。象马能负重致远教门能运凡登圣。即五乘之教如华严性起品具说五乘。无数者八万法藏及不可说法门也。出入息利者化从佛出为出化工归佛为入。教授为资息回向为大利也。乃遍他国者化流十方也。商估贾客亦甚众多者俗民有四业谓农商工估。农者田也。商者商量物价谓行货也。工者工匠。估者坐贩也。此字应西下为贝。今经文估字乃是估税之估耳。贾客者(假音)上是货物人。今贾客者即贾物人。此土禀道传化他方谓商也。此土受化即此土说法谓估也。通禀前二人所化如贾客也。即成道时有斯事故借以为喻也。时贫穷子下第三重序子就文为二。初明近父缘由。二正明近父也。游诸聚落经历国邑者近父缘由也。注经解云。恶趣如聚落善趣如国邑。皆是生死所经历也。又释聚落小故喻人乘国邑大故喻天乘。又释此明善根渐增长义如游聚落渐至国邑。然上中止一城既是佛初成道时穷子不应始游历生死。但今追序其往事。所以得至城者由迳历国邑所以至耳。由过去从恶趣至善趣及以善根渐增长故得近大乘理也。遂到其父所止之城者第二正明近父。善缘渐牵近至理也。父每念子下第四重序父就文为二。初明失子之苦谓大悲心。次假设得子之乐谓大慈心

问。前已明父与今何异

答。前明父求子不得故中止一城即是求子大乘善根不得。而垂应化诸菩萨。今明虽化菩萨而心不舍二乘故言父每念子。若以二化分门者上不废家业谓化菩萨也。从此文去尽譬皆是化二乘也。复每念子者以其背化久处生死大悲常欲济之是故念也。而未曾向人说如此事者初成道时但说菩萨大行。未说二乘人本是佛子曾受大化今违化久也。又释即詺二乘为人。初成道时二乘大机未发不堪闻说是子也。但自思惟心怀悔根者。悔恨者昔化不浓遂令失大乘流浪五趣也。盖是悲心内切寄名悔恨耳。自念老朽者释念子之意一方之迹一时之化将灭不久故言老朽。又废大化来久故言老朽。又如来亦以化工为命。所化之善既弱能化之工亦微义同老朽。又最后应付如老朽也。多有财物者文理无量也。无有子息者初成道时虽多菩萨实堪绍佛业。但为二乘作譬故言无有子息。二乘未能自悟如无子。复不未能传化如无息也。是以殷勤下结念子意有二因缘。一佛去世二无人绍继故法宝散失所以忆子。复作是念下第二作假设复子之乐。上忆子之苦作前无大机譬。今明得子之乐作当有大机譬。以佛必知当有大机堪绍佛业。是以预想得子乐耳。无复忧虑者既一期得子即付之以法财。令传化不绝为无尽法灯则畅佛本心。故无复觅不得之忧亦无散失大乘法财之虑也。世尊尔时穷子下第四父子相见譬。于一形内大乘善根成就必得领悟为子见父也。佛见其一形内必悟大乘如父见子。就文为二。初明子见父次明父见子。子见父中有四句合之为三。初明见父缘由次正明见父后辨正见父不识起避畏心也。佣赁展转者由佣赁展转故至父舍。由修行增长冥资大乘。如遇到父舍。父舍者大乘正理也。必应悟理与理交接如至舍也

问。初云向国次云到城今明至舍此三譬何义耶

答。此皆是去悟一乘近远义耳。大意明悟一乘善根凡有三品。一者下品善根去悟一乘理远如向国。中品善根去悟一乘理稍近如到城。上品善根与理交接如至舍也。住立门侧者始未信受如住。终必当行如立。未有大机不堪受大教如门侧也。遥见其父者第二正明子见父。始未信受如门侧终有悟大如遥见。其父者上序能见之机今出所见事也

问。初云舍次云门今言父后明珍宝。此四何异耶

答。皆是大乘正道随义立名。至理为众圣所栖如舍。虚通无碍称门。能生物善根为父。可贵重故如珍也。序所见文凡有六事。而初五别明所见。但所见既多不可具序。后一句总而结之。初五句者一见父踞师子床宝机承足。二眷属围绕。三庄严其身。四左右侍立。五覆以宝帐乃至出内取与。此五皆是叹父之富责。如叹佛住大乘无德不圆无累不尽。以对小乘贫贱令时众起欣厌二心也。踞师子床宝机承足者宜就佛内外二德释之。外德者华严经云处莲华藏师子之坐如踞师子床也。其地金刚谓宝机承足也。内德者一乘以中道正观为体。不受断常故云无畏。中道正观必履实相之境如宝机承足也。诸婆罗门刹利居士皆恭敬围绕者上叹能化今美所化也。又上叹富今叹贵。又八地已上法身清净如波罗门七地得无生忍名。入佛眼地。即是王种义同刹利。初地以上檀行满足义同大富譬居士也。皆翊赞如来助佛扬化故云恭敬围绕也。如华严十世界微尘数菩萨也。以真珠璎珞价直千万庄严其身者重叹能化也。形无非法则是法宝庄严。法宝庄严有其二种。一者外具相好二者内备众德。皆广劫所修世间无比故云价直千万也。吏民僮仆手执白拂侍立左右者此重序所化也。吏民者内凡也僮仆者外凡也。前辨登地以上菩萨从高位以至下。今序地前人亦从内以至外。此是说门次第非修行阶渐。亦得吏民僮仆四种拟宜地前四十心也。俱禀大化皆修除垢之法如手执白拂也。实是众生除垢。言为长者拂尘者以众生病故菩萨病众生除故菩萨亦除也。悟浅如左照深如右。随行所取故云侍立也。覆以宝帐垂诸华幡下叹教门也。慈悲荫覆为宝帐。然众生断结如长者拂尘。亦慈被众生如帐荫长者。四摄下垂喻如华幡。以禅定之水洒净戒地。淹烦恼尘散智慧华。阐扬正法以示于人如罗列宝物也。化从佛出故言出化功。归佛故言内。前人禀道为取。如来授道为与。畏则为威爱则为德。又折伏名威摄受名德。人天无敌故称特尊也。穷子见父下第三明子见父不识起避畏心。理能伏情名有大势力情惮于理如即怀恐怖也。悔来至此者小机禀大进无入理之福退有违教之罪故称为悔。此或是王或是王等者神通化物自在如王说法化物如王等。犹是上衣裓机案二物耳。有人言法身如王报身如王等。非我佣力得物之处者大乘道玄理绝。非修五戒十善得人天小果之物处也。不如往至贫里肆力有地者上明不堪受大今明正堪行小耳。人天乘是生死法无出世圣果为贫里。肆力者恣力也。五欲果报如衣食。求小果之乐不难名为易得。若久住此或见逼迫强使我作者此明小机不应住持大教。若住持大教则教不称机。违情为逼迫非乐为强使也。作是念已疾走而去者背理顺情。其义如崩走故云疾走

问。穷子前何故来今何故去耶

答。前明大机终有发义譬来。今据始有小机不堪受大故去也。时富长者下第二明父见子就文为三。初明见子处。二明见子便识。第三明以识故欢喜。然父子相见实无前后。但欲示由感故应故初说子见父后明父见子耳。于师子座者见子处也。见子便识第二句见其终有大机识子曾受大化也。心大欢喜下第三句由识是儿故心生欢喜。虽始无禀大之机终有悟一之理故言心大欢喜。即作是念下释欢喜凡有三意。初明既有可化之理。将可付以法财故欢喜。我常思念是子下第二明本愿满故喜。慈悲者常欲被物。但昔日未见可救之理而今化缘既发适慈悲之愿是故欢喜也

问。生善由佛云何名为自来耶

答。虽由佛为外缘。但善机是众生之感称之为自。以其冥发所以名来也。我虽年朽由故贪惜者第三明老年见子喜之甚也。财物于老年无用而贪惜为子。教法于佛乃无用贪惜为于众生也。即遣傍人下第五唤子不得譬领上长者救子不得譬。上火宅中开诫劝二门化子不得。今领此意而文开为两别。初各领二门化物不得。次合领二门息化。初别领二门化物不得即为两别。第一正明大乘化子不得。第二假设强授之以大则有损无益。此二与方便品二思惟大同。不与火宅之诫劝文同也。旧经师云领火宅诫劝门者失经旨也。就初文为二。第一正明为说大乘。二明无机不堪。初文二句前明遣使譬佛念欲遣化物。初成道时即欲为二乘人说于大法故名则遣也。傍人者在长者左右者故言傍人。大乘是佛常用法去佛亲近故称为傍。教能诠理如人能示语故云人也。急追将还者初成道时即显说大乘欲令了悟大乘故称为急。追其惑情使其反本还受大化故云急追将还。尔时使者疾走往捉第二明使者受旨。譬佛正说教被缘。教能宣传佛意譬之如使。初成道时则欲为二乘人说于大法名为疾走。教正被缘故称往捉也。穷子惊愕称怨大唤我不相犯何为见捉者第二明无机不受化也。大教被于小机非本意所期故云惊。小机不恻大教所由为愕。大教违小心而强授之为称怨。怨谓怨枉怨枉事甚为大显彰于外称唤。教大而机小其犹方盖而圆底理不相称名不相犯。不应授之如云何为见捉也。使者执之逾急第二假设。强授之以大则有损无益就文亦二。前明强授之以大。次明无益有损。必欲授之以大如执之逾急。知机小不堪大违情使其了悟为强牵将还也。于时穷子自念无罪而被囚执下第二明有损无益。无大机称为无罪。以大教被之如被囚执也。此必定死者教大机小乖其本情。心生不信则起诽谤断于慧命如必定死。又现世起谤后堕地狱亦名定死也。转更惶怖闷绝避地者小机闻大起惊疑怖畏故名惶怖。不能解大称为闷绝。又不能行譬之僻地也。父遥见子下第二合明息化就文为二。初正明息化。二明息化称机。初文又二。前念欲息化。二正息化。就初又二。前开两章门。次释两章门。开两章门者。前开息大章门。次标授小章门。所言遥见者。既不受大化。见彼小机去理遥远故名遥见。念欲息化如语使言。大乘理不容小机为不须此人。未可以大化之为勿强将来。以冷水洒面令得醒悟者第二标授小章门也。即是第六冷水洒面譬。初成道时既未堪授大化。但有人天小机故为说人天乘也。人天人机喻之如面。五戒十善能释迷解滞称彼根情。譬之冷水也。莫复与语者不可说大也。所以者何者双释二门也。父知其子志意下劣者。此明有小机释上授小也。自知豪贵为子所难者。明大乘尊极释上息大化也。审知是子者。知其过去曾发大心故云审知是子。而以方便不语他人云是我子者。此是释疑故来也。既实是子。何不语使云是我子令使往捉耶。即詺使为他人。犹是上傍人也。故今释云。虽云审知是子而以方便不得语使云是我子。此意明初成道时教门中不得说二乘人本是佛子。不说之意隐于实说即是方便也。前遣使唤子不得。谓不得以华严顿教化二乘人。今审知是子不语他人云是我子。即是不得渐说法华中一乘以化穷子也。使者语之下第二正息化也。亦有二句。初明大教不复被小机称为我今放汝也。随意所趣者顺小机行小教也。穷子欢喜下第二息大授小称彼根情也。亦有二句。初领息大。次领授小。以大教不称小机如被囚执。是故惊怖。息于大化称彼根情。故心生欢喜也。从地而起者领授小教也。牵往父所故僻地。放之故起行。不行大乘如僻地。堪修小教如起行也。尔时长者下第七诱引还家譬就文为二。第一雇子除粪譬。第二教作人譬。所以有此二譬者。初领隐实教起权教。次领隐本身起迹身。故初成道华严之会则双说从鹿园以去为双覆。至法华时为双开。今是双覆也。初譬有四。第一知小机喻。第二说小教譬。第三禀教得益譬。第四愍怪譬。将欲诱引其子者譬说二乘教意也。所以说二乘教者。欲诱引令悟入一乘也。而设方便者明诱引之事也。无二说二故称方便也。密遣二人者出方便之事也。若显灼云是长者之使。穷子则畏惮不受。若言开一为三。即是方便之三物不信受。故隐于此说而覆相示三故名密。二者昔说三乘是佛秘密之言。非二乘之所能解故名为密。三者虽复唱三密引归一故云密遣。四者说三乃欲令众生了悟非三非一言断意亡。是故此三名之为密也

问。安乐行品云佛教菩萨但以大乘法而为解说。佛今何故自说小乘耶

答。今文叹佛有知机力能说小为通大。安乐行品始行菩萨不知因小悟大但应说大乘法也。二人者即四谛十二因缘二教。能诠于理故名人也。形色憔悴无威德者释二乘教之名体也。教则浅近为形色憔悴。理非究竟为无威德。又生身相好不圆如憔悴。法身众德不满如无威德。又自调自度自净常行独善如憔悴。外无济物之功如无威。内无慈悲之心如无德。又菩萨有折伏摄受二能。折伏如威摄受如德。二乘不具故言无威德也。汝可诣彼徐语穷子者二乘教可施之于彼人为诣彼也。诱引将顺之言为徐语也。又大乘化物取成佛义速为疾走。小乘去佛奢缓为徐语。此有作处倍与汝直者。穷子前从地而起往至贫里以求衣食。即是行人天乘名为彼处。今对世间之彼故说二乘出世间法。名之为此。示四谛十二因缘是修行之所故称为处。示小涅槃之乐过人天之乐为倍与汝直。穷子若许者称彼根缘堪受小化名为若许。将来使作者从世间入出世间为将来。正禀于教令如说修行称为使作。若言欲何所作者小乘机发感化为欲何所作也。又释假设作机未解教意欲显教宗故有此责也。便可语之雇汝除粪者正教其修行断结显示小乘教之正宗也。以二涅槃之直与于穷子称为雇之。然后令彼断于烦恼名为除粪也

问。若以断结为除粪者。声闻但断见思。大士具除五住。则菩萨是大除粪人也

答。二乘见有烦恼可生故修解灭之。即是生灭断常故为鄙贱如除粪之人。菩萨了惑本自不生今亦无灭名无生灭观。故除无所除非除粪人也。故方便品云诸法从本来常自寂灭相。净名经云为增上慢人说断三毒耳。无增上慢者三毒即是解脱。故无所断也。我等二人亦共汝作者二乘不能离文求理。籍教诠理方能断结。则教有助智断结之功。为共作义也。于四缘中是增上缘。时二使人下第二领上为缘说教。缘教相会名为既已得之。为缘说教称具陈上事也。尔时穷子先取其价寻与除粪第三领上得益。贫贱之人其心局小恐不得直而有徒劳之弊。故先取其价然后乃作。二乘小心畏不得果。故前期涅槃之果然后修行断结。此譬即鄙之深也。其父见子愍而怪之第四父生愍怪。昔日本有大乘愿行而遂不受大法乐于小乘故可伤愍。愍不信大怪其取小。此中四大声闻作鄙斥小乘之譬。从上即遣傍人唤子不来至其父见子而生愍怪明好事唤子不来恶事呼而来何鄙之甚耶。今实得罗汉遂是除粪鄙贱之人。况未得果欲学小乘之者。如一形之内保执毗昙及成论者乎。又以他日于窗牖中第二领身之真应也

问。何故先领二教后领二身耶

答。要前照机不堪受一化信受二乘。然后隐法身而垂应迹然后为说小法。即是次第

问。云何为二教二身耶

答。即遣傍人谓一乘实教也。密遣二人谓方便教也。故前隐于实教而起方便教。二身者师子座之长者谓真身也。脱珍御服着弊垢衣谓化身也。既隐实教而说权教亦隐真身而起化身也

问。上譬喻品云。但明实教化子不得权教化子得。不明真应两身。今何所领耶

答。上品具有二教二身。门外长者谓法身也。惊入火宅谓应身也。是故今文还领上说。乃非是身教次第而大意有之故今领也。又四大声闻助佛扬化。佛既说教有权实。彼以教例身身亦有权实也

问。今文辨真应与譬喻品何异耶

答。譬喻品明门外长者即是法身惊入火宅谓应身也。今此文明居师子座长者即遣傍人。此譬初成道时卢舍那佛说大乘之教。次脱珍御服着弊垢衣语令勤作。即是隐舍那之身起释迦之化说小乘教门。故以实身说实教权身说权教。此并是迹中开本迹耳。就文亦四。一照机。二隐本垂迹。三说教门。四者明得益。此四即是次第。又以他日者。前是思惟不堪受大教堪受小教时。今是思惟不堪见本身堪见迹身故云他日也。于窗牖中者。长者隐大处而于小处见子。如不得用实智照小机而用权智照也。遥见其子者。见子去理远故名之为遥。又尔时犹居本身未垂应迹。去感尚远称为遥见。故下隐本垂迹得近其子也。羸瘦憔悴粪土尘坌污秽不净者出所照之机也。上明见其不堪受大教堪受小教。今照不堪见本身机堪见迹身机。无大乘之解为羸瘦。无大乘之行如憔悴。有凡夫二乘诸结使未除垢障所染。如粪土尘坌污秽不净。即脱璎珞下第二明隐本垂迹。初明隐本次辨垂迹。隐舍那之三德名为隐本。即脱璎珞谓隐解脱也。细软上服隐般若也。严身之具隐法身也。此非是法身地三德。何以知之。从中止一城以来竟又以他日遥见其子皆是初成道时有如此事。但二乘不堪见于此身故隐彼舍那示释迦耳

问。华严经云亦名为舍那亦名释迦文。即犹是一佛。何以开为二身耶

答。二佛有同义亦有异义。同义如向引文。异义如梵网经云。本身为舍那迹身为释迦。像法决疑经云。或见我身为报佛为百千释迦之所围绕。此与梵网意同。今欲显二教二身为异。本身说实教化菩萨。迹身说权教化声闻。故且用舍那释迦二佛以明本迹。然身处及教无有定判也。菩萨即见舍那在净土说大乘。二乘见释迦居秽土说小教。更着粗弊垢腻之衣者第二垂应身也。然二乘所见具有八相成道。今文略举凡圣二事。即更着粗弊垢腻之衣即父母生身同物有大患也。尘土坌身示同心有烦恼也。如纳妃生子为贪使。六年苦行为痴使。骂五人为嗔使。亦有三毒如尘土坌身也。右手执持除粪之器。上二句示凡方便。从兜率天下竟道树之前事等也。今示圣方便。即树王成道及趣鹿苑转法轮事也。又前示凡方便以圣同凡。今示圣方便令凡同圣。右手执作之便。真智有除结之能。手执器故除粪。智会理故断惑。状有所畏者释断结之意也。畏粪污身是故除粪。恐惑染心所以断惑。如三毒是三衰因。故出城四门即知贪欲致老嗔恚致病愚痴致死。畏三毒能生三衰。是故断惑。语诸作人下第三明说教。即是趣鹿苑转四谛法轮也。就文为四。一诫劝二益价三安慰四称叹。汝等勤作者劝令精进也。勿得懈息者诫令勿懈怠也。精进成众德之根。懈怠败万行之本。是故命初以诫劝也

问。趣鹿苑应说四谛。云何乃明诫劝耶

答。领教权实中已明说二乘法穷子修行。今隐本垂迹明教作人义故诫劝也。以方便故得近其子者释隐本垂迹之意也。佛理玄远。非此方便无由近之。后复告言咄男子第二明加价也。汝常此作者令其常在正教之中修行也。勿复余去者勿放逸入五欲心也。当加汝价者。上虽劝常在此作诫令勿复余去。恐不受诫劝故以加价诱之。旧云初成道已与人天乘竟今复赐其出世二种涅槃名为加价。今谓教权实中云此有作处倍与汝价。即是对人天乘说出世涅槃名为倍价。今言加价者于倍价上更复加之。谓涅槃果外诸余功德为加价也。诸有所须者涅槃果外余功德智慧悉是资神所用也。盆器米面下别出所须物也。凡加四物。一瓮器有盛贮之用。如戒为定慧之本。经云依因此戒则生诸禅定及灭苦智慧也。米面者即所食之物。米粗喻定。面细如慧。盐酢之属者五门三观等也。无常碱味。苦为酢味。不净无我是此比例。故云之属。注经解云定粗如米。精进行细如面。无碍如盐。解脱如酢。盐酢为众味之主。双道为二乘之根。有人言盆器如四禅。米面谓禅地诸功德。有漏功德粗如米。无漏功德细如面。盐酢为众味之主。止观为诸行之要也。莫自疑难者修之必得也。亦有老弊使人须者相给者虽与诸物复须人使。今故与老弊使人也。上赐其三学自德。今与其六通外化。菩萨神通运用广远犹如少壮。二乘神通力用狭劣喻老弊也

问。何故许其瓮器乃至老弊使人

答。欲示二乘人功德智慧浅劣不足珍贵用此以斥保小之流令厌小欣大耳。好自安意下第三明慰喻。非止内给所须。外复有善言慰喻令安心于道门。故云好自安意也。我如汝父者欲密示是父子也。就昔为言。声闻是小行。佛为大乘。非真父子。但禀教生解故言如子。勿复忧虑者若修无漏必不惧老病死苦也。所以者何我年老大而汝小壮者释父子义也。以道高是为老大。德浅为小壮。此领鹿苑时师资之义也。汝常作时下第四称叹也。上明内给所须外善慰喻。今即如说修行得于教益故称叹之也。如说行故无欺。常精进故无怠。知教不乖理故无嗔。得教益故无恨。知教等益无私故无怨言也。都不见汝有此诸恶如余作人者明无五种过故云无恶。反此五种则余作人也。自今以后如所生子者。上叹无过今为其立名。既无五失则有五德入于无漏。从佛口生从法化生。取佛法分故名如所生子也。即时长者更与作字名之为儿者。既入无漏为立贤圣之名称为佛子也。尔时穷子虽欣此遇下大章第四明禀教得益。蒙上加价慰喻称叹三事故云欣此遇也。犹故自谓客作贱人者。未识大乘为客作。尚守小分为贱人也。由是之故于二十年中常令除粪者。由未识大乘守于小分。是故于二乘法中修行断惑。二十年即二乘教也。有人言。断见思二惑为二十年。有人言。断见谛惑一无碍一解脱。断思惟惑九无碍九解脱。名为二十年。故杂心云。一种一种九种九种合二十也。过是以后心相体信者。上来序小乘法中修行断结竟。此下已去令其预闻大乘法也。过是以后者依二乘教修行断结得果已后也。心相体信者大机渐发堪闻大教也。出入无难者闻大乘法不生疑心。然其所止犹在本处者虽闻大教犹谓是菩萨法非已所学也

问。付财之教即是大品。大品是大乘之初。自大品之前但明三藏。故释论云佛于三藏中未说菩萨行。若尔前未明大乘。声闻何由已解耶

答。大品前亦明已说大乘。旧相传云佛成道六年说鸯崛摩罗经广明大乘法。又云佛成道六年说大波若十万偈。不来此土。又仁王经明金刚波若在大品前说。此法中善吉已闻波若悲喜交集。即是出入无难事。良由已闻大乘故大机渐动堪付财耳。若大机犹未发者不堪付财故说大机已动也。尔时长者有疾下第八付财密化譬。因闻法华得悟大品故领大品付财教也。然大品之与法华虽同是大乘。但大品显教菩萨密化二乘。以显教菩萨故菩萨领解得记成佛。密化二乘二乘未悟。至于法华显教二乘方乃得悟。始知昔日大品以去即是教我一乘。所以作此领解者。盖是自伤之甚也。前说小令我入大而未解者其失犹轻。大品之时亲付我大法而我不知。盖是愚之甚也。有人言波若教中声闻已得悟道者。盖是未善法华付财譬意故作此说耳。今谓大品教明悟声闻。法华教辨声闻悟也。大品教辨悟声闻者有二种人。一者本是小乘闻说般若遂得小果。二者本是大乘人闻说波若证于罗汉。六十菩萨即其事也。法华教明声闻悟者亦有二人。一者本声闻人悟于法华并成菩萨。二者菩萨之人闻法华经疑网皆除住不退转。就文为二。初命二受命。命中为二。一命之缘由二正命。自知有疾者。有人言如来一化前说小乘后说大乘。从波若以前说小乘教。终波若以后竟于双林说大乘教。然化功讫喻于命终。今废少化譬同有疾。若闻大教则知双林稍近譬之将终。故云将死不久。有人言三乘化功为命。今将说法华三乘化功应断。断故称死。大品去法华已短故言将死不久。今谓说大品时去涅槃小近名为有疾将死不久。说法华去涅槃转近如临欲终时。正入灭度如死时也。不须余释。语穷子言下第二正命又有二。初付财次密化。如大品之初告身子转教之始命善吉也。我今多有金银者。如大品劝学中举因果德行八十余科故言多有也。其中德行能续慧命者如仓。能养法身者如库。内德圆满如盈。化功外流如溢。其中多少所应取与者。广说为多。略说为少。受法者为取。授法为与。注经云应根利钝为多少。随机抑扬为取与也。汝悉知之者令其知上略广受授之事也。我心如是当体此意者。上是付财今是密化。使善吉领佛心也。所以者何我今与汝便为不异者释上当体此意也。就昔而言。明善吉承佛力说即是佛说故云不异。据密教声闻者佛为法王应自化菩萨。而今令小乘弘大道化菩萨者。将明小乘之人终与佛不异。意在于此故云当体此意。又菩萨化他二乘自行。今令自行之人而化他。即密示二乘是菩萨也。又令小乘人而说大法。密令小乘人学大法也。依智度论释者。命声闻说凡有二义。一者显示教中明菩萨烦恼未清净。人不信受故不命菩萨。声闻烦恼清净人则信受故命声闻。二者佛与菩萨其德尊高。众有疑问不能自尽。故佛与菩萨不说大法。命于声闻则有下接之义所以命说也

问。龙树何故不依法华意释命说耶

答。夫前教未得开后教。后教必得开前。龙树但当教明义故作此说。又实有斯义。所以作此释之。后教开前者。命小人而说大法有二种义。一者得密教小人。二者得显教菩萨。若命菩萨而说大法。则唯得显教菩萨不得密教二乘也。宜加用心无令漏失者用心谓顺法随机。无令漏失谓勿违理差机。密表大法将为已任故有此诫也。尔时穷子下第二受命而说。就文为二。一者领佛语。二者不识佛意。谓不领密化。领知众物者。序品初身子白佛。三假品始善吉受命。所以受命者。佛不妄敕宜从命而说。而无希取一餐之意者。佛言劝菩萨而意在声闻。今但领其言未知是己物故不体此意。然其所止故在本处下劣之心亦未能舍者。上明不取于大。此辨未舍于小也

问。大品付财定在法华前不

答。初分经在法华前。何以知然。智度论云十二年未制戒已说波若。又仁王经云佛成道二十九年说摩诃波若。而此经云四十余年方说法华。故知大品初分在于法华前也。龙树释毕定品云。须菩提闻波若中明菩萨有退。又闻法华经说一切皆作佛。以二经相违故取决于佛。所以问云。是菩萨为毕定为不毕定。佛答云是菩萨毕定。则以法华为实说。若尔则大品后分在法华之后。故龙树云是波若非一坐一时说也。复迳少时下第九陶练小心譬。所以须此譬者。二乘闻大品既不悟。何因缘故至法华便解耶。故须明大品已后诸方等经陶练其心。令稍鄙小心渐欣大道。至于法华方得取悟也

问。此品始终明几教耶

答。凡有五双十教。一顿渐一双。初化子不得谓华严顿教也。从冷水洒面譬说人天乘至法华教谓渐说大乘。则顿渐一双也。顿教化直往菩萨渐教通化二种菩萨。此中所明正化回小入大之人。就渐教中人天乘为世间教。从雇子除粪竟法华为出世教。即世出世一双也就出世教中雇子除粪喻谓小乘教。付财譬谓大乘教。谓大小一双也。大乘教中付财命说陶练小心此二密教声闻。法华已去显教声闻。谓显密一双也。就密教中付财命说令小乘人说于大法以化小人名为自教。陶练小心明大人说于大法以化小人名为他教。自他一双也。则此自他两教名为密教。委嘱家业谓显教也。此五双十教非但领释迦一化总摄十方诸佛法门

问。初化穷子不得。以几种教门即柔伏其心后得入法华耶

答。初华严教门此教直往菩萨令入佛乘。从华严以后依此品始终之意凡有四教。调伏回小入大之人方得入于佛慧。言四教者。一冷水洒面即人天教。令其离三涂之恶。次雇子除粪譬说二乘教。令离凡夫烦恼。三者付财密化譬及陶练小心譬此之二譬化彼二乘。同令离二乘烦恼。所以但举此二譬者。以大法化小凡有二门。一者令小人说大以化小人。则付财教名为自教。二者令大士说大而化小人。谓大品以后诸方等经名为他教。一切大乘中唯此二事。故用斯二调其小心。然后得悟一乘也

问。此四教调伏小心得悟一乘者。此之四教悉是入一乘之方便。若尔四教应俱是方便说教耶

答。不然。前之二教是方便教。故籍方便教悟入一乘。则以方便教为一乘方便也。后之二教并是大乘即是真实教。但籍真实教悟入一乘。故以真实教为入法华之方便也。父知子心渐以通泰第十委嘱家业譬。就文为三。一父知子大志譬。二正委付家业譬。三领解欢喜譬。初有二句。第一句明大机动也。自鄙先心第二句明小执移。异上付财中有二。一不取大二不舍小也。临欲终时而命其子下第二正说法华。就文为四。一辨时节。二明召集众证明。三结会父子。四委嘱家业。临欲终时者第一付财时节也。旧云如来三十成道八十灭度。其间五十年说法。此经邻次涅槃。故寿量品云于伽耶成道至今四十余年。诸师并云四十九年说法华。今明若说法华必是四十九年。则佛非十九出家三十成道。何以知之。若十九出家三十成道者则出家以后经十二年。而经及释论云踰城之夜生罗云。若尔何故知十二年耶。又经皆言六年苦行。若十二年者其间复何所为耶。以此推之非十九出家而三十年成道。若必十九出家者即二十五年成道。寿量品应云五十余年。不应言四十余年也。今依释论引经云我年二十九出家。若尔即三十五年成道。而寿量品云四十余年。即会其文也。若言经教不同适缘而见者。斯则时节不定也。既邻次涅槃如临终义也。而命其子下第二召集证明。即序品中列众事也。集二乘众如命其子。此经初分正为声闻。故云为诸声闻说大乘经名妙法莲华教菩萨法。所以云而命其子也。又从三昧起告舍利弗。即是而命其子。并会亲族者谓佛同行之人为亲族也。国王者多宝分身也。大臣者诸菩萨众也。刹利者诸天等幽众也。居士者人王等显众也。不列声闻众者。而命其子即声闻众也。即自宣言下第三会于父子正说法华也。文有三句。一明初为父子时。二辨中途相失时。三明父得于子时。此略举十譬始终三事也。此是我子者明声闻人本是佛子也。我之所生者昔日为说大乘教生其大乘之解。即以后句释上是子之言也。于某城中下第二明中途相失时。跉跰(跉零音跰破宁)行不正貌也。五十余年者流浪五道及修罗也。其本字某者昔受化时之称名谓也。我名某甲者能化之时名字也。昔在本城怀忧推觅者第三明得子时也。初句举不得昔大乘理法称为本城。犹是故乡耳。推觅大机犹未熟也。忽于是间会遇得子正明得子。此实我子我实其父者

问。上已云此是我子我之所生。今何故复说耶

答。声闻本非佛种。今忽言是子则似如权引。故重有此实之言也。又前明初为父子时。今欲付子之财故重言实是我子。今我所有下第四正委家业。即领上授身子记之言也。道合机熟父子义定法财大业并皆是付之。余缘众生一解一惑留托继人。故言前所出内是子所知也。又前所出内正指大品时。尔时虽复出内犹未知是己物。今乃知之故云是子所知也。是时穷子下第三领解欢喜也。大富长者下第三合譬但合五譬。一合初为父子譬。二合中途相失譬。三合诱引还家譬。四合付财密化譬。五合委嘱家业譬。所以但合五者。初为父子是结缘之始故须合之。背化流浪生死。盖是中途相失时亦须合也。后之三譬是释迦一期出世大小显密始终教门亦须合之。余譬说已显不待合也。世尊大富长者合父义也。我等皆似佛子者合子义也。菩萨为真子二乘非真故云似也。又过去始学大乘位行犹浅故言皆似佛子。若得真无生方是真子。如来常说我等为子者释上皆似佛子之言。如来常说我等为子。非我自称也。又佛眼照知我等昔禀大乘而背化入于五道。今复得悟虽复迷悟轮回未始非子故云常说也。世尊我等以三苦故下第二合中途相失譬。背大乘理已后凡有二事。一受三界之苦。二乐着小乘。故智度论云。退菩萨有二事。一贪三界二乐小乘。以三苦故者即贪着三界故受三苦也。所言三苦者。一苦苦二坏苦三行苦。有人言苦受是苦中之苦故有重苦之名。有人言。心为苦体。缘逼生苦。体具合说故名苦苦。众事分毗昙云。欲界为苦苦。色界为坏苦。无色界为行苦。欲界虽具三苦。但欲界有苦受故名苦苦。色界无外逼生苦。但有果报坏时苦。无色界非但无外逼生苦。而果报坏持苦亦不显。但有无常所役故苦。夫有重必有轻。则欲界具三苦。色界具二苦。无色界但一苦。俱舍论约三受释三苦。苦受为苦苦。以苦受生时苦住时苦。以二时苦故受重苦名称为苦苦。乐受为坏苦。以乐受生时不苦住时不苦但坏时苦故名坏苦。舍受名行苦。舍受三时苦皆不显但有无常所切故云行苦。迷惑无知下第二贪着小乘。凡夫时受三苦而不知出。今厌患三苦不求大乘而乐着小乘。所以乐小法者。正由迷惑无知故尔。今日世尊下合第三诱引还家譬。上有二。一领二教次领二身。今文转势合之。但领于教不复领身。就领教为二。初正领权教第二释疑。上领权教有四。今但合说教及信受。初文合上说教。我等于中下合上信受。然世尊下第二释疑。疑云既是父子恩情。何因缘故但令除粪不与妙乐。是故释云。佛知情乐小不受大化。是以不为说大而授小也。就文为二。初知根情故隐大不说。宝藏之分者即涅槃经贫女宝藏也。以方便力下第二授小。说如来智慧者如来智慧即是一乘。故于一佛乘分别说三也。一日之价者小乘果卑贱微也。如一年佣作一日詶劳。我等又因如来智慧下第四合付财密化譬。上有父付及子受。今但合子受。子受之内具合领父言不知父意。以方便力随我等说者明昔付财之时。佛知其乐小不得显教大乘。但得以方便力密化之耳。今我等方知下第五合委嘱家业譬。上文有三。一知子志大譬。二委嘱家业譬。三领解欢喜譬。今但合二。谓委嘱家业及得家业欢喜也。方知世尊于佛智慧无所吝惜者。昔见佛独以佛慧为菩萨说不为二乘说。则谓佛于二乘吝惜智慧。今得领悟始知佛无吝也。所以者何下举三事释佛无吝。一者我昔有大机即为说大。由我昔无大机故佛不为说大。故知佛昔无吝也。于此经中唯说一乘下。第二以佛今为我说一乘故知佛无吝也。而昔于菩萨前毁訾声闻下。第三义明昔赞大呵小即是为我说一乘意。但我自不知谓佛悭耳。是故我等下合第二领解欢喜譬也。如佛子所应得者皆以得之者。佛子所得凡有三事。一菩提心二菩萨行三未来得佛道。今具得三事也。尔时摩诃迦叶下第二偈颂

问。何故长行初明善吉今辨迦叶说偈

答。善吉迦叶各有一能。善吉有转教之功。迦叶有持法之用。是以二人前后互出也

问。大品不明迦叶转教。今偈中何云佛敕我等说最上道耶

答。上已通之。又迦叶善吉异口同音。迦叶说偈即善吉说也。又智度论云波若有二种。一独为菩萨说。二三乘共说。大品则是共说。迦叶虽复无言。而犹是善吉类故得言迦叶说

问。旧义亦明大品是付财教。与今何异

答。有三种异。一者旧但明大品是付财不会父子。今明大品有付财有会父子。所言会者。如上引毕定品事释之。二者旧明大品浅法华深。今明二经无异。非但二经无异。一切大乘经同辨一道同为菩萨。如长者家业始终无异。但说非子是子为别耳

问。即说子为深不说为浅。云何不异

答。本以长者家业喻大乘之理。家业既不异则知大乘理无别。但二乘在波若坐大机未熟。故不得说是子耳。如五百声闻在华严坐不得说其是子。可言华严浅法华深耶。三者法华波若眼目异名。法华会父子即是波若会父子也。七十三行半偈还颂长行二段。初二行颂法说。次七十一行半颂譬说。上法说有二。初序昔迷二陈今悟。今但颂悟不颂迷也。二偈为二。初偈明闻法故欢喜。次偈明见人得记故喜。亦初是现喜后是预喜。譬如童子下第二颂譬说。上文有三。初请说二开譬三合譬。今但颂后二。上开譬有十。今但颂八譬。不颂冷水洒面及陶练小心。上明父子有四番。初番明子有三义。一初为子义。二中途失父义。三子渐还乡义。今具颂之。但类例相从转势为异耳。初明子二义。一为子时。二失父时。子渐还乡回在后颂之。初半行明为子时。童子者喻初发菩提心也。幼稚者明善根微浅也。无识者上明解小今辨惑多也。次一行颂中途相失也。其父忧念下第二颂上父也。长行明父有三。一为父时。二失子时。三中止一城以待子时。今偈以类相从超取重明父入今文颂之。则开为四。三文如上。第四明忆子之苦也。其父二字颂上为父义也。忧念已下颂上第二失子义也。四方者四生也。子失父而称五道。父失子据于四生。盖互现文耳。求之既疲下颂上第三顿止一城以待于子。长行有四。一化处二化主三教门四徒众。今具颂之。顿止一城者颂化处也。造立舍宅者第二明垂应成佛颂化主也。无为而无不为故言造立。覆阴众生称之为舍。又垂应自居亦是舍也。五道皆化浅深随机谓五欲也。至人以度物为乐称为自娱。其家大富叹化主也。此文大意对子失父之贫贱。叹父失子而富贵。明声闻失大乘故贫贱佛得大乘故富贵。以此抑扬令时众欣大而恶小也。执文为三。初明父大富义。次叹父大贵义。三双结富贵义。富贵各明三事。富三事者。一者内多珍宝。二外丰象马车乘田业人民。三出入息利遍于他国。今叹内富即是内备众德。象马牛羊下此叹外富谓教门也。僮仆人民下犹是叹外富谓所化徒众也。出入息利下。上明一国之富。今明富遍他国。犹是释迦所化徒众义耳。商估价人者。商估谓行商。坐估谓卖物人也。价人谓买物人也。此长安地呼买为贾。不必依书典也。千万亿众下第二叹父贵义亦开三别。初半行明近众。次半行明十方佛之所爱念。次半行明十方菩萨所共宗重也。以诸缘故下一行结富贵义。以富贵具足故往来者众。赴机为往。受道为来。其数尘沙故云众也。而年朽迈益忧念子下第四颂上重明父义。上有二章。一忆子之苦。二假设得子之乐。今但颂初也。尔时穷子下此第三番重颂子也。长行明子有三义。一为子时。二失父时。三渐还乡时。初番已颂其二。今次颂第三子渐还乡。所以回初置今颂者。欲明子还乡有近远三时。一向国时二到城时三至舍时。盖是类例相从故转势颂也。初半行颂上驰骋四方以求衣食谓向国时也。从邑至邑下二偈颂上第二至城时也。然善根有二种。一者平品相生。如从邑至邑从国至国。二者增品相生。如从邑至国。长行显其增品。今明其平品也。或有所得或无所得者。行善因得善果为有所得。行无记因不得果为无所得。又定得果为有所得。缘差不得果为无所得也。饥饿羸瘦者。乐果不得自充足为饥饿。福因不能自强如羸瘦也。体生疮癣者。上明善小今辨惑多。外则受于讥毁。内为众惑所瘵尘也。佣赁展转下第四父子相见譬有二。初颂子见父。次颂父见子。子见父中长行有三。一明见父缘由。二明正见父。三起避畏心。今具颂之。尔时长者下颂正见父。长行有六句。今但颂三。一行颂化主。半行颂徒众。一行颂教门。此既是真法说者听人三事故颂之也。门内者至理虚通为门。长者既在门内。显穷子居理外也。眷属围绕者颂长行婆罗门等登地已上人也。诸人侍卫颂长行吏民僮仆地前人也。或有计算者明教门也。非长者自计算乃使人为之。初成道时七处八会加被菩萨说即是其事也。计算者明少多义。如五十二位深浅不同。又如初地百法明门二地千法门等。注记者现在行因未来得果也。计算明说法。注记谓授记也。穷子见父下第三颂子见父赴避畏心。借问贫里者。于时佛未说人天之教但有人天之机。扣佛说人天之教。如借问贫里也。长者是时在师子座下第二颂父见子。上有三句。一见子处。二见子便识。三见子欢喜。今但颂二不颂欢喜。初成道时未说是子故云默而识之。即敕使者下颂第五唤子不得譬。上有二。初唤子不得。二息化。今但颂初上唤子不得。不得中又二。初正唤子不得。二强牵将还。今但颂初半行颂正唤子。一行半颂无机不受也。何用衣食使我至此者何用人天乐以小善扣大圣也。长者知子下颂第七诱引还家譬也。上有二。初领二教次领二身。今具颂之。二教中有四。今但颂二。初三行颂说教。次一行颂信受。初三行为二。初一行明无大机。次二行正说小教。不信我言者不信实教也。不信是父者不信实身也。即以方便者第二说小教也。前已遣傍人唤子不得故云更遣余人。眇目矬陋无威德者。目视不正为眇。又云一目少为眇。譬二乘所见空有悉皆不正。涅槃云见菩萨八相成道名二乘曲见。谓有见不正也。又言若以声闻辟支佛心言无布施是则名为破戒邪见。谓空见不正也。但度三百由旬志不及远名之为矬。不得中道正观但是断常行心名陋也。外无济物之功如无威。内无救物之心称为无德。摄大乘论明二乘无三德。一无断德但除惑障不除智障。二无智德谓无一切智。三无恩德不能普救众生也。穷子闻之下第二颂上信受也。净诸房舍者六根非一如诸房舍。除六根中烦恼如净也。长者于牖下第二颂上二身。上有四。一照机二隐本。垂迹三说教四得益。今颂初三不颂后一也。初行颂第一。次偈颂第二也。方便附近下颂第三说教。上有四一。诫劝二益价三安慰四称叹。今转势亦四。二同上三苦言四柔语也。若如我子者古语呼汝为若也。并涂足油者。外国作使之人足多龟坼故以油涂之。譬得六通而足不履地也。饮食充足荐席厚暖者。作使之人必多饥寒。今赐其饱暖。无漏定慧如饮食。戒以安身如厚暖也。长者有智下颂第八付财密化譬。上文有二。一父付二子受。今二行颂父付。一行颂子受也。经二十年者。得罗汉果后始命说波若。如除粪已后方乃付财。则知命说之时犹住二乘位故称经二十年也。父知子心下颂第十委嘱家业譬。上父有三。一知子大志譬。二委嘱家业譬。三得家业欢喜譬。今具颂之。半行颂第一。欲与财物下颂第二委嘱家业譬。上有四。一明时节谓付财缘由。二召集证明。三结会父子。四委嘱家业譬。今不颂初一但颂后三。初一偈颂召集证明。于此大众下颂第三结会父子。上父有三。一初为父子时。二中途相失时。三父得子时。今具颂之。半行颂第一。一行颂第二。上半明舍父之岁。下半辨见子之年

问。禀人天教亦是见子。何故但说行二乘教为二十年耶

答。二乘方是佛子。人天未是佛子。故五种佛子中谓四果并缘觉。不说人天也。昔于某城下颂第三父得于子。上半辨失子之城。下半明得子之处。凡我所有下颂第四正季付财物。子念昔贫下颂第三得家业欢喜。又开三别。初半行序昔贫。次一行明今富。后之半行辨欢喜。三门各二。初门有二者。一昔贫二志意下劣。次门二者。半行明内富半行明外富。后门二者。一甚大欢喜二得未曾有也。佛亦如是下第二颂合譬。上长行合五譬。一合初为父子譬。二合中途相失譬。三合诱引还家譬。四合付财密化譬。五合委嘱家业譬。今亦合五但转势颂之。第一合唤子不得譬。第二合诱引还家譬。第三合付财密化譬。第四合陶练小心譬。第五合委嘱家业譬。初文有一偈。上半明有小机。下半明不说大法。次文有一偈。上半明得小法。下半辨成小乘人。佛敕我等下颂第三付财密化譬。今就此譬大开三别。第一合付财密化。第二合陶练小心。第三双明佛昔不为显说大乘。合初文为二。初一偈合父付。第二合子受。父付中上半明所付波若是最上之道。下半明波若教宗唯菩萨辨成佛。明显教菩萨及密化声闻并令作佛。盖是大品教宗。非三乘通教意也。我承佛教下第二颂子受。前文有二。一领父言二不识父意。今具领之。就领父言复开四别。初一行半正明受命转教。次一行明菩萨悟道。第三一行序佛授菩萨记。第四一行半结大品教但为菩萨说不为二乘也。如彼穷子下第二有三行颂不识父意。三行即三。初偈譬说次偈合譬后偈释无悕取。我等内灭者凡有三种义。一约大小乘明内外。大乘具灭三界内外。小乘但灭三界内故称内灭。二者菩萨并济众生内外俱灭。二乘但灭自惑不灭他惑故称内灭。三者约余无余明内外灭。结业既亡则未来生尽。入无余时于外山河日月亦随分得灭。今住有余未得无余故云内灭也。我等若闻净佛国土下合第二陶练小心譬。就文为二。初明保小故不欣大因。二明保小不乐大果。所以但明此二者。大品教后诸方等经陶练小心凡有二种。一者以大因陶练。二者以大果陶练。故今但明二种也。初文为二。前明不欣大因。次二偈解释也

问。何以故此文是合陶练小心譬耶

答。前章明为他说大乘。今文辨从他闻大。故知是付财之后诸大乘经也。所以者何下二偈释不欣大也。空无大小者此是成论人声闻空也。成论师不体此意谓是探明大乘。盖是小乘教中自有二说。毗昙悟人空但得其浅。成论悟法空则得其深也

问。成论亦辨法空。与大乘何异

答。略明四异。一者大乘明人法本性空。小乘明折法空。故大乘是真空小乘非真空。故方便品云。小乘涅槃非是真灭。诸法从本来常自寂灭相。大乘涅槃方是真灭。灭谛即空。灭既有真伪空亦然也。二者小乘但明三界内人法空。空义即短。大乘明三界内外皆空。空义即长。三者小乘人但见于空不见不空。大乘人具见空与不空故名中道。以空无诸累不可言有。有于众德不可言无。非有非无即中道。四者小乘人入空则失有。出有则失空。是故取舍行心断常二见。中论云。若有所受法则堕于断常。当知所受法若常若无常。大乘人不坏假名而说实相。故即有而常空。不动真际建立诸法。即空而常有。故不堕断常名中道观

问。大乘何位得并观耶

答。成实师云。六地未并七地学并八地真并。而璎珞经云初地已并者。成实师释云。凡夫著有二乘沈空。今初地对此故云并耳。其实未并。虽言八地并然照空之智终自四绝。鉴有之智万像不同。空有恒异。何由并耶。我等长夜下第二闻佛果德不生欣乐。就文为二。初一行正明不欣果德。次三行释执小故不欣大。三行复开三意。初半偈谓小是究竟与佛德齐故不欣大。次一行半所作已竟故不欣大。第三一行明报恩已毕故不欣大。依教得果是法供养。前二明所作已办。此序报恩已毕故不进求也。我等虽为诸佛子等第三双释付财密化及陶练小心二譬意也。就文为二。初一行半重牒付财譬略不牒陶练小心。第二偈明佛昔知未有大机但得密说不显言劝学大乘也。如富长者下此颂合第十委嘱家业譬。上长行有二。一委嘱家业二得家业欢喜。今具颂之。颂初委嘱家业又二。前一行半双标二譬。第二一行半双合二譬。所以双牒合者。此二相开故举始以成终也。以方便力者。若别取即是第七诱引还家。说二乘譬名为方便。故上文云。将欲诱引其子而设方便。若通论方便者。从一乘顿化不得故后以四教为方便。谓人天乘乃至陶练小心。如上释也。又合此四教亦得为三方便。人天乘谓世间方便。次说二乘谓出世方便。后付财密化陶练小心谓大乘方便。此即是下中上品方便调柔其心然后始得悟入一乘也

问。此与五时教次第有何异耶

答。法华文自作此判之。非人之穿鉴也。而与旧不同者。旧明波若及诸方等经皆劣于法华故是法华之方便。今明诸菩萨等于波若中皆已得悟。声闻钝根假菩萨究竟之教为得悟缘由。故云方便耳。非是大品未究竟称为方便也。故前文云。波若是诸佛密藏。但为菩萨演其实事。即其证也。二者五时教人谓波若净名法华之佛皆非究竟。今明三教辨佛皆究竟。三者他云华严一乘法华一乘浅深为异。今明二种无异。但初说一乘化子不得。后说一乘化子方得。得与未得其义乃殊。论其一乘理无异也。佛亦如是下一行半偈双合二譬也。我等今日下第二颂上领解欢喜。就文为二。初一行半总明得益。世尊我今下五行半别明得益。就文为二。初三行明得法益。次二行半明得人益。初三偈即三。第一偈明得慧益。得道得果者。昔得小乘道谛之道灭谛之果。今得大乘道果。如大品云。有法是菩萨道。即是无生灭观。无法是菩萨果。谓诸法实相

问。云何名无生灭观耶

答。昔谓灭惑生解是生灭观。今知惑本不生今亦无灭故名无生灭观。即是道果也。于无漏法得清净眼者。昔日会空断惑。乃至毗昙见有断惑称为无漏。今明二乘皆是断常之心悉名为有漏。今得平等正观始是无漏为清净眼。昔日二乘人断常覆心无清净眼。在华严坐犹如聋盲。今得了悟则同入法界也。我等长夜下第二明得戒果。昔持净戒得小解脱。今悟一乘得大解脱。解脱是木叉之果。故以解脱为戒果也

问。昔持小戒云何今得大果

答。佛昔令持小戒为令悟大。故小戒为因悟大为果。如胜鬘云。为大乘故说于六处。谓波罗提木叉出家受戒．具足戒．正法住．正法灭等。法王法中下第三有人言。通取一切戒为梵行。别名断淫为梵行。故大品云。淫欲障生梵天。何况菩提。今谓前已明戒果。今明定果。昔行小行至小涅槃。今悟平等至大涅槃也。我等今者下。前三即是三学之法次第。今明人利益。初偈明智果谓为他说法生他之慧。次一偈半明断果谓受他供养生他之福。又前偈自为法施主众生为福田。后偈明自为福田众生为施主。所以然者。始舍小乘断常信今日中道。堪为人天二乘福田。如大品。身子问菩萨住何等地为二乘福田。佛答从初发心为二乘福田也

世尊大恩下第二大段叹佛恩深难报。此经始终佛有十恩。一通结缘恩。谓佛初发心时立四弘誓愿。故方便品云。我本立誓愿欲令一切众如我等无异。三根声闻入此法门愿海。谓通结缘恩。二者别结缘恩。于过去世为说大乘曾为父子。谓父子结缘恩。三随逐化恩。诸子观弱倒强。流浪生死周旋诸国五十余年。如来随入生死而教化之。故云其父忧念四方推求。谓随逐化恩。四隐本垂迹恩。如来久证法身常乐我净。为诸子道缘应至方示修行成佛。故云中止一城以待于子。谓隐本垂迹恩。五思惟救济恩。初成道时三七日思惟欲救济大悲深厚。谓思惟救济恩。六舍深说浅恩。初成道时既不堪受穷深之佛慧。为说极浅之人天能为下劣忍于斯事。谓隐深说浅恩。七权诱恩。脱珍御服着弊垢衣。为说二乘令渐悟入。谓权诱恩。八付财密化恩。九陶练小心恩。十委嘱家业恩。就文为二。初标作恩报恩二章。次释二门。前偈标作恩章门。半行标报恩章门。手足供给下释二章门。前逐近释报恩章门。次释作恩章门。就初有二。一行标敬养二章门。上半标敬下半标养。次一行释恭敬章门。次三行释供养章门。中二偈半明其供养广。次半偈辨其时长皆不能报。诸佛希有下释作恩章门又二。初二行明神通轮恩。次四行半明说法轮恩。又前是大悲恩。后大慈恩。又初是隐本垂迹恩。次是隐实教而说权教恩。恩虽复十种略摄不出本迹二身权实二教。忍于斯事者。佛久积大乘为钝根故忍而不说。如净名云。释迦如来隐其无量功德。以贫所乐法度脱众生也

法华义疏卷第七

永仁甲午夷则二八嫡胤道尊大姊妙法同纪氏女孙女藤氏此昆弟戮力刊当卷义疏适当先妣十三之远辰以拟丁兰木母之至孝乃至蠢蠢含灵同会如如妙理而已

              都干缘沙门素庆谨志法华义疏卷第八

        胡吉藏撰

    药草喻品第五

所以有此品来者。自华严始集终竟灵山前会谓开五乘之教也。此经之始至信解之终合五乘归一乘也。今此一品举喻具释开合之义也。一地所生一雨所润。喻至理无二故合五乘以归一也。而诸草木各有差别。谓随五乘根性说五种教门。谓开义也。若但开而不合则得教而失理。若但合而不开则得理而忘教。故今明虽开而合虽合而开。虽合而开一而常五。虽开而合五而常一。具识开合理教始成。是以此品释成一化开合义也。然虽开而合合名开合。虽合而开开名合开。合开即非开。开合即非合。故非开非合非五非一强为开合。故下文云。究竟涅槃常寂灭相终归于空。盖是诸法实体故称为妙。不为诸边所染目为莲华也。次依法华论明此品来意者。火宅譬破凡夫病。穷子譬破二乘病云雨譬破菩萨病。菩萨之人闻上来所说唯有一乘。便谓毕竟无复三乘方便。此即得实失权存体忘用。然识权方乃悟实。达用乃鉴于体。既不识权亦不悟实即权实俱丧体用并亡。为治此病故明虽一地所生一雨所润而诸草木各有差别。虽至理无二而于缘有五。故权实义成体用方显。此经既称教菩萨法佛所护念。故令大士离凡夫二乘病及菩萨病。始是教菩萨法佛所护念。次依述成意生起此品者。譬喻一品正明说教。信解品明中根领解。今此一品如来述成。述成者据譬而言。一切草木凡有二义。一不知同二不知异。不知同者不知一地所生一雨所润也。不知异者不知草木自有差别也。假设如有一瑞草能知同异即是奇特。禀教之人亦有二迷。一不知理同二不知于缘有异。而迦叶一人能知理同能知教异乃名奇特。故下文云。如彼草木而不自知上中下性。汝等迦叶甚为希有。能知如来随宜说法能信能受。故举云雨药草述成迦叶领解。若望迦叶。于信解品十譬十恩叹佛功德犹自未尽。故更说云雨草木之譬广叹如来无方大用普益众生。叹不能尽故说此品也。若为释成信解品者。上明十譬十恩。无漏无为诸法之王。能为下劣忍于斯事。即时众谓佛过去之始今会之终屈曲崎岖难心苦心。是故今明如来虽复府仰顺从而无心屈曲。故华严云无心于彼此而能应一切。故举云雨无心之譬释成信解品也。言药草喻品者。药是草木中治病之通称。草即形木之别名。而言药草者通别两举者也。但言药草不举药木者。明木二即少草三即多故废少从多也。又今正述中根人领解故题药草不题药木。所以举药草喻中根人者凡有三义。一者禀教得解解生必能灭惑。喻如药草治病义也。二者药草能愈他疾。喻闻教得解即成菩萨必有兼济之功。三者药草是草中之贵。显成菩萨人中之尊贵异上声闻未得领悟如鄙贱穷子也

问。药草无情而受润。禀教有心而领解。何以为喻耶

答。欲明缘教相称义也。云雨无私而润。草木无心而受。若无私而润有心而受。即缘教相乖。何由领解。故举无心之根显无私之教。可谓其说法者无说无示。其听法者无闻无得。亦说如幻说闻如幻闻。无言显道绝听雨华。即其事也

问。何以知然

答。文云是法不可示言辞相寂灭。我今既示不可示。虽示而无言。亦是闻不可闻。虽闻而绝听也

问。譬喻药草化城皆是举喻。何故火宅独受譬喻名耶

答。通皆互得。而别不例者。火宅在初故受其通称。余皆居后当其别名也

问。文具举云雨草木四事。何故偏题药草名耶

答。就文而言。药草在前喻机感扣圣。云雨居后譬形声应物。要由感方应故从初立名。又今述中根领解故以药草题品。云雨不尔故不标名

问。举药草以述成故云药草品者。上明穷子以领解应云穷子品

答。穷子通迷悟。今言信解故用别以立名。卉木通于毒药。今云药草亦从别为称

问。上明穷子信解从信解以立名。今云如来述成应从述成以为称耶

答。今云药草品者可含二义。一者得述成中根领解。二者广明佛教利益无边。述成但得成前阙于后义故不云述成品。又领解题信解就法为名。述成称药草据譬为称。欲法譬两存不应一类立名也。就品为二。第一述成所解。第二广叹佛德。遍告迦叶者。迦叶是中根之尊又是说譬之主故偏告之。及诸大弟子者善吉之流也。善哉善哉者释论云。再言善哉者喜之至也。诚如所言者。两善哉述其言巧。诚如所言印其事实。但称叹有四句。或言巧而事不实。或事实而言不巧。或两具。或双无。今两具也。如来复有无量功德者第二广叹佛德。就文为二。初长行次偈颂。长行为二。初略标佛德无尽。第二广释佛德无穷。上明言巧事实者。盖是一方之迹。未尽无方之化。无方之化。非迦叶之所能穷也。净名经明佛三号。大千声闻如阿难总持以一劫寿不能受持。况无量号。号尚如是。况复功德。所以然者。法身即是实相。实相无边故功德无边。应身有众生数等方便。即功德亦不可尽。迦叶当知如来是诸法之王下第二广叹佛德无穷。就文为二。初法说明权实二智。次譬说辨形声益物。内有二智无幽不察。外有形声益物平等无私。盖穷圣德之渊府尽如来之化功故略举斯二也。上信解品有十譬十恩。今如来对之即明八法八譬。言八法者。一者诸法之王。二所说不虚。三说一切教。四同表一理。五叹佛有照理之智。六叹佛有知机之能也。七叹佛善识教门。八叹佛应机说教也。是诸法之王者。上十譬十恩但明一方之化即未能自在。今明诸法之王即知化之无方。但于法自在凡有二种。一者体法自在。二者化用自在。具二自在故名法王也。若有所说皆不虚也者第二句标所说不虚。既越其所叹似言过实。故今明言之实也。言实事多。略有三种。一者如来常依二谛说法故不虚也。二者能以巧智于一说三。说三之旨为诠一理故于理不虚。又于物实益故言不虚。三者就无方释之。如来实说亦实虚说亦实。顺说亦顺反说亦顺。以皆能开道皆能益物故无不实。故无不顺。故涅槃明四句。道说为道。非道说非道。道说非道。非道说道。以道心而说四句四句皆道。非道心而说四句四句皆非道。故思益经云一切法正一切法耶。于一切法以智方便而演说之第三明说一切教。所以明说一切教者。上十譬十恩盖是一方之教。辨教犹未尽。故今明说一切教方乃穷也。一切法者。智度论云。为无为摄一切法。又识所知法智所知法亦摄一切法。又云五法藏摄一切法。三世无为及不可说也。不可说即是诸法实相。非有为非无为言忘虑绝。正量部云。第五不可说者即是十四无记也。地持论云。四法摄一切法。谓世谛及世谛智第一义谛第一义谛智也。以智方便者。上句明所说之教。今明能说之智。智谓波若方便即沤和。此二是诸佛父母化物要方故明之也。今正以智为其体方便为用。故以智方便说一切法也。其所说法皆悉到于一切智地者第四明教所表理。上明以智方便说一切教。即是其言巧妙。此句明教所表理。谓其义深远。虽以智方便说一切法。大宗终归一切智之正观也。如来观知一切诸法之所归趣者第五句明佛知一切法终归至极。此文释上归一切智地之言也。由如来善知理无异趣。验向异说皆是到一切智之义也。亦知众生深心所行通达无碍者第六句明善知根性也。既知理一而说有万差者。以善达人根随其所宜故也。又于诸法究尽明了者第七句明善识法药。对上达人根也。示诸众生一切智慧者第八句应病授药不差根也。譬如三千大千下第二譬说。前开譬次合譬。今以三义释此譬文。一广开有八譬。二合八为四譬。三合四成二譬。言八譬者。一能生大地譬。二所生草木譬。三兴云譬。四澍雨譬。五受润譬。六增长譬。七同一地一雨譬。八草木差别譬。此之八譬即是次第。前有大地能生。次有草木所生。以有草木是故兴云。初既兴云次必澍雨。既有云雨即草木受润。初既受润后即增长。虽有受润增长然俱是一雨所润一地所生。虽能生能润是一而诸草木各有差别。故此八譬次第而来也。然要具八义譬义乃圆。今略合之。过去世佛教能生如地。所生五乘善根种子如草木。既有五乘种子感佛出世故如兴云。如来出世必说正法次明澍雨。众生初禀佛教欢喜故名受润。各蒙利益譬之增长。至理无二如一地一雨。于五乘得益不同如草木差别也。次合八譬成四譬者。初一双为能禀。次一双为所禀。第三双为正禀。第四双辨同异。次合四譬为二譬者。初六名禀泽譬譬于昔教。后一双论同异譬譬于今教也。三千大千世界者。有人言此譬五乘众生所住处。下明草木喻能住五乘之众生也。有人言大地是能生譬过去世习因。草木是所生譬现在世习果也。今谓大地譬过去佛教。佛教无私能生众生善根譬同大地。故下文云一地所生。即其证也。所生五乘种子譬同草木。但过去佛教广被无边譬同三千大千世界。此对迦叶叹佛一方之迹。今欲叹无方之化故举大千为譬也。山川溪谷土地者。上总叹佛教能生。今别叹五乘教为能生也。有人一一别配。义多不似。今宜略之。所生卉木丛林下第二明所生草木。前能生有两。大千为总山川为别。今所生亦二。一总二别。卉木丛林总明所生也。卉是百草之通名。木是众树之总称。草聚为丛。木丛为林。此譬总明五乘众生也。及诸药草下别明所生也。草有能治病者称为药草。所生别者众多而偏题药草者。犹其有愈病之功多所利益。即是偏叹中根领解成于菩萨上绍佛业下利益众生也。种类若干名色各异者通释草木差别义也。种谓种别类谓品类。略明草类有三木类有二。合譬可知。名色各异者。名以目体。色像外形。譬五乘众生名字不同体相各异也。密云弥布下第三明兴云譬。前明草木谓五乘种子。即是能感。要由感方得有应故次诸佛出世。喻若兴云。即是应也。云者喻佛身也。一无心而应譬之如云故华严明无心于彼此而能应一切。二应身润益譬之如云。三能遮热总譬之如云。四应身为说本如云为雨本譬之如云而称密云者利益深重也。弥布者广益也。遍覆三千大千世界者平等遍益也。如华严云其身遍坐一切道场。即是有缘同见义也。涅槃云。云名龙气。由龙有云。由云有雨。由法身垂应身。由应身而说法也。一时等澍其泽普洽者第四明雨譬。法施无前后故云一时。又云有感同闻又如一时。为说不偏故云等澍。遍益无边义同普洽。卉木丛林下第五明受润譬。初禀佛教信受欢喜名为受润。就文为三。初总明受润。及诸药草下别明受润。根茎枝叶譬信戒定慧四法也。三草各有四法名上中下。随上中下各有所受总结受润。一云所雨下第六明增长譬亦有三句。初句明能润是一。称其种性者第二明教称缘也。而得生长者下第三正明生长。未生五乘善根者令生。已生五乘善根者令增长。各成五乘之因如华。各成五乘之果如实。后合譬中更有余义。现下文也。虽一地所生一雨所润者第七明能生是同譬也。而诸草木各有差别者第八明所生差别譬。前三譬论昔教已竟。昔教虽多不出三种。初双明能禀。次双明所禀。后双明正禀。今此两譬论能生是同所生有异。即是至理无二于缘得益不同。所以论同异者。为欲破今昔二病称叹二人。破今昔二病者。昔五乘人正执教异不知理同。禀今一乘教人偏执理同不知教异。为破此二人故明理虽同不失教异虽五乘教异而至理常同。是以文云虽一地所生一雨所润而诸草木各有差别。又破二病者。昔五乘人不知于理未尝二。不知于缘未尝一。为破此病故说于地雨未尝异草木未尝一。今禀一乘教人虽知至理未尝异。不知于缘未尝一。为破此病故说于地雨未尝异草木未尝一也。称叹二人者。一叹佛能知同异。二叹迦叶能知同异。能知同者谓理一也。能知异者谓教异也。又能知同者于理无异也。能知异者于缘成异也。迦叶如来亦复如是下第二合譬。但合七譬不合大地譬。以大地是过去佛教。今正明现在法门。故略不合之也。就合七譬开为二章。初合前五譬。次合后同异雨譬。以前五譬明昔教后二譬辨今教故开两段合之也。合初五譬又开为二。第一正合五譬。次举譬帖之。就合前五譬转势明义与譬说不同。第一合云譬。二合草木譬。三合雨譬。四合受润譬。五合增长譬。所以与譬本不同者。譬本欲明由感故应。故前明草木后辨云雨。今欲明前有如来出世唱于德号。故前合云。众生闻唱德号故来至佛所。故次合草木。众生既来至佛所故如来便为说法。故次合雨譬。众生闻法欢喜。故次合受润譬。各蒙利益故次合增长譬。就初合云又开为二。第一正举德号合云。第二劝物来听受。就初合云又开四别。第一举形合云。第二总举声合云。第三举外号合云。第四举内德合云。谓形声内外摄义略尽也。初正举形合云。次以譬帖之。以大音声下第二总举声合云次亦以譬帖之。而唱是言下第三举外号合云。所以举十号者。以号令天下令知是佛出世异九十六师也。未度者令度下第四举内德以合云。内德之中前明四弘誓者。此述如来出世意也。如来所以出世者。良由昔有四弘誓。是故今明十号之人出现世也。故肇师云。结僧那于始心终大悲以赴难。即此文意也。璎珞经云。约四谛立四弘誓愿。未度苦海愿令度之。故云未度者令度。众生为集谛烦恼业缚愿令解脱。故云未解者令解。未安道谛者令安。未得灭谛涅槃者愿令得之。前二即是大悲愿。后二即是大慈愿也。今世后世如实知之者。上举昔四愿此举今四德。然德之与愿并皆合云。悉就今合以立名也。初德即是三达也。夫欲化物要须知其根性。众生根性在三世中行。故前明三达也。我是一切知者即是一切智也。三达但知有为智。故次明一切智即具知一切法也。一切见者下。然二乘人又有一切智。如大品三慧品说。而无五眼故说一切见也。知道者开道者说道者。虽具上来功德。意欲物入道。故次说导师也。然道语通邪正。善恶在心曰知。开其邪正二路为开。曲示通塞为说也。汝等天人下第二劝物来听受也。尔时无数下第二合草木譬即受劝而来也。如来于时下第三合澍雨譬。种种无量下第四合受润譬。正以初闻说法心生欢喜为受润也。决得善利下合第五增长譬也。此句总合增长。是诸众生下别合增长有二。前约世间利合增长。现世安稳者。以闻法故现世障灭善生故得安稳也。后生善处明生报也。以道受乐辨后报也。然此文通于生后。且寄后报辨之。由闻正道故感乐报。所以言以道受乐。亦得闻法下明得出世利以合增长亦有三句。初是闻慧离诸障碍下明思慧也。任力所能下明修慧也。如彼大云下第二举譬帖合。今初举云譬。雨于一切下举雨譬。卉木丛林下举草木譬。如其种性下举受润譬。各得生长下举增长譬。皆帖合上也。如来说法一相一味下合第二同异譬。就文亦二。初正合同异譬。二明知不知。合同异譬即二。初合一地一雨谓合同譬。次合而诸草木各有差别谓合异譬。一相一味者合上一地所生一雨所润也。一相谓一实相合一地也。一味谓一智味合上一雨也。故下偈云其云所出一味之雨也。所谓解脱相下双释上一相一味也。免五住烦恼缚故名解脱相。离三界内外业故名离相。灭二生死苦果故名灭相。究竟至于一切种智释上一味。离前三相故累无不尽。由离三相故照无不圆。照无不圆故非无。累无不尽故非有。即是中道之法也。其有众生下合上而诸草木各有差别譬也。不自觉知下第二明知不知。就文为二。初明佛知同异众生不知。二叹迦叶能知同异。即是破二病叹二人也。就初又二。第一明众生不知异佛能知异。次明佛能知同众生不知同也。初文为四。前明众生不知。二明唯佛能知。三结唯佛能知。四结众生不知。初言不自觉知者。盖是不知理同于缘成异故言不知耳。然五乘众生非不知五乘异也。所以者何唯有如来知下第二明唯佛能知。而标所以者何者。举佛能知释成众生不知也。此中明佛知四种法。初知四法。次知三法。次知二法。次知一法。知四法者。种谓种别也。三乘种类不同也。相者相貌也。如慈悲是菩萨相独静是缘觉相从他闻法是声闻相也。体者三乘体也。道种慧是菩萨体。一切智是二乘体。如三慧品说也。性者不改为义。昔三乘智体各住己分不互移改也。念何事下第二明知三慧。然三慧不同。或以三乘人为三慧。声闻智浅如闻慧。缘觉智小深为思慧。菩萨尽理如修慧。亦得三乘各有三慧。文有三番。初明三慧境。二明三慧体。三辨三慧因也。作意守境为念。即闻慧也。厝心思惟是思慧。深入是修慧。通称事者。以境为事。依毗昙三乘人同观四谛境生三慧毗昙闻慧但缘文。修慧但缘理。思慧或时缘文或时缘理。成实通观一灭谛境。大乘同观一实相境缘理。三慧位者。毗昙前三方便是闻思位。四善根是修慧位。成实四念处是闻思慧位。濡法以去是修慧位。云何念下第二明三慧体。谓能缘心不同也。以何法念下第三明三慧之因。方便不同宿习各异也。以何法得何法者第三明因果二法也。以何法谓因。得何法谓果也。众生住于种种之地下第四明佛知一法。所谓地也。而言种种者五乘地不同也。唯有如来下第三结唯佛能知也。如彼草木下第四结众生不知也。如来知是一相下第二明佛知同众生不知同也。就文为二。一者明佛能知。次辨昔不说之意。即显众生不知。究竟涅槃常寂灭相终归于空者。有人言。虽过去过尘沙未来复倍上数。终入无余灰断涅槃故云终归于空。此释寿量佛无常也。有人言。依覆相说常解释者。明此常即空无相不可得故言终归于空也。有人言空无二十五有故名寂灭也。今明有二种。一者凡圣终归大涅槃故云终归于空。亦如肇师涅槃无名论云。视听之所不暨。四空之所昏昧。九流于是乎交归。群圣于此乎冥会。则用此文意以作论也。二者自昔已来开五乘教用。至于法华息用归体。则无复五乘末。本对于五故明不五。既无有五亦非不五。即言辞寂灭故称为空

问。上明终归一切种智。与今何异耶

答。通是一道清净。随义立名或称种智或名涅槃或名一乘或名波若。故前明终归种智。今云终归涅槃。若以二文共相会者。前明终归种智谓三菩提果也。今云终归涅槃谓果果也。良由二乘智非究竟智故终归佛智。二乘涅槃非究竟故终归大涅槃也。上合大车亦取此二义合之。如前释也

问。何故偏明二果

答。二义。一者二乘有余涅槃智非究竟智故今明佛究竟智。二者二乘无余涅槃非究竟断故今明究竟断。谓二死果永绝超于五住流故名灭度也。又上云究竟种智。谓无境不照即波若。今无果不寂。谓解脱而法身居内也

问。既言归涅槃。何故言终归于空

答。或名究竟空或名大涅槃或名诸佛道也。然中论破涅槃品正破四种涅槃。一破有是涅槃。二破空是涅槃。三破亦空亦有。四破非空非有。而后结云。涅槃绝于四句超于百非。不知何以名之。强名为空也。佛知是以下第二明佛虽知理一为物未堪昔不即说。此即显众生不知同也

问。上句云佛知涅槃。今亦佛知众生心不堪故不说涅槃。何故言昔不说种智

答。二义。一者欲显大涅槃即是种智异二乘灰断无为。二者若言昔不说涅槃。于义不便。昔亦说三乘同入无余故也。即以此文责光宅等师。若终归于空既是灰断涅槃。既言佛知涅槃。何得云昔不说灰断涅槃耶。汝等迦叶下第二叹迦叶能知同异。今昔两缘各有偏执不知同异。而迦叶能知故名希有也。就文为二。初正叹。所以者何下释叹。然应具叹迦叶能知同异。但偏对昔病不知异是方便。故今偏叹迦叶于不知异人中为希有也。此文亦得具叹同异。能知如来随宜说法叹知异也。能信能受叹知同也。就偈凡有五十四行半分为二。初四行颂第一法说明权实二智。次有五十行半偈颂第二譬说明形声益物。上法说有八门。今转势说法。序叹佛出世大意。明今昔有默说不同。开为四章。第一偈叹佛昔随机权说。第二偈明如来昔日不说实法。第三释佛昔不说实意。第四释昔权说之意也。破有法王者。有人言破二十五有名为破有。如涅槃明得二十五三昧破二十五有。如来自破二十五有出生死外居法王之位。今出世亦为物破二十五有。又言破有者众生多滞于有故以空药破之。如中论云大圣说空法为离诸见故。然此二意皆是偏用之。文今言破有者破一切有所得也。本谓有生死故为说三乘。复言有三破三说一。遂封于一说言非三非一中道之法。复言有此两非之中终不免有。今破此有见故言破有。如来尊重下第二明昔不说实。上半明不说之人。下半明不说之事。超凡圣之表故称为尊。德不可称故名为重。此叹人也。智慧深远者。竖不见其底为深。横不恻其边名远。此叹佛内智也。久默斯要者。斯要即是平等大慧。内证斯法故称为默。不务速说者昔不匆务而即说也。又言务者事务。佛昔不得以大乘事务速为人说也。有智若闻下第三释佛昔不说之意。夫论不说其旨有二。一者至道无言言即乖道。是故不说。故肇师云。释迦掩室于摩竭。净名杜口于毗耶。岂曰无辨。辨所不能言也。二者如今文所明。恐根情未堪即生疑谤故不说也。是故迦叶下第四释昔权说意也。令得正见者正见即正观。正观甚难周正。三世诸佛种种因缘令人得之。迦叶当知下颂第二八譬。此文不依譬本次第颂之。亦不依合譬前后颂之。但转势说法更示一法门。第一颂云譬。第二颂两譬。第三颂大地譬。第四颂草木譬。第五颂受润譬。第六颂增长譬。第七第八同异两譬。合而颂之。要前兴云然后澍雨故前明云雨。云雨是能润。大地草木是所润。故前明云雨次明大地草木。大地草木禀于云雨故次明受润。受润故增长。能禀所禀有同有异。故次论之。前有如来出世故初明兴云。以出世故说法譬如澍雨。众生所以感佛形声者。由过去佛教生于善根。故明大地之与草木。既有宿习善根初闻说教欢喜譬如受润。禀教利益故增长。至理无二。随缘差别。故次明同异。云譬中上长行略今偈即广。凡有十种叹之。一者大云谓简小叹。如轮王出世十善化物乃至梵天说出欲论。皆是小益故名小云。乃至二乘菩萨不能普利皆名小云也。遍覆一切下第二平等叹。智度论云。摩醯首罗天韦纽天鸠摩罗伽天若爱众生即令所愿皆得。若恶之即使七世皆灭。故非平等遍益。华严明大龙王兴云从四天下乃至六天皆悉遍覆。随所见而兴云。随所乐而注雨。如来说法亦尔。于四生六道随所见而示现形。随所闻而说法。等观一切犹如赤子。故截手不戚捧足不欣。善恶自彼慈覆不二故名遍覆一切也。惠云下第三惠利叹。有云兴而无益。今是有益之云故名惠云。如来亦尔。示形说法必能益缘也。含润下第四作含德叹。自有焊云不能注雨。今是有润之云故云含润。如来之身大慈所勋。是故垂应必能益物。电光晃耀下第五放光叹。华严云。如大龙王从四天下至六天宫随所应见出种种色光。或阎浮檀金色乃至七宝色等。如来亦尔。将说法时随所应见出种种光。雷声远震下第六远闻叹。华严云。如大龙王从四天下至六天宫随所应闻出种种声。或天音或乐音乃至人中即闻雷声。今取雷声为喻者。能生众生五乘善根。能觉悟无明昏蛰。华严又云。通明无畏以为电光震实义雷也。令众悦豫者第七称缘叹。华严云。随所见而兴云随所闻而震雷故无不喜。佛形声亦尔。日光掩弊下第八破邪叹。云未兴时日有千光。以兴云故日光隐弊。佛未出世有九十六种邪智光明。佛既出世皆隐弊也。地上清凉者第九生善叹。由日光故众生热恼。由邪教故有邪见热恼。佛出世破邪见。即众生心地无邪见热恼。得正见清凉。叆叇垂布如可承揽下第十不思议。叹叆者叆晦也。叇者重累色也。大慈深厚所现之身犹如叆叇。府就于物为垂。随所见而普示形故称为布。如可承揽者遥观彼云可言傍揽及以下承。如来府顺于物如可承揽。不同众生故不可捉持。即是不思议也。其雨普等下第二颂雨譬。遍益为普。无私称等。四方俱下者从四无量心出普益四生也。流注无量者智慧辨才无滞必彻通。山川崄谷下第三颂大地譬。所生卉木下颂第四草木譬。雨之所润下颂第五受润譬。无善众生令其生善如干地普洽。有善根者令其增长如药木等并茂。一切诸树下颂第六增长譬。如其体相下合颂第七第八同异譬。佛亦如是下颂第二合譬。释合譬者不同。今宜开为二第一正合譬。第二末后两行重开示权实。就初合譬与上长行不同。上长行开为二。初合前五譬次合同异譬。合前五譬中初合云次合草木次合雨次合受润次合增长。今转势说法正合四譬兼合余四。正合四譬者。一合云二合雨三合受润四合增长。云雨是能应之形声也。受润增长是所感之利益。四义既要故正合之余四兼合。至文当出。上长行合云为二。初正合次劝众来听。今还颂此二也。上合云有四。初举佛形合云。二举佛声合云。三举号合云。四举德合云。今具颂之。初一偈颂第一。次一偈颂第二。次一行半颂第三。出于世间下两偈颂第四举德合云。上长行举五种德以合云。今但明二。五句举大悲德合云。三句举大慈德合云。大悲拔苦如云能遮离于热恼。大慈与乐如云能润也。安稳乐者现世乐也。世间乐者后世乐也。涅槃乐者出世乐也。又世间乐者生报乐也。涅槃乐者后报乐也。注解云。安稳乐者二乘乐也。世间乐者人天乐也。涅槃乐者大乘乐也。诸天人众下两偈颂长行第二劝众听受。初偈正劝众来听。第二偈释劝听意。上半简异邪师。即上叹于佛。次半明下益众生。为大众说下第二八偈颂合两譬。就合两譬又开三章。初借雨一味义以合譬。次借雨平等义以合譬。三借雨无懈惓义以合譬。所以但明此三义者。初章明所说为一理。次章教心平等等为五乘人令同归一理。第三叹佛为物说法无有懈惓。三章各二。初章二者。前偈明所说之法无二如雨一味。此即兼合上一相一味之言。第二一偈明所说之法无二能演之音亦一也。常为大乘而作因缘者。昔虽说五乘之味。此是为大乘作因缘耳。我观一切下第二二偈半借雨平等义以合譬。亦开为二。初一偈叹佛心平等。第二一偈半叹佛说平等。常演说法下第三三行半借雨无惓义以合譬。就文亦二。初一行半明能化之人说法无惓。贵贱上下下二偈举所化之人显成能化等说无惓。此即兼合草木义也。一切众生下第三十一行偈合受润譬。就文为三。初八偈正合受润。第二一偈半明理同随缘益异。第三一行半偈称叹于佛。就初又二。前一行总明受润。次七行别合三草二木受润不同。三草二木既是法华名教。今略序之。三草者下中上三品草也。二木者大小两树也。此是无阶级阶级故开诸位不同。不如有所得人一向定作浅深之解。所以然者。经中阶级之说无定。或说初发心时便成正觉。或说久劫行行方证菩提。或劝起道意令住不退转。或说实无发心亦无退者。皆是善巧化物。不可定相执之也。今示一方浅深故说三草二木。人天是世间乘名为小草。声闻缘觉是出世间乘名为中草。地前四十心既是大乘名为上草。若据无生忍而判义者。初地始得浅无生忍名为小树。七地深入无生忍名为大树。故智度论释无生有二位。一者初地二者七地。所以开二位者。若就二忍明义。地前凡位名为顺忍。初地已上既是圣位名为无生忍。若五忍明义地前名伏忍。初三地为信忍。次三地为顺忍。次三地为无生忍。若依璎珞经。后三地名寂灭忍。谓第十地等觉妙觉三地也。若依仁王经。但后二地谓法云地佛地也。第七地既是无生之始故名无生忍。若以功用无功用分二位者。初地至七地名功用位谓小树也。八地至等觉地是无功用道名为大树。经论不同。具有二义。依此经判位。三草二木总分三位。人天为下品。二乘为中品。菩萨为上品。就菩萨中自开三品。地前四十心为下品。登地已上亦开二品。若尔者二乘之人既称中草不及上草。即知是十信前人也。成论师不应言罗汉与六地齐功。又譬喻品云声闻之人以信力故得入一乘。即知未回小入大在十信前也

问。三草二木与五乘义何异

答。二科互有开合不同。五乘即开浅合深。三草二木即开深合浅。开浅合深者。开小草为天人两乘。开中草为声闻缘觉二也。合深者。总合大乘因果悉入佛乘也

问。何故尔耶

答。五乘之教并以果义标乘。故譬喻品云三车在门外。即以三果为三乘。菩萨为求佛果故还属佛乘摄也。人天乐果名之为乘。为求人天乐果故修人天两行。故以果标乘。为欲引物令修因趣果所以五乘明义。开浅合深也。三草二木开深合浅者。合前四乘为小中二草。以人天为小草。以二乘为中草。开深者。开大乘为三品。即上草及二木也。所以尔者。为扶此经赞扬大乘教菩萨法。明人天犹在三界火宅二乘未度五百由旬。是故合浅而开深也。又五乘明义即有佛果之乘。三草二木但取因乘不明佛果。所以然者。五乘为欲将五果以引物故说佛果为乘。今明三草二木受润增长之义故但说因也。又昔教明开义故开世间为人天二乘。开出世为三乘。故成五乘。今欲显合义故合世间为一。合二乘为一。故合彼四乘归于一乘。但一乘中自开三位。一者地前四十心为上草。二者初地已上为小树。三者八地已去为大树也

问。此与胜鬘经四种重担有何异耶

答。彼经明由大地故有四种重担。由摄受正法故有四乘。合天人为一。开二乘为二。合大乘因果为一也。与智度论五种善其义不同。不须会也。第二别明三草二木即为五段。初一行明小草。次二行明中草。次一行明上草。次一行半明小树。后一行半明大树也。佛平等说下一行半第二明理一而随众生得益有异。即兼合上第七第八同异譬也

问。何故合受润即合同异譬耶

答。上合云雨明同义。故云其法一味解脱涅槃。次合受润明三草二木差别异。今欲论其同异义也。明理唯有一随五种人故有五种异也。佛以此喻下一行半第三叹佛智慧也。如海一渧者。上信解品十譬十恩称叹于佛德。时众谓如来之德尽在四大声闻言下。故品初明八法八譬显如来复有无量功德。时众便谓叹佛德已尽。是故今明虽设此譬于佛智慧如海一渧也。我雨法雨下第四十一行半合增长喻。就文亦三。初八行半合增长喻。次一行半明理一随人得益不同。第三一行半称叹诸佛。前受润有三章。增长亦有三。以此科经于文极便。旧说异此。宜应改之。就初八行半又开为二。初三行半总合增长。次五行别合增长。就初又三。初一行法说。次一行举譬。后一行半合譬。声闻缘觉下第二五行别合。就文亦三。初一行半合中草增长。次一行半合小树增长。后二行合大树增长。故总合有三别合亦三也

问。何故不合小草与大草耶

答。前受润中已具合之。故今略彼二草

问。等是略者何故合中草耶

答。中草是小乘二圣。二木是大乘二圣。同是圣位增长义显。是故合之。小草是小乘中之凡。上草是大乘中之凡。既同是凡增长义不显故略不合也。又一义。前之二凡入总合中摄之。是以文云。令诸世间普得具足。世间即二凡也。但凡义增长不显故入总合中。增长意在圣果所以别合

问。受润亦明三草二木。增长亦明三草二木。有何异耶

答。受润据草木之因。增长明草木之果。但就因明受润不显故前文寄果明之

问。合大树中云闻诸法空心大欢喜。是何空耶

答。即上究竟涅槃常寂灭相终归于空。盖是明大涅槃果位之法。故大树因人闻之欢喜也。智度论云。譬如震雷小鸟闻皆怖孔雀大鸟闻之舞踊也。毕竟空法亦复如是。小人闻之惊疑怖畏。大士听受欢喜踊跃也。若言终归于空是灰身灭智空。八地已上菩萨岂生欢喜也。如是迦叶下第二一行半明理唯是一随缘得益为异。兼合上同异譬也。故同异譬受润增长二章兼合之。盖是转势之意。不应一一依长行也。迦叶当知下第三一行半称叹诸佛。前就不可尽叹。今就诸佛同有善巧叹。今为汝等下大段第二结示权实。初偈开权次偈显实。汝等所行是菩萨道者。昔说大因为小果。今指小果为大因。故二乘之果是菩萨道。法华论明无上义有十种。一者示现种子无上故说云雨譬喻。汝等所行是菩萨道者。谓发菩提心退已还发。前所修行善根不灭同后得果故。此意明本菩提心不灭故此善根即无上种子。由此种子故今闻法华。即是云雨后得成佛

问。若尔决定声闻善根应非菩萨道耶

答。决定之人即是守教封执小果。即被破不会。若转悟者即会而不破也

    授记品第六

授记既是法华要义亦是众经大宗。今略释之宜开七门。一来意门。二释名门。三能受人门。四所授人门。五阶位门。六料简门。七同异门。初来意门者为中根说法凡有四门。初譬说次领解三述成四授记。今即第四也。以领解十譬十恩于前。以八法八譬述成于后。其心安泰即当果可记。所以如来为其授记也。依法华论意者。自上三品破凡夫二乘菩萨三病。即悟非凡非圣非大非小。得无依正观行与佛相应故授以佛记也。若望今昔二病除者。昔执异不知同。今即执同不知异。若了前同异譬意。即今昔病得除便悟至道未曾同异。善巧方便同异适缘。以悟未曾同异即生于实慧。了随缘同异即生方便慧。具足二慧即佛道可成。故净名经云。智度菩萨母方便为父。父母具足则当成法身故与授佛记也。若接品末生者。上品末开方便门示真实相。诸声闻众皆非灭度谓开方便门。汝等所行是菩萨道谓示真实相。昔不悟大因为小果故执小果而迷大因。今悟小果是大因故便有大因。有大因必得大果故授以佛记也。二释名门者。授者云与也。记者云决也亦云莂也。所言决者。于九道内分决此人必当成佛故云决也。莂义亦然。悬说未来事以授前人故名授记。前人领受故云受记。又泛论记无记有三。一就三性门论记无记。若有善恶可记故名为记。无善恶可记故名无记。二善恶能感苦乐果。有苦乐果可记名为记。无记不能感苦乐果。无果可记故名无记。三者有物可记故名有记。无物可记故名无记。如华严以十四难为无记门也。即是无物可记故名无记也。如石女无儿可记也。而与此相违故名有记。今云修佛因得佛果。即是有果可记故名为记。圣记示人称为授记也。又释记者言录。示果有可记录也。十二部经中有授记经者。以因果事大物多惑之。宜别开一部。第三能授记人门者。此经授记人有二。一者佛授记二常不轻菩萨授记。此二不同者。佛具授通别两记。言别记者。如来具三达智知此人未来成佛久近。故与其劫数之记。如授三根人记等。故名别记。言通记者。如法师品云闻法华经一念随喜皆与授记。而不说其劫数久近。以去佛道长远义故但与通记。常不轻菩萨迹居因位三达未圆。故但得与通记不得授别记也。第四所授记人门者。泛论得记人自有三种。一者凡夫二者二乘三者菩萨。今此经备与三种人记。以此三人皆有佛性必当成佛故并得记之。依法华论释授声闻记中有四种声闻。一者决定声闻。二者增上慢声闻。三者退菩提心声闻。四者应化声闻。二种声闻佛与授记。谓应化声闻及退菩提心还发菩提心者也。决定增上慢二人根未熟故佛不与授记。然决定声闻保执小乘。增上慢人自谓究竟不信作佛。即不堪与记亦不堪破执及会归义。而此经会一切二乘以成佛者。盖是对应悟之人故说此经明破及会义耳。增上慢亦尔。如五千之徒不堪闻于破会。以根未熟故。常不轻所对增上慢者。其根已熟堪闻破会故为说一乘也。第五明阶位门者经论不同。或说一种授记故直名为授记经也。或说二种授记。如涅槃经明。应与迟记者授之以迟。其人闻速得佛心生轻慢故授以迟记。若言佛道难得久受勤苦然后成佛心即退失。为此人故授以速记。又善根熟者授之以速记。善根未熟者授之迟记。又乐久处生死化物者授之以迟。厌恶生死欲早成佛者授之以速。又有二种记。一总记二别记。如上释之。智度论明三种授记。一自知他不知。为利益自故不为利他。二他知自不知。为利益他故。三自他具知。具利益自他故。又有四种授记。一未发心授记。二发心授记。三现前授记。四不现前授记。未发心授记有二。一都未发心而授记。如鸠鸟等。二虽已发心而未成立亦名未发心也。二已发心授记有二种。一者初始发心即与授记。二者发心成立名为发心。即十信位。三不现前授记。谓三贤菩萨未得无生忍故不堪现前与无生记。四现前授记。初地已上得无生忍堪为现前授无生记。地持论云有六种授记。四种大同于前而明位小异。第五时量时定。谓劫数有限。第六时无量时不定。谓劫数无限。此二犹是上总别记耳。第六总料简门者。法华论明此经有六种授记。一者舍利弗迦叶等众所知识故名号不同故与别记。二者富楼那等五百人千二百人等同一名故俱时与记。三者学无学人等俱同一名又非众所知识故一时与记。四者与提婆达多记示现如来无怨恶故。五者与比丘尼及诸天女等记示现女人在家出家修菩萨行皆证佛果故。此五是如来自与授记。第六常不轻与四众记示现众生有佛性故。今更以四句释之。一者同时得记成佛有前后。如五百罗汉是也。二者同时得记同时成佛。如学无学二千人是也。三者前后得记前后成佛。如四大声闻是也。四者前后得记。同时成佛义应有之。又有四句。一者小乘无优劣大乘有优劣。如五百弟子同时成罗汉。故小乘无优劣。而转次成佛。如初人成佛竟授第二人记。故大乘有优劣。二者小乘有优劣。大乘无优劣。如学无学二千人。有学无学故小乘有优劣。同时成佛故大乘无优劣。三者小乘劣大乘胜。如阿难住初果故劣。罗云得第四果故胜。而阿难在前成佛。罗云在后成佛。故大乘胜。四者小乘胜大乘劣。则罗云得第四果故胜。阿难在学地故劣。而阿难在前罗云在后则其事也

问。何故经中呵受记。如净名破弥勒三世门中无受记无生法中亦无受记。今何故说受记耶

答。净名经为破有所得病言人为能受法为所受佛为能授菩萨为所授。是故破无受记。今为对声闻人言罗汉不成佛。是故与其成佛之记也。又彼经明不见能受所受能记所记故则不得记。今经明记无所记故云授记。二经不相违也。又佛法有二谛。如来常依二谛说法。依世谛门说法故有授记。依第一义谛门说法故无授记也。第七同异门者

问。授二乘记与菩萨何异

答。法华论云。二乘有佛性法身故授记。非修行具足是故与记。若菩萨有佛性法身又修行具足。是故与记。故大小得记不同

问。授声闻记与缘觉记云何异

答。大开四句。一者缘觉果人但在三界外闻法华经亦三界外得记。二者缘觉因人及声闻因位并在三界内闻经得记。罗汉有二。一者值佛界内闻法华经得记。二不值佛。如化城品中明佛灭后罗汉生三界外闻经然后得记。此四句大判为言

问。何以得知缘觉界外闻经

答。华严云。菩萨将欲下生前以天眼观世界。若有缘觉放光照之。若觉知者则取灭度。不觉知者移住他方。此人既三界内不值佛。故知三界外闻经方得记也。若有缘觉值佛者。亦有三界内闻经得记。此义小耳。就此品有二。初正授记。二闻下根之端许说宿世因缘。就初又二。前授四大弟子记。次授五百弟子记。逆击其心也。初中有二。前授迦叶后授三人。初授迦叶中前长行次偈颂。长行又二。初告大众后正明授记

问。授身子记但告一人。授迦叶记何故通告大众

答。互显其文也。又上根唯一人故但告身子。中根数多故通告大众。又欲开身子化物之路所以别告。欲广发时众求佛之心故通告也。唱如是言下第二正授记又二。前辨行因次明得果。行因中三句。一者奉觐诸佛。二供养已下明三业殖福。三广宣已下明弘法以种慧。于最后身下第二明得果有六种果。一化主果。国名光德下国土果。劫名下时节果。佛寿下寿命果。正法住世下住持果。国界严饰下重明国土果。前出土名今出土体。其国菩萨下明眷属果。虽有魔及魔民皆护佛法者大明土有三。一者秽土。一向有魔作于留难。二者纯净土。一向无魔。三中容之土。亦有魔亦无魔。顺同余方示现为魔是故言有。皆护佛法所以言无。然魔佛难识。了悟即魔为佛。不悟即佛为魔也。十二行半偈分为三。初一行半总标与记。十行半别释授记。后半行总结授记。就十行半又有二。初两行半颂行因。次八行颂得果。就初两行半中颂上三章。初一行半颂亲觐佛。次半行颂三业修福。次半行颂前弘法以种慧也。于最后身下颂得果。半行颂化主果。三行颂国土果。三行颂眷属果。眷属果中前颂菩萨次颂声闻。半行颂寿命果。一行颂住持果。略不颂时节果也。尔时大目揵连下第二授余三人记又开两别。初请记二授记。请记为二。前长行次偈颂。初请记者。示佛从修因所得。是故请也。皆悉悚栗者。三大弟子自谓已解大乘。而佛未为授记。三人恐所解非解堕增上慢故悚栗也。又三人喜其所解。次至惧于未堪喜惧交集所以悚栗也。偈文为三。初两行正请。次四行释请。后一行结请。三中各二。初文二者。前一行明叹佛已赐通记。次一行正请别记也。次文二者。一行半譬说。二行半合譬。小无大食为饥。背小向大为来。忽遇王膳得总记也。未敢即食未得别记也。若复得王教然后乃敢食。若得别记领解方决也。我等亦复如是下合前如从饥国来也。虽闻佛音声下一行合上未敢即便食也。若蒙佛授记下半行合上得王教然后乃敢食也。后一行为二者。初半行叹佛次半行结请。尔时世尊下第二授三人记即为三别。授善吉记中前长行次偈颂。长行有二。前明行因次辨得果。得果之中有七种果。一化主果。二时节果。三国土果。四眷属果眷属之中凡有三种。一者其土人民谓凡夫眷属。次声闻眷属。后菩萨眷属。盖是下中上品人也。次寿命果。次住持果。其佛常处虚空下明说法果。以善吉因时解空。得佛之时处空说法也。偈文为三。初二行总标佛记。次一行颂上行因。余九行颂得果。此中一行颂化主。一行半颂国土。三行颂眷属。眷属之中不颂凡夫但颂声闻菩萨。长行从劣至胜。前声闻后菩萨。今从胜至劣。前菩萨后声闻。次两行颂说法果。次半行颂寿命果。一行颂住持果。略不颂时节果。偈与长行前后不次第者。皆是转势说法。各示一门。有意寻经观文而生起之也。授栴延记长行为二。前行因次得果。行因为三。初于少佛所行因。过是已后下明于多佛所行因。供养是诸佛已下第三结因义具足。得果之中略明五果无时节果也。阎浮那提金光者。阎浮者此云秽。那提者州也。阎浮提州有水。水下有金光。金光出水上。借此为名也。偈文为二。初三行颂行因。后四行颂得果。得果之中三句略颂化主果。一句颂国土果。二行重颂化主。一行颂眷属。略无余三果也。授目连记长行中前明行因次明得果。行因中前于少佛所行因。当复供养下明多佛所行因也。得果中具足六果也。多摩罗跋者(草叶香名此云葵香也)眷属果中前从劣至胜故菩萨在后。次从胜至劣故菩萨在前。今示菩萨行于中道故在中间。又人天形心俱劣故在初。菩萨心胜形无定方故在第二。声闻心形俱胜故在第三也。初五偈颂行因。于意乐国下颂得果。一句颂国土果。三句颂化主。半行颂寿命。半行颂说法果也。二行颂眷属。一行颂住持。我诸弟子下第二段一行半总授五百人记。我及汝等下大段第二一偈许说宿世等因缘也

    化城喻品第七

今以三门释之。一来意门二释名门三决疑门。来意门者。乘权乘实凡有三周之说。一法说门二譬说门。此二已竟。今是第三亦法亦譬门。化城之前名为法说。化城已去称为譬说。上中二根各禀一说。下根之人须具陈法譬也。化城之前明法说者。谓说过去世结缘之始。化城已去明譬说者。由过去结缘现在更复相值故重为说化城之譬。具序二世始终钝根方乃领解故有此品来也。二者为释疑故来。疑者云声闻之人禀法华经即能解悟现在得记未来成佛。若尔何用菩萨历劫修行。为释此疑故明。三根声闻久劫已来曾发大心修菩萨行。但中途忘失暂证小果。今闻大乘还得本悟故现在得记未来成佛。为释此疑故说今品。故上二周领解即是得悟之果。今一品明得领解之因。故虽有三周不出因果二义也。三者譬喻品云为诸声闻说大乘经名妙法莲华教菩萨法。但声闻有二种。一者本乘声闻二者退大证小声闻。为二种人明二种说。为本乘声闻直说现在法门。谓现在有三乘根性。在三界火宅之中。权说三车引令得出。既得出宅更以种种方便调伏其心令小志渐移大根稍熟。然后为说佛慧令初起信心。上法譬二周多明斯意。谓化本乘声闻也。二者为退大证小声闻说过去世法凡有三时。一者初学大乘时。二退大取小时。三舍小悟大时。现在说化城譬亦有三时。一者初说大乘时。二者中途说小时。三后还说大时。如此之说多为退大证小声闻人也。故声闻不出二种。三周唯此两门。此皆大判为言。二门互通前后也。依法华论意者。论云实无而谓有增上慢人。以有世间三昧三摩跋提对治此故说化城喻。论明凡夫人得世间禅定计非想无想为涅槃。故今明声闻涅槃尚如化何况凡夫是实也。欲令声闻人舍小涅槃得大涅槃故说化城喻也。第二释名门者。竺法护所翻名往古品。此从初为名。罗什师所译称化城喻。即从后文受称。但二名各有一义。题往古者得显过去结缘之始。标化城明现在破执之终也。但往古意通漫破执义奢。化城语别斥病切要。以其无而忽有故称为化。防非却敌称之曰城。晓喻下根明昔果非真则是开方便门。进至宝所谓显真实义。直制此名具得开权显实故执断疑亡。故云化城喻品也。第三决疑门者

问。三车二使一城并皆是权。此有何异

答。本有三乘根性故说三车。二乘人领解知唯此一事实余二则非真故称二使。二乘虽异同断见思烦恼同得无为涅槃故名一城也

问。三车与三使何异

答。长者遣傍人唤子不得。更遣二使唤子便得。故一使是真实二使为方便。此义同长者衣裓机案化子不得三车救子得。衣裓机案是真实三车是方便

问。三车中大车为是实为是方便也

答。具有二义。若道理无二唯有一者。则二是方便一是真实。是故前云唯此一事实余二则非真。后又云唯有一佛乘息处故说二也

问。若尔既一使化不得二使化便得。亦应一大车引不得二车引便得

答。亦例。但譬喻品意宅内本三十子。不可但以一乘化之。故衣裓等救不得。为说三车便得。今二使正为二乘作譬。故一使唤不得二使唤便得也。二者云一乘是真实三乘是方便者。而以方便密遣二人故二乘是方便。脱珍御服着弊垢衣以是方便得近其子。此之佛乘亦是方便。所以然者。无有从凡夫身于道树下始得成圣。为二乘故方便示现也

问。二车一城俱方便。何故城一而车二

答。通而为论得互相类。既得称为一城。亦得称为一车。故声闻缘觉同名小乘。约智优劣既分二车。亦得就人不同开二涅槃。故下文云为止息故说二涅槃。涅槃经云世若无佛非无二乘得二涅槃。又言舍利弗等以小涅槃而般涅槃。缘觉之人以中涅槃而般涅槃。而今车二城一者。欲就根性利钝故明智有优劣。所以开为二车。俱出三界同止息义。故合为一城。大宗而言。欲显二乘异义故分为两车。二乘复有同义故合为一城

问。二乘有几义异几义同

答。异义乃多略明十一种异。一者根有利钝异。二者修因短长异。声闻极疾三世。极迟六十劫。缘觉极疾四世。极迟百劫。三者时异。声闻与佛同世。缘觉与佛异世。四者有悲无悲异。如智度论。三兽被围。声闻如鹿。但免自身。是故无悲。缘觉如羊。虽得出围回顾念子。则有少悲。五者福德厚薄异。缘觉身必有相好。但或具足不具足。声闻身或有相好或无相好。六者有印字无印字异。缘觉手中有十二因缘印字。声闻手中无四谛印字。七者现通说法异。声闻多为人说法。缘觉多为人现通。假令说法唯说一偈。八者利益浅深异。声闻说法能令人得七贤七圣。缘觉说法不能令人得燸法顶法乃至罗汉。所以然者。声闻与佛同世。众生福德利根故闻说教法得成圣果。缘觉出无佛世。众生薄福钝根虽闻说法不能深悟亦不堪多说也。九者境界异。声闻天眼依智度及杂心以二千世界为境界。缘觉天眼以三千世界为境界。十者出处异。声闻出于人世。缘觉隐处山林。十一者渐顿异。声闻渐得四果。缘觉顿证一果也。所言同者略明七种。一者断惑同。谓同断见思二惑。二者出义同。同出三界。三者智同。依大品同得一切智。依小乘同得尽无生。四涅槃同。同得余无余二涅槃。五见同。同见四谛理。六同知过去未来八万劫事。七同名一小乘

问。曰诸子出门何故不见三车中路见于化城也

答。据譬而言。子在宅内车在门外。就说法轮作譬。父虚指门外明有三车。诸子出门不见有三。此就今教为譬。欲显道理无三。为成等赐大车义。故寄诸子出门不见有三就父索三以显无三。城就神通轮为譬。城在迥道无物隔之。同侣诸子举目便见。此就昔教为言。明众人欲退故令其见城而入城也。若以城例车。昔既见城而入城。昔亦见车而乘车。车是涅槃。昔已证涅槃。如身子云尔时心自谓得至于灭度。若以车例城。今出门既不见车。今中道亦不见城。但如来转势说法。约今昔不同故城车有见不见异。又不见车显理无三明实智义。见有城显方便有三明权智义。又城车异者。车多据有为智德。取其运动为喻。城多据无为涅槃。取其静一以立譬也。宿世因缘说凡有三品。例前二周皆应有四。一正说二领解三述成四授记。今明虽有三品宜分为二。初品正说后两品明授记。其中并明领解。不可别开。所以但明二者。诸佛说法有略有广。前为利人是故广说。后为钝人故所以略明

问。初二周何故前领解后方授记。今宿世因缘说何故前授记后方领解

答。旧释云欲表下根人取悟为难。今虽为说尚未明了。更须授记解心始决方述领解也

问。何以知然

答。前云心犹怀疑惧未敢即便食。中根尚须待记解心始明。岂况下根人也。今谓此释小成难解。若中根待记解心始决。亦应待记方述领解。今更以一义释之。下根人闻说宿世因缘及化城之譬即为领解。是故如来便为授记。得记已后方述其领解。盖欲辨教门不同故三周得记领解前后为异耳。此品大意正欲明过去世作十六沙弥为汝说大乘经。但中途忘大是故取小。今还欲令汝舍小悟大故说法华。但此义不可直明。必须具陈宿世缘由之事。宜开二别。初一长行一偈略述过去结缘时节长远。次一长行一偈广明过去世结缘之事。就前又二。初长行次偈颂。长行为五。第一明结缘时节。尔时有佛下明结缘之佛。其国名好成下明结缘之处。劫名大相下明结缘劫名字。诸比丘下第五明结缘时节久远。所以明时节久远者。欲示诸声闻薄福钝根昔本学大乘经尔所时乃至于今由住小果一何可伤。二欲明生死长远令诸众生深起怖畏坚固道心令不退转。三欲叹如来能知久远犹如今日令二乘人自鄙浅劣欣乐佛智。四者欲示法华是古佛道法小乘闻说不应惊疑。就此文内又开五句。一者法说。譬如下第二举譬以问比丘。不也世尊下第三比丘奉答。诸比丘下第四正明过去长远。我以如来知见下第五称叹佛智。地持论明佛有三智。初第一义清净智谓断惑空智也。二一切智知有法也。略知四法。一者知一切时谓三世也。二知一切界谓世界及众生界。三知一切事谓有为无为事也。四知一切种谓世出世因果种别也。三无碍智亦是有智也。于上四法欲知则知而无有碍。今云如来知见者即是后二智也。又亦具三智。所以知然。叹佛观于久远犹若今日。此近远不二。故华严云。一念无量劫。无量劫一念。无来无积聚而现诸劫事也。偈文但颂三事。半行颂第一时节。半行颂第二化主。余六行颂第五过去久远。上长行有五。今但颂三。初二行颂第二举譬问诸比丘。次两行颂第四明过去长远。次两行颂第五叹佛智也。佛告诸比丘下第二一长行一偈颂广明过去结缘之事。就文亦二。初长行次偈颂。长行又二。第一明过去结缘之始。第二明现在复相值更为说法。此二是过现始终也。就初又二。第一明结缘之由。第二正明结缘。二文各二。结缘之由二者。一结缘远缘由。二结缘近缘由。正结缘中亦二者。初明一世结缘。二辨世世相值。结缘远缘由中开之为四。一明大通智胜成佛。第二十六王子请转法轮。第三成佛竟现瑞相。第四十方梵天云集供养劝请。四段次第者。初缘熟故成道。以成道故近众云集请说法。近众虽来远众未集故现瑞召之。有缘同见故远众皆集供养劝请。虽有四章不出二事。第一第三明能化事。第二第四辨所化事。就此四章各开三别。合十二章经。初门三者。第一明十劫坐道场未成正觉。第二诸天供养。第三过十劫乃成佛也。初文明佛寿五百四十万亿那由他劫者凡有三义。一者成上过去长远。佛寿已如此之长。况灭度后经尔所劫也。二者将明十劫坐道场及后入定八万四千劫。故前须明佛寿长远也。三者三周说法明乘权乘实将竟。欲远开寿量之义故明古佛寿远也。使后开释迦寿远不生惊疑

问。何故十劫坐道场

答。适缘不同。如释迦六年苦行弥勒即出家日成道也。而言十劫不成佛者。此欲待物缘熟在于十劫故此时方成也又有二益。未成道令其供养生物福也。成道竟受请说法生物慧也

问。菩提难得易得有何义耶

答。如大品数处明之。一者约有方便无方便明其难易。无方便故为难。有方便故为易。难易出两缘耳。菩提实无难易。又世谛门明菩提难得。第一义门菩提易得。又为轻贱佛道众生故言菩提难得。为怖畏生死长远众生故言菩提易得也

问。云何名道场

答。道场有二种。一者法身道场二者应身道场。法身道场者。道谓三菩提果道也场谓万行也。如净名经说由万行故能成三菩提道。是故因行为果道之场也。应身道场者。摩竭提界元吉树下起道之处为道场也

问。若言因行为道场。何为净名经云一切智等为道场耶

答。道场具通因果。一者即因能起道名为道场。如前说之。二者即果亦是道场。无上虚通故称为道。即此妙道圣所履践故称为场。今以四句释之。一者道而非场谓无上果道也。二者场而非道谓菩提树下起道之处也。三者亦道亦场即如前说谓果道场也。四者非场非道泯上三门归于寂灭言忘虑绝也。时诸梵天王下第二明诸天供养也。诸比丘下第三明过十劫大通智胜成佛。但成佛有二种。一法身成佛。如从初发心至等觉地后转成妙觉地佛。此是变易生死将倾故于三界外法身成佛也。依摄大乘论三界外有四种生死。三地以还名方便生死。四地至七地名因缘生死。八地至十地名有有生死。金刚心一刹那名无有生死。佛性论云。三地是世间地宜名世谛。亦是福德。福德望智慧则福德是缘义名方便生死。四地至七地名出世间地亦名真谛。称为智慧。智慧是因名因缘生死。论举喻云。方便生死如无明生行。因缘生死如行生识。故知无明为方便而行正是因也。有有生死者有生亦有死也。无有生死者但有一刹那生后则转成法身。法身成佛正是离无有生死。应身成佛者凡有二种。一者依大乘。十地行满坐于道场。或有三界外净土中成佛。或三界内净秽土中成佛。二者小乘成佛定在三界内。俱舍论有二种释。一云佛于菩提树下坐作不净观乃至次第证尽无生智始出观名为成佛。二云于道树下从四善根次第入见修道三十四心成佛。大小乘成佛异者。小乘从凡转成圣。大乘从圣至圣

问。依小乘而说。佛是大利根人。无有坐道场佛法不现前义。上云何佛法不现前耶

答。今就大乘方便住待缘三昧故言佛法不现前耳。若就小乘释迦六年苦行亦得称为佛法不现前也

问。六年苦行是坐道场以不

答。非也。六年苦行竟受乳糜已后始取草坐于道场方成佛也。其佛未出家时下第二明十六王子请转法轮亦开三别。一与眷属至于佛所。二到已恭敬赞叹。三正请说法

问。何故初列十六王子不前标其祖转轮圣王耶

答。凡有二义。一者十六王子有请转大小二乘法轮之功故前列之。二者十六王子又能覆讲。今正明与王子结缘故初列也。名曰智积者。平等大智皆已积聚。故能请转二轮及覆述妙法华经也。皆舍所珍者。至佛所意必欲出家。故舍小乐而求大乐也。诸母涕泣而随送之者。爱情未断是故涕泣。道缘已会故而随送之。到已头面礼足下第二次明敬叹。前长行身业恭敬。次偈颂口业称叹。自有叹而不敬敬而不叹亦敬亦叹非敬非叹。今具二也。偈文为四。初一行半叹佛成道。次两行叹坐道场。次四偈明自庆。后半偈结叹。尔时十六王子下第三请转法轮。前长行次偈。偈文为三。初二行半正请说法。次一行半叹佛知机释堪请之德。后半行正结请。而言百福者。一善有五品心。谓下．中．上．上中．上上。十善合五十。始有五十心终有五十故名百福也。佛告诸比丘下第三明成道已后现于瑞相。所以现瑞者。为欲广集有缘令受道法。又十劫坐道场谓圣默然意业利物。今辨放光谓身业利物。后受请说法谓口业利物。又成道已后具三业利益。放光为身业。动地为意业。说法为口业。就文又三。初动地。二放光。又其国界下第三明二瑞所至。所以放光者。表智炬将晖故身光前曜。二者欲灭众生障碍。三欲召集有缘令知佛出世。所以动地者。后偈颂释云。为觉悟群生灵动于一切。令众生知有佛出世也。别明二瑞所至者。前二章为利益余众。今的召集梵王也。尔时东方下第四明十方梵天云集请转法轮。所以但明梵王请者。上明十六王子为近众请。今列十方梵王明远众请。略举近远。其中间例可知之。故后文云诸梵来时见十六王子请及八部恭敬。故知略举近远例中间也。又十六王子明人请。今辨天请。以天人是受道器故。又十六王子明内眷属请。今明外眷属请。就文亦三第一明三方梵王来请。第二例于六方。第三别明上方梵天来请。三方请即三段。一一方例有六章。第一睹瑞生疑。第二诸梵谋议。第三寻光至佛所。第四三业供养。第五请转法轮。第六如来默许。是时诸梵天王下第二文也。尔时五百下第三文也。真谛三藏云衣裓是衣箱也。今谓衣前衿也。即时诸梵王下第四三业供养。前长行明财供次说偈明法供。又前是身业供养。后是口业供养。又前是供养后是称叹。长行为二。初辨恭敬。即以天华下明供养。初以华供养表欲行因也。次奉宫殿表欲求果也。华供养中前供养佛谓正果也。次供养菩提树谓依果也。又前表人尊后明处重。奉宫殿者。舍形之所栖欲求神之所宅。偈文为三。初两行称叹佛德。次一行自序来意。后一行请受供养也。尔时诸梵天王下第五请转法轮。前供养以祈福。今请说以求慧。又前叹佛之福田。今叹佛为施主。又前是自行今请法是化他。尔时大通智胜下第六默许

问。涅槃时亦默而不许受供养。今亦默然。何以知受请耶

答。有人言佛颜有舒敛故知受不受。有人言身光上下表之故有受不受。有人言初成道时佛有唱号。默然者便是受请。涅槃时默然者便不受请。余二方如文。西南方乃至下方第二段例余六方。上方梵王说偈称叹中十行半偈开为二。初八行半叹佛。次两行请受供养。初叹后请者。初叹明佛有胜德。故后请受供养。就初叹中初两偈叹佛慈悲德。前偈叹大悲次偈叹大慈。于昔无量劫下有六行半第二叹佛难值。初四行半明昔不值佛。次两行自庆今得值佛。初四行半中为二。初三行半明起爱众生不值佛也。住于邪见法一偈明起见众生不值佛

问。东南方诸梵云一百八十劫空过无有佛。次南方梵云过百三十劫今乃得一见。今此文云于昔无量劫空过无有佛。何故三处不同耶

答。寻佛应世感见不同者。犹由众生行有厚薄之异故睹接致久近之差。一百三十劫上品人也。一百八十劫中品人也。于昔无量劫下品人也。略举三品不同则略摄感应义。尽失乐及乐想者。对境发爱为乐。心取境故为乐想。又释乐谓乐具。想即乐受。生死无有实乐故称为乐想。尔行大通智胜下第二明近缘由。以去覆讲事近名近缘由。亦开为四。初受请说小乘法轮。第二十六王子请转大乘法轮。第三受请说法。第四说经竟入定。前一明说小。后三辨说大。就此四章各开三段亦合十二章经。初章三者第一明受请。第二明一会说法。第三多会说法。初文前列十方梵天后明十六王子者。前文从近至远故自人及天。今从天及人自远至近。又遂文势便接上天众故前列天后列人也。即时三转下第二正明说法。就文为二。初明说法二时众悟道。就初又二。前说四谛次说十二缘。就说四谛为三。初表三转十二行。次明余人不能转。后正明三转。言三转者。一示转谓是苦是集是灭是道。二劝转苦应知集应断灭应证道应修。三证转苦我已知集我已断灭我已证道我已修。引佛为证转。复有一谛三转。谓是苦苦应知苦我已知。余三亦尔。十二行者。若用教为法转说此十二种教生众生解。解行于境故称为行。又佛如行而说而众生如说而行故云十二行。若以解为法轮体一转生四行。谓眼智明觉。眼谓法忍。智谓法智。明谓比忍。觉谓比智。一转生四行故云十二也

问。一转既生四行则生四法忍四法智四比忍四比智。生行已足。后二转更何所明

答。成论师云。初转生闻慧。次转生思慧。后转生修慧。依婆沙宗为三根人故有三转。初转上根即悟生于四行。乃至三转下根人悟亦生四行。今三根合论故有十二行。若广开之便有四十八法轮。初转四行谓见道十六心。余二转各为十六合四十八也。又初转生未知欲知根。次转生知根。后转生知已根。又初转生见道。次转生修道。后转生无学道。依释迦趣鹿苑说法。天人但证初果。宜用前约三根人释之。若依大通智胜说法。皆悟罗汉。宜用三根三道二义释之

问。依毗昙宗用何为法轮体

答。杂心云。牟尼说见道疾故名法轮。谓见谛解起具戒定慧。以三种戒为轮毂。三种慧为轮辐。二种定为轮辋。三种戒谓正语正业正命。三种慧谓正见正思惟正精进。二种定谓正定正念也。所言轮者谓轮转义。观欲界苦次观上界苦。次乃至观欲界道次观上界道。以三界四谛上下轮转故名为轮。断见谛惑为轮用。照四谛境为轮行四方也

问。毗昙见道但有十五心。云何具十二行

答。道比智是忍家流类。印证见谛惑无。然非见道摄也。成实见道唯一空行。亦无十二行。故数论二家释十二行于文为难解也。别有经说十二因缘为十二行。若尔三转目四谛十二行约十二因缘两事合说也。若沙门下第二明余人不能转。智慧人有二分。出家为沙门。在家为婆罗门。天有二分。欲天主为魔。色天主为梵。及余世间此天人以外称为余也

问。三乘人尽得见谛道。何故言佛独能转余不能耶

答。二乘人虽能入见谛道成无学。而无一切智。不能善识机缘。不为物情所信。故不能转。又佛能自转能为他转。声闻不能自转故不为他转。缘觉虽能自转。而缘觉出世无他人成圣故不能为他转。故涅槃云。缘觉说法不能令人得燸法等。谓是苦下第三正明三转。略举其一也。及广说十二因缘下第二所以明说十二因缘者有二种义。一者广上四谛义。广苦集为十二相生。广灭道为十二还灭。二者时坐有二种根缘。一求声闻二求缘觉。为求声闻说四谛。为求缘觉说十二因缘。故信解品云密遣二人。即其事也。言无明者。一显通隐别故说无明。过去世中一切烦恼皆有闇惑迷理之义。就此通义故说无明。二者无明烦恼迷于本际集起生死。其力最强从强为名故说无明。无明有四。一迷理无明。所谓迷于二谛之理。故地经云不知世谛第一义谛故名无明。二发业无明。所谓三根三毒烦恼。三根烦恼能发思业。三毒烦恼发身口业。三覆业无明。谓造业已重于前境起贪嗔等。复助前业令其增长。四润生无明。若依成实论。唯爱能润余但远助。若据斯义。润生即狭唯在于爱。受生则广通于余结。地经亦然。故彼经言。爱水为润。无明覆弊。我心溉灌。毗昙云。润生受生诸结皆能。但缠垢等能润不能受生。行者谓罪福不动三行。亦身口意三行也。识支者凡有三种。一种子心识作行已后受生之前所有心识。为业烦恼所勋发故能生后果识说为识支。二者无明行中所有心识亦是识支。三受生心识名为识支。谓生时一念之顷染污识也。名色支者。四阴名名。色阴名色。当于尔时四阴才裁有其名未有其用故称名也。又释名色两字但目于色。谓此是内色。受众生名异外色也。又释色当法体为目。心从能诠名字受称。以心法隐昧故以能诠之名目之。六入者生识处名入。色增长名五入。名增长名意入也。触支者触对前境故名为触。依毗昙解触有五种。一增语触。谓意地触数能发语言。二有对触。五识中相应之触触对现境故名有对。三者明触谓无漏触。四无明触谓诸烦恼相应之触。五处中触所谓一切有漏之触。所言受者。或总名一受。或分为二。谓身心两受。五识相应为身受。意识相应为心受。或三或五或六。六根生受。或十八。六忧六喜六舍。此亦二。垢．净。为三十六。三世论之合百八受。所言爱者。涅槃经云染集一爱。尔时但有食爱未有欲爱故称为一。所言取者。烦恼既重四方驰求故称为取。毗昙四取具摄百八烦恼。欲界烦恼之中除于戒见故名欲取。以缘外欲故名欲取。上二界烦恼除于戒见缘于内生名我语取。此二分上下界异故开二取。次三界四见名为见取。三界戒取名为戒取。此二通三界论。钝使分二取利使分二取也。若依成论。身见一使名我语取。实无我体但着我名故云我语。依此身见起于边见取着断常。若见断者即着五欲名为欲取。以无后世贪现乐故。若见常者有利有钝。若钝根者则便持戒望后世乐名为戒取。若利根者说神是常苦乐不变即无罪福故起邪见说为见取。成实四取摄惑不尽。所言有者。业能牵于三有故名为有。又含有未来果故为有。现在世识名未来生。现在名色以去四果名为老死。十二缘义广。今略释名也。说是法时下第二明悟道。欲显说教不虚故明得道也。不受一切法者。心无爱着故名不受。有人言。空观现前不受三有相续故名不受。有人言。得道之人五根缘五尘不起烦恼。不起烦恼故不造恶业。无恶业故不受三恶果报。故名不受也。第二第三第四说法时下第三明多会说法。然弥勒有三会者度释迦余残三根众生也。于释迦佛持五戒人初会得道。受三归人次会得道。一称南无佛人三会得道。复有独与弥勒结缘。更为说法。不止局于三会。今四会说法类此可知。就文亦二。初明说法次辨悟道。文处易知也。尔时十六王子下第二请说大乘法轮。所以请者凡有二义。一者见诸人皆成罗汉大机欲熟故为请说大乘。二者远欲讥斥今日下根声闻。明我昔日为汝诸人以请说法华。况今成佛而不为汝说大乘耶。自昔至今凡经几载说。犹故不解此为极愚也。就此文亦三。初为请法故出家。二正请。三王眷属亦随出家。皆以童子出家者。四岁已上称为童子。即表菩萨修童真行也。又幼而悟道则众所归伏。出家者欲通化道俗。在家之人不得化出家人。二者欲引导八万亿人令出家。沙弥此云息恶行慈。谓息恶行慈。欲表菩萨为物请法有大慈也。前称智积举智慧门。今名沙弥明功德门也。作沙弥覆讲者。明幼而早悟世所希有。使物信之。如身子八岁登坐说法道俗赞扬震名遐迩。俱白佛言下第二正请。声闻皆已成就有二义。一欲令其回小入大。二明已化小今须教大。尔时转轮圣王下第三王眷属出家。以见王子舍于重位故亦随出家。尔时彼佛下第三明佛受请说大乘法。就文亦三。第一正受请说法。第二明时众感悟不同。第三明说经时节

问。彼佛受沙弥请即应说法。何故过二万劫然后说也

答。一欲令时众生勤重心。如昙无竭过六年竟乃说波若。二者例上十劫坐道场待于缘熟。今亦然也。三者或可例同释迦说小乘已后法华之前明二种教。一者付财密化谓波若教。二者诸方等经陶练小心。以此二门调伏其心。然后始得令入佛慧。故下偈云说六波罗蜜及诸神通事。即其证也。四者诸佛教法不同。或初说三乘教后说一乘。即释迦灯明是也。或初说二乘后说一乘。即大通智胜是也。说是经已第二明时众感悟不同。此中有三根。上根即十六沙弥。中根声闻人。亦能信解。沙弥前讽诵次信解者。夫欲覆讲必具二义。一诵持二得意。故具此二也。下根之流皆生疑惑者有四种义。一者中根声闻于佛有缘皆得信解。其余众生于十六沙弥结重因缘故佛不能度。覆讲之事起自其人。二者欲明过去世佛说法华时众生有信不信。显今现在有三根人亦有悟不悟。三者欲励今下根明过去世佛说法华利根能信解钝根生疑汝等比丘应同利根云何乃同钝根。四者明我之与汝俱在彼会共听法华。我以早悟汝今犹未解。一何可伤也。佛说是经于八千劫者第三明说经时节。以其文广是故时长。所以下云说是法华经如恒河沙偈也。说此经已下第四明说经竟入定。就文亦三。第一正明入静室。住于下第二明住定。八万四千下第三明在定时节。所以入定者。欲令十六沙弥覆述法华故也。但诸佛化仪不同。此经始末略有三种。一者灯明佛说法华竟即便涅槃。此明于佛结缘所应度者皆已度竟。二者今文明于佛结缘度之有尽不尽。利根者度之已尽。钝根者未尽。须佛起定称叹沙弥劝物亲近。故佛未得入灭也。三者释迦佛说法华竟不更再说。以应闻法华得了悟已竟故不更说法华。仍别说涅槃。是时十六菩萨下第二正明结缘。前缘由有二。一远二近。今亦开二。初明昔日结缘。次辨世世相值。二文各四合八章经。初文四者。第一明知佛入定为覆讲缘由也。第二正为众覆讲。第三明时众蒙益。第四辨佛称叹。各升法座下第二文。夫白日潜光即明月接耀。如来戢影故菩萨舒晖也。一一皆度下第三明众蒙益也。示教利喜者。智度论五十四卷云。示者示其善恶也。教者教舍恶从善也。利者。未得法味者心生退没。为说涅槃胜果使修善因令其心见利益为利也。喜者。随其所行而称叹之令其欢喜。若乐布施者即叹布施。以此四事庄严说法。今就法华释四事者。初示三乘是方便一乘是真实故名为示。次令舍三入一故云教。次说三乘果劣一乘果胜使修一乘因令其心见利益为利。观其根缘或以法说门说一乘。或以譬说门说或以宿世因缘说。随其所乐应机说法令生欢喜故言喜也。大通智胜佛下第四明佛称叹。以其说法会理称机。今欲令时众信受故佛印叹也。汝等皆当数数亲近者。以与沙弥有缘故令亲近。如十方佛劝常啼亲近法涌。佛告诸比丘下第二明结缘已后世世相值。就文亦四。一明所化得益二辨能化得益。第三结会古今。第四明未来相值也。初文三句。一明沙弥常乐说法华。以法华明于佛乘菩萨常求佛果故常乐说。又法华结会始终具摄一切教。若说法华则摄一切教。一一菩萨下明现在所得益缘也。世世所生下第三句明后时得益也

问。此中结缘后恒相值。穷子何故父子相失不相值也

答。有人言。此中明世世相值者。据大期一劫二劫。恒得相值穷子不相见。细论一世两世不相见耳。今谓与沙弥结缘有三品人。一者上品如此中说。得值多佛与师俱生。过去即悟也。二者中品人如下文说。于今有住声闻地者。过去不悟法华。现在值释迦闻一乘方悟。则穷子是也。三者下根如后文说未来世弟子。现在不事法师。未来随闻故始得悟。以有三根就三世得悟不同。是故今文与穷子不相违也。于今不尽者。一者过去善根未尽。二者值多佛犹自未尽也。诸比丘下第二明能化得益。所以明能化得益者。为击下根人也。明我闻法华遂进成佛。汝闻法华云何乃退作声闻。一何可愍耶。诸比丘我等下第三明结会古今。就文有三。初牒上根人。此诸众生于今有住声闻地者第二句明过去中根人也。是诸人等应以是法渐入佛道者释上常教化无上菩提也。疑者云既常教化无上菩提。何故说声闻法。又昔为沙弥时尚教大道。今云何乃说小乘。是故释云。说声闻法渐令入佛道。以佛慧微妙不可顿入故也。当知说小是渐说大乘。又昔有大机是故说大。但为退大取小是故今说于小。尔时所化下第三句正会古今也。我灭度后下第四段明未来相值即出下根人也。此是佛灭度后修道成阿罗汉。此人命终生于净土。释迦于净土中作佛更有异名。为此人说法华经方乃得悟。所以说此事者。明无有毕竟永住二乘。会须闻法华后当成佛。励下根人令及时信受

问。三根相貌云何

答。上根一闻法华世世与师相值。复值四万亿佛早悟一乘。中根人退大取小值释迦于灵山之会。下根人亦退大取小不面值释迦亦不闻法华。于未来方值佛闻法华方得了悟也

问。何故言更有异名

答。释迦是秽土佛名。今于净土化物故更有异名。诸比丘若如来下第二大段明现在相值更为说法。又开为四。一法二譬三合四举譬帖合。法说为二。初明说大次辨说小。若依上来次第。前明说小后明说大。今但远寻往昔曾禀大化故今还说大法。中间废忘习于小乘故次明小。后譬说中义亦同然。又诸佛说法有二。一从实起权二摄权归实。上来多明摄权归实。今欲辨从实起权也。说大中有二。一知机二说教。知机中五句。第一明说法之时。入大涅槃谓闻涅槃机熟。今是一乘缘熟谓将涅槃时也。故信解品云临欲终时而命其子。众又清净者。以四教调柔其心故得清净。用人天及二乘教调伏其心故无复凡夫烦恼。以付财密化及陶练小心令二乘烦恼渐得消除。既离凡圣二惑故言众又清净也。信解坚固者。上辨无障今明有堪受之机。谓大信大解可得闻经也。大信是钝根大解是利根。又大信为初大解为后。此二不退称为坚固也。了达空法者。前已闻波若等大乘毕竟空法开悟大心。若不闻毕竟空无所得法者。闻说一有三无则堕二见也。深入禅定者。未必是深入八禅。如大品云。一心向佛道无复凡夫二乘有所得动散。是故名为定也。便集诸菩萨下第二正说。初句即是序说。为说此经明正说也。正说虽多不出无二有一也。比丘当知下第二明说小。所以说少者。既无有二乘唯一佛乘。而昔说二者。为知众生不堪闻大但欲乐小故为说小。文有三句。初知机。为是等故明正说。是人若闻辨得益。知机中云。如来方便者为释疑故来。疑者云。若无二乘何故昔说有二涅槃。是故释云。如来有权巧之智。随机而作故说有二也。是人若闻即便信受者。既称机而说便信受得益也。譬如五百由旬下第二譬说。凡有九句。少第九闻一乘得益。开为三章。第一初说大乘譬。第二中途说小譬。第三后还说大譬。所以开此三者有三种义。一者譬上二世始终有于三事。十六沙弥初为说大。二者中间退失大乘为说小法。谓释迦初趣鹿苑竟灵山之前也。三者废小说大谓法华会也。二世始终唯此三事故立三章也。二者三世诸佛有三种法轮。一者根本法轮谓一乘教也。二支末法轮于一说三。三收末归本谓摄三归一。为显三轮故立三譬。三者上譬喻品破本乘声闻初小后大故开六譬。今为退大证小声闻故初明说大次明于小后摄小归大。初文二句。一所度恶道譬。二欲度之人譬。三导师将导譬也。五百由旬者所度恶道也。有人言五百者喻五道生死也。今谓不然。岂免三涂三百名为二乘。又二乘已免五道。应已度五百。有人言有四种生死。一流来生死。二变易生死。三中间生死。四分段生死。度三百免分段生死。度四百免七地二国中间生死。度五百免八地以上变易生死。有人言三界为三百。七住二乘为一百。八住以上复为一百。今谓义并不然。玄中具释。今正取三界为三百。二乘为二百。所以作此释者有义有文。言有义者。今正化二乘人令趣佛道。昔已度三界。未度二乘地。犹在恶道。岂住恶道之内为涅槃也。宜应舍之则必到佛道

问。若度三界二乘地。云何得到佛道也

答。有二种到。一者因到二者果到。言因到者如涅槃云。须陀洹人八万劫到。乃至辟支佛人十千劫到。谓到菩提心。即十住位成种性人也。至此位时免凡夫位及退为二乘。必到佛道故名为到。二者三界为分段生死。二乘之人居变易生死。度此五处免二种生死得大涅槃。谓到果也

问。何故得知有二种到

答。后偈文云。今为汝说实。汝所得非灭。为佛一切智当发大精进。此因到也。汝证一切智乃是真实灭。谓果到也言文证者。智度论释闻持品云。度四百由旬即知去城邑不远。龙树释云。三百譬三界。四百譬二乘。但大品合二乘为一百。此经开为二百。开合不同义无异也。又大品未废二乘此经始废。以此为异。俱是恶道两教不殊。又此经合譬中自明三界为三百二乘为二百。诸经义师不观文意而横有异释也。崄难恶道者明度意也。三界二乘度之即难故称崄难。智度论云。菩萨退有二事。一贪三界及乐二乘也。恶道者三界于二乘为恶道。二乘复是菩萨之恶道。故涅槃云。求二乘者名为不善。故此五处皆名恶道。又三界爱为其本。二乘见为其本。爱见皆是恶也。又三百是凡夫有见。二百是二乘空见。诸见皆是恶也。又凡夫外道谓三界为涅槃。既是痴迷颠倒。二乘谓变易生死为涅槃。亦是痴迷颠倒。以俱谓生死为涅槃。并是无常而计常故称恶也。旷绝无人者五百玄远故称旷绝。诸佛菩萨之所不住故云无人。怖畏之处者。学大乘人深畏此五处。三界无安犹如火宅。众苦充满甚可怖畏。涅槃云。今我怖畏二乘道果。如惜命者怖畏舍身。智度论有怨家树上来譬。即其事也。若有多众第二永度之人也。即沙弥所化徒众是也。上云无有智人。今明欲度人多。故云众多也。欲过此道至珍宝处者。菩萨发心凡有二意。一欲度凡夫二乘地。二欲求无上菩提也。有一导师下第三明将导师譬。即上十六沙弥及释迦也。道既无二故体道之人亦一。又善知道通塞之相一人而已故云一也。有导示邪正之能故名导师。聪慧明达者。智在耳曰聪慧。智在眼为明达。略叹二事也。又聪慧譬种智。明达譬三达。种智横照万法。三达竖鉴三世也。善知崄道通塞之相者。知大机发堪可度之名通。不堪度之名塞。又知得理为通。乖理为塞。此明导师内智也。将导众人欲过此难者叹外化能也。指期佛道远超二生死。是欲过此难也。所将人众中路懈退第二中途说小譬亦有三句。一知小机发譬。二说小教譬。三禀教得益譬。小机发有二。初明小机发。次明佛智照。小机发有三句。一标欲退二释欲退三结欲退。今是初也。中路者。初发大心欲出离生死。远求佛道欲离小行。而大解未成于此中间而退也。若譬上过去世事者。自昔化已后讫至今化之前。二楹之间废忘大心退失大行。亦得是未成佛道中间名为中路也。白导师言者。既其退大则有小机以扣于佛为佛慧所照。谓白师之义也。我等疲极而复怖畏不能复进前路犹远者。上标懈退也。今释懈退也。夫退有三事。一者疲极故退。喻习大乘观解微弱未有力势不能进至佛道。二怖畏故退。譬生死中多诸患难。三路远故退。譬佛道三僧祇劫然后乃阶过小之外。一行不堪修习故言不能复进也。今欲退还者此第三句结退也。退有二事。一退为凡夫。二退为二乘。今欲退还生死故名退也。亦得发始即不求佛故止而不进名为退还

问。曰此即是退。何故言欲退也

答。此明根性不定。一者可退为凡夫。二者可住为二乘。三者可进为菩萨。以不定故所以标欲也。导师多诸方便第二明照机亦有三句。一叹能化有知机之德。二明叙所化之过。三释所化之过。多诸方便者。前有引向大之能。今复解趣小巧。故云多也。又纵之而退。或逼之而进。或令永住二乘。悉非善巧。今不令退为凡夫。复不逼进求佛。能于中路权说小乘终悟大道故云多方便也。而作是念下第二叙所化之过。云何舍大珍宝下第三句释所化过。弃于佛乐名舍大珍宝。乐生死苦名而欲退还。举此二事释上可愍义也。多诸方便叹导师智慧。可愍以下叹导师慈悲。作是念已下第二明设小教凡有三句。初正设教二诫三劝。二乘利钝虽异。同断三界烦恼在分段之外故言过三百也。非实究竟而言究竟故名为化。断惑义同证无为不异所以称一。防生死患难故称为城也。告众人言汝等勿惧莫得退还第二诫也。勿惧者不须深惧老病死也。莫得退还者莫乐生死五欲也。今此大城可于中止者第三劝也。累尽涅槃比天人之乐故名为大。二种涅槃是息驾之处名可于中止也。随意所作者。结累既尽心得自在。若入是城快得安稳者。若证此涅槃离生死危苦也。有人言烦恼既尽随意自在即有余涅槃也。若入是城快得安稳。因果两患危苦都亡即无余涅槃也。若能前至宝所亦可得去者。有人言佛果譬宝所。声闻人若能发菩提心。求佛智慧亦可得去。如大品云若能发心我亦随喜。若就理中释者。此句显化城意。说二乘教本令得佛。譬如暂息脚欲令进路。昔不得显于斯意故假设此言。明虽暂证小乘终归大道。若就昔教明者。如云六十劫修得声闻百劫修证于缘觉。此二同证无余。喻可于中止。今譬菩萨三阿僧祇劫修行趣佛。故云若能前至宝所亦可得去也。是时疲极之众心大欢喜下第三禀教得益也。就文三别。一信受二修行三证涅槃。说教称机故称欢喜。叹未曾有者。二种涅槃是出世之法世间所无名未曾有。我等今者免斯恶道谓离生死苦也。快得安稳者得涅槃乐也。至此已来皆是初闻佛教生信受也。于是众人前入化城第二辨修行求涅槃也。生已度想生安稳想者。第三句证涅槃果也。出三界生死名生已度想。证无余涅槃生安稳想。又得有余名已度想。入无余名安稳想。又得尽智名已度想。得无生智名安稳想。实非究竟谓是究竟故称为想

问。无学乃可生已度想。凡夫学人亦得起此想不

答。凡夫学人乃未出三界。亦谓二乘涅槃是究竟法。故亦得起此想也。尔时导师下第三后还说大譬。就文为二。初知机二说教。免退为凡夫住小涅槃称为止也。望进求佛道为暂息脚之义故云息也。无复疲惓者。以小乘法调柔其心除粗烦恼心用稍强堪闻大乘也。即灭化城者第二说教也。废三乘究竟之教称为灭也。又会三为一无复三名亦是灭也。语众人言汝等去来者。劝声闻人修行求佛也。宝所在近者释上劝进之意。前路既近宜应去也。已度三百今唯二百故云近也。向者大城我所化作者。于一佛乘分别说三也。为止息者释说三之意。有止有息如前二义也。诸比丘下第三合譬。合三譬即为三别。上初譬有三句。一所度恶道。二求度之人。三明将导。今正合第三兼余二义。知诸生死合上所度恶导。应去应度合上善知通塞之相兼求度之人也。若众生下合上第二中道说小譬。上有三。一机发二说教三得益。今具合之。上机发有二。初明机发二照机。今具合也。则不欲见佛不欲亲近合上中路懈退乃至我等疲极。便作是念佛道长远合上前路犹远也。久受勤苦乃可得成合上而复怖畏。佛知是心怯弱下劣合上第二佛照机也。以方便力下合第二正说教也。说二涅槃者合上化作一城也

问。上云一城。今云何言二涅槃也

答。有人言上明同断三界惑故言一。今据余无余故言二。有人言大涅槃为第一。今是中路涅槃称为第二故名为二。如胜鬘经云。涅槃有二种。一无余在佛。二有余在二乘。今谓二释悉非。此文但以二乘人所证为二涅槃耳。如下偈云唯有一佛乘息处故说二也

问。上何故云一今称二也

答。二乘之人有同义异义。上取同出三界同证无为故言一。今约人利钝不同故复明二。又欲明五百由旬义。开三界为三百。二乘涅槃复为二百。欲令度二乘地故说为二也。若众生住于二地合第三后还说大譬。上文有二。一知机二说教。今具合之。初文即是合后知机。兼合前第三得益义也。又称住于二地者。上合度三百由旬竟。今余有二百故称二地。此文分明以三界为三百以二地为二百。旧经师不熟审其文故有诸异释也。如来尔时下合第二正说教也。初合即灭化城。汝所住地近于佛慧合上汝等去来宝处在近。当观察筹量所得涅槃非真实也。合上向者大城我所化作。然二乘有近佛慧远佛慧义。自谓所得涅槃为极不受大乘。故经言高原陆地不生莲华五无间罪犹能发意。此即二乘人远佛慧不及凡夫也。今言近者。以二乘断粗烦恼胜于凡夫故言近也。如彼导师下第四举譬怗合也。四十九行半偈颂长行。长行本有二。初说过去结缘。二现在更为说法。今还颂此二也。说过去世事又二。初结缘缘由二正结缘。今还颂此二也。缘由中有二。初远缘由二近缘由。今还颂此二也。初中有四。第一大通智胜成佛。二十六王子请转法轮。三大通智胜现瑞。四十方梵王请说法。今具颂此四也。初本有三。初明未成佛。二明诸天供养。三明成道。今具颂之。初一行颂第一也。次两行颂第二。次一行颂第三。彼佛十六子下第二请转法轮。长行本有三。初十六王子为请法故至佛所。二至佛所故恭敬称叹。三请说法。今具颂之。初一行颂第一。一句颂第二。而请转法轮下三句颂第三。世尊甚难值下颂第三现瑞。上有三。一地动二放光三二瑞所至。今一行但颂第一。东方诸世界下颂第四十方梵天集。上有三。初明三方梵众。二例余六方。三明上方。今开为二。初三行颂一方。次两行例九方。上一一方有六。今但颂五略不颂谋议也。又诸梵见此相一句含于谋议故具颂六也。无量慧世尊下颂上第二结缘近缘由。上有四。一受请说小法。二十六王子请说大。三受请说大。四说经竟入定。今具颂之。上受请说小中为三。初正受请。二明一会说法。三明多会说法。今具颂之。半行颂第一。两行半颂第二。六百万亿垓者。长行明六百万亿那由他。今云垓是此间数代彼那由他也。第二说法时下两行颂多会说法。时十六王子颂第二请说大法。上有三。一为请故出家。半行颂之。二正请。一行半颂之。略不颂第三王眷属。佛知童子心颂第三受请说大法。上有三。一说教二感悟不同三明说经时节。今两行半但颂第一。彼佛说经已颂说经竟入定。上有三。一明入定。半行颂之。次明住定。一句颂之。三明住定时节。亦一句颂之。是诸沙弥等第二颂正结缘。上有二。初明一世结缘。二明世世相值。今具颂之。初章有四。一知佛禅未出。今半行颂之。二正为说教。一行半颂之。三明时众得益。一行颂之。略不颂第四佛从定起称叹也。彼佛灭度后颂第二世世相值。长行有四。第一叹所化得益。一行颂之。二明能化成佛。一行颂之。三明结会古今。一行颂之。略不颂第四未来相值。我在十六数下颂第二大段现在说法。长行有四。一法二譬三合四怗。今具颂之。初两行颂第一。上文有二。初说大次说小。今但颂大。譬如崄恶道下颂第二譬说。上有三。一初说大乘譬。二中途说小譬。三后还说大譬。今具颂之。上初譬有三。一所度恶道。二求度之人。三导师将导。今具颂之。多毒兽者。有爱见烦恼能害法身慧命为毒兽也。无水草者。无大乘无漏定慧以自资也。无数千万众颂第二欲度之人也。时有一导师颂第三将导也。众人皆疲倦下颂第二中途说小譬。上有三。一知机二说教三得益。今具颂之。上知机有二。初小机发。一行颂之。次照机。一行颂之。寻时思方便下颂第二正说教。上有三。一说教二诫三劝。今具颂之。城郭者。城者别譬二涅槃。郭是城外郭邑。通譬无学果位诸功德也。庄严诸舍宅者。舍宅园林皆在郭内。别譬果地诸余功德。有漏五阴既名生死舍宅。无漏五阴圣人所栖为舍宅也。周匝有园林者。净名经以总持为园。小乘亦随分有也。阿含经中慈悲喜舍以为四园。无漏诸行称之为林也。渠流及浴池者。九次第定更相灌注称为渠流。八解脱名为浴池。阿含经以四禅为四池。一有觉有观池。二无觉无观池。三护念清净池。四名无苦无乐池。重门高楼阁者。三三昧名曰重门。尽无生智称高楼阁。又诸禅中有勋禅练禅。皆是禅之极名高楼阁。男女皆充满者。定慧为男女。亦得慈悲心为女善心诚实为男。声闻随分有也。即作是化已半行颂第二诫门。次半行颂第三劝也。诸人既入城一行颂第三得益。导师知息已颂第三后还说大譬。上有二。一知机。初句颂之。二说教。两行一句颂之。我亦复如是下颂第三合譬。上有三。初说大乘譬。第二中途说小乘譬。第三后还说大乘譬。今具颂之。初半行颂第一初说大乘譬。见诸求道者合第二中途说小譬。上文有三。一知机二说教三得益。初行颂第一。次行颂第二。既知到涅槃颂第三后还说大譬。上有二。一知机二说教。半行颂第一即兼颂上第三得益。三行半颂第二。诸佛之导师一行颂第四举譬怗合也

法华义疏卷第八

时永仁甲午黄钟中旬缁素男女合力运功雕□当文颂行普率愿上报四恩下施三有也

          都干缘沙门　素庆　谨志法华义疏卷第九

        胡吉藏撰

    五百弟子授记品第八

宿世因缘说中有二段。第一正为说法。此文已竟。今是第二次为授记。以闻法悟解行与佛应故授佛记。文凡有二。初授五百弟子记为一品。次授学无学人记为一品。所以开二品者。上授记品标其总名。今欲异上故以人别品。故总别两题立名相避也。所以约人分二品者凡有十义五双。一者五百弟子愿行是同。现在同时得记。未来相继成佛。后学无学人愿行亦同。现在同时得记。未来一时成佛。为此因缘故开二品。二者即欲以此二义摄授记义周。夫论授记不出二种。一者前后相继成佛。二者一时成佛也。三者前五百人谓高名显德众。后二千人藏名密行众。以部类显密不同故开为两品。四者即欲以显密二人摄授记义尽。五者前五百人同是无学位。后二千人是学无学位。以部类不同故分二品。六者即欲以此二义摄授记义周。七者前五百人同有领解。后学无学人同无领解。以部类不同故分两品。八者即欲以此二义摄授记义周。九者前五百人亦有发迹亦无发迹。如满愿则发迹余人不发迹。故为一类。后学无学人亦有发迹亦无发迹。如阿难罗云则发迹余无发迹。复为一类。所以分为两品。十者即以有发迹无发迹摄授记义周也

问。此品实授千二百人记。何故题五百也

答。五百即千二百数。所以别题者凡有四义。一者佛在世时有高名显威德五百罗汉常随侍佛故偏题之。二者此五百人愿行是同现在俱时得记未来相继成佛。三者此五百人同有自能领解说系珠之功故偏举之。四者佛初成道前度五人次度迦叶师徒即成五百。今从初立名故偏举也。品开为二。一者别授满愿记。二者总授余声闻记。别授满愿记者。满愿有发迹余人无发迹。满愿无自能领解余人有自能领解。以部类不同故开二段也

问。发迹何故无自叙领解。不发迹有自能领解

答。夫论领解。必是昔迷今悟。既其发迹则昔不实迷今非真悟。故发迹之人不自能领解。不发迹人既实昔迷今悟故有自领解

问。上中二人皆无发迹。何故至下根人有发迹耶

答。可具五义。一者文互有隐显。若并发迹则无实悟之人。若不并发迹则隐菩萨德。是以经文出没不同。二者下根发迹则显菩萨不可思议。现为声闻已是隐德。于声闻中复为下根。是故名为不可思议。三者示作声闻本为化物。今三根皆悟则化物事毕方得发迹。上章化事未周故不明发迹也。四者下根人尚发迹。中上根岂是实行耶。故摄大乘论云。舍利弗等皆是化人。故有经云。须菩提者是东方世界青龙陀佛。则知皆是权行人也。五者显示菩萨有发迹不发迹二种方便也

问。发迹有何利益

答。开一为三凡有二种。一者开一法为三法。二者开一人为三人。上来虽明一法为三法三法归一法。未辨一人为三人三人为一人。今发诸菩萨迹始得明一人为三人三人为一人。以具约人法明于开会义始圆也。授满愿记为二。第一闻法为领解之缘。二如来授记。初文又二。前明得解所由。二正明得解。初有四句。第一闻法为领解之缘。智慧者实慧也。方便者权慧也。总牒法譬二周中权实二慧法也。又闻授诸大弟子记者。总牒二周中授人记为领解缘也。复闻宿世因缘之事者。牒第三周化城事为领解缘也。复闻诸佛有大自在神通之力者。即大通智胜佛十劫坐道场及现瑞等事也。又解即是释迦能知过去久远之事为自在神通之力。所以但明四事者。初事谓教。次事是得益之人。宿世因缘叙教益所由。后明能化之主。摄义既周宜辨四事也。得未曾有下第二正明领解。亦开为四。初明内心欢喜。得无生忍无有所得垢故言心净。即从座起下第二明外形致敬。而作是念下第三默念领解。拔出众生处处贪著者如前文众生处处着引之令得出也。言贪著者非谓但是贪使。及说一切有所得心也。唯佛世尊下第四祈请授记。所以祈请授记者凡有二义。一为现摄下根之流。二为有缘众生发愿往生是故请记。深心者无生法忍即是菩萨行故名深也。本愿者无所得菩提心也。尔时佛告下第二正为授记。文开为二。初长行次偈。长行为二。前明行因后辨得果。行因之中明三世行因。第一叹现德谓现在行因。第二明过去行因。第三明未来行因。现德显彰是故前叹现在之德由过去修行。故次叹过去。二世行因犹未圆满故次叹未来。初文四句。第一句告众问之

问。满愿在坐。云何问众言见不耶

答。众但睹形未见其德。今欲显其德令众仰恭故告众问之。我常称其下第二句叹其有上弘之功。能于四众下第三句叹其下利之德。自舍如来下第四句出满愿之位即十地人也。汝等勿谓下第二叹满愿过去德。时众但谓现在有上弘下利之功。未知过去亦有此德故今叹之。就文为三。一明过去九十亿佛所有上弘下利之功。第二于七佛所有上弘下利之能。第三于释迦佛所说法人中最为善巧。此即从多佛以至少佛也。初文为三。第一叹满愿智慧。第二叹其神通。第三以具智慧神通故广能益物。初开又三。前叹有慧即实方便也。又于诸佛所说空法第二叹空慧谓方便实也。得四无碍智下第三合叹空有二慧。以具了空有方能无碍说法。不尔则成有所得也。具足菩萨神通之力第二次叹神通也。彼佛世人下第三明以具通慧广能益物。就文又二。初叹成就众生。为净佛土故下第二叹净佛国土。前又二句。一通益四乘众生。又化无量以下别益求佛人也。诸比丘下第二叹于七佛法中上弘下利之德。今于我所下第三叹于释迦佛所说法中第一。于贤劫中下第三叹未来修因亦开三别。初叹于一劫中佛所修行。亦于未来下第二多劫佛所修行。渐渐具足下第三叹修因圆满也。过无量下第二明得果。凡有六果。一化主果。其佛以恒河沙下第二明国土果。地平如掌者释有二。一云佛手掌平指事为言。二云海底有石方四千里平如镜面名为掌石也。诸天宫殿下第三明眷属果凡有四句。一明人天眷属。二明菩萨眷属。三辨声闻眷属。四总结。劫名宝明下第四时节果。国名善净下上出土体今辨土名。其佛寿命下第五明寿命果。法住甚久下第六明住持果。偈文为二。初颂行因次颂得果。颂三世行因即为三别。初七行总叹诸菩萨。即显叹满愿现在行德。第二五行颂过去行因。第三二行半颂未来行因。初七行为三。初偈标叹。五行释叹。一行结叹。明不可具叹也。五行为二。初四行叹菩萨作二乘方便。次一偈叹菩萨示凡夫方便。初四偈又二。前三偈叹菩萨作二乘方便能成就众生。次一偈明二乘方便能净佛国土。初三偈为三双。第一上半辨知机。下半示小乘威仪。谓机教一双。第二偈上半巧化他。下半自说是小道。谓自他一双。第三偈上半明度物。下半辨说教意。谓教理一双。虽小欲懈怠者。虽现小乘威仪说于小教似如于菩萨法懈怠。而实非懈怠。示众有三毒又现邪见相者。上现圣方便作声闻缘觉两圣。今示凡方便亦作二凡。一现为在家三毒众生。二现出家邪见外道也。又上现二乘方便即是无烦恼人。今示两凡方便谓有烦恼人。今大士体悟烦恼未曾有无故方便示现有无。如净名经云。菩萨不断烦恼亦不与俱而能示现俱断二事。今此富楼那下颂第二过去行因也。未来亦供养下颂未来行因。其后得成佛下颂得果为二。初别颂得果。次总结。别颂中半行颂化主果。半行颂国土果。一句颂时节果。四行一句颂眷属果。五句颂菩萨。一偈颂声闻。两偈颂天人。从胜至劣以为次第。法喜禅悦食者。则定慧能资养法身故名食也。又外从佛闻法欢喜为法喜。内如说修行为禅悦。又圣说法名法喜。圣默然名禅悦。佛敕弟子常行二事故唯有二食。余经说有九种食。世间四食出世五食。世间四食者揣触思识四食也。出世五食者一禅二愿三念四八解脱五喜。富楼那比丘下第二一行半总结净土也。尔时千二百下第二授余声闻记为二。一授记二领解。就授记中为二。初请记二授记

问。千二百五十人常随佛。此经前后何故但言千二百耶

答。或可出经人语其全数。或可本有千二百五十。至法华时五十已亡故但言千二百耳。我等欢喜得未曾有者。闻上来说法及以总记故欢喜也。不亦快乎者。千二百罗汉见诸人得别记。谓己不得别记故来请之。若得别记成佛事定故称为快。佛知此等下第二佛与授记。就文为三。初总许。二别授记。三命迦叶令其宣记。今是初也。于此众中下第二别授记。前长行后偈颂。前长行二。前别授陈如次别授五百。须知五百及千二百皆是千二百中之数也。千二百是得三乘道之初数。此千二百中五百为标领故云五百耳。设举五百亦是千二百中之数。如十七群及六群之名也。其五百罗汉下第二授五百人记。迦留陀夷者迦留此翻时。陀夷名之为起。十八部疏云。迦留者黑陀夷者上。谓悉达太子在宫时师也。周陀者翻为不乐。又云小路。莎伽陀翻为善来。本名恶来。外国亦云沙竭陀亦云沙伽陀。优陀夷亦云乌陀夷。此云出也。偈文亦二。前六行颂陈如得记。次三行半颂五百人得记。迦叶汝已知下第三段命迦叶令宣记。以无有二乘唯有一乘。一切声闻皆当作佛。命之宣记意在于此。尔时五百下第二自叙领解。就文为二。一长行二偈颂。长行为四。一法二譬三合四结欢喜。初法说又四。一标领解之缘。得记即是领解缘也。欢喜踊跃下第二内心欢喜。即从坐起下第三外形致敬。悔过自责下第四发言自叙领解。又开为四。一悔过自责。二述于昔迷。三叙今悟。四者解释。悔过自责者忏悔小乘有所得罪。令未改二乘执者因此而改已发大乘心者牢固不退。然此经始终寄千二百人破十方三世一切诸小乘人。令其舍有所得悟入平等正观。乃至寄三根人破斥十方三世封执大小乘二见菩萨。亦令悟入非大非小不一不三无依无得妙悟。是以此经始终皆用千二百人为言端耳。寄此人执迷以显大小有所得迷。托此人悟引一切有所得大小迷心悉令得悟也

问。若尔此经三周并是方便人无实悟道耶

答。寄此三根述于迷悟。令实行小乘人于法华经得信心。是故前云诸余声闻信佛语故随顺此经。即其证也

问。何故得知三根声闻皆是方便耶

答。无有实行之人闻法华经即能领解助佛扬化。所以此经佛有三周说。弟子亦三周说。若师若弟子皆是显发密教调伏众生。然寂灭正观未曾师弟子。为众生故方便师弟子。欲令受化之徒悟入平等。故涅槃经云。说法非师亦非弟子是名中道。师弟子既是方便。迷悟亦然。平等正观未曾迷悟。为众生故方便迷悟。故涅槃经云。一切众生不能破结。非不能破。非破非不破是名中道。恒须此意读法华经。若执昔开今会一有三无及始终迷悟者则成有所得。有所得者即无明。非平等大慧。有所得者无道无果不能行于佛因得佛果也。有所得者名之为粗非是妙法。有所得者即是染着。不名莲华。所言悔过者。佛过去令我发无所得不二菩提心。而我颠倒厚重背大取小。是我罪之一也。从经初已来两周为我说平等大慧。而疑悔不解。是我罪之二也。已于二世劳扰如来。是故忏悔过于佛。又执小疑大障法之深。故对法忏悔有所得罪也。自责者背大取小执小疑大。皆是己之钝根故自责也

问。何故下根独有此辞耶

答。三闻始了则有各累之深故偏说也。又三根声闻皆应悔过自责。但欲转势彰过故三种不同也。世尊我等下第二述昔迷也。今乃知之如无智者下第三明今悟。所以者何下第四解释。明应得大而保小自足故是无智之人。即释上如无智者也。譬如有人下第二譬说广述领解。此经佛有三周说。初周法说。次周譬说。后周亦譬亦法。弟子三领解亦有三阶。舍利弗闻上法说还作法说领解。迦叶悟前譬说还作譬说而领。今双了法譬双作法譬而领。故前明法说领解。今明譬说领解也。就譬始终凡有八句。一贫人至亲友家。二亲友设以酒膳。三醉酒而卧。四系以宝珠。五都不觉知。六起已游行求索衣食。七会遇亲友示以宝珠。八贫人得珠欢喜。亲友始终欲相利益。要具八事。以类相从义意唯三。初系宝珠譬。二中途相失譬。三会遇示珠譬。所以立此三譬者还领上三义。初领昔禀大乘。即大通佛时。次领忘大取小。从过去退菩提心竟今灵山前也。三领还得悟大。即灵山之会也。二者领化城三譬。前领初说大乘譬。次领中途说小譬。次领后还说大譬。三者领如来三种法轮。初领根本法轮。次领枝末法轮。后领摄末归本法轮也。譬如有人者即下根之流也。至亲友家者。昔有大乘之机感说大乘教故称为至。同有佛性又曾受化为出世法亲。同志菩提共出生死故名为友。譬喻品作父子之譬。信解品还作父子。而领化城品作导师伴侣譬。今还作兄弟而领。以十六沙弥过去前悟故称为兄。兄即友也。禀教之人后学即是弟义也。家者说大乘教处也。醉酒而卧者。光宅等云。贫人本醉往亲友家遂卧。譬众生为五浊所昏。情滞生死为醉。无明惑心得解不久而忘解。后遂不行如卧也。今谓不尔。下偈云。譬如贫穷人往至亲友家其家甚大富具设诸肴膳。既醉来而卧。云何得设。又既设肴膳。宁无酒也。此则譬事不成。今明此中可有二义。一者亲友设于酒膳。但长行略故不说。偈则具足。二者即此长行自含有之。文云醉酒而卧。酒者亲友所设也。醉者贫人饮酒而醉也。昔说法华。即大宗中道无相教为酒。滞教为醉。迷理为卧。故经云持空三昧瓶以盛无相酒

问。何以酒喻教耶

答。酒有欢适义。喻闻教欢喜自知作佛。二酒有昏迷义。喻其因教起迷。今喻大乘。正欲明三根声闻中途迷教义。故正借酒为喻。是以命初即云醉酒而卧

问。因酒故醉卧。设教应起迷

答。亲友共会本为怡神。不使昏醉。如来说教意在悟理。不使缘迷。但失旨故惑耳。是时亲友官事当行者。菩萨化物自在如官事。又大士益物非己如官事。又此士感尽他方缘至。不得不去。如官事当行也。以无价宝珠系其衣里者此正明系珠譬也。法华论云。有散乱增上慢人心实无有定。过去虽有大乘善根而不觉知。不觉知故不求大乘。于狭劣心生虚妄解以为第一乘。如是倒取。为对治此故说系宝珠譬。即是示其过去善根令忆念已。然后教令入三昧故也。论又云示现解无上故说系宝珠喻也。大乘中道之解譬之宝珠。理中之极故称无价。又由此不二之解感佛大果。以多有所堪故称无价。解由佛授故称为系。解隐微惑心中如衣里也

问。授解本由众生领悟。既云醉酒而卧都不觉知。云何于不觉知时而授解耶

答。系珠者。本说大乘之旨不令暂受而已。乃为染神历劫不朽。故借醉不觉知时以明系珠耳。实非是不觉知时系。二者夫解之珠喻菩提心。不失正在后时。今欲显后时不朽之解由于佛授故在后时说耳。又所以知系宝珠非是不觉知时者。珠喻菩提心。若都不觉知。云何发菩提心也。但今据后时废忘故云不觉知耳

问。系珠既是觉知时。饮酒亦有不醉耶

答。初未醉后方醉。如初禀教时未迷后方迷耳

问。亲友何故设以酒膳复系珠耶

答。亲友惠益可有始终二事。初则设以酒膳。终则惠之重宝。重宝是后时富贵之因。酒膳是当时会遇乐。初禀大乘亦具二事。一者当时得益如饮酒怡情。次解染神历劫不朽譬同系宝珠也

问。既是始终一解。何故不举一譬

答。酒膳但有当时之益而无后时不失之义。系珠但有后时不失而无交益之理。故举两譬以喻始终一解也

问。曰若唯是授于一解则初见亲友便是系珠。云何至醉卧时方始系也

答。两譬实是一时。而前后说者取其二义。饮酒取其初有微解。后则昏迷。虽复后迷而解隐迷内终不朽灭故如系珠。故酒譬显其解后起迷。珠譬彰其解虽复起迷解不朽灭

问。经自辨前后。云何言一时耶

答。后偈中明设酒膳即系宝珠。故知一时。但欲显始终二义。如前释也

问。酒珠但譬解亦喻教耶

答。通皆得喻。中道之教圆正如珠。陶神养性事同于酒。教既具两。解亦例然。但珠正譬解谓菩提心。故下合云一切智愿犹在不失。酒譬二义。一者喻教。二者饮酒益身喻禀教生解。故知具二义也。但酒正喻教也。与之而去者即时未可化不得不舍之也。又初设酒喻说教。以系珠譬授解。授解既竟此土感息。是故去也。其人醉卧都不觉知者第二中途忘大取小譬。既滞教起惑。经历生死不觉曾有大乘之解也。起已游行者。前句明忘于大解如都不觉知。此句辨习行小乘故云起已游行。又前句辨都不觉知忘失本解流浪五趣。此句辨起求二乘出世法也。小乘机发为起。修行小乘法为行。到于他国者。乃谓涅槃可证。所存非本故云他国。即大乘为本国。二乘教为他国也。信解譬中以大乘理为自国生死为他国。今以大乘为自小为他。为衣食故勤力求索甚大艰难者。二乘少乐义比衣食。伏惑不懈为勤力。空有涉虑为艰难。又非是顺理故称艰难。又菩萨如乐道声闻如苦道故如艰难。若少有所得便以为足者。上辨行因今明得果。保少为究竟故云自足也。于后亲友会遇见之第三会遇示珠譬

问。今始见亲友。前已见也

答。起已游行中已见亲友。但说小乘教未称昔日友故不说见耳。今既示珠还如昔友方乃称见也。于后者即说小教之后。大机潜发名为会遇。为佛智所照称为见之也。而作是言咄哉丈夫何为衣食乃至如是者。向明见机今辨说教。昔发大心行于大行。志力雄干故称丈夫。今遂弃大学小此可伤叹也。我昔欲令汝得安乐五欲自恣者昔欲令众生得于佛乐也。于某年日月以无价宝珠系汝衣里今故现在者。大通智胜佛时为年日月。为说法华授一乘之解为系珠。昔因不朽为犹故现在。而汝不知者明不知有大解也。勤苦忧恼以求自活者明其取小也。甚为痴也者忘大取小盖是无明烦恼故称痴也。汝今可以此宝贸易所须者。以菩提心宝。贸易必感佛道圆德也。以因感果即是贸易之义也。佛亦如是下第三合三譬。即三为菩萨时者合上亲友也。教化者合上设酒也。令发一切智心者合上系宝珠也。而寻废忘下第二合弃大取小譬。即兼合上醉酒而卧也。废忘正是合上都不觉知也。既得罗汉者。上合忘大此合取小也。一切智愿犹在不失者合第三亲友示珠譬也。今者世尊觉悟我等下合上咄哉丈夫乃至如是之言也。我久令汝等下合上我昔欲令汝得安乐至系珠文也。而汝谓为下合上而汝不知甚为痴也。世尊我今乃知下第四段结悟解欢喜。偈有十二行半颂上四段。即为四。两行半颂法说。六行颂喻说。三行颂合喻。一行颂结欢喜。上法说有四。初半行颂第一领解之缘。一句颂第二内心欢喜。一句颂第三外形致敬。一行半颂第四悔过。悔过自责有四。今但颂两。初半行颂悔过。次一行颂昔迷。即是释悔过之事。次六行颂三譬即为三别。一行三句颂第一系珠譬也。具设诸肴膳者。长行举酒偈举肴膳。酒譬说菩提心。设肴膳譬说菩萨行。亦得转譬。上以酒譬法华教。今以肴膳譬教也。言具设者。佛略说于前。沙弥广说于后也。默与而舍去者。解之不朽既显在后时。则后时之解非是言教所授故称默与。有人云。尔时不道此一发之善历劫不朽更相值遇故称默与。有人言。当时虽为说教钝根不解。与默无异故称默与也。又酒膳譬教名之为言。系珠授解故称默与。此释为正

问。偈中何故辨设肴膳则辨系珠也

答。为说大乘时即授菩提心解。实无异时故知相次说也。而舍去者。说教授解在益已圆故舍之。而去时卧不觉知下两偈一句颂上中途忘失大譬。与珠之亲友下两偈颂上会遇示珠譬。我等亦如是下三行颂上合譬。初偈颂合第一譬。次偈颂合第二。后偈颂合第三。我今从佛闻一偈颂第四结欢喜也

    授学无学人记品第九

学无学有大小乘不同。小乘学无学者成论云。学法者学人在第一义心也。无学者无学人在第一义心也。若缘真之心更有增进义。是名为学。缘真之心已满不复进求。是名无学。若出世俗心非学非无学。依毗昙云。会理进求名之为学。会理息求名为无学。缘事之心名非学非无学。然今品都不论此义。学无学既在观心。不可得记亦不可得受。今但就位判耳。三果名学。罗汉名无学。而言人者。智度论云。须陀洹者人也。须陀洹道者十五心也。须陀洹果者第十六心也。今正标其人以目品也。大乘学无学者。佛名无学。登地以上称之为学。就因地中。七地已还是功用道名之为学。八地已上无功用道名为无学。故大品云菩萨有学无学地

问。大乘有果地学无学。复有因中学无学。小乘何故无因中学无学耶

答。小乘因中无有功用无功用义故不开二也。但有功用故但有学道也。今明此中诸人多是佛之同行则是大乘学无学也。今授显名及密行二种学无学人记故以目品名也。品开为二。初请记二授记。请记为二。初阿难罗云二人请记。次二千人请记

问。序品列众阿难皆在无学众摄。今何故入学无学人众摄耶

答。凡有三义。一者上品明阿难之德。预是佛法第二师。虽非无学而在无学众摄。今据其位分。既是初果故不入无学众摄

问。若尔罗睺既是无学。何故不入前品摄也

答。要授阿难记方得授罗睺记。阿难既入今品摄。罗云亦入今品摄。二者阿难罗云与上五百弟子愿行不同故别入今品摄。三者上明无学人有权有实。如满愿为权余人为实。今欲明学无学人亦有权实。阿难罗云有发迹故所以为权。二千人不发迹故目之为实。然发迹不发迹皆是权人。如上释也。初文有三。一内心思惟。二外形致敬。三发言请记。则三业次第也。我等于此亦应有分者有二推二结。二推者。一举自推应得记。明我等于此亦应有分者。叙己得悟解也。唯有如来我等所归者。请佛证明验其有解。又迹居声闻宗归佛道故设此言也。又我等下第二举他推必应得记。此二人最为亲近。若遂不得记凡有二失。一乖于物望。二违其本愿。若佛见授第二明二结。我愿既满结上自推。众望亦足结上他推。又唯有如来我等所归。同余声闻故应得记。又我等为一切世间。明异余声闻故应得记。我愿既满结同余声闻。众望亦足结异余声闻。尔时学无学下第二二千人请记。尔时佛告阿难下第二授记。前授二人记次授二千人记。前授二人记中初授阿难记次授罗云记。初授阿难记有四。一授记二新学生疑三释疑四结喜。初授记中前长行次偈。长行前行因次得果。得果之中偏明寿长者。欲显阿难护法因缘故得长寿果也。尔时会中下第二新学生疑。所以疑者。佛加其神力欲发阿难之迹故兴此疑念也。尔时世尊下第三释疑。空王佛者。毕竟空是诸空中之王。故智度论云。性空菩萨所行。毕竟空是佛所行。释迦阿难同以毕竟空为本。故言俱于空王佛所发菩提心。释迦发心已后勤习毕竟空故自成佛。阿难多闻故以为侍者。师及弟子同起毕竟空。记与不记何所疑耶

问。勤习毕竟空何故成佛。阿难多闻何故为弟子

答。寄迹而言。多闻是众行中一行。勤进遍策众行。故有成与未成。阿难面于佛前下第四领解称叹。次授罗睺记如文。尔时世尊下第二授学无学人记。初授记次领解称叹也。寂然清净者。显二千人知诸法先来寂灭本性清净。故堪与无生记也。余文易知也

    法师品第十

今以四门释之。一来意门。二释名门。三体相门。四阶位门。来意门者略明十义。一者上乘权乘实凡有四章。第一略开权显实动执生疑。第二执动疑生申疑致请。第三广开权显实断疑生信。此三已竟。今是第四次明流通。所以明流通者。上但一处一时利益一会。然群生不穷大悲无限。今欲一切处一切时利益一切人。是故明流通也。二者依智度论云。释般若有二门。一直说门二称叹门。今亦两也。上来直说法华。此下称叹门说故有下诸品也。三者又有二门。一智慧门二福德门。上来三周说权实二智谓智慧门。此下明受持读诵功德无边谓功德门。四者复有二门。一者体门二者用门。上来三周广说平等大慧不二正观谓法华体。今明受持读诵如说修行能生福慧谓法华用门。五者约人又为二门。一者福德深厚众生现在值佛面受法华。二者福德浅薄但值经卷不睹如来三周说法。上来为福德深厚人。自此以下为福德浅薄人。故智度论云。福德厚者亲从法尚面受波若。福德薄者但值金牒文字。六者众生有二。一者与佛结重因缘。二与菩萨为善知识。自上以来为佛结缘众生说法华竟。今为与菩萨结缘众生说于法华。是故如来三周说竟付嘱四依。令有缘众异世同益也。七者有二门。一者燃灯二者传灯。释迦自说平等大慧谓燃灯也。今劝一切众生展转弘宣明众生不尽法灯常照谓传灯也。八者演说正法凡有二门。一正说门二证说门。自上已来明正说竟。从此以下辨证说门。故宝塔涌现证说不虚。令未信者信。已生信者不退。九者如来出世演说正法凡有二门。一者正说二者诫劝。所言劝者。令物受持乃至如说修行。所言诫者。一言毁法及弘经人其罪祸无边。自上已来明正说门。从此以下辨诫劝门。十者接上受记文相生者。如来授记凡有二种。一者别记二者通记。上来但明别记未辨通记则授记义未尽。今欲辨通记之义故有此品。言通别记者凡有三种。一者世通别。上但别明佛在世人得记。今通明二世人得记。二者人通别。上别明三根声闻人得记。今通明幽显凡圣预闻经生信者皆与授记。三者时通别。上别明劫数有限之得记。今通明得记不论劫数期限。所以然者。劫数有限必是深悟。今通浅深故不明期限也

问。何故具授通别两记耶

答。此经明唯有一乘无有余乘。一切众生并皆成佛故悉与佛记。亦是悉与佛记则显唯有一乘。故举授记释成一乘也。第二释名门。言法师者。法谓妙法。平等正观可为心轨故称为法。以人能上弘大法下为物师故云法师。如世药师以药治人病名为药师。不言为药作师。法师亦尔。不言为法作师名为法师。然复有以法为师故云法师。是以经云诸佛所师所谓法也。下文亦有此意。故示弘经模轨。则是以法为师。然虽有二事合成一旨。上既师于法。然后方能为人作师也。第三体相门者。旧云五种法师合受持为一。龙树解受持云。信力故受。念力故持。则受为其初持为其后。久久不失方是持义。则分受持为二故成六种。故成六种法师。若加正忆念者则为七种法师。然多小适时无定数也

问。五种法师具几业义耶

答。受持谓意业也。书写谓身业。读诵说谓口业。此大判为言耳。然书写具二业。运手必经意地。读诵等具三业也。约福慧者。说法多是智慧。自余四种可两通之也。第四明阶位门。然通而言之。十信已上皆能弘法为物作师。别而言之。依涅槃经。十六分中解一分义堪为物师也。旧云流通凡有五品开为三章。第一三品命觅弘经之人。第二持品受命弘经。第三安乐行品示弘经方法。所以有此三者。一周说法既竟。必须弘通。是以叹法美人令人欣慕弘宣于法。故有第一命觅弘经人也。如来有命大众顺旨。故有第二受命弘经。但既于恶世欲弘善道必多留难。令安住四法则身心快乐乃可弘道利人。故有第三示弘经方法。初又两前品正命觅弘经之人。第二两品证说。今谓不无此意。但法师一品正是流通。见宝塔已下别属大段。后当具足说。就此品中两长行两偈颂开为二别。第一一长行一偈叹持经人德令其心悦以劝弘经。第二一长行一偈叹法示弘经模轨以劝弘经。初文又二。前长行次偈。长行为二。第一前叹二时弟子。第二次叹两世法师。叹二时弟子即二。前叹佛在世闻法弟子。次叹佛灭后闻法弟子也。因药王告八万大士者

问。智度论云。说智慧门对出家人。说功德门对在家人。今何故说智慧对声闻。说功德对菩萨

答。两经各异。彼经明出家人好智慧在家人好功德。此经明声闻有执三之病故说平等大慧以斥之。所以对声闻也。菩萨无有此执故不对之。大士本欲弘道利人。今流通正是其事故对菩萨。又上来开三显一其义已周。则皆成菩萨无复声闻。故宜对菩萨也。又依龙树云。此经是秘密法不可付嘱声闻。故付菩萨。于菩萨中别告药王者。其人亲闻法华得悟以舍身命财弘通斯法。今欲令余人学之故别命之。所以因药王菩萨复告八万大士者。此八万人末世有于重缘。今欲令八万大士上学药王下利末世故因药王而告之也。药王汝见是大众中者凡有二义。一者欲使药王八万大士流通此经令其善根成就。故列二世弟子闻经得记令师识之。故云汝见之不。汝若弘经化之行则成就。若不弘经化之行则不成就。是以告之问言见不。二者欲以二世弟子付嘱药王及八万人。如金刚波若论云。以根未熟菩萨付根熟菩萨。故列众问之也。一念随喜则与记者。闻法一念随顺至理则与理会。与理会故而生欢喜。便行与佛应故得佛记。又一念随喜则知唯一无二。必当作佛不退为二乘。故得佛记。注经云。能现在闻法一念随喜。譬如松柏始萌便有陵云之势。今闻法虽浅已树菩提之根故与记也。佛告药王又如来灭后下第二明佛灭后弟子闻经得记。所以有此文来者凡有二义。一者前令八万大士于佛在世十方佛土弘经。今于佛灭后弘经也。二者有人疑云。佛在世时众生福德利根闻法随喜可得记耳。佛灭度后薄福钝根虽复随喜应不得记。是故释云。但使闻经信解功德一等皆与授记也。若复有人下第二叹两世法师功德。所以前明弟子功德今明法师功德者凡有三义。一从浅至深。前叹弟子浅功德今叹师深功德。二者前明弟子出所化之相。谓闻经随喜即与受记。谓所化之相也。今明法师功德出能化之人相貌。有此相貌故是法师。三者上告药王列二世弟子令师识弟子。今出法师相貌令弟子识师。以师弟子相知则弘法化人义成也。就文为二。第一别明二世法师功德。第二通明信毁。初又二。前明佛在世二种法师。次辨佛灭后二种法师。初明二种法师即为二别。一者下品二者上品。法师品位既多。今略明上下二品。约位而言。初依之人为下品。余之三依为上品也。所以分此二者。初依具烦恼性既是凡位。是故为下品。后三同是圣位。故合为上品。然位义难知。聊寄一门以为次第也。初人又四。一明现德则出法师相貌。谓有此相貌即是法师也。药王当知下第二出成法师往因。即是明法师过去德也。成就大愿者明寻此人既供养多佛应生净土但成就大愿故来生人间耳。药王若有人问下第三明此法师未来世果。此人既现在弘宣大乘。过去殖因久积故必定成佛也。何以故下举现因释当果也。是人一切世间下第四劝物供养。以具出法师三世功德。则是无上福田初心之佛。故应以佛供养而供养之。又弘于佛道宜设以佛供。何况尽能受持下第二明上品法师。此人文理俱备故称尽能受持也。若是善男子下明佛灭度后二种法师。亦前明下品次辨上品。此二品与前二品异者。前约弘法广略以分二品。今约为人少多以分二品。则如来使者。宣转教命为使义也。如来所遣者。流通得其旨趣。必可委之以理为所遣也。行如来事者。佛以益物为事。弘说有益为行如来事也。何况于大众中下第二明上品法师也。药王若有恶人下第二通明信毁。就文为二。初明毁之得大罪。后明信之得大福。所以明信毁者凡有二义。一者如来出世欲示众生罪福二门。故大品云。若不说魔事魔罪则是众生恶知识也。二者上明二种法师宣通正法之时。不应轻毁宜须供养。毁持经人罪重佛者。泛论罪福凡有二种。一者约心二者约境。约心者。重心则罪重轻心即罪轻。若尔重心毁佛则罪重。轻心毁佛则罪轻。持经人亦尔。不应言毁佛罪轻毁持经人罪重。二者约境。若骂胜境则罪重。毁劣境则罪轻。亦不应言骂佛罪轻骂持经人罪重。既不约心就境云何释此文耶。有人言。骂佛不作断法意故罪轻。毁弘经人作断法意故罪重。所以然者。由此人弘法。是故被骂此则骂人复毁于法。罪兼二种所以重也。竺道生云。法出于佛。若闻说骂佛是则骂人非骂法。是故罪轻。今受持有我。若毁呰之则是毁人有法乃毁法也。今明佛以离八风无复忧喜。虽复得毁不妨正化。今弘经之人犹是凡夫未免八风。若逢毁呰心则退悔不能弘法。法既不弘便无行法之人。既无行法之人谁复得佛。以断三宝种故罪重也。又弘经人闻毁则妨自行自不得成佛。亦妨化他他又不成佛。则罪之大矣。佛闻俱不妨自行化他故罪轻也。药王其有下第二叹弘经人福重也。以佛庄严而自庄严者。佛以正观之法庄严于人。通经之人亦入正观故以法严人。又佛住大乘用万德而自庄严。弘经之人行与佛应。亦随分具佛万德也。则为如来肩所荷担者。如来荷担于法。持经之人既其弘法。佛以恭敬于法。既担所弘之法亦担能弘之人也。就偈颂为三。初二偈颂第一二世弟子劝供养两种法师兼自受持。次十三偈颂上二种法师。后一偈叹法释成美人。就初两偈又开二别。第一偈上半明欲成就自然智者此是无功用智也。第二偈明一切种智慧者此明二种智。一切种智照有智也。慧者一切智照空慧也。若有能受持下第二十三偈又开两别。初七偈颂两世法师。次六偈颂前信毁。就前又二。初四偈颂佛在世二种法师。次三行颂佛灭后二种法师。就前又二。一行颂下品。三行颂上品。佛灭后亦二。二行颂上品。一行颂下品。次颂信毁亦六行。二行颂毁之得罪。四行颂敬之得福也。供养持经人胜佛者。亦不就福田及心。但得供养称叹则增进自行化他。佛则不尔故过佛也。而智度论云供养十方补处菩萨不及佛者。此约福田优劣判也。尔时佛复告药王下第二段所以有此文来者凡有四义。一者上来叹人今则美法。以叹人美法成流通之义也。二者上叹人明人为法师。今美法以法为法师。欲释成法师品有二种法师义故有是文来也。三者上叹人弘经得无量福。今美法则生无边慧。以福慧具足流通义成。四者上正叹人弘经今示弘经方法。释成上弘经之义也。亦有长行与偈。长行有三。一叹所弘之法。二明弘法之方。三明弘经利益。此三即是次第。初门有五。一约法叹。二就人叹。三约处叹。四约行叹。五明得失显成叹义也。我所说经典无量千亿者。谓华严已后灵山之前诸教非一也。已说令说当说者略举三说摄一切教也。已说者法华之前一切大小教也。今说者谓法华也。当说者谓法华已后涅槃之流也。而于其中此法华经最为难信难解者。法华之前大小分流其言易信。法华之后三一已会亦非难解。此经开方便门显真实义。反三之始归一之初。于昔执异之人故成难信难解也。始不受为难信。终不悟为难解。又破三归一斥短明长名为难信。非三非一不短不长目为难解也。此经是诸佛秘要之藏不可分布妄授与人者。此经明二权二实。言约理周故称为要。昔来隐而不传目之为秘。如人妙宝蕴在于内故名为藏。既称秘要之藏故不可妄授与人也。诸佛世尊之所守护乃至未曾显说者释上秘要之藏也。所言守护者。然法相寂然不须守护。非器妄传则便破法。以防于破法之情故言守护。而此经者如来现在犹多怨嫉者释上不可分布妄授与人也。一切群生处处染着。大乘处处破之。与世相违故称怨也。况灭度后者。佛在世时众生烦恼犹薄尚不信受。况灭度后颠倒厚重而能解也。药王当知下第二寄人叹。凡有五叹。一者为佛衣所覆。注经云。以一极为衿带无断常之飘落。解从佛所来。故曰以佛衣覆之。又为他方下第二佛护念叹。以弘经人行与佛应故为佛护念。令外恶不侵为护。内善得生为念也。是人有大信力下第三内善成就叹。信于三乘名为小信。今信一乘称为大信。初有信力次起大愿。则菩提心名志愿力。次修菩萨行谓诸善根力。此三则次第也。当知是人与如来共宿第四叹共宿有二种。一者自行论共宿。一乘之理是佛栖止。弘经之人亦住其中。故言共宿。二者化他共宿。佛以生死为长夜。应迹居生死中为物说经为宿止。此人能入理弘经参乎应迹谓共宿也。则为如来手摩其头者第五叹。父母念子故手摩其头。持经之人既是佛子。理应重爱。注经云。手摩表弘法人得宿止也。头表其行高也。又释佛以一乘智手摩其心顶劝其受持。故言手摩其头也。药王在在处处下第三寄处叹。前明在人则人尊。今辨在处则处贵也。不须复安舍利者法华论云。此经具说三种佛菩提。故十七名中一名坚固舍利。如来真如法身于此经中常不坏。故不须更安碎身舍利也。药王多有人下第四约行叹。就文为四。一法二譬三合四释。法说二对。初明善行不善行一对者。若未闻法华开权显实。未精识道之权实。则行菩萨道犹自回惶。或谓进成佛道。或可退住二乘。故不善行。以得闻此经有一无三。直进不退故名善行也。又未闻此经开权显实。则未识二慧不能化物。不名善行。与此相违名善行也。又不闻此经明身权身实。则不深厌生死欣乐佛身。亦是未善行义。与此相违名善行也。其有众生下第二对明近菩提不近菩提。梵本具足。今翻译者略故但有于近也药王譬如有人下第二譬说。此譬但有二意。一明去佛远。二明去佛近也。譬如有人者求佛道人也。渴乏者求佛之志其心猛决如渴思水也。于彼高原穿凿求之犹见干土去水尚远者。今须进退论此义。一者就法华之前明去佛道远义。二就法华自论远义。就法华前论远义有二。一者于二乘教中求佛去道远也。故大品云。以声闻经求菩提者名为不黠也。二者三藏后诸大乘经未废二乘者。于此教中求佛道亦有远义。以此教中明大乘。乃与法华不异。但未废二乘。则始行菩萨犹未精识权实。又犹有回遑之望。则求佛之心不决定。约此一边则有求佛远也。施功不已者闻法华经生闻慧也。转见湿土者于此经生思慧也。遂渐至泥者于此经生修慧也。其心决定知水必近者。既生三慧知佛性水必定近也

问。法华论何故水譬佛性耶

答。正言水隐地下如佛性之不显。故水譬佛性也。竺道生及注法华经云。此对小乘教求佛故知去佛远。就法华教求佛故去佛近也。二者就法华经自明近远。若禀法华未生三慧则去佛为远。若生三慧此则为近也

问。何故就法华教论近远耶

答。但明一高原求水有近远。只是一法华教求佛有近远也。高原者譬法华教也。法华教于二乘为难信。故称高原。又取佛道难得为譬。所以言于高原求水也。穿凿求之者谓书写受持如穿凿也。犹见干土去水尚远者未生三慧故去佛远也。施功不已者。读诵解释如说修行深求法华发生三慧故去水近也。菩萨亦复如是下第三合譬。亦得就二义释之。一者未闻法华不生三慧故去佛远。若闻法华发生三慧去佛则近。二者虽闻法华未生闻慧犹名未闻故去佛远。若闻法华发生三慧故去佛近也。所以者何下第四解释也。三菩提皆属此经者。此经明三佛菩提故三佛菩提皆属此经。又三佛菩提皆从此经出故皆属此经也。此经开方便门示真实相者。开二种方便示二种真实。昔不言二种是方便故名方便门闭。方便门闭则不得示两种真实。今说二种是方便则方便门开。方便门开故得示二种是真实也。是法华经藏深固幽远无人能到者。二权二实蕴在此经名之为藏。渊渊难测为深。古今不改为固也。求之芒然为幽。探赜所不及为远。十住未明名无人能到也。今佛教化者为释疑。疑者云若无人能到众生云何得解。是故释云为教化菩萨故开示之令得信解也。药王若有菩萨下第五寄得失以称叹也。惊疑怖畏者。非处生惧为惊。以一往闻无三乖其本情为惊。讵是佛说耶故疑。若无三即谓谤法故怖。一向不敢决为畏。心有所惧名怖。畏者面怖也。菩萨名新学二乘称增上慢者。声闻谓已满足是故名增上慢。菩萨直已昔不闻今忽闻之不谓已足是故称新。又有此文来者。未来有如此相者莫为说法华经。当为说三乘教也。药王若有善男子下第二示弘经方法。文有四句。一者请说方。是善男子下示说方。如来室者下释说方。安住是中下结说方。慈悲有覆荫之功。喻之如室。忍辱止于嗔恚恶容。如衣之蔽丑。空是安神之所。如坐是安身之处。此之三门即是次第。大悲拔苦大慈与乐。盖是种觉之洪基弘道之本意。欲说妙法宜前建此心。是故第一明入如来室。此诫菩萨莫为利养名闻势力徒众。但起慈悲心为物说法也。既于恶世欲弘善道必多留难。宜应忍之。故次明着忍辱衣。慈悲外荫和忍内安。若无空观虚明则二行不成无由悟物。是故次说毕竟空坐也。不懈怠说法者。上谓意业今身口业也

问。净名经云。慈悲心为女。毕竟空寂为舍。四禅为床坐。与今何故不同

答。二经各有一义。彼明慈悲有养育之能化适之用故喻之如女。今取其拔苦与乐之功在荫盖故譬之如舍。彼明毕竟空至虚无累能障非法风雨故喻之如舍。今明重玄憺怕可以栖卧于神故目之为坐也。药王我于余国下第三明利益。以识所弘之教复达弘教之方便感嘉瑞。则是利益。所以举灵瑞者。奖劝弘经人故也。凡有四事。一遣化众。二遣实众。三见佛身。四还得忆法。遣化众者。供养法师故。引导实人故。权护法师故。遣实众者亦具三义。复令实众得利益故。时时见佛身者。弘经之人若常在正观则常见佛身。故华严云。一切法不生一切法不灭。若能如是解诸佛常现前。但行人不能常在正观故。时时得见佛身。偈为三。初一行总标奖劝。第二十五行半偈正颂长行。第三两偈结叹说法之人。就第二中颂上长行三段即为三。初四行颂叹法。上叹法有五。今但颂第四寄行称叹。上长行寄行叹有四。法譬合释。今但颂譬合二事也。决了声闻法者。昔未开权显实则未知声闻非是究竟。今开权显实定知声闻非是至极乃是入大乘之方便耳。言经王者。此经于今昔权实开合自在故称为王。又独一无二亦是王义也。若人说此经下第二四行半颂弘经方法。若我灭度后下七偈颂第三感于灵瑞。上文有四。今开为五但不次第。初三行颂第一遣化众。次一行半颂第三见佛身。次半行颂第四还得忆法。次一行重颂第三得见佛身。次一行颂第二遣实众也

    见宝塔品第十一

释此品不同凡有三说。第一河西道朗等云。从此文去是第二大段明一乘果。次光宅法师云。此品犹属前章。为证上所说不虚故来。次印法师明。此品具兼二义。一者证上所说不虚。二为开后寿量之义。今同第三证前开后。而以开后为正。所言证前者。证上开权显实不虚义也。所以须证者。一为断疑心。众中犹有疑心。如闻大通智胜佛说时亦有生疑者。是故今须证说断彼疑心。二者为已信之人增长善根令不退转。如华严中七处八会说法既竟十方菩萨来为作证。彼以菩萨说故菩萨来证。今以佛说故佛来证也。言开后者。此经初后二分略有十事不同。一者化主不同。说初分经但以释迦一佛为化主。说后分经则有多佛。谓十方分身及过去多宝。所以然者。说初分经但明所乘之法未论能乘之人。故不须多佛。说后分经正论能乘之人。故须明多佛。集十方分身欲显本一迹多。开于宝塔示真实应灭。是故初分经但明一佛。后分经辨多佛也。二者说处净秽异。说初分经在秽土中。明后分经居净土中说。故法华论云。示现国土无上故现多宝塔。所以然者。说初分经未集分身故不变净。说后分经普集分身所以变净。又说前分经虽开乘权乘实犹覆身权身实。众生心垢一半犹自未净故土犹秽也。至后分经俱弊二权双开两实。则心垢悉除故国土清净也。三者说处空有异。说初分经在于灵山有处。说后分经能化所化并升虚空。所以然者。说初分经宝塔未现故在地说法。后分经宝塔升空故处空说法。又说初分经未辨佛身无生灭。由明有生灭故在有处。说后分经显法身如虚空。方便有生灭故升空说法也。四者徒众异。说初分经菩萨众少。说后分经受道众多。所以然者。说初分经但为三根声闻未正为菩萨。故菩萨众少。说后分经欲显释迦成佛已久。故明涌出菩萨众多显释迦成佛已久。又明法身果德令菩萨修习取证。故辨菩萨众多。又说初分经有三乘杂众。说后分经但有菩萨众。所以然者。说初分经正会三归一故列三乘众。说后分经会三已竟故但令菩萨修因证于佛果。故但有菩萨众也。五者时节异。说初分经时节即短。说后分经时节即长。所以然者。说初分经未明涌出菩萨问讯于佛故时节即短。后分经明涌出众多故问讯时久。又明问讯时久显涌出众多。以涌出众多显释迦成佛来久。初分未辨斯义故不辨时长也。六者请主异。说初分经声闻为请主。说后分经弥勒为请主。所以然者。说乘权乘实正会三归一。令声闻人回小入大。故声闻为请主。说后分经明身权身实。使穷学菩萨得证如来无生法身。故弥勒为请主也。七者说法异。上说所乘之法今说能乘之人。说所乘之法但明释迦一期始终教门。说法则略。能乘之人自从过去得道之初乃至穷未来劫一切诸教故说法则广。八者利益异。说乘权乘实但令声闻回小趣大入于十信。谓浅益也。又得益则少。说身权身实令无数菩萨得十二种甚深之利。又得益则多。所以然者。说初分经但开乘权乘实犹覆身权身实。故利益则少。说后分经俱废二权双显两实。故教不纤隐理无毫翳。故应得道者皆并领悟。是故得益者多也。九者瑞相异。是前分略明三瑞。但至万八千土。后分广明八瑞。现瑞处广。一一方四百万亿那由他国。十者功德异。前略叹持经之善。后广辨格量之福也。言见宝塔品者凡有二义。一者据事而言。宝塔从地涌出大众睹见。因事立名。二者宝塔涌现显法身无生灭方便有生灭。欲令大众因此悟解。故称见宝塔。品开五段。第一明宝塔涌现。第二释现塔意。第三次明开塔。第四二佛分座共坐。第五命觅持经之人。此五即是次第。初文大明形声二事。细分十句不同。一者明宝塔出时。二明宝塔现方。三辨名字。四明形量。五明出处。六辨住空。七明庄严。八明至处。九叙供养。十明出声也。尔时者明塔现时也。有人言。宝塔来意为欲证经。非今始涌出。应在广说之前。何以知然。前放光动地召集有缘。若当一人不集。众生受道缘则不具。是以得知应在略说之后广说之前三请中央。乃至普贤妙音亦并前来。以略说一周如来则止。若列其事则隔绝经文义势不次。是故待詶请广说。乃至流通竟方得列之。今谓此事难知。若在前列则有二过。一者夫论证说要待说经竟。是故华严及普贤观等经皆在后证说。若在前者不成证义。二者宝塔涌现为开身权身实。前但辨乘权乘实故不应涌现。故知在后出也。设令前出亦未得发声印证。以未说法华平等大慧。何由得唱如是之言耶。又依普贤观亦最后出。为证行者罪灭故来。则知证说不在初也。今言尔时者。一开法身时。二证说时也。佛前者第二明塔现方。欲证佛说故现佛前。欲开佛二身故在佛前也。有七宝塔者第三列塔名字。所以明塔涌现者凡有三义。一者依法华论云。所以明塔者示现如来舍利住持故。二者多宝誓愿为证说不虚。三者小乘之流谓佛毕竟无常。是故起塔。今塔涌现佛遂不灭。则知生灭是方便不生灭为真实。为此因缘故明现塔。余经但辨证说不虚。不欲开身权身实。故不以塔为证也

问。何故十方分身佛集但有一塔现之

答。法华论云。存略故也。略者多宝如来身一体示现摄取一切佛法身故也。高五百下第四叙塔形量。五百表法身无生灭。二百五十表应迹有生灭。以实胜权故相挍一倍。从地涌出下第五明塔出处。昔以权覆实故权教如地。今废权显实如从地涌出。又昔执迹迷本。以迷执为地。此执将倾故如地裂塔现也。住在空中者第六住处。明佛法身住于实相虚空。如普贤观经云法身住常寂光土也。种种宝物下第七明塔庄严。表法身众德所成也。五千栏楯譬总持众多。龛室千万谓种种法门度人无量也。无数幢幡谓六神通也。垂宝璎珞四摄法也。宝铃万亿四辨八音也。四面出香者戒香普勋四生也。其诸幡盖七宝合成者。明一一诸德皆为众德所成也。高至四天王宫者第八明塔至处。旧云表说四谛理尽也。三十三天下第九明供养塔。表三十心十地内外凡圣等崇仰法身也。尔时宝塔下第十明出声。向现灵塔容谓意识不存。今大音既发者则知法身不灭也。又欲证上所说不虚故发声也。平等大慧者。如来之慧不一不三绝缘绝观离一切高下取舍断常诸边。故云平等。此是体平等也。而说因果权实皆是法华妙用。诸用之中正明果用。唯有一果故果慧平等。所以然者。题称妙法。唯佛果为妙因行未妙。故正以果慧为平等大慧也。因中随分有妙亦随分有平等也。再称如是者明开权显实二事俱不虚也。尔时四众下第二明现塔意。又开两别。初疑问次佛答。疑问为二。初大众疑二大乐说问。大众有二疑。一疑有塔二疑出声。问亦二也。文处易知。尔时佛告下第二答。就文为三。一明多宝因中誓愿时以詶其二问。二从彼佛成道灭度时下即显有塔因缘詶其二问。第三从今多宝下明今日涌现时正答其二问也。佛答云多宝有大誓愿乃至为证明者。释论第七卷云。解请佛云。诸佛无人请者便入涅槃。如法华经中多宝世尊无人请故便入涅槃后化佛身及七宝塔证说法华一时出现。亦如须扇多佛弟子本行未熟便舍入涅槃留化佛一劫以度众生。相传云。多宝成道时无大机感不得说此经而取灭度故说此经处皆出证明。释论对此意也。而经云菩萨时有誓愿者。无妨因地缘事发愿。或一化众生无大机不闻此经故发斯愿。则因果及经论俱不相违具二义也。是时大乐说下第三次明开塔。所以须开塔者。向虽亲承音旨。未若睹形生信。故须开塔现形成信弥笃。则是开方便门示法身真实。就文为二。第一普集分身为开塔之缘。第二正明开塔。所以普集分身者。欲辨本一迹多也。所以然者。释迦与诸佛互指为分身。即知彼此皆非实佛。别有统一之本为妙极法身故垂净秽等迹。则知法身不二迹身不一也

问。释迦何故指净土佛为分身耶

答。净土佛妙尚是应而非真。则显释迦秽身弥是迹而非本。所以俱集净土分身之佛有其深旨也

问。何以得知二佛俱非真实以显法身非净非秽虚空之身乃为真佛耶

答。睿师传罗什解云。分身明其不实。则知二佛非真。不二为实。又理数应尔。但应直开宝塔。何因普集分身。故知托多宝之愿欲显不二之本不一之迹。所以集分身耳。法华论云。示现无量佛者示现彼此佛所作业无差别。故说集分身佛。又开为二。初明集分身佛之缘。二正明分身佛集。二章各四。初四者。一者神力发引令大乐说问。二佛答。三重问。四如来放光召集也。初以神力故问者。将说法身大事故受大乐说之名。及以神力加之然后问也。佛告下第二佛答也。大乐说白佛下第三重请。前欲见多宝即欲识法身无生灭应身有生灭也。今欲见分身佛者欲了本一迹多故也。本迹之义无穷略而论之。不出法身无生灭应身有生灭及本一迹多。故此品始末但显斯两义。尔时佛放白毫一光下第四正明召集分身。前四章是皆远缘由。今是近缘由也。就文亦四。一者放光遍照十方。二者叙十方诸佛来意。三者变秽为净。四者十方佛集开宝塔。初文有二。前明光照一方。次例余九方。所以放白毫光者。上显乘权乘实今显身权身实。昔二权覆两实喻同垢暗。今俱废二权双开两实。义既明显故以白毫表之。故但放白毫光也。上明所乘之法不二。今辨能乘法身唯一。故但放一光。法与人俱是中道故俱放眉间光也。既是中道即俱妙故有妙法妙人也。次例余九方如文。尔时十方诸佛下第二明十方佛欲来之意。而言欲见释迦及多宝者。由十方佛集得开二义。一开释迦本一迹多。二开多宝真常应灭。时娑婆世界下第三明变净。所以变净者。此是世界悉檀。为待宾故庄严土也。释论第十卷云。如人请贵客则庄严处所。家主则庄严一家。国主则庄严一国。转轮圣王则庄严四天下。梵王则庄严三千土。佛是法王则庄严十方也。二者表众生执迹迷本之心应净故明土净。三者欲以依果显于正果。诸佛依果本是秽土今还清净。则知秽是权土净是实土。欲显正果生灭是权身不生灭是实身也。法华论云。云现一切佛土清净者。示现出世间无漏善根所生也。非世间有漏善根所生

问。何故三变土耶

答。若一变者时众则不觉土旷佛多。今欲显土旷佛多令起信敬故三变也。二欲表三根之秽而得净悟也。又表三乘之秽皆除显一乘之净如净土也。又表彼此无量土同为一佛土彼此无量身同一法身也

问。亦得分身佛表三乘为一乘不

答。亦得也。本是一佛分为多佛。本是一乘开为三乘。今既集分身之佛皆是一佛。亦会三乘以归一乘也。就文明三变土即为三别。初文为二。一明变土二辨佛集也。无大海山林者。欲辨同成一法座客受佛菩萨也。法华论云。所以无秽者。示现一切佛国土平等清净故。言多宝者示现一切佛土同体实性故。十地论云。一佛土摄一切佛土者。以诸佛土同体故也。移诸天人者无缘众生不得闻也。是时诸佛各将一大菩萨者第二明佛集。但将一菩萨来者凡有二义。一法身之果无二。法身之因亦一也。又将一侍者来。为欲遣信开塔之用。即表诸佛云集欲开一法身用。故但将一人来也。各到宝树下者欲树立法身义也。皆坐师子座者。今显法身不畏众生起于疑怖。同上今我喜无畏也。次两变土如文易知。尔时东方下第四十方佛集欲同开塔也。就文为二。初说结佛集。次诸佛欲同开塔也。是时诸佛下第二文也。彼某申佛与欲开此塔者。此明诸佛同欲开宝塔现多宝身示于大众令知法身不灭。不必如僧中羯磨与欲也。又大集经二十一卷云。南方金刚藏佛答彼菩萨云。北方释迦牟尼欲为大众说法。为破大慢遣使从我索。欲我今与之。次西方东方皆亦尔。似僧事与欲。十方佛虽各为化主。一时共为佛事。亦得少分同僧。但不恒尔故异僧事也。尔时释迦牟尼佛见所分身下第二正明开塔。就文为四。一释迦升空。二大众起立。三正明开塔。四大众睹见赞叹供养。初二如文也。于是释迦以右指者第三正明开塔。右指谓手之便即是方便智用。说教化物事便。华严法界品云。安住长者开栴檀塔见过去佛皆不灭度。即是显法身无生灭也。法华论云。破三种无烦恼人染慢颠倒。一者信种种乘。二者信世间涅槃异。三者信彼此身异。为对此三种染故说三种平等。一者乘平等。与声闻授记唯有大乘无二乘故。二者世间涅槃平等。以多宝如来入于涅槃世间涅槃彼此平等无差别故。三者身平等。多宝如来已入涅槃复示现身。自身他身法身平等无差别故也。尔时四众下第四大众睹见称叹供养也。尔时多宝佛下第四明二佛共坐。就文又四。一多宝要释迦就坐。二释迦坐其半座。三大众睹见念欲升空。第四释迦接在虚空。此四文处易知。所以二佛同坐者。正欲以多宝显释迦也。多宝灭既不灭不灭示灭。释迦双林唱灭义亦同然。又多宝灭既不灭不灭示灭。即显释迦不生而生生而不生。以多宝出现欲显释迦实无生灭方便生灭。故要释迦共坐也。所以多宝欲显释迦者。正为禀释迦教人执释迦实有生灭故。举多宝以显释迦。破执释迦生灭病也。分身佛亦尔。以禀释迦教人正谓释迦是实佛故。集分身以显释迦。明净土佛尚是迹而非本则知释迦是应而非真。法华论云。二佛共坐者为显化佛报佛法佛皆为成大事故也。此欲明诸佛同心共显大事故共坐也。大事即是法身。以大音声下第五命觅弘经人。就文为二。一者长行二者偈颂。偈文为二。一者颂诸佛来意。二颂命觅弘经人。所以颂诸佛来意有二种义。一者时众虽睹多宝涌现分身佛集并未达来意。故今释之。二者将欲命觅弘经人故。前叙二佛来意以高励下。释成命持经意。初文为二。一释多宝来意。二释分身集意。二佛各为三义故来。释多宝来意有三。初一行半以高励下故来。次一行偈显法难遇故来。次一行偈举佛本愿故来。释成上二义。又我分身下第二释分身集亦有三意。初一行明为听法故来。次半行欲开宝塔显真常应灭故来。各舍妙土下第三令法久住故来。就文又三。初一行半标为法久住故来。次五行释为法久住故来。后半行结法久住故来也。告诸大众下第二颂命觅弘经人。颂多宝佛明过去世佛弘法华。颂分身佛明现在世佛弘法华经。今命诸菩萨弘经即辨未来佛弘经。此即三世诸佛共弘此经

问。何故现在十方佛集过去但多宝一佛耶

答。法华论云。以略摄广故但明一佛。即略摄一切佛也。又颂二佛来即辨所弘之法。今命弘经即辨能弘之人。以二佛来辨真应二身。故有所弘之法。次明能弘之人凡有四命四释。初一行半正命。次两行释命意。言当知此意者有二种意。一欲显诸佛流通法故来。二欲显真常应灭本一迹多。意在于此故言当知此意。诸佛子等下第二一命一释。初一行命次四行释。诸善男子下第三一命一释。初一行命。次十九行举六种难事解释。开为七别。初五行明广说难。次二行明书难。次两行明读难。次两行明为一人说难。次三行明问难。次三行明持难。后两偈叹教释成六难

问。现见世间持法华经者无量。何故有此六种难也

答。有六种人不信法华。一者贪着五欲见小乐而忘大乐故不信法华。二外道人执着诸见不受离见之法。三小乘人执权迷实不信一乘。故智度论云。五百部闻毕竟空如刀伤心。况闻有一无三也。四执此经是无常教人闻法华常不生信受。五执此经是覆相常闻说显了常不生信受。六有所得人执着此经决定是常闻说非常非无常不三不一无依无得不生信受。若然者古今南北信解者少。经唱六难言不虚也。诸善男子下第四一命一释。初一行半命。次六行叹持经利益释命也

    提婆达多品第十二

所以有此品来者。见塔品既证前开后具于二义。今亦然矣。言成前者凡有二义。一者远来意。此经开方便门示真实相。开一切方便示一切真实。但方便有二种。一顺方便谓诸佛菩萨。二违方便如调达善星。自上以来开顺方便其义已竟。如满愿实是菩萨方便示为小乘。释迦是果德方便示有生灭。今次开违方便用亦有二人。一调达谓人为违方便。二龙女谓畜生为违方便用。故顺方便真实有因果两人。违方便用有人畜二种也。二者上品明过去多宝自来证明法华。今此品释迦引调达为证明。由调达过去世为我说法华经今得成佛。是故法华功力深重宜须信持。故上是引他证。今引自证。是以两品相次来也。又上四番命持经。今叹经三力释成四命。三力者。引提婆达多证有成佛力。龙宫众集证经有广大力。龙女成佛证有速疾力。以经亲有三力故宜应信持。是故引三力释成四劝。所以有此品来也。次生后者凡有四义。一者上以多宝不灭示灭。显释迦方便生灭实无生灭。今复举调达例显释迦。调达非恶示恶。故恶是方便。善为真实。类显释迦不生灭示生灭故生灭是方便不生灭为真实。故上以他佛显于释迦。今引他菩萨显于释迦。是以两品相次来也。二者为成信义故来。如涅槃师子吼品说。云何为信。信如来毕竟不生灭。信提婆达多终不破僧。涅槃既两事相次。今亦然也。故说此品以违顺相对故二品相次也。三者然流通劝信皆是为始学耳。若深行人无劳劝也。今为接恶人自轻己身不敢学大法。是故今说调达虽是恶人得闻大乘受记成佛。故应须学之。四者根缘不同适时而说。以众中应闻此品得悟故应机说之。提婆达多是斛饭王子。提婆此翻为天。达多言热。以其生时诸天心热故名天热。所以然者。诸天知其造三逆罪破坏佛法。见其初生心生热恼故因以为名。此品叹经三力即为三段。一成佛力二广大力三速疾力。由提婆达多说经遂致作佛。故经有成佛之力。由文殊说法华经无量无边众生并得悟道。故叹法华有广大力。龙女闻经现身成佛。故叹此经有速疾力。所以叹此三力者。为成命觅弘经人故也。今从初作名故云提婆品。初章有四。一明提婆过去世事。二结会古今明现在世事。第三为提婆授记明未来世事。第四称叹此品利益。初文二。前长行次偈颂。长行又三。一明释迦积劫求经。二辨仙人施法。三明释迦报恩供养。初又三句。第一明过去受种种身常求法华。于多劫中下第二别作国王求无上道。此中前明求果。为欲满足下次明修因。修因之中初总明欲满六度。勤行布施下略辨檀度。檀度之中初明外施。头目已下次辨内施。时世人民下第三正明求法华经时。时有仙人下第二仙人授法。王闻其言下第三为法勤苦报恩供养。七偈半颂上三章即有三别。初两偈颂王求法。次二偈颂仙人授法。次三偈半颂王报恩。佛告诸比丘下第二结会古今明现在世事。告诸四众下第三为提婆达多授记明未来世事。提婆为释迦本师。今翻为授记。则知师弟子方便无定。违顺等用亦适时为物。小乘经明提婆堕无间狱竟后成辟支佛。然今大乘中明未来成佛。然既随缘违顺。亦适时大小也。二十中劫者。然大劫有三小劫亦有三。杂心文但说小劫以为中劫。善星经云十八小劫为一中劫也。佛告诸比丘下第四明说此品利益。所以偏言闻此品不生疑惑者。小乘经中明。调达教世王杀父。汝若杀父我杀瞿昙。便有新王新佛不亦快乎。调达自造三逆。复教他造逆。则是极恶之人。今遂言是过去善友未来成佛。学小乘者莫不惊疑。是故偏云不生疑惑。又外国诸小乘人不信方等。皆言是调达所作非释迦说。今劝信调达即是劝信大乘也。不堕地狱者。依成实论明四轮治于八难。今明一念信法华经不疑此品具离八难不堕地狱离三涂难。生十方佛前离佛前佛后难也。常闻此经离世智难。若生人天中离聋音难。若在佛前莲华化生离边地长寿天难。于时下方第二叹经广大力。又有七句。一智积请多宝还本土发起论端。佛告智积下第二释迦止请也。尔时文殊下第三明文殊来。序品文殊在座。今品称从海宫来者。据事而言。例如涅槃文殊初虽在席寻与纯陀相随而去至大众问品与纯陀共来。今亦然也。初分开经既竟。或可往海宫化道。今欲赞经功能及问安乐行故复来也。据理而谈者。文殊本停鹫岭而忽在龙宫。可谓虽去而住不往而来也。智积问文殊下第四正问也。文殊师利下第五答。初明文殊化直往菩萨。本声闻人下明化回小入大菩萨。尔时智积下第六智积称叹也。文殊师利言下第七推功归于法华。即是赞叹经力。智积问下第三明龙女成佛叹经速疾力。亦有七章。一问。二答。三设难。四龙女来。五身子难。六龙女举譬答。七明时众悟道。文殊师利言下第二文也。于刹那顷发菩提心得成佛者。伽耶山顶经明有四种发心。一初发心谓入初地。二行发心二地至七地。三不退发心谓八九地。四一生补处发心谓第十地。龙女发心成佛是第四义也。然十信菩萨亦能八相成道。位不可知也。又适化无方可有四句。一迟方便。如十劫坐道场。二速方便。龙女刹那成佛。三亦迟亦速。如释迦六年形此二种是也。四非迟非速。如净土中成佛。不论迟速又四句。一男身成道。则释迦之流。二女身成佛。别有经云佛出女国作女身成佛。三亦男亦女。则龙女是也。本是女变为男。四非男非女非天非人。如净土成佛。又三句。一出家成佛。如释迦。二在家成佛。如智度论云天王佛是。故不须钵及袈裟。则调达成佛号天王佛是也。三者俱非。谓净土佛。又三句。一童真成佛。龙女是也。二非童真成佛。释迦是也。三俱非净土中佛。所以如斯不同者。良由体无碍之道故有无碍之用。适无方之缘应无穷之益。若然者不应疑云此品非佛说。盖是有限之情局无方之化耳。智积菩萨言下第三作难也。言论未讫下第四龙女来。尔时舍利弗下第五身子作难也。尔时龙女下第六龙女举喻总答二人难也。尔时娑婆世界下第七明时众悟道得益

    持品第十三

此品来亦具二义。一者成前二者开后。言成前者。宝塔品偈文四番命持。提婆达品叹经三力。亦是劝持。今菩萨声闻应命持经故有此品。言开后寿量者。以菩萨声闻各明住于忍力者恐闻远寿心生惊疑故逆遮之也。所以应命者有四。一欲上报佛恩。二欲增进自行。三欲将劝余未弘宣亦令传化。四既是菩萨欲利益众生。故有此品来也。为秉持此经以化物故名持品也。品开为五。第一二万菩萨发誓弘经。第二五百声闻发誓弘经。三者学无学八千人发誓弘经。四者诸比丘尼发誓弘经。五者重命菩萨发誓弘经。就此五人可为二例。初四人是应佛前命自誓弘经。后一人佛重命弘经。就初四人中初一是直往菩萨自誓持经。后比丘比丘尼是回小入大菩萨自誓弘经。又为三类。初明诸菩萨慈悲深厚忍辱力大能于秽土弘经。二者自余三众迹示劣弱净土弘经。第三诸菩萨住不退地通于净秽二土弘经。初偏举二人者。药王既流通所寄。乐说能发辉涌塔。故为宣持之首。药王流通所寄者。流通乘权乘实也。乐说发辉涌塔者。开发身权身实之端也。尔时众中下第二文也。回小入大菩萨又分二别。初比丘自誓弘经。次比丘尼自誓弘经。初又二。前明无学人自誓弘经。次明学无学人自誓弘经。复有学无学第三文。涅槃云八十。今云八千。或可千字少点故误成十耳。或可别有八十也。然经既会三归一皆成菩萨。而犹言声闻者凡有三义。一者仍本为名。二者虽复悟一不失于三。所以然者。本破三病是故说一。三病既除一药亦息。非三非一故能一能三也。三者即詺菩萨以为声闻。如前云我等今者真是声闻以佛道声令一切闻。声闻于异土弘经者。一者迹示钝根。如前释之。二斥此土难化。三者注经云。菩萨于此土声闻于他土者。欲明一乘既显万流可一国无彼此悟无少大在誓虽异所畅弥同也。尔时佛夷母下第四比丘尼弘经。就文为二。前授记次辨弘经。授两尼记即为二别。初前请记二授记。此经始终授记有二。一不请而授。二请而授。请而授中自有三种。一发言请。如目连等。二心念请。如千二百等。三现相请。如大爱道等。于时世尊下次授记。授比丘尼记最在后者。一依上列众次第。最在后故。二示女人罪垢深重。三欲息世讥嫌故最后授之。憍昙弥者。憍昙是姓翻为埿土。弥者女也。次授耶输记亦两。初请次授也。尔时摩诃下第二发誓弘经亦开为二。前领解欢喜次发誓弘经。尔时世尊下第五重命菩萨弘经。就文为二。初明眼视二诸菩萨发誓弘经。初眼视者。显诸菩萨智慧利根悬得佛意及悬得经旨趣令物信之。如庄周云目击道存故也。是诸菩萨下第二发誓弘经。就文为二。前长行次偈颂。佛今默然不见告敕者。佛虽叹菩萨悬得佛意。而菩萨住谦让门。故言佛不告敕。师弟叹让合论。各据一义也。时诸菩萨下明菩萨重自思惟。佛虽无言我为菩萨。法应上弘下利满愿报恩也。遥见守护者。久知寿量常恒双林非永灭也。偈文为三。初一行总标发誓弘经。次十七行别明发誓弘经。后两行结发誓弘经。第二段中又开二别。第一明菩萨忍恶。第二明忍恶故为物弘经。忍恶中有二。第一明大士忍恶。二释起恶所以。初又二。第一一偈忍三业恶。如害提婆外道是也。恶世中比丘下第二忍口业恶。又开为二。第一起恶之人。第二正明起恶。各有二段。人中二者。是增上慢人即出人。或有阿练若下第二明处。出处摄一切人尽也。而作是言下第二明起恶亦两。第一明恶言谤。第二作善言谤。皆明菩萨能忍。恶言谤者谓毁法谤人。毁法谓是外道论。谤人谓是邪见之人。就文又三。初两行是私处毁法谤人。常在大众中下第二两偈向公处毁法谤人。第三半行明菩萨能忍

问。初既云说外道论义。复何得云自作此经典

答。初云说外道。而外道十八大经复无此说故是自作。但既非内教。理同外道也。为斯所轻言下第二作善言谤。故人中唯有出处谤中不出善恶也。又二。初半行明起谤。次半行明能忍。为斯所轻言汝等皆是佛者。小乘人谓学大乘人明诸法本性寂灭无有二相。便作是言。若众生与佛无二相者。汝应是佛。如世人云汝作此学便是佛也。此言重意轻也。以轻心出此言故名轻言也。浊劫恶世中下五行半第二释毁谤意。恶人所以毁谤者凡有二义。一者外魔来入身中令其毁谤。三行文是也。二者内愚痴故不知小乘是方便执以谤大。二行半文是也。诸城邑聚落下第二一偈释菩萨忍恶故处处为物弘经。后两偈结誓如文也

法华义疏卷第九

时永仁三年交钟七日中原氏女等戮力同志也雕一卷义疏祷工亲得脱夫恩山叠叠碧罗八万之巅德海洋洋苍溟三千之底故会稽曹[女*戒]投衣裳于江水吴郡女子晒屏风于堂床以畴孝行知今志然则玩直至妙乘于江北为即往安乐之指南耳

            都干缘沙门　素庆谨志法华义疏卷第十

        胡吉藏撰

    安乐行品第十四

释安乐行凡有六门。一来意门。二释名门。三开合门。四体相门。五阶位门。六同异门。来意门者亦有二义。一者成前。二者开后。成前者凡有三意。一者佛教声闻凡有三事。一令回小入大发菩提心则上三周说是也。二令修菩萨行则四安乐行是也。三令得佛果后寿量文是也。为此因缘故有今品来也。二者妙法莲华凡有二种。一者善巧用门。二者真实体门。上破三辨一谓对治之用。三病既废一药亦除。欲显不一不三无二正观即妙法华体。下偈云。观一切法空如实相亦不行不分别。则知三一两舍缘观并忘。今欲摄用归体故有此品来也。三者持品末云恶世弘经被毁辱诽谤受诸苦恼。小行之流多生退没不能弘经。是故今明安住四行虽居恶世常受快乐。今欲示末世弘经模轨故说此品。二生后者将明远寿之果。故今说远寿之因即四行是也。二释名门者。释四行名不同。今依竺道生及注法华经辨四行者。一空寂行。二无憍慢行。三离嫉妒行。四慈悲行。第一前明空寂行者。空寂即是诸法实相波若正观。既乖实相理则便有苦无乐。与理相应则便有乐无苦。今正明弘经安乐之义。是故初明空寂行也。虽内修空观但始行之人观力未成处众说法多恃解陵物。是故次明离憍慢行。夫为师匠若恃解陵他则忌他胜己盖是有识之常情。为弘经之巨患。是故次明离嫉妒行。通法之人虽无憍慢嫉妒。但所化之流凡有二种。一求大道。二执小乘。于此二人多生爱恚。若起爱恚则痴使随之。故须于学大乘者当起慈心。于非菩萨宜生愍侧。是故次辨菩萨慈悲行。义不尽者文当具足。通称安乐行者。安住四法则便得乐故称安乐。行者涉行之义。谓心行此四法也。第三开合门者。开成四行合但二门。初一是智慧后三为功德。心安福慧弘道利人则便得乐。谓福慧一双也。二者虽有四行不出得离二门。得门之中有两种德。空寂是智慧。慈悲为功德。中间二种称之为离故离门亦两。一离憍慢二离嫉妒。谓得离一双也。三者虽有四行不出空有二行。初一是空行。余三为有行。谓空有一双也。四者虽有四行不出自行化他。初三为自行慈悲是化他。谓自行化他一双也。第四体相门者第一行以毕竟空观为体。第二行以无憍慢心为体。第三行以无嫉妒心为体。第四行以慈悲心为体。然此四行唯一正观。约用不同故开四种。观实相义名空寂行。即此正观离过之义谓无憍慢嫉妒。即此空观拔苦与乐故名慈悲。慈悲心不碍毕竟空。毕竟空不妨慈悲。虽行慈悲常毕竟空。毕竟空不舍慈悲。是故超凡越圣。称菩萨行也亦是空悲二道。大品云。菩萨住二法魔不能坏。一者知空二不舍众生。第五阶位门者从初发心乃至佛地五十二位皆具四行。其中自有成与未成及功用无功用义。明昧浅深随位差别。但经正意为接退没之人。末世弘经多受苦恼。故令安住四法则便得乐。高位已上自具四行无俟说之。是故发心之人须依此品自行化他坐禅诵经忏悔。第六同异门者法师品末明于三事。一入慈悲室。二着忍辱衣。三诸法空为座。与今四行义不同者。上文前明有行。次辨于空。所以然者上品正释法师。夫为法师则为物说法宜前运慈悲。但慈悲之心久处生死多诸患难。宜应行忍虽有慈悲忍辱。若不入空观则慈悲忍不成。故次明空行。故从有入空。此品正为恶世弘经多受苦恼心生退没。故前明入毕竟空。则不见身心自他俱静便得快乐。故初明空行。以得空观故能不起憍慢嫉妒。以得空观故导成慈悲。故前明空行后辨有行。又两品欲示空有不二。故前后互说也。就品为二。一问二答。问中为二。初叹前二问后。答中亦二。初总标四行名。二别出四行体。安住四法者。心安住四法则无复苦。故得安乐名安乐行。一者安住菩萨行处及亲近处下第二别出四行体。又开四别。初正明行体。二叹教。三劝修。四总释安乐义。就出四行体即为四别。就初行体又开为三。第一正明行体。末后四行半偈第二辨安乐相初文即是释行。后文释安乐相。行谓因。安乐即行所得果。偈后长行第三总结初安乐行。就初文又二。一长行。二偈颂。长行又二。一标行近二章门。二双释二门。行处者修行之人已入于理而履行之名为行处。虽未入理亲而近之名为近处。此二始终之名。故合为一

问。行处既深。近处为浅。何故前明行处。后说近处耶

答。前明行处举深心标旨使习而近之

问。约位云何

答。有人言。七地已上已入于理称为行处。自尔已还入无生理渐近称为近处。今明依智度论无生既有二处行近义亦尔。但经意正为始学之人标此二处。以得无生相应名为行处。若未与般若相应令发心之人渐渐习近。故名近处。若亲近无生则与颠倒疏远便得安乐。若与颠倒亲近实相疏远则受苦恼也。云何名下第二释行近二章门。则为二别。释行处章门为三。谓标释结也。若菩萨下释章门也。此文意多含。今以七义释之。一依智度论二忍解之。住忍辱地者谓生忍也。后明观空谓法忍也。论云菩萨行生忍得无量功德。行法忍得无量智慧。生忍是违顺等境。菩萨能安忍之于违不嗔。于顺下贪故是功德。法忍不受一切诸法知其空寂故得智慧。此据空有二门以分福慧。又生空位浅与功德之名。法空既深受智慧之称。此约二空浅深以分福慧。又俱就有门以明二忍。忍违顺众生为生忍。忍众生违顺等法为法忍。此二亦有浅深。众生五情取之不得。又是假名。是故易忍。违顺等法是见闻现事。是故难忍。以约忍有浅深以分福慧。然自有福慧不二。无有浅深。今约观门阶级故分浅深也。初文四句。一住忍辱地者。总明三业也。忍辱名地有二种义。一者不为外缘所动故名为地。二者能生如地。以能忍诸辱得通大法。万善便生故名忍心以之为地。柔和善顺者。柔和其言不逆误物谓口忍也。而不卒暴者。虽刀杖加之而身不妄动。以不加报故是身忍。又是威仪庠序名不卒暴。如大品云。菩萨一心安祥也。心亦不惊者。又但非身口不加报。亦不起一念嗔心谓意忍也。又能安同异故心不惊。又复于法无所行者。上辨生忍。今是法忍。二者上是观方便。今是正观体。以调身口然后始得入实相观也。三者上明菩萨行。今明菩萨解。四者住忍辱地是方便慧。观空谓实慧也。五者住忍辱地是外行处。观空是内行处。六者住忍辱地然后观空者。要前明有中行诸功德。以有资空然后始得从空出有。不尔者堕二乘地。七者住忍辱地然后观空者。欲简异耶见观空。智度论云。邪见空前作恶业然后拨之。今言真空者。前行施戒忍禅然后观空也。又复于法无所行者。以住忍辱地调柔身口故得入空。以入空故不行一切生死涅槃等法也。而观诸法如实相者。上不行颠倒之法。今观实相法也。亦不行者。初明不行不实。次明行实。今实不实一切不行故言亦不行也。不分别者。亦不分别行与不行也。上忍辱等即世谛观。观诸法实相乃至不行不分别。谓第一义谛观。以诸佛说法常依二谛。故菩萨依佛修学亦作二谛观也。次就生法二空释者。从初不行至观实相谓法空。不行不分别谓生空观出。正法华下偈中亦有此意。初不行一切法即法空。亦不分别男女谓众生空。先明法空后辨生空者。一是说门次第。二惑者谓有人能作法空观。故复除其观主。智度论亦有此文。次就三谛释此文者。住忍辱地等谓世谛观。于法无所行而观实相谓真谛观。亦不行不分别谓非真非俗中道观。不行者不行真谛也。不分别者不分别世谛事也。故名非真非俗中道观。此三谛是因缘义以不二言二。二名二谛。二不二为中道也。次就泯境智释者。又复于诸法无所行乃至观诸法实相。明缘尽于观也。所言缘尽观者。一切颠倒邪缘皆尽于正观内也。亦不行不分别者。观尽于缘也。以邪缘既尽。正观亦息。故缘观并忘境智俱寂。后偈中亦有此意。初明生法二空谓尽缘。次偈言不得诸法不知不见即尽观也。故肇师涅槃论云。法无有无之相。圣无有无之智。法无有无之相。故无数于外。圣无有无之智故无心于内。于外无数。于内无心。不知何以目之强称正观也。是名菩萨下第三结行处也。云何名下第二次释近处。就文亦二。初明有近处。次明空近处。亦前是形近处。次是心近处。夫始行者择闲居以静身。然后心定以近理

问。行处中亦明空有。与今何异

答。前明空有为深。今明空有为浅。故始行者有空有二观可拟地前柔顺忍也。深行者亦有空有二观。登地已上无生忍也。就文又二。一明不应亲近。二明所应亲近。不应亲近凡离十缘。一不近国王谓离憍慢缘。二不近外道谓离邪见缘。始行之人未能邪正等观故不应近也。注经云。未能天地一指万物一马故不应近于外道。路伽耶陀者旧云是恶解义。逆路伽耶陀者是恶论义。注经云。路伽耶陀者如此间礼仪名教儒墨之流也。逆路伽耶陀者如老庄玄书绝仁弃圣之例。又言路伽耶陀翻为世间行。正法华云赞序歌音。逆路伽耶此云逆世间行。正法华云。结偶习俗也。亦不亲近诸有凶戏。第三离散乱缘。那罗者此翻为力。注经云。文身幻术等是也。文身者以彩画身使班也。亦不亲近旃陀罗下。第四离恶业缘。旃陀者此云可畏。亦云恶。罗者下姓也。又不亲近求声闻者。第五离小乘缘。始行菩萨大照未圆恐容染小法。故令意形宜隔行止勿共。或时来者随宜说法无所希求者。若有机感即为说法。不为名利无所希求也。又菩萨下。第六离染爱缘。五岁已还名小女。许嫁为处女。又云立志不嫁为处女。亦复不近五种不男之人者。第七离无志缘。十诵律五法第一卷云。一生不能男。二半月不能男。三妒不能男。四精不能男。五病不能男。又云。天刑都变半。天者天性不能。刑者被刑者。都者都无根。变者女变为男犹不能也。半者半月能半月不能也。注云。一无根。二二根。三不定根。四有限根。五妒不能男也。不独入他家者。第八离讥嫌缘也。若为女人说法下。第九离能生他爱缘。不乐畜年少弟子。第十离自生染爱缘

问。何故不亲近此十缘耶

答。始行之人颠倒强观行弱。忽亲近非道之缘者。进无济彼之功退有爱累之失。如少汤投冰反助成结。若得正观现前。随意亲近。如通达非道即是佛道。不见产业之事不入波若观者。又摄大乘论明菩萨有甚深戒。具作十恶五逆等业。则进有济彼之功。退无爱染之失。又菩萨有二门。一世界门。二第一义门。世界悉檀随国土风俗讥嫌。虽是深行不得亲近。二第一义门。不见近与不近四句不行。虽有二门而未曾二适时而动。常好坐禅下。第二明所应亲近

问。摄心应在观始。何故在终耶

答。由远离诸缘方得摄心耳。所以在后明之。又远离十缘谓菩萨戒。常好坐禅谓菩萨定。后明观空即智慧也

复次下第二明空亲近处。就文为二。初作第一义观。次明世谛观。初有十七句。观一切法空者不见有也。如实相者显空观是真实也。又观一切法皆如皆是实相。不颠倒者。不取空相也。不动者不生动念也。不退者一得不失也。不转者不为异缘所动也。如虚空者毕竟清净。不如数论外道所计虚空也。无所有性者本性尔也。一切语言道断者四句不能诠也。不生不出不起者智度论云。缘边毕竟不可得故名不生。因边不可得名不出。果边不可得故名不起。又解不从外来故名不生。不从内出故名不出。不从内外合有故名不起。无名无相者外无名故无名。内无相故无相。又离十相故名无相。实无所有者。实录无所有。又实录无所无。乃至实录无颠倒五句也。无量无边无障无碍者。六情不能量故名无量。又不堕三世名为无量。又言。无空有之量故称无量。边不可得故言无边。又无断常诸边故名无边。即有是空。即空是有。空有不二故云无碍。法性自尔。累不能障故云无障。但以因缘有者。第二明因缘世谛观。前明真谛后明世谛者。示实相为本诸法为末。又上明常好坐禅修摄其心。则从有入空今从空出有。璎珞经云。从有入空名第一义观。从空出有名平等观。因是二观为方便得入中道第一义观也。从颠倒生故说常乐者。上明空有二谛。即是显正义。此句叙缘迷。以不识因缘有故从颠倒生计有常乐。常乐属上句也。有人言。诸法实无所有从颠倒生。是故见有如眼病见空华也。光宅云。以取相因生诸法故云从颠倒生也。有人言。颠倒者即释成上因缘义上云因缘者。如大品明众生颠倒因缘故有六道也(常乐字向下牵之也)偈文为二。第一双标行近二处。第二释行近二处。初一行半谓双标也。常离国王下第二释二门也。长行明行近二处。各有空有二门。今偈转势说法。前合释行近二处有门。次合释行近二处空门。欲以空有合为一类也。释有门中前释次结。就释中但释有近处。不释有行处者凡有二义。一者欲显离十种恶缘通得作行近二处前方便故也。离十种恶缘既得为行近方便。即显前住忍辱地等亦通得与行近为方便也。二者为欲存略故。但举近处之有行耳

问。何故长行前明行处。今前明近处

答。长行中就说门次第前明行处之深次辨近处之浅。今依修行次第前明近处之浅。后明行处之深也。长行具明十缘。偈文不可分别。但略无第十生自染爱缘。所言三藏者凡有三种。一者小乘三藏。二者大乘自有三藏。如摄大乘论说。三者大小合论三藏。谓声闻藏缘觉藏菩萨藏。有人言华严等为大乘慧藏。决定毗尼经为大乘毗尼藏。地持论等为大乘阿毗昙藏。今谓大乘经中自有三藏。不应引论也。今言小乘三藏者。欲简余二种三藏也。深着五欲求现灭度者。深着五欲谓起爱人。求现灭度谓起见人。见有身心劳累故求速灭。是则名为行处。近处者第二总结。有人言。应结近处。复言及行处者。此是行家亲近。所以言及行处。以此二处者。有人言。唯应言以此一处。而言二处者。行处是第一。亲近处是第二。故言二处耳。今谓不尔。离上十缘通得是行近二处方便。是故名为二处也。又复不行下第二合颂行近二门空义也。就文亦有二。初二行半前颂空行处。次五行半颂空亲近处。初一行颂上不行之言。即辨法空义。上中下法者。有人言。善恶无记三性为三品也。今谓即以三乘为三品也。又人天为下。二乘为中。大乘为上也。有为无为者。为无为两舍也。实不实法者。上来泯昔教。此句泯今教。以三乘为权。一乘为实。今皆不行也。亦不分别是男是女者。半行颂上亦不分别上偈辨法空故今明生空也。不得诸法不知不见者。不得诸法泯境。不知不见泯观。二空义圆境智俱绝明理既周故。后半偈结为行处。一切诸法下第二颂空亲近处。就文为三。初一行半明空亲近处体。颠倒分别下二行明空亲近处前方便观也。观一切法下二偈明从方便观入于正观。三门次第者。前示观体。次令修习。修习既成后明得观也。又初辨得。次明失。后重明得。若有比丘下第二四行半颂安乐。即行果也。就文为三。初一行半标安乐。二行半释安乐。半行结安乐。两行半为二。初一行入定。谓圣默然。次一行半起定明圣说法也。又文殊下第三结初安乐行。又文殊下次明第二安乐行。有人言。第二行以说法为体。即名说法安乐行。然说法是音声性。法入所摄。今不论此正取动口言说之心。是第二行体。有人言。第二行口无四过为体。今明以无憍慢为体。良由内怀憍慢自举陵他。是故说人好恶长短等。欲弘大道宜应离之。又憍慢是痴使。菩萨不应起也。又众生皆有一乘。同有佛性。并当作佛。不应慢之。如戒经云。我是已成佛。汝是当成佛。亦如常不轻菩萨不轻一切。作此不轻即是弘一乘也。就文为三。一劝住安乐行。二明行体。三辨行果。若口宣说下明行体也。行体为二。初长行次偈。长行为二。前明离过为行体。次明集德为行体。不乐说人及经典过者。若说人过人闻起嗔不受大道。又说人过必是轻慢之心。则自生烦恼。不说经典过者。如来说法浅深随机终归一道。不得执大呵小执小呵大。如百喻经说。有二弟子。互打师两脚即其事也。亦不轻慢诸余法师者。弘小乘者名为余师。当起愍恻不应轻之。又劣于己者名为余师。当恕之不逮亦不应轻也。于声闻人亦不说其过恶。亦不称名赞叹其美者。别称名说过则生其嗔心。若称叹之则增其执见。但得用大通呵于小耳。善修如是下第二明集德行体。但以大乘而为解说者。设答小乘义者方便诱引终令入大。故药草品云。恒为大乘而作因缘。偈颂上二章。即为二别。但转势说法。又遂近颂之。前六行半颂于集德。次有五行颂于离过。初又三别。二行半明净于内外为说法方便。次有两行正示说法之方。次有二偈示答难之能。弘法之人唯此三事。故具陈之也。除懒惰意者。第二颂上离过。五偈二双。初一行诫令勿懈怠。次一行半劝使勤精进都。不肯说为懒惰。数数停息为懈怠。又不勤于事为懒惰。不坚于理为懈怠也。次一偈诫说法之人勿悕外财。次一偈半劝内心念法。我灭度后下第三明安乐果。就文为三。初一偈牒前行体。次两偈明离苦果。次两偈明得乐果也。又文殊下第三行。有人言。第三名离过行。取决定息恶之心为行体。有人言。以意除三毒为行体。今以离嫉妒为行体也。初长行次偈。长行为二初明行体后辨行果。行体为二。初诫次劝。诫中又二。初诫令于人不应起过。次诫令于法不应起过也。嫉其资财为嫉。妒其正报为妒。覆藏自性典情顺时宜名之为谄。为欺彼故现承事相称诳也。又亦不应戏论诸法下第二诫令于法离过。无记心中往复言论名为戏论。中论云。戏论有二种。一者爱论二者见论。今离此二也。有所诤竞者诫令不应偏有所执。求那跋摩遗文偈云。诸论各异端修行理无二。偏执有是非。达者无违诤也。当于一切众生下第二劝令集善也。不多不少者多说则起轻厌。少说则文理未足生彼迷心也。文殊下第二明行果。初明离恶果。得好同学下次明得善果也。偈文为二。五行颂行体一行颂行果。五行之中初二行颂上诫令离恶。三行颂上劝令集善。又文殊下第四慈悲行。前长行次偈。长行为二。初明行体次辨行果。行体为二。前明于学大乘人中起慈心。令其速悟得佛乐。次明于学小乘人起大悲心。欲拔其执小之迷令速离苦也。应作是念下出可悲事。不闻不知不觉者执小为究竟。初不曾闻小是方便。非但不闻。意亦不知小是权说。非但不知亦都不觉。又言不闻。谓无大乘闻慧。不知明无思慧。不觉明无修慧。不问不信不解者。非但执小不闻于大。住增上慢亦不访问学大乘人求其权实。学大乘人设为人说亦不信受。非但不受小执既深在根又钝。故不能解悟也。文殊下次明行果。亦开为二。次明离恶果常为比丘下次明得善果。对上慈悲两行故有得离二果。得果之中前明人爱。虚空诸天下次明天护

问。天上自有经卷。何故来人间听法耶

答。智度论云。佛不说天上有经卷。设令有者。忉利兜率二处有之。诸天来者。人有三事胜天。一能断欲。二强识。三精进。天有二事劣人。一欲天着五欲。二色无色天着禅味故不及人所以来人间听法。又菩萨天欲弘法利人。故来人间听法。又欲逐诸恶鬼及增益法师身心二力。是故来也。所以者何下第二大段次明叹教。所以叹教者凡有三义。一者四行由经而成故须叹经。二者上明弘经之行。今叹所弘之经。但如来在世善识物机默说有时。弘经之人亦须知时而动。不得闻经福重遇人便说。三者近为释成上人爱天护文生。此经既为三世佛所守护爱念。人天护念何足称哉。就文为三。一者双标二说。二者双举两譬。三者双结。双标者初明三世佛所护。文殊下叹教妙理深。无量国中名字不可得闻者。一者小乘国中所不闻也。二无缘国中不得闻也。三者不作闻相不作句相无闻者相。如此之闻无量国中甚难得也。譬如强力下第二双譬。为二别。初譬昔未得说法华。次譬明今始得说。皆前譬后合。转轮圣王譬佛。小王喻四魔。起种种兵明随机设教使物修行降伏四魔。战有功者明佛见众生。修行灭惑称为有功。称根授法各也。随功赏赐随所修行断惑多少得诸功德也。智断为田禅定为宅。有余涅槃为聚落。无余涅槃为城邑。惭愧为衣服。道品为珍宝。象马奴婢喻以神通。独王顶上有此一珠者唯佛与佛乃能究尽一乘妙法也。王眷属者谓十方佛及大菩萨。惊怪释迦以一乘大海。澍二乘牛迹。以未有大机而授大法理所不应。故称惊怪。合譬如文。文殊师利如转轮王下第二为今教作譬。大功者谓大障将倾大机欲动则为说一乘。法华论云。实有功德人闻说大乘而取非大乘。如是倒取为对治故说王顶解珠与之。十种无上中云。欲示现说无上故明解髻中明珠譬。文殊下第三双结为二。初结教妙理深。次文殊下结诸佛守护。次偈为二。初四行颂行体。次十行半颂叹教。不颂行果摄入后大段颂之。颂叹教中九行颂譬。一行半颂双结。略不颂双叹。上双譬双合。今总为一譬一合。三行颂初譬。一行颂后譬。三行半颂合初譬。一行半颂合后譬。此经为尊下一行半颂上双结。半行颂结叹教妙理深。一行颂结诸佛守护。我灭度后下第三大段。一行半劝修四行。而言亲近四法者若未能履行四法则应亲而近之。读是经者下第四大段。广释安乐近接劝修文生。就文为三。第一明觉中得益。第二明梦中得益。第三总结称叹

问。现见读法华人忧恼疾病。云何言读是经者常无忧恼耶

答。众生有二种。一定报业。二不定报业。不定可转定不可转二者转重为轻。故读经之人横罗殃咎。三者不如说行故病不除。如不依方服药。四者众生有无量劫罪渐得微薄

问。何故云读是经者常无忧恼

答。此经开二权二实。畅于佛心故能化之佛及三根领解并皆欢喜。即是欢喜经。是故读者常无忧恼。又无病痛者前叹能除心病。此叹能除身病。药王品云。此经是阎浮提人病之良药。所以然者此经始末破三种病。一凡夫二小乘三菩萨。是故读者得无病痛。颜色鲜白者上叹离益。今叹得益。不生贫穷者上叹得现报益。此叹得生报益。以一乘备万德故读者不生贫穷。以一乘尊极故读者不生卑贱。一乘理正故读者形无丑陋。众生乐见者上明离果。今明得果。刀杖不加者前离内恶今离外恶游行无畏上离内恶中有得有离。今外益中亦有得离。前明离果今明得果。若于梦中第二明梦中得益。望前则是后报益也。凡有五梦。初一行半梦见佛为众说法。次一行半见己身为众说法。次六行半梦闻法得授记。次一行半梦见修菩萨道。次五行梦见成佛。前梦得因中益以四言偈颂之。后梦成佛得果事大。以五言偈颂之。此五梦从浅至深以为次第。初明行浅故但见佛说法。次解渐深见为他说法。次见得记。次见修行。次成佛果。智度论有五梦。一热气多故梦。二冷气多故。三风气多故。四见闻多故。五天神与梦。今是第五。僧祇律明五梦。一实梦。二不实梦。三不明了梦。四梦中梦五前想后梦。今是实梦也。最后一偈第三总结如文也

    从地涌出品第十五

所以此品来者从见塔至安乐行。四品证前开后。此下三品正明开于后。谓辨身权身实。此品与见塔品同从地涌出俱显如来法身。但见塔品以能化显能化。涌出品以所化显能化。能化显能化者明多宝实不灭方便示灭。以显释迦法身无生灭应身有生灭普集分身明净土佛是应非真。以显释迦是迹而非本故名能化以显能化。今举所化显能化者涌出菩萨既多即显释迦成佛来久。故名所化显能化也

问。何故显成佛久耶

答。真应二身要具二义。一者法身无生灭。应身有生灭。二者法身唯一。应身即多。上品已显此二义。但未知释迦为近证法身为当久证。犹未明此一义。故举涌出众多显释迦证法身已久。具此三门义乃圆足。二者世间众生凡有二种。一身二命。身则生灭。命有始终。凡夫既尔。二乘亦尔。至人超四句之外出百非之表。但无名相中为众生故假名相说亦辨身之与命。上品明本一迹多真常应无常谓辨法身。今品以去明佛寿命。身则不生灭随缘生灭。寿则无始无终方便始终。辨此二门则果德究竟。故肇师涅槃论云。六趣无以摄其生。力负无以化其体。此明身无生灭也。随之不见其踪。迎之罔眺其首。谓寿无始终也。斥凡夫身命既尔。破二乘执义亦然。又有此品来者上品明多宝分身。各有三义故来如前所说。今千世界尘数菩萨从地涌出为欲流通此经。何以知然。塔品明佛命持经。今下方菩萨应命而出欲弘经。故弥勒偈明涌出菩萨云。为供养于佛及护持是经。乃至神力品初涌出菩萨发誓弘经即其证也。又有此品来者将说寿量。恐物不信受故前明大众云集。证后说不虚。又时会见多菩萨从地涌出。生希有心增长福慧。故有此品来也。又有此品来者显法华经有十不思议。即是十种妙义。上已明化主国土不思议竟。今次明徒众不思议也。所言涌出品者凡有三义。一者从事立名。千世界尘数菩萨从地涌出故目品。二者以昔教为地。谓昔说王宫实生双林实灭。则以始终教地覆佛无始终。今废始终之教显佛寿无始终。如烈地涌出。三者如来远寿昔为众生烦恼心地之所覆。故不得说。今烦恼心地将倾得说如来远寿。因名表义。故以目品也

问。有人言。初开三显一以明因此事已竟。今明开近显远以辨果是事云何

答。上已论之今当略说。开三显一者开二种三显二种一也。开二种三者明昔三因三果皆是方便也。显两种一者显今一因一果并为真实。若尔者不得言开三显一以明因也。又前正斥二乘果非究竟。叹佛果为究竟。则是正明果义。不应谓辨因也。又夫欲释经宜观其题题称妙法则以果为妙。因行未极则非妙也。故应正辨于果。不得言明因也

问。上既明佛果为妙。以何为因耶

答。显佛乘究竟为果。即显二乘非究竟故属于因。二乘既其是因。人天亦远属因摄。故五乘言之上辨佛乘为果。摄余四乘皆悉是因。以此详文理应然也。就此三品亦开四章。一明序说。二略开身权身实动执生疑。三执动疑生申疑致请。四广开身权身实断疑生信也。初分经去大序近故无小序。去大流通远故有小流通。后分经去大序远故有小序。去大流通近故无小流通。就序分中又开三别。一开发序。二疑问序。三诫许序。开发序者因涌出菩萨数多。开发释迦成佛已久也。疑问序者未了菩萨涌出之意。是故问佛也。寿量既大事。恐物生疑前须诫听许说也。就初又二。第一明远缘由。二明近缘由。远缘由者因他方菩萨发誓弘经得显涌出菩萨。因涌出菩萨得开释迦远寿。故以他方菩萨为远缘由。正明涌出为近缘由。初远缘由中为二。一他方菩萨请。二佛止请。初明他方菩萨请欲通经者从上见塔品命持经人。故诸菩萨应命欲持。而至此品方复发言者欲明三圣共开寿量。一者因释迦命持经人。二者诸菩萨待至今品方奉命请持。三者释迦止请。故仍有涌出菩萨开显寿量。故初分经有释迦现瑞。弥勒生疑。文殊答问。三圣共开乘权乘实。今亦三圣共开发身权身实也。尔时佛告下第二止请。上命持经。今言不须持者两言似反而实以符会。以佛命持诸菩萨请持故得止请。便得显涌出菩萨开佛寿量。此乃是前后相成非相乖也。是以前文命持故得弘经。后文止持故开远寿。则是弘经也。就佛止中凡有二句。一者止他方请。二所以者何下举此土自有菩萨以释止。以他方非释迦所化故不得显释迦寿量。是故止之。此土菩萨是释迦所化得显释迦寿量故举以释止也。前文标于他方菩萨意在于此也。而言六万者明所化菩萨自超六趣之中。得显释迦成道久也。菩萨眷属亦六万者明所化眷属亦超六趣之中今皆成就。弥得显如来成佛久也

问。菩萨涌出为开寿量。云何言护持读诵广说此经耶

答。开显寿量即是广说此经。又诸菩萨来有始终二事。一者初开寿量。二终弘宣此经。故涌出标其初开。神力序其终护也。佛说是时下第二明近缘由。就文亦二。一者通明诸菩萨涌出。第二别明四大士问讯。所以有此二章者初明涌出开能化寿量。即是教门。四大士问讯明众生易度。谓所化信受。即久已成佛众生久已信受。此二是缘教感应。宜分二章也。初有十章同显成道已久。第一明涌出时节。即辨昔非说寿量之时今正是其时也。娑婆世界者第二明涌出处。昔以近教覆远如地覆菩萨。今废近显远譬地烈而现。但娑婆地烈不辨余土烈者有二种义。一者欲明昔娑婆教门以近覆远。今废昔娑婆教故从地涌出。二者欲以释迦所化得显寿量。故还明释迦之土也。而于其中下第三明涌出之人。正以所化得开显能化故明涌出人也

问。塔品何故能化显能化。今以所化显能化

答。塔品明过去佛既方便示灭而实不灭。当知释迦亦然。现在分身佛非实佛。则知释迦亦尔。故能化显能化也。今以菩萨数多及并已成就。则知释迦成佛已久也。是诸菩萨下第四叹菩萨德。明所化德高。显能化成佛必久也。先尽在此下第五明菩萨来处。昔以生灭之教覆佛无生灭虚空法身。故言在此世界之下虚空中住。若不作此释文诸大士等分形六趣弘道利人。何由乃居世界之下虚空中住。故知必有所表也。是诸菩萨下第六明菩萨来意。闻塔品命持经之人是故发来。欲开显寿量及流通此经也。一一菩萨下第七列诸菩萨数。所以列数多者良由所化数多显成佛已久。如见学士积德数多。则知法师敷讲义来久。此中列数皆从少至多。但初导主少而眷属多。后明导主多眷属少。譬如领六万人来者唯有一师。领五万弟子来者则有二师。如是转倍也。是诸菩萨下第八明涌出仪则。至释迦多宝佛所者欲显释迦久证法身无生灭。应身有生灭也。至分身佛所者欲显释迦久得本一迹多也。塔品明诸佛来以显法身。今辨菩萨出欲显寿量故至二佛所。是诸菩萨下第九明问讯时节。所以明时节久者欲显菩萨数多。由菩萨数多故得显佛成道已久也。尔时四众下第十明大众睹见。任大众力不能尽见。今假佛威神故能见。明大众得见表假佛说身权实方得领悟也。是菩萨众中下第二段别明四菩萨问讯。开为四别。一诸菩萨问讯。二佛答。三随喜。四称叹。初又四别。一列名。在空有之表故云上行。踰断常之际名无边行。出垢累之外名净行。道足故称安。智圆故云立。谓安立行也。是四菩萨下第二句叹德。涌出菩萨凡有三品。上品有四人。中品有六万。故初止请。中云师及弟子皆有六万。下品无量千万亿数。在大众前下第三句问讯仪则。而问讯言下第四句正问讯。初长行次偈。长行二。初问讯能化。所应度者下问讯所化。少病少恼者凡有三。一者无病无恼。二者多病多恼。三少病少恼。三句之中但得一句。所以不得无病无恼者众生未得免疾。佛何由得无病无恼耶。不得多病多恼者众生若都不从一乘之化可言病恼多耳。复有受化故不得称多。但得问少病少恼也

问。少病少恼有何差别

答。智度论云。随世俗法有二种问讯。一问讯心为少恼。二问讯身为少病。若就所化释者众生无结使之垢故如来少病。众生脱厄苦之患则如来安乐也。尔时世尊下第二次答两问。前答初能化问。是诸众生下答所化问。就文为两。初明直往菩萨易可化度。始见我身闻我所说者即华严之会诸菩萨等闻说华严即入佛慧。除前修习学小乘者明回小入大之人大机未熟从华严之会竟灵山之前未得显教大乘故简除之也。如是之人下第二明回小入大菩萨大机已熟今化得之故名易度。亦称入于佛慧故知法华即是华严。不应谓华严理深法华义浅。然直往之人初见佛身即得领悟故佛无疲劳。回小之流经四十余年方得入道应有疲劳。但今取始终皆得悟入道总名易化无劳疲也。又言始见我身则见释迦过去久成佛之始。则涌出菩萨是也。此举过去之始明回小入大之人亦入佛慧。辨今世之终。始终之缘并皆得悟故众生易度耳。尔时诸大士下第三明随喜。以能化二权二实既显所化直往回小二人皆悟。此则称大士之怀故随而欢喜。于时世尊下第四称叹。欲显无嫉妒人为佛所叹。尔时弥勒下第二大段疑问序。开为两别。一弥勒问释迦。二分身侍者问诸佛。初又二。一怀疑。二发问。怀疑如文。时弥勒下第二发问。长行叙欲问意。偈文正问。正问为三。初一行标请。次十三行正问。后五行半结请。正问中凡有五问。开为二别。前两偈有二问。是从何所来者第二正问有二。一问来处。二问师资。初有二。前问所从来处。以何因缘集者第二问来意。巨身大神通者叹菩萨德。成上二问也。一一诸菩萨下有三问问于师资。就文为二。初九行序其数多。次二行正问师资。前二行先问后叹其德积。今三问初叙其数多。若德积而数少若德少而数多并不得显成佛久。要具此二义方得开于寿量。故弥勒问中具足序也。是诸大威德下第二问师资。一行问终成就之行。从谁初发心第二问其始行。称扬何佛法三句问中间之行。此三问中具问师与资。欲开寿命意在问师。故一一问初皆标谁。以正显师寿故问师也。如是诸菩萨下第三五行半结请。就文为二。三行半明弥勒未解故请。言乃不识一人者菩萨涌出为开法身之相。法身非十地所了故言不识一人。次两偈腾众请。尔时释迦下第二诸佛侍者发问。开为两别。初问。次答。如文。尔时释迦牟尼下第三段诫许序。又开二别。初叹问。次诫许。言大事者因此问得显寿量佛果大事。又因此问时众得十二种大益。又因此问广说寿量利益未来无边众生。故名大事。大品云。波若为大事故起者谓救济一切众生也。汝等当共下第二诫许。前长行。次偈。长行前诫次许。被精进铠者为说大法当精进求取之也。发坚固意者今闻说大法勿退没也。如来今欲下第二许说。文有四句。一宣示诸佛智慧力者开身权身实。理无不鉴谓智慧力也。故下文云或为此众故说佛寿无量。久乃见佛者为说佛难值。我智力如是慧光照无量故知明佛慧长短。即是明佛智也。诸佛自在神通之力者然诸佛法身非长非短而能长短适化故名自在神通力也。诸佛师子奋迅之力者师子本伏今起名为奋迅。所以奋迅凡有三义。一欲袪尘。二欲申舒。三显无畏。今说法身无生灭始终破凡夫二乘始终生灭之执喻同袪尘。昔以权教覆实实则不显。今开身权身实则真应义显。如师子舒申义也。昔为缘不堪故不说法身真实。故名有畏。今大机已熟堪闻说之。故喜无畏。如师子不惧也。诸佛威猛大势之力者既显法身常住双树无常。莫能摧伏故名威猛大势力。又今说法身必能灭惑生解。故称大势力也。偈文重明诫劝。佛智叵思议者非长非短能示长短。虽示长短未曾长短。故名不思议。若昔短今长何名不思议也。甚深叵分别者此明法身绝四句。超百非故下文云。非实非虚非如非异。岂可以常无常等而分别也。尔时世尊下第二大段略开身权身实动执生疑。初长行。次偈。长行又开二别。第一牒问。我于是下第二前答其师资之问。所以前答师资问者将欲开佛寿量故也。此诸菩萨下次答第一所从来处问也。阿逸多下此非答问。但释上在下方住意耳。所以下方空中住者虚空即是实相法身。菩萨心常游实相而勋习之故常在下方住也。不作此释则文无可消。偈文为三。初一行三句颂答第一师资问。次两行三句颂第二答来处问。志念力坚固下四偈重答第一师资问。又开三别。初一偈牒所化明弟子义。次两偈正明能化辨于师义。后一偈双结能化所化师资之义

问。偈前文云我于伽耶城菩提树下坐尔乃教化之。后文云我从久远来教化是等众。初文明近。后文明远。二语相违。云何会之

答。今以二义解释。一者有不二二义。二者有二不二义。不二二义者初言伽耶者盖是昔伽耶耳。以昔日亦在伽耶城成道化此等众即是久远已来。故与后文不相违也

问。昔云何亦有伽耶

答。寿量品云。自从是来常在娑婆说法教化。故知昔有娑婆及伽耶。又下文云常在灵鹫山。灵鹫即是净土。遂不毁灭。伽耶还同此义。前文直唱伽耶成道犹未明其过去之与现在。后偈云我从久远来则释上是过去伽耶也。次云二不二者即指伽耶之近以之为远。亦指过去之远为伽耶之近。欲显近远不二令众生悬悟正道也

问。何以知然

答。前明五十小劫即是半日。既是近远无二。今类此可知。竺道生云。言彼长者即伽耶是也。伽耶是者即非复伽耶。伽耶既非彼长者何独是乎。然则长短斯忘长短存焉。盖是古旧之说。勿得疑之。尔时弥勒下第三大段执动疑生申疑致请。弥勒所以疑者不知是昔日伽耶故生疑也。初长行。次偈。长行有二。初疑问次请答。就初又二。前怀疑。即白佛言下第二正问。又开为三。谓法譬合。法说又二。初明佛成道近云何于此少时顿能化尔许。斯等久远第二明菩萨修行来久不应始就佛受学。譬如下第二譬说。又两父少譬佛成道近。子老譬菩萨修行久。合譬为三。初明成道近合父少譬。如此大众下合子老譬。今日世尊下合父子老少互相指譬也。我等虽复下第二请答。又开为二。初明请意。唯然下正明请说也。偈文为二。第一十一行颂疑问。次三行颂请说。就疑问又三。即颂前法譬合。颂法说有三。初一行颂佛成道近。次二行半颂诸菩萨修行久。次一行半明久近相违请佛为说。次二行颂譬说。亦三。半行颂父少喻上成道近。一行颂子老譬上修行久。半行颂父子相违喻上第三近远相违。合譬中初半行合父少。次三行半合子老。请说三偈中二行颂请意。一行颂正请

    寿量品第十六

四门释之。一来意门。二得失门。三释名门。四开合。所以有此品来者明身权身实有四章。今是第四广开身权身实断疑生信也。然此品大明觉理囊括古今。文约义丰意深致远。虽是一章之经乃通会释迦始终一化意也。若能解其义趣生无尽之慧长无边之福。亦灭无量重罪。昔有数人共乘船遭风余伴并溺死。唯一人凭物浊济。夜梦云。汝所以偏得脱者昔曾听法华寿量品故也。又下分别功德品云。说此寿量品时十二种利益八种瑞相。余经明得道未有如斯之盛。讲者宣留意寻其旨归也

问。何故顿有功用耶

答。三世佛正果及三世佛依果皆为开寿量而兴。如多宝涌现即过去佛为开寿量故兴。分身佛即现在十方佛为开寿量而集。涌出菩萨即皆是一生补处。谓当来佛为开寿量而现。故十方三世佛皆为开寿量。即知寿量事大故有如上功力

问。三世佛云何为开寿量

答。如前品释之。过去佛为开法身无生灭应身有生灭故现出也。现在佛为开法身不二应身不一故普集。当来佛为显释迦久证法身明法身无始终方便示始终故现也。三世佛为三事故集也。又变净土为开寿量者由依果既其异昔即知远寿亦复不同。具如上释也。今言开权显实者开短为权显长为实也。然如来之寿实无长短。所以然者既称法身则以正法为身。正法岂是短之与长常无常乃至五句可取耶。但随所宜故有长短方便。昔非短说短今非长说长。非短说短欲令识短是长短。非长说长欲令悟长是短长。若闻短不识长则不成于短。闻长不识短则亦不成长。如此障碍行心失佛方便意也。又所以昔说短今明长者欲令众生因此长短悟不长不短正法耳。以悟不长不短故有长短方便用。若言昔短既非今长亦非。今长既是昔短亦是。但非长非短今因机缘宜叹为长明今长为是昔短则非。如涅槃经云。不可言佛定是有为定是无为。若正见者应说如来定是无为。何以故能生众生诸善根故也。此品望涌出品六双辨之。一者上为序说。今是正说。二者上以所化菩萨开能化佛寿。今能化自开能化也。三者上以神通门开能化。如千世界微尘数菩萨从地涌出显释迦成佛已久谓神通门也。此品对弥勒释佛寿量谓说法轮开寿量也。此二则是衣裓机案二物出子也。四者上密开成佛久。今显开于寿量以执近情难倾远寿难信示悟物以渐故前密后显。五者上品略说动执生疑。今广说破执除疑。六者上明所化不思议。今明能化不思议。故法华论有十种无上。第七示现教化众生无上故地中涌出无量菩萨。八者示现成大菩提无上故有寿量品。即其证也。第二得失门者释此经寿量凡有三师。一用五时教者云过去过尘沙未来倍上数。犹是无常。终归尽灭故前云终归于空。故如来寿有限量也。二执四时教者云此经覆相辨常则覆相明寿无量也。第三半满义者云一切大乘经皆明佛常。谓显了明佛寿无量也。今谓初谤经罪重为下根人也。次为过小轻谓中根人也。后得经之用未识经体三种之中谓上根人也。今明须识经体用方见此品意。所言体者法身超四句绝百非。不可言常与无常等。故非量与无量。如华严经云。法界非有量亦复非无量。牟尼悉超越有量及无量。法界则法身也。又下文云非实非虚非如非异。中论观如来品云。寂灭相中无常无常等四句。所言用者非常非无常昔为众生故说为无常。故云诸佛弟子众尚舍无常身明佛寿有量。今为破凡夫二乘执佛王宫实生双林实灭故非常非无常叹美为常显佛寿无量。若不识斯体用者则无十二种悟道人也。所以然者但作常无常解便成二见。云何得悟道也。第三释名门者。所言如来寿量者。依法华论三种如来。一者化身如来。二报身如来。三法身如来。寿量亦有三种。化佛寿量有始有终。故为二乘人八相成道王宫现生双林示灭也。二报身佛寿量有始无终。故下文云。我本行菩萨道所成寿命今犹未尽。以行因满初证佛果是故有始。一证已后湛然不灭。故无有尽终。三法身佛寿本自在之不生不灭无始无终。今品具明三种如来三种寿量。明化身寿量谓开方便门。辨法报二身寿量谓显真实义。故云寿量品。今更四句释之。一实而非权谓法身寿也。二权而非实谓化身寿也。三亦权亦实谓报身寿也。报身即是应身。应身有二。一者内应谓与法身相应。是故经云。诸佛所师所谓法也。以法常故诸佛亦常。二者外应谓与大机性相应故为大菩萨于净土中成佛。内应即实非权。外应谓权而非实。故云亦权亦实。第四非权非实上之三门皆是无名相中假名相说欲令众生因此名相悟无名相。故泯上三门归乎寂灭。第四开合门者经论之中说佛开合不定。大明四句。一本迹俱合。二本迹俱开。三开本合迹。四开迹合本。本迹俱合或合名一佛。谓三宝中一佛宝也。或开为二身。故云佛真法身犹如虚空。应物现形如水中月。既但有一迹一本。亦是本迹俱合。或开为三而三义不定。一者如七卷金光明辨三佛者一法。二应。三化。法身为真。余二为应。此则合真为一开应为二。二者法华论列三佛。谓法报与化。即是开真合应。开真者开法报为二也。合应者以应身为一。此意明本有义为法身。酬因义名报。应物义名应也。次开四佛者此义亦有二种。一者楞伽经明四佛。一应化佛。二功德佛。三智慧佛。四如如佛。彼经云。初一为应后三为真。此亦合应开真也。三佛之中功德智慧为报佛。如如为法身。二者如七卷金光明辨于四句。一化而非应。谓佛入涅槃已为物示龙鬼等身故名之为化。不示佛身故名非应。二者应而非化。经云。谓为地前身。释者云。地前菩萨所见佛身。乃从三昧法门中现名之为应。非六趣摄所以非化。三者亦应亦化。经云。住有余涅槃身。释者云。声闻所见佛身彼见如来相好形修之成佛故名为应。见佛在人中受生同人类故名为化。四非应非化谓法身。四句之中前三并应。后一为真。亦是开应合真也。真应俱开者真中分二。法之与报。应中分二。应之与化。依华严经明十佛。一无著佛安住世间成正觉故。二愿佛依愿出生故。三业报佛信成就故诸行皆成但略说一信也。四住持佛随顺世间不断绝故。五涅槃佛取灭度故。六法界佛于一切处无不现故。七心佛善安住故。八三昧佛成就无量功德无所著故。九性佛善决定故。十如意佛以普覆故也。三佛说不说义随缘所见适时用之。义可知也。广明身权身实有一品半经。开为五门。一劝信门。二正说门。三得益门。四称叹门。五格量门。深法难受。前须劝信。劝信既竟次为广说法。说法应机时众得道疑除领解。是故称叹。信解者福德智慧无边。所以格量。初门又三。一正劝信。二大众受旨。三者诫听。劝信解者劝始行者令信。深悟者令解。又令始信而终解。又今说法身唯佛证解。除佛已还皆是信解也。如来诚谛之语者出所信解也。佛心实为诚。所明寿量事实为谛。自有心实而事不实四句。今是第三句二俱实也。所以三劝令信者智度论第百卷云。为尊重法故殷勤至三。又受法者有三根。是故三说。又诸佛常法不过三。若过三不受是罪逆人。金刚神以杵拟之。次受旨诫听如文也。如来秘密神通之力者第二正说文。初长行。次偈长行为二。一明过去无始。二辨未来无终。但明此二者为破二乘人谓始自王宫终于双树故明王宫生非始双树灭非终也。既明本身无始终即辨应身有始终。本身无始终即显真实义。应身有始终谓开方便门。故但明斯二也。所以前明无始。后辨无终者为破凡夫二乘前明有始。后辨有终故也。又释弥勒父少子老之疑故前明过去久已成佛方化得尔许多人。则是父老子少之义令大众疑断也。又明过去久已成佛化得千世界尘数菩萨。未来无终方度法界一切众生。令受化之徒心生欢喜。此二门各有三章。初门三者第一明过去久成显真实义。第二释疑开方便门义。第三总结正答其问。故前明过去久成时众以昔近疑今远。故须解释。解释既竟方结久成。又初明久成显真实义。次释疑谓开方便门。此二既彰。故须重结。初门又二。第一明证法身久。二明垂应亦久。证法身久明自德满。垂应久明化他德圆。又证法身久破近执。垂应久释众疑。初证法身久为三。初总标如来秘密神通之力。二牒执情。三破近显远。今明佛寿故标如来也。昔未曾说称之为秘。所秘之法甚深故名为密。实长示短因为神通。令物反本还源称之为力。一切世间下第二出执情。皆谓之言正是执情。释迦以下出所执也。然善男子下第三破执显远。又开四别。一法说。二举譬问弥勒。三弥勒奉答。四佛合譬正明寿远。初法说中明成佛久者

问。为破近显远。为开近明远

答。凡有五义。一开近显远。昔不明近是方便故方便门闭。今明近是方便则方便门开。既明近是方便则显远是真实。二废近立远。昔立近废远。今对昔故立远废近。三覆近开远。如来近远二种教门犹如二鸟不相舍离。但为缘故今昔四句开覆。一者今昔俱覆。昔覆远今则覆近。二今昔俱开。昔开近今开远。三昔覆今开。昔覆远今开远。四今覆昔开。今覆近昔开近也。四者指近为远。此明近远无二。如经云。吾今此身即是法身。肇师云。近舍丈六而远求法身乎。五者破近明远。前之四种则是约教。后之一门就彼迷情。若望迷情即是破近显远。若望佛教即是显远开近。故法华论云。出释氏宫伽耶成道此明化佛。从此文去次明报佛也。譬如下第二明譬说。所以借譬者佛常理甚深非譬不显。故假喻晓之。弥勒菩萨等俱白佛下第三弥勒奉酬。文有三别。谓标释结。初标无量。次三句显无量。初明凡夫不知。一切声闻下明二乘不知。我等下明菩萨不知。世尊下第三结。世界无边明唯佛能知也。尔时佛告下第四合譬正显成佛已久。长安旧罗什经本无一尘一劫。梁世有僧造法华经。感于神梦令安此说。夫论劫者所谓时也。明过去时长故将尘数劫。言阿僧祇劫者显不可数义也。成佛之始尚不可知。一证湛然。宁有终灭。将欲明过去显当。故明过去不可数

问。后文云。过去本行菩萨道时所成寿命。此则有始。何故言不可数耶

答。有二义。一者明无始始义但始义长远故不可数。二者欲显法身无始终义故不可数也。然始无始有不二二义。二不二义。不二二义者初证法身是故有始。于三身中是应身。亦名报身。是故有始。而所证法身此则无始故是不二二义。二不二义者所证法身既无始终。言穷虑息能证亦无始终。以能证证于所证所证既无始终能证亦无始终也。自从是来下上辨证法身已久。今明垂应久义。以证法身久谓自德满。垂应久谓化他德圆也。常在此娑婆世界说法教化者。常在娑婆则应化两身也。说法教化者二身所说教也。明释迦久证法身。从证法身已来宜以应身得悟则示之以应身。宜以化身得悟则示之以化身。虽示二身实无所应。虽说一切教实无所说。正释弥勒疑也。以垂应既久常在娑婆说法教化。故有千世界尘数菩萨。即是父老子少非父少子老义也。即是释上涌出品云我于娑婆世界初成正觉方教化之。弥勒闻佛上说谓是今娑婆。是故生疑。今答之乃明过去娑婆。故释疑也。亦于无量百千万亿导利众生者又上释其时长。今明其化广也。诸善男子下第二开方便门。上显二种真实。一明证法身久辨法身真实。二明垂应久明应身真实。今亦开二种方便。一开因方便。二开果方便。因方便者过去值燃灯授记此是因方便也。果方便者示现出家始得成佛也。显二实开两权一切权实义尽也。前显二实一破执。二释疑。显证法身久破其近执也。显垂应久释弥勒涌出品疑也。今开方便又释二疑。就一一门各开二别。初门二者一略开方便略释疑。二广开方便广释疑。上明证法身久垂应久。弥勒旧疑已断。今时众更起新疑。疑云。若证法身久垂应复久者何故。昔说燃灯佛授记贤劫成道。是故释云。于是中间我说燃灯佛盖是方便之言。过去久成此为实说。上来即是显真实义。今释众疑谓开方便门。而称中间者过去得佛为初。今灵山之会为后。中间说于燃灯也。燃灯者智度论云。太子初生身光四边似灯。故名燃灯。太子后成佛时名燃灯佛。余经云。锭光佛者犹是燃灯耳有足者称灯。无足者称锭也。又复言。其入涅槃者瑞应经云。菩萨承事锭光至千泥洹。即是言其入涅槃也。燃灯举其初涅槃明其后。略说始终二事也。诸善男子下第二明广开方便广释疑。非但示燃灯一迹。于过去世有无量方便。故是广释疑也。上略释疑略开方便门。今广释疑广开方便门。又上直称教化之言未出化之仪则故今辨之。又开三别。一感。二应。三得益。若有众生来至我所者机发扣佛故名为至。即是感也。我以佛眼下第二明应。应中明三轮益物。我以佛眼观其信等诸根谓他心轮也。随所应度明神通轮也。自说名字不同者如华严经名号品说。或名舍那。或名释迦等也。年纪大小者住世短长不同也。亦复现言当入涅槃者上明神通之始。今举其终。如涅槃经云。我于阎浮提数数示现入于涅槃也。又以种种方便第三明说法轮。又上是身业益物。今口业益物。又此三句即是次第。名字不同年纪大小谓初方便。现入涅槃谓后方便。今明说法中间方便。化宜虽多此三总摄也。能令众生发欢喜心第三明得益。以三轮称缘故受者得益。故称欢喜也。诸善男子下第二举现在事释疑。亦开为二别。初略。后广。疑者云。若久成佛何故昔说十九出家三十成道。上既闻证法身及垂应久。时众具举近因近果二事生疑。上举过去燃灯即近因生疑。今举现在成道以近果生疑。又开四别。一见机二说教。三显实。四开权。见机中云。德薄垢重者不种大乘无所得善根称为德薄。具足烦恼名垢重。为是人说下第二明说教。为乐小人不堪闻说久证法身方便示现。故明佛实是凡夫从凡成佛也。然我实成佛已来下第三明显实。但以方便下第四辨开权。诸善男子下第二广开方便广释疑

问。上已释二世疑竟。今复何所释耶

答。上释久近之疑。今释虚实之疑。时众疑云。昔说近成今说远成。俱是佛说。即俱应是实。昔近既权今远亦权。若昔近为权今远为实者安焉知昔近非实今远非权。通疑今昔二说。言既相违并应虚妄。为释此疑故有今文来也。又有此文来者释迦现在益物凡有三时。一初成道二中间说法三终灭度。上明初成道方便竟。今明中间益物。于文为二。初明一切方便。二辨皆实不虚。如来所演经典皆为度脱众生者明佛说教大意也。诸佛说教有二种意。一谓未度苦海众生令度。二谓未脱集谛众生令脱也。或说己身或说他身者前句总明说法益物。今别开二种方便。即是二轮。自说释迦之身名说己身。说阿弥陀佛身名说他身。或示己身或示他身者上是说法轮。今是神通轮。如现分身佛等名示己身。示阿閦佛等名示他身。或示己事或示他事者三反净土名示己事。示香积土名示他事。身既有自他。说土亦应然。但例上可知诸所言说皆实不虚第二句正明不虚。又开二别。初标不虚。所以者何下第二释不虚凡有二意。一明证理实故所说不虚。二明深见机故所说不虚。证理实谓得法身。见机实谓起应化身。是故现通说法皆是实也。如来如实知见三界之相者总标知见相也。法华论云。三界相者谓众生界即涅槃界。不离众生界有如来藏故也。无有生死若退若出者释上如实知见于三界也。三界本是生死都域故上明三界。今次辨无有生死。若退若出者此死生彼谓生死也。此句正序具缚凡夫之人也。背大乘退入三界为退。譬喻品云。汝诸子等先因游戏来入此宅也。三乘诸子竞共驰走。争出火宅为出也。此句序三乘众生于三界中出入。故云退出也。今实相法身中悉无如此事也。故无有从上堕下为退。无有自下升上为出。故法华论云。无有生死若退若出者谓常恒清凉不反义也。亦无在世及灭度者上三句明不见众生生死。此二句明不见诸佛起灭。不见王宫初生乃至八十年住故云无在世者。亦不见双林灭尽故云无灭度者。如华严经云。欲令众生生欢喜善故现王宫生。欲令众生生恋慕善故示双林灭。如来实不出世亦不般涅槃。何以故。法身常住同法界故。法华论云。亦无在世及灭度者谓如来藏真如之体不即众生界不离众生界故。非实非虚非如非异者惑者闻上六事皆无便谓法身是实作决定实解。是故今明非实也。既闻非实便谓同幻梦之虚。故次辨非虚。既闻非实非虚便谓冥真如等法性。故说非如。既闻非如便谓与如异体故说非异。法华论云。非实非虚非如非异者离四种相。有四种相者是无常法故。此意释成法身常义也。不如三界见于三界者凡夫见三界故不见三不三。如来见三界又能见三不三。故法华论云。不如三界见于三界者如来能见能证真如法身。凡夫不能见故是故经云。如来明见无错谬故。又凡夫非但不见三不三。亦不见不三三。虽非三界而于众生宛然三界。故大品云。诸法无所有如是有如是无。是事不知名为无明。如来既知三不三故三界即法身。亦知不三三法身于众生即成三界也。佛知三不三故名沤和波若。即知不三三故有波若沤和。是以如来具足二慧。凡夫不知三不三故无波若。不知不三三则无方便慧。故凡夫无有二慧但有断常。以诸众生有种种性下第二上明见法身理实故所言不虚。今明见众生机实故所言不虚。又上见三不三义故三界是法身。今见不三三义法身于众生成三界。是故众生有种种欲。如涅槃云。是一味药随其流处有种种味。即其证也。内因难改名种种性。所乐不同称种种欲。过去业行各异名种种行。追知往缘不同名种种忆想。此从重至轻而说之。若从轻至重者众生忆想犹过去习行不同。习行不同由欲乐各异。实以久习欲成性故也。欲令众生种善根者上明知机。今辨应机授药。广而言之应八万四千病授八万四千药。略授四悉檀。应以世界门得道为说世界。乃至应以第一义门得道而说第一义悉檀。然一一悉檀中有无量门。如世界悉檀有无量世界。如华严云十佛国土乃至无量净秽不同。各各为人悉檀亦有无量。如涅槃经三十余诤论也。对治中亦有无量对治。谓有对治门。增治门。转治门。总治门。第一义悉檀亦有无量。如净名经三十余菩萨说入不二法门也。所作佛事未曾暂废者根性万差教门无数。总而论之为令悟入佛道故云所作佛事。从初得佛之始至今灵山之终及未来际常化物不断。故云未曾暂废。此文亦得明三佛俱是常义。初明一证报身湛然无灭谓报身常。上辨无有生死乃至非实非虚十种不义谓法身常。今明众生不尽化益无废谓化身常。如是我成佛以来至常住不灭者上辨过去无前中开为三别。一者标证佛已久。二者释疑显成证佛已久。此二门竟。今是第三结成佛久义。既称常住不灭。即是显了明常不得复言覆相及以无常释此经也。诸善男子我本行菩萨道下第二明未来无后。一证法身湛然无灭。故知双林非是其终。就文亦三。一明未来无终。二释疑。三辨不虚。初中举行菩萨道者既明佛果寿量远必须辨因长。故前显于长果今开于长因。明长果长因谓显真实义。辨短因短果即开方便门。如乘权乘实中亦明斯二。辨三因三果此是方便。一因一果名为真实也。行菩萨道者即长因也。所成寿命者成谓成就即长寿成就也。故下偈云。寿命无量劫久修业所得也。今犹未尽者法华论称为未满。以众生界未尽故佛本愿未满。非谓菩提未满足也。今经文称未尽者依论释此文者盖是明所度众生未尽。不论佛寿未尽。故与法华论经义相成也。复倍上数者依法华论云。所成寿命复倍上数上明本愿未满。故佛不得入无余永灭涅槃。故将本愿未满以释常义。斥小乘人谓佛无常永入无余。则是违于本愿。今明复倍上数。举寿命不可数以释成常义盖是具举因果两义以释于常。但经文语迮。又讲者不详论意。故合释之耳。所言复倍上数者上明过去无前有三不可数。一世界不可数。二抹世界为尘不可数。三成佛复过此数故不可数。凡夫二乘菩萨尚不知初一数。况能知余二耶。今言复倍者则是不可数不可数也。欲显如来寿出数量表。是故为常。如净名经云。佛身无为不堕诸数。如睿公传罗什法师解云。寿量定其非数。又普贤观云。信一实道知佛不灭。是名忏悔五逆十恶。又如法华论云。复倍上数者示现如来常命。方便显多数。过上数量不可数知。故以众事推之则知。显了明佛常矣

问。未来无后何故称为倍耶

答。过去有二种。一者无始。二者有始。约凡夫二乘及菩萨不见其初故言无始。而非无初证法身。是故有始。今言无后者非但凡夫二乘及菩萨不知其后。又一证法身则毕竟无灭。具此二义故称倍也。然今非实灭度下第二释疑。上既举本愿未满及复倍上数明未来无灭时众疑云。若尔见塔品中何故唱云如来不久当入涅槃。及答魔王自期三月当取涅槃。为释此疑故有今文来也。二者上明现世有三时益物。今即第三时也。又分三别。初开不灭示灭章门。次释。三结初标二门者然今非实灭度标实不灭也。而便唱言下标方便示灭也。所以者何下第二释章门。释中前明不示灭则有损无益。次明示灭则无损有益。薄德之人不种善根者过去不久种见佛因也。贫穷下贱者以不种善根故贫穷下贱也。贪着五欲者前明无善。此明有恶。恶义虽多不出爱见。贪惜五欲谓起爱也。入于忆想妄见网中明起见也。若见如来常在不灭者上叙众生心行。今明佛不得不灭。便起憍恣而怀厌怠者若不唱灭便有损也。闻佛常存心不尊重为憍。恣情五欲为恣。复有众生常见佛故厌患于佛。故称厌也。不勤修道称为怠也。不能生于难遭之想恭敬之心者前辨有损。今明无益也。是故如来下第二明唱灭无损有益。就文为二。初明唱灭。次辨众生得益。前有三句。初标难值章门。所以者何下释章门。非佛不常现。但众生障重故不见耳。故佛于众生为难值也。以此事故下第三结难值章门也。斯众生等下第二闻唱灭得益也。是故如来下第三结不灭现灭章门。又善男子下第三明不虚。又开三别。谓法譬合。所以明不虚者不灭唱灭似如虚妄。故须明不虚。法皆如是者有二种义。一者如涅槃答纯陀云。有为法尔。诸佛法亦然。有为之法有生必灭。诸佛由物感故生。感尽即应灭。盖是理数之常然。故云法尔。二者佛自释之虽实不灭为度众生方便示灭。于物实益。故称不虚也。譬如良医下第二譬说。此譬大意直明父实不死为治狂子方便言死而无虚妄。佛亦如是。其实不灭为度罪重众生方便唱灭而无虚妄。不烦作三世益物譬也。此譬始终有十三句。第一佛如良医譬。第二众生如子譬。第三前佛去世譬。第四众生起惑譬。第五后佛出兴譬。第六众生感见譬。第七应物说教譬。第八利根前悟譬。第九钝根未了譬。第十如来示灭譬。第十一钝根得解譬。第十二如来还归譬。第十三佛无虚妄譬。此十三句即是生起次第。合有十三句。开为三章。初七句明利钝众生过去同种善根。乃至现在同禀佛教。次一句明利根众生始从华严初集乃至灵山法华之会闻佛说法即便领悟不须唱灭。三者后五句钝根众生历闻诸教犹未悟解。要须唱灭方乃得悟。所以但开此二种众生者良医有二种子。一不失心子二失心子。不失心子与药则服不须父示灭。失心之子虽与其药而不肯服。是故示灭。故前章总明二子源由。后别明禀教难易。良医者略明三种。一外道五通。二声闻缘觉。三者诸佛菩萨。外道但能除众生三空已还诸烦恼病名为下医。二乘能治三界之病称为中医。诸佛菩萨能遍治三界内外诸病名为上医。故云良医也。又外道除病必当还发。故称为下。二乘治病或发不发故称为中。诸佛治病毕竟不发。故名为上。又凡夫二乘治众生病凡有四句。一损不增。二增不损。三亦增亦损。四不增不损。故不名良医。诸佛治病唯有一句。但损不增故名良医也。阿含经云。良医有四德。一善知病。谓冷热等。二知病所起。三病生已善知治方。四已差之病令更不生。佛亦具此四种之德。如良医也。法华论云。为不集功德人说良医譬喻。此人不曾修第一乘善根闻说第一乘心中不愿以为第一。为对治此故说良医譬。论又云。此人根未熟为令熟故示涅槃。是故如来说此譬喻。论又云。欲示涅槃无上故说医师譬喻。智慧聪达此叹德释良医义。在心为智慧。在耳为聪。在目为明。智慧譬一切种智。聪譬六通。达譬五眼。明练方药善治众病者方谓教。药譬于理。识教知理称为明练。善治众病谓知病源应病授药也。其人多诸子息第二众生如子譬。昔曾受化故名为子。受化之流更复转化。受彼传化故称为息。然六道众生皆有佛性并应是子。但佛性有二。一者正因。二者了因。具有缘正称为近子。余未禀化未有了因名为远子。或十二十乃至百数者上根难得为十。中根稍易得称为二十。下根转多故称为百。此不约三乘为三根。通就禀教始终有悟不悟。正就菩萨悟入佛慧以分三根也。若就此品始终意者千世界尘数菩萨过去已悟道名为上根。于现在世始从华严终竟法华得悟道者名为中根。若因唱灭为说涅槃而得悟者名为下根。若就现在辨于三根者法华之前直往菩萨已得悟者名为上根。至于法华回小入大名为中根。故涌出品云。初见我身闻我所说法即便信受入于佛慧。谓上根也。除前修习学小乘者。今闻此经亦入佛慧。谓中根也。自此已外犹未得道。闻于唱灭为说涅槃方得悟者谓下根也。三根多门今略示其三也。以有事缘远至余国下第三前佛去世譬。但受微化不得久住故往他方。如涅槃云。所应度者皆已度竟。余未度者为作得度因缘也。有事缘者此土感尽余土缘兴。佛化余缘于彼缘为近。此土感息故称为远。又息此应彼故称远也。诸子于后下第四众生起惑譬。于后者佛去世后也。饮他毒药者昔习观既弱还起颠倒。以正观为自。颠倒为他。故涅槃云。自境界者四念处也。他境界者谓五欲也。心起颠倒目之为饮。能害慧命称为毒药。药发闷乱宛转于地者起惑因熟名为药发。惑有二力。一迷境障智。故言心闷乱。又将死为闷乱。二感生死流浪六道如宛转于地。顺教得涅槃如登高山。背化受生死苦故名为地。又受心苦为闷乱。受身苦为宛转于地也。是时其父还来归家下第五明后佛出兴譬。前明利钝众生背化起惑总明感义。今明后佛出兴总明应义

问。众生起惑流浪五趣如宛转于地。何因感佛

答。苦极则反。如胜鬘经云。法种众苦乐求涅槃。又此中宜用三化。过去益物名一往化。宛转于地此中有随逐化。今还来归家即毕竟化。昔缘尽故去。今感熟称来。应入生死化物则生死为家。如上云譬如长者有一大宅。诸子饮毒或失本心或不失者。第六众生感见譬。过去习观若久虽起颠倒不失本解名不失心。习观未久颠倒强盛失于本解名为失心。又从华严至法华闻教得悟者名不失心。闻教不悟待唱灭方解谓失心也。此犹是起惑重轻。善有强弱故分为二也。遥见其父者正感释迦出世。但见丈六身成道未见法身去理尚远。故称为遥。皆大欢喜拜跪问讯善安稳归者。利钝虽异见佛出世皆同。欢喜谓意业也。恭敬拜跪即身业也。口业称叹谓问讯也。叹佛谓如来者。智度论云。佛从安稳道来故名如来。今称安稳归。归即来也。我等愚痴误服毒药者。上明利钝众生同有感见佛形机。今明利钝众生同有感教机。解机将发同述昔过。故云愚痴。起颠倒烦恼非其本意名为误服。愿见救疗更赐寿命者。请佛说教灭惑名见救疗。教能生解目之寿命。昔曾禀教已得生解。但中途背化起惑失于本解。今重请说教令得本解故称更赐也

问。从遥见其父至更赐寿命为是机缘中语。为据事耶

答。具有二义。机中为论此事。易明言据事者佛初出世人天之流皆大欢喜。乃至释梵请转法轮如言愿见救疗更赐寿命也。父见子等苦恼如是第七应缘说教譬。前譬为缘成道。此譬成道已后转法轮也。文有二句。父见子等譬佛见机也。依诸经方第二明说教也。依过去佛教谓依诸经方。求好药草者教所表理。理能愈病譬同药草也。色香美味者戒譬于色。定喻于香。慧譬于美味。三行圆备故称具足。梼蓰和合者初说小乘为梼。说中乘为蓰。说大乘为合。又法说为梼。譬说为蓰。合譬为合。如来说法不出此三。又总标为梼。别释为蓰。总结为合。说法之仪不出标释结也。又亦譬三转法轮为梼蓰合。而作是言下叹教也。汝等可服者劝如说行也。其诸子中不失心者第八利根前悟譬。从华严至法华禀教得悟者即其人也。余失心者第九钝根未了譬。即第三大段为钝根人不灭唱灭无有虚妄譬。亦即是现在三时中最后益物譬。见其父来虽亦欢喜问讯者。明此下根众生见佛出世亦起欣敬之心也。求索治病者亦有感教之机闻说妙法也。与药不肯服者钝根虽复寻教不能悟理。如失心不肯服药也。毒气深入失本心者释不服药邪行深入失本正解也。于此好药而谓不美者于佛正教不得其理味也。父作是念下第十如来示灭譬。就文为三。一念欲唱灭。二正唱灭。三明正灭。初欲唱灭者众生着常不肯修道。念欲去世欲示无常使其改悟也。即作是言下第二正唱灭也。如释迦自期三月。又如涅槃晨朝唱灭。又如经云吾年已八十形如故车朽当般涅槃也。是好良药今留在此者佛虽去世留法不灭。故十二部经付阿难迦叶也。作是教已第三正灭。遣使还告者正入涅槃遗形舍利起塔等事即是使也。是时诸子下第十一钝根得解譬。见佛泥洹心悟无常遂便得道如服药病愈也。其父闻子下第十二如来还归譬。众生闻佛泥洹既得悟解即见法身。知佛不灭还于本化故称归也。诸善男子第十三佛无虚妄譬。佛言我亦如是下第三合譬。但有三意。初明不灭。为众生下明方便示灭。亦无有能此辨不虚也。第二偈颂二十五行半。颂长行二章。初有二偈。颂过去无始。次有二十三行半颂未来无终。所以颂此二者显如来寿量无始无终。斥二乘凡夫谓有始终之义。长行二门各开三。初门三者一明过去无始。二释疑。三总结。但上文已广。今转势说法略为二意颂之。初偈颂证法身久。次偈颂垂应说法久。则总摄长行一切义尽也。为度众生故下颂第二未来无终。上长行亦三。初正明未来无终。次明不灭示灭以释疑。三明不虚。今偈亦但开二。初颂上第二不灭示灭以释疑。次颂不虚。所以颂此二者执教之流正谓佛无常双林灭尽。今欲显佛常住故须明不灭方便示灭。但不灭示灭似同虚妄。故次颂不虚。此二明未来无终义显故偈但颂此两也。长行不灭示灭既略。今转势则广颂之。开为三别。第一九偈就佛本迹二身明灭不灭义。第二四行半就净秽二土明灭不灭义。第三四偈总结身土。明感见不同。此三总摄一切诸义尽。长行不尽偈广序之。初文又三。第一两偈标灭不灭。第二六行半释灭不灭意。第三半偈结灭不灭。初两偈又二。第一偈就说法门明灭不灭。第二偈就神通门明灭不灭。说法现通摄义既周故但明此二也。众见我灭度下第二六行半举得益释灭不灭意。就文为二。第一偈明见佛灭度生福得益。第二五行半见佛灭度生智慧益。能化之中唯有说法神通。所化得益不出功德智慧。故但明此二义也。因上神通门生功德益。因上说法门生智慧益。上前明说法。后辨神通。今应先明智慧后辨功德。但逐近势故前明功德。后辨智慧也。就后智慧益中有二。初偈明众生感。后四偈半辨佛应。就应中即有三宝显不灭义。初半偈明佛僧二宝。俱出故二宝不灭也。我时语众生下第三辨说法。即是法宝明灭不灭。就说法中初一偈偏就此土论灭不灭。次一行半合就彼此论灭不灭。第三一偈半偏就他方论灭不灭。明灭不灭虽复无穷此三摄尽。神通力如是半行第三总结。明此灭不灭皆是神通示现而如来法身非灭非不灭。常在灵鹫山下第二四行半就净秽二土论灭不灭。所以有此章来者凡有二义。一者释疑故来。时众疑云。现见火劫起时乾坤涸尽。如来之身宁得常存。是故今明土有净秽秽土被烧净土不灭。迹身现灭而法身常存。二者上论如来真应两身辨正果已竟。今次论净秽两土辨佛依果。正果之义应身示灭。法身不灭。依果之义秽土自毁。净土不烧。故身但本迹。土唯净秽。欲辨斯义故有此文来也。此品既有净土。今略论之。法华论释此品明有三身。今对三身亦有三土。一者法身栖实相之土。普贤观云。释迦牟尼名毗卢遮那遍一切处。其佛住处名常寂光。即法身土。故仁王经云。三贤十圣住果报。唯佛一人居净土。璎珞经云。亦以中道第一义名法身土。然诸法寂灭相不可以言宣。孰论身与不身。亦何土与非土。但无名相中为众生故假名相说。故明身与土。虽开身土二实未曾二。但约义不同故分为两。能栖之义说之为身。所栖之义目之为土也。如七卷金光明三身品具有如如智及如如境。就义而望境即土也。二者报身报土。但报身即是应身。应身有二种。一内二外。内与法身相应名曰应身。此犹属法身与法身同土。法华论云。我净土不毁而众见烧尽者。报佛如来真实净土第一义摄。故此即是报身土也。若外应之义名为报身化大菩萨于净土成佛。此以宝玉为净土。此土乃不为劫火所烧而终有尽灭。所以然者今开身有常无常三句。一者法身但常非无常。二化身但无常非常。三者应身亦常亦无常。内应身义名之为常。外应之义名为无常。身既三种土亦例然。法身之土但常非无常。化身之土但无常非常。应身之土亦常亦无常。内应身土此即是常。外应身土此即无常也。若分净秽二土者法报二土此是净土。然化身之土此即不定。或净或秽

问。菩萨亦有三身三土不

答。随分有之。华严云。普贤身相犹如虚空。依于如如不依佛国。如如即法身土。余二可知

问。余众见烧尽而净土不毁此为是一质异见。为异质同处耶

答。依什师意及法华论是异质同处。所言异质者土净秽两质也。同处者净质在秽处。秽质在净处粗妙既殊不相障碍。故今文云常在灵鹫山。即知净土在秽处也。次明一质异见者。所言一质者此有多门。若望正道为论未曾净秽。随净秽二缘见净秽二土。以对净秽二见故言非净非秽名为一质。故言一质二见。若就二缘自论一质异见者。自有是一净质薄福之人自见其秽。自有是一秽质于福德之人自见其净。总论质见各有四句。质四句者自有一质异处。异质一处。一质一处。异质异处。一质异处者一非净秽质在净秽异处也。异质一处者净秽异质在非净秽一处也。所以有此二句者诸法本性寂灭故名一质。此本性寂灭不离净秽故在净秽二处。虽有净秽二质常本性寂灭。故是二质一处。一质二处者即是不动真际建立诸法。二质一处谓不坏假名而说实相。一质一处者直就实相而论实相。异质异处者土有净秽在彼此不同也。见四句者。一质一见一中道质菩萨之人因中道得正观故见中道土。异质异见者净秽异质随净秽二缘见。一质异见者一非净秽质于净秽缘见有净秽。异质一见者净秽二质智者了达知其无二。次约用论四句一质异处如一净质通在净秽二处。如释论云。昙无竭香城之质即在香城处。而香城在阎浮提秽中也。二者净秽二质同在一处。以粗妙不相碍故。三者二质二处净秽二质在彼此二处。四者一质一处如净质自在净处。秽质亦然。约见论四句者自有一质一见。于一净质还起净见。秽土亦尔。二者二质二见于净秽二质各起净秽二见。三者一质二见但是净质于二缘所见不同。四者二质一见虽有净秽二质于福德人但见其净。无福者但睹其秽也。常在灵鹫山下四偈半文开为四句。初半偈标常在灵鹫山。明佛之与土二俱不灭。第二半偈腾众伏疑疑云。现见劫火所烧人土俱无。何得常在。第三两偈半正明净土不毁。第四一行结净土不毁众生见烧也。是诸罪众生下第三四偈明感见不同双结人土。初二偈明于罪福二人感见净秽不同结成土义。第二两偈明为二缘说佛寿长短成上佛灭不灭义也。此二偈有三意。初偈正明随缘说短长。次半偈叹佛智。后半行偈举远因以释长果。汝等有智者下第三次颂长行不虚长行有三。法譬合。今具颂之。初偈颂法说。次偈颂譬说。四偈颂合譬。四偈为四。初偈正合譬明不灭示灭。第二偈释不灭示灭意。第三偈通叙佛随缘说一切教。第四偈明教所表理宗归作佛

    分别功德品第十七

此品是广开身权身实中第三明禀教得益。言分别功德者有二种义。一闻说寿量得益。佛对弥勒分别得悟之人功德浅深有十二位。从品初立名。二者此品末有大段流通。广分别持经人所得功德。从后段受称。合而言之俱从二处立名。故以目品。然功德之名有通有别。所言别者对智慧以辨功德。如五度有行为功德。波若照空为智慧。自有深悟为智慧。浅达为功德。如涅槃师子吼品说。地前为功德。登地为智慧。所言通者修功所得悉名为功德。若尔功德智慧并是修功所得悉名功德。今此品称功德者即是通名功德也。就文为二。初明得益。次辨感瑞。得益为二。第一经家总叙得益。于时世尊下别叙得益。所以别明得益者此诸功德非佛无分别。即大众不知。故须分别。就文为二。第一明登地以上大乘圣得益。第二明地前发菩提心益。法华论云。发菩提心益是十信位。得益虽多斯二摄尽。就圣得益中有十一位。有人言。初六位即是断界内分段生死六地菩萨。第二五位七地以上同断界外反易生死。界内去佛远未论生数。界外去佛近故论生数。今明此事难知。但依文为二。初六位明增道益。次五位辨损生益。虽有增道损生不同并是从劣至胜以为次第也。第一得无生法忍益。以闻佛寿量初证无生。无生是圣位根本故前明之。依法华论以初地为无生法忍也。第二得闻持益。此是得无生法忍更闻胜法持而不失。无生即是方便实慧闻持谓实方便慧。实方便慧既是巧用即胜于无生。故在第二。第三得乐说无碍辨才。闻持是自解。乐说谓化他。其义转胜。故在第三。第四得无量旋陀罗尼。于法门中圆满具足出没无碍胜前乐说。故在第四。第五转不退法轮。前虽得旋持未得不退。今登不退故胜前。第六能转清净法轮。前虽不退犹未清净。今证清净故胜前也

问。前一佛世界后言三千大千世界。此有何异

答。大智度论云。十方各如恒沙三千大千世界名一佛世界。是故三千与一佛世界异也。次明八生当得菩提者第二辨损生益。有人言。从七地至金刚心成损生之义。无明住地烦恼分为九品。一品为一生缘。谓随断一品即损一生。今七地下忍闻经为缘登七地上忍。断一品惑损于一生故言八生当得菩提。七地上忍闻经为缘。登八地下忍。断一品惑损一生。余七生在八地下忍闻经为缘进登八地上忍。复断一品惑损于一生。余六生在八地上忍闻经为缘登九地下忍。进断一品复损一生。余五生在九地下忍闻经为缘登九地上忍。复断一品损于一生。余四生在而文中。从八生乃至四生者经文存略故尔当知。四生即是九地上忍也。从九地上忍闻经为缘登十地下忍。断一品复损一生。余三生在。从十地下忍闻经为缘登十地上忍。断一品复损一生。余二生在。从十地上忍闻经为缘登金刚心。断一品复损一生。所余一生佛果断之乃尽也。今谓此释于义难明不能具叙其得失。今明经论之中有二种生。一者应生。二者实生。如智度论释往生品。明一生菩萨及三生菩萨并是应生何以知然者。住十地菩萨不应受人天生。而今受人天生者此是应生。今言八生乃至一生者。八过受人天生故得菩提乃至受兜率天一生当得菩提。故是应生也。然应生有多少者随缘故尔。亦得由悟理深浅断惑轻重。是故应生有多少也。次言实生者如仁王经叹菩萨三十生功德。一地有三生。谓入分为初生。住分为中生。满分为终生。摄大乘论地论悉有三位。若依此义明八生者。本是七地终生之人闻经力故登八地始生。故余八生在。本是八地始生之人闻经力故得入八地住分余七生在。本是八地住分人闻经得满分犹六生在。本是八地满分闻经得入九地初分余五生在。本是九地初分闻经得入住分余四生在。本是住分闻经得入满分余三生在。本是九地满分闻经得入十地初分余二生在。本是十地初分闻经得入住分余一生在。本是住分闻经力故得入十地满分便坐道场得成佛。盖是一方次第悟。作此论之。若超悟者其间无定。权实二生。正就实生。以闻经得实益故。依法华论云八生乃至一生得菩提者。此以初地离三界分段生死随分能见真如佛性名得菩提。非究竟无上菩提也。此意明本是地前之人闻经力故随分浅深。经八过受分段生乃至一过受分段生便证初地菩提也

问。闻经说寿量云何得无生忍乃至发菩提心

答。若依旧明此经辨无常佛者不应得无生忍。何以然者说无常云何令人悟实相耶。又佛既无常终归磨灭何足可乐而发心求之。若言此经是覆相常者既是覆相便非了义。云何得了义益耶。若言此经明佛决定常者即是常见。云何令人得无生忍耶。今明此品说佛法身绝四句超百非。故前云无有生死若退若出乃至非实非虚非如非异。即知非常非无常不长不短。而长短适缘常无常善巧。时众闻此故得无生及发菩提心也

问。佛寿无量而众生寿自然有量。此乃众生佛二见。诸有二者无道无果。云何得益

答。若作二见即不得益。今既悟佛寿无始无终不生不灭绝四句超百非。即了己身亦尔。此即悟众生佛不二。是故得益

问。此经但明佛寿无生灭始终。何处辨众生寿亦无生灭始终

答。作此问者不读法华寿量品。寿量品云。如来如实知见。三界无有生灭。乃至非实非虚。故知三界即是法身。亦令众生作如此悟也

问。余经悟道者少此教何故得益多耶

答。此经结会始终开二权二实。即教无不周。理无不备。所应得道者尽在此经。是故悟道者多。二者如来一化凡有三门。一摄邪归正门。二摄异归同门。三摄因归果门。法华之前唯有一门。此经初分谓摄异归同门。后分之经摄因归果门。又此经结会始终则具足三门。三门摄理教既周闻之并皆悟道。三者释迦所化凡有二子。一者失心。二者不失心子。不失心子始从华严终竟法华闻教皆悟。余失心者待佛唱灭至说涅槃方得解了。今辨不失心子所应悟者并皆得悟。是故入道者多。不失心子凡有二种一直往菩萨二回少入大。此二种人闻法华经皆得悟道所以多也。复有八世界微尘下第二明地前得发菩提心益也。佛说是法下第二明瑞相。显理既彰悟道非一。是故感于嘉瑞。凡有八瑞。如文所列也

问。前开三显一何故无瑞耶

答。初明一权一实义未究竟。及三根声闻生信犹浅故未现瑞。今具开二种权实悟道人多。故现瑞也。尔时弥勒下第四明弥勒疑除领解说偈称叹。十九行偈分为四别。初一行颂所说教。次十行颂得益之人。次六行颂瑞相。后两行称叹佛。第二段中又开三别。初一行总明得益。次八偈别颂得益。后一偈总结称叹也。八偈又二。初七行颂得圣益。后一行颂凡发心益。七偈之中三行颂增道。三行颂损生。一行总结颂斯二也。尔时佛告弥勒下第五格量称叹。就文为二。一长行。二偈颂。长行有三。第一正述功德。第二正格量。第三结叹也。若有善男子下第二格量。但举五度不举波若者信解寿长。此心即是般若。不可还以波若格量般若也。又般若即是佛寿照境之义。名平等大慧。用大慧为命故名为慧命。即此大慧用法为身。故名法身。故知波若即是佛寿。不可以寿格量寿也。胜鬘经具举六度格量者此是无方便波若耳。若善男子下第三结叹。偈文但颂后二章。十四偈颂格量。五偈半颂结叹功德。初又二。十二偈别颂五度。两偈颂格量。初又二。初一偈明时长行广总明五度。次别颂五度也。又阿逸多下大段第三次辨流通。凡十一品半经。开为二别。初四品半明赞叹流通。从嘱累品竟经七品明付嘱流通。要须叹法美人福慧深重方得凭累使受化弘通。故分此二也。就初文又二。一从此文至不轻品三品半经正明叹法美人。第二神力一品佛见二世众生闻经得益心生欢喜现大神力。初章又二。第一从此尽品略赞叹流通。第二三品广赞叹流通。初又二。第一叹佛在世时人弘经功德。第二叹佛灭后时人弘经功德。就初有三。第一明闻慧功德。何况广闻下第二明思慧功德。阿逸多下第三明修慧功德。又复如来灭后下第二明佛灭后持经人功德。初长行后偈颂。长行明四品人。一下品谓闻慧人。二中品思慧人。三上品修慧人。四上上品修慧之中更开此一品也。何况读诵下第二人也。凡有二句。一叹持经人顶戴如来。阿逸多下第二叹持经人摄诸功德。文有四句。第一总明叹持经之人摄起塔造寺功德。即为以佛舍利下第二别明持经人得起塔功德。阿逸多下第三别明持经人摄得造寺功德。是故我说下第四总结持经人具得塔寺二种功德。况复有人下第三明上品修慧人。若人读诵下第四上上品人。偈文但颂三品人不颂第一闻慧人。十一行半颂第二思慧人。次三句颂修慧上品人。不嗔不恶口下颂修慧上上品人也

法华义疏卷第十法华义疏卷第十一

        胡吉藏撰

    随喜功德品第十八

此下三品第二广明持经功德奖劝流通。三品即为三章。初随喜品明弟子下品功德。第二法师品明五种法师即是中品功德。第三常不轻品明持法华得六根清净乃至成佛谓上品功德。约位分者初随喜人从发心至十信位。第二六根清净三十心位。故法华论云得六根清净者凡夫人以经力故得根胜用未入初地。而经文云未得无漏。故知是地前人。第三常不轻品寄迹而言从内凡以上乃至得佛。此之三品则摄大乘五十二位。五十二位贤圣皆从法华经生故叹经胜用劝物宣持也。所以有此品来者。一者远从前法师品明二世弟子闻经随喜上虽言即与授记未广说其功德。今欲说之故有此品来也。二者若依品次相生闻上分别功德欣然相传故有随喜品。三者上品末说如来灭后若闻此经不生毁呰。起随喜心当知是为深信解相。今欲说其功德故有此品来也。四者欲举劣显胜叹其功德劝物宣持。但默念随喜福已无边。况复书持读诵等耶。五者上品明受持供养此经功德无量。复有人不能书持更谓不得功德。是故今明若不能书持但起随喜心福亦无边。又流通此经命初辨随喜品者。此经明二权二实与昔说相违。执教之徒逆耳违心不能信受。是故今明随喜功德无边。即是劝信解

问。何人闻经不生随喜

答。见塔品中已出六人。今明四种。一者学小乘人保执昔教闻二权二实逆耳违心不生随喜。二者执此经犹是无常因果犹未究竟。若闻一乘之因辨有佛性一乘之果常住不灭。亦逆耳违心不生信受故不生随喜。三者执覆相常人闻此经开方便门示真实相究竟无余了义之说。亦逆耳违心不生随喜。四者有所得人保权执实若闻非权非实无依无得谓是断见。亦逆耳违心不生随喜。故随喜者难得所以功德多也

问。云何名随喜相耶

答。二段经各有体用。乘权乘实体用者不三不一言断意忘谓乘体。昔为物说三今破三说一谓乘用也。身权身实中体用者法身非常无常。命不长不短。亦言断意忘谓佛身体也。昔无常今常。昔短今长谓身用也。随顺二权二实体用而生欢喜故有随喜相也

问。随喜有几种

答。略有二种。一随喜法。二随喜人。随喜法者若顺此经而生欢喜即是金刚般若。信心不逆故名随喜。二随前人所作而生欢喜。如见受持此经乃至解说而生欢喜故名随喜人

问。能随喜心与所随喜事优劣云何

答。有四句。一者俱无优劣。所随喜是无所得。能随喜亦无所得。二者能所俱劣。所随喜是有所得。能随喜亦是有所得。三者所随喜胜。能随喜劣。如凡夫随喜圣人所作善根。四者能随喜胜。所随喜劣。如圣人随喜凡夫所作善根

问。大品经明有所得随喜回向是杂毒食。杂毒食者初食虽美后则害身。有所得随喜初感人天之报后必受生老病死忧悲苦恼。今明何等随喜耶

答。佛意明随喜法华。法华是无所得法。即是波若。故前格量中举五度除于波若。故知作无所得随喜。又若作有所得随喜者。有所得还感世间果报。云何能胜后财法二施耶

问。有能随喜心。有所随喜事。云何成无所得耶

答。既称能所。即是因缘。故能不自能。能名所能。所不自所。所名能所。如此能所无有自性。即是寂灭。故中论云。因缘所生法即是寂灭性言。寂灭者盖是能所宛然未尝能所。故称寂灭。寂灭宛然而不失能所。能所宛然而寂灭。即是方便实慧。寂灭宛然而能所即是实慧方便。故大品云。菩萨随喜欲不堕想心见三颠倒者当用波若方便力也

问。四等中喜禅支中喜七觉中喜五受中喜与今何异

答。四等喜是庆他得乐。禅支中喜是自庆有所除得。五受中喜此通垢净自他。七觉中喜但是无漏。与今并异也

问。但作无得随喜亦作有得随喜耶

答。始行菩萨未堪习无得观。但作有得随喜犹胜逆耳之人也。品为二。初问次答

问。有长行与偈。弥勒发问者。随喜回向是菩萨法门。是故大士为物发问。所以的言佛灭后者为正不值佛世众生望岸自绝者也。佛答亦二。初长行次偈。长行又二。初正明随喜功德

答。弥勒问。第二泛明余四种人所得功德。明随喜人中有三。第一通明五十人随喜功德。第二取最后第五十人举财法二施格量。第三举后况初。明初者弥胜前。又开三。一明随喜人。闻是经随喜已下第二明闻法随喜。从法会出下第三次明转教。随喜即是自行。转教谓化他也。是诸人等下明第二人自行化他。余人闻已下明第三人自行化他。如是展转至第五十人上略出三人。今从四人已上至第五十。阿逸多下第二格量第五十人。上则明随喜。今此辨功德。则是品题二事。一随喜。二功德。又开四别。第一许说诫听。若四百万亿下第二正举财法二施以问弥勒。三弥勒奉答。四佛格量。初举财施。二举法施举财施中前明福田。次辨施主。举六趣明四生者杂心云。六趣但摄正生不摄中阴摄生不尽。今欲摄生尽故说四生。天与地狱一向化生。饿鬼有胎化生。人畜具四也。所言六趣者开合不同。或合为一。谓分段生死。或分为二。即善恶二趣。或分为三。所谓三界。又分为五。依正法念经修罗有二。或鬼或畜。故无别道。依伽陀经修罗有鬼畜天。三道所摄。故无别道。依此经则为六道。智度论云。三种地狱。谓寒热黑。三种畜。地水空。三种鬼。饿鬼食不净鬼神鬼。依余经二地狱。一正地狱在大海下。二边地狱在余山间。正地狱有一百三十六所也。依正法念经畜生有三十四亿种类。具有四生四食。饿鬼有二。一在人中。二在鬼界。阎浮提下五百由旬是饿鬼国。种别有三十六。始从镬身饿鬼终至燃身饿鬼。有形无形者六趣之与四生所摄。谓一门摄众生。即是趣门及与生门。今以二门摄。谓有形无形也。次三门摄。谓有想无想非有想非无想。次四门摄。无足二足四足多足。皆是增数法门以摄生也。有人求福下次明施主。而作是念下次明法施。凡有三句。前明法施意也。即集此众生下第二正明法施。一时皆得下第三次明得益。前二是法施。今明福田也。弥勒白佛下第三弥勒奉答。佛告下第四正明格量。二施时长行广所以不及随喜者。财施是世间因。法施但得二乘。随喜超凡越圣必当作佛。故随喜胜也。如十方萤火不及一日。大千野干不及一师子。智度论云。三千草树不及一如意树。又罪福从乖府理生世间。二乘善根去理远故福少。随喜去理近是故福多。善有三品。财施是世间因为下品。法施令得二乘是名中品。随喜作佛名为上品。阿逸多如是下第三以后况初。有人言。初人最胜后人劣者第一前听佛说法。次五十人闻法随喜即是五十位。谓十地四十心。第五十人是十信初心。最初人是十地终心。故后不及初也。今明不尔。闻经胜劣前后不定。今且就一方明之。初人亲闻是故福胜。后则传闻其福则劣也。又阿逸多下第二泛明余四人。弥勒但略问随喜。佛广答者智度论释往生品云。身子略问而佛广答者。如贫人乞少物富者多惠施也

问。品具明五人功德。何故偏题随喜品

答。随喜是五人之初。故偏说也。又今品以别标名。下法师品从通受称二名相避故互举也。第一人取其往诣听法。故得乘天宫等报。若就听法边明得报者福则无边。此中三品人。若下品动足得乘象马报。中品得乘七珍舆。上品乘天宫也。第二人但取分坐义边故得三王之报。若就听法边福则无穷。第三人正取劝人听法华义得四种报。一者劝人听经则是其人善友。故后还得值善友报。所以言与陀罗尼菩萨共生一处也。二者劝人听法前人受教须臾闻法发生智慧后还得智慧果报。是故经云利根智慧。三者以口业劝人听微妙法生他正信正解。故得离口丑陋得端正果报。四者劝人听经是人善友世世常得见佛闻法信受教诲。何况一心下第四人。其福最胜报不可说也。偈十八行。颂前五人。即为五别。但不次第。初九行颂第一。次五行颂第四。所以超颂第四者以第四人与初人皆是广说功德故一处颂之。余三既是略说故一处颂之。又随喜是为他人说法人。第四劝他听法人并是为他。义意相成故一处颂也。次两行颂第二。次一行颂第三。此既是行诣及分坐令坐。义类相续故相次颂之。后一行颂第五。前第一释长行有三。今九行具颂。初一行半颂第一。最后人下六行半颂第二举二施格量。次一行颂第三举后况初也

    法师功德品第十九

所以有此品来者一者远从法师品生。法师品略明二世弟子两世法师。随喜品已广说二世弟子功德。今次广说两世法师功德。二者近从分别功德品末明三品人。一者下品谓随喜人。随喜品已广明其功德。今次广说余二品人。故有此品来也。三者上随喜品杂明世出世二种功德。如乘天宫及轮王坐处谓世间功德。随喜转教后得成佛出世功德。今品但明出世功德。以六根清净三界所无故称出世也。约位明者前是十信弟子位。今是三贤师位。约人者前品明五人。今品亦明五人。此品明弘法之师得六根清净功德以奖劝持经也。品开为二。第一总明五种法师得六千功德。第二别释对常精进者。一随缘所宜。二者此人持经已得根净果报故还对之。三者欲得净根必须精进。因名表义故对之也。六千功德者菩萨行善不出三业。身三口四意三。合为十善。一善为首余九庄严。是则十善互相庄严成百善也。自行百善。教他行百善。人赞叹百善。法赞叹百善。合为四百善。约五种法师皆具四百成二千善也。此二千善又有上中下品。故成六千也。有人言。菩萨行十善。一善亦以九善庄严故成十善。十善便成百善。自行百善。教他行百善。叹法为百叹人为百。合为四百。此之四百有上中下品。成千二百。三根持经用胜具得三品故有千二百。余三根持经用劣但得中下二品故有八百。有人言。就百福为论。此经云百福相庄严。药王品百福庄严臂。则知六根皆具百福。一一福各十善庄严成一千功德。一根一千则为六千。但三根于弘经事胜功德则多余三既劣故少也。明五种法师为因故得六千功德也。普贤观经明忏悔六根罪故得六根净。但忏悔有二法。初对十方生身佛就事中忏悔六根罪。故云从无始来六根所作三障今悉忏悔。次对法身佛依实相忏悔。观六根是因缘生本来寂灭。具此二忏悔故六根清净

问。作二忏悔故六根方净。云何此经云五种法师得六根清净

答。观身实相忏悔即是持于此经。故不相违也。是善男子下第二别开六根清净。一一中各有长行与偈父母所生眼者法华论云。凡夫人以经力故得胜根用未入初地。若入初地则舍三界分段身便不用父母所生眼也。龙树判二忍亦尔。柔顺忍中名为肉身。无生忍则是法身亦名法性生身。今经所说肉眼者是柔顺忍也

问。眼但应见色。云何言见业因缘果报

答。小乘人云肉眼但见色法也。天眼通因天眼为方便故发天眼智能知未来生死等事。法华论云。六根净者于一一根中具足六用。是故眼根亦知业行及果报也

问。六根云何得互用

答。悟六根即是实相。实相即是法身故六根无碍。所以得互用

问。根具功德既多少不同。云何同见三千

答。如灯虽大小同照一室也

问。何故但见三千不多见耶

答。智度论云。三千界外有风轮与眼相违故不能见

问。既能见三千。何故不名天眼

答。非修禅所得净色来入眼中。又非生彼天报得。故不名天眼

问。二乘天眼见三千与今何异

答。二乘但见三千国土。今依实相忏悔。及持经力得此眼见诸佛及踊出菩萨及宝塔。故与二乘异

问。普贤观云忏悔六根罪。今云持经。有何异耶

答。一乘即实相故持经即忏悔。忏悔即持经也。弥楼山者此云高山。又云光山。须弥山者此云安明山。亦云好高山。次释耳根长行为三。初总明五种法师为因。得千二百耳功德下第二明果。以是清净耳下第三别叹耳用。则是明功德也。有三句。初总明闻声。象声下别明闻声。以要言之下总结闻声。言而不坏耳根者欲闻即闻随意自在。故不坏也。又持经人悟法寂灭虽闻而无所闻。故称又坏也

问。耳云何胜眼得千二百耶

答。无眼之人不妨自行化他。生聋之人阙此二义故耳胜眼劣。次释鼻根。长行亦二。初明五种法师为因。次明功德果。果中亦三。谓总别结。别中为二。初明闻三界内香。及声闻香下闻三界外人香。初有二。初明闻欲界香。次闻色无色界香。欲界中有二。初闻人中香。次闻天香。人中三。初闻非众生香。次闻众生香。及草木下合闻二香。欲天中亦有众生非众生二香。色无色界亦有二香。寻文易知。上声乱闻。今不乱者互显故也。言遥闻香者

问。小乘有三说。一者婆沙云。三根合中知。谓鼻舌身。三根离中知。谓眼耳意。杂心云。二根离中知。意不当离合也。成论云。眼但离而不合。鼻舌身合而不离。耳根亦合亦离。闻外声为离。闻耳鸣声为合。意根非离非合。今何故言鼻遥闻耶

答。旧释云任根常用则如上三释。今依经力故鼻能遥闻。法华论云。一根具六用。而言鼻遥闻香者此是知境胜用。鼻根知故此意鼻根既具六用。岂不能遥闻香耶。盖是菩萨无六而六权智巧用。若六而无六即未曾用也。无六而六名实方便。六而无六为方便实。持经人既悟此经具足二慧故能尔也。普贤观意亦尔。知六即实相故知六常无六。悟实相即六根故无六而常六。故六不六无碍。此是悟有无无碍。又就有中六根自无碍能一根为六用。六根为一用。华严云。眼入三昧耳出正受观眼无生无自性。说空寂灭无所有即其证也

问。毗昙云上界无香味。今云何言闻梵世香

答。梵世有细香。小乘人力劣不能知故言无香。大士利根无尘不察故云闻梵香

问。成论言金银无香金刚无味。何偈云地中众伏藏闻香知所在

答。有人言。论云无者无有粗香。今言有者有细香也。有人言。此是着体物故有香。金银之质则无香也。例如风本无色观音品云假使黑风。随所吹处故得此名今亦尔也。今谓同上破毗昙义小乘根钝不知其天香。大士则知也。须曼那华此云好意华。阇提华香此云生亦云实。波罗罗华此云重(伫龙切)波利质多罗波利此云护。质多罗云种种。呴鞞陀罗此云大游戏地地破也。瞻卜华香此云黄华树。亦云金色华。舌功德中得二种果。一者得上味果。谓诸苦涩物至其舌根皆变成上味。此有二义。一如天恶食变成上味。如饿鬼好食反成不净。二者佛咽喉中有甘露泉和一切食皆成甘露。今持经人随分有之

问。舌能知味恶味未到舌皆变成上味者。耳能闻声听诸恶声。何不变成好声耶

答。皆互通也。耳既遍闻好恶声。舌亦精别一切味。但互叹耳。又余人不能远闻声。今叹持经力能远闻。余人不得上味。叹持经人力能得上味。又声不益身故不须变。味正资质体故须变也。食中具诸尘味。尘既变者坚触亦变成软。乃至赤色变为白饭。举一例诸。又味正益身所以论变。余不正益故不论变也。是人所在方面诸佛皆向其处说法者。此人既背惑向理故常见佛面。故如转面向之。若背理向惑则不见佛如佛背之。释身根中得净身果。类上鼻既遥闻香。身根亦遥觉触。但今不取此义。明余人心不净故身根不净。持经人心净故在身则净。如阿难形面如明镜老少色像皆现其中也。偈云唯独自明了者持经人独自明了。余人不持经故不见菩萨所见也。释意根中偏言如来灭后者举一类诸也。明意清净具得四辨。闻一句一偈谓法辨。通达无量义谓义辨。能演说一句一偈谓辞辨。而言一月四月一岁者一月者是十二中之初。四月是四时中之一。一岁是时终。略举初中后三时也。三千大千世界下第四知机。即是乐说辨也

    常不轻菩萨品第二十

所以有此品来者凡有七义。一者三品明三种功德。上二品明下中二功德竟。今次明上品功德。二者此经始末明宣持之人得三世功德。分别功德品初明十二种利益。闻经悟道现世功德。从分别功德品至法师品叹经能生未来众生功德。今此一品叹经能生过去世众生功德。此皆约佛在时作此分三世。经力虽多不出利益三世。三者近证法师品故来。上虽言持经之人得六根净未有其事。今引释迦本生亲自证验。证验者正证佛灭后持经人得六根净。以奖劝未来众生令持经也。四者上明六根净果。今叙六根净因。欲得根净当如常不轻菩萨一心忍诸打骂为物弘经。必于现身得根净也。五者欲说众生悉有佛性成一乘义故说此品。一切众生但有佛性无有余性。故唯有一乘无有余乘。旧云。法华经但明善人有佛性。涅槃经始辨有心皆得成佛。今明此品正辨恶人有佛性义。方便品明一毫之善皆成佛道。则知一切有心并有佛性皆成佛也

问。此众生是何等恶人

答。保执小乘拒逆大乘是谤方等人。又执小人不信大乘。于大乘无信是一阐提人。即是极恶人。有佛性义与涅槃经无异也。六者自上以来明授记义犹自未尽。上但明佛授记未明菩萨授记。则能授记人未尽。上但授善人记未授恶人记。则所授人未尽。上但现在授记未明佛灭后亦得授记。此则时节未尽。今欲明三种尽义故说此品。七者上来二品余经已广叹持经人之福劝物明修行。今次广叙谤法毁人之罪诫约未来勿造斯业。故说此品也。常不轻者一切众生常有佛性。故云诸法从本来常自寂灭相。大士得此观心故常不轻物从人标名也。品开为二。初长行次偈。长行为三。一者双标信毁二人。二引过去双证二事。三双叹。即叹法美人。第一双标为二。初明毁人得罪。告得大势者显此菩萨知法本来常寂灭相有正观势力。不为结惑所摧令弘经人亦学之也。又即是显常不轻得大忍力不为打骂所摧令持经人学其行也。如前说者指譬喻品末也。其所得功德下第二明持经人得福也。得大势下第二引过去事双证。就文为二。第一明缘由。第二正出常不轻事。缘由中又二。初明一佛出世。次明多佛出世。初有七句。一明时节也。有佛名威音王下第二化主。劫名离衰下第三出劫名。国名大城下第四出国名。其威音下第五明教门。因三菩提说六波罗蜜者。因者由也。由令众生得三菩提。是故如来说六度。得大势下第六明寿命。正法住世下第七明住持。正法像法灭尽之后下第二明多佛出世。最初威音王下第二正出常不轻事。又开二别。初明二人行因。次明二人得果。行因之中凡五双。第一明行因时节。谓正法已灭于像法中有信毁二人。所以偏据像法者欲劝像法众生持经亦得根净。又诫像法之人勿毁人谤法也。增上慢比丘下第二双标二人。初标恶人次标善人也。得大势下第三双明二人行因。前明善人行因。此菩萨用三业破病弘经。一者身业礼拜。二口业赞叹。所以身敬者以一切众生皆有佛性。是当来佛。今欲敬于当来佛故礼拜之。口叹亦尔。以皆有佛性当得成佛故叹当佛也。身口既有敬叹必经意地故具足三业弘法华经也。律云比丘不礼俗人。今云礼四众者大小乘法异。如涅槃云。有知法者若老若少皆应恭敬

问。于时何故行敬叹事弘一乘耶

答。不轻弘经凡有二种。一者密说。二者显说。行于敬叹即是密说一乘。后得根净具智慧神通显说一乘。所以前密后显者。末世之时增上慢人恶强善弱不可顿说。故初但得仿佛说之。仿佛之中但明作佛。谓显实义。未得被斥二乘故不开方便门也。深敬汝等者显众生有正因佛性也。而言深敬者既有佛性。即是当佛为敬之极。故云深也。又众生有佛性是甚深义。故言深敬。行菩萨道者明缘因佛性也。虽有佛性要须修行乃得见也。当得作佛者本有佛性。今复行因具缘正二因义故得成佛。然经云一切众生本来是佛。于缘谓非佛。如长者见穷子是己儿。而穷子自谓客作非长者儿。是故现佛于缘成当也。又此中未堪说众生本来是佛但得说当成。后显说中方得明诸法从本来常自寂灭相即是佛也。四众之中下第二辨恶人行因。须菩提不起他诤今生他嗔者亦是大小乘异。宜适时而劝也。如此经历多年下第四双重明二人行因。今前明善人行因前但行善因。今次明忍恶也。说是语时下明恶人行因也。避走远住下第五双重明行因。上明忍于口骂。今次忍身打掷也。以其常作是语故下结常不轻名。即显恶人行因义

问。常不轻弘经与法师品三事何异

答。常不轻具足三事。有慈悲心方能行于敬叹即是入如来室。忍于打骂谓着如来衣。深敬汝等即是了知诸法常寂灭相。谓坐如来座也。经历多年常行此事即是以不懈怠心为四众说法。又即是四安乐行。以知有佛性佛性即是第一义空谓空寂行。既行敬叹即无憍慢。能忍打骂宁有嫉心。经历多年忍苦弘道。则具大慈悲。故备四行也。是比丘临欲终时下第二明二人得果。前明善人得果。次明恶人得果。善人得果有二。善明得果。次结会古今。得八种果。一者闻法能持果。此中云二十千万亿偈者即是首卢偈也。即得如上眼根清净下第二得根净果。得是六根下第三明得延寿果。是大士体法无生灭。宁有心于存亡。但欲为物弘经故示有长命耳。于时增上慢下第四恶人信伏果。大神通力者谓身示现神通力。乐说辨力者口业说法。大善寂力者意得禅定。又教化下第五善人住道果。命终之后下第六舍身值佛果。放诸佛法中下第七得六根常净无所畏果。今谓常不轻得八果。约位有三。初得根净谓内凡三贤之果。二得根常净即得初地已上。得无生忍了悟一切法本来寂灭故根常净。三得佛地果。未得根净之前则十信位。而弘经故此人具五十二位贤圣也。得大势下第八明当得作佛果也。八果不出三报。初四是现报。次一是生报。后三是后报。得大势于汝意云何下第二结会古今。得大势彼时四众下第二明恶人得果。亦开为二。初正明得果。二结会古今。得果中有二。一得恶果。二得善果。前得恶果后得善果者由打骂常不轻故得于恶果。后信伏随从故得善果

问。经云。诸佛菩萨不为众生作烦恼因缘。云何礼拜赞叹生其恶因。后令其得苦果耶

答。有二种义。一者增上慢四众恶已成就必堕地狱。今礼拜赞叹为作出地狱因得佛之缘。非是生彼恶也。所以知尔者常不轻未礼之时已是增上慢。尔时已执小不信大是谤方等人也。二者如世良医治病有二。一者与美药即便病差。二与苦药初虽不悦后必安乐。诸佛亦尔。自有初说妙法。即便了悟自有初为说法增其谤心堕于地狱。后因此善必得解脱。若不为说无解脱期也

问。譬喻品云。谤法华人入阿鼻狱迳无数劫。今何故但千劫耶

答。四众若直尔起谤即如彼说。今闻不轻强为其说。虽谤毁籍此力故受苦则轻及后得信解

问。不轻为是实行为是权行

答。既寿量之迹。则知是权行也。毕是罪已下第二明得善果。得大势于汝意云何下第二结会古今。得大势当知下第三大段叹教劝修又二。先叹次劝。前叹教者由法华力故常不轻得二种益。一者毕其余罪谓灭恶力。二得六根净乃至成佛。谓生善力。所化四众亦得二益。一者由经力受苦轻微。二得出地狱乃至不退菩提也。是故诸菩萨下第二劝修。偈文不颂长行双标信毁。但颂双证及叹教劝修。即为二别。初十五行半颂第一双证。余四行颂第二叹教劝修。上双证有二。第一缘由。第二正明常不轻事。今具颂之。初一行半颂第一。是佛灭后颂第二。长行有二。一明行因。次辨得果。今具颂之。前四行颂二人行因。其罪毕已下十行颂得果。初五行颂善人得果。时四部众下五行颂恶人得果。开示教人令住涅槃者恒令识诸法从本来常寂灭相。名此为法华教得涅槃也。亿亿万劫下第二颂叹教劝修。两偈颂叹教。以众生种中道不二善根既少故。于其人为难闻佛亦难说也。二行颂劝修。以难闻得闻。难说已说。宜及时修行。勿生疑也

    如来神力品第二十一

赞叹流通门有二。一者三品余经正明叹法美人。二者明如来现神力。所以初叹法美人后现神力者。上既叹法美人。诸佛道眼见现在十方未来遐劫二世众生咸欲宣持。由此善根自致作佛。是故欢喜现大神力。二者上虽叹法美人以劝宣持义犹未尽。今更现神力重叹法美人奖劝弘经。故下文云。诸佛神力无量无边。以是神力于无量劫叹经功德犹不能尽。是故行者应须受持。三者显此神力从此经生。若欲得斯果报宜受持此经也。四接上品生者上品虽引过去证得六根清净。而时众取信未明故广现神力。五者此经始终凡有三会。初在灵鹫山秽土一会说乘权乘实。次三变八方同国土为净土。以明身权身实。三从神力品十方世界通达无碍。同为一土令十方众生皆闻法华。此三会处从狭至广。徒众亦从少至多也。品开为二。第一诸菩萨闻上叹法美人发誓弘经。第二佛见菩萨发誓弘经心生欢喜故现大神力。诸菩萨踊出凡有二意。一为开发寿量则善其始也。二发誓流通令善其终也。真净大法者对二乘之伪故称为真。累无不尽所以称净。德无不备。目之为大。尔时世尊下第二现神力。初长行次偈。长行为二初现神力。二叹法劝修。现神力又二。第一明现神力。第二明时众睹见得益。初文又二。第一明于大众前。第二正明现大神力。所以于众前者欲利益大众故。二欲叹佛自在神力无所畏故。第二正明现神力。中凡现五种神力。一现舌相表说二权二实无有虚妄。法华论云。出广长舌者令忆念故。即是令忆念佛所说不虚。二放光者显此经能灭惑生解如光除暗显物。又欲令彼此相见

问。前二处但放一光。今何故放一切毛孔光遍照十方耶

答。上二处为表唯有一乘及法身无二故但放一光。今欲流通此经令二世众生皆得信持故放一切光也。次分身佛亦现二瑞者欲显同一法身皆是应迹故同现二瑞。又众见多佛现于神力则信敬益深。一佛或可所言不实十方诸佛何容欺诳。故同现舌相也。满百千岁者神力一时未足希有。满百千岁方是奇特。又是显法久住故神力时长

问。何故摄于舌相而不收光

答。表说法事竟故摄舌相。欲令十方通彻彼此相见故不收光。涅槃经表所作已辨故收光也。一时謦咳俱共弹指者。旧云謦咳表说二权二实畅悦佛心。法华论云。现謦咳声说偈令闻故。闻已如实修行不放逸故。弹指者表觉悟众生令修行者得觉悟故。动地者亦令众生觉悟知佛说法。又示无常相令速修此法。又表现在十方众生遥闻此会说法华经。随喜供养藉此善根后当成佛。是故地动依法华论意。舌相謦咳属口业瑞。放光弹指属身业瑞。动地谓意业瑞。而经文次第者初二是色瑞。次两是声瑞。此四是谓正果瑞。动地是依果瑞。五瑞次第者舌为说教之主。故初现之。说教必有灭惑生解之用。并令十方通洞彼此相见。故次放光。既彼此相见故謦咳令闻令闻为令觉悟。是故弹指。此四是现正果瑞竟。次动地现依果瑞也。其中众生第二十方众生睹瑞。前二处瑞多利益此会。今现五种神力多为益十方故明十方睹见。又开四别。初明睹见欢喜。即时诸天下第二诸天唱告劝随喜供养。彼诸众生下第三明十方顺从。所散诸物下第四佛重现二种神力。一成宝帐表成法身不二。即后分经。通达无碍如一佛土者同显所乘不别。谓初分经。为表十方同悟斯二。尔时佛告下第二叹法劝修。初叹法次劝修。叹法之中略明四句。如来一切所有之法者即初分经乘权乘实法也。如来一切自在神力者第二后分经身权身实。短长适化谓自在神力也。如来一切秘要之藏者此二摄义无不周。故称为要。昔所未说故名为秘。如来一切甚深之事者授五乘人成佛之记为甚深事也。此四句即是次第。又摄一部义周也。又初句明一乘因果之法。次句一部所现神通。第三句因果神通昔所未说故名秘要。第四句不异前释。是故汝等下第二奖劝也。偈文为二。初颂现神通意。次颂劝修。现神通力为三。初偈明为益现在十方众生故现神力。次两偈正颂现神力。第三一偈为利未来众生故现神力。嘱累是经故下第二颂奖劝。又开二别。第一称叹。第二劝持。初称叹凡有七门。初两偈颂功德无边叹。次一偈半得见诸佛叹。次两偈诸佛欢喜叹。次一偈不久得佛叹。次一偈半得四无碍叹。次一偈得经旨趣门叹。次一偈半灭惑生解叹。持法华经人得此七种果。第二劝持如文

    嘱累品第二十二

自上已来明称叹流通。今次辨付属流通

问。小乘辨佛永入无余不复化物可须付嘱。此经明法身常存有感斯应。何故明付嘱耶

答。有三因缘。一者时众闻佛殷勤付嘱则重法情深各欲宣持。二付诸菩萨即令其自行化他。三者众生于菩萨有重缘故令其弘法化物。亦开二别。一者此品正明付嘱。第二药王已下奉命宣通。所言嘱累者。嘱谓付嘱。累谓凭累。但嘱累有二。一以法付人。谓以大乘妙法付诸菩萨。二以人付人。以二世众生付嘱四依菩萨。如金刚波若论以根未熟菩萨付嘱根熟菩萨。今具此二也。智度论云。波若非秘密法付嘱声闻。法华是秘密法付嘱菩萨。论自释云。波若未明罗汉作佛。但明菩萨作佛其言易解。故声闻能通宜付嘱声闻。法华明阿罗汉成佛于昔教为甚深。声闻未解故付嘱菩萨。品开为三。初佛付嘱。二菩萨受付。三明说经事竟。三文各二。初文二者第一摩顶付属。而言现大神力者。有人言。即是前品七种神力。今谓不尔。释迦以数尺之手一时遍摩千世界尘数菩萨顶。神力之大亦莫其如斯也。而作是言者前现大神力谓意业付嘱。以手摩顶谓身业付嘱。今明口业也。难得菩提者叹菩提难得欲令物尊重法也。此经明二权二实。今总言菩提者即一正观。正观纵任自在。故名为乘。即初分经。能长短适化名为寿量。谓后分经也。今总言菩提即摄二分。所以者何下第二释嘱累意。即是示宣通之方。宣通之方凡有三种。一者令上学诸佛。二者令下知根性。三者具此二义法无不弘人无不益。为报佛恩。如来内有三德。一有大慈悲常欲拔苦与乐。二无诸悭吝不藏惜法宝。此二即是佛功德业也。亦无所畏者第三句明智慧业。内具此三德外与众生三种智慧。佛之智慧照有慧也。如来智慧照空慧也。自然智慧空有二种任运能知。即无功用慧也。此之三慧摄慧义尽。此经虽明二权二实意在摄入佛慧。故偏说之。汝等亦应随学者上明内有三德外与三慧。今劝菩萨学之。勿生悭吝者悭有五种。一住处悭。二家悭。三施悭。四称叹悭。五法悭。法悭有七过。一世世常盲。二生生愚痴。三常在怨家中生。四失圣胎。五三世佛怨。六善人远离。七无恶不造。有此重过故偏诫之。于未来世下第二劝下知根性。凡有二句。一者明有大心人宜授以实说。二者若有众生不信一乘当为说三乘教。汝等若能下第三若能上学佛二德。下知两机则通法利人谓报佛恩也

问。文云。若有众生不信受者即于如来余深妙法中为说。然小乘三藏非是深妙。大法即是大乘。云何别有余深妙耶

答。方等有二。一者大乘二者一乘。余法即是大乘

问。何故信大乘不信一乘耶

答。有二种人信大乘不信一乘。一者是小乘信大品等。以大品等虽是大乘未废小乘故小乘信大乘自是菩萨法。信小乘是声闻法。二者新学菩萨亦信大品云。大品明菩萨法为说大品等是我等所行。非二乘所行也

问。小乘人既不信一乘。何故信大品等大乘

答。大品等密令舍小密令信大。如前信解品中密大乘有自他两教也。亦为新学菩萨说大品令密信一密舍三也。时诸菩萨下第二菩萨受付。亦开两别。第一一称受付。诸菩萨下第二三过顺旨。一一文中皆具三业受付。初内心欢喜。二身业恭敬。三口业顺从。尔时释迦下第三明说经事毕亦开二别。一释迦令诸佛各还所在。二大众欣庆

问。何故令分身各还本土多宝独称还可如故耶

答。一多之疑易断故令分身散席。常灭之惑难破故多宝独停。如故者直令闭塔未遣还土也。次大众欢喜如文

问。何故欢喜

答。从经初至嘱累品明佛所乘法能乘人究竟故大众欢喜。下药王品乃明菩萨所乘法能乘之人故嘱累品在中间也

    药王菩萨本事品第二十三

自下第二诸菩萨奉命宣通故有药王品等来也。一者上来说法华经。今说行法华经人所得果报以劝宣持也。二者智度论云。波若有二门。一者说法为波若。二者明来生往生诸菩萨等行波若人亦为说于波若。法华亦尔。上来说法为法华。今明诸菩萨德行亦是说于法华。故法华有无量门令物悟入也。三者十二门论释大乘义。凡有二种。一者诸佛大人之所乘故名为大。二者弥勒文殊等诸大士之所乘故名为大。具此二门乘义乃备。此经明一乘亦尔。一者诸佛所乘。二菩萨所乘。自从经初至神力品明佛所乘之法及能乘之人。此一章竟。是故付嘱。从此已后明菩萨所乘之法及能乘人。但上开所乘之法及能乘人以为二段。今合明所乘法能乘人。开合不同者为转势说法故也。四者众生根性结缘不同。上来化与释迦结缘众生。斯事已竟。今化与诸菩萨结缘众生。故品品之中皆有悟道其证也。五者净名经云。或以诸佛而作佛事。或以菩萨而作佛事。上来明诸佛作佛事竟。此次明菩萨作佛事。六者明善知识凡有二种。一者诸佛是众生真善知识。是故普集分身及过去多宝。今次明菩萨为众生善知识故广说菩萨也。如华严说经竟至流通分法界品中。广明诸菩萨是善财真善知识。法华即是华严。故说法华竟。流通分中亦明无量菩萨宣通一乘是众生真善知识也。依法华论合此六品以为四章。初之二品明苦行力弘经。谓药王以身命财报恩供养。弘经利人教化众生。妙音菩萨分形六趣弘宣一乘谓苦行力也。第二观音陀罗尼二品明护难力弘经。观音以人护难。陀罗尼以法护难名护难力弘经。第三妙庄严王品示现功德胜力。谓净藏净眼有胜功德能令父王回邪入正。即是众生真善知识。谓胜功德力。第四普贤品亦名护法力。谓普贤以大神力宣通此经令无留难。亦名护法力。四门次第者。苦行力谓报恩供养宣通此经。即上弘大法也。但受化之徒多诸留难。宜须救之。方可受道即是下济。故有第二门也。所以下济者良由有胜功德。故举胜功德力释成下济。所以能上弘者必须护法。故举护法释成上弘。宣通之意唯此四门也。此品四章。一宿王华问。二佛答。三时众得益。四多宝称叹。问中又三。一总问。二偏问苦行。三请答。文处易知。佛答为二。一说药王本因缘。二者叹教人。人谓行法之人。法谓成人之法。即是叹人美法一双。就初又二。一明缘由。二正说药王本事。缘由中五事。一时节有佛号日月下明化主。其佛有八十下辨徒众。佛寿四万下明寿命。彼国无有下明国土。国土中前明无秽。地平如掌辨有净也。一箭道者二里也。尔时彼佛下第二正明药王本事又开四别。一明说经。是一切众生下第二明悟解。得此三昧下第三报恩供养。佛告宿王华下第四结会古今。就第三中又开二别。第一明现世报恩供养。第二明转身报恩供养。良以得恩深重故须累世报之。初文又二。第一明外财供养。从三昧起下第二辨内身供养。兜楼波毕力迦者。罗什云。出龙神国此土所无故不翻也(有人翻毕力迦为粗池也)。一切众生喜见下第二明转身供养。又开为二。初明佛在世时供养。二明佛灭后供养。初文二。一明前为父说于佛所得二种恩以化父。二明欲往佛所报恩供养。得恩中又二。初一偈半明闻法利益恩。说是偈已第二明供养得利益恩。甄迦罗频婆罗阿閦婆等偈者。有人言。初是四言偈。次是五言偈。后是七言。今明不尔。此文有二数。一者八百千万亿盖是此土之数。从百转增至亿。自那由他已上皆是外国数名。即从亿转增故有那由他等。不应如前释也。而初八者总贯于百乃至阿閦婆等也。如三僧祇之类。注经云。盖是外国数名。如此土垓兆之类也。甄迦罗(正法华。云何作)频婆罗(正法华。云模式)阿閦婆(正法华。云不动)大王我今下第二明供养又开二别。一明佛在世供养。即偈文是也。至此文以来备三业供养。前明入三昧雨华香等谓意业供养。次从定起烧身谓身业供养也。今说偈明口业供养。又合此三业以为二双。意业供养谓外财供养。烧身为内身供养。此二谓供养门也。今亦有二。一者恭敬。二者赞叹。此四并是报恩之事也。尔时一切下第二明佛灭后供养又开三别。第一喜见发问开涅槃之端尔时日月第二如来灭度。涅槃时到者谓安住三德为入涅槃也。灭尽时至者舍应归真也。尔时一切众生下第三正明供养又开二别。初明外财供养。尔时一切众生复自念言明内身供养又开五别。一者正明烧臂。令无数下第二时众得益。尔时诸菩萨下第三时众悲感。于时一切下第四明菩萨发誓身返平复。当尔之时第五感诸瑞相。佛告宿王华下第四结会古今。兼劝人烧指供养

问。依毗尼结戒烧身得偷兰遮。烧臂得突吉罗。此菩萨将不犯罪耶

答。此或可在家菩萨。不预犯戒之例。设令出家适时而化。如身子与须达共载一车而不犯罪也

问。地持论有十种供养。药王品具几耶

答。十种供养者一身供养。二支提。三现前。四不现前。五自作。六他作。七财物。八胜心。九无染。十至处道。初二约所供养差别。于佛身供养名身供养。供养佛灵塔庙名支提供养。依僧祇律有舍利名塔婆。无舍利名支提地持云。莫问有无皆名支提。明了论云。支提此云净处也。次两约时处分为二。随事分三。现前供养者面。对佛身及支提供养也。不现前供养者于不现前佛及支提广设供养也。此约时处分二。随事分三者余二如前。第三亦现前不现前供养。现前供养佛及支提。及不现前供养佛及支提。此三供养得三品功德。现前供养得大功德。不现前供养得大大功德。以境界广故。亦现前不现前供养得最大大功德也。次二能供养人分别为二。随事分三。一自作供养。谓自身供养佛及支提。二他作供养有少财不敢懈怠教他施作供养。三自他共供养。彼此同为也。自作供养得大功德。教他作得大大功德。自他共供养得最大大功德。次两一对。心事分别。以己财事而为供养。名财供养有三。一资具。谓衣食等。二敬具供养。谓华香等。三庄严具谓一切宝物等。次以殊胜心供养名胜供养。胜心为三。一专精解心善解施设种种供养。二纯净心信佛德重而设供养。三回向心求佛心中而设供养。后二供养就行分别。行离过失名无染供养。无染有二。一心无染离一切过。二财无染离非法财也。供养之行顺果名至处道供养。佛果是其所至之处。供养之行能至彼处名至处道。维摩经名法供养。地持论名行供养。于此中有三。一财供养为至处道。二随喜供养为至处道。三修行供养为至处道。于佛既十。法僧略同也。精捡药王具足十供养也。若复有人下第二段次明叹教又开二别。初总叹一部经。二别叹一品。总叹一经又四。一格量叹。二就教叹。三灭恶叹。四生善叹。譬如下第二叹教凡举十譬。始自山海终至诸佛自下之上。十譬不同亦得合为五双。初山海。二日月。三天人。四凡圣。五佛菩萨。此经能救下第三约人就灭恶门叹。若人得闻下第四生善叹也。若有人闻下第二别叹一品又分为四。初总叹得无量功德。若有女人下第二别约生报叹

问。闻此品不受女人者闻余品亦应受耶

答。闻品品皆不受。但约事相似故寄此品言之。以女人多爱着己身种种严饰。今明菩萨舍身舍臂破彼着情故不生染着。故舍女身也。若有人下第三明得现报。是故宿王华下第四付嘱。兼明闻经成佛即是后报叹。言病则消灭不老不死者。有人言。闻法华经要至老死无中夭而死也。今依智度论云。不断百八烦恼名之为病。得闻经已断此烦恼故云消灭。不老者不起六十二见名为不老。不死者不失智慧命故云不死。又堕二乘地名之为死。不堕二乘故云不死。又闻此经知老病死等本来寂灭。故云不老死也。说是药王下第三明说品利益。多宝如来下第四多宝称叹。前虽闭塔而犹称叹。则不灭义彰

法华义疏卷第十一

时永仁乙未仲夏下旬自南洛阳东大寺蒙三论宗学□中之宏恩雕义疏第十一卷之印本俯乞寺门基固五十六亿之霞轩无颂佛日光辉二千余岁之风流不变而已

            都干缘沙门　素庆谨志法华义疏卷第十二

        胡吉藏撰

    妙音菩萨品第二十四

苦行弘经有二品。今是第二。上明闻经得益以身命财报恩供养。今明分形六道宣通一乘。前则是功德业。今明智慧业。前多是自行。今多是明外化行。又上明过去本事弘道利物。今说大士现德通法益缘。又此下诸品多是根缘次第。不必须依义生起也。言妙音者此菩萨过去以十万种伎乐供养于佛故得美妙音声。因以立名。旧经称师子吼菩萨。今可得两音会之。即以妙音作师子吼。又众生乐闻称为妙音。音能显理伏物名师子吼也。此品六章。第一佛放光召彼妙音。第二妙音奉命而至。第三正明妙音弘经模轨。第四说品利益。第五妙音事毕还归本土。第六重明往来之利。就初又三。第一明佛放光遍照有缘。第二遍照净光国土。第三的照妙音之身。放光为二。前放肉髻光。次放眉间光也。所以放二光者一乘妙理踰空有之顶故放肉髻光明。极智不偏能发中道之照故又放眉间光也。又顶光表一乘为尊众圣所重。眉间光明一乘不偏中道圆正。欲以此法付嘱其人故放此二光以召之也。又上品云法华第一持经之人亦复第一。今表其人行高故佛放顶光。表其人解正故放眉间光。所以放二光表其人者欲令大众于此菩萨深起敬心受其道法得益也。过是数已下第二别照净光土也。尔时一切下第三的照妙音身也。又开三别。一列名。久已殖众德本下第二叹德。良由有此胜德故为佛光所召。叹德有二。前叹往因。二叹现德。各开二章。往因二者一殖众德本。二供养诸佛。现德二者一成就甚深智慧。二得诸三昧。三昧中有二。一者别明。二者总结。得妙幢相三昧者入是三昧于诸三昧中最为尊长。譬如军将得憧表其大相也。法华三昧者法华三昧经云。如树华开敷令树严丽。得此三昧诸三昧中开诸功德华以自庄严。依此经意释者于三一自在长短无碍道法华三昧也。净德三昧者令诸三昧清净。如焚石练金令金清净。无缘三昧者即灭尽定。又得此三昧于三受中不起三毒缘。宿王戏三昧者于诸三昧观达自在故名戏非爱结戏。智印三昧者般若是智。相应三昧是印也。又如人入安稳国有印得入无印不得入。菩萨得是三昧能入实相。解一切语言三昧者得是三昧解众生语而为说法。集一切功德三昧者得是三昧菩萨功德皆悉具足也。清净三昧者如有如意宝珠能净诸宝。是三昧能净诸三昧垢。烦恼垢易治三昧垢难断。神通游戏三昧者入是三昧能八相成道。慧炬三昧者如执炬夜行不堕险处。庄严王三昧者如恒沙等国土皆以七宝庄严佛处其中。得是三昧一时能庄严诸功德。又观此庄严空无所有于空有二庄严得自在故名为王。净光明王三昧者入是三昧能放光明令诸众生心得清净。净藏三昧者入是三昧能净诸功德藏。不共三昧者二乘无分。日旋三昧者如日天子乘日宫殿照诸众生周而复始。旧经名日轮三昧也。得如是下第二总结。释迦牟尼下第三的明光照其身。即白净花宿王智下第二明妙音奉命而来。又开二别。初明欲来之意。第二正辨从彼国来。初有十句。第一明妙音咨彼佛欲来之意。尔时净花宿王下第二彼佛诫许。又开三句初总诫。善男子下释诫。释诫中前明娑婆之劣。而汝身下辨净土之胜也。是故汝往下第三总结

问。前云初分经在秽土中说。后分经居净土中说。妙音来时正游净土。何故诫之

答。此经始末土有三异。一者初分经在秽土中说。二者后分经在净土中说。三从药王品来还在秽土中说。所以知尔者为集分身是故变净土。分身已散故土还复秽。妙音来时正游五浊故佛诫之。妙音菩萨白佛言下第三明妙音受旨。明妙音既承佛力为弘道利人故来岂生劣想也。故受佛诫敕。于是妙音下第四将欲发来先现瑞。于此土所以现瑞者令此土众生起尊敬心也。化作莲华者一即欲以莲华为座。二表妙音弘妙法莲华。化作八万四千者一欲拟八万四千菩萨座故。二表八万四千法藏皆入一乘妙法华故。白银为叶者即是显此经题是白莲华。开二实二权则八万四千法藏义皆明白也。甄叔迦宝者(此云鹦鹉此宝似鹦鹉鸟嘴而赤色)尔时文殊下第五文殊问瑞所由也。尔时释迦下第六佛答现瑞意。文殊下第七文殊重问妙音之德。凡有三问。一请初问种何善本。二问修何功德。此二问过去往因。三问行何三昧。此问现在所得之果。唯愿世尊下第四请佛欲见妙音。尔时释迦下第八释迦推于多宝令见妙音。但詶其后请未答前三问。下华德菩萨重牒三问佛方解释。所以推多宝者盖是随俗之事。俗人之礼推贤让长。多宝既久已成佛。故释迦让之。二者欲显多宝不灭故能现妙音。故推之也。时多宝佛下第九多宝命令来即詶文殊请。于时妙音下第十正明妙音来。又开十章。一明于彼国没。与八万四千下第二明与眷属俱共发来。所迳诸国下第三明现瑞相。是菩萨下第四赞叹妙音。那罗延者(真谛云。那罗翻为人。延云生本。梵王是众生之祖父故云生本。罗什云。天力士名那罗延。端正猛犍也。俱舍论云。持大千世界风轮名那罗延。那罗延应云天力也。)入七宝台下第五叙妙音升空而至。多罗树似此土宗卢树。一多罗去地七刃也。到已下第六明见佛仪则。而白佛言下第七奉宣圣旨。又开三别。初问释迦。众生易度下第二问所度众生。久灭下第三问讯多宝。世尊下第八妙音请见多宝。尔时释迦下第九释迦语于多宝。于时多宝下第十多宝赞叹妙音。从问讯多宝至多宝称叹皆是显多宝不灭斥凡夫二乘无常之执。尔时华德下第三论妙音弘经。前章则是弘经之人竟也。即人法一双。又上明妙音之果。今出其往因。谓因果一双也。即是显妙音二世之德。又开二别。初一问答论妙音神力。第二问答论妙音三昧。神力是智慧三昧。是定。略论菩萨定慧也。又神力是果。三昧是因。由三昧之因故能现神力。所以前论果后论因者由妙音现神力而来故前问也。寻华德两问皆是牒文殊上三问。以释迦上未答之故今重牒而问。初问又二。前问神力之因。有是神力正问神力之果。善根与功德异者善根就始功德为终。故分为二问。就答中又开为二别。第一答因问。第二答神力果问。答因问为二。初答种何善根问。又开六别。一明种善根之佛。国名下种善根之处。劫名下种善根之时。妙音下正种善根。以是因缘下明善根得果结詶其问。华德下结会古今。华德是妙音下第二答其修何功德问。华德汝但见下第二广答神力果问。又开二别。第一叹妙音于此土弘经。第二叹妙音十方通法。二文各三。初文三者一总标。二广释第三结叹。或现梵王身下第二广释开为五类。一现天身。二现人身。三现八部身四救济八难。五于后宫变为女身。现天身中二对。梵王帝释欲色之初。自在大自在二界之后。此四名君。后一双为臣。天大将军是梵辅天。梵王之臣。毗沙门帝释之臣。现人身中亦开二对。初一双谓人君身。或现长者下明人臣身。又为四类。初四是豪杰身。次四受佛戒身。次四现妇女身。后二现童真身后八部身。如文。诸有地狱下第四叹救八难。不言说法者一者苦重二者障深故但明救济。乃至于王下第五类。是妙音下第三总结称叹。又开二别。初叹所化有益。是妙音下次叹于能化无损。是菩萨下第二叹妙音于十方弘经。亦开三别。一总叹。二别叹。三结叹。三门各二。初门二者前结一土益物。十方下次叹十方弘经。若应以声闻形下第二别叹。又开为二别。初现存身。次现亡身。文处易知。华德下第三总结。神通结现身。智慧结说法。上一土中广现凡夫身。十方化中略现圣身。此欲明凡圣广略互现也又前凡身中有五类。今圣身中亦有五身

问。前凡中五类何故云说法华。今但称说法

答。说法语通。欲以通别互现故也。又上正明弘通法华故明说一乘。若有众生不信一乘则说五乘之法。同上嘱累品中佛令菩萨知大小机也。此品从凡至圣故先示凡后示圣。观音前圣后凡从胜至劣。又妙音前一后三。观音前三后一。尔时华德下第二问答论妙音所得三昧。亦前问后答。说是妙音下品中第四段明彼此蒙益。尔时妙音下品第五章明所作已竟还归本土。此为秽国故彼佛有问讯。彼为净土故此佛无暄凉也。说是妙音下品第六明利益

问。见菩萨来往何以得无生忍也

答。利根之人悟菩萨不来相来故来无所来。不去相去故去无所去则入实相。故得无生

问。无生法忍普现色身法华三昧有何异耶

答。心无所依犹如虚空。不生心动念故名无生法忍。虽空而有。纵任自在处处现身。即是普现色身三昧。三一开会无所染着即法华三昧也

    观世音菩萨普门品第二十五

上二品明苦行弘经有功德智慧二业。故有药王妙音两品。今第二次明护难弘经。初明人护难弘经。次明法护难弘经亦有二品。又根缘次第者。灵山之会八万四千人应闻观音得发菩提心故说此品。二者十方国土及来世有缘众生应蒙利益故说此品。开此品章段不同。今一往分为四双。一者双标。二者双释。三者双叹。四者双益。言双标者观音为名普门为德。故双标名德。夫胜人为理有名有德。是故双标以名观音普门品。言双释者初一问答释观世音名次一问答释观音德。言双叹者持地菩萨叹闻此名德功德无边。言双益者八万四千人闻此名德并发道心也。此四次第者为解义故。初略后广。故前略标次则广释。标释既竟名德显彰故菩萨称叹。叹释既竟听者欣仰。故减发道心。初双标中凡有十对。一者人法一双。观音为人。普门为法。然人法是因缘之义。非人无以御法。非法无以成人。故前明御法之人。后辨成人之法。谓人法一双也。二者真应一双。观世音即是法身。普门谓应身也。前以法身观机然后垂迹普应。谓真应一双。三者观音谓菩萨意业。普门即身口二业。前以意业观察然后身现神通。口业说法。谓内外一双也。四者观音谓大悲拔苦。普门即大慈与乐。故后释观音名明拔苦之义。释于普门即显与乐之功。所化众生但有苦无乐。能化菩萨有大慈大悲。谓慈悲一双。五者菩萨有二种身。一者药树王身。二如意珠王身。药树王身者根茎枝叶能愈众病。菩萨亦尔。故三业皆能济物。如意珠王身者如摩尼宝能与一切乐。菩萨亦尔。其见闻者无不蒙益。释观世音名叹药树王身。释普门名明如意珠王身。故珠药二王为一双也。六者释观音名显众生感义。标于普门明菩萨应义。初感非无应。后应非无感。但初举应以成感。后则标感以成应。谓感应一双也。七者标观音名叹菩萨能与众生世间之乐。标于普门显菩萨能与众生出世间之乐。故前文明七难消除二求愿满。即知是世间乐。后三十三身十九说法皆称得度。故知与出世乐。此皆大判为言。非别相说。前与世乐后与出世乐。此是次第法门。谓世出世一双也。八者标观音明神通。以察物音声即天耳通题普门谓示现。六通之中三是神通非示现。谓天耳天眼宿命也。三是神通亦是示现。谓他心神足漏尽。漏尽说法。神足转变。他心知机。即以事令人信验故名示现。谓神通示现一双也。九者标观音名谓明密利益。标普门明显利益。后现身说法故称为显。前不显身说法而能令物免难故称密益。菩萨济物不出显密二义。谓显密一双也。十者标观音明菩萨名。题普门显大士德。谓名德一双也。然此品内义虽具十双今以名德为正。如大品亦以二门说于波若。一者就菩萨字义门说波若。二者就菩萨所行门说波若。以菩萨字义门说波若者解释菩萨摩诃萨字。此字有无量义。故即是说波若。次明菩萨所乘叹释大乘。即是说波若也。今亦尔。叹释观音字义即是说法华。叹释观音德亦是说法华

问。此与波若何异

答。波若释通字义通所行。菩萨摩诃萨是通字义故释通名也。此经释观音字义故是释别名也。波若通释诸菩萨所乘。此经别释观音三密之德。又波若通释自行化他。今但释化他门。又波若具就二慧门释。今但就方便门释也。所言观音者外国名阿梨耶婆楼吉氐税。此翻观世音。菩萨有多种名。今依此品佛答中略辨三名。一观世音。二观世意。三观世身。圣人无名为物立称者欲生众生三业善也。立观世音名令物称名生口业善。立观世意名令物存念生意业善。立观世身名令物礼拜恭敬生身业善。以备生三业善故立此三名

问。既具三名。何但称观世音

答。三名不可具题。趣标其一。二者观世意名但生意业善。观世身名生身意二业善。生善义局故不标之。若口称名必备三业。以生善多故立观音名也。三者意业存念身业礼拜但得自行不得化他故不立身意二名。口称观音具得自行化他故立观音名也。四者娑婆国土以音声为佛事。义既显彰故立观音之名。余义不尔故不题余称。五者观音之名有行愿。过去世时值空王观世音佛发愿名观世音故依愿立名。又观音昔在此土行菩萨道以受观音之称。余二名阙斯二义故不题也。别有经云观世自在菩萨。此名备含三业。于名义最胜。复有经云光世音菩萨。或可是翻之不正。华严经云。此菩萨住大慈法门光明之行。从此立名云光世音也。又此菩萨住普门光明三昧。从所住法门为名。下复云。施无畏者此名总含。从功用受称。所言观世音者。观是能观之智。世音是所观之境。境智合题名观世音也。观具三观。境备三境。境备三境者众生发声因咽喉舌齿和合有声。谓因缘声。名为世谛。因缘所生法即是寂灭性称为真谛。亦为是假名。亦是中道义。即是非俗非真中道第一义谛。故此一音声具足三谛。菩萨观此三谛。即三种观也。二者观是菩萨之应。世音是众生口业之感。感应具题故立观世音也

问。云何名世音耶

答。三种世间中正是众生世间也。外书云。以声成文谓之为音。佛法不分音与声异如杂心云。声有三种。一因受四大声。谓众生音声。二因不受四大声。谓非众生声三因俱声。如人与外物合共出声。谓打钟等。三种声中可通余二也。所言普门者普以周普为义。门是开通无滞之名。又门是法门。如华严云。观音住大慈法门。又能通道令物悟入故称为门。普义有三。一他心普。谓不虑而知照穷法界。二神通普。谓不动而应十方现前。三说法普。无言可陈而声教弥八极也。尔时无尽意下第二明双释。初一问答释观音名。次一问答释观音德。又初问答为二。初问有三。一能问之人。二问之仪则。三正问。后答亦三。能问之人即是意业。问之仪则所谓身业。正发问即是口业。三章合有十句。尔时者问时节也。以众中八万四千人应得发心。是故应时而问。无尽意者第二能问之人。有二句。一别名二通号。外国称阿差末。此云无尽意。大集经云。初发心时已不可尽。况复智慧神通慈悲说法而可尽耶。正意而言众生无尽故大悲无穷也。故言无尽意菩萨者第二通号也。大集经云。其人是东方不眴世界普贤如来一生补处大士。若论其本乃是十方诸佛师。所化之人皆已成佛。即从坐起第二问之仪则。凡有三句。初明从座而起。孝经云。曾子避席礼云。请益则起。次偏袒右肩者外书云。劳而无袒。内教请道袒肩者风俗不同。其犹彼国露顶为礼。此土冠帽为恭敬也。次合掌向佛者袒肩用显形恭合掌以表心一。如掌本在异处今合而为一。心本他缘今敛而不散。心既冥漠难睹。故假外事以显内心。而作是言下第三正发问也。凡有四句。初经家叙其口业。世尊下第二正发言问。问有三种句。初句仰举尊号。即表能答之德。非是世尊不能释补处之疑。将欲申疑故显质疑之主。观世音下第二出所疑之人。以何因缘第三正明疑也。因谓因由。缘是缘藉。以何因缘受此名耶。名有二种。一有因缘。二无因缘。如身子因母目连因姓此有因缘。低罗婆夷实不食油强名食油。此无因缘。今未知。为有因立目无因立名是故问也。有因立名略有四种。一从趣立名。如生天趣故名为天。二从相立名。如身有异相因以立名。三从过立名。如盗贼等。四从德立称如诸贤圣今未知以何因缘有此名也

问。无尽意何因缘故问观世音菩萨名耶

答。菩萨三业皆为利缘。以众中八万四千人应闻名得益是故问也。二者欲为未来苦恼众生闻名脱苦是故致问。三欲显观音德。即是说法华经。观音即是能乘之人。三轮之德谓所乘之法。问于名德具能乘所乘。是故说一乘也。四为憍慢之徒自举陵他今欲显无尽意不自尊高。故问他德行。又嫉妒众生隐他之德扬他之过。菩萨之法隐他之过扬他之德。令一切众生仿而学之是故问也。又示有疑未了一切菩萨皆观世间音声。今以何因缘独受斯称。又三世诸佛发言有二。一者自开。如前从三昧起无问自说。二者因他。要待无尽意问后方说也。佛答有四。一释其名。二劝持名。三格量持名功德。四总结称叹。以问名故前须释名。释名广有利益故劝持名。一人名福等多菩萨名故格量之来成劝持义。初又三别。一释观世音名。二释观世意名。三释观世身名。一一中皆先释后结叹。即三释三叹也。无尽意但问一名。佛答多者问略答广。如上释之。又具释三名者欲显所观境周能照观足。境不出三业故唯观三业。故立三名也。所观之境具有三业。菩萨能观唯意业也。又立三名自有众生称名得度。自有众生口不能言但能心念。自有众生口不能言心又散动但身能礼拜。又众生忌讳不同故须立多名。就释观世音名中又开为二。一者略答。二者广答。初略后广为解义故。又前名总答。后名别答。前总答即名遍拔三界六道众生之苦。后别答中但拔欲界。于欲界中多拔人中苦。于人中多拔阎浮苦。余方不必有王贼等难。前总后别欲显感应义周。故开为二也。善男子者华严经称为佛子。余经多云善男子。有绍继义故名为子。纲干之能故称为男。所行有利他符理清升感乐之义目之为善。若有无量下正答其问。凡有四句。束为两双。一者众生受苦。此是感缘。即是称名之意。二者称名正是感体。三菩萨观机。四皆得解脱。即辨应义。束为两双者前两为感。后二为应。应感为一双也。又前两为感。即是世音。后二为应。释于观义。具此二双名观世音以答无尽意问也。初有二句。若有无量百千万亿众生此明受苦众生多也。所言亿者此土云万万为一亿。智度论云千万为一亿。盖是风俗不同也。受诸苦恼第二句明受苦非一。苦为八苦。亦有无量苦。恼谓九恼。亦有无量恼。闻是观世音菩萨下第二称名。即是感体。亦有二句。前明闻是观世音菩萨名者谓未受苦时曾闻菩萨名。或从经卷中闻。或从人传闻也。一心称名下第二句今日受苦时求救称名也。言一心者为释疑故来。自有称名不得解脱。盖是不一心故也。观世音菩萨即时观其音声下第三观机。即为应缘。自有人执此文属上而兴皇法师更足一观世音菩萨字。今谓足亦无失。但此文属下。何以知之。上既云闻是观世音名。又云一心称名。已再言名毕。是故属下明观音应也。皆得解脱者第二正明应。即是脱苦也

问。称名何故有脱苦不脱者

答。一意如上。有至心不至心故有脱不脱。二者脱有利益是则救之。脱无利益故不救也。三者与观音结缘有厚薄。薄者善少故不脱。厚者善多。是故得脱。四者众生业有定不定。不定可救定不可救。所言定者一重心作已心无惭愧。二者覆藏。三者作已更作。四起愿扶之。故决定得报。不可救也

问。若不可救应称名无利益耶

答。今虽无益作后世因。若有持是下第二别明救难以释观音之名。凡有七难。一救火难。二救水难。三救风难。四刑戮难。五罗刹难。六幽系难。七怨贼难。此并是诸难中至急。故略叙之。余有疾病虎狼雷电迷失道路。请观世音经并具说之。七难为二。初三是无情难。后四是有情难。此二略摄诸难。无情难不可请救故难免。所以前说有情可得请救。是故后明。又无情难是三大灾。广而且长。长即能至三禅。广则大千并坏。是故前说有情难不尔。鬼难云设满大千而不至于上界。有情难短又狭故在后说。就此二难各开为三。无情三者谓火水风。有情三者谓命身财。无情三有二种次第。一从急至缓。二依三灾次第从小以至大也。有情难从重以至轻故前命次身后财。二者从难至易。以命难难免乃至财难易脱也。就无情难又为二。第一明救三难。第二结观音名。然一一难中例应有四。一遇难。二称名。三观机。四免难。初二句释世音以辨境。后二句释观义以明智。又初二明感。后二辨应。但前后互现不同。今文为四。初持名。二遇难。三免难。四结神力也

问。上前遇难后称名。今何故前持名后遇难

答。火事为急。若身居火内方复称名则已受其弊。是故前辨持名后明遇难也。应验记非一。会稽高士谢敦字庆绪吴郡长影玄陆璒等并撰观音验记。宋临川王刘义庆撰宣验义记太原王琰撰冥详记皆出火事。昔有西域人。竺长舒居住茅屋忽值邻人失火。又正在风下。便诵念观音四邻荡尽其舍犹存。尔时有诸年少不信此事。仍于风下数夜以炬火掷其屋上。三掷三灭

问。称名云何免火

答。以菩萨力令火自然灭。或回转风势令火不烧。或接此人置火外。或注雨令灭。或火自然不烧。如耆婆入火。或以异物遮火。或令得禅定空三昧门随根所宜也

问。何故云入火火不能烧也

答。若未入火而称名得脱者或谓不必是观音力。今入火不烧必知是菩萨力

问。小火亦能烧人。何故言大火

答。或谓火少故不能烧。或谓禁咒力故令小火不烧。今入大火不烧则知是菩萨力。次水难文三意二。文三者一遇难。二称名。三则得浅处。前二明世音以辨感。后一释观以明应。大水方能为害。小则不能故火急在前水缓为次

问。火难何以前持名后遇难。水难何以前遇难后持名

答。触火则害人故前须持名。水则不尔。二者自有人前持名而后遇难。自有人前遇难后称名所以两存也。若有百千下第三明风难。所以知是风难者一依三灾次第故明火水风。二由风故飘堕鬼国故火以能烧为难。水以能溺为难。风以能飘为难。就文为二。初明世音以辨感。二释观以明应。初又二。一遇难。二称名。遇难为二。初明遇难缘。次正遇难也。若有无量者遇难人不一也。为求七宝下明遇难缘也。七宝不同。涅槃经以金象马神珠玉女主藏臣主兵臣为七宝。此是轮王之七宝。不通余人也。又恒水经明世有七宝。谓金银珊瑚白珠车渠明月摩尼。佛法亦有七宝。谓四果菩萨辟支及佛。智度论第十六卷云。金银琉璃车渠码瑙珊瑚真珠为七。此经所列第七是琥珀。真珠非七宝数故言等也。又宝塔品云。金银琉璃车渠码瑙真珠玫瑰又经云。正宝有七。杂宝有百二十种也。假使黑风下第二正明遇难。依华严经有十种风。依仁王经有五种色风。青风。赤风等。成论明风无色。论又云。风中或多触无香。或有香触必无色味。即彼品又云。有旧师云。风黑色。是事不然。此风与黑色为因非黑色也。今言黑风者一解云。此风起时前有黑云故云黑风。又云。此风欲起时海上有黑气仍以为名。又云。吹海岸黑沙故名黑风。吹其船舫者书云。自开已西称船开已东谓之舫。飘堕罗刹鬼国者由风力故令堕鬼国。非鬼难也。其中若有下第二称名。如人共船忧喜义同。应俱称名。而言一人者显心同义也。又一人称名众人免难。显菩萨力大也。是诸人等下第二释观明应义也。以是因缘下第二释无情难竟故总结之以詶其问也。若复有人下第二明有情难。此望前即是地大难。所以三灾无地灾而有地难者地以秉御成难不御非难灾任运起不须人御故无地灾。又四禅无有内灾患故外无地灾。今有人御故有地难。望后即是有情难也。合四难为三。如上释之。初二辨命难。以命最重故在前。火水风并皆害命。接此文生故前明命难。命难之中前人后鬼者人难显现。鬼难幽隐故从显至隐。又接火水风次明于地故前人后鬼也。设复有人下第二明身难。即系闭于身故名身难。三世往论皆悉有罪。而言无罪者就现前不作故言无耳。经云。大横有九。亦就现在不作故言横耳。若无罪而受苦者是无因有果。是事不然。若三千下第三辨财难。既云赍持重宝故知是财难。亦前释世音辨感。次释观辨应。初文又二。一遇难。二称名。其中一人下第二称名为二。初劝导。二受劝导。劝导为四。一诫。二劝。三释诫。四释劝。汝等下第二劝。是菩萨下第三释诫。汝等下第四释劝。众商人闻下第二受劝称名。称其名故下第二释观明应义。无尽意下大段第二前释名竟今叹名德。若有众生下第二释观世意。内心常念观察其意得离三毒故是释观世意。二者上拔苦果今拔苦因。三者上拔身难今拔心难。四者上拔肉身难今拔法身难。五者上拔世间难今拔出世间难。六者上拔报障业障今拔烦恼障。七者上拔一世难今拔三世难。八者上拔人中难今拔三界难。九者上为浅行人今为深行人。十者上暂拔难今永拔难。就文亦二。初释观世意名。无尽意下第二称叹名劝物常念。就救三毒即为三别。一一中前释世意明感。便得离欲释观辨应

问。念观音云何得离三毒

答。以常念故三毒不起。及常念观音实相法身即生如实观故三毒灭也。又此即是念佛三昧。念佛三昧能遍治一切障故。又常念故观音现身为其说法令三毒不起。又常念故观音能转前境。如净居天变覆诸采女以为不净。若有女人下第三释观世身名。礼拜供养即是身业。观察身业名观世身。又上拔其有难。有难有二。七难是身难。三毒为心难。今拔无难。拔无难亦二。一无男。二无女。三者上来是大悲拔苦。今是大悲与乐。四者上来与众生行果。今能满众生愿果。行有二行。愿亦有二愿

问。释三名有何次第

答。七难苦重故在初。三毒恼心为次。无男无女奢缓故居后

问。七难何故称名。三毒常念。无男无女供养礼拜

答。七难时短急不暇礼拜供养。亦不暇[僉*殳]心静摄但得称名。三毒时长难断必须治道故常念。无男无女异上二种故礼拜供养。又观音名具行愿故初令称名。余二名有行无愿故居后。二名之中意为本。身为末。复有次第也。就文亦二。一释名。二叹名

问。无男无女云何得生

答。观音菩萨托生为子故下现童男女身。又母子之业虽由宿缘而不决定。今修福力故令好人托生

问。何故男称福德智慧。女称端正有相

答。男有百行智为其端。女有七德容居其首也。此文前明世身辨感。便生下释观辨应也。是故众生下第二大段释三名竟结劝受持也。若有受持下第三大段次辨格量。又开为四。第一举持多名问无尽意。第二奉詶。第三正格量。第四结叹持名。所以有格量来者时众疑云。但受持观音名有此功德。受持余名亦有斯利。故格量优劣也。又受持观音与六十二亿等则持多名为难。持一名为易欲释成上劝持故格量也。初问三意。一辨持多名。复尽形下第二明时久。供养下明供养广。次无尽意答如文。佛言下第三正格量。又开二别。前明观音三事。一持名少。二时短。三供养狭。是二人福下第二正格量

问。格量有七。一凡不及圣。如大品云。教一人得初果胜教阎浮提人行十善。二少不及大。如二乘不及菩萨。三浅不及深。如浅行不及高行。四因不及果。如菩萨不及佛。五有所得不及无所得。如世间六度不及出世间六度。六末不及本。如五度虽是无所得终不及波若。波若是本故。七无缘不及有缘。如佛化须拔不及阿难。今是何格量

答。有人言。六十二亿是因位。观音是古佛。即是因不及果也。难曰。一切因不及果。岂六十二亿与果等耶。有人言。六十二亿是浅行。观音是深行。难曰。经不言六十二亿是浅行观音是深行。又浅行不及深行。云何六十二亿与观音等耶。有人言。观音是教主。六十二亿是听众。难曰。必以听众故不及者非但六十二亿不及。一切听众亦不及也。今所明六十二亿与观音位行是齐。而不及者众经有二种门。一平等门。二不平等门。平等门者如妙音得普现色身三昧八万四千菩萨亦得是门。则妙音与诸菩萨平等门。供养持名平等无异。二者不平等门六十二亿实与观音等。今欲令人尊重观音故于等作不等说之也。例如称扬诸佛经说。礼宝光明佛止灭二十一劫生死之罪。礼呴留孙佛却无量劫罪。此示不平等门故令众生生高下心。若实是平等而作平等说者则不得偏于观音起尊重心。法华论云。受持观音名及受持六十二亿恒沙诸佛名。论云。佛者皆是等觉地菩萨。既称等觉。即是等觉佛也。论云。彼福德平等有二义。一者信力。二毕竟知。信力有二。一求我身如观音自在无异毕竟信故。二谓于彼生恭敬心。如彼功德我亦如是毕竟得故。次言毕竟知者决定知法界故法界名为法性。彼法性入初地。菩萨能证入。一切诸佛菩萨平等身故。平等身者谓真如法身。是故持六十二亿恒河沙佛名受持观音名功德无异。此论大意就平等不二门辨无差别。初是信不二。后是悟不二也。然与前释亦不相违。无尽意受持下第四结叹。无尽意白佛下第二释普门明观音德。又上虽叹观音能拔苦与乐未知以何济拔。故今释言。一一难或用身业神通拔。或口业说法拔。或意业密拔。亦前问次答。问亦有三。一标能问人。白佛言下第二正问。观世音菩萨下第三明所问人。亦有三别。云何游此下问身业。次问口业。方便之力问意业。佛告下第二答。答中亦有三。一正答问辨三轮德。二劝供养。三总结称叹。初正詶三问故明三轮德。既有胜德即是福田故须供养。明三轮德即是施主。次辨供养显于福田。福田施主既彰故总结称叹。初文又二。第一别明三十三身十九说法。第二总结一切身教及方便也。初文又三。一现圣方便。二示凡方便。三示非凡非圣方便。初门明三乘圣。即为三别。一一中皆答三问。应以之言答意业问。即现佛身答身业问。而为说法答口业问。上从显至隐故云身口意。今从本至末故意身口。前意业知机。次现身后说法

问。此经会三归一。何故更示三乘

答。虽明会三归一而不失开一为三。从经初以来明于正说。谓摄用归体。故会三归一。今辨流通从体起用。故于一说三

问。妙音品有菩萨身。今何故无耶

答。彼不明三乘义故有菩萨身。今欲辨三乘之义菩萨身摄入佛乘故不说也

问。观音为是佛现佛身为非佛耶

答。经出不同。观音三昧经云。观音在我前成佛名正法明如来。我为苦行弟子。又云。我与观音俱时成正觉。又观音授记经云。观音于金光游戏佛所初发道心。彼国王名威德王。威德王入禅定二童子忽左右两面生。王起定问其名字。二童子说偈答。初就第一义门答无名。次就世谛门答有名。弥陀佛灭后世界出法音不断。彼佛于中夜入灭观音补处。世界转名众宝普集庄严。佛号普光功德山王。大势至补观音处。佛号善住功德宝王也。金光师子佛及弥陀佛皆有三乘。后二佛唯菩萨乘。闻此二佛名者得转女身却四十劫生死之罪

问。观音云何于此土有缘

答。弘猛海慧经云。昔此阎浮提有王名善首。有五百子。第一子名善光。值空王观音佛发十大愿。初愿得一切法。次愿得波若船。三愿值智慧风。四愿得善方便。五愿度一切人。六愿使超苦海。七愿得戒足。八愿登涅槃山。九愿会无为舍。十愿同法性身。皆以大悲观音为首也。观世音发愿。愿我未来作佛字观世音。三称我名不往救者不取妙色身。持此愿者清净庄严一室。以于此土行菩萨道故此土有缘

问。而为说法说何等法

答。说法不定。一者一身说一法门。二者一身说一切法门。三者一切身说一法门。四者一切身说一切法门。华严经中善知识但说一法门。今观世音现一切身说一切法门。梵王下第二示凡方便。又开三别。一天。二人。三杂类。天有三双。第一双欲色两界初王。第二双欲色两界后王。第三双欲色两界之臣。虽有三双不出君臣也。有人言。天大将军是天力士。如钵建提之类。亦如那罗延之流。有人言。是鬼神。如金光明散[日*旨]大将。散[日*旨]大将属毗沙门。出大集经。有人言。是韦陀天毗纽天也。毗沙门是北方天王。此云多闻。恒护佛道场常闻说法。故云多闻也。小王身下第二明人方便。亦开为二。初一示王身。次示臣身。臣身中有四。初示豪杰身。二示四众身。三示妇女身。四示童真身。居士有二种。一居舍之士故名居士。二居财一亿故名居士。即今文是也。婆罗门者此云外意。亦名净行。次示八部身

问。何故受龙身等不得道耶

答。乘急戒缓四句。一者乘缓戒急者生天人中不得道。二乘急戒缓者生鬼龙趣而得道。三乘戒俱急者生天人而得道。四俱缓者生余趣不得道。金刚神下第三示非凡非圣身。既为鬼神属四天处住。是故非圣身。实是楼至佛故非凡。楼至此云啼哭佛。独住半贤劫度众生。无尽意下第二总结。是故汝等下第二劝供养。又开六别。一劝供养。二受旨。三观音不受。四重请。五佛命。六受施回奉二尊

问。无尽意是出家菩萨。云何有璎珞

答。虽是出家不拘小道。二云是在家菩萨。涅槃云。入无供众列者此是他方在家菩萨。本非娑婆旧住故不持供来也。而言法施者如法布施也。又为法故施也。又达财法不二也。观音不肯受者一欲生施主殷重心故。二欲让二尊故。三示少欲知足故。后明观音受者一上顺佛旨。二下愍群生。分作二分者欲展转生施主福故。举二尊者示生灭平等不二故。释迦现生为智。多宝涅槃为断。示智断为福田故。无尽意下第三前既明施主福田竟。今第三总结称叹也。尔时持地下第三明双叹。就文为三。初明能叹人。言持地者即地能持故名持地。以其人得此三昧故以为名。即从座起下第二明叹之仪则。前白佛言下第三正叹。持地去佛座远。今起近佛前故云前白。观世音菩萨品自在之业者即牒初名也。以三业自在故故称自在之业。普门示现神通力者牒普门三轮德也。当知是人下正称叹也。佛说是下第四双益。初列得益之人。皆发无等等下第二正明得益。佛道无等。唯佛与佛等故名此道为无等等。所以名佛为无等等。复云无等等者佛具二义。一下有所异。二上有所齐。下有所异名为无等。上有所齐云无等等。以佛名无等等。今发佛心故云发无等等心也

    陀罗尼品第二十六

护难弘经二品。一以人护难如观音品说。今欲说神咒法护难故有此品来也。二者有多一两门。上来明诸菩萨各各弘道利物。名为一门。今品明众人说神咒。谓多人共弘道利物故有此品。三者说法华有种种门。或法或人或显或密。如上说因果即就法门说法华。说诸菩萨德行即是就人门说法华。此人法二种即显现门说法华。今明神咒谓秘密门说法华

问。何以知神咒是法华耶

答。下云闻神咒悟无生忍。岂非一乘耶

问。但是一法华。何故作种种名字说

答。虽是一法华随众生取悟不同。故作种种名字。如论云。波若是一法佛说种种名。论又云。波若在声闻心名道品。在菩萨心名陀罗尼。在佛心名萨婆若故知。陀罗尼即波若波若即一乘

问。在声闻心何故名道品。菩萨心中名陀罗尼耶

答。论云。道品但为趣涅槃。声闻但厌生死乐于涅槃故在声闻心名道品。声闻法中不说陀罗尼。菩萨欲遍持一切行令经身不失历劫逾明故在菩萨心中名陀罗尼。陀罗尼有无量门。今是咒陀罗尼。故举通以取别

问。咒是何物耶

答。诸佛菩萨说法有二。一显现二秘密。咒即是秘密法。如世人有二种法。一显现。谓世俗之常法。二秘密术。谓禁咒等。今随世俗亦作此二法。有人言。咒所论不出三义。一说极果胜德。或因中万行。故闻者发心。二说三宝名字。或诸佛菩萨之别名。或大力鬼神之名。召呼此名使魔耶闻者惊退。三说诸法深理无相使闻者悟道得无生忍

问。诸经中何故不翻咒耶

答。咒语多含。此间无物以拟之。若欲翻之于义不尽。又失其势用。如此间禁咒之法。要须依咒语法而诵之。则有神验不得作正语而说

问。云何得陀罗尼令人不忘

答。一以过去修习所得。二因咒术得。三因服药得。如诸仙等。四因现在修习得。五因禅定得。六深入实相故得也

问。陀罗尼与三昧云何异

答。三昧多以定为主。总持以念为主。二者三昧唯心相应。总持或心相应或心不相应。三始修名三昧。久习名总持。如习欲不改说名性。四本末异。三昧为本。三昧与实相合出生功德名之为总持。如坏瓶以火烧方堪持水。五失不失异。三昧转身或有退失。持则不失也

问。修习何因而得持耶

答。有四种因得持。一不习爱欲。二不嫉妒。三等施无悔。四乐法

问。咒云何能除患

答。一切法中各有增上。如水力增上能灭火。火得增上复能消水。今神咒力能除诸恶亦尔。恶有二。一有情恶鬼等。二无情谓恶风雨等。如是内难外难悉名为恶。地持论明有四持。一法持谓闻慧。二义持谓思慧。三咒持因禅起咒谓修慧。四忍持是入证行慧。四持位者地持云。闻义咒三初地成就者必不退。尔前得者不定。忍持起自解行地。成在初地。品开为三。第一对药王说经福重。二众人说咒拥护。三时众得益。初文又二。前问后答。所以说经福重者有二种义。一欲令人欣福持经。二明持经福重故次说咒护之。尔时药王下第二明五人说咒。药王勇施二是菩萨。次两是天。后一是鬼神也。药王说咒有五。一者请说。二者正说。三者叙说咒之人。即是六十二亿恒沙佛说。四明咒力用。第五释迦称叹也。案尔者咒不可翻。如前说。但读诵之人闻之茫然不解遂都不留心。今依正法华经仿佛翻之。多是明实相秘密法。

安尔(正法华云此云奇异)曼尔(此云所思)摩祢(此云意念)摩摩祢(此云无意)旨隶(此云永久)遮梨弟(此云所行奉修)赊咩(此云寂然)赊履多玮(此云澹泊)膻帝(此云志默)目帝(此云解脱)目多履(此云济度)沙履(此云平等)阿玮沙履(此云无耶)桑履(此云安和)沙履(此云普平)叉裔(此云灭尽)阿叉裔(此云无尽)阿耆腻(此云莫脱)膻帝(此云玄默)赊履(此云澹然)陀罗尼(此云总持)阿卢伽婆娑簸蔗毗叉腻(此云观察)祢毗剃(此云光耀)阿便哆罗祢履剃(此云有所依倚恃怙于内)阿亶哆波隶输地(此云究竟清净)区究隶(此云无有坑坎)牟究隶(此云亦无高下)阿罗隶(此云无有回旋)波罗隶(此云所周旋处)首伽差(此云其目清净)阿三摩三履(此云等无所等)佛驮毗吉利[厂@(失/衣)]帝(此云觉已越度)达磨波利差帝(此云而察于法)僧伽涅瞿沙尼(此云合众)婆舍婆舍输地(此云无音)曼哆罗(此云所说鲜明)曼哆罗叉夜多(此云而怀止足)邮楼多(此云尽除节限)邮楼多憍舍略(此云宣畅音向)恶叉罗(此云晓了众声)恶叉冶多冶(此云而了文字)阿摩卢(此云无有穷尽)阿摩若(此云永无有力势)那多夜(此云无所思念)

次明勇施说咒为三。一说咒意。二正说咒。三辨说咒之人

罗刹(此云可畏)吉遮(此云起尸鬼)鸠槃荼(正法华云厌鬼亦云冬苽)富单那(此云热病鬼)座隶(此云晃耀)摩诃座隶(此云大明)郁枳(此云炎光)目枳(此云演晖)阿隶(此云顺来)阿罗婆第(此云富章)涅隶第(此云悦喜)涅[(上/矢)*(入/米)]哆婆第(此云欣然)伊致抳(此云住止)韦致抳(此云立制)旨致抳(此云永住)涅[(上/矢)*(入/米)]墀抳(此云无合)涅梨抳婆底(此云无集)

次明毗沙门说咒亦三。初明说咒意。二正说咒。三结说咒意重发誓拥护

阿梨(此云富有)那梨(此云调戏)[菟-(色-巴)+(〦-一)]那梨(此云无戏)阿那卢(此云无量)那履(此云无富)拘那履(此云何富)

持国说咒为三。一说咒意。二正说咒。三明说咒之人

阿伽祢伽祢(此云无数)瞿梨(此云有数)乾陀利(此云曜黑)栴陀梨(此云持香)摩登耆(此云[凵@又]祝)常求梨(此云大体)浮楼莎抳(此云千器顺述)頞底(此云暴言至有)

罗刹女说咒为四。一说咒意。二正说咒。三结誓拥护。四佛叹述

蓝婆(此云结缚)毗蓝婆(此云离结)曲齿(此云施积)华齿(此云施华)黑齿(此云施黑)多发(此云被发)无厌足(此云无著)持璎珞(此云持华)皋帝(此云何所)

夺一切众生精气众生心中有七滴聒水。取一滴二滴令人头痛。三滴令人心闷。四滴五滴已下则死

伊提履(此云于是)伊提泯(此云于斯)伊提履(此云乎尔)阿提履(此云于民)伊提履(此云极甚)泥履(此云无我)泥履(此云无吾)泥履(此云无身)泥履(此云无所)泥履(此云俱同)楼醯(此云已兴)楼醯(此云已生)楼醯(此云已成)楼醯(此云而住)多醯(此云而立)多醯(此云亦住)多醯(此云嗟叹)兜醯(此云亦非)兜醯(此云消头大疾无得加害也)毗陀罗(此云青色鬼)建陀(此云赤色鬼)乌摩勒伽(此云食人精气鬼亦云大杀也)阿跋摩罗(此云影形鬼亦云无铠注经云转筋鬼)

如阿梨树枝者此树枝堕地即破为七分。正法华云华[卄/梨]剖也

    妙庄严王本事品第二十七

依论是第三过去胜功德力。能回父邪见使发心得记。即是善知识力弘法华经。此品犹述药王弘经。但流通法华凡四处辨于药王。一法师品因药王告八万大士。明二时弟子二世法师叹人美法示弘经方法。第二药王品述药王本缘。明因法华经得悟以身命财报恩供养弘道利人。第三陀罗尼品明持经功德说咒拥护法师。第四此品叹药王是众生善知识能令父王回邪入正受记成佛。第二第四明药王过去世事。第一第三辨药王现在世事。所以偏说其人两世事者以于法华有重因缘故为宣通之主。亦是根缘所宜也。应言药王本事品。但立名相避从所化之人立名故云妙庄严王本事品。所以共为父子者过去世时有四同学入山修道。一人往聚落求供养给之。于路见国王富贵荣华心自念言。未得道中间宜受此胜乐不亦快乎。三人得道一人作国王。于是三人欲度脱之而自念言。天下亲爱莫过儿妇。一人作妇二人作儿共化度之。以此本缘今世同为眷属。品开为二。初明缘由。二正述本事。初文有五。一过去时节。二化主。三国土。四列劫名。五述父子。文处易知。尔时彼佛下第二正述本事为二。初子化父令回邪入正生信心。二子化父令见佛闻法得正解。善知识力唯有此二。此二因二轮生。初明子以神通轮化父令生信。后佛以说法轮化王令得解又化父得信是菩萨为众生善知识。化王得解明佛是众生真善知识。二章各十句。初章十者一佛说经。二者二子劝母往见佛。三母令化父。四子自悲伤。五母令愍念父。六子正化父。七父受化。八许到佛所。九子求出家。十母听出家文处易知。于是二子下第二化父令得正解。亦开为十。一劝父母往到佛所。于是妙庄严王下第二父母受劝至佛所。尔时彼佛下第三明佛为说法。尔时妙庄严王下第四明闻法悟解。时云雷音下第五明佛受记。其王即时下第六明王及眷属出家得益称叹二子。尔时云雷音下第七佛述其所叹。妙庄严王下第八辨王辞退。又开四句。一叹佛。尔时下次叹法。我从今日下第三发誓。说是语下第四辞退。佛告大众下第九结会古今。佛说下第十明时众得道。法眼净有二。一者小乘是初果。二者大乘是初地。此难知也。但众经多明法眼是小乘。而闻大乘悟小果者有人钝根虽闻大法无巧方便故证小果。但证小果凡有二种。一者本是大乘人闻说大乘退证小果。如大品六十菩萨。二者本学小乘闻说大乘证于小果也

    普贤菩萨劝发品第二十八

法华论云。此品是第四护法流通。故下文云。我今以神通力守护是经于佛灭后广宣流布令不断绝。即其证也。又时众应闻说普贤事得道故有此品来也。又行一乘者即是行普贤行。故普贤来劝发也。又诵持此经者既是行普贤行行与普贤相应。则感普贤必来教其忏悔六根清净见十方佛及灭五逆十恶等罪。如普贤观说。又华严经七处八会普贤文殊善其始。入法界品流通之分此二菩萨又令其终。所以此二人在彼经始终者世相传云。究竟普贤行满足文殊愿。故普贤显其行圆文殊明其愿满。故于诸菩萨中究竟具足显华严是圆满法门。今说法华亦明文殊开其始普贤通其终亦显法华是究竟法。所以二经皆明两大士者欲显华严即是法华。为直往菩萨说令入佛慧故名华严。为回小入大菩萨说令入佛慧故名法华。约人有利钝不同就时初后为异故两教名字别耳。至论平等大慧清净一道更无有异。是故两经皆明二菩萨也。普贤者外国名三曼多跋陀罗。三曼多者此云普也。跋陀罗此云贤也。此土亦名遍吉。遍犹是普。吉亦是贤也。所以言普贤者其人种种法门。如观音总作慈悲法门名。今作普遍法门。普有二义。一者法身普遍一切处。故总摄三世佛法身皆是普贤法身。如华严云。普贤身相犹若虚空。依于如如不依佛国也。二应身普普应十方作一切方便。故十方三世佛应身皆是普贤应身。皆是普贤应用。故智度论云。普贤不可说其所住处。若欲说者应在一切世界中住。即其证也。注经解云。化无不周曰普。邻极。亚圣称贤。劝是奖劝。发是发起。以诸胜事奖劝发起持经人心故云劝发。依下文普贤以七事劝发。一为问四法为劝发。二现瑞相为劝发。三说神咒为劝发。四以通经力为劝发。五叹持经为劝发。六说持经果报为劝发。七护法为劝发。品开五段。第一明普贤来问佛。第二明佛答。第三正明普贤发誓护人护法。第四明佛称叹。第五时众悟道。初章又五。一明来方。二现神力。三眷属现神力。四到已修敬。五咨问于佛

问。华严经云。普贤身相犹如虚空。依于如如不依佛国。今云何言从东方来

答。净名经叹佛身云。不在方不离方。以离三界故不在方。无感不应故不离方。今东感之则见在东。若西感之则见在西。所以有此去来。华严辨其法身。此经明应迹故不相违也。普贤观经云。普贤身无量无边。欲来此国入自在神通促身令小故从东至西也。所经诸国下第二现神通力。又与无数下第三与眷属俱各现神变也。到娑婆下第四明到已修敬。白佛言下第五明咨问。初叙来意。唯愿下正请问。云得是法华经者此明解悟为得也。佛告下第二明佛答为三。谓标释结。释中明四法者。一外为诸佛护念。护令恶不侵念令善根成就。二者内殖德本。明初发一念不二正观为众善之本。以得此观行与佛应故为佛护念。三者入正定聚。聚有三种。一者邪定聚谓必入地狱。二者正定聚必得解脱。三者二楹中间名不定聚。约位明者旧云。内凡夫性种菩萨得生空解名为定聚。今谓十信第六心称不退信。亦得名为入定聚。四者发救一切众生心。如金刚般若论四种心。一广大心遍度众生故。二第一心与众生大涅槃乐故。三常心常不离是心故。四不颠倒心知众生本来常寂灭故。佛答四法次第者初一为外缘。次一为内因。谓因缘一双。次一明位。后一明行。谓行位一双。尔时普贤下第三发誓拥护。初既出所护人德。今正明拥护其人。就文为二。第一明普贤护人劝发。第二次明护法劝发。护人中为二。第一广举众事劝发。二者结劝持经。初又开四别。一护难劝发。二现身生善劝发。三叹自行劝发。四举果报劝发。此四略举灭恶生善行因得果两双以劝发也。初护难如文。是人若行若立下第二现身生善劝发。此中凡有三感三应。第一明读诵法华故感普贤现来安慰人心及供养经法。第二思惟此经感普贤来授其文句令得总持之益。第三教其行法释成上感见之义。初章以读法华经为因故见普贤来。智度论云。有一比丘读法华有国王见一金色人乘白象来住其人前立听法华经也。所以乘六牙白象者又二。一明菩萨仪则。二欲以灵兽伏诸魔毒。普贤观经云。六牙表六度。四足表四如意足。七支跓地表七觉分。经云。阎浮提人三障重故以智慧力化乘白象。其象六牙。七支跓地。于七支下生七莲华。象色鲜白颇梨雪山不得为比。象身长四百五十由旬。高四百由旬。于六牙端有六浴池池中生四莲华。华上有一玉女。手中化五箜篌。有五百乐器。以为眷属。象鼻有华。华中有化佛及化菩萨。放金色光照象顶上。化成金台。象头有三化人。一捉金轮。一持摩尼珠。一执金刚杵。举杵拟象象即浮空离地七尺。而印文现。于印文中千辐毂辋皆悉具足。一一辋中生一莲华。莲华上有一化象。如是举足下足生七千象以为眷属。随大象行化佛放光。至象背上化成金鞍。金鞍四面有七宝柱以成宝台。台中有七宝华。百宝为须。有大摩尼为台。普贤端坐其上身白玉色有五十种光。光中有五十种色以为顶光。身诸毛孔流出金光。其金光端有无量化佛及化菩萨。雨大宝华至行者前象即开口诸玉女鼓乐弦歌。其声微妙赞叹大乘一实之道。行者见已欢喜顶礼。如普贤观经中广说也。是人若坐下第二明思惟经时普贤来也。旋陀罗尼者得此总持故知十方诸佛菩萨所说皆能忆持也。以解一法门即解一切故名为旋。法音方便者解诸佛一切方便门。如三乘之流也。世尊若后世下第三示其行法。依普贤观经行法五品。一三七日即见普贤来。二七七日见。三一生得见。四二生得见。五三生得见。今但明上品人得见故三七日必见也

问。修何法耶

答。今依普贤观经略明六法。一在静处庄严道场烧香散华等。二洗浴内身着净洁衣。三六时礼十方佛。法身佛遍一切处。应身佛在净土。化身佛处于秽土。六时至心礼拜对十方佛及对普贤忏悔六根罪也。无始已来至此生内于一一根生六种烦恼。一见好色生贪。二见恶色起嗔。三见不好不恶色起痴。四见色起断常等成诸见外道。五见有无堕二乘地。六见色作有所得心成烦恼障。以起此六种烦恼故起结业不得离生老病死忧悲苦恼。障菩提心障于菩萨道及障佛果。一根既尔。五根亦然。深自呵啧起重惭愧于一一根三过对十方佛及普贤说之。请诸佛菩萨慈悲受其忏悔。及请六道众生受其忏悔。四于静处请释迦为和上。文殊为阿阇梨。弥勒为教授。此三人即是三世佛。释迦为现在佛。文殊为过去佛。弥勒为当来佛。故请为三师。次请十方佛为证人。十方菩萨为善友。请普贤为忏悔主。于此六师前自受三归。受三归竟自受三戒。一从今身尽未来劫誓息一切恶。二从今身尽未来劫誓修一切善。三从今身尽未来劫誓度一切众生。此三摄一切法皆尽也。五昼夜读诵大乘经。六端坐思惟第一义甚深空法。达此六根如幻如梦从因缘生。因缘生即是寂灭相。寂灭相即是实相。实相即是法身。作此观时念念见十方佛法身及普贤菩萨。于一弹指顷能灭百万亿阿僧祇劫生死之罪

问。前直云后五百岁。今云后世后五百岁。何异

答。正法五百年像法一千年。前明正法灭竟入初像法五百年也。今是像法第二五百。即是两后故云后世后五百年也。说神咒劝

阿檀地(此云无我)檀陀婆地(此云除我)檀陀婆帝(此云方便)檀陀鸠赊隶(此云宾仁和除)檀陀修陀隶(此云甚柔软)修陀隶(此甚柔弱)修陀罗婆底(此云句见)佛驮波膻祢(此云诸佛回)萨婆陀罗尼阿婆多尼(此云诸总持)萨婆婆娑阿婆多尼(此云行众说)修阿婆多尼(此云盖回转)僧伽婆弥只尼(此云尽集会)僧伽涅伽陀尼(此云除众趣)阿僧祇(此云无央数)僧伽婆伽地(此云计诸句)帝隶阿惰僧伽兜略(此云世)阿罗帝波罗帝(此云三世数等)萨婆僧伽三摩地伽兰地(此云越有为)萨婆达磨修波利刹帝(此云学诸法)萨婆萨埵楼驮憍舍略阿兔伽地(此云晓众生音)辛阿毗吉利地帝(此云师子娱乐)

若法华经下第三举自行劝发。若但书写下第四举果报劝发。是故智者下第二结劝。世尊我今下第二护法劝发。尔时释迦下第四释迦称叹。又开二别。初叹能护之人。第二叹所护之者。初叹能护人中即叹前二事。一叹其护人。而能作是神通之愿下第二叹其护法。普贤若有受持下第二叹所护之者。又开五别。第一为佛护念叹。如是之人下第二离诸恶叹。普贤若如来灭后下第三就后报得佛叹。普贤若于后世下第四就现报及得失门叹。是故下第五结叹。佛说是普贤劝发品下第五明说品利益又开为二。初明得益。二欢喜辞退也

法华义疏卷第十二

自去永仁元至同三年送首尾三个年之星霜开义疏十二卷之印板讫即就澄禅宗师之讲肆事讨论因聚南都北岭之旧疏加刊定加以择统略新选之相乱紏文字点画之纰缪傥有宋本岂加旃新雕木联尔哉尚恐庸愚揆文英贤察是风闻马鸣龙树负贝叶于五天也八不正观之月独辉震岭提婆罗睺洒法雨于三国也絁待妙法之华盛薰金陵从尔以降汉家本朝专弘此宗异乡边方虽玩斯教代属末法钻仰无人时覃季浇书写莫处呜呼从推古天皇御宇至当代七百余年相承仅传宗纲将乱三论章疏一无印板爰素庆幸逢难逢大乘忝闻难闻宏宗宛似雪山上士为半偈兮投身相同香城萨埵求般若兮洒血冀结缘缁素同志兄弟早驾非三非一之妙乘速到非近非远之宝所殊当卷檀那清原氏女拟七又逆修显如又妙理七世恩所通自他三界群生岂差别然则发破邪显正之觉成革凡入圣之妆也

            都干缘沙门　素庆虔跋

            再入宋桑门　慧海谨书

            雕刻诸人等　胜弘明眷

                            父信

                        伐祐快贤

                        严顺


法华游意

    No. 1722 [cf. No. 262]

法华游意

        胡吉藏造

    开题序

盖闻无上调御一切种智内镜三明外流七辨。蓄莫限之质适无方之化。并皆会道无匪称机。至如妙法莲华经者。斯乃穷理尽性之格言。究竟无余之极说。理致渊远统群典之要。文旨婉丽穷巧妙之谈。三圣之所揄扬。四依之所顶戴。昔仙人园内未曜此摩尼。今灵鹫山中方洒兹甘露。良以小志前开故早驰羊鹿。大心后发方驾此白牛。斯实萨埵之明训道场之玄轨也。此经文虽有七轴义有二章。一开方便门二显真实义。开方便门者开两种方便。显真实义者显二种真实。假三车于门外为引耽戏之童。设化城于道中以接疲怠之众。谓乘方便也。皆是吾子等赐大车。既知止息同到宝所。谓乘真实也。燃灯授记伽耶成道王宫诞生双林唱灭。谓身方便也。逸多不见其始。穷学莫恻其终。六趣无以摄其生。力负无以化其体。谓身真实也。两门既为方便。所以言粗。二种并云真实。故目之为妙。夫借一以破三。三除而一舍。假修以斥短。短息而修忘。然则言穷虑绝。何实何权。本性寂然。孰开孰覆。故理超言外强称为妙。为物作轨则目之为法。道玄像表假喻莲花。所言经者。妙显无言寂灭古今莫改。体可揩摸。故云经也

法华玄十门分别

一来意门　二宗旨门　三释名题门　四辨教意门　五显密门　六三一门　七功用门　八弘经门　九部党门　十缘起门

第一来意门者

问。佛何因缘故说是妙法花经耶。诸佛不以无事及少因缘而自发言。今有何等大因缘故说是经耶

答。妙法莲花其义无量。所谓因缘亦复非一。今略序纲要开十门一者欲为诸菩萨说诸菩萨行故说是经

问。始自华严之会终竟法花前集四十余年。诸大乘经已说菩萨行。今何因缘复更说是经耶

答。有二种菩萨。一直往菩萨二回小入大菩萨。自昔以来为直往菩萨说菩萨行。今欲为回小入大菩萨说菩萨行故说是经

问。何以知始自华严之会终竟法花之前为直往菩萨。今为回小入大菩萨耶

答。踊出品云。是诸众生始见我身闻我所说。即便信受入于佛慧。除前修习学小乘者。如是等人我今亦令得闻是经入于佛慧。既称始见我身者。即是寂灭道场见卢舍那佛。闻我所说谓花严之教。故知自昔已来为直往之人说菩萨行。除前修习学小乘者。则知尔前未为二乘说菩萨行。如是等人我今亦令得闻是经入于佛智慧。则知今为回小入大之人说菩萨行也

问。经文何故但据二人

答。初举为于大始。后标教于小终。一化中间则可知也

问。何故前为直往菩萨。后为回小入大之人

答。直往之人久行佛道福德利根。是故前为。回小入大之人不行佛道薄福钝根。是故后为。故方便品云。有佛子心净柔软亦利根无量。诸佛所而行深妙道。为此诸佛子说是大乘经。钝根乐小乘法贪着于生死。于诸无量佛不行深妙道。众苦所恼乱。为是说涅槃。乃至今正是其时。决定说大乘。故知菩萨利根先闻大道。声闻浅劣后入佛慧。明既其证也

二者欲受梵王请故说是经

问。云昔波若等教已明受梵王请故说之。与今何异

答。请有二时酬亦两种。请二时者。初请说一乘根本法轮。后请说三乘枝末之教。酬亦二时者。自昔已来受请说三乘之教。今方得酬其请说一乘根本法轮。是故今明受请与昔为异。具如方便品及智度论初卷说也

三者欲明十方三世诸佛权实二智互相资成故说此经。然诸佛之心未曾权之与实。岂是一之与三。故内外并冥缘观俱寂。但于无名相中假名相说。欲出处众生故。强称权实则于互有相资成故。非实无以辨权。非权无以辨实。实有起权之功。权有资实之用。是以文云于一佛乘分别说三。谓从实起权我设是方便令得入佛慧则以权通实。但禀教之徒或执权丧实或执实丧权执权丧实者。自昔已来执三乘教人不能悟入一实者也。执实丧权者。谓禀法花一乘菩萨既闻道理唯一无有三乘。遂守其理一失于三用。如法花论释药草喻品。为破菩萨病故来。虽一地所生一雨所润而诸草木各有差别。此明理虽是一随缘有三。岂可守一而失三用耶。然昔禀三乘教人既丧于实亦复失权执一乘教人既其失权亦复丧实故。此二人皆失如来权实二智。并住颠倒虚妄断常。欲破今昔互失之缘。令识如来权实二智互相资成。既识二智便入佛慧同归一道故说此经也

四者欲说三净法门故说此经。然众生本性寂灭未曾垢净。虽非垢净于众生颠倒是故成垢。但此垢重众生不可顿拔故。诸佛菩萨渐渐出之。所以开三净之教。一者以五戒十善净于三涂。次说二乘以净三界。后明一道以净二乘。以三涂为重苦。三界为中苦。变易为下苦故。说三门以净其三垢。三垢既灭则三净亦忘故说此经也。然说三净为止三垢。垢若不留净亦便息。了悟诸法本性寂然未曾垢净。乃入于佛慧直至道场也。

五者欲说三摄法门故说此经也。总谈群圣垂教凡有三门。一摄邪归正门。二摄异归同门。三摄因归果门。摄邪归正门者。释迦未出之前凡有二邪。一在家起爱众生。二出家诸见外道。此二并乖正道故称为邪。故方便品云。以诸欲因缘备受诸苦毒。即起爱之流也。入邪见稠林若有若无等。谓诸外道也。乃至譬喻品云。起爱譬彼毒虫。诸见喻同恶鬼。如来出世摄彼二邪归五乘之正。此二人中有无闻非法者。以人天善根而成就之。有三乘根性者。以三乘法而摄取之。故摄彼二邪归五乘正也。二摄异归同门者。若禀教之徒闻昔三乘而顿悟一道者。不须复更说法花之教。但钝根之流虽舍二邪更对执五异。今欲摄兹五异同归一乘。谓摄异归同门也。三摄因归果门者。摄前五异同归一乘但是因行。今为欲令修因证果故说如来真应两身。谓摄因归果门。法花之前但有初门。斯经既融会一化则具足三门。然明此三门意。欲为通寂灭无言之道令玄悟之宾体斯妙极未曾邪正乃至岂是因果耶。故此三门无教不收无理不摄。如空之含万像。若海之纳百川

六者欲说三种法轮故说此经。言三种者。一者根本法轮二者枝末之教三者摄末归本。根本法轮者。谓佛初成道花严之会纯为菩萨开一因一果法门。谓根本之教也。但薄福钝根之流不堪于闻一因一果故。于一佛乘分别说三。谓枝末之教也。四十余年说三乘之教陶练其心。至今法花始得会彼三乘归于一道。即摄末归本教也

问。此经何处有三轮文耶

答。信解品云。长者居师子坐眷属围绕罗列宝物。即指花严根本教也。唤子不得故密遣二人脱珍御服着弊垢衣。谓隐一说三谓枝末教也。如富长者知子志劣柔伏其心乃教大智。谓摄末归本教。又譬喻品云。如彼长者虽复身手有力而不能用之。但以殷勤方便勉济诸子火宅之难。然后各与珍宝大车。初句谓隐根本。次句谓起枝末。后句谓摄末归本。即三轮分明之证也

问。初明根本后明摄末归本此二何异

答。昔南土北方皆言。花严是究竟之教法花是未了之说。今谓不然。此经明初一乘救子不得。后辨一乘救子方得。得与未得义乃有殊。初后一乘更无有异。若后说一乘救子方得遂是不了义教者。初说一乘救子不得亦是不了义教。若初救子不得遂是不了教者。则诸佛出世便欲以不了义法用化群生。便乖诸佛本意伤父子恩情也。今明法花与花严有同有异。所言同者。明一道清净平等大慧故。踊出品云。是诸众生始见我身闻我所说。即便信受入于佛慧除前修习学小乘者。如是等人我今亦令得闻是经入于佛慧。佛慧即是平等大慧。故知花严与法花同名平等大慧。诸佛知见无有异也。所言异者略明五种。一化主异。花严化主多名卢遮那法花化主称为释迦。又花严一佛所说。法花则普集分身诸佛说花严则菩萨说。法花则佛自说。二者徒众有异。花严为直往菩萨说。法花为回小入大人说。花严纯为菩萨说。法花杂为五乘人说。花严顿为菩萨说。法花渐渐为菩萨说。三时节异。花严始说一乘。法花终明究竟。四教门异。直说一乘平等大道无所破斥名为花严教。此经破三乘执固然后始得归于一极也。五约处异。花严七处八会说。此经一处一会说

问。法华亦有多处多会以不

答。同在灵鹫山故唯有一处。而约前后凡有净秽三时。初分之经在秽土中说。见塔品已去竟于属累第二分经在净土中说神力一品十方通为一土中合在净秽中说。始自药王终讫普贤劝发品还在秽土中说。问三种法轮法花具几种。答一往则花严为根本法轮。自花严之后法花之前为枝末之教。此经则属摄末归本。然法花结束一化该罗顿渐则具足三轮。然此三轮皆是无名相中为众生故假名相说。然寂灭之道未曾有三亦无不三。无所依止也

七者欲释声闻菩萨二种疑故演说此经。声闻二种疑。一者旧疑。如身子云。我等同入法性。云何如来以小乘法而见济度。又云。欲以问世尊为失为不失四十余年常怀此疑。谓旧疑也。如云初闻佛所说心中大惊疑。则是新疑也。菩萨旧疑者。昔禀三乘之教既执道理有三。或疑退堕二乘地。或疑进成佛道。今疑者。疑佛所说今昔相违。昔说有三今不应明一。今辨有一昔不应说三。大小二人闻说此经两疑皆息。故方便品云。菩萨闻是法疑网皆已除。千二百罗汉悉亦当作佛

问。声闻新旧二疑所有文证。菩萨新旧疑出何文耶

答。身子三请中云。求佛诸菩萨大数有八万。欲闻具足道。当知菩萨亦有疑也

问。八万大士皆法身菩萨。何容有此疑也

答。身子权行接引实人。法身菩萨府同新学。故无过也

问。菩萨声闻疑有何异也

答。声闻自谓究竟闻非究竟。是故生疑。菩萨无此疑也。而但有上二种之疑。所以为异

问。释疑有何益耶

答。若不释疑。则声闻无进道菩萨有退路。今开方便门示真实相释大小之疑。则菩萨无退路声闻有进道。是故此经为益之深也

八者欲说中道法故说此经

问。何以知欲说中道耶

答。二周说初皆放眉间白豪光明。上不以顶下不以足放眉间光明者。表二周之说皆明中道法也。初周明一道清净。一道清净即是中道。第二周明一法身。一法身亦是中道。然法身更无有二。随义立名。故知二周皆明中道也

问。何故明中道耶

答。道未曾偏中。但为对昔偏病是故说中。所以然者。如来昔说五乘为显不五。既无有五亦无不五。本性寂然无所依倚名为中道。中道即是妙法。但禀教之徒闻昔说五乘遂作五乘异解故堕在诸边。禀人天乘者堕在生死边。求声闻缘觉乘者堕涅槃边。学三藏教者堕在小边。学摩诃衍者堕在大边。乃至昔禀五乘异堕在异边。今闻一乘作一乘解者堕在一边。今破此诸边令心无所著。即是妙法莲花经。故名中道也

九者欲显诸菩萨念佛三昧故说是经。自昔已来未具足显身真实真方便故。凡夫二乘及始行菩萨犹未识佛。故不解念佛亦不解礼佛。但以有所得心念佛者。便是念有所得竟不念佛。有所得心礼佛。乃是礼有所得亦不礼佛。不礼不念则佛非彼师彼非弟子。今既开身方便身真实方解礼念。始名师弟子

问。昔缘云何未识佛耶

答。昔执虽多不出三种。一者不识本一迹多。二者不识本无生灭应用有生灭。三者不识释迦久证法身非伽耶成佛。为对此三病故示三种教门一者普集分身示本一迹多。明释迦之与净土之佛皆是应迹。非此净秽乃为法身。故法身不二迹身不一。又若执应身不一法身不二者。亦未免二见。有所得心。即是不动而应十方现前。既不动而应。虽应常寂。故此应身则是法身。如涅槃云。吾今此身则是法身常寂而应。不失应身故不二而二。开于本迹二而不二。未始二身。二者开塔并坐生灭互显。多宝灭既不灭。则显释迦虽生不生。不生不灭名为法身。方便唱灭称为应用。若复言法身自不生不灭应身自生灭。还成生灭无生灭二见。今明王宫生生而不起。双树唱灭灭而不失。故生灭宛然未曾起谢。生灭宛然故是应用。未曾起谢称为法身。三者过去久成佛未来不灭称为法身。燃灯授记伽耶成道自为方便身

问。释迦久证法身。法身有久近不

答。法身无久近。以法身无久近故则知悟亦无久近。所以然者。悟本悟于法身。法身既无久近故。则知悟亦无久近。若尔释迦久悟而实无久。当知今近悟亦无有近。故知远悟亦无有远故知近远无二。不二而二不失古今也

问。何以故但明此三义耶

答。就释迦应身必备此三。初则法身不二迹身不一。未知不二之身为有生灭为无生灭。故次明法身无生灭应身有生灭。虽明法身无生灭应身有生灭。未知释迦为始证法身为久证法身。故第三次明久近。一切诸佛多具前二义。释迦则具足有三句

问。三身云何辨于权实

答。法身但实而非权。化身但权而非实。应身有二句。一者内与法身相应名为应身。法身既常故应身亦常。此即应身是实而非权。故涅槃经云。诸佛所师所谓法也。以法常故诸佛亦常。二者外与大机相应净土成佛故名应身。此之应身是权而非实。故七卷金光明云。应化两身是假名有非是真实。念念生灭故名曰无常。则其证也。既识三义即便识佛。故今念佛三昧倍复增益。又合此三种以为二义。前之二义以明身之权实。后之一义以明寿之权实。涅槃经亦明长寿与金刚身。所以但明此二者。众生唯有形与寿命。随顺之亦明斯二也

问。大品云。云何念佛。以无忆故。既其无忆。云何念也

答。了众生与佛本来不二。即不见佛为所念众生为能念故。内外并忘缘观俱寂。故名无忆也

问。大品可有斯文。今经何处明斯念佛也

答。寿量品云。如来如实知见三界之相。无有生死若退若出。亦无在世及灭度者。非实非虚非如非异。不如三界见于三界。三界即是众生。故知众生与佛无二。宁有能念所念义耶。故中论云。生死涅槃无有二际。众生法身义亦如是。斯即经论大宗。必须依斯礼念也

十者欲为现在未来十方众生如实分别罪福果报故说是经。如一言毁法及谤持经人。则获广大罪报。一念随喜则招无边之福。所以然者。夫论罪福从乖符理生。此经既说实理。故信之福多毁呰之罪重。一旧疏本明说经因缘甚广。今略明十门也

第二明宗旨门者。自古至今明宗旨与体。或言是一或言是有异。言其异者。以教为体以理为宗。故涅槃释七善文云。知法知义。知法者谓十二部经。知义者谓教所表理。故以能表之教以为经体。所表之理用以为经宗。言宗体一者。所表之理既是理宗旨。能诠之文还诠宗旨故宗体不二。今明一之与异随时用之。贵在得悟义无定也。昔在会稽撰释法华宗旨凡有十三家。今略明即世盛行有其三说。一云以万善之因为此经宗。所以然者。斯经文虽有七轴而宗归一乘。是者即因也。故乘以运出为义。运载行人从因至果。至果则更无进趣。是故非乘。如大品云。是乘从三界出到萨波若中住。智度论释此语云。乘到菩提变名种智。故知以因为乘。胜鬘经云。于佛果上更无说一乘法事。故则知果非乘矣

问。此经初分明因门后分辩果门。云何偏以因乘为宗

答。后章辩果为成前因。以行一乘之因得寿量之果故举果成因以因为宗。二者有人言。此经以果为宗。所以然者。夫欲识经宗宜观经题。题云妙法者谓如来灵智为体也。陶冶尘滓众尘斯尽故名为妙。动为物作轨即所以称法。自因位以来粗法未尽。不得称为妙。既以果德为妙法。即以果德为经宗。是以释迦以玄音始唱叹佛智甚深。多宝赞善称大惠平等。即其证也。三有人言。此经具以一乘因果为宗。故初分明一乘之因。后章明一乘之果。借莲花为喻者。此花不有而已。有即花实俱含。此经不说而已。说即有因果双辨也

问。今所明者为与旧同为将他异

答。今总观经论。宜开四句不同。一破而不取。二取而不破。三亦取亦破。四不取不破。言破而不取者。今不与旧同亦不与旧异。所以然者。求上来义。不成或不可与其同或不可与其异。求上诸义既不可得。与谁论同异耶

问。云何求上义不成耶

答。今以三意往推。即知其前义为失。一者总摄三师不出因果。而正观论盛破十家因果。则一切因果不成。今略题数门示不成相。三师既以万善为因寿量为果。为万行因内有寿量之果为无果耶。如若其有果。即因无生果之能。果无酬因之用。若万行之因无寿量之果。虽修万行终不生果。若万行因无果而生果者。万恶亦无佛果应生佛果。又大品经云。若言因中有果因中无果。亦有亦无非有非无。如是之人即。谤佛法僧系属于魔。是魔眷属。岂是一乘因果义耶。又因中有果因中无果亦有亦无非有非无。是僧佉．卫世师．勤沙婆．若提子外道之义非佛法矣。纵又修万行为因寿量为果者。万行之因为待果起而灭为不待果而灭。若待果起而灭则名为常。若不待果起而灭则名为断。既是断常则不成因果。以何为此经宗。又既是断常则障一乘妙法。云何用障法为宗。又若言一念之善相续至佛果者。为灭已而续为不灭而续。若灭已而续则有能续无所续。若不灭而续者。则有所续无能续。云何续至佛果耶。以经论推之。并无此因果与谁同异耶。二者纵有此因果者。彼便谓道理有此因果则成有所得。经云有所得者无道无果。以何为宗。又有所得者经云不动不出。都非乘义。云何用为经宗。涅槃经云有所得者名为无明。宁用无明为平等大慧经宗。有所得者名二十五有。云何用二十五有为众德经宗

问。大品与涅槃自可论有得无得。法华经明低头举手一豪善之并皆成佛道。岂简有得之善非一乘耶

答。得与无得盖是众经之旨归圣观之渊府。辨得失之根本示佛教之偏正。岂不该罗法花。又即此经文自辨得与无得。今略举三文。一初开宗即云我以无数方便引导众生令离诸着。二者后流通富楼那叹佛云。甚奇世尊以智惠方便拔出众生处处贪着。处处贪著者着小着大著三着一。故知此经正明无所得也。又此经盛谈寂灭。如云是法不可示言辞相寂灭。又云诸法从本来常自寂灭相。寂灭相即是无得实相异名。不应言此经辨有所得也。三者则用此经文责之。若言乘是因者。是义不然。今讲法花宜以法花为证。法花明三车一车皆悉是果。故譬喻品云今此三车皆是在门外。即三界外果德为车。故下合譬谈皆以果德合之。举涅槃合羊车。举自然惠合鹿车。举佛果四德智合牛车。举大涅槃果德合大车。故云皆以如来灭度而灭度之。又举佛果众德以合大车。故云悉与诸佛解脱三昧故名等赐大车。则知三车一车皆是果乘非因乘矣。又此经秤名妙法。妙法者佛果。德无不圆累无不尽故名为妙因德未圆累犹未尽不名为妙。则应以果为正宗。因非正宗也。次问第二。若偏以佛果为乘者。是亦不然。诸子求车佛即赐车。诸子得车即诸子得果。故云乘是宝车直至道场。即知以因为乘宁非乘也。又大品等经皆明乘是因义。何得偏用果为乘耶。次破第三。因果为宗是亦不然。此经初分始终盛谈果德。今略引三证。一者开宗略说叹佛智惠甚深。二者广说开佛知见。三者多宝证说叹大惠平等故知初分始终盛谈果德。非明因矣。以此众义求三家解释并皆不成。故无可与同异

问。何故要须洗破诸计

答。若有因果等见即是有所得。有所得名之为粗。不名为妙。有所得名为非法。不名为法。有所得即是不净染着。非是莲花。今息因果等见即是无所得。无所得故名曰妙法称为莲花。故是经宗

问。何以得知息有所得见即是妙法莲花耶

答。今略引三证。一正观论云。从因缘品来推求诸法。有亦无。无亦无。亦有亦无亦无。非有非无亦无。是名名如法性实际涅槃。故知求有所得因果不可得即是妙法。二者法花论释方便品云。我以无数方便引导众生令离诸着。著有四种。一者着界。谓三界等。二者着地。谓欲界地乃至灭尽定地。三者分着。谓在家着五欲出家著名利。四者乘着。着小乘着大乘等。故知有所著不名妙法。无所著即是经宗。三者关中肇公百论序云。萧焉无寄理自玄会。傥然靡据事不失真。变本之道着乎兹矣。故知心无所依着即是妙法。为此经宗也。第二取而不破者。要须前来破洗有所得执断常心毕竟无遗。然后始得辨佛因缘假名方便用。若众生应闻因为宗得悟即为说因。应闻果为宗得悟者即为说果。应俱闻因果为宗得悟则为说因果。三世诸佛菩萨说经造论。意在众生得悟为正宗。而教无定也

问。何以知然耶

答。凡引六证。一者文殊问经云。十八部论及本二皆从大乘出。无是亦无非。我说未来起。二者大集经云。虽有五部不同。皆不妨如来法界及大涅槃。三者摄大乘论云。诸佛唯以利益为定而教无有定。四者智度论明。六家释波若论主不判其是非。以皆出佛口并能开道常益物故。无非正经。五者中论观法品云。诸法无决定相。诸佛有无量方便。或说一切实或说一切不实亦实亦非实非实非非实。四句并皆得道。皆是佛法。六者求那跋摩三藏遗文偈云。诸论各异端修行理无二。偏执有是非达者无违诤。故知适缘所宜教无定也

第三亦立亦破者。因果等三虽出经文非是正意。故须破之。所言立者。今一往对上三师所明。此经以非因非果中道为体。因果等为经大用

问。因果等为用非因果为体。此出何文

答。方便品中明如是大果报种种性相义。此偈颂上因果之法。次偈即云是法不可示言辞相寂灭。此偈即明非因果义。故知以非因果为体。因果等为用。因果非因果既尔。三一近远权实亦然。非三非一为体。三一为用。非近非远为体。近远为用。非权非实为体。权实为用。然他义但得经用不识经体。既不得体云何得用。设使得用用义不成。若执因是乘者即斥于果。执果是乘者便破于因。各执因果即弹双用因果。而此经始终具四句明乘义。一者因乘非果乘。即诸子乘此宝车直至道场。二者果乘非因乘。故云佛自住大乘如其所得法定慧力庄严以此度众生。三者双用因果为乘。即含前二句。四者非因非果为乘。谓是法不可示。言辞相寂灭

问。乘是运出义。非因非果云何是乘耶

答。说非因果令众生出四句越百非。故名真运出义也。又经云佛性有五种名。五种名中名为一乘。而经既明佛性是非因果。一乘岂不得是非因果耶。虽有三句四句为乘用。第四句为乘体。故说上三句归于非因非果。第四句亦由非因非果故有因果等用也

问。古旧谁用非因非果为经体耶

答。注法花经采江左安．林．一．远．河右什．肇．融．恒．八师要说着于经序。故云出宅求车何小何大。灭城采宝孰近孰远。教凝于三一之表。果玄乎丈六之外也

第四非破非立者。然实未曾有三家义之可破。亦未曾有今义之可立。若有破有立即是可以言宣。何谓诸法寂灭相不可以言宣耶。肇公涅槃论云。须菩提无言以显道。释梵绝听以雨花释迦掩室于摩竭提。净名杜口于毗耶离。故口以之而默岂曰无辨。辨所不能言。即是法花言辞相寂灭。寂灭宁有破立之可存耶。若能如此照达。即是法花之宗旨也斯之四句盖经论之大宗。开道斥病之妙术也。必须采之以贯通众义

第三释经题目更开七门

一立名意门　二立名不同门　三转不转门　四具义多小门　五前后门　六翻译门　七释名门

第一立名意门者。涅槃经云。低罗婆姨实不食油强名食油。涅槃亦尔。实无名相强名相说。涅槃即是法花之异名。涅槃既无名相强名相说。法花亦无名相强名相说。所以强名相说者。欲令众生因名以悟理因理以起行因行以得解脱故也

二立名不同门者。众经或佛自立名。或待弟子发问。然后方立或序品之中预前立名。或正说之内方始立名字。或随说一义即立名字。或说一经竟最后制名。或一经之内但标一题。或一经之内立于多名。或有众经立于一名字。或有一部无别立名。立名不同略有五双十义。具如净名玄义已广述之。今此法花是佛于正说中自立名字。若依经佛但立一名。若法花论明一部始终。有十七种名字。如彼广说也

三转不转门者。一切佛经立名有二。一者名字古今不转。二者随佛出世名字改易。如涅槃云。或名法镜或云名甘露鼓等。今此法花经于二种中名字古今不转。故大通智胜佛．威音王．二万日月灯明．及释迦佛所说皆称妙法莲花。所以有转不转门者。盖是随宜不同。适时而说也

四具义多少门者。众经立名多小无定。或一义立名。或二义立名。或三义标名。一义立名者。或但人但法但处但时但事但喻。但人者提谓之流。但法者如涅槃之例。但处者如楞伽也。此翻为度处。但时者即时非时经也。但事者谓枯树经等也。但喻者金光明等也。二义立名者。或法譬双举。如妙法莲花。或人法俱题。如维摩诘不思议解脱等也。三义立名者。如胜鬘师子吼一乘大方便。胜鬘者谓为人名也。师子吼谓喻名。一乘大方便即法名也

五前后门者。依天竺梵本前皆无题。但云悉昙。此言好法亦名成就。立名皆在经末。而回后在初者盖是翻经之人随震旦国法。欲令因名字不同识部类差别故也

六翻译门者。依梵本云萨达摩分陀利修多罗。竺法护翻萨为正。故云正法花经。晋罗什翻萨为妙。故云妙法莲花经。迳山慧远双用前二更加两名。谓真法好法。今谓天竺一题名具含众义。译经之人随取一义故各别翻之耳。所言具含多义者。然诸佛所行之道未曾邪正。为对内外二邪故立为正。一者九十六种所说之法。称之为邪。如来所说之法目之为正。故对彼异道之邪明佛道为正。二者昔执五乘之异乖于一道名之为邪。所以然者。道尚无二。宁得有五。故执于五异乖于一道故称为邪。以对彼二邪故明佛所行道称为正法。言妙法者。诸佛所行之道未曾粗妙。为对二粗故叹美为妙。一者外道所说之法有字无义。是即浅近之法故名为粗。出世之法有字有义。目之为妙。二者对五乘之粗故叹佛乘为妙。又五乘是方便之说故称为粗。一乘是真实之法故称为妙。次言真法者亦有二义。一者外道之法目之为伪。诸佛所行称之为真如。涅槃云。是诸外道虚假诈称无有真谛。故明佛法有于真谛。次对五乘之伪以辨一乘之真。故方便品云。唯此一事实余二则非真。二尚非真况五乘实耶。言好法者亦有二。一对外道邪见名为恶法。诸佛法正见称为好法。涅槃经云。求二乘者名为不善。求大乘者名为之善善。即是好法

问。一乘教起但应对彼五乘。何故亦对外道耶

答。涅槃教乃斥三修比丘。而复简外道故。外道无有真谛及盗窃佛常。今明佛法为妙。岂不对外道非妙及五乘之粗耶

问。既具四名。何故独称为妙

答。凡有三义。一者经有妙文而无正称。如云我法妙难思。又云是乘微妙清净第一。即其证也。二者妙是精微深远之称立妙名。则称叹义。便以我法微妙凡夫二乘及以始行菩萨不能思量义。若云我法正难思义。则方言不巧于义不便也。三者次就义推。夫正以形耶受称。妙以待粗得名。宜以九十六法为邪。如来五乘之法称正。故正在五乘之法也。五乘虽正正而犹粗唯一乘之法乃称为妙。故妙主于一也。不得云外道为粗五乘为妙。亦不得云五乘为邪一乘为正。外道之形佛法其犹石之与玉。五乘之与一乘同皆是玉。但玉有精粗。故以五乘为粗一乘为妙也

第七释名门。今解达摩之法则释妙义。此经文虽七轴宗归一乘。宜以一乘之法为妙。故譬喻品云。是乘微妙清净第一。于诸世间为无有上。此偈对四乘之粗叹佛乘为妙。上半对二乘之粗叹佛乘为妙。下半对人天乘之粗叹佛乘为妙。是乘者谓佛乘也。微妙清净者叹佛乘也。以德无不圆故云微妙。累无不尽故名清净。又夫论累者所谓粗也。在粗既尽则众德并圆。累尽德圆故称为妙。又累无不尽。不可为有。德无不圆不可言无。非有非无则中道之法。故称为妙。同大涅槃空不空义。以空无二十五有。不可言有。有常乐我净。不可言无。而一乘与大涅槃更无有异。故譬喻品云。举大涅槃合于大车故。云不令有人独得灭度皆以如来灭度而灭度之。则其证也。所言第一者。方便品云唯有一佛乘无有余乘若二若三。则知第一之名对二三而起也。以二三乘累犹未尽德犹未圆。如涅槃云。二乘之人但见于空不见不空。故不行中道不得称为第一。诸佛如来德无不圆累无不尽。具见空与不空义。行于中道故称为第一也。于诸世间为无有上。人天为世间。世间乘则非妙。故云于诸世间为无有上也。上来总释偈竟。今次别释偈文。夫造十恶业报感三途故称为粗五戒招得人报则以人乘为妙。人乘乐少苦多故称为粗。十善感得天身则苦少乐多则天乘为妙。人天未勉生老病死故名为粗。声闻得出三界故名为妙。声闻福少钝根称之为粗。缘觉福厚利根名之为妙。声闻缘觉累犹未尽德犹未圆故称为粗。唯有佛乘德无不圆累无不尽故称为妙

问。今明一乘为妙与旧何异

答。释此经者凡有三说。一云。此经虽辨一乘之因犹感无常之果。是以文云过去过尘沙未来复倍上数。又药草喻品云究竟涅槃常寂灭相终归于空。终归于空者。终灰身灭智入无余涅槃。故犹是无常。至大涅槃方辨常住。既是无常则应是粗。但对前诸经未辨过去过尘沙未来复倍上数。故叹此经以为妙耳。若望涅槃教则犹是粗也。第二释云。此经已辨于常犹未显了。但是覆相明常。所以然者。此经未除八倒不明四德。但明寿命无穷故是覆相辨常。至涅槃教方显了辨常。第三释云。自小乘之教则辨无常覆相之说。一切大乘经皆是常住显了无余。今总评此三说。初释是下根之人。次释是中根之人。第三是上根之人也。所以然者。初释为谤法过甚深故是下根。次说毁呰少轻秤为中根。第三乃言究竟而封执成迷教故是上根人也。此皆就有所得中自开三品

问。初释云何谤法过深

答。今以四处征之。则知为谤深也。一用法花前教为难。二用法花正文责之。三寻关河旧说。四以义推难。法花前教。谓大小波若及净名等经。大品常啼品云。诸佛色身有去来法身无去来。金刚波若论云。三身异体故离彼是如来。故知如来非有为法。身即是常住。净名方便品云。此身可患厌。当乐法身。盖是毁生死身无常。即叹法身常住。故逼引之教成欣厌之观立。若生死无常法身复改起灭者。则同可厌弃。何所欣哉。故逼引之教不成欣厌之观行不立。弟子品云。法身无漏诸漏已尽。此明无有无常因也。法身无为不堕诸数。此明佛果无为常住也。寻波若净名。是法花前教当辨常住。法花居二经之后。宁是无常耶。次用法花文破之方便品云。我虽说涅槃是亦非真灭。诸法从本来常自寂灭相。此文明今昔大小二灭之真伪也。昔小灭非真灭。今大灭是真灭。昔小涅槃非真涅槃。今大涅槃是真涅槃。若尔者即昔小常非真常。今大常是真常。譬喻品云。但离虚妄名为解脱。其实未得一切解脱。声闻之人但断四住惑。名离虚妄。未断无明住地。即显今教具断五住地名一切解脱。若尔者小乘之人二生死之因未倾故是无常。如来五住地并尽所以是常住。乃至寿量品云。寿命无量阿僧祇劫常住不灭。文处甚多不可具列

问。若此经已明常住。何故寿量品云复倍上数耶

答。法花论云。复倍上数者示现如来常命不可尽故。则知此文非无常矣。三用关河旧释者。关中僧睿面受罗什法花其经序云。分身明其不实。寿量定其非数。分身明其不实者。释迦与诸佛互指为分身。则知俱非实佛。实佛者谓如来妙法身也。寿量定其非数者。寿者不可数。明如来寿命不堕诸数中。是常住。与法花论玄会也。又与净名经佛身无为不堕诸数其义同也。河西道朗着法花疏释见宝塔品。明法身常住理无存没。亦寿量品明如来寿量同虚空。一切世间唯身与命。今随从世法亦明斯两。故前明法身常后辨寿无灭。与涅槃经前明长寿后辨金刚身无异也。第四明用义难者凡有十义。一者此经虽明因果而妙义在果。因未圆极则犹未妙。若佛果犹是无常。无常则苦。既无常苦则无我不净。乃是粗法。何名为妙。二者经云。为一大事因缘故出现于世。何容终始以无常不了粗法以化物耶。此则乖父子恩情伤诸佛本意。三者前明一乘异昔三乘。后明常住异昔无常。以一乘异昔三乘故。得以一乘为药破于三病。以常异昔无常故。亦得以常住为药破无常病。则是双治之义。若今犹是无常者。但有以一破三。无有以常破无常。则治病未圆显理不足。四者若一乘异三而一乘之果犹是无常者。则还同昔异。终是三乘则无一乘教。都无两治也。五者又若今一异昔三而无常犹同昔。则因果果声闻果同罗汉。都非义也。六者前文明身子为请主。而身子小乘中之极执异之穷。故说一乘令改小入大舍异归同。则大有接小之义。小有欣大之理。则初分经机教符会。后分经弥勒为请主。弥勒是因位之穷无常之极。若说佛果犹是无常。则果无接因之理。因无欣果之义。便机教相乖也。七者天亲释寿量品明于三身。伽耶成佛为化身。久已得佛寿命无量为报身。无有生死若退若出非实非虚非如非异为法身。既具明三身。岂非是常住。八者涅槃经菩萨品云。如法花经八千声闻。得受记别成大果实。如秋收冬藏更无所作。故知法花显了究竟。岂不明常耶。九者二万日月灯明佛说法花经竟便入涅槃。当知说了义之法已竟然后灭耳。若未说了义之法则便不得灭也。十者若言品题如来寿量便是无常者。此有四句。一无量说无量。如涅槃云唯佛睹佛其寿无量。二有量说有量。如释迦方八十年。三有量说无量。如无量寿佛。四无量说于有量。如金光明经乃至此经。亦如花严云如来深远境界其量齐虚空也。次破第二说。谓此经是覆相明常者。是亦不然。即上十义明常显了。不应妄谓以为覆相明常。又此经开二方便门显二真实义。开二方便门者。谓乘方便身方便也。显二真实义者。谓乘真实身真实也。乘方便谓三因三果。乘真实谓一因一果。身方便谓生灭无常之身。身真实谓无生灭常住身。若犹是覆相。则是方便之门未开。真实之相未显

问。若此经已显了明常。何用涅槃更说也

答。众经明义各有大宗。法花广明一乘略辨常义。涅槃广明常住略辨一乘。所以然者。法花既明道理唯一。则知唯一佛性。既明寿命无尽。即知是常。不复广辨。但钝根人闻法花一乘不悟。广明佛性释成一乘。广明常义释成寿命长远。方得了悟

问。何故以知涅槃为钝根人说耶

答。此经明有二子。一不失心。二失本心。从花严至法花。为不失心子说并皆得悟之。不须说涅槃。失心子毒气深入失于本心。故闻法花不悟。唱灭说常方得解了。二者自说于法花已悟。闻说涅槃便复进解。三者复有众生不闻法花直闻涅槃而得悟者。相传云。宝性论云大品等为利根菩萨说。法华为中根人说。涅槃为下根人说。又如虽同是波若而波若有无量部。虽同明常明常何妨亦有多部耶。如七卷金光明已广明常住。可得不复说涅槃耶。次破第三。明此经已辨常住。此语应无简。然但今以正道望之犹未究竟。若执常住则计生死断灭。此乃是断常二见乖伤中道。故中论成坏品云。若有所受法则堕于断常。当知所受法若常若无常。故知有所得取着皆堕断常二见。既堕断常则非是佛亦不名为妙。外人问云。有所受法者不堕于断常。因果相续故不断亦不常。龙树答云。涅槃灭相续是则为断灭。此明得大涅槃灭生死相续故是断灭。得大涅槃常住则便是常住。经亦云。见生死无常名为断见。见涅槃常名为常见。故知执断常则堕二见非佛非妙

问。若三种释佛俱不成者。今云何辨佛而是妙耶

答。就龙树中论观如来品盛谈法身破十二种见。初明空有四句非佛。或言佛是世谛有。或言佛是真谛空。或言佛具有空有二谛所摄。或言佛非空非有出二谛之外。如此四见皆非法身。空有四句既非法身。常无常四句。边无边四句。义亦如是。外人问云。若有十二种计但非佛者。应无佛耶。论主答云。邪见深厚者则说无如来。故知非是无佛。外人又问。佛若非无便应是有。论主答云。如来寂灭相。分别有亦非佛也。外人又问。若佛非有非无者。云何运心观佛身耶。论主答云。如是性空中思惟亦不可得。故知微欲寄心则乖伤佛矣。若然者岂可用常住之见用为佛耶

问。盖是中论遣荡之言对邪之术耳。未知法花明佛。其相云何

答。中论云。如来寂灭相分别有亦非佛。法花云。诸法寂灭相不可以言宣。论主犹引法华寂灭相明于法身。论既辨法身出于四句。此经岂有不绝百非耶。故寿量品略明法身具足十不。谓不如三界见于三界。无有生死若退若出。亦无在世及灭度者。非实非虚非如非异。然能乘佛既非常非无常。所乘之法亦非常非无常。所乘之法亦非三非一。但为对昔三故强叹为一。为对昔谓佛无常故假说常耳。说一说常名为用妙。非常非无常不三不一言辞相寂灭秤为体妙

问。既以佛乘为妙。一化始终皆辨于佛。亦得并是妙不

答。约一化始终五种论之。一根本妙。二枝末妙。三摄末归本妙。四绝待妙。五无粗妙。根本妙者。谓花严之会明一乘因果究竟法身。故彼文云。欲令众生生欢喜善故现王宫生。欲令众生生恋慕善故示双林灭。如来实不出世亦不涅槃。何以故。法身常住同法界故。二枝末妙。于一佛乘分别说三。三中之二目之为粗佛乘为胜。故称为妙。故此经云。唯一事实余二则非实。三摄末归本妙。即此经中所辨佛乘究竟圆满。故称为妙。四绝待妙者。上来三种妙是皆对粗明妙。未是好妙。然第四妙非粗非妙。不知何以目之强叹为妙。故是绝待妙也

问。何处有此绝待妙文

答。涅槃云对苦说乐乐还成苦。非苦非乐方名大乐。又云不因小涅槃名大涅槃。故智度论云。十八空为相待空。独空非相待空。既有待不待二空。宁无待不待两妙。又罗什学士道场惠观着法花序云。秤之为妙而体绝精粗。寄花宣微道玄像表。颂曰是法不可示。言辞相寂灭。二乘所以息虑补处所以绝崖。作序竟示罗什。罗什叹曰。善男子自不深入经藏。不能作如是说也。又注法花经云。非三非一尽相为妙。非大非小通物为法。故知绝待释妙。关河旧宗也。五无粗妙者即净土法门。故香积菩萨云我土无有声闻辟支佛名。即无粗也。唯有清净大菩萨众。谓有妙也智度论云。七珍世界纯诸菩萨。亦是其事。此五种妙即是次第。又摄十方三世诸佛净秽二土一切教门

问。已知此经辨正果妙亦得辨因妙不

答。有人言。此经明因未辨佛性。但明万善缘因成佛。望前三乘之因故名为妙。若望后涅槃佛性正因。未是妙也。今以十种文义推之。不同此释。一者大乘若有三则有三性。既道理唯一佛乘。所以唯一佛性也。二者若言此经但明善人有佛性恶人无佛性异涅槃经者。常不轻菩萨见增上慢四众恶人云。我不轻汝等。汝等行菩萨道。必当作佛。法花论释云。示一切众生皆有佛性。故悉当作佛以此推之。知非善人独有佛性。又譬喻品劝信文云。汝等若能信受是语。一切皆当得成佛道。此分明说一切成佛岂简恶人。三者若此经但有一乘名故不明佛性者。盖是未识一法多名故生此谬耳。涅槃云。佛性有五名。一乘则五中之一。又言佛性亦一非一。云何为一。一切众生同一乘故为一。云何非一。非数法故。则知佛性与一乘皆是异名。四引例释之。若言此经无佛性语即是未明佛性者。涅槃花严无八识之名。亦无变易生死之语。则涅槃花严应未明八识及二生死也。五者宝性论云。究竟一乘经说有如来藏及三宝无差别。此经既明究竟一乘。则知亦辨如来藏。故信解品云。而不为我分别汝等当有如来知见宝藏之分。其证也。六者中论四谛品云。虽复勤精进修行菩提道。若先无佛性终不得成佛长行释云。如铁无金性。虽复锻炼终不成金。若此经不明佛性。虽修万善不得成佛。七者天亲释金刚波若上已明佛性。况法花耶。八者涅槃经引摩诃波若云。我无我无有二相。此明众生无我与佛性真我更无有异。而大品已明佛性。况法花耶。九者夫见佛性方得常身。寿量品既明常。岂得此经不明佛性。十者人语难依圣语宜信。天亲法花论七处明佛性。一者方便品云。唯佛与佛乃能究竟尽诸法实相。论云诸法实相者。谓如来藏法身体不变故。乃至释法师品云。知去佛性水不远故。以十种文义往推。即知此经已明佛性。即因门究竟谓因妙也。次释莲华经言。无名相法为众生故假名相说。欲令众生因此名相悟无名相。盖是垂教之大宗群圣之本意。所以无名相中假名相说者。如大品云。一切众生皆是名相中行。今欲止其名相故。借名相令悟无名相矣。通而言。妙法与莲华皆悉是名相。故经云。说大乘经名妙法莲华。据别而言。妙法则是无名而名。莲花是无相而相。故此经之题法喻双举名相俱陈也。旧云。外国称分陀利。此翻为连花。今谓分陀利未必翻为莲花。涅槃经云。人中莲花人中分陀利花。既其两出似如为异。今谓莲花为通。分陀利为别。所以然知者之凡引五证。一涅槃经迦叶问云。云何处浊世不污如莲花。佛具举优钵罗花．波头摩．拘物头．分陀利四花答问。即知莲花通四华故举四华答之。二者大品经有文列外国四华。谓优钵罗拘物头波头摩分陀利花。此有文列此土四花。谓青莲花乃至白莲花。三者地狱经云。优钵罗地狱形似青莲华。波头摩地狱其形似赤色。拘物头地狱其形示黄色。分陀利地狱形以。白莲花。四者悲花经列四华云。分陀利者谓白莲华。五者谓法显传及天竺诸僧皆云。分陀利者白莲华也。故知莲华是通白莲华是别。又此华凡有三时。未敷之时名屈摩罗。敷而将落名迦摩罗。处中盛时秤分陀利华即知分陀利是四色中是一色。三时中是一时。以其处中盛时荣曜备满足鲜白分明。以喻斯经也

问。即此法华有斯文不

答。妙音菩萨为弘通法花故。来化作八万四千众宝莲华阎浮檀金为茎。白银为叶。金刚为须。甄叔迦宝以为其台。即知是白莲华。以八万四千法藏皆摄入法华。今欲示弘白莲华经故前现白华之相也

问。智度论云。陆生华中须曼那花为第一。水生中青莲花为最上。今何故乃举白华为喻耶

答。青莲华形相则妙故譬如来之眼。白华所况为胜。宜喻于此经。所以然者。欲辨此经其义明白。故以白华为喻。何以知然。此经二章瑞相皆辨于白。初段放眉间白毫相光。开乘方便门显乘真实义。次见宝塔品初又放眉间白毫相光。欲表开身方便门显身真实义。以此经开二方便示二真实义最显明故。举白花为喻。二者白是众色之中本。明一乘为三乘之本。故于此一说三。说三为一。令归于一法身一。法身垂于应迹说于应用。为令悟于法身。故初章以一乘为本。次段以法身为本。欲显二本之义故。以本色为名。三者驾御大车即是白牛。白牛喻平等大慧。无有漏之垢故秤为白。此经文虽七轴宗归大慧。故举白牛为喻也

问。无漏出何文

答。方便品云。又告舍利弗无漏不思议甚深微妙法唯我知是相。十方佛亦然也。四者乃至普贤乘六牙白象护人通法。亦显菩萨所乘之法德无不圆累无不尽。故乘六牙白象王来也

问。于四花中何故不借余二为喻

答。屈摩罗时华犹未开形相未妙。喻昔来诸教未开方便门未显真实义。故不得喻于此经。迦摩罗时花既将落形好欲毁。喻法花后教已开方便门已显真实义。亦不得喻于此经。唯分陀利处中盛时形相可爱。喻于此经正开方便门正显真实义微妙第一。故华有三时。喻教有三种。故法师品云。已说今说当说中此法花经最为第一

问。何故举莲花为喻

答。略有三义。一者离喻。二者合喻。三者遍喻。言离喻者又有三义。一者此花不有而已。有则花实俱含。此经不说而已。说则因果双辨。故以莲花喻于因果。二者由花开故而实现。由言教故而理显。故以莲华喻于理教。是以经云其义深远其语巧妙。三者花未开而实未现花开则实方显未开方便门则真实相未显。开方便门则真实相方显。故以花开喻方便门开。实现譬真实相显也。次合譬者略明十义。一者此花从种而生。喻一乘必有其种。颂曰。天人两足尊。知法常无性。佛种从缘起。是故说一乘。二者此花从微至粗。喻佛乘渐渐增长。颂曰。渐渐积功德具足大悲心如是诸人等皆已成佛道。三者此花增长满足出浊泥水。喻佛德无不圆累无不尽出离生死诸浊泥水。颂曰。如来已离三界火宅寂然闲居安处林野。四者此花虽出泥水而不舍泥水。喻佛虽出四流之外不舍三界之中。颂曰。是时长者在门外立惊入火宅方宜救济。五者此花微妙鲜洁第一。如佛乘五乘中第一。颂曰。是乘微妙清净第一于诸世间为无有上。六者此花为凡圣称叹爱敬。佛乘亦尔。为世间出世间凡圣称叹爱敬。颂曰。佛所悦可一切众生所应称叹供养礼拜。七者此华台叶具足。喻佛乘万德皆圆满。颂曰。无量亿千诸力解脱禅定智慧及佛余法。八者此华诸佛菩萨而坐其上。大乘亦尔。为诸佛菩萨而住其中。颂曰。佛自住大乘如其所得法定慧力庄严以此度众生九者此花开合有时。喻一乘之法隐显有时。昔日即隐今日即显。颂曰。所以未曾说说时未至故今正是其时决定说大乘。十者劫初成时大梵天王坐莲华座。为一切众生之父。妙法莲华亦是三世诸佛根本。药王品云。如大梵王为一切世间之父。此经亦尔。为一切贤圣学无学人及发菩萨心者之父。普贤观经云。方等经是诸佛眼。诸佛因是得具五眼。佛三种身从方等生。是大法印印涅槃海。所以方等生三种身者。由方等故了悟实相断诸烦恼。断诸烦恼故法身现。法身现故有应身有应身故有化身。有三身故说十二部经。说十二部经故有法宝。有法宝故有僧宝。故有三宝。故有世间三善道。故知法华是世间出世间本也

问。法华论释云何

答。论云。以佛乘出离二乘浊泥水故。喻如莲华。又云此花诸佛菩萨而坐其上。此经亦为令舍二乘鄙贱之人同得入一乘。与诸佛菩萨同坐妙法莲华之坐。故借莲华为喻。犹是十义中两义耳。三遍喻者大集经云。慈悲为茎。智慧为叶。三昧为须。解脱为敷。菩萨蜂王采甘露味。是故我礼妙法莲华也

第四辨教意门。南方五时说北土四宗论无文伤义。昔已详之。今略而不述也。夫论四生扰扰。为失虚怀。六趣纷纷寔由封滞。故知回流苦海以住着为源。超然彼岸用无得为本。但累果非一故息倒多门。或始终俱大。或初后并小。或始小终大。或始大终小。或一时之内大小俱明。或无量时唯辨一法。或说异法而前后不同。或明同法而初后为异。良由机悟不一故适化无方。不可局以五时限于四教也。所言始终俱大者。如涅槃云。我初成道已有菩萨曾问是义。与汝所问等无差别。故知后辨涅槃初亦辨斯教。初后俱小者。如智度论云。从初转法轮至大涅槃集作四阿含。即其事也。初小后大者。鹿园初说小乘。鹫山已去明于大法。初大后小者。菩提树下初说花严。后趣鹿园方明小教。一时之内大小俱明者。如智度论云。显示教门即波罗捺园说大小。秘密之法则双林明大小。或无量时明一法者。如智度论云。波若非一坐一时说也。或说异法前后不同。者如智度论云。须菩提闻法花经辨一切成佛。复闻波若明菩萨有退。故今问此菩萨为毕定为不毕定。法花波若名为异法。而波若或在法华之前或在法华之后。故前后不同

问。何以得知在法华前说耶

答。智度论释三百比丘脱衣上佛云。有人言。十二年未制戒。即知波若在十二年已前说之。法华成道已来四十余年方乃演说。又信解品云明付财竟后方会父子。亦是波若在前法华居后。而向所引毕定品文即法花在前波若居后。或明同法而前后为异者。如五时同是波若之法。而仁王经云。二十九年说四种波若。第三十年说仁王波若。如是等事不可具陈。略举八条示圣教无方。不应限局五时及四宗之义也

问。若尔者则大小无分浅深浑乱。何得论明声闻菩萨两藏经开大小二种乘耶

答。佛教虽复尘沙今以二义往收。则事无不尽。一者赴小机说名曰小乘。赴大机说称为大乘教。而佛灭度后集法藏人。摄佛一切时说小教名声闻藏。一切时说大乘者名菩萨藏。则大小义分浅深教别也

问。何以得知唯有两藏

答。中论云。前于声闻法中说十二因缘。后为已习行堪受深法者。以大乘法说因缘相故。智度论云。阿难迦叶结集三藏。弥勒阿难文殊结集大乘藏。地持论云。十二部经名声闻藏。方等经名菩萨藏。而大品．思益．法华．涅槃此四经。皆对昔小秤赞今日大。则知一化始终俱明大小二教也

问。此经云唯有一佛乘。云何乃立大小二耶

答。如来赴大小二缘故说大小二教也。虽说二教终为显一乘故。药草喻品云。于一切法以智方便而演说之。其所说法皆悉到于一切智地。故知教无异表缘无异悟。然对异故明不异。在异既无则不异亦息。故云是法不可示言辞相寂灭。若守大小二藏及封执唯一乘者。此皆成一异两见。未悟本来寂灭。非学佛法人也

问。就法华始终有几种教

答。或一教二教三教四教乃至十教。言一教者。一切皆是一乘教。如药草喻品云。于一切法以智方便而演说之。其所说法皆悉到于一切智地。以所表理既无二。能表之教亦一也。言二教者。谓大小乘二如上说也。言三教者。谓根本法轮．枝末之教及摄末归本。亦如前说也。言四教者。方便品偈文明于四教。谓四调柔。一以人天乘调柔令离三涂。次以二乘调柔令离三界。此二调柔令离界内惑也。三以自教调柔。令二乘人得口自说大法以自知教调伏其心。四以他教调柔。诸佛菩萨为其说大法令小入大。此二教使其离三界外小乘惑也。此四调柔二乘人令入一乘。为一乘之方便也。故信解品云。如富长者以方便力柔伏其心乃教大智也。言十教者。一者顿教。谓初成道时即以大乘顿化穷子。但根性未堪。是故息化也。二者渐教。从说人天乘乃至法华。皆是渐说大乘也。然顿教正化直往菩萨。渐教则化回小入大人也。就渐教之中复开二种。一世间教。即人天乘。如冷水洒面譬也。二出世间教。从趣鹿园说二乘教。终竟法华也。就出世间教中复有二种。一小乘教二大乘教。初趣鹿园说小乘教。从波若已去谓大乘教也。就大乘教中复有二种。一者自说大乘。即大品付财命说之事。二者他教。从大品已后诸方等教。佛与菩萨为小乘人而说大乘也。此二种教谓密说大乘。至于法花谓显教小乘人大法也。此之五双十教并现信解品文也

问。大品等但是渐说大乘亦是顿耶

答。凡有四句。一顿而非渐。则初成道为诸菩萨说花严教也。二渐而非顿。谓人天及二乘教也。三亦渐亦顿。即大品教也。为菩萨说大品。大品于菩萨为顿。以大品中具足明一切大乘法故。信解品云。佛敕我等说最上道。修习此者当得成佛。故名为顿。而命小人说于大法。为入一乘方便故。于小乘人名为渐也。四者非渐非顿者。上之三句并是教门。因此教门欲显无言之道。不可论其渐顿也

第五明显密门又开四别。一通就诸经论明显密。二别举大品对法花论显密。三就法花内自论显密。四料简之。总明经论显密者。大明一化凡有四门。一显教菩萨不蜜化声闻。即花严教也。大机已熟故显教之。小器未堪不宜密化。故罗烈珍玩正为宗亲。穷子躃地未堪授珍宝故。二显教声闻不蜜化菩萨。即三藏教也。诱引将顺正为二乘。更遣余人不蜜化菩萨。三显教菩萨蜜化声闻。即波若教也。严土化人正教大士。付财命说密化小心。四显教菩萨显化声闻。即法花教也。大士疑除故显教菩萨。罗汉作佛故显化声闻。此之四门即是次第。三句属菩萨藏收。显教声闻不蜜化菩萨属三藏教摄。然华严大品及以三藏当教明义唯有一辙。法花结会始终是则具足四门

问。若华严但显教菩萨不密化声闻者。则应但明大法。何故亦辨小乘。如贤首品云。或说声闻小乘门。或说缘觉中乘门。或说无上大乘门。乃至性起品中具说五乘之教。何由尔耶

答。总谈一化复有傍正四门。一正显真宝傍开方便则华严教也。为诸菩萨说究竟因果故正显真实。夫为菩萨必须化物故。亦令大士知三乘是权。故傍开方便。二正闭方便正隐真实。则三藏教也。不明三乘是权故正闭方便。不显唯有一乘故正隐真实。三者正显真实傍闭方便。则波若等教。明大乘究竟故正显真实。未开三乘是权故傍闭方便。四正开方便正显真实。即法花之教。以辨三乘是权故正开方便。明唯有一乘故正显真实

问。法花明三乘是权。可得显一乘是真实。大品未辨三乘是权。云何得显一乘是真实耶

答。法华对权显实。大品辨二乘为劣大乘为胜。故以大乘为真实也

问。何文辨法花与大品已明真实

答。信解品云。一切诸佛所有秘藏但为菩萨演其实事而不为我说斯真实。故知大品已显真实。又大品自为菩萨说故。显佛乘是真实。未为声闻说佛乘故。不明三乘是方便。法花正为声闻人说佛乘是真实。故开三乘是方便

问。若大品明小乘为劣大乘为胜名已显真实者。三藏之教亦明二乘为劣大乘为胜。亦应已显佛乘是真实

答。大品等教正明大乘傍及小乘。故正显真实。三藏之教正明小乘傍及佛乘。故不正显真实。又大品教具足显了说佛乘。故正显真实。三藏之教虽明佛乘犹是隐覆之说。故不正显真实。何以知然。如三藏教明王宫实生双林实灭从凡得圣树王成佛。故法花云。长者脱珍御服着弊垢衣。以是方便得近其子。此是说三藏教中佛明是方便。故知明小教虽明佛乘为胜。犹未显真实。此傍正四门三句属菩萨藏。正闭方便正隐真实属声闻藏。余经当教明义唯有一门。法华结会始终具足四句。此皆一途依信解品大判为言。众经更异文。亦有别余义也。第二大品对法华论显密

问。智度论第一百卷云波若非秘密法故付属声闻。法花是秘密法故付属菩萨。云何称秘密非秘密耶

答。秘密不秘密有二门。一以大乘为秘密。小乘非秘密。大乘甚深不妄传授故秤秘密。小乘浅近可随宜而说故非秘密。如智度论云。显示教中说罗汉断烦恼清净菩萨未断烦恼故不清净。秘密法中说诸菩萨得无生忍具六神通超出二乘之上故菩萨清净。此则以小乘浅近故非秘密。大乘甚深故名秘密。二者就大乘中复有秘密非秘密。如大论第百卷说。波若不明罗汉作佛故非秘密。法花明罗汉作佛故是秘密

问。法花明罗汉作佛。何故是秘密波若不明罗汉作佛。何故非秘密耶

答。法华明罗汉作佛甚深难解故是秘密。波若明菩萨作佛其义易解故非秘密。故智度论云。罗汉作佛至佛时乃解。论甚深者正可论其余事。龙树既云未解至佛时乃知。故罗汉作佛甚深难解。涅槃现病品偈云。如佛所说阿罗汉一切当皆至涅槃如是甚深佛行处凡夫下愚不能知。故知罗汉作佛为难解也

问。罗汉作佛何故难解耶

答。此望昔教为言故秤为难解。以昔教明罗汉烦恼已尽不复更生。如无明糠脱故后世因中不复更生。今教遂明罗汉作佛故。于昔教为难解

问。昔教于谁为难解耶

答。正于声闻人为难解。故论云。大药师能用毒为药。小药师不能用毒为药。菩萨能解二乘作佛。如解毒为药。故法花付属菩萨。声闻但解菩萨作佛。如解用药为药故。波若付属声闻。不解二乘作佛。如不解用毒为药故。法华不付声闻。所以法华于声闻人为难解

问。若波若但明菩萨作佛未明二乘作佛。则波若教劣。法华明菩萨作佛复明二乘作佛。则法华为胜。何以得知然。智度论释问乘品列十种大经。法云经大云经法华经。如是等经中而波若最大。既称最大。则法华为劣。前后相违。云何会通

答。法华波若互有胜劣。若为声闻人明二乘作佛。则法花胜波若为劣。若为菩萨明实惠方便。则波若胜法华劣。所以然者。波若六十六品辨于实惠。无尽品已去二十四品明方便惠。此二惠是为十方三世诸佛法身父母。故净名经云。智度菩萨为母。方便以为父。一切诸导师无不由是生。既广明法身父母。故于一切方等经中最为深大。余经不正明此义。故不及波若。又波若广明实相。故于众经中最为深大所以然者三乘得道及以断惑辨忏悔重罪。此之三义悉依实相。而波若正广明实相。故三义得成。余经不正明实相。故有劣波若是以两经互有优劣。破龙树前后有于二文

问。此解何所出也

答。睿师小品序说波若法花二经互有优劣之义云。法华镜本以凝照。波若[穴/俱]末以解悬。解悬理趣菩萨道也。凝照镜本结其终也。终而不泯则归途扶蔬有三宝之迹拥惠不夷则乱绪纷纶有惑趣之异。是以法华波若相待以期终。方便实化[穴/俱]一以俟尽论其穷理尽性夷明万行。则实不如照。取其大明真化解本无三。则照不如实。照则波若。实则法华。故互有优劣。则其证也

问。若二经互有优劣。何故智度论复云法华是波若异名

答。波若法华同是正观平等大慧。显道无异故云法华是波若异名也。是以论云。波若是一法佛说种种名。随诸众生力为之立异字。今但约教为人故有差别。波若教明直往菩萨作佛。法花教明回小入大菩萨作佛。经约人不同而作佛无异。如长者大宅及以七珍始终无异。但付财之时未得说穷子是长者儿。委家业时始得会其天性以为付子之也

问。波若未明二乘作佛。得是不了教不

答。波若明菩萨作佛。此事显了。于时大机未熟故不得说二乘成佛。约此一边。亦得称为不了

问。若尔何得论释毕竟定品云。须菩提闻法花经明一切成佛。复闻波若辨菩萨有退。是故今问佛为毕定为不毕定。此问意审二经之同异。佛答云菩萨毕定。毕定者毕定成佛也。既明毕定成佛。则唯有一佛乘。不退为声闻则显无二乘。此意明波若同法华教。何得云波若未明二乘作佛

答。已如前通。波若非一时一座说。初分未明二乘作佛。故与法花异。后分明菩萨不退显有一无二。与法华大同。故不相违也。第三就法华自论显密

问。若法花显教菩萨显化二乘者。则法花是显了之教。始终应无覆相之说。若尔化城品明三千墨点犹为十六王子沙弥之位。寿量品明五百万亿阿僧祇世界末为微尘成佛已来复过是数。则寿量之佛是显了之言。十六王子便是覆相之说。何得一部皆显了耶

答。夫立教隐显要炉冶始终。今约一经大分四辙。一[雨/復]而不开。二亦开亦覆。三开而不[雨/復]。四不开不[雨/復]。[雨/復]而不开。初之一品嘉瑞交兴妙轮将转而未弊二权。犹隐两实。谓覆而不开。亦开亦覆者。始从方便品终竟法师品但明乘权乘实。所谓亦开。犹隐身权身实。秤为亦[雨/復]。故三千墨点始开结缘之始。十六数犹掩成佛之初。开而不[雨/復]者。即后分经也。俱废二权双显两实。则教无纤隐理无豪翳。致有十二深益八种嘉瑞。不开不[雨/復]者。夫借一以破三。三除而一舍。假修以斥短。短息而修忘故言穷虑绝。何实何权。本性寂灭。孰开孰[雨/復]理。超言外强秤妙法道玄像表假喻莲花。第四料简显密

问。小乘亦是说密一乘不

答。佛说小乘意在悟大乘。故说小乘亦是密说一乘也

问。小乘就何文是密说一乘耶

答。如云三乘人同得人无我同断烦恼同入无余。即是密说三乘同归一道也

问。大品唯付财。是密说一乘。更有余义耶

答。大品中明三乘人同是一如同入法性。即是密说三同入一乘

问。显说一乘为何人耶

答。为三种人。一者为不定根性声闻令入一乘。二者为练已定根性声闻令入一乘。三者为直往菩萨令知有一无三但进不退也

第六论三一义。此经始末论三一开会凡有十门。一者开三显一。二者会三归一。三者废三立一。四者破三明一。五者覆三明一。六者三前辨一。七者三中明一。八者三后辨一。九者绝三明一。十者无三辨一也。开三显一者。开昔三乘是方便示今一乘是真实。故云开三显一也。会三归一者会彼三行归一佛乘。故云汝等所行是菩萨道也。废三立一者。废昔三教立今一乘教。故云于诸菩萨前正直舍方便但说无上道也。破三明一者。破其执三异实之情以明一乘之道也。故文云唯有一乘法无三也。覆三明一者。如来赴三一两缘常有三一之教。昔则以三覆一。今则以一覆三。三前明一者。未趣鹿苑之说三前。寂灭道场已明一实之教。谓三前一也。三中明一者。从趣鹿苑说于三乘佛乘第一。缘觉第二。声闻第三。谓三中明一也。三后明一者。三乘之后法花教门以会彼三乘同归一道。谓三后明一也。绝三明一者。如无言世界。外则无言无示内则无虑无识。故不论一三而已。即以此为佛事故则复是一。故云绝一也。无三辨一者。如香积菩萨云。彼土无有二乘名字。谓无三辨一也。但有清净大菩萨众。谓有一也。前之五种就义论一也。后五种约时处前文不同教门差别。故开五也

问。云何名会三归一耶

答。欲识会三归一。先须知开一为三。开一为三者。昔指大乘之因说为小乘究竟之果也。今还指小乘究竟之果即是大乘之因。故名会三归一也

问。小乘人谓是究竟。为是迷因为是迷果

答。实是大因谓是小果。故是迷因也

问。一三有此十句。近远亦有十门耶

答。亦有十门。如寿量品文疏已出也

问。今明一乘。为是三中一为三外有一耶

答。此经始终具有二义。一者犹是三中一。所以然者。以叹五乘摄乘义尽。人天乘则摄世间乘。三乘摄出世间乘若尔则一乘犹是三乘中之佛乘也。故文云十方佛土中唯有一乘法无二亦无三。此以一二三为数。则以一乘为一。缘觉为二。声闻为三。则知一乘犹是三中一也。又文云但以一佛乘为众生说法更无有余乘若二若三。此明以佛乘为一声闻缘觉二乘为余乘。故下文言更遣余人。则知余人属二乘也。既言无有余乘。则无缘觉之第二声闻之第三。故知佛乘犹是三中之一。此文其例甚多不须疑也。二者一乘非是三中之一。如信解品说。长者以方便力密遣二人。则以二乘为方便。脱珍御服着弊垢衣。方便附近子语令勤作。则佛乘亦是方便。则知三乘并是方便。今明一乘是真实。故知一乘非是三乘中之佛乘也

问。以何义故明一乘是三乘中佛乘。复以何义明一乘非是三乘中佛乘耶

答。欲明三乘摄出世乘尽故。对二乘之方便明佛乘是真实。故文云唯此一事实余二则非真。所以明一乘是三乘中之一也。就佛乘中复自开真应。昔为二乘人说佛方便身故佛乘是方便身。即以今教明佛身是真实故。真实之乘异方便佛。如师子座长者异着弊垢衣长者。以约今昔两教明佛有权实不同。是故一乘非三乘中之一也

问。此经中始末或言佛以方便力示以三乘教则三乘并是方便。又云唯此一事实余则非真。是则二方便。两文相违。何以通会

答。此二文犹是一义。无相违也。于一佛乘方便说三。次云一乘是真实二乘是方便。如人手内实有一果方便言三果。次第考论者。一果是实。二是方便。故说三说二并是方便犹是一义不相违也

问。为会三归一。为会二归一

答。此且犹是一义智度论云。于一佛乘开为三分。如人分一斗米为三聚。亦得合三聚为一聚。亦得会二聚归一聚会三会二犹是一义不相违也

第七明功用门

问。何故受持读诵书写解说供养恭敬尊重赞叹。障累内消祥瑞外发耶

答。昔有天竺僧弼法师云。此经有三义故胜。一者众经不泯三为一。此经独三泯。二持者现得六根清净。三普贤等诸菩萨亲乘六牙白象来护人通法。故障累内消祥瑞外发。今明不正有此三事。此经是众经之实体也。诸佛之秘密藏。融释大小该罗今昔。理致渊远超四句之表。有十事奇特出众经之外。言十事者。一者化主不可思议余经或释迦自说或四佛共谈。至如法花十方分身俱来法会。三世等觉同赴鹫山。是以文云。一一方四百万亿那由他国土诸佛如来遍满其中。如是十方诸佛皆悉来集坐于八方。此谓现在佛集。多宝佛踊现明过去佛集。现在有十方佛。过去但明多宝者。法花论云。此以略摄广。明一佛之用总摄过去一切佛用。即与现在广略互现。诸大菩萨普会鹫山。谓当来佛集。以三世等觉同赴鹫山。大小诸经未有如斯之盛集。谓化主不可思议也

二者徒众不可思议。八方世界一一方四百万亿那由他国土诸佛各将侍者。又下方千世界微尘数菩萨从地涌出遍满虚空。乃至沙竭龙宫不可思议大士云集灵鹫山。虽复鹿园禀道之众鹄树闻经之宾。亦未有如斯之盛集之也。是谓徒众不可思议也

三者国土不可思议。灵塔踊现普集分身三变八方同为净土。乃至神力品云于时十方世界通达无碍如一佛土。至如仙人苑内匹此太遥。力士河边方斯亦远。是为处所不可思议也

第四者教门不可思议。如方广花严偈凡十万偈。摩诃波若数亦同然。如此等经尚以为多。至如大通智胜所说恒河沙偈。威音王佛所明二十千万亿那由他偈。所以辨其文多。意欲显其义广。是谓教门不可思议也

第五者时节不可思议。灯明佛说此经六十小劫。大通佛所说八千劫。妙光菩萨八十小劫。十六沙弥八万四千劫。释迦佛时踊出大士问讯之间五十小劫。说经之时当不可量也。所以辨说经时长。亦为显文多义广。是谓时节不可思议也

第六者神力不可思议。将开波若时。释迦独出现灵祥。欲震金鼓四尊共呈嘉瑞。未若斯经十方分身共现七种神力满百千岁然后摄之。是为神力不可思议也

第七者利益不可思议。如分别功德品明。闻经得十二种利益。始自无量恒河沙菩萨悟无生忍。终则八方世界微尘数众生发菩提心。如调达药王妙音观音陀罗尼妙庄严王本事普贤劝发。总陈八品得道者不可具陈。谓利益不可思议也

第八者功德不可思议。从初至后叹法美人功德无量。如随喜品说。第五十人闻一偈随喜转教。胜于施四百亿万阿僧祇世界六趣众生一切乐具及令得阿罗汉果。是为功德不可思议也

第九者明乘权乘实不可思议。如三藏等教唯辨小乘。波若诸经但明大乘。未若法花说实归本泯寂异途。开会一三融释大小。使羊鹿无息驾之累。白牛有直进之功。是为乘权乘实不可思议也

第十者身权身实不可思议。余经或但明生法。或直辨三身。至如多宝踊现示真常应灭。分身向集表本一迹多。并开近显远囊括古今。使悟应灭难期知长短无二。令菩提心力坚固猛利念佛三昧倍复增益。是为第十身权身实不可思议也。后之二事盖是一经大宗。即以释前八事。所以有前八不可思议。有良由此经具开二权双示两实故也

第八弘经方法

问。寻如来出世善巧化人。四依菩萨妙能通法。末世凡夫云何弘经

答。法师品云。佛灭度后若有善男子善女人欲说是经者。当安住三法。一者入如来室。二者着如来衣。三者坐如来座。入如来室者。大慈大悲心是也。如来衣者。柔和忍辱心是。如来座者。一切法空是。具此三法然后以不懈怠心为四众说法。佛垂妙轨。宜可依之。慈悲有隐覆之功。喻之如室。柔和忍有障弊之用。喻之如衣。空理可以安心。目之为座。详此三门则为次第。大悲拔苦大慈与乐。盖是种觉之洪因弘道之本意。欲说妙法。宜前建此心。是故第一明入如来室。既于极恶之世欲弘穷善之道。必多留难。宜应忍之。是故第二明着如来衣。虽复慈悲外覆和忍内安。若无空观虚明则二行不成。何由悟物。是故第三辨坐如来座。内备三心外勤说法。则道无不隆人无不利。故令安住三法弘法花经

问。何故起慈悲名入如来室

答。譬喻品云。我亦如是众圣中尊世间之父。一切众生皆是吾子。则知此经明父母之道。父则有乐无苦。子则有苦无乐。今大悲拔子之苦。大慈与子之乐。令一切众生普皆成佛。故说法花经。末世法师既代佛弘经。亦宜学佛之行。是故慈悲名如来室。若为利养名闻胜他势力而讲说者。则不拔苦与乐。乖父子恩情。非弘佛乘之道也

问。何故柔和忍辱名如来衣

答。譬如稚子未有所知兼为恶鬼之所娆乱。如毁辱于父父则生愍恻。勤加救疗不起嗔心。此经既明父子之道。一切众生观力未成。为烦恼鬼之所娆乱。若毁辱于佛佛深生怜愍。以妙法花药勤救治之不生慎恨。末世法师既代佛弘经。亦应学佛和忍。若起嗔恨便与佛乖。非弘佛道矣。是故柔和忍名如来衣

问。法师品云。是法花经如来在世犹多怨嫉。况灭度后。何故说此经时多留难耶

答。世人云。良药口苦美言逆耳。此经废五种乘之异执立一极之玄宗。故斥凡呵圣排大破小。指天魔为毒虫。说外道为恶鬼。贬执小为贫贱。挫菩萨为新学。故天魔恶闻。外道逆耳。二乘惊愕。菩萨怯弱。如此之徒喜为留难。世间多怨嫉言。岂可虚哉。又一切众生无始已来多起十恶业。小有人天之因起人天之因。尚少求二乘者转希。学佛道者弥复难得。所以然者。若不起凡见圣见。舍小心发大心。种中道善根。然后始得闻一乘极教耳。但众生皆有凡圣大小之障。闻说一乘。不能信受故喜为留难

问。何故知一切法空名坐如来座

答。毕竟空观者为成二行及辨弘经大宗。为成二行者虽有慈悲。若无空观者。则见有众生众生成缘。名凡夫慈。若无空观者则见有诸法成于法缘。成二乘慈。是以知一切法空。不见有众生及以诸法。而起慈者名无缘慈。无缘慈者谓如来慈。故以毕竟空观成慈悲行。若无空观而起忍者。则不成无生忍。亦非法忍。以有毕竟空观而起忍。则成无生忍及以法忍。故此和忍是如来忍名如来衣。次明毕竟空观成弘经大宗者。若无空观则破三着一。粗惑虽去细染寻生。以有空观虽复破三心不染一名无所得也。又药草喻品云究竟涅槃常寂灭相终归于空。即知空为诸法之体。昔说五乘谓从体起用。今会五为一则摄用归体。故言终归于空。为诸法之体。今既弘法则宜识其体。识体故则识其用。体用具足方可弘经也。又但明三法者。夫为法师要具三事。一入讲堂。二被法服。三登高座。若无慈悲则不入讲堂。心不和忍便无法服。若无空观则不登高座。党阙此三事安可弘经。说法既具此三事。受持读诵等乃至四威仪三业皆须安住此三也。悉合此三门以为二义成十种法师

一者慈悲忍辱名之为行。观毕竟空秤之为解。谓解行法师。自有解而无行。有行而无解。无行无解。有行有解。前三可为弟子。后一方是法师

二者慈忍为福德。空观为智慧。谓福慧法师。是故经云具二庄严能问能答

三者大品经云。住于二法魔不能坏。一者知一切法空。二者不舍一切众生。若见有众生不知诸法空。即堕有边。为魔所坏。若知诸法舍于众生。则堕空边。亦为魔所坏。今具此二法。则远离二边常行中道。即魔不能坏。堪于后世为物弘经。谓难坏法师

四者净名经云。譬如胜怨乃可为勇。如是兼除老病死者是菩萨心。以修空观所谓自行。慈悲和忍所谓化他。具自行化他谓雄勇法师

五者知诸法空越凡夫地。具于慈忍超二乘境。非凡夫行非贤圣行。是菩萨行。谓道行法师也

六者大品经云。菩萨住于二谛为众生说法。常行慈悲忍住于世谛。知毕竟空住第一义。以依二谛为物弘经。则所言不虚。谓诚谛法师

七者智度论云。解四悉檀则知十二部经八万四千法藏无相违背。今常行慈忍谓三悉檀。知毕竟空了第一义作四悉檀。为物弘经则识一切教无相违背。谓无诤法师

八者即此经云。又见佛子定慧具足。以无量喻为众讲法。常行慈忍名之为定。知毕竟空目之为慧。以具足定慧为物弘经故。名具足法师

九者即此经云。又见佛子心无所著。以此妙慧而求佛道。以观毕竟空故不着生死。常行慈悲故不住涅槃。于生死涅槃心无所著。谓无所著法师

十者摄大乘论云。知诸法空名为菩萨。常行慈忍谓摩诃萨。谓菩萨摩诃萨法师。又安乐行品云。辨于四行亦示弘经模轨。具如文疏述也

第九明部党不同。此经有新旧二本。古本名正法花。炖煌同处沙门竺法护以晋太康七年或人云十年八月十日译出此经。授优婆塞聂承远。九月二日讫。张士明张仲政笔受也。新本名妙法莲花。罗什以魏秦姚兴弘始十年二月六日于长安大寺译出。亦云弘始五年四月二十三日于长安逍遥园译出也。即晋．安．帝时观睿二法师并云。弘始八年集四方义学沙门二千余人译出斯经。睿公云。于时听受领解之僧八百余人。皆是诸方英秀一时之杰竭也。今谓十年翻译字之误也。罗什以秦弘始三年二月二十日至长安。弘始四年正月五日即就翻经。弘始八年八月二十日终于长安。不应十年更翻译也。又胡僧枝[彳*(苗/一/田/一)]魏甘露元年于交洲译出六卷。名法花三昧经。又沙门支道良晋代康元年抄译为五卷。名方等法花经。此二本南土皆无也。唯有一卷法花三昧经。又有一卷萨昙分陀利经。当别寻经目录也然晋有前后。昔有江右名为西晋。此经犹居外国自从无王度江左称为东晋。至晋安帝义熙中此经始度。然此经度江将三百年矣

第十明讲经原由。经既有二本。初讲亦有两人。汉地以竺法护为始。护公以永熙元年八月二十八日。比丘康那律师于洛阳写正法花经竟。与法护口挍古训译出深义。九月本齐十四日于东牛寺施设檀会讲此经竟。日昼夜莫不欢喜。次新翻法花竟。道融法师于长安讲之。开为九辙。时人呼为九辙法师。自尔已后著述讲说者不可具陈也

法华游意


法华宗要

    No. 1725 [cf. No. 262]

法华宗要

        元晓师撰

将欲解释此经。略开六门分别(初述大意次辨经宗三明诠用四释题名五显教摄六消文义)。初述大意者。妙法莲华经者。斯乃十方三世诸佛出世之大意。九道四生灭入一道之弘门也。文巧义深。无妙不极。辞敷理泰。无法不宣。文辞巧敷花而含实。义理深泰实而带权。理深泰者。无二无别也。辞巧敷者。开权示实也。开权者。开门外三车是权。中途宝城是化。树下成道非始。林间灭度非终。示实者。示□生并是吾子。二乘皆当作佛。算数不足量其命。劫火不能烧其立是谓文辞之巧妙也。言无二者。唯一大事。于佛知见开示悟入无上无异令知令证故。言无别者。三种平等。诸乘诸身皆同一揆。世间涅槃永离二际故。是谓义理之深妙也。斯则文理灭妙无非玄。则离粗之轨乃称妙法。权华开敷实果泰彰。无染之美假喻莲花。然妙法妙绝。何三何一至久至冥。谁短谁长兹□□总入之不易。诸子澜漫出之良难。是如来引之□权羡□车。于鹿苑示有□之粗身。驾白牛于鹫岳显无限之长命。斯乃□一以破三。三除一舍。假□以□短。短息而□忘。是法不可示。言辞相寂灭。荡然靡据。肃焉离寄。不知何以言之强称妙法莲花。是以分坐令闻之者。当受轮王释梵之座。迳耳一句之人。并得无上菩提之记。况乎受持演说之福。岂可思议所量乎哉。举是大意以标题目。故言妙法莲花经也

第二辨经宗者。此经正以广大甚深一乘实相为所诠宗。总说虽然。于中分别者。一乘实相略说有二。谓能乘人及所乘法。此经所说一乘人者。三乘行人。四种声闻。三界所有四生众生。并是能乘一佛乘人。皆为佛子。悉是菩萨。以皆有佛性当绍佛位故。乃至无性有情亦皆当作佛故。如宝云经言。菩萨发心便作是念。一切世界中少智众生愚痴喑哑无涅槃分不生信心者。□□菩萨之所弃舍。如是众生我皆调伏乃至坐于道场得阿耨菩提。发此心时。魔宫震动。又言。菩萨成佛众愿满足。方便品说。三世诸佛但教化菩萨。譬喻品云。一切众生皆是吾子故。又言。诸法从本来常自寂灭相。佛子□道已。来世得作佛。斯则无一众生而非佛子。所以广大。此众生界即涅槃界。是故甚深。如论说言。三界相者。谓众生界即涅槃界。不离众生界有如来藏故。是谓能乘一佛乘人也。此一乘人所乘之法。略而说之有四种。一谓一乘理及一乘教。一乘之因一乘之果。一乘理者。谓一法界。亦名法身。名如来藏。如萨遮尼揵子经云。文殊师利白佛言。若无三乘差别性者。何故如来说三乘法。佛言。诸佛如来说三乘者。示地差别。非乘差别。说人差别。非。乘差别诸佛如来说三乘者。示小功德知多功德。而佛法中无乘差别。何以故。以法界法无差别故。金光明经言。法界无分别。是故无异乘。为度众生故分别说三乘。又此经言。诸佛如来能知彼法究竟实相。论释此云。实相者。谓如来藏。法身之体。不变相故。又下文言。同者。示诸佛如来法身之性同诸凡夫声闻辟支佛等。法身平等无有差别故。案云。如来法身如来藏性。一切众生平等所有。能运一切同归本原。由是道理无有异乘。故说此法为一乘性。如是名为一乘理也。一乘教者。十方三世一切诸佛。从初成道乃至涅槃。其间所说一切言教。莫不令至一切智地。是故皆名为一乘教。如方便品言。是诸佛亦以无量无数方便。种种因缘譬喻言辞。而为众生演说诸法。是法皆为一佛乘故。是诸众生从佛闻法。究竟皆得一切种智故。是教遍通十方三世。无量无边。所以广大。故一言一句皆为佛乘。一相一味。是故甚深。如是名为一乘教也。一乘因者。总说有二。一者性因。二者作因。言性因者。一切众生所有佛性为三身果而作因故。如常不轻菩萨品云。我不轻汝。汝等皆当作佛。论释此言。示诸众生皆有佛性故。又言。决定增上慢二种声闻。根未熟故。佛不与授记。菩萨与授记。菩萨与授记者。方便令发心故。当知依此经意而说趣寂二乘无性有情皆有佛性悉当作佛。言作因者。若圣若凡内道外道道分福分一切善根。莫不同至无上菩提。如下文言。或有人礼拜。或复但合掌。乃至举一手。或复少倾头。若人散乱心入于塔庙中一称□无佛皆已成佛道乃至广说。本乘经言。凡圣一切善不受有漏果。唯受常住之果。大悲经言。佛告阿难。若人乐着三有果报。于佛福田若行布施诸余善根。愿我世世莫入涅槃。以此善根不入涅槃。无有是处。是人虽不乐求涅槃。然于佛所种诸善根。我说是人必入涅槃。尼健子经一乘品言。佛语文殊。我佛国□所有僧伽尼干子等。皆是如来住持力故方便示现此诸外道。善男子等。虽行种种诸异学相。皆同佛法一桥梁度。更无余度故。案云。依此等文。当知佛法五乘诸善及与外道种种异善。如是一切皆是一乘。皆依佛性无异体故。如法花论显此义。云何体法者。谓理无二体。无二体者。谓无量乘皆是一乘故。而下文言汝等所行是菩萨道者。谓发菩提心退已还发者前所修行善根不灭同后得果故。者为显种子无上义故。旦约发心善根而说。非谓余善不得佛果。是故□违前所引文。由是言之。若凡若圣一切众生内道外道一切善根。皆出佛性同归本原。如是本来唯佛所穷。以是义故广大甚深。如是名为一乘因也。一乘果者。略说有二种。谓本有果及始起果。本有果者。谓法佛菩提。如寿量品云。如来如实知见。三界之相无有生死若退若出。亦无在世及灭度者。非实非虚非如非异。案云。此文就一法界显一果体。非有体故非实。非无体故非虚。非真谛故非如。非俗谛故非异。如本乘经云。果体圆满无德不备。无理不周。无名无相。非一切法可得。非有体非无体。乃至广说。又言。二体之外独在无二故。是明法佛菩提果体。始起果者。谓余二身。如论说言。报佛菩提者。十地行满足得常涅槃证故。如经言。我实成佛已来。无量无边百千万亿那由他劫故。应化菩提者。随所应见而为示现。谓出释宫树下成道及与十方分身诸佛。如宝塔品之所广明。总而言之。一切众生皆修万行同得如是。□菩提果。是谓一乘一乘果也。如方便品云。舍利弗当知。我本立誓愿。欲令一切众如我等无异。如我昔所愿。今者已满足。化一切众生皆令入佛道。案云。此文正明如来所愿满足。所以然者。遍化三世一切众生。如应皆令得佛道故。如宝云经云。譬如油钵若已平满更投一渧终不复受。菩萨成佛众愿满足亦复如是。更无减少一尘之愿。大云密藏藏经云。大云密藏菩萨曰言世尊。唯愿如来。为未来世薄福众生。演说如是深进大海水潮三昧。佛言。善男子。莫作是言。何以故。佛出世难。此大云经闻者亦难。云何偏为未来之。吾当遍为三世众生广门分别。花严经云。如来转法轮。于三世无不至。依此等文。当知诸佛初成正觉。一念之顶遍化三世一切众生。无一不成无上菩提。如昔所愿已满足故。设有一人不成菩提。如昔所愿即不满故。虽实皆度而无尽际。虽实无际而无不度。以无限智力度无限众生故。而此经下文言。我本行菩萨道所成寿命。今犹未尽复倍上数。论释此云。我本行菩萨道今犹未满者。以本愿故。众生界未尽愿非究竟。故言未满。非谓菩提不满足故。所成寿命复位上数者。示现如来常命方便。显多过上数量不可数知故。此论意者。为明约今众生未尽□如是时本愿未满。非谓菩提已满。而其本愿未满亦非本愿未满。而说佛法已足。如花严经云。一切众生未成菩提。佛法未足。本愿未满。是故当知愿与菩提不满。等则已满则等满。如是名为一乘果也。合而言之。理教因果如是四法。更互相应共运一人到萨婆若。故说此四名一乘法。犹如四马更互相应共作一运故说四马名为一乘。当知此中道理亦尔。问理教及因共运众生到萨婆若。此事可尔。果既到究竟之处。云何与三共运众生。解云。此有四义。一者由未来世有佛果力。冥资众生令生善心。如是展转令至佛地。如涅槃经云以现在世烦恼因缘能断善根。未来佛性力因缘故还生善根故。二者当果报佛现诸应化化今众生令得增进。如本乘经云。自见己身当果。诸佛摩顶说法身心别行不可思议故。三者此经六处授记。记当得成阿耨菩提。由得此记。[竺-二+宗]心进修当果属彼□得运彼故。下文言。各赐诸子等一大车。四者此经中说一切种智。无□不尽。无德不备。一切众生同到此果。众生缘此能诠所诠发心。胜进迳四十心游戏神通化四生类。故说众生乘于果乘。乘乘能运因地众生。如下颂诸子是时欢喜踊跃乘是宝车游于四方。由方是四义当知果乘与余三法共运一人。人人四法因缘和合远离诸边不可破坏。除此更无若过若增。如是名为广大甚深究竟一乘真实相也。所诠之宗略述如是

第三明能诠用者。如法师品云。一切菩萨阿耨菩提皆属此经。开方便门示真实相。此文正明是经胜用。用有二种。谓开及示。开者开于三乘方便之门。示者示于一乘真实之相。总说虽然。于中有三。先开次示。第三合明开示之用。先明开义即有二种。谓所开之门及能开之用。所开之门即三乘教。此名方便略有四义。一者佛方便智之所说教。依主立名名方便教。二者即三乘教巧顺三机。持乘作名名方便教。三者为一乘教作前方便。因是后说一乘正教。对后正教名为方便。四者于一乘理权说方便非真实说。是方便义对真实说名为方便。依此四义故名方便。此名为门。有其二义。一者出义。诸子依此出三界故。二者入义。又依此教入一乘故。然门有二名。若言佛门人门。则门非佛人。若言板门竹门。则门是板竹。今三乘教名方便门者。同板竹门。门即方便。是故名为方便门也。开方便门。方便有其二义。若望出义说三乘时。开而不闭。望其入义说三之时。闭而不开。虽出三界未入一乘故。今说一乘教言。三是方便。方开方便门令入一乘故。如下文言。当知诸佛方便力故。于一佛乘分别说三。此言正开方便之门。诸余言语例此可知。次明示用。于中亦二。先明所示。次明能示。所示之真实相。谓如前说。一乘人法。法相常住。道理究竟。天魔外道所不能破。三世诸佛所不能易。以是义故名真实相。而非三非一。无人无法。都无所得。如是正观乃名真实究竟一乘。所以然者。诸有所得无道无果不动不出。故知如前非三是一。能乘所乘人法之相不出四句。是有所得。云何说此为真实相。解云。此言不然。所以者何。若言非三是一不出四句故是有所得非究竟者。是则有得为非无得为是亦入四句故是有所得亦非正观。若言寄言说无所得而非如言取于无得是故无得不入四句者。他亦寄言假说一乘而非如言取于一乘所以一乘亦出四句。是故当知遂言俱非。不如言取二说无异

问。若不取言皆为实者。彼三乘教亦应是实

答。通义皆许。而有别义。以三乘教下都无三理一乘教下不无一理故。三是权。一乘是实。虽不无一而非有一。是故亦非有所得也。所示真实其相如是。能示□用有其二种。一者则开之示。如前开三是方便时。即知一乘是真实故。如开门时即见内物。二者异开之示。异前开三别说一乘。闻之得悟一乘义故。如以手□方见内物。如下文言。诸佛唯以一大事因缘故出现于世。如是等言是示真实相也。第三合明开示用者。一开示中合有四义。一者用前三为一用。前三乘之教即为一乘教故。二者将三致一。将彼三乘之人同致一乘果故。三者会三归一。会昔所说三乘因果还归于本一乘理故。四者破三立一。破彼所执三乘别趣以立同归一乘义故。此经具有如是四种胜用。故言开方便门示真实相

问。用三为一。将三致一。是二未知以何为证

答。方便品言。佛以无数方便演说诸法。是法皆为一佛乘故。此文正是用三为一之证也。又言。是诸众生从佛闻法究竟。皆得一切种智。此言正是将三致一之证也

问。会三因果归本一者。为当三皆非实故归于一实耶。为当唯二非实故归于一实耶。若如后者。何故经言。我有方便力开示三乘法。若如前者。云何复言。唯是一事实余二则非真

答。或有说者。三皆非实。如前文说。而言一实二非真者。三中之一与无三之一俱。是佛乘。通说是实。余二不用开别言非实。由是义故二文不违。或有说者。唯二非实。如后文故。而说三乘皆方便者。于一实中加二非实合说为三。是三非实。如人手内实有一果方便言三。三非是实无三果故。考而论之。一果是实。二是方便。有一果故。如智度论云。于一佛乘开为三分。如人分一斗米以为三聚亦得言会三聚归一亦得言会二聚归。会三会二犹是一义不相违也。或有说者。前后二文各有异意。不可一会。所以然者。三乘之教有其二种。一者别教。二通教。别教三乘三皆非实。皆是方便。以彼教说三僧祇劫唯修四度。百劫之中修相好业。最后身中修于定惠。菩提树下成无上觉。如是因果以为佛乘。是故佛乘亦是方便。若论通教所说三乘。佛乘是实。定余二非真。以彼教说于十地中具修六度万行圆满致萨婆若。此萨婆若果不与三世合。如是因果究竟真实此为佛乘。岂是方便。是故当知二文意异。我有方便力开示三乘法者。是显别教所说三乘也。唯是一事实余二则非真者。是对通教所说三乘。其余诸文皆作是通

问。若说别教三乘因果皆是方便故归一者。为归一因为归一果

答。于一佛乘分别说三故。随其本归因归果。是义□何声闻缘觉若因若果皆于一因分别为二。如经说言。声闻缘觉若智若断。皆是菩萨无生法忍。当知此二皆归一因。归一因故终致一果。彼教中说。佛乘因果分别佛地化身少分。如经说言。我实成佛已来。百千万亿那由他劫故。当知彼说佛乘因果同归于此一乘果内。若有菩萨依彼教故望树下佛发心修行。如是愿行归于一因。同彼二乘未至果故。通而言之。应作四句。一以方便因归真实因。谓菩萨因及二乘因。二以方便果归真实果。谓于树下成无上觉。三以方便因归真实果。谓树下佛前菩萨行。四以方便果归真实因。谓二乘人之无学果。总摄如是四句。以说会三归一

问。方便教中有人天乘。何故不会此二唯会彼三

答。会三之言亦摄此二。所以然者。法花教中说。三乘有二。一者三车所譬。出喻品。二者三草所咒。出药草品。此义云何。人天二乘合为小乘。如小药草。声闻缘觉名为中乘。如中药草。依彼别教发心菩萨。说名为大乘。如大药草。会此三乘即摄五乘。然彼人天会因而不会果。果是无记。不作一因故。彼因善法有二功能。报因功能亦不会之。有受尽故。等流因用是今所会。无受尽故。会此因义入第一句

问。会三归一其义已显。破三立一云何可知

答。欲知此义。有广有略。略而言之。破四种三。一执三教定非方便。二执三人定是别趣。三执三因别感。四执三果别极。破此四种所执之相。遣其四种能执之见。是故建立一乘真实。谓立一教故则破三教。立一人故则破三人。立一因故则破三因。立一果故则破三果。立一理性通破四三。以四一皆同一乘理故。略说如是。广而论之。为破十种凡圣执故。说七种譬及三平等。此义至彼第六门释。第三明诠用竟也。第四释题名者。具存梵音。应云萨达摩分陀利修多罗。此云妙法莲华经。言妙法者略有四义。一者巧妙。二者胜妙。三者微妙。四者绝妙。言巧妙者。此经巧开方便之门。巧灭执三之见。巧示真实之相。巧生已一之惠。以是四义而作真轨故。言妙法言胜妙者。此经能宣一切佛法。能示一切神力。能显一切秘藏。能说一切深事。以此四义最为胜妙故名妙法。如神力品云。以要言之。如来一切所有之法。如来一切自在神力。如来一切秘密之藏。如来一切甚深之事。皆于此经宣示显示显说。故言妙法。言微妙者。此经所说一乘之果。无妙德而不圆。无杂染而不净。无义理而不穷。无世间而不度。以是四义故名微妙之法。如譬喻品云。是乘微妙清净第一出诸世间为无有上。故言妙法。言绝妙者。此经所说一乘法相。广大甚深离言绝虑。以是四义故为绝妙之法。如方便品云。是法不可示。言辞相寂灭。诸余众生类无有能得解故。此四义中。巧妙胜妙之法当能诠用立名。微妙绝妙之义从所诠宗作目。合而言之。具含如是。巧胜微绝十有六种极妙之义十方三世无二之轨以是义故名为妙法。妙法之名略释如是。莲花之喻有别有通。通者。此华必具华须台实四种。合成殊为美妙。喻于此经具四妙义合成一经。故名妙法。别而言之。即有四义。一者。莲花之类有四种。中分陀利者是白莲花。鲜白分明花开实显。喻于此经了了分明开权显实之巧妙也。二者。此花凡有三名。未敷之时名屈摩罗。将落之时名迦摩罗。已敷未衰处中之时开荣胜盛称分陀利。喻于此经大机正发之盛时宣示显说之胜妙也。三者。此花非直出离泥水。亦乃圆之香洁众美具足。喻于此经所说佛乘出烦恼浊离生死海众德圆满之微妙也。四者。此花非直荷广[卄/禍]深。亦乃不着水渧不染尘垢。喻于此经所说一乘法门广大道理甚深离言绝虑之绝妙也。由是四义有同妙法故。寄是喻以立题名也

第五明教摄门者。是法华经何教所摄。为是了义为不了义。有说。此经是不了义。所以然者。大分佛教有三法轮。一者有相法轮。唯为发趣声闻乘者。依四谛相转法轮故。如阿含经等。二者无相法轮。唯为发趣菩萨乘者。依法空性转法轮故。如般若经等。三者无相无上法轮。普为发趣三乘者依诸法空

无自性性而转法轮无上无容故。如解深密经等。此中前二是不了义。第三法轮是真了义。是义具如彼论广说。此法华经是第二摄。如偈说言。诸法从本来。常自寂灭相。佛子行道已。来世得作佛故。是故当知第二无相法轮所摄。既属第二。是不了义。此义即以二文为证。一者即彼解深密经云。一向趣寂声闻种性补特伽罗。虽蒙诸佛施设种种勇猛加行方便化道。终不能令当坐道场证得无上正等菩提何以故。由彼本来唯有下劣种性故。一向慈悲薄弱故。一向怖畏众苦故。乃至广说。二者对法论言。众生意乐。乐乐者。如为不定种性者舍离下劣意乐故。记大声闻当得作佛。又说一乘。更无第二。案云。彼经既是究竟真实了义说。说言声闻永不成佛。是知法花说诸声闻当得作佛。是方便语不了义说。是故阿毗达磨□云。是随众生意乐而说。非是直说真实道理。修多罗者。以文为胜阿毗达磨以理为胜。由有如是二种明证。当知法花一乘之教定非究竟了义说也。或有说者。法花经是究竟了义。所以然者。如来一代所说教门。略摄不出三种法轮。何者为三。一者根本法轮。二枝末法轮。三者摄末归本法轮。根本法轮者。谓佛初成道花严之会□为菩萨广开一因一果法门谓根本之教也。但薄福钝根之流深不堪闻一因一果故。于一佛乘分别说三。谓枝末之教也。四十余年说三乘之教陶练其心。今至法花之会始得会三归一。即摄末归本教也。如信解品明。长者居师子坐眷属围绕罗列宝物。即指花严根本教也。唤子不得故密遣二人。脱珍御服着弊垢衣。谓隐一说三枝末教也。如富长者知悉下劣□伏其心乃教大智。谓摄末归本教也。是□诸门处处有文。当知此中初后二教同是究竟了义之说。第二教者。于一说三。皆是方便不了义说。为成此义。明证有二。一者修多罗。二者阿毗达磨。修多罗者。略引三文一者如安乐行品云。此法花经能令众生至一切智。一切世间多怨难信。先所未说而今说之。是诸如来第一之说。于诸说中最为甚深。末后赐与如彼强力之王久护明珠今乃与之。二者化城品云。是诸佛方便分别说三乘。唯有一佛乘□处故说二。三者胜鬘经云。阿罗汉辟支佛。四智究竟得苏息处。亦是如来是方便有余不了义说。如是等文不可具陈。阿毗达磨者略引三处文。法花论云。决定增上慢二种声闻。根未熟故佛不与授记菩萨与授记。菩萨与记者。方便令发心故。二者智度论说

问。阿罗汉先世因缘之所受身必应当灭。住在何处而具足佛道

答。得阿罗汉时。三界诸漏因缘尽故。更不复生三界。有净佛立出于三界。乃至无有烦恼之名。于是国立佛所闻法花经具足佛道。三者宝性论云。问。说阐提无涅槃性常不入涅槃者。此义云何。为欲示显谤大乘因故。此明何义。为欲回转诽谤大乘心不求大乘心。依无量时。故作是说。以彼实有清净性故。依是等文。当知诸教说有二乘定不成佛。及说无性有情等言。皆是方便不了义说。若说一乘更无第二一切众生皆当作佛。如是经典是真了义。问若立初师义者。后师所引文云何和会。彼师通曰。诸一乘教所说诸文。皆为护彼不定性者。皆是方便。故不相违。法花论文及宝性论。亦为述后方便教意。智度论文说阿罗汉生净土者。是约不定种性声闻。由是道理亦不相违。问。若立后师义者。前所引证云何得通。彼师通云。深密经说终不能令当坐道场证得无上正等菩提者。是明决定当入无余永不能令不入无余直证无上正等菩提。是故说为一向趣寂。然彼声闻入无余时。住八万劫或住六万四万二万。然后起心即入大生于净土具足佛道。若论不定种性人者。唯住有余依地入大。如瑜伽论分明说故。是故彼经亦不相违。对法论文说一乘教为方便者。是述三乘权教之意而非究竟道理之说。如彼执三乘者说云。十五有漏□无记者。是约粗相境界而说。非是究竟真实道理。是故当知彼对法论或有述于方便教文。由是道理不相违也

问。二师所通一据相违。何者为实何者为胜

答。皆是经论。有何不实。所以然者。为护一向趣寂者意。则如初师所通为实。为护不定种姓人意。则如后师所说为实。皆当物机各得和通故。若就道理判其胜负者。彼师义狭而且短。彼说佛□不遍一切故。又说二□竟断灭故。第二师义宽而复长。返前短狭其义可知斯则以短狭义会宽长文。文伤□□会。用宽长义容短狭文。文狭则无伤义。则易会。由是道理后说为胜。是故当知此法花经乃是究竟了义之教也。今依是义以通诸文。诸文相违皆得善通。所以然者。以诸了义究竟教内不无方便不了之言。如解深密经中说言。一切声闻缘觉菩萨同皆共一此妙清净道。皆同是一究竟清净如。□是道理为彼经宗。所以彼经是真了义。而彼经说寂趣声闻终不能得坐于道场。如是等文是方便说。为护决定二乘意故。作是方便不了义说。由是道理夫人性等说彼以为不了义说。如是二文不相违也。又此法花经中说言。为□□故。化作宝城。更止息已终引佛果。依是道理以说一乘。是为经究竟了义。此经亦有不了义语□直说言唯有□□无二无三是文为□□定□□说无趣寂二乘之行。而实不无趣寂二乘之行。是故说无是方便语。由是道理对法论说为方便者。亦有道理也

法花宗要　　　弘安六年八月十七日相承之


佛教西来玄化应运略录

    No. 1794 [cf. No. 784]

    佛教西来玄化应运略录

        宋正议大夫安国军节度使开国侯程辉编

准五分律说。释迦牟尼佛。生中印土迦维罗城刹帝利家。父名白净饭王。母号摩耶。右胁而生紫磨金色不绍王位。十九踰城至雪山中。六年苦行日食麻麦。又至象头山学不用处定。三年知非遂舍。又至郁头蓝学非想定。三年知非亦舍。即以无心意而受行。悉摧伏诸外道。世尊时年三十。于二月八日明星出时成等正觉。于鹿野苑中。度憍陈如等五人。为教兴之始也。又准周书异记说。周昭王二十四年甲寅岁四月八日。有光来照殿前。王问太史苏由。对曰。西方当有大圣人生。后一千年教流此土。至后汉孝明帝永平七年正月十五日。帝夜梦金人身长丈六赫奕如日。来诣殿前曰。声教流传此土。帝旦集群臣令占所梦。时通人傅毅对曰。臣览周书异记云。西方有大圣人出世。灭后千载当有声教流传此土。陛下所梦将必是乎。帝遂遣王遵等一十八人。西访佛法至月氏国。遇摩腾竺法兰二菩萨。将白[疊*毛]上画释迦像及四十二章经一卷载以白马。同回洛阳。时永平十年丁卯十二月三十日也。因以腾兰译经之所名白马寺。后六年摧伏异道。二菩萨踊身虚空。为王说偈曰

狐非狮子类。灯非日月明。池无巨海纳。丘无嵩岳荣。法云垂世界。法雨润群萌。显通希有事。处处化群生

    四十二章经序

        昭文馆大学士中奉大夫掌诸路头陀教特赐圆通玄悟大禅师头陀僧溥光奉　敕撰

伏闻无上法王。为一大事因缘。出现世间随机接物。演河沙妙义。设无量行门。运神通四十九年。度众生百千万亿。将般涅槃嘱累国王大臣。宣扬正法续佛慧命。斯乃为未来世众生作无穷之利益。大慈远被其至矣乎。钦惟圣上道贯百王。智周庶品。每万机之暇。弘崇三宝。景仰一乘。思所以答列圣在天之灵。皇太后鞠育之恩。既创建大招提。博施诸贝典。又以为四十二章经。乃

释迦如来初成正觉。大弟子众记诸圣言。沙门释子臣寮士庶。率可遵行。适有以前代注本为进者。特敕有司一新板本遍颁朝野。将使或缁或素。若见若闻。顶戴奉行。咸登觉地。其深心愿心广大心。非聪明睿智孰与。于此诏头陀僧(臣)溥光为之序。(臣)溥光幸在空门。忝为佛子。夙承隆眷。不敢以固陋辞。窃惟能仁所演三藏十二分一切修多罗数等尘沙。如华严般若宝积大集涅槃等部。文富义博。事备理周。在龙宫海藏。烂若日星。而腾兰东迈独持此经。适符汉明西迓声教之运。而大振玄风于天下后世。是其可以常情卜度拟议哉。意其必有冥数潜通诸佛密证为震旦。万世五乘之大本。五性之通达。妙道至理。存乎其间者欤。研其义味。盖为佛者在日用修进之际。造次颠沛不可须臾离之要旨乎。明明天子流布宣扬。其犹捧佛日而曲照昏衢。滂法雨而普滋群槁。上不负如来之嘱累。下广开叔世之津梁。娑婆界中莫大之良因也。昔唐太宗敕书手十人录遗教经。遍付诸郡用伸劝勉方之今辰其有间矣。(臣)叹咏不足无任欢喜踊跃。焚香再拜书于经之首云

皇庆元年正月　　日上

    注四十二章经序

        宋真宗皇帝制

夫至真不宰。岂隔于含灵。群动无明。自迷于正觉。是以慈悲之上圣。因谈归救之妙门。接物而利生。随机而演教。布法云而润物。揭智炬以烛幽。示忘言之言。为无说之说。四十二章经者。盖能仁训戒之辞也。自腾兰之传译。即华夏以通行。朕尝以余闲潜加览阅。冀协宣扬之谊。因形注释之词。晦朔屡更。简编俄就。导群氓之耳目。虽愧精深。资众善之筌蹄。庶符利益。其有相传之疑误。累句之难分。亦用辨明。庶臻演畅。粗题篇首。以达予衷云尔

佛说四十二章经

佛者梵语。佛陀。此云为觉。盖觉悟之义也。觉有三义。一者自觉胜凡夫。凡夫汨没生死无暂觉者故。二者佛能觉他。胜声闻缘觉二乘人。不能觉他故。三者觉行圆满。胜诸菩萨。为菩萨虽行二利行未满。故至佛果位。三觉方满佛口所宣。故云佛说四十二章经者。即下文佛因事诫约劝诸弟子。成四十二章也。经者梵语。云修多罗。此云为经。经训常也。常者言其真常不易之法也

        迦叶摩腾共竺法兰奉　诏译

        宋真宗皇帝注

尔时世尊既成道已作是思惟离欲寂静是最为胜住大禅定降诸魔道　夫爱欲长于贪痴。禅定资于智慧。故世尊首言离欲之最胜。次劝住禅而降魔

今转法轮度众生于鹿野苑中为憍陈如等五人转四谛法轮而证道果　鹿野苑中证道之净土。憍陈如等闻法之弟子。四谛即苦集灭道也

时复有比丘所说诸疑陈佛进止世尊教诏一一开悟合掌敬诺而顺尊敕尔时世尊为说真经四十二章　接物度生随机演教。开彼疑惑示其戒敕。叙以轮贯乃成四十二章焉

佛言　凡经首标佛言者。皆是弟子阿难等结集之时。叙佛平生所说。故云佛言

辞亲出家为道识心达本解无为法名曰沙门　沙门梵语。合云沙迦门。曩已略其二字。此云勤息。谓能勤修众善勤息诸恶。又云。息恶取止息之义也。盖谓辞其亲出其家息诸恶勤诸善。乃为道人也。故名曰沙门

常行二百五十戒为四真道行进志清净成阿罗汉　二者五十戒其条目。具载大藏中小乘律四分戒。此不繁云四真道行。即知苦断集证灭修道为四谛真实道行也。若坚持清净进志不退即渐成圣果也

佛言阿罗汉者能飞行变化住寿命动天地　梵语阿罗汉。此云应。应具三义也。一应断烦恼障。二应不受后有身。三应受人天妙供养。既成此圣果能以六通飞行往来。又变化形体凡俗莫测。住寿命者。或生或灭延促自在。若要住世久长则经劫不灭。又能以神通震动天地。盖妙用难测也

次为阿那含阿那含者寿终魂灵上十九天于彼得阿罗汉　梵语阿那含。此云不还。言得此果位断尽欲界分别。更不还来生欲界也。故此一报命终生于色界。一十九天。十九天者。谓初禅三天。二禅三天。三禅三天。四禅九天。于彼十九天中。断尽烦恼当得阿罗汉果

次为斯陀含斯陀含者一上一还即得阿罗汉　梵语斯陀含。此云一来。唯一生天上。一还人间。乃得阿罗汉果

次为须陀洹须陀洹者七死七生便得阿罗汉　梵语须陀洹。此云预流。言此果位断尽三界分别烦恼。初预圣流也。七生七死者。于七度生死中断尽烦恼。即得阿罗汉

爱欲断者譬如四支断不复用之　爱欲断尽而得圣果者。譬如断其四支。更不可续圣流断其爱欲。更不再生惑也

佛言出家沙门者断欲去爱识自心源达佛深理悟佛无为内无所得外无所求心不系道亦不结业无念无作无修无证不历诸位而自崇最名之为道　夫能断爱欲则心源自明。善达深理则法本超悟趣。或归当道匪外求。是以不系道而道。有不结业而业解念作修证。复何为哉

佛言剃除须发而为沙门受佛法者去世资财乞求取足日中一食树下一宿慎不再矣　剃除须发。盖欲睹形厌俗饥寒之患。求乞度时。故知日中一食树下一宿自然身心澄静。贪欲不生则可日进其道法也

使人愚蔽者爱与欲也　夫不绝爱欲即为前境所转。既为前境所转则爱欲习气依然复生。故使真智蒙蔽无由证觉矣

佛言众生　假众缘依故曰众生

以十事为善亦以十事为恶何者为十身三口四意三身三者杀盗淫口四者两舌恶骂妄言绮语意三者嫉恚痴　夫为善者。不杀不盗不邪行。是为身之三善。不两舌不恶口不妄言不绮语。是为口之四善。不嫉不恚不痴是为意之三善。若背此者。即谗构离间谓之两舌。咒诅毁讟谓之恶骂语。无诚实谓之妄言。谄谀巧诳谓之绮语。妒贤掩善名之为嫉愤。彼衔怨谓之为恚。不忧生死。惟恣贪欲谓之为痴也

不信三尊以邪为真　三尊者佛法僧也

优婆塞行五事不懈退　梵语优婆塞。此云清信男。五事即五戒也。谓不杀不盗不邪行不妄语不饮酒。懈退者谓行之不专也。或中道而废也

至十事必得道也　十事即上文十善也。得道谓精勤不退乃证道也

佛言人有众过而不自悔顿止其心罪来归身犹水归海自成深广何能免离　愚迷之人日作众罪。既无退悔恶积于心致百殃之及身。若众流之朝海积彼岁时自成深广

有恶知非改过得善罪日消灭后会得道也　夫人善自知非能改其过日新之善渐积。过去之恶潜消即于后会得明道也

佛言人愚以吾为不善吾以四等慈护济之　四等慈。谓慈悲喜舍谓之四无量。心以护济愚人

重以恶来者　愚人不知恩。复以恶意来相侵也

吾重以善往　我亦复以善心诫之

福德之气常在此也害气重殃反在于彼　我常以德报怨故福德之气常在于我。彼惟以恶行重凌善人故害气重殃彼自贻也

有愚人闻佛道守大仁慈以恶来以善往故来骂佛佛默然不答愍之痴冥狂愚使然　愚人闻佛守大仁慈。乃恣恶辱骂于佛。佛即默然不答。盖惜彼痴愚使如是也

骂止　愚人止其骂也

问曰子　佛乃问之。子者男子之通称也

以礼从人其人不纳实理如之乎　此佛问彼之辞也

曰持归　此愚人答也

今子骂我我亦不纳子自持归祸子身矣　恶人骂止。佛问曰如子施礼于人　彼若不纳即子所施礼其理如何。愚人对曰。我自持归。佛复告曰。汝今骂我。我亦不纳。子自持归祸及汝身

犹响应声影之追形终无免离慎为恶也　佛言恶人害贤者犹仰天而唾唾不污天还污己身逆风坋人尘不污彼还坋于身贤者不可毁祸必灭己也　奸恶之人害于贤者。犹如怨天仰唾徒污于己逆风坋人惟坋自身。如彼害贤之人祸终灭己

佛言夫人为道务博爱　博行爱人

博哀施　见彼危厄博哀而救之

德莫大施　言施之德最为大也

守志奉道其福甚大　夫学道之人既能博爱哀施加以精进则其福弥大

睹人施道助之欢喜亦得福报　见彼行施奉道而能为彼欢喜赞叹。亦获福报

质曰彼福不当减乎佛言犹如炬火数千百人各以炬来取其火去熟食除冥彼火如故福亦如之　质曰者。求质其疑也言助之欢喜亦获其福。疑谓减彼哀施福报。佛乃答曰。犹如一炬之火。有数千百人。各以炬来求之。或熟饮食或照冥闇而本之一炬亦不减少故。哀施福报亦犹于此

佛言饭凡人百不如饭一善人饭善人千不如饭持五戒者一人饭持五戒者万人不如饭一须陀洹饭须陀洹百万不如饭一斯陀含饭斯陀含千万不如饭一阿那含饭阿那含一亿不如饭一阿罗汉饭阿罗汉十亿不如饭辟支佛一人饭辟支佛百亿不如饭一佛学愿求佛欲济众生也　此十等校量盖德有大小。障有厚薄。故饭之者福报不同。又梵语辟支佛陀。此云独觉。故言饭百亿独觉不如饭一佛。何者盖运大慈普济群生其福深广不可思议。而供佛之报亦最大也

饭善人福最深重　此言饭凡世善人福亦深重

凡人事天地鬼神不如孝其二亲二亲最神也　然善人中有二种。或能事天地鬼神。或能孝养父母。比量福报不及能事亲者

佛言天下有二十难贫穷布施难　凡人贫乏自逼饥寒而能辍己济人斯亦难矣

豪贵学道难　豪贵恣逸无诸苦恼而能厌其累尘。折节求道故为难矣

判命不死难　不字当为。必字盖传之讹也。若世人明达因果决志判命。或舍命身饲其猛鸷。济彼鱼鳖乃至忠臣烈士。以死殉义斯皆难也。何知当为必字缘。佛言二十难并说凡夫境界非论不生不灭之理。其义明矣。又据西戎南蛮语音。呼必为不

得睹佛经难　凡人不具信根罔忧生死。则出世之教安得见闻

生值佛世难　夫人若不结胜因不修众善则诸佛出世岂得遭遇实知难矣

忍色离欲难　六尘之中多为情欲所惑而能制伏妄念。防其越逸甚为难矣

见好不求难　彼之所好此或于求遂之贻贪冒之名违之招忿戾之患故能不求为难矣

有势不临难　势利之人威福之地而能唯道是从不形趋附亦为难矣

被辱不嗔难　不忍小忿则兴诤端非理相干。能以情恕斯亦难矣

触事无心难　心求清净触境而兴。若能遇事不徇物情。斯为难矣

广学博究难　怠惰则陷无明。多闻则有饶益。若能广究谊理以资智虑。斯为难矣

不轻未学难　凡曰群生同禀真性。而以能格物俗之常情故。不轻未学为难也

除灭我慢难　愚冥徇情彼我慢生违善兴诤罔不由兹。若能除灭故为难矣

会善知识难　感物生情理兹染习善恶之性。由是而迁故知识之善者。亦难矣

见性学道难　性本澄湛迷于妄情。道本真常昧于爱欲。能复本而见性。背伪而学道为难矣

对境不动难　前尘妄境致惑真性故悟之而寂照对之而不动者难矣

善解方便难　常怀大慈以视众生。种种方便以为饶益者难矣

随化度人难　众生之性亦有利钝。能于高下之中随化而度之者亦难矣

心行平等难　痴冥之类合尘背真。若能冤亲彼我一皆平等。斯为难矣

不说是非难　两舌妄言世尊所戒。众生无明而有差别。若能平等不构是非者难矣

有沙门问佛以何缘得道奈何知宿命佛言道无形相　真如之性与虚空等故。言无形相

知之无益　夫知而不学与不知同。必假修证。乃可得道

要当守志行譬如磨镜垢去明存即自见形断欲守空即见道真知宿命矣　夫欲通宿命者。当须志行清净常在禅寂久则尘障尽消。潜通宿命如磨镜去垢乃见形矣。苟非断欲守空。何以得证道真也

佛言何者为善惟行道善　佛言何者。盖各引一设之义惟精进行道。渐至证圣最为善也

何者最大志与道合大　断诸攀缘得无漏智志道淴合最为寂大

何者多力忍辱最健忍者无恶必为人尊　忍辱之人不怀仇怨。如彼勇健多力之人能拒强敌内不怀恶。终为人所尊也

何者最明心垢除恶行灭内清净无瑕　如白圭无玷晴空绝云心之最明也

未有天地逮于今日　极言其远大也

十方所有未尝不见得无不知无不见无不闻得一切智可谓明矣　此已证果位得一切种智故。于三世具正遍知明之至也

佛言人怀爱欲不见道者譬如浊水以五彩投其中　浊水譬染心。五欲喻五彩。心欲相投交错其中也

致力搅之　浊水五彩已不可分。仍用力搅之。喻世人妄想贪爱发乱其五欲也

众人共临水上无能睹其影爱欲交错心中为浊故不见道若人渐解忏悔来近知识水澄秽除清净无垢即自见形　浊水之上虽众临之无能睹影。爱欲交乱真心昏惑。岂得明道。若秽浊尽去心归清净即自然见道也

猛火着釜下中水踊跃以布覆上众生照临亦无睹其影者心中本有三毒涌沸在内五盖覆外终不见道　釜者喻染心。水踊跃者喻染心中贪嗔痴三毒烦恼踊跃也。以布覆上者。喻凡夫被五盖蒙翳终不得见道也。五盖谓。一贪欲。二嗔恚。三痴。四掉举恶作。五昏沉睡眠。俱为盖覆也

恶心垢尽乃知魂灵所从来生死所趣向诸佛国土道德所在耳　精勤坚固渐证果位。于禅定中乃知魂灵之所从来。乃无常报尽生诸国土道德所在矣

佛言夫为道者譬如持炬火入冥室中　冥闇也

其冥即灭而明犹存　犹字当为独犹字殊无义

学道见谛愚痴都灭无不明矣　夫已见道愚痴自灭。渐证佛智德无不明。犹如持火入诸闇室冥闇都灭而明独存也

佛言吾何念念道　佛训诱弟子言。我常念道更无杂念

吾何行行道　应物利生常行于道

吾何言言道　佛所言说惟谈于道。利益有情

吾念谛道不忘须臾也　念真谛圣道未尝须臾忘也

佛言睹天地念非常睹山川念非常睹万物形体丰炽念非常执心如此得道疾矣　夫对天地睹山川及万物形体。虽然丰盛当念皆是有为生灭终归无常。修行之人若常如此起念即证圣必速矣

佛言一日行　谓终一日念念修行也

常念道行道遂得信根其福无量　若人于一日之中而能修习常念于道忆持不忘。或于一日而常行道修习不怠。乃能成就信等诸根得无量福。一日尚然而况多日其福弥盛

佛言熟自念身中四大各自有名都为无吾我者寄生亦不久其事如幻耳　有情之身俱是四大假合以成其形。仍假虚名也。且地水火风是名四大。以要言之。即骨肉毛发是地津液。精血是水。暖触是火。四支百脉摇动是风。各以假名成此幻身。若熟念之。何者为我寄生浮世倏忽而灭都如幻梦尔

佛言人随情欲求花名譬如烧香众人闻其香然香以薰自烧愚者贪流俗之名誉不守道真花名危己之祸其悔在后时　凡世之人但恣情欲惟求虚花之名不忧生灭。罔慕真实之道。譬如上妙之香被人所焚虽得远近普闻。其如形质速尽亦同愚者徒慕虚名而丧道真及祸至危己悔在后时也

佛言财色之于人譬如小儿贪刀刃之蜜甜不足一食之美然有截舌之患也　夫耽嗜财色少时快心及恶积祸来。沉沦六趣。亦如小儿刀刃之蜜。其甜味至少。徒截舌之祸尔

佛言人系于妻子宝宅之患甚于牢狱桎梏榔档牢狱有原赦　牢狱之苦。或值赦免

妻子精欲虽有虎口之祸已犹甘心投焉其罪无赦　夫世人为妻子羁绊宝宅萦心。祸患难免。甚于牢狱

佛言爱欲莫甚于色色之为欲其大无外　世间诸欲缠缚难解者。莫甚于色故知色欲之过其大无比也

赖有一矣假其二同普天之民无能为道者　滋生死障涅槃唯色欲一端楞严亦云淫心不除尘不可出

佛言爱欲之于人犹执炬火逆风而行愚者不释炬必有烧手之患贪淫恚怒愚痴之毒处在人身不早以道除斯祸者必有危殃犹愚贪执炬自烧其手也　凡世有贪淫恚怒愚痴之毒处人心中若有智者须早以道消去乃免危殃之祸犹如愚人不早释逆风之炬必自烧其手也

时有天神献玉女于佛欲以试佛意观佛道　天神者主天界之神也。玉女天女也。盖天欲试佛之意观佛之道如何也

佛言革囊众秽尔来何为以可诳俗难动六通去　遣去也

吾不用尔天神愈敬佛　如皮囊中贮诸秽恶。难惑六通之佛。六通谓。神境通。天眼通。天耳通。他心通。宿住通。漏尽通

因问道意佛为解释即得须陀洹　天既知神通不可惑乱。因问道意佛为说法。得证初果

佛言夫为道者犹木在水寻流而行不左触岸亦不右触岸不为人所取不为鬼神所遮不为洄流所住亦不腐败吾保其入海矣　木喻于人。海喻于道

人为道不为情欲所惑　修行之人坚持戒行不被情欲所惑。如木在流不为二岸所触

不为众邪所诳　正见之人坚持操行不被众邪诳惑。如沿流之木免其人鬼所取

精进无疑吾保其得道矣　木无众滞自至于海。如人之精进免其诳惑必得其道矣

佛告沙门慎无信汝意汝意终不可信　言当慎守正心勿信纵邪意。若信纵之即为烦恼牵惑也

慎无与色会色会即祸生　惟举色者。盖色能惑乱入生死苦海为祸根最大者也

得阿罗汉道乃可信汝意耳　缘阿罗汉烦恼断尽。任纵其意必不入邪见也

佛告诸沙门慎无视女人若见无见慎无与言　熟视其色当生欲情。若每见之想如无见。仍诫勿与交言也

若与言者敕心正行　若不护己为缘事故须至言语者即默自诫如下文

曰　默语也

吾为沙门处于浊世当如莲花不为泥所污　若欲发言。先正其心自诫之曰。我持净戒处兹浊世。当如莲花虽在淤泥不为所污

老者以为母长者以为姊少者以为妹幼者予敬之以礼　凡见女人当作此观想仍皆接之以其礼

意殊当谛惟　谛审也惟思也言当审思之

观自头至足自视内　意殊者谓情炽盛用前观想未能息者即想自己头至足。收视于内也

彼身何有唯盛恶露诸不净种。以释其意　既内视当想身中盛诸不净秽恶之物露泄不止。即邪意当息彼身自谓此身也

佛言人为道去情欲。当如草见大火来已劫道人见爱欲必当远之　佛诫修道之人去其情欲。当如枯草已被大火焚劫。言急切速避之

佛言人有患淫情不止踞斧刃上以自除其阴佛谓之曰若使断阴不如断心心为功曹若止功曹从者都息　功曹主者之称。从者谓功曹之从人。在上位者若严率其下。则从者自然凛惧故以心喻功曹。欲情喻从者。若自净其心欲情岂得生也

邪心不止断阴何益斯须即死佛言世俗倒见如斯痴人

有淫童女与彼男誓至期不来而自悔曰欲吾知尔本意以思想生吾不思想尔即尔而不生佛行道闻之谓沙门曰记之此迦叶佛偈流在俗间　过去诸佛知众生罪业皆从。妄想生起。妄想若息即无诸恶。故迦叶佛曾作此偈流传于后。及释迦佛因行道闻。此女自悔而诵故令沙门记之

佛言人从爱欲生忧从忧生畏无爱即无忧不忧即无畏　夫为前境所诱乃起爱欲。既为爱欲所惑忧畏从之而生。若本无爱欲。即忧畏何由而至矣

佛言人为道譬如一人与万人战　夫一人敢敌万人者。勇猛之极也。譬修道之徒发精进果决之志矣

被甲操兵出门欲战意怯胆弱乃自退走或半道还或格斗而死　意怯胆弱乃是退走以至半道而还。皆喻修行之人中路退心也。格斗而死。譬学道之人无坚刚之志毙于诸魔也

或得大胜还国高迁　夫将兵者。或立殊勋而施则。爵赏自然超于众也

夫人能牢持其心精锐进行不惑于流俗狂愚之言者欲灭恶尽必得道矣　夫被精进甲。仗智慧剑坚持戒行。魔障尽灭证无漏智。乃得道矣

有沙门夜诵经其声悲紧欲悔思返佛呼沙门问之汝处于家将何修为对曰常弹琴佛言弦缓何如曰不鸣矣弦急何如。曰声绝矣急缓得中何如曰诸音普调佛告沙门学道犹然执心调适道可得矣　佛闻声悲将施诲诱。乃询其在家所为既对弹琴。故佛因以琴声急缓喻之。夫修行之人必使妄念不生。身心虚寂则自然调适可得道果矣

佛言夫人为道犹所锻铁渐深垂去垢　垂字当作尽字垢乃铁中滓也

成器必好学道以渐深去心垢精进就道异即身疲身疲即意恼意恼即行退行退即修罪　异者谓不能尽去心垢精进成道故。使身心疲倦则烦恼。烦恼则戒行退。戒行退则翻成罪

佛言人为道亦苦不为道亦苦惟人自生至老自老至病自病至死其苦无量心恼积罪生死不息其苦难说　夫求道之人不惮众苦。寻师访道不避寒暑。不惮驱驰昼夜不卧修习禅定。或舍身判命救一切苦。此则学道之士虽有此苦。及证果之后乃出没三界逍遥自在。若尘世之徒惟恣三毒不思出离。轮回六趣无有休息。生老病死常在盖缠。罪业报应其苦无量

佛言夫人离三恶道得为人难　三恶道。谓地狱饿鬼畜生。故言免此三恶而得人身知其难也

既得为人去女即男难　女人之业经中具载得转男身斯为难也

既得为男六情完具难　既得男身六根具足免诸残废之疾。亦为难矣

六情已具生中国难　边鄙之地多诸障难。生在中国实为难也

既处中国值奉佛道难　夫人得生中土而能奉道勤修者鲜矣

既奉佛道值有道之君难　既勤修奉而时值明主则自在精进无诸障难。故为难也

既值有道之君生菩萨家难既生菩萨家以心信三尊值佛世难　得生正见之家复有信心乃值佛世诚哉难矣

佛问诸沙门人命在几间对曰在数日间佛言子未能为道复问一沙门人命在几间对曰在饭食间去子未能为道复问一沙门人命在几间对曰呼吸之间佛言善哉子可谓为道者矣　此佛诲诱学者令知念念无常在於呼吸。自然绝诸妄想密密精进若谓命在数日或在食顷则自宽其限妄念随生涉于懈怠安得成道也

佛言弟子去离吾数千里意念吾戒必得道　佛劝弟子若忧生死事大坚持戒行虽别师数千里其心如一必得道也

若在吾侧意在邪终不得道其实在行近而不行何益万分耶　若学者虽在师左右。而其意染邪必不成道。何者其要在闻而行之虽常近师而不能修习。无益于万分之一也

佛言人为道犹若食蜜中边皆甜吾经亦尔其义皆快行者得道矣　佛言我所说经由如蜜味若人食之中外尽甜更无二味。慕道之士。若悟经深旨身心快乐当证道矣

佛言人为道能拔爱欲之根譬如擿悬珠一一擿之会有尽时恶尽得道也　夫欲出生死苦得大自在必须坚持戒行断尽爱欲。如高处悬众珠一一擿之。苟心无懈怠即珠必有尽时。若修行之徒销其众恶。积诸善行久而不退。即诸恶断尽。乃得道也

佛言诸沙门行道当如牛负行深泥中疲极不敢左右顾趣欲离泥以自苏息沙门视情欲甚于彼泥直心念道可免众苦　言沙门直心行道欲出生死苦海。须念念相应勿起妄念。如牛负重于深泥中求避泥淖。以自苏息亦念念忧惧不敢左右顾也

佛言吾视王侯之位如尘隙视金玉之宝如瓦砾视纨素之服如弊帛视大千世界如一诃子视四耨水如涂足油视方便如筏宝聚视无上乘如梦金帛视求佛道如眼前花视求禅定如须弥柱视求涅槃如昼夜寤视倒正者如六龙舞平视等者如一真地视兴化者如四时木　夫至圣圆通道无不在。岂于世谛而有分别哉。益以大慈利生随机悟物。谓王侯之贵不可恃金帛之宝不足贪故。兴尘隙瓦砾之喻。以制其欲心。又以方便之门无上之乘佛道。禅定之名涅槃平等之类。可循而不可致滞。可习而不可迷方。因广去就之喻以防执缚之蔽也。闻道之士可以叩寂而悟之焉

诸大比丘闻佛所说欢喜奉行

佛说四十二章经

    题焚经台诗

        唐太宗文皇帝制

门径萧萧长缘苔。一回登此一徘徊。青牛谩说函关去。白马亲从印土来。确定是非凭烈焰。要分真伪筑高台。春风也解嫌狼藉。吹尽当年道教灰

此台在洛阳。台者坛也。考此烧经比论之坛。乃后汉明帝筑也。元此四十二章经皆有来因。是永平七年。明帝夜梦。一人体有金色项有日光。飞空而至殿前。明旦宣问群臣。有通人傅毅占梦。奏曰。臣闻西域有得道者。号曰佛。经举能飞具六神通。今应此梦。帝悟大悦。即遣羽林郎蔡愔。博士秦景王遵等十二人。望葱岭而往寻西土。求迎佛法行至中路。月氏国众乃骇然。得瞻迦叶摩腾共竺法兰二梵僧圆项方袍之异相。乘白马携释迦真像白[疊*毛]之图。并此四十二章一卷回朝。时永平十年也。帝喜躬亲迎。奉宣委鸿胪以陈国礼。敕令彩画释迦顶相于清凉台。因建立白马寺。请此二尊者住院。于帝说法至冬。值岁旦五岳道士贺正之次。道士褚善信。费叔才等。共六百九十人互相语曰。帝弃我道教远求胡教。乃自率众。各将所持道经共上表。愿与胡佛教比试其真伪。帝遂降敕尚书令宋庠。引入长乐宫前。宣曰道士与僧就元宵日骈集。白马寺南门外立两坛。至期试之。西坛烧道经六百余卷。顷刻烧尽。唯取得老子道经一卷是真。其余是杜光庭撰。今云杜撰也。帝观东坛佛像并此四十二章烧不能坏。但见五色神光。天雨宝花天乐自振。叹未曾有。帝共群臣称悦。太傅张衍语诸道士曰。既试无验可就佛法。其道士褚费等。深有愧恧皆气盛自死。余有吕惠通等六百二十人。皆弃冠帔投佛出家。因此流通佛教。州县建寺敬僧。始从四十二章。自后人续去取五千余卷。至今益显于世间。三界之中含识之类。蒙恩受赖绵绵不绝也


佛说阿弥陀经疏

    No. 1759 [cf. No. 366]

佛说阿弥陀经疏

        唐海东新罗国沙门元晓述

将释此经。三门分别。初述大意。次释经宗致。其第三者。则入文释。第一述大意者。夫众生心之为心也。离相离性如海如空。如空之故无相不融。何有东西之处。如海之故无性是守。岂无动静之时。尔乃或因染业随五浊而长流。或承净缘。绝四流而永寂。若斯动静皆是大梦。以觉望之无流无寂。秽土净国本来一心。生死涅槃终无二际。然无二之觉取之良难。迷一之梦去之不易。所以大圣垂迹有遐有迩。所陈言教或褒或贬。至如牟尼善逝现此秽土。诫五浊而劝往。弥陀如来御彼净国。引三辈而导生。今是经者。斯乃两尊出世之大意。四辈入道之要门。示净土之可愿赞妙德而可归妙德可归者。耳闻经名则入一乘而无反。口诵佛号则出三界而不还。何况礼拜专念赞咏观察者哉。净土可愿者。浴于金妙莲池则离有生之染因。游玉树檀林则向无死之圣果。加复见佛光入无相。闻梵响悟无生。然后乃从第五门出。回辔生死之苑。憩烦恼之林。不从一步普游十方世界。不舒一念遍现无边三世。其为乐也可胜度乎。极乐之称岂虚也哉。言佛说者。从金口之所出。千代不刊之教。阿弥陀者。含实德之所立。万劫无尽之名。能所合举以标题目。故言佛说阿弥陀经也。第二辨经宗致者。此经直以超过三界二种清净。以为其宗。令诸众生于无上道得不退转。以为意致。何者名为二种清净。如论说言。此清净有二种。一者器世间清净。二者众生世间清净。乃至广说故。然入此清净有其四门。一圆满门。唯佛如来得入此门。如本业经说。二一向门。八地已上菩萨得入此门。如摄大乘论说。三纯净门。唯有第三极欢喜地已上菩萨得入此门。如解深密经说。四正定聚门。唯无退者得入此门。无邪定聚及不定聚。如两卷经说。通论极乐世界。具此四门。今此经宗二种清净。正示第四正定聚门。不定声闻。及说凡夫亦得生故。论说二乘种不生。决定种性不得生故。声王经说。安乐世界阿弥陀佛有父母者。是变化女非实报女。论说女人不生彼者。无实女故。知变鸟此亦如是故。又复虽有父母而非胎生。寔是化生假为父母。如彼经言。若四众能正受彼佛之名号。以此功德。临命终时阿弥陀佛。即与大众往此人所。令其得见。见已寻生庆悦倍增功德。以是因缘。所生之处永离胞胎秽欲之形。纯处鲜妙宝莲华中自然化生。具大神通光明赫奕。当知父母假寄之耳。又彼经言。阿弥陀佛与声闻俱。如来应供正遍知。其国号曰清泰。圣王所住。其城纵广十千由旬。而观经说。彼佛身高六十万亿那由他恒河沙由旬。城小身大不相当者。当知彼佛有众多城。随众大小城亦大小。大城之中。示以大身。小城之中。现以小身。声王经十千由旬者。是与声闻俱住之城。当知佛身相当而住。观经所说身高大者。当知其城亦随广大。与诸大众俱住处故。如两卷经及此经中。池中莲华大小悬殊。随池有大小其华亦大小。当知城身大小亦尔。其余相违准此而通。或说。声王经中说有父母。是显彼佛所住秽土。是义不然。所以然者。彼经既说。宝莲华中自然化生。具大神通光明赫奕。又下文言有二菩萨。一名观世音。二名大势至。此二菩萨侍立左右。此等悉是净土相故。不异观经之所说故。当知彼经所说提婆达多。及魔王等。悉于净土变化所作。不由此等为非净土。如化畜生非秽土故。且止乘论还释本文。此下第三入文解释。文有三分。序正流通。序分之中有其六句。于中前二是其标句。其后四事证成前二。言如是者。总举所闻之法。表有信顺之心。言我闻者。别提能闻之人。表无违诤之意。下四则引二对证成。明忆闻时处。成能闻之不谬。既有大师大众。证所说之可信。于中委悉如常可知。第六序大众有三。先声闻众。次菩萨众。后杂类众。声闻众中。舍利弗者。此云身子。目揵连者。此云赞诵。迦叶者。此云饮光。迦旃延者。此云扇绳。摩诃拘絺罗者。此云大膝离婆多者。此云假和合。周利槃特伽者。此云蛇奴。或云小道难陀。此云庆喜阿难陀。此云欢喜。罗睺罗。此云覆障。或云宫生。憍梵波提。此云牛齝。宾头卢。此云耆年。颇罗堕。此云利根。迦留陀夷。此云黑上。此是悉达未出家时师也。劫宾那。此云房宿。薄拘罗。此云善容。阿[少/兔]楼驮。此云无贫。或云如意。菩萨众中。阿逸多者。此云无能胜。乾陀诃提者赤色。余则可知尔时佛告已下。第二正说分。于中有三。一者正示二种清净果。二者劝修二种正因。其第三者。引例证成。初中有二。略标广解中二句。先标依果。后标正报。释中亦二。先释依果。后释正报。依果清净之中义门有二。文相有六。别总功德有其十五义。门二。一释名门。二辨相门。六者名门开二。相门分四故。别总十五者。别有十四总成一故别有十四者。六文之中有其四例。前一各有一。后二各有二。第三文中开三。第四文中分五。是故合有十四功德。第一文言。无有众苦但受诸乐者。是无诸难功德成就。如论颂言。永离身心恼受乐常无间故。第二文言。七重栏楯罗网行树者。是庄严地功德成就。如论颂言。杂华异光色宝栏遍围绕故。第三文中有三功德。池水金沙者。是庄严水功德成就。如论颂言。诸池带七宝渌水含八德。下积黄金沙上耀青莲色故。阶道楼阁有金银等者。是种种事功德成就。如论颂言。备诸珍宝性具足妙庄严故。莲华如轮青色青光等者。庄严妙色成就功德。如论颂言。无垢光焰炽明净耀世间故。第四文中有五功德。一妓乐功德。常住天乐故。二宝地功德。黄金为地故。三雨华功德。六时雨华故。如论颂曰。金地作天乐雨华散其间。欢乐无疲极昼夜未尝眠故。四自在功德。乘通游行故。五受用功德。饭食经行故。如论颂曰。供养十方佛报得通作翼。爱乐佛法味禅三昧为食故。然彼土食有二种。一者内食。如此论说。二者外食。如余经说。如两卷经言。若欲食时。七宝钵器自然在前。百味饭食自然盈满。虽有是食而无食者。但见色闻香意以为足。今此经言饭食经行者文相合。于受用外食也。第五文中有二功德。如变化功德化作众鸟说妙法故。如论颂曰。种种杂色鸟各各出雅音。闻者念三宝忘想入一心故。二大义功德。无恶道等之名体故。如论颂曰。大乘善根男等无讥嫌名。女人及根缺二乘种不生故。案云。经说无有恶道讥嫌。论显无有人道讥嫌。互举之尔。义如所说。第六文中有二功德。如论说言。庄严虚空功德成就者。偈言无量宝交络罗网虚空中。种种铃发响宣吐妙法音故。二者庄严性功德。如论说言。庄严性功德成就者。偈言正道大慈悲出生善根故。今言自然间生念三宝心者。正是性心。以依出世善根种子。不待功用自然生故。正念三宝离邪归正。结道众行故名正道。念此三宝胜妙功德。回施一切名大慈悲。上来合有十四功德。无不超过三界六道。是故总名清净世界。如论说言。庄严清净功德成就者。偈言观彼世界相胜过三界道故。或有论说十八圆满。今此经中依果清净说。此十五若加后说正报四句。则有十九清净功德。然经与论有同有异。于中委悉准之可知。舍利弗于汝意云何。此下第二正报清净。于中示显四种功德。一者主功德。二者伴功德。三者大众功德。四者上首功德主功德中略出二种一者光明无量。二者寿命无量。准此经文释阿弥陀。此土译之应云无量。又言成佛已来于今十劫者。为遣疑情。有人疑言寿虽无量要有始终。未知今者为始为末。今解言。今既所过唯经十劫。当知今后无量劫住故。第二伴功德者。声闻弟子皆阿罗汉故。论云庄严眷属功德成就者。偈言如来净华众正觉华生故。案云。此言净华众者。谓得七种净华之众。何等为七。一者戒净。二者心净。三者见净。四度疑净。五道非道知见净。六行知见净。七行断知见净。于中广说出瑜伽论。有此七种浮华之众。从佛正觉华中化生也。第三大众功德者。众生生者。皆是阿鞞跋致故。乃至十念功德生彼国者。入正定聚永无退故。论言何者庄严大众功德成就。偈言人天不动众清净智海生故。案云。皆依如来智海。含润入正定聚无动转故。第四上首功德者。其中多有一生补处。乃至阿僧祇说故。言何者庄严上首功德成就。偈言如须弥山王胜妙无过者故。案云。一生菩萨十地中胜如妙山王故。论中具显八种庄严。此经略示四种功德。上来二文合为第一。示显二种清净果已竟。众生闻者应当发愿。自此已下。第二劝修二种净因。就中有四。一劝发愿。二明修因。三示受果。四结劝。言第二文中明二种因。一者正因。二者助因。正因中言不可以少善根福德因缘得生彼国者。显示大菩提心摄多善根以为因缘乃得生故。如菩萨地发心品文。又诸菩萨最初发心能摄一切菩提分法。殊胜善根为上首故。能违一切有情处所三业恶行。功德相应。案云。菩萨初发菩提之心。能摄一切殊胜善根。能断恶业功德相应。是故说言非少善根福德因缘得生被国。所以得知。此为因者。两卷经中摄九品因以为三辈。三中皆有发菩提心。论中唯显此文意。言大乘善根男等无讥嫌名。此意正言生彼国者。虽有九品齐因大乘发心善根。所以等无讥嫌之名也。有人难言。若要发大心方生净土者。不应生彼而证小果。彼无退具故。若乃退大而证小果无有是处故。又两卷经中十八愿中言。设我得佛。十方众生至心信乐。欲生我国。乃至十念。若不生者不取正觉。唯除五逆诽谤正法。若未发大心不得生者。则应亦拣未发心。而不拣故明知不必然。不至心为至心言之所拣。故更不须拣。虽有是破皆不应理。所以然者。发菩提心既是正因。未发心者。直是无因。而非有障何须拣别。五逆谤法乃是障碍。非直无因故须拣别。是故此难无所闻也。又非生彼退菩提心。但在此间先发大心熏成种子。后时退心下地现行。良由先发大心种子不失。故得作因以生彼国。而退现行大乘之心。故生彼国取小果耳。是故彼难还显自短之耳。第二明助因者。执持名号一心不乱。故阿弥陀如来不可思议功德所成之名号故。一日乃至七日者。胜人速成劣者迟熟故。声王经说。十日诵名者。劣人十日乃成故。或一二日等是下品因。五六七日者。是中品因。乃至十日成上品因。故其人已下。第三受执。我见已下。第四结劝。上来四文合为第二劝修因竟。如我今者赞叹已下。大分第三引例证成。于中有四。一者引余佛说证有可信。二者释此经名成有胜利。三者举愿无违重劝发心。四者叹法希结劝信受。初中先辨自所称赞。后引六方诸佛同赞。于汝意云何已下。是第二文。于中有三问。次第三劝信。若有人发愿已下。是第三文。先示愿势。后劝发愿。如我今者已下。是第四文。于中有三。先己赞他。次他赞己。其第三者结叹劝信。上来三分正说文竟。佛说已下。是流通分

佛说阿弥陀经疏(终)

往生教观。真摄心成道之要术也。而小本弥陀不特时所宗尚秦译。且造疏立章者。众生有以六方佛已去。为流通分。虽近古尝辟之。晚学又乃承用。不遇指南何从正辙。唐初海东晓法师。不唯以佛说此经已下为流通分。且以执持名号为助因。此尤超然。拔萃于诸疏之上。予获是本喜不自胜。俟他日刻诸梓与天下共之。则使浪断经科臆判正助者。当北面敛衽俯伏而抱愧焉。时庆元四年五月既望。霅川乌戌比丘宗相题跋


佛说阿弥陀经疏b

    No. 1760 [cf. No. 366]

    刻弥陀经义疏序

孤山圆师撰弥陀经义疏。后又钞之名曰西资。吾邦未见流行。学者憾焉。比偶获义疏。订正镂刻。使学者免传写之劳。他日若有得钞者。与此疏并行于世。则在西刹行者。岂不大资哉。窃望焉

  时

正德甲午仲秋谷旦

            谈峰莲光院沙门光荣谨书

佛说阿弥陀经疏(并序)

        孤山沙门释智圆述

夫心性之为体也明乎静乎一而已矣。无凡圣焉。无依正焉。无延促焉。无净秽焉。及其感物而动随缘而变则为六凡焉。为三圣焉。有依焉。有正焉。依正既作则身寿有延促矣。国土有净秽矣。吾佛大圣人得明静之一者也。乃假道于慈托宿于悲。将欲驱群迷使复其本。于是乎无身而示身无土而示土。延其寿净其土。俾其欣促其寿秽其土俾其厌。既欣且厌则渐诱之策行矣。是故释迦现有量而取秽土。非欲其厌耶。弥陀现无量而取净土。非欲其欣乎。此则折之。彼则摄之。使其复本而达性耳。故净名曰。随所调伏众生而取佛土者。其是谓乎。虽宝楼金地无悦目之玩。而非惑荡之色而能达唯心无境矣。虽风树鸟声有入耳之娱。而非惉懘之音而能念三宝有归矣。夫如是则复乎明静之体者如转掌耳。经云众生生者皆是阿鞞跋致是也。大矣哉圣人之善权也如此。是故群经森列而偏赞净方。其有旨哉。佛说阿弥陀经者。其偏赞之谓欤。吾爱其辞简而理明其文约而事备足可以诱弱丧而击童蒙焉。于是约龙树之宗。准智者之说。依经辨理为之义疏。若极深研几则吾岂敢。庶乎有助于真风。为益于后昆尔

释题玄义五重。二土果人名也。方等实相体也。信愿净业宗也。舍苦得乐用也。生苏大乘教也。夫名以诠体。会体由宗。宗成有用。四义成列。大小未辨。故须教相区以别之。初六字之名有通有别。经字通名。大小同号故。上五别名。此说异彼故。于别名中佛是果人之通名。弥陀是果人之别号。释迦既此方化主。庶物咸知。故隐别而彰通。弥陀是彼土世尊。理须标简。故略通而存别。通别互现其义惟明。若统而括之凡有三对。经即能诠之教。上乃所诠之义。教义对也。阿弥陀标彼土世尊。佛说指此方化主。彼此对也。说者诚实口业。佛者黄金之色身。身口对也。宽之狭三对在焉。佛者极果之美号也。果必由因克。始悟名因。悟必从迷。不迷何悟。迷非本是悟复何从。欲瓢明斯旨。当晓六即。一理即佛。二名字即佛。三观行即佛。四相似即佛。五分真即佛。六究竟即佛。凡圣不滥故六初后皆是故即。理即佛者。一念心即如来藏理。如故即空。藏故即假。理故即中。三智一心本来具足非适今也名理即佛。名字即佛者。理虽即是自用不知。以未闻三谛不识佛法。如牛羊眼不识方隅。或从知识或从经卷闻如上说。于名字中通达解了。知一切法皆是佛法名名字即佛。观行即佛者。若但闻名口说。如虫食木偶得成字是虫不知是字非字。既不通达。宁是菩提。必须心观明了理慧相应所行如所言所言如所行言行相应名观行即佛。相似即佛者。愈观愈明。愈止愈寂。粗垢自落。六根互□□□□证如鋀似金贵实珠形色相似名相似即佛。分真即佛者。因相似观入初住位。破无明见佛性。开秘藏显真如。始发心终等觉。或普门示现于九界利生。或八相成道以佛身度物名分真即佛。究竟即佛者。从等觉心转入妙觉。智光圆满不可复增。惑闇灭尽更无可断。唯佛与佛乃能知之名究竟即佛。譬若贫人家有宝而无知者。知识示之而后知。于是耘除草秽而掘出之渐渐得近。近已藏开尽取用之获大富乐。以喻六即。其旨可见。今言佛者即释迦化主乃究竟人也。如此解者岂但识果地之崇高必由因克。抑亦达自心之微妙本有果性。是则始凡理具趣取无怯。终圣在佛上慢不生。说者悦也。得机而说称悦。佛怀此经即得彼物机。与弥陀有缘者乃赞彼依正令发愿往生。既生彼国则不退转而终趣菩提称悦。佛其在此矣。阿弥陀梵语也。兹言无量。阿之言无。弥陀言量也。何故名无量耶。以四义故得名。一光明照耀无量。二寿命数限无量。三大小弟子无量。四一生补处无量。由兹四事以无立尊号。诸经翻为无量寿佛者。乃下之一义耳。四义悉在经文。夫诸佛皆有生法二身则有两种无量。一生身无量。此则有量之无量。二法身无量。此是无量之无量。法身譬虚空无生无灭。生身如水月有隐有显。故释迦弥陀俱得法身之无量。但此土机劣故见生身是有量。彼土根胜故见生身是无量。但以人天莫数故言无量。若望法身定属有量。当知释迦亦能现无量以取净土。弥陀亦能现有量以取秽土。故大论曰。释迦文佛更有清净国土如阿弥陀佛国。阿弥陀佛亦有不严净国如释迦文佛国。又云此间阎浮提恶故佛寿应短。余处好故佛寿应长。涅槃云。西方去此三十二恒河沙有无胜国。所有庄严如安乐世界。我于彼土出现于世。岂非释迦现净耶。鼓音王经云。阿弥陀佛婆罗门种。母名殊胜妙颜。亦有恶逆弟子名为调达。既有女人及恶逆者。岂非弥陀现秽耶。故知二佛生身皆为两重。若示净秽随缘不同。问释迦既自能现净土。何故不劝众生发愿生彼而度令往弥陀国耶。答物机不等。为化亦殊。若唯于一佛有缘则始终自化。若于二佛有缘则彼此共化。是故释迦现秽土而折伏。弥陀现净土而摄受。此折彼摄共熟众生令至菩提耳。问菩萨法应度众生。何以但求乐国。答大论四十三有此问而龙树答云。菩萨有二种。一者慈悲心多为众生。二者多集诸佛功德。乐多集功德者至一乘清净无量寿国土。好多为众生者至无佛法僧处赞叹三宝之音。问若尔应乐多集功德者即不化众生也。答不然。先后异耳。故大论四十五又云。菩萨有先自成就功德然后度众生者。有先成就众生后自成就功德者。经者梵言修多罗。义翻契经者。诠表义理契合人心。即契理契机也。经者佛地论云。能贯能摄故名为经。以佛圣教贯穿所应说义摄持所化生故。释名竟。二辨体者。方等实相为经正体。方谓方广。等谓平等。实相之体横遍诸法故言方广。竖该凡圣故言平等。是则圆融大乘悉名方等。但鹿园一向说小。十二年后创谈斯理。故偏得其名。所以无量义云。次说方等摩诃般若。涅槃云。从酪出生生苏。譬从修多罗出方等典皆指第三时也。此经既属生苏。则宜用此名以释其体。应知弥陀由究显此体故依正庄严。众生由理具此体故愿生。即得方广平等其在此乎。然则体义有三。谓主质义底义达义也。若乃为四章之所依作三分之所趣。况四民之臣主喻三光之丽天。此主质义也。若乃大乘因果无非实相。智度大海唯佛穷底。此即体是底义也。若乃般若是一法佛说种种名。实相亦尔。多诸名字号。此即体是达义也。释体竟。三明宗者。信愿净业为经宗致。然则宗者要也。种种众行言因则摄。无量功德言果则摄。当知因果并宗要。经云应当发愿生彼国土。是明因也。又云闻是经受持者皆得不退转于阿耨多罗三藐三菩提。是明果也。虽两义兼有而因正果傍。以正劝行人求生故。故经云若有信者应当发愿生彼国土。又云闻说阿弥陀佛执持名号乃至七日即得往生。故以信愿净业为宗也。明宗竟。四论用者。此经以舍苦得乐为用也。用谓力用。依言修习能舍此方之众苦得受彼国之极乐。是经之力用也。论用竟。五判教者又二。一教味区别。二经疏因起。初文此经既对告声闻弟子。验非初乳顿说。而谈众生作佛。岂是酪味小乘。不说诸法皆空。则非熟苏般若。又不开会二乘故异法华涅槃。教文贞实当第三生苏方等大乘也。详其所劝。该乎人天及四教初心。比乎观经。则彼乃定业此唯散善。彼被圆机此通偏渐。论得生则但云心不颠倒即得往生。岂与夫乘金刚台证无生忍同耶。语庄严则但云华如车轮。岂与夫华叶小者纵广二十五由旬同耶。以此观之优劣可知矣。二经疏因起者。此经有新旧两译。一秦罗什法师旧译。名佛说阿弥陀经。一唐玄奘三藏新译。名称赞净土佛摄受经。秦本立题即依经云如我今者称赞阿弥陀佛不可思议功德之利也。唐本立题即依经云当信是称赞不可思议功德一切诸佛所护念经也。护念乃摄受之异名耳。乃知两译立题各有文证。今所解者秦本也。此疏之因起。予忝学天台之道。誓欲用三观法门撰十疏以伸十经以为法施之资焉。笔削之功已及其七会卧疾经年。虑石火不久过隙难留。有负畴昔之心。于者乎遂扶羸隐几续成其三。即无量义普贤观及此经也。彼二疏中各有因起一章。斯文也染毫于大宋天禧五年辛酉十月晦。绝笔于十一月二日午后。虽辞理无取。庶填本誓且为往生之先容也。十疏既毕。一生几何。空华之躯谷响之言于我何有哉。是时予行年四十六也。世有弥陀经疏。自日东传来言智者说者非也。词俚义疏。谅倭人之假托乎。判教竟。释经为三。一从如是讫列众为序。二从尔时讫生彼国土为正宗。三从舍利弗如我今者讫经为流通。诸经皆有通别两序。六事同有故言通。发起事异故言别。此经存通而阙别。问佛说诸经皆有发起。或因献盖。或由放光。或饭讫收衣。或晡时禅起。何于此经全无由藉乎。答夫大圣垂范皆有兴致。但事非特异。故译者略而不叙耳。何者。以此众集。知必请法。是故如来无问自说。应知集众义兼发起。新译则有其词。故彼经集众之末乃云。为闻法故俱来会座。是也。而诸经咸有如是等六事者。大论明。佛将灭度。阿难咨问。一切经首当安何语。答云当言如是我闻佛住某国与某大众等。岂唯我然。三世诸佛经初皆尔也。今释六事作二意分之。前三彰阿难。后三显教主。前三者。一阿难示所闻。如是故。二阿难显能闻。我闻故。三阿难指闻时。一时故。后三者。一称教主美号。佛故。二明教主所居住舍卫等故。三示化主徒众。与大比丘等故。虽离成二意。终成阿难之证信也。言如是者。实相之理无二相称如。绝百非曰是。经诠此理故云如是。又如是只是指事之词。谓如是净土之教是我亲闻故。次句即云我闻也。我闻者。我有三种。一见二慢三名字。阿难于结集时已是无学人则见慢俱尽。但为传化故顺世间名字称我也。闻者大论云。耳根不坏。声在可闻处。因缘和合作意欲闻即闻也。然则理本无闻。顺世称闻尔。一时者。谓如是净土之教我闻当于某年某月某日也。而不言年等但云一时者。以诸国王制立时各不同故。如此土四时彼三际东夏以合朔为月旦西干以既望为月旦。两方尚尔。四夷可知。既难以准定故通言一时耳。佛者。夫法通四人所说。今指亲从佛闻。非从弟子诸仙诸天化人而闻也。天竺言佛陀此翻觉者。谓究竟觉了诸法唯只是心。如此觉了之人故号觉者。在舍卫国等者。谓我从佛闻乃有其处。即在舍卫祇园闻佛说也。在者住也。如来本住寂光。怜悯众生故迹住舍卫。梵语舍卫此翻闻物。谓具足欲尘财宝之物闻解脱之人故也。祇树等者。即只陀太子所施之树。给孤长者所施之园。只陀此云战胜。波斯匿王太子生时。王与外国战胜。因立其名。给孤独者。此方语梵云须达多。翻为善施。以善行施故乡人美之名给孤独也。少而无父曰孤。老而无子曰独。以此长者常给施此人故。树先园后者。君尊臣卑故。与大比丘下徒众也。阿难谓非但我于祇园独闻。况佛与声闻菩萨诸天人天众同住。而我厕预其间同得闻故。所以六事展转相由者。阿难意在谬非谬传以生物信也。父为三。一声闻众二菩萨三杂众。以形服言之。则声闻规顶炬袍每居佛侧故先。菩萨随机外厥状不常故次。人天身非出俗故后。众生但见其迹莫测其本。故以形服而分胜劣。若以内心。则声闻沈空。人天著有。菩萨从中道。故列于季孟之间以表示之。声闻众分六。一明类。二示数。三显位。四叹德。五列名。六总结。与大比丘僧明类也。与共也。大者梵云摩诃。而含三义。大义多义胜义。此诸尊者悉为天王大人所敬故言大。遍解内外典籍故言多。超出九十五种外道故言胜。译者偏就一义而翻也。比丘者因果六义。因名乞士怖魔破恶。果号应供杀贼无生。乞士者告求资身永离四种邪食故。怖魔者。发心出家魔王怖其出境故。破恶者。能破九十八使烦恶因故。而此所列同闻众皆大罗汉。名虽在因其实果人也。僧者具云僧伽。此翻众和合。谓四人以上乃至无量示事理二和无有违诤故名众也。千二百五十人俱者示数也。佛初成道度五人讫乃化三迦叶。谓优楼频螺伽耶那提也。兄弟共有弟子千人。次化舍利目连。二人共有弟子二百五十人。悉翻邪向正而获上果。感佛之恩故常随侍。又普曜云。诸经多列千二百五十人者。重其最初归佛故经家列之。而未必俱在会也。皆是大阿罗汉显位也。谓诸比丘非是学人。皆无学极果也。罗汉含三义。一应供。堪为人天福田故。此乃乞士之果也。二杀贼。断尽烦恼故。此乃破恶之果也。三无生。不受后有故。此乃怖魔之果也。众所知识叹德也。闻名钦德曰知。睹形敬奉曰识。长老下列名。舍利此翻珠子亦身子。以其母好身形而聪明之相在乎眼珠。因名珠亦名身也。尊者是珠所生故名珠子。摩诃目揵连者。摩诃云大。目揵连云胡豆亦采菽。上古有仙。隐居求志。采菽豆而食。尊者是彼苗裔也。同姓者众。标大以别之。摩诃迦叶此云大饮光。古仙身光翕赩吞饮余光使不得现。从此命族。迦旃延云扇绳。尊者早孤。其母恋子不得再嫁。如绳系扇。由是立名。俱絺罗云大膝。以膝盖大故。舍利弗舅氏也。离婆多云室星。北方宿也。父母祷此星而生子故。周梨槃陀伽者翻蛇奴。或言周利云大路边。槃陀伽云小路边。以此尊者生于道旁故。诸经律谓周梨槃特是也。难陀云喜。本牧牛人。以牧牛事诸佛。佛为说法。然后入道。阿难陀此云庆喜。佛之从弟也。以佛成道日生。举国欣庆因立喜名。罗睺罗云障蔽。此修罗之名。以其能障蔽日月故。此尊者障佛出家。如修罗障月故。乃如来之嫡子也。憍梵波提云牛齝亦牛迹。以过去为牛故。口有牛齝。足有牛蹄之相。宾头卢颇罗堕或云宾度罗跋罗堕阇。或云军屠钵汉。皆梵音楚夏也。宾头卢翻不动。颇罗堕真谛三藏翻揵疾或利根或广语。本行集翻重幢。婆罗门十八姓中一姓也。尊者是彼种族故。迦留陀夷云黑光或粗黑。以其形丑黑故。劫宾那云房星。以父母祷房星得子故。薄呴罗云善容。以彼好容仪故。阿[少/兔]楼驮云无贫亦无灭。以其常富是故。如是下总结。弟子者。学居师后故称弟。解从师生故称子。弟则显师之谦让。子乃明资之尊仰。并诸下菩萨众又三。一明类二列名三总结。初文菩萨者。菩谓菩提此云觉。萨谓萨埵此云众生。谓以智上求菩提。以悲下救众生也。列名中文殊师利此云妙德。以微妙三德分开发故。法王子者大论云。佛为法王。菩萨入法正位乃至十地故悉名法王子。皆任为佛。如文殊师利也。阿逸多此云无胜。超出偏小故。乾陀诃提此云不休息。中道正观念念流入故。常精进者无二边懈怠。与如是等总结也。及释提桓因下杂众。具云释迦因陀罗。此翻能天帝。能为诸天作主故。言等者等取梵王护世也。此皆天主上首。无量诸天即其余天众也。大众即总包人及修罗等也。经末结益云一切世间天人阿修罗等闻佛所说。故知在会也。新经则于此备列之。尔时下二正宗分为二。一总告二别示。初文告舍利弗者。经家叙对告人也。所以不告菩萨诸天而告声闻者。意令小乘初心欣乐求生回小入大故。身子已证上果在方等时菩提心死。自谓证入无余究竟灭度。大乘望之方生变易。而此二途并不求生极乐同居也。今如来对告者高训下耳。问且小初求生。岂名入大耶。答经云阿耨多罗三藐三菩提。岂非入大耶。从是下总告之辞也。初句明相去之数量。次二句明依正之名号。前句指界标名。后句举佛显号。简非过未故云今现在法。舍利下二别示为二。一明二报庄严。二劝愿生彼国。初又二。一依报二正报。初又二。一征名释义。二约报示相。初又二。一征名。其国下二释义。故名极乐者。以对娑婆备有众苦故受极乐之名。若四土转论其乐未极。言四土者。一凡圣同居土。谓具缚凡夫断惑圣人同居住故。二方便有余土。谓修方便道断四住惑。而余有无明在故。所以出三界外受法性身而有变易生死也。三实报无障碍土。谓修中道真实之观破无明惑。得生彼土而受色心无碍之报也。四常寂光土。即心性妙理也。常即法身。寂即法身。寂即解脱。光即般若。应知前三是事。后一是理。三土如像如饭。寂光如镜如器。若各论苦乐者。五浊重故苦。体观断惑巧故乐。方便也。次第修证故苦。圆融顿入故乐。实报。分证未极故苦。究竟圆满故乐。寂光也。初后约果论苦乐。中二望因明苦乐。若展转相望。则前七皆苦。后一唯乐。当知究竟寂光乃名极乐耳。佛意欲令一切咸至第八之乐故。且赞第二令厌初苦。若得第二既不退转则第八可期。大圣之善权其若是乎。又舍利弗下二约报示乐相。为五。一栏网行树庄严。二池水楼阁庄严。三金地天华庄严。四奇妙杂鸟庄严。五风树妙音庄严。由兹五严故名但受诸乐也。初文栏楯者。栏槛也。纵曰栏。横曰楯。四宝者。金银琉璃水精也。二池水楼阁庄严。八功德水者。称赞净土经云。一澄清。二清冷。三甘美。四轻软。五润泽。六安和。七饮时除饥渴。八饮已长养诸根。亦以金银下列七宝也。琉璃具云吠琉璃。此云不远。以西域有山去波罗奈城不远山出此宝故以名之。字体本作流离。后人从玉。颇梨正云窣坡致迦。其状少似此方水精。然有赤白二色。车渠梵云牟娑洛揭拉婆。此云青白色宝。尚书大传曰。大贝如大车之渠。渠谓车[車*閏]。赤珠者。佛地论赤虫所出或珠体赤名赤珠。智论云。真珠出鱼腹中竹中蛇脑中。不必唯生蚌胎也。玛脑梵云摩婆罗伽隶。此云玛脑。此宝色如马之脑。因以为名。新本云阿湿摩揭柆。此云藏杵。或翻胎藏。取此宝坚实为名字体作马脑。后人加石或玉。池中下明莲华有三。先通示形量。如车轮故。次示光色。有四异故。后总示香气。微妙香洁故。三金地天华庄严。曼陀罗翻适意。以适悦人意故。其色白故或翻为白华也。衣裓古释云衣襟也。真谛云外国盛华器也。饭食经行者。食后经行以消息故。四奇妙杂鸟庄严。又二。一正明二释疑。初文凡有四意。一举类。二列名。三演音。四显益白鹤者。相鹤经曰。体尚洁故其色白。声闻天故其顶赤。食于水故其啄长。轩于前故后指短。栖于陆故足高而尾凋。翔于空故毛丰而肉疏。大喉以吐故。修颈以纳新。故生天寿不可量。鹦鹉者山海经云。黄山有鸟如鸮。青羽赤啄人舌能言名曰鹦鹉。郭璞注云有白者。舍利者此云春莺或翻鹙鹭。迦陵频伽此云妙声。在[穀-禾+卵]中其音已超众鸟故。共命之鸟者。两首一身异神识同报命故名共命。法华云命命。天王云生。涅槃云耆婆耆婆。悉此鸟耳。耆婆梵语。此翻活或翻生或翻命。故知雅音者雅正也。演畅者。演广也畅通也。五根谓信进念定慧也。能生曰根。增进堪任非障曰五力。七菩提分者云觉分亦支也。诸经云七觉支是也。七者谓念择进喜轻安定舍。前一兼定慧。次三是慧。后三是定。八圣道分者。诸经谓八正道是也。八者正见正思惟正语正业正精进正定正念正命。闻是音已下显益也。念佛如医王。念法如良药。念僧如瞻视人。三者既备则烦恼之病可差也。此念别想三宝耳。又反观自心寂而常照则诸相炳然念佛。照而常寂则无法可得名念法。寂照不二即存亡亡存和合名念僧。此念同体三宝也。众鸟一音演说。众生随类各解。故约别相同体两义释之。舍利下二释疑又二。一斥内疑二为解释。初文者恐身子内心疑云。既有杂鸟则有畜趣。此三恶之一也。以由众生造罪而感三恶报生。何名净土耶。故佛斥云。汝勿谓此鸟实是罪报所生也。所以下二为解释又二。一简非二显是。初又二。一直言彼无。二举名况实。初文汝莫言实是造罪感报。以彼土无三恶道也。舍利弗下二举名况实。且彼净土尚无三恶道之名字。况有罪报所生之实体乎。是诸下二显是如文。五风树妙音庄严如文。舍利弗于汝意下二明正报。问以身望土则身贵而土贱。何故先土而后身。答有二意。一者名便既报名依正故先土后身。二者义便以世界先成后乃佛出故。就文分二。一征名释义。二约报示相。初又二。一征名。阿弥陀此云无量。舍利下二释义又二。一明名含二义。二明成道十劫。初文有二义故得无量名。一光明无量。二寿命无量。问释迦光明亦能照无量国。应名阿弥陀。答释迦现劣应身常光一寻而已。及现通放光方照无量。彼佛现胜应身常光无量。故受其名。舍利下二明成道十劫。以前总告云今现在说法故。此示其已成之劫数也。又舍利下二约报示相又二。一大小弟子庄严。二生者不退庄严。前言庄严则庄严极乐。此言庄严则庄严无量。语同意别也。然则弟子是其辅佐。生者是其人民。既二皆无量故使法王名无量也。望前共有四义。一光明二寿命三弟子四生者。此四皆无量。是故号阿弥陀也。前二从自。后二从他。初文谓声闻弟子菩萨弟子悉无量也。声闻者闻四谛声教而悟道故。又舍利弗下二生者不退庄严。阿鞞跋致此翻不退转。而不退有三。位行念也。通教初果以去齐罗汉位不退。七地行不退。八地念不退。别教以信行向对之。初地证念不退。向但修耳。圆教初信至七信位不退。八信以去行不退。初住证念不退。经云皆是则义必该三。一生补处即等觉也。彼国既寿长境胜故于生身多至等觉。阿僧祇翻无数。舍利弗众生闻者下二劝愿生彼国。文为三。一总劝二别示三结意。初文众生闻者。谓闻向依报极乐正报无量也。与诸上善人是同彼正。俱会一处是同彼依。舍利弗下二别示又二。一反显二正示。初文不可以小善得生。则反显可以多善得生也。小善谓等闲发愿散乱善称名。多善谓执持名号要期日限。舍利弗下二正示又四。一修因二感相三显益四得生。初文执持名号者。执谓执受。持谓任持。信力故执受在心。念力故任持不忘。其人下二感相。是人下三显益。即得下四得生。悉如文。舍利弗下三结意。我见是利故说此言者。谓见彼世界土极乐寿命无量二报庄严之利也。遂劝众生发愿生彼故云故说此言。舍利弗下三流通分文为二。一佛劝流通。二众喜会散。初又三。一诸佛同赞二结劝往生。三举难劝信初又二。一明释迦赞。二显诸佛同。初如文。东方下二显诸佛同。而但列六合者。秦本略也。唐译则十方备矣。就文为六。谓四方上下也。而各有二。一叙彼佛现相表彰。汝等下二示彼佛发言劝信。阿閦鞞此云无动。不为二边所动故。出广长舌表无虚妄故。汝等众生当信等者劝信此经也称赞至佛所护念。是此经别名也。唐译名称赞净土经者正依此文也。称赞不可思议功德。释迦说弥陀之依正。一切诸佛所护念。显十方诸佛咸随喜护故使天魔不能挠乱念故令信者不退菩提。日月灯喻三智故。名闻光者。名称普闻如光遍照。大焰肩者。肩表二智。焰表照理。须弥灯者。须弥云妙高。妙则三智圆融。高则超过因位。灯则喻三智之遍照也。难沮者。内证实相四魔不沮败。网明者。智明如网遍覆十界故。达磨此云法也。下连法幢持法故存梵以异其文。而此三名似表三谛。法乃真空寂然可轨。法幢则俗谛照者可见。持法则中道双持二边。杂色宝华严身者。以万行因华严佛果之体故。娑罗此云坚固。舍利弗于汝意下二结劝往生又二。一闻经佛利益。二明愿生功能。初又三。一牒异名起征。舍利弗下二约经佛显益。阿耨多罗云无上三藐云正。又三云等。菩提云觉。极果超因故云无上。正则正观中道。等则双照二边。盖果上一心三智也。是故下三总结劝双信。舍利弗下二明愿生功德又二。一举愿显益。若已生等者。过去已发愿者已生。现在今发愿者今生。未来当发愿者当生。是故下二约信结劝。佛法大海信为能入智为能度故。舍利弗下三举难劝信又二。一明我赞彼。二明彼赞我。初文今者称赞。即所举六方是也。彼诸下二明彼赞我又二。一举彼赞二显不虚。初文释迦翻能仁。牟尼翻寂默。能仁则大悲应物。寂默则大智冥理。能为甚难希有之事者。一于五浊得菩提。二为众生说难信法。娑婆云堪忍。以众生堪任忍受三毒故。劫浊者梵语劫波。此云时分。下四浊聚在此时名为劫浊。见浊者即身边等五利使。烦恼浊即贪嗔等五钝使。众生浊者。揽利钝果报而立假名催年促寿谓之命浊。通言浊者。譬如沙土投之清水。土失留升水亡清洁汨然浑浊。今由此五浊理水亡清。说是难信之法者。说一日执持名号命终即生极乐而得不退菩提。以兹少善根获此利。是为难信也。然则凡夫贤圣等无高下。心净土净超越须臾若生极乐。甚易可信。但为迷深执重闻而不受故云难信耳。舍利弗下二结不虚。是为甚难者。五浊界中行难行之行而得菩提。其事已难。复说此难信之法。二事兼作。是甚难也。诸佛赞我。岂虚言哉。佛说下二众喜会散。阿修罗云非天。彼趣富乐如天。而多谄诳无天行。故因受其名。闻所未闻故欢喜信受。重法尊师故作礼而去

佛说阿弥陀经疏


佛说阿弥陀经要解

    No. 1762 [cf. No. 366]

佛说阿弥陀经要解

        三藏法师鸠摩罗什译

        西有沙门蕅益智旭解

原夫诸佛悯念群迷随机施化。虽归元无二而方便多门。然于一切方便中求其至直捷至圆顿者。莫若念佛求生净土。又于一切念佛法门之中求其至简易至稳当者。莫若信愿专持名号。是故净土三经并行于世。而古人独以阿弥陀经别为日课。岂非有见于持名一法普被三根。摄事理以无遗统宗教而无外尤不可思议也哉。古来注疏代不乏人。世远就湮所存无几。云栖和尚着为疏钞。广大精微。幽溪师伯述圆中钞。高深洪博。盖如日月中天有目皆睹。特以文富义繁边涯莫测。或致初机浅识信愿难阶。故复弗揣庸愚再述要解。不敢与二翁竞异。亦不敢与二翁强同譬如侧看成峰横看成岭。纵皆不尽庐山真境。要不失为各各亲见庐山而已。将释经文五重玄义

第一释名者。此经以能说所说人为名。佛者此土能说之教主。即释迦牟尼如来。乘大悲愿力生五浊恶世。以先觉而觉后觉。无法不知无法不见故名佛也。说者悦所怀也。佛以度生为怀。众生机熟。佛为应时说法令得度。脱故悦也。阿弥陀者。即所说彼土之导师。以四十八愿接信愿念佛众生。令生极乐世界永阶不退者也。梵语阿弥陀此云无量寿亦云无量光。以要言之。功德智慧．神通道力．依正庄严．说法化度．一一无量．聊举寿命光明二事以为言端耳。经者训法训常。一切金口所宣通名为经。今对佛说阿弥陀五字即是通别合为题也。教行理三各论通别。广如台藏所明。自应寻之。兹不繁述

第二辨体者。诸大乘经皆以实相为正体。何谓实相。即现前一念心之自性是也。吾人现前一念心性不在内．不在外．不在中间．非过去．非现在．非未来．非青黄赤白．非长短方圆．非香．非味．非触．非法。觅之了不可得而不可言其无。具造百界千如而不可言其有。离一切缘虑分别相而缘虑分别。亦非离此实相别有自性。离一切语言文字相而语言文字。亦非离此实相别有自性。以要言之。离一切相即一切法。唯其离一切相故无相。惟其即一切法故无不相无相无不相故不得已强名实相。实相之体非寂非照。而复寂而恒照。照而恒寂。照而恒寂强名为常寂光土。寂而恒照强名清净法身。又照而恒寂强名法身。寂而恒照强名报身。又性德寂照强名法身。修德寂照名报身。又修德照而恒寂名为受用身。修德寂而恒照强名应化身。当知寂照不二．性修不二．身土不二．无非实相。实相无二亦无不二。是故举体作依．作正．作法．作报．作自．作他。乃至能说所说．能度所度．能信所信．能愿所愿．能持所持．能生所生．能赞所赞．二无非实相正印之所印也

第三明宗者。宗是修行之要径会体之枢机而万行之纲领也。提其纲则众目皆张。挈其领则襟袖随至。故次体之后应须辨宗。此经以信愿持名为修行之宗要。非信不足以启愿。非愿不足以导行。非持名妙行不足以满其所愿而证所信。是故经中先演极乐依正以生信。次劝应当发愿以导行。次示七日持名以径登不退。信则信自．信他．信因．信果．信事．信理。愿则厌离娑婆欣求极乐。行则执持名号一心不乱。信自者。信我现前一念之心本非肉团．亦非缘影。竖无初后．横绝边涯．终日随缘．终日不变。十方虚空微尘国土元我一念心中所现之物。我今虽复昏迷倒惑。苟能一念回心决定得生自己心中本具极乐。更无疑虑。是名信自。信他者。信彼释迦如来决无诳语。弥陀世尊决无虚愿。六方诸佛广长舌决无二言。随顺诸佛真实教诲。决志求生更无疑惑。是名信他。信因者。深信散乱称名犹为成佛种子。何况一心不乱安得不非生净土因。是名信因。信果者。深信净土上善聚会皆从念佛三昧得生。譬如种瓜得瓜．种豆得豆。亦如影必随形．响必应声。决无虚弃。是名信果。信事者。深信只今现前一念不可尽故。所以依心所现一切十方世界亦不可尽。实有极乐国土。在十万亿土之外。最极清净庄严不同庄生寓言。是名信事。信理者。深信极乐国土虽在十万亿土之远。而实不出我只今现前介尔一念心外。以吾现前一念心性实无外故。又复。深信西方依若正若主伴皆吾现前一念妙明真心中所现影。全事即理．全妄即真．全修即性．全他即自。我心遍故佛心亦遍。佛心遍故一切众生心性亦遍。譬一室千灯光光互遍。重重交摄不相妨碍。是名信理。如此信已则娑婆即自心所感之秽。而自心秽理应厌离。极乐即自心所感之净而自心之净理应欣求。厌秽须舍至究竟方无可舍。欣净须取至究竟方无可取。故妙宗钞云。取舍若极与不取舍亦非异辙。今设不从事于取舍。但尚不取不舍。即是执理废事。既废于事理亦非圆。若达全事即理。则取亦即理舍亦即理。一取一舍无非法界。故次信之后而明愿也。言执持名号一心不乱者。名以召德。德既不可思议故名号亦功德亦复不可思议。名号功德不可思议故使散乱称名为佛种。况执持至一心不乱安有不径登不退者乎。然诸经所示净土要行万别千差。如观像观想礼拜供养五悔六念等。一一行成皆生净土。而惟此持名一法收机最广下手最易。故释迦慈尊于此经中无问自说。特向大智舍利弗拈出。可谓方便中之第一方便．了义中无上了义．圆顿中最极圆顿。故古人云。明珠投于浊水浊水不得不清。佛号投于乱心乱心不得不佛也。信愿持名以为一乘真因。四种净土以为一乘妙果。举因则果必随之。故以信愿持名为经正宗。至于四种净土之相。详在妙宗钞及梵网玄义。兹不具述。俟后消释依正文中。当略点示耳

第四明力用者。往生不退为力用。往生有四土各得论九品。今且略明得生四土之相。若执持名号未断见思者。随其或散或定自于同居土中分三辈九品。若执持名号至于事一心不乱见思任运先落者。则生方便有余净土。若执持名号至于理一心不乱。豁破无明一品乃至四十一品。则生实报庄严净土。亦名分证常寂光土。若无明断尽则是上上实报亦是究竟寂光也。不退有四义。一念不退。二行不退。三位不退。四毕竟不退。一念不退者。破无明显佛性。径生实报分证寂光。二行不退者。见思既落尘沙亦破。生方便土进趋极果。三位不退者。带业往生在同居土。莲华托质永离退缘。四毕竟不退者。不论至心散心．有心无心．或解或不解。但令弥陀名号一历耳根或六方佛名或此经名字一经于耳。假使千万劫后毕竟因斯度脱。如闻涂毒鼓远近皆丧。又如食少金刚决定不消也

第五教相者。此是大乘菩萨藏摄。又是无问自说。彻底大慈之所加持。能令末法多障有情依斯径登不退。故虽经法灭。尽之后。仍以悲心弘愿特留此经。住世百年广度含识譬如。阿伽陀药万病总治。绝待圆融不可思议。华严之奥藏法华之秘髓。一切诸佛之心要菩萨万行之司南。皆不出于此矣。设欲广为叹述穷劫莫尽。有智者自当知之

入文为三。初序分二正宗分三流通分。此三分者名为初善中善后善。阙一不可序分如人之首五官具存。正宗如人之身脏腑无阙。流通分如人之手足运行不滞。故智者大师释法华经。初品作序。中十五品半为正。后十一品半皆为流通。又一时迹本二门各分三段。则法师讫安乐行五品皆为迹门流通。盖序必总提一经之纲领。而流通则法施方不壅于来世。其关系殊非浅小。后人不达才见经文稍涉义理。便一概判入正宗。致使序及流通不过如八寸三帽子一顶草鞋一双而已。安所称初语亦善中语亦善后语亦善也哉

  初序分二。初通序二别序。初中二。初标法会时处。二引大众同闻。今初

如是我闻一时佛在舍卫国祇树给孤独园　如是标信顺。我闻标师承。一时标机感。佛标教主。舍卫国祇树给孤独园标说经处也。如是者实相妙理古今不变名如。依实相理念佛求生净土决定无非曰是我闻者阿难了知实相之理非我非无我不坏假名故仍称我。耳根发耳识亲聆圆音。如空印空故名为闻。一时者时无实法。特以师资道合终竟一会。说听周足故名一时。佛者自觉觉他觉行圆满。人天大师故名为佛。舍卫此云闻物。中印度大国之名。波斯匿王所都也。祇树给孤独园者。匿王太子名为只陀此云战胜。匿王大臣名须达多长者。此翻给孤独。给孤长者布金买园。供佛及僧。余有少地未布。只陀感叹不复取价施此少地。故并存二名也

  二列大众同闻三。初声闻众二菩萨众三天人众。声闻最居初者。一是出世相故。二是常随从故。三佛法赖僧传故。菩萨众居中者。一以相不定故。二以不常随故。三表中道义故。天人众列后者一是世间相故。二凡圣品杂故。三明外护侍从法应尔故。初声闻众又三。初明类标数。二表位叹德。三列上首名。今初

与大比丘僧千二百五十人俱　与者共义。大比丘者受具足戒出家人也。比丘是梵语。含三义故不翻。一乞士义。谓一钵资身无所蓄藏专求出要。二破恶义。谓正慧观察破烦恼恶不堕爱见。三怖魔义。谓发心受戒羯磨成就魔即怖也。僧者具云僧伽。此翻和合众。理和则同证无为解脱。事和则有六种。所谓身和同住。口和无诤。意和同悦。见和同解。戒和同修。利和同均也。千二百五十人者。三迦叶波兄弟师资共千人。舍利弗目犍连师资二百人。耶舍长者子等五十人。皆佛成道未久先得度脱感佛深恩故为常随众也

  二表位叹德

皆是大阿罗汉众所知识　大阿罗汉是表位。众所知识是叹德。阿罗汉含三义。一应供义即乞士果。二杀贼义即破恶果。三无生义即怖魔果。复有慧解脱俱解脱无疑解脱三种不同。今是无疑解脱故名大也。又实是法身大士。示作声闻证此净土不思议法故名大也。从佛转轮广利人天故为众所知识

  三列上首名

长老舍利弗摩诃目犍连摩诃迦叶摩诃迦旃延摩诃拘絺罗离婆多周利槃陀伽难陀阿难陀罗睺罗憍梵波提宾头卢颇罗堕迦留陀夷摩诃劫宾那薄拘罗阿[少/兔]楼驮如是等诸大弟子　德腊俱尊故名长老。舍利弗此云鹙鹭子亦云身子。母身端正眼如鹙鹭。从母得名也。声闻众中智慧第一摩诃目犍连此云大采菽氏。神通第一。摩诃迦叶此云大饮光。身有金色光明。头陀胜行第一。传佛心印为西土初祖。摩诃迦旃延此云大文饰。南天竺婆罗门种。论议第一。摩诃拘絺罗此云大膝。即舍利弗之母舅。答问第一。离婆多此云星宿。无倒乱第一。周利槃陀伽此云继道。因根钝故调息悟道。仅持一偈入定演说。辩才无尽。义持第一。难陀此云喜。佛之亲弟。仪容第一。阿难陀此云庆喜。佛之堂弟。复为侍者。多闻第一。罗睺罗此云覆障。佛之太子。密行第一。憍梵波提此云牛齝。宿世恶口感此余报。受天供养第一。宾头卢此云不动。尊者之名。颇罗堕此云利根。尊者之姓。久住世间应末世供。福田第一。迦留陀夷此云黑光。为佛使者。教化第一。摩诃劫宾那此云房宿。知星宿第一。薄拘罗此云善容。寿命第一。阿[少/兔]楼驮或云阿那律陀。此翻无贫又翻无灭又翻如意。亦佛堂弟。天眼第一。如是等诸大弟子者。结略指余也。此等诸大弟子本是法身大士。亦作声闻为影响众。今于此会同闻净土摄受功德。则能得第一义悉檀之益。任运增道损生自净佛土。复名当机众矣

  二菩萨众

并诸菩萨摩诃萨文殊师利法王子阿逸多菩萨乾陀诃提菩萨常精进菩萨与如是等诸大菩萨　并者承前声闻众而言之。菩萨摩诃萨此云大道心成就有情。乃悲智双运自他兼利之称。文殊师利此云妙吉祥亦云妙德。佛为法王。菩萨绍佛家业名法王子。菩萨众中智慧第一。自非勇猛实智。不能证解净土法门。故最居初。阿逸多此云无能胜。即弥勒菩萨之名。当来下生成佛。现在居等觉位。正以究竟严净佛国为其要务。故次列之。乾陀诃提此云不休息。旷劫修行不暂停故。常精进者自利利他无疲倦故。与如是等诸大菩萨亦结上例余也。此等深位菩萨亦必求生净土。以不离见佛不离闻法不离亲近供养众僧。乃能速疾圆满菩提故

  三天人众

及释提桓因等无量诸天大众俱　及者亦上文声闻菩萨言之。释提桓因此云能为主。即忉利天王。主四天下者也。等者下等四王。上等夜摩兜率化乐他化乃至色无色界。故云无量诸天。又云大众俱者。谓八部修罗人非人等无不与会。无非净土法门所摄之机也。通序竟

  二别序发起序也。净土妙门甚深不可思议。无人能问。故佛自唱彼土依正名字而为发起。又佛智鉴机无有错谬。见此大众应闻净土妙门而获四益。故不俟人问便自发起。如梵网下卷自唱位号云我今卢舍那等。智者大师亦判作发起序。例可知也

尔时佛告长老舍利弗从是西方过十万亿佛土有世界名曰极乐其土有佛号阿弥陀今现在说法　净土法门三根普摄。绝待圆融不可思议。甚深难信故特呼大智慧者而与之言。以非第一智慧不能直下无疑故也。从是者从此娑婆世界也。西方者横亘直西。标所示现之处也。过者超越也。十万亿者千万曰亿。今又积亿至十万也。佛土者三千大千世界通为一佛所化名一佛土。且以此土言之。一须弥山东西南北各一洲。同一日月所照。同一小铁围山所绕名一四天下。千四天下名小千世界。千小千名中千世界。则有百万须弥四洲日月及小铁围。千中千界名为大千世界。则有十万须弥等故名三千大千世界。过如此等佛土共十万亿之西方是极乐世界也。问何故极乐定在西方。答此非善问。假使极乐在东。汝又须问。何故在东。岂非戏论。况自娑婆视之则极乐在西。倘自十一万亿佛土视之则极乐又在东矣。何足致疑。有世界名曰极乐者。序依报国土之名也。过去现在未来迁流名世东西南北四维上下方隅为界。既示依报则必竖约三世以辨时劫。横约十方以定疆隅。故称世界。言极乐者梵语须摩提此翻极乐。亦翻安养亦翻安乐亦翻清泰。乃永离众苦第一安隐之谓。具如下文广释。然佛土有四。各分净秽。所谓凡圣同居土。五浊重者则秽。五浊轻者则净。方便有余土。析空拙度证入者秽。体空巧度证入者净。实报无障碍土。次第三观证入者秽一心三观证入者净。常寂光土分证者秽究竟满证者净。今正指同居净土。亦即横具上三净土也。其土有佛号阿弥陀者。序正报教主之名也佛是通名。阿弥陀是别名。梵语阿弥陀此云无量寿无量光等。亦如下广释。佛有三身名论单复。法身单者指所证理性。报身单者指能证功德智慧。化身单者指所现相好色像。法身复者一自性清净法身。二离垢妙极法身。报身复者一自受用报身。二他受用报身。化身复者一示生化身。二应现化身。又一佛界化身。二随类化身。虽辨单复三身。实则非一非三而三而一。不纵横不并别。离过绝非不可思议。今云阿弥陀佛正指同居土中示生化身。仍复即报即法。故令闻名必得不退也。今现在说法者。简非过去已灭。亦非未来未成。正尔说法度生。故应发愿往生亲觐说法速成正觉也。复次有世界有佛现在即劝信序也。世界名极乐即劝愿序也。佛号阿弥陀即劝持名妙行序也。复次阿弥陀序佛也。说法序法也。说法必有听众。序僧也。佛法僧同一实相。序体也。从此起信愿行。序宗也。信愿行成必得往生见佛闻法。序用也。唯一佛界为所缘境不杂余事。序教相也。文略意周矣。初序分竟

  二正宗分二。初广陈彼土依正妙果以启信。二正劝众生发愿持名以成因。信愿持名一经要旨。信愿为慧行。持名为行行。得生不得生全由信愿之有无。品位高下全由持名之深浅。故慧行为前导。行行为正修。如目足并运也。初文为二。初陈依报国土妙。二陈正报主伴妙。初又二。初总标名义。二别释庄严。今初

舍利弗彼土何故名为极乐其国众生无有众苦但受诸乐故名极乐　娑婆苦乐相杂。苦是苦苦。逼身心故。乐是坏苦。不久住故。不苦不乐是行苦。性迁流故。彼土永离三苦。不同此土对苦之乐。乃名极乐。盖凡圣同居净土五浊轻。故无分段八苦。但受不病不死自在游行天食天衣上善聚会等乐。方便有余净土体观既巧。故无沈空滞寂之苦。但受游戏神通等乐。实报庄严净土一心圆证。故无隔别不融之苦。但受无碍不思议乐。寂光净土究竟平等。故无法身渗漏真常流注之苦。但受称性圆满究竟乐也

  二别释庄严四。初明地树庄严。二明池楼华色庄严。三明天乐华雨庄严。四明法音庄严。今初

又舍利弗极乐国土七重栏楯七重罗网七重行树皆是四宝周匝围绕是故彼国名为极乐　栏楯以严际畔。罗网以严空界。行树以严露地。各言七重者。表七科道品。皆是四宝者。表常乐我净四德。周匝围绕者。彼土佛及菩萨并诸声闻其数无量则有无量住处亦有无量七重栏楯罗网行树遍满彼国。处处庄严不可穷尽。故云周匝围绕也。同居净土此等庄严。则是增上善业所感。亦是圆五品观所感。以缘生微妙五尘为体。方便净土此等庄严。则是即空观智所感。亦相似三观所感。以妙真谛无漏五尘为体。实报净土此等庄严。则是妙假观智所感。亦分证三观所感。以妙俗谛无尽五尘为体。常寂光土此等庄严。则是即中观智所感。亦是究竟三观所感。以妙中谛称性五尘为体。欲令易解作此分别。得意为言。四土庄严一一无非因缘生法。一一无不即空假中。下皆仿此。不复繁述。问同居方便实报三土得言栏楯行树池楼华雨等一切庄严。常寂光土既惟理性。何得亦有此等庄严。答一一庄严无非全体理性。一一理性具足无量庄严。方是诸佛究竟依果。若谓寂光不具胜妙五尘。何异小乘所证偏真法性

  二明池楼华色庄严

又舍利弗极乐国土有七宝池八功德水充满其中池底纯以金沙布地四边阶道金银琉璃玻璃合成上有楼阁亦以金银琉璃玻璃砗磲赤珠玛瑙而严饰之池中莲华大如车轮青色青光黄色黄光赤色赤光白色白光微妙香洁舍利弗极乐国土成就如是功德庄严　七宝池者。金银等七宝所成之池。不同此方土石所成也。八功德者。一澄净二清冷三甘美四轻软五润泽六安和七除饥渴八长养诸根也。充满其中者。不同此方或时枯竭或时泛滥也。池底纯布金沙者。不同此方惟是污泥也。池边阶道四宝合成者。不同此方惟是砖石也。陛级名阶。坦途名道。重屋名楼。岑楼名阁。亦以七宝严饰。不同此方惟是土木丹青也。莲华大如车轮者。轮王金轮大四十里。且举华之最小者言。若据观经及宝积无量寿会。则大小品类实不可量。青色名优钵罗。黄色名拘勿头。赤色名钵头摩。白色名芬陀利。色必有光。盖由净业所感。不同此方之华有色无光也。又极乐莲华光色无量。此经亦略言耳。微妙香洁是略叹莲华四德。结云成就如是功德庄严者。明上来所说种种庄严皆是阿弥陀佛大愿大行称性功德之所成就。故能普遍庄严四种净土。普摄十方三世一切凡圣令往生也

  三明天乐华雨庄严

又舍利弗彼佛国土常作天乐黄金为地昼夜六时雨天曼陀罗华其土众生常以清旦各以衣裓盛众妙华供养他方十万亿佛即以食时还到本国饭食经行舍利弗极乐国土成就如是功德庄严　诸天所作微妙乐音恒无间断。故云常作天乐。七宝所严清净地界体是黄金故云黄金为地。初日分后日分名昼三时。初夜分中夜分后夜分名夜三时。故云昼夜六时。然彼土佛及菩萨各有身光众生生者亦有身光。常明不闇。不假日月光明。安分昼夜。或以华开鸟鸣为昼。华合鸟栖为夜。或虽实无昼夜。且顺此方常习假说昼夜耳。曼陀罗者天华之名。此云适意亦云白华。从空而下故名为雨。众生者上自等觉下至凡夫。衣裓者盛华之器。众妙华者即所雨天华。明其非止曼陀罗一种而已。应如法华经所明四华以表住行向地四因位也。供养他方佛者。即表真因会趋极果果德无所不遍也。仅言十万亿者。且据极乐。去此娑婆十万亿土。意显得生极乐国已欲还供释迦弥勒皆不难耳。若据弥陀神力所加。则何远不到哉。即以食时还到本国者。明其神足自在不假逾时也。饭食经行者既云食时故云饭食。念食则食自至。不俟造作安排。食毕则钵自去。不劳洗拭收举。故但经行宝地任运进修而已。凡圣同居净土其乐已自如此。况即于彼土又可横超方便实报寂光。其乐又当何如

  四明法音庄严又二。初别明二种法音。二结叹功德成就。初中二。初化鸟音。二风树音。初又二。初正明法利。二征释伏疑。今初

复次舍利弗彼国常有种种奇妙杂色之鸟白鹤孔雀鹦鹉舍利迦陵频伽共命之鸟是诸众鸟昼夜六时出和雅音其音演畅五根五力七菩提分八圣道分如是等法其土众生闻是音已皆悉念佛念法念僧　种种奇妙杂色之鸟言其多且美也。且寄此间所爱赏者。以言其似。舍利即鹙鹭。及白鹤孔雀鹦鹉四种皆此地所有。人所共珍。迦陵频伽此云妙音。未出[穀-禾+卵]时已有音声超众鸟故。此地所无。共命鸟一身两头识别报同。亦此地所无。西土雪山等处有此二种。然皆不可比于极乐奇妙众鸟。特言其似而已。言昼夜六时出和雅音。则知净土亦不以鸟栖为夜。当知实无昼夜假说昼夜。良以莲华化生之身本无昏睡不假夜卧故也。五根五力等者。三十七道品也。不言四念处四正勤四如意足者。文省略耳。三十七品通于四教。四念处者。一身念处。二受念处。三心念处。四法念处。四正勤者。一已生恶法令断。二未生恶法不令生。三未生善法令生。四已生善法令增长。四如意足者。一欲如意足。二进如意足。三心如意足。四思惟如意足。五根者信进念定慧也。信正道及助道法名信根。行正道及诸助道善法勤求不息名精进根。念正道及诸助道善法更无他念名念根。摄心在正道及诸助道善法中相应不散是名定根。为正道及诸助道善法观于苦等四谛名慧根。五力者。信根增长能破疑惑破诸邪信及破烦恼名信力。精进根增长破种种身心懈怠成办出世大事名精进力。念根增长破诸邪念成就一切出世正念功德是为念力。定根增长能破乱想发诸事理禅定是为定力。慧根增长能遮通别诸惑发真无漏是为慧力。七菩提分者亦名七觉分。一智慧观诸法时。善能简别真伪不谬取诸虚伪法。名择法觉分。二精进修诸道法时。善能觉了不谬行于无益苦行常勤心在真法中行。名精进觉分。三若心得法喜善能觉了此喜。不依颠倒之法而生欢喜住真法喜。名喜觉分。四若断除诸见烦恼之时。善能觉了除诸虚伪不损真正善根。名除觉分。五若舍所见念着境时。善能觉了所舍之境虚伪不实永不追忆。名舍觉分。六若发诸禅定之时。善能觉了诸禅虚假不生爱见妄想。名定觉分。七若修出世道时。善能觉了常使定慧均平。或心沉没当念用择法精进喜三觉分以察起之。或心浮动当念用除舍定三觉分以摄持之。调和适中。名念觉分。八圣道分者亦名八正道分。一修无漏行观见四谛分明名正见。二以无漏心相应思惟动发觉知筹量。为令增长入大涅槃。名正思惟。三以无漏慧除四邪命。摄诸口业住一切正语中。名正语。四以无漏慧除身一切邪业住清净正身业中。名正业。五以无漏慧通除三业中五种邪命住清净正命中。是为正命(五邪命者。一为利养故诈现异相奇特。二为利养故自说功德。三为利养故占相吉凶为人说法。四为利养故高声现威令人敬畏。五为利养故说所得供养以动人心)六以无漏慧相应勤精进修涅槃道。名正精进。七以无漏慧相应念正道及助道法。名正念。八以无漏慧相应入定。名正定。此等道品若依生灭四谛而修即藏教道品。若依无生四谛而修即通教道品。若依无量四谛而修即别教道品。若依无作四谛而修即圆教道品。藏道品名为半字法门。净土浊轻似不必用。为小种先熟者或暂用之。通教道品名大乘初门。三乘共禀同居净土多应说之。别教道品名为独菩萨法。同居方便二种净土亦多说之。圆教道品名为无上佛法。有利根者于四净土应皆得闻也。结云如是等法者。等前念处正勤如意足。等余一切四摄六度十力无畏无量法门也。虽诸佛法三十七品收无不尽。而为机缘不等或作种种开合名义不同。以要言之。随所欲闻无不演畅。故能令闻者皆生。念佛念法念僧之心。所念三宝亦有别相一体乃至四教义意之不同。如余经论广明

  二征释伏疑

舍利弗汝勿谓此鸟实是罪报所生所以者何彼佛国土无三恶道舍利弗其佛国土尚无恶道之名何况有实是诸众鸟皆是阿弥陀佛欲令法音宣流变化所作　恐有疑曰。既是净土。何有众鸟。故今释曰。非罪报所生。乃弥陀欲令法音宣流故变化作此诸鸟耳。问既云无恶道名。则白鹤孔雀等独非畜生道名耶。答既非罪报所生。则一一名字皆诠如来究竟功德。所谓究竟白鹤究竟孔雀等。无非性德美称。岂更名恶道哉。问佛欲法音宣流。随所化现皆可。何必化作众鸟。答有四悉檀因缘。一者凡情喜此诸鸟。顺情而化之。令欢喜故。二者鸟尚说法。令闻之生善故三者鸟能说法。不于众鸟起下劣想。对治分别心故。四者鸟即弥陀化作。不异弥陀法身。令悟法身平等无所不具亦无所不造故

  二风树音

舍利弗彼佛国土微风吹动诸宝行树及宝罗网出微妙音譬如百千种乐同时俱作闻是音者自然皆生念佛念法念僧之心　众鸟法音是化作有情声。风树法音是化作无情声。情与无情同宣妙法。皆是阿弥陀佛愿力所成种智所现。皆是吾人净业所感唯识所变。佛心生心互为质影。如众灯明各遍似一。全理成事。全事即理。全性起修。全修在性。读者亦可深长思矣。奈何舍此净土而别谈唯心净土甘堕鼠即鸟空之诮也哉。初别明二种法音竟

  二结叹功德成就

舍利弗其佛国土成就如是功德庄严　重重结叹欲令闻者深信而不疑也。初陈依报国土妙竟

  二陈正报主伴妙二。初明教主妙。二明眷属妙。初中二。初总征二别释。今初

舍利弗于汝意云何彼佛何故号阿弥陀　二别释二。初约光明释。二约寿命释。今初

舍利弗彼佛光明无量照十方国无所障碍是故号为阿弥陀　心性寂而常照故为光明。今彻证心性无量之体。故光明无量也。十方三世诸佛皆悉彻证心性全体。皆悉照十方国无所障碍。皆可名无量光。而由因中愿力不同。各随因缘以立别名。今佛昔为法藏比丘所发四十八愿曾有光明恒照十方之愿。故今果成如先所愿也。法身光明竖穷横遍故无量。报身光明称真法性故无量。此则佛佛道同。若夫应身光明则有或照一由旬者。或照十旬百旬千旬者。或照一世界者。或照十百千世界者。惟弥陀普照十方无量世界故别名无量光。然三身不一不异。为令众生得四益故强作此分别耳

  二约寿命释又二。初正明主伴寿皆无量。二兼示成道已经十劫。今初

又舍利弗彼佛寿命及其人民无量无边阿僧祇劫故名阿弥陀　犹云彼佛及其人民寿命皆无量无边阿僧祇劫。盖西域每用倒文故也。心性照而常寂故为寿命。今彻证心性无量之体故寿命无量也。法身寿命无始无终故无量。报身寿命有始无终故无量。此亦佛佛道同。皆可名无量寿。应身则随愿随机延促不等。今以法藏比丘四十八愿曾有佛寿无量及人民寿命亦无量之愿故。今果成亦如先愿别名无量寿也。此则实有限量。特以人天莫数名无量耳。然三身既不一异。则应身亦可即是无量之无量矣。问佛寿无量可也。人民寿命胡得亦无量耶。答佛本愿力不思议故。信愿持名功德不思议故。信愿持名是正因缘。佛本愿力是增上缘

  二兼示成道已经十劫

舍利弗阿弥陀佛成佛已来于今十劫　前文既明弥陀现在说法。此文又明未来寿命无量。故今更明过去成佛已经十劫也。然法身本无成与不成。不应论劫。报身因圆果满名成。应身为物示生名成。皆可论劫。又法身因修德显亦可论成论劫。报身别无新得。应身如月印川。亦无成与不成亦复不应论劫。然诸佛成道各有本迹。本地并不可测。且约西方极乐示成之迹则成佛十劫即是三身一成一切成。亦是非成非不成而论成也。问唯识论云。过去未来皆非实有。今胡得云过去十劫未来无量耶。答过去未来非现非常。所以不可执为实有。亦复岂可执为定无。且现在一刹那法唯识论中纵许有实体用。岂不言其无间即灭不容稍停又何尝执为定实定常。须知对今现在故说过去成十劫。而过去已灭。宁别有十劫堆积何地犹未化耶。又复对今现在故说未来寿命无量。而未来未至。宁别有无量劫预贮何地渐次来耶。须知时劫无性。故三世当体全空。而无性原非断灭。故时劫差别宛尔。虽复差别宛尔。并是现前一刹那中所现影子。故曰十世古今始终不离于当念也。思之。初明教主妙竟

  二明眷属妙又二。初声闻菩萨妙。二生者不退妙。今初

又舍利弗彼佛有无量无边声闻弟子皆阿罗汉非是算数之所能知诸菩萨众亦复如是舍利弗彼佛国土成就如是功德庄严　问往生论云。二乘种不生。何故彼佛仍有声闻弟子。答定性二乘不回向菩提不发大愿则不得生。若先习小行临终回向发愿则便得生。虽得生已小习先熟。佛顺其机为说小法彼寻证果。旋即向大不终滞于小也。是故不同此土藏教声闻直俟法华开会方得入圆。应是通教声闻或是别教七住先断见思故名阿罗汉耳。盖藏通二教不闻他方佛名。今既得闻弥陀名号信愿往生。总属别圆二教之所摄矣。声闻菩萨不可算数。并是弥陀因中大愿大行所致。故云成就如是功德庄严

  二生者不退妙

又舍利弗极乐国土众生生者皆是阿鞞跋致其中多有一生补处其数甚多非是算数所能知之但可以无量无边阿僧祇说　阿鞞跋致此云不退。而有三义。一位不退。证入圣流不堕凡地故。二行不退。恒欲度生不堕二乘地故。三念不退。心心流入萨婆若故。若约此土则藏初果通见地别七信圆初信名位不退。通菩萨别十行圆十信名行不退。别初地圆初住名念不退。今净土中则虽五逆十恶十念成就带业往生居下下品者例皆得三不退。以净土无退缘故。又一生净土则皆寿命无量。任运进修直至一生补处。观彼十方世界何处无佛何处机熟。便往示现成佛。故一生补处甚多。非是算数所能知也。初广陈彼土依正妙果以启信竟

  二正劝众生发愿持名以成因三。初劝发愿。二劝立行。三总结劝。今初

舍利弗众生闻者应当发愿愿生彼国所以者何得与如是诸上善人俱会一处　前既举彼土依正妙果以劝深信。今更劝闻而信者随应发愿以求往生。信愿二种即是往生净土之要领也。何者。若不闻有极乐依正之名。或复为说而不肯信。则不得名为闻。今既得闻。便属别圆二教初机。故教之以发菩提愿。盖彼国虽通四土。然既在此娑婆三界之外。又非二乘所证偏空涅槃境界。故但肯发愿求生。即属别圆二教弘誓所摄。以既不求人天福报又不求声闻缘觉。非是菩提大愿而何。设使或求人天或求趋寂。则非生彼国之愿矣。故此愿生彼国之愿从深信生。合此信愿的为净土指南。而下文执持名号乃为正行。若信愿坚固。纵使临终十念一念亦决得生。若无信愿。纵使将此名号作个语头。持至风吹不入雨打不湿如银墙铁壁一般。亦万无一得生净土之理。修净业者不可不知也。所以者何下。征释应当发愿往生之故。得与如是诸上善人俱会一处。指前文所说无数阿罗汉无数诸菩萨乃至无数一生补处人也。苟无大信大愿。何得与此诸上善人会一处哉。大本阿弥陀经亦以发菩提愿为要。正与此同

  二劝立行

舍利弗不可以少善根福德因缘得生彼国舍利弗若有善男子善女人闻说阿弥陀佛执持名号若一日若二日若三日若四日若五日若六日若七日一心不乱其人临命终时阿弥陀佛与诸圣众现在其前是人终时心不颠倒即得往生阿弥陀佛极乐国土　生净土者即得不退。又与诸上善人俱会一处。如此不可思议横超法门。故非善根福德鲜少者所能生也。菩提正道名为善根。即是亲因种种助道施戒禅等名为福德。即是助缘。声闻独觉菩提名少善根。人天有漏福业名少功德。皆不可生净土。唯以信愿执持名号。则一一声中皆悉具多善根福德。纵令散心称名善根福德亦不可量。况一心不乱哉。故使感应道交文成印坏。弥陀圣众不来而来亲承接引。行人心识不往而往托质宝莲也。善男子善女人者。不拣在家出家。不论贵贱老少。亦复不拘六趣四生。但得闻佛名者即是多劫善根成熟。即五逆十恶亦皆名善男女也。闻说阿弥陀佛即闻慧。执持名号即思慧。一心不乱即修慧。阿弥陀佛是万德洪名。以名可德。罄无不尽。故即以执持名号而为正行。不必更涉观想参究等行。至简易至直捷也。闻而信信而愿乃肯执持。不信不愿与不闻等。虽亦得为远因。不名闻慧。执持则念念忆佛名号故是思慧。然有事持理持。事持者信有西方阿弥陀佛。而犹未达是心作佛是心是佛。但以决志愿求生故。如子忆母无时暂忘名为事持。理持者信彼。西方阿弥陀佛是我心具是我心造。即以自心所具所造洪名。而为系心之境令不暂忘名为理持。一日乃至七日者。克期辨事也。利根一日即得不乱。钝根七日方得不乱。中根或二三四五六日不定。又利根即能七日不乱。钝根仅能一日不乱。中根或六五四三二日不定。持至一心不乱便成修慧也。一心亦有二种。谓不论事持理持。持至伏除烦恼乃至见思先尽。皆名为事一心。又不论事持理持。持至心开见本性佛。皆名为理一心。事一心则。不为见思所乱。理一心则不为二边所乱。不为见思所乱故感变化身佛及诸圣众现在其前。心不复起娑婆界中三有颠倒。即得往生同居方便二种极乐世界。不为二边所乱故感受用身佛及诸圣众现在其前。心不复起生死涅槃二见颠倒。即得往生实报寂光二种极乐世界。当知执持名号虽复简易直捷。仍复至顿至圆。以一念相应即一念佛念念相应即念念佛。不劳观想不必参究。当下圆明无余无缺。上上根人终不能踰其阃。下下根人亦可臻其阈。可谓横该八教竖彻五时。所以彻底悲心无问自说。且深叹其难信也。问临终佛现宁保非魔。答修心之人不作佛观而佛忽现。非本所期故名魔事。念佛见佛已是相应。况在临终非致魔时。何须疑虑。问七日不乱约平时耶约临终耶。答约平时也。问若约平时则假如有人。七日不乱之后更复起惑造业亦得生耶。答若果得一心不乱之人决无更复起惑造业之事。问大本十念宝王一念约平时耶约临终耶。答十念通于二时。若晨朝十念则属平时。若十念得生则与观经十声称名是同但约临命终时。一念则但约临终时。问既十念一念并皆得生。何故此经要须七日。答若无平时七日工夫。安有临终十念一念。纵令观经所明下品下生五逆十恶之人现世不曾修行。并是夙因成熟。故感临终得遇善友闻便信愿。如此等事万中无一。岂可不预辨资粮乃侥幸于万一哉。问西方去此十万亿土何得即生。答十万亿土并不出我现前一念心性之外。以心性本无外故。又仗佛力接引。何难即生。问既判信愿属慧行持名属行行。则执持名号应是助行。何名正行。何得一一声中皆悉具多善根福德。答依一心说信愿行。非有先后亦非定三。盖无愿无行不名真信。无行无信不名真愿。无信无愿不名真行。今全由信愿而持名号。故一一声中信愿行三皆悉圆具。所以名多善根福德因缘。观经所谓称佛名故于念念中除八十亿劫生死之罪。此之谓也。若使善根福德不多。安能除罪如此之大。问临终念力猛切故能除多劫罪。平日至心称名亦除罪否。答譬如日出群闇自消。称佛洪名万罪自灭。问散心称名亦能除罪并往生否。答亦必除罪不定往生。必除罪者名号功德真实不可思议故。不定往生悠悠散善难敌无始积罪故。良由吾人无始劫来所造生死重罪。假使重罪有体相者。尽虚空界不能容受。故虽从生至死百年之中一一昼夜弥陀十万一一声中尽灭八十亿劫生死重罪。然所灭罪犹如爪土。所未灭罪如大地土。惟能念至一心不乱。则如健人突围而出非复三军所能制耳。问既不定生称名何益。答一称佛名便为成佛种子。犹如金刚终不可坏。故佛世有一老人欲求出家。五百圣众以道眼观。皆谓从无善根不肯剃度。后至佛所佛即度之。弟子问佛因缘。佛言此人于无量劫前。入山采薪为虎所逼。上树避之。虎复绕树跑哮。以怖急故失声称南无佛。今此善根成熟值我得道。非诸二乘道眼所能知也。由此观之。法华方便品中所明若于过去佛所散乱称名皆已成佛。岂不信哉。伏愿若缁若素若智若愚。于此简易直捷无上圆顿法门。勿视为难而辄生退诿。勿视为易而漫不策勤。勿视为浅而妄致藐轻。勿视为深而弗敢承任。盖所持之名号真实不可思议。能持之心性亦真实不可思议。持一声则一声不可思议。持十声百声乃至无量无数等声。则声声皆悉不可思议故也

  二总结劝

舍利弗我见是利故说此言若有众生闻是说者应当发愿生彼国土　佛眼所见究尽明了。以信愿而执持名号。的确是多善根福德。以此善根福德因缘。的确能感佛及圣众来迎。的确能生四种极乐世界。是为不可思议功德之利。故殷勤再劝发愿往生。以愿能导行故也。二正宗分竟

三流通分信愿行三。一经之要旨备矣。此无上法门甚深难信。故既无问自说以为发起。复引六方诸佛广长舌相同为证明。以广流通。若非流通之力。何能使妙法筌蹄不壅于来世。圆顿心要永传于未闻也哉。文分为五。初引六方诸佛称赞劝信流通。二重征名解释劝信流通。三约已今当生劝愿流通。四引诸佛称赞难事敦信流通。五大众欢喜信受流通

初中六。初东方(至)六上方。唐译十方当知文有详略义无增减也。今初

舍利弗如我今者赞叹阿弥陀佛不可思议功德之利东方亦有阿閦鞞佛须弥相佛大须弥佛须弥光佛妙音佛如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经　承上正宗分中广赞阿弥陀佛依正庄严劝人信愿持名径登不退。此于出世大功德利之中。尤为不可思议。故不惟我释迦如来赞叹。举凡六方诸佛无不异口同音赞叹也。言不可思议者略有五意。一横超三界不俟断惑故。二即于西方横具四土非由渐证故。三但持名号不假禅观诸方便故。四一七为期不藉多劫多生多年月故。五持一佛名即为诸佛护念不异持一切佛名故。阿閦鞞此云无动。余皆可知。佛有无量德。应有无量名。随机立名。或取因或取果或性或相或行愿等。虽偏举一隅。仍各具四悉。随一一名显所诠德。劫寿说之亦不可尽。但可意解而已。东方虚空不可尽故世界亦不可尽。世界不可尽故现住世间诸佛亦不可尽。略举五名以等恒河沙数诸佛。如此诸佛各出广长舌相说诚实言劝信此经。而众生犹不生信。顽冥极矣。言广长舌相者。寻常之人三世不妄语则舌能至鼻。藏头果佛三大阿僧祇劫久不妄语。故舌薄而广长出可覆面。今证大乘净土妙门。所以遍覆三千大千世界。用表言必诚实决非虚谬也。此经正名称赞不可思议功德一切诸佛所护念经。罗什法师顺此方好略之机故。但译云佛说阿弥陀经。玄奘法师取舍两楹。故又译云称赞净土佛摄受经。当知亦是文有详略义无增减

  二南方

舍利弗南方世界有日月灯佛名闻光佛大焰肩佛须弥灯佛无量精进佛如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经

  三西方

舍利弗西方世界有无量寿佛无量相佛无量幢佛大光佛大明佛宝相佛净光佛如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经　问无量寿佛即是极乐世界阿弥陀佛否。答即是亦可。不是亦可。即是亦可者。佛无我相。为度众生不妨自赞。如释迦亦自赞故。不是亦可者。十方同名诸佛无量。非止一佛名为无量寿故

  四北方

舍利弗北方世界有焰肩佛最胜音佛难沮佛日生佛网明佛如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经

  五下方

舍利弗下方世界有师子佛名闻佛名光佛达磨佛法幢佛持法佛如是等恒河沙数诸佛各于其国出广长舌相遍覆三千三千世界说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经　下方者。此界水轮金轮风轮之下复有下界非非想天等。乃至重重无尽不可说不可说也。达磨此云法。余可知

  六上方

舍利弗上方世界有梵音佛宿王佛香上佛香光佛大焰肩佛杂色宝华严身佛娑罗树王佛宝华德佛见一切义佛如须弥山佛如是等恒河沙数诸佛各于其国出广长舌相遍覆三千大千世界说诚实言汝等众生当信是称赞不可思议功德一切诸佛所护念经。上方者。此界非非想天之上复有上界风轮银轮及三界等。重重无尽不可说不可说也。问既六方各有诸佛。亦必各有净土。何故偏赞西方。答令初机易标心故。又弥陀本愿胜故。又与此土众生偏有缘故。又念弥陀一佛即为念无量佛。生西方一净土即为遍生无量净土故。若浅位人知西方胜于余方。便可决志专求。若深位人知西方即摄十方即具四土。亦不必舍西方而别求华藏。盖若谓西方是权华藏是实西方则小华藏则大者。全堕众生遍计执情。以不达权实一体大小无性故也。初引六方诸佛称赞劝信流通竟

  二重牒名解释劝信流通

舍利弗于汝意云何何故名为一切诸佛所护念经耶舍利弗若有善男子善女人闻是经受持者及闻诸佛名者是诸善男子善女人皆为一切诸佛之所护念皆得不退转于阿耨多罗三藐三菩提是故舍利弗汝等皆当信受我语及诸佛所说　阿耨多罗此云无上。三藐三菩提此云正等正觉。即大乘果觉也。此大乘经独诠简易直捷圆顿心要。又诸佛名字并诠无上圆满究竟万德。故闻经受持及闻诸佛名者皆为诸佛所护念皆得不退大菩提也。问闻经受持护念不退可矣。但闻佛名岂亦得护念不退耶。答此义有局有通。所言局者。如占察经云。若杂乱垢心虽复称诵我之名字。而不名为闻。以不能生决定信解。但获世间善报。不得广大深妙利益。若到一行三昧则成广大微妙行心。名得相似无生法忍。乃为得闻十方佛名。此亦应尔。故须闻是经已受持此经所示执持名号之法。持至一心不乱方得闻诸佛名。方为一切诸佛所护念也。所言通者。诸佛慈悲不可思议。名号功德亦不思议。故一闻佛名不论有心无心若信若谤皆成缘种。譬如入栴檀林若拜若打皆染香气。况佛度众生不简怨亲恒无疲倦。苟闻佛名佛必护念又何疑焉。然据金刚般若三论皆云根熟菩萨方为佛所护念。准位须在别地圆住。盖是惟约自力故必入同生性乃可护念。今仗他力故相似位即蒙护念。即能圆得三种不退。下至一闻佛名。亦于同体法性有资发力。亦得远因终不退也。闻名功德如此之大。释迦及六方佛同所宣说可不信乎

  三约已今当生劝愿流通

舍利弗若有人已发愿今发愿当发愿欲生阿弥陀佛国者是诸人等皆得不退转于阿耨多罗三藐三菩提于彼国土若已生若今生若当生是故舍利弗诸善男子善女人若有信者应当发愿生彼国土　已发愿者即已生。今发愿者即今生。当发愿者即当生。正显依信所发之愿愿无虚发必克果也。非信则不能发愿虽信而不发愿亦不能生。故殷勤再劝发愿。愿者信之券而行之枢尤为要务。举愿则信行在其中矣。问今发愿者但可当生。何得云若今生。答此亦二义。一通约一期名今。则现生发愿持名临终决定得生净土是今发愿即今生也。二局约刹那名今。则一念相应一念生。念念相应念念生。妙因妙果不离一心。如秤两头低昂时等。何俟娑婆报尽方育宝池。只今信愿持名使非娑婆界内人矣。极圆极顿难议难思。惟有大智方能谛信

  四引诸佛称赞难事敦信流通又二。初引诸佛同赞。二自结叹难信。今初

舍利弗如我今者称赞诸佛不可思议功德彼诸佛等亦称赞我不可思议功德而作是言释迦牟尼佛能为甚难希有之事能于娑婆国土五浊恶世劫浊见浊烦恼浊众生浊命浊中得阿耨多罗三藐三菩提为诸众生说是一切世间难信之法　诸佛功德智慧虽皆平等。而施化则有难易。于净土成菩提易。于浊世成菩提难。为净土众生说法易。为浊世众生说法难。为浊世众生说渐法犹易。说顿法尤难。为浊世众生说余顿法犹易。说此净土横超顿法尤难。为浊世众生说净土横超顿修顿证妙观已自不易。说此无藉劬劳修证。但持名号径登不退。奇特胜妙超出思议第一方便。更为难中之难。以是一切九法界世间所难信故。所以名为甚难希有之事。而十方一切诸佛无一不称扬赞叹推我释迦偏为勇猛也。劫浊者浊法聚会之时。见浊者五利使邪见增盛。所谓身见边见见取戒取及诸邪见。昏昧汨没故名为浊。烦恼浊者五钝使烦惑增盛。所谓贪嗔痴慢疑。烦动恼乱故名为浊。众生浊者见烦恼所感粗弊五阴和合假名众生。色心并皆陋劣故名浊。命浊者因果并劣寿命短促。乃至不满百岁故名浊

  二自结叹难信

舍利弗当知我于五浊恶世行此难事得阿耨多罗三藐三菩提为一切世间说此难信之法是为甚难　信愿持名万修万去。永离五浊圆净四土。如此妙法真实难信。故不惟诸佛称赞即自亦叹其甚难。设非大悲弘誓尘劫熏心。何能行此难事也哉。此而不信辜负慈尊甚矣。四敦信流通竟

  五大众欢喜信受流通

佛说此经已舍利弗及诸比丘一切世间天人阿修罗等闻佛所说欢喜信受作礼而去　法门不可思议难信难知。故无一人能发问者。佛智鉴机知机已熟。故无问自说令得四益。既得闻已如时雨化故欢喜信受也。身心怡悦名为欢喜。毫无疑惑名之为信。领持不忘名之为受。感大恩德投身归命名为作礼。依教修一往不退名为而去

佛说阿弥陀经要解

    跋语

经云。末法之中亿亿人修行。罕有一得道者。惟依念佛得度。呜呼今正是其时矣。舍此不可思议法门。其何能淑旭于初出家时。亦以宗乘自负藐视教典。妄谓持名法门不过曲为中下。后因大病发意西归。嗣复研求妙宗圆中二钞及云栖疏钞等书。始知念佛三昧实称无上宝王。方肯死心执持名号。万牛莫能挽也。适吾友去病大士久事净业。欲令此经大旨辞不繁而即炳着。命余述此要解。余正欲普与法界有情同生极乐。理不可却。举笔于丁亥年九月二十有七。脱[葶-丁+呆]于十月初五。凡九日而告成。所愿一句一字咸作资粮。一见一闻同阶不退。或信或疑皆植道种。或赞或谤等归解脱。仰惟诸佛菩萨摄受证明。同学友人随喜加被。西有道人蕅益智旭阁笔故跋。时年四十有九

    刻弥陀要解后序

经云。三界唯心万法唯识。古人云。念自性弥陀生唯心净土。合而观之。则是心作佛是心是佛心外无佛佛外无心之义明矣。后人不达。舍西方极乐而别言唯心净土。舍万德慈尊而别言自性弥陀。不几心外有佛佛外有心耶。吾蕅益师深悟心性无外之体。故若宗若教若性若相一以贯之。既着梵网合注佛顶玄文唯识心要大乘止观释要等书。阐明权实妙理。复为正知拈此弥陀要解。一展读时便觉信愿持名人可自操其券。诚所谓直捷痛快言简意周者也。盖末世弘法大士各有专门。鲜克兼通性相。惟蕅师先从心源荐彻。所以性相宗教无不游刃而解。了知心佛众生三无差别百界千如心具心造举凡净土依正无非自心所变相分。故于四土横竖之致如指诸掌。然此特法海一滴耳。若欲尽蕅师涯底。当遍览合注玄文心要等大部著述。又进求于未举笔前。庶不认指而迷月矣。古吴净业弟子正知识

弟子沈纯社愿以此刊施功德上荐先考恰所府君讳自郇先妣孺人潘氏先室孺人陈氏亡妾彭氏亡女祺官同生净土永不退转并祈保孙男孚尹念温曾孙式棠肇嘉端赐等归依三宝世修福慧伏惟我佛慈悲护念


佛说阿弥陀经义疏

    No. 1761 [cf. No. 366]

佛说阿弥陀经义疏(并序)

        西湖灵芝崇福寺释元照述

一乘极唱终归咸指于乐邦。万行圆修最胜独推于果号。良以从因建愿秉志躬行。历尘点劫怀济众之仁。无芥子地非舍身之处。悲智六度摄化以无遗。内外两财随求而必应。机兴缘熟行满功成。一时圆证于三身万德总彰于四字。是以知识广赞感狱火化为凉风。善友教称见金莲状同杲日。八十亿劫之重罪廓尔烟消。十万亿刹之遐方倏如羽化。嗟乎识昏障厚信寡疑多。贬净业为权乘。嗤诵持为粗行。岂非耽湎朽宅自甘永劫之沉迷。悖戾慈亲深痛一生之虚丧。须信非凭他力截业惑以无期。不遇此门脱生死而无路。闻持颇众正协于时缘。著述虽多鲜穷于要旨。尽毫端而申释敢敩前修。舒舌相以赞扬誓同诸佛。太虚可际。鄙志奚穷。敬勉同舟深崇此道矣

将释此经。先以义门括其纲要。始可入文释其义趣。初中大觉世尊一代名教。大小虽殊不出教理行果。因教显理。依理起行。由行克果。四法收之鲜无不尽。初中言教大略有二。初明教兴二辨教相。初中大本经云。佛言如来以无量大悲矜哀三界。所以出兴于世。光阐道教普令群萌获其法利。开示五趣度未度者。决正生死泥洹之道。此明出世大意。该于众典。是谓通明教兴也。次据今经略言五意。一欲令众生知娑婆苦求出离。故经云。彼国众生无有众苦。二令知佛境界生忻慕。故下明依正庄严劝生彼国。三令摄心安住念佛三昧。故下云。闻说阿弥陀佛执持名号一心不乱等。四令破障脱苦得清净乐。故下云。是人终时心不颠倒即得往生等。五令生彼国成就菩提。故下云。是诸人等皆得不退转等。此明说经正意局在今文。所谓别叙教兴也。次辨教相。净土教观通明现在十方诸佛。即如下引六方恒沙诸佛出广长舌劝信是经。即其证也。又准下文。善男善女闻经受持。不历阶渐皆不退转阿耨菩提。故知一切净土教门皆是大乘圆顿成佛之法。定非偏小。如别委论。二明理者。理即教体。亦分为二。初通二别。初中一切大乘皆以方等实相为体。方谓方广。等即平等。实相妙理横遍诸法故名方广。竖该凡圣故言平等。故知横竖一切诸法悉自缘生。皆不思议无非实相。此通一代大乘所诠之理。二言别者。今经即以弥陀修因感果依正庄严不思议功德为所诠理。良以因中发无相大愿。修无住妙行感无得圣果。点事如理相即非相。故所感身土无非实相。即下经云。如我今者赞叹阿弥陀佛不可思议功德。若非妙理。那称不思议乎。三明行者。行即教宗。亦有通别。初通明大行。不出发无上道心修六度万行。备在众经。不复具举。二别论者。修行净业感生净土。别是一门出离径术。就净业中复有多种。诸经所示行法各殊。观经三福妙观。大本一日一夜悬缯幡盖。十日十夜奉持斋戒。大悲经中一日称名展转相劝。般舟经中一日若过系念现前。九十日中恒不坐卧。鼓音声经十日十夜六时礼念。陀罗尼集诵诸神咒。大法鼓经但作生意知有彼佛。权巧赴机行法不一。教门虽异无不往生。今经专示持名之法。正是经宗。于今为要。故当委示。不可笼通。括束经文且为五例。一心起忻厌厌苦忻乐。二身须西向正立合掌。三克期日限。一日七日。四系心佛境专一不乱。五期死无退。决誓求脱。若此称名下至十念尚得往生。况一日七日乎。四明果者。果即教用。亦有二别。一者近果经云。是人终时心不颠倒。即得往生极乐世界。由前称佛结业成因。舍此秽苦感彼净乐。即获法性净身住同居净土也。二者远果下云。众生生者皆得不退阿耨菩提。此谓生彼国已闻法得忍。修菩提道断惑。证真究竟成佛。即证清净法身居法性土也。上列四章略提梗概。余如后释。仍委他文。次释文中。此经凡有两译。一姚秦罗什法师译。即今本也。二大唐玄奘法师译。今见藏中立题各异。如下所明。自古解释凡有三家。唐慈恩法师通赞一卷。今朝孤山法师霅溪法师皆有疏记见行于世。今之所出各从其志时有异同。临文目见。次正释文相又二。初释经题二释经文。初中此经本名称赞不可思议功德一切诸佛所护念经。总十六字。经字为通题。上十五字为别题。上八字属教。即经所说依正庄严称名往生皆是弥陀修因感果威神愿力不思议功德也。下七字属机。即依教起行。专修成业。众圣冥加摄持。不退直至菩提也。奘师唐译即用本题云称赞净土佛摄受经。语虽少异义意大同。对文可见。今经秦译隐略本题在六方佛后。即下云汝等众生当信是等。据宗取要别建此题略有五意。一则上符经旨。经中唯示持名方法。故取佛名用标题首。二则下适机宜。弥陀名号众所乐闻。故用标题。人多信受故。三理自包含。但标佛名。称赞护念任运自摄故。四义存便易。梵号兼含耳闻淳熟故。五语从简要。后世受持称道不繁故。且如唐译。从本立题而未闻流布。又如大本。从华标目。而罕见诵持。乃知秦本深体圣心。故得四海同遵百代无古。感通传说。罗什法师七佛以来翻经。信非虚矣。今释此题。上五字为别。局今经故。下一字为通。同众典故。就别题中。上二字标能说教主。定是释迦。但举通号。下三字示所说人。简非他佛故标别号。通别互举译人之巧。倾出我口畅悦彼心。以教合机故称佛说。阿弥陀此翻无量。经自释云。彼佛光明无量。照十方国无所障碍。是故号为阿弥陀。此谓无边量也。又云。彼佛寿命及其人民无量无边阿僧祇劫。故名阿弥陀。此谓无数量也。光表佛智。寿表佛福。以此福智严本法身。三德圆备以立嘉号。余如下文。通题中。梵云修多罗此翻为线。线能贯摄。即喻教诠。文理连贯包摄群机。训法训常义如常说。次释经文。大分三分。初至大众俱为序分。二尔时佛告下至是为甚难为正宗分。三佛说此经下至末文为流通分。初中诸经皆有证信发起二序。此经但列证信独无发起。往生传序云。此乃十二分教无问自说之经。其犹母之拊婴儿。不俟其请。但欲顾其手足乳而哺之耳。今以义求略为二意。一表他方净刹非二乘偏小境界。纵有权行。示同不知。不假因缘。孤然自说。彰其特异。即下诸佛叹释迦云。能为甚难希有之事。说此世间难信之法。是也。二表我佛世尊大慈悯物。如母爱子。怜其小騃。不能请问。召以诲之。彰其深切。故下如来嘱云。汝等皆当信受我语及诸佛所说。是也。就证信中。此即阿难结集奉教安列。六事为证明非虚谬。令物信故。六缘不具教则不兴。名六成就。诸经之首。解释极繁。此但略提大要。余广如彼。初如是者。如云指法之辞。即指正宗所说法门。契理曰如。离非曰是。信故闻持名信成就。二我闻者。阿难自言亲从佛闻非他传告。即闻成就三一时者。主伴会集说听始终。简非余时。即时成就。四佛者。释迦教主。金口亲宜非余所说。即主成就。具云佛陀。翻云觉者。觉名乃通。此局妙觉究竟极果。十号之一也。是为通号。五在舍卫等者。说经有处。举舍卫乃游化之境。举祇园即依住之处。即处成就。舍卫翻闻物。言人物富庶远闻诸国故。只陀施树。给孤买园。共成佛刹故以为名。六与大比丘下。道俗四部大众同会。非我独闻。即众成就。众有三类。初声闻众。二并诸下即菩萨众。三及释提下人天众。声闻常时侍佛。威仪复胜。故在前列。菩萨隐显无定。形服不拘。故以次之。人天俗众形服全乖。故列于后。初中有四。初示数。二皆是下叹德。三长老下列名。四如是下总结。初中。大比丘者。上首弟子。如下列者。千二百等眷属弟子并不列。比丘或云苾刍。此翻乞士。乞食资身。乞法练心。又翻怖魔。志怖彼魔德令魔怖。又云破恶。禀戒破业。定慧破惑。此三因名。果号如后。僧者具云僧伽。此翻为众。四人已上秉御一切灭恶生善羯磨。总该凡圣通收理事。故云众也。佛初成道度三迦叶。共有弟子千人。次度舍利弗目连。共有弟子二百五十人。此皆本是外道。遇佛得度。荷佛恩深故常随侍。或云重其最初归佛。故多列之。未必常预会也。叹德中。阿罗汉亦有三翻。初云应供。堪为物养。即乞士果也。次云杀贼。摧伏魔怨。即怖魔果也。三云无生。结尽苦亡。即破恶果也。即如下列会中上首。人天大众知其德业识其仪貌。故云众知识也。列名中。德重[藹-言+月]高故称长老。语局初人义该诸位。舍利弗此翻身子亦云珠子。其母好身形。聪明在眼珠。时人以子显母为作此号。又云舍标父。利标母。双显父母故言舍利弗。弗即子也。摩诃目犍连。摩诃翻大。同名者众。加大简之。下皆类之。目犍连。文殊问经翻莱茯根(莱茯读为萝卜)。真谛云。勿伽罗翻胡豆。二物古仙所嗜。因以命族。名尼拘律陀。乃是树名。父母祷神树得子。因以名焉。迦叶此翻大龟氏。其先代学道。灵龟负仙书而应。从德命族。真谛翻为光波。上古仙人身光炎涌。状若波燃。亦云饮光。能映余光使不现故。名毕钵罗亦是树名。由祷树得故。迦旃延翻文饰。亦云肩垂亦云好肩。亦名柯罗。此翻思胜。皆从姓为名。拘絺罗此翻大膝(有云膝盖大故)舍利弗舅。与姊论义常胜姊。姊孕不胜。知怀智人。遂往南天竺。读诵众经无暇剪爪。时人呼为长爪梵志。离波多亦名离越。此翻星宿。或云室宿。父母从星乞得。因星作名。或云假和合。文殊问经称常作声。有人引智论。尝宿空亭证二鬼诤尸。依实判归小鬼。大鬼怒拔其手足。小鬼取尸补之。因其烦恼不测谁身。故云假和合。又心怀疑惑。逢人即问。见我身否。众僧语云。汝身本是他之遗体。非已有也。因即得道故以为名。周利槃陀伽此翻蛇奴。或言周利云大路边。槃陀伽云小路边。生于道傍故以为名。难陀此云善欢喜。亦翻忻乐。本牧牛人。以牧牛事试。佛为说法忻乐得道。故有处名牧牛难陀。或云即律中跋难陀也。阿难陀此云欢喜。或云无染。净饭王闻太子成佛。王大欢喜。白饭王奏生儿。举国忻然。因以为名。罗睺罗此云覆障。佛之嫡子。酬往业故在胎六年。故云覆障。真谛云。罗睺本言修罗。能手障日月。应言障月。佛言我法如月。此儿障我不即出家。世世能舍故云覆障。憍梵波提此翻牛齝(音诗)或云牛王。或云牛迹。昔五百世曾作牛王。余报未尽。唼唼常嚼。时人称为牛齝。亦由此故名是为牛迹。避人见笑。常居天上。宾头卢颇罗堕。上是据姓。宾头卢此翻不动(言其所证)。颇罗堕真谛翻捷疾。或利根或广语(言其根性)。婆罗门中一姓也。迦留陀夷此翻黑光。或云粗黑。从形貌为名。劫宾那此翻房宿(音秀)。祷星感子故以为名。又初出家欲往见佛。夜雨寄陶师家宿。又一比丘随后而来。前比丘推草与之。在地而坐。后比丘即为说法。豁然得道。后比丘即是佛。共佛房宿(音夙)。从得道处为名。薄呴罗此翻善容。亦云伟形。而色貌端正故言善容。年一百六十。无病无夭。昔持一不杀戒。九十一劫命不中夭。昔施僧一诃利勒果故身常无病。感今胜报。故以为名。阿[少/兔]楼驮亦云阿那律。或云阿泥卢头。皆梵音奢切耳。此翻无贫。亦云如意。或云无竭。昔于饥世施支佛稗饭。九十一劫果报充足。故以为名总结中。略举上首一十六人。不可尽列。故云如是等。南山云。学在我后故为弟。解从我生故称子。次菩萨中三。初示数。二文殊下列名。三与如下总结。初中。同闻极多。略举四名故云诸也。菩萨梵言之略。天台戒疏云。摩诃菩提质帝萨埵此翻大道心成众生。或云。菩萨翻觉有情。觉谓上求。即是智也。有情谓下化。即是悲也。列名中。文殊师利亦云曼殊室利。此翻妙吉祥。妙即彰其所证。吉祥美其利物。或云妙德。义亦同之。绍隆佛种称法王子。智论云。佛为法王。菩萨入正法位。乃至十地悉名法王子。乃知此名该下诸位。阿逸多此云无能胜。言其悲智非偏小所及。乾陀诃提此翻不休息。众生无尽修因感果无穷已故。常精进者。众生无量。上求下化无暂懈故。总结中。然菩萨名通于初后。如上所列。莫非深位补处。或是权现影响故云诸大也。三人天中。释提桓因具云释迦因陀罗。此翻能天帝。即三十三天主。今言帝释即华梵双举。大梵四王天主甚多。不复尽举故云无量也。更兼道俗四众龙鬼八部。故云大众俱。序中从略。文见流通。第二正宗分大分三段。从初至俱会一处。先赞二报庄严令生忻慕。二不可以少下。正示专念持名教修行法。三如我今者下。后引诸佛同赞劝信受持。科分三节曲尽一经。有智试观。思过半矣。初中又二。初总标依正。上二句指对告人。众集即告。故云尔时。身子大权智慧第一。知言解意深契佛怀。故诸经便多令对语。弥勒下生经云。大智舍利弗能随佛转法轮。佛法之大将。乃知身子才辨超伦。及至此经殊无一词申疑请问。从始至末尽是如来呼以告之。即向所谓示同不知义见于此。从是已下即所告事。上四句标依报。净土多种。如别所论。今此所标同居净土。如世邦国方向远近。二皆是定。对此极苦故名极乐。亦名安乐亦号安养。十万亿刹凡情疑远。然弹指屈臂刹那可到。一以十方净秽同一心故。二以心念迅速不思议故。十疑论云。但使众生净业成者。临终在定之心。即是净土受生之心。动念即是生净土时。为此观经云弥陀净土去此不远。又心业力不思议一念即生。不须愁远等。下三句标正报。但言化主必兼徒众。简非过未故云现在。舍利下二别释依正。又二。从初至庄严释依报。舍利弗于汝意下次明正报。初中又二。初略释名义。又舍利下广明胜相。初中上三句征问。下四句释通。无众苦者。对显娑婆令生忻厌。三界六道总名苦果。于中复有八苦五苦三苦。生．老．病．死．贫困．爱别．怨会．求不得为八苦也。杀．盗．淫．妄．饮酒五种恶业并是苦因。必招苦果。名五苦也。苦苦．坏苦．行苦名三苦也。诸经论中略示名数。谛论忍土。一切皆苦无一可乐。火宅牢狱未足为喻。弥陀净土境界殊绝。圣贤同会闻法悟道。寿命永劫不退菩提。更有余乐不能过此。秖无诸苦。已为可乐。况具诸胜事。其乐何穷。故云极也。大本云。设我得佛。国中人天所受快乐不如漏尽比丘。不取正觉。善导云。愿生彼国。必须励心克己毕命为期。上在一形似如小苦。前念命终后念即生。长时永劫受无为法乐。直至成佛不退生死。岂不快哉。次广明中。依报国土耳目所对。不出声色。据经后结成就庄严。止有三处即为三段。初栏网树池唯是妙色庄严。二金地华乐则兼色声庄严。三鸣禽风树止是法音庄严。故今科约与昔全殊。请考经文无宜执旧。就初庄严分二。初至香洁即列相。舍利下二结示。列相又二。初至极乐举栏网行树以显名。又舍利下二引池阁宝莲以示相。初中上七句示相。下二句结名。言行树者周回七重。一一树高八千由旬。行行相当不参差故。其树枝叶上下七层皆垂珠网。状同佛塔。观经云。妙真珠网弥覆树上。一一树上有七重网。一一网间有五百亿妙华宫殿。一重树下一重栏楯故亦七重网是珠璎复依树上。则知皆是下二句止显树栏之体耳。一金二银三琉璃四玻璃是为四宝。初正示若准观经。七宝华叶无不具足。又大本中根茎枝叶七宝间错。此中略举。委在他文。周匝围绕。有云凡佛菩萨居处皆然。非谓一国土止有七重耳。结名可解。下诸庄严例顺此结。二池阁中分四。初明池水。二池畔阶道。三阶上楼阁。四池中莲华。初中七宝池者。彼有八池。七宝所成。池中之水亦七宝色。名八功德。一澄清。二清冷。三甘美。四轻软。五润泽。六安和。七除饥渴。八长养诸根。每一池心有如意珠王。水从中出流注池中。金沙布地者。观经云。渠下皆以杂色金刚以为底沙。二中阶砌亦即四宝。三明楼阁。乃列七宝。观经云。众宝国土一一界上有五百亿宝楼。琉璃梵语。此翻不远。去波罗奈城不远有山出此宝故。玻璃亦云颇胝迦。此翻水玉。或云水精。砗磲下并华言。如车之磲。磲谓车辋。赤珠者。佛地论云。赤虫所出珠。体赤故。码瑙。应法师云。此宝色赤如马脑焉。大本云。设我得佛。自地至空。宫殿楼阁池流华树皆以无量杂宝百千种香而共合成。严饰奇妙超诸天人等。四示莲华有五。一形量。二显色。三光焰。四香气。五洁净。对文可见。若准观经。一一池中有六十亿七宝莲华。一一莲华团圆正等十二由旬。既言七宝。非止四色。十二由旬。非止车轮。然车有大小。难为定准。此间极大不过数尺。可依轮王车轮为量。十住毗婆沙云转轮圣王千辐金轮种种珍宝庄严其辋。琉璃为毂。周圆十五里。准此。未及半由旬。亦约小者耳。所以二经不同者。慈恩云。华有大小。彼据极大。此约最小。今准大本。池中莲华或一由旬乃至百千由旬。则知大小不同。经中但是随宜趣举。不必以此较经优劣。二结示中。如是者。指上多种殊妙之相。皆是弥陀菩提愿行从因至果历劫熏修之所成就。故云功德庄严。故观经云。如此妙华是本法藏比丘愿力所成。自余皆尔。岂唯华座乎。四十八愿结云。彼佛于大众中建此愿已。一向专志庄严妙土等。下结诸文并同此释。第二庄严二。初列相。舍利下二结示。初中有三。一天乐。二金地。三天华。初常作天乐者。准观经。作乐有三。水观中云。百亿华幢无量乐器以为庄严。八种清风鼓此乐器等。又楼观云。其楼阁中有无量诸天作天妓乐。又有乐器悬处虚空。不鼓自鸣等。准下经云。风吹树网如百千种乐。故知彼土天乐非一。二黄金为地者。准观经。彼国皆琉璃地。以黄金绳杂厕问错。兼以七宝界其分齐。今言黄金。乃地面庄严耳。三天华又三。初六时雨华。其土下二盛华供养。即以下三供已还国。初中彼国光明常照。既无日月则无昼夜。顺此方机且言六时。准大本中。彼以莲开鸟鸣为晓。莲合鸟栖为夜。曼陀罗此翻适意。言其美也。又翻白华。取其色也。二中其土众生。通目九品。衣裓真谛云。外国盛华器也。才生彼国即获六通。日往他方为闻法故。观经云。应时即能飞行。遍至十方历事诸佛。又游历十方供养诸佛。于诸佛前闻甚深法等。十万亿者趣举大数。三中食时谓中前也。大本云。彼国宫殿衣服饮食犹第六天自然之物。若欲食时。七宝钵器自然在前。百味饮食自然盈满。虽有此食实无食者。但见色闻香意以为食。自然饱足。事已化去。时至复现等。寄归传云。五天道俗多作经行。直来直去唯遵一路。如织之经。故曰经行。四分律云。经行有五益。一堪远行。二能思惟。三少病。四消食。五得定久住。结示同前。第三庄严亦二。初列相。舍利下结示。初列相中复有二种。初至所作众鸟演圣法。舍利下二风树出妙音。初中又二。初正示。舍利下释疑。正示有三。先列众禽略举六种。前三易识。舍利此云春莺或云鹙鹭。迦陵频伽此翻妙声。在[穀-禾+卵]中鸣已超众鸟。共命者。两首一身报同识异。故法华中翻为命命鸟是也。准观经。更有百宝色凫雁鸳鸯等。是诸下次明演法。和雅谓声音感人。演畅谓说法无滞。五根者。一信。二精进。三念。四定。五慧。能生圣道故总名根。即此五法能排业惑故名为力。七菩提分即七觉支。一择法。二精进。三喜。四除。五定。六舍。七念。无学实觉七事能到故名为分。八正道分者。一正见。二正思惟。三正语。四正业。五正命。六正精进。七正念。八正定。前二慧学。中三戒学。后三定学。即是离明三学。初果已去见真谛理皆名正道。亦名圣道。余如法界次第委明。准观经云。常赞念佛念法念僧。或说苦空无常无我诸波罗蜜。故云如是等法。其土下后显益物。念佛知佛恩重。念法知法功深。念僧知僧德大又念佛愿速证诚。念法愿勤修学。念僧愿亲参预。又念自心佛体自觉了。念自心法轨生圣道。念自心僧随缘和合。三宝多种随机浅深。当知此界心垢常思五欲。彼方心净专念三宝。晨夕所存更无他意。两土升沉于兹可见。次释疑中二段。初至有实遮其疑情。是诸下二决所疑事。初中三节。先遮疑情。浊世禽畜罪业所招。极乐净土何缘有此。所以下次伸意。彼国唯有人天两道。法藏愿云。设我得佛。国有地狱饿鬼畜生者。不取正觉。舍利下三举况。大本云。彼国无有三涂苦难之名。但有自然快乐之音。是故其国名曰安乐。二决疑中弥陀变化者。准观经。即池水中如意珠王涌出金光。其光化为百宝色鸟。和鸣哀雅。当知众鸟即是弥陀化身。欲使法音遍布远近。显知非是罪报所生也。二风树妙音分二。初示相。即前树网风动成音。其音美妙如众乐焉。闻是下显益同前。结示可解。第二明正报中分二。初至十劫化主名号。舍利下二徒众庄严。初中复二。初征问。汝意云何。审其解否。既无所对故为释通。阿弥陀此翻无量。一者光明二者寿命。无量是通。光寿为别。初光明无量者。佛光有二。一者常光。二者现起光。今此乃是弥陀常光。大本云。无量寿佛威神光明最尊第一。诸佛光明所不能及。是故号为无量光佛。乃至我说彼佛光明。昼夜一劫尚不能尽等。又佛观云。身诸毛孔演出光明。如须弥山。彼佛圆光如百亿三千大千世界。又云彼佛有八万四千相。一一相有八万四千好。一一好有八万四千光明。遍照十方世界念佛众生。摄取不舍。当知我辈处佛光中。都不觉知。佛光常摄。略无厌弃。犹如盲人居日轮下。又如溷虫乐在秽处。抚膺自责实可悲痛。二寿命无量又二。初明主伴寿量。舍利下二示果成劫数。初中佛寿有二。法报二佛一向无量。应佛皆具长短二量。今此净土弥陀应身示其长量。大本云。彼佛寿命长久不可称计。假使十方无量众生皆成声闻缘觉。都共集会竭其智力。百千万劫悉共推算计。不能穷尽。又云声闻菩萨天人之众寿命长短亦复如是。故云及人民也。阿僧祇此云无数。或云阿僧祇耶。翻无央数。二示劫数。言十劫者。准法华。大通智胜佛时。弥陀乃是十六王子之一数。释迦既经尘劫。弥陀岂得不然。楞严势至章云。我于往昔恒河沙劫。有佛出世名无量光。十二如来相继一劫。准大本中。即阿弥陀也。今经大本皆言十劫。乃是一期赴机之说。不足疑矣。二徒众庄严分二。初至祇劫说正示圣众。舍利下二结劝往生。初中又二。初至庄严通列两众。又舍利下别显行功。初中又二。初正列。舍利下结示。初中声闻弟子即中三品。诸菩萨众即上三品。总摄初心不退补处(众总三乘独无缘觉应以断证同声闻摄)。故大本云。彼国声闻菩萨其数难量。不可称说。神智洞达威力自在等。往生论说二乘不生。盖是定性取涅槃者。今此谓曾发大心求佛菩提。示修小行。法华获记真声闻。涅槃知常出家菩萨之类也。次结示中此亦弥陀所化。来生彼国修因证果。威神说法。为国庄严。义同前释。二别显中众生生者。通九品收。阿鞞跋致此云不退转。下云是诸人等皆得不退阿耨菩提。则知生彼国者下至凡夫直至成佛更无退堕。十疑论云。彼国有五因缘故不退。一弥陀愿力摄持。二佛光常照。三水鸟树林常说法。四纯诸菩萨为友无诸恶缘。五寿命永劫。余广如彼。一生补处。即等觉菩萨。如观音势至等。众类既多。非算所及。止可但言阿僧祇耳。问得忍补处只合垂形五道入三涂处救苦众生。何以长居净土。答随其志愿摄化有殊。或游戏十方。或往来三界。宣扬法化利乐群生。准大本云。十方恒沙佛国无量菩萨悉生彼国。恭敬供养听受经法。宣布道化。又云于此世界有六十七亿不退菩萨。往生彼国。又复授记十方菩萨。皆当往生。广如下卷。二结劝中初正劝。众生闻者通指末代闻上所说。劝令发愿。愿必引行。行必感果。所以下伸意。如是者指前所列三乘圣众。皆是善人。欲明此界三恶充满皆不善聚是可厌耳。第二正示行法分三段。初至彼国简余善不生。若有下二正示修法。我见下三结显劝意。初中如来欲明持名功胜。先贬余善为少善根。所谓布施持戒立寺造像礼诵坐禅忏念苦行一切福业若无正信回向愿求皆为少善。非往生因。若依此经执持名号决定往生。即知称名是多善根多福德也。昔作此解人尚迟疑。近得襄阳石碑经本。文理冥符。始怀深信。彼云。善男子善女人闻说阿弥陀佛一心不乱专持名号。以称名故诸罪消灭。即是多功德多善根多福德因缘。彼石经本梁陈人书。至今六百余载。窃疑今本相传讹脱。二中分三。初至不乱专念持名。其人下二临终感圣。是人下三正念往生。初二句索持机不简男女次二句劝信受。或披经典。或遇知识闻必生信。信故持名。次七句示期限。一日七日随人要约。今经制法。理必依承。若准大本观经。则无日限。下至十念皆得往生。十念即十声也。后一句教系想。此一句经正明成业。先须敛念面向西方合掌正身。遥想彼佛现坐道场依正庄严光明相好。自慨此身久沈苦海。漂流生死孤露无依。譬如婴儿堕在坑阱叫呼父母急救危忙。一志依投恳求解免。声声相续念念不移。虽复理事行殊定散机异。皆成净业尽得往生。不然则无记妄缘定成虚福耳。善导问曰。何故不令作观。直遣专称名号。有何意耶。答曰。乃由众生障重境细心粗识扬神飞观难成就。是以大圣悲怜直劝专称名号。正由称名易故相续即生。又云弥陀世尊本发深重誓愿。以光明名号摄化十方。但使信心求念。上尽一形下至十声一声等。以佛愿力易得往生问达法本空心净土净。何须念佛求生净土。答若真达理。语默皆如不碍修持。何妨念佛。若贬念佛。未曰达人。何以然者。既达法空则不住于相。既常念佛则不滞于空。超越二边从容中道。念念契合弥陀法身。声声流入萨婆若海。临终决定上品上生。岂非心净佛土净乎。故十疑论云。智者炽然求生净土。达生体不可得。此乃真无生。非谓生法外别有无生也。净名云。虽知诸佛国及与众生空。而常修净土教化诸群生。即斯谓也。问观经云。是心作佛是心是佛。何须念他佛耶。答只由心本是佛故。令专念彼佛。梵网戒云。常须自知我是未成之佛诸佛是已成之佛。汝心佛者未成佛也。弥陀佛者已成佛也。未成之佛久沈欲海。具足烦恼杳无出期。已成之佛久证菩提。具足威神能为物护。是故诸经劝令念佛。即是以己未成佛。求他已成佛而为救护耳。是故众生若不念佛圣凡永隔。父子乖离长处轮回。去佛远矣。问四字名号凡下常闻。有何胜能超过众善。答佛身非相。果德深高。不立嘉名莫彰妙体。十方三世皆有异名。况我弥陀以名接物。是以耳闻口诵。无边圣德揽入识心。永为佛种顿除亿劫重罪。获证无上菩提。信知非少善根。是多功德也。华严云宁。受地狱苦得闻诸佛名。不受无量乐而不闻佛名。药师经云。若彼佛名入其耳中堕恶道者。无有是处。阿难诸佛境界诚为难信。皆是如来威力。非声闻支佛所能信受。唯除补处菩萨耳。瞻察经云。欲生他方现在净土者。应当随彼世界佛名专意念诵一心不乱。决定得生彼佛净土。善根增长速获不退。当知一切善根中其业最胜等。余诸佛名闻持尚尔。况我弥陀有本誓乎。末俗障重多忽持名。故委引圣言。想无迟虑也。二感圣中。其人下是人并指上文执持名者。临终摄引弥陀本愿。大经云。十方众生至心发愿欲生我国。临寿终时假令不与大众围绕现其人前者。不取正觉。圣众现前亦有多别。或真佛化佛观音势至随其品位。委在观经。或谓临终见佛以为魔者。或云自心业现。实无他佛来者。斯盖不知生佛一体感应道交。自障障他为过不浅。如别所明。三正念中。凡人临终识神无主。善恶业种无不发现。或起恶念或起邪见。或生系恋或发猖狂。恶相非一。皆名颠倒。因前诵佛罪灭障除。净业内熏慈光外摄脱苦得乐。一刹那间。下文劝生其利在此。三结显中。我见是利即蹑上科。故说此言。覆示前段。正报中文对文可见。大段第三劝信中三节。初至佛所说引诸佛同赞劝。若有人下二约三时因果劝。如我今者下举诸佛互赞劝。初中又二。初至之利指前自赞。东方下次引诸佛赞。初中如前所说依正殊特持名脱苦。莫非弥陀大悲愿行。从因至果功德利益殆非心思口议所及。二中又二。初尽六方正列。于汝意云何下释经名。初中但列六方。若依唐译则列十方。今谓但举六方四维自摄。但言略耳。下诸佛名相承不释。今以义详。或从色相。或取言音。或约行业。或从譬喻。大略不出果德三身。收无不尽。文或偏举。义必兼含。初东方分二。初叙现通。二引赞词。余五例此更不重分。初中阿閦鞞。此云不动。法身体寂无迁变故。若就因行。毁誉敬慢同一如故。次列三佛皆从喻名。众山之中须弥最胜。诸佛法身超过诸法。初言相者其状同也。次言大者出过喻也。三言光者光则表智法兼报也。妙音说法称机即应佛也。河沙佛土略列五名。故云如是等。各于其国者。正当释迦说此经时。十方诸佛同时劝赞令信是经。若据诸佛。言无虚妄。但由众生障重信难故。现舌相表示诚言。诸佛常舌上至额际今此现起。长广量等随宜大小。何止大千乎。次引赞词。当信是句绝称赞下即经本题。上句指前释迦所说。下二句如后经文所解。余见题中。下五并同此释。二南方中。日月灯三皆破闇。或次对三身。或单喻智德。名闻光者。名闻十方。如光遍照。大焰肩者。言相则两肩光焰。在智则双照真俗。须弥灯者。山灯即喻法报二身。无量精进。从行为名。方便度生未尝暂懈。众生无量。悲智亦然。三西方。前三皆名无量。初即寿命。二即相好。三即所证法身。无上故喻如幢。大光大明并喻佛智。自行化他破障除惑。宝相者。应佛相好如宝可贵。净光者亦即法报。问初无量寿即是弥陀。若自劝赞。于义非便。答同名甚多。必非极乐法藏所成之弥陀。四北方中。焰肩同前。但无大字。最胜音同上妙音。难殂者。法身坚密不可坏故。殂音叙。又音疽。坏也。日生者。如世晨曦破晦暝故。网明者。法门交映如帝网故。五下方中。狮子者。众圣中尊故。以兽王比焉。又狮子一吼兽闻皆死。喻佛说法魔外消亡。名闻名光。义同前释。达磨翻法。单云法者。所证法身轨持万化故。次云幢者。高出物表故。三云持者。任持常住故。六上方中。梵音者。梵即净。法音清朗众乐闻故。宿王者。宿音秀。星宿中王。所谓月也。经云。众星之中月天子为第一。或可北辰居天中。而众星拱之。而辰星为宿中王。亦喻法身出过诸法也。香上者。众德如香。超诸菩萨更兼智德。故云香光。焰肩须弥同前故不释。杂色宝华者。以万行因华严法身果德。下宝华德义亦同之。娑罗此翻坚固。冬夏不凋。即喻法身无变易故。见一切义者。洞达诸法甚深义趣。诸佛果海德量何穷。三世道同。理无差异。随机顺物一相为名。以意裁量。略如上解。后贤披阅更试讲磨。次释名中分三。初至念经征前经名。上句已见前文。故但问下二句。恐未晓故问释之。舍利下二示义。又二。先叙闻持。是诸下次明得益。初中闻经受持者。牒上二报庄严。正明行法二大章也。及诸佛名者。牒上引佛劝信。第三一章初科所引六方名也。次得益中。诸佛护念直至菩提。护谓覆护。不使魔娆。念谓记念。不令退失。势至章云。十方如来怜念众生。如母忆子。大论云。譬如鱼母若不念子。子即坏烂等。阿耨多罗此翻无上。三藐云正等。三菩提云正觉。即佛果号。薄地凡夫业惑缠缚。流转五道百千万劫。忽闻净土志愿求生。一日称名即超彼国。诸佛护念直趣菩提。可谓万劫难逢。千生一遇。誓从今日终尽未来。在处称扬。多方劝诱。所感身土所化机缘。与阿弥陀等无有异。此心罔极。唯佛证知是故下三劝信。信我语者。谓信教也。如不信我。十方诸佛岂虚妄乎。次三时因果中。初正示。是故下二结劝。初中已即过去。今即现在。当即未来。发愿是因。生即是果。三因三果别对可知。欲显净土。唯恐无愿。有愿必生定无漏失。十疑论云。生彼国已悉得无生。未有一人退落三界为生死业缚等。次结劝中。若有信者。简彼不信。任不发愿自甘涂炭。是谁之咎。三诸佛互赞中二段。初我赞诸佛。彼下诸佛赞我。初文如我今者等。即指前科六方劝信。二中又二。初出彼赞词。当知下二显示诚实。初中释迦翻能仁。即大慈垂应。牟尼翻寂默。即妙智冥真。合此为佛。则三身备矣。他不能为故甚难。举世未见故希有。下列二难。于此恶世修行成佛一难也。为诸众生说此法门二难也。初中娑婆亦云索诃。此翻堪忍。悲华经云。是诸众生忍受三毒及诸烦恼故。准佛刹经有二义。初义同上。二云彼有行菩萨乘者。成就忍辱。将护有情。善自调伏。若人加害。悉能含忍终不放逸。故云堪忍。五浊亦云五滓。又言恶者。谓能具造十恶业故。劫者梵云劫波。此翻时分。下四浊聚在此时。从减劫人寿二万岁时即入劫浊。见者。身见边见邪见戒取见取五利使也。烦恼者。贪嗔痴慢疑五钝使也。众生者。揽阴为人。假名众生。命者。刹那生灭。催年促寿。第二难中。念佛法门不简愚智。不择豪贱。不论久近。不选善恶。唯取决誓猛信临终恶相十念往生此乃具缚凡愚屠沽下类刹那超越成佛之法。可谓一切世间甚难信也。二显实中。承前二难则彰诸佛所赞不虚。意使众生闻而信受。第三流通分。正说既终。众喜受持。展转传布遍于四海垂于万世。故因众散以为流通。一切世间总收四部。别举三趣。以决序文。阿修罗此翻非天。受乐如天。怀谄同鬼。从行为名。欢喜则出离有门。信受乃忆持修习。得法巷怀。仰恩荷德。倾诚展敬。志愿流通

阿弥陀经义疏


佛说般若波罗蜜多心经赞

    No. 1711 [cf. No. 251]

佛说般若波罗蜜多心经赞

        沙门　测撰

将释此经四门分别。一教起因缘。二辨经宗体。三训释题目。四判文解释

言教起者窃以至理幽寂妙绝有无之境。法相甚深能超名言之表。然则趣理无方乃开二藏之说设教有依具现三身之应。可谓泉水澄清月影顿现诸敌冥动天鼓自鸣。然则应物有时随机接引。所以如来说三法轮未入法者令趣入。故波罗奈国施鹿林中创开生死涅槃因果。此则第一四谛法轮能除我执。为已入者回趣大乘。鹫峰山等十六会中说诸般若。此是第二无相法轮。由斯渐断有性法执。而于空执犹未能遣。是故第三莲华藏等净秽土中说深密等了义大乘。具显空有两种道理。双除有无二种偏执此即教之兴也

言宗体者体即总明能诠教体。宗者别显诸教所诠。然佛教体诸说不同。萨婆多宗用声为体名等无记声是善故。依经部宗相续假声离声无别名句等故。依大乘宗诸教不同有处唯声如无垢称。或有佛土声为佛事。有处但用名等为体如成唯识。法无碍智名等为境有处合说声及名等如十地经云。说听之者皆依二事。谓声名等如何。诸教有此异者据实以假从实皆用声及名等以为体性。而诸圣教各据一义故不相违。所以者何以假从实用声为体离声无别名句等故。以体从用名等为体能诠诸法自性差别。二所依故。假实相藉合说为体随阙一种说不成。故以境从心用识为体。经说诸法不离识故摄妄归真用如为体仁王等说诸法性故。所诠宗者略有三种。一随病别宗二部别显宗三约时辨宗。随病别宗者谓诸有情由无明故起贪嗔等八万四千诸尘劳门。是故如来应病设药。蕴等八万四千法门由此一一随其所应。蕴处界等为所诠宗。部别显宗者于一一部虽有诸门究其意趣随部各别。如法华经一乘为宗无垢即以不二为宗。依涅槃经佛性为宗华严贤圣因果为宗。自余诸部准上应知。约时辨宗者虽诸圣教部类众多就时辨宗不过三种。三种即是四谛无相了义大乘如深密说。今此一部诸宗之中无相为宗

佛说般若波罗蜜多心经　言题目者佛说即是标能说主。梵音佛陀此翻名觉。具真俗智自他觉满故名为佛。开敷妙门令众生解名之为说。般若波罗蜜多辨所说法。此土翻为智到彼岸。心经正显能诠之教。卢道之中心王独秀于诸般若此教最尊。从谕立名故曰心也。经有二义贯穿摄持。贯穿所应说义摄持所化生故。此即依主就能所诠法谕立号故言佛说般若波罗蜜多心经

观自在菩萨　第四判文解释。于此经中总有三分。初明能观智次舍利子下辨所观境。后以无所得故下显所得果。所以无序及流通者于诸般若简集纲要。故唯正宗无序流通如观音经不具三分。观自在菩萨者就初分中复分为二。初标能观人次辨观智体。此即第一标能观人。若依旧本名观世音。观诸世间称菩萨名音声语业。以救诸难因而立号名观世音。犹未能显观身意业。而今本云观自在者内证二空外观三业。不依功用任运自在故曰观自在。今此菩萨实是因位一生补处。为已成佛设尔何失。若是菩萨如何会释观音三昧。彼经说曰佛告阿难我今道实其事不虚。我念观世音菩萨于我前成佛号曰正法明如来应供正遍知明行足善逝世间解无上士调御丈夫佛世尊。我于彼时为彼佛下作苦行弟子。若是佛者如何会释观音授记。故彼经曰善男子阿弥陀佛寿命无量百千亿劫。当有终极当般涅槃。复曰善男子阿弥陀佛正法灭后过中夜分明星出时。观世音菩萨于七宝菩提树下结加趺坐成等正觉。号普光功德山王如来十号具足。乃至国名众宝庄严。又无量寿曰观音菩萨于是国土修菩萨行。命终转化生彼佛国。解曰观音名同人异故彼此说互不相违。如法华经诸佛同号日月灯明。又解观音自有二种一实二化。一者实身如观音经二者化身如无量寿。如法华论。释迦如来成道已久就化相故。今乃成佛虽有两释。后解为胜顺诸圣教不违理故

行深般若波罗蜜多时者　第二辨能观智于中有二。初明智体后辨智用。此辨智体行谓进行是能观智深即甚深。深有二种一者即行深。无分别智内证二空离诸分别。无能所行以为行相故名行深。故大品曰不见行不见不行是名菩萨行深般若。二者境深谓二空理离有无相绝诸戏论。无分别智证此深境故曰行深。梵音般若此翻名智。言波罗者名为彼岸。蜜多名到顺彼应云智彼岸到。从此方语智到彼岸。因智断障至涅槃城是故说为智到彼岸。时谓时分智度论说依有为法假说时分。而时数等非蕴处等诸数所摄法。沙门论亦同此释。故彼论曰因法假名时离法无别时。瑜伽等说有为法上前后分位假立时分。不相应法行蕴所摄。依佛地论亦同此说故彼论曰立不相应时节分位。或心影像总释意曰。般若有三谓即文字观照实相为显观照简实相等。故言行深般若波罗蜜多时(此中应说三种般若)

照见五蕴皆空者　辨其智用用有二种。一者自利二者利他此明观空即是自利。将释此文先叙诸观后依前观。释此经文言诸观者若夫佛法甚深本唯一味。学者未悟乃成异说。是故世尊佛地经说佛告妙生譬如种种大小众流。未入大海各别所依水有差别水有增减。若入大海无别所依水无差别水无增减。如是菩萨未证入于如来清净法界大海各别所依智有差别智有增减。若已证入如来清净法界大海无别所依智无差别智无增减受用和合一味事智。亲光释曰千年已前佛法一味过千年后空有乖诤。佛灭没已一千年后南印度界健至国中有二菩萨一时出世。一者清辨二者护法。为令有情悟入佛法立空有宗共成佛意。清辨菩萨执空拨有令除有执。护法菩萨立有拨空令除空执。然则空不违有即空之理非无不违空即色之说自成。亦空亦有顺成二谛非空非有契会中道。佛法大宗岂不斯矣。问有无乖诤宁顺佛意。答执我胜论甚违圣教佛自许为解脱菩萨。况二菩萨互相影向令物生解违佛意乎。故今略述二种观门。一者清辨依诸般若及龙猛宗立一观门。谓历法遣相观空门立一切法皆悉是空无生无灭本来寂静自性涅槃。故般若经曰一切有为法如梦幻泡影如露亦如电应作如是观。又思益经云以心分别诸法皆邪不以心分别诸法皆正。又中论曰若有所不空应当有空。不空尚不得何况得于空。又中论曰诸佛或说我或时说非我。诸法实相中非我非非我。如是等文诚证非一。是故清辨掌珍论曰真性有为空如幻。缘生故无为无有实不起似空华。二者护法依深密等及弥勒宗立一观门。谓在识遮境辨空观门立一切法通有及无。遍计所执情有理无。依他起性因缘故有。圆成实性理有非无。故深密说依所执故说一切法皆无自性。宝积经说若拨诸法皆无性者我说彼为不可治者。瑜伽等曰依所执性故契经说一切诸法皆无自性。辨中边论颂虚妄分别有。于此二都无此中唯有空于彼亦有此。故说一切法非空非不空有无及有。故是故契中道。如是等文诚证非一。是故二十唯识等曰非知诸法一切种无乃得名为入法无我。然达愚夫遍计所执自性差别诸法我无如是乃名入法无我。叙观如上今当释文

言五蕴者所谓色蕴受想行识五色根境及法处。色方所可知有质碍义故名为色。苦乐舍受如次领纳违顺中境故名为受。诸识俱想取境分齐如男女等起诸说故名之为想。思等心法驱役于心令造善等名之为行。眼等诸识于境了别故名为识。五种皆有积聚义故名之为蕴。如是五蕴有其三种一者遍计所执五蕴情有理无。二者依他起性五蕴因缘假有。三者圆成实性五蕴真实理有故。中边曰蕴有三种一所执蕴二种类蕴三法性蕴。斯取新本。十八空论亦同彼说。故彼论曰所有三种一者分别二者种类三者如如。于此三种五蕴之内一一皆有生法二空。言皆空者显所证理。即前二空依此诸空分成两释。依清辨宗自有二解一曰三中遣前二性非圆成实。故中论曰因缘所生法是即说为空。一曰三性五蕴皆空。故掌珍曰无为无有实不起似空华准此应知。圆成亦遣。依护法宗三种蕴中但遣所执以辨空性。所引理教具如上说。或有本曰照见五蕴等皆空虽有两本。后本为正。捡勘梵本有等言故后所说等准此应知

度一切苦厄者　此即第二显利他用此有三种。一曰苦即是厄故名苦厄。六释之中是持业释。有漏诸法无非是苦故世尊说三界皆苦。然此苦门略有三种所谓苦苦坏苦行苦。中则有八谓生老病死怨憎会苦爱别离苦求不得苦五盛阴苦。广有苦苦谓二十五有一一皆有生住异灭四有为相。故成百苦。二十五有四人四恶趣四空及四禅梵王六欲天无想阿那含。拟注一曰苦厄即是四厄。所谓欲有见及无明。如是四种系诸有情令受诸苦犹如车轭。若依此释苦之厄故名为苦厄。故六释中是依主释。一曰苦厄别有所目如前两释故六释中是相违释

舍利子者　自下第二辨所观境于中有二。初约四句以辨空性后依六义以显空相。前中有二初标受化人后正辨空性此即标人。梵音奢利富多罗或云舍利弗多罗。此翻舍利名鸲鹆弗多罗此云子。母眼青精似鸲鹆眼故立母名号为鸲鹆。明度经曰鹫鹭子或云优娑提舍者从父立号。旧翻身子者谬也。问此般若是菩萨法何故世尊告舍利子而非菩萨。答如智度论说舍利弗其人得十千三昧。于一切佛弟子中智慧第一故。世尊说一切众生智唯除佛世尊欲比舍利弗智慧及多闻。于十六分中犹尚不及一。又舍利弗年始八岁凡所立论辞理超绝时诸论师叹未曾有。愚智大小一切皆伏自余因缘广如彼论。是故此中告舍利子又欲引小回趣大乘

色不异空空不异色色即是空空即是色者　此约四句正辨空性于中有二。初约色蕴以辨四句后类四蕴皆有四句。此约色蕴以辨四句将释四句。先辨空性者如前分别。空有二种。一者生空二者法空。所说生空有其四种。一者所执我无说之为空。诸法数中所不摄故。是故瑜伽菩萨地曰有为无为名为有。无我我所名为无。二者生空所显真如空所诠故亦说为空。三者苦谛所摄有漏别空即用有漏五蕴为体故。成唯识第六卷曰。别空非我属苦谛故。四者诸法所摄通空非我。即用诸法以为体性。故诸经说一切法无我。虽有四种依三性理摄以为三。一所执性空二依他性空三圆成实空。如其次第三性为体。法空四种虽无正文以理推征应有四句。法空三种准上应知。若广分别有十八空如十八空论。依大般若或说十六十七十八乃至二十。具如彼经。今依三性以释四句。于四句中初之二句标宗正说后之二句遣外疑情。色不异空者标俗不异真。空不异色者标真不异俗。后遣外疑情外人设疑互相依故为不异耶。为相即故名为不异故作此说。色即是空空即是色非相依故名为不异。非相即故名为不异。即依此文西方诸师自有两释。一清辨等曰色有三种谓所执等空能遣性体非三性。今言色即是空者遍计所执本来无故说之为空。据实此空亦非是空。故中论曰若有不空法。则应当有空法。实无不空法何得有空法。后二性空准此应知为除有执说彼空言。依他起性犹如幻等从缘故空。圆成实性以不起故如似空华自体亦空。有解宗中更有一释遣前二性非圆成实。两宗共许离有无相绝戏论。故问色空相对为一异耶。一体相即便成一执体若异者则是异执。亦一亦异宁不相违非一非异应成戏论。释此四句分别成两解。一外道小乘多依表门。以说四句言有无等有所诠故二依大乘有无等言皆是遮诠。一切诸法不可说故。然一切法皆有二相。谓即自共。自相唯是现量智得非假智言所可得故。若假智言所诠得者谓即共相且如说青。茎叶等相其相各异唯现量得。由斯假智及诸名言但能诠表青上共相。而说青时遮黄等故名为说青。非正表青故说遮诠。就遮诠中自有两说。一清辨宗其性道理不可以名名不可以相相。破而无执立而无当。所引理教准上应知。二护法宗实有世俗胜义道理皆离名言。于中真性对世俗故说真性言非无所诠。清辨宗中一师所说亦同此释。是故护法破清辨曰。若依真性说诸法空便成相符极成之失。于清辨宗遣依他性护法不许故有差别。由斯道理内宗所说有无等言皆是遮诠。远离一异戏论等失。依清辨宗释文已讫。二依护法释四句者色有三种。谓三性色空亦有三。体即三性是故无著菩萨辨中边曰。空有三种一无性空性非有故。二异性空与妄所执自性异故。三自性空二空所显为自性故。依遍计色对空四句有其三种。一所执色对所执空以辨四句。随情所执根境等色不异所执本无之空。是故说为色即是空。本无之空随情即有故言空即是色。此是同性相即。标宗二句准上应知。二所执色对依他空以辨四句。附托依他所执实色不异依他无实之空。是故说言色即是空。而彼妄情于彼空处执有实色故言空即是色。标宗二句准应可知。此是异性相即。三所执色对圆成实以辨四句。于圆成性执为实色不异圆成自性之空。于自性空执为实色故言色即是空空即是色。标宗二句准应可知。此如依他异体相即。依他起色对异性空有其四句。谓缘生色不异依他异性之空。然此空性是质碍故。是故说为色即是空空即是色。此是同性相即。标宗二句准应可知。又释依他缘生之色对二性空有二四句。对异性故不异前释。对自性空亦有四句。谓缘生色用如为体。然彼空性不异依他。故成唯识作如是说。故此与依他非异非不异如无常等性。又中边云此中唯有空于彼亦有此。由斯道理依他圆成互不相离。是故说言色即是空空即是色。非缘生空故说相即。不尔应成违宗失故。此是异性相即。标宗二句准应可知。圆成实性对自性空有其四句。谓圆成实是依他起色。实性故名之为色。我法二空之所显故说圆成空。由此道理是故说言色即是空空即是色。此是同性相即。标宗二句准应可知

受想行识亦复如是者　此即第二类释四蕴皆有四句。四句相即准上应知。又解此经自有两本一本如上。一本经曰受想行识等亦复如是。所言等者准下经文有六善巧。谓蕴处界缘生四谛菩提涅槃。今举四蕴等余五门皆有四句故说等言。六门义别后当分别

舍利子是诸法空相不生不灭不垢不净不增不减者　自下第二约六种义以显空相。于中有二。初约六义正显空相后依空相遣六门法。显六相中命舍利子如上已释。六相即是不生不灭不垢不净不增不减。然此六相西方两释。一者清辨二者护法。依清辨宗释六相者本无今有名生。暂有还无名灭(如瑜伽说)性染不净名垢离染非垢称净(如诸教说)执法有用曰增妄计法坏名减(如摄大乘论说)三对六相三说不同。一曰此文约位辨三。谓真空性离诸相故。道前远离流转生灭。道中即无惑智垢净。道后永舍体用增减。一曰此文约性辨三。遍计所执本来无故不生不灭。依他起性从缘生故不垢不净。圆成实性以不起故不增不减。一曰此说三对六相一一皆通诸位诸性。总遣三性无所存故。三中后胜。顺本宗故。依护法宗理实空相乃有众多。谓非一异及有无等。而经且说三对六者。生灭即是有为通相垢净止辨诸法自性。增减言显法上义用理实。三空通有六相经意正显是自性空。生法二空所显真理通与迷悟为所依故

是故空中无色无受想行识者　自下第二依前空相遣六门法。遣六门法即分为六。此即第一遣五蕴门。谓诸法空具六种相是故空中无五蕴法。五蕴义别如前已释。此中所说六门法者总显二乘通别二境。初三止显诸法性故。是故说言三乘通境。依前法性随根别说缘生等门。是故后三名为别境。故法华曰为声闻人说四谛法。为缘觉人说缘生法。为诸菩萨说六度法

无眼耳鼻舌身意无色声香味触法者　此即第二遣十二处故今略说十二处义。三门分别。一明教兴二释名字三出体性。言教兴者自有二意。所谓悟入生法二空。入生空者如彼二十唯识论云。依此所说十二处教谓。若了知从六二法有六识转。都无见者乃至知者。便能悟入有情无我。入法空者即此所说遣十二处显法空理。清辨护法遣法差别如上应思。次释名者先总后别。初即总明十二处者十二是举数。处是生长义。谓六根境生长一切心心所法故名为处。六释之中是带数释。后别名者如瑜伽论第三卷说。复次屡观众色观而复舍故名为眼。数数于此声至能闻故名为耳。数由此故能嗅诸香故名为鼻。能除饥羸数发言论表彰呼召故名为舌。诸根所随周遍积聚故名为身。愚夫长夜莹饰藏护。执为己有计为我所及我。又诸世间依此假立种种名想。谓之有情人与命者生者意生及儒童等故名为意。数可示现在其方所质碍可增故名为色。数宜数谢随增异论故名为声。离质潜形屡随风转故名为香。可以舌尝屡招疾苦故名为味。数可为身之所证得故名为触。遍能任持唯意忆性故名为法。第三出体者。眼根者如诸论说。四大所造眼识所依净色为体如说眼根。乃至耳根四大所造耳识所依净色为体。意根通用八识为体。色者如集论说四大所造眼根所行二十五色以为自性。谓青黄赤白长短方圆粗细高下若正不正光影明闇云烟尘雾迥色表色空一显色。声有十一谓若可意若不可意若俱相违若因受大种若因不受大种若因俱大种若世所共成若成所引若遍计所执若圣言所摄若非圣言所摄。香有六种谓好香恶香平等香俱生香和合香变异香。味有十二苦酢甘辛咸淡若可意若不可意若俱相违若俱生若和合若变异。触有二十六所谓四大滑涩轻重软缓急冷饥渴浊饱力劣闷痒黏病老死疲息勇。如此五尘广如杂集。诸论同异具如别章。法处即用百法门中八十二法以为自性。谓心所法中五十一色中有一。谓法处色不相应二十四。无为有六依集论等。八十八法以为自性。谓四种法处色及二无为具如彼说。余门分别广如别章

无眼界乃至无意识界者　此即第三遣十八界此十八界三门分别。一显教兴二释名字三出体性。言教兴者谓执色心以为我者及下根者。是故世尊说十八界。次释名者先总后别。总名十八界者十八是数界是种族义及性别义。一切诸法十八种族及性别故。是带数释准上应知。次别名者六根六尘如处中说。六识得名有其二义。一者从境名为色识乃至法识。随境立名顺识义故。二者从根名为眼识乃至意识随根立名具伏发等五种义故。此即色之识故名为色识。乃至意之识故名为意识。故六释中是依主释。若具分别如成唯识第五卷说。后明体者眼等十二如处中说。眼等六识百法门中如其自名。眼等六识以为自性。自余诸门广如诸论

无无明亦无无明尽乃至无老死亦无老死尽者　此即第四遣缘生门。然此缘生自有二种。一者流转二者还灭。由无明故能起诸行乃至由生为缘老死。如是顺流五趣四生如满月轮始不可知。于空性中无此流转。故经说言无无明乃至无老死。由观智力令无明灭。无明灭故诸行亦灭。如此乃至由生灭故老死亦灭。此即轮前还归涅槃。故名还灭。于空性中无此还灭故经亦说。无无明尽。乃至亦无老死尽。如何说此经起门者如法华经。为求缘觉故说缘生。而今此缘为显法空故说此门。然此缘生不同常释故。今略以三门分别。一释名二出体三废立。言释名者先总后别。言总名者十二即是总标其数如缘起经。如是诸分各由自缘和合无阙相续而起故名缘起。依瑜伽论因名缘觉果名缘生。于此名中举数显宗故六释中是带数释。后出别名者三际中愚于境不了故名无明。福等三业迁流造作名之为行。眼等八识了别境界故名为识。相等色等召表质碍故曰名色。眼等六根生长心等名为六处。苦等三触对前境故名为触。苦等三受领顺违等名之为受。自体等贪染自境故名为爱。欲等四取执取境等名之为取。行识等种能招生等故名为有。识等五法本无今有名之为生。即彼五法衰变灭坏故名老死。第二出体有其三义。一引生差别二正出自性三现种分别。引生差别者无明及行名为能引能引识等五果种故。识等五种名为所引是前二支所引发故。爱取有三名为能生近生当来生老死故。生及老死即是所生。是爱取有近所生故。正出体者能发正感福等三业为无明支。即彼所发为行支体亲生当来第八识种为识支体。除后三因。余因皆是名色支体后之三因如名次第。即后三种有解名色即摄五种以为自性。于中随胜立余四种。谓赖耶种名为识支立余三种。谓六处等能润行等六种种子。贪欲名爱缘爱复生欲等四取为取支体。然此四取如瑜伽论第十卷说。如其次第于诸欲境及余四见于诸邪戒及萨迦耶见所起贪欲为取支体。经论同异如缘起等。行及识等六种种子被润已后转名为有。识等五种所生果法始从中有至本有中未衰变位名为生支。至衰变位总名为老身坏命终说名为死。现种别者有其二义。一就实正理门二相从假说门。相从假说一一皆通种及现行。故十地论无明有二一者子支二者果支。乃至老死应知。亦尔就实正理生与老死唯现非种。识等六支唯种非现无明与行及爱取支皆通现种。第三废立有其三义。一约定遍废立诸支二约开合分别诸支三约世地辨其同异。约支废立者如成唯识第八卷。说问如何老位不别立支。答非定有故附死立支。问病何非支答不遍定故老虽不定遍故立支。诸界趣生除中夭者将终皆有衰朽行故。问名色不遍何故立支。答定故立支。胎卵湿生六处未满定有名色。又名色支亦是遍有有色化生初受生位虽具五根而未有用。尔时未名六处支故。初生无色虽定有意根而不明了未名意处故。问爱非遍有宁别立支生恶趣者不爱彼故。答定故别立不求无有生善趣者定有爱故。问若尔不还应无有爱。答虽不现起然如彼取定有种故。又爱遍生恶趣者于现我境亦有爱故。依无希求恶趣身爱。经说非有非彼全无。二开合差别有其二义。一引生相对以辨开合二发润相对以辨开合。引生相对如彼论说。何缘所生立生老死所引别立识等五支。因位难知差别相故依当果位别立五支。具说如彼。果位易了差别相故总立二支以显三苦。具说如彼。发润别者如彼论说。何缘发业总立无明润业位中别立爱取。虽诸烦恼皆能发润。无明力胜具足如彼而发业位无明力增以具十一殊胜事故谓所缘等广如经。于润业位爱力偏增。说爱如水能沃润故要数溉灌方生有芽。且依初后分爱取二无重发义。立一无明三约世地辨其同异有其二义。一约地辨同异二约世辨同异。地同异者如彼论说。诸缘起支皆依自地有所发行。依他无明如下无明发上地行。不尔初伏下地染着。所起上定应非行支。彼地无明由未起故。世同异者如彼论说。此十二支十因二果定不同世。因中前七与爱取有或异或同。若二三七各定同世。如是十二一重因果足显轮转及离断常。施设两重实为无用。或应过此便致无穷。解曰论依先申自宗一重缘起破萨婆多两重缘起。寻即可知自余诸门广如彼说

无苦集灭道者　此即第五遣四谛门。如何说此四谛门者如法华经为求声闻说应四谛。今此经中为显法空遣四谛法。然此四谛三门分别。一释名字二出体性三种数差别。言释名者先总后别。言总名者四是标数。谛有二义如瑜伽论。一如所说相不相离义。二由离此故致究竟意处是带数释准前可知。言别名者谛别不同乃至四种一苦二集三灭四道。三苦所成名之为苦。能招后果故名为集。集苦尽故名之为灭。能除能通故名为道。第二出体者苦谛即是有漏五蕴能感惑业以为集谛。择灭无为为灭谛体。道谛即道无漏圣道。第三种数别者或二或三。所言二者一者世俗二者胜义。于一一谛皆具四谛如显扬等。恐繁不叙。依胜鬘经亦有二种。一者有作二者无作。由烦恼障及所发业感分段生。彼所感果名为苦谛。能感惑业故名集谛。彼苦集尽名为灭谛。生空观智名为道谛。无漏业因无明为缘感变易生。所招异熟以为苦谛。能感惑业名为集谛。彼苦集尽故名灭谛。法空观智名为道谛。问岂不法执不能发业亦非润生。无漏圣道非苦集谛如何经说无漏为因无明为缘。答如成唯识第八卷说。断法执及资助缘故说无漏为因无明为缘。理实即前感分段业及所感果由资力故。转胜转妙以为变易。广说如彼。所言三者二种四谛皆具三性。谓所执等如中边论及成唯识第八卷中。广辨其相寻即可知不繁具述

无智亦无得者　此即第六遣智断门。如何说此智断门者如法华经。为诸菩萨说六度法。今此经中为显法空遣智断门。然即智断自有两释。一曰在因名智即是般若。果位名得即是菩提。一曰菩提名智涅槃名得。虽有两释后说为胜。诸部般若皆遣菩提及涅槃。故菩提涅槃后当分别

以无所得故菩提萨埵依般若波罗蜜多故心无挂碍者　自下第三显所得果于中有二。初正明得果后引例。证成前中有二。初辨观有能后显所得果此即初也。于中有三初以无所得故者辨空离相。理实空性离六门法。举后显前但言无得。次菩提萨埵者观人发意如前所说。菩提名觉萨埵即是所化有情。上求菩提下化有情发此智悲故名菩萨。后依般若波罗蜜多故心无挂碍者辨观有能。翻名释义如上。应知般若名智别境中慧心言即显与慧俱心。心有二种所谓性相挂碍即是惑智二障。总释意曰真性空理离六相故。发意菩萨依彼观智令慧俱心证空断障。非诸执有异生二乘内证二空断其二障

无挂碍故无有恐怖远离颠倒梦想究竟涅槃者　此即第二显所得果。或有本云远离一切颠倒梦想虽有二本后本为胜。然所得果有其四种。一无挂碍故无有恐怖者远离诸怖畏。怖畏即是五种怖畏。如佛地论第二卷说。五怖畏者一不活畏二恶名畏三死畏四恶趣畏五怯众畏。如是五畏证得清净意乐地时皆已远离。二远离颠倒者远离果颠倒。即是三四七八。三者谓即想见及心。四者所谓无常为常于苦为乐不净为净无我为我。七倒不异前三四倒。八倒谓即于前四倒更加四种。理实佛果常乐我净执为无常无我不净翻乐为苦。三远离梦想者远离梦想果。即八妄想其想如梦故名梦想。瑜伽名为八种分别。释彼意曰诸有情类由不了知真如空性。由此因缘能生三事。一者根境二我见慢三贪嗔痴。由贪等故能造诸业能生有情及器世间。由斯长时转轮生死故。寻思等生法空观断除惑业证大菩提故。今略述八分别义如瑜伽论三十六曰。又诸愚夫由于如是所显真如不了知故。从是因缘八分别转能生三事。能起一切有情世间及器世间。云何名为八种分别者。一者自性于一切法分别自性如色声等。二者差别谓即于彼分别可见不可见等。三者总执谓即于彼色声等上计有情我舍军林等。四者我分别。五者我所此二分别于诸有漏有取之上即计为我惑计我所。六者爱分别。七者非爱。八者俱相违。如其次第于妙非妙及俱离事所生分别。三藏解曰八种皆以无记异熟生慧为其自性。或可寻伺以为自性生三事者。初三分别能生戏论所依缘事六根六境。次二分别能生我见及以我慢。后三如次生贪嗔痴。当知此中所依缘事为所依故生我见慢。见慢为依生贪嗔痴。由此三事能现有情及器世间流转品法。四寻等观具如诸论。此经意曰由般若故内证法空远离颠倒八种妄想。四究竟涅槃者证得涅槃果。涅槃略以四门分别。一释名字二出体性三种数多少四问答分别。第一释名旧曰梵音名为涅槃或云泥洹。此土翻译名为寂灭。大唐三藏曰波利匿缚喃此云圆寂。究竟离障生死喧动故曰圆寂。谓欲存旧名为涅槃。第二出体诸说不同。萨婆多宗有余无余皆用择灭无为为体有实自性。依经部宗烦恼灭处名有余依。苦果尽处名无余依。假而非实自有两释。一曰灭谛为体惑业灭处灭谛摄故。一曰皆用道谛为性于道建立惑等灭故。今依大乘诸说不同。昙无忏曰四德为林玄致为本。真谛三藏说大乘中有四涅槃三是道果本来清净非道果摄。又说般若及以大悲为无住处涅槃自性。如此等说不可具述。今三藏曰四种涅槃用如为体。故成唯识第十卷曰。四种涅槃皆依真如离障建立。而涅槃说法身般若解脱三事成涅槃者举能成智意。取所成离障真如非能成智为其自性法。数类分别自有两释。一曰初后即是真如中间二种择灭所摄。一曰初一即是真如后三皆是择灭所摄。虽有两说护法正宗以后为正。第三种数分别者略即二种广开为四。所言二者一者性净二者方便净。开为四者自性清净有余无余及无住处。如成唯识第十卷说。涅槃义别略有四种。一本来自性清净涅槃。虽有客染而本性净具无数量微妙功德。唯真圣者自内所证其性本寂故名涅槃。二有余依涅槃。谓即真如出烦恼障虽有微苦所依未灭而障永寂故名涅槃。三无余涅槃。谓即真如出生死苦烦恼既尽余依亦灭众苦永寂故名涅槃。四无住处涅槃。谓即真如出所知障大悲般若常所辅翼由斯不住生死涅槃。利乐有情穷未来际用而常寂故名涅槃。一切有情皆有初一。二乘无学容有前三。唯我世尊可言具四。第四问答。问如何善逝有有余依。答虽无实依而现似有。或苦依尽说无余依。非苦依在说有余依。是故世尊可言具四。问若声闻等有无余依如何有处说彼非有(如胜鬘等)答有处说彼都无涅槃岂有余依彼亦非有(此亦胜等)然声闻等身智在时有所知障。苦依未尽圆寂义隐。说无涅槃非彼实无。烦恼障尽所显真理有余涅槃尔时未证无余圆寂。故亦说彼无无余依。非彼后时灭身智已无苦依尽无余涅槃。广说如彼。问诸所知障既不感生如何断彼得无住处。答彼能隐覆法空真如故断彼时显法空理。此理即是无住涅槃。令于二边俱不住故。问若所知障亦障涅槃如何断彼不得择灭。答择灭离缚彼非缚故。问既尔断彼宁得涅槃。答非诸涅槃皆择灭摄不尔性净应非涅槃。有说。亦是择灭所摄广说如彼。已外问答如理应思

三世诸佛依般若波罗蜜多故得阿耨多罗三藐三菩提者　自下第二引例证成。于中有二初正明得果后约用叹胜。此即初也文有三节。三世诸佛者辨得果人。三世即是过现未来有为法也。如其次第曾有现有及以当有以为三世。又说如次当不有法正现有法曾不有法以为三世。然此三世有其三种。一种子三世二道理三世三唯识三世。如此三世诸宗同异具如诸论。如理应思。梵音佛陀此翻觉者。具有五义故名为佛如佛地论。言五义者一具二智(一切智一切种智)二离二障(烦恼所知)三达二相(一切法一切种法)四具二利(自利利他)五具二譬(如睡梦觉如莲华开)具此五义故名为佛。次依般若波罗蜜多故者辨能得智如前可知。后得阿耨多罗三藐三菩提者显所得果即是菩提。梵音如上。而翻此言诸说不同。一曰阿之言无耨多罗云上三名正藐言真后三名正菩提曰道。总言无上正真正正道。一曰阿之言无耨多罗曰上三名正藐言遍三云知菩提名觉。如理智缘真如名正。如量智缘俗言遍。无分别智断二无知名知。菩提出睡梦之表称觉。此四智是菩提体超二乘果故名无上。今大唐三藏曰阿之言无耨多罗名上三名正藐名等三又言正菩提云觉。无法可过故言无上。理事遍知故云正等。离妄照真复云正觉。即是无上正等正觉。问标宗得果但说涅槃。引例证成唯菩提者。以觉证灭岂不相违。答理实皆通智断二德各据一义。影略互显此。菩提义略以三门分别。一释名字二出体性三诸门分别。第一释名梵音菩提此翻名觉。觉有三种谓三乘智而今且说无上菩提。即真俗智双证二空故名为觉。第二出体有其二种。一就实出体四智为性故。成唯识第十卷曰菩提即是四智相应心品为体。二相从假说略有三门。一智断分别即用二空观智。及断二障所证无为。以为自性故。瑜伽论菩萨地曰二断二智名为菩提。彼说二断为菩提者智之果故。相从假说亦名为智。三二身分别通用三身以为自性。故摄大乘智殊胜体即是三身。彼曰法身通名智者智之性故似说名智。三五法分别通用五法以为自性。佛地经曰有五种法摄大觉地。所谓四智及净法界。彼经真如为大觉者同摄大乘。觉之性故。依智度论觉之境故名之为觉。故彼论云说智及智处皆名为般若。第三诸门分别先释四智后辨三身。且说四智五门分别。一标名出体门二转识得智门三心所相应门四所缘差别门五初得现起门。一标名出体门者一大圆镜智如依圆镜众缘影现。如是依止如来智镜诸处境识众像影现。从谕立号即用第八相应心品以为自体。有十一喻如佛地经。二平等性智自他有情悉皆平等从用立号名平等智。有十平等如经广说。第七相应心品为体。三妙观察智相应心品善观诸法自相共相从用立号名妙观察智。有十种喻如经广释。第六相应心品为体。四成所作智普于十方示现种种变化三业所应作事。此亦从用名成所作智。有十种喻如经广说五识相应心品为体。二转识得智者佛地第三。有二师说。一曰转第八识得大圆镜智。转第七识。得平等性智。转第六识得妙观察智。转五现识成成所作智。一曰转第六识得成所作智。转五现识得妙观察智。此不应理非次第故。说法断疑则遍观察非五用故。无性摄论亦有两释。广如彼说。大庄严论同佛地论第二所说。成唯识第十卷中即同佛地初师所说须会。三心所相应者一一皆与二十一法心品相应。谓所遍行别境各五善有十一具如佛地。四所缘差别者大圆镜智如佛地论。自有两释一曰缘如一曰通缘一切诸法。虽有两说后者为胜。唯识第十亦同彼说。若广分别具如佛地。平等性智佛地唯识皆有三释。一曰但缘第八净识。一曰但缘平等真如。一曰普缘真俗为境。具如二论。妙观察智缘一切境无有诤论。成所作智有其二说。一曰但缘五种现境。一曰遍缘三世诸法。后说为正。如彼二论。五现起差别者依佛地论。大圆镜智金刚心时初得现起。平等性智相应心品菩萨初地初现观时最初现行。妙观察智相应心品亦在初地。初现观时最初现行。成所作智自有二释。一曰初地已上皆得现行。一曰佛果方得现行。后说为正。广如彼论。依成唯识大圆镜智自有两释。一曰金刚心时初得现起。一曰佛果方得现起后说为正余如佛地。三身略以七门分别。第一释名字。第二出体性。第三五法摄身。第四常无常。第五形量大小。第六所化同异。第七依土差别。第一释名先总后别。言三身者三是标数身有三义谓体依聚故。成唯识第十卷曰。体依聚义总说名为身。佛地第七亦同彼释。此即六中带数释也。后别名者一自性法身谓即真如体常不变故名自性身。力无畏等诸功德法所依止故亦名法身。次受用身能令自他受用种种大法乐故名受用身。后变化身谓利有情示现种种变化事业名变化身。第二出体法身即用真如为体。次受用身即用四智自利功德。及为地上所现化相一分功德以为自性。其中同异五法门中当广分别。第三五法摄身依佛地论自有两释。有义前二摄自性身中间二种摄受用身。成所作智摄变化身。经说真如是法身故(如金光明经及佛地经等)。论说转去阿赖耶识得自性身。大圆镜智转第八得故知前二摄自性身(如摄大乘说得自性摄论庄严皆转第八得圆镜智)。此经中说成所作智起诸化业。庄严论说成所作智于一切界发起种种无量难思诸变化事。故知后一摄变化身(更勘说处)平等性智如诸论说。能依净土随诸菩萨所乐示现种种佛身(更勘说处)。妙观察智亦如论说。于大集会能现一切自在作用说法断疑(如庄严论说)。又说转去诸识故得受用。故知中二摄受用身(如摄大乘论说)。又佛三身皆十义中智殊胜摄故知三身皆得有智(如摄大乘中殊胜也)。有义初一摄自性身。四智自性相应共有及为地上菩萨所现一分细相摄受用身。若为地前菩萨等所现一分粗相化用摄变化身。诸经皆说清净真如为法身。故赞佛论说如来法身无生灭故。如此等文故知法身即净法界。具说如彼。庄严论说大圆镜智自受用。佛摄大乘说转诸转识得受用身。然说转去阿赖耶识得法身者。此说转去第八识中二障种子。显得清净转依法身。非说镜智是法身佛。又受用身略有二种。一自受用三无数劫修所成故。二他受用为诸菩萨受法乐故是故四智相应共有及一分化为受用身。经论皆说化身为化地前众生现种种相。既是地前众生境界故知非是真实功德。但是化用。经论唯说成所作智能起化业非即化身。但虽三身智殊胜摄法身是智所依证故。化身是智所起用故。似智现故说假为智亦无有过。成唯识论不异前说故不重述。第四常无常者问受用变化既有生灭。云何经说诸佛身常。答由二所依法身常故受用法乐无休废。故数数现化无断绝故。如常受乐如常施食故说名常。庄严论说常有三种。一本性常谓自性身。此身本来性常住故。二不断常谓受用身受用法乐无间断故。三相续常谓变化身没已复现化无尽故。具说如彼。第五形量大小者自性法身由如虚空不可说其形量大小。就相而言遍一切处。受用身者有色非色非色诸法无形质故。亦不可说形量大小。若就依身及所知境亦得说言遍一切处。色有二种。一者实色二者化色。言实色者三无数劫修习所生充满法界。遍实净土唯佛与佛乃能知之。言化色者由悲愿力为入大地诸菩萨众。现种种身形量不定。为化地前所现化身通色非色。非色无形故无形量。色即不定随所化故。广说如彼。第六所化同异者如佛地论。一切如来所化有情为共不共。论有三说。一曰唯共一切功德行愿同故广如彼说。一曰不共以佛所化诸有情类本相属故。广说如彼。如实义者有共不共。无始时来种性法尔更相系属。或多属一或一属多。广说如彼。依成唯识同第三释。如论应知。第七依土差别者如成唯识。身有四种所谓自性受用及变化身。土有四种一自性土二自受用三他受用四变化土。即前四身如其次第住四种土。虽自性身与自性土体无差别。而属佛法相性异故义说能所。其变化身非唯住净亦通秽土广如彼论

故知般若波罗蜜多是大神咒是大明咒是无上咒是无等等咒者　自下第二举用叹胜于中有二。初长行广释后举颂结叹。前中有二初明自利后辨利他。此即初也。所言咒者咒术之名。明即妙慧证空断障。言要妙术故以咒言叹其胜用。神用莫测名大神咒。遣暗除痴称大明咒。超过二乘故云无上。越彼菩萨佛慧均平是故重言名无等等

能除一切苦真实不虚者　此即第二辨利他用。依此妙慧令诸有情越生死苦证涅槃乐。舒舌发际尚表诚言。况覆三千而语有谬。故经说曰是真语者

故说般若波罗蜜多咒即说咒曰揭谛揭谛波罗揭谛波罗僧揭谛菩提莎婆呵者　此即第二举颂结叹于中有二。初长行标举后以颂正叹。然释此颂诸说不同。一曰此颂不可翻译古来相传。此咒乃是西域正音秘密辞句。翻即失验故存梵语。又解咒中说诸圣名或说鬼神。或说诸法甚深奥义言含多义。此方无言正当彼语故存梵音。如薄伽梵。一曰诸咒密可翻译如言南无佛陀耶等。释此颂句判之为三。初揭谛揭谛此云度度。颂前长行般若二字。此显般若有大功能自度度他故云度度。次波罗等句即颂长行波罗蜜多。此云彼岸到是即涅槃名彼岸也。揭谛言度度到何处。谓即彼岸是度之处。故云波罗揭谛。言波罗者翻名如上。僧揭谛者此云到竟。言菩提者是彼岸体。后莎婆呵此云速疾。谓由妙慧有胜功用即能速疾到菩提岸。又解颂中有其四句。分为二节。初之二句约法叹胜后有二句就人叹胜。就约法中先因后果。重言揭谛此云胜胜。因位般若具自他利二种胜用。故云胜胜。波罗揭谛言彼岸胜。由般若故得涅槃胜岸。故言彼岸胜。就叹人中先因后果。波罗僧揭谛此云彼岸僧胜。此叹因位一乘菩萨求彼岸人。菩提莎婆呵此云觉究竟。此叹果位三身果人。觉法已满名觉究竟。或可四句叹三宝胜。初之二句如次应知叹行果法。第三四句如次应知叹僧及佛矣

般若心经赞(终)


佛说观无量寿佛经疏

    No. 1750 [cf. Nos. 365, 1751]

佛说观无量寿佛经疏(并序)

        天台智者大师说

夫乐邦之与苦域。金宝之与泥沙。胎狱之望华池。棘林之比琼树。诚由心分垢净。见两土之升沈。行开善恶。睹二方之粗妙。喻形端则影直。源浊则流昏。故知欲生极乐国土。必修十六妙观。愿见弥陀世尊。要行三种净业。然化因事渐教藉缘兴。是以阇王杀逆韦提哀请。大圣垂慈乘机演法。曜玉相而流彩。耸珍台而显瑞。虽广示珍域而宗归安养。使末俗有缘遵斯妙观。落日悬鼓。用标送想之方。大水结冰。实表琉璃之地。风吟宝叶共天乐而同繁。波动金渠。将契经而合响。观肉髻而瞻侍者。念毫相而睹如来。及其瞑目告终。上珍台而高踊。文成印坏。坐金莲而化生。随三辈而横截。越五苦而长骛。可谓微行妙观至道要术者哉

此经心观为宗。实相为体。所言佛说观无量寿佛者。佛是所观胜境。举正报以收依果。述化主以包徒众。观虽十六言佛便周。故云佛说观无量寿佛。经者训法。训常。由圣人金口故言经也

释经五义。名体宗用教相(云云)第一释名者。一切众经皆有通别二名。通则经之一字。别则有七。或单人法譬。或复。或具。今经从能说所说人以立名即教别同名为经即教通为行不同。从一乃至无量即行别。同会常乐即行通。理虽无名将门名理。理随于门四四十六。即名理。别门随于理。即名理通。此约一化以明通。别更约一题。佛说即教。观即是行。无量寿佛。即是理。教行理足任运有通别意。更就一字说者。释论云。所行如所说。说即是教。如即是理。行即是行。佛即法身。观即般若。无量寿。即解脱。当知即一达三。即三达一。一中解无量。无量中解一。于一字尚达无量义。况诸字况一题。况一经一切经耶。故经云。若闻首题名字。所得功德不可限量。若不如上解者。安获无限功德耶。初释佛者。佛是觉义。有六种。即涅槃经云。一切众生即是佛。如贫女舍宝众物具存。力士额珠圆明顿在。如来藏经举十喻。弊帛裹黄金。土模内像。闇室瓶盆。井中七宝。本自有之非适今也净名云。一切众生皆如也。宝箧云。佛界众生界。一界无别界。此是圆智圆觉诸法。遍一切处无不明了。虽五无间皆解脱相。虽昏盲倒惑其理存焉。斯理灼然。世间常住。有佛不能益。无佛不能损。得之不为高。失之不为下。故言众生即是佛。理佛也。如斯之理。佛若不说无能知者。法华云。一百八十劫。空过无有佛。世尊未出时。十方常闇瞑。涅槃云。于无量世。亦不闻有如来出世大乘经名。若佛出世方能阐智慧日。识三宝之光明。开甘露门。知十号之妙味。因说生解于宝适悦。故须达闻名身毛皆竖。昏夜大朗巨关自辟。此名字佛也。观行佛者。观佛相好如铸金像。心缘妙色与眼作对。开眼闭目若明若闇。常得不离。见佛世尊从大相海流出小相。浩浩漾漾如大劫水。周眸遍览无非佛界。念一佛与十方佛等。念现在佛与三世佛等。一身一智慧力无畏亦然。念色身念法门念实相。常运念无不念时。念念皆觉是名观行佛也。相似佛者。念佛相好身。得相似相应念佛法门。身得相似相应。念实相身。得相似相应。相似者。二物相类。如鋀似金。若瓜比瓠。犹火先暖涉海初平。水性至冷饮者乃知。渴不掘井听说何为。略举其要。如法华中六根清净。即是其相。名相似佛也。分证佛者。初发心住。一发一切发。发一切功德。发一切智慧。发一切境界。不前不后亦不一时。三智一心中得。得如来妙色身湛然应一切。开秘密藏。以不住法即住其中。以普现色身作众色像。一音随类报答诸声。不动真际群情等悦。应以三轮度者能八相成道具佛威仪。以佛音声方便而度脱之。况九法界三轮耶。初住尚尔。况等觉耶。是名分证佛也。究竟佛者。道穷妙觉位极于茶故。唯佛与佛。乃能究尽诸法实相。边际智满种觉顿圆。无上士者。名无所断。无上士者。更无过者。如十五日。月圆满具足。众星中王最上。最胜威德特尊。是名究竟佛义。佛有无量德。应有无量号。举一蔽诸。华严有十万号。又经有万号。三世诸佛通有十号。净名三号以劫寿说。不能令尽。何况诸号耶。说者悦所怀也。即十二部经八万法藏。六度四等一切法门。又于一法中。作四门分别。于一一门巧作四悉檀利益。闻者欢喜赞用受行。信戒进念而得开发。贪恚愚痴豁尔冰消。革凡成圣入法流水。或三二一益。若都无益则乐默然。若一机扣。圣于一门施四益者。余三门亦如是。为一缘说一法既尔。诸缘诸法亦如是。观者观也有次第三观。一心中三观。从假入空观。亦名二谛观。从空入假观。亦名平等观。二空观为方便。得入中道第一义谛观。心心寂灭自然流入萨婆若海。此名出璎珞经。今释其意。假是虚妄俗谛也。空是审实真谛也。今欲去俗归真故。言从假入空观。假是入空之诠。先须观假。知假虚妄而得会真。故言二谛观。此观若成。即证一切智也。从空入假观者。若住于空与二乘何异。不成佛法不益众生。是故观空不住于空。而入于假。知病识药应病授药。令得服行。故名从空入假观。而言平等者。望前称平等。前破假用空。今破空用假。破用既均。故言平等观。此观成时证道种智。二空为方便者。初观空生死。次观空涅槃。此之二空为双遮之方便。初观用空。次观用假。此之二用为双照之方便。心心归趣入萨婆若海。双照二谛也。此观成时。证一切种智。是为次第三观也。一心三观者。此出释论。论云。三智实在一心中。得秖一观而三观。观于一谛而三谛。故名一心三观。类如一心而有生住灭。如此三相在一心中。此观成时证一心三智。亦名一切种智。寂灭相种种行类相貌皆知也。寂灭相者。是双亡之力。种种相貌皆知者。双照之力也。中论云。因缘所生法。即空即假即中。释论云。三智实在一心中得。即此意也。此观微妙。即一而三。即三而一。一观一切观。一切观一观。非一非一切。如此之观摄一切观也。无量寿者。天竺称阿弥陀佛。本无身无寿。亦无于量。随顺世间而论三身。亦随顺世间而论三寿。亦随顺世间而论三量法身者。师轨法性。还以法性为身。此身非色质亦非心智。非阴界入之所摄持。强指法性为法身耳。法性寿者。非报得命根。亦无连持。强指不迁不变名之为寿。此寿非长量。亦非短量。无延无促。强指法界同虚空量。此即非身之身。无寿之寿。不量之量也。报身者。修行所感。法华云。久修业所得。涅槃云。大般涅槃修道得故。如如智照如如境。菩提智慧。与法性相应相冥。相应者。如函盖相应。相冥者。如水乳相冥。法身非身非不身。智既应冥亦非身非不身。强名此智为报身。法寿非寿非不寿。智既应冥亦非寿非不寿。强名非寿为寿。法量非量非无量。智既应冥亦非量非无量。强名无量为量也。应身者。应同万物为身也。应同连持为寿也。应同长短为量也。智与体冥能起大用。如水银和真金能涂诸色像。功德和法身处处应现。往能为身非身。能为常寿为无常寿。能为无量能为有量。有量有二义。一为无量之量。二为有量之量。如七百阿僧祇及八十等。是有量之量。如阿弥陀实有期限。人天莫数是有量之无量。应佛皆为两量。逐物随缘参差长短。然此三身三寿不可并别一异。即乖法体。即一而三即三而一。乃会玄文释名竟。次辩体者。体是主质。释论云除诸法实相余皆魔事。大乘经以实相为印。为经正体。无量功德共庄严之。种种众行而归趣之。言说问答而诠辩之。譬众星之环北辰。如万流之宗东海。故以实相为经体也书家解。礼者。训体也。体有尊卑长幼。君父之体尊。臣子之体贱。当知体礼之释。是贵极之法也。复次体是底也。穷源极底理尽渊府究畅实际。乃名为底。释论云。智度大海唯佛穷底。故以底释体也。复次体是达义。得此体意通达无壅。如风行空中。自在无障碍。一切异名别说。皆与实相不相违背。释论云。般若是一法。佛说种种名。故以体达释经体也。次明经宗。初简宗体。次正明宗。有人言。宗即是体。体即是宗。今所不用。何者宗既是二。体即不二体若是二。体即非体。宗若不二宗即非宗。如梁柱是屋之纲维。屋空是梁柱所取。不应以梁柱是屋空。屋空是梁柱。宗体若一。其过如是。宗体异者。则二物孤调。宗非显体之宗。体非宗家之体。宗非显体之宗。宗则邪倒无印。体非宗家之体。则体狭不周。离法性外别有诸法。宗体若异。其过如是。今言不异而异。故有宗。不一而一。故有体也。今此经宗。以心观净则佛土净。为经宗致。四种净土。谓凡圣同居土。方便有余土。实报无障碍土。常寂光土也。各有净秽。五浊轻重同居净秽。体析巧拙有余净秽。次第顿入实报净秽。分证究竟寂光净秽。娑婆杂恶荆棘瓦砾。不净充满同居秽也。安养清净。池流八德树列七珍。次于泥洹皆正定聚。凡圣同居上品净土也。方便有余者。修方便道断四住惑。故曰方便。无明未尽故言有余。释论云。出三界外有净土。声闻辟支佛出生其中。受法性身非分段生。法华云。若我灭后实得阿罗汉。不信此法。若遇余佛。于此法中。便得决了。就中复有利钝。指上为净。指下为秽也。实报无障碍者。行真实法感得胜报。色心不相妨。故言无障碍。纯菩萨居无有二乘。仁王经云。三贤十圣住果报。即是其义。释论云。菩萨胜妙五欲。能令迦叶起舞。华严云。无量香云台。即其土净妙五尘。就中更论次第顿悟上下净秽等也。常寂光者。常即法身。寂即解脱。光即般若。是三点不纵横并别。名秘密藏。诸佛如来所游居处。真常究竟极为净土。分得究竟上下净秽耳。故以修心妙观能感净土。为经宗也。次辩经用。用者力用也。生善灭恶为经力用。灭恶故言力。生善故言用。灭恶故言功。生善故言德。此皆偏举具论必备也。苦是恶果。贪恚痴是恶因。恶因不除果不得谢。是故此经能令五逆罪灭。往生净土。即是此经之大力用也。教相者。此是大乘方等教摄。赴机适化广略不同。大本二卷。晋永嘉年中。竺法护译。此本是宋元嘉时畺良耶舍。于扬州译。两经皆在王舍城说。复有小本名阿弥陀。在舍卫国说。阿弥陀无量寿。彼此方言。二藏明义菩萨藏收。渐顿悟入此即顿教。正为韦提希及诸侍女。并是凡夫未证小果。故知是顿不从渐入。题称佛说。简异四人弟子。诸仙诸天化人等说也

分文为三。序正流通。从如是讫清净业处序分。尔时世尊放眉间光。讫诸天发无上道心正说。当机益分。尔时阿难白佛当何名下。讫经流通分。序中文二。证信发起正说亦二。净业妙观。流通复二。王宫鹫山。初证信序六句。如是标于信。我闻异外道。一时辩息诤。佛正明化主。王城论住处。列众为同闻。如是者。诸法实相古今不异名如。如理而说故为是。决定可信故云如是。我闻者。表异外道亲承有在。我者自在义。一切法空无我。何故说我。随俗假名说我。谓见慢名字。若无我则无闻。若无闻化道则绝。为此义故。虽知无我为传化不绝。假名说我。如人以金钱易铜钱及草木等。卖买法尔人无笑者。故言我闻。一者佛法无有定实之一。云何称一。随俗假说一耳。释论广破一异也。时者有二种。一迦罗即短时。亦名实时。二三摩耶名长时。亦名假时。今不论长短假实。说此经竟。总云一时。佛者亦婆伽婆。此云有大名声。亦云能破烦恼。佛者平等开觉故。名为佛。既能自觉。复能觉他。觉行备满。一切智异外道慈悲。异二乘平等。异小菩萨。尊极名为佛。在者。暂时曰在。久停名住。一往语耳。住者。四威仪皆为住。差别者。谓天住梵住圣住佛住也。天住谓六欲天。因即施戒善心也。梵住从初禅至非想。因即四无量心也。圣住三乘人。因即三三昧也。佛住。首楞严百八三昧十力四无畏十八不共也。王舍城者。天竺云罗阅只伽罗。释论解。摩伽陀国王有夫人生子。一头两面四臂。人谓不祥。王即裂其身首。弃之旷野。罗刹女鬼名阇罗。还合其身以乳养之。后大成人。力能并国王有天下。取诸国王万八千人。置此五山。以大力势治阎浮提。阎浮提人。因此名王舍城也。又先所住城。城中失火一烧一作。如是至七。国人疲役。集诸智人宜应易处。即求觅地。见此五山周匝如城。即作宫殿王于中住。故名王舍。又古昔国王名婆薮。厌世学仙。妄云天祀中应杀生啖肉身陷地狱。其子广车。次复为王。自念我父生入地狱。今欲出家复畏地狱。欲治天下复恐有罪。当何处身。作是念时。空中语言。汝行若见难值希有处。当作舍住。王出畋猎。见一鹿走疾如风。王便逐之。至此山周匝峻固。其地平正。生草细软好华遍地。茂林华果温泉浴池。皆悉清净。天雨天香奏天伎乐。乾闼婆等适见王来。各自还去。见此灵奇于中起舍。故名王舍城也。耆阇崛山者。翻名灵鹫。诸圣仙灵依之而住。又名鹫头。峰形似鹫。又山南有尸陀林。诸鹫食尸竟栖其山。然法身无像。实不假地所居。为欲利益故。随化身明化主住处耳。与大比丘众下。列同闻众也。先声闻次菩萨。显示教中二乘外相为胜。菩萨心虽是胜外相无定。是故后说也。声闻先标位。次列数。何不叹德。非是无德。译经人略。与者共义。一处一时一心一戒一道一见一解脱等。皆一故名共也。今经与阿难诸大众同闻。故云与也。大义有三。谓大多胜。天王大人所敬故言大。遍解内外经书名曰多。出九十五种上号为胜。此等皆是无学。小乘中极故云大也。比丘者。因果六义。因名乞士怖魔破恶。果号应供杀贼无生。释论净目问舍利弗。乞士者有四种食。合药种植田园。名下口食。仰观星宿名仰口食。四方巧语名方口食。咒术卜算四维口食。比丘不作此四。名清净乞士也。怖魔者。若发心出家。地行夜叉唱。飞行空中。展转乃至六天。魔王闻之。怖畏失人众也。破恶者。能破烦恼九十八使。悉皆破断。故名破恶。众者四人已上。乃至百千无量。一处羯磨作法行筹布萨。事理二和无有违诤。名和合众也。一有羞僧。持戒无违。二无羞僧。不持戒不别好恶。三无知僧。虽不破戒不别轻重。二人共诤不能判决默然无言。四真实僧。谓学无学人。今此二僧得共羯磨同闻证信。唯取无学人也。千二百五十人者。列数也。三迦叶兄弟有千弟子。优楼此云木瓜林。伽耶此云城。那提此云江。昔共起刹今连枝也。舍利弗名翻言珠子。亦云身子。姓拘栗陀。目犍连姓也。翻赞颂。亦莱茯根。或云胡豆。二人共有二百五十人。迦叶舍利弗等。先并事火。翻邪入正。艰苦累载。都无所获。一遇见佛便得上果。感佛恩深常随侍佛。为同闻众。菩萨位中有四。第一明位。第二列数。三万二千人。第三标名文殊。第四结为上首。天竺云摩诃菩提质帝萨埵。此云大道心成众生。文殊此云妙德。以法化人。名法王子也。二发起序者。诸经不同。或放光动地。微笑入禅自唱位号。劝人令问。今经正以杀父以为发起。何故举此逆事。为发起耶。为彰此界极恶令人厌弃。亲所生子犹尚危害。即欲令人同欣净土。下韦提希愿。为我说无忧恼处。不乐阎浮浊恶之世。就中为二。初尔时下正明杀父。次问守门人下。明欲害母。问频婆何故遣人说法。韦提何故如来自往。答父愿闻法。遣人传授为化义足。母求生净土。非佛不开。故须自往。频婆娑罗此云摸实。亦曰影坚。韦提希此云思惟。阿阇世此云未生怨。或婆罗留支。此云折指。内人将护名为善见也。初段为四。一频婆为子幽禁。二国太夫人密奉王食。以济王命。三漱口毕下。圣为说法以润王心。四如是时间下。明因食兼由闻法多日不死。初尔时王舍太子阿阇世者。当佛在王舍城时。未生怨者。未生之日相师占之。此儿生已定当害父。随顺调达恶友教者。调达此云天热。亦云天授。是斛饭王子。是佛堂弟阿难亲兄。阿难此翻欢喜。亦云无染。或云欣乐。调达有三十相。出家诵六万法聚。满十二韦陀。为利养故往诣佛所。求学神通。佛不为说。令观无常自可得道。复至舍利弗目连。乃至五百弟子所。皆不为说取通之法。阿难亲未得他心。授与通法。调达入山学得五通。心念谁作檀越。阇世太子有大王相。或自变身作象马宝。于王子前抱持歍嗽。复至天上取天华天食。语王子言。我作新佛汝作新王。岂不快耶。随顺恶友收执父王。调达破僧。舍利目连教化还合。推山压佛。密迹金刚以杵拟之。碎石迸来伤佛足指。华色比丘尼呵之。拳打眼出。作三逆罪。生入地狱。频婆往日毗富罗山游行猎鹿。空无所获。遇值一仙正坐。使人驱逐令去。遂敕杀之。临终恶念。愿我来生。还如今日心口害汝。如此等事皆是大士善权现化。行于非道通达佛道。众生根性不同。入道有异。一逆一顺。弘道益物。示行无间而无恼恚。阇王现逆为息恶人。令不起逆。二明夫人奉食。王食糗饮浆。求水嗽口合掌遥礼。请受八戒澡浴清净。三二圣为说法。目连是佛右面弟子。昔为辟支佛剃头作袈裟。愿得神通。授八戒者。不杀不盗。不淫不妄语。不饮酒不着华香。不观听伎乐。不上高床。此八是戒。不过中食是斋。毗昙不着香衣不上高床。同是庄严处。合为一也。富楼那。此云满愿子。亦满慈子。从父母得名。说法第一。巧开人心故偏遣之。四频婆因食闻法。遂得多日不死也。次害母中为四。一为子幽闭。二因禁请佛。三佛与弟子因请往赴。四见佛伤叹请法。初中又三。一欲害母。二二臣谏不听害。三敕内官幽闭。初阇世问守门者。王今在不。二守门者以事实答。三王闻嗔怒。名妇为贼。母为贼伴。即执利剑欲害其母。应杀守门人。而欲害母者。守门有辞。王先有敕。制诸群臣。不言妇女。沙门从空飞入。非我能禁。王虽贪国杀父。犹不违法。劫初已来一万八千。未闻无道害母。害母眼见何得言闻。谓不忍闻。世人传说不宜住此。欲奔他国。故云不住。有国已来。虽有刑罪不加女人。况所生母故不住也。以手按剑却行而退者。按剑现威以息王忿也。惊怖惶惧者畏惧也。耆婆此云固活。生时一手把药囊。一手把针筒。昔誓为医能治他病。从德立号。庵罗女子也。是国贤臣。贤臣去必国亡也。汝不为我者。耆婆重谏慎莫害母。忏悔求救前愆也。即便舍剑止不害母。敕语内官幽闭深宫。韦提希被幽闭下。第二请佛。谓请如来令遣弟子与己相见。文为二。初明请人。次明请法。韦提何故。请见目连及以阿难。目连是门师。阿难佛侍者。先恒教诫故偏求见。居在深宫不敢偏求。内厌恶界愿生净土。欲令二人传意请佛。悲泣雨泪望佛哀怜。遥向佛礼。前已礼竟。今复重礼。表己殷勤。世尊在耆阇下。如来现宫不异胜鬘。即生此念时。佛于空中现也。文为五。一神通。二色身。三坐座。四眷属。五雨华。知韦提希心念者。是知他心。从崛山没王官出。显神通也。问前频婆请弟子。意在如来。今夫人亦请弟子意在佛。何故前请遣弟子。今请自往耶。解有二义。一阇王与调达杀父。如来若躬赴。恐世王起怨嫌心。为护彼故不得自往。二者佛法寄在国王。频婆定死。阇世当为国主。如来若往者。王得国主佛法不行。故不得往。夫人无此诸事。如来自往。伤叹请法中有二意。韦提见佛下。正明请其生处。今向世尊下。明请往生之因。初明供养问往生因。次问生处也。我有何罪生此恶子。世尊复有何等因缘。与提婆达多而为眷属。此经不答余经说之。昔于锭光佛时。释迦为摩纳。就珍宝仙人学。学习既成念欲报恩。自惟贫乏。于时耶若达欲嫁女。时有须摩提求为女。婿聪明有智而形貌丑。摩纳遇见论义。须摩提屈在言下。耶若达欢喜。大赐珍宝以女妻之。摩提生忿发誓。未来世世常恼。为此因缘常触恼也。浊恶者。浊五浊也。一见。二烦恼。三众生。四命。五劫。恶者十恶也。杀盗淫妄语恶口两舌绮语贪嗔邪见也。三途地狱名泥犁。译云不可乐畜生云帝行。从主畜养。为人驱使食啖。饿鬼饥虚怯畏。三千刹土同有此恶。故曰盈满。多不善聚恶道因也。无人不起故名曰多。人常现行杀盗淫等。违理枉物为不善。积集称聚也。愿我未来。不闻恶声不见恶人。今向世尊五体投地。两肘两膝头顶。是为五体也。忏摩梵言。悔过汉语。彼此并举故云忏悔。将果验因。知过去有罪。恐偿未尽来更受。故须忏悔。惟愿佛日启告所求。佛能破坏众生痴闇。如日除昏。故言佛日教我观于清净业处。序文竟

尔时世尊放眉间光下。第二正说文为三。初明净业。次辩妙观。三利益。如来眉间有白毫相。犹如珂雪。长一丈五尺。毫有八楞。周围五寸。其毫中空右旋宛转。如琉璃筒。从此发光照无量国。还住佛顶变为金台。广现诸国。令韦提希乐生安养。初放光酬前请于生处。次世尊微笑下。酬前净业近答。思惟正受三种净业。散心思量名曰思惟。十六正观说名正受。就初有二。第一答其生处。惟愿下明见净土。更请净国之因。初放光普示诸土。次或有下示土差别。韦提下示生处。思惟是愿愿思是业。正问其因。正受者。非邪曰正领纳名受。即第二问。观行微笑中有二。初明三种净业答思惟。汝是凡夫下。次明十六妙观答正受。初业共凡夫。次共二乘。后是大乘不共之法。初净业中有三。第一明三种净业。告阿难下。第二叹其所问妙契佛心。从阿难汝当受持下。第三略付阿难令持获利也。就初复三。初明光照频婆获道。次世尊告韦提汝今知不下。举果劝修因。三欲生彼国者下。明往生之因也。何以不直答其土因。而复放光微笑耶解有二。初为次增道。次欲使王与夫人因光相见。王既睹光增道。知国非实。视死如眠。夫人见王无忧。观法成果也。微笑如释种被诛。如来光色益显。正以如来善达因缘。业报无差对至叵避。王虽应死而获道迹。夫人幽絷。即是现净土之缘。有此多缘所以致笑也。阿那含者。第三不还果也。去此不远者。安乐国土去此十万亿佛刹。一一刹恒沙世界。何言不远。解云。以佛力故欲见即见。又光中现土显于佛顶。一念能缘言不远也。第一孝养父母奉事师长。敬上接下慈心行也。修十善业是其止行。身除三邪口离四过。意断三恶也。第二三归者。佛法僧也。在家戒亦即是十戒。具足诸戒者。道俗备受。微细不犯。威仪者。三千悉皆不缺也。第三发菩提心。是愿起意趣向。名为发心。菩提是道。佛果圆通。说为菩提。读诵大乘明修解也。行能运通说之为乘。余二不及是言大也。佛告韦提。此三种业三世诸佛净业正因。是叹辞也。谛听谛听善思念之。谛听令生闻慧。善思思慧念之修慧。烦恼贼者。此能损慧命伤法身。故名为贼也。即得无生忍。是初住初地。仁王经说五忍。一伏二信三顺四无生五寂灭。初明韦提见土之由。次一问答。明为未来众生请见土之方法。汝是凡夫。彰其分齐不能远观。韦提实大菩萨。此会即得无生忍。示同在凡夫。心想羸劣未得天眼。不能远照见彼国土。有异方便令汝得见。异方便者。即十六观。非直观名方便。以佛力故见彼国者。亦是方便也。韦提白佛如我今者下。为佛灭后众生请也。浊者五浊。不善者十不善。五苦者。五道非乐故云五苦。或是五恶五痛五烧。五恶杀盗邪淫妄语饮酒如大经。现遭厄难王法刑罚。是五痛也。五烧即当来堕三途苦毒名五烧。云何当见阿弥陀极乐国土。正为启请。答中有十六观。一日观。二水观。三地观。四树观。五池观。六总观。观一切楼地池等。七华座观。八佛菩萨像观。九佛身观。十观音观。十一势至观。十二普往生观。十三杂明佛菩萨观。十四上品生观。十五中品生观。十六下品生观。就十六观分文为三。初六观观其依果。次七观观其正报。后三明三辈九品往生也

第一日观示令系心。佛告下。略明系念总劝修观。云何下。正明作日观。一切有目皆见。日没下。举所观境。当起想下。正教观察。是为下结也。教令正观为除疑心。大本所明。以疑惑心修诸功德。生彼国者。落在边地。复受胎生。故作此观令除疑惑也。障者。大本言。唯除五逆诽谤正法。故须作观。五逆重罪除六十劫生死罪等下辈自论

第二水观初作水想者。举所观境界。从见水澄清下。正起观行。是为水想下。结观也。一作水想。二变水成冰。三变冰为琉璃。四观琉璃以成大地内外映彻。地下宝柱承擎地上诸相庄严。以众宝间错其地。一一宝出杂色光明。光明成诸楼观。楼观两边有华幢。幢上多有乐器。宣说妙音也。八种清风者。彼处实无时节。若寄此八。谓除上下余四方四维。故云八。亦可用对八卦也

第三地观。文有四。一渐想观。从若得三昧下。第二实观。佛告下。明利益。作是观下。显观邪正。前水是想不能灭罪。地观是实。故能除断也

第四树观。文三。初明结前生后。次观宝树下。正明观行。是为下结。正观中有五。一明树体。二明庄严相。三明生法。四有大光明下。现佛国土。五见树茎叶下。结观也

第五池观。中有五。一明池体。二明池相。三明随心适意。四明利益。第五结观。摩尼者。如意珠也。八功德者。轻清冷软美不臭。饮时调适饮已无患。清是色入。不臭香入。轻冷软是触入。美是味入。调适无患是法入

第六总观中有四。众宝国土下。明总观。初宝楼。二树。三地。四池。观楼中初正观楼。次观上及虚空中。诸音乐声。结成观想名为粗见。从是为下。二结。从若见下。第三利益。作是观下。第四显观邪正

第七明佛身中有四。第一佛告下。敕听许说。第二从说是语时下。明佛现身相。第三从时韦提下。为未来请。第四佛告下。酬请广明佛身。五种观门。第一观华座。第二观像。第三观佛身。第四观观音。第五观势至。初华座中有五。一明成座法用并辩其相。二一一金色下。明能随机利物。三是为华想下结观。四阿难如此华下。明由愿力所成。五若欲念彼佛下。明观未来有利益

第八明像想中有三。初泛明诸佛法身自在从心想生。二是故应当下。遍观彼弥陀。并示观行。三作是观者下。明修观获利也。法界身者。报佛法性身也。众生心净法身自在。故言入众生心想中。如似白日升天影现百川。即是三十二相八十种好。明佛身自在。能随物现前。明佛菩萨此显能随也。又法界身是佛身。无所不遍法界为体。入一切众生心想中者。得此观佛三昧解入相应。故言入心想中也。是心作佛者。佛本是无心净故有。亦因此三昧。心终成作佛也。是心是佛者。向闻佛本是无心净故有。便谓条然有异。故言即是。心外无佛亦无佛之因也。始学名作。终成即是佛。若当现分别诸佛。法身与己同体。现观佛时心中现者。即是诸佛法身之体。名心是佛。望己当果由观生彼。名心作佛也。正遍知海从心想生者。以心净故诸佛即现。故云生也。亦因此观佛三昧出生作佛。多陀阿伽度。或明十号。无量名号等。此中略举三号。即如来应供正遍知。天竺三名相近。阿罗诃翻应供。阿罗汉翻无生。阿卢汉翻杀贼。令与修多罗合者。观行之时。令与教法相应。故言合也又解。与十二部经教合。入定是修多罗出定之时心与定合。故云与修多罗合也

第九观佛真法身中有五。一明结上。第二次当更观下。正观佛身。第三从作是观下。正明观于佛心。第四从作此观者舍身他世下。举利劝修。第五从作是观者下。显观邪正。观身大小。高六十万亿那由他恒河沙由旬。毫相如五须弥山。须弥山举高三百三十六万里。纵广亦尔。彼佛毫相过此五倍。眼如四大海水。准眼量以度身。身量太长。世人身长七尺者。眼长一寸余。四大海水。一海八万四千由旬。四海合三十三万六千由旬。身过其眼。五十六亿倍。假令极多无出万倍。何缘佛身得长六十万亿那由他恒河沙由旬。准眼定身。正六十万亿那由他由旬。言恒河沙者译人谬耳。眼见佛身即见佛心。身由心起故见身即见心。由见身心想转明。故得见佛心。佛心者大慈悲心是。以无缘慈普摄众生。释论云。慈有三种。一众生缘。无心攀缘一切众生。而于众生自然现益。如涅槃经。我实不往。慈善根力。能令众生见如斯事。二法缘者。无心观法。而于诸法自然普照。如日照物无所分别。三者无缘。无心观理。而于平等第一义中。自然安住。以无缘慈摄诸众生。辩佛心相也。念佛众生摄取不舍者。若为佛慈悲所护。终得离苦永得安乐。释论云。譬如鱼子母。若不念子则烂坏众生亦尔。佛若不念善根则坏。今明无缘慈者。诸佛所被谓心不住有无。不依三世。知缘不实。以众生不知故。实相智慧令众生得之。是为无缘也。舍身他世生诸佛前。以修念佛三昧故发见佛。愿生生常值。如人习巧从少至长所作遂妙。以随念佛三昧故。得生无量寿佛国。故般舟经云。众生问佛。何因缘得生此国。弥陀佛答。以修念佛三昧得生我国也。从一相好入但观眉问白毫者。如观佛三昧经云释迦如来眉间白毫者(云云)宝性论明。佛毫相在两眉间。阔三百六十万里。方圆亦然。故文云。无量寿佛身量无边。非是凡夫心力所及。正可取如释迦毫相大小现。观若得三昧观心成就。方可称彼佛相而观也。智度论云。为增长诸菩萨念佛三昧故。说般若波罗蜜经。今说般若现奇特身相光明色像遍至十方。以此为观也

第十观观音中有三。初结上。次复应观观世音菩萨下。正明观菩萨身也。第三作此观者。观之邪正也。观菩萨法身中有三。初观身相。冠中立化佛者。带果而行因也。第二明与佛同异。第三佛告阿难下。还举利劝修也。释迦毗楞伽翻能圣

第十一势至中有三。初明因光神力制二种名。次此菩萨天冠有五百宝下。明与观音同异。后除无量劫罪下。劝修。略无观法当不异上。故不重明。所以观佛。先作像想。后观法身菩萨。直明法身者。但佛法身妙极。不可一往而观。故先作像想流利。后观法身则易。菩萨者。观佛既竟。次二大士是眷属庄严。如王来即有营从。有佛必有菩萨也

第十二普观普杂何异而为二耶。普观作自身往想。称彼境界一一具观。杂观明佛菩萨神力自在转变非恒。大小不定。或随物现故名为杂。以此为别。普中有二。初从见此事时当起自心下。作自身往想次无量寿佛化身下。佛及菩萨化身来现也

第十三杂观有二。第一观丈六像。第二无量寿佛身量无边下。明弥陀变现自在。坚固行者。常令习观修行不倦。所观若大若小皆是佛身。拂去众疑生人重意。众云何疑。前闻广大无量。今闻观小。疑非佛身。于小不敬。故须拂去。明皆是佛生其重意。但观手相者。有作头首解者。上言观音头上。天冠中有一立化佛。势至头上有宝瓶。以此为别。作手解者。上云其手柔软。有八万四千画。以此宝手接引众生。皆是经文用无在也

第十四上品生观。此下三观。观往生人者有二义。一为令识三品往生。舍于中下。修习上品。二为令识位之上中下。即是大本中三品也。释会经论者。问依往生论。二乘不得生。此经中辈小乘得生。答正处小行不生。要由垂终发大乘种尔乃得生。经说现今。论举本始。何故复证小果。释虽复垂终发大心。先多学小。至彼闻苦空无常。发其本解。先证小果。得小果已。于小不住。必还入大。问论女人根缺不生。此经韦提希及五百侍女。同皆往生。释言。论说女人根缺不生者。就彼为言。生彼国者净根离欲故。无女人身根精上故。无根缺经语初往故。有善心一切得往。问大本五逆谤法不得生。此经逆罪得生。释有两义。约人造罪有上有下。上根者。如世王造逆。必有重悔。令罪消薄。容使得生。下根人造逆。多无重悔故不得生。二者约行。行有定散。观佛三昧名定。修余善业说以为散。散善力微。不能灭除五逆。不得往生。大本就此故言不生。此经明观故说得生。就三品中更为九。上品之人。始从习种。终至解行菩萨。中品者。从外凡十信已下。下品即是今时悠悠凡夫。何以得知。上品见佛闻法便悟无生故。是道种人。下品备造四重众罪亦得往生。类此似尔。上品位当道种。中品位当性种。下品位当习种。一得道有迟疾。二所乘有异。初则金刚台。中紫金台。下金莲华。就初中文为三。第一标。第二若有众生愿生彼国下。正释。第三从是名下结。释中复四。初明修因。第二从生彼国时下。明值缘。第三从行者见已下。正明得生。第四从生彼国下。生后利益。至诚心者。即实行众生。至之言专。诚之言实。深者。佛果深高以心往求故云深心。亦从深理生。亦从厚乐善根生。故十地经言。入深广心。涅槃经云。根深难拔故言深心。六念者。佛法僧施戒天。六事安心不动。称之为念也。无生忍言登初地也。陀罗尼者。一能特善。二能遮恶。是总持也。上品中生者有三。第一标。第二释。第三结。释中有四。初往生因。第二行此下。明值缘。第三行者自见下。得生。第四行者身作紫磨金色下。往生利益。甚深第一义者。谓诸法实相。言语道绝心行处灭。名之深妙。精进最称第一。阿耨不退转者。谓道种菩提。亦通是道种地不退位。现前受记者。四种受记一往现前也。上品下生中有三。初标。第二亦信因果下释。第三是名下结。释中有四。第一明往生之因。第二行者命欲终时下。值缘。第三见此事时下。得生。第四一日一夜下。生后利益。得百法明门者。地论云。入百法明门。增长智慧思惟种种法门义故。欢喜地者初证圣处多生欢喜也

第十五中品生观。中品上生者有三。第一标。第二从若有众生下释。第三从是名下结。释中有四。初明生因。第二从临命终时阿弥陀佛下。值缘。第三从行者见已下。得生。第四从当华敷时下。明生后利益。五戒者。不杀盗淫妄语饮酒也。八戒者。加不上高床。不着华鬘璎珞香涂身熏衣。不得歌舞作乐及往观听也。四谛者。苦集灭道也。罗汉者。应共不生杀贼也。三明者。过现未来明也。六神通者。天眼天耳他心宿命漏尽。身得如意。此六悉皆无壅故为通。八解脱者。一内有色相外观色。二者内无色相外观色。三者净。四空处。五识处。六无所有处。七非非想处。八灭尽解脱也。此八中前三种微妙五欲无染无著。中四于下得离。后一能脱心虑故名解脱。亦名背舍。背者背彼净洁五欲也。舍者离是着心也。释会者。论明小乘不生者。决定不生。此中明生。退菩提心得生。至彼处无漏道熟。即证第四果。大论亦然。或接引小乘。然彼实无。中品应时即得罗汉。何以不及九品。解云。是退菩提声闻往生彼国。无漏道熟。便证小果不守小位。而往还起大心进行弥速。或五劫或十劫得成初地。如是阶级犹是其胜。大本。上品明其出家。中品不明出家。此中所明是则中品。若其不出家。经云一日一夜持沙弥戒故知有也。而大本不明据长时始终为语。今言出家者。就短时而论。中品中生者有三。初标。第二从若有众生下释。第三是名下结。就释中有四。初明生因。第二从如此行者下。明值缘。第三从行者自见下。明得生。第四在宝池中下。明生后利益也。十戒者。即前八戒。更足不捉金银生像。及不过中食。为十戒也。具足戒者。二百五十戒。五百戒等。须陀洹者。翻修习无漏。或逆流也。中品下生者有三。初标。第二从若有下释。第三是名下结。释中有四。初明因。第二此人命终时下。明缘。第三从闻此事下。得生。第四从经七日下。生后利益也

第十六下品生观。下品上生者有三。初标。第二从或有众生下释。第三从是名下结。释中有四。初明因。第二从尔时彼佛下。明缘。第三从作是语下。明得生。第四经七七日下。明生后利益也。下品中生者有三。一标。二释。三结。释中有四。初明因。第二从吹诸天华下。明缘。第三从如一念顷下。明得生。第四从经六劫下。明生后获利也。下品下生有三。初标。二释。三结。释中有四。初明因。第二从见金莲华下。明缘。第三从如一念顷下。明得生。第四从于莲华中下。明获利。称无量寿佛至于十念者。善心相续至于十念。或一念成就即得往生。以念佛除灭罪障故。即以念佛为胜缘也。若不如此者。云何得往生也。问云何行者。以少时心力。而能胜于终身造恶耶。大论有此责。是心虽少时。而力猛利。如垂死之人必知不免。谛心决断胜百年愿力。是心名为大心。以舍身事急故。如人入阵不惜身命。名为健人也。第二利益中有二。初明夫人道悟无生。二明侍女发心也

第三流通亦二。第一明王宫流通。第二尔时世尊足步下。明崛山流通初有四。一列名教持。二行此下。明修有益劝人奉信。三告阿难下。付嘱令持。四说此下。目连等闻欢喜。初中阿难先问。发当何名下。问经名字。上来所说言义非一。当于何义而名此经。此法之要云何受持。问受持法。佛答。名观极乐无量寿佛观音势至。亦名净业生诸佛前。对其初问。汝当受持无令忘失。对其后问。次明有益行。前十六观门得大利益。现身得见彼佛菩萨。善男子善女人闻名下。明其念佛菩萨之益。但得闻名除无量罪。何况忆念。明念佛菩萨有大利益。举劣况胜。念佛者人中分陀利华。明其身胜。观音势至为胜友伴胜。当坐道场。得道之场名曰道场。菩提树下得道故名为坐。依之得果。义说为坐。依之起行。名生佛家也。结名付嘱。亦名观无量寿佛。亦名灭除业障也。欢喜者。三义故喜。一能说人清净。佛无碍智无有错谬。名为清净。二所说法清净。能令众生得证三昧。三依法所得果清净。依法修行满足身证清净果也。耆山流通中。初佛步空还耆阇崛山。为增物敬。奉顺其言。故现此变。次阿难及天龙等。闻法欢喜。作礼而去也

佛说观无量寿佛经疏终


佛说金刚般若波罗蜜经略疏

    No. 1704 [cf. No. 236]

佛说金刚般若波罗蜜经略疏卷上

        唐至相寺沙门智俨述

将欲释文先于文首作五门分别。一明教兴所由。二明藏摄分齐。三明教下所诠宗趣及能诠教体。四释经题目。五分文解释

初教兴所由者金刚般若波罗蜜经者盖是实智之美称。真德之通号。宗本冲寂神凝湛一。独曜幽原圆明等觉。含晖至朗而泯于分别。冥津玄旷而隐于缘数。斯乃可谓众生之本际涅槃之圆旨。因缘之实性法界之说府是知真性虚融。斯无不在一言。无所不摄殊说。更无异盈但为圣化随机明教门非一。为进初心菩萨爰引根熟声闻。遂分张别分以成空文坚固之教矣

第二藏摄分齐者有三。一约一乘二约三乘三约自部种类。此经所为名同小乘。所有法门主伴不具。所述文义唯局一法。唯说理门遂其解行。以此为验非即一乘。若从所流皆依一起。第二约三乘辨者有二。第一所诠三故藏即为三。第二所为二故藏即为二。所诠三者一谓定学是修多罗藏所诠。二谓戒学是毗那耶藏所诠。三谓慧学是阿毗达摩藏所诠。此经是修多罗藏所摄。第二门者一小乘藏二大乘藏。亦言二乘及以三乘。云三乘者有二义。一约根辨三人同依一法故。二约法辨对三人所轨故。此经即是大乘三藏所摄也。第三自部种类相摄者。般若经依梵本三十万偈译成六百卷。总作十六会说处别有四。前六会同王舍城鹫峰山说次三会同在室罗筏誓多林给孤独园说。次一会他化自在天说。次四会还同前誓多林说。次一会同前鹫峰山说。次一会在王舍城竹林园白鹭池侧。说此金刚般若经当第九会说。梵本有三百偈今成一卷。亦无别品。若准说经依处之义理亦不同。初依处者王舍城说举教自在敌非显德义静相胜故也。第二处者表显化生分齐临机济危拔苦之相也。第三处者显处校量明教尊胜覆荫决定故也。第四处者显教自在防非显德众义建立。亮神之所津润之状相也

第三教下所诠宗趣及能诠教体者有二。一总明宗趣。此经即用三种般若。一实相般若二观照般若三文字般若。所以知者为下经文具明理行及教三义故。第二别明宗趣者有五义。第一教义相对用教为宗以义为趣。第二因果相对以因为宗用果为趣。为下文中所住及修行并调伏并约成因行义故。第三人法相对者用法为宗以人为趣为依法成佛故。第四理事相对者以理为宗用事为趣。第五境行相对以境为宗以行为趣立境教欲成其行故也。第二能诠教体者若约一乘以唯识真如为体。不可以分别智知故。若约三乘有二义一同小乘教二同一乘教。具如经论

第四释经题目者

佛说金刚般若波罗蜜经　元魏三藏留支译　(音释)琳音云。正梵音嚩折罗此翻云金刚。般若。般本梵音云钵啰(二合)啰取罗字上声兼转舌。其二合者两字各取半音合为一声。古云般者讹略也。若(而者反)正梵音枳(音鸡以反)娘(取上声二合)合为一声(守护国界经咒云枳娘唐言智慧或云正了知)古云若略也。波罗蜜。波正梵音应云播(波个反引声)罗正梵音应云啰(取罗上声转舌呼之)蜜多正云弭多(弭迷以反)具足应言嚩折啰钵啰(二合)枳娘(二合)播(二)罗弭多素怛缆

佛者此既三乘教故佛是化身佛。说者陈章吐教故名说也。又化佛不说法身授与说也。金刚等者从喻名也。智难坏故喻金刚也。般若等者西域语也。此云实智。般若即智。波罗即彼岸也。所言蜜者此云到也。真照之慧穷源实相性出无染义显终极迹绝有海。故云智彼岸到也。所言经者真净之教文诠理纬。显用行心训仪常则谓之为经

第五分文解释者经文有三。初序分二正宗三流通。序有二种。一证信序二发起序。初证信序兴所由者阿[少/兔]楼驮教彼阿难问其未来四法。一问经首安何字。二问未来以何为师用戒为师。三问未来弟子依何而住依四念处住。第四恶性人云何共住以梵坛治之。又约佛序及弟子序现在序未来序等。思以准之不劳繁解

如是我闻一时婆伽婆在舍婆提城祇树给孤独园与大比丘众千二百五十人俱　序经文有六句。一如是者大论云信顺譬信于实法顺而敬举也。二我闻。三一时。此有三义。一平等时谓无沉浮颠倒。二相应时谓今闻能闻正闻。三转法轮时谓正说正受。四佛婆伽婆此有多义。即身口意满等也。五住处。六同闻众。辨所为机及同闻影响众。又释前之二文局在证信。后之四句义通发起。问所以无菩萨众者。答般若坚固甚深难识。若影响徒众及所为机通菩萨者回心。声闻及凡夫等于斯绝分。为欲引下故略不明。就其第二发起序中大分有二。初佛世尊讫乞食缘为前方便。二尔时诸比丘下正时集众以显发起

尔时世尊食时着衣持钵入舍婆提大城乞食于其城中次第乞食已还至本处饭食讫收衣钵洗足已如常敷座结跏趺坐端身而住正念不动　初文有四。初严仪乞食。即为行始。二于其城中下。还归本处。显行终。三饭食讫下。为显法方便。四结跏趺下。显定依止

尔时诸比丘来诣佛所到已顶礼佛足右绕三匝退坐一面尔时慧命须菩提在大众中即从座起偏袒右肩右膝着地向佛合掌恭敬而立白佛言希有世尊如来应供正遍知善护念诸菩萨善付嘱诸菩萨世尊云何菩萨大乘中发阿耨多罗三藐三菩提心应云何住云何修行云何降伏其心　第二文中有四。初正时集众。二尔时慧命已下。为请法方便。三白佛希有下。赞佛具德。四世尊云何下。正明请问。以显发起。此问有四。初一总显发心之相。二问所住之理。即显问实相般若。三问能修行。即问观照般若。四问降伏心。即调伏方便。即问文字般若。下答准之。就第二正宗文中大分有三。初赞问善哉。诫众略说。即为立义分。二佛告须菩提诸菩萨下。广辨般若体相。即为解释分。三须菩提菩萨发阿耨多罗已下。结说究竟分

尔时佛告须菩提善哉善哉须菩提如汝所说如来善护念诸菩萨善付嘱诸菩萨汝今谛听当为汝说如菩萨大乘中发阿耨多罗三藐三菩提心应如是住如是修行如是降伏其心须菩提白佛言世尊如是愿乐欲闻　就初立义分内大分有五。初赞问善哉。二即彼赞说者具德。天亲论云。善护念者。约根熟菩萨。护成自他德。善付嘱者。约根未熟菩萨。未成成已究竟。由善付嘱胜能故也。三诫听许说。四略举四义以答上问。五须菩提白佛下。显其善欲起后广说。今明大乘中发菩提心者略有十义。一求佛果尽。二显法界尽。三明修行尽。四明断三种障尽。五度众生尽。六求善知识尽。七成其善愿尽。八顿发位尽。九善应因果尽。十自在摄成诸功相入等尽。所言应如是住者。即实相般若。明法界真如。本觉寂静。离念明慧。无分别智之所显现。一得不退。名之为住。言如是修行者。显修成正智。正助圆满应业行心。名为修行。言如是降伏其心者。凡夫心识。虚妄纵荡。轮转长时。今依方便。调令应法。故名降伏也。就第二解释分大分有二。初约解心显三种般若。二尔时须菩提白佛言乃至云何住云何修行下。约其行事辨三种般若。又前解者。即约正说法身。又后证行者。即约正证法身。此可思准之。就初解文大分有二。初显解三种般若体德分量。二尔时须菩提白佛言世尊当何名此法门下。举行显解。明解非妄。就初文中大分有二。初明显解般若离妄坚固。二复次佛告慧命须菩提下。释其余疑辨解决定。就初文中大分有二。初约众生界等以答上问。即决四疑。谓上菩提心所住修行降伏等。即三般若体。第二须菩提于意云何东方虚空可思量不下。明般若德用。就初文中大分有四。初约众生发心。即有四义。一广大。二我皆令入下。即第一也。三如是灭度无量下。即常也。四何以故须菩提若菩萨有众生相下。明其心不颠倒。所以发此四心。为显深心功德满足故。即广上第一总发菩提心。问何以偏约众生者。答显舍自爱。生众生爱。慈悲大顺。翻彼二乘及凡夫见宜便故也

佛告须菩提诸菩萨生如是心所有一切众生众生所摄若卵生若胎生若湿生若化生若有色若无色若有想若无想若非有想非无想所有众生界众生所摄　初广大文大分有六。初一句总。二约四生明摄法分齐。三约色无色显界周尽。四约想有无以决外疑。五若非有想下。除外道增上慢见。为外道将非想为非生死故。六会彼妄见。摄从正智境。谓所有众生界众生所摄者。即无众生及似众生所摄也。问所以言似者。答经云不可以似似。故云似也。故似不妨无。问若尔众生即空。何所摄也。答只为是是空空。即众生分别所摄。故辨摄。若不彰摄。解不明净故也

我皆令入无余涅槃而灭度之　二第一文。无余涅槃者。即无分别余也。即性净涅槃也。若约一乘。即三世常涅槃。亦三世常觉。若约三乘。即一世智得三世常涅槃。及应化二身是有余。法身是无余。又报身在烦恼灭。是有余。惑断报身灭。是无余。若约小乘。唯约报身是无无余。烦恼先灭是有余。于此一义之中。约智数断惑。诸宗不同。与分别相应。不灭心见。有此差别也。下可准。今此经宗。唯拣小乘。义局大乘及一乘义也

如是灭度无量无边众生实无众生得灭度者　第三常文

何以故须菩提若菩萨有众生相即非菩萨何以故非须菩提若菩萨起众生相人相寿者相则不名菩萨　就第四不颠倒文有其四句。初何以故。责生同无不度所由。第二答文。显知者是正。三复重责。若不知无众生之者。即不顺法相。显不知者失。第四答意。顺此可知

复次须菩提菩萨不住于事行于布施无所住行于布施不住色布施不住声香味触法布施　第二广上如是住有二。一由法性无住。绝于自他相想。平等究竟。二由自性体寂。绝于为非故。于文间亦有两句。一对于事显知住法即假尘境。二不住色下。约实尘以显住义

须菩提菩萨应如是布施不住于相想　第三广上如是修行文有三句。所以可知。问不住相想。二义何别。答所知分齐。不依分别住。名不住相。能知之心。不依分别取。名不住想。余可准之

何以故若菩萨不住相布施其福德聚不可思量　第四广上降伏其心文即用不住于事已下所离分别取心不生。即名降伏。问何故及修行等。偏约檀度明之。答檀是菩萨起行之初首。若此一净余度易明。又檀度之中。得摄于六。故天亲论云。檀度摄于六。资生无畏法。此中一二三。名为修行住。广解如论。为此义故也。就第二德用文中。大分有四。初于意云何东方虚空可思量不等。明三种般若德用分量。二须菩提可以相成就下。明德用离相。三须菩提白佛言世尊已下。显三种般若德用功能。四须菩提是诸菩萨生如是无量福德聚已下。显三种般若甚深。问云何得知此文等中有三种般若。为论解云。檀等是法性所彰。又从法异流。即知是实相般若。檀度等中有修得无分别智。即是观照般若。为下文菩萨菩萨论主解云。初菩萨者是圣菩萨。第二菩萨者。是凡夫菩萨。即知凡夫菩萨中有其两义。一凡夫菩萨与圣为诠。即是教智。第二凡夫菩萨由未证法身。但依教生智。利生受记。亦依教智。故是文字般若。此之三相。无二无别。自性离故。言实性者。性本空寂。有佛无佛。体相常住。不迁不变。无作无起。不来不去。不动不转。但因缘有。犹若虚空故经云三界虚妄。唯一心作。十二因缘。是皆一心。无有作者。无有知者。一切诸法随心转故。是以即斯而言。虽复克勤备修。积德云兴而无增。息累尘境。浮冥至寂而无减。然依本来无始世界熏修对治因缘行故。说离烦恼妄想。深心清净转胜。圣若现前。无为缘集。菩提涅槃。妙果圆极。功显于此。故经言。观一切法。不生不灭。因缘而有。顺如能善达斯趣者。生死尘累不待遣而自亡。涅槃真证不假饰而圆备。功显自本。无有作者。惑非我除。净非我莹。德穷常乐。不迁不变。观照文字。义亦同然。何以故。无二无别故。此可思准之

须菩提于汝意云何东方虚空可思量不须菩提言不也世尊佛言如是须菩提南西北方四维上下虚空可思量不须菩提言不也世尊佛言如是如是须菩提菩萨无住相布施福德聚亦复如是不可思量佛复告须菩提菩萨但应如是行于布施　就初分量文中。大分有二。初喻。次合。喻文展转有四句可知。合文有三句可知。问此法以何义相。合前虚空。答此举三种般若无分别故。取相不及。以为分齐。合前虚空也

须菩提于意云何可以相成就见如来不须菩提言不也世尊不可以相成就得见如来何以故如来所说相即非相佛告须菩提凡所有相皆是妄语若见诸相非相则非妄语如是诸相非相则见如来　第二德用离相文中有七句。初审定可否。二答成离相。三何以故下。责离相所由。四述真法体。五显相是妄。六翻妄成真。七印成大顺。令离妄相者。谓生住灭摄一切法尽。论解如此。问何故此义约佛明之。答此举果德净义显初信心是便。又因中障习未尽。显离相难彰故也

须菩提白佛言世尊颇有众生于未来世末世得闻如是修多罗章句生实相不佛告须菩提莫作是说颇有众生于未来世末世得闻如是修多罗章句生实相不佛复告须菩提有未来世末世有菩萨摩诃萨法欲灭时有持戒修福德智慧者于此修多罗章句能生信心以此为实佛复告须菩提当知彼菩萨摩诃萨非于一佛二佛三四五佛所修行供养非于一佛二佛三四五佛所而种善根佛复告须菩提已于无量百千万诸佛所修行供养无量百千万诸佛所种诸善根闻是修多罗乃至一念能生净信须菩提如来悉知是诸众生如来悉见是诸众生　就第三德用胜能文中。大分有五。第一疑问。第二佛呵而不受。三佛复告须菩提有已下。述其正德。四佛复告须菩提已下。赞其胜德。五须菩提如来悉知已下。显用成就。第三文中有二句。一略二广可知。第四文中有五句可知。今言净信者。信心有三种。一者直心。正念真如法界故。二者深心。乐集一切诸善行故。三者大悲心。欲拔一切众生苦故。真如信者。成通三昧。不住见相。不住得相。乃至出定。亦无懈慢。所有烦恼。惭觉微薄也。余义可知。第五文中如来悉知者。在于比观之内。与知识力相应。非谓有其别佛为能知者。如来悉知者。在证知心中。现知识力智相也。问何故上文已来数言如来之名。及告须菩提即言佛者何也。答如告须菩提。即显佛是化主。得觉胜法故。若立义中言如来者。欲显理事等法。无不是如。皆从实道现成如相。故作此说也。就大段第四文显法深内有三。一举德用之体。二何以故下。释成深相。三须菩提若是菩萨有法相下。显比观德用分齐

须菩提是诸菩萨生如是无量福德聚取如是无量福德　初言生如是无量福德聚取如是无量福德者。如是无量深福德聚。一者因深。檀等无分别故。二者果深。如来等离相故

何以故须菩提是诸菩萨无复我相众生相人相寿者相须菩提是诸菩萨无法相亦非无法相无相亦非无相何以故须菩提是诸菩萨若取法相则为着我人众生寿者　就第二文中有四句。一何以故。责离相所由。二答成离相义。所言离相者有八重。一我相。二众生相。三人相。四寿者相。此四有二义。若约正使。即是声闻障。此中二障。并通我及我所。若约习气。则是菩萨障。若至下文。亦有同异。应可准之。第五是有法相。六无法相。七有相。八无相。此四并是菩萨障。此义云何。解心初起。见有法相为所轨则。应分别妄。为离此相。故言无法相也。学者不了。即谓无法以为所轨。论云。呵此为空说。为离此妄故。彼恶世时。菩萨具足持戒智慧故。能生信心。名不空说。故文言亦非无法相也。学者不了。谓离所见有无法相。别有波罗蜜以为实相。为离此妄谓。故言无相也。学者不了。即谓离有无相外。无有实相。为离此见。故文言亦非无相也。三何以故须菩提下重责离八相所由。四是诸菩萨下。答须离所以

须菩提若是菩萨有法相即着我相人相众生相寿者相何以故须菩提不应取法非不取法以是义故如来常说筏喻法门是法应舍非舍法故　就第三文中有五句。初总明离妄方便。二何以故。责成方便离相所由。第三一句。显相二仪得成方便。第四一句。举喻以况。第五一句。述成方便法也。凡论筏喻。有两义取舍。初依筏时取。二至岸离筏故舍。第二依筏未显用故舍。若至彼岸用彰显故取。法合即以此准之也。上来文中我相等四种者。一者我相。见五阴差别。一一阴中妄取是我。众生相者。见身相续不断相也。命相者。一报命根不断住故。亦云人相。寿者相者。命根断灭复生。受六道故也。就第二释余疑中。大分有四。第一正释余疑。第二须菩提于意云何须陀洹已下。泯相入实。第三佛言须菩提如恒河中已下。校量其德。第四复次须菩提随所有处已下。显德殊胜。就初文中。大分有二。初正释余疑。二须菩提于意云何已下。校量会除前疑功德

复次佛告慧命须菩提须菩提于意云何如来得阿耨多罗三藐三菩提耶如来有所说法耶须菩提言如我解佛所说义无有定法如来得阿耨多罗三藐三菩提亦无有定法如来可说何以故如来所说法皆不可取不可说非法非非法何以故一切圣人皆以无为法得名　就初文中。大分有五。初总告须菩提审定其相有二可知。二须菩提言已下。答显其义有二可知。三何以故已下。问答现实有二可知。四非法非非法已下。正显其相。五何以故已下以法成人。并去疑情。有二可知。文中所言非法非非法者。依真如义说。非法者。一切法无体相故。非非法者。彼真如无我相实有故。所以文中无有定法如来可说者。但有说即能诠故。故论云。应化非真佛。亦非说法者。说法不二取。无说离言相。此偈显化身不证阿耨菩提。文言无有定法者。据化身为语。说法不可取者。即依真如为言。文中所以道一切圣人皆以无为法为名。非独佛者。欲显一切皆有如令清净故也

须菩提于意云何若满三千大千世界七宝以用布施须菩提于意云何是善男子善女人所得福德宁为多不须菩提言甚多婆伽婆甚多修伽陀彼善男子善女人得福甚多何以故世尊是福德聚即非福德聚是故如来说福德聚福德聚　就第二校量除疑德内有二。初约其义显德无量。并会初疑。二佛言须菩提若善男子善女人已下。显其教胜功德无量。即会前第二疑。法虽不可取不可说。而德不空故。故论云。受持法及说。不空于福德。福不趣菩提。二能趣菩提。此偈演何义。受持及演说。二能趣菩提。少一即不成。文言福德聚者。有二种聚。一者积聚义。即自分德。二者进趣义。则他分德。积聚之义是自分故。不能独得菩提。云何福德聚。第二进趣义。摄前积聚能至大菩提故。文云如来说福德聚福德聚。初福德聚。是积聚福德聚。次福德聚。是进趣福德聚。初云世尊是福德聚者。即单一福德聚。就初文中有二。初举布施事校量。文有三可知。二彼善男子善女人已下。正校量显胜。此文有四可知。文云得福甚多者。具二福德聚。故甚多也。文云何以故者。责须具足所以也。问此中明解。何故举行显德。答欲令解行故。而又举行。令人解行

佛言须菩提若善男子善女人以满三千大千世界七宝持用布施若复有人于此经中受持乃至四句偈等为他人说其福胜彼无量不可数何以故须菩提一切诸佛阿耨多罗三藐三菩提法皆从此经出一切诸佛如来皆从此经生须菩提所谓佛法佛法者即非佛法是名佛法　就第二显教功德中。大分有四。初略举施事。即为能校量。二若复有人于此经中已下。正明校量。此文有二可知。三何以故已下。除疑显德。此文有四可知。四须菩提所谓佛法已下。述成其义。文言皆从此经出者。法身菩提出在此经。此教即为了因。报身菩提及化菩提。此教为生因。故言皆从此经出。文言所谓佛法者。述正佛法。分别不得。故云非佛法。非彼余人分别之佛法。唯独诸佛法。第一不共义。以与第一法为因。故福德多不可校量也。就大段第二泯相入实中。大分有二。初泯小乘行位以从实法。二佛告须菩提于意云何如来昔在已下。会大乘行位以从实法。就初文中有二。初会其小位。二以须菩提实无所行已下。会其行相以显实

须菩提于意云何须陀洹能作是念我得须陀洹果不须菩提言不也世尊何以故实无有法名须陀洹不入色声香味触法是名须陀洹佛言须菩提于意云何斯陀含能作是念我得斯陀含果不须菩提言不也世尊何以故实无有法名斯陀含是名斯陀含须菩提于意云何阿那含能作是念我得阿那含果不须菩提言不也世尊何以故实无有法名阿那含是名阿那含　就初文中。须陀洹等四位。即为四段。前三果各分有五可知

须菩提于意云何阿罗汉能作是念我得阿罗汉果不须菩提言不也世尊何以故实无有法名阿罗汉世尊若阿罗汉作是念我得阿罗汉即为着我人众生寿者世尊佛说我得无诤三昧最为第一世尊说我是离欲阿罗汉世尊我不作是念我是离欲阿罗汉世尊我若作是念我得阿罗汉世尊则不记我无诤行第一　就阿罗汉文中。大分有七。初审定其法。二答。三何以故责。四显其实法。五反以显过。六顺成其德。此文有三可知。七有一句。反述已结成所以。此位皆得从实。由佛所说皆以无为法为名故。由圣人无为故。不取六尘境界以为我所。故文言不入色声香味触法也。入之言得耳。言须陀洹者。此云逆流。逆分段生死流故。斯陀含者。此云住薄。住薄烦恼故。阿那含者。此云不还。不还欲界故。阿罗汉者。此云不受。不受三界故。文言作是念我得阿罗汉即为着我人众生寿者。此有二种义。一者正使。二者习气。若在观中。习气亦不生。若在观外。正使心必不起。故言实无有法名须陀洹等。寻此文相。正意少隐。欲覆法我名。引声闻人以我人从其一实大乘。摄彼法执分别入习气我人。是文中意。若摄人习属法执一观俗引得声闻同一乘也。少得相应。所以知者。于彼证离取我等烦恼。是故无如是心我能得果。若是正使。观外亦不起。何须说观中。以此故知无诤行。亦准正习二门取之。又四果人等。各皆自分离粗烦恼。是自境界无有分别。即是实性三般若。若余分别。即非圣意。名增减执。此可思准

以须菩提实无所行而名须菩提无诤无诤行　就第二会大乘行位中。大分有二。初会大乘得法之始位。二佛告须菩提若菩萨作是言已下。会其行法

佛告须菩提于意云何如来昔在然灯佛所得阿耨多罗三藐三菩提法不须菩提言不也世尊如来在然灯佛所于法实无所得阿耨多罗三藐三菩提　初文有三可知。所以须会者。为于然灯佛所言语所说不取证法。今以证知不可说不可取。真实之义成无取说故也。就第二会行文中。大分有二。初会依报土因行。二须菩提譬如有人已下。会正报行

佛告须菩提若菩萨作是言我庄严佛国土彼菩萨不实语何以故须菩提如来所说庄严佛土者则非庄严是名庄严佛土是故须菩提诸菩萨摩诃萨应如是生清净心而无所住不住色生心不住声香味触法生心应无所住而生其心　就依报中。大分有四。初总举显过。二何以故已下。责成过所以。三须菩提如来所说庄严佛土者。答即对过显真。四是故须菩提诸菩萨已下。观成实相。此文有四。初第一成实相心。二而无所住者。显心相。三不住色生心。对过显真。四应无所住。述成正义。此净土等。真实智成。故不可取。若言可取。彼不实说。文言即非庄严是名庄严佛土者。第一义相土非形相。及第一并是庄严成。非有为形相也

须菩提譬如有人身如须弥山王须菩提于意云何是身为大不须菩提言甚大世尊何以故佛说非身是名大身彼身非身是名大身　就第二会正报行中。有五段经。初举事以况。第二审定可不。三须菩提答。四问答显正义。第五述结。文言须弥山王大者。势高远故名为大。而无所取我是山王。以无分别。佛亦如是。无上法王无分别故。佛说非身是名大身。以无分别相故。彼身非身。非诸漏身。是名大身者。以有清净身故。就第三校量显德中。大分有二。初举多功德为能校量。二佛告须菩提已下。正校量显德。就初文中有二。初成多功德因缘。二佛言须菩提我今实言告汝已下。显多功德

佛言须菩提如恒河中所有沙数如是沙等恒河于意云何是诸恒河沙宁为多不须菩提言甚多世尊但诸恒河尚多无数何况其沙佛言须菩提我今实言告汝若有善男子善女人以七宝满尔所恒河沙数世界以施诸佛如来须菩提于意云何彼善男子善女人得福多不须菩提言甚多世尊彼善男子善女人得福甚多佛告须菩提以七宝满尔所恒河沙世界持用布施若善男子善女人于此法门乃至受持四句偈等为他人说而此福德胜前福德无量阿僧祇　前文有四句。后文有五句。可知。问此门校量。与前除疑后校量何别。论自分云。前说三千大千譬喻。明福德多。今重说无量三千世界。倍多前故。所以倍前者。为渐化众生。令生深信故。又前释疑。未泯诸相。故少校量。今此泯相。得大菩提。功德胜故。大校量也

复次须菩提随所有处说是法门乃至四句偈等当知此处一切世间天人阿修罗皆应供养如佛塔庙何况有人尽能受持读诵此经须菩提当知是人成就最上第一希有之法若是经典所在之处则为有佛若尊重似佛　就第四显德殊胜文中。大分有二。初有三句。以少彰多。显德殊胜。二须菩提当知已下。就多功德。以明殊胜。此中胜有二种胜。一所说处胜。随何等处说此经。令生奇特尊重想故。二能说人胜。能受持及说故人胜。又所以二俱胜者。彼珍宝施。是染烦恼因。能生烦恼事。今此二胜。离烦恼因。故说胜也。就大段第二约其行事显三般若证前解实文。大分有二。初广显行。二须菩提以要言之已下。以略显广。就初文大分有二。初第一总举行体。显解是实。以发信心。二尔时须菩提闻说是经涕泪悲泣已下。明信行相。初文有二。初陈问。二疑二相。佛告须菩提已下。答其二相。答文有二。初举法门名。以詶第一问。二以是名字下。詶上第二问。就此文中。大分有四。初有三句。总举行体。二须菩提于意云何三千大千已下。显德分量。三佛告须菩提于意云何已下。显行德离相。四佛言须菩提若有善男子已下。校量显德

尔时须菩提白佛言世尊当何名此法门我等云何奉持佛告须菩提是法门名为金刚般若波罗蜜以是名字汝当奉持何以故须菩提佛说般若波罗蜜则非般若波罗蜜　初三句者。初总举法门名以劝持。二何以故。责。三佛说般若波罗蜜已下。答成行相。此文有三可知。于中即非般若波罗蜜者。非有为檀等故。此无为波罗蜜。能成大菩提故

须菩提于意云何如来有所说法不须菩提言世尊如来无所说法须菩提于意云何三千大千世界所有微尘是为多不须菩提言彼微尘甚多世尊须菩提是诸微尘如来说非微尘是名微尘如来说世界非世界是名世界　就第二显德分量。有四句可知。所以言微尘复非微尘。说世界非世界者。非烦恼等分别微尘故。故云非微尘等也。是名微尘等者。是地等无分别微尘也。地等无分别。既无分量心。无分别分量亦如是

佛言须菩提于意云何可以三十二大人相见如来不须菩提言不也世尊何以故如来说三十二大人相即是非相是名三十二大人相佛言须菩提若有善男子善女人以恒河沙等身命布施若复有人于此法门中乃至受持四句偈等为他人说其福甚多无量阿僧祇　就第三离相文有四可知。文云三十二相即是非相者。于大菩提非法身故。诸法因果非胜故。余义可知。第四校量显德文有二可知。就第二段信相文中。大分有三。初辨信相体。二须菩提如来说忍辱波罗蜜已下。引事证成。三复次须菩提若善男子善女人能于此法门已下。校量信德

尔时须菩提闻说是经深解义趣涕泪悲泣扪泪而白佛言希有婆伽婆希有修伽陀佛说如是甚深法门我从昔来所得慧眼未曾得闻如是法门何以故须菩提佛说般若波罗蜜即非般若波罗蜜世尊若复有人得闻是经信心清净则生实相当知是人成就第一希有功德世尊是实相者则是非相是故如来说名实相实相世尊我今得闻如是法门信解受持不足为难若当来世其有众生得闻是法门信解受持是人则为第一希有何以故此人无我相人相众生相寿者相何以故我相即是非相人相众生相寿者相即是非相何以故离一切诸相则名诸佛佛告须菩提如是如是若复有人得闻是经不惊不怖不畏当知是人甚为希有何以故须菩提如来说第一波罗蜜非第一波罗蜜如来说第一波罗蜜者彼无量诸佛亦说波罗蜜是名第一波罗蜜　就初文中。大分有四。初有三句。总显信相。二何以故须菩提已下两句。出其信体。第三世尊若复有人已下有四句。显其信德。四世尊我今得闻如是已下。显信德殊胜。此文有四。初举易显难以立宗。二若当来世已下。正显信之殊胜。三何以故已下。有三句问答。显信离相。四佛告须菩提如是如是已下。结成希有。述其信义。于中有五句可知。问因何须菩提得智眼已来不闻此经。答以须菩提义当受法之机。虽得小乘智眼。未闻大法。回心得大。故言希有。般若波罗蜜即非般若波罗蜜者。此智法门。坚实深妙。非余人分别波罗蜜也。文云实相即是非相者。即是信心清净无相也。又实相实相者。是无相之实也。文云此人无我相等者。示所取境不倒相故。又云我相即是非相者。示能取境界不倒相故。此二相我空法空无我智故。文云不惊者。谓不于非处生惧也。不怖者。以不起不能断疑心故。不畏者。不一向怖故。文云如来说第一波罗蜜即非第一者。此经法门胜余修多罗故。此法门名为大因。故如来说第一波罗蜜。又此法门名为清净。诸佛共说也。就第二引事证成中。大分有四。初有四句。正引住事。证成信相。二是故须菩提已下。劝成信体。于中有四句。初总劝。二责。三答。四离非显是也。三是故佛说菩萨已下。引圣教证成信实。此文有二。初总引圣教。二须菩提菩萨为利益一切众生已下。举法述成。就此述文。大分有二。初法说以显信实。二须菩提譬如有人已下。喻合双成。显其信义。四复次须菩提已下。显其信实。诸佛证成

须菩提如来说忍辱波罗蜜即非忍辱波罗蜜何以故须菩提如我昔为歌利王割截身体我于尔时无我相无众生相无人相无寿者相无相亦非无相何以故须菩提我于往昔节节支解时若有我相众生相人相寿者相应生嗔恨须菩提又念过去于五百世作忍辱仙人于尔所世无我相无众生相无人相无寿者相是故须菩提菩萨应离一切相发阿耨多罗三藐三菩提心何以故若心有住则为非住不应住色生心不应住声香味触法生心应生无所住心是故佛说菩萨心不住色布施须菩提菩萨为利益一切众生应如是布施须菩提言世尊一切众生相即是非相何以故如来说一切众生即非众生须菩提如来是真语者实语者如语者不异语者须菩提如来所得法所说法无实无妄语须菩提譬如有人入闇则无所见若菩萨心住于事而行布施亦复如是须菩提譬如人有目夜分已尽日光明照见种种色若菩萨不住于事行于布施亦复如是　问何故引往忍辱波罗蜜为证者。答忍顺实相理故。又问。次复第二义相中。何故引檀度为证者。以檀行在初故。余准可知。又初地得忍波罗蜜。顺理法故。又檀波罗蜜摄五波罗蜜。故偏约之也。文云如来是真语者。不妄说佛菩提故。实语者。不妄说小乘苦谛等故。如语者。不妄说大乘法无我真如故。不异语者。不妄说三世受记故。文云无实者。诸佛所说法。此法不能得彼证法故。以如所闻无如是义故。是故无实。文云妄说语者。随顺义故。以此所说法。随顺证法故。文言如人入闇等者。有人疑云。若真如普遍。何故不见。如入闇中。无明智故不见。非无实法。文云夜分既尽等者。喻有明智。即无遮障也

复次须菩提若有善男子善女人能于此法门受持读诵修行则为如来以佛智慧悉知是人悉见是人悉觉是人皆得成就无量无边功德聚须菩提若有善男子善女人初日分以恒河沙等身布施中日分复以恒河沙等身布施后日分复以恒河沙等身布施如是舍恒河沙等无量身如是百千万亿那由他劫以身布施若复有人闻此法门信心不谤其福胜彼无量阿僧祇何况书写受持读诵修行为人广说　就第三校量信门行德中。文言受持读诵者。闻慧之中有三法。一受。二持。三读诵。修行者。内思。及为他说等。福中之胜也。问何故此中广校量者。引证之中。决疑胜故。就第二以略显广成信门中。大分有四。初举总信相。二须菩提我念过去已下。引往事证成。三若复有人于后末世已下。举胜校量以劝学。四须菩提若有善男子善女人已下。举广结略

须菩提以要言之是经有不可思议不可称量无边功德此法门如来为发大乘者说为发最上乘者说若有人能受持读诵修行此经广为人说如来悉知是人悉见是人皆成就不可思议不可称无有边无量功德聚如是人等则为荷担如来阿耨多罗三藐三菩提何以故须菩提若乐小法者则于此经不能受持读诵修行为人解说若有我见众生见人见寿者见于此法门能受持读诵修行为人解说者无有是处须菩提在在处处若有此经一切世间天人阿修罗所应供养当知此处则为是塔皆应恭敬作礼围绕以诸华香而散其处复次须菩提若善男子善女人受持读诵此经为人轻贱何以故是人先世罪业应堕恶道以今世人轻贱故先世罪业则为消灭当得阿耨多罗三藐三菩提　就初总中。略有十二事。一举德无边。二举所以非小。三上圣智见加持。四成无边功德。五成大果因。六非小境界。七非凡能知。八感众供养。九成处是胜。十恭敬供养有福。十一灭三世罪。十二当得菩提

须菩提我念过去无量阿僧祇阿僧祇劫于然灯佛前得值八十四亿那由他百千万诸佛我皆亲承供养无空过者须菩提如是无量诸佛我皆亲承供养无空过者　就第二段引事证成有二可知

若复有人于后世末世能受持读诵修行此经所得功德我所供养诸佛功德于彼百分不及一千万亿分乃至算数譬喻所不能及　第三举胜校量

须菩提若有善男子善女人于后世末世有受持读诵修行此经所得功德若我具说者或有人闻心则狂乱疑惑不信须菩提当知是法门不可思议果报亦不可思议　就第四举广结略门中有三可知。文云心则狂乱者。不得静住。离净法故。疑者。犹豫不得定心故。惑者不成明智故。不信者。不见胜德故也

佛说金刚般若波罗蜜经略疏卷上佛说金刚般若波罗蜜经略疏卷下

        唐至相寺沙门智俨述

就大段第二约彼行相显三种般若。问此下明行教。与前行教何别。答。前文约见闻已去说。此约成观已去说也。文中大分有三。初陈四疑。问三种般若体相。二佛告须菩提菩萨发下。广答显相。三须菩提发阿耨已下。结成前义

尔时须菩提白佛言世尊云何菩萨发阿耨多罗三藐三菩提心云何住云何修行云何降伏其心　问。何故须约行说。答。学者于闻思虽复明了。于修不进不发有迷。故须重明也。就第二段广答显相文中。大分有二。初约行释三种般若体相。二佛言须菩提如来得阿耨菩提已下。约行释其余疑。就初文中。大分有五。初约众生界释三种般若。二须菩提于意云何如来于然灯佛所已下。引彼往昔行事证成。第三须菩提若有人言已下。辨行真伪。四须菩提譬如有人已下。显行分量。五须菩提若菩萨作是言我庄严佛土下。会相入实。今此所以对行广明三种修行者。为前起解我能如是修三种行。不免喧杂分别。为除此惑。故须约行辨三种也

佛告须菩提菩萨发阿耨多罗三藐三菩提心者当生如是心我应灭度一切众生令入无余涅槃界如是灭度一切众生已而无一众生实灭度者何以故须菩提若菩萨有众生相人相寿者相则非菩萨何以故须菩提实无有法名为菩萨发阿耨多罗三藐三菩提心者　就初行体相门中有五。初总辨生起菩提心。二我应灭度下。明心所趣。三如是灭度下。显其实相。四何以故下。问答显过。五何以故下。举实结成。问。此文内辨三修行及以发心。何故一处通释而不别明者。答。前是解法。须约别论之。今就行门。不得分别。由众生即无。与佛不异。解此法故。即名菩提心。由知众生即无我空故。即名如是住。成无分别智证。即名如实修行。本来无烦恼。即名降伏其心也

须菩提于意云何如来于然灯佛所有法得阿耨多罗三藐三菩提不须菩提白佛言不也世尊如我解佛所说义佛于然灯佛所无有法得阿耨多罗三藐三菩提佛言如是如是须菩提实无有法如来于然灯佛所得阿耨多罗三藐三菩提须菩提若有法如来得阿耨多罗三藐三菩提者然灯佛则不与我受记汝于来世当得作佛号释迦牟尼以实无有法得阿耨多罗三藐三菩提是故然灯佛与我受记作如是言摩那婆汝于来世当得作佛号释迦牟尼何以故须菩提言如来者即实真如　就第二引往事为证内。大分有六。初审定可不。二须菩提白佛言下。有二句。答显实相。三佛言如是下。述成正义。四须菩提若有法已下。反成其失。五以实无有法已下。以理成事有二句。六何以故已下。问答约佛显成行相。亦即兼释伏疑云若无菩提即无诸佛如来。为决此疑。故文云即实真如也

须菩提若有人言如来得阿耨多罗三藐三菩提者是人不实语须菩提实无有法佛得阿耨多罗三藐三菩提须菩提如来所得阿耨多罗三藐三菩提于是中不实不妄语是故如来说一切法皆是佛法须菩提所言一切法一切法者即非一切法是故名一切法　就第三段辨行真伪中有五句。初明言不称实。二举义证言。三须菩提如来所得下。显法同异。不同有为五阴相故。文言不实。无色等相即菩提相故。文言不妄语。四是故如来说一切法。类成正义。五须菩提所言一切法。结成正义。文言一切法。即真如体故。复一切法。即如来证故。即非一切法。色等相不住故。故名一切法者。即诸法非法。是诸法法。就第四显行分量中。大分有二。初举事显成分量。二佛言须菩提菩萨亦如是下。结成分量广大

须菩提譬如有人其身妙大须菩提言世尊如来说人身妙大即非大身是故如来说名大身佛言须菩提菩萨亦如是若作是言我当灭度无量众生则非菩萨佛言须菩提于意云何颇有实法名为菩萨不须菩提言不也世尊实无有法名为菩萨是故佛说一切法无众生无人无寿者　前文有三句可知。所以成法分量者。为其行体离烦恼障及智障。毕竟具足法身故。此中妙大有二种。一者遍一切处。二者功德大。是故名大身。遍一切大者。真如一切法不差别故。文言即非大身者。离诸相身。名大身者。是真如体。就第二结成大身内有四。初结成大义。二佛言下。审定可不。三世尊已下。显成正义。四是故佛说下。举圣教结成正义也。就第五会相入实中。大分有四。初正明会依正二相。二佛言须菩提于意云何如恒河中下。明行德分量。三须菩提于意云何佛可以具足相下。辨行离相。四尔时慧命须菩提白佛言已下。显行殊胜。就初文中。大分有二。初会依报相以从实行。二须菩提于意云何如来有肉眼已下。会其正报以从行实

须菩提若菩萨作是言我庄严佛国土是不名菩萨何以故如来说庄严佛土庄严佛土者即非庄严是名庄严佛国土须菩提若菩萨通达无我无我法者如来说名真实菩萨菩萨　就初文中。大分有四。初总显过。二责所以。三答以显是。四举观通达。以结成行相。文云庄严佛国土是不名菩萨者。论偈云。不达真法界。起度众生意。及清净国土。生心即是倒。故不名菩萨也。又文云庄严佛国土即非庄严者。若菩萨通达无我法。起自智信心。故此信智。通摄世谛菩萨起。及出世菩萨起。是故经文重说菩萨菩萨

须菩提于意云何如来有肉眼不须菩提言如是世尊如来有肉眼佛言须菩提于意云何如来有天眼不须菩提言如是世尊如来有天眼佛言须菩提于意云何如来有慧眼不须菩提言如是世尊如来有慧眼佛言须菩提于意云何如来有法眼不须菩提言如是世尊如来有法眼佛言须菩提于意云何如来有佛眼不须菩提言如是世尊如来有佛眼　就会正报文中。五眼即为五段。一一段中。各有二句可知。所以有此教兴。若菩萨不见。即无胜能。为答此疑。故文云。如来有五眼。能了别诸法。见彼颠倒相。毕竟无为。故名五眼

佛言须菩提于意云何如恒河中所有沙佛说是沙不须菩提言如是世尊如来说是沙佛言须菩提于意云何如一恒河中所有沙有如是等恒河是诸恒河所有沙数佛世界如是世界宁为多不须菩提言彼世界甚多世尊佛言须菩提尔所世界中所有众生若干种心住如来悉知何以故如来说诸心住皆为非心住是名为心住何以故须菩提过去心不可得现在心不可得未来心不可得须菩提于意云何若有人以满三千大千世界七宝持用布施是善男子善女人以是因缘得福多不须菩提言如是世尊此人以是因缘得福甚多佛言如是如是须菩提彼善男子善女人以是因缘得福德聚多须菩提若福德聚有实如来则不说福德聚福德聚　就第二行德分量文中有五初问答定其法数。二佛言须菩提下。问答现世多少。三佛告须菩提下。类成心数分齐。有三句可知。四须菩提于意云何下对境成行。有四句可知。五须菩提若福聚有实下。成行分量。文言如来说诸心住皆为非心住者。此句示现远离四念处故。此以何义。心住者住彼念处故。又文言若福德聚有实如来即不说者。有实福德聚。是有漏故。是其颠倒。故不说也。福德聚福德聚者。无漏福德聚。为智慧根本故。即为福德聚

须菩提于意云何佛可以具足色身见不须菩提言不也世尊如来不应以色身见何以故如来说具足色身即非具足色身是故如来说名具足色身佛言须菩提于意云何如来可以具足诸相见不须菩提言不也世尊如来不应以具足诸相见何以故如来说诸相具足即非具足是故如来说名诸相具足佛言须菩提于意云何汝谓如来作是念我当有所说法耶须菩提莫作是念何以故若人言如来有所说法即为谤佛不能解我所说故何以故须菩提如来说法说法者无法可说是名说法　就第三行德离相文中。大分有三。初有四句。约色身辨离相。有六句可知。二佛告须菩提下有四句。约意业功德辨离相。三佛言须菩提于意云何下。约口业说法辨离相。于中有七句。文言说诸相具足即非具足者。色身具足。非法身具足。色身及相身。不离于法身。故文言说名诸相具足。又文言说法说法有二种。一者所说法。二者所有义。故言说法说法。又文言无法可说是名说法者。说法不离于法界。说法无自相。故言无说为说法也

尔时慧命须菩提白佛言世尊颇有众生于未来世闻说是法生信心不佛言须菩提彼非众生非不众生何以故须菩提众生众生者如来说非众生是名众生　就第四显法殊胜文中。大分有四可知。又言非众生非不众生者。若有信此经。彼人即非众生。非不圣体故也。非不众生者。以有圣体故。彼人非凡夫众生。非不是圣体众生。又言众生众生者。如来说非众生。是名众生故。如来说非众生者。非凡夫众生也　就大段第二释余行疑中有二。初释余疑。二须菩提于意云何汝谓如来下。会相入实。就初文中。大分有二。初正释余疑。二三千大千世界下。校量显胜

佛言须菩提于意云何如来得阿耨多罗三藐三菩提耶须菩提言不也世尊世尊无有少法如来得阿耨多罗三藐三菩提佛言如是如是须菩提我于阿耨多罗三藐三菩提乃至无有少法可得是名阿耨多罗三藐三菩提复次须菩提是法平等无有高下是名阿耨多罗三藐三菩提以无众生无人无寿者得平等阿耨多罗三藐三菩提一切善法得阿耨多罗三藐三菩提须菩提所言善法善法者如来说非善法是名善法　初文有五。初审定可不。二须菩提下。答显成正义。有二句。三佛言下。如来述成正义。四复次须菩提下。显正义相。有三文。即为三义也。五须菩提所言善法者下。拣非显是。此义云何。以法界不增减。是法平等。故无证得菩提者。文言善法善法者。初善法者。是有漏善法。非无漏净善法。后善法者是无漏善法。非有漏善法。故名善法也

须菩提三千大千世界中所有诸须弥山王如是等七宝聚有人持用布施若人以此般若波罗蜜经乃至四句偈等受持读诵为他人说于前福德百分不及一千分不及一百千万分不及一歌罗分不及一数分不及一优波尼沙陀分不及一乃至算数譬喻所不能及　就第二校量文中。大分有三。所以教兴者。疑者云。若一切善法得菩提。即所说法不能得成佛。以无记法故。为断此疑。故今教兴。虽所说法是无记而能成佛。以远离所说法。不能得佛故。又此无记语。同小乘说。今此大乘。是善非无记。泛言校量胜者有四种。一数胜。二力胜。三不相似胜。四因胜也。数胜者。如文百千分不及一等也。力胜者。如经歌罗分不及也。不相似胜者。此福德中数不似也。因胜者。因果不相似。如经乃至优波尼沙陀分不及一也。就大段第二会相入实门中。大分有四。初会三相以从实。二须菩提若善男子善女人下。校量其德。三须菩提若有人下。显行体深。四须菩提若善男子善女人下。显行德分量。所以有此教兴者。疑者云谓行观外解相不入行理故也。就初会三相中。大分有三。一约度众生相会从行理。二须菩提于意云何可以相成就下。约其身相会从行体。三须菩提于意云何如来下。约因成果相会从行理

须菩提于意云何汝谓如来作是念我度众生耶须菩提莫作是念何以故实无有众生如来度者佛言须菩提若有实众生如来度者如来则有我人众生寿者相须菩提如来说有我者则非有我而毛道凡夫生者以为有我须菩提毛道凡夫生者如来说名非生是故言毛道凡夫生　就初文中大分有五。初有四句。显成实义。二佛言须菩提下。反以显过。三须菩提如来说下。会其圣意。四而毛道下。明妄不识真。五须菩提毛道下。明会述从正。故论偈云。平等真法界。佛不度众生。以名共彼阴。不离于法界。假名与法界无差别故。如来不度一众生。若度众生者。即是五阴中取相故。文言说非生者。不生圣法。故言非生也。就大段第二会身相文中。大分有二。初长行总显。第二尔时世尊下。说偈别明

须菩提于意云何可以相成就得见如来不须菩提言如我解如来所说义不以相成就得见如来佛言如是如是须菩提不以相成就得见如来佛言须菩提若以相成就观如来者转轮圣王应是如来是故非以相成就得见如来　初文有五。初审定可不。二须菩提下。答显实义。三佛言如是下。述成正义。四佛言须菩提下。反成显过。五是故非以相下。顺结也

尔时世尊而说偈言若以色见我以音声求我是人行邪道不能见如来　彼如来妙体即法身诸佛法体不可见彼识不能知偈文有四。初半行。举过体。次半行。显过义。次半行。举法体。次半行。显法德义。言彼识不能知者。彼凡夫识也

须菩提于意云何如来可以相成就得阿耨多罗三藐三菩提耶须菩提莫作是念如来以相成就得阿耨多罗三藐三菩提须菩提汝若作是念菩萨发阿耨多罗三藐三菩提心者说诸法断灭相须菩提莫作是念菩萨发阿耨多罗三藐三菩提心说诸法断灭相何以故菩萨摩诃萨发阿耨多罗三藐三菩提心者于法不说断灭相故　就第三会因成果相文中有五。初审定可不。二须菩提莫作是念下。抑见菩提成熟之相。三须菩提汝若作是念已下。成其能感发心过相。四须菩提莫作是念下。呵其谓情。五何以故已下。问答显德。外人疑云。若菩提心不感于果。即谓不依福德得真菩提。为去此疑。故经云。菩萨发菩提心者。于法不说断灭相。以能成就智慧庄严功德庄严故

须菩提若善男子善女人以满恒河沙等世界七宝持用布施若有菩萨知一切法无我得无生法忍此功德胜前所得福德须菩提以诸菩萨不取福德故须菩提白佛言世尊菩萨不取福德佛言须菩提菩萨受福德不取福德是故菩萨取福德　就第二校量其德内。大分有五。初举能校量法。二若有菩萨已下。对校量显胜。三须菩提下。显离取德。四须菩提白佛言下。述成前义。五佛言须菩提下。显法同异。结成正义。文言得无生法忍者。有二种无我。不生二种无我相。是故文云受而不取者。彼福德得有漏果报故。彼福德可呵。此福德无有漏报。是故此福德受而不取

须菩提若有人言如来若去若来若住若坐若卧是人不解我所说义何以故如来者无所至去无所从来故名如来　就第三显行体深文有三可知。初应报化身有用。彼法身诸佛不来不去。故凡夫不解。二何以故。责。第三显法身相常如是住。不变不异。故是深也。故论偈云。去来化身佛。如来常不动。于是法界处。非一亦不异

须菩提若善男子善女人以三千大千世界微尘复以尔许微尘世界碎为微尘阿僧祇须菩提于意云何是微尘众宁为多不须菩提言彼微尘众甚多世尊何以故若是微尘众实有者佛则不说是微尘众何以故佛说微尘众则非微尘众是故佛说微尘众世尊如来所说三千大千世界则非世界是故佛说三千大千世界何以故若世界实有者则是一合相如来说一合相则非一合相是故佛说一合相佛言须菩提一合相者则是不可说但凡夫之人贪着其事何以故须菩提若人如是言佛说我见人见众生见寿者见须菩提于意云何是人所说为正语不须菩提言不也世尊何以故世尊如来说我见人见众生见寿者见即非我见人见众生见寿者见是名我见人见众生见寿者见　就第四显行德分量文中有五。初有四句。举碎微尘末之数。显染尽净。于法界中无一住相故。微尘众者。示现非一喻故。二何以故。问答释教兴意。三复何以已下。明圣教所趣。于中展转有五句可知。四佛言须菩提下。显其正义。五但凡夫之人下。会其圣意。于中有八句相生可知。文言若世界及一合相实有者。如来即不说。何以故。凡夫应是。圣人应非故。余者准之。文言一合相者。如分别见一实相也。若欲识其文意。先对文言。约凡圣二位。开其二相。一约众生。见一合相。即是一合相。即非一合相。二约圣者。说一合相。即非一合相。是名一合相。依此二门。取解即易。其义云何。众生见一合相者。由依似作实尘解。即不见似尘藉于众缘。及作时不住故。不成合相。迷见实尘唯见一有故。是一合相者。由见实尘定有性。故是合也。即非一合相者。由见尘实即无实理。与无不异故。即非合故。佛说一合相者。佛知似尘假合而成。非有似有。故说合相。即非一合相者。此有二义非一合相。第一非彼凡夫所谓实尘一合相。第二由彼诸缘作时不住不作故故非似合也。是名一合相者。由彼诸缘似合成尘。故非是无。名一合相也。今圣意说一合相。显凡分别是其失明。圣人所见一合相者。是离分别顺其正理。故有此二言。趣入方便。其义云何。有二种方便。一由似作故。离无分别。以见似有。不得是无。若见是无。即是分别。由似不作故。离有分别。以见似无。不得是有。若见是有。即是分别。二由似作故。离无分别。以见似有。不得是无。若见是无。即是分别。由似作故。离有分别。今见似有。非是实有。若见实有。即是分别。由似不作故。离有分别。以见似无。不是实有。若见实有。即是分别。由似不作故。离无分别。以见似无。不是实无若见实无。即是分别。此可思。何以故。由此中义。与后八喻有不同故。就大段。第三结文有五。初正结前分。二何以故。责。三答显正义。四须菩提若有菩萨下。校其德。五云何为人演说下。福德利他。明行胜用

须菩提菩萨发阿耨多罗三藐三菩提心者于一切法应如是知如是见如是信如是不住法相何以故须菩提所言法相法相者如来说即非法相是名法相须菩提若有菩萨摩诃萨以满无量阿僧祇世界七宝持用布施若有善男子善女人发菩萨心者于此般若波罗蜜经乃至四句偈等受持读诵为他人说其福胜彼无量阿僧祇　前文云如是知者。如是知法不生故。即结前行发心。如是见者。即见实相即结前行中如是住。如是信者。信行可成。即结前行中如是修行。如是不住法相者。即离分别故。即结前行中降伏其心也

云何为人演说而不名说是名为说尔时世尊而说偈言一切有为法如星翳灯幻露泡梦电云应作如是观　就第五利他说法胜用文中有二。初长行总说生起。二偈颂释成。就偈文中有三段经。初一句举其法。次有二句九义显其观相。三有一句结以观成。言九义者。一星映不见。喻能见心法有而不见。二翳者。见毛轮等色。有为法亦尔。以颠倒见故。三灯者。识亦如是。依止贪爱法住故。四幻者。所依住处亦如是。以器世间种种差别无一体实故。五露者。身亦如是。以少时住故。六泡者。所爱事亦如是。以受想行三法不定故。七梦者。过去法亦如是。以唯有念故。八电者。现在法亦如是。刹那不住故。九云者。未来法亦如是。以于种子时阿梨耶识与。一切法为种子根本。无先因相。故如云。余文可知。异现如星。无实如翳。速灭刹那若灯。缘成比幻。无常喻露。体空况泡。见实如梦。有用象电。无本并云。二法中皆有九义不成实耳

佛说是经已长老须菩提及诸比丘比丘尼优婆塞优婆夷菩萨摩诃萨一切世间天人阿修罗乾闼婆等闻佛所说皆大欢喜信受奉行　就第三流通文有二。初举十众为受益者。第二闻佛所说下。正明益相耳

佛说金刚般若波罗蜜经略疏卷下

石埭除子静施洋银四十圆敬刻此经连圈计字二万零一百九十一个

光绪二十六年夏五月金陵刻经处识


佛说盂兰盆经疏

    No. 1792 [cf. No. 685]

佛说盂兰盆经疏上

        充国沙门宗密述

始于混沌。塞乎天地。通人神。贯贵贱。儒释皆宗之。其唯孝道矣。应孝子之恳诚。救二亲之苦厄。酬昊天恩德。其唯盂兰盆之教焉。宗密罪衅早年丧亲。每履雪霜之悲。永怀风树之恨。窃以终身坟垄。卒世蒸尝。虽展孝思不资神道。遂搜索圣贤之教。虔求追荐之方。得此法门。实是妙行。年年僧自恣日。四事供养三尊。宗密依之修崇。已历多载。兼讲其诰。用是未闻今因归乡。依日开设道俗耆艾。悲喜遵行。异口同音。请制新疏。心在松柏。岂慢乡闾。式允来情。发挥要道

稽首三界主。大孝释迦尊。累劫报亲恩。积因成正觉。将永锡众类。应请演斯经。欲使背恩人。咸能酬罔极。我今所赞述。愿众圣冥加。自他存殁亲。离苦常安乐

将解此经。先开四段。一教起所因。二藏乘所摄。三辨定宗旨。四正解经文。初中复四。一酬宿因故。二酬今请故。三彰孝道故。四示胜田故　初教起所因(四)　初酬宿因者。悉达太子。不绍王位。舍亲去国。本为修行得道报父母恩。然菩萨用心。不务专己。故开盂兰法会。以福自他二亲。此经所兴。本意如此。二酬今请者。谓大目犍连因心之孝。欲度父母。报乳哺之恩故。出家修行。神通第一。观见亡母。堕饿鬼中。自救不能。白佛求法。佛示盆供。救母倒悬。繇爱其亲。施及一切故。为道俗弟子。请佛留此法门。酬目连所请。即是说经之繇致也。三彰孝道者。复有其二。一通明孝为二教之宗本。二别明二教行孝之同异。初通明中。且明儒教。以孝为本者。谓始自天子。至于士人。家国相传。皆立宗庙。虽五孝之用。则别而不行之。源不殊故。开宗明义。章中标为至德要道。道德以之为体。教法繇是而生。何有君子。而不务本。既为天经地义。须令企及俯从。虽论礼坏乐崩终诃衣锦食稻。甚哉孝之大也。圣人之德。又何以加于孝乎。次释教以孝为本者。然一切佛。皆有真化二身。释迦化身说。随机权教。舍那真身说。究竟实教。教者。经律也。经诠理智。律诠戒行。戒虽万行。以孝为宗。故我卢舍那佛。最初成正觉时。便说华严大经。菩萨大戒。又经标云。尔时释迦牟尼佛。初坐菩提树下。成无上正觉已。初结菩萨波罗提木又。孝顺父母。师僧三宝。孝顺至道之法。孝名为戒。亦名制止。涅槃亦云。奇哉父母。生育我等。受大苦恼。满足十月。怀抱我身。既生之后。推干就湿除去不净。大小便利。乳哺长养。将护我身。以是义故。应当报恩。随顺供养。上通明二教以孝为本竟。次别明二教行孝之同异者。于中初明其异。后显其同。初谓生前侍养异。后谓殁后追思异。侍养异者。儒宗则慎护发肤。扬名后代。故乐春不出。曾子开衾。释教则祝发坏衣。法资现世。故优陀通信。净藏回邪。是谓为善不同。同归乎孝。殁后异者。复有三异。一居丧异。儒则棺椁宅兆安墓留形。释则念诵追斋荐其去识。二斋忌异。儒则内斋。外定想其声容。释则设供讲经资其业报。三终身异。儒则四时杀命。春夏秋冬。释则三节放生施戒盆会。良繇真宗。未至周孔。且使系心今知礼有所归。不应犹执权教。且福之大者。莫大于施。生是释梵之本因。类天地之大德。今杀彼祭此。岂近仁心。是若可忍。孰不可忍。虽云祈福。实是立仇。自徇虚名。殃于神道。问父母生于余趣。则可改祭为斋。如堕鬼中。宁无飨祀。答黍稷非馨。苹蘩可荐。应知禴祭。胜于杀牛。况鬼神等差。岂皆受飨。上明异竟。次显其同者。复有其二。初明存殁同。后明罪福同今初约纪孝行章中五句之文以辨其同。即摄于生前殁后也。一居则致其敬者。儒则别于犬马。释则举身七多。二养则致其乐者。儒则怡声下气温清定省等故。有扇床温席之流。释则节量信毁分减衣钵等故。有割肉充饥之类。三病则致其忧者。儒中如文帝先尝汤药。武王不脱冠带。释中如太子以肉为药。高僧以身而担。四丧则致其哀者。儒有武丁不言。子皋泣血。释有目连大叫调御舁棺。五祭则致其严者。儒有荐笋之流。释有饷饭之类。但以至教未来难弘报应。故先且立于祭法。令敬事于神灵。神灵则父母之识性。足显祖考之常存。既形灭而神不灭。岂厚形而薄神乎。余如前辨。上来存殁同竟。次辨罪福同。罪同者。儒则条越五刑。犯当五摘而恩赦不该。释则名标七逆。戒黜七遮而阿鼻定入。福同者。儒则旌于门闾上天之报。释则莹于戒德净土之因。上来总彰孝道竟。第四示胜田者。喻如世间人。欲得仓廪中五谷丰盈岁岁不乏者。必须取谷麦种子。以牛犁耕于田地而种之。不种则竭尽也。法中亦尔。以悲心敬心孝心为种子。以衣食财帛身命为牛犁。以贫病三宝父母为田地。有佛弟子。欲得藏识中百福庄严生生无尽者。须运悲敬孝心。将衣食财帛身命。给济敬养于贫病三宝父母。名为种福。不种即贫穷无福慧。入生死险道。谓种福之田名为福田。如种谷之田名谷田也。然种子有精新干焦。田有肥浓确瘦。如悲敬孝心有恳切闲缦。贫有浅深。病有轻重。佛有真化。化有住世入灭。法有大小。教有权实。僧有持毁。父母有现生七世。一一配肥瘦之田。昭然可见。今盂兰供会具三种肥田。故云胜也。谓佛欢喜日。供养自恣净戒大德。敬田胜也。报父母恩。恩田胜也。父母在厄难中。悲田胜也。为欲示此胜田故。说此经也。二藏乘所摄。第二藏乘所摄者。藏谓三藏。乘谓五乘。三藏者。一修多罗。此云契经。契者契理契机。经者。佛地论云。贯摄为义。谓贯穿所应知义。摄持所化生故。此教于三学中诠于定学。二毗奈耶。此云调伏。调谓调练三业。伏谓制伏过非。此教诠于戒学。三阿毗达磨。此云对法。法谓涅槃四谛。对谓对向对观。其能对者。即是妙慧。此教诠于慧学。然经是化教。开诱化导也。律是制教。制约行业也。论则推征。解释经律之意也。今此盂兰盆据其名题。即化教摄。属于经藏。据其义意亦制教摄。属于律藏。五乘者。乘以运载为名。五谓人天声闻缘觉菩萨。此五力有大小。载有远近。一人乘。谓三归五戒。运载众生越于三涂生于人道。其犹小艇才过溪涧。二天乘。谓上品十善。及四禅八定。运载众生越于四洲达于上界。犹如小船越小江河三声闻乘。谓四谛法门。四缘觉乘。谓十二因缘法门。皆能运载众生越于三界。到有余无余涅槃。成阿罗汉及辟支佛。皆如大船越大江河。五菩萨乘。谓悲智六度法门。运载众生总超三界三乘之境。至无上菩提大般涅槃之彼岸。如乘舶过海也。今此经者。谓是人天乘所摄。在小乘藏中。三辨定宗旨。三辨定宗旨者。此经以孝顺设供。拔苦报恩为宗。今以二门分别。一释行相。二配句数。初者为目连。本为孝诚欲酬恩德。力所未及故先出家。是以始得六通。便观三界见其亡母生饿鬼中。虽饷香饭旋成猛火。悲号投佛。佛教设于盆供。拔冥途身脱一劫苦。不辜生育大报劬劳。细详经旨备斯四义。二配句数者。有四四句。一孝顺两字。自有四句。一孝而非顺。如三牲之养等。二顺而非孝。如病索禁忌之食而即供。欲行非为之事而不谏等。三亦孝亦顺。谓有隐无犯。三谏而随顺色。观志三年无改。四非孝非顺。如水中葬父之类。二以孝顺设供。相对复为四句。一孝顺非设供。如董黯王祥等。二设供非孝顺。为己求福而修斋等。三俱是。即盂兰盆会。四俱非。谓逆而悭也。三以孝顺对拔苦。亦为四句。一孝顺非拔苦。谓董永等。二拔苦非孝顺。谓救他人之苦。三俱是。即兰盆会。四俱非。谓逆小之人也。四以孝顺对报恩亦为四句。一孝顺非报恩。护发肤不骄危非法不言等。二报恩非孝顺。扶轮报一餐修行报施主等。三俱是。盂兰盆会也。四俱非。谓辜恩逆人。今修此一门。即圆四行所得功德何可校量。实繇境胜心强彻于神理故也

佛说盂兰盆经疏上终佛说盂兰盆经疏下

        充国沙门宗密述

四正解经文(二)。正解经文于中复二。初释题目。二解本文。初释题目

佛说盂兰盆经　此经总有三译。一晋武帝时。刹法师翻云盂兰盆经。二惠帝时。法炬法师译云灌腊经。应此文云。具饭百味五果汲灌盆器香油锭烛等故。三旧本别录。又有一师。翻为报恩经。约所行之行而立名故。今所释者。即初译也。义净三藏云。颁自我口畅之。彼心以教合机。故称佛说。盂兰是西域之语。此云倒悬。盆乃东夏之音。仍为救器。若随方俗应曰救倒悬盆。斯繇尊者之亲魂沈闇道。载饥且渴命似倒悬。纵圣子之威灵无以拯其涂炭。佛令盆罗百味式贡三尊。仰大众之恩光。救倒悬之窘急。即从此义以立经名。经者正名为线。义曰契经。线能贯华。经能持纬。谓所诠之义似纬似华。能诠之文能持能贯。今顺此方典诰。是以目之为经。借义助名。仍加契字。此释符佛地论。二义中贯穿之义。杂心论五义中结鬘之义也。二解本文。解本文分三。一序分。三正宗分。三流通分。以三分之兴。弥天高判冥符西域。今古同遵。初序分中诸经多有二序。一证信序。谓如是之法我从佛闻。标记说时说处分明。大众同闻非谬。以为证据令总信受。经无丰约非信不传。繇是经初必须证信。故智度论云。说时方人令生信故。二发起序发明信起正宗之法。如净名宝盖法华毫光之类。然证信亦云通序。诸经皆同故。亦云经后序。佛说法时而未有故。发起亦云别序。诸经各别故。亦云经前序。佛先自发起。方说正宗故。初证信序

闻如是一时佛在舍卫国祇树给孤独园　则佛临灭度时。阿难请问四事。佛令置此言也。所问四事佛一一答。谓一依四念处。二以戒为师。三默摈恶性比丘。四一切经初。皆云如是我闻一时佛在某处与某处若干人俱。诸经多具六种成就。文或阙略义必具之。谓一信二闻三时四主五处六众。六缘不具教则不兴。必须具六。故云成就。今经阙于列众也。又闻成就为初异余经者。各是译人之意。谓或云如是之法我从佛闻。或云我于佛边闻如是法。皆是指法之词也。不云我者。意彰圣人皆证无我理故。余经有者。即阿难自指五蕴假者。不同情计之我。亦无过也。闻谓耳根发识听彼外声。次云如是者。信成就也。夫信者言是事如是。不信者言是事不如是。故肇公云。信顺之词也。一时者。师资合会说听究竟。总名一时。简异余时也。谓如来说经。时有无量。不能别举。一言略周故但云一。诸方时分延促不定故。总言一时。然诸经中不指定时指定处者。有解招难故不用之。今详其意。以处则不过十六国中。游化住止之处而有其数。易为标指。时则年月春秋寒热昼夜寅卯须臾等时。变异迅速积数无量。不可说录。难为标指故。佛者梵语佛陀。此云觉者。谓觉了真妄性相之者也。觉有三义。一自觉我空。简异凡夫。二觉他法空。简异二乘。三觉满俱空合于本觉。名究竟觉。或名大觉妙觉。简异菩萨。在舍卫等者。处成就也。真谛记云。住处有二。一境界处。谓化在俗之流。二依止处。谓统出家之众。初即舍卫。后即祇园。婆沙论云。举舍卫者。令远人知。举祇园者。令近人知。舍卫此云闻物。谓具足财宝之物。多闻解脱之人。远闻诸国故。义净三藏译金刚经。云名称大城。祇树等者。即只陀太子所施之树。给孤长者所买之园。只陀此云战胜。波斯匿王太子也。生时王与外国战胜因以为名。给孤独者。是臣之号。本名须达多。此云善施。谓给孤独。即是善施。又常行施故名善施。乡人美之号给孤独。然园是须达所买。树是只陀所施。园总树别。先合标园今以礼别尊卑故。树先园后。西国呼寺为僧伽蓝摩。此云众园。以佛教东流初至中国。止鸿胪寺宾异域僧僧既渐多。散置别馆。存其本号皆曰寺焉。其买园施树者。涅槃经说。须达长者为儿聘妇。诣王舍城。因见佛发心。请入舍卫说法。佛令舍利弗随归先拣住处。择得只陀太子之园。长者问买。太子戏云。侧布黄金满即卖之。长者便欲交付。太子云。是戏言。共请断事之人断之。彼断令依先语。长者载金侧布。唯少一隅。太子见其不惜财宝。知佛殊胜。遂施所余之地置立门屋。施园中树以为林荫。二人共成精舍请佛居之。故云祇树等也。阙众成就者。但文略也。如无常经等。然有其时。必具徒众故。经末云四辈弟子欢喜奉行。二发起序(六)。发起者。此经既以孝顺拔苦为宗故。托救母之缘而为发起。文分为六。第一目连道满。第二知恩欲酬。第三攀慕遍寻。第四得见所在。第五痛哭往救。第六恶习现前。初目连道满

大目犍连始得六通　此人姓大目犍连。唐言菉菽氏。彼国上古有仙。常食菉豆。尊者是彼之种族也。名尼拘律陀。即树名也。尊者二亲因祭此树神而生尊者。故名此也。是王舍城中辅相之子。时人贵其种。所以称其氏。始得六通者。始即是初。初得圣道便度二亲。本因亲而修道故也。道虽无异本愿各殊。故诸圣者不必皆尔。六通者。一神境通。智证神境故。亦名如意通。身如其意欲往即到故。二天眼通。三天耳通。谓能见能闻若近若远。障内障外色声等故。四宿命通。能知宿世本生本事故。五他心通。谓于定散漏无漏心。一切能知故。六漏尽通。谓身中漏尽而能知故。六皆无拥故总名通。二知恩欲酬

欲度父母报乳哺之恩　度谓度脱。然报恩两字。但是通标虚位。度脱正是其报。乳谓母乳。哺是嚼哺。然父母有远近。恩有轻重。报有分全。远者七世乃至多世。近者即生此身。七世者。外教所宗。人以形质为本传体相续。以父祖已上为七世故。偏尊于父。佛教所宗。人以灵识为本。四大形质为灵识所依。世世生生皆有父母。生养此身。已去乃至七生所生父母为七世也。然寄托之处。惟在母胎。生来乳哺怀抱亦多是母。故偏重母。是以经中但云报乳哺之恩也。乃至多世者。于中偏取归依佛已来所有生身父母。能生我身修道器故。诸佛成道之时。多生父母皆相会遇。闻法获益。恩有轻重者。此生父母最重。余渐轻也。报有分全者。侍养一生为分。度脱多生为全。故经云。左肩担父。右肩担母。遍行大地。亦不能报恩。故知此生所报为分。设同孟宗董黯董永之类。亦为分也。今经云。欲度父母者。意令得道。明其全也。若总不报。便是不孝罪人。况加逆事。且泛论一切人恩。华严经云。不知恩者多遭横死。观佛相海经云。有恩不报。是阿鼻因诸恩尚然。况于父母。父母之恩无可校量。故诗云。蓼蓼者莪匪莪伊蒿。哀哀父母生我劬劳。乃至无父可怙无母可恃。出则衔恤入则靡至。父兮生我。母兮鞠我。抚我畜我。长我育我。顾我。复我。出入腹我。欲报之德昊天罔极。故三藏云。父母义高天地恩深巨海。是以系仰顾腹之恩。思答劬劳之德。父母恩重经云。父母怀抱含笑未语和和弄声。饥时须食非母不哺。渴时须饮非母不乳(云云)。计论母恩昊天罔极。呜呼慈母云何可报(云云)。至于行来东西邻里井窖碓磨。不时还家。母忽心惊。两乳流出。即知我儿家中忆我。即便还家。问详此经文浅朴。偏诫贫贱之流何也。答君子自孝故。偏诫小人。又君子有箪瓢之贫。何妨确磨等事。又偏叙艰勤之语。始彰鞠养之劳耳。又云。其儿遥见母来。或在栏车摇头弄脑。或复曳腹随行呜呼向母。母为其子曲身下就。长舒两手摩拭尘土。呜和其口。开怀出乳。以乳乳之。母见儿欢。儿见母喜。二情相交恩爱慈重。莫复过是(云云)。既生长大朋友相随。梳头摩发欲得好衣覆盖其身。敝衣故破父母自着。新好绵帛先与其子。至于行来官私急疾。倾心南北。逐子东西。横簪头上。子渐长大。为与索妻。得他女子父母转疏。私房室内共相语乐。父母年老气力衰微。终朝至暮不来借问。或复父孤母寡独守空房。犹如客人寄止他舍。常无恩爱。或无襦被寒冻苦辛。厄难遭之太甚。年老色衰多饶蚤虱。夙夜不卧长吟叹息。何罪宿愆。生此不孝之子。或时呼唤。嗔目惊怒尽不从顺。妇儿骂詈低头含笑(云云)。帝释梵王诸天人民。一切众会。闻经欢喜发菩提心。号哭动地泪下如雨。评曰。细思其事诚哉是言。或有母不如此儿不如彼者。百中无一也。良繇众生无始无明迷真执妄。既根本颠倒故。枝末一一皆然。祸哉凡愚。云何可度。三攀慕遍寻

即以道眼观视世间　观求生处是天眼通。繇证道而得故云道眼。世间有二。谓三界是器世间。六道是有情世间。然尊者丧亲之日犹是凡夫。不知父母生于何道。今成圣果力。可追求故。以天眼上下观视于三界处寻六道身。得通便观。故云即也。四得见所在

见其亡母生饿鬼中。不见饮食皮骨连立　本观世间俱寻父母。父生乐处不假施劳。既非经宗故此不述。母生鬼道已属三涂。复在饿中。是鬼之极苦。拔济苦者唯盂兰盆。发起正宗意在斯也。生饿鬼中是异熟果。酬引业故。不见饮食是等流果。酬满业故。是悭贪业之果也。皮骨连立是增上果。准正理论。鬼本住在此洲之下五百繇旬。纵广亦尔。有琰魔罗界。从此展转散取余方。人间一月为一日。乘此积月积年寿五百岁。然鬼有三种。一无财鬼。以无福德不得食故。二少财鬼。少得净妙饮食故。三多财鬼。多得净妙饮食故。此三种鬼复各有三。无财三者。一炬口鬼。谓火炬炎炽常从口出。繇是前生烧坏村栅焚炙贤良。以此求财堕于地狱。从地狱出堕此鬼中。故正法念经云。若人贪嫉枉夺人财。破人城郭杀害抄掠得财。奉王大臣。转增凶暴。堕炽然饿鬼中。二针咽鬼。谓头大如山。咽如针孔。繇于破斋夜食盗窃众僧之食故。故斋法清净经云。目连路逢数百万鬼。头如大山等。三臭口鬼。谓口中腐臭自恶受苦。以多贪名利自是非他。赞叹恶人毁谤贤善故。据此三种。宁吞铁丸不食信施。少财三者。一针毛鬼。毛利如针行便自刺。为贪利故。妄行针炙及刺畜生。但为求财不愈疾故。二臭毛鬼。毛利而臭自拔受苦。繇于贩卖猪羊烹宰鹅鸭。汤烂刀剥楚痛难堪。地狱罪终堕斯鬼趣。三大瘿鬼。咽垂大瘿自决啖脓。繇嫉妒于人常怀嗔恨故。多财三者。一得弃鬼。谓常得祭祀所弃食故。繇于罪多福少少施多悭。弃掷之物方惠施故。二得失鬼。谓常得巷陌所遗食故。以于现财常生悭着。疑欲失者而方舍故。三势力鬼。谓夜叉罗刹毗舍阇等。所受富乐类于人天。或依树林。或住山谷。或居灵庙或处空宫。形竖而行。属于鬼趣。此等变化多端者。繇于因地罪福不精苦乐之因相杂作故。付法藏传说。僧伽耶舍比丘。游大海边见妙宫殿。其家锁二鬼等。今尊者之亲。是无财鬼中炬口鬼也。又有处说。饿鬼有三种。一外障。得遇水时即见有人执刀仗等而障碍故。二内障。口有火炬。或咽如针故。三无障。见河是猛火。或食粪秽。或自割身肉食啖等。今尊者之亲当内障也。上来诸鬼皆繇自心因行所招。果报必应。譬如影响繇于形声。虽父母至亲不相替代。故诸智者宜各励心。傥遇善缘不应空过。一朝去世谁为修崇。纵托子孙七分获一。况无孝子。悔恨何追。且浊世凡流鲜怀仁孝。唯忧妻子。岂念幽灵。贫贱者迫以饥寒。富贵者荒于财色。设能追福厌课者多。竭力罄心万中无一。世途目击岂不昭然。故恩重经云。夫妻和合同作五逆。彼时呼唤急速走使。父母之语十唤九违。不相从顺骂詈嗔目。生存尚尔。殁后可知。自既不仁。儿岂能孝。故昔有送父林野。乃持舆回归。以古观今虽途迹异而心同也。五恸哭往救

目连悲哀。即以钵盛饭往饷其母　悲哀者。生育恩重如上所陈。死别隔生忽然再见。纵使颜容仍旧亦可啼泣悲伤。况睹鬼形皮骨连立。喉中烟焰腹里空虚。苦似倒悬命唯喘息。岂不能碎身擗踊竭气号啕。恨罪逆之偷安。痛慈亲之受苦。经标总意但曰悲哀。细察当时何疑不尔。故三藏科云摧恸。释云。感激彻于骨髓。号叫动于天地。钵饭往饷者。母既气绵夕漏厄在朝饥。饥而且渴。理须救济。济此之急饭食为先。故以钵盛饭持饷于母。六恶习现在

母得钵饭便以左手障钵右手揣食食未入口化成火炭遂不得食　境随心变。果藉业成。饿因未除饱缘宁致。鬼是炬口。食近口而炽然。水作坚冰。冰近汤而确耳。即知神力不禁业力。除饥要且除悭。故六通往饷而招殃。百味盆罗而致苦。大哉业熟可思者焉。今左手障钵悭恐余侵。右手揣食贪于自给。悭贪猛盛如此现行。饭食劣缘若何充济。故化为火不得食也。上来序分竟。二正宗分(二)。正宗分文分为二。初目连悲陈苦厄。二如来广示因缘。初目连悲陈苦厄

目连大叫悲号涕泣。驰还白佛具陈如此　子急告父。臣急告君。自力不如。理宜投佛。弟子勤观四谛。已证三明。可以反覆山河。回转日月。岂料母萦极苦。命若到悬。竭其孝诚尽其神变。而竟不能令除恶报暂济饥肠。所以叫泣奔还。备申哀恳　二如来广示因缘(八)。如来广示因缘。且依三藏大分八段。第一彰母罪深。第二明子德劣。第三斥邪无力。第四显正有能。第五许以救方。第六示其正法。第七孝子领悟。第八慈母获益。初彰母罪深

佛言汝母罪根深结　有经中说。定光佛时目连名罗卜。母字青提。罗卜欲行。嘱其母曰。若有客来娘当具膳。去后客至母乃不供。仍更诈为设食之筵。儿归问曰。昨日客来若为备拟。母曰。汝岂不见设食处耶。从尔已来五百生中悭悭相续。故云罪根深结。罪谓身口之业。根谓悭贪之心。多生相续为深。交固难解为结。从悭所起皆是罪业。非唯彼时一度妄语。谓悭贪是苦根。所作是苦业。饿鬼是苦果。为三事也。若准十重戒中。悭亦是业。唯贪为根。起罪业故。问五百生悭为人为鬼。答人鬼相间。造受相资。若唯人身不名恶报。若唯鬼身不应造业。或亦为畜于理无妨。但悭习不除即名相续。问目连自定光佛世已来。所生之母不一。如何偏救彼之青提。答青提与目连缘深。今生复为其母。但救此身所生之母。非谓救彼远世青提。余论云云。皆为未达　二明子德劣

非汝一人力所奈何　汝母悭心。悭于一切。时经多世。事历多人。岂汝一人力可济拔。三斥邪无力

汝虽孝顺声动天地天神地祇邪魔外道。道士四天王神。亦不能奈何　三藏云。纵汝感天灵于上界。激地祇于下方。纵摄邪魔横罗外道。统六合以同一家。总八部以为一众。并其神力亦不奈何。外道道士者。外道中之道士也。简内道中之道士。佛教初传此方。呼僧为道士故。四天王者。毗沙门等护持世界者也。四显正有能

当须十方众僧威神之力乃得解脱　三藏云。一缕不能制象。必假多丝。一人不能除业。必资众德。今详前后经文。以邪正一多相对乃有四句。一正而非多。此不能救故。前非汝一人奈何。二多而非正。亦不能救。即前神祇邪魔外道等也。三亦多亦正。方可救拔。即十方僧也。四不多不正。居然不可。故无经文。五许以救方

吾今当说救济之法。令一切难皆离忧苦　今当说者。正是许词。救济法者。是所许事。令一切等者。千钧之弩。不独为鼷鼠发机。三界之尊。岂偏令汝母离苦。六示其正法。示正法于中分二。初教孝子献供之法。后教众僧受供之仪。初复有五。一定胜时。二发胜意。三设胜供。四赞胜田。五获胜益。谓自恣日为胜时。如春阳之月孝心为胜意。如精新种子百味五果等为胜供。如好牛犁以之供养。如能耕垦贤圣为胜田。如膏腴之地。存亡父母六亲眷属。乃至七代离苦生天为胜益。如千箱万斛秋收冬藏。经文意势。岂不然乎。智者详之。如指其掌。初教孝子献供法(五)。一定胜时

佛告目连十方众僧七月十五日僧自恣时　梵语僧伽。此云众和合。谓若众而不和。如群商群吏及军众等。不名僧宝。若和而不众。如二人同心之类。亦非僧宝。众而和合为福之因。方名僧宝。和合者。此有六种。谓身和同。事语和同。默意和同。忍戒和同。修见和同。解利和同均也。儒说小人君子。或和或同。今释子比丘和而同也。今云十方者。法无限局岂隔亲疏。众僧者。唐梵重标译人之拙。七月十五日者。前三月夏安居竟故可自恣。自恣有三日。或十四十五十六。今举中间也。此剩僧字。去之又句阙。亦是译人之失也。何不云共自恣时。自恣者。自己之过恣他所举。谓一夏安居九旬加行。不阶四果亦得四禅。佛设教门本意如此。正像末法僧等皆然。虽后五百岁。亦有持戒修福者故。然将超苦海谨护浮囊。犹恐当局者迷。必藉旁观得失。纵不断惑证果。还希罪灭福生故。褊袒于众中白大德长老。或见我过。或闻我罪。或疑我犯。恣任所举。哀愍语我。我当忏悔。如此则身心清净。犹如琉璃。禅定解脱或有之矣。供养此者力用可知。岂不拔济先亡资熏现在。故三藏云。比丘受岁之日。大众自恣之时。僧多获道于四果。故能济厄于七代。二发胜意

当为七世父母及现在父母厄难中者　当为者。能救之心。七世下所救之境。约境明心故云胜也。七世者。所生父母。不同儒教取上代祖宗。厄难中者。通于存殁。殁则地狱鬼畜。存则病痛枷禁。皆名厄难。七世父母虽似转疏。皆是生我修道之器。既蒙鞠育岂负深恩。故三藏云。天地覆载。既无惮于劬劳。幽显沉沦。理合答于罔极。三设胜供

具饭百味五果汲灌盆器香油锭烛床敷卧具。尽世甘美以着盆中供养十方大德众僧　具饭百味者。总标也。如人盛馔盘筵邀命宾客唯云吃饭。故饭为总统于百味。百者大数非定一百。五果者。一核果。如枣杏桃李等。二肤果。如瓜梨柰椹等。三壳果。如胡桃石榴等。四糩果。如苏荏等。五角果。如菱豆等。上皆舌所尝也。汲灌盆器者。沐浴等所用。并下床敷卧具。皆身所觉也。香者鼻所嗅也。油锭烛者昭燎等。用眼所见也。亦可香油涂身。亦属身摄。西域如此。尽世甘美者。亦属舌也。上来于五欲境中唯阙声也。尽世之言。详其意趣。有二种尽。谓富贵则尽世所有。有即须求。贫贱则尽力所及。及则须觅。即知不定少多之物。但在竭尽其心。亦类彼享于克诚馨于明德也。着盆中者。译经讹错。如何床等可置盆中。应云着盂兰盆供会之中也。供养二句者。正明行也。据经本意。但以可受用物。供养大德之僧。不必雕镂金玉剪割缯彩高耸栏架等也。故三藏云。汝须物华四事盆美八珍。历十方而运想。澄一心而供养。四赞胜田

当此之日一切圣众。或在山间禅定。或得四道果。或在树下经行。或六通自在。教化声闻缘觉。或十地菩萨大人权现比丘在大众中。皆同一心受钵和罗饭。具清净戒圣众之道。其德汪洋　初二句约人赞时而总标。末二句以威仪赞人而总结。中间人法有其五对。但文不次。谓处有山间树下对。证有四果六通对。行有自利利他对。学者戒定对。人有大小对。亦名权实对。又总束之不出人法。谓三学三乘对也。从初至四果禅定也。次从或在下至自在教化智慧也。皆同下三句净戒也。三乘即声闻缘觉十地大人也。皆同一心是意和合。谓受供时皆同运惭愧殷重心慈悲报恩救济心。人虽位有凡圣德有优劣。而所运心一而无异。故云同也。受钵和罗饭者。钵中饭也。梵云钵多罗。此云应量器。和字讹也。今时但云钵者略也。经题云盆。即是钵也。译时随俗。题之云盆。盆之与钵皆是器故。故三藏释题翻为救器。此一句经正明自恣大德受盂兰盆供也。五获胜益

其有供养此等自恣僧者。现世父母六亲眷属。得出三涂之苦。应时解脱衣食自然。若父母现在者。福乐百年。若七世父母生天。自在化生入天华光　此一唱经有两节意。初一半者。蒙悲愿之力而离苦。后一半者。蒙慈愿之力而得乐。乐中有存亡之异。初云此等自恣僧者。指前五对所说也。现世父母者。生此身父母也。非谓未亡名为现世。故指得益云出三涂。其现在未亡之父母下。自有文云福乐百年是也。不应重举三藏错会。故作异释甚非文意。六亲者。父母兄弟夫妻。眷属者。一切姻戚通于表里。出三涂解脱者。总名离苦也。衣食自然者。且翻三涂生于人天。故属拔苦之文。亦可得乐属于后也。若父母下明存亡得乐。文相可知。天华光者。天上妙华光明也。略指快乐之相矣。二教众僧受供养仪

时佛敕十方众僧。皆先为施主家咒愿。愿七世父母。行禅定意然后受食。初受食时先安在佛前塔寺中佛前。众僧咒愿竟便自受食　此中前半净三业。后半具三宝。前中咒愿口业。禅定意业。受食身业。后中塔前是佛。咒愿是法。受食是僧。从他受而后食。法律如此。即受字亦属法也。塔者边国讹语。正云窣堵波。此云高显处。此中意通殿塔。塔安舍利。殿安佛像。七孝子领悟

时目连比丘及大菩萨众。皆大欢喜。目连悲啼泣声释然除灭　净业既成必知离苦。观因验果声响不差。故喜而止啼也。如处世刑狱嘱大力人。财赌既行其心已喜。八慈母获益

时目连母。即于是日得脱一劫饿鬼之苦　目连闻经且是受教施设盆供。合在余时。今说经次。便云脱饿鬼者。译经阙略也。应于正宗终处叙结集家文云。尔时目连闻是。是法已至七月十五。施设盆供。供自恣僧已。其母即于是日得脱一劫饿鬼之苦。则文义俱显矣。故三藏云。孝子既献供于此晨。慈母乃除殃于是日。大哉圣力速疾如斯。其饿鬼受苦年劫时分待检叙之。三流通分。流通分有三。一申请。二赞请。三答请。一申请

目连复白佛言。弟子所生母。得蒙三宝功德之力众僧威神之力故。若未来世一切佛弟子。亦应奉盂兰盆救度现在父母乃至七世父母。可为尔不　说此语时。亦是设供之后。非一席之事。至毕钵罗窟。方始总集为经也。目连爱其亲而及他人。如颍考叔谏庄公也。二赞请

佛言。大善快问。我正欲说。汝今复问　初句标赞大善快问者。深契圣心。后二句释所以。以正欲说即遇问词。机感相投潜通密应。故言快问。佛本意者。欲说孝道最大故。拔苦事重故。盂兰法胜故。世尊睹众胜缘机熟可教化故。三答请(五)。一教起行

善男子。若比丘比丘尼。国王太子大臣宰相三公百官万民庶人行慈孝者。皆应先为所生现在父母过去七世父母。于七月十五日佛欢喜日僧自恣日。以百味饭食安盂兰盆中。施十方自恣僧　虽贵贱品隔僧浴道殊。自非化生湿生。无不有父有母。慈乌鹦鹉尚解思恩。岂况人伦而不济拔。孝之利害已具玄谈。既识是非须依正道。故云应先为所生等也。据制令必为。不为即是违制。故亦当于制教。是以前判亦属律藏。然佛无悲喜。今于此日示现欢喜者。应机缘也。以佛本出世只为劝人修行。见人造恶则悲。见人修善则喜。今比丘九旬加行日满倍更恳诚。三千界中皆同如此称佛本意。宁不欣欢。此日设供其福甚矣。二教发愿

愿使现在父母寿命百年无病。无一切苦恼之患。乃至七世父母离饿鬼苦。生人天中福乐无极　所修必假行门。所获必繇心愿。愿者心之乐欲。欲得存殁咸安。存者保寿于人间。常无病恼。殁者迁神于天上。永绝冥涂。行愿相资。无所不利。三教常作

是佛弟子修孝顺者。应念念中常忆父母。乃至七世父母。年年七月十五日。常以孝慈忆所生父母。为作盂兰盆施佛及僧。以报父母长养慈爱之恩　是佛弟子修孝顺者。反明非佛弟子及不孝顺。孝即任不设盆供也。念念常忆者无终始也。长养是事。慈爱是心。故前起行及发心愿以报之也。余文可解。三藏云。父母结爱。既念念不去心。孝子报恩。须年年不绝供。四劝受持

若一切佛弟子。应当奉持是法　智度论云。信力故受。念力故持。今云奉者。即受之义。应当者。勖此二力。五喜而奉命

时目连比丘四辈弟子。欢喜奉行　四辈者。僧尼士女。或云。人天龙鬼。疑故两存。然凡厥生灵皆依恃怙。故父母恩均于天地。此虽至孝不得其门。今受神方信知灵验。必能除七世之厄难。报二亲之劬劳。自知心有所之。是以欢喜承命

佛说盂兰盆经疏下终

盂兰经疏。唐圭峰禅师。会孝道要言以注经。广明释门真孝。令学者得报亲之方。不落异解傍岐。入佛最上乘也。故历代高僧。于自恣日诱诸缁素。设盂兰会作度亲筏。实遵此经疏耳。庆与徐序东孝廉结弘法会集。诸宰官居士续梓方册。三百卷目中。适此疏未镌。李太仆捐资镂板。余检阅南北藏。文句不同。今依云栖大师定本刻之。大师分科节目别出手眼。但南北较讹多不能书。谨跋数语。令观者不独识文句异同。或因指见月。得佛大孝报恩之旨。是所愿矣　贵州赤水雪山沙门继庆跋

    疏主传略(案孝衡钞传灯录二本节要)

终南山圭峰宗密禅师。果州西充县人也。姓何氏。唐建中元年生。髫龀通儒书。冠岁探释典。元和二年将赴贡举。偶造遂州道圆和尚法席。欣然契会。遂求披削。当年进具。传契心印。又遍访名能。广乎知见。著述圆觉华严涅槃金刚起信唯识盂兰盆法界观行愿经等疏钞。并集诸宗禅言。为禅源诠。及酬答书偈议论等。总百余卷。并传于世。文宗太和中。诏入内赐紫。累问法要。朝士倾慕。寻请归山。至会昌元年正月六日。于兴福塔院坐灭。四众哀泣喧野。奉全身于圭峰。茶毗得舍利数十粒。明白润大。藏之石室。世寿六十二。僧腊三十四。宣宗追谥定慧禅师。塔曰青莲。尝有偈云。作有义事。是惺悟心。作无义事。是狂乱心。狂乱随情念。临终被业牵。惺悟不繇情。临终能转业


观经玄义分

    No. 1753 [cf. No. 365]

观经玄义分卷第一

        沙门善导集记

先劝大众发愿归三宝

  道俗时众等　　各发无上心
  生死甚难厌　　佛法复难欣
  共发金刚志　　横超断四流
  愿入弥陀界　　归依合掌礼
  世尊我一心　　归命尽十方
  法性真如海　　报化等诸佛
  一一菩萨身　　眷属等无量
  庄严及变化　　十地三贤海
  时劫满未满　　智行圆未圆
  正使尽未尽　　习气亡未亡
  功用无功用　　证智未证智
  妙觉及等觉　　正受金刚心
  相应一念后　　果德涅槃者
  我等咸归命　　三佛菩提尊
  无碍神通力　　冥加愿摄受
  我等咸归命　　三乘等贤圣
  学佛大悲心　　长时无退者
  请愿遥加备　　念念见诸佛
  我等愚痴身　　旷劫来流转
  今逢释迦佛　　末法之遗迹
  弥陀本誓愿　　极乐之要门
  定散等回向　　速证无生身
  我依菩萨藏　　顿教一乘海
  说偈归三宝　　与佛心相应
  十方恒沙佛　　六通照知我
  今乘二尊教　　广开净土门
  愿以此功德　　平等施一切
  同发菩提心　　往生安乐国

此观经一部之内。先作七门料简。然后依文释义。第一先标序题。第二次释其名。第三依文释义并辨宗旨不同教之大小。第四正显说人差别。第五料简定散二善通别有异。第六和会经论相违。广施问答释去疑情。第七料简韦提闻佛正说得益分齐

第一先标序题者。窃以真如广大。五乘不测其边。法性深高。十圣莫穷其际。真如之体量量性不出蠢蠢之心。法性无边边体则元来不动。无尘法界凡圣齐圆。两垢如如则普该于含识。恒沙功德寂用湛然。但以垢障覆深。净体无由显照。故使大悲隐于西化。惊入火宅之门洒甘露润于群萌。辉智炬则朗重昏于永夜。三檀等备。四摄齐收。开示长劫之苦因。悟入永生之乐果。不谓群迷性隔乐欲不同。虽无一实之机。等有五乘之用。致使布慈云于三界。注法雨于大悲。莫不等洽尘劳。普沾未闻之益。菩提种子藉此以抽心。正觉之芽念念因兹增长。依心起于胜行。门余八万四千。渐顿则各称所宜。随缘者则皆蒙解脱。然众生障重。取悟之者难明。虽可教益多门。凡惑无由遍揽。遇因韦提致请我今乐欲往生安乐。唯愿如来教我思惟教我正受。然娑婆化主因其请故即广开净土之要门。安乐能人显彰别意之弘愿。其要门者。即此观经定散二门是也。定即息虑以凝心。散即废恶以修善。回斯二行求愿往生也。言弘愿者。如大经说。一切善恶凡夫得生者莫不皆乘阿弥陀佛大愿业力为增上缘也。又佛密意弘深。教门难晓。三贤十圣弗测所窥。况我信外轻毛敢知旨趣。仰惟释迦此方发遣。弥陀即彼国来迎。彼唤此遣。岂容不去也。唯可勤心奉法毕命为期。舍此秽身。即证彼法性之常乐。此即略标序题竟

第二次释名者。经言佛说无量寿观经一卷。言佛者。乃是西国正音。此土名觉。自觉觉他觉行穷满。名之为佛。言自觉者。简异凡夫。此由声闻狭劣唯能自利阙无利他大悲故。言觉他者。简异二乘。此由菩萨有智故能自利。有悲故能利他。常能悲智双行不著有无也。言觉行穷满者。简异菩萨。此由如来智行已穷时劫已满出过三位故名为佛。言说者。口音陈唱故名为说。又如来对机说法多种不同。渐顿随宜。隐彰有异。或六根通说。相好亦然。应念随缘。皆蒙证益也。言无量寿者。乃是此地汉音。言南无阿弥陀佛者。又是西国正音。又南者是归。无者是命。阿者是无。弥者是量。陀者是寿。佛者是觉。故言归命无量寿觉。此乃梵汉相对其义如此。今言无量寿者是法。觉者是人。人法并彰故名阿弥陀佛。又言人法者是所观之境。即有其二。一者依报。二者正报。就依报中即有其三。一者地下庄严。即一切宝幢光明互相映发等是。二者地上庄严。即一切宝地池林宝楼宫阁等是。三者虚空庄严。即一切变化宝宫华网宝云化鸟风光动发声乐等是。如前虽有三种差别。皆是弥陀净国无漏真实之胜相。此即总结成依报庄严也。又言依报者。从日观下至华座观已来总明依报。就此依报中即有通有别。言别者。华座一观是其别依。唯属弥陀佛也。余上六观是其通依。即属法界之凡圣。但使得生者共同受用故言通也。又就此六中即有真有假。言假者。即日想水想冰想等是其假依。由是此界中相似可见境相故。言真依者。即从琉璃地下至宝楼观已来是其真依。由是彼国真实无漏可见境相故。二就正报中亦有其二。一者主庄严。即阿弥陀佛是。二者圣众庄严。即现在彼众及十方法界同生者是。又就此正报中亦有通有别。言别者。即阿弥陀佛是也。即此别中亦有真有假。言假正报者。即第八像观是也。观音势至等亦如是。此由众生障重染惑处深。佛恐乍想真容无由显现。故使假立真像以住心想。同彼佛以证境故言假正报也。言真正报者。即第九真身观是也。此由前假正。渐以息于乱想心眼得开。粗见彼方清净二报种种庄严以除昏惑。由除障故得见彼真实之境相也。言通正报者。即观音圣众等已下是也。向来所言通别真假者。正明依正二报也。言观者照也。常以净信心手以持智慧之辉。照彼弥陀正依等事。言经者经也。经能持纬。得成匹丈有其丈用。经能持法理事相应。定散随机义不零落。能令修趣之者必藉教行之缘因乘愿往生证彼无为之法乐。既生彼国更无所畏。长时起行果极菩提。法身常住比若虚空。能招此益故曰为经。言一卷者。此观经一部虽言两会正说。总成斯一故名一卷。故言佛说无量寿观经一卷。此即释其名义竟

三辩释宗旨不同教之大小者。如维摩经以不思议解脱为宗。如大品经以空慧为宗。此例非一。今此观经即以观佛三昧为宗。亦以念佛三昧为宗。一心回愿往生净土为体。言教之大小者。问曰。此经二藏之中何藏摄。二教之中何教收。答曰。今此观经菩萨藏收。顿教摄

四辩说人差别者。凡诸经起说不过五种。一者佛说。二者圣弟子说。三者天仙说。四者鬼神说。五者变化说。今此观经是佛自说。问曰。佛在何处说。为何人说。答曰。佛在王宫为韦提等说

五料简定散两门即有其六。一明能初言即是韦提。二明所请者即是世尊。三明能说者即是如来。四明所说即是定散二善十六观门。五明能为即是如来。六明所为即韦提等是也。问曰。定散二善因谁致请。答曰。定善一门韦提致请。散善一门是佛自说。问曰。未审。定散二善出在何文。今既教备不虚。何机得受。答曰。解有二义。一者谤法与无信八难及非人此等不受也。斯乃朽林硕石不可有生润之期。此等众生必无受化之义。除斯已外一心信乐求愿往生。上尽一形下收十念。乘佛愿力莫不皆往。此即答上何机得受义竟。二出在何文者即有通有别。言通者即有三义不同。何者。一从韦提白佛唯愿为我广说无忧恼处者。即是韦提标心自为通请所求。二从唯愿佛日教我观于清净业处者。即是韦提自为通请去行。三从世尊光台现国。即是酬前通请为我广说之言。虽有三义不同。答前通竟。言别者则有二义。一从韦提白佛我今乐生极乐世界弥陀佛所者。即是韦提自为别选所求。二从唯愿教我思惟教我正受者。即是韦提自为请修别行。虽有二义不同。答上别竟。从此已下次答定散两门之义。问曰。云何名定善。云何名散善。答曰。从日观下至十三观已来名为定善。三福九品名为散善。问曰。定善之中有何差别。出在何文。答曰。出何文者。经言教我思惟教我正受即是其文。言差别者即有二义。一谓思惟。二谓正受。言思惟者。即是观前方便。思想彼国依正二报总别相也。即地观文中说言如此想者名为粗见极乐国土。即合上教我思惟一句。言正受者。想心都息缘虑并亡。三昧相应名为正受。即地观文中说言若得三昧见彼国地了了分明。即合上教我正受一句。定散虽有二义不同。总答上问竟。又向来解者与诸师不同。诸师将思惟一句用合三福九品以为散善。正受一句用通合十六观以为定善。如斯解者将谓不然。何者。如华严经说。思惟正受者但是三昧之异名。与此地观文同。以斯文证。岂得通于散善。又向来韦提上请但言教我观于清净业处。次下又请言教我思惟正受。虽有二请。唯是定善。又散善之文都无请处。但是佛自开。次下散善缘中说云亦令未来世一切凡夫已下即是其文

六和会经论相违。广施问答释去疑情者。就此门中即有其六。一先就诸法师解九品之义。二即以道理来破之。三重举九品返对破之。四出文来证定为凡夫不为圣人。五会通别时之意。六会通二乘种不生之义

请者诸师解者。先举上辈三人。言上上者是四地至七地已来菩萨。何故得知。由到彼即得无生忍故。上中者是初地至四地已来菩萨。何故得知。由到彼经一小劫得无生忍故。上下者是种性以上至初地已来菩萨。何故得知。由到彼经三小劫始入初地故。此三品人皆是大乘圣人生位。次举中辈三人者。诸师云。中上是三果人。何以得知。由到彼即得罗汉故。中中者是内凡。何以得知。由到彼得须陀洹故。中下者是世善凡夫。厌苦求生。何以得知。由到彼经一小劫得罗汉果故。此之三品唯是小乘圣人等也。下辈三人者是大乘始学凡夫随过轻重分为三品。共同一位求愿往生者。未必然也。可知

第二即以道理来破者。上言初地至七地已来菩萨者。如华严经说。初地已上七地已来。即是法性生身变易生身。斯等曾无分段之苦。论其功用。已经二大阿僧祇劫。双修福智人法两空。并是不可思议。神通自在转变无方。身居报土常闻报佛说法。悲化十方须臾遍满。更忧何事乃藉韦提为其请佛求生安乐国也。以斯文证。诸师所说岂非错也。答上二竟。上下者。上言从种性至初地已来者。未必然也。如经说。此等菩萨名为不退。身居生死。不为生死所染。如鹅鸭在水水不能湿。如大品经说。此位中菩萨由得二种真善知识守护故不退。何者。一是十方诸佛二是十方诸大菩萨。常以三业外加于诸善法无有退失。故名不退位也。此等菩萨亦能八相成道教化众生。论其功行。已经一大阿僧祇劫。双修福智等既有斯胜德。更忧何事乃藉韦提请求生也。以斯文证。故知诸师所判还成错也。此责上辈竟。次责中辈三人者。诸师云中上是三果者。然此等之人三涂永绝四趣不生。现在虽造罪业。必定不招来报。如佛说言。此四果人与我同坐解脱床。既有斯功力。更复何忧乃藉韦提请求生路。然诸佛大悲于苦者。心偏愍念常没众生。是以劝归净土。亦如溺水之人急须偏救。岸上之者何用济为。以斯文证。故知诸师所判义同前错也。以下可知

第三重举九品返对破者。诸师云上品上生人是四地至七地已来菩萨者。何故观经云。三种众生当得往生。何者为三。一者但能持戒修慈。二者不能持戒修慈。但能读诵大乘。三者不能持戒读经。唯能念佛法僧等。此之三人各以己业专精励意。一日一夜乃至七日七夜相续不断。各回所作之业求愿往生。命欲终时。阿弥陀佛及与化佛菩萨大众放光授手。如弹指顷即生彼国。以此文证。正是佛去世后大乘极善上品凡夫日数虽少作业时猛。何得判同上圣也。然四地七地已来菩萨论其功用不可思议。岂藉一日七日之善华台授手迎接往生也。此即返对上上竟。次对上中者。诸师云是初地四地已来菩萨者。何故观经云。不必受持大乘。云何名不必。或读不读故名不必。但言善解未论其行。又言深信因果。不谤大乘。以此善根回愿往生。命欲终时。阿弥陀佛及与化佛菩萨大众一时授手即生彼国。以此文证。亦是佛去世后大乘凡夫行业稍弱。致使终时迎候有异。然初地四地已来菩萨论其功用如华严经说。乃是不可思议。岂藉韦提致请方得往生也。返对上中竟。次对上下者。诸师云是种性以上至初地已来菩萨者。何故观经云亦信因果。云何亦信。或信不信故名为亦。又言不谤大乘但发无上道心。唯此一句以为正业。更无余善回斯一行求愿往生。命欲终时。阿弥陀佛及与化佛菩萨大众一时授手即得往生。以斯文证。唯是佛去世后。一切发大乘心众生行业不强。致使去时迎候有异。若论此位中菩萨力势。十方净土随意往生。岂藉韦提为其请佛。劝生西方极乐国也。返对上下竟。即此三品去时有异。云何异。上上去时。佛与无数化佛一时授手。上中去时。佛与千化佛一时授手。上下去时。佛与五百化佛一时授手。直是业有强弱。致使有斯差别耳。次对中辈三人者。诸师云中上是小乘三果者。何故观经云。若有众生受持五戒八戒。修行诸戒不造五逆。无众过患。命欲终时。阿弥陀佛与比丘圣众放光说法来现其前。此人见已即得往生。以此文证。亦是佛去世后持小乘戒凡夫。何小圣也。中中者。诸师云见道已前内凡者。何故观经云。受持一日一夜戒回愿往生。命欲终时。见佛即得往生。以此文证。岂得言是内凡人也。但是佛去世后无善凡夫命延日夜逢遇小缘授其小戒。回愿往生。以佛愿力即得生也。若论小圣。去亦无妨。但此观经佛为凡说。不于圣也。中下者。诸师云小乘内凡已前世俗凡夫唯修世福求出离者。何故观经云。若有众生孝养父母行世仁慈。命欲终时。遇善知识为说彼佛国土乐事四十八愿等。此人闻已即生彼国。以此文证。但是不遇佛法之人虽行孝养亦未有心希求出离。直是临终遇善劝令往生。此人因劝回心即得往生。又此人在世自然行孝。亦不为出离故行孝道也。次对下辈三人者。诸师云此等之人乃是大乘始学凡夫。随过轻重分为三品。未有道位。难辨阶降者。将谓不然。何者。此三品人无有佛法世俗二种善根。唯知作恶。何以得知。如下上文说。但不作五逆谤法。自余诸恶悉皆具造无有惭愧乃至一念命欲终时。遇善知识为说大乘。教令称佛一声。尔时阿弥陀佛即遣化佛菩萨来迎此人即得往生。但如此恶人触目皆是。若遇善缘即得往生。若不遇善定入三涂未可出也。下中者。此人先受佛戒。受已不持即便毁破。又偷常住僧物现前僧物。不净说法乃至无有一念惭愧之心。命欲终时。地狱猛火一时俱至现在其前。当见火时。即遇善知识为说彼佛国土功德劝令往生。此人闻已即便见佛。随化往生。初不遇善狱火来迎。后逢善故化佛来迎。斯乃皆是弥陀愿力故也。下下者。此等众生作不善业五逆十恶。具诸不善。此人以恶业故定堕地狱多劫无穷。命欲终时。遇善知识教称阿弥陀佛劝令往生。此人依教称佛乘念即生。此人若不遇善必定下沉。由终遇善七宝来迎。又看此观经定善及三辈上下文意。总是佛去世后五浊凡夫。但以遇缘有异。致令九品差别。何者。上品三人是遇大凡夫。中品三人是遇小凡夫。下品三人是遇恶凡夫。以恶业故临终藉善。乘佛愿力。乃得往生。到彼华开方始发心。何得言是始学大乘人也。若作此见。自失误他。为害兹甚。今以一一出文显证。欲使今时善恶凡夫同沾九品。生信无疑。乘佛愿力悉得生也

第四出文显证者。问曰。上来返对之义云何得知。世尊定为凡夫不为圣人者。未审。直以人情准义为当。亦有圣教来证。答曰。众生垢重智慧浅近。圣意弘深。岂宁自辄。今者一一悉取佛说以为明证。就此证中即有其十句。何者。第一如观经云。佛告韦提。我今为汝广说众譬。亦令未来世一切凡夫欲修净业者得生西方极乐国土者。是其一证也。二言如来今者为未来世一切众生为烦恼贼之所害者说清净业者。是其二证也。三言如来今者教韦提希及未来世一切众生观于西方极乐世界者。是其三证也。四言韦提白佛。我今因佛力故见彼国土。若佛灭后诸众生等浊恶不善五苦所逼。云何当见彼佛国土者。是其四证也。五如日观初云。佛告韦提汝及众生专念已下乃至一切众生自非生盲有目之徒见日已来者。是其五证也。六如地观中说言。佛告阿难。汝持佛语。为未来世一切众生欲脱苦者说是观地法者。是其六证也。七如华座观中说言。韦提白佛。我因佛力得见阿弥陀佛及二菩萨。未来众生云何得见者。是其七证也。八次下答请中说言。佛告韦提。汝及众生欲观彼佛者当起想念者。是其八证也。九如像观中说言。佛告韦提。诸佛如来入一切众生心想中。是故汝等心想佛时者。是其九证也。十如九品之中一一说言为诸众生者。是其十证也。上来虽有十句不同。证明如来说此十六观法但为常没众生。不于大小圣也。以斯文证。岂是谬哉

第五会通别时意者。即有其二。一论云。如人念多宝佛。即于无上菩提得不退堕者。凡言菩提乃是佛果之名。亦是正报。道理成佛之法要须万行圆备方乃克成。岂将念佛一行即望成者。无有是处。虽言未证。万行之中是其一行。何以得知。如华严经说。功德云比丘语善财言。我于佛法三昧海中唯知一行。所谓念佛三昧。以此文证。岂非一行也。虽是一行。于生死中乃至成佛永不退没。故名不堕。问曰。若尔者。法华经云。一称南无佛皆已成佛道。亦应成佛竟也。此之二文有何差别。答曰。论中称佛唯欲自成佛果。经中称佛为简异九十五种外道。然外道之中都无称佛之人。但使称佛一口即在佛道中摄。故言已竟。二论中说云。如人唯由发愿生安乐土者。久来通论之家不会论意。错引下品下生十声称佛。与此相似。未即得生。如一金钱得成千者。多日乃得。非一日即得成千。十声称佛亦复如是。但与远生作因。是故未即得生。道佛直为当来凡夫。欲令舍恶称佛。诳言道生。实未得生。名作别时意者。何故阿弥陀经云。佛告舍利弗。若有善男子善女人。闻说阿弥陀佛。即应执持名号。一日乃至七日一心愿生。命欲终时。阿弥陀佛与诸圣众迎接往生。次下十方各如恒河沙等诸佛各出广长舌相。遍覆三千大千世界说诚实言。汝等众生。皆应信是一切诸佛所护念经。言护念者。即是上文一日乃至七日称佛之名也。今既有斯圣教以为明证。未审。今时一切行者不知何意凡小之论乃加信受。诸佛诚言返将妄语。苦哉奈剧能出如此不忍之言。虽然仰愿一切欲往生知识等善自思量。宁伤今世错信佛语不可执菩萨论以为指南。若依此执者。即是自失误他也。问曰。云何起行而言不得往生。答曰。若欲往生者。要须行愿具足方可得生。今此论中但言发愿不论有行。问曰。何故不论答曰。乃至一念曾未措心。是故不论。问曰。愿行之义有何差别。答曰。如经中说。但有其行行即孤亦无所至。但有其愿愿即虚亦无所至。要须愿行相扶所为皆克。是故今此论中直言发愿不论有行。是故未即得生与远生作因者。其义实也。问曰。愿意云何乃言不生。答曰。闻他说言西方快乐不可思议。即作愿言我亦愿生。导此语已更不相续。故名愿也。今此观经中十声称佛即有十愿十行具足。云何具足。言南无者即是归命。亦是发愿回向之义。言阿弥陀佛者即是其行。以斯义故必得往生。又来论中称多宝佛为求佛果即是正报。下唯发愿求生净土即是依报。一正一依。岂得相似。然正报难期。一行虽精未克。依报易求。所以一愿之心未入。虽然。譬如边方投化即易为主即难。今时愿往生者并是一切投化众生。岂非易也。但能上尽一形下至十念。以佛愿力莫不皆往。故名易也。斯乃不可以言定义。取信之者怀疑。要引圣教来明。欲使闻之者方能遣惑

第六会通二乘种不生义者。问曰。弥陀净国为当是报是化也。答曰。是报非化。云何得知。如大乘同性经说。西方安乐阿弥陀佛是报佛报土。又无量寿经云。法藏比丘在世饶王佛所行菩萨道时。发四十八愿。一一愿言。若我得佛。十方众生称我名号。愿生我国。下至十念。若不生者不取正觉。今既成佛。即是酬因之身也。又观经中上辈三人临命终时皆言阿弥陀佛及与化佛来迎此人。然报身兼化共来授手。故名为与。以此文证故知是报。然报应二身者眼目之异名。前翻报作应。后翻应作报。凡言报者。因行不虚定招来果。以果应因故名为报。又三大僧祇所修万行必定应得菩提。今既道成。即是应身。斯乃过现诸佛辨立三身。除斯已外更无别体。纵使无穷八相名号尘沙。克体而论。众归化摄。今彼弥陀现是报也。问曰。既言报者。报身常住永无生灭。何故观音授记经说阿弥陀佛亦有入涅槃时。此之一义若为通释。答曰。入不入义者唯是诸佛境界。尚非三乘浅智所窥。岂况小凡辄能知也。虽然。必欲知者。敢引佛经以为明证。何者。如大品经涅槃非化品中说云。佛告须菩提。于汝意云何。若有化人作化人。是化颇有实事不空者不。须菩提言。不也世尊。佛告须菩提。色即是化。受想行识即是化。乃至一切种智即是化。须菩提白佛言。世尊。若世间法是化。出世间法亦是化。所谓四念处．四正勤．四如意足．五根．五力．七觉分．八圣道分．三解脱门．佛十力．四无所畏．四无碍智．十八不共法．并诸法果．及贤圣人．所谓须陀洹．斯陀含．阿那含．阿罗汉．辟支佛．菩萨摩诃萨．诸佛世尊。是法亦是化不。佛告须菩提。一切法皆是化。于是法中有声闻法变化。有辟支佛法变化。有菩萨法变化。有诸佛法变化。有烦恼法变化。有业因缘法变化。以是因缘故。须菩提。一切法皆是化。须菩提白佛言。世尊。是诸烦恼断。所谓须陀洹果．斯陀含果．阿那含果．阿罗汉果．辟支佛道．断诸烦恼习。皆是变化不。佛告须菩提。若有法生灭相者皆是变化。须菩提言。世尊。何等法非变化。佛言。若法无生无灭是非变化。须菩提言。何等是不生不灭非变化。佛言。无诳相涅槃是法非变化。世尊。如佛自说。诸法平等非声闻作。非辟支佛作。非诸菩萨摩诃萨作。非诸佛作。有佛无佛诸法性常空。性空即是涅槃。云何涅槃一法非如化。佛告须菩提。如是如是。诸法平等非声闻所作乃至性空即是涅槃。若新发意菩萨闻是一切法皆毕竟性空乃至涅槃亦皆如化者心则惊怖。为是新发意菩萨故。分别生灭者如化不生不灭者不如化耶。今既以斯圣教验知弥陀定是报也。纵使后入涅槃。其义无妨。诸有智者应知。问曰。彼佛及土既言报者。报法高妙。小圣难阶。垢障凡夫云何得入。答曰。若论众生垢障。实难欣趣。正由托佛愿以作强缘。致使五乘齐入。问曰。若言凡夫小圣得生者。何故天亲净土论云女人及根缺二乘种不生。今彼国中现有二乘。如斯论教若为消释。答曰。子但诵其文不窥理。况加以封拙怀迷无由启悟。今引佛教以为明证。却汝疑情。何者。即观经下辈三人是也何以得知。如下品上生云。或有众生。多造恶法。无有惭愧。如此愚人命欲终时。遇善知识为说大乘。教令称阿弥陀佛。当称佛时。化佛菩萨现在其前。金光华盖迎还彼土。华开已后观音为说大乘。此人闻已即发无上道心。问曰。种之与心有何差别。答曰。但以取便而言。义无差别。当华开之时。此人身器清净正堪闻法。亦不简大小。但使得闻即便生信。是以观音不为说小。先为说大。闻大欢喜即发无上道心。即名大乘种生。亦名大乘心生。又当华开时。观音先为说小乘者。闻小生信。即名二乘种生。亦名二乘心生。此品既尔。下二亦然。此三品人俱在彼发心。正由闻大即大乘种生。由不闻小故。所以二乘种不生。凡言种者即是其心也。上来解二乘种不生义竟。女人及根缺义者。彼无故可知。又十方众生修小乘戒行愿往生者。一无妨碍悉得往生。但到彼先证小果。证已即转向大。一转向大以去更不退生二乘之心。故名二乘种不生。前解就不定之始。后解就小果之终也。应知

第七料简韦提闻佛正说得益分齐者。问曰。韦提既言得忍。未审。何时得忍。出在何文。答曰。韦提得忍出在第七观初。经云。佛告韦提。佛当为汝分别解说除苦恼法。说是语时。无量寿佛住立空中。观音势至侍立左右。时韦提应时得见。接足作礼。欢喜赞叹即得无生法忍。何以得知。如下利益分中说言。得见佛身及二菩萨。心生欢喜。叹未曾有。廓然大悟得无生忍。非是光台中见国时得也。问曰。上文中说言。见彼国土极妙乐事。心欢喜故应时即得无生法忍。此之一义云何通释。答曰。如此义者但是世尊酬前别请举劝利益方便之由序。何以得知。次下文中说言。诸佛如来有异方便令汝得见。次下日想水想冰想乃至十三观已来尽名异方便也。欲使众生于此观门一一得成。见彼妙事心欢喜故即得无生。斯乃直是如来慈哀末代举劝励修。欲令积学之者无遗圣力冥加现益故也

证曰。掌握机糸十有三结。条条顺理以应玄门讫。此义周三呈前证者矣。上来虽有七段不同。总是文前玄义。料简经论相违妨难。一一引教证明。欲使信者无疑求者无滞。应知

观经玄义分卷第一观经序分义卷第二

        沙门善导集记

从此以下就文料简。略作五门明义。一从如是我闻下至五苦所逼云何见极乐世界已来明其序分二从日观初句佛告韦提汝及众生下至下品下生已来明正宗分。三从说是语时下至诸天发心已来正明得益分。四从阿难白佛下至韦提等欢喜已来明流通分。此之四义佛在王宫一会正说。五从阿难为耆阇大众传说复是一会。亦有三分。一从尔时世尊足步虚空还耆阇崛山已来明其序分。二从阿难广为大众说如上事已来明正宗分。三从一切大众欢喜奉行已来明流通分。然化必有由。故先明序。由序既兴正陈所说。次明正宗。为说既周。欲以所说传持末代叹胜劝学。后明流通。上来虽有五义不同。略料简序正流通义竟

又就前序中复分为二。一从如是我闻一句名为证信序。二从一时下至云何见极乐世界已来正明发起序。初言证信者即有二义。一谓如是二字即总标教主。能说之人。二谓我闻两字即别指阿难。能听之人。故言如是我闻。此即双释二意也。又言如是者即指法定散两门也。是即定辞。机行必益。此明如来所说言无错谬故名如是。又言如者如众生意也。随心所乐佛即度之。机教相应复称为是。故言如是。又言如是者。欲明如来所说。说渐如渐。说顿如顿。说相如相。说空如空。说人法如人法。说天法如天法。说小如小。说大如大。说凡如凡。说圣如圣。说因如因。说果如果。说苦如苦。说乐如乐。说远如远。说近如近。说同如同。说别如别。说净如净。说秽如秽。说一切诸法千差万别。如来观知历历了然。随心起行。各益不同。业果法然众无错失。又称为是。故言如是。言我闻者。欲明阿难是佛侍者。常随佛后多闻广识。身临座下能听能持教旨亲承。表无传说之错。故曰我闻也。又言证信者。欲明阿难禀承佛教传持末代。为对众生故如是观法我从佛闻。证诚可信。故名证信序。此就阿难解也

二就发起序中细分为七。初从一时佛在下至法王子而为上首已来明化前序。二从王舍大城下至颜色和悦已来正明发起序禁父之缘。三从时阿阇世下至不令复出已来明禁母缘。四从时韦提希被幽闭下至共为眷属已来明厌苦缘。五从唯愿为我广说下至教我正受已来明其欣净缘。六从尔时世尊即便微笑下至净业正因已来明散善显行缘。七从佛告阿难等谛听下至云何得见极乐国土已来正明定善示观缘。上来虽有七段不同。广料简发起序竟

二次解化前序者。就此序中即有其四。初言一时者正明起化之时。佛将说法。先托于时处。但以众生开悟必藉因缘。化主临机待于时处。又言一时者。或就日夜十二时。年月四时等。此皆是如来应机摄化时也。言处者随彼所宜如来说法。或在山林处。或在王宫聚落处。或在旷野冢间处。或在多少人天处。或在声闻菩萨处。或在八部人天王等处。或在纯凡若多一二处。或在纯圣若多一二处。随其时处如来观知不增不减。随缘授法各益所资。斯乃洪钟虽响必待扣而方鸣。大圣垂慈必待请而当说。故名一时也。又一时者。阿阇世正起逆时。佛在何处。当此一时。如来独与二众在彼耆阇。此即以下形上意也。故曰一时。又言一时者。佛与二众于一时中在彼耆阇。即闻阿阇世起此恶逆因缘。此即以上形下意也。故曰一时。二言佛者。此即标定化主。简异余佛独显释迦意也。三从在王舍城已下正明如来游化之处。即有其二。一游王城聚落。为化在俗之众。二游耆山等处。为化出家之众。又在家者。贪求五欲相续是常。纵发清心犹如画水。但以随缘普益不舍大悲。道俗形殊无由共住。此名境界住也。又出家者。亡身舍命断欲归真。心若金刚等同圆镜。悕求佛地即弘益自他。若非绝离嚣尘。此德无由可证。此名依止住也。四从与大比丘众下至而为上首已来明佛徒众。就此众中即分为二。一者声闻众。二者菩萨众。就声闻众中即有其九。初言与者。佛身兼众故名为与。二者总大。三者相大。四者众大。五者耆年大。六者数大。七者尊宿大。八者内有实德大。九者果证大。问曰。一切经首皆有此等声闻以为犹置。有何所以。答曰。此有别意。云何别意。此等声闻多是外道。如贤愚经说。优楼频羸迦叶领五百弟子修事邪法。伽耶迦叶领二百五十弟子修事邪法。那提迦叶领二百五十弟子修事邪法。总有一千。皆受佛化得罗汉道。其二百五十者。即是舍利目连弟子。共领一处修事邪法。亦受佛化皆得道果。此等四众合为一处。故有千二百五十人也。问曰。此众中亦有非外道者。何故总标。答曰。如经中说。此诸外道常随世尊不相舍离。然结集之家简取外德。故有异名。是外道者多。非者少。又问曰。未审。此等外道常随佛后。有何意也。答曰。解有二义。一就佛解。二就外道解。就佛解者。此诸外道邪风久扇。非是一生。虽入真门气习由在。故使如来知觉不令外化。畏损众生正见根芽。恶业增长此世后生不收果实。为此因缘摄令自近不听外益。此即就佛解竟。次就外道解者。迦叶等意自唯旷劫久沉生死。修还六道。苦不可言。愚痴恶见封执邪风。不值明师永流于苦海。但以宿缘有遇得会慈尊。法泽无私我曹蒙润。寻思佛之恩德。碎身之极惘然。致使亲事灵仪无由暂替。此即就外道解竟。又问曰。此等尊宿云何名众所知识。答曰。德高曰尊。耆年曰宿。一切凡圣知彼内德过人。识其外相殊异。故名众所知识。上来虽有九句不同。解声闻众竟。次解菩萨众。就此众中即有其七。一者标相。二者标数。三者标位。四者标果。五者标德。六者别显文殊高德之位。七者总结。又此等菩萨具无量行愿。安住一切功德之法。游步十方行权方便。入佛法藏究竟彼岸。于无量世界化成等觉。光明显曜普照十方。无量佛土六种震动。随缘开示即转法轮。扣法鼓执法剑。震法雷雨法雨。演法施常以法音觉诸世间。掴裂邪网消灭诸见。散诸尘劳坏诸欲堑。显明清白光融佛法。宣流正化。愍伤众生未曾慢恣。得平等法具足无量百千三昧。于一念顷无不周遍。荷负群生爱之如子。一切善本皆度彼岸。悉获诸佛无量功德。智慧开朗不可思议。虽有七句不同。解菩萨众讫。上来虽有二众不同。广明化前序竟。

二就禁父缘中即有其七。一从尔时王舍大城以下总明起化处。此明往古百姓但城中造舍。即为天火所烧。若是王家舍宅悉无火近。后时百姓共奏于王。臣等造宅数为天火所烧。但是王舍悉无火近。不知有何所以。王告奏人。自今以后卿等造宅之时。但言我今为王造舍。奏人等各奉王敕。归还造舍更不被烧。因此相传故名王舍。言大城者。此城极大居民九亿。故道王舍大城也。言起化处者即有其二。一谓阇王起恶。即有禁父母之缘。因禁则厌此娑婆。愿托无忧之世界。二则如来赴请。光变为台影现灵仪。夫人即求生安乐。又倾心请行。佛开三福之因。正观即是定门。更显九章之益。为此因缘。故名起化处也。二从有一太子下至恶友之教已来正明阇王恍忽之间信受恶人所误。言太子者彰其位也。言阿阇世者显其名也。又阿阇世者乃是西国正音。此地往翻名未生怨亦名折指。问曰。何故名未生怨及名折指也。答曰。此皆举昔日因缘故有此名。言因缘者。元本父王。无有子息。处处求神竟不能得。忽有相师而奏王言。臣知山中有一仙人。不久舍寿。命终已后必当与王作子。王闻欢喜。此人何时舍命。相师答王。更经三年始可命终。王言。我今年老。国无继祀。更满三年何由可待。王即遣使入山往请仙人曰。大王无子。阙无绍继。处处求神困不能得。乃有相师瞻见大仙。不久舍命与王作子。请愿大仙垂恩早赴。使人受教入山。到仙人所具说王请因缘。仙人报使者言。我更经三年始可命终。王敕即赴者是事不可。使奉仙教还报大王具述仙意。王曰。我是一国之主。所有人物皆归属我。今故以礼相屈。乃不承我意。王更敕使者。卿往重请。请若不得。当即杀之。既命终已。可不与我作子也。使人受敕至仙人所。具道王意。仙人虽闻使说。意亦不受。使人奉敕即欲杀之。仙人曰。卿当语王。我命未尽。王以心口遣人杀我。我若与王作儿者。还以心口遣人杀王。仙人道此语已即受死既死已即托王宫受生。当其日夜夫人即觉有身。王闻欢喜。天明即唤相师以观夫人。是男是女。相师观已而报王言。是儿非女。此儿于王有损。王曰。我之国土皆舍属之纵有所损。吾亦无畏。王闻此语忧喜交怀。王白夫人言。吾共夫人私自平章。相师道儿于吾有损。夫人待生之日。在高楼上。当天井中生之。勿令人承接。落在于地。岂容不死也。吾亦无忧。声亦不露。夫人即可王之计。及其生时一如前法。生已堕地。命便不断。唯损手小指。因即外人同唱言折指太子也。言未生怨者。此因提婆达多起恶妒之心故。对彼太子显发昔日恶缘。云何妒心而起恶缘。提婆恶性为人匈猛。虽复出家恒常妒佛名闻利养。然父王是佛檀越。于一时中多将供养奉上如来。谓金银七宝。名衣上服。百味果食等。一一色色皆五百车。香华伎乐。百千万众赞叹围绕。送向佛会施佛及僧。时调达见已妒心更盛。即向舍利弗所求学身通。尊者语言。人者且学四念处。不须学身通也。既请不遂心。更向余尊者边求。乃至五百弟子等悉无人教。皆遣学四念处。请不得已。遂向阿难边学。语阿难言。汝是我弟。我欲学通。一一次第教我。然阿难虽得初果未证他心。不知阿兄私密学通欲于佛所起于恶计。阿难遂即唤向静处次第教之。跏趺正坐先教将心举身似动想。去地一分一寸想。一尺一丈想。至舍作空无碍想。直过上空中想。还摄心下至本坐处想。次将身举心。初时去地一分一寸等亦如前法。以身举心。以心举身。亦随既至上空已。还摄取身下至本坐处。次想身心合举。还同前法一分一寸等周而复始。次想身心入一切质碍色境中。作不质碍想。次想一切山河大地等色入自身中。如空无碍不见色相。次想自身或大遍满虚空。坐卧自在。或坐或卧。以手捉动日月。或作小身入微尘中。一切皆作无碍想。阿难如是次第教已。时调达既受得法已。即别向静处。七日七夜一心专注即得身通。一切自在皆得成就。既得通已。即向太子殿前。在于空中现大神变。身上出火身下出水。或左边出水右边出火。或现大身或现小身。或坐卧空中。随意自在。太子见已问左右曰。此是何人。左右答太子言。此是尊者提婆。太子闻已心大欢喜。遂即举手唤言。尊者何不下来。提婆既见唤已。即化作婴儿直向太子膝上。太子即抱鸣口弄之。又唾口中。婴儿遂咽之。须臾还复本身。太子既见提婆种种神变。转加敬重。既见太子心敬重已即说父王供养因缘。色别五百乘车载向佛所奉佛及僧。太子闻已即语尊者。弟子亦能备具色各五百车。供养尊者及施众僧。可不如彼也。提婆言。太子此意大善。自此已后大得供养心转高慢。譬如以杖打恶狗鼻转增狗恶。此亦如是。太子今将利养之杖打提婆贪心狗鼻。转加恶盛。因此破僧。改佛法戒教戒不同。待佛普为凡圣大众说法之时即来会中。从佛索于徒众。并诸法藏尽付属我。世尊年将老迈。宜可就静内自将养。一切大众闻提婆此语。愕尔迭互相看甚生惊怪。尔时世尊即对大众语提婆言。舍利目连等即大法将我尚不将佛法付属。况汝痴人食唾者乎。时提婆闻佛对众毁辱。由如毒箭入心。更发痴狂之意。藉此因缘即向太子所。共论恶计。太子既见尊者敬心承问言。尊者今日颜色憔悴不同往昔。提婆答曰。我今憔悴正为太子也。太子敬问。尊者为我有何意也。提婆即答云。太子知不。世尊年老无所堪任。当可除之我自作佛。父王年老亦可除之太子自坐正位。新王新佛治化。岂不乐乎。太子闻之极大嗔怒。勿作是说。又言。太子莫嗔。父王于太子全无恩德。初欲生太子时。父王即遣夫人在百尺楼上当天井中生即望堕地令死。正以太子福力故命根不断。但损小指。若不信者自看小指。足以为验。太子既闻此语。更重审言。实尔已不。提婆答言。此若不实。我可故来作漫语也。因此语已遂即信用提婆恶见之计。故道随顺调达恶友之教也。三从收执父王下至一不得往已来正明父王为子幽禁。此明阇世取提婆之恶计顿舍父子之情。非直失于罔极之恩。逆响因兹满路。忽掩王身曰收。既得不舍曰执。故名收执也。言父者别显亲之极也。王者彰其位也。频婆者彰其名也。言幽闭七重室内者。所为既重。事亦非轻。不可浅禁人间全无守护。但以王之宫合理绝外人。唯有群臣则久来承奉。若不严制恐有情通。故使内外绝交。闭在七重之内也。四从国大夫人下至密以上王已来正明夫人密奉王食。言国大夫人者此明最大也。言夫人者标其位也。言韦提者彰其名也。言恭敬大王者。此明夫人既见王身被禁。门户极难音信不通。恐绝王身命。遂即香汤渗浴令身清净。即取酥蜜先涂其身。后取干糗始安酥蜜之上。即着净衣覆之在外衣上始着璎珞。如常服法。令外人不怪。又取璎珞孔一头以蜡塞之。一头孔中盛蒲桃浆。满已还塞。但是璎珞。悉皆如此。庄严既竟。徐步入宫与王相见。问曰。诸臣奉敕不许见王。未审。夫人门家不制放令得入者有何意也。答曰。诸臣身异复是外人。恐有情通。致使严加重制。又夫人者身是女人。心无异计。与王宿缘业重久近夫妻。别体同心。致使人无外虑。是以得入与王相见。五从尔时大王食糗下至授我八戒已来正明父王因禁请法。此明夫人既见王已。即刮取身上酥糗。团授与王。王得即食。食糗既竟。即于宫内夫人求得净水。与王漱口。净口已竟。不可虚引时。朝心无所寄。是以虔恭合掌。回面向于耆阇。致敬如来。请求加护。此明身业敬。亦通有意业也。而作是言已下正明口业请。亦通有意业也。言大目连是吾亲友者。有其二意。但目连在俗是王别亲。既得出家即是门师。往来宫合都无障碍。然在俗为亲。出家名友。故名亲友也。言愿兴慈悲授我八戒者。此明父王敬法情深。重人过己。若未逢幽难。奉请佛僧不足为难。今既被囚。无由致屈。是以但请目连受于八戒也。问曰。父王遥敬先礼世尊。及其受戒即请目连。有何意也。答曰。凡圣极尊无过于佛。倾心发愿即先礼大师。戒是小缘。是以唯请目连来授。然王意者贵存得戒。即是义周。何劳迂屈世尊也。问曰。如来戒法乃有无量。父王唯请八戒。不请余也。答曰。余戒稍宽。时节长远。恐畏中间失念流转生死。其八戒者如余佛经说。在家人持出家戒。此戒持心极细极急。何意然者。但时节稍促唯限一日一夜作法即舍。云何知此戒用心行细。如戒文中具显云。佛子。从今旦至明旦一日一夜。如诸佛不杀生。能持不。答言。能持。第二又云。佛子。从今旦至明旦一日一夜。如诸佛不偷盗。不行淫。不妄语。不饮酒。不得脂粉涂身。不得歌舞唱伎及往观听。不得上高广大床。此上八是戒非斋。不得过中食。此一是斋非戒。此等诸戒皆引诸佛为证。何以故。唯佛与佛正习俱尽。除佛已还恶习等由在。是故不引为证也。是以得知此戒用心起行极是细急。又此戒佛说有八种胜法。若人一日一夜具持不犯。所得功德超过人天二乘境界。如经广说。有斯益故致使父王日日受之。六从时大目连下至为王说法已来明其父王因请得蒙圣法。此明目连得他心智遥知父王请意。即发神通。如弹指顷到于王所。又恐人不识神通之相故引快鹰为喻。然目连通力一念之顷绕四天下百千之匝。岂得与鹰为类也。如是比校乃有众多。不可具引。如贤愚经具说。言日日如是授王八戒者。此明父王延命致使目连数来受戒。问曰。八戒既言胜者。一受即足。何须日日受之。答曰。山不厌高。海不厌深。刀不厌利。日不厌明。人不厌善。罪不厌除。贤不厌德。佛不厌圣。然王意者既被囚禁更不蒙进止。念念之中畏人唤杀。为此昼夜倾心仰凭八戒。望欲积善增高拟资来业。言世尊亦遣富楼那为王说法者。此明世尊慈悲意重。愍念王身。忽遇囚劳恐生忧悴。然富楼那者于圣弟子中最能说法。善有方便开发人心。为此因缘如来发遣为王说法。以除忧恼。七从如是时间下至颜色和悦已来正明父王因食闻法多日不死。此正明夫人多时奉食以除饥渴。二圣又以戒法内资善开王意。食能延命。戒法养神。失苦亡忧致使颜容和悦也。上来虽有七句不同。广明禁父缘竟

三就禁母缘中即有其八。一从时阿阇世下至由存在耶已来正明问父音信。此明阇王禁父日数既多。人交总绝水食不通。二七有余命应终也。作是念已即致宫门问守门者。父王今者犹存在耶。问曰。若人食一餐之饭限至七日即死。父王以经三七。计合命断无疑。阇王何以不直问曰门家父王今者死竟耶。云何致疑而问犹存在者有何意也。答曰。此是阇王意密问也。但以万基之主举动不可随宜。父王既是天性情亲。无容言问死。恐失在当时以成讥过但以内心标死口问在者。为欲息永恶逆之声也。二从时守门人白言下至不可禁制已来正明门家以事具答。此明阇世前问父王在者。今次门家奉答。白言大王国大夫人已下正明夫人密奉王食。王既得食食能延命。虽经多日父命犹存。此乃夫人之意。非是门家之过。问曰。夫人奉食身上涂糗。衣下密覆出入往还。无人得见。何故门家具显夫人奉食之事。答曰。一切私密不可久行。纵巧牢藏。事还彰露。父王既禁在宫内。夫人日日往还。若不密持糗食。王命无由得活。今言密者。望门家述夫人意也。夫人谓密外人不知。不其门家尽以觉之。今既事穷无由相隐。是以一一具向王说。言沙门目连已下正明二圣腾空来去不由门路。日日往还为王说法。大王当知。夫人进食先不奉王教。所以不敢遮约。二圣乘空此亦不犹门制也。三从时阿阇世闻此语下至欲害其母已来正明世王嗔怒。此明阇王既闻门家分疏已。即于夫人心起恶怒口陈恶辞。又起三业逆三业恶。骂父母为贼名口业逆。骂沙门者名口业恶。执剑杀母名身业逆。身口所为以心为主。即名意业逆。又复前方便为恶。后正行为逆。言我母是贼已下正明口出恶辞。云何骂母为贼。贼之伴也。但阇王元心致怨于父。恨不早终。母乃私为进粮故令不死。是故骂言我母是贼贼之伴也。言沙门恶人已下此明阇世嗔母进食。复闻沙门与王来去。致使更发嗔心。故云有何咒术而令恶王多日不死。言即执利剑已下此明世王嗔盛。逆及于母。何其痛哉。撮头拟剑。身命顿在须臾。慈母合掌曲身低头就儿之手。夫人尔时热汗遍流心神闷绝。呜呼哀哉。恍忽之间逢斯苦难。四从时有一臣名曰月光下至却行而退已来正明二臣切谏不听。此明二臣乃是国之辅相。立政之纲纪。望得万国扬名八方昉习。忽见阇王起于勃逆执剑欲杀其母。不忍见斯恶事。遂与耆婆犯颜设谏也。言时者当阇王欲杀母时也。言有一大臣者彰其位也。言月光者彰其名也。言聪明多智者彰其德也。言及与耆婆。者。耆婆亦是父王之子。柰女之儿。忽见家兄于母起逆。遂与月光同谏。言为王作礼者。凡欲咨谏大人之法。要须设拜以表身敬。今此二臣亦尔。先设身敬觉动王心。敛手曲躬方陈本意也。又白言大王者。此明月光正欲陈辞。望得阇王开心听揽。为此因缘故须先白。言臣闻毗陀论经说者。此明广引古今书史历帝之文记。古人云。言不关典君子所惭。今既谏事不轻。岂可虚言妄说。言劫初已来者彰其时也。言有诸恶王者。此明总标非礼暴逆之人也。言贪国位故者。此明非意所贪夺父坐处也。言杀害其父者。此明既于父起恶不可久留。故须断命也。言一万八千者。此明王今杀父与彼类同也。言未曾闻有无道害母者。此明自古至今。害父取位史籍良谈。贪国杀母都无记处。若论劫初已来。恶王贪国但杀其父不加慈母。此则引古异今。大王今者贪国杀父。父则有位可贪。可使类同于古。母即无位可求。横加逆害。是以将今异昔也。言王今为此杀母者污刹利种也。言刹利者乃是四姓高元。王者之种。代代相承。岂同凡碎。言臣不忍闻者。见王起恶。损辱宗亲恶声流布。我之性望耻惭无地。言是旃陀罗者。乃是四姓之下流也。此乃性怀匈恶不闲仁义。虽着人皮行同禽兽。王居上族押临万基之主。今既起恶加恩。与彼下流何异也。言不宜住此者即有二义。一者王今造恶不存风礼。京邑神州岂遣旃陀罗为主也。此即摈出宫城意也。二者王虽在国损我宗亲。不如远摈他方。永绝无闻之地。故云不宜住此也。言时二大臣说此语已下此明二臣直谏切语极粗。广引古今望得王心开悟。言以手按剑者。臣自按手中剑也。问曰。谏辞粗恶。不避犯颜。君臣之义既乖。何以不回身直去。乃言却行而退也。答曰。粗言虽逆王。望息害母之心。又恐嗔毒未除系剑危己。是以按剑自防。却行而退。五从时阿阇世惊怖下至汝不为我耶已来正明世王生怖。此明阇世既见二臣谏辞粗切。又睹按剑而去。恐臣背我向彼父王更生异计。致使情地不安故称惶惧彼既舍我。不知为谁。心疑不决遂即口问审之。故云耆婆汝不为我也。言耆婆者是王之弟也。古人云。家有衰祸非亲不救。汝既是我弟者岂同月光也。六从耆婆白言下至慎莫害母已来明二臣重谏。此明耆婆实答大王。若欲得我等为相者。愿勿害母也。此直谏竟。七从王闻此语下至止不害母已来正明阇王受谏放母残命。此明世王既得耆婆谏已心生悔恨。愧前所造即向二臣求哀乞命。因即放母脱于死难。手中之剑还归本匣。八从敕语内官下至不令复出已来明其世王余嗔禁母。此明世王虽受臣谏放母。犹有余嗔不令在外。敕语内官闭置深宫。更莫令出与父王相见。上来虽有八句不同。广明禁母缘竟

四就厌苦缘中即有其四。一从时韦提希下至憔悴已来正明夫人为子幽禁。此明夫人虽勉死难。更闭在深宫。守当极牢无由得出。唯有念念怀忧。自然憔悴。伤叹曰。祸哉今日苦。遇值阇王唤利刃中间结。复置深宫难。问曰。夫人既得勉死入宫。宜应讶乐。何因反更愁忧也。答曰。即有三义不同。一明夫人既自被闭。更无人进食与王。王又闻我在难转更愁忧。今既无食加忧者。王之身命定应不久。二明夫人既被囚难。何时更见如来之面及诸弟子。三明夫人奉教禁在深宫。内官守当水泄不通。旦夕之间唯愁死路。有斯三义切逼身心。得无憔悴也。二从遥向耆阇崛山下至未举头顷已来正明夫人因禁请佛。意有所陈。此明夫人既在囚禁。自身无由得到佛边。唯有单心面向耆阇。遥礼世尊。愿佛慈悲表知弟子愁忧之意。言如来在昔之时已下此有二义。一明父王未被禁时。或可王及我身亲到佛边。或可如来及诸弟子亲受王请。然我及王身俱在囚禁。因缘断绝。彼此情乖。二明父王在禁已来。数蒙世尊遣阿难来慰问我。云何慰问。以见父王囚禁。佛恐夫人忧恼。以是因缘故遣慰问也。言世尊威重无由得见者。此明夫人内自卑谦归尊于佛弟子。秽质女身福因鲜薄。佛德威高无由轻触。愿遣目连等与我相见。问曰。如来即是化主。应不失时宜。夫人何以不三加致请乃唤目连等。有何意也。答曰。佛德尊严。小缘不敢辄请。但见阿难欲传语往白世尊。佛知我意。复便阿难传佛之语指授于我。以斯义故愿见阿难。言作是语已者。总说前意竟也。言悲泣雨泪者。此明夫人自唯罪重。请佛加哀。致敬情深悲泪满目。但以渴仰灵仪。复加遥礼。叩顶跱[跳-兆+余]。须臾未举。三从尔时世尊下至天华持用供养。已来正明世尊自来赴请。此明世尊虽在耆阇。已知夫人心念之意。言敕大目连等从空而来者。此明应夫人请也。言佛从耆山没者。此明夫人宫内禁约极难。佛若现身来赴。恐畏阇世知闻更生留难。以是因缘故须此没彼出也。言时韦提礼已举头者此明夫人致敬之时也。言见佛世尊者。此明世尊宫中已出。致使夫人举头即见。言释迦牟尼佛者。简异余佛。但诸佛名通身相不异。今故标定释迦使无疑也。言身紫金色者。显定其相也。言坐百宝华者。简异余座也。言目连侍左等者。此明更无余众唯有二僧。言释梵护世者。此明天王众等见佛世尊隐显王宫。必说希奇之法。我等天人因韦提故得听未闻之益。各乘本念普住临空。天耳遥餐雨华供养。又言释者即是天帝也。言梵者即是色界梵王等也。言护世者即是四天王也。言诸天者即是色欲界等天众。既见天王来向佛边。彼诸天众亦从王来闻法供养。四从时韦提希见世尊下至与提婆共为眷属已来正明夫人举头见佛。口言伤叹。怨结情深也。言自绝璎珞者。此明夫人身庄璎珞犹爱未除。忽见如来羞惭自绝。问曰。云何自绝也。答曰。夫人乃是贵中之贵。尊中之尊。身四威仪。多人供给。所著衣服皆使傍人今既见佛耻愧情深。不依钩带顿自掣却故云自绝也。言举身投地者。此明夫人内心感结怨苦难堪。是以从坐踊身而立。从立踊身投地。此乃叹恨处深。更不事礼拜威仪也。言号泣向佛者。此明夫人婉转佛前闷绝号哭。言白佛已下此明夫人婉转涕哭量久少惺。始正身威仪。合掌白佛。我自一生已来未曾造其大罪。未审。宿业因缘有何殃咎而与此儿共为母子。此明夫人既自障深不识宿因。今被儿害谓是横来。愿佛慈悲示我径路。言世尊复有何等因缘已下此明夫人向佛陈诉。我是凡夫罪惑不尽有斯恶报。是事甘心。世尊旷劫行道正习俱亡。众智朗然果圆号佛。未审。有何因缘乃与提婆共为眷属。此意有二。一明夫人致怨于子。忽于父母狂起逆心。二明又恨提婆教我阇世造斯恶计。若不因提婆者。我儿终无此意也。为此因缘故致斯问。又夫人问佛云与提婆眷属者即有其二。一者在家眷属。二者出家眷属。言在家者佛之伯叔有其四人。佛者即是白净王儿。金毗者白饭王儿。提婆者斛饭王儿。释魔男者是甘露饭王儿。此名在家外眷属也。言出家眷属者。与佛作弟子故名内眷属也。上来虽有四句不同。广明厌苦缘竟

五就欣净缘中即有其八。一从唯愿世尊为我广说下至浊恶世也已来正明夫人通请所求。别标苦界。此明夫人遇自身苦觉世非常。六道同然。无有安心之地。此闻佛说净土无生。愿舍秽身证彼无为之乐。二从此浊恶处下至不见恶人已来正明夫人举出所厌之境。此明阎浮总恶未有一处可贪。但以幻惑愚夫。饮斯长苦。言此浊恶处者正明苦界也。又明器世间。亦是众生依报处。亦名众生所依处也。言地狱等已下三品恶果最重也。言盈满者。此三苦聚非直独指阎浮。娑婆亦皆遍有故言盈满。言多不善聚者。此明三界六道不同种类恒沙。随心差别。经云。业能庄识。世世处处各趣随缘受果报。对面不相知。言愿我未来已下此明夫人真心彻到厌苦娑婆欣乐无为。永归常乐。但无为之境不可轻尔即阶。苦恼娑婆无由辄然得离。自非发金刚之志。永绝生死之元。若不亲从慈尊。何能勉斯长叹。然愿我未来不闻恶声恶人者。此明如阇王调达杀父破僧及恶声等。愿亦不闻不见。但阇王既是亲生之子。上于父母起于杀心。何况疏人而不相害。是故夫人不简亲疏。总皆顿舍。三从今向世尊下至忏悔已来正明夫人净土妙处非善不生。恐有余愆障不得往。是以求哀更须忏悔。四从唯愿佛日下至清净业处已来正明夫人通请去行。此明夫人上即通请生处。今亦通请得生之行。言佛日者法喻双标也。譬如日出众闇尽除。佛智辉光无明之夜日朗。言教我观于清净已下正明既能厌秽欣净。若为安心注想得生清净处也。五从尔时世尊放眉间光下至令韦提见已来正明世尊广现净土酬前通请。此明世尊以见夫人广求净土。如来即放眉间光照十方国。以光摄国。还来顶上化作金台。如须弥山。如之言似。似须弥山。此山腰细上阔。所有佛国并于中现。种种不同庄严有异。佛神力故了了分明。加备韦提尽皆得见。问曰。韦提上请为我广说无忧之处。佛今何故不为广说。乃为金台普现者有何意也。答曰。此彰如来意密也。然韦提发言致请。即是广开净土之门。若为之总说。恐彼不见心犹致惑。是以一一显现对彼眼前。信彼所须随心自选。六从时韦提白佛下至皆有光明已来正明夫人总领所现感荷佛恩。此明夫人总见十方佛国。并悉精华。欲比极乐庄严。全非比况。故云我今乐生安乐国也。问曰。十方诸佛断惑无殊。行毕果圆亦应无二。何以一种净土即有斯优劣也。答曰。佛是法王。神通自在。优之与劣非凡惑所知。隐显随机望存化益。或可故隐彼为优独显西方为胜。七从我今乐生弥陀已下正明夫人别选所求。此明弥陀本国四十八愿。愿愿皆发增上胜因。依因起于胜行。依行感于胜果。依果感成胜报。依报感成极乐。依乐显通悲化。依于悲化。显开智慧之门。然悲心无尽智亦无穷。悲智双行即广开甘露。因兹法润普摄群生也。诸余经典劝处弥多。众圣齐心皆同指赞。有此因缘。致使如来密遣夫人别选也。八从唯愿世尊已下正明夫人请求别行。此明韦提既选得生处。还修别行励己注心。必望往益。言教我思惟者。即是定前方便思想忆念彼国依正二报四种庄严也。言教我正受者。此明因前思想渐渐微细觉想俱亡。唯有定心与前境合名为正受。此中略已料简。至下观门更当广辩。应知。上来虽有八句不同。广明欣净缘竟

六就散善显行缘中即有其五。一从尔时世尊即便微笑下至成那含已来正明光益父王。此明如来以见夫人愿生极乐。更请得生之行。称佛本心。又显弥陀愿意因斯二请。广开净土之门。非直韦提得去。有识闻之皆往。有斯益故。所以如来微笑也。言有五色光从佛口出者。此明一切诸佛心口常威仪法尔凡所出光必有利益。言一一光照频婆顶者。正明口光不照余方。唯照王顶。然佛光随身出处必皆有益。佛足下放光即照益地狱道。若光从膝出照益畜生道。若光从阴藏出照益鬼神道。若光从脐出照益修罗道。光从心出照益于人道。若光从口出照益二乘之人。若光从眉间出照益大乘人。今明此光从口出直照王顶者即授其小果。若光从眉间出即从佛顶入者。即授菩萨记也。如斯义者广多无量。不可具述。言尔时大王虽在幽闭已下正明父王蒙光照顶。心眼得开。障隔虽多。自然相见。斯乃因光见佛。非意所期。致敬归依即超证第三之果。二从尔时世尊下至广说众譬已来正明答前夫人别选所求之行。此明如来从上耆阇没王宫出讫至此文。世尊默然而坐。总未言说。但中间夫人忏悔请问放光现国等。乃是阿难从佛王宫见此因缘。事了还山传向耆阇大众说如上事始有此文。亦非是无时佛语也。应知。言尔时世尊告韦提已下。正明告命许说也。言阿弥陀佛不远者。正明标境以住心。即有其三一明分齐不远。从此超过十万亿刹即是弥陀之国。二明道里虽遥去时一念即到。三明韦提等及未来有缘众生注心观念。定境相应行人自然常见。有斯三义故云不远也。言汝当系念已下正明凡惑障深心多散动。若不顿舍攀缘。净境无由得现。此即正教安心住行。若依此法名为净业成也。言我今为汝已下此明机缘未具不可偏说定门。佛更观机自开三福之行。三从亦令未来世下至极乐国土已来正明举机劝修得益。此明夫人所请利益弥深。及未来回心皆到。四从欲生彼国者下至名为净业已来正明劝修三福之行。此明一切众生机有二种。一者定。二者散。若依定行即摄生不尽。是以如来方便显开三福。以应散动根机。言欲生彼国者。标指所归也。言当修三福者。总标行门也。云何名三。一者孝养父母。即有其四。一言孝养父母者。此明一切凡夫皆藉缘而生。云何藉缘。或有化生。或有湿生。或有卵生。或有胎生。此四生中各各复有四。生如经广说。但是相因而生即有父母。既有父母。既有大恩。若无父者能生之因即阙。若无母者所生之缘即乖。若二人俱无即失托生之地。要须父母缘具方有受身之处。既欲受身。以自业识为内因。以父母精血为外缘。因缘和合故有此身。以斯义故父母恩重。母怀胎已经于十月。行住坐卧常生苦恼。复忧产时死难。若生已经于三年恒常眠屎卧尿床。被衣服皆亦不净。及其长大爱妇亲儿。于父母处反生憎疾。不行恩孝者即与畜生无异也。又父母者世间福田之极也。佛者即是出世福田之极也。然佛在世时。遇值时年饥俭。人皆饿死白骨纵横。诸比丘等乞食难得。于时世尊待比丘等去后。独自入城乞食。从旦至中门门唤乞。无与食者。佛还空钵而归。明日复去又还不得。后日复去又亦不得。忽有一比丘道逢见佛。颜色异常似有饥相。即问佛言。世尊。今已食竟也。佛言。比丘。我经三日已来乞食不得一匙。我今饥虚无力。能共汝语。比丘闻佛语已。悲泪不能自胜。即自念言。佛是无上福田众生覆护。我此三衣卖却。买取一钵饭奉上于佛。今正是时也。作是念已即买得一钵饭。急将上佛。佛知而故问言。比丘。时年饥俭人皆饿死。汝今何处得此一钵纯色饭来。比丘如前具白世尊。佛又言。比丘。三衣者即是三世诸佛之幢相。此衣因缘极尊极重极恩。汝今易得此饭与我者。大领汝好心我不消此饭也。比丘重白佛言。佛是三界福田圣中之极。尚言不消者。除佛已外谁能消也。佛言。比丘。汝有父母已不。答言有。汝将供养父母去。比丘言。佛尚云不消。我父母岂能消也。佛言。得消。何以故。父母能生汝身。于汝有大重恩。为此得消。佛又问比丘。汝父母有信佛心不。比丘言。都无信心。佛言。今有信心。见汝与饭大生欢喜。因此即发信心。先教受三归依。即能消此食也。时比丘既受佛教愍仰而去。以此义故。大须孝养父母。又佛母摩耶生佛经七日已即死生忉利天。佛后成道。至四月十五日。即向忉利天一夏为母说法。为报十月怀胎之恩。佛尚自收恩孝养父母。何况凡夫而不孝养。故知父母恩深极重也。奉事师长者。此明教示礼节。学识成德。因行无亏。乃至成佛此犹师之善友力也。此之大恩最须敬重。然父母及师长者名为敬上行也。言慈心不杀者。此明一切众生皆以命为本。若见恶缘怖走藏避者。但为护命也。经云。一切诸众生无不爱寿命。勿杀勿行杖。恕己可为喻。即为证也。言修十善业者。此明十恶之中杀业最恶。故列之在初。十善之中长命最善。故以之相对也。已下九恶九善者至下九品中次应广述。此明世善又名慈下行也。二言受持三归者。此明世善轻微感报不具。戒德巍巍能感菩提之果。但众生归信从浅至深。先受三归后教众戒。言具足众戒者。然戒有多种。或三归戒。或五戒八戒十善戒二百二十戒五百戒沙弥戒。或菩萨三聚戒十无尽戒等。故名具足众戒也。又一一戒品中亦有少分戒多分戒全分戒也。言不犯威仪者。此明身口意业行住坐卧能与一切戒作方便威仪也。若轻重粗细皆能护持。犯即悔过。故云不犯威仪。此名戒善也。三言发菩提心者。此明众生欣心趣大不可浅发小因。自非广发弘心。何能得与菩提相会。唯愿我身身同虚空心齐法界。尽众生性我以身业恭敬供养礼拜。迎送来去。运度令尽。又我以口业赞叹说法。皆受我化。言下得道者令尽。又我以意业入定观察。分身法界。应机而度。无一不尽。我发此愿。运运增长犹如虚空。无处不遍。行流无尽彻穷后际。身无疲倦心无厌足。又言菩提者即是佛果之名。又言心者即是众生能求之心。故云发菩提心也。四言深信因果者即有其二。一明世间苦乐因果。若作苦因即感苦果。若作乐因即感乐果。如似以印印泥印坏文成。不得疑也。言读诵大乘者。此明经教喻之如镜。数读数寻开发智慧。若智慧眼开即能厌苦欣乐涅槃等也。言劝进行者。此明苦法如毒恶法如刀。流转三有损害众生。今既善如明镜法如甘露。镜即照正道以归真。甘露即注法雨而无竭。欲使含灵受润等会法流。为此因缘故须相劝。言如此三事已下总结成上行也。五从佛告韦提下至正因已来明其引圣励凡。但能决定注心必往无疑。上来虽有五句不同。广明散善显行缘竟

七就定善示观缘中即有其七。一从佛告阿难下至清净业已来正明敕听许说。此明韦提前请愿生极乐。又请得生之行。如来已许。今就此文。正欲开显正受之方便。此乃因缘极要。利益处深。旷劫希闻。如今始说。为斯义故致使如来总命二人。言告阿难者。我今欲开说净土之门。汝好传持莫令遗失。言告韦提者。汝是请法之人。我今欲说。汝好审听思量谛受莫令错失。言为未来世一切众生者。但如来临化偏为常没众生。今既等布慈云。望欲普沾来润。言为烦恼贼害者。此明凡夫障重妄爱迷深。不谓三恶火坑闇在人之足下。随缘起行。拟作进道资粮。何其六贼知闻竞来侵夺。今既失此法财。何得无忧苦也。言说清净业者。此明如来以见众生罪故为说忏悔之方。欲令相续断除。毕竟永令清净。又言清净者。依下观门专心念佛注想西方。念念罪除故清净也。二从善哉已下。正明夫人问当圣意。三从阿难汝当受持下至宣说佛语已来正明劝持劝说。此法深要。好须流布。此明如来前则总告令安心听受此文则别敕阿难受持勿忘。广多人处为说流行。言佛语者。此明如来旷劫已除口过。随有言说一切闻者自然生信。四从如来今者下至得无生忍已来正明劝修得益之相。此明如来欲为夫人及未来等显观方便注想西方。舍厌娑婆。贪欣极乐。言以佛力故已下此明众生业障触目生盲。指掌谓远。他方隔竹篾即踰之千里。岂况凡夫分外诸佛境内窥心。自非圣力冥加。彼国何由得睹。言如执明镜自见面像已下此明夫人及众生等入观住心。凝神不舍。心境相应悉皆显现。当境现时。如似镜中见物无异也。言心欢喜故得忍者。此明阿弥陀佛国清净光明忽现眼前。何胜踊跃。因兹喜故即得无生之忍。亦名喜忍。亦名悟忍。亦名信忍。此乃玄谈。未标得处。欲令夫人等悕心此益。勇猛专精心想见时。方应悟忍。此多是十信中忍。非解行已上忍也。五从佛告韦提下至令汝得见已来正明夫人是凡非圣。由非圣故仰惟圣力冥加。彼国虽遥得睹。此明如来恐众生置惑。谓言夫人是圣非凡。由起疑故即自生怯弱。然韦提现是菩萨。假示凡身。我等罪人无由比及。为断此疑故言汝是凡夫也。言心想羸劣者。由是凡故曾无大志也。言未得天眼者。此明夫人肉眼所见远近不足为言。况净土弥遥。云何可见。言诸佛如来有异方便已下此明若依心所见国土庄严者。非汝凡能普悉归功于佛也。六从时韦提白佛下至见彼国土已来明其夫人重牒前恩。欲生起后问之意。此明夫人领解佛意。如上光台所见。谓是己能向见。世尊开示始知是佛方便之恩。若尔者。佛今在世。众生蒙念可使得见西方。佛若涅槃。不蒙加备者。云何得见也。七从若佛灭后下至极乐世界已来正明夫人悲心为物同己往生。永逝娑婆长游安乐。此明如来期心运度彻穷后际而未休。但以世代时移群情浅促故使如来减永生之寿。泯长劫以类人年。摄憍慢以示无常。化刚强同归于磨灭。故云若佛灭后也。言诸众生者。此明如来息化众生无处归依。蠢蠢周慞纵横走于六道。言浊恶不善者。此明五浊也。一者劫浊。二者众生浊。三者见浊。四者烦恼浊。五者命浊。言劫浊者。然劫实非是浊。当劫减时诸恶加增也。言众生浊者。劫若初成。众生纯善。劫若末时。众生十恶弥盛也。言见浊者。自身众恶总变为善。他上无非见为不是也。言烦恼浊者。当今劫末众生恶性难亲。随对六根贪嗔竞起也。言命浊者。由前见恼二浊。多行杀害无慈恩养。既行断命之苦因欲受长年之果者。何由可得也。然浊者。体非是善。今略指五浊义竟。言五苦所逼者。八苦中取生苦老苦病苦死苦爱别苦此名五苦也。更加三苦即成八苦。一者五阴盛苦。二者求不得苦。三者怨憎会苦。总名八苦也。此五浊五苦八苦等。通六道受。未有无者。常逼恼之。若不受此苦者即非凡数摄也。言云何当见已下此明夫人举出苦机此等罪业极深。又不见佛不蒙加备。云何见于彼国也。上来虽有七句不同。广明定善示观缘竟

初明证信序。次明化前序。后明发起序。上来虽有三序不同。总明序分竟

观经序分义卷第二观经正宗分定善义卷第三

        沙门善导集记

从此已下次辩正宗。即有其十六。还就一一观中。对文料简。不劳预显。今定立正宗与诸师不同。今直以就法定者。从日观初句下至下品下生已来是其正宗。从日观已上虽有多义不同。看此文势但是由序也。应知

就初日观中先举。次辨。后结。即有其五。一从佛告韦提下至想于西方已来正明总告总劝。此明韦提前请弥陀佛国。又请正受之行。如来当时即许为说。但以机缘未备显行未周。更开三福之因以作未闻之益。又如来重告劝发流通。此法难闻广令开悟。言佛告韦提汝及众生者。此明告劝。若欲等出尘劳。求生佛国者。宜须励意也。言应当专心已下。此明众生散动。识剧猿猴。心遍六尘无由暂息。但以境缘非一。触目起贪乱想。安心三昧何容可得。自非舍缘托静。相续注心。直指西方简余九域。是以一身一心一回向。一处一境界一相续一归依一正念。是名想成就明正受。此世后生随心解脱也。二从云何作想下至皆见日没已来。正明牒所观事。此明诸众生等久流生死不解安心。虽指西方。不知云何作意。故使如来为生反问遣除疑执。以示正念之方。言凡作想者。此明总牒前意显后入观之方便。言一切众生者。总举得生之类。言自非生盲已下。此得简机堪与不堪。言生盲者。从母胎中出眼即不见物者名曰生盲。此人不得教作日观。由不识日轮光相故。除生盲以外遇缘患者。教作日观尽得成就。由未患眼时识其日轮光明等相。今虽患目但令善取日轮等相。正念坚持不限时节必得成就。问曰。韦提上请愿见极乐之境。及至如来许说。即先教住心观日。有何意也。答曰。此有三意。一者欲令众生识境住心。指方有在。不取冬夏两时。唯取春秋二际。其日正东出。直西没。弥陀佛国当日没处。直西超过十万亿刹即是。二者欲令众生识知自业障有轻重。云何得知。由教住心观日。初欲住心时。教令跏趺正坐。右脚着左髀上与外齐。左足安右髀上与外齐。左手安右手上。令身正直。合口齿勿相近。舌柱上齶为令咽喉及鼻中气道宣通故。又令观身四大内外俱空都无一物。身之地大皮肉筋骨等心想。散向西方尽西方际。乃至不见一尘之相。又想身之水大血汗津泪等心想。散向北方尽北方际。乃至不见一尘之相。又想身之风大散向东方尽东方际。乃至不见一尘之相。又想身之火大散向南方尽南方际。乃至不见一尘之相。又想身之空大即与十方虚空一合。乃至不见一尘不空之相。又想身之五大皆空。唯有识大湛然凝住。犹如圆镜。内外明照朗然清净。作此想时。乱想得除。心渐凝定。然后徐徐转心谛观于日。其利根者一坐即见明相现前。当境现时。或如钱大。或如镜面大。于此明上即自见业障轻重之相。一者黑障犹如黑云障日。二者黄障又如黄云障日。三者白障如似白云障日。此日犹云障故不得朗然显照。众生业障亦如是。障蔽净心之境不能令心明照。行者若见此相。即须严饰道场安置佛像。清净洗浴着净衣。又烧名香。表白诸佛一切贤圣。向佛形像。现在一生忏悔无始已来乃身口意业所造十恶五逆四重谤法阐提等罪。极须悲涕雨泪深生惭愧。内彻心髓。切骨自责。忏悔已还如前坐法安心取境。境若现时。如前三障尽除。所观净境朗然明净。此名顿灭障也。或一忏即尽者名利根人也。或一忏但除黑障。或一忏得除黄白等障。或一忏但除白障。此名渐除不名顿灭也。既自识业相如是。唯须勤心忏悔。日夜三时六时等但忆得即忏者。最是上根上行人也。譬如汤火烧身亦觉即却。岂容徒待时待处待缘待人方始除也。三者欲令众生识知弥陀依正二报。种种庄严光明等相。内外照曜。超过此日百千万倍。行者等若不识彼境光相者。即看此日轮光明之相。若行住坐卧礼念忆想常作此解。不久之间即得定心。见彼净土之事快乐庄严。为此义故世尊先教作日想观也。三从当起想念下至状如悬鼓已来。正教观察。此明正身威仪面向西方。守境住心坚执不移。所期皆应。四从既见日已下至明了已来。辩观成相。此明标心见日。制想除缘。念念不移。净相了然而现。又行者初在定中见此日时。即得三昧定乐。身心内外融液不可思议。当见此时。好须摄心令定不得上心贪取。若起贪心。心水即动。以心动故净境即失。或动或闇或黑或青黄赤白等色不得安定。见此事时。即自念言。此等境相摇动不安者。由我贪心动念。致使净境动灭。即自安心正念。还从本起。动相即除。静心还现。既知此过更不得起增上贪心也。已下诸观邪正得失一同此也。观日见日。心境相应。名为正观。观日不见日。乃见余杂境等。心境不相应。故名邪也。斯乃娑婆之闇宅触事无以比方。唯有朗日舒辉。寄想远标于极乐。五从是为已下总结。上来虽有五句不同。广明日观竟

二就水观中亦先举。次辩。后结。即有其六。一从次作水想下至内外映彻已来。总标地体。问曰。前教观日。为知业相等。故令观日。今此观中又教观水。有何所以。答曰。日轮常照。以表极乐之长晖。复恐彼地不平。类此秽国之高下。但以娑婆闇宅唯日能明。此界丘坑未无高下之处。欲取能平之者。无过于水。示斯可平之相。况彼琉璃之地也。又问曰。此界之水湿而且软。未审彼地亦同此水也。答曰。此界之平水。以对彼地等无高下。又转水成冰者。对彼琉璃之地内外映彻也。此明弥陀旷劫等行无偏。正习俱亡。能感地轮之映彻。又问曰。既教想水以住心。转水以成冰。转冰以成琉璃地者。云何作法而令境现。答曰。若住身威仪一同前日观中法。又欲观水以取定心者。还须对相似之境而观。即易可得定。行者等于静处取一碗水。着床前地上好满盛之。自身在床上坐。当自眉间着一白物如豆许大。低头临面水上。一心照看此白处。更莫异缘。又水初在地波浪不住。临面观之不见面像。为观不休渐渐面现。初时面相不住。乍长乍短乍宽乍狭乍见不见。此相现时更须极细用心。不久之间水波微细似动不动。面相渐得明现。虽见面上眼耳鼻口等。亦未须取亦不须妨。但纵身心知有勿取也。唯取白处了了观之。正念守护勿令失意异缘。当见此时心渐得住。水性湛然也。又行者等欲识知自心中水波浪不住者。但观此水动不动之相。即知自心境现不现明闇之相也。又待水静时取一米许。当水上信手投之水中。其水波即动遍于碗内。自面临上观之。其白者即动。更着豆许投之。水波更大。面上白者或见不见。乃至枣等投之于水。其波转大。面上白者及自身头面。总皆隐没不现。犹水动故也。言碗者即喻身器也。言水者即喻自心水也。言波浪者即喻乱想烦恼也。言渐渐波浪息者。即是制舍众缘住心一境也。言水静境现者。即是能缘之心无乱。所缘之境不动。内外恬怕所求之相显然。又细想及粗想。心水即动。心水既动。静境即失。又细尘及以粗尘投之寂静水中。其水波浪即动。又行者等但看此水动不动相。即识自心住不住也。又境现失不失邪正等。一同前日观也。又天亲赞云。观彼世界相。胜过三界道。究竟如虚空。广大无边际。此即总明彼国地之分量也。二从下有金刚七宝下至不可具见已来。正明地下庄严。即有其七。一明幢体等是无漏金刚。二明擎地相显映庄严。三明方楞具足表非圆相。四明百宝合成量出尘沙。五明宝出千光。光周无边之际。六明光多异色。色照他方。随机变现。无时不益也。七明众光散彩。映绝日轮。新往者睹之卒难周悉。赞云。地下庄严七宝幢。无量无边无数亿。八方八面百宝成。见彼无生自然悟。无生宝国永为常。一一宝流无数光。行者倾心常对目。腾神踊跃入西方。又赞云。西方寂静无为乐。毕竟逍遥离有无。大悲薰心游法界。分身利物等无殊。或现神通而说法或现相好入无余。变现庄严随意出。群生见者罪皆除。又赞云。归去来。魔乡不可停。旷劫来流转。六道尽皆经。到处无余乐。唯闻愁叹声。毕此生平后。入彼涅槃城。三从琉璃地上下至分齐分明已来。正明地上庄严显标殊胜。此明依持圆净。七宝池林等是能依。琉璃宝地是所依。地是能持。池台树等是所持。此由弥陀因行周备。致使感报圆明。明净之义即无漏为体也。赞云。宝地庄严无比量。处处光明照十方。宝阁华台皆遍满。杂色朎胧难可量。宝云宝盖临空覆。圣众飞通互往来。宝幢旛盖随风转。宝乐含辉应念回。带惑疑生华未发。合掌笼笼喻处胎。内受法乐无微苦。障尽须臾华自开。耳目精明身金色。菩萨徐徐授宝衣。光触体得成三忍。即欲见佛下金台。法侣迎将入大会。瞻仰尊颜赞善哉。言金绳已下。正明黄金作道状似金绳也。或以杂宝为地琉璃作道。或以琉璃为地白玉作道。或以紫金白银为地百宝作道。或以不可说宝为地还以不可说宝作道。或以千万宝为地二三宝作道。如是转相间杂。转共合成。转相照曜。转相显发。光光色色各各不同。而无杂乱。行者等莫言但有金道。而无余宝作道也。四从一一宝中有五百色光下至乐器以为庄严已来。正明空里庄严。即有其六。一明宝出多光二明喻显其相。三明光变成台。四明光变成于楼阁。五明光变成于华幢。六明光变成于宝乐之音。又明地上杂宝一一各出五百色光。一一色光上涌空中作一光台。一一台中宝楼千万。各以一二三四乃至不可说宝以为庄严合成也。言如华又如星月者。佛以慈悲畏人不识。故借喻以显之。言于台两边各有百亿华幢者。宝地众多光明无量。一一光等化作光台。遍满空中。行者等行住坐卧常作此想。五从八种清风下至无我之音已来。正明光变乐音。转成说法之相。即有其三。一明八风从光而出。二明风光即出即鼓乐发音。三明显说四倒四真恒沙等法。赞云。安乐国清净。常转无垢轮。一念及一时。利益诸群生。赞佛诸功德。无有分别心。能令速满足功德大宝海。六从是为下总结。上来虽有六句不同。广明水观竟

三就地想观中。亦先举。次辨。后结。即有其六。一从此想成时者。正明结前生后。二从一一观之下至不可具说已来。正明辨观成相。即有其六。一明心标一境不得总杂观之。二明既专一境境即现前。既得现前必令明了。三明境既现心。闭目开目守令莫失。四明身四威仪昼夜常念。唯除睡时忆持不舍。五明凝心不绝即见净土之相。此名想心中见。犹有觉想故。六明想心渐微。觉念顿除。正受相应证于三昧。真见彼境微妙之事。何由具说。斯乃地广无边。宝幢非一。众珍曜彩。转变弥多。是以劝物倾心。恒如对目。三从是为下总结。四从佛告阿难下至说是观地法已来。正明劝发流通随缘广说。即有其四。一明告命。二明劝持佛语。广为未来大众说前观地之益。三明简机堪受堪信欲得舍此娑婆生死之身八苦五苦三恶道苦等。闻即信行者不惜身命急为说之。若得一人舍苦出生死者。是名真报佛恩。何以故。诸佛出世种种方便劝化众生者。不欲直令制恶修福受人天乐也。人天之乐犹如电光。须臾即舍还入三恶长时受苦。为此因缘但劝即令求生净土。向无上菩提。是故今时有缘相劝誓生净土者。即称诸佛本愿意也。若不乐信行者。如清净觉经云。若有人闻说净土法门。闻如不闻。见如不见。当知此等始从三恶道来。罪障未尽。为此无信向耳。佛言。我说此人未可得解脱也。此经又云。若人闻说净土法门。闻即悲喜交流身毛为竖者。当知此人过去已曾修习此法。今得重闻即生欢喜。正念修行必得生也。四明正教观宝地以住心也。五从若观是地者下至心得无疑已来。正明显观利益。即有其四。一明指法唯观宝地。不论余境。二明因观无漏之宝地。能除有漏多劫罪也。三明舍身已后必生净土。四明修因正念不得杂疑。虽得往生含华未出。或生边界。或堕宫胎。或因大悲菩萨入开华三昧。疑障乃除。宫华开发身相显然。法侣携将游于佛会。斯乃注心见于宝地。即灭宿障罪僣。愿行之业已圆。命尽无疑不往。今既观斯胜益。更劝辨知邪正。六从作是观已下。正明辨观邪正。邪正义者前日观中已说。上来虽有六句不同。广明地观竟

四就宝树观中。亦先举。次辨。后结。即有其十。一从佛告阿难下至次观宝树已来。正明告命总举观名。结前生后。二言观宝树者。重牒观名也。言一一观之已下。生后观相。正教仪则。此明弥陀净国广阔无边。宝树宝林岂以七行为量也。今言七重者。或有一树。黄金为根。紫金为茎。白银为枝。码瑙为条。珊瑚为叶。白玉为华。真珠为果。如是七重互为根茎乃至华果等。七七四十九重也。或有一宝为一树者。或二三四乃至百千万亿不可说宝为一树者。此义弥陀经义中已广论竟。故名七重也。言行者。彼国林树虽多。行行整直而无杂乱。言想者。未闲真观自在随心。要藉假想以住心。方能证益也。三从一一下至由旬已来。正明树之体量。此明诸宝林树皆从弥陀无漏心中流出。由佛心是无漏故其树亦是无漏也。赞云。正道大慈悲。出世善根生。净光明满足。如镜日月轮。言量者。一一树高三十二万里。亦无老死者。亦无小生者。亦无初生渐长者。起即同时顿起。量数等齐。何意然者。彼界位是无漏无生之界。岂有生死渐长之义也。四从其诸宝树下至以为映饰已来。正明杂树杂严杂饰异相。即有其四。一明林树华叶间杂不同。二明一一根茎枝条果等皆具众宝。三明一一华叶转互不同。琉璃色中出金色光。如是转相间杂。四明更将一切杂宝而严饰之。又赞云。备诸珍宝性。具足妙庄严。无垢光炎炽。明净曜世间。又赞云。弥陀净国宝树多。四面垂条天衣挂绕。宝云含盖。化鸟连声旋转临空奏法音而入会。他方圣众听响以开心。本国能人见形而取悟。五从妙真珠网下至色中上者已来。正明树上空裹庄严相。即有其七。一明珠网临空覆树。二明网有多重。三明宫殿多少。四明一一宫内多诸童子。五明童子身服珠璎珞。六明璎珞光照远近。七明光超上色。六从此诸宝林下至有七宝果已来。明其林树虽多而无杂乱。华实开时。不从内出。斯乃法藏因深。致使自然而有。七从一一树叶下至婉转叶间已来。正明华叶色相不同。即有其五。一明叶量大小等无差别。二明叶出光色多少。三明恐疑不识借喻以显。如天璎珞。四明叶有妙华。色比天金。相喻火轮。五明迭相显照。婉转叶间。八从涌生诸果下至亦于中现已来。正明果有不思议德用之相。即有其五。一明标果生时自然涌出。二明借喻以标果相。三明果有神光化成旛盖。四明宝盖圆明内现三千之界。依正二严种种相现。五明十方净土普现盖中。彼国人天无不睹见。又此树量弥高。纵广弥阔。华果众多。神变非一。一一树既然。遍满彼国所有诸树之果众多。尽皆如此。应知。一切行者行住坐卧常作此想。九从见此树已下至分明已来。辩观成相。即有其三。一明结观成相。二明次第观之不得杂乱。三明一一起心住境。先观树根。次想茎枝乃至华果次想网宫。次想童子璎珞。次想叶量华果光色。次想旛盖广现佛事。既能一一次第观之者。无不明了也。十从是为下总结。斯乃宝树连晖。网帘空殿。华分千色。果现他方。上来虽有十句不同。广明宝树观竟

五就宝池观中。亦先举。次辨。后结。即有其七。一从次当想水已下。总举观名。即是牒前生后。此明宝树虽精。若无池水。亦未名好。一为不空世界。二为庄严依报。为斯义故。有此池渠观也。二从极乐国土下至如意珠王生已来。正明池数并辨出处。即有其五。一明标指所归之国。二明池有八数之名。三明一一池岸七宝合成。正由宝光映彻通照。八德之水一同杂宝之色。故名宝水也。四明是诸众宝体性柔软。五明八池之水皆从如意宝中出。即名如意水。此水即有八种之德。一者清净润泽。即是色入摄。二者不臭。即是香入摄。三者轻。四者冷。五者软。即是触入摄。六者美。是味入摄。七者饮时调适。八者饮已无患。是法入摄。此八德之义已在弥陀义中广说竟。又赞云。极乐庄严安养国。八德宝池流遍满。四岸含晖间七宝。水色分明映宝光。体性柔软无坚触。菩萨徐行散宝香。宝香宝云成宝盖。宝盖临空覆宝幢。宝幢严仪围宝殿。宝殿宝铃垂珠网。宝网宝乐千重转。随机赞叹宝宫楼。一一宫楼有佛会。恒沙圣众坐思量。愿此有缘常忆念。舍命同生彼法堂。三从分为十四支下至以为底沙已来。正明池分异溜旋还无乱。即有其三。一明渠数多少。二明一一渠岸作黄金色。三明渠下底沙作杂宝色。言金刚者即是无漏之体也。四从一一水中下至寻树上下已来。正明水有不思议用。即有其五。一明别指渠名显彼庄严之相。二明渠内宝华多少。三明华量大小。四明摩尼宝水流注华间。五明宝水从渠而出寻诸宝树上下无碍。故名如意水也。五从其声微妙下至诸佛相好者已来。正明水有不可思议德。即有其二。一明宝水华间流注。微波相触即出妙声。声中皆说妙法。二明宝水上岸寻树枝条华果叶等。或上或下。中间相触皆出妙声。声中皆说妙法。或说众生苦事。觉动菩萨大悲。劝令引他。或说人天等法。或说二乘等法。或说地前地上等法。或说佛地三身等法。六从如意珠王下至念佛法僧已来。正明摩尼多有神德。即有其四。一明珠王内出金光。二明光化作百宝之鸟。三明鸟声哀雅天乐无以比方。四明宝鸟连音同声赞叹念佛法僧。然佛是众生无上大师。除邪向正。法是众生无上良药能断烦恼毒病。法身清净。僧是众生无上福田。但使倾心四事不惮疲劳。五乘依果自然应念所须而至。其宝珠前生八味之水。后出种种金光。非直破闇除昏。到处能施佛事。七从是为下总结。上来虽有七句不同。广明宝池观竟

六就宝楼观中。亦先举。次辨。后结。即有其十一。初言众宝国土者。即是总举观名。牒前生后。此明净土虽有宝流灌注。若无宝楼宫阁亦未为精。为此依报庄严种种圆备也。二言一一界上者。正明宝楼住处。地界遍于彼国。楼亦无穷也。三言有五百亿者。正显其数。一界之上既然。遍满彼国亦皆如是。应知。四从其楼阁中下至作天伎乐已来正明阁内庄严。五从又有乐器下至不鼓自鸣已下。正明楼外庄严。宝乐飞空声流法响。昼夜六时如天宝幢。无思成自事也。六从此众音中下至念比丘僧已来。正明乐虽无识即有说法之能。七从此想成已下至宝池已来。正明显观成相。此明专心住境。悕见宝楼。克念不移。自上庄严总现。八从是为下总结。九从若见此者。牒前观相。生后利益。十从除无量下至生彼国已来。正明依法观察除障多劫。身器清净应佛本心。舍身他世必往无疑。十一从作是观者下至邪观已来。辨观邪正之相。上来虽有十一句不同。广明宝楼观竟

七就华座观中。亦先举。次辨。后结。即有其十九。一从佛告阿难下至除苦恼法已来。正明敕听许说。即有其三。一明告命二人。二明敕听令之谛受正念修行。三明佛为说华座观法。但能住心缘念。罪苦得除。二从汝等忆持下至解说已来。正明劝发流通。此明观法深要。急救常没众生妄爱迷心漂流六道。汝持此观处处劝修。普得知闻同升解脱。三从说是语时下至不得为比已来。正明娑婆化主为物故住想西方。安乐慈尊知情故则影临东域。斯乃二尊许应无异。直以隐显有殊。正由器朴之类万差。致使互为郢匠。言说是语时者。正明就此意中即有其七。一明告劝二人时也。二明弥陀应声即现。证得往生也。三明弥陀在空而立者。但使回心正念愿生我国。立即得生也。问曰。佛德尊高不可辄然轻举。既能不舍本愿来应大悲者。何故不端坐而赴机也。答曰。此明如来别有密意。但以娑婆苦界。杂恶同居八苦相烧。动成违返。诈亲含笑。六贼常随。三恶火坑临临欲入。若不举足以救迷。业系之牢何由得勉。为斯义故。立撮即行。不及端坐以赴机也。四明观音势至以为侍者表无余众也。五明三尊身心圆净光明踰盛也。六明佛身光明朗照十方。垢障凡夫何能具睹。七明佛身无漏。光亦同然。岂将有漏之天金比方之也。四从时韦提希见无量下至作礼已来。正明韦提实是垢凡女质不足可言。但以圣力冥加彼佛现时。得蒙稽首。斯乃序临净国。喜叹无以自胜。今乃正睹弥陀。更益心开悟忍。五从白佛言下至及二菩萨已来。正明夫人领荷佛恩。为物陈疑。生于后问。此明夫人意者佛今现在蒙尊加念。得睹弥陀。佛灭后众生云何可见也。六从未来众生下至及二菩萨已来。明其夫人为物置请使同己见。七从佛告韦提下至当起想念已来。正明总告许说之言。问曰。夫人置请。通已为生。及至如来酬答。但指韦提不通生也。答曰。佛身临化说法以逗机。不请尚自普弘。何论别指而不等备。但以文略故无兼为之。心必有也。八从七宝地上下至华想已来。正明教观方便。问曰。众生盲闇逐想增劳。对目冥若夜游。远标净境。何由可悉。答曰。若望众生惑障动念。徒自疲劳。仰凭圣力遥加。致使所观皆见。云何作法住心而令得见也。欲作法者。诸行者等先于佛像前至心忏悔。发露所造之罪。极生惭愧悲泣流泪。悔过既竟。又心口请释迦佛十方恒沙等佛。又念彼弥陀本愿言。弟子某甲等生盲罪重。障隔处深。愿佛慈悲摄受护念指授开悟。所观之境愿得成就。今顿舍身命仰属弥陀。见以不见皆是佛恩力。道此语已。更复至心忏悔竟已。即向静处面向西方正坐跏趺。一同前法。既住心已。徐徐转心想彼宝地杂色分明。初想不得乱想多境。即难得定。唯观方寸一尺等。或一日二日三日。或四五六七日。或一月一年二三年等。无问日夜。行住坐卧身口意业常与定合。唯万事俱舍。由如失意聋盲痴人者。此定必即易得。若不如是。三业随缘转。定想逐波飞。纵尽千年寿。法眼未曾开。若心得定时。或先有明相现。或可先见宝地等种种分明不思议者。有二种见。一者想见。犹有知觉故。虽见净境。未多明了。二者若内外觉灭。即入正受三昧。所见净境即非想见得为比校也。九从令其莲华下至八万四千光已来。正明宝华有种种庄严。即有其三。一明一一华叶备众宝色。二明一一叶有众多宝脉。三明一一脉有众多光色此令行者住心一一想之。悉令心眼得见。既见华叶已。次想叶间众宝。次想宝出多光。光成宝盖。次想华台台上众宝及珠网等。次想台上四柱宝幢。次想幢上宝幔。次想幔上宝珠光明杂色遍满虚空。各现异相。如是次第一一住心不舍。不久之间即得定心。既得定心。彼诸庄严一切显现。应知。十从了了下辩观成相。十一从华叶小者下至遍覆地上已来。正明叶叶有种种庄严。即有其六。一明华叶大小。二明华叶多少。三明叶间珠映多少。四明珠有千光。五明一一珠光变成宝盖。六明宝盖上照虚空下覆宝地。十二从释迦毗楞伽下至以为交饰已来。正明台上庄严之相。十三从于其台上下至妙宝珠以为映饰已来。正明幢上庄严之相。即有其四。一明台上自有四幢。二明幢之体量大小。三明幢上自有宝幔状似天宫。四明幢上自有众多宝珠辉光映饰。十四从一一宝珠下至施作佛事已来。正明珠光有不思议德用之相。即有其五。一明一一珠有多光。二明一一光各作异色。三明一一光色遍于宝土。四明光所至处各作异种庄严。五明或作金台珠网华云宝乐遍满十方。十五从是为下总结观名。十六从佛告阿难下至比丘愿力所成已来。正明华座得成所由。十七从若欲念彼佛者下至自见面像已来。正明重显观仪。如前次第住心。不得杂乱也。十八从此想成者下至生极乐世界已来。正明结观成相。即有二益。一明除罪益。二明得生益。十九从作是观者下至名为邪观已来。正明辨观邪正相。斯乃华依宝地。叶间奇珍。台莹四幢。光施佛事。上来虽有十九句不同。广明华座观竟

八就像观中。亦先举。次辨。后结。即有其十三。一从佛告阿难下至次当想佛已来。正明结前生后。言所以者何者。是其问也。所以须想佛者何。二从诸佛如来下至心想中已来。正明诸佛大慈应心即现。有斯胜益故劝汝想之。问曰。韦提上请唯指弥陀。未审如来今总举诸佛。有何意也。答曰。欲显诸佛三身同证。悲智果圆等齐无二。端身一坐影现无方。意赴有缘时临法界。言法界者有三义。一者心遍故解法界。二者身遍故解法界。三者无障碍故解法界。正由心到故身亦随到。身随于心故言是法界身也。言法界者是所化之境即众生界也言身者是能化之身即诸佛身也。言入众生心想中者。乃由众生起念愿见诸佛。佛即以无碍智知。即能入彼想心中现。但诸行者若想念中若梦定中见佛者。即成斯义也。三从是故汝等下至从心想生已来。正明结劝利益。此明标心想佛。但作佛解从顶至足心想不舍。一一观之无暂休息。或想顶相。或想眉间白毫乃至足下千轮之相。作此想时。佛像端严相好具足了然而现。乃由心缘一一相故。即一一相现。心若不缘。众相不可见。但自心想作。即应心而现。故言是心即是三十二相也。言八十随形好者。佛相既现。众好皆随也。此正明如来教诸想者具足观也。言是心作佛者。依自信心缘相如作也。言是心是佛者。心能想佛。依想佛身而现。即是心佛也。离此心外更无异佛者也。言诸佛正遍知者。此明诸佛得圆满无障碍智。作意不作意常能遍知法界之心。但能作想即从汝心想而现似如生也。或有行者。将此一门之义作唯识法身之观。或作自性清净佛性观者。其意甚错。绝无少分相似也。既言想像假立三十二相者。真如法界身岂有相而可缘。有身而可取也。然法身无色绝于眼对。更无类可方。故取虚空以喻法身之体也。又今此观门等唯指方立相。住心而取境。总不明无相离念也。如来悬知末代罪浊凡夫。立相住心尚不能得。何况离相而求事者。如似无术通人居空立舍也。四从是故应当下至三佛陀已来。正明如前所益专住必成。展转相教劝观彼佛也。五从想彼佛者。牒前生后。言先当想像者。定所观境。六从闭目开目下至如观掌中已来。正明辨观成相。即有其四。一明身四威仪眼之开合见一金像似现目前。常作此想。二明既能观像。像即须有坐处。即想前华座。想像在上而坐。三明想见像坐已。心眼即开。四明心眼既开即见金像及彼极乐诸庄严事。地上虚空了然无碍。又观像住心之法一如前说。从顶一一想之。面眉毫相眼鼻口耳咽项肩臂手指又抽心向上想。胸腹脐阴胫膝[跳-兆+尃]足十指千轮等一一想之从上向下名顺观。从不千轮向上名逆观。如是逆顺住心。不久必得成也。又佛身及华座宝地等必须上下通观。然十三观中此宝地宝华金像等观最要。若欲教人即教此法。但此一法成者。余观即自然了也。七从见此已下。结成上像身观。生后二菩萨观也。八从复当更作一大莲华下至坐右华座已来。正明成上三身观。生后多身观。欲观此二菩萨者。一如观佛法也。九从此想成时下至遍满彼国已来。正明结成上多身观。生后说法相此明诸行者等行住坐卧常缘彼国一切宝树一切宝楼华池等。若礼念若观想。常作此解也。十从此想成时下至忆持不舍已来。正明因定得见极乐庄严。又闻一切庄严皆能说于妙法。既见闻此已恒持莫失名守定心也。十一从令与修多罗合下至见极乐世界已来。辨观邪正之相。十二从是为下总结。十三从作是观者下至得念佛三昧已来。正明克念修观现蒙利益。斯乃群生障重。真佛之观难阶。是以大圣垂哀。且遣注心形像。上来虽有十三句不同。广明像观竟

九就真身观中。亦先举。次辨。后结。即有其十二。一从佛告阿难下至身相光明已来。正明告命结成前像观。生后真身之观也。二从阿难当知下至金色已来。正明显真佛之身相踰天金之色也。三从佛身高六十下至由旬已来。正明身量大小。四从眉间下至菩萨为侍者已来。正明总观身相。即有其六。一明毫相大小。二明眼相大小。三明毛孔光大小。四明圆光大小。五明化佛多少。六明侍者多少。五从无量寿佛下至摄取不舍已来。正明观身别相光益有缘。即有其五。一明相多少。二明好多少。三明光多少。四明光照远近。五明光所及处偏蒙摄益。问曰。备修众行但能回向皆得往生。何以佛光普照唯摄念佛者。有何意也。答曰。此有三义。一明亲缘。众生起行。口常称佛。佛即闻之。身常礼敬佛。佛即见之。心常念佛。佛即知之。众生忆念佛者。佛亦忆念众生。彼此三业不相舍离。故名亲缘也。二明近缘。众生愿见佛。佛即应念现在目前。故名近缘也。三明增上缘。众生称念即除多劫罪。命欲终时。佛与圣众自来迎接。诸邪业系无能碍者。故名增上缘也。自余众行。虽名是善。若比念佛者。全非比校也。是故诸经中处处广赞念佛功能。如无量寿经四十八愿中。唯明专念弥陀名号得生。又如弥陀经中。一日七日专念弥陀名号得生。又十方恒沙诸佛证诚不虚也。又此经定散文中。唯标专念名号得生。此例非一也。广显念佛三昧竟。六从其光相好已下。结少显多。辄欲观者难为周悉。七从但当忆想已下。正明庄严微妙。出过凡境。虽未证目前。但当忆想令心眼见也。八从见此事者下至摄诸众生已来。正明功呈不失观益得成。即有其五。一明因观得见十方诸佛。二明以见诸佛故结成念佛三昧。三明但观一佛即观一切佛身也。四明由见佛身故即见佛心也。五明佛心者慈悲为体。以此平等大慈普摄一切也。九从作此观者。下至得无生忍已来。正明舍身他世得生彼益也。十从是故智者下至现前授记已来。重明结劝修观利益。即有其五。一明简出能修观人。二明专心谛观无量寿佛。三明相好众多不得总杂而观。唯观白毫一相但得见白毫者。一切众相自然而现也。四明既见弥陀即见十方佛也。五明既见诸佛即于定中得蒙授记也。十一从是为遍观已下总结。十二从作此观已下。正明辨观邪正之相。斯乃真形量远毫若五山。震响随机光沾有识。欲使含灵归命注想无遗乘佛本弘齐临彼国。上来虽有十二句不同。广明真身观竟

十就观音观中。亦先举。次辨。后结。即有其十五。一从佛告阿难下至菩萨已来。正明结成前真身观生后菩萨观。二从此菩萨身长下至皆于中现已来。正明总标身相。即有其六。一明身量大小。二明身色与佛不同。三明肉髻与佛蠃髻不同。四明圆光大小。五明化佛侍者多少。六明身光普现五道众生。三从顶上毗楞伽下至二十五由旬已来。正明天冠之内化佛殊异。四从观音已下。正明面色与身色不同五从眉间下至莲华色已来。正明毫光转变遍满十方。化侍弥多更比红莲之色。即有其五。一明毫相作七宝色。二明毫光多少。三明光有化佛多少。四明侍者多少。五明化侍变现遍满十方。六从有八十亿光明下至庄严事已来。正明身服光璎非众宝作。七从手掌作五百亿下至接引众生已来。正明手有慈悲之用也。即有其六。一明手掌作杂莲之色。二明一一指端有八万印文。三明一一文有八万余色。四明一一色有八万余光。五明光体柔软等照一切。六明以此宝光之手接引有缘也。八从举足时下至莫不弥满已来。正明足有德用之相。九从其余身相已下。指同于佛。十从唯顶上下至不及世尊已来。正明师徒位别果愿未圆。致使二相有亏。表居不足之地也。十一从是为下总结。十二从佛告阿难下至当作是观已来。正明重结前文生其后益。十三从作是观者下至何况谛观已来。正明劝观利益。十四从若有欲观观音下至如观掌中已来。正明重显观仪劝物倾心。使沾两益。十五从作是观已下。正明辨观邪正相。斯乃观音愿重影现十方。宝手停辉随机引接。上来虽有十五句不同。广明观音观竟

十一就势至观中。亦先举。次辨。后结。即有其十三。一从次观大势至已下。总举观名。二从此菩萨身量大小已下。次辨观相。即有其五。一明身量等类观音。二明身色等类观音。三明面相等类观音。四明身光相好等类观音。五明毫相舒光转变等类观音。三从圆光面各百二十五由旬已下。正明圆光等不同观音之相。即有其四。一明圆光大小。二明光照远近。三明化佛多少。四明化佛侍者多少。四从举身光明下至名大势至已来。正明身光远备照益有缘。等及他方。皆作紫金之色。即有其八。一明身光总别不同。二明光照远近。三明光所触处皆作紫金之色。四明但与势志宿业有缘者。即得睹触此光。五明但见一毛孔光即能多见诸佛净妙身光。此即举少以显多益。欲使行之者悕心渴仰入观以证之。六明依光以立名。七明光之体用。即无漏为体故名智慧光。又能除息十方三恶之苦。名无上力。即为用也。八明名大势至者此即依德立名也。五从此菩萨天冠下至皆于中现已来。正明天冠庄严之相与观音不同。即有其四。一明冠上宝华多少。二明一一华上宝台多少。三明一一台中映现十方诸佛净土。四明他方土现。彼此都无增减。六从顶上肉髻下至普现佛事已来。正明肉髻宝瓶之相。七从余诸身相已下。指同观音也。八从此菩萨行时下至如极乐世界已来。正明行与观音不同相。即有其四。一明行不同相。二明震动远近相。三明所震动处华现多。四明所现之华高而且显。多诸莹饰以类极乐庄严也。九从此菩萨坐时下至度苦众生已来。正明坐不同观音相即有其七。一明坐相。二明先动本国相。三明次动他方远近相。四明动摇下上佛刹多少相。五明弥陀观音等分身云集相。六明临空侧塞皆坐宝华。七明分身说法各应所宜。问曰。弥陀经云。彼国众生无有众苦但受诸乐故名极乐。何故此经分身说法乃云度苦者。有何意也。答曰今言苦乐者有二种。一者三界中苦乐。二者净土中苦乐。言三界苦乐者。苦则三涂八苦等。乐则人天五欲放逸系缚等乐。虽言是乐然是大苦。必竟无有一念真实乐也。言净土苦乐者。苦则地前望地上为苦。地上望地前为乐。下智证望上智证为苦。上智证望下智证为乐。此例举一可知也。今言度苦众生者。但为进下位令升上位。转下证令得上证。称本所求即名为乐。故言度苦也。若不然者。净土之中一切圣人皆以无漏为体。大悲为用。毕竟常住离于分段之生灭。更就何义名为苦也。十从作此观者下至十一观已来。正明辨观邪正总结分齐。十一从观此菩萨者已下。正明修观利益除罪多劫。十二从作此观者下至净妙国土已来。正明总结前文重生后益。十三从此观成已下。正明总牒二身。辨观成相。斯乃势至威高坐摇他国。能使分身云集演法利生。永绝胞胎常游法界。上来虽有十三句不同。广解势至观竟

十二就普观中。亦先举。次辨。后结。即有其六。一从见此事时已下。正明牒前生后。二从当起自心下至皆演妙法已来。正明凝心入观即常作自往生想。即有其九。一明自生想。二明向西想。三明坐华想。四明华合想。五明华开想。六明宝光来照身想。七明既蒙光照作眼开想。八明眼目既开作见佛菩萨想。九明闻法想。三从与十二部经合下至不失已来。正明定散无遗守心常忆。一则观心明净。二则诸恶不生。由内与法乐相应。外则无三邪之障。四从见此事已下。明观成之益。五从是为下。总结。六从无量寿下至常来至此行人之所已来。正明重举能观之人即蒙弥陀等三身护念之益。斯乃群生注念愿见西方依正二严。了了常如眼见。上来虽有六句不同。广解普观竟

十三就杂想观中。亦先举。次辨。后结。即有其十一。一从佛告阿难已下。正明告命结劝生后。二从先当观于一丈六已下。正明观像以表真想水以表地。此是如来教诸众生易境转心入观。或在池水华上。或在宝宫宝阁内。或在宝林宝树下。或在宝台宝殿中。或在虚空宝云华盖之内。如是等处一一住心想之。皆作化佛想。为令机境相称易得成故也。三从如先所说下至非心力所及已来。正明境大心小卒难成就。致使圣意悲伤劝观于小。四从然彼如来下至必得成就已来。正明凡心狭小圣量弥宽。注想无由。恐难成就。斯乃不以小故难成。不由大故不现。直是弥陀愿重。致使想者皆成。五从但想佛像下至具足身相已来。正明比校显胜。想像尚自得福无量。何况观于真佛者得益之功更甚。六从阿弥陀下至丈六八尺已来。正明能观所观佛像虽身有大小。明皆是真。即有其三。一明弥陀身通无碍。随意遍周。言如意者有二种。一者如众生意随彼心念皆应度之。二者如弥陀之意五眼圆照六通自在。观机可度者。一念之中无前无后身心等赴三轮开悟。各益不同也。二明或现大身或现小身。三明身量虽有大小皆作真金之色。此即定其邪正也。七从所现之形已下。正明身虽大小有殊。光相即与真无异。八从观世音菩萨已下。正明指同前观。佛大侍者亦大。佛小侍者亦小。九从众生但观首相已下。正明劝观二别。云何二别。观音头首上有一立化佛。势至头首之上有一宝瓶。十从此二菩萨已下。正明弥陀观音势至等宿愿缘重。誓同舍恶等至菩提。影响相随游方化益。十一从是为下总结。上来虽有十一句不同。广解杂想观竟

上从日观下至杂想观已来。总明世尊答前韦提第四请云教我思惟正受两句

总赞云。初教日观除昏闇。想水成冰净内心。地下金幢相映发。地上庄严亿万重。宝云宝盖临空转。人天音乐互相寻。宝树垂璎间杂果。池流德水注华中。宝楼宝阁皆相接。光光相照等无荫。三华独回超众座。四幢承缦网珠罗。禀识心迷由未晓。住心观像静坐彼。一念心开见真佛。身光相好转弥多。救苦观音缘法界。无时不变入娑婆。势至威光能震动。随缘照摄会弥陀。归去来。极乐安身实是精。正念西归华含想。见佛庄严说法声。复有众生心带惑。缘真上境恐难成。致使如来开渐观。华池丈六等金形。变现灵仪虽大小。应物时宜度有情。普劝同生知识等。专心念佛向西倾

又就前请中。初从日观下至华座观已来。总明依报。二从像观下至杂想观已来。总明正报。上来虽有依正二报不同。广明定善一门义竟

观经正宗分定善义卷第三观经正宗分散善义卷第四

        唐沙门善导集记

从此已下次解三辈散善一门之义。就此义中即有其二。一明三福以为正因。二明九品以为正行。今言三福者。第一福即是世俗善根。曾来未闻佛法。但自行孝养仁义礼智信。故名世俗善也。第二福者此名戒善。就此戒中即有人天声闻菩萨等戒。其中或有具受不具受。或有具持不具持。但能回向尽得往生。第三福者名为行善。此是发大乘心凡夫自能行行兼劝有缘。舍恶持心回生净土。又就此三福之中。或有一人单行世福回亦得生。或有一人单行戒福。回亦得生。或有一人单行行福回亦得生。或有一人行上二福回亦得生。或有一人行下二福回亦得生。或有一人具行三福回亦得生。或有人等三福俱不行者。即名十恶邪见阐提人也。言九品者至文当辨应知。今略料简三福差别义意竟

十四就上辈观行善文前总料简即为十一门。一者总明告命。二者辨定其位。三者总举有缘之类。四者辨定三心以为正因。五者正明简机堪与不堪。六者正明受法不同。七者正明修业时节延促有异。八者明回所修行愿生弥陀佛国。九者明临命终时圣来迎接不同。去时迟疾。十者明到彼华开迟疾不同。十一者明华开已后得益有异。今此十一门义者约对九品之文。就一一品中皆有此十一。即为一百番义也。又此十一门义就上辈文前总料简亦得。或就中下辈文前各料简亦得。又此义若以文来勘者。即有具不具。虽有隐显。若据其道理悉皆合有。为此因缘故须广开显出。欲令依行者易解易识也。上来虽有十一门不同。广料简上辈三品义意竟

次下先就上品上生位中。亦先举。次辨。后结即有其十二。一从佛告阿难已下。则双标二意。一明告命。二明辨定其位。此即修学大乘上善凡夫人也。三从若有众生下至即便往生已来。正明总举有生之类。即有其四。一明能信之人。二明求愿往生。三明发心多少。四明得生之益。四从何等为三下至必生彼国已来。正明辨定三心以为正因。即有其二。一明世尊随机显益意密难知非佛自问自征无由得解。二明如来还自答前三心之数。经云。一者至诚心。至者真。诚者实。欲明一切众生身口意业所修解行必须真实心中作。不得外现贤善精进之相。内怀虚假。贪嗔邪伪奸诈百端。恶性难侵事同蛇蝎。虽起三业。名为杂毒之善。亦名虚假之行。不名真实业也。若作如此安心起行者。纵使苦励身心。日夜十二时急走急作。如炙头燃者。众名杂毒之善。欲回此杂毒之行求生彼佛净土者。此必不可也。何以故。正由彼阿弥陀佛因中行菩萨行时。乃至一念一刹那三业所修皆是真实心中作。凡所施为趣求。亦皆真实。又真实有二种。一者自利真实。二者利他真实。言自利真实者。复有二种。一者真实心中制舍自他诸恶及秽国等。行住坐卧想同一切菩萨制舍诸恶我亦如是也。二者真实心中勤修自他凡圣等善。真实心中口业赞叹彼阿弥陀佛及依正二报。又真实心中口业毁厌三界六道等自他依正二报苦恶之事亦赞叹一切众生三业所为善。若非善业者敬而远之。亦不随喜也。又真实心中身业合掌礼敬四事等供养彼阿弥陀佛及依正二报。又真实心中身业轻慢厌舍此生死三界等自他依正二报。又真实心中意业思想观察忆念彼阿弥陀佛及依正二报。如现目前。又真实心中意业轻贱厌舍此生死三界等自他依正二报。不善三业必须真实心中舍。又若起善三业者。必须真实心中作。不简内外明闇。皆须真实。故名至诚心。二者深心。言深心者。即是深信之心也。亦有二种。一者决定深信自身现是罪恶生死凡夫。旷劫已来常没常流转。无有出离之缘。二者决定深信彼阿弥陀佛四十八愿摄受众生。无疑无虑。乘彼愿力定得往生。又决定深信释迦佛说此观经三福九品定散二善。证赞彼佛依正二报。使人欣慕。又决定深信弥陀经中十方恒沙诸佛证劝一切凡夫决定得生。又深信者。仰愿一切行者等。一心唯信佛语。不顾身命。决定依行。佛遣舍者即舍。佛遣行者即行。佛遣去处即去。是名随顺佛教随顺佛意。是名随顺佛愿。是名真佛弟子。又一切行者但能依此经。深信行者。必不误众生也。何以故。佛是满足大悲人故。实语故。除佛已还。智行未满。在其学地。由有正习二障未除。果愿未圆。此等凡圣。纵使测量诸佛教意。未能决了。虽有平章。要须请佛证为定也。若称佛意。即印可言如是如是。若不可佛意者。即言汝等所说是义不如是。不印者即同无记无利无益之语。佛印可者即随顺佛之正教。若佛所有言说即是正教正义正行正解正业正智。若多若少。众不问菩萨人天等。定其是非也。若佛所说即是了教。菩萨等说尽名不了教也。应知。是故今时仰劝一切有缘往生人等。唯可深信佛语专注奉行。不可信用菩萨等不相应教以为疑碍。抱惑自迷废失往生之大益也。又深心深信者。决定建立自心。顺教修行。永除疑错。不为一切别解别行异学异见异执之所退失倾动也问曰。凡夫智浅惑障处深。若逢解行不同人多引经论来相妨难。证云一切罪障凡夫不得往生者。云何对治彼难。成就信心。决定直进。不生怯退也。答曰。若有人多引经论证云不生者。行者即报云。仁者虽将经论来证道不生。如我意者决定不受汝破。何以故。然我亦不是不信彼诸经论。尽皆仰信。然佛说彼经时。处别。时别。对机别。利益别。又说彼经时。即非说观经弥陀经等时。然佛说教备机。时亦不同。彼即通说人天菩萨之解行。今说观经定散二善。唯为韦提及佛灭后五浊五苦等一切凡夫。证言得生。为此因缘。我今一心依此佛教决定奉行。纵使汝等百千万亿导不生者。唯增长成就我往生信心也。又行者更向说言。仁者善听。我今为汝更说决定信相。纵使地前菩萨罗汉辟支等若一若多乃至遍满十方。皆引经论证言不生者。我亦未起一念疑心。唯增长成就我清净信心。何以故。由佛语决定成就了义。不为一切所破坏故。又行者善听。纵使初地已上十地已来若一若多乃至遍满十方。异口同音皆云释迦佛指赞弥陀。毁呰三界六道。劝励众生专心念佛及修余善。毕此一身后必定生彼国者。此必虚妄。不可依信也。我虽闻此等所说。亦不生一念疑心。唯增长成就我决定上上信心。何以故。乃由佛语真实决了义故。佛是实知实解实见实证。非是疑惑心中语故。又不为一切菩萨异见异解之所破坏。若实是菩萨者。众不违佛教也。又置此事。行者当知。纵使化佛报佛若一若多乃至遍满十方。各各辉光吐舌遍覆十方。一一说言释迦所说相赞劝发一切凡夫。专心念佛及修余善。回愿得生彼净土者。此是虚妄。定无此事也。我虽闻此等诸佛所说。毕竟不起一念疑退之心。畏不得生彼佛国也。何以故。一佛一切佛。所有知见解行证悟果位大悲等同。无少差别。是故一佛所制即一切佛同制。如似前佛制断杀生十恶等罪。毕竟不犯不行者即名十善十行随顺六度之义。若有后佛出世。岂可改前十善令行十恶也。以此道理推验。明知诸佛言行不相违失。纵令释迦指劝一切凡夫。尽此一身专念专修。舍命已彼定生彼国者。即十方诸佛悉皆同赞同劝同证。何以故。同体大悲故。一佛所化即是一切佛化。一切佛化即是一佛所化。即弥陀经中说。释迦赞叹极乐种种庄严。又劝一切凡夫。一日七日一心专念弥陀名号。定得往生。次下文云。十方各有恒河沙等诸佛。同赞释迦能于五浊恶时恶世界恶众生恶见恶烦恼恶邪无信盛时。指赞弥陀名号。劝励众生称念必得往生。即其证也。又十方佛等恐畏众生不信释迦一佛所说。即共同心同时各出舌相遍覆三千世界语诚实言。汝等众生皆应信是释迦所说所赞所证。一切凡夫不问罪福多少时节久近。但能上尽百年下至一日七日。一心专念弥陀名号。定得往生。必无疑也。是故一佛所说即一切佛同证诚其事也。此名就人立信也。次就行立信者。然行有二种一者正行。二者杂行。言正行者。专依往生经行行者是名正行。何者是也。一心专读诵此观经弥陀经无量寿经等。一心专注思想观察忆念彼国二报庄严。若礼即一心专礼彼佛。若口称即一心专称彼佛。若赞叹供养即一心专赞叹供养。是名为正。又就此正中。复有二种。一者一心专念弥陀名号。行住坐卧不问时节久近念念不舍者。是名正定之业。顺彼佛愿故。若依礼诵等。即名为助业。除此正助二行已外自余诸善悉名杂行。若修前正助二行。心常亲近忆念不断。名为无间也。若行后杂行即心常间断。虽可回向得生。众名疏杂之行也。故名深心。三者回向发愿心。言回向发愿心者。过去及以今生身口意业所修世出世善根及随喜他一切凡圣身口意业所修世出世善根以此自他所修善根。悉皆真实深信心中回向愿生彼国。故名回向发愿心也。又回向发愿愿生者。必须决定真实心中回向愿作得生想。此心深信由若金刚。不为一切异见异学别解别行人等之所动乱破坏。唯是决定一心投正直进。不得闻彼人语即有进退心生怯弱。回顾落道。即失往生之大益也。问曰。若有解行不同邪杂人等来相惑乱。或说种种疑难。道不得往生。或云汝等众生旷劫已来及以今生身口意业。于一切凡圣身上。具造十恶五逆四重谤法阐提破戒破见等罪。未能除尽。然此等之罪系属三界恶道。云何一生修福念佛即入彼无漏无生之国永得证悟不退位也。答曰。诸佛教行数越尘沙。禀识机缘。随情非一。譬如世间人眼可见可信者。如明能破闇。空能含有。地能载养。水能生润。火能成坏。如此等事悉名待对之法。即目可见。千差万别。何况佛法不思议之力岂无种种益也。随出一门者即出一烦恼门也。随入一门者即入一解脱智慧门也。为此随缘起行。各求解脱。汝何以乃将非有缘之要行。障惑于我然我之所爱即是我有缘之行。即非汝所求。汝之所爱即是汝有缘之行。亦非我所求。是故各随所乐而修其行者。必疾得解脱也。行者当知。若欲学解。从凡至圣乃至佛果。一切无碍皆得学也。若欲学行者。必藉有缘之法。少用功劳。多得益也。又白一切往生人等。今更为行者说一譬喻守护信心。以防外邪异见之难。何者是也。譬如有人欲向西行百千之里。忽然中路见有二河。一是火河在南。二是水河在北。二河各阔百步。各深无底。南北无边。正水火中间有一白道。可阔四五寸许。此道从东岸至西岸。亦长百步。其水波浪交过湿道。其火焰亦来烧道。水火相交常无休息。此人既至空旷迥处。更无人物。多有群贼恶兽。见此人单独。竞来欲杀此人。怖死直走向西。忽然见此大河。即自念言。此河南北不见边畔。中间见一白道。极是狭小。二岸相去虽近。何由可行。今日定死不疑。正欲到回群贼恶兽渐渐来逼。正欲南北避走恶兽毒虫竞来向我。正欲向西寻道而去。复恐堕此水火二河。当时惶怖不复可言。即自思念。我今回亦死。住亦死。去亦死。一种不勉死者。我宁寻此道向前而去。既有此道。必应可度。作此念时。东岸忽闻人劝声。仁者。但决定寻此道行。必无死难。若住即死。又西岸上有人唤言。汝一心正念直来。我能护汝。众不畏堕于水火之难。此人既闻此遣彼唤。即自正当身心。决定寻道直进。不生疑怯退心。或行一分二分。东岸群贼等唤言。仁者回来。此道崄恶不得过必死不疑。我等众无恶心相向。此人虽闻唤声。亦不回顾。一心直进念道而行。须臾即到西岸。永离诸难。善友相见。庆乐无已。此是喻也。次合喻者。言东岸者即喻此娑婆之火宅也。言西岸者即喻极乐宝国也。言群贼恶兽诈亲者即喻众生六根六识六尘五阴四大也。言无人空迥泽者即喻常随恶友不值真善知识也。言水火二河者即喻众生贪爱如水嗔憎如火也。言中间白道四五寸者。即喻众生贪嗔烦恼中能生清净愿往生心也。乃由贪嗔强故即喻如水火。善心微故。喻如白道。又水波常湿道者。即喻爱心常起。能染污善心也。又火焰常烧道者。即喻嗔嫌之心能烧功德之法财也。言人行道上直向西者。即喻回诸行业直向西方也。言东岸闻人声劝遣寻道直西进者。即喻释迦已灭后人不见。由有教法可寻。即喻之如声也。言或行一分二分群贼等唤回者。即喻别解别行恶见人等妄说见解迭相惑乱。及自造罪退失也。言西岸上有人唤者。即喻弥陀愿意也。言须臾到西岸善友相见喜者。即喻众生久沉生死。旷劫沦回迷倒自缠。无由解脱。仰蒙释迦发遣指向西方。又藉弥陀悲心招唤。今信顺二尊之意。不顾水火二河。念念无遗。乘彼愿力之道。舍命已后得生彼国。与佛相见。庆喜何极也。又一切行者行住坐卧三业所修。无问昼夜时节。常作此解。常作此想。故名回向发愿心。又言回向者。生彼国已还起大悲。回入生死教化众生。亦名回向也。三心既具。无行不成。愿行既成若不生者。无有是处也。又此三心亦通摄定善之义。应知。五从复有三种众生已下。正明简机堪能奉法依教修行。六从何等为三下至六念已来。正明受法不同。即有其三。一明慈心不杀。然杀业有多种。或有口杀。或有身杀。或有心杀。言口杀者。处分许可名为口杀。言身杀者。动身手等指授名为身杀。言心杀者。思念方便计校等名为心杀。若论杀业。不简四生皆能招罪障生净土。但于一切生命起于慈心者。即是施一切众生寿命安乐。亦是最上胜妙戒也。此即合上初福第三句云慈心不杀也。即有止行二善。自不杀故名止善。教他不杀故名行善。自他初断名止善。毕竟永除名行善。虽有止持二善。总结成慈下行也。言具诸戒行者。若约人天二乘之器即名小戒。若约大心大行之人即名菩萨戒。此戒若以位约者。当此上辈三位者即名菩萨戒。正由人位定故自然转成。即合上第二福戒分善根也。二明读诵大乘者。此明众生性习不同。执法各异。前第一人但用修慈持戒为能。次第二人唯将读诵大乘为是。然戒即能持五乘三佛之机。法即薰成三贤十地万行之智慧。若以德用来比校者。各有一能。即合上第三福第三句云读诵大乘也。三明修行六念者。所谓念佛法僧。念戒舍天等。此亦通合上第三福大乘之意义也。言念佛者即专念阿弥陀佛口业功德身业功德意业功德。一切诸佛亦如是。又一心专念诸佛所证之法并诸眷属菩萨僧。又念诸佛之戒。及念过去诸佛现在菩萨等难作能作。难舍能舍。内舍外舍。内外舍。此等菩萨。但欲念法不惜身财。行者等既念知此事。即须常作仰学前贤后圣舍身命意也。又念天者即是最后身十地之菩萨。此等难行之行已过。三祇之劫已超。万德之行已成。灌顶之位已证。行者等既念知已。即自思念。我身无际已来。共他同时发愿。断恶行菩萨道。他尽不惜身命。行道进位。因圆果熟证圣者。踰于大地微尘。然我等凡夫。乃至今日虚然流浪。烦恼恶障转转增多。福慧微微。若对重昏之临明镜也。忽思忖此事。不胜心惊悲叹者哉。七从回向发愿已下。正明各各回前所修之业。向所求处。八从具此功德已下。正明修行时节延促。上尽一形下至一日一时一念等。或从一念十念至一时一日一形。大意者。一发心已后誓毕此生。无有退转。唯以净土为期。又言具此功德者。或一人具上二。或一人具下二。或一人三种尽具。或有人三种无分者。名作着人皮畜生。非名人也。又不问具三不具三。回尽得往生。应知。九从生彼国时下至往生彼国已来。正明临命终时圣来迎接不同去时迟疾。即有其十一。一明标定所归之国。二明重显其行指出决定精勤者。亦是校量功德强弱。三明弥陀化主身自来赴。四明观音已下更显无数大众等皆从弥陀来迎行者。五明宝宫随众。六明重观音势至共执金台至行者前。七明弥陀放光照行者之身。八明佛既舒光照及即与化佛等同时接手。九明既接升台观音等同声赞劝行者之心。十明自见乘台从佛。十一正明去时迟疾。十从生彼国已下。正明金台到彼。更无华合之障。十一从见佛色身下至陀罗尼门已来。正明金台到后得益不同。即有其三。一者初闻妙法即悟无生。二者须臾历事次第授记。三者本国他方更证闻持二益。十二从是名已下总结。上来虽有十二句不同。广解上品上生义竟

次就上品中生位中。亦先举。次辨。后结。即有其八。一从上品中生者已下。总举位名。即是大乘次善凡夫人也。二从不必受持下至生彼国已来。正明第六第七第八门中回所修业。定指西方。即有其四。一明受法不定。或得读诵不得读诵。二明善解大乘空义。或听闻诸法一切皆空。生死无为亦空。凡圣明闇亦空。世间六道出世间三贤十圣等。若望其体性毕竟不二。虽闻此说其心坦然不生疑滞也。三明深信世出世苦乐二种因果。此等因果及诸道理不生疑谤。若生疑谤即不成福行。世间果报尚不可得。何况得生净土。此即合第三福第二第三句也。四明回前所业标指所归。三从行此行者下至迎接汝已来。正明弥陀与诸圣众持台来应。即有其五。一明行者命延不久。二明弥陀与众自来。三明侍者持台至行者前。四明佛与圣众同声赞叹述本所修之业。五明佛恐行者怀疑故言我来迎汝。四从与千化佛下至七宝池中已来。正明第九门中众圣授手去时迟疾。即有其五。一明弥陀与千化佛同时授手。二明行者既蒙授手。即自见身已坐紫金之台。三明既自见坐台。合掌仰赞弥陀等众。四明正去时迟疾。五明到彼止住宝池之内。五从此紫金台已下。正明第十门中到彼华开时节不同。由行强故上上即得金刚台。由行劣故上中即得紫金台。生在宝池迳宿如开也。六从佛及菩萨俱时放光下至得不退转已来。正明第十一门中华开已后得益不同。即有其五。一明佛光照身。二明行者既蒙照体目即开明。三明人中所习到彼众声所彰还闻其法。四明既得眼开闻法即下金台亲到佛边。歌扬赞德。五明迳时七日即得无生。言七日者恐此间七日。不指彼国七日也。此间迳于七日者。彼处即是一念须臾间也。应知。七从应时即能飞至十方下至现前授记已来。正明他方得益。即有其五。一明身至十方。二明一一历供诸佛。三明修多三昧。四明延时得忍。五明一一佛边现蒙授记。八从是名已下总结。上来虽有八句不同。广解上品中生竟

次就上品下生位中。亦先举。次辨。后结。即有其八。一从上品下生者已下。总举位名。即是大乘下善凡夫人也。二从亦信因果下至无上道心已来。正明第六门中受法不同。即有其三。一明所信因果不定。或信不信。故名为亦。或可亦同前深信也。又虽信不深。善心数退恶法数起。此乃由不深信苦乐因果也。若深信生死苦者。罪业毕竟不重犯。若深信净土无为乐者。善心一发永无退失也。二明信虽间断。于一切大乘不得疑谤。若起疑谤者。纵使千佛绕身。无由可救也。三明已上诸善似亦无功。唯发一念厌苦。乐生诸佛境界速满菩萨大悲愿行。还入生死普度众生。故名发菩提心也。此义第三福中已明竟。三从以此功德已下。正明第八门中回前正行向所求处。四从行者命欲终时下至七宝池中已来。正明第九门中临终圣来迎接去时迟疾。即有其九。一明命延不久。二明弥陀与诸圣众持金华来应。三明化佛同时授手。四明圣众同声等赞。五明行者罪灭故云清净。述本所修故云发无上道心。六明行者虽睹灵仪。疑心恐不得往生。是故圣众同声告言我来迎汝。七明既蒙告及即见自身已坐金华之上。笼笼而合。八明随佛身后一念即生。九明到彼在宝池中。五从一日一夜已下。正明第十门中到彼华开时节不同。六从七日之中下至皆演妙法已来。正明第十一门中华开已后得益不同。七从游历十方下至住欢喜地已来。正明他方得益。亦名后益也。八从是名已下总结。上来虽有八句不同。广解上品下生竟

赞云。上辈上行上根人求生净土断贪嗔。就行差别分三品。五门相续助三因。一日七日专精进毕命乘台出六尘。庆哉难逢今得遇。永证无为法性身。上来虽有三位不同。总解上辈一门之义竟

十五就中辈观行善文前总料简即为十一门。一者总明告命。二者正明辨定其位。三者正明总举有缘之类。四者正明辨定三心以为正因。五者正明简机堪与不堪。六者正明受法不同。七者正明修业时节延促有异。八者正明回所修行。愿生弥陀佛国。九者正明临命终时圣来迎接不同去时迟疾。十者正明到彼华开迟疾不同。十一者正明华开已后得益有异。上来虽有十一门不同。广料简中辈三品竟

次就中品上生位中。亦先举。次辨。后结。即有其八。一从佛告阿难已下。总明告命。二从中品上生者。正明辨定其位。即是小乘根性上善凡夫人也。三从若有众生下至无众过患已来。正明第五第六门中受法不同。即有其四。一明简机堪与不堪。二明受持小乘斋戒等。三明小戒力微不消五逆之罪。四明虽持小戒等不得有犯。设有余愆。恒须改悔必令清净。此即合上第二戒善之福也。然修戒时。或是终身。或一年一月一日一夜一时等。此时亦不定。大意皆毕命为期不得毁犯也。四从以此善根回向已下。正明第八门中回所修业向所求处。五从临命终时下至极乐世界已来。正明第九门中终时。圣来迎接不同去时迟疾。即有其六。一明命延不久。二明弥陀与比丘众来无有菩萨。由是小乘根性还感小根之众也。三明佛放金光照行者身。四明佛为说法又赞出家离多众苦。种种俗缘家业王官长征远防等汝今出家。仰于四辈。万事不忧。迥然自在。去住无障。为此得修道业。是故赞云离众苦也。五明行者既见闻已不胜欣喜。即自见身已坐华台。低头礼佛。六明行者低头在此。举头已在彼国也。六从莲华寻开者。正明第十门中到彼华开迟疾不同。七从当华敷时下至八解脱已来。正明第十一门中华开已后得益不同。即有其三。一明宝华寻发。此由戒行精强故也。二明法音同赞四谛之德。三明到彼闻说四谛。即获罗汉之果。言罗汉者此云无生。亦云无著。因亡故无生。果丧故无著。言三明者。宿命明。天眼明。漏尽明也。言八解脱者。内有色外观色一解脱。内无色外观色二解脱。不净相三解脱。四空及灭尽总成八也。八从是名已下总结。上来虽有八句不同广解中品上生竟

次就中品中生位中。亦先举。次辨。后结。即有其七。一从中品中生者。总举行名辨定其位。即是小乘下善凡夫人也。二从若有众生下至威仪无缺已来。正明第五六七门中简机时分受法等不同。即有其三。一明受持八戒斋。二明受持沙弥戒。三明受持具足戒。此三品戒皆同一日一夜。清净无犯。乃至轻罪。如犯极重之过。三业威仪不令有失也。此即合上第二福。应知。三从以此功德已下。正明回所修业向所求处。四从戒香熏修下至七宝池中已来。正明第九门中行者终时圣来迎接去时迟疾。即有其八。一明命延不久。二明弥陀与诸比丘众来。三明佛放金光照行者身。四明比丘持华来现。五明行者自见闻空声等赞。六明佛赞言汝深信佛语。随顺无疑故来迎汝。七明既蒙佛赞即见自坐华座。坐已华合。八明华既合已即入西方宝池之内。五从经于七日已下。正明第十门中到彼华开时节不同。六从华既敷已下至成罗汉已来。正明第十一门中华开已后得益不同。即有其四。一明华开见佛。二明合掌赞佛。三明闻法得于初果。四明经半劫已方成罗汉。七从是名已下总结。上来虽有七句不同。广解中品中生竟

次就中品下生位中。亦先举。次辨。后结。即有其七。一从中品下生已下。正明总举行名。辨定其位。即是世善上福凡夫人也。二从若有善男子下至行世仁慈已来。正明第五第六门中简机授法不同。即有其四。一明简机。二明孝养父母奉顺六亲。即合上初福第一第二句。三明此人性调柔善不简自他。见物遭苦起于慈敬。四正明此品之人不曾见闻佛法。亦不解悕求。但自行孝养也。应知。三从此人命欲终时下至四十八愿已来。正明第八门中临终遇逢佛法时节分齐。四从闻此事已下至极乐世界已来。正明第九门中得生之益去时迟疾也。五从生经七日者。正明第十门中到彼华开不开为异。六从遇观世音下至成罗汉已来。正明第十一门中华开已后得益不同。即有其三。一明迳时已后得遇观音大势。二明既逢二圣得闻妙法。三明迳一小劫已后始悟罗汉也。七从是名已下总结。上来虽有七句不同。广解中品下生竟

赞云。中辈中行中根人一日斋戒处金莲。孝养父母教回向为说西方快乐因。佛与声闻众来取。直到弥陀华座边。百宝华笼经七日三品莲开证小真。上来虽有三位不同。总解中辈一门之义竟

十六就下辈观善恶二行文前料简。即为十一门。一者总明告命。二者辨定其位。三者总举有缘生类。四者辨定三心以为正因。五者简机堪与不堪。六者明受苦乐二法不同。七者明修业时节延促有异。八者明回所修行向所求处。九者明临终时圣来迎接不同去时迟疾。十者明到彼华开迟疾不同。十一者明华开已后得益有异。上来虽有十一门不同。总料简下辈三位竟

次就下品上生位中。亦先举。次辨。后结。即有其九。一从佛告阿难已下。正明告命。二从下品上生者。正明辨定其位。即是造十恶轻罪凡夫人也。三从或有众生下至无有惭愧已来。正明第五门中简机举出一生已来造恶轻重之相。即有其五。一明总举造恶之机。二明造作众恶。三明虽作众罪于诸大乘不生诽谤。四明重牒造恶之人非智者之类也。五明此等愚人虽造众罪。总不生愧心。四从命欲终时下至生死之罪已来。正明造恶人等临终遇善闻法。即有其六。一明命延不久。二明忽遇往生善知识。三明善人为赞众经。四明已闻经功力除罪千劫。五明智者转教称念弥陀之号。六明以称弥陀名故除罪五百万劫。问曰。何故闻经十二部但除罪千劫。称佛一声即除罪五百万劫者。何意也。答曰。造罪之人障重加以死苦来逼。善人虽说多经。食受之心浮散。由心散故。除罪稍轻。又佛名是一。即能摄散以住心。复教令正念称名。由心重故即能除罪多劫也。五从尔时彼佛下至生宝池中已来。正明第九门中终时化众来迎去时迟疾。即有其六。一明行者正称名时。彼弥陀即遣化众应声来现。二明化众既已身现。即同赞行人。三明所闻化赞但述称佛之功。我来迎汝。不论闻经之事。然望佛愿意者。唯劝正念称名。往生义疾。不同杂散之业。如此经及诸部中处处广叹。劝令称名。将为要益也。应知。四明既蒙化众告及即见光明遍室。五明既蒙光照报命寻终。六明乘华从佛生宝池中。六从经七七日已下。正明第十门中到彼华开迟疾不同。七从当华敷时下至得入初地已来。正明第十一门中华开已后得益有异。即有其五。一明观音等先放神光。二明身赴行者宝华之侧。三明为说前生所闻之教。四明行者闻已领解发心。五明远迳多劫证临百法之位也。八从是名已下总结。九从得闻佛名已下。重举行者之益。非但念佛独得往生。法僧通念。亦得去也。上来虽有九句不同。广解下品上生竟次就下品中生位中。亦先举。次辨。后结。即有其七。一从佛告阿难已下。总明告命。二从下品中生者。正明辨定其位。即是破戒次罪凡夫人也。三从或有众生下至应堕地狱已来。正明第五第六门中简机造业。即有其七。一明总举造恶之机。二明多犯诸戒。三明偷盗僧物。四明邪命说法。五明总无愧心。六明兼造众罪内心发恶外即身口为恶。既自身不善。又见者皆憎。故云诸恶心自庄严也。七明验斯罪状。定入地狱。四从命欲终时下至即得往生已来。正明第九门中终时善恶来迎。即有其九。一明罪人命延不久。二明狱火来现。三明正火现时遇善知识。四明善人为说弥陀功德。五明罪人既闻弥陀名号即除罪多劫。六明既蒙罪灭火变为风。七明天华随风来应。罗列目前。八明化众来迎。九明去时迟疾。五从七宝池中下至六劫已来。正明第十门中到彼华开时节不同。六从莲华乃敷下至发无上道心已来。正明第十一门中华开已后得益有异。即有其三。一明华既开已观音等梵声安慰。二明为说甚深妙典。三明行者领解发心。七从是名已下总结。上来虽有七句不同。广解下品中生竟

次就下品下生位中。亦先举。次辨。后结。即有其七。一从佛告阿难已下。总明告命。二从下品下生者。正明辨定其位。即是具造五逆等重罪凡夫人也。三从或有众生下至受苦无穷已来。正明第五第六门中简机造恶轻重之相。即有其七。一明造恶之机。二明总举不善之名。三明简罪轻重。四明总结众恶。非智人之业。五明造恶既多罪亦非轻。六明非业不受其报。非因不受其果。因业既非是乐。果报焉能不苦也。七明造恶之因既具酬报之劫未穷。问曰。如四十八愿中唯除五逆诽谤正法不得往生。今此观经下品下生中简谤法摄五逆者。有何意也。答曰。此义仰就抑止门中解。如四十八愿中除谤法五逆者。然此之二业其障极重。众生若造直入阿鼻。历劫周慞无由可出。但如来恐其造斯二过。方便止言不得往生。亦不是不摄也。又下品下生中取五逆除谤法者。其五逆已作。不可舍令流转。还发大悲摄取往生。然谤法之罪未为。又止言若起谤法即不得生。此就未造业而解也。若造。还摄得生。虽得生彼。华合迳于多劫。此等罪人在华内时有三种障。一者不得见佛及诸圣众。二者不得听闻正法。三者不得历事供养。除此已外更无诸苦。经云犹如比丘入三禅之乐也。应知。虽在华中多劫不开可不胜阿鼻地狱之中长时永劫受诸苦痛也。此义就抑止门解竟。四从如此愚人下至生死之罪已来。正明闻法念佛得蒙现益。即有其十。一明重牒造恶之人。二明命延不久。三明临终遇善知识。四明善人安慰教令念佛。五明罪人死苦来逼。无由得念佛名。六明善友知苦失念。转教口称弥陀名号。七明念数多少声声无间。八明除罪多劫。九明临终正念即有金华来应。十明去时迟疾直到所归之国。五从于莲华中满十二劫已下。正明第十门中到彼华开迟疾不同。六从观音大势下至发菩提心已来。正明第十一门中华开已后得益有异。即有其三。一明二圣为宣甚深妙法。二明除罪欢喜。三明后发胜心。七从是名已下总结。上来虽有七句不同。广解下品下生竟

赞云。下辈下行下根人十恶五逆等贪嗔四重偷僧谤正法。未曾惭愧悔前愆。终时苦相如云集。地狱猛火罪人前。忽遇往生善知识急劝专称彼佛名。化佛菩萨寻声到。一念倾心入宝莲。三华障重开多劫。于时始发菩提因。上来虽有三位不同。总解下辈一门之义竟

前明十三观以为定善。即是韦提致请如来已答。后明三福九品名为散善。是佛自说。虽有定散两门有异。总解正宗分竟

三就得益分中。亦先举。次辨。即有其七。初言说是语者。正明总牒前文生后得益之相。二从韦提已下。正明能闻法人。三从应时即见极乐已下。正明夫人等于上光台中见极乐之相。四从得见佛身及二菩萨已下。正明夫人于第七观初见无量寿佛时即得无生之益。五从侍女已下。正明睹斯胜相。各发无上之心。求生净土。六从世尊悉记已下。正明侍女得蒙尊记。皆生彼国。即获现前三昧。七从无量诸天已下。正明前厌苦缘中释梵护世诸天等从佛王宫临空听法。或见释迦毫光转变。或见弥陀金色灵仪。或闻九品往生殊异。或闻定散两门俱摄。或闻善恶之行齐归。或闻西方净土对目非远。或闻一生专精决志。永与生死。分流。此等诸天既闻如来广说希奇之益。各发无上之心。斯乃佛是圣中之极发语成经。凡惑之类蒙餐。能使闻之获益。上来虽有七句不同。广解得益分竟

四次明流通分。于中有二。一明王宫流通。二明耆阇流通。今先就王宫流通分中。即有其七。一从尔时阿难已下。正明请发之由。二从佛告阿难已下。正明如来双标依正以立经名。又能依经起行三障之云自卷。答前初问云何名此经一句。三从汝当受持已下。答前后问云何受持一句。四从行此三昧者下至何况忆念已来。正明比校显胜劝人奉行。即有其四。一明总标定善以立三昧之名。二明依观修行即见三身之益。三明重举能行教之机。四正明比校显胜。但闻三身之号。尚灭多劫罪愆。何况正念归依。而不获证也。五从若念佛者下至生诸佛家已来。正显念佛三昧功能超绝。实非杂善得为比类。即有其五。一明专念弥陀佛名。二明指赞能念之人。三明若能相续念佛者此人甚为希有。更无物可以方之。故引分陀利为喻。言分陀利者。名人中好华。亦名希有华。亦名人中上上华。亦名人中妙好华。此华相传名蔡华。是若念佛者。即是人中好人。人中妙好人。人中上上人。人中希有人。人中最胜人也。四明专念弥陀名者即观音势至常随影护亦如亲友知识也。五明今生既蒙此益。舍命即入诸佛之家。即净土是也。到彼长时闻法。历事供养。因圆果满。道场之座岂赊。六从佛告阿难汝好持是语已下。正明付属弥陀名号。流通于遐代。上来虽说定散两门之益。望佛本愿意在众生一向专称弥陀佛名。七从佛说此语时已下。正明能请能传等闻所未闻。见所未见。遇餐甘露。喜跃无以自胜也。上来虽有七句不同。广解王宫流通分竟

五就耆阇会中。亦有其三。一从尔时世尊已下。明耆阇序分。二从尔时阿难已下。明耆阇正宗分。三从无量诸天已下。明耆阇流通分。上来虽有三义不同。总明耆阇分竟

初从如是我闻下至云何见极乐世界已来。明序分。二从日观下至下品下生已来明正宗分。三从说是语时下至诸天发心已来。明得益分。四从尔时阿难下至韦提等欢喜已来。明王宫流通分。五从尔时世尊下至作礼而退已来。总明耆阇分。上来虽有五分不同。总解观经一部文义竟

窃以真宗叵遇。净土之要难逢。欲使五趣齐生。是以劝闻于后代。但如来神力转变无方。隐显随机王宫密化。于是耆阇圣众小智怀疑。佛后还山弗窥委况。于时阿难为宣王宫之化定散两门。异众因此同闻。莫不奉行顶戴

敬白一切有缘知识等。余既是生死凡夫。智慧浅短。然佛教幽微。不敢辄生异解。遂即标心结愿。请求灵验。方可造心。南无归命尽虚空遍法界一切三宝。释迦牟尼佛。阿弥陀佛。观音势至。彼土诸菩萨大海众。及一切庄严相等。某今欲出此观经要义楷定古今。若称三世诸佛释迦佛阿弥陀佛等大悲愿意者。愿于梦中得见如上所愿一切境界诸相。于佛像前结愿已。日别诵阿弥陀经三遍。念阿弥陀佛三万遍。至心发愿。即于当夜见西方空中如上诸相境界悉皆显现。杂色宝山百重千重。种种光明下照于地。地如金色。中有诸佛菩萨。或坐或立。或语或默。或动身手。或住不动者。既见此相。合掌立观。量久乃觉。觉已不胜欣喜。于即条录义门。自此已后。每夜梦中常有一僧而来指授玄义科文。既了更不复见。后时脱本竟已。复更至心要期七日。日别诵阿弥陀经十遍。念阿弥陀佛三万遍。初夜后夜观想彼佛国土庄严等相。诚心归命一如上法。当夜即见三具硙轮道边独转。忽有一人乘白骆驼来前见劝。师当努力决定往生。莫作退转。此界秽恶多苦。不劳贪乐。答言。大蒙贤者好心视诲。某毕命为期。不敢生于懈慢之心(云云)。第二夜见阿弥陀佛身真金色。在七宝树下金莲华上坐。十僧围绕亦各坐一宝树下。佛树上乃有天衣挂绕。正面向西合掌坐观。第三夜见两幢杆极大高显。幢悬五色。道路纵横人观无碍。既得此相已。即便休止不至七日。上来所有灵相者。本心为物。不为己身。既蒙此相。不敢隐藏。谨以申呈义后。被闻于末代。愿使含灵闻之生信。有识睹者西归。以此功德回施众生。悉发菩提心。慈心相向。佛眼相看。菩提眷属作真善知识。同归净国。共成佛道。此义已请证定竟。一句一字不可加减。欲写者一如经法。应知

观经正宗分散善义卷第四


观弥勒菩萨上兜率天经题

    No. 1772 [cf. No. 452]

观弥勒菩萨上兜率天经题序

        大慈恩寺基撰

原夫性质杳冥超蹄象而含总。觉体玄眇绝视听而融贯。方智云法縠月察神理而犹迷。假慧仞于丛筠揆灵机而不测。至道圆而粹容显。实际彰而真识净。然后俯提十地疏海目于宝方。下控三乘挺仙仪于垢城。若鸿钟之虚受应物扣以腾声。譬皎魄以澄晖循器清而肆影。故有绍隆报佛即灌顶于甄台。纂业化身先贻神于绀殿。抚根熟而趋座待生机而降迹。斯乃三际受职之宏仪一生补处之灵范者也。今此经者洒群萌之一雨。济众兽之通津。运弱丧之大舟。引炎童之妙轮。虽复探幽晓秘归乎异线之华。然而拯溺符机寔在此筌之叶。所以金光夕烛旗有景于昏徒。芳蘤前雾表无亏于后实。妙祥之俦波萎鹙子之辈云趋。虽则禀训一时实乃津梁千祀。若夫天宫圣境资莫限之因严。觉苑神几协无强之德履。匪心枢而揽观。岂语极之扬光教府自陈题衡息。赞　观弥勒菩萨上生兜率天经者。六事齐修二因兼积。心勤妙境欣趣日观。弥勒梵音此云慈氏。母志悲缠蠢类。子性恤及怀生。宿愿今诚俱以标号。道圆上果迹履下因。祈觉运生假称菩萨。上生即往升兜率。言知足自在光洁神用名天。此由补处天宫端居利他。祈心住观必获瞻奉。经者摄也贯也常也法也。生资教摄永绝樊笼。理藉文贯长离散灭。百灵常轨千叶良规。利物诠真目为经也

初释经文聊以五门分别。一佛成权实。二慈氏所因。三时分有殊。四往生难易。五问答料简

第一佛成权实者。权谓随宜接物。实谓究理往真。佛之身说皆有此二。只如法华经为引不定性云。唯此一事实。余二即非真。显一乘教为实二乘教为权。即涅槃经半满教也。胜鬘经中明决定义云。若如来随彼意欲而方便说唯有一乘无有二乘。即唯说有一乘为权。说有四乘为实。谓大乘独觉声闻及无闻非法众生以人天善根而成就之。教既如是。身亦复然。故金刚般若经云。若以色见我以音声寻我。彼生履邪断不能当见我。彼如来妙体即导师法身体不可见。彼识不能识。其论又云。应化非真佛。彼亦非说法者。说法不二取无说离言相。以法身为实。二身为权。法华经中执粪器而着垢衣喻权身也。现寿量而无边际显实身也。此以受用为实。化身为权。然此三身有二四句。有报非化谓自受用身。有化非报谓现八相身。有报亦化谓他受用身。多受法乐可言受用。随机而现可言变化。有非报化谓佛法身。复有四句。有报非化谓自受用身。有化非报谓随生类六趣化身。长者居士猿猴鹿马种种之身。有报亦化谓他受用及八相身。前变化身亦此句摄。有非报化谓佛法身。虽此四句说身不同。权实二德总皆摄尽。略有二种。一者法身称实。余二并权。实者诸法体真。权者事相权迹。般若论云。应化非真佛等是。二者法身及自受用唯佛与佛乃能知之。是身之本俱离差别。功德智慧一一无边。不可以色形量而取。都无分限起尽之相。具真实德。修证实成。非应物现。名之为实。他受用身及八相化身随生类所示现。身可令下类皆知见是身之末。俱有差别。功德智慧非并无边。可以色心形量而取。然有分限起尽之相。具相状功德。因利他取起。应物而现。名之为权。故佛地论云。佛身有二。一实身二生身。然此实身各居自土。俱遍法界非方处求。法身本有诸佛共同。凡由妄[雨/復]有而不觉烦恼缠裹得如来藏名。由近善友断妄生死。出缠裹时具法身之称。诸功德法所依止。故胜鬘经中在缠名如来藏。出缠名法身。约位因果得名别。故但可说证不可说成。初地以上分亦证得。佛果圆证。自受用身新修所起有情分别事体异故。从凡夫位但有无始无漏种子。由近善友听闻正法。种子渐增为报身本。亦名如来藏。楞伽经云。阿梨耶识名空如来藏。具足熏习无漏法。故名不空如来藏。前法身藏。此报身藏。发心修行如幽赞说。在地前位唯修种子令渐增长。由此势力令有漏善业生。生当感报相好圆满生于八相。变化土中至初地上便资有漏得十王位。生生常得三十二相八十随好。然未无漏亦未圆明。唯有六七二识无漏。生他受用随类土中。如梵网经说位大小。金刚道后有漏皆灭无漏五蕴一切圆明。舍无常色获得常色。受想行识亦复如是。获得无漏三十二相八十随好。尽未来际相依相续。然诸菩萨受变易身。有从初地即受变易。如入灭定怖烦恼故。有终乃至七地满心方受变易。如入灭定不怖惑故。其变易身一得不舍觉。其势尽还入定。资乃至金刚转位方尽。由此七地满心之中直往菩萨便生第四静虑广果天中。避五净居不生彼。故资此下地感现身业。乃至十地数数资助将至金刚。遂往色究竟上妙净土中。华严经云。有妙净土出过三界。第十地菩萨当生其中。生者起也往也住也。十地云。现报利益受佛位故。后报利益摩醯首罗智处生。故瑜伽第四解深密经对法论等皆作是言。超色究竟有妙净土。十地菩萨方生其中。有十相现大宝华王出菩萨坐中而成正觉。金刚心位身犹有量。犹是因位有漏皆是在。至解脱道身遂无边既名果位。无漏圆满。此所修生无漏果身等法。身量智境两如。事理相称皆无分量。不可相求。故名为实。彼二权身各有差别。随宜即现。方处可求。只如他受用身为初地菩萨现。由彼菩萨悟十百门。能见百佛。一佛即是一佛所王三千大千。此理即是百亿化身。一佛化同故言一佛。虽见百佛总一受用。此受用佛坐百叶华。一叶即是百亿化身一佛土也。此一佛土地前所见。为彼所现身称彼土然有二类。一者一四天下所现之身。二者三千界中同一主佛。由彼地前有阶降故。初地所见他受用身称百叶华。不大不小。初地菩萨随侍彼佛。大小相称。然彼地前随生何界身随小大多等佛半。初地以往既证真如。现生无漏功德渐胜。相好转明。故所感身称佛大小。分段变易粗细有殊。功德力资身量必大。于十王位为此洲王。随类化生。惑受不受故。此身量亦复不定。正智证真如后智见彼佛。如十百门一一宣说。若至二地得千法门。见受用身坐千叶华。一一叶中百亿化佛。其佛处坐大小相称。菩萨随侍身量亦尔。如化弟子侍佛大小。故梵网经云。我今卢舍那方坐莲华座。一华百亿国。一国一释迦。各坐菩提树一时成佛道。亦如阿弥陀佛。眼如四大海水。眉间毫相如五须弥山。法华亦云。众生见劫尽大火所烧时。我此土安稳天人常充满。常在灵鹫山及余诸住处说是法华经。等皆他受用随大小菩萨所宜便现身量不定。现处亦尔。非唯净土色相有殊。感处便或在西方或在此处。只如妙吉祥所见。乃是他受用身。舍利弗所见即为化身。故华严会舍利弗如盲如聋不闻不见。文殊师利引出会已方始知见。后得所观。即是权身。正智所证即是实身。若第十地菩萨将成佛时。必往色究竟上大自在天妙净土中。大宝华王坐中而取正觉。此大宝花王量等十阿僧祇百千三千大千世界。十地菩萨坐中大小相称。况此所见他受用佛。彼佛身量无量无边。此处定在色究竟上。如前所引经论等文。然此等土必无二乘女人黄门恶趣等生。设有皆是佛及菩萨之所作化。故无量寿经论言。女人及根缺二乘种不生。佛地论云。设有鹦鹉等庄严道场。皆佛菩萨为令他方菩萨来生喜心所以化作。鼓音王经云。阿弥陀佛父名月上。母名殊胜妙颜。子名月明。奉事弟子名无垢称。魔王名无胜。调达名寂。既无女人。母非实女。佛等所化。如命命等。故是报土亦不相违。有解。是实女人者化。阿弥陀佛有报佛土。螺髻所见。劫尽常在灵山说法是报佛土。然华严云。摩耶夫人腹中三昧见腹含容。无边世界诸大菩萨集会听法。故知报佛有化父母。此亦未爽。观世音授记经云。阿弥陀佛寿命无量百千万亿劫。当有终极。灭度之后观世音菩萨明相出时。于七宝菩提树下成等正觉。号普光功德山王佛。国土胜阿弥陀佛国百千万亿。不可为比。国名众宝普集庄严。此佛灭已大势至成佛。名善住功德宝王佛。不说先住何方后来补处。不同化佛。然于此处补处。无失化处。欲令欣乐心深。所以先有住处。其他受用即以花台为道场坐。下位有父母。上位不见父。且如化身为地前菩萨二乘等现或净或染或小或大。任物所宜。将成佛时先升知足。以彼天处机宜相称厌苦心深生死乐具已知足故。不处余天必在于此。只如释迦弥勒处知足天。菩萨处胎经说。具足五十六亿七千万岁下生。根熟方下成道。三际成道皆有道树金刚座道场降魔等事。其降魔不同。如理趣疏。金刚圣道二障已拂。解脱道中无漏道备。冥真契德证觉利生已故名成佛。今此下生经明成佛事。非法身佛理但可证非有上下生成等义。亦非自受用。彼无处天成佛之相说法利生令生见义。他受用佛不处天宫。不住摩竭提。令地前见故。即是化身上生成佛。虽标化佛影彰余身。自受用身圆成道果。真如妙理障尽圆证。自利果满宿愿须行。当此会中化生。权起他受用佛。应十地所宜变化佛身。随地前所现。虽复此处彰化体。而影显余佛。见者自成机别。现者身亦说殊。非实佛身有其异体。如月出云际圆朗彻空影现水中。水月圆明任器器成万别。月本一同。岂以影有千差遂令月亦有异。真权两体义理必然。真即理源。权随物迹。故知上生成佛备彰化质。欲令随类济生欣修易。故钵经说。弥勒语文殊师利言。如我后身作佛如恒河沙等。文殊师利不能知我举足下足之事。鸯掘摩罗经言。北方有国名曰常喜。佛名欢喜藏摩尼宝积。文殊师利即彼佛也。文殊既是佛不知弥勒者故知化也。摄大乘等八相成道既是化身。故知上生定非真佛。菩萨有三。一者一生所系。二者最后之身。三者坐于道场。上生则一生所系。下生局得二身。成佛由因故三皆尽。唯化佛有余不见文。以理而推亦应通有。如第七地菩萨。唯此一身即受变易名一生所系。八地以上名最后身。无别分段生死相故。往大自在宫坐莲华座名坐道场。此名成自受用身亦有三菩萨。他受用身理亦如是。观音之身名最后身。其坐道场一生所系。未见诚证。理必定。有说。弥勒菩萨名一生者。住在人中名一生。一大生故。如七生等。据实并中有合有四生。若说天中唯有半生。并中有二生。大智度论说为三生。设在人中除成佛身故有三也。然诸菩萨有五种生。一除灾生。由愿自在为大鱼等济诸饥乏。为大医王救诸疾病。为大善巧善和斗诤。为大国王如法息苦。为大天神断邪见行。为火为水为乘为舟为种种物息除灾患。二随类生。愿自在力于傍生等恶类中生彼所。行恶而自不行。彼不行善而自行之。如入酒肆能立其志入诸淫舍示欲之过为说正法除彼失。三大势生。禀性生时寿量形色种姓富贵最为殊胜。能断众生轻慢等过。四增上生。受十王界自在化导。随所应示。五最胜生。此生资粮已极。圆满如释迦等。生刹帝利大国王家。能现等觉作诸佛事。今者弥勒住都史多天具后四生。或二三四。若下此洲第五生摄。此即第一佛成权实也

第二慈性所因者。依正梵本应云梅呾利耶。此翻为慈。古云弥帝疑或云弥勒者皆语讹也。依贤愚经第十六卷云。生波罗奈国劫波利村辅相之家。即上生经云。劫波利村波婆利大婆罗门家初生。便有三十二相八十随好。身紫金色姿容挺特。辅相欢喜召相师相之。相师既见转赞其善。因欲立名方问生时之相。父答之言。其母素性不调。怀子以来慈矜苦厄。相师占曰。此即儿志。因为立号名梅呾利耶。若释此名应云梅呾利曳尼。梅呾利尼是女声。母性慈故因名慈氏。父母爱重声誉远闻。王梵摩达心恼生惧恐夺其国。伺其未长方欲降之。内人既知潜报父母。私送舅氏避难习业。舅名波罗利。领五百弟子。异方学道。舅甥师弟聪颖超群。数岁之间学通经典。舅后闻佛出世。遣慈氏等一十六人往至佛所而为四问。一问几相。二问年齿。三问弟子。四问种姓。慈氏问已如来具答。慈氏欢喜。佛因更化余十五人得法眼净。俱从坐起并乞出家。佛言善来。衣严发落。方便更说并成应果。唯有慈氏不预彼流。后从世尊游迦维罗卫国。其大爱道手自缦绩金叠袈裟系想奉持。世尊不受令供养僧。僧中次行无敢取者。到慈氏所寻为取之。身披金叠从佛游化。身紫金色衣贯金彩。表里相称巡行乞食。持钵巷陌。观者无厌。虽皆敬欢无与食者。有穿珠师将还供养。妇来嗔骂言。失穿珠之利。慈氏得珠持还问众人。广说过去供养所生福利佛因无灭。说过去事便说未来慈氏之事。慈氏后作佛。故犹名慈氏。庆喜问佛慈氏名因。佛言。过去此赡部洲有大国王。名达磨流枝。此云法爱。尔时有佛号曰弗沙。有一比丘入慈三昧。身相安静放光照耀。王问此僧何定致此。佛言入慈定。王倍生欣跃云。此慈定巍巍乃尔。我当习之生生不绝。往法爱王者今慈氏是。从彼发意常号慈氏。久习性成佛称弥勒。又一切智光明仙人慈心经说。佛在摩伽提国寂灭道场弥加女村自在天寺精舍。一时佛与千二百五十比丘经行林中。弥勒菩萨金色相好放银光明。黄金校饰如白银山。来至佛所。结发梵志五百人等遥见弥勒。五体投地白佛。请问弥勒光明乃与佛等于何佛所初发道心。佛言。梵志乃往过去无量无边阿僧祇劫时有世界名胜华敷。佛号弥勒。恒以慈四无量法教化一切。经名慈三昧光大悲海云。闻者必超百亿劫罪成佛无疑。时有大婆罗门名一切智光明。六十四能多智博达。闻佛彼经即生难诘不能屈伏。便发信心而发愿言。愿持彼经必得成佛号曰弥勒。即舍家入山谷长发梵行。满八千岁乞食诵经。时有星现表王淫荒。彗星横流洪水不止。不得乞食七日空住。时林中有五百白菟。有一女菟。母子见仙无食而作是言。仙人为法不食多日。法山将崩法海将竭。我今为法应不惜命。便告诸菟。诸行无常众生爱身未曾为法丧舍身命。今者欲为生类作大桥梁供养法师令法久住。即说颂曰

  若有畜生类　　得闻诸佛名
  永离三恶道　　不生八难处
  若闻法奉行　　生处常值佛
  信法无疑惑　　归依贤圣僧
  随顺诸戒行　　如是疾得佛
  必至大涅槃　　常受无上乐

说此偈已告诸菟言。我今以身欲供养法。汝等随喜。我从多劫三毒所使为鸟兽形虚受生死。今将为法弃舍身命。时山树神为积香木。菟王母子绕仙七匝白言。大师我今为法供养尊者。仙人告曰。汝是畜生。此心难办菟言。我今身供养者为法久住饶益众生。王语其子言。汝可随意求觅水草系心思惟正念三宝。子闻母告跪白母言。如尊为法欲供养者。我亦愿乐。即投火中。母亦随入。当尔菩萨舍身之时。大地振动天雨诸花持用供养。肉熟之后诸神白仙。菟王母子为供养故投身赴火。今肉已熟。宜可食之。仙闻神言悲不能对。以所诵经书置树叶而说偈言

  宁当杀身破眼目　　不忍行杀食众生
  诸佛所说慈悲经　　彼经中说慈悲者
  宁破骨髓出头脑　　不忍啖肉食众生
  如佛所说食肉者　　此人行慈不满足
  当受短命多病身

仙发誓言。愿我世世不起杀想。恒不啖肉。入慈三昧。乃至成佛制断肉戒。语已投火而死。与菟母子并俱时命终。地六种振动。天神之力树有光明。金色晃曜照千国土。众生见光寻光来至。见仙与菟俱死火中。得所说偈并佛经。已持还上王。王遗遍宣令。闻皆发大菩提心。佛告梵志。时菟王者今我身是。其菟儿者罗睺罗是。诵经仙人者今弥勒是。五百菟者大迦叶等五百人是。山树神者舍利弗目揵连等二百五十人是。时千国王者今跋陀波罗等千菩萨是。彼国众生得闻法者贤劫佛所得道者是。由是菩萨乃至成佛犹名弥勒。其所说经亦名慈三昧光大悲海云。此说初时。贤愚经说弗沙佛时。乃近代也。欲显生生常习慈行相师立名远符往性。今古合称故名弥勒。若依此。姓名为慈者应云梅呾利曳那。梅呾利那是男声。自性修慈故称男也。婆罗门种姓有众多。其此慈者父王本姓。父姓母姓俱有慈故名为慈氏。又有云。慈氏本姓颇罗堕。字阿氏多。又王姓颇罗堕。字阿氏多。字理无差。姓成乖角。其弥勒者母及自性俱行慈爱。因以为名。由是得号。是心行性亦种姓也。如释迦是姓牟尼是号一切义成是名憍答摩是皇。如此立姓之所生圣也。是名第二慈性所因

第三时分有殊者。劫有多种。如别章说。观药王药上菩萨经云。尔时释迦佛告大众言。我曾往昔于妙光如来末法之中出家学道。闻是五十三佛名心生欢喜。复教他人。他人闻已转转相教。乃至三千人。异口同音称诸佛名。一心敬礼即得超越无量亿劫生死之罪。其初千人者花光佛为首下至毗舍佛。于过去庄严劫中得成为佛。毗舍佛者即七佛中第三毗舍浮佛。此中千佛拘留孙佛为首下至楼至如来。于贤劫中得成为佛。后千佛者日光如来为首下至须弥相佛。于未来星宿劫中当得作佛。贤劫经亦云。过去庄严劫有千佛出现世间。文皆同此。其三千佛复各自类同修胜业。俱时获果。故别类出无垢称经第六卷。云过去轮王名为宝盖。今宝焰如来。轮王千子今贤劫千佛。月盖王子今释迦是。五浊经云。今当贤劫第九住劫已有四佛。人寿四万岁迦诺迦村陀佛出世。人寿三万岁迦诺迦牟尼佛出世。人寿二万岁迦叶波佛出世。贤劫经云。人寿一千二百岁释迦始生都史。人寿一百岁出世作佛。都史天寿四千岁人间当五十六亿七千万岁。正法五百年。像法一千年。不论末法。仍云过千五百年后释迦法尽独觉行化。与诸经不同。人命转促。正法之时人寿不减。像末法中人寿便减至三二十岁。有饥馑疫病刀兵次起。人多死尽国界空疏。仙人相诫人怀其善。子年倍父渐渐长寿至八万四千岁。从增六万岁至增八万。皆有转轮圣王相次而出。八万岁时王名儴佉。弥勒方出。然论释云。劫减佛兴。劫增转轮王出。以此捡。弥勒八万四千劫初减方出。厌生死故人寿百岁慈氏生天。人寿八万四千方始下生成佛。当人间五十六亿七千万岁。以此而推。劫减时长。劫增时短。慈氏光照四十里。梵志经云。父名梵手母名梵经。子曰德力侍者曰海氏。智慧弟子曰慧光神足弟子曰贤精进。正法八万岁收佛舍利共兴一大塔寺。贤劫经云。从迦诺迦忖陀佛至第九百九十九佛共出一大劫。第一千楼至佛独出一劫后。更十二劫空过无佛。后有一佛名净光补王。寿十小劫即是星宿劫中第一日光佛也。翻名有异体即一佛。过此以后三百劫中空过无佛。楼炭经中明。楼至佛独出一劫。所由广如彼说。金刚力士经云。昔有轮王千子具足。各发胜心共求作佛。父王试子何者先成佛。香水浴筹令千子取。得第一者即最初成。最后得者即最后成。其最后者为余者讥。我等成佛人已化尽。汝何所度。小子悲泣复思惟。世界无边众生无数。诸兄所度何能尽也。愿我作佛度人寿命一等诸兄。岌然地动佛即咸记。由是因缘故后一佛独出一劫。以啼泣故名啼泣佛。和上解云。胡卢支故卢支者此翻云父爱。父小子偏所爱念故为名也。于是诸兄愿作金刚。拥护小弟。依小乘说。菩萨百劫修相好业。释迦买五花以供养定光。定光即燃灯也。遂为授记。汝于来世当得作佛。又由释迦弥勒同事弗沙世尊入火光定灭光恍曜释迦赞叹复超九劫故。先弥勒以得菩提。故经数说。弥勒自言。我宁千阿僧祇劫都史天说法度人。不能昔时舍身少分。以稽留故在后成佛。然释迦佛百劫修相好中九十一劫中第一劫逢毗钵尸佛。第三十劫逢尸弃佛鞞湿婆佛。第九十一劫逢贤劫千佛。有云。住劫中初五劫无佛出世。第六劫有俱留孙佛。第七劫有俱那含牟尼佛。第八劫有迦叶佛。第九劫有释迦。第十劫有弥勒。有云。四佛并第九劫。四已出讫并前即为七佛也。弥勒当贤劫第五佛也。即是第三时分有殊

第四往生难易者。且如西方天亲净土论无著往生论俱。言报土女人及根缺二乘种不生。又阿弥陀经云。非少善根因缘而得生彼。又言。其中皆是阿鞞跋致诸大菩萨。又观经云。上上品生得无生法忍。须臾之间遍十法界。奉事诸佛即得受记。上品中生经一七日得不退转。经一小劫得无生忍。上品下生者经三七日其华始敷了了方闻说法音声。经三小劫住极喜地。中品上生应时即得阿罗汉果。中品中生者经七日华开得须陀洹。迳半劫已成阿罗汉。中品下生者过七日已花开。遇二大菩萨说法。迳一小劫成阿罗汉。下品上生者经七七日花敷。经十小劫具得百法明门得入初地。下品中生者经六劫莲花乃敷。闻二菩萨说法发无上道心。下品下生者经十二大劫莲花乃开。闻说法已方发道心。百法明门说初地得。岂阿罗汉胜初地耶。又中品生得阿罗汉。下品始发心。即迂会者胜直往耶。又言得须陀洹等。岂由片时修故遂便得果处处皆说阿罗汉果。若练根者六十劫成。岂由小善遂超生死成利根阿罗汉。又云。作诸观成得生西方。岂举心已诸观便成。若由小善便得果者。便同说假部。由福故得圣道。道不可修道不可长。观无相等资粮加行便徒施设。又无垢称经云。若诸菩萨行于八法。行无疮疣方生净土。一思于有情恒作善事不希善报。二思代有情受苦所有善根悉回施与。三思于有情其心平等心无挂碍。四思于有情摧伏憍慢敬爱如佛。五信解未闻经典无碍无谤。六于他利养无嫉妒心于己利养不生憍慢。七调伏自心常省己过不讥他犯。八恒无放逸当寻善法精进修行菩提分法。岂生净土者皆具八法也。又对法第十二卷云。别时意趣者。如说若有愿生极乐世界皆得往生。意在别时。故摄大乘云。譬如一钱而得千钱。意在别时。非唯由发愿即得生。故又云。对治秘密者。一治轻佛。二治轻法。故说我于尔时曾名胜观如来等。与彼法身等无差别。故法华经云。我成佛道以来无量无数劫等皆是。三对懈怠。故作如是言。若有愿生极乐世界皆得往生。四对治小善生喜足。故于一善根或时称赞。为令欢喜勇猛修故。或时毁訾。五治贪行者称赞净土富乐庄严。六治慢行者称赞诸佛或有增胜。七为除悔恼障修善法说如是言。于佛菩萨虽行轻毁。然彼众生亦生天趣。八为除不定性于声闻等下劣意乐说大声闻当得作佛。又说一乘更无第二。又佛毫相如五须弥。岂凡地前能见此相。身量大小可得。初地所见。凡若能见皆为超越。又念弥陀弥勒功德无有差别。现国现身相成胜劣。但以弥勒恶处行化慈悲深故阿弥陀佛净土化物慈悲相浅。又净土多乐欣生者多。厌心不深。念令福少。非奇特故。恶处多苦欣生者少。厌心深重故念福多。甚希奇。故虽知佛力念亦可生。圣教不同屡生心惑。知足天宫同在此界。外道内道大乘小乘所共信许。既是化身决定得生。由此经文四众行六事法。八部闻名叹喜。造诸恶业忏悔归依修十事行。回愿生彼一切皆得。菩萨处胎经第二卷云。弥勒初会九十六亿受我五戒者。次九十四亿受持三归者。后九十二亿一称佛名者。故知微善回向皆是往生成佛。经中说由十一业来生我所。一谓读诵分别决定修多罗毗尼阿毗昙。为他演说赞叹义味不生嫉妒。教于他人令得受持修诸功德。来至我所。乃至第十一或有恩爱别离朋党诤讼极大苦恼。以方便力令得和解。修此功德来至我所。故知不由唯修胜业方始得生。诸教共同必无异说。或有释言。生西方者决定不退。生兜率者或可有退。故不愿生。理亦不然。此经亦言。诸有敬礼弥勒如来。闻名称名暂睹豪光。下至听闻弥勒所说一句法义归依。生彼定不退于无上正觉。无量劫罪皆尽消灭。无量善法运运生长。故见弥勒得生彼所。虽有天女种种侍卫。或佛菩萨所化为。或实天女彼闻能说不退之法。厌欲过患必无退转。佛力所加心生决定。岂由欲界即皆退耶。位至不退处处皆不退。未至不退彼何必不退。且上圣上贤皆修此业。西域记说。西方即有无著天亲师子觉等菩萨。高僧传说。此方亦有弥天释道安庐山慧远慧持等。近亲所见。大唐即有三藏和尚文备神泰法师等。皆修彼业兼有上生灵感。或有身在现相。或有将终现相。或有生后现相。人所共知。具如别传。西方胜处人所乐生。此土秽方谁能愿住。但以经论明证贤圣同修。背苦求乐诚非上士故。无量寿经下卷云。阎浮提一日一夜受持斋戒。胜无量寿国百年修善。以彼佛国无有恶故。又维摩经云。阎浮提修道一日一夜。过诸佛土百千大劫。良以此世界中有十胜事。谓以布施摄贫穷等。厌苦心深有苦可拔。西方净土便无是事。处秽方而修净行。寔圣者之利他。居净域而严净因。非上士之弘济。愿于盲暗世界为作灯明。邪见众中安立正道。但业行残缺愿往西方。万一不生。恐成自误。故当己行应修此业

第五问答料简者。依上生。下文优波离问云。此阿逸多具凡夫身未断诸漏。虽复出家不修禅定不断烦恼等。明知此等皆小乘经。大乘菩萨无是义故。今依上生。初列跋陀波罗文殊师利诸菩萨等。后陈化佛说陀罗尼。佛以一音声说百亿陀罗尼门。复言。身圆光中有首楞严三昧。又云。令五百亿天子不退于阿耨多罗三藐三菩提等。明知是等皆大乘经。小乘经中无是事故。由是古德或说。此经为小乘。从阿含离出说。慈氏佛犹是凡夫身故。或说。此经为大乘。说初列菩萨众等。复非阿含中出。有云。依大智度论云。小乘经初唯列声闻。大乘经初备兼菩萨。今上生经初既列声闻菩萨。明知大乘经。下生虽略亦大乘云。大卷成佛经中。三会说法皆有得证声闻独觉发于无上正等觉心。故知并大乘。其优婆离身处小位所解局迹。以己所知辄为此问。岂慈氏位次为彼所知。故定大乘。如金刚般若唯列声闻。岂非大乘。此上生经并弥勒受决及一切智光经等皆晋代安阳只译。下生经中大卷有如是我闻者。晋时竺法护所翻。小卷云大智舍利弗无如是我闻者。是晋时罗什所译。古人解云。小卷者阿含中出。大者别坐所说。又解。翻者有异其实一本。今大师云。大者有三分无结集本。其小卷无序分者是略。偈颂即二藏中菩萨藏摄非声闻也。问弥勒释迦谁初发意今者成道前后乃然。答佛藏经云。弥勒发心先四十劫释迦方发心。佛本行经第一卷云。昔有如来号曰善思。弥勒菩萨于彼佛所最初发心。在于我前四十余劫。然后我发无上道心。有佛名示诲幢如来。我于彼国作转轮王名曰罕弓。初发道心。此中皆说后时发心。弥勒发心因弥勒佛。释迦发心因释迦佛。故彼非初。但以舍身苦行修业不同。所以弥勒成道终后。问如贤劫经明超劫事。佛本行经第三卷发心供养品云。昔有佛出世号曰弗沙。彼佛在杂宝窟。我见彼佛心生欢喜。合十指掌翘于一足。七日七夜赞叹彼佛。佛言。是人过九十四劫当得作佛见真理。佛言。是人过九十三劫当得作佛。毗婆尸佛言。是人过九十一劫当得作佛。佛地论亦说。释迦超九劫。因事弗沙翘足而叹。说超九劫即百劫中修相好时。故经多言过去九十一劫有毗婆尸佛。不说百劫。其九十一劫初有毗婆尸。故多作此说。涅槃等言。雪山菩萨为半颂舍身超十二劫。金光明经萨埵王子投身饲虎超十一劫。摩纳仙人布发掩泥超于八劫。菩萨地言。菩萨修行有超水火及日月劫。无超阿僧祇。彼所言超何时超也。答虽无正文理准应尔。翘足超九百劫中超。余说超者阿僧祇内。不尔何位更得说超。问诸天胜所经说。无边一生菩萨何独知足。答知欲乐之足易可厌成故。菩萨处中劝化易故。上界欣掉既重。恶趣戚行极深。既无佛现。余处不如知足。三际诸佛皆同住故。依智度论。往生品说。兜率天众利根结薄。一生补处常住其中。自下三天结深心乱。自上二天结厚根钝。所以不住。不言他方来者。恐生疑谤。句化生故。不住人中后生作佛。非应机宜欣不深故。问十王果报应为第四禅主。何故一生所系居知足也。五地菩萨定处何天。答据因克果应为第四禅主。符下行化故舍而居知足。五地克果位处知足之天。修行不定处一方。何必要居兜率。一生住此。五地化游亦不爽也。但说菩萨应受十位。非诸菩萨皆定受之。舍位修行随利生故。问何故释迦劫减百岁出世。弥勒劫增出世。答释迦愿于恶劫教化行苦行等。并异弥勒。弥勒愿好时教化。所以不说超劫。又释迦众生遭苦发心。乐即退败。弥勒众生乐即发心。苦即退败。如闻俱胝耳乐妙乐具故。所以不同见。恶时出厌心深故。乐时出者欣心胜故。问何故释迦刹帝利姓。弥勒菩萨婆罗门种。答释迦出自恶时众乐于富贵。弥勒出自好时众生乐于净行。由斯二佛生姓不同。问长阿含经云。毗婆尸佛人寿八万岁时出世。尸弃佛人寿七万岁时出。毗舍浮佛人寿六万岁时出。拘留孙佛人寿四万岁时出。拘那含牟尼佛人寿三万岁时出。迦叶佛人寿二万岁时出。释迦一百岁时出。弥勒佛人寿八万岁时出世。岂前三佛同住劫耶。答五浊经明。贤劫前四佛同出第九住劫。或云。住劫中初五劫无佛。阿含经说佛出世时人寿长短。不说同劫。亦不相违

如是我闻

赞曰。今此经中总有三分。初从如是下至合掌住立佛前。说经因起分。次尔时优婆离下至若他观者名为邪观。是发请广说。尔后尔时尊者阿难下至礼佛而退。是闻名喜行分。神光炬烛惊集有缘。舌相舒耀总持方演。慈氏应时独悟请记佛前。释迦为益当来因斯记别。故名说经因起分也。婆离见悕记相。复念往昔佛言。所以发言申请。世尊为其广说。故名发请广说分。陈事既周时众获益。将冀流通后代。庆喜问其经名。闻法者积喜于胸怀。爱道者奉言以行学。故名闻名喜行分。初分之中复分为二。一说经通所因。如是我闻等诸经通有故。二说经别所缘。尔时世尊出广长舌下是此经别有故。或初名证信序。委证此经破疑生信故。后名发起序。显发此经起之所由。今随义增各标别称。不尔信起岂不通耶。若依古师通序有六。今依佛地通序有五。一为令生信总显己闻言如是我闻。二说者听者共相会遇时分无别故名一时。三法必有主。欲显主尊法必胜益。故须称佛四说必依处。在舍卫国祇树给孤独园。化身所居非报土也。五教所被机放光召集根宜闻。故阿难请其四事佛遣致其通。由世尊为断众疑。庆喜又陈别序。俱承佛教并利玄宗。观教释文何容一准。佛地论说。如是之言依四义转。一依譬喻如。有说言。如是富贵如毗沙门。如是所传所闻之法如佛所说。定无有异。定为利乐方便之因。或当所说如是。文句如我昔闻。二依教诲如。有说言。汝当如是读诵经典。此中如是远则佛之教诲。近即传法者之教诲也。或告时众。如是当听我昔所闻。三依问答。谓有问言。汝当所说昔定闻耶。故此答言。如是我闻。四依许可如。有说言。我当为汝如是而思如是而为如是而说。谓结集时诸菩萨众咸共请言。如汝所闻当如是说。传法菩萨便许可言。如是当说。如我所闻或信可言是事如是。谓如是法我昔曾闻此事。如是齐此当说定无有异。由此四义故经初置如是我闻。真谛师云。微细律说。阿难升坐集法藏时。身如诸佛具诸相好。下座之时还复本形。勘集藏传亦作是说。众生有三疑。一疑佛大悲从涅槃起更说妙法。二疑更有佛从他方来住此说法。三疑彼阿难转身成佛为众说法。故经初言如是我闻。非此三事。为令先信除此三疑。注法花云。如是者感应之端。如以顺机受名。是以无非立称。众生以无非为感。如来以顺机为应。传经者以名教。出于感应故立言如是。注无量义经云。圣人说法但为显如唯如为是故言如是。瑶公云。以离五谤名为如是。第一句如是此经离执有增益谤。第二句如是此经离执无损减谤。第三句如是此经离执亦有亦无相违谤。第四句如是此经离执非有非无愚痴谤。第五句如是此经离执非非有非非无戏论谤。光宅云。如是将传所闻前题举一部也。如是一部经义。我亲从佛闻即为我闻。作呼辙耳。梁武帝云。如是如斯之义。是佛所说故言如是。长耳三藏云。如是有三。一就佛。三世诸佛共说不异名如。以同说故称是。由斯可信。以同说故。二就法。诸法实相古今不异故名为如。如如而说故称为是。既称理言不增不减。决定可信故称如是。三就僧。以阿难言望佛本教。所传不异故名为如。求离过非故称为是。又如是者信顺之言。智度论云。如是我闻生信也。信受奉行生智也。信为能入智为能度。信为入法之初基。智为究竟之玄术。信则所言之理顺。顺则师资之道成。因信故所说之法皆可顺从。由顺故说听二徒师资达立。于此信中略为十释。一信者依仁王等经。趣圣道之初因证谛理之鸿渐。故四十心以信为首。将入圣位有信根信力。有信根故七觉因此而生。有信力故四魔不能屈伏。故由斯经首创令信生。二依大毗婆沙论。信者食法味之喜手。学佛法者如大龙象以信为手。以舍为身。以念为颈。以慧为头。于两肩担集善法。象所饮啖以鼻为手。故学法者最初信生。三学者大商元规法实。故初生信获彼圣财。显扬论云。七圣财者。谓信戒闻舍慧惭愧。信即一焉。四瑜伽论云。入一切法欲为根本。起希望故作意所生数警觉。故触所集起时对境。故受所引摄领在心。故定为增上心微寂。故慧为最胜择善恶。故解脱为贤固息缠缚。故出离为后边觉道满。故信既为欲依。故最初令起。五成唯识论云。信如水精珠。能清浊水能治不信自性浑浊。故宣尼云。兵食信三信不可弃。春秋亦谓。苟有明信。涧溪沼沚之毛苹蘩蕰藻之菜可荐于鬼神可羞于公王也。六俱舍论云。拔众生出生死泥。正法佛手即正宗也。信为众生手序分也。两手相接出淤泥故。七诸论云。信者能越恶道离贱贫因。故入圣已有不坏信。故初令起。以下三解准经为释。八浮大溟海假手以行舟。渡生死河资信以发慧。九见珍财资手以采拾。闻法宝藉信而方得。十游旷野而有手持甲伏以捍群贼。出生死源而有信发慧解而断烦恼。由斯经首如是我闻。为令众生起正信故。以上合有二十六释。言我闻者。传法菩萨自指己身。言如是法亲从佛闻故名我闻。我谓诸蕴世俗假者。然我有三。一妄所执我。谓外道等所横计我。二假施设我。谓大涅槃乐净常我。除二乘倒强施设故。三世流布我。谓世共传天授等名。今传法者随顺世间自指称我。不同前二。即是无我之大我也。问诸佛说法本除我执。何故不称无我闻乃言我闻。答以四义故但称我闻。一言说易故。若言无我。知此表谁。二顺世间。三除无我怖。言无我者。为谁修学。四有自他染净因果事业等故。所以称我。问若尔者。何故不称名字但称我耶。答有三义。一亦不乖俗。西域方言泛皆称我。宗虽显真说不乖俗。理虽显妙言不乖粗。欲显真谛不离俗故。二我者主宰自在之义。阿难多闻闻持。其闻积集三慧齐修文义并持。于三藏教总持自在。若称名字。虽顺正理无于诸法得自在义。由斯称我不道阿难。三我者亲义。世间共言我见我闻。此将为亲证。若言阿难闻。或非亲闻。从他传受。今显亲闻世尊。可说非是传闻破他疑网故。不称字但言我闻。闻即耳根发识听受所说。今废耳别就我总称故名我闻。虽依大乘根识心所境至和合方名为闻。然根五义胜识等故根名闻。若但闻声可唯在耳。既缘名义便在意中。故瑜伽言。闻谓比量。耳名闻者。亲闻于声与意为门意方闻。故因闻所成总名为闻。若缘名义称之。为闻既在于意。故合名闻废别耳意总称我闻。以耳为门熏习在总。因闻所成总名为闻。故名我闻。庆喜于时虽亦见觉知佛所说然三义。但言我闻欲证深理要先闻故。此界以声为佛事故。希证菩提要闻重故。由斯经首不说见觉知唯说我闻。据实于时亦见佛说。诸余佛土以光明等而为佛事可言见等。龙军等言。佛唯有三法。谓大定智慧久离戏论曾不说法。由佛慈悲本愿缘力众生识上文义相生。此文义相虽亲依自善根力起。而就强缘名为佛说。由耳根力乃自意变。故名我闻。故无性云。闻者识上直非直说聚集显现以为体性。若尔云何菩萨能说彼增上生故作是说。譬如天等增上力故令于梦中得论咒等。故佛亦言。始从成道终至涅槃。于其中间不说一字汝亦不闻。亲光等言。佛离分别名无戏论。岂不说法名无戏论。谓宜闻者善根本愿缘力如来识上文义相生。此文义相是佛利他善根所起。故名我闻。世亲说言。谓余相续识差别故令余相续差别识生。彼此互为增上缘。故由此经说。我所说法如手中叶。未所说法如林中叶。此中二解随彼两文绮互解释。应知说此如是我闻意避增减异分过失。谓如是法我从佛闻。非他展转显示。闻者有所堪能诸有所闻。皆离增减异分过失。非如愚夫无所堪能诸有所闻。或分别不能离增减异分。结集法时。传佛教者依如来教初说此言。为令众生恭敬信受。言如是法我从佛闻。文义决定无所增减。是故闻者应正闻已如理思惟当勤修学

一时

赞曰。第二说教时分也。法王启化。机器咸集。说闻事讫总名一时。此就刹那相续无断说听究竟假立名。论有二解。一道理时。说听之徒虽唯现在五蕴。诸行刹那生灭。即此现法有酬于前引后之义。即以所酬假名过去。所引之义假名未来。并于现在法上假立。即说听者五蕴诸法刹那生灭。前后相生事绪究竟假立三世总名一时。非一生灭名为一时。二者说听二徒识心之上变作三时相状而起。实是现在。随心分限变作短长事绪终讫总名一时。如梦所见。谓有多生觉位唯心都无自体。听者心变三世亦尔。唯意所缘不相应行蕴法处法界所摄。此中不定约刹那。亦不定约相续。亦不定约四时八时及十二时。亦不定约成道已谢竟年数时节名为一时。但是听者根熟感佛为说。说者慈悲应机为演说。听事讫总名一时。由能说者得陀罗尼说一字义一切皆了。或能听者得净耳意闻一字义一切皆解。或说者少时听者多时。或说者多时听者少时。故不定说一念多劫之时节也。由于一会听者之机有利有钝。如来神力或延短念为长劫。或促多劫短念。亦不定。故但约说听究竟名一时更无异义。问何不别说四时六时。答昼夜时分诸方不定。经拟诸方流通。所以不得别说。问何不别说成道竟后若干时节。答虽随化相亦可言之。然凡圣所见佛身报化所说浅深成道近远各不同故。经拟凡圣同行。所以不得定说。问处中有净秽。随机定说处。时中凡圣殊。何容不定说。答说处标秽净。秽可定知。说时短长凡圣不可准一。会机宜有利有钝长时短时。如何准定。故处定说而时总言

佛

赞曰。第三教主也。佛陀梵音。此略云佛。有慧之主。唐言觉者。自觉觉他觉行圆满故称为佛。如次不同凡夫二乘菩萨三种故以为名也。佛地论云。具一切智一切种智。能自开觉亦能开觉一切有情。如睡梦觉如莲花开。故名为佛。即古所言无明惛睡觉法相理中觉空智有智理智事智真智俗智如所有智尽所有智之差别也。准依梵本。标薄伽梵。即第十号。以此一名总标众德。由此外道皆称本师名薄伽梵。此以翻译之主意存省略随方生善故称佛名。问此三身中何身所摄。答准所施化即是化身。文殊在中亦通报佛。应化非真佛亦非说法者。推功归本即是法佛。由机不同一处见异亦非定准。弥勒八相之尊说者故成化佛。理通报法义亦无违。今显主尊教。随最胜初标胜主。令生喜故

在舍卫国祇树给孤独园

赞曰。第四说法处也。梵云室罗筏悉底。言舍卫者音讹略也。此中印土境憍萨罗国之都城名。为别南憍萨罗故以都城为国之称。真谛法师云。昔有兄弟二人。一名舍婆二名婆提。故彼所翻金刚般若云。在舍婆提城兄弟二人于此习仙后而果遂。城因此号名舍婆提。今新解云。应云丰德城。一具财物。二好欲境。三饶多闻。四丰解脱。国丰四德故以名焉。祇树者应云誓多林。祇树者讹也。誓多云胜。此即太子名。太子生时邻国怨至战而得胜。遂以为名。给孤独者是苏达多长者。此云善施。善施仁而且睿。积而能散。拯济贫乏哀恤孤老。时人美其德号给孤独。是钵剌[尸@羊]删特特王旧云婆斯匿。此名胜军。彼王之大臣也。佛在摩揭陀未游舍卫。给孤独长者为儿取妇遂诣王舍城。时有长者将延请佛。敬修供具。善施问其所由。长者具陈请佛。彼闻佛德深心欢喜。佛在鹫山相去数十余里。遥放光照善施。寻光遥见世尊。悲感喜哽如子见父。寻光诣佛。路逢天祠。善施礼拜佛光遂灭。善施惭愧光明还烛。寻明至佛。请佛诣国普化有缘。何独此土。佛时许可。令舍利子先瞻度焉。佛言。出家之人当须寂静。丰德人闹。城中小隘。唯城南五六里余有太子誓多之园地。唯[塽-(爻*爻)+((人/人)*(人/人))]垲泉林蘩郁壁方十里。可设伽蓝。善施请买。太子不许。因戏言曰。布金满地厚敷五寸时即卖之。善施许诺。太子辞以戏言。因陈不与。善施请为断理。时净居天恐人遮之曲从。遂化为断事者。断与善施。善施得之布金而取。时少五百步未满十里。一库金尽。使者来报。善施思惟。当取何金。太子疑其情吝请悔地还金。善施具陈心非悔买。太子知其情邈自发胜心。人之所贵莫过金宝。而彼当能倾库买地以造僧园。我何所乏而无修建。请悔先地。长者不从。太子云。许地取金。未论林树。地随汝主林属我身。共助成功。俱陈供养。佛后游此告阿难曰。园地善施所买。树林誓多所施。二人同心共崇功德。自今已后应谓此地为誓多林给孤独园。化身在此。彰报佛而有净土劫尽火烧而我土由来安稳。结集不可具陈。二佛并显净秽之土随标一土。义准有三。事中有二。理亦有三。三身所居各有异故。如理趣疏

尔时世尊于初夜分举身放光其光金色绕只陀苑周遍七匝照须达舍亦作金色

赞曰。第五教所被机也。于中有二。初放光集众。后瞩光众集。问何故此经放光集众。余经不尔。答弥勒上生因深果远。若不警召有缘。有缘无由闻见。又无明昏夜觉照难生。不警群机无由自悟。故放光召集不类余经。集众中有三。初放光。次雨花。后化佛说言。此即初也。于中有六。一明化主世尊。二明时在初夜分。三明处举身。四明神变放光。五明相状金色。六明化境绕只陀园照须达舍。无垢称经佛告阿难陀。以要言之。诸佛所有威仪进止受用施为皆令所化有情调伏。是故一切皆名佛事。如涅槃经云。佛入涅槃二月十五日等佛皆自说。各有所表。故此经文皆有表示。化主可知。二放光时者。涅槃晨朝。法花白日。般若日中。此经初夜。各有所表。释迦牟尼出于五浊。是时有情烦恼已重。其未度者愚痴更多。所以初夜放。要初夜者。无始无明极昏闇故。今佛初夜放大光明。表说深经。欲令于释迦不得度众生令见弥勒得圣智光破重无明故。举者遍也。遍身放光明。涅槃从其面门。法华从白毫出。般若次第遍身皆放。今举身以放光。显佛慈悲普弘济故。显修行者并得度故。遍十方法界悲智皆照故。要放光者。导迷徒故。破处黑闇诸众生故。照愚盲者智眼开故。作金色者。法华白光。涅槃四色。此为金色。表可宝重故。济末代众生第一之珍宝。故绕只陀园警出家众。照须达舍者。警俗众故。大施主故。欲显闻经惊集二众。二众闻经。于当来世弥勒佛所普得度故。言七匝者。表令出家者现在未来破七随眠故。除身语七诸恶业故。持七支戒故。当超七生得七觉分故。法应如是

有金色光犹如霞云遍舍卫国处处皆雨金色莲华

赞曰。第二明雨华有三。一光形二光处三雨金色莲花。光形如霞云者。表佛法身周遍法界化身随物犹如霞云。荫四生故。说法雨故。慈悲如云。遍舍卫者。释迦牟尼受须达请授弥勒记。此国众生遍有缘故。舍卫丰德表弥勒世出世财皆具足故。雨莲花者。花有五德。一能掩恶。喻灭众罪。二能生果。喻闻此经见弥勒佛获证圣道。三香气远闻。学经见佛英声远振故。四能出水。喻闻经等已出生死海故。五能开敷。喻今后佛敷妙义故

其光明中有无量百千诸大化佛皆唱是言

赞曰。第三化佛说言也。有四。一化佛二皆唱三显因四明果。此初二也。化佛者。喻弥勒上生迹非真故。诸佛神变难思议故。皆唱言者。喻百亿释迦同与弥勒等授记故

今于此中有千菩萨最初成佛名拘楼孙最后成佛名曰楼至

赞曰。此后二也。今于此中有千菩萨者。显未成佛居贤劫位。当弥勒等现居因故。最初成佛名拘留孙最后成佛名曰楼至。于此有缘果当成佛故。令诸众生各起希愿得亲近故。如千佛因缘经具陈其事

说是语已尊者阿若憍陈如从禅起与其眷属二百五十人俱

赞曰。第二众集也。于中有三。初四众集。次二众集。后八部集。初中有四。一苾刍众。二苾刍尼众。三近事男众。四近事女众。苾刍众中有四。一耆旧尊宿众。二少欲杜多众。三神通外化众。四智慧内德众。此即初也。梵云阿若多解也。憍陈那婆罗门姓中之一性也。憍陈如讹也。梵萨缚遏剌他悉陀(唐言一切义成旧云悉达多讹略也)太子踰城之后。栖山隐谷己身殉法。父王净饭乃命家族三人。一阿湿婆此二马胜。二拔提。三摩男呴利。舅氏二人。一憍陈那。二十力迦叶。王云。我子舍家修学孤游山野。故命汝曹随知所止。内则叔伯舅氏。外则君而且臣。凡厥动静宜知进止。五人衔命相望营卫。因即勤求欲期出要。每相谓曰。夫修道者苦证果耶。乐证果耶。二舅氏曰。要乐为道。三家族曰。勤苦为道。二三交诤未有以明。太子思惟其理。为伏苦行外道。日食麻麦以资支身。二舅氏曰。太子所行非真失正道矣。道由乐证。今乃勤苦非吾徒也。舍而远遁自思果证。太子六年苦行未证菩提。欲验苦行非真。受乳糜而证果。三家族曰功垂成矣。今其退乎。六年苦行已一旦损功。遂亦逃舍相从求觅舅氏二人。既相见已往坐论曰。昔见太子出王城就荒谷。去珍服被鹿皮。精勤苦心求无上法。今乃受牧牛女乳糜。败道亏志无能为也。二舅氏曰。君何见之晚乎。此猖獗人也。处深谷受尊位。不能静志遁迹山林。弃轮王之大宝为鄙贱之庸人。何可念哉。言增惨切。太子浴尼连河坐菩提树成等正觉号天人师。思察。应度唯郁头蓝子者证非想定堪受妙法。空天报曰。彼命终来经今七日。如来叹惜。斯何不遇重。更观察。有阿蓝迦蓝证无所有处定。可授至理。诸天又报曰。终已五日。如来再叹愍其薄福。又更谛观。谁应受教。唯施鹿林有五人者。堪先诱导。佛从觉树趣鹿野园。威仪寂静神光晃耀。毫含玉彩身莹金色。安祥前进导彼五人。五人遥见互相谓曰。一切义成彼来者是岁月淹久都无果证。心期屡返。故寻我徒。宜各默然勿起迎礼。如来渐近。威神所逼五人忘制各起礼迎侍从如来。如来渐诱示之妙理。为其示相劝修作证。三转法轮。佛问解耶。时憍陈那最初答解。地神唱告净居。诸天亦言。憍陈那先解如是。乃至声遍大千。因以为名名解。憍陈那今与其徒大德耆旧见光晃耀雨花。宣唱从禅定起趣世尊所。旧经或云尊者了本际。或云解无智。皆得。阿若多义。不正得名。又不解憍陈那之姓故也

尊者摩诃迦叶与其眷属二百五十人俱

赞曰。第二少欲杜多众也。摩诃大也。迦叶波饮光也。略故云迦叶。此婆罗门姓。饮光仙人种。昔有婆罗门获证仙果。身皮金色饮蔽日月之光。尊者是彼之种。以姓标名。又迦叶身光饮日月光故以为名。付法藏传云。昔过去九十一劫毗婆尸佛入涅槃。后四部弟子起七宝塔。中有佛形像。佛面金色少处缺坏。有一贫女。游行乞丐得一金珠。见像面坏欲补像面。迦叶尔时作锻金师。女即持往请令修造。金师闻福欢喜。为治用补像面。因共立愿。愿我二人常为夫妇。身真金色恒受胜乐常修梵行。从是以来九十一劫身真金色生天人中快乐无极。最后托生第七梵天。时摩竭国有婆罗门名尼俱律陀。过去修福。聪明多智巨富无量。金银七宝牛羊田宅奴婢车乘比瓶沙王千倍为胜。瓶沙王有金犁千具。彼婆罗门恐与王齐畏招罪咎。其家但作九百九十九具。其家有量。最下之者其价犹直百千两金。有六十箪金粟。一箪有三百四十斛。其家虽富竟无儿息。于其舍边有一树神。夫妇常往祈请祭祠求乞有子。多年无应。嗔忿语曰。今更七日尽心奉事。若复无验必相烧剪。树神愁怖告四天王。四天王告帝释。帝释观阎浮提无堪彼子。即诣梵王所广宣上事。梵王即以天眼遍观见。一梵天临当命终。即往劝之劝其往生。梵天受教即来托生。满足十月生一男儿。颜貌端正身真金色光明赫奕照四十里。相师占曰。此儿宿福必当出家。父母闻之甚怀愁恼。夫妇议曰。当设何方断绝其意。覆自思惟。世所耽着唯有美色。当为娉取端正好女用断其情。至年十五欲为娉妻。语父母言。我心清净不须妇也。父母不听。儿知难免便设权计语父母言。能为我得紫金色女端正超世。我当取之。父母即召诸婆罗门遍行娉求。诸婆门铸一金女端正奇特。舆行村落高声唱言。若有女人得见金神礼拜之者。后出嫁时必得好婿身真金色端正殊妙。女闻悉出。唯有一女躯体金色端正殊好。即是往日施金珠女也。以昔胜缘有此妙身。志乐清洁独不肯出。诸女强将共见金神。此女既到金色光明映夺金神。婆罗门见即为娉。得既到夫家夫妇相对。各皆清洁了无异意。共立要契各住一房。父母知已严涂一房令其同舍安置一床。迦叶语妇。我若眠息汝当经行。汝若眠卧我当经行。后次妇卧垂手床前。毒蛇入室欲螫其手。迦叶见已以衣裹手举着床上。妇便惊悟而责之异。我立誓要不相近。今复何缘窃举我手。迦叶答言。有蛇来入恐伤汝手妨废修道。是故举之实无染意。即指蛇示。妇意乃悟。夫妇节操深厌世间。启辞父母求欲出家。父母见已遂便听许。于是夫妇俱共出家来至佛前。佛为说法。即于此时得阿罗汉。三明六通具八解脱。妇于后时亦得阿罗汉。迦叶在世常与如来对座说法。佛灭度后所有法藏悉付迦叶。迦叶后时结集三藏竟至鸡足山。全身不散。后弥勒佛出世之时。从山而出。在大众中作十八变度人无量。然后灭身未来成佛号曰光明。如法华中佛为授记

尊者大目犍连与其眷属二百五十人俱

赞曰。第三神通外化众也。梵云摩诃没特伽罗。此云大采菽氏。今讹略云大目犍连。此婆罗门种。上古有仙居山寂处。常采菉豆而食。因以为名名大采菽氏。与舍利子小为亲友。舍利子以才明见贵。尊者以精鉴延誉。才智相比动止必俱。结要终始契同去就相与。厌俗苦求舍家。遂师珊阇耶焉。舍利子遇马胜阿罗汉。闻法悟圣。还为尊者重述闻。而悟法遂证初果。与其徒众一百人俱。亦云二百五十人。俱到佛所。世尊遥见指而告曰。彼来者我弟子中神足第一。既至佛所请入法中。世尊告曰。善来苾刍。净修梵行得离苦际。闻是语时鬓发自落俗裳变缁。戒品清净威仪调顺。经七日结漏尽证阿罗汉果得大神通。后佛在无热恼池。人天咸集唯舍利子不侍从会。佛命没特伽罗往召来集。没特伽罗承命而往。舍利子于时方补护法衣。没特伽罗曰。佛在无热恼池。命我召尔。舍利子曰。且止待我补竟。与子同行。没特伽罗曰。若不速行。欲运神力举尔石室至大会所。舍利子乃解带置地曰。若举此带而得动者。我身或动。时没特伽罗运大神通举带不动。地为之震。因以神足还诣佛所。见舍利子已在会坐。没特伽罗俯而难曰。今乃以知神通之力不如智慧之力矣。今标其辈云二百五十人俱

尊者舍利弗与其眷属二百五十人俱

赞曰。第四智慧内德众也。梵云设利弗呾罗。设利此云春莺亦云鹙鸟。弗呾罗云子。今讹略故云舍利弗。母未怀子前言词讷钝。每共弟摩诃俱絺罗论议。常不如弟。怀子以去辨捷难酬。捔论恒胜。以母多辨号曰春莺。春莺即今百舌鸟也。是彼所生故复称子。亦云鹙子也。尊者大婆罗门种。其父高才博识深鉴精微。凡厥典籍莫不究习。其妻感梦具告夫曰。吾昨宵寐梦感。异人身被铠甲手执金刚。摧破诸山退立一山之下。不知何所表。夫曰。梦甚善。汝当生男。达学贯世摧诸论师破其宗致。唯不如一人为作弟子。果而有娠。母忽聪明高论剧谈。言无屈滞。尊者年始八岁名擅四方。其性淳质其心慈悲。朽坏结缚成就智慧。与没特伽罗子少而为相友。深厌尘俗未有所归。于是与没特伽罗子于珊阇耶外道所正修习焉。乃相谓曰。斯非究竟之理。未能穷苦际也。各求明导。先尝甘露必同其味。时大阿罗汉马胜执持应器入城乞食。舍利子见其威仪闲雅即而问曰。汝师是谁。曰释种太子厌世出家成于正觉。是我师也。舍利子曰。所说何法可得闻乎。曰我初受教未达深义。舍利子曰。愿说所闻。马胜乃随宜演说。舍利弗闻已即证初果。遂与其徒一百人。亦云二百五十人。往诣佛所。世尊遥见指告众曰。我弟子中智慧第一彼来者是。至已顶礼愿从佛法。世尊告曰。善来苾刍。闻是语时戒品具足。过半月后复闻佛为长爪梵志说法闻余论而咸悟。遂证阿罗汉果。后阿难承佛告灭期。展转相语各怀悲感。舍利子深增恋仰。不忍见佛入般涅槃。遂请世尊先入寂灭。世尊告曰。宜知是时。告谢门人亦至本生里。侍者沙弥遍告城邑。未生怨王及彼国人莫不风驰。皆悉云会。舍利子广为说法。闻已而去于后夜分正意系心入灭尽定。起已而寂灭焉

摩诃婆阇婆提比丘尼与其眷属千比丘尼俱

赞曰。第二苾刍尼众也。梵云摩诃钵剌阇钵底。摩诃云大。钵剌阇云生。钵底云主。即大生主。旧云婆阇婆提。此云大爱道。皆讹谬也。佛母摩诃摩耶夫人此云大术。早为迁寿。生主是佛小母。故称为姨母。为育养世尊因证正觉。佛之所化三乘圣人名曰大生。或大者众义。一切众生皆为佛子。姨为佛母。大生贺赉故言大生主。佛许出家事如律说。梵云苾刍此具五义。一曰怖魔。二云乞士。三云净持戒。四云净命。五云破恶。尼者女声。女有五德名苾刍尼。言比丘尼者音讹略也。与其眷属一千人夜瞩神光俱来佛所

须达长者与三千优婆塞俱

赞曰。第三近事男众也。梵云邬婆索迦。邬婆近也。迦事也。索男声也。于男声中以呼之即近事男。旧云伊[卄/補]塞优婆塞。优婆塞云清信男。皆讹谬也。戒德俱圆。皆堪能亲近承事苾刍大阿罗汉。故善施耆尊称为长者。灵光既照亦来佛所

毗舍佉母与二千优婆夷俱

赞曰。第四近事女众也。梵云毗舍佉。此云黑鹿。因儿得称名毗舍佉母。邬婆斯迦云近事女。斯女声也。业行清洁皆能亲近苾刍尼众大阿罗汉尼故。鹿子因缘如经广说

复有菩萨名跋陀婆罗与其眷属十六菩萨俱

赞曰。自下二众也。梵云菩提萨埵。此略云菩萨。菩提觉义。智所求果。萨埵有情义。悲所度生。依弘誓语故名菩萨。又求三菩提之有情者故名菩萨。或萨埵者勇健义。不惮处时求大菩提。有志有能故名菩萨。又菩提即般若。萨埵谓方便。如是二法能利能乐一切有情故名菩萨。摩诃大也。萨埵如前。今此菩萨位居十地。为简于小故言大萨埵。梵云跋陀婆罗。跋陀者贤义。婆罗者护义。此云贤护菩萨。具大贤德护念众生弘护佛法故名贤护。与其徒十六菩萨俱

文殊师利法王子与其眷属五百菩萨俱

赞曰。梵云曼殊室利。此云妙吉祥。文殊师利音讹也。鸯掘摩罗经言。是北方常喜世界欢喜藏摩尼宝积佛。诸有闻名敬礼归命种种事业菩萨皆能为作吉祥。神用无比名妙吉祥。法王子者久应证觉迹履因位。绍继灌顶佛之太子。由此独标法王子称。亦与其眷属五百菩萨俱。此二因缘如经所说。前大智众此大悲众。前今圣众此先圣众。前十地众此绍位众。故名二众。法花论云。跋陀波罗等十六人威仪不定具种种行。故此别标。何故先列声闻后彰菩萨。声闻等类形像同佛。出家威仪常亲近佛。令诸菩萨于声闻众生恭敬。故舍憍慢故

天龙夜叉干达婆等一切大众睹佛光明皆来集会

赞曰。第三八部众也。八部者。一天。二龙。三药叉旧云夜叉。四犍达缚旧云乾闼婆。五阿素落旧云阿修罗。六揭路荼旧云迦楼罗。七紧捺路旧云紧那罗。八莫呼路伽旧云摩睺罗伽。药叉者此云勇健或云暴恶。飞行空中食啖生类。亦摄地行诸罗刹婆。罗刹婆者此云可畏。犍达缚者此云寻香行。诸作乐神中有此等辈。由此西方呼诸散乐名犍达缚。不作生业寻食香气作乐乞求。阿素洛者此云非天。阿之言非。素洛云天。提婆之异名也。多行谄诈无彼天行故云非天。揭路荼者妙翅鸟也。翅羽严丽杂色庄挍特异众禽。禽中最大。旧云金翅鸟。一切飞禽皆此所摄。紧捺洛者此云歌神。莫呼洛伽此云大腹田父。虾蟆蟒蛇等类皆此所摄。此中且举彼类之首。其中一一各有无量形容异类。如是等辈一切大众睹佛光明皆来集会。由佛智悲广为引化。有灵之类皆悉奔波。希法雨以润萌牙。冀智药而除众苦。如归慈父若趣医王。但由平等慈非恩沾动植故也

尔时世尊出广长舌相放千光明

赞曰。上明说经通所因。下明说经别所缘。于中有五。一出舌放光。二有多化佛。三化佛说法。四释迦自陈。五弥勒领悟。此即初也。将说深经先出舌者。明授弥勒记济度有缘不妄语也。三十二相中舌广博相。凡时舌相但覆面轮至发等际。若作神通或覆大千。或更无量。智度论说。佛与阿难从舍卫国向婆罗门城。时婆罗门城主信属外道。闻佛欲来即立制限。若与佛食共佛语者。当罚金钱满五百文。后佛来到入城。乞食人皆闭门。佛与阿难空钵而出。见一老婢持破瓦器盛臭[米*番][米*定]出门弃之。见佛相好空钵而来心念欲施。佛知其意申钵。从乞所弃[米*番][米*定]。老婢净心持表施佛。佛受施已语阿难言。此婢因施十五劫中天上人间受福快乐不堕恶道。后得男身出家学道成辟支佛。当时佛边有一婆罗门。闻佛此语即语佛言。汝是净饭王之太子。何故为食而作妄语。时佛出舌遍覆面轮上至发际。而语之言。汝颇见有如此舌人而作妄语。婆罗门言。若舌覆鼻尚不妄语。何况覆面上至发际。即生信心而白佛言。我今不解少施报多。佛即告言。汝颇曾见希有事不。婆罗门言。我曾行见尼拘陀树。其荫遍覆五百乘车。佛即问言。树种大小。彼即答言。大如芥子三分之一。佛复语言。谁当信汝。婆罗门言。实尔世尊我眼见之非虚妄也。佛即语言。我见此女净心施佛得大果报。亦如此树因少报多。时婆罗门心开意解。向佛忏悔。佛为说法得须陀洹果。即时举手大声唱言。一切众人甘露门开。如何不出。诸人闻已皆送五百金钱与王请佛供养。即破制限。王与群臣亦归依佛。佛为说法悉获道果。故今出舌显授当记众生修行愿至彼所定得往生。表不妄语故。般若论解。不妄语者云于授记曾不妄语。放千光者表小千界。各有化佛破诸众生愚痴暗故

一一光明各有千色一一色中有无量佛

赞曰。第二有多化佛各有千色者表中千界。各有千化佛。一一色中有无量化佛者表大千界。当来同有百亿弥勒一时生故

是诸化佛异口同音皆说清净诸大菩萨甚深不可思议

赞曰。第三化佛说法于中有二。初总后别。此初也。身别故异口。语等故同音。清净诸大菩萨者。谓第十地因已圆满障亦微细名为清净。或八地已上一切烦恼皆不行故名为清净。或初地已上证性净理能伏诸惑令总不行名为清净。此三解中初解圆得。次解任运相续而得。后解分证。一切无违。甚深者微妙义。不可思议超分别心言说道故。梵云陀罗尼此云总持。念慧二能总含众德以为体性。识达简择明记不妄。能以少略含多广故名为总持。法者教也。说彼法故也

所谓阿难陀目佉陀罗尼空慧陀罗尼无门陀罗尼大解脱无相陀罗尼

赞曰。此下别列也。此四别者。一喜有。二解空。三于因无碍性。四于果大解脱。解脱即无相。或第三谓四无碍解。外化辨才。第四谓诸福慧内德解脱。或八地任运得初二。九地得第三。十地得第四。或四总持。一法。二义。三能得菩萨无生法忍。四诸明咒。如次配之。教法名有。所诠义名空。无生法忍名无碍性。得此忍已于一切法无碍达故诸咒名为大解脱。无相能解脱障缚不可分别名无相故。如幽赞中略已显示

尔时世尊以一音声说百亿陀罗尼门

赞曰。第四释迦自陈。欲明所记不虚故今化佛同说。如说法花。能寂自陈犹恐他惑。多宝塔涌为证方明。今亦如是。非但我言。化佛同唱。欲令弥勒深悟解。故佛以法义二持广宣教理。故以一音演其百亿。以略含广名总持也

说此陀罗尼已尔时会中有一菩萨名曰弥勒闻佛所说应时即得百亿陀罗尼门

赞曰。第五弥勒领悟也。于中有二。一明领悟二明请记。此初也。因行久圆果今示证。微假资习多有所成。释迦一音才宣。百亿弥勒领悟万倍解生。由此应时即得百万亿也

即从座起整衣服叉手合掌住立佛前

赞曰。此明请记。坐中证悟遂起整衣。申虔敬之仪。展请记之轨。从坐起者。表有所得从生死起。言衣服者。表四仪圆备七支无缺戒德满故。叉手合掌者。表心与境冥理与神会空智有智照冥真俗智德圆也。住立佛前者。表结使俱已断德圆备。或住而不动。表证三昧心不动摇定德成也。或示将有往生相故。所以起立。此意总显已出生死三学久成唯希为记当生当觉。唯此轨仪唯有身业。事不虚设。故各有表。威仪进止皆法轮故

观弥勒上生兜率天经赞卷上观弥勒上生兜率天经赞卷下

        大慈恩寺基撰

尔时优婆离亦从座起头面作礼而白佛言

赞曰。上明说经因起分。下明发请广说分。一生补处受记非轻。示相劝生严因寔重。若不因请而说。补处之相未尊。若无请而自谈。欣当生心不重。故放光集众普召有缘。假请谈经令兴重业。于中有二。初辨外果后辨内果。辨外果中复分为三。初波离启请。次世尊广答。后佛告优婆离若有比丘及一切大众下结劝生彼。请中有二。初明请轨后明陈请。此即初也。梵言优婆离此云近执。佛为太子。彼为佛大臣亲近太子。执事之臣。古人云佛之家人。非也。今云优波离讹也。亦从座起者。既见弥勒位立。优波离垂斯启请。是故称。亦表闻弥勒之事当证菩提故。从座起头面作礼者。屈己首尊礼佛卑足。一心顶戴虔恭深故。憍慢久除为显成佛尊贵因故。无见顶相之妙业故也

世尊往昔于毗尼中及诸经藏说阿逸多次当作佛

赞曰。下明陈请。于中有二。初举昔生今问。后显今征后问。此初也。前言世尊呼佛。又言世尊谈佛。谈佛往昔说弥勒故。世出世尊略言世尊。即是第十薄伽梵号。梵云毗奈耶此云调伏。调和控御身语等业。制伏灭除诸烦恼故。即是广律本也。古云毗尼或云毗泥皆讹也。近执明究律藏颇亦谙经。受记多在律中。因斯起问。阿逸多者此云无能胜。弥勒字也。名弥勒字阿逸多。往昔佛在耆山说。次我后当成佛者名曰弥勒。时有菩萨名曰慈氏。从座而起白言世尊愿我未来作彼弥勒。佛言可尔。故今腾昔而生后问

此阿逸多具凡夫身未断诸漏此人命终当生何处

赞曰。显今征后问也。文有其二。初举今征后生之处所。后举今征后生处净秽。此初征也。波离下器情局小乘。以己所知辄揣尊极。小宗说于菩萨三劫犹是凡夫树下三十四心方成圣者。欲恚害觉时亦未已故言凡夫。未断诸漏。漏有三种。如法华赞。生何处者。三界何界五趣何趣四生何生九有何有。观因验果未遣心疑。唯愿法王指陈生域

其人今者虽复出家不修禅定不断烦恼佛记此人成佛无疑此人命终生何国土

赞曰。征净秽也。从缁落饰形貌出家。常现威仪不修禅定。受姨母之妙服。欲贪未遣。瞩毫光而不识。尚有无知。佛记果圆理深难测。命终生处净秽何方。但以菩萨不起灭定而现威仪。将继法王。遂取金叠让。推光位等问豪光。波离不知乍谓。无定情粗睹相真疑有惑。禅定有九。烦恼有十。如余处说。然且成佛之先必在睹史一生补处大小共同。波离挟己下心辄量上位。示有不知以发今请

佛告优波离谛听谛听善思念之如来应供正遍知今于此众说弥勒菩萨摩诃萨阿耨多罗三藐三菩提记

赞曰。下佛广答有二。初敕听许说。后依问具申。此初也。谛者审谛。听音察理。贵在审情。恐听不明。重令谛听。极妙作意名善思念。如来者第一号也。涅槃经云。如过去佛所行妙行三十七品十一空等来至涅槃故云如来。应者第二号也。应已求害烦恼贼故。应不复受分段生故。应受世间妙供养故。正遍知者第三号也。正知遍知名正遍知。非邪小知。正满知故。具二种智知空有故。上来三号如次断德恩德智德。阿耨等者。阿之言无。耨多罗云上。三言正。藐言等。又三云正。菩提云觉。即是无上正等正觉。诸法莫先名无上。理事遍知名正等。离妄真照名正觉。或智断圆名无上觉。简异生邪智名正觉。简小乘分智名等觉。简菩萨缺智复名正觉。下一觉字贯通上文。弥勒当圆证此独得全名。记者识也验也。佛自称三德。今为汝等验识分别慈氏菩萨当来成佛之事

此人从今十二年后命终必得往生兜率天上

赞曰。下依问具申有二。初答生处。后答净秽。此即初也。从今十二年后者示受记。已求超生死十二缘。故生兜率天而为补处

尔时兜率陀天上有五百亿天子一一天子皆修甚深檀婆罗蜜为供养一生补处菩萨故以天福力造作宫殿

赞曰。下答净秽有二。初正答净秽。后佛告优波离此名兜率陀天十善报应下结此所因叹处胜妙。初中有三。初五百亿天子造外众宝宫。次一大神造法堂内院。后五大神于此二宫种种严饰。夫诸天福力果出自然。况补处之宫岂更须他造。欲显福异余天果从他作诸天敬重发愿严因。又诸天资具凡业所生。知足宫园必由胜行。外陈他作内表修因。譬人王之内苑似天帝之喜园。不说自然之报唯陈他造之果。皆是菩萨未上生前。预知欲生发愿先作。初中有三。一诸天植因发愿。二时诸天子作是愿已下明天愿果。三五百亿龙王围绕此垣下龙王守护。初复有三。初明植因。次我今持是等下正明发愿。后如是诸天子等下明行愿皆同。初中复二。初明所因。后明植因。此即初也。修愿行之所因者。一为修檀度。初业之妙行故。二为供养菩萨故。菩萨尽此一生必定成佛福田既大。故应植因。因者檀度。缘者愿助现傍资者。天之福力由现。天福傍资因缘二种力。故变成天宫因缘之果。冀在良田天之福资变成宫殿。五百亿者。由信精进念定慧五根为胜因缘内证法苑乐外感五百亿天为造宫殿。修余万行资此五根。故以百亿为称。或是菩萨化预庄严。准报土中所有严饰胜出世间善根所起故。此所说五根为因

各各脱身旃檀摩尼宝冠长跪合掌发是愿言

赞曰。此明植因。旃檀者檀香也。色通赤白。摩尼者如意珠。即诸天所著。如赤白檀香色。如意神珠乃天顶上所戴宝冠神珠。施者表当果生所求皆得故。种智圆明得如意故。脱宝冠者顺尊敬故。受记为佛得最尊故。诸天并脱。故言各各。长跪者双膝着地直身而住敬相周故。表修定慧恒无间故。合掌者虔恭貌。表心冥境证智合理故。上明修行身业因。下发愿者语业因能起。二者意业因三轮备故

我今持是无价宝珠及以天冠为供养大心众生故

赞曰。第二明发愿。此起愿因。慈氏广以智悲运苍生。而居彼岸情怀广大。居因位而号众生。摩诃萨埵云大有情。以义解之名大心众生

此人来世不久当成阿耨多罗三藐三菩提我于彼佛庄严国界得受记者令我宝冠化成供具

赞曰。正明发愿。此人者慈氏。当在人中未生天趣预兴此愿。故言此人于未来世当成正觉。我于彼土佛成正觉时。可为庄严殊胜国界得预彼会受记别者。令我宝冠化成供具。供具者四事什物供养之具。变宝冠而为供具者。显转凡而修成圣德。此但说冠略无宝珠。所愿同故。或宝谓如意珠。冠谓天冠。合而论故。若不尔者。何故行因冠珠两舍。及其发愿独有天冠。故应后释不违正理

如是诸天子等各各长跪发弘誓愿亦复如是

赞曰。第三行愿皆同上。虽总说诸天已讫。结集之家恐生疑惑施说。诸天愿唯一发。今显行该一切愿亦普同三业修因相皆等故

时诸天子作是愿已是诸宝冠化作五百万亿宝宫

赞曰。上明植因发愿。自下第二明天愿果。于中有二。初明十重严饰。后时乐音中下重显前严。十重饰者。一宫二园三宝四光五华六树七色八金九天女十音乐。此初也。既有十地菩萨围绕。亦有凡夫十善往生。复是菩萨十力增上之所显现。宫有十重。故下经云。菩萨福力十善报应。宫谓法苑。初地真智得空寂。金初创得。故内修五根。所以感宫等皆言五百

一一宝宫有七重垣一一垣七宝所成

赞曰。此有二严。二地持戒生长善法。守护六根感园围绕。三地证得。闻思修慧照了大乘教理行果。起智光明故感园宝色。成此各七者。二地持戒七支备故。三地能照三乘教理行果七故。又具忍辱七种观故。一安受苦忍。二谛察法忍。余五并是耐怨害。忍谓亲善想准法想无常想有苦想摄受想。如幽赞上卷说

一一宝出五百亿光明一一光明中有五百亿莲华

赞曰。此有二严。四地修得菩提分法。慧焰增故。百行助成感百亿光。五地作四谛观出生死泥智花敷故。内解五明外感五五百亿华

一一莲华化作五百亿七宝行树一一树叶有五百亿宝色

赞曰。此有二严。六地作十二因缘观。厌生死苦树。感七宝树故。思慧风动树观缘起故。七宝树者七十七智观所引。故七地纯作真无相观。证法性色感妙色故

一一宝色有五百亿阎浮檀金光一一阎浮檀金光中出五百亿诸天宝女

赞曰。此有二严。八地相土皆得自在故能现起阎浮金光。此于诸金最为第一。近阎浮树水下而有色蔽诸光。故偏举此。九地成熟四无碍解。化利众生出生善根感宝女故

一一宝女住立树下执百亿宝无数璎珞出妙音乐

赞曰。此第十严女执诸宝及众璎珞。此宝璎珞出妙音乐。第十地中陀罗尼门三摩地门。无碍神通感宝璎珞贵庄严故。云雨说法感乐音故。此上十严皆由内具彼德外招彼果。十善业道十力智等随应释相

时音乐中演说不退转地法轮之行

赞曰。重显前严有四。一广第十乐音说法。二广第六七宝行树。三广第四破暗光明。四广第二垣墙高厚。此初广乐音也。不退有五。一未信者信。信不退故。二未定者定。位不退故。三未得者得。证不退故。四未修者修。行不退故。五已断者不生烦恼。断不退故。此乃三乘通不退地法轮之行。法轮能诠。行是所诠。正法轮者。唯所诠行。摧灭移转行周圆。故行即法轮。今言法轮之行。故知教名法轮。说彼五位所修行也。以彼听众具三乘故法轮有五。一自性。二眷属。三因。四境。五果。如章中说。今明行者。即摄初三或摄一切

其树生果如玻璃色一切众色入颇梨色中

赞曰。第二广树。颇梨色者。谓红赤色此为根本。一切宝色为此所含皆入此色。显所化众生究竟位皆归一乘

是诸光明右旋宛转流出众音演说大慈大悲法

赞曰。第三广破暗光明。右旋宛转表菩萨行一切不离智慧光明及慧所引拔苦与乐大慈悲法。大慈以无嗔为性。大慈以无嗔无痴为性。此各有三。一有情缘缘假有情。二法缘不见有情但唯有法。三无缘法相亦无唯有真理。或有情缘缘有情起。法缘缘十二分教起。无缘缘真如起。无所缘故。弥勒慈尊导万物故演慈悲之法

一一垣墙高六十二由旬厚十四由旬

赞曰。第四广垣。垣谓围墉。高六十二由旬者。显生彼者逾破六十二见故。厚十四由旬者。御摧十四不可记事故。此四严中初二进行皆归一乘。发心证果有差别故。次一破嗔痴济有情类。后一永断外道邪见

五百亿龙王围绕此垣

赞曰。造宫之中下第三段龙王守护有三。一明守护。二雨宝树。三次树说法。此初也。法王教化天神警卫。恐致外侵龙王守护。五百亿者。显内具五力四魔不能屈伏。外有龙王非人不能逼害。内持五戒诸恶不侵。外感龙围横灾自灭

一一龙王雨五百亿七宝行树庄严垣上

赞曰。明雨宝树。因五力起七财故。感龙王雨树严饰。七圣财者。谓信戒闻舍慧惭愧

自然有风吹动此树树相掁触演说苦空无常无我诸波罗蜜

赞曰。明树说法。风喻大悲。任运所击真俗智树棠触谈演如是等法。所谓一切有漏逼迫自性皆苦所执。法体都无名空。有为起尽迁流生灭无总自体。一常实我。由此能令诸修行者越到彼岸名波罗蜜

尔时此宫有一大神名牢度跋提即从座起遍礼十方佛发弘誓愿

赞曰。明外果中次下第二明大神为造法堂。慈氏内院也。以堂为主名造法堂。据实而言。具造内院。至下当悉。于中有三。一发愿。第二既发愿下所愿果遂。第三尔时十方无量诸天下诸天睹胜发愿往生。初中有二。一明仪轨二明发愿。此初也。普凭威力遍礼十方。欲解广大发弘誓愿。虽知凡圣同感内院方成菩萨。力增多由圣现。一大神者。表无漏智能起妙土。佛地经云。胜出世间善根所起如如意珠有神用。故亦是凡夫发菩提心加行智感

若我福德应为弥勒菩萨造善法堂令我额上自然出珠

赞曰。正明发愿。宣妙义舍名善法堂。表亲尊重。珠从额出。内院宫字如下自陈。法堂尊胜故标愿首

既发愿已额上自然出百亿宝珠琉璃玻璃一切众色无不具足如紫绀摩尼表里映彻

赞曰。下明愿遂。于中有五。一明作宫。第二时诸园中下作园。第三亦有七宝大师子座下作座。第四时宫四角有四宝柱下作柱。第五如是天宫有百万亿无量宝色下天宫天女宝色皆同。作宫中有八。一明作宫。二栏楯。三天子女。四手生花。五光明。六乐器。七起舞。八说法。作宫殿中有二。初出珠后作宫。此初也。琉璃碧色。颇梨红色。一切众色皆具足者。额上之珠举碧红为首。自余众色一切皆足。或此二宝一切色类皆悉具足。紫谓紫色。绀者说文云。帛深青而阳赤色含绀也。青而含赤色。今此绀者与彼稍异。如紫青色。如意神珠表里映彻

此摩尼殊回施空中化为四十九重微妙宝宫

赞曰。此作宫也。四十九重者。持戒坚牢宫遂重密

一一栏楯万亿梵摩尼宝所共合成诸栏楯间自然化生无量亿万七宝莲华一一莲华上有无量亿光其光明中具诸乐器如是天乐不鼓自鸣此声出时诸女自然执众乐器竞起歌舞所咏歌音演说十善四弘誓愿诸天闻者皆发无上道心

赞曰。自下第二作栏楯。第三化生天子天女。第四手生莲花。第五有无量光明。第六光有乐器不须击鼓而自然响。第七乐声既动女起舞歌。第八歌舞不作生死之戏皆演十善行四弘之誓愿。四弘愿者。一未离苦愿离。二未得乐愿得。三未发菩提心断恶修善者愿早发心断恶修善。四未成佛者愿早成佛。亦云知苦断集证灭修道。诸天闻已发大乘心。此由圣行八圣道支八解脱乐。凡持八戒不杀不盗不邪淫不妄语不饮酒。不香鬘涂身歌舞作倡。不腾高广大床。不非时食。如其次第之所感得。圣凡众行助正智等之所集成。如慧为先安布间饰。故能致此。不尔何缘有斯胜处

时诸垣中有八色琉璃渠一一渠有五百亿宝珠而用合成一一渠中有八味水八色具足其水上涌绕梁栋间于四门外化生四华水出华中如宝华流一一华上有二十四天女身色微妙如诸菩萨庄严身相手中自然化五百亿宝器一一器中天诸甘露自然盈满左肩荷佩无量璎珞右肩复负无量乐器如云住空从水而出赞叹菩萨大波罗蜜

赞曰。第二大段愿遂中一大神作园。于中有二。初列七事严。后结生彼得。初中有七。一八色渠八色渠者。青黄赤白红紫碧绿。二宝珠合成。三八味水即前八色皆悉具足。八味者八功德水可爱味故。八德水者。一清二轻三冷四濡五香六美七饮时不损喉。八饮已不伤腹。四水涌绕梁门外生华。八色之水从花而出。水色交映如宝花流。五花出天女二十四者。持七支戒防三世恶别三心受。故所感果有二十四。六手出宝器甘露满中。表得法味故满甘露。七此诸天女左佩璎珞右负乐器。从八色水而出。如瑞云住空。口赞菩萨诸波罗蜜。持七支戒身三语四。反修七圣财兼行七觉分。除七随眠之所招感。此等天女或非实女。并佛菩萨所共化成。庄严道场。或是女人宿持净戒精进无犯之所感现。不可凡心之所测度

若有往生兜率天上自然得此天女侍御

赞曰。结生彼得

亦有七宝大师子座高四由旬阎浮檀金无量众宝以为庄严

赞曰。第三大段明愿遂中大神作座。于中有十。此文有二。一座量高广清净法界内含四德。化身之座高四由旬。二金宝庄严。三业智行所严饰故。言七宝者。三文不同。无量寿经云。金银琉璃颇梨珊瑚马脑车渠。恒水经云。金银珊瑚真珠车渠明月珠摩尼珠佛地论云。一金二银三吠琉璃四颇胝迦五牟娑珞扬婆(当车渠也)六遏湿摩扬婆(当马脑也)七赤真珠。虽有帝青大青石藏杵藏。非常所重故多不说。三文随方爱乐差别。不可释其不同所以

座四角头生四莲华一一莲华百宝所成一一宝出百亿光明其光微妙化为五百亿众宝杂华庄严宝帐

赞曰。三生四花。慈悲喜舍内四无量外感花故四。百宝饰十善业道自作教他赞叹庆喜。少分多分全分少时多时尽喜行。故一一有十名为百行。内修百行外百宝成。所以上下多说百数。五放光明。智破暗故。六杂花庄严。众行助故

时十方面百千梵王各各持一梵天妙宝以为宝铃悬宝帐上时小梵王持天众宝以为罗网弥覆帐上尔时百千无数天子天女眷属各持宝华以布座上是诸莲华自然皆出五百亿宝女手执白拂侍立帐内

赞曰。七内修四辨外有大梵悬宝铃天人敬重。八内修总持外有小梵为网。九天子天女持花布座。十宝女执白拂侍立帐内。皆由凡除十恶修善戒。菩萨亦持十无尽戒之所招感

持宫四角有四宝柱一一宝柱有百千楼阁梵摩尼珠以为交络时诸阁间有百千天女色妙无比手执乐器其乐音中演说苦空无常无我诸波罗蜜

赞曰。第四大段愿遂中大神造柱。于中有四。一于宫四角各有一柱。二宝柱各有宝珠楼阁梵摩尼者。谓净摩尼或大梵王如意珠也。此柱皆以梵如意珠而为交络。三阁间天女手执乐器。四乐音演法内修四念住心住不动。外感四柱种种庄严

如是天宫有百亿万无量宝色一一诸女亦同宝色

赞曰。第五大段愿遂中天宫天女宝色皆同。欲显内院种种庄严。欲令有情同入佛慧故

尔时十方无量诸天命终皆愿生兜率天宫

赞曰。大神造堂中大段第三诸天睹胜发愿往生。弥勒生已方皆发愿。亦有未生而发愿者

时兜率天有五大神

赞曰。自下第三大段明五大神于外内宫种种严饰。于中有二。初标后显。此标也。由菩萨等内修五蕴妙用莫方。外感五神威力无比。五蕴者。一戒蕴。二定蕴。三慧蕴。缘有为慧。四解脱蕴。胜解数也。五解脱知见。蕴缘无为慧

第一大神名曰宝幢身雨七宝散宫墙内一一宝珠化成无量乐器悬处空中不鼓自鸣有无量音适众生意

赞曰。内持戒得尊高。如宝幢高显故。戒七支雨七宝。由持戒故各称人心。感得乐音适众生意

第二大神名曰华德身雨众华弥覆宫墙化成华盖一一盖华百千幢旛以为导引

赞曰。内修定蕴外感大神名曰花德。定水澄清出妙花故。起四无量垂覆四生。故雨众华化成花盖。无量众行助严禅定。感百千幡以为导引

第三大神名曰香音身毛孔中雨出微妙海此岸栴檀香如云作百宝色绕宫七匝

赞曰。内具慧蕴说法利物破无明臭。外感大神名曰香音。智慧可重如海此岸香。海此岸香六铢价直娑婆世界。绕宫七匝除七漏故。七漏者。谓见漏念漏爱漏思惟漏根漏恶漏亲近漏

第四大神名曰喜乐雨如意珠一一宝珠自然住在幢旛之上显说无量归佛归法归比丘僧及说五戒无量善法诸波罗蜜饶益劝助菩提音者

赞曰。内严解脱蕴。外感大神名曰喜乐。离邪解忧苦得胜解喜乐。心既决定修行能成。故雨如意珠也。心常决定住于真如。外感神珠住在幢幡之上。既说三归又说五戒及诸善法。饶益者利乐义。劝者赞勉义。助者资益济苦义。音谓音声。者谓行者。此意总显神珠演说三归五戒利乐劝勉发求大菩提声之行者

第五大神名曰正音声身诸毛孔流出众水一一水上有五百亿华一一华上有二十五玉女一一玉女身诸毛孔出一切音声胜天魔后所有音乐

赞曰。内修解脱智见蕴。外感大神名曰正音声。智顺正理。如正音声故。出众水者。智水润渡正觉牙故。五百亿花严众德故。二十五玉女者。利益出生二十五有诸善根故。此诸玉女出诸声者。二十五有一切众生皆归念故。出世间声美妙可爱故。胜天魔后所有音乐。或五大神凡持五戒之所感得。亦是五通之所招集。神通他心宿命天眼天耳如次之所感现

佛告优波离此名兜率陀天十善报应胜妙福处

赞曰。答净秽中。上来第一答处净秽。下结所因叹处胜妙。于中有二。一结因二叹胜。此结因也。十不善业得果有四。一异熟。二等流。三增上。四士用。十善业道能得五果加离系果。无漏得四除异熟果。有漏有四除离系果。二种相资故得五果。下明内身即异熟果。又云于一时间成熟五百亿天子得不退地。即离系果。长寿相等名等流果。此等外果有二。一增上二士用。如瑜伽论第五十九六十及对法论第八广说十恶业道所有果相。翻彼即是十善道果。此中总说十善道果不别显示。然诸善法十善摄尽。业道据重十善通轻。故此据总摄一切尽。随义应知

若我住世一小劫中广说一生补处菩萨报应及十善果者不能穷尽今为汝等略而解说

赞曰。此叹胜也。一小劫者日月岁数劫也。三劫行因果应无量。况佛示现境界难思。凡善因果亦广大。故一小劫说亦难尽。即是圣凡之因所招外内二果下上两品所招集故。今为小器略而解说。广则无边

佛告优波离若有比丘及一切大众不厌生死乐生天者爱敬无上菩提心者欲为弥勒作弟子者当作是观

赞曰。明外果中自下第三结劝生彼。于中有三。一示生彼人。二教生彼行。三结成正观。此示生彼人也。略有三人。一者菩萨行法不厌生死受生死苦行利乐故乐生天者。詑脱所依修妙行故于一切生受尊贵。故处劣。自体行不圆故生天得见弥勒佛。故不同二乘厌生死苦恐天放逸不乐生也。二者爱敬无上菩提心者。乐修胜行求大菩提。于弥勒所开大法故。不乐大乘希小果者随受生处欣涅槃故。三者欲为弥勒作弟子者。愿于恶界为作善利。苦有情所希行救济不愿净土。作余佛弟子彼无苦有情可行济度无苦可厌。欣心不深故。又释迦末法持戒犯戒有戒无戒释迦皆嘱弥勒度之。自揣解行难生净土。可为弥勒作弟子者。于上所说天宫处所应作是观。其观者何

作是观者应持五戒八斋具足戒身心精进不求断结修十善法一一思惟兜率陀天上妙快乐

赞曰。二教生彼行也。此修五因。一持五戒。二持八戒。三持具足戒。即是出家五众所受皆名具戒。四身心精进不求断结。精谓精纯无恶杂故。进谓升进不懈退故。不求断结者。非作精进六行断结。断结便生上二界。故五修十善法。今此且论凡夫散心。五粗因行感内外院。增上果业未是巨细分别。解释生彼业因。广劝生中方具教示。虽修此因要须一一思惟。彼天上妙快乐回愿生。故前行非观观为首。故思惟彼故名之为观

作是观者名为正观若他观者名为邪观

赞曰。结成正观。去佛时遥病重行阙。受佛付嘱欣当佛度末代津梁。真为正观。业浅识微智量疏拙。欣生报土。越分所望不称病行名为邪观

尔时优波离即从座起整衣服头面作礼白佛言世尊兜率陀天上乃有如是极妙乐事

赞曰。上明外果下明内果。于中有三。初启请。次广答。后佛灭度后劝生于彼。启请有三。一请仪二叹胜三正请。此中具二。作礼以上请仪。白佛以下叹胜

今此大士何时于阎浮提没生于彼天

赞曰。正请也。有二问。一问此没二问生彼

佛告优波离却后十二年二月十五日于波罗奈国劫波利村波婆利大婆罗门家本所生处结加趺坐如入灭定

赞曰。下广答有四。第一答此没。第二时兜率陀天七宝台内下答生彼天。第三阎浮提岁数下乘言便故说下生时节明住彼天之寿量也。第四佛告优波离是名弥勒下总结。初中有七。此文有三。一命终年月却后十二年者。表闻授记得度生死十二缘起。二月者。涅槃经第三十云。二月名春阳。春阳之月万物生长。种植根栽花果敷荣。江河盈满百兽孚乳。是时众生多生常想。为破此常说一切法悉是无常。唯说如来常住无变。于六时中孟冬枯悴众不爱乐。阳春和液人所贪爱。为破众生世间乐故演说。常乐我净亦尔。言二月者喻二种法身。谓自性身及智法身。冬不乐者喻于智者不乐如来无常入于涅槃。二月乐者喻于智者乐于如来常乐我净。种植者喻闻法欢喜发菩提心种诸善根。河者喻于十方诸大菩萨来诣我所咨受如是大涅槃典。百兽孚乳者喻我弟子生诸善根。花喻七觉。果喻四果。以是义故二月涅槃。师子孔言。初生出家成道转妙法轮皆以八日。何故涅槃独十五日。善男子如十五日月无亏盈。诸佛亦尔。入大涅槃无有亏盈。故以十五日入涅槃。如十五日月盛满时有十一事。一破暗。二令见道非道。三令见邪正。四除郁蒸得清凉。五能破坏萤火高心。六息一切贼盗之想。七除众生畏恶兽心。八能开敷优钵罗花九含莲花。十发行人进路之心。十一令诸众生乐受五欲多获快乐。如来满月亦复如是。一破无明暗。二演说正道邪道。三开示生死邪险涅槃平生。四令人远离贪嗔痴热。五破坏外道光明。六破坏烦恼结贼。七除灭畏五盖心。八开敷众生种善根心。九覆盖众生五欲之心。十发起众生进修趣向大涅槃行。十一令诸众生乐修解脱。故十五日入涅槃义理既同。故涅槃之时与佛无异。上明岁月。二者涅槃处。处即于本国本村。父名波婆利。本生之处。释迦佛于迦维罗卫国生。于俱尸那国入灭。表此化缘毕余方教化。处胎经第二说。我身今灭不复更生于阎浮提。于十方面三十二说诸佛刹。中遍施佛事。此缘尽故彼不尽故。慈氏本生处入灭者。此缘未尽。表于此灭后于此生行利他故。三者入灭形相结跏趺坐如入灭定。释迦北首右胁枕手而入灭者。四威仪中卧为极故。表释迦佛化缘尽故。欲卧必坐。显弥勒佛利乐未终当得果时事方终故。二相不同。表极未极有差别故。如入灭定者。似入涅槃实未圆灭。方上生故

身紫金色光明艳赫如百千日上兜率陀天

赞曰。第四终后生相。身紫金色者。表利当生最第一故。如百千日者。能破众生痴爱想故

其身舍利如铸金像不动不摇

赞曰。第五舍利之形也。舍利者[米*舀]壳也。驮都者体也。佛体大小如[米*舀]谷量故以为名。释迦如来碎分舍利表分身十方处处导利。弥勒舍利全身且在兜率行一佛化故。不动摇者。表佛法身本无生灭动作事故

身圆光中有首楞严三昧般若波罗蜜字义炳然

赞曰。第六圆光神异。梵云三摩地。此云等持。三昧者讹也。大乘之中妙定及慧字之与义二俱炳然。炳然者焕烂之异名也。此意即显圆光之中有定与慧字义焕烂溢目显然瞩其文而义显。故义称现。不尔如何光能现义显。虽入灭禅定智慧由来明焕

时诸天人寻即为起众宝妙塔供养舍利

赞曰。第七天人供养。身虽入灭舍利犹在

时兜率陀天七宝台内摩尼殿上师子床坐忽然化生

赞曰。自下第二答生彼天。于中有六。一生处。二生相。三身量庄严。四异圣神变。五相好光明。六说法利益。此即初也。七宝台者。七财饰故即法堂也。师子座者。于彼台中法王位极得无畏故。忽然化生者。四生中最胜故。自余诸天于父膝上忽然化生。弥勒乃于师子座生。凡圣异故。欲显菩萨离欲生故

于莲花上结跏趺坐身如阎浮檀金色

赞曰。第二生相莲华上者。于师子座上更有莲花。一切佛座净土等中皆坐莲花。表出生死之淤泥秀二乘之浊水故。结跏趺坐者。如盘龙居。以左押右降伏而坐。以右押左吉祥而坐。既将说法显作吉祥。身色如金表可宝重

长十六由旬三十二相八十种好皆悉具足顶上肉髻绀琉璃色释迦毗楞伽摩尼百千万亿甄叔迦宝以严天冠

赞曰。第三身量庄严。长十六由旬者。德高无比能越六道超十地故。相好之义如下当说。寿量随天示同俗故量越天众真德高故。肉髻上发绀青琉璃之色释迦毗楞迦摩尼者。谓能种种现如意珠及甄叔迦宝以严天冠。甄叔迦宝状如延圭似赤琉璃

其天宝冠有百万亿色一一色中有无量百千化佛诸化菩萨以为侍者复有他方诸大菩萨作十八变随意自在住天冠中

赞曰。第四异圣神变。意显心首。常共诸佛十方菩萨为伴侣故。十八变者。一振动。二炽然。三流布。四示现。五转变。六往来。七卷。八舒。九众像入身。十同类往趣。十一隐。十二显。十三所作自在。十四制他神通。十五能施辨才。十六能施忆念。十七能施安乐。十八放大光明。如瑜伽论三十七说

弥勒眉间有白毫相光流出众光作百宝色三十二相一一相中五百亿宝色一一好中亦有五百亿宝色一一相好艳出八万四千光明云

赞曰。第五相好光明。眉间毫相第三十一相也。诸佛毫相皆眉间者。极端严故。面为尊。上间表两中显佛恒时贵处中道。毫相若舒便长无量。卷如秋月。圆皎鲜光。白类雪珂。晖焕众景。白为色本。表作情。依时有卷舒。显随缘现。流众光者。显演三乘相中最胜。所以偏说下圣无有。由此独陈。三十二相者。依大般若第三百八十一。佛言。善现云何如来三十二相。善现世尊足下有平满相。妙善安住犹如奁底。地虽高下随足所蹈。皆悉怛然无不等触。是为第一。世尊足下千辐轮文辋毂众相无不圆满。是为第二。世尊手足皆悉柔软如睹罗绵。胜过一切。是为第三。世尊手足一一指间犹如雁王咸有鞔网。金色交络文同绮画。是为第四。世尊手足所有诸指圆满纤长甚可爱乐。是为第五。世尊足跟广长圆满与趺相称胜余有情。是为第六。世尊足趺修高宛满柔软妙好与跟相称。是为第七。世尊双腨渐次纤圆。如翳泥耶仙鹿王腨。是为第八。世尊双臂修直佣圆。如象王鼻平立摩膝。是为第九。世尊阴相势峰藏密。其犹龙马亦如象王。是为第十。世尊毛孔各一毛生。柔润绀青右旋宛转。是为第十一。世尊发毛端皆上靡。右旋宛转柔润绀青严金色身。皆可爱乐。是第十二。世尊身皮细薄润滑。尘垢水等皆所不住。是第十三。世尊身皮皆真金色光洁晃曜如妙金台。众宝庄严众所乐见。是第十四。世尊两足二手掌中头及双肩七处充满。是第十五。世尊肩项圆满殊妙。是第十六。世尊髆腋悉皆充实。是第十七。世尊容仪洪满端直。是第十八。世尊身相修广端严。是第十九。世尊体相纵广量等周匝圆满。如诺瞿陀。是第二十。世尊颔臆并身上半威容广大。如师子王。是第二十一。世尊常光面各一寻。是第二十二。世尊齿相四十齐平。净密根深白逾珂雪。是二十三。世尊四牙鲜白锋利。是二十四。世尊常得味中上味喉脉直。故能引身中诸支节脉。所有上味风热淡病不能为杂。由彼不杂脉离沉浮延缩坏损拥曲等过。能正吞咽津液通流。故身心适常得上味。是二十五。世尊舌相薄净广长能覆面轮至耳发际。是二十六。世尊梵音词韵和雅随众多少无不等闻。其声洪震犹如天鼓。发言婉约如频迦音。是二十七。世尊眼睫犹若牛王。绀青齐整不相杂乱。是二十八。世尊眼晴绀青鲜白红环间饰皎洁分明。是二十九。世尊面轮其犹满月。眉相皎净如天帝弓。是第三十。世尊眉间有白毫相。右旋柔软如都罗绵。鲜白光净逾珂雪等。是三十一。世尊顶上乌瑟腻沙高显周圆犹如天盖。是三十二。善现是名三十二大士相。善现云何如来应正等觉八十随好。善现世尊指爪狭长薄润光洁鲜净如花赤铜。是为第一。世尊手足指圆纤长佣直柔软节会不现。是为第二。世尊手足各等无差。于诸指间悉皆充密。是为第三。世尊手足圆满如意。软净光泽色如莲花。是为第四。世尊筋脉盘结坚固深隐不现。是为第五。世尊两踝俱隐不现。是为第六。世尊行步直进庠序如龙象王。是为第七。世尊行步威容齐肃如师子王。是为第八。世尊行步安平庠序。不过不减犹如牛王。是为第九。世尊行步进止仪雅犹如鹅王。是为第十。世尊回顾必皆右旋如龙象王。举身随转。是第十一。世尊支节渐次佣圆妙善安布。是第十二。世尊骨节交结无隙犹如龙盘。是第十三。世尊膝轮妙善安布坚固圆满。是第十四。世尊隐处其文妙好威势具足圆满清净。是第十五。世尊身支润滑柔软光悦鲜净尘垢不着。是第十六。世尊身容敦肃无畏常不怯弱。是第十七。世尊身支坚固稠密善相属着。是第十八。世尊身支安定敦重曾不掉动圆满无坏。是第十九。世尊身相犹如仙王。周匝端严光净离翳。是第二十。世尊身有周匝圆光。于行等时恒自照曜。是二十一。世尊腹形方正无欠柔软不现众相庄严。是二十二。世尊脐深右旋圆妙清净光泽。是二十三。世尊脐厚不窊不凸周臣妙好。是二十四。世尊皮肤远离疥癣。亦无黡点疣赘等过。是二十五。世尊手掌充满柔软足下安平。是二十六。世尊手文深长明直润泽不断。是二十七。世尊唇色光润丹晖如频婆果上下相称。是二十八。世尊面门不长不短不大不小如量端严。是二十九。世尊舌相软薄广长如赤铜色。是第三十。世尊发声威震深远。如象王吼明朗清彻。是三十一。世尊音韵美妙具足如深谷响。是三十二。世尊鼻高修而且直。其孔不现。是三十三。世尊诸齿方整鲜白。是三十四。世尊诸牙圆白光洁渐次锋利。是三十五。世尊眼精青白分明。是三十六。世尊眼相修广譬如青莲花叶。甚可爱乐。是三十七。世尊眼睫上下齐整稠密不白。是三十八。世尊双眉长而不曲。致而细软。是三十九。世尊双眉绮靡顺次绀琉璃色。是第四十。世尊双眉高显光润形如初月。是四十一。世尊耳厚广大修长轮埵成就。是四十二。世尊两耳绮丽齐平离众过失。是四十三。世尊容仪能令见者无损无染皆生爱敬。是四十四。世尊额广圆满平正形相殊妙。是四十五。世尊身分上半圆满如师子王威严无对。是四十六。世尊首发修长绀青稠密不白。是四十七。世尊首发香洁细软润泽旋转。是四十八。世尊首发齐整无乱亦不交杂。是四十九。世尊首发坚固不断永无[禾*愛]落。是第五十。世尊首发光滑殊妙尘垢不着。是五十一。世尊身分坚固充实逾那罗延。是五十二。世尊身体长大端直。是五十三。世尊诸窍清净圆好。是五十四。世尊身支势力殊胜无与等者。是五十五。世尊身相众所乐观尝无厌足。是五十六。世尊面轮修广得所。皎洁光净如秋满月。是五十七。世尊颜貌舒泰光显。含笑先言。唯向不背。是五十八。世尊面貌光泽熙怡。远离颦蹙青赤等过。是五十九。世尊身支清净无垢常无臭秽。是第六十。世尊所有诸毛孔中常出如意微妙之香。是六十一。世尊面门常出最上殊胜之香。是六十二。世尊首相周圆妙好。如末达那亦犹天盖。是六十三。世尊身毛绀青光净如孔雀项。红晖绮饰色类赤铜。是六十四。世尊法音随众大小不增不减。应理无差。是六十五。世尊顶相无能见者。是六十六。世尊手足指约分明庄严。妙好如赤铜色。是六十七。世尊行时其足去地如四指量而现印文。是六十八。世尊自持不待他卫。身无倾动亦不逶迤。是六十九。世尊威德远震。一切恶心见喜恐怖见安。是第七十。世尊音声不高不下。随众生意和悦与言。是七十一。世尊能随诸有情类言音音乐而为说法。是七十二。世尊一音演说正法。随有情类各令得解。是七十三。世尊说法咸依次第必有因缘。言无不善。是七十四。世尊等观诸有情类。赞善毁恶而无爱憎。是七十五。世尊所为先观后作轨范具足令识善净。是七十六。世尊相好一切有情无能观尽。是七十七。世尊顶骨坚实圆满。是七十八。世尊颜容常少不老好巡旧处。是七十九。世尊手足及胸臆前俱有吉祥喜旋。德相文同绮画。色类朱丹。是第八十。善现是名八十随好。善现如来应正等觉成就如是诸相好。故身光任运能照三千大千世界无不遍满。若作意时即能普照无量无边无数世界。然为怜愍诸有情故摄光常照面各一寻。若纵身光即日月等所有光明皆常不现。诸有情类便不能知昼夜半月月时岁数。所作事业有不得成。佛声任运能遍三千大千世界。若作意时即能遍满无量无边无数世界。然为利乐诸有情故声随众量不减不增。善现如是功德胜利我先菩萨位修行般若波罗蜜多时已能成办。故今相好圆满庄严。一切有情见者欢喜皆获殊胜利益安乐如是。善现菩萨摩诃萨行深般若波罗蜜多时能以财法二种布施摄诸有情。是为甚奇希有之法。三十二相由行五修。一发心二长时三无间四殷重五无余之所感得。如瑜伽论三十七说。故一一相有五百亿光。八十随好中由行八万四千教行。逗八万四千根病。因之所感。故一一好艳出八万四千光明云。艳者美义。非是焰义。云者出生荫覆之义。三百五十法皆行六度。合二千一百。除贪嗔痴及等分。行由此复成八十。四百又各能除四大六尘所生过失。故总合成八万四千

与诸天子各坐华座昼夜六时常说不退转地法轮之行

赞曰。第六说法利益。于中有三。一陈所说。二明利益。三显常业。此初也。各坐花座表菩萨众并出生死之淤泥故。昼三夜三名为六时。佛住六时恒起六神通恒说六度行。拔六趣生破六随眠超六尘故

[這-言+至]一时中成就五百亿天子令不退于阿耨多罗三藐三菩提

赞曰。此明利益。成五百万亿天者。令生五根具足五力。当圆五眼超五道故

如是处兜率陀天昼夜恒说此不退转法轮度诸天子

赞曰。显佛常业。彼恒光明都无暗。夕以起睡相。得其夜名。佛即不然。常度天子

阎浮提岁数五十六亿万岁尔乃下生于阎浮提如弥勒下生经说

赞曰。第三明下生时节。即住彼天之寿量也。梵云瞻部。此树名也。言阎浮提讹耳。此洲从树为名。四洲所由如余处辨。此间四百岁当彼天中一日一夜。类彼三十日为一月十二月为一年。彼天寿四千岁。慈氏穷彼天寿而方下生。不中夭。故此经云当阎浮提五十六亿万岁者。依瑜伽论第四及立世经毗婆沙等计。此间四百岁为彼一日。此四千岁为彼十日。此间四万岁为彼百日。彼天一年当此一十四万四千岁。彼天十年当此一百四十四万岁。彼天百年当此一百四十四亿岁。彼天千年当此一千四百四十亿岁。彼天四千岁当此五千七百六十亿岁。即与经文不同。今以理推。初以人间四百年为彼一日一夜。复若数以一百而为一类。数计即相当。一当百故人间四十岁为彼十日。人间四百岁为彼百日。人间一千四百四十岁为彼一年。人间一万四千四百岁为彼十年。人间一亿四万四千岁为彼百年。人间十四亿四万岁为彼千年。彼四千年当人间五十七亿六万岁西方有三亿数。一十万为亿。二百万为亿。三千万为亿。以理推排。以千万为一亿。计之即相当矣。是故于经亿字之上应加七字。其前六字应万上安。只恐梵本诵有参差过。译家自成谬。若不尔便少一亿五万岁。理定应尔。智者应知。然此岁数四文不同。贤劫定意经云。弥勒五亿七千六万岁当下作佛。其五亿者即五十亿。前以千万为一亿成五十亿。此以万万为一亿。故成五亿。七十万者即七亿也。十万为一亿故六万数同。更不劳释。唯此一经增减虽殊。与论算同。自余皆别。双卷泥洹经云。一亿四千岁。全不相当。此经及一切智光明仙人慈心经云。五十六亿万岁。如前已正。菩萨处胎经及贤愚经云。五十六亿七千万岁。其六字应云七。其七字应云六。其千万者以百万为一亿以算之。六千万者六十亿也。义不相违。如是推寻。虽乖古疏寻文究理亦应无谬。菩萨在天寿量曾无中夭生在人间。大成佛经说。寿六万岁天尽其年人间长者时宜现。故不同释迦大尽其年人间早灭众生厌故化缘毕故。处胎经说。弥勒人间寿八万四千岁。若依彼说。不须和会。如下生经陈下生事。天利既毕人机复熟。故乃下生

佛告优波离是名弥勒菩萨于阎浮提没生兜率陀天因缘

赞曰。第四大段总结上说。因缘者相状所由为利益故终说上生。皆有所由名因缘故

佛灭度后我诸弟子若有精勤修诸功德威仪不缺扫塔涂地以众名香妙华供养行众三昧深入正受读诵经典

赞曰。明内果中自下第三劝生于彼。于中有三。初劝生彼行。次众发希愿。后结成正观。初文有五。一弟子修六事法往生。二八部闻名敬喜往生。三二众犯戒悔净往生。四归依不退当得度脱。五四部弟子愿往生者修十善行念名恭敬等灭罪多少。虽有五段分之为三。初三段明三品往生。次一段明作归依总劝归生证得善利。后一段示归生者灭罪多少。初之三段明三品生中分三。初一段上品行生。次一段中品行生。后一段下品行生。初中有六。一示其六法。二教其回愿。三明正往生。四诸天赞劝。五生彼利益。六总结成上。此初文也。六事法者。一精勤修福敬恩悲田中所作业等。二威仪不缺坚守诸戒行自住轨则等。三拂塔涂地修饰道场正理制多等。四香花供养四事什物随给济等。五凡夫行三昧闻思等定。圣人入正受。随所得禅或凡三昧非六行定。六行定者必上生。故深住闻思亦名三昧。六读诵经典演说修习十法行等。且举偏胜易行。上首有此六事。其中一一具摄众业。若具修六或能修五上上品生。若修三四上中品生。若修一二上下品生

如是等人应当至心虽不断结如得六通

赞曰。第二教回愿。文势有二。初叹业胜。虽诸凡夫不断结使异于圣者。若修六事神用广大必定往生。如得六通圣者无异

应当系念念佛形像称弥勒名

赞曰。次明称念。虽复修行。仍须正念心想形容口恒称念

如是等辈若一念顷受八戒斋修诸净业发弘誓愿

赞曰。后明回愿。如上所说行六事辈极少但能于一念顷至心不犯。持八戒斋随修净业。发愿资助回向定生。言一念者非余时犯。唯一念持戒。初唯发愿一念持故。何况多时

命终之后譬如壮士屈申臂顷即得往生兜率天于莲华上结跏趺坐

赞曰。第三明往生有二。一生时节。譬如壮士屈申臂顷。显业决定生便速疾。二生处。所莲花之上结跏趺坐定出生死除烦恼故。既生彼天住于梵行故。于花上结跏趺坐

百千天子作天妓乐持天曼陀罗华摩诃曼陀罗华以散其上

赞曰。第四诸天赞劝有三。初散花也。摩诃曼陀罗花者此云大适意花

赞言善哉善哉善男子汝于阎浮提广修福业来生此处

赞曰。次赞叹也。叹美深极重善哉。由习大因今成胜果

此处名兜率陀天今此天主名曰弥勒汝当归依

赞曰。后劝归也。处名知足。由是不耽生死。主号慈尊。故能垂矜苦厄

应声即礼礼已谛观眉间白毫相光即得超越九十亿劫生死之罪

赞曰。第五生彼利益中有二。初灭罪也。无间罪劫一增一减。余处罪劫岁数为之末劫。凡夫行多庸鄙能超恶境祈彼净方。夙运不殚生为上品。况乎灵景独在毫光心专谛观不超生死者也

是时菩萨随其宿缘为说妙法令其坚固不退转于无上道心

赞曰。后获得也。随说宿缘令忆前业识因知果自成不退。昔不退者更为坚固。随其位次成上发心

如是等众生若净诸业行六事法必定无疑当得生于兜率天上值遇弥勒

赞曰。第六总结成上。中有四。一得生上也。三业俱净六事齐修后生彼天。此事何惑。随修六法少净三业心期不退后定上生

亦随弥勒下阎浮提第一闻法

赞曰。二随下也。父子之道尚感天然。虎啸风生此事何惑。六事满三业圆。上品生彼者随初会而闻法

于未来世值遇贤劫一切诸佛

赞曰。三值贤劫佛也。善业纯备正见恒生。既具智福之资粮逢贤劫之佛

于星宿劫亦得值遇诸佛世尊于诸佛前受菩提记

赞曰。四值星宿劫佛也。小乘中说。初劫逢七万五千。第二劫逢七万六千。第三劫逢七万七千佛。依涅槃经第六卷行四依中。初依在地前逢五恒沙佛。第二依在前六地逢六恒河沙佛。第三依在七八九地逢七恒河沙佛。第四依在第十地逢八恒河沙佛。初地菩萨得值百百亿佛。二地千百亿乃至十地无量无边。故生彼者因见弥勒得逢星宿劫千佛。此何疑也。受菩提记者。此句通上。贤劫诸佛亦为受记。受记有六。如菩萨地说

佛告优波离佛灭度后比丘比丘尼优婆塞优婆夷天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等是诸大众若有得闻弥勒菩萨摩诃萨名者闻已欢喜恭敬礼拜此人命终如弹指顷即得往生如前无异

赞曰。此第二段八部闻名敬喜往生。即是第二中品生也。于中有二。初明敬喜发愿往生。后明不愿生闻名亦利益。此即初也。四众八部先不犯戒亦不造恶。罪轻微者闻名心喜语发恭敬身礼拜者。由因胜劣当果虽殊。天赞罪除不退值佛。与前无异。具三业者中上品生。唯具二业中中品生。若唯一业中下品生

但得闻是弥勒名者命终亦不堕黑闇处边地邪见诸恶律仪

赞曰。此明不愿生闻名亦利益。有二。初无恶后有善。无恶有四。一不堕暗处。若处黑暗名暗处。即诸地狱及二界中间若黑果处名暗处。即三恶趣二界中间生无佛法处也。二不堕边地。不堕之言贯下三句。若处边名边。即诸边境远贤良处。若行边名边。即摄处边及蔑戾车达絮等处。前不堕三涂。此不堕八难。三不堕邪见。若别邪见唯断善根类若不正名邪见恶见。皆是四不堕诸恶律仪。恶者不善。律者法。仪者式。即不律仪。对法第八不律仪有十四或十五。谓屠羊．养鸡．养猪．捕鸟．捕鱼．猎鹿．置兔．劫盗．魁脍．害牛．缚象．立坛咒龙．守狱．谗构好为损等。涅槃经中说有十六。牛羊猪鸡为利故养。肥已转卖。即以为四。为利故买已屠杀。复以为四。并前为八。捕鱼捕鸟猎师劫盗魁脍两舌狱卒咒龙复以为八。合前十六。瑜伽第九说有十二。加对法一少对法三。杂心说十二。谓屠羊养猪养鸡捕鸟捕鱼猎师作贼魁脍守狱咒龙屠犬伺猎。总有十二。四文不同者。涅槃猎师即摄猎鹿兔兔缚象三种。对法据多分且说三种。涅槃意通捉雉之属。对法乐损涅槃中无。对法宽故。涅槃初八开差别故。即对法四俱彼生。故对法谗构即是两舌名异义同。故杂心小宗俱说重者名非律仪。余者轻故。此恶律仪亦摄一切犯戒恶行。其堕邪见及恶律仪有佛无佛中方边方皆具有之。若闻弥勒名皆定不堕。三业归依深心欢喜。四等宿愿威力加故

恒生正见恒生正见眷属成就不谤三宝

赞曰。此明有善有三。一恒生正见。翻前邪见。二眷属成就。翻前不作诸恶律仪。诸恶律仪者恶眷属故。三不谤三宝。翻前不堕闇处。不生边地恒逢三宝生信向。故不但中品无四恶有三善。上下品生随应亦有。欲明闻名者改八部之异形受四生之胜体。偏于中品而独明之

佛告优波离若善男子善女人犯诸禁戒造众恶业闻是菩萨大悲名字五体投地诚心忏悔是诸恶业速得清净

赞曰。此第三段二众犯戒悔净往生。即是第三下品生也。于中有三。一悔归罪灭修行往生。二见得不退。三未来值佛。初中有三。一罪灭罪灭有二。一者先受戒禁而后犯之。二者先不受戒造众恶业。闻名归礼两手二足及以头首五体投地至诚忏悔罪速清净

未来世中诸众生等闻是菩萨大悲名称造立形像香花衣服缯盖幢幡礼拜系念

赞曰。二修行也。设不作罪忏悔愿生。但修十行定得生彼。一闻名称。二造形像。三香供。四花供。五衣服供。六缯盖供。七幢供。八幡供。九身恒礼拜。十心口系念

此人欲命终时弥勒菩萨放眉间白毫大人相光与诸天子雨曼陀罗华来迎此人此人须臾即得往生

赞曰。三往生也。犯戒造恶。悔归清净闻名修行。命欲终时菩萨放白毫之妙光灭其罪暗。雨绮花之丽色长其道种佛天来迎。表慈深故须臾往生。显业胜故。此中有三。忏悔造像供养礼拜及系念者下品上生。忏悔造像供养礼拜不恒系念者下品中生。忏悔造像供养而已不恒礼拜不常念者下品下生。虽归忏悔罪得销除。不造形像供养礼拜等。或但形像或但供养或但礼拜或但系念或一称名亦下下品。说不生彼三会之中亦得度脱

值过弥勒头面礼敬未举头顷便得闻法即于无上道得不退转

赞曰。第二见得不退转也。善根久熟见便礼敬。慈悲自起疾得闻法。除不信心速得不退

于未来世得值恒河沙等诸佛如来

赞曰。第三未来值佛也。上来三类明九品生。并内众中亲得见佛速闻法也。若生外众。虽第九品任运后时还成不退。佛号慈尊。善自长故

佛告优波离汝今谛听是弥勒菩萨当为未来世一切众生作大归依处若有归依弥勒菩萨成多陀阿伽度阿罗诃三藐三佛陀时如此行人见佛光明即得受记

赞曰。第四大段总但明有归依不退当得度脱。有三。一明作归依。我即灭度真报之佛未逢末法弟子皆嘱慈尊令度。若不见者便失大利名作归依。二归依者得不退。三弥勒成佛见光受记。其得圣者慧瞩智光。其凡夫者眼见金色。多陀阿伽度如来也。阿罗诃应也。三藐三佛陀正遍知也

佛告优波离佛灭度后四部弟子天龙鬼神若有欲生兜率天者当作是观系念思惟

赞曰。第五大段明上九品愿往生者修十善行念名恭敬等灭罪多少。于中有二。初明乐生业满得生。后明不乐行亦未满。乐生中有四。一令念。二劝行。三教愿。四灭罪。此初也

念兜率陀持佛禁戒一日至七日思念十善行十善道

赞曰。第二劝行也。且论持戒不论余业。举其极小一日至七日亦得往生。何况多年多生修行。以一切善十善摄尽故思念之。行据重者名十善道

以此功德回向愿生弥勒前者当作是观

赞曰。第三教愿也。有行无愿。而行心孤未必得生慈氏所故。有愿无行而愿必虚。前既无因果不生故。所以教愿与行相扶

作是观者若见一天人坐一莲华若一念顷称弥勒名此人除却千二百劫生死之罪

赞曰。第四灭罪有三。一逢缘驻想。二闻名起敬。三礼拜投诚。此即初也。初缘有二。一有情二诸法。见一天人者。随遇一有情缘即念弥勒。有苦念拔。无乐念与。恶者念除。善者念摄。胜者欣求。劣者念厌。善友念崇。恶友念拒。见一莲花者。随遇一法即念弥勒。好法思供养。恶法思不遇。染法欣断。净法欣修。此中且举有情及一法即念弥勒。此意总显作上生业。二品修者逢缘思念。一切时念不暂休废。若一念顷念灭千二百劫生死之罪。慈氏宿愿念者心专故致于此。阿弥陀佛八十劫灭。弥勒昔愿力不同。慈悲深浅乐苦土殊。欣心轻重有差别故。如前校量中说

但闻弥勒名合掌恭敬此人除却五十劫生死之罪

赞曰。第二闻名起敬也。前明若逢缘一念顷念灭千二百劫。此但闻名合掌恭敬除五十劫。但发身业首不至地。归心轻故

若有敬礼弥勒者除却百亿劫生死之罪

赞曰。第三礼拜投诚也。以首至地昼夜相续除罪百亿劫。身心等归并皆重故。此为最重见毫。第二一念顷。第三闻名合掌。第四轻重异故。问何故见身毫相不如遥念。答见佛身相灭罪寔多。良以遥念行而难生。见归崇而易起。行化之法先劝作难修后劝作易行。又人间苦重欣意殊深。天上乐多厌心诚浅。又遥念者一念顷时长故意念故。见光者暂时间时短故眼见故。遥念者灭罪多。见毫光者灭罪小。问闻名归念灭罪多。小经有明文。造形供养功德多少。答功德更多。作事相续念亦大故。此中且举少念少礼一暂归闻。若数数听闻频频敬礼朝朝供养。功德更多。前三品修但明得生之福。未论灭罪之相。第二段中明作归依不退利益。今第三段方明灭罪。即是总说作大归依。令众欣生归崇灭罪

设不生天未来世中龙华菩提树下亦得值遇发无上道心

赞曰。此明不乐生业力未满者龙花三会亦发道心。其前乐生三品业满龙花三会悉得道。此唯发心故成差别。菩萨处胎经第二卷说。汝生快乐国。不如我国苦。汝说法甚易。我说法甚难。初说九十六受我五戒者。次说九十四受持三归者。后说九十二一称南无佛。据实上品生修六事法。彼经唯言受我五戒。初会度者但举行者修六中一。威仪不缺摄。上下品生唯一事故。受持三归第二会度者中三品中中上品生。具三业故。一称南无佛第三会度者下三品中下下品摄。唯口念故。彼经且举三中各一。粗俗所修非具显。故不相违也

说是语时无量大众即从座起顶礼佛足礼弥勒足绕佛及弥勒菩萨百千匝

赞曰。劝生彼中自下第二大段众发希愿有二。初众发希愿。后佛记生。愿中有二。一明威仪。二明发愿。此初也。从坐起者。表生于彼从生死起。礼二足者。舍烦恼故。绕佛菩萨百千匝者。显百千生常不离故

未得道者各发誓愿我等天人八部今于佛前发诚实誓愿于未来世值遇弥勒舍此身已皆得上生兜率陀天

赞曰。此发愿也。未得道者但举凡夫。圣随愿故不还无学等神通可往。励劝末代故唯举凡不谈圣往。未来值遇三会得度。舍此身已方愿生上

世尊记曰汝等及未来世修福持戒皆当往生弥勒菩萨前为弥勒菩萨之所摄受

赞曰。下佛记生。汝等及未来下品行者乃至一念称弥勒名皆得生彼。况能修福持戒上品不生。三乘五乘皆度脱故

佛告优波离作是观者名为正观若他观者名为邪观

赞曰。劝生彼中第三大段结成正观。为度末代殷勤劝往

尔时尊者阿难即从座起叉手长跪白佛言世尊善哉世尊快说弥勒所有功德亦记未来修福众生所得果报我今随喜

赞曰。一部之中第三大段闻名喜行分。于中有四。一问。二答。三时众获益。四喜退流通。初中有二。初赞说随喜。后正问持名。此初也。叹凡及圣功德业果。故成前说皆通二感

唯然世尊此法之要云何受持当何名此经

赞曰。此问持名。唯然者敬诺词。此经要妙如何受持。行之仪轨复何名之

佛告阿难汝持佛语慎勿忘失为未来世开生天路示菩提相莫断佛种

赞曰。第二随答为二。此答受持。我今灭度末代无依。故劝受持敕令不妄。为令未来近受天中之法乐舍四趣之沦丧。远示菩提之妙相出三界而超骧。经在有善植根法。灭便断佛种。佛谓圆觉。种名为因慧。学故慧生。不学种断

此经名弥勒菩萨般涅槃亦名观弥勒菩萨上生兜率陀天劝发菩提心如是受持

赞曰。此正答名。说弥勒菩萨涅槃之事故以为名。示生彼相令有瞻观。劝发道心流通万代。依名释义。如是受持。受谓领纳之在心。持谓任持之不妄

佛说是语时他方来会十万菩萨得首楞严三昧

赞曰。第三时众获益有二。一圣益后凡益。此初也

八万亿诸天发菩提心皆愿随从弥勒下生

赞曰。此凡益也。不但当时发心。亦愿未来随下

佛说是语时四部弟子天龙八部闻佛所说皆大欢喜礼佛而退

赞曰。第四喜退流通。得未曾有由此欢喜事讫。依教故退流通。恶果恶因生于季俗之末。佛前佛后长于无暇之中。欣生净土妙行不成。若冀天宫恐胜因无结净土。虽无恶染圣教自有参差。天宫虽有欲乐。道理定无疑惑。厌尘境者触事染而不染。耽欲乐者是事不染而染。戒业缺然福慧浅薄。佛既应物机而现秽。凡亦契圣境而欣生。上圣上贤皆为此业。下凡下位何得越之。故行同者皆应专习。率已穿鉴。望充生因。自余状迹具如别传

大宋高僧传第四云。后躬游五台山。登大行至西河。古佛宇中宿。梦身在半山岩下。有无量人唱苦声。冥昧之间初不忍闻。徒步陟彼层峰。皆琉璃色。尽见诸国土。仰望一城。城中有声曰。住住咄。基公未令到此。斯须二天童自城出问曰。汝见山下罪苦众生否。答曰。我闻声而不见形。童子遂投与剑一镡曰。割腹当见矣。基自割之腹开有光两道。晖映山下见无数人受其极苦。时童子入城持纸二轴及笔投之。捧得而去。及旦惊异未已。过信夜寺中有光。久而不灭。寻视之数轴发光者。探之得弥勒上生经。乃忆。前梦必慈氏令我造疏通畅厥理耳。遂投毫次笔锋有舍利二七粒。而陨如吴含桃许大。红色可爱。次零然而下者。牧如黄梁粟粒(云云)

  依此赞得义　　本经行讲演
  欣以此法施　　顺次诣都率
  慈尊受教诫　　显法身无相

观弥勒菩萨上生兜率天经赞卷下终


观无量寿佛经疏妙宗钞

    No. 1751 [cf. Nos. 365, 1750]

观无量寿佛经疏妙宗钞卷第一

        宋四明沙门知礼述

此经义疏人悕净报。故说听者多矣。所禀宝云师。首制记文。相沿至今。著述不绝。皆宗智者。岂有不知修心妙观。感四净土文义者耶。良以愍物情深适时智巧。故多谈事相。少示观门。务在下凡普沾缘种。方今嘉运。盛演圆乘慕学之徒。皆欲得旨而修证矣。故竭鄙思。钞数千言。上顺妙宗。略消此疏。适时之巧。非我所能。愿共有情。即心念佛。乃此钞所以作也。天禧五年。岁在辛酉。重阳日下笔故序

此之疏题。佛等八字。备举经目。皆是所释。唯疏一字是能释也。今之五章。释其八字。义稍委悉。入文自见。若欲预知可陈梗概。经是通号。余是别名。今且明别。佛说者。释迦化主。四辩宣演也。观者。总举能观。即十六观也。无量寿佛者。举所观要。摄十五境也。且置能说。略明所说。能观皆是一心三观。所观皆是三谛一境。毗卢遮那遍一切处。一切诸法皆是佛法。所谓众生性德之佛。非自非他非因非果。即是圆常大觉之体。故起信论云。所言觉义者。谓心体离念。离念相者。等虚空界无所不遍。法界一相即是如来常住法身。依此法身说名本觉。故知果佛圆明之体。是我凡夫本具性德故。一切教所谈行法。无不为显此之觉体。故四三昧通名念佛。但其观法为门不同。如一行三昧。直观三道显本性佛。方等三昧观袒持显。法华兼诵经。观音兼数息。觉意历三性。此等三昧历事虽异。念佛是同。俱为显于大觉体故。虽俱念佛。而是通途。显诸佛体。若此观门及般舟三昧。托彼安养依正之境。用微妙观。专就弥陀。显真佛体。虽托彼境。须知依正同居一心。心性遍周。无法不造。无法不具。若一毫法从心外生。则不名为大乘观也。行者应知。据乎心性观彼依正。依正可彰。托彼依正。观于心性。心性易发。所言心性具一切法造一切法者。实无能具所具能造所造。即心是法。即法是心。能造因缘及所造法。皆悉当处全是心性。是故今观。若依若正。乃法界心。观法界境。生于法界。依正色心。是则名为唯依唯正唯色唯心唯观唯境。故释观字。用一心三观。释无量寿用一体三身。体宗力用义并从圆。判教属顿。五重玄义本是经中所诠观法。大师预取解释经题。欲令行者用此视法。入十六门而为修证。故于序文。以主包众。以正收依。观佛既即三身。观余岂非三谛。寄语行者。观虽深妙。本被初心。若能进功。何忧不就。纵未入品。为因亦强。生至彼邦。得预大会。所见依正。微妙难思。速入圣阶。度生亦广。永异事善及小乘行。得往生者。如此土人宿圆修者。于诸座席见相殊常。闻法易悟。以此类彼。功在妙宗。但为戒福不精。无往生愿故。在秽土闻法入真。须惧娑婆不常值佛。纵遇善友色心不胜。难发我心。况尘境粗强。诚为险处。故须外加事忏内勤理观。正助双行加愿要制。必于宝刹速证无生。今解观门其意在此。疏者疏也。决也。疏通决择上之义趣。通而不壅。令其行者得意修之故也。次能说人号。备于别传及诸章记。有未知者须寻彼文。二释文。初释序三。初叙经观意二。初正明观行二。初叙意二。初对垢立净二。初法二。初明二报苦乐。欲论观行。先示二报苦乐之相。文有四句。一一皆论净秽相对。初句以所成国土苦乐相对。安养净国。但受诸乐故名乐邦。堪忍秽土多受众苦。义言苦域。次句以能成物体贵贱相对。彼纯七珍。略言金宝。此多众秽略语泥沙。次句以初生受质。垢净相对。此土六道具有四生。今就人中多从胎藏。母食冷热及饥饱时。儿在胎中。如处寒热倒悬山压地狱之苦。故云胎狱。彼土九品。八从莲生。下品之人虽经多劫。大本中说。疑心修善。生彼胎宫乐同忉利。况八九品不生疑惑。岂有苦耶。是故华池受生即乐。次句以生后游处粗好相对。此则荆棘丛林。彼则金渠玉树。然此四句虽一一句。苦乐相对。意则对秽显彼净相。又复应知。四句之文似唯显示同居二土。据下明宗。具论四。土净秽之相。以后验此不专同居。当知四句一一通于四种净秽。见思轻重。则感同居乐邦苦域。体析巧拙。则感方便乐邦苦域。次第顿入。则感实报乐邦苦域。分证究竟。则感寂光乐邦苦域。以例金宝泥沙。胎狱华池棘林琼树。亦复如是。一家制立。正文与序必不相违。但序总示。文宗别说。是故似异。问下三净土既皆有相。则可论于金宝等事。寂光之净已全无相。如何可说金宝华池及以琼树。答经论中言寂光无相。乃是已尽染碍之相。非如太虚空无一物。良由三惑究竟清净。则依正色心究竟明显。故大经云。因灭是色获得常色。受想行识亦复如是。仁王称为法性五阴。亦是法华世间相常。大品色香无非中道。是则名为究竟乐邦。究竟金宝。究竟华池。究竟琼树。又复此就舍秽究尽取净穷源。故苦域等判属三障乐邦。金宝以为寂光。若就净秽平等而谈。则以究竟苦域泥沙而为寂光。此之二说但顺悉檀无不圆极。问佛无上报是即理之事。可论金等。究竟寂光是即事之理。岂有金等。若其同有事理既混。如何分于二土义耶。答佛无上报是究竟始觉。上品寂光是究竟本觉。始本既极岂分二体。应知二土纵分事理实非有无。岂真善妙有而非理邪。秘藏之理岂同小空。故此事理二名一体。以复本故。名无上报事也。以复本故。名上寂光理也。故妙乐云。修得四德。本有四德。二义齐等。方是遮那身土之相。况净名疏。显将寂光为佛依报。故知定执报土有金宝等。寂光定无。斯乃迷名全不知义矣。二诚由下。明二因心行。诚实也。由从也。报之净秽实从心行二因致感。心即迷了二心。行即违顺二行。六道三教迷三德性。为三惑染。故曰垢心。身口诸业违理有作。皆名恶行。此之心行感四秽土。沉下粗浅也。唯圆顿教了三德性。离三惑染。方名净心。身口诸业顺理无作。称为善行。此之心行感四净土。高升深妙也。心虽本一。以迷了故。须分垢净。行业虽同。以违顺故。须开善恶。从此二因感报净秽。应知圆人。以上寂光而为观体。凡圣因位皆即究竟。不同别人要心只齐一十二品。故分证秽。正在别教。问至理微妙不垢不净。无取无舍。今立垢净令人取舍。既乖妙理即非上乘。何得名为修心妙观显一实相。答据名求义万无一得。以义定名万无一失。良以理外理内。小乘大乘。渐次圆顿。所立名言率多相似。须以邪正定其内外。次以空中甄其小大。复以渐顿分其别圆。则使名言纤毫不滥。方可凭之立乎观行。是故今家评此等义。而用六句判于同异。所谓相破相修相即。各有二句。即六句也。今用此六判此相违。先以别义定其同名。所谓外道断无不垢不净见。二乘空理不垢不净证。别教但中不垢不净门。圆教秘藏不垢不净理。复有四净。外道欣厌执净之见。二乘断惑灭净之证。别教离染渐净之门。圆教即染顿净之理。既知此已。乃可论于净与不垢不净相破之句。圆教顿净破于别教二乘外道不垢不净。圆教不垢不净。破于三种之净。相修句者。三种之净。修于圆教秘藏不垢不净。三种不垢不净。修于圆教即染之净。相即句者。圆教即染之净。即是秘藏不垢不净。秘藏不垢不净。即是即染之净。今之妙观。即于染心观四净土。既照寂光。岂异秘藏不垢不净邪。若谓今经舍秽取净异于秘。藏双非理者。何故韦提闻观净土。分证秘藏邪。应知今净净于垢净。乃以垢净平等之理。而为于净土。名偏义圆。斯之谓矣。但以机缘舍秽心强。宜以净门净一切相。故今谈净与不垢不净。全不相违。又复应知。取舍若极。与不取舍亦非异辙。二喻。形端喻净因。了性净心。顺理善行。影直喻果。四净土也。源浊喻秽因。迷性垢心。违理恶行。流昏喻果。四秽土也。若翻上喻。形曲影凹。自可喻于逆修因果。若翻下喻。源净流清。亦自可喻顺修因果。今举二喻各喻一种其义甚明。二故知下。就净示修。上已对秽显于净相。故今就净而明修法。前示二因。通云净心及以善行。此明修相。故的指今十六妙观三种净业。于十六境不照三谛。岂明妙观修三种福为三惑染。不称净业。妙观是正。净业为助。正助合行。能感四种极乐国土。得见三身弥陀世尊。文从互说。观论生土。业论见佛。依正既俱。正助非隔。二然化下。示文二。初示教兴二。初明兴由革凡之化。要因近事。而为鸿渐。诠理之教。必藉机缘。方得兴起。近事为渐通于诸化。今化别由杀逆之事欲令众生厌浊世故。此教当机。是韦提希。华言思惟。善修观故。二大圣下。明现土。佛是极圣。故称为大。佛慈下被。名之曰垂。托韦提请。布所证理。名乘机演法。曜玉相等者。经云。尔时世尊放眉间光。遍照十方无量世界。还住佛顶化为金台。如须弥山虽广示等者。经云。十方妙国皆于中现。或有国土七宝合成。复有国土纯是莲华。乃至云。时韦提希白佛言。是诸国土虽复清净。我今乐生极乐世界阿弥陀佛所。二使末下。示观相二。初总标。使末俗等者。经云。如来今者教韦提希。及未来世一切众生。观于西方极乐世界。以佛力故。当得见彼清净国土等。二落日下。别示十六观法不出三类。即依报正报。及三辈往生。今顺此三。撮要而示。文自为三。初依报。初观落日状如悬鼓。令心坚住专想不移。此有二意。一令观日心不驰散。二令心想正趣西方。故云用标送想之方。次观清水。复想成冰。良以彼土琉璃为地。此地难想。且令想冰。冰想若成宝地可见。故云实表琉璃之地。次示树观。而经但云其诸宝树七宝华叶无不具足。而无风吟天乐之事。乃取小本中语。成今树观之文。故彼经云。微风吹动众宝行树。及宝罗网。出微妙音。譬如百千种乐同时俱作。故云共天乐而同繁。次示池观经云。有八池水。从如意珠王生。分十四支。黄金为渠。其摩尼水流澍华间。其声微妙。演说苦空无常无我。诸波罗蜜等。故云将契经而合响。二观肉下。示正报。先明观音势至二菩萨观。以此二观皆明肉髻故。经云。若有欲观观世音菩萨者。先观顶上肉髻。次观天冠。其余众相。亦次第观之。势至。经云。顶上肉髻如钵头摩华。于肉髻上。有一宝瓶。盛诸光明。普现佛事。余诸身相如观世音等无有异。斯是如来教示行者。想二大士观法之要也。此二菩萨。次当补处。今为近侍。故云瞻侍者也。次示弥陀观。经云。观无量寿佛者。从一相好入。但观眉间白毫。极令明了。见眉间白毫者。八万四千相自然当现。岂非教示观法之门。故云念毫相而睹如来也。三及其下。示三辈观。下疏判云。观三品往生有二意。一令舍中下修上品故。二令识位高下。即大本三品故。此之二意初策自行。次则观他。故今略叙。就策自行。即修观行人功有浅深。致使往生相分三品。故云及其瞑目告终等也。初明上品上生及上品中生。以经明上生乘金刚台。中生坐紫金台。故云上珍台也。次文成下。明上品下生。经云。即见自身坐金莲华。文成印坏者。大经二十七云。譬如蜡印印泥。印与泥合。印灭文成。以喻凡夫现在阴灭中有阴生。今借此文以喻往生菩萨此土阴灭彼国阴生。须知垂终自见坐金莲身。已是彼国生阴故也。成论明极善极恶俱不经中阴。如[矛*(替-曰+貝)]矛离手也。上虽三品但是上辈。次总示三辈往生之者。俱出轮回。言随三辈者。非谓随他。盖是随己所修。三辈行业皆能横截五道。永得不退也。大本云。往生安养国横截五恶道。五苦者。此方五道俱不免苦。天道纵乐还堕恶趣故。二可谓下。结叹观行。微行者。叹三种业。虽是身口运为之善。今顺理修。皆成无作幽微无相之行也。妙观者。叹十六观。虽托安养依正之境。而皆称性绝待照之。即不思议圆妙观也。此之观行能令修者达四净土。纵具见思而能不退。诚为至极之道要妙之术。如此叹结意令闻者尚之修之。不肖之徒。轻欺生死不求不退。于斯要术生谤障人。痛哉痛哉。二此经下。叙经宗体。心观者。经以观佛而为题目。疏今乃以心观为宗。此二无殊。方是今观。良以圆解全异小乘。小昧唯心佛从外有。是故心佛其体不同。大乘行人。知我一心具诸佛性。托境修观。佛相乃彰。今观弥陀依正为缘。熏乎心性。心性所具极乐依正。由熏发生。心具而生。岂离心性。全心是佛全佛是心。终日观心终日观佛。是故经目与疏立宗。语虽不同。其义无别。又应须了。若观佛者。必须照心。若专观心。未必托佛。如一行三昧直观一念。不托他佛而为所缘。若彼般舟及此观法发轸即观安养依正。而观依正不离心性。故曰心观。须知此观不专观心内外分之。此当外观以由托彼依正观故。是以经题称为观佛。若论难易今须从易。法华玄云。佛法太高。众生太广。初心为难。心佛众生三无差别。观心则易。今此观法非但观佛。乃据心观。就下显高。虽修佛观不名为难。是知今经心观为宗。意在见佛。故得二说义匪殊途。又应了知。法界圆融不思议体。作我一念之心。亦复举体作生作佛。作依作正。作根作境。一心一尘至一极微。无非法界全体而作。既一一法全法界作。故趣举一即是圆融法界全分。既全法界。有何一物不具诸法。如义例中。僻解师云。四教中圆。唯论心具一切诸法。身色依报则不论具。唯一顿顿方明三处皆具诸法。荆溪论曰。四教中圆。何尝不云三处具法。禀今宗者。若云心具色等不具。同彼谬立渐圆之见。望彼顿顿。天地相悬。尚劣于彼。何预今宗。以一切法一一皆具一切法故。是故今家立于唯色唯香等义。若其然者。何故经论多以一心为诸法。总立观境邪。良以若观生佛等境。事既隔异。能所难忘。观心法者近而复要。既是能造。具义易彰。又即能观而为所照易绝念故。妙玄云。三无差别观心则易。纵观他境亦须约心。此经正当约心观佛也。实相为体者。心观之宗。方能显发中道实相深广之体。所以者何。若于心外而观佛者。纵能推理但见偏真。即如善吉观佛法身。但证小理。今约唯心。观佛依正当处显发中实之体。中必双照三谛具足。故云。此经心观为宗。实相为体。文特于此。举宗体者。成前叙观。显后叙题。成前者。以叙观文虽具三观四土之义。语且总略。恐失意者。谓但叙于同居净土观行之意故。叙观毕。特示唯心妙观之宗。以显中道实相之体。实相既是常寂光土。若谓十六只观应佛依正之相。岂能显此实相寂光若于十六用圆三观。尚能感得寂光极乐。岂不能感三土极乐。以此成前乐邦。金宝等诸文义。皆明四种净土因果也。显后者。行人若得此宗体意。则知叙题能说之佛。所说观境徒众依报。及以通名。如是诸义悉皆圆妙。非小非偏。方是今经首题名字。叙观叙题两楹之际。云乎宗体。其意在兹。三所言下。叙经题目二。初别题七字。具含能说所说能观所观正文释名备显其义。今序但明以胜摄劣揽别为总。立题之意也。以十六境佛境最胜。故云佛是所观胜境。盖十六观不出依正及以徒主。若论依正。佛是正报。举正收依。则摄日冰地树等六观也。若分徒主。佛是化主。述主包徒。则摄观音势至三辈等九观也。故云观虽十六言佛便周。故入正文以圆三观释乎能观。以妙三身释所观佛。佛既总摄。余十五境。岂不一一皆是圆妙三谛三观邪。二经者下。通题。儒经讲解。有兹二训。万代轨则。故训法也。百王不易。故训常也。佛经亦然。十界咸规。三世不易。复以由义而释于经。由佛大圣金口。宣吐自证之法故。名为经。法华玄义委解通名。当宗学人不可不究。二入文二。初取义释题二。初标列。注云云者。令依诸部明于通释五章之义妙玄最委。故彼文云。就通作七番共解。一标章。二引证。三生起。四开合。五科简。六观心。七会异。标章令易忆持。起念心故。引证据佛语。起信心故。生起使不杂乱。起定心故。开合料拣会异。等起慧心故。观心即闻即行。起精进心故。五心立成五根。排五障成五力。乃至入三解脱。略说七重共意如此。今疏从略。但标五名也

二随释五。初释名二。初标。二一切下释二。初对通略示二。初就三处论通别三。初约一化二。初释二。初示诸题具通别。他释经题皆以经字为能诠教。余字并是所诠之义。作此分之。甚违佛旨。且人法譬皆是名字。岂非能诠。那得一向属所诠义。经字不可一向属教。如妙经云。法华经藏深固幽远无人能到。又云。为佛护念植种德本。入正定聚。发救一切众生之心。成就四法。必得是经。疏释此四是开示悟入佛之知见。知见证理名为得经。此二岂非以理为经。金光明云。十方诸佛常念是经。岂令诸佛但念于教。此例盖多。不能备引。故知诸师。以能诠所诠释众经题。失旨之甚。今家皆用通别释题方无所失。二通则下。明通别有三种。今解诸经通别二名。俱是能诠俱是所诠。良以通别各自具于教行理故。勿谓二名但在于教。须知通别自有教名行名理名。如一别题。佛说是教。观即是行。无量寿佛是理。岂非别教别行别理。以此三别对于经字。即是通教通行通理今于三中。初明教通别二。初正明一化通名者。顿说渐说施权开权律论之外。皆名为经。故称通也。别名者。别相乃多。今从三种。谓人法譬。单三复三。并具足一以成七别。单三者。单人。如阿弥陀经等。单法。如大般涅槃经等。单譬。如梵网经等。复三者。人法。如文殊问般若经等。法譬。如妙法莲华经等。人譬。如如来师子吼经等。人法譬具足者。如胜鬘师子吼一乘大方便方广经等。以此七别与通。合标一代佛法。二今经下。别指此经。本论一化。言此经者。以明七别。此属单人。是故言也。虽属单人而人自分。能说释迦。所说弥陀。以此二人而为别目。经同一化。故曰通名。据有观字合是人法。能从于所。以人兼之。故略不示。然分通别。不同广释故未委悉。二为行下。行通别。诸经有用一种之行而为别名。以对通名。经即通行。若论别行。其数无量。卒难说尽。今以增数示于行人。似可领会。一如一行等。二如二智等。三如三观等。四如四念等。五如五根等。六如六妙等。七如七觉等。八如八正等。九如九禅等。十如十度等。乃至百千万亿无量行也。此等别行皆趣涅槃。究竟四德略言常乐。约趣涅槃别行即通。故为行经。彼释签中。乃以因果判行通别。须知其意。非谓至果其行方通。欲知意者。据各修因名为行别。约趣一果。此别即通。斯乃别时论通。通时论别。岂唯行尔。教理亦然。如以机应对教通别。佛以一音演说法。众生随类各得解。各解则机别。一音则应通。各解不离一音。一音不妨各解。如金光明玄。以能诠文字为教通。以能诠所以为教别。所以即是四悉檀也。一一悉檀皆用文字。一一文字不离悉檀。如以名实对理通别。多名不离一实。一实不妨多名。故三通别皆悉同时。悉类乐中管色之韵。约声则通。约曲则别。通别二用不相妨碍三理虽下。理通别。名实相对名即是门。乃以四门彰一理也。亦是事别而对理通。良以诸经多用一事而彰于理。得理别名。如此经题以无量寿佛。名为别理。以对通名经则通理。若于一化以通别理解经题者。莫若四门以为别理。四门者有门。空门。双亦门。双非门。四门名通。须分四教。所谓三藏教。通教别教。圆教。四教各开有等四门。四四乃成一十六门。诠于别理成十六理。理尚非一。那得十六。然理无碍能应诸门。犹彼虚空其体实非方圆大小。以无碍故。故能随彼方圆等物成无量相。从无量说即是别理。体是一空名为通理。无通不别无别不通。通别合标成一题目。二此约下。结五时之内。一一经题皆具通别。若不用此教行理判。徒分通别。全无所以也。然无量行会一常乐。四教四门同诠一理若专方等未堪此闻。乃是预取法华之意。跨节而谈。于佛灭后。解释诸经不约法华宁穷一化。二更约下。约一题。一化经目通别二名。具教等三关涉既广。思修或难故。就即今所解经题。明教行理。宛然可见。此三皆别。以对经字。即是三通。故云任运有通别意。欲使行者。即此一题。就说解教起能观行见真佛理。三更就下。约一字。一题虽约而涉三名。今示一字。解行证三悉得具足。此复为二。初就说字兼含释题。中说字最可显于教行并理。故引释论所行如所说句。以示说中含于行理。如者真如也。如名不异。一真觉性。物成无殊。三际平等。契此如理。方得心口说行不异。故金刚般若云。云何为人演说。如如不动。法华云。诸法空为座。处此为说法。事相解如。二物相似。以为不异。理观解如。二物性一。方名不异。故释经如是。三藏则以传佛所说。似水传瓶。名曰文如。衍教不尔。通以二谛相即为如。别则唯闻中道为如。圆以文字。性离为如。三教约此方曰文如。论就理观心口理一。方得说行如如不异。此令说者行契如理也。二佛即下。就诸字互具释。佛复本源究竟觉体。非寂非照。故属法身。观字即是清净智慧寂而常照。故属般若。无量寿是自在神通。照而常寂。故属解脱。今将诸字。分对三德。深有所以。所以者何。向就一字明教行理。虽约说字义具于三。既约修辩。尚通前教。而又未明字字具三。故今特用涅槃三德。对于诸字。乃彰诸字性各具三。非前教人所能思说。良以三德性本圆融。一一互具故。直法身非法身。法身必具般若解脱。直般若非般若。般若必具解脱法身。直解脱非解脱。解脱必具法身般若。三德即是教行理三。般若是教。智在说故。解脱是行。用从缘故。法身属理。是所显故。佛字既是法身之理。即具二德及教行也。观字既属般若之教。亦具二德及行理也。无量寿既是解脱之行。亦具二德及理教也。若不然者。岂得即一达三即三达一。问本以一字具教行理。今何得以无量寿三字。方具于三。则不名为约一字也。答以题诸字对三德释。斯是妙谈。贵在得意。欲令行者知三德性遍一切处。一字一句。一偈一品。一部一经。一时一化。乃至一切依正色心。多亦三德。少亦三德。一尘三德不小。刹海三德不大。故引华严云。一中解无量等也。若得此意。今之妙观有造修分。应色一相可照三身。依报一尘即寂光土。故十六观皆照三谛。其不信者则辜吾祖立兹法矣。二于一下。约一字以校量三初正校量。上穷妙旨。从广至狭。今校功德。从少至多。一字尚诠大涅槃理。况一切经岂不圆遍。二故经下。引经证。如金光明及诸大乘。多作此说。三若不下。结今得。不明一字圆具三德。诸经所说一句一题。受持功德无量无边。便成虚设也。自非道场得入三昧发旋总持。曷能妙说自在若斯。二初释下。就别广明。置通释别也。文四。初释佛字二。初正约佛名示六即二。初翻名标示。梵云佛陀。华言觉者。即说教主。别号称曰释迦牟尼通号有十。今举第九。故标佛也。既是极果。即究竟觉。起信论云。觉心初起。心无初相。远离微细念故。心即常住。名究竟觉。此觉圆净无所对待。生佛依正镕融总摄。十方三世亘彻无外。五住二死尽净无余。无量甚深永绝思议。强名妙觉。此之觉义有六种即。即者是义。今释迦文。乃究竟是圆净之觉。一切凡圣无不全体皆是此觉。虽全体是。且迷悟因果其相不同。故以六种分别此是。所谓理是。名字是。观行是。相似是。分证是。究竟是。然若不知性染性恶。所有染恶定须断破。如何可论全体是邪。全体是故。免于退屈。六分别故。免于上慢。六不离即。即不妨六。六即义成圆位可辩。问所言凡圣全体即佛。为即自己当果之佛。为即释迦已成之佛。答自己当果。释迦已成。二佛之体究竟不别。故诸果佛为生性佛。迷则俱迷。见则俱见。故己他佛于今色心。皆可辩于六即义也。又复应知。六即之义不专在佛。一切假实三乘人天。下至蛣蜣地狱色心。皆须六即辩其初后。所谓理蛣蜣名字乃至究竟蛣蜣。今释教主。故就佛辩。以论十界皆理性故。无非法界。一一不改故名字。去不唯显佛。九亦同彰。至于果成。十皆究竟故蛣蜣等皆明六即。二涅槃下。就觉广明六。初理即。六种即名皆是事理体不二义。而事有逆顺。名字等五是顺修事。唯理性一纯逆修事。此逆顺事。与本觉理体皆不二。其逆顺名自何而立。以知不二。事皆合理。名之为顺。其不知者。事皆违理故名为逆。名字等五。若浅若深。皆知皆顺。若初理即唯迷唯逆。而迷逆事与其觉理。未始暂乖。故名即佛。所以者何。良由众生性具染恶不可变异。其性圆明。名之为佛。性染性恶全体起作。修染修恶更无别体。全修是性故得迷事无非理佛。即以此理起惑。造业轮回生死。而全不知事全是理。长劫用理长劫不知。不由不知。便非理佛。以全是故。名理即佛。以不知故非后五即。然理即佛。贬之极也。以其全乏解行证即。但有理性自尔即也。又理即佛。非于事外指理为佛。盖言三障理全是佛。又复应知。不名障即佛。而名理即佛者。欲障后五有修德是。此之一位唯理性是也。又障即佛。其名犹通。以后五人皆了三障即是佛故。释此为三。初引诸经示即。初引大经迦叶品云。众生即是佛。何以故。若离众生不得三菩提故。如来性品。我者即是如来藏义。一切众生悉有佛性。即是我义。如是我义。从本已来。常为无量烦恼所覆。是故众生不能得见。如贫女人舍内多有真金之藏。家人大小无有知者。时有异人善知方便。乃至即于其家掘出金藏。又云。譬如王家有大力士。其人眉间有金刚珠。与余力士捔力相扑。而彼力士以头触之。其额上珠寻没肤中。都不自知是珠所在。其处有疮。即命良医。欲自疗治。乃至时医执镜以照其面。珠在镜中明了显现等。如来藏经十喻者。彼经十文。一法。九喻。一是所喻。九是能喻。以所从能。故云十喻。一法者。经云。佛告金刚慧菩萨。我以佛眼观一切众生。贪嗔痴诸烦恼中。有如来智。如来眼。如来身。结加趺坐。俨然不动。善男子。一切众生虽在诸趣烦恼身中。有如来藏常无染污。德相具足如我无异。于此文后。即举九事以喻其法。各有长行重颂。一萎华佛身喻。二岩蜂淳蜜喻。三糠绘粳米喻。四粪秽真金喻。五贫家宝藏喻。六庵罗内实喻。七弊衣金像喻。八贫女贵胎喻。九焦模铸像喻。弊帛者。经偈云。譬如持金像行诣于他国。裹以秽弊物。弃之在旷野。天眼见之者。即以告众人去秽现真像。一切大欢喜。我天眼亦尔。观彼众生类。恶业烦恼缠生厄备众苦。又见彼众生无明尘垢中。如来性不动无能毁坏者。土模者。经偈云。譬如大冶铸无量真金像。愚者自外观但见焦黑土。铸师量已冷。开模令质现。众秽既已除。相好划然显。我以佛眼观。众生类如是。烦恼淤泥中。皆有如来性。闇室下。复出涅槃经云。如闇室中井。及种种宝。人亦知有。闇故不见。有善方便。然大明灯照之得见。是人终不生念是水及宝本无今有。涅槃亦尔。本自有之。非适今也。大智如来。以善方便。然智慧灯。令诸菩萨得见涅槃。今文但引闇井具宝。以证理即。不取人亦知有等文。诸喻皆尔。须知诸喻。理兼圆别。若言三障定覆佛性破障方显。此犹属别。若全性成障。障即佛性。以不思议德。障消者则诸喻皆圆。方是今文理即之喻。故如来藏喻止观显别。今文显圆。次净名皆如。语尚涉通。今须圆解。次宝箧下卷胜志菩萨。向佛说偈。己界及法界。众生界同等。己界即心法。法界即佛法。佛以法界而为体故。对众生界即成三法。心生在因佛法在果。三无差别故云一界无别界也。二此是下。就本觉明佛。前引诸经。虽云即佛。犹未的示觉了之相。且指三障体全是理。今示此理。当处照明。名为本觉。佛义成也。此自分二初正示。言此是者。指上大经众生即佛。诸喻宝物。净名皆如。宝箧法界。此等皆是本性圆智。非三般若融即微妙。智不名圆。知一切法一一含受一切诸法。全法是智。全智是法。待对斯绝名圆觉诸法。诸法乃是生佛依正。三际十方。此等时处。既全是智。何有一处一物一尘。体不明了。然此明了非心意识所能及也。故起信论本觉义云。心体离念无所不遍。等虚空界本性明了。既其离念安以情求所谓不思议智照等也。勿认六道漏心三乘证智而为本觉明了之相。妙觉之觉方是理佛。全修在性斯之谓欤。二虽五下遮情。情执者云。诸有业缚无明惑暗。那言众生即是佛邪。故遮之曰。虽业至无间。而皆当体是三解脱。虽见思昏倒而本觉理未始不存惑业。全是性德缘了佛性。岂可更坏理佛。刀不自伤故。二斯下。对四事辩理。世间常住者。即十法界三十世间。一一皆住真如法位。法位常故。世相亦常。然世本代谢而言常者。以一切法即真实性。性不改故。故名为常。若谓迁流不得言常。斯谓情见。良以生法即性故。常住异灭法即性故。常即性之常。非常无常不可思议。言偏意圆。故可得云一生一灭无非中道。唯生唯住。唯异唯灭。法华迹门显所证云。世间相常住。于道场知已。本门乃云。如来如实知见三界之相。非如非异。故知世间即是三界常住。岂乖非如非异。本迹虽殊不思议一也。此理秘妙。佛能明见故。故云灼然。今我智者成秘妙观。虽是肉眼而名佛眼。能见秘藏亦云灼然。故妙乐云。显露彰灼称为真秘真秘之理即世相常。世相常故众生即佛。此理妙故。有佛教化不益一毫。空过无佛不损一毫。五即得之何足为高理即失之未始暂下。对此四事示理佛也二如斯下。名字即。此至究竟皆修德也。须论损益及以高下。言名字即佛者。修德之始。闻前理性能诠名也。然有收简。收则耳历法音。不门明昧异全不闻。俱在此位。简则未得圆闻。齐别内凡。尚属理即。以七方便未解妙名。岂知即佛。此自分二。初带喻示名字二。初不闻之失。理虽是佛全体在迷。佛出不闻经名绝听。此乃却指但理之失也。二若佛下。闻名之得。六即辩佛。故今名字唯约三宝及十号也。无明长夜佛出令晓。阐本智日乃识三宝照世光明。生死巨关无佛长锁。佛能于此开甘露门。令知十号是常住味。此光此味。乃从众生心性流出。还使众生解此光味即本性佛。因说等者。却指贫女舍宝喻也。初既不知家有宝藏。唯受贫苦。因示得知。宝虽未掘预生适悦。此等法喻皆示于名有识知义。能知所知即名字佛。二故须下。引人明即佛。梵云须达多。此云善施。亦曰给孤独涅槃二十七云。舍卫有长者。名须达多。为儿娉妇。诣王舍城。宿珊坛那舍。见彼长者中夜而起。庄严舍宅。乃问。当请摩伽陀王耶。答云。请佛。须达初闻身毛皆竖。复问。今在何处。答曰。在迦兰陀精舍。须达思念欲见。于时忽见光明如昼。寻道而出。城门自开。见佛闻法证须陀洹。疏云。巨关。即城门也。今明毛竖。即惊觉也。闻名生觉即本性佛。若论大经追叙昔事。方证初果。验闻名时。未能解了觉即本性。及前科中三宝十号。亦涉于小。今约跨节取意而谈。五时示现身相名号说法度人。乃至闻者一念微解。一一皆是全性起修。当处无非本性佛法。如前一化增数诸行。皆会圆常。四教四门。唯诠一理。不从跨节焉消彼文。况文出涅槃。部已开会。故约惊觉示名字佛

观无量寿佛经疏妙宗钞卷第一观无量寿佛经疏妙宗钞卷第二

        宋四明沙门知礼述

三观行即。此中观法。异常坐等直观心性。故托他佛而为所缘。然是大乘知心作佛佛即是心。其观未成为尘所动。始自圆闻观佛妙境。至识次位勤行五悔。若未发品。此等行人皆属名字。故知名字其位甚长。今明对尘即成佛观。其中念念觉知之心。名观行佛此自分。二初观妙色即真法。以大小相皆悉周遍。故此色身即是真法。又二。初约一佛二。初示始习即心观相。此是名字升进之位。不独解名能修观故。但未入品。非观行位。观佛相者。若此经中八万相好。非羸劣想而可系缘。故须初心先观落日。渐观地树及以座像。观既深着方观胜身。今依般舟初心先观千辐轮相。次第逆想至肉髻。三十二种是下品相。复从足起。可作始行系心之境。不须更以落日为缘。若相若好。皆依于身。身唯金色。故云如铸金像。此之色相虽从心想如在目前。故云与眼作对。言妙色者。即是不可思议色也。所以者何。由此行人已圆闻故知色唯心。知心唯色。五根所对尚体唯心。况想成色岂在心外。此色非色非色非非色。而能双照。色与非色。既离情想故名妙色。非由三观莫见妙色。非由妙色莫成三观。境观相资尘念靡间。方能得入观行位也。二开眼下。明观成称性。周遍。妙心作相妙相发心。心心不休成观入品。尘缘莫动佛常现前。闭目了然开眼不失。在明见佛处暗不忘。性无间然。佛岂暂阙。一一相海庄严法身。相为大相。好为小相。观大发小名为流出。劫水虽大止剂二禅。佛相遍周称于法界。且以分喻显于周遍。观行佛眼名曰周眸。此眼所观何处非佛。问金光明玄义。观于三道显金光明。似位尚云闭目则见。开目则失。今观三身位在观行。因何开闭俱得见邪。答彼明性德金光明理。此理初住方任运见。故于似位犹论得失。今带事定。托彼应色。观于三身。以其应相凡心可见故理三身虽乃未显。不妨应色先与定合。故令开闭皆见佛身。如以三观观彼落日。三观未成而能开闭。皆见于日。故虽事理一念同修。而理难事易。事易故先现。理难故后发。故般舟三昧。以三十二相为事境。以即空假中为理观。境观虽乃同时而修。境必先成。托境进观。藉观显境。更进更显。从凡入圣。故知彼就趣真无住。对似爱顶堕。为开闭得失。此就应色。得成观行。为开闭俱见。不知事理难易浅深。此相违文何能销释。二念一下。等诸佛二。初约一佛等诸佛。为成观故不可散缘。故以弥陀一佛为境。虽观一佛何异十方。虽照现今何殊过未。此彰一切不离弥陀。良以弥陀是无量之一。故能等于一中无量。二一身下。明诸佛同三法。一佛等彼一切佛者。以由佛佛同得三法。身是法身。智慧是般若。十力四无所畏是解脱。亦是三身三涅槃等。身智言一者。显于诸佛法报不别。应用亦同。故力无畏结云亦然。同身智一也。菩萨因中分破无明。分同妙觉所证三法。无明破尽。则究竟同诸佛三法。诸佛三法既其不二。是故弥陀三法不少。一切诸佛三法不多。故言等也。二念色下。念三身以结。示色是应身。通于胜劣及他受用。法门是报身。以诸法门。聚而为身。即八万四千陀罗尼为发。第一义谛为髻。种智为头。慈悲为眼。无漏为鼻。四辩为口。四十不共为齿。二智为手。如来藏为复。三三昧为腰。定慧为足等。此诸法门。若从所证名为法身。今从能证名为报身。自受用也实相是法身。非不具于一切法门及诸色相。让于能证及垂应故。今是所证及以能垂。但名实相前论观法文中。但言相好周遍。次文乃约三法论等。至今结示云念三身。应知法门及以实相。不离色身举一即三。全三是一。法尔相即非纵非横。是故此经第九佛观。经示相好。疏名真法。不知圆观。此名莫消。若观佛身。不涉后二。便同小外。何预妙宗。须知此文。是结前观色相周遍已具三身。二常运下。明即佛。观行位人一切时处。念佛三观。常得现前。故云无不念时言念念皆觉者。示即佛义。虽是始觉即同本觉。非全本觉观不名中。亦得义论始本一合。虽非究竟及真似合。而亦得是观行合也。若论即字。广雅训合。荆溪云依训乃成二物相合。于理犹疏。今以义求其体不二。方名为即。然其始觉与本觉合。虽名为合非二物合。正是荆溪体不二义。良以始本觉体是一。故知六即得名六合。理即乃以逆修之觉与本觉合。五皆顺觉与本觉合。六合无非体不二也。荆溪有时亦以合名明不二体。故不二门云。复由缘了与性一合。方能称性施设万端缘了是始性岂非本。修性体一复名为合。四相似即。今既释佛。乃似本觉。良以此位始觉之功。尚伏无明。全未破故。非真本觉。唯得名为相似即佛。若四十一位分破无明。故得分分是真本觉。名分真佛。至极果位无明既尽。本觉全彰。故得名为究竟是佛。即究竟本觉。亦究竟始觉。亦是究竟始本一合。亦是究竟始本俱忘。例前五即皆有四义。问名字等五。以始对本。论合及忘四义稍可。唯初理即。既全在迷。岂有始觉及二义邪。答理虽全迷而具三因及五佛性。缘了二性岂非本有修因始觉果。及果果二种佛性。岂非理中究竟始觉。理若不具此等始觉。名字等五。便须别修。复何得云全修在性。但有即名无即义也。自非山教圆位徒施今当相似位中四义。文自分二。初标释二。初约三身明即佛。前观行位。常用三观念佛三身。观觉虽成似觉未发。加功不已。今本觉三身相似而发。与始觉三观相似相应。应是合义合而不忘。非妙觉也。问于一本觉约何要义。显示三身令人可见。答本觉诸法即空假中。觉诸法假。即相好身。觉诸法空。即法门身。觉诸法中。即实相身。如此论之其义宛尔。更于一觉约寂照说。照而常寂自在神通。即相好身。寂而常照清净智慧。即法门身。非寂非照而寂而照。即实相身。此之二三皆非纵横不可思议。乃是寂觉照觉。双遮照觉全本成始。即是相应及俱忘义。此位三身即佛义显。是故文中不特言觉示于即佛。二相似下。约四喻明相似。行人本觉寂照及双相似而发。成相似位三种之觉。此觉似真若鋀若瓜。比金比瓠。此之二物喻始似本。如将至火先觉暖气。行欲近海预睹平相。此之二事喻于相似近乎分真。前二约法论似。后二约位论似。二水性下。劝证二。初约事劝。本觉清凉其犹冷水。似觉饮之知消烦热。名字之人如热渴者。须三观功掘无明地方得真似清凉之水。徒闻之水不施观功。又无事行取水具物。守渴而终至极热处。二略举下。引文证相似相应功德之相。如彼法华六根清净。文虽稍广其相显然。行者易知故得名要。六根同有五种似发。所谓肉眼天眼慧眼法眼佛眼。肉耳天耳慧法佛耳。乃至意根亦有五相。此之六五。即三相应肉天法六。即相好身相似相应。慧六佛六。即法门实相相似相应。以五眼等是不次第相似发故。可以对于圆三身也。行者能于三观。观佛六根三德。不久相应。五分证即。即心观佛。托境显性。虽得相似尚属缘修。今则亲证属于真修。分破无明。起信论中称随分觉。寂照双融。本觉真佛分分而显。从所显说。名为分真。从能显言。名为分证。四十一位皆受此名。自分二。初明初住。一代教中圆位显者。唯起信论及华严经。经说三身初住顿得。论明八相初住能垂。若此位不论破无明惑。安得如此上冥下应。故知十向方伏无明。初住但能断于见惑。此等经论是渐次教。不可与其华严起信顿修顿证菩萨一槩。是故今立诠中道教论次不次。分于别圆。今就彼经明分证佛。此文分二。初约发心明即佛二。初约三法明发就初住名示。即佛相。位名发心。发本觉心也。常寂常照寂照双融。是本圆觉。即一而三。不发而发。故成三发皆言一切者。法界无外摄法不遗。诸佛众生色心依正同一觉体。全体为缘全体为了。全体为正。缘因发故。了正亦发。了因发故缘正亦发。正因发故。缘了亦发。盖三法圆融。发则俱发。缘发名功德。能资成故。了发名智慧能观照故。正发名境界。是真性故。是所显故。问三德既是一本觉性。由证显发。今云一是所显境界。二名能显功德智慧。若是能显。二则是修。何得名证本觉三德。答其理如是。方不思议。所以者何。三虽性具缘了是修。二虽是修。非适今有。二若非修三法则横。二若非性三法则纵。故释签明三点不纵横云。虽一点在上。不同点水之纵。三德亦尔虽法身本有。不同别教为惑所覆。虽二点在下。不同烈火之横。三德亦尔虽二德修成。不同别人理体具足而不相收(文毕)辄出其意。别教法身为惑覆者。良由不知本觉之性具染恶德是故染恶非二德也。故别惑通惑业识事识烦恼结业三乘六道。变易分段此等一切迷中二法。非二佛性既非佛性。乃成定有能覆之惑。是故但有法身本觉。随于染缘作上一切迷中之法。以是名曰为惑所覆。应知覆义不同泥土覆彼顽石。既覆但中佛性之理。如淳善人。一切恶事非本所能。为恶人逼令作众恶。故说善人为恶所覆应须还用随染觉性。别缘真谛及以俗中。次第别修空假缘了或中边缘了种种二因。或初缘次了。或初了次缘次第翻破一切迷法。显于法身本觉之性。是故覆理成于纵义。圆人不尔。以知本觉具染恶性。体染恶修即二佛性故通别惑事业识等一切迷法。当处即是缘了佛性。岂有佛性更覆佛性。如君子不器善恶俱能。或同恶人作诸恶事。则彰己能何覆之有。故即二迷以为缘了。显发于正。缘了二德体迷而得。义当所发。元是修德复当能显。虽分修性皆本具故。义不成纵言别人理体具足而不相收者。亦为不知本觉之性具染恶德。不能全性起染恶修。乃成理体横具三法。言不相收者。以其三法定俱在性皆是所发。犹如三人各称帝王。何能相摄。是故不知性中三法。二是修者二乃成横。圆人不然。元知本觉具染恶性。故使迷中一切染恶。当处即是缘了佛性。以此二修显于一性。如一主二臣。主摄于臣臣归于主。三德相收亦复如是。今初住位所发三法。皆性具故发则俱发。故云不前不后以此三法。二为能显一是所显。修性宛尔。故云亦不一时不一时故非横。不前后故非纵不纵不横不思议发。是故名为初发心住。二三智下。约三身明佛。前以正助二修。对性明圆发相。今约报智证法起应。报应二修对法一性论分证佛。从智证法。从法起应。即非一时。三身顿得故非前后。不纵不横复见于此。从始圆修一心三观。今圆三智一心中得。即以此智证得法身。智性即色三一体融名妙色身。此身湛寂如鉴无情。形对像生山毫靡间。名应一切。三身三德体离纵横。今始发明名开秘藏。入理般若名为住此住无住住秘藏中。二以普下。约被物明佛用二初总示三轮。色像即身轮。一音即口轮。等悦即意轮。身名神通轮口名正教轮。意名记心轮。妙观察智也。轮者转义。亦能摧碾。己心证法转入他心。能摧碾他一切业惑。此三业应有十界相。皆是初住分得佛用。二应以下。别示十界。上明能用种种三业不出十界。今分别之。先明佛三。况出九界。佛应三土。且说同居。化有始终。须彰八相。大机所见八相难思。若应小乘八种皆劣。大示出没如水之波。全法界身八皆胜妙。小乘生灭体是无常。如火烧薪终归灰断。故两八相不分而分。胜劣宛尔。此等皆是果人法则。名佛威仪。初住能为名之曰具。威仪属身。音声属口。方便是意。应以佛界而得度者。即为现此三轮相也。佛相至高尚能迹示以佛况九。现之不难。既现九界各具三业然非直现十界而已。于一一身。复现十界重重无尽。以得普现诸身三昧故也。二初住下。况后位。初住始破一品无明。分证三身。垂形十界。其相尚尔。况二三住。况第十住行。向登地至于等觉。破惑转深。德用转广。宁以心口而思说邪。良由位位始觉本觉一合俱忘。致使体用高广若此。六究竟即。一切诸法无不是佛。迷故不知。故圆实教不顺迷情。直示一切皆是佛法。世间相常众生是佛。不禀教者。但有理是全不知是。若闻此教。于名知是。若入五品于观知是。入十信者相似知是。四十一位分真知是。今登极果。究竟证知一切诸法皆是佛法。此自分二。初据位直明。等觉已名满足方便地菩萨究竟地。始觉道穷本觉理极。本始既泯无以名焉。强称妙觉。大品般若四十二字。字字互具诸字功德。南岳用对圆顿教中四十二位。初住阿字中四十字对至等觉。最后茶字当于妙觉。虽一一位皆能遍具诸位功德。然是分具。今此极位。乃究竟具诸位功德。故引法华唯我释迦与一切佛。乃能究尽诸法之权。实相之实。达无明底到诸法边。名边际智。不思议权智也。今已究竟。故名为满。于种种法证本圆觉。不思议实智也。此觉极满名为顿圆。复用第七无上士号。显智断极。有惑可断名有上士。等觉位也。无惑可断名无上士。即是妙觉。断德究竟名大涅槃。更有过者。名有上士。亦等觉也。更无过者。名无上士。即是妙觉。智德究竟名大菩提。二约喻称叹。用彼大经月爱之喻。十五日月。对四十二圆因果位。皆智光增惑暗减灭。故初之三日对住行向三十位也。从初四日至十三日。对十地位。十四日以对等觉。十五日对妙觉位。此乃合前三十。开后十地。若三十三天同服甘露。对四十二位皆证常理。开前三十位对三十天。合后十地用对一天。等觉对一。妙觉极位次对释天。若四十二字。字字互具四十一字。对于圆证四十二位。位位相收则前后俱开。若开示悟入佛之知见。对圆真因四十位者。前后俱合也。今十五日月光既满。即智德圆。暗无不尽即断德极。故大师云。此之增减日日有之。此之智断位位有之。故不更用后十五日邪光减也。复以众星对诸因人。月喻果佛。最上等言。皆是称叹究竟佛也。二佛有下。以例诸号明难说。圆极之果所有名字。一一不虚究竟成就。盖其所召皆真极故。以望真因尚带虚设。妄未尽故。七种方便一切凡夫。悉是虚名一无实义。故大经云。世谛但有名无实义。第一义谛有名有实义。佛是究竟第一义故。又复应知非别有法。名为究竟第一义谛。毗卢遮那遍一切处。一切诸法皆是佛法。是则世间及出世间二死五住。至鞞荔多蠢动蜎蜚五无间等。若因若果无非圆极第一义谛。故此诸名皆实不虚。悉是究竟佛之异名。是故称为佛有无量德。应有无量名。今唯举佛一名当之。故诸大乘明于佛号或增或减。皆是四悉赴彼物机。今于通号十名之中。举第九佛也。净名经云。正遍知如来及佛。此三句义。大千众生皆如阿难多闻第一。以劫之寿不能尽受。随其宜乐举此三名以少况多。功德无尽

二释说字二。初牒释。悦是畅悦。怀是心怀。若就此经即是如来久修久证念佛三昧。蕴之在怀。今机扣发。说之乃畅昔之所怀。二即十下示相。据今之说正在念佛。次文委示。今不预陈。故且通涂明其说相文二。初明所说法相。十二部经总明说相。谓或作长行说。或作重颂说。或作未曾有说。或作无问自说说等。若八万法藏乃具示所说种种法门。合云四千。且举大数。然应了知有多八万。且约四谛示诸八万。若言八万法藏。即苦谛八万尘劳。即集谛。八万对治门。八万三昧门。八万陀罗尼。皆道谛。八万波罗蜜。即灭谛。今虽示一。义以兼三。以法藏名是蕴聚义。判属苦谛。复由蕴义兼得三谛。盖四名言不离阴故。如俱舍云。牟尼说法蕴。数有八十千。彼体语或名。是色行蕴摄。故十二八万俱通小衍。或云小乘唯有九部。大则十二。或云小有十二。大唯九部。或云大小皆有十二。六度四等虽在大乘。亦通三藏事度菩萨。然其名数四教皆同。须就所诠真中二理。定其权实。复论四种能趣观行。用简偏圆。使宝渚化城迂直不滥。二又于下。明能说善巧二。初于一法一门明四悉。上之所列八万等法。既通四教。即是生灭八万无生八万。无量八万。无作八万。如生灭八万。趣举一法。须开四门。四门假人同皆叵得。若其实法四义不同。约有门说。念念无常如灯焰焰。约空门说。三假浮虚犹如云雾。双亦门说。二相从容。双非门说。二相俱舍。四中一门机生熟故。四悉被之为未种者。作世界说。令其乐欲赞用受行。为已种者用中二悉。善根未发作为人说。令起宿善信戒进念。恶未破者。必对治说。令其三毒豁尔冰消。为已熟者。第一义说令得契真革凡成圣。佛智鉴机。说之必中。知不入理令得三益。知不破恶令得二益。无善可发作世界说。但生欢喜。若全无益佛则不说。二若一下。例诸法诸门示四悉。上明一门被机四悉。余之三门被机亦尔。八万中一四门四悉被机既尔。其余诸法四门四悉被机亦然。一教八万门悉既然。三教亦尔。八万法藏。例于尘劳及对治门三昧总持波罗蜜等。一一八万。法法四教。教教四门。门门四悉。其十二部六度四等。准此可知。以此略明佛说之相。三释观字即所说也。上十二部八万等法。岂非所说。然是泛举显于能说。下无量寿及今观字。的是此经所说义也释观分二。初牒释双标。牒起观字。以观释之。乃用观法观于胜境若非观法将何观之。撮经所诠立兹题目。经明十六以为能观。今释题名唯论三观。经文是别。题是总名。总总于别。别别于总。若也立题收文不尽。则不能应篇章之式。故知今立三观释观。乃是经文十六观体若就十六。各各示于三观相者。其文繁广。故于释题总而示之。令其修者以兹观法入十六门。则境境皆三。心心绝妙。四依被物言简意周。双标次第及以一心。二三观者。此乃以次显于不次。不融别观无以明圆。如止观中皆用思议显不思议。二从假下。据教双释二。初次第三观二。初列名指经。所列诸名释中自见。二今释下。释相结果。依前列名释三观相。第一空观而有二名。假是等者见思取境无而谓有。虚假凡俗知虚名谛。二空之理是审实法。知实名谛。不究俗虚莫知真实。要须照假方得入空。是故名曰从假入空。又假是等者。迷世俗时谓虚是实。则二俱不谛。若悟俗虚必知真实。则二俱谛。故复得名二谛观也。此观等者。修观名因。证智名果。释论三智为易解故。分属三人。故以声闻对一切智。即空观果当于别教十住位也。第二假观。亦有二名。先斥住空堕二乘地。若修假观能成佛法。能益众生观空欲作入中方便。故于空智证而不住。三界惑着须荡令空。诸法因缘须究本末。见思重数如尘若沙。以大悲心遍观遍学。名为知病。诸法诸门破性破相。一一对治无不谙练。是名识药。随惑浅深知机生熟。神通骇动智辩宣扬。四悉当宜各令获益。如此授药方肯服行。皆由证空能入此假。故此观名从空入假。而言等者。前除见爱破假用空。今遣尘沙破空用假。于空于假各一破用。前后相望至今均等。故复名为平等观也。此观等者。若依释论以菩萨人对道种智。即假观果。位在十行。二空下。第三中观。初双标。初观空生死者。别人初心。信今知觉本是常住中道佛性。从教道故。名为但中。唯善唯净不具染恶。虽无染恶其性灵知。强觉忽生境界斯现。分别境相执着我人。不昧之知。邪思邪见。现前染恶既非性具。皆是随缘变造而有。是变造故非性本然。是故见思不即中道定须破故。即义不成。故不得云唯爱唯见唯色唯香。设欲修中能所不绝。故修空为正。中观为傍。何者。心既著有须别缘空破兹爱见。所观之空是二乘法。既非性具。乃是别修空非毕竟。是故空观但空生死。次观空涅槃者。生死之有虽已破除。心又着空。须别缘假破此空着。假是建立是菩萨法。非性具故。亦是别修。能荡空著名空涅槃。此之等者。前空生死见思惑忘。次空涅槃尘沙惑尽。二惑既尽心无偏着。是故得为双遮方便。初观等者。复因次第用于二观观其二谛。是故得为双照方便。方便立已圆观可修。于十向中即以所显中道佛性。而为能观中道之观。谛观不二惑智一如。三观圆融是无作行。故得自然入萨婆若。此观之果。名一切种智。位在初地。二一心三观。斯乃称性而观。绝待而照。盖一切法。性是法身般若解脱。如伊字三点。三非孤立。一一圆具。举一即三。乃以三德而为三谛。般若是真。解脱是俗。法身是中。德既不纵不横。谛乃绝思绝议。此是佛之所谛。今以此谛而为所观。谛既即一而三。观岂前后而照。故依妙谛以立观门。即于一心而修三观。此观观法能所双绝。况无量寿佛。本修此观成就三身。法报泯然真应融即。非兹妙观宁显妙身。化主若斯徒众亦尔。正报既妙依报岂粗。故十六境皆须妙观。此文为三。初依智论释二。初释相二。初约法释。三智即前次第所明一切智。道种智。一切种智。令易解故。分属三人。克性圆论三智实在一心中得。三智是果。三观是因。果在一心因岂前后。因果不二方曰圆修。故举智后即明三观。只一观而三观者。趣举一观即具三观。举一空观假中亦空。三观悉能荡相着故。举一假观中空亦假。三观皆有立法义故。举一中观空假亦中。三观当处皆绝待故。若知三观只在一心。则一一观任运具三也。观于一谛而三谛者。谛观名别其体不殊。全谛发观观还照谛。既无别体。以何义故立谛立观。若欲分别就三因说。性三为谛修三为观。性了是真。性缘是俗。正是中谛。不是了因非大真谛。俗中亦然。此之三谛方与三观体性不殊。顽空为真与观体别。俗中亦尔。三观互具者。盖性三本融。全性成修此之谓矣。二类如下引类释。以有为法类无为性。一刹那心初生即灭。两间名住。不无三相而在一心。三相无常尚居促念。三观称性无作无生。具于一心其义何爽。二此观下结果。不明智果观法无归。故示观成惑灭理显。豁然妙证三种智慧。实在一心。或具论三智。或从胜说。只但名为一切种智。寂灭等者论自解释。一切种智双寂二边无明之相。双照二谛种种行类。始自初心圆修三观。妙观中道。念念双忘。而即二边念念双照。一心二观。法尔如然。今入分真本智显发。全由始行亡照之功。二引中论证。论云。因缘所生法。我说即是空。亦名为假名。亦名中道义。论通衍三。今证圆观。观所对法岂有不从因缘生者。今修圆观必先解知能生因缘及所生法。皆不思议。方于此境观空假中。又须了知妙谛妙观。悉是能观因缘所生阴等诸境。皆是所观。前且直云观于一谛而三观。须知于阴等境观一谛等也。勿守略文。须寻观义。又不可谓先解所观不思议故。便不得言阴及无明。何者本说因缘及所生法。是不思议。若非无明何名因缘。若非阴等何名所生。有人见释心法妙云。心法在因约迷以说。佛法在果约悟以说。辄便难云。心法称妙何得是迷。良由此人不知所以解迷是妙。方曰圆人。如论苦集称为无作。及十二因缘名不思议。岂不得云不思议无明。人虽解妙法体是迷。不知理即一向在迷。妙觉一向属解。中间四位迷解共俱。名字即人若不观迷。何处用观。等觉之位若不破迷宁登妙觉。以上上智断下下惑。惑非迷邪。人之多僻其类实繁。释论三智已如前释。三此观下。约妙结示。初一句总叹微妙。次二句约三一叹妙。一不定一。一即是三。三不定三。三即是一。释论以不决定解不可思议。次三句对十六叹妙。上明一三融即总一妙观也。即此一观遍入诸门。名一观一切观。虽入诸门只一妙观。名一切观一观。观若定一。莫入多门。观若定多。不可为一。实不可以一多思议。故云非一非一切。后二句结示。虽非一多能摄一切。是故十六无非妙观。四释无量寿。正示三观所观境也。前明三观。且以三德。及以三因。而为谛境。盖示所观融即用显能观绝妙须知性中三德。体是诸佛三身。即此三德三身。为我一心三观。若不然者则观外有佛。境不即心。何名圆宗绝待之观。亦阿弥陀三身以为法身。我之三观以为般若。观成见佛即是解脱。举一具三。如新伊字。观佛既尔。观诸依正理非异涂。此意不明非今观佛。释此为二。初牒名从梵。无量寿者已是华言。天竺梵语称阿弥陀。二佛本下。从真出俗二。初约本无三。标无量寿。乃是无量而为其量。是则题中已言寿量。寿量依身乃成三义。故约三义而论有无。所言佛者。究竟觉也。理智既极始本两忘。无相无名不可说示。宁得立其身及寿量。二随顺下。随世俱立二。初列三身各三。据究竟觉第一义谛。则不可言身及寿量。为度生故。乃顺世间立名立相。故说三身及三寿量。是则真佛无三。随世故有。然须了知有无之意。言佛本无身无寿量者。但无有相随情之三。非无性具征妙身等。是故真佛究竟一切净秽法门。若一向无何异小乘所诠真理。故真无俗有。真有俗无。皆是悉檀不可偏执。今文意者。盖立三身释无量寿。恐执定有。是故先言佛本无三。随世说有。得此意已。分别三身三寿三量。则无滞也。二法身下。释三身三义二。初约义分别。二据理融即。以有次文尽理融即故。今且约修二性一。一涂分别。初自为三。初法身二初别释三。初法身者。师轨释法。舍通从别。通则生佛俱轨法性。然其九界虽轨而违。如人依师不顺师教。唯有诸佛从初发心。轨法而修。今能究竟冥合法性。故大经云。诸佛所师。所谓法也。以法常故。诸佛亦常顺法性故名法为师。实非所师。与能体别。故即所师法而为其身。虽名为身已出五阴。故非色质。及非心智。色是初阴。心智即四阴。既其非阴亦非入界故非三科任持摄属。此则已简分段变易。以示生死阴等摄故。亦可色质简应心智简报。三科简因。既非此等何以状名。为物机故。强指法性名为法身。二法性下。寿连持之寿。亲依命根。今法性寿非识息暖报得命根。亦非三事连持之寿。为物显德。乃指法性非八相迁。非九世易。强名为寿。三此寿下量。寿之分量合论长短及以延促。今法性寿实无此等分量之相。此则通简。若别简者长是报佛。短是众生。能延能促即是应身。非此等量为成观故。强指法寿同虚空量二此即下。总示。法性三义。非阴聚身。非报得寿。非长短量。不可思议强于法性说身说寿说量故也。二报身二。初称法有报二。初引经。报即酬报也。修行是因。感于妙报而酬因也。法华证智德经云。慧光照无量久修业所得。大般涅槃证断德也。此二果德酬答修因。是故名报。二如如下释相感报之时。其相何似。故以一法二喻显之。如名不异。所观差别。不名如境。智外有境不名如智。各二如者。境如如智智如如境。此之境智故得应冥。智慧名通。故以果觉菩提简之。即是无上菩提之智。与法性境相应相冥。先举函盖喻其相应。恐谓函盖虽际畔相当。终存两相。故重举水乳以喻相冥。令知始本同是觉性。其体泯然。正同水乳。则显境外无智。智外无境。水乳可见。二法身下。于报立三。即身寿量也。三中一一言法身者。报智所冥。离法无报故。初身言非身者。非应佛有分齐身。非不身者非报佛无分齐身。又非身则非有。非不身则非空。中道法身乃本觉体始觉冥此能冥亦忘。为成观故。强名报智。二法寿下。明寿言非寿者。非应同连持之寿。非不寿者。非报智不连持寿。双非二边冥中法体。强名之意。同前身也三法量下。明量。非应有量非报无量。及非二边义同身寿。三应身三。初明应物有三。初身。如谷答响。大小随声。如鉴现形端丑在质。应万物感现胜劣身。二应同下寿。身既同物寿岂差机三应同下量。随宜长短示量无量。二智与下。明依二有应三。初法。智即报身。体即法身。此二冥合。应用无方。二如水下喻。真金上色须水银和。方能涂物。阙此一缘金无涂用。三功德下合。报智功德契会法身随有机处应无不往。三能为下明应遍三土二。初双明报应。二有量下。单示应身。初义者上所说报。但论冥法。即自受用也。今明垂应以他受用常住之应。对于生身无常之应。示二迹用。是故双明身等。身即生身。有分齐相。故名为身。非身是报。无分齐相。故曰非身。小般若云。佛说非身是名大身。大身者乃他受用身也。无分齐身其寿则常。故无量也。有分齐身寿。则无常。故有量也。此二应用乃依真中二理而住。机依事业二识而见。住理广如金光疏说。二识委在起信论。明论意要在事识见。则取色分齐。故名应佛。业识见则离分齐相。故是报身。此义至后释观佛观钞中辩之。行者须知常身无量。通应三土。无常有量但应同居。所以者何盖实报机分证论见他受用身。方便土人唯禀别圆。所见佛相虽小优降。然匪生身。悉是报佛。若同居土具四教机禀别圆者。能睹报佛。故法华明常在灵山。华严说法尽未来际。及诸大乘即于应相。见是法性尊特之身。故知常身遍应三土。若无常身唯应同居。逗藏通机生凡夫善也。次义分二。初明有量二义。上之所说自受用外。垂三土身。皆名为应。其他受用虽就对机名之为应。而是实因之所感克。复名为报。非是差别逗机之用。若论逐物随缘参差长短身寿量者。须就同居无常用说。故今别示应身之相。但于有量开出两量。而此两量依于事识但空见故。唯属无常。若依业识不空见者。即此无常全体是常。则常无常二用相即。二鸟双游也。若上二土机息应转。亦是无常。以非八相。故且言常。言七百等者。首楞严三昧经云。坚首菩萨问。佛寿几何。佛令往东方过三万二千佛土。于庄严国问照明庄严自在王佛彼佛答云。如释迦寿我亦如是。汝欲知者。我寿七百阿僧祇劫。坚首回此白佛。阿难云。彼佛乃是释迦异名。虽机胜见长。而七百犹可数故。亦是有量之量。若阿弥陀。人天莫数。故是有量之无量也。二应佛下。结应佛皆然。佛佛既皆三身圆证。应身被物。物寿长短。岂不随顺各示两量。故弥陀现长亦能现短。释迦现短亦能现长。故大论第三十六云。当知释迦文佛。更有清净国土如阿弥陀佛国。阿弥陀佛亦有不严净国如释迦文佛国。又第三十八云。此间阎浮恶故。释迦寿应短。余处好故佛寿应长。故涅槃二十二云。西方去此三十二河沙有无胜国。所有庄严如安乐世界。我于彼土出现于世。斯皆随逐物机也。二然下。据理融即。上辩三身。法是本有。报约修成。应论现往。其言似纵。须知报应二种之修性德本具。虽是性德修相宛然。全性起修全修在性。三一冥泯思说莫穷。不可等者。如上竖论显非并一。若言性具三身寿量显非别异。若作并别一异之解。即乖所诠圆常法体。即一而三故不横。即三而一故不纵。非纵非横不可思议。如此解者。乃会能诠玄妙之文也

观无量寿佛经疏妙宗钞卷第二观无量寿佛经疏妙宗钞卷第三

        宋四明沙门知礼述

二辩体前文解释能说所说。能观所观皆能诠名。今辩此名所诠之体。欲令学者因筌得鱼。寻名显体。寻名意在忘名。显体知无别体。此乃今师释名辩体之妙意也。复应了知。释名是总。总三法故。三章是别。别三法故。是故解释通别二名。无不义具教行理三。能说之佛。既具三身。所说观境各具于三。故云释名总于三法体章别在法身。宗用别当余二教相一章分别总别。今之辩体虽在一法一必具三。故明体礼体底体达三种之义。虽论三义但是法身中三。未明余二各三。故涅槃玄云。总唱秘藏故当其名。法身摄一切法。不纵不横以当其体。般若摄一切法如面三目。以当其宗。解脱摄一切法。如三点伊。以当其用。如此敷演。即是其教。非但经体义成。余义亦显(文毕)今出其意空假皆中故三属体假中皆空故三属宗。中空皆假故三属用。用是解脱特喻三点。点是文字故宗当般若。特喻三目。目能照明故。法身之三特泯纵横。彰离念故故知释名总于九法。辩体别在法身中三。然九不多。三不为少。方是圆教总别之义。此自分二。初牒起略示。名傍是宾。体正是主。名是假名体是实质。一切名下。皆有其质。二释论下。正释主质四。初据二文定体。诸法当处。不生不灭非有非空。无能无所。离言说相。离名字相。离心缘相。离此等相。名为实相无相之相也。谁人不具何法不然。若论证知唯有诸佛。故法华云。唯佛与佛乃能究尽诸法实相。禀圆说者初心即用佛智照境。故能信解诸法实相。既解实相。亦解诸法实性。实体实力。实作。实因。实缘。实果。实报。实本末究竟等。十法既实。即是实生实佛。实依实正。一色一香无非中道。一切诸法皆是佛法。既一切皆实。实外无余。复何得云余皆魔事。应知此说以理简情。若离心缘能所等相名为实相。介尔有相即为魔事。故别教已下至六道法。皆有能所心缘等相。魔能说之悉名魔事。故知一切皆魔一切皆佛。以情分别一切皆邪。离情分别一切皆正。今简情取理而为经体。应知实相全体照明。称为真心。亦名本觉。觉体遍故诸法皆实。若指其要。不离现前分别之念。念即本觉觉即经体。无别经体以为所诠。以此觉心观于依正。能所即绝待对斯忘。妙观之宗自兹而立。若不尔者。何须得体方立经宗。实相印者。印即符印亦信也。亦印定义。乃以所诠定其大小及以邪正。理符佛旨方可信从。小乘三印无常无我。此之二印印于生死。寂灭一印印于涅槃。小乘涅槃与生死异。故各印之。所诠符此则可信受。是小乘经非魔外说。大乘一印即一实相。二种生死三德涅槃。其体是一。究竟真实。义符于此可以信受。是大乘经非小非外。今据此经圆实为大。若从彼论三藏对衍。通别二教亦名一印。今不取二。唯圆实相名一印也。则能说之人。所观依正。四种净秽。五逆罪等。其性不二。以此一印为经正体。二无量下。为四章所归。无量功德等者。经用归也。经之力用亦名功德。力有灭恶之功。用有生善之德。灭一切恶生一切善。是故功德受无量名。如此功德共严实体。其犹帝王治乱育民。以此功德庄严圣躬。种种众行即经宗也。从理起行全理成修。如水为波波还归水。宗必会体。故云既趣。通则万行别观十六。故名众行。言说问答即经名也。能诠之名在于言说。言义幽奥。复须问答种种诠辩。以立经名而彰实体。问题目为名。何尝问答等邪。答名能诠体。一部言句皆能诠名。如法华经本迹十妙。以为其名但题是总。故就题释名。余之四义皆遍始终。故一经之名问答诠辩等。从后向前。示能归法。不别云教。兼在名中。自禀曰名。化他为教。自他虽异俱是能诠。故知四章同归一体。三譬众下。约二喻显尊。体于四章。犹如北辰众星环拱。又似东海万水潮宗。以其四章不暂离体。一切诸法无理不成。经体既然。安得不辩。四故以下。以一印结示。三书家下。具明体德。体对释名。但在一德。所谓法身。盖释名中。总示三法。利根虽解。钝者未明。何者以总示文带于宗用。体混其中。情想叵忘。本性难显。故于总后。别示灵源。永异四魔。诸法皆实。于彼圆伊。当上一点。绝思绝议。非用非宗。而其性融。一不定一。如伊一点。点不孤然。故直法身非法身。法身必具般若解脱。故别显体而谈三义。虽彰三德意在法身。以空假皆中。是故明三名为体德。中三。初约礼义明法身。书既以体而释于礼。故今以礼而释于体。礼别尊卑意崇君父。前明魔事已拣偏邪。今之臣子唯拣宗用。故君父体即是法身。诸佛所师万法朝会。体非修证理绝言思。欲使标心。强称贵极。斯是本觉非寂非照。亦是法性非深非广。第一义谛名为本性法身德也。寻能诠名欲识此体。体显故行。令修观者以此体德体彼依正。一一贵极成妙宗矣。二复次下。约底义明般若德空即中故。故般若德是诸法底。亦名本源渊府实际。若得中体则能穷畅也。论云。智度即实相般若。佛以观照般若于诸法中证此智体。故云穷底。然法性甚深无有底际。云穷底者。良由佛以无底际。智称性而证。义言穷底。七方便人以有底智。故不能到诸法源底。若圆教人。从名字即以信解心。穷智度底。五品观行穷底。十信相似穷底。四十一位分证穷底。唯佛与佛究竟穷底。以此底义辩于经体。则彰法性甚深第一义空。名般若德也。寻名识体体显。故行令修观者以此体德。穷彼依正。一一到底成妙宗矣。三复次下。约达义明解脱德。假即中故。故解脱德是一切法自在之体。复具一切真实名义。若识此体则于诸法通达自在。复于世间及出世间一切异名。一中解多多中解一。论云般若。亦实相般若。般若解脱名殊义一。故互举也。前明底义以观照般若穷实相底。今明达义以文字般若。说实相般若种种名也。七方便人迷此体故。于诸异名壅塞障碍。圆教行人名字体达。观行体达。相似体达。分真体达。论今举佛究竟体达。达义辩体。则彰法性无量如来藏义。名为真性解脱德也。令修观者以此体德达彼依正一一无壅成妙宗矣。三明宗。宗谓宗要。此经之要在修心妙观感于净土。心观即是一心三观。释名之中其相已委。感土之相。此文备论。今经妙宗。在此因果。且分为二。初标列。二有人下。随释二。初简示宗体。以其宗体一异之相。人多惑之。故须简示。文二。初简二。初简宗体一二。初牒言略斥。宗是因果。此属于事。体是一性。此属于理。虽不相舍。二义须分。定执是一。于义实乖。故云不用。二何者下。据义广破三。初约义破。宗是宗趣。趣果趣理。趣果必因。若趣理者。要须修观。观有明昧理有证不。皆成因果。故云宗既是二。体本是理。观虽趣理。理非明昧。因果依理。理非因果。如波依水波有千差。水常是一。故云体即不二。不谈诸法同一理性。则不名为大乘经体。故云二即非体。不论修证因果二法。则非佛经所证宗趣也。二如梁下。立喻破。屋空梁柱虽不相离。若谓是一则无虚实也。三宗体下举过结。二简宗体异二。初牒言破。虽破是一不可执异。若其定异则二物孤调。宗异于体则非全性而起成修。观行有作属于八倒。既不符理信非圆宗。故云邪倒无印体。若异宗则理不即事。事外之理其体不周。法性之体既异因果。则一切法皆成别有。二宗体下。举过结。二今言下示。今据普贤观经。验其宗体不定一异。故彼经云。大乘因者诸法实相是。大乘果者。诸法实相是。实相因果不异而异。非倒有印。此为妙宗。因果实相不一而一。非事外理此为妙体。岂同他立定一定异。他不闻此。偏说奈何。讲兹疏文。合知宗体。唯想事境。三观靡施。正同次家邪倒无印。可伤之甚。二今此下。就体明宗三。初依经直示。大乘之法。其要在心。心具易知。色具难解。故止观云。因通易识。果隔难知。故观自观他。皆修心观。今观净土须求于心。心能具故。心能造故。心垢土垢。心净土净。此犹通示。未是的论。的在一心。顿修三观。此观观于安养依正毕竟清净。名心观净。此观能令四佛土净。如是方为此经宗致。二四种下。约土广明三。初列四土。二各有下。立净秽。随文释义。教观俱沈。用义解文。解行可发。前释观字文中明示一心三观。又文频示心观为宗。至结宗云修心妙观能感净土。今消此文四土净秽。须准此观为四净因。若依诸文逐其四土。各论土因。何能通贯前后之文焉。令闻者证无生忍。初五浊轻为同居净者。此净甚通。须知别意。如戒善者。四教凡位。皆悉能令五浊轻薄。感同居净。而圆观轻浊。感同居净。依正最净。如此经说地观已去一一相状。比于余经修众善行。感安养土。其相天殊。言体析巧拙有余净秽相者。此土人众。净相亦宽。析观感秽。可在三藏。体观感净不专通人。衍门三教对三藏析。俱明体法。通但空体。别次第体。圆不次体。三人生彼俱感净相。圆人最净如观音疏。别向圆修。圆七信去。见彼依正。同于实报。住行及通。见相俱劣。今经妙体须异三人。故同居有余所明净相。文通意别。须以前后顿观之文。妙宗之语。解此通文令归的趣。言次第顿入实报净秽者。若论实证。此土唯有圆圣所居。别人初地证与圆同。称实感报。有何优降。今就教道十地不融。致所感土异于圆人。故约渐顿分于净秽。言分证究竟寂光净秽者。若就别人同圆证实。论寂光者唯约真因。对圆极果而分净秽。今论教道诠于极果。但断无明一十二品。寂光犹秽。圆知须断四十二品。名究竟净。仍要了知圆人始终。能用上品常寂光理。而为观体。今谈究竟意成行人修心妙观也。三娑下释名相。但释土名略指净秽。若的论四净能感之因。唯一圆观。已如向述。文四。初释同居。同居约人。净秽约土。谓凡人圣人。同居秽土也。净土亦有凡圣同居。二处凡圣凡即是实。圣通权实。始证为实。应来为权。次于泥洹者。泥洹涅槃梵音新旧尔。生安养者烦恼调伏近于涅槃。故名为次。皆正定聚者。三聚判也。若如此土博地凡夫。属邪定聚。发心修行未不退者。属不定聚。得不退者属正定聚。若生安养不论高下。五逆罪人临终十念得往生者。亦得不退。故云皆正定聚。起信论明初心生彼住正定。故小弥陀经云。生彼皆得阿鞞跋致同居净中。极乐当其上品土也。若依今经十六观门圆妙修者。通惑纵存生于彼土。常睹胜相。如此土华严诸大乘会机所见也。二释有余三。初约修断释名。九种行人合生彼土。藏二。通三。别住行二。既修空假皆方便道。别向圆信所修虽实。犹居似道。判属方便。不生分段。盖除四住。约此修断得名方便。断通余别故曰有余。二释论下。据经论释相。小乘虽云同入法性。而执法性体类虚空。子果若忘永无身土。大乘法性体具色心。子果若忘身土广大。释论以大。对破小乘界外无土。特云出界而有净土。小乘法性无有色心。是故特云受法性身。又引法华遇余佛者。即有余土佛也。此约灭后不值四依不生实信。自谓永灭而生有余。蒙佛开权即能决了。三就中下。明利钝净秽。彼土利钝。唯约大说。若在此土已修中观生彼则利。佛乃为说不次第法。若在此土未修中观。生彼则钝。佛乃为说次第法也。利根居上。故云指上。指下例此。利根所见同彼实报。故名为净。钝根所见相劣于上。故名为秽。以今利钝验前体析。唯圆名体。前三皆析。别向观中稍同圆体。三释实报三。初约因果释名。行真实道者。圆人初从。别人十向能于诸法。称实观中也。中理今开。即感妙报。色心不二。毛刹相容。纯是法身菩萨所居。尚简圆似。况七方便。收简语宽。宜善分别。二仁王下。依经论释相。仁王借别而名圆位。三贤十圣借别名也。住果报者名圆位也。三贤既与十圣同住果报。验是实报。不证中道宁住实报。故知名别。其义属圆。今取果报证实报土。问前明实报无有二乘。今那忽云迦叶起舞。答须知四土有横有竖。仍知横竖只在一处。如同居土趣尔一处。即是实报。若破无明转身入者。斯是法身同佛体用。称实妙报。则六根净人。亦莫能预。岂居二乘。此则一处竖论实报。若未破无明。即身见者。此乃诸佛乃大菩萨。为堪见者。加之令见实报土也。盖有机缘虽未破惑。已修中观。如华严会及诸座席杂类之机。感见身土难思者。是今引论文。乃方等中为弹斥故。示实报土胜妙五尘。令迦叶等顿忘少欲。起动舞戏。欲令声闻知大法妙。生欣慕心鄙弃小道。此等皆是一处横论实报土相。故八部二乘。机热皆见也。今以劣喻显于胜土。如其鬼趣居人境界。有人舍报堕彼趣者。即同彼类非他人共。有人即身能见彼趣。不妨他人同见其相。堕譬竖入实报土者。见譬横论实报土也。实报既尔。方便寂光横论同处。亦复如是。于同居处。论三土横竖。于方便处。论二土横竖。于实报处论一土横竖。至寂光处无横无竖。当处亦无。问论云。迦叶对于菩萨胜妙五欲。生爱之甚。不安起舞。至法华中。迦叶叙昔。闻菩萨法游戏神通。不生一念好乐之心。二事皆是菩萨之法。因何爱恶顿尔相乖。答应知二心。俱是别惑。爱于妙欲即同体思。恶于度生即界外尘沙。如不肖子但爱富贵而怠修学。例净名中斥身子云。结习未尽华则着身。畏生死故五欲得便。既畏生死乃指尘沙为结习耳。又引华严无量香云。即前所明同居。横示实报之相。三就中下。明渐顿净秽。四释寂光三。初克体立名。前三在事。故从居人修断因果。而立土名。此土属理。故从本体三德为名。问分证寂光三障未尽。何得一向就理立名。答障未尽边自属实报。今就因果分忘之处。名为中下常寂光土。二诸佛下。约能居示相。金光明云。如来游于无量甚深法性诸佛行处。过诸菩萨所行清净。无量即寂。甚深即光。法性即常。又普贤观云。释迦牟尼名毗卢遮那。此佛住处名常寂光。常波罗蜜所摄成处。我波罗蜜所安立处。乐波罗蜜离身心相处。净波罗蜜灭有相处。故知此土乃从四德究竟处立。以四彼岸显于三德。常我即法身。乐即解脱。净即般若。三德互具。一一论三。故法身等。各具四德。虽云三四。实非十二。学者知之。如是方名不纵不横秘密藏也。三分得下。明分满净秽。分得名秽。从证者论。常寂光名从极理立。三故以下。据义结示。释题观字。明圆三观。至今明宗。初云以心观净则佛土净。为经宗致。次即广明四土净秽。今乃结云。故以修心妙观能感净土。为经宗也。若其不用圆妙三观感四净土。则标结文全为无用。释题三观。为被何人。为何处用。若谓欲感实报寂光二种净土。须圆三观。若有余净但修体空。若同居净。只用事行不须三观者。此义不然。偏空体法种种事行。虽是二种净土之因。非是此经的示宗致。盖以此经本为韦提厌同居秽求同居净。故谈妙观观彼依正。那得辄云感同居净不须三观。三观若成粗垢先落。非有余净更生何处。岂有余净非妙观耶。须知正为生同居净。故说三观良由观妙。能破三惑。不独感于同居净土。随其惑断浅深之处。自然感得有余等三。如病须药。本为身安。求得仙方修合服之。不但身安兼能轻骨。身安可喻生同居净。轻骨可喻感上三土。只是。一药效乃深胜。如一妙观能净四土。起信论说。初心修行大乘正信。惧在此土不常值佛。信心退失。乃教求生极乐世界。令观彼佛真如法身。毕竟得生。住正定故。非圆三观宁照法身。那谓极乐因唯事善。四论用。宗是自行所修之法。用是利他所施之法。自行趣理故明妙观。化他摄机合通众善。他宜妙观。亦须教修自行助道。岂废众善。是故宗用法必齐等。但有自行化他之异耳。文二。初标名略示。力方有用。故言力用。力用何为。生善灭恶也。行者应知体宗用三。别明三法。乃从一性起于二修。体是法身所显性也。宗是般若能显智也。用是解脱所起力也。二虽修成须知本具。一虽是性全起成修。故非纵横不可思议。二德在性全指惑业。即是性具善恶二修。今体逆修既全性具。当处融妙乃化他德。故以此二为经宗用。用遍一切。非无恶用。以顺性故。生善灭恶。故染恶用称性用之最能灭恶。灭恶下。约义广释二。初约善恶具明。既施力用必成功德。是故一用而有四名。偏论灭恶。须施功力。偏论生善在于德用。斯是一往。若二往说力用功德。皆能灭恶。力用功德皆能生善。须知灭恶极至阿鼻。生善理合至于妙觉。方是圆经力用功德。二苦是下。就灭恶偏释二。初无恶不除。所言灭恶须灭恶因方除恶果。如果报修因二种行人。不除三毒众苦之本。纵暂免苦。终非永谢。今明化他修净土观。则令诸恶因果俱灭。惑纵未断生彼不起。断在不久。故能永灭恶因恶果。以要言之。此经力用灭五住因。除二死果。二是故下。从重别显。恶之重者莫过五逆。五逆是业。从于上品烦恼而起招无间苦。此经大力能灭此等极重三障。即生净土。若此三障性非三德。何能无间转为极乐。从极钝根且论十念生最下品。若从利根非不能生上之八品。以其五逆体是寂光。故可于此净四佛土。五判教相。教是圣人被下之言。相是相状。览而可别。上之四义皆是言教。谓诠名教。诠体诠宗诠用之教。若以其相而分别之。则令览者观之显了。故约五时二藏渐顿。而示其相文二。初正判所说教三。初约五时判二。初明教部。于大小乘。此属大乘。经中亦有频婆证小。然非此教正所被机。今从正为韦提希等宣净土观。尚非通别。岂是小乘。于五时中。是其第三方等时也。二赴机下。明广略且辩文相未论定散。二约二藏判。约人判法。此属菩萨。阿含等经虽说三乘。从多从正属声闻藏。大乘诸部虽有二乘。非部正意。是故判藏归菩萨也。三约渐顿。若约化仪论渐顿者。华严属顿三时皆渐。经在方等非化仪顿。今经顿者。乃于化法以圆为顿。故就韦提即身得忍。判教为顿。且无生忍位。别在初地。圆在初住。别教凡夫经无数劫。方至此位。唯有圆教。即生可入。若将结益判教偏圆最为明显。是故今文就其当机证位定之。是顿非渐。二题称下。傍简能说人。若四人说。如来印之亦得称经。今经始末皆出金口。故称佛说二分文下。随经显义。前取经中名等五义解释总题。总意虽彰别文难显。故须以句节定经文。令义显现总别虽异义无两涂。方知玄义释此经题。复了疏句不显他义分二。初总别科判。总科三分。别判六章。二初证下。随科解释三。初序分二。初正信序即是通序。大论云。佛将涅槃阿难问佛。一切经首。当安何语。佛答阿难。应云如是我闻一时佛在某处某国土与某大众。非独我法如是。三世诸佛经初亦然。故知六义即是通序。以诸经同故。亦名经前序。付嘱令安故。亦名经后序。结集者所置故。今言证信者。令闻者不疑故。论第四问曰。何不直说般若而言住王舍城。答说时方人。令人信故。言六句者。但以诠义究竟为句。如佛但一字亦名句也。二初标指六句。如是标于信者。释论第二问曰。诸佛经何故初称如是。答佛法大海。信为能入。智为能度。如是义者。即是信也。若人有信能入佛法。无信不入。不信者言是事不如是。信者言是事如是。我闻异外道。亲承于佛。故曰我闻。不同外道不禀佛也。一时辩息诤者。谓机熟受道之时。故无诤也。释论云。不应无一时。佛自言。一人出世。多人得乐。是者何人。佛世尊也。二如是下。随文释义六。初标信。信名忍乐。理当言善。方忍方乐。理当则不异名如。言善则无非曰是。四教言理皆称如是。而有浅深。若其三藏。唯就世俗。论于不异及以无非。通虽即理但在二谛。别教知中要先破二。唯圆初心。即了诸法一一中实当处皆如。称此而谈无非曰是。故圆望三教。皆不如是。此经所信。虽未开废而所被机。不从偏小。故但就圆明于如是。决定可信也。此句既尔。下之五句皆意在圆。故通序文通。其义亦通而其意别。今以别意释其通文。故此云也。二我闻下。异外道二。初正释。有在者。在于佛也。虽释我闻意多明闻。次文明我。二我者下。料拣二。初立难。我者自在及主宰义。凡夫小乘。于人法中而着于我。今传圆观合顺二空。何得言我。二随俗下。通难二。初直通。毕竟空中虽我叵得。此空即俗。诸我宛然。今且约三。分别我相。横计主宰名为见我。俱生主宰名为慢我。随世流布即名字我。阿难尊者至结集时。尚破同体见慢之我。岂有界内二种我邪。为传化故。故顺妙俗立名字我。二如人下。举譬。知无我理。如用金钱。随俗立我如易铜钱及草木等。三一者下。辩息诤二。初示论释二。初释一。先约真破。次随俗立。在文可见。释论广破一异者。论云。若一与物一。一与物异。二俱有过。问曰。若一有何过。答曰。若一。瓶是一义。在在有一。处处皆应是瓶。则无衣等诸物。一中之过既然二中之过云何。答若一与瓶异。瓶则非一。若瓶与一异。一则非瓶。若瓶与一合。瓶名一者。今一与瓶合。何不名一为瓶。是故不得言瓶异。一彼文极广盖瓶显可见。故以瓶喻时也。一则是数。时则是体。若于数体定执一异。则诸惑纷然。能离执者则于法解脱。斯乃寄于数体一文。示离着观令于诸法皆袪定计。即知六事及以诸文皆须离于一异之见也。二释时。此土诠召。但直云时。天竺二音。若云迦罗即是实时。云三摩邪即是假时。亦如此间心有二称。言智是解心。言识是迷心。故令依智不依识也。外人执时以为实因。是故对彼云三摩邪。显时是假。若内弟子依时而食。护明相等。乃言迦罗显时是实。言迦罗短时三摩邪长时者。若据论文。短时长时。并名三摩邪也。谓方时离合一异长短等名字。出凡人着心。是故长短。皆假无实。今以短长分对二名者。恐是大师依建立门。巧会论意。以依佛制时则生死时短。外道执时则生死时长。既回论文必有此意。二今不下。明今意。言不论等者。今非界内护明相等。故不论实时。又非破外执时为实。故不论假时。长短如前。但是众生机熟。佛应说经。机应合一之时。亦是谛智合一之时。故云一时。文但从应。故云说经。岂无机感佛空说法。故佛说竟韦提悟讫。然一时文义本通深浅。今意别在圆机感佛。故使凡夫顿入法忍。四佛者下。化主三。初约异名释。大论第四。以四义释婆伽婆。一能破烦恼。二有功德。三巧分别。能分别诸法总相别相故。四好名声。无有得声名如佛者故。今文略出二义。新云薄伽梵。具六义。一自在。二炽盛。三端严。四名称。五吉祥。六尊贵。以多含故不翻。旧云婆伽婆讹也。二佛者下。约三觉释。佛者下。总示。既能下别示。三觉对迷说自。对自说他。对因说满。一平等觉对三不同。说为三觉。三一切下。约超因释。一切智故。异外邪痴。无缘慈故。异小自度。三智等故。异偏菩萨。究竟觉故。异诸因位。能异不殊。对所异故。四种分别然释佛义。六即等说其文稍委故今略云。五在者下。论住处二。初释住二。初会在同住。在暂住久一往分之。故非尽理。久在暂住有何所妨。况灵鹫山如来应身常在其中。岂得言暂。二住者下。约论释住。此经云在。大品言住。其义不别。故引彼论住义释在。分二。初标列。四威仪者。谓行住坐卧。此之身仪。皆住灵鹫而能住法。则有四差。即天梵圣佛也。二天住下。解释。今四住文。乃是尽取论释住义。是知四中。皆明因果而能住法。正在于因。所谓如来以摄物故。示现施戒及十善心。此即佛以欲天之法。住王舍城。为物示现四无量心。示三三昧。即梵法圣法住王城等。此皆如来随他意住。若随自意即以楞严至不共等。住王城也。故普贤观云。释迦牟尼名毗卢遮那。此佛住处名常寂光。释迦遮那既是异名。王城寂光。毕竟无二。故云此佛住处名常寂常。今之所住是何境界。又应了知。若以人法分于能所。施戒至于首楞严等。皆所住法。佛为能住。若以王城为所住处。上之人法皆名能住。又据经文但云佛住。论应唯就首楞严释。而明前三者。荆溪二解。一从通以趣别。从广之狭也。二将胜以摄劣佛住王城必摄欲色及以三乘。佛住既胜则无法不住。非不住恶为引物故。且从善说。而于善中就世间善。略指定散收一切善。故言天梵。于出世中。略指小大。摄一切法。故言圣佛。他人不明能住心法。唯云身住王舍城等。则抑极圣同凡夫住。况复凡圣各各有于能住之法。且如比丘修戒定慧。乃以天梵及以圣住住于房舍。若破戒者则以地狱住于房舍。其有能修一心三观。则所住处即空假中。岂非楞严为能住法初心尚尔。如何果佛唯论身住。二王舍下。释处二。初各释城山二。初释城二。初翻梵名。亦名摩竭提。此云不害。言此国法不行刑戮。其有犯死罪者。送置寒林。二释论下。解释三。初约诸王治化释。二又先下。约移居免火释。三又下。约畏罪得处释。二耆阇下。释山二。初翻名。二诸圣下。解释三。初约圣灵依就释。二又名下。约山形似鹫释。三又山下约鹫鸟栖隐释。二然法下。总示法应。不言报者。报能冥法。复能垂应。既言法应报在其中。三身融妙言且暂分。体常相即。六与大下。列同闻二。初标科辩次。二声闻下。依次解释二。初声闻众二。初分科示略。二与者下随文解释二。初标位四。初释与。与即共义。以七一释。七种一故。方成共义。若据时判。已属生酥。且从本说。七在三藏。同感佛时。同鹿苑处。同别脱戒。同一切智心。同无漏正见。同三十七道。同有余脱。昔同七者。今日同闻。然此观门佛将阿难及以目连。入韦提希后宫宣说。大众未闻。至回灵山阿难具述方得同闻。二大义下。释大。华言大者。梵曰摩诃。乃含三义谓大多胜。故须就本三义释之。大人所归。德量大故。梵王师陈如。帝释师迦叶等。通内外典。识解多故。出九十五。知见胜故。皆无疑解脱。故小中极。虽标一大义必具三。三释比丘二。初标列六义。因三果三。一一主对。二释论下。随要释三。因三若成。果三自克。复欲行者效彼修因。故释因三。三中初乞士。今举身子答彼净目乞士之义。须离上下方维之食。常行乞食清净活命。故名乞士。至果乃成应供德也。二怖魔。魔主生死。在家受欲增长生死。出家离染趣向无生。是故魔王闻之生怖。染欲破戒魔还快乐。勤修三学果证无生。三破恶。见思二使共九十八。名恶名贼。修观推穷名为破恶。证智断尽名为杀贼。四众者下。释众三。初释通名。二一有下。释别相。三今此下。明去取。羯磨通凡。故取有羞。今此二僧者。即有羞真实也。论云。是中二种僧可共百一羯磨同闻证信。尚简学人。前三绝分也。二千二下。列数二。初标人合数二。初合一千。二舍利下。合二百五十。二迦叶下。常随所以。二菩萨众二。初科四文。二天竺下。释二义二。初释位。二文殊下翻名。二发起序三。初对辩不同二。初泛举差别。放光如法华经放眉间光。照东方万八千土也。动地如大品世尊以神通力。大千国土六种震动。微笑如报恩经。尔时如来熙怡微笑也。入禅如金光明经。是时如来游于无量甚深法性也。自唱位号。如梵网经。我今卢舍那方坐莲台也。劝人令问。如涅槃经。普告众生。大觉世尊将入涅槃。若有所疑。今悉可问。为最后问也。然诸经发起事。或兼有之。今且各举一端。以明发起之相。二今经下。正显今经二。初正显。二何故下。释疑。二就中下。总科略释二。初分科。二问频下。释二。初问答释疑二。初问频婆韦提皆请弟子。赴频婆请。何故唯遣目连楼那。至赴韦提。何故如来躬亲而往。答频婆国父。愿闻戒法。可遣人授。韦提国母。机在妙观。须佛亲开。父母之称从阇王得。二频婆下。预翻名字。三初段下。随科解经。初正明杀父二。初分科。二初尔下。随释四。初为子幽禁二。初随释经文二。初师资现事二。初释时处标人。经云尔时。即当佛在城不远耆阇山时也。前译阿阇世为未生冤。今方释义处胎之日有冤害相。占者预记因以为名。二随顺下。明顺友造逆五。初释恶友名族。二为利下。释恶友谋术二。初从人学术。阿难亲弟。知取通法。自未得通不知其心。故授与之。二心念下。诱人同谋。作象马宝。以轮王事诳惑阇世。作抱持等。欲其生爱也。三语王下。明恶友言教正教造逆。我杀牟尼以作新佛。汝杀频婆以作新王。新王新佛共化世间。不亦快哉。四随顺下。明太子造逆。阇世受教乃行杀逆。五调达下。明恶友造逆。调达自造三逆成就。复教阇世杀父成就害母加行。自行教他五逆罪故生陷泥犁。二频婆下。父子前因。被杀仙人生恶念故。即来为子。胎中已有害父之怨。二如此下。总结权化。调达阇世频婆韦提。皆是大权。现逆现顺。利益众生。二夫人奉食。三圣为说法。二初释目连授戒二。初释疾至。以其宿世事辟支佛。今得神通疾至王所。二授八下。释戒相。初开香衣及上高床。以为八戒。斋在八外。次合香衣高床为七。不过中食为第八。则斋在八内。法无增减数有开合。皆名为八戒斋也。二富楼下。释楼那说法。四频婆下法食延寿。二次害下。明欲害母二。初分科。二初阇下。随释四。初为子幽闭三。初欲害母三。初王问在不。二守门下。以事实答。三王闻嗔怒二。初消经文。二应杀下。释妨难。二劫初下。二臣谏三。初释劝辞。二以手下。释劝相。三惊怖下。明从劝。三敕语下。敕幽闭。二韦提下。因禁请佛二。初分科。二韦提下。随释二。初请人。一是门师。一是佛侍。先常教诫。故偏请二人。既在深宫。故请二人不敢偏一。欲传我意请佛宣说生净土因。请人之意也

观无量寿佛经疏妙宗钞卷第三观无量寿佛经疏妙宗钞卷第四

        宋四明沙门知礼述

二悲泣下。请式。科云请法。即法式也。三世尊下。因请往赴二。初分科。胜鬘等者。胜鬘夫人也。即舍卫国波斯匿王女。末利夫人所生。为踰阇国妃。其后父母遣书云。佛出我国。神通自在。普益众生。胜鬘执书。对使说偈云。仰惟佛世尊。普为世间出。亦应愍我等。速来至此处。即说此偈时。佛于空中现。复说偈赞云。如来妙色身世间无与等等。今韦提哀请佛即降赴。其事相类。故云不异。二知韦下随释五。初神通二。初消文。如来之心寂而常照。无数河沙世界众生若干种心。悉知悉见。非同小圣作意方知。他心及以身如意通皆无记通也。二问前下。释妨二。初出妨。此难重出。问不异前。答不同彼。言二解者。一灭即今嫌佛之恶。二生以后行法之善。何以故。若佛入彼频婆之室。即令世王谓佛朋父还谋国政怨嫌既重。后不行法。故不穷往。母无斯事故佛亲赴。二时韦下。色身。三坐百下。坐座。四目连下。眷属。五普雨下雨华。四伤叹请法二。初分科。今向世尊下。明请往生之因者。即二意中第二请示往生净土之因。经云。唯愿佛日教我观于清净处文也。初明供养问往生因者。即第一意问往昔生中。何罪为因。生此阇世恶逆之子。应知此二语同意别。分二。初我有下。供养问往生因。经自绝璎珞。举身投地。号泣向佛。即三业供养。绝璎投地是身。号泣是口。以二显意。阇世之因已略如前。疏今但出调达之缘。二浊恶下。正问生处。二今向下。请往生因。第二正说分二。初泛科悬解二。初科三段。二如来下解初文。二初放下。重科广释二。初总别分科。酬前生处者。前韦提请云。惟愿为我广说无忧恼处。佛今放光照其净土。令彼见之。以酬前请。酬前净业者。前请云。惟愿教我观于清净业处。今示三种净业十六妙观。即教彼观净业处也。近答等者。以韦提希于酬生处中因光见土。乃再请云。教我思惟教我正受。此在正宗。故云近答。若酬序中所请。即是远答。二随科解释二。初酬二问二。初酬前生处二。初答其生处三。初尔时下放光普示。二或有下示土差别。三时韦下。的示生处。二思惟下。见土更请因。此请净土正助二因。初教我思惟。若不思惟不成愿乐。有愿之思。乃成业因。惟愿世尊。教我修于净土愿思。令成业因。此请事善助道之业也。次教我正受离邪倒想。领纳所缘名为正受。此请世尊教我修行净土观法。即正观也。二微笑下。酬前净业二。初总别分科。初业共凡夫等者。今三种福是圆助道与正观合。皆如来行故。云三世诸佛净业正因。但以三种有通有局。初孝养等通于大小及以博地。故云初业共凡夫。次归戒等唯通大小凡夫无分。故云次共二乘。若菩提心等专在大乘。不通凡小故云不共之法。二何以下。随科解释二。初三种净业。答思惟三。初正明净业三。初光照频婆得道二。初释微笑二。初问。二答二。初解有下答放光。观法得果者。无生法忍是圆三观习果故也。二微笑下。答微笑。恶业之报害命。絷身。而为获果及净土缘。如来心了善恶因果交互万差。欲表内心是故微笑。二阿那下释阿那含。二去此下。举果劝修因二。初问。大本小本俱云极乐去此十万亿刹。刹即大千故云河沙。何言不远。二解云下。答有二意。初以佛力故。令修观者欲见即见。故此文云汝当系念谛观彼国。故知佛力加欲见者。令观成见。后文云。一切众生观于西方极乐世界。以佛力故当得见彼清净国土。故般舟见佛而论三力。一佛威力。二三昧力。三行者本功德力。次意即是光中现土即目睹见也。其二种见皆由感应。虽远而近。然若心性不具尘刹。则佛无应现之理。生无感见之功。故此经谈是心是佛。观迷此意则非妙宗。三第一下。正示往生因二。初正示三。初共凡夫业。此经正被顿修之机。虽修佛行。父母师长岂不孝事。轮王十戒岂不止行。但能修之心。一一称性。何妨所修慈孝之善。共于凡夫。二第二下。共二乘业。圆顿行者岂违小乘出家之式。三归众戒威仪等事。但受持之心合于一体。依于毕竟而所行之法共于二乘。三第三下。大乘不共业。依无作境起无缘誓。名发菩提心。实相不二而二。立因果殊。二而不二。始终理一。信此因果方名为深。读诵大乘修三智解。运圆乘行。以此解行教其行者名为劝进。此三种业得前前者不得后后。得后后者必得前前。故今行人能修前二。前二不能修于大乘。故云余二不及是言大乘。二佛告下结叹。既是佛业验是圆修。故大经中复有一行。名如来行。虽云一行而具五行。今亦如是虽是佛业而具三种。二谛听下。叹其所问。谛听等者。诸经诫听皆有此语。莫不令人生于三慧。而须按教明慧偏圆。能听所听。能思所思。能念所念。若作生灭解者。即三藏三慧。无生解者通教三慧。无量无作别圆可知。今令韦提等生圆三慧若不尔者。安能此座即证法忍。三即得下。略付阿难经如执明镜等者。观法如镜修之如执。观成土现如见面像。是知外有三种净业。内备十六妙观。乃得见也。此虽略付净业。意说妙观。初住初地者。圆住别地俱破无明。是无生忍位。妙玄一实位云。若入初住正破无明。是明圆教无生忍位。今意在圆。引仁王五种忍位者。用显无生居三忍上。若依别教十信伏忍。十住信忍。十行去顺忍。十地无生忍。妙觉寂灭忍。若约圆位五品伏忍。六根清净信顺二忍。初住至等觉名无生忍。妙觉名寂灭忍。然别初地即圆初住。故引仁王以证今位。行者应知。如来将说十六观法。预彰所说是圆妙观。故云一切众生观于极乐观成即得无生法忍。是故韦提闻说十六随语观成。说讫即证此之妙位。经示此观是取初住径捷之门。故不可云想事而已。二初明下。明十六妙观。答正受二。初分科。二汝是下。随释二。初明韦提见土之由。经未得天眼等者。问阿那律天眼最胜。但见大千。岂有得天眼者越十万亿土见安养乎。答此语未得分真菩萨天眼。非二乘也。故大经二十二云。菩萨所得清净天眼。异于声闻缘觉所得。以是异故。一时遍见十方世界现在诸佛。大论亦同此说。韦提实大菩萨者。此显韦提本住法身。为欲发起净土观法故示同凡。此会即得无生忍者。即者方将也。此会闻观将证法忍。非谓前文说无生忍是韦提证。前文乃是通说未来众生修十六观能得无生。人见示同凡夫之言。便谓前文是韦提证。须知即得非已得也。既云实大菩萨。乃是久证无生。如来据迹言是凡夫心想羸劣。劣想凡夫修之得忍。显兹妙观能革下。凡顿成圆圣。异方便者。十六观法奇异方便也。故起信论云。修多罗说有胜方便。系念极乐令生彼国。非直观名方便者。谓彼依正有二方便。能令此土凡夫得见。一者修观正受方便令心眼见。二佛神力示现方便能令目击。既得见之由。有其二种。故云非直观名方便。佛力令见亦是方便。韦提乃得二种之见。一者将有随文作观之见。二者已蒙佛力示现见也。故云韦提见土之由。二韦提下。为未来请见土之法二。初请。韦提先领示现方便而为请由。是故经云。如我今者以佛力故见彼国土。然复正请观法方便。乃以众生而为请缘。故经云。若佛灭后诸众生等。浊恶不善五苦所逼。云何当见极乐世界。五苦者。疏有二释。初以五道非乐释。二以五罪招报释者。地狱烧煮苦。饿鬼饥虚苦。畜生屠割苦。人间八种苦。天上五衰苦。次释者。圣意多含更明五恶招于二报。名出大本无量寿经。今云大经是也。疏文先列三五之名。次五恶下。释出三五。杀至饮酒五恶因也。如大经下。释五痛即华报也。五烧下。释五烧即果报也。然其二报并无五相。各称五者皆从五种恶因而立。故彼五文。后皆结云。是为一大恶一痛一烧。乃至总云。五大恶五痛五烧。故知二五皆从因立。二答二。初列观分科二。初列观。义例云。夫三观者。义唯三种。一者从行。唯于万境观一心。万境虽殊。妙观理等。如观阴等即其意也。二约法相。如约四谛五行之文。入一念心以为圆观。三托事。如王舍耆阇名从事立。借事为观以导执情。如方等普贤其例可识。问今十六观于三种中属何义邪。答既不撮乎。法相入心成观。信非附法。又非借彼事义。立境立观。验非托事明矣。如来直谈十六观行修证之门。正当从行也。问义例三种。皆是理观今之十六历依正事何预三种邪。答托事附法二种三观有事有理。且置未论从行三观以何义故。不得历事。既言从行。必四种行。常坐一种纵直观理。余三三昧岂不兼事。如般舟三观历念佛事。方等三观历持咒事。法华三观历诵经事。请观音三观历数息事。觉意三观历三性事。此等历事若非从行摄属何邪。般舟三昧初观足下千辐轮相。次第逆缘至肉髻相。彼观相时即用三观。彼是从行今那独非。况义例云。唯于万境观一心。岂今依正不唯一心。经文具列十六境相。大师但于首题示圆三观。令将此观观十六境。正是万境虽殊妙观理等。又今三观。并诸历事三观。若非从行等者。那云三观义唯三种。问今经但于像观示。云是心作佛是心是佛。诸文皆无观理之语。则知佛外皆是事观。纵将此义例观十五。斯是行人用理观意。据经现文但是事观。答若自依经修观入证。何须四依解说经意制立观法。大师深得佛旨。故于首题以妙三观释能观观。以妙三身释所观佛。而云观虽十六言佛便周。今依大师用三妙观观十六境。岂是行人自用观意。应知四种三昧无不于事观三谛理。但般舟等依定散善事。觉意纵任善恶等事。是故偏得历事之名。若常坐等直于三道之事。而观三谛。不兼修善及纵恶事。故受理名。今经观法岂可异于四三昧邪。故知十六正是从行历事观理也。应知十六皆用三观为想相之法。三观微故且观落日及以清水。三观渐着乃观地树座像佛身。下去诸境皆须三观。二就十下分科。以十六观三类分之。六属依报者。日标送想之方。冰表琉璃之地。虽此土物意显彼邦。是故六观皆彼依报。七属正报者。座为三圣亲依。像类三圣真体。是故七观皆名正报。三辈之人自此之彼。修因托质事相不同。是故此三自为一类。二第一下。随科解释三。初六观观依报六。初日观二。初立意分科。先作日观意令系心。凡心暗散何能明见净土妙境。故令专想落日之形。一事系心想之不已。其心则定。心若静细种种观法皆可造修。系心之法须落日者。欲令定想趣于西方。是向弥陀所居处故。二随解释二。初佛告下。总劝修观。经韦提希汝及众生者。韦提希等是现在机。一切众生是未来机。故知修观不专佛世。况复韦提是发起者。正为今人请正受法。是故我佛劝众生修。修法如何。专系一处所谓西方。二云何下。正明日观三。初举所观境。经文意者谓。昔曾见者。或现前见日欲没相。为所观境。盖以此观所被周遍。唯除生下。双目俱盲。既不识日故莫能想。若曾有目即今盲者。亦可修之。况现有目见日分明。修之越易。即以所见落日为境。想之令起观中之日。二当起下。正教观察。释题观字明妙三观。题目是总。经文是别。岂不以总而贯于别。今想落日。而能想之观随解而进。三藏事定能想所想无非生灭。通教事定能想所想皆如幻化。别知能想元是佛性。于想能所次第观中。圆人妙解知能想心本具一切依正之法。今以具日之心缘于即心之日。令本性日显现其前。斯乃以法界心缘法界境。起法界日。既皆法界。岂不即空假中。圆人六根常所触对。尚须念念即空假中。岂今修观顿废此三。此犹总示。若别论三观成日功者。以根境空寂故。心日无碍。以缘起假立故。累想日生。以其心日皆法界故。当处显现。此之三观同在一心。非一非三而三而一。不可思议。以其圆人凡修功行皆悉如是。若不尔者非是圆人修事观也。通人必。以如幻之心。修诸事定。以验圆人用即中心成其事观。既以妙心观于落日。此心坚住能于本性显现日相。不唯闭目能见开目亦皆明了。若如此者则日观成也。疏出二义二。初教令下除疑。大本下卷云。若有众生以疑惑心。修诸功德愿生彼国。不了佛智修习善本。愿生其国。此诸众生生彼宫殿寿五百岁。常不见佛。不闻法。不见僧。于彼国土而受胎生。此人宿世无有智慧。疑惑所致。乃至生彼宫殿无有一念恶事。但于五百岁中不见三宝。故作此观令除疑惑者。经云。不了佛智则生疑惑。疏云。故作此观令除疑惑。即显此观能了佛智。若其不用一心三观观落日者。则迷佛智。那名此观能除疑惑。日观既尔余观例然。故知大师依乎佛智立今观法。然十六观属顿教故。原始要终皆用佛智。若凡小善乃于临终回向佛智。作众恶者须依佛智求灭罪障。此等亦名了于佛智不生疑惑。既有乘种生彼速得见佛闻法预于海众。不生边地及胎宫也。二障者下。灭障即五逆重罪也。彼经散善力弱。故逆谤不生。故彼经云。若有众生闻其名字信心欢喜。乃至一念至心回向愿生彼国。即得往生。住不退转。唯除五逆诽谤正法。若依今经修正观者。下至日想即能灭除五逆重罪。是知逆罪得生必由修观。下辈自论者。下品下生观云。除八十亿劫生死之罪。今言六十者。恐六字误。问既用法界以为心境。显法界日。令闭目开目常得见日。即是观行见法界理。当中三品。今何判位在名字初。属下下品。答理观事定相即修者。心虽不二。事杂凡情。故未伏惑。事定可成。理观忘情。伏惑方发。故别惑初伏名观行位见法界理。深伏乃名相似位见。分断方得真见法界。今之行者观日观冰及观琉璃。虽用法界心境而观。而惑全未伏。凡情尚浓方得名字见法界日。非观行位。作此判者。盖约钝根于日等观。且得定心假想之益。故在名字也。若利根者法界日显便能圆伏。及任运除二种粗惑。岂非日观历九品邪。问今用理解想日现前。纵未断惑事定已成。据下经说。下下品人以苦逼故不遑念佛。但十念顷称彼佛名。心虽相续终不可类见日定心。因何同在第九品位。答彼由造逆及作众恶。临终苦逼得遇善友为说妙法。虽不能念彼佛三身。怖地狱故。苦切称名具足十念。既绝后恶即乘此念。托彼莲中名下下品。今论始行乐习三昧亲善知识。闻法了心。本具净土依正诸法。标心具修十六观法。故先观日令心坚住。望后诸观此当末品。彼人虽即不成事定。而能十念称佛不散。亦为定摄复兼临终勇决之力。故得预于第九品也。是故行相虽少不同品位无别。三是为下结。二水观二。初分科二。二随释三。初举所观境。即以曾见大陂池水为所缘境。二见水下。正明起观。既禀圆宗知能想心具七大性。故以具水之心托彼即心之水。观于本性令水现前。并及诸相皆于心性观令显现。经文为四。初作水想。妙心既运性水即生专想澄清令心不散。二既见下。变水成冰。性具之法转变自由。故可令水。而作坚水。三见冰下。变冰为琉璃。冰想若成琉璃可识。四此想下。观琉璃成地。心藏具法。有何边涯。无妙观缘隐而不发。今依佛语顺性想之。宝地光明种种奇相随心出现。此自六段初成地莹彻。二下有下。宝幢光明。三琉璃下。地上庄严。四一一下。宝光楼阁。五于台下。华幢乐器。六八种下。风乐演法。疏实无时节等者。大本云。彼无四时不寒不热。及无日月常有光明。寄于此土四方四维。有八种风。故亦顺此对有八风。然彼八风不同此土令物生长及以衰落。但鼓自然之乐演乎妙法之音耳。三是为下结。三地观二。初分科。二随释四。初渐想者。转于冰想用表琉璃。虽复观地种种庄严。未称彼佛胜应所居。良以三观尚微犹兼假想故。于彼地名为粗见。二若得下。实观。妙观功着三昧有成。见彼胜身所依之地。庄严之相岂可具陈。应了同居横具三土其相非少。如诸经说。凡小善行回向求生。纵依大乘仍是散善。故感养净相犹劣。若今顿教心观。妙宗所见净相永异他部。如修妙观于同居秽。尚见尊特及实报土。岂净同居身土一槩。故今地想妙三昧成。见庄严事不可具说。三佛告下。明利益。疏云。前水是想者。盖托此方水成冰事。表彼宝地。但是假想故名粗见。今成三昧实见彼地则名实观。言假想不能灭罪。斯是大师顺经策进。令其行者速成三昧。非是假想全不灭罪。何以知然日观尚类下品下生灭罪之数。岂粗见地全不除愆。四作此下。显邪正。观与经合则称性见。名为正观。见相乖经是发魔事。故名邪观。下去皆然。四树观二。初分科。二随释三。初结前生后。二正明观行。问日观水观皆先立境。地树等观何不云邪。答别论水日有曾见相。可指为境。地树已下。非曾睹对。将何为境。若通论者皆得有境。何者诸观皆用教所示相。忆持在心为所缘境。仍了能观本具此法。托境想成令性具法发明心目。是故心观及所发相一一皆三。故知通论皆得有境。此文为五。初观宝下。树体者下之庄严及生法等。皆是能依。今一一树八千由旬。即所依体。二一一下。庄严相。琉璃具云吠琉璃邪。此云不远。谓西域有山去波罗奈城不远。此宝出彼。故以名之。玻璃正云窣坡致迦。其状少似此方水精。然有赤白者。三诸天下。明生法。生即众生诸天童子也。以生对诸庄严之事。皆称为法。释迦毗楞伽此云能胜摩尼。正云末尼。此翻离垢。言此宝光净不为垢秽所染。又翻增长。谓有此宝处必增其成德。旧云翻为如意随意。此皆义译也。色中上者。谓摩尼之光间杂众宝色像殊妙最上无过也。阎浮檀金。阎浮具云染部捺陀。此是西域河名。近阎浮捺陀树。其金出彼河中。此则河因树立称。金由河得名。如帝释瓶者。帝释具云释迦因陀罗。此云能主。言其能为天主。言瓶者。释论第十五云。有人常供养天。其人贪穷一心供养满十二岁。求索富贵。天愍此人自现其身。而问之曰。汝求何等。答我求富贵。欲令所愿皆得。天与一器名曰德瓶。而语之言。所须之物从此瓶出。其人如已。应意所欲无所不得。今此妙华涌出诸果。如彼天瓶出种种物。故以喻之。四有大下。现佛国。非独现一大千十方佛刹。亦于中现树观。若发转观佛土亦应不难。五观见下结观。虽因光盖见十方土。然从树起故。须结末而归其本。三是为下结。此乃结树当第四观。五池观二。初疏科。二释经五。初明池体。体义同树。二一一下。明池相。支派金渠底沙莲华。皆是八池奇妙之相。三其摩下。明随心。论其宝水称适人情。自然上树然后流下。故上生经明兜率宫有水。游梁栋间与此同也。四其声下。明利益。即水声说法增人观慧也苦空等是说小诸度相好是说大又赞念佛法僧则令人深观三宝也。说法既分大小。验此三宝亦赞别体同体之殊。涅槃经中琉璃光菩萨欲来此土先放光明。非青现青。文殊言。此光明者即是智慧。大师引此立有分别色。若心若色唯是一色。今水声说法光明化鸟。岂不彰于有分别色。色能造心色具于心。唯是一色耶。须知万法唯心。尚兼权教他师皆说。一切唯色但在圆宗。独从吾祖以变义兼别具唯属圆故。五是为下结观。疏释八德而对五入。并前说法即声入也。虽成六入无非妙境。故令行者速证无生。六总观二。初疏科二。经文四。初明总观二。初观宝楼二。初众宝下。正明观楼。二其楼下二处乐声。即楼中天作及空裹自鸣。此乐音中皆诠三宝微妙观门。二此想下。结成总观。最初系念且寄此土。落日及冰以为方便。次观彼国地树池楼。应知此四得后后者必得前前。故楼观成四事都现。是故至此得总观名。虽云总见若望后观此犹约略。故曰粗见。二是为下结。三若见下。明利益。除无量亿劫极重恶业者。华座中云除五万亿劫罪。前地观除八十亿劫。然其灭罪多少之数。皆是佛智如量言之。非是初心所能思议。但可信奉而已。四作是下。显观邪正二。七观观正报二。初分科二。随释四。初敕听许说。二说是下。佛现身相。三时韦下。为未来请。四第四下。酬请广明二。初别从酬请列五。韦提因睹三圣乃为未来请三圣观。如来酬请须示五门。何者既欲观佛。佛必坐座故先观座。又真佛难观要须想像使心流利。是故答三陈兹五观。而独标佛者以主包徒也。二初华下。通就所观释七。具论正报。须依前科照于七境。文七。初第七华座观二。初疏科二。经文五。初成座法用及辩相。子科分二。初佛告下。明法用谓观法之用也。以由理具方有事用。能想之心何法不具。依圣言境就性而观。华座庄严不现而现。一令其下。辩相。即法用所成华座众相也。文四。初华色数量。二一一下。华间殊光三释迦下。华台宝网。甄叔迦者。此云赤色。西域有甄叔迦树。其华赤色形大如手。此宝色似此华因以名焉。四于其下。宝幢庄严。须弥山者。此云妙高。亦曰安明。夜摩天者。具云须夜摩。此云善时。以彼天光明无昼夜之别。故曰善时。应知能观三观转深所发胜相渐大。如前宝树止高八千由旬今之华座台土宝幢自如万亿须弥。验其座体极为高大。故知妙境随观增明矣。二一一金色下。明能随机利物。座观若成。十方佛事随观皆睹。三是为下。结观。四佛告下。明由愿力成。彼佛因中作菩萨比丘。名为法藏。于世自在王佛所。发四十八愿。取此净土摄诸众生。今愿力成。故令所依华座若此。五若欲下。明未来利益。二第八佛菩萨像观二初分科。二法界下。随释三。初泛明诸佛法身从心想生。欲想佛身须知观体。体是本觉起成能观。依体立宗斯之谓矣。须知本觉乃是诸佛法界之身。以诸如来无别所证。全证众生本性故也。若始觉有功本觉乃显。故云法身从心想生。又复弥陀与一切佛。一身一智应用亦然。弥陀身显即诸佛身。诸佛相明即弥陀体。是故泛明生诸佛身以为观察。弥陀观体。疏约三义释此经文。初释初八句二。初约感应道交释二。初明佛入生心。报佛法性身者。满足始觉名为报佛。究显本觉名法性身。始本既冥能起应用。然须能感应方现前。今论三观净心念佛。方名能感。故云众生心净法身自在。此二道交是为入义。复以白日升天喻始合本。影现百川喻应入净想。二即是下。相随物现。三十等者。牒经是故汝等已下文也。明佛下释义。由法报冥故。应用自在。有净心感悉能示现。前明佛菩萨者。即指诸佛是法界身之文也。而言菩萨者。以法界身通分证故。故兼菩萨意明前虽显示法身入心。未明随观现身之相。今明观佛相好佛以相好随心观现。故云此显能随也。二又法下。约解入相应释。前明感应道交。恐谓佛体异众生体感召方入。今袪此见。故云佛身无所不遍。既法界无外岂少异众生。若尔佛体本遍全是众生色心依正。何故经云入众生心。然虽全是而众生迷背。是故佛体成出离义。今得观解契合佛体。是故佛体入观解心。故得名曰解入相应。斯乃始觉解于本觉。是故本觉入于始觉。问解入相应释之方的。此义即足。何须前约感应释邪。答今之心观非直于阴观本性佛。乃托他佛显乎本性。故先明应佛入我想心。次明佛身全是本觉。故应佛显。知本性明。托外义成唯心观立。二释相假。是今观门故感应释阙之不可。二是心下。释中二句二。初作是别明二。初约能感能成释作。作有二义一净心能感他方应佛。故名是心作佛。言佛本是无者。法身妙绝无有色相迭相见故心净故有者。众生净心依于业识熏佛法身。故见胜应妙色相也。二三昧能成己之果佛。故云亦因等也。复名是心作佛。初作他佛次作己佛。二是心是下。约即应即果。释是。是亦二义。一心即应佛。故名是心是佛。向闻等者佛体无相。心感故有。是则心佛及以有无。条然永异。经泯此见。故言心是应佛。心外无佛。二心即果佛。故名是心是佛。即亦无佛之因一句也。既心是果佛。故无能成三昧之因也。众生心中已有如来结加趺坐。岂待当来方成果佛。初是应佛二是果佛。此乃消释经疏之文。若论作是之义者。即不思议三观也。何者以明心作佛故。显非性德自然有佛。以明心是佛故显非修德因缘成佛。应知外道诸句三教四门。所有思议不出因缘及自然性。故佛顶经明乎七大皆如来藏循业发现。一一结云。世间无知惑为因缘及自然性。皆是识心分别计度。但有言说都无实义。彼云世间该于九界。今于一念妙观作是能泯性过。即是而作。故全性成修则泯一切自然之性。即作而是。故全修即性则泯一切因缘之性。若其然者何思不绝。何议不忘。既以作是绝乎思议复以作是显于三观。以若破若立皆名为作。空假二观也。不破不立名之为是。中道观也。全是而作则三谛俱破。三谛俱立名一空一切空。名一假一切假也。全作而是则于三谛俱非破非立。名一中一切中也。即中之空假名作。能破三惑能立三法故。感他佛三身圆应。能成我心三身当果。即空假之中名是则全惑即智。全障即德。故心是应佛。心是果佛。故知作是一心修者乃不思议三观。十六观之总体一经之妙宗。文出此中义遍初后。是故行者当用此意修净土因。不可不知。故今略释。二始学下。作是共释二。初约始终释。若论六即皆作皆是。今辩修证作是须分。始则名字观行相似三位。修而未证。故且名作。终则分证究竟任运真觉。得名为是意存拣滥。故有此释。二若当下。约当现释。以现释是。以当释作。为令即心见佛法体。以此现因而证当果。故以心佛同体名心是佛。观生彼果名心作佛。意在即心念佛及令慕果修因。故有此释。三正遍下。后二句。三智融妙名正遍知。无量甚深故喻如海。斯乃究竟圆明大觉。与我心体无二无别。今依顿教即三惑染修圆净心。能生诸佛正遍知海。此约他释心生也。若依此心能成当果。此约己佛释心生也。二多陀下。偏观弥陀并示观法二。初令偏观。经是故应当者。上已明示心感诸佛。心即诸佛以是义故。知可即心而观弥陀。心尚能作诸佛。岂不感于弥陀。心尚即是诸佛。岂不即是弥陀。应知弥陀与一切佛不多不少。诸佛乃即一之多。弥陀乃即多之一。一心系念谛观彼佛者。即一心三观也。但云谛观那云三观。以所观境列三号故。显于能观知是三观。何者多陀阿伽度。此云如来。阿罗诃。此云应供。三藐三佛陀。此云正遍知。此之三号即召三德。今就所观义当三谛。正遍知即般若。真谛也。应供即解脱。俗谛也。如来即法身中谛也。以三德为三谛三一圆融不一不异。此谛与观名别体同绝思绝议。此乃复见弥陀观体。当以此观观像观真。疏释三号其文可见。问像观文中示心作佛。示心是佛。复以三号显于三谛。妙观既立。可用此法观下诸境。其落日观至华座观。佛既未示三观之式。何得行人预用兹观。答佛对当机示观前后。全由圣意非凡所知。灭后之人欲修观行。所用法则须凭四依。大师释题能观之观。既论三观。题目是总经文是别。岂不以总而贯于别。况云观佛十六俱包。今依天台修习教观。不凭智者更托何人。如般舟三观妙门。普贤六根悔法。皆于定内见圣方宣。而大师教人。预习精熟方入道场。何不疑之。那独责此且禀斯宗者。若闻若思不离三观。须于动静用空假中立一切行。若其然者。今何不用空假中心。想乎日冰及地树等种种相邪。如心想日以何力故日想现前。般舟经云。我所念即见心作佛。心自见心。心者不知心。心有想则痴。心无想则泥洹。彼经初心以佛相为境。故言心作佛等。今之初心既先观日。岂不得云心作日心自见心等耶。止观以彼经此文。示于中观。中观若立三观自成。如此观日方依此疏修日观也。况一切法皆是佛法。何得依报非佛法邪。二想彼下。示观法子科分经为四。初观佛像二。初正明像观。既是具足三号之像。理合于像。照空假中如见此方泥木之像。尚须体达性。若虚空三身宛然四德无减。观中宝像岂可不然。若于像观不达三谛。次观真佛宁见三身。二见像下。因像见土像。观既成心眼开发。广见依报地树诸相。应知树等出过前树无数倍也。何者以今宝像必称华座。座像高胜树合覆之。皆由妙观转深故。使所观愈胜。二见此下。观二菩萨。三圣设化动静必俱。一主二臣非并非别表乎。三法三一妙融真身既然像合相似。观二足佛令妙观成三。三此想下。像放光二。初明光照诸树。二一一下。明树皆三像。四此想下。行者闻法二。初明因定闻。二行者下。明与经合。此文疏有二释。初须定与教合。二须散与定合。初义者。谓出定忆持。定中闻法须与经中所说符契。故云令与教法相应。次意者。谓心虽出定对彼五尘须息爱憎。净乎身口三业。若尔虽不住定亦闻法音故。云出定入定常闻妙法。言与十二部经教合者。以十二部总称修多罗同名为经。三藏分之经诠定学。律诠戒学。论诠慧学。故名经为定。与修多罗合。是与定合。经若不合名妄想者。若定不合经若散不合定皆是发于魔事。全非像观禅定。故名妄想。若已合名粗想见极乐界者。谓以经验定无差。出定与在定相似。得名粗想见彼国界。问见此妙事那名粗想。答以像望真须分粗妙。此想乃是佛观方便。岂可全同。真佛观邪。三作是下。明修观利益像想。若成真观可获故。于现身得念佛三昧

观无量寿佛经疏妙宗钞卷第四观无量寿佛经疏妙宗钞卷第五

        宋四明沙门知礼述

三第九佛身观二。初分科。真法身者。前观宝像则似佛身。今对彼似故名为真。然此色相是实报身应同居土。亦名尊特。亦名胜应。而特名法身者。为成行人圆妙观也。良以报应属修法身是性。若渐教说。别起报应二修庄严法身一性。若顿教诠。报应二修全是性具。法身一性举体起修。故得全性成修全修在性。三身融妙指一即三。问既言指一即三。但名为应自摄二身。何故疏文立法身称。答若言报应恐滥别修归于别教。今以报应名为法身。即显三身皆非修得。故今家生身应身报身法身。对藏通别圆。行者应知。圆宗大体非唯报应称为法身。亦乃业惑名为理毒。三观十乘名性德行。慈悲与拔性德苦乐。今之胜应称为法身。显示妙宗其旨非浅。须袪滞想方见旨归。二随释五。初明结上。二正观佛身。既指报应名为法身。即显弥陀三身具足既为妙境。但是法身行人心观即空假中。空假是二修。中观是一性。修性冥妙三观圆融。既为能观。但是般若境观相契见尊特身。虽具三身但名解脱。此则以三照三故发现三合此三三只是一三。三不定三。同在一念。一念无念三三宛然。如此方名修心妙观。此观能令四土皆净。若不尔者非是顿教所诠妙观。当以此观观弥陀身。子科分经为三。初次当下。总标略列。二正观佛身相四。初阿难下。观身色二。佛身下。观身量疏释分二。初略消经文。二眼如下。商较分量二。初以眼度身。二定经斥译。三观身光。然观色量及相好光明。皆须用前是心作佛是心是佛。而为观法。以心作佛故能观所观破立宛尔。破则三惑三智皆荡。立则三谛三观皆成。非此破立则非净心作佛义也。以心是佛故。忘能忘所非破非立。作是一念遮照同时。此则即观无观用无作行修念佛定。此法乃是观佛要术。今若不用宣示奚为。此术不施胜相不发。观光分四。初身诸下。毛孔光。二彼佛下。观圆光。三于圜下。光中化佛。四一一下。化佛侍者。四观相好二。初无量下。正示相好身。总相别相总好别好总光别光。此三总别皆云八万四千者。即障显德故成。此数佛居凡地具于八万四千尘劳。于此尘劳皆见实相。理智既合故能示现相好光明故。节节云八万四千。行人今观知心即是。能于尘劳皆即佛相。二一一下。光明摄生生佛体同。虽土广生多摄无一失。观佛心处还释此文须摄之意。三明观成能见二。初其光下。见一佛。二见此下。见诸佛中观见佛。佛体圆融一即一切。同尊特身故观一佛。能见诸佛三正观佛心。疏三。初眼见下。因身见心。疏有二释。初约如来由大悲心起胜应身故。令行者观身见心。由见身下二。约行者观想明故得见佛。心所以明者由观佛身。是故二意皆是由色而见于心。以心无形由色表故。以圆人所观色心不二。既见微妙色。岂隔大悲心。故胜鬘云。如来色无尽智慧亦复然。既三种慈体是三谛。今三观明故三慈显。以用果法为观行故。故于位位见佛色心。二佛心下。正示心体。若匪无缘慈悲不大。三以无缘下。引文广释三。初牒经引论以明文意。问经文但云以无缘慈摄诸众生。疏中何故兼明生法皆云无心。答起三慈者。由三观智照三谛也。照真即起法缘之慈。照俗即起众生缘慈。照中即起无缘之慈。此三谛慈浅不具深。深必具浅故照真俗。未必照中。若能照中必具真俗。故次第生法不即无缘。今无缘慈合具生法。岂但具二亦乃俱深。故今生法皆云无心。故涅槃云。慈若有无非有非无。如是之慈非诸声闻辟支佛等所能思议。当知三慈其体本一非三非一而三而一。如是方名佛心慈也。此自分三。初众生缘慈三无差别。今尽现前心与众生。能所既绝无我心想。缘他众生而一切众生与我同体。十界因果不离一心。而此一心是慈体。故十界苦集四种道灭。能于一时任运与拔。故云无心攀缘自然现益。如涅槃下。梵行品文也。然彼经如来凡说八事。一伏醉象。二降力士。三化卢至。四度女人。五涂割疮。六摩调达。七救群贼。八医释女。一一皆结云。慈善根力。见如是事。今文云我实不往者。即引第五涂割疮文。文现一处意通诸缘。言割疮者。经云。波罗柰城有优婆夷名摩诃斯那达多。夏九十日屈请众僧。奉施医药。有一比丘身婴重病。良医诊之当须肉药。若不得者命将不全。是优婆夷寻自取刀。割其股肉切以为羹。施病比丘服已病差。女人患疮苦恼发声称佛。我在舍卫闻其音声。于是女人起大悲心。是女寻见我持良药涂其疮上。还复如本。善男子。我于尔时实不往至波罗柰城。持药涂彼。当知皆是慈善根力。令彼女人见如是事。今云我实不往者。正引此缘。不言女人而言众生者。通收十界众生。不以文害意也。即俗谛慈也。涅槃云。慈之所缘一切众生如缘父母妻子亲属。以是义故。名众生缘。以缘十界同在一心。故非次第生缘慈也。二法缘慈。十界缘起是三谛法不离一心。唯佛究尽。境相既寂能观亦忘。是故得云无心观法而毕竟空智。照此三谛不受一尘。此智自然照破众生三谛惑着。或为众生说斯空慧。皆令得离有相之苦证真实乐。此即不思议真谛慈悲。名为法缘。故涅槃云。不见父母妻子亲属。见一切法皆从缘生。是名法缘。不见之言须忘十界。是佛法缘也。三无缘慈。以佛性中成究竟智。有何别理为心所缘。故云无心观理境智既泯。空有又忘。无住无依绝思绝议。此名安住第一义中。心既无缘慈乃周遍。入众生性称为内熏。或为现身说第一义称为外熏。以此摄生名无缘慈。二念佛下。却牒前经以对初慈。即前正观佛身光明摄生之文也。虽与无缘慈体不别。若约义辩为门不同。是故此慈念佛众生摄取不舍。终令离苦永得安乐。此从感应生佛相关。顺于俗谛名生缘慈。故举鱼母念子不失。喻此慈相也。三今明下。正以无缘会释经意。既与生缘为门有异。须辩慈相不同前二。故生法慈。约次第论则两二乘及偏菩萨有修证分。若此无缘唯圆唯极。今约极显故云诸佛所被。不住有无者。正与生法辩不同相。生缘妙有法缘妙空今是妙中。故云无缘。中必无缘故也。不依三世者。此之慈悲非四相故。知缘不实者了苦乐事即性德故。以众生等者。此慈所被。令众生发即境之智方乃名得实相智慧。得此智者方终离苦得于永乐故。与前慈门异益等。若对法缘亦以实慧。故一切空。是故三慈益物不异。疏不云者略也。四举利劝修子科分三。初正举益劝。得生极乐则见十方一切诸佛。故云生诸佛前。法身观成已入相似。是故至彼即证无生。别圆地住也。疏释分四。初舍身下牒释。二如人下喻显。习巧如修观。从少至长喻观有微着。所作遂妙喻生彼土亲见真法。然且分喻是心作佛。行者应以是佛与作佛义。一念圆照。方合今经由观见佛。三以随下结示。四故般下引证。二的示观法。相有八万都想难成。故令但观眉间毫相如五须弥。此观若成。八万皆现。此为要门也。疏释二。初从一下牒经。二正示四。初如观下。引他文示二种毫量。此明释迦胜劣两相。以例弥陀。经明劣相论明胜相。云云者。即前疏云。长一丈五尺毫有八楞周围五寸。二故文下。据此经明凡心难及。即第七杂观中经文也。三正可下。正示初心从易现观。斯是大师别示初心即观佛相入门要术也。若从落日水冰方便。次入地树座像等观心得流利观已宏深。此之行人自可称彼毫量而观使八万相自然而现。故如令观劣应毫相乃为未修前诸观者。及以虽修观不成者。故于佛身别指。初心可观之相。为三昧门也。行者须知所托之境有胜有劣。若能观观皆须顿照即空假中。以胜劣相皆心作故。皆心是故。四克示观成称彼而见二。初若得下正示。因用作是观劣应毫。观渐深着得成真似念佛三昧。乃能称彼胜相而见。二智度下。引证。引此释迦胜身说法。增真似位念佛三昧。类彼弥陀八万相好。须真似人方能观见。三见无下。就观结成。五作此下。显观邪正。然此佛观义具释题。疏文既略。学者多疑。若不释之造修无路。故更寄问答明乎境观。问此经观佛止论八万四千相好。若华严说相好之数有十华藏世界微尘。二经所说优降天殊。彼经正当尊特之相。此经乃是安养生身。凡夫小乘常所见相。钞中何故言是尊特。答一家所判丈六尊特。不定约相多少分之。克就真中感应而辩。如通教明合身之义。见但空者唯睹丈六。见不空者乃睹尊特。生身本被藏通之机。尊特身应别圆之众。今经教相唯在圆顿。释能观观是妙三观。释所观境是妙三身。疏解今文云观佛法身。约位乃当圆教七信。正托法性无边色像尊特观心。使其增长念佛三昧。据何等义云是生身。用圆顿观显藏通身。未之可也。问以坐华王具藏尘相。而为尊特。三十二相老比丘形。而为生身其文炳着那云不以相好分邪。答约相解释四教佛身。此乃从于增胜而说。未是的分相起之本。其本乃是权实二理空中二观事业二识。就此分之则生身尊特如指诸掌。故金光疏云。丈六身佛住真谛。丈六尊特合身佛双住真中。尊特身佛双住俗中。法身佛住中道。此依二理故有二佛。众生二识有二观因。故感二佛。言二识者。起信论云。佛用有二种。一者依分别事识。凡夫二乘心所见者。名为应身。以不知转识现故。见从外来。取色分齐不能尽知故。二者依于业识。谓诸菩萨从初发意。乃至菩萨究竟地心所见者。名为报身。身有无量色。色有无量相。相有无量好。所住依果亦复无量。种种庄严随所示现。即无有边不可穷尽。离分齐相随其所应。常能住持不毁不失。如是功德皆因诸波罗蜜等无漏行熏。及不思议熏之所成就。具足无量乐相故说为报(文毕)此乃佛用依二识彰也。应是生身报是尊特。论意要在见从外来取色分齐。与知转识现离分齐相而分二身。然须了知权理但空不具心色。故使佛身齐业齐缘。生已永灭故曰生身。名应名化体是无常。实理不空性具五阴。随机生灭性阴常然。名法名报亦名尊特。体是常住。须知依事识者。但见应身不能睹报。以其粗浅不穷深故。依业识者。不但睹报亦能见应。以知全体起二用故。随现大小彼彼无边。无非尊特。皆酬实因悉可称报。故妙经文句云。同居方便自体三土。皆是妙色妙心果报之处。故知菩萨业识见佛。一切分齐皆无分齐。岂比藏通佛邪。方知智者师与马鸣师。精切甄分生身尊特其义罄矣。问约相多少分于二身。其义已显。何须理观及就识分。答华藏尘相及八万相虽是尊特。三十二相不局生身。何者。以由圆人知全法界作三十二及以八万藏尘相好。故三品相皆可称海。既一一相皆无边底。是故悉可名为尊特。故止观并辅行以法华三十二相。观无量寿八万相华严十华藏尘相。同是别圆道品修发法身现相。对斥藏通相非奇特以验三经所谈相海。皆是尊特。然有通局。三十二则通。大见无边小见分齐。若藏尘八万唯大非小。若也不就理观等分此义全失。故金光明龙尊叹佛。经文但列三十二相圆光一寻。疏乃判云。正叹尊特。故知不定以相数多。方为尊特。只就不空妙观见耳。问行人睹于劣应谈圆佛相。只可即是法身及自受用不即尊特。以尊特身现起方有不现则无。岂见不空不待佛现。便自能见尊特相邪。答既以尊特对于生身。分身非身常无常等。今云劣应但即法身及自受用。不即尊特则成寿量属于尊特。身相自属生身。如此分张进退皆失。须知行者无有一见非如来力。如来鉴机未始差忒。有须现者即为现之。如梵网华严及此经等相多身大也。不须现者。即以力加令于劣身不取分齐。见三十二相即无有边。以知丈六是法界故。应持不见其顶。目连莫究其声。丈六身声既因二圣穷不得际。后之圆人岂不即劣见于无边。不必一一待现方见。若不尔者。用圆解为用业识为。若但即法身及自受用不即尊特。此说全乖顿足之义。何者。如释签解色无边故。般若无边云。五阴是理故即阴是。实相般若故皆无边。以由理故令法无边。自受用身既证理极。岂不即劣而无边邪。行者应知今之妙观观佛法身见八万相。不同金光但于劣身见无分齐。今是彼佛全法界身。应圆似观现奇特身。非是彼土常身常相。若彼常身即般舟中三十二相也。今乃特现八万四千相好光明。经文自云身量无边非是凡夫心力所及。正类净名如须弥山显于大海。安处众宝师子之座。药师中巍巍堂堂如星中月。大论中色像无边尊特之身。此等经论所明尊特与今所现无少差殊。彼色像无边既称尊特。此云身量无边。那谓生身。问所言龙尊叹尊特相。非现起者是义不然。以彼疏释尊特身云巍巍堂堂。若不现者何谓堂堂。答华藏尘相华严经列九十七名。与龙尊叹全不相应。又无身相高大之说。以验非是特现之相。只由龙尊言中妙示即劣含胜难思之文。大师见彼得意之处。是故疏云巍巍堂堂。得意处者。即总叹云。诸佛清净微妙寂灭也。清净乃是四德中净。必不阙于常乐我也。寂灭岂非涅槃之义。即称微妙是大灭度秘密藏也。以总冠别故三十二相遍严三身。生身则百福所成。见无厌足。尊特身则色无分齐。劣即堂堂。法性身则色性即智法门为相。疏云。此三不纵不横。若纵横一异则不清净。非微妙寂灭。岂非圆人了乎三身是秘密藏。密藏乃是法界总体。一摄一切事事相收。应用无边不离毫末。相好至劣星等虚空。故法华中龙女赞佛。微妙净法身具相三十二。显是劣应以法身具故。相相尊特。是故荆溪类同华严一一相好与虚空等。又文句云。一一相皆法界海。又妙玄云。垢衣内身实是长者。释签云。即是璎珞长者。璎珞长者岂非尊特。何待现邪。又妙乐云。若隐前三相从胜而说。非谓太虚。名为圆佛。法华已前三佛离明隔偏小故。来至此经从劣辩胜。即三而一。若也法华但即法身不具尊特。正以太虚而为圆佛。又不具尊特。如何得名从劣辩胜即三而一。问法华文句云。地师说多宝是法身。举南岳破云。法身无来无出。报身巍巍堂堂。应身普现一切。若即此谓是三佛者。未尽其体。只是表示而已。多宝表法佛。释尊表报佛。分身表应佛记释云。无来者不合东来。无出者不应踊出。巍巍不应塔内。应身不应唯此。尚非应身岂具三身。既云巍巍不应塔内。信知报佛须现大身。若其即劣便得名报。塔内何妨何得破他。答此破地师不知表示。真将舍利便为法身。故记破云。尚非应身岂具三身。又以世人不知法华开权之妙即劣显胜。只执身大相多为报故。就其见斥云巍巍不应塔内。此用世人通解之义。而破于彼不可据此便令法华相非尊特。只如记云尚非应身岂具三身。亦非今家尽理之说。如荆溪据论若知像性遍虚空。三身宛然四德无减。泥木之像尚具三身。岂全身舍利皆不具邪。虽曲引文欲令非报。然终不能令法华机非业识见佛也。问请观音疏云。无量有二义。若生身无量是有量之无量。法身无量是无量之无量。大论云。法性身色像无边尊特之身犹如虚空。既云法性身。此乃不灭方名尊特。今第九观观于佛身。第十即观观世音身。观音既是补处菩萨验佛有灭。岂非生身有量无量。安以此身便为尊特。答藏通补处彰佛有量。别圆补处显佛无量。以十方三世一切如来更无彼此迭相见故。同一法身一智慧故。菩萨机忘如来应息。名补佛处。实异藏通前佛定灭后佛定生。为补处也。故金光明四佛降室。疏乃释云。若见四佛同尊特身一身一智慧。即是常身。弟子众一故。若见四佛佛身不同。即是应化。弟子众多故。故知只就同与不同常与无常。分于二身。藏通三乘故弟子多。别圆纯菩萨。故弟子一。岂论相好多少等邪。既同一身复云常身。岂竖分当现横论彼此。是知观音补法身处。愈彰尊特无量之无量矣。且华严佛身委明八相。既是尊特。此论补处与彼何异。云是生身。是知今佛全法界身。故灭即非灭。观音补处生即非身。不灭不生常身义成。尊特相显。问今所观佛高六十万亿那由他由旬。虽云高大只是净土常所见身。何以知然如法华中。净光庄严国妙音菩萨欲来娑婆。彼佛诫云。汝身四万二千由旬。我身六百八十万由旬。汝往彼土于佛菩萨勿生劣想。故知净土常身高大。安以常身便为尊特。答于同居中净光庄严土唯演顿。如净名中众香之土。以其所被纯菩萨故。所以但现高大之身。佛知妙音所将之众。不知娑婆开权之妙。于佛辄起定小之讥。故寄妙音规未达者。意令得悟即劣之胜秘妙之权。既诫勿生下劣之想。乃是令起尊特之心。若谓不然。安得皆获普现三昧。若安养土渐顿俱谈。声闻菩萨共为僧故。故使佛示生身法身二种之相。三十二相通于生法。大小共见。若八万相局在法身。大乘贤圣方得见也。是故众经多说弥陀生身常相。今当略出。小弥陀经云。彼土莲华大如车轮。大弥陀经说。弥陀浴池广四万八千里。以依验正身未极大。般舟经说。阿弥陀佛三十二相。此经中说惯习小者。生彼即得见佛闻法。便证小果。更有丈六八尺之身。此等岂非常身常相邪。若今所观八万相好。别圆真似方得见之。故上品下生疏判已登习种性位。生彼七日见佛众相。心不明了。三七日后乃了了见。及闻众声皆说妙法。唯上品上生道种性位。生彼即见众相具足。光明宝林皆说妙法。即悟无生。三贤菩萨。依业识故。知心现佛。乃就尊特论乎明昧。若惯习小者。及诸凡夫依事识故。不于尊特而论明昧。良以此等虽因临终回向得生。佛顺本习。故且用小令其证果。既说无常苦空之法。须以生身相好应之。浴池之身三十二相。正对此机。故般舟经云。在菩萨众中说经。又云。在比丘僧中说经。信三十二相通大小人常所睹见。是故彼经观法之初。不托日冰便观此相。斯盖凡心可想之境故也。若八万相是彼如来现奇特身。增进深位念佛三昧。非是凡夫心力所及。是故此经初令观日。疏释齐于下品下生。以验想冰至假想地。属下三品当名字人。次得三昧见彼实地。合入观行初二两品。次观宝树及以池楼。至总观成当三四品。宝座观成当第五品。以座上宝幢如百千万亿须弥山大。比知座体其量难思。非第五品三观功成。凡小事禅见莫能及。此观虽就经文未便许观佛身。乃令先想一大宝像称座而坐。及二菩萨皆想坐座。况复悉用作是不二妙观观之。使心流利方令观佛。学者应知日观已来所修三观共于事禅。良以皆须想成相起故也。事禅既胜三界思惑悉已被伏。妙观观像见破即登第七信位。得此位已。方令观佛真法之身八万相显。乃得名为念佛三昧。即感诸佛现前授记。生彼便证无生法忍。经文如此明圆深观所显之相。诚谓奇特。实匪生身凡夫小乘常所见相。问释题序云。无量寿佛是所观胜境。岂非托彼依正色心。修乎三观显三谛理。今八万相既是正报。义当生身。托此修观观成理显。乃见藏海尘数之相。方名尊特。岂分段生身便为尊特邪。答前正释题。以妙三身解所观境。今至经文。以八万相为所观境。信八万相与妙三身无二无别。二处皆用不思议境而为所观。故八万相观之令显。显名观成无别所显。且行人念佛。谁不托佛正报修观。但境随解名生名法。小机不解所观佛身是法界用。谓正习生故曰生身。大机能解所观之佛。是法界用。应既有本生即同法。是故受于法身之称。故见佛相若多若少皆称法身。今经明示佛法界身入心想中。故疏标云。观佛法身斯乃即三而一之法身也。况今不是初心观境。乃圆七信所观境耳。岂于座像圆观已成。却托藏通生身修观。又观生身显藏尘相。此乃通人被别圆接。全非顿教始终圆观。只如般舟三十二相即知心现。故相相皆中。据所观胜境言是生身。深不可也。学者应知八万相显即三谛显。良以此相法身所具。与彼三惑本不相应。故一一相即真俗中。即一而三即三而一。不可思议名真善妙色。今之三昧显本妙相。故观音观云真实色身也。问尊特既是他受用报。须入别圆地住方见。今八万相似位能见。验非尊特合是生身。答据何文义别圆似位唯见生身。须知尊特地住已上分证论见。地住之前相似论见。斯乃如来以实报身。应下二土

观无量寿佛经疏妙宗钞卷第五观无量寿佛经疏妙宗钞卷第六

        宋四明沙门知礼述

故荆溪云。胜兼两处劣唯鹿园。若其似位全不见者。法华四信何故见于实报土邪。有余那见圆满相海。通教案位受接之人为见何相。若非尊特合身不成。今经明说无量寿佛身量无边。与大论云色像无边。有何异邪。彼云无边既称尊特。此何独非。况疏专引彼论此文。以证身量无边之义。验今佛身的是尊特。不须疑也。问若是尊特合是常身。何故法华疏中。判观无量寿佛经。云实有量而言无量。答此乃刊正钞中错引彼疏。彼疏并云实有量而言无量。如阿弥陀与金光疏及此疏同。盖以小大二弥陀经不专尊特被于顿机。故彼佛现三十二相通被众机。大机虽见尊特常身。其惯习小人洎诸凡夫。虽因回向得生彼土。未宜尊特说常住理。故以应化说无常法。成其小果。是故佛寿虽不可数。终归有量。娑婆生彼多是此机。以别圆似位人难及故。三疏约此。故判弥陀在有量中。若观无量寿佛经纯被圆人。明说佛身全法界起。应既有本。生即同法。的类释论法性尊特。正当无量之无量也。故释签云。教分二身为机劣故。暂现生身。今机不劣岂对生身。问大本中云。生我国者身皆具足三十二相。彼国人民既具此相。佛身理合超胜于人。故知常身有八万相。般舟经云三十二相。盖借释迦为初心观境耳。答般舟经云。菩萨用是念佛。故当得生阿弥陀佛国。当念如是佛身。有三十二相悉具足。光明彻照端正无比。在比丘僧中说经。经指弥陀有三十二相。何文言借释迦为境。况止观无文辅行不说。岂得自言成于己见。又彼人民三十二相。故佛常相须八万者其义不然以同居土佛应同人。只净由土人。皆有于三十二相。故佛常身须现此相。但于同中相相皆胜。秽土佛身虽异凡鄙。亦同上人。故应此方所有相法。故三十二同轮王相。亦于同中而分明昧。三十二相既同彼人。验是彼土常身常相。是知八万别为大机现尊特相。更何所疑。问一等尊特。以何因缘相分三品。答悉檀因缘故。盖一类机应以藏尘尊特之相得四益者。故佛称机而为现之。应以八万尊特之相。应以三十二尊特之相得四益者。佛皆称机而为现之。仍须了知此之相海。别教则用别修缘了成就此相。即修成之尊特。故名报身。圆教能了二修即性修德无功。乃性具之尊特。故名法身。已在此观开章中说。须知华严华藏尘数之相虽多。此以兼别故犹带修成。此论八万既唯圆顿无非性具。故三圣观疏皆示云观于法身。行者当须以教定理。就理明观于观显相。无得但以多数斥少使胜成劣。实在精学然后勤修。欲罢不能故兹辩析。四第十观音观二。初疏科略释带果行因者。观音三昧经云。观音昔已成佛号正法明。今为菩萨修净土行。斯乃带昔果德行今因行。顶有化佛表带果也。二依科列经三。初结上。二正观菩萨身三。初正观身相。子科十一。初次复下身量。应云十八万亿。今云八十者。翻过佛身二十万亿。故知误也。问如释迦丈六人身八尺。今佛身六十万亿菩萨十八。菩萨之身何太卑邪答净土胜应不可以秽土劣应例也。亦如妙音身量但四万二千由旬。佛身六百八十万由旬。佛身之量去菩萨更多。二身紫下身色。三顶有下肉髻。四项有下项光。五举身下身光。六顶有下天冠。七观世下面色。八眉间下毫相。九臂如下臂相。十手掌下手相。十一举足下足相。二其余下与佛同异。肉髻是相。无见顶是好。此之相好表于极果。今作因人故不及佛。三举利劝修子科二。初佛告下举观利劝二。初约修观明灭罪。二如此下约称名况获福。二若有下示观次第。身相既多先观何相。故今示云先观肉髻次观天冠。以此二种能别表示观音德相。何者。肉髻降佛表现行因。冠有化佛表昔成果。别相若显其余通相则易可明。行者观于冠髻毫面身色光明。一一须用心作心是。而为能观。说在像前用在此处。既云作佛是佛。岂不能作观音是观音邪。作髻作冠是髻是冠。皆可为例。不独以佛例观菩萨。亦须例于普杂三辈。岂唯以前例后。亦合以后例前。以今行人览经始末。方修观故。大师得意乃于释题总示三观。若也不于十六处用。则令大师虚说。亦见行者谩修。当遵佛言勿背祖法。专用妙观显乎胜相。以此妙观为见佛本。迥出余因。至彼土时速证法忍。三作是下结观邪正。五第十一势至观二。初分科叙意二。初分科。二叙意二。初略无下约当门明阙真观。观佛真身乃立观云正观佛身等。观音中云正明观菩萨身。今势至观但云因光神力制二种名。及云与观音辩同异。何不例上各立观法。故疏出意云略无观法当不异上。以大势至与观世音身量大小皆悉同等。此令行者辩异之后。用观音观观势至身。何须别立。二所以下兼观音明无像想。观成见佛真法身后。观二侍者。岂须更修像想方便邪。二依科列经三。初因光神力制二名。子科二初遍示诸光。二但见下正立二名。光照十方。故立无边光为名。令三途人得佛十力。故立大势至为名也。行者应知即举身光名智慧光。以是邻极色心不二。若不尔者。焉得色相名为法身。二明与观音同异子科三。初此菩下正明同异。二此菩下更示行坐。观音行坐岂不动地集佛等邪。但于势至观中说耳。若不然者。何得云除顶上宝瓶。余与观音等无有异。三作此下结成观相。经云色相疏称法身。若非全色是心色由心造。安令色相即名法身。此乃三谛一境之法身。发我三观一心之般若。相冥见相则三脱圆彰。故云佛法界身入心想中。疏云。念佛三昧解入相应。非此相应不发胜相。三除无下灭罪以劝修。名为具足观观世音大势至者。以二菩萨唯有顶上化佛宝瓶。二种有异余相皆同。同异分明名具足见。六第十二普往生观二。初疏科二。初对杂辩异。二普中下就普分科。二经文二。初作自身往想。上来诸观先依次正先主次徒。虽皆观成未为普总。又未想身生彼亲见。故今令想身终生彼一时普见。非独所观境界顿足。亦乃往生心想成就。可类前文依报之观。初地树池等别观。至楼观成四事总见。名为总观。然但能总依报四事。今想生彼普见普闻依正诸相。故名普观。问上品上生乘金刚台。上品中生乘紫金台。上品下生入金莲华。今三圣观成方修普观。合是上品上生之者。何故同彼上品下生邪。答十六观人对九品位义有多途。今且一往以三圣观及普观成。当上中品杂及三辈四观成者。方是上上故上中品终时虽见坐紫金台。此台到彼成大宝华。经宿则开。此文亦云生极乐界于莲华坐作开合想。莲华开时见佛满空。及说妙法。正合上品中生之相。若上品下生华开七日乃得见佛。仍于众相心不明了。故知此文与上中品生相正齐。若其以品对别圆位。至三品观方得委论。二无量下明三圣来现。上想终后生于彼土见佛菩萨。今想未终三圣常来入我心想。良由当念即是来际。故能预想将生之事。复由生佛体不别故。故令三圣不来而来。斯乃三观一心作是双运。致令心佛往彼来此。故知观体不可言思。七第十三杂明佛菩萨观。今评此观略有二意。一为前观佛及菩萨胜相不成者。乃令舍大而观丈六。二为观前胜相已成之人。令其更观胜劣化用遍十方界。使品位增进。若谓不然。前观既成修后诸观有何益邪。疏从前意故作拂疑生重释。以观成者。自知经意。是故大师从初意示。释此为二初分科。二随释二。初佛告下观丈六像。经若欲等者。行人于前依正诸观修虽不入。求生之意弥加敦督。名为至心。故令此人舍胜观劣。未观二侍前想弥陀。故云先当观于一丈六像。行人欲托彼土莲池。故令观像在池水上。应知胜身既心作心是。岂今丈六非作是邪。圆人作为皆了唯心。全具而变全变是具。具变不二。故观佛相胜劣皆然。二明弥陀变现子科二。初示化主随物二。初如先下劝常修观。二阿弥下拂去众疑。疏二。初所观下示相问疑。二前闻下示疑明破。胜身观法修虽不成。而且得知广大无量。今闻观小顿违前说。宁免轻疑。为拂此疑。故说弥陀。神通如意能大能小皆全法界。但以重心观令成就。勿疑身谢不生西方。二明补处同生二。初观世下明劣应同众生。佛应既随万物。补处亦同众生。二但观下仿胜身论观法。前明观音胜身观法。先想冠髻则令众相次第皆明。势至观中髻有宝瓶。其余身相不异观音。以此二种是二大士身之别相。令修观者但观别相。别相若显同相则明。疏释首相虽通两说。然头首之首手足之手皆是别相。悉可以别而显于通。应知观佛丈六之身。先观白毫方彰众相。备如前疏约释迦说。三后三观明三辈往生四。初立观所由。此中二义。初即杂观观劣应者。位在中下。令识三品进修胜观登于上品。次义即是前观胜应。及修杂想了随机化。在八九信。今令此人以妙三观。分别九品。即大本三辈。事理穷深登第十信。既云此下三观观往生人有二义。乃是修前观法行者观于九品往生之相。非是凡小求生之者。读今三辈经文改转行业。纵通此义亦是傍兼。非今增进观行意也。二释会经论二。初会论即无量寿经论。今云往生论是也。天亲所造有十七成就。至第十六大义门成就中。偈云。大乘善根男。等无讥嫌名。女人及根缺。二乘种不生。长行释云。故净土果报离二种讥嫌过。一者体。二者名。体有三种。一二乘人。二女人。三诸根不具足人。无此三种过故名离讥嫌也。名亦三种非但无三体。乃至不闻二乘女人诸根不具三种名故。此十七成就俱明彼土果报。故无二乘等悉约彼土。非是此方二乘等不得生也。恐惑者不晓。故和会解释之。分二初会二乘二。初会不生。且据彼论二乘种不生句。并于此经小戒得生。以具足戒及沙弥戒等是小乘种故。二说相违而为诘问。今以住小回心以会释之。坚住小道志趣无余。不求净土。故云正处。若回小向大转小乘业。作净土因故云要由。经就现今向大时说。是以得生。论就本始住小时说。是故不生。然论说彼土无二乘人。由在此身因转故也。二何故下释证果云。垂终回小向大方生彼国。何故中辈三品行人生彼复证小乘果邪。今释意者。回心故得生。惯习故证小。知大证小不执偏真而为究竟。不久证大也。二问论下会女人。复举论偈女人根缺不生之文。并于此经韦提侍女得生之说。而为诘问。今约彼此会释二说。论就转报。是故彼土无有女人及根不具者。若名若体。经就此土修净业者。故有善心一切得往。故大弥陀经薜荔多蠢动蜎蜚皆得往生。故知经论无少相违。二问大下会经二。初对经双问。逆罪得生即下品下生文。二释有下立义双释二。初悔有轻重。上即利根下即钝根。俱舍云。愚智所犯轻重不同。愚作罪小亦堕恶。智为罪大亦脱苦。如团铁小亦沉水。为钵铁大亦能浮。涅槃云。智者有二。一者不造诸恶。二者作已忏悔。愚者亦二。一者作罪。二者覆藏。如阿阇世王杀父害母。至涅槃会身疮肿热。生重惭愧悔过自责。耆婆劝往佛所。佛为说法得无根信。文载涅槃梵行品。此经明逆罪得生净土者。即同阇王上根利智能重心忏也。彼经不生者。下根愚人至于临终不能重悔也。二二者下约行有定散。大本就此者。指上散善力微也。此经明观者。即观佛三昧。问若定力得生下下品。云此人苦逼不遑念佛。善友告言。若不能念者应称无量寿佛。如是至心令声不绝具足十念。此与大本散心十念理应无别。答此虽造恶已曾修观故。使临终善友劝称十念。定心则成。亦是法行乘急戒缓人也。修观故乘急。造恶故戒缓。由乘急故得值善友。纵现世不修三昧。亦是宿种今熟。故得往生。所以华开见二大士说实相法。自非定善孰至此乎。故十疑论云。临终遇善知识十念成就者。并是宿善业强始遇知识等。当知作此解释方合此中定善之义。若本不修三昧之者。则属前悔有轻义也。三依品定位二。初通示九品二。初就三下示三中具九。经文显示三辈各三。二判九品属三二。初上品下约位判。虽分九品。以义定之不出三位。即内凡外凡及悠悠者。然习种解行及十信名。乃是别教地前凡位。以为今经往生位者。略有三意。一别位次第对品显故。二别具四观收机广故。三九品多判所观人故。若以九品判今能观圆观位者。则以三贤对今十信。彼之十信对今五品。悠悠即对名字人也。以名字位通修未修故。应知疏用此之三位。判九品人其意深细。不可粗心。今试略言盖一切善若能回向。皆净土因。仍一切恶若能忏愿。亦净土因。故种种善修之浅深。无非九品。其一一恶约忏功力。亦皆九品。故上上品善通下下品。下下品恶通上上品。三心六念或闻或修。未能伏惑属下三品。以此伏惑入中三品。能破二惑方预上三。如五逆罪临终十念为能消功。属下下品。阇王重悔得无根信。即是上辈三品所摄。岂非五逆随于忏功自分九品。中间七品若善若恶若修若忏。随功浅深一一皆须明于九品。若据经文下三唯恶。中下世善。中中中上即小乘行。上三唯大。疏则纯用大乘三位。判九品者。以中三品回向大乘故。下三品人依大灭罪故。故九品行一一成大。随一品行若至三贤。皆上三品。若至十信皆中三品。全未伏惑即下三品。应知经为收机尽故。故以大小善恶分其九品。盖约增胜高下互显也。大师得意乃约三位判乎九品。则何机不摄。何行不深。乃由妙解大小观行善恶之业全修即性。一一具于四种净土。但能回向随功能显四种乐邦。如是说者。多约一行随功浅深历于九品。亦自有人节节改行历于九品。若以三位定其高下。改与不改皆悉不滥。问今十六观既是圆修。为一一观皆通九品。为须节节改观入品。答虽俱圆观。而所托境随其宜乐有改不改。合有二途。若就现文。多从改观历于九品。以初心人虽了根尘皆是法界。而心想羸劣胜境难观。是故如来设异方便。先观落日于西定心。疏云。除五逆罪下辈自论。故知妙观想落日成当下下品。次以三观想水结冰。合在下中。转想琉璃粗见彼地可对下上。若得三昧见彼宝地及宝树宝池。虽五品初而五住圆伏。名得三昧。品当中下。总见依报五品中心合当中中。华座观成五品后心即中上品。此之三品虽成三昧能伏五住。见惑未断事识犹存。未可即观胜妙身相。故修三观观于宝像。像想现前见思俱尽。所以尽者。以事定力深能伏思。见断即登圆第七信。即上下品。事识既尽。全依业识可观三圣真法之身。及普观成在八九信。即上中品。故难思相法界光明。十方佛事悉能洞见。后修杂观及三辈观成。当第十信。即上上品。内外尘沙任运除尽。故随机应相。及差别行业观察明了宣示无穷。此约修者从微至着。三圣观成后修杂想及三辈观。故当如此。若观胜相不成就者。始依杂观观丈六身。此人或在下。之三品。或沾中辈。今观九品。必能进功从劣观胜求预上流。是故疏云。令识三辈往生。舍于中下修习上品。此从节节改观次第入品。如是说也。有因改观超品位者。不可定判。此上皆从次第改境修观者说。其不改者十六境中宜乐何境。即用妙观修之不舍。乃从名字修成观行。入相似位历乎九品。然十六中佛境最宜。从劣观胜成于九品。故疏令观释迦毫相。以为初心入门之渐。杂观令观一丈六像。经虽不云从一相入。据理合然。若般舟经则从足下千辐轮相。次第上观至顶肉髻。故知但解今家住前三位以判九品。于境于行改与不改。次比自成也。非独今经九品如此。法华五品其义亦然。解一千从矣。二何以下以经验。以无生忍位在别圆初地初住。非别十向圆第十信。何能见佛便登此位。上上既尔诸品例知。复以造罪验下三品。以别圆教内外凡位不造众恶。既约罪说。知是未入外凡人也。类此似尔者。经不明示。故以得悟及造罪等。比类验之。此乃大师尊经谦己。近人判解不逊者多。二别明上三二。初上品下约三位定。上以三品判于九品下至悠悠。今则别明上辈三品。故约种性以分三位。璎珞经明六种性。一十住习种性。二十行性种性。三十向道种性。四十地圣种性。五等觉性六妙觉性。问今此上品是出假位。合在秽土利益有情。何故求生净土邪。答大论四十三正有此说。故彼问云。菩萨法应度众生。何以但至清净无量寿佛国土中。答曰。菩萨有二种。一者有慈悲心多为众生。二者多集诸佛功德乐多集功德者。至一乘清净无量寿国土。好多为众生者。无佛法众处赞叹三宝之音。故知一等断惑菩萨而好乐不同。故有二别。又论第四十五云。菩萨有二。有先自成就功德。然后度众生。有先成就众生然后自成就功德者。故知今十向菩萨求生净土。乃是先自成就功德人也。故十疑论明未得无生忍已还要须常不离佛故须求生。二一得下约二义求。上上生已即悟无生法忍。上中经七日得不退转。上下经三。小劫住欢喜地。得无生忍证念不退。即欢喜地也。四随文解释三。即十六中后三观也。疏前标云。此下三观观往生人。若但读文不名为观。必须览经所诠之相入一念心。用空假中微妙之观。照于心性本具净土因缘果报。生佛咸然三无差别。诸佛净土因果已满。能应众生。众生由具净土因果。能感诸佛。感应缘起不一不异。一一融妙相相宛然。随品随功感佛感土。观之不已。则难思俗谛净土因缘自然明了。明了之位大判有三。若相似明当上三品。若观行了即中三品。名字观解属下三品。论断伏等虽有高下。而皆了知一切善恶回向忏悔。皆通九品。或共不共或超不超。或改不改或进或否。状类万差难以言具。若不尔者。岂得名为观于三辈往生人邪。初第十四上品生观三。初上品上生二。初分科。二随释三。初标。二释四。初明生因。经有二段。初段既云发三种心即便往生。知此三心是一人发。次段乃云复有三种众生当得往生。据此合是三人各修成三种行。然修之在人。或别一行或兼余行。或具足修。但能位至别教道种圆第十信。即得名为上品上生。言至诚等三心者。此与起信论中三心义合。彼云。一者直心。正念真如故。二者深心。乐集一切诸善行故。三者大悲心欲拔一切众生苦故。今初至诚疏以专实释之。非念真如。岂名专实解于深心。疏虽三义而不相舍。求高深果须契深理。欲契深理须厚乐善根。此乃立行依理求果也。二经证成三种深义。不出彼论乐集一切诸善行也。经回向发愿心疏虽不解。义当彼论大悲拔苦之义。盖以真如实念趣果善心。二心功德善巧回向。愿生净土速证法忍。广拔一切众生苦恼。然此三心顺于三法。何者。初念真如平等一性。次二即是自行化他二种修义。既是修二性一。乃就圆融三法而发心也。今此三心一念中修。见思尘沙任运先去。入第十信。故当此品。若此三心但能圆伏即中三品。若全未伏当下三品。文在此中义该下八。经慈心不杀具诸戒行者。以无缘慈不害物命。知性离非心具诸戒。读诵方等者。随文成观也。修行六念者。涅槃疏云。前三念他后三念自。戒施是自因生天是自果。戒是止善施是行善。天有近果远果。远即第一义天也。安心下释念义。谓念同体三宝一心戒施第一义理。悉不为二边所动。故通名念。经回向发愿等者。总论不杀等皆须善巧回向。愿生净土。证无生后广度含识。经具此功德者。或全或分皆得言具。一日乃至七日即得往生者。上一一行修之成就。至道种位长时弥善。下至七日或唯一日。皆得预于上上品生也。此等悉须约于断伏及全未伏。分下八品。若不尔者。岂令初修六念等人。三惑尚炽便登极品邪。须知九品难将法定。只可随功。此去科节经疏分明。钞不标也。上品中生明生因云不必受持方等经典善解义趣等者。是义持人不乐读诵。但于经中取一句偈深穷旨趣。于绝言思深广之理。心不惊动。又复其心安住中道。不为二边之所惊动。了达因果皆是实相。名为深信。虽不遍习或闻大教赴机异说。知显一理不生疑谤。此一种因亦通九品。但今此观位至圆教八九信位。故当此品。若第一义解全未伏惑。只在下品三品摄也。如常不轻不专读诵。但以一句礼拜授人。深知义故多年不懈。此以第一随喜品行。始从名字历于五品至六根净。故知读诵等四品行皆可从于名字修之至六根净。若证分真无偏修者也。生后利益中。疏云名之深妙精进等者。以闻众声说第一义。能成趣理不思议观。既顿泯绝情尘微碍。是故进趣其疾如风。比余事行杂而且滞。故此精进最称第一。疏牒阿耨不退。释云道种菩提等。以阿耨多罗三藐三菩提翻为无上正等觉。斯是行人心之本性所求之果。于此不退其位有三。若破见思名位不退。则永不失超凡之位。习种性也。伏断尘沙名行不退。则永不失菩萨之行。当性种性及道种性也。若破无明名念不退。则永不失中道正念。圣种性也。上中生者此土已得性种菩提。到彼一劫始得无生圣种不退。今于七日所得菩提不退转者。义当道种菩提不退也。通名地者凡圣所依皆名地故。四种授记一往现前者。净名大疏出四受记。谓未发心记密记现前记无生记。言一往现前者。以现前记通于凡圣。今无生位。佛就一往通名现前耳。上品下生亦信因果不谤大乘。同上中品故名为亦。彼以解了第一义谛而为别行。此以但发无上道心而为别行。究理摄生标心虽异。从凡入圣历位无殊。谓依无作四谛妙境。发四誓愿名为真正发菩提心。未度苦者誓令得度。阴入皆如故。未解集者誓令得解。尘劳本净故。未安道者誓令得安。即惑成智故。未证灭者誓令得证。即生成灭故。发此道心亦通九品。名字中发自有静散。即下三品。观行五位即中三品。相似既分三般种性。即上三品。今习种发故当此品。此心深运分真可阶。岂不能至上上品邪。约位判之无法非九。生后利益中。经虽见佛身。于众相好心不明了。于三七日后乃了了见者。以此品人位当习种。见思虽破尘沙未除。故于众相心不明了。过三七日。进入性种侵断尘沙。故八万相一一分明。自此三劫游历十方。供佛闻法进入道种。登于初地。此地即得百法明门。言百法者。如百法论所出名数。今于此法皆证三谛。乃以百法而为明达三谛之门。三谛若明。则了一切。是故论云。增长智慧思惟种种法门义。明此义故心大欢喜。故名欢喜地也。中品上生明生因中。但言众戒。斯乃略举三学之初也。若据生彼闻赞四谛。便成罗汉三明八解。以果验因不专持戒。合修小乘理观事禅。但未证果犹在贤位。于临终时闻赞方等。回心向大愿生净土。然回向心须至别教七信已上圆教观行四五二品。方是中品上生人也。若其小行已至忍位及世第一。但案位回即当此品。若在暖顶及外凡者。须猛利回超入此品。大约小乘并世间善。从回向心深浅高下判于九品。生后利益疏二。初正释经文。四谛者。既是共二乘行。由宿习故而闻生灭无生二种四谛也。生灭者。苦则三相迁移。集则四心流动。道则对治易夺。灭则灭有还无。无生四者。苦无逼迫相。集无和合相。道不二相。灭无生相。次三明者。过去宿命明。现在漏尽明。未来天眼明。此三名明。复得名通。余三但得名通者。婆沙云。身通但是工巧。天耳但是闻声。他心缘他别想而已。是故非明。宿命知过去苦生大厌离。天眼知未来苦生大厌离。漏尽正观断惑。是故此三称明。大论问通明何别。答直知过去等名通。知过去等因缘行业名明。次释八解脱。一内有等者。内色即内身骨人也。为修八色流光故存骨人。欲界结使难断故。以不净心观外色也。位在初禅能脱自地及下欲界。二者下位在二禅。二禅内净故坏灭内身骨人。欲惑难断。故犹观外不净之相。三者下除外不净相。但于定中练八色光明。清净皎洁故名净也。住在三禅。四空处者。若灭根本四禅及三背舍等色。一心缘无边虚空而入定。即观此定依阴入故有。无常苦空虚诳不实。心生厌背而不受着。五识处者。若舍空缘识入定。即观此定虚诳不实。而不受着。六无所有处者。若舍识缘无所有入定时。乃至而不受着。七非非想处者。若舍无所有处缘非非想入定时。乃至而不受着。八灭尽等者。背灭受想诸心数法也。诸佛弟子患厌散乱心。欲入定休息以涅槃法安着身中。故云身证而想受灭也。前三等者。位在色界能离自地五欲也。中四等者。位在无色界皆展转离下地。然前三亦离下。中四亦离自地。互现说耳。后一可知。亦名下背舍因称解脱果名。二释会下释诸疑妨三。初会小乘不生疑。疏与释论取法华意会于今经及往生论。论云不生。据决定性。入无余者。今经云生。是退菩提。取小乘者。疏前会云。正处小行不生要由垂终发大心故生。若无宿种。岂能垂终回小向大。故知与前义不相反。仍释伏疑既因回心向大得生。何故至彼却证小果。故释云。无漏道熟等。以退大既久习小功深。是故彼佛称习说小且令证果。或接下再出经论引小之意。今经释论说至彼土证小果者。意欲别接小乘求生。其若生已。咸慕大乘必不证小。然虽出此意前义为正。二中品下释中不及下妨。以下下品生彼闻法。应时即发菩提之心。中上生彼何故只证无学果也邪。以大小故难第四品不及九品。解云下以登地速而为答也。中上顺习虽证小果。不逾十劫必入初地九品恶重十二大劫。方得出胎。虽发大心更经多劫。方阶法忍。故以速证比彼为胜。三大本下通中不出家难。彼明中品云虽不能行作沙门。故云不明出家。长时始终者。谓尽形出家者。就短时者。谓一日一夜也。是知若据短时大本约义亦有。若论长时此经约说亦无。此乃二经事同也。中品中生修因中。疏云十戒者。释经持沙弥戒也。金银生像者。南山云。胡汉二彰。谓胡言生像此翻金银也。善见云生色似色。似即像也。此谓金则生是黄色银则可染似金。故云生像。若尔生像此方之言何谓胡语邪。答谓五竺之北胡地言音有涉汉者。故谓生像胡人重译又却入汉。故存胡音。中品下生修因中。经云孝养父母行世仁慈。此凡夫善不能伏惑。岂预中辈。疏前判位中辈人常别教十信。即圆五品。斯由垂终善友广说阿弥陀佛随顺本性取极乐国。及谈法藏称理发愿。行者闻已解悟大乘。发回向心求生净土。经虽不云发回向心。既闻广说岂不回心。特是影略。临终发心心猛利故。能入别圆外凡初位。通伏顿伏。故令世善当此品位。大师唯就大乘三位对于九品。深有其致。生后利益中过一小劫成阿罗汉。问到彼证小皆顺本习。今此行人本习世善。是人天因非声闻行。至彼那得阿罗汉邪。答孝养仁慈大小基址。何教不谈。而其阿含偏论此善以果验因。是依三藏行孝顺等。虽行世善心在无常。既久标心无漏道熟。故证小果。第十六下三品人造罪轻重值缘得灭。为往生因。须知经意为易解故。以三业等恶灭。为下三品因。回向凡小为中三品因。以大乘诸善为上三品因。此乃上下互相显映为观法境。若称实观依义而说。大小善恶逐回向心随灭罪力。浅深阶位各论九品。今之三人闻法称佛。虽业障灭全未伏惑。位在名字故属下三。若灭罪心利入别圆外凡。即中三品。能至内凡即上三品。阇王悔逆得无根信。是其类也。下品上生经云虽不诽方等经典者。此品不谤显罪犹轻。至下一品云五逆十恶具诸不善。则谤经等一切恶业无不造作。故言具也。圆顿教说罪无轻重悔则皆灭。如仙预杀诸婆罗门。地狱三念知谤方等。心生改悔即生佛国。下品中生经偷僧祇物盗现前僧物者。所盗之物不出四种常住。一常住常住。谓众僧厨库寺舍众具。华果树林田园仆畜等。以体通十方不可分用故。二十方常住。如僧家供僧常食。体通十方唯局本处。三者现前现前谓僧得之物。四十方现前。如亡五众轻物。若未羯磨从十方僧得罪。若已羯磨望现前僧得罪。则属第三现前现前盗前二种。名偷僧祇物。盗后二种名现前僧物。不净说法者。但求名利非益物也。无有惭愧者。屏处为恶不。惭于天。显露为恶不愧于人。惭愧犹羞耻也。下品下生疏释修因中二。初称无下明念佛灭罪。二引大论问答二。初问云下约少时责。二是心下约猛心答。此猛利心从二缘发。一值善友二为苦逼心怖恶道耳听佛名。是故牢强至诚称念。既境胜心猛故时少功多。能超百年悠悠愿力若此二缘猛心不发。此人乃是合堕地狱也。二明利益二。初疏科。二释经二。初夫人悟道。经豁然大悟逮无生忍者。以凡夫心闻十六观。即闻即修顿入圆住。盖由了知依正应色即报即法非纵非横三一融妙。全心作佛全心是佛。能所既忘思议泯绝。三德秘藏当念顿开。是故名为豁然大悟。悟通观行及相似位。是故特云逮无生忍。显此大悟的在分真。若十六观非妙宗者。岂令当机顿入圆位。经文结益显此观门非偏非渐。信不可用事相销文。二明侍女发心。经文但云。发无上正等觉心。是何位邪。经示夫人无生忽后。别云发心验非真发。净名疏云。苦萨柔顺忍方有发义。故多约相似明发心位。名字观行亦有发义。去无生远故下得论。大段第三流通分。金光明疏云。流名下澍通名不壅。欲使正法之水从今以澍当。圣教筌罤不壅于来世。是故此下举名举益劝人修习。若不尔者。安令法水下澍不壅。疏二初总别分科。二随科解释。今经两处流通观道。初于王宫佛自嘱劝。次回灵鹫阿难备述。初文自四。初列名教持二。初阿难问二。初当何下问经名。疏云言义非一等者。经文别示三种净业十六妙观。未审以何而为总目二。初法下问持法。二如来答二。初佛答前问。观之一字心观妙宗也。极乐三圣实相圆体也。此从宗体而立此名。净除业障极至五逆。生诸佛前该于九品。此名从用总此三义即是释名。此四既圆即当教相。故示二名五章意足。信今释题冥符佛旨。二汝当下答后问。无令忘失即是念心。念心能成欲等四法。良以欲进巧慧一心。若其忘失皆不成就。佛令不忘则具五法。受持之功于兹尽矣。二举益劝修三。初明生善灭恶二。初次明下直明生见佛善。能见弥陀及二菩萨真法之身。生善极也。以深比浅何善不生。二善男下况显灭生死罪。闻名是闻慧。忆念是修慧。举闻之劣况其修胜。行者应知前无忘失。亦是忆念然属方便。今之忆念乃是正修。名同义异善须分别。二明身胜友胜二。初念佛下喻白莲明身胜。分陀利者此云白莲华。涅槃云。水生华中分陀利最为第一。显修圆观超余一切修道之人。即七方便也。二观音下类补处明友胜。二圣本修圆念佛定。今为补处。行者今修亦是此定。位虽高下所修法同。故可为友。其犹世人道术之交。岂分贵贱。三当坐下明得果起行。事相解释。菩提树下坐金刚台。此处成佛名为道场。事本表理。今观本性弥陀觉体。此体即是所坐道场所生佛家。理一义异名场名家。此理为场坐必得果。此理为家生必起行。果即分果行即真修。此观本期分证之果无功用行。欲以病行及婴儿行度众生故。修念佛观求生净土。生彼速获故云当坐。三结名下结名付嘱。经好持者。好即妙也。以不纵横绝思议心。方能受持此经章句。别文既妙。是故能持经之总名。上以三一融妙释者。意在于此此寄阿难嘱今人也。四欢喜下众闻欢喜。言三义者。一遇人。二闻法。三得果。文出大论义归此经。人既是佛。佛必具足四无碍智。谓法义词及以乐说。说观佛法离于错谬。故名清净。今遇此人宁不欢喜。法是观法。一十六门曲尽其妙。能令凡心入深三昧。离虚设故名为清净。闻如是法岂不欢喜。果即修观克获之果。韦提希等闻法即修登分真果。侍女诸天得相似果。目连阿难同佛化机。或能增道莫测浅深。各以离惑名为清净。得如是果岂不欢喜。此三相由。得果由法法由人说。彼众欢喜具兹三义。我于今日虽面不睹金容。而为妙智所被。又得闻此微妙观法。但未获果。是故阙于第三喜耳。二崛山流通二初耆山下佛步空还。前赴请时从崛山没。于王宫出。今步虚空还于崛山。二俱神通前隐后显者。前欲施化化法未成。故但密往。今宣妙观当机已益。欲使同遵此法。是故现变彰灼而还。二次阿下阿难重述。王宫机悟崛山未知。故遣重宣普令信受。阿难所述即是佛言。是以文云闻佛所说皆大欢喜。理合同前三义故喜

观无量寿佛经疏妙宗钞卷第六


观无量寿佛经义疏序

    No. 1754 [cf. No. 365]

    观无量寿佛经义疏序

        释元照述

堪忍浊土异趣群居。安养净邦上善俱会。是知棘林胎狱宜奋志以长辞。宝界金池可潜神而直往。潮音偏赞遍见琅函。海众高栖备闻青史。但以机宜殊等诱掖多门。或恒课密言。或专持嘉号。或克期系念。或洁己修斋。各赴时缘。备存众典。唯兹正观毕趣无生。信是除疑舍障之神方。长生不死之要术也。历观前古受诵尤多。逮至方今乐闻益众。忝从早岁专玩斯文。翻嗟亿劫之无归。深庆余生之有赖。然则诸师著撰各尚所宗。后进披寻莫知攸往。由是参详名理酬挍古今。摭取优长芟除繁琐。述而不作。何敢侮于前修。统之有宗。庶可贻于来学。文从简易意在修治。月藉指标见月而无劳执指。岸因舟度到岸而自可忘舟。曲被未来不负韦提之虔请。仰承遗嘱敢忘庆喜之重宣。聊赞上来冀资西迈云耳

观无量寿佛经义疏卷上

        西湖灵芝崇福寺释元照述

将释此经先列义门令知总意然后入经分文别释。初中分四。初教兴来致二摄教分齐三辨定宗旨四料简异同

初教兴来致二。初通明一代教兴二别叙今经教兴

初通明一代教兴　大觉世尊从本垂迹为欲开示众生佛之知见令其悟入。于是乘时利见而大有为焉。经曰诸有所作常为一事。唯以佛之知见示悟众生。则知出生示灭一代声教半满虽殊莫不皆使诸有凡庸自悟己心。与十方如来法界含灵体性平等无有差异。具足无量河沙胜德包摄一切世出世法。清净本然广大无际十方法界微尘刹土大地山河依正因果悉是我辈自心中物。犹如一沤浮于大海亦如片云点太清裹。即下经云。是心作佛是心是佛诸佛正遍知海从心想生。当知此心即是菩提涅槃元清净体即是大乘一实境界非他法也。故占察经曰。一实境界者谓众生心体从本已来不生不灭自性清净圆满十方究竟一相。但以众生无明痴暗熏习因缘妄现境界。令生念着计我我所。没溺生死不自知觉。我佛如来先觉此心悯诸未悟。慈悲方便演说诸经。华严顿示鹿园渐诱。归源无二方便多门。经云小智乐小法不自信作佛。又云虽说种种道其实为佛乘。或于此土破惑证真则运自力故谈大小诸经。或往他方闻法悟道须凭他力故说往生净土。彼此虽异莫非方便令悟自心洞达诸法。然后发大乘意修菩提道上求下化究竟成佛。以智慧故不住生死。以慈悲故不住涅槃。历微尘刹示生唱灭说法度生。众生无尽行愿身土亦无有尽。华严云我知十方一切诸佛毕竟无有般涅槃者。唯除为欲调伏众生而示现耳。楞伽亦云无有佛涅槃亦无涅槃佛。是谓出世大事因缘。十方皆尔岂独释迦。教法所兴在此而已

二别叙今经教兴　韦提机发净土缘兴。故使阇王公为逆害幽禁父母苦切忧愁。遥望耆山请佛求救。大悲怜愍即赴幽宫。先陈三种净福以为兼济之缘。后说十六妙观正示往生之术。今括诸文略陈十意。一为愍众生忍受众苦无由脱故。经云。若佛灭后诸众生等浊恶不善五苦所逼等。又云。为未来世一切大众欲脱苦者说此观地法。二为愍众生为业缠缚无由解故。如下经云除无量亿劫八十亿劫生死重罪等。三为愍众生烦恼障重不能断故。经云。如来今者为未来世一切众生为烦恼贼之所害者说清净业。四为愍众生福德浅薄受贫苦故。经云。但想佛像得无量福况复观佛具足身相。又云。如此菩萨但闻其名获无量福何况谛观。五为愍众生随邪背正去佛远故。经云。若念佛者当坐道场生诸佛家等。六为令众生离诸染着住清净境界故。经云。若念佛者当知此人是人中分陀利华。七为令众生心易得定故。经云。应当专心系念一处想于西方。若不定指一方则三昧难成故。八为令见身成就念佛三昧故。九为令见身见无量寿佛故(此二皆下经文)十为令众生疾成佛故。下云。心想佛时是心即是三十二相等。即弥陀经云。生彼国者皆得不退阿耨菩提。佛意幽深凡情罔测。且用十意括示大途则一经兴致咬如指掌矣

第二摄教分齐有三。初明二土立教纯杂二辨大小渐顿三简了不了义

初明二土立教纯杂二。初娑婆入道教观二净土往生教观

初娑婆入道教观　娑婆五浊惑业重轻根性差别在机既杂。教亦不纯。故有大小殊科偏圆异彻。经论宗师古今判教互有不同迭相废立广在他文不可备叙

二净土往生教观　极乐净土纯一大乘清净良伴。众生生者虽分九品莫不皆发无上道心。到彼进功皆得不退菩提妙果。故往生论云。二乘种不生。虽有声闻弟子皆是先发大心暂履权乘不住小果。是知二土立教纯杂不同。则净土诸经不劳简判也

二大小渐顿　天台疏判教相中只云此是大乘方等教摄。二藏明义菩萨藏收。渐顿悟入此即顿教。远疏亦云。此经是顿教法轮。韦提希等并是凡夫便证无生。不从小入。故知是顿准知一代弥陀教观皆是圆顿一佛乘法更无余途。慈云法师云。小乘经部括尽贝书曾无一字说有净土何况劝生。又小乘中不谈他佛亦无一字说有弥陀。是则净土弥陀一历耳根即下大乘成佛种。不闻不信岂非大失乎

三简了不了义　慈云云。佛法有二。一小乘不了义法二大乘了义法。大乘复有了不了义。今谈净土唯是大乘了义中了义法也。经曰。十方谛求更无余乘唯一佛乘。斯之谓矣。言了义者了彼净土即我自心非他方也。达彼弥陀即我自性非他佛也。如此则回神亿刹实生乎自己心中。孕质九莲岂逃乎刹那际内。故经曰。是心作佛是心是佛。即是开示众生佛之知见。大乘了义岂复过此。楞严势至圆通云。若众生心忆佛念佛现前当来必定见佛去佛不远(言成佛不久也)至若法华妙部如来亲记往生(药王品云受持此经即往生安乐世界等)华严极谈普贤躬陈回向(普贤十大愿结云临命终时一刹那中即得往生极乐世界等)即知净秽身土悉是众生自心只由心体虚融故使往生无碍。只由心性包遍遂令取舍无妨。嗟今未学不达唯心。但认点灵便为净土。自谓心净土净不假他求。佛即我心岂须外觅。指弥陀为外物。贬极乐为他邦。故慈云云。或曰净土在心何须外觅。心净土净岂用迢然求生他方净土耶。释曰。子不善心土之义将谓我心局在方寸。便见西方夐在域外。若了一念心遍一尘亦遍。十万亿刹咫步之间岂在心外。世人若谈空理便拨略因果。若谈唯心便不信有外诸法。岂唯谤法亦自谤心殃坠万劫。良可痛哉。妄构是非障他净土真恶知识也(上皆彼文)古贤苦口愍物情深。傥属意以研详必因兹而超悟矣

三辨宗旨有三。初定经宗二明事理三辨观法不同

初定经旨　宗是主义一经之主义须辨示。天台云。此经以心观为宗。此则单就能观为言也。观佛依正得非心观乎。远师善导并云。诸经所辨宗趣各异。此经以观佛三昧为宗。此则通就能所而立也。观虽十六依正不同而主在观佛。即下经云。于见身中得念佛三昧。念即是观。但语通余佛尚滥他经。可如首题简别斯尽。观佛三昧经云。佛告阿难此观佛三昧是一切众生犯罪者药。破戒者护失道者导。盲冥者眼愚痴者慧黑暗中灯。烦恼贼中是勇猛将诸佛世尊之所游戏。首楞严等诸大三昧始出生处。又云。若能观佛一毛孔是人名为行念佛定。以念佛故十方诸佛常在其前为说正法。此人即能出生三世诸如来种。何况具足念佛色身。又云。若四部弟子谤方等经作五逆罪犯四重禁偷僧祇物污比丘尼破八戒齐作诸恶事种种邪见。若能至心一日一夜系念在前观佛一相好者诸恶罪障皆尽灭等。准知观佛功德难思。良由摄虚妄心冥真实境。假彼福慧济我贫穷。藉彼慈悲拯我沉溺。是却恶之前陈为入道之初门。故楞严云。不假方便自得心开如染香人身有香气。是则名曰香光庄严。略举大要余广如后

二明事理　理是虚寂之强名事乃施为之总目。名虽两立体实一如。其犹水动为波墨书成字。波虽万状水湿何殊。字有千差墨色无二。若谓冥心住寂能所泯亡则为理观。举心动虑取舍历然即为事观。是则理事敌对。未是圆融。今依天台十疑论云。智者炽然求生净土达生体不可得。此乃真无生。愚者为生所缚。闻生作生解闻无生作无生解。而不知生即无生无生即生。不达此理横相是非。几许谬哉。是知达事即理理非事外。是真无生故称妙观。又准南山理事二忏须分两根。利根达理则一切唯心。钝根未达则专依事行。余经理观唯被上根。今经观法通摄利钝。利根修者莫非理观。钝根修者皆归事想。利钝虽异皆得往生。但生彼已阶位浅深。进道迟速耳。然古今判释互说不同。一云十六妙境无非理观。一云据经始末皆是事想。一云前后十五是事唯第九佛观为理。今谓初释则遗于中下次解则抑彼上根后说两分最非通论。夫达理者则诸法皆理安有此是而彼非乎。尝考经文但出所观之境不分理事之殊。得非能观之人根有利钝见有通塞任其分量皆可趣入乎。唐高僧辨秀尝谓人曰昔闻西方之行是有相大乘。此乃蓬心不直非达观之说。何耶夫出言即性发意皆如。而一色一香无非中道况我正念乎。细详此说深会经宗。但未悉此经通收中下耳。问今经理观如何修习。答修法有二。一者能观心即以现前识心想念为体。下云当起想念谛观于日是也。二者所观境即以弥陀依正庄严为体。即下所列十六种境是也。能所相冥方成观行。问起心取境那名理观。答了此心境皆因缘生。缘生无生体非生灭即无生理。十疑论云夫不生不灭者于缘生中诸法和合不守自性。求于生体了不可得。此生生时无所从来故名不生。此灭散时去无所至故言不灭。非谓因缘生外别有不生不灭也。今明理观一准论文。以缘生心观缘生境。心境虽殊缘生不异。能观是心所观即佛。心法佛法皆不思议。华严云心佛众生三无差别即其义也。故诸行者先开智解通达无疑。然后晨夕念念系想彼方依正胜境炽然求生不妨心境。体自无生。非谓造作使之然也。是知世出世间诸所有法出处语默莫非妙理。非唯此观一代大乘所立观法莫不皆尔。法华云观一切法空如实相不颠倒等。又云一切诸法皆无所有无有常住亦无起灭。普贤观云当知一切诸法即是佛法。净名云一切诸法即菩提相。华严云一切法无生一切法无灭。又云了知一切法自性无所有。如是解法性即见卢舍那。金刚般若云一切有为法如梦幻泡影等。如是等文遍在大藏不复尽举。若离诸法而谈妙理即堕偏邪去道全远。净名云譬如造立宫殿。若依空地随意无碍。若依虚空终不能成。诸佛说法常依二谛。不坏假名而说诸法实相。圣量若此正理坦然。必欲进修深须研核

三辨观法不同　一代时教所明观法略为五例。一总观诸法如经观一切法空等。二别观自心如止观还源观法界观净心观等。三或但观色经云观身实相观佛亦然及不净白骨等。四兼观色心经云照见五蕴空十二入十八界数息等。五对观胜境即如诸经观佛菩萨等。今此观经即当第五。就观胜境复有五别。一观佛相海即观诸佛三十二相也。二观普贤行法即观六牙白象菩萨身相也。三观药王药上即观二菩萨行愿色相也。四观弥勒上生即观兜率天宫求生内院也。五即今经观弥陀依正求生净土也。上三灭业破障下二忻愿求生。又下二中第四是娑婆天界第五即极乐净方。然此方入道要在观心。净土往生义须想佛。今举此方观心一种对校今经略为六别。一观心则摄想归心今经则送心他境。(经云一心系念谛观彼佛天台疏云落日悬鞁用标送想之方)二观心不局四仪此经则要须正坐(义通余仪)三观心则不拘方所此经则定须西向。四观心则不简余时此经则须除便食(观佛经云除便转时地观云唯除食时等)五观心则断惑证理此经则成业感生。六观心则魔业发现此经则圣德护持。略明六异则知净土观门迥然天别。问今十六观可名观心否。答若乃达境唯心则彼弥陀身土孰非心乎。但恐反求本阴局认点灵则尽属他经。非今正观矣。问或谓佛法太高众生法太广唯观心为要。今经观佛岂不相违。答观法被机各有所主。若此方入道断惑证真则观心至要。若往生净土修因感报则观佛最优。彼明断证正取观心故有此语。非谓生佛二法永不通观。观佛三昧皆被未来义非徒设。问心佛无差上乘了义。今明观法何必强分。答理本虽融行相宜别。将使造修有托必须境智相应。古德有言观佛有二。一者自心三昧所见佛。二者西方从因感果佛。诸经观心即观自心所见佛也。今十六观正观西方感果佛也。据此两分求无疑滥故。天台十疑论云凡求生者希心起想缘阿弥陀佛相好光明。又观彼土七宝庄严备如无量寿十六观等。今经观佛斯为明据。问曰经云若以色见我以音声求我是人行邪道不能见如来。今观佛境岂非色见声求耶。答曰三十二相犹皎月落于百川。四辨八音若清响发于幽谷。然有披潭捉月入谷寻声不了性空故不见佛。达士不尔。了色非色何妨端想于圣容。达声非声岂碍侧闻于妙法。故华严云色相不是佛音声亦复然。亦不离色声见佛神通力。觌兹妙论宁复疑乎

四料简异同二。初简身土通局二辨古今废立

初简身土通局二初明佛身二明佛土

初明佛身　佛身多种经论所出随宜不定。今准天台戒疏且明四身。一谓法身二谓真应二身三谓法报应三身四谓法报应化四身。彼云毗卢遍耀正法为身舍那行满报果为身。释迦应迹感赴为身随缘不定变化为身。一切诸佛皆具四身。今弥陀身者经云诸佛如来是法界身即法报也。六十万亿那由他即净土应身也。或现大身满虚空中。或现小身丈六八尺及圆光中恒沙化佛。又云无量寿佛化身无数以至白鹤孔雀凫雁鸳鸯等皆是弥陀变化所作此等皆化身。然此应化合则为三开则成四。当知西方弥陀果德之身。即是法身即是报身即是应化佛身一体非一非异随召皆得。若乃从本垂迹则一身为无数身。至于摄末归本则无数身还归一身。华严云一切诸佛身即是一法身即其义也。远师疏云然佛寿命有真有应。真无有尽应有短长。观音受记经云阿弥陀佛寿虽无量当有终极般涅槃后观音补处号普光功德山王。据此定知是应。十疑论云有满凡夫随分得见佛身粗相谓应佛也。菩萨见微细相谓报佛也。故知报应由机佛身何定。如水中月随器不同。器大则影全器小则影缺。全缺在器而影无展缩。水澄则影存水浊则影亡。存亡在水而影无去来。以喻身寿无不通晓。故涅槃云佛告纯陀。汝今不应思惟诸佛长寿短寿。一切诸法皆如幻相。如来在中以方便力无所染着等。又华严云如来法身藏普入世间中。虽在于世间于世无所著。譬如清净水影像无去来。法身遍世间当知亦如是。又云譬如工幻师示现种种事。其来无所从去亦无所至。幻性非有量亦复非无量。于彼大众中示现量无量。以此寂定心修习诸善根出生一切佛。非量非无量有量及无量皆悉是妄相。了达一切趣不着量无量。准知佛身体量叵得。尚非言思所及。岂容拟议于其间哉

二明佛土又二。初正明二拣滥

初正明　诸佛国土其数无量。如华严云。不可说不可说佛刹微尘数世界。又如法华云。譬如三千大千世界摩以为墨。过于东方千国土乃下一点。如是展转尽地种墨等。又如弥陀经。十方各有恒河沙数诸佛国土。是知佛土何有穷尽。举要言之不出二种。一者法性土。圆觉云众生佛土同一法性。普贤观经云毗虚遮那遍一切处。其佛住处名常寂光。常住法性诸佛如来所游住处强名为土实非土也。此谓唯心净土。举足道场非净非秽而不妨净秽。无去无来而不碍去来。慈云云十方净秽卷怀同在于刹那。三际往来足迹未移于一念。众生迷而不失虽日用而不知。诸佛证而无得故乘权而起用。此唯妙觉果人所居。仁王般若云唯佛一人居净土即此土也。二应化土。微尘佛刹若净若秽皆是诸佛随机应现摄化众生。应诸菩萨则有实报土。仁王云三贤十圣住果报是也。应诸二乘则有方便土。智论云三界外有净土。声闻辟支出生其中受法性身非分段生是也。应诸凡圣则有同居土。同居有二。一同居秽土二同居净土。释迦现居秽土非无净土。弥陀示居净土非无秽土。然同居秽土圣则大小三乘凡通善恶六趣。同居净土圣则纯一大乘凡但人天。两报土明诸土各赴机缘。法性是所依应化为能依。首楞严云空生大觉中如海一沤发。有漏微尘国皆依空所生。大觉即法性土也。微尘国即应化土也。应化依虚空虚空依法性。能所本末思之可见。今经所明即是弥陀所取同居净土。又复西方有河沙净土。果佛有同居弥陀。今须定指。往昔法藏发愿修成极乐净土弥陀果佛光台现土其致在兹

二拣滥　诸经所说净土多种名字相滥故须辨示。且如心净土净之言人虽引用不知本末。此言本出维摩经。彼说菩萨取净土法。以诸佛净土必假十方众生同业共成故。历劫化他令修善业。揽彼净业以成其土故。彼经云菩萨随所化众生而取佛土。当知直心是菩萨净土。菩萨成佛时不謟众生来生其国。乃至十善是菩萨净土。菩萨成佛时十善众生来生其国。乃至云若菩萨欲得净土当净其心。随其心净则佛土净。彼文甚广不复具引。金光明云愿我来世得此殊异功德净土如佛世尊。法华经云教诸千亿众令住大乘法而自净佛土。又云少欲厌生死实自净佛土。净名云常修净土教化诸众生。此等皆明菩萨取土法也。又净名经螺髻梵王语舍利弗。我见释迦佛土清净如自在天宫。佛以足指按地。大千世界百千珍宝严饰如宝庄严佛净土。乃至云我佛国土常净若此。又涅槃经佛临涅槃娑罗林间变成净土。经云尔时大千世界以佛神力故地皆柔软。众宝庄严犹如西方无量寿佛极乐世界。又如今经光台所现极乐净土及结益中众见彼国。此等皆是如来神力现起。所谓于一毛端现宝王刹是也。仁王般若云唯佛一人居净土。圆觉经云众生国土同一法性。地狱天宫皆为净土。此皆法性理土所谓寂光土也。法华云众生见劫尽大火所烧时我净土不毁。此即释迦果报土也。上引诸经所谈净土皆非今经弥陀极乐净土。诸经论中此类极多。准前简判则无滥矣

二辨古今废立分五。初明福观二辨定散三示地位四解魔说五指滥传

初明福观　下经韦提请云唯愿世尊教我思惟教我正受。古疏以三福答思惟。十六观答正受。善导玄义云诸师将思惟合三福正受合十六观。今谓不然。华严经说思惟正受但是三昧异名。韦提前请但云教我观于清净业处。即知思惟正受秖是请观耳。观前方便故曰思惟正观成就故名正受。但修观之人须修福业助成观智故。先明三福后出观行。三福如宝货观智如船桅。是则事理相资福智双运。安有修观兀然端坐。不事师亲不持归戒不诵大乘耶。故须众善辅成正观。单轮只翼何有所至哉。至后释文更为委辨

二辨定散　善导玄义云前十三观为定善。后三福九品对前三福为散善。今谓不然。若如所判。即应止有十三观那名十六观耶。况下九品上品结云是名上辈生想名第十四观。中下亦然。何得后三独名散善。止用此求不攻自破。依法不依人涅槃极诫。至后九品当更辨之

三明地位　准玄义云古来诸师皆用大乘三贤十圣。对上三品小乘两凡四果对中三品。大乘始学凡夫随过轻重对下三品。彼文委破不复具引。今谓准下九品生彼土。已方论地位可如诸师。又据经文此土求生并是凡夫须依玄义。彼引十段经文为证。可验昔非。经云我今为汝广说众譬。亦令未来世一切凡夫欲修净业者得生西方一证也。又云如来今者为未来众生为烦恼贼之所害者说清净业二证也。又云如来今者教韦提希未来众生观于西方极乐世界三证也。又云韦提白佛言因佛力见彼国土若佛灭后诸众生等浊恶不善五苦所逼云何当见彼佛国土四证也。又云汝及众生应当专心乃至自非生盲有目之徒皆见日没五证也。又云佛告阿难汝持佛语为未来世一切大众欲脱苦者说是观地法六证也。又云韦提白佛我今因佛力故得见彼佛及二菩萨未来众生当云何观七证也。又云佛告韦提希及汝众生欲观彼佛当起想念等八证也。又云诸佛如来是法界身入一切众生心想中是故汝等心想佛时九证也。又如九品中一一皆言若有众生等十证也。上来十段证明如来说十六观止为常没众生不于大小贤圣人也(上并玄义中文)详此十文一二四五其文最要。则知此典专被浊世具缚凡夫逮至彼方始论断证耳

四解魔说　或谓修西方净业临终感相皆是魔者。斯由未披教典不乐修持。喜以邪言障他正信。为害不浅故须辨之。且魔有四种。一五阴魔二烦恼魔三死魔四天魔。上之三魔是汝身心。唯有天魔居欲界天。乃是大权退恶进善。有大功行方可动之。凡夫修道内心不正必遭魔扰。若心真实魔无能为。是知魔自汝非他所致。如世妖治媚惑于人端心正色必不能近。纵情顾盻定遭所惑。今引众说以绝群疑。一云大光明中决无魔事。犹如白昼奸盗难成。一云此土观心反观本阴多发魔事。今观弥陀果德真实境界故无魔事。一云念佛之人皆为一切诸佛之所护念。既为佛护安得有魔。一云修净业人必发魔者佛须指破如般若楞严等。佛若不指则误众生堕于魔网。今净土诸经并不言魔。即知此法无魔明矣。山阴庆文法师正信法门辨之甚详。今为具引。彼问曰或有人云临终见佛菩萨放光持台天乐异香来迎往生并是魔事。此说如何。答曰有依首楞严经修习三昧。或发动阴魔。有依摩诃衍论修习三昧或发动外魔(谓天魔也)有依止观论修习三昧或发动时魅。此等并是修禅定人约其自力。先有魔种被定击发故现此事。傥能明识各用对治即能除遣。若作圣解皆被魔障(上明此方入道则发魔事)今约所修念佛三昧乃凭佛力。如近帝王无敢干犯。盖由阿弥陀佛有大慈悲力大誓愿力大智慧力大三昧力大威神力大摧邪力大降魔力天眼远见力天耳遥闻力他心彻鉴力光明遍照摄取众生力。有如是等不可思议功德之力。岂不能护持念佛之人至临终时令无障碍耶。若不为护持者则慈悲力何在。若不能除魔障者智慧力三昧力威神力摧邪力除魔力复何在耶。若不能鉴察被魔为障者天眼远见力天耳遥闻力他心彻鉴力复何在耶。经云阿弥陀佛相好光明遍照十方世界念佛众生摄取不舍。若谓念佛临终被魔障者光明遍照摄取众生力复何在耶。况念佛人临终感相出自众经皆是佛言。何得贬为魔障乎。今为决破邪疑当生正信(已上彼文)。又楞严云禅定心中见卢舍那踞天光台十佛围绕等。此名心魂灵悟所染。心光研明照诸世界。暂得如是非为圣证。资中疏曰若修念佛三昧斯境现前与修多罗合名为正相。若修余观设见佛形亦不为正。以心境不相应故。况观真如不取诸相而有所著岂非魔耶。资中栋判极为精当。仍具引前诸说永除疑障

五指滥传　净土教法起自古晋庐山白莲社。自后善导怀感慧日少康诸名贤逮至今朝前代禅讲宗师亦多弘唱。唯天竺慈云法师精穷教理盛振一时。出大小弥陀忏仪往生传正信偈念佛三昧诗并诸图[巾*((宋-木)/登)]见行于世。自后鲜能继者。时移事变相承讹滥斯法几息。纵曾听习臆说最多。苟不辨明恐误来学。略引数事识者详之。此方儒典亦说西方如周书异记说。佛生时瑞气浮空。太史苏由奏曰有大圣人生在西方。一千年后声教被此。后佛灭时白虹十二道南北通贯。太史扈多奏曰西方大圣人入灭之兆。又列子云昔商太宰嚭问孔子执为圣人。孔子对曰西方有圣者焉。不治而不乱不言而自信不化而自行等。文中子曰佛法西方之教中国则泥。以至后世儒者多以佛教为西方者乃此土西天竺国非今经所谓西方也。试略言之。夫一日月一须弥一四天下名一世界。如此一千世界名小千界。一千小千名中千界。一千中千名大千界。此释迦一化之境。今此南阎浮提乃一世界中一洲耳。此土神州又州中一隅耳。五天竺国当阎浮之中。神州在彼东南。以此望彼故号西方。若论弥陀净土。出大千界外复过十万臆刹。智者云西方净土出过三界。即知与此阎浮西竺近远天别安可滥同。窃观古今不信净土其障有二。一为他障二即自障。言他障者谓世传异说不辨是非。故于佛言反不信受。略列数条余非可尽。如僧传慧布云。方土虽净非吾所愿。若使十劫莲华中受乐不如三途极苦处救众生也。今谓得忍菩萨可容此说。若未得忍自不能救焉能救他。智度论云具缚凡夫有大慈救众生者无有是处。委如十疑论第一疑中所破。有人云心若清净即是自性西方何必求生他方净土。今谓非无此理。斯乃教中法性理土而非今经所明也。然具缚凡夫未登忍地。假令顿悟自心孰能恒守清净。法虽高妙不摄群机。但有虚言何由造入。又云西方去此十万八千里。此亦误以四竺为西方也。经云从此西方过十万亿佛土有世界名曰极乐。岂止十万八千乎。略指一端。诸余不足议也。有人云此十六观唯被下根耳。今谓此经乃圆顿上乘成佛之法。是心是佛出自今经。韦提一闻即破无明得无生忍。五百侍女发菩提心。岂皆下根耶。又云念佛人临终感佛菩萨来迎。皆是自心业现实无他方佛来。今详此说乃有多失。一则不信佛语。观经九品临终感相皆佛说故。二不修佛力。诸佛菩萨慈悲誓愿拔苦与乐不遗物故。三不信佛体。佛与众生体性平等有感必应。佛若无应三身不备则非佛故。此三不信孰可信耶。又有人云莫学愚人求生净土。今谓无量寿经说十方诸菩萨皆愿往生净土。况普贤行愿势至圆通皆愿往生净土。补处不退诸上善人岂皆愚人耶。又僧传所叙古晋高僧生融持远南岳天台庐山十八贤皆修此法。岂亦愚人耶。汝今滞着三界耽恋五浊。甘受众苦无思出离。反是智人。一何颠倒。假令自得忍力乐住三界度生。那发此言障他修习。又云求生净土念佛修观皆是执着取相殊非超越之法。今谓着与不着取与不取在人心智所见明昧。岂得凡见修持例皆着相于恣不捡尽是通人。且佛言不着相者盖令不着我人众生寿者等相不住所修法相遣除人法二执即达人法二空。何尝以系念进修而为着相乎。且世人争竞我人炫耀权势。耽荒声色奔逐利名。聚敛财谷系恋妻拏。此等诸相无始爱缠佛劝远离反更深着。念佛三昧无始未经。佛劝修习反疑着相。众生迷倒一至于此。今谓若修念佛三昧定非着相。何以然耶。佛身无相有何可着。故智论云植佛福田者谓慧心坚着也。随以香华供养至佛无尽。龙树论师岂不解般若。而言坚著者岂亦着相耶。夫般若空法元为修六度者令不住相。六度不修般若焉用。真得道者达修无修了念无念。所谓终日修而未始修。终日念而未尝念。金刚般若云无我人众生寿者修一切善法则得阿耨菩提。故知了达之士何尝不修善耶。又有说云临命终时若见幢幡莲华等境界现前并不得去。今谓临终境现自有正念善业所感。亦有邪心造恶所招。岂得一槩斥为魔事。况恶相既现任运业牵岂由汝意愿去不去。如人造业合堕三途临终恶现何由不去。故知谬传。不足取信。有人发愿云愿从今生至成正觉未得道前。身无横病寿不中夭。正命尽时不见恶相。长得人身聪明正直。不生恶国不值恶王。乃至所生之处值佛闻法童真出家为僧和合。今谓若生净土则无横病夭寿恶国恶王之患。任运常值三宝出家为僧。只由不知净土故有此愿。亦犹陈除陵愿云。愿即还人中不高不下处托生等。彼乃儒流不在言责。禅讲宗师率多此见。皆言但愿后世不失男子出家学道。尝试语曰汝今已得男子出家。秖合便求出离。何乃复求男子再愿出家略无胜进乎。二自障者略说六种。一云净土难生吾无力量非敢过望。但不失人身足矣。一云吾毁戒破齐恶业深重。西方净土何由可生。一云佛说西方权诱众生且念为善。皆无其实。见修净业反生嗤笑。一云聪明利智直悟己心。任己所为无非合道。岂同下士念佛修行耶一。云凡人之生血气所聚假名为身。及乎死去百骸溃散一切归空。何有净土是可生耶。一云临终作想夺彼胎阴刹那换报不历胞胎。今谓色心报法宿业所成。安有我神能夺他报。窃恐识神灵妙先托彼胎。报谢趣生即非他阴。假令可夺作想劳神求入胞胎未知何意。违出家志背解脱门。而况我佛大慈开示净土。殷勤观嘱遍诸大乘。目见耳闻特生疑谤。自甘沈弱不慕超升。如来说为可怜愍者。良由不知此法特异常途。不择贤愚不简缁素。不论修行久近不问造罪重轻。但令决定信心即是往生因种。慈云法师云唯安养净业捷直可修。若有四众欲得速破无明永灭五逆十恶重轻等罪当修此法。欲得大小戒体还复清净。得念佛三昧成就菩萨诸波罗蜜当学此法。欲得临终离诸怖畏自心安快。众圣现前授手接引初离尘劳。便至不退不历长劫即得无生当修此法等。古贤法语能无从乎。已上五门略标纲要。自余不尽委在释文。按开元藏录。此经凡有两译。前本已亡。今本乃疆良耶舍译。僧传云疆良耶舍此云时称。西域人性。刚直寡嗜欲。善通三藏。宋元嘉初达于京邑。文帝深加叹异敕止钟山道林精舍。僧含请译此经并观药王药上经。含即笔受。后游岷蜀还卒江陵。又前代解释凡有数家。隋朝慧远法师天台智者大师皆有章疏。唐善导和尚亦立玄义。并行于世。而各尚宗风互形废立故。今所释择善从之。必有差讹不无纪正

观无量寿佛经义疏卷上终观无量寿佛经义疏卷之中

        刘宋西域三藏畺良耶舍译

        西湖灵芝崇福寺释元照述

第二别释经文二。初释经题二释经文

初释经题　据经下文阿难请问佛立二名。初云此经名观极乐国土无量寿佛观世音菩萨大势至菩萨。加一经字共二十字。此就心境为名也。又云亦名净除业障生诸佛前。更加经字共有九字。此从破障感报为名也。就初名中观之一字能观智也。下十八字所观境也。极乐国土即是依报摄前六观。无量寿下即是正报摄后十观。观佛总前三观。下二菩萨总摄七观。故此一题十六皆足。次名中净除业障总前十六观行力用。观成破障即见因也。生诸佛前即来果也。不指弥陀而言诸佛者即下经云见无量寿佛者即见十方无量诸佛等。今翻译家止用初名仍从省约。但据诸佛深合经旨。天台疏云举正报以收依报述化主以包徒众。观虽十六言佛便周。此约举要包摄前后释也。远师疏云此经以观佛为主故偏举之。此据经宗诸观相从释也。今详两释后义最长。以正为观佛须先国土以为由渐后因观佛旁及徒众以显周遍。是以佛观文中独名念佛三昧也。题中上七字为别题别在今文。下一字为通题通及众典。上二字标能说教主。下五字示所说行法。初能说中佛是十号之一。说谓悦可众心。此方化主定是释迦故但举通号。下所观境恐滥余尊则通别齐举。准智度论云经通五人说。一佛二圣弟子三诸仙四诸天鬼神五变化人。欲显此经是佛自说简非余人令生信受。然一代时教律唯佛说特彰秘胜。经通余人但须印可。然就经中净土一法定是佛说明非小圣余凡所知。是以他经或容不着。诸净土经并须标简。二所说法中上一字即能观心。下四字即所观境。初中大小观法并指第六意识为能观体。五阴之中善行阴摄。行前三心体唯无记。必取行心成业方能感报招生。准下经文或名想念或号思惟。名异体同莫不皆指意思为能观耳。次所观中梵云阿弥陀。此翻无量寿亦云无量光。即四十八愿中二愿光明寿命有能限量不取正觉。寿即表福是解脱德。光即表智是般若德。般若解脱共严法身。即同居净土摄生教主。观音补处实有寿限且据凡小莫数故言无量。佛者具云佛陀此翻觉者。觉有二义。一觉察义。四住如贼唯圣觉知不能为害。二觉悟义。无明如睡圣慧一起如眠得悟。对彼二乘故名大觉。超彼等觉故名妙觉。且据一相余如别说。身相光明具如佛观。经者梵云修多罗此翻为线。贯穿理义摄持众生。能贯能摄有如线焉。即能诠教声名句文。由教知理依理起行因行感果。理行果三出生于教。故知像末唯教有功。得道因缘出道基本。古人诃呰为遣滞情。末学妄痴妄生轻蔑断佛种子坏佛法身永坠邪坑长遭难地。纵使执指为月认筏为堤亦为解脱远缘不失人天福报。况超拔为利叵穷。古疏又云训法训常。由圣人金口故云经也

二释经文　经文为三。即序正流通三分。从初至清净业处为序分。尔时世尊放眉间光至无量诸天发无上道心为正宗分。尔时阿难白佛当何名此经下尽末文为流通分。三分判经弥天为始。或多或缺随经不同不必一槩

初序分二。从初至而为上首名证信序。六事同证使无疑故。尔时王舍下名发起序。法不孤起假缘发故。亦名通别二序。证信通于众典发起别在今经。又证信文通而义别。如是等法局指当经。发起文别而义通。众经之首皆有因缘。又证信结集方安名经后序

初证信序六　一如是者即指正宗所说之法。二我闻者阿难亲从佛闻明非自说。三一时者始从众集终至毕席一期之时简非余时也。四佛者说教之主显非余人。五王舍城下说经之处。六大比丘等同闻之众。初指正宗所说法

如是　称理云如离非曰是。决定可信故云如是　二明非自说

我闻　诸法无我无我则无闻。随俗假名故说为我　三简非余时

一时　如来说经时有无量不可定指故云一时。又西土此方年月日时历数不同。流布他方人难晓故。又复诸经或有一席未能终毕。至后结集方缀成文。前后不一。难为标指即如今经阇王造逆如来说经阿难重述岂是同时。故以一言包罗斯尽　四说教主

佛　佛翻为觉自觉异凡夫觉他异二乘觉满异诸菩萨故名大觉。即指开示净土释迦大师也　五说经处二。初游化境二依止处。初游化境

在王舍城　梵云罗阅只伽罗此云王舍。智论所解。古王创置从本为名。即王所居之处　二依止处

耆阇崛山中　耆阇崛此翻灵鹫。诸灵依此而住。又峰形似鹫或众鹫所栖因以为名　六同闻众二。初声闻众二菩萨众。初声闻众

与大比丘众千二百五十人俱　若论志愿则菩萨为先。今取威仪故声闻居首。声闻又二。大比丘即上首弟子迦叶阿难目连身子等。大之一字即是叹德。梵云摩诃此翻为大多胜。人天所尊故言大。遍解经书故云多。超出异道故言胜。因名比丘有三义。乞士怖魔破恶也。果号阿罗汉亦三义。应供杀贼无生也。梵语僧伽此翻为众。四人已上和合无诤。羯磨说戒能辨一切灭恶生善之事故名为众。千二百五十人即眷属弟子。三迦叶共有弟子千人。目连身子共二百五十。其先并是事火外道。久受勒苦都无所证。一见如来便登圣果。感佛恩深故常随侍。二菩萨众三。初示位二列数三略标上首　初示位

菩萨　梵云摩诃菩提质帝萨埵此云大道心成众生。虽名含大小行有浅深今此同闻莫非补处　二列数

三万二千　总举上首眷属之众　三略标上首

文殊师利法王子而为上首　文殊师利此翻妙德。从法化生绍隆佛种名法王子。大本小本弥陀经列众甚广。今经最略。翻传适时各其志也。计应更列人天杂众。下流通云无量诸天龙夜叉等。即知序中亦略之耳。二发起序　诸经缘起随事不同。今经乃以杀逆为发起者略有二意。一欲彰此界众生极可厌恶。亲生膝下尚敢危害况于余人。意令末世忻乐净土故。二为表此方机缘非遭极苦。不念脱离求往生故。故下韦提希云为我广说无忧恼处我当往生。不乐阎浮提浊恶世等。就中分二。初至和悦正明囚父时阿阇世问守门者下次明欲害母　初正明囚父四。一频婆为子幽禁二国大夫人密奉糗浆三祈请戒法以济心神四法食兼资日久不殒。初频婆为子幽禁

尔时王舍大城有一太子名阿阇世随顺调达恶友之教收执父王频婆娑罗幽闭置于七重室内制诸群臣一不得往　阿阇世此云未生怨。涅槃云由未生时相师皆言此儿生已定当害父。又云阿阇名不生世者名怨。以不生佛性故则烦恼怨生等。调达具云提婆达多此云天热。生时诸天心皆热恼。知彼出世必破三宝故。是斛饭王子佛之堂弟阿难亲兄。有三十相出家诵六万法聚十二韦陀。因见如来王臣归仰利养充溢心生嫉忌。即往白佛求欲摄众。为佛所诃遂谋害佛。阿难不知授与通法。入山修习获得五通。乃自思推谁作檀越。阇世太子有大王相。种种变现惑令信受。语太子言我作新佛。汝作新王岂不快哉。于是推山压佛。密迹金刚以杵拟之。碎石迸来伤佛足指出佛身血。自号为佛五法化人。三闻达等五百新学受彼邪化别众乞食。别自布萨即破法轮僧。莲花色尼路逢诃之。拳打眼出即杀阿罗汉。犯三逆罪生入地狱。阇王杀父害母共造五逆。此皆大权化事或逆或顺无非益物。为绝后世起逆业故。经云示现有三毒又现邪见相。我弟子如是方便度众生。又涅槃云提婆达不曾堕狱造逆等。实非声闻缘觉境界。唯是诸佛之所知见是也。频婆娑罗此云模实亦名影坚。皆为形体充实从身立名。亦有翻为颜貌端正。七重之室不虑往来。复加制约欲令饿死。二夫人奉食

国大夫人名韦提希恭敬大王澡浴清净以酥蜜和糗用涂其身诸璎珞中盛蒲桃浆密以上王　韦提希此翻思惟。先受此名即为今日请观之谶。浴身令净糗密涂身璎珞中空可盛果浆潜入深室故云密也三王请戒法又三初王陈目连二目连应机三佛遣富那说法　初王请目连

尔时大王食糗饮浆求水漱口毕已合掌恭敬向耆阇崛山遥礼世尊而作是言大目犍连是吾亲友愿兴慈悲授我八戒　目犍连此翻采菽氏。上古仙人。采菽豆而食。因以命族是王门师故称亲友　二目连应机

时目犍连如鹰隼飞疾至王所日日如是授王八戒　目连知已应机往赴如鹰隼飞喻神足之疾。隼音荀。字书云鸷鸟谓猛鸟也。八关齐戒唯局一日一夜故逐日别受。即多宗所计。若准成论延促不拘　三佛遣富那说法

世尊亦遣尊者富楼那为王说法　富楼那此翻满慈子。从父母得名。说法人中最为第一。善巧开诱故特遣之　四法食兼资

如是时间经三七日王食糗密得闻法故颜色和悦　食以资身法以沃心。本图饿死反更充盛。因慈忿怒推究元由。若准涅槃与此少异。故须委引方尽始终。经云罗阅阇王频婆娑罗其王太子名曰善见。业因缘故生恶逆心欲害其父而不得便。尔时恶人提婆达多亦因过去业因缘故复于我所生不善心欲害于我。即修五通不久获得。遂与太子共为亲友现作种种神通之事。太子见已生敬信心严设供养。太子告言我今欲见曼陀罗花。提婆即往三十三天求之。其福尽故都无与者。既不得华即欲自取。便失神通还见己身在王舍城。心生惭愧不能复见太子。遂至佛所求索大众白言唯愿如来以此大众付嘱于我。佛言痴人。舍利弗等聪明大智。我犹不以大众付嘱。况汝痴人食唾者乎(谓现通时现作婴儿食阇世唾)于是提婆倍生恶心乃言瞿昙汝虽调伏大众势亦不久当见磨灭。即时大地六反震动。提婆寻即躄地。身边出大暴风吹诸尘土而污坌之。提婆复言若我此身必入阿鼻我要当报如是大怨。寻起至太子所。太子即问何故颜容憔悴有忧色耶。提婆言我今与汝极成亲爱。外人骂汝我岂不忧。太子言云何骂我。提婆言国人骂汝为未生怨。太子问何故。提婆言汝未生时一切相师皆言此儿生已当杀其父。一切内人获汝心故谓为善见。毗提夫人闻是语已既生汝身于高楼上弃之于地坏汝一指。复号汝为婆罗留枝。我闻是已心生忧愦而复不能向汝说之。提婆以如是等恶事教令杀父。若汝父死我亦能杀瞿昙沙门。于是太子收其父王闭之城外。以四种兵而守卫之。毗提夫人即至王所。时守王人遮不听入。夫人诃骂守人即告太子。大王夫人欲见父王不审听否。太子嗔嫌。即往母所前牵母发拔刀欲研。耆婆白言有国已来罪虽极重不及女人况所生母。太子闻已即便放舍。遮断父王衣服卧具饮食汤药。过七日已王便命终。引彼校此或异或同。方便随机不足怪矣。二明欲害母四。初至不令复出幽闭深宫。二韦提下翘诚请佛。三未举下佛知往赴。四时韦提下见佛求法。初幽闭深宫三。初执釰欲害。二二臣谏止。三敕令幽闭。初执釰欲害四。初王问门者。二守门实答。三王闻嗔骂。四执釰欲害。初王问门者审其在否

时阿阇世问守门者父王今者犹存在耶　二守门实答

时守门人白言大王国大夫人身涂糗蜜璎珞盛浆持用上王沙门目连及富楼那从空而来为王说法不可禁制　王制群臣不言国后。沙门空入非门能禁故设此词。意图免过　三王闻嗔骂

时阿阇世闻此语已怒其母曰我母是贼与贼为伴沙门恶人幻惑咒术令此恶王多日不死　名父为贼母即贼伴。沙门幻术明非贤哲　四执釰欲害

即执利釰欲害其母　即如上引涅槃经所说　二二臣谏止三。初修谏礼二设谏词三谏已欲去　初修谏礼

时有一臣名曰月光聪明多智及与耆婆为王作礼　月光华言耆婆梵语此翻固活。生时一手持药囊一手把针筒。昔誓为医治疾存活。从德立号。庵罗女之子。二皆多智显是贤臣　二设谏词

白言大王臣闻毗陀罗论经说劫初已来有诸恶王贪国位故杀害其父一万八千未曾闻有无道害母王今为此杀逆之事污刹利种臣不忍闻是栴陀罗不宜住此　毗陀经即俗典或作韦陀梵言少异。如此间史书纪其国事。贪位杀父此犹有理。非辜害母诚为无道。西竺四姓摄一切姓。刹帝利婆罗门二为尊贵毗舍首陀二为下贱。刹帝即王者姓。栴陀罗此云杀者。即此间魁刽之类。君既无道贤臣不辅故不宜住　三谏已欲去

时二大臣说此语竟以手按釰却行而退　按釰却行示威令惧　三敕令幽闭

时阿阇世惊怖惶惧告耆婆言汝不为我耶耆婆白言大王慎莫害母王闻此语忏悔求救即便舍釰止不害母敕语内官闭置深宫不令复出　阇王惊惧贤臣去国社稷必危。不为我者求救之词。为犹佐也。耆婆重谏王悔乃从。敕闭深宫发起之本　二翘诚请佛三。初遭苦思法二陈词致请三悲哀礼请　初遭苦思法遥礼伸敬

时韦提希被幽闭已愁忧憔悴遥向耆阇崛山为佛作礼　二陈词致请

而作是言如来世尊在昔之时恒遣阿难来慰问我我今愁忧世尊威重无由得见愿遣目连尊者阿难与我相见　阿难是佛侍者常往慰问。传法利人必假王力。虽佛上圣曲顺常情以为后范。韦提敬佛不敢辄请。愿见二师欲闻法要。阿难此云庆喜亦云无染或云忻乐　三悲哀礼请

作是语已悲泣雨泪遥向佛礼　三佛知往赴二。初感佛垂应二礼起见佛　初感佛垂应

未举头顷尔时世尊在耆阇崛山知韦提希心之所念即敕大目犍连及以阿难从空而来佛从耆阇崛山没于王宫出　知其心念即他心智。乘空出没即如意通　二礼起见佛

时韦提希礼已举头见世尊释迦牟尼佛身紫金色坐百宝莲华目连侍左阿难在右释梵护世诸天在虚空中普雨天华持用供养　见佛有四殊胜。一身色二莲座三左右侍从四诸天供养。释迦翻能仁即应身。牟尼翻寂点即法身。上冥下应报在其中。释即帝释具云释提桓因。此翻能天。即三十三天主也。梵即大梵天王色界天主。护世即四王等。古疏问曰频婆韦提俱请弟子。何故前遣弟子后乃自往。其意何耶。解有二义。一阇王杀父。佛若亲往则起怨嫌护彼心故。二欲行佛法须委国王。频婆定死阇王登位。佛若自往则障碍不行。为护法故韦提无此自往无妨　四见佛求法二。初作礼申敬二请法　初作礼申敬

时韦提希见佛世尊自绝璎珞举身投地号泣向佛　被囚日久不期遇佛。悲喜盈怀无暇容缓。挽断项缨持用献佛。投身于地以竭其诚二请法有二。初通问往生处二正请往生因　初通问往生处二。初泛问宿因二正问生处　初泛问宿因

白言世尊我宿何罪生此恶子世尊复有何等因缘与提婆达多共为眷属　我之母子爱出天性。佛之兄弟情同天伦。反生逆害必有往因。本唯自责兼问如来。但是伤叹往业以为陈请之由。经律多说。佛与提婆从因至果常相恼害。盖是大权影响而非实事。即法华云由提婆达多善知识故令我具足六波罗蜜。乃至却后过无量劫当得成佛。号曰天王如来等　二正问生处为三。初标忻厌二叙可厌三立誓远离　此之三节即示末世修行要术。若不尔者则徒修净业定不往生　初标忻厌

唯愿世尊为我广说无忧恼处我当往生不乐阎浮提浊恶世也　无忧恼处者韦提所问。言相通含据下佛答即指净土。娑婆五浊人间天上皆有忧恼。唯佛净土依正俱胜但受诸乐宁有忧乎。阎浮提或云剡浮赡部此翻胜金。从树为名。以树半临海水水底有金光色映树故以为名。提或云檀此翻为洲。即别指南洲也。据令通指娑婆大千。且从近论令易解耳。或可阎浮于四洲中浊恶最甚故特标之　二叙可厌

此浊恶处地狱饿鬼畜生盈满多不善聚　浊谓五浊。即见烦恼等五皆不净故总名浊亦名五滓。恶即十恶。即杀盗等。五浊则具该依正。十恶则别指行业。若据浊恶实该六道。特举三途苦果以彰可厌。遍于大千故云盈满。多不善聚者即上恶趣共聚此处。或可别指人中。少有良善如下所愿不见恶人怨亲逆顺无非不善。阇王调达岂善聚乎。上随文解次约义论。此浊恶处即指世间郡邑民居亲族会处。其间心行万差三恶盈满皆不善聚。又浊恶处即指我等众生现前识心。无始至今三业所造无边业种日用所起三恶道行不可穷数故云盈满多不善也　三立誓远离

愿我未来不闻恶声不见恶人　五浊三界五逆十恶皆是恶声。其中众生造如是业尽号恶人。极乐世界尚无恶道名即无恶声也。诸上善人俱会一处。即无恶人也　二正请往生因

今向世尊五体投地求哀忏悔唯愿佛日教我观于清净业处　头及四肢为五体五处皆圆亦名五轮。着地礼之重也。由有宿罪故受此苦。今欲厌离故须求悔。梵云忏摩此翻悔往。今言忏悔华梵并举。有云忏即断后悔是耻前。如来说法破障除疑如日照世故云佛日。极乐依正莫非主伴净业共成故名清净业处。据此韦提正求观法故云教我观也　第二正宗分三。初至那含放光现土审定机宜。尔时世尊下二正明观法净业正因。说是语时下三显示利益结劝修习　初放光现土审定机宜三。初如来放光普现诸土。二韦提白佛选定一方。三频婆蒙光护证道果。佛恐末世以为十方净土随愿可生何独定指弥陀一国特现此瑞以决后疑。今多此见正达佛意　初如来放光普现诸土

尔时世尊放眉间光其光金色遍照十方无量世界还住佛顶化为金台如须弥山十方诸佛净妙国土皆于中现或有国土七宝合成复有国土纯是莲华复有国土如自在天宫复有国土如玻璃镜十方国土皆于中现有如是等无量诸佛国土严显可观令韦提希见　如来眉间有白毫相。长一(丈寸)五周圆五寸外有八棱中空如筒白如珂雪右旋宛转。表从中道流出诸法。初散后聚亦表摄多归一。即显此经圆纯究竟一佛乘法。故现此相异于常时。光台高耸喻若须弥。现土无量不可具举。略示四种以示可观。七宝成者言其尊贵。纯莲华者言其洁净。如天宫者言其快乐。颇梨镜者言其明莹。若论诸土庄严极众。经文从简各举一相。欲彰极乐具兼诸美令韦提见。即示放光现土之意　二选定一方三。初通叙诸土非是所类。二别指极乐正合机缘。三求请往生所修观法　初通叙诸土非是所愿

时韦提希白佛言世尊是诸佛土虽复清净皆有光明　二别指极乐正合机缘

我今乐生极乐世界阿弥陀佛所　良以此界下凡心多驰散。若不的指一方专观一佛则观行难成往生多障。况弥陀光明常照誓愿弘深。是以生一土则诸土皆通。想一佛则诸佛齐见。十疑论佛答普广其理照然。善导专修义亦同此　三求请往生所修观法

唯愿世尊教我思惟教我正受　初修方便作意观缘名思惟。观想既成任运妙契名正受。如地观云如此想者名为粗见极乐国地即思惟也。若得三昧见彼国地了了分明不可具说即正受也。善导玄义据华严经思惟正受并是三昧。与此地观文证大同。又观佛三昧经云佛告阿难。佛灭度后佛诸弟子闻是法者思是法者观是法者此人常于梦中见佛。又云闻是语思是法者有正念者有正受者。准知思惟正受皆属观法浅深有异。又复前云教我观于清净业处。即知韦提唯请观耳　三频婆蒙光获证道果

尔时世尊即便微笑有五色光从佛口出一一光照频婆娑罗顶尔时大王虽在幽闭心眼无障遥见世尊头面作礼自然增进成阿那含　初如来现土正意在兹。机感相投潜通密应。故佛微笑。观佛相海经云诸佛常法凡笑必有五色光。从口而出光照王顶。佛力加被令增道果。蒙光见佛深悟无常。发智断惑遂证三果。阿那含此云不还。结惑将尽不还下界。据此频婆见佛得果。应与夫人同闻观法。后结益中但叙韦提五百侍女。乃知频婆证果即归灭矣　第二正明观法净业正因二。初如来许可二正示所说　初如来许可

尔时世尊告韦提希汝今知不阿弥陀佛去此不远汝当系念谛观彼国净业成者我今为汝广说众譬亦令未来世一切凡夫欲修净业者得生西方极乐国土　先审知否者欲明净土非佛自说他无知者。弥陀经云从此西方过十万亿佛土。而云不远者此有三释。一佛眼观故如楞严说。天眼观大千界如观掌果。况佛眼乎。譬如登高视下一目万里。所谓登大山而小天下也。二心念速故。心神无碍遐方异域举念即至。所谓心念疾于风也。三佛力摄故。虽未得通乘佛神力。如十疑论说。劣夫从轮王一昼夜行四天下。所谓青蝇附于骐尾也。净业成者总目彼土依正二报。极乐境界众生未识以物比拟故云众譬。如下云如亿千日其光如华等。或可所有言谕通名为譬。亦令未来者正彰本意非止当机。所谓千钩之弩岂特为鼷鼠而发机乎　二正示所说复二。初先示福业二明正观初先示福业　所以先明三福者即是修观行人合行事业。非观无以导其福非福无以成其观。有观无福则阙于庄严。有福无观则牵于异趣。阙庄严则护报非胜。牵异趣则往生莫由。二法相资无往不利。寄言学者克意研求。无惑两岐自迷发足　今释三福三。初通标二别释三结告。初通标

欲生彼国者当修三福　欲生者言其志愿。当修者教令必为　二别释

一者孝养父母奉事师长慈心不杀修十善业　既是三世佛因。明知菩萨大行。第一共凡夫业第二共二乘业第三大乘不共业。就中四句。上二句报恩行。父母生育恩师长教导恩。下二句离恶行。不杀为十善之首故特标之。身除三邪口离四过意断三恶也

二者受持三归具足众戒不犯威仪　就中三句。上句即翻邪三归。凡夫无始系属于魔。作法归投希求救护。若但受归有善无戒。若受众戒必兼三归。下二句即受戒法。在家五八出家十具故云众戒。受持无缺故云具足。威仪亦戒。轻细难持人多陵犯。故特标简

三者发菩提心深信因果读诵大乘劝进行者　就中四句。初即发大心。菩提翻道即无上道心。二即起大心。善恶因果皆我自心了知畏慎故云深信。三即生大解。教诠本智因诵发生。四即修大行。劝诱修行不令退堕。上三自行后一化他　三结告

如此三事名为净业佛告韦提希汝今知不此三种业过去未来现在三世诸佛净业正因三世果德籍此而成故曰正因　二明正观四。初敕听示说二赞请三劝嘱四示法初敕听示说

佛告阿难及韦提希谛听谛听善思念之如来今者为未来世一切众生为烦恼贼之所害者说清净业　谛听善思即闻思两慧。为未来者正指像末也。烦恼贼害即具缚凡夫也。清净业即十六观也　二赞请

善哉韦提希快问此事　悦可圣心故云快问　三劝嘱三。初明是佛所教二依教修成三因修获证　初明是佛所教

阿难汝当受持广为多众宣说佛语如来今者教韦提希及未来世一切众生观于西方极乐世界　阿难多闻劝令持说。由在幽宫同闻尚少。后还耆山意令重述故预嘱之。如来今者等并是付嘱阿难所说之词　二依教修成

以佛力故当得见彼清净国土如报明镜自见面像　教由佛说即是佛力。所谓如来异方便也　三因修获证

见彼国土极妙乐事心欢喜故应时即得无生法忍　得无生忍位当初住。若据观法功德力强见生可证。准下佛观即指生彼获证之相。下云舍身他世生诸佛前得无生忍是也　四示法有三。初叙韦提见土由二为未来请其方便三如来答其所请　初叙韦提见土由

佛告韦提希汝是凡夫心想羸劣未得天眼不能远观诸佛如来有异方便令汝得见　大权引实故示同凡。天眼六通之一。障内障外无不彻见。凡仙小圣虽得天眼遐方净刹亦不能观。异方便者若对当机即前光台现土令韦提见。据论垂教即下十六观法专被未来。欲彰权智道同故言诸佛　二为未来请其方法三。初叙己得见二伤他不见三正为陈请　初叙己得见

时韦提希白佛言世尊如我今者以佛力故见彼国土　二伤他不见

若佛灭后诸众生等浊恶不善五苦所逼　此即大悲权巧利物方见。韦提位非凡小。浊恶不善义同前释。五苦者疏云五道皆非乐故。修罗一道开则为六合但有五。或取大本五恶五痛五烧以为五苦。即五戒所禁五种之过为五恶。犯此五事遭难犯法为五痛。后堕三途名为五烧　三正为陈请

云何当见阿弥陀佛极乐世界　未来众生一生不值佛二浊恶转盛三苦逼益深。业障如此。疑无见土之理。有何方便令得见乎　三如来答其所请又二。初标示系想处二别列十六观法　初标示系想处

佛告韦提希汝及众生应当专心系念一处想于西方　净土观门要在专一故。须指定一方以为投心之处。故放光现土厥意在兹。故十疑论中名为一相三昧。文殊般若亦名一行三昧。比诸观法有三不同。余观不定方隅。今此定须西向。余观收神归念今此送想彼方。余观遍历自他今此定缘圣境。义门备拣心境历然。乖此别修终名邪观　二别列十六观法　自古章疏多广悬谈。及至观文例多简略。今谓观文正当心要义须委细科释文言。听习之徒切宜留心。今先总分后方别解。就十六观大分为二。初一种先观此方落日指定向方。后十五种正观彼土依正二报。初观是总该下十五。下皆为别各不相收。就后十五复分为二。前五先观彼土依报庄严。后十观彼正报殊胜。就前五中又分为二。前二观彼所依境界。观水成冰见冰为地。后三观彼庄严之相。国土庄严不出三种。树即观彼林荫池即观彼流泉楼即观台阁。地观为总摄余三故。树等为别皆依地故。就后十中复分为四。前三观佛。第七观佛坐处。第八观像表真。第九正观佛相。十与十一观佛侍者左右分殊。十二十三总观三圣普杂不同。十四五六观佛徒众三辈差降。若此分对一经大要皎如指掌。逐观别分广更如后　第一日观三。初所观境二能观想三结示　初所观境

云何作想凡作想者一切众生自非生盲有目之徒皆见日没　方隅渺[漭-廾+卉]无物表彰。此间落日有目皆见显了易观。是可标准。疏云落日悬鼓。用标送想之方。即此意也。言作想者想即是观。胎中失目谓之生盲　二能观想四。初示修仪二示观相三显成相四劝常观　初示修仪

当起想念正坐西向　起想即发观也。正坐则身仪也。全趺半趺直身累手如坐禅法。故僧传中古晋高僧坐不背西盖遵此耳　二示观相

谛观于日欲没之处令心坚住专想不移　心境相应凝然不动即定体也　三显成相

见日欲没状如悬鼓　日没近地云散光收莹如鼓面。悬住空中　四劝常观

既见日已闭目开目皆令明了　想成相起念念相续任运不忘　三结示

是为日想名为初观　结示可解　就后十五观前五依报中第二水想欲成此土凝冰。第五想水正观彼方池沼。名同体别学者宜知　第二水观二。初所观境二结示　水想正为观地。琉璃宝地举世所无。水面结冰是人皆识。因此见彼用似比真。故先举水冰后成宝地。疏云大水结冰实表琉璃之地是也　初所观境二。初观水二观地　初观水三。初正想水二变水成冰三变冰为琉璃　初正想水

次作水想见水澄清亦令明了无分散意　显上澄清湛然不动故云无分散意　二变水成冰

既见水已当起冰想　三变冰为琉璃

见冰映彻作琉璃想　齐此已来当观文毕。此想已下属后地观　二观地三。初地体明彻二地下幢擎三地上庄严　初地体明彻

此想成已见琉璃地内外映彻　二地上幢擎二。初示幢体二珠光上映　初示幢体

下有金刚七宝金幢擎琉璃地其幢八方八楞具足一一方面百宝所成　八面八楞其状如塔　二殊光上映

一一宝珠有千光明一一光明八万四千色映琉璃地如亿千日不可具见　三地上庄严四。初地面华级二众宝色光三合此宝光以成台阁四华幢乐器　初地面华级

琉璃地上以黄金绳杂厕间错以七宝界分齐分明　金绳七宝互相间错如世花塼　二众宝色光

一一宝中有五百色光其光如华又似星月悬处虚空　众宝色光其光从地升空故如华。从上照下故如星月　三合此宝光以成台阁

成光明台楼阁千万百宝合成　四华幢乐器

于台两边各有百亿华幢无量乐器以为庄严八种清风从光明出鼓此乐器演说苦空无常无我之音　华幢乐器四面围绕。风动出声说法警众。风生八方故云八种。彼无时节。且对此方故云八耳。苦空等法即四念处。观身不净观受是苦观心无常观法无我。以此四法对破四倒。文中空字且对观身。知倒计亡非空何谓　二结示

是为水想名第二观　结文可知　第三地观　所观之境备在前文故。第三但有蹑前结劝而已　文有四节。初思惟二正受三彰益四辨邪正　初思惟

此想成时一一观之极令了了闭目开目不令散失唯除食时恒忆此事如此想者名为粗见极乐国土　一一观者指前总别相也。除食时者开暂间也。有依别本改为睡时。寻诸古本并作食时。且凡人睡时任运自息岂待除耶。或云大小两乘各有食观故此除之。此局道众亦非通论。今谓余诸观法不择时处。此观圣境理合虔恭。对食起想义乖尊敬故。观佛三昧经观像法云想念成已唯除食时除便转时一切时中恒见佛像等。斯为明据不须改作。初心渐想未成定相故云粗见言其未明也　二正受

若得三昧见彼国地了了分明不可具说是为地想名第三观　三昧正音三摩地此翻正定或云等持。想成见地不待作意任运契合见境分明。如人学射初生后熟发无不中。言思叵及唯证方知故云不可具说　三彰益二。初重嘱转教二正彰利益　初重嘱转教

佛告阿难汝持佛语为未来世一切大众欲脱。苦者说是观地法　敕阿难者以前二观止是此方之物以为发观之端。及观宝地心达彼方定能脱苦破障除疑。重嘱转教意见于此

二正彰利益二初破障二除疑　初破障

若观是地者除八十亿劫生死之罪　八十亿劫或云无量劫或云五万或云五十亿劫随宜不定非凡所测　二除疑

舍身他世必生净国心得无疑　此观若成往生已决。如唐高僧大行于泰山结庵修净业。未三七日见琉璃地心眼洞明。至后得疾其地复现。乃曰吾无观想宝地复现。岂于安养无缘哉。即日终于所居　四辨邪正二。初显正二简邪　初显正

作是观者名为正观　言作是者指前观相。心境相称教行无违故　二简邪

若他观者名为邪观　乖前境量名为他观。不正曰邪。虽是佛教大小观法若非往生净土之观。并是偏邪非同外道邪见之邪。余皆例此　第四树观三。初结前生后二。正明观行三结示　初结前生后

佛告阿难及韦提希地想成已次观宝树　告敕之语或标不标译人之变　二正明中二初举所观二示能观　初所观二。初示体量二明庄严　初示体量三初教遍观二示行数三明高量　初教遍观

观宝树者一一观之　树相多种故云一一　二示行数

作七重行树想　周回七重匝绕彼国。或云处处皆有七重　三明高量

一一树高八千由旬　由旬亦云由延亦云踰善那。西竺驿亭之量。经律所出远近不定。诸家多取四十里为准　二明庄严二。初光明庄严二花果庄严。初光明庄严又三。初示叶具二明色光三明珠网　初叶具

其诸宝树七宝华叶无不具足　叶具足者无凋落故　二光明庄严

一一华叶作异宝色琉璃色中出金色光玻璃色中出红色光码瑙色中出砗磲光砗磲色中出绿真珠光珊瑚琥珀一切众宝以为映饰　宝色与光五色相间。琉璃碧色出黄光。颇梨青色出红光。码瑙赤色出白色。车渠白色出绿光。若准大本。琥珀七宝诸树周满世界。金银琉璃颇梨珊瑚玛瑙车渠等树。或有二宝三宝乃至七宝转共合成。广如彼说。即是众宝为映饰　三珠网四　初示重数二网间宫殿三殿中童子四珠缨光明　初示重数

妙真珠网弥覆树上一一树上有七重网　每树七层每层一重其形如塔　二网间宫殿

一一网间有五百亿妙华宫殿如梵王宫　网间宫殿如色界天梵王居处　三殿中童子

诸天童子自然在中一一童子五百亿释迦毗楞伽摩尼以为璎珞　一一下天童严饰。释迦毗楞伽此云能圣。摩尼亦云离垢亦云如意　四珠缨光明

其摩尼光照百由旬犹如和合百亿日月不可具名众宝间错色中上者　众宝间者不独珠也。色中上者异于常也　二华果庄严又二。初总举二别示　初总举

此诸宝树行行相当叶叶相次于众叶间生诸妙华华上自然有七宝果　行相当者当犹对也。叶相次者如鳞接也。花果如下释　二别示三。初明树叶二明树花。三明树果　初明树叶

一一树华纵广正当二十五由旬　三句示量。二十五由旬计一千里

其叶千色有百种画如天璎珞　三句明色。百种画即叶上痕脉。如天璎者状其文也　二明树花

有众妙华作阎浮檀金色如旋火轮婉转叶间　阎浮檀如上已释。洲边有树海底出金光色无比。置于暗中其暗即灭。华色同焉。其花旋转犹世风车　三明树果又二。初体相二光变幢盖　初体相

涌生诸果如帝释瓶　帝释瓶谓帝释殿前有瓶莫测其量。以叶度果其大可知　二光变幢盖

有大光明化成幢幡无量宝盖是宝盖中映现三千世界一切佛事十方佛国亦于中现　映现有二。大千佛事一也。十方佛国二也。示生唱灭说法度生皆名佛事　第二示能观

见此树已亦当次第一一观之观见树茎枝茎华果皆令分明　恐其参乱故令次观。茎等五种即是次第。茎谓根干必兼枝条　三结示

是为树想名第四观　结文可解　第五池观四。初示体相二明池莲三明池光四结示　初示体相四。初举数二明水色三明流渠四明渠底　初举数

次当想水欲想水者极乐国土有八池水　一国八池渠道相通　二明水色

一一池水七宝所成其宝柔软从如意珠玉生　上二句明色相。池塘阶岸众宝合成。池中泉水色亦如然故云七宝成也。下二句示出处。每一池心各有珠玉。泉从玉出流落池中常时盈满　三明流渠

分为十四支一一支作七宝妙色黄金为磲　十四支即是渠道　四明渠底

渠下皆以杂色金刚以为底沙　杂色金刚金有五色又精刚者　二池莲三。初示数二明量三明水流花间　初示数

一一水中有六十亿七宝莲华　一一水中即上八池各六十亿。小本经中四色四光。今言七宝故知多别　二明量

一一莲华团圆正等十二由旬　十二由旬计四百八十里。小本经但云大如车轮。举其极小者耳　三明水流花间

其摩尼水流注华间寻树上下其声微妙演说苦空无常无我诸波罗蜜复有赞叹诸佛相好者　从如意珠出故云摩尼水。华梵互举也。寻树上下寻犹循也。树即茎也。言水循华茎上入花中旋转发声却从茎下。演说有三。四念处一也六度二也赞佛相好三也　三池光二。初从珠涌光二光化灵禽　初从珠涌光

如意珠玉涌出金色微妙光明　二光化灵禽

其光化为百宝色鸟和鸣哀雅常赞念佛念法念僧　即小本中白鹄孔雀。今经下文凫雁鸳鸯等。即知珍禽非止一类。今此但举毛色以通收耳。赞叹三宝令归向故　四结示

是为八功德水想名第五观　八功德一轻二清三冷四软五美六不臭七饮时调适八饮已无患。不出色香味触四尘而已

观无量寿佛经义疏卷之中(终)观无量寿佛经义疏卷下

        刘宋西域三藏畺良耶舍译

        西湖灵芝崇福寺释元照述

第六总观四。初正明二结示三彰益四显邪正　初正明二。初别观宝楼二总观四种　初别观宝楼四。初示数二诸天作乐三天乐悬空四乐音说法　初示数

众宝国土一一界上有五百亿宝楼阁　众宝国者总召彼土也。一一界者准小本即池岸上。经云四边阶道上有楼阁等　二诸天作乐

其楼阁中有无量诸天作天伎乐　伎即乐人　三天乐悬空

又有乐器悬处虚空如天宝幢不鼓自鸣　如宝幢者言其量也　四乐音说法

此众音中皆说念佛念法念比丘僧　即赞三宝　二总观四种

此想成已名粗见极乐世界宝树宝地宝池　承前楼观兼牒前三即为总观。若别若总各逗机缘。此观依报收无不尽。言粗见者即思惟也。下文若见此者即正受也　二结示

是为总观想名第六观　三彰益

若见此者除无量亿劫极重恶业命终之后必生彼国　破障除疑　四显邪正

作是观者名为正观若他观者名为邪观　并如前释　次就后十观正报中四。初如来劝嘱二三圣现身三夫人为未来申请四如来广明　初如来劝嘱三。初劝听二许说三重嘱　初劝听

佛告阿难及韦提希谛听谛听善思念之　如上观依意在观正故重劝嘱　二许说

佛当为汝分别解说除苦恼法　娑婆众苦非观佛三昧无由可脱名脱苦法。三界为苦器六道是苦报　三重嘱

汝等忆持广为大众分别解说　二三身现身

说是语时无量寿佛住立空中观世音大势至是二大士侍立左右光明炽盛不可具见百千阎浮檀金色不得为比　前文光台现土令韦提见以为依报发请之端故云以佛力故见彼国等。今三圣共临以为正报发请之由故云因佛力故得见佛等。佛立空中二圣侍立。三圣立像斯为明据。阎浮金色犹不可比。则知其光不可尽见　三夫人为未来申请二。初见佛设礼二白佛申请。初见佛设礼

时韦提希见无量寿佛已接足作礼　二白佛申请

白佛言世尊我今因佛力故得见无量寿佛及二菩萨未来众生当云何观无量寿佛及二菩萨　即白释迦也。菩萨存心不专为己。虽令我见意在未来　四如来广明　就下十观大分为四。如上已明今依次释　第七华座观二。初正明观行二总劝谛观　华座观者欲瞻尊境先观坐处。如对君上目视阶陛　初正明观行三。初总示依处二别列庄严三结示　初总示依处

佛告韦提希欲观彼佛者当起想念于七宝地上作莲华想　华依于地。显是台座非池莲也　二别列庄严二。初华叶二华台　初华叶六。初色二脉三光四示量五显数六明珠光　初色

令其莲华一一叶上作百宝色　二脉

有八万四千脉犹如天画　其文工巧故如天画　三光

脉有八万四千光了了分明皆令得见　四示量

华叶小者纵广二百五十由旬　二百五十由旬讨有万里　五显数

如是莲华具有八万四千叶　六明现光

一一叶间各有百亿摩尼殊玉以为映饰一一摩尼珠放千光明其明如盖七宝合成遍覆地上　光形如盖下覆其地　二华台三。初明台体二台外校饰三台上宝幢　初明台体

释迦毗楞伽宝以为台　即莲心也。释迦毗楞即如意珠。出生无尽皆如人意故云能生　二台外校饰

此莲华台八万金刚甄叔迦宝梵摩尼宝妙真珠网以为校饰　文列四宝。甄叔迦此云赤色宝。梵即翻净　三台上宝幢三。初明幢体二明宝幔三珠光　初明幢体

于其台上自然而有四柱宝幢一一宝幢如百千万亿须弥　即上台面四向立柱。上擎网幔以覆佛顶　二明宝幔

幢上宝幔如夜摩天官　夜摩即欲界第三空居天。彼天华光庄严最胜故多取为比　三殊光四。初示数二珠光三光色四其色变现　初示数

复有五百亿微妙宝珠以为映饰　二珠光

一一宝珠有八万四千光　三色光

一一光作八万四千异种金色　四其色变现

一一金色遍其宝土处处变化各作异相或为金刚台或作真珠网或作杂华云于十方面随意变现施作佛事　其色变现为三。金台珠网华云也。更有别相故云随意等　三结示

是为华座想名第七观　结文可知　二总劝谛观五。初推本因二明由渐三教纯一离杂想四示益五简邪正　初推本因

佛告阿难如此妙华是本法藏比丘愿力所成　阿弥陀佛昔为国王遇世自在王佛弃国出家。法名法藏。发四十八愿。彼国依报境界身寿光明种种庄严一切果相皆愿所成。岂唯华座。寄此点示使知净土即佛愿体。愿由心发即佛心体。故知愿力理绝言思矣　二明由渐

若欲念彼佛者当先作此华座想　不先华座则观佛不成　三教纯一离杂观

作此想时不得杂观皆应一一观之一一珠一一光一一台一一幢皆令分明如于镜中自见面像　一一观之贯下五种。花叶及幢皆有珠光。台不明光在文少略。镜中见面喻其无差　四示益

此想成者灭除五万劫生死之罪必定当生极乐世界　灭罪除疑此是观佛最初方便灭罪犹少。次至像观灭罪乃多。后至佛观得无生忍即破无明　五简邪正

作是观者名为正观若他观者名为邪观　解同前　第八像观二。初结前标后二正示观法　初结前标后

佛告阿难及韦提希见此事已次当观佛　众生无始未识真佛多见形像故使先观。以像表真观佛易就　二正示观法三。初通示想佛之意二正明想佛之法三结示　初通示想佛之意四。初明佛身普遍能应物心二明行者想成即具佛体三举彼果德令信因心而结劝修因须依果德　此一段经我佛如来欲明佛观故于像观之首先叙观佛之功。即是开示众生成佛要道。一经妙旨唯在此文。后学讨论宜须精究。此而不了余竟何言　初明佛身普遍二。初征二示。初征

所以者何　观佛其利安在　二示

诸佛如来是法界身入一切众生心想中　此中正说弥陀以法身体同故言诸佛。华严云一切诸佛身即是一法身。一心一智慧力无畏亦然。此明诸佛果证法身无所不遍。则与众生因地法身无二无别故。众生作想佛身随应。疏云众生心净法身自在故。能入众生心想中如白日升天影现百川故。想佛心即是三十二相八十种好也。如势至圆通云。十方如来怜念众生如母忆子。此明佛常念众生。若子逃逝虽忆何为。此明众生不念有应无感也。若众生心忆佛念佛现前当来必定见佛去佛不远。此明众生念佛感应道交也。此实弥陀世尊同体大慈悲善根力随缘赴感应物垂形。不思议用。苟明此理佛入何疑　二明行者想成即具佛体

是故汝等心想佛时是心即是三十二相八十随好是心作佛是心是佛　就中初二句示心境相应。次三句显因成果相。下二句释成上义。是心者即指行者观佛之心。由观佛相相现心中。此心即具佛之相好。此据小身丈六为言。其功若此。若观八万四千相好心具亦尔。教令观佛其功若此。众生依教修因感果始于此心故云是心作佛。恐谓修成佛从外得。只由此心当体是佛故使建修无不果满故云是心是佛。若不尔者生彼国已具三十二大人相好自何而得耶。当知今日想佛之心相好果德悉已具足。莲胎孕质即是此心是证菩提不从他得矣。三举彼果德令信因心

诸佛正遍知海从心想生　正遍知者十号之一也。出世法无不究尽。深广无际故喻如海。佛德无边略举遍知以摄余者。果人万德皆心想生。意勉下凡专勤修习功不虚矣　四结劝修因须依果德

是故应当一心系念谛观彼佛多陀阿伽度阿罗诃三藐三佛陀　只由观佛功德高深故劝系想。前则通举诸佛。此则别指弥陀结归今经正意。故云谛观彼佛。多陀阿伽度此云如来。阿罗诃此云应供。三藐三佛陀此云正遍知。即十号中略举三号。委释如别　二正明想佛法三。初别明三像二总明三像三显益　初别明三像二。初弥陀像二二菩萨像　初弥陀像三。初见像色相二见国土庄严三诫令谛观　初见像色相

想彼佛者先当想像闭目开目见一宝像如阎浮檀金色坐彼华上　以像表真从易至难故。若画若雕随人见熟即以为境。坐彼华者即前华座　二见国土庄严

见像座已心眼得开了了分明见极乐国七宝庄严宝地宝池宝树行列诸天宝幔弥覆其上众宝罗网满虚空中　即前依报　三诫令谛观

见如此事极令明了如观掌中　观掌中者言其明了也　二二菩萨像又二。初观华座三观形像　初观花座

见此事已复当更作一大莲华在佛左边如前莲华等无有异复作一大莲华在佛右边　如前莲华者即佛所坐者。据菩萨身计应须减　二观形像

想一观世音菩萨坐左华座亦作金色如前无异想一大势至菩萨像坐右华座　亦作金色者即菩萨身同前佛色　二总明三像二。初眼见胜境二耳闻说法　初眼见胜境又二。初三像放光二遍见三像。初三像放光

此想成时佛菩萨像皆放光明其光金色照诸宝树　三像放光光色照树　二遍见三像

一一树下复有三莲华诸莲华上各有一佛二菩萨像遍满彼国　遍见三像无处不有　二耳闻说法二。初众音说法二忆持不忘　初众音说法

此想成时行者当闻流水光明及诸宝树凫雁鸳鸯皆说妙法出定入定恒闻妙法　水光树禽风鼓乐器并如前示。苦空无常无我诸波罗蜜故云妙法　二忆持不忘

行者所闻出定之时忆持不舍令与修多罗合若不合者名为妄想若有合者名为粗相见极乐世界　谓所闻之法不乖教典故云合也。修多罗此翻契经。违教即妄合法犹粗。对下三昧以分粗妙　三结示

是为像想名第八观　准上经文明列三像。或谓二菩萨无像观者未知何意　三显益

作是观者除无量亿劫生死之罪于现身中得念佛三昧　文有二。一除罪障二近三昧。即下佛观像观若成真身必见故云现身即得　第九佛观二。初蹑前起后二显所观境　初蹑前起后

佛告阿难及韦提希此想成已次当更观无量寿佛身相光明　此与像观皆有蹑前起后次第之文。意使正修不容异彻。自昔科为真法身观。今准下结云是为遍观一切色身相名第九观。必应指彼弥陀果佛色相即法身耳。下二菩萨其例颇同　二显所观五。初正明二结益三劝修四结观五简辨　初正明三。初示身相二彰言略三示所证　初示身相七。初显身色二示身量三眉毫量四眼色量五毛孔量六明项光七相好　初显身色

阿难当知无量寿佛身如百千万亿夜摩天阎浮檀金色　百千万亿夜摩天喻其大也。阎浮金言其自体也　二示身量

佛身高六十万亿那由他恒河沙由旬　佛身无量机见有殊。文中所举假以数量显非数量。欲彰佛身不可定故。即下文云如前所说无量寿佛身量无边非是凡夫心力所及。又云或现大身满虚空中。举此证前知无限量。蠡杯酌海丈尺量空。是可得乎。喻可见也　三眉毫量

眉间白毫右旋婉转如五须弥山　右旋婉转其状如珠。一须弥高三百三十六万里纵高亦尔。五须弥共一千六百八百八十万里。疏引宝性论佛眉毫方圆三百六十万里。疑是误算一须弥也　四眼色量

佛眼如四大海水青白分明　一大海八万四千由旬四大海共三十二万六千由旬　五毛孔光

身诸毛孔演出光明如须弥山　光即身光也。一一毛孔光如须弥。演即流也　六顶光

彼佛圆光如百亿三千大千世界于圆光中有百万亿那由他恒河沙化佛一一化佛亦有众多无数化菩萨以为侍者　百亿大千言其量也。化佛菩萨即应现也　七相好

无量寿佛有八万四千相一一相中各有八万四千随形好一一好中复有八万四千光明一一光明遍照十方世界念佛众生摄取不舍　丈六之身则具三十二相八十种好。今弥陀身相好光明三量八万四千则其数无量不可算矣。下示光明遍照摄生。即是弥陀慈悲心体。问不念佛人佛光摄否。答念与不念光无不摄。但念佛者与光相应摄取往生定无退堕。智论云。譬如鱼子母若不念子则烂坏。楞严所谓佛念众生如母忆子但子于母有忆不忆耳。又如盲人在日轮下日无不照盲者不见。不念佛人亦复如是　二彰言略

其光相好及与化佛不可具说但当忆想令心眼见　其光相好兼上身项二光。化佛即圆光所现。言不能尽忆想方见。心眼即意思也　三示所证二。初观一佛二观佛身　初观一佛

见此事者即见十方一切诸佛以见诸佛故名念佛三昧　见多佛者法身体同。念佛三昧从此得名　二观佛身

作是观者名观一切佛身以观佛身故亦见佛心佛心者大慈悲是以无缘慈摄诸众生　见佛心者身为心相故佛无一切心唯有大慈悲。慈者与乐悲即拔苦。众生无尽佛大慈悲亦无有尽。智论云。慈有三种。一众生缘慈。无心攀缘一切众生而于众生自然现益。二法缘慈。无心观法而于诸法自然对治。三无缘慈。无心观理而于平等第一义中自然安住。后一据理体前二约事用。今举无缘义收三种。谓诸佛心不住有无不依三世。平等大慧常照法界。以此摄生生无不摄。不由缘起故云无缘。即前所谓念佛众生摄取不舍是也　二结益

作此观者舍身他世生诸佛前得无生忍　舍身他世生彼土已即证无生。故知此观若成则上品上生明矣　三劝修二初劝观二教入处　初劝观

是故智者应当系心谛观无量寿佛　智者即自修观之人。依前观法即是谛观。以修此观往生得忍功深利大故劝系心。故般舟经众生问佛何因缘故得生此国。弥陀答言。以修念佛三昧得生彼国也　二教入处二。初观一相二观一佛　初观一相

观无量寿佛者从一相好入但观眉间白毫极令明了见眉间白毫相者八万四千相好自然当现　多相自具者眉毫一相总诸相故。若据经文即观五须弥量故云八万四千相好自然当现。即知非丈六眉毫　二观一佛

见无量寿佛者即见十方无量诸佛得见无量诸佛故诸佛现前授记　多佛授记者皆蒙印可授记作佛　四结观

是为遍观一切色身相名第九观　一切之言或总指所见诸佛或别在弥陀诸相。二释并通　五简辨

作此观者名为正观若他观者名为邪观　文可解　第十观音观二。初结前标后。二正示观法　初结前标后

佛告阿难及韦提希见无量寿佛了了分明已次复当观观世音菩萨　二正示观法四。初示境二结观三劝修四简邪正　初示境九。初观身二观光三观冠四观面五观臂六观手七观足八指同九简辨　初观身三。初身量二身色三顶髻　初身量

此菩萨身长八十万亿那由他由旬　二身色

身紫金色　三顶髻

顶有肉髻　二观光二。初顶光二身光　初顶光二。初光量二光中变化　初光量

顶有圆光面各百千由旬　二光中变化

其圆光中有五百化佛如释迦牟尼佛一一化佛有五百化菩萨无量诸天以为侍者　如释迦者丈六身也　二身光

举身光中五道众生一切色相皆于中现　五道众生合修罗故。菩萨垂形五道救苦众生故于光中现其色相　三观冠二。初观体二冠中化佛　初观体

顶上毗楞伽摩尼宝以为天冠　毗楞伽即摩尼珠也　二冠中化佛

其天冠中有一立化佛高二十五由旬　冠中化佛以表带果而行用　四观面

观世音菩萨面如阎浮檀金色眉间毫相备七宝色流出八万四千种光明一一光明有无量无数百千化佛一一化佛无数化菩萨以为侍者变现自在满十方世界　五观臂

臂如红莲华色有八十亿微妙光明以为璎珞其璎珞中普现一切诸庄严事　六观手

手掌作五百亿杂莲华色手十指端一一指端有八万四千画犹如印文一一画有八万四千色一一色有八万四千光其光柔软普照一切以此宝手接引众生　七观足二。初举足相二下足相　初举足相

举足时足下有千辐轮相自然化成五百亿光明台　轮有千轮号千辐轮　二下足相

下足时有金刚摩尼华布散一切莫不弥满　即踏莲华金刚摩尼二宝所成　八指同

其余身相众好具足如佛无异　九简辨

唯顶上肉髻及无见顶相不及世尊　二结观

是为观观世音菩萨真实色身相名第十观　真实色身即应身也　三观修四。初指前劝观二彰功力三举闻以况四教次观。初指前劝观

佛告阿难若有欲观观世音菩萨者当作是观　当作是者即上诸相不可异故　二彰功力作是观者不遇诸祸净除业障除无数劫生死之罪　不遇诸祸除现难也。除无数劫罪破往业也　三举闻以况

如此菩萨但闻其名获无量福何况谛观　闻名获福如普门品广说　四教次观

若有欲观观世音菩萨者先观顶上肉髻次观天冠其余众相亦次第观之悉令明了如观掌中　从上至下以为次第　四简邪正

作是观者名为正观若他观者名为邪观　解同前　第十一势至观四。初观行相二结示色身三彰益四双结　初观行相三。初身相二行相三坐相　初身相五。初身量二观光相三观天冠四观肉髻五指余相　初身量

次观大势至菩萨此菩萨身量大小亦如观世音　如观音者亦八十万亿那由他也　二观光相二。初顶光二身光　初顶光

圆光面各百二十五由旬照二百五十由旬　百二十五由旬计五千里此即光体照则倍之　二身光三。初示色量二有缘得见三因光得名　初示色量

举身光相照十方国作紫金色　二有缘得见

有缘众生皆悉得见　修此观者即有缘人　三因光得名二。初从光立名二从威势为名　初从光立名

但见此菩萨一毛孔光即见十方无量诸佛净妙光明是故号此菩萨名无边光　因见菩萨一毛光即见十方诸佛光。从光立名　二从威势为名

以智慧光普照一切令离三涂得无上力是故号此菩萨名大势至　以光照众生拔苦与乐。从威势为名。无上力者即十力也　三观天冠三。初华二台三台中现土　初华

此菩萨天冠有五百宝华　二台

一一宝华有五百宝台　三台中现土

一一台中十方诸佛净妙国土广长之相皆于中现　四观肉髻二。初色相二瓶光变现　初色相

顶上肉髻如钵头摩华　钵头摩此云赤莲华　二瓶光变现

于肉髻上有一宝瓶盛诸光明普现佛事　五指余相

余诸身相如观世音等无有异　谓面臂手等　二行相二。初十方震动二动处庄严　初十方震动

此菩萨行时十方世界一切震动　二动处庄严

当地动处有五百亿宝华一一宝华庄严高显如极乐世界　他方动处宝华高显与极乐无异　三坐相二。初国土动摇二分身说法。初国土动摇

此菩萨坐时七宝国土一时动摇　即本国也　二分身说法

从下方金光佛刹乃至上方光明王佛刹于其中间无量尘数分身无量寿佛分身观世音大势至皆悉云集极乐国土侧塞空中坐莲华座演说妙法度苦众生　具举上下含摄中间诸佛刹土。三圣化身来集填空说法化导　二结示色身

作是观者名为正观若他观者名为邪观见大势至菩萨是为观大势至色身相名第十一观　同前所辨　三彰益

除无数劫阿僧祇生死之罪　即是破障　四双结

作是观者不处胞胎常游诸佛净妙国土此观成已名为具足观观世音大势至　结前观音势至二观。不处胞胎等者脱娑娑苦生佛净土宝莲孕质永绝胞胎。从顶至足总摄身相故云具足。文牒二名故知双结　十二十三两观前观依报第六总观。今此普杂亦即总观三圣。普观则先观自身后见依正。杂观则唯观正报大小不同。先别后总摄机斯足。对文可见　第十二普观三。初示观相二结名义三彰感应　初示观相二。初想自身二明普见　初想自身二。初蹑前二起后　初蹑前

见此事时　二起后四。初起心往彼二莲中跏坐三想花开合四花开光照。初起心往彼

当起自心生于西方极乐世界　二莲中跏坐

于莲华中结跏趺坐　三想花开合

作莲华合想作莲华开想　四花开光照

莲华开时有五百色光来照身想眼目开想　二明普见二。初圣众满空二依正说法　初圣众满空

见佛菩萨满虚空中　佛菩萨者即三圣也　二依正说法

水鸟树林及与诸佛所出音声皆演妙法与十二部经合出定之时忆持不失　水鸟树林依报说法。及诸佛者正报说法。仍须合教以验真妄　二结名义

见此事已名见无量寿佛极乐世界是为普观想名第十二观　双结依正故得普名　三彰感应　无量寿佛化身无数与观世音大势至常来至此行人之所　三圣常来安慰印可　第十三杂观三。初拣机二示观法三结示　初拣机

佛告阿难及韦提希若欲至心生西方者　若欲者则拣非欲不预此法也　二示观法二。初观佛一观二菩萨　初观佛五。初先观小身二后观大身三举像况真四身量不定五指余诸相　初先观小身

先当观于一丈六像在池水上　顺此方机故观丈六。不言坐立应是立像　二后现大身

如先所说无量寿佛身量无边非是凡夫心力所及然彼如来愿力故有忆持者必得成就

先所说者指前佛观。凡夫心劣虽不能观。仗佛愿力有想必成　三举像况真

但想佛像得无量福况复观佛具足身相　想像获福观真可知　四身量不定

阿弥陀佛神通如意于十方国变现自在或现大身满虚空中或现小身丈六八尺　佛无大小随机有异　五指余诸相

所现之形皆真金色圆光化佛及宝莲华如上所说　金色圆光如前佛观。宝莲即花座观　二观二菩萨二。初示同异教令辨识二明随侍以显须观　初示同异教令辨识

观世音菩萨及大势至于一切处身同众生但观首相知是观世音知是大势至　身同众生即彼徒众中下二辈形相全乖。诸大菩萨则有相滥。经云众生生者皆是阿鞞跋致。其中多有一生补处。其数甚多等。但观首相可辨二圣。观音冠有立佛势至髻有宝瓶　二明随侍以显须观

此二菩萨助阿弥陀佛普化一切　助佛行化即影响众由常随侍故必观之　三结示

是为杂想观名第十三观　三圣不同大小有异故云杂想也　十四已下三种观彼徒众。三辈九品并所观境。因明生相人多惑之。今谓文中所叙并是已生彼国之人。当本修因感果之相以为三种近观之境。又云为令识位有上中下即是大本三品也。今谓大本三品皆标发菩提心。可对今经上三品耳。中下二品则非所对。况复因行与今全别。寻经校之方知不尔。今明上三品即彼菩萨众也。中三品即彼声闻众也。下三品即彼人民众也。三辈九品摄尽彼方圣凡之众。又复三辈各分高下如后具明。第十四上辈有五。一发菩提心大乘心也。二解第一义大乘解也。三修行诸行大乘行也。四深信因果大乘信也。五回向往生大乘愿也。如此五法上三品中出没互见。上品上生具五。经明三心三行是也。上品中生有四。唯缺大行。经云善解义趣是也。上品下生有三。缺于解行。经云但发无上道心是也。若无第一不为上品。若无四五即不往生。故上三品即摄补处不退初心诸大菩萨也　第十四上辈三。初上品上生二上品中生三上品下生　初上品上生三。初标二释三结　初标

佛告阿难及韦提希上品上生者　二释四。初修因二感胜缘三见已得生四生后益　初修因二。初发三心二修三行　初发三心

若有众生愿生彼国者发三种心即便往生何等为三一者至诚心二者深心三者回向发愿心具三心者必生彼国　发三心者菩提心也。亦名无上道心。一至诚者。求佛菩提决定坚固至佛不移也。二深心者。于大乘法闻思修习至佛不已也。释论云。智度大海唯佛穷底故云深也。三回向发愿所修功德普施众生至佛无尽。若对三聚初即摄律仪无恶不断故必至诚。二即摄善法无善不修故必渐深。三摄众生无生不度故必回施。若对三佛初是断德法身佛也。二即智德报身佛也。三即恩德应身佛也。果有三佛因必三心。不可缺一。余广如别　二修三行二初列行相二示时限　初列行相

复有三种众生当得往生何等为三一者慈心不杀具诸戒行二者读诵大乘方等经典三者修行六念回向发愿愿生彼国　发上三心必修三行。然有径修三行义具三心故云复有三种众生等。一不杀是诸戒之首故别标之。具诸戒行此上品中须纳大乘菩萨戒。依善戒经先受五十具后受菩萨戒故云诸戒此即对上至诚心也。二读诵经典不唯读诵必须学解发生智慧。此即对深心也。三回向发愿对上可知。仍加六念即念三宝及戒施天名大乘六念也　二示时限

具此功德一日乃至七日即得往生　少至一日多至七日举少况多欲彰功胜。则知菩萨大行一念能行犹为佛种。况一日七日宁不往生耶　二感胜缘三。初众圣来迎二弥陀光照三众圣同音　初众圣来迎

生彼国时此人精进勇猛故阿弥陀如来与观世音大势至无数化佛百千比丘声闻大众无数诸天七宝宫殿观世音菩萨执金刚台与大势至菩萨至行者前　精进勇猛即能感也。精进不懈勇猛不退。阿弥下彰圣应。佛与大众共集其前。七宝宫殿即佛居处。金刚台即莲华座。下云此紫金台如大宝华是也。但此金刚与下为异。二圣共执付与乘之　二弥陀光照与众接引

阿弥陀佛放大光明照行者身与诸菩萨授手迎接　三众圣同音赞叹劝进

观世音大势至与无数菩萨赞叹行者劝进其心　三见已得生

行者见已欢喜踊跃自见其身乘金刚台随从佛后如弹指顷往生彼国　得生所感圣境故必欢喜。形留神往有如蝉蜕。十万亿土刹那即至彼佛威神众生业力。易躯换报如反掌耳　四生后益五。初见佛菩萨二闻法得悟三游历十方四获记还国五证总持门　初见佛菩萨

生彼国已见佛色身众相具足见诸菩萨色相具足　生彼即见与下为异　二闻法得悟

光明宝林演说妙法闻已即悟无生法忍　说妙法者大乘法也。得无生忍即断证也　三游历十方

经须臾间历事诸佛遍十方界　承事诸佛习学方便　四获记还国

于诸佛前次第授记还到本国　即佛观云诸佛现前授记是也　五证总持门

得无量百千陀罗尼门　陀罗尼此翻总持。一能持善二能遮恶。即于无量法门无不通达　三结

是名上品上生者　二上品中生三。初标二释三结　初标

上品中生者　二释四。初修因二感缘三得往生四生后益　初修因二初行业二发愿　初行业

不必受持读诵方等经典善解义趣于第一义心不惊动深信因果不谤大乘　上二句示缺行也。善下彰有解也。第一义者了达诸法毕竟空寂。由从缘起无自性故出过诸法故云第一。心不惊者不狐疑也。信因果者诸法虽空善恶因果无毫差也。如此信解方契大乘岂有谤耶　二发愿

以此功德回向愿求生极乐国　回此功德向彼庄严故云回向。若无愿求纵有信解不出轮回　二感缘三。初众圣来迎二赞叹安慰三授手接引　初众圣来迎

行此行者命欲终时阿弥陀佛与观世音大势至无量大众眷属围绕持紫金台至行者前　紫金台亦即莲花　二赞叹安慰

赞言法子汝行大乘解第一义　从法化生故名法子　三授手接引

是故我今来迎接汝与千化佛一时授手　三得往生

行者自见坐紫金台合掌叉手赞叹诸佛如一念顷即生彼国七宝池中　弹指一念经文互举　四生后益九。初经宿花开二身变金色三宝华承足四众圣光照五开悟深法六下台礼赞七不退菩提八游行十方九得忍获记

初经宿花开　此紫金台如大宝华经宿则开　二身变金色

行者身作紫磨金色　准大本中彼土众生身皆金色。此中特标必应殊异　三宝华承足

足下亦有七宝莲华　四众圣光照

佛及菩萨俱时放光照行者身　五开悟深法

目即开明因前宿习普闻众声纯说甚深第一义谛　六下台礼赞

即下金台礼佛合掌赞叹世尊　七不退菩提

经于七日应时即于阿耨多罗三藐三菩提得不退转　即七日已得不退转　八游行十方

应时即能飞行偏至十方历事诸佛　具六神通故能飞行　九得忍获记

于诸佛所修诸三昧经一小劫得无生忍现前授记　一小劫者亦据此土一增减为言　三结

是名上品中生者　三上品下生三初标二释三总结　初标

上品下生者　二释四初修因二感缘三得生四生后益　初修因二。初有信发心二回向愿求　初有信发心

亦信因果不谤大乘但发无上道心　显无解行　二回向愿求

以此功德回向求生极乐国　义同前释　二感缘

行者命欲终时阿弥陀佛及观世音大势至与诸菩萨持金莲华化作五百佛来迎此人五百化佛一时授手赞言法子汝今清净发无上道心我来迎汝　金莲花亦即台座赞言清净者既发大心必离诸恶故　三得生

见此事时即见自身坐金莲华坐已华合随世尊后即得往生七宝池中　不言时限同前一念　四生后益五。初华开二见佛三闻法四游历五入位　初华开

一日一夜莲华乃开　二见佛

七日之中乃得见佛虽见佛身于众相好心不明了　三闻法

于三七日后乃了了见闻众音声皆演妙法　四游历

游历十方供养诸佛于诸佛前闻甚深法　五入位

经三小劫得百法明门住欢喜地　百法明门者华严云初地菩萨于刹那顷得百三昧见百诸佛。神通能过百佛国能动百佛世界。光明遍照百佛世界能成就百众生能知过去未来百劫能入百法门能现百身。复为一身以百菩萨庄严眷属。若仁王经有千法明门万法明门等。欢喜地即初地。初登圣果多欢喜故　三总结

是名上品下生者是名上辈生想名第十四观　三品行相如上已明。今更重分。浅深有异。一临终接引异。上生佛菩萨接中生与千化佛接下品下生五百化佛接。二所乘华座异。上生金刚台中生紫金台下生金莲花。三见佛闻法异。上生到即见闻中生经宿下生七日至三七日。四花开异。上生已开中生经宿下生一日一夜。五证入异。上生到彼即证中生一小劫下生三小劫寻文可见　第十五中辈三品此摄四果声闻众。经云彼佛有无量无边声闻弟子皆阿罗汉等。问彼国纯一大乘清净良伴何有小乘声闻耶。答此土声闻则有二种。一者定性谓沈空滞寂取灭度者。往生论云二乘种不生即此类也。二不定性谓中间回向。已经开显知常获记。虽是声闻不住小果。法华真阿罗汉涅槃出家菩萨净土声闻即同此类。已闻大教发菩提心。但先学小乘闻说苦空无常无我发其本习先证小果终归大乘。此三品中上生常持五八十具四种戒行。中生亦持四戒但一日一夜。下生孝养仁慈。上二专持佛戒并有回向愿求。下一止依世教故但临终遇善。三阶行别故分高下　第十五中辈三初中品上生二中品中生三中品下生　初中品上生三初标二释三结　初标

佛告阿难及韦提希中品上生者　二释四。初修因二感缘三得生四生后益　初修因二。初明行业二示愿求　初明行业

若有众生受持五戒持八戒斋修行诸戒不造五逆无众过患　五八在家二众戒。诸戒即包十具出家五众戒。五戒者一不杀二不盗三不邪淫四不妄语五不饮酒。八戒加三。六不着花鬘缨络香油涂身七不坐高床及不歌舞倡伎八不过中食。淫断邪正名加净行。齐一其心故名八齐。禁闭诸根亦名八关。广如律中。然此四戒或道或俗各持。或出家兼具。既持净戒必离众过。五逆过中之大故特标之　二示愿求

以此善根回向愿求生于西方极乐世界　善根为因生彼是果　二感缘三。初众圣现前二光明照触三说法开悟　初众圣现前

临命终时阿弥陀佛与诸比丘眷属围绕　二光明照触

放金色光至其人所　三说法开悟

演说苦空无常无我赞叹出家得离众苦　赞叹出家即明此品。多收道众。离苦者近离尘缘远清烦惑　三得生

行者见已心大欢喜自见己身坐莲华台长跪合掌为佛作礼未举头顷即往生极乐世界　坐莲礼佛识神即脱　四生后益三。初花开二闻法三得道　初花开

莲华寻开当华敷时　合有见佛文略不明　二闻法

闻众音声赞叹四谛　赞四谛者顺所习故。苦集二谛世间因果是所断。灭道二谛出世因果是所证。四法皆实故并名谛　三得道

应时即得阿罗汉道三明六通具八解脱　阿即翻无罗汉为生。结惑已尽不受后有故言无生亦云应供杀贼。如别所明。三明者过去宿命明现在漏尽明末来天眼明。三皆洞彻独得称明。六通一天眼二天耳三他心四宿命五如意六漏尽。六皆无壅故总名通。八解脱亦名八背舍。一内有色相外观也(不怀内身骨人而观外色不净此位在初禅)二内无相外观也(怀灭内骨人观外不净得入二禅)三缘净背舍身作证(除外不净定心清洁名缘净以无著心受三禅乐名身证)四虚空处背舍(灭四禅色心缘无边空而入定知无常苦空心厌背故)五识处背舍(舍空缘识入定知无常生厌背)六无所有处背舍(舍识缘无所有入定知无常生厌背)七非有想非无想背舍(舍无所有缘非非想入定知无常生厌背)八灭受想背舍(背灭受舍诸心心数法入定休息名背舍)余如法界次第　三结　是名中品上生者　二中品中生三。初标二释三结　初标

中品中生者　二释四。初修因二感缘三得生四生后益　初修因二。初行业二愿求　初行业

若有众生若一日一夜受持八戒斋若一日一夜持沙弥戒若一日一夜持具足戒威仪无缺　文略五戒前略十具。前后互见必具四戒。沙弥戒即十戒。前八戒中分七为二。加不捉金银钱宝。具足戒即大僧大尼所受戒。七支具发遍该生境故云具足　二愿求

以此功德回向愿求生极乐国戒香薰修　持戒净业以求净报。持戒成德名称远闻。故喻如香　二感缘二。初见佛众圣二闻空赞叹　初见佛众圣

如此行者命欲终时见阿弥陀佛与诸眷属放金色光持七宝莲华至行者前　放光照触持花迎取　二闻空赞叹

行者自闻空中有声赞言善男子如汝善人随顺三世诸佛教故我来迎汝　三世诸佛并劝持戒断恶修善。故今持戒即是随顺　三得生

行者自见坐莲华上莲华即合生于西方极乐世界　花合即生亦一念顷　四生后益三。初见佛二闻法三获证　初见佛

在宝池中经于七日莲华乃敷华既敷已开目合掌赞叹世尊　文叙赞叹理合先见　二闻法

闻法欢喜　闻法亦即四谛苦空无常等下品同然　三获证

得须陀洹经半劫已成阿罗汉　须陀洹此翻逆流谓逆生死流即初果也　三结

是名中品中生者　三中品下生三初标二释三总结　初标

中品下生者　二释四。初修因二。遇缘三得生四生后益　初修因

若有善男子善女人孝养父母行世仁慈　执劳侍奉顺色承志故名孝养父母。儒教以为百行之本。推爱及物博施济众故云行世仁慈。儒宗以为君子之德由生前积善故临终遇缘　二遇缘

此人命欲终时遇善知识为其广说阿弥陀佛国土乐事亦说法藏比丘四十八愿　以善化人众所知识。知其道德识其仪貌。法华妙庄严王云善知识者是大因缘。即指妻儿为善知识。故知但能开导不局僧俗。国土乐事如上依报及大小弥陀经所说。法藏比丘者弥陀因名。昔为国王遇世自在王佛弃国出家。即于佛前发四十八愿具如大本　三得生

闻此事已寻即命终譬如壮士屈伸臂顷即生西方极乐世界　此中合有临终持花接引等事文略不叙。壮士屈伸顷亦即少时前后语变　四生后益三。初花开二闻法三得道　初花开

生经七日遇观世音及大势至　经文但云七日不说花开　二闻法

闻法欢喜　二圣说法未及见佛　三得道

得须陀洹经一小劫成阿罗汉　三总结

是名中品下生者是名中辈生想名第十五观　前二品临终见佛蒙光闻法。下品并无前二。生已见佛闻法。下品但见观音势至。上二并叙乘花而去到彼花开。下品不明义须合有但文略耳。上生应时即得四果。中生半劫下生一劫寻对可了　第十六下辈三品并无修因。皆是平生作恶临终遇善。准十疑论若无宿善今亦不遇故。此三品不无远因。上生但泛尔作过不知惭愧。中生所叙多是出家五众希贪名利毁破戒律。下生即造十恶五逆诸极重罪。罪有轻重故分三等　第十六下辈三。初下品上生二下品中生三下品下生　初下品上生三。初标二释三结　初标

佛告阿难及韦提希下品上生者　二释四。初生来造恶二临终遇缘三见相得生四生后利益　初生来造恶

或有众生作众恶业虽不诽谤方等经典如此愚人多造恶法无有惭愧　作众恶业明非极重不谤经典尚有正信　二临终遇缘二。初知识开导二化佛来赞　初知识开导二。初闻法除业二称名灭罪　初闻法除业

命欲终时遇善知识为说大乘十二部经首题名字以闻如是诸经名故除却千劫极重恶业　二称名灭罪

智者复教合掌叉手称南无阿弥陀佛称佛名故除五十亿劫生死之罪　经题佛号功力难思。灭罪劫数文中趣举　二化佛来赞二。初化众来迎二赞叹接引　初化众来迎

尔时彼佛即遣化佛化观世音化大势至至行者前　二赞叹接引

赞言善男子汝称佛名故诸罪消灭我来迎汝　三见相得生

作是语已行者即见化佛光明遍满其室见已欢喜即便命终乘宝莲华随化佛后生宝池中　四生后利益三。初花开二观音说法三闻法入证　初花开

经七七日莲华乃敷　二观音说法

当华敷时大悲观世音菩萨及大势至菩萨放大光明住其人前为说十二部经　十二部经一切诸佛所说经法。总大小乘有十二类亦名十二分教。一契经二重颂三授记四讽诵五无问自说六因缘七譬喻八本生九本事十方广十一未曾有十二论义部即类也　三闻法入证

闻已信解发无上道心经十小劫具百法明门得入初地　此下三品生彼闻法皆发大心。前中三品但明小果。以其先发大心故不明耳。百法明门义同前释　三结

是名下品上生者　二下品中生三。初标二释三结　初标

佛告阿难及韦提希下品中生者　二释四。初造恶因二遇知识三得往生四生后益　初造因三。初别列四过二总结四过三示来报　初别列四过四。初毁戒过二犯盗过三说法过四无惭过　初毁戒过

或有众生毁犯五戒八戒及具足戒　文略沙弥戒　二犯盗过

如此愚人偷僧祇物盗现前僧物　僧物最重故特标之。僧祇此翻大众。即常住物有二。一常住常住即寺宇米谷等。二十方常住即供僧食饮等。现前僧物亦二。一现前现前谓据数即分者。二十方现前谓作相普施者。四种僧物盗皆结犯。经云五逆四重我亦能救。盗僧物者我所不救。斯极诫也　三说法过

不净说法　言不净者假托佛法希求利养　四无惭过

无有惭愧　公然造作内无羞耻　二总结四过

以诸恶业而自庄严　恶迹盈满故云庄严　三示来报

如此罪人以恶业故应堕地狱　应堕狱者应犹合也　二遇知识三。初业相现前二知识开导三闻法灭罪　初业相现前

命欲终时地狱众火一时俱至　地狱众火即镬汤炉炭镕铜铁丸等。天台云火车相现即火轮也。因中果相自心中业　二知识开导

遇善知识以大慈悲即为赞说阿弥陀佛十力威德广说彼佛光明神力亦赞戒定慧解脱解脱知见　说佛功德有三。一十力二光明三五分法身。十力者。一是处非处力(佛知说法因缘果报从是因不生是果佛悉遍知)。二业智力(佛知一切众生三世诸业因缘果报)三定力(佛知一切诸佛三昧)四根力(佛知他众生诸根上下)五欲力(佛知众生种种乐欲)六性力(佛知世间种种性)七至处道力(佛知一切道至处相)八宿命力(佛知种种宿命一世二世乃至百千世劫)九天眼(佛天眼净见众生生死业报等相)十漏尽力(佛诸漏尽故无漏心解脱)五分中上三可解。修因感果名解脱。五住二死究竟永尽果后起用名解脱知见　三闻法灭罪

此人闻已除八十劫生死之罪地狱猛火化为清凉风吹诸天华华上皆有化佛菩萨迎接此人　感圣来迎以闻佛德一念信受转恶为善。火化清风境随心变其速若此　三得往生

如一念顷即得往生七宝池中莲华之内　四生后益三。初花开二二圣说法三闻法获益。初花开

经于六劫莲华乃敷　二二圣说法

观世音大势至以梵音声安慰彼人为说大乘甚深经典　三闻法获益

闻此法已应时即发无上道心　三结

是名下品中生者　下品下生三初标二释三总结　初标

佛告阿难及韦提希下品下生者　标中上中两辈止于上品标佛告等。独下三品一一别标者以作恶往生反常骇众易惑难信故频标示。意令听受　二释四。初造恶因二遇缘三得生四生后益　初造恶因二。初叙现业二示来报　初叙现业

或有众生作不善业五逆十恶具诸不善　五逆者杀父杀母杀阿罗汉破和合僧出佛身血。违负恩德故名五逆。生报即随阿鼻名五无间业。十恶者即身三口四意三一切恶业皆十摄之。既作极重余无不为故云具诸不善。问大本云下至十念不生我国不取正觉唯除五逆诽谤正法。今经五逆亦得生者。今解若据弥陀愿力岂遮造逆之徒。方便赴机言乖趣合。彼则显乐邦殊妙欲进于善人。此明净业功深不遗于极恶。但使持名回愿无不灭罪往生故。观佛三昧经云四部弟子谤方等经作五逆罪犯四重禁等。如是等人若能至心一日一夜系念观佛一相好者。诸恶罪障皆悉消灭。引彼证此罪灭何疑　二示来报

如此愚人以恶业故应堕恶道经历多劫受苦无穷　随犯一逆阿鼻一劫何况多犯故经多劫　二遇缘二。初知识开导二胜相现前　初知识开导四。初说妙法二病苦不能三教修十念四灭罪数　初说妙法

如此愚人临命终时遇善知识种种安慰为说妙法教令念佛　说妙法者赞净土也。令念佛者作观想也　二病苦不能

此人苦逼不遑念佛　遑暇也　三教修十念

善友告曰汝若不能念彼佛者应称无量寿佛如是至心令声不绝具足十念称南无阿弥陀佛　心观为念口诵为称十念谓十声也　四灭罪数

称佛名故于念念中除八十亿劫生死之罪　念念即约佛声　二胜相现前

命终之时见金莲华犹如日轮住其人前　花如日轮者喻其量也。若准俱舍日面径五十一由旬。今此但取地居仰望。大小未必如论　三得生

如一念顷即得往生极乐世界　四生后益三。初花开二二圣说法三闻法获益。初花开

于莲华中满十二大劫莲华方开　二二圣说法

观世音大势至以大悲音声为其广说诸法实相除灭罪法　罪从缘生无有自性。诸法皆尔故名实相。普贤行法云一切业障海皆从妄想生。若欲忏悔者端坐念实相是也　三闻法获益

闻已欢喜应时即发菩提之心　三总结

是名下品下生者是名下辈生想名第十六观　第三显示利益二。初众见彼土依正庄严二随机获益　初众见彼土依正庄严

说是语时韦提希与五百侍女闻佛所说应时即见极乐世界广长之相得见佛身及二菩萨　前但韦提独见今此大众皆睹　二随机获益三。初夫人入证二五百侍女发心获记三诸天发心　初夫人入证

心生欢喜叹未曾有豁然大悟逮无生忍　豁然大悟破无明也。逮无生忍证法性也　二五百侍女发心获记

五百侍女发阿耨多罗三藐三菩提心愿生彼国世尊悉记皆当往生生彼国已得诸佛现前三昧　问往生论女人根缺皆不得生今何违者。答非谓此土女及根缺不得生彼。盖言生彼国者不受女人及根缺报耳。以弥陀发愿若有女人未生我国复受女像不取正觉。又云国中人天不具三十二大人相者不取正觉。　是知彼无女人及根缺也。余如十疑论说　三诸天发心

无量诸天发无上道心　佛在幽宫说此观法。阿难目连侍佛左右。止有夫人侍女诸天以为听众余无闻者。后还灵山阿难重述。菩萨大众始得同闻　第三流通分二　初至皆大欢喜幽宫即座付属流通。二尔时世尊下还归崛山转说流通。由此二处众闻信受展转传授流注无究　初幽宫付属四。初立名教持二劝修获益三付属忆持四众闻欢喜　初立名教持二。初双问名持二别答　初双问名持

尔时阿难即从座起前白佛言世尊当何名此经此法之要当云何受持　一问经名二问持法故云双问　二别答二。初示名二教持　初示名二。初从能观所观为名二约功用为名　初从能观所观为名

佛告阿难此经名观极乐国土无量寿佛观世音菩萨大势至菩萨　总包依正但缺徒众。首题避烦但摘五字包摄亦备　二约功用为名

亦名净除业障生诸佛前　灭罪往生是经力用　二教持

汝当受持无令忘失　智论云信力故受念力故持。既受且持则无忘失　二劝修获益五。初见境胜二灭罪胜三自身胜四伴侣胜五果报胜　初见境胜

行此三昧者现身得见无量寿佛及二大士　势至圆通云若众生心忆佛念佛现前当来必定见佛　二灭罪胜

若善男子善女人但闻佛名二菩萨名除无量劫生死之罪何况忆念　举闻况念其胜可知　三自身胜

若念佛者当知此人是人中分陀利华　分陀利此云白莲花一人间奇瑞二性洁无染故以比焉　四伴侣胜

观世音菩萨大势至菩萨为其胜友　补处为友无宜自轻　五果报胜

当坐道场生诸佛家　坐道场者谓成佛也。得道之场故名道场。一切诸佛皆于菩提树下趺坐断惑破魔成道。法身一体诸佛同证。故是佛家。势至章云去佛不远。小本经云皆得不退阿耨菩提。并同此意　三付属忆持

佛告阿难汝好持是语持是语者即是持无量寿佛名　意令对说持名功大持经亦然　四众闻欢喜

佛说此语时尊者目犍连尊者阿难及韦提希等闻佛所说皆大欢喜　欢喜者一所未曾闻今得闻故。二清净国土得往生故。三展转开示利生无穷故。具斯诸义故怀大喜　二转说流通三。初佛还本处二阿难转说三众闻礼散　初佛还本处

尔时世尊足步虚空还耆阇崛山　据佛王宫说经时久。或众不散待佛还来。或是再集。皆不可测　二阿难转说

尔时阿难广为大众说如上事　累嘱忆持意见于此　三众闻礼散

无量诸天及龙夜叉闻佛所说皆大欢喜礼佛而退　照前列众文略龙天。阿难亲闻代传佛语故云闻佛说也

佛说观无量寿佛经义疏卷下(终)

观无量寿经者。净业之正因。除障之胜行。超凡入圣之妙术。长生不死之神方也。是以。受持代盛疏钞人伙。如吾祖灵芝律师义疏。综括众说芟除繁琐。文词简古义理精明。可谓得治经之旨矣。师正思念常处五浊。提诱群有令入佛道也。及读高僧传。慧布法师曰。方土虽净非吾愿。若使十劫莲华中受乐。何如三途苦处救众生也。既符所见。愈轻净业。而后染重病色力痿羸。心识迷茫总失趣向。且知志虽洪大力未堪忍。忽觉前非深自感伤。因见天台十疑论云。初心菩萨未得无生忍。要须不离佛。又引智度论曰。具缚凡夫有大悲心。愿生恶世救苦众生。无有是处。譬如婴儿不离母弱羽可传枝矣。于是弃掷平生之所业。博寻西方教二十余年。作疏为赞勉诱来者。此疏其一也。师讳元照。字湛如。自号安忍子。若其道德高辉敷映。僧史唯欣净之一门。未尽其致。得之师之礼忏仪序中。卒撮梗槩以告于兹矣。此疏始科与疏不接。本经言亘两端起尽易惑。一览之次。分科于文前。入疏于经间。缮写成一本。密助捡阅之费功。或人曰。寿诸梓广于世可乎。岂止非便初学。抑又西资之益不少也。余以是于或者之言也。今经疏者佛祖经疏。纵令刊行流布得非狂简乎。遂投书肆以充其需。非敢进之先达。只与同志人俱之。浅识所窥。错谬定多。聊俟英俊之订正。庶繙看之辈。观解顿发。共游唯心之净土。愿行速就。各见本性之弥陀矣。时宽文十二岁次壬子四月八日释湛慧书于洛东山戒光丈室


观无量寿经义疏(本)

    No. 1749 [cf. No. 365]

观无量寿经义疏(本)

        净影寺沙门释慧远撰

此经开首先知五要然后释名。何者五要。第一须知教之大小。教别二藏谓声闻藏及菩萨藏。教声闻法名声闻藏。教菩萨法名菩萨藏。差别义如常释。此经乃是菩萨藏收。第二须知教局渐及顿。小教名局。大从小入目之为渐。大不由小谓之为顿。此经是其顿教法轮。何故得知。此经正为韦提希说。下说韦提是凡夫。为凡夫说不从小入。故知是顿。第三须知经之宗趣。诸经所辨宗趣各异。如涅槃经涅槃为宗。如维摩经以不思议解脱为宗。大品经等以慧为宗。华严法华无量义等三昧为宗。大集经等陀罗尼为宗。如是非一。此经观佛三昧为宗。第四须知经名不同。诸经立名差别不等。或有就法如涅槃经般若经等。或复就人如萨和檀太子经等。或有就喻如金刚明大云经等。或有就事如枯树经等。或复就处如彼伽耶山顶经等。或复就时如时经等。或人法为名如胜鬘经等。或事法双举如彼方等大集经等。或法喻并陈如法华经法鼓经等。如是非一。今此经者人法为名。佛是人名说观无量寿是其法名。诸经列人凡有四种。一举说人如维摩经胜鬘经等。二举问人如弥勒问经等。三举所说人如萨和檀太子经等。四举所为人如玉琊经须摩提女经等。今此言佛举其说人。第五须知说人差别。诸经起说凡有五种。如龙树辨。一佛自说二圣弟子说三神仙说四诸天鬼神所说五变化说。此经五中是其佛说。以知五要。次释其名。初言佛者标举说人。此翻名觉。觉有两义。一觉察义对烦恼障。烦恼侵害事等如贼唯圣觉知不为其害故名为觉。此之一义如涅槃说。二觉悟义对所知障。无明昏寝事等如睡圣慧一起朗然大悟如睡得寤故名为觉。所对无明有其二种。一性结无明迷覆实性。对除彼故觉法实性故名为觉。二事中无知于事不了。对除彼故觉知一切善不善等三聚之法故名为觉。故地持云于义饶益聚非义饶益聚非非义饶益聚平等开觉故名为佛。既能自觉复能觉他觉行穷满称之为佛。言自觉者简异凡夫。言觉他者别异二乘。觉行穷满彰异菩萨。是故独此名之为佛。下次举其所说之法。口音陈唱目之为说。系念思察说以为观。无量寿者是所观佛。观佛有二。一真身观二应身观。观佛平等法门之身是真身观。观佛如来共世间身名应身观。真身之观如维摩经见阿閦品说观身实相。观佛亦然。我观如来前际不来后际不去今则不住如是等也。要而论之。妙绝众相圆备诸义。妙绝众相乃至无有一相可得。圆备诸义乃至无有一德不具。虽具众德同体义分。犹如虚空无碍不动无有彼此差别之相。以无彼此差别相故诸根相好皆遍法界如海十相同体周遍。以周遍故用眼为门。诸根相好及佛刹土一切众生莫不皆悉一眼中。观余相好皆悉同然。其应身观如彼观佛三昧经。取佛形相系想思察名应身观。此佛应身随化现形相别彼此不得一种。应身观中有始有终。闻菩萨藏知十方界有无量佛系想思察令心分了。以如是等粗净信见名之为始。以大神通亲往礼觐或复往生面睹供养名真实见此以为终。真身观中亦有始终。闻菩萨藏知佛法身系心思察粗净信见名之为始。息除妄想内觉相应说以为终。今此所论是应身中粗净信观矣。应身观中有通有别如彼观佛三昧经说。泛取佛相而为观察定无彼此名之为通。观察弥勒阿閦佛等说以为别。今此所论是其别观。别观西方无量寿佛。然佛名号有通有别。如来应供正遍知等是其通号。释迦弥勒阿閦佛等是其别号。别中立名乃有多种。或从种姓如迦叶佛释迦佛等。或就色身如身尊佛身上佛等。或就音声如妙音佛妙声佛等。或就光明如妙光佛普明佛等。或就内德如功德佛智慧佛等。或就譬喻。喻别种种或从寿命。今此所观从寿为名。然佛寿命有真有应。真如虚空毕竟无尽。应身寿命有长有短。今此所论是应非真。故彼观音授记经云无量寿佛命虽长久亦有终尽。故知是应。此佛应寿长久无边非余凡夫二乘能测故曰无量。命限称寿。问曰此经非直观佛亦观刹土观音势至九品生等。何故偏名观无量寿。观佛为主故偏举之。又复诸事不可具名且举观佛。经者外国言修多罗此翻名綖(或线)。圣人言说能贯诸法如綖贯花。是故就喻名之为綖。而言经者綖能贯花经能持纬其用相似故复名经。若依俗训经者常也。教之一法迳古历今恒有曰常。此经始终文别有三谓序正流通。从初乃至世尊何缘与提婆达为眷属来是其由序。唯愿为我说无忧下是其正宗。阿难白佛言当何名此经下是其流通。化女有由故先明序。由序既兴正陈所说故次明正宗。为说既周欲以所说传布末代叹胜劝学付传于后故明流通。就初序中文别虽众义要唯二。一发起序二证信序。言发起者佛将说经先托时处神力集众起发所说名为发起。以此发起与说经为由名发起序。证信序者阿难禀承欲传末代先对众生言如是法我从佛闻证成可信名为证信。以此证信与传经为由名证信序。其义且然文别如何。初如是我闻一向证信。一时佛下义有两兼。取其本事发起之义判为发起。阿难引来证成可信名为证信。义既两兼不可偏取。人情是非备如常辨。就初一向证信序中三门辨释。一解如是我闻之言有之所由二明立意三释如是我闻之言。言所由者何缘经首得有如是我闻之言以佛教故。佛何故教阿难请故。彼何缘请由其阿泥楼驮教故。彼何缘教由见阿难心忧恼故。阿难比丘何故忧恼由见如来般涅槃故。佛将灭度在双林间北首而卧。是时阿难以佛将灭心怀忧恼莫能自胜。阿泥楼驮。遂开觉阿难。汝传法人何不请佛未来世事徒悲何益。阿难对曰我今心没忧海知何所问。阿泥楼驮遂教阿难请问四事。一问佛灭度后诸比丘等以何为师。二问佛灭后诸比丘等依何而住。三问恶性比丘云何共住。四问一切经首当置何字。阿难被教心少醒悟遂便请佛。佛依答之。言诸比丘何为师者当依波罗提木叉为师。若我住世无异于此。木叉是戒比丘所学故说为师。言诸比丘依何住者当依四念处住。何谓四念处。谓比丘观内身修身观精勤一心除世贪爱。如是观外身内外身受心法亦如是。是谓比丘所依住处。故经说言若住四念名自境界不为魔缚。若住五欲名他境界为魔所缚。恶性比丘云何共居者梵檀治之。若心调伏为说离有无经。梵檀胡言此方名为默不共语。一切缘首置何字者当置如是我闻等言。故今经首同有如是我闻之言。第二次明建立如是我闻之意。佛本何缘教置此言为生物信。如是之言云何生信。阿难自已信顺佛语导佛语。如言佛语是令他众生同己生信。我闻之言云何生信。阿难自是不足人。若言此法是己所说人多不信。由言此法从佛闻故人皆同信。生信如是。信有何义而为生乎。信乃是入法初门摄法上首。凡入佛法要先起信。故经论中说信为手。如人有手至珍宝所随意采取。若当无手空无所获信亦如是。入佛法者有信心手随意采取道法之宝。若当无信空无所得故为生之。第三门中次释如是我闻之言。先解如是人解多种。今正论之解有两义。一约法解二约人解。言约法者阿难道佛言如诸法故名为如。如来所说皆称前法。说理如理说事如事说因如因说果如果。如是一切故名为如。如法之言是当道理目之为是。良以乖法名为非故如法名是。言约人者今释迦说如于过去一切佛说故名为如。异说则非如说者是故曰如是。言我闻者阿难对彼未来众生陈已餐说故曰我闻。闻实是耳何故言我。诸根之别皆我用具。就主彰名故言我闻。问曰法中无人何处有主而言就主说为我闻。释言法中虽无定主非无假名统御之义故得称我。故涅槃云譬如四兵合以为军。虽无定主亦得称言我军勇健胜彼。此亦同然。问曰阿难得理圣人。以何义故同凡说我。释言阿难虽复说我不同凡夫。云何不同。如龙树释。说我有三。一见心说我。谓诸凡夫见使未忘我见心中称说有我。二慢心说我。谓诸学人见使虽除慢使犹在我慢心中称说有我。三随世流布宣说有我。谓无学人见慢已除。随世流布宣说其我。然今阿难结集法时身居无学见慢已除。随世流布宣说其我故不同凡。问曰无我道理精胜。阿难今者何不就胜宣说无我。乃随世俗宣说我乎。化我众生法须如是。若不说我何由可得标别彼此使人识知。是故乃至诸佛化人亦自说我。一时已下义虽两兼对前一向证信序故自下偏就发起以释。就中随处开分为二。文别有五。言处二者一异处起化序。佛在耆阇玄起后时王宫之化。二佛从耆阇崛山没下身往摄化序。此与胜鬘大况相似。诸经之中此例非一。文别五者初言一时明起化时。第二明佛标其化主。三在王舍下明起化处。四与大下辨列徒众。五尔时王舍大城已下明起化事。初一时者有人异解备如常破。今正论之。为化之晨目之为时。于佛一代化时众多。简别余时是故言一。与涅槃中我于一时在迦尸国。我于一时在王舍城。我于一时在恒河岸。我于一时在尸首林其言相似。勿得异释。佛如前解。第三处中在王舍城就宽通举。此城古昔多在王住名王舍城。耆阇崛山随处别指。此翻名为灵鹫山也。多有仙灵居住此山。并有鹫鸟居在此。山名灵鹫山。又亦翻名为鹫头山。以诸鹫鸟居此山顶名鹫头山。又此山顶像似鹫头名鹫头山。游化处中目之为在。法身平等实无栖托示化有方故云在耳。以何义故偏在此处。此义如彼法华论释。为显胜法故在斯耳。以诸城中王舍最胜五山之中耆阇最好故寄表法。第四众中先列声闻后彰菩萨。诸经多尔。何故而然。解有三义。一近远分别。以诸声闻常随如来故明佛后随近先列。菩萨不尔是故后论。何故声闻偏近如来。解有两义。一谓诸声闻智解微劣未闲道法。虽得圣果进止威仪常须佛教故多近佛。是故如来乃至双林常为制戒。如涅槃中制诸声闻不食肉等。菩萨人深闲道法不假佛教故不近佛。二以声闻现蒙佛度越凡成圣荷恩深重故常随佛围侍供养。菩萨随感游化不定故不近佛。此是第一近远分别。二形相分别声闻之人威仪严整世共尊敬故列在前。菩萨随化形仪不定故彰在后。如经中说。文殊一夏三处安居。迦叶呵罚即其事也。三就德分别。如龙树说教有二种。一秘密教。菩萨德尊理宜在先。声闻德劣法须在后。二显示教。声闻辟支同佛漏尽故列在先。菩萨之人随化现凡不断诸漏。若闻菩萨在罗汉上人多惊怪故列在后。今依显示先列声闻后彰菩萨。声闻众中初言与者以身兼彼称之为与。大比丘者标列其众。大外国名曰摩诃。此翻有三。一名为多如多人聚名曰大众。二名为胜胜过余道。三名为大广备高德。比丘胡语此方义翻备含五义。一名怖魔。将出家时令魔战怯故曰怖魔。比丘出家何豫魔事而生恐怖。魔性姡弊惧他胜己故生怖畏。又畏比丘化他同出空其境界是故恐怖。如涅槃说。此之一义就初彰名。二名乞士。既出家已无所贮畜乞求自活故名乞士。三名净名。正命乞求离邪命法故曰净命。此二就其中间立称。四名净持戒。精进持戒无有毁犯。五名破恶。以持戒故破离诸恶。此后两义据终为目。非一称众。言千二百五十人俱列其数也。此千二百五十比丘诸经多列。何故而然。佛初得道先度迦叶兄弟三人并其徒众合有一千。次第来至彼舍城中。度舍利弗及大目连并其徒众二百五十合为一千二百五十。此等诸圣蒙佛先度舍邪归正荷佛恩重常随供养故多列之。下列菩萨。言菩萨者标其众别。外国正名菩提萨埵翻者略之直云菩萨。此方翻之名道众生。菩提名道萨埵名众生。良以此人内心求道而有道行。以道成人名道众生。若尔声闻缘觉之人斯皆求道同有道行并以道成。何故独此偏名菩萨。释言贤圣名有通别。通则义齐。故涅槃云乃至须陀亦名菩萨。求索尽智无生智故。亦名为佛正觉共道不共道故。乃至诸佛亦名须陀修习无漏逆生死故。为分贤圣是故独此名为菩萨。等分贤圣何故独此偏名菩萨。解有三义。一就愿心望果分别。唯此众生期大菩提余悉不求是故独此名道众生。故地论言上决定者愿大菩提故独言菩萨故义当斯耳。二就解心望理分别。凡夫住有二乘着无。有无乖中不会中道。是故不得名道众生。菩萨不尔妙舍有无契会中道。是故其人名道众生。三就行分别。入佛法中凡有三门。一教二义三者是行。教浅义深行为最胜。声闻软根从教为名。声者是教餐声悟解故号声闻。缘觉次胜从义立目。缘者是义从缘悟解故号缘觉。菩萨最胜就行立称。行谓自利利他之道。以能成就自利利他俱利之道名道众生。故地持云声闻缘觉但能自度。菩萨不尔。自度度他名为道胜。以道胜故名道众生。三万二千辨其数也。文殊上首列其名字。亦得名为简胜异劣。文殊师利此云妙德。自下第五明起化事。于中有二。一明频婆为子幽禁如来遣人为之说法。二时阿阇世问守门下明韦提希为子禁闭如来自身往彼摄化。以何义故前宜遣人后身自往。释言前者频婆沙罗宜愿闻法遣人传授为化义足故身不往。韦提夫人求生净国净土之化非佛不开故须身赴。何故举此恶逆之事而为起发。为彰此界极恶可厌令人弃背。亲王之子犹相危害何况他人。即欲使人同悕净土故。下韦提对佛说言唯愿为我说无忧处我当往生。不乐阎浮浊恶之世。即其事也。就初段中文别有四。第一明其频婆沙罗为子幽禁。二国大夫人名韦提下明其夫人密奉王食以济王身。三嗽口毕下圣为说法以润王心。四如是时间迳三七日下明王因食兼由闻法多日不死。初中尔时王舍大城有太子名阿阇世举禁父人。言尔时者当佛在于王舍城时。王舍大城出其处所。有一太子指斥其人。名阿阇世辨其名讳。此方翻之名未生怨。未生之日相师占之。此儿生已定当害父。因以立字名未生怨。随顺调达恶友之教者明禁父缘。事如经说。提婆达多是佛堂弟阿难亲兄。出家之后修得五通。托阿阇世而为檀越。又于一时往至佛所求索徒众。世尊年迈众宜付我我当教示。佛时呵曰舍利弗目连神通大智吾尚不以徒众付之。况汝痴人食唾者乎。调达闻之遂生嗔恕。往世王所说彼世王初生之日被伤因缘劝其害父。自身为王我杀瞿昙自己为佛。新王新佛共匡世间不亦乐乎。世王因是生心害父。故今说言随顺调达恶友之教也。自下明禁父。收执父等禁闭其身制诸群臣一不得往遮不见人。频婆娑罗往昔有何因遭此危害。如涅槃说。频婆沙罗往昔为王。于毗富山游行猎鹿空无所获。值遇一仙。王便作念正坐此人驱逐令去。遂敕杀之。仙人临终便发恶愿愿我来世还如今日心口害汝。彼仙今日阿阇世是。敕害者频婆王是。是故今时还为世王之所危害。自下第二明其夫人密奉王食以济王身。于中先明夫人奉食。后王食之。前中初言国大夫人名韦提希标列其人。此是世王亲生之母。恭敬大王明心敬也。由敬奉食所以举之。澡浴净等身奉食也。王食可知。自下第三明圣为说以润王心。于中初明频婆启请。时目连下圣赴为说。请中初言嗽口毕已牒前起后。合掌遥礼身业请佛欲使如来垂哀授法故身礼也。而作言下口请目连。言大目连是吾亲友欲令汝赴愿兴慈悲授我八戒求哀汝授。圣为说中初明目连应前口请为授八戒。如鹰隼飞疾至王所对前吾亲身业赴也。日日如是授王八戒对前求戒口言授也。何者八戒。不杀不盗不淫不妄语不饮酒不歌舞唱伎及往观听不着香薰衣及余严身具不上高广床不得过中食是其八也。此乃是九何得言八。若依毗昙。不着香薰衣不上高床此二同是庄严处起合以为一是故言八。若依成实及大智论。前八是戒后一是齐。齐戒合说名八戒齐。八戒齐义广如别章。此应具论。此八是其在家之人持出家法故令授之。下明如来赴其身请遣人为说。何不自往义如前释。何故偏遣富楼那为说。以富楼那诸弟子中说法最上巧开人心故偏遣之。下第四明频婆沙罗因食闻法多日不死。相显可知。自下第二明其夫人为子幽闭佛往摄化。于中有四。一明夫人为子幽禁。二时韦提希被幽闭下因禁请佛。三未举头下佛与弟子因请赴就。四时韦提希见世尊下因见伤叹。初中有三。一明世王欲害其母。二时有臣下臣劝不听。三敕内宦下余嗔禁母。初中三句。一阿阇世问守门者。王今在耶。二守门者以事具答。三王闻嗔怒即欲害母。于中初言闻此语已明嗔所由。怒其母等口言呵骂其母。名父为贼名母为伴。后诃沙门以为恶人。言显可知。即执剑下身欲加害。此初段竟。第二臣劝不听之中文曲有四。一臣劝不听。二王见惊怖。三耆婆重劝。四王闻放母。就初段中先列劝人。为王礼下明其劝相。时二大臣说此语下劝已舍去。劝人可知。就劝相中作礼身劝白等口劝。于中初先彰昔异今。初劫已来无量恶王无人害母。王今已下明今异昔。今若害母汗刹利种。臣不忍下明已嫌恶。臣不忍闻心不忍也。杀母眼见何得言闻。谓不忍闻世人传说。不宜住此身不住也。上来劝竟下明舍去。说此语竟结前起后。以手按剑却行而退正明舍去。臣已背王恐王危害。以剑自防故须按之却行退矣。上来臣劝。自下第二王见惊怖。世王惊惧内心怖也。由见二臣按剑而退恐为异计所以惊怖。告耆婆等口言问也。恐彼背己亲向父王故今问之不为我也。耆婆白下是第三段耆婆重劝慎莫害母。是劝辞也。王闻此下是第四段因劝放母。闻此语者闻前耆婆重劝之辞忏悔求救悔前愆也。谓悔向前欲害之愆求彼二臣令不杀己故曰求救。即便舍剑止不害母息后过也。息彼杀事。上来四段合为第二臣劝不听。敕语已下是第三段明阿阇世余嗔禁母。余嗔未止并恐其母更奉王食故敕闭之。从阿阇世问守门者至此第一明韦提希为子被幽闭。自下第二因禁请佛。谓请如来令遣弟子与己相见。于中有三。一将请先礼。二作是言下发言正请。三作是语已悲泣已下请已重礼前中初言被幽闭已牒前起后。愁忧憔悴明心恼也。向耆阇等身业礼也。礼即身请。第三发言正请之中世尊昔时恒遣阿难来慰问我。举昔类今望佛必遣。今我愁等求今同昔。我今愁忧彰己有苦。世尊威重无由得见不敢望佛。愿遣已下请遣弟子与己相见。韦提何故求见目连及与阿难。良以目连是家门师阿难佛侍先恒往来故偏求见。又复夫人居住深宫偏求见一宜相不便故并求见。求见何为。韦提内心厌此恶界求生净土。欲令二人泣传意请佛。所以求见。第三段中作是语已悲泣雨泪望佛哀怜。遥向佛礼求遂所请。前已礼竟今复重礼表己殷勤。自下第三佛与弟子随请赴就。于中初言未举头顷明赴时也。机会难差故彼韦提未举头顷圣即赴之。尔时已下明圣赴就。尔时世尊在耆阇山彰圣所在。知韦提希心之所念内心知也。敕大目连及以阿难口言敕也。佛耆阇没于王宫出身自赴也。为赴韦提深敬之意故敕弟子乘空而去。如来自身此没彼现。又复韦提禁闭深宫地行难赴故现此变。韦提希向前求见弟子。如来何故自身亦去。净土之化非佛不开传说难尽故须身往。自下第四明韦提希因见伤叹。于中初见后对伤叹。就前见中时韦提希礼已举头明见时也。见世尊等正明所见。佛及弟子并是大夫世仪须避。宫合之化无宜辄处。故与弟子在空而现。下明伤叹。韦提见佛牒前所睹。自绝璎珞举身投地身业懊恼。白世尊下口业怨伤。我宿何罪生此恶子伤己宿愆。世尊何缘与提婆达共为眷属问佛往因。又复前句自伤恶子。后句怨佛有恶徒众。由提婆达教阿阇世兴造恶逆故为此怨。自下第二明其正宗。文别有四。一韦提通请。二尔时世尊放眉间下佛为通现。三韦提白佛是诸佛土虽复净下韦提别请。四尔时世尊即便微笑下如来别显。初中有四。一求生净国。二不乐阎浮浊恶世下明厌秽土。三今向世尊五体投地下对前所厌忏灭恶因。四唯愿佛日教我下对前所忻请问善因。初中唯愿专求辞也。专心求佛故曰唯愿。无忧处正明所求。净土安适名无忧处。我当往生明求所为。第二明厌中不乐阎浮提浊恶世者总明所厌。不乐阎浮即为一门。明厌人中怨害之苦。不乐浊恶复为一门。明厌娑婆恶道之苦。此浊恶下别明所厌还明前二。从初乃至多不善聚显前不乐浊恶世也。明有三途苦果。所以不乐此浊恶处。牒前总中浊恶世也。指此娑婆为浊恶处。地狱畜生饿鬼盈满明有三途恶道果也。地狱外国名曰泥梨。杂心释言不可乐故名为地狱。地持释曰增上可厌名曰泥梨。此皆约就厌心以释非是当相。当相论之。地下牢狱。是彼罪人受报处故曰地狱。言畜生者杂心释言以傍行名为畜生。此乃辨相非解名义。名义云何。盖乃从主畜养为名。一切世人或为驱使或为啖食畜养此生故曰畜生。言饿鬼者杂心释言以多求故名为饿鬼。此亦辨相非解名义。正解名义者饥渴名饿虚怯多畏目之为鬼。三千刹土同有此恶故曰盈满。多不善聚恶道因也。无人不起故名为多。又常现行亦名为多。杀盗淫等违理损物说为不善。积集称聚。以此浊世具有向来不善因果所以不乐。愿我未来不闻恶声不见恶人显前不乐浮提也。以阎浮提有其恶行有其恶人所以不乐。宿世罪行今逢恶人。罪行名字名为恶声。愿己不闻尚不欲闻。况复更造未来所逢。阿阇世等造逆众生名为恶人。愿更不见亦可如彼。阇世等所作造罪名之为恶。恶逆名字名为恶声。愿己不闻尚不欲闻况复逢值。造逆之者名为恶人。愿己不见此是第二明己所厌。自下第三对前所厌忏灭恶因。今向世尊五体投地明忏方便。两手二足及与头顶是其五体。五轮设礼为敬法尔故云投地。求哀忏悔正明忏也。求佛哀怜听己忏谢故曰求哀。忏摩胡语此云悔过。胡汉并举故曰忏悔。彼韦提希何时造罪今求忏悔。谓过去世。韦提何缘知过有罪。今求忏悔。释言韦提今生恶子为之被幽闭。将果验因明过有罪。恐此罪业现偿不尽当更受之故须忏悔灭。自下第四对前所忻请问善因。唯愿佛日启告所求。佛能破坏众生痴闇如日除昏故曰佛日。教我观于清净业处正明所请。余妙佛土纯善所归。是故名为清净业处。此净业处愿教我观。自下第二如来对请为其通现通现一切诸佛国土。于中初先放眉间光。如来眉间有一毫毛白如珂雪。其长一丈五尺五寸之围。其间空中如琉璃筒宛转右旋。今从此相而发光明。次明所放照无量土还集佛顶变为金台。后明台中广现诸国令韦提见。问曰韦提乐生安养。何不望直为现彼国而通现乎。若不通现无由得显弥陀最胜增其深乐故。故通现之。自下第三韦提别请。别请安养韦提白佛是诸佛国虽复清净皆有光明通领前现。我今乐生极乐世界阿弥陀佛所偏彰所求。唯愿教我思惟正受请问其因。思惟正受两门分别。一定散分别。下三净业散心思量名曰思惟。十六正观说为正受。第二就彼十六观中随义分别。初二想观名曰思惟。地观已后十四种观依定修起说为正受。自下第四如来别显。于中有二。一身放光明利益彼王。二口言说法利益夫人。前中初明佛光照王。王后得益。王先须陀故今增进成阿那含。益夫人中初佛为说。说是语已韦提夫人五百侍女得无生下明其得益。前中有四。一略示其处去此不远。二汝当系下总劝观察。三我为汝广说喻下显示说相并显说益。四欲生彼国修三福下正说生业。初中汝知阿弥陀佛去此不远者十万亿刹名为不远。就第二段总劝观中。汝观彼国劝观依报。净业成者劝观正报。谓佛菩萨及与三品往生人等名业成者。第三段中我今为汝广说众喻显已说相。下以此方日水等相并以此方佛菩萨像类度于彼方名为众喻。亦令已下明说利益。现益韦提兼益余凡故云亦令一切凡夫修净业者得生西方。第四段中文别有二。一教修习三种净业散善往生。二佛告阿难下教其修习十六正观定善往生。前中初先总劝观修习次别列之后总结叹。欲往彼国当修三福是总劝也。别中初门共凡夫法。第二是其共二乘法。第三大乘不共之法。初门之中先明作善。孝养奉事师长敬上行也。慈心不杀慈下行也。修十善业是其止行。身除三邪口离四过意断三恶是其十也。广如别章。此应具论。第二门中受持三归在家戒也。此亦即是沙弥十戒。三归之义广如别章。此应具论之。具足众戒不犯威仪出家戒也。不犯四重名具众戒。离余轻过说为威仪。又离性罪名具众戒。谓离一切杀盗淫等离余遮过名不犯威仪。谓离一切饮酒过等。第三门中先修自利后明利他。前自利中发菩提心明起愿也。菩提是道佛果圆通说为菩提。起意趣向名发心。要而论之。如佛所得我亦当得如是等也。菩提心义广如别章此应具辨。深信因果明修信也。读诵大乘明修解也。行能运通目之为乘。乘别有三诸佛所乘余二不加是故言大。此前自利劝进行者是其利他。上来别列下总结叹。如此三事名为净业是总结也。告韦提希此三种业三世诸佛净业正因是叹辞也。定善生中观别十六。一是日观二是水观三是地观四是树观五是池观六是总想观一切楼树池等七华座观八佛菩萨像观九佛身观十观世音观十一大势至观十二自往生观十三杂明佛菩萨十四上品生观十五中品生观十六下品生观。此十六中初之七门观其依报。后之九门观彼正报。前言汝当谛观彼国是初七观。净业成者是后九观。观别如是。然今文中初之六观一处论之。后十观门一处而辨。华座之观应与前六一处论之。以与佛观相起义便故在后说。前六观中文别有三。一佛敕许说二韦提请问三如来为说。初中有五。一总对阿难及韦提希敕听许说。二善哉下别对韦提叹前快问。三阿难下别对阿难劝持劝说。四如来今下佛自彰己所说有益。五韦提汝是凡夫下显已说相。就初段中先告二人。次敕谛听及以善思。谛犹审也。善是好也。下许为说。如来今为未来众生恼。贼苦者说清净业烦恼侵害故说为贼。能起五恶牵生五痛五烧等事名之为苦。为说净业而为对治此。说日等六种观门以为净业。第二段中善哉韦提是总叹辞。善犹好也。哉是助辞。快问此事出其所叹。由前请问广开往生净土之业所以叹之。第三段中初敕阿难。今自受持。后敕阿难广为他说。第四段中如来今者举能教人。教韦提等举所教者。近教韦提远教未来一切众生。圣意普也。观于西方极乐世界出所教事。前六观中未教观人。是故直言观极乐土。以佛力下明观利益益有三种。一佛力故见。见之分了故如明镜自见面像。由佛教力并由神力故得见之。二由见心喜。三应时下由见心喜得无生忍。由知彼国从心而现达本无法故得无生。无生理也。慧心安理名无生忍。忍具有五如仁王经说。一是伏忍在于种性解行位中学观诸法能伏烦恼故名为伏。二是信忍二三地于无生理信心决定名为信忍。三者顺忍四五六地破相入如趣顺无生名为顺忍。四无生忍七八九地证实离相名无生忍。五寂灭忍十地已上破相毕竟冥心至寂证大涅槃名寂灭忍。今言无生是第四门。下文宣说韦提希等得无生忍即其事也。第五段中告韦提希汝是凡夫彰其分齐。不能远观彰所不堪。韦提夫人实大菩萨。此会即得无生法忍。明知不小亦化为凡。心想劣等正明不堪。心想羸劣明心不能远照彼土。未得天眼明目不能远见彼国。有异方便令汝得见明已巧示。此即略显说之相也。教观此方日水等事令知彼方名异方便令得见矣。上来第一佛敕许说。自下第二韦提启请。韦提白佛我以佛力故见彼国领荷佛恩明己已见。韦提前于佛光台中得见彼国名佛力见。若佛灭下为他请问。灭后众生浊恶不善明有恶因。浊谓五浊。何等为五。一曰命浊命报短促。二众生浊无其人行。三烦恼浊诸结增上。四者见浊谓谤不信。五者劫浊所谓饥馑疫病刀兵。此五同能浊乱净心故名为浊。恶者五恶。杀盗邪淫妄语饮酒是其五也。不善是其十不善业。身三口四及意三邪是其十也。亦可五恶通说以为浊恶不善。五苦所逼明有苦果。如大经说。五痛五烧是其五苦。何者五痛。有人造作杀盗邪淫妄语饮酒现遭危难王法刑罚是其五痛。何者五烧。即前五恶当堕三途受诸苦毒名为五烧。云何当见阿弥陀佛极乐世界正为启请。自下第三佛为宣说。是中应先解净土义然后释文。义如别章。文中初先教其观日令知方所。后五教观彼土严相。日观有三。一总劝观二教三结。汝及众生应当专心想于西方是总观也。云何下教。云何问也。凡作下教。一切有目皆见日没举所观事。当起想下正教观察。是为下结。第二观中文别有四。一辨观相二是为下结三此想成下显其成相四如此想者名粗见下结成分齐。初中有四。一作水想二变水成冰三者变冰以为琉璃四观琉璃以成大地。于中有三。一观琉璃内外映彻二见地下宝柱承擎三见地上诸相庄严。庄严有四。一以众宝间错其地二宝出杂光成诸楼观三楼观两边有诸华幢四华幢上多有乐器演出妙音。余皆可知。第三观中文别有五。一辨观相依三昧见名为地想二是为下结三佛告下劝持劝说四若观下明观利益五作是观下辨观邪正。第四观树文别有三。一结前生后以为起发二辨观相三总结之。文显可知。第五观水文亦有三。一总生起二辨观相三总结之。八功德水者清净不臭轻冷濡美饮时调适饮已无患是其八也。清净色入不臭香入轻冷及濡是其触入美是味入后二法入。下第六门是其总观。文别有四。一辨观相二总结之三明观益四辨观邪正。初中有四。一观宝楼二树三地四观宝池。就观楼中初正观楼次观楼上及虚空中多诸音乐后结成相名为粗见

观经义疏(本终)观无量寿经义疏(末)

        净影寺沙门释慧远撰

后十观中文别有四。一佛对阿难及韦提希敕听许说辨劝传持。二由佛劝韦提求见故令彼佛菩萨俱现。三由彼观韦提设礼仰荷佛力为物启请。四因其请如来为说后十观法。前中三句。一对二人敕听劝思。二许宣说。除苦法者由观灭罪舍此生彼名除苦法。三劝持劝说。第二段中初先明其佛菩萨现后明所现威光无比。第三段中初明韦提因见设礼次荷佛力现有所睹后为物请。文显可知。第四佛说余十观中相从为四。初五。一分佛菩萨观次有一门自往生观次一复明佛菩萨观后三明其他生之观。就前五中初之一门作佛座观次一作彼佛二菩萨三像之观后三作彼佛二菩萨真身之观。初坐观中文别有六。一辨观相二是为下结三阿难下辨明此坐得成所由谓法藏愿力故成四若欲下重显观仪五此想成下明观利益六作此下辨观邪正。文皆可知。就像观中文别有四。一辨观相第二令与修多罗下明观邪正三是为下结四作是下明观利益。初中复四。第一略观唯观一佛二菩萨像。二此想成下明观成相。三一一树下明其广观。观诸树下皆有一佛二菩萨像。四此相成下还显成相。就初略中先观佛像后明观察二菩萨像。佛像观中先劝观佛为佛所表。后正观像劝观佛中应先解释三佛之义然后释文。义如别章。此中所观是应身也。文中有三。一结前生后以为起发见前事已次当想佛。二所以下释劝所以。三是故应当一心念下结劝观察。第二段中所以者何征问起发。佛身出情所以劝想。下对释之。佛法界身入于一切众生心中故劝想之。是故已下明佛心想即成前佛入众生心义。于中四句。一明心是佛。言是故者乘前显后。是佛法身入于一切众生心故。心想佛时是心即是诸佛相好。二明心作佛成前心是。三是心是佛结前初句。四诸佛遍知从心想生结前第二。云何名作云何名是。两义分别。一就佛观始终分别。始学名作终成即是。二现当分别。诸佛法身与己同体。现观佛时心中现者即是诸佛法身之体名心是佛。望己当果。由观生彼名心作佛。上来第二释劝所以。自下第三结劝观察。言是故者是佛法身入于一切众生心故应当一心系念观彼阿弥陀佛。佛号无量略举四种。佛是佛号义如前解。多陀阿伽度是如来号。乘如实道来成正觉故曰如来。阿罗诃者此名应供。佛具智断合可供养故名应供。外国语中三名相通。一阿罗诃此云应供。二阿罗汉此云无生亦云无著。三阿卢诃此云杀贼。今举初义。三藐三佛陀此翻名为正真正觉。三之言正藐之言真三复名正佛陀名觉。上劝观佛为像所表。想彼佛者先想像下正劝观像。文显可识。前观佛像下次观察二菩萨像。先为二坐后正观察二菩萨像。上来一段是其略观。余如前释。文显可知。佛身观中别有四。一结前生后二广辨观想三是为下结四辨观邪正。第二段中文复有四。一广辨观相二见此事者即见十方下明观利益三观无量寿佛从一相好下重辨观义四见无量寿佛即见十方下重辨利益。初中先别念佛众生摄取不舍已下总以结劝。前中有三。一观佛身色二佛身高下观其大小三于圆光下观其多少。初段可知。观大小中句别有五。一观身大小高六十万亿那由他恒河沙由旬。二举毫相大小如须弥。须弥举高三百三十六万里纵广亦然。彼佛高相过此五倍。三眼大小如四大海。准此白毫及眼大小以度其身。身量太长准身度其白毫及眼其量太小。是事云何。凡世人身五尺者一寸之眼。身于其眼不过长短五六十倍。佛亦应然。无量寿佛眼如四大海。一海纵广八万由旬。四海合有三十三万六千由旬。身过其眼五六十倍纵令极多无出百倍。何缘佛身得六十万倍那由他恒河沙由旬。准眼定身正长六十万倍那由他由旬。言恒河沙者或传译者谬而置之。若身实长六十万亿那由他由旬白毫及眼便是极小。当亦是其传者谬矣。观音势至身量大小准佛身量长短未定。四身光大小一一毛光如须弥山。五圆光大小犹如百亿三千世界。就第三段明多少中句别有五。一明光中化佛多少。于圆光中有其百亿那由他恒河沙化佛。二侍者多少一一化佛无数菩萨以为侍者。三明相多少有其八万四千诸相。四明好多少彼一一相各有八万四千之好。五明光多少于一一好各有八万四千光明。上来别观。念佛众生下总以结劝念佛众生摄取不舍。光明相好及以化身不可具说结以显多。但当忆等是劝辞也。此初段毕。自下第二明其观益。于中有三。一明得见阿弥陀佛即得见于一切佛身。二明得见阿弥陀佛身即见佛心。三结劝观察。初中三句。一明见前阿弥陀佛身相事者即见十方一切诸佛。诸佛体同故得见一即见一切。二明由见一切佛故即得具足念佛三昧。三作是观下结以显益。第二段中句亦有三。一明见身即见佛心。身由心起故得见身即得见心。又由见身心想转明故得见心。二佛心者大慈悲下辨佛心相。谓无缘慈普摄众生。然慈悲心有大有小。攀缘分别名之为小。心想都灭而于众生无所分别自然现益目之为大。小中有三。一众生缘。缘诸众生欲与其乐欲拔其苦。二者法缘。观诸众生无我无人但有五阴生灭法数而行慈悲。无我无人云何行慈。如维摩说自念为生说如斯法故名为慈。又念众生妄为我人之所缠缚深可哀伤故行慈悲。既无众生为谁说法念谁为我之所缠缚。经言无者但无人性。非无幻化假名众生故得为说念之被缚。三者无缘。观阴空寂本无所有而行慈悲。法既不有云何行慈。亦有两义。一念为生说如斯法。即是第一义乐与人故名为慈。二念众生妄为有法之所缠缚深可哀伤故行慈悲。法既不有何处有人而为说乎。释言据彼菩萨自心实不见人亦不见法。不见法故无所言说。不见人故无可为说。故经说言平等法界佛不度生。据彼众生以望菩萨。于众生外别有菩萨。闻彼菩萨说无人法舍妄契实同其所得便言菩萨为生说法。故经说言众生强分别说佛度众生。此前三种缘观修习通名为小。大无量心亦有三种。一众生缘。无心攀缘一切众生而于众生自然现益。故涅槃云我实不往慈善根力令诸众生见如是事。二者法缘。无心观法而于诸法自然普照。如日照物无所分别。三者无缘。无心观如而于平等第一义中自然安住。今此所论是其大中众生缘也。故今说言以无缘慈摄取众生。此是第二辨佛心相。三作此观者舍身他下结明观益。此是第二明见佛心。是故智下是第三段结劝观察。上来第二明观利益。观无量寿从一相下是第三段重显观仪。四见无量寿佛即见十方无量佛等重显观益。此是第二广辨观相第三总结。第四辨邪正。文显可知。次观观音文别有六。一结前生后二此菩萨下广显观相三是为下结四佛告下明观利益五若有下重显观仪六作是下辨观邪正。第二段中观相有十。一观身相二观顶相三观圆光四观宝冠五观面相六观毫相七观璎珞八观手相九观足相十其余下并举余相指同前佛。初观身中先观身量。向前佛身长六十万亿那由他恒河沙由旬。此菩萨身长八十万亿那由他恒河沙由旬。后观身色色如紫金。观顶可知。观圆光中句别有三。一观光中化佛多少二观化佛侍者多少三观化佛色身光明。五道众生皆于中现。观宝冠中先观宝冠后观冠中化佛大小。第五门中观其面色如阎浮金。观毫相中句别有五。一观毫色色如七宝。二观毫光。第三观察毫相光中化佛多少四观化佛侍者多少五观化佛所现神变。现自在满十方界下观璎珞及手足等。文皆可知。自余总结观益观仪及观邪正。文亦可知。势至观中文别有五。一总生起二辨观相三总结之四除无数下明观利益五此观成下总结观音及大势至二观成义。第二段中文别有七。一观身相二观宝冠三观肉髻四观宝瓶五诸余下并举余相同观音六行时下观其行相七坐时下观其坐相。初观中先观身量如观世音。后观身光。于中先观身光广狭。二有缘下明光利益有四。一有缘皆见此菩萨一毛孔光即见十方一切佛光。以此菩萨与一切佛法身体同故见此光即见一切诸佛光矣。二是故下结叹其名名无边光。三智慧下明光利益。明照众生令离三涂得佛上力。四结叹其名名大势至。次五可知。观坐相中初劝坐时一切动摇后明分身无量诸佛观音势至悉皆云集演说妙法。上来第二广辨观相。第三总结。第四观益。第五总结观音势至二观成义。文皆可知。此二相须故今总结。上来一分佛菩萨观。次下一门自往生观。于中有五。一往生想二与十二下明其观仪三见此下彰成分齐四总结之五明观益。化佛菩萨恒至其所。初中有七。一往生想二于花中跏趺坐想三花合想四花开想五莲华开时有诸光明来照身想六眼目开想七见佛菩萨及闻法想。余皆可知。次下一门重复明其佛菩萨观。何故须重。向前所辨佛菩萨观凡下不及故此复重教凡观察。于中先辨后总结之。辨中先明观察佛身后观菩萨。观佛有六。一正教观察丈六之像在池水上。像表彼佛池水表彼琉璃之地。二如先下辨明须教观像所以。如前所说。佛身无边非凡所及故教观像。三然彼下明诸凡夫观者必成生人学意。由彼如来本愿力故观者必成。四但想下明观多益劝人观察。但观形像得无量福。况复佛身。五阿弥陀下明其所观若大若小皆是佛身拂去众疑生人重意。众云何疑。前闻佛身广大无量。今闻观小疑非佛身于小不敬。故须拂遣明皆是佛生其重意。六所现下明其所现。大小虽殊色身相好与前不异遮人异观。人闻大小皆是佛身谓作异相亦得观察故说如前防其异观。下观菩萨。于中初明观音势至于一切处身同众生难以取别。但观已下教人别之。但观首相即知二别。此观头首非观手足。观音顶上有其化佛势至顶上有其宝瓶。故观二首便知别矣。此二菩萨助阿弥陀者彰此二菩萨助化多益令人必观下总结之。此佛菩萨通以观察故名为杂。自下三观合为一分为他生观。观察他人九品生相。何故观此。为令世人知其生业上下阶降修而往。生所以劝观。于中先以六门分别。然后释文。其六门者。一定别其人二辨其因三明去时见佛不同四明到彼生时有异五彰生彼得益差别六释会经论。初定其人粗分为三细分有九。粗分三者谓上中下。大乘人中种性已上说为上品。小乘人中从凡至圣持戒无犯说为中品。大乘人中外凡有罪说为下品。细分九者上辈有三。所谓上上上中上下。大乘人中四地已上说为上上。生彼即得无生忍故无生地。理实于中亦有多时得无生者。经言即得就胜为言。初二三地信忍菩萨说为上中。经说生彼过一小劫得无生故。理实于中亦有二劫三劫得者。经言一劫就近为语。问曰地持说初地上要过一大阿僧祇劫方至八地。此经何故说一小劫即得无生。解有三义。一时劫不同如华严说。娑婆一劫当无量寿一日一夜。彼中一劫当此娑婆无量无边阿僧祇劫。地持据此故说一大阿僧祇劫方至八地。观经就彼弥陀国界长劫为言故说一劫得无生忍。二去处异。地持所说一大僧祇至八地者说初地去。观经所云过一小劫到无生者就信忍中终处为语。信忍之终在于三地。若就初地不唯一劫能得无生。三所到别。地持所说一大僧祇到于八地。观经所论迳一小劫得无生者到第七地初得无生在七地故。上中如是。种性解行说为上下。经说此人过三小劫得百法明到初地故。问曰地持说从种性一大僧祇方到初地。观经何故说三小劫已到初地。释言时劫不同故尔。地持据此娑婆短劫说一大阿僧祇劫方到初地。观经就彼弥陀长劫故说三劫得至初地。问曰地持说从种性到初地时过于一大阿僧祇劫。初地至八地亦过一大阿僧祇劫。今此何故宣说上中经一小劫即得无生。宣说上下过三小劫方到初地。理实齐等举之左右。前说上中经一小劫得无生忍者。就信忍中终处为语。所说上下过三小劫到初地者。就伏忍中始处为语。此一左右。又前宣说经一小劫得无生者。望于七地无生之始不至过处。后云三劫至初地者。到其过处。此二左右。上辈三人分齐粗尔。中辈亦三。所谓中上中中中下分齐何处。小乘人中前三果人说为中上。生彼即得阿罗汉故。理实于中亦有多时得阿罗汉者。经言即得就胜为语。问曰罗汉为生不生。此经不说以阿罗汉更不生故。问曰龙树说阿罗汉亦生净土。故彼文言有妙净土出过三界无烦恼名。是阿罗汉当生彼中闻法华经。云何不生。解有两义。一就愚法声闻以释。执小迷大为愚法。是愚法人舍现阴形未即受身入无余灭。不可思议劫未来无余涅槃之后心想生时方于净土受身闻法。龙树据终说生净土。此经就始故不说生。二就不愚法者以释。阿罗汉中解小知大名不愚法。是人死已。即于净土受身闻经而非一切。是义云何。土有粗妙。粗处杂小妙处唯大。又复粗国通有分段凡夫往生。妙土唯有变易圣人。弥陀佛国净土中粗。更有妙刹此经不说。华严具辨。彼不愚法阿罗汉人爱结已尽专心求大。生于妙土不生粗国。龙树据妙故说罗汉当生净土。故彼文言有妙净土出过三界无烦恼名罗汉当生。观经就粗故不说生为是偏说。前三果人以为中上。见前已前内外二凡。精持净戒求出离者说为中中。经说生彼七日闻法得须陀洹过半劫已得罗汉故。理实于中亦有多时闻法得果。经言七日及半劫就胜为言。见道已前世俗凡夫修余世福求出离者说为中下。经说生彼过一小劫得罗汉故。理实于中亦有多劫得罗汉者。经就胜为言。中辈如是。下辈亦三。所谓下上下中下下。于彼大乘始学人中随过轻重分为三品。未有道位难辨阶阩。人别如是。此一门竟

次辨其因。于中初先当相分别后约人论。当相如何。经说不同。依大品住宣说般若空慧为因。修空慧除灭罪障故于净土欲生即生。依涅槃经一切善业皆净土因不可具列。粗要有四。一修戒为因。远离十恶修行十善。自持净戒不与犯重。同共止住得生净国。二修施为因。旷路作井种植果林。施病医药造立僧房。供持戒人及说法者。造像立塔种种供养。如是一切悉得往生。三修慧为因。书写经卷乃至一偈听受读诵为他演说得生净土。四护法为因。守护正法不谤方等得生净土。此等能为一切土因。求安乐者宜须修之。依维摩经八法为因。故彼经言具足八法行无疮疣生于净土。何等为八。一饶益众生而不望报此即是慈。二代一切生受诸苦恼此即是悲。三所作功德尽以施之此即是喜。由喜除嫉故作功德尽以施之。四等心众生谦下无碍。此即是舍。舍除怨亲齐能卑敬故等无碍。此四利他后四自利。五于菩萨亲之如佛。所未闻经闻之不疑。于自所学起信敬心。于人起敬于法生信。六不与声闻而相违背于他异学袪息碍心。七不嫉彼供不高己利。而于其中调伏其心。于受用事息瑕秽心。八常省己过不讼彼短。恒以一心修诸功德。所修行事起专精心。此八能为一切土因。求安乐者亦须修之。依往生论五门为因。一礼拜门称名礼拜阿弥陀佛求生其国。二赞叹门赞阿弥陀佛光明智慧一切德。三作愿门愿生其国修弥陀佛所行所成。四观察门所观有三。一观彼国功德庄严二观彼佛功德庄严三观彼菩萨功德庄严。各有多义不可具列。五回向门不舍苦生回向为首所作功德回以施之共生彼国。依此观经因亦众多。粗要为四。一修观往生。观别十六备如上辨。二修业往生。净业有三亦如上说。三修心往生。如下文说。心有三种。一者诚心。诚谓实也。起行不虚实心求去故曰诚心。二者深心。信乐殷至欲生彼国。三者回向发愿之心。直尔趣求说之为愿挟善趣求说为回向。愿有二种。一愿生彼国。二愿见彼佛。所行所成亦尔。此是第三修心往生。四归向故生。如下文说。自虽无行善友为说佛法僧名或为叹说弥陀佛德或叹观音势至或叹彼土妙乐胜事。一心归向故得往生。于中或念或礼或叹或称其名悉得往生。当相如是。次约人论。经说不同。依无量寿大经之中粗约三品以别其因。上品生者舍家弃欲而作沙门。发菩提心一向专念无量寿佛。备修诸德愿生彼国。即得往生。中品生者不作沙门亦复不能大修功德。发菩提心一向专念无量寿佛。少修福善奉持齐戒。造像立塔种种供养愿生彼国。即得往生。下品生者不作功德发菩提心。一向专念无量寿佛乃至十念。闻说深法欢喜信乐不生疑惑。以至诚心愿生彼国。即得往生。依此观经九品别论。先明上辈。同修大乘以之为因。于中别分。上上生者先发三心。一至诚心二者深心三者回向发愿心。次修三业。一者慈心不杀是上初业。二具诸戒是第二业。三读诵大乘修行六念是第三业。后回此善欲生即生。上中生者亦须先起三种之心。与上初同故更不论。下亦如之。次修三业。慈心不杀具戒如前故更不论。于大乘法不能受持读诵修行。唯能解了第一义谛深信因果。此前第三净业所收。后回此善愿生即生。上下生者亦复先起三种之心与前相似。次修三业慈心不杀具戒如前。于大乘法不能受持读诵解义。唯信因果而为行因。此信是前第三净业。后回此善欲生即生。上辈如是。次论中辈。同修小乘而为行因。以其最后发菩提心念弥陀佛故得往生。于中别分。中上生者于小乘中前三果人。内备圣德经文不说但明其人。具诸戒行此犹是前第二净业。后回此善欲生即生。中中生者一日一夜持八戒斋。一日一夜持沙弥戒及与具戒。此亦是前第二净业。后回此善欲生即生。中下生者孝养父母行世仁善。此乃是前第一净业。于临终时善友为说阿弥陀佛国土乐事并说法藏比丘四十八愿。至心信乐欲生即生。中辈如是。次论下辈。此人过去曾修大乘故大经中宣说。此人发菩提心。闻说深法信乐不疑。现在遇缘造作诸罪故此经中偏彰其过。现虽作罪善友开导。归向之力故得往生。于中别分。下上生者现犯轻罪。善友为说大乘经名教称彼佛。灭罪故生。下中生者现犯重罪。善友为叹弥陀佛德欢喜信乐。灭罪故生。下下生者现犯四重五逆等罪。善友教称无量寿佛。如是至心令声不绝乃至十念。灭罪生。辨因如是。此二门竟。次明去时见佛不同。佛具三身。一者真身谓法与教。二者应身八相现成。三者化身随机现起。依如大经。上品之人见佛应身而来迎接。中品见化。下品梦睹不辨化应。真身常寂无迎接相。为是不论。依此观经上辈三人同皆见佛应化二身而来迎接。但于其中见化多少为别异耳。上人见其无数化佛中见一千下见五百。中辈三人有见不见。中上中中二人见佛。中下不见。以行劣故。问曰大经宣说中辈一切见佛。此经何故有见不见。释言大经总相言之从多说见。此经细分故有不见。其有见者唯睹应佛不见化身劣于前故。下辈三人有见不见。下上下中人见佛下下不见但见莲华。问曰大经宣说下辈不得见佛。此经何故说有见者。释言此经明修观行由观灭罪故。令下辈分有见者虽后见佛但睹其化劣于前故。问曰大经宣说上人唯见其应中唯见化下唯梦睹不辨化应。此经何故宣说上辈应化俱见中辈见应下辈见化。释言此经明修观行由观心明。是故上人应化俱见中人见应下人见化。大经之中不明观行为其不同。此三门竟。次论往生彼土时有异。上辈三人生时各异。上上生者至即花开不经时日。上中生者经宿方开。上下生者一日一夜其花乃敷。中辈三人生时亦异。中上生者至即花开与上上同。何故如是。此小乘中圣人往生。余业虽劣无漏净心故往即生。中中生者七日花敷。中下生者文中不辨。但云生已过七日后遇圣闻法。下辈三人生时亦别。下上生者经七七日其花乃敷。下中生者罪报深重六劫方开。下下生者罪障极重十二大劫莲花乃敷。由其罪重尔许时节澄练其心方堪入法。时分如是。此四门竟。次彰生后得益差殊。上辈三人得益各异。上上生者至彼即得无生法忍。无生七地。于中亦有多时得者。就胜为言。上中生者迳一小劫得无生忍。亦有过者。就胜为言。上下者过三小劫得住初地。中辈三人得益亦异。中上生者生彼即得阿罗汉果。亦有多时。就胜为言。中中生者过七日后得须陀洹。过半劫后得阿罗汉。中下生者过一小劫方得罗汉。下辈三人得益亦异。下上生者迳十小劫得到初地。以此先是善趣人故。下中生者过于六劫闻法发心。下下生者过十二大劫闻法发心。发心种性以此下辈宿习大故同发大心得益如是。此五门竟。次第六门释会经论。问曰依如往生论中说。二乘种不得往生。此经何故宣说中辈学小得生。释言弥陀菩萨正处唯修小行不得往生。要由乘终发菩提心种大乘种方乃得生。故大经中宣说其人发菩提心。彼往生论据终为言故说二乘种子不生。此经就始故说中辈学小得生。问曰若此要由乘终发菩提心方得生者。至彼应证大乘道果。何故但得小乘果乎。释言此人虽复乘终发菩提心。先多学小故至彼国闻苦无常发其本解先证小果。以其乘终发大心故得小果已于小不住必还入大。问曰依如往生论中宣说女人根缺不生。此经宣说韦提希等五百侍女同皆往生。是义云何。释言论说女人根缺不得生者就后为言。生彼国者净报离欲故无女人。身报精上故无根缺。若论此者但有善心一切不简。又问大经说五逆不得往生。此经宣说逆罪得生。其义云何。释有两义。一约人分别。造逆罪人有上有下。善趣已前常没造逆说以为下。善趣位中遇缘造逆说之为上。如世王等上人造逆必有重悔。令罪消薄容便得生。此经就之故说五逆亦得往生。下人造逆多无重悔不可得生。大经就此故说不生。二约行分别。造逆之人行有定散。观佛三昧名之为定。修余善根说以为散。散善力微不能灭除五逆重罪不得往生。大经就此故说不生。定善力强能消逆罪容得往。此经明观所以说生。分别如是。次释其文。先观上辈三人往生。于中初先三品别论后便总结。就上上中初举次辨后总结之。辨中有三。一明其因。二生彼国时此人已下因成往生。彼国见佛已下生已得益。就明因中初心后行。心中初言若愿生彼发三种心总以标举。次别其名。何等问也。下对辨之。言诚者是其实心。起行不虚名为诚心。又实求往亦名诚心。言深心者殷至心也。起行殷至名曰深心。求去殷至亦曰深心。回向发求去心也。狭善而求名曰回向。谓回己善向大菩提又回己善向彼国生故名回向。回向之义广如别乘。此应具论。直尔趣求说以为愿。愿大菩提又愿生彼故名为愿。具三必生总结。其能行中初言复有三种当得往生总以标举。次列其名。先问后列。此三犹上三种净业。慈心不杀是上初业。前初业中明供父母奉事师长慈心不杀修行十善。今举慈心余略不论。具诸戒行是前文中第二业也。读诵大乘乃至发愿是前文中第三业也。回向已下通用前三。愿生彼国一日至七日明修分齐。即得往生结明修益。上来明因。第二因成往生之中此人精进弥陀如来与观音等彼来迎此。行者见已欢喜已下此往生彼。第三生彼得益之中事别有三。一生彼国见佛闻法得无生忍。二遍事诸佛从之受之受记。三还本国得陀罗尼总持之门。是名下结。次观上中。先举次辨后总结之。辨中亦三。一明其因成往生。三生已得益。因中初言不必受持方等经典简此异前。善解成等正辨其因。以此愿下用之求生。前上品中三种之心并慈具戒此亦应有。同前不说。第二生中初彼迎此。行者自见坐金台下此往生彼。迳宿则开彰生时节。第三益中文亦有三。一生彼得益二遍事诸佛修学三昧三于其国迳一小劫得无生忍现前受记。生彼益中身作金色正报胜也。足下莲华依报胜也。佛及菩萨放光照等善友胜也。因前习等闻法胜也。即下金台礼佛赞等起行胜也。迳七日等所成胜也。次论上下亦先标举次辨。中有三。一因二生三明得益。因中不明善解义趣彰此劣前。亦信因等正辨其因。有信同前是以言亦。以此德下用之求生。第二生中初彼迎此。见此事下此往生彼。迳一日夜莲华乃开彰生久近。以此劣前故一日夜其华乃敷。益中亦三。一生彼得益见佛闻法。二遍供诸佛从之闻法。三于彼国迳三小劫得百法门住欢喜地。是名上生。第十四观总以结之。次观中品三人往生。于中初先二品别论后总结之。别中先观中品上生。先举次辨后结之。辨中有三。一辨其因二因成往生三生已得益。因中初言五戒八戒是在家戒。修行诸戒是出家戒。此明修洽。不造五逆无诸过患明其离过。以此善下用之求生。第二生中初彼迎此。行者见下此往生彼。莲华寻开彰生时节。此圣往生故华即开。第三益中初华开闻法后得道果。得罗汉者此名无生亦名无著。无著因亡无生果丧。言三明者所谓宿命天眼漏尽是其三也。言六通者所谓身通天眼天耳他心宿命及与漏尽成如别章。八解脱者经中亦名八背舍也。名字是何。内有色相外观色一。自身名内他身名外。于自身色未灭未坏名为内有观。内外色悉皆不净名外观色。问曰此中内外俱有以何义故偏言内有。释言内色初有后无。约对后无故说初有。前三解脱未灭外色非初独有。以是义故不名外有。问曰此门通观内外悉皆不净。以何义故遍言观外。释言此乃隐显彰名。前内彰有隐其观称。今外彰观隐其有名。论释如是。内无色相外观色二。于自己身豫作死相虫食火烧破坏之相名为内无。观察外色悉皆不净。此前二种是不净观。净相解脱以为第三。于内外色除去皮肉唯观白骨。前三色观空处识处无所有处及悲想解脱复以为四。通前为七。圣人得彼四空处定即说为此四解脱也。灭尽解脱以为第八。谓灭尽定此八解脱。广如别章应具论之。次观中中。初举次辨后总结之。辨中亦三。一明其因二戒香勋下因成往生三华既敷下生彼得益。第二生中初彼迎此。行者自见坐莲华下此往生彼。迳于七日莲华乃敷彰生久近。以劣前故迳于七日其花乃敷。得益可知。次观中下。亦先总举次辨后结。辨中亦三。一明其因二因成往生三生彼得益。因中有二。一孝养父母行世人善。二临终闻友赞扬彼国及闻法藏四十八愿愿乐欲生。第二生中此人行劣无佛来迎直尔往生。第三益中此人行劣不观见佛。直从观音势至闻法得阿罗汉。是名中下别结中下。是名中辈通结中品。下次观察下品三人。此应在于善趣已前。分齐难知。于中亦初三人别论后总结之。别中先观下品上生。亦先总举次辨后结。辨中有四。一彰其罪过。二命欲终下明其善因。闻经灭罪称佛除恶故得往生。三尔时彼佛遣化佛已下明其往生。于中初先彼化迎此。作是语已行者见下随化生彼。迳七七日莲华乃敷彰生时节。以罪轻故七七华开。四花开敷时大悲观音放光已下生彼得益。于中初先观音为说甚深经典后明其人闻法信解发心得道。次观下中亦先总举次辨后结。辨中亦四。一彰其罪。二如此罪人以恶业下明其善因。由闻佛德及戒定等灭其罪业。三地狱火化为风下明其往生。于中初先化佛来迎。如一念下寻化往生。六劫华敷彰生久近。此罪转重故过六劫乃开敷。四观音势至为说法下生彼得益闻法发心。次观下下。亦先总举次辨后结。辨中亦四。一彰其罪。作不善业总以标举。五逆等别。言五逆者杀父杀母杀阿罗汉破和合僧出佛身血是五逆也。问曰如大经中五逆不生。今此何故五逆亦生。释言随人不同故尔。若是宿世无道根者现造五逆终无生理。若是先发菩提心人。虽复遇缘造作五逆四重等罪。必生重悔如世王等亦得往生。乃至大乘善趣之人有造作五逆四重谤法罪故。十恶名义备如上列。具不善者具四重等。此前第一彰其罪业。二如此罪人以恶业故应堕已下明其善因。于中有二。一反举其告。二善友告下顺彰其得。失中两句。一以恶业应随地狱。二临终下善友教示不遑念佛。遑犹暇也。无暇念佛故曰不遑。得中两句。一善友教劝称彼佛名具足十念。二以称佛故念念除去八十亿劫生死之罪。此第二段明其善因。三命终后见金华下乘善往生。于中初先明见莲华次得往生后彰生彼。十二大劫花乃开敷此罪极重故十二劫乃敷耳。四观音势至以大悲下生彼得益。总结可知。上来广教三种净业十六正观。下明说益。益别有三。一韦提及与五百侍女见安乐国佛及菩萨得无生忍。二五百侍女发菩提心愿生彼国佛说悉生。三诸天发心。此正宗竟。下明流通于中有二。一王宫流通。二足步下耆阇流通。前中有四。一列名教持。二行此下明目连等闻法欢喜。初中阿难先问发起。当何名此经问经名字。上来所说言义非一。当于何义而名此经。此法之要云何受持问受仪。此法极要云何受持。下佛答之。名观极乐无量寿佛观音势至亦名净业生诸佛前对其初问。汝当受持无令忘失对其后问。无令忘失是持义也。自下第二明修有益。于中初明行。前十六三昧观门得大利益。现身得见彼佛菩萨。男子女人但闻名下明其念佛菩萨之益。但闻二名除无量罪何况忆念明菩萨有大利益。举劣况胜。若念佛下明念彼佛得大利益。若念佛者人中分陀明其身胜。分陀利花花中殊好。此人同彼名分陀利。观音势至为胜友明伴类胜。当坐道场明所成胜。场犹处也。得道之处名曰道场。如治麦处名为麦场。如是一切随化以论。菩提树下得佛道处名为道场。处斯得佛故名为坐。据实以论。义有通局。通则菩萨一切行德能生佛果斯名道场如维摩说。局则末后金刚三昧亲生佛德名为道场。依之得果义说为坐。生诸佛家明所入胜。亦得名为所依处也。不思佛法是佛住处名为佛家。初地已上入佛家中依之赴行名生佛家。第三劝持第四闻喜。文显可知。第二耆阇流通之中。初佛步空还耆阇山为增物敬奉顺其言故现此变。次阿难说。后天龙等闻喜礼去

观无量寿经义疏末(终)


观音玄义

    No. 1726 [cf. Nos. 262(25), 1727]

观音玄义卷上

        隋天台智者大师说　门人灌顶记

夫法界圆融像无所像。真如清净化无所化。虽像无所像无所而不像。化无所化无所而不化。故无在无不在化应九道之身。处有不永寂入不二之旨。是以三业致请蒙脱苦涯。四弘为誓使沾上乐。故娑婆世界受无畏之名。宝藏佛所禀观音之目。已成种觉号正法明。次当补处。称为普光功德。其本迹若此宁可测知。方便随缘趣举一名耳。今言观世音者。西土正音名阿耶婆娄吉低输。此言观世音。能所圆融有无兼畅。照穷正性察其本末故称观也。世音者是所观之境也。万像流动隔别不同。类音殊唱俱蒙离苦。菩萨弘慈一时普救。皆令解脱故曰观世音。此即境智双举能所合标。经者由义。文理表发织成行者之心。故曰经。普门者普是遍义门曰能通。用一实相开十普门。无所障阂故称普门。品者类也义类相从故名为品也。大部既有五章明义。今品例为此释。五意者。一释名。二出体。三明宗。四辩用。五教相。释名为二。一通释。二别释。通者人法合明。别者人法各辩。何故尔。缘有利钝说有广略。今就通释为四。一列名。二次第。三解释。四料简。一列名者十义以为通释。所以者何。至理清净无名无相非法非人。过诸数量非一二三。但妙理虚通无名相中假名相说。故立无名之名假称人法。虽非数量亦论数量。故大论云。般若是一法佛说种种名。随诸众生类为之立异字。今处中说。略用十义以释通意也。十义者。一人法。二慈悲。三福慧。四真应。五药珠。六冥显。七权实。八本迹。九缘了。十智断。第二次第者。此有两意。一约观明次第。二约教明次第。约观则总初中后心因圆果满。约教则该括渐顿小大诸经。约观以人法为初者。欲明观行必有其人人必秉法。譬如人受一期果报揽阴成人。虽具无量德行必先标名字。故以人法居初。意亦例此。人法居九义之初可尔。何意乘以人法为次耶。此须据经。经云。以是因缘名观世音。即前辩人。后云方便之力普门示现。即却论于法人能秉法。故言人法也。二次慈悲者。良由观音之人观于实相普门之法。达于非人非法实相之理。一切众生亦复如是。故华严云。心佛及众生是三无差别。此理圆足无有缺减。云何众生理具情迷颠倒苦恼。既观是己即起慈悲誓拔苦与乐。是故明慈悲也

复次若就言说为便。初慈后悲。亦是就菩萨本怀欲大慈与乐。既不得乐次大悲拔苦。故初慈后悲。若从用次第者。初以大悲拔苦。后方以大慈与乐。又就行者先脱苦后蒙乐。故先悲后慈。今从前义次第也。三福慧者初则人法相成此据其信。次则慈悲与拔者此明其愿。欲满此愿必须修行。修行不出福慧慧即般若福即五度。互相资导以行顺愿事理圆足。若智慧增明则大悲誓满拔苦义成。若福德深厚则大慈誓满与乐义成。故福慧居三也

复次言说为便。先福后慧。若化他本意先欲实慧利益。如其不堪方示福德。又资故先福导故先慧。四真应者。若智慧转明则契于法性。法性即实相名。为法身。法身既显能从真起应。真显应起只由福慧开发。故次第四也。又若就方便化物。先用应后用真。今从前义为次第也。五明药珠二身者。先明真应。直语证得未涉利人。今明两身俱能益物。真身破取相谕如药。应身对万机类于珠。就两字明次第者。与慈悲相似也。六明冥显者。前明二身道理即能显益。今辩被缘得冥益或得显益。故次二身后明也。七明权实者。前缘得益何意不同。良由权巧无方赴机允当。不失其宜二智之力。故以此为次也。先权后实者。此就浅深为次也。若依文者先以实益次以权度。此随物为次。若就佛本意。先只为一大事因缘。先显实益。众生未堪后用权度。八明本迹者。虽复益物权实之巧。而巧有优降必是上中下智本迹之殊。权实略而且横。今欲细判高下以明次位。若其本高所作权实之迹则妙。是故次总略之后辩其细妙之能也。非本无以垂迹故先明本。非迹无以显本应先迹也。九明了因缘因者。上来行人发心修行从因克果。化他利物深浅不同。从人法至真应是自行次第。药珠至本迹是化他次第。此乃顺论未是却讨根本。今原其性德种子。若观智之人悲心誓愿。智慧庄严显出真身。皆是了因为种子。若是普门之法慈心誓愿。福德庄严显出应身者。皆是缘因为种子。故次第九也。十明智断者。前明缘了是却讨因源。今明智断是顺论究竟。始则起自了因终则菩提大智。始则起自缘因终则涅槃断德。若入涅槃众行休息。故居第十也。二约诸教明次第者。又为通别。通义可解。别今当说。如华严顿教教名大方广佛华严。依题初明人法。此人秉法必具慈悲。菩萨修因居然福慧。既入地位必证真应。既能利物则辩药珠。物得其益有冥有显。而未得别论权实本迹缘了智断者。通义则有别意则无。何故尔。佛一期化物明于顿渐。顿教虽说渐教未彰。故不明四意也。所以不明者。彼经明小隔于大如聋如哑。覆于此权未显其实。故云久默斯要不务速说。故言无权实也。言无本迹者。彼经未发王宫生身之迹。寂灭道场法身之迹。未弹指謦欬发久远所得生法二身之本。故言无本迹。言无缘了智断者。不明小乘根性及有心之者。本自有常住之因。当克智断菩提本果。故言无也。次约三藏教。但明人法慈悲福慧三义。无真应等七种。何故尔。二乘教中但明灰身灭智。那得从真起应。既无真应将何益物。私难。通论备十别语但三。此三若约真谛则随通义乃具十意。何止但三。若言是别。别应约中道。既得有中道人法三种。何意无七。私答。通论十意此约三乘。别语三科的据菩萨。三藏菩萨得有慈悲福慧伏惑之义。既伏而不断故无真应七法。师云。齐教止三。若约方等教对小明大。得有中道大乘人法至冥显两益等六意。然犹带方。便调熟众生。故不得说权实等四意。若明般若教。虽未会小乘之人。已会小法皆是摩诃衍。但明人法等六意。亦带方便未明权实等也。若约法华教则会小乘之人。汝实我子我实汝父。汝等所行是菩萨道。开权显实发本显迹。了义决定不相疑难。故知法华得明中道人法至本迹八意。前诸教所不明法华方说。故云未曾向人说如此事。今所说者即是今当为汝说最实事也。三世诸佛调熟众生。大事因缘究竟圆满备在法华。故二万灯明但说法华息化入灭。迦叶如来亦复如是。若约涅槃。即有二种所谓利钝。如身子之流皆于法华悟入。八义具足不待涅槃。若钝根弟子于法华未悟者。更为此人却讨源由。广说缘了明三佛性。若论性德了因种子。修德即成般若。究竟即成智德菩提。性德缘因种子。修德成解脱断德涅槃。若性德非缘非了即是正因。若修德成就。则是不纵不横三点法身。故知涅槃所明。却说八法之始终成智断。十义具足。此历五味论十法次第。约四教则可解。故知十法收束观教结撮始终。商略大意。何观而不摄何教而不收。意气宏远义味深邃。前后有次第粗细不相违。以释生起意也

问。法华前教同有六意云何为异

答。华严六意。于利人成醍醐于钝人成乳。三藏中三意。于利人密去于钝人成酪。方等六意。于利人成醍醐于钝人成生酥。般若六意。约利人成醍醐于钝人成熟酥。若法华八意。于钝人成醍醐。第三解释者。人即假名所成之人也。法即五阴能成之法。此之人法通于凡圣。若色受想行识是凡鄙法。揽此法能成生死之人。戒定慧解脱解脱知见。是出世法。揽此成出世圣人。故大论云。众生无上者佛是。法无上者涅槃是。虽通凡圣不无差别。上中下恶即成三途之人法。上中下善即成三善道之人法。故有六趣阶差。若更细论百千万品。圣人人法亦复不同。若三藏有门。观众生我人如龟毛兔角毕竟不可得。但有五阴之法。此即人空法不空。观此法无常生灭不住。发生暖顶等位。即是揽方便之法成似道贤人。若发真成圣生方便有余土。揽法性色识等成彼土行人。若空门明有实法之体。揽此实法得有假名之人。观三假浮虚会入空平。暖顶即揽方便法成似道贤人。若发真成无学生方便土。揽法性五阴成彼土行人。余两门人法例此可知。摩诃衍中明人法者。亦不言人空法不空。亦不言体有假用。但观假名阴入等性本自空。故大品云。色性如我性我性如色性。始从初心终于后心。常观人法俱空。故大论云。菩萨常观涅槃行道。以观人空即是了因种子者。论云。众生无上者佛是。佛者即觉。觉是智慧。始觉人空终觉法空。故知观人空是了因种也。观法空是缘因种者。大论云。法无上者涅槃是。以生死阴断涅槃阴兴。大经云。因灭是色获得常色。乃至识亦如是。大品云。菩萨行般若时得无等等色无等等受想行识。当知涅槃是无上法也。揽此法成无上之众生。号之为佛。故知观法空是缘因种也。以观人法空即识三种佛性。故大经云。众生佛性不即六法不离六法。不即者。此明正因佛性非阴非我。非阴故非法。非我故非人。非人故非了。非阴故非缘。故言不即六法也。不离六法者。不离众生空而有了因不。离阴空而有缘因。故言不离六法也。佛从初发心观人法空。修三佛性。历六即位成六即人法。今观世音未是究竟之人法。即是分证之人法。前一番问答是分释无上之人称观世音。后一番问答分释揽无上之法故称普门。当知人法因缘故。故名观世音普门也。二释慈悲者。悲名愍伤慈名爱念。愍故拔苦念故与乐。菩萨若但起慈悲心不牢固。故须发弘誓加持使坚。譬如工匠造物节廨虽复相应若无胶漆则有零落。誓愿如胶亦复如是。悲心愍伤。拔于世间苦集因果兴两誓愿。所谓众生无边誓愿度。烦恼无量誓愿断。此两誓愿从大悲心起。以慈爱故。欲与道灭出世因果之乐兴两誓愿。所谓法门无边誓愿知。无上佛道誓愿成。此两誓愿从大慈心起。但前明人法凡圣不同。今辩慈悲大小亦异。若三藏行人观分段生老病死八苦即起誓愿。众生无边誓愿度。若观分段颠倒结业而起誓愿。烦恼无量誓愿断。欲令众生观此因果无常生灭念念流动。修于道品即起誓愿。法门无量誓愿知。若观真谛无为之理即起誓愿。无上佛道誓愿成。如此慈悲缘有作四谛所起也

复次通教观老死八苦如幻如化。众生颠倒谓为真实即起誓愿。贪恚痴等如幻如化。众生颠倒为之受恼即起誓愿。观即色是空即识是空。即贪痴等是空。非色灭空色性自空。空亦不可得。而众生不能即色是空即起誓愿。又观涅槃若有一法过涅槃者我亦说如幻化。而众生谓有佛道。可求即起誓愿。是约无生四谛起慈悲誓愿也。别教观假名之法森罗万象。应须分别导利众生。那得沈空取证。观此苦果非止一种即起誓愿。无量之苦由无量集。集既无量治亦无量。灭亦无量。如此誓愿。缘界内外苦集因果无量四谛而起誓愿也。圆教观法界圆融。本非违非顺非明非闇无明闇故则违。违之则有苦集因果。智慧明故则顺。顺之则有道灭因果。缘此违顺因果而起慈悲。譬如磁石不作心想任运吸铁。今此慈悲不作众生及以法想。任运拔苦与乐。故名无缘慈悲也。菩萨从初发心修无缘慈悲历六即位。今此观音是分证慈悲。若前一番问答明无缘大悲拔苦。一心称名即得解脱。后一番问答从无缘大慈普门与乐。皆令得度。故知以大慈大悲因缘故名观世音普门也。三释福慧者。亦名定慧。定名静爱慧名观策。大论云。定爱慧策。寂照之智无幽不朗。如明镜高堂。福德禅定纯厚资发。如明灯净油。亦称为目足备得入清凉池。池即涅槃。涅槃称为二种庄严庄严法身。释此定慧自有多种。三藏以无常观理为慧。以事中诸禅定为福。以定资慧发真无漏天然之理。名为法身。若通教但以体法异于析法尔。若别教以缘修智慧与诸禅定。助开中道法身也。圆教以实相观为慧。实相寂定为福。共显非定非慧之理。名实相法身。今圆教菩萨。从初发心修此不二定慧历于六即。观音所以用智光照苦者。苦是颠倒迷惑所致。智慧是破惑之法。故智慧能拔苦。华严云。又放光明名智慧。又放光明名无恼。思益亦然。请观音云。普放净光明灭除痴闇瞑。故知前问答应机拔苦。是从慧庄严以得名。后问答住首楞严普现色身。不起灭定现此威仪。安禅千偈赞诸法王。故知普门示现从福德受名。良以福。慧因缘故名观世音普门也。四释真应者。真名不伪不动。应名称适根缘。集藏名身。若契实相不伪不动之理。即能称机而应。譬如揽镜像对即形。此之真应不得相离。苦外道作意修通虽能变化。譬如瓦石光影不现。岂可以此为应。尚未破四住显偏真理。那忽有中道真应。若二乘变化修通所得此亦非应。譬如图画作意乃成了不相似。大乘不尔。得实相真譬得明镜。不须作意法界色像即对即应。如镜写像与真不殊。是时乃名真寂身应。菩萨从初发心历于六即。今经。前问答明于真寂而不动法界大益。观音从真身得名。后问答明随机广利出没多端。普门是从应身得名。良以真应因缘故。名观世音普门也。五释药树王身如意珠王身者。药王疗治苦患。出柰女经。珠是如意之宝。广历诸教明治病得宝。今约圆教明者。如华严云。有上药树其根深入枝叶四布。根茎枝叶皆能愈病。闻香触身无不得益。菩萨亦如是。大悲熏身形声利物名大药王。身又如如意。珠能雨大千珍宝随意而不穷不。尽菩萨大慈熏身与众生。乐名如意珠王。身此亦约六即判位。就前问答遍救幽厄苦难。此从药王身以得名。从后问答称适所求。雨实相雨得涅槃乐。此从如意珠王身以得名。故知二身因缘名观世音普门也。六释冥显两益者。冥是冥密显是彰露。大圣恒以二益利安一切。而众生及以下地日用不知。譬如日月照世。盲虽不见实荷深恩。故药草喻云。而诸草木不觉不知只同是一地。下品不知上品冥显两益。如文殊不知妙音神力所作。以不知故名为冥益。此亦约六即判位。若就前问答。不见形声密荷深祐。名为冥益。圣人之益虽不可知。圣欲使知昆虫能知。如后问答亲睹色身得闻说法。视听彰灼法利显然。故知观音从冥益得名。普门从显益得名。以冥显因缘故名观世音普门也。七释权实者。权是暂用实非暂用。略言权实则有三种。一自行论权实。自观中道为实二观为权。二就化他论权实。他根性不同。或说权为实说实为权。不可定判。但约他意以明权实也。三自行化他合明权实者。若自观三谛有权有实。皆名为实。化他随缘亦有权有实。皆名为权。用此三义历四教。复就自行权实明六即判位。寻此品意是明自行化他论权实前。问答从自行化他之实智益物后。问答从自行化他之权以益物。故知权实因缘故。名观世音普门也。八释本迹者。本名实得迹名应现。若通途作本迹者。世智凡夫本意难测。乃至别教本迹。若圆教无始发心。初破无明所得法身者名之为本。垂形百亿高下不定称之为迹。若一往判真应。多用上地为真为本。下地为应为迹。地地传作此判。真本唯据于高应迹唯指于下。此义不可。今细明本迹则与真应异。本是实得。始坐道场及初住所得法身即是其本。迹为上地之佛及作上地菩萨悉名为迹。不可以上。地高故称之为本。始得初住目之为迹。何以故。实不得上地上地非本。实得下地下地非迹。故寿量云。随自意随他意。是本迹意也。就本迹明六即。就前问答不可说示。但冥祐前人。从本地得名。后问答殊形异状应现度脱。从迹地得名。故知本迹因缘故。名观世音普门也。九释了因缘因者。了是显发缘是资助。资助于了显发法身。了者即是般若观智。亦名慧行正道智慧庄严。缘者即是解脱。行行助道福德庄严。大论云一人能耘一人能种。种喻于缘耘喻于了。通论教教皆具缘了义。今正明圆教二种庄严之因。佛具二种庄严之果。原此因果根本即是性德缘了也。此之性德本自有之非适今也。大经云。一切诸法本性自空。亦用菩萨修习空故见诸法空。即了因种子本自有之。又云。一切众生皆有初地味禅。思益云。一切众生即灭尽定。此即缘因种子本自有之。以此二种方便修习渐渐增长。起于毫末得成修得合抱大树。摩诃般若首楞严定。此一科不论六即。但就根本性德义尔。前问答从了种受名。后问答从缘种受名。故知了因缘因。故名观世音普门也。十释智断者。通途意。智即有为功德满。亦名圆净涅槃言有为功德者。即是因时智慧。有照用修成之义故称有为。因虽无常而果是常。将因来名果故言有为功德满也。断即无为功德满。亦名解脱。亦名方便净涅槃。言无为者。若小乘但取烦恼灭无为断。但离虚妄名为解脱。其实未得一切解脱。此乃无体之断德也。大乘是有体之断。不取灭无为断。但取随所调伏众生之处。恶不能染。纵任自在无有累缚。名为断德。指此名无为功德。故净名云。不断痴爱起诸明脱。又云。于诸见不动而修三十七品。爱见为侍。亦名如来种。乃至五无间皆生解脱。无所染碍名为一切解脱。即是断德无为也。寂而常照即智德也。小乘灰身灭智。既其无身将何入生死。而论调伏无碍无染。灭智何所照寂如此智断圆极故法身显著。即是三种佛性义圆也。法身满足即是非因非果正因满。故云隐名如来藏显名法身。虽非是因而名为正因。虽非是果而名为法身。大经云。非因非果名佛性者。即是此正因佛性也。又云。是因非果名为佛性者。此据性德缘了皆名为因也。又云。是果非因名佛性者。此据修德缘了皆满。了转名般若缘转名解脱。亦名菩提果。亦名大涅槃果。果皆称为果也。佛性通于因果不纵不横。性德时三因不纵不横果满时名三德。故普贤观云。大乘因者诸法实相。大乘果者亦诸法实相。智德既满湛然常照。随机即应一时解脱。断德处处调伏。皆令得度。前问答从智德分满受名。后问答从断德分满受名。故知以智断因缘名观世音普门也

问。此十义名字出余经。那得用释此品

答。大乘义通众经共用。若不许此者。佛性出涅槃。五住二死出胜鬘。诸师那得浪用通众经耶。此品在文虽无十名。总将二问答帖十义意。宛然可解。今已如前。今更别点句句来证十义者。如文云。以何因缘名观世音。又云。以是因缘名观世音。即是据人名也。后文云普门示现即是明法也。有如是等大威神力多所饶益即慈也。愍诸四众即悲也。欲知智在说。十九说法即智慧也。一时礼拜得无量无边福德之利。即福德也。自在之业。即法身也。何故尔。法身于一切得自在。智慧契此故名为业。寿量云。慧光照无量久修业所得。威神之力巍巍如是。如是满足之名。即是真身也。普门示现神通力。即应身也。游诸国土度脱众生。即药树王身也。于怖畏急难之中能施无畏。即如意珠王身也。福不唐捐即冥益也。三十三身即显益也。现佛身即实智也。现余身即权智也。观音身即本余身即迹也。又大威神力是本方便力是迹。闻是观世音。菩萨名者若有闻是品者。即证了因。功德不少即缘因。不肯受常舍行故。及即时观其音声。观即智。皆得解脱种种调伏众生。八万四千发心等。是利益即断也。第四料简者

问。人对观音法对普门者。方等有。普门法王子标于人名。此义云何同

答。此应作四句分别。人非法法非人。人即法法即人。若约华严次第意地。前生死行人未是实相之法。此法亦非彼人。若作不次第意者。人即实相实相即人。人法不二也。若三藏有门明无假人但实法此法非人。若空门揽实法成假人。人法两异。若其不离人论法不离法论人。此乃是二谛意非中道之人法也。若方等对小明大论人法者。明小同三藏明大同华严。般若涅槃等例尔。今方等中明普门者。即大乘意。今明普门是法。何得有法无人。彼明普门是人。何得但人无法。此则人法互举。彼经标人此处标法尔。例如小乘明身子智慧第一。余弟子各就余法门论第一。本以智慧断惑发真无漏。余人无慧那得入道。既得道果果知有慧。但各举其初门别称第一。譬如刀刃断物必藉于背方有利用。诸数如刀背慧数如刀刃。今普门义亦尔。但以因缘之法当普门之名。何得无了因之人耶。若并从观音标名者。此则通漫。欲使世谛不乱互举别名。如身具六根但称为净眼净意。岂得无余根耶。料简慈悲者

问。若大悲拔苦苦除即是得乐。大慈与乐乐至即是拔苦。何意两分

答。通论如此别则不然。譬如拔罪于狱。未施五尘身虽免痛根情未娱。此但拔苦未名与乐。又如施五尘于狱。耳眼虽悦不名拔苦。为从别义各显一边。故别说尔

问。此中何意不论喜舍

答。四无量心名虽有四但是三义。大经云。忧毕叉。毕叉名舍。舍者两舍也。即是非慈非悲不二之意。不二而二即是慈悲。喜者。从乐生喜初欲与乐。众生苦重不能得乐则无所可喜。若拔苦竟即能得乐。还遂本怀故乐后加喜。苦后无此故不开喜。如阿输加王七日应死。虽有五欲之乐忧苦切心。又如一身少许痛恼能夺一身之乐。故知苦重不得乐也

问。禅支明喜在前乐支在后。复云何

答。禅支就从粗入细。此中庆彼得乐故喜心在后也

复次外道修四无量自证禅定。作想虚运彼无实益。不能令他拔苦得乐。虽自获定虚妄世法。报尽还堕不免于苦。自他俱无利益。若二乘修四无量但自拔苦于他无益自拔分段未免变易。灰身灭智非究竟乐。今菩萨不尔。非凡夫行非贤圣行。非凡夫者不同自受禅乐。非贤圣者不同自拔于苦。不同自受乐故即与他乐。不同自拔苦故即拔他苦。亦是即拔苦是即与乐。即与乐亦即是拔苦。但分别说之誓愿相对。前明拔苦后明与乐尔。料简福慧者

问。观音对智称之而拔苦。普门对福见之而得乐何也

答。智是光明正治闇惑。惑是生死苦恼。若治闇惑之苦。岂不用智解之光。故称智慧人名即拔苦也。法是法门门名能通。通至涅槃安乐之处。初习此法是得乐因。后证此法是得乐果。故对此普门明其与乐也

问。福慧相须本不相离。若定而无慧者此定名痴定。譬如盲儿骑瞎马必堕坑落堑而无疑也。若慧而无定者此慧名狂慧。譬如风中然灯摇扬。摇扬照物不了。故知福慧相资二轮平等堪能运载也。若尔。何意以智慧拔苦福德与乐耶

自有福德是智慧智慧是福德。自有福德非智慧智慧非福德。大小乘皆备四句。如六度菩萨修般若。分阎浮提为七分。此是世智不能断惑。此犹属福德摄。即名此福是智故。此智是福不断惑故。若声闻人智慧能断若名智慧非福德。如饿罗汉也。若福德非世智亦非出世智者。如白象也。若大乘四句者。别教地前三十心行行名福德慧行名智慧。此慧不能破无明。此慧还属福德摄。不破无明故。此福是智慧方便治取相故。若地前皆名福德。地上皆名智慧。此智慧非福德福德非智慧。方等般若带小明大。若带小福慧如前四句。明大福慧如向四句。今此普门名福慧者。福即是慧。慧即是福。福慧不二。故大论云。如是尊妙人则能见般若。此慧那得无定。得首楞严定何曾无慧。论云健相三昧能破强敌。大经云。佛性者。有五种名。亦名般若亦名师子吼。亦名首楞严亦名金刚佛性等即是定慧具足之名也。非禅不慧。非慧不禅。禅慧不二。不二而二。分门别说作定慧二解。故释论解般若明十八空。解禅定明百八三昧。此是二说二即不二。料简真应者。亦有四句之殊。非真非应。应而非真。真而非应。亦真亦应。若非真非应。此就理可解。又就凡夫。不见理故非真无用故非应。此亦可解应而非真者。外道亦得五通同他施化。通论亦得是应而不得名真。真而非应者。二乘人入真断结。灰身灭智不能起应。此亦是通论其真尔。亦真亦应者。此则别显中道为真。即真而论用为应真应不二。不二而二者故言真应尔。今依文互举一往言其真应。前番问答明真身常益。后番问答明应身间益。常间不得相离二鸟俱游。二往为论真身亦恒亦不恒。应身亦间亦不间。若小乘明义。例如善吉石窟观空见佛法身。莲华尼则不见。此岂非小乘中真身恒益不恒益义。丈六之应亦有见不见。此岂非应身有间有不间义。大乘法身亦尔。于理为恒益于情为不恒益。应身亦尔。此缘灭彼缘兴无有断绝是不间义。同质异见是其间义。而今分别。一往前问答属恒益。后问答属不恒益也。料简药珠二身者。药有差病拔苦之功。亦有全身增命致宝之用。故经云。若全身命便为已得玩好之具也。如意珠王非但雨宝亦能除病。大施太子入海得珠还治父母眼。大品云。若人眼痛珠着身上病即除愈故知通具二义。若别据一边。约除患以譬药证乐以况珠尔。料简冥显两益。凡有三十六句。料简权实二智者。前问答实智照真而众生得脱。权智照假而众生得度。度为度权亦度于实。脱为脱真亦脱于假。答此亦具四句。或因真智解脱于权。七难消除二求愿满是也。或因真智解脱于实。三毒皆离是也。或因权智得度于实。三十三身得度是也。或因权智得度于权。于怖畏急难之中得无畏是也。或二俱度脱。或二俱不度不脱。今依文判互出一边。前文脱权后文度实。料简本迹者。通论本迹俱能拔苦与乐。故寿量云。闻佛寿无量得清净无漏无量之果报。即是从本得乐。请观音云。或游戏地狱大悲代受苦。此是从迹拔苦。众生不达本源后流转苦恼。若识本理即于苦而得解脱也。众生若不见迹中施化。不能三业种福则无功德之因。焉致乐果。非本无以垂迹非迹无以显本。前问答是明迹本。后问答是明本迹

问。本迹与真应云何异

答。真应就一世横辩。如诸经所明。本迹就三世竖论。如寿量所说。料简缘了者

问。缘了既有性德善亦有性德恶否

答。具

问。阐提与佛断何等善恶

答。阐提断修善尽但性善在。佛断修恶尽但性恶在

问。性德善恶何不可断

答。性之善恶但是善恶之法门。性不可改历三世无谁能毁。复不可断坏。譬如魔虽烧经何能令性善法门尽。纵令佛烧恶谱亦不能令恶法门尽。如秦焚典坑儒。岂能令善恶断尽耶

问。阐提不断性善还能令修善起。佛不断性恶还令修恶起耶

答。阐提既不达性善。以不达故还为善所染。修善得起广治诸恶。佛虽不断性恶而能达于恶。以达恶故于恶自在。故不为恶所染修恶不得起。故佛永无复恶。以自在故广用诸恶法门化度众生。终日用之终日不染。不染故不起。那得以阐提为例耶。若阐提能达此善恶。则不复名为一阐提也。若依他人明阐提断善尽为阿梨耶识所熏更能起善。梨耶即是无记无明。善恶依持为一切种子。阐提不断无明无记故还生善。佛断无记无明尽无所可熏故恶不复还生。若欲以恶化物。但作神通变现度众生尔。问若佛地断恶尽作神通以恶化物者。此作意方能起恶。如人画诸色像非是任运。如明镜不动色像自形。可是不可思议理能应恶。若作意者与外道何异。今明阐提不断性德之善遇缘善发。佛亦不断性恶机缘所激慈力所熏。入阿鼻同一切恶事化众生。以有性恶故名不断。无复修恶名不常。若修性俱尽则是断不得为不断不常。阐提亦尔。性善不断还生善根。如来性恶不断还能起恶。虽起于恶而是解心无染。通达恶际即是实际。能以五逆相而得解脱。亦不缚不脱行于非道通达佛道。阐提染而不达与此为异也。料简智断者。此是一法异名不得相离。如人一体。何故从智拔苦从断与乐。然而慧解之心称智。无缚碍身称断。譬如人被缚。运力属智肃然附外属断运力属心。故名智慧庄严。附断体散属色身名福德庄严。今经文言说不得一时。故互举智断若深得此十义意者。解一千从。广释观世音普门义则不可尽也。第二别释名者。为二。先明观世音。次明普门。以何因缘名观世音。通释如前。别者则以境智因缘故名观世音。云何境智。境智有二。一思议境智。二不思议境智。思议境智又二。一约理外。二约理内。理外为四。一天然境智。只问此境为当由境故境由智故境。此智为当由智故智由境故智。若由境故境此境是境。境即自生境。若智由智故智亦是自生智。自生名性自尔。非佛天人所作。照与不照恒是境智。故名天然境智。二明相待者。若境不自境因智故境。智不自智因境故智此即他生义。何故尔。境自生境既称为自。以境望智。智即是他。今境从智生岂非他境。智亦如是故名相待。次明因。缘境智者。若境不由智故境亦不由境故境。智境因缘故境。智亦如是。此即境智因缘共生义。共生有二过堕自他性中。次绝待明境智者。非境非智而说境智。此即离境离智无因缘而辩境智者。此是无因缘绝待。从因缘尚不可得。何况无因缘。一往谓绝理而穷之不成绝待。并是理外行心妄想推计。故中论云。诸法不自生。亦不从他生。不共不无因。是故说无生。那得如前四种。计执是实余妄语。性实之执见爱生着九十八使。苦集浩然流转不息。云何执此而生苦集。随执一种境智谓以为是。随顺赞叹心则爱着而生欢喜。即是贪使。若人违逆责毁心则忿怒而生嗔恚即是嗔使。贪恚既起岂非痴使。我解此境智他所不解以其所执矜傲于人岂非慢使。既执此为是。今虽无疑后当大疑岂非疑使。我知解此法。法中计我岂非身见。六十二见随堕一边岂非边见。如此妄执不当道理岂非邪见。执此是实计为涅槃岂非见取果盗。谓此为道依之进行岂非戒取因盗。十使宛然皆从所执境智上起。将此历三界四谛则有八十八使。就思惟历三界则有九十八使。此则集谛结业颠倒浩然。方招苦果生死不绝。于其境智不识苦集。何处有道灭。既不识四谛则破世间出世间因果。无世出世法故无法宝。不识出世果无佛宝。不识出世因无僧宝贤圣之义。一切俱失。若作如此执自生境智者。只是结构生死。增长结业过患甚多。若非理外境智更将何等为理外耶。故大论云。凡夫三种语。见慢名字。圣人但一种语。名字。今凡夫见慢取着谬用佛语。介尔取着乖理成诤。虽傍经论引证文字。如虫蚀木偶得成字。寻其内心实不能解是字非字。口言境智不解境智。以不解故如服甘露。则以境智起见伤命早夭。故为龙树所破。今不取此为境智以释观世音。自生境智既尔余三句亦然。二明思议理内境智者。亦作上四门。名字虽同观智淳熟不生执见。毕故不造新成方便道。发生暖顶乃至十六心眼智明觉。豁然得悟。破诸见惑与理相应。譬如盲人金[金*畀]抉膜灼然不谬。此之真观名之为智。所照之理名之为境。以发无漏故称理内境智。虽见此理终是作意入真。故名思议境智也。今明观世音亦不从此境智因缘得名也

次明不思议境智者。若自他共无因等四句俱非境智者。今诸经论所明或从自生他生共生无因等。若不尔者。云何辩境智耶

答。经中所明。皆是四悉檀赴缘假名字说。无四性执。若人乐闻自生境智。即说境是自境智是自智。以赴其欣欲之心。或时宜闻自境自智闻必生善。或时对治说自生境智。说必破惑。有时说此令即悟道。若无四悉檀益。诸佛如来不空说法。虽作四说无四种执。无执故无见爱。众生闻者如快马见鞭影。即破惑入道故名为智。此智所照名之为境。如是通达则识苦集道灭。三宝四谛宛然具足。若以智照境入空取证。成真谛理内思议境智。如前说。若不以果为证。知此境智但有名字名为境智。是字不在内外中间。是字不住亦不不住。是字无所有故。虽作四句明境智实不分别四句境智。虽作四句闻境智实不得四句境智。虽体达四句境智实不作四句思量境智。言语道断心行处灭。不可四句思惟图度。故名不思议境智。金光明云。不思议智照不思议智境此具如大本玄义境智妙中广说。龙树先破一异时方然后释如是我闻等义。今类此先破理外境智。后明不思议四悉檀。悉檀义如大本玄义。夫依名字为便。应先明观智次辩世境之音。若解义为便。前明世境。次辩观智。如先有境可得论观。若未有境何所可观。譬如境鼓后方映击。今从义便。先明世音。后论观智也。世者为三。一五阴世间。二众生世间。三国土世间。既有实法即有假人。假实正成即有依报故名三种世间也。世是隔别即十法界之世亦是十种五阴。十种假名。十种依报。隔别不同故名为世也。间是间差。三十种世间差别不相谬乱。故名为间。各各有因各各有果。故名为法。各各有界畔分齐。故名为界。今就一法界复有十法。所谓如是相性究竟等。十界即有百法。十界相互则有千法。如是等法皆是因缘生法。六道是惑因缘法四圣是解因缘法。大经云。无漏亦有因缘。因灭无明即是三菩提灯。是诸因缘法即是三谛。因缘所生法我说即是空。亦名为假名亦名中道义。故明十种法界三十种世间。即是所观之境也。此境复为二。所谓自他。他者谓众生佛。自者即心而具。如华严云。心如工画师造种种五阴。一切世间中莫不由心造

问。自他那得各具十法界

答。观身实相观佛亦然。华严云。心然佛亦然。心佛及众生是三无差别。岂不各各具三谛境耶。音者即十法界口业之机也。界既不同音亦有异。问众生各有三业何意但观音。然通论皆得。常念恭敬得离三毒即是观世音。礼拜供养所求愿满即是观世身。而今但言观世音者。旧释此义为六。一趣立者。诸名不可累出举一趣以标名。若称为观世身者。已复还问此言。何意不名观世音此则非问。二随俗者。释迦所说以音声为佛事。故言观世音。若游诸国土随彼所宜。三互举者。能观所观。所观即众生色心也。今从能观故但言观。能闻所闻。能闻是圣人耳识。所闻是众生音声。今取所闻之音声。举所闻得能闻。举能观得所观。从此为名故言观世音。旧问。能所既尔何不取。所观之色心能闻之耳识。以标名称为闻色心菩萨耶。旧答云。菩萨一观于色心此是应广。众生之一音此是机狭。若从难者则机有两字应但一字。便是应狭机广故不如所难。今更作难。此语应从义理那得逐字。菩萨以能观色心。何意不能观音声。众生何意但以声感色心不能感耶。若其俱感俱应此逐字为。观则感应齐等若为判其广狭。今不作此明互举凡圣感应皆通三业。而圣人与意凡夫与声。故言观世音尔。四义摄者。如发声必先假意气触唇口其音能出。口业若成则摄得身意。若观于口业亦摄得身意。观余不尔故言义摄。五隐显者。身虽礼拜意虽存想。未知归趣何等故名隐。若口音宣畅事义则彰故名显。举显没隐故言观世音。六难易者。临危在厄。意则十念难成身则拜跪迟钝。口唱为急故成机。从易受名也。又第六为有缘。观音昔为凡夫居兹忍界见苦发誓。今生西方多还此土。既有誓缘急须称名。今明。若如前六义皆遍有所举。若依释论其义即圆。何以故。出入息是身行觉观是口行受为心行。心觉观故尚具三业。何况发音成声而不备三业耶。但举一观即备三应。但举一音即备三机。而凡情谓声强智利逐物标名。圆义往推悉皆具足

观音玄义卷上观音玄义卷下

        隋天台智者大师说　门人灌顶记

第二明观者。又为二。一结束世音之境。二明能观之智。结境即为六。一结十法界是因缘境。二四谛境。三三谛境。四二谛境。五一实谛境。六无谛境。此具出大本玄义。二明观智者。傍境明智作五番明观智。就因缘则四番因缘论观。四谛亦有四番论观。三谛有两番论观。二谛有七番论观。一实谛则一番论观。无谛则无观。如此等义具在大本。今约三谛明观。若通论十法界皆是因缘所生法。此因缘即空即假即中。即空是真谛即假是俗谛即中是中道第一义谛。若别论六道界是因缘生法。二乘界是空菩萨界是假佛界是中。论境即有二意。今对境明观亦为二意。一次第三观。二一心三观。次第者。如璎珞云。从假入空名二谛观。从空入假名平等观。二观为方便得入中道第一义谛观。此之三观即是大品所明三智。一一切智。知一切内法内名一切能知能解。一切外法外名能知能解。但不能用以一切道起一切种。故名一切智。二道种智。能知一切道种差别则分别假名无谬。故名道种智。三一切种智。能于一种智知一切道知一切种。一相寂灭相种种行类能知能解。名一切种智。通而为论观智是其异名。别而往目因时名观果时名智。此三观智即是大经四种十二因缘观。下中上上上。涅槃通取析法明于四观。大品璎珞直就摩诃衍但明三观三智。今若开二经合涅槃者。应开衍法从假入空观生灭一切智也。若合涅槃就二经。合下中二观同是一切智也。若将三经若开若合对五眼者。天眼肉眼照粗细事皆是世智。悉为诸观境本。若三观三智从此即入体法一切智。若四观四智此即入析法一切智故肉眼天眼为本。若入一切智对慧眼。道种智对法眼。一切种智对佛眼。中论偈因缘所生法一句为观智之本。三句对三智。若将三观智对四教。即须开之如前。若将涅槃四观对四教。下智是生灭一切智对三藏教也。中智是体法一切智对通教也。上智即道种智对别教。上上智即一切种智对圆教。所以应明三观。那忽对四教者何。若无教即无观。禀教修观得成于智。所以明教也。教必有主。有主即佛也。或可一佛说四教。或可示四相明四佛。四教既有四主即应有四补处。即是四种菩萨辅佛弘此四教也

若言诸法寂灭相不可以言宣。大经云。生生不可说乃至不生不生亦不可说。一教尚不可说云何有四

答。理论实尔皆不可说。赴缘利物有因缘故亦可得说。非但生生可说乃至不生不生亦可说。以佛教门出生死苦。三藏教者。如释论引迦旃延子明菩萨义。释迦初为陶师值昔释迦佛发愿。从是已来始发菩萨心。即是行人所求菩提即名为法。深厌苦集欣求灭道。即起慈悲心誓度一切。行六度行。行愿相扶拔苦与乐。所以者何。悭名为集堕饿鬼名苦。行檀名道悭息名灭。菩萨自伏悭贪悲心熏物。众生称名即能脱苦。自行檀施慈心熏物。物应可度即能示现令得安乐。当知为满弘誓而修檀行也。乃至愚痴名集生天名苦。修慧名道痴伏名灭。修慧度时自破苦集为成悲心以熏众生。众生称名即得解脱。自证道灭以成慈心以熏众生。众生有感应机得度。故知行填于愿。行此六度各论时节。尸毗代鸽是檀满。须摩提不妄语是尸满。歌利王割截不动是忍满。大施抒海是精进满。尚阇梨坐禅是定满。劬傧大臣分地是般若满。如此修行至初僧祇劫。不知作佛不作佛。第二僧祇心知作佛口不言作佛。第三僧祇心知口言。过三僧祇已又百劫种相。百福凡用三千二百福修成。三十二大人相现时方称菩萨摩诃萨。但伏惑不断。如无脂肥羊。取世智为般若即此意也。用此菩萨行对声闻行位者。初僧祇可对总别念处。二僧祇可对暖法。三僧祇可对顶法。百劫种相可对忍法。坐道场时可对世第一。三十四心断结成佛。即对十六心发真乃至九解脱无学也。尔时坐道场上三十四心断惑。正习俱尽名为三藏佛。所以释迦精进弟子纯熟。以精进故九劫前超八相成佛。此即是三藏教主所说教门。此中补处位在百劫。种相伏惑住最后身。六度行成誓愿将满。慈悲熏于众生拔苦与乐。若就此辩者。但是因缘生法世智明观。即是三藏教观世音义也

问。依三藏说释迦弥勒同时发心。一超九劫。何意二佛俱成贤劫中佛耶

答。释迦值弗沙促百劫。弥勒值诸佛何必不促为九十一劫耶

若尔则无百劫义

答。任此法门则有百劫。以精进力传超。通教者。如大品明。三乘之人同以第一义谛无言说道。断烦恼入涅槃。共缘一理用观断惑通也。亦名共般若教。此事与三藏异。释论破云。岂以不净心修菩萨行。如毒器盛食。食则杀人。檀有上中下。谓舍财身命也。勇士烈女亦能舍身。何得中舍名檀满。中檀但名施非波罗蜜。不见能所财物三事皆空非悭非施。此是真檀波罗蜜。乃至非愚非智无著空慧。名真般若不取世智。论云若不信空一切皆违失。当知汝所修皆不与理相应。若信诸法空一切有所作。良以空故能成一切诸法。故知若得空慧能具一切法也。又复菩萨无量劫修行。何但三阿僧祇。如是等种种破三藏失。以显摩诃衍中通教意也。大品云。菩萨发心与萨婆若相应。此即观真断结与理相应也。发心已来即观真断结便称菩萨。即是假人也。又观真即是法也。常与慈悲俱起。自断苦集修道灭。亦以慈悲誓愿断一切众生苦集与其道灭。体达诸法如幻如化不生不灭。三事俱亡以行檀。乃至一切法无所著名般若。以此诸行填愿。即能破四住惑见第一义。则有三乘共十地。所谓干慧乃至佛地。若将此十地来对声闻者。干慧地对总别念处。性地对四善根位。八人地对八忍。见地对初果。薄地对二果。离欲地对三果。已办地对四果。支佛地自对支佛位。菩萨地自是出假方便。道观双流断正侵习佛地尽。故论云。是人烦恼尽习不尽。以誓扶习还生三界。利益众生净佛国土。岂同三藏菩萨伏惑行六度行耶。此菩萨修行断惑余残未尽。譬若微烟。慈悲五道示现度物。众生若称名若感见。即能拔苦与乐解脱得度也。此是通教体假入空观。亦名一切智。即是通教观世音义也。别教者别异通也。别明不共般若故言别也。比教虽明中道。为钝根人方便说中。次第显理广明历劫修行。故大品云。有菩萨从初发心游戏神通净佛国土。次第修习恒沙法门助显中理。前却四住次破尘沙后破无明。十信通伏诸惑而正伏四住。十住亦是通伏诸惑。而正断四住成一切智。十行出假断无知。成道种智兼伏界外尘沙。十回向断界外尘沙。成道种智正修中道伏无明。十地断无明见佛性。成一切种智。譬如烧金尘垢先去然后镕金。次第断结亦复如是。此菩萨发心秉法慈悲修行。自断无明成就真应。大誓慈悲熏于法界。众生机感即拔苦与乐。此是从空出假观道种智。别教观世音义也。圆教者。此正显中道遮于二边。非空非假非内非外观十法界众生。如镜中像水中月。不在内不在外。不可谓有不可谓无。毕竟非实而三谛之理宛然具足。无前无后在一心中。即一而论三。即三而论一。观智既尔谛理亦然。一谛即三谛。三谛即一谛。大品云。有菩萨从初发心即坐道场转法轮度众生。即于初心具观三谛一切佛法。无缘慈悲于一心中具修万行诸波罗蜜。入十信铁轮已能长别苦轮海。四住惑尽六根清净名似解。进入十住铜轮初心即破无明。开发实相三智现前。得如来一身无量身湛然应一切。即是开佛知见示悟入等。文云。正直舍方便但说无上道。又云。今当为汝说最实事。即是圆教一实之谛三观在一心中也。大品云。若闻阿字门则解一切义。大经云。发心毕竟二不别如是二心前心难。是故敬礼初发心。即是义也。此中知见但称为佛知佛见。即是一切种智知佛眼见。佛眼见佛智知。非不照了余法。从胜受名。譬如众流入海失本名字。大论云。十智入如实智无复本名。但称如实智。眼亦如是。五眼具足成菩提。而今但称为佛眼。大经云。学大乘者虽有肉眼名为佛眼。若例此语学小乘者。虽有慧眼名为肉眼也。若能如是解者名圆教人法。约无作四谛起无缘慈悲。修不二定慧成真应二身。真遍法界药珠普应一切。横竖逗机冥显两益。以无缺宝藏金刚般若。拔根本究竟解脱。以首楞严法界健相与三点涅槃大自在乐。是名中道第一义谛观一切种智。是名圆教观世音义也

问。此观。观众生非空非有。云何行慈悲

答。如净名中说

问。若观十法界非空非假者。即是破一切因果耶

答。若不明中道则不识非权非实。亦无权无实则无四番因果。若明中道则权实双照。得有三种权四谛苦集因果三种道灭因果。乃至一实无作四谛世出世因果。宛然具足在一念心中。所以者何。以实相慧觉了诸法非空非有。故名为佛宝。所觉法性之理三谛具足。即是法宝。如此觉慧与理事和名僧宝。事和即有前三教贤圣僧。与理和即有圆教四十二贤圣僧。故大经月光增损而举两喻。前十五日约光论增。后十五日约光论减。而其月性实不偏圆。前后往望不无盈昃。月性圆者喻于实相。光明增减以喻智断。智光增者即诸法不生而般若生。断光减者即是诸法不灭而烦恼灭。大经亦称无明为明。故知用譬邪光灭也。如是增减日日有之。如是智断地地皆具。若十五日体圆光足。则月不更圆光不更盛。此喻中道理极菩提智满。故云不生不生名大涅槃。若三十日体尽光减究竟无余。此喻无明已遣邪倒永除无惑可断。故云不灭不灭名大涅槃。初三日月即喻三十心智断。次十日月喻十地智断。十四日月喻等觉智断。十五日月喻妙觉智断。仁王天王等般若以十四日譬十四般若。即此意也。如此明僧宝智断皆约中道一实相法。一切因果无所破失也。若不明中道非空非假但计断常等。即是破生灭四谛世出世因果。破三藏三宝。若但说无常生灭者。即破无生四谛通教三宝。若但说体法不生不灭真谛者。即破无量四谛别教三宝。若但说次第显非空非假者。此亦破圆教无作四谛一体三宝。传传相望前所破失者多。后所破失者少。可以意得

问。若圆修实相一法三谛一心三观具足诸法。亦应一教四。诠称于圆教即足。何用四教如前分耶

答。上开章云。次第三观一心三观。明教亦二。若一教圆诠一切诸法者赴利根人。若四教差别逗钝根人。若不假渐次分别圆顿何由可解。用别显圆故先明四教也。虽说种种道其实为一乘。又于如来余深法中示教利喜。余法即三方便引导弄引开空法道。若入佛慧方便无用。故云唯此一事实余二则非真。故知但一圆顿之教一切种智中道正观。唯此为实观世音。余皆方便说也

复次若有所说若权若实悉是方便。非权非实言语道断心行处灭不可说示。不生不生妙悟契理方名为真。此亦无实可实。次明观心者。夫心源本净无为无数非一非二。无色无相非偏非圆。虽复觉知亦无觉知。若念未念四运检心毕竟叵得。岂可次第不次第偏圆观耶。犹如虚空等无有异。此之心性毕竟无心。有因缘时亦得明心。既有论心即有方便正观之义。譬如虚空亦有阴阳两时。心亦如是。虽无偏圆亦论渐顿。若作次第观心者即是方便渐次意也。若观心具有性德三谛性德三观及一切法。无前无后无有次第一念具足。十法界法千种性相因缘生法。即空即假即中。千种三谛无量无边法一心悉具足。此即不次第观也。华严云。一切世间中无不从心造。心如工画师造种种五阴。若观心空从心所造一切皆空。若观心有从心所生一切皆有。心若定有不可令空。心若定空不可令有。以不定空空则非空。以不定有有则非有。非空非有双遮二边。名为中道。若观心非空非有。则一切从心生法亦非空非有。如是等一切诸法在一心中。若能如是观心。名上上观得诸佛菩提。净名云。观身实相观佛亦然。观身相既等于佛观心相亦等于佛。华严云。心佛及众生是三无差别。当知观此心源与如来等。若作余观观心皆是方便。名为邪观。若作如此圆观。名为真实正观。即开佛知见坐如来座。如此慈悲即是入如来室。安忍此法即是着如来衣。修此观慧即是如来庄严。其人行住坐卧皆应起塔。生如来想如此观心名观佛心也。第二明普门。即为二。一通途明门二历十义解释。通六意者。一略列门名。二示门相。三明权实。四明普不普。五约四随。六明观心。列门名者。通从世间。如人门户通至贵贱居室。凡鄙以十恶五逆为门。通至三途。清升以五戒十善四禅四定等为门。通至人天。外道以断常为门。通至惑苦。爱以四倒为门。见以四句为门。善恶虽殊束而为言。俱是有漏世间之门。通至生死尔。若就佛法论门亦复众多。三藏四门通有余无余涅槃。通教四门近通化城远通常住。别教四门渐通常住。圆教四门顿通常住。此则四四十六教门。又有十六观门。合三十二门。能通之义分别其相在大本玄中。二示门相者。三藏四门所谓阿毗昙是有门。成实是空门。昆勒亦空亦有门。车匿非空非有门。一一广明行法判贤圣位。由门通理。通教四门者。谓如幻之有。如幻之空。亦空亦有。非空非有。一一作行相判贤圣位。由门通理。别教四门。观佛性如闇室瓶盆即有门。观佛性如空迦毗罗城空即无门。观佛性如石中金福人得宝罪人见石。是亦有亦无门。观佛性离二边即中道。非有非无门。一一作行相判位由门通理。圆教四门名不异别。但一门即三门。三门即一门。不一不四无历别之殊。圆融不四之四。一一判不思议行位之相由门通理。此义皆在大本。次论诸门权实。三藏通教教观。十六门能通所通皆是权。别教教观能通是权所通是实。圆教教观八门能通所通皆是实。具论在彼玄义。次明普不普者。若凡夫外道见爱等门尚不能通出三界。何况普耶。三藏通教虽通化城亦复非普。别教渐通亦非普义。唯圆教教观实相法门能遍十法界。千性相三谛一时圆通。圆通中道双照二谛。独称为普门也

复次如净名中说入不二门者。生死涅槃为二。不依生死不依涅槃。名为不二。亦复非一。何以故。既除于二若复在一。一对不一还复成二。岂名不二耶。今不在二故言不一不二。亦名不有不无。不有是破假。不无是破空。不有是破二。不无是破一。若尔者。应存中道中道亦空。大经云。明与无明其性不二。不二之性即是中道。中道既空于二边此空亦空。故名空空空。名不可得空。是为入不二法门。即是圆教就空门辩普门之意也。三十一菩萨各说不二门。文殊说无说为不二门。净名杜口为不二门。细寻彼文皆有四门义。肇师注云。诸菩萨历言法相即有门。文殊言于无言此即空门。思益云。一切法正一切法邪。亦是普门意。游心法界如虚空。是亦空亦有门。净名默然即非空非有门。大品四十二字门先阿后茶中有四十字。皆具诸字功德。此亦是不二普门。上方便品云。其智慧门难解难入。譬喻云。唯有一门而复狭小。众经明实理门者。悉普门意也。四随观心等悉在大本。二别释普门者。至理非数赴缘利物。或作一二之名。或至无量。广略宜然且存中适十义一慈悲普。二弘誓普。三修行普。四断惑普。五入法门普。六神通普。七方便普。八说法普。九供养诸佛普。十成就众生普。上过途普门已约法竟。此十普门皆约修行福德庄严。前五章是自行。次三章是化他。后二章结前两意。自行中前四是修因后一是明果。修因又二。初二是愿。后二是行。总生起者。菩萨见一切苦恼众生起大慈悲。此心虽不即是菩提心能发生菩提心。譬如地水虽非种子能令芽生。今因大悲起菩提心亦复如是。次誓愿者。若但慈悲喜多退堕。鱼子庵罗华菩萨初发心三事。因时多及其成就少。以不定故。须起誓愿要期制持此心。即菩提坚固。次明修行者。若但发愿于他未益。如无财物势力权谋不能拔难。菩萨亦尔。须福德财神通力智慧谋。乃可化道。大经云。先以定动后以慧拔。修行填愿意在此也。次断惑者。成论人无碍道伏解脱道断。若然者。修行是伏道为因。断惑是解脱道为果。若毗昙明无碍道一念即断。那得容与七觉而有伏惑之义。以方便道伏无碍道断解脱道证。引释论云。无碍道中行名菩萨。解脱道中行名佛。此约究竟为语。佛证三菩提。名解脱道也。若然者。修行是方便道。断惑是无碍道。入法门是解脱道。取此自行次第也。次神通者。若欲化他示三密。神通是示色身。方便示意同情。说法是示口随其类音。此是化他次第也。供养诸佛结自行。非但华香四事是供养。随顺修行是法供养。于供养中最。大经云。汝随我语即供养佛。禀教而行是结自行也。成就众生是结化他。菩萨四威仪中尚不忘众生。何况入诸法门净佛国土。皆为饶益一切众生。故一句结化他也。次解释者。始从人天乃至上地皆有慈悲。此语乃通不出众生法缘无缘。若缘众生众生差别假名不同。因果苦乐有异。尚不得入于法缘之慈。何得称普耶。若法缘无人无我无众生。从假以入空尚不得诸假名。何况是普。若无缘慈者。不缘二十五有假名。不缘二乘涅槃之法。不缘此二边。虽无所缘。而能双照空假。约此起慈名无缘慈。心通三谛称之为普也。别释者。若修众生缘慈者。观一法界众生假名。可不名普。今观十法界众生假名。一一界各有十种性相本末究竟等。十法界交互即有百法界千种性相。冥伏在心虽不现前宛然具足。譬如人面备休否相。庸人不知相师善识。今众生性相一心具足。亦复如是。凡人多颠倒少不颠倒理具情迷。圣人知觉即识如彼相师。知此千种性相皆是因缘生法。若是恶因缘生法。即有苦性相乃至苦本末。既未解脱。观此苦而起大悲。若观善因缘生法。即有乐性相乃至乐本末。观此而起大慈。具解如大本。今约初后两界中间可解。地狱界如是性者。性名不改。如竹中有火性。若其无者。不应从竹求火从地求水从扇求风。心有地狱界性亦复如是。地狱相者。揽而可别名之为相。善观心者即识地狱之相。如善相师别相无谬。故名相也。体者以心为体。心觉苦乐故以当体。譬如钗铛环钏之殊。终以银为体质。六道之色乃异只是约心。故心为体也。乃至运御名力。缘山入火皆是其力也。作者为动曰作。已能有力即有所作。或作善作恶也。因者业是因也。缘者假藉为缘也。如爱润业因缘合也。果者习果也。如地狱人前世多淫。生地狱中还约多淫见可爱境。即往亲附名习果也。报者报果也。昔有淫罪今堕地狱受烧炙之苦。名报果也。本者性德法也。末者修得法也。究竟等者揽修得即等有性德。揽性德即具有修得。初后相在故言等也。地狱界十相性既如此。余九亦然

问。当界有十性相可然。云何交互相有。余界交互已难可信。云何地狱有佛性相本末耶

答。大经云。夫有心者皆当得三菩提。如仙豫杀婆罗门即有三念。又婆薮地狱人好高刚柔等义。虽在地狱佛性之理究竟不失。故知地狱界即有佛性。佛相者即是性德之相也。净名经云。一切众生即菩提相。圣人鉴之冷然可别也。体者即是地狱界心实相理也。力者法性十力变通大用也。作者从无住本立一切法。如师子筋师子乳也。因者正因也。缘者性德缘了也。果即般若菩提大果也。报即大涅槃果果也。本即性德。末即修得。等者修得相貌在性德中。性德中亦具修得相貌。故言究竟等也。大经云。雪山之中有妙药王亦有毒草。地狱一界尚具佛果性相十法。何况余界耶。地狱互有九界。余界互有亦如是。菩萨深观十法界众生。千种性相具在一心。远讨根源照其性德之恶性德之善。尚自冷然。何况不照修得善恶耶。如见雪山药王毒草。以观性德恶毒恻怆怜愍。起大悲心欲拔其苦。以观性德善乐爱念欢喜。起大慈心欲与其乐。此十法界收一切众生罄无不尽。缘此众生假名修慈。岂非众生慈普耶

问。地狱界重苦未拔。云何言与乐耶

答。众生入地狱时多起三念。菩萨承机即与乐因。故言与乐也。又菩萨能大悲代受苦。令其休息。余界苦轻与乐义可解。二法缘慈者。观十法界性相一切善恶悉皆虚空。十法界假名假名皆空。十法界色受想行识行识皆空。十法界处所处所皆空。无我无我所皆不可得。如幻如化无有真实。常寂灭相终归于空。众生云何强计为实。良以众生不觉不知为苦为恼。不得无为寂灭之乐。拔其此苦而起大悲。欲与其此乐故起大慈。净名云。能为众生说如此法。即真实慈也。若缘一法界法起慈者可不名普。今缘十法界法岂非普耶。是名法缘慈普也。三无缘慈者。若缘十法界性相等差别假名。此假则非假。十法界如幻如化空则非空。非假故不缘十法界性相。非空故不缘十法界之真。既遮此二边无住无著。名为中道。亦无中可缘毕竟清净。如是观时虽不缘于空假。任运双照二边。起无缘慈悲拔二死之苦。与中道之乐。如磁石吸铁。无有教者自然相应。无缘慈悲吸三谛机更无差忒。不须作念故言无缘慈悲也。行者始于凡地修此慈悲。即得入于五品弟子。观行无缘慈悲。进入十信位相似无缘慈悲入于十住。方是分证无缘慈悲。乃至等觉邻极慈悲熏众生。不动如明镜。无念如磁石任运吸铁。故名无缘慈悲。三谛具足名之为普。通至中道故称为门也。二弘誓普者。弘名为广。誓名为制。愿名要求。是故制御其心广求胜法。故名弘誓也。弘誓本成慈悲。慈悲既缘苦乐弘誓亦约四谛。若见苦谛逼迫楚毒辛酸。缘此起誓故言未度令度也。若见集谛颠倒流转迷惑系缚。生死浩然而无涯畔。甚可哀伤约此起誓故言未解令解也。清净之道众生不识。行此道者能出生死至安乐地。欲示众生立于此道。故言未安令安。灭烦恼处名为涅槃。子果缚断获二涅槃。约此起誓故云未得涅槃令得涅槃。生死因难识苦果易知。故先果后因。涅槃理妙须方便善。故先因后果。大经云。不解钻摇浆犹难得况复生酥醍醐。如此四意但一往。只迷心起业业即感果。欲识果源知果因集。制心息业则生死轮坏。烦恼调伏名之为道。修行不懈苦忍明发。子果俱断证尽无生。名之为灭。虽有四别终是一念。更非异法。四谛既尔弘誓亦然。次明普不普者。若凡夫既厌下攀上。约此立誓是不名普。二乘见三界火宅畏此修道。此乃见分段四谛亦不名普。若别教先约分段次约变易此亦非普。若圆教菩萨于一心中照一切苦集灭道。遍知凡夫见爱即有作之集。二乘着空即无作之集。故净名云。法名无染。若染于法。是名染法。非求法也。又云。结习未尽华则着身。即是变易之惑全未除也。大经云。汝诸比丘于此大乘未为正法除诸结使。即无作集也。乃至顺道法爱生亦是无作集也。是名遍知集。遍知苦者。以有集故即能招苦报。有作之集招分段苦。无作之集招变易苦。即知苦谛也。遍知对治苦集之道灭。从五戒十善不动不出。二乘四谛十二因缘。通至有余无余涅槃。通教亦尔。别教历别通至常住。不能于一道有无量道。不名普道。圆教中道即是实相。普贤观云。大乘因者诸法实相。修如此道名为圆因称为普道。故所得涅槃即是究竟常住。一切烦恼永无遗余。譬如劫火无复遗烬。故名普灭。所观四谛既周。缘谛起誓何得不遍。故称弘誓普也。私用观十法界性德修得善恶。而起弘誓论普不普。自是一节大义。与四谛语异故逭用之亦应善也。三明修行普。先明次第修行。次明不次第修行。具在大本行妙中。四明断惑普者。若从假入空止断四住惑。华犹着身。未为正法除诸结使。但离虚妄非一切解脱。若从空入假止除尘沙。不依根本而断亦不名普。若空假不二正观中道。根本既倾枝条自去。如覆大地草木悉碎。故名断惑普也。五入法门普者。二乘若入一法门不能入二。何况众多。若修历别之行阶差浅深。我唯知此一法门余不能知者。此亦非普。若入王三昧一切悉入其中。譬如王来必有营从。营从复有营从。王三昧亦如是。入此三昧一切三昧悉入其中。所谓三谛三昧。三谛三昧复有无量法门而为眷属。亦皆悉入王三昧中。故名入法门普。六神通普者。若大罗汉天眼见大千。支佛见百佛土。菩萨见恒沙佛土。皆是限量之通故不名普。何以故。缘境既狭发通亦小。今圆教菩萨缘十法界境发通。遍见十法界而无限极。三乘尚不知其名。何况见其境界。眼见既尔余例可知。神通妙中当广说。七方便普者。进行方便是道前方便。起用方便是道后方便。今正明道后方便也。若二乘及小菩萨所行方便入一法门。若欲化他齐其所得起用化物。道前道后俱非是普。圆教菩萨二谛为方便。收得一切方便。入中道已双照二谛。二谛神变遍十法界。而于法身无所损减。道前道后皆名为普。八说法普者。二乘小菩萨说法不能一时遍答众声。又殊方异俗不能令其俱解。大经云。拘絺罗于声闻中四无碍辩为最第一。非谓菩萨也。今圆教人一音演法。随类得解。以一妙音遍满十方界。如修罗琴随人意出声。故名说法。说法妙中广说。九供养诸佛普者。就此为二。一事二理。华严云。不为供养一佛一国土微尘佛。乃至为供养不可说不可说佛。能不起灭定现诸威仪。安禅合掌赞诸法王。以身命财一切供具。周至十方。譬如云雨供养诸佛也。理解者。圆智正观之心名为觉。觉即是佛义。万行功德熏修此智此智名一切。修功德资供此智。即是供养一切智。净名云。以一食施一切。故云供养诸佛普。十成就众生普者。譬萤火灯烛星月为益盖微。日光照世。一切卉木丛林遍令生长华果成就。外道如萤火二乘如灯烛。通教如星别教如月。成就义约。今圆教圣人慈慧饶润。冥显两益而无限量。华严云。菩萨不为一众生一国土一方众生发菩提心。乃为不可说不可说佛刹微尘国土众生发心。成立利益一时等润。譬如大雨一切四方俱下。故名成就众生普。普门之义何量何边岂可穷尽。如净名之俦不能受持。今此观世音普门即对三号。观即是觉。觉名为佛。世音是境。境即是如。普门即正遍知。此之三义不可穷尽。若见其意则自在说也。私就普门品搜十普之义。证成此者。若如观音愍诸四众受其璎珞者。诸是不一之名。愍是悲伤之义。此即慈悲普。有慈悲任运有弘誓普义也。以种种形游诸国土度脱众生。即是净佛国土。岂非修行普。自既无缚能解他缚。自既无毒令他离毒。一时称名皆得解脱。皆是偏悉之言岂非断惑普。普门示现即是入法门普。方便之力即是方便普。神通力者即神通普。而为说法即说法普。多所饶益即成就众生普。分作二分奉二如来即供养诸佛普。如是义意悉在经文。故引以为证也。第二释体者。以灵智合法身为体。若余经明三身者。则单以法身为体。此品但有二身义。故用理智合为体也。只此智即实相理。何以故。若无灵智实相隐。名如来藏。今知权实相与理不二。如左右之名尔。若明实相体义。广出大本玄义。第三明宗者。以感应为宗。十界之机扣寂照之知。致有前后感应之益。益文虽广直将感应往收。如牵纲目动。所以用感应为宗。余经或用因果为宗。今品不尔者。因果语通从凡乃至上地。各有因果。能感所感既皆有因果。但经文意似不至此。机家虽有因果但以感为名。圣虽无因果但以应为名。则扶文义便也。感应义有六。一列名。二释相。三释同异。四明相对。五明普不普。六辩观心。具在大本

问。若言机者。是微善之将生。恶微将生亦是机不

答。然

问。机为是善为不善。若已是善何须感圣。若未是善那得言善之将生

答。性善冥伏如莲华在泥。圣人若应如日照则出

又问。若言机是关者。为善关不善关。若已是善何须关圣而成善。若非是善复何得关圣而成非善。凡圣条然何曾相关

答。善关于大慈恶关于大悲。故言相关

问。若言宜释机者。此乃是应家观机用与之言。那释感义

答。圆盖圆底互得相宜

问。为用法身应为用应身应。应身无常此则无应。法身若应此则非法身

答。法既言身何不言应。应身既称应何意不应。故俱应

又问。感应为一为异。若一感即是应凡便是圣。若异则不相关

答。不一不异而论感应

问。感应为虚为实。若是实者凡夫是实。实则何可化。若言是虚虚何所化

答。云云。以他

问。圣人是所感凡夫是能感。圣人是能应凡夫是所应。所感非是感所应非是应。云何言感应道交

答。所感实无感从感名所感。言圣人是所感。所应实无应。从应名所应。言凡夫是所应。还是感所为应能。应能为感所。亦是应所为感能。感能为应所。既无感应之实。亦无感应之异。不异而异者。圣没所感目为能应。凡没所应目为能感。故言感应道交。私难此语。若实无感应之异。今圣没能感凡没能应。何不圣没能应凡没能感。若如此则无凡圣之殊。若不如此感应便异何言不异。又感能无感能之实。而名感能者何不名应能。若应所无实何不名感所。若尔则无凡圣感应。若不尔则是异云何不异。又难。若以感能为应所感所为应能。此是自生义。若能应只是所应能感只是所感。还是自生义。若应能生应所感能生感所。能感生所感所感生能感。能应生所应所应生能应。皆是从他生。岂非他性义。若共生则二过。若离二堕无因过

问。若尔则无感应

答。圣人以平等无住法不住感。以四悉檀随机应尔

问。妄执之善能感不

答。妄执是恶亦得感

问。妄执既非一应亦为二

答。应本无二为缘何所不作

问。凡名凡僻。善则招乐恶则感苦。圣名为正。正则非善非恶非苦非乐。善恶之僻何能感非善非恶之正耶

答。正圣慈悲拔其善恶之僻。令入非善非恶之正。故有感应

第四慈悲利物为用者。二智不当用耶

答。二智语通今别附文。以盛明隐显之益。故以此当用尔。他释。法身冥益为常。应身暂出还没为无常。今明。法身常寂而恒照此理宜然。应身处处利益未尝休废亦是常义。若言有应不应以为无常者。法身亦有益无益故知俱是常无常俱有冥显。如日月共照一亏一盈。如来恒以常无常二法熏修众生。故言二鸟双游。而呼为常无常尔。譬如种植或假外日风雨内有土气暖润。而万物得增冥显两益亦复如是。此中应用王三昧十番破二十五有。以辩慈悲益物之用。具在大本玄中

问。观音利物广大如此。为已成佛。犹是菩萨

答。本地难知而经有两说。如观音受记经明。观音势至得如幻三昧。周旋往返十方化物。昔于金光师子游戏如来国王名威德。化生二子。左名宝意即是观音。右名宝尚即是势至。往问佛何供养胜。佛言。当发菩提心。从如来初发菩提心。次阿弥陀佛后当成正觉。观音名普光功德山王。势至名善住功德宝王。又如来藏经亦云。观音文殊皆未成佛。若观音三昧经云。先已成佛号正法明如来。释迦为彼佛作苦行弟子。二文相乖此言云何。乃是四悉檀化物。不可求其实也。第五明教相者。夫观音经部党甚多。或请观世音。观音受记观音三昧。观音忏悔。大悲雄猛观世音等不同。今所传者即是一千五百三十言法华之一品。而别传者。乃是昙摩罗谶法师亦号伊波勒菩萨。游化葱岭来至河西。河西王沮渠蒙逊归命正法。兼有疾患以告法师。师云。观世音与此土有缘。乃令诵念患苦即除。因是别傅一品流通部外也。此品是法华流通分。既通于开权显实之教。令冥显两益被于将来。以十法界身圆应一切。使得解脱。圆人秉于圆法流通此圆教故。即是流通圆教相也。五味为论即是流通醍醐味也

问。文云。方便之力种种不同。说亦应异。何得是圆教相

答。就能说之人为圆。弘圆教遍逗法界之机。机虽不同不可令能秉法人随机而遍。例如佛于一乘分别说三。岂可令佛便是声闻缘觉耶。又付嘱云。若人深信解者为说此经。若不信者于余深法中示教利喜。既奉佛旨圆逗万机。种种不同只是流通圆教。又问。能说人圆于教亦圆。行人机异此人禀何教耶。若禀偏教与鹿苑人同若禀圆教机亦应。一答昔鹿苑佛未发本显迹。不会三归一。人法未圆。所禀方便不得称圆。今经已开显权实。虽是种种身本迹不思议一。虽说种种法为开圆道。于义无咎

问。上文云正直舍方便。此中那言以方便

答。上正显实故言其舍。此中论用故言示现。体用不思议一也

观音玄义卷下


观音玄义记卷

    No. 1727 [cf. Nos. 262(25), 1726]

观音玄义记卷第一

        宋四明沙门知礼述

知礼俯伏惟念。早年慕学投迹宝云。遇授法师讲说此品。神根既钝遂数咨疑。先师念我学勤。不辞提耳。故所说义粗记在心。昔同闻人今各衰朽。虑乎先见不益后昆。共勉不才抄录于世。但疑识暗谬有所传。圆宗哲人刊正是望。时天禧五年岁在辛酉八月一日绝笔故序

观音玄义从略标之具存应云观世音菩萨普门品玄义。以其序中及以正文具明人法。故且略标。言玄义者能释之义门也。玄者幽微难见之称。义者深有所以也。斯盖大师以三昧力彻法性际。深见今品人法之意也。应知名等五义皆悉幽微七方便人智莫能见。卷上者。既有两轴乃以上下而甄别。之次示能说之人。即天台智者。既是门人记录所说。故不敢正斥其法讳也。天台山者即大师栖身入寂之所。故以此处显其人也。若山之得名居之所自。入灭相状灭后灵异。具于大本及辅行别传等文。今不备述。智者者。即隋帝求受菩萨大戒讫。师云。大王迂遵圣禁宜号总持。王曰。地持经云。传佛法灯即是智者。师既传灯可号智者。自此凡上书疏皆云弟子总持和南智者。言大师者。斯乃帝王大人所师故称也。非同今时补署之号。说者悦也。纵乐说之辩悦妙悟之怀。异乎诸师采摭经论。著述疏章消解经文也。故大忍法师睹智者说法。对众叹云。此非文疏所载。乃是观机纵辩。般若非钝非利。利钝由缘。丰富适时。是其利相。池深花大钝可意得。记录乃是章安尊者。解行灵异始终事迹。本传具彰。释文为二。初释序文二。初叙真应益物二。初正明真应二。初示二身妙用三。初明体妙故。二用泯亡二。初法融应泯。法界圆融者。色心依正以即性故。趣指一法遍摄一切。诸法遍摄亦复如是。法法互遍皆无际畔。乃以无界而为其界。此之法界无不圆融。即百界千如百如千界也。是故得云唯色唯心唯依唯正。若不尔者。即非圆融。观音证此以为本体。全此妙体而起应像。以法界应赴法界机。亦是以法界机感法界应。法界无二能所自忘。感应尚忘体用宁异。故虽设应无应可存。故云像无所像。二真如下性净真忘。真如清净者。起信论云。真如者。所谓心性不生不灭。是故一切法从本已来。离言说相离名字相。离心缘相毕竟平等。无有变异不可破坏。唯是一心故名真如。又云。此真如体无有可遣。以一切法悉皆真故。亦无可立。以一切法皆同如故。既不可破立自绝言想。则与河沙烦恼本不相应。故曰清净。观音证此而为本体。即以此体示诸众生。令观行知或真似见。此知见者成伏断益。若其未有此知见者。但能三业精进成机亦离众苦。悉得名化。此皆真身益物相也

问。同缘曰应。欻有名化。此二种身皆非智德。今何以化而为真身

答。欻有之化即化现化也。今对像论化取化转化也。所以者何。上言于像则应化皆像。自实报下至地狱身。皆已摄尽。若欲化转凡贤入圣。须示真智。若非真身不能化转。言化无所化者。据性平等忘于化功。虽令九道皆趣涅槃。而无众生得灭度者。平等真法界佛不度众生。终日化物终日无化。二虽像下明用忘故。二益周遍二。初显益周。色心诸法虽无生性。因缘和合法尔而生。观音妙证同诸法性。虽无形相。众机扣之。无像不现。此由绝于垂应之念。故能遍应法界群机。其犹明鉴无念而现。故云无所而不像。二化无下冥益遍。以上虽字贯此句初。虽中实性不可变化。不变而变迷悟宛然。观音顺理虽知不变。常以真智化一切凡成不二圣。此则由无化物之念故。遍令他革迷成悟。其犹磁石无念而吸。故云无所而不化三故无下遮照相即。结二身德相二。初应身相。中道法界双遮二边故无所在。当体双照故无不在。化应九道之身者。此中云化作欻有释。并应成二。显益相足也

问。经云应以佛身得度即现佛身。今那云九

答。佛界身者有通有局。局在妙觉智相之身。三千实相以究尽故。尚非等觉心眼观见。况乎下地及凡小耶。通则三教果头之相。及以圆教凡圣所见。虽分粗妙皆名佛身。然是随机应现之相。是其事识或是业识之所见。故虽是佛身而通二乘菩萨界摄。经文从通故云现十。今文从局故云九道。二处有下真身得。通以九界名之为有。以其皆有业报故也。应身虽乃处在其中。而其真智自冥极理。故云寂入不二之旨。前即真身而垂应相。此即应相而示真身。二是以下明两用摄生。上明真应两用既然。今示与拔摄生之相。初二句明真身拔苦。次二句示应身与乐。佛答前问。三业显机感乎冥应。七难二求及以三毒尽诸苦际。故云蒙脱苦崖。佛答后问三业显应赴其冥机。三土众生十重获益。终归秘藏。故云使沾上乐。然其四誓非专与乐。虽在此明实通上句。以上三业即能感之因。此明四誓是能应之本。上下互显彼此无亏。应知三业亦通冥机。现在虽无宿生须具。二故娑下兼明本迹二。初示诸名二。初今昔因。名今堪忍土称无畏者。此经两出。怨贼难中一人唱言。诸善男子勿得恐怖。汝等应当一心称观世音名号。是菩萨能以无畏施于众生。乃至云。称其名故即得解脱。又劝供养中佛自叹云。是观世音菩萨摩诃萨。于怖畏急难之中。能施无畏。是故此娑婆世界皆号之。为施无畏者。宝藏等者。悲华经云过去散提岚界善持劫中。时有佛出名曰宝藏。有转轮王名无量净。第一太子三月供佛及比丘僧。发菩提心。若有众生受三途等一切苦恼。若能念我称我名字。为我天耳天眼闻见。不免苦者我终不成无上菩提。宝藏佛云。汝观一切众生欲断众苦。故今字汝为观世音。二已成下过未果号。已成等者。千手眼大悲经云。此菩萨不可思议威神之力。已于过去无量劫中。已作佛竟。号正法明如来。大悲愿力安乐众生故。现作菩萨。又观音三昧经云。先已成佛号正法明如来。释迦为彼佛作苦行弟子。次当等者。观音授记经云。观世音菩萨次阿弥陀后。当成正觉。名普光功德山王如来。补处者。犹储君之义也。二其本下结难测。如上经说。或已成如来或现为菩萨。往世正法曾作释迦之师。今曰观音仍补弥陀之处。亦如妙德元是能仁九代祖师。孙已果圆祖犹因位。本迹高下安可测量。然须用其高下四句。以显诸圣难思之相。二今言下叙人法标题二。初叙人兼经字二。初叙人二。初对梵翻名。诸神咒经先称梵名。今文稍略。而其华语名多互出。此云观世音。余云观自在。唯千手眼大悲经中云。观世音自在菩萨。其义似足。然约境智而明感应。则今三字诠显无亏。若依今解已彰自住。二能所下约华释义二。初别释二。初释二。初释观字二。初中边妙达。能所圆融中智也。有无兼畅二智也。只于一心双遮双照。于照中时即达二谛。故云兼畅。是则十界言音即起即观常遮常照。二照穷下修性俱明。照穷正性见性德也。察其本末见修德也。此约妙境显其妙智。本具三千虽即三谛。对修故合但云正性。修中缘了各有本末。合掌低头缘之本也。福德庄严缘之末也。一句一偈了之本也。智慧庄严了之末也。顺修既尔逆修亦然。造恶之时慧数诸数。岂非其本。受苦之时习果报果即是其末。若以修性论其本末义复臻极。性德三千语本方尽。修起三千论末乃穷。非上三智莫照斯境。非此妙境莫发其智。函盖水乳聊可方之。二释世音。即十界众生遭苦求救。称名等音也。是所观境者。上之境智皆是能观可譬槌砧。此之世音可譬淳朴。非前境智观此世音。焉令十界俱脱三障。又复应知前之境智。即是菩萨难思体用。即能应也。世音之境乃是众生由苦成机。即能感也。此即境智及以感应。三字之中悉得成就。万像等释世。类音殊唱带世释音。俱蒙离苦致感获益。二菩萨下结。可见。二此即下总示。观等三字境智也。能所者感应也。能即能应所即所应。岂可重云能照所照。二叙经。此品既已别行于世。本多题云观世音经。或云观世音菩萨普门品经。故今叙人名后略释经字。言由义者。净名玄义云。经由圣人心口故称为经。悉檀致教。经由如来心口。故名经也。又云。前圣后圣莫不经此悉檀所说之教。而得成道。文理等者。取经纬义法喻参明。文经理纬互相表发。织成行者观智之心也二普门下叙法兼品二。初叙法二。初消二字。二用一下示十普。实相者。三千皆实相相圆融。而言一者。不二义也。万德总称一乘异名。下文十义以示其相。一无缘慈悲。二无作弘誓。三圆修之行。四不断之断。五圆入法门。六无记神通。七体内方便。八施开说法。九普供诸佛。十普益众生。从愿立行自因之果。全体起用上供下益。原始要终摄诸法尽。十皆实相互通遍摄无所障碍。二叙品。虽顺别行立乎经目。然是法华流通一品。故今叙之不忘本也。中阿含云。跋渠此翻为品。取义类同者集为一章也。二大部下释正文二。初例大部。妙玄五章解释甚委。经之一品妙义岂殊。彼但正明五字通目。今之所释一品别题。况复抗行。故须自立五义分别。虽复自立还须符彼开权显实圆妙之文。故释名则纯妙人法。显体则不二理智。明宗则难思感应。论用则无缘与拔。判教则终极醍醐。此之五章名总三别教判总别(云云)。二释名下释今文五。初释名四。初列章。二通者下示相。三何故下对根。通既是略一往对利。别解则广一往对钝。若其二往须明二持。闻持则以广说为利。义持则以略说为利。钝可意得。槃特名钝是就闻也。目连称钝盖约义也。今之二释对乎两根。须约闻义互论利钝。四今就下正释二。初通释二。初标列二。一列下正释四。初列名三。初略标示。二立名意二。初明理超名数。大师虽用十种义门通释题目。而深体达观音至人。普门妙法。本离言说心缘之相。故云至理清净等也。故起信云。一切言说假名无实。但随妄念。不可得故。二但妙下名数显理二。初约义示。上言至理清净无名相等。盖约自证绝乎言思也。今云妙理虚通假名相说。乃据被物设教而谈也。言虚通者。此明妙理无坚住性。虽无名数而能遍应一切名数。故荆溪云。性本无名具足诸名。故无说而说说即成教。是则离言依言皆顺至理。圣默圣。说俱有大益。故起信

问曰。若一切法不可说不可念者。诸众生等云何随顺而能得入

答曰。若知一切法虽说无有能说可说。虽念亦无能念可念。是名随顺。若离于念名为得入。今亦如是。以十种义无说而说。意令学者无念而念。二故大下引文证。般若无相即是一法。悉檀为物立种种名。三今处下正列名二。初明中当。今立十义离于太广及以太略。广则令智退。略则义不周。我今处中说令义易明了。二十义下正标列二。第二下次第三。初标示两意二。初正标示。约观约教各有生起次第不乱。二约观下明总该。若观若教能总能该。观总三心。人法慈悲初心也。福慧中心。真应至八皆在后心。缘了极性示因方圆。智断究尽明果方满。教约五时无不该括。华严顿也。三时渐也。复于渐中三藏唯小二酥部大。若论法华出前四味。以非兼但对带故也。已备诸说故今略之。二约观下解释两意二。初观次第十。初人法二。初能冠九双。慈悲等九皆以人法而为所依。是故品题特标此二。故以凡夫假实为譬。先有揽阴所成众生。方可论其种种德行。人法冠九义岂不然。二人法下当科次第二。初疑。何意乘以人法为次者。法是所乘人是能乘。理合先说本性所乘。方论始觉能乘。今何反此。二此须下释。能乘所乘先后无在。今有二意。先人次法。一据经文。二从义便。人能秉法即其义也。二慈悲二。初十中次第。二二法前后。下去诸科例有此二。次于人法论慈悲者。大士既观本性普门之法。乃达生佛无差之理。而闵迷者枉受众苦。失于本乐。故起誓愿永期与拔。观境发心正当其次。先慈次悲者。文有四释。今从语便及以本怀。不从用次及以行人。故结示云今从前义。三福慧中。人法据信者。愿行之前人观圆法止且成信。依乎忍乐立其四弘。若匪行山莫填愿海。行即福慧义当六度。五资于慧慧导于五。其犹目足不可互阙。五除事障慧消理惑。此二功圆则悟理得事矣。是知福慧成前慈悲之心。起后与拔之用。先福次慧亦从语便不据本怀。若论资导复何先后。四真应者。信愿福慧皆在于因。因能克果故成真应。福资于慧显出真身。慧导于福显出应用。真应次者。若就渐化先示应身接其小器。后令入实方示真身。亦可先顿次渐。则真前应后。今不从设化但就真显应起。而立其次。故云从前亦是语便。五药珠者。福慧二行显发真应。故云直语证得未涉利人。今明药珠则示两身益物相也。真身冥理见则三惑皆消。即差病益也。应身赴物感则众善普会。即雨宝益也。言真破取相者。既以三智冥理为真。岂但能破见思取相。应知见思取生死相。尘沙取涅槃相。无明取二边相。若次不次俱有其义。药珠次中与慈悲相似者。药即同悲珠可类慈。彼有四义定乎先后。言说本怀即先慈次悲。从用就机则先拔后与。今之次第似彼后二。六冥显者。前明二身破惑如药对机如珠。机既破惑则显见真身。故云二身即能显益。今辩二身常普被物。有见知者俱名显益。不见知者称为冥益。如是说者。方尽圣人益物之相。二益先后不可定判。亦从语便故云冥显。此既易解故不言也。七权实中。前缘不同者。盖所被之机根性差别也。权巧无方者。即能鉴之智无定方所也。或冥或显破恶生善。深浅不同广狭有异。皆由二智逗会无差。故于益后须论权实。二智前后虽有三义。且据浅深为次。八本迹中。巧有优降者。谓智有高下也。上中下者。以妙觉为上。等觉为中。降此为下。前权实鉴机必须双用。故云横也。今本迹约位既论高下。人必从本方乃垂迹。故云竖也。二法前后可见九缘了二。初指前顺论自他。如上八双从微至着。皆是顺论仍未分配。今挹流寻源。须明性德而为诸法生起之本。二明今却讨种子。则逆推真身智慧悲誓观智之人。元以性德了因为种。若应身福德慈誓普门之法。元以性德缘因为种。自行既然以例化他。本证实智冥益药王属乎了种。迹化权智显益珠王功归缘种。乃以顺论却讨为次。十次缘了论智断者。前既逆推尽乎因德之始。今更顺说至于果德之终。即以始终而为其次。过茶无字故十后不论矣。二二约下明教次第二。初牒章立门。二通义下依门释义二。初通者。五时四教各可论十。随法义立不可深穷。且如三藏立十双者。人法则揽阴成人谛缘度法。慈悲则声闻法缘菩萨生缘。福慧则声闻三学菩萨六度。真应则五分法身作意通应。药珠则治四住病雨三乘宝。冥显则众生获益有见闻不见闻。权实则称真之实随情之权。本迹则自证之本示现为迹。缘了则一句了因微善缘种。智断则声闻四果菩萨顿成三藏尚备通别可知。二别今下别二。初五味二。初释五。初乳二。初明具前六义。乳即部顿故指华严。六字别题具法人喻。大方广法也。佛是舍那果人也。华严喻诸地因华严果德也。只就一题已含六义。以慈悲乃至真应不出自行因果。药珠冥显只是化他能所。即就中道别论六义也。二而未下明阙后四义二。初明通别二。初明无别。二通义下许有通。若以别圆对权实体用论本迹。微因之约了。大觉之智断。亦有理存焉。二何故下明阙具二。初缘化始明阙。权实等四说出世意。示久远成。却讨三因终归秘藏。初成设教别接大机。既匪终穷故阙斯意。二所以下对具明阙二。初对法华言小隔于大者。旧经三十七云。时舍利弗祇园林出。不见如来自在庄严变化。及生意念亦不乐说。不能赞叹。以声闻人出三界故。此即如聋如哑之文也。以未说为实施权开权显实故也。言无本迹者。华严初云。于菩提道场始成正觉。今法华云。一切世间天人阿修罗皆谓今释迦牟尼佛出释氏宫。去伽耶城不远坐于道场得三菩提。然我实成佛已来无量无边百千万亿那由他劫。斯是华严被废之文也。言弹指謦欬者。如神力品。释迦牟尼与分身诸佛出广长舌相。上至梵世。一切毛孔放无量光。皆悉遍照十方世界。满百千岁然后还摄舌相。一时謦欬俱共弹指。是二音声遍至十方诸佛世界。地皆六种震动。乃至佛告地涌诸菩萨。汝等于如来灭后。应一心受持读诵解说书写如说修行等。此乃本门为嘱累地涌菩萨通经。现斯神力也。疏云。謦欬者。通畅之相。弹指者。随喜也。盖表如来远本之意。已获通畅。随喜菩萨闻于远本。增道损生也。二言无下对涅槃。言不明小乘根性等者。不如涅槃明二乘之人及一切众生皆有佛性。悉当作佛。故阙后二双。二次约下酪二。初太师明阙具二。初正明阙具。二何故下明阙具所以。言二乘教者。以三藏菩萨果同二乘。如大论中通指阿含为声闻经耳。此教不谈妙有之真。故身智灭不能起应。既无真应岂有药珠等邪。二私难下章安私料简二。初正料简二。初难者。恐人不了大师立今通别之义。故设兹难作说示之由。乃约真中设通别难。由此二是通别理故。二私答下释者。不以真谛通对中道别。盖约三乘通对菩萨别。若三藏三乘从因至果。可就真谛通论十义。今释观音须在因位此教菩萨因中唯有求佛人法。四誓慈悲。六度福慧。伏惑未断。故不得论真应等七。岂唯无于中道之七。亦乃未有真谛之七。二师云下指师意。只齐三藏别论菩萨。前之三义异于二乘。不就中道别论三义。三生酥。部虽四教。今对偏小明圆中道人法等六。未开权迹及却讨等。故无别四。四熟酥。虽会小法。未开小人。同前二部但明六意。五若约下醍醐二。初法华二。初明部彰八意。六虽同前不无小异。前是隔偏之圆。此乃开粗之妙。故人理教行咸会一乘。权实本迹唯彰此典。若约自他及以偏圆论权实者。前部非无。今所论者为实施权开权显实。会权归实废权立实。此之权实余部永无。若理事理教教行体用四重本迹不独今经。诸部容有。若尘点劫前最初成佛而为实本。中间今日示现成佛皆为权迹。此名权实本迹。本门开竟。此身即本。迹门已说及诸部谈。皆名为迹。是名今已本迹。此之二重诸经绝议。故云诸教不明法华方说。二三世下明化满一期。方便品中五佛章内。皆先施方便后显种智。方便即四时三教。种智是法华一乘。是知诸佛化终此典。灯明迦叶出于净土。故至法华即入灭度。今佛释迦现于秽土。故说涅槃以为赎命。二若约下涅槃二。初明摄机罄尽。渐化已来法华入者。望前已钝。复有未入待至涅槃法华犹利。然法华破大阵涅槃收残党。法华为刈获涅槃是捃拾。大化之功在乎灵鹫。余机未尽故至双林。极钝既昧法华八义。须为此人委明佛性。一代之机终穷于此。二若论下明示法无遗。涅槃既摄钝机。故始穷本性终显极果。十义整足。故以性三起于修三。既修性各三则因果不二。双非缘了。即是中道正因之体。而此正体必具双照之德。故至修成三点法身也。例知缘了亦各具三修德。须云三点般若三点解脱等也。当知今文为顺经题人法二义。故立十门始终皆二。二即不二中在其中。数有亏盈法无增减。故止观云。首楞严偏举一法。具一切法亦不减少。名秘密藏。乃至涅槃三法具足法亦不多。亦名秘密藏。盖诸经赴缘不同故也。二此历下结中。云此历五味论十法次第者

问。前约观明十法。自行化他原始要终。实成次第生起不乱。今历五味。但明诸部具法多少。何名次第生起邪

答。前约观中正论修证次第。今约教中乃论用与次第。明其十法随于部味次第被机。前之四味但三但六。后至醍醐具八具十。岂非用与次第邪。应知前明诸教观法次第。今明观法随教次第。虽乃约修约用不同。而皆得名十法次第也。二约四下四教者。通论则随真随中各有十双。若别论者。三藏别就菩萨。唯有人法慈悲福慧三双。以未断惑故无真应等义。具如前说。例此通教亦就菩萨。而可别论真谛六双。以第七地去誓扶余习。神通托生双流化物。得有真应药珠冥显之义。二乘无此。故名为别。若其别教行虽次第。而可就中明乎六义。凡三圣三其相可见。法华前圆亦只有六。涅槃四教皆知十双。然约重施不无进不。前历五味已含教义。故云可解。三故知下结叹两意二。初结叹。观论此十则因有愿行果有力能。教论此十则论法有始终。被机尽利钝。故禀教修观者何莫由斯道也。商略犹较量也。以此十义较量一代教观。摄无不尽。该修德之极故云意气宏远。彻性德之本故云义味深邃。又横收四教故云宏远。竖摄五味故云深邃。人法至真应自行之前后。药珠至本迹化他之前后。缘了与智断修性之前后。三义为粗六义为细。乃至八义犹粗十义最细。此就略广以辩粗细。若以粗妙释粗细者。诸味纯杂可以意得。二问法下料简

问。意者。法华之前别论华严方等般若同有六义。有异意否。虽问三味六意同异

答。中委出酪味中三及醍醐八。以五味中根有利钝。利人部部得入醍醐。钝者随味次第转改。故华严六义。高山王机即入地住。穷子迷闷见思全在。三藏但小故无显露得大益者。若八万诸天获无生忍。故云密去。二乘之人方破见思。故但成酪。方等中六有褒有贬。利者。闻褒即得圆益。小人被贬冥入通门。般若中六意在淘汰。利闻圆空得不共益。声闻转教密破尘沙。法华八意调机已熟。开彼权门即示实理。复废近迹令见本身。钝人皆得一乘利者复增圣道。涅槃同味故略不言。但为捃拾具说十双。于极钝根亦获常益。故知四味虽谈圆顿机悟浅深。至第五时益无差降。不禀山门焉知一化机教之相。第三解释三。初略标。二人即下广释十。初人法三。初立所言入者。阴中主宰也。略论四名。所谓我人众生寿者。具论十六。即于四上加其十二。谓命者生者养育者众数作者使作者起者使起者受者使受者知者见者。言假名者。自无实体。但藉五阴和合而成。如揽五指假名为拳。是则拳由指得指非拳成。拳如于人指如于法。能成是实所成是假。此之假实就大小教辩常无常。小明人法终归无常。大说假实究竟常住如藏通教。始从凡地至有余涅槃。皆有假实。若入无余身智既忘。假人安寄。若别圆教三惑二死尽净之时。人之与法常住自在。假人是尊极众生实法名常住五阴。以要言之。若云惑尽人法永无。斯是小乘亦称权教。若言惑尽人法不灭。斯是大乘亦称实教。凡言别圆初后知常。盖知人法不可灰断。藏通反是故曰不知。又复应知假人之号。多从依正实法而立。如世人称谓。或从形貌或从德业。即正报实法立名也。或从住处或从统摄。即依报实法立名也。今观世音为假名者。观是观智世音是境。此是自他正报岂非实法。但以名为观世音菩萨。故判属人。普门既是此人所乘。故判属法。若云普门法王子观世音者。即须却判普门属人观音属法。盖由今品以观智目人。是故释义皆用智慧而对人也。须知观智体是实法。既以观智目人。则九双中悲慧真药冥实本了智皆是实法。目其假人。于今知已。释下诸文则皆可见。二此之下释二。初总示二。初示通凡圣。虽漏无漏偏圆因果优劣不同。而其假实终无暂阙。二若色下各明假实二。初凡。庸常曰凡弊恶曰鄙。即六道五阴唯成分段生死人也。二戒定下圣二。初示相。既革凡成圣即转五阴而为五分。三乘四教虽权实异。皆能转阴而为法身。随位揽法成其假人。二故大下引证。妙觉极位人法二执究竟尽处。假名一千皆成四德。名无上众生。依阴二千一一四德。名无上实法。故偏小及圆因位。无非本性无上人法。但二执未尽。而其修得不名无上耳。二虽通下委释二。初凡。善恶为因人法是果。各论三品此约总示。其中别业交互感果非算数可及二圣人下圣。性德人法何尝改变。但以随机教门示观。致有小大共不共异。故于圣中分别其相。初小三。初就有门释。即毗昙中人法观也。言人空法不空者。非全不破实法。盖此门观行。破假人时未破五阴。且云不空。以此二空前后观故。而前后相两途不同。若观假人如兔角等。惑落见谛即于修道观阴无常。破彼思惑。若其人执虽被穷逐。见惑不破而更度入实法之中于阴生见。即须观阴无常无我。破此见惑。故法空观能破二惑。乃于节节各有人法。若见惑未伏即有漏人法。其能伏者即方便人法。发真断结及生有余。皆无漏人法。然小教中不说生处。今约跨节故生界外。如大论云。出三界外有净国土。声闻缘觉出生其中。以大乘说身智不灭。无漏业牵生彼五阴。二若空下就空门释。即成实中二空观也。揽阴成人不同有门阴中求我。三假浮虚且异实法生灭。人既揽阴而有观乃即法观人。从始至终假实双破。言三假者。谓因成相续相待。名不殊大义归小乘。大观三假。生即不生亦复无灭。今观三假因缘和合体性不坚。大若空华此如云霭。由此观故会入真空平等之道。三余两下例二门释。亦有亦空门即昆勒论之所申也。非有非空门未见论来。有人言。犊子阿毗昙申此门意。未可定用。然假人不有四门是同。唯论实法四相有异。若毗昙明析色存于邻虚。成实析色破于邻虚。昆勒说色亦有亦无。第四门意例应双遣。然此四门诠法虽殊。谛理是一。若不得意四门成诤。故大论云。若不得般若方便。入阿毗昙即堕有中。入空门即堕无中。又大师云。数存邻虚论破邻虚。此与邪无相滥等。若得意者。色若粗若细总而观之无常无我。破于见爱得入空平。双亦双非语似中道。理只在空。但能从容会入空理。节节人法例前可知。二摩诃下衍三。初明体空通三教。不言人法空不空者。异彼毗昙观人空时。未破实法。不言体有假用者。异彼成实揽实法体成假人用。但观人法本自不生今亦无灭。色是五阴之首我是十六之初。故各举一以例其余人法即空故曰如也。观此二空始因终果。若人若法不生不灭名为涅槃。常修此观以行正道。应知大品谈空义含深浅何者。若钝根者谓但空有。即入偏空证其通理。若利根人一闻于空知空二边。名见中空属后二教。又此中空复分二种。离边而解此当别理。即边而解乃属圆理。如来巧智善谈于空。能被三根断证不等。又复应知彼经空义虽通三教。今之人法非前二种。唯用最后即边之空。净其二执成圆假实。若不尔者非今人法。二以观下明缘了通别圆者。前明二空未明缘了。意虽在圆通人有分。今约二空明二佛性。故在圆别不涉通门。今文既以观人法空。明二因种。一言于空须分二种。若毕竟空观于人法显圆二因若次第空观于人法。即别二因。文以无上人法为缘了种。亦须善别。百界假实为佛涅槃斯为圆观。若唯佛界故属别也。文意在圆别人有分。释此为二。初了因中。以观人空即了因种者。大乘空观荡情显德。今经既以智慧目人。故人执空则智人显。况观本空乃显本智。本智即是性德了因。故引论文果佛为证。则因果不二修性一如。故知今文正明圆观。言始觉人空终觉法空者。人是觉智。不独自空人执。复能空于法执。虽云始终非次第观。此由大乘观性相二空。破生法二执。显真俗二谛。观虽不次说有始终故也。如大本疏云。真谛即法空俗谛即生空。俗假真实。辅行云。若有性执世而非谛。破性执己乃名世谛。故云世谛破性。性执破己但有名字。名之为假假即是相。为空相故观于法性。观理证真名真谛破相。空非前后二谛同时。为辩性相前后说耳思之思之。不见此意徒谓即空(上皆补行)此明觉智一念之中。空人法执有始终义。勿迷此语定判属别。说时非行时斯之谓也。二缘因中。观法空即缘因种者。由觉智故法执既亡五阴清净。乃以净阴而为缘因。况了本空乃阴本净。本净之阴名性缘种。故引大论大经极果法空。及大品真因法空。以显缘因相。当知真因极果既十界圆融。则百界五阴皆无上之法。揽此等法称之为佛。若以三千言之。则众生一千皆佛之假名。阴土二千皆佛之实法。故荆溪云。三千果成咸称常乐。又云。一佛成道法界无非此佛之依正。修德既尔性德本然

问。文中缘了并云种者。其义何邪

答。夫言种者。凡有二义。一敌对论种。如三道是三德种。二类例论种。如缘了是智断种。性德法身为修德法身种。此二皆取能生之义也。若以二空为种即类例义。若以二执为种即敌对义。今文既云观人法空即缘了种。是类非对。若就觉智观于二空。为二因种。则取修二类于果二。若就性德本自二空为二因种。则取理净类于己净。故圆论性种有对有类。别无对种学者审思。圆教反是。学者思之。三以观下明即离唯圆顿二。初约六法示三因二。初引经标即离众生佛性者。性德三因也。六法者。五阴神我也。斯盖本觉常寂常照常非寂照。寂是缘因。照是了因。双非是正因。此三于六不即不离。乃不思议不生不灭之六法也。立门既妙。故别初心不能造趣。二不即下据理明即离。正因不即者。正非寂照故不即一切。迷时不即我阴人法。解时不即修中缘了。良以始终无变改故也。缘了不离者性德二因既当而寂而照。寂是百界实法照是百界假人。此之假实能迷能解。迷故举体而为一界假实。即非局而局。是故二因不离六法。若即迷成解转成修中缘了。破于二执显本寂照百界假实。名为二空。即非遍而遍。故云不离众生空而有了因。不离阴空而有缘因。结云不离六法者。不动我阴而成二空故也。只一觉性具三种德。名为三因即三而一即一而三。非一非异不纵不横。欲彰秘藏绝乎思说。故对六法言非即离。人见文中正因不即缘了不离。不达妙旨分对而已应。知一王一数一根一境。随迷随解从因至果。但趣举一皆名佛性。不可谓是不可谓非。故云不即六法不离六法。亦名一念即空假中。中故不即空假故不离。义非异途。故此观唯属圆教。二佛从下约三性明分证。言佛从者。欲对观音明分满故。佛于三性六即究满。良由初心能以三观观于六法。应知三性即是性中三德三观。初发心时须于性三起于修三。六位虽殊三性无别。是则六即皆是无上人法。故下结云。二番问答是分释无上人法也。三前一下结文有二。初结指经文。二当知下结归题目可见。二慈悲三。初标示。二菩萨下解释二。初约四誓论功二。初明须誓三。初须誓意。所言慈悲弘誓者。简于凡小无誓慈悲。显今菩萨有誓慈悲。二譬如下举喻显。慈悲摄生如节廨合。无誓胶漆拔与不长。三誓愿下牒喻结。二悲心下示运心二。初二誓明悲。今既通示世间之言兼两三界。后出世间亦当例此。二以慈下二誓明慈。前拔苦中果重因轻。故先拔重。今与乐中因显果密。故先与显。斯是菩萨利物之心。则与声闻知苦断集慕果修因不同故也。若璎珞中明四誓云。未度苦谛令度苦谛。未解集谛令解集谛。未安道谛令安道谛。未得灭谛令得灭谛。彼经所立四皆利他。今文所列三通自行。应知语有自他意必双具。二但前下约四教辩相。以其立誓须依四谛。若不依谛名为狂愿。何者。四既称谛。则能审实迷解之相苦乐之际。依此起誓方有拔苦与乐之理。傥于法不谛。徒兴与拔之心。终成狂简之愿。此有二。初例前科。二若三下明四教依谛立誓。须知权实各有事理。故以四教明乎谛相生灭无生无量无作。皆明菩萨依之起誓。初三藏。此教为于迷真重人。说世出世二因二果。不即真理故互生灭。菩萨观此兴有作誓。有生可度有惑可断。有法可知有佛可成。四皆有作谛使然也

问。三藏所谈灭非真谛。今文依灭起第四誓。那云真谛无为理邪

答。灭谛之体是二涅槃。虽非真谛能冥于理。故云因灭会真。道是灭因苦集违理。佛既契真。故成佛誓观真而发。二复次下通教。所拔所与二因二果大同前教。但以此教所被之机迷真轻故。事皆即理。四并如幻不生不灭。所谓苦无逼迫相。集无和合相。道不二相。灭无灭相。观此四谛而起四誓。谛既如空誓亦如幻。言若有一法过涅槃等者。大论第五十先引经云。诸天子心念。应何等人听须菩提所说。须菩提知诸天子心念语言。如幻人听法无听无闻无知无证。乃至云。佛亦如幻化涅槃法亦如幻化。论释云。一切众生中佛第一。一切法中涅槃第一。闻是二事如幻。惊疑谓。须菩提错说为听者误。是故更问须菩提。须菩提言。以二法皆从妄法生故。法属因缘无有定实。须菩提作是念。假令有法过胜涅槃。能令如幻何况涅槃。三别教。此教为迷中重者。虽谈无作果不通因。故初发心但依无量。所诠森罗万像之法。皆为迷于如来藏性而起。然此藏性虽不具九。而能随缘变造诸法。性随染缘则起世间无量苦集。性随净缘则起出世无量道灭。故妙玄明别教如来藏者。名为妙有。为一切法而作依持。从是妙有出生诸法等。但由苦集定能为障。故须别缘道灭对而翻之。先以生灭四谛伏于通惑。次以无生四谛断于见爱。中以无量四谛破于尘沙。后以无作四谛断于无明。此四四谛在于别教。皆名无量。故云缘界内外苦集因果无量四谛而起愿也。所以然者。盖知一切迷解之本。皆是佛性。性无量故谛称无量。前教不尔故不受名。圆教虽有无量之义。三皆即实故云无作。四圆教二。初示四誓二。初明誓相。法界者。即十法界也。圆融者。总论百界别语三千。既生佛依正互具互遍。故曰圆融。非违等者。以性夺修千法皆性何修不泯。破戒比丘不入地狱。清净行者不入涅槃。岂唯地狱涅槃即性。抑亦破戒净行非修。非违非顺泯苦灭也。非暗非明泯集道也。无明暗故则违等者。上示全修即性是故俱非。今论全性起修。是故俱立。荆溪云。性无所移修常宛尔。既观不违而违。故起悲愿拔其二苦。既观非顺而顺。故起慈愿与其二乐。由知法界圆融。故非违顺亦由法界圆融。故有违顺。有违顺故起誓。非违顺故无缘。二譬如下明无缘二。初喻。不得前意此喻莫销。二今此下法。正以三慈分缘无缘。若依生法则缘有空。心若即中方绝缘念。以绝念故。乃能周遍法界任运与拔。大经十四梵行品初云。慈有三种。一缘众生。二缘于法。三者无缘。众生缘者。缘一切众生如父母亲想。法缘者。见一切法皆从缘生。无缘者。不住法相及众生相。大论二十亦云。慈有三种。众生缘者。谓缘十方无量怨亲中人。法缘者谓缘无漏罗汉支佛诸佛圣人。破吾我相。但观四缘空五众法。无缘者。不住有无。唯诸佛有。此与涅槃文意大同。又大论第五明悲亦有众生等三。故知将三慈悲以对三谛。义甚显了。今从胜说但云无缘。若得无缘必具生法。二菩萨下明六即。皆由理具方有事用。今全理慈起修德五。而观世音未臻究竟犹处分真。欲令众生知理慈悲修成五即。故兴两问以生二答。槌砧相扣器诸淳朴。三若前下结归二。初结指经文。二故知下结归题目可解

观音玄义记卷第一观音玄义记卷第二

        宋四明沙门知礼述

三福慧三。初标示异名。福中之胜不过于定。举胜摄劣。则五度备矣。二定名下依名释义二。初明二法功能四。初定慧之功。静爱观策者。由寂静故能爱摄诸行。由观照故能策进诸行。爱而不策则生凝滞之心。策而不爱则成散越之慧。爱策具足方有趣果之功。二寂照下福智之德。寂照之智者。即权实二智也无幽不朗者。即无三惑之暗也。福德禅定必含诸度及大小诸禅。以福资智如油助灯也。三亦称下目足之称。清凉池即涅槃者。涅槃必须三德具足。极在妙觉。分通初住。四涅槃下庄严之名。二严属修法身是性。性有阙具。故使二修有真缘之异。如下所辩。二释此下约四教解释二。初明四教。三藏菩萨虽云观理。伏而未断。且举诸禅实兼余度。发真必在三十四心。若通菩萨体法巧慧理度助之。因即发真至佛方竟。别人虽信能造之心即是佛性。性不具九为惑所覆。故须别缘真中二理。破通别惑。是故名为缘修智慧。乃以俗谛诸禅三昧助显法身。圆谈性恶。了惑实相即为能观。名实相观。定亦如是名实相定。复以实相名所显身。即一而三名定慧身。即三而一同名实相。若昧性恶何预初心。二今圆下示圆六即如文。三观音下结指经题二。初指经文。言智光照苦者。经无此文。而有其义。无量众生遭苦称名。菩萨即时观其音声皆得解脱观是智照照即光也。观音妙智即是众生三道之体。众生迷故颠倒乃生。观音照之解脱斯在。频引三经放光文者。若非色者。安得云放。若定是色那名智慧。故知色心其体不二。色性即智智性即色。岂惟光然。一切色然。普现色身义准可识。又岂独果事实存因理。良由理具方有事用。二良以下结归题目。四真应三。初标名示义。二身皆有集藏之义。真集一切。智慧藏于一心。应集一切神通藏于一色。色心不二通慧一如。唯色唯心斯之谓也。二若契下对拣是非二。初约法示三。初法实相之体即是法身。能契之智即自受用报。此二于今皆名真身。法报既冥则能称机。起胜劣等应。二譬如下喻。揽镜譬证真。即形譬起应。三此之下结。三千俱体为真。三千俱用为应。此之真应方不相离。无谋之说义显今宗。诸家所谈难逃作意。二若外下说人简二。初简小外。根本有漏禅境不明。纵少现通不能益物。此简非应。尚未下简非真也。若二乘等者。且举二乘。必兼两教及二菩萨。准妙玄意。藏通二教皆是作意神通。以须灰灭无常住本不能起应。若别接通别惑未断。亦不得应。纵令赴物皆名粗应若别初心亦不能应。初地初得三观现前。证二十五王三昧。法身清净无思无念。随机即对。是不思议妙应也。二大乘下示圆人二。初明二身。得实相真者。正语圆住义该别地。与真不殊者。名质为真。圣人应像同机体质。已证众生本觉之性。用机百界应百界机。体本不二安得少殊。二菩萨下示六即。三今经下结指经目二。初指经文。二良以下结题目。五药珠三。初标名示教。柰女经者。具云佛说柰女只域经。一卷。柰女即维耶离国梵志家柰树所生。颜色端正宣闻远国。因蓱沙王往娉。后生一男名曰只域。生时手把针筒药囊。至年八岁广通医术。遍行治病。后逢小儿担樵。只域视之。悉见此儿五脏肠胃。只域心念。本草经说有药王树。从外照内见人腹脏。此儿樵中得无有药王树邪。即往问儿。卖樵几钱。儿曰。十钱。便雇钱取樵。下樵置地闇冥不见腹中。只域思惟。不知束中何所为是药王。便解两束一一取之。以着小儿腹上。无所照见。辄复更取。如是尽两束樵。最后有一小枝。裁长尺余。试取以照具见腹内。只域大喜。知此小枝定是药王。悉还儿樵。儿既得钱樵又如故。欢喜而去。只域于国遍治病人。皆以药王照视。悉见病本。然后治之无不愈者。今取譬真身拔苦。如药王之治病也。珠是如意之宝者。如华严中得摩尼珠十种莹治。能雨众宝。今取譬应身与乐。如摩尼之雨宝也。二广历下约教辩能二。初略指三。随教浅深益物广狭。以明治病得宝之相。二今约下广明圆二。初释二身二。初药树身二。初喻。根深喻真妙。四布喻应广示理行果教。如根等次第。信行修四如闻获益。法行修四如触获益。二菩萨下法。今品初段专明拔苦。即是大悲熏于真身。与治病义齐也。形声利物且就通说。若据经文须在冥益。不以形声合前闻触。意亦在兹。二又如下珠王身二。初喻。如文。二菩萨下法。即以大慈熏于应身。普令得乐。与宝义同也

问。大悲熏真其相如何

答。真是妙智能破妄惑。悲名愍伤能拔他苦。同是法身一清净用耳。欲彰照理有利他益。故立拔苦之悲熏于破惑之智。即显有悲之智。普除众生妄惑之苦。例于大慈熏应与乐。同是法身一自在用。一用二能。故有能熏所熏之义。良由应身本是自行证得之法。以慈熏故。方遍益他。然则慈心非不熏真。悲心非不熏应。真身非不与乐。应身非不拔苦。欲令易解。是故经文寄两问答。分别说也。二此亦下辩六即。博地已具治病雨宝二种之理。与佛不殊。名字已上随浅随深。能治能雨。三就前下结指经目二。初指经文。二故知下结题目。六冥显三。初释名。二大圣下辩相二。初明二益三。初示相。大圣常以真智冥熏。妙色显被。无明隔故益而不知。二譬如下举譬。两曜喻二益。盲者喻无明。凡小全在下地分隔。眼膜既有厚薄之殊故。不见之相不可一揆。三故药下引证。三草二木而皆不知一地一雨。下不测上亦通圆人。故引妙德不知妙音。言以不知故名为冥益者。此明二身于不知者。皆称冥益。即彰真应于其知者。皆称显益。发智见理于真显益。见身不识但荷冥利。真冥应显可以意思。二此亦下明六即。理同极圣此则不论。名字即人所有智行兼他之益。彼七方便受而不知。况内外凡二益非薄。皆知即性故离我能。三若就下结指二。初指经文。前论真应各有冥显。斯为尽理。今以人法别对二益。且随文尔。二故知下结题目。七权实三。初释名。暂用则权宜。非暂则究竟。二略言下辩相二。初泛明三种二初总示三种。即唯自唯他及自他共。以诸经论所谈权实。其相不同。或言自行有权有实。或许化他有权有实。或经论说自行之法皆名为实。化他之法皆名为权。是故今家凡论权实。须明此三。若不然者。禀学之徒。则不尽知权实之相。于诸经论不免生疑。复应了知权实法相。或约理事或约理教。教行缚脱因果体用。渐顿开合通别悉檀。皆通自他及自他共。今以中观对于二观为权实者。似用因果而辩三番。自修三观为自行权实。若约化他但随他意。四悉适时不可定判。若第三番自行三观。有权有实。以顺智故只称为实。化他之法虽有权实。以顺情故唯称为权。二用此下遍历诸教二。初略指四教。随教浅深明理事等。约自约他及自他共。义皆不阙。二复就下明圆六即。六通三教即唯在圆。复就自行。明六权实从因至果。义便故也。二寻此下别用第三。前番问答有权实。七难二求在权。永离三毒是实。以由大士用于自行一心三观。观其音声令皆解脱。故都判为实。后番问答。十界身说显有权实。以是大士随差别机示种种应。故睹判为权。此乃判于自行化他。以为权实无第三番。如何分经两段而对权实。三前问下结归二。初结指经文。前后皆云自行化他者。简异单自行单化他权实。意云。前番是自他相对之实。后番是自他相对之权。二故知下结归题目。八本述三。初名义。净名玄义云。所言本迹者。本即所依之理。迹是能依之事。事理合明故称本迹。譬如人依住处。则有行往踪迹也。住处是所依。能依之人有行往之迹。由处有迹寻迹得处。当知若高若下实得皆本。若高若下应现皆迹。二若通下解释二。初通凡渐。世智高者诸有施作。但见踪迹莫知本意。二教贤圣至别似位。本所证得下位焉知。节节皆可通论本迹。二局圆圣二。初局分满二。初略示。的论其本。须破无明证法身体。所垂之迹或九界身或现八相。二若一下简判二。初简一往。二今细下取细明二。初约义明二。初明本迹通高下。若知四句释之方尽。一本下迹高。初住法身迹为八相。上位菩萨。八相元是妙觉威仪。故云迹高。二本高迹下。妙觉法身迹为下地及九界相。三俱高。妙觉法身迹为八相。四俱下。初住法身迹为九界。中四十位本迹高下。可以意知。二何以下明实得辩是非。二故寿下引文证。自意是本他意是迹。二就本下通六即。五位本迹理皆具足。三就前下结归二。初指经文。前以实本益他。后以垂迹益他。二故知下结题目。九缘了三初标示名义三。初示名义。此之名义修性皆然。二了者下辩流类。类至极果。节节名异其体不殊。三大论下引论释。缘了之相实同耘种。非此二力性田不丰。二通论下依教解释二。初诸教皆具。藏通义立全乖性种。别教虽有初心别修。唯有圆教修性不二。虽云皆具须辩此殊。二今正下克就圆论二。初克辩二因二。初明二种因果。此中二因且在修类。二原此下讨二种根本三。初总明性德。前之因果犹在修中。今穷其源性具缘了。净名云。一切众生本涅槃相不可复灭。本菩提相不可复得。起信论明真如二德。谓如实空如实不空。当宗明三千即空三千即假。皆是性德缘了文也。二大经下别引文释二。初证释了因。不明三千徒消一切。非空假中莫辩自空。如实空性与一切染本不相应。一切染者。不出三惑。自非本性即空假中。岂能不应一切染邪。乃毕竟空为了因性。亦用等者。全性起修方见本空。二又云下证释缘因。经云众生即菩提相及涅槃相。或谓理中独具佛德。今文众生有初地味禅及灭尽定岂非性具天法声闻法邪。既具此二。余诸法界那不具邪。又具二定者。从二习果及报果说。岂不各具性相等邪。不以理具而消此文。如何欲散便是灭定。性德缘因于兹验矣。三以此下依性立修。以此二种者。性种也。方便等者。智行也。毫末者。类种也。由斯性类。修成智行乃至二严。二此一下不论六即。此科正意但明理即非论五位。三前问下结指经题二。初指经文。明今二严必有其本。故从二种受名。二故知下结题目。十智断三。初略标二通途下广释二。初不二而二明智断二。初约通途明二德。言通途者。此解兼别。以有为无为对智断故。若唯圆说。苦集尚无作智德岂有为。然名虽借别其意唯在圆。以修妙三观得成圆断功。因时立此能至果须休息。故将无作行暂立有为名。断德称无为别从道后立。此犹教道设。是故曰通途。此文自二。初智德二。初列异名。圆净等者。智极故圆惑尽故净。不生不灭名为涅槃。二言有下释有为。智虽无作有断证功。故借别教立有为称。因虽无常等者。涅槃经中。因外道辈执因是常成无常果。佛用别教以无常因感常住果。而对破之。故因无常犹在别教。将因等者。由惑未断故起智照。一分惑灭一分智忘。故智无常。既有照用故名有为。果既惑尽称理常住。更无为作。将因名果故令智满受有为名。二断即下断德二。初列异名。解脱者。不系名解。自在为脱。在染不染名之解脱。方便等者。机生则生。是生不生。机灭则灭。是灭不灭。权示生灭不被染碍。故此涅槃名方便净。二言无下释断义二。初简小。不知三种世间常住。谓烦恼灭便无身心。安能自在名无体断。但于虚妄见思解脱。未得三千三谛自在。二大乘下明大二。初正示。妙觉三脱名有体断。所言断者。任运断也。已有智德了三惑空。故处九道恶自相离。众生之心如涂胶手捉物皆粘。诸佛之心如净洗手捉物不粘。已有智水洗其胶故。致令净用自然不着。此智断德说有次第。用无前后。以三千法究竟即空。名今智德。三千之法究竟即假。为今断德。三千之法究竟即中。是法身德。道前道后悉是一心。通教尚是双流。圆果岂当分隔。二故净下引证。证有体断。见受业报全体即是性恶法门。如富豪人七宝家业。凡夫生盲转动挂碍。为宝所伤。二乘热病见是鬼虎避走远去。圆人之眼不盲不病。明见是宝自在用与。非触不被损伤恐怖。而能以此自给惠他。于此证理名为自给。以此利物即是惠他。今之断德正在惠他。此等皆由体达修恶即是性恶。今明究竟体达位也。二寂而下约寂照简非德。常住寂照妙色妙心。方名智断庄严之相。小乘灰断身智俱忘。将何永度众生。将何常照寂理。二如此下二而不二明三德二。初约即三明理极二。初明二三不殊。而寂而照即是智断。非寂非照即是法身。二德既穷法身乃极。亦名究竟三种佛性。二法身下明因果无别二。初别示三法因果二。初法身隐显。法身一德体非因果。而有隐显者。斯由缘了逆顺故也。缘了逆性而成惑业。故使正因非隐而隐。名如来藏。缘了顺性而成智断。故使正因非显而显。名为法身。虽有隐显体无增减。故大经云非因非果。二又云下二德修性。是因非果复名佛性。佛是果称。岂非果法而为因种。是果非因复名佛性。性是因称。岂非因法而为果德。不以修性缘了销之。此文安解。二佛性下总示三法因果二。初约义示。前虽因果互是互非。而皆称佛性。验知缘了通因通果。又言。佛性非因非果。良以正因不即我阴。故曰非因。缘了不离我阴。故曰是因。不即故一点在上。不离故二点在下。是故性三不纵不横又正因不即智断。故曰非果。缘了不离智断故曰是果。不即故一点在上。不离故二点在下。是故果三不纵不横。故知妙三贯通因果。方得名修性不二。二故普下引文证不达妙三始终该亘。普贤观文如何可解。二智德下复就二符经文。若匪智德常照。何能即称即脱。若非断德遍调。安得身说普应三前问下结归二。初指经文。二故知下结题目。三问此下贴文为证二。初约无文立难。揽乎别文立其总目。释题十义名出余经。今经全无此文。何名揽别为总邪。二答大下约有义答通三。初明衍义众经共用二。初约法义明。大乘诸部皆谈中道。故使义门可以共用。二若不下以人师验。诸师说释诸大乘经显理则须论佛性。指惑则莫非五住。岂以当经无文为责。二此品下以二问答贴义无亏。十种别名文虽不列。以二问答总贴十义。明如目击。故曰宛然。三今已下别点句句。证十义二。初结前有义开后有文。前云在文无十名者。但无次第明示十名。若于品中散取诸句。则有文有义也。二如文下约句对义。自在之业即法身者。真应二身亦称色法。应则现色真则冥法。名从所契故曰法身。理具一切一一融通。最自在也。业是德业即智德也。真身契法名自在业巍巍是重明高累之貌。高明如是即满足也。此等理智相合。皆真身名义也。若运三业无显应者其福不失。须知密有与拔之功。即冥益也常舍行者。毕竟空智无所受着。故属智德。又以即观音声属智。皆得解脱为断此彰二德同时而用。应知句句证义不独示其十义有文。亦显十重二二互具。四料简二。初别料简十。初简人法二。初问。彼经具明十法王子。观世音法王子外。自有普门法王子。既以普门而名于人。今释普门那定属法。二答二。初立句二。初泛立四句。句虽有四义实唯二。不出相非及相即故。如此二义皆通大小。今意在大。而论小乘即离句者。欲示名言须将理定。所辩人法。若其不以二谛中道。甄其权实但言即离。何能的显今之相即。二若约下以部对句二。初明诸部人法即离四。初华严。彼经别教。缘实相法。修次第行。未能即以实相之法。为观行人。是故人法互不相即。圆观不次。即以实相为观行人。是故人法更互相即。别则证道方即。圆则始终不二。二三藏。此教有门。人如兔角故无。阴有生灭故实。此唯非句。空门两向。揽实为假假实不同。名互非句。既不相离复名互即。此教两门虽谈即离。人之与法俱非中道。三方等。四教并谈。藏通唯二谛。别圆同华严。四般若下例余。般若荡相钝谓但空。同前二谛。利分二种同前别圆涅槃四教虽俱知常。初心用观不无差别。藏通且须顺于二谛。别初心人未即圆法。二今方下明难属方等即句。二今明下通难三。初正约即句通难。今品前问答观音属人。能观所观岂非法邪。若后问答既以普门为所证法此法岂无能证人邪。方等既以普门目人。能目普门岂可非法。论其大意。观音普门皆中道法。随悉檀益将何目人。唯圆始终即揽实相。而为假人。二例如下傍取人物例显二。初以人显。二譬如下举物喻。三今普下以人法互具结示三。初明法具人。二若并下明人具法。三如身下以身为例。皆可见矣。二简慈悲二。初简慈悲名相三。初明与拔同异二。初与拔相兼问。苦除即乐。如夕尽即晓。乐至苦除。如灯来闇灭。趣举一种即有二能。何以慈悲而分两法。二答通下与拔不俱答。一能兼二。此就通论对境发心。实须别说。故举二喻以彰别相。二明喜舍阙具二。初问。二答二。初不二是舍。四无量心。舍无别体。奢摩他观体既是定。定能与乐毗婆舍那观体既是慧。慧能拔苦。二观不二即忧毕叉。亦名平等舍。故不二而二则立慈悲。二而不二即是于舍。今既明于不二慈悲。则已含舍故不别立。二喜者下苦在阙喜二。初约法释。今明慈悲是立誓愿。运慈与乐生既苦重。即须运悲。二俱未遂何喜之有。福慧满时药珠功毕。方与众生生乎庆喜。二如阿下引事例。阿输加王即育王弟。不归三宝见兄饭僧乃生嫌谤。育王见愍设计劝之。王入温室诈言已崩。策之绍位。方登御座育王出怒。其罪当死。乃令七日受王五欲。使旃陀罗逐日唱死。过已王问。受乐否邪。答言。我闻几日当死唯苦无乐。王言。沙门观念念灭。虽受供养宁有着心阿输知已。出家修道得阿罗汉。少痛夺乐近事可验。众生若此。故菩萨心未生喜也。三问禅下明支等前后二。初约前后问。今论四等慈悲喜舍。慈能与乐则乐前喜后。何故禅支喜前乐后。初禅五支。谓觉观喜乐一心。二禅四支。谓内净喜乐一心。三禅无喜。四禅无乐。今约初二。皆喜在前乐支在后。其意何邪。二答禅下约自他答。自证禅支从粗至细。前喜后乐。利他四等先与其乐。后方庆喜。故其次异。二复次下简与拔有无三。初外道虚想。四禅四空及四无量十二门禅。根本定也。通于内外小大圣贤。而修证之。若诸外道及正信凡夫修慈悲喜舍。自证此定。虚想众生离苦得乐。于他无益。自虽暂益不免退失。二若二下明二乘自利。二乘修此虽不益他。自拔分段得小涅槃。三今菩下明菩萨遍益二。初明行超凡圣。不同凡外随禅受生。异小圣贤但自拔苦。盖非生法二种缘慈。乃以无缘法界与拔。令诸众生离一切苦得究竟乐。二明同时与拔。无缘慈悲不二而二。用不异时。分别令解故各说耳。言前明拔苦等者。从本怀故先标于慈。若从用次先拔后与。是故四誓从用为次。三简福慧二。初定福智与拔所以二。初问。二答。因修福慧。至果则成智断二德。此德与生体性无二。故称观音智德人名。即能显召本性了种。是故能除暗惑苦也。若对普门断德应身。即能引起本性缘种。是故获于因果之乐。若不尔者。何名感应道交。二问福下辩福慧一异是非二。初约隔异难。备举相资难今隔异。二自有下约偏圆答二。初立即离四句。大小皆四故。知即离名同义异。二如六下通偏圆诸教二。初明三教即离俱非二。初明小衍二。初三藏。菩萨一位得两即句。罗汉白象得二离句。虽有即离同在三藏。二若大下大乘。约别地前论于四句。初以行行对于慧行而为福慧。不破无明故俱名福。即此二福能破取相。复受智名故。此福智当两即句。又地前福智无明全在。故皆名福。地上福智分破无明。故皆名智。此之福智当两非句。故两四句非今福智。二方等下例二部。二今此下明圆教开合俱是二。初释二。初二而不二三。初明相即。一心三止为福。一心三观为慧。始从理性终乎极果。定慧不二是今两即也。二故大下明互具。般若既是尊妙人见。验慧具福。尊妙即是上定故也。论即大论。彼翻首楞严为健相也。三昧既能破彼强敌。验福具慧。强敌即是无明故也。三大经下明异名。五名之中。般若师子吼是慧。楞严金刚是定。佛性是通名也。既是异名弥彰体一。是故此五皆双具之称。复以无妨禅慧以结不二。二不二下不二而二。法虽不二。不妨分门各作名数而为解释。二此是下结。论虽分门别相而说。须知禅慧毕竟不二。四简真应二。初正简真应二。初立句。二若非下简示二。初简前三句非。且简凡小实兼通别。通教灰断同藏二乘。地前作意非不谋应。圆六根净虽全性发。别惑在故未名真应。二亦真下示后一句。是即真而应世之常谈。自舍今宗莫穷其妙。都为他师不知性恶。致令起应不得无谋。徒说无缘之慈。不究无缘之旨。二今依下兼定常间三。初一往且分。以经二段别对常间。二常间下二往互具二。初立。二鸟者。大经第八鸟喻品云。善男子。鸟有二种。一名迦邻提。二名鸳鸯。游止共俱不相舍离。此品答前。云何共圣行。娑罗迦邻提。旧解或云。娑罗一双邻提一双。或云。娑罗一只。邻提一只。或云娑罗翻为鸳鸯。章安云。然汉不善梵音。只增诤竞。意在况喻。取其雌雄共游止息。以喻生死涅槃中俱有常无常。在下在高双飞双息。即事而理即理而事。广如彼疏。今喻二身常间两益不得相离者。乃是观音分证涅槃中常无常二用也。二若小下释二。初小真理天然是佛法体。善吉观见常无间然。于莲华尼似如有间。故于二圣明常无常。斯乃真身自有二益。丈六之相于有缘者常得睹之。若其无缘同处不见。岂非应身亦有二益。二大乘下大。佛法界身未尝不益。于情执者而成间灭。真具二也。佛应化身随机生熟出没无间。应身常益也。见不见异令应不常。又成间益也。故知二身各具二益。三而今下顺文别对。前文即称即感。别对真身常益之义。后文现相生灭。别对应身间益之义。五简药珠二。初依义互具。但就譬说即显真应各能与拔。斯为尽理矣。二若别下就文别对。前文除苦名为药身。后文与乐名为珠身。且顺经文作斯别对。六简冥显。三十六句者。冥显机应各论四句。冥机者。过去善能感也。显机者。现在善能感也。亦冥亦显机者。过现善业共能感也。非冥非显机者。过现无善当能生善而能感也。冥应者。法身也。显应者。应身也。亦冥亦显应者。二身俱应也。非冥非显应者。亦法身。但以不见不闻而知而觉为冥应。不见不闻不知不觉即双非应。故此二应皆果中法身也。识此八已。相对互对具足而言成十六句。约机感应约应赴机。各成十六。加根本四即三十六。若解此意则无生不感无时不应。除诸邪见深荷圣恩。亦知一切众生无一不成佛也。七简权实二。初定文立难。真即是实假即是权。答文备见四种相也。二立句答通二。初详论互具。真智冥应脱有浅深。七难二求免事中之苦。脱权也。离三毒根成佛无疑。脱障实惑也。权智显应得度不同。见身闻法破惑显理。度实也。事中怖难得无畏者。度权处也。机熟之者。对此二智得权实理。名俱度。离浅深障名俱脱。机生返此。是故俱名不度不脱。二据说且分。八简本迹二。初本迹俱与拔二。初各具二用。二非本下相由贴文。非脱众苦之迹。不显一真之本。故前问答是明迹本。非证千如之本。莫垂十界之迹。故后问答是明本迹。二问本下本迹。异真应二。初问。二答。诸经所说始从地住终至等妙。一分真明一分应起。岂唯一世实居当念。是名横辩。别明本迹如寿量品。即今说久远为本。诸经及迹门名已说。近成为迹。既约久近。是故名就三世竖论。前明观音多就体用。而论本迹。今彰部故约久近。而明本迹。九简缘了二。初约当宗问答四。初明善恶法门性德皆具二。初问。缘能资了了显正因。正因究显则成果佛。今明性具缘了二因。乃是性德具于成佛之善。若造九界亦须因缘。九界望佛皆名为恶。此等诸恶性本具不。二答。只一具字弥显今宗。以性具善诸师亦知。具恶缘了他皆莫测。故摩诃止观明性三千。妙玄文句皆示千法。彻乎修性。其文既广且义难彰。是故此中略谈善恶。明性本具不可改易。名言既略学者易寻。若知善恶皆是性具性无不融。则十界百界一千三千。故得意者以此所谈。望止观文不多不少。二明提佛但断修中善恶二。初问。一阐提者。此翻无欲。以于涅槃无乐欲故。又翻信不具。以其不信善恶因果故。既无欲无信名断善尽。佛已永离五住二死名断恶尽。善恶既是理性本具。则不可断是何善恶提佛断尽。二答。夫一切法不出善恶。皆性本具非适今有。故云法住法位世间相常。若因修有安得常住。大经云。十二因缘非佛修罗人天等造。不是性具何得非造。起信云。一切法真不可遣故。若非正具那得皆真。以皆本具故得名为性善性恶。复以性具染净因缘。起作修中染净因缘。乃有所生世出世法。若具言者。本具三千为性善恶。缘起三千为修善恶。修既善恶。乃论染净逆顺之事。阐提是染逆之极。故云断修善尽。佛是净顺之极。故云断修恶尽。若其性具三千善恶。阐提与佛莫断纤毫。三明性中善恶不断所以二。初问。二答二。初约理答。善恶是性性不可改安可断邪。既不可改。但是善恶之法门也。法名可轨。轨持自体不失不坏。复能轨物而生于解。门者能通。可出可入。诸佛向门而入则修善满足修恶断尽。阐提背门而出。则修恶满足修善断尽。人有向背门终不改。二譬如下举譬类。魔烧佛经如提断修善。性善不尽以法合也。佛烧恶谱如断修恶。恶法门存即是合也。焚典坑儒双喻二人断修善恶。岂能等合也。四明提佛迷达起不起异二。初问二人善恶既皆断修而存于性。何故阐提后起修善。如来何故不起修恶。二答二。初以了达故不起实恶。提以邪痴断于修善。既不能达性善本空。故为善染修善得起。佛以空慧断于修恶。了达性恶本来清净。恶不能染故泯修恶。二以自下以自在故。能起权恶。佛能达恶于恶自在。现恶摄生不染不起。阐提若尔则名佛矣。二若依下破他义显正二。初叙他非义二。初明他得修失性。他即陈梁已前相州北道。弘地论师也。又有摄大乘师。亦同地人之解。他明梨耶是无记无明善恶所依。能持一切善恶种子。阐提但断现行之善。后为种子熏起于善。佛断此识无恶种熏。永不起恶。仍释伏难。佛断恶种。如何现恶化诸众生。故释云但以神变现恶化众生耳。二问若下难他作意同外。断恶既尽神变现恶。全是作意。非同明鉴无念而形。虽相州南道弘地论者。以法性为依持。然不明性具诸恶法门。现恶度生亦未能逃作意之咎。二今明下明今妙旨二。初正明由性具善恶起权实善恶二。初正示今义。阐提成佛诸佛现恶。若非不断性善性恶。则义不成。二以有下结成妙旨。断常名通别人缘理断九。以定断九故昧性恶。名为断见。不能忘缘是存修恶。名为常见。涅槃已前皆名邪见。斯之谓欤。断修存性既离断常。乃绝一切边邪之义及种种思。斯是妙旨庶去滞情。二如来下重明由达不达故。自在不自在。现恶达恶岂能染恶。恶际实际缚相脱相。非道佛道。以了达故无有挂碍。阐提不尔故永异也。十简智断二。初明二德同时二。初举一法难与拔二用。既是一法而立异名。必无所局。何故拔与。定属智断。二然而下约身心。从二严立称。名从义立不无亲疏。心解通融属智。身力自在属断。心则智慧庄严。身则福德庄严。此之二严宜对拔与。二今经下示两文互举。智断二德何曾相离。今且各说互相映显。前段明智后段明断。二若深下总结益。举此十双以为义例。庶乎行者遍通一切。若其然者释今题目无边际也。第二别释二。初标列。谓分文人法各自解释也。二以何下解释二。初释观世音二。初结前生后二段。二云何下依别委释二初。简示境智二。初标科。思议中理外理内者。此与余文所说有异。若四教义以藏通二谛为理外。别圆二谛为理内。盖约真谛非是佛性。故云理外。若净名玄义以衍门三教。皆为理内二谛。盖由通教真谛含中故也。今文通以外道及四教起见之徒。皆名思议理外境智。故引中论以为能破。若思议理内境智者。既破四性观理证真。正在通教义兼三藏。若不思议境智者。正唯圆教亦兼别教。圆该六即别在后心二。一天下释相二。初明思议二。初约理外二。初立四。谓天然相待因缘绝待。此四即是四性异名。用此名者。略有二意。一示名言通于邪正。须以理惑定其是非。且如天然及以绝待。本圆极名今在理外。故知不可以名定理。二明理外不全外外。意令内人勿于正法生于性计。故立此名定其见过。又四句中皆双检者。盖以境智俱有自生等过故也。初天然中。言由智故境由境故智者。借彼相待显此天然。二相待者。境待智成智待境立也。三因缘者。非是单自单他。而成于境。乃自他和合方成于境。因缘即是自他故也。智亦如是。此即共性。四绝待者单自单他及自他共。此待皆绝。约无三句情谓。一往立绝待名全非绝理。二并是下破二。初总约性执斥三。初约理外斥。上之境智既属四性不入三谛故云理外。二故中下引中论斥。法离四性那计四邪。三计执下约起过斥。理外妄想于四计中。自执者是实。他语者皆妄。见惑既盛爱使亦增。见爱相添即九十八。因兹造业受苦无穷。二云何下别示。四性过二。初自生二。初举过二。初约能迷所迷二。初能迷诸惑。随执一种即生十使。利中有钝即背上使。历三界四谛。成八十八。虽遍三界及以四谛。随生一见即能具起一处理显顿能除灭。是名通名利使烦恼。若思惟惑界系不同。既非迷理不对四谛但历三界而成十使。足前乃成九十八使。二此则下所迷诸法。即四四谛四三宝也。二若作下约能执所执二。初能执性计二。初正判属计。纵学佛法。若执境智自天而然。若照不照常是境智。我见不忘者唯增生死。惑业既盛。与彼外外轮回一等也。二故大下引大论证。彼论明三种我义云。凡夫三种我。谓见慢名字。学人二种。无学一种。见即利使初果顿断。故云学人二种。慢即顿使四果方尽。故云无学一种。但随世俗分别彼此。有名字我言三种语者。即三种语我不同也。二今凡下所执正教。以见慢心用经论语。如虫蚀字不知是非。唯增见慢即不知非。以此障理名不知是。昧是非故。服不死药而致早夭。二今不下结非。二自生下例三。若增见慢。于百千句起过皆然。二二明下约理内二。初示相二。初明理内。于上四种境智之中。随用一种。而知本为除于见慢。遂加精进研境成智。于惑能破名为毕故。于智不著名不造新。乃成似解而发真证。譬如盲人等者。大经如来性品云。譬如百盲人为治目故。造诣良医。是时良医即以金錍抉其眼膜。以一指示之。问言见否。盲人答言。我犹未见。复以二指三指示之。乃言少见。彼经所譬具示三谛方云少见。今文但喻抉见思之膜示真谛之指。虽非佛性且约见空得称理内。二虽见下斥作意。斯境智者虽灭惑证真。非唯境唯智。思议不绝非今所论。二今明下结非。二次明下不思议二。初据前破性难。四句境智若非。云何立于境智况诸经论所明境智不过此四。二答经下离性四悉答二。初辩相二。初四悉檀相二。初明赴机四悉二。初明四相。圣人境智永袪四执。若其众生于自然境智。有欢喜生善破恶入理机者。圣乃随机。说言境智自天而然。众生若于相待境智。因缘境智。绝待境智。有四悉檀机。圣人一一随彼机缘。为作相待等三种说也。各令获益。是故经中作此四种说境智也。二虽作下辩离情。圣说境智天然等相。永无四执爱见不生。故令闻者破惑入道。得真境智。三悉境智亦复如是。二如是下明能显正法若知四种执着过患。名识苦集。若知四悉被机获益。名识道灭四谛既明三宝则立。诸佛之法无不现前。二若以下不思议相二。初再明思议。于四境智离计而修。四性既空入空取证。虽成理内未泯言思。二若不下正明不思议三。初约义示

问。摩诃止观破见思假节节皆明性相二空。不思议境中约法性无明。检四性过。荆溪云。本自二空为性德境推检二空为修德境。是则思议及不思议。各须性相二空之观。今文何故顿乖诸说。乃以二空分对两处

答。通别二惑同障中道。委论观法皆须二空。今既略谈名有存没。通惑破处虽具二空。小人得之住涅槃相。是故且没相空之名。若破别惑从胜而说。但存空相而于其中。含二空义。何者。以观四种境智名字。不住四句亦不不住。四句属性不住属相。既了四种境智之名。无说无闻。不起分别。不作思量。岂于别理犹计性实。今分二空破通别惑。且顺诸论教道之说。小但人空大得二空。先人后法。良由今文未论观法。且寄次第示妙境智也。二金光下引经证。三此且下指大本。二龙树下引类。大论释经皆先破计。后方示义。今明境智亦类彼文。先破理外见慢惑心。次斥小乘思议之证。后方显示不可思议四悉境智。二夫依下正释境智二。初定先后。二世者下依义释二。初释境二。初释世二。初释名义二。初示世分三种二。初直列三种。大论释百八三昧中。至释能照一切世间三昧云。得是三昧故。能照三种世间。谓众生世间。住处世间。五阴世间。故一家用义。准彼论之三世。演法华之十如。妙谈三千。固非常情之所企及。二既有下义须至三。二世是下辩三通十界二。初约依正明世间。二各各下约因果明法界。二今就下示妙境二。初示妙义二。初明三千缘起。界有相性至究竟等。因果方备。十界皆尔则成百法。十界互具既成百界。则使因果成于千法。如是千法不出解惑因缘。及以所生世出世法。小说无漏因缘但能灭法。故令四圣终归灰断。大说无漏因缘则能显法。故使四圣终归常住。故引大经证大乘义。须了缘起修性皆然。皆由理具方有事用故也。然复应知今明千法即是三千。以约三种释世间故。且一界报须论依正。正复假实。又如初相。如世日者记于此世。夭寿贤愚实法也。僧俗仕庶假名也。衣食田宅依报也。岂非初相能表三邪。初后既尔中可例知。故千法三千但广略尔。今文前明三种世间。今说一千因果之法。前后相显其义圆足。二是诸下示三谛妙境。以三千法皆因缘生。是故一一即空假中。三谛互具非纵非横。故荆溪云。三德三谛三千。皆绝言思是为妙境。二此境下该三法二。初约三人分二境。一家明观不出二境。四念处心对阴色。而分内外。此文心对生佛。而分自他。十不二门以心对彼依正色心而分内外。则依正生佛及己色阴。皆名为外。荆溪特会两处之文。立外境也。应知生佛依正。及己色心皆是法界。无不具足三千三谛。故内外自地皆是妙境。但为观境近而复要。莫若内心。故诸经论多明心法遍摄一切。须知遍摄由乎不二。故四念处云。唯是一识唯是一色。万象之色既许心具。千差之心何妨色具。众生成佛是依报成。国土废兴岂是他事。有不达者。但执唯心不许色具。而立难云。色具三千应自成佛。何处曾见草木受记。是何言欤。是何言欤。以说心具义则易明。于色示具。相则难显。故使教文多明心具欲禀教者因易解难。以心例色。乃显诸法一一圆具。故云唯色唯声唯香唯味唯触。况唯心之说有实有权。唯色之言非权唯实。是故大师为立圆宗。特宣唯色。乃是吾祖独拔之谈。固隐圆宗唯同他说。其意何邪。唯心之义。今非不谈。以明自心及依正色。此之三处各具诸法。则令唯心不与他共。何者。忽若不明万法互具。如何可立心具三千。金光明云。于一切法含受一切。斯之密义深可依凭

问。大意云。色由心造全体是心。何教文云。心由色造。全体是色。又义例说。心具三千。是于无情立佛乘义。亦是心摄何关色邪

答。约能造心摄法易解。故顺经论以心摄法。而为观境。故云色由等也。大师既云。唯是一色而分二种。谓有分别色无分别色。意指识心为分别色。此色造心有何数量。那云。一向色不造心。既云。唯是一色。那云。不云全体是色。又至果时。依中现正正中现依。刹说尘说因果理同依正何别。理性名字已有依正不二之相。何缘坚执一边具邪。无情佛乘约心具说。元是一体从易而观。勿引此文证色不具大。师此说令知皆具。而今据此唯局在心。是得意邪为失意邪。欲人生解邪为符我见邪。二问自下引二经明各具二。初问。前以十界而为世境。次明世境有自有他。他即生佛自即己心。乃引华严心如画师造种种阴。种种之言岂非生佛。故据此文而设今问。能造之心可具十界。所造生佛云何各能具十界邪。以知世人不解三法无差之义。谓心为理生佛是事。理能造事心随解缘造佛。心随迷缘造生。三不相离名无差别。此解违经隐覆圆义。故兴此问以生后答。二答。先引净名实相者。即诸法实相也。约今经意。十界诸法皆实相也。观身观佛实相既然。岂不各具十法界邪。复引华严三无差文。以证各具。彼经如来林菩萨云。心如工画师造种种五阴。一切世间中莫不从心造。如心佛亦尔。如佛众生然。心佛及众生是三无差别。经文先示心造一切。便以此心而例于佛。示佛权造同心实造。次复以佛而例众生。示生实造同佛权造。权实虽异因果暂殊。三皆能造一切世间。故得结云三无差别。云何却谓一是能造二为所造。何得此三无差别邪。此是今家消彼经文。若明其义更匪他知。以今经说因缘果报。即是实相。因缘是能造果报是所造。此之造义既在实相。是故造义理本具足。以此理造方有事造。三法皆尔。是故得云理事不二本末相映。理既互融事宁隔异。三法互具互变互摄。深有所以。圆顿之旨终极于斯。荆溪叹云。不解今文。如何消偈心造一切三无差别。前问那得自他各具十界。今答岂不各具三谛。故知十界若通若别。皆是三谛。二释音二。初约口业正释。十法界中佛者。今既明机。须除极果自分证还但是圆机皆名佛界。悉可称名。二问下明三业俱机二。初问起。二然通下答释二。初正明俱通。真寂常照岂简身意。唯赴口机。二而今下对偏显圆二。初明古遍局六。初趣举。二随俗。三互举三。初正释。圣标于观必照生之色心。即身意也。生标于音。必对圣之耳识。既闻音声复观色心。则是圣应三业机也。二旧问下通难二。初他难。一等互举。何不名为闻色心邪。二旧答下古通三。初叙古通。举观为应。既色心两字则彰应广。举音为机音但一字。则是机狭。机狭应广。深显圣德也。二今更下今载。难若逐字者。则彰感应有可有不。若俱应俱感。则不应云应二感一也。三今不下今为通圣三俱应凡三俱感。但约与夺互举口意。四义摄。独有言音具于三业。故云义摄。五隐显。六难易二。初难急口机易。二又第下誓深宜急称。二今明下引论圆释二。初以觉观况音声。且引释论。三业之事无不圆具。觉观才动与息共俱。已成身行。既是语本又成口行。意业隐细尚能具三。身口粗显各具可知。二但举下明观音圆感应。大圣一观非独具于一种三业。须知具足百界三业。以全法界而为应故。众生一音圆具亦尔。以全法界而为机故。斯由大圣照穷正性察其本末。难思感应。岂以人师凡见测邪

观音玄义记卷第二观音玄义记卷第三

        宋四明沙门知礼述

第二释观智二。初标列。二结境下解释二。初结束世音之境。欲明观智先束境界。世间音声品类无边。尘沙莫喻。须依圣教结示谛境。方可明观。观不依谛邪错何疑。十界是因缘境者。以十如是类十二缘。义无别故。二二明下正明能观之智二。初泛明诸境观。谛缘通四教故四。三谛唯别圆故二。二谛加三接故七。一实唯圆极故一。无谛体忘观亦不立。二今约下今依三谛观者。境顺涅槃新伊之文。观依中论相即之说。荡情立法示妙融心。像末观门此为最也。初示境通别。通对顿观别对渐观。二今对下明观渐顿二。初双列。二次第下双释二。初历教释。二种观二。初偏圆并释二。初约诸部释五。初依璎珞明三观。体于三假四句不生。即俗见真名从假入空观。观三假俗入即空真。由俗入真复名二谛。于空不证。分别一切三假药病。应病授药。故名从空入假。前用真破俗。今用俗破真。若俗若真破用既均。复名平等。以前二破作双遮方便。即以二用作双照方便。次第破用既立。一心遮照可修。故云二观为方便等。三观俱用从胜名中。心既即中思议忘泯。名第一义谛观。二此之下依大品明三智三。初正明三智相。内法内名者。谓理内所诠法相。及能诠名字。外法外名者。即理外所诠法相。及能诠名。空观若成。于此名相悉能体达无我我所。故佛言。摩诃迦叶婆罗门法皆知。沙门法皆知。故云内外能知能解。然其空智但能总达诸法无生。不能别知诸法缘起。故不能用诸佛道法。发起众生一切善种。假观能尔。故以道种而名其智。于一种等者。夫中观智者。则了一切皆是中道。中则不偏绝待为义。一法若中。则一切众生因种。一切佛之道法。无不咸趣。一外有法不名中也。一法既尔。一切皆然。故云于一种智。知一切道知一切种。一相等者。结前所说而成遮照。双遮则一相寂灭。双照则种种皆知。遮照同时。故名一切种智。二通而下对上辩通别。璎珞三观大品三智。通则异名别分因果。三此三下对大经四智二。初略示四智相。大经二十五云。观因缘智凡有四种。谓下中上上上。下智观者不见佛性。以不见故得声闻菩提。中智观者不见佛性。不见佛性故得缘觉菩提。上智观者见不了了。不了了故住十住地。上上智观者见则了了。得阿耨菩提。辅行释云。因缘不殊四观不等。对别教中。云住十住地者。以次第行从住入空。乃至十地方入中道。次第住三故名为住。住及不了并约教道。二涅槃下对上判离合。四教证修唯三观智。空分析体故成四也。大经观缘明四智者。取藏析空为下智故。大品三智璎珞三观简小明衍故。若以二经之三。就大经四者。应开析空生灭一切智。若以大经四就二经三者。应合下中同入空智。四若将下以观智对五眼。肉天二眼是四智三智。所观境本不论开合。慧法佛眼与三观智。主对己齐。若论四智须于慧眼。而对析体二空智也。五中论下以中论四句结。二若将下对四教释二。初正对四教二。初正对教。二所以下出所以。观必教诠智由观得。今明观智须能诠教。二教必下广明四相二。初四教主二。初明教主一异。文有二义明其一异。初跨节论。只一圆佛被四种机。说四教法。次或可下约当分论。随机所见据教所诠。四佛体用优劣硕异。二四教下明补处偏圆。补处亦明当分跨节。例主可知。二若言下四教法二。初明理尚无一。二答理下明赴缘说四。前通释题。十义之首已明此义。证理绝言被缘须教。初明赴缘。二三藏下明说四四。初三藏三。初明教相二。初明愿行二。初依谛立誓。初为陶师者。合云陶师之子。因遇彼佛入城乞食。相好巍巍。乃发善心而兴供养。遂对彼佛发于誓言。愿我当成佛。一如今世尊。故今释迦法住之时。度人多少等。皆同往佛。言即起慈悲者。发心拔苦欲与其乐。若不谛审非想结集及轮回苦。又不谛审三无为灭。及尽苦道。则不拔苦际非与真乐。凡外不谛二乘无誓。菩萨双非依谛立誓。二行六下依誓起行二。初六度填愿。文中所明六蔽为集。六道为苦。六度为道。蔽息为灭。略举初后中四例知。此教菩萨自伏六蔽。对破六道。令他断集离苦故也。菩萨戒疏云。檀破饿鬼。尸救地狱。忍济畜生。进拔修罗。禅静人中。慧照天众。二行此下六度满时。如尸毗王遍割身肉就鹰贸鸽。至尽一身不恼不没。自誓真实感身平复。是檀满相。如须摩提王以身就死持不妄戒。是尸满相。如忍辱仙人被歌利王割截身体。慈忍不动作誓即感血化为乳。是羼提满相。如好施太子求如意珠雨宝济贫。得珠坠海抒海取之。筋骨断坏终不懈废。诸天问之。云生生不休。故助抒海海水减半。龙恐海干送珠与之。是毗离邪满相。如尚阇梨得第四禅出入息断。鸟谓为木于髻生卵。定起欲行恐鸟母不来。即更入禅鸟飞方起。是禅满相。如劬嫔大臣分阎浮提地为七分。城邑山川均故息诤。是般若满相。所言满者度本治蔽行期满愿。今蔽已离与拔遂心。即知六度其功克满二如此下明时位三。初约时明行相。从古释迦至罽那尸弃佛。名初僧祇。准望声闻位。在五停心及别相总相念处也。观力既微故不知作佛。从罽那尸弃至然灯佛时。名第二僧祇。位当暖法。既有证法之信。必知作佛。心未分明故不向他说。从然灯至毗婆尸佛。名第三僧祇。位在顶法。内心了了自知作佛。口自发言无所畏难也。无脂肥羊者。大论云。此菩萨虽有上妙五欲不生贪着。以有无常等观故。譬如有王有一大臣自覆藏罪。王欲罚罪。语言。若得无脂肥羊当赦汝罪。大臣有智。系一羊养以水草。日日三时以狼怖之。羊虽得养肥而无脂。王问。云何得尔。答以上事。菩萨亦尔。见无常空狼。令结使脂销而功德身肥。二用此下约观明涉位

问。声闻根钝尚能速入七贤四圣。菩萨利智何故三祇犹居顶法

答。声闻但于一境一门。修念处等故易成就。菩萨遍于一切境界。一一四门。复加六度久远熏修。使一一行摄诸众生令种熟脱。故三祇内凡化几人超凡入圣。自身此岸度人彼岸。故经劫长证位犹下。言三十四心正习俱尽者。顿证罗汉及以支佛。亦三十四心无间而得。但不以此顿尽正习一言于习有见思习及尘沙习。菩萨修学尘沙法门。治其劣慧。于一一门用四谛观。伏其正使于一一门六度行熏见思习。故树王下三十四心。于尘沙法上证四真谛。故令正使及二习气俱时而尽。故能二谛皆究竟也。方异三乘弟子独彰佛眼佛智。三此中下约佛明补处。二若就下结观智。若于三藏明观音人其相如是。三料拣二。初简超劫二。初问。一超九劫者。婆沙云。尔时有佛。号曰底沙。有二弟子。一名释迦。乐修利他行所化机先熟。二名慈氏。乐修自利行所化机在后。彼佛念曰。回多人就一人即难。回一人就多人即易。欲令释迦先成道故。于是舍二弟子入至山中。时释迦菩萨随后入山。寻求本师不见踪迹。正行之次。忽见彼佛在宝龛中入火界定。威光赫奕特异于常。行次忘下一足经于七日。说于一偈叹彼世尊云。天地此界多闻室(即北方多闻天王之室也)逝宫天处十方无(逝宫即梵王宫。外道计彼为常佛为破彼。故称逝宫)丈夫牛王大沙门。寻地山林遍无等。因此精进超于九劫。在弥勒前成佛。二答。弗沙与底沙梵语赊切耳。弥勒值佛必有超劫。恐梵文未至。二简百劫二。初问。二答。住此法门者。若任运行于六度法门。则须百劫。此据常途理数而言。若精进功倍。亦何局于时分。二通教二。初明教相二。初示名教。三乘因位共能忘言契真谛故。同断见爱故受通名。然有利根通入后教。今分四相且从钝说。前教菩萨至果方断。三乘不通也。二此事下辩行相二。初斥三藏明行位二。初对事度显空行三。初斥事非度。大论斥三藏菩萨云。具足三毒。云何能集无量功德。譬如毒瓶虽贮甘露皆不中食。菩萨修诸纯净功德。乃得作佛。若杂三毒。云何能具清净法门。菩萨之身犹如毒器。具足烦恼名为有毒。修习佛法如贮甘露。此法教他令他失于常住之命。檀有三品。谓命上身中财下也。贸鸽割身犹是中舍。既不了空焉到彼岸。二不见下明空成行。施本治悭悭不可得。三事既空施相不立。能所既泯真空现前。是真檀度。下之五度能所皆空。是则名为道不二相。以此空慧荡生法执。故令众行称理圆成。三又复下斥定三祇。空心立行长劫忘劳。摄无量生经无量劫。何得限定三阿僧祇。为逗衍机须破三藏。非是废除彼教接物。二大品下约断结明共位二。初衍门行位二。初断结行。梵云萨婆若。此云一切智发心与此空智相应。即能断见及破思惟。即是无生人法法缘慈悲。自行化他积行填愿。皆与无生四谛相应。故能因中断结证理。二则有下断结位。二若将下对小阶级。八人地对八忍。人者忍也。世第一后十六刹那齐道比忍。犹属于贤。至道比智即名为圣。二位同在无间三昧。故以十六对八人见。此教菩萨从已办地。留习润生用慈悲道。与真空观双行化物。前断正使今侵二习。至于佛地。见思习尽真谛究竟。尘沙习尽俗谛究竟。第七地中有断有留。故尽不尽。二以誓下约扶余习以利他。正使既尽习不润生。以誓扶之能生三界。以藏通教俱不谈常。生死之身全由惑业。二乘惑尽不受后身。菩萨利物恐同二乘。故藏菩萨用慈悲誓。扶于正使受生化物。通既断正以誓扶习而作生因。尽在不久故似微烟。既为益他留形三界。故称名感见能拔苦与乐。二此是下结观可见。三别教二。初明教相二。初示名教。诠中故异通。次第故异圆。故名为别。不共般若不共二乘。全别前教。圆亦不共故未别后。不名不共意在于兹。二此教下辩行相二。初约次第明行位二。初明次第意。虽说众生见闻觉知体是佛性。而全起作三种之惑。故须用此觉知之性。观空破有观假破空待二均平。方照本性中道之觉。故名方便。次第显理既此迂回。故经尘劫。从初标志。次第修学河沙观智。破河沙惑。显如来藏河沙性德。故缘无量四谛发心。二十信下明伏断相二。初法。十信缘中通伏三惑心正著有。要先观空伏断四住。方袪滞有。复偏着空故观六界药病。成就体析八门道种。又观四圣惑智因缘。无量无作八门道种。二观既成故照中道。此时三观只在一心。别向圆修斯之谓矣。二喻。圆譬冶铁作器。别喻烧金作器。冶谓镕铸。淳朴顿融任运粗垢先落。烧谓锻炼。物体犹坚特要粗尘先去。然后融金以除细垢。圆观顿穷法界。无意先观二谛。二惑任运先落。别观次第显中。有意先观二谛。故使二惑先除。二此菩下期真应以利物。初虽次修后能圆应。二此是下结观智

问。别向圆修。何但结为出假之智

答。后胜受名故。约教道故。如辅行云。一教始终虽具三谛。若入证道不复名别。是故别教但在于假。四圆教二。初约行位明圆二。初广示相二。初正释行位二。初约法示相二。初教所诠理。说一切法皆是中道。一色一心一染一净。皆具三千悉非空假。非内即非性。全性成修故。非外即非修全修在性故。既其空假双亡。修性俱泯。则中道之义显矣。二观十下教所诠观二。初正示二。初明修观二。初对境示观。教所诠法令生妙解。今依妙解而修妙观。十界众生所观境也。镜水譬性德三千。像月喻修起三千。内外有无皆无实性。而三千三谛终自宛然。二观智下就观明谛。此无缘观照无相谛。以无相谛发无缘观。谛观名别其体本同。是故能所二。即非二。二大品下明证释二。初证发心相。若发真心似心观心及名字心。随位约即明坐道场转轮度生。故佛藏云。众生身中已有如来结跏趺坐。理即尚尔况修中位。二即于下初发心德。二入十下入位。二文云下引文称叹四。初此经叹真实。二大品叹具法。三涅槃叹初心。四此中下诸文叹眼智二。初约此经总示。开示悟入皆佛知见所知见境既该百界。验能知见即三智五眼。从胜称一。如海具众流。二引二文别释二。初大论明智。言十智者。谓世智他心苦集灭道法比尽无生也。如此十智通于三藏三乘。唯如实智属于衍教。今但证圆。二眼亦下大经明眼。既见粗色。即是佛性具一切法。即观行五眼从胜名佛。肉眼见性褒之以佛。慧见偏空贬之为肉。二若能下兼明人法二。初示圆六双。二以无下明经二益。三点涅槃者。大经云。秘密之藏犹如伊字三点。若并则不成伊。纵亦不成。如摩醯首罗而上三目。乃成伊我亦如是。解脱之法亦非涅槃。如来之身亦非涅槃。摩诃般若亦非涅槃。三法各异亦非涅槃。此乃三德即一而三。名大涅槃也。二是名下结归题如文。二问答显妙三。初明无缘与拔二。初据中道妨慈问。二指净名成慈答。观众生品文殊问维摩言。云何观于众生。维摩言譬如幻师见所幻人。如智者见水中月。如镜中见其面像等。文殊言。若菩萨作是观者。云何行慈。维摩言。菩萨作是观已。自念我当为众生说如斯法是即真实慈也。彼品既是通相。从假入空彻见三谛即是中道无缘与拔。二明中道建立二。初约双非皆破问。二明中道遍立答二。初约明中能立偏圆三宝四谛二。初略示迷中之失。四教四谛是权实相。皆依中道非权非实。而得建立。今既迷此则一切皆失。二若明下广示明中之德二。初示四种四谛唯心。十种法界忘言之理。名为中道。得此理故方施权实之教。十界融即说者名圆。十界次第说者名别。六界无生说者名通。六界生灭说者名藏。此之四教各论四谛。若识中道诸法皆融。故于一心具四四谛。二所以下释一体三宝具渐二。初约圆观明三宝。佛但双非者。且从略示。遮必具照三智圆觉。方名佛宝。以法三谛显佛不孤。僧宝中云。理事和者。上三谛法性本圆融。名之为理。随情差别名之为事。佛实相慧具于权实。实慧和理能说圆法。权慧和事能说偏法。故文句明法用方便云。智诣于规善用圆法。逗会众生如圆举指目于圆处。智诣于矩善用偏法。逗会众生。如偏举指目于偏处。言事和即有前三教等者。权慧随情照谛差别。即说别教次第三谛。或说藏通即离二谛。乃有三教行人。禀法修行成三僧宝。若其实慧和随智谛。即说不次第三谛。乃有顿修行人。禀法成于圆教因果之僧。不独令他禀教成僧。亦能应作偏圆行人。修成僧宝

问。四十二位。自等觉来合判为僧。妙觉为佛。云何因果皆名为僧

答。别相三宝乃以因果而为僧佛。今论一体。一人一念具足三宝。四十二位位位报智冥于法性。皆名二宝。位位应身皆名僧宝。故妙觉应最能三土统理大众。是故僧宝究竟成就。若能善识一体三宝。任运能具诸渐教中三宝之义。以能和于理事三谛故也。二故大下引月爱明。僧相二。初据经文明诸地智断二。初正引涅槃二。初通譬诸地二。初顺喻白黑论增减二。初举月光喻。白月光增以喻发智。黑月光减以喻断惑。喻虽前后法乃同时。二月性下以体用合。实相则因果不二。智断则增减有殊诸法不生诸法不灭。三千无改也。烦恼灭般若生。无明即明也。大经等者。以无明体是强觉。故亦称为明。二如是下约法地地论智断。舍喻就法四十二地。一一智断故云皆具。二若十下别对诸地二。初以晦望对妙觉。月望以喻妙觉理体智德二俱圆极。故重云不生。月晦以喻妙觉独头相应二皆究尽。故重云不灭。二初三下约开合对诸地。合前开后。故以十五对四十二。此中初三即有黑白两初三也。乃至十五亦复如是。二仁王下例诸般若。但明因位故以十四对四十一地。地地之中具三般若。二如此下结僧实立一切因果。若与中道理和。必与三教事和。是则权实由果皆由中道而得建立。二若不下约迷中。即破渐顿三宝四谛二。初示得前失后。四教三宝及四四谛。但依二种中道而立。藏通依离断常中别圆依佛性中。各有即离故成四教。外计断常都迷二中。故失四教三宝四谛。三教得失在文可见。二传传下明前多后少。二以权显实二。初约圆诠废渐问。二约权能显实答二。初舒渐显圆二。初以观例教。观既以次显于不次。教亦以三显于一圆。利可直谈钝宜渐显。今若四说利钝不遗。二若不下以三显圆二。初示立三意。二虽说下引文证释。余深法者。藏通余而不深。圆教深而不余。别教亦余亦深。故将唯余及以两亦助显唯深。弄引者。引去声。谓曲弄之前必有引起。言开空法道者。谓前三教是开通圆空之法道也。二若入下卷权归实二。初废三立圆。前是为实施权。今明废权立实。十方三世法皆尔也。二复次下忘言契理。寄言显理从偏入圆权非实是。恐失意者是非不泯。故以双非绝其思议。权既不生实亦不生。故二不生彰乎妙契。应知此立非权非实。但是袪乎着语之情。其所契悟理无别途。勿谓双非理过一实。二观心明二种观

问。上明诸教无非对境立乎观门。况复约圆境观皆妙。何故至此更说观心

答。上为解释观世音名。故约四教明乎观法。既观世音。正以他生而为观境。心佛众生虽无差别。就生佛境高广难观。若就心境近而易照。佛世当机随闻悟入。境无远近。灭后初学修观要须拣难从易。故今诸部约教释中。纵己明观。后须更立观心一科。又复他生不出心性。若观自心。则能明见十界众生。故知观心成前约教世音之观。今示观心其意略尔。先标。次夫心下示二。初约心源本无境观二。初明本无心境二。初明性绝百非。心源本净等者。只现前心当处即中。名之为源。离一切相名为本净。无为下列所离相。既其若此焉立心境。二虽复下明心非四运。尚不可以知觉而求。岂能以生灭而取。是故不可立心为境。二岂可下明莫陈观法三。初法。心境本无观于何设。二犹如下喻。无以比况强指虚空。三此下合二有因下由缘感须立观心二。初由缘立心。有十因缘能修证者。无能所中立所观境。二既有下由心立观二。初略立三。初法。二喻。三合。二若作下委示二。初示渐观。虽明二观二意在圆。故次第观略指而已二。若观下示顿观二。初明全性成修二。初就法直明二。初示二。初于一念观性三因三谛即正因。三观即了因。一切法即缘因。具缘了之正名为三谛。具正缘之了名三观。具正了之缘名一切法。故大经云。法身亦非般若亦非解脱亦非。此之三法举一即三三即是一。非纵非横同居一念。二十法下观千法皆有三谛。以其千法皆因缘生。故趣举一性相叵得故空。缘起宛然故假。性绝待对故中。一法既然千法皆尔。学者须知千种三谛只一三谛。说千不散说一不合。以圆融故千法各得三谛全分。盖由三谛体是三德。名秘密藏。一切诸法不出此藏。此藏全体遍入诸法。如世真金具灿烂色。具转变能具不改性。若成师子。则全以色等作头作尾作乎胸背四足牙爪众毛。岂有一处不具色等三邪。此三岂可暂分隔邪。得此喻意则于千种三谛。不起合散一多之计也。况今千法且总略言。广则三千一一三谛。故荆溪云。三千即空性了因。三千即假性缘因。三千即中性正因。心法既尔。众生三千诸佛三千同一秘藏是故一一皆具三谛。此等法门同居一念。二此即下结。即不次第观者。不思议境境即是观。若境自是境更起观智。来照此境。此乃别修非性德行。故止观十乘是观别相。三千空假中是观总体。以此为妙境。以此为发心。以此安其心。以此能遍破。以此通塞着。以此调道品。以此合助道。就此论次位。以此忍他缘。以此离似爱。此外无行此外无果。以将果理为妙行故。故示千种三谛之后。便云此即不次第观也。二华严下按经委示二。初引经示观二。初明心造一切。十种世间皆住真法。真法无碍故十互融。融故百界千法具足。此之理具已有造义。由理造故方有事造。故一言心造即二造也。二若观下观一切皆三。理事二造各论一切。略则千法广则三千。若观心空理事三千无不空也。观心假中理事三千无不假中。既三千空空即三观。三皆能破故总言空。观三千假假即三观。以皆立故故总言假。观三千中中即三观。皆绝待故故总言中。此乃三德三谛三千故也。二如是下结法归心。二若能下指修是佛二。初广引经文二。初引证齐佛三。初约大经观缘得佛。十如即是十二因缘。今观即性故见三千即空假中。名上上智。初心修此即名得佛。二引净名观身等佛。观境虽异实相岂殊。故得观自身心等彼果佛。三引华严心佛无差。如前委说。二若作下约经叹观二。初叹正观。余观望此皆悉偏邪。迦叶未闻已前皆是邪见。二即开下叹是佛。开示悟入佛之知见。今家四释。一圆四位住行向地。二圆四智谓道慧即毕竟空。二道种慧不思议假。三一切智双遮中道。四一切种智双照中道。三圆四门。即不思议空门有门双非双亦也。四圆四观即三观皆空。三观皆假。即三而一即一而三。皆如次对开示悟入。四位竖论余三横辩。故知开等通浅通深。座室衣三皆称如来者。以用果法为行故也。位虽高下境观无殊。是故四仪皆应起塔。二如此下结成佛法。非今所明难越九界。三明普门二。初开章。二随释二。初通途明门二初列。二释六初略列门名三。初列门下通约喻显。二凡鄙下别就法示二。初世间二。初示诸门。外唯世间故至惑苦。惑即集也。爱着三界常乐我净。故言四倒。见惑虽多。不出有无及以一异。各执四句。二善恶下束归生死。二若就下佛法门二。初示四教通之能所。通真含中钝入化城见空真也。利达常住见中真也。二此则下明四种有乎教观。大本立云。若于一教以四句诠理。即是四门。四四合为十六门。若以行为门者。禀教修观因思得入。即以行为门。藉教发真则以教为门。若初闻教如快马见鞭影。即入正路者。不须修观如依电光即得见道。不更须教。并是往昔善根习熟。今于教门得道名信行。于观门得道名法行。三能通下广指大本。二二示下示门相四。初三藏。俗既实有不即真谛。故于俗谛明四种门。以通于理。假人叵得四门是同。但就五阴分别四相。实法无常是有门观。三假浮虚是空门观。二门俱用从容而修。是两亦门观。离空有相绝言而修。是双非门观。随成一观皆得会真。二通教。二谛相即四门不诤。或观幻有或观幻空。或双存观或双泯观。但随根性。依一门修皆得入道。三别教。言观佛性者。信分别心是本觉性体是三谛。根钝不知性具九故。致令三谛体不融即。随禀一门而修观法。禀有门者。观本觉性是真善妙有。如瓶盆寻为闇覆故。不能显现。佛藏十喻皆此门意。禀空门者。观于本觉是毕竟空。无相可得。由我执者不得睹见。如迦毗罗城空者。此城本是释尊生处。为琉璃王之所破灭。释种既尽城邑荡然。阿难愁恼。世尊怡悦。因阿难问。故佛答言。汝见迦毗罗有。我见迦毗罗城空。大涅槃空亦复如是。禀双亦门者。观本觉性不定有无。如石中金福人见故亦有。罪人不见故亦无。有无双照可以证入。禀双非门者。观本觉性不可有无而思说也。绝念而观方可妙悟。圆教者。真善妙有及毕竟空双遮双照名岂异前。但以别人不知三谛体是三德。不纵不横一一互具。以此三谛而为四门。失此意故。随门各解名有四之四。今圆得旨。乃于彼四融即而观。故得名为不四之四。虽立行位皆不思议。三次论下明权实。偏真为权中道为实。前之二教能诠能观共十六门。所诠所证但在偏真。故皆是权。别教教道能诠能观皆次故权。见所诠理及所证地同圆故实。圆教教观。能诠所诠能行所到始终俱圆。故皆是实。四次明下明普不普二。初凡渐不普。二圆门是普二。初约法直示。三千之法即空假中。乃以所通而为能通。门外无理能所泯亡。此之妙门普义成就。二复次下引经委释二。初众经圆门二。初别示四门三初约二经一往属空二。初引净名。不专引文。已含释义。彼经文云。善意菩萨云。生死涅槃为二。若见生死性则无生死。无缚无解不然不灭。如是解者是为入不二法门。彼疏释云。生死是缚是然。涅槃是解是灭为二。今观生死性本来常寂。本自不缚何所论脱。又亦不然岂应是灭。既无然灭不复有二。是为入不二门

问。经疏但以中道之一。不于缚解然灭之二。今文何故更加非一

答。所言中者。体绝待对。若定是一必须待二。善谈中者必忘中也。故末陀摩经正诠中道。而以忘中名为中道。故自注云。末者。莫义。陀摩者。中义。即莫着中道也。又复今文以彼。善意所谈不二。建立圆空释普门义。若于三谛荡之不尽。非毕竟空。岂成普邪。故知四依深谛中义。破用自由。不可执文难于妙解。二何以下释经义二。初据本经释。若真不二必不存一。亦名不有不无者。圆教中道也。此中能破藏通二教单俗单真。故云不有破假不无破空。又破别教复俗单真。故云不有破二不无破一。盖前三教各以二谛为缚解故。圆中能具三种二谛。具故融即乃以融即破于不融。令成不二。若尔下明能融亦荡。虽曰圆中存则成待。二大经下例涅槃释。净名生死与涅槃不二。大经无明与明不二。二遣一亡。两经义合。既其二边与中俱荡。名毕竟空。此乃约空明普门也。二三十下寻净名门。门具四二。初举一品诸门。三十一菩萨妙德净名。若说若默无非实相。当体为门。若就现文增胜而说。可以分对空等四门。及以第五不可说藏。皆名不二无非普门。二细寻下示圆义各四。大师妙解尽理而穷。见一一门具四门义。如向所引生死涅槃。二既即中中亦即二。中即生死名妙有门。中即涅槃名妙空门。二即中道中必遮照。双照是第三门。双遮即第四门。虽于一门约义开四。此四皆悉摄法遍周。俱得名普。余三十门既皆融二。而归不二各四宛然。文殊以言显于无言。净名以默彰于无说。盖示三谛体是秘藏本绝言诠。既示三谛岂非四门。复由向者三十一菩萨。皆从无说显示四门。门门妙绝不可言思。得意之机随其所闻。忘言而证。其失意者犹谓有说。莫契无生。故二大士以言以默。显乎四门离言说相。则使彼彼四门之机。各于其门忘言趣理。须了无说被四门机。其功最大。故诸菩萨虽各兴言不谈一字。净名杜口广说四门。是则说时常默默时常说。若不尔者。何故备举三十三门。而言皆有四门义邪。非旋总持莫穷斯旨。细寻之说其致甚深。三肇师下就诸经分文对四。三十三门门门具四。义虽成就。文且幽深。欲使咸知故。就显文示四门相。肇注净名经云。诸菩萨历言法相文殊言于无言。山家准肇判属二门。思益一切即邪即正。邪是俗有正是真空。华严游心遍入法界。岂非妙有。即达如空岂非妙空。故此二经皆双亦门也。复取净名杜于言说。显于诸法皆非二边。示第四门其文甚显。此则诸经据圆实理开乎四门。深而复广皆是普门。二大品下通明普门。大品法华三句明门。虽不别属四门之数。而遍摄法皆是普门。四十二字字字皆具三种般若。非纵非横而高而广。故能互摄诸字功德。智门一门皆通实理。难入狭小其义相成。难入故狭狭故难入。四十余年调机方说。此门甚妙非七方便能解能入。斯乃至广而受狭名。三众经下结门名普。此经开权永异诸部。显示实理与昔圆同。故与众经同明普门。四随观心并在大本第八辩体中明。谓随彼根机种种差别。赴欲赴宜赴治赴悟。故四门异说也。观心者。若以教为门。即于四门随门得悟。不须修观。名信行人。若闻而不悟。应须修观。名法行人。四教四门各有十观学者寻之。二别释普门二。初标。二至理下释六。初明中适。二列十章。三上通下辩异通。十双通释既以十只释观音人。即以十只释普门法。故云通途已约法竟。今之十门于二严中。就福德论因果自他庄严法身。然是性德之行。还严于性能所本亡。即非庄严庄严也。四分别相。五总生起七。初慈悲。菩提之心非小智能发。心由旷济之念。而兴无上之心。二誓愿。通释慈悲即是誓愿。不分两门。今明弘誓能制慈悲。功力既殊故须别立。又复慈悲通语与拔。誓依四谛别示要期。又慈通凡小誓唯菩萨。三修行。福德财者。即前四度。神通力者。即禅定之用。智谋即般若也。四断惑二。初引两论二三道。修行断惑及入法门。此之三门有开有合。若依成论断即解脱。对于无碍只立二道。若依毗昙断证不同。对于方便乃成三道。二引释下依释论用三道。菩萨有断故行无碍。佛果无断故行解脱。既分因果不可合明。故用毗昙三道为次。故今列章。第三修行即方便道。第四断惑即无碍道。五入法门即解脱道。五神通。从初至五乃是自行从因至果。今论化他不出三密。第六神通即当身密。第七方便即是意密。第八说法即是口密。六供佛。以法供养结于自行。七度生。言入诸法门者。以中道实智。入二谛权门。化度众生同归中道。六随章释二。初标。二始从下释三。初且约十义释普门十。初慈悲二。初约次第三慈通释二。初就人标列。凡圣慈悲三种摄尽。大经十四梵行品云。慈有三种。一缘众生。二缘于法。三者无缘。众生缘者。缘一切众生如父母亲想。法缘者。见一切法皆从缘生。无缘者。不住法相及众生相。大论二十亦云。慈有三种。文意与涅槃大同。又论第五明悲。亦有众生等三。辅行云。将三慈悲以对三谛。义甚显了

观音玄义记卷第三观音玄义记卷第四

        宋四明沙门知礼述

二若缘下约法简判二。初简生法不周。次第生法二种慈悲。藏通二教及别住行。若众生缘亦兼凡外。二有所缘何得名普。二若无下别无缘方普。别教十向圆教初心。修此慈悲至入地住。乃能分证。犹如明鉴不动而形。磁石无念而吸。此之慈悲方得名普。二别释下约圆顿三慈别释。三慈一念不纵不横。故大经云。慈若有无非有非无。名如来慈。有即生缘无即法缘。双非即无缘佛心圆具。今修佛慈。故一一慈皆不思议。文分三。初众生缘慈二。初总示二。初一心缘一界非普。二今观下一心缘十界。是普二。初观众生三。初法。对下法缘毕竟空真。故今众生是难思俗。真实俗假故曰假名。非独人我。称为假名。十界性一举一即十。故成百界。各有相性体力作因缘果报本末究竟等。故有千种。岂唯已千。生佛各千皆冥在性。二喻。三合。凡夫一心具而不识。圆圣法眼一念遍知。二知此下起慈悲圆。闻名字学佛慈悲。即于一念观百界生善恶因缘苦乐本末。而起慈悲与拔之想也。大本十如四类解释。一四趣。二人天。三二乘。四菩萨佛。若分苦乐者。应以四趣为苦。人天等为乐。或六凡为苦四圣为乐。或九界为苦佛界为乐。二今约下委释二。初明观法二。初指初后两界。狱是苦之尤。佛是乐之极。二地狱下明一念千法二。初明地狱具余九界二。初直明地狱十法二。初明十法。十初性。二相。三体。大本通取摧折色心为体。今取觉苦故的指心。四乃至下力。堪任刀火长劫不绝。五作。既堪受苦必任作恶。六因。三业动作成恶习因。七缘。假藉诸恶我及我所。一切具度助成习业。八果。因习淫欲业既成就。果于苦具见是欲境。如本染爱。九报。习果在心境随心变。报因既满即受烧然。十本末。大本乃以初相后报而为本末。则修性皆尔。今欲彰于理事不二。故以修性而为本末。全修在性全性成修。方得名为究竟等也。二地狱下例九界。若非十法不成一界。二问当下明具九界十法二。初约佛法难具问。界有法分云何互具。佛法离染顿出凡圣。云何地狱具兹十法。二答大下明凡心即佛答二。初正明地狱具佛十法十。初佛性。仙豫大王欲化外道。十二年中供养五百婆罗门众。后令归信大乘方等。其不归信乃谤言无。仙豫闻谤乃杀五百。五百堕狱即生三念。一念此是何处乃知地狱。二念从何处来。乃知人道。三念何因堕狱知谤方等。因兹悔过便生佛国。终获佛身。此乃仙像知地狱人有佛性故。杀之令堕三念中发。婆薮过去杀生祭天。因堕地狱于狱教化九十亿人。从地狱出至方等会。佛言。婆者。好也。薮者。高也。好高之人岂堕地狱。又言。婆者。刚也。薮者。柔也。刚柔之人岂堕地狱。斯是大权示现恶相。显于地狱有佛性矣。二佛相。三佛体。上品恶心即中道故。四佛力。性具大用即八自在。五佛作。此云从无住本立一切法者。欲明顺修是佛界作也。九界因果皆违本立。唯佛因果顺本而作。以本觉性元离住着。即无住本。若不顺本无住而作。则非佛界因缘果报。此是妙修此修起时。豁然能绝七种方便智行之作故喻师子筋弦弹绝百兽筋弦。师子之乳点化百兽之乳。须知地狱之心。本具佛界修性之性。如大本中以相性体为佛性三。力作以去是佛界修。此之修性凡心皆具。得此作意则了诸修皆顺性起。六因者。即是顺修所显之理。故曰正因。七缘者。即是顺修能资智行。故曰缘了。而言性德者。以地狱心本具故也。八果。九报即前缘了所克二果。地狱之心无不具也。十佛本末究竟等。约修性相在释。与前地狱不异。二大经下以佛界况余界十法。雪山者。极恶心地也。妙药毒草者。初后二界也。佛法超胜地狱尚具。岂不能具余八界邪。二地狱下余九皆即十界。地狱具九已如上说。九界各各具余九界。可以意得。二菩萨下起慈悲二。初约十界解释三。初深观善恶境二。初法。菩萨修慈只于一念。遍观十界。修得善恶皆即性具。以性照修尽善恶际。二如见下喻。二以观下广运与拔心。观于九界七法因缘。及以所生二死果报。皆即性德故起大悲欲拔其苦。观于佛界七法因缘。及以所生二德果报。皆即性德。故起大慈欲与其乐

问。性德善恶及以苦乐。皆是法门不生不灭。今何与拔

答。斯之妙谈不可轻议。以三菩萨观于苦乐但谓修成。故存与拔之功。莫运无缘之力。是故慈悲俱不名普。今知所生苦乐及以能生因缘。皆是性德。故拔一切苦不损毫厘。与一切乐不增微末。方得慈悲广普尘劫忘劳。此众生缘与其无缘无二无别。三此十下结成慈悲普。二问地下就地狱料简二。初约重苦妨乐问。二约乘机代苦答二。初答众下乘机示因。以第三念忆知先罪必有悔心。大圣承机现身说法。或密警发令起善心。即乐因也。或即得乐如婆罗门。或后得乐如婆薮所化。二又菩下代苦与乐。请观音云。或游戏地狱大悲代受苦。二法缘慈者。前众生缘若缘六界但生死俗。不得名普。圆观十界二乘即真。菩萨是俗佛是中谛。既在一念。即非次第。况复互融而成百界。弥显一假一切假也。此众生缘安得不普。今明法缘即于此境而观于空。二乘空俗菩萨空真。佛空二谛。既约百界即一空一切空。名毕竟空。具足言之。三千即空名今法缘。安得不普初明观境三。初深观性空三。初观千法空。十界必百姓相有千。观此皆空毕竟无相。二十法下观三千空。上之千法于假于实。及于依报即成三千。三无我下观二取空。无能观我无我所观。无智无得离二取相。二如幻下举喻本空。不但俗幻真中亦幻。方是圆家法缘之喻。三常寂下引证圆空。三千荡相即是今教终归于空。二众生下起慈悲三。初正示慈悲二。初明所与拔相。生死涅槃本无二相。以不觉故唯苦无乐。二拔其下明能与拔法。即以三谛如幻慈悲。拔与十界如幻苦乐。二净名下引证真实。说三谛空慈即真实。三若缘下结成圆普可解。三无缘慈者。中观之别名也。中则绝待有缘非中

问。慈悲须对众生苦乐。若其无缘何能与拔

答。大乘所说同体慈悲。心佛众生三无差别。圆名字位学即心佛慈度即心众生。众生既同体。苦乐元性具。故无能缘所缘。亦无可拔可与。如此慈悲尽未来际。拔一切苦与究竟乐。圆谈不独无缘若此。生法亦然。何者。生缘假名三谛俱假。法缘空寂三谛俱空。无缘即中三谛绝待。三慈皆照圆融三谛。岂可二慈非同体邪。但随宜乐故立三门。宜取门者。故说生缘。宜舍门者。故说法缘。宜不取不舍门者。故说无缘。释此为二。初约三观示慈悲二。初明修相二。初约双遮明观法。若缘六界假名。此假定假即有所缘。既缘十界假不定假。故缘即不缘。若缘六界如幻此空定空即有所缘。既缘十界空不定。空缘即无缘。故云不缘十界性相。不缘十界之真。即边是中故遮二边。既是即边复何中道。中边绝迹不可思议。强谓无缘。二如是下约双照辩慈悲三。初法。心无所寄自在双照。无拔遍拔拔一切苦。不与遍与与究竟乐。二如磁下喻。不教喻无缘相应喻与拔。三无缘下合。二行者下明入位二。初约位辩有证。应知理性具三慈悲。全性起修成三观智。虽则六位无缘不殊。必在证悟方彰与拔。二不动下引喻显无缘。明镜如慈体现像即与乐。磁石如悲能。吸铁即拔苦。二三谛下约三谛明普门。三谛名普即是能通。复云通至中道者。约证为所通也。又即一而三为能通。即三而一为所通。所通绝待强名中道耳。二誓愿普二初释名。二弘誓下明义二。初通明誓相三。初明四誓功用二。初通明誓成慈悲。苦集二谛苦因果也。道灭二谛乐因果也。二若见下别明誓之与拔四。初愿度苦果。二若见下愿解集因。三清净下愿安净道。四灭烦下愿得涅槃。二生死下明四誓铨次二。初通示因果前后。拔苦二愿约知难易。易必居前。与乐二愿先修后证。而为次也。二大经下别证由道获灭。钻摇喻道品浆喻有漏善。酪等四味喻四教灭。道品不调失方便善。况四灭果。不云酪及熟酥者。文略。三明四誓总要二。初明四谛依一心。世出世间二种因果事类非一。原其总要不出自心。何者。集是四心苦是三受。道是定慧灭是证智。岂非四谛皆是一心邪。二以四谛例四弘。二次明下明普不普二。初大师约偏圆拣二。初偏誓不普三。初凡夫。厌下等者。即六行观也。谓厌下苦粗障攀上胜妙出。故四无量约此与拔。虚伪浅狭何普之有。二二乘者。须兼两教也。不言菩萨者。与拔分齐只在界内。故斥二乘见彼不普。三别教。以次第故初心不普。二若圆下圆誓能普三。初一念圆照明普意。十界苦集四教道灭。即于一念圆顿而观。二遍知下四谛遍知明普相四。初集普三。初知凡夫集。摄大乘师称有为缘集。体是见爱也。二二乘下知二乘集三。初示集名。摄大乘师称无为缘集。体是无明也。二净名证。不染生死而染涅槃。结习者。结使之余习也。以小教中未说声闻别惑正使。且寄通惑余习言之。三大经证。二乘道品以大望之。是邪非正。三乃至下知圆集。住前似爱住上真爱。亦是等者。即无为缘集通至等觉也。若摄大乘师立四种缘集。前二集上更加自体及以法界。今家二意但立二种。以自体法界不殊无为。悉是障中无明故也。若约无为分出二种。是亦无失。即以第十地为自体。等觉为法界。广如净名疏记。二遍知苦下苦普。以因对果知之不谬。三遍知对下道普二。初遍知偏道不普。人天例立道灭之名。道不动惑灭不出界。有名无义。三教道灭虽能动出。普义不成。二圆教下知圆教中道普。三千皆中即名实相。不动而运方曰大乘。以此为因故称普道。四故所下灭普。三千实相究竟显处。名为圆灭。劫火譬中智遗烬喻无明。三所观下依谛遍周起普誓。二私用下章安用修性判菩萨起誓。欲断十界众生之恶。欲生十界众生之善。观此善恶若但修成。不知性具者。此誓不普。何以故。修必次第。或少或多那得普邪。观此善恶是性具者。此誓乃普。何以故。性既圆融事必遍摄。如别教人不知性九。故十唯十。圆知性九故十即百。岂唯界界遍摄。亦复性相互收。故得一如而收十界。以如收界以界收如。一一无边重重莫尽。此之界如。不出善恶。誓断此恶何恶不断。誓生此善何善不生。故知观性誓愿方普。章安私简以师之义。成师之说令前偏圆显然可见。故云语异不言义别。逭者迭也。以性十界与圆四谛。迭相显映也。三修行普。指行妙者。彼约大经五行。明次不次。且次第五行者。一圣行。谓戒定慧。二梵行。谓慈悲喜舍。此二皆是地前修因行也。三天行。谓初地已上证第一义天。天然之理。由理成行故名天行。四婴儿行。谓示同三乘。七方便人所修之行也。五病行。谓示为九道之身。现有三障之相。此二皆是从果起应之行也。不次第五行者。即大经云。复有一行名如来行。所谓大乘大般涅槃。大乘是圆因涅槃是圆果。今文虽示次第意在不次。以如来行是修行普。四断惑普二。初明二观断不普。藏通三乘及别住行皆二观摄。十向圆修属后中观。二若空下明中观断方普。圆人初心体于见思即是中道。正破无明名拔根本。根本既动枝叶先摧。观障即德名翻大地。既观中道二观自成。三观圆修无惑不破。故得名普。五入法门普二。初明偏小不普。修不称性证乃阶差。我唯知等者。华严善财寻善知识。历百一十城。所见知识皆云我唯知此一法门。新经至第五十见弥勒。第五十三见文殊普贤。则不复云唯知一法。故知即是前渐后顿。二若入下约圆顿名普三。初法。大经明二十五王三昧破二十五有显于我性。三昧者。此云调直定。而言王者。妙玄云。空假调直不得为王。所以二乘入空菩萨出假。不名法王中道调直故得称王。二喻。三合。三谛之下理定之外。各有种种助道禅定。名为眷属。六神通普。神通有六。谓天眼天。耳他心宿命身如意漏尽。皆名神通者。璎珞云。神名天心通名慧性。天然之慧彻照无碍。故名神通。今文略举天眼以例余五。初明天眼二。初偏教非普大罗汉见大千者。准大论第五云。大罗汉少用心见二千界。大用心见三千大千世界。辟支佛亦尔。今言见百佛土者。大部文句亦云。支佛见百佛世界。不以风轮为碍。亦无己他界隔。前同罗汉人属三藏。此必在通。菩萨见河沙佛土者。正唯别教义兼于通。应知此等天眼见土。皆约同居净秽言之。以有余土体质是一故。二今圆下圆教是普。缘十法界等者。圆真天眼具足五眼。见六道即肉天二眼。见二乘即慧眼。见菩萨即法眼。见佛界即佛眼

若尔。与佛眼何别

答。净名疏云。见十法界粗细之色。名真天眼。见三谛无二名为佛眼。二眼见下例余五神。通妙中明二乘依背舍胜处一切处。修十四变化发得神通。六度菩萨因禅得五。坐道场时得六。通教菩萨因禅得五。依体法慧得六。别教地前依禅得五。登地发六。圆教不因事禅而发。乃是中道之真。自有神通任运而发。又云。三轮不思议化。七方便普二。初简通取别。毗昙三道方便道伏。无碍道断解脱道证。今以无碍。而为道中。进行伏惑名前方便。于解脱位观机授法皆后方便。二若二下明普不普三。初小教不普。小菩萨者。藏通二教也。不云别者。以今正明道后方便。别证同圆故不言也。二圆教名普。二谛为方便者。圆人虽乃三谛顿观。中须是实。二谛为权故二名方便。应知三谛是性三因。而缘了属修。故三互融离纵横过。不同别教三皆在性互不相收。是故真则三谛俱破。俗则三谛俱立。既破既立方便义成。收得一切方便者。此之破立何所不收。若人若天若小若大。所有智慧为俱破摄。人等福善为俱立收。以此破立资发中三不破不立。故一念圆观。具性具修含权含实。思议不绝莫造其门。入中道已双照等者。道前自行既以二谛。资发于中。道后利他亦复如是。照真则以真身益物。照俗则以应身赴机。故神变二字有通有别。通则二身皆有神变。别则真运神灵拔三障若。应能变现与三德乐。皆以三千而为神变。故云遍十法界。双照用增双遮体显。于其法身何损之有。圆人始末方便既然。故皆名普。八说法普二。初小教不普。此亦指前二教。以今说法是别圆分证位中。化他之用也。二圆教名普。一音者。即八十好中一音能报众声。殊方异类莫不获益。起信云。圆音一演异类等解。九供养普二。初标列。二华严下随释二。初释事供。分证三千事之本也。十方六尘理之用也。上献佛者。表因趣果。二理解下释理供二。初正释。万行熏智名为供佛。智具三故名为一切。此智即是十方三世诸佛正体。复名一切。二净名下引证。食即三谛能发三智。理佛事佛咸资咸供。十成就普二。初举普不普喻二初举萤等。二举日光。卉木丛林总举三草二木。华果成就略喻十番利益。二外道下明普不普法二。初明凡小通别。二今圆下明圆圣慈慧三。初正明。二华严下引证。因乃称性发心。果则随机遍益。三譬如下重喻。此则今经一地一雨众生谓异圣意无偏二。普门下明普门义无量二。初明净名三号难受。彼经云。诸佛之法悉皆同等。是故名为三藐三佛陀。名为多陀阿伽度。名为佛驮。阿难。若我广说此三句义。汝以劫寿不能尽受。正使三千大千世界满中众生。皆如阿难多闻第一。得念总持。此诸人等以劫之寿。亦不能受。净名之俦者。彼经俦类。诸大乘经所称三号。悉应难受。二今此下明今题三义同彼。今之观字同彼第三佛驮之号。此云觉者故。世音同彼第二多陀阿伽度之号。此云如来。以今世音即如如境故。普门同彼第一三藐三佛陀之号。此云正遍知。一实相开十门故。此之三义若广说者。劫寿莫受。三章安就品证十义。大章第二释体二。初略示今品体二。初示今体。灵智者始觉也。法身者本觉也。同是一觉何所论合。但为本迷觉成不觉。圆名字位寻名觉本。功非伏断合义未成。五品顿伏得名观合。六根似合。分真证合。今观世音邻极之合。全本为始实非二体。以有不觉故约伏断而论于合。本觉轨持生始觉解。故名为法。自然集聚三千妙德。故名为身。始觉元明故名为灵。今能断证故名为智。本始不二是所诠体。二若余下异他经二。初以三二对辩。余经明三身者。金光明经。立化身应身法身。又云。如来游于无量甚深法性。如来是应能游是报。法性是法。此经迹门云。唯佛与佛乃能究尽诸法实相。五佛即应。能究是报。实相是法。本门云。如来如实知见三界之相。非如非异等。如来即应。如实知见是报。非如非异是法。净名有解脱名不思议是法。住是解脱即报。能以须弥入芥子中是应。大品三般若亦是三身。此等众经皆可三身对体宗用。此品但有二身义者。名观世音即真身义。普门示现即应身义。真是内证之智。应是外化之身。若比诸经即当宗用。虽无体文而有体义。以智不孤立必合法身。岂有盖无函有光无鉴。是则诸经三身故。可别以法身为体。此品二身即须法报合而为体。二只此下明理智不二二。初约出缠明不二。前云灵智合法身者。非二物合。只此灵智体是法身。以本觉不觉是故在缠。名如来藏。本觉自觉是故出缠。名大法身。今既出缠验智即理。二今知下约一物喻不二。性德本具权实之相。七方便人非性德智。是故不知同体权实。今之灵智既知权实。验理智不二。理智二名只名一体。其犹一物人若在右物则成左。人若在左物则成右。左右名异物未始殊。故二智与理名异体一。二若明下广指大本释。三明宗四。初正明今品宗二。初略指。体章既明智合法身。斯是出缠之体也。此体广有自在之应。此应对于冥显两机。收一品文罄无不尽。故以感应为此品宗。二十界下示相二。初示机应相。上出缠之体是寂照之知。十机若扣即寂之照。遂蒙真智冥拔众苦。十机若扣即照之寂。乃蒙应像显与诸乐。寂照不二只是一知。与拔虽殊岂须动念。致有前后者。即二问答。说有前后非一时也。二益文下二示宗要义。七难三毒二求得脱。三十三身十九说法得度。此之文义喻如纲目。若牵感应之纲。目无不动。斯为宗要谁谓不然。二余经下与他经辩异二。初示他用因果。本部明一乘因果。净名明佛国因果。观经明心观。金光明指果德。虽单复不同。而不出因果。斯是众经明宗之相。二今品下就此明去取二。初去因果通义。言不尔者。明今品宗不用因果也。何者若以义推谁无因果。从凡至圣能感所感。此义通漫非的今宗。但经意不至此者。出不用因果之意。盖由经文不谈观音自行修证故也。以如来答得名之由。但云即时观其音声。尚不明观音声观法。岂有观成入位之相。若佛顶首楞严经云。昔观世音佛教我从闻思修入三摩地。初于闻中入流亡所。所入既寂动静二相。了然不生。如是渐增闻所闻尽。尽闻不住觉所觉空。空觉极圆空所空灭。生灭既灭寂灭现前。忽然超越世出世间。十方圆明获二殊胜。一者上合十方诸佛本妙觉心。与诸如来同一慈力。二者下合十方一切六道众生。与诸众生同一悲仰。乃至同慈力故能现应身。同悲仰故能施无畏。又大悲心陀罗尼经云。昔千光王静住如来。为我说此广大圆满无碍大悲心陀罗尼。以金色手摩我顶上。作如是言。汝当持此心咒。普为恶世一切众生作大利乐。我于是时始住初地。一闻此咒故超第八地。乃至身生千手千眼等。若今大部迹本二门。广明如来修因证果。及诸经中明佛因果文皆可见。此品不然。故云文意似不至此也。二机家下取感应扶文。以前答中冥应显机。具诠三业。称名常念及礼拜等。文有因也。免七种难离三毒根。文有果也。至后答中显应冥机。是故不说三业现因。而感诸身说。皆云得度。盖随浅深悉能到岸。此有果文也。此因果文以感往收。有何所漏。圣虽无下文虽不示观音修证。而具谈冥显济物无穷。以应往收更无所失

问。前释名章通论十双。慈悲福慧属因。真应智断在果。至别释中解人。则圆观初终。释法则十普始末。至今明宗。何故乃云圣无因果

答。通别释名明观世音及以普门。既是等觉无上人法。道理须明发心立行从因至果。乃取一代教中所诠修证法相。解释人法此乃义推。合有因果也。今明宗要理须扶文岂。可却取他经因果邪。须知今言圣无因果。乃是文无不妨释名义求自有。是故今云文不至此。应知今宗不取因果。特用感应略有三意。一者经既不谈所证之理。故让灵智合法身为体。既冥理属体故摄物为宗。二者经不谈圣自修证相。若用因果则不扶文。三者一品始终唯诠冥显两应对冥显二机。若用感应。宗要善成。三感应下指大本。四问若下杂料拣显相。共十一番问答分五。初四番约机拣四。初善恶俱感明微义二。初问。若言等者即大本释名中云。机是微义。故易云。机者动之微。吉之先现。众生有将生之善。此善微微将动而得为机。今以善例恶。亦有将生微动之义。可得为机否。答然者。许亦是机。圣心圆照善恶不遗。善微将生念欲与乐。恶微将生念欲拔苦。二性善冥伏明生义。二初问。不知性善有可生义。故兴此问。二答。冥伏未现故须圣应。是善性故得将生。三善恶慈悲相关义二。初问。若善已成不须关圣。若关圣应微善成着。恶关圣应亦微恶成着邪二答。圣岂成就众生之恶。但以善性法尔关慈应。则善成得乐。恶关悲应恶灭离苦。同体故关非条然也。四感应相称释宜义二。初问。圣智鉴机宜用何法。那将释感云机宜邪。二答宜必相宜何局于应。底盖之喻不在一边。二一番约应简二。初约二身无应问。二约二身俱应答。法身聚集无量法门。能应众生种种观智。应身聚集无量神变。能应众生种种见闻。三三番相对简三。初明感应非一异二。初问二答。不一故感应不异故相关。二明感应非虚实二。初问。二答。云云者。义应例上。既非一异亦非虚实。然双非虚实及非一异须得其意。心佛众生三无差别。理本无差差约事用。三千理同故不异。迷悟事异故不一。悟故佛法为应。迷故心生是感。理本一故非实。事暂异故非虚。故不二门云。幻机幻感幻应幻赴。故地住前异相仍存。真位分分同佛体用。至于究竟感应既亡。复何论于一异虚实。三以他下明感应难思议二。初叙他问答二。初疑凡圣隔异非感应。克论感应其体各别。虽互立能所。而凡圣定分。所感是圣必非能感。所应是凡定非能应。感应分隔何名道交。二答能所存没故道交二。初互论能所。先立所感所应不实。何者。所感非凡故不实。所应非圣故不实。次立能应能感不实。何者。良以还将所感为能应。所感既不实。故能应不实。又将所应为能感。所应既不实故能感不实。二既不实二亦非异。二不异下各论存没。既无实无异。何名感应道交。故以互存互没而立不异而异。以由所感而为能应。所应为能感。故感应不异。而今圣边没于所感。目为能应。凡边没于所应目为能感。故成而异就于而异。故有感应。就其不异故得道交。斯是古师情解感应及道交义。二私难下章安破立二。初难他义不成二。初难立义不成二。初明存没不成。虽以能所互论存没。究其体状只于圣边。没其凡感复于凡边没于圣应。以其圣没能应不得。凡没能感不得。若尔。感应永殊。那言不异。二又感下明不异不成。大意同前。二又难下以四性结过。感能应所自属于机感所应能自属于应故是自性次之二句虽涉感应。义不相由还属自性。次有四句皆从彼生。故属他性。第三不独由自不独由他。须二合生乃属共性。若离自他属无因性。二问若下明今能妙契二。初离四句无感应以问。二答圣下用四悉立因缘而答。大圣圆证三千理事。同在一心故心平等。一一皆了即空假中。故心为住。圣既用此平等无住为能应法。故不住着所应机感。但随十界乐欲便宜破恶入理四机扣之。即以世界为人对治第一义四种之法。任运而应。此之感应岂可以其自他共离而思议邪。又复众生于自生感应。有四益者。亦可说言自感自应。若于三种有四益者。亦可说言由感生应由应生感。共能生感共能生应。离二有感离二有应。皆可得说。既无四执随机说四。故诸经论谈于感应。不出此四也。四问妄执下一番约机简二。初疑妄执之善非机。二答妄执是恶能感。五问妄执下二番相对拣二。初示妙应随情所为二。初问。二答。二问凡下示至圣拔邪归正二。初问。二答。四慈悲利物用二。初标

问。感应慈悲为同为异。若其同者。那得分对宗用二章。若其异者。请陈其义

答。法相开合制立多途。今文既以般若法身合之为体。乃于解脱分出宗用。虽是一德而有二能。感应则通语关宜。慈悲则别明与拔。若论感应不说慈悲。则似仁王降世而无治理之功。今明感应则收经义尽。故立为宗。次示慈悲则利物义足。故立为用。开一为二。其意略尔。二二智下释二。初正论冥显二。初略辩二。初对二智辩用二。初问。妙经之用断权疑生实信。正当二智那指慈悲。二答。二智之用通亘一部。具智慈悲今品别用。二他释下就二身明益二。初叙他局解。二今明下明今正义二。初法二。初明二身皆常间二。初明二身皆常。法以寂照为常。应以不休为常。二若言下明二身皆间。二故知下明二益无二别。二譬如下喻。二此中下指广。大本明二十五王三昧破二十五有。显真常我性。通有四意。一出诸有过患。二明本法功德。三结行成三昧。四慈悲破有。观音自行已破诸有惑业过患。功德三昧皆已成就。正以慈悲令他破有。故知今用即第四意也。二问观下兼辩本迹三。初明本迹难知二。初问。二答。二如观下明因果异说二。初引二经犹在因。二若观下引一经已成果。三二文下用悉檀和会二。初问。二乃是下释。或说已成或说未成。盖顺机缘令获利益。勿求其实。第五明教相二。初定文相二。初泛明部党。二今所下的示所传二。初示妙经一品。二而别下明别行之由。二此品下明教相二。初同本经醍醐相二。初明品意。通于开权显实者。且举迹门。亦应更云开迹显本此乃以方便品讫分别功德品十九行偈。俱为正宗。以十九行偈后。俱为流通本迹二门也。二圆人下明教味。圆法即本迹二门所诠之法也。圆教即本迹二门能诠之教也。二问文下核今品施开义三。初核成施权相二。初约方便乖圆问。二答就下约为实施权答二。初约实人施权答。圆圣偏说为引渐机。岂佛说小令佛是小。就能说人判属圆教。二又付下约权能通实答。深信解者。即嘱累云信如来智慧者。若不信者。即七方便人。二又问下核成开权相二。初约机同鹿苑难。说人虽圆禀人通小。且如鹿苑佛岂不圆。只就禀人判属三藏。今岂不然。二约部开权迹答。阿含小部未开权迹。遂令教味随机属小。今经开显即权是实。即迹是本。虽说小法为通圆经。岂同鹿苑邪。三问上下核成妙用相二。初约舍用相乖问。二约体用难思答。正宗废权立实故言舍。流通为实施权故须用。显实体后而论权用。斯是今经秘妙方便

观音玄义记卷第四


观音义疏

    No. 1728 [cf. Nos. 262(25), 1729]

观音义疏卷上

        隋天台智者大师说　门人灌顶记

此文既别出大部。有人亦作三段分文。谓初问去为序。佛答去为正。持地去为流通。复有云经家序者为序。无尽意白佛去为正。持地去为流通。今师有时亦作三段。有时不作三段名。但分为三章。一无尽意问二佛答三持地叹。或为四章三如前。四者闻品得益。或作二段。谓前后两问答也。多种分章随人意用也。若作问答分章则有两问答。初问答明观音树王冥益等义。后问答明普门珠王显益等义。就前问答为二。一问二答。就问为四。一时节。二标人。三敬仪。四正问。一尔时者尔言即也。即是说东方妙音弘经已讫。次说西方观音弘经之时故言尔时。或可大众已闻妙音弘经欢喜已竟。宜闻观音发心生善之时。故言尔时。或可时众疑于妙音。若为利益上来说法破众疑情已竟。时众有疑观音之德。正破此疑之时。故言尔时。或可时众机在妙音闻即得道。如二土菩萨得道已竟。八万四千悟理之时须闻观音。故言尔时。诸佛如来不空说法。有四悉檀因缘尔乃为说。正是敷演四悉檀时故言尔时也。二标人者。即是无尽意也。名无尽者。非尽非无尽为对小乘名尽故言无尽。小乘明尽为对尽智无生智。灭色取空之尽故名无尽也。又云。何无尽所谓空不可尽假不可尽中不可尽。故言无尽。大品经云。即色是空非色灭空空故无尽也。又大集经释无尽意。东方过十恒沙国微尘世界。国名不眴佛号普贤。纯诸菩萨无二乘名。但修念佛三昧不灭不生不出。心行平等犹如虚空。是为念佛。即见佛时即具六波罗蜜得无生忍。所谓不取色即檀。除色相即尸。观色尽即羼提。观色寂灭即毗黎耶。不行色即禅。不戏论色即般若也。身子问。谁为汝作字名无尽意。答曰。一切诸法因缘果报无尽。一切诸法不可尽。初发无上菩提心已不可尽。譬如虚空不可穷尽。为一切智发菩提心。岂可尽乎。诸佛戒定慧解脱解脱知见十力无畏等无尽。因如是等发心故不可尽。众生性无尽。教化众生无尽。知一切法性无尽故无尽。是名菩萨发心无尽。又檀波罗蜜无尽。乃至方便无尽。凡八十无尽。八十无尽悉能含受一切佛法。从是得名名无尽意也。又净名云。何谓为尽谓不尽有为。何谓无尽不住无为。华严有十无尽法门如此等经皆就假名。分别一切诸法因缘果报。以明无尽意。又如胜鬘经云。如来色无尽智慧亦复然。一切法常住。又大品经云。一切法趣意是趣不过。意为法界意则非尽非无尽。如是无尽例如非常非无常是乃为常。又净名云。法若尽若不尽皆是无尽相。无尽相即是空空则无有尽与不尽。故知非尽非无尽是真无尽义。又大品经云。痴如虚空不可尽。乃至老死如虚空不可尽。色不可尽乃至识不可尽。如此等经皆约中道之理。以名无尽。通达空假中三谛之法不可尽。故名无尽意菩萨。亦名无尽心智识色受想行等义。不可说不可说不能具载。菩萨者。外国云摩诃菩提质多萨埵。此云大道心众生。始心行者为烦恼所生。二乘为五分法身所生。六度菩萨为福德所生。别圆为中道所生。故大品云。如来身者不从一因一缘生。如来身菩萨为众行生。故言众生发心求佛。故言为大道。利益一切以法道成他。或言成众生。广释菩萨义如别记。三敬仪者为三。一起二袒三合掌。起者礼云请益起请业起。菩萨于佛备其二仪故言起也。观释者菩萨常修远离行故言起。亦是契诸法空空即是座。于此空无所染着故言起也。又菩萨安住空理理本无起。愍众生故乘机利益故言起。又中道之寂非起非不起。而能起能不起无起之起。起即实相亦起众生实相故言起也。偏袒右肩者。外国以袒为敬露右者示执奉为便。表弟子事师充役之仪。是故以袒为恭也。此方以袒为慢。然古有须贾肉袒谢于张仪露两髀也。此方亦不一向是慢也。观解者。覆露表空假二谛。又表权实实不可说。如覆左表有冥益权于化便。如露右表有显益也。合掌者。此方以拱手为恭。外国合掌为敬。手本二边今合为一。表不敢散诞专至一心。一心相当故以此表敬也。观解者。昔权实不合而今得合。又五指表阴。仁王经云。法性色受想行识。此即实智真身亦有五阴也。应化因缘亦有五阴也。众生性德之理亦有五阴也。众生生死果报亦有五阴也。圣人为化众生示有应身五阴。是则权实阴殊。若众生法性理显。圣人亦息化归真权实不二。合掌表于返本还源。入非权非实事理契合故合掌也。向佛者。表万善之因向万德之果也。亦是行人分证权实合。向于究竟权实合故言向佛也。四发问者。此下有两番问答。初番问观世音后番问普门。前问为三。一称叹。二标所问人。三正问。大经云。汝具二庄严能问是义。我具二庄严能答是义。今无尽意具二庄严欲显观音二种庄严。咨发如来。如来究竟具二庄严。当答此义。释论云。问有多种不解问试问赴机问。今无尽意即是赴机问也。世尊者。即是称叹尊号十号具出释论。用彼释此观世音菩萨。即是标所问之人也。具如前释。何因缘者。因缘甚多略言境智因缘。若就众生则以善恶两机为因。圣人灵智慈悲为缘。若就圣人观智慈悲为因。众生机感为缘。以是因缘名观世音。如上释也。第二佛答即为三。初总答。次别答。三劝持。就初总答为二。一明机。二明应。就机为四。一标人数。二遭苦。三闻名。四称号。数者十法界机实自无量而言百千万亿者。此乃通途商略。业同者如一地狱界大略是同。其间优降复有何量。如一狱复有百千万亿品格之殊。一一品格复有百千万亿罪人。是罪业正同所以同受一品罪苦。将此意广历饿鬼畜生修罗人天皆亦如是。故知此数是标同业之意也。所以举多数者。明百千万亿种业遭苦称名。一时有机一时能应。皆得解脱。何况一人一业一机独来而不能救。此举境众机多以显观深应大也。二明遭苦者。即是受诸苦恼也。此语成上义。上百千是业同此言诸苦恼。一苦恼是一业者。凡有百千万亿。故知有诸百千万亿。上明数同下明业别。用此意历十法界万机之徒。不可说不可说也。今言受苦恼者。正是现遭苦厄也。此苦由于结业果多故因亦多。此即总答文略而意广。遍该十界不止人道而已。后别答中文广而意狭。别举人间七难而已。故此处总答也。三闻名者。上明遭苦次明生善。善恶合为机。此即明文闻有四义如别记。若能如是通达四种闻义即闻慧。心无所依无住无著即是思慧。一心称名。即修慧。此文虽窄三慧意显。四称名者。称名有二。一事二理。若用心存念念念相续余心不间。故名一心。或可如请观音中。系念数息十息不乱名一念。或可无量息不杂异想。心想虽长亦名一心。一心归凭更无二意。故名事一心也。称名者。或可略称。如此文或广称如下文。南无者。归命之辞。皆是事一心称名也。理一心者。达此心自他共无因不可得。无心无念空慧相应。此乃无一亦无心知声相空呼响不实。能称所称皆不可得。是名无称。是为理一心称名也。二应者。先明应次明解脱。应有多种。三教之应应不一时。圆教观音一时圆应众机厄急应速。一时闻即称是机速。称即应是应速。皆得解脱者。即是蒙应利益也。皆者非但显于多机众益。亦是显于圆遍之应也。或时为机速应速平等利益速贴文

问。十法界众生无量机既无量。云何一时令得解脱

答。譬如父母念子心重多智多才具大势力。众子在难即能俱拔之。菩萨亦如是。无缘慈悲重权实二智深。圣财无量神通力大。十界虽多应有余裕。安乐行云。忍辱大力智慧宝藏。以大慈悲如法化世。即此意也。又如毒龙罪报尚能以一眼遍视一切。视之皆死。何况菩萨种智圆明耶。又如礠石。亦类明镜。又是入王三昧力一时十番利益一切。此义具在大本玄义

问。一心称名皆得解脱。今见称唱累。年不蒙寸敩何也

答。经云。一心称名有事一理。一二途。无取可能感圣。譬如临镜背视对谷闭口。何能致影响耶。第二别答为三。一口机感应。二意机感应。三身机感应。就口机为二。初明七难。次结口机。有人云。次第三机者口显居前音成由意意识成身也。通论口机亦脱三种苦。但先除果苦。次除苦因。次满愿与乐

问。此中明拔苦那忽与乐

答。少分与乐欲引接之也

问。何意不与其乐因

答。因非引接故不与。又其文在后为说法是与乐因

问。悲门既少分与乐。慈门应少分拔苦

答。前悲全拔苦已竟后但与乐。无苦可拔何论少分。有人解七难为两双一只。火水无识为一双。鬼非类为一只。王贱是类为一双。鬼开去来王论轻重故成七难也。次第者火水无识为难则重。鬼虽有识非类为次。王贼有识是类故轻。然鬼王相间初以鬼比王。王轻则鬼重。又以王比鬼。王重鬼轻。此二相似故间出。有师以风足为八难。有人弹之。文云。称名皆得解脱。罗刹之难不道风为难。今明圣人赴机何必如此情卜。次第何必不次第。今不同前者。此本明赴机拔苦。那得更以与乐间之。今言次第者。先入国随俗赴口机为初。意冥身显以为次也。若寻经意一时观其音声皆得解脱。经不云次第观机。那可作次第释耶。他既作七难次第。今还复作对之耳。入火即有焦身绝命之忧。最为卒重故居初。水漂沉浮小缓于火。罗刹虽暴如经云有五百罗刹女。妻五百飘人生子受乐。时节犹长。然后顿食。此复缓于水。王难非即得即戮。研罪虚实实刑虚赦。不同于鬼一概并食。故复次罗刹也。鬼来取者无的所取。衰乃逢害逃脱可免。不同王法定判死生。故复次王难也。枷锁节身不虑失命。但有禁固之苦小缓于鬼。怨贼觅宝输宝即毕。若能卑辞善巧方便即可免脱。此一往次第尔。至如凶贼忽发与火烧何异

问。诸难众多何意取七耶

答。此有所表人以六种成身。还以六种自害。如人共七难同住复以七为难。今通用七难等来表六种也。火水风即表身内三种也。刀杖枷锁表地种也。鬼贼王等表识种也。三千大千世界表空种也。云何空得为难。如人身有内空。四大围之识于中住。何异大千界围地水火风。王鬼贼等于中住耶。空为难者空是来难之由。如身体坚实外病不侵。身若虚疏众疾逼恼。又如人家宅无垣墙。盗贼则进能来难。故空亦成难。识种是难者心识耶。计横起爱见毁灭法身慧命。如王鬼贼劫夺财宝。断伤寿命故识种是难。所以不多取者正应表此。假令多举诸难亦是表此一。火难为四。一持名即是善为机。二遭苦即是恶为机。三应。四结。上总云受诸苦恼未判其相。今别答故举水火等也。释诸难例为三意。一贴文。二举事证。三观行解释。贴文者。持者口为诵持心为秉持。秉持为理不失。虽非口持觉观亦得是口行。故通属口业机摄。若有设有复有皆是不定挑脱之辞也。余皆难起方称名。此中前持名而遭难。此或是前后互出尔。今为火难卒暴须预忆持。忆持必无此难。设脱有者。皆是放舍所持。背善从恶称之为设。如慈童女因缘。若能至意修孝不遭火轮。违母绝发受地狱苦。此是秉孝不纯广出因缘。云云。行人持名本不应遭难缘差忽忘。设入大火若能忆先所持。即得免难。火难既重机亦须深。故先持后脱其义可见。威神力是结火难也。次约证者。晋世谢敷作观世音应验传。齐陆杲又续之。其传云。竺长舒晋元康年中于洛阳为延火所及。草屋下风岂有免理。一心称名风回火转邻舍而灭。乡里浅见谓为自尔。因风燥日。掷火烧之。三掷三灭。即叩头忏谢。法力于鲁郡起精舍。于上谷乞得一车麻。于空野遇火。法力疲极小卧。比觉火势已及。因举声称观。未得称世音应声火灭。又法智遇野火。头面作礼至心称名。余处皆烧智容身所无损。又吴兴郡吏此皆记传所明非为虚说信矣。三就观行释者。火有多种有果报火业火烦恼火。果报火至初禅。业火通三界。烦恼火通三乘人。果报火难者。从地狱有上至初禅皆有火难。如阿鼻鬲子八万四千内外洞彻上下交炎。饿鬼支节烟起举体焦然。畜生燠煮汤炭。修罗亦有火难。人中焚烧现见故。若至劫尽须弥洞然。诸天宫殿悉皆都尽。初禅已下无免火灾。凡一十五有众生百千万亿诸业苦恼。持是观世音名火不能烧。何但止就阎浮提人作解耶。直就一十五有果报。望旧解火诚可笑哉。余九番非彼所知。次明修因恶业火者。随有改恶修善之处。若五戒十善多为恶业所难。故经云。烧诸善根无过嗔恚。虽生有顶头上火然。术婆伽欲火所烧。金光明云。忧愁盛火今来烧我。能破善业退上堕下。皆名为火。若能称名得离恶业。故请观音云。破梵行人作十恶业。荡除粪秽今得清净。由斯菩萨威神之力也。次明烦恼火。若声闻人厌恶生死。见三界因果犹如火宅。四倒结业烟炎俱起。轮转堕落为火所烧。生死蔓延昼夜不息。勤求方便竞共推排争出火宅。称观世音机成感应。乘于羊车速出火宅。入有余无余涅槃。即得解脱也。次明支佛。次明六度行。次明通教。次明别教。次明圆教。次明变易土钝根人。次明变易土利根人。凡有九番行人。修道之时并为五住烦恼惑火之所烧害。各修方便。方便未成火难恒逼。称观世音方便即成便得解脱。一一当其法门细作机感之义

问。菩萨住何法门而能如是耶

答。菩萨法门无量不出别圆两观。本起慈悲故能十番垂应。所以者何。菩萨元初发菩提心。见果报火烧诸众生。即起慈悲誓当度脱。受持禁戒亦起慈悲救诸业火。修无漏观白骨流光发火光三昧。八胜处中有火胜处。十一切处中有火一切处。皆起慈悲当为众生灭烦恼火。又观诸火悉是因缘所生法。体之即空。又从火空而观火假分别因缘。又观火中见火实相。如是次第节节皆有慈悲誓当利物。今住补处力用无尽。以本誓力熏诸众生未曾舍离。随有机感即能垂应。若事火起称名求救。即对本时果上慈悲拔苦与乐。恶业火起即用持戒修定中慈悲。烦恼火起即用无漏入空入假入中等慈悲。节节相关。若众机竞起一时牵感。慈悲遍应皆得解脱。如华严第四十云。善财诣进求国。见方便命婆罗门修苦行求一切智。有大刀山四面火聚。从刀山上自投于火。语善财云。能入此者是菩萨行。善财生疑言是邪法。梵语善财。莫作此念。此是金刚大智人欲竭爱海。自在天云。此菩萨五热炙身。令我灭邪见离我心诸魔。又云。菩萨炙身时。我等宫殿犹如聚墨。我即发菩提心。乃至他化自在天于烦恼中得自在法门。乃至龙鬼阿鼻皆发菩提心舍本恶念。善财闻空中语已。即时悔过。登刀山入大火聚。未至得菩萨安住三昧。入火得菩萨寂静安乐照明三昧。此火山者名为无尽法门。若入此门能知诸法。故举彼经火法门如此。证成观音火法门慈悲救苦十番利益也。次明菩萨本修圆观所起慈悲者。但观一火具十法界。一切诸法入火字门于一火门虽无分别。明识一切果报火业火烦恼火等。明了通达。无缘慈悲遍覆一切。是为火门入王三昧。若法界火起菩萨以本地誓愿。普应众生如磁石吸铁。虽无分别而分别说者。以十五三昧救果报火。用二十四三昧救修因火。二十五三昧通救二乘通教六度别圆等入空烦恼火。还用二十五三昧救别教山假火。还用二十五三昧圆救圆教人入中烦恼火。虽应入诸火不为诸火所烧。大集经云。譬如虚空火灾起时所不能烧。菩萨亦如是。以不思议慈悲。普应一切皆得解脱也。常途释七难。止解得救人中苦。失二十四有及变易中苦。止得如幻三昧少分。全失二十四三昧广大之用也。第二水难者。亦为三意。一贴文。二引证。三观释。贴文为三。一遭水是有苦。二称名是善。三得浅处是应也

问。何意言为大水所漂

答。小水不成难或戏故入水亦不成难。欲论其难故言大水所漂。火难所以言入者。小火亦能断命。若故入若不故入。入则害命。今举其重难。重难既救何况其轻。是故言其入火不言入水。言其大水亦言大火。水论其浅即成应。火犹少在未成应也。二引证者。应验传云。海盐有溺水同伴皆沈。此人称观音。遇得一石困倦如眠。梦见两人乘船唤入。开眼果见有船人送达岸。不复见人船。此人为沙门大精进。又刘澄随费淹。为广州牧。行达宫停遭风。澄母及两尼声声不绝唱观世音。忽见两人挟船遂得安隐。澄妻在别船及他船皆不济。道冏三人乘冰度孟津。垂半一人前陷一人次没。冏进退冰上必死不疑。一心称观世音。脚如蹋板夜遇赤光径得至岸。此例甚多。皆蒙圣力也。三约观解者。果报水至二禅。恶业水通三界。烦恼水通大小乘。如地狱镬汤沸屎碱海灰河流漂没溺。饿鬼道中亦有填河塞海。畜生淹没冲波致患。阿修罗亦有水难。人中可知。水灾及二禅泛漾无岸。是时若不称名尚不致浅处。何况永免耶。次恶业水者。诸恶破坏善业者。悉名恶业波浪爱欲因缘之所毁坏。澍入三恶道中忘失正念放舍浮囊。见思罗刹退善入恶者即是水漂。何必洪涛巨浪耶。若能一心称名即得浅处也。次次明烦恼水者。经云。烦恼大河能飘香象。缘觉观爱欲之水增长二十五有稠林。潦水波荡恼乱我心。暴风巨浪有河洄澓没溺众生。无明所盲而不能出。涅槃彼岸何由可登。二乘人修三十七品之机。运手动足截有生死险岸。前途遥远一心称名。若发见谛三果皆名浅处。无学为彼岸。次支佛侵习为浅处。通教正习尽为彼岸。次别教断四住为浅处。断无明为彼岸。次明圆教六根清净为浅处。入铜轮为彼岸。变易中分分是浅处。究竟无明方称彼岸

复次初果免见流。三果免欲流。四果免有流。乃至圆教方免无明流。菩萨所以遍应水难者。皆是本修别圆二观慈悲。今日成就王三昧力。所以者何。菩萨修别观时。见众生漂果报水。起誓拯济。菩萨修戒定时。以善治恶。于诸禅定水光三昧水胜处水一切处。皆起慈悲以善攻恶。又从水假入空发真无漏。从空出假达水因缘。入水中道见水实相。节节法门皆起慈悲熏诸众生。今成王三昧。寂而常照众生报水所漂。称名为机对事。慈悲救果报水。戒定慈悲救恶业水。三观慈悲救烦恼水。一切一时皆得解脱。如华严三十八明。善财至海门国。海云比丘为说普眼经云。十二年来常观此海渐渐转深。大身居止珍宝聚集。如是观已则见海底生大莲华。无量天龙八部庄严华上。有佛相好无边。即申右手摩于我顶。为说普眼经千二百岁。一日所受阿僧祇品无量无边。若以海水为墨须弥聚笔。书写此经不能得尽。当知水法门摄一切法。亦如大品阿字门具足一切义。观音于水法门久已通达。故能遍应一切水难

复次本修圆观法门。无缘慈悲遍应一切者。观水字门。十法界趣水字是趣不过。水尚不可得。云何当有趣不趣。十法界趣水是俗谛。水尚不可得即真谛。云何当有趣不趣。即双非显中道第一义谛。如此观水字十法界三谛之法。即起无缘慈悲遍熏三谛十法界众生。故能圆应一切。若分别观者。以十六三昧救果报水。以二十四三昧救恶业水。以二十五三昧救二乘通别圆入空有流等水。以二十五三昧救别教出假。于有流中令无染湿。以二十五三昧救圆教入中无明流水。一切一时俱得解脱也。第三罗刹难者。亦为三。一贴文。二约事。三观释。贴文又为二。一明难。二结名。难中为五。一举数。二明遇难之由。三遭苦。四明机。五明应。人数者但举百千总数不定判多少。明入海求珍结伴无定。难无定数终不可独往。故举百千也。贤愚云。田殖百倍商估千倍仕宦万倍。入海吉还得无量倍。故入海也。次遭风是难由约下文证。今若开风为正难。下文云。皆得解脱罗刹之难。此岂不独是罗刹难也。难由正应无在由者。何但由风。由风堕难由入海遭风。求宝入海由贪求珍宝。展转相由风灾难切。故风是堕难之由也。七宝是正宝珠是伪宝。又如意珠宝最上。今言等者等上等下诸宝也。楼炭云。巨海有七种似宝一百二十种真珠宝。黑风者。旧云风无色吹黑沙故尔。有人弹云。沙中无船水中无沙。非是吹黑沙乃是吹黑云尔。今还例此难。水中无云云中无船。何得弹沙而取云。风能吹黑云何意不能吹黑沙。请观音云。黑风洄波。仁王般若有六色风黑赤青天地火也。受阴经明五风。阿含亦云。有黑风风加以黑怖之甚也。罗刹是食人鬼人尸若臭能咒养之令鲜。复有啖精气鬼。人心中有七渧甜水和气精神。鬼啖一渧令头痛。三渧闷绝。七渧尽即死。一人称名余者悉脱者。同忧戚休否。是共虽口不同唱。心助觅福故俱获济是均。若后值贼则同声者。陆地心多不并决。须称号令。使齐与水难为异。何意就此结观音之名。此正就一人称名而赖兼群党。明慈力广被救护平等。显观音之名也。二约事证。应验传云。外国百余人从师子国泛海向扶南。忽遇恶风堕鬼国。便欲尽食。一舶众人怖称观音。中有一小乘沙门不信观音。不肯称名。鬼索此沙门。沙门狼狈学称亦得免脱。次观释者不但明世界中风。黑业名风。华严云。嫌恨猛风吹罪心火常令炽然。吹诸行商人堕落恶道。失人道善宝及无漏圣财。从地狱上至三禅。皆有果报风难。如僧护经明地狱种种形相。疾风猛浪没溺破坏。饿鬼所啖若鬼道中寒风裂骨身碎碑。[石*妻]畜生飞走之类倾巢覆卵何可胜言。修罗亦有风灾。若风灾起时诸山击搏。上至三禅宫殿碎为微尘。当此之时谁能救济。唯当一心称观世音菩萨。以王三昧力。或以手障或以口吸。无量方便令得解脱也。次明若修诸善恶。业风吹坏五戒十善船舫。堕三途鬼国及爱见境中。大经云。罗刹妇女随所生子而悉食之。食子既尽复食其夫。急须称观世音菩萨。以慈悲力能令解脱。次明二乘人采圣财宝。为烦恼风吹慧行船。行行舫堕见爱境。为见爱罗刹所害。若能称观世音得脱见爱二轮。永得免二十五有黑业也。次明支佛六度行通别圆变易等。入烦恼海采一切智宝。八倒暴风所吹飘。诸行船堕二边鬼国。用正观心。体达诸法不生不灭。入实际中。即得解脱。鬼义合前后章故不重说也。法界风难无量一时圆应者。皆由别圆慈悲所熏。菩萨本修别观。见事中风即起慈悲修戒定。见恶业风即起慈悲修三观时。节节慈悲令入风实相王三昧中。以事慈悲救果报风。以戒定慈悲救恶业风。三观慈悲救烦恼风。故能十番拔难。若作圆观论机应者。但观风字门具照十法界。三谛宛然通达无碍慈悲遍覆。若分别说王三昧者。以十七三昧救果报风。以二十四三昧救修因风。以二十五三昧救二乘通别圆从假入空烦恼风。以二十五三昧救别教出假无知风。以二十五三昧救圆教入中无明风。变易可解。如是遍救法界。一切一时皆得解脱也。第四明刀杖难者。亦为三。一贴文二约证。三观释。贴文为三。一遭难即是苦。二称名即是善。三应。今言刀杖段段坏者。明人执杀具。一折一来随来随断。弥显力大

问。水火何不令再灭耶

答。刀杖折再来重明圣力。水火灭后谁复持来。既无持来灭何所显。今只令绝炎不烧洪流更浅。存显力大各有其意。不得一例作难也。二约事证者。应验传云。晋太元中彭城有一人被枉为贼。本供养金像带在髻中。后伏法刀下但闻金声。刀三斫颈终无异。解看像有三痕。由是得放。又蜀有一人檀函盛像安髻中。值姚苌寇蜀。此人与苌相遇。苌以手斫之闻顶有声。退后看像果见有痕。其人悲感。宁伤我身反损圣容。益加精进。晋太元高简荣阳京人。犯法临刑一心归命。钳锁不复见处。下刀刀折。绞之寸断。遂卖妻子及自身起五层塔在京县。宋太始初四方兵乱。沈文秀牧青州。为土人明僧骏所攻。秀将杜贺刑妻司马氏云云。三明观释者。非但世间杀具名为刀杖。恶业亦能伤善业身命。烦恼六尘三毒等皆名刀箭。从地狱去即有刀山挂骨剑树伤身。锯解屠脍狼籍痛楚。饿鬼更相斩刺互相残害。畜生自有雌雄牙角自相触突。又被剉切[利-禾+皮]剥。修罗昼夜征战。龙王降雨变成刀刃。人中前履白刃却怖难诛。复有横尸塞外。复有衔刀东市。天共修罗斗时五情失守。皆有刀杖怖畏失命之苦。若能称观世音。若应刑所刀寻断坏。若应战阵立之等力令得安和。次明修诸善因。为三毒刀箭恶业破坏善心。割断戒皮定肉慧骨。微妙心髓法身慧命。退失堕落失人天道。乃至正命登难崩易。万劫不复起怖畏心。称观世音即蒙救护。三毒不伤清升受乐。即菩萨力也。次明声闻人厌患生死。即时观三界见思剧于刀箭。故大经云。宁以终身近旃陀罗。不能暂时亲近五阴爱诈亲善六拔刀贼。趣向正路如为怨逐。大论云。譬如临阵白刃间。结贼未灭害未除。如共毒蛇同室居。如人被缚将去杀。尔时云何安可眠。五苦章句云。十二重城三重棘馆五拔刀人守门。尔时思惟如此怖畏何由得脱。着于正路。须一心称观世音。三业至到机成感彻。则能裂生死券度恩爱河。不为烦恼刀杖所害。欲主魔王无如之何。次明支佛。次明六度行。次明通别圆变易等。五住刀箭伤法身损慧命者。若能称名即蒙圣应。免离通别刀杖脱二死地。岂非法身慈力耶。复次明刀杖机应遍法界者。良由本修别圆观时。见诸锋刃伤毁。即起慈悲我当救护。修善遮恶时。于善恶业复起慈悲。若观刀杖是因缘生法修三观时。复起慈悲愿行填满。今住王三昧中。无量神力以本事慈悲对果报刀箭。修善慈悲救恶业刀箭。三观慈悲救烦恼刀箭。刀杖是质碍属地字门摄。菩萨于质碍地门通达明了。如华严四十明。弥多罗童女于师子奋迅城师子幢王宫中。处明净宝藏法堂。不可思议庄校此堂。一琉璃柱一金刚壁一摩尼镜。诸宝诸铃诸树诸形像诸璎珞中。住是一切质碍具内。悉见一切如来从初发心行菩萨道。乃至成等正觉入灭。皆于中现无不明了。如于净水见月影像。此法门名般若普庄严法门。善财入此地法门时。能得不可说陀罗尼大慈大悲陀罗尼。能作佛事陀罗尼。一切法无不具足。当知地字门普应一切令得解脱也

复次圆观观地大质碍之法。摄一切十法界三谛宛然。明了在地门中。圆起慈悲遍于法界。寂而常照无机不应。若欲分别说之令易解者。以十三昧救果报刀杖。以二十四三昧救三毒刀杖。以二十五三昧救入空烦恼刀杖。以二十五三昧救出假无知刀杖。以二十五三昧救入中无明刀杖。一切一时皆得解脱。第五鬼难亦为三。一贴文。二约证。三观解。贴文为四。一标处所。二明遭难即是苦。三称名即是善。四应。三千大千满中者。此假设之辞也。若言满中复。更从何处来。知是假言尔。上水火何不假设满大千耶。鬼有心识相延故满假设为便。水火无心假设为难。鬼所以畏者观音有威有恩。若非怀恩则是畏威。所以闻名尚不能加于恶眼。岂容兴害心。害心恶眼二俱歇也。次约事证者。次观解者。若果报论鬼难者。地狱道亦应有弊恶大力鬼恼诸罪人。鬼道中力大者恼于小鬼。畜生道鬼亦啖畜生。人中可知诸天既领鬼何容为鬼所恼。如阿含中云。有大力鬼忽坐帝释床。帝释大嗔鬼光明转盛。释还发慈心鬼光明灭即去。天主既为鬼所恼。何况四王修罗道耶。如是等处鬼难怖畏称观世音。即不能加害也。次明修因者。自有恶业名为鬼。自有鬼动三毒。如阿含云。淫亦有鬼鬼入人心则使人淫佚无度。或鬼使嗔使邪。当知鬼亦破善。三毒当体是鬼者。淫破梵行。嗔破慈悲。贪鬼恼不盗戒。嗜鬼恼不饮戒。乃至十善诸禅亦如是。皆为恶业鬼毁损。人天动不动业若能称名即不加害也。次明烦恼鬼者。见心为男鬼。爱心为女鬼。若论此鬼即得满三千大千世界。非复假设之言。何以故。以见使历三界有八十八。爱历三界合有九十八。岂不遍满。此鬼欲来恼二乘人乃至六度通别圆等行人。大经云。唯愿世尊。善良咒师当为我等除无明鬼。又云。愚痴罗刹止住其中。岂非烦恼鬼耶。若称名诵念观智成就。能令见爱尘劳随意所转不能为害也。次别圆本观慈悲机应者。别观菩萨初发心时。见诸恶鬼恼乱世间。无能救解。如讫拏迦罗等恼毗舍离。是故菩萨兴起慈悲为作拥护。若修诸善为恶所坏。亦起慈悲令善成就。若观此鬼及以业鬼。皆是因缘生法从假入空出假入中。皆节节慈悲誓愿。于诸烦恼深达实相成王三昧。以誓愿熏修法界众生。若遭鬼难能遍法界救护。以事中慈悲救果报上鬼。修善慈悲救恶业鬼。以三观慈悲救爱见无明等鬼。悉令诸鬼堪任乘御。不能为恶眼视之。如华严四十三迦毗罗婆城。娑婆陀夜天。于日没后见处虚空。见其身上有一切星现一毛孔中。见所化众生。或生天上或得二乘。或修菩萨行种种方便皆悉见闻。尔时夜天告善财言。我于恶众生发大慈心。不善众生发大悲心。于声闻缘觉发安立一切智道心。我见众生远离正道趣于邪径。着诸颠倒虚妄迷惑受众苦恼。我见此已。无量方便除诸邪惑安立正见。故知法身菩萨以夜叉鬼身。能作如此安立众生。观音菩萨于此鬼神法门。岂不通达。普应一切令得无害。若圆观识种是爱见鬼门。一切法趣此识种鬼法门。十法界三谛具足无缘慈悲。普被一切即是鬼门。王三昧力遍应法界。若分别说者。以十三昧救事鬼。二十四三昧救恶业鬼。以二十五三昧救二乘通别圆入空鬼。乃至入中道。一切一时俱不加害。第六枷锁难亦为三。一贴文。二约证。三观释。贴文为四。一标有罪无罪。二遭难。三称名。四应。上临当被害此定入死目。此明有罪无罪。或是推检未定。或可判入徒流。若判未判俱被禁节。明圣心等本救其囚执。不论有罪无罪也。在手名杻在脚名械。在颈名枷连身名锁。此则三木一铁之名也。系名系碍检是封检。系未必检检必被系。系而具检忧怖亦深。鸟死声哀人死言善。若能称观世音者。重关自开铁木断坏。次引事证者应验传云。盖护山阳人。系狱应死。三日三夜心无间息。即眼见观音放光照之。锁脱门开寻光而去。行二十里光明方息。张畅为谯王长史。王及畅系廷尉诵经千遍。锁寸寸断不日即散。虚丞相云云。三观释者。地狱体是囹圄。鬼及畜生亦有笼系。修罗亦被五缚。北方及天上自在应无此难。降是已还无免幽厄。若能称名皆得断坏也。次明修因恶业即名枷锁也。诸业虽有力不逐不作者。若有造业果终不失。故云不失法如券。若人修习诸善被恶业覆。如大山映覆于心。使善败坏更增恶业。恶业即招果缚无由可解。若欲脱此业者因时可救。急称观音能令三恶业坏。故经云。妻子以为锁械。钱财以为牢狱。王法以为狱籍。遮碍行人不得修道。望现在是果报缚。望过去是业。次明声闻者。凡夫及三果皆是有罪。罗汉是无罪。大品云。摩诃那伽虽有罪无罪同在三界狱中。五阴绳所缚三相无常检束印封之。权实上惑名杻。定慧上惑名械。中道上惑名枷。法身上惑名锁。如是等束缚行人不能得脱。称名系念必蒙灵应。若发定慧是械断。若发权实是杻断。若破无明是枷断。法身显现是锁断。入无余涅槃是缚断。免三相是离检。出三界是出狱。此复有通别意。次明支佛六度行通别圆。若论枷锁犹是地质碍。别圆本观所起慈悲遍应之义不异于前。若三千大千以表空种。王贼鬼等以表识种。论其十番普应此亦如前论其本观。今当说菩萨见众生以空识成果报身。还为空识所恼。修诸善时空识之业亦能坏善。观空识有三谛之障有三谛之理。如是节节皆起慈悲。悲欲拔众生苦。慈欲与众生乐。故净名云。菩萨观四大种空种识种皆空空故。无四大无空无识。是为入不二法门。成王三昧能遍十法界垂应。以事中慈悲。救果报空识难。以修善慈悲。救恶业空识难。以三观慈悲。救烦恼空识难。故知观音于空识法门而得自在。华严三十九善住比丘于虚空中大作佛事。若作圆观。观空种因缘性相本末究竟等。则一切十法界悉趣空门。识亦如是。起无绿慈悲熏诸众生。十法界有机即能一切一时而得解脱。第七怨贼难亦为三。一贴文。二约证。三观释。贴文为四。一标难处。二标遭难人。三明有机。四明应。难处者先明处。即是大千国土。次明难即满中怨贼满中假设之辞也。国旷贼多圣力能救显功之至也。怨者此难重也。贼本求财怨本夺命。今怨为贼必财命两图。若过去流血名怨。现在夺财名贼。如此怨贼遍满大千尚能护之。轻者岂不能救也。二标遭难人者。即商主也。此又为四。一明主。二有从。三怀宝。四涉险。商者训量。此人择识贵贱善解财利商量得宜。堪为商人之主。既有商主即有将领。诸商人既涉险远所赍者。必是难得之货。故言重宝也。险路者或可旷绝幽隘。名为险路。或值怨贼冲出之处。名为险路者也。机者亦四。先明一人安慰。二劝称名。三叹德。四众人俱称。所以安慰者止其恐怖也。所以劝称名者设其上策也。所以叹德者奖令定胆也。若不安慰则怖遽慞惶。虽安慰止怖。若不设计唐慰何益。故劝称名。虽劝称名。若不叹德设计。则心不定胆亦不勇。所以叹德。故知此菩萨决定能施无畏。决果依凭三义既足。俱时称唱机应即得解脱也。南无云归命。亦称为救我。次结口机也。今言观音势力既大加护亦旷。岂止七难而已。当知遍法界皆能救护。故言巍巍。巍巍者。重明高累之辞也。明观音之力出于分段之外竖应二土。故言重明。载沐神应故言高累。以是义故。故言巍巍如是也。二约事证者。应验传云。慧达以晋隆安二年。北陇上掘甘草。于时羌饿捕人食之。达为羌所得闭在栅中。择肥者先食。达急一心称名诵经。食余人稍尽。唯达并一小儿次拟明日。达竟夜诵犹冀一感。向晓羌来取之。忽见一虎从草透出咆哮。诸羌散走虎因啮栅作一穴而去。达将小儿走叛得免。又裴安起从虏叛还。南至河边不能得过。望见追骑在后死至须臾。于是称观世音。见一白狼安起透抱。一掷便过南岸。即失狼所。追骑共在北岸望之叹惋无极。道明于武原劫夺船道往径遇贼难等。三观释者。若果报论怨贼者。从地狱至第六天皆有斗诤。如阿含云。忉利战不如修罗。索援至第六天。如此怨会称名得脱也。次修善时恶多是怨。犹如冰炭。称名恶退善业成就。如闇灭明生。次明烦恼为怨贼者。一切烦恼是出世法怨。商主是三师羯磨。受戒人是商人。无作戒是重宝。五尘是怨贼。或法师是商主。商人是徒众。理教是重宝。两遇魔事是怨贼。或心王是商主。心数是商人。正观之智是重宝。觉观为怨贼。或般若是商主。五度万行是商人。法性实相是重宝。六蔽是怨贼。将此意历诸教义自在作。悉成称名即得解脱也。复次约怨贼难结成别圆慈悲应。例前可解云云

观音义疏卷上观音义疏卷下

        隋天台智者大师说　弟子灌顶记

第二从若有众生多于淫欲去。是明意机也。释此为二。初贴文二观解。贴文为二。初正明意机。次结意机。意机约三毒为三章。章各有三。一明有苦。二默念。此两即是明机。三明离即是明其应三也。通称毒者。侵害行人喻之如毒。但名有单复。有人解云。三毒多者不知其是过故不求观音。少者念观音梵行之德。所以能感。意谓此解乖文。文云。若有众生多于淫欲念即得离。云何对面违经耶。今明三毒多者。能念观音菩萨有力令多得离。何况少相。此则以多况少尔。大论云。女人违戒垢谤法余殃。不择禽兽不避高墙广堑之难。不计名闻德行。破家亡国灭族倾宗。祸延其身。如术婆伽祸延其国。如周败褒姒。净住及禅经明。多欲人有欲虫男虫泪出而青白。女虫吐血而红赤。又言。有欲鬼娆动其心令生倒惑。如大经云。若习近贪欲是报熟时。此举多欲相也。若少欲人虫鬼潜伏。无过狂醉是少欲相。嗔恚多者今世人不喜见。如渴马护水如射师子母。故遗教云。劫功德贼无过嗔恚。华严云。一念嗔起障百法明门。菩萨以嗔乖慈障道事重。大集云。一念起嗔一切魔鬼得便。涅槃云。习近嗔恚。若例淫恚亦应有鬼。如柰女经。嗔则有蝎虫是名多嗔相。与上相违是嗔少相愚痴多者邪画诸见。拨无因果谤毁大乘。如大经。例前亦应有虫鬼。三毒过患如此。欲离此故至心存念观音。即得离也。有人解云。起伏相违称之为离。非灭离也。今谓经文说离何意言非。若依请观音者。净于三毒根成佛道无疑。今作十番明救三毒。三番是伏惑论离。七番是断惑论离也

问。离烦恼须智慧。但念岂得离耶

答。经称常念即是正念。体达烦恼性无所有。住贪欲际即是实际。绝四句无能无所念性清净。如此正念非是智慧。更何处觅智慧。此慧不离烦恼。其谁能离耶。若如所难必须别用。智慧破烦恼者。此则有惑可断有智能断。非唯惑不可断慧还成惑。岂得名断惑之慧耶。今此正念不以色念不以非色念。如是四句亦以色念亦以非色念。如是四句或次第论非念。或不次第论非念。或不次第论念。或次第论念。或次第论离。或不次第论离。次就观解者。七番例上可解。今但顺逆两意约界外作也。不取分段三毒相。今取善欲之心名贪。大经云。一切善法欲为其本。二乘欲乐涅槃名贪。厌生死名嗔。不达此理名痴。开三毒即有八万四千宛然具足。净名云。结习未尽华则着身。二乘未断此三毒。即变易三毒相也。未断别惑菩萨亦同有此三毒。故云菩萨贪求佛法于恒沙劫未曾暂舍。多学问无厌足即贪相。恶贱二乘不喜闻其名。故言宁起恶癞野干心不起二乘心。如大树折枝之譬。岂非嗔相。无明重数甚多。佛菩提智之所能断。佛性未了了者皆是痴相。欲除此三烦恼故。常念观音随机应赴即得永离。永离有两种。若此菩萨于生身中全未除别惑。就变易论全未永离。若生身中已侵别惑。就变易中除残论永离。次明逆说三毒观者。一切众生名为少欲嗔痴。何以故。止嗔三途之苦。贪人天之乐。二乘只嗔生死欲得涅槃乐。皆名为少。菩萨不尔。乐求佛法非但求一佛法。遍求一切不可说佛法。如海吞众流犹自不满。非但不受生死亦不受涅槃。故大品五不受此即大嗔。无明力大佛智能断。菩萨于无明大力之惑尚在。又痴如虚空不可尽。乃至老死如虚空不可尽。如此三毒即为三法门。一取二舍三不取不舍。大慈大悲四摄十力无畏三昧解脱无上菩提。净佛国土化度众生。名为取门。即大贪也。一切法空无所有不住不着。般若如大火炎四边不可取。大涅槃空迦毗罗城空。言语道断心行处灭。不以四句得菩提。无得无证即是舍门。名为大嗔也。中道非取非舍。不憎不爱。不断不常。无去无来。无生无灭。如镜中像不可见而见。见而不可见。非可见非不可见。遮二边故不可言说。净名杜口名为中道。此即大痴。故文殊云。我是贪欲尸利嗔恚尸利邪见尸利。此即其明证。欲满此三法门。常念观音即得满愿一切。圣人自行化他无不从此三门而入。离此更无有道。故无行经云。贪欲即是道。恚痴亦如是。如是三法中。具足一切佛法。一切佛法不出万行波罗蜜。不受三昧广大之用中道实相。此三法门不可宣示。愍众生故或作顺说或作逆说互有去取。此即四悉檀意赴缘利益。如华严四十二明。险难国宝庄严城婆须密多女。说离欲际法门。一切众生随类见我。我皆为其女像。见我者得欢喜三昧。共我语得无碍妙音三昧。执我手得诣诸佛刹三昧。共我宿者得解脱光明三昧。目视我者得寂静法门。见我嚬伸得坏散外道法门。阿[黍-禾+利]宜我者得摄一切众生三昧。阿众鞞我者得诸功德密藏。住是离欲法门广为利益。此岂非逆顺欲法门导利群品耶。又四十一满幢城满足王。于正殿行王法。其犯法者斩截烧煮劈裂屠脍。嗔目诃责苦楚治罪。善财生疑。王断事已执善财手入其宫。见不可思议境界不可譬喻。语善财云。我知幻化法门。化作众生。而苦治之。以调一切。其见闻者发菩提心。此岂非嗔法门。方便命婆罗门五热炙身即是痴法门如前说。次此应明别圆两观观三毒慈悲机感例可知。不具记。第三从若有女人去。明身业为机亦为三。一贴文。二引事证。三观解。贴文为二。一求愿满。二结叹求。又为二。一求男二求女。文云。女人求男若是无子则绝嗣。有子则父母俱欣。云何独标女人求男耶。解者或云。女厌女身非求子也。又解女性多爱欣子偏重故标女人。今解女人以无子为苦。夫之所弃并妇所轻旁人所笑。又妇有七失。六犹可忍无子最剧。容恶性妒不能事公姑贪食无子拙。无子既苦故以标女人求男也。求男文为三。一立愿。二修行。三德业。愿与行如文。德业者。明士有百行智居其首。若但智而无福则位卑而财贫触途壈坎。智与福合弥相扶显福则财位高升。慧则名闻博远。故言便生福德智慧之男也。求女文中但明愿与德业不明修行者。行同礼拜故不重论。愿德既殊故须各辩。女人端正七德之初。但端正无相者或早孤少寡相禄不佳。今明貌与相相扶弥显其德。端正则招宠爱相则招于禄敬。故文云。众人爱敬。若爱带慢何谓为德。爱而敬之故是相也。有人解。宿植德本是释疑。众人咸谓。观音但能交会父母智慧端正儿之宿植。若是观音与其智慧端正。则堕无因之过。私难此语。若言福慧是儿业。观音唯能会其受生。儿无生缘观音会生。儿无福慧观音亦能使有。观音遂不能令无福。种福何能使无生而生。论福畏堕无因。论生何不畏堕无因。若尔。圣人全不能与福慧。只能作媒人。此不可解也。难观音不能令儿有福慧者。上一人称名多人皆脱罗刹之难。此无因而不与彼。无机那忽脱耶。今明圣力甚大无所不与。能使先世有福慧者托生也。纵令先世不植善缘。亦能令其于中阴中修福。此义出中阴经也。今不取此句为释疑之意。若有礼拜福不唐捐。此结成身业之机。亦是释疑之义。结义可解。释疑者若言礼拜愿满。自有礼拜不蒙愿满者。何得云不唐捐。唐者言徒。捐者言弃。由心不志即愿未满。礼拜之功冥资不失。此得是释疑也

问。礼拜是身业机亦应脱水火等难不

答。此举男女为言端尔。次引事证者。应验传有人姓鬲。四月八日生月氏国痴人。次观解者。果报求男女者如阿含中。地狱界已上乃至欲天皆有无子之苦。礼拜求愿亦能满心。次明修因论男女者。先辩法门。次明与愿。法门者无明为父贪爱为母。六根男六尘女。识为媒嫁生出无量烦恼之子孙。此男女不劳愿求任运成眷属也。若外书以天阳地阴沈动为男女。何况佛法而无此耶。若就佛为国王经教为夫人。出生一切菩萨佛子。又善权方便父。智度菩萨母。一切诸导师。无不由是生。又慈悲为女善心为男。或禅定静细为女。观慧分别为男。二乘定多慧少。菩萨定少慧多。大经云。若闻大涅槃佛性之法。当知是人有丈夫相。正观刚决为男。无缘慈悲含覆一切为女。今借世间男女以表法门尔

问。那得以男女表法门。无男女故即无法门。如大经永离十相名大涅槃。大论云。无男女相故名无相。净名云。一切诸法非男非女。如佛所说亦非男非女。安乐行云。亦不分别是男是女。入不二法门云。无声闻心即无于定。无菩萨心即无于慧。小乘三藏缘谛理。吾闻解脱之中无有言说。成论入空平等亦无男女。男女既无所表安在。故知无定慧法门也

答。大乘实相不当有男女及无男女。善巧方便以四悉檀说于有无。天女云。无离文字说解脱义。文字性离即是解脱。皆以文字有去来今。非谓菩提实相亦尔。非有非无非二而二。明此二法未曾相离。譬如一身有左右手。定慧亦尔。定静慧照。虽复二分。不离法性。言定即有慧。言慧即有定。譬如女人而有左手。亦如男子而有右手。定慧亦尔。无缘之慈具正观慧而以定当名。中道种智。具大慈定以智标目。何但理然今文亦尔。文云。便生福德智慧之男。此语自具二法门何劳有疑而称男子也。文云。便生端正有相之女。端正无邪丑表中道正观。离二边之丑。即慧义也。相即三十二相慈心所种。即表定义也。虽具二而名女。故知此文若作男女二解。即表定慧不二而二。若作不二解。即表定慧二而不二。理实非二非不二。赴缘为二为不二。即是表二法门文义斯在。次明应机满愿者。果报满愿如前说。修因者。若就修五戒事论。不杀是仁不盗是廉。属女表定法。不妄语是质直不淫是贞良不饮酒是离邪昏。此属男表慧法。若不得此五戒男女。则失人天道。孤独堕在三途。归命求救五戒完全即男女愿满。十善例可知。修禅时。方便修慧精进等三方便为男。念一心为女。若就支林。觉观喜为男。乐一心为女。乃至非想禅禅中细作可解。次明声闻男女者。五停心观。治嗔用慈治散用数。此二为女。治贪用不净。治痴用因缘。治障道用念佛。此三属男。又直缘谛理正智决断名为男。出观用法缘慈为女。若不得此两法。即当堕落凡夫。为火宅烧害贫穷孤露。若蒙垂应五停心男女生即得入真。出观男女生得入假。二义既满则不复畏二十五有也。次支佛者。缘方便道起慈观名女。慧观为男。若发真缘理名男。出观缘慈名女。支佛譬鹿犹有回顾之慈也。若不得如此定慧。何由速出殷勤求法。若得愿满坦然快乐。次明六度菩萨。菩萨有慈悲不断惑在生死利物名女。行六度方便智慧名男。女人法应生子。慈悲法应受生死化物。化于前人善心开发。即是生子义。前人生五度者是生女。前人生智慧是生男。若定慧义不成。则菩萨行不立。故求观音而获愿满。次通菩萨。既断烦恼则有智断缘谛理之慧为男。慈悲扶余习入三界名女。何以故。如男法不生表智慧决断断于烦恼。不生三界而今还生者。乃是慈扶余习故得更生。称之为女。求愿观音蒙此愿满。次明别教十信菩萨。修福德庄严五波罗蜜为女。从一地二地智慧庄严为男。三十心名男女交处圣胎。初地中道正智开发名为男生。无缘慈心发名为女生。此两要在初地方得开发。亦名男女双生。若不如此即堕二乘生死两边之过。生此男女者生大欢喜故称欢喜地。慈悲被物物荷恩故称为大慈大悲。大慈大悲能成佛道生出般若。是诸佛之祖母故称为大女。十力无畏等众生不知故不名为大也。次圆教以无缘慈悲种三十二相业亦名为女。此女端正有相以中道智慧为男。此男质直福德。十信六根清净名为处胎。初住慈智男女双生。若得此男不畏爱见大悲顺道法爱。亦不畏无慧方便缚无方便慧缚。方便与慧俱解者。即男女具足二求愿满也。变易两番可解

复次从五戒十善齐第六天已来皆无禅定。番番悉是散心慧法狂男子也。但慧无定四禅有支林一心名为男女福慧备也。从三界定慧男女。男无破惑之功。女无生出无漏之力。此无用之男女。从二乘通教等。慧有断惑之用。则是干事之男。女有发生无漏绍继之德也。从二乘通教所有定慧不能破无明见佛性虽男而女。定则不能怀于中道之子犹如石女。虽女而男。故大经云。二乘之人定多慧少不见佛性。通教菩萨之人慧多定少亦不见佛性。自此之前我等皆名邪见人也。唯有别教登地真明慧发无缘慈成。此乃名为真正男女。圆教初住见中道时。定慧具足男女相满。方称经文男则福德女则端正。故知借事表法。何得作媒嫁解观音耶。第三从是故众生去。是劝受持也。即为三。一劝持。二格量。三结劝。持者上说观音得名因缘其力广大。既不辩形质相对正述名论德。若欲归崇宜奉持名号。故举持名为劝也。二格量为四。一格量本。二问。三答。四正格量。格量本者举三多。六十二亿举福田多。尽形寿举时节多。四事具足举种子多。旧但三意今持名号多。凡举四多为格量本也。次问答如文。次正格量者。还举四少以格四多也。功德正等持名少田少时少种子少

问。何意以少敌多

答。佛眼称量不增不减。四多重倍功德正齐如此。格量秋毫无谬

问。何意等

旧解有五。一云其福实殊引物论等。此解乃是虚谈。观音遂无实德可贵也。二云田有高下薄瘠所致。如供养百初果不如一二果乃至无学。此亦非叹德之意。乃是以下比高法应优劣尔。三心有浓淡故令福不等。四时得解不得解。此二释皆是前人心力致福。何关观音德高也。五有缘无缘者。如供毁路人罪福浅。供毁父母罪福深也。今明一多性不可得无有二相。一则非一多则非多。同入如实际实际正等无异。一中解无量故说六十二亿。无量中解一故说观音展转生非实者。则是一无一实一从无量生故。多无多实多从一生故其理正均。故言不异智者。无所畏者照其事理既明不生疑畏。故言正等也。法华论云。毕竟决定知法故。法即法性真如法身。是故六十二亿佛名与观音名功德无差别也。又约观解者。二观发中道二观实不等而言等者。以中道等故。故言为等。如乞人等彼难胜如来故言等也。三结成一时称名福不可尽。大品云。一华散空乃至毕苦其福不尽。如文第二问答。从无尽意白佛言云何游娑婆下前

问。何缘得名佛

答。众生三业显机为境法身灵智冥应。境智因缘名观世音。此义已竟。今问。云何游此娑婆世界。佛答以普门示现。三业显应应众生冥机等十义。一问二答。问即为三。一云何游是问身业。云何说是问口业。方便是问意业。此是圣人三业无谋而遍应一切。亦名三不失三轮不思议化也。亦名三不护。三不护者。明观音住不思议圆普法门。实不作意计校筹量。次第经营方施此应。既无分别亦无前后。任运成就譬如明镜随对即现一时等应。故言三业不护也。三无失者。众生根机不同深浅有异。观音虽不作念逗机。逗机无失契当前人。冥会事理故言不失。三轮不思议化者。若示为佛身亦示佛心佛口。乃至示执金刚神身。亦示金刚心口。虽普现色身屈曲利物。于法身智慧无所损减净名云。善能分别诸法相。于第一义而不动。不动而动。此乃不思义化故也

问。意业云何可示

答。圣意无能测者。若欲示之。乃至昆虫亦能得知也。佛答为三。一别答。二总答。三劝供养。初别答还答三问。应以之言是答其方便之力意业问也。何以故。意地观机见其所宜。宜示何身宜说何法。随而化之。故知应以是答意也。现身是答身业。说法是答口业。故知具答三问也。又但作二答兼得于三。论其现身不止色阴而已。必具五阴。即兼答意也。口亦依身即兼答口。若说法者不止如树木无心。欲知智在说巧运四悉檀方便。即兼口以答意也。二释俱明答三问也。从别答中凡现三十三身十九说法。束为十界身。而文阙二界者。或指上品云菩萨身。或翻脱落或依古本正法华文。或言观音即是菩萨身。何须更现若三解皆有难今所不用。今依古本为明菩萨义故。然菩萨一界或权或实。种种应化义不可阙。故释菩萨界也。又无地狱界身者。或指上品或言苦重不可度。或言其形破坏人见惊畏故不现。今明别释虽无总。答中有文云以种种形游诸国土。何得言无耶。又请观音云。或游戏地狱大悲代受苦。或言止代受苦不论说法。若依方等婆薮教化即有说法。释论云。菩萨化地狱多作佛身。狱卒见不敢遮。以此而推。应有地狱界身说法也。若尔。十法界身则为具足。今通约十身四句料简。自有一界身度一界。自有十界身度十界。自有一界身度十界。自有十界身度一界也。若妙觉法身应实报土。为舍那佛受化之人。纯诸菩萨皆求佛道更无异身。此一界度一界也。若方便有余土五人同生皆求大乘。上文云。而于彼土求佛智慧于此土为佛。亦是一界度一界也。若同居土寂灭道场。初成佛先开顿说。禀教之徒皆有见思烦恼之人。而是圆机同感佛身。亦得是一界身度一界也。若寂灭道场禀教之徒诸界不同。或人或天龙神鬼等。又根性圆别两异。虽诸界不同同见一佛身而为说法者。即是一界度多界也。若有一界之机但见一界身现则不得度。则示种种之身眷属围绕。共逗一缘。是名多界身度一界也。若佛身菩萨身遍作十法界身。遍入诸道各令得见。同其形像而为说法。此是多界度多界。用此四句。历五味五时现身皆如此

复次约说法多少者。如善财从百一十知识闻诸法门。则多法为一人说。如净名云。为声闻说四谛。为缘觉说十二因缘。乃至为梵王说胜慧。为帝释说无常。一人用一法为一人说。若如通教说般若三乘人同禀。此则一法为多人说也。若是一切无碍人一道出生死开佛知见。此则多法为多人说。复次因果相对明多少者。五戒十善因少果亦少。声闻五停心暖顶等入二涅槃此因多果少。支佛见花飞叶落即得道此因少果多。诸菩萨万行成就万德果圆因多果亦多。观音明了众生根之所趣。或示现身多少。或说法多少。或修因多少。或证果多少。逗彼机宜必无有差。有人云。现因身说果法。现果身说因法现一身说多法。现多身说一法。或现身而无说。此比十法界机狭。旧释三十三身为三。初三乘人。二四众。三八部。各有枝末以人天为圣末。以其是受道器故。童男童女为四众未。可成四众故。执金刚为八部末。同有大力故。若尔。执金刚力大何意为末。答此最在后为掩迹故也。今明三十三身文为八番。一圣身。二天身。三人身。四四众身。五妇女身。六童男女身。七八部身。八金刚身。明其次第出自人意尔。一明圣人先明佛者。为是应佛为是化佛。但圣人逗物具有二义。若一时欻有为化。应同始终名应。若寻此文明于应义也

问。何不以真佛为众生说法而以应耶

答。佛身多种。若应化非真佛。亦非说法人。真佛者据妙觉法身究竟极地毗卢遮那乃名真佛。真佛渊远不可说示。云何能解。如妙音所作文殊不知。况下地凡夫为示真身耶。如为牛羊弹琴不如作蚊虻之声。若从妙觉应。为实报圆满相好光明无量。同四十一地实报土众生。为说一实谛正真之法而教化之。如此之应非余界所堪也。何以故。此等诸地已分入地位。不可以余界身应。亦不得以余佛身应。如此应者唯应彼土。非余土所堪也

复次变易土明应佛者。小乘经云。三界外无生大乘五种意生身方生方便土。此即三界外受生生变易土也。释论云。法性身菩萨生三界外。既有生宁无应佛。法华云。我于余国作佛更有异名。即是此义也。此应佛即有两相。一示胜应身。圆满相海如前实报之应。二示劣应。令见者劣于前。但为二佛更不示为种种诸身。何故尔。五种意生利钝之别。赴此根性故示二身。但说次第不次第两种大乘。故不须余身余法化也。若圆人无明未破及已分破。别人于回向中及分破无明者。此人生于彼土则利。别人未修未破。及通教断惑者。三藏中断惑者。生彼皆钝也。凡圣同居土明应佛者。土有二种。一净二秽。如富楼那土西方等土。其中众生具三毒见思。无三恶名果报严净。此名净土。如此娑婆三恶四趣荆棘丘墟。是名秽土。若净若秽皆是凡圣同居土也。二土众生各有二种。根利浊重根钝浊重。根利浊轻根钝浊轻。浊重者若娑婆众生身形丑恶矬短卑小。命止八十或复中夭。烦恼炽盛诸见心强。时节粗险。是为五浊重也。净土不尔。是为五浊轻也。何故尔。不多修福德生重浊土。多修福德生于轻土。若秽土中生有戒乘俱缓。有乘急戒缓。有乘缓戒急。有戒乘俱急。戒急受人天身。乘急有感圣之机机有二种。一大二小。小机则示三藏佛身说法。大机应以舍那佛身说法。是故降神母胎即示两相。顿机所感即见舍那菩萨与百千围绕处胎说法。十方众圣皆在胎中。出胎光明遍满寂灭道场。成卢舍那佛转一实谛无量四谛等法轮。譬如日出高山前照。即闻顿教见佛性得度也。故涅槃云。雪山有草名曰忍辱。牛若食者即得醍醐。此之谓也。若小机之人感佛。正念入母胎出生王宫。六年苦行树下坐草。成老比丘佛。于鹿野苑转生灭四谛法轮。拘邻五人初得甘露悟小乘道。既非醍醐未名得度。故云。但离虚妄名为解脱。其实未得一切解脱。未堪大教如聋如哑。于其无益于大教中。止有冥勋之力。取譬如乳。闻方便说三界断见思时。尔时转乳名酪。次闻方等四种四谛。用大弹小耻权慕实。起殷重心名为生酥。次闻般若三种四谛转教。其心稍纯名为熟酥。次闻法华舍三方便。但说一实佛之知见。声闻疑除受记作佛。菩萨迷去增道损生。尔时名为醍醐。菩萨之人处处得去。钝者亦同二乘。二乘之人始自于此得见佛性。故云。始见我身闻我所说。即皆信受入如来慧。证前大机人初得醍醐也。除先修习学小乘者。我今亦令得闻此经入如来慧。即证小机始于法华得入醍醐也。若复有钝根于法华不悟。更于般若调熟至于涅槃。说胜三修。即明常住得见佛性。乃是醍醐。是为同居秽国示现佛身说圆渐法。或示种种身说圆渐法。四句此开五味义。秽国既尔净国亦然。既有利钝两机。宁不顿渐二说以明应身及说法也。此中应明别圆本观所起慈悲。今遍法界起应例前思之云云

问。经但言游于娑婆。不言实报方便等国

答。总答中云游诸国土诸是不一。岂止独娑婆耶。又如大本。文云。若能深观见我在耆阇崛山共声闻菩萨僧。此即娑婆而是方便也。又云。即见我纯诸菩萨无声闻缘觉者。即此是实报也。故约二土明义无咎

问。二土同称为法性云何异

答。真谛中道此则大异。次明应以菩萨得度者。或上地下地三藏通别圆等辅佛不同。若佛于实报作佛。观音即为实报菩萨形。或作方便土菩萨形。或作同居土菩萨形。赴利钝两缘。赴利缘者即如华严中法慧金刚藏等。赴钝缘者或如弥勒等。若佛转五味法门。法门兴废辅佛菩萨亦节节兴废。若权若实广利众生。此中亦应明别圆本观机应。次明应以支佛者。如文殊二万亿劫作支佛。化众生现身说法。次明应以声闻身者。或作三藏或作通教声闻。或作随五味转。声闻内秘外现庄严。四枯四荣引导众生。次引华严中诸菩萨比丘入法界所见住不思议法门者。成此义也。次引大经四种观十二因缘观。别圆本地慈悲不取不舍。今作四种圣人普应一切

问。佛云何度佛

答。等觉菩萨作佛身度初地佛。何意不得。如人亦能度人云云。二明梵身者。梵即色天主名为尸弃。此云顶髻。璎珞明四禅皆有王。此言梵者。应是初禅顶。犹有觉观语法得为千界之主也。观音修白色三昧不取不舍。不取故不随禅生。不舍故应为梵王说出欲论四句现身以权引实。应以帝释身者。此地居天主也。具云释迦提桓因陀罗。释迦言能。桓只是提婆。提婆即是天。因陀罗名主。能作天主。菩萨修难伏三昧不取不舍。说种种胜论。四句现身以权引实。自在天是欲界顶。具云婆舍跋提。此云他化自在。假他所作以成己乐。即是魔主也。净名云。多是不思议解脱菩萨住赤色三昧不取不舍。应为魔王令诸魔界即是佛界。四句现身以权引实。大自在即色界顶魔醯首罗也。楼炭称为阿迦尼吒。华严称为色究竟。或有人以为第六天。而诸经论多称大自在是色界顶。释论云。过净居天有十住菩萨号大自在。大千界主。十住经云。大自在天光明胜一切众生。涅槃献供大自在天最胜故非第六天。释论云。魔醯首罗此称大自在。骑白牛八臂三眼是诸天将。未知此是同名为即指王为将。天大将军者。如金光明即以散脂为大将。大经云。八健提天中力士。释论称魔醯首罗如前。又称鸠摩伽。此云童子。骑孔雀擎鸡持铎捉赤旛。韦纽此称遍闻。四臂捉贝持轮骑金翅乌。皆是诸天大将。未知此大将军定是何等四句相对。小王身者。或云天王为大人王为小。就人王中四种转轮王自有大小。如非四轮王者名粟散王。自有小大。中国名大附庸名小。传传相望。今言小者。小尚为之何况其大耶。此亦有四句。何独为福业受报。入同居土具足化他。共修功德慈心利物。是为王也。长者身者。应释十长人之德内合法门。居士者。多积贿货居业丰盈。以此为名也。宰官者。宰主义官是功能义。谓三台以功能能辅政于主故云宰官。郡县亦称为宰官。宰政民下也。婆罗门者。称为净行。劫初种族山野自闲人以称之也。一一身皆有四句本观。次列四众释如旧。次妇女者。不明小王妇女者。王家禁固不得游散。化物为难故不作。若如妙音即云于王后宫变为女像也。童男女者。取妙庄严二子释之。华严童子算砂嬉戏也。七明八部者。上列大威德天。今更举二十八天等。或可星宿掌人间者也。龙有四种。一守天宫殿持令不落人间。屋上作龙像之尔。二兴云致雨益人间者。三地龙决江开渎。四伏藏守转轮王大福人藏也。肇师但出三不出天龙。夜叉此云捷疾。此有三处。海岛空中天上。传传相持不得食人。佛初成道及说法传唱至天。乾闼婆此云香阴。帝释乐神。在须弥南金刚窟住。天欲作乐其心动。什师云。在宝山中住身有异相。即上奏乐也。阿修罗千头二千手。万头二万手。或三头六手。此云无酒。一持不饮酒戒。男丑女端。在众相山中住。或言居海底。风轮持水如云居其下。上文云。居在大海边。有大力口诃日月。日月为之失光。掌搏须弥须弥为之跛[跳-兆+我]。入海齐腰。见天饮甘露。而四天下采华。置四海中酿。海中众生业力持。进失甘露退不成酒。即断酒故云无酒。神不饮酒故得大力也。迦楼罗者。此云金翅。翅头金色因以名之。此鸟与龙约汝绕须弥令断。我搏海见泥。我不如输子为汝给使汝不如输子与我啖。天力持须弥不可断故龙输子。卵生食卵龙。不能食三生。湿生食二胎生食三。化生食四。紧那罗者。天帝丝竹乐神。小不如乾闼婆。形似人而头有角。亦呼为疑神。亦为人非人。今不取人非人释紧那罗。此乃是结八部数尔。摩睺者。什师云。是地龙。肇师云。是大蟒腹行也。八部皆能变本形在座听法也。金刚非八部数。手执此宝护持佛法。或言。在欲色天中教化诸天。即大权神也。经云。是吾之兄

问。上界身可化下。下界身云何化上

答。菩萨所为应以得度乃应之尔。如王闻蚁斗。第二从成就如是功德者。是总答也。此则结别开总。成就如是功德是结别也。以种种形游诸国土是总答也。诸名不一。横则遍周十方。竖则冠通三土。随机变现何止三十三身。托化逐缘岂局在娑婆世界。以种种形总明示现身广。游诸国土总明所化处广。度脱众生总明得益广。言虽略上义极广前故。称为总答也。善财入法界文虽广义未必该十法界。地人见文广判为圆宗。见法华文略判为不真宗。若寻此意无不真之义也。三从是故汝等去。是劝供养也。佛答前问先总后别。末劝受持而众生仰荷冥益。但可持名秉字而已。故前开三段始终开合于义相称。佛答后问前别后总。末劝供养众生既荷显益。见色闻声故劝供养。此则开合始终相称。而总别前后者互举尔。有人以总答为叹德。此分文伤义

问。后劝供养受旨奉璎珞。前劝持名何得无耶

答。默然持名故不彰文。供养事显须脱璎珞也。又欲成冥显义前是显机。更持名默念即成冥机。后是冥机。复更供养即成显机。合二义具足

问。亦应更成二应耶

答。二机既具必知有应。故不更说。初劝供养。二奉旨。初又二。先称美功德如文。二出供养之意。意者正由能施众生无畏从德受名。众生于畏得脱为作此名。德既无量名亦应多。不可说不可说也。奉旨供养中为六。一奉命。二不受。三重奉。四佛劝。五受。六结其德。经文不定。或众宝璎珞或珠或众宝珠。此翻译减长尔。众宝者。众宝间珠共为严饰也

若依璎珞经。从初住铜宝璎珞乃至等觉摩尼璎珞。今无尽意位高。那忽止直百千两金

答。此略言百姓万氏尔。实不啻堪此也。若就观解者。将事表理何得一向事解耶。颈者表中道一实之理。以众多无著法门庄严实相如璎珞在颈。解者表菩萨为常舍行故。一切愿行功德乃至佛智菩提涅槃。亦不住不着无依无倚故言解也。大集云。戒定慧陀罗尼以为璎珞。庄严法身也。百千是十万。此表一地有万功德。即十万也。法施者。旧云。如法施重法施求法施学法施皆名法施。无尽意重法故施也。今明如法施也。正以财通于法名财。即是法财。即因缘生法即空即假即中。三谛一心一切具足。于法平等于财亦等。如此施者即是法施。不肯受者。事解无尽意奉命供养。我未奉命那忽辄受。亦是事须逊让。观解者。不受三昧广大之用故无所受重白愍我者。或可请上愍下。或可地位相齐故相愍。或可我为四众故施。仁愍四众故受。以无所受而受诸受。佛劝愍者。即是愍一切众生及四众也。正以菩萨为物故施为物故受。二分者。表事理二。因奉二佛者。将二因趣二果也。理圆即法佛。事圆即报佛。二佛表二果也。第三从持地说去。叹闻品功德也。文云。闻是观世音者。是闻上冥益一段问答也。普门品者。是闻显益一段问答也。此中明自在业。者若是凡夫之业为爱所润。有漏因缘不得自在。观音为调伏十法界。示此三业慈悲力润随感受生。不为烦恼所累。故言自在业。为中道第一义谛所摄。于二谛中得自在无等等者二乘虽出三界犹有上法非是无等。佛是极地故言无等。发求佛心故言无等等。等于佛也。又约心。心中具足八万四千法门。若发实相心即是等八万四千法门也。亦是八万四千波罗蜜。亦是八万四千尘劳门为如来种故。经云。发心毕竟二不别。如是二心前心难。今发初心等于后心。初心难发故言是无等。等于后心名无等等。此即四悉檀意明发心也。发心有三。一名字发。即五品弟子。二相似发。是六根清净。三分真发。即初住已上此。发心是真发心也

观音义疏卷下


观音义疏记

    No. 1729 [cf. Nos. 262(25), 1728]

观音义疏记卷第一

        宋四明沙门知礼述

释疏二。初释题目二。初正释题。义者。宜也。谓解释经文使合宜也。又义理也。斯盖智者入法华三昧。于观行位中见第一义理。以此义理解今经文。疏者。通意之辞。又音疏。即疏通疏条之义也。二说记人二。释疏文二。初预分章段二。初叙二家三段。此品既是谶师为北凉沮渠蒙逊。别传于世。故凉陈已来讲者甚众。于是分节经文三段有异。二今师下示天台多种二。初泛明多种分文。二若作下正依二段节目。二就前下正释经文二。初前问答二。初分科。二一尔下随释二。初问四初时节二。初释字义二即是下明悉檀二。初别释相四。初世界。东方西方随机乐欲。二或可下为人。或有根性闻于前品已得世界。故云喜竟。今闻此品即生宿善。三或可下对治。疑破解事属于对治。疑破悟理属第一义。今从解事当第三悉。四或可下第一义。二土者。谓净光庄严土八万四千随妙音者。此土华德及四万二千天子。因彼菩萨来往得道。今八万发心悟在观音。二诸佛下总明悉。如来如鼓四机如桴击之有声声不孤发。今乃四机扣佛之时也。二标人二。初释别名三。初中道对小。此菩萨名由证中立。中必不偏。今偏从无尽者为对小乘。是灭尽法特彰中道。性无尽故。小乘尽智者。谓我见苦已断集已。证灭已修道已。如是念时无漏智慧见明觉也。无生智者。谓我见苦已不复更见。断集已不复更断。尽证已不复更证。修道已不复更修。如是念时无漏智慧见明觉也。二又云下三谛明圆二。初总示。二大品下别示三。初圆空无尽。拣析示体故。云即色是空。应知体空通衍三教。通则但体生死即空。此偏空也。别圆能体涅槃亦空。此中空也。离边属别即边属圆。今在圆也。圆中名空此空无尽。二又大下圆假无尽二。初引经示相三。初大集约八十明假二。初本土所修。此是妙假具于三观。不灭故假。不生故空不出故中。盖不流出二边故也。此观观佛具观三身。至分证位名为见佛。一切佛法无不现前。且举六度耳。二身子下依法立字二。初身子问。二菩萨答。具彰愿行。愿行无尽名于此立。因缘果报即依苦集立誓。因缘集也。果报苦也。为一切等依灭立誓。以一切智及五分等佛果法故。众生性下依道立誓。以顺法性教化众生知道法故。皆云发心。知是立誓。又檀下依誓立行万行皆为檀等摄也。称波罗蜜行到果也。若愿若行皆无作故方得无尽。凡八下结上愿行。皆即法界。是故皆含一切佛法。二又净下净名就二谛明假。有为是俗可尽之法。无为是真不可尽法。小乘智浅。尽于有为住于无为。故归灰断。圆人观俗即是妙有。故行万行。观真能达不空之真。是故不住三无为坑。是故二谛皆是常住不思议假。故名无尽。三华严约十藏明假。新经二十十无尽藏品云。菩萨有十种藏。三世诸佛皆说。所谓信藏戒藏惭藏愧藏闻藏施藏慧藏念藏持藏辩藏。乃至云。此十种无尽藏有十种无尽。令诸菩萨究竟菩提。何等为十。饶益一切众生故。以本愿善回向故。一切劫无断绝故。尽虚空界悉开悟心无限故。回向有为而不着故。一念境界一切法无尽故。大愿心无变异故。善摄取诸陀罗尼故。一切诸佛所护念故。了一切法皆如幻故。是为十种无尽法。能令一切世间所作皆得究竟无尽大藏。二如此下结经明假。三又如下圆中无尽二。初引经示相四。初胜鬘约佛法明中。以一切法皆佛法故。法无不中。中故常住。常住故无尽。二大品约法界明中。法界体是大总相故诸法皆趣。如提纲领毛目悉归。造境皆中何法非总。今特言意盖为释经。意为法界理必双非。名无尽者。名偏意圆故例真常实无边倒。今释无尽上下皆然。三净名示即边是中。空有当体皆是圆中。中性不改。岂可有尽此之无尽荡二边情。是故能空尽与不尽。故知下结成圆中是真无尽。四大品明诸法皆中。修恶全体是性恶故。十二因缘及以五阴。一一如空常住周遍。非当宗义此文莫销。二如此下结经明中。三通达下从德立名二。初正立名。能达之意从所达法。得无尽名。学者须了。意即三谛无别所达。能达亦无。若其不然非无尽意。二亦名下例诸法。心智五阴及一切法既即三谛故。皆得立无尽之名。二菩萨下释通名三。初对梵翻名。二约华释义二。初释众生二。初通明因果。能生实法所生假人。始自凡人讫尊极人。莫不从于众法而生。二别明菩萨。从于无尽众行而生。故曰众生二发心下释余字。又约上求下化而释。前以众行生己假人。今以道法成他众生。三广释如别。三敬仪二。初分经。二起者下随释三。初释起二。初事释。礼即曲礼。彼云请业则起请益则起。郑氏注云。尊师重道也。起若今抠衣前请也。业谓篇卷也。益谓受说不了。欲师更明说之。今无尽意欲请观音利他之业。欲益己心菩萨之行故。从座而起。二观释三。初约空论起。文有二意。初明空观不着诸法。次明空观自不着空。故名为起。二又菩下约假论起。即不起灭定现诸威仪也。三又中下约中论起。中道遮照皆绝待对。故起不起无非中实。即遮之照。名不起之起。此起自能起发中实。亦能令他起发中实。二偏袒下释袒二。初事释二。初约西土。二此方下约此方。言须贾谢张仪者。合云张禄字之误也。元是范睢魏人也。初仕魏与中大夫须贾使于齐。齐以睢为贤。私赏金璧及牛酒。须贾嫉而怒之。使还谗睢于魏相魏齐云。范睢以魏密事告齐。魏齐大怒。拉胁折齿遭箦卷弃之厕中。睢不死求守圊者出之。睢既得免。易姓名曰张禄随秦使王稽。入秦见昭王。昭王悦之拜为客卿。稍迁左丞相。后须贾为秦使。睢乃微服而出杖于路。贾见而大惊。问睢曰。复说于秦乎。睢曰。逃亡之人免死而已。何敢说秦乎。又问睢曰。秦相张君子知之乎。睢曰。主人公亦得接近。贾曰。今欲因子请谒张君。于是同诣下车。守门者惊起正色。贾疑之。睢入而不出。贾问门人知是秦相失色。战惧脱冠肉袒请入谢罪。睢乃数而恕之。及贾使还睢曰。为我报魏君。令斩魏齐。不然我将图魏矣。魏齐后乃自缢。魏王斩首送秦。二观解。以事表理既成法门。可以修观故名观解。三释合掌二。初释合掌二。初事释。二观解二。初表权实。昔分今合顺部表观。百界一念权实唇然。二又五下表事理。迷殊悟合。法性五阴凡圣岂殊。但圣出缠众生在染。染中性阴起生死阴以为能感。故使圣人出缠实阴起于权阴而为能应感。若复性应则归真。故以两掌表今方合。欲令行人即观事阴。合于性阴。二释向佛。文唯观解而有二意。初直明向佛。次兼合掌明向义。四正发问二。初分文立意三。初带总分节。二大经下问答功德。三释论下简示今问。二世尊下依文释义三。初释称叹。二观世下释所问。三何因下释正问二。初问能成因缘二。初别取境智。境是机感智即圣应。感应名局因缘则通。二若就下互通凡圣。因亲缘疏互论因发。互论缘助。二名观下问所成名号。因缘是实法。名号是假人。揽实成假也。二佛答二。初分科。二数者下随释三。初总答二。初贴文二。初明机四。初标人数二。初举多数三。初牒经略示。经文所举百千万亿。非谓十界共有此数。盖指一业有如许人。二如一下同受一苦。以苦验人知同一业。若不然者。那得同受一品苦邪。三将此下以例诸趣。二所以下明多意。凡地发心尚能遍摄。果中济物岂有所遗。境众等者。机薪若多应火必盛。二遭苦二。初成上义显无量二。初以别业该同受。上言百千是同业者。共受一苦。今言诸苦。即是有诸百千万亿。二用此下以此意历十界。界界有诸百千万亿。华严明数极至不可说不可说。二今言下对别答彰遍该二。初明总答。文略意广。上明诸苦实遍十界。苦由惑业即显能脱十界三障。广岂过此。二后别答。文广意狭别答七难。约观行解始通三乘。今之总答文该十界。三闻名二。初遭苦闻名共作机。由过现恶故遭诸苦。复由二世之善而得闻名。妙玄云。从阐提起改悔心。上至等觉皆有善恶相带为机。二闻有下四闻三慧俱能感二。初释相二。初别指四教四闻三藏能闻所闻皆是实有。通教即空。别教即假。圆知能所皆是法界。闻既有四思修亦然。故大本疏解我闻。有闻闻闻不闻不闻闻不闻不闻。二若能下正示圆教三慧。前三闻慧不得圆闻。圆教闻慧四种遍达。达四皆是不闻不闻。即闻而思何依何着。二慧导行。一心称名名圆修慧。二此文下结示。四称号二。初牒示事理。二若用下各示称念二。初事二。初明一心。有相续一心。有数息一心。二明称名。今文但称所归之名。未称能归之辞。故是略非广。二理二。初明一心。心有生灭不名为一。今达心性非四句生。既本不生亦复无灭。乃名一心。然立一心对他成二。若无一无心则无诸无法。毕竟叵得名理一心。言达此心者。即是体达事中一心。二知声下明称名。既达心空。从心所生一切皆空故。令声响能称所称皆非生灭。故曰理称。事未必理理必具事。以此为因。安不感圣。二明应二。初分科。二应有下随释二。初明应相二。初判偏圆益相三教作意。应不一时。圆任运应一时普遍。二众机下明机应速相。观音应赴心内众生。众生机感心内观音。若不然者不遍不速。二皆得下明解脱二。初约多机显圆应。故前释人数。云此举众境机多以显观深应大。二或时下约三速再贴文。经云观世音菩萨即时观其音声皆得解脱。如何观之。能令众苦普皆解脱。说听之者宜善思之。二问十下料简二。初明十界机应俱时遍二。初以多机差别难。二答譬下以四事圆普答五。初以四喻示。二菩萨下约四法合。三安乐下引此经证。智慧宝藏证财智二。四又如下又三喻显。五又是下示三昧力。中道为王。统摄二谛。一心圆入十益普沾。观音入此三昧。即是遍入一切众生心性。常以三昧之力。与其十番之益。但由机感亲疏。致使利益深浅。王三昧在妙玄第四十益在第六。二问一下明一心事理立能感二。初久称无效问。二散心乖法答。若能一心称于事理。其犹形对影生声腾响答。第二别答二。初分科叙意二。初分科。二叙意二。初叙他师意三。初立三机三。初有人下定三业前后。二通论下论三机与拔。免难是除果离毒。是除因得子是与乐。三叙三番料拣三

初问。那忽与乐者。古以得子为乐故也

答。云少分与乐不碍悲门

二问。礼拜乞子示求乐果。何不令求戒善等业为乐因邪

答。乐果称意可引人。求修因勤苦。非引接法。其文在后者。十九说法广示修因也。三问。并答可见。二有人下立七难二。初明双只。鬼开去来者。去谓飘堕其国。来谓到此恼人。王论轻重者。被害则重检系则轻。体则是五开则成七。二明次第。鬼王相间者。三鬼国难。四临害难。五来恼难。六枷锁难。三四相比。鬼难在海国则重。王难在城邑似轻。四五相比。王难或死故重。鬼恼或不死故轻。各论轻重故云相似。乃相间也。三有师下立八难二。初一师立。二一师破。二今明下明今师意二。初明三机二。初斥他非二。初斥情卜圣应。二今不下斥悲门与乐。二今言下明今意二。初随世立次。此娑婆国声为佛事。口机为初。意根冥密起必先身。身业粗显后心。而动三业之次岂不然乎。二若寻下圣应无谋。且随世俗立次如前。据圣无谋即扣即应。二他既下明七难二。初明次第二。初且一往立次。从重至轻一往次第。二至如下诫不可定执。二问诸下明所表二。初以难多唯七责。二答此下以七难表六答二。初正示表意二。初通明七六。经明七难。不止在事。故约观释通亘三乘。若无所表不能该深。故约七难以表六种。外水火风表内三种。刀锁坚碍表内地种。王等有情可表识种。大千世界虽非正难。是难所依可表内空。二云何下别示空识二。初明表相。二空为下明为难二。初空。虽非正难而是难由。若论观行亦为所观二识。识起爱见必该通别二种爱见。二所以下结示唯七意。二一火下依义释文三。初口机二。初明七难七。初火难二。初科意三。初节经文。二上总下叙经意。三释诸下列义门。二贴文下随释三。初贴文四。初持名二。初释文义二。初释持名。秉持属口者。大论云。出入息是身行。觉观是口行。受为心行。秉持之心既是觉观。故属口业。二释若有。挑字去声不定貌也。二余皆下明先后二。初叙古。谓是互出其义不然。二今释三。初约义释。二如慈下引事劝二。初引事证。此是男子名慈童女。鬻薪养母督于孝诚。后欲涉海。母抱其足不欲儿去。违母掣身绝母一发。海上失伴入诸宝城。多岁受乐。行孝报也。后入铁城火轮着顶。绝发之报。若专行孝不遭火轮。二行人下劝忆持。三火难下约重结二遭苦三应。四威神下结。二次约下举事二。初示二人着传。二其传下举四人免难。三就观下观释三。初通标列。报是事火。眼见身觉。业与烦恼但有烧义。令世善业及三观坏故名为火。是以称为就观行释

问。三观所对唯在烦恼。纵兼远障只至于业。事相火等全不妨观。何得果报预观释邪

答。经列七难。止在人中。智者深穷。救难之功在王三昧。即二十五有真常我性观音证已。乃能遍拔众生之苦。于一一有十番破障。令与我性究竟冥一。方尽大士拔苦之用。然十番破不出三障。若尽理说。于一一番皆破三障。今欲易解从增胜说。报且在事业属有漏。唯惑至极。观音修习王三昧。时具有弘誓拔于法界三障之苦。故今众生三障苦逼。一心称名皆得解脱。其义若此。岂得不论果报火等。应知吾祖说观世音圆修三昧。圆发僧那圆入法门。圆救诸难。意令行人仿之修入。所列三障岂独即今修观之境。亦是将来所拔之苦。故知具示七难浅深。正论观行始末之相也。二果报下示分剂。报业烦恼始自博地终至等觉。皆具此三。故辅行明分段土至实报土各有三道。分段三道谓见思惑为烦恼道。烦恼润业名为业道。感界内生名为苦道。方便三道谓尘沙惑为烦恼道。以无漏业名为业道。变易生死名为苦道。实报三道谓无明惑为烦恼道。非漏非无漏业为业道。彼土变易名为苦道。今从增胜而说。故约事火而为果报。只至初禅轮回之因。以为业火。故至有顶。三观所破方名烦恼。故通三乘。下去诸难其意准此。三果报火难下随次释三。初果报火二。初遭难三。初通明处。二如阿下别示相。三凡一下总结数。四趣四洲六天初禅。若加梵王合云十六。同在初禅且云十五。二持是下感应二。初机成获脱。二直就下指数斥局。直就果报地上清凉。验于旧解所失者众。因华已去丸番破有他不闻名。二次明下恶业火二。初遭难。二初明修因。上之所明于现报上求免苦厄安其果身。今所论者修行戒善及八地定。求于未来人天乐果。二多为下明遭火三。初释相。宿习破戒十恶业等。于修持时起作障难。使戒定等善业不成。名为被烧。有顶等者。然有漏善极非想定。非恶业火。无所有下即为恶业。且欲示于恶通三界。故引之耳。二术婆下引证二。初引事。术婆伽淫欲炽盛火起烧身。此即业火。能生事火。验三种火其性不别。二金光下引经。三能破下被烧。上升之善既为所焚。乃随恶业牵堕于下。二若能下感应三。初成机得脱。二故请下引消伏证。梵行者。净行也。谓大小诸戒是三乘之人清净之行。十恶是能破梵行是所破。三由斯下用此文结。三烦恼火二。初就机应解释二。初明偏圆机感二。初别释二初约声闻广示。见思之因分段之果。四心流动三相迁移名为火宅。竞共推排争出此宅。若非一心称观世音。或当堕落为火所烧。此教观音身在此岸度人彼岸。故令声闻得二涅槃。二次明下例余位俱机。剂于通教见思为火。别教正以尘沙为火。圆教初后无明为火。上之二土通名变易。未能伏断无明惑者。名钝根人。若能伏断称利根人。伏在方便断穷实报。二凡有下总示二。初修观被烧。唯除求离果报火者。戒善已上皆名修道。故云九番。并为五住惑火烧者。修因禅定。亦被爱惑三住所烧。况三毒业见思通摄。二称观下称名得脱。各依本法而修一心及以称号。若成机者无不得脱。二问菩下明渐顿慈悲二。初问起。如上所明二十五有三障苦难十番令脱。未知大士修何方便。证何法门。得如是力。二答菩下释出二。初略示。二所以下广释二。初明渐次二。初修观本誓三。初果报慈悲。既于元始发菩提心。凡曰见闻终期济拔。二受持下修因慈悲。略云禁戒。须兼根本十二门禅。以其业火皆能坏故。三修无下无漏慈悲二。初事定。若据根本。味禅之外有根本净禅。谓六妙门十六特胜通明禅。此等亦带无漏能灭烦恼。今但从观骨光等为无漏者。盖取出世事禅之中有火名者。辩其观相。此乃以事禅之火。灭见思之火。然事禅有四。即观练熏修。观谓九想八背舍八胜处十一切处。练谓九次第定。熏谓师子奋迅三昧。修谓超越三昧。今于四中但举观禅。中三不引八背者。以八背中无火名故。盖随便也。初云白骨流光者。即九想中于第八白骨。修八色流光。言八色者。见地色如黄白净洁之地。见水色如深渊清澄之水。见火色如无烟清净之火。见风色如无尘迥净之风。见青色如金精山。见黄色如薝卜华。见赤色如春期霞。见白色如珂贝雪。见色分明而无质碍。八胜处者。一内有色相外观色少。二内有色相外观色多。三内无色。相内观色少。四内无色相外观色多。此四句末皆云若好若丑是名胜知胜见。五地胜处。六水胜处。七火胜处。八风胜处。此于缘中转变自在观心淳熟胜前八色故也。十一切处者。一青一切处。二黄一切处。三赤一切处。四白一切处。五地一切处。六水一切处。七火一切处。八风一切处。九空一切处。十识一切处。此于所观普遍即观禅成就也。二又观下三观。诸火者。报业烦恼及事定中火。皆是三观所观境也。此境缘生故。先即空次假后中故成别观。节节慈悲誓。拔报业及三惑火。二今住下熏心起应二。初乘誓赴难三。初真悲妙力。即是邻极同体慈悲冥熏众生。令成机感垂应拔苦。二若事下众机关誓。众生若起三种火时。与本菩萨所起无殊故。关分果之悲。以答因中之誓。肇师云。发僧那于始心。终大悲以赴难。三若众下一时普救别教虽则修有次第。证必圆融。故十种机能一时应。二如华下引经证成二。初引经

问。今家判华严。善财未见弥勒文殊已前。皆是别教历别法门。今文既云此火山者。名为无尽法门。若入此门能知诸法。此门岂非圆融义邪

答。此唯于火法门中能知诸法。不能于余法门知诸法故。以彼经云我唯知此一法门。故知仍是教道之说

若尔。此之三昧住何谛理破何等惑

答。既云。无尽法门。又云。能知诸法。即是中道三昧破无明惑。故释签明。善财若于知识得实相三昧。则破障中微细无明。多分并约教道不融。破无明惑(上皆释签)二举彼下结示。观音若是别教。救于烦恼火者。即如方便命婆罗门所修之相也。十番利益者。乃是通结前来三番慈悲。二次明下明圆顿二。初明本修圆观慈悲。初心观火不思议境。即一火门具三千法。虽皆互遍相相分明。即于此境发菩提心。誓拔众生三障火难。誓与众生三种火乐。二若法下明入位法界机应二。初释三。初无谋而应。圆修圆证以圆誓愿。熏圆力用。不动一心救十火难。二虽无下不分而分。圆普之悲彻底而拔。实非前后。浅深应之但就机感。三障分齐对二十五王三昧力。自成多少。免果报火。当于十五王三昧力。修有漏善免恶业火。当二十四王三昧力。关何一邪。若除恶业不用非想。若成善因不用地狱。以地狱因无成就。故非想之因无破除故。故修因恶业极上极下互论不用一三昧也。二乘已去至圆入中。节节皆用二十五有王三昧力。三虽应下入而不入。虽入诸有三障之火。以其体了即空假中故。无相可得。何有能烧及所烧邪。二菩萨下结。二常途下示己他得失。如幻三昧破阎浮有。具论十番。他师唯知果报一益。故云少分。二水难二。初列义门。二贴文下随门释三。初贴文二。初科经。二问何下释义三。初遭水二。初问二答二。初就水难答。二火难下对火难答。二称名。三水论下蒙应。二引证。三观释二。初列三水。从增胜意同前火难。二如地下释三水三。初果报二。初遭难。二是时下机应。二次恶下恶业二。初遭难。放舍浮囊等者。大经云。如人带持浮囊欲度大海。有一罗刹乞此浮囊。初则全乞。其人不与。次乞其半。次乞三分之一。次次乞手许。后乞微尘许。其人念言。若与尘许。气当渐出。何由度海故悉不与。护持禁戒亦复如是。常有烦恼罗刹令人破戒。若破根本如全与。破僧残如半与。破舍堕如与三分之一。破波夜提如与手许。破突吉罗如与尘许。所破虽少。若不发露则不能度生死彼岸。菩萨护持重禁及突吉罗等无差别。今明恶业故言放舍。二若能下机应。三烦恼二。初明机二。初论惑水二。初通明诸有水。菩萨香象足虽到底。若未达岸宁免被飘。缘觉观集而为初门。故云爱水增长诸有。二二乘下别示四教机二。初示声闻。二次支下例诸位。支佛修行不立分果。深观缘起久种三多。福慧既隆预侵二习。虽未发真。四流莫动名得浅处。顿证极果安到彼岸。通教菩萨正尽得浅。习尽到岸。变易二土同以别惑而为中流。上品寂光方为彼岸。二复次下示四流。常途四流只是界内之惑。今取别惑方名无明。故知即与五住无异。但合色爱及无色爱。为一有流耳。二菩萨下明应。前之十番各有修相。皆所被机求脱之事。今说本观二种修相。皆是观音垂应之本。二初通示二观慈悲。兼别观者。略有二意。一者此教初心立行虽依渐次。以知中实后心能证王三昧故。二者欲以历别之相。显于圆融一念具故。摩诃止观十乘之初。先明次第显不次故。今释此品。本观皆两有兹二意。二所以下别明三昧渐顿二。初渐二。初渐修。元始发心上求下化水光三昧。即观白骨八色流光中一色也。水胜处等例如火难中说。二今成下顿应二。初乘誓赴难。渐修顿证常鉴法界。十番机缘三障水漂。对于因中节节誓愿。令彼一切皆得解脱。二如华下引经证成二。初证。托于事海观三障海。十二年者。十二缘也。渐渐转深见海十德十观成也。生大莲华显妙境也。天龙庄严者。具妙力用也。有佛相好常见卢舍那也。申右手者。权智应也。摩我顶者。实智感也。即以感应道交彰。始本分合也。说普眼经者。分得果法也。一日所受至不能得尽者。一念心尘显大千经卷也。二当知下结。既如阿字具一切义。应知亦是中道法门。但带教道。唯知此一耳。二复次下顿二。初顿修十界趣水者。水为法界。摄诸法尽故言趣也。既立能趣及以所趣。故当俗谛。水尚等者。所趣之水全体是性。无相可得。无所趣故那有能趣。能所俱空名为真谛。云何等者。水尚叵得则无有趣。有趣既绝不趣自忘。即以双非显于中道。此之三谛同一法性。即一而三即三而一。不思议谛也。二如此下顿应二。初明不应而应。大经云。慈若有无非有非无名如来慈。岂非三谛起慈悲邪。前总难中十界众生受苦称名。菩萨即时观其音声皆得解脱。不观十界即空假中。那得一时离于众苦。良以三谛是生本性亦圣果源。无有二体。故同体悲方能圆拔。二明不分而分。大意同前火难中说。今以四流对诸位难。四教入空离于有流。等于见欲二流也。假于有流无染湿者。假虽彼空亦不著有。以双流故。应知假显空亦弥着。名平等观。义在于斯。中破无明。如常所说

观音义疏记卷第一观音义疏记卷第二

        宋四明沙门知礼述

三罗刹难二。初列义门。二随门释三。初贴文二。初科经。二人数下随释二。初明难五。初举数二。初释人数。若百若千或万或亿。以其泛海必乘大舶故。云结伴不可独往。二贤愚下明入海。二次遭下难由三。初正释难由二。初证。风非证难。以古师足风为八难故据结文但成鬼难。二难由下推。风是难由。若展转推之。皆是难由。于诸由中风由最切。是故经文特言风耳。二七宝下追释宝物二。初分真伪。二示似真。三黑风下更释风相二。初他解三。初旧师立。二有人下他人弹。三今还下今例难。二请观下今释二。初经明风色。二风加下风黑怖甚。三罗刹下遭苦。罗刹鬼者。本毗沙门天王所管。有其二部。一曰夜叉。捷疾鬼也。二曰罗刹。食人鬼也。遍在诸处。然其本居海外有国。或人飘往其国。或鬼来此恼人。皆由恶因相关故也。四一人下明机。五明应。二何意下结名。二约事。三观释二。初明风义不局。世界中风果报风也。黑业名风。至失人道善宝。皆恶业风也。失无漏财烦恼风也。以下第五又明鬼难。具明三障恶鬼之义故。今观行且从难由风义。而示欲于六种。明别圆观即是一切观境之式。二从地下释风通三障三。初果报二。初遭苦二。初上至三禅。二如僧下下遍诸趣。僧护比丘明四阿含为众知识。五百商人入海采宝。来就世尊。请此比丘船中说法。佛知有益许之。令去船还海岸登陆而行。夜宿树下。商人早发忘唤比丘。因兹失伴。独行山林。见僧伽蓝比丘住处。若饮食若房舍若温室。若园林若田地若受用。皆是苦具日夜之间。受种种苦。有百余条。僧护问故。皆答云。当还问佛。自当知之。既至佛所。具陈所见。佛皆答之。悉是比丘破诸禁戒。毁坏常住侵用众物。于彼海山受地狱苦。学者览之足以自诫。二当此下明机应。二次明下恶业二。初遭难三涂约果爱见约因。皆由宿业。令起爱见堕于三涂。贪欲之心如罗刹妇。破戒定善如随食子。失人天报如食其夫。二急须下机应。三次明下烦恼二。初明机二。初声闻。圣财不出七种。一闻。二信。三戒。四定。五进。六舍。七惭愧。慧行即无常析观。行行即不净慈心等。二行约凡位所修。七财约圣位所得。二次明下诸位。八倒风者。支佛六度通别圆入空之观。以常等为倒。假中变易以无常等为倒。用正观一心称观世音。即出二边恶鬼境界。即能达到中道宝渚。鬼义合前后章前即此章贴文约事。后即第五鬼难章也。二法界下明应二。初通示二观慈悲。别虽渐修果能圆应。二菩萨下别明三昧渐顿二。初渐二。初修时逐行起誓。二今入下明证时随难相关。二若作下顿二。初修持三谛圆融。风字门者。如请观音疏释六字章句。以六道等为六字门。良由六道。体是法界能通实相。故名为门今以风字为门。其义亦尔。字者。召法之辞。二若分下用时一念差别。四刀杖难二。初列门。二解释三。初贴文二。初科经。二释义三。初遭难。二称名。三今言下蒙应二。初据文消释。二问下对前料简二。初问。二答。二约证。三观行二。初通示三障。二从地下别释三相三。初果报二。初明遭难。娑伽龙王本宫安住兴云降雨。六天四域修罗龙鬼感见不同。天见华宝。人得清水。修见刀剑。二若能下明机应二。次明下恶业二。初遭难。恶业所感三毒炽然。近障戒定远妨三观。言思绝处即微妙心。二起怖下机应。三次明下烦恼二。初机二。初声闻二。初遭苦二。初释相。二故大下引证。彼经云。譬如有王以四毒蛇盛之一箧。令人养饴瞻视卧起。若令一蛇生嗔恚者。我当准法戮之都市。其人闻已舍箧逃走。王时复遣五旃陀罗拔刀随之。密遣一人诈为亲友。而语之言汝可来还。其人不信投一聚落。都不见人求物不得。即便坐地闻空中声。今夜当有六大贼来。其人惶怖复舍之去。乃至路值一河截流而去云云。合云蛇若害人不堕恶道。无三学力。必为五阴旃陀罗害。若不识爱。为诈亲诳。观于六入犹如空聚。群贼住于六尘六入。欲舍复值。烦恼驶流应以道品船筏。运手动足过分段河。十住未免唯佛究竟。经文本喻三乘始终。今喻声闻观法。十二因缘关禁如城。黑白不动三种之业。系属如馆。五欲为害如拔刀人。魔境难出如门被守。二尔时下得脱。二次明下诸位。各以本观一心称名即时解脱。二复次下应二。初渐二。初明本誓。随见随修皆起誓愿。拔于众生三障刀杖。二今住下明赴机三。初赴机相。三昧神力称本诸誓一一能拔二刀杖下所住法。以七种难。表内六种对于观门。此地种门今修成也。三如华下引经证。六种遍收一切观境。刀杖坚碍属地字门。故引屋壁地种能现诸佛。及能发明善财定慧一切功德。当知地门能成普应。二复次下顿二。初圆修。地为法界。生佛依正无不趣入地字法门。当知一尘无不具足三谛等者。一尘即空一切皆空。假中亦尔。二圆起下顿应二。初总示。三谛慈悲无不遍摄。故能一时遍拔众苦。二若欲下分别。圆悲该亘不可别论。若欲易知对机分别。四洲四趣四王忉利。此之十有有事刀杖。能感一十王三昧力。修有漏善遮恶。刀杖感二十四王三昧力。四教三观一心称名。感二十五三昧之力。第五鬼难二。初列门。二贴文下随释三。初贴文二。初科经。二三千下释义四。初标处二。初大千假设。二对上料拣。二遭难。三称名。四鬼所下蒙应。恩威即是折摄二门。以恩摄故害心恶眼二俱休歇。以威折故恶害亦然。二约事标而不释合注云云。上罗刹难已彰其事。故不重说。三观解三。初果报二。初明难诸天等者。嗔增诸恶助鬼之威。慈为善本消鬼之势。行者当知。若多嗔恚。常与恶鬼同其事业。若常慈悲。与佛菩萨。同其出处。二如是下明感。二次明下明恶业二。初明难二。初鬼动三毒。虽是恶鬼使人淫佚。亦是淫业所召。以其多起淫思。致令淫鬼得便。嗔恚邪见亦复如是。又是宿业互相招集。故于今日同造恶因破于善业。二三毒下诸恶名鬼。如前业火业水业风。故今诸恶得名为鬼。皆以三毒而名恶业。与烦恼何异。任运起者名为烦恼。卒起决定能动身口名三毒业。今既能破五戒十善。必非任运贪嗔痴也。人天散善名为动业。四禅四定名不动业。二若能下明感。三次明下烦恼二初机二。初明难二。初所遭难二。初明满大千。男性刚利如见推划。女性柔染如爱缠绵。二何以下遍三界。二此鬼下遭难人。小草已上八番行人。俱为烦恼鬼之所害。二若称下明感。见爱尘劳即染而净。是故净名取譬。侍者随意所转。二次明下明应二。初渐二。初随修立愿。如讫拏迦等。即请观音经缘起也。毗舍离此翻广严。彼国人民遇大恶病。眼赤如血两耳出脓。乃至六识闭塞犹如醉人。有五夜叉名讫拏迦罗。吸人精气。二于诸下乘誓普救三。初示相。渐修顿证法身自在。法界众生三障鬼难关于本誓。一一救之。能令诸鬼皆为佛乘。二如华下引经。斯是菩萨住鬼法门。能以鬼身广作佛事。三障之鬼或破。或用得自在故。一切鬼难一时普救。三故知下结益。二若圆下顿二。初明圆观慈悲。识种乃通今约鬼修。别从爱见识种为境。一识一切识一切识一识。非一非一切而一而一切。此是鬼门十界。三谛依此妙境。真正发心乃能遍应。二若分下明随机分别。事鬼既能恼于帝释。故地居天四洲四趣。感于十种王三昧力。余义同前。六枷锁难二。初列门。二随释三。初贴文二。初节经。二上临下释义四。初标罪。二在手下遭难。三鸟死下称名。曾子云。鸟之将死其鸣也哀。人之将死其言也善。四蒙应。二约事。三观释二。初正明枷锁三。初果报二。初明难。事系唯在四趣三洲。二若能下明感。二次明下恶业三。初明难。二若欲下明感。三故经下引经。廷尉检系可有散时。妻子钱财系无脱日。望现在等者。只今妻子及钱财等亦业亦报。何者。若从现说名之为报。从过去说名之为业。应知障善皆是宿恶。此之宿恶或已成报。乃附报为障。即今妻子及自身依报等也。若未成报今在业道。亦自有力令善不成。又今妻等不定为障。若于往世同营善因。今则能为修道助缘。如妙庄严王因妻子故。见佛悟道。现见有人妻子劝善畜财能施。今从恶因所感。妻等名锁名狱。若归观音则成报之业。及未成者是恶皆息。三次明下烦恼二。初明机二。初约声闻二。初约小释二。初明难。凡夫见思全在。初二三果思惑未尽。皆名有罪。罗汉思尽名为无罪。大品经指学无学。名为大龙。故云摩诃那伽。学人残思名为有罪。无学断尽名无罪俱未无余。名同在狱。既有果身宁逃五阴及以三相。乃名检系。权实等者。此约有罪示也。碍于二智提拔名杻。妨于二行进趣名械。小以断常为中道枷。能障五分为法身锁。只是见思对于所障。得杻等名。二称名下明感。二此复下明通大。若就通惑论杻械等。即藏通人。若就别惑明杻械等。即别圆人。二次明下例诸位。二若论下明应。因中渐顿慈悲。果上圆普与拔。皆如上说。二若三下兼明空识二。初普应指前。二论其下本观。今说二。初渐二。初本观慈悲二。初随观示。一切烦恼是识所为。识最是难。空虽非难能来难。故空亦名难。空为业者。亦是业由身内有空故。能动作造于业因。外空亦然。空为惑者。于境迷悟成障成理。一切法邪一切法正。而于节节起誓与拔。二故净下引经证。入不二法门品。明相菩萨曰。四种异空种异为二。四种性即是空种性。如前际后际空故。中际亦空。若能如是知诸种性者。是为入不二法门。既云四种性。即是空种性。就性明空空是中理。此以中理不于事二。彼约五种即性故不二。今明六种岂不即性得经意故加于识种。弥显不二。若其空识不即中道。将何以为王三昧体。二成王下乘誓应赴二。初示相。二华严下引证。见空实相。能于虚空立种种事。利诸众生。二若作下顿二。初空识圆修。诸门观法多推心识。从近从要初心易故。人根不等。有宜观外而得益者。四念处中。下界众生多着于外。故令摄境观于内心。上界众生多着内心。故令观色夺于内着。今观空种。亦是色类。唯是一色空外无法故。一切十界悉趣空门。空即三谛故。一切法皆即三谛。三谛慈悲无生不摄。二起无下慈悲普应。第七怨贼难二。初列门。二贴文下随释三。初贴文二。初正释怨贼二。初科经。二难处下释义四。初标难处二。初明处。二次明下明难二。初释满中。二怨者下释怨贼。二二标下遭难人二。初示四义。二商者下释四义四。初释商主。二既有下释商人。三既涉远下释重宝。以人众路远显所赍宝贵。四险路下释险路。以处以人二事释险。三机者下明有机二。初示经四义。二所以下通释四义二。初明前三助进二。初释二。初明设三所以。一心称名为计策者。更无过此知德可凭其胆则定。二若不下明无三不进。二故知下结。二三义下明后一能感二。初明因三故唱。二南无下翻梵就华。四明蒙应。二次结下寄结口机二。初举经。二今言下释意二。初约威力明。二巍巍下约字义显。二约事证。三观释三。初果报。二修善下恶业。修善治恶。若恶多善少恶即怨贼。若善多恶少恶为仆从。冰炭之势多能灭少。系念成机恶销善立。三次明下烦恼二。初略明机二。初通明四行遭贼。以前六遍。备明八番破惑感应。故今怨贼但明四行。遭烦恼贼将历四教。自摄八番。言四行者。一戒法受持。二听习教理。三研修正观。四正助合行。出世行人要先禀戒。随境护持持心习教。凭教显理称理修观。以正导助。若非此四入圣何期。初商主下戒中三句明受一句明持。五尘能杀持护之心。名戒怨贼。次或法下听法中。师徒说听皆欲依教而显至理。此二俱得名重宝者。以其诠旨得则俱得失则俱失。其犹识指方乃见月。故知解教诚为不易。何况理乎。而其徒主两喜杂魔。二宝俱失。师为利故说。徒为名故学。斯之两人皆成魔业。或师嗔弟子。或弟子恨师。亦是二人值于魔事。或心下修观中。心王若正心数亦正。王数同求正智之宝。三毒觉观能劫此宝。最为怨贼。或般下正助中。正观般若导五助行。共显理宝。般若如知金藏。五度如用功掘出。六蔽之贼害此二因。还今藏隐。是名怨贼。二将此下历诸教明感。四教行人一一须四。若遇怨贼。一心称名四行皆就。二例明应。例前六种故略不说。第二意业机二。初列门。二贴文下随释二。初贴文二。初科经。二释义二。初正明意机二。初总示经文。二通称下通释经义三。初依经论释三毒二。初通释二。初明单复。云贪嗔痴。此三单也。今从复列。故云淫欲嗔恚愚痴。大本疏云。自爱为欲爱他为淫。自忿为恚忿他为嗔。自惑为愚惑他为痴。二有人下明多少二。初他明少。二意谓下今明多二。初立少乖经。二今明下明多能感。毒之多少由习重轻。求之进不由机有无。无机者毒多毒少俱不求离。若其有机毒之多少俱能求离。古人不解执多不求。今明能念任多亦离。二大论下别释二。初正别释三。初贪欲四。初大论明宿因。意同此经。谤经之罪历诸恶道。纵得人身。淫欲炽盛不择禽兽。若不求离。复沦苦趣无解脱期。二不择下现事明过患。术婆伽缘略如玄记。褒姒者。褒国之女也。周幽王伐褒。褒人以姒献之。王甚惑之。初幽王与诸侯约。有寇即击鼓举烽。诸侯来赴。及惑褒姒褒姒无笑。王欲其笑。乃击鼓举烽。诸侯皆至而无寇。姒乃笑。又好闻裂缯之声。发缯裂之以适其意。及申侯与犬戎兵至。击鼓举烽。诸侯以为如前见欺。无复至者遂败。三净住下二经明虫鬼。各是有情。以共业故资人倒惑。又阿含云。淫亦有鬼。鬼入心则使淫佚无度。四如大下大经明多少。习果若成报果在即。故云熟也。如人灾至合当王宪。即有恶人奖助为恶虫鬼如助者。地狱如王宪。此多欲相也。若反此者名为少相。二嗔恚四。初约喻明嗔相。二故遗下二经明障道。慈是一切善法根本。嗔既乖慈名劫名障。百法明门者。即障别圆地住所证之法也。仁王云。初地得百法明门。二地得千法等。地论云。入百法明门增长智慧。思惟种种法门义。故百法者。应如百法论所明。三大集下二经明魔业。佛以慈定能伏天魔。是知嗔心为魔所降。习近嗔恚是报熟时。四若例下例上有虫鬼。若虫鬼潜伏是嗔少相。三愚痴二。初明过患。三句明于邪痴之相。如大经者。合云习近愚痴是报熟时。此乃邪痴习报二果。痴心习成。地狱报熟也。二例前下例虫鬼。多少随人。二三毒下总结过。二欲离下约伏断明得离三。初示念得离。二有人下斥非显正二。初他解非灭离。以由他师不解常念。致令三毒不得灭离。二今谓下二经明尽净。经直言离。那专伏释。若以念故唯能伏者系念六字能净毒根。至成佛道亦只伏邪。三今作下正明伏断果报修因。三藏菩萨。此三伏惑。声闻缘觉通别圆菩萨方便土人实报土人。此七断惑。三问离下约问答明常念二。初约念非离惑难。二答经下约念即智慧释二。初略明正念之德二。初即念明慧之功。念想观智等诸名字。有过有德有偏有圆须约六句定其法体。故圆中念破偏小智。圆中之智破偏小念。偏小之念修圆中智。偏小之智修圆中念。圆中之念即圆中智。圆中之智即圆中念。以此六句评法是非。方解一切经论名相。问家昧此。故使非念而是于智。今此圆文既云常念。显非二边有生灭念。双遮双照中正之念也。体烦恼性是观音身。不破烦恼不立观音。破立既忘能所斯绝是为常念。恭敬观音。不离三毒而离三毒。若有观音可生缘念。若见三毒须灭离者。此乃增毒非离毒也。二若如下离念说慧之过。二今此下委明修观之相二。初忘照各论四句。此之正念染体既绝忘照不妨。即照三谛即忘三观。虽约四句唯忘三观。以双非双。亦只是中故不以色念忘俗也。以色例于一切诸法。不以非色念忘真也。合云。不以非色非非色念。忘双遮中也。不以亦色亦非色念。忘双照中也。约照三谛复成四句。亦以色念照俗也。亦以非色念照真也。亦以非色非非色念。照双遮中也。亦以亦色亦非色念。照双照中也。应知善忘假者方善照假。善忘空者方善照空。善忘双非方照双非。善忘双亦方照双亦。不须以空忘假以假忘空。双非双亦皆悉尔也。此就圆论念。即法界无德不备。故作四句说之自在。终日忘四终日照四。如此方是常念观音。二或次下渐顿有诸四句。次第非念忘四句也。次第论念照四句也。忘照本求离于三毒。故次第离亦有四句。若得别教三观之意诸句可见。何者。如照空时。必须忘空以遣着。故忘照成者必离见思。故此空观有忘有照有离。次观假后观中。皆须论于忘照离三若不次第忘照及离。斯是圆观如向四句。二次就下观释二。初前七番指上。果报已上至通菩萨。皆不能破无作之集。别人虽破而在后心。今从初心故同前指。二今但下后三番当说二。初三毒逆顺委示二。初约界外双标。二今取下依法相广释二。初逆顺各示二。初顺约烦恼释。初明毒害二。初二乘三毒二。初明毒相二。初合明三毒。二开三下开成八万。既有三毒须论等分。四分各具二万一千。是故成于八万四千。界内既尔界外亦然。何者。以大乘说诸法不灭。云断惑者。但转有漏而成无漏。入假入中。八万四千随观而转。至果乃名八万四千波罗蜜也。二净名下引经证。观众生品。天女以天华散诸菩萨大弟子上。华至诸菩萨即皆堕落。至大弟子便着不堕。一切弟子神力去华不能令去。尔时天女问舍利弗。何故去华。答曰。此华不如法是以去之。天曰。勿谓此华为不如法。所以者何。是华无所分别。仁者自生分别想耳。乃至云。结习未尽华着身耳。结习尽者华不着也。彼疏解云。华至菩萨皆堕落。者表菩萨住不思议解脱。生实报土已离别惑。彼妙五欲所不能动。故华不着身皆自堕落。至大弟子便着不堕者。二乘但断界内五欲故。世间五欲所不能动。别惑未除故。为界外上妙色声之所染污。故诃言。结习未尽华则着身

下文料简云。结习未尽华则着身。何关别惑

答。大论云。于声闻经说为习气。于摩诃衍说为正使。即是别惑二未断下菩萨三毒。同有此三毒者。望前二乘名同义异。前但贪空。今贪俗中前嗔生死。今嗔涅槃。前不达真。即是中道为痴。今见中道未得了了为痴。如大树折枝之譬者。大论三十云。譬如泽有树。名奢摩黎。枝觚广。大众鸟集宿。一鸽后至住一枝上。枝觚即时为之而折。泽神问其故。树神答云。此鸟从我怨家树来。食彼尼俱类树子来栖我上。或当放粪。子堕地者恶树复生。为害必大。是故怀忧。宁折一枝所全者大。彼喻菩萨畏于二乘坏灭佛乘心也。二欲除下明机应二。初明正念机应。二永离下明上土全分。生身菩萨若未得入别圆地住。生方便土。故于变易论全未离无明之惑。若在生身入地住者。即生实报。故于变易除残别惑。一变易土分于方便实报。异者只由生身于无明惑。有侵未侵不同故也。二次明下逆约法门释。以烦恼名立观法称。不顺常涂故云逆说。然若不知性恶之义。云何三毒而为三观。于中二。初明毒观欲成二。初明凡小毒少。法略于痴人略菩萨。痴随贪恚亦名为少。菩萨偏假三毒非多。二菩萨下示圆人毒多二。初就毒名论大。语稍同前意则永异。前在二谛偏论取舍。是可离法。今就三谛说贪嗔痴。是究竟道。理性之毒莫不遍周。故皆名大。五不受者。谓受亦不受。不受亦不受。亦受亦不受亦不受。非受非不受亦不受。不受亦不受。皆言不受者。即无生观荡于取着也。前四即离四句也。后一谓观亦自亡也故大品第三。身子问须菩提何故不受。答云。般若波罗蜜空故自性不受。无明下明痴毒须论即性异前唯修。又痴下明痴等。若非即性。岂皆如空不可尽邪。二如此下约法门明妙三。初标列三门。理性之法德过一际。或称毒害。或称功用。今明三毒是三法门。则佛菩萨无不修证。二大慈下解释三相圆观见思三毒之境即三法门摄一切德三。初大贪法门。大慈大悲者。诸佛以无缘慈悲普熏三业。于十方世界普现色身。而作佛事。慈悲之名虽同四无量中而体永异。四摄。一布施摄。二爱语摄。三利行摄。四同事摄。众生情所爱者即是此之四法以四接引导以正道。而度脱之。十力者。一是处非处力。二业力。三定力。四根力。五欲力。六性力。七至处道力。八宿命力。九天眼力。十漏尽力。无畏者。即四无所畏。一一切智无所畏。二漏尽无所畏。三说障道无所畏。四说尽苦道无所畏。于八众中广说自他智断既决定无失。则无微致恐惧之相。故称无所畏。三昧即百八三昧解释并如法界次第也。二大嗔门。般若即三般若。四边不可取者。观照般若即寂而照。不可以有取也。方便般若即照而寂。不可以空取也实相般若非寂非照。不可以双亦取也。而寂而照不可以双非取也。迦毗罗城如玄记。三大痴法门。前取舍二门虽具中道。而取门终以立法为宗。舍门终以荡相为主。今两舍门岂不具于二边。而终以双非为体。不三而三三门宛然。三而不三门门绝妙。初约无缘直示。二举鉴像难思。三引净名杜口。三引人证结。诸法无行经云。诸天子白佛言。世尊。文殊师利名为无碍尸利。上尸利无上尸利。文殊语诸天子言。止止诸天子。汝等勿取相分别我不见诸法是上中下。如汝所说文殊义者。我是贪欲尸利。嗔恚尸利。愚痴尸利。是故我名文殊师利。乃至云。我是凡夫从贪欲起。从嗔恚起。从愚痴起。我是外道是邪行人。诸天子言。以何事故自言我是凡夫等。文殊言。是贪欲嗔恚愚痴性。十方求不可得。我以不住是性中故。说我是凡夫。文殊。汝云何名外道。文殊言。我终不到外道。诸道性不可得故。我于一切道为外。诸天子言。汝云何是邪见行人。文殊言。我已知一切法皆是邪虚妄不实。是故我是邪行人。说是法时万天子得无生法忍。二欲满下常念感应四。初明机成德满。二一切下明诸圣所依。三故无下引无行经证。四一切下结成佛法。二此三下逆顺合谈二。初被物双示。就三烦恼常念求离。名为顺说。约三法门常念求满。名为逆说。满离俱时。但约悉檀去取说耳。二如华严下引经委证三。初证贪欲逆顺。说离欲际顺也。随类见女逆也。欲是烦恼是故说离。欲是法门是故说住。即离即住唯离唯住。离深住深。离极住极。今观世音乃是际极住离贪欲故。一切机求离求住。皆须常念。二又四下证嗔恚逆顺。以调一切顺也。苦楚治罪逆也。恚害烦恼是故须调。嗔恚法门是故须行。逆顺无二调行不偏例前贪欲其义是同。但欲是乐法故作实事接物令离。恚害是苦。故以幻事调他令离。若其机缘宜以实杀。而得益者。即如仙豫杀婆罗门为嗔法门。此乃假实互现例于贪痴。亦可幻设。但得逆顺相即之意。不拘假实也。三方便下证愚痴假实。如前火难。具引经文逆顺满离。例前二毒其义不殊。二次此下明二观慈悲。例前大士。本修三毒满离之观。复见众生为三毒过之所恼害。亦见欲满三毒法门。故起慈悲。誓令众生离三毒过满三毒德。今成补处邻极三毒。故能任运遍法界应。普令众生满离成就。然渐顿观皆观三毒。顿则满离不二而观。渐则初心但观于离。后乃满离相即而照。二结意机。经文可见

观音义疏记卷第二观音义疏记卷第三

        宋四明沙门知礼述

第三身业机应二。初列门。二贴文下随释三。初贴文二。初分经料简二。初分经。二文云下料简二。初独女求男问。二解者下女无子苦答二。初他谬解。二今解下今正释。二求男下依经解释二。初求愿二。初大师销文二。初释求男二。初唱经。二释义二。初分经三义。二愿与下略二解一二。初略愿行。二德业下释德业。二释求女二。初唱经。二求女下解释二。初明存略意。二女人下明相貌意。二有人下章安斥谬二。初斥非显是二。初叙他谬立。宿植德本众人爱敬。此之二句据义犹是女之德业。他师谬谓双释男女伏疑之文。意恐人疑。男之智慧女之端正。皆由修种忍智之因。非圣能与。不修而得堕无因过。故出彼意云。众人咸谓。观音但能交会父母等也。二私难下明今正义二。初难破二。初立义难。福慧受生皆由缘办。观音既能与其生缘。何不能与福慧缘邪。二难观下引文难。儿不修因。圣不能令有福慧者众不称名。何故得脱。此以现文破无因执。不用义解同心乞福也。二今明下正立二。初释。观音用遍三千法界。于诸众生得大自在。无生缘者令植生缘。无福慧者亦能令种。此等皆于中阴中作。故中阴经云。妙觉如来以神足力。将于无量四众八部。入中阴中。化作七宝讲堂七宝座等。彼中阴众生七日至一日。终者尽令住寿。如来与化佛说法教化。令七十八亿百千那由他中阴众生。起无上正真道意。经说甚广。尚能令彼中阴众生发菩提心。岂不能令植福慧邪。二今不下结。二结叹二。初两句解释。四句经文虽是结句。亦是释疑则可两向。若宿植德本众人爱敬两句经文。定属生女德业句也。二问礼下对前料简二。初问。二答。二引事。三观解二。初明果报二。初无子苦。阿鼻地狱无求子念。诸余轻系苦乐相间。六欲诸天皆有亲爱。故无子者而生苦恼。二礼拜下明机应。二明修因。有漏无漏一切善法不出定慧。即男女义。皆须修习并名修因。不同诸难。别以有漏之善名为修因二。初列章。二法门下释义二。初辩法门二。初以事表法二。初正表法二。初表世间法二。初明苦集。无始至今常为痴爱。及根尘识习熏资熏。生于惑业无量男女。此之眷属一切众生莫能舍离。二若外下示外书。易云。乾道成。男坤道成女。礼云。天子之与后犹阴之与阳。天子修男教后修女顺。二若就下表出世法二。初表能生父母。佛于一切而得自在。名为国王。尊严如父。经教含理开发智慧。养育如母。佛法和合生三乘僧。故经云。从佛口生从法化生。得佛法分。又权智历缘能成果用。实智冥理能生果智。故一切佛皆由此生。初则果能生因。次则因能生果。共成一义也。二又慈下表所生男女。净名云。慈悲心为女。善心诚实男。先据此文立于悲智。名为男女。冥中道智即是诚实善心故也。乃类此法立诸男女。初以禅慧对于男女。次分三乘以对男女。后约佛性见对不见。而分男女。何者。既以见性为丈夫相。即彰不见为女人相。复约照性自具男女。佛性正观决破无明。为福德智慧之男。中道慈悲含覆一切。为端正有相之女。二今借下结表意。二问那下释难明表二。初执无妨有难二。初立无男女理。二大经下引无男女文二。初正引教文二。初引大乘文。大经二十八云。涅槃无相。谓色相。声相。香味触相。生住坏相。男相。女相。是名十相。无如是相故名无相。次大论净名及安乐行皆列男女二名。非之以显无相。若不二门云。无定慧乃是男女所表之法也。二小乘下引小乘文。理无相故不可言说。无相即非男女相也。空平等故。离男女等一切相也。二男女下结无所表。能表男女既无。所表定慧安在。二答大下即遮而照释二。初广释三。初说默相即二。初据理妙绝。若论绝理尚不可说无男女相。岂可被论有男女邪。二善巧下被机有无。若于众生有四益者。或说无男女。或说有男女。故引天女。不离文字说解脱相。性空即脱。何妨文字。真无三世俗即有。二谛既即说默无违。二非有下明一二本融三。初法中道双非则无定慧。当体双照定慧宛然。言未曾相离者。即定慧不离法性也。二譬如下喻。岂因左右令一身异。岂可一身而废左右。三合只一觉性有寂照德。名为定慧。岂此二德暂离觉性。三言定下明定慧互具二。初约义明具三。初法。一觉静明名为定慧。是故此二终不孤立。二譬上以一身左右。譬于二德不离一性。犹恐谓其二德相离。故以二人左右譬之。此如修性不二门云。二与一性如水为波。二亦无二亦如波水。当以彼喻而寻此喻。三定慧下合。二何但下据文证释二。初慧具定。男本表慧而兼福德。即慧具定也。二文云下定具慧。慈心种相者。经云。清净慈门刹尘数。共生如来一妙相。即无缘慈定而修其相也。互具可知。二故知下总结二。初以一二相即结。此文男女各具二德。即表定慧二法互具。若非体一何能互具。故以互具。显乎体一。故二不二舒卷自在。二理实下以说默相即结。理非一二赴缘两说。如此说者何异不说。经示男女其德互具。表于定慧一二无异说默不殊。能此解者方得经文表法之义。二次明下与愿二。初示义门二。初明十番感应四。初果报。二修因下世善三。初五戒二。初表行法。二若不下求愿满。行人若为五种惑业。牵破持心。当念未来感报苦乐。归命观音。障退戒完二求即满。二十善。若例五戒妄摄口四。酒即意三。并慧属男。若自细作。不绮是真实属男。不两舌是和爱。不恶口是柔善属女。不贪痴是无染智慧属男。不嗔是慈属女。余同五戒。三修禅下。八定定即四禅四空各有修证。且论初禅五法为修五支为证。修以乐欲精进巧慧。此三方便分别属男。忆念一心此二方便静细属女。若证支林三支慧多属男。二支定多属女。若论二禅四支。一内净。二喜属男。三乐。四一心属女。三禅五支。一舍。二念。三慧属男。四乐五一心属女。四禅四支。一不苦不乐与第四一心属女。二舍三念清净属男。若论四空。一空处定。二识处定。三无所有处定。四非有想非无想定。此四虽无支林男女。而有微细四阴。通以四处受想为女。行识为男。若论四无量心。慈悲属女。喜舍属男。今且粗辩备在禅门。须者应检。三四教四。初三藏三初声闻二。初表行法。略举停心以为所表。念处乃至正道节节应明男女之义。以诸道品不出定慧二法故也。直缘谛理者。即四谛十六行观也。出观等者。历事之时。愍物执常为说四谛。名法缘慈。二若不下求愿满。出观男女者。法缘即正智之男。慈悲即柔和之女。既带空入假则历事不染故不畏诸有也。二支佛二。初表行法。缘方便等者。即凡地修福种相之时。名起慈观。慧观者。即观十二因缘无常无我发真约顿证之位。出观能用。生法二缘之慈。譬鹿回顾者。大论譬三兽在猎围求出不同。声闻如獐惊怖跳出都不顾群。缘觉如鹿虽顾盻群怖不停待。菩萨如大香象。虽遭刀箭拥群共出。二若不下求愿满。三次明下菩萨二。初表行法。方便智慧。或第六度分地世智。或辩六度邪正之智。或是事中伏惑之智。此皆方便也。此等犹是能生男女所被之机必修六度。乃以五一而为所生之男女也。二若定下求愿满。二通教二。初表法。小同三藏唯论菩萨。凡亦同前。唯于真位以智为男。以慈为女。二求愿下愿满。三别教二。初明男女生相。此教外凡为破见思所修。正助作意趣空。望中犹名有为有漏。五度福严故称为女。而知地上无作智严在今心性。乃缘此性通伏无明。名之为男虽缘无作为偏修空。尚违中理。故男女相遥。若入内凡见思破处。心趣假中顺于本性。名男女交。至回向位正修中观。名怀圣胎。证初地时即遮而照。慈智合发名为双生。得念不退无两边过。副本期故地名欢喜。二慈悲下明男女有能所生。初地慈智男女既是真因。任运能生上地男女。上地复生极果男女。是故诸佛皆以初地。为祖父母。仍辩慈智得名。所以慈悲称大者。以拔苦与乐物荷深恩。故称为大。十力无畏既唯自证。物莫能知故不称大。四圆教二。初表法。此教顿修。始心即用性德慈智。以为男女。方称经文双具德业。慈无偏缘故名端正。慈即佛相故名有相。女德备矣。智离边邪故名质直。智含万善故名福德。男德备矣。似位无明不覆而覆。名曰处胎。初住慈智不显而显。名曰双生。真慈出假爱见莫拘。真智趣果无似爱滞。亦不畏者同体权实。二皆无缚。二方便下愿满。四变易。言两番者。方便实报同名变易。乃以二土名为两番。若实报人断证虽分四十一品。皆是破于障果无明。唯求究竟慈智男女。故于此土论一番益。其方便人根虽利钝。法分渐顿而皆大乘。俱求佛智。此土唯望实报为益。唯求分真慈智男女。是故论益亦只一番。二复次下作三差料简三。初明人天定散二。初明有善禅之德。空居四天因亦修定。以散心强故但名男。例此四空以定强故。合云唯女。四禅诸支既对定慧即名男女。俱时而得故曰一心。二从三下斥无动出之功。三界功德虽名定慧。而皆爱味。或杂邪见都属有漏。是故男女无动出用。二从二下明藏通智断二。初明有无漏之德。二从二下明无中道之失。大经既以见佛性者。名为丈夫。故不见性皆名女人。无漏诸定不能发生中道之智。故如石女。二乘偏空名为定多。菩萨偏假名为慧多。此之定慧俱不能见。寂照平等三德之性。迦叶菩萨涅槃之前。岂是外道名。邪见者。盖未出二边。望中名邪。三唯有下明别圆地住。修因虽异证道是同。斯乃性德缘了。显为果中定慧。二故知下斥他局第三劝持二。初科经。二劝持下释义三。初劝持。二格量二。初科。二格量下释四。初格量本。经举六十二亿恒河沙不多不少者。佛顶首楞严云。此三千大千世界现住世间。诸法王子有六十二亿恒河沙数。修法垂范教化众生。随顺众生方便智慧各各不同。既是现住娑婆菩萨。是故特举为格量本。二问。三答。四正格量二。初约教释二。初约佛眼略示二。初以少格多。二问起答释二。初以人情问。二答佛下约佛眼答。佛眼所照称法界量。四多法界不增。四少法界不减。故云功德正齐。二问何下对他解广释二。初问。虽示佛眼称量不谬。其意难明。故须问起。先引古释方彰今义。二旧解下答二。初叙旧解非五。初引物论等。其福实殊者。谓六十二亿之福实胜观音。但是方便引物论等此解最谬。破意可知。二二云下田有高下。对劣显胜。不见观音证理之德。何名为叹。三心有浓淡。四时解不解。意谓观音虽少。称名之时解心现前。六十虽多。供养之时解心不发。是故多少得福乃等。此之二释皆在持供。心之优劣叹德远矣。五有缘无缘。父母有生育之缘。故供之福深毁之罪重。路人无缘故浅。文虽不斥理亦全疏。岂可观音但与众生有缘而已。二今明下明今义是二。初明今立义二。初约实际释。一多人法皆无性相。二空既显一实斯彰。存则假实暂分。亡则一多齐致。存亡不二方名正等。二一中下以经偈释。举华严偈释今经意。良由一与无量俱同实际。故互能圆解也。以实际之多生观音之一。故非是一。以实际之一生河沙之多。故非是多。既其一多无决定性。故互生非实也。照其事理者事谓一多之相。理谓融即之体。慎勿以多为事以一为理。二法华下引本论证论以持六十二亿河沙佛名为校量者。古云。论误。盖不解论意也。今具引论文并荆溪解释。方晓其义。论云。受持观音名。与六十二亿恒沙诸佛名。彼福平等者有二种义。一信力故。二毕竟知故。信力复二一者。求我如观音。毕竟信故。二生恭敬心如彼功德。我亦得故。二毕竟知者。决定知法界故。法界者名为法性。初地菩萨能证入一切诸佛平等身故。平等身者。谓真如法身。是故受持观音。与六十二亿恒沙诸佛。功德无差。荆溪云。以此验知。须依圆释。何者。于二义中。信力约事毕竟约理。事理相资方成所念。如信力二中。既云求我身如观音。即指化身。又云。观音功德我亦得之。乃指报身愿齐报应。方乃成念。但念果德者。何必识理。故次义云。知法界等。次引证位。即是初地且引分证。令人识之。故知若念观音三身。须却以念佛校之。若以念法身论之。纵引十方诸佛其功亦等。何但六十二邪。所以论文虽似举经。乃是增句释义。亦如方便。初加难解难知。欲说大法乃增三句。而为申释。今六十二亿菩萨加以佛释。二又约下约观释。虽三种观俱受修名。而中是性是故得云二观发中二观实不等者。破立不等也。虽乃不等而二皆是中道之德。二与中道毕竟不异。中道既等。二岂不等。是故言空三皆是空。假则皆假。中则皆中。乞人难胜其实不等。亦以此二同一法性是故等也。三结成。此但通云受持名号。以正格中言一时故。复引大品一华供佛。以类一时持观音名。其善流入法性海。故如海无尽。言至毕苦者。二死尽也。盖言成佛散华之福犹尚不尽。大章第二问答二。初标章述意二。初标章二前问下述意二。初述前科。称名常念及以礼拜。三业现前。故曰显机。菩萨以此为所观境。法身灵智即始本二觉。分合之真身也。望于众生即能观智。乃以此知冥应拔苦。即此境智而为因缘。亦名感应。以此因缘名观世音。蒙说已领。二今问下示今意乃明观音意业鉴机身业现相。口业说法。既令众生知觉见闻。故云显应。而且不说众生三业修行之相。此由宿善冥伏在怀乃能致感故曰冥机。通释十双即当法慈福应珠显权迹缘断十只之义。二分科释经二。初分科。二一云下释经二。初问二。初示三业文。方便问意者。非是道前取理方便。正当证后鉴机方便。二此是下明三业德二。初通释三业二。初标列三义。二三不下解释三义三初释三不护二。初法。作意等十字是其护义。实不两字彰于任运。然须不其三惑之护。即能三业任运度生。二譬如下谕。二三无下释三无失。不护显于思义寂绝。无失彰其逗会称宜。得三悉益即会事也。得第一义即冥理也。三三轮下释三轮二。初遍示三轮。三业应机旋转自在。能为众生摧破三障。故名为轮。二虽音下释不思议化二。初约义释相。心体离念。即是法身本性智慧。今虽垂应委悉被机。而能称本离于思念。故于法身无所损减二净名下引经证释。分别诸法证于垂化。于义不动证不思议。即理而事名不动而动。二问意下别明示意二。初问。二答。若随自意无能测者。若随他意昆虫亦知。又无机者不测。有缘者令知。二佛答下答二。初分经二。初别下释义三。初别答二。初悬示经意三。初明诸身。皆答三业二初释相二。初以三答三。二又但下约二答三二。初现身具三。二若说下说法具三。不如树木风吹作声。口兼身业其义易明。故不言也。二二释下结示。二从别下以诸身。束对十界二。初约义示。若据身说理合齐等。但约经中结说文少。故云十九。如八部四众伹结一说耳。二而文下足阙文二。初明菩萨二。初叙他四解。二若三下今取古本。若指上品今品那阙。若云脱落余何不脱。若言观音即是菩萨不须更现。妙音菩萨何故更现。故云。三解皆有难也。若依古本。即今品文菩萨一界为化义广。最不可阙。二又无下明地狱二。初叙三释若指上品亦可为例。其次二释人之局情耳。二今明下明今有义二。初依总答明有。总文既云现种种形。岂可无于地狱形邪。二又请下据二经明有。请观音经游戏五道文。先明地狱。方等陀罗尼经说。婆薮大权示为商主。坚执邪见杀羊祀天。生陷地狱于地狱中。说法教化九十亿罪人。来至佛会皆令得道。那言代苦不论说法。况复论云多作佛身。岂不说法。三今通下约诸身对机四句二。初释相二。初通示四句。经云众生应以佛身得度。即现佛身为独现佛。为兼余身同度彼生。又为一界独感于佛。为兼余界同感于佛。诸身乃至执金刚神能应共独。能感共独不可偏执。故今通就十法界应。对十界机。一多相对立以四句。方见经文感应之相。二别对三相。不唯感应多少成于四句。人法因果亦有多少故。须更立两重四句。初机应四句二。初若妙下释四句四。初一界度一界。三即下三土以现佛身。必遍三处。盖等觉下至于凡夫皆能感佛。故须三土以明其应。初实报能度所度纯一佛界。二方便土就本而说。故曰五人。生彼土已没其异称。以皆求佛。是故感应亦纯一界。三同居土且明寂场圆机感佛。不论形类及兼别机。是故亦当第一句也。二若寂下一界度多界。更以寂场对于次句。不唯形异亦乃根殊。能感虽多能应唯一

问。何不二酥对于次句。那将初乳配两句邪

答。本论佛界度于多界。二酥之佛胜劣相合。钝见劣身尚是偏空。体非佛界。故以寂场一中道佛。度于圆别佛菩萨界及五道形。方名一界度多界句。三若有下多界度一界。诸时诸会三乘八部翼从世尊共化一机。或诸大权共成化事。或佛自遍现而度一机若有一人应以十界身而得度者。观音即现十身而为说法。四若佛下多界度多界。文中且约作十界身。遍入诸道而为此句。若委论者。或有多机同在一处应以十身而得度者。亦随彼现也。用此下历五味。若就根性为能感机。就所证体而为能应。则乳唯得一界度二界。醍醐唯得一界度一界。若就形相为感应者。则味味中各有四句。既云应以何身得度。知正约形为感应也。学者应知约土约味。别对句者欲易解故。若见一多四句相。已一切时处应自在作。二复次下人法四句。上之四句以人对人。今之四句以法对人。此由经云而为说法。故须更论人法四句。初句云。善财从百一十者所历之城也。知识即五十三人也。虽带人辩意在所说法异。二三两句可见。第四句云。一道出生死。而言多法者。盖于法法开佛知见。以开十界十如。皆是实相即不思议之多法。此四能被多少之法虽引诸经。皆显观音能应之德。三复下因果四句。上二四句对机说法。法须修证从因至果。自若不然他何所效。如转四谛灭我已证。道我已修。故诸身说一一皆有因果始终。方能被物。故四句中戒善粗略。感报亦然。故因果俱少。声闻因中凡分内外。圣有见修正助行法。遍于三藏。而只证得二种涅槃。故因多果少。独觉不禀三学行法。但观雕变顿成果已。能具种种神通化事。故因少果多。菩萨修因时长行广。及成佛果二智万德。故因果俱多。此等皆是悉檀示现。修因证果大略如是二观音下结示二。初结归圣能。二有人下叙他斥局。虽因果迭论一多互说。不能显于权实体相。今以十界三重四句。望彼之义尘岳相殊。二旧释下科释经文二。初科经二。初旧科二。初分三枝末。二若尔下释疑问答。二今明下今科。二一明下释义八。初圣身四。初佛身三。初垂应相状二。初约身简定二。初定应化。化则变化。欻然而有欻尔而无。盖是暂时益物相也。应则应答同物始终。如极乐人民。寿不可数佛同无量。此土寿促佛同八十。有降生日有入灭时。即八相佛也。若寻等者。据列三乘八部四众。至金刚神。宛是一期化物之相。知非欻尔也。二问何下拣真应二。初问。因向文云。妙觉法身应于三土说法被机。既本是真佛。何用垂应方说法邪二答。虽云多种。岂出四身法报应化。法身则远而难示。应化则近而易狎。报身则亦远亦近。智同法身像属胜应。般若赞云。应化非真等者。此以真法而夺应化。是则无相之相方名真佛。无说之说方名说法。据妙觉法身等者。此据住上品寂光。方是真法上地菩萨亦莫能睹。以等觉还皆住果报并依业识见佛。若望妙觉俱是胜应。故云真法渊远。如妙音等者

问。妙音东来。先现八万四千众宝莲华。文殊见已而问于佛。据此亦是不识应相。那忽引证不知真身

答。斯乃见迹不识其本。即是不知真身也。故下问云。是菩萨种何善本。修何功德。行何三昧。即真法也。二若从下就土分别三。初实报二。初示应相。圆满相好者。如华严如来相海品。及随好光明品说十莲华藏世界。微尘数相一一皆以妙相庄严。说一实谛者。若约教道。实报犹有别教根缘。亦说无量四谛。今约实论也。二示机宜。四十一地皆与妙觉分同体用。故不可以九界之身并劣应应之。二复次下有余二。初论有无二。初大小有无。方便实报二土俱受变易生死。偏目此者。上土分破此中全在。从强受称也小乘不说常住佛性。见思若尽果报永亡。大乘谈常。故三界外更立三土。无明全破则居寂光。分破实报全在有余。五种意生身即全在者也。楞伽但明三种意生身。今家约义开为五种。且三种者。一入三昧乐意成身。此拟二乘入空意也。二觉法自性意成身。此拟通教菩萨出假意也。三种类俱生无作意成身。此拟别教菩萨修中意也。若开为五者。于三昧开两教二乘。于觉法开别教十行。或作七种两教二乘。各开为二。不云别教十住者。义同二乘入空故也。若论九人生方便土更取别教十住。及取圆教十信。摄入三种意生身中。以未断无明未生实报。通言意者。以未发真。皆是作意成之。以生并从果说。此依妙玄并辅行撮略而辩。二释论下经论定判。二此应下明机应二。初明但示两应。初示胜应者

问。前实报身而云此应非余土堪。至此那云圆满相海。如前实报

答。彼应真机与应分合。此应似机与应未合。此犹作意彼则任真。能见既殊所见宁一。但为此机无明已伏或少分除。故用报相引令入真。云如前者。稍似实报非谓全同。二示劣应者问此土一佛。示于胜劣两种相貌。与同居土尊特丈六合身之相。同异如何答方便两应。但说次第及不次第二种大乘五种意生。其土禀教虽有利钝。既皆禀大学佛智慧。俱知佛身是大觉性。能修中观伏无明者。见相则胜。若在二观未伏无明。见相则劣。相虽胜劣只一尊特故非合身。若同居土说通教时。钝但见空。故感丈六利见不空。故感尊特。大小二机。于一佛身见解有异。故名丈六尊特合身。此纯大见故不名合。二何故下明唯被二机二。初总示。二若圆下别示。言圆人无明未破者。即七信已上。言分破者。仁王般若说十地惑。有三十品。既于一地自有三品。是知圆圣四十二位皆有三品。初住三品即第十信三心用观而对破之。初心用观对于上品。破则中心。中心用观对于中品。破则后心。后心用观对于下品。此品若破方名初住。生实报土。今云分破犹生方便。即第十信中后心也。如等觉人住于后心。经历多劫。方破下品证入妙觉。别九向位十向初心。俱名未破。第十回向中后二心。名为分破。此圆别人俱修中观。伏破无明虽生方便其根既利。感佛胜身说圆顿法。别第七住至十行位。及通菩萨偏观于假。藏通二乘偏在于空。此等生在方便有余。虽已知常。求佛智慧尚滞二边。并未观伏无明之惑。其根既钝。但感劣身说渐次法。三凡圣同居土。或称净秽同居土。谓净土秽土。各有凡圣而同居之。释此为二。初释相二。初通明二土二根二。初明所感二相三。初二土净秽。论土净秽有横有竖。若以分段对于变易。为净秽者。则约通惑尽不尽说。即竖论也。如释论云。出三界外有净国土。声闻缘觉出生其中。若于分段自说净秽。则约五浊轻重相对。即横论也。今以极乐及善净国。对于堪忍。是横非竖。故使净土有见思毒。无恶道名。毒非苦因。则见与烦恼二浊轻也。果报严净劫命轻也。众生居此有何鄙称。弥陀愿行摄之。故轻非是断惑方生其中。以世慈善五逆称佛亦能生。故娑婆秽相目击可知。此是横论净秽二土。而此二土皆有凡圣。凡如前说。圣有二种。谓应来圣有修得圣。二土皆然。二两根利钝。浊重之土论悟道根。自有利钝浊轻土根亦有利钝。以土对根故成四句。三五浊轻重。身形至卑小即众生浊。时节粗险即劫浊。余三名显。净土不尔者。如大本疏问云。既言五浊何者是五清。答准例邪正三毒。邪是五浊。正是五清。他方净土无邪三毒。则五障轻也。二何故下明能感二行。言福德者。即三种福也。如观无量寿佛经云。一者孝养父母奉事师长慈心不杀。修十善业。二者受持三归具足众戒。不犯威仪。三者发菩提深信因果。读诵大乘劝进行者。此三种业三世诸佛净土正因。彼疏云。初业共凡夫。第二共二乘。第三是大乘不共之业。彼经云。欲生极乐国者。当修三福。故今云。多修福德不多修福。为二土行。就此福而论也。二若秽下别示秽土二根二。初示乘戒四句二。初立句相戒论十戒。唯取不缺不破不穿不杂。此之四种前三事戒后一事定。皆人天因。不取随道无著智所赞自在。随定具足。以此六种虽名为戒。体是三观自属于乘。乘论五乘不取人天。以其二种虽名为乘。不动不出体是漏善事戒所摄。唯取三乘以声闻等该于四教。是入理智虽分深浅。皆能动出烦恼生死。故得名乘。今以四戒而对三乘。论于缓急以成四句。二戒急下判所感。乘戒约过去。机感约现在。二机有下明大小二根二。初通明大小感佛。不问事戒有持有毁。但论习学理乘大小。是故文中置戒明乘。故涅槃云。其戒缓者未名为缓。于乘缓者方名为缓。以戒缓者唯失人天。若其乘缓无解脱路。乘分大小。昔为偏真修观行者。今作小机。唯感劣应佛之形声。昔为中道修观行者。今作大机能感胜应佛之形声。言降神等者。如来昔于大通佛所。覆讲法华与无量众生作一乘因。中间退大染着五尘。佛恐堕苦。遂以小乘而救拔之。或用衍三而引导之。如是大小种种成熟。堪于今世悟入佛乘。是故如来为此一事出现于世。然其机发复少差别。故于一代而分五时。有机堪能直入于实。有机但能迂入于实。虽此二类熟在一时故。于华严顿谈圆别。被二种机。此机从始即见胜相。若于中间习小深者。虽于今世入一佛乘。而小先熟。故为此机示现劣身。初说三藏。诸味调熟。来至法华方开佛慧。此机于始唯见劣身。故降母胎即示两相

问。华严顿后方施小化。譬如穷子急追不至。徐语方来。前顿后渐其义善成。今那忽云降神母胎即示两相

答。诸文所论初顿次渐。盖是化仪施设之语。今此所说大小双应终归一乘。方尽鉴机始末之事。如方便品。思无大机念欲息化。诸佛劝谕方施小乘。次文却云。无量劫来赞涅槃法。生死永尽我常是说。是故思机然后施小。此等之说皆是仪式。不可据此以难今文。预鉴群机原始要终。度物之意也。二顿机下别示大小得益二。初大机益相。一类众生大种先熟即感胜应。入胎住胎出胎成佛其相皆胜。转一实谛即华严部。顿说圆教。既兼别教。故云无量。彼经预叙一代始终。故立譬云。犹如日出先照高山。次照幽谷。后照平地。今家义开平地为三。对于涅槃五种牛味。高山大机能感顿教。日光前照。即有次第及不次第见佛性也。若涅槃中譬从牛出乳。次第五味。则对一代五时教味。次第相生。今明顿机。能见佛性。是故兼用食草之譬。乃以雪山譬舍那佛。忍草譬十二部经。牛食譬大机修观。即得醍醐譬见佛性

观音义疏记卷第三观音义疏记卷第四

        宋四明沙门知礼述

二若小下小机益相四。初酪益二。初明小机应。即是小种先熟之者。初感劣应。始从入胎至于成佛。其相皆劣。拘邻或邻儿或憍陈如。此五人首也。其四人者即阿鞞。跋提。摩诃男。拘利。太子初于鹿园证四谛理。名得甘露。此乃佛日次照幽谷。二既非下对大甄拣二。初进对法华拣悟。初教得道虽曰甘露。既非第五醍醐之味。岂得度于二种生死。故未名得度。故云等者。引此经也。但用一门解脱虚妄见思之缚。其实未得一切境界解脱尘沙无明惑累。其至灵山方证斯脱。二未堪下退就华严辩机二。初于大名乳。此中乃以证小之后。遇大不闻。以验在凡机。不受大。以聋哑文在经后分。其时仍长。义当方等般若之时。亦可通在鹿苑之前。是故迦叶却叙小机蒙大拟时。迷闷躄地以后显前。机未堪大其意宛然。虽有冥益。其如见爱炽然现行。故机在华严全生如乳。二闻方下于小名酪。急追付财称怨大唤。徐语除粪欢喜随来。乃施方便说三界苦。以畏苦故断见思集。既革凡成圣。名转乳为酪。次闻下生酥。四教俱演横摄众机。小闻弹诃渐能慕大。密得通益。钝根菩萨益同二乘。调此等机得生酥味。应知约教明五味者。不取浓淡但语相生。以其顿乳即醍醐故。若约机者有浓淡义。然就三乘极钝者说。为此一类于彼华严全无显益。如腥血乳说三藏时。此机成酪。次第渐浓至于极味。次闻下熟酥。不谈三藏具示衍三。利根之人入圆者众。声闻至此被加转教。既于真空具谈万行。故令钝根冥得别益。约调渐机名熟酥味。四次闻下醍醐二。初法华二。初明三乘皆得成佛。舍前三教方便四谛。但说一实无上之道。复开三教方便之门。皆是一乘真实之相。乃是此经待绝二妙。谈兹妙故。方令二乘焦谷更生。三教菩萨权疑永息。是故无一不成佛者。二故云下证一代俱入醍醐。若大机先熟。华严初见即入佛慧。若小机先熟。即须渐引。今闻开废方得佛慧。初得今得皆是佛慧。俱譬醍醐。但彼兼别至此纯圆。二若复下涅槃。开显之意法华具彰。执权之机大阵已破。更须涅槃收其余党。故法华后复谈般若。调熟其心。令于涅槃得醍醐味。是故彼经就般若部后分结撮五味。次第云。从摩诃般若出大涅槃。说胜三修者。彼经明三种三修。一邪二劣三胜。邪即世间邪师所教常乐我也。劣即依佛半教破于邪执。谓无常无乐无我也。胜即依佛胜教破于劣修。谓常乐我也。法身常恒无有变易。游诸觉华欢娱受乐。具八自在无能遏绝。如是修者入秘密藏。名胜三修。二是为下结例三。初结佛身。二或示下例余身。佛身既能说五时教。若示余身。亦于五时引诸实行。随味而转。复须论于示现多身度于一人。或一度多或一度一。或多度多约人既尔。人法因果多少相对。各成四句。故初悬叙立三四句。方尽身说感应之相。三秽国下例净土。如安乐世界。菩萨无数声闻亦然。良以法有顿渐。是故人分大小。具如九品。生彼土后入大小位。皆由闻法。验知应彼净土度生。须论渐顿二种身说。二此中下本观慈悲。如上所明。三土垂形五时化物。秽指释迦净约弥陀。二佛化事教文备彰。以显观音示现佛身与此不异。分真究竟体用同故。果用若此岂无本因。故今却寻本观誓愿。是修别圆观行之时。起慈悲誓。期遍法界现身说法度诸众生。今住寂光本誓所熏。能遍三土。形声利益例前赴难。本誓文中已备说也。三问经下简土名体二。初辩土名二。初问。娑婆之名翻为堪忍。于同居中尚不通净。那得具约三土释邪。二答。菩萨举一以为问端。如来称法周遍为答。故云。以种种形游诸国土。横亘十方竖彻三土。故言诸也。皆是观音应身游处。此约如来答过于问。据文释也。若更约义其相宛然。何者。经示方便及实报土不离娑婆。故云若闻长寿深心信解。则为见佛常在耆阇崛山。共大菩萨诸声闻众围绕说法。既云常在耆山。则劫火洞然此土安隐。复以菩萨共诸声闻。而为听众。岂非娑婆即方便土。复云。又见娑婆世界。其地琉璃乃至楼观皆悉宝成。其菩萨众咸处其中。既云又见。即非前处唯有菩萨。不共声闻。即纯菩萨而为僧也。验知娑婆即是实报。此文皆是四信妙观即于堪忍。而见二土。观音深智游于娑婆。岂容独应同居秽邪。二问二下明土体二。初问。大论云。出三界外有净土。声闻辟支佛出生其中。受法性身非分段生。即方便土也。大品云。法身佛为法性身菩萨说法。其听法众非生死人。但云菩萨不共二乘。即实报土也。二土不同皆称法性。云何分别。二答。小乘灰断无界外生。论云出界。复云受身。此据大说。大乘法性体本常住。即是一切色心之源。何者。小谓色心因见思有。故因缚断其果永忘。大说色心因惑生灭。不因惑有体是法性见思。若尽无明全在则当真谛法性色心。方便生灭无明分破。本性分显。义当中道法性色心。实报生灭。无明究尽。则复本性常住色心离生灭相。常寂光也。今明方便及实报土。法性名同。约断惑论真中大异。二次明下菩萨二。初明应相二。初辅佛不同。横论四教竖则三土。同居四教各有教主。各有菩萨辅翊化机。方便二教实报一圆。各须菩萨辅佛逗缘。二赴利下赴缘有异。大略而分。顿部根利渐教根钝。若委论者。顿中别钝渐中圆利。所说之法随机废兴。辅佛菩萨亦随改转。不可文备宜准教思。二此中下明本观。佛章略述。二支佛。若论独觉。既不值佛禀教。何能说法。欲化众生但现神变。今云说法。乃论佛世禀因缘教者也。此明权示亦引其类随味而转同声闻也。四次明下声闻二。初明所现。二内秘下明能现。前列所现全同实行。今明能现知是大权。此中有四。初能现意。外示权迹。意在庄严涅槃双树。言双树者。四方各双。东方一双一枯一荣。南西北方亦复如是。东方枯荣表常无常。南乐无乐。西我无我。北净不净。如来于中。北首而卧入般涅槃。则表双非常无常等。经文略举因中六人。即是身子目连空生那律迦叶阿难及果一人。即如来是。此皆善能庄严双树。斯盖如来与身子等久证三德。欲令众生得入秘藏。双非常等真四德故。初于三藏主伴相与同诸实行。殷勤修证无常无乐无我无净。成四枯也。次于二酥褒圆折偏耻小慕大。说菩萨法。引诸众生破于无常。修学常等成四荣也。至法华会及今涅槃。引诸众生。皆同证入非枯非荣中道四德大般涅槃。经示主伴一代化功。今已成就乃于双树中间涅槃。而表显之。故云六人及以如来能严双树。观音示现声闻之身。其意如是。二次引下能现人。善财所见诸善知识。如海云比丘善住比丘。现声闻身说别圆法。二乘机扣即说藏通。既住不思议法门何所不说。此合今文人法四句。三次引大下能现法。上总约法彰能现人。今此的示现小之术。故引大经四种之智观十二缘得四乘果。观音若修别观。则次第用四智观缘。若修圆观则一心用四因缘智。而于一一皆起誓愿。度诸众生。不取四相不舍四法。不取故非有不舍故非空。双遮二边即无缘誓。双照生法。即四慈悲。今行愿成故遍法界。现四形声普应一切。今于四中的取下智。为能现法。四问下寄料简二。初问。因前分别以十界身应十界机。一多交互。虽成四句而终有佛度于佛界。故有今问。答中等觉度初地者。约别教义也。以圆六即佛义太宽。别教登地佛界义显。何者。别教三贤用于三乘所修观法。入地证中迥超九界。始本分合体用同佛故。然是分证惑必厚薄智论浅深。是故上位现化他佛。度于下位自行之佛。取譬人中师度弟子。须知能度之佛或现八相。或坐华王。所度之佛必作因身。以佛威仪非禀法相故。四教佛皆无师智。又今一往且云等觉度于初地。若本下迹高。可云初地度于等觉。以示佛迹是妙觉身。乃由极果加被故也。二二明下天身六。初梵王二。初释名相。二观音下明本观。此天依正多是白色。观音因时观于白色。即空假中住白法界。即是此有真常我性。名王三味。不取不舍者。不取此禅有相。谓见思也。不取此禅空相。尘沙也。不取此禅亦有亦无相非有非无相。无明也。则不随三惑生于此禅三土也。以不舍故。即能应为凡夫梵王同居也。复能应为方便梵王。即阿含云。已证三果将入方便土也。复能应为实报梵王。即仁王云。证七地故说出欲论。亦三惑欲也。四句现身。即是感应一多相对。以成四句。以权引实。引三土实行人也。具如佛章。下去诸身皆应例此。二帝释。三自在。四大自在。五天大将军。阙释毗沙门以可见故。三小王下人身五。初小王。二长者。十长人之德。如大本疏第五云。世间长者备十种德。一姓贵。二位高。三大富。四威猛。五智深。六年耆。七行净。八礼备。九上叹。十下归。姓则三皇五帝之裔。左貂右插之家。位则辅弼丞相盐梅阿衡。富则铜陵金谷丰饶侈靡。威则严霜隆重不肃而成。智则胸如武库权奇超拔。年则苍苍棱棱物仪所伏。行则白圭无玷所行如言。礼则节度庠序世所式瞻。上则一人所敬。下则四海所归。内合如来十种功德。及观心十德。具彰彼疏。三居士。四宰官。五婆罗门。四次列下四众。比丘者。或言有翻。或言无翻。有翻者。此云除馑。众生在因无法自资。得报多所馑乏。出家戒行是良福田。能生物善除因果之馑乏也。无翻者名含三义。一破恶。二怖魔。三乞云云。比丘尼者。比丘同前。尼者。此翻女也。优婆塞。此云近事男。优婆夷。此云近事女。以受归戒堪近事出家二众。又在家二众。或翻为清信士清信女。五妇女。六童真。七八部。八初天。二龙。三夜叉。四乾闼婆。五阿修罗。六迦楼罗。七紧那罗。八摩睺罗伽。八金刚二。初释相。二问答二。初问。二答。第二总答三。初牒章示文意二。初牒章。二示文。二初名下依文明义广二。初依文释二。初明垂应遍三土。就同居说十方土异。约上二土则无异域。故同居对方便一异分之。方便对实报融不融别。实报对寂光相无相简。若同居中众生种类。尘沙莫喻。观音悉能示其三业。而度脱之。经文所列三十三身盖略示也。欲彰周遍。故总示云以种种形游诸国土度脱众生也。二以种下据总文示三广。不明三广。但依别答。则成限局观音应化矣。二言虽下结义广。三善财下按义显他狭二。初明文广义狭。二斥违义立宗。若寻今意。一菩萨身能现十界。复云以种种形游诸国土度脱众生。三广义彰不可思说。经文明示普门示现。佛意令知本性发明。就何文义云梦幻不真。乃是刚然贬挫妙典。故知此师但见文略不究理圆。故作斯判矣。第三劝供养二。初标章立意二。初标章。二佛答下立意二。初明始终相称二。初示今立章二。初前后皆三。二初叙前三。二佛答后下示今三。二而总下明总别互举。二有人下斥他伤义。前三后三始终开合。各得相称。若以总答为叹德者。则令后三义不相称。佛以总答广前别答。若废总答。则令三广义意不显。故云伤义。二问后下问答释疑二。初番二。初疑前无奉旨。二答默念成机二。初明默念。前劝持名唯令心念。是故受旨但当冥默。后劝供养。必假外物以表内怀。是故解璎而为法施。二又欲下互成机。前陈三业已是显机。奉旨默念更成冥感。今但宿善即是冥机。奉旨解璎即成显感。前后互现。各有深致。二番二。初问以机难应。二答以机显应。二初劝下依文释义二。初分文。二先称下释义二。初劝供养二。初称美。二出供下出意。若佛顶首楞严经明十四种无畏功德。即以救七难。赴二求免三毒等。为施无畏。今品既在第二问答之后。明施无畏。似用现身说法为施无畏。若据文云。于怖畏急难之中。能施无畏。亦可总该前番问答。是则真应二身俱为能施。冥显二益皆得无畏。二奉旨二。初科。二经文下释六初奉命二。初释解璎二。初事释二。初评众宝文。二若依下释百千价二。初问。经以事璎表于行璎。诸地功德庄严法身。既有阶差。故以世宝贵贱为表。今无尽意入位既高璎珞合用无价之宝。岂可止直十万两金。二答。言百千者。略举多数如云百姓。岂局一百。万民亦然。约位辩璎必无价也。二若就下观解。所言百千。乃以事数表于理观。岂专约事定其多少。颈是所严故表中道。此性德也。全性起修。故能严行皆无著也。此行称性如璎在颈而言解者。菩萨虽有上求下化一切功德。未始不与常舍相应。欲示众生常舍行故。乃解璎珞而为施也。大集盖明行璎严理。一地成万者。了达一心。十界百法百界千法千界万法。此之万法性本具足。全性起修转名万德。即三学六度三昧。总持神通智慧。四等四摄三念八脱。十力无畏十地。悉能分证。万德即成十万。故知言数不专事也。二法施下释法施二。初旧取重法施。因重圣法故行财施。是则财法分为两派。理岂然乎。二今明如法施。法是三谛圆常理性。今体财即性诸法趣财是趣不过。财尚叵得。云何当有趣与非趣。故财与法无二无别。财外无法。法外无财。岂唯财尔。施及受者皆空假中无非法界。如是乃名以法界心。对法界境起法界施。于财下引净名经。以一璎珞分作二分。一分施与最下乞人。一分奉于难胜如来。而作是言。若施主等心施一最下乞人。犹如如来福田之相。无所分别。等于大悲不求果报。是则名曰具足法施。彼疏释云。此即观所施田入平等法界。无有二相成无缘悲。具足一切佛法。不求缘修之报。即是具足法施之会。如此明文诸师何得但约说法以明法施。疏文彼经居士观于悲田。法界等佛。今无尽意对于敬田。既称法施。岂不等彼一切众生邪。二不肯下不受二。初事释。二观解。不受三昧即毕竟空。一心三观破无不遍。以即空故不受于有以即假故不受于空。以即中故不受二边。照空假故不受中道。如是不受在一心中。方离次第及以但空。以五不受义遍衍门。应当料简。三重白下重奉。三义解愍。前二自行后一利他。此犹事释。以无等者。复约理观求观音受。何者。圆论不受则于诸法无所遗。故毕竟不受即毕竟受。故云。以无所受而受诸受。四佛劝。五受施。观音本地唯佛能知。今现因身须求极果。故虽受施回奉敬田。以一璎珞作二分者。表于一行必具二因。理则正因。事则缘了。事理不二名曰妙因。能成二身不思议果。法无增减而能出缠。性即修故报有断证。然匪功成修即性故。若其然者。方曰事理之因趣于法报之果。不论应身者。因人趣果合表二身。法报若成应用自发。六结德。文后重颂什公不译。诸师皆谓。梵本中有。荆溪云。此亦未测什公深意续高僧传云。偈是阇那崛多所译。智者出时此偈未行。故无所解。荆溪亦于辅行记中。引还着于本人之文。故知具释理亦无妨。近有天竺寺式法师。分节其文对于长行。二种问答宛如符契。今依彼科略消此偈。偈有二十六行分三。初一行双颂二问二。初一句叹德。世尊具相诚由万德之所庄严。是故叹相。即是美德。次我今下三句双问二。初一句含上二问。长行先问得名因缘。次问三业游化之相。今既重颂岂阙后问。故知句中问彼两字兼含次问也。二佛子下两句别颂初问。文甚显著。二具足下二十二行双颂二。答二。初二句经家叙。缉缀之语。合当直说。今为偈者。或集经者乘便颂之。或是崛多以偈翻之。贯散无在。二汝听下正颂佛答二。初一行半加颂总叹愿行。汝听二字敕令审谛。观音行者。一心三智观彼类音。令无量苦一时解脱。即是已成利他行也。不动真心垂形三土。方名善应。处处现往故曰诸方。此二句总叹所克真应二身。次则总论能成行愿。初明始心四弘愿广。复示行行经劫难量。以誓深故长时不退。以时长故值佛唯多。随佛作为。方名侍佛修诸佛行也。一一佛所皆发净愿。后心别愿也。若不尔者。安得真智遍拔众苦。安能应身普度一切。二我为下别颂二答二。初颂初答观音得名二。初一行颂总答。举要言之。故云略说。闻名故称口业机也。见身故礼身业机也。心念正当意业机也。上明冥应。今云见身二应具也。亦可见于妙智之身。不亏冥应。长行总答机但称名。而别答中机具三业。至今重颂总中三业。别但心念绮文互现。颂之巧也。二假使下颂别答二。初十二行颂七难。十二初一行颂第一火难。如前疏释。下去诸难皆可例知

问。上长行中求离三毒。常念观音。疏云。常念乃是正念。体达烦恼即是实际。无能无所。今偈那云念彼观音。彼此既分岂忘能所

答。圆妙之教不可情求。文似相违义归一揆。即于无差而说差故。岂有差别异无差邪。今文言彼。义当两向。若就佛说观音为彼。即是师弟而分彼此。若就众生。念彼观音此乃感应。而分彼此。师弟感应妙教诠之。皆是法界一一圆融众生。乃感心中彼佛。诸佛还应心内彼生。此教行人或遭苦难。念彼观音。岂谓能念异所念邪。以知皆是法界故也。达彼观音即念而具。既知即念有何能所。故彼此虽分能所俱绝。是故偈文虽云念彼。与上正念全不相违

问。求脱苦难。心念观音一切机缘俱能感圣。今释念彼那但约圆。岂果报等机全不能感

答。王三昧力救一一难。皆论十番。始离恶报终入寂光。十界众机谁不蒙益。疏释前答。此义备彰。颂开七难而为十二。各合具明十番感应。但以部意正在醍醐。是故长行佛示意机。唯令常念。常念必须绝于破立。今闻重颂念彼观音。必合疑云前令绝所今教念彼。岂不相违。故须约圆释此伏难。彼此即念能所岂存。学者应知。观音应物虽无所遗。今宗示人唯在妙观。是故前疏释乎意机。全废余涂。一向圆解。至今重颂念彼观音。岂可异前。自从浅解违大师意。劝今学人。若说若行勿离圆观。一苦一乐常念观音。既成妙机何爽圆应。一实事益念念常沾。二或漂下一行颂第二水难。三或在下一行加颂堕须弥峰。四或被下一行加颂堕金刚山。五或值下一行超颂怨贼难。六或遭下一行颂刀杖难。七或囚下颂幽执难。八咒诅下加颂咒诅难。还着本人者。凡咒毒药。乃用鬼法欲害于人。前人邪念方受其害。若能正念还着本人。如譬喻经中。有清信士初持五戒。后时衰老多有废忘。尔时山中有渴梵志。从其乞饮。田家事忙不暇。看之遂恨而去。梵志能起尸使鬼。召得杀鬼。敕曰。彼辱我往杀之。山中有罗汉。知往诣田家语言。汝今夜早然灯勤三自归。口诵守口身莫犯偈。慈念众生可得安隐。主人如教通晓念佛诵戒。鬼至晓求其微尤。无能得害。鬼神之法人令其杀。即便欲杀但彼有不可杀之德。法当却杀其使鬼者。其鬼乃恚欲害梵志。罗汉蔽之令鬼不见。田家悟道梵志得活。辅行引此云。正是观音经中还着于本人之文。九或遇下追颂罗刹难。十若恶下加颂恶兽难。十一蚖蛇下加颂蛇蝎难。十二云雷下加雷雨难。足前七难而为十二。皆须具约报业烦恼六道。四教一一释之。若论所表不出六种。须弥金刚亦是地种。雷雨属水。兽蛇咒诅同是有情皆表识种。菩萨因中于此大种修别圆观。今住六种如实之际。故遍法界救诸苦难。皆令得住六种本际。斯是观音证恶法性于恶自在。方能任运遍赴诸难。以要言之。一切依正皆是观音妙身妙心。一切众生于圣色心而自为难。求救三业亦即观音。是故机成即时而应。当以此义念念观之。何患不同观音利物。二众生下一行总颂三毒二求。一切众生多于界内贪嗔邪见。及以界外三毒之惑。外则无于报得男女。内则乏于定慧男女。致招二种生死困厄。是故名为无量苦逼。若其能以正助为机。即感真身妙智之力。救于二种世间之苦。疏解长行三毒二求。义该一切。对今重颂更无所遗。二具足下颂次答普门示现二。初正颂示现二。初一行超颂总答。长行先别后总。以总结别。今颂先总后别。开总出别。前后互显矣。长行总答云。以种种形游诸国土度脱众生。今颂却论能应之由。由神通力及智方便也。若匪千如全体之用。不名具足神通力也。通虽性具。复由广修妙智方便。照性发通故。得普门示现自在。十方无外三土非他。不离一心遍应诸刹。二种种下追颂别答。上长行中别列诸身。身皆三业。今颂别示三业。业皆遍周。重颂之巧也。文三。初一行别颂身业普应。合明十界但示三涂。以下况上也。又种种恶趣通指九界。九界望佛皆名为恶。次别举三涂极恶故也。九界二死皆有四相。渐令除灭归于常寂。二真观下颂意业普观二。初一行明本观慈悲有五。观字皆去声呼。具明三观及以慈悲。真观空也。清净观假也。假从空得无见思染。故名清净。又空唯自净假令他净。故名清净。又不思议假三观具足离三惑染。故名清净。广大智慧观中也。双遮双照无偏无待即平等大慧也。此之三观或次第修。或不次修。无不皆以慈悲合运。而其慈悲皆称观者。其意有二。一者慈悲是观如四无量心。名四种禅。禅即观也。观音乃以无缘慈悲。观察众生名慈悲观。二者慈悲之法必用三观。良以三观能成众行。用三观拔苦故名悲观。用三观与乐故名慈观。故上文云。即时观其音声皆得解脱。岂非悲心用于三观。虽有二解体是一也。菩萨从初至于邻极。三观慈悲未始离念。故令众生常愿修此常仰兹观。疏解长行冥显二应。因中合有本观慈悲。后译重颂果有其文。信智者言冥符佛意。二无垢下一行明智光遍照。三观慈悲因中立誓也。智光遍照果上益物鉴机也。无垢净光照穷正性察其本末。若其不破三惑诸暗。二死风火何能普益。二世间机火灾至初禅。喻同居生死。风灾至三禅。喻实报生死。水灾至二禅。喻方便生死。举二不言水者。中可例知。三悲体下一行颂口业普说二。初二句颂二轮化本。说虽在口。必假身意为授法本。初句者为法现形。本期救苦。故说法身名为悲体。此身先用戒德警人。如天震雷物无不肃。次句者菩萨以慈而为心意。无缘而被名之为妙。物无不覆。譬若大云。二轮既施然可授法。二澍甘下二句正颂口轮说法。甘露者。智者云。诸天不死之神药也。所宣至理解必无生。若匪无生焉能不死。本性常法非说那知。于慈云中澍大法雨。众生受者三惑焰灭。以兹三普为入道门。故当别颂普门义也。二诤讼下加颂显机。长行显应以被冥机。疏以施璎彰显机义。今逢重颂有显机文。益见天台冥契圣旨。事系讼庭身临战阵。心忧刑罚命虑兵残。今昔冤仇此时合会。一心致感众难皆祛。亦可例前疏释七难。通于三障。即诤讼等义。该诸有及以三乘。思之可见。三妙音下三行双颂二劝二。初颂劝受持二。初一行明智境深妙。以劝常念。初三句中有五音字。皆是众生称唱言音。以由菩萨妙智观。故皆成妙境。三智照故音成三境。双遮空有即成妙音。双照空有即成世音。世即二世间也。不别而别。此二音字中智境也。梵是四等慈悲喜舍四观照之。即成俗谛故名梵音。称俗照机若熟若脱。时节不差名海潮音。此二音字假智境也。毕竟空智出九界情。照众生音超二世相。是故名为胜世间音。此一音字空智境也。言虽次第观在一心。智外无音。音外无智。境智冥一思虑顿忘。是故须常念者。正勤持念也。此之类音虽是众生口业所发。大圣三智照成三谛。即是三身故。劝行者念此三身。言常念者。如疏解云。即是正念非破非立。无能无所。三谛俱照三观俱亡。不次不偏名常名正。若其然者名为妙机。二念念下一行明感应难测。以劝勿疑。上先举境智。次劝常念。今先劝勿疑。次陈感应。左右互显耳。言念念者。相续系念也。念即观音深妙智境。虽达常住未免迁流。即于迁流照常境智。是则念念不离观音。如大师示众偈云。实心系实境。实缘次第生。实实迭相注自然入实理。言实缘者。刹那念也。次第而起。一一皆是实观之缘。如是系念唯慎生疑。疑兕若生理境斯障。故明圣德以劝息疑。纵久修不成求之未应。须知净圣冥资不虚。于二死中。如父如母可依可怙。念念持护感应必彰。然疑有三。所谓疑人疑法疑自。今但举人其二可息。劝令常念复诫生疑。疑去念成。劝持意足。二具一下一行颂劝供养。先举功德方劝顶礼。初句总示一切功德。次二句别彰慈眼及以福聚。慈为善本福收万行。结示普门劝修供养。礼既属身身必具口。非意不行。顶礼已成三业供养。第三叹闻品功德。二初持地叹功德二。初释闻上二益。经云持地者。宝云经云。菩萨有十法。名持地三昧。如世间地。一者广大。二众生依。三无好恶。四受大雨。五生草木。六种子所依。七生众宝。八生众药。九风不动。十师子吼亦不能惊。菩萨亦尔。经一一合。妙乐引彼释今持地。结云。以八教判方应今经。二此中下释自在之业。业有多种。大约论三。一有漏业。为见思所润受分段土生。二无漏业。三非漏非无漏业。同为无明所润。受变易土生。此约自行受生以说。若利他者。皆以慈悲润彼彼业。同他受生。三藏菩萨众生缘慈润有漏业。同居业生。通教菩萨法缘慈润有漏业习。于同居土神通受生。法身菩萨无缘慈润不思议业。三土应生。今观世音等觉后心无缘慈悲。润于中道自在之业。故云中谛摄也。应十界感十方。净秽方便实报同彼机类。现身说法。故云于二谛得自在也。即普门示现神通力矣。闻者能得观行真似微妙功德。故云不少。二无等下闻品获利益二。初约四悉释无等等。疏有四节。结云。四悉以明发心。初释四。初世界。二乘有上是可等法。佛智无上是无等法。初发大心等于无等。即无等中而论于等。只是等于佛智故也。大小体别名世界也。二又约下为人。乃以人数用表法门。刹那刹那莫不具足八万四千净秽之法。此一一法无非实相。若缘诸法作念而修尘劫不等。性中八万。若即实相无缘发心。刹那能等八万四千究竟之法。发实相心。是生理善。即为人也。三亦是下对治。八万四千始终无改。迷即尘劳悟即彼岸。说波罗蜜翻彼尘劳。即对治也。四故经下第一义。前心难者初破无明实为难事。大经所赞。正在分真。是故顶礼初发心。即发心住也。此位能具四十一位真应功德。此心超胜已不可等。此不可等等于妙觉。既是真发即第一义。二此即下结上之四释。初四等果。二三等理果。理不二岂有阶差。然约诸文。三慧四悉多就位辩。故须四释。不别而别。约位而明。五品闻慧即超二乘。不二观成凡心等佛。小果有上大果无等。小大差别故当世界。初信至七位当思慧。既粗垢先除发实相似解。照乎性德八万法门。既生理善故属为人。八信至十位当修慧。内外尘沙不除自遣。能以性中八万功德。对破逆修八万尘劳。自他恶破故属对治。初发心住三慧功成。性三圆发。四十二位互具虽等。较其难易初入功深。此位始得。真心开发名第一义。二发心下约三即显真发。名字发者。于能诠名。豁然开发三种菩提愿行之心。对违顺境此心弥炽。圆伏三惑名观行成。若名字即纵能勤修八法成乘。以未开悟不名为发。今发观行称名字者。盖此五品非真非似。但是信解诠妙名字。于妙三谛决无疑滞。能伏无明不为境动。是故称为名字发也。相似发者。因观加功。故三菩提倍前开发。似于本性六根互用。稍类分真。如鋀比金犹火先暖。故名相似发菩提心。真心发者。一发一切发发一切方便。发一切观照发一切真性。此三菩提圆融通达不前不后亦不一时。分证三德分同果佛。故华严云。初发心时便成正觉。所有慧身不由他悟。微妙净法身湛然应一切。始从初住终至等觉。皆有此发位。位转深前之二发相显故来。经文结益正在真发

观音义疏记卷第四

    释重颂

        宋天竺寺沙门遵式述

第二重颂。是隋炀大业中智者灭后笈多所译。方入大部。故疏阙释。灵感传天人语南山云。什师八地菩萨。译法华阙观音重颂。既涉冥报。信有此文。今扶上二番问答。随文略释固难尽理。讲者但令不失上文。大途梗概何必骋异。此颂二十六行为二。初一偈双问二章。次二十五偈双答二问。初问中一句叹德。三句正问。一句之内名体合。叹世尊名也。所以略举尊号。则知上九并为三世中尊叹之要也。具相质也。相妙而具妙是叹辞。具谓三十二满足。又可妙即是好。以八十种好严其相。令妙好也

复次名实俱叹法身。名是妙名相为妙相。上文云。具相三十二以八十种好用庄严法身。即此意也。具此相好者。即具二严能答我问。故举而叹也。正问中初句兼于二问。文云重问。即重问上二段之事。孰谓不然。次二句别问观音。欲佛先答。初章就近更征故也。亦可三句并问初章。自招后答。既有真身冥益。岂无应像显赴耶。故许说中双许二番。谓闻名及见身是也。第二答中作三意。初二偈总答二章。次十九偈别答二章。三四偈劝持名供养。总答中初一偈正答。次一偈依本观慈悲汝听观音行是总答前章。观音即境智因缘得名。善应诸方所是总答后段普门示现。并用上总意消之。次一偈却寻本观慈誓。显今智断十番利益。本依别圆无量无作四谛。起于愿行。由誓境深广故。弘誓如海。弘即广也。历劫显时。久远一一劫中。侍多千亿。显值复多。一一佛所复发别愿。如四十八等。一一愿含法界故。复云大也。历劫约竖侍多约横。一一竖中有横。一一横中有所历之时。广说云云。将此总中本誓。历下别答一一难及。普门后广作可知。第二别答复二。初一偈是双许说二章。闻名是许前章。见身是许后章。向诫听今许说。言略说者。即别答也。总答多含。即文略而意广。别答陈列。且约人界果报边。明七难等。普门且约三十三身等。即文广而意略。今取意略信是许别答也。闻名闻观世音境智名也。上文约四种闻释成三慧。义观两全可解。见身即普门示现。显应三业也。心念不空者。明二段应益也。心念属意。不云身口者此从冥显二机摄。二章语便。何者。初章显机。若身若口俱须域意故。意能总摄也。故上释持名云。口为诵持心为秉持。为理不失。虽非口持觉观是口行。通属口业机摄。例如小弥陀执持名号一心不乱。亦不妨口机。下文皆云念彼观音力。例同此释。后段冥机约心为便。可解。不空者。纵使称名都无显验。冥益不虚。第二十八偈正答。又二。初十三偈颂初章。次五偈颂后章。初又二。初十二偈明口业机应。次一行略颂身意二种机应。上文七难表六大种。而云假令。多举诸难亦是表此。今偈加推堕二山恶兽蛇蝎。此四皆识种摄。毒药从人及虫鬼识种摄。从尘体地种摄。雨雹水种摄。又合罗刹鬼难。加六成十二难。初一偈火难。上文例作三科释。贴文事证观解。于观中初广约十番。遭苦称名成机致感。次约别圆二种本住法门及慈悲誓愿。显前十界圆益。今但略作贴文一释。余可准上。不复备叙。讲者应具示其意。使义观不壅有益来者。言大火坑者。上直云大火。此加之以坑。大而更深。意显圣力火无浅小。皆能成难。况乎大坑。设使劫火从地狱至初禅。如此大坑满中红焰。菩萨亦能或以吹灭。或以口噏。或复手遮令其不烧。或作凉池次一偈水难上得浅处。即能免难。若加龙鬼浅亦可畏故。值死缘多重。于上文弥彰圣应尔。次一偈堕须弥难。如日住空显圣力难思。然但是假设。何人能到复被推等。设有此事圣无不为。顶生人王能上妙高。因贪帝位还降人间。若能称名必有免理。四一偈堕金山难。五一偈怨贼难。六一偈王难。七一偈枷锁难。八一偈毒药难。大慈等爱。理合均除。而还着本人者。被害称名机成须救。能害无机恶心自克。非圣使然。又毒药有鬼。须得着人。若不杀他必须自害

问。若恶心自克怨贼。何故但令起慈

答。贼害事显。但令起慈即彰圣力。毒药阴谋反害方验。然贼亦有自害。如东林老僧为贼所斩。贼反以剑自刺心入背出。群党奔迸。又毒药未必例皆还着。有作折摄二用释者。若二俱有机则可然。若能害者无冥显二机折亦徒施。九一偈罗刹鬼难。然兼毒龙。前有鱼龙及鬼。此重言者。龙鬼通水陆。前但在水也。上文四种龙等云云。十一偈恶兽难。十一一偈蛇蝎难。十二一偈雨雹难。欲益观行者。应巧约恶业烦恼。作蛇虎等法门释之。使顺道理。若准请观音疏。作三义明消伏力用。谓约事约行约理。对此中果报烦恼及所住法门会之。亦应可解。口业机应竟。第二一偈总颂身意。二种机应。三毒猛盛心不自在。名之困厄。四类同栖各说所苦。鸽说淫为最苦。蛇说嗔为最苦云云。女无子苦如上说。或分二句对意对身。细作可了。若作观解十番为三毒所困。及约界外作顺逆法门应释。应用上文意消三毒义。身业无子无修因男女。乃至无圆顿男女。寻上文消之。若心念身礼二业成机。断除三毒根满足二庄严。永拔十界三土世间之苦。故云观音妙智力能救世间苦。亦应更明别圆本观慈悲云云。第二五偈别答普门示现。此中文狭。望上别文此仍成总。又为三。初二偈颂普现次二偈颂本观。三一偈结成圣者。三业初又二。初一偈直颂普现。二一偈别举所化。三种法界。上文列圣身。至金刚神。阙地狱界。此中举劣况胜。成互出耳。一一身说约四句如前。又上文约三土为所应。此十方当约三土释十方云云。次二偈本观。又二。初偈行愿。次偈观成普益。初又三。二句辩观一句慈誓。一句诫归。向真观了空成一切智。清净观出假处有无染成。道种智广大智慧。即中道观遍于诸法名广。胜出二边名大。中道体即智慧观。此体故名智慧观

问。何以智慧名中体耶

答。顺此经意。此经以寂照合法身为体。感应为宗。得作此说。三智实在一心中得。不可一异。悲观等者。誓愿通称为观缘谛发故。如止观十法通名为观。次偈辩益。又二。上二句明智光。次二句慈光。破暗照世云云。三一偈结成圣者。三业显应。戒雷对身业。慈云对意业。澍雨对口业。戒检七支身业为便。戒净能拔三恶之苦。故名悲体。身轮现通骇动群情。复如雷震。内心爱念名慈普覆一切如云。无谋而应逗会不差。复名为妙意业也。口轮演实相之法。为甘露雨。三草二木平等蒙润三惑热恼为之清凉。广释三无缘三不护等如上文。一一应迹一一说法。皆须明别圆菩萨所住法门。方有事用。释普门一番竟。第三四偈劝持供养。又为二。初二行一句劝持。二一行三句劝供养。初又二。初一行重举前口业机应。以为劝由。由前口业居初。举一摄二。所以特举。官讼军阵者。水火难稀鬼虎事寡运衰。方值诤讼事众世之诤本。财色田宅日用有之。劝持则要也。刀杖幽执有过方遭。军阵王役事非由己。又捔力相持白刃森目。刀杖案籍赊死之难。贼夺有财非如师旅。斯亦劝之要也。次一行一句正劝。又二。初三句约权实格量。次二句结劝。先举菩萨实证实益为格量本。胜彼九界权乘慈智故。云胜世间音。秖音尘一法以实智佛眼观之。即实谛妙音。权智法眼观之。即俗谛世音。此实证也。缘中道修慈名为梵音。此慈能与机会名海潮音。譬不失度此实益也。与夫九界生法二慈作意应物。岂复为类。故云胜彼格量明矣。二句结劝。初劝常念有事理二行云云。若事理行成。自见菩萨色法二身故。一句复止疑劝也。次一行三句劝供养。初一句叹菩萨清净三业。从正命生故云净圣。言共堪受供养也。正命是圣法。人禀此法名人为圣故。云观音净圣。次别举德以为劝由。于苦恼下二句颂上施无畏德。苦恼死厄怖畏处也。作依怙无畏力也。如幼子恃怙父母。更何所畏即指前现权实身说为父母。护三乘子免二死厄。具一切下三句举福田劝。具一切功德举菩萨报身敬田。慈眼视众生举应身恩田。福聚海无量总叹二田。高出如山之谓聚。深广无际之谓海。亦是二田所依叹法身也。顶礼正劝以三业供养也。身仪事显故。特举之必具三业。上文脱璎珞。望今乃互举耳。又此劝事普一切。皆得供养。百金之璎孰人可辩。又能严尚贵所严。岂复轻耶。观心者身业勤则增长福德供养。应身口业勤则说般若供养。报身意业勤则会理供养法身云云。释偈竟

宋慈云尊者疏别行重颂附大部入藏。而南方教苑不传。几二百年矣。至元甲午。为教门入京。于燕城弘法寺。待之东归。犹至宝然不敢自秘。遂锓诸梓以惠来学。大德壬寅夏五。兴元住山苾刍性澄谨题


华严经骨目

    No. 1742 [cf. No. 279]

    华严经骨目序

        此经新本大唐证圣元年于阗实叉难陀译八十卷成

天台宗教第九祖师荆溪尊者有愿行观门骨目一卷(今分两卷)。即略撮纲要用拟观本。斯文久流他国未行于中朝。故人罕得而见之。然诸佛密藏如来性海视之者莫识其指归。挹之者罔测其涯际。倘留神此典。实玄览要门。洞明诸佛果源。开悟众生理本。无边刹海岂隔毫端。十世古今不逾当念。法界大都于兹入矣。则与夫看诵华严大教一部校量功德。复何有异焉。敬叙元由以冠经首。庶知其所自云耳

大方广佛华严经愿行观门骨目上

第一会菩提场中说经六品十一卷

    世主妙严品第一(此经共有三十九品唯阿僧祇品如来随好光明功德品是佛自说余皆加诸菩萨说)

佛在摩竭提国阿兰若法菩提场中始成正觉。又云。佛神力故令此道场一切庄严悉于中现。曰既异寿量久成。不同阿含。菩提树下任运在迹。别圆教也。又云。诸佛神力所加。一念之顷悉包法界。曰加异自力。亦在教道。又云。于一切法成最正觉。智入三世。身满世间。遍一切土。列众中十佛世界微尘菩萨围绕。皆是如来共集善根诸杂众。皆云。成就大愿。具菩萨行等。一一皆云。有佛世界微尘数。或云。不可思议数无量数等。各得诸佛不思议解脱法门(尽第五卷)

    如来现相品二(卷六欲说胜法先现胜相相依理成还为理表故先现之作理标帜)

诸菩萨及一切世间主作是思惟。云何诸佛地境界加持所行力无所畏三昧无能摄取眼耳鼻舌身意光声(一一皆有云何诸佛字)。颂中云。佛眼云何无有量等。佛知其念。面门齿间放光。光中说偈。十方菩萨皆悉来集。诸菩萨光中说偈云。即以利益诸众生。而为自行清净业。又云。一一尘中无量身。复现种种庄严刹。三世所有一切刹。一刹那中悉能现。又如来白毫相中有菩萨而说偈曰。佛身充满于法界。普现一切众生前。随缘赴感靡不周。而恒处此菩提座。如来一一毛孔中。一切刹尘诸佛坐。菩萨众会共围绕。演说普贤之胜行(此品只是具明如来相好以一具多以正摄依)

    普贤三昧品三(卷七为述相由故入藏身指因表果明相有在)

尔时普贤而于佛前坐师子座。承佛神力入于三昧。名一切诸佛毗卢如来藏身。普入一切。佛平等性同于虚空法界海。出一切诸三昧法。普能包纳十方法界。三世诸佛智光明海皆从此生。含藏一切佛力解脱。诸菩萨智能令一切国土微尘普能容受无边法界。如此普贤十方虚空法界亦然。佛眼所见佛力能到佛身所现一切国土。所有微尘一一尘中。有世界海微尘数佛刹。一一刹中有世界海微尘数佛。一一佛前有佛刹微尘数普贤菩萨。皆入此三昧。一一普贤皆有十方诸佛而现其前。同声赞云。一切诸佛共如于汝。十方诸佛同时摩顶。尔时普贤从三昧起。即是从十种三昧门起。第五从一切众生舍宅三昧门起。偈云。

  所现国土皆严净　　一刹那中见多劫
  普贤安住一切刹　　所现神通胜无比

    世界成就品四(卷同既具能化必有所被故示所见为所化境)

尔时普贤以佛神力遍观察一切世界海众生海诸佛海众生业海根欲海佛法轮海一切三世海愿力海神变海。观已告诸菩萨。佛知一切世界海成坏。清净智不可思议。乃至神变海智不可思议(遍历一切)。颂云。一切刹土入我身。所住诸佛亦复然。普贤行愿无边际。我已修行得具足。普贤又告诸菩萨言。三世诸佛说世界海有十种事。所谓世界海起具因缘所依住形状体性庄严清净佛出兴劫住劫转变差别无差别门(具如初句)。若广说者与世界海微尘数等。又有十因缘故已成当成现成。所谓佛神力故。法应如是故。众生业故。菩萨智故。众生菩萨同集善根故。菩萨严净佛土愿力故。菩萨成就不退行愿故。菩萨清净胜解自在故。如来善根所流及诸佛成道时自在势力故。普贤自在愿力故。广说亦有世界海微尘数。颂云。一一身包一切刹。一念普现于三世。佛以方便悉入中。此是毗卢所严净。又云。有种种所依形相体乃至差别门

    华藏世界品五(卷八九十虽示所化正报之人须知依报所现之土)

普贤告大众言。此华藏世界海是毗卢遮那如来昔于世界海劫修菩萨行时。一一劫中亲近世界海微尘数佛。一一佛所净修世界海微尘数大愿。严净世界。须弥山尘数风轮持。颂云。华藏世界所有尘。一一尘中见法界。宝光现佛如云集。此是如来刹自在。又有世界海大轮围山。山中有地。皆金刚所成众宝庄严。此世界海大地中。有不可说佛刹微尘数香水海。众宝庄严底岸等。一一香水海各有四天下微尘数香水河。众宝摩尼以为岸等。诸佛因行皆现其中。一一河各有世界尘数庄严。此华藏世界海皆以世界海微尘数清净功德之所庄严。又此不可说佛刹微尘数香水海中。有不可说刹微尘世界种安住。一一种有不可说佛刹微尘世界。于世界海中依住形状等不同。颂云。十方所有广大刹。悉来入此世界种。虽现十方普入中。而实无来无所入。以一刹种入一切。一切入一亦无余。体相如本无差别。无等无量悉周遍。一切国土微尘中。普见如来在其所。此香水海在华藏中。如天帝网分布而住。最中者名无边妙华光香水海。如是十方各以二十重佛刹微尘世界围绕。颂曰。华藏世界海。法界等无别。庄严极清净。安住于虚空

    毗卢遮那品六(卷十一既其通示能所依正仍须别辩一方偏迹举偏知圆示别识总)

普贤菩萨告大众言。乃往古世过世界微尘劫。复倍是数有世界海。名普门光明。此世界海中有世界。名胜音。依摩尼华海住。须弥山微尘数世界而为眷属。其形正圆。其地无量庄严。三百重宝围绕。宝云覆上如须弥山。衣服饮食随念而至。彼胜音世界中有香水海。名清净光明。中有大莲华须弥山出现。名华焰普庄严幢山。上有林名摩尼华。众宝庄严。百万亿那由他城周匝围绕。种种众生于中止住林东有城名焰光明。人王所都。百万亿那由他城周匝围绕。彼胜音世界最初劫中有十须弥山。微尘数如来出兴。第一佛名一切功德山须弥胜云。王名喜见善慧。统领百万亿那由他城。夫人婇女三万七千。王子五百。大威光为首。有十千夫人。太子见光。以昔所修善根力故。证十种法门已说偈。以佛神力其声遍满胜音世界。其王闻已与夫人俱来至佛所。八部眷属皆悉来集。闻法获益。大威光得无量智光明。佛灭后有波罗蜜善根庄严佛出世。尔时大威光童子见佛。即得念佛三昧名无边海藏门等十千法门值第三第四佛。获益已还归本处(已上从普贤三昧来皆普贤菩萨说)

第二会普光明殿说六品四卷

    如来名号品七(卷十二虽知一方偏示之别理须遍达十方之别)

菩提场中始成正觉。于普光明殿坐莲华藏师子之座妙悟皆满。与十佛刹微尘数菩萨俱。皆一生补处。悉从他方而来集此。为令众生永断一切烦恼故。说十住十行十向十藏十地十愿十定十通十顶。及说如来地。境界神力所行力无畏三昧神通自在无碍眼耳鼻舌身意辩才智慧胜愿(皆云如来)。尔时世尊知诸菩萨心之所念。现神通已各于十方过十佛刹微尘数世界各有一世界佛。与十佛刹微尘菩萨俱来佛所。东方世界名金色。上首菩萨名文殊。乘佛威力观诸菩萨而作是言。诸佛子。佛国土佛住佛刹庄严佛法性佛刹清净佛说法佛出现佛刹成就佛菩提皆不可思议。何以故。佛于十方知诸众生。随其所应说法调伏。如来于此娑婆诸四天下种种身名色相修短寿量处所诸根生处诸业观察(皆云种种)。皆令众生所见不同。如来于此四天下中或名一切义成。或名圆满月。或名释迦牟尼毗卢遮那等。十千名号如是。四天下十方各一世界各十千名。此娑婆世界百亿四天下有百亿万种种名。又于娑婆外十方各有一世界。各有百亿万种种名号。十方尽虚空界种种不同

    四圣谛品八(卷同既了别人应知别法)

尔时文殊师利菩萨告诸菩萨。诸佛子。苦圣谛此娑婆世界中或名罪。或名逼迫。或名变异攀缘聚剌等。集圣谛或名系缚灭坏爱着义妄觉念等。灭圣谛或名无诤离尘寂静等。道圣谛或名一乘趣寂导引等。如是十方世界一一各有四百亿十千名号

    光明觉品九(卷十三欲宣其法先动其情横满虚空竖穷色顶明其人法所被分齐)

尔时世尊足下放光。照百亿四天下乃至百亿色究竟天。佛神力故皆见如来。十佛刹微尘数菩萨围绕。十方各一大菩萨。各与十佛刹微尘数菩萨俱。文殊师利为首。尔时一切处文殊师利各于佛前同时说偈。尔时光明过此世界十方各十佛刹微尘数世界。各有四天下乃至色究竟。一切处文殊说偈亦然。尽法界虚空界亦如是

    菩萨问明品十(卷同欲破无明先启其萌能问所问俱是大人故云菩萨众位之初故首为称)

尔时文殊问觉首菩萨言。佛子。心性是一。云何种种差别。所谓善趣恶趣诸根满缺受生同异端丑苦乐。心不知业业不知心。受不知报报不知受。心不知受受不知心。因不知缘缘不知因。智不知境境不知智。觉首答曰。诸法无作用。亦无有体性。是故彼一切各各不相知。譬如河中水湍流竞奔逝各各不相知。诸法亦如是。眼耳鼻舌身心意诸情根。以此常流转而无能动者。法性本无生。示现而有生。是中无能现。亦无所现物。若实若不实。若妄若非妄。世间出世间。但有假言说。文殊问财首菩萨。佛子。一切众生非众生。云何如来随其时。命身行解言论心乐方便思惟观察。(各有随其)于如是众生中为现其身教化调伏。财首以偈答曰。分别观内身。此中谁是我。若能如是解。彼达我有无。文殊问宝首菩萨。一切众生等有四大。无我无我所。云何而有受苦受乐端丑内外现报后报。然法界中无美无恶。宝首以偈曰。譬如净明镜。随其所对质。现像各不同。业性亦如是。亦如胎藏中。诸根悉成就。体相无来处。业性亦如是。亦如地狱中。种种诸苦事。彼悉无所从。业性亦如是。文殊问德首菩萨言。如来所悟唯是一法。云何乃说无量诸法。现无量刹。化无量众。演音示身知心。现通震界等(皆云无量)。德首偈答。譬如火性一。能烧一切物。火焰无分别。诸佛法如是。海波风吹雨地亦如是又如地界一。能生种种芽。非地有殊异。诸佛法如是。文殊问目首菩萨言。如来福田等一无异。云何而见众生布施果报不同。所谓种种色形家根财主眷属官位功德智慧(皆云种种)。如来于彼其心平等无异思惟。目首偈答。譬如大地。一随种各生芽。于彼无冤亲。佛福田亦然。亦如水一味。因器有差别。亦如净明镜。随色而现像。如阿伽陀药。能疗一切病(下二句大同)。文殊问勤首菩萨言。佛教是一众生得见。云何不即断一切烦恼。然其五阴三界三毒无有差别。是则佛教于诸众生或有利益或无利益。答曰。由进怠不同而令种种。文殊问法首菩萨。如佛所说若有众生受持正法悉能断除一切烦恼。何故复有受持正法而不断者随诸烦恼。法首答曰。如人水所漂惧溺而渴死。于法不修行。多闻亦如是。如人设美膳自饿而不食。如人善方药自疾不能救。如人数他宝自无半钱分。如人生王宫而受馁与寒。如聋奏音乐悦彼不自闻。如盲缋众像示彼不自见。(下二句并同)文殊问智首菩萨。于佛法中以智为首。如来何故或赞施戒乃至智慧及以四无量心然终无有。唯以一法能成菩提。智首偈答。佛知众生心性分各不同。随其所应度如治而说法。悭者为赞施等诸法。文殊问普贤菩萨。诸佛唯以一道而得出离。云何今见佛土不同。贤首偈答。文殊法常尔。法王唯一法。一切无碍人。一道出生死。一切诸佛身。唯是一法身。一心一智慧。力无畏亦然。一切诸佛刹。庄严悉圆满。随众生行异。如是见不同。佛刹无分别。无憎亦无爱。但随众生心。如是见有殊。十首次问文殊言。我等说已。仁者当说如来所有境界。何等是佛境界因度入智法说知证现广(皆如初句)。文殊亦以十偈答。如来深境界。其量等虚空。一切众生入。而实无所入。如来深境界。所有胜妙因。亿劫常宣说。亦复不能尽(余九皆以究竟无差别答)。由是答故。娑婆十方尽虚空界。以佛神力故。悉皆明见十种差别。所谓法差别业世间身根受生持戒果犯戒果国土果(下九句同初)

    净行品十一(卷十四虽善其趣非行不前去俗进道故名为净净彼行故行假兹净彼此俱得净行之号)

智首问文殊言。佛子。云何得无过失。身语意业不害不可毁不坏不退转不可动殊胜清净无染智为先导(具如初句)。云何得生处具足。种族家色相念慧行无畏觉悟。(皆云具足)云何得胜慧第一。最上最胜无量无数不思议无与等不可量不可说(皆云慧)。云何得因力。欲力方便力缘力所缘力根力观察力奢摩他力毗钵舍那力思惟力及十种善巧七觉六度(经具列十七觉加空无相无愿六度加慈悲喜舍)佛十力八部守护。云何得与众生为依。救归趣炬明照导胜导普导(如初句)。云何于一切众生中为第一大胜最胜妙极妙上无上无等无等等。(加为)文殊告智首菩萨言。为欲饶益世间天人问如是义。若诸菩萨善用其心则获一切胜妙功德。于诸佛法心无所碍住去来今。诸佛之道随众生住恒不舍离。当如普贤色像第一。一切行愿皆得具足而为众生。第二导师皆由发此一切大愿。始从居家入僧伽蓝。修行诸仪皆发大愿。偈云。菩萨在家。当愿众生(下二十一偈第二句同)。知家性空。免其逼迫。孝事父母。善事于佛。护养一切。妻子集会。怨亲平等。永离贪着。若得五欲。拔除欲箭。究竟安隐。伎乐聚会。以法自娱。了伎非实。结跏趺坐。善根坚固。得不动地。若举于足。出生死海。具众善法。整衣束带。检束善根。不令散失。大小便时。弃贪嗔痴。蠲除罪法。洗涤形秽。清净调柔。毕竟无垢。以水洗面。得净法门。永无垢染。见修园圃。五欲圃中。耘除爱草。见欢乐人。常得安乐。乐供养佛。见苦乐人。获根本智。灭除众苦。见疾病人。知身空寂。离乖诤法。若见沙门。调柔寂静。毕竟第一。若饭食时。禅悦为食。法喜充满。洗浴身体。身心无垢。内外光洁。盛暑炎毒。舍离众恼。一切皆尽。若洗足时。具神足力。所行无碍。以时寝息。身得安隐。心无动乱。睡眠始寤。一切智觉。周顾十方。若诸菩萨。如是用心。则获一切。胜妙功德

    贤首品十二(卷同尽十五贤位之初故云贤首即是初住近方便也圣中之贤故名为贤贤家之首故名贤首)

尔时文殊说无浊乱清净行大功德已。欲显示菩提心功德故。以偈问贤首菩萨曰。我今已为诸菩萨。说佛往修清净行。仁亦当于此会中。演畅修行胜功德。贤首乃说七百一十五行七言偈答。初一句诫云。善哉仁者应谛听。次十五句欢菩提心自谦云。彼诸功德不可量。我今随力说少分。犹如大海一滴水。次二句标发心因缘云。菩萨发意求菩提。非是无因无有缘。次九行正明发心因缘。以三宝菩提众生国土以为所缘。能信之心以为自因。偈云。于佛法僧生敬信。以是而生广大心。不求五欲及王位。富饶自乐大名称。但为永灭众生苦。利益世间而发心。常欲利益诸众生。庄严国土供养佛。受持正法修诸智。证菩提故而发心。次信为道元下十四行欢信心胜妙。次若常下广欢发心。从始至终诸行相生以至果用。次广述因果诸用

第三会忉利天宫说六品三卷

    升须弥山顶品十三(卷十六不动而升赴机得处)

尔时如来威神力故。十方一切世界。一一四天下阎浮提中。悉见如来坐菩提树。尔时如来不离此座。升须弥山向帝释殿。尔时帝释遥见佛来。以佛神力庄严此殿置即子座。诸供养具一一庄严。及所围绕皆有十千。皆称善来请佛入殿。佛即受请十方皆然。以佛力故殿中所有乐音自息。帝释自忆。过去佛所种诸善根。而说二十偈以叹十佛。谓过去七佛等一一皆云。是故此处最吉祥。十方世界亦复如是。世尊坐已此殿忽然广博宽容。十方世界亦复如是

    须弥山顶偈赞品十四(卷同既登山已欲说法性还依法性以叹于人人胜法尊投心有在)

尔时十方各有一大菩萨。各与佛刹微尘数菩萨俱。从百亿佛刹尘数世界外来。文列十慧菩萨。法慧为首。各列彼十界及界中十佛。各各化作毗卢遮那师子之座各坐其上。十方各集亦复如是。世尊两足放百千亿妙色光明普照十方。此众皆见。十慧各说十偈叹佛。二一切慧偈曰。假使百千劫。常见于如来。不依真实义。而观救世者。是人取诸相。增长痴惑网。系缚生死狱。盲冥不见佛。法性本空寂。无取亦无见。性空即是佛。不可得思量。若知一切法体性皆如是。斯人则不为烦恼所染着。凡夫见诸法但随于相。转不了法无相。以是不见佛。三胜慧偈云。了知一切法。自性无所有。如是解法性。则见卢舍那。因前五蕴故。后蕴相续起。于此性了知。见佛难思议。四功德慧偈云。我昔受众苦。由我不见佛。故当净法眼。观其所应见。无见即是见。能见一切法。于法若有见。此则无所见。五精进慧偈云。世间言语法。众生妄分别。知世皆无生。乃是见世间。若见见世间。见则世间相。如实等无异。是名真见者。法性本清净。如空无有相。此亦无所修。能见大牟尼。六善慧偈曰。智者说无尽。此亦无所说。自性无尽故。得有难思尽。所说无尽中。无众生可得。知众生性尔。则见大名称。七智慧偈曰。此人无慧眼。不能得见佛。有诤说生死。无诤即涅槃。生死及涅槃。二俱不可得。八真实慧偈云。宁受地狱苦。得闻诸佛名。不受无量乐。而不闻佛名。现在非和合。去来亦复然。一切法无相。是则佛真体。若能如是观。诸法甚深义。则见一切佛。法身真实相。知以一故众。知以众故一。诸法无所依。但从和合起。九无上慧偈云。如来光普照。除灭众暗冥。是光非有照。亦复非无照。此中无有二。亦复无有一。大智善见者。如理巧安住。无中无有二。无二亦复无。三界一切空。是则诸佛见

    十住品十五(卷同正说真位此十居初初安圣境故名为住智断相应且略云十)

尔时法慧承佛神力入菩萨无量方便三昧。以三昧力十方各千佛刹微尘数世界之外。有千佛刹微尘数诸佛。同名法慧。普现其前。告法慧言。善哉善哉汝能入是三昧。千刹尘佛共加于汝。又是遮那往昔愿力及汝所修善根力故。入此三昧令汝说法。为增长佛智故。深入法界故。善了众生界故。所入无碍故。所行无障故。得无等方便故。入一切智性故。觉一切法故。知一切根故。能持说一切法故。所谓发起诸菩萨十种住。是时诸佛即与法慧无碍等十种智。十方诸佛申手摩顶。法慧定起告诸菩萨言。佛子。菩萨住处广大。与法界虚空等。列十名已初释初住云。此菩萨缘十种难得法而发于心。所谓十力应劝学十法。所谓勤供养佛。乐住生死。主导世间。令除恶业。以胜妙法常行教诲。叹无上法。学佛功德。生诸佛前恒蒙摄受。方便演说寂诤三昧。赞叹远离生死轮回。为苦众生作归依处。治地住中发十种心。修行住中行十种观。生贵住中成就十法。具足方便住十法利生。正心住闻十种法。心定不动。不退住闻十种法坚固不退。童真住住十种业。王子住善知十法。灌顶住成就十智。一一住中各勤修十法。十方所说文句义理无有增减

    梵行品十六(卷十七重述圣因因秪是行故名为行行体离染故名为梵)

正念天子白法慧言。一切世界诸菩萨众依如来教。染衣出家云何而得修习梵行。法慧言。应以十法而为所缘。所谓三业及佛法僧戒。如是一一观察皆空寂故。知佛法平等故。具一切佛法故。名为清净梵行。复应修十种力。一一力中有无量义。悉应咨问。闻已应起大慈悲心。观察众生思惟诸法无有休息。不求果报了知境界如幻化等。于诸法中不生二解。一切佛法疾得现前。初发心时即得阿耨菩提。知一切法即心自性。成就慧身不由他悟

    发心功德品十七(卷同举劣显胜以初例后此位所开名之为发所开之体故总云心心之胜能故云功德)

尔时帝释白法慧言。发心功德其量几何。答言。此义甚深难知难说难分别难信解难证难行难思惟难度量难趣入。虽然我承佛力而为汝说。假使有人供养十阿僧祇世界众生以一切乐具住于一劫。然后教令净持五戒。得福多不。答言甚多。法慧言。比发心功德百分千分乃至优波尼沙陀分亦不及一。如是供养百劫已令持十善。经千劫已令住四禅。百千劫已令住四无量心。经亿劫已令住四无色定。经百亿劫已令住初果。经千亿劫已令住二果。经百千亿劫已令住三果。经那由他亿劫已令住四果。经百千那由他亿劫已令住支佛(问答如前)。法慧言。比发心功德百分乃至优波尼沙陀分不及其一。何以故。一切诸佛发心不为如是等故。为佛种不断故。乃至第十知一切佛境界平等故发菩提心。又云。且置前喻。假使有人。于一念顷过东方阿僧祇世界。如是尽阿僧祇劫。此诸世界无有能知其际者。第二人于一念顷过前人所经世界。如是经于阿僧祇劫。乃至第十人乃至十方如是世界可知其际。发心功德不知其际。何以故。不为住尔所世界。但为了知十方世界粗世界。即妙世界妙世界即粗世界。仰覆大小广狭一多净秽相即亦尔。一切世界一毛端中一切世界中一毛端一体性一世界中出生一切。一切无性一念知一切广大世界故发菩提心。又云。菩萨不为知十方一切劫成坏故。为知成坏劫尽无余故。所谓长短劫平等一多有佛无佛一佛多佛有量无量有尽无尽。一念与不可说不可说与一念。一切劫与非劫等平等亦尔。为欲一念中尽知三际世界成坏劫故发菩提心。欲知众生种种差别等亦复如是。皆以如前十方十人为喻。供养十方诸佛。喻亦如前。度众生喻亦如是(发心所缘是所观境境具三谛无性空一切假平等中)

    明法品十八(卷十八重叹所得故云明法明谓所证法则方法依方有契故云明法)

尔时精进慧菩萨白法慧言。初发心菩萨成就如是大功德。三世佛摄受决定至菩提。于佛教中云何修习。使愿行满足。众生得度绍三宝种。法慧言。如是问者同于如来。我承佛力为说少分。菩萨发心应离十种放逸。得十种清净。复修十法。令诸佛欢喜。又修十法。令速入诸地。具足如是大功德已。渐入佛地。是菩萨于一念中悉遍知一切诸法。唯除如来。无能胜者。无见顶者。文中广列诸佛功德叹此菩萨。又云成就三世如来智

第四会夜摩天宫说四品三卷

    升夜摩天品十九(卷十九同升须弥品)

尔时如来威神力故。十方世界一一四天下南洲及须弥。皆见如来处众说法。莫不自谓皆对于佛(余大同前须弥顶)

    夜摩偈赞品二十(卷同同须弥赞)

尔时佛神力故。十方各一大菩萨各与佛刹微尘数菩萨俱。余大如前。但菩萨中以功德林为首。十林为异。佛名号集会等皆同。一一林各以十偈叹佛。第六精进林菩萨偈云。众生非众生二俱无真实。如是诸法性实义俱非有(生亦名法性)。七力林菩萨云。分别此诸蕴。其性本空寂空故不可灭。此是无生义。众生既如是。诸佛亦复然。佛及诸佛法自性无所有。八行林菩萨云。身亦非是佛。佛亦非是身。但以法为身。通达一切法。若能见佛身。清净如法性。此人于佛法一切无疑惑。若见一切法本性如涅槃。是则见如来。究竟无所住。九觉林菩萨云。譬如工画师分布诸彩色。虚妄取异色。大种无差别。大种中无色。色中无大种。亦不离大种。而有色可得。心中无彩画。彩画中无心。然不离于心。有彩画可得。彼心恒不住。无量难思议。示现一切色。各各不相知。譬如工画师不能知自心而由心故画。诸法性如是。心如工画师。能画诸世间。五蕴悉从生。无法而不造。如心佛亦尔。如佛众生然。应知佛与心体性皆无尽。若人知心行普造诸世间。是人则见佛。了佛真实性。心不住于身身亦不住心。而能作佛事。自在未曾有。若人欲了知三世一切佛。应观法界性。一切唯心造。十智林菩萨云。所取不可取。所见不可见。所闻不可闻。一心不思议。有量及无量二俱不可取。若有人欲取毕竟无所得。譬如随意珠能现一切色无色而现色。诸佛亦如是。又如净虚空非色不可见。虽现一切色无能见空者。诸佛亦如是。普现无量色。非心所行处。一切莫能睹

    十行品二十一(卷同依真修习故名为行无差而差故置林称)

尔时功德林菩萨承佛神力。入菩萨善思惟三昧。入已十方各过万佛刹微尘数世界。诸佛皆号功德林。而现其前告功德林。十方诸佛同加于汝(余如前)。及列释十名行相。初欢喜行为大施主为护众生习诸佛行(广释事施)。如是行施利益众生而无我想。但观法界众生界无边际法空法无所有法无相法无体法无处法无依法无作法。作是观时不见受施财物果报。次观三世一切众生身皆灭坏。为说平等不坏法性。二饶益行护持净戒(广释事戒)。复作是念。我当随顺一切如来。具诸佛法。住无上平等处。等观众生。三无违逆行安住佛法。了身空寂。无我我所。若苦若乐皆无所有。摄受众生。趣向涅槃。四无屈挠行修诸精进。于一切世界中。令诸众生究竟涅槃。五离痴乱行成就正念。最上清净善知音声。生住灭相心不惑乱。三昧增广。六善现行能知三业皆无所有。善巧方便现无生相。成熟调伏教化众生。十行品(卷二十)第七无著行广明念念入阿僧祇世界。严净阿僧祇世界。诣佛承事等。皆云僧祇。如是菩萨深入法界。住于佛住。说无所说。一一毛端处尽未来劫。修菩萨行。入于法界。而无所著。遍于法界。行菩萨行。八难得行此菩萨成就难得善根。难伏最胜不可坏无能过。不可思议无尽。自在力大威德。与一切佛同一性(皆云善根)。深入众生界。如法界无有二相。无有增减。以一切法法界无二故。教化众生。不说一法。以法界中无有一法向诸乘故。诸法无二无不二故。譬如虚空求不可得然非无虚空。九善法行得陀罗尼。大悲坚固普摄众生。于一切世界变身金色。妙音具足而作佛事。十真实行展转深妙。到一切佛法海实相源底

    十无尽藏品二十二(卷二十一行相宽博故云无尽含摄不赀故云藏也)

尔时功德林菩萨告诸菩萨言。有十无尽藏。三世诸佛已说今说当说。谓信藏戒惭愧闻施慧念持辩。一一皆十。信谓信一切法空无相无愿无作。无分别无所依。不可量无有上。难超越无生(如初句)。如是信已闻十种不思议。心不怯弱。所谓闻佛法不思议。心不怯弱。一切佛生界众生界虚空界涅槃界过去未来现在入一切劫(如初句)。何以故。此菩萨坚信智无边无尽故。心不退转故。戒藏亦十。所谓普饶益戒。不受不住无悔恨。无违诤不损恼。无杂秽无贪求。无过失无毁犯(文中广释)。惭无始恶。愧现世恶。闻谓广知因缘四谛三乘等。施有十。所谓分减施竭尽施内施外施内外施一切过现未究竟。分减者凡有所食。施于身中八万户虫。竭尽者。乃至尽命。内谓身分。外谓外财。内外谓二俱。一切者己身妻子乃至七宝轮王位。过去者如过去佛菩萨所行。我亦如是。未来亦然。现在者闻四天王乃至色究竟二乘位。闻已不着。究竟者闻有所须。经阿僧祇劫。令菩萨身不具。不生悔心。但观身中种子乃至究竟不净。慧者所谓如实知四谛因缘。谓于五阴一一阴了知四谛十二支。支支四谛三乘一一皆了四谛。如云知声闻。知声闻法。知声闻集。知声闻涅槃。皆如实知。以不可坏故。念谓念过去不可说生。念不可说佛名号。念不可说佛出世。念不可说修多罗乃至论议。念不可说众会演法根性烦恼三昧。持谓持诸佛所说修多罗。余如念中说。辩谓为众生说。如上念持经于不可说劫

第五会兜率天宫说三品十二卷

    升兜率品二十三(卷二十二大旨同前夜摩品)

尔时佛神力故。十方一切世界一一四天下余如前。供具众集倍于前

    兜率偈赞品二十四(卷二十三大旨同前)

金刚幢(菩萨下同)云。色身非是佛。音声亦复然。亦不离色声。见佛神通力。众生及诸法了达皆无碍。普现众色像。遍于一切刹。坚固幢。云何有智慧人于佛得见闻。不修清净愿。履佛所行道。勇猛幢云。如人获宝藏永离贫穷苦。菩萨得佛法离垢心清净。设于无数劫财宝施于佛。不知佛实相。此亦不名施。譬如虚空界不生亦不灭。诸佛法如是。毕竟无生灭。光明幢云。了法性空寂。如幻而生起。所行无有尽。导师如是现三世一切佛。法身悉清净随其所应化。普现妙色身。智幢云。一切国土中普现无量身。其身不在处。亦不住于法。譬如净满月普现一切水。影像虽无量本月未曾二。如是无碍智成就等正觉。普现一切刹。佛体亦无二。星宿幢云。众生妄分别是佛是世界。了达法性者。无佛无世界。法幢云。若有诸众生未发菩提心。一得闻佛名决定成菩提。若有智慧人一念发道心必成无上尊。慎莫生疑惑。如来自在力无量劫难遇。若生一念信速证无上道。设于念念中供养无量佛。未知真实法。不名为供养。虽尽未来际遍游诸佛刹。不求此妙法。终不成菩提

    十回向品二十五(卷同趣理渐极故名回向坚固难动义之如幢)

尔时金刚幢菩萨入智光三昧。各过十方十万佛刹微尘数世界外有十万佛刹尘佛。同号金刚幢(余如前)。列十回向名释。初救护众生回向。具行六度四无量等。回此善根饶益众生。令至究竟永离众苦。令得一切智。以入一切法平等性故。等视众生。如日天子出现世间。不以乾闼婆城阿修罗手阎浮提树崇岩邃谷尘雾烟云等物之所覆障隐而不现

(二十四卷)二不坏回向。发一念心。求一切智。得不坏信。心常回向出世之道。积集善根。得法实相。具菩萨行。于一切相皆无所著。明见真实善巧回向。三等一切佛回向。顺三世佛回向之道。善巧方便永拔一切取着根本。四至一切处回向。修诸善根。功德之力至一切处。普遍开示。普摄众生。称可佛心等

(二十五卷)五无尽功德藏回向。忏除业障。所起善根回向。庄严一切佛土。无有分别等。得十无尽藏。六随顺坚固一切善根回向。此菩萨或为帝王临御大国。威德广被靡不归顺。发号施令。悉依正法。周行率土。于法自在。见者咸伏。不刑不罚。感德从化。以四摄法摄诸众生。具足修行一切布施

(二十六卷止二十八卷)广说施愿。偈云。了达诸法真实性。而于法性无分别。知法无性无分别。此人善入诸佛智。法性遍在一切处。一切众生及国土。三世悉在无有余。亦无形相而可得

(二十九卷)七随顺一切众生回向。积集善根。普施众生。成满佛智

(三十卷)八真如相回向。智常观察一切众生。心恒忆念善根境界。以等真如平等善根回向众生无有休息

(卷三十一)九无著无缚解脱回向。以此心成就普贤行愿大回向心

(卷三十二)十等法界无量回向。广行法施起大慈悲。安立众生。于菩提心常行饶益。长养善根。平等回向皆如法界

(卷三十三)菩萨于一切佛刹中。一方一处一毛端量。皆有无边不可说菩萨。成就智慧。充满而住尽虚空界。皆悉如是。皆以同体善根回向故

第六会他化自在天宫说一品六卷

    十地品二十六(卷三十四生成深广故立地名该摄事理故名为藏权实俱实真俗咸真)

尔时世尊在他化自在天宫。与大菩萨众俱。其诸菩萨不退菩提。从他方来集。住一切菩萨智所住境。入如来智所入处。十方各过十亿佛刹微尘数世界。外各有十亿佛刹尘佛。同名金刚藏。而现其前赞金刚藏菩萨。乃能入是智光三昧。如向诸佛共加于汝(余如前兜率品)。十方诸佛与其身智。各申手摩顶。金刚藏菩萨从三昧起。普告诸菩萨众。佛子。诸菩萨愿善决定无杂。不可见广大如法界。究竟若虚空尽未来际。一切佛刹救护众生。为佛所护入三世佛智地列十地已默然。解脱月三请。诸大菩萨同声共请。世尊眉间出清净光。名菩萨力焰明。百千阿僧祇光明以为眷属。遍照十方息诸恶趣照佛众会。一切诸佛所加说法。菩萨之身作是事已。于上空中成大光明云网台而住。欲令大众增净信故而说偈。说已广赞地上功德。佛子。住此欢喜地。念诸佛故生欢喜心。念佛法故。念诸菩萨故。念菩萨行故。念清净诸波罗蜜故。念诸菩萨地殊胜故。念菩萨力不可坏故。念如来教化众生故。能令众生得利益故。念一切如来智方便故(如初句)。复作是念。我转离一切世间境界故。亲近一切佛故。远离凡夫地故。近智慧地故。永断恶趣故。与众生作依止故。见一切如来故。生佛境界中故。入一切菩萨平等性中故。远离一切怖畏毛竖等事故(亦如初句)。何以故。此菩萨离五怖畏故。于一一法皆云广大如法界等

(卷三十五)菩萨起十种深心。入第二离垢地。性自远离一切杀生。有命之者生慈念心等。乃至上上十善证十力四无畏一切佛法。又云。杀生之罪堕于地狱畜生饿鬼。若生人中得二种报。一者短命二者多病。以愿力故见多百千亿那由他佛作转轮王。三发光地得无量神力。以一身为多身。多身为一身。作三十三天王

(卷三十六)四焰慧地修诸观行。作须夜摩天王。五难胜地利益众生示现世间。伎艺算数文字方药吉凶休咎咸善观察一无错谬。渐令安住无上佛法。多作兜率陀天王

(卷三十七)六现前地恒以大悲不舍众生。般若波罗蜜现前。名无障碍智光明。多作善化天王。七远行地功用行满智慧自在。虽行实际而不作证。多为自在天王

(卷三十八)八不动地得无功用法。深入如来所行境界。于无量国土修菩萨行。多作大梵天王。九善慧地起四无碍辩。于无量佛所演说法音周遍法界。多作二千世界主大梵王

(卷三十九)十法云地神通智慧说不可尽。此地菩萨以自愿力起大悲云震大法雷。通明无畏以为电光。福德智慧而为密云。现种种身周旋往反。于一念顷遍微尘国。演大法摧魔怨。霔甘露雨灭除一切众惑尘焰。能现无量自在神力。大众闻此堕在疑网。时金刚藏入一切佛国土体性三昧。大众自见在金刚藏身内。大千世界庄严之事说不能尽。又见菩提树高广严好等。现已还令各在本处。住此地菩萨多作摩醯首罗天王

大方广佛华严经愿行观门骨目上大方广佛华严经愿行观门骨目下

第七重会普光明殿说十一品十三卷

    十定品二十七(卷四十此十种定以称理故一一皆从理具而起故凡所入恒具恒空恒在法性即体而用体用不二六即言之皆可修入)

尔时世尊存摩竭提国阿兰若法菩提场中始成正觉。于普光明殿入刹那际诸佛三昧。恒住一相。所谓无相。与十佛刹尘数菩萨俱。靡不皆入灌顶之位。具菩萨行等于法界。更列一百菩萨名等。十佛刹尘数菩萨皆与毗卢遮那如来同修菩萨行。次普眼菩萨问佛。普贤菩萨及住普贤所有行愿。诸菩萨众成几三昧解脱。而于菩萨诸大三昧或入或出。佛略赞普眼已告言。普贤菩萨今现在此已能成就不可思议自在神力等。诸菩萨闻普贤名。得无量三昧。其心寂静等。普眼白佛。普贤菩萨今在何处。佛言。今在道场亲近我住初无动移。普眼及诸菩萨观察不见其身及座。佛言。普贤菩萨住处甚深不可说故。普贤菩萨获无边智慧门。入师子奋迅定。得无上自在用。入无碍际。生佛十力。以法界藏为身。于一念顷悉能证入三世佛智故汝不见。普眼闻说得十千阿僧祇三昧。以三昧力复更欲见亦不能睹。佛言。若有得见普贤菩萨承事。闻名思惟忆念生信。勤观始趣向正求觅。兴誓愿相续不绝。皆获利益无空过者。佛言。汝等宜更礼敬。殷勤专至观察十方。想普贤身现在其前周遍法界。深心信解厌离一切。誓与普贤同一行愿入真实法。普现世间知众生根。若能如是当见普贤。普眼如教。普贤为现。令诸菩萨皆悉得见。在此众中坐莲华座。亦见从十方来。亦见在彼说法。菩萨见己如见十方诸佛。以佛威神以菩萨信解普贤本愿力故。自然无量供养。放光照不可说世界。令不可说菩萨入普贤行。不可说菩萨成普贤行。不可说菩萨悉得圆满普贤行愿成就菩提(从前至此始结得道)。次普眼赞普贤菩萨。如来印述。佛告普贤。汝为普眼等说十三昧。列十大三昧已言。若成就者则名为佛如来十力导师一切智等(广说不思议功能)。尔时普贤承如来旨观普眼等。分别广说有十种无尽法。住此三昧超过世间。譬如比丘住不净观。菩萨亦尔。观察法身见诸世间普入其身。于中明见一切世间及世间法皆无所著。是名第一普光明三昧。妙光明三昧者能入大千。微尘大千一一世界现大千尘身。一一身放大千尘数光。一一光现大千尘数色。一一色照大千尘数界。一一界调伏大千尘数众生。界种不同染净等别而无杂乱。譬如日影照诸宝山。其影各各展转互入。菩萨住此三昧不坏世界。不住内外无所分别。而能于诸界长短等相入诸界中事宛然可见

    十定品(卷四十一)

三遍往诸国土神通三昧者。于十方尘界入此三昧。长短不同刹那乃至不可说劫。若法若非时法不生分别。四清净深心行三昧者。知佛身数等众生。于诸佛所而作供养。恭敬尊重顶礼。举身布地问法称扬。于一念顷悉能了知亦不分别。住世涅槃等从定而起忆持不忘。五知过去庄严藏三昧者。能知诸劫诸刹诸佛说法。佛说中心乐诸根。调伏佛寿次第不失故。于三昧能入百劫乃至不可说劫。六智光明藏三昧。能知未来一切诸法。于一念顷能知一切劫。七了知一切世界佛庄严三昧。悉能次第遍入十方世界。见佛出兴神力众会。众会大小等四天下。乃至充满不可说佛刹微尘数佛刹。亦见自身在彼说法。及以一切所作佛事。及见佛身不同。色量各别得十种速疾十种法印等

    十定品(卷四十二)

八一切众生差别身三昧。能于一切无著。能于诸身更互起入诸趣身。起入一四天下乃至不可说不可说佛刹尘众生身。起入一身多身。更互起入现种种光等。九法界自在三昧。一一毛孔入此三昧能知一切

(卷四十三)十无碍轮三昧。一切无碍普眼白普贤。得如是法同于如来。何不名佛何不名十力一切智等。何故修普贤行愿犹未休息。何故不能究竟法界舍菩萨道。普贤告曰。此菩萨则名为佛。于如来所修菩萨行无有休息名为菩萨。如来诸力皆悉已入则名十力。乃至观察展转增胜名为菩萨。虽证普眼境界增长名为菩萨。于一切佛刹而成正觉。或于一念而成正觉。或须臾一时一日半月一月。乃至不可说劫而成正觉

    十通品二十八(卷四十四定从体立通从用生体用不二准前可知是故理有方能事用事由于理故六即中名理通具)

普贤言。一他心通。知不可说佛刹尘界六道心三乘心八部心难处心等九界。二天眼通者以无碍清净天眼智通。见不可说不可说佛刹尘界中众生死此生彼善恶趣罪福相乃至八部皆见无谬。三宿命通者。知过去不可说不可说佛刹尘劫众生生处姓族苦乐因缘品类国土趣生形相行业结使心念等差别。悉知诸佛名号出兴众会父母侍者弟子城邑出家成道说法涅槃调伏众生法住塔庙己身发心亦复如是。四知尽未来际劫智通。知不可说不可说佛刹尘数界中众生及界因果行业善恶。悉知乃至佛名字等(如前)。五无碍清净天耳。圆满广大聪彻。不可说不可说世界中所有音声所闻(如前)。六住无体性无动作往一切佛刹智通。凡有所闻一切世界佛名相貌种种国土等皆悉不动而往。七分别一切众生言音智通。不可说不可说佛刹尘数界中众生种种言辞圣非圣等皆能了知。八无数色身智通。入于法界能现其身作种种色。所谓无边色无量色清净色庄严色普遍色具相色文列百例。九一切法智通。知一切法无有名字无有种姓。无来无去非异非不异等不可言说。而以方便分别安立。十一切法灭尽三昧智通。于念念中入一切法灭尽三昧。亦不退菩萨道不舍菩萨事。佛子。如此十通余一切菩萨不能思议

    十忍品二十九(卷同并是无生之异名从法从喻从理从用故立十名名下释义悉从所依忍名从因地非果故得真因定故立斯号)

普贤言。菩萨有十种忍。得此忍者到于一切菩萨无碍忍地。一切佛法无碍无尽。所谓音声忍顺忍无生法忍如幻忍如焰忍如梦忍如响忍如影忍如化忍如空忍。音声忍者。闻诸佛法不惊不怖。深信悟解忆念修习。顺忍者。谓于诸法思惟观察。平等无违正住修习。无生法忍者。不见少法生灭。若无生灭则无差别无处。寂静离欲无作无愿无住无去无来。如幻忍者。知一切法从因缘生已。了达诸法一多相即。了达诸法法界平等。譬如幻士幻作种种非有而有。知因缘性无有动转。如焰下五义势大同。住是十忍诸法具足

    阿僧祇品三十(卷四十五初地已上入佛所知意正为明数非数故名佛所知非数而数下位不测以由正证非数非非数故遍一切法)

尔时心王菩萨白佛言。故佛所说阿僧祇无量乃至不可说不可说为云何耶。佛言。汝欲令诸世间入佛所知而问是义。百洛叉为一俱胝。俱胝俱胝为一阿庾多。阿庾多阿庾多为一那由他。乃至不可说不可说。一百二十四重。佛为心王菩萨而说颂曰。不可言说不可说充满一切。不可说不可言说诸劫中说不可说。不可尽不可言说诸佛刹。皆悉碎粖为微尘。一尘中刹不可说。如一一切皆如是。此不可说诸佛刹一念碎尘。不可说念念碎尘悉亦然。尽不可说劫恒尔。此尘有刹不可说。此刹为尘说更难。以此诸尘数诸劫一尘十方不可说。尔劫称赞一普贤。无能尽其功德量。于一微细毛端处有不可说诸普贤。一切毛端悉亦尔。如是乃至遍法界。一毛端处所有刹。其数无量不可说尽虚空量。诸毛端一一处刹悉如是。国土佛名佛身佛色光明。光中华华中叶。叶中色色中叶。叶中光光中色。色中光光中月。月中光光中日。日中色色中光。光中座座中严。严中具具中光。光中色色中净光。光中妙光此光复现种种光。光中妙宝如须弥。一一光中复现宝。宝现众刹。一刹为尘。一尘色相一一皆云不可说。又约所说利生等三百余重不可说。最后云。如是三世无有边。菩萨一切皆明见

    寿量品三十一(卷同由证非量非无量故得能量能无量今此且从迹量边故以诸量为其目)

尔时心王菩萨告诸菩萨言。娑婆一劫为极乐一日一夜。袈裟幢等更有九重。如是以劫而为一日一夜。最后云。乃至过百万阿僧祇界。最后世界一劫于胜莲华界贤胜佛刹为一日一夜。普贤等诸同行大菩萨充满其中(并语佛刹末云已曾成佛)

    诸菩萨住处品三十二(卷同并是法身示迹之处或是古佛现作因人令末代人斯心有在睹迹慕本发意修行)

尔时心王菩萨告诸菩萨。东方有处名仙人山。从昔已来诸菩萨众于中止住。现有菩萨名金刚胜。与其眷属三百人俱。常在其中而演说法。南方胜峰山法慧菩萨。与五百人俱。西方金刚焰山菩萨。名精进无畏行。与三百人俱。北方香积山菩萨名香象。与三千人俱。东北方清凉山菩萨。名文殊师利。与一万人俱。海中有金刚山。菩萨名法起。与千二百人俱。东南方支提山菩萨名天冠。与一千人俱。西南方光明山菩萨名贤胜。与三千人俱。西北方香风山菩萨名香光。与五千人俱(广如初文)。大海中有庄严窟。从昔已来诸菩萨住。毗舍离南有住处。名善住根。摩度罗城有满足窟。俱珍那城住处名法座清净。彼岸城有目真邻陀窟。摩兰陀国住处名无碍。龙王建立。萨遮国住处名出生慈。震旦国有那罗延窟。疏勒国有牛头山。迦叶弥罗国住处名次第增长。欢喜城有尊者窟。庵浮梨摩国住处名见亿藏光明。乾陀罗国名苫婆罗窟。一一皆云从昔已来诸菩萨众于中住止(九处有人十三处不出人)

    佛不思议法品三十三(卷四十六前因人土为所依今举果德法为所托依止不二身土何殊不二而二以分能所)

尔时大会中诸菩萨念诸佛国土。云何不思议诸佛本愿种性出现佛身音声智慧自在无碍解脱(如初句)。尔时如来加青莲华藏菩萨。令满普贤大愿。知见一切佛法。告莲华藏菩萨言。诸佛世尊有无量住处。所谓常住大悲住等。又有十种普遍法界。所谓一切诸佛有无边际身。色相清净普入诸趣而无染着。无障碍眼于一切法悉能明见。无障碍耳悉能解了一切音声。有无边际鼻能到诸佛自在彼岸。有广长舌出妙音声。周遍法界身应众生心咸令得见。意住于平等法身无碍解脱。示现无尽大神力。清净世界随所乐见。菩萨行愿圆满(如初句)。诸佛又有十种念念出生智。又有十种不失时。谓成正觉成熟缘记菩萨随心现等。又有十无比十种智十普入法十难信十大功德十究竟

(卷四十七)十佛事乃至更有二十余重十。皆是如来之妙德也

    如来十身相海品三十四(卷四十八前辨所依土法今明所现身相土法即身能所何别身即是法相即无相)

尔时普贤告诸菩萨。今为汝说如来相海。佛子如来顶上有三十二大人相。一一皆悉周遍十方。如是乃至左足指端第九十七一一皆云周遍法界。毗卢遮那有如是等十华藏世界海微尘数大人相。一一皆以妙相庄严

    如来随好光明功德品三十五(卷同相之眷属粗细无非法界故尔)

尔时佛告宝手菩萨言。如来有随好名圆满王。出大光明名为炽盛。七百万阿僧祇光明而为眷属。我在兜率时。放大光明名光幢王。照十佛刹尘界。彼界地狱遇光息苦。得十种清净六根咸生兜率。彼天有鼓名甚可爱乐。彼天生已此鼓发声。汝以心不放逸于如来所。种诸善根昔近善友。遮邪威力于彼生此。次足下千辐轮名光明普照王(亦如前)

    普贤行品三十六(卷四十九果满由行感果示因皆由计我能治行生行虽众多不出二种差及无差一切相入)

尔时普贤告诸菩萨。如向所演但随众生根器。以诸众生无智计我(广说诸障)。明诸障已次明修行十法。谓不弃众生等。即得具足十种清净。谓通达甚深法清净等。次得十种广大智。谓知一切众生心行等。次得十种普入。毛道与一切世界。一切众生身与一身。不可说劫与一念。一切佛法与一法。不可说处与一处。一切根与一根。一切根与非根。一切想与一想。一切音与一音。一切三世与一世。皆更互相入。次十种胜妙心。次得十种善巧智等

    如来出现品三十七(卷五十称理而现故引愿力)

尔时世尊放白毫光。名如来出现。无量百千亿那由他阿僧祇。光明以为眷属。其光遍照十方尽虚空法界。作佛事已入如来性起妙德菩萨顶。此菩萨一心向佛而说偈赞佛。于口放光名无碍无畏。入普贤口。菩萨身座过于本时百倍。次性起问现相意。普贤答。偈云。法性无作无变易。犹如虚空本清净。诸佛性净亦如是。本性非性离有无。法性不在于言论。无说离说恒寂灭。十方境界性亦然。一切文辞莫能辨。普贤言。于无量处见如来身。何以故。不应于一法一事一身一土一众生见如来身。应遍一切见如来身。譬如虚空遍至一切色非色处。非至非不至。何以故。虚空无身故。佛身亦尔。遍一切处一切众生一切国土一切法。非至非不至。身无身故为众生故示现其身。是名佛身第一相。次广说譬喻。如虚空日轮等。又云譬如月轮有四奇特。一者映蔽一切星宿光明。二者随时示现亏盈。三者多处现影。四者见者皆对目前。如来亦尔。映蔽一切声闻缘觉。随其所宜示现寿命。净心众生菩提器中影无不现。众生皆谓唯现我前

(卷五十一品同)普贤说如来音声十种相。次说如来心十种相

(卷五十二品同)普贤云。如大海水皆从龙王心念所起。如来亦尔。一切智海皆从大愿之所起也。又南洲二千五百河。西洲五千河。东洲七千五百河。北洲一万河。其水多不。答言。甚多。普贤言。复有八十亿诸大龙王。一一展转。其水倍倍于前。皆流入海。又娑竭太子宫殿中水出复倍于前。娑竭龙王宫中水涌出入海复倍于前。其水绀琉璃色涌出有时。是故大海潮不失时。如来智海复过于是。譬如金翅鸟王飞行虚空。以清净眼观察海内诸龙宫殿。以左右翅鼓扬海水。悉令两辟知龙男女命将尽者而搏取之。如来亦尔。知诸众生根已熟者。以止观翅鼓生死海而撮取之。乃至文中一一广释。皆云云何知。应正等觉音声心意识境界行成正觉转法轮般涅槃见闻亲近所种善根(如初)。于十方界现大神通。十方各八十亿佛刹微尘同名诸佛同说此法等。皆遮那本愿之力

第八再会普光明殿说一品七卷

    离世间品三十八(卷五十三世间不同故辨杂行)

尔时如来在菩提场普光明殿。坐师子座妙悟皆满(始成异名)。二行永绝等。与不可说百千亿那由他佛刹尘数菩萨皆住一生。从他方来称叹佛德。尔时普贤入佛华庄严三昧。从三昧起。普慧菩萨问。何等为菩萨依。何等为奇特想。何等为善知识。行勤精进心得安隐。何等戒。何等成就众生入界入劫等二百问。普贤广答皆有深义。答奇特想中云。于一切行生自行想。愿亦如是。答心安隐中有十种。皆以自行令他得之心则安隐。答戒中有十种戒。全是利他。所谓不舍菩提心戒。远离二乘地戒。观察利益众生戒等。有十种自知受记。所谓以殊胜解发菩提心。永不厌舍诸菩萨行。住一切劫行菩萨行。修一切佛法。于一切佛教一向深信。修一切善根。皆令成就。置一切众生于佛菩提。于善知识和合无二。于善知识起如来想。恒勤守护菩提本愿(句下皆有自知受记)。十种入入诸菩萨。十种入入诸如来。十种入众生行。十种入世界。十种入劫乃至十种佛。谓成正觉佛愿业报住持涅槃法界心三昧本性随乐十种发菩提心因缘。并以众生为首

(卷五十四)有十种园林。生死是菩萨园林无厌舍故。化物不疲住劫摄行。净土住止魔宫降他。思法观理行行绍继。一切佛法转法轮行一念成道

(卷五十五)有十种发无量无边广大心。于一切佛所观一切众生界。观一切刹一切世一切法界。观察一切法皆如虚空。一切菩萨广大行。正念三世一切佛。观不思议诸业果报。严净一切佛刹。遍入一切诸佛大会。观察一切如来妙音(皆云发广大心)

○(卷五十六)菩萨有十种无碍用。所谓众生无碍用。国土法身愿境界智神通神力力(如初句)。于身无碍用有十。以一切众生身入己身。无碍用己身入一切众生身。一切佛身入一佛身。一佛身入一切佛身。一切刹入己身。以一身示现三世众生。一身示现无边身。入三昧一身示现等众生数身。成正觉于一众生身现一切众生身。于一切众生身现一众生身。一切众生现法身。法身现一切众生身(如初句)

○(卷五十七)菩萨有十种习气。菩提心习气善根化生见佛受生行愿诸度思惟平等法境界差别。十种眼。肉眼见诸色故。天眼见众生心故。慧眼见众生根故。法眼见实相故。佛眼见佛十力故。智眼见诸法故。光明眼见佛光明故。出生死眼见涅槃故。无碍眼所见无障故。一切智眼见普门法界故。十种耳。闻赞声不贪着。闻毁声不嗔恚。闻说二乘不求不着。闻菩萨道欢喜踊跃。闻地狱苦起大悲心。闻说人天知其无常。闻赞诸佛加行圆满。闻说六度四摄发心修行。闻十方音声达深妙义。初心后心常闻正法不舍众生。有十种鼻。闻臭不嫌。闻香不着。闻香及臭其心平等。闻非香臭安住于舍。闻众生依正知其业行。闻诸伏藏皆能辨了。闻六道生知其过行。闻声闻行住一切智。闻菩萨行用平等心。闻诸佛智不舍菩萨行。有十种舌。开示一切众生行。舌开示无尽法门舌。赞一切佛功德舌。演畅无碍辨才舌。开阐大乘助道舌。遍覆十方虚空舌。普照一切诸刹舌。普使众生悟解舌。悉令诸佛欢喜舌。降伏魔外至涅槃舌。有十种身。人身化于人。非人身化三恶。天身化三界。学身现学地。无学身示现罗汉地。独觉身化独觉地。菩萨身成就大乘故。如来身智水灌顶故。意生身善巧出生故。无漏法身以无功用道示现一切众生身故。有十种意。上首意发起善根故。安住意深信难动故。深入意随顺解了佛法故。内了意知众生心乐故。无乱意诸惑不杂故。明净意客尘不染故。观众生意无一念失时故。善择所作意未曾一处生过故。密护诸根意调伏无散故。善入三昧意入佛三昧故。行住坐卧处各十。有十种师子吼。所谓唱言。我当必定成佛。是菩提心大师子吼。我当令一切众生未度者度等四。是大悲大师子吼。我当令不断三宝。是报佛恩大师子吼。我当严净一切刹。是究竟坚誓大师子吼。我当除一切恶道及诸难处。是自持净戒大师子吼。我当满足诸佛三业及相庄严。是福德无厌大师子吼。我当除灭一切天魔及诸魔业。是修正行断诸烦恼大师子吼。我当除我我所净三空门。是无生忍大师子吼。最后生菩萨示生王宫出家成道。是如说行大师子吼

(五十八卷)六度各十法相通漫多属别门。四无量各十亦尔。有十种求法。直心精进一向断他惑。益自他入智慧。出生死为利物。断他疑满佛法。十魔十魔业十舍魔业十种魔所摄持。谓懈怠心魔所摄持。志乐狭劣少行生足。受一非余不发大愿。乐寂断惑永断生死。舍菩萨行不化众生。疑谤正法。十种佛所摄持。谓初发菩提心佛所摄持。不失菩提心。觉魔事能离。闻如说修行。知苦不厌恶。观深法得果。说小不取证。观无为不住。至无生受生。证智起于行。菩萨住兜率天。有十种所作业。于兜率天将下生时现十种事

(卷五十九)菩萨示现处胎有十事。为成就小心劣解众生。不欲令彼起念菩萨自然化生故。为成熟父母眷属宿世同行善根等。示生微笑行七步。现处童子地现处王宫。出家苦行诣道树。坐道场降魔成佛转法轮。般涅槃各有十事

第九会给孤独园说一品二十一卷

    入法界品三十九(卷六十知识虽众不出法界法界无二任运差别差别知识为法界用无差别知识为法界体)

尔时世尊在室罗伐国逝多林给孤园大庄严重阁。与菩萨五百人俱。普贤文殊而为上首。列一百四十菩萨等。皆悉成就普贤行愿广叹德已。尔时世尊知诸菩萨心之所念。以大悲身以方便力充满虚空。入师子频申三昧已。一切世间普皆严净。大庄严阁忽然广博无有边际众宝庄严。佛神力故其逝多林忽然广博。与不可说佛刹微尘数诸佛国土其量正等众宝庄严。何以故。如来有不可思议自在用故。十方各不可说佛刹微尘世界海外。各一世界各一佛各一菩萨。与世界海尘数菩萨俱来各现神变。以佛力故于一佛所一念之顷普见十方无所迷惑。于刹那顷悉能往诣。如是等菩萨满逝多林。尔时舍利弗等诸大声闻在逝多林。皆悉不见如来神力如来严好境界游戏神变尊胜妙行威德住持净刹。亦复不见不思议菩萨境界。菩萨大会等皆悉不见。以善根不同故。本不修习见佛善根。本不赞说十方世界佛刹功德诸佛神变。于生死中发菩提心。令他住菩提心。令如来种性不断等。种种皆悉本无故。以是缘故不能见闻念等。依声闻乘而出离故。如恒河岸无量饿鬼。为渴所逼求水不得。虽住河边而不见河。设有见者但见枯竭。声闻亦尔。譬如有人于大会中。梦见须弥山顶种种庄严天人受乐。亦自见身如彼。诸天会人同处。而彼不见彼不梦故。声闻亦尔。譬如雪山具种种药。良医乃见则非捕猎放牧者见。譬如比丘于大众中入遍处定。其余大众皆悉不见。如人生已则有二天恒相随逐。一曰同生二曰同名。天常见人人不见天。尔时毗卢遮那愿光明菩萨等十菩萨。各说十偈皆劝声闻。令观如来及诸菩萨。皆说如来及以菩萨不思议事理。唯最初菩萨中有一行偈。斥声闻人云。一切诸缘觉及彼大声闻。皆悉不能知菩萨行境界。此诸偈意多明圆因圆果作用等

(卷六十一)尔时普贤菩萨普观众会。以等法界方便等虚空界方便等众生界方便等一切法光影方便。为诸菩萨以十种法句。说此师子频申三昧。广明依正自在胜用。尔时如来欲令诸菩萨安住此三昧。眉间白毫放大光明。名普照三世法界门。普照十方一切世界诸佛国土。广明如来神用竟。乃云。文殊承佛神力。欲重宣此逝多林中诸神变事而说偈言。汝应观此逝多林。以佛威神广无际。一切庄严皆示现十方法界悉充满等。二十六行颂颂前所见。时诸菩萨以佛三昧光明照故。即时得入如是三昧。得不可说大悲门。广于十方而作佛事调伏众生。尔时文殊从善住阁出。种种供养佛已。辞退南行往于人间尔时尊者舍利弗承佛神力。见文殊师利与诸菩萨出逝多林人间游行。作如是念。我今当与共往南方。时舍利弗与六千比丘出自住处。来诣佛所具白世尊。世尊许已右绕而出往文殊所。此六千比丘是舍利弗自所同住出家未久。所谓海觉比丘善生福光电生净行天德等(并非小乘所列)。此等六千悉曾供养无量诸佛深植善根。解力广大信眼明彻。其心宽博观佛境界。了法本性饶益众生。常乐勤求诸佛功德。皆是文殊说法教化。舍利弗令诸比丘观文殊师利清净身相及众会具足等。诸比丘闻。心意清净。信解坚固。举身踊跃。忧苦悉除。具菩萨根。得菩萨力入深境界。白言。大师将引我等往胜人所。时舍利弗将至文殊所已白言。此诸比丘愿得奉觐。诸比丘白文殊言。愿我悉得仁者所得。文殊以十事劝之。令行菩提道。诸比丘闻即得无碍眼三昧。见一切佛境界。悉见诸佛种种依正。知十方世界众生前后十生。忆彼界中过未十劫。念彼如来十本生事。成道转法轮神变说法各有十种。又即成就十千三昧。文殊乃劝诸比丘住普贤行(故知所得未入普贤行)

○(卷六十二)文殊劝已南行至福城东。住庄严幢娑罗林中。说普照法界修多罗时。无量百千亿龙生人天中。一万龙于阿耨菩提得不退转。无量众生于三乘中各得调伏。福城中优婆塞优婆夷童子童女数各五百皆来集已。五百童子中善财为首。文殊于是观察善财得名因缘等。知因缘已又知童子已曾供佛深种善根成佛法器。文殊观察已而为说法。说一切佛积集法相续次第法众会清净法法轮法法身法等(如初句)。令其发心。闻已勤求阿耨菩提。说偈赞叹自责等。文殊印述令亲近善友。向菩提行亲近善友。是具一切智最初因缘。善财问。云何学菩萨行修菩萨行。趣行净入成就随顺忆念增广。令普贤行速得圆满。文殊更劝近善知识。从此南行有胜乐国。妙峰山有德云比丘(云云)。德云比丘告善财言。我得自在决定解力。信眼清净智光照耀。普观境界离一切障。善巧观察普眼明彻。具清净行往诣十方国土。供养诸佛持诸佛法等。善男子。我唯得此忆念一切诸佛境界智慧光明普见法门。岂能了达诸大菩萨无边智慧清净行门。广明念佛法门。于一念中见一切刹一切诸佛。次令南行。海门国海云比丘。善财一心念善知识教及以法门。至海云所见已(云云)。问。云何舍凡夫地入如来地等。海云言。我住此十二年。来常以大海为其境界思惟大海。广大无量甚深难测渐次深广。如是观时大海有莲华现。华中佛现。为我说普眼法门。我唯知此普眼法门。善住比丘住楞伽道边海岸聚落。善财至已见此比丘。从空中来往语善财言。我已成就无碍解脱门。见一切众生心行等。皆无障碍供养诸佛皆得自在

(卷六十三)至达里鼻荼国城名自在。有人名弥伽。大士所得菩萨妙音陀罗尼光明法门。次南行至住林聚落有解脱长者。所得如来无碍庄严解脱门。次南行至阎浮提畔摩利伽罗国。有海幢比丘。所得般若波罗蜜境界清净光明门

(卷六十四)渐次南行至海潮住处普庄严园林。有休舍优婆夷。所得离忧安隐幢解脱法门。次南行至那罗素国。有毗目瞿沙。语善财言。我得菩萨无胜幢解脱。善财言。其相云何。时毗目仙人以右手摩善财顶执善财手。即见十方各十佛刹尘数界佛相好威仪。善财因此得毗卢遮那藏三昧。摄诸陀罗尼。次到伊沙那聚落胜热婆罗门。所得菩萨无尽轮解脱法门

(卷六十五)次到师子奋迅城。有慈行童女。是师子幢王女。是女于王宫中坐毗卢藏殿。善财见已问女。女言。汝观我所住宫殿。观已乃见一一壁柱镜相形珠宝铃树缨络等中悉见法界。一切如来从初发心成道说法现入涅槃。此是般若波罗蜜普庄严法门。我思惟时得一切陀罗尼门。次到三眼国。善见比丘语善财言。我年既少出家又近。我此生中于三十八恒河沙诸佛所净修梵行。或一佛所一日一夜。或七日七夜乃至不可说劫。于一念中十方界众生恭敬供养佛。菩萨行海诸根海等皆悉现前。得菩萨随顺灯解脱法门。次到名闻国。自在主童子与十千童子在河上戏砂。得一切工巧大神通智光解脱法门。海住城具足优婆夷语善财言。我得菩萨无尽福德藏解脱法门。于一小器随一切众生所欲。出于四事不可穷尽。十方皆然。大兴城明智居士。居市四衢十千眷属。皆令发心善根增长。所得随意出生福德藏解脱法门

(卷六十六)次到师子宫城法宝髻长者所。得菩萨无量福德宝藏解脱法门。次至藤根国普门城。普眼长者治一切病。病差已具与一切四事。如应说法具足诸行。所得一切普见诸佛欢喜法门。次到多罗幢城。无厌足王如法治国。十千大臣共王理事。十万猛卒种种治人。语善财言。我此土众生杀盗乃至邪见作余方便。不能令其见已生厌发心。所得如幻解脱法门。次至妙光城。大光王于四衢道以一切资生摄取众生。所得大慈随顺世间三昧解脱法门。次到安住王都。有不动优婆夷。以堂宇中一切金色光明摄生。所得菩萨难摧伏智慧藏解脱法门

(卷六十七)次至都萨罗城。遍行外道是出家外道。城东有山名曰善得。于彼山上徐步经行。十千梵众之所围绕。所得至一切处解脱法门。次到广大国。鬻香长者名优钵罗华。所得调和香法。次到楼阁城。见船师名婆施罗。在城门外与百千商人无量大众海岸上住说大海法。所得大悲幢行。次到可乐城。长者名无上胜。在其城东大庄严幢无忧林中。无量商人百千居士围绕说法。所得至一切处菩萨行清净门。次到输那国迦陵城月光园。比丘尼名师子频申。所得成就一切智解脱法门

(卷六十八)次至险难国。宝庄严城市廛北宅中有女名婆须蜜多。所得离贪欲际解脱法门。次至善度城。居士名鞞瑟胝罗。所得不般涅槃际解脱法门。次至补怛洛迦山。菩萨名观自在。语善财。我已成就大悲行解脱法门。我住此门常在一切诸如来所。普现一切众生之前。各以一法摄之。以同类形而共居止。次有正趣菩萨从东方来。观自在菩萨令善财至正趣所。得普门速疾解脱法门。次至堕罗钵底城大天神所。得云网解脱法门。次至此阎浮提摩竭提国菩提场中。有主地神其名安住。所得不可坏智慧藏解脱法门。次至迦毗罗城。主夜神名婆珊婆演底。所得破一切众生暗法光明解脱法门

(卷六十九)次至此阎浮提摩竭提国菩提场中。主夜神名普德净光。所得寂静禅定乐普游步解脱法门。次近有夜神名喜目观察。所得不思议大势力普喜幢解脱法门

(卷七十)次至此众会中。普救众生妙德主夜神。所得普现一切世间调伏众生解脱法门

(卷七十一)于此不远有主夜神。名寂静音海。所得念念出生广大喜庄严解脱法门。次至此菩提场如来会中。主夜神名守护一切城增长威力。所得甚深自在妙音解脱法门

(卷七十二)次至此佛会中。主夜神名开敷一切树华。所得广大喜光明解脱法门

(卷七十三)此道场中主夜神。名大愿精进力救护一切众生。所得教化众生令生善根解脱法门

(卷七十四)此阎浮洲有一园林名岚毗尼。有神名妙德圆满。所得示现受生自在解脱法门

(卷七十五)次至迦毗罗城瞿波释种女。所得观察一切菩萨三昧海解脱法门

(卷七十六)次至摩耶夫人。所得大愿智幻庄严解脱法门。次至忉利天正念王天主光女。所得菩萨无碍念清净庄严解脱法门。次至迦毗城。童子师名遍友言。此有童子名善知众艺。学菩萨字智。得菩萨解脱。唱四十二字入般若门。次至摩竭提国婆呾那城贤胜优婆夷。所得无依处道场解脱法门。次至南方沃田城长者坚固解脱。所得无著念清净庄严法门。次至此城中(同上沃田)。妙月长者。所得净智光明解脱法门。次至南方出生城。长者名无胜军。所得无尽相解脱门。次至此城南(同上出生)有法聚落。婆罗门名最寂静。所得菩萨解脱名诚愿语

(卷七十七)次至南方妙意华门城。童子名德生。童女名有德。告善财言。我证菩萨解脱名为幻住。于此南方有国名海岸。有园名大庄严。中有广大楼阁。弥勒菩萨安处其中。尔时善财向海岸国。自忆往世不修礼敬。忆念往音无量诸过对治而行。得无量法门已。于毗卢遮那庄严藏大楼阁前思惟观察。入遍一切处智慧身平等门。普现其身。在一切佛前菩萨前善知识前塔庙前乃至一切三乘圣众前十方一切众生前尽未来际等。善财童子入如是智。端心洁念于楼阁前举体投地。从地而起一心瞻仰目不暂舍。绕无量匝作是念言。此大楼阁是解空无相愿者之所住处。具列一切法。皆云之所住处。尔时善财以无量称扬赞叹法而赞阁中诸菩萨已。一心愿见弥勒菩萨。乃见弥勒从别处来。无量八部大众围绕来至阁所。善财见已五体投地。是时弥勒观察善财指示大众。叹其功德而说偈言。汝等观善财智慧心清净。为求菩提行而来至我所等。一百一十四行偈赞已。善财闻已欢喜踊跃。以文殊之力众华璎珞忽然现手以散弥勒。弥勒摩顶偈赞善财。善财又以偈赞弥勒

(卷七十八)善财白言。一切如来授尊者一生记。若一生已超一切菩萨所住处。具足一切菩萨地等。弥勒问众。见不叹言已。于福城受文殊教。展转南行经由一百一十善知识已。然后而来至于我所。告善财言。汝为饶益一切众生故发菩提心。菩提心者能生一切诸佛法故。菩提心者犹如良田能长众生白净法故。如是总一百一十八句赞叹菩提之心。又以一百五譬以譬圆菩提心。如是说已复赞于善财所有行愿菩提心等劝入此阁

(卷七十九)于是善财右绕弥勒白言。惟愿为我开此阁门。弥勒弹指其门即开。命入入已还闭。见其楼阁同于虚空种种庄严。于一处中见一切处。一切诸处悉如是见。具见种种不可思议自在境界。尔时弥勒即摄神力入楼阁中。弹指告言。善男子。起。法性如是。此是菩萨知诸法智因缘聚集所现之相如幻梦等。善财起已又复告言。汝住菩萨不可思议自在解脱。此解脱门名入三世一切境界不忘念智庄严藏。此门中有不可说解脱门。一生菩萨之所能得。善财问言。此庄严事何处去耶。弥勒答云。于来处去。问。从何处来。答。从菩萨智慧神力中来。依菩萨智慧神力而住。无有去处亦无住处。非集非常。远离一切。次明无来无去。善财言。大圣从何处来。弥勒言。菩萨无来无去如是而来。无行无住如是而来。次述从一切法处来。善财问。何者是菩萨生处。答言。有十种菩提心。是菩萨生处。生菩萨家故(云云)

第八十善财童子受弥勒教。渐次游行一百十城已。至普门国苏摩那城住其门所。思惟文殊随顺观察。是时文殊遥申右手。过一百一十由旬按善财顶。为其说法令入普贤行道场。文殊师利还摄不现。于是善财思惟观察。一心愿见文殊师利。及见大千尘数知识亲近供养。渴仰欲见。普贤菩萨即于金刚藏菩提场师子座前一切宝莲华藏座上起。等虚空界广大心见十种瑞相。又见十种光明相已。普摄诸根一心求见。于时善财即见普贤。在如来前坐师子座。诸菩萨众会中最为殊特。一一毛孔出尘数光。遍虚空一切世界。灭众生苦生大欢喜。又念念中出种种香云。遍法界虚空界广作佛事。见已即具十波罗蜜。普贤摩顶即得一切佛刹微尘数三昧门遍见普贤。于十方界一一尘中悉皆如是。次普贤说偈。复为诸菩萨说一百九十行偈叹佛

大方广佛华严经愿行观门骨目下


华严经决疑论

    No. 1741 [cf. No. 279]

    华严经决疑论序

        东方山逝多林寺比丘照明撰

北京李长者皇枝也。讳通玄。性禀天聪。智慧明简。学非常师。事不可测。留情易道。妙尽精微。放旷林泉。远于城市。实曰王孙。有同舍国。年过四十。绝览外书。在则天朝。即倾心华严经。寻诸古德义疏。掩卷叹曰。经文浩博。义疏多家。惜哉后学。寻文不暇。岂更修行。幸会华严新译义理圆备。遂考经八十卷。搜括微旨。开点义门。上下科节。成四十卷华严新论。犹虑时俗机浅。又释决疑论四卷。又略释一卷。又释解迷显智成悲十明论一卷。至于十玄六相。百门义海。普贤行门。华严观。及诸诗赋。并传于世。恐寒暑迁谢。代变风移。略叙见闻。用传知己。起自开元七年。游东方山。隐沦述论。终在开元十八年三月二十八日卒。时夜半山林震惊。群鸟乱鸣。百兽奔走。白光从顶而出。直上冲天。在于右近。道俗无不哀嗟。识者议曰。惟西域净名遍行是其流。此方孔老非其类。影响文殊普贤之幻有也。照明亲承训授。屡得旨蒙。见其殂终。嗟夫圣人去世。思望不及。时因访道君子。询余先圣之始末。不敢不言。谨序之。尔时大历庚戌秋七月八日述

略释新华严经修行次第决疑论卷一之上

        大唐北京李通玄撰

夫大方广佛华严经者。是一乘圆教佛果之门。佛果者体无成坏。以化众生故。示现自成正觉。佛果之样。举自五位因果。及摄化境界。报得庄严。示与后人。令其发志。依法仿学。令修行者所归不疑。若不晓解发心初因。如何发意修其成佛之道。设畏罪修福。及息妄住心。及愿生净土。乃至二乘得果。永超三界。且是求自免苦之心。未有以十方三涂人天苦道。及自心之境。便成智境。与一切众生。及以诸佛同一智海之门。三乘之流。但且说空破有。说一切众生。有自性清净。又说三千大千世界。为一佛报境。又云无数劫修菩萨行成佛。又说他方有净土。此间是秽土。皆是随情接引。皆是化城。非真实说。此一乘智境。皆非边量。云十佛刹微尘数身土交参。意明。如虚空无尽无限。智境相入故。化仪利物皆如是故。三世劫量。无去无来。无时可迁。不见三世。不见世间。及以众生。不见成佛。及不成佛。不见有佛处。无佛处。亦无正法像法。末法时分法故。但以自性普光明无作大智如虚空。平等无作大悲。住众生见。应根利物。而无失时。无所造作法。如是故智由三昧观照迷解显得。不是修成。悲由愿兴。不是自然。以愿兴成。功终愿废。五位之中。十住第八。十行第八。十回向第八。十地第八。分分无功。智悲任运利物故。皆至等觉。方终智悲道满。时亦不改。法亦不移。但为住熟不同。时法元来不异。如三乘一乘境界殊别。事广难量。今但略叙纪纲。广申难尽。意令行者顺辙。不枉其功。于此一部之经。略立十门。以知进修之轨。望得免其未得识过归真。约立十门者

一举佛自果。劝修生信门。二自己发心。信解修行门。三以定该含古今三世门。四入佛果位。现障成位门。五明自行所及。至果成佛门。六明自成佛果。普贤恒行门。七明成佛果满。一切皆成法界门。八以佛果法利益人间俗众门。九令世间人及龙。劝修入法。信心修行因果同时门。十至妙峰山。入位举行修行门

第一举佛自果。劝修生信门者。即初会中六品经是。六品经者。一世主妙严品。明示成正觉。表如来觉道。及智身周遍。经云。于一切法成最正觉。又十方世界一切人天中俱时出现。经自有文。经云始成正觉者。三世长短执尽。契无古今。名之为始。智现相尽。名之为成。以理智大悲。三法同体。名之为正。达悟心境。一切无明。便成大智。普照十方。都无所得。名之为觉。自成此道。名之为成。余义论本具言。第二现相品。如来口中放光十方告众。知佛成正觉。令众咸集。此明如来语业。及音声周遍。第三普贤三昧品。明如来体用行门周遍。第四世界成就品。明如来身行周遍。如世界成就品。一一世界海。有世界微尘数所依住。或方或圆。或非方或非圆。无量差别。或如水漩流形。或如山焰形。如是无量无数。依住形状差别。皆无量同虚空。如来行皆周遍。悉有如来转法轮。一一众生。前而皆遍至。化无失时。明如来行业国土。及化生国土。及同行周遍。第五华藏世界品。明如来智悲圆满。报得功德庄严周遍。其此华藏庄严世界海。有须弥山。微尘数风轮所持。其风轮都举次第。有十二重所持。其上庄严差别。此十二重风轮。以明十地通等妙二觉。于中所有愿行所成。皆是十地初心。欣求佛果。大愿力所起。略言有须弥山微尘数风轮。皆以大愿为风轮体。于中报得庄严。以从行生。以行由愿起。还以大愿风所持行上功德。以明果不虚来。是故普贤云。如是华藏庄严世界海。皆由普贤愿力起。以普贤是差别智上行。以明行由愿生。其实而论愿海无尽。略言须弥山以为尘体者。以表初地欣修十地。及等妙二位。一终愿也。总收无尽之大愿。如四弘大愿也。通收无尽大愿。以少该多如经云。如来以亲近不可说世界微尘数佛。一一佛所。净修世界海微尘数愿。广如经说。如此风轮上。持一大香水海。大香水海中。有大莲华藏世界海。此大莲华藏世界海中。有十不可说佛刹微尘数香水海。一一海中。皆有世界种。安住其中。一一世界种。复有不可说佛刹微尘数世界。如天帝网分布而住。此中有香水海。名无边妙华光。以现一切菩萨形。摩尼宝王幢为底。出大莲华。名一切香摩尼王庄严。有世界种。而住其上。此一世界上下安立二十重。从下向上。渐倍增广。一一重中。皆有佛果名号。具在经说。以明十地升进。一地中有正有向。两位各有因果。报得渐渐。广大殊胜。以此向上。渐渐增广。重重中皆有佛果名号者。以明随位升进因果。佛号也。十地中二十重世界。二十个佛果名号。皆是一根本普光明智中。随位升进立名。无别体也。如一大莲华。都含不可说佛刹。微尘数香水海。及世界种者。是一佛之报境。以智境无限。摄化利生无限。还报境庄严亦无限。如近金刚轮围山边。四周有十世界种。上下各有四重世界者。以明四摄法四无量心。摄化众生之极。尽无限心报生故。皆明报果。皆有因缘。果不虚来。且如是略知。广在经文及大论中。第六毗卢遮那品。明举古佛之果。表今古同法。令生信种。不疑古无今有者不可信。以此品经法。令发菩提心者。仿而学之。又初世主妙严品中。十个普贤众海。月光等十个别名众。明以普遍别。方成普义。通神天等众。有五十众。是佛以五位摄生之众。又示现入法。入即齐佛所知。以明修行者。入佛知见故。不令错修。如经具明。此无相法身。根本智。差别智。三法是一根本智之无相无作神用之源。皆遍周法界虚空界也。此一部经。以文殊师利。此云妙德。明无相法身智慧门。毗卢遮那佛。此云种种光明遍照。以根本智光。遍照种种众生。同行济生。名曰普贤。无相法身。明成普贤大悲之行。处世间而不染也。根本智明。神性光明。自无体性根本之相。善知一切众生业也根种。悉皆明了。名之差别智。此三法是一体性。初发心者。皆须以禅定观照助显。方便发起令明。以此信心之后。安立五位之法。进修之行。治此三法。渐渐令明。修行者。常以此文殊师利。毗卢遮那。普贤三法。为始终之体。如修道者。虽有拟成佛之意。多有滞一法。不知进修之路。以迷情固守。不求胜道。少得为足。是故此初会中。有此三法六遍周义。初发心者。一一遍知法则也。立志作意。一似佛所行。行之样万成信心。此是信他佛所行之样。以成自己信心。自己信心。如下第二会。普光明殿中自明也。此初会中言神。言八部鬼王。言天王。总有五十众。明如来自行。五位众。因果行门。覆荫遍周。以明智业如虚空。无色无形。而大用遍周。不往而速。不来而至。不作而用。应物而成功。号之为神。体净无垢。非质碍所留。隐现自在。号之为天。以智于生死利物。一念而十方遍知。同异差别无作性。应物而用得自在。号之为王。王者自在义。以如来身行遍周。同天同人。乃至十方六道。悉皆遍利遍益。而非天非人。非鬼神之神。以明智之神用覆荫遍。故上略明佛五位。因果报境行门。令初发志趣求。拟成佛者。一如佛所行之法。然后以大愿力。起于一切善法。禅定观照。无疲劳心。久住生死。无疲劳心。达取无明痴爱。便为智海。无疲劳心。常于生死大海。便为大智大慈悲海。不出不没。无疲劳心。一似佛所行之行。当建是意。方可发菩提心。自信自心。佛果所修行行之法样。如下方明。若能于此一乘佛果。起如是趣求。志愿力得不退。志愿力犹如虚空。无有退动。当知是人。超过声闻缘觉。净土菩萨之地。彼三乘中。皆有厌生死之心。不达生死无明。本唯智境。自求乐果。无有大智大慈悲心。故于一乘法界外。别求小果。避生死苦。二乘且以禅定三昧观照力。超三界现行之业。自化其火。烧分段身。同太虚空。智悲永绝。有贪三昧者。经劫不觉头上打鼓。不复闻声。净土菩萨。厌患生死。往生净土。见佛闻法。无大悲心。且受自乐。后当回向。此皆迷自无明本是大智。而于小道别有所求。于维摩法华经中。皆回此果。经中具说。不可再言。是故能于生死海。成大智境。能行大慈悲。不出不没者。初发心时。能超三乘出世之业果故。如此经下文。贤首品具明。经云有以三千大千界。顶戴一劫。身不动。彼之所作未为难。信是法者乃为难。有以手擎十佛刹。尽于一劫。空中住。彼之所作未为难。能信此法乃为难。十刹尘数众生所。悉施乐具。经一劫彼之福德未为胜。信此法者为最胜。十刹尘数如来所。悉皆承事。经一劫。若于此品能诵持。其福最胜过于彼。时贤首菩萨说此偈已。十方世界。六返震动。魔宫隐蔽。恶道休息。十方诸佛。普现其前。各以右手而摩贤首菩萨顶。同声赞言。善哉善哉快说此法。我等一切悉皆随喜。为明贤首菩萨说。能信此法者。真实心相契当故。感应及福德业如是故。如经广明。又经颂云。一切世界群生类。鲜有欲求声闻道。求缘觉者转复少。趣大乘者甚希有。趣大乘者犹为易。能信此法为甚难。大乘者但观空破我。行六波罗蜜。但经中说别有净土在他方者。总是大乘义。一乘者毗卢遮那报佛果德智悲之海。便以无明生死之海。成于大智大慈悲海。无三世古今净秽之见。是为法界。一切刹海。智凡同止。重重不碍。如光影像。不说他方别有净土之名。是为一乘。此为大心众生。所开示悟入。使入佛知见故。三乘所说。但说一切空平等。及一切众生有自性清净平等藏。平等佛国。有此土他方净秽故。一乘说空。无有自他净秽平等。三世诸佛。自性清净。无古今性。一时成佛。无前后际平等。一切众生有如来大智慧平等。一微尘中。十方智凡同住平等。一切法无大小中边。如虚空量平等。又文殊普贤毗卢遮那。三法体用平等。名为一乘。初发心者。应如是信解。如是观察。如是修学。如是悟入。普观自他一切智凡。同一智境。不见余相。皆如如来相。无有生灭。以智自在。大悲随世。而安立诸法。解众迷心。智自无有一法可得。以如来智慧。观一切众生。迷如来智慧。从虚妄业执。以幻生其身。知业本无所有。知见本是虚空。无作自在明净智之知见。名如来知见。普见一切心境。无非佛事。经颂云。欲知诸佛心。当观佛智慧。佛智无依处。如空无所依。众生种种乐。及诸方便智。皆依佛智起。声闻及缘觉及诸佛解脱。皆依于法界。当知法界一切无依。如来设教解迷。总令悟此无依之境。名为解脱。而实言之无缚无解。应如是信解佛境。佛心量。佛所行门

第二自己发心。起信修行法门者。有六品经。一佛名号品。信佛名号。随根随世界。名号不同周遍二四谛品。明四圣谛。苦集灭道。随其根欲。十方皆悉不同。明法门不同。随根遍周。不离四谛。三光明觉品。明佛足轮下光明。最初凡夫。起信之始观照之门。令心广大明净。四菩萨问明品。明文殊师利。同目首等九个菩萨。各说一法。明十信菩萨。发生明慧之心。五净行品。明一百四十愿。以净信心者心行。六贤首品。明如来三昧。名方网三昧。同别自在。令信心者信之修行。行满必得此法。同自在神功大用。以此六法。用成十信心门。又第二会初。复有尔时世尊。在摩竭提国。阿兰若法菩提场中。始成正觉。及十定品初。离世间品初。总有此言者。以菩提场。第一会普光明殿。第二会及十定品。离世间品。此四会经。总如是重叙意。明此经教。以根本普光明智。以为教体。以初会明觉得此智。以为菩提体。以普光明智。为初成正觉之体。为智无古今延促之性。始终教意。即明升进不同。部分差别。说教时。即不离一念。说教音声。即不离一声。明此一部经意。以根本智为体。以无量差别法。不离一法界。一时一念无古今。一音声中说也。设升天诸会亦云。不离菩提场普光明殿。而升忉利夜摩等天。世间众生。情识妄立。有古有今。有延有促。迷亡智现。即无此见也。是故经云。智入三世。而无来往。如今见道智。即古今三世诸佛。一时成佛。普见一切众生。无众生相。皆同一智之境是故经言。佛心众生心。乃至于自心。三心无差别。大意言之。以普光明智。为所觉之教体。会意虽有升进不同。不离普光明智。大觉之体。不属时收。如是四重叙致。是故一切处文殊师利。同声说颂曰。一念普观。无量劫无去无来亦无住。如是了知三世法。超诸方便成十力。此自己修信心之中。文殊师利。及觉首等十首菩萨。是成十信心。修行之人。金色世界。妙色世界。莲华色世界等。十色世界。是信心者。能信之心。以十个信心是。初凡夫生灭色心。生信而起十胜解故。云色世界。如易中渐卦。言鸿渐于干者。亦明初入道。信心升进。为鸿之与白鹤俱是鹤流。为带色故。以明初信。亦言。白色纯素故言鸿也。不动智佛。无碍智佛。等十个智佛。是所信自心之果。一切处文殊师利所说之颂。及觉首等九个首菩萨。各说一颂。是所信之法。如来足轮下光。是信心者作观随光引心。渐令心广大。其光于初会中。眉间放出。照十方已。入足下轮中。名一切菩萨智焰明照耀十方藏。其状犹如宝色灯云。作是观时。作白净宝光明想。初照三千大千世界作想。成已第二其光至于东方十佛国土。南西北方四维上下亦复如是。悉皆遍观。第三光照百佛世界。十方遍观。第四光照千佛世界。十方遍观。第五光照十千佛世界。十方遍观。第六光至东方十千佛世界。照百千佛世界。第七光明过百千世界。照东方百万世界。第八光明过百万世界。遍照东方一亿世界。第九光明过一亿世界。遍照十亿世界。第十光明过十亿世界。遍照东方百亿世界。千亿百千亿。乃至不可称。不可量。尽法界。虚空界。作光明想。如是四维上下如虚空。光照耀成已。然以此光明。一念十方遍周。然后照此能观光明之心。无体无相。无身无心。无内无外。无中无边。无大无小。一切皆无名为法身。于此法身无作性海。体无一物。唯无依之智。本自虚空性无古今。体自明白。恒照十方。无有本末方所可依。名曰根本智。名为智身。一切众生同共有之。迷之不了。用作贪嗔。着我我所。流浪生死诸恶道中。妄想执固。随自心所作行业流转。非他能与。若能如是。观照力灭。方能显得。不是修生。如是相应。名十住初心初发心住。便同善财童子。妙峰山顶。德云比丘所。得忆念一切诸佛智慧光明门。与一切诸佛同一正智家生故。言初发心时便成正觉。与此无依智慧相应已。十信心满。入法智流。以十住波罗蜜智行严之。如炼真金。转更明净。以住一位。总收五位因果。五位行门。皆在一位通收。以初发心住。已契根本智。时不迁。智不异。中间而有升进。渐渐微细。至十住第六住。心方入通。化身自在。如善财至海幢比丘是也。此法一向令随智见不取世间情识所知。如随光引心。令心增广。有二义。一入智境界。犹如虚空。本无中边。二随智行慈悲。度脱众生。亦如智境。无有限极。如此光明觉品颂云。见诸众生在险道。生老死苦常逼迫。修诸方便无限量。誓当悉度。是其行闻法。信解无疑惑。了法空寂不惊怖。随形六道遍十方。普救群迷是其行。如是光明引发心境。令其称本。显智境无边。如净行品一百四十广大愿。皆缘众生。以成大慈悲行。使令深厚。终不拟独求自身无苦。以是义故。从十信中。开廓心境。皆如虚空。等十方众生际。无有一众生拟有舍离之心。若根堪不堪。不离其一切世间。一切初发菩提心者。皆须建如是愿如是心。起不退想。然后顺其志愿。求一切智。心无懈倦。具一切智。常于十方三界六道众生前。对现色身。各随根欲。而引接之。令其解脱。无有休息。于信心中。常起如是愿。于一切众生敬之如佛。为一切众生。以如佛智慧。而作生因。总是佛智海中众生。若也迷解不见始成佛。不见众生灭。以法无增减故。为法无众生故。智无成坏故。但为迷悟不同。若也迷解时不见新成佛。不见旧众生。以智无故新故。观一切众生如幻相。体无本末。犹如幻化人。无有根栽生死等相。但以无依本智。而作分别。令见真体。不见是而与非。名入佛知见。是故经云。是法住法位。世间相常住。诸法住法位。方可于自心境。体会无尘。若也存是立非。情见纷挠。何时入道。长劫轮回。善可思之。益处奉行。如经云。东方过十佛刹微尘数世界有世界。名为金色。佛号不动智者。表法中以明初发心者。众善初生。觉心始发。是东方义。以明东方是青龙吉庆。春阳发明。万物初生之始。佛号不动智。以明东方是震动。以明正在动中。是不动智。故过十佛刹微尘数世界。有金色世界者。以明迷。贪嗔无明慢疑身边二见戒取邪见十。无明为过十佛刹。微尘之数。以表烦恼广多障。根本不动智。妄谓动故。自作沉沦。若论佛刹海。无有中边。何有远近。以情障处立名。达其情尘本无。即世界名金色。以金为白。光明无垢。以表根本不动智光法身无垢故。名为金色

问曰。金位在西方。何为举东方。为金色世界

答曰。以金受气于寅。胎于卯。表十信初心如胎也。上首菩萨。名文殊师利者。能了达无明本无性。显其智用故号。文殊师利。此云无相法身。虚空妙慧。能显本智之先导故号。文殊为一切诸佛之师为母。一切圣智犹如空慧发生显起故。一切处金色世界。一切处不动智佛。一切处文殊师利者。迷亡尘谢。智慧朗然。十方智境。无非法事。唯是智用起唯法起。名不动智。故云一切处不动智。以其空慧显明此理。号一切处文殊师利。文殊师利。与十佛刹微尘数诸菩萨。俱来诣佛所者。以明无边妙慧根本智。为一体用。云来诣佛所。契会敬顺。以信心初以空妙慧。简择显发。根本智现。既显智业慧为智使故。到已作礼。即于东方化作莲华藏师子之座。以表明智已生方可心境。无垢以为座体。智境无垢。含容万德。无可染着。名为莲华。于一方界常游。一切众生生死畏中。得大无畏。名为师子。若于智体清净报果上。有无量众福庄严。如光如影。重重无有障碍。亦有此庄严。今言化作者。以引化十信心众生。望实报得。不言化作。自尔恒然。无来无去。此乃令信心者。自信己身心。有此十智十世界。一切处不动智佛。一切处文殊师利。皆自有之。及以普贤差别智。以此三法以为教体。令修行者仿之。此初以檀波罗蜜为主。余九个佛为伴。今且略述此一门。自余九法在广论已说。皆随方义。表之升进。一切内外经书。设教皆令自身心中。以法行之学之。不可推之。与先贤圣者。圣者无教。性自天然。略述十信门竟。以十个智佛。文殊师利等十菩萨众。各说一法门。和会佛果大用妙慧智慈悲愿。六品经。十个智佛以为信体。名为十信。此信中方便。起入道观门。以如来足轮下光明引心广大。向十信入圣位之方便。作意者依法观之。次第如前

略释新华严经修行次第决疑论卷一之上略释新华严经修行次第决疑论卷一之下

        大唐北京李通玄撰

第三入位契真。会佛智慧门者。如十住以升须弥山顶表之门。山顶至相尽处也。善财童子至妙峰山亦同此也。得忆念一切诸佛智慧光明普见法门。以处表所升进心所至之道。以升山顶。像从十信有为信心。升此十住。空慧现前。一切心境。都无所得。是名为智慧光明普见法门。以明无相慧光。破无始长夜。计执之闇。常流苦海。今升此位。真空智慧现前。无始执障无明一时顿尽。如升山顶至相尽处也。若功至慧明。不劳登山。今以处表法。以升须弥山表之。于中明升进。得法之人。还以所得之法为名。是故十个菩萨俱名为慧。以法慧菩萨为首。于中修行之佛果。十个佛果。下名悉同名之为月。殊特月佛为首。以明无相智慧光明。能破无始长夜无明贪嗔炎热。得大清凉乐。故佛果号殊特月。此位中十慧菩萨。是此位修行者之身。十个华世界。是能开敷妙慧之心。十个月佛。是妙慧行。十波罗蜜中清凉之果。各随十波罗蜜行。下意配当皆自有意义。如殊特月配檀波罗蜜。以檀体能舍。以明此位入真空慧。一切见障执业。无明烦恼炎热。都亡皆舍。此为殊特月佛。配初发心住。檀波罗蜜为主。余九为伴。无尽月佛者。以明无相法身为戒体。无有成破。一受恒然。名无尽月佛。以忍体如空。心无倾动故。名不动月佛。以此位空慧增明。恒以空慧而观诸法。转转增明。以为精进。如风无体。而能生众法。能成能坏。佛号风月佛。以禅定身心清凉。能净诸垢。佛号水月佛。以意准知。世界名因陀罗华者。因陀罗者。此云能主。以空智慧光明。堪能主导一切众生。开敷慧眼。令其发明。波头摩华世界者。此云赤莲华。以戒体内心空寂。戒相外严。见者善生。以赤色表法。众有可观也。已下十波罗蜜意。表之各有意义。华者明此位贪嗔既亡。智慧开敷也。略释如是。广在论本。法慧菩萨。入无量方便三昧者。以一心念亡。无量境界一时亡。无量境界亡。无量智慧一时现。以三昧力。十方各千佛刹微尘数世界之外。有千佛刹微尘数诸佛。皆同一号。名曰法慧。普现其前。以言慰叹。及手摩法慧菩萨顶者。若在迷即千佛世界微尘数迷。名之为外。若以三昧力净。如许烦恼无明净。还成如许智慧现前故。有千佛刹微尘数佛智慧现前。明以定发慧。定慧正相应际。名为千佛刹微尘数法慧佛。而现其前摩顶者。定慧相印也。言赞者。以慧发即能为妙言。慧由定起故。须赞能定之心。与法慧菩萨智者。以明不离定而起用。不同二乘空定无慧。以言之与智。十信心位。不入定而说法者。明信是生灭心。未入正位故。此位入定者。非是息心定故。是任性无功。自性净故。以任法本定。即寂用不碍。即如善财于别山顶上。见德云比丘。徐步经行者。是其样也。以明自住之山。初止心不乱。有定可依。别山徐步经行。是寂用自在。是无定乱。可依之定方成定也。此定出过摄念息心修定。方入佛解脱智慧光明之中。凡摄念存心。息止所得之定。是随其深浅。并是色无色定。三界业收。心如虚空。烦恼灭不生三界。无大智慧。证涅槃乐。是为声闻定也。此十住位。所入之定。非如是也。是一切法。本自性定。能起智慧。转更增明体无沉掉而发生无量智慧。成就智悲。长处生死。不坏本性。恒无业门。此位言升须弥山。向帝释宫者有二义。一名如来成道。身行遍周。一切须弥王总至。二表十住升进。以处表法。如表法中。帝释遥见佛来。以明从十信起信。向十住之心。以信未真契十住之智慧故。云遥见佛来即以神力庄严此殿者。心意作念。置普光明藏师子之座者。安置身心。入无作自性清凉定。包含万境。无不皆净。能会本智慧故。名之为普光明藏师子之座。得于生死恒无畏心。名为师子。悉以妙宝所成者。定慧庄严。名为妙宝所成。智慧光明。超多烦恼。名十千层级。以表升进为层级。广意在论本。今且略言。佛入殿者。明定慧相应也。此位有六品经。成此十住之位。如升须弥山品。以明从十信升进。偈赞品明已前诸佛。同入此法。古今法同。令入者不疑。十住品说十种住。以明十种升进。皆十波罗蜜为体。一中具十。互体十中有百。五位皆然。梵行品明戒体。无相法身为戒体。无成坏性。初发心功德品。明发心者。广大无限。利益广多。获功德无限。称其心量。与虚空等。论主颂曰。虚空虽广无有边。不能出生诸功德。菩提智悲如虚空。重重功德不可说。又经颂云。一念供养无边佛。亦供无数诸众生。悉以香华及妙鬘。宝幢幡盖。上衣服美食。珍座经行处。种种宫殿悉严好。种种光明。妙宝珠。如意摩尼。放光耀。念念如是持供养。经无量劫不可说。其人福德虽复多。不及发心功德大。以明有为修福德者。虽无限量。一念恶心尽灭无余。设得一劫终归破坏。以初发菩提心。无为智现。智悲相应。一念功德过于虚空。无有限量。以虚空但空。无有福善。无有智悲。无有功德。普光大智为菩提体。初发心功德。不可限量。若迷智体。即有恶道业。以自庄严。若一念发心。智业现前。以智自性清净。业中有无量不可说无边功德海。自然庄严。何况大慈悲。饶益一切众生。行上所有功德。何有限量。发心者应如是发菩提心。应如是开廓心海。誓度众生。无有限量。一依此样。功德不唐捐。应可仿之不虚其德。无法发意。毕竟何归。虽知发心。不知如何发意如何进求。如十行位。在夜摩天。说有二义。一明佛身行。利众生遍周。二表十行胜于前位。又明此天在空而居。以明十住中。以得法空。智慈一终和会。此位明于法空起行。以明在行无著。以此十行在夜摩天中说。以夜摩天依空而住故。师子座有万层级者。以升进见道。智慧广多。净烦恼业。以成座体。层级广多。前位座置普光明藏师子之座。此位化作宝莲华藏师子之座。以法空起行故云化作。空行无染故号莲华。十个菩萨下名悉同。名之为林。功德林菩萨为首。林者以明行能荫覆众多故。十个佛号之为眼。常住眼佛为首。十个世界。皆名之为慧。十林菩萨。是修行之人。十慧世界。是修行者智慧。十个眼佛。是修行者。以智知根。利众生也。皆是随位因果法门。自余法事如前。此位有四品经。成此位法门。第一升夜摩天宫品明升进。二夜摩天宫偈赞品。明古今诸佛。同入此法。三十行品。明此位所行之行。四十无尽藏品。明信戒惭愧闻施慧念持辩等是。如十回向位中。有三品经。成十回向位。一升兜率天品。以明升进。二兜率天宫偈赞品。明古今诸佛。同入此门。三十回向品。明十住十行。虽修大智大慈悲。然修空智慧。出世心多。此位回十住十行出世心。令入生死。长养大慈悲。是故善财童子善知识。十住十行之首。皆有比丘。至此十回向位。长者青莲华为首。以明出生死解脱心。入于生死。长大慈悲行。处生死不染。是故善财于十回向位中。以俗人长者。号青莲华为首表之。以前两位迎佛之众。但有诸天众。无天女众。以表但得出世间智慧慈悲。未得入生死。同行利生慈悲。以是义故。无有天女。此十回向位中。全入生死大慈悲行。诸天女龙神八部。无量大众。皆悉具足。论本广明。此中略述。令发心者。约知法则。不迷趣求。自知生熟。兜率天王。敷摩尼藏师子之座。百万亿层级者。以明此位但处生死。成就大悲之行。胜前出世心故。以是义故。庄严各阿僧祇等宝。百万亿层级。此回向位。于解脱中。作起智门。广兴等众生数。情识想念。及大愿海。成普贤道。饶益一切无限众生念。解脱智慧心。于生死中。了生死性本是解脱。如师子王。而得自在。广度群生。无有休息。后之十地。及等觉位中。满此十回向位中大愿。即是更无别意。以是说十地位。时不言遥见。不言迎佛。意在同此位中大愿满也。此位兜率天中说者。明和会智悲。令圆满故。是中道义表此天。欲界之中处中故。下有忉利夜摩。上有化乐他化。一切诸佛示现诞生。皆从此天。而降神也。如发菩提心者。善识经意修行

问曰。此十回向位。已经十住十行二位。各有十法。以皆知诸法自性空无相无性。智慧现前。至此回向位中。更兴无量大愿海。作无量想念情识。起智悲门。岂非是生灭心耶。如何称道

论主以颂答曰。十住十行是初心。多有缘真念增胜。为除彼行缘真习。是故兴愿令回向。是达生灭是无生。起愿行慈不生灭。善知世间生灭性。想念情识无非智。初心定慧缘真多。此位起愿令知本。善知本者。处世间游行三界如师子。方能常处世间中。度脱群迷未曾已。是故十地位满。欲入普贤行。以无量三昧。推求普贤菩萨。竟不能见。却生想念。方见普贤菩萨。在一切十方诸佛前。坐莲华座。或从他方相续而来。广意在十定品。十地尚有此三昧涅槃习障。何况十住十行。是故须兴大愿。成就普贤行。入生死六道。一切处一切法一切愿。度脱一切众生。思惟分别。成就无边差别智。于一切境界。无不皆是。无生法门。方可功终。算数广大愚。如来随好光明功德广大愚。唯佛当究竟。十如来地一。及等觉位中十定品。总依回向中愿行。满普贤道。即是其法。于中升进法则。在他化自在天说。以处表法中。以他化天观他变化。以成己乐。亦名乐变化天。以乐他变化。以自成乐想。以表十地菩萨所修道业。皆乐欲成他众生。令其得乐。以为自乐。此地中有三十八个菩萨众为首。共成此十地法。三十七个下名悉同为藏。以金刚藏为首。一个独名解脱月者。三十七个菩萨同名为藏。为明三十七道品法。一切菩萨所成道业。成等正觉。皆由此生。解脱月一人。是此三十七品中果故。此十地之中。解脱月是能问之人。金刚藏是能说十地之中法门之主。以明因果。自相问答。余不能知。如初欢喜地。为见闻如来色身。及转法轮。乃至闻正法。多欢喜多适悦。名为欢喜地。广在经文。以檀波罗蜜增上为主。余九波罗蜜为伴。随力兼修。为闻法故。于身命财皆能舍。得离五怖畏。不活畏。恶道畏。大众威德畏。无我观。以不作此业故。如此初地中。总别同异成坏六相义。是初地中。总摄十地中义。及如来义。总须解其同别。乃至以一国土。一切国土。入一国土中。如帝网门。自在无碍。此六相义。总摄诸法。皆有此六义。今且举天帝释宝网一门。余万事准知。如天帝释宫殿中。庄严宝网。以天中净宝所成。其宝网光净。互相参映彻。一一宝中。影现重重。无有尽极。天帝释眷属。及宫殿庄严。亦影像重重。无有尽极。以用此像。以表心智境量同虚空。无有中边内外等相。一切境界。皆如幻化。本来参映重重不碍。但为众生妄心识种执业。自障不知。若无自业。本是如是。一切境界。光影相入。能以一智身。一时普现一切国刹。一切众生前。如应现身。如应说法。令使解脱。得无量乐。根未熟者。方便接引。以智无表里等。一切境界法界众生界故。本同一切众生心故。以初地菩萨。知此道理。发广大愿。令速成就此大智大慈悲行。又初地遍学十地法。及如来地法。总别同异法门。悉具知故。方可渐渐修习而成熟故。设当渐渐修学。经无量劫。而不移初发心时故。以智无三世古今。不迁移故。以十地修行。智用一一殊胜。名之为别。不离根本智。及古今无时。元来一际。名之为总。心行修行。一切境界自体无作。名之为同。一一位次。能净业障。智慧神用增明。名之为成。一一地中修行。不见修。不见行。不见成不见菩提涅槃等事。名之为坏。且于人身。眼耳舌身手足肢节。共成一身。名为总相。是一心随用不同。名为别相。皆四大火风所成。名为同相。六根各用不同。名之异相。依业成身。名为成相。一切法缘缘。无主无作者皆如虚空。名为坏相。此六相门通一切法。皆具六事法故。总持门以智观察可知。如十玄门。义亦如是。一同时具足相应门。二一多相容不同门。三诸法相即自在门。四天帝网影像重重互参无碍门。五微细相容安立门。六秘密隐显具德门。七诸莲华藏纯杂俱含无障门。八三世圆融互参相入门。九唯智同别自在门。十托事表法生解门。华严经有此十事大体。显无尽法。以智观之可见。今此初欢喜地菩萨。总通修十地及佛果。并普贤常恒利众生之行。此位通知。以因知果法。方可修行。如世造作。先须立样。如檀波罗蜜门为增上。如炼真金。于一体之上。渐令明净。然后方堪作轮王宝冠。二离垢地。上上十善戒为增上。治欲界惑。三发光地。忍波罗蜜为增上。治上色界无色界着禅烦恼。入三界自性清净平等无造作禅。四焰慧地。修三十七助道观。生如来智慧家。五难胜地。作四谛乃至世谛真谛等二十谛观。六现前地。作十二有支观。七远行地。成就方便波罗蜜。离修空无相无愿道。恒常不离三界度众生。广在经文。大意明前初地至第六地。虽常以慈悲为首。以四谛十二缘观。及教化众生。常有出世心增多。此第七地以所得三空无作无愿解脱。常居生死。度脱众生心多。第八不动地。得一切法。无生忍无功智观现前。滞净心多。诸佛加持以手摩顶。劝修行起智门。令念本愿。起愿兴悲。一念以无功自在智。所作福业。初地至七地。百分不及一。乃至百千亿那由他分不及一。如是七劝广如经说。第九善慧地。说法自在。第十法云地。受一切智职位。坐一大莲华。量等百万三千大千世界。以众妙宝间错庄严。超过一切世间境界。出世善根所起。知诸法如幻性。众行所成。常放光明。普照法界。有三千大千世界微尘数莲华。而为眷属。无量菩萨以为眷属。各坐其余莲华之上。以明一乘智境发心广大。受职广大。不同三乘中权学十地菩萨受职。但云莲华座等一三千大千世界。为三乘菩萨信解心狭。所见十地菩萨受职亦狭。但以一三千大千世界。为一毗卢遮那之智境。各自随根所见不同。此一乘如来智境所坐之座。量等法界虚空界。以为智之实报所感。今之所信。各依器量不同。若论至实究竟之门。要依一乘智为实。若欲信此一乘如来智境发心。于此经中。初信之首。以十色世界。十智如来。为自心中本有。文殊师利为自妙慧。为能信之心。此经中十信十住十行十回向十地等觉妙觉二位。从根本普光明大智。无相法身普贤差别智。以为此经修行之体。所发行愿知见。皆如来法界虚空界所作。五位方便。重重以炼磨。行意在大智大慈悲。使令圆满。深厚广大称实。广意在经。教文事广而难录。今略述少许门户。劝修未可备尽其意。有修行者。以定慧观行兼读经。看菩萨所修行愿广大之样。令不错路。设修不得。信种须成。以信内勋力。渐渐自能发志不退。任运成就。是故普贤作食少金刚喻。过身便彻任运。至金刚际始住。若人闻如来名号。及所说之法门。一经于耳。设当不信。亦能成种。以一闻法内勋。任运至佛金刚智始住。修行者莫虑此经法深远。难到难入。若不发心信解修行。恒在生死。长远未有休期。何如一念归心。设修不得常生人天。福乐果报。渐渐见佛闻法。解脱成无上道

第三以定该含三世古今无异门者。以明十定品。还在普光明殿中说。明以普光明智。以为定体。以明此教于一言音一三昧。无前后说。出世涅槃同时。故明智境无三世。是故此品。还叙尔时世尊。在摩竭提国菩提场。始成正觉。及普光明殿。初成正觉之时。古人云。三会重来普光明殿。实无重来重去也。意明三十九品经。一时无前后说。乃至三乘总然。于一时说法。各自随根闻一乘三乘之教。各自不同。依菩萨本业璎珞经说。有十会四十品经。在第三禅一会。说佛华三昧品未来。此品令十地菩萨。入普贤行。令十地菩萨。舍涅槃三昧。上稠林烦恼。方始入普贤行门。为普贤是入世间同众生行。十地菩萨。是出世间成佛之行。和会此二行。令处世间自在故。不属二边。心无所著。离二边习气障故。十个定名。是如来自说。定之大用是普贤说。以明根本智。是佛自说定名。智中大用。是普贤差别智。还普贤自说。佛告诸菩萨。普贤菩萨今现在道场众会。亲近我住。初无动移者。普贤差别智万行为会。不离根本智为住处。今明无求出世。但随世间行不染着是佛也。本来如是。只为迷流多劫。须求出世十地。功终道成方舍。但世间诸事总尔。事终缘坏。功毕作亡。事既未成功不可废。此十定品初。一百个菩萨三十个同名为慧。七十个各各异名。以十地位。三空慧满七觉分终。至此入普贤行。方舍方入。任运智慈恒尔。始绝希求。如十定十通十忍三品。总是十住中普贤行。名等觉位。总是普贤自说。以明普贤自行之法。还属普贤自行。佛自说者。是佛果位法。准此知之

第四入佛果位现障成位门者。心王菩萨问佛阿僧祇品。如来自说。其数如经自明。此数唯佛知见。非余位所知。若不能以智眼知此广大数法。及如来随好功德多少之量。即犹有此二障。不得称一切智。故号佛果二愚。过此二愚障。方成满足一切智佛。此之二法。非下位菩萨。及天龙外道所知。以加算法知之者。是菩萨法。如来智眼。知不须算法。自十地以来。有十一种粗重。二十二种愚痴。此之二障佛位知之。心王菩萨问者。以其心得自在。方可能为问主。十一种粗重者。以明从初地至十一地。普贤行未满。位位有一迷以为十一。故一位之中。有因果正向。为二十二愚痴。如来加青莲华菩萨。说佛十种不思议者。不可以心思意议。以佛是根本智。无作无言。而自在方便。无言无说中说。说根本智无作神用之法。名佛不思议说。佛果中神用故。青莲华者。是如来自性清净智中妙用智慧。一切法无染污自在性。是文殊师利。随显法之异名也。菩萨住处品。心王菩萨说。以明住持世间。一切处现在。令诸众生所依不绝。如来十身相海品。有九十七种大人之相。是普贤菩萨说。如来随好光明功德品。即是如来自法身。根本智自性清净无作业中自有。是故如来自说。今言十身者。有十华藏世界微尘数身。下文言。有十华藏世界微尘数大人之相。一一身分众宝妙相以为庄严。如华藏世界品。说是本报身及境界。今此品令普贤菩萨说。即明以根本智起差别智。行万行上功德。庄严本智之身。是故普贤菩萨说普贤行品。至此等觉位行满门

第五明自行佛果所成果门者。即如来出现品。以明自十信心。十住十行十回向十地十一地等觉心等。明信心者自行佛果。满文殊普贤毗卢遮那三法果。总终如此。如来放眉间光明。灌文殊顶。是问法之光。放口中光。灌普贤口口。是说教之光。令普贤说法。以明佛是根本智。是显得无作无说之智。文殊是无相法身妙慧。是能问之人。普贤是根本智中大用。是说法者三法具足。故如来出现此教。皆有始终。以此三法为体用。至此功终。如炼真金。功终号为出现。付嘱流通总在此中

第六普贤恒行门。如离世间品。是佛果后。普贤常行无休息。常处世间。而无染污。名离世间。此普贤常行。还以根本普光明智。还普光明殿中说。明不离初信之果用。恒利众生恒在世间。而无染污。名离世间品

第七成佛果满一切皆为法界门者。法界品在给孤独园说。以升进以明升天。望法界即不离一切处。总法界于法界。初如来普贤文殊师利三法。以成法界之大理智大用。十方普该之大体也。此是一切功终之果。名为法界。菩萨即云。如是等五百人俱。如四十个菩萨是四位。一一位中。具百是四百。通一百宝冠菩萨是五百众。一百宝冠菩萨。以明十波罗蜜本数。十中百众也。前四十心中。一一皆百。至此法界功终行满。一切十方世界尘尘中。皆有无尽如来转法轮。尘尘中皆有无尽普贤身。各化无量众生。明一人成道行满。入法界体。得如天帝网光影互参。身一时云集。皆珠帐网。罗覆其身。重重相入。普周法界。遍利众生。海觉等六千比丘。示现宿世有种。故得法获益。舍利弗等五百声闻。示现往世无信种。不闻此一乘智境。如盲若聋对面不见不闻

第八以佛果法利益人间门者。文殊师利出自楼阁。以明智慧重重。舍利弗出自房舍。以二乘人无大智慈。自身解脱名为房舍。六千比丘皆新出家。未证罗汉果。依舍利弗为师。悉皆随从文殊师利。南行人间觉城。六千比丘舍利弗。劝观察文殊师利身相福德。六千比丘一时观察文殊师利身相功德。行路两边左右各八步。妙宝庄严具。随路庄严。以八正行报生。观察文殊师利。便即归依发愿。顶礼文殊以为和尚。文殊即为说十种发菩提无疲劳心种种劝慰。一时获得十眼十耳十身十辩。渐诣觉城东。六千比丘通信位及五位修行。一时总摄号为六千。路上发心者。明声闻有行未有智。今既发心竟智悲。万行通兼

第九说教劝修门者。至觉城东明众善明也。古佛庙者。明所设教不异古也。娑罗林此云高耸。出过余林者。出过人天三乘。及外道之行也。庄严者以普贤行为庄严本智也。幢者智无倾动也。文殊师利既至觉城。从众来有无量劫数四众。但言五百者。堪入五位行门。龙众有一万。龙表智。以智兴行故。于五众之中善财为首。五众总成入法之人。善财初受胎之夜。宅有金苗纵广七肘者。以信心为胎。十月诞生者。十波罗蜜为十月也。初生之时。宅有五百宝器。遍其宅内者。以信通收五位。五百波罗蜜行中之果报也。宅中有宝楼。高及纵广各七肘。明信心中七觉支分法报生。文殊师利说普照法界修多罗经。是说根本普光明智。普印之者。大众获益。独举善财为首。劝叹起信竟。劝令南行觉城东也

略释新华严经修行次第决疑论卷一之下略释新华严经修行次第决疑论卷二之上

        大唐北京李通玄撰

第十善财入位契真门者。自三有为城郭一段颂。三十四行经。善财说颂。叹三有苦及诸法分。第二尔时文殊师利菩萨如象王回已下一段长行及颂。是文殊师利。赞叹善财能发菩提之心。及令不厌生死苦。令具足普贤行分。第三尔时文殊师利说颂已下至辞退南行。此一段长行经。是文殊师利。叹善财发菩提心。及示善知识分。第四南行向胜乐国。是善财求善知识分。从此已下至经末。通文殊师利。总有五十三个善知识。五十个以明十住十行十回向十地及等觉位。各有十个善知识为本位。通有五十人。自文殊弥勒普贤三个。以为佛果理智大用。而与五位中五十个法门。而作因果理智体用。五十个升进位中。常有此根本智。无相法身简择妙慧。普贤差别智中万行。以为因果。一一位中。皆有此三法。以成因果。因中有五十。果中有五十。都为一百。重因果五位。常以十波罗蜜。以为升进之行。名为一百一十。此十波罗蜜。常以根本智。无相法身。普贤万行。以为体用。故如修行者。未发心时。无始正使无明。十住初发心见道一时总断。习气烦恼渐渐微薄。佛果方终节级次第。后五十个善知识自有次第。如十住初心。妙峰山顶至第三住。一向缘真心多。以三个比丘表之。从第三住至第六住海幢比丘。以明回彼缘真心多。事须了俗。以弥伽长者。解脱长者。一居市肆。一以禅门。并海幢比丘一人。共表世间挠处是净。并学字智名句。世间万境总是解脱。以此三人二俗士一比丘表法。始明六波罗蜜具足。方明出世间及世间解脱。从此二种解脱之后。以第七方便行。恒处生死。长养大慈大悲。不厌生死。念苦众生。兼修智业。至第八住。方一分世间净智中。无功智成。方以满愿优婆夷。仙人毗目瞿沙表之。以明智悲之位。第七第八。令成一体智悲圆满门。以二位同住海潮处。第九以明八住智净无畏。获不死之神。以能同邪见等外道。同行引彼邪流。令归正见。五热炙身。火焰连天。刀山无际。登刀山入火聚等。以胜热婆罗门表之。第十和会十住。一终智慈圆满之行。如师子幢王女慈行表之。师子幢王是智。女是慈悲。以为所表。第七满愿优婆夷。梵云休舍。始从方便行。入于生死。长养慈悲。犹存染习。故以优婆夷表之。至第十住中。以明从智行悲。而无染习。即以师子幢王童女表之。以修行五位生熟智慈不同。事须于一乘佛果理智体用。十住十行十回向十地等觉之位。重重逆顺。五十度炼治。始得智慈众艺。万事方终。功终行满也。若也直求一解脱出世之理一法。总无同声闻二乘小道。不可号为人天之师。若也欲求无上佛乘一切智乘。即处生死。不出不没。大智大悲众艺须明。不可将无智无知是佛也。经云。佛以法为身。通达一切法。以明无不知无不解。是佛法身也。如是五位五十个行门。一百一十重因果。总根本智文殊普贤为体用。故以文殊妙慧。善简诸法。以普贤差别智。以明知一切众生根器。而与同行。以根本智号之为佛。恒无造作。自体如空。不属三世。无古今始末之性。同于世间无量劫。然智无有时。始终不异。行果不迁。处世不污。以根本智为万行之体。为此一乘法门。以根本智为佛果。以明智为初发心。以明一生成佛。以为此五位中修行之果。以同此教行之法也。以根本智相应。无古今多少劫生。故见一切众生本性无生也总一生也。如今见道。共过去未来诸佛一时成佛。即如弥勒楼阁中。现三世劫。总在今时。以智境界法如是故。令发心者。会此智业亦复如是。不见多生。名初发菩提心。于智境中。无三世古今时分等量。是法本如是故。妄见多少是妄。是识业。是生死。是执障。是邪见。从正不可从邪也。是故此五十个善知识。为升进之行。文殊普贤弥勒。为五十位中理智体用之因果。始终不离此三世法也。成一百一十之法门。如前所述。已前四段。已明劝叹善财能发菩提心。及正示善知识所在。已下明善财辞退趣求。入正及菩萨行

此已下一段。明入初发心住。于十住中初门。以檀波罗蜜为主。余九为伴。南方有国。名曰胜乐者。南者为正。为明为日。为虚无为文章。离法心。以明心达虚无。其智慧文章。心自然明白。即正慧现前。是故礼佛。先称南无。即东方为首。以东方春生发明。万物生之首故。为法事之首也。以南为法门为正。为虚无为正慧。是以先称。以东方为万物生发明之首。是以为法事之首故。是以木贯日为东字。以木生明故。以木字管十方诸法。南方亦管十方之法。以十下八为木字。以东方为青龙为智。以普贤菩萨在东方表之。观世音是慈悲。位在西方表之。以西为金。为白虎为杀害。以表慈悲之法。在杀害恶趣行之。是故十回向位中。和会智悲二门。观世音在金刚山之西阿。正趣菩萨从东方而至。同会而见。正趣表智。观音表悲。皆取方像。表之法故。然一方法。即十方遍也。今且略述东方之义少分。以明表法不可广言。以木字表智满十方。横通竖彻。通含八卦之法。总在其中。通上下二方法。为智满十方法也。少一法不名圆智。且如东方为震卦。震为木为长男。为音声为号令。即十方总通遍。且如音声语言出于口。口为兑。巽为言说风教。离为文章为心。为目为虚无。干为圆净。坤为众信顺为腹。坎为水为玄武为奸邪。是智者之所治。艮为山为小男。为童蒙为止。上方为天。含容万像。是故十信位中。上方世界名平等。佛号观察智。以表根本智。以虚空为体。下方戊巳。土王四季。表智悲圆满。负载万物。以一方之法。而遍十方。若十方参像。以该世间万类之属。以君子道明十方之法。常在一心之恒用。始可为正慧为明。为日为文章。是故十门八千为南字。以表南方为正为明。以八至之日。以八尺之表。于南方定影盈缩。且约略如是。广即云云。今言南方者。有是十种智慧恒圆满故。可以定正邪决是非是南方义。有国土名为胜乐者。从启发达此。十智圆明。破长夜之暗。名为胜乐。其国有山。名为妙峰者。夫欲入正位。且非定不启。欲入胜慧。以正止为初。山者止也。但止心不动如山。心境自然见尽。心亡相尽。即正慧便生。相尽由定。慧由定发。定慧既现。执障惑亡。执业惑亡。大智便现。相尽知现。名曰妙峰。以登山顶。至相尽之处。于空无相之理。空慧恒明。无始业尘。一念便尽。身心都尽。内外总亡。身见见取戒取邪见等五见既尽。名为见道。既见道已。唯空智慧恒照现前。随行习气。以道治之。治习渐薄。智慧增明。智慧既增广行悲愿度脱众生。当尽我愿乃亡。众生不尽我行不止。大慈如日普照十方。大悲如月清凉有海。始终如是。无有休息。名为修道。且如妙峰山上。是见道位。以根本普光明智为道体。以文殊师利妙慧修普贤行。成普贤道。为众生界作大悲门。安立五位行相。和会智悲增损。至妙觉位方终。令智海增明。大悲深广。众艺通明。四摄行圆。慈悲功满。如下自有次第。如是始终修治行满。不出刹那之境界。以智印之。莫作情解。如此初发心住。明以从禅定。显得根本空智慧门。无明始谢。智慧始明。初生如来智慧之家。名住佛所住。故得忆念一切诸佛境界智慧光明普见法门。以此见道。无古今中边等见。经历五位。炼磨习气。增长慈悲。名为修道。故言。初发心时便成正觉。方可修道。治行上智慧诸艺不圆满。障菩萨行。是以善财南行。求诸胜友皆云。我已先发阿耨多罗三藐三菩提心。云何学菩萨行。修菩萨道。不云增长佛道。故为根本智。以定显得。无作无修。但修菩萨道。学菩萨行。根本智自明自显。无有修作。如根本智。常与诸菩萨行作。无著无染。无生灭无生死之性。若不得正觉之体诸行并是无常。皆是人天有生死业报也。善财于妙峰山上七日者。七觉支分劝故云七日。四维上下求觅渴仰者。此是定后作十方观。观察诸法体性也。遥见德云比丘。在别山顶。徐步经行者。以明自住之山。是自止观。故遥见是信。以为止观之后。信有定慧寂用不二法门。是故别山上徐步经行。山上是定。徐步经行是用。以不离止而有用。以明不住寂不住乱。是故徐步经行。见已往诣者升进也。到已合掌契会也。顶礼者至本位之果也。右绕者信顺奉行。自东自北自西自南为右绕。依甲行不依辰为右绕。今人行道返此。德云比丘言。我得决定解力。信根清净。智光照耀。普观境界。离一切障。善巧观察。普眼明彻。具清净行。往诣十方一切国土。恭敬供养一切诸佛。常念一切诸佛总持。一切诸佛正法。常见一切十方诸佛所。见于东方一佛二佛十佛百佛乃至不可说佛刹微尘数佛者。此是见道之后观也。用法眼智眼观之如前。我得决定信解力。信眼清净。智光所照者是也。以清净眼智光明。照于东方一佛二佛百佛百千佛亿佛千亿佛百千亿佛那由他亿佛。乃至见无数无量无边无等不可数不可思不可量不可说不可说。乃至见不可说不可说佛刹微尘数佛。如东方南西北方。四维上下。亦复如是。此是入佛知见佛境界。供养诸佛。学菩萨神通观门。答前善财所请。云何于普贤行疾得圆满。修行者应以清净智光明眼。一依此法。从东方观。一切众生心如自心。无体无相无心性。不见一切众生苦乐好恶是非长短等相。但以清净智眼。光明普照。唯见一切众生真体。不随情识肉眼所见。但见一切众生功德果体。如诸佛相。不见人天恶道地狱等相。一切境界如光如影。无实无虚。性自无垢。诸佛众生。及以自身身心体相。本来一味。须起佛色身境界海。皆以智而生。无相法身境界。以智体本无。万相空寂。如弥勒楼阁。从无处来灭。向无处去。全见一切众生境界。是涅槃境界。全见众生境界。是如来境界。不从妄情所知。但随智光所照。令使有无自在。不坏肉眼。见诸众生。不坏法眼。境界无体。不坏智眼。幻生万境。见诸佛身。皆自在故。入智无作大用光明神化法门。皆自幻智所作。无内外有也。从于东方及四维上下无限。总以清净智光明作用。而令自在。皆须先以无作自性定。显发法身无相普光明净智。无贪嗔业。具慈悲心。始可入此智幻法门。有无自在。若不具慈悲业。便作大力鬼神恶夜叉恶罗刹。如普贤行品说。此是见道后观。未入智境者未堪也。若一向观空净业贪。缘空理虚神。妙用不行即滞寂。是二乘行种。若也迷理智妙神。一向有作想观者。即是有为生灭。同西方阿弥陀净土观也。此一乘智境观门。使清净无作智光神妙。从根本无相法身清净大智光明。成大用门。学菩萨神通。入普贤道。一向作想者亦不至。一向真心多者亦不成。回真入用者始可作也。如经中德云比丘。赞善财所求。汝求菩萨神通。乃至求菩萨生死涅槃门。求菩萨观察有为无为。心无所著。是故开此入佛境界门。和会生死涅槃有为无为。而无所著法门。以清净大智光明入。菩萨大用神通妙用恒寂故。于别山顶上徐步经行。表动寂得所。以是义故。身不处座而坐也。修行入见道已。以正智光明作如是观。一如经作体用之门。使无偏学以滞其功。以此生作一观门。成当生便入报业神功。大用自在也。此是一刹那际。来生以圆智照之可见。如西方净土观。一向有为作想。以心想成。犹尚得变易生死报业神通。如十善业尚生天上。得报业神通。如龙大力鬼。尚以无明恶业。犹有神通。何况道眼开敷。慈善根力。使智神用一生作意。而于来世不获大用神通者也。以明初发心便成正觉者。即法身无相根本普光明智。体无作理。以为正觉之体。以此成就神通。是菩萨行。正觉智体。今此现生一生发心相应时。得以正智于分段身。作观行心成。兼修善兼修众艺。观行心成。来生入变易身。以今生分段之身。是过去作业。今身以智修观行业。来生得神用变化生也。一一自行功成始得者是。自行功力得者是真也。如佛菩萨力暂时加持力得者是不真也。去却神力还自依旧。如以神鬼加持力即是魔业。转变人心不得自在。便即令心狂乱不可取也。一一以自见道力明智心境无物。净贪嗔痴业。且以性自清净平等。同体大慈悲业。无见而见。无知而知。所作皆真。以智为用。用其智印印一切众生三世业果。总为佛境界也。方得自心无垢也。从我唯得此忆念一切诸佛智慧光明普见法门已下。是推德升进。此已上一段。初入佛知见。智总该三世诸佛境界总为一时。一真法界无古今性。不见新成佛。不见旧成佛。以法无古今新旧成坏等性故。以普眼见之

第二治地住。以戒波罗蜜为主。余九为伴。南方义如前释。南方有国名曰海门国者。以戒波罗蜜为海门体。以大海不宿死尸。以表法身智光为戒体。自性无垢。不宿烦恼恶业识种诸见贪嗔死尸。以法身根本普光明智以为戒体。性自无垢故。此智现前十二有支生死海。便为一切诸佛诸功德大福德海辩才海。故曰海门。如经自有文。比丘海云者。以表十二有支。是一切众生烦恼业之大海。今以戒定慧净。为普光明智诸佛大海诸功德海大智慧海。能显示此法。覆荫润益一切众生。令开觉悟。十二有支。便成海云。故善财至海云比丘所。顶礼其足。以明升进至位也。合掌者以明契会此位之法也。善财言。我以先发阿耨多罗三藐三菩提心。欲入一切无上智海。此明善财请法。广如经说。海云比丘叹善财。能发菩提心。要得普门善根光明。具真实道三昧智光。生种种大福。长白净法。无有懈息。事善知识。不生疲厌。不顾身命。无所藏积。广如经说。海云比丘言。我住海门国十有二年。常以大海为其境界。所谓思惟大海无量众宝奇妙庄严。广如经说。言住海门国十二年者。住十二缘观。观十二缘生死海。便成大智海。乃至无量众宝奇妙庄严。以明迷十二因缘。无明缘行。行缘识。识缘名色。名色缘六入。六入缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老病死苦。咨嗟叹息。涕泪忧愁。苦果相随。无有休息。今三昧观照。方便力便为清净大光明智海。诸功德海。一切众宝微妙庄严海。无量智慧之海。广如经说。迷此十二有支。即有无量苦果。地狱畜生饿鬼贫穷困苦之所庄严。若以定慧观察。方便力便为一切诸佛海。诸功德智慧之海。如十二有支但迷三法。第一不悟心境体空。直执心境实有。名曰无明。第二迷名色为境。第三自六根为主。以意根不了。以迷名色。根境相对。行触受爱取有以生识业。以斯三缘十二缘起相续。三界苦果无有停息。今以方便力治。令成大智业。绝生死苦流。以禅定止自意根。令不于五根之中。不缘境界。意根不生。自余眼耳鼻舌身五根无生。意根既净。心境俱亡。无内无外。无大无少。无有三世古今。分别识种总亡。以意灭十二缘灭。三界一切苦果灭。唯有真智朗然明白。普照十方。智及境界万法无体。以智无体故。本明净故。量同虚空。等法界故。无中边故。神用遍周。无去来故。入一切众境界。如焰如化。如幻如影。如虚空。无取舍故。智自无我。不见他主故。智自无依。不见他依住故。智同法界。所见皆法故。智同净妙光明。现诸物像。普含容故。智为妙神。自无体性。故善能分别十方事故。智净如空。感生福海。皆同光影妙庄严故。智如帝网。于一切境界。及一切众生前。普现其身。随业差别。对现色身。无去来故。智如水清宝。一念现前。无始无明。十二有支浊水。一时清净故。是故无明灭。根境识十二有支生死苦海一时灭。法界自性清净普光明智。及一切功德智慧海一时发开。是以劝观十二有支六根境识。成如来智慧诸功德海。以得前妙峰山一切相尽。诸佛智慧光明高显。出世之道用。观察现行六根名色识种十二有支。令达世间。成一切智种诸功德。海云比丘言。善男子。我作是念时。此大海之下。有大莲华。忽然出现。以无能胜因陀罗尼宝为茎者。以天帝能主为名者。以此为一切宝中之主。尼罗是净妙青色宝也。表是由根本智。报生檀波罗蜜行所起。自余以次九波罗蜜行配之。百万阿修罗王。执持莲华茎者。王表菩萨所行万行。不离根本普光明智而得。处生死不没自在故。像阿修罗处大海而不没。百万龙王。雨以香水者。主差别之智。以为戒体。其智如龙。恒处法空。雨法利生。以为香水。以智体恒空。清净无垢。能净诸业。以为戒体故像之。如龙游空降雨故。自余依波罗蜜行配之。自余诸宝庄严。是十波罗蜜行报生。此莲华有如是庄严。芬敷布护。弥覆大海者。以明万行自体。无染而能周遍。覆荫法界一切众生。以莲华表之。是故经云。此大莲华。如来出世善根所起。十方世界。无不现前。从如幻法生。如梦法生。清净业生。无诤法门之所庄严。入无为印。住无碍门。充满十方一切国土。莲华上有佛。结跏趺坐。其身从此上。至有顶者。根本智为佛体。为智体本无神用妙净。尽诸有海。圆满十方。无见其际。言上至有顶者。尽诸有见色尘之顶。如经云。无见顶相。不可思议。此如来即伸右手。而摩我顶者。右手者作用之法。摩顶者引接会真。道合印可除疑故。为我说普眼经者。以明契会。智眼普周量齐法界。普观根境。随根教生。根境无穷。教亦无尽。若无根境。教亦本亡。以明根本智。对物设教。等一切众生。根量遍故。名普眼经。经云。假使有人。以大海水为墨。须弥聚为笔。书写此普眼法门。一品中一门。一门中一法。一法中一义。一义中一句。不得少分。何况能尽者。以教不自生。因根境而起。以众生无限。烦恼系着又多。是根境无边。教门无尽。以根本智为普眼差别智为经。我于彼佛所。一千二百岁。受持如是普眼法门。于日日中。闻持陀罗尼。光明领受无数品者。以表十二缘生之法。有百烦恼。从十无明上。互体有百。以遍在十二缘中。十二缘中。缘缘有十。千二百大烦恼根本。与十方一切众生。而作无量迷缘。流转生死大海。今以禅定观察。方便力便为一切清净普光明智海。及差别智海故。名一千二百岁受持如是普眼经。以明差别智。于根本智。起无量利益众生法门。名为我于彼佛所。受持读诵。此明以妙峰山相尽。出缠之智。作十二缘生观。治六根名色。及识生死苦海。以成清净智光普眼法门。令于生死海。成智悲之海。从我唯知此普眼法门已下。是推德升进。如是八万四千诸尘劳。皆不离五蕴六根。色受想行识起。但名色六根。以意根于五根中。取名色之境。为不了故。有十二缘生。及十大烦恼。成八万四千。如华严经云。于五蕴之上。一蕴之中。有百烦恼。五蕴之上。有五百烦恼。内有五百。外有五百。如是等乃至八万四千。以明五蕴上。内外有一千烦恼。于十使上。一使之上有一千。十使上有一万。还于十使分内外。各有一万。以为二万。以贪嗔痴增上有六万三千。通收贪行多者二万一千。嗔行多者二万一千。痴行多者二万一千。三个等二万一千。为八万四千。四千是五蕴上内外本数。八万是十使上缘境起贪嗔痴数。皆以六根名色识三事。成无尽烦恼。等十方界大迷。此三事中。以意根为主。今但以定净意想本无。五根本来无主。一切内外山河大地。及水火风等境界。皆意根取相起识。执成名为七识。但以执处成名。亦无别体。随成业处。生三界有漏界。名为第八种子。亦无别体。但是一个意识所成。今修行者但止意根。不动如山。心境自然相尽。意亡境谢。识灭智成。无始迷尘。只缘意惑。意亡智现。十方朗然。心境空虚。名为智地。以智日普观万境。无体相。迷空幻生。无本无末。无生死之体。三界六道人天地狱一切世界。皆是意想妄尘所生。意灭故妄境界随灭。如薪尽火灭。意尽业空。四大同谢。山河大地。与意俱丧。此非放荡情亡。思念都尽。以正定相应方知也。不在情识斟酌。论主颂曰。山河大地及火风。三界境界由意生。意识灭尽。如虚空一切境界同时灭。意尘识灭妄境无。唯真智境妙庄严。智境庄严如光影。皆相照彻非有无。智境无身。亦无见。以智净故。业如是。以其大智照世间。不见世间。唯智境。能以肉眼见世间。于所见中无染着

问曰。根本智既自体无垢。何不自然本是佛。何故能随迷作六道众生。轮回苦海。若修得即是生灭无。常属人天因果。若不修得。何不自然是佛。而作众生。有苦有乐。六道生死差别

答曰。为其真智。自无有性。无有本体。凝然常住。言我是佛。是自性清净故。以无自性故。无自然我是佛。我清净。若有自然我是佛。我清净。我是智慧。我成正觉者。即有处所可得之法。即是常见。即是破坏。谛观十方。无有此物。有凝然者。若有此物。不应有十方三界。有苦有乐。长寿短寿。万物不同。众生差别。若无自体凝然常住者。要须待缘方始显得。不是修生作得。为智无自性故。不属凝然常住。亦不属修生作得。此二者皆属断常诸见。以无自性故。迷心境。缘执着。成业因。执轻重。违顺情多。嗔爱贪痴。有种种六道生死苦乐不同。由执业嗔喜爱着诸烦恼故。有种种业生。从此轻烦恼中。有人天乐果者。知生死苦故。方能有自觉圣智。有因师发心。皆以知生死长远。方始发志。求于真道。皆无自然天生是佛。是真正为真智。无自性故。设从天人龙神中。有能觉知生死长远轮转过失。或以依先达圣智为师。以成觉悟。以净心境。方能显发本心无性。方知心所缘境。总皆无性。自性无生。心境无生。名为智境。以智现故。方照意所迷境。一切总无。方名为智境。夫三界因果皆由业。作得智由无作定显。方能了智自无性。不作无明。不作成佛。为智自无性故。觉知一切总皆无性故。不作无明。为智自无性。不作凝然本有佛故。是故有教说云。诸法不自生。待缘故。不从他生。诸缘自无性故。不共生。智及修行体空无自性。无合散性故。不无因生。要待觉悟修行方显。不自然成故。无成而成。无坏而坏。以无依之智无自成。亦无自坏。以智不属成坏故。不属断常故。以智觉知。无自性故。不属生死。以智觉知。自无依处故。不属生死。以智觉知。自无依处故。不属处所可得故。神用十方随根对现。不速而遍。在神无神。而能大用。在智无智。而能大明。总虚无体也。以虚无故。水火不能灾。利刃不能伤。生死不能变。言空而有大空神用。言有而无形相可得。广而不张。小而不缩。为利益未明。而幻生名也。在名无名故。所知者如响。见诸如来体如光影。教化众生如焰。兴大愿如风。行慈悲如云降雨。以虚空智含容万法。与其同体。而无厌舍一切众生。对现色身。一念遍周。而无作者

略释新华严经修行次第决疑论卷二之上略释新华严经修行次第决疑论卷二之下

        大唐北京李通玄撰

第三修行住。忍波罗蜜为主。余九为伴。南义如前云。从此南行六十由旬者。以明从十二缘观竟。重观眼耳鼻舌身意六根之上现行分别。一一根中所有现行分别。皆悉解脱。以前十二缘生观。观六根名色识三种成智。今此位中。以智随六根现行分别。无不解脱故。云从此南行六十由旬。楞伽道者。此楞伽山居大海中。四周大海。其山高峻。傍无门户。难往难登。于此大海岸上有道。以明于十二有支。五蕴六根中。至大道超度生死。明其六根以成智境。根境无染。超生死海。以表其山难往难登。今已登得故。云楞伽道也。以比丘空中经行。如楞伽山。从空而入者即得。以明于十二有支六根名色识种。智三法起。无明生死大海。我慢嗔痴高山。甚难超越。今以禅定观照。方便力了根境识悉皆空虚。无明灭。生死海竭。我慢高山皆摧裂。智净六尘如满月。故云。楞伽道边有聚落。名为海岸。今既六根皆为智海。五蕴十二缘六根境界。总为法界大海普光明智聚落也。善财至楞伽道海岸聚落。观察十方。求觅善住比丘者。重观自六根上习气使。令同空理。合及十方众生六根中境界。总同观一性虚空。令其见闻觉触使空。智慧门所行。法界聚落。见闻触受一切声香。皆为法界也。比丘名善住者。以明善住法空。常行利物。不离法空故。于空中往来经行。故名善住。以明常于生死海。行一切行。生死海。及行利众生。总不离虚空。无所染故。已下天王龙王十王恭敬者。有二义。一明有道感招。二表行十波罗蜜行。自在如王。广在经文。已上三善知识。第一妙峰山顶德云比丘。以明初入相尽。智慧光明高胜。出世间。以比丘表之。第二海门国海云比丘。以明自得离一切相。诸佛境界智慧光明。须观生死海一切自他十二缘六根名色识现行作用上。以成根本智大光明海。得普眼经法门。第三至楞伽道边海岸聚落善住比丘。得速疾供养诸佛。成就众生菩萨无碍解脱门。以明重观六根上习气。得超渡生死海之岸。得法空智慧。成利益世间生死。自在之岸。此已上三善知识。且明净得五蕴中十二有支六根上烦恼。成智慧出世解脱之业。唯度众生之行。仍是出世功成修道行门。事合如是。以是义故。以比丘表之。以明比丘是出俗行。是故善财至此位问。云何修行佛法。云何积集佛法。乃至云何不舍见佛。于其常精勤修习菩萨道。广如经说。以明此位双问。佛法菩萨法会融。以明出世智以成。菩萨俗习未了已下。意明不离世间根本清净智。而学菩萨世间之智。即示已下善知识。俗士弥伽以居市肆。说轮字庄严门。以次俗士解脱长者等。以明世间闹处是解脱。不假要居山居空。迁彼前心。令成后位。为升进已下。弥伽解脱长者海幢比丘。成世间不离出世间法。俗士兼比丘表之

第四生贵住。以精进波罗蜜为主。余九为伴。南方义如前。有国名达里鼻茶。其国在南印度之境。名义未翻。城名自在者。为此善知识。以达出世之智。又通明俗谛。真俗二谛自在故。城名自在。其中有人。名曰弥伽。身是俗人。又居市肆。一如俗相。故名为人。为居市肆。不可称名长者居士之号。故名曰人。弥伽者此云降伏诸邪论。故弥伽问善财云。汝已发菩提心耶。善财言唯弥伽下座。顶礼善财。五体投地散华。及宝无量种香供养善财。然后为说轮字庄严门者。为明菩萨敬菩提心。善财以得佛根本智慧光明。弥伽是根本智中行。以明敬本智故。以世间敬出世间智故。为明菩萨处世间。行菩萨道。于生死海不出不没。不沉沦者。获无量功德海者。只由根本智致使如是。以是义故。得此智者。须当敬之。为明根本普光明大智。是万德之宗。出生死之本。行大慈悲者之源。普贤行之宫室堂殿楼阁。生一切众生之本母。养一切众生之衣服饮食。资生之大海。人天善根总由此根本智生故。是以闻发心者。敬之即佛。故弥伽闻善财已发菩提心。是故五体投地散华。众香及众宝衣服供养善财。珍重施礼。然后说法。此乃不轻未学。敬学如佛。为善财放口中之光。以明教也。为说轮字品者。轮者圆满之义。以俗间名字说法。圆满清净。能坏生死诸不善业。句义名诠次第圆满有见。及闻受持之者。得清净智业。破生死业。破不善之海。成大善海。破愚痴海。成大智海。破贫穷苦恼海。成大福德海。一一句义。主伴相成。无失道意。一一句义说。如因陀罗网互相参彻。一一字内。随器随根。转无量法轮。无异世间诸名字法。便成出生死法。能变世间法。以为佛法。能变世间愚痴。以为智慧。能变世间言音。以为诸佛言音。广说无量利益。略而举之。思之可见。从我唯知此菩萨妙音陀罗尼光明法门已下。是推德升进

第五具足方便住。禅波罗蜜为主。余九为伴。南义如前。自此南行有一聚落。名曰住林者。此位不言国城。但从此南行。以明弥伽在市肆上闹处是静。以明一切众生生死大海尘劳为市肆。以明不离世间生死闹处。为住禅林也。聚落者众人所居。众多为聚落。此明生死众生众多处。智者处之为禅林。前位弥伽。此位解脱长者。同处生死世俗烦闹之处。以为寂静故。从南行。不言方。不言国。不言城。但云南行。南者正也。行者升进也。为正法为升进故。云从此南行。以一切世间生死尘境。总为法聚落。总为禅林故云住林。以此第五禅体。一切众生境界。以为自性禅故。是故以俗士解脱长者表之。回前三比丘出世心。令入众生生死聚落。以为禅林聚落。善财于解脱长者所请法。解脱长者。以自善根力。佛威神力。文殊师利忆念力故。以法身智体清净。皆自有之。是自善根力。以根本智。本自十方大用恒寂静故。是佛威神力。初所显自清净智。由无相法身空慧。而能发起自清净智。是文殊师利忆念力。还以此本清净智。以为禅门。性自无垢。含容总为一身。一切佛刹互相容入。如光影像。且举各随方面。各十佛刹微尘诸佛国。清净庄严身。如净琉璃含诸影像。色相无碍。于身中显现。无量诸佛。出兴于世入涅槃。一切诸佛众生无尽三世业果一切显现。以明自性无垢。禅性自遍周故。无虚空不遍。无境界不容。无作净智本自如是。圆三世因果法自如是。无延促性。不是作得。是一切世间法自性禅。一切境界。本来自定自静故。以俗士解脱长者表之。不令于世间外别有欣求。修行者应如是信解。如是修行。世间万境现前。皆是住林。皆是禅林。只为世间强取他境。而执是非。自分他土。其心以生诸业。当生苦果。知复如何也。自我唯知此如来无碍庄严解脱门已下。是推德升进。此已上两位。明俗体本真。世间闹处是静。一切万境。及一切众生心量。性自禅门

第六正心住。般若波罗蜜为主。余九为伴。从此南行。至阎浮提畔者。以明至此位修行。至出世间及世间二法极。表之畔。从妙峰山已下三比丘。表出世间智慧解脱。从弥伽长者至此海幢比丘。表世间中出世间智慧解脱。二俗士一比丘表之。有一国土。名摩利伽罗未翻。彼有比丘。名曰海幢者。以此第六般若道成。身心意想寂灭不生。离出入息。身体支分十三处。出化身不同。十方利物。智慧如海。身心寂然。都无思觉。名之为幢。善财见海幢比丘在。经行道侧。结跏趺坐。离出入息。经行道是用。结加趺坐。离出入息是寂。以明寂用无碍。足下出无数百千亿长者居士婆罗门众。十方化利者。以明长者居士婆罗门众之行。居卑谦下。离慢不自高故。足下出居士婆罗门众也。两膝出无数百千亿刹帝利婆罗门众者。是王种也。以明膝是卷舒自在之义。以明王者世间自在故。像菩萨于生死自在故。腰间出等众生数仙人众者。以明腰是行五欲之所在。仙人是净离五欲故。以明菩萨处于欲境。恒不染着。不着不离恒清净故。仙人表之。两胁出不思议龙众。不思议龙女众。十方利润众生者。以明两胁是挟持覆荫义。以明大智大悲心。以龙及龙女表之。龙表智。龙女表慈悲。像菩萨恒游法空。智慈恒遍。众生摄持覆荫雨法。故胸前卍字中。出无数百千亿阿修罗身者。胸前卍是万字。以明菩萨于生死中。行万行而不没。以阿修罗王表之。以阿修罗王在大海中。足至海底。水至半身。背上出二乘众无数百千亿声闻独觉者。以二乘背生死。背智悲故。以是背上出。从其两肩出无数百千亿夜叉罗刹王者。以明两肩是力用大自在处故。以出夜叉罗刹王。皆能飞空。力用自在。是防护义。以明菩萨示行威势。多力守护僧伽蓝及以善人。从其腹出无数百千亿紧那罗王及女者。以明腹是包含义。以明紧那罗王是歌乐之神。女表慈悲。像菩萨大智大悲。包含万德。常于十方人天六道。以众法乐乐众生。令离众苦忧恼。以紧那罗王及女表之。王者自在义。腹中出无数乾闼婆及女。此是乐神。如此技儿在十宝山中住。诸天须音乐时。往彼天中设乐。亦表菩萨智悲。包含众德。法乐以娱乐众生。令得欢喜。离诸苦恼也。从其面门出无数百千亿转轮王者。口者是说正教之门户。像菩萨恒以四无碍辩。以为四兵。以七菩提分法以为七宝。不作无义绮语言词。以表口出转轮王。一切言音皆成教法。两目出无数百千日轮。普照一切诸大地狱及诸恶趣。目者眼也。以明眼中瞳人是也。以像菩萨常以智眼大慈悲眼。观一切众生。随根设教。令离诸恶。白毫相中出无数百千亿帝释身者。帝释此云能主。能与诸天作主故。以明眉间毫相。是诸佛放中道智慈圆满果光处。以取帝释为能主。表菩萨以中道智悲圆满行。主导一切十方众生故。头上出无量佛刹微尘数菩萨众。头者相尽。智悲行圆乃无极故。举无量佛刹微尘为量。顶上出无数百千亿诸佛者。顶上尊高最胜。故出佛众。像根本智也。已下十二处化用。总是顶上起。通顶上有十三处。此位已明正心住。离出入息。寂用无碍。至十地中第六地。还同此位。得寂灭神通。但以智悲深广不同。十地夜天表之。此位比丘表之。思之可见。善财住立。思惟观察。经一日一夜者。以檀波罗蜜舍心圆满也。七日七夜七支戒圆也。半月者忍圆满也。以忍自利不益于他。以为半月。一月者精进波罗蜜。自利利他以为一月。六月者以度行成。六日者六个智慧满。海幢比丘云。此三昧名普眼舍得者。以慧眼如空。十方普照。空慧无体。物亦本无。根境恒空。照无不彻。于境不染。名普眼舍得。既无取舍。正见现前。故以佛知见故。又名般若波罗蜜境界清净光。又名普庄严清净门。以明用空智慧。于身支分十三处。幻生诸身。起化如云。充满十方一切诸佛境界众生界。成就教化庄严一切众生事业。然其身心都无思觉。此是出情量之无作妙神。性同虚空。大用自在。从我唯知此一般若波罗蜜三昧光明已上。是推德升进。此上六波罗蜜。以满出世间心。及于世间中心已竟。后休舍优婆夷。以明成就大慈大悲。以方便波罗蜜。入于生死。同于众生八万四千那由他烦恼行。同事摄生。后位是也。如后具文。若不如是。出世解脱偏多。大悲不满。从妙峰山上初发心住。海门国治地住。海岸上修行住。从弥伽长者达里鼻荼国生贵住。至住林聚落具足方便住。第六正心住。一终解脱。从第七不退住。成后三位。至灌顶住。若不如是位位相成。修行者得一法。自谓言足。不知进路。未得谓得。未满谓满。以是义故。安立五位同异法门。解行理智。大悲诸艺。神力通用。令知不错使无稽滞。初发心时便成正觉。以此正觉用治习气。德能妙用。及诸众艺。普贤道顿成。于无始无终。无三世古今之智中。便具成众德。令使正觉圆明。具普贤行海使满。不可将一无作之理。万事不明。以为佛者。乃是声闻独觉之道。非为佛也

第七不退住。方便波罗蜜为主。余九为伴。从此南行。以明从海幢比丘。于世间中。出世间智慧光明行。入生死。与一切众生八万四千那由他烦恼境界。而同其行。方便以四摄法事。随时引之。令解脱故。南义如前。有一住处。名曰海潮。以明第七方便行。以正智慧日。入生死海。普照一切众生八万四千那由他烦恼波浪。随其大小。而皆引接故。住处名海潮。以明菩萨知根知时。以度众生。而不失时故。有园林。名普庄严者。以明方便之行。处生死海。游止其中。与众生乐。以为己乐。故号为园。以八万四千那由他无边众行。遍一切众生心。皆令一切众生欢喜发菩提心。及得人天之乐。名普庄严。园中有优婆夷。名为休舍。此云满愿。为能满足一切众生所行善愿。成其善法。为于生死中。化恒尔不休。亦号意乐。以满一切众生意乐。令回向一切善法故。优婆夷所止之处。垣墙众宝树林。客殿楼间。皆言百万。广如经说。不可具言。皆为优婆夷大悲深广。依报庄严果不虚来。皆因行所起。观果知因。因果相似。即知所行。身为正报。其身金色光明绀发垂鬓。戴海藏真珠网冠。挂出诸天真金宝钏。师子口摩尼宝以为耳珰。如意摩尼宝王以为璎珞。一切宝网垂覆其身。坐真金座。此明缘身果报也。有八万四千那由他同行眷属。常居此园。以明大慈大悲行。一一行中。有八万四千那由他行门。摄众生遍故。所有依报正报。皆以慈悲心行业之所生故。善财问优婆夷发心久近。略言十佛刹微尘。具在经文。都言三十六恒河沙佛所净修梵行。于此已往佛智所知。以明从前海幢比丘。三空智慧。六波罗蜜。以为六数。以三空智慧。以能照破六根六尘上烦恼。成就一切诸佛智慧光明。如是三空六度七觉支分等三十七道品。四摄四无量心。至十地满。佛果已来。成普贤行。任运功成方休以无功智悲。用而不止。六波罗蜜行。修出世心。多至三空智慧。一终出世之道。已前虽有慈悲。教化众生。以空慧未明。照一切未毕。常欣出世之道。至前第六海幢比丘正心住。照用功毕。离出入息。神慧起化自在。如前已明。三空妙慧入于生死。成大慈悲行。同一切众生八万四千不可说诸尘劳门。与之同行。成灌顶住。已来三位。使令智慈圆满。后自有次第。若不如是。至第六正心住。得世间中出世智慧功成。若也无后第七位。即入生死。大慈大悲之行绝也。即后三位中。大用不成。是故至此第七不退住。满愿优婆夷云。发心已来。经三十六恒河沙佛所。净修梵行。先举燃灯佛等十个古佛名目。自余但举三十六恒河沙佛数。以表三空智慧解脱。三世古今诸佛总同。故先举也。以不离此三空智慧。六波罗蜜所得法门。入生死海。成后三位。使智慧圆满。成普贤行门。前位以此比丘表之。此位以优婆夷表之。以取世间一分慈悲之义。正以明修行者男女。皆尔须具慈悲柔和善忍。不舍众生故。夫圣教微密。言说难及。举比丘居士长者儿女表之像也。观像取意。得意像亡。三空者空无相无作。从此三空。却兴大愿。入十方三界六道。誓度一切众生令尽。众生不尽普贤行不休。十地中亦同此。以第七地中愿行。成后八九十地。及普贤行。如来大用神功。成法界之事业。十力四无畏等。若无第七地起大愿。入生死。但至第六地。行波罗蜜。得寂灭神通出世。自谓满足。不知所行。即后七八九地等妙。及佛果后普贤恒行绝矣。此十位中法则与彼相似。智慧慈悲增广。习业生熟不同。以此十住中。以比丘居士长者优婆夷仙人婆罗门王女。为像十地。以九个夜天神。一个如来妻瞿波女。破生死长夜。神用表之。功行胜劣。可知意况也。善财问圣者。久如得阿耨多罗三藐三菩提。优婆夷答言。不为教化一众生。乃至云。教化一切众生尽。我愿乃尽。供养诸佛尽。庄严一切道场尽。我愿乃尽。意明。佛果菩提无始终。普贤行无始终。自我唯知此离忧安隐幢解脱门已下。是推德升进。以明此位入生死海。成大慈悲。不厌喧闹。心无烦恼故。设有无量众生。一时恼之亦恒欢喜故。名离忧安隐幢解脱

第八童真住。以愿波罗蜜为主。余九为伴。于此南方海潮处有国土。名那罗素者。此云不懒堕。以表此位菩萨。得一分无功智增。忆念本愿兴悲行。行无有懈怠。倍胜于前故。云不懒堕。同前位名海潮者。前是长养大慈悲。此位智增明。以明智悲一体。以第七住此位。从悲起智。第十灌顶住。从智行悲。师子幢王女。名曰慈行是也。有仙人名曰毗目瞿沙。此云出声可畏。以第八童真住。一分正智增明。所出言音众邪惊畏。此位何故以仙人表之。为有二义。一以智净如仙无五欲也。二明得智增明。能随邪见。同行接生故。引求仙者。令入正智。仙人摩善财顶者。以明许可印信至此智位不疑。执善财手明引接。即时善财自见其身。往十方十佛刹微尘数世界中。到十佛刹微尘数诸佛所。见彼佛刹及其众会。广如经说。以明入于智位增明。与佛同见能说。佛国土身境自在。以智如虚空。见佛及境界。如虚空无不遍故。于一念中。以三昧力。印无量劫。一时并见。仙人放善财手。还复如故。此是童真住。初至智位一分增明。以假圣所接引加持。方得见诸佛国境界。若至佛功终。十方常在现前。无劳所加力。从我唯知此菩萨无胜幢解脱已下。是推德升进

第九法王子住。以力波罗蜜为主。余九为伴。于此南方者。从前升进入后位故。南义如前。有一聚落名伊沙那者。此云长直。以此法王子法师位。成其智长直。以说教利生。长于前位。依根不曲。故云长直。总明心境无不是法界。名为聚落。有婆罗门。名为胜热。以得智同邪。五热炙身。不能所害。名为胜热。世间之火由烦恼生。智慧清凉胜于烦恼。以胜烦恼故。火亦不能烧。此智入神用。非心迹所为。登刀山入火聚。四面积薪如山。火焰连天。刀山高峻。投身入火中。以明修行至此位。烦恼业亡。智堪如是。破诸邪见。令归正见。劝善财令登刀山。善财致疑。诸天劝慰。使无疑心。以明金刚焰三昧光明。烧烦恼薪。截邪见网。令归正法。内是金刚三昧入者。烦恼都亡。如清凉池意表法中。以无相智慧为刀山。无性妙光能破惑。是金刚焰定。若存金刚赫奕之状。不可能破计着执尘。论主颂云。根本智火遍虚空。生妙智慧金刚刃。能破众生坚执业。还成本智妙光明。以明根本智作无明时。从十住初心。以明无相慧显得。今至此十住第九法王之位。以从根本智起用。妙慧利益众生。以是为金刚三昧之火。起无量智慧刀山。照割一切众生长夜烦恼。及方便引接妄行苦行。五热炙身之流

第十灌顶住。以智波罗蜜为主。余九为伴。南方有城。名师子奋迅者。以明灌顶住中智波罗蜜增明。此位以智行悲。处生死海中。了心境本智体无生灭。不畏生死。名师子幢王。以一智中。一时普与十方。一切众生前对现色身。如响普应。一时普遍。犹如师子奋迅。一时全身普振。有童女名曰慈行。是师子幢王女。师子幢王是智。童女慈行是慈悲之行。以明此位从智行慈悲。与世同行。以无染习。即以童女表之。如第七休舍优婆夷。从慈悲成智。即犹存染习故。即以优婆夷表之。皆像知法。得法像亡。思之可见。五百童女以为侍从者。如五蕴中烦恼。经云。一蕴之上有五百烦恼。五蕴之上有二千五百烦恼。以此智慈之行。总收五位上五百波罗蜜行。遍十方一切众生五百烦恼。共同其行。乃至八万四千五百为主。住毗卢遮那藏殿。以明大慈悲居根本智光明藏。以为殿体。龙胜栴檀蹙金线网天衣座上。而说妙法者。以师子幢王根本智。而起妙慧。以龙降大法雨。润益众生。栴檀者香名。为此香能息毒蛇热恼。正热时毒热恼盛。以身缠树。热恼清凉。以明此善友降法雨时。无明毒蛇皆得清凉。金线网衣座者。线者贯穿义。网者教网也。衣者覆盖义。以善能贯穿教网。覆护众生。报居此座。善财诣王宫门。求彼女者。智王悲宫。是所求之处。观其报果。一一境界之内。皆有一切如来。从初发心时。乃至成道转法轮。示现入涅槃。如帝网之光影参彻。以此波罗蜜印。印三世古今之业。境界都尽如是。童女告善财言。善男子。此是波罗蜜普庄严门。我于三十六恒河沙佛所。求得此法门者。三空智慧六度。以为佛数。一佛所演。余不重说。以明从根本智。起三空智慧。总是佛智慧。亦是一个三空。空无相无作智慧。六度行门。转一切众生六根内外尘。总为清净。普能庄严法界众生。总为佛智慧。如下文所说。无量般若波罗蜜。总以根本智。起三空智慧为体。能清净一切众生差别业门。而令成就如来智慧。皆以三空智为体。广如经说。从我唯知此般若波罗蜜普庄严门已下。推德升进。意明。第七住入生死海。同一切众生八万四千及不可说量。同虚空诸烦恼门。皆与同行。至此第十住位中修行行满。一终智慧行圆。还从根本智。起八万四千不可说智慧。总根本智生。以三空为体。能破一切众生六根中一切诸烦恼。故若无众生诸烦恼众多。三空智慧亦无有也。众生烦恼广多。般若波罗蜜广多。如来化身亦广多。以将十住中所修福德智慧。神化之事用。成十行中一切利益众生行门。及自治自随行习气不自在障。令使自在故

已上十善知识以后。凡夫修行出世间及世间。出世间空智慧解脱出世慈悲心多。于众生艺治化饶益利门未学。立位明法。五位前后殊分。若行之者。不出一时一法。一位遍收前后时法故。以智境之中无古今也

略释新华严经修行次第决疑论卷二之下略释新华严经修行次第决疑论卷三之上

        大唐北京李通玄撰

    十行位

第一欢喜行。南方有国土。名为三目。彼有比丘。名曰善见。南义如前。国土名三目者。以明法眼智眼慧眼。以此善知识。于此行中。常以此三眼。善利众生。故名三目。目者眼也。以法眼明净。常见法身。智眼知根。善知根器。慧眼简择。明见正邪。以此三眼处行无惑。若无此三眼。自亦恒迷。事无不染。何堪利物令离盖缠。以善知识道德行门。而标其国。名为三目。比丘名善见者。以此三眼知根。应根与益。不浪施教。名为善见。何故此十行之初。以比丘为首。以明处行。先以三眼明彻。于世间中心境无垢。名曰比丘。以比丘无染。是解脱义。此十行初以比丘。是处行不染义。十住初妙峰山顶德云比丘。是从定起观。以明相尽出俗之义。十回向初。鬻香长者号青莲华。以明回出缠心多者。令入生死。成大慈悲行。处世知真。而不染污。故号青莲华。以俗表之。如净名之流是也。十地初以婆珊婆演底主夜神。此云主当春生。以明十地大悲行常处生死长夜。主当一切众生。令善芽增长。亦是主当春生苗稼神。善财至三眼国。于城邑聚落村邻市肆川源山谷一切诸处。周遍求觅者。城者可知。邻者尚书大传曰。五家为邻。三邻为朋。三朋为里。五里为邑。此是虞夏之制也。自余可知。善财如是求觅。以明观察诸法。静乱无体。一切处无著。比丘在林中经行往返者。以明万行如林覆荫。庄严万有也。地有林庄严真境。人有行庄严自身。及益他人也。往返经行者。明体不住生死。不住解脱涅槃。故其比丘壮年者。以明在世毁赞无倾。利生无尽。为壮年美貌端正可喜。其发绀青右旋不乱。顶有肉髻。皮肤金色。颈文三道。额广平正。眼目修广。如青莲华。如是等三十二相具足。以明法眼智眼慧眼内严。外彰善行。慈悲和悦知根接。生以得报相严身具。有三十二相正果报也。正经行时。不迟不速。审谛经行。无量天龙八部释梵护世等。十众前后围绕者。以行感招受化之众也。主方神随方回转者。震巽离坤兑干坎艮上下二方为十方。皆有神随逐回转而行。又表法中震为木。以木中都含十方之法。以十下八为木字。震为音声。为震动。为青龙。为吉庆。为春生。为发明。为众善之首。以此法事先东方为首。南方离。为虚无。为正为日。为目为心。为文章。为盛明。若达心虚无。即有智慧文章明也。故问一知十者。是智盛明义。以此十朋之龟者。问一知十。表智慧明也。北方者为坎为水。为玄武为始明。此方以明暗创分。以为北字。故十一月一阳生。以明暗始分之始。暗去明来。明暗相背也。又表正在玄武。迷愚奸邪之际。善恶不和。不相信顺。亦是明暗不比。皆相违背。故云北字。海幢比丘背上。出二乘以表之。又坎为牢固为水。水善利万物。皆是随方回转之义。善恶之道十方参有。东北方为山。为石为止。为小男为童蒙。年初岁末在其中。丑未相冲。是阴阳之介。金墓在丑。木墓在未。日生于寅。月生于申。以艮为山故。表山高难升。以人巴为艮字。若表圣道难登。心净不动如山。方正道现也。即以艮止其心。正道现为艮义。皆随方回转义。东南方为巽。为风为长女。为言说为风教。故巽主辛丑辛未。以丑为小男。未为众人为信顺。以明巽为言说风教。以化众人。童蒙小男已至道者。德合天地。然不须教也。是故口出风。而施言教。以定正邪。是非尽言说俱巳。故两巳共成巽字。约略如是。十方之法难量。一方之法具有十方。互体参差卒申难尽。但随世法及出世法。随事回转。是故经言。主方神随方。回转者法也。以明法无定体。随事变通。以明处此位中。随其世间事宜。教行自在。随方回转。引导其前者。以明善施教行。引导一切众生。以教行为先也。足行神持宝莲华。以承其足。神表智。于万行中处世无染也。以明行体性无垢故阎浮幢林神。雨众杂华云。此林近阿耨达池。以表万行如林。覆荫含生。不行一行。处行无量。度脱众生。华者行也。无尽光神。舒光破暗者。恒以智慧破一切迷暗故。不动藏地神。现诸宝藏。令一切众生修其善业。发开智慧宝藏故。普光明虚空神。庄严虚空者。以普光明智度众生。普令众生行于空行。破诸迷暗。获无量福德。以自庄严成就。德海神雨摩尼宝者。以大慈悲行净众生垢故。无垢藏须弥山神。顶礼恭敬。曲躬合掌。以明自智高胜。恒行谦敬。无我慢之心。无碍力风神。雨妙香华。此是巽神。以明智慧善说风教。闻者欢悦。是香华义。巽为风教义。春和主夜神。庄严其身投地者。众善行为庄严。一切者。行不离根本智地常觉悟。主昼神执普照诸方摩尼幢。住在虚空。放大光明者。以明无相法身为虚空。根本智光为摩尼宝幢体。以智自性无垢净光为照耀体。以明万行及以心境。恒以根本普光明智普照十方。无一法可得。而以万行度诸众生。不离此智。常不迷心境。即能于世间而无染着。处于世间教化众生。常行此十行法。而无过失。此十个神以表神智处世之行十波罗蜜。令修行者仿之。我闻圣者已下请法。比丘答之。我年既少。出家日近者。以明初从十住。创入十行之首也。我此生之中。于三十八恒河沙佛所。净修梵行者。以明不离法眼智眼慧眼三法为三十。此三法上。皆能破除心境识上十无明。以此三法所观。一切心境识。皆不离法眼智眼慧眼。所知见故。即八正道行。恒相应故。故言三十八恒河沙佛所净修梵行。以恒河沙邪见一切烦恼。以三眼观之。无有一法不解脱者。不离法眼智眼慧眼所知见故。无有一法不清净故。身口意悉清净故。故云三十八恒河沙佛所净修梵行。以三眼净。一切见闻觉知境。总净名为佛之知见也。经云。或有佛所。一日一夜净修梵行。乃至七日七夜。半月一月。一岁乃至不可说劫。净修梵行。乃至入无所证处。净修梵行。亦见彼佛成等正觉。说法各各差别。无有杂乱者。以月无始无终。无有本末。一切心境之上。不见一法是非能所。是修梵行。梵者净也。善了心境无染净是非之性。常作如是观。是于一切佛所净修梵行。以自心境一切净故。即是佛也。修行者终不可于自他之上。存是立非。得为成佛也。设经尘劫勤劳。无免生死。何如心境皆净。以三眼随用。住持世间。修行者应常以三眼观察世间。令心境识以成智业。心境清净慈悲和悦。主导众生。无有劳倦。何事须忧。一切佛法自然明了。我唯知此菩萨无尽灯解脱门已下。明推德于前更令升进。以法眼智眼慧眼常照现前。令不迷心境。即情识种子总亡。唯智慧现前。名为无尽灯法门。又以一灯燃百千灯。冥者皆明。明终不尽。故云无尽灯也。此位以檀波罗蜜为主。余九为伴

第二饶益行。南方有国土。名曰名闻。南义如前。国号名闻者。以明自在童子智德高远。物无不晓。书数算法。技术众艺。世间益生之法。莫不洞达。以是名声远闻。故国名名闻。童子名自在者。以童子得不死之命。一切世法不能沮坏。于生死中。随器现形而自在。故云自在。在河渚者。水中可居处大者名洲。小者曰渚。小渚曰沚。聚砂为戏者。以明算法随聚砂之多少。算知颗粒。此位中童子自在知之法。约有十法。一书二算三印四医五工巧六和合仙药七农八商贾九相十知人根器而教授之。有此十法。而利众生。算法阿庾多。此方一兆。那由他此方一亿。自余算数梵本未翻。从我唯知此一切工巧神通已下。是推德升进。此位以戒波罗蜜为主。余九为伴。十住位以十二缘生观。观生死海。为佛智海为戒体。此十行法为戒体。以成饶益之行

第三无违逆行。以忍波罗蜜为主。余九为伴。南义如前。有一大城。名为海住。前之二位所云国。此位云城者。何以明但以约智德所知为国。今此位以忍防护身口意业。不令高慢。名之为城。城名海住。明下心如海。容纳众流而无所弃。优婆夷名具足者。以能具足施戒忍进慈悲。具此五法名为具足。在此城中所住之宅者。以明忍行内严。不居其外。故在城中。所居之宅。四面无量种种众宝庄严者。以明一心内怀法忍。感招无量功德庄严。优婆夷处于宝座者。以忍为座体。盛年美貌端正可喜。以忍报严也。素服垂发。身无璎珞者。此舍外华严。以明忍状。色相威德光明者。忍行志德感乘故。容貌可喜。其宅广博。一室而开四门者。以忍施仁慈广大。以四摄法四无量心无限也。以一小器置于座前。一切世界无限大众来所食。皆随根得食得道。各各差别。以法忍施戒慈悲谦下。无自大憍慢为小器。即功德广大施无边。若能忍心如虚空。福德庄严无有尽也。故颂云。行忍身心无中边。除见大小如虚空。其心平等无高卑。十尘法施亦无尽。此位明十行忍门。十千童女总明忍辱柔软和悦之行。以女表之。眷属有百万阿僧祇者。以明忍辱慈悲柔和行周。从我唯知此菩萨无尽福德藏解脱门已下。明推德升进。以明忍辱一门即诸行具足。诸功德藏具足也

第四无屈挠行。精进波罗蜜为主。余九为伴。南义如前。有城名大兴者。以明精进波罗蜜。大兴财法二施之行悉周遍。故城名大兴。居士号明智者。以智能随俗。善行二施。饶益一切众生。故名明智。善财于城内市肆衢道七宝台上。处无数宝庄严之座。而坐其上。其座十种庄严。广如经说。皆依十种波罗蜜行报生。故先云七宝台上以为座体者。以明万行以七觉支分为体。七觉者。一择法觉支。二精进觉支。三念觉支。四喜觉支。五猗觉支。六定觉支。七舍觉支。以根本智为长者之身。故为明智。居士者居世间而不染。故名居士。以其明智坐七觉支。成无量妙行门。作自利利他升进之行。明一切万行觉观。治习解迷。精进无倦。成就大慈大悲。皆不离一切法空。自性无垢白净无作智为本体。以染净习气。及乐出世间心之胜劣。令知慈悲增减不圆满障。安立十住十行十回向十地等妙二位升进之行名目。与修行者作样。令学者仿之依教不错。故市四衢道坐七宝台座。以七觉支为座体。以明四摄四无量心。故名四衢道。以七觉支分十波罗蜜及无量行。名众宝庄严。常处生死烦恼为朝市。以明此位精进之行。应如是行财法二施之门。善财请法。居士令观来众色类无量广多。及来众欲乐不同。劝观之已。居士须臾系念。仰视空中。如其所须悉从空而下。一切大众普皆满足者。以表明智自体是空。一切果报。皆从空智而幻生故。以此仰视虚空。表其空智幻生福报诸功德海。从此空智而生。是以观其本源。令知果报功德所生之因。大慈大悲财法大舍。悉从空智而起。一切万行从空智慧而生。及以一切众生及以业果。皆如是也。令修行者善知心境一切功德果报。及一切众生所行因果。皆从空智而有。众生不了妄作无明。而作善恶业。迷其空智。生死流转。了此法者得大明智。而常随俗行于慈悲。诸功德海财法二施。广大无尽随念而至。从此空智而有故。是故须观令学者识本。仿之在行无染。犹如莲华而有可观。处水无染。前十住中。第四精进波罗蜜。即以弥伽长者。于市肆上。为十千人众。说轮字庄严门。令学诸善知世智。了世名言书字句义一切名字互体相生。一一名字有一切名字。互成生起。本性体无。今十行中。第四无屈挠行。行精进波罗蜜。以明智居士在市肆衢道。以明四摄法。行财法二施。摄众生行。从空智生。自余广意经中具明。从我唯知此随意念念生福德藏解脱门已下。明推德升进

第五离痴乱行。禅波罗蜜为主。余九为伴。南义如前。大城名师子宫者。明禅定能发大智慧。于生死中及大众中。说决定破生死法。得无怖畏。故名师子宫。明此智慧。不从外依他而来。以自心寂定所显得。故名师子宫。智慧为师子。善财于市中见宝髻长者。以明此位不住禅。体在生死烦愦之中。引接一切众生。故长者接善财手。将诣所居。示其舍宅。光明真金所成。白银为墙。颇梨为殿。绀琉璃宝以为楼阁。砗磲妙宝而为其柱。百万种宝周遍庄严。赤珠摩尼为师子座。摩尼为怅。真珠为网。弥覆其上。玛瑙宝池香水盈满。无量宝树周遍行列。其宅广博十层八门。善财次第观察。此以禅体大智慧功德八正行报生依果故。观果知因。善财观察报居宅舍因果。即得所修之道。论主颂曰。禅心自净为光明。自性无垢为真金。廓彻如空无涯际。此是智者之宅舍。智眼普观一切法。白净无垢无中边。诸法取舍不可得。此是智者之垣墙。了色尘境本性无。心王善治名为殿。净智明见照世间。于法普照为楼阁。常于一切见闻中。常无取舍。无倾动。一切色声能见闻闻中不闻为宝柱。色境自性本无性。智者以之为座体。能于十方尘劳门坐。为大智无垢染。成大智慧无所畏。此是智者师子座。善设教网。漉众生。心恒清净香水满。楼阁十重宅八门。十度八正是其行。最下重中施饮食。第二戒施为宝衣。第三忍辱宝华璎。第四慈悲精进女。第五禅慧妙庄严。五地通明菩萨住。第六净慧妙空乘。六地菩萨于中住。七层方便处生死。八层无功智自在。九层一生法王居。十层佛果咸充满。如是次第而修学。毕竟无初及中后。以此定慧总持门住智。自在非空有。善财白言。种何善根。获是果报。长者告言。善男子。我念过去过佛刹微尘劫有世界。名圆满庄严。佛号无边光明法界普庄严王如来应正等觉。十号圆满。彼佛入城。我奏音乐。并烧一丸香而供养。以此功德回向三处。谓永离一切贫穷困苦。常见诸佛及善知识。恒闻正法故获此报也。释云。过佛刹微尘数劫者。处迷未悟曰尘劫也。有世界名圆满庄严者。以明根本普光明智自性。有无边功德世界也。佛号无边光明法界普庄严王者。即根本普光明智自性无垢。恒照法界虚空界。一切众生同共有之。但为处迷。随三界六道果报。善恶不同。若也一念与天真自性无修无作禅相应。一切心境色尘性。自无垢便成普光明智。性自无依。不依空有。而能普照十方法界妙用自在。无边功德自然庄严。但为隔迷本体。与无明贪嗔不相离也。一念净心迷解大智现前。但以十住十行十回向十地等觉位五十个法门调和智慈生熟。使令均齐。成普贤行。然其智体不离初心。时亦不迁。智亦不改但令智悲神用。渐渐增广渐渐增明。使令廓彻。量同虚空。等周法界。同一切众生。心住一切众生。随心而现。悉能普应十方世界。无处不至。始终如是。自性常尔。不作神通想念变化。以慈善根力。法尔恒然。功行方满。此宝髻长者。以一切色尘自性无作禅。开发此普光明智。显发教化一切众生。但迷时即言佛刹微尘劫。悟已古今总无所有。升进不离。无古今中。而有渐渐。如空中云。不离空体。而有聚散。然其空体。不属时收言无边光明法界普庄严王佛。入城我奏音乐。并烧一丸香。供养彼佛。得此功德者。但表乐音是五尘之境。便达五尘本来法体。本是法界普光明智之境界。以为法乐。名为供养。得此道者。是回向三处。永离贫穷困苦。常见诸佛及善知识无边功德。以此达妄成智。而用教化众生而得也。我唯知此无量福德宝藏解脱门已下。明推德升进。以无明迷解。以成普光明智。以用教化众生。是无量福德藏。十住解脱长者禅身。含十佛刹海。以境而从体。以为禅体。此十行中。宝髻长者。以禅体而就用为禅体。一切色尘无不禅收

第六善现行。以般若波罗蜜为主。余九为伴。南义如前。有一国土。名藤根者。以表此位智慧深固。彻于水际。不可倾拔。名曰藤根。城名普门者。为此长者世无不达。无不救济。医方疗疾无病不明。大小三乘。及一乘根种。无不皆示。依法接引。所称时宜。香汤沐浴名衣上服饮食上味。无不给施。故其城名普门。长者名普眼者。以明此位智慧幽微。世无不晓。十方世法一切皆明。名为普眼。此位以智慧成满一切医方。一切佛法。大小法门。及饮食衣服。十方恒施。亦和合一切香。供养诸佛。广在经文。我唯知此令一切众生普见诸佛欢喜法门已下。是推德升进。此位令修行者见道之后。以慈悲故。利众生事。无不顿明。以益群品。十住中海幢比丘。入寂灭神通。十方化利。此位普眼长者。以正法大小诸乘。及世法诸功。普皆等济

第七无著行。方便波罗蜜为主。余九为伴。南义如前。有大城名多罗幢。此云明净。王名无厌足。此位中明善治国政。慈愍含生。无有厌足。治世间有多恶逆。多不善行。故示威严。自化其身。作十万猛卒。形貌丑恶。衣服偏陋。执持器仗。攘臂嗔目。作诸苦具。见者恐怖。自化其身。作种种恶。还以自化其身。而追捉之。或截耳鼻挑目。种种苦治。令实众生惧而不犯。厌而离之。能发无上道心。明菩萨大慈大悲之行。以治恶法。外示威严。内怀慈愍。以大慈悲心。实不伤一蚤一蚁。何况人耶。广如经说。我唯得此如幻解脱门已下。是推德升进

第八难得行。以愿波罗蜜为主。余九为伴。南义如前。有城名妙光。王名大光。此妙光是无色形之根本。妙智大光王。是妙智之大自在用。是差别智。以此位成一分顺理无功之妙行。仍有顺解脱之心。多不同十地第八地任法无功智现前。恐随智体自性无作。而滞大慈悲。故从十住直至十地。皆以愿波罗蜜防之。令至其位。念本愿力。起大悲行。不令住净。于智悲行渐渐殊胜。广大三昧涅槃道上烦恼习气。至十地位满。方舍始于普贤行而得自在。其位未成者助道之行。不可厌废。其位已至助道之行不可留。如世间法皆然。思之可见。从十住第八十行第八十回向第八十地第八。各随本位。皆有一分无功之智。和会智慈之行。胜劣之体。如十住第七位。即以休舍优婆夷与第八位仙人。同住海潮处。以明智悲无二体也。此十行位。第七第八。以明净城妙光无厌足王大光王。和会大悲体。以明随位胜劣。即以仙人与王表之。所行随位力用不同。诸位仿此知之。位位皆然。道无二体。但明位位殊胜。如十回向第七第八。以观音正趣菩萨。同会而见。以圣者表之。渐渐入神所用幽微广大故。妙光城纵广一十由旬者。一之与十皆为大数之母。母者本也。是根本智。十亿衢路。十亿是差别智中众行。明不离本妙智之体。而有无边众行大用。表之其一之与十。而遍十亿及十不可说乃至一切数之大体故。一一道间。皆有无量万亿众生者。以明差别智。及众行中一一行。摄化无量万亿众生。根欲不同皆得其所。已下诸众庄严。皆智悲之行报得。具如经文。观果知因。其王二十八相者。以明后有善法行真实行。二行未圆。一行中有因有果。阙此四重因果。未具三十二相也。以明后二种行满。即化行遍周。三十二相亦满。以不住大智楼阁故。在四衢道中。以明四摄法四无量所摄行遍故。诸相具足也。当此妙光城中。有一楼阁。名正法藏。阿僧祇宝以为庄严。光明赫奕。最胜无比。众生见者无有厌足。大光王处中者。楼阁是根本普光明智。大光王是差别智。城中有无数宝楼阁。皆是本位十波罗蜜行之所报生。最居城中楼阁。根本智之报体。大光王于所住楼阁。不远坐如意摩尼宝莲华师子座者。以不住智净名不远。以四摄法摄化众生为四衢道。随意利生。名如意宝也。智恒无垢号曰摩尼。常处世间而无染污。是广大莲华座。其城各随众生业力所见。净秽不同。入大慈为首。随顺世间三昧者。以明不住净智。随俗行慈顺俗利生。心无沉掉名为三昧。名菩萨幢行随顺世间三昧。入此三昧时。其城内外六种震动。树木楼阁一切境界。倾身向王。皆悉顶礼。是三昧力所感。广在经文。我唯知此大慈为首随顺世间三昧门已下。是推德升进。此位以明不住净智。随俗行慈悲行遍故

第九善法行。力波罗蜜为主。余九为伴。南义如前。有一王都。名安住者。五位之中但是第九。皆是法王之位。以明至此位。说法自在。故号王都。住持轨度。身心寂静。故名安住。以明法师志德也。有优婆夷名不动。以明法师志德慈悲和悦柔软。心不随境。以明法师之行。以不动优婆夷表之。不即要以妇人为法师也。优婆夷言。于自眷属不生嗔恨。何况他众生。善财叹此女人。有三种行。颂曰。守护清净戒。修行广大忍。精进不退转。光明照世间。善财见优婆夷。但恭敬合掌。不致礼拜者。以此位说教。无高卑性。不行曲礼。如无行经。得性相平等无我无人者。又文殊师利白佛言。所见如来。不应礼敬。以此号为无行经。此至道者无上礼也。但有合掌观察。合道其体平等。智慈不施曲礼。得法之后。方随俗礼。以是辞去。方礼法师位。有十种行。一慈悲二柔软三谦敬。四色境之中心无倾动。五持戒六忍辱七精进。八广明世间出世间诸法对治门。九善说四辩分明。十言音和悦生致慰问。此为法师之志德也。我唯得此求一切法无厌足三昧光明为一切众生说微妙法皆令欢喜已下。是推德升进。此法师位其意广大。具在经文。今且略知经之大意次第。诸有作者。善依经本。而更审谛。自策其志。此优婆夷云。尔时劫中受持如来所说法门。未曾废舍一文一字。乃至世俗文字。亦复如是。乃至世间技术之法。一一法中。亦复如是。以看古样。自励已躬

第十真实行。以智波罗蜜为主。余九为伴。南义如前。有一大城。名无量都萨罗者。此云有无量大喜乐事。为此善知识行。以四摄法正邪。同事爱语方便。众生见者。无不蒙益故。城名有喜乐事。有出家外道。名为遍行。不着三界。名曰出家。一切众生皆同其行。名为遍行。三千大千世界中。九十六种外道。皆悉与其同行。故名遍行。在山顶上平地经行。以明智波罗蜜。智高出世俗。名为山顶。大悲平等。普摄众生。名为平地。善知识以无依智。于此阎浮地城邑聚落一切众生中男女大小。常现其身。同其色类。而为说法。诸众生等。皆悉不能知我从何所来。唯令闻者如实修行。十方一切世界人天六道常皆如是。故号遍行。从我唯知此至一切处菩萨行已下。是推德升进。已上十善知识。成就世间诸艺治化之行。兼修出世之心多。若恒以生死苦海常处其中。不出不没。以成大智大慈悲。及一切智海后位方明

略释新华严经修行次第决疑论卷三之上略释新华严经修行次第决疑论卷三之下

        大唐北京李通玄撰

    十回向

第一救护一切众生离众生相回向善知识。以檀波罗蜜为主。余九为伴。南义如前。有一国土。名为广大者。以此回前十住十行。自修解脱心多。令同于生死。调和生死涅槃。五位菩萨地位升进。教化一切众生相。智慧之香。令成就普贤广大愿海。由此为首。故国名广大。有鬻香长者。以明能和鬻诸香。以表能调治生死。便成大智大慈悲五分法身戒定慧解脱解脱知见香。普熏一切众生。皆令发意。故名鬻香。鬻香融易出世间解脱。入于生死。成大智大悲。以为一体无二也。解脱不坏。能与生死一体。犹如净水处泥不浊。犹如水精宝入浊水中。能清浊水。其水现在而不浊性。犹如臭草处栴檀林。犹如浊水生妙莲华。又如阿泽迦药一两。能变千两铜铁。以成真金。纯作金体。无有铜铁性。若人一念与根本普光明智相应时。能和无始无明恶业。变为如来大智大慈悲海故。犹如和合诸香。以为一丸。互为资熏。以成妙味。然诸香体各不相知。纯杂自在。一一诸香。不合不离。是故菩萨以清净智。同于生死。以为一体。一切众生八万四千不可说诸尘劳门。皆与同成智悲之海。生死无垢智无清净。无和无合。不散不离。若见生死有浊。见智有清净。即居染净二心。心境无非解脱。以长者号青莲华者。以明同生死。而不染污故。像此十回向。回前十住十行出世心多。回入生死。成就大悲。无染着故。以俗人长者青莲华表之。十住初十行初。皆以比丘为首。表出世心多。既得出世已。须入生死。广行行海。度脱众生。是故此十回向。以俗士长者号青莲华表之取像。下意思之可见。以回真入俗等尘劳。而无尘劳可污也。长者云。我知一切香者。以明一切众生。皆有五分法身之香。只为发心时未至。一切烧香者。于生死海中教化令觉悟。焚烧烦恼故。一切涂香者。以明于生死海中慰喻赞叹一切众生。令欢喜发心故。一切粖香者。令一切众生散烦恼故。亦知香王出处者。根本智香王出。在无明中。以达无明。成根本智慧为佛知见。自在为王。以万境不能染污故。已下天香龙香等八部众。有八种香。以明和合世间人天八部众八种邪思惟等。成圣道中八种正道。已下善香恶香及世所受用香。有十三种香。以明和合人天六道中六根。及境上善恶烦恼有十二。总合为一丸。成圣所知见受用之香。即十三也。已下菩萨差别香。差别智也。一切菩萨地位香以明五位差别升进。总结。如是等香。形状生起。及根本者。以明和合五位升进生起相。且如十住有十位生起形相。皆以后位生前位。引令修行者。升进不得停住。使令加行不息。智德慈悲诸艺。速明道行增广。不滞一法。又初发心住。至第三住。出世心现前。以第四住弥伽居士市肆上者。为生起引前位出世心多。使令知闹处是出世故。第四住至六住。有世间出世心多。即第七住纯入生死。无求出世。成大慈悲行以为生起。皆有十重。及第四第七两度生起。后十住以十行为生起。十行以十回向为生起。五位皆然。若不如是得一法。即自谓言足。便即无求也。人间有香。名曰象藏。因龙斗而生者。以明象为大力。含藏大用在其身。表根本智。以明无明贪欲所翳障。今以定慧观照力。与贪欲嗔爱龙斗。方始发明其香。若烧一丸。起大香云。弥覆王都者。以量周虚空。生死界为王都。以智者于中止故。于七日中。雨微细香雨。着其身者。悉皆金色。以明与无明斗。现根本智。白净无垢。以起差别智。说七净财之妙法。有能悟入。身心白净无垢。名为金色。若着衣服。宫殿楼阁亦皆金色者。以明慈悲喜舍诸助道行。总皆金色。以明万行以根本智为体。若因风吹。入金殿中者。以明因说教风吹。入众生心。信受七觉支观。以为七日七夜。欢喜充满者。法乐也。广如经说。并此象藏香向下。通有十种香。五位通用。且如十住。一住配一。十行十回向十地。各各十位。皆配一种香。第五如雪山中香表禅。第六罗刹界中香。表第六智慧。以智慧如罗刹能食啖众生血肉。取力用猛壮所。表当位之法。以明智慧罗刹破坏无明。不可为对。此罗刹界香。名为海藏。以智慧为海藏。其香但为转轮王所用者。以明第六位般若波罗蜜智慧成已。方能善转法轮。像轮王也。烧之一丸。及四军皆腾虚空者。以明至般若波罗蜜位。所说之法。身心四辩。皆与空合。一一像取之。得法像亡。从我唯知此调和诸香法已下。推德升进。以明此十回向法。前十住十行。出生死心多。令入生死中。而无所著。起普贤行愿。亦与后十地及等觉位。为大智大慈悲之体故。于兜率天宫。于欲界处中而说故。以此调和根本智普贤行愿。总满十地及等觉位。依样而行故。前经中于膝上放光。说十回向位。以表膝者。卷舒自在义。以彰此位调和生死涅槃。而得自在故。将合和香法而表之

第二不坏回向。以戒波罗蜜为主。余九为伴。以明不坏清净法身智身。以为戒体。以此清净戒体为大慈悲。处于世间生死。而了生死之性悉清净故。若处迷也心境俱缚。若在悟也心境俱真。故名不坏回向。于此南方。南义如前。有大城名楼阁者。为以无量重重差别智。观察诸根。以为其楼。无尽智海。随根随时。接生为阁。有船师名婆施罗者。此云自在。为此位以净戒处生死。而不污。故云自在。其船师在城门外者。以接众生故。不住自智德故。处外接众生也。海岸上者。以此位大慈悲为戒体。明临生死海岸。接众生。令无失时故。像大海潮无失时故。百千商人。及余无量大众围绕者。以明万行圆满。船师云。我在此城海岸路中。净修菩萨大悲幢行。以明于生死大海流转路中。净修菩萨大慈悲幢行者。以明处生死不倾动故。摧破一切生死军故。此船师有二义。一以菩萨常处世济难。现同凡行。为大船师。引诸商众。生其宝所。辩诸宝类。定其宝价。非圣智不可为也。二示法以明此位大慈悲为戒体。以十住十行。得出生死之海。此位回令入于生死海。济渡沈伦生死众生故。以船师像之。是故船师云。闻我法者。令其不怖生死海。必得入于一切智海。广如经说。从我唯得此大悲幢行法门已下。是推德升进

第三等一切佛回向。以忍波罗蜜为主。余九为伴。南义如前。有城名曰可乐。城是从前位升进。至此位言。城是防护之义。以明心境之上。永不起嗔恨不忌之心。故名为城。城云可乐者。为常行忍辱。众所乐见故。长者名无上胜者。以明诸行之中。忍为最胜。此位善财所以悲泣流泪。以明忍辱慈悲之行故。见无上胜长者。在其城东者。是春生众善发明之首也。大庄严林幢无忧林中者。以忍心成满在万行无忧。以为处所也。居无量商人者。以求法宝也。百千居士者。处世俗而恒真也。如上诸众之所围绕者。接生行圆也。善财见彼长者。以身投地。顶礼其足。良久乃起。以明忍行以成深智礼敬也。无上胜长者云。我成就至一切处菩萨行门无依无作神通。初云三千大千世界一切人中。次云三十三天。及八部龙神。乃至十方一切国土。地狱恶道之身。皆遍周。以其同类教化。皆令欢喜。随器所堪。皆令离苦。以明法忍即成。无依智现。以智无处所大小中边。非三世所摄。性自遍周。量济法界。不往而到。不来而至。此乃无神而神。大用遍周。无作而作。大功普应。十方六道。恒常于一切众生前。对现色身。随应教化。现同凡事。而诸众生无疑怪心。此乃十方人天世间常尔。是普贤常道也。此乃立样。令修行者。设功行未及知位。欣修须及。不无其此。我唯知此至一切处修菩萨行清净法门无依无作神通之力已下。是推德升进。此前之三位。是十回向。入生死成大悲行。以鬻香长者号青莲华。船师自在。无上胜等。三个长者俗士表之。至此南方有国土。名曰输那。有比丘尼。名师子频伸。是十回向中。入生死出世间慈悲故。以比丘尼表之。尼字者慈悲之音。比丘者出世之相。以表生死中出生死清净大慈悲行。为明修行者。了生死而性清净故。愍其不了者。恒处其中。无有出期

第四至一切处回向者。以明此精进行。无生死不遍。无恶道不至故。以精进波罗蜜为主。余九为伴。南义如前。有国土名输那者。此云勇猛。为此位于生死之中。行大慈悲度。量同虚空界。六道众生。随器现形。悉遍周故。无不济度故。以精进如是。国土名勇猛。其国有城。名迦陵林。此云斗诤时。以明此位处世无染。大慈悲。于世间能和斗诤。故以为名。比丘尼名师子频伸者。以德行立名。以明清净智如师子。久处生死。以大慈悲故。广度众生。无辞劳倦。心恒适悦。名曰频伸。师子频伸者。展舒适悦之义。此比丘尼。在胜光王所舍施之园中者以明于生死中。行出生死大慈悲之行。而得自在。故名胜光王。舍施之园。以明行慈悲法。以表居生死中。胜于生死。行慈施法。以为悦乐。故名为园。园者游观悦乐义。以像菩萨恒居生死。度脱众生。以为已乐。故名之为园。此位中以普光明智。成种种意生身。十方利益。一身作无量身。遍周法界众生前。成就差别智门。意明。此慈悲精进行。都含十方虚空六道众生总为一。大慈悲饶益众生。令离苦得乐。发菩提心。成无上道。广大之园。一众生不尽不出。其中一切菩萨皆如是行。以众生界本真性故。以比丘尼号师子频伸像之。园中所有宝树。及尘陂池楼阁等。皆以明依行报庄严。广如经说。从我唯知此成就一切智已下。是推德升进

第五无尽功德藏回向。以禅波罗蜜为主。余九为伴。于此南方。有一国土。名曰险难者。以女人术行。以违真理。闻者难信。故国名险难。城名宝庄严者。为明及至其所。心大慈悲故。常随生死之流。广利群品。同行利生。了五欲性无。不离禅体。以大慈悲故。不离俗体。为大智故。处俗而不染。夫俗间之境。畏而离之。是二乘法。染而爱之。是凡夫法。故菩萨不同此二。为大慈故处生死。同行。为大悲故。了生死及世间境界总无也。以大慈悲故。以智幻生其身。处于世间。如影犹如化人。虽同世间。无境可染。亦无心染境。但为大慈悲行。于世间不行一行。行无量等众生行门故。虽同世间。世间如化。自身如幻。以智随尘。尘无染者。尘亦本无。以此义故。虽同世俗。常离欲际。法门以明自智无五欲。以大慈悲故。常入生死。随俗利生。得大功德。五名无尽功德藏回向。故城名宝庄严。以自智无五欲。为利众生。行万行故。城名宝庄严也。是故净名经云。示受于五欲。亦复现行禅。令魔心愦乱。不能得其便。火中生莲华。实可为希有。在欲而行禅。希有亦如是。此位以大慈悲为禅体。居世间不染。如婆须蜜女表之。表一切菩萨大慈之行。法合同缠不要须是女也。如离世间之行。亦无菩萨行故。为众生烦恼多。菩萨行多。众生无烦恼。菩萨行亦无故。前比丘尼。以入生死中。成大慈悲。得出世解脱慈悲行门。此位以于出世解脱慈悲中。入于五欲境界。以明菩萨心大慈故。不染而染。染而不染。示受五欲。而无亏女志。不坏无作自性禅门。十方世界。随所见者。如应差别。各身不同。善财见婆须蜜女。此云世友。以能十方一切世界。对现色身。随所根睹者友而不舍。皆令离苦得乐故。云世友。所居在市廛之北。自宅中住者。以此位生死尘劳为市廛。无法不寂为自宅。其宅广博严丽宝墙宝树园林楼阁。一切皆宝庄严者。以禅体遍周。万行圆满。所得果报生也。若有闻法得见亲近。无不获益。离贪欲际。广如经说。宅居市北者。以表北方为玄武。主奸邪盗贼。夜暗之所也。以菩萨常处无明长夜生死市廛。以接迷流。令归正见故。行贪欲方便化迷。善财问修何福业。得如是自在。其女答言。过去有佛。名曰高行者。以此禅位体高胜。出过情念诸见故。佛号高行。城名妙门者。以定能发慧。故名妙门。彼佛入王城蹈彼门阃。其城一切悉皆震动者。以明定慧相应。一切烦恼悉皆破坏。其城忽然广博众宝庄严者。以禅体相应。心无内外。量等虚空。名为广博。无亏定体。入廛同事。以接众生。获得报化庄严。不离禅定自在故。我为长者妻者。以禅定为夫。慈悲心为妻也。以明不失禅心。大悲随俗不污也。以将一宝钱。供养彼佛者。世中流通可贵。莫过宝钱。于世间圣道流通者。莫过于智慧也。文殊师利为佛侍者。是根本智之妙慧也。以此根本智为定体。出生妙慧为侍人。教化众生。发菩提心。是菩萨自在故。以明不坏禅心。而能随俗。表菩萨大智大慈悲为禅体。处生死廛肆。垢净不能滞其禅。喧诤不能留其性。从我唯知此离贪欲际解脱门已下。是推德升进

第六随顺坚固回向。以般若波罗蜜为主。余九为伴。南义如前。有城名善度者。以明此第六位般若波罗蜜智悲以成。善度群品故。城名善度。有居士。名鞞瑟胝罗者。此云包摄。以表此位智慧无边。包含万德。救摄一切众生。常供养栴檀座佛塔。以明栴檀是香树。能止蛇之热毒。以此居士常坐智慧解脱之香座。能消一切众生之热恼。塔者佛形像之所居。此塔唯置栴檀座。座上不置形像者。以明坐空慧之座。以为佛塔。以明空慧是佛不灭解脱门也。开栴檀座塔。即得三昧。名佛种无尽者。以明无作空智慧现前。是佛种无尽。亦是普见三世诸佛。亦是佛不灭度门。以此无作空智慧法。无有生灭故。恒用而常寂静故。一切诸佛共同有故。能坏生死。神用自在故。如空中响应系成故。十方普应。无去无来。是故居士供养栴檀座佛塔。得佛不灭度法门。以空智慧为座体。来观栴檀座佛塔中无形像。即是佛不灭度故。以明空智是佛故。无有灭度也。但来观塔。即得道而去故。城名善度。从我唯得此菩萨不涅槃际解脱门已下。是推德升进

第七等一切众生回向者。以明凡五位之中。第七皆以第六空智慧法门。随顺一切众生。处于生死。成大慈悲行。故云随顺一切众生回向。以方便波罗蜜为主。余九为伴。南方义如前。有山名补怛洛迦者。此云小白华树山。其山多有小自华树。以表观世音菩萨。处大慈悲行。教化众生令使不作小非。不弃小善。纤微之善。皆悉行之。以大由小起故。以积微霜而坚冰至。聚微尘而山岳成。是以圣人诫小过。如大非至。行小善。而大善自成。但于一切法性自空虚。无微心可生。是非尽矣。是故观世音以慈悲行。居小白华树山表之。旧经云观自在者非理也。依新经为观世音者正也。以表大慈悲义。善财于此山西面岩谷之中见观世音。于金刚宝石上结跏趺坐。无量菩萨。皆坐宝石。在山西面。于岩谷之中。坐金刚宝石者。以表山西面及岩谷者。以明大悲菩萨。常处一切崄恶道中。行大慈悲行。以明山及西岩谷。并是诸恶趣。行大慈悲行。以明西为白虎。为金为秋杀。为凶害故。以大悲表于恶趣行慈悲。即有一切处东方。一切处西方。十方总尔。坐金刚宝石。不现众妙宫殿楼阁庄严者。以明坚固大悲。不舍恶趣一切众生。常于恶道对现种种身相。度脱众生。无退无动故。坐于金刚宝石。余菩萨所坐宝石皆然。以常于恶道潜形。同类利生。不现自报庄严之事。常为大众说慈悲经。为善财说大慈悲行解脱门。于一切处。恒以爱语利行同事。摄众生故。从我唯得此菩萨大悲行法门已下。是推德升进

第八真如相回向。以明此位智位增明。心境皆真也。以此真智回向。入生死不住真体。以愿波罗蜜为主。余九为伴。尔时东方有菩萨。名曰正趣。前之诸位皆云南方。此位何独言东方。以此十回向。回真入俗。成大慈悲行。此第七第八位。和会悲智之体。东方表智。以春生发明之首。西方表悲。以秋杀潜明之首。以表正趣是智。观音是悲。和会智悲。而无二体。举来处即从东方妙藏世界普胜生佛所来至此也。又举从彼佛所来时久近言。经不可说佛刹微尘数劫。一一念中。举不可说佛刹微尘数步。过不可说不可说世界微尘数佛刹。一一佛刹。皆遍入至其佛所。以供具而为供养。此诸供具。无上心所成。无作智所印。乃至下方一切众生前教化。广如经说。及善财见正趣菩萨。与观世音同会而见。以明观音正趣。会智悲一体。又表第七是悲增。第八智增。以明正趣得智体增明。返归悲位。是就观音同会而见。云从东方妙藏世界普胜生佛所而来。以明法身无身。无相妙慧。以为世界。自性清净普光明无作智海性。自遍周十方国刹。名为普胜生佛。以此根本普光明。智生差别智。一念遍周十方一切佛前。一切众生前。如应现身。供养诸佛。教化众生。一时普现十方。无有来去。论主颂曰。犹如于日月普现河海中。池沼众泉流。无不皆普现。其相无来去。光影悉遍周。影之与本质其性如虚空。众生业力起。业性无来去。本智亦如是。体相如虚空。光明照十方。普现众生水。教化十方众。及供养诸佛。亦无能作者。以智自在故。神用满十方。在神无有神。神功乃如是。如是大用神功遍周。及供养种种供具。经云。皆是无上心所成。无作法所印。以明无作智体。有无量功德福业而庄严故。大意此之观音正趣。和会智悲。无二门已后。直至第十回向。无量功德。不离第七回向中慈悲之门。以观世音是一切古今诸大悲之体。以明智悲广故。不离本也。乃至十地之样。不离观音。一切诸佛。不离其此。此先立样。后位仿之。从我唯得此菩萨普速疾行解脱门已下。是推德升进

第九无缚无著解脱回向。以力波罗蜜为主。余九为伴。南方有城。名堕罗钵底。此云有门。为此位是第九法师位。有大法门故。城名有门。其中有天神。名曰大天。善财见已顶礼致敬。申请大天。长舒四手。取四大海水。自洗其面。持诸金华。以散善财者。以明敬初发心。又长舒四手。以四摄法遍也。自洗其面。以清净智眼。用观众生。知根引接。为善财说云网法门。天者清净义。慈悲义。覆荫义。十方普含容养育众生义。以明覆荫如云普润。教设如网漉取众生故。是故天神出财宝如山。以施所乏。以五停心观。随器受法。以明修行者智会天然。用神妙道。出过情作。任智施为。包含博施。任真而用故。会大天神。以为胜友。此明根本智之无作本体。名号天神。一切法门。从此而出故。城名有门。从我唯知此云网法门已下。是推德升进

第十等法界回向。以智波罗蜜为主。余九为伴。此阎浮提有国者。以明等法界回向法遍周故。总言阎浮提。摩竭国菩提场中者。以表此修行至本菩提体故。有地神。其名安住者。前天神表根本清净之智。地神名安住。表智中慈悲之体。天神出天中宝藏。地神出地中宝藏。以明慈悲之中福德也。以利众生之福感也。天神是智之妙用。地神是智慈之恒寂。用而恒寂故。名安住不动。以天动地静以设名也。此两位明修行者于生死中修行。至寂用之本源也。乃至十地果。终不离此二法故。与后作样。令十地及等觉位中。悲智惯习成满。不移此二法为一法也。以天为覆。地为载。含养之道。不出于此。智悲圆满之法。是故取天地之像。像智慈覆载含养之法。故天地含养。由众生作业之化生。大道含养。由智悲之妙灵也。天地无私。而万物成。大道无私。而万神济。不为而成。而成十方大功。不作而作。而作遍周法界。是故安住地神。以足指案地。百千亿阿僧祇宝自然涌出。告善财言。今此宝藏随逐于汝。是汝往昔善根果报福力之所摄受。以明其神如地静。故地出众宝自严其神清也。如天大开宝藏。天清地静。神自彰焉。皆智悲合道。神不为而福德万物应也。以明修行者智合天。而天且清。悲合地柔和。而育含生。而神常静福德自明矣。是故地神以足指按地。即众宝涌现。以智终悲满任无功。而神用含养遍周。是以天地之间果报福力众宝感应。皆不从欲想有作业生也。无为无作智悲。任用满众生界。福感自彰。经云。我忆自从燃灯佛来。常随菩萨恭敬守护。观察菩萨所有心行者。言发心之首依他也。亦以根本普光明智为燃灯佛。是发心之首。过须弥山微尘劫。有劫名庄严。世界名月幢。佛号妙眼者。以自发心来所有迷障为尘劫。迷解得法清凉为月幢。妙慧现前为妙眼佛。妙慧无形。体性如空。不可破坏。含容众法。名之为藏。从我唯知此不可坏智慧藏法门已下。是推德升进。已上明十回向于生死之中智悲圆满一终讫。像天地之灵养而不穷。无怖其报。末后天地之神表之。向下九个夜天。一个瞿波女。以表十地长养大慈大悲。破生死无明之长夜。以夜天神表之。如下具明。已上十善知识。以明入生死海。不出不没。成就智悲。及一切智智令圆满。如海功多。若以生死海中。大智大慈悲渐渐任智无功。破长夜暗。周满十方。覆荫众生。任其神用。普周主治世法。如下十地位中诸夜天神等众是也。已下皆依十回向中法样。成满至于等觉位也

略释新华严经修行次第决疑论卷三之下略释新华严经修行次第决疑论卷四之上

        大唐北京李通玄撰

    十地位

此已下九个夜天神。一个瞿波女。是如来往古因中时为夫妻。至今道满。以为十地善知识。如下经自具有文。至位方明。此已下十地及等觉位各十善知识。总依十回向中行愿满。即是其法。等妙二位。普贤行成亦是回向法愿行满故。至十信心中所信之果。乃至十住心中所得根本普光明智。行之果成满也。前后一智故。但明生熟行不同。非谓智别

第一欢喜地。檀波罗蜜为主。余九为伴。此阎浮提摩竭提国。不言南方者。为此国是佛生之处。会其本体。以表其本智无方。明其圆智也。又十地之初。都含后等妙二位。已满来于中道节级智悲升进生起。此位智见愿行同欣修故。然后安立生熟次第。以起观行均亭。使出俗入缠。令智悲圆满。十地及等妙二觉果成。总由十信初十住初十行初十回向初十地初。皆是都含诸位。一时起其愿行。成后位故。若无初首。后何有法。而能行之。即初心方成后位。如层台百丈。功亏一籄之土。以无初因之果。后果不成。如种子种果。而方有因生。而后有果。不异初因果故。以此初地发心。都收后位。时之与智前后都该。分毫不异。然别开升进生熟后。初欢喜地创始发心。事同凡类。以檀波罗蜜为首。第二离垢地。以戒波罗蜜为首。方舍离妻子。舍家出家。修其戒体。净其所著。治欲界烦恼。第三发光地。修上色界无色界禅。治乐寂静烦恼。得出三界业现前。已上位出三界心多。第四焰慧地。修三十七道品观。观身受心法。于心境上。世间诸法转令明净。使其心境于三界中所有事业。令心无著。生如来家。第五难胜地。以其禅定治四圣谛上苦集二谛。世间烦恼。本自性清净。无非灭道。以明世谛即是解脱。即是第一义谛。以治声闻乘。及净土菩萨。畏苦取涅槃证。无智悲舍众生障。第六现前地。十二缘生观。观六根名色取境。名之为识。以观六根及名色。本来空无体性。无有内外中边等五见。便为智业。自在妙用神功。即成就无量智慧解脱神功。以除缘觉观十二因缘。以空为证。于解脱无有智慧。舍大悲障。起于无量智慧神通。教化众生。已上三位成就。世间中得出世间智慧。已上六波罗蜜。得出世间及世间中出世间解脱一终。第七远行地。入于生死。会融染净。成大慈悲。不舍世间众生界。成后无功智。渐令圆满。及如来妙觉位因此而成。除于生死中不自在障。令使如来十力四无碍辩大智大悲十力圆满皆自在故。恒处生死。不求别有出世故。第八不动地。无功智成。不离第七地所成。此地终是于生死中无功悲满。净智现前。如观音正趣同会而见。自此不知所进。要得诸佛加持力。令念本愿。兴悲利物。为净智广大。一念兴悲。下地菩萨功不可及。三加者。一如来现身。二摩顶。三语业言赞。七劝者。一劝修佛十力四无所畏十八不共法。二劝行精进不舍无生忍门。三劝愍念一切众生。四劝忆念本愿。饶益一切众生。五劝修诸佛身相国土果报。六劝学佛无量法门。七劝学无量众生差别业智。皆悉通达起悲智业。不令滞其无功智门。已前诸地贪修解脱。和会智悲。至此位。于生死海中调和解脱大智慈悲一终。已满方学佛解脱大用功能。是以三加七劝。令使升进不滞无功智中。第九善慧地。得无碍辩。入法师位中。四无碍法者。一法无碍智。二义无碍智。三词无碍智。四乐说无碍智。第十法云地。同佛位满。受如来职。坐一大莲华王座。量等百万亿三千大千世界。三乘至十地位。座量等一三千大千世界。此一乘中。十地道满。非但所坐百万三千大千华王之座。并有十三千大千世界微尘数莲华座。以为眷属。无量菩萨。各坐其余莲华之上。周匝围绕。如是等十地法。总在初地中。一时通学。以是义故。于此夜天身中。乃含一切众生境界。乃至身毛孔。总含星象日月。及众生境界。以此善知识所居。直言阎浮提国。不言南方。城名迦毗罗者。此云大体。以五印度中。此国友城都。含摄诸国。故名大体。亦名黄物城。以此地曾有黄头仙人所居以为名故。又于五印度中处中。含摄诸国。像中宫戊巳土圆遍。故云黄物城也。善财从城东门而入者。以明初入十地中初地。东者众生启发创明之智故。从城东门而入伫立。未久便见日出者。以明从十回向后观照进求。此地法门相应时名入城。会融此地之果。名伫立未久。前位障亡。此位智现。名为日出。又此位长入生死长夜。说法教化众生故名天神。乃见夜神在虚空。处宝楼阁。以明法空随大悲行。起无量智慧之门。报生其果也。坐香莲华藏师子之座者。为明十地等菩萨。长养大慈悲行故。以夜天神及莲华座以表之。香者以明根本智。具足戒定慧解脱。及知见五分法身香。成就长养大慈大悲行。以为座体。以像思之可见。此以九个夜天神。一个瞿波。总是女类。以明十地升进。以大悲为体首。以前十住十行十回向。皆以本清净智为先导。而以成大悲行。即比丘长者居士婆罗门优婆夷童女表之。此十地中。即以大慈悲为先导。即九个夜天神。纯是女类表之。皆以大慈悲为先首。以天表智自在。神表智之大用遍周。言夜者。表破一切众生生死长夜。十回向和会慈悲行。处生死长夜。十地长养慈悲行。是故以香莲华藏以为座体。以明坐一切众生生死海。而无染污。以莲华表之。神名婆珊婆演底。此云主当春生。亦明。能生众善。身真金色目发绀青。以明法身智身无垢。具行慈愍柔和之行。智慈同成已。行具所为报身。以智无垢目发绀青。以慈和悦谦柔离慢。报得身真金色。智悲合体成其身也。形貌端正。人所喜见。总在其中。众宝璎珞。以为严饰。璎珞是行。以严智身。身服朱衣。朱者赤色衣。是南方之色。南为日。以夜天能以慧日。破众生长夜暗故。首戴梵冠者。梵者净。智恒净故。一切星宿。炳然在体。是十方国土。身也。一一毛孔。皆现度无量众生。以智无限。身及毛孔所含。国土亦皆无限。所化众生亦皆无限。自余广意具在经文。所于十方刹海。随根对治。法门境界。及现身济苦无限。具如经说。不可具云。以初地都含佛果等妙二位。一时顿现。使进求有法。不滞一门。从我唯知此菩萨破一切众生暗法光明解脱门已下。推得升进

第二离垢地。戒波罗蜜为主。余九为伴。阎浮提摩竭提国菩提场内者。以法身根本智为戒体。还不离阎浮提。在菩提场内。有主夜神。名普德净光。是婆珊婆演底之师者。以明万行依本智起。故名为师。夜神名普德净光。以明净智如日。以为戒体。无方不照。名为普德。戒体无垢。名为净光。破生死长夜苦。名之为神。神者无色无形不为而应。万物遍周。一时普济。名之为神。故名普德净光。善财请法。夜神劝修十法。具在经文。夜神修四禅者。一大悲救护一切众生。一心不动修初禅。二息一切意业。摄一切众生。智力勇猛。喜心悦豫。修第二禅。三思惟一切众生自性清净。永离生死。修第三禅。四悉能息灭一切众生诸苦热恼。修第四禅。成就一切众生广多境界。具在经文。不可具言。此四种禅。以明随大悲行。教化一切众生。随根摄化。总是禅门。无非禅者。但净意业。智自分明。万境皆禅故。从我唯得此菩萨寂静禅定乐普游步解脱门。是推德升进。为此夜神在菩提场内。还以无相法身本智。以为戒体。以智起用。教化众生。总是禅故

第三发光地。以忍波罗蜜为主。余九为伴。去此不远于菩提场右边者。不远以明不离菩提根本智。而行万行大用故。以右大用故。又右为大慈悲体。以忍行恒卑。名之为右。有一夜神。名为喜目观察众生者。以忍行内严。慈悲法悦。目视无厌。所示知根。随时引接故须观察。善财见夜神。在于如来众会道场。坐宝莲华藏师子之座。入大势力普喜幢解脱门者。以明忍为众行之源故。在佛众会中。佛众会者。不离本智。行众行故。还以本智为忍体。以此在佛众会。会者众行也。以根本普光明智。从此十地中。作十度炼真金。喻渐渐明净。以此为华璎轮王宝冠等。不离金体。以明一切万行神用遍周。皆不离根本智。渐殊胜故。如此位夜天神。以入大势力普喜幢法门。大用境界。利众生。事业在身毛孔。一一毛孔。现化身云。无方不至。无刹不现。无众生前不有其身。说种种引接门。广在经说。不可具言。但从十地之中。皆以法界身。一一毛孔。含容刹海。或一一毛孔。出化身云。无方不至。但以得法久近住世广多。常居生死。化度群品。以为次第。表大慈悲深久。从初地婆珊婆演底夜神。从初发心得法已来。云经须弥山微尘数劫。此第三地从喜目观察众生。发心久近。云过于刹尘劫。以明升进。大慈悲久近深广。如第二地。不言发心久近者。以明得菩萨寂静禅。普游步解脱。无三世古今可说。以明禅体遍周故。以明在菩提场内。会根本智故。从我唯得此大势力普喜幢菩萨解脱已下。是推德升进

第四焰慧地。以精进波罗蜜为主。余九为伴。此会之中。有一夜神。名为普救众生妙德。但言此会中。不言东西南北者。以不离佛会忍门。而有精进之行。以于根本智中。而行精进行。以智无不周。行无不遍故。夜神名普救众生妙德。夜神放眉间光明。入善财顶。善财即得究竟清净轮三昧。得是三昧。悉见二神两处中间所有。一切地水火风。及等微细诸尘。及摩尼众宝。华香璎珞。一切庄严具。等微细诸尘中。各各皆见佛刹微尘数世界成坏。广如经说。以明四地菩萨。得生如来家。智境同佛。又以精进行。普摄普贤行门。入微细智得现。如因陀罗网。境界身遍周法界众生界。无不现前。随时化引。以大悲行。多劫多生。常在一切众生海中。普皆应现。如经云。出生普贤行愿力故。增广菩萨大悲海。故善财问得此解脱。其已久如。夜神言。善男子。是处难知。诸天世人二乘之所不能测也。何以故。是普贤菩萨行境界。住大悲者境界故。广如经说。不可具言。略叙行门次第。知有指归。趣求不谬。教文广多。不可具录。修行者各各自寻经文勿滞。初之少得。渐渐令心境广大。入普德之法门。夜神举发心久近。云往古过佛刹微尘数劫尔时有劫。名圆满清净。世界名毗卢遮那大威德。有须弥山微尘数如来。于中出现。以妙德夜神。所曾亲近恭敬。闻法之佛数。所得法门。行菩萨行之初始。当初发心。是轮王女。见普贤菩萨福智光明。破一切众生长夜生死。因兹发愿。愿如普贤。以此初因经今。是以作夜天。照众生迷暗。广如经说。以明大慈悲深厚举劫久远如然。若以本智刹那不移也。从我唯知此菩萨普现一切世间调伏众生解脱已下。是推德升进

第五难胜地。以禅波罗蜜为主。余九为伴。去此不远。有主夜神。名寂静音海者。以明第五禅体。遍周含法界故。言去此不远。还不离佛会。以根本智为禅体。为至此位。令其智体转更增明。以升进故。云去此不远。以不离旧智。而有增明也。故云不远。以禅体普含色声香味触俱净故。主夜神号寂静音海。坐摩尼光幢庄严华座者。摩尼此云离垢宝。光者明也。以明禅体本真。心境无垢。光明照耀。以为座体。幢者以明心境及一切法本无倾动。故以为禅门。名之为幢。百万莲华座者。处生死而无生死可染也。百万阿僧祇主夜神前后围绕者。万行圆满也。以明坐一切法自性无作动静禅。普印法界一切智禅。以无作大慈悲恒覆荫一切众生禅。善财问夜神发心久近。夜神言。经二佛刹微尘数劫。又生今贤劫中供养。从迦罗鸠孙驮佛。乃至尽未来际佛。悉皆亲近。乃至初发心时。清净光金庄严世界。今犹现在。以表禅体无古今三世。普印三世。供养诸佛。闻法行菩萨道。一时无前后际。不离白净智禅。前位一佛刹尘劫。以明修行远近。此位二佛刹微尘。以明大悲行行渐渐深广。令后学者仿之。善财以颂叹夜神德曰。不取内外法。无动无所碍。清净智慧眼。见佛神通力。身为正法藏。心是无碍智。既得智光照。复照诸群生。心习无边业。庄严诸世间。了世界是心。现身等众生。知世悉如梦。一切佛如影。诸法皆如响。令众无所著。为三世众生。念念是现身。而心无所住。十方遍说法。无边诸刹海。佛海众生海。悉是一尘中。此尊解脱力。从我唯知此念念出生广大喜庄严解脱门已下。是推德升进

第六现前地。以般若波罗蜜为主。余九为伴。此菩提场如来会中者。以明第六以智为菩提体。为智慧现前。以智慧能治无明。以成大智悲故。又以如来会不离智慧故。云此菩提场众会中。有主夜神。名守护一切城增长威力者。以明此正智慧善能守护一切心境无明恶贼。不令得入。以明心境体无无明恶贼。自然消灭。大智法王自然出现。故名守护一切城增长威力。善财见夜神。坐一切宝光明摩尼王师子之座。摩尼王此云离垢宝。以明第六地智慧现前。破烦恼令清净。自在如王。以为座体。故名一切宝光明摩尼王师子之座。以智慧光明。能破长夜执障。以设座名。无数夜神所共围绕者。众生圆满也。现一切众生色相身等。如是对现一切众生前。随类调伏。广如经说。问言发心久近。云经过于佛刹转微尘劫者。数法未详。此第六位明般若波罗蜜境界。所现化利。如经具言。不可具录。善财颂叹夜神德曰。已行广大妙慧海。已度无边诸有海。长寿无患。智藏身威德光明住此众。了达法性如虚空。普入三世皆无碍。念念攀缘一切境。心心永断诸分别。了达众生无有性。而于众生起大悲。自余广如下文具说。从我唯知此甚深自在妙音解脱已下。是推德升进

第七远行地。以方便波罗蜜为主。余九为伴。此佛会中者。以明此位以智慧解脱力。不离根本智妙慧。出超诸境界。无所染法门。以方便力。还归生死。超一切普贤大愿海。以是义故。云此佛会中。有一夜神。名开敷一切树华者。以明此第七地有行。有开发返还生死。同一切众生生死六道行。而无舍离一切众生。成后佛果。如来大智大慈悲行。总由此位起。随流生死道。不出其中。而成大智悲海故。若无此地返还生死。同行摄生。但得六波罗蜜。出生死道。舍其后位。佛十力大悲总无。以此夜神名开敷一切树华。覆阴开发一切众生行。遍在此位故。是故六十童女宝光明为首。因依一切法音圆满盖王所。发菩提心。以明六波罗蜜出世智慧。回入生死。大慈悲心故。名六十童女。王者今毗卢遮那佛是也。以明不离根本智。修六度行。还以六波罗蜜出世之道。回入生死。长养慈悲。便于生死海。成一切智悲之海。六波罗蜜各具十。故云六十。前以出世心多。此位回入慈悲。故名童女。发心却还生死。身含法界。一切星象。炳然在身。广如经说。言发心久近。云经世界海微尘劫。此有二义。一明大慈深广。二表法。以明回前六波罗蜜出世心多障。于生死成大悲心。有尔许尘障。今已回之。故云六十童女。十住之中第七位。以休舍优婆夷表之。此十地第七。以六十童女表之。十住有染习犹存。此位虽与一切众生同行。心无染习。以童女回心表之。以明升进渐胜。童女者今开敷树华夜神是也。表七地却还生死。成大智悲行。同一切凡夫。开敷众生。悉同尘行。方便利生。皆同安乐故。名开敷一切树华。从我唯知此菩萨出生广大喜光明解脱门已下。是推德升进。以明此位菩萨恒居苦流生死。利益无限众生。是菩萨广大喜。恒入法界虚空界。尘尘中无限身一时恒济故无休息也。是菩萨广大喜故

第八不动地。以愿波罗蜜为主。余九为伴。此道场中。有一夜神。名大愿精进力救护一切众生。此道场中者。以明无功智成。不离本智。与本智体会故。名道场中。以根本智体如虚空。性自无垢。若心会者。一切诸系烦恼总无。以此智善治诸惑故。号道场中。有一夜神。名大愿精进力救护一切众生者。以明八地无功智成。念其本愿。兴悲利生。无有尽极。因行立名也。善财见夜神在大众中者。不离本智。行普贤满法界众生界行。是在众中。坐普贤一切宫殿摩尼藏师子之座者。以此位修行。会根本普光明智为座体。以根本普光明智自体。无性无相。性自光明。量同法界虚空界无边。无表里大小等量。普能含纳一切境界。总在其中。而同其体。以为座体。以普现法界国土摩尼宝网。罗覆其上者。以明会根本智。一切随方。国刹教化一切众生。所有教网。皆从根本智现差别智。设无边教网漉众生。而成报果故。大意明从初发心已来。会根本智。至此位功高智净。行博教多悲宽。益广报无尽也。夜神现日月星宿影像身。现随众生心普令得见身。现等一切众生形相身。现无边广大色相海身。如是广如经说。善财见已一心顶礼。举身投地。良久乃起。合掌瞻仰者。地是物中之卑。以知识道真智朗。卑己敬之。除我慢之极也。合掌者契会也。瞻仰者智德可尊也善财问夜神言。发心久如。初以智境答。后立时劫答。初智境答者。经云。一切法自性。等入于诸法。真实之性证无依法。舍离世间。悉知诸法色相差别。亦能了达青黄赤白性。皆不实无有差别。乃至我入此解脱。了知法性无差别。而能示现无量色身。意明。智体与三世体齐。虽大用神化遍周。无初得法之时可说。经中亦作日在空中。无时劫喻等。亦作幻人住世教化喻。后方立时者。经云。乃往古世过世界海微尘数劫。初名善光。以为劫初。为胜光王。太子名为善光伏。是初心之因。举此为初发之心及时劫。其太子具二十八相。以明九地十地四重因果未及。不具三十二相。在此身以救地狱罪。发慈悲心。至如今。作夜天神。以表此位无功智中。念本愿力。而行悲行。此位法合诸佛。三加七劝法如前。第八地中具文已释。从我唯知此教化众生善根解脱已下。是推德升进。第九善慧地。以力波罗蜜为主。余九为伴。此阎浮提有园林。名岚毗尼林者。以明此园是如来所生园。不云国邑。都举一阎浮提之境界。是如来降神受生诞生摄化之境。然后次三千大千百亿阎浮提。乃至十方一切刹海。乃至以刹海尘中微细境界。皆有摩耶夫人坐此园林。如来受生诞化一时同现。是故都言此阎浮提也。岚毗尼林者。此云乐胜光园。以如来欲降神时。十方一切诸佛。悉放脐中光明。来照此园。及照摩耶身。又此园林及地。常有光明。时诸天龙神八部。常作乐音。而为供养。又此园林。常有众宝庄严香华妙事。见者悦乐故。为乐胜光园。亦名无忧园。善财见妙德神。在一切宝庄严阁中。坐宝莲华师子之座。以神所居表神智德。重重行门。普虚楼阁。以众宝树妙庄严。坐莲华座者。以表如来受生及诞生。是化众生行故。坐莲华座表之。二十亿那由他诸天恭敬围绕。为说菩萨受生经。以明智悲行满故。以明此位智悲行圆。示现受生诞生。十地即受如来职位。便坐众宝庄严莲华座。量等百万三千大千世界。眷属菩萨有十三千大千世界微尘数。各坐莲华座。周遍十方。是故九地行圆。十地果满。经云。菩萨有十种受生藏。如经广明。如妙德神云。经百年。世尊果从兜率天。而来生此者。以从八地处兜率天。至九地降神。诞生以为百年。一地中修一波罗蜜行。一波罗蜜中。有百波罗蜜行满。故来生此园。以一十百。总是大数之本。以表万行圆满。即受生也。以十地之果。以八地无功之智。任运成故。如来欲受生时。园中有十种相。具如经文。摩耶夫人腹中。及身毛孔。普现十方国刹。及世界海。一切尘中。一时普现菩萨受生自在。广如经说。如菩萨欲诞生时。摩耶夫人前。忽然从金刚际出大莲华。名一切宝庄严藏。金刚为茎。众宝为须。如意宝王而为其台。有十佛刹微尘数叶。一切皆摩尼所成。自余庄严具如经说。此是如来初诞生第十相。以明如来福智所感。十方一切诸佛。放脐中光明。名菩萨受生自在灯者。以明脐中是受生之始。脐向上长头身。脐向下长腰脚。向上是阳。向下是阴。如树巢。向上生茎干。向下生根须。以脐是受生之始故。十方诸佛。放脐中光明。名菩萨受生自在灯。毕洛叉树。此云高显。为如来在此树下生。此树枝干庄严殊胜高显故。善财问得法久近云。往古过亿佛刹微尘数劫。复过是数。时有世界。名为普贤悦乐。八十那由他佛于中出现。第一佛于宝焰眼王夫人号喜光。于彼示现之时。妙德神以为佛乳母。从是以来念念。常见毗卢遮那佛示现。菩萨受生海。十方世界。及一切尘中。菩萨受生自在。亦恭敬供养承事。听所说法。从我唯知此菩萨于无量劫遍一切处示现受生周遍供养自在解脱已下。推德升进。论主以偈赞菩萨受生自在法行。颂曰。普光智体如虚空。无有中边大小量。蠢动含识皆同体。无自无他性平等。以本愿力慈悲心。方便现生名为父。或现莲华中化生。或以慈悲幻生母。如是念念满十方。对现色身如云布。一切刹尘普现身。随根影现无来去。智体本性无形色。无住无依无有处。一念普现色身云。各各不同非念虑。无功大智恒自在。十方诞生无挂碍。无像法中现妙像。引接迷流达虚妄。善达心境非一二。亦达诸像亦无像。一尘境界智幻生。智体如空幻皆寂。若了智境无体性。作与不作本无迹。菩萨以是得其源。常如万法绝攀缘。非是心缘彼诸境。只为无功智印然。无功大智满虚空。受生诞化总其中。一念遍含三世法。时日本来无始终。以智本无大小量。以是化彻微尘中

略释新华严经修行次第决疑论卷四之上略释新华严经修行次第决疑论卷四之下

        大唐北京李通玄撰

第十法云地。以智波罗蜜为主。余九为伴。此迦毗罗城。有释种女。名曰瞿波者。以明十地行。不离本处。与初地同处。以表菩提体无先后。始终不移。故云迦毗罗城有释氏女。瞿波者。乃是如来往古为太子时妻。是过百佛刹微尘劫有王。名智山。王有太子。名善光。有居士女。名净日。善光太子出家为比丘。于净德林中住。入城乞食。净日女见善光比丘。因生染爱。便解身璎珞并珠。置其钵中。便即发菩提心。于二百五十劫。不复堕三恶道。常生胜乐处。常见善光比丘。经二百五十劫。后生于善现家。莲华化生。见财主王。有太子。名威德。太子纳为妻。因此之后。常共太子供养诸佛。乃至闻法得道。迄至如来。为太子时。还为其妻。是往昔本愿因缘常为其妻。依古德云。如来为太子时。有三夫人。一罗睺罗母。耶输陀罗。作比丘尼。二名瞿波。作善财十地善知识。三名摩奴舍。未详所在。夫如来神智性同虚空。非物像能与其类。如其智体。非情想能得其迹。但以无形质之妙灵。而十方随根。普应对上根之类。莲华出现。应中下之流。母胎诞生。只为本愿慈善力故。于十方世界。随物现形。岂有存妻子。而居世间也。但为化凡引俗。示生人间。八万四千尘心迷皆同行。化妻幻子。化幻众生。示现处缠。难舍能舍。对三乘之种。舍诸饰好。应一乘佛果之门。即具华冠璎珞九十七种大人之相。及十华藏世界微尘等相。今以瞿波女。以表一乘智境。无别求出世。全以根本智。普印世间。万境全真。更不说他方别有净土。便以瞿波女用。同真性无取舍法。便将表法。便明十地道满。法喜为妻也。一切境界。总是法乐。是故法华会三归一乘。故说世间相常住。是法住法位。全将世间。以为解脱。无别欣厌也。又此经集会人间众。但有五百优婆塞。五百优婆夷。五百童子。五百童女。一万诸龙。但集世间俗众。无比丘出世众。如来是福智大慈悲圆满之行。世间无厌形相也。今以瞿波女。表十地法悦。无取舍法。是故净名经云。法喜以为妻。慈悲心为女。善财至菩萨集会普现法界普光明法堂者。至十转法轮智满故。此是初会菩提场所契会普光明智。亦是第二会普光殿。从第二会自起信进修行。至此十地。自以智慧道满。同诸佛法轮之智慧。以此为终。故号菩萨集会普现法界普光明讲堂。其中有主宫殿神。名无忧德。并一万守宫殿神。来迎善财。赞叹善财所修行善根。是入十地之因。见瞿波女。是十地之果。一万守宫殿神。是守护十地智悲之行。瞿波女曾供养无数诸佛。久远劫来承事毗卢遮那。自身位登十地。犹言未了菩萨身及身业。亦不知心智。诸劫所行之道。以未入等觉位普贤行门。至十地道满。须舍见道烦恼。禅三昧上烦恼。涅槃清净乐上烦恼。总舍恒入世间。一切众生前对现色身。教化利乐。是恒常之道。更无欣进出世三昧涅槃解脱。习气之心。以是如经中十地行满。以无量三昧推求普贤。了不能见佛。劝令以想念求觅。方见普贤在十方一切佛所。或来或去。以是瞿波立样。以成后学令知轨则。修行不惑。从我唯得此观察菩萨三昧海解脱已下。是推德升进

已上十地善知识竟。十一地等觉位普贤行如下。从前十住初心至十住满。师子幢王女。且得一分世间出世间智慈圆满。从十行初至十行满。出家外道名为遍行。且得一分随行行上。不坏出家无染解脱。从十回向初至十回向满。见天地之神。以于世间生死智悲之行含养自在。从十地初至十地满。见瞿波女。于菩萨集会普现法界讲堂。及无忧德神。及一万守宫殿神。以十地道齐诸佛智慧。转法轮中。智慈自在。从十一地等觉位普贤菩萨行门。初摩耶夫人至十一地满。见德生童子有德童女。以恒往十方生死六道。入幻住门。是等觉位之功终。文殊师利弥勒如来普贤菩萨三人。总通是五位及十信位中一理智妙行之体用法界之门。从初发心来至五位满。皆不离此三法。文殊是三空解脱之妙慧。妙简正邪之理。弥勒如来寄同此教。一生至佛果故。是根本普光明智。普贤是根本普光明智中差别智利众生行门。三法是一体用之门。即于诸法而能自在。此之三法成此一部经之教体。故名一乘圆教也。从十信心修行至五位未终。常以文殊师利为拣择引导之首。普贤为伴。至入法界之果门。即普贤为首。文殊为伴。根本智常为此二法无染之体。若根本智未明。籍妙慧观照显发。若根本智明。即妙慧是根本智妙使。普贤是根本智中万行之体。总是一法理智大悲体用分三。若不如是合离分张。修行者不知有智悲体用通塞自在。文殊师利出善住楼阁。南行化利人间。启发童蒙故。名文殊师利童子。菩萨以化童蒙。见道智因行立名。是故未见道时。由慧显得本智。见道之后。慧为佛之使也。观察取意可知。总是理智体用互参

等觉位初以檀波罗蜜为主。余九为伴。此世界中。有佛母摩耶者。此位能以处生死中。大慈悲心普含摄一切世间之境界。不分内外。东西南北直言此世界中也。佛母者。如来以大慈悲心为母体。能发大智慧。教化众生故。实无如世间父母所生。为大慈大悲不违初发心。本愿力化众生故。宜应所见。以其自智。幻作父母。化作妻子。或现莲华化生。种种生法。同众生行。宜应化现。总是如来一智之境。随宜幻生。何得有父母诞生入胎出胎去住之相。望其自智。以智体神妙。无色无形。无迹无垢。自体清净。及随本愿。大慈悲力有依正二报功德。福智庄严。如光影像。不可提摩。隐现自在。如慈氏楼阁。如华藏世界是也。共一切众生。同住各不相碍身为正报。国土为依报。亦依正二报互相参入。如帝释宝网光影相参重重无尽。如是摩耶夫人。如来眷属。总是同一切根本之智幻化所生。以接童蒙故。以大慈悲为母。幻生佛故。如十住之末。从智生慈悲。即师子幢王女。名曰慈行。此等觉位即慈悲生智。即以母生佛。升进次第如然。善财叹。摩耶夫人身。是超六处。离一切着智。无碍道具清净法身。以如幻业而现化身。以如幻智而现世间。以如幻影而持佛法身。乃至无依处身。广如经说。善财先见主城神。名宝眼。眷属圆满者。是悲中之智眼。引接众生故。先见也。以杂色宝华散善财者。以明入大慈悲行。非一种行。行无量种种行。是以众色宝华而散善财。又劝善财二十八种守护心城法门。意令修行大慈悲。处生死行。广大无限。于生死行中。不贪境界。但欲成就如来十力。广如经说。意明欲入生死。成大悲行。不舍智业。本清净法大悲圆满。普周世间。谓和无二。不令有滞。此二十八种守护心城法。是和智悲。成普贤入生广大行门。令不染不离。是入生死。成大慈悲。前方便故。是故先见宝眼主城神也。又云。佛子。菩萨摩诃萨。若能如是修心城。则能积集一切善法。何以故。蠲除一切诸障故。所谓见佛障。闻法障。供养如来障。摄诸众生障。净佛国土障。此有五种障。皆是有所欣求功德善法。惧生死心。非是真入无作任运大慈悲者。故今欲见此位善知识者。常除如是等五障之心。不用功力。则便得见。以明十地道满。入等觉位。普贤大慈悲。处世间众生海。当除此五障。方得见摩耶之身。此乃是不求出世。不求功德。不求见佛。不求闻法。纯以无作大慈悲。一往同一切众生生死流。教化利物。无有身心所求果报。及惧生死。尔时有身众神。名莲华法德。及妙华光明无量诸神前后围绕。从道场出。住虚空中。以妙音声种种称叹。是处生死海。住法空。无染之行满。摩耶夫人。从耳珰放无量色光明网。普照无边诸佛世界。令善财见十方无边国土一切诸佛。其光明网右绕世间。经一匝还来。入善财顶。乃至遍入身诸毛孔。善财即得净明眼。永离一切愚痴暗。故得离翳眼。能了一切众生性故。广如经说。何故耳珰放光。以六根之中意根。以成智业。余五根中耳根。随用为胜。以表大慈悲救苦海。以遍法界之众生界。闻声即救。不待见身。且取耳能远闻过余四故。且如雷震百里耳根得闻。若有大声千里亦闻。四根不及。以表慈悲之光耳根为体。光照诸佛国土。次照世间。以慈悲之光。照佛国众生国一体无二。从善财顶入。然后遍入身。及毛孔皆遍者。以明大慈悲光普周。高卑等入。体同一性。大智光明眉间起。受生光明脐轮起。大慈悲光摩耶耳珰起。四十心光手中起。十信光足下千辐轮中起。十住光足指端起。十行光足趺上起。十回向光膝上起。十住中第六住海幢比丘眼中放日轮光。照恶道苦。善财蒙光入身。能了一切众生性者。以同体大悲。能了一切众生性故。次见守护菩萨堂罗刹鬼王。名曰善眼。与其眷属一万罗刹俱。于虚空中。以众妙华。散善财上。明罗刹是女。住在大海之中。有大势力。能食啖众生。而得自在。亦能游空。以明菩萨以法空大智。常居生死海。守护一切众生。而无舍离。以为宫殿。而能餐啖一切众生无明贪嗔痴爱热恼血肉故。以罗刹王表之。取此居大海中。力用残害速疾为像也。散众华于善财上者。以大慈悲是行故。是故散华也。劝叹善财。令入大慈悲之行。广如经说。罗刹王为善财说求善知识法。善男子。汝应顶礼十方。求善知识。正念思惟一切境界。求善知识。勇猛自在。遍游十方。求善知识。乃至观身观心。如幻如梦如影。求善知识。善财受行其教。即时睹见大宝莲华从地踊出。所有庄严广如经说。以明大慈悲为地。大慈悲行为莲华。能起大慈悲心。为摩耶夫人身。诞生诸佛。以明从悲起智。以明万事皆是大智大慈悲。幻生诸法。度脱众生。是如幻智中。幻生自在无碍。方如大智大慈悲功终不可得。智净如空。守空而住。不可但随悲逐行。迷彼智门。皆须圆备。如主城神。一度和会慈智之行。身众神及摩耶耳珰放光。一度和会智悲之体用。罗刹王一度和会智悲之体。如是三度劝发和会。观行次第因缘成竟。方始莲华从地踊出。具众宝庄严。摩耶居中而坐。坐于众妙宝座。一切诸庄严中。起化庄严。及摩耶夫人。出化身云。遍周十方。成就一切众生。广如经说。乃至善财等摩耶所化。总现其前。亦广如经说。如摩耶夫人。身相如本。乃能容受十佛刹微尘数菩萨众海。八万诸龙等众。悉在腹中。菩萨于腹中受生时。于摩耶夫人腹中游行自在。一步过三千大千世界。一一步皆悉如是。乃至一切行普贤行。普贤行者。受生菩萨教化众生。悉在其中。故知。只是诸佛大慈悲母体也。如经所说。不可具言。善财问摩耶得法久近。云。乃往古世过不可思议非最后身菩萨神通道眼所知劫数。是得法久近。从我唯知此菩萨大愿智幻解脱门已下。是推德升进

第二戒波罗蜜为主。余九为伴。善知识。于此世界三十三天有王。名正念。此是前十住中正念天子。其王有女。名天主光。以明此位以慈悲为戒体。以天主是智。女是慈悲。以此位智悲圆满为戒体。名天主光者。天为净也。主者入生死中。主持教法。以利众生。光者虽处生死尘劳。大悲同行。摄取众生。同缠不污。戒光具足。名天主光。得无碍念清净庄严解脱门

第三忍波罗蜜为主。余九为伴。迦毗罗城。有童子师。名为遍友。善财请法。便指此城中有童子。名善知众艺。此两位善知识。共成主伴。以例儒门。如此孔丘颜回是也。以教童蒙故。一名童子。说四十二字母。具在经说。说四十二字母时。以四十二般若波罗蜜为首。入无量无数般若波罗蜜门。善知众艺菩萨解脱门是也

第四精进波罗蜜为主。余九为伴

第五禅波罗蜜为主。余九为伴。此摩竭提国有一聚落。彼中有城。名婆怛那。有优婆夷。号曰贤胜。此城在南印度。此名喜增益。得无依处道场。说随六处中。各得无尽智性。于世间出世间法。无不了知。阴阳五行医方众艺。无不博达。以随用为禅体

第六般若波罗蜜为主。余九为伴。南方有城。名为沃田。彼有长者。名为坚固解脱。得法门名菩萨无著念清净庄严者。以智慧体本无所著。以一切心境悉皆无故。名为清净。妙慧能生众生善根。故城名沃田。以智慧能破无明故。长者名坚固

第七方便波罗蜜为主。余九为伴。即此城有长者。名为妙月。以第六智慧。即不异方便波罗蜜故。以智慧能净烦恼故。名为妙月。虽以方便行。入于生死。恒以净智相应故。宅有光明。得智光明法门

第八愿波罗蜜为主。余九为伴。南方有城。名出生。以明无功妙智现前。以本愿力大慈悲行故。城名出生。有长者。名无胜军。以无功之智。善破异道。无能胜者。故名无胜军。得无尽相法门者。以无功之智。量同虚空。于一切世界。常现等众生。无量身相。而无不济度众生故

第九力波罗蜜为主。余九为伴。此城南有一聚落。名为法者。此是法师位。以将一切世间万境。总为法聚落故。有婆罗门。名最寂静者。以表万法心境总寂静故。一切方无不寂静。婆罗门者是寂静故。表世无法不静故。得诚愿语解脱者。以明出言。诚谛的无虚谬。皆称众生念愿所求故。以诚愿语。又自所出言。更不移改。皆堪为法

第十智波罗蜜为主。余九为伴。南方有城。名妙意华门。以明此位妙行圆满。智悲行圆。随十方一切众生意。皆为现身。一时普遍故。童子名德生。表智。童女名有德。表慈悲。以此位智悲二行已满。将一男一女。共成一位而像之。又以十方恒处。一切同行随流。摄生利物。以智悲无染习故。以童子童女像之。然实要须小男小女。佛行如之。又表诸人行行。常具慈悲柔和谦顺。无自憍慢故。以小男小女表之。于一切国。恒以智幻生种种身。行种种行。起种种色相。化种种众生。无古无今。无终无始。常无断绝。如化人出生。如幻人住世化幻众生。寻常等遍故。得如幻住门。以智幻生。住幻住法。无心意识。化利众生

已下五十个善知识。五位行满。如海岸国弥勒如来。是根本智圆三世。在楼阁中。却指善财。令见初知识文殊师利。以明至果不离于因也。时不迁智不异故。便闻普贤菩萨名。乃至菩提道场金刚藏莲华座前。起愿自见其身。等普贤身。普贤摩善财顶。总是一生修行。五位行满。不离初发菩提心。根本普光明金刚智无相法身。成满普贤无边妙行。时不迁智不异处不移。犹如梦人不离一处一时一身一心。而梦见作种种岁月时日。游行种种国土。作种种事业。而忽惺觉。不离本一时之间作梦也。以明根本智。观一切世间万法境界。如梦以觉者。万事不迁不移。如光如影。如幻人住世。无心无体。不延不促。一切处文殊师利同声颂云。一念普观无量劫。无去无来亦无住。如是了知三世事。超诸方便成十力。以文殊师利明无相法身空慧。佛是根本普光明智。普贤是根本智中差别智万行也。以此三法是一法体用。圆满之门成。五位中五十重因果始终。为一体用周遍门。皆以十波罗蜜为行体。一中具十。十中具百。五位之中随升进。处不同。五位中有五百波罗蜜。五位中五十个善知识。一一中皆有因有果。五十重因果共有一百。不离本十波罗蜜行。为一十。总一百一十重因果。总以十波罗蜜为行体。文殊及佛根本智。普贤差别智。以为大体修行。仿之不失其大道。永决疑网。不错修行。犹如大路善置牌牓。令行者除疑故。此等觉位中。普贤行位。同世人士。不全现异相。以引凡流故。得道之后。常在十方生死。以智幻生其身。任众生感见不同。恒化利故。住幻住门。无出没故。以神智妙用。遍周恒无作故。以如响智应物成音。无生住灭故。以如空智日。恒大光明普照十方。无中边故。以智境界。入十光影身。如天帝网重重影。像无去无来故。一如德生童子有德童女。智悲齐圆。处幻住门。以智幻生十方等众生量身。教化成就一切众生。同普贤道。无有休息也

略释新华严经修行次第决疑论卷四之下

    决疑论后记

太原府寿阳方山李长者造论所。昭化院记。元祐戊申七月。商英游五台山。中夜于秘魔岩金色光中。见文殊师利菩萨。慨悟时节。誓穷学佛。退而阅华严经义疏。汗漫罔知统类。九月出按寿阳。闻县东三十五里。有方山昭化院。乃长者造论之所。斋戒往谒焉。至则于破屋之下散帙之间。得华严修行决疑论四卷。疾读数纸。疑情顿释。因诘主僧曰。圣贤游止之地。奚其破落如此耶。僧曰。长者坐亡于此山久矣。神之所游。缘之所赴。年谷常熟。而物不疵疠。此方之人。乃相与腥膻乎方山之鬼。莫吾长者之敬。院以此贫。吾惟古之使者。毁淫祀或多至数千所。即移县废鬼祠。置长者像。为民祈福。十月七日治地基。八日白圆光现于山南。于是父老叩头悲泪曰。不知长者之福吾土也。请并院新之。施心云起。不唱而和。主僧伻圆来告。太师曾公子宣闻其事。谓商英曰。子盍发明长者之意而记之。使学华严者益生大信。而知所宗。则长者放光。以累子也不虚矣。商英曰。蒙塞何足以知长者。虽然尝试以管窥之。夫华严之为教也。其佛与一乘菩萨之事乎。始终一念也。今昔一时也。因果一佛也。凡圣一性也。十方一刹也。三界一体也。正像末一法也。初中后一际也。当处现前。不涉情解。以十信为入佛之始。以十地为成佛之终。十住十行十回向十地十一地谓之五位。六位具十者。以十波罗蜜为之主也。凡五位之因果各五十。加本位之五因五果。为一百有十。所以成华严世界之佛刹善财童子之法门。华严世界一百一十而加一何也。一者佛之位。万法之因也。五位者所标之法也。善财者问法。而行之之人也。五十三胜友者。五十则五位也。三则文殊普贤弥勒也。此经也以毗卢遮那为根本智体。文殊为妙慧。普贤为万行。方其起信。而入五位也。则慧为体。行为用。及其行圆。而入法界也。则行为体。慧为用。体用互参。理事相彻。则无依无修。而佛果成矣。故归之于后佛弥勒。十信以色为国者。未离乎色尘也。十住以华为国者。理事开敷也。十行以慧为国者。定慧圆明也。十回向以妙为国者。妙用自在也。种种名号者。智体之异名也。观其名则知所修之行矣。种种庄严者。性行之依果也。观其果则知所行之因矣。大悲广济谓之海。除热清凉谓之月。普雨法雨谓之云。包含万象谓之藏。严其上首。谓之宝髻。因果同时。处世不染。谓之莲华。摧邪见正而不动。谓之幢。悲智中道谓之斋。性愿普薰谓之香。无为而成者天也。无方而应者神也。无外而大者王也。飞潜而雨者龙也。处生死海。而不没者修罗也。搏根熟众生。而至佛岸者。迦楼罗也。凡乎圣乎。疑而不可知者紧那罗也。胸行匍匐谦恭利物者。摩睺罗伽也。守护伺察者夜叉也。同乎恶趣。而灭其贫苦者。鸠槃荼也。法音娱乐者乾闼婆也。金为坚为刚。为黄为白。轮为圆为满。颇梨为莹彻。琉璃为明。净无垢谓之摩尼。漉沈拯溺谓之网。高显挺特谓之茎干。开敷覆荫谓之华叶。含育利生谓之宫殿。观照之根。谓之楼阁。无畏谓之师子。超尘谓之台榭。出俗谓之比丘。入廛谓之居士长者。同乎外道。谓之仙人婆罗门。慈而无染谓之女。以悲生智谓之母。此华严事相。表法之大旨也。至于一字含万法。而普遍一切。其汪洋浩博。非长者孰能判其教。抉其微乎。长者名通玄。或曰唐宗子。又曰沧州人。莫得而详。殆文殊普贤之幻有也。以开元七年。隐于方山土龛。造论。十八年三月二十八日卒。垒石葬于山北。至清泰中。村民拨石。得连珠金骨扣之如簧。以天福三年再造石塔。葬于山之东七里。今在孟县境上。说者以伏虎负经。神龙化泉。昼则天女给侍。夜则齿光代烛。示寂之日。飞走悲鸣。白气贯天。此皆圣贤之余事。感应之常理。传所谓修母致子近之矣。今皆略而不书焉。

年月日商英记


华严经探玄记

    No. 1733 [cf. No. 278]

华严经探玄记卷第一

        魏国西寺沙门法藏述

  归依大智海　　十身卢舍那
  充满诸法界　　无上大慈尊
  方广离垢法　　圆满解脱轮
  普贤文殊等　　海会大菩萨
  我在具缚地　　悕心大法门
  唯愿见加哀　　令增念智力
  开此秘奥藏　　广益于自他
  愿令法久住　　传灯报佛恩

夫以法性虚。空廓无涯而超视听。智慧大海深。无极而抗思议眇眇玄猷。名言罕寻其际。茫茫素范。相见靡究其源。但以机感万差。奋形言而充法界。心境一味。泯能所而归寂寥。体用无方。圆融叵测。于是无像现像。犹阳谷之升太阳。无言示言。若沧波之倾巨壑。是故创于莲华藏界。演无尽之玄纲。牢笼上达之流。控引令阶佛境。然后化沾忍土。渐布慈云。洒微泽以润三根。滋道牙而归一揆。是知机缘感异。圣应所以殊分。圣应虽殊不思议一也。华严经者。斯乃集海会之盛谈。照山王之极说。理智宏远。尽法界而亘真源。浩汗微言。等虚空而被尘国。于是无亏大小。潜巨刹以入毫端。未易鸿纤。融极微以周法界。故以因陀罗网参互影而重重。锭光玻黎照尘方而隐隐一即多而无碍。多即一而圆通。摄九世以入刹那。舒一念而该永劫。三生究竟坚固种。而为因。十信道圆普德显。而成果。果无异因之果。派五位以分镳。因无异果之因。总十身以齐致。是故觉母就机于东城。六千疏其十眼。童子询友于南国。百十圆成以一生。遂使不越树王六天斯届。讵移华藏。十刹虚融。示宝偈于尘中。齐辉八会。启王珠于性德。七处圆彰。浩浩铿鋐。隔思议而迥出。巍巍焕烂。超视听于聋盲。是故舍那创陶甄于海印。二七日旦爰兴。龙树终俯察于虬宫。六百年后方显。然即大以包含为义。方以轨范为功。广即体极用周。佛乃果圆觉满。华譬开敷万行。严喻饰兹本体。经即贯穿缝缀。能诠之教着焉。从法就人寄喻为目。故云大方广佛华严经。世间净眼品者。器等三种显曜于时。光洁照明况于净眼。法喻合举故云世间净眼。语言理一。格类相从。故称为品。此经有三十四品。此品建初故称第一。故言大方广佛华严经世间净眼品第一。余义如下说

将释此经略开十门　一明教起所由　二约藏部明所摄　三显立教差别　四简教所被机　五辨能诠教体　六明所诠宗趣　七具释经题目　八明部类传译　九辨文义分齐　十随文解释

初教起所由者。先总辨。后别显

总者。夫大教之兴因缘无量。故智论之初。广辨般若教起因缘。如须弥山不以无事及小因缘而能令动佛。亦如是。大因缘故而有所说。所谓般若波罗蜜。流行世间广益群品故也。法华亦云。如来为一大事因缘故出现于世。所谓开示悟入佛知见等。此经下云。如来应供等正觉性起正法不可思议。所以者何。非少因缘成等正觉出兴于世。以十种无量无数百千阿僧祇因缘。成等正觉出兴于世。何等为十。一者发无量菩提之心不舍一切众生。如是等乃至广说应知

次别显者。略提十义以明无尽。何者为十。谓由法尔故　愿力故　机感故　为本故　显德故　显位故　开发故　见闻故　成行故　得果故

初法尔故者。一切诸佛法尔皆于无尽世界。常转如此无尽法轮如大王路法尔常规。无停无息尽穷未来际。是故下文不思议品云。一切法界虚空等世界。悉以毛端周遍度量。一一毛端处于念念中。化不可说不可说佛刹微尘等身。乃至尽未来际劫。一一化佛身有不可说不可说佛刹微尘等头。一一头有不可说不可说佛刹微尘等舌。一一舌出不可说不可说佛刹微尘等音声。一一音声说不可说不可说佛刹微尘等修多罗。一一修多罗说不可说不可说佛刹微尘等法。一一法中说不可说不可说佛刹微尘等句身味身。复不可说不可说佛刹微尘等劫说异句身味身。音声充满法界一切众生无不闻者。尽一切未来际劫常转法轮。如来音声无异无断不可穷尽。解云。准此经文。于一毛端处于一念中出于如上业用。余念念中皆亦如是。如一毛端处如是念念业用无尽。余一一毛端次第周遍虚空法界等一切世界。各皆如是无尽无尽。此即处以毛端该于法界。时以刹那尽于劫海。谓于此处明顿起业用。谓于此时明常起业用。此亦不待因缘。诸佛法尔。此经下文所说皆尔。问若尔何故。处唯八会时局二七耶。答遮那品云。一一微尘中佛国海安住。佛云遍护念弥纶覆一切。又云。一毛孔中无量佛刹庄严清净旷然安住。彼一切处卢遮那佛于众海中演说正法。解云。况八会处而不该摄十方法界。又发心品云。知无量劫即一念一念即是无量劫。解云。况二七日时不摄无量劫海。不思议品云。一切诸佛于一微尘中普现三世一切佛刹。于一微尘中普现三世诸佛自在神力。于一微尘中普现三世一切众生。于一微尘中普现三世一切诸佛佛事。解云。此中尘内三世通括一切前后际劫。是谓诸佛法尔常说故也

二愿力故者。谓是如来本愿力故。令此教法称机显现。是故卢遮那品云。十方国土中一切世界海。佛愿力自在普现转法轮。又云。卢遮那佛神力故一切刹中转法轮。普贤菩萨愿音声。遍满一切世界海。解云。即是此经该于十方。虚空法界等一切世界及诸尘内诸刹土中。同时说此经者。皆是本师愿力所致。是故下诸会初皆云卢遮那佛本愿力故。又云集品颂云。无量无数劫此法甚难值。若有得闻者当知本愿力。解云。此即由佛愿力令众得闻。又云。如来不出世亦无有涅槃。以本大愿力显现自在法

三机感故者。如来平等无有改易。随应众生现身说法。此有三义。一以佛果色声清净功德为增上缘。应彼机感以成摄化。云集偈云。有眼有日光能见微细色。最胜神力故净心见诸佛(此现身也)。又法界品云。佛于过去行得一微妙音。无心于彼此而能应一切。(此说法也)二佛果无有色声粗相。但以平等理智增上愿力。机感相应有形言现。云集偈云。三世一切佛法身悉清净。随其所应化普现妙色身。又云。一切诸如来无有说佛法。随其所应化而为演说法。三通上二义有无无碍。以称法界无障碍故舍那品云。佛身充满诸法界。普现一切众生前。应受化器悉充满佛。故处此菩提树。一切佛刹微尘等尔所佛。坐一毛孔皆有无量菩萨众。各为具说普贤行。解云。正是此经所说分齐

四为本故者。谓将欲逐机渐施末教故。宜最初先示本法。明后依此方起末故。是故最初说此经法。然后方于鹿园等处渐说枝末小乘等法。又下性起品云。犹如日出先照高山等。如下立教中引说

五显德故者。谓显佛果殊胜之德。令诸菩萨信向证得。此有二种。一依果谓莲华藏庄严世界海。二正果谓如来十身通三世间等。并如下文说。此二无碍有四句。一依内现依。如尘内现刹海。二正内现正。如毛孔现佛等。三正内现依。如毛孔现刹等。四依内现正。如尘内现佛等。是故随举一门即摄一切。无不皆尽。并如下说。为显此果德故说是经

六显位故者。为显菩萨修行佛因。一道至果具五位故。此亦二种。一次第行布门。谓十信十解十行十回向十地满后。方至佛地。从微至着阶位渐次。二圆融相摄门。谓一位中即摄一切前后诸位。是故一一位满皆至佛地。此二无碍广如下文诸会所说

七开发故者。为欲开发众生心中如来之藏性起功德。令诸菩萨依此修学破无明[穀-禾+卵]显性德故。此亦有二种。一以言说显示。令知有故。二教其修行得显现故。如下文破微尘出经卷等。具如彼说

八见闻故者。示此无尽自在法门。唯是极位大菩萨境。而令下位诸众生等于此见闻。而得成彼金刚种子不毁不尽。要当令其至究竟位故也。亦如性起品说

九成行故者。谓为示此普法令诸菩萨成普贤行。一行即一切行。初发心时便成正觉。具足慧身不由他悟。又云。菩萨受持此法。少作方便。疾得阿耨多罗三藐三菩提等。此亦二种。一顿成多行。二遍成普行。并如下说

十得果故者。令得佛地智断果故。亦有二种。一断果谓除障故。即普贤品明一障一切障小相品明一断一切断。广如下说二智果谓成德故。具足十身尽三世间。逆顺自在依正无碍。如不思议品等说。此上略由显示如是十义令此经教兴起故也

第二藏部明摄者。略显十义以明收摄　一明三藏　二显所摄　三辨二藏　四释相违　五开种类　六定所摄　七一部收　八三部摄　九或九部　十具十二

初明三藏者

一名修多罗。或云修妒路。或云素呾囕。此云契经契有二义。谓契理故。合机故。经亦二义。谓贯穿法相故。摄持所化故。贯穿者。世亲释云。谓能贯穿。依故相故法故义故名素呾囕。谓于是处。由此为此而有所说。名之为依。真俗谛相名之为相。十善巧法等名之为法。随密意等以说诸法名之为义。又无性释为贯穿缝缀。解云。贯穿是契入义。缝缀是契合义。谓以圣言贯穿义理。令不散失令不隐没。缝缀连合。令成诠表令得久住。佛地论云。能贯能摄故名为经。以佛圣教贯穿摄持所应说义及所化生名为契经。契理之经依主释也。契经即藏持业释也。又杂心五义。一涌泉。二出主。三显示。四绳墨。五结鬘。正翻名线。何故称经。谓线能贯华经能持纬。义用相似。但以此方重于经名不贵线称。是故翻译逐其所重废线存经。从譬立名

二毗柰耶。此云调伏。调者和御。伏者制灭。调和控御身语等业。制伏除灭诸恶行故。此是所诠行。谓调伏之藏也。或翻名灭。灭有三义。一灭业非。二灭烦恼。三得灭果。或云尸罗。此名清凉。三业过非犹如火燃戒能息灭故云清凉。十诵律中名为性善。或云守信。如昔所受实能持故。或云波罗提木叉。此云随顺解脱。由持戒故顺至解脱。亦名别解脱

三名阿毗达摩藏达摩名法。阿毗有七义。一名对法。此有二义。一对向。谓因智趣向涅槃果故。二对观。谓果智观证涅槃灭故。虽因智亦有对观。然以仰进修故但名对向。世亲摄论云。此法对向无住涅槃能说诸谛菩提分等诸妙门故。此约因智说。此唯所诠。二名数法。梁摄论释云。诸法中随一法或以名相或以别相或以通相等。数数显此一法故名数法三名伏法者。彼论云。此法能伏诸说。立破二能。由正说依止等方便故。故名伏。四名通法。此能通释契经义故。契经称法。此法能通彼。即法之通。梁摄论名解法。由阿毗达摩修多罗义易解故也。五名无比法。六名大法。七名择法。此三唯约所诠。又顺正理云。或契经名为达摩论能决了名为对法。此即以教对教。同上通法。或云摩得勒伽。此云本母。以教与义。为本为母。亦名分别解脱。或云优波提舍。此云论义。杂集中名解释也。此契经等上三种。皆含摄所诠出生义理。俱名为藏。庄严论第四云。彼三及此二云何名藏。答由摄故。谓摄一切所应知义也。初藏通持业依主。后二藏唯依主。以从所诠为名故。余出体性及诸门分别。广如别说

第二显所摄者。此经何藏摄者。或唯契经摄。以非余二故。或二摄。以有决择义理对法收故。或三摄。下文亦显诸戒行故。此约同教辨。或是下文十藏所摄。以主伴具足显无尽故。此约别教。问三藏据教。十藏约义。如何以义而云摄教。答若小乘教义俱不融。三乘义融教不融。一乘教义俱融。是故得摄。如意言无分别观入教摄等。三乘中已有况一乘耶。但标召表示即属教摄。思之可见

第三约辩二藏者。谓声闻藏菩萨藏。初者约声闻小根。立三藏教诠示声闻理行果等为声闻藏。二约菩萨大根。立三藏教诠示菩萨所行等法为菩萨藏。庄严论第四云。此三藏由上下乘差别故。复说为声闻藏及菩萨藏

第四释相违者。问经中亦云。为求缘觉者说十二因缘。何故不名缘觉藏耶。答以诸缘觉亦唯断我执唯证生空果成罗汉入灭不殊。望于菩萨俱是下乘故不别说。问等俱是下。何故独名声闻藏。答以缘觉亦有出无佛世无教者故。声闻不尔故偏得名。问小乘教中亦有诠示菩萨乘法。何不亦名菩萨藏耶。答以彼宗菩萨所断所证所入涅槃亦与二乘无差别故。又以菩萨唯一不多故亦不说。问若尔何故。普超三昧经三藏品及入大乘论。说彼三乘即为三藏。一声闻藏。二缘觉藏。三菩萨藏。答彼经论中。皆云大乘之中有此三藏故。非谓小也。问即据此文缘觉有藏。与庄严论如何会释。答前据理果不异故合也。此约教行小别故分也。是故二说不相违也

第五开种类者。就声闻藏中。准诸经论曲开三种。一诤论声闻藏。谓契经四阿含。调伏五部。对法二十。互相违诤。所说不同。不妨圣果。是故总名为诤论藏。二称实声闻藏。谓如瑜伽声闻地及声闻决择诠示声闻行位果等。皆悉称实与理相应。不同婆娑及诸异论。以补处所说非诸异论所能诤故。是故总名称实声闻藏。问此中所说既与小乘诸部不同。岂声闻人有两种耶。答此约教中说声闻法尽理不尽故。开为二。非谓声闻亦有差别。三假立声闻藏。如大乘经中。为引声闻令回心故。所立法门亦同声闻名数而说。如无作四谛及道品等。如诸大乘经中说。不能繁引。既非菩萨所学。是故名为假立声闻藏。问此中名虽同小乘义实是大。何得总说为声闻藏。答只为此义名为假立。问诸声闻人根熟回心所学即是菩萨藏收。此假立藏于彼何用。答但声闻回心有二种。一胜二劣。胜者一往入大不藉此藏。劣犹怖大。是故方便同彼名数。令易信受故立此门

第二菩萨藏中。准诸圣教亦有三类。一小乘中菩萨藏。谓诠示菩萨依三十四心等次第成佛。亦不论于十地行位。仍复不同声闻等者是也。如婆娑俱舍说。二大乘共教中菩萨藏。谓诠示菩萨次第行位。虽说有回心直进不同。俱依十地行布渐次修至佛果。如瑜伽菩萨地及诸大乘经论中说。三不共教中菩萨藏。诠示菩萨依普贤行位五位圆融。谓一位即一切位。一行即一切行。圆极法界无碍自在。始终皆齐。一一位满即成十佛主伴具足等。故智论云。般若波罗蜜有二。一者共。谓此大品经及余方等经与诸声闻共说故。二者不共。谓不思议经不与声闻共说故。解云。此中共大之小非愚法。共小之大非别教。是故有三菩萨藏也。问菩萨声闻二藏别故。即彼二人各别得果。菩萨藏中既分三位。应三种菩萨各别成佛。答成佛唯一。但机有浅深。教说三类。匪谓成佛体实有三。今就教开不约佛体。问若三说俱称理。佛体亦成三。若成佛理是一。二说即为虚。答于一成佛通有三义。一以本从末门。如小乘说。以同声闻故。二开本异末门。如共教说。以与声闻相对辨异故。三末尽唯本门。如不共教说。二乘聋盲无对异故。佛体圆融具斯三义。是故三说各异佛无若干。是故今菩萨藏中有此三类

第六定所摄者。此经何藏摄者。俱非前三声闻藏摄。于后三种菩萨藏中正唯后摄。以智论中别指此经为不共故。或三类中唯除初一后二俱摄。以此经中具普别故。或亦通彼假立声闻藏收。以经中亦辨四谛等故。或亦总通二藏所收。以声闻藏法并依一乘法界所流味无别故

第七一部摄者。于十二部中或唯约方广一部所摄。对法论说一切有情利益安乐所依处故。宣说广大甚深法故。名为方广。又瑜伽说声闻藏中无方广故。或此经题目已显现故

第八三部摄者。谓记别。自说。方广。以法华中说余九部为小乘故。此经非彼故唯三摄

第九或九部摄者。谓除因缘。譬喻。论义。以涅槃第三说护大乘者受持九部。除前三故

第十具十二者。一是契经摄。以涅槃经说始从如是终至奉行是契经故。二应颂。如下文。具有重颂故。三记别。如下文。具有记成佛等故。四讽颂。如下文有直说颂等故。五自说。如下文从定起即说本分等六缘起。如下文因请说故。七譬喻。如下文广说喻故。八本事。如下说卢舍那等及普贤本所经本事故。九本生。如下说舍那等本生相故。十方广一门可知。十一希法。如下文毛孔说法及座出众宝柱现佛等。十二论义。如瑜伽八十一说。谓诸经典循环研核。摩怛理迦。一切了义经皆名摩怛理迦。谓于是处世尊自广分别法相等。如下文明难品等说。是故此经具有十二部摄也。余义如下十二部经处说。藏部摄竟

第三明立教差别者。略提十类　一叙古说　二辩是非　三述西域　四会相违　五明现传　六定权实　七显开合　八教前后　九就义分教　十以理开宗

初中。古来诸德立教多端。难以具显。略叙十家。以成龟镜

一后魏菩提留支立一音教。谓一切圣教唯是如来一圆音教。但随根异故分种种。如经一雨所润等。又经云。佛以一音演说法。众生随类各得解等

二陈朝真谛三藏等立渐顿二教。谓约渐悟机。大由小起。所设具有三乘之教。故名为渐。即涅槃等经。若约直往顿机。大不由小。所设唯是菩萨乘教。故名为顿。即华严等经。后大远法师等亦同此说

三后魏光统律师承习佛陀三藏立三种教。谓渐顿圆。光师释意一为根未熟。先说无常后乃说常。先空后不空等。如是渐次名为渐教。二为根熟之辈。于一法门具足演说一切佛法。谓常与无常空不空等。一切具说。更无由渐故名为顿。三为于上达分阶佛境之者。说于如来无碍解脱究竟果德圆极秘密自在法门故名为圆。即以此经是圆顿所摄。后光统门下遵统师等亦皆宗承同于此说

四齐朝大衍法师等立四宗教。一因缘宗。谓即小乘萨婆多等部。二假名宗。谓成实论及经部等说。三不真宗。谓诸部般若。说即空理明一切法不真实等。四真宗。谓华严涅槃。明法界真理佛性等故

五护身法师等立五宗教。谓此于前第四宗内。开真佛性以为真宗。即涅槃等经。第五名法界宗。即华严明法界自在无碍法门

六陈朝南岳思禅师智者禅师等立四教。一三藏教。亦名小乘教。如法华云不得亲近小乘三藏学者。智论中说小乘为三藏大乘名摩诃衍藏。二名通教。亦名渐教。谓大乘经中通说三乘通被三根等。又如大品中干惠等十地通三乘者是也。三名别教。亦名顿教。谓诸大乘经中所说法门道理不通小乘等者是也。四名圆教。亦名秘密教。谓法界自在具足圆满一即一切一切即一无碍法门。亦华严等是也

七唐朝海东新罗国元晓法师造此经疏。亦立四教。一三乘别教。谓如四谛教缘起经等。二三乘通教。谓如般若经深密经等。三一乘分教。如璎珞经及梵网等。四一乘满教。谓华严经普贤教。释此四别如彼疏中

八唐吉藏法师立三种教。为三法轮。一根本法轮。即华严经最初所说。二枝末法轮。即小乘等于后所说。三摄末归本法轮。即法华经四十年后说回三入一之教。具释如彼

九梁朝光宅寺云法师立四乘教。谓如法华中。临门三车即为三乘。四衢道中所授大白牛车即为第四乘。以临门牛车亦同羊鹿俱不得故。若不尔者长者宅内引诸子时。云此三车只在门外。诸子出宅即应得车。如何出已至本所指车所住处。而不得故后更索耶。故知是权同羊鹿也。以是大乘中权教方便说故。具释如彼法华疏中

十唐江南印法师敏法师等立二教。一释迦经。名屈曲教。以逐机性随计破着故。如涅槃等。二卢舍那经。名平道教。以逐法性自在说故。如华严等。彼师释此二教略有四别。一主异。谓彼释迦化身所说。此是舍那十身所说。二处异。谓彼说在娑婆世界木树草座。此说在于莲华藏世界宝树金座。三众异。彼与声闻及菩萨说。此唯菩萨极位同说。四说异。谓彼但是一方所说。此要该于十方同说。广释如彼华严疏中。第二辨是非者

此上十家立教诸德。并是当时法将英悟绝伦。如思禅师智者禅师等。神异感通迹参登位。灵山听法忆在于今。云法师依此开宗讲法华感天雨华等。并如僧传等所显。又此诸德岂夫好异。故分圣教。但以解该群典异轸呈根。言不得已。开宗别释。务令圣说各契其宜。问此上十说谁是谁非。答依成实论。佛说内外中间之言遂即入定时。有五百罗汉各释此言。佛出定后同问世尊。谁当佛意。佛言并非我意。诸人问佛。既不当佛意将无得罪。佛言虽非我意各顺正理。堪为圣教。有福无罪。况此诸说各有少多圣教为证。是故不可全非弃耳

第三述西域说者。真谛三轮。笈多四教。波颇五说。并如别说。又法藏于文明元年中。幸遇中天竺三藏法师地婆诃罗。唐言日照。于京西太原寺翻译经论。余亲于时乃问。西域诸德于一代圣教颇有分判权实以不。三藏说云。近代天竺那烂陀寺同时有二大德论师。一名戒贤。二称智光。并神解超伦。声高五印。群邪稽颡。异部归诚。大乘学人仰之如日月。独步天竺各一人而已。以所承宗别。立教不同。谓戒贤即远承弥勒无著。近踵护法难陀。依深密等经瑜伽等论立三种教。谓佛初鹿园说小乘法。虽说生空然犹未说法空真理。故非了义。即四阿含等经。第二时中虽依遍计所执自性说诸法空。然犹未说依他圆成唯识道理。故亦非了义。即诸部般若等教。第三时中方就大乘正理具说三性三无性等唯识二谛。方为了义。即解深密等经。又此三位各以三义释。一摄机。二说教。三显理。且初唯摄声闻。唯说小乘。唯显生空。二唯摄菩萨。唯说大乘。唯显二空。三普摄诸机。通说诸乘。具显空有。是故前二摄机教理各互有阙故。非了义。后一机无不摄教无不具理无不圆故。为了义

第二智光论师远承文殊龙树。近禀提婆清辩。依般若等经中观等论亦立三教。谓佛初鹿园为诸小根说小乘法。明心境俱有。第二时中为彼中根说法相大乘。明境空心有唯识道理。以根犹劣未能令入平等真空故作是说。于第三时为上根说无相大乘。辩心境俱空平等一味。为真了义。又此三位亦三义释。先摄机者。初时唯摄二乘人机。第二通摄大小二机。以此宗计一分二乘不向佛果。三唯摄菩萨。通于渐顿。以诸二乘悉向佛果无异路故。二约教者。初唯说小乘。次通三乘。后唯一乘。三约显理者。初破外道自性等故。说缘生法定是实有。次即渐破二乘缘生实有之执。说此缘生以为似有。以彼怖畏此真空故。犹存假有而接引之。后时方就究竟大乘说此缘生即是性空平等一味不碍二谛。是故法相大乘有所得等属第二教。非真了义。此三教次第如智光论师般若灯论释中。具引苏若那摩诃衍经说。此云大乘妙智经。此昔所未闻也

第四会相违者。问此二说既各圣教互为矛楯。未知为可和会为不可会耶。答无会无不会。初无会者。既并圣教。随缘益物何俟须会。即是智论四种悉檀中各各为人悉檀。亦是摄论四意趣中众生乐欲意趣。于一法中或赞或毁。是故二说不须强会。二无不会者。有二门。一约教应机。二约机领教。前中但佛教门了与不了有其四位。一约摄机宽狭。二约言教具阙。三约益物大小。四约显理浅深。初者若唯摄二乘不兼菩萨。或唯菩萨不兼二乘。各摄机狭故非了义。若宽摄三机周尽方了义。二者若唯说小不兼说大。或唯说大乘不兼小乘教。言各有阙故非了义。若言包大小具足三乘方为了义。深密经等据上二门。戒贤所判亦有道理。三约益物大小者。若令一切众生得小乘益。或令一切有情得大乘益。有得小益不能全令得究竟益。俱非了义。若能令彼一切众生及入寂二乘。悉皆当得大菩提益。方为了义。四显理浅深者。若于缘起随说实有。或虽破实犹存假有。既会相未尽显理未极故。非了义。若说缘生即是性空不碍缘起融通无二。会缘既尽理性圆现。方为了义。彼妙智经据上二门。智光所判甚有道理。是故二说各据别门互不相至。岂有相违。二约机领教者。问二说三教各初说小。华严初说如何会释。答诸德三释。一云此三法轮约渐悟机说。华严最初约顿悟机说。若尔密迹力士经初时具说三乘法。此为属渐为属顿耶。若是渐教应唯说小。若是顿教应唯说大。彼既具三极成违害。是故此释亦难用也。一云若依显了门。则有如前三法次第。若约秘密门即诸说同时。若尔者即初时小显而大密。何不以大显而小密耶。又判此显密出何圣教。理既不齐。复无圣教。故难依用。此上二释此三法轮摄法不尽。初即渐而非顿。后即显而非密。一云但是如来圆音一演。异类等解。就小结集唯说小乘。就大结集唯说大乘。就通结集具说三乘。若尔随一结集俱无前后。何有如此三教次第。今解此难便会二说。泛论如来圆音说法大例有二。一为此世根定者说。二为此世根不定说。初中三节。一或有众生此世小乘根性定者。见佛始终唯说小乘。如小乘诸部。结集三藏总无大乘。二或有众生此世三乘根性熟者。见佛始终但说三乘。如密迹力士经。佛初鹿园说法之时。无量众生得阿罗汉果。无量众生成辟支佛道。无量众生发菩提心。住初地等。乃至广说。大品大般若亦同此说。以此义准后时所说。皆通具此三乘。如诸大乘经中所说。三或有众生此世一乘根性熟者。即初见佛于树王下华藏界中依海印定。唯为菩萨演说无尽圆满自在无碍法门具足主伴。乃至终极亦同此说。以此法中通括九世摄前后故也。二为不定根者。有二位。一此世小乘根不定故堪可进入三乘位者。即初闻唯小以为不了。次闻唯大亦非是了。后闻具三方为了义。解深密经就此根辩。二此世小乘根不定故堪可进入一乘位者。即初唯说小为不了教。次通大小亦非了教。后会三归一唯说一乘方为了教。妙智经当此意也。由根不定有此二门。是故二师各述一门故不相违。由有如是此世根定及不定故。是故令彼教门或有前后。或无前后。准释可知

第五明现传者。当今诸德于大乘中自有二说。一立三乘大乘。以此宗许入寂二乘定不成佛。是故约彼五性差别具说三乘。二立一乘大乘。以此宗许入寂二乘亦并成佛。是故约此佛性遍有唯说一乘。前师引教成立云。如大般若经第五百九十云。若有情类于声闻乘性决定者。闻此法已速能证得自无漏地。于独觉乘性决定者。闻此法已速依自乘而得出离。于无上乘性决定者。闻此法已速证无上正等菩提。若有情类虽未证入正性离生。而于三乘性不定者。闻此法已皆发无上正等觉心。又解深密经第二云。乃至更说法要。谓相无自性性。胜义无自性性。乃至诸声闻乘种性有情亦由此道此行迹故正得无上安稳涅槃。一切声闻独觉菩萨皆共此一妙清净道。皆同此一究竟清净更无第二。我依此故密意说言唯有一乘。非于一切有情界中无有种种有情种性。或钝根性或中根性或利根性有情差别。解云。此约三乘同一所观无性道故。密意说此名为一乘。理实三乘各证涅槃非是一也。又瑜伽论第三十七云。补特伽罗成就者。略说四种。有声闻种性。以声闻乘而成就之。有独觉种性。以独觉乘而成就之。有佛种性。以无上乘而成就之。无种性者。即以善趣而成就之。善戒地持皆同此说。又解深密经云。一向趣寂声闻种性补特伽罗虽蒙诸佛施设种种勇猛加行方便化导。终不能令当坐道场证阿耨多罗三藐三菩提。深密解脱亦同此说。十轮经第九卷亦说三乘各定差别。如是等文并非小乘。是大乘中许三差别。是故各为三乘大乘教也。二后师引彼一乘大乘教者。涅槃经三十三云。一切众生同有佛性。皆同一乘同一解脱。一因一果。同一甘露一切当得常乐我净是名一味。又法华第一云。十方佛土中唯有一乘法。无二亦无三。除佛方便说。又云。初以三乘引导众生。然后但以大乘而度脱之。又第三云。我灭度后复有弟子不闻是经。不知不觉菩萨所行。自于所得功德生灭度想入于涅槃。我于余国作佛更有异名。是人虽生灭度之想入于涅槃。而于彼土求佛智慧。大智度论第九十五亦同此说。又法华论中四声闻内退菩提心及应化。此二声闻佛与授记。决定及增上慢此二根未熟故。菩萨与授记。方便令发心。解云。既但云未熟不言无根。故知定当得佛菩提。又复云方便令发心。即是发菩提心也。又入楞伽第二第四第七皆同说二乘无实涅槃但是三昧力住。后必当得无上菩提。法华论云。第四人者方便令入涅槃城故。涅槃城者。诸禅三昧城。过彼城已令入大般涅槃城。此同楞伽住三昧乐。离分段故假说涅槃。而实有彼变易身。故于净土中行菩萨道。胜鬘经云。言诸二乘得涅槃者。是佛方便。唯有如来得般涅槃。又此经及无上依经宝性论佛性论皆说入灭二乘于三界外受变易身。又密严经中二乘必无灰断永灭。如是等文亦是大乘。不许三乘决定差别。是故名为一乘教

第六定权实者。或有说者。一乘是权三乘是实。以深密经第一时教唯为发趣声闻乘者。说即总无成佛。第二时教唯为发趣修大乘者。说即总无不成佛。此二若过若不及。故俱非了义。莫若第三时教。有种性者成。无种性者不成。方为了义。法华既当第二时教。即是密意权说。是故胜鬘经以一乘为方便说。是故理实但约不定种性说为一乘。摄论庄严论显扬论等皆同此释。又法华第三生灭度想入涅槃等。依瑜伽八十一并是变化声闻示现入灭。楞伽密严皆同此会释。无上依经宝性等论并是不定二乘向菩提者增寿变易。非谓入灭更起受身。瑜伽说本转二识成就不成就四句中第四俱不成就者。为声闻独觉入无余依涅槃界时。又八十云。无余依涅槃界中唯有清净真如法界。依此等文。入涅槃已。身智俱灭。根识永无。岂有变易修行成佛。是故唯有一乘非极了义。深密经中第三时普为发趣一切乘者说名为了义。故知三乘是尽理实教。又深密第二第四皆云一乘是密意说故知是权也。或有说者。一乘是实三乘是权。谓法华经唯一佛乘是深密经三乘后说定性二乘灭亦不存故。方便说三。实唯一故。若言法华是第二时教。为引不定二乘故说一切悉皆成佛。而犹未说定性不成故非了者。若尔法华之时犹未说有定性二乘。何因彼论立四声闻彼定性言从何处得。若有定性岂得总成。若许总成何名定性。故知定性之言牒前深密所说。后至法华明悉全成佛。是故彼论顺此经文。会前权说归后实教。故知法华定在深密后说。妙智三教一乘在三乘后。梁论成立正法三中亦一乘在后。并同此说。法华中生灭度想入涅槃等。释为变化示现灭者。极违教理。违教者。若是变化声闻即实是诸佛菩萨。岂可迷自所示涅槃乃生灭度之想。若作此释元未读经。违理者。若入涅槃是永断灭。诸佛菩萨于所化前示现涅槃。若彼所化不定种性是勇猛者。不怖生死能修胜行。若有一类性怯弱者。怖畏生死学佛菩萨。先入涅槃拟欲于后行菩萨道。汝宗入灭既无有起。岂不误彼一类众生。此乃误众生何成引导。况复此文无不相干。又亦未见胜鬘经意。乃辄断一乘以为方便。彼经云。若如来随彼所欲而方便说(谓二乘)。即是一乘无有二乘。二乘入于一乘。一乘者即第一义乘。又彼经中广破二乘云无涅槃。又云。此经断一切疑。决定了义入一乘道。岂说一乘以为方便。解深密经一乘是密意者。是未说法华之前故作是说。及后说法华时会前三乘皆是方便。瑜伽转本俱灭。显扬六义说一乘。摄论十义说一乘。皆同深密会释。以此等论随彼经造故。法华论说决定二乘亦受记等。是随此本经造故。若不信一乘守权乖实甚为可愍故。百喻经第二卷云。昔有一聚落。去王城五由旬。村中有好美水。王敕村人常使日日送其美水。村人疲苦悉欲移远此村去。时彼村主语诸人言。汝等莫去。我当为汝白王改五由旬作三由旬使汝得近去来不疲。则往白王。王为改之作三由旬。众人闻已便大欢喜。有人语言此故是本五由旬。更无有异。虽闻此言信王语故终不肯舍。世间之人亦复如是。修行正法度于五道向涅槃城。心生疲倦。便欲舍离顿驾生死不能复进。如来法王有大方便。于一乘法分别说三。小乘之人闻之欢喜以为易行。修善进德求度生死。后闻人说无三乘故是一乘。以信佛语终不肯舍。如彼村人亦复如是。解云。此经即是金口良断。权实显然。可息诸说耳

第七显开合者。然此三乘一乘各有二种。三乘二者。一异时三乘。如深密经初时唯小乘第二唯大乘。二同时三乘。如第三时普为发趣一切乘等。于此教中一乘相隐三乘相显。是故就显总名三乘。一乘二者。一破异明一。如法华经。破二实灭。及涅槃经破无佛性。俱是对权会破方说一乘。二直体显一。如华严经不对二乘无所破故。为大菩萨直示法界成佛仪故。是故初说华严无权可会。终说涅槃会前诸权。是即非尽权无。以显实是俱名一乘。又复更开各有三种。初三乘三者。一始别终同三。谓始约因修四谛缘生六度等别。终就得果三乘之人身智同灭。如俱舍等说。比约初时小乘教说。二始同终别三。谓同闻般若同观无性。三乘之人各得自果。如前所引说。若据圣谛缘生六度行异亦得名为始终各别。此是第二第三时教说也。三近异远同三。谓法华等初以三乘方便诱引。后同以大乘令得度等。一乘三者。一存三之一。如深密等说。二遮三之一。如法华等。三表体之一。如华严等。是故通说有其四句。一或唯三无一。如俱舍等。二或唯一无三。如华严等。三或亦一亦三。此有二位。初三实一权。如深密等。后一实三权。如法华等。四或非一非三。约理绝言故。大般若中舍利子问善现云。如来授诸天子记于三乘中何乘得记。善现答言。于法相中无一无三。云何问言于何乘得记。是故一乘三乘有存有泯。诸说不同。或闻唯破二乘即谓唯约不定种性。或闻无二亦无三即谓大乘实教亦破。或闻不破大乘即谓大乘权教亦存。今释有二位。一约事破二乘实灭。二约教亦会大乘权教。大乘权教许入寂二乘不成佛故。但深破二乘即是破三。是故破二破三皆不相违

第八教前后者。今辩如来一代所说。约时显教。大例有四。一本末差别门。二依本起末门。三摄末归本门。四本末无碍门。初中本末同时始终一类各无异说。然有三位。一若小乘中即最初度彼憍陈那等。最后度于须跋陀罗。中间亦复唯说小乘唯益小机。如四阿含经及五部律遗教等说。二若约三乘即从始至终皆说三乘通益三机。如前所引力士经大般若等诸大乘经。于中虽有权实不同皆具三乘。三若约一乘即从初至极为大菩萨唯说一乘。如最初时说华严等。其中不通二乘。复摄九世该于前后。是故至极更无异说。然此三类既依此世根定者说。此即诸教相望各通始终。竟无前后。二依本起末门者。有四类。一谓初时为大菩萨说大乘。次说中乘。次说小乘。后说人天。如此经下性起品云譬如日出先照一切诸大山王次照一切大山次照金刚宝山然后普照一切大地。如来应供等正觉亦复如是。成就无量无边法界智慧日轮常放无量无碍智慧光明。先照菩萨摩诃萨等诸大山王。次照缘觉。次照声闻。次照决定善根众生随应受化。然后悉照一切众生乃至邪定。为作未来饶益因缘。又此品中如三千界初始成时。先成色界诸天宫殿。次成欲界诸天宫殿。次成人处及余众生诸所住处。如来应供等正觉亦复如是。先起菩萨诸行智慧。次起缘觉声闻及余众生一切善根。依此等文明佛初时说大后渐说小。约法以明依本起末。非约根器。以无先学大后学小故。问法岂不别耶。答小乘之法定从大乘所流出故。文殊问经云。十八及本二皆从大乘出。普超三昧及入大乘论意并同此。三摄末归本门者。依无量义经。初时说小乘。次说中乘。后时说大乘。依解深密经。初时唯小乘。第二时唯大乘。第三时具三乘。依妙智经。初时唯小乘。次具三乘。后唯一乘。此即无量义经合大开小。深密等合小开大。谓于大乘开于权实。然深密妙智既各圣教。不可取一舍一。是故合此二经总有四门。一初时小乘。二经同说。第二时唯大乘。唯深密说。第三时具三乘。此是深密第三妙智第二。第四时唯一乘。唯妙智第三时说。是故当知妙智经在深密后说。若谓妙智经此土未翻而不信者。彼深密经既当第三时教。然许定性二乘及无性有情并不成佛。具足三乘名一切乘者。是即法华涅槃既在深密后说。然定性二乘及无性阐提悉皆成佛。当知即是第四时名一乘教。是故与妙智经悬会无疑。又初小乘教。依法华等佛成道后三七日等说。依真谛三藏记云。佛成道七年后说诸部般若。是第二时教。又云。三十八年后说解节经。当第三时教。今依法华经及无量义经。并云四十年后说法华等。故知是深密后说。真谛此说必有圣教。若无圣教岂可自作年数。若不信此者。即涅槃经最居末后是即无疑。然此四时皆前权后实以后会前。法华涅槃会深密之三乘归究竟一乘其义决定。是故此四从浅至深明摄末归本之渐次也。四本末无碍门者。谓初举照山王之本教。明非本无以起末。后显归大海之异流。明非尽末无以归本。是即本末交映。与夺相资。方为摄生之善巧也。是故通论总有五位。一根本一乘教。此如华严说。二密意小乘教。三密意大乘教。四显了三乘教。上三如深密经说。五破异一乘教。如法华涅槃等说。此上四门既圆通无碍。是即前后即无前后。无前后即前后。皆无障碍思准之耳

第九以义分教。教类有五。此就义分。非约时事。一小乘教。二大乘始教。三终教。四顿教。五圆教。初小乘可知。二始教者。以深密经中第二第三时教同许定性二乘俱不成佛故。今合之总为一教。此既未尽大乘法理。是故立为大乘始教。三终教者。定性二乘无性阐提悉当成佛。方尽大乘至极之说。立为终教。然上二教并依地位渐次修成。俱名渐教。四顿教者。但一念不生即名为佛。不依位地渐次而说。故立为顿。如思益云。得诸法正性者。不从一地至于一地。楞伽云。初地即八地乃至无所有何次等。又下地品中十地犹如空中鸟迹。岂有差别可得。具如诸法无行经等说。五圆教者。明一位即一切位一切位即一位。是故十信满心即摄五位成正觉等。依普贤法界帝网重重主伴具足故。名圆教。如此经等说。若约所说法相等者。初小乘法相有七十五法。识唯有六。所说不尽法原。多起异诤。如小乘诸部经论说。二始教中广说法相小说真性。所立百法决择分明故无违诤。所说八识唯是生灭法相名数多同小乘。固非究竟玄妙之说。如瑜伽杂集等说。三终教中少说法相广说真性。以会事从理故。所立八识通如来藏随缘成立具生灭不生灭。亦不论百法名数不广。又不同小亦无多门。如楞伽等经宝性等论说。四顿教中总不说法相唯辩真性。亦无八识差别之相。一切所有唯是妄想。一切法实唯是绝言。呵教劝离毁相泯心。生心即妄。不生即佛。亦无佛无不佛无生无不生。如净名默住显不二等是其意也。五圆教中所说唯是无尽法界。性海圆融缘起无碍。相即相入如因陀罗网重重无际微细相容主伴无尽。十十法门各称法界。具如下说。然此五教有开有合亦有五重。一或总为一。谓唯是如来一大善巧摄生方便也。二或开为二。谓一乘三乘教前诸教中虽有存三泯二不同。然皆通三乘趣入故名三乘教。后一直显本法不通二乘故唯是一。即智论中名共教不共教。此亦同上印师等所立二教也。三或分为三。谓小乘三乘一乘教。智论既将此经为不与二乘共故名为不共。即是一乘。大品等为通三乘同观得益故名为共。即是三乘。义准四阿含经既不共菩萨亦名不共。即是小乘。依此三位梁摄论第八云如来成立正法有三种。一立小乘二立大乘(有本作三乘字)三立一乘。第三最胜故名善成立。此亦同上妙智经说。又真谛三藏部异执疏第二卷中亦同此说。四或分为四。此有二义。一于上共教中约存三泯二开两教故为四。一别教小乘。二同教三乘。如深密等。三同教一乘。如法华等。四别教一乘。如华严等。二约历位无位开渐顿二教故为四。一小乘教。二渐教。三顿教。四圆教。五或散分为五。于上渐教复分始终二教。此上五教非局判经。但多分而论。如上所指通诸经论。并可知第十以理开宗。宗乃有十。一法我俱有宗。谓人天位及小乘中犊子部等。彼立三聚法。一有为法。二无为法。三非二聚。即初二是法。后一是我。又立五法藏。一过去。二未来。三现在。四无为。五不可说。此即是我以不可说是有为无为故。二法有我无宗。谓萨婆多等。彼说诸法二种所摄。一名。二色。或四所摄。谓三世及无为。或立五法。一心。二心所。三色。四不相应。五无为。此即但有此法无别有我。三法无去来宗。谓大众部等说。有现在及无为。以过未法体用俱无故也。四现通假实宗。谓说假部等。彼说无有去来二世。于现在法中在蕴可实在界处为假。随应诸法假实不定。成实论及经部别师亦同此类。五俗妄真实宗。谓说出世部等。彼说世俗法假以虚妄故。出世法实以非虚妄故。六诸法但名宗。谓一说部等。一切我法唯有假名都无实体。此又通于初教之始。七一切皆空宗。谓大乘初教。说一切法悉皆性空超于情表无分别故。如般若等皆辩。八真德不空宗。谓终教诸经所说。一切法唯是真如如来藏中实德摄故。真体不空具性德故。九相想俱绝宗。谓顿教中绝言所显离言之理。理事俱泯平等离念。十圆明具德宗。谓如别教一乘。主伴具足无尽自在所显法门。上来分教开宗粗陈挭概广引教理。具明义相如别记说

第四教所被机者。通有十位。于中前五简其非器。后五正显所为前中五者。一违真非器。谓不发菩提心不求出离。依傍此经求名求利庄饰我人。经非彼缘故非其器。下云。为名利说法是为魔业。又如不净说法堕恶道等。二背正非器。谓诈现大心伪修邪善。近感人天终成佛。恐堕阿鼻地狱多劫受苦。如提婆达多为阐提顶。又如八大善人当成不善。前据初时即可知。此就终时方显。下云。忘失菩提心修诸善根是为魔业。经非此缘故亦非器。三乖实非器。谓虽不巧伪。然随自执见以取经文。遂令超情至教回不入心故成非器。地论云。闻作闻解不得不闻。又如随声取义五种过失等。此上三位俱是凡愚众生境界。下云。此经不入一切众生之手。唯除菩萨。良以此经非是众生流转之缘。故不入手。四狭劣非器。谓一切二乘无广大心亦非此器。下文云。一切声闻缘觉不闻此经。何况受持。又舍利弗等五百声闻皆如聋盲不闻不见。五守权非器。谓三乘共教诸菩萨等。随自宗中修行未满初阿僧祇亦非此器故。下文云。菩萨摩诃萨。虽无量亿那由他劫行六波罗蜜修习道品善根未闻此经。虽闻不信受持随顺。是等犹为假名菩萨。问璎珞经等十千劫修十信行满。何故此中无量亿等不信此经。答以彼但于行布位中修行信等。于此圆融普贤十信一摄一切犹未闻信。由此故知二宗差别。若不尔者修行既经尔许时劫不信此经。何名菩萨摩诃萨也。简非器竟第二显所为中五者。一正为者。谓是一乘不共教中普机菩萨。正是此经所为之器。下文云。如是经典。但为乘不思议乘菩萨摩诃萨说不为余人。解云。乘者运转为义。若依别门初运至十信。次转至十住乃至佛果。次第相乘以阶彼岸。名可思议。若依普门一位即一切位故。亦一运即一切运。名不思议乘。乘此乘者十信满心即得六位。如贤首品等说。又十住等位皆亦如是。如下文诸会处说。又如善财一生具五位等。皆是普法相收故也。又舍那品云。非余境界之所知。普贤方便皆得入。又普贤诫众云。普眼境界清净身我今演说。仁谛听如是可知。问何故此法非余境界。答以卢舍那周遍尘方普应法界一切群机。若彼别机称自根器。但各见己所见闻自所闻。皆不见他所见不闻他所闻。此普贤机乃见一切所见闻一切所闻。皆尽卢舍那能化分齐故云普眼境也。是故当知。普别二机感普别二法各不同也。二兼为者。谓遗法中见闻信向此无尽法。成金刚种当必得此圆融普法。如下文吞服金刚喻又小火广烧喻等。又如兜率天子从地狱出得十地无生忍。展转利益不穷尽等。皆由宿闻此法为本因故。又下文云。虽在于大海及劫尽火中。决定信无疑必得闻此经。三引为者。谓彼如前共教菩萨。于彼教中多时长养深解穷彻行布教源。即当得此普贤法界。既云无量亿那由他劫不信此经。即知过此劫数必当信受。以离此普法更无余路得成佛故。经不说彼过此劫数犹不信故。问若彼地前过彼劫数必信受者。即知地上二宗不别。岂彼所信无十地耶。答于彼教中具有行布十地渐次乃至佛果。长养彼根器务令成熟。极迟之者至此劫数定当信入。如其疾者是即不定可准知耳。四转为者。谓诸二乘以根钝故。要先回入共教大乘舍二乘名得菩萨称。然后方入此普贤法。故说此经唯为菩萨不摄二乘。若不尔者余大乘经有声闻众为所被机亦引二乘令其入大。唯独此经众无声闻之机文无回小之说。何成了义深广之典。设第八会有声闻者。为寄对显法表如聋盲非是所被。其六千比丘非是罗汉故不相违。是故当知。一切二乘总无顿入普贤法界。依究竟说无有二乘而不回入共教菩萨。无彼菩萨而不入此普贤之法。是故展转无不皆是此法之器。五远为者。谓诸凡愚外道阐提悉有佛性。以障重故久远亦当得入此法。如佛性论及宝性论皆说。以一阐提谤大乘因。依无量时说无佛性。非谓究竟无清净性。又如此经性起大树于二乘阐提二处不生牙亦不舍生性等。又如日照生盲喻等。是故当知。一切众生究竟无不皆入此法。以此普法众生具有故。下文云。菩萨知一切众生身中有如来菩提等。问若尔何故瑜伽等论。定性二乘及无性有情定不成佛。答此由教门有了不了故有诸说。若依小乘一切众生总皆无有大菩提性。如小论说。若大乘初教即五性差别。一分有性一分无性。如瑜伽等。若依终教一切众生悉有佛性。如涅槃等经佛性等论。若依顿教众生佛性一味一相。不可言有不可说无。离言绝虑。如诸法无行经等说。若依圆教众生佛性。具因具果。有性有相。圆明备德。如性起品如来菩提处说

第五能诠教体者。通论教体。从浅至深。略有十门。一言诠辩体门。二通摄所诠门。三遍该诸法门。四缘起唯心门。五会缘入实门。六理事无碍门。七事融相摄门。八帝网重重门。九海印炳现门。十主伴圆备门。初中有二。先辨小乘。后显大乘。前中依萨婆多宗诸德三说。一云但名句文身以为教体。故发智论云。十二部经以何为性。答名身句身文身次第住等。一云以声善故是佛教体名等无记是教作用。婆娑论第一百二十六云。佛教云何。答谓佛语言词唱评论语音语路语表是佛教。乃至说者语业为体。佛语何法。答谓名身句身文身。次第行列。次第安布。次第连合。此即总显佛教作用。解云。评家正义音声为体。经部宗亦以音声为性。故顺正理论第十四破经部云。汝不应立名句文身即声为体。又无性摄论破彼云。诸契经句语为自性不应理故。初是法处后是声处。亦又因前二说诸德合取以为教体。余如彼说。就大乘宗有四句。初摄假从实。唯声为体以名等依声屈曲假立无别体故。无性摄论云。依弘誓愿立菩萨声。杂集论云。成所引声谓诸圣说。二分假异实。以名等为性故。唯识论第二云。若名句等不异声者。法词无碍境应无别。三假实合辩。亦声亦名等。维摩经云。有以音声语言文字而作佛事。十地论中说者以二事说。听者以二事闻。谓音声名字。问依此宗声表善恶声是无记。又名句文是自性无记。何得无记为圣教体。答若有漏心变可是无记。若佛菩萨后得智说俱是善摄。十地论云。依止何事者谓音声及善字。四假实双泯。非声非名。以即空故。言即无言故。维摩云。文字性离是即解脱。十地论中风喻音声。画喻名字。若动树叶风及壁上画是即可取。若空中风及空中画皆不可取。大乘声名当知亦尔。皆不可取以相尽故。此上四句为一教体。是故空有无碍名大乘法。谓空不异有有是幻有。幻有宛然举体是空。有不异空空是真空。真空湛然举体是有。是故空有无毫分别。故佛藏经云。诸法如毫牦许不空者即诸佛不出世。又下云。诸法毕竟空无有毫末相。如是非一也。第二通摄所诠门者。非但如前取能诠教。亦渐通取所诠之义。以并是所知所解法故。瑜伽八十一云。诸契经体略有二种。一文。二义。文是所依义是能依。如是二种总名一切所知境界。解云。以义依文而得显故。第三遍该诸法门者。谓一切诸法悉为教体。此亦二种。一有为法。二无为法。以无不能令生开觉故。如下文华鬘宝地香树云阁法界法门无非佛事。如胜音菩萨及所坐莲华即通人法教义行位因果理事总能发生胜解行。故并为教体。准思可知。第四缘起唯心门者。此上一切差别教法无不皆是唯心所现。是故俱以唯识为体。然有二义。一本影相对。二说听全摄。初中通辨诸教总有四句。一唯本无影。如小乘教。以无唯识变现等故达摩多罗等诸论师多立此义。二亦本亦影。如大乘始教。众生心外佛有微妙色声等法。由闻者善根增上缘力击佛利他等子为因。于佛智上文义相生为本性相教。由佛此教增上缘力击闻法者有漏无漏善根种子闻者识上文义相生为影像相教也。二十唯识论云。展转增上力二识成决定。护法论师等悉立此义。三唯影无本。如大乘终教。离众生心佛果无有色身言声事相功德。唯有如如及如如智。大悲大愿为增上缘令彼所化根熟众生心中现佛色声说法。是故圣教唯是众生心影像。故下文云。一切诸如来无有说佛法。随其所应化而为演说法。又云。如来法身不思议无色无相。无伦匹示现色像。为众生十方受化靡不见。如是非一。龙军坚慧诸论师等并立此义。四非本非影。如顿教中。非直心外无佛色等。众生心内所现之佛亦当相空。以唯是识无别影故。色等性离无所有故。一切无言无言亦无故。是故圣教即是无教之教。如经云如来不出世亦无有涅槃。又密严经明佛常在法界无不出世等。龙树等宗多立此义。此前四说总为一教。圆融无碍皆不相妨。以各圣教从浅至深摄众生故。思之可见。第二说听全收者。亦四句。一离佛心外无所化众生。况所说教。是故唯是佛心所现。此义云何。谓诸众生无别自体揽如来藏以成众生。然此如来藏即是佛智证为自体。是故众生举体总在佛智心中。下文云。诸佛悉了知一切从心转。又云。如来菩提身中悉见一切众生发菩提心修菩萨行成等正觉。乃至见一切众生寂灭涅槃亦复如是。皆悉一性以无性故。又云。三世一切劫佛刹及诸法诸根心心法一切虚妄法。于一佛身中此法皆悉现。又佛性论第二如来藏品云。一切众生悉在如来智内故名为藏。以如如智称如如境故。一切众生决定无有出如如境者。并为如来之所摄持故名所藏众生为如来藏。是故离佛心智无一法可得。二总在众生心中。以离众生心无别佛德故。此义云何。佛证众生心中真如成佛。亦以始觉同本觉故。是故总在众生心中。从体起用。应化身时即是众生心中真如用大更无别佛。起信论中盛明此义。又下文云。若人欲求知三世一切佛应当如是观。心造诸如来。三随一圣教全唯二心。以前二说不相离故。谓众生心内佛为佛心中众生说法。佛心中众生听众生心佛说法。如是全收说听无碍。是谓甚深唯识道理四或彼圣教俱非二心。以两俱形夺不并现故。双融二位无不泯故。谓佛心众生无听者故。众生心佛无说者故。两俱双泯二相尽故。经云。夫说法者无说无示。亦其听法者无闻无得。又此下文云。众生所生非是生。亦无流转生死中。又经云。如来不说法亦不度众生如是等。是故此四于一圣教圆融无碍方为究竟

第五会缘入实门者亦有二义。一以本收末。二会相显性。初中以诸圣教皆从真流是故与真性常不异。如海起潮不失碱味。论中名为真如所流十二分教。又云。从最清净法界等。流教法等。是故以本收末唯是真如也。二会相显性者。谓彼一切差别教法皆悉从缘起。从缘起故必无自性。无自性故即是真如。是故空相本尽真性本现唯是真如故。经云。一切法即如也。又下文云。彼生灭法如如相也

第六理事无碍门者。亦有二义。一谓一切教法举体真如不碍事相历然差别。二真如举体为一切法。不碍一味湛然平等。前即如波即水不碍动相。后即如水即波不失湿体。当知此中道理亦尔。是故理事混融无碍唯一无住不二法门。维摩经中盛显斯义。又此经云。知非有是有．有是非有．非相是相．相是非相。良由本以非有为有。是故此有即是非有。圣教准此理事无碍思之可见

第七事融相摄门者。亦有二义。一相在。二相是。初中先一在一切中。谓如一教法不碍在事全是真理。真理遍余一切事中同理。教事亦如理遍。是故一切法中常有此一。依是义故无一微细尘毛等处无佛说教。故此经云。一切佛刹微尘中卢舍那现自在力。弘誓愿海振音声调伏一切众生类。二一切在一中。谓无分齐理既不改性而全是事。是故一事摄理无不皆尽。余事如理在一事中。以理无际限不可分故。随一事处皆全摄也。是故一中常有一切依是义。故此经云。于此莲华藏庄严世界海之内一一微尘中见一切法界。又云。于一法中解众多法众多法中解了一法。若具通说有其四句。初一在一中。谓别说一切差别事中一一各有彼一法故。二一在一切中。谓通说一切悉有一故。三一切在一中。谓别说一中摄一切故。四一切在一切中。谓通说一切悉有一切故。又此常含一切之一即复恒在彼一切中。同时自在无障无碍。不动一方遍十方等。皆是此义思之可见。既一切法悉为教体。皆互相收圆融无碍方是此经教之体性。二相是者。先一即是一切。谓如一教事既全是真理。真理即为一切事故。是故此一即是一切。一切即一反上应知。此经云。若一即多多即一义味寂灭悉平等。通亦四句准前思之。良以全理之事与全事之理非一非异。由非一门故得相在也。由非异门故得相是也。深思可见。依是义故一句即是一切句而无穷尽。一切亦尔。下文云。欲具演说一句法阿僧祇劫无穷尽。如是自在是此教体。第八帝网重重门者亦二义。先辨一门后类显一切。前中如一句内即具一切。此一中一切复一即一切。如是重重具即不可穷尽。总是一句

二类显者。如此一句余一切句一一皆尔。是即无尽无尽具唯普眼所知非是心识思量境界。下文云。于彼一一修多罗分别诸法不可说。于彼一一诸法中又说诸法不可说。又云。若于一小微尘中有诸佛刹不可说。于彼一一佛刹中复有佛刹不可说。解云。如是重重如因陀罗网。是谓此经圆宗教体

第九海印炳现门者。亦有二义。一约果位。如前差别无尽教法皆是如来海印定中同时炳然圆明显现。设所化机亦同缘起在此中现。是故唯以此三昧海为斯教体如下文云一切示现无有余海印三昧势力故。二约因位。要普贤等诸大菩萨方得此定同前业用亦无差别。是故十信满处普贤位中亦得此定。如贤首品说

第十主伴圆备门者。谓此普法教不孤起必主伴随生。如下文普庄严童子闻佛说一切法界无垢庄严经。有世界微尘数修多罗以为眷属。如是等文处处皆有。此眷属经有其二义。一同类。二异类。初同类者。如说十住十方各有十刹尘数菩萨来证。同名法慧。我等佛所亦说十住。大众眷属名味句身等无有异。是故当知一十住经十方各有十刹尘数修多罗等以为眷属。如一十住余一切处所说十住皆摄尔许尘数眷属。十住既尔余十行等一一品会皆有证法。数量准释可知。二异类者。谓随一方一界为一类机说一会法。既无结通十方等说。故非主经。然亦与主为胜方便故为眷属。是故主经必十方尘道同时同说。伴经不尔随方各别。是故一一主经各有尘数眷属。是谓本末相资主伴圆备。教体门竟

第六宗趣者。语之所表曰宗宗之所归曰趣。然此大经宗趣难辨。略叙十说以显一宗

一江南印师敏师等多以因果为宗。谓此经中广明菩萨行位之因及显所成佛果胜德。下文所说不离此二故以为宗

二大远法师以华严三昧为宗。谓因行之华能严佛果。此上二说但得所成行德遗其所依法界

三依衍法师以无碍法界为宗

四依裕法师。以甚深法界心境为宗谓法界门中义分为境。诸佛证之以成净土。法界即是一心。诸佛证之以成法身。是故初品之内。初天王偈赞无尽平等妙法界悉皆充满如来身。末后复明入法界品。故知唯以法界为宗。此上二说但得所依法界遗所成行德

五依光统师以因果理实为宗。即因果是所成行德。理实是所依法界。此虽义具然犹未显

六今总寻名案义以因果缘起理实法界以为其宗。即大方广为理实法界。佛华严为因果缘起。因果缘起必无自性。无自性故即理实法界。法界理实必无定性。无定性故即成因果缘起。是故此二无二。唯一无碍自在法门故以为宗

七别开摄法界以成因果。谓普贤法界为因。舍那法界为果。是故唯以法界因果而为宗趣。于中分别有十事五对。一所信因果。如初会中舍那品内先明莲华藏世界果后显普庄严因。二差别因果。如第二会至小相品说。于中初二十五品说五位差别因。后三品说三德差别果。三平等因果。如普贤品说平等圆因性起品说平等满果。上二门是生解因果。四成行因果。如离世间品中二千行法内先明因行后显果行。五证入因果。如入法界品先祇洹林中现自在果后善财童子辨证入因。因果五周一部斯毕。是故唯辨因果不失所依。但以因果为宗理亦无咎

八会因果以同法界。法界法门略显十事五对。一教义相对。举此所说教法为宗。意显所诠义理为趣。或反此。以辨义深教胜故。二理事相对。举事法为宗。意取理性为趣。或反此。以依理性方成事故。三境智相对。举所观境。意欲令成观智行故。或反此。以令修起智证同真境故。四行位相对。举所依之五位。意令依之修成胜行。或反此。以积行成位故。五因果相对。劝彼修因。意在证果。或反此。以举果劝乐令修因故。此上五对通于一部处处皆有故不别属。是故唯辨法界不失所成。但以法界为宗理亦无违

九法界因果分相显示中。亦有十义五门。一无等境即理实法界。此有二位。一是出缠最净法界。二是在缠性净法界。此二为所信所证故。二无等心。此亦二义。一大菩提心为普贤行所依本故二信悲智等随行起故。三无等行。此亦二义。一差别行各别修故。二普贤行一即一切故。四无等位。此亦二义。一行布差别位比证不同故。二圆融相摄位一位即具一切位故五无等果。此亦二义。一修生果二修显果。此五门十义通收此经一部略尽。是故具以为宗。义亦备矣

十法界因果双融俱离。谓性相混融无碍自在亦有十义。一由离相故。因果不异法界。即因果非因果也。二由离性故。法界不异因果。即法界非法界也。三由离性不泯性故。法界即因果。以非法界为法界也。四由离相不坏相故。因果即法界。以非因果为因果也。五由离相不异离性故。因果法界双泯俱融。回超言虑也。六由不坏不异不泯故。因果法界俱存现前。烂然可见也。七由上存泯复不异故。超视听之法恒通见闻。绝思议之义不碍言念也。八由法界性融不可分故。即法界之果统摄法界无不皆尽。因随所依亦在果中。是故佛中有菩萨也。九即法界之因摄义亦尔。故普贤中有佛也。十因果二位各随差别。一一法一一行一一德一一位皆各总摄无尽无尽诸法门海者。良由无不该摄法界圆融故也。是谓华严无尽宗趣。余义如指归等说

第七释经题目者。略释十名。一数名。二法名。三喻名。四义名。五德名。六事名。七开名。八具名。九合名。十品名

初数名者。依梁摄论第十胜相云百千经者。是华严经有十万颂名百千经。此即从本数以立其名

二法名者。依智度论属累品云名不思议解脱经有十万偈。又彼中自指是华严故良为此经所说之法皆一摄一切无不悉是不思议解脱故以为名

三喻名者。依涅槃经及观佛三昧经名此经为杂华经。以万行交饰缘起集成从喻标名。犹杂华耳

四义名者。如下离世间品出生菩萨深妙义华等十义立名。至彼当辩

五德名者如性起品末就十胜德以立其名。亦至彼当释

六事名者华严之称梵语名为健拏骠诃。健拏名杂华。骠诃名严饰。日照三藏说云。西国别有一供养具。名为骠诃。其状六重下阔上狭饰以华宝。一一重内皆安佛像。良以此经六位重叠位位成佛正类彼事故立此名。人天八会亦似彼应知

七开名者此一名开为十事五对。一通别一对。谓大方广等一部通名。世间净眼是当品别目。二就通中教义一对。谓大等是所诠义。经之一字是能诠之教。三就义中法喻一对。谓大等是法。华严为喻。四就法中境智一对。谓大等是所证所觉。佛是能证能觉。亦是人法一对。五就境中简持一对。谓大字是能简。方广为所简。即简大异小简实异权简果异因故也

八具名者。大有十义。一境大。谓十莲华藏及十佛三业无边依正为所信境。如初会等说。二心大。谓依前大境起大心故。如贤首品及发心品说。三行大。谓依大心起大行故。如离世间品等说。四位大。谓积大行成大位故。即五位圆通等。如第二会至第六会来说。五因大。谓行位普圆生了究竟。如普贤品等说。六果大谓随缘自体果德圆明。如不思议品等说。七体大。谓大用平等皆同真性。如性起品等说。八用大。谓念念益生顿成行位。如小相品等说。九教大谓一一名句皆遍一切。如下结通等说。十义大。谓所诠皆尽无边法界。如一尘含十方一念包九世八会等说。此上十义一一统收一切法尽莫不称大。又有七义。如瑜伽等七种大性相应等。以释大义。又依涅槃经更有三义释大。经云。所言大者名之为常。又言。大者其性广博。又云。能建大义名大涅槃。又起信论亦以三义释大。谓体相用等。次释方广亦有十义。一周遍义。谓言教广遍诸尘方故。二普说义谓普宣说一切法故。三深说义。谓说甚深法界海故。四备摄义。谓普摄无尽众生界故。五广益义。谓要令众生得佛菩提大利乐故。六荡除义。谓遍除二障及习气故。七具德义。谓具摄无边诸胜德故。八超胜义。谓独绝超余无比类故。九含摄义。谓通摄众多异类法故。十广出义。谓能出生佛大果故。然此十义如二论说。入大乘论。一为众生说对治法故。二有众多乘故。三多庄严具故。四能出生无量大果故。五除断一切诸邪见故。名毗佛略。又杂集论释方广者。谓菩萨藏相应言说名为方广。一切有情利益安乐所依处故。宣说广大甚深法故。亦名广破。以能广破一切障故。亦名无比法。无有诸法能比类故。次释佛义亦有十种。如无著佛等。寻文具辩。次释华严。问华有几义。复何所表以华为严。答华有十义。所表亦尔。一微妙义是华义。表佛行德离于粗相故说华为严。下并准此。二开敷义。表行敷荣性开觉故。三端正义。表行圆满德相具故。四芬馥义表德香普熏益自他故五适悦义。表胜德乐欢喜无厌故。六巧成义。表所修德相善巧成故。七光净义。表断障永尽极清净故。八庄饰义。表为了因严本性故。九引果义。表为生因起佛果故。十不染义。表处世不染如莲华故。次释经字亦有十义。如宝云经说。余义同上

九合名者。大即当体为目包含为义。方即就用为名。轨范为义是方法故。性离邪僻是方正故。能治重障是医方故。遍虚空界尽方隅故。广即体用合明。周遍为义。谓一切处一切时一切法一切人无不周遍。皆重重如帝网。此中且就一摄一切名大一遍一切称广。前广后大。理亦不违。方即是广大即方广皆持业释。此是所得之法佛是能得之人。觉照为名果满为义。此中人法境智有相依相即。相依者。智依境故方广之佛简下乘佛。境依智故佛之方广。简因位法。此二相依各有有力无力缘起四句。思之可见。皆依主释。相即者。谓佛即方广方广即佛。人法无碍全体相即。空有四句亦准思之。此唯持业释。既佛非下乘法超因位。果德难彰寄喻方显。谓万德究竟瑰丽犹华。互相交饬显性称严。此有二门。一诸德互严。亦有相依相即。各有四句存亡俱泯。皆持业释思之可见。二理行互严。亦有相依相即。初相依四句者。一理由修显故即行华严性也。二行从理起故即理华严行也。梁摄论云。无不从此法身流。无不还证此法身。三理行俱融不二而二。非真流之行无以契真。非饬真之行不从真起。良以体融行而因圆。行该真而果满。是故标为佛华严也。四理行俱泯二而不二。以理之行故非行。行之理故非理。是即能所两亡。超情离相。非严非不严是谓华严。相即四句。理行全收。准思可见。是知法喻交映昭然有在。余如前释

十品名者。世间是法。净眼为喻。世者是时。间者是中。时中显现故云世间。世间不同有其三种。一器世间。为所依处。二智正觉世间。为能化主。三众生世间。为所化机。此品之内不越此三。故立斯名。器有二种。一场地别处。二华藏通处智正觉亦二。谓三身十身。众生亦二。谓同生异生。净眼三义。一洞彻义。况器世间。内彻理故。下文云。法界不可坏莲华世界海。二现像义。况智正觉。下文云。清净法身无像而不现。三照瞩义。况众生世间。下文云。犹如净眼观明珠。又若通论此三世间各有净眼三义。思准可知。又释佛未出世无善导故如盲。如来创出世间净眼现名世间净眼。是故佛涅槃时言世间眼灭。品者类也别也余义可知

第八部类传译者。亦有十义。一恒本。二大本。三上本。四中本。五下本。六略本。七论释。八翻译。九支流。十感应

初恒本者。下不思议品云。一切法界虚空界等世界悉以一毛周遍度量。一一毛端处于念念中不可说微尘等身尽未来际劫常转法轮。解云。此通树形等异类世界各毛端处念念常说。无有休息。此非可结集。不可限其品颂多少。亦非下位所能受持

二大本者。如下海云比丘所受持普眼经。以须弥山聚笔四大海水墨书一品修多罗不可穷尽。如是等品复过尘数。此是诸大菩萨陀罗尼力之所受持。亦非贝叶所能书记

三上本者。此是结集文中之上本也。故西域相传。龙树菩萨往龙宫见大不思议解脱经有三本。上本有十三千大千世界微尘数颂四天下微尘数品

四中本者。有四十九万八千八百偈一千二百品。此上二本并秘在龙宫。非阎浮提人力所受持故此不传

五下本者。有十万颂三十八品。龙树将此本出现传天竺。即摄论百千为十万也。西域记说。在于阗国南遮俱槃国山中具有此本

六略本者。即此土所传六十卷本。是彼十万颂中前分三万六千颂要略所出也。近于大慈恩寺塔上见梵本华严有三部。略勘并与此汉本大同。颂数亦相似

七论释者。龙树既将下本出因造大不思议论。亦十万颂以释此经。今时十住毗婆沙论是彼一分。秦朝耶舍三藏颂出译之。十六卷文才至第二地。余皆不足。又世亲菩萨造十地论。偏释十地一品。魏朝勒那三藏及菩提留支于洛阳各翻一本。光统律师自解梵文令二三藏对御和会合成一本。见传者是。金刚军菩萨及坚慧菩萨各造十地释。并未传此土。又魏朝此土高僧灵辩法师。于五台山顶戴华严膝步殷勤足破血流遂经三载冥加解悟。于悬瓮山中造此经论一百余卷现传于世。后敕请法师入内于式干殿讲此大经

八翻译者。有东晋沙门支法领。从于阗国得此三万六千偈经。并请得北天竺大乘三果菩萨禅师名佛驮跋陀罗此云觉贤。俗姓释迦氏。即甘露饭王之苗裔。曾往兜率天就弥勒。问疑。以晋义熙十四年岁次鹑火三月十日。于扬州谢司空寺别造护净法堂于中译出此经。时堂前有一莲华池。每日有二青衣童子。自池之出堂洒扫供养。暮还归池。相传释云。以此经久在龙宫龙王庆此传通躬自给侍。后因改此寺名为兴严寺。沙门法业及慧严慧观等亲从笔受。时有吴郡内史孟顗右卫将军褚叔度等为檀越主。至元熙二年六月十日出讫。至大宋永初二年十二月二十日。与梵本再校勘毕于法界品内从摩耶夫人后至弥勒菩萨前所阙八九纸经文。今大唐永隆元年三月内有天竺三藏地婆诃罗。唐言日照。有此一品梵本。法藏亲共校勘至此阙文。奉敕与沙门道成复礼等译出补之

九支流者。谓此大经随力受持分成多部。兜沙经一卷是第二会初。菩萨本业经一卷是净行一品。小十住经一卷是十住品。大十住经四卷。渐备一切智德经四卷。并是十地品。如来性起微密藏经两卷是性起品。显无边佛土经一卷是寿命品。度世经六卷是离世间品。罗摩伽经三卷是入法界品。近于神都共于阗三藏翻华严修慈分一卷不思议境界分一卷金刚鬘分十卷。此分翻未成三藏亡殁。今现于神都更得于阗国所进华严五万颂本并三藏至神都现翻译。其慈恩寺梵本与旧汉本并同无异。新来梵本品会及文句有少不同。明此大经数本故也。此并大经支流随器分流

第十感应者。宋主请西来三藏令讲此经。其人恨以方音未通恐说不尽旨。乃入道场祈请才盈七日。遂梦以汉首易己梵头。因即洞解宋言讲授无滞。又九陇山尼敬重此经。专精转读二十余载。遂感目睹毛端刹海。又五台山尼常诵此经。从曛至晓一部斯毕。口中光煇遍耀山谷。又北齐炬法师崇重此经阙于师受。专读祈解。十五余年遂梦善财授聪明药。因即开悟造疏十卷。讲五十余遍。又定州中山修德禅师翘诚护净钞写此经。后开函放光照一百二十里。又阉人刘谦之因于五台山专读此经。遂复丈夫形。诸如此例事极繁广具如五卷华严传中说

第九显义理分齐者。然义海宏深微言浩汗。略举十门撮其纲要。一同时具足相应门。二广狭自在无碍门。三一多相容不同门。四诸法相即自在门。五隐密显了俱成门。六微细相容安立门。七因陀罗网法界门。八托事显法生解门。九十世隔法异成门。十主伴圆明具德门。然此十门同一缘起无碍圆融。随有一门即具一切。应可思之

就初门中有十义具足。一教义具足。二理事。三境智。四行位。五因果。六依正。七体用。八人法。九逆顺。十应感具足。谓众生机感如来应赴。下云。一切众生所乐示现云。然此十对同时相应为一缘起。随一各具余一切义。如初门既尔余广狭等九门皆各具前十对。但随门异耳。是故一一门中各有十百千等。思之可见。今且于一事法之上辨此十对。余可准知。如下文中。一莲华叶表令生解为教。即是所诠为义。如下胜音菩萨莲华处说。二华相为事。华体是理。下云。法界不可坏莲华世界海。三华是所观亦即能观。以此经中可以内行为外事故。四行事之华结成位故。五因事之华揽成果故。六华台所依亦入正故。如国土身等。七华体同真用应机故。八全揽为人恒是法故。九逆同五热顺十度故。十应赴群机亦能感故。如一华事既尔余一切事皆准知之。事法既尔余教义等一切皆然。准思可见。如具自十对既尔彼一华叶具前十门亦然。何者此莲华叶具前十义同时相应具足圆满故。是初门也

二即彼华叶普周法界而不坏本位。以分即无分无分即分广狭自在无障无碍。下云。此大莲华其叶遍覆一切法界。是故或唯广无际。或分限历然。或即广即狭。或广狭俱泯。或具前四。以是解境故。或绝前五。以是行境故。下皆准此

三即此华叶舒己遍入一切法界中。即摄一切令入己内。舒摄同时既无障碍。是故镕融。或有四句六句。准前思之。下云。以一佛土满十方十方入一亦无余

四此一华叶废己同他举体全是彼一切法。而恒摄他同己全彼一切即是己体。一多相即混无障碍。解行境别六句同前。下云。知一即多多即一等

五华能摄彼即一显多隐。一切摄华即一隐多显。显显不俱隐隐不并。隐显显隐同时无碍。全摄俱泯存亡俱成。句数同前。下云。东方见入正受西方见三昧起等

六此华叶中微细刹等一切诸法炳然齐现。下云于一尘中微细国土旷然安住

七华叶一一微尘之中各皆并现无边刹海。刹海之中复有微尘。彼诸尘内复有刹海。如是重重不可穷尽。非是心识思量所及。如帝释网天珠明彻互相影现影复现影而无穷尽。下文如因陀罗网世界等

八见此华叶即是见于无尽法界。非是托此别有所表。下云。此华盖等从无生法忍所起等

九即此一华既具遍一切处。亦复该一切时。谓三世各三。摄为一念。故为十世也。以时无别体依华以立。华既无碍时亦如之。是故下云。过去一切劫安。置未来今。未来一切劫回置过去世。又云。无量劫即一念一念即无量劫等

十此圆教法理无孤起。必眷属随生。下云。此华有世界海尘数莲华以为眷属。又如一方为主十方为伴余方亦尔。是故主主伴伴各不相见。主伴伴主圆明具德。如一事华带自十义具此十门即为一百门。余教义等亦各准之故成千门。如教义等望自类十义及同时等十门有此千门。彼同时等亦望自类十门及教义等亦成千门。准思可见

问有何因缘令此诸法得有如是混融无碍。答因缘无量难可具陈。略提十类释此无碍。一缘起相由故。二法性融通故。三各唯心现故。四如幻不实故。五大小无定故。六无限因生故。七果德圆极故。八胜通自在故。九三昧大用故。十难思解脱故

初缘起相由故者。谓大法界中缘起法海。义门无量。约就圆宗略举十门以释前义。谓诸缘起法要具此十义方缘起故。阙即不成。一诸缘各异义。谓大缘起中诸缘相望要须体用各别。不相和杂方成缘起。若不尔者诸缘杂乱失本缘法缘起不成。此即诸缘各各守自一也

二互遍相资义。谓此诸缘要互相遍应方成缘起。且如一缘遍应多缘各与彼多全为一故。此一即具多个一也。若此一缘不具多一即资应不遍不成缘起。此即一一各具一切一也

三俱存无碍义。谓凡是一缘要具前二方成缘起以要住自一方能遍应遍应多缘方是一故。是故唯一多一自在无碍。由此镕融有六句。或举体全住是唯一也。或举体遍应是多一。或俱存。或双泯。或总合。或全离。皆思之可见。此上三门总明缘起本法竟

四异门相入义。谓诸缘力用互相依持互形夺故。各有全力无全力义缘起方成。如论云。因不生缘生故。缘不生自因生故。若各唯有力无无力即有多果过。一一各生故。若各唯无力无有力即有无果过。以同非缘俱不生故。是故缘起要互相依具力无力。如阙一缘一切不成余亦如是。是故一能持多一是有力能摄多。多依于一多是无力潜入一。由一有力必不得与多有力俱。是故无有一而不摄多也。由多无力必不得与一无力俱。是故无有多而不入一也。如一持多依既尔多持一依亦然。反上思之。是即亦无多不摄一一无不入多者也。如一望多有依有持。全力无力常全多在己中。潜已在多中。同时无碍。多望于一当知亦尔。俱存双泯二句无碍思准之

五异体相即义。谓诸缘相望。全体形夺有有体无体义。缘起方成。以若阙一缘余不成起。起不成故缘义即坏。得此一缘令一切成起。所起成故缘义方立。是故一缘是能起。多缘及果俱是所起。是即多为一成多是无体。一能作多一是有体。由一有体必不得与多有体俱。多无体必不得与一无体俱。是故无有不多之一无有不一之多。一多既尔多一亦然。反上思之。如一望多有有体无体故能摄他同己废己同他同时无碍。多望于一当知亦尔。准前思之。俱存双泯二句无碍亦思之可见

六体用双融义。谓诸缘起法要力用交涉全体融合方成缘起。是故圆通亦有六句。一以体无不用故举体全用。即唯有相入无相即义。二以用无不体故。即唯有相即无相入也。三归体之用不碍用。全用之体不失体。是即无碍双存。亦入亦即自在俱现。四全用之体体泯。全体之用用亡。非即非入圆融一味。五合前四句同一缘起无碍俱存。六泯前五句绝待离言冥同性海。此上三门于初异体门显义理竟

七同体相入义。谓前一缘所具多一与彼一缘体无别故名为同体。又由此一缘应多缘故有此多一。所应多缘既相即相入令此多一亦有即入也。先明相入。谓一缘有力能持多一。多一无力依彼一缘。是故一能摄多多便入一。一入多摄反上应知。余义余句准前思之

八同体相即义。谓前一缘所具多一。亦有有体无体义故亦相即。以多一无体由本一成多即一也。由本一有体能作多令一摄多。如一有多空既尔多有一空亦然。余义余句并准前思之

九俱融无碍义。谓亦同前体用双融即入自在亦有六句。准前应知

此上三门于前第二同体门中辨义理竟

十同异圆备义。谓以前九门总合为一大缘起故。致令多种义门同时具足也。由住一遍应故有广狭自在也。由就体就用故有相即相入也。由一摄多时为显。令一入多为隐。多摄一入亦尔。又就用相入为显。令就体相即为隐。显入隐亦然。又异门即入为显。令同体为隐。同显异隐亦尔。又由以异门摄同体中相入义故现微细门也。由异体相入带同体相入故有重重无尽帝网门也。由此大缘起法即无碍法界法门故有托事显法门也。由此融通自在。今依此法上所辨时法亦随此无碍自在故有十世门也。由此法门同一缘起相带起故。随一门必具一切故有主伴门也。此之一门于前第三门中以辨义理。上来十义总是缘起相由门竟。余门如指归中说

华严经探玄记卷第一华严经探玄记卷第二(尽世间净眼品)

        魏国西寺沙门法藏述

第十随文解释者。今此三万六千偈经有七处八会。谓人中三处天上四处为七。重会普光为八会。于中有三十四品。初一品是序分。卢舍那品下明正宗。流通有无以四义释。一以众生心微尘下二颂为流通。以结叹劝信故。二为经来不尽。阙无流通。三为此经是称法界法门说故总无流通。问若尔何得便有序分。答以有见闻通趣入故有始为序。以所入无极故无终流通。如修生佛果有始无终。若不尔者何故八会一一会末皆无流通。大般若经十六会中彼会会后皆别有流通。大集经中诸会末皆亦有。之此经不尔。故知别意有所表也。四以余三乘等法逐机差别利益众生为流通益相。又大远法师分此经为四分。初品名缘起净机分。二舍那品名标宗策志分。三名号品下至第八会来名显道策修分。四末后普贤所说偈名属累流通分。今更寻下文总长分为五。初品是教起因缘分。二舍那品中一周问答名举果劝乐生信分。三从第二会至第六会来一周问答名修因契果生解分。四第七会中一周问答名托法进修成行分。五第八会中一周问答名依人入证成德分。流通有无以如上辩。此五分皆依前起后文次相生义理周足。是故不增减也。就初序分之中分为二。初明此土中序分。二明十方无尽世界中序分。初中有三。初有四字唯是证信。二一时下通二序。三动地下唯是发起。若通后说得有四句。或唯证信是初。或唯发起是后。或俱是中间。或俱非是下正宗。又初四字义通而文局。以文在初首义通八会故。一时下文通而义局。以下诸会皆有尔时等故文通也。今此局初故义局也。又依佛地论分为五。一总显已闻。二教起时。三显教主。四教起处。五教所被机。依法华论等有六成就。一信。二闻。三时。四主。五处。六众

今释此义略作四门。一明此六义安立所由。二辨闻之亲传。三定传法之人。四释文

初中立此六句。所由有六。一佛教安立。依智论佛临涅槃告阿难。十二部经汝当流通。复告优婆离。一切戒律汝当受持。告阿那律。汝得天眼常守护舍利劝人供养。告大众。我若住一劫若减一劫会亦当灭。语已双林北首而卧欲入涅槃。阿难亲属之爱未除。心没忧海。阿泥卢豆语阿难。世尊今日虽在明日即无。汝宜问彼未来要事何因同彼愚人如是闷绝。阿难即起问言。我今不知请问何事。卢豆教云。要事有四。一问如来在世亲自说法人皆信受。如来灭后一切经首当置何言。二问如来在世诸比丘等以佛为师。如来灭后以何为师。三问佛在世时诸比丘依佛而住。如来灭后依谁而住。四问如来在世恶性车匿佛自治之。佛灭度后云何共住。阿难如教请问。世尊答云。经首当置如是等六句。二云比丘皆以波罗提木叉为师。三云皆依四念处住。四恶性比丘以梵檀治之。此云默摈。若心耎伏为说迦旃延经。此云离有无经。破我慢心也。又如大悲经中阿难请佛。云何结集法眼。佛告阿难。我灭度后大德比丘应如是问。世尊何处说大阿波陀那等经。汝应如是答。如是我闻一时在摩伽陀国菩提树下初成正觉说法。乃至云娑罗双树间说法。如是等二十余处所说之经。佛自重教阿难结集。是故此六句佛教立也。二为断疑故安此六句。如真谛三藏云。依微细律阿难当升高座结集法藏之时。其身如佛具相好。若下座时还复本形。众见此瑞还生三疑。一疑佛大师慈悲从涅槃起更为众说法。二疑佛仙从他方来。三疑阿难转身成佛。今为除此三疑故安六句。是故阿难自称如是之法我从佛闻。明知非是佛重起说。亦非他方佛来。又非阿难自身成佛。但以法力令我似佛故也。三为未来生信故。智论云。一切经初置时方人等者。欲令生信心故。四离增减过故。佛地论云。应知说此如是我闻意避增减异分过失。谓如是法我从佛闻。非他展转显示闻者。有所堪能诸有所闻皆离增减异分过失。非如愚夫无所堪能诸有所闻或不能离增减异分。结集法时传佛教者依如来教初说此言。为令众生恭敬信受。言如是法我从佛闻。文义决定无所增减。是故闻者应正闻已如理思惟。当劝修学。五为息诸诤论故。若自制作则诤论斯起。故不然也。此依智论辨。六异外道故。彼外道经论或云石崖崩得。或云青雀衔来。故不可信也。是故今具显委曲明法非谬令人信受

第二明阿难等亲闻传闻不同者。若依小乘有二说。一云阿难既是佛得道夜。生年二十方为佛弟子。其二十年已后经是亲闻。已前是传闻故转法轮经云。阿难结集时自说偈云。佛初说法时尔时我不见。如是展转闻。佛游波罗捺为五比丘众转四谛法轮。故知已前非亲闻也。二云皆是亲闻故。萨婆多论云。阿难为佛作侍者时请愿言。愿佛二十年中所说之经尽为我说比尼母论亦同此说。故知总是亲闻。若依大乘一切皆亲闻有二义。一佛重为说。如胜鬘经等佛还本处重为阿难说。又如上大悲经中佛总重说。故是亲闻。二阿难常闻故。涅槃经云。阿难多闻士。若在若不在自然能解了常与无常义。又云。阿难得觉意三昧佛所说经近远常闻

三定传法人者。问说此经时二乘人等并如聋盲。岂得阿难而称我闻。答有二义。一设是阿难此亦无过。何者依阿阇世王忏悔经有三种阿难。一阿难陀。此云庆喜。持声闻法藏。于上二乘随力随分。二名阿难陀跋陀罗。此云庆喜贤。持中乘法藏。于上大乘随力随分。于下小乘容预兼持。三名阿难陀娑伽罗。此云庆喜海。菩萨持大乘法藏。于下二乘容预兼持。准此经文阿难海是大菩萨能持大法。理亦无违。若依圆教并是卢遮那佛海印三昧内现此传法人等故。即是佛也。二云非是阿难所传。理亦无违。何者智论云。一显示教。二秘密教。此大品经是显示教故付嘱阿难。如法华经是秘密教故付嘱喜王等。又涅槃经云。阿难所未闻经弘广菩萨当为流通。准此是弘广菩萨称如是我闻。又准智论是文殊师利称我闻。以彼论云文殊与阿难在余清净处结集摩诃衍藏。又文殊师利般涅槃经中。佛般涅槃后四百年时文殊师利犹在世间。故知是彼传此法也

第四释文。依智论如顺也。是信也又是印也。即印顺信受故言如是。如是总举一部文义。谓指己所闻之法。故云如是。依长耳三藏约三宝释。一约佛云谓如佛所说是我所闻。如我所闻是佛所说。二约法云如我所闻是称理之说。如称理之教是我所传。三约僧云如我所闻是诸菩萨之所同闻。如诸菩萨之所同闻是我所传故也。依佛地论云传佛教者言如是之事我昔曾闻。如是总言依四义转。一依譬喻。二依教诲。三依问答。四依许可广释如彼论。中我者谓五蕴假者。泛论我有四种。一真我。谓真如中常乐我净等。真如为性。二自在我。谓八自在我等。以智为性。三假我。谓五蕴假者。以唯识所现似有主宰等以其为性。四执我。谓分别俱生所执为性。又缘我之心亦有四种。一见。谓诸凡夫等。二慢。谓诸学人。三习。谓无学人。四随世流布。谓诸佛。此中我者于前四中通有初三。约教准之后四中唯一。亦可通后三。思准之。何故不说无我而说我耶。谓显亲闻故。语便故。随世间故。显无我故。并如智论说也。问传法者何故不自称名而言我耶。答有滥同名失故。问我岂不通耶。答已称我定属自故简别他故。问何不言耳闻。答以总收别故。问耳但闻声。岂能解耶。答耳闻其声。意解文等。和合无二从亲说闻。萨婆多根闻。成实识闻。智论和合闻。即空无作也。涅槃云。四因缘和合故闻。一耳根不坏。二声在可闻境。三中间无障碍。四有欲闻故得闻。是故此闻则不闻闻也。又具十缘。一本识为根本依。二耳识种子为因缘依。三末那为染污依。四意识为分别依。五自类耳识为等无间依。六耳根不坏为同境根。七作意欲闻。八有境为所缘缘。九中间无障碍。十境近在可闻亦通余法不碍等。是故此闻无自性故不闻闻也。约教准辨之。一时以下通二序。即是六句之内后四句。于中初三同辨。谓时主及处。后一别辨。谓同闻众。此亦即是三世间相应知。前中亦二。先通标三相。后始成正觉下别释三义。何故有此二门者。谓约处前则通举染净。后则别显净相。又前寄染后别辨净。又以时有始终处有染净佛有浅深故。须重料简也

前中三。初一时者依佛地论或一刹那或多相续但取说听究竟。是故总名假立一时。小乘实时。大乘假说。若别释梁摄论一时有三义。一平等时。谓无沉浮颠倒故。二和合时。谓令闻能闻正闻。三转法轮时。谓正说正受

二佛者觉义有二。谓本觉始觉。又论云。如莲华开如睡寤等。此初觉所知后觉烦恼。或三觉谓自他满即有觉之者名为觉者。或名婆伽婆。有四义如智论中。一名有德。谓婆伽名德婆名有故。二巧分别。婆伽名分别婆名巧故。三名有名声。婆伽名声婆名有故。四名能破淫怒痴。婆伽名能破婆名淫怒等故。此四中初一总后三别。别中初智德次福德后断德。又佛地论有六义释。彼颂云。自在．炽盛．及端严．名称．吉祥与尊贵具斯六种。义差别。是故总号为薄伽。广释如彼。又真谛三藏引真实论有十义释。佛谓觉胜天鼓等(云云)。三处者国通场别。智论云。于摩伽陀国尼连禅河侧区楼频螺聚落中得阿耨菩提等。此名不害国。以此国中诸有犯罪唯有摈罚无有刑戮故。托此表示大法慈济之相也。或名善胜国。或云摩伽是星名。此云不恶。主十二月。陀者处也。名为不恶处国。亦名星处国。寂灭有四义。一障灭谓性灭及治灭。二证灭理故。三显其灭德谓示佛十身及普贤等法。经云。大般涅槃能建大义故。四益物成灭故。可知。道场亦四。一事处。二行。如经施是道场等。三理。如维摩经一切法是道场知诸法空故等。四通一切法。谓人法等一切准之。皆得道之处名道场。依主释。亦如世谷场简去秕秽而择取真实。此中亦尔。灭惑成德。亦得道即场故持业准之。事场者如俱舍论云。于剡浮洲中央从金刚地上起金刚座彻剡浮洲地与上际平。一切菩萨皆于中修习金刚三摩地。何以故。更无余依止及能堪受此三摩地。一切菩萨者谓贤劫千菩萨也始成正觉下第二别料简上三义。初料简时。二处。三主时中且作五门。一定分齐。二摄前后。三显差别。四表示法。五释本文。初定分齐者。菩提流支云。华严八会中前之五会是佛成道初七日说。第六会后是第二七日说。以十地经初云第二七日故。又有人说。第八会是后时说。以彼文中有鹙子等五百声闻并后时度故。此等所判恐不顺文。以初七日定不说法。十地论云。何故不初七日说。思惟行因缘行故。既言思惟。明知非说法。设有救言只不说十地非不说余法者。则不得言思惟也。下论又释。为显己法乐是故不说。故知初七定非说耳。又第八会亦非后时。何得于一部经前已说半中说余经后方更续。岂令佛无陀罗尼力不能一念说一切法。祇园鹙子并是九世相入。下文云过去一切劫安置未来今。未来一切劫回置过去世。又云。于一念中建立三世一切佛事。乃至广说如是等文处处皆有。岂可所用鹙子祇园而非此类。是知此经定是第二七日所说。二摄前后者。有三重。一于此二七之时即摄八会同时而说。若尔何故会有前后。答如印文读时前后印纸同时。问若尔云何重会得成。答重亦同时以无碍故。如灯光相入等。余不动升天等准释可知。二即于此时摄彼前后。各无量劫无不皆尽。以是不思解脱时故。三摄于重重无量念劫。如因陀罗网重收摄故。三显差别者。依普曜经第二七日于鹿野园为彼五人三转四谛。此是小乘。依密迹力士经第二七日鹿园为于无量大众转法轮时有得罗汉辟支菩萨道等。此是三乘。依此经第二七日于树王下为海会菩萨转无尽法轮。明是一乘。上三同时者约法表本末同时。约人显机感各异。依法华三七日。四分律六七日兴起行经七七日依五分律八七日。智论五十七日。十二游经一年方说。此并末教机异。宜闻各别故致不同。本教机定故唯二七。四表示法者。十地论云。时处等校量显示胜故。此法胜故。在于初时及胜处说。此有三义。一此经约初时表本法胜故。二末教亦同表末不离本故。三显本非末故。末时不定本时定故。时定二七更无异说。第五释文者。始成正觉者意显初始之义。然有二相。一初七日是现世之始。二第二七日是说法之始。此中是成正觉来经今七日故云始成正觉也。通有五义。一约小乘。以生身佛于此树下三十四心初成正觉同诸罗汉实成非化。二约大乘。八相化身示现于此初成正觉。三约报身。十地行满无间道后果现圆明名初成正觉。四约法身。谓创得了因最初圆现。故曰初成。此上大乘并无初之初。五约十佛。谓遍一切因陀罗网无边世界。念念之中皆初初成佛。具足主伴。尽三世间。是故此即具摄前后无量劫初也。此中正唯第五兼摄前四。准可知。以此五重不相离故。摄方便故其地金刚下第二别料简处。于中亦作五门。一定其处。二辨摄入。三显差别。四表示法。五释本文。初定处者。问说此经处为是净土。为是染界。设尔何失。二俱有过。何者若是净土。何故上文云摩竭提国。下文复云如此四天下阎浮提等。由此当知。非是净土。若染土者。何故下文此莲华藏世界海六种十八相震动等。明知此经非染土说。如此相违云何指定。答但依此经染净二土镕融相摄有其四句。或唯娑婆。以本从末故。或唯华藏。以末从本故。此二如上辨。或双现。以依华藏而有娑婆染净相分。末依本故。如下文云华藏界中娑婆世界。此之谓也。或染净双绝。以就果海不可说故。此上四门合为一土。镕融无碍随说皆得。第二辨摄入中。初明融摄者亦有三重。一此觉树下即摄八会人中天上。是故皆云不离此也。二摄十方。无余刹土皆悉不离此树王下。三摄毛端微尘内等重重之刹。犹如帝网无有穷尽。以皆是此莲华藏界之所摄故。二融入亦三。谓融此觉树入前三重所摄处故。第三显差别者。然佛说经处有三种。一唯界内十六大国化身说处。此通小乘及三乘教。二唯界外诸妙净土十八圆满受用土中报佛说处。如佛地经等。此妙净土非三界摄而亦不离。以遍一切处故。此通三乘及一乘说。三染净圆融帝网无尽莲华藏界十佛说处。依正浑融具三世间。此唯别教一乘说处。今此所辨正唯后一。兼摄前二。以彼本末不相离故。第四表示法者。托此胜处表示法胜。地论云。此法胜故在胜处说。然有三重。一此树下得菩提故。不起此说。明表所说如所得故。非逐异机有改动故如鹿园说等。二托圆融莲华藏界表示所说圆满殊胜性开敷故。三托此重重帝网之处表示所说亦重重无尽。如不思议解脱等。余义如下世界章说。第五释本文者。文中有三。初明道场地。二地上有菩提树。三树下有师子座。此则地为行所依本。树为行德建立。座为行用摄益。如缘起性各全融摄法无不尽。然此三位文中各以十门分别

初释场地中有标释结。标中其地金刚标其地体。谓体无不坚。下文言金刚厚地不可破坏。此之谓也。具足严净标其地德。谓相无不严。即下文中莲华藏界地下具摄风轮香海莲华王等以为严净。地上具有妙宝光明香河树网。如是上下净德圆备故云具足。此则垢无不尽曰净。德无不满曰严。二别释中十句。显十种严净。一宝华严净。二宝轮严净。三妙色严净。四幢等严净。五香鬘严净。六宝网严净。七雨宝严净。八华树严净。九佛力严净。十奇特严净。具此十种故云具足严净。初宝华严净者。谓众宝杂华具四义故。一微妙义。二开敷义。三出果义。四严净义。下文言。宝华遍覆一切地悉能长养佛功德。二宝轮严净者。谓此宝轮具足五义故。一圆满义。离缺减故。二摄德义。辐辋等具故。三转动义。从此向彼故。四摧惑义。如碾碎等故。五降伏义。如圣王轮宝故。又宝是可贵义。下文言。宝华成妙色庄严光明轮。充满诸法界。十方靡不遍。三色相严净。谓此妙色具四义故。一炳着义。具形显故。二即空义含虚而立故。三具德义。一摄一切故。四有用义。众生见闻获胜益故。此类多端。故云无量无不交饰。故云庄严。谓此器海深而且广。蕴德包含润益无边故云如海。大海十相于此应辨。下文世界海名从此而立。四幢等严净。谓幢旙盖光四义别故。幢有二义。一高出。二降伏。如帝释幢。幡有二义。一幖帜。二随缘盖。亦二义。一显胜。二荫覆光。亦二义。一除闇。二照现。下文云。于宝幢中有光明。垂宝旗幡而庄严。五香鬘严净。谓妙香是芬馥义。妙华是开敷义。妙鬘是贯穿义。以此三事遍布周围以成供养。又亦以妙香之华穿以成鬘。垂幢四面以成庄严。下文云。悬杂华鬘为庄严。六宝网严净。网是隐映庄严。下文云。宝轮罗网弥覆其上。依称赞净土经七宝者。一金。二银。三吠琉璃。四颇胝迦。五赤真珠。六阿湿摩揭拉婆。七牟娑陀揭拉波。七雨宝严净。谓所雨广多无不皆成法门之用。故云自在。即现身说法此之谓也。八宝树严净。谓众德建立义也。下文云。清净宝树云庄严。普能照明一切身。故光茂也。九佛力严净。谓佛神力故者举其所因。令此等者辨其所成。一令体广。二相严。三用照。下文云。一切世界海有无量庄严宝轮无边色。如来神力起。十奇特严净。依智论宝有三种。一人宝。如轮王珠宝能雨物之用。二天宝。谓诸天所有并堪使唤。三菩萨宝。堪令说法度人。今此菩萨宝望前人天已为奇特之宝。况如来所有无尽善根所生之宝并甚奇特。以即是法门复是事宝故也。下一句总结。以善根无限量故。出生严具。亦无限量故。云无量善根庄严道场。又亦以此善根即用庄严。如下文云百万亿波罗蜜云及善根云等以严宝座。今亦同彼故也。无量者。下文云。卢遮那佛过去行令佛刹海甚清净。无量无数无边际彼一切处自在转。余义至后品中广明。此中亦有总别同异成坏六相。可准通之。场地竟

第二觉树中亦十句。初一总句。菩提树有三释。谓邻近依主及持业。以圆教中依正无碍人法相是故。得菩提即树也。高出六天显曜十方。故云殊特。此是总句也。下以九句别显殊特。一干殊特。谓是树身明净坚固义故。云净琉璃等。二枝殊特。谓树枝[條-(仁-二)+彳]是方便随机差别义故。云宝枝等。三叶殊特。谓枝[條-(仁-二)+彳]头叶是荫机成益义故。云宝叶等重(平声)云是龂齶义。又重(上声)云是叆叇义。四华殊特。是众行绮饰义。即益所成行故。云杂色等。五果殊特。是行成感果义。如意者。一如能化意平等救故。二如所化意求皆得故。摩尼是珠宝通名。简通取别故。云如意摩尼。又此上五句成一树体。谓净法界如地。显现佛身如地生树。随机见异如树枝分。见无不益如叶成荫。由益成行如树花敷。行满得果如树生果。此约起化摄生现于佛树。又释。本识如地。识中菩萨种姓如树子。发菩提心如生树芽增修正行如长养树身。随位造修如树分枝。此约自行。荫覆利他如树叶荫。自他二行交饰如华。因圆果现如树成果。此约修行次第。以成佛树。此上五句明树体摄众德。下有四句。明此觉树妙用自在。谓第六句显光殊特。谓光用遍至。七化现殊特。谓随所至处现作佛事。以无际故不可极。即一切处也。无休故不可尽。即一切时也。八法殊特。谓于诸处作何佛事。普现大乘菩萨道教。以是阿含光明故能现法。又此上三句如其次第是身意语三业所摄。九佛力殊特。谓佛力加持出音赞德。若不树中自出音赞世人无有能知如来胜功德者。此十句中六相总别可准知之。觉树竟也

第三宝座殊胜。于中亦有十句。初一是总。依智论佛为人中师子。佛所坐处若床若地皆名师子座。王坐处亦尔。又坐此座说于无畏师子吼法。是故亦名师子座。下离世间品明十种座。中师子座。分别演说甚深义。此上皆依主释。或亦持业释。以依正浑融故。又以此座苞含法界。人法教义一切法及彼十方诸佛世界深广殊特故。云不可思议谓如大海。下以九句别显不思议。一严饰不思议。谓体摄众德故云众妙宝华等。二流光不思议。谓妙用无方如云普遍故云流光等。三含摄不思议。谓内含无数菩萨大海故云藏也。四语业不思议。谓大音远振成益难量故云不思议。又此上三句随其所应。是身意语三业用也。五加持不思议。谓虽此座流光普照。然佛光明重更弥覆。显殊胜故。以摩尼珠光可有照及四十由旬覆轮王宫。今佛光明遍照法界。弥覆此座。超过彼量故。云踰摩尼等。六变化不思议。谓化用开觉故。云作佛事。七应机不思议。谓十方根熟一切悉睹。一座普应无所挂碍。八迅速不思议。谓一念者时极促也。一切化者所现多也。充法界者极深广也。于此一念能现一化已为希有。况现一切。能于一念化现一切已甚希有。况诸所现一一深广充满法界。于一念顷迅速起此无边大用。余念念中皆亦准此。九真性不思议。谓如来藏体普遍故。令前妙用速成无碍。又此上四句明此座用。次第相由。初有何相。二云何应。三如何速。四由何成。如次四句答此四问应知也。下一句总结。以别说难周故。结云无量众宝等。以座高显故亦称台。问此师子座有何义理名不思议。答既名不思议。义实无尽。略论十种。谓不可有分思。以同法界故。不可无分思。为机现故。不可以理思。宝华事严故。不可即事思如来藏性故。不可依报思。以菩萨等所成故。不可正报思。是佛依果故。不可以人思。所依法摄故。不可以法思。具有三业为人用故。不可以果思。具有因位诸菩萨故。不可以因思。佛果所有故。此上十义无碍相即。谓一座是总相。十义是别相。齐是座义是同相。十义不杂是异相。由此十义令座法起是成相。各住自法是坏相。问既云为机现故。非无分量。未知其量分齐若为。答然亦难知。但可比况辨之。如地品说。十地菩萨座量周围如十阿僧祇百千三千大千世界之量。以此座量比如来座。其犹以豆许土比大千世界。是如来座量极难量也。上来三段总明器世间圆满竟

自下第三明智正觉世间圆满。于中略作五门料简。一定佛身。二明融摄。三显差别。四表示法。五释本文

初定佛身者。问此八会佛是何等身。答有人释云。是化身佛。以菩提树下八相成道是化身故。不离升天是重化故。以释迦异名名卢舍那非别报身故。又有释云。说此经佛是实报身。以是卢舍那法界身故。居莲华藏净土中故。下第七会初叹佛具彼二十一种殊胜功德。是实报也。但以不离化故该此树下非是化身。今释。此佛准下文中是十佛之身通三世间。以说十信及三贤等地前所见非实报故。然居华藏非局化故。国土身等非前二故。具摄前二。性融通故具足主伴。如帝网故。是故唯是周遍法界十佛之身

第二融摄者有二。一直摄一切三世间尽。以具此三事方为佛故。三身二身但是三中智正觉摄。妙净土及同生之身无不皆是此中所摄。二亦正报毛孔。依报尘中。各重重具摄三世间等一切诸法如帝网现。准思可见

第三显差别者。此一释迦身随应群机差别多种。或同凡而非圣。如见三尺黑象脚身及树神身等。此在人天位。或是圣而非凡。以同罗汉圣人身故。或亦凡亦圣。以是父母所生实报身故。四大成故。同凡身也。具五分法身诸流尽故。是圣也。或非凡非圣。以是大乘三身摄故。非同小乘罗汉圣故。或是化非法报。以具八相在阎浮故。色顶别立彼实报故。如梵网经等说。此约初教。或是报非法化。即此身具二十一种殊胜功德。受用身故。如佛地经初说。此约终教。或是法非报化。以色即如故。经云。吾今此身即是法身。此约顿教。或亦法亦报化。如前三说故。或非法非报化。以是十佛故。通三世间故。具足主伴故。如此经下文说。此约圆教。是故此释迦身圆融无碍极难思也

第四表示法者。然说法之佛总有四位。一同罗汉身。以表说小乘法故。二化身佛。表说三乘。广说地前略说地上。三报身佛。表说三乘。广说地上略说地前。四十身佛。表一乘法。六位齐说。以此所说具足主伴无尽法故。佛亦同此十身无尽

第五释文者。文中释此智正觉义还以十门。初一总余九别。总中先身安宝座。故云如来处此等。后智契真原。故云于一切法成最正觉。又如来者。地持论云。言语所说不乖于如故名如来。又转法轮论云。第一义谛名如。正觉名来。正觉第一义谛故名如来。又经云。乘六波罗蜜来成正觉故名如来。又论云。乘如实道来成正觉。问此既出障得名如来。何不在缠名为如去。答亦有是义。故经云。法身流转五道名曰众生。既云流转。当知有去。或亦无去。以虽在缠而不动故。问若尔出障不动应无有来。答净法顺真从真所起故得有来。染法违理是妄法故不得有去。或亦无来。以始觉同本觉故。既无始觉之异。是故无来。故经云。如来者无所从来亦无所去。故曰如来。又一切法者所觉二谛之法。最正觉者能觉之妙智。以菩萨亦有随分正觉。然位未极。不得称最。今就至极名最正觉。下以九门别显如来成正觉之义。谓于如来一法界身随缘显现有三重三业。初有三门。明平等三业自在摄生。二其身遍坐下明摄生三业成益非虚。三悉能普现下明成益三业即用归如。就初中先明身业。于中有二。初句明平等身业。次普入下辨摄生身业。又上句显深下句明广。又上明不即三世。故云平等。下辨不离三世。故云普入。又初不变义。后随缘义。又初体。后用。又了谓照了。三世法者显前一切法也。平等者一了知过未等于现在。故云平等。此约俗境。二了知三世迁流之法泯归一实无三之异。故云平等。此约真境。文意在此。斯则不住事而入理也。普入等者是不住理而随事也。又前则不坏事而显理。理而非事。后则不乖理而随事。事而非理。理事镕融二而不二无障无碍。二句显示与余功德作依止义是身义次明平等语业妙音遍至者明如来圆音如缘起性遍一切处而亦不坏别别诠表。若由等遍失其音曲。则圆非音。若由音曲乖其普遍。则音非圆。今则不坏曲而等遍。不动遍而差韵。是谓如来圆音。非是心识思量境界。如虚空有五种义。似佛圆音故以为喻。一周遍义。譬佛圆音周遍法界无处不至。犹如目连远寻佛声不得涯畔。二平等义。谓空虽普遍体恒无二。况佛圆音平等一味。三无碍义。谓此虚空无所障碍。譬佛圆音随根生熟闻与不闻俱无障碍。四对现义。谓一切众生皆谓虚空对其前而空无现前。圆音亦尔。随种种机别别独闻而音无彼此。五含受义。谓此虚空苞含容受诸色法故。圆音亦尔。含摄所诠诸法义故。余义如下性起品说。下意业中二。先明平等意业。等心下明摄生意业。又初理后量。又先智后悲。又二利无住缘。相融无二相故。又平等法相犹是佛智游履之所故云行处。如空者喻此行平等之法。又以境智相如能所俱泯如空无碍故。一味故普遍故含摄故有用故。又或唯境如空。或唯智。或俱。或不俱。思以准之。又释。佛果戒等功德称同真性。故云平等。唯佛智所知故云智行处。然无分限故如虚空。佛地论第四云。如契经言。乃至所有施设譬喻喻诸如来所有功德。一切皆是谤诸如来。唯除一喻。谓虚空喻。如来戒等无量功德同虚空故。乃至广说。下句等心随顺众生者有四义。一无思益物故云等心。二等被圆教。三等授极果。四等达其性不碍摄化。此则是前如空之德堪以摄生。故云随顺。上来平等三业竟

第二摄生三业成益不虚。于中初一句总标就机。谓其身遍坐具三业故。一切道场者有三类。一遍一切须弥山界。二遍一切树形等界。三遍一切尘道。重重如帝网界。故下文云。是虚遮那佛常转法轮处。又下结通皆依此文。别中初二句先明意业。一摄生意业。谓了知根器故云悉知一切等也。二明成益不虚。谓以慧日破众生痴闇故云智慧日等。次有三句明身业。一依土现身故云悉能等。二依身放光。一光体通三际故云三世光。二光照三世境亦云三世光。皆从智慧大海中出故云智海光明。所照机境熟故名净。无量光明者光摄眷属。又亦多故无量。又照净显深。无量明广。次二句明语业。初明实教无改动故云不坏。二明教所依因故云以力无畏等。以者由也。此即望前为因义。又以犹用也。用此力等开方便门。教化众生成此权教。是故望后权教亦是所依。又自在力光者通用无碍该于权实。成益三业竟。第三用归如中先明身业。谓虽普现多处即用同体。故云如空。而无来去以普遍故。不动故。起信论云。虽起大用而亦无有用相可得。此则用而常寂也。次二句明意业。一遣妄。二顺真。又初会性永无。二实相不灭。又前了其不有。后证其不无。中边论云。无二有。此无是二名空相。斯之谓也。又此亦是释成前义。谓何因普现而无来去。释云。以了达无性何以去来而是无性。以彼去来顺平等故。顺平等之大用无明闇尽名一切光明。不失大用故云普现诸佛所行。下一句明语业。诸佛世界者诸所遍处也。不思议音者所顺多繁故云不思。此上三三业。各一总二别。又初总余二别。又三三九为别。最正觉为总。同异成坏准思可见。智正觉竟

大段第二明众生世间圆满。于中先总料简。后释本文。初中略作十门分别　一明众数　二新旧　三定器　四世出世　五界趣　六诸乘　七权实　八位地　九表法　十因果

初众数者。谓此初会有五十五众。始从普贤至摩醯众为三十四类。后从善海还至普贤为十八众。牒前总为五十二众。海慧内众并新集十方及胜音众。牒前总为五十五众

第二会中有新旧二众。牒前总为五十七众。三四二会各有天王菩萨二众。牒前总为六十一众。第五会中升天品内有五十二众及云集一众。第六会有同生异生二众。及第七会一众。牒前总为一百一十七众。第八会中菩萨声闻及天王三众牒前则为一百二十众。于中一一或以十佛世界尘数为量。如是等皆无分齐。然此等八会既并同时互相融成一法界大会。即知一一会中各有一百二十众无分齐相。此且约此一世界八会中说。若通十方虚空法界一切世界皆各有此无边众会。相入重重如帝网无尽。即不可说不可说也。是谓华严海会之众数二诸会新旧者。或唯旧无新如六七。二会或唯新无旧如三四五三会。或亦新亦旧如初二八三会。余意各如下文集众中说

三定器者泛论列众有三义。一是当机。二是影响。三是寄法。今此通三也

四世出世者有四义。或俱是世间以时中显现故。又三世间中是一故。或俱出世。如其行德非世摄故。或亦世亦出世。由具前二义故。又随相论初普贤等是出世。余是世故。或非世非出世。以是出出世摄故。是故此众通其三位具斯四句也

五界趣者。于三界中除无色天。以随相寄法非殊胜故。若仁王经亦有无色天等。五趣中除地狱众。以彼极苦寄相显法亦非胜故。若方等陀罗尼经亦有此众。又无人王众。以相显非奇故。或菩萨即人众也。或唯列王众。如后十八众说。以表法自在故。或通王臣。如此三十四众中说。以具主伴故

六诸乘者。大智论云。若小乘经初唯列声闻众。若大乘经初具列菩萨声闻二众。义准若一乘经初唯列菩萨。所以知者彼论以大品等为共教。别指华严为不共教。以不与声闻共说故。又此上三门各有二说。初中二者。一若为成小教得小果等唯列声闻。此是愚法小乘。如阿含等经说。二为回小乘显所被机。唯列声闻。是大乘回心教。如金刚般若经初辨。二具二众中亦二。一或先列声闻后列菩萨。此通始终顿三教。如净名等经办。二或先列菩萨后列声闻。此通顿教及同教。如罗摩伽经惟楼王经和休经等辨。三唯列菩萨中亦二。一虽唯列菩萨主伴不具。是同教一乘。如十一面经等辨。二若主伴具足即别教一乘。如此经说

七权实者。若约三乘佛居此娑婆界。杂众是实。以实报生故。菩萨是权。方便现故。如经云。彼诸菩萨隐其无量自在力等。或菩萨是实以地前菩萨犹生此土故。杂众是权依大集经并是他方大菩萨等权形所作故。若佛居净土菩萨唯实。实报生故。杂众是化非实有故。摄论云。受用土中实无此等众生。欲令净土不空故。化作如是杂类众生。若一乘中佛在此华藏界菩萨杂众或并是实。以是海印定现实德摄故。或俱是权以随缘而现故。余义思准

八明其位者。若约三乘此普贤等皆是十地已上菩萨。彼神王等多分并是随类生摄。即是八地已上。若一乘中如缘起际诸位皆齐。是故一人具五位位位皆遍收。准之

九表法者。若三乘中但寄人显法。仍人非是法。若一乘中此等诸人并是法界缘起法门。又此一众即通三世间。以或作河池井泉水等国土身故。余可知

十因果者。若三乘但是因位。若一乘中或皆是因。以未是佛故。或俱是果。以并是佛海印中现故。又乘解脱力入佛海故。或通因果。由前二义故。或俱非。以离性平等故。并如下叹德中说

次释文者。一一众中皆有四种圆满。一数圆满。谓先举数等。二行圆满。谓列名等。以名依行立故。三德圆满。谓叹德等。四供养圆满。如下三业供养等。于此众圆满中有二。先明外众。后海慧下明其内众。就外众中亦二。先列三十四众具前三种圆满。后摄为十八众显第四供养圆满。问前列中以普贤为首摩醯为终后兴供中何故反此。答古德释云。初从下向上。表进行增微。后从上向下。表尊位次第。此释难用。岂令普贤最为卑劣。今释前则从近向远。表依本起末。后从远向近。明寻末归本。良以本末无二远近不殊。二文互举无障碍也。就前中二。先辨同生。后明异生。或以声闻为同菩萨神等并为异生。此约小乘。以约相明同故。如同坐等。或以出家菩萨及声闻等为同。余并为异。此约始教。或以菩萨为同。声闻等为异。此约终教。或唯地上菩萨为同。以同证法性故。余悉为异。或八地以上为同。以俱纯熟纯无流故。此二通始终二教。或唯菩萨为同。以通诸位故。神天等为异。是法界别德故。或菩萨神等俱是同。以法界无二故。或俱异。以法界差别故。此约一乘辨。就同生内。初数圆满中。大者有八义。一数大谓十刹尘等也。二德大谓位具一乘法界德故。三作业大谓救众生极重苦故。四敬大谓天王等大人所敬故。五胜大谓一切众中最殊胜故。六行大谓修二利六位行故。七愿大谓十种大愿十尽句故。八时大谓三无数劫或无量僧祇而修行故。菩萨者依佛地论及无性摄论等总有三释。一云菩提此云觉。是所求也。萨埵此云有情。是所度也。从境为名。义言若从心称应言悲智。二菩提如前。萨埵是能求。谓求菩提之有情也。此约人法为名。亦是心境为目。三菩提如前。萨埵此云勇猛。谓有志能。于大菩提勇猛求故。又智论云。萨埵或云众生。或云大心。即是上二义也。俱者谓传法菩萨与之俱闻故。如来与之俱说故。又智论云。一处一时一心一戒一见道解脱是名为共。共犹俱也。第二行圆满中。菩萨名杂者有二意。一为显下粗细等杂世界故。二以此众通八会序故。德周法界曰普。至顺调善曰贤。智论名遍吉也。此中同名普者以圆遍故。次名月者德清凉故。次名王者德自在故。次名光者了闇用故。次坚固德故。次德独出故。次演清凉教故。次德明尊故。智论云。问菩萨甚多何以列少。答菩萨无量说不可尽。若都列者文字难载。复次菩萨不过二种。所谓在家出家。此方他方。在家谓颰陀罗等。出家谓妙德等。此方谓慈氏等他方谓观音等。若说此二当知一切都以摄尽。解云。此约娑婆世界说。就华藏众如文可知

第三叹德圆满中二。先约人。后约法。初中友者德齐也。即显因果无二也。此文有二意。一举佛显德。如云欲观其人先观其友等。二何故集此。以是友故。相成故。俗书云。同志曰友也。此中善友有三义。一过己义如善财进友。二德齐义以是朋友故。三少劣义以普贤等名第二尊导故。二约法中初一句总。此一切菩萨皆悉成就无边功德。深广如海。十相准之。下别辨中二。先成就自分功德。后无上智愿下成就胜进功德。然此二分通说有七重。一约一行生熟分。二约二行如施行已成后修戒等。三约二利以分。四就行位。以得位为胜进。五约比证以分。六约二位。谓前位已成为自分。趣向后位为胜进。七就因果。因成自分。入果胜进。今此文中正就末后兼通可知。就自分中成就九种功德。一成行满功德谓无处无时而不见。行施等七度故云诸度普照。二成慧眼功德。以何义令此度行而得圆遍。以净慧眼如彼三际而等观故。云慧眼等也。三成深定功德。谓依何得此慧眼。以依深定发故。此中有三义。一于定不味故云净。定发胜慧故云明。二处于定纯熟入出无碍故云明净。如下文东方入正受西方三昧起等。三顿入多定令一摄一切故云具足明净。下文云。如入微尘数诸三昧一三昧生尘等定也。上来三句明自利行。四成妙辩功德。谓巧能说彼难说之法故称辩才。即下四十无碍等。以一言说一切名广。所说皆玄曰深。此深及广悉无崖无底故云无尽。五成普曜功德。以佛功德身光普现照曜群机故。六成调化功德。谓善巧了知众生心器。即心行稠林也。称根授法。调令离障伏使入法故云如应调伏。上三句即三业化他行也。七成就真智功德。以金刚智普照一切差别境界。悉同一味平等法性。八成量智功德。以广大之慧明达深智所知之境。无不周尽故云靡不明达也。上二句明智照二谛德。此上八句约行显德。九成摄位功德。此有二义。一摄前诸行入信等五位之中。二随在一位即摄前后一切诸位。此二亦有二。一约相入明摄。二约相即明摄。如前十门处准之。此从十信满心已去诸位见此相摄。是故下贤首品中。信满之处即具一切位乃至佛果等。是此义也。上来自分竟

第二胜进入果中二。初十句明体德圆满。二遍游下六句显妙用自在

前中成于佛果十种功德。一得佛智愿德无上者。佛果无加故。智谓大智。即四智十智等。愿谓大愿。即自体无障碍愿。大智已成。大愿已满。并皆现今成满已讫。非是当成故云皆已成满。二具佛密教德。此有二义。一言不尽理名秘密教。以非了义故。二微妙难解非下位能测故。名密教。以是深广故。此中据后说。何者深。谓言即不言故。何者广。谓不言之言周法界故。下文鹙子如聋等是也。此深广教唯佛所有。今此菩萨具足同佛故名也。三得佛果法德。谓十八不共等果位功德。望下皆名不共。佛佛相望名为共法。非是与菩萨共故云佛共法也。四同果位德。此有四义。一同佛行者谓大悲行故。二同佛地者得佛十地。谓毗卢遮那智藏大海地等。三同佛德者得佛无边福智德故。四同佛力者得十力故。又得十种大力等如不思品说。五三昧自在德。此有二义。一出入自在故。二相摄自在故。上五句得佛自利德。六机感现形德。谓机感繁多故云生海。圆身普应故云应现。如经云应以佛身得度者即现佛身等。七随行摄生德。谓随其根行授与法门令增正行故云建立。前句现身。此句说法。此二句得佛化生德。八巧证法海德。谓缘起法深广繁奥苞含如海巧达其际故云善入。九入海回转德。谓善入缘起陀罗尼门。令一摄一切故云回转总持也。十果海充身德。谓由于缘起法海巧回转故。令佛无边功德法海皆悉摄取充满己身。是故皆得佛果功德意由此也。下文云。菩萨于因缘和合中自在。乃至能随意示现于佛身。此之谓也。第二妙用自在中有六。一遍游诸刹用。此穷世界海。二出生愿海用。谓由此愿力入国土海。又前句游他佛刹。此句愿严自土。三三达圆明用。以未来难知是故偏。举。理实通三。可知。四历事供养用。五愿海深广用。故云普贤愿也。六化物智圆用。故云于众生智满也。同生众竟

第二异生众中先辨金刚力士众。以卫佛近故先列也。表佛德缘起不坏相故。众行所依如金刚际故。即行眷属余众亦然。叹德中八句。初一句总明本愿侍佛。后七句别显其德。前中若三乘教中。八地已上方乃现形。显卫。已前密卫。一乘中。信满已去并显卫。如下贤首明法二品说。又随心求义为愿。要契至诚为誓。下别中二。先内德圆满。后无量神力下外用普周。前中三句。初愿行具。二福智净。三大定深。外用中四句。一力同果遍。二大小重入。三身出众表无大众畏也。四随类巧现。皆如缘起际准之。第三道场神者。在树下近故次列之耳。叹德中略举往因。如下善财第十回向知识处说。又守护道场。如宝髻等。又道场之神此依主释。或道场即神持业释。一乘通二释。以并法门故。三乘唯依主。人法别故。下诸神名二释准之。第四龙居上荫覆义故。云严法堂。如下普光堂龙所造等。第五地神居下。运载义多现女身。如坚牢等。第六树神居中。建立义德树高情故喜也。第七药神是对治义。法药遣惑是悲门也。第八谷神是资持义。育养黎元令喜故也。如后稷等社公(云云)

第九河神是流润义。德中勤是流义。益是润义。第十海神是具德义。如下十相等。德中以法同事可知。第十一火神是成熟义。照明义。焚烧义。除闇义。初二成二严。后二灭二障准之。第十二风神是聚散义。如风灾为散风轮持聚等。散惑聚德可知。又即令众生身不分散。皆是法界缘起舍那风神力也。又内风有五种。一息风。出入息从脐轮起。二消风。向下消食。三持风。令人行健。四灾风。令人成病。五力风。人将死解人支节临死人面有五色风。入地狱者黑色。生畜者青色。饿鬼黄色。兼以舌出。生人面如常色。生天鲜华色。精光可爱。第十三空神有七义。一无边。二无碍。三一味。四含摄。五显示。六离染。七坚固。前五名中准后二德中彰。第十四主方神是显示义。谓显示方隅令达迷向正故云善照。照犹示也。第十五主夜神是助成义。非正时故。或闇夜中导引众生。如下夜天等准之。第十六主昼神是正修义。是正时故。故云信乐正法。又是明饰义故云庄严。第十七阿修罗新为阿素洛。依婆沙名非天。佛地论说天趣摄。多作谄诈无天实行故名非天。如世恶行名曰非人。或名非端正。或名不酒。于大海中作酒不成等(云云)。或云毗摩之母本从天生故云劣天。阿含经云。劫初成时光音天来海中洗浴。水触其身失精在水。遂成肉卵。经八千岁乃生一女。身若须弥。有九百九十九头。头有千眼。有九百九十九口。口有四牙。牙上出火。犹如霹雳。二十四手。九百九十九脚。在海浮戏水精入身生一肉卵。经八千岁生毗摩质多。身有九头。头有千眼。口中出水。有九百九十九手。有其八脚。其形四倍大须弥山。纯食淤泥及以藕根。又多与天诤。广如正法念经说也。然修罗有五住处。一地上众相山中。如下文说。二须弥山北下入大海二万一千由旬。修罗王名罗睺。此云障碍。能以手障日月等领无量众。三从此下更过二万一千由旬王名勇健。亦领多众。四复过二万一千由旬王名华鬘。亦领诸众。五复过是数王名毗摩质多。此云响高。是舍脂父身如五须弥山。与天帝战时。发自海底扬声大叫云。我是毗摩质多。我是毗摩质多。时阎浮山岳一时震动。亦名穴居。谓彼中有光明城。于中住故。或天趣摄。如上佛地论。或依毗昙鬼趣摄。以谄曲所覆故。或依正法念经鬼畜摄。以罗睺是师子儿等故。或依伽陀经天鬼畜摄。由上说故。故唯有五道。若分六道善中上中下配天人修罗。恶中三品配下三涂可知。依智论其罗睺阿修罗王是大菩萨。第十八迦留罗新名揭路茶。此云妙翅鸟。鸟翅有种种宝色庄严。非但金色。依海龙王经其鸟两翅相去三百三十六万里。阎浮提止容一足。依涅槃经此鸟能食消龙鱼七宝等。唯除金刚。以不能令消故。又食应命终龙。又过去受三归者不食。袈裟缕系者亦不食。又依增一经四生金翅中如卵生鸟。从铁叉树下入海取卵生龙。水犹未合还至本树上食之。若向胎生龙鸟身即死。若胎生鸟得取胎卵龙不得余二。若湿生鸟得取三生龙不得取化生龙。若化生鸟得取四生龙。又日别食一大龙王五百小龙。绕四天下周而复始次第食之。命欲终时诸龙吐毒不复能食。饥火所烧耸翅直下至风轮际。为风所吹还复上来。往还七返。无处停足。遂至金刚轮山顶上命终。以食诸龙身肉毒气发火自焚。难陀龙王恐烧宝山降雨灭火。渧如车轴身肉消散。唯有心在。大如人髀。纯青琉璃色。轮王得之用为珠宝。帝释得之为髻中珠。又下文云。菩萨金翅王生死大海中。搏撮天人龙安置涅槃岸。此之谓也。第十九紧那罗新云紧捺洛。此云歌神。能唱歌咏。作乐。杂心入畜生道摄。亦名疑神。谓是畜生道摄。形貌似人。面极端正。顶上有一角人见生疑。不知为人为鬼为畜。故云疑也。第二十摩睺罗伽新名莫呼洛迦。此云大腹。亦云大蟒。又名腹行神。能护法故。能除疑也。第二十一鸠槃荼。依正法华经名厌媚鬼。啖人精气等。亦名冬瓜鬼。王名毗楼勒。此云增长。主是南方。天王领二部鬼。一名鸠槃荼。二名薜荔多。从所领为名。第二十二鬼神王是北方毗沙门。此云多闻。亦是所领为名。以摄诸恶鬼不令损恼众生故云勤护也。第二十三月是清凉义。如下文菩萨清凉月等。二敷发义。如敷发莲华等。如文发宝心等是也。又依俱舍论月去地四万由旬。广五十由旬。以水精白银合为两面。回转相影故有亏盈。依长阿含经其城正方一千九百六十里。高亦尔。二分。一分天金作。一分琉璃作。王座二十里以遥看似圆。天寿五百岁。子孙相袭一劫。第二十四日广五十一由旬。其城正方二千四十里。高亦尔。宫城纯金七宝莹饰。王座二十里。寿命子孙同月天。以风持故绕须弥山四面。上日月天子俱是四天王左右初天所摄。并是道力随缘殊形异现。德中初句自利。后句利他。如日有成就义饶益义。又依宝性论说曰有四义。一破闇如慧。二照现如智。三轮净如解脱。四上三不相离如同法界也。第二十五忉利此云三十三天。三十三天者。佛地论第五云。妙高山四面各有八大天王。帝释居中故有三十三也。若具应云释迦提婆因陀罗。此云能天主。依三法度经此中天子身长一由旬。衣长二由旬。广一由旬。重六铢。寿一千岁。德中具二利可知。第二十六夜摩此云时天。以时华开合辩昼夜故名也。佛地论云。谓此中随时受乐故名时分。此天身长二由旬。衣长四由旬。广二由旬。重三铢。寿二千岁。德中自分胜进可知。第二十七新名睹史多。此云喜足。佛地论云。后身菩萨于彼教化。多修喜足行故云喜足。依长阿含经身长四由旬。衣长八由旬。广四由旬。衣重一铢。半食甘露。寿四千岁。德中慧定可知。第二十八化乐者。佛地论名乐变化天。乐自变化作诸乐具。以自娱乐也。又自化乐具还自受用不犯他。故名善化。亦名化乐。依三法度经身长八由旬。衣长十六由旬。广八由旬。衣重一铢。食甘露。寿八千岁。德中二利。第二十九他化自在者。佛地论令他化作诸乐具。显己自在故名也。依三法度经身衣寿命过前一倍。准之。德中入法自在也。第三十梵者。新名离欲染故。净中之极名离欲也。佛地论离欲寂静故名梵。身者众也。依长阿含于梵众中以梵音语故名也。天者自在义。光明义。净义。依智论天有三。一人天。谓帝王。二生天。谓欲色天。三净天。谓佛菩萨等第一义天也。尸弃此云火色。或云火顶。以火灾至此故。若修上禅即生此天。于梵众中发大梵音诸天各自谓。唯共我语。于大千界最得自在。颜如童子。身白银色。长半由旬。衣金色衣。非男非女。禅悦为食。寿一劫。此依长阿含辨。德中四句。一以何度。二何所度。三何所除。四成何德。如文可知。初禅大小等于欲界一千四天下。一千初禅始等二禅。二禅为火灾顶。一千二禅殆等三禅。三禅为水灾顶。一千三禅殆等四禅。四禅为风灾顶。又梵摩此云寂静清净洁。皆得亦云梵洁。又尸弃者火灾顶初禅主。又云持髻(云云)。第三十一光音者。依智论第二禅通名光音。彼天语时。口出净光无边。身长二由旬。寿二劫。又为初禅火光发音。引摄令生此天故名也。德中慧定可知。第三十二遍净者。以三禅中离喜故。身心遍净。依长阿含以上方便生此天王。名净智。四臂持风轮御金翅鸟。德中以此是乐位故。令得真性广乐也。第三十三果实者。以第四禅是世间善果中最胜故。亦名广果也。德中以是不动位故入性寂也。第三十四摩醯首罗者。依智论此云大自在天。有八臂三眼骑大白牛。知大千界雨渧数。以于大千界中最极自在更无过故立名也。又依智论第一云。第四禅有八种。五种是阿那含住处。是净居。三种是凡圣共居。过八处有十住菩萨住处。亦名净居。号大自在天王。由此当知。净居之名有四种。一约报纯净。此通凡圣。二约德过凡。此唯那含等。三约因。如云有十住菩萨。十住菩萨即是十地。十地中是第十地摄报果也。四约果。谓此中有三乘中报身净土等。故立此名也。又准智论八天外更有别十住菩萨天也

第三叹德。此文有二释。一但显此众德。二通辨上来异生众德。便即释疑。疑云前普贤同生同在果海。此异生众既杂类卑末。如何亦在果海中摄。释如文中。初二句总标。谓内修离相外预胜流故。在缘起果海中也。下别辨中二。初举其德。后所以下释同果海。前中二。初一句外化普周。次内德盈满。盈满中四。初三业殊胜。二同佛所乘。三断德离染。四照烛真源。初中先身成妙色。二意善安住。三语辩不倾。此中初离不勘说。故在众不倾。后离不能答。故难无能坏。所以具此胜三业者由佛所乘常现前故。所以佛乘得现前者由离二障故。所以得离此二障者由睹胜缘故。是故入佛海也。此即以后释前。又义以前释后。谓由具此胜三业故佛乘现前。佛乘现前故得离二障。离二障故得见佛法界身。是故得在众数。以若具障者视日尚失眼光。况得见佛。如下如盲等。又断德中二句。初习种全灭。后句正使久除。文可见。释同中二。初果能摄因。二因能入果。初中二。先征。次释。征意所以此众同在佛海中耶。释意以佛成彼故不别也。于中有三。一举佛为行缘。二种种因缘下明依缘成行。三各随下结行属缘。前中三句。一往时。二往行。三为物集善根。二成行中有五句。初一句令得三贤位。二一句证地位。三逮得下明八地已上位。四皆悉下成法云位。五具足者结总也。三结行属缘中。初各随得出结行也。悉由等者属缘也。是故在果海中也。二因能入果者。谓乘解脱等即乘因入果故。乘别入总故。乘门入海故。如下文中十种解脱九世相即。乘此力故得因果圆满同一际也。是故于佛果海中法门悉得自在。下文叹法门即是其事。若三乘则不得如此。以事异故。师弟别故

自下大段第二。供养圆满。从远向近辨十八众中。前三十四内于四天中略举南北。具列诸神。今此兴供之中从道场神至摩睺罗伽。略此十八具显四王。何故尔耶。释云。以前龙等属西方摄。余类多分东方所收。由此二类所领多故。分王从众。略彼二王具显十八。今此欲明上首赞佛摄众从王。东西收尽。是故略彼十八加列二王。以南北所领文中不广不类东西故无开合。是故三十四中略却十八唯有十六。复加二王故成十八。于中前则先同后异。今乃先异后同。何故尔者。谓前表依本起末。今明摄末归本。又异生中前则先劣后胜。今乃先胜后劣。何故尔者。谓前表法增微。今显尊位次第。又释。此等并显法界缘起逆顺自在无障无碍总合为一大法界众。故作是说。既云兴供。何故不列诸事供耶。释事供非奇不足显胜。经云诸供养中法供养最。是故唯显法供养耳。若尔何故下文海慧及新集众皆列事供。释海慧等众从座中出复持事供。为显奇故他方客众各从本土。持彼事供。不类此等常随之众。如释迦身以舍利弗等为常随之众。但以修行化人作法供养。亦更不辨余事供等。此舍那身眷属亦尔。于中各入法门洞达自在为意业供。说偈赞佛为语业供。在会虔敬为身业供。又夫论法供有其二种。一顺教修行。得法自在。二赞扬显发法化传通。今此三业具斯二行。文中有二。初有一句总标。故云各于佛法门而得自在。下别辨中二。初十七众各一法门自在者。分总成别名为异生。后普贤一人一切法门自在者。摄别成总揽异归普名为同生。是故二众同一缘起思之。文中十八众即为十八段。一一各二。先长行得法。是经家序列。后偈颂赞叹。是当时文也

就初首罗众内十天得法中。初明体用。体中法界空境也。寂静证也。用中方便者善巧应机。光明者觉照成益。法门者法有三义。谓自性轨则及对智也。门有四义。一标别义如此门非彼等。二通智游入义。三收入义一切入一以一为门。四通出义于一门中能出一切不穷尽故。此法即门持业释也。法界虚空等即法门亦持业。下诸门并准此知之。此等并是法界缘起佛境界中差别法门。然此诸众各洞一门入佛海内。属佛别德。故称自在。又于此一门摄一切门。作用无尽故名自在。下并准之。二一切法者境也。普游者智也。又初教后义。颂存后释也。三不生灭是法身。方便是色身。又初证道。后教道。又不生灭者有十义。一真理离有为相。故不生不灭。二非有为故不生。是无为故不灭。三不守性故不生。不改性故不灭。四不变故不生。随缘故不灭(此上约圆成)五缘起无性故不生。缘起不失故不灭。六缘起不失故不生。以理性不现也。缘起无性故不灭。以理性显故。七由缘起故不可生灭取也(此上约依他)八由情执无理故无可生灭也。九所执故不生。是无相观境故不灭(此上约所执)上来约境。方便者上诸道理巧现于机也。十不住世间故不生。不同凡夫。不住涅槃故不灭。不同二乘。以不生有方便故。不住涅槃也。以不灭有方便故。不住世间也。若不尔者异凡应同小。异小应同凡。由方便故得双异也。此上十义总别无二。以六相镕融思准之。四巧智深广难测故。光者除闇故。游者升入故。五依普门禅故云一切也。见法界理佛故。灭惑故。生起无量乐也。六染分可怖转灭故。净分寂静转现故。游是证也。七境界者分齐也。化用遍故。不起者不作也。用而恒寂故。八妙绝三际故。又佛德应机而无往返。九真理寂静是佛所缘境也。十佛多方便是众生所缘故也。此十法门中初门为总。余九为别。同异成坏准可知之。颂中先生起。以佛力者显非自力。观自众者示普摄故。显同说故。何故偈赞者。地论云。少字摄多义故。诸赞叹者多以偈颂故。又颂有四种。一数字颂。谓依梵本三十二字为一颂。不问长行及偈。二伽陀颂。此云讽颂。或云直颂。谓不颂长行也。三祇夜颂。此云应颂。谓应重颂长行法也。四愠陀南颂。此云集施。谓以少言含摄多义云集。用以施人令易受持故。云集施。此上三种颂。或七言或五言四言三言。如处世界如虚空为三言也。皆以四句为一颂。此中当第三重颂之偈也。下文诸颂准之。偈中二十行四句成偈。总有十偈。一偈颂前一法门。问此欲叹佛。何故颂己法门。答此众既是佛海印中现属佛别德故。颂己法即是叹佛。以佛德玄妙非余所知。若非佛德无以显佛故。智论第十二云。唯佛应供养佛。余人不知佛德。如说智人能敬智。智论则智喜。智人能知智。如蛇知蛇足。颂中初颂颂初法门。初三句颂体后一句颂用。前中初一句颂境。次二句颂证。或身满法界。或法界满身融故也。心寂故无取。境寂故无起。又初句颂上法界。次句颂虚空。次句颂寂静。下句颂方便。二颂中初二句颂上一切法。次一句颂上普游。下句结天名也。三中初一句颂上不生灭。证道。次二句颂上方便。教道。初句身方便。后句口方便。下句约天。明得法自在立名也。四中初二句颂上方便智海。次一句颂上光。下句颂游及结人得法。五中初三句颂上禅无量乐事。下一句颂普起及乐名。六中初句颂上痴畏。次句颂游静。次句颂转。谓照除也。下句结人得法。七中初二句颂无量境界。次一句颂不起。下句结法属人。八中初二句颂上一切法。次一句颂不来去。下句结法属人。九中初三句颂佛境寂静。下句结法属人。十中初三句颂无量境界。无量境界有三。一时无量。上句显之。二境界无量。谓菩提及众生次句显之。三善巧无量。下句显之。下句结人得法

二第四禅果实天有八。一观物根兴法云注法雨以逗前根也。二妙色者现身故方便者说法故。此二是能应也。念者念持法故。观者观色身故。此是所应机也。由此念灭痴成净。三见如因陀罗网土。由缘起无性故。四入缘起陀罗尼。一门中即摄圆融法界。故云普门也。五不转爱者自留惑故。转他众生受生之爱令永灭也。又令他灭惑不于三界处生。六一切世间境者器及众生也。佛入中说法而恒住寂故云不思议也。七会二空。显二谛。众生及法者举人法也。出要者会真空也。八令机证真源入果海故也。颂中有十九偈。有二。初十七颂前法门。后二举因总叹。前中初二偈颂初法门中。初偈叹佛德深颂上能观。后偈颂上法云开润根欲。二中亦二偈。初偈颂妙色方便。后偈颂念观。三亦二偈。初偈巧现真理。后依理现事。因陀罗网通理事故。四亦二偈。初颂普门现法界身。后显法界法。五有三偈。初偈断德摄生转灭惑业苦也。次偈转显福智等也。然各通因陀罗。后偈结法属人。方便即是不转爱也。前长行中但有初偈中事应知。六二偈。初颂上入一切世间境界。后偈中三句颂不思议。下句结法属人。七二偈。初偈颂上众生出要令知无我以显俗谛。后偈颂一切法出要令知无我以显真谛。八二偈。颂上受化者入佛境界法门。初一以果就机。后一摄机入果。后二偈中。初一举因成德。后一对机显用。又释。此偈逆次颂前法门。初二颂末后。次二颂第七。次二超颂第二。次二超颂第四。次三颂第三。次二却颂第六。次二却颂第五。后四颂第一。并可知。以是任放辩才说不待次故也

三第三禅遍净天有七。一观诸众生三品善根令增长故。又释。如观城门首所闻佛名善根鹙子不见等。二一切有者一切世界也。佛于中出觉悟众生照现诸法故云觉照也。三总持于心具文义故。宣之于说具四辩故。四佛出希逢故生乐。出已除难故云解脱。五众生即如。顺缘起际显德无穷故生欢喜。六初化菩萨胜用也。次德相备。后入无尽顺极体。并是一乘别教法耳。七苦众生是所救。慈悲是能救。智者不取相故。满者化德具故。成彼益故。颂中十一。初一颂初法门。前长行举所观。今显能观之德故也。又释。初二句能观谓佛智无碍普遍也。次一句明善根难知是佛境界。下句结人得法。二有四偈。初二颂上处有及照。于中初一明依体起用。后一明用归体。后二颂上觉义。于中初一开迷显觉。后一明觉超情。三一颂。初二句颂持。次一句颂辩下句结法属人。四一颂。初二句颂乐佛出。后二句颂解脱。五一颂。初二句颂众生甚深法。后二句颂生欢喜。以见理功德故。六一颂。初二句颂上化菩萨。后二句颂上功德周备入无尽也。七二颂初二句颂所救。后二句颂能救及智。谓见净是智也。下一颂明满。谓初二句化身满。后二句化业满

四第二禅光音天众有十。初寂静处者。一理静。二事静。三田静灭苦亦三。一性灭。二智灭。三福灭。下颂中但有田及福也。二中初断德。心净性净故。离垢治净故。宝性论云。一自性净。二无垢净。次智德。谓广修等也。又心净是器离垢是缘。德海是依缘所修也。颂中存后释。三有二释。一长短相即。以时劫如如故。二自在位与不自在位德优劣故。四有三释。一云世间生住灭种种者是染缘起。清净者即染性净。性净之德故云功德。一云是净法缘起但简真如。故云世间生等。简染过患。故云净功德。一云世间是处也。生住灭是佛出及住灭等多门益物灭染成净故也。下颂中存后释。但以义通故兼余释也。五一生菩萨能供中极是故。就彼显广说也。如下百万亿等准之。六得自在陀罗尼力。一念能多受。一念能多说。七场处佛出名庄严。八神足即功德。又神足是能益。功德是所益成相。九福智深广与机为境。十愿力功德力。是因位愿行即能持也。喜藏是果即所持也。喜是大智。智体含摄故名藏。颂中十偈各颂一法。初偈颂依静田生福灭苦。二中初句颂离垢行缘。次句颂心净行器。次句颂所成德海。下句结法属人。庄严即是妙杂光也。三中初句显方便广故次句显多劫修故。次句性无碍故。由此方便一念出生多劫功德名方便门。法主音即是自在音故结人得法也。四中初三句颂世间生住灭。即佛兴世等故。下句灭痴颂净功德。胜念结天名也。五中初句田广。次句能供广。次句供益广。总颂上菩萨在兜率广说供也。下句结法属人。六中初三句颂于一劫说地义。下句颂能一念受说。以得心自在故。七中初句能严。次二句现庄严相。下句结名。八中初二句颂无尽神足。上句体。下句用。下二句颂益成功德海。上句令得地前六根净。下句令至地上甚深法。亦是结人名。九中初二句颂功德海。上句慧。下句福。次句颂境界。下句结法属人。十中初二句颂过去佛功德力。次一句颂愿力。下句颂所持喜藏。即所成果也

第五初禅梵天众有十。初从真起应名照现法。应不异真名入不思。以即寂为照不可寂思。即照为寂不可照思。二一切禅等观者是法身理。以此是禅中平等观境故。寂静善住者妙智证契也。三初本智照法。后后智巧化。又刹尘法海名诸法不思。一音演说尘劫不尽名入方便。偈中有后释。四佛音圆应名妙音海。齐均普契名平等度入。五柔根者摄取。刚强者伏取。然此方便佛身中现故名最胜。六佛身普应。诸刹中现名能起住。语业普周。净音说法名分别法。七无边三业巧化众生。八法离情计名净相。妙智善证名住寂行。九过未无来去。现世无所依。又生无从来。灭无所去。住无依止。于此观心名为勇猛。十随有一行。即皆普照无尽法海。颂中八偈。前七各颂一。初中初半颂照现诸法。后半颂入不思议。二中初半颂禅等观。后半颂寂静善住。复即下句结法属人。三中初句颂照诸法不思。次二句颂入方便。下一句结法属人。四中初三句颂妙音声海。下句颂平等度入。亦是结也。五中初半颂摄伏。后半颂最胜。六中初三句颂一切刹能起安住。谓现身也。下句颂分别诸法。谓净音说法故也。七中初半颂无量方便。即三业轮也。后半颂化众生。谓自在照机故。八中初半颂住寂行。后半颂诸法净相。后二法门略无颂。又释总在第八颂中。谓初句颂第八法门。次句颂第十。次句颂第九。下句结名。乐是第九名。音是第十名

第六他化天众有十。初中众生有二藏。一烦恼藏化令转尽。二如来藏化令转现。此二不二。和合融通故得化益也。二令众生得大涅槃乐。三知机巧益。四分别众生有三性义。又佛为众生一音显析广大法海。偈中存后释。五慈念覆机。慧眼观察。六大慈十力碎慢高山。七应念摄化。八普念诸佛妙尽佛境。九佛功德自在者显能化之德。觉悟满念者普应群机。随顺者一根缘相顺。二令机入法。十佛国土海。唯佛慧境故离世间也。颂中有十。各颂一法。初中初半颂藏。后半颂化众生。亦可通颂。二中三句颂前法。下句结人。三中初句颂解众生也。疑地枯林颂性欲也。余颂方便。及结人得法。四中初句颂分别。次句颂义。次句释疑。疑云何故一音能演多法。释云遍故。下句结。胜勇是精进也。五中初半颂观察。谓智观纳法名入佛毛等。下半颂慈念。及结名。六中初句颂魔事。次二句颂超出。下句结。七初半颂由念佛故得智。灭痴离染因也。后半离染果。及结名。八中初句颂十方诸佛。次句颂念充满。以满其念故。后半明满念益。及结名。幢犹轮也。九中初句颂佛功德自在。次句颂觉悟及念随顺。下半颂充满及结。十中初句颂离世间。以是土海故。次句颂境界。次句明离世因。以世间相尽。土海无可超故云无高心。谓无分别。下结名

第七化乐天众有十。初以缘起无作分别诸法。二有三释。一云观三有二我之实性故。一云一切有者理有也。我者情计也。情理不二故云真实。佛性论云。真谛无人法故不有。显二空故不无。又人法无不无。二空有不有。于俗谛分别性故不有。依他性故不无。又分别不定无。依他不定有。是故二谛俱离有无也。又辨中边论(云云)。又云佛虽现有。然于有求佛不得。以有即真实是无有故。云观一切有真实。佛虽现我。然我求佛不得。以我即真而是无我故。云观我真实。偈中存后释。三能灭众生愚痴之慧。圆满在于佛果故。四圆音普悦起彼勇修。五十莲华藏微尘数相海故云具足无尽。如相海品说。好功德者是小相。如小相功德品说。六三世劫事在佛智中照不杂乱。故云次第。此偏约过去。偈中具也。七福智无涯利益众生。又长众生无边福智。下偈顺初释。八缘起事身同法性普遍。无碍者有七。一质不碍身。二身不碍质。三遍不碍隐。谓机不感处。虽遍而隐。四满不碍分。谓应机现长短。而不碍满虚空。五坐不碍行等。六一不碍多。谓诸方现多而恒即一。七理不碍事。谓空界者界犹性也。即性空理跏坐是事。缘起融通故无碍。余诸根等准之。九业行缘起巧为机现名方便。无尽是机所缘故。复云境。十一切众生善恶因果。同在法界而无来去故。云等观。颂中十各颂一。初中化有三义。一化起所依。二显化无体。三化现似有。初半偈颂初义。谓上句颂一切法即所依也。下句颂分别化即所起也。次句颂无体。下句颂现有。谓佛与众生互为缘起故也。二中初半颂观一切有及我。谓俱无所有。后半颂真实。及结人也。三中初半颂离痴。后半颂慧满。及结名。力是天名。四初半颂佛音。下半颂发起喜勇。及结。五初半颂佛相好。后半颂无尽。及结。六初半颂过去无量劫等。后半颂智慧忆念。七初半颂种种功德智慧体。后半正颂福智及结。余略不颂。结中净知见既是净。光胜天何故名如来者以此天等即是佛故。如上辨。八颂空界坐无碍中。前长行明果用。此中颂彼因行。谓初句时多。次德满。次勇修。下结名。九初半颂方便境。后半颂无尽力及结。谓能现法之力周普故云无尽。十初半颂众生业行苦乐。次句颂等观。下句结照是华光也。又亦可此颂第九门前颂第十。思之可见

第八兜率天众有八。初为机现世名为成就。随欲说法名转法轮。二慧光照真空。又空体也。净德也。光用也。三无碍愿海与物同体故云入。自性离相故云寂静。四约遮十相俱无名无量无相。约表恒沙性德名无量无相。令诸众生观察修行灭惑业障名为观行。五佛境有二。一分齐。二所证超踊有二。一过凡小。二越思议。觉力有二。一证理。二照机。六以佛功德熏习众生。名喜修习。令发心不退故。云不坏菩提心也。七量智调机。八中初无尽缘起。次速归真性。亦是回法拟机后入机正现。又无边心海根器也。念念回向无间欲乐也。随器普现佛能应现也。颂中顺后释。颂中少非次。初中初句法轮体。次句所为。次句正轮。下句结胜。又初半颂成就。后半颂转法轮。二超颂第三法门。初半颂广愿海。后半颂入众生寂静。诸法方便是也。胜是天名。三却颂第二法门。初半颂虚空界。后半颂净光。四中初半观所为也。次句颂无量无相。即观境也。下句颂观行成也。五超颂第七诸佛调伏众生方便法门。六却颂第五法门。初半颂佛境超踊。后半颂觉力。又释亦可前颂五此颂七。如文可知。七中初半颂喜修集。次句颂菩提心。下句颂不可坏。八中初半颂无边心海。谓佛子是念念。回向有三义。一云集义。二向佛兴供。三向佛听法。如经悉来集故供养故听法故。下句颂随器普现

第九夜摩天有十。初令众生离世忧恼向出世顺体之善。又法身断德名离忧。教众生净道名向善根。二所缘分齐各非一故。三中初大智离过不住生死。次大悲摄生不住涅槃。又由具大悲救生。令离苦患。颂中顺后释。四了信等善根差别无边。即根行稠林也。又知一根中有一切根。相即入等重重无尽。又知诸根即同真性而诸根历然故云分别也。五陀罗尼门穷尽法界故云无量。总持诸法瞩同水镜。故云照明。依首楞严经娑婆世界边畔有须弥山上天王。名持须弥。得首楞严三昧。遍在百亿须弥顶上帝释宫中住。余夫不见。今此乃在夜摩众中以。菩萨自在处处现化未足怪也。六中有四义。一造业缘。即身等为缘。二所造业。即善恶不动。三缘起无作。业性即真。四业虽即真而不失生果。如经境界故业行故真实故不思议故。又缘佛为境。所造善业决定不虚故云真实。虽种少善定能当得大菩提果。故云不思议。如尼拘陀子等。颂中顺后释。七初转一乘三乘等无尽法轮。次扣机成益故云调伏。又初轮体。次轮益。谓调令入法伏除过恶故也。八中生界所见。胜眼能见。普观正见。谓见众生界极广故。即真性故。一中一切故。具因果胜义等故。如帝网故。名为普也。三乘无此眼故云胜也。又胜眼观机普雨法雨。颂中顺此。九以普智照法令现。又以法实。普现群机。十中天众是机。次应机施化。令除心惑故云心净。此化益也。又虽化不见能所。亦名心净属自也。颂中八偈。各颂一法门。初中初半颂离忧。后半颂回向善根。二中初半约正理明境界。次句约大智。下句约大定。又初半所证。次句能证。下句证亦是结天名。三中初半颂所离诸患。次句颂具大慈悲。下句结天名。四中初半明了达无碍。即颂上分别。次句颂诸根。谓行即根行也。下句明知根之意。为化故也。五中兼颂第七转法门。以同故。初句颂无量总持。次二句颂照明及转法轮也。下句结天名。又准地论初句体。次句因。次句果。下结。六中超颂第八法门。于中初半妙身胜眼。次句观已现身。下句结。光是天名。胜是眼名。境是所观也。七中一见如来身颂境界也。次二句颂业行真实。一灭染因。二离染缘。下句颂不思议。以证得净妙境故。八中通颂第九第十二门。初半颂普现。次句颂施作。下句结第十天名

第十忉利天有十。初中三世佛出等者。是九世中三现在故。就机兴废。通依正故。即所观境。下辨能观。谓于上兴废妙达胜用名决定智。顺理善证名念喜。又用虽起尽照理湛然。故云大智念喜。二中二色同如功德本净。又佛现同众生之色故云众生色。而众生色即如故亦名如来色。从体起用名功德力。结初句也。用不异体名为清净。结后句也。三平等者同体故。智导故。不简怨亲故。云者覆空故。润益故。含法水故。洒雨沾机故。四念佛光等过于尘算故名为众。一一皆备摄法界功德故名具足。别别作用皆遍法界。互不相妨名为普势。五了业果差别。又达彼即如故云观等。又佛以净业为缘。令机见佛为报。又众生依佛种得善根为业。缘佛得见为报。六佛土具净者净宝所庄严故。受用灭惑故。净者所居故。即本性净故。七世间缘起名生。无作即真名灭。由无二故生即灭。灭即生故。经云初生即有灭不为愚者说。一切法不生我说刹那义等。佛智照此名观。八缘起毛孔现众行法名起诸行。令菩萨修名化众生因。以是因人修故。修成入理名为起念。九乐有四。一欲界散乐。二定地乐。三小涅槃乐。四大涅槃大菩提大悲等乐。一乘三乘等乐。皆由佛得成。今据初故云天乐。以是欲天故。理实通。又名佛为第一义净天。是彼乐也。十化诸天子一念念佛。近离恶趣远灭痴惑故名流通善根。颂中初内初半颂三世佛出兴并大智。次句颂住灭。谓约佛国土身。下句颂念喜。二初半颂众生色如来色。下半颂功德力清净。并结人得法。又初句显清净。次句显二色。谓所应是众生色。次句显功德力。三中初句颂大慈。次句颂平等。次句颂荫覆。下句结人见法。四中初半颂念佛普势。下半颂众光色具足并结。五中初句总颂业报。次句颂观。下半别颂善业报并观。六中初半颂诸佛国土。以智正觉即器世间故。下半颂具净。谓受用净故及结。以念是天名故。七中初句颂观。次句颂世间。下二句颂生灭。谓应机是生灭义。又令智生惑灭故。妙音是天名。八中初句颂起诸行。次句颂化众生。佛子犹因也。下半颂起念及结天名也。九中二句颂一切天娱乐。次二句颂乐所因。下句结人得法。十中初半颂天处教化。下半颂流通善根。慧日是天名

第十一日天子有十。初慧日舒光。照众生海。性穷三际。以未来难知故偏举耳。称本缘起安固摄德故云正住庄严。又佛慧光照机。令众生尽未来际正住修行庄严故也。二照色即同萨婆若海。又以智海照现诸色。又照众生色而知其心。又照见心孔中水色。亦知心念。令其开悟发生大智故云也。颂中顺此。三佛为增上缘。发起众生舍劣从胜离染功德故云转胜。又佛身出世名起众生。以佛是大身众生故。说法益生名转胜净德。四苦行是因。度有二义。一是到义到此因门苦行际故。二是过义超因得果故。五无碍是智体。普照是智用。又照一法即现一切故云无碍。无碍即照名普照。又无尽辩才名无碍。演法周备名普照。颂中顺此。六佛光照机令发道意故云也。七由佛光照令众生增长善根名积集等。又由佛多劫积德故。得光照世间。是故能照。八性海具德可贵名宝。应机印现依正教义故云也。九巧除痴[目*壹]名开净眼。令见真理名观法界藏。法界藏者如佛性论云五藏等(云云)。十多根所感五乘终竟归于一揆。以诸乘皆净故名净乘。又亦分一为五。更无余杂故亦云净。颂有十一初内初句颂尽未来际。次句颂照十方众生众生世间即器故。二文互举。次句颂正住。以机缘契合故。下句颂庄严。二中初半颂照诸色。下半颂无上智海。三中初半颂起众生。下半颂转胜清净功德。又亦可所起众生。此中略无颂。四中初半颂苦行。谓难行故。是难行有四种。一时难如经无数劫故。二处难如经诸有中故。三所行难如经难行苦行故。四所向难如经为众生故。下半颂乐度。谓果也。五中初句颂无障碍。余三颂普照。六中初半颂净日光照。下半颂所照众生身并益相。七中初句颂所照世间。下并颂能照之光及积集功德。八中初句颂众宝海。下并颂现种种色境界。谓性海印机。法尔显现依正教义故云法如是。九中初半颂一切趣开净眼。下半颂观法界藏。十有二偈。初偈颂诸众生乘。谓五乘方便也。下偈颂净。谓会末归本等。又初同教。后别教。无二故净也

第十二月天子有十。初中先以加行调伏其心。次令正证名照法界。又普照有三种。一光照众生令见佛故。二照除痴惑。此二名调众生。三照现法界令入真理。二中普观是能观智也。一切等是所观境也。摄者以此普智会摄诸法。同彼普门无不皆是普智境界。三中心及境界。或有心转境不转。如十一切入等。或境转心不转(云云)。或俱(云云)。又心念繁多云海。是佛地心智之所缘。故云境界。称根授法令舍妄喜真名转。颂中顺此。四无分别智正趣真理名为爱乐。此爱超情名不思议。又正智爱证彼不思境故名也。此智因佛净法而生。故云能生也。又世间猗等诸乐皆因佛生悉名不思议。五佛令众生见二谛道理故云实见。又见即实故。又见之实故。又二谛三性及三无性皆有实义。一一辨之。六中大慈悲者。佛性论云。于已得苦救令脱故。于将得苦护令免故。苦在五识。恼在意地。俱救故。又救苦护乐不令失故。各通因果。七法喻双举。月四奇特。如下准辨。八中三性观诸法。先观依他如幻化。化不托物故异幻也。以依他中具有力无力二义故。又无体如幻。有用若化。真如有空不空二义。今且举一故云空也。遍计亦二义。谓情有理无。今约理显故云无也。九中所起有二义。一由善恶业熏起本识。二生起果报。以从缘故即不起。然妙达此际故云善解。又有经本作趣者。谓因趣果故。及离邪趣正故。十照理断疑超度惑染。颂中有八偈。初一颂初法门。于中初三句颂调伏众生。后一句颂所照法界。二中初半颂普观摄。次句颂一切诸法。下句颂境界。谓以所化为境也。三中初半颂众生心海境界。后半颂皆悉令转。四中初半显所为。后半正明能生不思议爱乐。五中初句颂令众生。次二句颂实。下句颂见。亦是结人得法。实中初分别者推求也。谓推求世间即无性故见真也。次句业果不亡见俗也。六中超颂后二法门。于中初半颂前第九法门可知。后半颂前第七法门。上句颂无痴。下句颂净月。谓巧慧清凉故。七却颂第六法门可知。八中初句颂第八法门。后三句颂第十。谓初二句颂照度。下句颂灭疑。以离疑浊故云清净见也

第十三东方天王众有十。梵名提头赖吒。此云持国主。从所领为名。此天身长半由旬。衣长一由旬。广半由旬。衣重二分。食甘露。以人间五十年为一日夜。亦以三十日为一月。十二月为一岁。如是寿命五百岁。此王领二部鬼。一名乾闼婆。二名毗舍阇。乾闼婆此云寻香。谓诸乐儿寻于他家饮食之香。即便往彼为他作乐而得彼食故以为名。亦名食香。唯食细香居十宝山中。常为诸天作乐时。身有异相即飞上天。法门中初者以法音乐巧摄众生。又令见正道法乐自娱。二福智绮缋。又具十种庄严。如明法品说。三中约凡顺流生喜。乖失生忧。二乘于灭生喜。于流生忧。今俱令离思准。四说甚深法灭除九结十使等垢。五中有二。谓悕生天者为说净土调其希望。希二乘者以一切智调其希望。六由见佛得无尽乐故云一切乐。依此修因能摄果故名藏。果称因起名正住。有用惬情故云喜光。七于十方界普洒净法。八圆回身普应无尽故名也。广智者横亘十谛竖该五乘故也。九中树者菩提树也。佛以方便增长众生菩提心。名长养树。得果名喜。胜用名光。十回动劫海。是佛境所作故云行。令众生见此息苦永安为受乐。又亦有本作爱乐。谓令睹此起正悕望故名也颂有十偈。各颂一法门。初中初三句颂方便。谓初句多次句深。后句广。下句颂摄众生娱乐。二中初句显佛功德海庄严体。次句明德相。后二句辨德用。三中初句颂众生忧喜。次句颂离字。下二句明离所由。四中初半明能灭之缘。次句正颂灭结使。下句明灭惑因。五中初半以净土调伏。后半以种智调。六中初半颂一切乐。下半颂喜光正住。七中初半明所被机。即雨宝处。颂一切方也。下半明所雨宝。幢是天王名也。八中初半颂现妙身。下半颂广智。九中初三句颂长养诸树。下句颂喜光。十中初半颂佛境界行。下半颂悉令众生受乐

第十四南方天王。从所领为名。余如上辨。有十。初者以忍智力除慢灭诤。二自他行海名一切行。慈门起此故云现前。又行能得果亦名现前。三邪执五趣从自性等生。今专明诸趣自心变起故云正也。又调诸众生正其意趣故名也。颂中顺此。四善恶平等。平等者是无记也。以此三性即如故云清净。又善是涅槃净法。恶是生死染法。由二俱无性融摄无碍故云平等。然具性德故云清净。又由善恶二法并堪作法轮故云平等。法轮利物故云清净。颂中顺此。五除痴见正名无畏。令永离苦名安稳。得佛净智名庄严。六爱润生死深广如海。爱心猛盛如火炽然。如烧天祠等。佛以身智照令永尽故云除灭。娑罗是涅槃灭爱处也。七佛身普应一切诸趣。依身出电光名照明。音雷雨法名云也。八普者光体遍周。照者光用除惑。九拔苦与乐通名大慈。遇违不改名不退转。慈门摄德多故名藏。积劫修此令现名起。十现身遍十方名起。在一切趣而无去来名所作。又于彼摄生亦名所作。颂中十偈。各颂一法门。初中初三句颂能灭斗诤。下句明益相。二初半颂一切行。上句自行。下句利他。后半颂现前。上句慈能现行。下句行能现果。三正其意趣故令欢喜。四初半颂善恶法。谓佛力现恶故难思议。次句颂平等。下句颂清净。五中初半颂众生无畏。次句颂安稳。下句颂庄严。谓净智也。六初句颂爱海。次句颂除灭。下半辨益相。宝树是天名也。七初句应一切趣。次句方便化物名照明。次句颂云。下结人得法。八初句颂普。次句颂照。下半颂所显现。九初句颂起大慈。前慈此悲。文绮互耳。次二句颂不退转。与乐灭苦事不虚故名不退也。下句颂藏。谓出生净德如华开敷。十初半颂起一切趣。无去来亦是所作。次句亦是所作。下句结。无量门是天王。即是入佛海故名佛能见也

第十五西方毗楼波叉。此云杂语主。新名丑目。领二部。一富多那此云热病鬼。二一切龙。依须弥藏经龙报有五种形。一善住龙王为一切象形龙王。二难陀龙王此云欢喜。为一切蛇形龙王三阿那婆达多龙王此云无热恼。亦名清凉为一切马形龙王依谤佛经此龙王远离诸龙三种过患。一热沙不堕其头。二不以蛇形行欲。三无伽楼罗畏。又举阎浮提龙皆有四苦。谓三种如上。更加风吹宝衣露身生苦。唯此龙王独免斯恼故曰清凉。依智论此龙王是七住菩萨。四婆楼那龙王此云水。为一切鱼形龙王。五摩那苏婆帝龙王亦名摩那斯。此云慈心。亦名高意。正云摩那。云意。斯云高。谓有威德意高余龙。为一切虾蟆形龙王。又如律中说诸龙初生及死时。睡眠行欲此四时。不能变形。余时皆能变也。十中初内二释。一约相灭炽然救龙热沙苦也。济恐怖救金翅苦也。二约实灭恶炽燃救恶趣因。下句济恶趣果也。二中四释。一能转龙身现应机色。及佛净德名不思议。二能于一念成上事故亦名不思。三一毛孔现亦名不思。四龙身即佛身。是故佛毛孔现即名转龙身。亦是不思也。三声演深法诸趣齐闻。四中一示众生德海于佛毛孔。二摄众生入大功德海。五德叉伽此云多舌。舌有多故。或由嗜语故名多舌。又云名能损害者。谓此龙王若起嗔时。于世间人目视气歔皆令舍命故以为名。佛智净光救恐怖苦。六于佛身现十方佛像。含雨润机名无量云。多劫严土名超度等。七毛孔现土名安立等。于中说法名分别等。八法称物机故令欢喜。由离染故。知足故。巧证故也。九中一约性满等观。二约为机齐等。十众生为嗔盖痴覆。以悲度脱名离苦。又此龙王于鳞甲中。流出诸水。日夜不竭。济阎浮众生故名悲也。颂中非次。初二颂前初二法门可知。三中初半颂净法轮。后颂闻声。四超颂第十法可知。五六颂二法可知。七中初半颂现云。下半颂住寿等。八中初半颂安立界。下半颂分别等。九中初半举往因。下半颂善恶音声。皆为度生故名平等。十颂前第八法门可知

第十六北方多闻主领二部。一夜叉此名轻捷鬼。二罗刹此名可畏鬼。如罗刹女夺人精气。众生心孔中有七渧甘水。取一渧令人头痛。二渧令人心闷。三渧令人身病。四谛已上令人死。此八部中唯紧那罗龙。毗舍阇是畜生。余五皆鬼。以夜叉罗刹力大故独与鬼名。是故上文名此为鬼王也。此有八王。一等观理智也。方便量智也。此是能救下成救事。初离恶次益善。二中一普应机现胜身。二普济生成胜益。三中精气有二。一恶气谓烦恼业苦。以此中是法门夜叉故能除彼也。二善气依大集经说国内帝王敬奉三宝。令此国中三种精气增。一地气谓五谷熟成等。二人气谓烦恼轻薄颜貌悦泽等。三善根气谓常转法轮三宝炽盛等。此文中据生菩提分善根名生气也。四智观佛德。言叹显法。五理智观众生即佛法身。量智照十方众生业果故名也。六中与乐有二。初则斥邪示正乐。终则堪化令调乐。七中一任持自体力用救生。二持用智力救生也。三谓佛福智。是地持论三持中毕竟持也。然此福智超过众生。是故有力能救彼也。颂中顺此。八多劫修因。因能顺果故云佛具十力。颂中次第各颂一法。初二可知。三中初半颂夺精气。后半颂生精气。四中初半明往昔观叹诸圣德。后半明今成已德令他观叹。五中初理智。后量智。六中二乐可知。七中初由有力救故令福胜。后慧深。八中初半明起随顺。后半明佛力也

第十七力士众有十。一示佛色身出世。二一一毛孔重现光色。三中法身无涯名离垢。起用普应名自在等。四中净音有四义。谓深故广故妙故益故皆不可量也。下颂中四句如次应知。五中二初处中现身。后众中说法。皆有多门故云种种。下颂中各以二句如次应知。六中二一摄相归真故无不入真之余相。二从真起用故无真不入真之余用故名也。颂中如次各二句显可知。七中移情住法名举也。实通一切就净名天。八中初功德体。此具因果。颂中初二句因。次一句果。广照是用。颂中后一句显也。九中现佛身土令机灭恶住善。颂中初现土。后现身。十光云遍世洒法宝雨故名也。颂中十偈各颂一法。如前应知

第十八普贤众中何故前中人人各得一法。此中一人具多法耶。以前是总中别故。异生故。此是别中总故同生故。又何故前列多人此唯一耶。以此人是形居道位德标普门。彰一即一切一切即一。以普收别故也。文中有二。谓直说重颂也。前中二初总后别。总中初自分后胜进。别中十门。一严土调生。此二相即融成四句。可知。二称佛遍尘沙起佛德。三中五位十愿。二行可知。四中一门有一切门名普门。于中现一身即一切身名法界身。身皆洒法雨故名云也。五身作诸刹名护持土。于中复以三轮调化故名也。六遍诸佛国大会现身名众中现。说此一乘菩萨本行名菩萨境界。七中生灭是极促也。三世劫是极长也。一念如是知极速也。此中知有三义。一穷彼长短际。二知彼相即入。三达彼平等性。此三无二故也。八菩萨根欲是能观。境界海是所观。辨此二别名分别显。此中或举境明根。或举根取境。或俱显可知。九中身有二。一性二用。法界亦二。一理二事。如次二身遍二法界。二界两身自互相即。四句无碍思之。十中初广明因法。后入一切下明其契果。又初以一言说一切门名广等也。后一一门中复显一切法名入等也。颂中顺后释。颂中二十偈两偈次第颂一法门。由因果无二法体全收。故直说显因。重颂明果。文绮互耳。初二偈中初一严土。后一调生。二中初一诣诸佛。谓见犹诣也。后一起功德三中初一依位起行。后一依行入证。四中初二句颂普门。次四句颂法界身。下二句颂云。以下法雨故名教导等也。五中初一颂持佛土。后一方便轮。六中初一颂众中显现。后一菩萨境界。七中二偈内各上半所知谓长短也。各下半能知谓达真也。八中初一颂菩萨根欲。此与长行文绮互也。后明境界海。九中初一体遍。后一用充。十中初一颂广辨菩萨法。后一明入一切智。又亦可通颂。此中释普贤分齐以八门明因陀罗网。可以知之。一理。二土。三身。四教。五法。六行。七时。八事。事即尘等也。泛论大意约文有二。一但有使习烦恼染业及报并入凡境。自外入圣境。圣中有二。谓理量。此二各有二法。因陀罗网境界是理中量及量中之一分耳。可思准之

第二。明海慧等内众者。显因果同体故。依正无碍故。境智无二故。缘起楼观内因外果。内即外故出菩萨也。文中有三。初明出处。二所出人。三兴供养。初中一座在楼观内。此是如来别住处故。二楼观即座。如上云宝台是也。二所出中有三。谓标数列名结数也。三供养中三。谓身意口。初一财。后二法。前中二初正供。后随所下归静。初中三大。一供大。二心大。三田大。前中二。初有五事。谓散华烧香放光作乐雨宝如文。此等皆并是缘起法门之状。所谓行华戒香智光语音及所说法宝。然亦不坏华等事相也。下明供分量。分量中初明供多。后明供广。下皆大喜下明心田二大。田中先佛。后大众。并可知。问何故外众不辨财供。此中说耶。答外众财供非显胜故。内众财供显奇特故。此别显也。下文雨供具等是通论故。二意业法供中二。先法。后供法中二。先明所得。后具足下结成满。前中二。初句约境标门。下二句释显二利。二约智标门。下二句释显因果。后结成满于中先结因圆。经云。爱有二种。一饿鬼爱。二法爱。如来无饿鬼爱。怜愍众生故有法爱。此中妙智巧取真理故名法爱。爱即无相名大力也。后结果满。于中初句智德。后句断德。又初句修成。后句入理。又初无常德。后常德。又初有为。后无为也。下正以供佛。问何故财供中通供佛及众。此中唯供佛耶。答显法供深细唯佛穷故。第三语业供中先标人后偈赞。以一一严具中各出海慧等众。今总标举诸众之中各一上首俱名海慧。同说此偈。故云一切海慧等也。颂中十九偈。义分有九。一初一明体净。谓境智无碍。二三偈明相满谓三世间故。三二偈明用胜。谓初速后益也。四二偈明往因深固。五一偈叹众观无厌。六四偈叹严座。一主二香三鬘四光也。七二偈叹说法。八二偈叹处圆满。九二偈叹佛普遍。如结通等

第二大段。发起序于中有二。初动地。二兴供。初中三。先佛力动因也。华藏动处。六种等动相也。此中四句分别。一动处。二动相。三所为。四泛明动时。初中问。何故此摩竭国即云是华藏界耶。答准下文中通有四句。一或云此界唯是娑婆。此约三乘说。或云即是华藏。约别教一乘辨。或云华藏中娑婆界。此约同教一乘说。或非华藏非娑婆。此约国土海平等性说。是故随所说法令处差别。今此文约别教说耳。第二明动相有二。一六相。谓中踊边没等。中边四方为六也。此约三乘及同教。二十八相约别教及同教。动是掉扬不安。如风动树。依涅槃经小动名地动。大动名大地动。有小声名地动。有大声名大地动。独地动名地动。山河树木及以大海一切动名大地动。又动名地动。动时能令众生心动名大地动。此等约三乘说。今此中动有三品。一动谓一方。二遍动谓四方。三等遍动谓八方又四方八方十方。又初独一方动。二十方次第动。三十方同时动。又大般若中名动等动等极动。下五相皆准此。各有下中上亦名小中大。故有十八也。起是摇起如面起。同性经中名作摇。大般若中名击。谓加打也。觉是大声惊悟。同性中名声。大般若名爆。地论释名上去。振是下声隐隐。地论名下去。吼是平声哮吼。涌是涌出峰桶。如泉涌等。又六方踊没。谓东踊西没等。又动起涌三是色。余三是声。此六皆名动者初一就胜通名。余五从别为目。如十色处同名色处初色处亦名色处。三明动所为者。依胜思惟梵天经论说。一令诸魔生惊怖故。二令说法时大众不起散心故。三令放逸者生觉知故。四令众生念法相故。五令众生观说法处故。六令成就者得解脱故。七令随顺问正义故。八智论云欲令众生知一切法空无常故。九古德云动其所执故。十表说大法现征祥事故。又依地论依四种众生。一依不善众生。二依信种种天众生。三依我慢众生。四依咒术众生等故也。第四泛明动时。如智论说有八时。如长阿含说。一大水动时。二尊神试神力时。三如来入胎时。四出胎时。五成道时。六转法轮时。七息教时。八入涅槃时。九若依增一经第二十八中。更加大神足比丘心得自在乃至观地无相故动也。十若依智论第十。授诸菩萨记当得作佛为天地人主。是时地神大喜。我今得主。是故地动。如王初位臣民庆喜称万岁歌舞等也。又依涅槃经。菩萨下生阎浮提时名大地动。菩萨出家成道转法轮般涅槃是以大地六种振动。何以故菩萨下生。欲色诸天及诸菩萨等悉来侍送。发大音声赞叹菩萨。以口风气吹故令大地振动。又菩萨是人中象王龙王。龙王初入胎时有诸龙王。在地下或怖或怯。是故大地六种振动。第二兴供文中二。初此土。后结通。前中世界诸王有二义。一是前所列王众。二是余十方世界中王。通是二也。于中初总。次别。三结可知。上来唯明一世界三世间自在相竟。第二大段明结通十方。以一会即一切会显教圆满。摄主伴故。于中有二。初牒此土三世间相。后正结通。前中佛坐道场者牒智正觉及器。此二果德融遍十方义相显。故不别释也。众生世间同果普遍义相隐故。是故别释。何故此众能同佛果而普遍耶。释中有二。初辨其所因。后正同果遍。前中三。初定慧力故。二法门力故。三如来力故。初中各随已得法门分齐故名境界。依三昧门不味定故。不废用故。巧摄法门令普遍故名方便也。欣厌是慧也。二法力中圆法法尔速遍诸方。速令至果名勇猛法。菩萨证此随法普周故云通达。此同上文乘解脱力入如来海等。三佛力中佛力令入佛境界中故能遍也。下句结同果海。度是到也。彻也。此等并是上文一一所得一法门。但前为显德据别广陈。此为牒结就通略举。下类通可知也

华严经探玄记卷第二华严经探玄记卷第三

        魏国西寺沙门法藏述

    卢舍那佛品第二

自下明正宗　将释此文四门分别　一释名　二来意　三宗趣　四释文

初释名中。卢舍那者古来译或云三业满。或云净满。或云广博严净。今更勘梵本具言毗卢遮那。卢舍那者此翻名光明照。毗者此云遍。是谓光明遍照也。此中光明有二种。一智光。二身光。智光亦二义。一照法谓真俗双鉴。二照机谓普应群品。身光亦二种。一是常光谓圆明无碍。二放光谓以光警悟。此中遍者亦二种。一平漫遍无碍普周故。二重重遍如帝网重现故。此二圆融。各全体遍非是分遍。是故下文云。佛身充满诸法界。普现一切众生前。如是等无量如文说。此中身智无碍故身光即智光。二遍无碍故平遍即重重。光遍无碍故光明即遍照。遍照性开觉。是故名为佛。此明下文世界海等诸事一一皆是称性缘起无碍离闇觉照称光。无不普周法界名遍。此舍那佛非局报身。以通器等三种世间具十身故。问如下文中略明五海。广辨世界。何故不云世界品乃题佛名耶。答古德释云。以从主为名故以主胜故。举土主以说之。今释以佛通三世间故。下文土等即是舍那佛。如十身中国土身等。又以依正无碍故是故标释。互举文绮耳。又以五海中佛海即具余四海余亦尔。以佛胜故。独标为轨故以为名。余不说也

二来意者。前既序已。次显正宗义次第故。是故次来

三宗趣者有二。一约人二约法。人亦二。一化主。二助化。各有体相用。主中内证法智为体。七日思惟解脱为相。加说为用。此三不二唯是一果。助化中入定为体。蒙加为相。起说为用。此三不二唯是一因。此上因果融摄不二唯是一人。法中亦二。一约义理。二约教事。亦各有体相用义。理中性海为体。别德为相。应教为用。此三不二唯一义理。教事中本分内五海十智为体。十世界及华藏界为相。益机为用。此三不二为一教事。此上教义融摄不二为一法也。又上人法复圆融不二为一宗趣。此四义各三为一缘起相即无碍。是故或唯果以俱是佛故。或唯因俱是普贤故。或教或义或人或法或体或用或主体乃至或教用。并皆摄尽准思可见。下诸会宗皆有此相。但随法异耳

第四释文中有二。一通辨经论解释分齐生解方便。二别释本文初中略有十种方便。一解释决择。二释文方轨。三四种悉檀。四四意趣。五四秘密。六四道理。七五力。八六相。九六释。十八声

第一解释决择者。依杂集论第十五云。释决择者谓能解释诸经宗要。开发彼义故。案云彼中略开六种。广有十四具如彼说。今略举一门。论云。摄释门者。谓若于是处宣说诸经缘起所以句义次第意趣释难。案云缘起所以者显教起所因也。句义次第者品会文义相生次第也。意趣者显经宗趣也。释难者释外妨难也。余如彼论恐烦不述

第二释文方轨者。摄论第五云。若有欲造大乘法释略由三相应造其释。一由说缘起。二由说从缘所生法相。三由说语义。无性释云。为欲开晓诸造释者解释道理故说略由三相等言。世亲释云。由此三相随其所应应造一切大乘法释。案云初由广说自性缘起为所依本。即阿赖耶识与诸法互为缘起。二依此所生转识诸法于上分别三性道理。谓于依他所执无圆成有得不得见不见同时等。如论具释。此二门观道理解释。三由说语义。谓显佛言下义意此有二种。一德处谓显佛果二十一种殊胜功德。无性释云。已得在已圆满饶益。故名为德。二义处谓显菩萨三十二行相。无性释云。未得在已随顺趣求。故名为义。此二所说皆以初句标。余句释。此是观说者意解释

第三四悉檀者。智论第一云。有四悉檀。总摄一切十二部经八万四千法藏。皆悉是实无有相违。一世界悉檀者。有法从因缘和合故有。无别性。譬如车辕轴辐辋等和合故有无别车。人亦如是。五众和合故有无别人。若无世界悉檀者佛是实语人。云何言我以天眼见诸众生随善恶业死此生彼。当知是人以世界悉檀故非第一义悉檀。二者各各为人悉檀。观人心行而为说法。于一法中或听或不听。如为断见人说杂业故杂生世间得杂触得杂受。如为常见人说无人得触无人得受如是等。三对治悉檀者。对治则有。实性则无。如酸碱等于风病名药余病非药。不净等于贪等亦尔准之。四第一义悉檀者。一切法性一切言论差别皆悉平等一味。解云。或约世界说有胜义为无。如第一说。或胜义为有世界为无。如第四说。或对异机说有对余机说无。如第二说。或治此病为要于余病为非。如第三说。皆须得其本意法悉有用。随言混取失意成谤

第四四意趣者。杂集论第十二云。由此四意趣故。方广分中。一切如来所有意趣。应随决了。又庄严论第十三云。诸佛说法不离四意。摄论第五云。以此决了一切诸佛言教。一平等意趣。谓如说言我昔曾于彼时彼分即名胜观正等觉者。无性释云。谓一切佛由资粮等互相似故说彼即我。非昔毗婆尸佛即今释迦。楞伽中约四义释。一字等二语等三身等四法等故说即彼。而实非彼。二别时意趣。谓如说言若诵多宝如来名者便于无上正等菩提已得决定。又由唯发愿便得往生极乐世界。无性释云。谓劝懈怠不能于法精勤学者故作是言。此意长养先时善根。如世间说但由一钱而得于千。庄严论释。此由别时得生故。解云以后别时得彼千也。三别义意趣者。谓如说言若已逢事尔所殑伽沙等佛。于大乘法方能解义。无性释意约证相大乘。不就教相大乘故作是说。庄严论云。如佛说一切无有自性故无生故。解云此约证无生说。四补特伽罗意乐意趣。谓如为一先赞布施后还毁呰。尸罗及一分修当知亦尔。无性释云。先为悭贪赞叹布施。后为乐施毁訾布施。余戒修亦尔。庄严论云。由得少善便为足故赞毁也

第五四秘密者。杂集论云。如是四种于大乘中略摄如来一切所说秘密道理。梁摄论第六云。如来所说不出四意四依。依即密也。无性摄论第五云。四种意趣四种秘密。一切佛言应随决了。一令入秘密。为化怖断有情。依世俗道理于声闻乘中说有化生等诸有情。于大乘中说心常等。此则于大小乘说有人法。并是秘密。庄严论云。应知教诸声闻入于法义令得不怖。说色等是有故。二相秘密。谓于是处说诸法相显三自性。无性释云。为令悟入所知相故。解云此虽说法相意显三无性故为密也。又庄严论云。应知于分别等三种自性无体无起自性清净说一切法故。解云此虽说三性意显三无性。如次可知。三对治秘密。谓于是处说对治行八万四千。解云谓于无说有于同说异等皆是密意。对治所化有情障故。说此八万四千等也。四转变秘密。谓如颂曰。觉不坚为坚善住于颠倒。极烦恼所恼得最上菩提。无性释云。刚强流散说名为坚。非此坚故说名不坚。即是调柔无散乱。定即于此中起坚固慧觉彼为坚。解云散心流动显名不坚。散心刚强就密名坚。定心守境显名为坚。定心调柔密名不坚。若取显了于散乱起坚固慧。则远菩提。今取秘密于定心起坚固慧。则得菩提也。无性云。谓于四颠倒善能安住知是颠倒。决定无动。解云若取显了则住于无常等计常等四倒之中。岂得菩提。今取秘密知此常等于无常等横计而起。决定知此名为善巧住于颠倒故能得菩提也。又世亲释云。是于能颠倒中善安住义。于无常等谓常等名颠倒。于无常等谓无常等是能颠倒。此义则倒彼所计义名颠倒。于此安住故得菩提。言极烦恼所恼者无性释云。为所化有情精进劬劳所疲倦故。解云若取显为贪嗔等恼乱行者名为烦恼。此则远菩提今取秘密精进勤苦劬劳行者亦名烦恼。此则得菩提如颂处生死久恼但由于大悲。梁魏摄论及世亲庄严对法等论并准可知

第六四种道理者。杂集第十一。因辨观察契经等法应当解释诸法道理。道理有四。一观待道理。二作用道理。三证成道理。四法尔道理。案云观待有二。一俗谛缘起要相待生。因此通染净。二真谛之理待了因显。此唯约净。二作用亦二。一缘起诸法各有业用。二真如法界依持等用。三证成亦二。一比量成立。二现量成立。四法尔亦二。一诸缘起法有佛无佛性从缘起。二真如法界性自平等

第七五力者。思益经第二。若人能于如来所说文字语言章句。通达随顺不违不逆。和合为一随其义理不随章句言辞。而善知言辞所应之相。知如来以何语言说法以何随宜说法以何方便说法以何法门说法以何大悲说法。梵天若菩萨能知如来以是五力说法。是菩萨能作佛事。案云下经次第广释。初言说者如来说三世法垢净法世出世流无流等法。是言说如幻人说无决定故。乃至云说如虚空无生灭故。当知是言说为无所说。乃至云是名如来言说。二随宜者如来或垢法说净。不得垢法性。故或净法说垢。贪着净法故。乃至云生死是涅槃无退无生故。涅槃是生死以贪着故。实语是虚妄以生语见故。虚妄是实语为增上慢人故。如来随宜故或自说我是说常边者。乃至广说。三方便者如来实不得我人众生寿者。亦不得施亦不得悭等。乃至方便为诸众生赞说布施得大富等。乃至广说。四法门者谓六根等诸法皆是解脱门。以空无我所性自尔故。乃至文字亦尔。五大悲者佛以三十二种大悲谓一切诸法无我。而众生不信不解。如来于此而起大悲。乃至广说。案云。此上五种初一约能说。以不言之言而说故。二约所说谓法随迷悟辨是非故。三约所为机。以巧方便于无说有故。四约法自体。本来自空为解脱门故。五约能说之心。为愍物迷而起说故

第八六相者。十地论第一云。一切所说十句皆有六种相门。一总相。二别相。三同相。四异相。五成相。六坏相。具释如下十地品中

第九六释者。亦名六合释。一依主释者亦名依士。谓两法相望假依彼主而立此名。如说眼识非眼即识以依眼之识名为眼识。若离言眼是能见义。识是了别义。今此合辨故名合释。若单法为名者非六释所收也。二持业释者亦名同依释。谓举其业用以显自体。如说藏识。藏是业用。识是其体。藏即识故。持用释体非是别体相依。既非二法何名合释。以体用不离故名合也。三有财释者亦名多财释。谓从所有物以立其名。如说佛土。土是佛之所有名为佛土也。四相违释者谓如一句中有多名言。各别诠义。如偈说于佛及法僧等。非如依主持业等虽有多言同目一义也。五邻近释者谓从所近以立其名。如四念处观。实以慧为体。以与念相近名为念处也。六带数释者谓以数显义。如说十地等。皆从数以显义别也。问此六释摄法尽不。答凡诸法得名略有五例。一离合得名。如此六释。二单法当体立名。如信等。此约直诠。三无他受称。如无明等。此约遮诠。四譬类得名。如华严等。从喻彰名。五相形立号。如大乘形小以立其名等。是故六释但据初门。若于前六帖后四释。总为十释。略摄诸法得名差别

第十八声者依西国法。若欲寻读内外典藉。要解声论八转声法。若不明知必不能知文义分齐。一补卢沙此是直指陈声。如人斫树指说其人。二补卢私是所作业声。如所作斫树。三补卢崽拏是能作具声。如由斧斫。四补卢沙耶是所为声。如为人斫。五补卢沙[多*頁]是所因声。如因人造舍等。六补卢杀娑是所属声。如奴属主。七补卢铩是所依声。如客依主。瑜伽第二。名上七种为七例句。以是起解大例故。声论八转更加[彳*契]补卢沙。是呼召之声。然此八声有其三种。一男声。二女声。三非男非女声。此上且约男声说之。以梵语名丈夫为补卢沙故。又此八声复各三。谓一声。二声身。三多声身。则为二十四声。如唤丈夫有二十四女及非男女声亦名有二十四。总有七十二种声。以目诸法可以准知。然此方多无此例

第二释文者。此品有二分。初大众疑请分。二尔时世尊下如来现答分

前中分二。先明诸会请问。后释此文。前中作四门

一明有无者于八会中初二后二有。余会皆无。何以尔者谓初会标果起因故。问第二会初为寻因至果故问。但为因位升沉寄于五会以答果位无差。故当会答。然五会中间诸品之内更有余问者。并是为显当会所说法中差别随说问答。非是别问大位之相。第七会中明因果纯熟故有问。谓行修无碍六位顿成故当会答也。第八会中明称性因果故有问。谓俱入法界无差别故亦当会答也

二所问法不同者。初会第八唯果分有因。但所信摄化为异。第二第七唯因分有果。但位行为异

三能问人不同者。初及第八各具同异二众齐问。以所问法众同依故。第二唯同生众问。以所入位同生胜故。第七唯一人问。以造修之行各别成故

四请问仪式者有二。一约言念。二约通别。初中泛论请有二。一言请。二念请。答亦二。一言说答。二示相答。此二问答如次及交络成四句可知。为成三慧有斯二例。初二会及第八唯念请。答通二。谓佛示相答。菩萨以言答。以对佛兴请不待言故。明佛智领疑身相现答自在故也。第七唯言请言答以行法约言明了显故。又对普贤兴问还普贤答故也。二通别者初会及八别问通答。第二第七别问别答皆可知

二释文者。此中有二。初长行。后重颂。此二差别大例有十。一约利钝。谓钝根未悟更重为颂。二约前后。以后来未闻为之重颂。三约生熟。熟人直说便悟。生类曲巧方知故重颂也。四约文质。或有爱质直示长行。或有乐文示颂言美妙。五约二持。论云长行散说生正解故义持成就。偈颂总摄易受持故文持成就。六约资成。谓更以偈颂资显长行义明了故。此上通诸文重颂。七约成圆。以颂中兼显长行阙无成前所说。义圆满故。此如发心功德品偈等。八约体相。以从门约相长行直说。此约同教及三乘。以就体圆融偈颂巧显。此约别教。此如十行品偈等。九约通别。以长行别指的重颂通该摄如此品世界等颂文是也。十约心言。谓长行直显心所念法。偈颂宣示令请圆满。此唯此文也。又有义凡佛说法法尔有二相。谓直说契经必有祇夜重颂。下诸品中重颂皆约此十例准之。就此长行中有三。初标能问人。谓同生异生俱在法界故云咸也。言说事彰非显奇故。念心入法显深细故云念也。二明所请法。三唯愿下结请。所请中古说云。此有二十三句分二。初二十一句问果法。后二句问因行。前中准下答中五海。此文为五。初十二句问佛海。次三句如名问三海。后六句准下当是根欲性海。但由根欲不同致能被之缘差异。此中举缘显根。下文举根显缘有斯左右。今更释此中有三十五句分二。初三十句问果法。后一切菩萨下五句问因行。就前中分三。初十句问佛内德盈满德。二从示现菩提。下十句问佛外相显著德。三世界海下十句问化用普周德。就初中初一句总余九别。于中何等是三字贯三十五句。一切诸三字通前三十句。果问应知。何故此经最初问佛果法耶。谓标帜故宗归故为本故显德故生信故指南故。经首题佛华严者义存于此。言佛地者。佛地论第一云。清净法界及彼妙智受用和合一味事等。是佛所依所行所摄故名佛地。解云即以净法界为所依。妙智为所行。余功德等皆为所摄。即以真理妙智无碍为体。依大乘同性经佛有十地。一切菩萨二乘所不能行。何等为十。一名甚深难知藏明智德地。乃至第十毗卢遮那智海藏地如下十地章具释。二佛境界者下九皆是佛地中开出故是别句。谓开清净法界是佛所证之境。或总举所知通于真俗。下性起品云。一切众生是如来境界。乃至第十非境界境界是如来境界。又亦是分齐境界故。明难品中明十种佛境云。如来深境界其量齐虚空等。又释通有所知及分齐境。下不思议品中佛有十种不可譬喻不可思议境等。应寻下三处文于此具辩。三佛持有四义。一以净法界任持一切诸功德故。二以大圆镜智及相应净识各能任持诸功德故。三后得智中大陀罗尼门总持无量诸法海故。四是十佛中持佛随顺故。又下第十地佛力持等十持。又离世间品中亦十持。初佛持乃至第十智持。此二文中皆以初句为总。摄别入总俱名佛持。又如下不思议品佛有十种出生住持智慧等。并应具寻辨之。四者。准下颂文此中次佛无上智一句。此则是下十智等可知。五佛行者是大悲摄生之行。又是大智造作之行。此并不作之作。无思成事。性起品无障碍行如如行等。是如来行。此是异二乘功德。六佛力者有二义。一不为他所屈伏故。二能摧坏魔怨故。别说有十。谓是处非处智力等。又有十种。如不思议品最胜力大力无量力乃至第十大力那罗延幢佛所住法等。七佛无畏者所说不怯故名无畏。是伏外道功德或四或十如离世间品说。上来明大智德。八佛三昧者谓师子奋迅等微尘数三昧海摄略为十。如不思议品说。此明大定功德。九佛自在者依定发起无尽神通。所作无碍故云自在。不思议品佛有十种自在正法。又离世间有十自在等并可知。此明神通功德。十佛胜法者殊胜功德超过余德故云胜法。亦有十种。如不思品说。此明大福功德。上十句明内德盈满竟。第二外相显著中初示现菩提者。谓对机示现成大菩提。如性起品成菩提处说。又不思品亦说并应知。此是总句下九是别。以六根三业皆是成菩提相故。下不思品及离世品此之九门一一各以十门辨说加彼应知。佛光明是身业。余并可知。上来明外相显著竟。第三化用普周十句中初世界海者。是化用处也。通染净土。即入十佛国土身摄略说十种。如此品下文说。二众生海者是所化机也。通粗妙空有等。亦入十身摄。又如离世间品十种入众生等应知。三法界方便海者此有四义。一理性法界。是前众生及世界等所依之界。二染事法界。谓彼所化众生蕴界法等。三离垢法界。谓佛所得最净法等。四净用法界。谓佛摄生所用善巧故云方便。如不思品佛有十种法界无量无边等应知。四准下颂中此文阙调伏海。调伏海即是所调伏。是根欲性海摄。但颂与长行文家互有存略故也。五佛海者能化之佛非一如海。谓遍一切处而转法轮故。六波罗蜜海者有二义。一是佛所说行法。以授群机故。二是彼所化所行之行。即化所成益。谓十度等。七法门海亦二。一是佛所设之教法通彼游入故。二是彼所化行成证理所入之法。此亦有十。如不思品说。八化身海者异机别感现相多端。如云诸毛孔出化身云等。又卢舍那佛遍十方出一切化庄严身等。又离世间品十种变化等。九佛名号海者对根宜闻名号非一。如名号品。一一世界有百亿万等。十佛寿量海者应机修短亏盈万差略有十位。如寿命品说。上来果问竟。第二因问中五句。初一句总下四句别。一明十住初发心住等。二即十行中十度行也。三愿者即十回向大愿也。四智慧藏者即十地中以智为性。含摄蕴积故。如下地品菩萨同名藏等是也。第三结请中唯愿慈悲者。明佛有说因不疲倦故。方便者显佛巧说令易解。故由悲发心由巧得解。二颂中为显奇故。不以常口说。表依正无碍故供具中说。即是下刹说耳。九颂分二。初三叹德请。后六举法请。前中初二叹佛请。明具说因故。后一叹众请。明具说缘故。前中初一显佛自德圆。初半辨因尽过去现果无功。后半用穷来际无思普应。云者洒法雨故润机缘故自无本故。后一明外化备。谓初半令灭恶生善。后半令离苦得乐。又初令得涅槃。后令得菩提。二无量下明叹众请中。一心者心无异念故。合掌者身无慢怠故。观最胜者住念向佛故。下半总举所念愿佛开阐。第二举法请中分三。初三颂举前初十句。于中初一颂内有六句。一地。二境。三持。四智。五力。六无畏。下句结请。次一颂中有三句。一定。二行三自在即神力是也。下句请说。后一颂颂胜法。亦是示现菩提等可知。第二一颂颂第二十句。以三业不离六根故同颂也。第三二颂颂第三十句。初颂内有五海。后颂中有二海。余三海及因问总摄故云无量无边等。下句结请

第二答相中古来诸德亦有将此诸问配下诸会中答之。此判恐谬。以第二会等自别有问别有答故。四番问答不交杂故。是故总于此品并通答也。以下说分具果因二说故

就此文中长分有十　一面光集众分　二毫光示法分　三法主入定分　四诸佛加持分　五大众同请分　六定中略说分　七起定成益分　八毛光赞德分　九许说令喜分　十正陈法海分

初中二。先放光后集众。前中亦二。先身光遍觉。二光语呼召。此二亦即答上佛光明音声问。初中亦二。先此光照彼。二诸菩萨下寻光见此。前中有五。初知念者领疑也。以将欲答故即放光所因也。二明光出处。面门者诸德有三释。一云是口。一云是面之正容非别口也。光统师云。鼻下口上中间是也。准下施鼻文亦如所说。今释依梵语称面及口并门悉名目佉。是故翻此目佉为面门也。故知此中通举其事。口者为表教道遐被也。面者正对向机也。门者开法摄生也。齿者胜用也。谓思咀法味故。治碎惑障故。以缘起具德相差别故。云一一各放尘数光也。三别显所出有十门。通论一一皆通三世间等。别明初六佛海。次二器海。次一众生海。后一法界方便海。又前八意业记说轮。次一身业神通轮。后一语业正教轮。四摄眷属。五所照处。此中放光有四意。一现相表实。二惊起信心。三照触救苦。四为集众远召。是故彼众依光睹此知所集处。颂中九偈半。有四义。初六颂半通举佛德以劝往。次一别明能说以劝诣。次一别标所说以劝观。后一通结佛德显深广。此四皆以后释前思之可见。初中二。先举德。后人尊下劝往。前中三。初二身业。一体一用。次二意业。一用一体。后一语业。劝中初半劝为法。次半劝多众。次半教兴供。虽圆音顿说九世愿海。然不坏本法故非一念也。即标下所说法门也。余文可知。第二集众中先明诸会有四义。一有无。二来处远近。三本处名等不同。四偈叹及前后。初中六七二会无。以证位及行熟俱皆离相故。余六皆有。所为可知。凡集新众有四意。一为摄机。二为证法。三为兴供。四明众圆。第二远近者初二十刹尘。三百。四千。五万。以寄位渐增故。八过不可说者显证法深故。第三者一处二佛三菩萨四供多少并随会应知。第四者初二会无偈赞。以起修始故。余四皆有。以显法位增故。又前五定前集。以从修入证故。第八定后集。以依证起用故

二释文中有二。长行偈颂。初中亦二。先众集。二显德。初中亦二。先集后结。初中十方即为十段。一一方皆有七。一器海名。二刹名十二佛国土等。此二是所依法相。但通别为异。三佛名。四菩萨。此二是能入智。但满分为异。五主伴俱来。明具德圆满。六兴供供佛顺益义。谓因顺果也。七依本方坐。明摄散归静。何故先辨东方。谓显开明之始故。顺彼方故。以西域方仪以东为上故。其堂殿皆面向东。如祇洹寺菩提寺皆面向东。如来说法亦多分面向东。故面门光出正即向东。问下文此华藏界无边。云何此中有东等耶。答以华藏界是边无边不二故名无边。如下说。无边边不二故名有边。如此说。是则不坏边而恒无边。不破无边而恒边若谓无边乖于边边乖无边。是情计所及法非正缘起也。以此边无边是一事故。双超情计也。其犹锦窠白线彻编而不杂紫窠。紫等亦尔。又白窠有紫由是绵故。若白中无紫紫线不至两编即绣非绵也。白窠无紫由是绵故。若白有紫现则坏文非绵也。是故由白有紫得成。白无紫无白亦尔。当知。此中道理亦尔。思以准之。问若尔彼十方世界是华藏不。答是不。谓由即是故不是。不是亦尔。准上思之。又何以故。由是华藏东等故即不即也。问此十世界外更有余界不。答无也。何以故。以华藏为主彼十为伴。此主及伴圆融普遍一切尘道重重如帝网故。余皆即此。如虚空故。又此中诸供并是法门。随相有十。一妙宝是可贵义。二须弥胜高义。云是润益义含两义。龂齶义。三日是除闇义。轮是具德义。四阁是重成义。如正智上起悲等。五华是净义。开敷义。六香云是戒等芬芳义。七座是摄益义。八盖是荫覆义。九幢是独出义。十树是建立义。余并准之。又约法亦有十例。一或以色法为云。如宝妙色云等。二以大声为云。如妙音及叹佛德等。此约事。三以无尽佛土为云。如十种不思议佛刹云等。此约依报。四以九世理性为云。如三世佛法身光明云等。此约体。五以佛八相等为云。如十种佛变化云等。此约用。六以无碍解脱法门为云。如十种解脱盖云等。此约不思议解脱也。七以佛所证境为云。如十种佛境界云等。此约果。八以一切菩萨行为云。如十种菩萨所行示现云等。此约因。九以一切众生欲乐为云。如十种一切众生乐不可尽示现云等。此约法器。十以现佛大愿为云。如十种一切诸佛所愿示现云此约赴机。此等一一皆以十门说者为显无尽故也。此上十义皆一一中有一切法。缘起无碍。是故或人或法或理或事或境或行或依或正或因或果。此中一一供具皆云满虚空者。明称本性空集而不杂如缘起性也。是故真理妙行可即事而成。云华宝等事可即理而为法。此约别教思之。第二结中。一结土。二主。三伴。四供。五座。第二现德用。次第座者缘起无碍集而不杂也。于中二。先明德体无碍。后念念下妙用胜益。前中通用中初句总有六重无碍。并倍倍多前。一身光无碍。二光人无碍。三人法无碍。四尘刹无碍。五依正无碍。六化用无碍。如一念中于一世界化一佛刹尘数众生。即此念中于一切世界亦如是化。一念既尔。余一切念悉皆然也。如一刹中现此尽念三世诸佛。余一切刹各别所现亦如是也。如一尘中有此一切现佛之刹。余一切尘各别亦尔。如一菩萨法门遍此一切现刹尘道。余一切菩萨法别遍亦尔。如一光出此一切遍尘菩萨。余一切光别出亦尔。如一毛孔放此一切出菩萨光。余一切毛别出亦尔。上来总辨一菩萨身中事。如一菩萨一切亦尔。如主伴亦然。是则重重无尽非心言能及。此是一乘法界法尔缘起实德非变化也。此等并是普贤位德。菩萨既尔。佛果德用非此能比。可准思通。二用益中三。初标所化众二以梦下明能化法。三于一念下辨化益。能化中十句。初九别辨。后一总结。九中一梦自在者即实即空故。一念现多法故。二净故化故。三教义故。四显胜神通令归依故。怖令入法故。动相归真故。五愿力摄生故。六深音性离故染音净用故。显净音普收故。七圆音普降故。如法界头口等。八体用惊机故。九建圆因故。三蒙益中有六故。释有四重。以文含多势故。一令离重苦。二堪成出世器。三令得二乘解脱果向十位。此大乘中二乘非愚法也。又小乘中五停心观前在邪定。依成实暖顶已上悉名正定。永不退故。依毗昙忍心已上方得不退。若依地论见道已上方名正定。故彼云正位正定者见道已上方是正位。言不定者此二中间名不定也。四入大乘三贤位。五证十地。六成佛果。此约同教。又初三同前。四入初教。五入终教。六入顿教。此约病尽处说三。又初人天。次二小乘。四是渐教。五顿。六圆。此约果显圆说四。又初人天。次三三乘。后二一乘。因果分二也。此上并是一念中益。余一切念准之。颂中十偈。初五总叹菩萨德。后五颂前法门。初中前三明自分德。一自利。二化他。三得法。后二胜进。一外益。二内圆。后五中。一现法。二动刹。三身严。四入劫。五说法。此等并是上毛孔中事。颂文巧略故也

第二光示法主分中二。初此界。后结通。前亦二。初示主是教义源故。二于彼下示法是教义相故。初中四。初明光意。言无边佛境者有三意。一令知所说法故。二即是普贤故。三显佛非不能说故。二显光名相中二。先明光相。眉间表中道一乘法也。白毫表无流证道白净法也。又白为众色本故。表此一乘为诸教源也。又毫者是长毛也。又是毫毛也。依观佛三昧海经云。太子时舒长五尺。树下长一丈四尺五寸。成佛已放之长一丈五尺。圆卷如秋满月。分明皎净珂雪宝色光体也。灯明光用也。又理可贵故名宝色。智普照故名灯明。境智遍益故名云也。又如未尼同诸色故。二立光名为显因人故名菩萨也。三辨光胜用中。一事故遍故广故。二理故正故深故。三辨说因故由大愿力方有说也。四显法门故令众知法从普贤门中出故。上文既不云别照普贤。何故乃云显现示众者。以上所照即是普贤故。四摄用归本中。毫出足入者。表上法可以传下。传下不失本故还入也。眉间足下处别。何故言还者。显上下无二故。又毫光照普贤明果乘因。还从足下入者明因成果也。第二示法中二。初辨莲华是所诠义也。二显胜音是能诠教也。坐华者称义施教也。初中一句总。于彼者场地也。又是相轮也。莲华者开敷故。出三乘水故。不染故。微妙故。众圣蜂所采证故。二宝茎者可贵故。坚固故。三藏者含摄故。出生故。具德故。四叶者覆盖故。以广大甚深故遍法界也。五香须者氛氲眷属故。六阎浮檀金是宝中之上故。金是贵相显著故。台是高出故。七结也。此等并法门也。若约三乘托此事别表法。然彼事非即法。若此一乘即彼事是此法。仍有事显现也。二显能诠中二。初标体。二偈颂明说相。前中三。先举教从佛眉间出者表依证起说故。教从佛出故。如胜流法界。又论云从最清净法界所流法也。出菩萨者为被因人故。诸法是所诠。胜音是能诠。论云。契经以文义为体也。若依一乘看此菩萨即名见教体。人法无碍故显教圆。故具主伴也。顺理故敬绕也。二明称义故坐台须也。三由称义故。令教诚实故叹德也。德中四句。一下惬群机。二上顺佛境。三穷兹义海。四令归佛果。二说相中二。初胜音明教体殊胜。二炎光明教威胜用。初中三颂。一明一佛遍法界而在道树。二多各遍法界之佛同坐一毛孔。三如一毛一切亦尔各具主伴。此三如是渐次增广也。又释。初一明舍那身满法界。后二明毛孔中现无量三世间重重无尽也。二教威中师子者有三种。一不畏义理深故光照也。二不畏不益故炎烧惑也。三不畏异学不降故奋迅也。同是教故亦名音也

颂中初明法轮义。后释文。前中转法轮义略作十门。一释名。二辩体。三种类。四转相。五分齐。六转处。七转时。八转人。九转机。十诸门

一释名者。法是轨持义通有四种。谓教理行果。轮是所成义。亦有四。一圆满义以离缺减故。二是具德义以毂辐辋等悉皆具故。三有用义谓摧辗惑障故。四转动义谓从此向彼即从佛至众生故。亦从彼向此即从众生至佛果故。法即是轮。持业释。又轮是喻。况如圣王轮宝即法之轮故。依主释

二体性者。通论教等四法为性。克性唯八正道为性。以戒为毂。谓正语正业正命。以慧为辐。谓正见正思惟。以定为辋。谓正定。余正念正精进为庄饰成轮。此约小乘。初教亦同。又唯以无分别智为法轮体。又唯真理为性。此约终教。或理智俱泯。教果亦亡。离言绝虑。为法轮体。此约顿教。或通摄无尽法界。谓人法教义等一切自在法门海并为法轮体。如帝网重重具足主伴等。此约圆教。亦即摄前诸位。此中皆具约同教也

三种类者有三。初小乘四谛之下各有四义。谓苦空无常无我此四苦谛。因集有缘此四集谛。灭止妙离此四灭谛。道如迹乘此四道谛。此上十六约所知谛。若约能知亦各有四。谓眼智明觉。眼谓总观苦等。智谓别观过去苦等。明谓别观未来苦等。觉谓别观现在苦等。是故四谛各四故成十六。新大毗婆娑论第七十九云。眼者谓法智忍。智者谓诸法智。明者谓类智忍。觉者谓诸类智。又眼是观见义。智是决断义。明是照了义。觉是警察义。三转十六成四十八行法轮。此约小乘。如毗婆沙论具说。二明三乘中法轮。然有三义。一同小乘三转四谛通益三机。如密迹经辨。此则说四谛而具三乘。又三转即空常净。维摩经云。三转法轮于大千。其轮本来常清净。此之谓也。此约初教。二唯说大乘亦通三根得大小果。如诸大乘经中所说。或分相开三。如转照持等三种法轮。或合为一。谓唯一实谛。上约终教。三离言法轮无转不转。非四三一。不可说故。此约顿教。三一乘法轮准下文有十谛差别。谓说诚谛等谛各十行。谓具足清净四无畏等。是故总有一百行法轮。准下文亦有十轮。谓过去愿力故等。即十转百行为千法轮。并寻下文应广具显。何以皆言十者。为显无尽故。此则无尽法界为大法轮海。常转无休息也

四转相者。小乘三转有二。一为自转。初转在见道名印相转。次转在修道名应作转。后转在无学道名已作转。二为他转。初名示相转。谓此是苦等令陈如等入于见道。次名劝知转。谓苦应知集应断灭应证道应修。令彼入修道。后名引证转。谓苦我已知乃至道我已修。令彼入无学道。若三乘法轮二。同前说。但义理差别。约菩萨人者。准大品等经既言鹿园转法轮时无量众生发菩提心等无量菩萨得初地等无量一生菩萨一时成佛。此亦应同彼三转。是通非别。不可别配。若依一乘转无尽称法界法轮。与所被机同一法界无二无别。法尔常恒无新辩益之谓也

五明法轮分齐者。若小乘中有一义。佛说四谛苦无常等语音入法轮摄。如问阿难天雨等如是世语皆非法轮。若三乘中佛一切语及身威仪皆入法轮。以无不益生故。维摩经云。诸佛威仪进止无非佛事。以此准之。若一乘中通三世间俱入法轮。一切众生语言音声亦入法轮。国土法轮如刹说等准之

六转处者。小乘唯一娑婆百亿鹿园等处。三乘或一百亿或千百亿或如恒沙为一佛化境。一乘遍通树形等界乃至华藏犹如帝网重重主伴。经云。此是卢舍那佛常转法轮处

七转时者。小乘三乘或二七日或三七日。复或六七日或七七日或八七日或五十七日或一年等。此并以是末教随机见闻异耳。亦无前后相摄等事。一乘本教要在初时第二七日。更无异说。仍摄前后各无量劫。念念无间。一一念中亦各摄彼前后际劫。亦如帝网重重无尽。九世十世之所转也

八转人者。先主后伴。小乘主谓释迦生身及化身佛。声闻弟子为伴三乘主即三身佛。声闻菩萨为伴。谓舍利弗等。一乘主谓卢舍那十身。普贤等菩萨为伴。亦如帝网重重现准之

九转机者。初唯为小机。次通被三机。后唯一普机准之

十诸门者。一教及念处等为法轮因。由此得圣道故。二福慧万行为法轮眷属。三真俗二谛为法轮境。四二障使习是法轮所断。五菩提涅槃法轮果。诸宗准之

释文者。颂中十偈分四。初三明佛法轮清净广大。于中初句标教主。次句明法轮清净。清净者灭惑染故现净理故教轮净故如梵轮也。下明法轮广大自有六门。初一句巧说广。二一句说人广。三二句说处广。于中国土海世界海双举者此二相成故也。四二句说因广。谓由大愿力说尽来际故。亦名说时广。五二句说机广。六二句言音广。二有二颂叹普贤能遍说法。一佛力加故令语业普遍。二身业称理亦遍雨法。三有三颂叹舍那佛说法。一语业。二意业出光也。三身业。四末后二颂叹三世佛亦同说法。一令见说法。二令闻说法。下结通有二义。一结上集众通十方界。二既在示法后结则知示法亦通十方。示法主分竟也

第三法主入定分。于中二。先料简诸会中有四。一有无者唯第二会无者以所表法未成位故。余会所表法位成故。二出不出者唯第八不出。以表一证法界无退失故。余表起化故。三因果者初及七八为果定。以初说果故。七行深故。八证玄故。余皆说因故。又释。第七中亦以通有因义以华严是因行成严故。若如此判通有四句。或唯果谓初及八。或唯因谓三四五六。或亦因亦果谓第七。或非因非果谓第二总无也。四能入人者唯第八佛自入。表法界解脱自在唯佛穷故。初虽说果为令物信故。七行虽深然是因人行故。二释文者于中二。先此土后结通。初中于佛前坐者显因果不相离故。何故入定者显非证不说故。为受加故。除众疑故。何故入果定。为说果法故。何故因人入。为被因人故。净有四义。一自性净。二治惑净。三善根净。四益用净。藏有四义。一含摄。二蕴积。三出生。四无尽。三昧此云等持。离沉浮故。定慧均故名等也。心不散故。住一境故名持也。纳法在心名为正受。此中净之藏。净即藏。如来之净藏。如来即净藏。净藏之三昧。三昧即净藏。皆二释思之可见。下释显其义。初句释如来。后句释净藏。离垢净也。满足藏也。虚空喻上二也。结通者此经一切处说总成一部。谓一部即一切部。今且举此一方中事。恐断其本部故。数于文末。钓取一切。结成本部。以明无尽无尽也。因此略明所入三昧分齐差别有十重。一约一切定无碍。故起分中言普贤菩萨从彼三昧起从世界尘数等三昧起。解云此有二义。一此定含摄多三昧故。二此定遍入多三昧故。是故此定即是尘等三昧海也。二约一切处无碍。如此文云普贤菩萨于此世界三昧正受。尽法界虚空界等一切佛刹亦复如是。此亦二义。一定中包含十方刹故。二此定遍于诸尘道故。三约一切时无碍。如起分云普贤从一切三世三昧起等。此亦二义。谓定含三世及遍入三际。四此上三重融含为一普贤三昧无碍自在。以此三说是一定故。不相离故。五于上尘等三昧海中随一即具一切诸定。各苞十方尽三世故。六如一三昧一切亦尔。七随一尘内即见普贤圆明三昧。各摄十方亦尽三际。八如一尘内一切尘道皆亦如是。九随一念中即有普贤。入尘等定各苞尘道。尽十方刹及穷九世十世等尽。十如一念中余念念中尽前后际。一切劫海皆亦如是。如此十重为则。余一切位中及教义理事等准此思之。入定分竟也

第四诸佛加持分中二。先辨诸会有二。初有无者二七八三会无。以二位未成故无入定故。七行依法不异前故。八佛自入定不假加故。余会非此故皆有也。二佛远近多少名异。皆如文应知二释文中三。先口加及所为。二意加。三身加。又初劝说以益辩。次冥被以增智。后摩顶而觉。然加赞互成有四句。一加而非赞如佛意身二加。二赞而非加如诸菩萨偈赞等。三亦加亦赞如佛口业。四非加非赞如余文也。口中二。初明加赞。二释所为。初中三。初明诸佛不移本刹而现身于此。以明彼即此而不坏彼故远即近而不坏远故也。如缘起性知之。二赞得深定。三明定因。初他力后自力。又果力因力缘起合成也。又佛本愿者明佛往昔曾见是事。因即发愿愿今成也。释所为中为何义故加。为说此法故。于中十句。初一总。谓一乘法轮最初转故。以是果法轮故云佛也。别中有九一所转义法轮体也。开犹现也。一巧转尽源。法轮相也。及十方者是结通处也。三妙除惑障。即法轮用也。四十方齐转法轮处也。又穷土海也。五转因入果法轮分齐也。六一门摄一切果法轮德也。七巧令乐果即法轮境也。八巧随世俗法轮方便也。九审根授法即法轮所被也。同异成坏准思知之。二意加中二。先加后释。初中一总余别。别中一得法智。谓五海智非一故云无边等。二尽边智。谓穷尽五海该三际佛。三成坏智。谓五海集散亦世界海也。四所化智。谓五海约染亦众生海也。五理智。谓五海皆深亦法界海也。六三昧智。谓五海皆定境也。七根欲智也。八语辩智。九身遍智。十圆音智此皆通五海等准之。与下十智大同也。释中先征后释。问诸佛有力有悲。何故唯加普贤不加余耶。答以长子故众首故尽佛愿底故本愿故普德具故得定法故余人不得故。又凡有此定处诸佛法尔皆聚彼。如海法尔摄彼众流故云法也。缘起法门理数尔也。是故诸佛智断亦得与人。问佛何不自说。答有二意。一所说既玄。恐因人绝分故也。若尔何不余人说耶。为说普法故。二明凡说此法必具一切诸佛共说。若佛自说则理无加授。便乖共说。是故普贤一说即一切佛说也。三身加中何故摩者。令觉故令具佛威德故。此中佛身未必来此。申手未必修延。各令触顶未必相妨。悉同时摩未必前后。皆是缘起自在无碍思之应知。加持分竟

第五大众同请分中二。初长行怪不即说以生后请。亦是具身意二业请。谓恭敬身也观察意也。二俱专住一心也。后正语业请中与上请何别。谓此别请普贤故。以知是说法主故。又此具新旧二众。故不同前也。所问之法不异前。故不别列也。十颂分三。初八叹法主请。二有一颂举所说请。后一颂叹众乐闻请。初中二。先有五颂。通叹普贤德

后三别叹说法德。亦即前叹有说因后叹有说果。前中略显普贤十种功德。一因行愿满。二果德平等。初一颂显之。三色身普遍。四福智深广。第二一颂显。五普见佛海。六能现尘刹。第三一颂显。七广遍时处。八深定常现。第四一颂显。九体充法界。十用遍生海。亦是前智后悲。第五颂显。又此十德摄为五对。一因果。二身智。三见现。四深广。五体用。下别叹说德中。初颂叹证断为因普周广说。谓初句证理。次句断障。次句普周。下句广说。二一颂叹内外为因能益妙说。谓初句叹普贤内证。一切佛德海生。次句叹外能普放说法光云。次句叹能益众生坚其净行。下句由此故能妙说佛境。三一颂叹深行为因能云雨说法。此上三中若约能说辩。一广说。二妙说。三顿说。若约所说。一佛法。二佛境。三法界。下一颂明所说法。初一句总举下文华藏界等。次句举下文佛严净事次句中能入是佛海法界海。所入是众生海及根欲海。下句结请。末后一颂叹众有二德堪闻。一乐欲。二根器。前中亦二。一身离慢怠故云恭敬。二心离异想故云观普贤。二根器中虽一心乐闻。若无智慧不能领受。此亦有二。一深智达深理故。二广智鉴广事故。下句结请愿说。同请分竟

第六定内略说本分中二。先观五海。后说十智。又前是所观之境。后是能观之智。又前是证本。后是教本。何故不起定而说耶。谓明定不碍用故。寄显法深故。双行故。初中二。先明境海深故观非自力。二正观审法五海略作十门。一辨义相。谓于无尽圆明性海藏中分兹五义。一是所依义通一切准之。二萌发义亦积聚义。三轨用义。四巧别义性别义。五觉圆义。此五皆一即具余四。并深广无尽具德难思故云海也。二约染净有二。一别者或唯净谓佛海。或唯染谓众生海。或俱谓世界及根欲。或不俱谓法界。二通者或俱净以众生等亦返流故。本净故。或染以佛等亦随缘故。或俱或不俱思准之。三约理事亦四句全摄可知四约人法有二先别者众生及佛是人法界是法根欲亦人亦法世界非人非法二通者亦具四句全摄可知。五约因果亦二。别中世界俱。法界不俱。余二句可知。通中亦四句思准。六约三世间七约境智。八约依正。九约三宝。此上四门皆有通别句等思准。十约融摄有二。先约海。谓世界即众生如下众生形世界。世界即法界如法界不可坏莲华世界海。世界海即根欲如心作世界。世界即佛如国土身。二约众生即世界。如前说。亦即法界如经。即此法界流转五道名为众生。亦即根欲如心心所作故。亦即佛是十身中众生身。又众生即真故。后三海一一即具余。皆思可见。二约智中亦二。先别初三智是前三海智。后七智是后二海智。二通者谓一智有五海。一海有十智。镕融思摄。五海深玄。寄半数说者令易信故。十智稍粗。寄十数说者会其本故。是故境智不殊。粗妙恒别。此约一乘。又如解深密经云。如来所行如来境界此何差别。佛言如来所行谓一切种。如来共有无量功德。众所庄严。清净佛土。如来境界所谓一切种五界差别。所谓有情界世界法界调伏界调伏方便界。地持瑜伽亦名此五名五无量。此五既是如来境界故。后说智名回观智。此约三乘。问既观海。何不说海而说智耶。答以海是证境故。证欲说彼即是说智。如人至寺观塔熏在自心后归家说塔。即是说心非彼塔也。问既在定得说。后何须起耶。答为寄法故。何者谓在定观海。此在心中最细也。十智观海。虽在定中然寄在言。故次细也。说分最粗。就机故。出定表示也。是则说以智为本。智以海为本。以说依智成智依理起故。文中三。初据智。二许说。三明说意。此中佛子有五义。如摄论。一愿乐大乘为种子。二般若为母。三定为胎。四大悲为乳母。五诸佛为父。又有十义。如下弥勒知识处说。十智者一由成即败故成净也。败亦尔。由此即具余九等。故名不思也。此不思句遍下九句。二中以众生空有不二故。类多故相即故相入故。具一切法故根性多故故亦不思。又界是如来藏。随缘作众生名起也。又起在智中也。三中一约有为。二无为。三俱。四不俱。各通染净思准之。根欲摄在上二智中。亦在下七。如上问中辨。下七明佛海。四无碍故。五称根欲授故。普转故。六显德故。七光音故。八三轮摄故。九深定故。相即及体用皆不坏也。十以总结别也。本分竟

第七起定成益分中二。先起主伴定。前明定不碍用故说十智。此明用不碍定故云不坏。不坏彼定故也。云何不坏。以由方便智释显也。二起益中二。先内益亦二。初益此众有四。一证法体。二依证起巧智。三依智起妙辩。四说无断绝谓由愿力故也。二结通显圆。二外益中三。初动。二益。谓动时令恐。返此故乐也。又安善因授乐果。又动时令坏。返此故宝严。三雨宝谓是法门也。以是减十故标十列七也

第八毛光赞德分中二。初一切如来毛孔及光等。是上能加佛也。赞普贤德显具德说法。令众尊重生渴仰故也。是上光明赞叹音声智。二十四颂中分二。初八叹普贤广大三业尽佛源底。于中初三身。次半语。次二半意于中初一半定。后一慧。次二尽佛源底。后六叹体用普遍无碍应机。于中初一体遍。谓普贤身在此会坐。即于十方无边世界一一皆见常在处彼。本来当处而身不分。亦无来去。一切尘中一切众生身中皆亦如是。以众生等即如故。是普贤也。而实一乘佛国亦同普贤圆遍。即就胜易解故。简土约理寄三乘显一乘耳。思之可见。后五明用。一现身。二现法。三净愿。四众生。五现智

第九许说令喜分中亦二。先长行摽意。谓前闻本分已生欢喜。今更许说分故云重喜。二颂显喜事。于中有十颂分三。初二颂半举佛化德超情不测。于中一深智说法。二严土调生后半通结能化所化无尽难测。第二有五颂半诫众令净堪为法器。于中初半简不堪闻。言乐恶者作恶趣因也。著有者设作善业不求出离。下句结非。谓不能了等显非器也。次一颂明具三力方堪为器。一宿善根力。二近善友力。三佛护念力。下句结云是等众生能得上智。次一颂具七心方堪闻法。一直心离谄曲故。二净心离求过等故。三慈心为益物故。四悲心为救生故。五深心为修行故。六信心受深法故。七无厌足心渴心无满故。下句结云彼闻此法喜无量也。上来二颂十门通辨一切堪闻法器。次二颂别举此众。初一明具四德堪知佛境。一住普贤地。二具普贤愿。三行普贤行。四证法界空。下句结知佛境。次一颂叹此大众现得二利。一现前见佛。二得普贤方便。后一颂通结但诸众生得闻佛法皆是佛力。第三有二颂举法许说劝观令乐。一举法劝观。以佛及刹在身内故。劝众令于毛孔中观。后一明具普眼方睹此法。下句许说诫听可知。下十眼中第十普眼者。平等法门见法界故。若通论总具十眼名为普也

第十正陈法海分中。先明诸会能说人异。唯僧祇小相二品是佛说。余并菩萨说所表。如下释。又依智论有五说。一佛说。二弟子说。三神仙说。四诸天说。五变化说。此据出声名句等。若望授与即通情非情。此约三乘。又有五说。如下云。佛说菩萨说刹说众生说三世一切说。此通三世间等一切法。约一乘也

文中二。初广辨世界海。答前果问。二从乃往过去下答前因问。初中二。先散说世界。后偈颂总持。前中二。初通论十世界。后别辨华藏界。亦是释第十坏世界。以成即是坏故。前中二。先摽列章门。二依门别解。初中三。先总告引证。二正列十名。三结其无尽。此十中初者有四义。一以土体绝相由言方成故云说世界。如四堪智中成也。如下缘生中说缚观等。二由名言熏识现土故名说也。三土中言音如下颂中辩。四世界立名不同故云说也。初一说即世界。后三说之界。二揽缘界。三依故得久。四外状区分。五内体盈满。六德相严丽。七离垢用净。八器净佛兴。九经时多少。十缘散离作皆繁多深奥同名海也。凡一世界即具此十

今通释诸世界海略作十门　一种类　二居人　三名体　四染净　五漏无漏　六共不共　七世间涅槃　八依正　九人法　十无碍

初明种类者。小乘唯有一类娑婆等界。无别净土。三乘中有二。一约佛自住处有三。一法性土。二实德土。谓妙行等。三色相土。谓胜宝等。后二为自受用土。此三非是摄化处故此中不辨也。二约佛摄化处亦有三。一化身土。此有二。一染谓此娑婆等此约释迦。二净谓余方化土此约余佛。二变染土。谓足指案地等。三他受用土。谓十八圆满等。初中二。若依始教唯有百亿阎浮百亿释迦为摄化境。若依终教如智论中以三千大千世界为一数。数至恒沙为一世界性。数此性复至恒沙为一世界海。数此复至恒沙为一世界种。数此复至无量恒沙为一佛世界所化分齐。其受用土若始教在色界顶。为引小乘同界说故。若依终教不在三界。如涅槃云西方去此三十二恒河沙佛土有世界名无胜。是释迦佛实报净土。又于一切须弥楼山世界畔间往往数有一净佛土。此通报化为引众生。三依一乘有二。一约果分十佛自体国土海。此当不可说。寄缘说十。如第二会说。二约摄化处有三类。一从须弥山界及树形等已去乃至一切众生形世界海为第一类。二三千界外别有十世界。一世界性。二世界海。三世界轮。四世界圆满。五世界分别。六世界旋。七世界转。八世界莲华。九世界须弥。十世界相。此等当万子已云轮王境界为第二类。三十莲华藏庄严世界海具足主伴如帝网等。是佛境界为第三类。此上三类通有十事。为首成世界。一说世界海。二起具因缘世界海。三住世界海。四形世界海。五体世界海。六庄严世界海。七清净世界海。八如来出世世界海。九劫世界海。十坏方便世界海

二所居人者。若小乘唯有有余依圣及凡位居也。三乘三中初二通有凡夫二乘及地前菩萨并佛化身居也。后一初地上菩萨及佛报身居也。解深密经中三地菩萨生佛净土者彼约七地明义。即初地当彼第三也。又起信论中许地前菩萨见报身佛者彼约终教。依三昧见也。一乘三中多分论时。初见闻位。次解行位。后向果位。通即可知。三处佛身同是十佛也

三名体者。世是时。界是分齐。谓于时中分齐显现。从相得名。繁多奥积深广难穷同名海也。世界即海从喻。持业释也。若小乘以子母七微及色等四尘并能造四大实色为体。若三乘中凡小地前俱以赖耶识为体。地上二义。报土亦同赖耶识为体。若二智所现即以唯识智为体。故摄论云。菩萨及如来唯识智乃至为净土体故。若依终教俱以如来藏真如为体。若一乘以无尽法界通三世间。人法理事等诸行相即互为其体准思可知

四染净者。若小乘唯染。三乘有二。一约位。二约法。初中有四对显其染净。一约因果。谓金刚已还菩萨所住名果报土。不名净土。以过患未尽故。唯佛一人使习都亡所居名净。是故仁王经云。三贤十圣住果报。唯佛一人居净土。二约一向非一向。谓八地已上菩萨所住得名净土。以一向出三界事故。具足四句一向义故。谓一向净一向乐一向无失一向自在。七地已还未名净土。以非一向出三界故。纵由愿力而得出者。四句一向不具足故。谓无流观智有间断故。非无失等也。此依摄论辨。三约纯杂。谓凡夫二乘杂居之处不名净土。地上菩萨生处名净故。瑜伽论说世界无量有其二种。谓净不净清净世界中。无那落伽傍生饿鬼。亦无欲界色无色界。纯菩萨众于中止住。是故说名清净世界。已入第三地菩萨由愿力故于彼受生。无有异生及非异生声闻独觉。解云。此第三地既名净意乐。即是欢喜地。以约七地辨故。四约退不退。谓入十住已去不退位。三贤菩萨生处名为净土。于中亦有四果二乘等。如阿弥陀土生彼皆住正定等。堪任已还轻毛退位。三聚众生共生之处不名净土。此四对八义中。初约果唯净。后约退唯染。中间相形皆通染净。二约法四句者。或唯净谓于上四门中形取净故。退位所居自性净故。或唯染谓四门中相形取染故。佛果随缘约机说故。起信论中名随染业幻所作也。或俱由前二义不相离故。或俱非以二义互融非定一故。二相尽故。一乘亦二。初约类中初类染。后类净。中类通二。二约法中或俱净以即佛故。或俱染即众生故。或具二由前二义不相离故。或不俱以二相融二相尽故。上三类中一一皆具此四句准思知之

第五流无流者。若小乘唯有流。三乘有二门。一随相门。二融通门。初中四句一唯有流谓凡小地前所变土。二唯无流谓佛所现土。三俱谓地上菩萨二智所变及赖耶所现。此二虽为苦道二谛摄然无别二体。但随义异摄。四俱非谓皆即空故。不堕数故。此上约始教。二融通中亦四句。一或一切皆无流乃至凡位亦尔。以离诸流性故。如经云。色无流无系受想行识无流无系乃至广说。二或一切皆有流乃至佛亦尔。以不离流法故。如经言。诸佛安住三毒四倒五欲等中得阿耨菩提乃至广说。前句不异流之无流故即无流。后句不异无流之流故无流即其有流。三俱以前二义不相离故。四俱非以皆离缚脱性故。如经言色无缚无脱受想行识无缚无脱乃至广说。一乘中如缘起法界。若无一即一切不成。互融无碍亦具四句。全摄可知思之

第六共不共者。于中有二。先明分齐。后显义相。初中随一世界皆是有情。谓异熟识由共相种成熟力故。变似色等器世间相。问凡一世界有几有情异熟识变。答唯识论中有三师说。初师说云。一切有情。以契经说一切有情业增上力所共起故。次师破云。若尔诸佛菩萨应实变为此杂秽土。诸异生等应实变为他方此界诸净妙土。又圣者厌离有色生无色界必不下生变为此土复何所用。有此三种大过失故明不得通一切有情。应说现居及当生者彼异熟识变为此界。经依少分说一切言。诸同业者皆共变故。后师转破第二云。若尔器世界将坏时。既无现居及当生者。谁异熟识变为此界。又诸异生厌离有色生无色界现无色身。预变为土此复何用。设有色身与异地器粗细悬隔不相依持。此变为彼亦何所益。亦由如此三种大过。是故现居及当生者皆不成变。谓初器将坏。当生现居俱无受用。二若现受无色界身而于此土无受用义。三设有色界身与此粗细异。亦无依持受用。是故此三俱无变义。若尔谁识变耶。正义应云。凡所变土本为色身依持受用故。若于身可有持用。设令生在他方自地彼识亦得变为此土。故器世界将坏。初成虽无有情而现有土。此土并依唯识论辨。第二显共不共义相者。若小乘中既是极微所共合成故唯是共。若三乘中有四句。初或亦唯共。谓彼依报虽不离识而识是别。土相是一。由彼彼识中共相种子共所现故。如揽四尘共成一柱。一柱之相不离四尘。非随四尘而有四柱。当知此中道理亦尔。若自受用土佛与诸佛共有一土。犹如法身诸佛共依故。以是同法性土故。若他受用土亦佛与菩萨之所共有。如王与臣共有一国。诸杂染土亦是有情共业所现故无别也。二如是依果实皆不共以各于自本识中现故。论云。俱是有情异熟识各变。同处相似不相障碍。如众灯明。如多所梦。因类是别。果相相似。处所无别。假名为共。实各有异。诸佛净土亦复如是。各别识变皆遍法界。同处相似说名为共。解云。若有一土不随识别。则心外有法不成唯识。论云。我说识所缘唯识所现故。由是当知。皆自识变故各不同。三亦共亦不共者由前二说不相离故。瑜伽云。外等诸物或由不共分别为因。或复由共分别为因。若共分别之所起者。分别虽无由他分别所任持故。而不永灭。若不尔者他之分别应无其果。彼虽不灭得清净者。于彼事中正见清净。譬如众多修观行者。于一事中由定心智种种无量异见可得。彼亦如是。解云。此说依报随共分别。其不共分别同前第二。是故随外器世界皆具如是二义而成故双存也。四非共非不共者有二义。一由前二说互形夺故。随定取一不可得故。是故俱非。二由土依识土相尽故。识从缘起无自性故。是故共与不共性相皆离不可说也。此上若约果报赖耶识所变等即是初教。若如来藏赖耶所现即属终教。若一切相尽唯一净心平等平等。离言绝虑即属顿教。若依圆教有二义。一如前诸教所说即同无尽法界帝网重重即入无碍具足主伴即属此摄。二以义求亦有四句。一或唯共以同一法界故。相即故。二或唯不共以缘起各别故。相不杂故。三或俱以上二义不相离故。以全体相即而不坏故。四或俱非以二相泯故。形夺尽故

第七世间涅槃门者有二。初随相。二融通。初中有四句。一或唯世间谓地前及凡位所居。二或唯涅槃谓诸佛果位所住涅槃。设自受用土亦得是彼大涅槃摄。三或亦世间亦涅槃。依宝性等论依无流法界中有三种意生身应知。彼因无流善根之所作故名为世间。非是有流业烦恼作亦名涅槃。依此义故。胜鬘经云。世尊有有为世间有无为世间。有有为涅槃有无为涅槃。解云有为世间是凡位。无为涅槃是佛果。有为涅槃无为世间是变易报。所望异故属俱句。四义准诸佛清净法界是非世间。非涅槃。以非是二乘涅槃故。又亦非双林涅槃故。二融通者亦四句。一或唯世间谓佛净土亦悉是器世间摄故。二或唯涅槃谓众生染土亦相尽同性故。三或俱以理事无碍故。论云。世间与涅槃无毫厘差别。以无别故。无二而二双现前也。四以无毫分别故。二而无二。形夺俱尽故俱非也。经云。如来不见生死不见涅槃。又此经云。世间与涅槃二俱不可得。此之谓也

第八依正门者。若小乘是唯依报。三乘中器世间虽是本识及镜智所现。而唯依报摄。若依圆教中通三世间。以舍那佛有国土身等是故世界悉是佛身。又有众生形世界等。是故众生即世界。此并依正混融无碍故也。相即自在故

第九人法门者。小乘非人法。三乘可有是法门义。一乘具有。是佛普贤及众生等故唯是人。或诸世界并是法门故。如文云。清净妙形入于无量正法之门。此明世界等悉是法门

第十无碍门者。小乘世界唯是事相。于上但有苦无常空无我等理。三乘中法性土唯理。余皆是事。然上二宗。理之与事非一非异名为无碍。若一乘中略有十重。一情事无碍。谓应情显现事超情外。文云喻如幻无方皆从妄想生。二理事无碍。谓全同真性而刹相宛然。文云法界不可坏莲华世界海等。三相入无碍。谓文云以一佛土满十方。十方入一亦无余等。四相即无碍。谓文云无量世界即一世界等。五重现无碍。谓于尘中见一切刹。刹内尘中见刹亦尔。如是重重如因陀罗网。六主伴无碍。凡一世界必有一切。以为眷属。七体用无碍。谓一刹海必有大用。赴机说法。八隐显无碍。谓染净隐显异类隐显等。约缘定之可知。九时处无碍。谓或于一刹现三世劫。或一念中现无量刹。如是无碍。十成坏无碍。谓成即坏坏即成等。无碍显现自在难知。超过情虑。此十无碍同时具足。应以六相方便而会融之。十世界义略辨如是。诸余义相随文当显

第二依章别释中。十内初一不释。以释余九即为说故。文中初释前八后释第十。前中初七各二。谓长行及颂初文无颂。初中长行内四。一标二成三辨四结。一切世界海者是彼三类各各非一故也。已成等者一以此诸缘通成三世一切世界。而诸世界已未等异。二成一世界即遍三世。前缘通界别。后界通缘别思之。此约一乘。八缘中。一后得通慧。二缘起法尔。三所化业力。四菩萨行满。应于彼界而得成佛。则由此力彼界得成。五普因成也。六菩萨为严净无余刹故修愿行。刹随愿行无碍容持故云解脱自在。七大觉正因。八普愿摄成。然此八中初四是权成。其粗相故。亦通染。后四约实成。其细相故。唯是净。如经我此土常安稳等。而一世界即具粗细故也。又此八中总有四对。一初及第七约佛明权实。二八及第五别约普贤明权实。以第八是为物故。三四及第六通约一切菩萨明权实。四第二及三约理事为权实。以业行缘成不实故也。何故要具如此四缘。谓佛为教主。普贤是助化。菩萨及众生所化。初二中若无权无以熟生。若无实无以应真。后二中众生业报缘虚后必有所依真性。如此八种等尘数因缘成一世界。皆互无障碍全体遍收作不作等如缘起性。即空即有即一即多融无分别思之。余一一界准之。颂中有二十分七。初四颂前佛神力。于中一刹依镜智现。二土以行修成。三化菩萨。四悟众生。次四菩萨应得道力。于中初上半明行因。下半明智果。度犹到也。二上半明土因。下半起土果。三上半依正因成。下半明证入依正果境。四上半果广。下半因久。次二颂众生业力。次二颂菩萨严净佛土愿行力。次二颂普贤善根力。次四颂普贤自在愿力。次二颂佛依果故也。此颂总通缘起异义。即为法如是故。不别颂也

第二住中长行内二。先具标数。谓凡一世界即具如是刹尘所依故云一一也。二略列七事。一依善净力住。二依无碍。三依如意宝或一切。四依通明。五依缘起力。六依法身持。七依法界愿。依智论中摩诃名大那名无。伽名罪。此约无失义释。又云或名大象。即陆行中力大也。或名大龙。即水行中力大也。又初如善调象能破军敌约自利也。后如大龙降雨约利他也。颂中十六半分九。初一颂依庄严住。二一颂虚空住。三二颂依宝住。四一颂佛光谓威神是也。五一颂力士。六五颂上标中刹尘。依此犹略也。七二颂幻业。八一颂普贤愿力。九二颂半通显因陀罗网安住相。初偈一尘内现依正。后一半类多尘可知

第三形内长行中别列七种。初四及七当相辨形五六二种约喻显状。一方如斗。二圆若珠。三非方是四维形。四非圆是八隅形。五水洄洑形。六华形。七众生形者谓有二义。一有世界似众生形。二即种种众生皆是世界。如身中八万户虫各有九亿虫等。此即是世界准下文亦是舍那佛转法轮处也。是故文中但言众生形不言如众生形。故知即以众生为界也。此等一一形类皆遍法界。颂中十七半分二。初三正颂前文。后十四半明刹德用。前中初一颂上总数。次一颂上别形。但颂初四略无后三。依智论摩尼珠有八楞。喻此隅形也。后一上半显因异。下半明果相。二德用分二。初六半明德自在。后一毛孔下明用自在。前中初三约佛显刹明堪应机。一体成法门。二相显临机。三舍那光照。是佛所有也。后三半约机正应显成差别。一机心业异感土多形。二佛土自在能随感现异。三虽应成染净而法流不断。四下半结业多门感现难测。二明刹自在中三。初四明依正自在。次二出其所因。后二结用归主。初中初二毛孔现刹。佛于彼中为众演法。毛孔即明正报摄依佛还在自毛孔之内。后二尘内所现种种形界。佛亦在中转尊法轮。尘是依报摄正等也。二出所因中。由何得此自在容持。一由佛誓愿自在力故。二由众生心业不思议故。三结归中。初一举尘内佛。次半举尘内刹。下半正结归主

第四体长行中。别内五并约事显也。凡论土体有五重。一真如。二真智。三本识。四五尘。五诸事。诸事即法门。将为叹故。是以文中辨也。颂中十行。一宝华体。二炎空体。三光明体。四电光及愿体。五日珠体。六宝炎及化体。七佛化体。八心业起体。或业起心海成土。或心业起土。或妄念为体。九佛身光体。十普贤化愿体。此等并是任放辩才说不待次故也

第五庄严长行内别中有四。一云通相。二染业行。三净因果。四结可知。颂中十偈分五。初一颂上总数。次二偈颂云严。次一颂上众生业严。次五颂上佛严。于中初二严依。次一严正。谓佛数等众生故也。或众生数等佛也。次二杂严。后一颂上普贤严

第六清净别中有五。一行缘净。二自利净。三利他净。四行满净。五得位净。皆从前起后可知。泛论土净有七。一当体净谓以净识为相等。二事相净谓净宝等故。三受用净谓受用此土灭惑成德故。四住处众生净谓有德众生满此世界故云净也。五主净谓佛之土等。六净行因生故。如文无量行海所修集等。七净行即土故云清净。以行为依止故也。如文可知。偈中九颂分五。初一偈颂上总数。次一颂亲善友。次二颂上自利。谓一三昧行。二信忍行。次一颂上利他次二颂上二行满。次二颂上得位益第七佛出世别中三句。初约现身普遍。谓以二身遍满一切差别法界一一之处皆身全现。亦不分身亦无限分故也。寿长短者如须扇多佛旦成暮灭。迦叶七日。释迦八十等此谓短寿。弥勒八万。弥陀极算等为长寿。皆由机感故致然也。又初约一切处现。后二句约一切时现。谓长短具故为一切也。问若尔处何不然。答差别法界遍多少通有无故云遍满也。颂中十偈。初三颂前长行。初一颂总。次一颂身遍。后一颂修短。后有七偈明佛出现无方胜用。此中分七。初一严土多少。次一说乘多少。次一救生多少。次一化现广狭。次一圆音普应。次一主伴遍充。次一慈海普现总结也。此中或短寿度多生。或长寿度少生。或长寿度多生。或短寿度少生。或短寿说小乘。或反上。或长寿说多。或反上。如是等与虚空法界等。皆是慈海力所现故也

第八劫中略无偈颂。总中尘等劫住者非是一一世界各住尘等劫。良以一一世界劫住不同长短差别如尘等也。所谓下别举二门。有如是下总结差别劫。义如别说

第九释第十坏方便世界海者。但坏有二种。一成即坏。以诸缘各无作故。性自坏故。二三灾坏即事坏也。今此文中辨初义。下重颂偈中明后义故。又释。初即坏成。后即成坏坏。故名方便坏也。又以后坏亦从缘无性故。何故须俱坏者欲令见心尽故。成坏圆通故。问若尔亦得初即不成故成成。后即不坏故成坏。此则坏成俱成何不尔耶。答理实应尔。但为此文释第十坏义。非释成故不辨也。文中有二。先举意总告。谓分别华藏开示群机。二正明所说。说中三。初举主辨因。二有须弥尘等下明因所成果。三是佛常转法轮处结果属主。初中三。先总辨谓从初发意即修此因。明因深果厚也。问瑜伽论说。一切诸佛要经三阿僧企耶劫修行成佛无增无减。何故此中乃说阿僧祇个世界。一一世界并末为尘。一尘为一劫。据此则有不可说个阿僧祇劫。何故不同耶。答彼约三乘。据一方化仪唯就此须弥楼山世界说。是故宝云经云。我为浅众生说三阿僧祇劫修行。然我实于无量阿僧祇劫所修行也此是约会三乘归一说。此文约一乘该通十方因陀罗网等及树形等诸类世界说。又为约法辨时。以法无尽故时亦无尽。文中且举十大数中初数为则。亦即通帝网喻故亦无尽也。问若尔一劫即无尽。何不但言一劫耶。答此中无尽无尽故也。又德无不备曰严。垢无不尽曰净。又初即福智交饰。后断德离染。又亦得严即是净严故也。别中泛论土因有二种。一依因谓真如净识及镜智。二生因谓诸妙行愿。今约后义略陈三种。一广福。二大愿。三妙行。初中一一劫者时广也。一一劫中供尘等佛者田广也。又是佛故田深胜也准下地品应有一切供具。即供具广也。以上心深。心即供心广。此文存略故耳。准地论恭敬供养各有三种。应寻彼文。新金刚般若论上卷亦有三种供养。一给侍左右。二严辨所须。三询承法要。二愿中一一劫时广也。一一佛所者胜缘广也。尘等愿愿广也。谓以大誓自要要成此果。即要期愿也。又所修福行悕成此果即悕须愿也。对佛发弘为修。真实离染为净。又十大愿中净佛国土愿及余诸愿应寻论之。三妙行中修时广缘深广行事广可知。亦对缘进造曰修。修成离染为净。谓十度六度等行乃至一切行准之。又三中初自利后利他中间通二利。又亦可具四多。即四修一尘数劫即时多为长时修。二尘数佛所即供佛多为恭敬修。三一一佛所发愿即愿多为无间修。谓愿心相续也。四尘数行即起行多为无余修

第二所成果中分二。先明此主世界。后辨结通。前中有三初显本世界为依持处二从此香水海上有世界性住下明次重显杂类世界性三从香水海名乐光明下更重辨十二佛国土七世界性。然此本师佛摄化境界。诸教所说分齐不同。若小乘中但有此一娑婆世界。若三乘有二。一化身化境。谓此娑婆等。二他受用身化境。谓十八圆满净土等。若约一乘十佛化境。莲华藏庄严世界海有三种。一莲华台藏世界虽遍法界。对地上菩萨机现有增减。寄在色顶唯说一界。二即此遍法界之华藏说十显无尽。即无尽个华藏一一皆遍法界。三树形等杂类世界。一一皆有莲华藏并似彼界。悉遍法界。各各有十。无尽无尽。此三中初一约同教一乘辨。后二约别教显耳。今此文中据须弥山世界中辨华藏故。是故风轮水轮还似彼也。以易信解故。印机而成故

初文中分二。初别显严相。后一一下总结。前中有六。初辨风水华地为根本所依。二明地山上海严等。三地能映现严。四地上香海严。五海间香河严。六河间宝树严。此六段中各有二。谓长行偈颂

就初段长行中有五。一风轮无碍持。二依风有香海。三依海有莲华。四依华有世界。五依界有围山。初文有三。初总次别后结。别中前七各持宝地中此有二义。一谓一风轮上有一宝地如是次第。二其诸宝地皆远在莲华上。然此风力虽缘起门各别。主属无碍任持故是法性风也。此中风有二义。一无碍义。二有力义。故成缘起也。宝地亦二义。一可贵义。二依持义。人法解行等法门。准之。八持时者。以时依法立无自体故说持也。须弥山地是下文所持杂世界处事遥有所主故。一切有者。一是诸世界中三有等也。二亦得通是宝地上诸庄严事为一切有。又以义求前七次第从细向粗。但属持诸宝地。后三渐粗持下文所持诸世界性四时三有等。又此中最下风轮超越持于华上宝地。最上风轮邻次持于华下香海者。显上下镕融自在无碍故。为异彼染土碱烈海故。言香水海也。香有二义。一普熏义。二芬馥义。水亦二义。一清净义。二洗濯义。海亦二义。一深广。二具德。又有十义。如下说。以具主伴故云一切也。华中二。初句辨义。大莲华者。梁摄论中四义。一如世莲华在泥不污。譬法界真如在世不为世法所污。二如莲华性自开发。譬真如自性开悟众生若证则自性开发。三如莲华为群蜂所采。譬真如为众圣所用。四如莲华有四德。一香二净三柔软四可爱。譬真如四德。谓常乐我净。如此等并为依止义故也。彼论又约一复次释。谓如来愿力所感。大宝莲华王为净土作依止也。华藏之名因此立也。下句香幢等者依义立名。名有四义。一香有二义。一约体是氛氲义。二约用是普熏义。二幢亦二义。一约体是独出义。二约用是降伏义。如帝释幢等。三光明亦二义。一是照闇义。二现法义。四庄严亦二义。一是具德义。二交饰义。此中香即幢。香幢即光明。光明即庄严。皆持业释亦通依主准之。下明所持二句。初句中华义同前。藏是含摄义出生义具德义。此中通论有二义。一由此土内含摄一切人法等诸法门故。二含摄一切诸余刹故。下句金刚亦二义。一是坚义二利义。山亦二义。一是高义二是静义。围绕亦二义。一是内摄益义二外防敌义。谓以金刚外敌障不能侵。内德增长也。偈中二十颂分二。初七略颂前文。后十三明胜用利益。前中分五。初一颂举果体用。次一颂前因中供佛净福。次二颂前大愿。次一颂前果内风持宝地。次二颂前土因大愿。以是任放辩才故说不待次也。第二胜用中二。先六颂明依报用益。后有七颂明正报用益。前中二。先明胜用有四颂。一世界光。二菩萨光。三华色光。四净宝光。并是智等法光故能充照法界。后有二颂明益相。初一灭惑成德。二睹帝网法界。后正报用益亦二。先明胜用有二颂。一明刹外佛用。二明华内佛用。又前珠中菩萨遍十方。此则华中诸佛等众生界。依正无碍故也。下明益相于中五。一举所益机。二兴普教。三巧调机。四令住自分断德。五令闻胜进智德。问何不佛等语说法而于光云等说耶。答以此明刹用故尔也。问若尔何故辨佛光等耶。答以依正圆融故。佛亦是刹也问此中意辨华藏界。何故乃说诸杂化用耶。答有二义。一以此是刹用故辨用显体。二即此化用为依止故即是刹也。问何故与长行不同耶。答长行略标颂中广显故也

第二总明山下地海严者长行五句。初二句显地名。谓莲华台面为宝王地。二明地镇海。三地相具德。四地体坚固。五明地胜用。于中初句出法宝。后句起智照。颂中十偈分二。初六明众德严。后四明法行严。又初是体备众德。后明妙用自在。又初依后正。又初事相严后法理严。又初法后人。又初颂前文后明异义并可知。初中前一总辨严因。次二颂上山地。于中初一标谓宝轮香轮为山上严。珠轮众宝为山下依。后一释谓初二句释上宝轮严。次一句显上香轮。下一句辨庄严义。楚云斫迦罗此云轮围山也。次一偈颂上体相二严。谓初体后相。次一偈颂上香水海。次一偈颂上地胜用。亦是海岸边宝地上即有宝树。树下座上有佛菩萨之身也。第二段中四偈。初一总明身语法轮。次二别辨身色依正无碍。于中初一佛现多严具之中。次多佛现一严具内。即调物为法轮也。又前华香幡盖中菩萨充法界。此则宝幢宝树庄严中众诸佛身云满十方。并以正为依也。后一偈别显上语法轮。此即刹说也。此上通三世间圆融无碍。随入一门皆具一切故致然也。又此等诸文长行所说则编其次第。令随事生解。偈中所颂则融其始终。圆通无碍顺于法性。长行以法就机。偈颂会机归法。文家绮互善巧之相应知

第三宝珠严内长行中六句。初句显宝名。谓山为外墎世界居中故云内也。非在山中为内。名不可坏有四义。一体不可坏谓金刚末尼故。二德不可坏谓藏摄众宝同在自中。众宝不相破以无相不相形夺故。自亦不坏以无二故。三用不可坏谓雨物多端互无夺故。四映不可坏谓能映现多身不可夺破。现处重现不相碍故。二辨珠胜用谓洞彻明焕故能现也。此中映是能现影为所现也。何故不现佛等及余刹耶。谓彼非所化故。若尔何不现心念耶。谓非色法无现义故。三宝华严地中以为庄严者。通上二句同严大地。四云严。五香严。六三世严者谓三世诸佛严华藏界皆与此同。又亦此严同三世故也。又所严藏体通三世故。纵于现世以一华严由同所严故即通三世。是知一华一鬘皆遍三世。三世俱现。各具过未即该九世也。又以犹用也。纵所严刹唯在一念用于三世一切严具而庄严故。即所严同能严而遍三际也。又亦得能所一念即含九世。通相即入故具十世。以显无尽也。于上四释后三为胜。颂中十偈分四。初一偈半颂上不坏摩尼。次二偈半颂宝华严。次一偈颂云严。次五偈颂三世刹严。于中初一地现三世行。次一地尘俱刹入。次一菩萨受用严。次一佛法体用严。次一得普贤愿及佛智者能入多刹

第四香海严中长行别内十四句。一香宝岸。二宝网覆。三宝水流。四众华敷。五末香其水。六出佛音。七香普熏谓教法所及也。八宝阶道谓入法阶梯也。九珠栏楯谓防外非守内德。十潮浪声。十一华阁围。十二华城周外。十三香华布水。十四香树为严。并即事即法可准思之。颂中十偈。初一颂海。二颂岸。三颂水及佛音。四颂阶及栏。五颂宝树。六颂华布。分陀利此云白莲华也。七颂宝网。八颂华城。九一颂以周其外。十举因结成

第五香河严内长行别中三句。一华覆。二出处。三随流。以依正无碍从佛出。为表正故眉间出。谓教河流润从证智出故也。然教带真义故宝王随流不失真性。即随缘不变无二是也。颂中十偈。一总明河相。二涯岸庄严。三香水流浪。四回旋所至。五踊宝自然。六河体普周。七网演因修。八岸闻果行。九河周舒因。十河原从果

第六宝树中长行内五句。一明树体谓无流法林树等。即众德建立义也。二宝幔覆即大慈普覆。三因力所起。四果德加成。五极尽严际。颂中二偈。初一颂果行自在。后一颂因行所起。又此二颂即是树。以人法无碍故。第二总结中分齐境多。别说难尽故。总云一一。然于一中严事犹多故。总云尘数。又严别难彰故。通云清净可知

第二大段明第二重。依前莲华台内诸香海上所持诸杂世界性。于长行中初总后别。别中先辨所依住有六。后显能依形有九。此中世界性者谓积世界成性。积性成海等。如上所引智论说。又此下文于世界海中有世界性。世界性中有一世界等。故知积成也。何故名性者有二义。一望前诸界摄诸流类积结成性。如久习成性等。二望后海等有为因义故亦得名性。问积界成性。界亦因义何不名性。答无融结故阙初义也。问十世界中海望于后亦积成余界。何不名性。答初积结摄已得性名。后开异义转立别号故不名性也。颂中十偈分四。初二偈颂上住形。二有三偈明刹有色声庄严。显体德圆备。三有三偈明诸刹土即入无碍。显妙用自在。四有二偈明三世间自在。即显摄化胜用依正无碍也

第三大段明向上广持诸刹。于中二。初牒上海及海上华。二辨持刹及性。此中十二佛土七世界性有诸德释。为华藏界外十方国土。详其文恐不然。既取华藏内香海中莲华而持。故知非外。况下文结属舍那故亦非外。但此中大意明众香海。中略举一海。一海所持十方刹中略举一方。一方既尔说不可尽。余方例准一海所持十方无尽皆遍法界。余一一海皆持十方各遍法界。无碍圆融无尽自在即不可说不可说也。大意如此思之。二所持中二。初一方后结十方。前中二。先明十二重佛土。后辨七世界性。此十二佛土。有人用配十二因缘。有配菩萨十二住等。一一释之。义恐不然。岂以十二数同即便配释。但此经所明皆应十数以显无尽。纵有十二七八等数皆是增减之十。如地论释。还是十数。岂得配耶。况义理又别。又此经所说一事一土皆遍法界具足一切人法教义因果理事等一切法门。非适一相故不可以一门释耳。上下诸文皆准此知。问若尔上来诸文何故皆以一二义等释耶。答还以一切之一释故无过。是故或一不少。或多不增。为成文故布之前后。深须得意。多少无碍。又泛论佛及刹立名不同。略由五相。一或因机感。二或由佛本愿。三或依本行。四或先佛记别。五或表示法门。此中佛及刹土依正圆融可以法义而消息之。尘数香海及世界性准释可知。又有义此上总为二重。初辨此佛华藏土及所持世界性。后从十二佛土下辨他佛土。亦持世界性。总为二对须思之。结通及结属并可知

第二重颂中有七十颂。但颂次前长行中事。非是颂前十世界海及华藏等。以彼各有偈。重颂讫。由前十二佛国七世界性皆通有此十海义故。是故偈中颂显其状。与彼长行绮互广略亦同前诸文。于中分二。先九颂总颂前文。二余颂别颂前中十海。初中有四。初一显根本所依华藏土海。次三总辨能依异类诸刹。次三别略显能依刹形。后二通举佛刹大用。第二颂十海中文则为十。初有十一偈。颂起具因缘世界海。于中有七因缘。初三颂神力因。此中初一就本无坏。后二随末亏盈。二如依种种下二颂颂业种因。初一报异。后一业殊。三譬如意宝下二颂颂愿力因。初一宝珠现色喻。后一就现空云喻。四犹如工幻下一颂幻业因。五如见彩画等一颂颂心画因。六众生心不同等一颂颂妄想因。七犹如见导师等一颂颂心行因。此七何别者。初是现威神。二是种子。三是宿愿力。四是现行。五是本识现。六是转识相。七乐欲器故别也。二无量真珠下二颂颂庄严世界海。三或有佛刹地下四颂颂清净世界海。于中初一唯染次二亦染亦净后一唯净心初一众生次二菩萨后一诸佛故令所居土有染净。此三渐次向净故也。四一佛国土中下四颂颂坏方便世界海。亦初一唯坏次二亦成亦坏后一唯成无坏。以染可坏净常存故。五或有佛刹起下二十颂颂体世界。于中初六纯染苦体。次四杂苦乐体。后十纯净乐体。于中初五随事辨体。后五妙用自在。六或无量佛土下三颂颂住世界海。于中初一举能依之形。后二显所依住相。七或如师子座下三颂颂形世界海。八或寿命一劫下二颂颂劫世界海。九或国土无佛下五颂颂佛出世世界海。于中初一总标。次二明化身示现。次一机熟无时不现。后一非器无时有现。十或刹极浊恶下七颂颂说世界海。于中初二恶道声。次二善道声。后三法轮声。上来总相通答于前果问竟

自下第二大段辨得果之因。答前问中一切菩萨所修行海等问也。又释亦是于前诸世界性中开一世界性。显内所有三种世间及五海等。文中分四　一举往时处辨佛兴世。为修行缘　二从彼炎光城下明普庄严童子能修行人　三童子见佛下辨对缘。正修成自分行　四彼佛灭后下明复更见佛成胜进行

初中四。一举往时。二明往处。三处中场。四场上佛出。第二往处中四。一海中取性。二性内山林。三林东胜城。于中初依报胜。后人众胜。四眷属城严。第三场内。初场地后华座。第四佛兴中。初佛出后放光利益

第二举能修行人中。王有顺理善慧令物爱见。问涅槃中一切轮王。皆定千子不增不减。何故此中乃不同耶。答彼是王四天下之轮王。约三乘说。此是主世界性之轮王。故宽细于彼。如白净宝网等。以一恒沙金轮王福所感。此约一乘。说不同也。又王及长子是福分。童子为慧分。是故成入道之器。德周法界曰普。普德交饰为严。普之严普即严。普严之童子。普严即童子。并通二释。离染贞洁素为道器故云童子。如文殊等

第三修成自分行中二。初见佛得定为自分之始。后闻经得定成自分之终。前中有四。一自利得定。二偈劝化他。三王喜偈告。四俱共诣佛。初中见佛功德善根因缘故者有三释。一由见佛功德善根之因缘力。此则唯属境力也。二由见佛功德所生善根因缘力故得定。三由外见佛功德为缘内自宿有善根为因因缘具故令得定也。此十定中初五为成利他。一具果法。二入普巧。三巧成严器。四正益机。五益分齐。后五为成自利。一成加行。二入正证。三广后智。四顺涅槃。五顺菩提。又初一总余九别略释可知。二普劝中初说偈后偈声分齐。偈中初四叹佛德难遇。次三明遇成胜益。后一结劝兴供。三王喜偈告中二。初王闻欢喜。后偈敕告令于中三。初一举告宣告。次七令严辨胜供。后一令兴念诣佛。四俱共诣佛。初王及内眷属。后八部外眷属。第二闻经得益中三。初明说经名者谓行能现果。举果取因故云现等。若从此义唯据因也。又此佛集会即为显现。此则唯果。此中三世是三现在故即具九世十世也。不尔过未既无。如何说现。是一乘圆教故摄眷属耳。二童子获益中二。初得定自利益。二说偈化他益。初中四定。一普该境法。二摄入归心。三契法无畏。四慧眼圆明。二利他中二。初说偈后得益。偈中三。初一总。谓上半颂前法眼定。下半总举眼所见。次七偈别辨佛本生。由佛而得见。后二别见诸佛而为物修因。获益可知。三如来赞述九偈中分五。初一总叹童子。次二别记正报。次二别记依果。次二叹其苦行。后二总记依正

第四大段成胜进行中二。初举佛为行所依缘。于中先佛灭后佛兴者。为行异缘别故也。童子报命犹存者。为行相续故也。二依缘成行益。于中二。初见佛得四定为胜进之始。一念佛者。地论云如佛所得我亦当得为念佛也。二入于普门穷兹海藏。三智持为能转。智法轮正成所转。四深法悦神故也。二闻经得定为胜进之终。经名者谓法界自性清净故云离垢。具恒沙功德故曰庄严。前经就果相。此中约果体者为自分胜进渐深故也。二定中初约自利后约利他。又此中童子得法是何位者。义准上下经意有三种成佛。一约位以六相方便即十信终心胜进分后入十解初位即成佛。以此是三乘终教不退之位故。以一乘六相融摄即具诸位至佛果也。是故此中童子见初佛为信位自分。闻初经为信位胜进。见后佛当解位初自分。闻后经为解初胜进。以摄诸位皆具足故。二约行总不依位。但自分胜进究竟即至佛果。三约理则一切众生并已成竟。更不新成。以余相皆尽故。性德本满故。此后应有结会。谓彼童子者今某甲字等。亦应有动地雨华他方来证及结通十方并偈重颂等。但经来不尽故未有也。问此会既了。何不众中有人得益。答略由四意故无别益。一于前三义中由初二义故。说童子益相。由后一义故。众中无别获益。二光统释云。此经佛初成道说。但显一乘圆教法轮体为诸教之本。诸教益相为此益故不辨也。三但教有二种。一说逐机教。摄法随机。机有增进随分辨益。二逐法教。摄机同法。法无增损故无别益。四此经犹如日出先照高山。既无中下之机故无随分之益。下文诸会并准此知。释第一会竟

华严经探玄记卷第三华严经探玄记卷第四(此从第二会初尽此会竟)

        魏国西寺沙门法藏述

    名号品第三

亦作四门分别　初释名　二来意　三宗趣　四释文

初中三。先分名者自下明第二修因契果生解分。谓从此至第六会来。辨说所修五位之圆因成十身之满果。令诸菩萨解此义相故以为名。二会名者名普光法堂会。然释有五义。一约事。谓佛于堂内放光普照故。名此堂为普光。于中说法又名法堂此依主释。二约法。谓真俗遐周曰普。妙智照达云光。境智玄轨为法。此普光即法。又诠普光之法。堂内说此。依主为名。法通二释。堂唯依主。三约境。谓普体光用。法通教义。四唯约智。亦如境说。五约实。谓无碍法界一尘一行。皆遍因陀罗网重重显现。故称为普。即普圆明焕曜。故复云光。无不正轨。故亦云法。则法应缘成阴为堂。皆持业释。如以三空为门等。例准可知。又信该六位称普。灭惑显理为光。阴机为堂。三品名者如来之名号依主释。或如来则名号。以十号中如来为一故。于中名谓释迦等别名。号谓十号诸佛通名。又召体为名。标德为号。又亦名号无别。如文内说

二来意亦三。先明分来者前既举果劝生信乐。今明彼果能得之因令生正解故次来也。二会来者修因之中信最初故故次来也。又谓前会明所信之境。今辨能信之行。义次第故也。问名号等三岂属能信。答为成信故同会辨之。问前岂不成信。答凡约境生信。境有二义。一标举境法明有所在。二摄以就心令成信行。前会据初义。此中约后义。又前会果广而因略。相从俱属果。此会因广而果略。相从俱属因。问等是果法。何故前会明依。此中说正。答依报粗现易见故先辨。正报细隐难知故后说。又若约佛先须净土栖托。后辨正报。又亦可互在随举皆得。问明修因之中。何故此会与第六皆有果法。同会中间诸会无此例耶。答此会是修因之始而与果同会。而果在会初。十地等是成因之终。亦与果同会而果在会后。此等为显依果海以起圆因。因满还融归圆果。此乃文中宏致始终之幖帜者也。三品来者有二释。一云前品明依果。此明正报。正报之中不过三业。此品明身业遍应。谓名号依身而立故。四谛品明佛口业普周。光明觉品明佛意业遍觉。三轮摄伏。俱是正报。然身业最粗。故先辨耳。二释云。准下问答又此品明国土海义。前品既辨世界海。即明体随缘显其果相。今即约缘反显明其果体。辨相所依之实故次来也。各通三世间思之可见。又前会约华藏。此约忍土。有意(云云)

三明宗趣者亦三。先明分宗通至第六会来同是一番问答故。须同辨。谓是二周因果。初相后体。前是因果缘起。后是理实。二约会亦二。谓人法。人亦二。谓所信能信。所信中化主内证土海为体。七日思惟为相。又即如其像为相。加说为用。又现通及光照为用。助化中文殊以信中妙慧为体。吉祥胜德为相。又遍一切处为相。所说益物为用。谓说偈等。二能信中亦二。先约因证净为体。具德为相。殊胜功业为用。并如贤首品说。检出(云云)

二约果信中所显无尽法界为体。十身胜德为相。应机化益为用。亦如贤首说。法亦二。先约境谓信中平等土海为体。约机说十。及胜德为相。与行教相应为用。二约行谓信行内证为体。融摄诸位为相。成佛益生为用。问未知此舍那佛是何位中佛。答若说信法即信中佛。余位亦尔思之。三约品亦二。一约相以如来身名普应广益群生为宗。二约实以十佛国土海为宗

四释文者。于此修因契果生解分一番问答之内长分有三　初序分　二请分　三说分

此中序亦通第六会已来。请说亦尔

初中有三。先举佛所在明器世间。二善觉知下叹佛功德明智正觉世间。三与十佛土下叹菩萨功德辨众生世间初中相传。普光堂在菩提树东南可三里许熙连河曲内。佛初成道诸龙见佛树下露坐。遂为佛造此法堂。良以诸龙多为阴覆供养故耳。又以堂近树故与场同举。又依此经以菩提树为本。余处皆不离此也。又此中初始得者约信法辨之。莲华藏者信行开敷离染摄德。约法准之。又大集经中菩萨得莲华陀罗尼故。凡说法处皆有莲华座。余义并同前释

二善觉智下释智正觉世间殊胜。于中十句。文同摄论受用身二十一种殊胜功德中初十句。如下第七会初二十一句总具。今依摄论及佛地论释此十句。初一总余九别。总中善觉智者彼名正觉。谓具后九德名善觉。以顺理离邪名正名善。开明照察名觉名智。别中初无二念者是一向无障功德。谓离二障故。异凡小故。又于远时方等境无知不知二现行故。是故由无二念名善觉智。二了达法性者论名趣无相法。此是能入无二功德。亦名调化方便功德。谓自能入离有无相清净真如。亦令他入故。三住佛所住者是观所调化功德。谓住大悲常观世间故。又是任运无功利乐有情不休息功德故。又安住圣天及梵住故。四等如来者谓得诸佛相似事业功德。于法身中所依意乐作业无别。即理智益生三法无别。五至无碍趣者是永断所治功德。谓修二障对治道成就现前。已到解脱一切障处所依趣故。六具不退法者是伏外道功德。谓证教法彼不能转。伏彼显已正道法故。七无坏境界者是伏魔怨功德。谓违顺中境不能碍心。虽在世间八法不污。以世境娆心障善称魔。此降彼故。八住不思议者是安立教法功德。谓所说胜教超过一切寻思境故。九等达三世者是记莂三世功德。谓记莂去来皆如现在。分明无别故名等达。具此九别成初总句。同异成坏准思可见

三释众生世间中有二。先简定其人。后叹其实德。初中有四。一简多异少。谓十佛国土微尘数故。二简大异小。谓大菩萨故。三简终异始。谓一生补处故。四简新异旧。谓从他方来集。然此四位以前望后。展转奇特皆可准知。三中一生有三义。一约人中。二约天上。三约下生之身。此就化相。若约实报四种变易报中。唯有末后无有生死一位犹存。故云一生。此经意约前义辨也。二叹德之中。文有八句。义有七对。初二句药病一对。谓初句了彼机器种性。后句深证所授法界。二常善思等明染净一对。谓如摄论中依他起上遍计染分名生死。圆成净分名涅槃。二分不异名一依他。若见一分余分性不异。是故经说。如来不见生死不见涅槃。又中论云。世界与涅槃无毫厘差别。此名染净无碍。四句融摄。或以本从末唯世间。或反此唯涅槃。或相融而双现。或形夺而两亡。巧观此理名曰善思。恒观不息名曰常思。三因果一对。谓诸众生报果业因种种差别。明了此等皆依众生诸识心行而得成立。四教义一对。谓义是所诠诸法之义。味是能诠诸法之教。则名句味身。五缚解一对。谓观彼世间相即空故名离世法。不待坏世。六理事一对。谓缘所起法名曰有为。无性真理名曰无为。会缘即真而不坏缘起。是名究竟分别无为。泯理唯事而不失理。名曰究竟分别有为。下文云。于有为界出无为界而亦不坏有为界。无为亦尔可思准之。七三世一对。谓知三现在各摄过未。及相即入。是为十世。靡犹无也。贯谓通也。于此三世无不通达。上来序分竟

第二请分此中通请下五会文。于中有三。初念请。二念问。三念现。问中裕梵等法师离为一百二十四问。谓初十问法身自体之行。中间一百问报身起修之行。后十四问方便身平等之行。又若合中间九十问为九问。即总四十三问。光统师合随喜心等为一问。即为三十四问。初十问先际佛法。次十问中际佛法。后十四问后际佛法。至下第六会来答之。今依此释总分为三。初十问因所依果。次十问果所起因。后十四问因所得果。摄论云。无不从此法身流。无不还证此法身。欲明因依果成还能克于果。果能垂于因还为因成果。因果相成缘起无性无自性故。即真法界无性即体不碍缘起故。真法界不坏因果。因果缘起理实之义案此而立。又初十问此会初三品内通答之。若别分四谛答说法一问。光觉答势力正觉二问。此品答余问。通答顺文。明难下三品别自有问。以信不成位故。无悬问十信之言。不同十住等。此初十问二释。一约依正二果为问。谓初一通问净土依报。二通问法身正报。三问土严具。四问法身所证。五问土离染。六问证后说法。七问前土体。八问正报光轮。九问应缘起土。十问现正等觉八相等事。二唯约土海为问。以准下文及璎珞经此会明国土海义故也。十中前五明土众德具足。后五明土体用圆备。又初一是总余九是别。别中土有九义。一别住义谓红莲华等如摄论说。二具德义谓理行事等各有校饰。三轨持义谓土法比证所得不同。四离染义谓自性与相及用等净。五成教义谓约言显土如说世界等。六自体义谓理智识事皆有体故。七妙用义谓威光摄伏等。八缘起义谓随众生机佛刹起故。又令随刹而起因行。又随刹佛出故亦云起。此顺兜沙经。又随因缘具而刹得起。如起具因缘世界等。九现觉义谓诸刹海现成正道以依正无碍故。余义准下答中知之。次因中十问从升须弥下至菩萨住处来答之。初九问约位自行。后随喜下问随缘化物行。初中十藏何故。问在回向后。下答在回向前者。以藏有二义。一是出生义故在回向后。出生地上证智故。二是收摄义故在回向前。收摄诸行令成回向故。由此二义二处互显故不相违。十愿初地内答。十定十忍品答。以观心纳理为忍。止心不散为定。止观无碍唯是一心故。二处各显一义。以诸菩萨缘真俗境皆有二义。一不颠倒。二不散乱。具如梁论说耳。十自在十明品答。以作用明委故立二名。以别翻菩萨本业经彼问中亦名十明故。兜沙中名十飞法。又十顶不见别答。古人有将梵网经于此计会云此脱错。恐难依用。今寻彼经十一处说法。六处同此。彼云化乐天说十禅定。初禅说十金刚心。二禅说十愿。三禅说十忍。四禅摩醯首罗宫说心地法门。不云重会普光及祇洹重阁。又此问与彼有同不同故难用耳。有云不思议品有答。但不思品等既答后果问。不可属此。又僧祇品明十大数。因位穷终数中之极。故亦得云十顶。但此品初自别有问。故亦难属。寿命品中十重佛土上至穷终。贤首佛刹最极际故称为顶。然有十重故云十顶。亦得无伤。以彼品初既无别问故得为答也。此中约望下尊高为问。下文就当处相续而答。又但此经下文别有问者即于此无问。下若无问而有说者即是答此问也。故须知之。随喜心下明问菩萨随缘起行。即菩萨住处品答之。以彼文中明菩萨随机普应诸处起胜行故。此约能依之行为问。下就行所住处为答。依此而判中际佛法中。问答相属亦极明耳。下明随缘化他中。初见他少善而心随喜。二化众生令绍佛种。谓下佛种子于众生田等。此二是化他心。下明化他行。谓云何不断。以救度故。何处救。烦恼妄想中故。如何救。知根行故。以何救。解法药故。云何救度成。谓令离集垢超苦难决道疑证爱灭。如次四句应知。后际中十四问。不思议品至普贤品通答之。于中胜法者是菩提胜法。同上文。不动转者是无功用故。余义多同前会释

第三说分中通下五会答前所问。于中分三。初此会中答前初十问前际佛法。二从第三会下答中际佛法。三从不思议品下答后际佛法。就初中二。先集众显圆。后对缘正说。前中二。先明能集。后明所集。初中有二意。一望前为答问。二望后为集众。前意中知心念者领所问也。又举受法心器量也。即如其像现神力者现像答也。满其器也。谓如其所念如上一百二十四问。及下至第六会来所说法门答此问者。皆于如来法界身中无不圆明顿现其像。是故展后五会而不延。一身顿现而亦不促。又六位历然而不殊。圆融即入而不坏者良由此也。令众睹此以沃虚襟则为答耳。以彼念云愿为我现故今现之也。下经云清净法身中无像而不现故也。又像者缘集所成无碍之义。以机心器量印于佛身而成此像。又以佛身应机而现此像各有空有二义及有力无力义。四句融摄无分别义思之。又以应机现像动摄功能为神通力也。二为集众者世尊举集众人。知心念者辨集众所由。如其像者明称法合机。现神通力者正明召众令集。又如所说像而现神力。使他方菩萨见此通光。知说某法而来集此。亦使此众见佛此像。知定说我所问之法欢喜而住。何以知者以如来身光有其二种。一密故难知。二显故令知。令知之中随其所应。将说何法。而佛身光先现彼像令众见已知说某法。如说般若时(勘智论)。如说法华时(云云)。故云如其像现神通也。二所集中十方内一一方各有三世间可知。又各有八义。一远近。二出土名。三标佛号。四主菩萨。五摄眷属。六来此致敬。七化作座。八依本方坐。世界同名色者表信位法相粗显著故。佛同名智者表信中最初始觉从本觉起故。菩萨同名首者表信是因初故。其文殊名义略叙五义。一者名文殊师利或云尸利。或云漫殊室利。或翻为敬首。或云溥首。又云濡首。又云妙德。又云妙吉祥。此中十菩萨依梵本同名室利。兜沙经中亦同名师利。又梵语唤头为室利。吉祥德等亦为室利故致翻译不同也。二出处者若依文殊般涅槃经是此土婆罗门家生。佛灭后四百年。于香山顶已入涅槃。若依此经是东方菩萨现在清凉山。寂调音经亦云。是东方去此万佛世界。国名宝住佛名宝相。彼土菩萨也。三明师资者。依放钵经昔为释迦师。此经云是三世诸佛之母一切菩萨之师。四明位者若约因是十地菩萨。以常住首楞严三昧故。若约果依首楞严经于南方平等世界成佛号龙种。五明德用者依如幻三昧经降魔场等是调生力也。依现宝藏经迦叶摈等是胜通力。从空决定论难叵当慧力也。此约三乘。如下光觉品一切处等是一乘也。诸方菩萨皆头面礼佛者。礼佛义略作三门。一礼数。二敬仪。三明得果。初中三业礼有二意。一以有三处礼故。二显佛有天眼天耳他心故。二敬仪有七。如孔目(云云)。三得果者有二。一近得五果(云云)。二远得佛果如贤首品说(云云)。依方坐者依智论第十二。外道他法轻佛故坐。白衣如客故坐。一切五众身心属佛。是故立。若大阿罗汉事已辨者许坐。余三果不听坐。大事未辨故。如王有重臣坐余皆立。今此并是大菩萨故是以坐耳

第二对缘正说中分二。初三品正通答前问。后三品因论生论。别问别答。又释前三是能发行缘。后三是所发行相。又释前是所缘果境。后是能缘因行。以此信行是住之方便自无别位故。初无问也

就前三品中有五。初叹众希有。二牒问总标。三征标显体。四征体辨相。五征相明用

初中何故问佛文殊答者。以即同佛慧故。吉祥妙慧达土海故。增诸菩萨踊悦心故。何不入定者以信无位故。前会岂有位耶。以是果德深细故。此中岂无果法耶。以为成因故。通具广因故。叹希有者略由二义。一以此一会即是一切虚空法界等处会故。二以此即是法门故并如光觉品说

二牒问内佛出是牒前七八二问。阿耨菩提牒前示成正觉。或佛出牒示成正觉。七八二问略不牒。阿耨菩提是通结。余句同前可知。总标初句不思议者贯通诸句。故结云皆不思议。不思议者此中大意于一味法界义分为二。一能随之土海。二所随之机缘。此二无二通融无碍。若以缘从体即当相圆融无别可别。言说不及也。若以体从缘即复印成差别缘起。约此殊形缘起反显土体妙极难思。是其意也。由此义故不思之义有于三种。一寄缘之诠反显土体绝缘之义。此即言在缘中意居缘外故云不思议也。二既约缘显土。以缘起尘算故。令土体从缘印成差别。此即明土无别之别别而不别故不思议也。三缘无别缘以体即缘。是故差别缘起即是甚深土海。此谓理至近而难识故不思议也(思之)

第三征标显体中。先征标云何以得知不思议者。后显体云以诸佛法随彼所化等法界故。二门双融故无限际故。此约体略释也

第四征体辨相中。先征体云何以得知差别无边等法界故。后辨相云未论十方尽空世界。且约此一娑婆界说略辨十种。以显无尽。余无边界应准知之。此种种身等有诸德。释为佛身等。是故下辨名号不同。则释种种名也。今细寻此文。及准兜沙经。此乃是所化众生非是能化之佛。以此句长是西国语法。应云教化一切种种身等乃至不同之众生为一句。所见亦异别为一句。义即可解。但为佛土平等无别可别故。寄于所化众生差别以辨土海差别之相。于十句中。初一总举五蕴身差别。二依身立名不同。三身在一切处。四随种种处有种种形。色谓白黑等。五随有身命有修短。六识能取得诸境。或修行证得分齐。七境体入根。或智能入法。或悟入门异。八略唯六根。广二十二根。或信等五根。或利钝生熟等。如下第九回向诸根海处说。九诸趣差别。或四生五趣如生行稠林等。十业异报殊如业行稠林等。依梵本及兜沙经此一一句皆有种种言。存略故尔。是故结云种种不同众生也。所见亦异者非直业报依正差别无边。心中怀见悕望各异。兜沙中名各各有闻佛声。又亦前九句辨报差别。第十明业差别。此显见差别。又说此众生差别分齐为土海相者有三义释。如上标中不思议处辨。可于此思之用耳

第五征相辨用中。先征相云所随根器差别可尔能随差别云何可见。释用云异机印现佛法多门难可具说。就异论三。初身名普应用。二言教遍周用。三光轮穷照用。并与下为则。又可分二。一佛二法。佛中亦二。一身二名。法亦二。一实二权。于中佛身及实教差别难明。光觉品同说。佛名权教易辨差别。此二品别论。又释此初二品文殊举义答酬前所问。后一品如来举事答释成前义故。就前二品中辨名教二法。既此差别如上所问。佛刹等义差别难思。与法界等意存于此。即为通答也。就初释名别中二。先显名别。后是皆下释别所由。前中二。初征后释。释中三。初辨此界。二十方界。三尽穷法界。问此中名号为唯是舍那佛名。为通余佛。答若约三乘。唯此界内百亿万是释迦名。余十方界是别佛名。若约一乘。尽法界总是舍那名。问若尔何故上文云十方诸佛说法知彼心行等。答皆此佛所化处。故无别佛也。又是释迦海印中现故无别佛。又释如一佛名既遍十方。余十方佛皆各如是遍于十方也。又若三乘机。于诸四天下中随各闻彼当处佛号未必知于余处佛名。若一乘机。一时顿纳一切名号以应一切机之名。一机能受者是普贤机故。一机即是一切机故。又此名号若依小乘是实名。三乘初教即假即空之名。终教此名即平等同真如。经云名字性离。是名解脱也。顿教一切皆绝名。无名俱离。圆教亦俱离不碍名故。今一名即一切名。一切名入一名而不坏不碍。摄一切法界尽。因陀罗网名也。问此大千界依余经论大围山内平满有百亿四天下。上方下方不得更有四天下。若上下皆有则一一四天下皆有上下。故应有三百亿。云何仍说唯百亿耶。答若小乘实处理无改动。若三乘虽即空真如等。而不碍事故不坏本事。若此一乘事即无碍融改自在。是故此中明处随教而圆融。应十数显无尽。此娑婆一界有二种融。一以说法之处即为当中。为成主伴融彼百亿令有上下。使得圆故无三百也。二纵于最东近围山边一四天下为说法主。即是当中融彼余四天下还有十方眷属具足。以诸四天下皆望他为伴望自为主故。是则围山亦随融移改也。余十方界等融义准之。此约一乘教。若约三乘不得如此。如余经论说之。娑婆此云堪忍。悲华经云。是中众生贪嗔痴等过梵王忍之故为名也。放钵经(云云)。须菩提此云善实。诃尼此或云舍义或云生灭。以本语难定也。婆伽婆有六义(云云)。伊那婆那此云王林。谓佛为太子时在此林中生故立此名也。第二释别所由中三。初牒机。二施化。三化意。初中二意。一云此等名号遍法界者。犹自且依于佛有缘可化众生有此差别。非谓一切。二云此机何得于佛有缘。谓佛往昔多劫修时。见闻随喜等故有缘也(更有逆顺云云如别记在)。二施化中五句。初句总说三轮摄化善巧。二语业方便。三身业方便。四意业方便。五施化称根。又释初句身现威仪以摄生故云种种方便。二语业梵音等。三所说法谓为人天说业报等。为二乘等说于权道即四谛是。三化意者谓随说人天二乘等法意。欲令其知如来法

    四谛品第四

四门同前

一释名者。四是数。谛是义。谓理实故能生无倒解。故俱名谛。即带数释。此品非是解四谛义。但明四谛名字不同故名四谛品

二来意中五。一为释成前品末权道之义。二依前身业次辨语业故也。三前明能说之人名字不同。此明所说之法名字不同故来也。四答前问中佛说法问故。五为释成前机所印成差别法中权教异相故次来也

三宗趣者。以无边甚深谛海为宗。及同上土海。四谛义略作五门。一释名。二辨相。三体性。四业用。五种类(别时作)

四释文中三。初明此土谛名。二辨娑婆外十世界中谛名。三显十界外尽空世界谛名。初中四谛内一一各三。先列名。二结数。三辨意。谓为应机令调伏故立此名。调者调和。伏者制伏。谓调和控御身口意业制伏除灭诸恶行故。何故文殊说者。明妙慧善达实谛义故。又何故唯显四谛差别。谓是权教差别易知故。又为寄显法故。何者谓此小乘局处之法尚有如此遍空世界差别不同。则知一乘通方之法差别无边。理不疑故也。又为破计引机。何者谓演彼小乘局法令遍故。使失本执。便显一乘无边法界。令其趣入故。又此约一乘共教为则故。通收下位故。生苦之集故云苦集。苦尽之灭名苦灭。至苦灭之道故云苦灭道。不得单言苦道。以道非生苦不同集。又非灭苦不同灭。但能证灭应云灭之道。以灭是苦灭故云苦灭道。余文可知

    如来光明觉品第五

四门同上

初释名者。谓如来之光明光明之开觉。谓依体起用依用成益。皆依主释可知

二来意者有七。一前明身语今明意业故来也。二为别答前功德势力等问故。三前二品别明人法遍。此为双显二遍故。四为前但论佛名普遍。此显佛身实德亦遍。前说四谛权教普遍此辨十偈实教亦遍。谓长行及颂二处是也。五为断疑故谓前品文殊说佛名法名差别普遍。恐众疑故。佛以身光照现彼事令众目睹疑网自消故来。六非直如前但佛名谛名遍虚空法界等世界。而今如来即此说华严时亦如是遍一切尽空世界。一一皆时同处同众同说同。即自验见为下轨则故来也。七前佛名谛名则多名别别遍。以是权故。今明一法一会即圆融遍。以是约实故。又前是差别遍。此是无差别遍故须来也

三宗趣者。先宗后趣。宗有二。一开二合。开中三。一能照之光。二光所照境。三照所成觉。此三各二。一身光照事境令众觉见。事无限碍即长行所辨二智光照理境令众觉见。理无差别即颂中所明。二合者良以理事俱融唯一境故。故得一事即遍无边而不坏本相。由境无二故。身光即智光。唯一无碍光。如涅槃经云。是光无相非青见青也。又亦则事觉即理觉。平等唯一觉。又以此光不异觉境三法圆融唯一法界。虽平等绝相而具一切恒不杂乱。以无障碍故。二明意趣者显此无碍理事有多意趣。略谓五种。一近与信中菩萨为所信境故。二远与下文一部为则。以下诸会等中皆结通云一切世界亦如是说者指此文也。三为显如来出世以一乘圆教于须弥楼山等一类世界施化分齐故。四为显一会则一切会故。第一卷云其身遍坐一切道场者是也。五显理事俱无障碍。令众生舍执依法故也

四释文者此光所照随处无限。大约总数有二十五重。前九别说。后十六同辨。则为十段。此中非是二十五度放光。亦非一放光次第渐照二十五处。但一放光则并顿照。同时显现。以引机入法令渐睹见。自近及远故有次第

于初段中二。先佛以身光照事。令众得见。后文殊智光说法。令众得闻。前中二。初明能照之光。二明所照之境。前中初放光人。次光出处。后显光数。足下相轮放光者有三意。一初义表信为万行首故。二卑义表信行最微故。三本义表信为万行之本故。智论第九云。足下放光者身得住处皆由于足。此之谓也。百亿光明者以所照世界虽复无边皆是须弥楼山世界故各有百亿四天等为所照故。是故光明亦唯百亿。二所照现中二。先明照现本世界中染净等事。二如此见佛下明照现自法会普遍之相。前中四。一现人界。此海边有大树名阎浮提。因树立此洲名也。弗婆提此云胜身。以生彼者身皆殊胜故。狗伽尼此云牛货。以彼以牛为货易故。郁单越此云胜生。以定寿千岁衣食自然故。二现佛兴。于八相中初三未是出现相故此不论。

问佛初成道第二七日。放此光明如何却现菩萨生等。又佛始出世。何因乃现有般涅槃。答下文云。于一念中显现三世一切佛事。此明现在摄过未也。问若尔何不现彼无量劫事。答此中文意但为论此世界中佛兴之事故。不说余耳。三现诸天可知。四此世界等一句总结悉现。二现自法会中二。先现本会。二以佛神力下现新众来集。于中佛神力者是前则如其像现神力是也。所集中有三世间等可知。又如此处光照无边界一一众会皆悉显现。彼一一会皆亦如是。光照无边以法无二与此不别也。又诸光交往不相突碍。以各见当处光照他不见他处光照自故。何以故主主及伴伴皆不并故。主伴伴主皆不违故。问此诸会云何相显。答有二相。一以此光照彼令彼现此摄成一会彼处亦尔。此同法华分身诸佛。二即此一会佛及文殊等融遍法界。是一切会。以圆教中未有一法不则一切者。是故一文殊从东来则是一切处文殊一时来。纵今西方过无边世界说华严处。亦见文殊从东十刹外来。东方亦尔。未有见彼过向西者。乃至贤首亦然。以是一乘缘起门不杂故思之。二智光觉中二。先此处后结通。此中颂意只融会前光所照诸事。于中二义。一约境有三种初一颂明法离情谓。二有八颂会事同理。三末后一颂显事无碍。皆依前起后。二约心者一恐众见前光所照事随相执取。是故初偈约佛遣之。令众舍相离乖理之失。又涅槃经云。如来非无流。何以故。如来常行有流中故。又佛地论明。佛非流非无流故也。二恐众生疑。何因此事而得普遍。故次八偈会事同理。令众见真显顺法之得。三疑云事既同理则平等无二。何因得有事事普遍。故后一偈明则理之事故。而得一事则无量事也。八颂中初一前既知佛是无流法便为过失。未知若为是无失邪。今云观佛无所有是无失也。以佛功德法从缘无性自散灭故。又释观佛及法悉离性故。此即会前放光之佛明离见也。二会前光所照处。又明前依正俱绝住着。三明依正不二也。又明佛身及无流法俱无所有故不二也。心随者是方便观也。入者是正证观。四通会三世间。我是众生我执也。佛是智正觉。此二主伴平等。彼二所住是器世间。无所住故离诸有也。又我谓妄执。佛则真智。此二平等是标也。下二句释真智。于理住无所住。妄我当体远离于有。五通会五蕴。数是缘起俗数之相。谓五蕴若有可在俗数。以蕴空故无有数。又会前所放百亿光等及所照世界诸数量等。皆依五蕴色心上立。求此五蕴实无彼数。故云无数。六绝能所观。非直所见世界等空。能见之智亦无所有。又见者是人。此亦空也。七即用常寂观。谓此佛出世即无起故。又如此空理现前名为佛出。则空佛名无起。八二空观上句人空次句法空。转如是相者一约执转却二执之相。二转现二空理相。皆下一句明观益。并可知。一中解无量等者。为明此一会等中而有无量会等无量会等中而是一会。是前光所照处也。于中初二句标次一句释后一句益。标中通论此有同体异体。各有相容相即。准上释应知。此文且明相容故云一中无量等。然通同异体也。二释中略举二因以释。一由展转生故。二由非实故。初门者总揽如此尽穷法界差别之缘成一缘起。是故一一诸缘相望各有二义。一约体。具空有义故有相即。谓若无一即一切缘全失自体。何以故。以无一时多无所成无所成故不是缘也。是故有一即有一切却一即却一切。此即一切是空义故。泯自即他。以一是有义故摄他即自返上。即一是空义故亦泯自即他。多是有义故摄他即自。由二空二有各不俱故无不相即时。一空一有不相碍故恒时有相即。又由一一缘中空有不二故不坏自而即他。妙义思之。二约用。有有力无力义故有相入。谓诸缘起非各少力而共生故。即一一缘各有全作义全不作义。何以故。若无一缘余全不作。则一有力余皆无力。余缘亦尔。是即一有力故能容多。多无力故潜入一。多有力等亦尔。亦由二有力二无力不俱故。无不相入时。一有力一无力无碍故常恒相入耳。又于一一缘中各由有力无力不二故。不坏在外而恒相入思之。由缘起门中有此相作等义成一多故云展转生也。此即一多更互展转相生故得一中无量无量中一也。二非实故者亦二门。一相即义。谓一非实一故能摄多。多非实多故能即一。又多非实多故能摄一。一非实一故能即多。又即多之一非一。即一之多非多。何以故以不实故。又即多之一方名一。即一之多乃名多。何以故是不实一故。多亦尔。又是亦一亦不一。亦多亦不多。何以故。不实故具二义。又非一非不一。非多非不多。何以故。不实故绝二相也思之。二相容门者。谓一事是不实以无性故。无性真理既无分限。是故于一事上观无性时。无不圆尽法界真如。若观一少事无自性时。不得圆尽法界真者即真如有分。便同有为。是故一事无性即摄真尽。摄真尽时余一切法既不碍存。而即真故同理俱在一事中现。多中亦尔准之。又由俱不坏本事故不是相即门也。由不实之事摄真理故得相入也。又可前展转生约异体即入。此门约同体即入思之。又但此经中相即相入义释皆有二门。一约缘起相由门。二约法性融通门。故是此二文也。由展转生故不实。即二门不别。又由相即容二门各摄法尽故亦不别也。然义恒不杂思之。此下文与此同者应准此知。此文且约相容义说。故云一中无量等知之。观益者达此正理于缘不惧故云无所畏也。以境法无碍故令智无畏也。二结通中唯结此一娑婆界中百亿阎浮处。非是后文尽空界等。次第二重云一切处文殊者。但是十方十佛国土各百亿处。非是第三重处。乃至末后方为尽法界。文意如此应知

第二重照十方各十世界。长行同前。偈中分二。初六叹佛。后四叹菩萨。初中一显佛求道之因。二转正法轮。初句标。次句释不常。下二句释不断。三大誓为本。四慈力伏魔。五内智断证。六外智化益。叹菩萨中。一游刹。二念佛。三救苦。四护法。皆下句结因果

第三重照十方各百世界。偈中作二释。一初一偈叹报身德。余九叹化身德。前中初二句明大智德。次一句大定德。下一句大悲德。又释以理智照真故。觉诸法如空得心净无碍也。以量智了俗故。觉诸法如幻得调群生也。二释初一是总余九别。总中由应机现起故。如幻故。令见差别。由则不起故。如空故。平等一味。由起不起无二故。调伏众生。则常心净故。云无障碍。下九偈中各具此无二义故用常寂也。又前三句明净缘起体。下一句明缘。下九偈以体从缘正明缘起相。于中或见者有三义。一就一人异时见。谓如初时见初生乃至后时见涅槃。次第而见。二多人同时见。谓有人见正说法时则于彼上有见涅槃等。皆无障碍互不相见。三一人同时见。谓见初生时于中则见涅槃等。如下文八相微细等。良由净心无碍故得圆融普应。于中一初生。二行七步时。三顾眄十方时。四师子吼说天上天下我独尊时。五出家。六成道。七转法轮。八现神力。九入涅槃

第四重照千世界。偈中分三。初二明法身。次四辨解脱。后四明般若。法身中初一明理应缘起。谓初句标深。下释无所取相亦无有能取智。然不住此故应机现也。后一明现即不现故离诸尘也。二明解脱中三。初一何者解脱。谓初句明脱体。下三句明脱用。谓机感相应名和合起。次二偈半辨何处解脱。谓初一离苦缚离分段故不在世间。离变易故号人师子。次一离业缚。谓根境本空虚妄业尽故俱脱也。次一句离烦恼缚。次一句通结永尽故长流不转也。下半偈明由何解脱。谓由二利圆满故。如文。三明般若中三。初一照真。次二了俗。后一双结真俗融无碍也

第五重照万世界。偈中劝诸菩萨修十种业。一慈悲业。二信心念佛业。三善慧业。四无间业。五长时业。六观身实相业。七观心实境业。八神通业。九分别佛土业。十了知多佛业。于此十中。初一缘众生行。次四缘佛行。一信。二慧。三观。四求。次二入观行。一自二他。又一身二心。后三起用行。初一通用。下二智用。一知土二知佛

第六重照十万世界。偈中依梵本各四句为一颂。总有十一偈。于中二。初七言六偈明佛体性寂灭。后五言五偈明妙用自在。前中初一明执色乖真。二妙相超情。三显超情所以。谓以非相为相故。四相即非相故无合散。五明佛无五蕴。若约小乘佛有有流五蕴。如婆沙等说。若约始教。佛有无流五蕴。如成唯识等说。若终教及顿圆等佛无无流五蕴。如佛地论云。如实义者如来身土甚深微妙乃至非蕴界等法门所摄。但随所宜种种异说。六明佛外身内心不异。以俱脱故。无二故。绝色心也。二妙用中三。初一智光照。次二身赴感无碍。初一一多无碍。后一理事无碍。后二举妄显真。初一举妄。后一显真。如是真实者是前妄想也。由迷人谓妄为实不见妄实。悟人见妄无实即见妄实。以称妄法故。又迷人有妄不识妄故无妄实。悟人无妄故识妄识妄故得妄实思之

第七重照百万世界。颂十偈。初一独拔超世。二妙绝心境。无依者无境也。三性治离染。上句性离。次句治离。下二释成。四离妄解真。五转不转法轮。六离有无想名正意思。七约真谛法绝一多。八约俗谛。于中初二句一多无杂。后二句显了知之益。问上云一中解无量等。与此相违。如何会释。答此中缘起有四句。一一中有多以一无性故。二一中无多以一不坏故。三一中亦多亦不多。以不坏一而无性无性而不碍一故具二义也。四一中非多非不多。以二义全夺融双泯故。又由初故有二。以若非无性即坏一故。由二故有初。以若坏一无无性故。是故二义唯一事也。此约不坏。前约无性故不相违。是即由一中无多故一中有多也。返上亦尔。第三句与第四句俱不俱相顺亦尔。并无碍成立。思准之。九观三法相尽名念菩提。一诸法。二众生。三国土。十观三法如性名了佛法义

第八重照一亿世界。西国数法有三种亿。一百万。二千万。三万万。下文百千百千名一俱胝。俱胝者此云亿。是千万为亿。此中据千万为一亿。对法论(云云)。二十偈叹佛善巧力。二颂为一义。皆先举所作。末后一句结由巧力。于中有十。一智断圆满力。二大智乐境力。三无功成事力。于中三法。一众生。二化处。三内禅。并离着故云巧力也。四理智入实力。五示果摄生力。六智入深密力。七境智双亡力。八记时了处力。九了达群机力。十善达三际力。于中初一约俗后一约真

第九重照十亿世界。二十偈。叹佛利他行。亦二颂为一事。于中初二总标化意。次十六别辨化事。后二结用同体。初中师子吼者决定度故。别中八对。皆初一举所救。后一辨能救。初对中前一救痴爱众生。如人堕海由四义难脱。一水深。二波峻。三被网系。四黑闇故难脱也。众生亦尔。此中爱有二义。一已得多故如海。二求不足如流。痴亦二义。一不见过故如冥。二见有乐故结网。后一是能精进行为能救。即是佛悲境故云是佛境也。二救五欲众生。谓色等五境昏心为醉。实无谓有故云兴妄等。三度着我众生。慧者是佛。本际是我。我是生死本故佛能灭也。下三句是所救。初句前无际。下句后无穷。无我法为寂灭也。四救恶趣众生。初偈是深苦。后二句是重苦。五救外道邪见众生。六救着三有众生。七救无明众生。八救长囚众生。下结中二偈。初六句因圆。初句有缘。二行本。三行处。四行广。五二句行深。下二句果满。同一切三世间身故也

第十有十六重。以别说难尽故总论之。亦二十偈。初六举果叹德。后十四明因趣入。前中初二内智契真。于中初二句一念观多劫。次二句一念泯三际。次二句知缘起即真。次二句功毕具果。次有二偈明胜德外彰。于中初二句名遍。次二句离染。次二句身遍。次二句说遍。下二偈明依正因果。于中初福因得依果。后智因得正果。后十四中通论教修七种行。初二偈修二利行。先自利。初句福。二忍。三定。四慧。后利他。二二偈成见佛行。初见应后见真。一切有无法了达。非有无者有三门。一约三性。二约三无性。三约双融。初中复二。初别后总。别中三性各有二义。所执中一是情有二是理无。依他中一是幻有二是性空。圆成中一离相二是体实。此上三一一各融不二为一性故。总者所执是无。圆成是有。依他是俱。以真妄该摄二相尽故无二也。二约三无性者初无相观境中。所执有无皆虚故。又无有有无故俱离也。依他无生性中。无幻有有性空不二故俱离也。圆成无性中。无二性有真理亦不二故俱绝也。三约双融者。三有三无。圆融无碍二相绝故俱离也。三二偈教说法行。于中初二句是所化境。乐是信乐。信乐非一故满十方也。次一句化处。次一句正说。次二句化益。先离染后成德。下二句功成。四二偈受法行即是见正说法身。以七觉为法轮故也。五二偈明舍相见真行。六二偈佛等生界行。七二偈生灭无本行喻。上来通答前初十问竟

    明难品第六

五门分别

初来意有二。先分来者前明所依果法。今辩依果所成因行故也。二品来者所成行中。位前方便信行最初。信中解行及德。明难辨解。居初故来

二释名者。菩萨是人。明难是法。简异果法故依主释。明难有四义。一约心境。难谓真俗幽邃。明谓妙智朗照。二约教义。难谓十义甚深。明谓往复显畅。三约论道。谓难问。明答。以通问答故名明难。何者但举法直咨曰问。非理诘责为难。随问直陈曰答。委释显焕为明。四分宾主。约宾则长行中明设于难。约主则偈中明释于难。故曰明难

三料简者。就此因中或分二。初比位。谓此品下至回向二证位。谓十地品下证位。或分三。初三品是位前方便。升天品下十三品明三贤正位。十地下六品明十圣真位。或分四。初从此尽第三会为十解。以信是住之方便无正位故。摄属十住中。二第四会十行。三第五会十回向。四第六会十地等。或分五。开信异住故。又光云义分或三。初三品明始起于先际。二从升天下明善修于中际三不思法品等明终显于后际。或分四。初未信者令信。二第三会下已信者令入。谓解行也。三十地品下已入者令纯熟。四不思品下已纯熟者令解脱

四宗趣有二。初通后别。通论此三品明十信行法。于中作八门辨。一释名。二出体。三发心。四定位。五行相。六除障。七进退。八德用

三发心者谓始从具缚不识三宝名字等。创起一念信等。此约始教。如本业经(云云)。终教如起信论修行信心分(云云)。圆教如贤首品初(云云)。以小乘非此故不约说。顿教无位故亦不说(云云)。亦可小乘亦有初信义。如小论(云云)。顿中亦有信(云云)

四定位者此十信法于始教中自是位。如梁摄论云。如须陀桓道前四位。谓燸等。菩萨地前四位亦如是。谓十信十解十行十回向。又彼论及佛性论等皆云。地前修四行。谓十信修信乐大乘行。十解般若行。十行三昧行。十回向大悲行。又为除四黑障正使故。谓初除阐提不信障。二除外道我执障。三除声闻畏苦障。四除独觉舍大悲障。又信成净德因种。解成我德因种。行成乐德因种。回向成常德因种。又仁王经寄四轮王报。谓铁铜银金。以此教义故知。十信亦是位也。若约终教此信但是十住位之方便。自无别位故。本业经云。未上住前有此十心名字。谓一信心。二念心。三精进心。四慧心。五定心。六不退心。七回向心。八护心。九戒心。十愿心。增修是心一劫二劫三劫乃得入初住中。心心有十增成百法明门名入习种性中。故知无位但是方便行也。又准六种性六忍六慧等文故亦是成证。又仁王但言三贤十圣不言四也。又此经中后四位皆有入定。出已列十名辨十义等。唯信中无此。故得知也。又本业经但有四十二贤圣不说五十二故知。问若尔何故仁王经十信为种性位仍只立三贤位耶。答此有相摄故如是。何者义准有四句。一以本位摄方便故唯有三贤。则没信名唯论住位。引文可知二以方便摄本位故即十住名十信。没十住名也。故仁王经云。十信十止十坚心。则不论十住但名十信也。三开方便异本位故。则如住前有此十心为方便等。四于方便处假说正位。如前始教。若约圆教有二义。若依普贤自法一切皆无位。若约寄法则同终教。然信满入位之际。通摄一切后诸位皆在此中。无不具足。此则约行摄位故也。问信既实无正位。何故始教说为位耶。答为始教机粗智浅行位不分。影似小乘教故说四位。终教机细智深克实分异故也

五行相者若始教行信等十心行(云云)。若依终教如起信论中四种信心五门修行等(云云)。若圆教如此三品所说(云云)

六除障者始教如前除阐提不信障。终教如论深伏烦恼等(云云)。若圆教如文总灭百障等(云云)。并是满心时灭

七进退者修信未满一万劫以还一切皆退。以是不定聚故。依本业经如轻毛随风等(云云)。设第六有不退心者但是作此不退之心。以非是位故。未得不退也。亦有人解将此为信不退者义恐不可。以经中说如轻毛故。无位故。论说修信未经万劫皆有退故。若至万劫信便已满。非第六故。若就始教以随粗相说信为位。是故今后三贤亦随相粗说。是故至十回向以上方得不退。如佛性论第一卷说。问彼论中是叙萨婆多师说。岂是大乘耶。答虽是萨婆多说然非彼宗。以说有十回向名位故。小乘无此位也。若终教中信满入住则为不退。如起信论信成就发心不退故。及此下文深心净信不可坏等(云云)。以圆同终故。入位已后方说为不退信也。以因从果称故如信忍等

八成德者始教中成净德因。及得铁轮王报亦能进入十解等。终教能成十住位已则能少分见法身佛。现八相成道等事(云云)。圆中通成后诸位。若约因得普贤三业遍周法界。约果遍尘世界成等正觉。如贤首说。二明品宗者以十甚深义为宗。信中成解行为趣

五释文者。此中三品则为三。初品明信中解。次品依解起行。后品解行具故成德耳。又释初行次愿后德位。就初中二。初正辨十义。后结通普见。前中依迁禅师释为十甚深义。于中分二。初文殊问众人答。明妙慧导众行。后众人问文殊答。明以众行成妙慧。又衍法师云。初一人问多人明。一中解无量。二多人问一人明。无量中解一。又文殊为法主故。多人同问佛境深法也。初一是缘起甚深。二教化甚深。三业果甚深。四佛说法甚深。五福田甚深。六正教甚深。七正行甚深。八助道甚深。九一乘甚深。十佛境界甚深。初缘起者。诸法依阿赖耶识自性缘生方得集起故也。何故最初辨此义者。摄论云。菩萨初学应先观诸法如实因缘以成正信解故。此之谓也。于中先问后答。亦是先明设于难。后明解于难。前中二。初总告。何故最初问觉首者。谓创发厌求非初觉不起。如善财初发于觉城故。又缘起甚深亦非觉不达故。二正难中此难何因生者。凡诸菩萨起信解行等皆依如此唯心道理。得异凡小而成正行故。起信论云。有法能起摩诃衍信根。是故应说。所言法者众生心。是心即摄一切世间出世间法。是故于此而起难问。问意云。心性是一果报种种。云何一心而生多报。又心性既一。果亦应一。果报既多。心亦应多。设尔何失。谓心若随报成多则失于唯识。报若如心为一则乖于业果。设若救言。若立唯一性心无有能熏可如所难。今明心性虽一随善恶业等能熏转故生果报异。此有何失。后遮此救。重更难云。业不知心心不知业等既不相知。何成熏习。熏习不成何得种种。难意如此。文中二。初举法设难。后五句遮救重难。前中三。初一句举法案定。次一句正显相违。后五句释成违相。初云心性一者谓心之性故。是如来藏平等一味故云一也。又心即性故。是第八识无二类故云一也。云何能生种种果报者显相违也。此是本末相违难。三或至善趣等者释成违相。于中五对。初一约依报。善趣是人天。恶趣三涂。二对约正报。于善趣中眼等诸根有具不具。恶趣中亦尔。三对重就依报。于根具中屠猎等为恶处戒施等为善处。根不具中亦尔四对重约正报就善处中有端正丑陋恶处中亦尔。五对就端正中有苦乐。丑中亦尔。如是种种差别故云不同。报既如此不同。其一心之义何在。自下五句古人释云。约不相知为难。谓心以觉知为性。能生于业。心之与业并得相知。云何经言业不知心心不知业等。此释恐不顺文。何者此不相知等与上诸句为同成一难。为更成别难。若同成一难。前心性是一果报种种。正是相违。故已成难。此不相知于彼何用。若成别难。复因何义而生此难。故知文意少别。是故今释不同古也。谓此即是遮救重难。然救在文外。设若救言心性虽一。然有善恶业等熏习种子功能生果有别。所依心性一而无二故无失也。今重难中有五对。初一约能依所依不相知故不成熏。此中业是能依心是所依。离所无能能不知所故业不知心。离能无所所不知能故心不知业。既不相知何成熏习。熏习无故岂得因业心生多报。此等相知约性力说。但无性无力。故不相知。非约情知。上约本识因相说。第二约果相。谓因果不相知。果谓异熟。果报具有二义。一能受报心。是本识种子识。二所受报相。是果报识。以种是果因不自因故。受不知报。以报是因果不自果故。报不知受。既不相知因果斯泯。心生种种。其义安在。第三约新熏不相知。谓于此报上受谓采纳则诸转识。以为能熏不同受报。心谓集起则第八识。以为所熏。互无自性。各不相知。熏习既亡。一心云何能生种种。故瑜伽云。不见藏住不见熏习。是名菩萨菩萨。第四约亲疏不相知。谓种子为因。所依本识为缘。以相待无性谓不自不他不共等故。亲疏相尽。故不相知。因缘既离。心生何在。第五约境智不相知。智谓能知即诸识见分。法谓所知即诸识相分。俱依一心各无自体。自体无矣。谁共相知。心境既亡。能所斯寂。心生种种其义安在。又释境法是心变故不知心。心托境生故不知法。无有境外心能取心外境。是故俱不相知。相无不尽也

第二答中二。初一颂赞问劝听。上半叹问会机。下半劝听许说。后有十偈。举义正答。于中初五偈答后遮救难。以救义若成本难方遣故。须先答后五偈答前本法难。此中答意。明藏识缘起有其二义。一是不起义以无自性故。二是有起义有此无性缘起故。此二不二。是一无碍甚深缘起。此中由不起故成起。是故只由诸缘不相知故而成熏习。有种种法生答后难也。二由起故不起。是故只由诸法种种生故。各无自性唯一心性答前难也。又前即不碍一心即是种种。后即不碍种种即是一心。缘起正理无碍镕融是其意也。前五偈中。初一法说。后四喻况。或可长为五分。一宗二因三喻四合五结。诸法不自在者立宗也。谓诸法是有法。不自在是法。法与有法和合名宗。于中有二义。一藏性缘起能所熏起摄多法。故云诸法。以互为因缘更相系属。各各不得自有所在。二从诸缘起无自性故无自可在。二出因者何以得知不自在耶。因云求实不得故。以本识诸法互依缘起更相形夺各无自性故云求实不得。此有二义。一约本识明不自在。以依彼诸缘无自性故云求实不可得。二约能熏等法明不自在。以依本识无自体故云求实不可得。或通论有四义。一诸法依识故于诸法求实有不得。二本识为依故于本识求实无不得。三诸法起识故于诸法求实无不得。四识随缘起故于本识求实有不得。或开为八句。谓各有有无俱不俱四句。故准思可见。又释此有四句。一以不起不异起故求不起实不得。是故不起不自在。二以起不异不起故求起实不得。是故起亦不自在。三以无二故求二实不得。是故无俱自在。四不碍二义故求俱非实不得。是故无俱非自在。何以如此不自在者以缘起自在故。何故不实者以缘起理实故。三是故一切法下结也。以结随法故在宗因后。明合随喻故在喻后说。二俱不相知者如上能所熏中各有有无二义。以二有二无各不俱故不得相知。以一有一无一无一有各无二。故无可相知。正由如是不知等故得有一切法。故云一切不相知也。此显非直平等一味不坏诸法。亦乃只由平等有诸法也。四喻中有四喻。此藏识四义。一相续因果依他义。二互为因果生识义。三受熏义。四相依持义。初云如驶流者唯识论中明阿赖耶识恒转如瀑流。是此义也。此中无绝是彼恒义。流流是彼转义。故彼论云。恒言遮断。转表非常。若细别分凡水流时要有四义。一有能流之水。曲有三。一水体清净喻本识。是如来藏本性清净心。二土杂成浊喻如来藏自性清净为无明所染有其染心。三遇冷成水喻如来藏还与妄识俱成本识缘起。故楞伽云。如来藏名阿梨耶识。而与无明七识俱等。二相由故流。以喻本识自相义。谓后水推故前得流。或前水引故后得流。各有有力无力等。互不相知而得流注。此即不流之流。如云江河竞注而不流此之谓也。经中名流注生灭。唯识论第三云。如暴流水非断非常相续长时有所漂溺。此识亦尔。从无始来生灭相续非常非断漂溺有情令不出离。乃至谓此识性无始时来刹那刹那果生因灭。果生故非断因灭故非常。非断非常是缘起理。乃至应信大乘缘起正理。谓此正理深妙离言。因果等言皆假施设。观现在法有引后用假立当果对说现因。观现在法有酬前相假立曾因对说现果。假谓现识似彼相现。如是因果理数显然远离二边契会中道。诸有智者应顺修。学又依楞伽云。刹那息烦乱寂静离所作。一切法不生。我说刹那义初生即有灭。不为愚者说。无间相续性妄想之所熏。解云前论中生灭隔念。经中生灭同念。是故则不生不灭之生灭(更思之)。经约终教。是不生灭与生灭和合名阿梨耶识等故。论约始教唯生灭是识。细克亦不成生灭。以生时无灭应非有为。以相不具故。若有灭应不得生。以相违故。是故终教中同念。以各虚假故不相碍也。又依真心故得同。随相故有异(更思之)。过去灭能成生。当来灭能坏生。生法能坏过灭能成当灭。又一灭相望前生能坏。望后生能成。一生相望前灭能坏。望后灭能成是故相续无绝(更思之)。又生由灭起故。是故生中具有灭。具有灭故。令生不住还复成灭。灭由生有故。是故灭中含于生。含于生故。令灭不住还复成生。是故生灭交涉。前后同时。不相障碍。流注不断。又一生相中有四种灭义。同时具足。一性不成就名灭。二由灭故起是故具灭。三能成灭故具灭。四由生灭俱是梦妄计妄中看有前后。理实照时皆无前后。是故生时还有灭也。(更思之)前念灭流流至于生。后念生流流至于灭。生灭二流故云流流。未得治道已前无暂停止故云无绝已。二流各无等不相知也。三依风故有二义。一依风得流。喻藏识因相义。谓依惑业风熏习种子而漂流故。此约因相辨。二依风起浪。楞伽云。藏识海常住。境界风所动。种种诸识浪。腾跃而转生。唯识第三云。又如瀑流虽风等击起诸波浪而流不断。此识亦尔。虽遇众缘起眼等识而恒相续。此中一风吹故流。二由水故流。故云流流。互依无性各不相知。或种子流及所依识流等。虽不相知而有流。上文业不知心准之。四依地高下故流。喻本识果相义。依种种受生地报故流。人天处为高。恶道处为下。此约果相。此中心与报为二。无性故不相知。上报不知受等准之。或带物而流。故唯识云。又如瀑流漂水上下鱼草等物随经不舍。此识亦尔。与内习气外触等法恒相随转也。第二灯焰喻成依者有三义一生识义。二互为因果义。三执受义。初生识者如依前焰烧炷故后焰得生。明照前境但一念故不暂停。六识亦尔。名言等依本种子识故能生后识照于境界。前灭后生间无暂停。此中以本识如炉油识中诸种子如灯炷。所生现行六识如炎无体速灭故不相知。二俱不相知者古人云。炎炉为二。炷油为二。四法和合而生各不相知。此恐无理。文意似取前焰后焰为二。由速灭不住无体可以相知。六识依本无体亦尔。心不知受等准之。二同时互为因果义。如摄论第二云。论曰。譬如灯光与灯炷生及烧燃一时更互为因。释曰。由炷体依止能生光炎故。炷是光炎生因。光炎则此生刹那中由能烧燃炷。光炎则为炷烧燃因(乃至云云)。论曰。应知本识与能熏习更互为因。其义亦尔。如识为染污法因。染污法为识因。释曰。此阿梨耶识为种子生因。若无此识三业生灭无可依处。如体谢灭功能亦尔。故由此识诸法体生。功能亦立。是故本识为彼生因。彼法亦尔。若彼法无此识。起在现在无有道理转后异前此变异是彼法果。解云。此中前念炎炷同一刹那更互生烧。各有因果亦同时谢灭。后炎亦尔故云炎炎。未至治际此法恒起。故不暂停。以二因二果不俱故不相知。一因一果无二故无可知。又亦能烧炷之炎及炷所生之炎故云炎炎。以生理不停故则是烧。烧理亦尔故云不暂停。不相知如上。此中互为因果义略作二重。各有三门。一护过。二显德。三示过。如问答中(云云)。三执受义者。此中明灯有二功能。一内烧炷燋。二外发光照。喻此本识有内外执持。瑜伽云。此识执受有二。一内执受种及五根身。二外执受器世间。犹如灯炎内执膏炷外发光明。此之谓也。此内外二故云炎炎。恒执无间故云不停。内外为二。以无性故不相知也。第三风喻熏习义者。此中风有二义。一有力能动他。喻转识能熏成种子等。二无体义。谓此风不能自现动相。要吹物令动方知风相。此动乃是物动故知风无自体。诸能熏法不能自成种子。要熏本识成种子已方显能熏。此种乃是识种。故知能熏无性。二俱不相知者风物为二。依物之动则风无性。随风之物物无自性。亦二无二有不俱。一无一有无能所。故各不知也。识中亦尔准之。故云诸法亦如是。第四地喻相依持义。如地轮依水轮水轮依风轮风轮依虚空虚空无所依。心义亦尔。境界依妄心妄心依本识本识依净心净心无所依。又释现行依种子种子依本识本识依真如真如无所依。不知者空与风为依。自无体故不知风。风与水为依自依空故无力能知水。水望地亦尔。识中亦准之。上来答后遮救难竟。第二答前本难中五偈分二。初二正答前难。后三便显观门。前中难云。心性既一。云何能生种种果报。今答以随诸转识熏习故生。非是一心自作种种故云眼耳乃至因此转众苦。前或至善趣等五对皆约报辨。故通云众苦也。此中眼等五识可知。心是本识有集起义故。意是末那有思量义故。情是识则第六是了别义故。此八各有根。五根可知。意为第六根。七八互为根。皆有生识义。是故云情根。因此能所熏和合转众苦。疑云既随熏转众苦即是成多心。云何仍说唯一心耶。答云此能熏诸法若是实可使随熏失一心。众苦既虚假故得一心实不转疑云若实不转云何前言随熏转众苦。答云但示现转非是实转。疑云于法性若有此示现亦得相违。答云但随他有示现。于彼法中无此示也。何以无者以示现无所有故。此偈中上半明不染而染。下半明染而不染。下三偈便明三无性观。初一遍计无相观。谓上八识等。约执但是虚妄都无所有故云也。次一明依他无生观初句观。方便寻思等。次句观境有者是前眼耳等。无所有者以众缘无性故空也。次句正观以见无所有理故云不倒也。下句释云。以得见法之眼不杂无明故云净也。后一明真实无性性观。于中虚妄是所执性。非妄是无相性。实是无生性。不实是依他性。二观若成是出世间。二观若无是世间。约观智说。此等有无相待不实。故云但有假言说。有无俱亡方入无性性观也。此应广说三性二性等观约解约行分之

第二教化甚深何故来者。前明摄心入理。此辨后智救生。财是法财故也。于中先问后答。此中问答似少不同准答取问。问中应云。如来既十随教化。云何复说众生则非众生。答中明身命等皆空故。是十随教化则非教化。以众生非众生教化亦非教化。此有何失。又准问取答。难意云。如觉首所说。众生既空。云何教化。教化之时若如圣智称理见空。则不成化。若同凡执横计为有。即不能化。此是有无相违难。答意众生是空空是众生。大品云。非以空色故名色空但以色即是空空即是色。解云。以即色之空方是真空非断空故此非凡智境也。则为如此众生以如此十随说如此法门。方为真教化。难问中二。初一句举正义。二云何下显相违。于中古人将随身是总。今初一是总余十是别。初一是发心时得道时等。论云。难处生者待时故。二随其报命。或长时或短时应受化故。则于彼时而教化之。三随其所受身时。如待得人身方教化等。四随所作行业时。如待作恶行方得法忍。如净诸业障经说善行等准之。五随当起何欲乐而受化时。六随起何誓愿而受化时。七随起何意念何事时。八随起何方便而欲造修时。九随起何思惟照察时。十随起何筹量计度时。十一随起何等见应受化故。如来尔时则便化之。既如此随机屈曲教化。而说众生则非众生。其理安在。第二答中二。初一偈赞德劝听。上半叹文殊德以智中不杂无明故云明智。能照唯心之理故云境界。何故恒照此境者以常乐寂灭行故。后九偈中二。初七正答前问。后二遮难重答。前中随时一问无答。以总不离别故。初三偈答随身一问。次二答随命一问。次一答随行一问。后一通答余七问。初中先二明人空。初一昔来谓我在身中故。今明身无我亦无。则以界分别观观是身不可得故。则达所执身中我有即是无也。次一昔来谓身依止于我。今明我无身亦无。则寻能依身分观所依之我不可得故则于身不着也。次一以内类外明法无我。于中初二句标次一句释下句益。如此随身则非随故。不异众生则非众生。是故无失也。就答随命二偈中。初一观境后一观智。前中身谓名色则果报身。命谓正受生识则是本识。本识与身从始至终更互因果和合无二。喻说可知。此互为因果非二乘愚夫乱识境。故言不可知。此义谁能知。以智者能观察故则佛菩萨法如智也。所以得知身命更互为因缘者。以分别依他无常法更互为因故有身命。以常住法不成因故既云无常。即有非有各无自性故云空无我。及离增益损减等一切相。就答随行一偈中。由本识与意识诸熏习法更互为因故。业功能生非有人法等故云无我犹如梦。非唯业行独绝二我。业所得报我性亦寂故。其因果似前后异。无我义同曾无异也。次一偈答后七问。以随欲乐等七皆是心数。依心王不自在故。故举心王总收通答。故云唯以心为主故。又释。一切世间法唯是自心变异所作心为其本故云主也。然愚夫不了唯心义故。妄随分别起此欲乐等七种心念。以皆取相故悉是颠倒。是颠倒故则空无所有。是故随之则非随也。下释遮难。恐有难言。若众生如此则空自是法门。随亦尔者何须更化。释云。以不能解诸法则是无二故。是故化之。又更难云。则此不解真实之众生岂不则是空耶。释云。以从缘起故非无。速灭不住故非有。此二不二是众生故云无异相。是故得教化。前偈明须化。后偈明成化

第三业果甚深内先难后明。难中二。先举法正难。后然法性下遮救重难。此中难意。若四大中无我者谁作善恶。谁能受报。此中执有作用应有作者。是以用征体难。设小乘救言。虽无我人作者然有善恶因果法故得如此也。犹是法执。故重难云。然于法性无善无恶。此显法空。既于法性空无善恶。若无作者更因何法而有业果。故知有我。我既实有无我之理安在。难意如此。前中二。先一句举正义。下显相违。于中五对十句。初一约受报计有受者。二约作业计有作者。三约报中差别。内约行外约身。若无作业者何因有此别。四约多少报。如经中说。能作多业受报亦多。少亦尔。故知有我。上约生报。五约现后报。下遮救难可知。亦是覆却重征。第二答中。何故宝首答者。谓事中显理得可贵多宝。于中有二。初一偈法说。下九喻况。前中二义。一举义正答。二引佛证说。非已能知。初中上二句明业果不坏。下一句明无作者。谓随其所作诸差别业熏于本识。本识依他变似其业所起果报。故有多报等种种不同。但是诸识缘起互相集成无自性故得有业果。实非四大中别有人我能作业受果故云造者无有也。此则由无性理故法性无善恶。由无性故成因果故有业果差别。此但有无性之因果。何关有我人。故云四大中非我等也。如此正法理数决定。三世诸佛之所同说故云诸佛说也。楞伽第一云。我常说空法。远离于断常。生死犹如梦。而彼业不失。此之谓也。下九喻中皆有二义。谓业果历然而无所有故成喻也。一明依他离性喻。谓本识如镜。随熏所现业果如像。此是依他义。内外无所有者明离自性义。此有三重四句。一约像。谓无质不现故。内无所有非镜无现故外无所有。由是一像故俱无所有。由是像故俱非无所有。以凡是像义必由内外方得现故。二约质。谓面南像北故质内无所有。由如面而现故质外无所有。俱不俱可知。三约镜。谓镜铁坚密间无空处。不受物故像非内也。凡欲观像者皆临镜观之。所以非外。俱不俱等准之。如此无所有而影像历然。业如像性如镜故云亦如是也。起信论云。二者因熏习镜。谓一切世间境界悉于中现。不出不入不失不坏。常住一心。以一切法则真实性故。此之谓也。第二明无知成因喻。谓本识如田。业等如种子。多类种子同一本识故各无自体可得相知。然识功能不失坏故而能为因。如纯净土得雨生草。此多草种于彼土中求各各性皆不可得而能为因。纵深掘地所得之土得雨生草。草种同土虽多年不失。此亦尔经云。业虽经百劫而终无失坏。遇众缘合时要当酬彼果。故云业性亦如是也。又水土为疏缘。种子为亲因。各全夺有无故。是故不相知。识中准此知之。第三因能现果喻。谓业性如幻师现果如幻色。虽似有而非有故也。第四果法无念喻。谓由咽喉等因缘和合出声。实无我能。但从名言熏习生似于言说。如木人出声无自念云我能出声及非我出声之二念也。又木如藏性。匠如妄想业等。木人如众生报相。故无我非我也。第五因体无杂喻。谓鸟在[穀-禾+卵]时未辨音相。出[穀-禾+卵]随类方有异音。口业种子在本识中同无记性。无若干相。至受生处报熟之时能出众声。又功能生果不同如鸟出[穀-禾+卵]。业体性空无别如鸟在[穀-禾+卵]。此乃喻是前后。约法同时。第六现果无来喻。谓如父母为缘受生识有烦恼业等种子为因。此识与赤白和合时名因缘会则此名受生。无别来者虽无来去而报渐长不妨诸根各别。业亦尔。思动身等造业。无别来处。后若熟时感报差别。第七苦报无本喻。谓以恶业熏自心故令心变作种种苦具。还自恼害。然彼苦具虽外无来处。然恼害事不坏。业亦如是。虽无自性然感报不灭故云业性亦如是也。第八胜果无根喻。谓善业熏心心幻现果亦无根本。小乘说轮王灭后七宝贮在铁围山中。后圣王出七宝还复现于王前。今此不尔。但由业熏自心变现。无别宝体使之来去。业性亦尔。论云。善恶熏于心。何故异心说。第九有无同性喻。谓有流业未得果。及治道前为本识摄持功能不灭。名为成。至其得果及得治道时。业功能尽。名为败。寻其成时无所从来。求其败时亦无所趣。此并不坏世间说第一义也

第四佛说法甚深。初难中二。先举法正难。后遮救重难。前中二。初举正义。二正设难。谓十种相违。一法是一味真如也。难意云。所觉既一设教种种。义若非一可使随言并实。即乖一味应失所证。义若一味而不随言即诸教种种皆应虚妄。此是教义相违难。彼若救言。我此所证一味理中具多德故。是故诸教各显一德故不相违。为遮此救故重难云。而于法性中分别推求如此多种实不可得。不可得故教便乖义。又释此是体用相违难。谓觉一法是体。应机现多是用。若以体从用应乖失一法。若用同体种种便虚。若言一法之内有种种故不相违者。而法性中求种种不可得故不成救也。十句中。初一总余九别。一教声普遍。二教力摄生。三声声差别(已上口业)四身业。五意业。六身用。七依报。八严土。九分齐。若具说应一一句初皆云唯觉一法云何无量也。答中德首答者显法理德深故。于中二。初一偈叹问略答。答意云以一味法界是无分别义非是一数之一。是故随缘成多而不异一味。一味湛然而不碍种种。此二无二。是故诸教并实而一味理存。如此无碍。是故名为甚深微妙义也。又释。此不异多之一。是如来所觉。不异一之多。是如来所说。是故一为甚深。以不异多故。多亦尔。反上可知。故云甚深妙义。求功德者以知一起多堪摄生故。求此一得。又知多归一堪证理故。求此多得故名智者也。下半偈德首自显约法为名也。此中九喻并显不改一无分别而成事差别。一明法能荷载万机喻。二缘灭众惑喻。三入器无变喻。谓如法界胜流义等。四拂动诸根开觉喻。谓熏成种子动令厌求也。五应欲随润喻。龙如佛身雷如梵音雨如正教无分别故不异一也。六缘生众德喻。谓依净法界成修生诸行等。七无垢照机喻。八应机无往喻。九随缘不变喻。此上诸门皆不异一。无分别而现多种利益事。如梵应大千喻如说无量也。身无异喻一味常存也。余门并准

第五福田甚深难中。初正难后遮救重难。难意上既云佛德无异。则应设施得果不殊。如何今见得报差别。此是缘果相违难。恐彼救言。佛田虽一若人于佛兴上妙供。佛于此人生亲爱念。故得胜报。弊恶返之。为遮此救故后云如来平等无有怨亲。此是三念处法也。正难中初举正义后显相违。于中初句总十句别释上总中不同之言。一色相好丑。二人中四姓及五种姓等。三如贵而非富富非贵等四句是家。四眼等根具阙好恶及根机利钝等。五生财金粟等。六等一布施有得奇特财物。如树提伽白叠以钉入地七寸不穿等。七眷属善恶等。八既各卑己行施。应同得自在。今乃有。或于一人得自在余处不得等。各有分齐。阶降不同。九福德多少。十智慧浅深遮救可知。答中目首者见此法明白故。答意凡施佛由二因。一由施者用心不等故。遂令得报千差。如温室经说。皆由用心不等故。二由佛大悲不思议故。究竟皆悉令得解脱故。大悲经第二云。下至畜生能念佛者。悉得最上涅槃尽烦恼际。况于人等。又如下性起见闻之益等。是故偈中众生故有异。是初义也。能烧一切有是后义也。此二无二。同一报故不相违也。引十喻示。一缘能现果喻。二应机随解喻。三善巧随顺喻。四应感令喜喻。五物感现形喻。六善除惑障喻。七殄灭智障喻。八悲情普被喻。九动令生厌喻。谓不令坚乐也。十焚烧尽灭喻。谓令得涅槃也

第六正教甚深难中三。初举教力。二为知下举行力。于中十法分三。初总知五蕴。二知三界染净报别。三知痴爱是报缘。三若知下以行难教显教无力。难意为因教法断惑。为因勤观诸法断惑。若因教能断则不须精进。若因勤行能断则教无增损。谓此教法于德不增于惑不损。又释得教不增失教不损。以无用故。此是教力相违难。答意以教是精进之缘勤观扶教方能断惑。是故速出。教有胜力懈怠乖教则无教力。是故难脱也。难者以行力夺教力。答者显行由教力故也。以应教离懈怠故。进首答之。偈中三。初一劝听总说开二章门。次一偈辨精进顺教释速出门。三有八偈明懈怠违教释难脱门。一多闻懈怠喻。是人先已小闻尚不能领悟。如小火也。今更强求广多闻诵。如湿薪也。以新旧俱失都无成益故为懈怠。又此人欲以少时顿学多法。学既不成遂成懈怠。二无力懈怠喻。是人薄福少心力。复数废习。无所成故为懈怠也。又此人虽亦多时然数间断。故业不成名懈怠也。三偏修懈怠喻。是人背善知识偏于经卷求习闻慧。无所得故懈怠也。又此人虽无间断。然阙缘故业亦不成。四倒修懈怠喻。是人闻说书持经卷便证解脱以不知别时意故。久而不得便生懈怠。又此人虽有外缘并是错学之人。妄取倒求。故颠堕也。五过求懈怠喻。是人不自知无闻慧。径望总达一切佛法。既不能达便生懈怠。又此人虽外有良缘内因有阙。谓无信心手无持戒足。不挛定弓不茹智箭。云何能射烦恼大地。六少力懈怠喻。是人以刹那意识则望究尽佛法深海。既不得入。便生懈怠。又闻一念称佛灭多重罪。但称一句则休云我罪已灭等。七小治懈怠喻。是人闻佛教能灭烦恼火。则以小闻望尽灭之。久而不尽则谓佛教无用。并皆弃舍。故是懈怠。八无求出意喻。亦名执我慢高喻。是人闻说众生则真如。以不解迷悟故。则云我既是真如则是已证得法界更何所修。则生懈怠故也

第七正行甚深难中三。初引佛语举正义。二云何下设难显违。于中初句总。次随十种垢法是别。恒上心现行故不离心也。三心无所行等是结难反征。谓虽闻正法无心依行而欲断惑。故知佛说闻法能断其义何在。又释此是遮救重难。谓若救言。若依教行即能断惑。故闻法能断义还存者。今重难云。此依教行既是心有所行何能断惑。若依道理。要须心无所行方能断结故。是故闻法终不能断。答意则此心无所行名如说行。故能断结。若但唯闻实无断义。可有闻而不行。无有行而不闻。故曰一切佛法以闻法为本故也。此与前正教甚深何别者。前以行征教难。教力摄行答。谓若无教勤行不成故。此中以教征行难。行能行教答。谓若不行多闻无用故。执教成行故。法首答也。十偈初一劝听总答。非但积多闻者明多闻不是过患。但是唯也。以阙行为失故也。后九举喻显失。一不如说行喻。二随说废思喻。三计文迷行喻。四自谓非分喻。亦名耽文失行喻。五恶业障碍喻。六不解自说喻。七不见自义喻。谓前约教此约义。八废正成助喻。谓如牛王目比丘诵八万法聚永度多亿众得道。自身不免堕地狱等。九隐非现是喻。谓如调达善说法内怀朽烂等。又倚恃此说非分自高。返为所害等。问何故此中诃毁多闻。十住品中乃赞多闻。答为信中行劣恐滞文故。又是闻熏之初令成一心无倒听闻故。十住已去行胜故。不滞着故。能广利生故

第八助道甚深难中三。初举正义。二何故下设难显违。于中六度四等为十。此约行辨。若约位论则加方便等四为十。此中般若应是世间慧摄。不尔非难故。三此一一法下结难反征。难意云智慧为众行之主。何不唯赞此而叹余行。余行离慧皆不得菩提。何须赞之。此即以助征正难。答意者以正助相资答。以能会助同正故。智首答之。十偈中分三。初一叹问劝听。次二偈开二章门。谓初偈明果非一行成正要待助资。后偈明众生乐欲别。随根故别赞。三释二章。初三偈释随根别赞。又涅槃中于悭等人前不得赞施等者据根未熟。为将护故。此文约根熟故。余亦尔。后四偈约法喻。释初相须章门。施为摄他。戒为自摄。此二通为众行之本。已修善根忍防不失。未生之善进故令生。又忍护外烦。进防内慢。故云防护。禅定伏除。智慧求断。故云安稳。又禅摄外散。慧证真理。故云安稳。四等益生称悦自意。故云安乐也

第九一乘甚深难中三。初举正义。二设难显违。三结难反征。难意一切诸佛同修一乘。因行既同。得果应一。云何今见诸佛世界种种不同。乃至法住如是十种各各不同。无有不具如是一切差别佛法。而言唯以一乘。其义安在。此是以因征果难。因同果亦同。亦是以果征因难。谓果异因亦异。答意理实因同果无差别。但随众生感见差别。非是诸佛自有优劣。以明达一乘顺相故。贤首答之。十偈分二。初二偈就实以明因果俱一。明上唯一乘得出也。于中先因一后果一。因中初半明所依法性一。下半能依行修一。果中初半所证法身一。下半修生胜德一。于中心是大定齐。次是大智齐。此二是内同。力无畏等是外化用齐。通论有三。初体同。次德齐。后用等。二有八偈。明以体从缘现有种种。明上世界等不同。是随机见异。非佛有别。则展转释疑。于中初一明佛随机现差别。二疑云何故现异。释以众生业异见差别故。三疑何以得知众生俱依自业见异。释以众生既不见诸佛法身众等故。明知是但见自心所现差别。非是佛体有若干也。此明报佛身土地前二乘俱不能见也。四疑真佛平等众生不见。谁能见耶。释本行广净等者得见故。此明地上菩萨见实报身土。五疑地前众生既不得见。何由得入真。释以佛力自在各令分见后还令入。六疑佛力既自在。何不则令众生一种见耶。释佛无憎爱。彼依自心故见差别。七疑云我今现见佛自差别。岂开我心。是故差别过在于佛。释云若不唯汝心可如所责。既实是汝自心变现故非佛咎。八疑云若佛不自有差别现。何故有常见有不见等。释云净心器者自心感见。以佛是心法如是故也

第十佛境界甚深。上来文殊问多人。今多人问文殊。首伴互彰故。上论余法余菩萨说。今辨佛境界。同请文殊者久已成佛显智深故。又文殊问皆以理反征相违结难。今但咨请不敢难者为显尊故长故众首故。又此佛境界通二种。一所证境谓真俗等。二分齐境。谓依小乘三十四心以去是佛境也。若三乘十地满后是佛境界也。若一乘十信满后是佛境也。则如此辨在信中者是也。又三乘等不通因位。一乘因果同故。亦是普贤境界。余义如性起说。文中二。先问后答。问中四。一总告。二结已说。三叹文殊。四正陈请十一句。初二问自利德体。次五问利他德用。次三问所益众生。后一结其广大。又初一是总果体也。二以因成果。问体证境因。三入处谓因圆果满乘化普入世间等。四所度谓入世间辨所度生也。五辨知度生法之智。谓知法界法门之智。六所设法药。七应机差别说。八明机入法。谓非染识所识也。九既非染识境。云何令得知。十既得知已照除何法。又释此三问令所化如次得三慧益应知。十一总结佛境广遍何处。答中十偈内第八一偈答八九二句。余偈次第答余九问。初偈答境界。上半举所入法。此通二义。一齐者等也。谓齐等虚空即是真如为所缘境也。二齐者分齐也。谓齐法性真空已去是佛境。又上句深下句广也。下半明众生证入。言无所入者。以众生则是法身故无更入。如常在虚空。岂得更言入虚空也。二答因者一他分因唯佛能分别。二自分因说不尽。以多劫修故。又多故说不尽。等佛故唯佛能分别。唯佛能分别显深也。说不尽广也。自余者除佛以外余人说不能尽也。三答入者。上半明随缘。下半明不变。谓寂而常用故普入也。用而常寂故寂然也。和而不同故云不同世所见。正由能入故不同也。四答度者。谓入在世间作何等事。谓度众生。上半举度生。下半明度数。五答知度生法。之智。谓上半是能知。下半所知。六答法药。谓初句明法体。次句法用。下半明用不异体故唯佛知也。具分别有二。一以无异法界随机多说多故难知。若具分别唯佛知。二此多说则无异。无异则多说。此各不坏二门不碍即一。此难分折。若欲具分唯佛能知。七答知音说法智。上半所知。下半能知。谓虽了知众生言音而以说法。然常无作故无分别。八答识中二句。初句不可议故言语道断。非耳识等所识。下句不可思故心行处灭。非心思量也。又非染识亦非染心。如楞伽云取相名识不取相名智故。四依中不令依识也。九答决定知中二句。初句举法。谓自性清净如来藏法。下句示令决定知也。十答照中。上半照除烦恼障证寂灭涅槃。下半照除所知障得菩提平等行世间。又无明者无能照也。无所行者无所照也。平等行世间者绝能所而照故云平等行。行犹照也。十一答广中。上半所知广。下半能知广

第二结通普见。明此则是一切处文殊共一切处觉首等说法。前品光照令见众会。此中佛力令众见所说法事。谓因果也。文有三。初辨此界。二显东方。三类九方。初中三。先明佛加众。二明所见十事。三如是下结。十中前五因。一行所轨法。二依法成行。三行非出世。四依身等起行。五随根欲所乐而作行业。后五果中。一总。二依。三正报中持毁。四正中说法。五总结。又释。初一是智首所说六度行法。二是宝首所说业性义。三是进首所说懈怠难脱义。亦是法首多闻过等。四是财首所说随身随行教化义。五是德首所说佛法一味随根分多。亦是目首因一随缘多等。六七八是觉首所说心性随缘果报不同等。九十是贤首一乘文殊佛境可知。类余方中。是前光觉品所辨者是也

    净行品第七

释此品四门同上

一释名者。依梵本名圆净行品。无性摄论中名清净所行经。谓三业无过云清净。心起愿称行。行顺普法名圆。此持业释。又净是理。行是智。理智无碍为圆。依主释也。又愿是能净。行是所净。令行光洁。称性名圆。以是普贤愿行故也。又愿无垢名净。即愿是行故云净行

二来意者。前解次行。又前行次愿。义次第故来

三宗者以愿海为宗。但愿有四种。一誓愿谓行前要期等。二行愿此有二种。一与行俱起。二但对事发愿。则此是行以防心不散故。三行后愿谓以行回向愿得菩提等。四自体无碍愿谓大愿究竟同法性海。任运成辨一切诸事。此中唯论行愿。余者义通可知

四释文中二。先问后答。以对缘巧愿非智不熟故。智首问也。显事近而趣远微妙难知故。文殊答也

问中相从为十一分二。初七明自分因行。后四明他分果行。前中二。初三明三业成福智。后四明福智之果。前中九种三业分三。初三离过是创修故。谓离三毒。次三成三行是次修故。谓一自得不失。二他不能动。三能摄得他故令赞也。后三显三德是修终故。谓一福德。二断德。三智德。皆以后释前可知。二果中二。初明福果中十句。一依果胜。涅槃说。常生中国有佛法处。二种姓胜。地持论说。生于上族。三富而贵。是家胜。亦是如来家生。四身有善色。亦是诸根完具。五身有福相。亦是相好具足。六念定亦是胜。念亦是总持不忘。七慧观亦是报生智。于法能解。八意趣谓向理等。九威德胜。亦是自在胜。谓情无怯惧。依智论菩萨别有四种无畏。一总持无畏。于法记持不惧忘失。二知根无畏。知根授法不惧差失。三决疑无畏。随问能答不惧不堪。四答难无畏。有难皆通不惧屈滞。十常自开觉。亦是觉他。谓觉知生死。心生厌离。二明智果中九句。初二胜凡夫。次二胜二乘。五深故不可量。六功能广故不可数。七离分别故情不能思。八体实故不可称。九离言故不可说。第二因力成行中二。初一能成之力。二善知下所成诸行。前中八力。一因力者。如梁摄论云。多闻熏习与阿梨耶识中解性和合一切圣人以此为因。则是性习二种姓备故云具足。二现行勇意。是摄论中正思惟力也。谓思量是意义故。三巧便入法。亦是依思动身口而起行故云方便。四善友助成。是摄论善知识力也。五所观现前引起观智故。六机根已熟。堪为入法之器。又具信进等根。又是资粮善根当摄论福智二力也。七防心照理止观俱行。八止观熟已得深禅定。此上八种皆能成行灭惑得果之胜用。故同名力也。于初菩萨云何而得令彼具足。故为问也。第二成行者。谓依前诸力得成解行有三。初善解法相行有十法。一蕴。二界。三入。四缘起及三界三世。各善知差别而不可得等。二摄念入理。行亦十法。谓七觉三空照真理故。三广修十度行可知。第二问胜进果行中四。一内谓具十胜德故。二外谓十王敬护故。三悲德普覆故。四智德独超故。初中十力略作三门。一释名。二出体。三建立(别作)。三悲德中九句。一作善友覆荫。二救其现苦。三令其离怖。四为得乐之处。五炬除惑闇。六与大智明。七灯照现理。八引至方便道。九引至究竟处。又释九句相从为四。初二句化生除障。谓覆荫众生令外恶不干名舍。在苦能拔为救。次二句化物生善。谓始为物归终为趣向。次三句教生智慧。谓令解教法为炬。见理法为明。令知行法为灯。后二句导以起福。谓生福之始为导。成福之终为无上导。更别解如下第一回向经中自释。寻之具辨。四问智德独出中七句。初第一者位过世间。二大者德体无待。三胜者行用殊胜。四上者下不能及。五无上者上无能过。六无等者余无能等。七无等等者无等大圣自相等故云无等等也。又释第一有二义。一大二胜故云第一。谓化德过人名大。自德过人名胜。大有二义。一上二无上故云大。胜有二义。一无等二无等等故云胜

第二答中二。先叹问二通答。前中多饶益是授因行。多安隐是令得果。此二标也。慧利释初也。安乐释后也。又释初益成出世因果。后哀愍下令益人天因果。又佛地论第七云。令修善因名利益。令得乐果名安乐。又令离恶名利益。令其摄善名安乐。又拔其苦名利益。施与乐名安乐。此世他世世出世等应知亦尔。二通答中三。初标意答。二偈颂答。三结益相。初中二。先举意总标。谓成熟身口意是以愿净三业也。能得下明所得益相。二于佛下释成三业得妙功德。于中二。初明自分因行。于中三。初明意业胜德。二去来下明语业胜德。于中初总辨。二不舍众生者明法轮应机。三明达实相者法轮应理。四断恶者法轮离过。五具善者法轮具德满。三色像下明身业胜德。第二胜进果行中初具种智。二于法无碍。三辨定德。佛为第一。简异佛故云第二也

第二举颂正答中二。初标起后正答。答中有一百四十愿通答前诸问。何以尔者以一一愿中皆有六义故。能随事转本所习防净三业巧成菩萨二利行。体契普贤法具上诸益。是故通答彼诸问也。一转舍事。二转成法。三转他令离过。四转他令入法。五转显自过。六转成自行。且约初一愿作之。余一一皆准知。谓初愿转所居事家。是转舍事也。二愿成所证空法。是转成法也。如净名经云毕竟空寂舍。斯之谓也。三愿众生离家难。是转他令离过也。四入空法中。是转他令入法也。五自虽居家由此发愿。转自见家之心不作世间家解故。令过患不入自心。是自转离也。六既不见世家则见为法。悲念众生令入此空法。是自转成悲智行也。此六中前四当成以是要期誓愿故。后二现就以是则行愿故。所以有此六义者以凡一愿上必有三义。一所依事。二所为众生。三自智缘彼。此三皆有舍世事成法门之二故有六也。如此随事防心不随世法。常游法理不失正观。是其意也。又此下诸愿中随事逆顺差别相从略辨十势。一转事入理势。如初偈转事家入空理等。二转染成净势。如若得五欲是染功德具足是净等。三相似类转势。如布施转令悉舍一切心无著等。四转因成果势。如顶礼佛塔是行因得道无见顶是果等。五转世同出世势。如在房室等为世。贤圣地为出世。六转依同正势。如见城郭是依报也金刚身等是正报也。七转伪归真势。如见仙人等。以仙非真脱故。转向正真究竟解脱。八转人同法势。如见疾病人等。身空是法以知人病身则是真空法故何苦不脱。九转境成行势。如受着袈裟等。是境离三毒心欢喜是智断二行也。十转虚同实势。如若在伎乐为虚法乐为实。余偈皆各类知之耳。就此文中长分为十。初明菩萨在家时愿。二从以信舍家下明创出家时愿。三从受持净戒下明既出家已受禁戒时愿。四从若敷床座下明既具戒已修定慧行时愿。以出家人三学是其正所修故。五从下床安足下明既出定已于住处进止威仪时愿。六从手执锡杖下明为乞食利生故疾速进路时愿。七从见趣高路下明在路见闻诸事时愿。此中二。初见依报事。二从见严饰人下明见人物事。八从入里乞食下明行至聚落乞食时愿。九从若入水时下明食讫礼诵时愿。十从昏夜下明昼夜寝觉时愿。如是始终随事发愿无空过也。智论第十二云。智慧人有二。在家名婆罗门。谓七世清净。生满六岁皆受戒出家名沙门。此云息恶。问何故璎珞明入理愿此经多明对事愿耶。答此经顺一乘。在事益大。彼约三乘。在事不胜故入理辨也

    贤首菩萨品第八

释此品作四门

一释名者。依梵本名跋陀罗。此云贤。室利此云吉祥。或云德或云首或云胜。是故非是初首之首亦非上首之首。此等梵语皆有别名故。此但为显吉祥胜德超绝为首。当体至顺调柔曰贤。贤约体性首约德用。是持业释。于此信满入普贤位。具有二义。若约果则下文贤首佛刹等。此中约因故云菩萨也。或唯约人贤首则是菩萨故。又以此人是说法者从人为名故。或唯是法菩萨则是贤首故。所说亦是贤首菩萨法门故。或人法合目则依主释也

二来意者。收前行愿以成普贤广大德用故来也

三宗者明普贤行位体及相用广大无边始终俱括。应在信门该摄诸位成佛妙果。是此所明也

四释文者。此中二。先问后答

问中亦二。先经家序列。何故文殊问贤首答者。以信收万行非妙德无以发起。信该六位非贤德无以宣扬。又达深显慧净德彰福。二以颂正问中二。一结前二问后。此中亦二。先问甚深行。后问广大德。何故此中问答皆以偈颂者。释有二义。一以始德深广该彻穷终散说难周故以偈颂总摄。二显圆德胜妙故以美辞赞述。地论云。偈颂者以少字摄多义故。诸赞叹者多以偈颂故。是上二义也

就贤首答中总有三百六十三颂。前十三五言。后三百五十七言。于中总长分有八分　一叹深难说分　二略示行相分　三略辨胜能分　四摄诸行位分　五无方大用分　六喻况玄旨分　七校量劝发分　八显实证成分

就初中有七颂。于中分三。初二明德广说略可知。次四释略说所由。后一结已略相。就第二释中。初一辨德广所依。二明依心德胜。前中有四种难故虽是初心令此功德广大无边。一处难谓于生死苦恼之处而能发心。此为难故生德广也。二时难谓久已发心一向不动未足为难。今则反此。故生德多也。三境难谓能求此无限菩提。以心从境故广大也。四心难谓若发心进退不定生德不广。今则反此故广大也。一颂四句如次应知。此是起信论三种发心中当最初信成就发心。故云初也。同下文十住初发心住及发心功德品。此约信终彼就住初故无二也。既以信满入住方为信。何不住满入行为住耶。释云信不成位故不例也。二所起胜位中。初一举小犹无尽。后二显多则亡言。何得说之。而不略耳。三结说中少分者有三重。一多劫所修此难辨。故且论一念功德。二则此一念之中功德自如来穷劫说不尽。是故且论一时中所说功德三则此一时所说功德。犹自深广唯佛能说。菩萨不知。是故复于佛所说中分取小分菩萨所知而今说之。又此少分与彼广大通融有四句。一以此少分不异多故。摄少同多则此所说亦是不说说也。如鸟所履之空不异未行之处广大空也。是故性起品云。如鸟飞虚空经游百千年行处未行处皆悉不可量。若人百千劫演说如来行已说及未说皆悉不可量。二或摄多同少义亦圆备。如地论云。如实满足摄取故。三或二俱摄故亦说亦不说。四或二俱不摄故非说非不说。并准思之。问何故此中信位菩萨得有如此广大功德。答此是普贤法界行德。但就信门。于中显现故说不尽。若分别论总有四句。一或唯约信门当相阶降以辨。则此信但是善趣位如轻毛等。如璎珞本业及仁王等经说。此约三乘。二或唯约普贤当体德辨。如普贤行品说。三或俱。谓约彼信门显此普贤德。如此品所说。此约一乘因分说。四或俱非。总不可说。此约果分离言之处。是故圆教中所明信位与彼三乘中十信义别不同也

第二从非是无所因下六颂明略示行相分。于中二。先一总标因缘释成发心广大所以。此中因者谓如来种姓。缘者谓习所成性。又地持瑜伽因有四种。一种性具足。二佛菩萨善友摄。三起大悲心。四不怖大苦。缘亦四。一见佛神变等。二虽不见佛然得闻法。三虽不闻法见法欲灭。四见无佛法处众生造恶。又有四力。一自力。二他力。三因力。谓宿习大乘闻熏等。四方便力。谓闻法方能修善等。又四因四缘及自力因力发心决定。他力方便力发者不定。又起信论智印经有七因缘发心。谓三坚四退如彼应知。此上约三乘。若依此经有十种发菩提心因缘。如下文说。此约一乘。又以如来藏内熏为因所余为缘。二释所发心相。此中通论有十义。俱是心心广大功德因缘之义故云非是无所因等也。十义心者。一初二句明正直趣理心。论云直心者正念真如法故。二次一颂明深信三宝心。三有一颂远离四过心。四句各一可知。四一颂大愿度生心。五二句明大慈大悲心。谓拔苦与乐故也。六一句严净佛刹心。七一句广供诸佛心。八一句建立正法心。九一句正求胜果心。十净修果因心。此上十心并所缘境无限量故令心摄亦无限也。故下文云。菩萨不为供一佛故发心。不为供百千世界尘数诸佛故发心。悉欲供养一切佛故是故无限也。如供佛信三宝离过失度生严土。悉皆无限故广大也。略示行相分竟

第三深心净信不可坏下有九颂。明略示胜能分。于中初二明信能成发心。以是行本故。后七明信能成余德。以行所成故。前中初一约三宝境。成不坏信方能发心。二约三佛性境。初句约信自性住佛性。次句引出佛性。次句至得果佛性。又释初句信佛及教法。次句信僧及行法。次句正向信果。下因此深信成就方能发心。又此中信不可坏者信满心得不退故云不坏。依此信发心。故知此心已入住。然约能入方便故属信终。下明成德中非直成前入十住初发心之位。亦更通成已后位中所有行位。是故此中略辨所成二十功德。一能生福智。谓觉道之元福德之母。二能断疑示道。三能离垢心坚。谓除慢释离垢敬本释心坚。上三各二句如次应知。四信体具德故如宝藏。五纳法成行故如净手。六能舍染离着。七能解深玄。上四各一句应知。八转进成果。两句可知。九能令善根明利。十力用无坏。十一能灭恶业。十二能得大果。十三入法无碍。十四离八难报障。十五能越魔境。十六巧示脱因。十七为大果坚因。谓佛地一切诸功德法莫不皆以不坏之信为彼因种。十八生觉树果。十九长种智门。二十示妙觉果。上初八自分行。后十二为胜进德。此等功德并是已后诸位乃至佛地所成之德。俱在信中之所成就也。下一颂结叹显胜。是故者是前信能成彼二十胜功德故。所说次第所修行中。是故信乐最胜难得也。后半喻况。一信体希有喻。二能出众德喻

第四若信恭敬下有五十颂。明能广摄行位分中二。先摄行。后若生无上菩提心下明摄位。前中先明信敬三宝行。后明信顺三宝行。前中初有三颂明信佛成二行。初二成持戒行。后一成供养行。二有一颂信法成二行。谓闻教无厌行。欣证难思行。三有一颂信僧成二行。谓信体无坏及信力无动。下明信顺三宝行中。初二颂顺僧成二行。谓利根舍恶友及近善友修胜行。次一顺法成二行。谓解因果行法。成解脱果法。后一颂顺佛亦二行。谓顺果佛护。起因发心。上来摄行为入十住之方便竟

第二摄位中摄后四位则为四段。初有二颂半明摄十住位。谓菩提心则是入初住位。勤修佛德是治地修行二住行也。生佛家是生贵住。谓生在佛家种姓尊贵故也。无著是五六二住行也。深心妙净是七八二住行也。殊胜无上心是九十二住行也。皆准释可知。二若得无上下三颂明摄十行位。于中波罗蜜总举十行。摩诃衍是异小乘行法。供是顺理行谓是初四行也。念佛定是离痴乱行。见佛常住是后五行。以后五俱是般若摄故。三若知如来下二颂半明摄十回向位。于中行成称理故法永存。谓是如相及法界等。辨说度生。是救众生离众生相等。前七回向亦是诸门回向众生义也。大悲者是此位中所成大悲行。对治独觉舍大悲障故也。四若得大悲下有三十三颂明摄十地位。于中初半颂摄初地。谓喜乐深法是初极喜地。所证遍满真如名深法也。二半颂离有为过是离垢地。以离犯戒有为之过失故。三有一颂明第三地。以得禅离慢故不味着故能兼利众生也。四有一颂明第四地。以得道品智故处生死而无忧也。十度行中此当进行故云精进无上也。五有一颂明第五地。以此地成禅度依禅起通也又能善解世间五明处等故云解众生行。六有一颂明第六地。以此地得悲智不住般若大智现前故也。此中成就众生是悲成生智是智也。七有二颂明第七地。初一是有中殊胜行故四摄摄生。后一是空中方便智相导故令住无上道也。八有三颂明第八地。初一超四魔。谓舍分段故无阴魔。无舍命故离死魔。惑永不现行故无烦恼魔。是故天魔亦不得便也。此第八地成就超四魔之因云道也。次一得位及忍。彼释名分及净忍分。后一授记位如善慧仙人于第八地得授记等。现佛前在彼四种一向佛土中故。九有一颂半明第九地。谓彼菩萨作大法师故解佛密教顺教说法令佛护念。佛德自严为他说法。十有二十一颂半明第十地。于中有三。初十三颂半明殊胜三业。于中先有五颂半明身业胜。此中三颂正报胜。二颂半依报胜。次有四颂明语业胜。此中初二解深巧辩。次二明智身说法。后四颂明意业胜。一他心智。二断惑智。三证实智。四十地十自在等结位也。命自在等十种成就此位故。二若十地种下有四颂明十地终心受位分。此甘露水灌顶等明此信满中受职。三若身下四颂明结叹显胜。初一明入理深广天人莫知。谓此法身满空十方不动。是故于此无等界诸天世人莫能知也。次一行成果满见闻广益。于本所行无不果者。所求毕故无不果遂也。又如下明法品云。见闻供养者皆住不退地故云不空也。次一颂半威力护法常益不断。如维摩经云此经住世皆弥勒威神力也。又初体。次德。后用。下半颂结。上句结慧。下句结福。俱无尽如海。又此信门中展转钩锁该摄如此。十地等者以信为道元功德母诸位行相皆信而成。故上总云信能转胜成众行究竟毕至如来处。斯之谓也。又云在于一地普摄一切诸地功德。是此一乘圆教法也。三乘中则不得如此

第五从或有刹土下有二百颂半明无方大用分。以信满成此贤首位故。同普贤等广大三业该因及果遍一切处尽一切时常作无边法界大用。此为恒式。当相而论不依诸位。今约信门之中显现则属信摄。然大用无涯难以具述。依例辨十以显无尽。则是十三昧门之业用也。一圆明海印三昧门。二华严妙行三昧门。三因陀罗网三昧门。四手出广供三昧门。五现诸法门三昧门。六四摄摄生三昧门。七穷同世间三昧门。八毛光觉照三昧门。九主伴严丽三昧门。十寂用无涯三昧门。以业用差别所主各异。功能纯杂依门不同故以三昧门而辨差别。如水一切处定等。又以创辨大用之本故

初显海印后明用不异体。故末后辨寂用无碍

就初文中有五颂半分二。初明业用后显所依。前中五。初一偈明现佛说法。次二一偈显无功成事。谓不作功用故云断希望也。又释以因位满故更无希求故云断。次三一偈明现八相。次四一偈明现三乘。次五一偈现杂类。后二句结用所依。海印者从喻为名。如修罗四兵列在空中于大海内印现其像。菩萨定心犹如大海。应机现异如彼兵像故。大集经第十四云。喻如阎浮提一切众生身及余外色。如是等色海中皆有印像以是故名大海印。菩萨亦复如是。得大海印三昧已能分别见一切众生心行。于一切法门皆得慧明。是为菩萨得海印三昧见一切众生心行所趣。解云。此中见字亦现字。谓由见故现也。通二应知。问此中既是十信菩萨现成佛者为是暂时化现。为实成耶。答若三乘初教中总无化现成佛。以未得不退故。若终教十信满心胜进分上入十住初。则得不退故能暂时化现成佛。如起信论说。若一乘圆教中实则不依位。寄终教位相以辨之。于信满不退之际则明得彼普贤法界行德具摄因果圆融无碍。若以因门取则常是菩萨。若果门取则恒是佛。由此镕融有其四句。或唯是菩萨。或唯是佛。或俱不俱等思准之。问此中果门成佛与终教化现何别。答彼但于一位依一世界化现一佛。此中具十地等摄一切位也。十方世界者一切处也。念念中者一切时也。问此中既言示现只应暂现同上终教。答如文无悕望之功用能一念顷游十方。若斯之德自非因位穷满孰能具此。故知定是实行满也。不同彼是劣位人也。又一切诸佛于诸世界为物成道皆是示现。以废机约自无成不成等故也。又大集经第十四云。得灌顶正位于一切诸菩萨行得次佛神力。若菩萨成就如是等法者能于无佛世界示现八相成佛。乃至广说

第二华严三昧于中二颂半分二。初辨业用。于中有七行。一严土行。二供佛行。三光明行。四教化行。五智慧行。六说法行。七十度行。后二句结行所依三昧。以行门无碍称一切自在。华严是行法故结属之。如第七会入华严三昧说二千行法等

第三因陀罗网三昧于中有四颂分三。初二句标定门。谓将现因陀罗网土故。先入因陀罗定也。二明其业用。于中二。先明一尘内现。后类一切尘。三后二句结所依定。虽法界缘起理数常尔然由菩萨不乱智力而得显现故云自在力也。亦名解脱者是不思议解脱以离诸碍故。如下文不思议品末说有十种。谓一尘中现三世佛事等。又可上句是定力解脱是智力。以不乱是定作用无碍是解脱故也

第四手出广供三昧。于中有十七颂分三。初三句标定门。二辨业用中二。初手内出供。二无量清净下明手光严供。以是法界手故求差别性了不可得。然出供具不可穷尽。三后一偈结所依定。涅槃中名佛为大仙也

第五现诸法门三昧。于中八颂分四。初一标门及意。二明业用有二十二门。摄众生通入故云门也。三有二句结无尽。四一偈结所依定

第六四摄摄生三昧。于中十六颂一句分三。初一颂标定门及意。二明业用。三末后一句结无尽。就业用中四。初二颂明布施摄。二以诸相好下四颂辨爱语摄。于中初示爱色令脱。二柔软下妙音说法。此八种梵音义略作三门。初种类。二名体。三业用。初中检诸圣教有四种类。一约教义辨。如十住经说。如来有八种音声。一谓见苦。二谓向苦。三谓见习。四谓向习。五谓见尽。六谓向尽。七谓见道。八谓向道。此八以音从所说辨。以约佛音用故也。二约佛音体。亦如十住经谓。梵音有八种。一不男音。二不女音。三不强音。四不软音。五不清音。六不浊音。七不雄音。八不雌音。三约佛音德亦八种。如梵摩喻经说。一最好声其声清雅如迦陵等。二易了声言辞辨了。三调和声大小得中。四柔软声言无粗犷等。五不误声言无错失。六不女声其声雄朗。七尊慧声言无惮怯如尊重人如胜慧人言无所畏。八深远声齐轮发声犹如雷震。此上三类是佛圆音体德用分三耳。四约通融有六十四种梵音声。此有二释。一别数六十四种如密迹力士经中具显。二诸德于前三类之中。以初八入后八内。一一具八。是故八八成六十四也。二名体。先名者具足五义方名梵音。如阇尼沙经说。其有音声五种清净乃名梵声。何等为五。一者其音正直。二者其音和雅。三者其音清彻。四者其音深满。五者周遍远闻。具此五义乃名梵音。又梵者圆洁之谓又如梵天普应等故名也。声者是执受声。音者明彼有诠表之韵是故名也。二体者小乘唯是色蕴摄。是不可见有对色。十二处中声处摄。十八界中声界收。初教声处等则空为性。又是十一识中言说识为体。终教此声用佛净识为性。然此净识复不异真如故则以真如为彼自性。顿教梵音称同本性则不可说也。圆教以彼无尽法界无碍为性。是故通摄一切。圆融自在如下性起品如来音声处说。三明业用者有二。初约益生。小乘唯益当会等众。三乘乃益显密等众。一乘益于无尽显密。谓重重无尽也。二约分量。小乘唯同人类言音。三乘佛音遍一切界。如目连寻不知等。一乘遍因陀罗网法界处重重无尽无尽也。三众生苦乐下明同事摄。于中初同其事。二若有不识下明示法。十行是十度也。四或有众生下四颂显利行摄。于中初示生死过令舍。二如来十力下显佛德令求。三如是方便无有量一句结无尽也

第七穷同世间三昧。于中有十七颂一句分二。初三句标意。二博综下正辨大用。于中二。先明身业用。二若见世间无正见下明语业用。初中有五。一作王臣等益。二或于旷野下作非情益。三若见世界下作悲匠益。四咒术下作仙人益。五作外道益生皆令解脱。二语业用中三。初一偈总举。二别显。三知一切下二句结所依定。一心说法名三昧也

第八毛光觉照三昧。于中有八十九颂分四。初一标门及意。二所放光下正辨业用。三是名下结所依本。四所修行业下重释成分齐。第二业用中有二。初明一毛光用。二如一毛下类显多毛。前一毛中复二。初略辨四十三门。二如是等比下广结恒沙。谓此菩萨身同法界穷尽九世遍该尘道。常有如此光明大用无休息时。是故此光常定恒有恒无。于净眼者无时不见故恒有。无净眼者无时暂见故恒无。法光常定。废兴在缘故也。前中四十三门内一一皆有三义。一出光名。二显光益。三出光因。初光中因内或以言说显三宝。或约事如开佛门现塔形等。第二中灯明离染闇故得净光。或灯照现净境。三四二因内各二。一事因。二法因。第五欢喜光因内。一庄饰佛像令见者喜。二赞佛德令闻者喜故也。第六因中。一自乐三宝。二教他乐。寂静光因内离十种非法语者。以恶语恼人令他心不安静故是障也。依燃灯经十种非法语。一妄语。二痛心语。三粗语。四苦恶语。五不喜语。六不乐语。七不爱语。八不入心语。九恼他语。十结怨语。又见佛光中依西国法。有欲舍命者令面向西卧。于前安一立佛像。像亦面向西。以一旛头挂像手指。令病人手捉旛脚。口称佛名。作随佛往生净土之意。兼与烧香。鸣磬助称佛名。若能作此安处非直亡者得生佛前。此人亦当得见佛光也。又乐法光因中有七。一听。二说。三书。四爱。五护。六施。七行故也。此中护法者通论有四义。一护理法不滞见故。二护行法令增长故。三护教法说不倦故。四护果法。谓敌对恶王等护住持三宝故。于此四处皆不惜身命而存护也。第二广结中。业者是光往因也。果是现光也。二俱同现者过去因行以依十世门故亦在此现也。第三结所依中不乱故明了故结定智二门也。第四重释中。何须重释者以上云彼光觉悟一切众生何故乃有众生而不见耶。释中三。初二偈法说。于中有七种众生。得遇此光。以有缘故。一同业。二随喜。三闻修。四见行。五修多德。六供多佛。七求大果。二有三偈半喻说。于中初二偈明机眼开闭喻。二有一偈半明机业善恶喻。三有一偈明闻法胜益

第九主伴严丽三昧。于中有六颂分二。初一偈标名及意。二三千下正显业用。于中五偈。初一偈化现身座则主也。次一摄眷属。次一释眷属胜。次一显主胜。次一结通十方无边法界身也

第十寂用无涯三昧。于中有三十五颂分三。初一偈标意。于中往返约方出入约定。二或东方下正显业用。三是名下结无尽。第二业用中二。初约位总明自在。二一切鬼神入正受下明微细差别自在。前中三。初明器世间自在。二东方世界下于智正觉世间自在。三于眼根中下于众生世间自在。凡论菩萨三世间自在有二义。一菩萨身作三世间故得无碍。二菩萨于三世间处示现自在。今此文中初二世间约后义说。众生世间约前义说。文中互举。理实遍通具此二义也。就初二世间自在中。何以得成东入西出等者。通论文中有四重无碍。一处无碍。谓以东方则西故。是故不移东而常在西也。问文中不言不移而至。何必不是东没西出耶。答文中既言常见在东亦常见在西。故知非移动也。二佛无碍。谓以东佛则是西佛故。常在东佛前则是恒在西佛边也。三身无碍。谓在东之身即是在西身故。是故不动东身常现西也。问岂是不分身一身在东一身在西耶。答若多身在多处何成奇特。何得名为不思议用也。是故当知定不分身。四入出无碍。谓以入定则是出故。是故不坏入定常见出也。问何必不是先入后出耶。答既言常见入亦常见出故知是则也。理实义中具斯四重。然此文意为但显彼菩萨功力故。初之二种非此所辨。以初二则菩萨无力故。问此刹那入定何因则是出耶。答如幻巾作兔此兔则生是死。何以故。以有则是无故。入出等亦尔准思之。又此菩萨以法界为身故。是故纵于东方百千界外见。法界时以法界非是分限法故随显现处无不全现。故菩萨身常在入定中现恒在出定中现。无碍圆融难思议也。是故若向出定门中看唯见出不见入。亦不见出竟时也。余义准之。又若约境论理数法尔如此圆融。若约智说由菩萨智了达此法回动自在。今此文中具通二也。就众生世间自在中二。初约自身。后约他身。自中约十二处辨。于中缘起无碍定等圆融。一一皆有十事五对无碍之相。第一对根境无碍。既观根入定还应从根出。为显此根则是境故从境出也。以一心缘起无二而二故。恒相则而根境两分。第二对二定无碍。谓理事二定也。为分别境事应入境定。反入根中为观根空寂应入根定。反入境中以分别境事智即是观根无生智。是故二定无碍唯是一心。第三对二境无碍。谓深广也。此所分别广事即是无生无性深理故。是故真俗双融唯一法界。但以不碍二义故。寄俗于境寄真于根。理实遍通。第四对入出无碍。谓以入定则出故。是虽起定而念不乱也。第五对体用无碍。谓自他也。谓虽现于境广故。人不能知。恒寂故。虽起于定深故。自心恒不散。是故此上十义同为一聚。法界缘起无碍相则故也。又此中复有三重希有。谓根入境出已为一希有。复能境中更示无边分别。非天人所知。为二希有。从境出已示此分别已甚希有。复于彼时定心不散更复希有。何以如此者欲显三昧纯熟故也。文处可知。二童子身下于他身无碍。此有二义。一菩萨化现彼身转变速疾。二菩萨既具三世间身。则以一切众生实报之身作自身故。是故现彼身入此身出也。而彼遍计众生不觉不知。除应度者。此明定用自在可知。第二微细差别自在中。亦三世间皆分折显示。于中毛孔毛端是众生世间之差别。佛光明为智正觉之差别。微尘等余并器世间之差别。悉是菩萨身现于彼等中出入定也。非是观彼入定等。以文中皆言现故。现者现身于彼中也。第三结者有二意。一近别结此第十定。二远通结前十门。是略。约实则无尽

第六喻说玄旨分。亦名举劣显胜分。以上来所明正显一乘普贤行德穷乎佛境。然位次之言盖是外凡十信之位。既越三乘反于视听。滞情对教取信无由。是故举斯近事以镜玄趣令开悟耳。于中有七十七颂分二。初一偈总标。于中众生业等者。下文诸天修罗等是正报。海风等为依报。次一句是下诸龙兴雨等。下句是声闻三昧及梵天等。并于世间有少不测。故云难思。所以为喻况。二别辨中有十八大喻。一声闻现通喻。喻菩萨自在饶益众生力。于中三。初标意。谓理实声闻之通比于菩萨。如牛迹之与大海萤烛之与日光故云无可为喻也。但以今举萤德尚尔。矧乎羲阳。令聪慧者翻对悬解彼云聪慧者能解是义也。次得八下举近喻。后现作下显远趣。二水现四兵喻。喻菩萨海印三昧德。三海天妙音喻。喻菩萨总持巧说令众喜德。四女授辨才喻。喻菩萨方便智授法令喜德。五幻师化术喻。喻菩萨不思议解脱力转变悦机德。六修罗入丝喻。喻菩萨自在无碍通。七象王随变喻。喻菩萨定用隐显自在德。八修罗大身喻。喻菩萨现法界等身德。谓如上文三千大千世界中化一莲华满世界等知之。九帝释破怨喻。喻菩萨降破众魔德。十空声说法喻。喻菩萨无功用心说法利生德。十一空声安慰喻。喻菩萨慈音除恼德。十二天王普应喻。喻菩萨圆回之身应机无碍德。十三魔王自在喻。喻菩萨十力摄生令同行德。十四梵身殊现喻。喻菩萨以解脱力遍坐道场说一切法德。十五摩醯数渧喻。喻菩萨一念了知一切众生心德。十六风轮持散喻。喻菩萨大愿宿成无心无碍而辨说应机德。十七大海包含喻。喻菩萨蕴积众德印现群机德。十八龙王遍降喻。喻菩萨穷尽法界普雨法雨德

第七校量劝发分。于中有十颂半分四。初一偈喻况难。二一偈明说者难。三有三偈半显信行者难。四若三千下五偈举易显难。各是一事向后渐难可知

第八显实证成分中有三偈。一辨益有三。一动地。二降魔。三灭苦。二诸佛摩顶。三述赞随喜

第二会竟

华严经探玄记卷第四华严经探玄记卷第五(是第三会尽)

        魏国西寺沙门法藏述

    佛升须弥顶品第九

将释此文。四门同上

一释名有二。初会名者。约法名十住会。约处名忉利天会。准释可知。二品名者。佛是化主动静无碍不去而进故云升。升至何处。谓须弥顶须弥此云妙高山。谓以四宝所成故云妙。谓东面黄金西白银南颇梨北马瑙。余山唯金故非妙。独出九山故云高。高八万四千由旬。纵广正等。亦名安明山。顶者山巅也。谓此山顶中央有帝释宫。四面各有八埵如台。去释三由旬中别有宫城。三十二天辅弼帝释。并释有三十三也。今趣释宫故云顶也。约处表法明十住成位不退胜故居山顶也。即从人用及处三义立名。问何不在人间说耶。答为显行位渐升进故。又表成位离染故居天也。问何不至四天王天。答有三意。一以彼是杂鬼神天显法非胜故超过也。二为寄法以十信是外凡退位十住是内凡不退。欲表进退悬殊故越四天王处也。三若未至山顶容有进退。到山顶上即安住不退。是故越彼山腹处天至此顶处以表法也

二来意亦二。初会来者一答前十住问故。二前已明信。今显依信起解故次来也。三前信但是位前方便。方便既满。正位显彰故次来也。二品来者前品辨信究竟。今将赴后位故来也

三宗趣亦二。初会宗亦二。先约人谓化主及助化各有体相用。约住准之。二约法谓十住教义义中以平等法界为体。十住行位为相。应教所诠为用。教中以六决定为体。十住不同为相。益机为用。相即无碍准上思之。二品宗者以严处请佛如来赴感为宗

四释文者就此会中有六品分二　初二明方便发起即序分　余四品是当会正宗

前中二初品是如来应感序明果德备。后品明集众光赞序明因德圆。即显十住位中具因果宗圆备故也。前中三。初辨化缘。二尔时帝释下严根欲。三尔时世尊下明根缘契合。初中二。先体融遍周法界。后明用融。谓不动而进。前中初一句明体融所由谓佛力也。下明融遍之相。于中十方各一一阎浮等者。是上光明觉品所辨。十方各乃至不可说不可说虚空法界等世界中皆有菩提树下卢舍那佛。各与海会菩萨众并与文殊师利乃至贤首等悉各说法。以诸会众各不杂故云自谓在也。今并同时集众各升本界天上而不离本处也。若约小乘三乘等中说经施化。但论在某处等。无此一说一切说等。今欲明一乘法。即主伴圆明故法如此也。于中一三世间融。二依正二融。三于正报中有三宝相融谓说种种为法宝。菩萨为僧。对如来故。四于诸菩萨有三业融。谓显现是身。说法为语。自谓为意。问何须集此者。答欲明具主伴。凡一法起必具一切故。问何故皆以菩提树为本。答以是得法初处故。又是觉门故

第二用融中初一句用融所由。次不起等正明用相。此中不起此而升彼者。古人三释。一云本释迦身不起道树别起应化以升天上。若依此释升天之身是重化身。既非深妙。恐乖文意。一云不起是法身。升天是化用。此恐非理。岂可法身坐道树耶。一云此升天是不往而至。以往即不往故。所以不起也。不往即往故。所以升天也。如不来相而来名善来等。若依此释但是无升相而升天。非是树下有不起之身故亦难用。今解此文略有八义。一约处即入门。谓以一处中有一切处故。是故此天宫等即本来在彼树王下中。故云不起也。然先未用此天宫处。今欲于中说法用故说为升也。又相即故不起也。门别故有升也。二约佛谓此坐树王下之佛身即遍法界一切处故。是故佛身本来在彼忉利等处故不待起也。今欲用此忉利门中之佛故曰升也。是故若起即不成升也。三约时谓由此树下座上佛身即遍前后际等九世十世一切时故。是故此佛坐树下时升天。去时到天处时。一一时皆遍法界摄前后际尽。即知坐树下时永无起时法云不起也。若正去时亦如此。故唯有去无余也。皆念念不相至。各各收法界。如是缘起门无碍恒不杂。四约法界门谓此升去无自性故即摄真如法界。以彼树下坐等亦不异真故。同真如在去门显显故。不起而升也。五约缘起门谓坐由行故坐。坐在于行中。行由坐故行。行在于坐中。是故由行中坐故升天即不起也。由坐中行故不起而升天也。行坐无碍故即升常坐。即坐恒升故也。六约佛不思议德谓即不起此坐即是行即是卧即是住。即是到一切处。即是作一切事。并非下地所知。七约所表谓表前位行成究竟坚固不坏故云不起前座。而有赴机用故云升也。八约成会谓后会必具前故不舍前而成后。若舍则坏缘起。是故不起前而升后也

第二严根欲中遥见佛来者。约佛用从体起。约机境从心现故也。于中二。先严座表相。于中先总后别。别中初外报后内报。二合掌下辨欲第三根缘契合中亦二。先升殿益。后升座益。前中二。先赴感。二成益。此二各二。谓此界及结通益中二。初寂然等示得定益。后偈赞发慧益。于中二。初忆本行。二颂德。颂中理实过去一切诸佛体同用融。法尔无二。皆于此殿说十住法。而今却次但说十佛者为显无尽故。为说十住故。迦叶是姓此云饮光。拘那含牟尼此云金仙人。拘楼孙此云所应断已断。谓生死烦恼等也。随叶亦名毗舍符。此云一切胜。亦云遍现。谓诸处皆身现故。尸弃此云有髻。毗婆尸此云种种见。新名净观。弗沙此云增盛。以无阙减故。亦是星名。提舍此云说。谓常说法也。亦名光也。波头摩此云赤莲华。锭光是燃灯佛。此佛为太子初生时一切身边如燃灯。故名燃灯太子。太子成佛亦立此名。问此中后七佛是过去庄严却中佛。何因得于此贤劫中忉利天宫而说法耶。答此天宫等有粗有细。粗者前劫烧灭。细者常存故也。如经天人见劫尽我此土常安稳等。又三乘所说者灭。一乘所辨者常存故。第二升座益中二。初此土后结通。前中二。初升座后辨益。谓广其殿者改常所见故破情也。同天处者显同理故也。前升殿益人。此升座益处者。为显依正俱胜故也

    菩萨云集品第十

四门同上

释名者。菩萨是体。云是相。以诸菩萨含法雨故。相龂齶故。集是用。殿是集处。妙胜有三义。一佛众为妙胜。妙胜者之殿。二于中说此妙胜法故。三殿即妙胜。以称性故。说偈是语业谓法界。菩萨如云而集。各以妙辩宣扬佛德。故云菩萨云集说偈品也

二来意者。前明如来升天将欲说法。必有所被机缘故次来也。又前明果德临机。今因力助化。先主后伴义次第故

三宗者谓集众放光。偈叹为宗。众有三类。一助化众。谓十方菩萨影向如来。二表法众。谓诸首诸慧诸林诸幢等各为寄人表示法也。三当机众。谓教所被等。此文通兹三也

四释文中三。初集众。二放光。三说偈

初中二。先此土后结通。前中二。初显所从来处。二佛神力下明菩萨集来。前中二。初明分量者。前十此百显行位渐增故也。此中意者取百佛世界抹为微尘。如是东方过尔许尘数刹外有一世界。名因陀罗。从此间东复过如上百尘刹外有土。名莲华。如是向东十重世界。各各相过百尘界外所以说十重者。以显无尽故。如东方十界余九方亦尔。世界佛名菩萨等皆同故。云一一方各十界等。并同列名也。此唯据斯一天宫会。余十方界皆各如此。为法界无边会耳。谓一会一切会等。如结通处辨。二正显本处三世间名。其世界名杂者表所解法相非一故。佛同名月者此是住中果相有其三义。一约体是圆满义。二约用是光照义。三约德是清凉义。又初是正体。次是后得。后是大悲。用月表况。菩萨同名慧者是住中因相。谓解达真俗明了义故。各于本佛修梵行者显因依果成故。相顺故。二正集来中二。初至此致敬。二敬已安坐。皆云佛力者是来坐所由。果力加成也。充满十方者是缘起无碍义

第二放光序中六。一放光人。二光出处。谓如足指按地乃得住立。表此十住成位不退故名住也。三光数。四光相。谓解相炳着故云妙色。亦是名也。五光照处。谓是上光觉品所辨。又是诸文结通之处。前品佛力显现菩提树下诸身。今光照树下及天上。六如来大众等明照所显现通同为一法界圆明之会故也。又云树下须弥顶知之

第三偈赞中。十菩萨即为十段。初一总后九别。以是说法主故名法慧。是故总叙此会本末以显佛德。后皆于此总说上叹差别德。是故总别无碍。唯一如来法界身。于中或即理即事。即教即义。即因即果。即人即法。即心即境。圆融自在举体全摄。此等即是十住中法。下诸偈应准知此意

初偈中分二。先叙此会事。后三释疑。前中初二叙升天品事。次三叙此处集相。次二叙结通事。于中先明所由。后显其相。二释伏疑。疑云。佛果自在可得一身赴一切会无有障碍思议不逮。菩萨因人既局不足。何因亦得如此普遍。释中三。初偈初发心深。二修行深。三成德深故。得同佛遍也

二一切慧者以解一切法离相故。十偈分五。初三明佛非妄取所见。一明小菩萨取相见佛不睹真法。二明凡夫妄染总不见佛。三明二乘虽观法执不亡着假名法也。次三既妄取不见。谁能见耶。谓离妄正解佛常现前。于中一见真佛。二泯能所。以无所取无能见故。三显观益。三一偈明妄取何失而不见耶。谓痴冥故。四二偈真佛何德而超妄耶。谓法界净等故。于中初偈约佛明修生功德不生灭义。谓初二句明相好功德离三世生灭。即立宗也。下二句举二因释成。一云以此功德住于无住之本故同无住也。又显即无自性故云无住。是故即不生灭而不无功德。一言若无明未尽。障隔真如令修生德未全同真故有生灭。今即返此。始觉同本故云悉净。故不生灭也。后偈约法。以见缘起法即是佛故。以因缘生即是不生故。见理佛。与第四偈不生灭见佛同。五后一偈推功在本

三胜慧者以净慧胜眼解佛深智深智为胜也。十偈分五。初三举妄情失。一迷或佛深智。二妄取障佛相。三迷阴障法身。次二辨慧解益。于中初偈中。若约三乘观法不实即见理佛。一乘即见舍那法界身通理事。后明阴转无我是佛。次三喻显前失。于中初虽因阙缘失。二虽缘因杂失谓杂无明故心不净也。亦是无信心也。三虽缘阙因失。次一喻显前益。后一推功在本

四功德慧者以福庄慧故。十偈分四。初四辨迷失。一取相。二见取。三无明。四无法眼。又释上二起妄后二迷法。前中一执虚为实。二取劣为胜后二中一迷自心。二迷真空。次四辨解德。一求法眼。二心无著。三有净眼。四离能所见。上二句无见即见。下二句见即无见。次一叹佛顺法摄生。后一推功

五进慧者以离妄想放逸故。十偈分二。初一明痴妄之失。后九明慧悟之得。于中初一双了真伪。谓了妄伪不实真理是实。次二舍伪归真。谓初约所执无相观。后约依他无生。次三明真伪双融。则圆成无性。一俱真。二俱泯。三释不俱所以。后三伪尽真圆。一不可议。二不可思。三观益

六善慧者知佛离害心故。善说明净道故。十偈分四。初三偈举佛实德。一二利圆妙。二积德方见。三同理超情。二四偈辨佛所说法。一显法无说。二明无说之说说无尽也。又亦前偈明无说故尽言。此偈明尽言亦离。故云无尽。三释前见大名称。初偈明无见见中。众生是见者。此亦无也。后偈明见无见中。不坏者。一见不待破故。二见不坏之理故。三见体即真故。三一偈半结前知佛及说益相。四一偈半推功

七智慧者闻教生慧故。十偈分四。初一辨自顺教生慧故立其名。次六明众生违理损。于中初二横计人法故不见佛。初人后法。谓不观身实相故。后四约位明不见佛。初二约凡位。一就情过。二就正理。谓生死涅槃相待故俱不可得。又是二乘涅槃故。又染分是生死。净分是涅槃。双融故俱不可得。后二约二乘。一约迷教。二取相。如庵提遮呵舍利弗云我在静室中尊常目前现。仁称阿罗汉常随而不见。次一劝令顺理成益。次二举法释成。谓何以执有不见佛耶。释云。法实是无以佛智求不可得故。又云以明了三世一切法空故名如来。是故当知。若取相等不见佛也

八真慧者见法身真理故。又慧同理名真慧。十偈分二。初二叹佛名德。一标二释。后八明佛义德。于中二。初三会佛所知二谛境成法身观。一标谓以伪无和合故俗等真。二释约三时求合相不得。三成观益。次五会佛境智成绝能所行。于中四。一举境智。二泯能所。谓境智一亦不可。二亦不可。证如反望。无如外智故无觉。亦无智外法可取故无所觉。是佛所修故无一无二也。此有三义。一约境真俗非一二。二约智虚照非一二。三约境智非一二。准释可知。三释无一二。以境智无合故。又上半标宗。下释以一法无自所依故为众也。为一亦尔。两俱无性。何有缘合。又藏性依缘一为众也。诸法依藏众为一也。互无自性各无所依。无所依故云何有缘合。以体用俱泯故云作者及所作俱无也。四若能下明观成益。二句标四句释。谓此不可得处是佛所依。此中绝能所故云无依无觉也

九无上慧者慧离上相故。十偈分三。初一释已名。次八显佛德。于中初六辨佛内证德。谓一境离粗妙修生德是粗。由空故不作也。真理是细本有不悕望也。二离数无数。此二约境。三离照无照。此约智。四一偈半离依无依。五一偈半离一二相。此上约境智俱融。后二显佛外化德。一教令住法无所住也。二得见真身无所见也。后一推功

十坚固慧者知佛恩不可坏故。十偈分三。初六举佛恩深。次三庆已逢遇。后一结叹无尽。前中初一句标恩。余释显恩相。一为物出现。二见物深苦。三明救苦唯佛。四与乐亦佛。五佛众亦能。六见闻获益。二庆遇中三。一庆已益。二众同益。三重庆见智益。亦是结已所说。后一是总结上九人说

    十住品第十一

初释名者。菩萨是人。十住是法。谓得位不退故云住。住法应圆依则说十。即带数释。又此住法是菩萨所有。是有财释。又菩萨之住。依主释。又菩萨即住。持业释。问前外凡贤首品唯约人名。后十地圣位唯约法名。于此内凡三贤之中人法合目者何耶。答前位未成故就人法目。三贤位劣人法合称。圣位显著故唯约法名。此亦是施设渐增之相。问等是人法合目。何故十行十回向提别人名。此中举通名耶。答于贤位中有三。谓下中上。此当下品。劣故举通名。十行是中贤次故。虽提别名然约义少改名华聚等也。回向是上贤胜故。称本别提名金刚幢回向也

二来意者序义既彰。正宗宜显故次来也

三宗趣者十住法为宗。依此得果为趣。余义如本分中说

四释文者。就正宗中有四品分二　初三品是当位行德。后一品是胜进趣后　前中三品即为三段。初品明位。次品明行。后品叹德。又初是解。次是行。后显德。同上明难等三品。问何故前会无别胜进趣后。此中有耶。答此中位成故。胜前故。又前信无位总为趣。住方便故。今此位成。是故别有进后方便也。问若尔何故回向品后无胜进耶。答以世间位满故不须也。又总摄前诸位。作证地方便故也

就此品中有七分　一三昧分　二加分　三起分　四本分　五说分　六证成分　七偈颂分

初中何故入定者有六意。一以此三昧是法体故。二显非证不说故。三显此法非思量境故。四察机审药故。五为受佛加故。六为显诸佛同说故。文中四。一辨入定人。何故法慧入者。是众首故。余入则乱众调伏故。显十住法慧能说故。二显非已力。三明所得定谓简佛果故云菩萨。观解善巧故云方便。即住法也。方便多端故云无量。即是十种也。四纳法在心故云正受

二加分中三。初总辨能加。二显加所为。三正明加相。初中六。初显能加佛处所远近。二能加佛数。论云。何故多佛加。显法及法师所增长恭敬心故。又欲显一切佛同说。是以承诸佛神力。于此法慧说即是一切佛说也此通因果二说故。三显佛名同者有四意。一明得法不异故。二彼菩萨闻诸如来同已名重增踊悦故。三显住中因果同故。四俱诸佛于此住门中为能加显显皆名法慧。以法力故法尔故。四叹得此定。乃能者是希越之辞。明希有能入此三昧者。问何故诸佛于大众中叹入此定。答以彼法慧默入斯定。为众不知所入是何无心渴仰不得为说。是故诸佛举三昧名。对众称叹起众欲乐也。五善男子下明得定所依。谓彼诸佛自说。由已作加力故令得此定。六又卢舍那下彼佛自释作加所由有三句。一由舍那本愿力故令我作加。依地论释。舍那过去曾见有一卢舍那佛。加一法慧菩萨说十住法。当时能加诸佛同名法慧。因即发愿愿我成佛亦有斯事。今如本成。是故加耳。二亦是舍那现在神力相感同加。三是法慧自善根熟。堪说法益众上感诸佛。是故同加。略无大众机感之力。后会处具有。又舍那宿愿显法根深。谓久远已来修此住法。拟于今时为机宣说。威神力者正显今时传授。此上是化主力。后一助化力。显因果俱融主伴合辨。以成化事耳。二显加所为中。初句总。次九别。后一结。同异成坏准可知。别中一增长本有佛性真慧令向佛果成不退。故此约智也。二开解在缠法界真理令得显现。此约境也。又开示解释法界理故。三剖析众生性类令辨在十住等位各差别故又知五性差别。此约后智。又众生之界即如来藏。分别者为了因故。又是解释故。又分别一众生处即有一切众生及一切诸法门等故也。四约一乘。即治灭性灭三障四障使习等故。三乘除外道我执上心黑障。此约断德。五无明障尽智冥真境故云入无碍境也。又入因陀罗境故云无碍也。此约胜进入果境。六巧入果智相摄总持。此约入果智。即入密智也。七明照真俗。此约智用。八知众生根生熟多端。又知同如。又知一根即一切根。如根欲性海等。九称根说法。任持根性使不差失。又持行不失持义不散。又持法不灭等。结者谓广说何法成此等事。所谓菩萨十住也。三加相中三业加。口加劝说以增辩。意加冥被益智。身加摩顶以增威。何故先口加。以因前语便故。次意加中二。初加后释。加中十句。初一总谓令于大众中说法无碍。即无碍解也。九句别显无碍。同异成坏可准之。一无住着故。无碍即无著辩才。二说时不断。谓不忘名义即住放辩才。说不待次言辞不断等。三说时不杂无明。以不乖正理故。四所说理决定故。又异论不能坏故。五善净无过故。谓不求名等恶故。六于一切法能随顺说故。又达一切义故。七超过下位故。又余无能越故。八说无厌倦故。又离慢故。九言无退失故。又言无退理故。又言不退屈故。下释偏加所由。诸佛有力有慈悲。何故唯加法慧不加余者。释有二因。一以得定力故。二法尔故。谓如水流法尔趣下。今此亦尔。凡有能说十住法人。理数如此诸佛神力流聚在中故云也。身加摩顶者增其威故。令从定觉故安慰令说故。又彼诸佛等不来至此。手亦不长而摩此顶。又诸佛手皆全摩其顶而互不相碍。是法界缘起不思议法也

第三起分者有四意故。一已内证法故。二已得胜力故。三说时至故。四定无言说故。是故须起也。前初会普贤为果法深细故。定中说。又显普贤自在故。此明因行故寄出也

第四本分中二。先证本后教本。亦是先体后相。初中先对前后诸位料简者。何故信中无此义者。以未成位故。此是位体故。何故此名种性乃至十地名善决定者。以此位最劣约种为名。十行次增约依种所发业行为名。十回向更增故约行后大愿为名。回前诸行向正证故。十地已得真证必然故名善决定。此等并是位中通体。随位渐增有兹阶降。是故十住十行无大善决定者是劣故也。又以三贤中下故。最劣故。未辨此大用也。又以自利增故。又以约种未现行故。种性义略作三门。一释名种是因义。性是体义。又性是族义。谓种族也。又姓是类义。谓种类也。二出体有二。一性种性。二习种姓。性种有二门。一就有为无常门。如瑜伽云。六处殊胜无始展转法尔所得(云云)。二约无为常住门。如宝性论云。真如性者如六根聚经中说(云云)。习性有无者。一约护月唯本性。二胜军唯习姓。三护法俱二。四如缘起俱离。三诸门分别作五门。一约性习前后。二约五性。三约六性。四寄位。五诸教并如别说。又性起品云。菩萨摩诃萨自知身中悉有一切诸佛菩提。何以故彼菩萨心不离一切如来菩提。如自心中一切众生心中亦复如是。无量无边。无处不有。不可破坏不可思议。文中六句。初一句总。谓五种性中简去余位故云菩萨种性。下五句别显种性义。一甚深者是幽邃义。一约有为性彻穷后际故。二约无为性真如法性离相离性故。三约用出生胜德不可尽故。四彻同佛果故。又照穷逾远曰深。毕竟无底曰深。幽玄无极故曰甚深。二广大者是苞含义普遍义无边义。前即深无底。此即广无涯此通有为无为能生所生因果等法。准别显之。三与法界等者是胜善义。谓大白法界等故。又具足人法教义因果理事等一切法故也。四与虚空等者是因善义。谓成无常爱果因故如虚空。以在地前略无常果因。又亦由上深故等法界。广故同虚空。或俱通二。或与上别可知。五是不怯弱义。以从佛种中生故。亦是释种性名义。又亦得诸佛从菩萨性中生。又是释上诸句。谓何以得知深广等法界等耶。释云。以是三世佛种性能生一切菩萨等故。二显相中三。初标数引证。谓三世佛果无不皆由十住因感。如大王路埋无岐径。故云同说

二列名。谓一周圆以明十种。三结说。此中十住义略作十门。一释名。二辨体。三明所依身。四所行行。五所观境。六所离障。七所成德。八所寄法。九所摄位。十所成果。初释名有二。一总名如前释。别中初者谓依外凡。十千劫来修信善根方便行满。于大菩提起决定心入位不退故云初发心。初发心即住。是持业释。此当起信论中信成就发心也。二精练此心使离染明净。故云治地。谓铸治心地也。三妙观空有而正行薰修故云修行。四生在佛家种性尊贵故云生贵。谓此寄当无流位故。五巧不滞真。起悲愍物。滞真随俗。此二合观离边巧备故云具足。此同五地难合真俗而能合也。六观无二法。既渐纯熟闻赞毁佛等心不倾动。故云正心。心即是正故云正心。又正是境。心是智。以心住正理故云正心。七止观双运缘不能坏故云不退。此同七地双行相。八三业光洁离染如童。童行性成物莫能沮故云真也。此同八地无功用行。九应机善说。绍嗣法王故云子也。十住位满足成就智身。诸佛法水以灌其顶故云顶也。若依圆教。此灌顶位满即成佛更无十行等。如下文海幢比丘处说。若三乘教则不如此。但是解相未证真。故得名有三。谓第四八九十从喻为名。第七约离过受称。余并约功能为目可知。二明体性者作三门。一约所依即以无量方便三昧为体。以依此定说十住故。下论云。此三昧者是法体故。二约本即以前种性甚深等为体以彼是此十住体故。但随位说十。而无别性。三克性约所缘以真俗二谛。约能缘以悲智二行。余行眷属皆此所摄。又真俗境俱融。悲智唯一。此二复圆俱融。法界无障碍具德自在是其体也。此约圆教辨(余门别作)

第五说分者十住有二分。一果分圆融不可说。二因分随说有二分。一约普贤自体行。二约普贤位相此有二分。一阿含位如此品说。二证位如十地品说。今此正说阿含位。于中有二。初明摄体之位。后辨随相之位初中释十住即为十段。一一皆有二。谓先标后释。释中皆二。初修行是其别相。以一一住中各修一行故。二观解是其别相。以诸住皆有解悟相故。前中各二。初自分行后学十法为胜进行。胜进行各二。先正修。后何以下释修意。其中第一第十文相加者以初为行本赖多缘故。后为位满德深广故。又释一一中皆二。谓标释。释中皆三。初明入住行。二学十法为净住行。三住满得果。准地论。诸地皆有因体果相即。入住为因。净住为体。住满为果。并可知。今且依前释。初住中先标名后释义。释义中二。先别行中二。先自分后胜进。前中二。先明行本谓发菩提心为十住之本。但转此心渐增胜故成后诸住故也。二所得。前中初六句举发心所依缘。次一句明所发心体。次一句明发心所求。后一句明不退还。又释初六句释发。次句释心。次句释菩提。后句释住义。前六句中二处闻说法者。初闻余人说。后闻佛说。又初略说后广说。又初说因法后说果法。又七缘发心准辨。又一向不回者简异外凡也。二所得中分是因义。谓由初发心得成十力果法之因故。此约始教辨。二分是未圆义。谓由入住不退始生佛家得佛体分故。谓于十力随分而得。此约终教辨。三分圆无碍故得分即得圆。但以就普贤门中辨。是因而非果故云分也。此中于流尽亦分得者准教知之。又此十力小乘中至佛果始得。三乘中地上始分得。一乘入位即得故也。二胜进中二。先正辨后释成。前中有十句。一供诸佛。二叹诸菩萨能舍自乐忍苦求果。三以胜妙法化诸众生。不令彼心堕凡小位故云护。又护善根令得增长。四准下颂当第三常叹贤圣。此云亲近者此约自利。颂约利他。谓进而常叹也。五叹净妙法。魔等不坏故知不退也。六以佛功德安立菩萨故云修。此顺颂。七巧化众生令得见佛故云叹美生诸佛前。八善修三昧以教众生故云方便。九转妙法轮灭生死轮故云也。十为生死苦类作清凉归处。又释九令离无常苦。十令其得常乐。此十并准下颂文知之。二释意中。先征后释。征云发菩提心已。何故复须学此十行。释有三义。一欲使此心转增胜故。二令坚固故。三令成果故。又一令自分坚因。二胜进转增。三终成佛果故须也。二同相中明悟必赖缘故云有所闻法。解从内发故云不由他悟。然他义有三。一小教。二心外。三性外。自解亦三。翻前可知。故下云虽知一切法不由他悟。而求善知识无有厌足。下诸住中随位渐增义皆同此

二住中。初自分内十心者有二义。一随于一众生即起此十心以显无尽。二为辨十心别异相故明于十种众生处起。一于怨憎众生不念加报。二于受苦众生。三于乏资具众生。四为不善众生令住善行故。论云安者因处乐者果处。五于得善因乐果众生。六于有流众生度令发心。七于初发心众生。八于修菩萨道少劣于己众生摄令同己。九行与己学推之同师。十德少过己敬同于佛。此十并如第二地集果中释。二胜进十行中。初一总谓若不多闻行无所依。又以何化生故须也。余九别。一标求多闻意。又是舍离已欲。二近善友。三顺其教。四不非时请问。五不畏不得法。又不畏深法。六解深义。七达正教。八于教义中择取修行之法。九依法正修离障成德故云不动也。下释云以此十行修治慈等令更增广。故须修也

三住中初十自分是护烦恼行。谓是中令行不住故总明无常义。初一是总。无常者是无物可为常。谓自性不成实。无常等三性准之。二苦谓五蕴洞达空为苦等。三空谓三无性真理空等。四无我谓无二我。又于我无我而不二等。具如掩提遮说。五系属因缘不得自有所在。六世法妄秽恶不净相。又以速灭乐所以不逮。七成无所集坏无所散。八无实可当名。又不得须臾住。九相有体无曰虚。执虚为实称妄。又无实故虚。诈实故妄。十世法速灭。纵加心防护亦不能令住。又释缘中无力故云无精勤。由无力故无和合。无和合故无坚固也。此十无常如三地论中释。后十句胜进中是护小乘行。于中初一是总。谓分别众生假名不实等。又分别种类差别等。余九是别。一知众生惑业染净法界差别故。二知众生依处别。次四知四大成众生别。次三知三界别众生粗细别。又释第三句总知依报。次四大出器体。次三界辨器相。皆分别即空及差别等。释中征云前既但观无常空等。何故复起如此分别。释云以即空分别事方令慧明净故也

四住标中释名可知。法华云。从佛口生从法化生等。初十自分同四地中十种法知。初三摄心入理以修止行。一证心于佛。二穷法原底。三安心契彼。以此寄当出世位故。于三宝得不坏净信。后七照达事相以修观行。一分折所化聚类多端。二应机现刹差别非一。三众生依报染净类异。四业有黑白不同。五果有苦乐之异。六生死有七种差别。七涅槃二四五异。皆于此等分折显空及聚类差别。二义准之。又释七中一总举正报染净。次二依报染净。次二因果染净。次二分位染净可知。后十胜进中。初三寻思简择。次三择已正修。后三修已成满。末后一总结无二。又释初三教法。次三行法。次三果法。后一理法。征释可知

五住中初自分内。初一总余九别。前第二住发起此心此住举善根。显所为渐熟故别也。九中一令修善行。二令得乐果。三不令着乐。四令修出道。五令所生处离八难等。又令离惑业等难。六毕欲令出分段变易等苦。七示以正法令灭不信及疑故喜。八授以三学控御造修。九令得学果。又七智八定。十断果胜进学中。一由无对治故生死无边。二此约去来故为二句。三约现在苦。四约十方。又约体性。又约根欲。五约下二界。六约无色界。又约类多。七约所执性。八九约依他性。谓初句依缘后句无实。又初无性后似有。十约圆成实中空如来藏辨。又七约无相。八约无生。九约无性。十总结三无性。下释中无染著有二义。一既以善根救摄众生。以学知众生无边等故不着限分等心。即是广常二心也。二学知空等故不执着。实是不颠倒心也。由此所学令前慈等方得顺理行增故须学也

六住自分十中。初四约所敬三宝修平等观。次三约所悲众生修平等观。后三约知法界明平等。以赞毁之辞皆从缘起同无自性。无性之理是此观境。是故不动名正心住也。又佛具胜德理宜褒赞。故闻叹不动。若执佛情有既非正理。故闻毁不动。又毁相令尽。赞理令显。故皆不动也。是故商主天子经云。又复问文殊师利。若复有人毁汝所说彼将何云。答言当向涅槃。又问何缘作如是说。答言一切无有不毁语言而能得至圣解脱中者。所以者何。其圣道中无有名字章句语言可说可示。若不信者彼等当不解脱。又问何缘作是说。答言不可已得解脱复得解脱。又法界随证有浅深故云量无量也。世界多故云法界成坏。故颂中云世界成坏也。空不空为有无也。由得此十种决定心故于缘逆顺皆不能动。于此位中有示现退。为引初心懈慢等故。如舍利弗法才王等。是故第七方名不退。胜进十中。初三约三无性观。四约惑业。五约果报。六约能现。七约所现。八无体。九现实。十缘集。又释此十皆展转释疑。疑者闻所执法无相即谓依他为有。释从缘无性。复执既无依他。在缠真如岂不须修显。释性净故不待修也。复云真若性净烦恼业等岂不断除。释无所有故。执云若尔何故现有依正果报。释以依真不实故。复云若世法不实真理与诸法作依。此应是有。释如虚空与色等为依然自体非有。复云所依若无能依诸法应有。释以依他无自性故。复云若尔应坏业果。释如幻故。复云若尔世人何不见是幻而见是实。释以在梦故。复云梦者见梦境。悟者则不见。世法不尔凡圣同见。释如响虽长幼俱闻然了不了别也。何以故者。问云前闻十法心定不动。已顺正理。何须更观如是等耶。释云欲更深入令得后位不退忍故

七不退住自分中。心坚不转者与前正心何别。释前正心入理。今理事不退。以念念淳至双现前故同七地也。又可前位会事入理。此俱行。后位从理向事。以渐纯熟故也。是故前位但于三宝等处闻赞不喜。闻毁不忧。犹未堪闻有之与无。以不胜故。此中闻有无利害。转深坚固不动故过前也。中约理为无。约事为有。以是有即无之有故。闻有亦得无不为有所动。以无即有之无故。闻无亦得有不为无所动。以得双行故尔也。又约三性以释有无。又不出生死者以无可出故。大悲不舍故。又三世同如故。一相不坏差别故非一。胜进中十法五对。一一多相即。二教义相依。味是教也。三有无无碍。一所执理无为非有。即是情有故为有。二有此理无故非有是有。三约理法。谓非情有是理有。四依他似有故非有。有此有故以为有。五依他无生为非有。不坏似有故为有。六有此无生故准之。七真如离相故非有。有此真故为有。八空真如为非有。即是不空为有。九无性性为非有。有此为有。十随染隐故非有。性本净故为有也。有是非有者翻前十义即是应知。四相非相无碍。五性非性无碍。并具十义。逆顺同前准知。又释后三对约三性三无性。如次应知。释所学中。欲使双行无碍善巧圆满故云具足等也

八住中谓从理向事而不失理故云心得安立。自分中初三业无染是童真体。以不失真理令事清净。是自利行。余是利他行。以三业净故。能受生自在。知信等心。从心起欲乐。习欲成性。依性造业。并如第九地十稠林处说。又如发心功德品说。知器世界二十劫成等。又知集故成散故坏等。神通自在总结三业胜用也。胜进中初六外器自在。后四自身自在。又释初七明广学知广大三业。后三明自在三业。初中光明意业。中一总知器。二知已能用。三虽动以愿力持令不坏。又持令常用。四观其即真等。又观染净差别。将欲往诣故。五明身业。谓观已须往处诣之。六非但次第往诣。亦能一时遍至也。佛刹定有佛也。世界通有佛无佛也。七明语业。谓若至有佛处能问佛妙法。若至无佛界能善答众难。别本中同后释。八明自在身业。谓非但一身至多世界。又能变化复作多身成法界身业。九语。十意。皆成法界自在胜用可知。下征释中明凡于一切法即得巧用自在圆满成就故

九住中同善慧地。于自分内。一解六趣即是生行稠林。二是使行稠林。三是习气行稠林。上三所化。四是能化方便智。五是智成就解法药。六知化仪示法师威仪。七解化处。谓所化众生住处。八解化时。谓所化根机生熟时等故知三际也。九不动真际建立诸法。十不坏假名示诸法实相。胜进中既为法王之子故须学知法王住处等。于中一住处者有八。一约法身无住处。二约智住真理即住无所住也三约报身住净土等。四约行德住四梵三空及慈悲殿等。五约化身住摩竭国等。六约十佛住国土海。七住华藏界等。八内住无障碍法界。二善知外化现四威仪。谓随众生须行即行等。三善知安立法王处者。谓由机感及悲愿赴故身土方现。故云安立。别本名兴立也。四巧证真理又巧就应机。五依证起说又就机剖别。六知佛以智水灌得位菩萨顶等。七知佛正法当以何持而堪受持。八知佛十无畏答难不怯等。九知佛处世不染又无著辩才等。十知叹佛之轨则。又知佛可赞之实德。释中为得九地四十无碍智故。十住自分中二。先十显所成就智。后十叹其胜德。前中初五明世界无碍智一随心回转。二晖光照觉。三愿等任持。四自在普入。五至处皆严。次三知众生心行智。一知心。二知心所行境界。三知根海。后二授法智。一应根与法。二令灭惑成德。故云调伏也。又亦初标意后释成。谓云何度。以三学调伏故也。二辨胜德十中。初四明身业不可知即是业自在义。后六心智不可知即是智自在义。前中一身色微妙。二依身起胜业。三变现奇异。四奇特无碍。又释初身体。二用。三神足体。四用。皆不可知者以事即同理而显事故。又以用遍显密故。后六中初三智穷三际。即三达妙智知一切时也。四严净刹智。即器世间自在智。知一切处也。五众生世间自在智。以染净业集起心是众生故。六智正觉世间自在智。又释心即定也。后为慧也。又释心境是俗谛。以是集起故。即是上九之本智。境是真。以照理故。即结归真也。以此真俗无碍双照悬鉴故皆不可知。下简定其位。谓岂可同位菩萨及佛亦不知耶。今释如文。后胜进十中学佛一切智一切种智。即当位满足灌顶作佛。以摄诸位皆具足故。如下入法界品海幢比丘顶佛说法处知之。一准下颂文总学三世诸佛智。二学佛教法智。三理法智。四理事多门无碍智。五大用普周智。六对缘觉照智。七世界依持智。八下穷生界智。九上尽佛果智。十果德多门智。此中灌顶有受职义。与法云等同异(云云)

第六显实证成分中二。先显实。后证成。此二各二。先此界后结通。显实中此界内三。先动地内。一动因。二动处。三动相。二雨供即身业。三出音即语业以法准之。二证成中此界内四。一菩萨来此于中有来因来处来人也。二发言赞美。三述已引证中。一说人同。二处同。三主同。四义同。五众同。六教同。四显其来意正结成证

第七偈颂分中以四句成一颂。即有一百一颂半。分二。初有九十二颂半颂前十住法。后九颂结叹劝修。前中颂十住即为十段。就初住有四十六颂。于中分四。初三颂前发心缘及体。二三十二颂得十力分。三从菩萨如是发心已下十一偈颂应学十法。第二中亦三。初十颂十力行。二有二颂求所知二谛法发心。三震动下二十颂为求佛三业发心。于中初十颂身业。二十方已下三颂语业。三一切十方下六颂意业。下一结叹。又此广大三业是此住中所得。谓三业随智行等(云云)三颂胜进所学中。不退教者说顺正理教无改易。又说此入位不退之义教。又顺此教法得不退故。前是持业。后二依主。于前胜进十法之中。十颂次第各颂一法。后一总结并可知。第二住中六颂。初二颂自分。后四颂胜进。第三住中有五颂。初二自分。后三胜进。第四住有六颂。初三自分。后三胜进。第五住有四颂半。初三自分。后一半明胜进。第六住有五颂。初四自分。后一胜进。第七住有四颂。初二自分。后二胜进。第八住有五颂。初三自分。后二胜进。第九住有三颂。初二自分。后一胜进第十住有八颂。初五自分。次一显德。后二胜进。第二大段结叹劝修中九颂分三。初一总叹十住。二有七别叹初住。后一以初住倍类显后

    梵行品第十二

初释名者。离妄念之染故云梵。会无我理故云行。此行即梵。二离染中极名梵即真境也。智能证此故云行。三涅槃果为梵。以寂静故。修因为行。此二梵之行。净与梵何别者有六别。一约报。欲天为净色天为梵。二约人。在家戒是净。出家戒为梵。三行位。信中修为净行。入位已去修为梵行。四约二利。三学自利为净行。四等利他为梵行。此如涅槃经说。五约二行。随事造修施戒等为净行。离念契玄为梵行。如文。六约因果。涅槃为净。道谛行为梵。经云梵行已立。是也

二来意者有五。一前位次行。谓前明正位今辨成位之行。故文云何修习梵行具足十住。二前明正位今辨依位起行。三前别此通。谓前十住之中各修一种别行。今辨诸位中同行之行。四前通此别。谓前辨位通。今别明出家人行。五前显位相差别。今会缘入实。即前相后体故也

三宗趣者以无念正行为宗。所成十住位及速成佛等为趣。无念理观略作五门(云云)

四释文有二。初问后答。问中明受离染法之器故寄天子。离妄念器方能受故名正念。具下文天光女文也。文中初举事信家。非家是空法非家也。二彼诸下正问有三。初问修梵行。二成位。三得果。答中所以法慧说者以照法之慧方能示法故也。于中亦三。初答修梵行问。二又复修习下答成位问。三如是观者下答得果问。又亦可此品重更释成上十住中初住之义。于中三。谓初释上发心。二释发心所得十力。三释上自悟得果会同法界。是故即此初住具摄十住也。初中有四。一明寻思观。二又知过去下明如实观。三菩萨正念下观成益相。四是名下结观名。初中三。先举十法为所观。二应如是观下以理征破显梵行真理。三当如是下结。何故但就十法观者。以摄法略尽故。谓身口意是有为果。三业是彼因。佛法是出世果。僧戒是彼因。又出家人修出世行要依此十法方成梵行。谓三宝及戒是四不坏净境。即所信所入也。身口意是能修行具。即能信能入也。三业是对境所修所成行。今推求此梵行在何法中。既求不得。即相尽理显方为真实梵行。是故文中约此十法唯征梵行不征余法。文中二。先以理案定。二若身是下纵破显非。又初是总后别。初略后广。此中征核十法。即为十初中若身是梵行者定其所立。下以理推征。谓梵既净法。身是杂秽故非也。以此身等六事是通染净法故。但约染净相违明非梵行。不破彼六之自体。后四是净法。顺梵行故。即别推折以显真理。身中八句。初一总余七别。一无可轨则非是出世之法。二饮食资成。三恶气熢勃。四具三十六物。五垢污尘染。六邪命自养。七诸虫唼食。依观佛三昧经佛将成道魔来恼。时佛以白毫拟之。令彼魔女自见身内脓囊涕唾九孔根本生藏熟藏回腑宛转踊生诸虫。有八万户户有九亿诸小虫等游戏走入小肠中。张口上向。大虫游戏入大肠中张口亦尔。唼食藏髓脉。生虫细于秋毫数甚多。其女见此即便呕吐等。又小乘中说。虫头向内虫尾向外。编作人皮。又此虫是观境故虽实有之作虫观。时方见。如白骨等亦观时见也。小乘即实。初教即空等准之。上来但是纵破。故云当知梵行则为虫等。若具应云虫等既非梵行。明知梵行不即是身。如身无梵余门亦尔。以依此等成梵行是故于此十法求梵不得。离此十法亦求不得故。下文云何等是梵行。梵行法为在何处等。其意如此。随文准知

二身业可知

三口中心触者。是触数缘境起言助发口业。俱舍论十六种触中名增语触

四口业中语言与前何别者。前约报体。后约业用故别也。实论口体属身分摄。但取能发语边名语。所发语法名语业。是故新翻为语业。古译就相名口也。作无作是语业体中表无表义也

五意中幻梦者以睡中意识行故。梦中所见能所等事皆心幻作故也。此中觉观等既是心法。犹是举数以征王也

六意业中约遍行五征之。以是根本动作故。想是想数。施设是思。寒热饥渴是触。苦等是受。略无作意也。上来但染净相反显非梵。不待细破。后四顺梵故别破。细折方显真理故不同也

第七佛中。一约五阴。二约相好。三约神通业报者示金枪等也。此上三处皆依前起后次第征之

八法中六句。一净教。二理果。三约缘生不生。四就体实不实。五就情为虚妄。六成坏为合散。此中通有三义。一净谓初二句。二染谓虚妄。三非染非净谓所余句。以约三性随见一分余分性不异故俱非法也。又约执故。梁摄论云。计涅槃以无生寂静为体能离三苦为用等。皆成法我及我所执。是故俱非法也

九僧中。一约位求僧。谓四向四果以同证无我。和合者谁。故无僧也。二约德用求。谓三明六通。三约根求。谓钝根罗汉假托时处方得解脱名时脱。利根反此名非时脱

十戒中寻思可知。上来是四寻思方便亦名求智。一以名求。二义求。三自性求。四差别求

自下第二明如实智观。于中六。初征梵行所依时。谓三世皆空。初总观后别释。谓此现在法无体可住故。无有流至过去世中。又由无体故无可续流至未来世。又以过去灭无故无物可相续流至于现在。又以未来无体故无法可起令至于现在。刹那前后当知亦尔。二征梵行体。三征梵行所依处。谓于上十法何者是梵。梵在何处。四征梵行主。五约有无征。六约五阴征。第三观成利益中。初观成中先法说。如上约三世观十法皆空。故云分别三世诸法平等。后喻况。可知。二如是下明益相有二。初妄不碍心益。谓云何得不碍。以不取相故。何因不取。以无性故。二洞照法界益。法喻可知。又亦可前观身等六法平等如空。后观佛等四法如空。第四结名可知。答初问竟。自下答第二问。由前观行成故更增修胜行入十住位。文中有三。初深观果智。二增长大悲。三悉分别下以理导前二。即是三心三戒成三德三身等也。以彼上文于初住中得十力分故。今行成入位。最初辨也。初二文可知。第三内二。初法后喻。法中二。先以理导悲。谓不舍寂灭不舍众生。以空有不二是众生故。般若大悲是一心故。二以理导果。谓行无上业不求报者。以即空故不求。以不坏故常行。亦是止观俱行空有不滞中道行也。何因得如此。以观诸法如幻等故。无体如幻。现实如梦。有用如电。缘聚如响。成事如化。答第三问中二。初牒前二起后。起后中两重显少因得大果于中各二。先标后释。初标中以少方便是因。疾得等是果。释中何以少因而疾得大果。释以常乐观悲智空有等无二法故。是故疾得。故云斯有是处也。第二重中。标者初发心时是因。便成正觉是果。亦是转释前。谓前云疾得佛果未知何时名疾得。今释发心时即得故。下云初发心菩萨即是佛故悉与三世诸如来等。此明行满入位时即得普贤位故。一位即一切位乃至佛果无不圆备。故云正觉。下释何因得如此。以知一切真实者。显理圆也。具足慧身者智德备也。不由他悟者内自开觉也。岂是因中说果耳。此一乘普贤行位。因果圆融相即无碍故致然也。宜须思准之

    初发心菩萨功德品第十三

初释名者本觉内薰大心创起故云发心。行成位立名为菩萨。功超远劫德广尘沙故云功德。此明菩萨初发心之功德。是此所辨为简二乘故云菩萨。简终心故云初发。此明发心所摄功德。非辨发心之相故以题名

二来意者有三。一前住及梵明行位体。今显其胜德故来也。二前品末初发心时便成正觉未知此心有何功德便能如此。为来释此义故也。三前二品以法就机说令行位有分齐。今则以机就法显德量无限。是故前二通同别二教。今则唯明别教为一乘玄妙故。下偈中以美言词赞述故次来也

三宗趣者。辨初发心摄普贤德具因果分量与法界等。是其宗也

四释文于此品中有说分为四分。初请。二说。三证。四颂。今说于中有二。初长行散说。后偈颂总摄。前中亦二。初此界后结通。前中亦二。初正说后证成。前中亦二。初问后答

答中三。初总叹甚深令生希欲。二校量显胜生其净信。三当相辨深令生正解。初问中天帝问者在天故显功德自在故。法慧说者称法之慧方穷功德之际。二说中二。初叹深令信。二虽然下正说令解。又释前起其希欲后正授法理。又释前显体甚深后明用广大。又释前显义大深后显教大广故也。前中初句总六句别。一自不能知。二他闻不信。三思惟不解。四言宣不明。五修慧不能通。六报生智不能分别。故甚深也。又释一教量难知。二义深难信。三思惟难解。四应教难说。五欲证难通。六数极故难分别也

第二校量显胜中总有十一段校量。一约益物校量喻。二约步刹校量喻。三算劫成坏喻。四善知欲乐喻。五善知诸根喻。六善知悕望喻。七善知方便喻。八善知他心意喻。九善知业相喻。十善知烦恼喻。十一供佛功德喻。论中摄以为六。初三为三。次五为一。次二为一。后一为一。故为六也。释有三门。一对前六甚深。二约菩萨菩提心相似。三约治六障。初中有二。先校量显胜。后何以故下释胜所由。前中有十重为二。初一别说后九通说。初中有四。一举广事二正征问。三答显广。四辨超过。初中亦有四广。一所供广谓僧祇众生等。二供事广谓一切乐具。三供时广谓一劫等。四利益广令修五戒等。下九中亦四。初并举九事。于中亦具四广。准初知之。但增多等为异。二问三答四超过并可知耳。二释显胜中二。初何以故正征责。征责有二意。一云如前所说功德甚多。何因比此而非类。故释云。初发心菩萨不为齐限尔所等故非比也。二云初心菩萨有何胜德而超过前位。释云悉欲不断佛种等故。是故过前也。下诸文皆准之。二佛子下释成。释成中二。先明不为齐限事故发心。显前四广非为广也。二欲不断佛种下明为无齐限事故发心。是故显此超过彼也。此中有十二句。初一位过。是总以菩提心是佛种菩萨恒起名不断。又菩萨化众生立如来种中不令取小果亦名不断。不同前五戒也。余句是别。一是心过。准下应云欲以慈悲心充满十方界。翻前十僧祇界等。二行过。谓欲度一切众生。翻前限局故云一切也。三知器相成坏过。是知所化处。谓知成坏差别。又知成即坏等。是佛一切智。是故广也。四知器中众生报类垢净皆由业异。即是业力智也。五知前器体本净是如理智也。六知所化生使习粗细是流尽智。谓知彼即空亦即成障等也。七是生死智通即天眼力也。八根力智。九他心智。十是三达智亦有宿命智。十一亦如理智。又此十一中。初二是大悲余九是大智。智中第五及十一是佛地一切智。余是一切种智。并无分齐故是故超过也

第二步刹校量喻中亦二。先明喻所不及。后何以故下释显胜相。前中喻相有一百重。初十重别说。余者总说。释中二。先征责。后释成。释成中亦二。先明不为齐限事故显前不及后。悉为下明无齐限故显此过前。此中亦十二句。初二约悲心。初总标。后别释。谓欲令度得果故云为也。次十约智。为成自在智故。于中初一总知。次八别显。后一结意。又初一平漫普遍知。次八重重即入无碍知。此中一大小相即。二多少相即。三广狭。四一多。五相入。六染净。七帝网。八相生。此八中有二义。谓相即相入。此二各有二。谓同体异体。此二复有二义。得成即入。一约缘起门。二约真性门。初中亦二义。一约体。有空有义故得相即。二约用。有有力无力义故得相入。约缘。有待不待义故有同异二门也。约性亦二义。一不坏缘故相入。二缘相尽故相即。并圆融无碍自在之义。准上思之

第三算劫校量喻。此中亦二。初明喻所不能及。后何以故下释超过之相。初中亦二。先辨喻广大。二对显超过。前中初辨东方有十重倍倍可知。后类结九方亦各十也。二释中先征后释。释中二。初不为齐限知尔所等故是故过前也。后菩萨欲悉了知下明为知无齐限事故是故不可喻也。此中有十句。初一总知。次八别知。云何分别知耶。谓如是即入重重相摄自在无碍如是知耳。亦可初是平遍而知后重重即入无碍而知显纯熟之相。此八中。一长短相即者。长是大劫短是小劫。又娑婆界是短劫安乐界等是长劫。相即故无碍也。二一多相即。三约佛有无。如庄严劫及贤劫等。是有佛劫。如过星宿劫后有六万二千劫。空过无有佛。以此二劫相即故也。四约佛多少者。如星宿劫中有八万佛出。是一劫中无量佛也。如大通智胜佛出世时。梵王赞云或千劫等空过无有佛今始得见大通一佛。亦相即故云也。五异无异者。是纯杂无碍。或过未名异现在名无异。过未入现现入过未故云也。六尽不尽者。是存灭无碍。如天人见劫尽此土常安稳等。七一念即无量劫。以积念成劫无别劫体故即念也。八有无相入者。推妄归真。劫入无劫。依真起妄。无劫入劫。又初以事从理。后以理从事。故无碍也。结中初总结所知。后结其本誓。是故功德等于佛果故不可说也

第四知众生欲乐校量中亦二。初明喻所不能及。十方各有十重。倍倍可知。后何以故下释超过。于中初责胜所由。后释胜所以。此中先不为齐限等明前不及。此后欲悉知下明过前之相。此中初一句是总。谓以如来一切众生欲乐智力。知于众生欲乐之海故云种种欲乐也。下别显中有二。初约法别知。后一一众生下约人通知。论名前为遍知后名微细知亦得。前是异相后是同相。前中有二十三句。一约众生求心。别名无量欲。同期一果名即一欲。虽同期一果。然求行恒别故云不坏一切欲性。又以悕望之念无二。同是别境中欲数所摄。心法不殊故云即一。而所乐差别故云不坏等也。此约一众生心前后欲乐多端而相即无碍耳。二乐欲繁多深广如海。三异类众生欲乐心海缘起无碍故相即也。又知一众生善恶无记。一切众生亦尔故云也。四于一众生随三际中。前后欲乐种种而知。一一众生悲皆如是故云一切等也。五于中流类同者名相似。所乐异者名不相似。六约三乘欲别名一切。同归一乘名即一欲。实即一乘名为一欲。权开三乘名一切欲。又约缘起无碍。通自他等位可知。七同佛果智。是十力中欲乐智力故也。八求三乘等名有上欲。求一乘名无上欲。九于所求处若是究竟名无余欲。反上名有余。十求理名等。求事名不等。十一托余心所是有所依。独起欲数名无所依。又依境起欲名有依。知境唯心心智无寄名无依。十二同求名共。异求名不共十三欲在因位名有边。至佛果位名无边。以惑障尽故。十四顺理名善欲。违理名不善。十五随流名世。返流名出。十六求佛智德名大智欲。十七求佛断德名净欲。十八过凡小位名胜欲。十九求成菩萨诸地证智波若之欲。又论中释。大智欲在种性位。净欲是见位胜是修位。无碍智是八地已上无功用位。二十在佛果位。大智无碍圆明解脱。二十一染而不染名清净欲。不染而染名不清净。又若离世名利名净。求世名利名不净。二十二多求名广。少求名狭。又大悲救生名广专求自脱名狭。二十三求深名细求浅为粗。下约人辨欲同相中。初举十数列名有八。此是减数十也。一因生死苦逼遂乐涅槃。谓因苦念乐。如囚求脱。二于善恶事中。因闻思惟而生欲乐故名方便欲。三于可意事求名悕望欲。四得已不舍名味着欲。五由宿因种子生名随因生。又从思想生。经云欲欲知汝本但从思想生。我今不思汝。汝还不得生。六外托境生名随缘生。又为善恶发化引生亦名随缘生。七无法不求名尽欲。又求涅槃尽灭亦名尽欲。八广求诸法名一切欲。又求无边菩提亦名一切欲。下总结中。欲网者有三义。一难脱义。如世罗网鱼鸟难脱。由种种欲网生死难出。此约染欲。二涝漉义。如世网涝漉。谓起净欲漉诸有情令出生死苦海。下文云。智慧王所说欲为诸法本。应起清净欲志求无上道。此约净欲。三隐映义。如帝网差别。染净等欲交涉无碍重重相入故云网也。此约欲体

第五知根校量准例。亦应具显为类同。故文中略辨。为求如来十力中种种诸根智力

第六悕望与前欲何别。通即是一。于中分别。欲据始故根前说之。悕望就终故根后说之

第七知方便者。造缘起行名方便。是发业方便故不同业

第八知心意者为求如来他心智故。前明心法此辨心体

第九知业者为求佛十力中业智力也。此上五门并略举。类上欲门应知

第十知烦恼校量中二。先明喻所不能及。后释显胜相。胜相中先征后释。释中先不为齐限知故显此过前。后悉欲分别下为无齐限流尽智力故明前所不及也。此中初句总。所谓下别显。有十八句。略作十门分别。初二句约轻重分别。谓率略心起名轻烦恼。殷厚心起名重烦恼。又微起易止名轻。粗起难息名重。又正使为重残习为轻。又本烦恼为重随烦恼为轻。又随中小随轻。上中重。可知。二有二句。约使缠分别。使谓十使即五见及疑贪嗔痴慢。缠谓十缠即无惭无愧睡悔悭嫉掉眠忿及覆。地持瑜伽说八缠除忿覆。何故除者。为有论师说。忿覆是使性。谓忿是嗔使性。覆是贪使性。为贪他利覆藏已过。使缠何别者。杂心云。根本名使。津液为缠垢。急缚名缠。轻缚名垢。又此中结即是九结可知。三有二句。约因果分别。一一众生无量烦恼是贪嗔痴等所起果。烦恼觉观是烦恼因由彼而生故。涅槃经说有八种觉观。故云种种。一欲觉求可意事。二嗔觉念欲嗔他。三恼觉念欲恼他。四亲里觉忆念亲缘。五国土觉念世安危。六不死觉积财资养。七族姓觉念族高下。八轻侮觉侮是慢念自恃欺人。四有二句。约本末分别。亦是痴爱分别。谓无明是无明住地。依无明起是恒沙上烦恼。爱是欲色有三爱。是有爱住地相应是与爱相应之烦恼也。谓因爱生忧等。五有四句。约三不善根分别可知。六有二句。地起分别。初句是五住起。后句是五住地也。七约利钝分别。我我所是利。慢是钝。八约相生次第分别。邪念虚妄是心想见三倒。生烦恼是从三倒生四倒。九约诸见本末分别。谓六十二见皆依身见生。以彼为本故。十有二句。约过患分别。盖谓五盖即贪嗔睡眠掉悔及疑。覆盖行人不得禅智故名盖也。障谓二障即烦恼所知。以所知障亦得名烦恼故。下结中以烦恼难脱通名惑网。由委细了知一切烦恼是一切种智。皆欲断令永尽。是大慈悲也

第十一供养佛功德校量中二。初举事校量明喻所不及。后何以故下释显超过。前中有十重。初一重别说余九总说。前中四。初举广。二对问广不。三答显极广。四校量显胜。初中先举东方后类余九。前中有五。初一念见多佛多众生。二自于多时。兴多供。三劝前众生同已供。四自起胜塔供。五劝他亦同起塔供。余文可知

就释显超过中二。先征后释。征问意云。且如东方一念即见无边诸佛。以此念力经无量劫供。明佛等甚广如东方余亦尔。即显极广。如一人既尔更复劝他一切众生亦如是。况复倍倍过前。至第十明此功德分限难知。因何比此发心功德。乃至于不可说分中不及其一故云何以故也。下释中。先明不为齐限故显前劣此。后欲悉下为无齐限故显此过前。此中过相虽复无量。太略而言有六种。一处过。谓尽欲供养十方无尽法界虚空等无尽世界处佛故。此通帝网等处故不同前。二时过。谓尽三世佛即通九世十世等无尽重重时也。三佛过。谓尽佛境界所有诸佛皆供养故非但如前。四供过。谓尽法界中有自他色心理事行等并以供养。非但如前。五心过。谓于前无尽佛境一一佛所各以无尽供事各经无尽时供心犹不尽是故过也。六行过。谓了达能所三事平等圆融无碍故过也。问只可全比非等。岂可不可说分中不同一分耶。答此发心功德即同法界。不可分折故。纵不可说分中一分亦即遍法界。无问多少皆无比也。如常住僧谷米一斛亦遍十方僧乃至一合亦遍十方僧。以是不可分故。思之可知

第三当相显深中二。先标后释。初中发是心已者。牒前诸喻所校量之心。即是标发心字。得知下标辨功德甚深。于中初摄因尽故深。二等佛果故深。此中是发彻后际之菩提。心是穷尽佛境也。前中初举所知境。谓知三世佛功德智慧。二成深行。谓信向是十信。受持是十住。修习是十行十回。得证是初地已上。身证是十地满已还。又内证为得证。相外彰故云身证。如小乘中以灭尽定为身证。此亦同也。又初是行证后位证。又初智相应后身相应。又可得证约因圆身证约果满。二悉等诸佛功德者是等佛果故深也。二何以故下释前二标。于中三。初释因等。次释果等。后结因分齐。初中先征问。谓何以知初发心已即能证得三世诸佛大福智耶。下释中二十句。显谓同三世佛音所行路故云等也。于中初十一句外化德。后九句内自德。又前是悲德。后是智德。前中初一句是总。谓化众生使发菩提心。绍继佛种故云不断也。后十句别显。一起愍物心。二作救度意。三知所化住处。四知所化类别。谓善恶业起苦乐报故云垢净起。亦是十力中业智力也。五起广大意亦是令离业障。六知所化惑障轻重。亦是求流尽智力。亦是令断烦恼障。七知轮转相。亦是天眼智力。亦是令舍报障。八知根生熟。是起行所依即是诸根智力。九知心造修正明起行。亦是他心智力。十总结所知。亦是三达智力也。下九句求佛自利德中。初一是总余八别。于中初二因果分别。初知菩提果。二知菩提因。谓净法是也。次二理行分别。初知理法平等。二知智行清净。次四体德分别。初三佛德。一十力。二无畏。三不共。后一佛体。谓实智平等故也。二释果等中。先征起后释成。释成中。初一句总。二别。三结。初中即是佛故者。有人释。或云因中说果。或云解同佛境。或云约理平等。若约三乘教亦得如上说。今寻上下文。约一乘圆教始终相摄。圆融无碍。得始即是终。穷终方原始。一由陀罗尼门缘起相摄故。二由普贤菩提心遍该六位故。即因是果也。三由法性无始终故。发心入始即正是终故也。是故上文云初发心时便成正觉具足慧身不由他悟此之谓也。二别中有十五句。初五句约佛内德盈满等。后十句约佛外化用普周等。初中一总四别。别中初二所依法等。一俗谛境。二真谛境。后二能依德等。一身。二智。二外用中初一总余九别。别中初三化令出苦。一动令生信。二照令惊觉。三正令出苦。后五化令入法。一严化处。二现成佛。三现通令喜。四正令入法。五入法已护令不失。后一结外化智。又释。此十五句中。初一总十四别。别中初五句是智正觉世间自在等。于中初二约法等。一所缘及分齐等。二理教等。下三三业等。谓所化约语业辨也。次四器世间自在等。于中。一动。二照。三除。四严。后五众生世间自在等。一为现。二令欣。三授法。四护持。五得果。若不护恐堕二乘地故也。第三结因分齐中。不离三世之中三宝众生染净等法者。此有二义。一由菩萨得通三世之身。是故常遍三际无所不在故也。二由菩萨得即法界之身。竖含染净横遍三际故云不离。余文可知第二显实证成中二。先显实中。一动地。二雨供。三振音。四放光。二证成中二。先现身证。后举益证。前中何故佛自证者。以初发心即摄佛因果此事难信故佛自证。又表因果同性故。又表胜进之因果摄成故。二举益中。举彼一切世界之中法慧所说。既有此益。明知。此法决定不虚。亦以此说难信受故致此证也。由此心藏摄德圆净故名净心如来。上来此一世界中说竟

第二结通中二。先显法普周无尽世界。后有十句。释遍所由。谓何故此法遍于十方说处说人说法及证悉皆同耶。释佛力等十句故也。一此舍那佛及一切佛各以现在威神之力同共加持故使然也。二诸佛本愿之所摄持。三为欲显示佛所得法。理数如此遍十方故。四明佛智光使普照故。五欲令解悟真理普遍故。六法界缘起相由法尔故须遍说。七为欣大法者示此称性广大之法令欢喜故。八佛德普周欲具赞故。九显示十方一切诸佛同所得法。谓平等无差故也。十为令解知十方法界无二辙故。由是十义故说普遍所以说十。亦是式则显无尽耳。上下诸文结通之义。并准此知之。上来此界他方总无尽世界一切处长行散说竟

第二大段偈颂总持中二。先序说意。后正重颂。初中十句。一以十方无尽世界同说此法故须观也。二欲令十方一切众海悉同闻故。三为显自心如空无偏局故。四观成就众生之法门故。五观称法性虽净如空而因果不失故也。六欲令离惑。七得一乘解脱。八了达根海。九会缘入实。十现自无尽发心功德令众见已而修学故。就正颂中总有二百四十一颂半分四。初一百六十三颂半逆颂前第三段当相之文。二有二十九颂颂前第二喻校量文。三有三十九颂颂前最初略显甚深文。四有十颂结叹显胜。就初文中长分有二十七段。初六颂颂前欲令慈悲心充满十方世界等文。二从欲悉分别知下七颂颂前欲悉知一切世界广狭即入等文。此中并显作用益生等。三从欲令诸佛种下三颂颂前欲不断佛种故等文。四从信心不可沮下二颂颂前悉得诸佛智慧光明文。五从悉能分别知下二颂颂前欲知众生种种业种种心种种根性等文。六菩提心无量下六颂颂前欲得法界等三世诸佛平等智慧文。七从清净无量心下二颂颂前供养一切佛文。八于诸甚深法下八颂颂前得佛智慧因缘文。谓智慧所因即是甚深三昧及从真如境所生也。此中并显通慧作用故也。九从具足大悲心下九颂颂前度脱一切众生等文。十从世界若成坏下三颂颂前知世界成坏等文。谓此成坏唯佛智境。今信佛无疑故亦了知。十一从尽于未来际下五颂半颂前休息一切世界众生诸恶道苦。十二从菩萨放大光。下七颂颂前悉能普照一切世界。此中兼辨所照刹中问佛说法。十三从明净利智慧下四颂颂前与三世诸佛正法等文。十四从清净妙法身下十一颂颂前悉于一切世界示现成佛等文。十五一身悉充满下八颂颂前得佛智慧等平等文。十六从一切诸世界下八颂颂前得如来一身无量身等文。十七从其心无所染下十颂颂前亦与三世佛境界等文。此是分齐境界有十种齐等。一离染等。二救生等。三智慧等。四相好等。五所知等。六证理等。七深定等。八行坚等。九心安等。十充满等。十八从欲求道师慧下二颂举德劝修。十九从菩萨摩诃萨下四颂显说分齐。上二不颂前文。二十从善分别众生下六颂颂前得三世诸佛智慧光明。谓照俗境常在真故。二十一从无量不可数下四颂颂前悉能严净一切世界文。二十二从慧眼无障碍下八颂颂前与诸佛所化众生皆悉同等。二十三悉能分别下四颂颂前知劫长短相即相入等文。二十四成就智慧力下十二颂通颂前初心所得佛十力智。二十五从一一毛孔中下九颂颂前悉能震动无量世界。谓入帝网等。二十六如是深法门下七颂颂前悉欲长养诸佛智慧文。二十七从菩萨摩诃萨下六颂颂前菩萨不离诸佛菩萨及二乘众生等文。上来至此总是逆颂第三段。当相辨文竟。自下第二。有二十九颂颂前第二约喻校量文。于中初六颂颂第一益生喻。二从无量无有边下二颂颂前第二步刹喻。三从去来现在劫下有四颂颂前第三算劫喻。四十方世界中下六偈颂前欲等五喻。谓一欲二悕望三根四方便五心法合可知。五一切众生类下四颂颂前第九第十知业烦恼二喻。六十方诸世界下七颂颂前第十一供养诸佛。上来第二大段喻校量竟。第三三世人中尊下有三十九颂。颂前第一标叹显深文。于中分七。初有七颂颂前最初总句甚深之文。谓深彻佛果故。深超群有故。深同法性故。深用普遍故。深智远知故。并如文可知。二常修妙下有七颂颂前第二难知甚深。于中初四句深广难知。次二佛以深德加持难知。后一结德难知。谓德如虚空非算能知故名难知也。三初发菩提心下五颂颂前难信甚深。谓以初发心即成佛果无边功德此难信受故也四一切辟支佛下八颂颂前难解甚深。谓令二乘三界所得安乐。乃在菩萨初发心中。此事难解。是故文中。初四颂标二位得乐。各二颂。后四释彼二位得乐所由。亦各二颂可知。五无量智慧明下五颂颂前难说甚深。谓智深德广业用数多言说难及故云称赞不可尽也。六普观一切法下四颂颂前难通甚深。谓心住平等为众说法。二位相违令极相顺。甚难通会故也。七无量妙功德下三颂颂前难分别甚深。谓此初心同佛位际限难分故也。第四大段欲得一切佛下十颂结叹劝修。初二举德劝修。次二显德深广。次四显德用胜能。后二劝学究竟

    明法品第十四

四门同前

初释名者有四义。一后位行法垂明前位。此明即法也。二明是教法是义。三明是智法是境。此二法之明明之法。四智行离染当相名明。即明可轨是以称法。又诸行焕照称性为明。当体妙轨故亦云法。故云明法。不尔是闇即亦非法

二来意者。前明当位体德。今辨胜用趣。后义次第故是故来也。又前明自分。今显胜进。故次来也

三宗趣者。明法不同有四种。一理法谓真如性。二行法谓六度等行。三教法谓十二分教。四果法谓菩提涅槃。今此正明行法兼明余三故以为宗。又此四中依理起行依行成果。教说前三故唯四耳

四释文者。此文分三。初请分。二说分。三证信分。初中二。初长行后偈颂。前中二。初领前自分。后问后胜进。前中若非勤策照理之机无以堪受胜进转增之法。又若非具此洞真净行法无以能说。故进慧问法慧说也。颂中有八句。一总七别。别中一大誓自严二行乘果乘。三入于因位。离犹无也。谓至无生位道余处释为初地位也。此在地前相摄故也。四背。五向。六同佛住。七定成果。二正问后胜进中二。先正问行法之体。后问依行所成之德。前中总有十一句。初六自利行。次四利他行。后一通结俱利究竟。前中彼菩萨者牒前发心具德之人。初句问修习何行令功德转胜。问前品中云甚深诸三昧无量陀罗尼诸佛自在力无量妙功德庄严初发心。又云即是佛等。何所少故更修习耶。答此圆教普贤行中大位有二门。各摄法界。前约自分。此辨胜进。前中亦具后后中亦具前。然前恒非后。后恒非前。谓具前之后非前。具后之前非后。故位分前后。摄义恒周故也。二问修习何行令如来欢喜。是故云何修习之言贯通下诸句准之。三问位地。四依位起行。五大愿助成。六积德成藏。利他中初应物机化。二不废自行。三赴欲度生。前生此熟为异。四化令趣菩提故。使三宝不绝成兴隆耳。下一结俱利中。善根境结自利。方便结化行。二俱究竟故云不虚。善哉下乃至欲闻。此文有二意。望上则为结请劝说。望下即是希闻后问。二问所成德中。如诸菩萨所修功德者总举所依之德。灭除已下明依德所成是所问法也。于中准下答总有十八句分二。初十七句明德备。后得善根力下明胜用。前中二。先十六句内德圆。后天王下外尊敬。前中二。先九句明自利德。后具足佛刹下七句问利他德。前中二。先有七句问因德。后庄严下二句问果德。前中二。先六句明行修具足。后菩萨一切下众德圆备。前中有二。初四句是断障行。谓先离无明住地是离恶因也。二伏魔。三制外道是离起恶缘。四离尘垢是离恶习也。二修善行有三。初修成福德。二超离恶果。谓离三恶八难也。三修具净慧。此慧下文将为答也。故唯有六句。总是除二障成二严。行修具足故也。下德圆中有七。一摄十地。二具十度。三多三昧。四妙总持。五六通。六三明。七清净法总结也。下果德中二。先依正三业果。后力无畏等摄众德差别果。下利他中四。初一句应机现刹具足。二随成就众生下以正行摄生。于中初随成行缘。二及诸菩萨下正结行法有五。一胜德。二所轨。三依法造修。四行能至果。五广摄所缘及分齐。皆悉满足。是总结也。三速成等者明行有辨果功能故云速成也。四成护法行有四。初句总明护法行。云何护耶。下三句别显。一广说教开示义。二不为异道所侵。三自具文义总持常说。顿说而无穷尽。上来内德圆。下明外敬护中有二。初总举世间十王及佛法王守护。二别显中三。先一切世间等显前十王护。二常为下显法王护。三一切菩萨下明同位护。行体德圆备竟下明胜用。谓依诸德有此胜用。于中四句。初增自无流法故云白法。即自成证行也。二能开等者以证法教人。三自具教行。四次第等教人教行。二偈颂中。四句成颂有十一颂。初一总请。下别颂。别中二。初一颂颂前文。二云何下正颂问后行法。于中初颂前十一种行法。二人雄下颂前依行所成德。于中初二句颂上善哉愿说文。次一颂半颂上行修离障。次二句颂众德备。次一句略颂果德法。次随其下三句颂上利他中行缘。次一切下一颂颂上护法行。后一颂上十王敬护。于中四。初智德无畏犹师子。二福德圆备如满月。三断德离染若莲华。四净果现前如最胜。此四亦是颂上善根力增白净法等胜用文也

第二答中二。初直说。后重颂。前中二。先叹问许说。后以法正答。前中二。先叹问。后佛子下许说分齐。前中先叹所问益。后叹能问者德。前中先辩益。谓饶益增善因。安乐授乐果慧利令得出世法利。后哀愍下结意叹能问中。先叹自分德有五。一称实慧。二不动而进故云大力。三无间修故云一心等。四位成就故云不退。五当位满故超出世也。又初句明有解。后四明有行。又此等亦是释进慧名可知

下叹胜进德。谓于问自在等如来也

下正答中二。先答前十一问行法之体。后答彼依行所成之德。前中依问次第答之。答初句功德转胜有二十句。初十始修。后十终成。又初是自分。后是胜进。前中已得发心之藏。牒前拟后也。应离痴等是总举也。又涅槃经云。不放逸根深固难拔。因不放逸根固一切诸善根皆得增长。不放逸有二。一约事如论释(云云)。二约理如法集经(云云)。下别中三。初标数。二列名。三结数。列中此中对治十种放逸。一破戒逸。二迷菩提逸。三失悲心逸。四懒堕逸。五乐諠杂逸。六乐世间逸。七乐劣善逸。八乐二乘逸。九染功德逸。十生绝分逸。如次十句对治应知。初者既得发心已要须持菩萨三聚净戒。然持三种。一不作三业恶。二不为名利。三不起戒见。此是标中守护也。二者不于菩提起有无等见而发心。此是标中离痴也。三依言摄物故离谄曲。四所作善根必使终成故云不退。此是标中精勤也。余皆不离此等三也。五者造业求生是凡夫行。菩萨离之常乐寂静有二种。一约身有二。一所住静。谓离家室喧扰等处。二能住静。谓持净戒离三业非。此以福舍罪离在家凡夫。二约心亦二。一所住谓真空妙境。二能住谓定慧之心。此以慧舍惑离出家凡夫。六厌背世乐。七专修出业。八虽求出舍二乘无悲救世之心。九虽修菩萨大悲功德而不见能所修故无污也。十知己身有四义。一知身从缘而有离我我所。二知己道行力若劣终不强对烦恼境界。三知力若强即须精苦作进修行。四定知已身有菩提种当得佛故。二胜进中。净法者谓练治前行使纯熟离染故云净也。十中一正念净。二舍离下离过净。三安住下正行净。四常乐下求法净。五随所下除疑净。六具足下智慧净。七心常下三昧净。八闻好下解空净。亦是向忍净。九等视下胜想净。十恭敬下报恩净。亦是敬养净

第二答令如来欢喜有二十句。亦初十自分。后十胜进。前中初结前。不舍下生后。于中初句牒下初五句。二心无倚牒下第六。修甚深法牒下七八二句。于无诤等下牒下第九第十。是故总标下十行。称可圣心故令如来欢喜。下别十中。初三修有行。初一勤勇行。次二于有中离过行。谓内身不惜外财不求。次三修空慧行。一加行修空。二正证照实。三后得分别而犹无倚。七常求菩提故名大愿。八胜相现前故云光明。九随有离过故云善知损益(云云)。十以无著心造履诸法故云清净也。下明胜进十法。修已成就故云安住。十中一对过不染。二证实舍相。三四慈悲摄物。五六行满离染。余四愿智具。一大愿具。二巧慧双行。三思择胜力。四达性无碍。故云无依止也

第三答菩萨所住功德亦二十句。初十自分中。一起行心。二正行行。三智顺理故超言。此上修始也。四近善友。五若不精勤虽近无益。六若不取意会法虽勤无益。又善取佛意者有三种。一约教。以二谛三性三量四理四悉檀四意四密六相六释八声五力等会取经意而受持之。二约义。谓言近意远。虽说法相诸门意在真理超言之处。三约行。谓意在灭惑成德。非但口言故也。七若不依行会意亦何益。此上修次也。八成大誓二严。九因位成满。十圆同果位。此上修终。胜进中二。先明观解。后摩诃萨作是念下明依解起行。前中初结前生后。谓善成诸地名巧方便。又于地不着亦名巧便。成地之要。故云先应修习也。十中初八是所成地法。初一总。二是诸地证智。三施戒等行。四所依净土。五所缘及分齐。六胜通及十自在等。七示现异身。八后智说法。此并诸地非一故皆云随其也。下明能成方便。谓虽分别而无著是方便也。由心造者释无著所以。谓知心外无法故无所著。心造有三重。一转识分别作。二本识随薰作。三真心依持作。皆心作故不有。心作故不无。是故无著也。菩萨若能下结能成地。下明起行于中三。先标。二释。三结。并可知

第四答清净行有二十句。初十自分中。谓十度纯熟出障故。净谓初施即无不舍。二戒即无毁犯等。皆明清净相也。前六可知。七巧成诸行故是方便也。八大愿坚誓尊重如山。此同下尊重行。九由思择力修习力说法除热。如世凉池。十智度摄生令同佛法。后胜进中。以后过前故云转胜。十中。初三宿成行。次三依缘行。后四悲智行。前中。一内有实德外感佛念。二由依护念更增胜善。三能同佛八相现粗隐细名密方便。又了达如来玄密之义。如王髻中珠等。又善解权密之教等故名安住也。次依缘中。一近善友谓身亲近心依附。二依善友起正行。三生正解。谓揽别成总故非总。分总成别故非别。全夺俱尽双融无碍。是故缘起俱非总别。后悲智行中。先一大悲。后三大智。于中。一实智。后二巧智。一成因巧。二向果巧第五答大愿满有二十句。初自分中所求皆得名愿满。一忍恼摄生。二严土为物。三于佛兴供。四于法守护。通论护法有四重。一护理法。谓照理不杂无明等。二护行法。谓行不杂名利懈怠等。三护教法。谓如法说授广宣流布等。四护果用法。谓存护形像等。五令物身生净土。六令物智入法门。七令他愿满。八无足修行。谓行尽未来际。令如须臾不生厌倦。又愿劫随心转。九愿因究竟。十愿果圆净。后胜进十中。一大誓严心不虑不成故无忧也。二仰念胜侣转起彼愿。三悉愿往生者顿起诸行。四究竟等常起所行。上自利。五化令愿满。六常化不倦。七处苦益生。八舍乐利物。九授以果法。十得果平等。上利他

第六答得菩萨藏。初结前生后。总有十句。谓以蕴德成藏深广无尽故无胜进。一见佛。二持法。即是持藏。三说法即辩藏。四悲普。五妙定。六胜用。七入证。八依证起通。谓以天眼见地伏藏及海中众宝。并知众宝出处价直等事。九佛加增德。十智达器界

第七答随其所应而化度之。先结前生后。谓称机授法名随应化。于中三。初知根机。二教离过。三教修善。初中亦三。初知众生病患所宜。二知宿习因缘。三知现在心念。二教离过中三。先一句总次九句别。第八由观自他平等不起慢于他也。第九心谄曲者多为名利喧心不直。菩萨知其非有故心静也。三如是下结。三教修善中。初一句总下十三句别显。于中初八自分法化。后五胜进法化。前中初二于法能说。一观理等而不违事别。二折事坏而不碍理存。良以理事虽复相夺俱尽而不碍双存故也。又释。分别是说。谓于平等法上虽更以异门种种别说而皆不失本宗故云先后无违。此是本末无碍。二说缘起法无性名破坏。而亦不碍缘起法界无所散灭。此是成坏无碍。已下于人能益。三化令生信。信除疑故欢喜也。四化令生解。解实理名入。下教令起行。五福行趣果。下教慧行。六破相行。七入实行。八无著行法皆依心。二边俱离故云无染。下明胜进化。九教以此无二平等之念念敬诸佛。此近佛身。十教自学软音而无所著。十一于他异音而无差别。此二学佛语业。十二学佛法教。十三具足下修佛智慧。此二学佛意业。下结可知

第八答不舍诸波罗蜜。先结前生后。此有二义。一虽常化物。而内心恒寂故云不舍自行。二为他行此。是故不舍自行。即是利他故云也。以十度中后四是第六中开出故但标六。又以后四严前六故云一切诸度具。庄严六于十中第二内。不倚戒以自高。又不执戒为有故令净也。三中初安受苦忍。闻恶无忧等耐怨害忍。闻好无喜法思惟忍。未曾等双结违。四中初勤修佛因。究竟下勤修佛果。五禅中一入定体。舍欲等是初禅。次第入是后三禅。此是事定入而不着故云无染。下明灭惑出定。是理定。下明定用起通。二超次。谓于八九次第入。及超越入。此是上事用。三入一知多。四渐具智德。此二是理定用。六智度中。初求闻慧。次所闻等下明思慧。次入真等明修慧。上是加行智。次妙善等辨正证智。次具足等明后得智趣佛慧。七方便中有六种方便。皆以悲智相导巧无住着故。云方便。一悲示威仪。智离爱见。二悲现身。智无染。三悲外示童。智内具黠。四悲现缚脱。智巧不取。五悲智现严。六悲能入趣。智了所行。八愿中有十。一一皆愿尽彼原际。各云究竟。初化众生愿。二净佛土愿。三供养佛愿。四摄智慧愿。五修法界行。六大志愿。谓以志力修上行时尽来劫住谓若须臾。七修促愿。谓愿以长劫为促。上句但转能见之心。此回所住之劫。是故上句有住字此无也。八成坏愿。谓愿解达世界成坏。一缘集成不作坏。二劫初成劫未坏。皆愿了达。九现净土愿。十成正觉愿。九力度中有十义皆有堪能。不可屈伏故名力也。一一各初标名后释义。初中释。内离烦恼等是离过也。具净等是成德也。此二成自行故名自专正。二释中。谓以胜力正理他时无能坏者故也。此二总举利他。三拔苦心满。四与乐心齐悉能覆护一切。是力义也。此二利他心。五持力内蕴法义。六辨力外宜应机。此二利他德。七大行具严力。八弘愿不断力。九因力多出。十果力普覆。十智度中。谓识病了根称理授法故云智。亦有十句。于中初四知病轻重。次三知根欲。谓一知病者学位。二知其心中串习所行。即根行也。三知欲乐悕望。次三知法药。初知境法。二知智法。三知境智无碍无边法门。故云法界

第九答所请众生皆能度脱中三。先结前生后。二教化一切下十句正显度脱。于中初一化出恶道。谓初句修善因后出苦果。二化出众难。谓精进修出因。超难出八难果。次三教治三毒。但贪欲有二种。一贪色教不净观。二贪财教离欲观。嗔亦二种。一嗔有情教慈心观。二嗔无情教平等观。以不称意无情物与称意物无二故云平等。愚痴亦二种。一顽无知教界分别观。二邪见愚痴教因缘观。以诸法从因缘生非自在等作故也。又以不信因果故教因缘观也。次三教化令出三界。初教离欲恚等。舍欲界至初禅等。二教增上观。舍色界增上至无色处。三教细微智。以照察细想令断尽。证空超出三界。次二句化令入三乘中三。乘初教寂静行有三义。一以彼二乘修离生死喧杂行故。二令修证入人空寂静行故。三无余涅槃名寂静。修彼名行。二教以十力等。是超过凡小严显大乘。三下释所请度义。谓如初发心举其本愿。指本曰如。见生堕恶举愿所为。大师子吼举其愿辞。誓言决定名师子吼。知病法济正显愿相。此中文意显从初发心见众生苦故以决定言请取一切众生誓悉度之。具足下结意可知

第十答兴隆三宝中三。初标。次释。后结。释中初九别后一总。别中九句为三重。有释云。初约教道。次约证道。后约不住道。今更释。谓初中后分三也。且约佛宝。初教发菩提心。次已发菩提愿者赞彼大愿令不退转。三令依愿起行使佛因圆故云下佛种等。因圆果发名生正觉牙。是故始终相继令佛宝不断。二约法宝者。初示深教法。次释理法。三护持等明行法。又释。初总示深法。次以法深难解故须解释令解法流行。三法既行已即加守护不顾身命。是故令斯法宝广行不绝。又释。初契经。次是对法。后是毗尼。故须严护。三约僧宝者。初受持威仪教法。是僧行方便。次行六和敬。僧行成就成行不乖曰和。行和相导曰敬。谓三业慈为三。同戒同施亦云同舍。同见亦云同慧。故有六也。后善御大众。心无恼。是僧德已成统摄绾御。是故能令僧宝常存。下总结可知。此中有三宝章。如别说

第十一答所为境界不虚。于中初结前。从菩萨如是安住下生后。于中三。初总。次别。后结。总中三。初语业不空。二彼菩萨下身业不虚。谓所作不谬是也。三如是一切下意业。智慧回向不虚。二别中三。初法。次喻。后合法中。初标。次列。后结。列中初五明自依正严。后五明法摄生严。前中初三三业即正报严。次二依报严。于中初明土离染。谓受用此土长道灭惑故也。后明土具净德。谓常有光明故也。后五。一摄胜众。二示神力令生信。三授圣教令生解。四化现成佛。谓涅槃者此非是圆寂之义。梵云泥畔此名化也。是此所用故应云化地严。谓是现化处故也。五量机授法。余结可知。喻合亦可知。上来答初问竟

第二答行所成德中有二十句。初灭愚痴是牒前问。具智慧故是答也。下诸句皆先举问后显答。二慈悲答降魔问。三慧功德力答制外道问。四入金刚定除心习垢答离尘垢问。上来离过行也。五于先佛所等答具足成一切德问。六净慧满足答能离恶道等问。上六总是行修具足。七次第方便智慧力答诸地等六种名众德圆备。一地。二度。三定。四通。五明。六无畏。上来因圆。八白净法力答佛依正三业之问。九智慧分别速解诸法等答得佛十力等问。前句明依正相好果。此句明功德差别果。此二总明果满也。上来总是自利门竟。十愿力神力智力答随其佛刹问。十一随应受化等答随成就众生等问。十二菩萨如是修行等答修行成佛问。十三于无量刹等答护持法藏问。十四成就四辩等答分别广说问。十五于大众中无所畏等是牒问。具足增上般若是答魔不能坏问。十六次第分别等答摄持正法无穷尽问。十七具足大悲下答于一切世界悉能演说问。十八十王敬护略无答文。又此是行果故无答。又除佛无过等亦是通答耳。问十地满后受职菩萨方云唯除如来余无能过。何故此中位是地前十住之处即有此言。答此是圆教普贤位相陀罗尼法。是故一位成满之处即摄一切诸位皆尽。如下海幢比丘顶上佛说法处十住满后即补处成佛更不言入十行等者同此说。此据初位为言。如下小相品中从地狱出即到十地无生忍后位至离垢三昧前等者。彼据终位而说。中间二答位准可知矣。十九一切世间恭敬等亦无答。同行果故。亦可同在后门内通。二十佛子下答得善根力增长白法等问。于中初总举后释成。前中初身业胜利。次以慈心下意业胜。后具足辩才下语业胜。下释中有十一句。初六成自分因德。一成证智净。二如证而巧说。三于教能念持。四如念能巧说。五于已得法能记持。六于未得法能推求。后五成胜进果德。一得佛外力用。二得佛内实智。三得佛巧说智。四正说深法。五成佛胜智。谓具理量及菩萨愿智等也

第二偈颂中有二十偈。初十三颂前初段十一种行法。后有七偈颂后十八种行所成德。前中初四偈颂初二段。谓初一偈半颂所修转胜。谓名初发心住为初地也。已得发心功德之藏故云长养也。次句颂灭放逸。次句颂离痴闇。次二句颂菩提心不忘等。下二句颂如来欢喜。次一偈重颂修胜。初三句颂不退转。下一句颂离在家出家凡夫。余略不颂。后一偈重颂佛喜可知。次有二偈。颂次三段。谓初五句超颂第四清净之行。次具足诸地一句却颂第三所住

功德下半颂第五大愿成满。次半颂第六得菩萨藏。次一偈半颂第七随其所应而化度之。次一偈颂第八不舍诸波罗蜜。次一颂第九随所请众生皆悉度脱。次一颂第十兴隆三宝。次二颂菩萨所为不虚。自下七偈颂行所成德。于中初一偈半颂十八句中初九句因圆果满文也。次二偈半颂护持正法及广说等。次三偈颂第十八三业利益文。谓颂上于大众中安谛威猛坚固甚深说法除惑故也。下明所说契理故如来随喜所说合机故大众奉行。此上第三会竟

华严经探玄记卷第五华严经探玄记卷第六(尽此第四会)

        魏国西寺沙门法藏述

    佛升夜摩天宫自在品第十五

初释名者有二。先会名约处名夜摩天会约法名十行会。准释可知。二品名者。佛是化主。依体起用。赴机云升。应感何处。所谓夜摩。夜摩者若具云苏夜摩。苏者此云善也。夜摩此云时也。谓此天无日月可知时节。故大集经云观赤莲华开是昼青莲华开是夜。俱舍论释名唱乐天。亦名多戏乐天。天者是净义光明义。此天着乐全不念善。赖有孔雀王菩萨。及彼天主名牟修楼陀天王。每以开导。或实天失伴。悲泣告王。或化天堕水。怖令生厌故也。问前后俱是不离而升。应齐名自在。何故此会独标自在。答不动升游。此空居天过前地居故称自在。创越地居不同兜率故独标名。又约行入玄过前解故。以自在表之。又以解行相接故。次忉利而至夜摩。俱是内凡不同前信。以感果在此表行离相。故届此空天

二来意者亦二。初会来谓依解起行故。答前十行问故。是故来也。二品来者。谓明法是前会住极。升天是此会由致。邻接次第。是故须来。又明法解深起用入行。是故升天。故须来也。此约法辨

三宗趣中亦二。初会宗者。约人化主及助化。约法教事及义理。皆各体相用相融无碍。准前知之。但就行为异。二品宗者严处请佛如来赴感。是此所明

四释文者。此会有四品经。初二是序。后二正说。前中二。初是请佛序。后是赞佛序。又初是彼升天。后菩萨集。以佛是化主故于先。菩萨是伴次居后。又初果后因。初能化后所化故也。初中科文。一释同前会初说又释有七。初十方觉树法王同现。二十方诸佛各升夜摩。三十方天王各严座请佛。四十方诸佛受请升殿。五十方天王获益叹佛。六十方诸佛同升华座。七十方宝殿各皆广博。何故皆于十方同辨。以圆教法门亘周法界凡一法起必一切俱现。是故将说此法。理非偏局故致十方无尽同说。即一说一切说等故。此中有三重无碍。一一即多故。一树下佛即一切树下也。二动即静故。树下之佛即升天也。三动静则一多故。是故一切处不动升天也。此是十佛具德无碍圆融之相。非余宗所辨。思准之。文中前之二段同前会释。就第三严请中有三。初遥睹胜缘。二严座表根。三请佛显欲。严座中初总后别。前会一万此中十万者。表位增相。又前殿非宝此中宝严者显行可贵具德之相。别中有二十三句。初七辨器世间庄严。次十万天子七句显众生世间庄严。后十方如来下九句智正觉世间庄严。又释。初七外事严。次六内报严。后十法门严法门。严中。初句因相。二果相。三德相。四定相。五愿相。六胜相。七法相。八用相。九妙相。十教相。三请佛中。初结前后正请。第四受请升殿显机缘相契。先明此土。后类余方。第五天王获益中。亦先辨此界。后类余方。前中先得定益。后发慧益。慧中先忆自善根。后叹昔十佛显今处胜。理实过去一切诸佛皆同于此说十行法。然今为表位相渐增故。于前会十佛向前次第举此名称佛等十佛叹之。向后迦叶等向前诸余佛。非不皆曾同于此处说十行法。第六升座。第七广殿。并准前可知

    菩萨说偈品第十六

初释名者。自体妙因。行集文斑。教则显彰。故云菩萨说偈

余义并来意及宗。并同前释

四释文者。三义同前。初集众内。先此界后类通。前中初显所从来处。后佛神力下明菩萨集来。前中初分量远近者显位渐增故。前百此十万等。余分齐同上准之。二正显本处三世间相。世界同名慧者。用前解慧为行所依故也。佛名同眼者。表行心见法明白故。又表行诸度导引世间故也。菩萨同名林者。表行法界之行成法界之德。德高方树。行广称林。十度郁尔齐修万行森然潜发。法况相似故名为林。余文可知

第二放光中。足指是光出处。但足指有行住二力。前彰住此显行。故别也。余同前释

第三偈赞中。十菩萨偈即为十段。初一总叙此会事理。后九别显佛德义门

先德林者标别说人。以是会主故先首说。承佛神力显叹说所依。普观十方者四意。一地论云。显无我慢无偏心故。二显所说法遍十方故。三十方等化故。四十方夜摩同有此说。合会同时而方说故。十一行偈分二。初七总举会中事。后四叹佛自在德。前中初一颂此品放光事以近故先显也。次二颂前品中事。于中初一半颂此界。下半颂类余十方。次三颂此品中事即十方处通颂显示。次一颂不离觉树而至夜摩等。文人中是前一一阎浮也。道场是前菩提树下也。下四叹佛德中。初一叹佛德深用广。各半偈显。次二释前用广。谓一应世离世。亦各半显。二一多无碍。上半标下半释。此即现一卢舍那身。一切树王下现者是也。后一释前德深。亦上半标下半释。可知

第二悟因果益故名慧林。十偈分二。初一标章。谓上半举佛德难逢明值可庆。下半举众难遇显值可欣。离垢大人是菩萨也。后九释中。初一释菩萨众难遇所以。上半显自智明。下半辨益物胜。后八释佛德难逼所由。于中初六正显佛德。后二约解校量。前中初一明佛为灯破闇。二六度圆照三胜德超情。四寂用益生。五见闻获益。六因深果厚下明知解益中。初一寄对供佛校量解益。后一寄对广施以彰迷损

第三由悟殊胜法故名胜林。十偈分二。初四叹佛光深广。后六明照理见佛。前中初二举喻。后二法说。前中八句。初句喻佛成佛之时。二喻佛心垢障尽。三喻佛身放净光。谓日喻佛身也。四喻光普照。五喻光广多。六喻不知边。七喻智尚不知。八喻何况愚痴等。下法说中。初一显光广大。后一显光甚深。以同法性。下六中。初三离相。次一离性。后二释疑。前中一离三世相。二离生灭相。下半明观益。后诸偈皆准此。三离所有相。次一离性以从缘虚假。是故无性。无性故无所解也。次二释疑显无生。疑云若缘起无性何因有生。释云由所生故。所生即是妄想。以妄想依缘而起故名所生。由此妄想执故说有生。而实无生。此约所执性。又释。所生是果。由待对此果说因能生果。既依他无生因。亦无待故不生也。此约缘起性。又释。所言有生者是明如来藏随缘义也。由所生者由能薰薰故。是故随缘。能薰既虚。所薰不动。故亦无生。以彼能薰亦是心之所生故名所生也。此约圆成性。此偈是待所生泯能生。后偈类能。遣所生。故云所生观亦如是也

第四由信乐深理不惧恶趣故名无畏林。十偈分五。初二明闻信此佛所说法益。先辨所闻。此处者此华藏处也。又是此佛所说法处。上二句显广大。次句辨随缘。下句显不变。后一偈显闻信此法利益也。二有二偈。明闻余方佛法有益。先明所闻。初半显闻处广也。次句所闻深也。下句闻不忘也。后偈彰利益。上半牒前所闻。次句用之求佛。下句明求必得。故云究竟等也。三有二偈。明闻信过去佛法有益。各上半举所信。下半明信益可知。四有二偈。闻信现在佛法有益。于中初句能信。次二句所信。佛下句所信法。后偈显益。以得闻难故也。又释。前偈上半明信现佛。下半明信益。谓彼由此信成等正觉等也。后偈显法胜难闻也。五有二偈。总结上来一切佛法结劝修学。于中初偈劝持劝说。初句牒上法。次句劝持。次句劝说。下句叹胜劝之。后偈劝持劝行。上半劝行由劝修行成二严也。次句劝持与前别者。前由持故能说此由持故能行。下句明修行利益。谓得菩提也

第五离无渐分别故名惭愧林。十偈分二。前九别叹佛法。后一双结前二。前中初一叹佛所证法。上半法胜。下半信益。后八叹佛能证智有二。初一明证法周尽。上半明一切佛说自所证。次句明一佛慧证无不尽。是故难思也。后七明无证为证。于中初一标章。谓上半无证下半为证。谓上半中有五。一约智释。谓此正证无分别智。不从世间分别智生。亦不从愚痴及色法等生。故摄论云。此智非智非非智。非智非是分别智。非非智非是色法。此中非智据愚痴也。二约境释。谓所证理智但为了因。非生因故。愚痴无智生了俱非故。皆云不生也。三约境智正会释。谓智如境故非智。境如智故非无智。四约寂照释。谓智即寂故非智。不失照故非无智。五约绝待释。谓智相尽故非智。无智可待故非无智也。下半中如此无智之智方能照法灭闇故为证也。后六偈中。初五释上半章。后一释下半章。五中皆上半举喻。下半法合。初一愚智性别喻。二同成虚妄喻。三二性相乖喻。四愚智缘隔喻。五用无相成喻。此五皆显愚智事别。俱不真故。迷悟斯绝智相尽也。后一释妙智胜用。中上半举喻。伽陀此云良药。谓能除一切毒。下半法合可知。后一双结中。上半结佛智胜。下半结上法胜

第六勤观理事而无分别故名精进林。十偈总叹佛照无差别智。初一总余九别。前中诸法性相无差别义。唯佛能知。然委细具知名分别知也。次句备知。下句深知。别中皆初喻后法。初一真妄交彻喻。谓依真起妄如金现色。非法是妄喻以金色。无体即真故性无别。又真心随缘为法非法。心体不殊故性无别。是故楞伽云。如来藏作善不善因。又涅槃云。与不善俱名为无明。与善法俱说之为明。明与无明其性无二。无二之性即是实性。此之谓也。又维摩经不二法门品皆是此义也。二两俱无实喻。谓众生约内报喻法。非众生约外器喻非法。皆无定性。俱不有。又释。以众生即无我故。众生不真。无我不碍众生故。非众生亦不真。理事相夺故皆不真。经云。于我无我无二者是无我义。又以众生即非故非相亦离。故皆不真也。法合可知。三生无灭相喻。谓生法即无生。犹如无灭相。又此未来当相即无。犹如未来无过去相。四灭无生相喻。谓生法即不生。犹如已灭法。又过法即无过。犹如无现未。五法体离取喻。谓涅槃离相故不可取。约报烦恼灭处说余无余。而实灭理无有差别。六性无差别喻。谓数法不殊法同空性。七随缘成异喻。谓以十数为本。增至多十。智慧于上作百千等解故云差别。然于彼数皆是诸十故云皆是本数。况彼真理随缘成异。求彼异法不异一真。略无法合。八体坚无坏喻。谓虽同有为而恒常湛然。九执异乖同喻。可知

第七达世间空名力成就。林偈意明会染净空。显叹真佛。十偈分二。前九会境。后一成行。前中初六约缘起性以显无生。后三约所执性以显无相。前中二。初四显世法不生。后二类显出世。前中初二生空。后二法空。前中初一偈半推末归本。后半以本显末。谓心随薰变以作众生。心既如幻不真。即心众生宁容有实。下二中。初由不知世间虚故还复轮转于空世间。后由不知世间苦故而常流转于苦世间。此中世间非自作非他作。有四重。一约外道(云云)。下二类出世中。初标。谓翻此世间名为出世间。世间既空。宁有出世而可取耶。故云二俱非真。上半理实。下半情妄。后偈释中。初三句释显世空。下句无世对故。出世亦不真。又准此文。但遮世名出。无别表示故亦空也。二约所执无相中亦二。初二世间空。后一类出世。前中初一征情后一显理。前中初句征体。次句征相。下二句明凡迷失。后偈中。上半明情执无。下半明理性显。后类出世中。佛及法是出世。并约情计。俱无所有。下明成行。上半灭妄见真。下半明法佛常现

第八照佛法身名坚固林。叹佛法身体寂。十偈分二。初七显法。后三成观。前中初二标能所二章。先显所叹体寂。谓地生草木。然于地中求草木种实不可得。喻佛应机现有差别于佛求别意不可得。故下云无量身非佛等。后显能叹平等可见。下五广释中。先三偈释前能叹空。一明业非有。二以业类身身亦非有。三以业身类识识亦非有。下二偈释前所叹非有中。先明应机大用。后明体非若干。下三明行益中。一证见法身益。二破相归真。三证实离相

第九由观心真如故名如来林。十偈分二。初六明心作凡。后四明心起圣。前中初四偈半举喻。后一半法合。前中初二是画师造画喻。喻妄法依真。次二明画心造画喻。喻妄依心。后半明画师不知画心喻。喻缘起无知。此中意说。一切众生皆依真缘起。本识之心随名言有支我见等薰。有六道身现。缘起虚假不碍无不坏有。是故会摄有其二门。若会缘从实即差别相尽唯一真如。若摄末归本即六道异形唯心而转。约初缘起不存。是真如门故。约后缘起不坏。是生灭门故。是故存坏无二。唯一缘起二门无碍。唯是一心故。起信论云。依一心法有二种门。一心真如门。二心生灭门。然此二门皆各总摄一切法此之谓也。今此文中画亦二义。一依壁故唯平也。二依画师巧心故似有高下也。初二偈明初门。谓初偈上半喻随薰布异。次句显异在妄情。下句相尽同真。四大喻真心也。彩色喻缘起虚相也。后偈上半明真妄不即。上句明能造非所造喻。摄妄之真不即妄。以性真故。下句明所造非能造喻。依真之妄不即真。以性虚故。下半明妄不离真。谓以虚彻真虚尽真现故云不离。是故不离不异不即思之。次二偈明画像依画心喻后生灭门。此画师心喻本识等能变之心。画色喻五蕴身所变之报。上半明能所不即。下半显本末不离。谓以心本形末所以不即。心变为报是故不离。此明心能变境。心体非境。境从心变。境相非心。从心变故。境不离心。能变境故。心不离境。是故虽不即不离而要唯是识非唯境也。问前偈但明彩不离四大。不明四大不离彩。何故与此不同耶。答前明真不变妄。此显心变于境。故不同也。后偈上半明画师工巧心喻能变识。无住为本故难思也。下半显所现画色喻所变相。各从心现无体可相知。后半画师不知此画皆从心现。喻诸众生迷自心量。下一偈半法合可知。第二明心起佛中。如心佛亦尔。将凡类佛。如心造凡作佛亦尔。皆从心起。如佛众生然。将佛类凡。下二句会以显同。谓心作佛。心佛无别。心作凡夫。心凡无别。能所依同故云无别也。又释。此是第二结劝修学中。初一偈融结本末。本末有三。一唯本谓真理以就性净本觉名佛。二唯末谓所变众生。三俱谓能变之心。以依真能变故。此三缘起融通无碍。随一全摄余。性不异故云无差别也。次一举益劝修。上半明佛已知。举上劝下。次句劝下同上。下句结明知益。次一偈明身心不即不离。上半身心相别故不即。下半依心现身故不离。下一偈劝修。上半举所求。下半劝依理观。谓此会心入实则是如来。返此为去故也。又释。亦是心变佛相而现故也

第十知佛体用深广故名智林十偈分三。初三叹佛法身离相。次一明能叹佛得大功德。后六叹佛应现色声。前中初一明离六尘相。谓初句离香味触三尘故云不可取也。次句离色尘。次句离声尘。下句离法尘。次一离量无量相。无量是多。有量是少。皆是妄计俱不可取。次一离言说相。有二义。一谓如八时不应说而说故自他无益。二不知法身非言说境。而谓如言而为他说则堕有无。四谤等故欺诳自他。如下随声取义五过失等是也。上二偈明法身心行处灭。此偈明言语路绝故不可思议也。第二一偈明叹佛所得功德可知。第三叹佛应现德。六偈分二。初三明佛身相。谓无身现身身则无身。后三明佛语相。谓无声现声声则无声。前中一所现非真喻。谓如如意珠以黄衣映则作黄色。此有二义。一珠非黄而现黄。二所现之黄非实黄。佛身亦尔。机映而现。二义同喻。故下句答云佛亦如是也。如智慧庄严经广说此喻应知。二能现离见喻。谓依空现色而空非可见。喻佛应机现色而佛非色不可见也。下一举法合。谓佛地。大智有二义。一圆明义前喻显之。二离相义后喻显之。皆有应机现色。而非色故云莫能睹也。准此文。自受用身无色等粗功德明矣。佛地论(云云)。第二明佛言声中。初一明非声非不声。各半偈显以依诠会实。故云离声不知也。次一叹深劝学。庄严无上道趣实之益。远离诸妄舍虚之益。后一明非说非不说。各半偈显。可知。亦是佛地无说说在机缘明矣

    功德华聚菩萨十行品第十七

初释名者。十度利润体名功德。有庄感之功如华结果。众行交饰如华聚。又德是行体。华是行用。聚是行相。菩萨是人。有彼德者则有财释也。此是功德林之异名。如下金刚幢回向品相似。十行是位法则带数立名。菩萨之十行亦依主受称。人法题章

二来意者。前序分既彰。正宗宜显故也。又前众既集。次正说授故次来也

第三宗趣者有三。一明约三乘寄位法。二明别行法。三一乘普贤行位法。初中诸圣教散说多门统收有十。一因果二度中是因度位。二七阿僧祇中地前三内第二精进行僧祇摄。三地前四行中成破虚空器三昧行。四法身四德了因中成乐德了因种。五地前方便四人中是第三十行人也。此上并如梁摄论等说。六六慧中是第二思慧位。七六忍中是行忍。八六种姓中是性种性摄。此上并如本业经等说。九三持中是行方便持摄。如瑜伽地持说。十地前除四障中是第三伏除声闻畏苦使得银轮王报王三天下。第二明其别行者。仁王经第二性种性位有十心。谓观身受心法不净苦无常无我。三善根则施慈慧。三意止谓过去因忍现在因果忍未来果忍。已过我人知见众生等想及外道倒想所不能坏。本业经亦同。又行有二种。一通谓信等十行。二别谓此十度。此中明别非通。别中复二。一因。二果。此中明因波罗蜜也。此并约三乘教中寄法显行。第三就圆教明普贤行者。则此十行中具摄前后诸位中行。一切皆尽。是故此位满际则至究竟位。如第十行满云入因陀罗网法界自在成就如来无碍解脱为人中雄大师子吼为法轮王转无碍法轮等。解云此是究竟中菩萨犹非是佛。以果分当不可说故

第四释文者。此正说中有二品。初品明其所行。后品显其所成。又初是约位阶降行。后是通相始终行。又初是位。后是行。又初自分。后胜进就初品中七分同前。一三昧分。二加分。三起分。四本分。五说分。六证成分。七偈颂分。何故尔者。欲明依证起说故先入定。显法殊胜故佛同加。说时将至故从定起。言不顿彰故略标本分。非略能具故后广说。显所说称周故结证究竟。于所说法令易受持故有偈颂分。初中何故入定者有六意。同前释。此中三。先举入定人。谓行成功德如林说十故不异名入也。二显非己力。谓推化归佛故云承力也。三正明得定。谓潜神证契故云入也。菩萨者标人别法简佛果。定善伏者举能显异。善有二义。一巧能义。二顺理义。伏亦二义。一制伏义。二调伏义。初是约障巧能制伏。令永不起故。云善伏。二是约行修行顺理。调伏之行故云善伏。三昧同前释

第二加分中三。初总显能加。二释加所为。三正辨加相。初中五。一明诸佛现身。二彰佛同名。三叹此得定。四明由加得定。五彼佛自释作加所因。初中。问此诸佛为当过万佛刹尘之外一处并有尔许佛。为当散居耶。答是散居。云何散耶。且如东方过万佛世界尘数刹外有一功德林佛。从此向东复过万佛世界尘数刹外复有一功德林佛。如是向东展转数至万佛世界。尘数诸佛各各相去。数亦同前。如东方余九方亦尔。又多佛加者增长大众敬人重法心故。又显诸佛聚力同说故。二佛名同者四意同前。一令功德林增踊悦故。二彼佛同得此法故。三显此位中具因果二德故。四于此门为能加佛。法尔皆得功德林名。以法力故。三叹此得定中。乃能者是希越之辞。显能入此希有之定。何故尔者。以功德林默入斯定。众既不知所入是何。无心渴仰不得为说。须佛叹显起众欲乐。四由加得定者。谓彼他方诸佛自说彰已作加令其得定。五释自作加所由中有三句。初由卢舍那本愿力故是故作加。何者地论释。舍那过去曾见有一卢舍那佛加菩萨说此十行法能加佛同名功德林。因则发愿。愿我成佛亦有斯事。今如本成。是故加也。二云亦是舍那现在威力相感同加。是故加耳。三云又诸菩萨善根之力应闻此法感佛同加故也。又前说十住则云以法慧善根力故。今云诸菩萨者显前劣此胜故多也。又前显自利增。此显利他广。又是文绮互影略。理实齐有。第二明加所为中。初句是总。谓欲令汝广说普贤十行法界前后诸位及诸因行。无不此至。无不此收故。云甚深。甚深有九种。一养果深。谓长本有之因令成果故。此约自智。二照性深。谓分折众生性类差别故。又知性种异故。又于众生如来藏性开示解释故云分别。又知一众生则具一切法门及一切众生。以性融通而分别故。如下文第八行中云不离一众生着多众生不离多众生着一众生不增众生界不损众生界。乃至云菩萨深解众生界法界无二无二法中无增无损无生无灭法性真实。如是等此约所知。三除障深。谓障约烦恼碍约所知。种现正习无不尽故云离一切等也。若依三乘此中寄伏声闻畏苦黑障现行。四入法深。谓证入真理境不碍心故云无碍。下偈云悉入诸法界随顺到彼岸究竟得自在法日之所行也。又亦能入帝网法界相即相入圆融自在无碍之境。下文云入因陀罗网法界自在成就如来无碍解脱此之谓也。五巧便深。谓巧以一法摄一切法。又巧以一行一位各摄一切。一身赴一切有无俱不滞。如是多门善巧故云成就一切方便。下云穷尽诸佛方便大海故也。六成果深。谓能成就种智果故。前养据始此成约终。是如量智种别而知故。七理智深。谓如理智觉一切法皆同一性故也。八知根深。谓善知众生根器差别。又知生熟不同。又知同一如性。又知一根则一切根等。如诸根海说。九闻持深。谓成十种大陀罗尼。如下第九行中说。下一句结。谓广说如上。总别十种甚深之法是何位法。所谓菩萨十行是也

第三加相中三。初一句告说是口业加。二意加中二。先加后释。此并当时有事无说。结集者如事而结之。前中十句。初一总余九别。问何故此中与法前与智耶。答所与是一。但前会为成解见理增故名为智。此中为成行轨范增故名为法。总中谓起说自在名无障碍。又与无碍辩令说无滞碍故也。下别中。一于法不疑情无异缘故云安住。又与无畏智令说时心安不惧他坏。二解发自中故云无师。又与同佛智令对众说同佛无师故也。三见法分明故云无痴。不杂无明故。又令说时无所知障碍故也。四见法次第故云不乱。又不杂余乘及世间章句等。五所解真正故云清净。又智体无过。六所解广多故云无量。又是称法界法门。七所解深胜故云最胜。又与果法相应。八令说时不慢不谄不懈不贪故云无垢。九所得不忘故云不退。又言无退失。又无退于理。又无退屈故也。下释偏加所由并身加及起分。并同前释

第四本分中二。先行体后行相。体中行业不思者标体显德。谓此普贤圆融之行具德超情名不思议。此行不思总有十种。一广大故。谓以一切身于一切处遍一切时念念顿修称法界行。是故此行名不思议。二甚深故。谓此广大行则是思数皆无自性。则同真如。而彼行相宛然不失。是性起之行故亦不思。三殊胜故。谓超过余乘非下位图度故亦不思。四摄位故。谓此在地前能摄一切前后诸位名不思。五证理故。谓此行能证不思之理名不思议。六断障故。谓此行能顿断难断不思之障故。七利他故。谓此行能一念广利尽穷众生界故不思议。八圆融故。谓一行则一切行一切行则一行难定量故名不思议。九重成故。谓此所作如因陀罗网重重无尽故不思议。十成果故。谓能成佛不思之果故亦不思也。所以辨十欲显无尽。如下偈中大龙所行等准知。此约圆教辨。若约三乘则不得作如此释。以此犹是有漏位故。广如法界究竟如空者显前不思之相。然法界有十。如下说。今举二门以释此行。谓行宽名广。行深曰大。此广此大皆称性成。故曰如法界。虚空亦有十义。如下第八地虚空身处说。今亦举二义。一行能破相证入毕竟法性虚空故云究竟如空。二行能出生无量爱果如依空现色色无尽故云究竟如空。下释中先征后释。以此行是三世诸佛之所行故是故如此也。又释。前行业当观相善决定。不思当真实善。法界当胜善。如空当因善。学三世等当不怯弱。余同前会释

二行相中先标数显要。谓三世诸佛同共说故。二列名。此十行之义略作十门分别。一释名。二体性。三建立。四种类。五修相。六定位。七行相。八所依身。九所离障。十所得果

初释名者有二。施戒等十从行体为名。欢喜等十约行用为目。今辨后名。于中总名如品初释。二别名者施悦自他名为欢喜。欢喜则行名欢喜行。此约自喜。是持业释。又亦欢喜之行名欢喜行。此约令他欢喜。成自行故依主释也。二净持三聚双益自他。三忍力息除自他恚恨。四精勤修摄胜德无尽。五止观双运痴乱斯绝。六般若照理善现朗然。又观法实相般若现前。七巧起胜行于空不滞。又以无著之心起诸所行。八无碍大愿摄胜善根深可尊重。九深达根器善于法化。十言行相应不空受称。又此十中得名有三。谓第八从德立名。第三第五第七约离过受称。余并从功能为目。可知。二体性有二。先总后别。总中有三门。一约所依。以善伏三昧为体。以依此定证十行体然后说故。地论云此三昧者是法体故。二约本。以本分中行业不可思等为性。此是思数广大等十义如前释。以是广说之本故为体也。三统收。约境二谛双融。约行悲智无碍。复心境圆融。无碍法界具无边德以为体性。思之可见。二别辨体性者各如下释文处辨(余门待别作)

第五说分中释十行有二分。一果分同性海平等不可说故此中不论。二因分约缘随说有四重。一唯约比位行。如仁王经及本业经等说。二唯明自体普贤行。如下普贤行品说。此不依位。三以自体行从位而说。即如此中长行所说。四会摄位相从于自体圆融之行。如下偈中说。今说分中唯辨后二。文中有二。初明此一世界十行。后如此下明十方界中十行。以此一说则一切说故合为一部。前中有二。初正辨十行。后动地等显说益相。前中别释十行。即为十段释初行中作六门

一辨体性有三。一约随相亦三。一以无贪善根。二彼俱思。三兼取三业无表。假实通论此三为性。此约初教。二约性或以真如为性故。起信论云知法性体无悭贪随顺修行檀波罗蜜。此显顺同法性之中无贪之功德故也。此约终教。三约实准下文于施门中所摄无尽圆融法界为性。此约圆教

二明种类者。施有三种。谓财法无畏。财中亦三。谓外内俱。外中二。一无过之物随索便施。二有失之具。谓刀杖罥网毒药等皆不应施。增不善故。二内中亦二。一约自破悭心于彼有益则便施与。仍亦有二。一施身力等。二施支节等。二若自悭已破于彼或虽有安乐无饶益。或俱无等于余有情有广利乐则不应施与。或天魔等故欲损害菩萨而不与无犯。以救彼恶业故。此上并如瑜伽等说。或初心菩萨未能耐苦。且许而未与是亦无犯。故十住论令说偈安慰彼乞者。言我初发道心善根未成就愿我速成就后必当相与故也。三俱中亦二。一身及王位依正同舍。故云内外施。如十藏说。二吐食及发抓皆亦内外施。如瑜伽等说。二法施至下第十回向于彼当辨。三无畏施者。或以财施济危。或施法存躯。或施二免苦。皆则无畏施也。或俱非。谓于怨不酬等。或救拔苦厄。总说有二类。一根缘相应者救之。二作业受报二种定者暂时舍之。又此施种类瑜伽地持九门。十藏离世间各十门。第六回向一百二十门并如彼等说

三收摄者有二。一约三檀摄六度行。谓财施摄初。无畏摄二。由持戒故应杀不杀。由忍故应酬不酬故。法施摄三。谓勤说一心说不倒说故。由方便等四助前六故。是故十行总在初摄也。二只一财施亦则十度及万行等如下第七地中说。应知之

四因果者有三。一随分果谓大财等(云云)。二位果谓地前因地上果(云云)。三得佛果。佛性论第二云。舍有二种。一由昔舍物施他今即损于贪爱。二由昔舍法施人今则轻灭无明。由此舍故贪爱无明并稍轻薄。以是因缘得解脱果。又成佛果大功德聚等。如贤首品说

五秘密行者。商主天子经云。又复问文殊师利汝宁悭耶。答言我实为悭。又问何故。答若心不舍是即名悭。又问云何不舍名悭。答我常不舍诸佛法众而不舍一切众生。以是义故说我为悭

六释文中三。谓标释结。释中二。先明财施。后观察下明法施。前中北台意法师云。先明行体。后从菩萨修欢喜行时下净治此行。又释分三。初明行顺理自庆欢喜。二菩萨修下遂物求心令他生喜。三从离诸我想下明离三轮以成檀度。初中先释后结。释中三。初正行施行。二简其所离。三显其所求。前中三。初施主者。对法论第八云。为大施主者此显数数施义。由串习成性。数数能施故为主也。舍离一切释显主义。则是解脱舍舒手施也。二等心等者。是论中无偏党施义。三者行成大喜故云无悔。二所离者是对法中无染意乐也。于中四句。一不望未来资财之报。二不求现在名闻。三不期当来人天胜处。四不悕现在利养。三所求者既不求报等为何事耶。下十句显其意。一救现贫苦。二摄令向道。三益令修行出离之行。上三是以施物摄生。四学习诸佛本昔所行。是自分始。五正忆。是自分终。六胜进始。七是胜进终。上四是随物而行。八弘显。此行令他施习。九兼行而说。令他受学。十结传授意。上三以行益物

第二对缘行施生众生喜中二。初总以标举。二随方下别显其相。于中有二。先明修施方便。后于念念下正明成行。方便中贫处者是依止苦田。愿生者是依止愿。对法云依止愿修。谓由依止本愿力于波罗蜜多修习正行。豪贵者是对法依止报修。由胜自体力于波罗蜜多修习正行。财无尽者是依止大财修成施行。二于念下正明施行中。依对法论第十二中。菩萨依止六种意乐修波罗蜜多。一无厌意乐者。谓诸菩萨于一有情一刹那顷。假使殑伽沙等世界满中七宝以用布施。又以殑伽沙等身命布施。如是经殑伽沙等大劫。如于一有情所如是乃至于一切有情界如是施时皆令彼于阿耨多罗三藐三菩提速得成就修行。如是差别施时。菩萨意乐犹不厌足。是名菩萨于施波罗蜜多无厌意乐。二广大意乐。谓乃至菩提施无暂息等。三欢喜意乐。谓遇受施者等。四恩德意乐。谓见受施者于已有恩以助我菩提故。五无染意乐。谓虽于有情兴大施福而不希报恩当来异熟。六善好意乐。谓广施之果皆施有情。又以此福共诸有情回向菩提。具说如彼论文。此文有四。初明无厌意乐及广大意乐。无财曰贫。空尽曰寠。二从不以求索下明欢喜意乐。三作如是念下明恩德意乐。谓生我福故名福田。起我行故名善友。我今应下结报其恩。四从我于三世下明善好意乐。于中三。初用行成果以济众生。二施福与生令先成佛。三然后自得可知。第三明离三轮着成波罗蜜。于中二。初观解破执。后如是观时下观成舍相。又释。初通离二执。后别泯三轮前中先七句明离人执。于中福伽罗者此云数取趣。谓数数取诸趣故。旧翻名人是也。依瑜伽第八十三有八名。一我者于五蕴起我我所见现前行故。二有情者谓诸贤圣如实了知。唯有此性更无余故。又复于彼有爱着故。三意生者谓此是意种类性故。四摩纳缚迦者谓依止于意或高或下故。五养育者谓能增长诸有业故。能作一切士夫用故。六补特伽罗者谓能数数往取诸趣。无厌足故。七命者谓寿和合现存活故。八生者谓具生等所有法故。依大般若有十三名。八同瑜伽。更加五种。一作者。二受者。三见者。四知者。五士夫(更检三本)般若论中释。二法界下七句明离法执。一谓众生界空与法界无别。二体空无取故云离欲。三性无定实。四相无所有。五不能自住。六非可依据。七缘成离作。二观成舍相中九句。初三见三事空。庄严论云。施有三碍。谓我相他相施相。着此三相布施是世间檀非波罗蜜。以于世间中不动不出故。离此三著名出世波罗蜜。以世间中能动出故。四不见生福之田。五不见所生福业。六不见因施得异熟果。七不见得等流果。八不见得佛地大果。九不见于菩萨地中所得小果

第二法施中二。初念伤物苦。二起意饶益。前中谓观三世众生。一无明所覆。二四住所缠。此具苦因。三受深苦果。四明阙正济。谓不得佛三坚之法故也。我当下起意饶益。于中先自修佛因化他同习。二自当成佛令他同得。令净对前苦因。顺灭对前苦果。下结可知

第二饶益中亦作六门。一体性者三门。一随相门。谓于思上假立无表。亦有三事。一思。二无表。三身语表业。故论云菩萨戒以三业善为性。二约本亦以真如为性。起信论云。知法性体净无染随顺修行戒波罗蜜。三约实以无尽法界为体(云云)。二种类者有十类差别。一依梵网等经有菩萨三归戒。二依善生经五戒。是在家菩萨戒。三依文殊问经八戒名世间菩萨戒。四亦依彼经十戒。谓即沙弥所持者名出家菩萨戒。五依方等经二十四戒亦在家菩萨受。六依璎珞梵网十无尽戒通在家出家菩萨所受。七依瑜伽地持四波罗夷戒。观此戒相多分似是出家所受。亦兼在家。八善戒经及重楼戒经等八重戒。谓声闻四重上加瑜伽中四重。故为八。此文局为出家菩萨受。以先受五戒十戒具戒方得受菩萨戒。如四重楼阁渐次成等故也。九依梁摄论戒学云如毗奈耶瞿沙毗佛略经说。菩萨戒有十万种差别。十依华严经有十十等无尽戒品。如十藏品及离世间说

三摄行中。依瑜伽论。七众所持解脱戒是菩萨律仪戒摄。六度十地等是摄善法戒收。四摄四无量等是饶益有情戒摄。又有摄义。如对法论第十二中说

四得果者亦三。初随位得果。摄论名大生摄。故谓即由戒所得胜利胜善趣摄。二由此资粮当得地上所得胜报及自性戒。三得无上菩提果。谓由律仪戒得断德法身果。由摄善戒得智德报身果。由益众生戒得化身恩德果

五秘密中菩萨亦破戒。如商主天子经云。又复问云如我惟忖文殊所说。汝于今者亦是破戒。答言我亦破戒。问何故。答若人破戒彼堕三恶道。我故思惟堕于恶道成就众生。以是义故称我为破戒

六释文中三。谓标释结。释中二。先略辨离过以明行体。二菩萨如是下对缘广显坚固行用。初中亦三。先举净戒行。谓自持净戒不染六尘。说此化人成二利行。下显二意。先明所离。后但坚持下明其所为。其所为中尽不为求世间胜报为何事耶。为有四种。一为离生死大过患故。烦恼等是苦因。悲苦等是苦果。此是律仪戒所离。二下于众生不违悲愿故云不负。谓称本弘誓而救拔。故此摄众生戒所成。三上顺佛意故令欢喜。此是摄善法戒所成。此上是因圆。四为菩提果满故也。第二对缘广显中有三。先明难持能持。则律仪戒。二从作是念众生长夜下明难救能救。则摄生戒。三从我当舍离下明难作能作。即摄善戒。前中有六。一非其境逼。二尔时菩萨下深见其过。三是故下明心坚同佛。四不违方便而内心逾坚。五不为下释显坚相。于中先顺释。宁舍下返释。六自见佛下举轻况重。谓从自昔初发心来名见佛来。中间至今未曾起想。是举轻也。何况从事是况重也。谓想尚不起况有形事。下返结其无。二明摄生戒中三。初念众生为欲所缚。二我今下建志标其所作饶益。三观一切佛下依标顺理以法正益。前中五句。一未得思求名忆念。二创见缠染名贪着。三得已深味名爱乐。四久处不舍名常流。五于后不厌名永没莫能出也。二标意作益中二。先标所作。后何以下释显其意。前中三。先立地前净戒。二令得地上不退。三成菩提涅槃果。下释中。先征意他人有恶于已何急。下释。此是我业。谓令众生立于净戒乃至涅槃。是诸菩萨家业法尔。是故应作。三世诸佛本在因时亦同作此。安人净戒乃至涅槃故云离诸非行。下伤已不及行之太晚。由我无知昔来不作。今始方为。犹恨迟耳。三依标顺益中亦三。初总明得平等法为说除倒。二不离众生下辨释倒相。即是平等。三悟一切法下明观解之益。第二中众生是依他缘起性。颠倒是妄想所执性。谓依似执实。不离生有倒依执似起。不离倒有生。二倒能起生倒内无生。生能起倒生内无倒。三倒从生起而非生。生从倒有而非倒。四即生非倒。倒非内。离生无倒。倒非外。五生亦尔。相依相夺俱非内外。空无所有下类余一切法。皆是虚妄不实。三观益中。先自知之益。未度下化他益。于中九句。一令度苦。二令脱集。三授与戒学。四与定学。五与慧学。六令离粗惑。七细习亦尽故云清净。八令得涅槃。九得菩提。第三摄善戒中五。一起愿心修善上顺故令佛喜。二出所喜事成就佛因安住佛果。三成观解谓觉众生平等了法亦空。四远离染障。于中离恶是舍业障余是烦恼。五成就净德。初句是因。悉得下成果。初得教智。后空慧是证智

第三无恚恨行即是忍度。亦作五门

一体性者。瑜伽论云。忍有三种。一耐怨害忍。以无恚善根相应慧数为体缘众生为境。二安受苦忍。以精进相应慧数为体缘法为境。三法思胜解忍。以定慧二数为体缘无法为境。以正智入观境智同如故。又通论四法为体。初无嗔。次勤。后慧并思。是三业通前故也。又起信论知法性体无嗔离恼故随顺修行忍波罗蜜

二修忍方便者约初忍。庄严论云。由三思五想即能忍受。三思者。一思他毁我是我自业。若报即重自造苦苦不由于他。二思彼我俱行苦。以彼无知于苦加苦。我今有知云何复尔。三思声闻自利尚不以苦加人菩萨利他岂得以苦加物。五想者。一修本亲想。一切众生久来无非亲属故。二修法想。打骂者不可得故。三修无常想。众生性是死法尚不应嗔。况加害。故四修苦想。众生不离三苦。止应令离不应加。故五修摄取想。本愿令乐不令苦故。又智论云。若被毁害但思对治法不应起嗔。如遭风雨但求遮法而不嗔之。广如智论有多门辨

三种类者。或唯一。谓忍度。或二。智论云一众生忍二法忍。或三。如前。或五。谓信忍等。或十如下十忍品及离世间品说

四秘密者。商主经云。又问文殊汝有嗔恚心耶。答言如是。又问何故。答宁不嗔心。是不爱耶。答言如是。文殊言。我于烦恼二乘无有爱念。以是义故我有嗔心。余门如别说(云云)

五释文中。释内初标行显意。二菩萨成就下对缘辨相。前中初一句总以标举。谦卑下别显。先显自行。后教人。前中先约三业性有忍想。谓自谦敬他是心忍相。和颜是身忍相。爱语是口忍相。下约离三毒现成忍相。初约离嗔。谓不自害等。自有苦事不能安忍。自刑害等。违安苦忍行。于怨不加名不害他。此是耐怨忍双辨前二故云俱也。智论有二忍。一于违能忍。二于顺能忍。上是违忍。二约离贪。于顺能忍。谓不为名利起慢自高傲他及俱并可知。三约离痴。不言自是离慢也。不虚是他离谄也。双离不俱也。又于所作自不言是。于所爱处不言是彼是。二俱舍不言两是。此是法思忍相。又释。约三业。初由和颜故不害。次由谦卑故不举。后由爱语故不是也。二教他化亦是显意。为欲教人断恶先自修忍。于中先教离过。二以大忍下成治行。谓具三忍治三毒等故云大忍。二对缘辨忍行相。谓难忍能忍。于中有二。先广举害辱。二于辱能忍。前中四。一多众生。二多骂辱。三多伤害。四经多劫。此难忍也。二安心能忍。于中亦四。一深见嗔过忍。二思往励今忍。三身苦俱空忍。四同佛摄生忍。初中遭苦生恚。反举不忍。下彰其过有八句。初七失自行过。于中。一不自调心过。二不护身口过。此二无戒失。三明无慧由嗔覆心不见法理名不明了。四由嗔暄心令不寂静。此障修定方便。五障修正定。六行虚非实过。上是妨善失。七增恶过。谓由自爱身不受他侵故致嗔恼以增恶业。下明失利他过。何能令喜明无始善。而得度脱明无终利。第二思往自励中。谓自思于往昔因护此身心。起诤造恶受苦无穷。今若不忍更重增苦。多劫无憩。以此自励令心喜忍。又释。由我有此身心为苦因故。令他得有所恼害事。苦本在已。何不自责。故涅槃经云。因手刀杖及以我身故得名打。我今不应横嗔于他。乃是我身自招此咎。譬如因的则有箭中。我亦如是。有身有打。以此自励。又释。我于往昔未曾不有凡愚身心。或由恶业于地狱等处尚无量劫虚受大苦无一饶益。况今受此小苦成就菩萨大忍之行。以此自励。故生欢喜。对前门忍说此为重。劝心不退励心令进。由见此益于辱喜受名心欢喜。调心离忿。摄不造恶故云调摄。下释调摄意。先征后释。为令自他住无上法故此亦是安受苦忍。第三身苦俱空忍中。对前二门说为复更思也。思益经云。诸法念念灭其性常不住。于中无骂辱亦无有恭敬。若节节解身其心常不动。知心不在内亦复不在外身怨及刀杖皆从四大起。于地水火风未曾有伤损。此中初是生空。无真实下明法空。此自观也。诸法空下明利他。方欲为他说空。岂得自迷不忍。是故下结可知。此亦法思惟忍也。第四同佛摄生忍中。先有七句念众生苦。后一句欲同佛救护。前七中。一愍其有恶。二益令修善。三安其乐果。四不令着乐故云摄取。五速令至佛故云不舍。此令至地前。六令得地上不退。七令得究竟菩提果也。下明同佛行。谓诸佛因时修行此法我今亦同方于众生作大饶益。何容不忍反加恼害。故云佛所行等也

第四无尽行即是精进波罗蜜作四门

一以勤思二法为体。依起信论知法性等

二种类者。依瑜伽有三种精进。一被甲精进是始修。二加行精进是次修。三无厌足精进是修究竟。以三业策勤为性。依此文及下离世间品俱说十种精进

三秘密者。商主经云。问文殊汝有懈怠。答言有。又问何故。答夫懈怠者不以身口意发修诸行。我今如是。亦不发行亦不欲行不舍不取。以是义故我名懈怠

四释文。释内有二。先标行显意。后从菩萨成就如是精进下对缘辨相。又亦前是当位行体。后是难行能行净治此行。前中二。先标行。后菩萨复作是念下显意。前行中二。先行体。二彼菩萨下明离过。前中初句总余九别。别中过凡名胜。二越小名最。三修善行极名第一。四化他行极名大。五离过行极名妙。六上能过下名上。七下不能加名无上。八下不能齐名无等。九过下同上名无等等。二离过行中离大小烦恼。通有十种。如文(云云)。上是被甲精进亦名勤勇精进。二显意中。初不欲恼生显其所离。后正显所为。此中有二十句分三。初三为断惑。次七为知所化摄生。后十为知法理。初中初句伏离现行。次句正害种子。后句离残习气知所化中。初一总余六别。别中初二知染过。一知苦报转。二知惑集因。后四知受法之器。一乐欲多门。二分齐差别。三根有利钝。四心所念异。三为知法中。初句总余九别。别中初四为知佛理法。一知如来藏具恒沙功德不空实性。二知如来藏在染当相平等。三约因位前后三际不殊。四在果净位亦无生平等。又此三亦是三种佛性。初约自性住。次约引出。后至得果。又初是地论中自性无生。次数差别无生。三佛果作业无生。次二为证果法。初句标。下句释。谓以一巧智门广摄佛果之法。次二欲知佛果大用法。一知佛无尽神通德。二知佛权实智慧德。方便是权也。后一句知佛教法。又亦得。初四约加行。次二约正体。后三约后得。又此二十句中。初三约自利。后约利他利他中。初七知所化器。次九知化法药。后一正以法授机。可知。第二对缘难行显行坚固。于中有二。初假举重苦以要问。显行。先二问后两答。二假以尘海令数要显。亦先问后答。答中二。初令他免苦利。后自他成果益。此上亦是摄论中难坏精进。瑜伽中无厌足精进

第五离痴乱行即是禅波罗蜜亦作四门

一以别境中定为体。起信论知法性等

二种类者。依瑜伽亦有三种。一现法乐住静虑谓八定等。二饶益有情静虑谓依此起四摄摄有情等。三引神通功德静虑谓能引十八变等。又下文有十种以显无尽

三秘密者。商主经文殊言我有乱心。何以故夫乱心者无有住处。我于圣中心得解脱。成就一切诸众生故无有住处。以是义故称我乱心

四释文。释内由修观离痴习止息乱。梁摄论云。诸菩萨于诸位中常修二行。一不颠倒。二不散乱是此行也。文中三。初是现法乐住禅。二是菩萨成就寂静下引生功德禅。三菩萨闻此下利益众生禅。初中二。先总后别。前中十一句。初二句标二章。谓初句标离乱后句标离痴。次八句历法通辨。相从为四。初一约所受持。次二约流转受身。此是悲愿留惑受身故不痴乱。下六地云死有二种作。一以不知故。令后生相续者是约凡夫说也。又大集经云。凡夫受胎。男于母生爱女于父生爱。是故入胎痴乱也。又在胎内情识分明出时苦逼。遂即昏乱。菩萨异彼。入出俱无痴乱等也。又瑜伽第二云四种入胎。一正知入而不正知住出。谓轮王二正知入住不正知出。谓独觉。三俱能正知。谓菩萨。四俱不正知。谓所余有情。次三约修道起行可知。后二约觉离魔事。以修止观时多为魔邪鬼等恼乱是故辨之。如起信疏中(云云)。下一句结多劫修也。第二别辨中二。先明离痴。后明离乱。前中初牒前。于无下显后。于中先由离痴闇闻法不忘。二何以下释成。前中三。初总。二所谓下别。后菩萨闻此下结。别中十七句法。一体深。二相妙。此二理法。三具德。四多德。此二行法。五教法。六因法。七果法。八欲愿法。九处世离染法。十巧分别于世法。此二智法。十一所知普遍名广法。十二所知多门名无量。十三明了剖折法。十四真通名共。十五俗别不共。十六因位所知有限量法。十七果位所知无分限法。下结。由离痴闇虽闻多法经久不忘。下释中。先征。后释有四句。一不恼他定。二常护正法。三修善不歇。四智慧常行故不忘也。二释不乱中二。初闻多声由无宿障。是故不乱。后如是等下闻广大声由善观察是故不乱。前中三。先闻六声。次明十二不乱。后无四障。释十二中。初八自行不乱。后四利他不乱。前中一知声体空故念不乱。然菩萨于六尘境悉能不乱。以高大声是动乱中强是故偏举。二正定不废。三所缘不错。四入理不错。五檀等常行。六本心不忘。谓习菩提愿。七念佛定。八证真理下明利他。一将起化智。二正成化事。三化所成益。四观化事空。虽闻彼声不废此等。本所常行故云不乱也。下释成所由中由无四障。谓前二不行惑业两障。后二尊人重法。故得如是。不为乱也。第二广声不乱中二。先总明广声不能乱。二释不乱所由有三。初寻思方便观。先观声相生灭不停。次观彼性亦不可得。后观能闻缘会为闻亦无闻者。二闻好恶下明如实离染观。三知一切下明正证法性观。于中先明相尽与法性等。后明性显此声非直不能坏乱菩萨正念乃与菩萨作入法性境反成长道缘非是乱心境。如幻三昧经中。假以大地为鼓。须弥为槌。于须菩提耳边一劫打鼓亦不能令微念心乱。何以故。入空定故。第二引功德中引成六种功德渐次增长。初明离乱得定。二离痴引智。三定增摄伴。四智增长悲。五定圆无间。六智满当果。第三益众生定中三。初益令离乱。二于一切下益令离痴此令成因。三究竟下益令得果

第六善现行即般若波罗蜜

一以别境中慧法为性

二种类者。唯识论云有三。一生空慧。二法空慧。三俱空慧。瑜伽亦三。加行。正体。后得。又有四慧。一能证智。二后得智。三利他智。四俱生慧。下文十慧以显无尽。如彼应知。又智论云。若无般若五度如盲。是以慧眼道余令得成波罗蜜

三秘密者。商主经云。文殊言我是无智。何以故。夫无智慧者不畏生死不悕烦恼共迷惑众生同处娱乐。我亦于生死烦恼中不畏不悕。共迷惑众生一处安住。同彼娱乐为成就故。是故称我无有智慧

四释文内有三。初牒前起后。二无所依下正明行相。三是菩萨住此下彰行益用。初中四句。初二合标。谓无所有三业体空。无所示现三业用空。后二开释。谓开染净。无缚染空。无脱净空。释前体空。下句开释用空。由此体用染净俱空名为寂灭身口意业。欲依此起观照达深理故先牒举。二显行中四。先明加行智。推相入实观。二不生不灭下明正体智。相尽证实观。三菩萨作如是念下明后得智。依实起相实无碍观。四以大悲随相摄化观。由是即实之相故唯相亦无过。前中初三句明唯识无相观。谓观所取相空。始无所依终无所住。何以知境空无依住。以随心住故。此明正住唯识观。此即依识遣妄境也。辨中边论云。依识有所得境无所得生。旧论云。由依唯识故境无体义成此之谓也。次明识体无生观。无量心等者观能取心性同一切所取法性同无性相等犹同也。此是依无尘以遣识。辨中边论云。依境无所得识无所得生。旧论云。以尘无有故本识则不生。此之谓也。示现无相相者印前所取空。谓无相之相现前故也。深无底者印能取识空。以识空为本。识尽故无底也。如如性者双印二空。谓心如境如。同一真性。虽于如中无相可起名离业报。然此加行能起正证故云善方便出生离生。离生则是证位。谓总结前加行有起证功能。自下第二明正证智。谓境智相如之理不为生灭所迁故云不生灭。泯同真理故云涅槃等。此明不有。不有即是不无故云非有说有。有无既绝言犹无起故云言语道断。简证异比。谓世智有依住。此中无倚故云离一切等也。自下显证益有五句。一增善益。由证真故令先所起善极倍增长故云长养等也。初刹那无流智起则更受薰成令其增益故也。二明断障益。谓顺证名入。舍妄名离。断烦恼障种名无缚。害所知障种名无著。三证真益。谓证昔未证之真理。四超位益。谓过世间也。五起智益。谓由此证理能起后智分别世法。第三明后得智中二。初明以理会事方便思求。二菩萨解如是下明理事无碍彰如实正解。先总次别。别中八句。初解世寂灭知妄体空。二解佛深法知真离相。三染净双融故等无别。四即染恒净世入佛法。五不染而染佛法入世。六染净门别故不杂。谓全体即净而不失染。举体则染而不失净。是谓染净不二而二。七释不杂义。以世法虚故不待坏不碍存。以不待坏故未曾不即佛法。以不碍存故未曾杂于佛法。故云世法不坏。八以佛法真故不可破不碍随。不碍随故未曾不则世法。不可破故未曾杂世法。故云佛法真实等也。又释。佛法虽入世间不为世法所坏。何以故。以真实法界不可坏故。问若尔何以不言世法入佛法世法亦不坏耶。答以世法入佛法可有坏尽故不论也。以真妄不齐故如此也。所以如此蹂蹋染净为欲常于世间摄化而恒住涅槃故。下大悲摄生而不乖观理者是此法也。第四大悲观中有五。初安住三世等明依理起悲。二建摄生志。三以己愍物四自诫不舍。五对缘正救。第二中五句。一我不成生谁成者化令成善。二调离恶业。三寂灭烦恼。四喜得因成。五净得果满。三以己愍物中。是一句显己所解。后正愍物苦有二。先明具诸重苦。二不离三障下无解脱乐。前中法喻合。法中见生。受苦是现苦。趣危径是当苦。此是苦果。烦恼缠是苦因。合法中。恩爱系是苦因。在生死等是苦果。此四恶趣义(云云)。其阎罗王依诸圣教说有五种。一是地狱趣摄。如瑜伽第二说。二是鬼趣摄。如瑜伽菩萨地说。更有经文未见。三非二趣摄。如此经文别有阎罗王趣故四是变化作。如观佛三昧经第五说及二十唯识论等说。五是菩萨作。如瑜伽第七十七云。炎魔名法王。为作益为作损应言唯作益。故知是菩萨也。又正法念经中。阎罗王为罪人说偈言。汝得人身不修道如至宝所空手归。汝今自作还自受。叫唤苦者欲何为。问此王为断中有众生。为断本有众生。答断本有众生。以中有不在地狱中故。无解脱乐。中初明有障。谓不离烦恼业苦为三障。下明无脱。文有三对。一无脱因。谓痴闇是有障。不见真明是无治。二无解脱果。谓无穷生死是有障。不得脱亦无治。三成前二。谓初明有障。不睹正道明无治

第四自诫中。众生有是重苦。若不先化彼而自先成不应道理。第五正摄生中三句。成善调恶度令解脱

第三大段行益。以此般若行胜余行故。是故前诸行后皆无此益。如文可知

第七无著行以无住心集诸善根。又以悲智相导巧无住着无著之行。无著则行则方便度也。以后得智悲为体。种类者有二。唯识论云。一回向方便。二拔济方便。下文有十种可知

释内有三。初自分行中修无著行。二菩萨于诸佛国下胜进行中修。三于一念下明成满行中修。前中二。初明大智行彰自利无著。二菩萨如是观真下明大悲行显利他无著。前中三。先见净不染。二睹秽不嫌。三双释前二。初中二。先别释。后此菩萨下牒结。前中十四句。初四成净土行。于念念中是无间修也。于中一观严刹无著。二诣佛供无著。三造修巧无著。谓无所行是无著也。四所成业无著。谓思是业体泯以入真名无思法住是无著也。二于念念下十句明法身行。于中初三见佛宝无著。次二于法宝无著。初一闻法处。后一正闻法。次三于僧宝无著。一见僧处。二见声闻僧。三见菩萨僧。上八于三宝境修无著行。下二于自己行修无著行。一于摄法行中修。二造修正行中修。二牒结中二。初牒前净土行。二见佛下牒前法身行。下结以成严。谓以此等法严彼净土。结别成总显初句也。二于染无著中唯一句者。以净法顺求易着难舍故约多门。三释中先征问。一切世人爱净憎秽。菩萨何故不如是耶。下释中。初对问总释。观染净法寂灭平等故。无憎爱下别显六对法。并相待相夺。各无自性故不憎爱也。第二大悲行中。初牒前入后。谓牒前观法性智。便则顺入众生性中。以同性故。是故化生而常无著。下正显相有七。一于所化无著。二于化法不着。三于化心无著。谓大悲同果住佛所住。四于化教无著。谓随方言异故云种种语等。五于化处无著。谓六道等是众生所居。又是化行无著。谓以二乘等是所化行处故云道。六于起化所依无著。谓依三昧起化他事。七于游刹无著。此等并于诸行及事令智圆转而无滞着。第二胜进行中三。先自成胜行。二得受记已下大悲摄化。三不着身下大智照理以显无著。初中九句。一悟实教。于前所游诸佛国处以无著心领解佛说尽理之教故云实教。二寻教得旨故于道无碍。三依教立行故云于法已立。四因修行成故云具菩萨行。五行成不动故云住菩萨心。六依心成德故云成寂解脱。七德成离相故云不念着所行。八离相入证故云住净道。九证成摄果故云受记。受记义如下离世间品中具说。二大悲行中二。先念众生无善有恶。二尔时菩萨下兴悲济度。又前是大悲增长。二是大悲随逐。前中二。初明由痴爱故流转生死。谓不知苦无见灭。闇无信不断集。心不真者远离道。此上痴过也。常行染者是爱过。流转者由前痴爱集业故苦果相续。二不见佛下明由邪见慢故受种种苦。于中二。初由障故不遇正人法。是故起邪见。二不求下明由慢故谤正人法入魔邪境。于中初不求善友。二闻空生怖者拒闻正法。三不正思故谤。四弃舍等明倒修行。下明由此邪慢著有受苦。二尔时菩萨见下结悲心增长不着自善。二大悲随逐中三。先起化心。次显无著。后成化行。前中初总显意。谓为多众生各经多劫各无暂离不去如毫端。明大悲心随逐众生如犊逐母等。二别显悲深。谓多处各多时为化一生。多生亦尔。念念不绝明无间修。下一一毫处具等明起化行。是长时修也。第三大智照理以明无著所由。于中先有十句直辨无著。后何以故下释成所由。释中先征问。何故菩萨一切不着。下释中约八喻显。一谓总释。以观一切缘起法界非有为有犹如幻故。是故不着下次第遣疑。疑云世间幻火不成烧用。佛今出世广益众生。岂同彼耶。释云如电亦有照闇等用。岂是实有。然电有三义。一忽有义。二照闇义。三速灭义。佛果三义。一即寂起用。是忽有义。二即用恒寂。是速灭义。三寂用无碍广益众生。是照闇义。此显上于佛不着。三疑云。若佛如电何以菩萨起行往求因既不虚果宁不实。释云菩萨行如梦安得是实。然梦亦三义。一体无义。二现实义。令梦者见有故。三有用义。与觉为缘故。如梦中因走遂便惊觉返顾无来不走望自身本不动。菩萨既未成佛。于自心大梦未究竟悟。是故修行亦有三义。一证理故空。二无明未尽故实。三能成佛果故用。谓于无明梦内勤勇多劫。豁然大悟佛果现前。返望梦中都无所作。顺顾本性具德宛然。如下第八地中梦度河喻知之。由此释上文于菩萨行无著。四疑云。若菩萨行如梦无所有何故经说此是菩萨行此是二乘行。释云所闻法如响。响亦三义。一以声谷等缘成义。二无本义。三言诠义。圣教亦三。一机感佛应。二当体无本。三称根诠示。是故此教是不说说也。此等释上于自行无著。五疑云。向说果行等可狭是空。世界事广。此应为实。释云如化。化亦三义。一神力持起。二非众生数。三有众生用。世界亦同。一自识变起。二性相无实。三盛贮有情。此显上文观净秽国心无所著。六疑云。若土如化不有何故彼因有善恶差别。释云业报起如摩[少/兔]摩化身。古德释云。此名重化之身。谓化上更起化。是故因果俱化故也。今更问三藏师。摩[少/兔]摩此云意生。或云意成。即意生身也。彼身更起化故复云化身。此亦三义。一两化俱非有。二两相现宛然。三有因果生酬之用。业果三义同此准知。是故即有是不有也。七疑云。若业果俱空者众生报类由何差别。释云由心画故画像亦三义。一平泯义以同壁故。二有高下义以画工不失故。三无碍义平高无碍故。众生亦尔。于真如平壁心画成像。一是空义泯同真故。二有义业果不失故心随薰变故。三无碍义谓空有无碍。则是全空相宛然相显无所有是故摄化不废。恒无所化故不着也。八疑云。若众生如此何故菩萨赴机说法。释云所说法如实际。谓即此言说常同实际。非谓无言方为同彼。向来四门释上利他行中无著义。第三就究竟满足行中明无著者。于中三。先自行。二化他。三释成。前中三。先行广一念是时速。二满十方是处广。三行大。四如法界显行胜。五如空彰行广。谓由照见法性而成此称性之行。二明解广。谓解知诸佛证理决定所有方便。三释成前二以显无著。谓由了知自己之心迅速一念能遍十方世界。顿成解行如前成就。又知己心性随缘而起即亦无起理事无碍不一定住故云回转迅速。由此故能称法而起大行。二大悲利他行中。先行。后乃至下明无著。前中五句。初睹胜生喜。二起大慈下自他不忧。三未成下标其化意。谓成善调恶。四远离下明起其化行。五若闻下在有正化。谓一言音不同。二造业各异。三诸方法则名施设。四摄众差别故云和合。五趣向不同故云流转。六所修各别名诸行。七分齐差别亦是所缘。八得位亦殊。九趣果不等。十我当下起愿正化。三双释可知

第八尊重行作五门

初释名。菩萨愿行深广高胜可贵立名

二体性者。以大愿为行体。然是后得智故。瑜伽第四十九云。悕求后后地智殊胜性名愿波罗蜜多。又以信欲胜解三法为性。又起信论(云云)

三种类者。唯识论云愿有二种。一求菩提愿。二利乐他愿。或四弘五愿。如瑜伽说。或十愿如下说

四功能者。由此大愿通遍诸行。由资令高胜。从此功能名尊重行

五释文辨相内有二。先明自分行。后彼菩萨下显胜进行。前中有三。初明行起所依。谓诸善根。善是顺理义。根是增上义。生长义。于中九句。初一总余八别。别中。一起行心坚。二高出情表。三行深难测。四生德广多。五证寂难动。六行妙无对。七取舍心息。八广行同佛。具此诸义故名尊重。第二正显行相。于中有四。一内心坚谓起愿行二念。二外缘胜谓逆顺二缘。魔是逆缘亦能成行。三行成尊重谓净苦二行。四愿成不退。第三此菩萨下明行成利益。于中安住尊重行已者结此自分行已成也。念念下正明二利。先自利中于患转离于德转增。理实通增一切行愿。约愿显者以此是愿度位故也。下明利他。由此菩萨内具实德。令外见闻皆不虚也。第二胜进行中三。初修成尊重心行。二依心修成尊重慧行。三依慧修成尊重悲行。初中亦三。先明修无碍心行。二菩萨如是下明修无尽心行。三而菩萨下双结二行。初中二。先依理起化明无碍行。二于众生数下明理事混融无碍之行。初中法喻合。问既不趣生死不趣涅槃应言不住。此二中流云何偏言不住生死中流。答远法师释云。前不趣二处是离有也。不住中者是离无也。谓生死无处名断中流。不住此无故云不住中流。今更释如东流水。不住南岸。不住北岸。亦得说言不断北岸中流。以中无别体约岸分故。若尔南岸亦得。何以不言涅槃中流。释以所度众生在此岸故。是故偏就生死而论。约彼亦得。问何以离岸无别中耶。答如于一切众生以如水之如来藏为彼岸以如波之妄心为此岸。以即波之水非动故彼岸非此以即水之波非静故此岸非彼。由此义故两岸俱存。又以非动之水即波故彼非彼岸。非静之波则水故此非此岸。非此非彼是谓中流。是故菩萨居中未尝不即则。凡小在岸未尝不即中。依此义故。菩萨是能化终是不能。众生是所化终亦无化。以中边相即能所圆融无碍思之。二理事混融中作二释。一约相。二就实。前中初句是总通于一切。心无所著下别显中。先直辨有五对十句。一上云无著者非是于一众生无著余皆有着。亦非是多离一盖。以一切俱不着故也。二益以修善不增。化令断恶不损。此望因位未成果说。三善满果起不生。惑障永尽不灭。又功德果满不生。住大涅槃不灭。此望初成果说。四纵皆成果。生界不尽果位不长。此望已成果后说。五虽如上说无增损等然此化事成益不虚。化事虽复不虚然不违前说。故亦无二。此都结前也。下释中二。初中征问。现化众生有增有损。何故乃言无二。释以生界同法界是故无增损生。灭等无倚着。释前不着一多等。后释中。先征问。设同法界岂得无二。释以法界无二故令生界亦无增损等二也。二约实释者。初句显菩萨自心无染。以有着之智不能照此无碍法故。下显无碍相。初五对中分三。初二为一。会事令融。一多无碍。初标后释。着犹置也。谓于一众生置多众生于一不增于多不损。于多置一返上可知。众生界者是如来藏也。以性通相融故得事随理而无碍。次二为一。明事已同理起尽无碍。亦一标一释可知。后一双结前二。明理事无碍。谓同真理而不失事故云不虚。现事相而即真。是故无二。下释中二。先释事同理。后释以理摄事。不增不减经云。众生界法界无二无别。即此法身以惑污故流转五道名为众生。又云。法身则众生众生则法身。法身众生义一名异。又云。若有言众生界法界有二有别者。我说彼人名一阐提也。第二菩萨如是下依无尽心修无尽德。于中二。先直显后释成。前中先依理起行后胜德自严。初显福胜。善能分别下明慧深。以照法原际名到彼岸。二悉分别下明外化普应。初身业普现。次意业无染。后语业广说。二释成中法喻合。法中谓虽于一切法离诸欲际而不断自行之道不舍化他之行。是故依寂起行行德无尽。令前二利德相殊胜故也。言功德无尽者德广也。入净法界者证深也。合中二利可知。三双结者谓融前二心为一行故。是故形夺两相俱泯。于中五对十句。初对约行修。谓究竟是无碍心行。以入理息求故非究竟。是无尽心行以生德无穷故。以生德则入理入理恒生德是故双非。下并准此。二约断惑。谓照惑性空无可断离。异本末照故非不离。三约证理。谓由理无相非是可依。则由照此无依之理。令智圆明非是不依。四约所成。谓证理之时约染空无可舍故非世间。净非斯有故非佛法。又无染可厌无净可欣。五约位非凡少。谓得果是二乘四果等。自下第二依心修成尊重慧行。于中初句牒前起后。谓成就重心是牒前心也。修习菩萨行者正明依前修习智慧之行。于中二。初明照行入理智。二譬如虚空下理行双融智。前中初明化行无教。二自行无念。前中初五对十句。正显可知。二何故下释成。于中无受无转者。无正法可领受。无邪惑可转灭。又不纳异缘故无受。正行坚住故无转。又于上五对二乘等法而能不受。于不教正理而能不转。秤理起行而无退歇故云不退也。二自行无念中二。先正显后释成。前中行是寂灭时者牒前也。不念等正显无念。此同八地无功用行故无念也。不为十法动念。谓三时三科三位。内是正报。外是依报。内外具二。又根境识三亦得。后一就位结。以此位中虽修大愿而亦无念。下释中二。先释何以无念者。以了达诸法平等之中无有智行而能趣向所缘所成故无念也。后释何以无向者。以能向所向无二故无二亦离。故云无不二也。又此亦是释前起后。谓理行不二释前也。虽合而无二然能所宛然。故云无不二。此起后文也。二理行双融智中二。初正明理行无碍。二此菩萨下明功成德立。前中二。初法喻标起。谓无差别显行同于理行相泯也。非不成等明理同于行行功存也。此二是一行准喻中只非无此无差别之虚空。非谓有余物。是则法中非不成此无差别之正觉。非谓无别约理成等约行。此明以无成为成思之。下释中。先释无行之行。后释行即无行。又初明理不违行行揽理而成功。后明行不违理理泯行而归寂。先释初义。谓揽理之行虽万行而恒寂。此是八地之行也。于中初一句正显真理不违正行。下彰即理之行相。先自利行。二调伏下利他行。不坏因果结二行。谓不碍存故不待坏故也。下释行不违理可知。二明功成德立中有二。初于佛能等。谓三世如来皆同成此无碍之行。今亦得彼是故同也。此是总。下别辨。初显内本觉故云不断佛性。二行虽即理而造修恒起故云不坏正法。是故等佛。二于法能兴。初句总。辩才下别显有三。初兴法之辩无染。二安住下明兴法之智无畏。三不舍下明兴法之行无著。第三依慧修习尊重悲行。于中初明牒前起后。菩萨如是成就尊重智慧者牒前所成深智慧也。修菩萨行者依彼修此大悲行也。下正显中二。先总标悲行之意。谓先化令出障教化成。下化令住道。又前令出恶难得人天益。后令出生死得解脱益。二如是教下以事考心显成悲行。于中有二。初明心无异求。二但欲调伏下唯为益生。前中先直辨后释。前中先恶人后善人。谓设彼恶人各有明慧善友满世间。我终不为名利等故竞化为修。又释。菩萨终不于邪见恶人舍化。以彼不顾恩不得名利故。于明慧善人而摄化。以彼顾恩得名利故。云我不为善人得名利处修菩萨行。下释无异求。一缕是利中极少。一爱言是名中极少。少尚不为。况多也。二唯为益生中。亦先直辨。为他调者授三学。净者令断惑。度者令得果。下释中先征。何以不求己安但为益生。释云一切诸佛法如是者举佛类己。下彰己同佛。于中初化心同。二欲令下化益同

第九善法行中作七门

一以得善巧智力说法为机故名也

二来意者。大愿渐净增成力度。又(云云)

三体性者。又依摄论以后得智大悲无边智能为体

四业用者。依摄论有二种。一思择力。能伏一切正行等所对治障令不起。二修习力。能令一切善行坚固决定

五种类者。或二力如前。又有十种如前后说

六差别者。此位同第九地无碍辩力故也。以约圆教此位满后则便成佛不待余故。文内显之可见

七释文中四。一标。二辨。三结。四叹。第二辨相中二。先自分行。后胜进行。前中初总显其相有三句。初以法益机。谓能以净法除生热恼名清凉法池。二弘扬正法。谓以持辩弘显正法名守护。三弘法之益。谓以十身多劫宣化不绝名佛种不断。是故智论云。令般若流行世间则是佛种不断此之谓也。此等亦是略显善法行名。下别辨中有四。一持成就。二说成就。三问答成就。四语益成就。初中由持法不忘方能演说。故先明之。十中皆初明持体后显业用。由持法分明故云清净。依此说法故无障碍。此是总句余九是别。初四持起四辩。五由行入佛境。诸佛为说一切智甘露之法灌其心顶。持此不忘说称物机故令欢喜。六由内自证法故起同证之辩无尽。七由入同理之辩故说文义广多无尽。八由善正方言故。能异异言论名无量辩。与前何别。前据语圆义足故名正语。又是当义之语故别于此也。九能现身同佛。叹不可尽。下显业用可知。第二随所应化下明说成就中二。初正显说相。二随所应于一一下明开化无碍。前中初明所应之机三句。一随多所化熟机。二各各以彼所解言音。三各随彼根宜闻差别。下正为宣说。说称化心名不违悲。二开化无碍中。初多音开化无有障碍。二设有下以一音开化无碍自在。又前是一多。后是多一。此二无碍是一圆音。第三尔时下明问答成就者。有四义微细过前说成就。一前但云世界未显微细处自在。初假举此中一毛头一念中有无量众。二一念类余念乃至尽过未劫。三异语异问。四菩萨无怯畏言。设一切众生问尚一言答。况此少众况以多言。此明智力辩才有余自在。此在地前。得此自在者是圆教中普贤位也。若余宗未得如此。如瑜伽等说。第四语益成就者。显上所说言具义利五句。初句总。二言具深慧。三能成福藏谓受持生福。四照理周备。五能成果智。第二胜进行中二。初总标。后如此下别释。前中初牒前。谓自分行成故云安住。同下初地中安住地分。次标二利两章。二释中二。先略。后佛子下广。前中先释自净。前自分中但言于三千界现佛三业。今显过彼故云如三千乃至不可称数世界。身口可知。于一切法无碍明意业净。作佛事者明此三业所作。下释益。他谓以前自净之三业能作化他事。二广释中二。先广前自净。后摩诃萨下广前利他。前中初标数。二别释十身作五门

一辨体性者。以净法界及根本智并后得智三法为体。如文可见。又总唯境智为性。又境智双融唯一法界为性

二释相者。一一身皆先标后释。初中理无不证故入无边法界。世无不超故灭一切世。世灭理现为法界身。二理无能滞故向未来世。无不生故一切趣生。前则超世令尽此则遍世同生。三虽遍趣同生然住寂不动故云不生。四虽即生不生然彼趣中身恒不灭。此不异不生而不灭者言不及故言语道断。五彼离言身无有实状。以则是真如故。又释以真如为身。然真离相故云不实。以是理性真实故是故离实也。六离痴者体出妄染。随应者净用无碍。如日出云照用自在。七虽起应用常无来去离死。此等释成。准此定出分段生死。八非但用无来去。亦乃体无变坏。亦是缘不能阻。九非直不为四相所迁。亦乃妙绝三际。不可以已未等言而取故。十无相不碍相。通名身者皆有依止义故也

三相摄者有二门。一约三身。谓此中法界不实不坏一相此四是法身。不生不灭无来无去无相此四是实报身。未来离妄此二是化身。二约十身三。初约下离世间品说十身(云云)

二约胜天王经十身(云云)。三约法集经十身(云云)。四得处者有四位。一或唯地上得。如胜天王及法集经十身。此约三乘辨。二或唯地前得。如此所说。三或通二得。如下离世间十身。四或非地前非地上得。如三身十佛等果位得故。五定分齐者。若三乘中菩萨。地前必是分段之身。地上方有变易身。除回心二乘地前亦有。是故此十非彼所摄。若一乘中有二说。若摄方便言地前地上俱有变易。以一一位终至佛地故。若就自教言俱是分段。以白净宝网转轮圣王得普见肉眼等是十地菩萨故。如下文说。又如善财童子以分段身至普贤位。然并是即法门之分段故非过患也。第二广前益他者。先牒前起后。谓依此十身化导众生。句别有十。一生善。二离苦。三住乐。此上世益。四示其出路。五令其趣入。六令解俗谛。七令得真谛。八令其断惑。九令成因位。十示果令向

四叹中。初作清凉池总叹也。得佛法底释能作法池所由也。又初结叹前自分。后结叹胜进也

第十真实行中亦作七门

一释名者依言依行。成德称言行不虚故云真实。真实即行。持业得名

二次第者。行力转胜增入实智

三体性者。以后得智用为性。兼以大悲等

四业用者。依梁摄论不住生死涅槃是智用。利益凡圣是智所成事

五种类者有二。一照物机智。二授法药智。又有十智如下说

六所成者。以此位同下第十地满足相故智波罗蜜增上。余行无不皆具。是故此位行满已入普贤无边境界故。下文云。入因陀罗网法界自在成就如来无碍解脱等也

七释文中亦四。标释结叹。释中三。初举本誓言。二此菩萨下依言成行三得一切法下行成德立。又初即言实。二行实。三益实。初中亦三。初总标举。二略释。三此菩萨成就下举事广释。初中如说能行者。谓行称初誓而成。显先言实也。如行能说者。言称终成之行。显后言实也。由此始终实言无二故名第一诚谛之语。然此始终二诚实言总有三类。一约自行。如菩萨初誓言舍眼。若有乞至如言而施。有问其故答。为菩提。此言何证。便发誓言事若不虚令眼平复。表非妄语。眼随言平复。此则初言能起行。后言能增行。二约利他行。如菩萨初誓度众生如言救度。纵自行满亦不就果。要称本誓以尽生界。此亦初言能起。后言能满。三约因果。谓如菩萨初发诚言。要修万行当成佛果。如言行满后果成佛。师子吼言。我独尊等。此即初言辨因。后言显果。下云人中雄大师子吼等。是此门也。上三义中。于此行内。义通具三。文唯后二可知。二略释中二句。初释如说能行。谓如言起行故云实语。证入诸佛平等实性起入理行也。善根齐等起缘事行也。二释如行能说。谓虽成广善而不乖化志。不失先言故无二语。以终不改始故名无二。此即初能行故实。后终不改故无二也。此并三世诸佛同行顺佛果智故云随顺等也。三广释中二。初行德虽高而不舍本誓。二何以故下释不舍意。初中先成十力智显德尊高。后而不舍下明不舍本誓救摄众生。菩萨之行十力之义如净行品处已释。净名经云。虽得佛道转于法轮入于涅槃而不舍于菩萨之道是菩萨行。下释意中三。初反释。谓举失。违誓自诫不应。二我当下顺释。谓酬遂本愿以理自开。三何以下转释。谓忆本念今令心勇悍。于中二。先忆本谓言发自里。岂还自食。此恐违本誓失。二是故下念今谓由非他所请而能废自为他。是故令自德成殊胜。今若舍救便乖此德。此恐违现德失。由前起后故云是故也。又释我于众生是有胜德堪为救度。若舍不救则违此德。于中六句。皆初标后释。一无著故胜。二能调故上。三解空离闇。四愿满已得。五具德能变。六佛念能摄。上来成立本誓。显不可违

自下第二依本誓言而成所化。于中三句。初由前不舍得此度生无上智慧。二随一切下正明救度。三随其等明成满本愿。谓如言所作无不究竟故云满足已也

自下第三行成德立者。谓此位满成就普贤法界圆明自在之德。于中有二。先成因满足。后摩诃萨住大悲下明成果德备。以德满菩萨具此因果二用故。前中三。先标二利。二释显成满。三此菩萨义身下结德无尽。前中得自在智标自行满也。令众生净者标利他圆也。二别释中二。先显前自在亦二。一明身无不至等空法界。无量无碍者明一处现即一切处现故也。无依者明身起无本故得自在。二明身无不容内含一切。谓三世间等悉身内现。由此法界之身竖含三位横该九世。是故未来诸佛亦于中现。二此菩萨下显前令众生净。于中三。先知化器。二随其下现身说法。亦是化自身内之众生。三于化不着。谓以诸幻法化梦众生。是故虽化恒是无化。三结德无尽中二。先由前外化满显量智无尽。二入诸三昧下由因行圆显理智无二。众生依二者举凡显圣。上来因德竟。同等觉位也。智度论第四十。复次十住菩萨与佛无有差别。如遍吉文殊师利观世音等。具足佛十力功德等而不作佛。为广度众生故。乃至云。是诸菩萨于余菩萨为大比于佛不能遍知。如月光虽大于日即不现。解云。彼约十地名十住。是第十地。同此第十行中业用也。第二同果德用中。初牒前起后。得佛下正显所成。此同妙觉位。文中通成如来十种功德智。一得佛圆明十力智。二入帝网法界智。三成佛无碍解脱智。谓不思议解脱如不思议品说有十种。四成人雄无畏智。谓吼其实德故也。五得转大法轮智。谓法王宣法故。六成佛无碍智。显无微细碍无明。七绝生死下成佛无垢智。显无微细着无明。亦显变易尽处也。八广益众生智。九兴护正法智。十无功摄化智。谓能尽同古佛摄化方便。下结及叹可知。上来正说竟

自下第二明说别益有二。初动地者生信功德。二雨供等者是敬重功德有四。一雨供。二作乐奏十行曲。三天光。四天音赞十行德。上来总是一世界中说十行竟

自下第二大段明十方无尽世界所说十行。供等亦尔。与此合同。结成一部。谓一十行即一切十行故也。上来一说一切说总明说分竟

自下第六明证成分。于中二。初明此处证。后明一切处证。前中四。初明菩萨来集。二叹此所说。三各举证事。四是故下述意成证。问既由行法圆融令彼菩萨世界诸佛同名功德。何故此处佛及世界不名功德。答此经中凡是所证皆悉同是卢舍那佛。世界同是华藏娑婆。其说法菩萨即从法受名。凡是能证必同法名。以主伴异故。若此处望彼此为能证。即此名同彼彼名同此。是此经中规例宏致之所尔也。上来十方各十万刹同说十行。总属于此一主之伴。犹自非是十方主摄。是故后更结于十方。明一切处同证。上来一证一切证总明证说竟第七重颂分中二。先叙意后正颂。前中句别有十。一观十方显同说。二观眷属令乐闻下正显说意。三为令绍果。四为令净因。五愿坚。六行续。此上自分。七胜进摄佛。此上自德。下明利他。八说十行众生善根差别令物习学。九量器授法。十总结。此等并约因门而说故俱名种。又是性种之位故也。正重颂中。七言五言梵本无别。俱以四句为颂。总有百一偈耳。此中偈颂与前长行文势不同。略论五例。一前即约位始终布列而说。今即会融前说令无始终。是故一一行中具一切行也。二前约别行此明普行。以普别无碍二文互显。三前唯约因此通果行。以因果圆融为此行门法界故也。四前约同教摄彼中根。今显别教被斯上达。以同别无碍为一圆教故也。五前约不杂辩才此约任放辩才。说不待次。言辞不断故也。文中有二。初有五偈叹佛功德令人愿求。二十方一切下颂菩萨行令人习学。显此位中具因果二行故。又为由佛加说故。先叹佛由行所说故。后颂行。前中二。初二颂叹舍那佛。此化主故。于中初一叹佛无垢无挂碍智。次二句叹佛胜德广大。后二句叹佛证行圆净。二叹十方佛。以是助加故。于中初一显二严果满。谓解真惠深。无等福胜。速究满果。次一真悲广益。后一显智断德齐。第二颂菩萨行中三。初七言六偈颂前本分中行业不思。广如法界。究竟如空。二句句广分别下颂前说分十行差别。末后四偈结叹显胜。前六偈中显六种行业皆不思议。初一见佛离妄行。二见理成德行。三无功广大行。四寂用无碍行。五愿坚尊胜行。六摄位多门行。各一颂显可知。二颂前十行中。初一总说十行。下别显中。初六偈颂欢喜行。于中初三无畏施。一离害益生。二济苦令安。三语意受恼。次二法施。一究义。二说教。后一财施。百福者。涅槃经说。下中上上中上上五品心中各修十善。即为五十。始修五十。终修亦尔。故有百福。百福严一相也。第二善入下五偈颂饶益行。于中初一颂律仪戒。谓过不能动。次二颂摄善法戒。一顺法行。二离二行。次一偈半摄众生戒。一化处。半化行。下半总结三聚。第三智慧不可量下四偈颂无恚恨行。于中初一法思胜解忍。次二安受苦忍。谓自修行时有苦堪耐。一忍心苦。谓上半举所修。心无怠明心安忍。二忍身苦。亦上半举所修。身行无碍明身安忍。次一他不益忍。上半举所忍境。菩萨悉救举益翻损正明能忍。第四修习佛法下五偈颂无尽行。于中初二加行精进。一颂前勤修精进等十句。二颂前欲悉知众生根欲性等故修行精进。次一被甲精进颂前为众生受地狱苦等。后二无厌足精进。一智光遍益物。后一神力常益生故无足也。第五善解下二偈颂离痴乱行。于中一现法乐住禅。上半加行。颂前分别世间色法。经论等。下半住定。明慧彰离痴。不动显离乱。后一引功德禅。无尽地者颂前闻受正法乃至多劫不退忘等。第六无量下二偈颂善现行。前加行正体略不颂。后得智中。一大智自行颂前而亦不舍菩提心等。二大悲利他颂前不舍化众生增大慈等。第七佛甘露下四偈颂无著行。于中初一颂前受真记。以方便度此中满足故云究竟也。次一颂前悲念众生等。后二颂前于语言道心无著。第八安住下八偈颂尊重行。于中初一颂前深解法界住无相住。次一颂前于无量劫行菩萨道不计众苦而生忧恼等。次二以普眼见佛亦是颂前与三世佛等。次一延促解脱是不思议解脱亦得。颂前非究竟非不究竟等。次一颂前若有众生恭敬见闻皆得住不退转等。次一颂前心常爱乐诸佛妙法。后一颂前不离一众生着多众生等。第九具足智下三偈颂善法行。于中初一颂持成就清凉法池等也。次一颂说及问答成就等。后一依定现身颂前金色身及十身等。第十究竟下四十六偈颂前真实行。于中分五。初三总颂。初一忍智过尽。次二身土无碍。一如意通。一幻通。次二有七偈。颂前言行相应。于中初三偈颂所成十力智。次一颂正言行不虚。下三偈颂入三出佛性及善根等。三深入智海下有十二偈。颂前依誓起行如言摄生。上文略此中广。于中初三授眼雨法。次二坚信知心化。次不思下四偈显三业自在化。次二知根授法。后一结叹显胜。四彼智无与等下九偈颂前所成因满之德。于中初四二严两利满。后五三业二用极。一身。二意。三语。四身用。五语用。如次应知。是上文此菩萨义身味身不可穷尽也。五修习佛解脱下十五偈颂前所成佛果德。于中二。初七偈别颂上文。后八通颂彼德。前中初一颂前成如来无碍解脱人雄无畏等。次一颂绝生死流入智慧海饶益众生等。次三八相恒寂颂前穷尽诸佛方便大海。次一颂前观不二地等。次一颂前护三世诸佛正法。下通颂此行德。于中八偈。初四二利成满德。先三自利中。初一偈叹色根胜。偏叹眼耳及身是通性故不论鼻舌。次二叹心胜。一慧。一定。又初叹通叹智。后一叹定叹慧。下一利他。次一切知见下四偈三业殊胜德。一生处胜。二言辩胜。三身光胜。四应机胜。第三四偈总结十行。叹以显胜可知

    十无尽藏品第十八

释名者。标人别法故云菩萨之十藏。非是人法合目。谓此十种是诸菩萨所行之法。菩萨之十藏。依主立名。一周圆数依则说十。含摄蕴积出生名藏。此一一藏内含法界体非限分故云无尽。二一一各摄一切行相故云无尽。三一一皆能出生果德无有穷竭故云无尽。无尽即藏。持业释。约十带数。菩萨依主。三释可知

二来意者有五义。一为答普光十藏问故。二前明正位今依位起行故也。同上梵行品。三前明约位别行此辨始终通行。四前行位成立今辨净治彼行。同十地等信等十行。五前自分究竟今胜进趣后。同上明法品。准问应在回向后。今此辨者但藏有二义。约蕴摄义。在十行后。约出生义在回向后。义通二处。问答互显

三宗中作二门。先通辨藏义。或一同一法界藏。或二谓大小。或三谓契经等并三乘等。或四加杂藏。或五谓名相等。或六谓大小各三。或九谓独觉亦三。或十如下离世间品。或无尽如此品。二别显此宗者。此中正十种行法该始括终。具足普贤法界行德为此品宗

四释文中。通文及义总作六门。一举数。二释名。三体性。四摄行。五释相。六结叹

初中功德林说者以是会主故。又表此行法众德建立故。三世同说者谓佛出虽异同说十藏显此十种法界之行。如大王路三世无易。故云同说

二释名者。总名如前。别中信者于实德能深忍乐欲心净为性。对治不信乐善为业。由此含摄出生诸德。故名为藏。则持业释也。下并同此。二防非名戒。三业善为性。止恶作善为业。三惭者依自法力崇重贤善为性。对治无惭止息恶行为业。四愧者依世间力轻拒暴恶为性。对治无愧止息恶行为业。五餐教广多闻慧为性。聪敏为业。六辍已惠人无贪思为性。破悭为业。七慧者于所观境简择为性。断疑为业。八念者于曾习境令心明记不妄为性。定依为业。九持者任持所记念慧为性。经久不忘为业。十辩者巧宣所持以慧为性。应机为业。此上十中信惭愧念慧。此五各当体得名。余五功能受称。谓戒施行用立名。闻持辩智用为目

三体性中有二门。一约相。谓信惭愧是善十一中三法各当自体为性。念慧是别境五中二法亦当自体为性。戒以三业善思及表无表为性。施以无贪相应思为性。依智论持以定慧为性。闻辨二种俱以慧用为性。二约融通。谓总是一法界之行。随义说十。一是法界性自澄净义如清水珠。二法界性自离过义。三四俱是法界性能灭过义。五法界摄德广多义。六法界自性放舍义。七法界自性开觉义。八法界自性明照义。九法界自体任持义。十法界随缘应机义。是故一法界为性

四摄行者作七门。一约二利分别。别论前九为自利后一为利他。通论皆具二行。二约本末分别。初一是行本故上云信为道元功德母等。余并依成故是末也。三约正助分别。慧正余助。四约资导分别。慧为能导余为所导。余是能资慧是所资。五约财守分别。前七则是七圣财由念持守护使不损失。由辨贩致令得增长。六约行相分别。初四离过行。一是本。二防未起过。三四殄已起过。余六修善行。闻是修始。施慧修次。六度皆修。举初举后。中间可知。后三修终。初二自熟。后一化他。七约生起次第分别。信为入法之初。是故先辨。依信起行离过为先。故次明戒。戒或有犯深生惭愧庄严戒行令其光洁故云有二白法能救众生过。既防离将增善品要以博闻为首。为求所闻要必舍自内外。既忘私为法必正慧现前。正慧既现必须温念增明。正念既明必须忆持令久。持既不忘。要须辩说于他令二利行圆方为究竟

五释相中释此十藏则为十段

就初信中四。谓标释结叹释中二。先明修相。后成就如是无量下明修成。前中三。初明对法起信。二明由信故闻法不怖。三何以下释不怖所以。又释初信理法。次信教法。后信果法。初中信十法。于中初三信所执无相。空谓情有理无名空。空无空相名无相。无相故无所愿求。次三信依他无生。一缘起无作。二如幻不实。三无体自守。后四信圆成无性。一性德无量。二胜故无上。三深不可到。四常不可生。又初一切法中量不可得。上亦不可得上。文云上相不可得故号为无上此之谓也。二由信故闻法不怖。于中十句。初二于胜上法不怖。次四广多法不怖。何者所化。谓众生界。以何法化。谓法界。何处化。谓尽空界。化置何处。谓涅槃界。后四宽远法不怖。谓三世入劫为十世也。此十中不思有二义。一则无所有而说有故非可有。无所能思议。二此等十法并无边无尽非余位智能知故云不思。亦由二信故闻之不惊。一由信达三性三无性理故闻初门不惊。二由仰信佛智平等无量无边此既佛智所知我亦随信。此闻后门而不惊也。初义如前显。后义释中彰故也。三释中先征后释。释中初一句显信佛心坚。次句明前十法是佛智所知。故云佛如是知也。彼境广大佛云何知。良以佛智亦如彼境无尽无边故。彼既佛知。菩萨信佛故不惊也。十方下释佛智是可信所由。先大用不虚故可信。二彼诸佛下明体无增损故可信。于中有十不。此文显佛智非生灭法同无为也。第二修成相中二。初一句总乘如来乘趣于佛果。二别显中。先成行体有八句。一称所信故无边。二体坚不退。三所信不杂故名不乱。四缘不能沮。五深信离相。六信从慧起。涅槃云从闻思生也。又有慧之信名有根。无慧而信长无明。无信而慧长邪见。信慧具足方得入法故。梁摄论第十一云。由菩萨自证施故行施。不由信他故行施。前信有根故成信。后信无根故不成信。七顺同古圣。八家业法尔下显行功能有四句。一能护法。二能增因。三能顺果。四德从佛生。三是名结。四住此叹有二利可知

第二戒藏中三。谓标释结。释内二。先开十章。后一一牒章广释。光统云。初一摄众生戒。次八摄善法戒。后一律仪戒。又第二中不受外道乌鸡鹿狗戒等。第四中以先不犯故后无疑悔。准此文。似故犯一切戒人往昔曾作五逆罪来。是彼恶习也。又涅槃经云。何故持戒。为不悔故。何故不悔。为欢喜故。何故欢喜。为悦乐故。乃至为得大涅槃故。第五中不食苏盐等为更造立。又断谷服气等法外立制等。第七中若以断常见持戒。即是杂无明故名犯戒。第八中邪命或四种。一方口食。二仰口食。三维口食。四下口食。又十住论第二云。谁名五邪命法。一矫异。二自亲。三激动。四抑扬。五因利求利。矫异者。有人贪求利养故。若作阿练若。着衲衣若常乞食若一坐食若常坐若中后不饮浆。受如是等头陀行作是念。作是行得供养恭敬。我作是行或亦得之。为利养故改易威仪名为矫异。二自亲者。有人贪利养至檀越家语言。如我父母兄弟姊妹亲戚无异。若有所须我能相与。若有所作我为作。我不计远近能来问讯。我住此者正相为耳。为求供养贪着檀越能以口辞牵引人心。如是等名自亲。三激动者。有人不计贪罪。欲得财物作得物想如是言。是钵好若衣好。若户钩好。若尼师檀好。若我得者即能受用。又言随意能施。此人难得。又至檀越家作是言。汝家羹饭饼肉香美衣服复好。当供养我。我以亲旧必当见与。如是示现贪相是名激动。四抑扬者。有人贪利养故语檀越言。汝极悭惜尚不能与父母兄弟姊妹妻子亲戚。谁能得汝物者。檀越愧耻俯仰施与。又至余家作是言。汝有福德受人身不空。阿罗汉常入出汝家。汝与坐起语言。作是念相。檀越或生是心。更无余人入出我家。必谓我是。是名抑扬。五因利求利者。有人以衣若钵僧伽梨若尼师檀等资生之物持示人言。若王王等及余贵人与我是物作是念。檀越或能生心。彼诸王贵人尚能供养。况我不与是人。因以此利更求余利故名因利求利。第九中。诸法无行经云。若见破戒人不说其过恶。应当念彼人。久久亦得道。问涅槃云。见破戒者应当摈默呵啧举处。当知是人得福无量。此文何故将护不呵。岂为摄生。答彼据慈心呵令悔过。以根熟故。此约护彼。恐更增恶心。根未熟故。余文可知

三四二藏惭愧者。涅槃云。惭者羞天。愧者羞人。惭者自不作恶。愧者不教他作恶。惭者内自羞耻。愧者发露向人。又俱舍论云。无惭者若善人所呵于中不见怖是名无惭。无羞者于功德及有功德人不尊重。无敬畏心名无羞。无羞者是无愧。经部说。观自身由过失不耻名无羞。观他身由过失不耻名无惭。又瑜伽对法唯识(云云)。惭藏释中三。初念昔自他无惭之过。于中先自后他也。六亲者谓父母兄弟妻子为六。二自惟下举过自诫。三是故下正修惭行。愧藏中三义。同惭可知

第五多闻藏释内二。先所学之法后摩诃萨下明其学意。前中亦二。先开十章后次第释。十中初四约十二缘生(检瑜伽)。理实出世间亦有无取五蕴。今是取蕴担苦积集。故是世间。又约小乘亦得。又五分法身翻前五蕴。故为出世。又理实有为更通余位。今取三界及众生并是惑业之所为。故是有为。于无为法中。一开合者。或唯说三。谓虚空择灭非择灭。此约小乘。或说四。加真如。如掌珍论说。或说六。加不动。是第四禅及灭定如百法论等说。此二约初教初说。或说八。于真如中开善法真如不善法真如无记法真如。如瑜伽对法说。此约初教终说。四中择灭有二义。一灭惑障名择灭。灭定障名不动及灭定。是故总摄在择灭中也。八中欲渐展一切法悉真如故。开善等三性诠门显示。二假实者。唯真如无为是实。余并是假。以于如上假建立故。如佛地论说(云云)。又真如中亦二。一安立是相分故。二非安立非识现故。初假后实。三转异义者如此文六无为。一事无处名虚空。二性净之果名涅槃。三无间道数断结所得名数缘灭。四余缘不起名非数缘。五十二因缘是无为者。依俱舍论僧祇部犊子部并说十二因缘是无为法。以如来出世若不出世此法常住故。经部师破如彼说。又远法师引涅槃经释。就人论三世流转是其有为。废人谈法法相常定。故曰无为。如十二因缘阴界入等一切皆然。如涅槃经说。今释。以此缘起各无自性各无造作故名无为。涅槃云。十二因缘则是佛性。又大品云。菩萨观十二因缘犹如虚空不可尽等。六法界者是如来藏体。实不生灭故是无为。又于一真如义立此六。一无相义。二所证义。三惑尽义。四性净义。五随缘义。六不变义。亦是为因义。有记中四谛等者。约顺理善有可记录故。上来多是小乘法。下无记中虚妄法不可记录故也。智论说十四难。此中十六种。俱舍论有外道名郁胝歌。此云能说。问佛世间有边无边等四。此约始终为问。常无常等四约断常问。所以不答者。若彼执我为世间已我无故答不应理。若执一切生死名世间四答亦不应理。若世间常住者无一人得涅槃若非常住即一切皆断灭自然涅槃。若具二必定一分不得涅槃一分自然涅槃。若非常非非常者应非得涅槃非非得涅槃。问若自得涅槃有何失。答若自然得者由涅槃至。得随属道故如尼干雀握不可定答也。如来有异死等四问此约缚解问。以外执梵王及已师已得解脱名如来。由观问人意故佛不答。以彼执已解脱我名如来。既执有我故佛不答。余检智论第二第十七瑜伽俱舍舍利弗阿毗昙并正疏总计会具作之。第三四句中如去不如去等四中。如来者如从前来。向后亦尔。故云如来。非是佛。四句何别。有人计神我与阴一阴灭我亦灭。若言还如来时去此语不受。二计我与阴异阴灭我不灭。若言不如来时去此亦不受。三计我体常如虚空。说有来去俱不受。四执我有粗细说无来去亦不受。谓粗我与阴一。同灭故如去。细我与阴异。不同灭故不如去。不受。第四四句中。我是体众生是用。由我有众生。依体有用。二反此。三双存。四双反。余文可知。大况上来所学之法并小乘及外道等法为知故。为欲因此摄众生故下明学意可知

第六施藏中。释内先列十门。后一一次第释。一一各三。标释结。初中由久宿习乃至自食。亦有施心。谓舍所极要命受中夭。附近死边名最后难。又诸施中最在后故。内施中少壮轮王者明难舍能舍故。内外施依瑜伽剪发剔吐等为内外。此中通依及正。唯除妻子。一切施中并有妻子故别也。七过去施中。初举所贪境。二闻已下以理正观。于中先直观空不失方便。后况其谢灭。三菩萨下正成舍行。此三世施但舍自贪心。与无贪善根相应故。入此中收。又通论四句。一舍而非施。如三世施。二施而非舍。如自食施身虫等。三亦施亦舍。如前门。四非施非舍。如信藏等。未来现在亦各三义。同上可知。现在所贪中净法内但举二乘者。以佛菩萨现在缘成非不求故不同过未谢及未至无缘起故。是故不同前。第十中四。初乞至。二菩萨喜。三观身过患。四开意成施。谓纵是好物我尚应舍。况此恶物。又纵无所益我尚应施。况复令我得三坚法身财自在

第七慧藏释中三。初明照法成慧。二菩萨成下明慧成益相。三显无尽义。初中二。先明慧自照法。后明为他正说。前中初总举所知。二释成能知深妙。前中以四谛历知十法。谓五蕴无明爱及三乘。五蕴约染果。痴爱约因。此七皆当相是苦。缘成是集。无性即灭。显灭为道。以为诠门显灭故。又是菩萨巧回成道具用。故如论诸惑成观分生死为涅槃。后三约净。声闻是人。四谛为法。所行道品为集。所成果为涅槃。十二缘是缘觉法。无边法界是菩萨法。又释知声闻即是知苦。以声闻苦是已知故但举其位。二是彼所行法则道谛。三彼惑习等未尽即是集谛。已有断故法后说之。涅槃是灭。缘觉菩萨准可见。二释能知中。初问意。知有二种。一随相知如小乘人。二称理知如菩萨人。今但言知于此二中是何知。故云云何知也。下释。是称理。知有六句。一总举因起。二非我下二句显无二我。上句明相不实。下句体空无。三不取下三句明对法离染。不取坚固对前上句。不取所有对前下句。三知一切下释不取所由。二为他说中。初句标。二云何下释。释中三。初总。二何等下别。于前十法略举九门。以即同如故不可坏也。三何以故下出所由。先征现见色等是可破坏。何以言不坏。释以从缘起自他共言皆不到故色心俱离也。二菩萨成就下慧成益中二句。一少功广达。二自悟非他。三显无尽义。中十句内。初三自分。于中先二自利后一利他。后七胜进。于中。初四自利后三利他

第八念藏释中三。初对境明念。二菩萨下显念胜相。三菩萨作是下彰念益相。初中有十。一念过去一生至多。二念过去一劫至多。三念一佛至无量。四念一佛授记至无量。五念一佛出世至无量。六念从一佛受经至无量。十二部经如别章。七念一会一时说法至无量。八念一法器根至无量。九念一所治烦恼乃至无量。十念一三昧乃至无量。二显念胜相十句。一妙念者妙过余人。二净念者所记分明。三不浊念者不杂闇障。四遍净念者于法悉明。五离尘念者于所念事不生贪染。六离种种尘念者不生余结。七离垢念者不计我能。八光曜念者广照无极。九乐念者乐修不息。十无碍念者发意即知不待思量。三彰念益中四句。一世苦不乱。二根净不染。三念坚不坏。四持法不错

第九持藏释内十一法。一一品经乃至无量。二佛名。三界名。四劫名。五佛记。六一部经至多。七会名。八说法。九根。十烦恼。十一三昧。下结叹中。唯佛境者显因深彻果故也

第十辨藏中亦四。标释结叹。释中二。先举辨体谓后得甚深智故。二显辩功能有二。先自分。二此菩萨下胜进。自分中初广说不违典是总显。下别辨。于中二。先明说自在说前所持十法也。二何以故下释自在所由。二胜进中二。初总显谓法光辨演深法。二以广长下别辨。于中二。先无碍说有四句。一明说益。二善入下于教自在。三入普照下于义自在。四不舍下明不失自行。后何以下释无碍所由。谓此位即是究竟位故成此满空法界清净法身。是无垢真身故云净也。叹中十句。一无量者多门故。二无分齐者一一皆无边故。三多门无间。四和杂不坏。五自体无断。六不为缘断以非是可断法故。七言无怯惮。八悬远甚深。九廓然无底。十摄法释成

第六结叹十藏。初一句结。下叹胜。叹胜中。初一句结叹谓令众生得菩提故。下十门别显。别释唯有七句。各标释。一叹行利。二行常。三行广。四行巧。五行多。六行坚。七行入理。是名下总结叹也。此后应有证成及偈颂等。文不足。或是略故耳。上来总第四会竟

华严经探玄记卷第六华严经探玄记卷第七(尽第五回向)

        魏国西寺沙门法藏述

    如来升兜率天一切宝殿品第十九

自下明第五会。四门同上

释名中。会名者。约处名兜率天会。约主名金刚幢会。约法名十回向会。品名者。如来明佛法界身。升是赴机起用。兜率是所赴之所。三义题名。又赴此喜足天者表世间行满故也。一切宝者表摄行多门。可贵交饰故也

二来意者。初会来为答前十回向问故。又前明解行。今起大愿。若不起愿恐证无为。故次来也。又回前解行向于真证故也。二品来者将欲说法先辨所依处故明也。又前会既终赴后之始故先辨此

三宗趣者。先会宗亦有人法主伴教义。各体相用准前可知。又以大愿回向无尽之行为此会宗。至下当辨。品宗者。谓天王严称法界之器殿为能感。如来以遍法界之身云为能应。感应契而无动。无动寂而繁兴。缘起具德为此品宗

四释文者。此会三品。初二序分。后一正说。何故无后进趣者。以摄前解行总为趣地方便回向当体自是胜进。是故无也。此经上下此例有四。一约行满入位之际。如贤首信满总为入住方便。二约比满入证之际。如此回向品初僧祇满总为入地方便。三约功用满入无功用之际。如第八地初总摄前七地为方便。此二僧祇满。四约因位成满之际。如第十地初摄前九地为入方便。此约三祇满处摄也。余同位相接即别有方便故非一例。就前序中二品二序差别同前辨异

初品中有七。初本会圆现。二不动升此。三天王严处。四迎佛设供。五睹佛胜德。六天王敬请。七受请成益。初谓前十方觉树普光忉利夜摩等说法之会并皆未散升此。所说与彼同时。是故横遍十方竖通八会。同时前后无碍而说。余义同前说

第三严处中二。先明一方严。二结会十方严。前中二。初遥见佛者明睹胜缘。二即于下显严胜座。于中先总显后以无量下别辨。前中以此座是实德所成是故有十三种圆满相。一自相谓宝座具德故。二因相谓宿善所生故。三不坏相佛护念故。四胜相多因所生故。五真净相佛净法起故。六共相众生共严同受用故。七具德相。八离恶相。九微妙相观无厌故。十出世相。十一无染相。十二同相谓相同在世间缘集成故。十三无尽相谓众生见不能尽。亦是甚深相唯佛境故。第二别显中。初一句标。二所谓下正显。于中有二。先辨器世间庄严。后百万诸天神下辨众生世间庄严。此中亦分有智正觉义。前中亦二。先外事严。后从百万亿神力下明内法严。前中二。先色相严。后百万亿天盖幢一切宝铃下音声严。前中四。初杂事严有五十二种。第二百万亿大海月下别事严。于中宝有二十一种香王十七种云雨二十一种。第三百万亿天宝幢下重明杂严有二十九种。第四天杂宝衣下重明别事严。于中衣幢各十种。第二音声严中有四十二句分二。先乐音有十种。后妙音下明法音。于中二。先总叹三宝功德。后别叹十住菩萨功德。前中三。初十句叹佛宝功德。二叹一切菩萨下四句叹菩萨僧宝功德。三叹深法下八句叹法宝成益功德。二别叹十住功德。以是正位摄因行故可知。外严竟。第二内法严者。亦是上来庄严。今辨严已出生胜德显座德用。于中三十一句分三。初十三句出信进念定慧等杂行。净解脱是不思解脱也。二有十一句十度行。于中末句结十度可知。三普入下七句明出三业大用。此是师子座三业以依正无碍故。器世间严竟。第二众生世间庄严中亦二。先有五十八众外相严。后出菩萨净愿下内法严。前中二。先四十四显人天众严。后十四辨菩萨众严。前中。先十五欲界人天八部等。后二十九色界天等然余处说于四禅中各有三天。此各四者。皆一是总余三是别故也。谓初禅中梵眷属天。二禅中光天。三禅中净天。四禅密身天。此各是总故不同也。又四禅中少密身余处说名福爱天。无量密身是称福生天。密果是果宝天。亦名广果。以第四禅天身行断无出入息故俱名密也。次五净居天。后更云百万亿种种天者应是无色界天。既不显名。或通一切也。第二菩萨众中。初十依本位名显德用。后四以天名说。此上并是海印中法界自在差别实德。以人法无碍依正混融故致然也。第二内法者。亦是上来庄严。今是严已成德堪为胜用。有二十句法门行相可知。上来一方严座竟。第二如此世界结通十方无尽世界敷座。可知。上来十方天王严主伴座竟

第四迎佛兴供中二。先出迎兴自分供。二佛神力下设胜进供。前中二。初诸天兴天供。于中先雨十种供。后从身出众总合观礼。二不可数下明菩萨兴出世间供。第二胜进供中亦二。先诸天兴天供。后菩萨兴出世供。前中四。初佛力令天睹希自庆。二阿僧祇下衣盛华等诣佛奉散供养。三亿那由下于佛行处庄严虚空。于中十种。初一总余九别。别中一一各初起胜心后兴妙供可知。四无数亿下从身出供在路供佛。八句可知。二菩萨兴出世供中三。初从意业出供。二从身业出供。三语业叹佛。初中二。先总显供事。后一切宝盖下别明供佛。前中二。先标。谓离三界标供分齐。从真法生标供所因。下释中先释分齐。以离惑故慈普故智深故唯佛能知故离三界也。下释所因。从四因生故名真实法生。一坚信是加行智。二不思善是正证智。三变化是后得智。四真法是所证理。既从此起还称性平等故以无行法印之所印定。下别辨供佛中九种。一一中各有五义。一举供事。二遍法界明称真性。三用供佛。四过天显胜。五出因。又亦初四是上总中分齐。后一是上所因。于高座供中心境等佛者明证理同佛也。依此起座令座亦同佛境也。以此菩萨并是普贤极位因果同等故。余准可知。二身业供中从身出八事云供可知。三无量菩萨下语业供养叹佛法身无边功德可知

第五睹佛胜德中二。初大众睹佛法界身云。二尔时如来下明佛现此身云之意。前中亦二。初见法界身无边德用。二尔时诸天见如来身下明见佛身光妙用无尽。前中然此所现所见佛法界身岂有限量。今且依下结文分为十门。于中二。先显十门之德。后如是正念下结十门之名。前中辨此十门即为十段。然望后结少不次第。从初至清净善根来超明第十见佛示现不可思议自在神力门。于中先举能见人。后显所见佛身。无量者正显法界无限量之身。显前一切世界菩提树下无不现也。不思神足者显前不离觉树升天等也。文中有四。初妙用益生。二周遍下德普利物。三成就下用深令敬。四随所下应机成济。二显现如来下却辨第一大众如是正念如来门。于中二。先明如来现自胜德。谓大福大智大定及体遍。二令一切下广益众生。于中三。初益地前。二悉能下益地上。三一切法云下益令果满。三以正觉下明第二观察正觉门。于中二。先明自觉成满。谓初觉俗谛境。后于不退下觉真谛境。二教化一切下明觉他成满。四示现色身下明第三入智慧渊门。于中色身是起智所依。下显智相有四。初观众生智。二善解下明知佛十力等智。三住一切下知法门智。四悉能下明成智渊海。五如来日下明第四入功德海门。于中有四功德。一寂用无碍德。谓照机日不没恒住佛寂灭。二于我我所下明大行无染德。三在大众下明大智无著德。四以大悲下明大悲摄化德。于中初举化事。悉善分别下明化意。谓为众生分别菩萨智信等行令成正觉彼方出佛大慈之心显佛之悲。不尔岂在佛慈心内。六佛身无量下明第七正知如来门。于中初辨如来身语二业。二于去来下明如来意业。于中二。初照三际以摄生。后普于下遍十方而化物。七佛智慧月下明第五至虚空慧门。下文云。菩萨清凉月游于毕竟空。此中显佛月游空故也。于中二。初明照空无碍慧。先照真。次慧心下照俗。后一切世间下会俗显真。二顺众生下益物无著慧。于中三。初现身含受益。解了下明无著。二随顺下拔苦离染益。未曾下无著。三正观下令成善利益。永离下无著。八放光明网下明第八观察如来净业相好门。于中二。初佛光照现。二令一切众下明众寻光见佛十方净业相好。此中二。初见佛自相业。谓先见佛于十方刹所现相好。后菩萨所行下见佛净业。谓先见自利净业。善分别下利他净业。二成就下见佛能成他相好。谓先能成。后皆令成就下所成。九自在法王下却明第六知众生福田门。于中二。先总显后别显。总中初照现如来福田胜相。后释显胜义。以依智缘生故胜也。二别中显如来十种功德为世福田。一身智遍世德。二无碍天缯下胜福临机德。此二是田体状以为田生福义在世间故皆云世间。自下明益物成德。显田胜用。三无上导师下明导师巧引德。无畏乘是导师游处也。四一切世下明医王善疗德。初治惑障。次善能下令离苦报。后随其下令离恶业。五随其所应现佛下随应现身方增善德。六一切众生下觉迷安怖德。七如来最胜下智王开晓德。八无量功德下因圆果净德。于中初句标果。业行下显因圆。谓因时于世所修业行但能感示世间之报。及慧到岸成佛之时令前行等皆悉清净以出染故。九能满下能满世愿德。十示世下能为世友德。是故名佛为胜福田。十光明清净下却明第九正知法身普照十方门。于中七。初照除行障。六弊中举初也。二悉令下净其行愿。三等观下破染生净德。于等观等佛智普照也。起净业令修对治。降魔殄染缘。灭惑除染因。生力是所成德。谓十力也。四一切世间下破痴授智。前破四住此灭无明。初破痴法施下授智。五如来智下令离怨满愿。六最胜下为缘生善。初总。少修下别。谓以佛田胜故少修供养获大功德置众生无尽智地。是故德大显上果报无量。智地显上具足清净。七喜德除难。谓善由心起。心既见佛生喜。喜心中生善广大。是故除三恶八难也。上来十门别辨竟。自下第二总结名。但此佛德既圆融无碍同一法界之身。是故此结皆有通别。如是正念如来者。通论总具上诸功德名为如来。明此大众于如是如来专心住想名如是正念。别论此结上第二门。二者通论上诸功德总名正觉。以无不照察故。明众于此摄虑照达故名如是观察正觉。别论此结上第三门。三者通论上佛诸德无不总是智慧之渊。以明照无底故。明众于此智契相应名如是入也。别论此结上第四门。四者通论上佛诸德总是功德大海明此众智契合名入也。别论此结上第五门。五者通论上佛诸德总名虚空智慧。以鉴照名慧则慧称性一味无限无碍名空。明此众智达到其际名如是至也。别论此门超结上第七门也。六者通论具上诸德之佛名为众生福田。以此堪能生胜福故。众了达此名如是知。别论超结上第九门。七者通论具上诸德名为如来。以皆从证理而成故众知可解。别论却结上第六门。八者通论上德无不皆是佛果净业之相好。众观可知。别论此结上第八门。九者通论上德无不皆是大功德法而成佛身。无不明照普遍十方。众知可解。别论超结上第十门。十者通论上德无不皆是如来不思议自在神力。别论却结上第一门。又此上十门应以六相融摄取之理方显耳。自下第二明众见佛身光明妙用。于中有三。初见佛毛孔出光用有十句。初本余九末是光中事。并法门可知。二尔时诸天复见下明见佛从身出光用。三又睹自在下见佛神力益物用。就身光中有二。先见出杂色光。后又佛身下出妙宝光。前中七句。一光照法界。二示现下光现说法。三显现阿僧祇下光现奇严。无尽中生者释不穷尽义也。四悉普照下现光中刹内佛出益生。五显现下现多化身。六普照无量下照穷法界。七持一切下明光起意。下出光因。谓平等真如是佛所住从彼生也。二身出妙宝光中有二。先出光辨因有三。一功德二大愿。三不放逸。后出生无量显光用。三明见佛神力益生中二。初通益众生。二于一切下广益菩萨。上来大众观佛法界身云竟。自下第二明佛现此身云之意。于中有二。一现此身云为益众生令随正行。二如来显现下为令众生知佛无边自在胜德。前中大悲普覆明佛现德之心。智慧庄严显所示现德。谓牒举上文所现之德以皆是大智庄严显故也。欲令下正显所为。于中三。先随位渐次益。有六句。即是信等六位之益于果位中得深法是大涅槃。具慧光是大菩提。余可知。二满足下随行渐次益。于中亦六。一求果心坚。二不坏法性下于法观解。三满足下依解起行。四成就清净下行成入证。五具足修下明证满德备名普贤行。六成就如来下因圆得果。三远离下随义差别益。于中三。一令远邪魔得正智愿。二令常见佛得大智断。三令常依佛得法入众。二令众知佛无边德中现如是等类无数净善。总牒上文所现之德。以皆是佛净善根相故。调众生总举其意。云何现德而为调生。谓悉令知佛功德海。正显所为有二。初别辨后总结。别中五。一令知佛德备。二如来下用广。三本所下果极。四成就法王下智圆。五成就最胜下德深。谓体净德齐。相严丽也。二于一切劫下结德无尽。以别说难周故总通结

第六天王敬请中。善来者明佛具法界德不动而来故巧应机来故顺理而来也

第七佛受请成益中有二。初升殿益。后尔时世尊下升座益。前中二。先受请升殿。后尔时下明其益相。前中二。先升此界殿无边相海是佛相庄严。令天王喜等正明受请意。即升殿等明机缘契合也。二如此下结会十方升殿圆满。二益相中三。初严处益十句可知。二尔时下明天王得定益。于中初不乱正念正明得定。下依定增善。增善有四。一进心。二喜心。三菩提心。四总持。三令天王忆自宿善叹佛。显处益中二。先此界谓叹前夜摩十佛之前十如来寄显渐深远过前故也。理实通于一切诸佛。后结十方。第二升座益中二。先此界升。后十方升。前中二。先升座。后益相。益相中。先法益谓初现同三世佛之身。二应机说法。三明法身无著。下明事益及结并可知

    兜率天宫菩萨云集赞佛品第二十

初释名者。明如来将说妙法必英徒影赴电速云臻遍满虚空集于法界各以妙偈叹佛实德故以为名。又天宫是处。菩萨显人。云集是身业自在。赞佛是语业功德。约身语处用以题名

余来意及宗并同前释。但加叹菩萨德及光益为异

四释文中四。一集众。二放光。三叹众。四叹佛

初集众内。先此界集后十方集。前中三。初举本位。二一一菩萨下明集来。三以正直下显德。初中佛力显集所因方等显分量。国名坚固者表显所依行成难坏故也。佛与菩萨同名幢者表回向善巧因果独出摄伏故也。宝网覆身表德备也。放光用广也。三叹德中二。初叹其行德。于中二。先自行后一切众生下利他行。谓十地已还等一切众生同时于此菩萨身念念观见。别别法门皆新新引摄。故云观无厌足。二此菩萨下显所得法门。于中初总。后所谓下别有十种法门。一身遍游。二智见理。三多身遍。四入果用。五得果智。六巧便光。七广辨。八深持。九见法界。十尽虚空。应以六相融摄思准

第二放光中两膝放者过前足指表行渐胜故也。又膝有屈申进趣用表回因向果进升之相故也。于中四。一出处。二光数。三所照。四缘见。谓因时同行果时感会故见也

第三叹众德中二。先别叹。后总结。前中二。先明所乐谓佛不思议解脱用也。二明所得于中有五。一得法界身。二得无碍下明得法界心。于中有四。一三昧心。二无著心。三无碍心。四离垢心。宝心是证心故能离垢也。三得佛无量下显得佛力。初标。决定下释显也。四得诸下明得佛证。初标入深下释。谓入深智是能证底。净法身等所证底。五得一切下明得佛智。于中十句。初句总标。下九别释。于中。一智依理起故云妙趣生也。二智起开明。三成金刚大智。四金刚喻定破微细愚。上来本智。下明后智。五摄生智。六自在智。七无著智。八照俗智。初名学数终名究竟。九善住下照真智。后成就下总结无尽。此等并是究竟位中菩萨与佛同一法界。是故皆云得佛所得也。但就因门说为菩萨耳

四偈叹佛中十段内。初金刚幢标别说人。以此菩萨为先首者由是会主故。承力显说所依。普观四意同前会释。十颂叹佛寂用无碍德。于中分五。初二明佛无生灭示现有。初颂正辨。于中。初半无生灭。下半现有。后颂寄对彰深。谓上半寄劣显深。谓则寂之用非四心境是故难思。下半就胜显妙。既非四心是谁境界。谓彼智还是佛智及普贤位满智境。以称佛境智要佛智方尽故明深也。二有二颂明佛非色声示现有。亦初颂正辨后颂寄显。上半亦寄劣彰深。谓凡小及地前名劣智也。下半就胜显妙。谓地上证智能为佛本名本业智。十地位满名成就则普贤智也。又成就亦是佛智。三有二颂明佛无来去示现有。初颂正辨后颂显深广。谓此则无来去之来去。身遍诸刹语广说妙意恒住寂。又上三句显广。下一句显深。四有二颂明佛智不动示现用。亦初颂正辨。上二句入证。下二句现用。后颂显深广。上半深。下半广。五后二颂劝修辨益。初颂劝修。后颂辨见益

第二以观佛心坚名坚固幢。十偈分三。初七叹佛德。次二劝修趣入。后一结见闻益。初中五。先二偈明体用超情。谓初一体深。次半用广。下半超情。二有二偈明德深劝近。初偈德深。上半说深法。下半起净身。谓明佛净身随顺万行因缘而起。谓本性为因所修为缘。何故显此德者明从缘起是可成法。后偈劝求义理便故。三一偈叹佛令供广。益德谓净心常心供令成佛。四一偈叹佛令观增行德。初句增长德。二长行。三离惑。四结观。五一颂叹大人观解德。谓究竟法性之佛子方解了故。劝修中。初偈劝起欲求道。后偈劝报恩敬近。下结益。上半结叹。谓见佛结上佛德。闻佛法结上导师所说等法。下半显益

第三智力勇健尽佛海原名勇猛幢。十偈分二。初七叹佛为修行胜缘。后三显佛自在之德。前中初一明佛难见要具净信心为因佛力为缘方得见佛。细色合佛以难见故。二明见难尽。谓要以普贤猛智方尽原底。三明佛难成。谓要依圆净心海十地之所出生。四明佛法难遇得便离垢。五明佛难逢见能灭惑。六明闻信难成要由善友。七校量显胜。若化一人令信入佛德过上施。下显佛德中。一德圆。二用广。三体寂

第四以于生死夜现晖智光名夜光幢。十偈分三。初一叹佛用广十方普见故。次七明佛用深融理而起故。后二双结深广无涯底故。用深中。初一体一无一故现多。二明无二而二现庄严。三明一二双融德无尽。谓空喻体幻喻用。上叹此佛下类余佛。四依体起用。五用相无功。摄论云。如摩尼天鼓无思成自事。如是不分别种种佛事成。六明体用无碍。谓则体成用而不失体故云不坏法性。即用常体而不废用故云不着法界。是故由不着理故恒用不废。由不坏性故用无不寂故也。七双融自在。上半约体绝待。谓化非化俱不可得。下半约缘示现化非化。又上二句标。下二句如次释可知。又释此明依真起化作二门释。一开义。二融合。初中真应各有二义。真中。一不变义。谓虽现化而常湛然初句显之。二随缘义。谓不守自性无不现应故云亦非非化。二化中。一无体即空义。谓揽缘无性故云诸法无化。二从缘幻有义。故云示现有化。二融合亦二义。一别合。二通融。初中由真中随缘则不变故。是故亦真亦不真。非真不非真名为真法身。化中体空则幻有故。是故亦化亦不化。非化非不化名为佛化身。二通融。谓由真不变显化体空。此是真不无化不有。以为法身不无化用。以有化中空义故。又由真随缘显化幻有。此是化不无真不有。以为化身不无真理。以有真中随缘义故。又由随缘幻有不异不变体空故。是故现化纷然未尝不寂。真性湛然无曾不化。真化镕融为一无碍清净法界。思之可见。下二偈双结中。初结上体深无底广无涯。后结上用。上显深。下彰广

第五深慧无碍名智幢。十偈分三。初四叹佛德用无限。次四叹佛一异无碍。后二叹佛生灭自在。前中初二显用无限。后二明德无穷。前中先辨感用之器。谓具无碍智及无限悲修行之者普于十方常见诸佛。此显如来于彼大机之所无时暂隐。然有五义。一一身圆广故云十方见。二一身则一切故云见一切佛。三明此用未曾暂歇故云常见。四显此用未曾不寂故云无来处。五彰所说复深故云法亦无著。下明德无穷内。谓前所现一切之身彼一一身各摄法界无尽之德。是故于不思劫说彼一身之德尚不可尽。况余一切之身三世众生等校量显多。二叹一异无碍中。初一法说。谓无二法界融故不可思议。何者谓不可无二思以现多身故。不可多身思未曾有异故。不可一多思以无两法故。不可俱非思以体用宛然故。是圆融难测量也。次一喻况。次一法合。下一释非一异。并可知。三生灭自在中。初一明不生灭而现生灭。后一明所现生灭还则不生灭

第六照理可贵故名宝幢。十偈分二。初三叹佛身心自在。后七叹佛出世自在。前中初二明身。一无量现量。二无处遍处。下一自明心。上句明无八识心王。次句明无心所有。下半结法体。智论云。佛地无有心心法也。问若约法身可如上说。约受用身无心法。岂可令佛同非情类。答若依初教佛地具有清净八识及二十一心所。设言无者但无染识非谓无净。又由智胜但云有智。非谓无识。若终教唯一圆智内证真如外起化用。亦无心王心数之异及八识差别故。梁摄论佛果唯如如及如如智独存故也。若约顿教以始觉则同本觉无始觉之异故。遂合此智当相则是如。智相亦尽。唯一妙理离言绝虑为佛果也。若约圆教既理智混融举法界俱为智。说十显无尽。是故此智未尝不即法界。思准之后七中。初四明此佛后三类余佛。前中初二明佛为益出世而则无出。谓初一明不出有损。次半明出世益。下半显实无出。诸法无行经云。如来不出世亦不度众生。众生强分别作佛度众生。解云明此释迦身出世之时则常无出。非谓别约法身。下二释不出世所由。谓凡论佛出皆于时处。今推此二俱非等觉。是故即出而无出也。下明众生机熟。自于心内见佛日出。然佛自觉本非净日。下类余佛。中初一法说正类。上半牒前出。此佛出世则无出义。谓前众生心所见佛并是虚妄无有故言语断也。下半正类三世佛出。理亦同然。次一喻况。上喻佛出则无出。谓破闇名日出。日出闇已无。闇无日非出。是故出则非出也。下半喻不出而出。出但有名也。下一法合。上半合出则无出。下半合无出而出。出但有名。是故不异彼不出也

第七勤观妙理名精进幢。十偈分二。初一泛举诸佛标德同应异。后九正叹此佛。前中身同是法身同。义是功德同。下半应异亦是用同。文意理实诸佛体德齐同。所有异者皆随应现。此同等功德。如无性摄论云。于法身中所依意乐作事无差别功德者则是开示逮得一切佛平等性。所依无别者一切皆依清净智故。意乐无差别者一切皆有利益安乐一切有情胜意乐故。作业无差别者一切皆作受用变化利他事故。后九中二。初三略释。后六广显。前中初一明境义深广。释上义同。二明身非是根境内外。释上身同。三随机见异释上应别下六偈中。初二明法身体非分数。先法说后约喻。如横计之我本无所有。纵四智五眼思亦不及。以无物故。此举妄计情有理无非圣智境。以况法身理有情无非下位测。二次一明依体现相。次一应缘见用。次一明用成益。后一显用广大

第八净慧照实染障已除名离垢幢。十偈分四。初三叹佛身智净。于中先一叹净智益世。后二叹身净。一拂应显真。二依真现应。二次二叹三业净。初一意业净。谓名德虽高而心常安。后一身语可知。三次三融摄净。一照理。二现事。三融显无碍。以器世间则是智正觉故云即是身。此身无性复则真谛故言则是最胜。最胜是胜义理故也。下半释显无碍者是上融摄相即等知彼故名无碍智。四后二离妄净。一泯境智。谓菩提是能照佛。法是所照寂故无得。后一绝三际。谓于三时求前智证竟无得故离彼倒也

第九了佛应身即同真故名真实幢。十偈分二。初二明佛无方大用。先一明所应处。后一明所现身八相用也。下八会用同体。于中初二约思见会。先一征用。后一同体。二次一约身土。上半举用。下半会体。三次一约化用会可知。四次二约佛德会。初句标涅槃德。次句标菩提德。下半如次释可知。次中上半举神力德。下半总会无所有。五后二约佛因果会。初一牒举因果。谓明佛往昔知唯心道理明解诸法悉皆如是不可得故。是故速成正觉。由此佛果平等离言同一真体。后一正会显体可知

第十善解成佛之法故名法幢。十偈分四。初二明近佛益。先一总举。后一释成。上半举损显益。下半彰益异损。二次三明于佛所发心利益。先一总举。二释成。三校量显胜。谓不知发菩提心之方便犹非供养。若能一念发菩提心则是最上法之供养。三次二明于佛所闻法利益。于中。一由闻故求因。二由闻故得果。四后三明于佛所生解利益。于中初二举损显益。一标二释。谓过去无量劫由不知是法既不成佛。今时纵尽未来际劫若不知是成佛之法终亦不成。下一彰益异损。上半举理境法。下半成智行法益也。上十菩萨百偈叹佛。或总为一。以融会为一法界佛故。或别。以十佛百门德差别故。或同。以百偈无非显佛德故。或异。以门门相别故。或成。由此德缘佛果立故。或坏。各住自法本不作故。准思之。又此偈后应有结通十方世界。但为前诸菩萨各云普观十方。则已显现故不更论。前会等处皆准此知

    金刚幢菩萨回向品第二十一

释名者。德成无坏喻号金刚。独出世间举幢以表。此中即以金刚为幢。菩萨是人。有彼德者。有财释也。回已善根向于三处。此是行德法。谓刚幢之回向。依主释亦通有财。又通持业。以人法相即故。但以寄人显法故双举耳。此即从德标名依人显法故也

二来意者。序分既彰。正宗宜显故次来也

三宗趣者。十种大行回向三处。为此品宗。又以无边行海随顺无涯大愿成就普贤法界德用为此宗趣。如下文显引之

四释文中有六分。一三昧分。二加分。三起分。四本分。五说分。六证成分。以随行别颂故无偈颂分。同下地品。初中何故入定者亦有六意同前。释文中三。先标入定人。为说金刚法故。高出法故不异名入也。二承力。三正显所入。菩萨者标人别法。简非果定。明智者泛论有四义。一初加行定。谓是证智之明故云明智。如明得明增等。二约根本智定。本智证理破无明等名为明智。如大乘光明三昧。地论释。光明者对治无明故。三约后得智定。明了所缘故名明智。四约自在智定。谓普贤圆智朗照法界故名明智。如锭光颇梨珠照十佛世界等。此中智是体。明是用。又若三乘寄位言此中唯初定。若约刚幢自德论具本后二智定。若约圆教显唯约后一门。三昧此云等持。如前释

二加分中三。初中总显能加。二辨加所为。三正显加相。前中亦五。一明诸佛现身。谓十方百万等散居相去同前准之。又多佛加者增重法显同亦如前。二同名者四意同前。三告叹得定。四善男子下明得定所依。谓十方佛自说作加令得此定。五又卢舍那下彼佛自释作加所由。有四句。一由舍那宿愿力故令我作加。二由舍那现在神力相感同加。三由刚幢智净上感是故作加。四由诸菩萨善根机熟应闻此法感诸佛加。是故刚幢得入此定。又前十住中但有自善根力无诸菩萨力十行中有诸菩萨力无自善力。此中具者显位相渐增前后影略故也。四中初二果力后二因力。何故须此四力者。初力显法根深久远积德而成。二德成现在动发扣机。此上化主力。三助化力。四机感力。二辨加所为中二十二句。初十标所成。后十二明所作。初中欲令菩萨字通下诸句。十句分三。初四令诸菩萨得智德圆。一十无畏智于缘无惧。二四十无碍智常说不断。三入缘起法界相即自在智。四令因智入果显成圆极广心是大悲也。次三令诸菩萨福德满。一明善根广多。二明善离染谓无漏故名白净。三明善甚深谓入普法界。又显重重无尽。以一一门中摄一切门名普门。故乘此普门故入深法界。是故具德无穷尽也。后三令诸菩萨起用自在。一令现佛神足通。二令净宿命念。三令得诸根智力。谓分别佛境以持机根。又有本作谓持彼善根使增长也。为成此等益事。是故加也。二明所作中十二句分二。初三正明所作。谓广说正法。一总显多门下别辨。初句明持成就则起说方便。后句正显所说十向圆备故云具足。下九显说所为分三。初三约位。一摄地前。二安地上。三绍佛果。次三约修。一令开发十向大愿。二令说入实际回向。三令知回向广大法界。次三约人。一令种根者生喜。又以回向是一切菩萨同所修故悉欢喜也。二明此回向是一切佛同所修故劝令修也。三结成因行。谓行为了因能显性故名护持也。又释前十成诸菩萨自利行。后十二成诸菩萨利他行。然亦互通。又皆初总后别。同异成坏准地论应知

第三加相中三。先语业加。次意加。后身加。初语加中九句。汝说此法者是总余是别。此说法有二种。一他力说。亦是果力亦是增上缘力。如经承佛力说故。二自力堪说。亦是因位力亦是因缘力。是故此法以自他因果亲疏融合方得有说。自力八中。初三明有作净法力。一总谓既住佛家理宜宣法以行家业。下别一长无漏功德。二入总持智慧故在佛家。次二句无作净法力。一证佛常身。二照法真性。后三显身净力。一白净等是二乘不同尽。二住广等是菩萨尽。三住无碍等是佛尽。此是地前而云佛尽者。是圆教普贤位摄。如前后说。二意加二。先正加。教释偏加意。前中十句。初一总余九别。别中初三与授说智。一分别句身是辞无碍。二无留碍是乐说无碍。三无碍法明与法义二无碍。次三与同化三业智令以三轮同佛成化故可知。后三与说法仪式智。一令说法时心无偏党但为利益故云向福智也。二触对诸法皆能发生巧便胜解。三对缘正说无有穷尽。又初是说心。次说解。后说行。一切处是顿说。不断是常说。释偏加及身并起分。并如前释。第四本分中。先警告大众。下明显有二。先明体后显相。前中二。先总标。二悉普下别辨不思。大愿者总标起。谓期求名愿。深广名大。出过分量名不思议。此是普贤自体无障碍愿具尽法界无限德用。如下此品所说。诸德总在此一大愿句内故云不思议。总说虽尔别论有十。一所期不思。谓要得无上大菩提。二忍苦不思。谓无有世间恶道等苦经多劫受能坏此愿。三受恼不思。谓于背恩恼害菩萨难化众生如初摄化大愿不转。四难坏不思。谓无有天魔二乘异说能坏此愿而不从化。五广故不思。谓尽法界众生界等如十尽句说。六深故不思。契同法性如性起愿。七佛摄德不思。当体具摄法界之无限大功德海。八出生不思。谓依此大愿出生一切波罗蜜行不可穷尽犹如大海出宝无尽。九大用不思。谓大愿宿成无功辨事如灭定闻声愿力起等。十逆顺不思。谓大愿普应类机成益逆顺多端非下位测。然大愿实德无尽。依则辨十。并皆如下说分中显。下别普救等明利他广大。学三世等显自利广大。各具前十义可知。又此中初是观相。次大善。后不怯弱六决定中有三也。余义同前释

二显相中二。先举数显胜。谓三世同说显法要胜。二列名显胜。先列名后引三世同说显胜也。列名者十回向义略作五门。一释名。二义相。三体性。四定位。五行法差别。初释名者先释总名。一周圆数依则说十。回向是义即带数释。然回向有三。初约理者。舍相曰回入理名向。二约利生者。得理不证曰回大悲随有救生名向。三约菩提者。所修善根不愿三有二乘名回正趣无上菩提曰向。二别名者菩萨善根济诸众生烦恼业苦名救。令住菩提名护。虽成救护然于众生照性平等故名离相。又救是大悲。离是大智。又初是广大等心。后是不颠倒心。回向是行。谓以善根回向成如此救生离相之行故名回向。从所向立名。二于三宝得不坏信。以此善根而成回向。此约能回行体为名。三学三世佛所作回向名等诸佛。从所学立名。通能所回。四菩萨令善根至一切处而亦回向于一切处。通能所立名。五以自所成无尽功德之藏而成回向。从能回向行为名。六施绝三轮名顺平等。此亦是能回之行。又名坚固善根者舍三不坚顺成三坚故名也。七以善根等以顺益众生。能所立名。八善根合如。以成回向所依为名。九不为相缚。不于见着。作用自在故名解脱。如不思解脱等亦能所合目。十称性起用。谓以法界善根回向法界。当法立名

第二显义相者有二。先别后通。别中前七随事行。后三称理行。前中初一悲智不住明行本。次四明行相。于中初一起行心坚。二约佛辨广。三约法显遍。四约德显多。下二明行成。一智行成。二悲行成。后三中。一正与理合显体深广。二明依体起无方大用。三显体用无碍圆明自在。二通论一一中皆有三种回向。谓以善根回向众生。回向菩提。回向实际。此各二义故成回向。且众生二者。一由菩萨善根必依众生成。是众生之分。是故法尔还向众生。二泛既是菩萨必为度生是救生具故理须向彼。不尔即同二乘自度非是菩萨。二菩提二者。一菩萨善根依大菩提成。从彼流故。是彼分故。法尔归彼。二泛是菩萨意其必至求无上菩提。是故家法向大菩提。三实际二者。一菩萨善根缘成无性依真而成。从彼流故。是真之物法尔向彼。二泛是菩萨必为证真背无明故照二空故。问何故须此三回向耶。答此三有多义略论十种。一约菩提心有三心故。起信论云。菩提心有三。一直心正念真如法故。二深心乐修一切诸善行故。三大悲心救拔一切众生苦故。二约成菩萨三聚戒故。谓律仪离过向实际也。摄善广修向菩提也。摄生大悲向众生也。是故法集经云。若菩萨舍于三聚回向之心菩萨不应共住。三约成二行。实际向护烦恼行。余二护二乘行。四成二利行。向实自利。向众生利他。向菩提通二利。又释。菩提自利。众生利他。实际俱非。五为成三德三身。由因位三行果成三德。向实际成断德。向菩提成智德。向众生成恩德。三身如次可知。六约成悲智。智中。照理显事分二故有三也。七唯约悲。谓何故向菩提。为众生故。何故为生。以彼即真而不知故。八约智。谓见众生染相尽故即是实际染相不坏。是故为生授以佛智。故向菩提。九约无碍。谓菩提智证同理性。众生染相即真无异。是故向一即向三也。十约圆明。谓三法圆融各摄法界具德自在。一切法门相即相入无碍思之

第三明体性者有二。先总后别。总中有三。一约所依以明智三昧为体。二以本分中大愿为体。三具论有六法为性。一定。二智。三愿。四悲。五所依法界。六并通慧作用不思解脱等为性。二别辨体。下说分处随位显之

第四定位者此当解行位终第一僧祇满。依佛性论至此位满方名不退之位。依瑜伽此中犹自堕地狱中。有说此犹属资粮位以于回向后。别说四善根为加行故。有说此通二位。以于第十回向之中摄加行故。有说此总加行。以住心已还属前二善根位满心已还属后二善根位故也。上总约初教说。有说十住初即位不退。况至于此。又三贤总为趣圣方便。不分资粮加行近远。此约终教。顿教一切行位俱不可说。又准此下文。于此位中摄一切位具普贤行。是故位满即是因圆。此约圆教普贤位说

第五行法差别者有二。一约实位普贤行相。二约寄法差别行相。并如下说分中辨

第五说分中。但大回向位有二分。一果分当不可说非此所论。二因分随说有四。一唯约位相。如始终教说。璎珞本业经等辨。二唯约自体。如普贤大回向行不依诸位。三以行体从位门阶差说。如此下文。分回向为十门者是。四以位门随行体圆融说。如下一一位中摄一切位。第十即至究竟法界因圆满者是。今此文中正辨后二兼摄前二。亦内摄果分准思之

文中二。先辨一方说十回向。后结通十方所说一切无尽十回向。前中亦二。先正说。后动地等明说益。前中说十向即为十段。一一各二。先长行。后偈颂。长行各二。初位行。后位果。亦有不具者。至文知之。诸位行各三。初标起。二释显。三结名

初回向释中二。先举行体。谓此菩萨所行六度四无量等诸行善根。拟将回向。其文可知。二修善根已下正明回向。于中二。初回向众生及菩提明救护众生。后从菩萨如是回向亦无著下回向实际明离众生相。前中四。初明为众生利益安乐而作回向。于中三。初总标。二以此所修下别辨。三佛子下结。别中二。先以善根济三恶道名救。二复作是念下拔苦置善名护。又初令离苦名安乐。后令修善名利益。于中十句。一拔现苦。二令除烦恼障。三离业障是故无怖。四令至菩提。五令得涅槃。六令断所知障使。七令断所知障习。八令得如理智。九令得如量智。十令得理量无碍智。三佛子下总结。令得一切智。二佛子此菩萨下于怨恶众生调练深悲受恼回向。于中有五。初于怨众生调练悲心。二于恶众生调练悲心。三何以故下以理释成练行所由。四菩萨如是观下调练行成悲念转增。五菩萨以诸善根回向时下正以善根回向成益。初中二。先明菩萨平等观心有标征释。二若众生坏恶下对怨境以练心有法喻合。二一切童蒙下于恶众生调练悲心。于中亦二。初总于恶类心不动乱有法喻合。合中二。先明不动本心。二正意下不失饶益。前中被恼退大学小名散乱。二一切众生下别于恶类不舍饶益。于中有五种众生。一于多恶不嫌。二于难化不舍。三虽有下于邪嗔不转。四若见下于无信不弃。五若与下摄痴无恼。三以理释中。先征后释。征意恶人何幸背恩蒙救。菩萨何事被恼仍救。下释中。先总释。谓由菩萨大智见理能不计恶。由有大智堪救人恶。如日有二义。一虽生盲谤无日无计念。二亦不舍还照谤人。菩萨智日亦尔故云乃至调伏一切众生也。二别释有二。初念本大志成调伏行亦二句。初反举六事。谓既本志不为一众生等。岂遇小违而乖大志。二顺显亦六事可知。谓方成大事。理应受违救彼恶人。二重现大心以成调行。于中初句是总。谓此菩提心体可尊贵故名宝。是故设有违恼为存护此心理应无转。下别中六句。一势力义。谓能生如来之境是故名为彼境力也。二普遍义故云广大。三甚深义故云平等。四离垢义故云无懈怠。五希有义故云修难得。六最胜义故云与佛等也。为此大心理应如此救恶人故。是故菩萨令行增也。四菩萨如是观下结调练行成令悲增长。于中如是观善牒前行解。信心净者于前所解道理信心决定也。下依此决定令悲增长。谓悲行不虚故云非但口言。此悲心是总。于诸众生下九心是别。一欢乐饶益。二无行疑浊故云明净。三屈己就物故云柔软。四怜愍情殷故云慈心。五慈念深彻故云爱念。六摄令同己菩提法中故云摄取。七授与大行故云饶益。八令得涅槃故云安乐。九令得菩提故云最胜。由前思择行解力故于诸众生生此等心。是故依此以成回向。五调练善根正以回向。于中先举善根。谓彼菩萨依胜心正以善根回向之时作是誓念。非直令我昔本善根回向众生。若我因前回向众生所有功德。及为众生回向菩提所有功德。复将此功德回向众生令得如此清净趣等。以此要誓送诸善根令至众生所也。于中有二。先回向众生令成法器。二复作念下令得法成满。前中二。初令得法器身。谓净趣是修行处也。净生是修行身。余是行缘。具不可尽也。二常得下令得法器心有二。先令于过不染。谓身虽尊贵心不错逸。虽居净趣而不迷染故云分别趣。二思量下于德起求可知。二令得法满中二。先见佛得信。二闻法持行。于法行中二。初令成自分行德。七财者。依涅槃经信戒惭愧闻施慧为七。即十藏中前七是也。二修学一切下令成胜进德。于中三。初令自利德满。二于一切下成利他满。有三业可知。三令一切下成佛果究竟。第三从菩萨复念众生造作下明于受苦众生以深厚大悲代苦回向。于中有七。初总于苦生起念代救。于中二。初念众生罪业受苦。二我当于彼下起念代救。于中二。先总举。不以苦故心退等者调练悲心深厚无倦。二何以故下释显代救之意。于中先征意云。他诸众生自受苦恼。于菩萨。何急而欲代受。下释中二。初为满自本愿。是故代救。谓菩萨从初大誓舍自身命只为众生离苦得乐更无余为。是故众生皆是菩萨所荷之担。为满如此同体大愿。是故彼苦是菩萨所忧。下度脱一切等显其所作。谓救苦因果也。二众生常为下为愍其迷谬代救无倦。于中三。初标痴爱是苦因。二染着下明依爱受苦。三随诸下明依痴受苦。于中随魔是痴从邪。疑佛是痴背正。此无善因。不得出世道明不得菩提。不见安隐明不得涅槃。此无善果。常驰等明恒受苦果。二菩萨见众生下标自所作回向救仪。于中三。初总举如前众生受苦悲见回向。二以大回下正显行仪有三句。初以大回等尽自大心。此有四义。一以称法界善根回向一众生。余一一众生亦尔。二为一一众生于无量劫受苦无倦。三要令一一众生先得无上菩提。四然于众生及回向行不见能所。同一法界平等无二是名大回向回向。二顺同三世菩萨所作。谓三世菩萨所应作回向我亦如彼而作。三顺极至教。谓如圆教所说普贤回向我当顺彼教而作。三令一切下明因回向令有所得。三复作是念我当悉令下标自回向救所成益。于中三句。初智王住处是涅槃。二令得一切智心是菩提。三拔出等令离生死。谓拔恶崄等出分段苦。度生死流出变易苦。四复作是念我当为一切下明既见上益建志正欲代其狱苦。于中四。初总标举。二我当为一切下建志欲于一切处代苦。三我当于一一下明于一切时代苦。四何以故下释代苦意。问自作自受云何菩萨能得代邪。答此中菩萨代众生苦。通论有六义。一谓以苦事自要增其愿行故。瑜伽第四十九云。问菩萨从胜解行地随入净胜意乐地时。云何超过诸恶趣等。答是诸菩萨依止世间清净静虑。于胜解行地己善积集菩提资粮。于如前说百一十苦诸有情类。修习哀愍无余思惟。由此修习为因缘故于彼色类诸有情所得哀愍意乐及悲意乐。由是因缘为利恶趣诸有情故誓居恶趣如己舍宅。作是誓言。我若唯住如是处所能证无上正等菩提。亦能忍受为除一切有情苦故一切有情诸恶趣业。以净意乐悉愿自身代彼。领受苦异熟果。为令毕竟一切恶业永不现行一切善业常现行故心发正愿。彼由修习如是世间清净静虑悲愿力故。一切恶趣诸烦恼品所有粗重于自所依皆得除遣。由此断故菩萨不久获得转依。于诸恶趣所有恶业毕竟不作。于诸恶趣决定不往。齐此菩萨说名超过一切恶趣。亦名超过胜解行地。亦名已入净胜意乐地。解云净胜意乐地是初地。由于地前起此悲愿断恶趣业即入初地。于彼有情未必实代。此依初教辨。二约菩萨留惑同事受有苦身。同苦众生为其说法。令闻法免苦故名代也。三设有众生而欲造作无间等业。菩萨化止不从遂断其命。由断彼命菩萨自受恶趣苦报令彼得免无间大苦。此亦名代。此依梁摄论第十一辨也。此上二释依终教。四由菩萨从初正愿为生受苦修习此愿至究竟位愿成自在。常处恶趣救代众生。如地藏菩萨等及庄严王菩萨等。五由菩萨此愿契同真如彼众生苦亦缘成无性即是真如。以同如之愿还潜至即真之苦。依此融通亦名代也。此约同体愿力。六由普贤以法界为身一切众生皆是法界。即众生受苦常是普贤故名代。今此经文顺后三释。虽是地前是普贤位故。是故能代。问若尔何故犹有受苦众生。答此事不定。若令受苦而有利益则菩萨令受亦名为代。此密益非常人所知故不可难。又释由业有二。谓定不定。得报亦尔。彼不定报由二缘力。是亦可转。一由因力。谓彼众生增上作意力。二由缘力。谓由外缘增胜境力。今菩萨于不定报所为胜缘力及令彼发增上作意故令彼报有轻有脱。五菩萨复作是念我当下明诚言表志显为物不虚。于中三。初诚言为物。有总标别释。谓因见众生苦发心为救。此言若虚即本不发心。心因此发。是故言行不虚

二不求尊下彰不自为。亦初总辨。次何以故下释成。后菩萨明见下结不为。三但欲下结其所为。六菩萨复作是念我当以诸善根下明正以善根如言回向令得利乐。于中二。先令得乐。后令成利。前中初得种种乐是总标。下别有十句。一佛果穷极名究竟。二利润无涯名饶益。三超过余人名不共。四无为常安名寂静。五离过清净名无染。六缘不能坏名无动。七称性广多名无量。八性无变易名不死不转。九常恒无尽名不灭。此是大涅槃乐。十明慧自在名一切智。此是大菩提觉知乐。依解节经亦有五乐。一出家乐解脱家难故。二远离乐以断欲得初禅故。三寂静乐二禅为首觉观息故。四菩提乐于法如实觉故。五涅槃乐息化入无余故。二我当为作调御下令成利益。于中十句。初六并举。一师。二臣。三明。四炬。五趣。六离难及解法。以并同上故略之耳。七令解深理。八智行成度。九福行求果。十令向涅槃故云示彼岸也。七菩萨以是无量下明行实成益。于中十句。初一牒前回向。次二下救生苦上顺佛意。次二得正舍邪。次二远恶近善。次二成净灭染。后具足下总结。第四菩萨以善根正回向已下明孤标大志普为众生无念回向。于中三。先标己大志。二明无念求。三显至极回向。初中先结前。作是念下起后。于中二。先喻有二。初一日多照喻。二日照业成喻。后菩萨亦如是下法合。于中二。初明独志广益合初喻也。二欲为下正成益事合后喻也。于中十句。可知。二菩萨复作是念下无念求。于中二。先反举。谓于善众生无念求恩于恶众生无念舍离。后但勤下顺显。谓初令得乐果摄少下令成善因。谓以少善根回求大菩提果故名回向广大。此显悲深。纵令少善亦以方便成广回向。三若诸善根下正明至极回向。谓善无不摄向无不极。于中二。先举至极善根。初反举。谓若我善根实不能益生我亦不修彼善亦不作回向。下顺显。谓以我善根实能益生是故回耳。此明彻到回向。二令一切众生下明回成至极。不着法等令舍妄。以众生性等明入真。此亦是令众生入实际也

第二大段菩萨如是回向亦无所著下明离众生相。即是实际回向。于中二。初明会相入实。二随方便智下明依实起用。亦是初明无回。后明无不回。前中二。初会前回向众生明入实际。二修行清净下会前回向菩提明入实际。前中三。初正显。二但欲下释疑。三以如是下总结。初中亦三。初离妄相。二不住心颠下明离妄想。三不着下明离假名。诸经中多约此三明离妄也。初中三。先会前大悲救护众生。二不求下会前调练悲心于怨恶等。三不取众生相下会前代苦等行。初中二。先会能回之行。谓不见有能回有三句。一总显无著。二破性。三破相。二业报下会所向众生。谓不见有所向。能所两绝平等平等也。于中初总显众生业果俱妄。是以菩萨不着。下别显之。不取五阴是不住有也。不坏五阴是不住无也。此上于众生报果不着也。不取妄业者于众生业因不着。二会前调心中不为求报于背恩等所起嫌恨等。虚妄因缘下释。谓因空故不生。缘空故不起。报空故不住。大悲忍恼名坚固。空故不住之。求恩报等是虚妄法亦空故不住。三会代苦中。不取众生相者明所代众生空无代也。不分别世界者明所受苦处。是上文于一切刹一切地狱等空故无代处也。谓见苦乐染净世界平等故云不分别。上离妄相竟。二离妄想中。三倒即是皮肉心三烦恼也。三以相想俱空名言亦绝。故云不着语言道也。二释疑中。疑云。若众生皆空回向亦离。菩萨何因而作回向。释中五。初句总释。为令众生解此生空无回实法。是故回向。非谓有回。此同净名经为众生说如斯法是则真实慈。二观察等者别观所向众生平等为作回向。三法界印等别显能回善根称性回向。初以理印行。后行性离染故云离欲等也。四解一切下明能所无二同一法界无回而回。五转疑云若如是回向于诸众生何所增损。释此无二之回向于德不生于惑不灭。何以故。以皆即空同真性故。故云不生等也。三以如是下总结平等回也。二修行清净下会前回向菩提以入实际。于中三。初牒举前行修对治是出世因也。善根向出世正是前回向菩提。二于善根下正会入实。于中初句总标举。不作二相者善根业是因所向。出世萨婆若是果随相为二。会缘归性平等不二故也。下别显之。先明因果不即不离。显俱离有无故名不二。后愿智业下明离有无之因果称性皆明净。明净性不殊故名不二。此下并同净名经布施回向一切智为二布施性即是回向一切智性是名入不二法门。三舍离下明观益。初离散动益。离憍慢等离惑染益。上来久实竟。自下第二依实起用。于中三。初总标。谓于寂不滞即实起用名随方便智。二令一切众生下正明所作。谓令众生得此即真之脱。不着法性者不滞寂也。称性善根故云无量等也。无业报出业报者明依理起事以成无功之大用。明业果不亡也。三结观益。离恶是离过益。佛赞是成善益。又离恶趣下益。佛赞顺上益。佛子下第三总结名也

第二重颂中二。先叙意后正颂。初中承佛力显说所依。观十方明说分齐。谓十方同说故也。及一切众彰说所为。观法界显所说理。入深句义明教义玄。大悲普覆辩说心广。护持等明所传益。谓令此法流行即是佛种不断。入一切佛等显所入益。出生等明所出益。善能分别等彰应机以法。谓分别心是知欲也。过去善根是知根也。知时不失是机熟授法不失时也。具足等明所现说法之身。谓内具法身外现色身。此是有法门之身故也。下正偈颂中以四句为颂。有二十八偈分二。初五颂总叹殊胜。非颂前文。二十方一切下别颂前文。初中分二。初二颂明大心为物方入此藏。于中有六心。初二句明广心。二坚心。三常求等是胜心。四净心。五敬养心。六深心。解法是智。救生是悲。彼能善入等者结行入位。具此六种殊胜大心方能入此回向之藏。是故此藏为极殊胜。二有三颂明大力为益生方入此地。亦有六力。于中初一颂中三力救生。一猛勤力。二净智力。三坚忍力。常能下一句正结救生。二一颂中二力益生。初净信力。谓无等是佛。心安是信心安固也。喜净释显信相。二大忍力。谓受恼荷载故如大地。下句结为益生。三不以苦行下三句明大悲力救生。初二句举悲行。常能一句为结救生。上来总明大力救生能入之行。下彼人速入等结行入位。谓具彼大力方能速入如此回向大无碍地。是故此地为极殊胜。第二正颂前文中三。初有三偈。颂前所回行体。于中初一偈颂前四等行。谓普摄众生。心安住通具四心也。修回向者明行堪回向故也。后二偈颂六度行。二十方一切世界中下十偈颂前救护众生即是回向众生及菩提分七。初二偈颂前利乐众生回向。一颂安乐。二颂利益。二有一偈颂前代苦回向。三有一偈颂前回向意。谓不为五欲。但为生求佛。四有二偈颂悲智行回向。初是智及行。后是悲及行。谓游界安生是悲也。此犹是前调练行也。五除灭下二偈颂离染心回向。犹是前于恶众生不起嫌心等。六菩萨未曾下一颂明不着五蕴三界回向。七诸佛下有一颂。总结菩萨摄生行极。三菩萨一切心安住下十偈颂离众生相。即实际回向分二。初三颂前会相入实。初二明三业契真。后一明三业顺理故令佛喜也。后七偈颂前依实起用。于中有四。初一颂明身业胜行。二有四颂明意业胜行。于中。一止恶。二契真。三行坚。四行满。三有一颂明语业胜行。谓不着言不碍语故也。四末后一颂结行顺理令佛欢喜

第二不坏回向中二。先长行后偈颂。前中亦二。先位行后位果。前中三。谓标释结。释中三。先举所回行体。二菩萨如是等善根下正辨回向。三菩萨如是善根回向欲度一切下明回向益相。初中二。先明不坏信。二佛子菩萨安住下明依不坏信生长善根。前中十句分三。初三于三宝境得不坏信。先佛次僧后法。二有四句。于所修行得不坏信。于中。一信护持正法决定成行。二信回向众生决定令益。三信所修善根顺理白净。文有标释。四信所行回向之行直心等释成。三有三句。于难知境得不坏信。一信说法师如夜叉。说法亦起佛想。又纵见违行为重法故不坏自信。二信佛果作用。逆顺难知。如现为老比丘等。三信菩萨善巧。示现逆行秘密之事。如现淫女等。此并难知而能坚信故也。二生长善根中有三。初牒前信境明种生善根。于中初牒前不坏信。于诸佛下明对生善。于中声闻等亦是僧宝摄。众生是前爱眼所观所利之境。如是无量境通结前所信多境。由于彼境信不坏故种生得此无量善根。二分别下明依此善根复增大心以生善根。亦先牒善根。谓分别思惟前所生善根令心勇锐增其大心。复生善根。谓由分别前于三宝等所生善故令菩提心长养也。由分别前于众生境所生善故修习大慈也。由此二心增广故依此复更生诸善根故云所生善根也。三广修下明依此大心复增大行以生善根。于中二。初成阿含行。先依前慈心起大悲等观行。后学佛所学等依菩提心起佛所学行。依此悲智二行摄生一切净善根。二明证理行。先依智证理集功德。后依悲慧施修功德。又释。前阿含行是加行中摄善根入实。是正证中集功德行。大慧施等是后得内修功德。行体竟

第二正回向中二。初回向菩提及众生。二观无生性下明实际回向。前中亦二。初正以前善根回向。二菩萨善根回向已下明以回向所生胜报复将回向。前中亦二。初正回向。后菩萨如是精勤下结成。前中十句。初回向一切智总标所求菩提。常见佛下九句回向成因行。于中初五句成行所依。一常见佛。二近善友。三菩萨同会。此三成行缘。次一句成行因。谓念萨婆若。是上所向一切智也。次一句摄行法。谓于佛兴处受佛教法。于佛灭后护佛遗法。自下四句所成行。初一成利他行。谓愿能处有益生而常不离出世之向。次三成自利行。一供师行。二照理行。三满愿行。二结成中三。初结上所回善根。谓无量善是前依信所生善根。积集长养等是前依菩提心等所生善根。二正念等下结能回之智。谓筹虑观照回向道理义真实故。是故回向。三恭敬下正摄威仪以成回向。二依前回向所得胜报复更回向。于中初牒前起行总举所回。令我下正回所向。于中初供养佛。二明供养所为。三结供分齐。四辨能供之心。初中二。先供现佛。后供舍利。初中先举所供佛。于诸如来下正明兴供。于中三。先总。谓如佛所应者明称佛境界所应之供而以供养。谓遍法界等不可知故但云如佛所应。二以阿僧祇下别显供有六十七句阿僧祇供具。三以如是等上妙下总结常供。二此诸最胜下明供舍利。二欲令下明供所为有三。一为益众生是故供佛于中三句。一令众生见此殊胜供养欢喜爱乐生长善根故云摄取。非是菩萨摄众生善。二令依善离苦发菩提心。三依菩提心起行自严超出世表。二示现下有二句。为重佛德是故兴供。一为佛希遇。二为满佛供力。谓于佛兴此大胜供养为显如来威力圆满。三清净下二句为自心于佛信乐至重是故兴供。一为信重佛德。二为爱护佛法。谓兴此胜供令人敬重于佛故也。三如是下结供分齐。谓不穷尽也。四诸佛成就下辨能供行心。于中十句。一初即不退。二中即无休。三终未曾懈。四三时喜悦无间名不坏忧恼。五情无异求名利等故云无著。六亦无彼念故云无心想。七都无现求故云无染无依。八于所生善根亦不生着故云不味等。九既不求现名利复不味善根如何成行。谓佛真实法印印彼所作之业。十心净平等称佛境界故云住佛所住

第二实际回向中二。初始修。二菩萨如是舍离下明终成。前中二。初明称实回向。二以此善下明回向益相。前中七句回向。初一句明加行智观。谓观无生境印能起心明能所寂灭受持等明顺佛圣说。二观平等法性一句明正体智证入实际。三入无行下四句明后智修行观。于中。一明趣证起行。二巧随有行。三处有离染行。四二行无碍行。后一句总结悉回。二以此善根下明益相。于中八句四对。初句厌有心坚故不可坏。二求果心彻故云不退。三自行不乱。四化他不着。五自行广大。六化行坚固。七因行圆净。八果德穷满故云究竟等也。自下第二终成行中。初牒前起后。观察平等下正显入法之行。于中二。先明无碍行。后如是菩萨下明摄行回向。前中二。初十句明解法至深。二分别菩萨下明起无碍行。前中初句总观诸法理事无碍故云平等。谓等理之事穷彻圣源故云深入。等事之理尽兹事际故亦云深。双融无际智解穷底故云深入。下九句别显。一明业无体。二报暂酬因。三诸行无主。四缘生无属。五正行似有。六无著法眼生者释菩萨行如影所由。谓如世眼瞳所现影像今此亦尔。依法眼现也。七既由无作法眼之所作故。其性恒寂也。八会有为同无为故云入也。九双融无二故云解如实性。涅槃云。明与无明愚者谓二智者了达其性不二。不二之性即是实性。此之谓也。下明起无碍行。于中四句。初明理事无碍行。谓由解前不二法故分别行相而不着相也。二二利无碍行。谓同事利他不舍白净为自利也。三障碍斯离故结无碍着。四由解行深故诸佛护念外缘胜也。远愚痴内行增也。自下第二摄行成回有三。初则不坏事而明见理以事即理不待坏故。二善解下明不碍理而巧现事以不待坏之事不碍存故。如是无碍方于法性而到彼岸。三了法回向。谓如理之回以向佛地大智令诸余善根皆称理成故云心净也。是故此回终日回而无回故云行无所行也

自下第三大段明回向益相有四。先为度生益。于中。初令增佛种灭诸业苦。后一切众生得下令成果智灭诸烦恼。二究竟下明成菩提益。三得平等下结实际益。四摩诃萨下总结回向成趣果之益。上来别释竟。佛子下第三结名。上来位行讫

摩诃萨下第二明位果。于中。初十句别显。后一句总结。前中。初一见佛益。二得法益。下八成行益。三普于众生下利物心成。四舍痴入法自利解成。上来自分行成。下明胜进。五得诸如来等明破邪行立。六具足生贵等明具正行本。谓出世间心为生贵也。又从佛正法生故也。七得无碍智等明大智内发。八于一切法等智起照实。上来成智正觉世间智。九于一切刹下成器世间智。十智慧具足下成众生世间智。下一句总结可知

第二偈颂总有二十五颂分四。初二颂前所回行体。二一切上妙下九颂半颂前回向众生及菩提。于中分四。初四颂前因回向得胜报供养诸佛。二善分别下二颂前供佛所为为益众生。三一切诸佛下二颂半颂前供佛舍利。四菩萨善知下一颂颂前供佛回向行。三胜妙智下七颂半颂前实际回向。于中分四。初三颂明观理随缘行。一半自利一半利他。二观众生心下二颂明推缘入实行。三分别所有下一颂半明双融无碍行。四方便回向下一颂明结行成相。四菩萨一心下六颂前结回向益相。于中初一上念诸佛。十地论云如佛所得我亦当得名为念佛。二下救众生。三守护正法。四处有离着。五摄法离生。六德圆离相。各一颂显可知

第三等诸佛回向中亦二。谓长行及偈。前中亦二。初位行后位果。前中三。谓标释结。释中三。初标举所学回向之意即释名也。二此菩萨修行时下正显回向。三如是摩诃萨以诸善根正回向。已成就妙身下明回向所成益。第二正回向中二。初众生菩提回向。后复作是念如彼过去下明实际回向。前中亦二。初因事以行回向。后摩诃萨若在家下随缘摄善回向。前中三。初举因事之行。二正以回向。三摩诃萨以大愿摄取行等下结成益相。初中谓于二境得三净心。一于违顺二境得离憎爱之结。二既离此结喜乐无坏。三既离结情欢令身心调畅轻安适悦既得此乐因即回向。二正以自乐回向之中有三。初回向佛。二回向菩萨。三回向众生。初中明自得乐之时念欲回向供诸佛。是故先牒诸佛自乐故云诸佛虽有净妙快乐。下有十句。正愿诸佛所得之乐。问诸佛德满乐圆何须愿佛得乐。设愿佛德岂增。答佛岂须人间香华为表孝情供养以此菩萨爱敬如来。是故自所得乐回以向佛。十中初一总。谓愿佛得非我测量佛所住乐。余九别显。皆不思议也。一三昧乐是佛自德所依。谓出入游适故也。二大悲乐是佛化德之本。谓处生死如游园观。三解脱乐是佛不思议解脱。如下不思议品说有十种等。谓离碍自在故称乐也。四神足乐是佛通用自在故乐。如十通等。五尊重乐是佛胜德。独出无比故云乐胜乐被人名覆如来。六无量力乐是佛十力智用自在名力乐。上来是大菩提乐下是大涅槃乐。七离觉乐是佛涅槃离觉观故。涅槃经云离诸觉观名为涅槃。八不变乐是变易生死尽故也。九不坏乐是佛德圆常乐。略举三事。一佛德无碍无能使碍。二无不在定无能使乱。三无知不知之二行无能使二故云不坏也。又此九种摄为四。初一三昧乐。二大悲乐。次四名大智乐。后三名寂灭乐。二回向菩萨中十句分二。初令成自德。二能下令成化德。前中六。初令得信位百四十愿。二令入十住正解直心。三令修十行波罗蜜行。四令住十回向金刚幢大菩提心。五令成初地已上求智佛心证不退转。六令得八地上无功用行故云不舍大严守护菩提等。二令成利他德中。初化令成地前行。二安住下化令成地上行。三得诸下化令得八地上德。四证萨婆若下化令成果。三回向众生中。初结前生后。次正回向。于中二。初明菩萨自力回向益生。二如佛下希同诸佛回向益生。前中十句回向。初一回令见佛闻法近僧。次三回令念三宝。余六回令起行。五不离佛是近善人。六令于佛起净信。七令分别生解。八令起行成德。九令成净通之因。十令疑或永尽。二同佛益生中。先总举同佛。二令一切下别显其相。于中十事。初五令离苦谓出四恶趣及诸难处。后摩诃萨下五令住善。初成地前行三句。一发心。二长心。三离障常乐。下成地上行。令一切生究竟等成果德。三结叹益相中。以诸大愿摄取行等者此文意难见。致令诸德释各不同。光统师云。此结上三道究竟之义。行等行者结乐与佛成证道行。积聚等者结与菩萨成助道行。长养等者结与众生成不住道行。远法师云。证心游理名行。一备一切名等行助道渐满名为积聚。一一行中具一切行名等积聚。不住渐增名为长养。一一门中备摄一切名等长养。范法师云。但起一行名之为行。总众多行名为积聚。增进胜前名为长养。犹是前行异名显耳。菩萨所行行既无量不可备举。但等言之故皆云等也。正法师云。善根者施等善也。以诸大愿摄取者愿大故行大也。行者二利行也。等行者等行一切行也。积聚者积行成位德也。等积聚者成一切德也。长养者从行生行。等长养者生一切行也。辩法师云。行者是佛于愿乐位中所行。菩萨以大愿摄同彼行故云等行。积聚者是佛功用位修积聚。菩萨同修名等积聚。长养者是佛无功用位修。菩萨同修名等长养。是故上云如佛回向开化一切。菩萨回向亦复如是此之谓也。今更释。菩萨所有善根皆以大愿回向力故令此善根摄成胜行。诸行齐行。故云等行。又由愿力摄此善根所成诸行。令不散失故云积聚。有行斯积故云等积聚。又由愿力摄此善根所积众行。复生诸行名为长养。一一行生一切诸行名等长养。是故皆由愿力令此善根皆悉广大具足充满也。上来第一因事之行以成回向竟。自下第二随缘起行以成回向。又释。亦得上来是为菩提回向众生是故结云长养等也。自下为众生回向菩提。是故结云今集等善皆回向也。于中三。初明大悲随顺回向。二复作念乃至小大下明大悲深重回向。三如是菩萨下总结三世回向。初中先别显。后是为下总结。别中三。初明悲故随染巧智无污。二摩诃萨下正念现前动与道合。三摩诃萨以如是下明于诸群品广成利乐。于中三。先总举。二无量诸愿下别成饶益。于中。初辨能益之行。二除灭下明所成之益。先令除障念法。后修习下成行入地。三令一切下别成安乐谓离苦等也。二大悲深重回向。谓乃至畜生等苦皆救拔也。于中二。初救生离苦后如是等下总结回向成益。前中初令离苦因。离畜生趣下明离苦果永度苦海。是总。谓众苦繁多深广如海。苦受者三受中取苦受也。苦阴者恶趣五阴。苦觉者苦从内发。以觉观为苦。此上皆是粗重之苦名增上大苦。下明细苦。苦行者是行苦亦是以苦为业行。苦藏者身心摄苦众多蕴积。苦根者谓惑业生苦处也。又以苦为依苦为根本。又欲界二禅已来为苦根。苦舍者谓以苦自覆故云舍。又释。苦受是受阴。苦阴是色阴。苦觉是想阴。增上大苦是识阴。苦行是行阴。通论一切有流之蕴为苦藏。苦因能生为根。苦果自阴为舍。小乘为实苦。初教即空苦。经云五受阴洞达空无所起为苦义。终教即真如为苦义。顿教绝言是苦。圆教通法界具一切法门为苦。如是等下总结。二回向之中二。初为生回向及教生回向如是菩提境界。二正念下回成二利之行。先成自行。后修如来下成利他行有十事五对。一慈悲遍。二令得乐守善。三令究正远邪。四令入深出浅。五令具因住果。文皆可见。三如是菩萨下总结三世善根皆悉回向。问未来善根未有以何回向。答有二义。一以今逆起大愿回向未来善根。亦修成时即向菩提更不待回向故须回也。二依圆教宗九世之中三现是有。是故回向亦通三际故也

第二实际回向中有二。初学三世佛回向。后摩诃萨学三世下结叹显胜。前中二。初学过去佛行。后例同现未。前中亦二。初举过去菩萨所行。二如彼下以已善根同彼回向。前中二。先举彼善根回向菩提。二而无所著下明彼菩萨修离相行。于中二。初离妄乐真。谓离蕴入界不住世法是十八界也。二知法如空下行穷真际中二。一总穷空际谓超越五趣故云非趣岸也。又至真源更无所趣故云非趣也。二照解下别约三性照三无性。于中。初明所执无相中。先照实舍相。一切诸下明正契无相。谓法相自无。何处说虚。无净可趣无染可坏故也。二无有自性下明缘起无性中。先显法无性。于一念中下明正契无性真。三常乐下明圆成具德以成佛果。二以已善同彼回向。如彼过去举佛类已。我亦如是彰已同佛。于彼过去诸佛所行行法起始乐心起终证心。又于彼行法理法故云乐证也。然于如是离相法中发心修习而亦不违诸法之相所以者。何以所有起法悉如幻等。是故此有不碍于无。又既此有不碍于无故于真无如实修入。初举喻显法。悉分别等释法同喻。唯如来地等简果异因明回向所趣也。下二明以过去例同现未可知。二结叹殊胜中。先举三世诸佛菩萨殊胜回向。我亦如是已同彼胜。第一下结显胜相有二十句。初十句约形对辨胜。一过凡名第一。二越小名为胜。三超因名最胜。四独出故名上。五无加过故名无上。六无与齐均名无等。七至极无二故云无等而相等也。八无相似比。九无待对。十德重可尊。下十约自体显胜。一体微。二称实。三理正。四摄德。五大用。六离障。七具善。八净行。九离过。十舍染。上来正回向竟。自下第三明回向成益。于中二。先因前回向成净三业。二因净三业令所作净。初总显净。住菩萨下别明净行。于中二。初明离恶得位。二入一切法空下明入理舍着。先观空。无著分别下了有无猗。谓空有无碍心无住着故也。三佛子下结名可知。上来位行竟

自下第二明位果内。得此一位成十种胜德。一深入佛因。二趣佛果德。三智入深理。四不离悲业。五巧无住着。六入理转深。七成大福善。八照解佛性。九巧知诸法。十无著受生

第二偈颂中有二十四偈分六。初一颂上标意释名。二次二颂上回向佛乐。二一切世间下十一颂上回向众生令成佛。于中三。初四偈以随喜及乐回向众生。二菩萨修此回向时下四偈明同佛回向利益众生。三菩萨所修诸行业下三偈明正念回向安乐众生。四十方无量下四偈颂上回向菩萨。五心不称量下二偈颂上回向实际。初偈达法际后偈尽想原。谓知想无性名度一切想。亦不坏想以想心必无性不待坏故。亦不坏无想以无不无性故。如是了知众生之想离有离无。六下有四偈颂叹利益。于中初一偈颂三业净。次二颂学三世佛回向。后一偈叹胜有七慧可知

第四至一切处回向中亦长行偈颂。前中亦二。初位行后位果。前中亦三。谓标释结。释中三。初回向众生及菩提。二摩诃萨如是善根回向了无所有下回向实际。三摩诃萨如是善根回向令众生下结叹利益。初中三。初以善根回供三宝。二如是庄严下明供所为正显遍向。三譬如无我下辨彼善根摄德胜用。初中二。先略明。后摩诃萨复作是念下广显。前中三。初法次喻后合。初中。如是回向总。以标举德力。至一切指显其相。谓一切处是所至。善根是能至。能至故名力。此由回向故使然也。喻中实际无处不至略论十处以显无尽。此以理喻行故也。一切有者是三有二十五有等。余并可知。合中二。先总显供三世佛。二过去下别显供三世。先令过去佛本愿所作悉得成满。次令当来佛速具佛严。后虚空下于现在佛及大众皆悉供养者明此菩萨普供于彼。如诸天者如诸天所作随念皆成。菩萨一念充遍亦尔。显供自在也。广大下显成供所由。谓以已广大福智回向力故令于诸佛成上供耳。二广显中二。先于一切界供现在佛。二复作是念下于一切劫供三世佛前中三。初举所供佛。二摩诃萨下明兴供养。三以此一切下正以深心回向。初中二。先一切界佛后彼有菩萨下明有菩萨同佛所作。谓所供佛有二种。一实报佛。二位极菩萨能于十方示现成佛。此二俱是现在佛故。是俱现在所供收。故论之。文有十句。一所解深。二化现广。三身普遍。四证法源。五同佛体。六巧圆应。七从理起。八体坚固。九持用久。十从德生。二兴供养中供现佛及于灭后供于像塔。三以此下明深心回向。于中有十心。谓如何回向。以一心等者以是用也。一一心下应皆有回向字。但文家存略初后安也。中则准知。一情专注。二念不散。三非缘沮。四深崇敬。五喜乐行。六不留滞。七不染着。八无能行亦是离所为。九质直离害。十正顺涅槃。自下第二于一切劫供三世佛。于中二。初举所供田。谓多时多佛相严报身理严法身及多众也。二我以已下正回向兴供。谓由前善根十心回向重成此供。于中初有十供。一香。二华。三鬘。四涂。五末。六衣。七宝。八灯。九严具。十摩尼。又此十内各有香盖等二十门。故成二百。于中一一复各有阿僧祇栏楯等十门。故成二千门。各阿僧祇并前二重总有二千二百一十门。皆云不可说。或云无分齐等。又释。初供佛正报。后于一一境下明严佛依果。三如是庄严下明供所为。于中二。初总显所为。谓令众生出生死至佛地。二于诸下别辨有三。初令成化行满。于中法明是化法。教化等是化行。无量心等是化心广法。无所至是化绝功用。出善是化所成德。二令生睹佛下使成自德圆。于中见佛是行缘。安住等是所成。普入等是行成。入理善根回向等是行成趣果。三令生因此下使因成得果。三譬如下明至一切处善根摄德胜用。于中先喻后合。初举喻显法。我善亦尔辨法同喻。此亦以理喻行。谓此善根既如无我遍一切处。是故摄取彼法以增已行。文有二十句。初十二摄成自利行。后八句摄成利他行。前中初三摄成敬顺三宝。四成行。五成解。六摄佛通成自善。七摄化德成行心。八摄因德成理解。九摄巧便示果用。十摄果用成兴供。十一摄刹为严。十二摄劫为时修下明利他。一为物现身。次二化令成德。一行德。二断德。次四称器化益。一应根化。二赴欲净。三现身调。四令解已。后一护法自下第二实际回向。于中有三。初一明尽事而归理。二不碍事而显理不碍理而成事。三理泯而事用。由上三义混同一际。是故泯理而唯事。未尝事而非理。尽事而唯理。未曾理而非事耳。良以事虚揽理无不理之事。理实应缘无碍事之理。故此三门或破有显空有未曾损。依空立有有未始存。是故约理不隐不显。约事不存不坏。思之可知。初段之中如是回向牒前。了无所有总明入实际。下别显之有二。先离所取。后离能取。谓不因中计果果内计因。故云业中不取等也。又释。业空不见能生报。报空不见从业生故也。上离妄。下明入真。胜善是理善也。远离下明益相。谓离散修善也。以照所取空故。于情有诸法而不信入。求彼妄法之有不见自性。而是成就。下释显。以作者坏者皆不可得。此明成坏俱离。下明能取亦空以知所取空故。是故解了能取亦无见者等也。论云离能取所取方是真空此之谓也。上来第一尽事归理竟。自下第二明理事无碍而立者以渐纯熟事还存也。谓达理而不碍事存方是圆满解也。何故不碍存。以得因缘地故。此解缘起本识为地。如何复照理。谓则于此因缘地处见如来藏法身际等。如何理事得无碍。照以等观故也。又何故此事同理而不碍存。以解世间如化故。是故化事同理而现。明达众生等者明理事混融全摄无碍故云一法无二。又由此事既与理无二故此事业不可舍也。下重释显。谓事尽而显理然事不损故云于有为等。泯理而现事。然理不隐故云于无为等。此即不损事而尽显理。不隐理而泯现事。是故为无为无二无不二故也。自下第三明理泯而成事。于中。初总明观理而起事行。二精勤下别约称理之事起于大行有三。初成智行。二以虚空下成福行。三得离痴下双结二行。上来实际回向竟。自下第三结利益。于中二。先结成益生。于中有十。一令净器世间。二得智正觉。三能化众生世间。四得大总持。五为世福田。六为生采福宝。七为世出慧日。八善满法界。九救众生。十令成净德。二摩诃萨下结成自德。于中十句。初一总谓成就诸行能为佛因名如来性。坚心摄成名守名持。下别显所成果德。各对辨因故皆云性。性者因故也。一成佛果化物因。二净刹因。三佛地业用无尽故云不坏令成彼因故云性。四成量智因。五理智因。六身通因。七语辩因。八涅槃因。九菩提因。上二意业也。是名下第三结名。上来第一明位行竟

自下第二辨位果。谓此位成已得如是果。同下十地中调柔摄报等果。于中三。初总显谓牒上位成故云安住也。能以一切等辨其胜能。二别显所得。谓以至一切处善根回向故。是故得此至一切果有十。初三明三业遍。次三业用遍。初依身起通。二依辩说。三依意知法。下四显用自在。一于器世间自在。二于众生。三于劫。四于念。三佛子下总结所能。谓以一切善根各如实际至一切处俱回向故成此位也

第二偈颂总持中四句成颂。有十一颂分三。初七颂回向众生及菩提。于中二。初四偈行称真理而善回向。后三明诸业同佛而学回向。二未曾下三颂回向实际。三如是下一颂明回向所成果

第五无尽功德藏回向。于中长行内亦二。初位行后位果。初中亦三。谓标释结。释中五。初明所回行体。二摩诃萨以此善根皆悉回向下明回向菩提及众生。三摩诃萨以如是等无等等下明回向实际。四摩诃萨如是善根回向已得无尽善下明依前回向更生善根复将回向。五摩诃萨如是回向时下结成行德。初中此菩萨修悔过离业障者。今略通辨悔过等义作八门。一明开合者诸圣教中种种开合或作八重。一供养佛。二赞佛德。三礼佛。四忏悔。五劝请。六随喜。七回向。八发愿。如离垢慧所问礼佛法经说。或为七以赞礼合辨。或为六略无供养。或为五以发愿同回向如十住论说。或为四除礼佛。或三如智论云。菩萨昼三时夜三时各行三事。谓忏悔劝请随喜。行此三事功德无量转得近佛。或二但忏悔罪障善根回向。如善戒经说。今且依五事而释。二释相者礼佛有三。或七等如上礼佛仪式章辨。二忏悔者罪有二种。一违教遮罪还依教作法悔以除灭。二违理性罪起行悔灭。此有二种。一随事行忏。或方等诵咒等与教相应。或苦极礼万五千佛名等应彼圣教。或昼夜六时殷勤礼忏。以经多载或读诵大乘转重轻受等。如是非赞叹如来功德亦大灭罪生福。二依理观灭。谓观诸法空罪相不可得无不消灭。如经云。若欲求除灭端坐观实相等。又如下小相品说者亦是其事。此门以义亦通灭遮性两罪。问如受持正法及悔先罪。此罪为灭为不灭耶。答得说亦灭亦不灭。由持法及悔令重轻受以不受重是故名灭。然受轻故亦是不灭故。新翻金刚般若经论说云。如十恶业由持法及悔不生恶趣名拔根灭。然于现身轻受苦报亦言不失。故彼引说如来品云。若复有人受持此经乃至演说。是人现世或作恶梦或遭重疾或被驱逼强使远行骂辱鞭打乃至损命。所有恶业咸得消除。大集经亦同此说。三劝请者。智论说劝请诸佛有二。谓初成道时劝请转法轮。般涅槃时劝请久住世间。虽知诸佛而自知时。然生胜福故须劝请。又准地藏菩萨经三时劝加劝。菩萨速成正觉。四随喜者准智论及十住论有三位。一遍于十方一切诸佛所有已成无尽功德。二十方界菩萨声闻等所有现修一切功德。三下至人天凡夫善根。于上三位皆悉深心而生随喜获无量善根。五者回向亦三。谓众生菩提及实际广如上辨。三止作分别者。或五俱止。俱离障故。或五俱作发胜行故。或忏悔止障余发胜善。四余障分别者。礼佛除我慢障。忏悔除恶业障。劝请除谤法障。随喜除嫉妒障。回向除异求障。又除乐世有障。五生德分别者。礼忏生胜福。劝请生胜慧。随喜通福慧。回向回前二行。令有所成。又由回向摄持力故令此不堕三界二乘。六次第分别者。初礼赞佛求灭罪主及生福缘故先辨也。二依佛胜缘令得罪灭器净故次忏悔。三依此净器希心请法。四于他胜行忘私生喜摄同自行。五回前所成以向菩提方为一周故也。七得果差别者。果有二种。一别果。谓礼佛得尊贵果。忏悔除障得具足依正果。劝请得正慧果。随喜得大眷属并大福及大财等果。回向得离邪果。谓常遇佛世常能修行而不退等。二通果。并皆远得无上菩提。八约教显异者。若小乘五行皆实宗中亦不上之。初教即空以成五行。终教即如而成。顿教绝言为五。圆教内法界无尽一一行中摄一切行。各无尽为五行也。初行体文中有七。一悔过善。二随喜善。三于诸如来下明礼供善。四劝请善。五入法善。于中四慧。初闻慧。二忆念是思慧。三如说行是修慧。四入不思是证智所有善根。六重明随喜善。何故明者以摄善多故。依大品经随喜品。问于初发心菩萨功德乃至一生补处菩萨功德起随喜心得几许福德。佛言四天下国土可秤知斤两。乃至三千大千国土皆可秤知斤两。是随喜心福德不可秤量。又三千大千世界国土满中海水取一毛发破为百分以一分渧取海水可知渧数。是随喜心福德不可数知。文中三。先于佛菩萨善根随喜。谓此菩萨由增上深心随喜彼善。是故令心契摄彼善故云喜已安住彼善。二三世下于诸佛所度众生善根心生随喜。三三世下总结。三世佛因果位所有善根皆悉随喜。七彼诸如来下修余善根有四。一护法善。二念佛善。三因位善。谓菩萨道法是自己境界。四果位善。上来辨所回行体竟。自下第二显回向菩提及众生。于中以此善根皆悉回向者是总举回向。下别显之有三。初牒前善根。二如此善根尽过去下正将回向。三如是摩诃萨善根回向下结回所成。前中有十二句。一于前善根若创修时所得功德。二若进学时所发善根皆将回向庄诸刹等。三若久累功时。四若深解悟彼善根时。五于彼善根生庆悦时。六而彼善根若具备时。七彼善成时。八依彼善根成余行时。九依善得证时。十思择彼善时。十一领纳任持时。十二摄同自实执志守持时。于此等时皆发生善根普将回向。自下第二正明回向。谓此菩萨以善根回向庄严三世佛刹令众生净。即是回向菩提及众生也。泛论严土有三种净。一处所净。二住处众生净。三法门流布净。亦名受用净。今此文内具此三义。初明菩萨回求事严。二摩诃萨复如是回向下明求人宝庄严。三摩诃萨以善根方便回向下明受用净。前中有三。初别显三世佛刹异严。二总摄以用严诸世界。三显所严刹之分齐。初中三。先辨严过去佛土。二严未来佛土。三严现在佛土。初严过去中如此善根牒前所修尽过去际明时长也。一切佛界彰处广。无量行起显因多。佛知菩萨识约人显深。应众生等明土应机。如来所持等明佛净识所现。净因所成此是主圆净。普贤等明广因所起。是眷属圆净。彼界若有等显是佛土。以于此中成正觉故。二庄严未来土中二。先明土严有四。一处广。二时长。三一切诸佛下明土因净。四杂宝下明土果严。二摩诃萨下明菩萨修因行有五。一解净法。二持不忘。三依法起行。四入证定上是因圆。五佛慧光照摄成果满。是故令土得圆净也。三如未来下明严现在土。于中。初类同未来。种种下别显严相。种种是严多净。具足是离垢极。德普是利益广。色香等七别显严。随善知识等下用以庄严一切香等十三种。二以如是等下总摄上三世刹严用严己界。于中三。先总。次别。后结。别中有二十七句。此等皆是三世诸佛异刹庄严而用总严于己世界。三如是庄严于一世界下显所严分齐有二。初以三世庄严而严一界。二以一类多皆尽三世略论九种佛刹庄严。上来事严竟。自下第二求菩萨人宝庄严彼刹。即住处众生净故名净土也。文中有三。初总明回求人宝充满。二此诸下别显严相。三于一佛刹少分下结所严分齐。别中二。初明人德满刹。后充满下显成严相。前中辨菩萨德有二重。初明菩萨行修具足。后悉从下显诸菩萨德用圆备。前中二。先别显后总结。前中二初显福慧胜能行后成就殊特下明善根心志行前中二。初福慧成二利。于中先举福慧善能等成利他。入深等成自利。二成就念佛下明福智生胜德。于六念内略无戒天二念。此是福行。法日下明智行。于中初广智普照。次显深智入玄。谓从无所有生释显深相。智依理起故深也。下明生德。谓从智生力无畏等一切净德故云出生等也。二善根心志行中。初成善根。谓成即真理之善名殊特。垢染斯尽故云清净。过下名最胜。上出名增上。二建立下显大志行。先举行本谓大菩提心也。后净魔业下辨行胜能五句。一净魔业。二了物机。三照法空。四舍四倒。五灭无明下结。修诸善者结上善根也。满大愿者结上菩提心愿也。二成就如是下总结多德可知。自下第二明菩萨德用圆备中三。初悉从法门生者总显胜德所成也。下别显。后成就如是下结。别中二。初自分德。二随顺下明胜进德。初中三。初明善根德用。二得菩提下明大智德用。三于诸菩萨下明三昧德用。初中胜善是德。常作等显用。就智用中三。初是明智德用。先举智体谓无痴闇故是明也。一身等显胜用。二成就下是大智德用。初智德分别法界是智用。三遍游下是净智德用。游刹心净是智体净。谓无功用故如空也。悉能分别是妙用广。三三昧德用中。初显所得三昧。谓体用深广名不思议。下彰胜用有三。一巧便趣果用。二住依了正用。三达深无畏用。上来自分竟。自下第二明胜进入佛境界。于中十句分二。初六上摄佛境德。二悉能下四明妙用无方德。前六中。一同佛因善。二照佛所证。三持佛所说。四演佛圆音。五得佛同辩语言法是也。六得无上佛地者是结得果位。二下明妙用四中。一遍刹无碍。二摄法无染。三心智广用。四称实说法。此四中初一身业。次二意业。后一语业可知。成就下结德显多庄严。世界者显人宝庄严。故法华云。国名大宝庄严以菩萨为大宝。故此句总严。下别显有六句。一胜人满刹。二实德成严。三称理而住。四进德相资。谓善修者自德进也。薰修者诸菩萨德互相资熏也。五德净无染谓不杂无明。又不念异乘也。六息繁顺道下第三结所严分齐有三。初约一刹内一少分处既有如此十种大数菩萨充满。二类显彼一刹内余一一少处皆有如此十种大数菩萨悉满。三既一刹中有如是多十大数重重菩萨类虚空法界等世界皆亦如是菩萨充满。自下第三明受用严净。亦是法满严净。于中有十事。一向刹令严净如前辨。二令菩萨满亦如前。三令佛现。四有所求果法。五有能求大愿。六行法出要。七令所化机净。八令于彼界当得见佛。九令佛常住。十转实教法轮。以非权教故云不退转也。上来正回向成严竟。下第三结回向所成有五句可知

第三实际回向。于中三。初正回向实际。二辨入实成益。三结行成相。初中有六句。初牒前起后。二心净等因前成行。谓由前回向趣大极果。是故令心极净若空安固如地。三入不思下正明入实。谓绝无能所而有回向名不思也。四乐观等释显无能所所由。五无尽等谓无能所成称性功德。六平等顺等明释显无尽之所由。二摩诃萨下明入实。成离妄益有十对。初对离能回之妄。次不妄取佛等三对明离所向之妄。次不取业等二对明离回向业果。初对离总报业果。后对离别报业果。上来离有。次不坏等明离无。以即空而不碍存故是故不坏。又性自即真故不待坏也。次不取有等明有无双离。以不取有是遣有执不坏有是遣无执也。次生死非离等明离背向相。以法离生死相故非杂乱。亦离涅槃相故非寂静。今谓文意只如此。然古德有多释。远法师云。泛释有二。一就破相解。解生死体空。故非杂乱。涅槃亦如故非寂静。二寂用解。解生死体寂故非杂乱。何者是体近说空。是深说则不空如来藏。是大般涅槃能建大义妙用繁兴无所不为故非寂静。然依后义。此二佛境佛所行道名境界道。生死涅槃法无定相故曰无法。诸圣同依故名同止。衍法师云。以缘就实生死非杂乱。以实从缘涅槃非寂静辩法师云。如来境界道者此非有非无。真如是佛证智行处故云境道也。非他作无法同止者。自心真如故非他作。唯佛智依故无法同止。今更释。此第十对明离回向行果相。谓能趣佛境之道此道无性即空故非他作。趣至佛果冥同性海。无能依智与所依理同处而止故云无法同止。又因相绝故道非他作。果相离故无法同止。下明结行成。于中二。先结上修入行成。后离诸下结上行益相成可知

第四依前所得无尽善根复将回向。中有三。初显所得无尽善根。二以如是等下正将回向。三眼终不见下明其益相。初中十句。初句是总。由前回向已得此无尽善根。常念下九句别辨。一由前念学三世诸佛回向严土是故发生无尽善根。二因前愿求人宝严土生无尽善故云度菩萨也。三因前严土令诸刹净所生善根。四因前回向求净众生所生善根。五因前实际回向中随顺法界所得善根。六因前心净如空不动如地等所得善根。七因前解如来境界道非他作等所得善根。八因前不虚妄取等成菩萨净业所得善根。九总结。因前严土等行皆通三世所得善根。自下第二正以前善复回向中。先总标回向之能。以者用前善根至极回向故能称性度脱众生。下别显有十句。一为度故入众生界。知体空故不见众生。回向求此无障碍德故名回向。二无寿命。三无自在我。四无人福伽罗旧义翻为人今正名翻为数取趣。以数数取诸趣而受生故。上四约生空。下约法空。五以法无是非故离忿诤。六缘生不实。七理实无著。八知土体真故无染。九了行从缘故无坚固。十达境唯心故空无也。自下第三辨益相中三。初见理益。于中九句。初五句明离相。后于如来下四句得实。二此菩萨下明成德益。于中上摄佛果中具佛因。下摄众生。三彼菩萨下妙用益。于中宝藏是用体。次庄土。后摄生显用相。上来第四段竟。自下第五明由前回向所成行德。威力故者由前起后也。有十句。一行胜无伦。二行坚无坏。三威高伏魔。四成德不退。五满本要期。六心广。七用速。八深智。九广智。十菩提心力称同法界。上来别释竟。下第三结名可知。上来位行竟

自下第二明此位果。得此位故复得斯果有三。先举数。次列释。后结。释中十内。皆先列藏名后释其义。一见佛藏。二法。三念。四慧。五义。六愿。七德。八智。九辩。十果。又此十中。初六自利行。一见佛。五知法。五中。初知理法。二闻持教。三解文教。四悟意趣。五证法实。亦是闻思修证。次三利他行。一以功德身应。二以意业晓悟。三语业辨说。后一摄行成果。谓由此回向力令菩萨行速得圆满。是故受职而得成佛。后佛子下结

第二偈颂总持中有二十五偈分五。初一偈颂前行体悔过等中。但颂随喜行德。二三世下九偈颂前回向菩提及众生。于中三。初四颂上庄严三世佛刹。一学佛严。二摄法严。三显所严。四结同佛严。二彼真佛子下四颂上菩萨人宝严土。于中初一颂上法门中生。次一颂业胜具身口也。后二叹德胜。亦是意业胜。未曾想念等是上文浮净不杂等。三一偈颂上受用净。亦是法满净。令生成佛具佛法故名佛土也。三十方下有二偈。超颂前第五结所成德。于中初二句颂上威摄众魔。次句颂上一切世间所不能坏。次句决定修等颂上行无伦疋。次句上大愿成满。次句回向功德等颂上成就不退功德。次二句通颂所成德深报广。四善能观下有五偈颂上第三实际回向。于中初一颂上正向实际兼颂成益中不妄取业报。余四并颂成益。次二句明无色心之有无。即颂上不着意业及果报也。次二句颂上不取有为及无为。次一偈颂上不坏因果不取有无等。一切众生下一偈三句颂上生死非杂乱。后一句佛刹亦如是者亦得颂上涅槃非寂静类同世法空如。故云亦如是也。五菩萨如是知下有八偈。颂上第四依前生善复将回向。于中初一颂上所得十种无尽善根。次二偈颂上以前善根正成十种回向。次五偈颂上回向益相。于中初二妄见已灭。弃等是上眼终不见不净佛刹等。后三偈颂上不见异相众生。谓众生称性离有无等无异也。第五回向竟

华严经探玄记卷第七华严经探玄记卷第八(尽此回向品)

        魏国西寺沙门法藏述

第六随顺一切坚固善根回向。于长行内亦二。谓位行位果。位行中亦三。谓标释结。释中有三。初行所依身。二离诸业障下明依身起行。三摩诃萨若能以此善根回向下辨行所成益。初行所依身者。依转轮圣王身而起施行有四意。一在家是能施位。二有七宝可施。三明难舍能舍。四摄化无敢违命。文中二。先显王统摄自在德。后此摩诃萨下辨王正报殊伦德。前中轮王成就七宝义略作三门

初显名者。下文云。一金轮宝名胜自在。二象宝名曰青山。三绀马宝名勇疾风。四神珠宝名光藏宝云。五主藏臣宝名曰大财。六玉女宝名净妙德。七主兵臣宝名离垢眼。得是七宝于阎浮提作转轮圣王

二辨相者。先辨轮宝。依涅槃经。顶生王于十五日处在高楼沐浴受齐即于东方有金轮。千辐毂辋具足非工匠造。我当试之。以左手擎此金轮。右手执香炉。右膝着地而发愿言。若是轮宝不虚应如过去转轮圣王所行道去。作是誓已。是金轮宝飞升虚空遍四天下已还来住在王左手。依俱舍论。但阎浮提有轮王出。以福力故。令帝释宫内地热。帝释即知有轮王出遣守宫门。五百夜叉扶一轮宝下应轮王。以得轮宝故曰轮王。又有小论说。轮王未出此轮宝等在铁围山间。诸大力鬼神守护。轮王亦出即送至王所。是故先有住处。若准此经。上文云譬如转轮王成就胜七宝彼无所从来。明知但由业力所起无别来处。然此轮有四种。一铁轮二百五十辐。二铜轮五百辐。三银轮七百五十辐。四金轮千辐菩萨本行经轮有千辐。纵广四十里。周匝百二十里。王欲行时轮在前导。不宾伏者金轮自然在头上旋。自然降伏。不用兵仗。二象宝者。七支至地。六瘤成满如白莲华。行疾如风。王乘其上一念之顷周四天下。三马宝。其色绀炎。髦尾金色。行不[馬*奔]骤迅踰疾风。致远不疲。乘者安豫。巡游四方不失主意。一念之顷遍四天下。四神珠宝。依涅槃经。于王宫内自然有摩尼珠。大如人[月*坒]。能于闇中照一由旬。此珠力故。为天雨渧如车轴能作盖覆一由旬。遮此大雨不令下过此珠。依观佛三昧经说。是金翅鸟心。依智论是佛舍利。于末法后变作摩尼珠。又依贤愚经有三品。上者置高幢头王烧香请。随王意雨诸财宝及饮食等满八十由旬。中者雨四十由旬。下者雨二十由旬。其光常明。及遮雨亦尔。又菩萨本行经中珠宝昼夜常照千六百里。又真谛三藏云。如意珠有三种。一如意珠能随人意所欲从心。二清水珠令浊水变清。三吐金珠自有三品。一下品投一两金得千倍。二中品投一两金得万倍。三上品投一两金得无量倍。五主藏臣宝。依俱舍。主藏臣宝得眼根力能见一切地中伏藏。以手揽海宝随五指现。又菩萨本行经典藏臣王意欲须金银七宝衣被饮食披其两手。七宝财产一切所须随意所欲从手中出而无有尽。六兵宝。未伏之处立计平论无斯不伏。又菩萨本行经典兵臣宝王意欲得百千万兵自然而至。七玉女宝。不长不短不黑不白身诸毛孔出栴檀香。其目视一由旬。耳闻鼻嗅亦尔其舌覆面。以手触王衣即知王身安乐病患。亦知王心。此女定从莲华化生。又依菩萨本行经。女香洁如优昙华。王意欲得清凉之时身自然冷。王欲得温时身自然温。声如梵声常使王喜

三诸门者有五重。初一约粗报。谓有彼宝能遮四十里雨等。是相似七宝。如萨遮尼经(云云)。二约细报。谓实报金轮王七宝如前辨。三约行缘。谓菩萨轮王七宝等物。皆是菩萨净业所起。堪为菩萨修行所用。准有五义。一令菩萨不生爱染。二令成施行。三满乞者意。四令乞者发心修行。五堪令教化众生故。智论十二云。宝有三种。一人中宝能雨物如轮王宝等。二天宝能解语使唤等。三菩萨宝能说法化众生等故也。四约深报。谓如圆教世界性等已上有万子。已去轮王所有宝等如白净宝网转轮圣王有锭光颇梨珠。照十佛刹尘数世界海。以一恒河沙金转轮王善根所生如是等。五约行德。如下经云。波罗蜜金轮诸通为象宝。神足为马宝。净慧无上殊妙行为女宝。四摄宝藏臣方便。主兵宝无上转轮王。今此文中据后三门所说。以于无尽法界中成普贤无边行海故。后此摩诃萨下明正报殊伦。那罗延此云坚牢力。依俱舍能持一大千界风轮。是那罗延量。依涅槃经校量可知。二依身起行中三。初略标行事。二摩诃萨如是诸善根回向已作如是念下广显行相。三摩诃萨以此善根回向时下行极契真。前二即是菩提众生回向后一即是实际回向。又前二是广大回向。后一甚深回向。初中有三。先略标七十事所施之物。从饮食至床座。十从住处至盖(二十)。从幢至眼(三十)。从耳至肉(四十)。从心至爪(五十)。从为法投火至以身覆佛(六十)。从以身施一切至悉能舍离(为七十)。于中有内施外施内外施。又财法无畏。代命救残是无畏施。断杀有二。望所杀是无畏。望能杀。令持五戒等。是法施。普告佛名亦是法施。又释。此等既并是法门。是故俱通三施也。又此并是无尽法界大缘起门普贤无碍自在之行。以是等若内若外情非情物及法门行尽以施与于一众生。如一众生一切亦尔。于一世界一微尘处施一切众生。一切尘处皆亦如是。如一世界虚空法界等一切世界处皆亦如是顿成大施。于一刹那即遍如是法界世界行此施行。如是念念尽前后际。一切诸劫一切刹那皆亦如是。此一菩萨以满法界身备起如是无边大施。仍有纯杂门别。若约纯以施眼门者。即见如上一切处一切时一切物一切田唯施于眼毕竟不见所余诸门。何以故。余门不观如虚空故。即此一门遍法界故不见施眼之初际亦不见施眼之后际。以无始终故。余门亦尔。随其纯杂皆悉不同。可准思之。二若诸众生下明对田成施。三作如是念下显施所为中有八句。有人解云。此摄取佛果三坚是回向菩提。今谓此文犹辨菩萨摄取。称法界之依正。在此坚固善根门内。令具胜行之缘。更得成称法界之行。胜人是国中人。眷属是已眷属。余文可见

第二广显行相中有二。初别显向前七十门大施之行别明回向。后此摩诃萨以如是等下总结所为大喜回向。前中七十门有开有合。至文当辨。初施食内二。先明自施心离过。后以此慧施下正明以此施食善根回向众生。但以法食者。依阿含经。出世间食有五种。一禅悦食。二愿食。三念食。四解脱食。五法喜食。永离揣食者。阿含世间食有四种。谓段思触识。为化众生。现受揣食者令众生成化身佛。摄论云。为生施主善但如来食时诸天为受施。诸众生令得成佛故示现以手触食。施食获五果。经言得常命色力安无碍辩。又瑜伽云。施饮食能感大力。问若贫无多食颇有得成大施行不。答有。如大乘方便经上卷云。若生贫穷家是菩萨乃至乞食若得一揣食持用施僧。若施一人不以为愧。应作是念。如佛所说。心增广大胜以财施。我财施虽少以一切智心愿是善根成一切智令诸众生悉得宝手。犹如如来以是缘故具足施或禅定禅处。是名菩萨行于方便。施饮中。回向内得净法爱是法喜食。法身柔濡是解脱食。三昧调心是禅悦食。施味中。先举所施。二善根回向。于中得上味相。甘露充满者是佛三十二相中上味相也。经云。如来大牙复有甘露泉。但食入口悉为甘露。下诸回向中悉以事同法。相似相类而成回向。三是为下结名。施乘是令得代步喜。施衣令得蔽形喜。瑜伽施衣服能感妙色。又若能新作衣成持用。供佛有二种。一暂献便取得无量福。二作时分施亦得大福。如今日午时以衣施佛直至明日午时。若中间取即是取佛物。至期限满取即无失有福。施华令得供养喜。又华令人喜。施自身者。如智论第十三违罗摩菩萨施外道有诸天遣自施福胜外道无量。如彼具说。鬘严饰喜有二种。一贯华作环置于头上。二以线穿华络于身上。西国尚此也。施端正报。香亦供养戒德氛氲。故同香也。涂香亦严身。床座令安稳喜。上是初十也。施住处及房舍。亦令安稳喜。施灯明令破闇喜。近令得好色报远令众生得佛慧光。瑜伽施诸灯明能感净明。又燃灯功德经中。烧灯供养大灭罪生福令发愿言。愿能以大海为油。须弥为炷。燃大灯明。遍佛刹海。供养无休。又愿以法性为油。大智为炷。燃大悲为灯普曜世间。故经云。净信心为炷。慈悲为香油。正念为宝器。燃彼曜世灯。施汤药令除病喜自。近得无病。如薄俱罗比丘五不死等。远得药树王身。又如药王子。手触疾病无不皆愈。死后取其烧处灰土亦能除疾。身疾既除心病亦遣。施器令得盛贮喜。施车令得运载喜。亦是代步。瑜伽施车乘能感快乐。于中有三。先列五种福田。次列十种宝车。后随田成施以善回向。此中施五田即为五段。初施佛及塔有二种流类回向。一约田相似回向如文。令众生乃至云得诸如来无碍解脱一切种智等。二约所施物相似回向令众生摄取大乘等。余文中亦有约施心回向。谓欢喜心施亦即随发回向等。并通准之。二施菩萨及善知识回向。三施佛大众僧宝回向。四施声闻缘觉回向五施一切福田回向。菩萨十种道者十度行乘。又十地道也。四轮义略作三门。初辨相者。一住正国轮。庄严论第六云有四种不放逸轮。一者胜土轮土胜有五因缘。一易求。谓四事供身不难得故。三善护。谓国王如法恶人盗贼不得住故。三善地。谓处所调和无疫疠故。四善伴。谓同戒同见为伴侣故。五善寂。谓昼日无喧夜绝声故。二者善人轮。善人亦具五因缘。一多闻成就阿含故。二见谛得圣果故。三巧说能分别法故。四怜愍不贪利故。五不退无疲倦故。三者自正轮。亦具五因缘。一善缘妙法为缘故。二善聚福智具足故。三善修止观诸行相应时修故。四善说无求利故。五善出所有上法恭敬修故。四者先福轮。先福亦具五因缘。一可乐由住胜士为因故。二无难由值善人为因。三无病。四三昧。五智慧。此三以自正轮为因。第二除难者。依成实论四轮除八难。住正国轮彼论名住善处轮。谓生中国除五难。谓三涂北洲长寿天。依正土轮彼名依善人。谓值佛世除佛前佛后难。平等愿轮彼名自发正愿。谓正见除世智辩聪难。本功德轮彼名宿植善根。除生盲聋喑哑。前五是恶处难。第六是恶时难。第七是恶因难。第八是恶果难。第三成德者。四中。初二是外缘。后二是内因。谓愿是智因。德是福因。菩萨无边净行皆赖此因缘而德成满。上通约三乘教辨。又正国真如法性土也。正土般若正观也。功德施等五度行也。本愿菩萨十种大愿也。此约终教辨。又正国即十佛国土海。正士即十佛正报。功德即性起功德。愿即普贤愿海。此约圆教。同一无尽大法界缘起故也。象马别施合以回向。施床座中。前所施是泛尔床座。今此是圣王所坐之座。故不同也。三种世间所不能坏者。辨法师释。地前愿乐世间。初地至七名功用世间。八地至等觉无功用世间。令得佛殊胜座。因位三种无常世间所不能坏。衍师云。是三灾不坏。今释。以应是不为过未等三世之所迁坏三相亦得。以是称法性之座故。经云诸法空为座。第二十施盖中。如宝积所持如来合盖遍覆三千。明摄化境也。又菩萨本行经佛在郁卑罗国涉热而行。有牧羊人即以净心编草作盖。覆佛随行。佛便微笑。阿难问故。佛言此人草盖覆我。十三劫中不堕地狱。天上人间生便辄有七宝之盖。随而覆上。后得出家成辟支佛也。幢幡合施。亦可是幢上悬幡俱施。百缘经佛出世时有长者子名波多迦。生已空中有一大幡遍覆城上。随行覆之。值佛出家得阿罗汉。阿难问故。佛答昔毗婆尸佛灭后起七宝塔。时有一人。于塔设会。作一长幡。悬着塔上。发愿而去。九十一劫不堕恶道。随所生处。幡常荫上。今得见我。开宝藏施。中令得十六智宝者。依小乘八忍八智为十六。辨师云。地前光得等四定。地上大乘光明等四定。各有自分胜进为十六。依此发智为十六智宝。以下释云三昧正受究竟增广智慧之宝。又有人释。佛地四智。智各有四为十六。以果位自在互得融通。施庄严具中。百福具好者。依涅槃菩萨修身。不杀戒十善有五种心。谓下中上上中上上。乃至正见亦复如是。是五十心名初发心具足。终成有五十心。如是百心名百福具足。以此百福共成一好。故云百福具好而自庄严。又依瑜伽决择中。百福行者谓离十不善业道。小分离杀生。乃至小分离邪见。是初十行多分离杀生。乃至多分离邪见名第二十行。若全离杀生乃至全离邪见名第三十行。若小时离杀生乃至小时离邪见名第四十行。若多时离杀生乃至多时离邪见名第五十行。若尽寿离杀生乃至尽寿离邪见名第六十行。若自离杀生乃至自离邪见名第七十行。若劝他不杀生乃至劝他不邪见名第八十行。若称扬赞述不杀生乃至赞述不邪见名第九十行。若见离杀生乃至见离邪见者庆悦大喜名第十十行。又依肇法师法华疏中十善为本。一善以九善庄严名为百福。不知出何圣教。施冠珠中。以施熏心令更成胜进大施。故云向增上。因此施念令慧深。见施中正理故云修慧。又因施作意令成舍根。谓究竟大舍也。因施作意令慧广觉。余一切行回向中。令得无见顶相者是佛三十二相中无见顶相表佛胜出更无过故也。摩尼宝冠者如文殊师利头上天冠。是毗楞伽宝所成。首楞三昧所起。于中常现无量佛刹及诸佛身救狱囚苦。如大悲菩萨等者此等菩萨主当此门于一切处一切时常行此行。余下诸门所引菩萨皆亦如是。身代死囚者是舍身命比前财施极超过。如菩萨本行经中。过去有五百长者子各出珍宝象马车乘衣被饮食。随乏悉与。有一贫人见而问言汝等施福求何等愿答欲求佛道。又问何谓佛道。答中广叹佛德。贫人闻已自念。我今欲习学此愿广度一切。加复贫穷无财行施。当持己身而用惠施。念已索蜜涂身卧于冢间。我今以身施与一切。若须血肉皮头目髓脑悉以与之。持是功德用求佛道广度一切。作是愿已。应时三千大千世界而大震动。诸天惶懅。帝释天眼见于菩萨卧在冢间以身布施。下来欲试。化作众狗鸟兽。来就欲食。菩萨见有欲来啖身。心便欢喜。无有退转倾动之意。天帝复形赞问所求。为求轮王帝释梵王。答言不尔。唯求佛道广度众生。帝释诸天同赞。善哉语菩萨言。汝此勇猛过彼五百菩萨所施百千亿倍不可计倍当先作佛。时贫人者今我是。五百长者子今此弥勒五百菩萨是。我以精进勇猛之力故超诸菩萨所作功德而先成佛。施连肤顶发及髻明珠者有二事。一割剥头皮连发而施。二依西国贵种。皆初生时。刀开顶皮内一神珠。封药着已珠在皮内。今有人乞执刀开施。梵言周罗此云顶髻第三十施眼中。依瑜伽四十九。菩萨内施有二。一总求菩萨身以身施而作仆使。有三意。一为速证菩提。二为众生利益安乐。三为布施波罗蜜多速圆满故。二别求眼手足头目支节血肉筋骨乃至髓者髓其所欲一切施与。又智论十四舍利弗六十劫行菩萨道欲度施河。逢乞眼退不到彼岸。回向内令众生得十种眼。又如与他贯计衣道并是施眼之用。亦应如是回向后渐能总舍。施耳鼻用亦准应同。面门者。有人解。是口。光统云。鼻下当柱为面门。岂以施鼻得口端正。施牙齿中象王者。如十轮经说。又智论第十四云。如象王施牙是法身菩萨。又引法身菩萨变身作象与猕猴及象为亲友存仁敬以化人兽等。施舌中亦有施用。施头中。菩萨本行经月光王欲舍头与婆罗门。诸臣谏王。王身是我等一切人共有。如一妙宝众人共有。岂得一人独自用耶。王语婆罗门。汝何不屏处索。汝今少去。我安慰臣。语臣言。此于我有宿怨。今若不偿更何时还后去去臣唤婆罗门。汝于林中待我。后至令彼断取其头。遂以王发系树。下刀斫之。误断树枝。婆罗门谓已斩竟即生欢喜。以诸天力不令见王身首等。树神呵啧婆罗门。婆罗门谓。真断头怨心得解即便还去。手与足合施。问若菩萨施身支节等为一切所求皆施。为有不施时。答瑜伽三十九云。若诸菩萨于所行施意乐清净见有无量利众生事正现在前。设有来求自身支节不应施与。彼菩萨为令于施意乐得清净故。须舍现前利众生事而施身分。若魔天众并魔所使众生来乞菩萨身分支节不应施与。其魔恶心恐彼当获上品罪故。有痴狂人来求菩萨身分支节不应施与。由彼不住自性心故。不为义利而乞求故。其心狂乱不自在故。空有种种浮妄言说。是故不应施身分。除上所说来求菩萨身分支节。随其所欲悉皆施与。是名菩萨于内可施乃不施也。坏身出血及髓肉合施。智论第十四中。月光太子出城见癞人。问医人言。可治不。医言可治。但药难得。谓须从生来不嗔人血髓。和药涂之即差。菩萨自忆。生来不省有嗔。即出血髓救彼令差。愿得法身差其心病。此施肉是第四十也。五藏中心别施。肠肾肝肺四藏同施。又智论十四施有三种施。饮食等为下施。衣服珍宝为中施。头目五藏等为上施。广引释迦本行。此三施事如彼说

支节诸骨同施。施皮者。智论十六中。如毒龙受一日夜戒被剥五色皮忍己施之。又金刚胁鹿王者。菩萨本缘集经第四中。菩萨往世堕畜生中。而为鹿身。两胁金色。脊似琉璃。余身杂厕。种别难名踝如砗磲。角如金精。其身庄严如七宝藏。身色光炎如日初出。为诸群鹿而作饶益。于大暴河见人欲溺投身救之。其人得济后遂背恩。告王将兵欲杀鹿取皮。将王及兵至鹿。指示两臂俱落。王知背恩发心礼鹿谢过而去。广如彼说也。施手足指中。如有练指供养等亦是其类

第五十施连肉爪者亦求法而施也。为法投火中七仞者。一仞七尺。七七四十九尺火坑也。为法受苦者如勇健王者。菩萨本行经过去有王名处阇那弥梨。为求一偈割身千灯。后因帝释问立誓表心。遂还平复。所求一偈言常者皆尽。高者亦堕。合会有离生者有死。王闻偈喜忘其所苦。敕举国人皆令书诵(云云)。为法舍国等如法华提婆达多品说等。教断杀等是无畏施。以施其命故过一切也。智论世间所贵。各唯已命。无有价直。五戒等望能杀是法施。望所杀是无畏。三种戒者是律仪等三聚戒也。救毁形苦亦是无畏施。俱舍论有黄门救五百头牛毁形之事。以此善根力故男形具足。是其现报也。文中肆字者是恣也。具足无上丈夫正法者。依涅槃经莫问男女。具四相义即名丈夫。谓自正。正他能随问答。善解因缘义。若不具此四种相义虽曰男子不名丈夫。女以反上即名丈夫。又云虽是女人能信自身有佛性者即是丈夫。若有男子不知自身有佛性者我说彼人犹是女人。又云七丈夫趣者有四说。一依世间。依瑜伽中丈夫有七义。一长寿久住。二妙色端严。三无病少恼。四非仆非女非半择迦。五智慧猛利。六发言威肃。七有大宗业。具此七法名为丈夫。亦有趣故。二依小乘亦有七丈夫。即七贤圣。一随信行人。二随法行。三信解脱。四见到。五身证。六慧解脱。七俱解脱。信他得度名信行。不从他信名法行。钝根三果是随信行所得。信果离缚名信解脱。利根三果是随法行所至。故名见到。灭尽正受法似涅槃与身合故名为身证。障有二种。一烦恼障。二解脱障。但离烦恼障名慧解脱。二障并除名俱解脱。三依大乘瑜伽有七地。亦是贤圣丈夫所游履故名趣也。一种性地。二胜解行地。三净胜意乐地。四行正行地。五决定地。六决定行地。七到究竟地。初二是地前。次一是初地。次一从二地至第七。次一第八地。次一第九地。未后是第十地及佛地合说。以因果俱究竟。四依璎珞本业等亦有七位。一信。二十住。三十行。四十回向。五十地。六等觉。七妙觉。叹佛出世是法施。如上普庄严童子赞佛偈声普遍世界。又如悲华中。释迦往作大悲菩萨行。遍诸国大声教言。如来出世。如来出世为甚难遇等。施大地中如来及塔菩萨知识并父母等是恩田亦敬田。圣僧二乘是德田亦敬田。余乞者是贫人等是悲田亦苦田。此等皆能生福故名福田。从喻为名。又有四句。自有是敬非悲。如佛等。自有是悲非敬。如贫苦众生等。自有亦悲亦敬。如贫病罗汉等。自有非悲非敬。除上所余等。智论十四云。若怜愍施谓于贫穷下贼及诸畜生。二恭敬施谓于佛及法身菩萨等。三怜愍恭敬施谓于老病贫穷阿罗汉辟支等。问悲敬二田何者为胜。答有三义。一若就约境救彼现苦约心增大悲行为利他行本。即悲田为胜。是故像法决疑经中。乃至施佛菩萨声闻众生不如人施畜生一口饮食等。二若就约境恩深德厚约心领法增智为自利行源。即敬田为胜。是故校量功德经中。施畜生得百倍等校量。又甚希有经以七宝等供满四州施四果圣人及灭度后起极广塔。不如造[麩-夫+廣]麦等佛塔功德。乃至算数譬喻非比等。又大品中天帝云我非不欲供舍利但舍利从般若中出。是故宁供养般若也。三若约二利齐均悲智双举。即二田平等。如净名云。一分施难胜如来一分施最下乞人。犹如如来福田之想无所分别等于大悲此之谓也。问等是敬中如父母恩田与圣僧德田胜劣云何。答如校量经乃至云供养百罗汉不及供养一生身父母。又阿含经中供养父母功德共供养一生补处菩萨功德。齐等。问等是恩田。师僧与父母胜劣云何。答舍利弗问经在家人父母恩大。师僧恩次。出家人师僧恩大。父母恩次。以师于在家教授力劣。出家反此。又以师僧生育法身法身累劫无尽。父母生育生身恩及七世。问等是德田。供养别众胜劣云何。答如梵网经别请五百罗汉不如僧次一凡夫僧。问施有三事。一田。二物。三心。此三胜劣云何。答有四句。一自有田劣心等胜。如罽眤吒王礼赞尼干子塔塔遂崩倒。二田胜心物劣。童子施土于佛钵中戏尔故心轻。由田胜故得作铁轮王。三田心胜而物劣。如智论第九中老婢以绀淀奉佛得十五反受人天福后得辟支涅槃有人疑佛以妄语。佛以舌覆面用决彼疑云。引尼狗子小生树大等。四三事俱胜。如龙女献宝珠速成佛等。今此中菩萨与施心悲智齐于虚空。辨施物事种穷乎法界。举施田凡圣尽于十方。是故此中三事性尽深无底。三事殊特胜无比。三事广大遍无崖。三事相融俱无碍。又俱舍论问施支提塔此中无能受用云何成福。答福业有二种。一弃舍为类。若由舍物此福业得生。二受用为类。若由受用所舍物此福业生。若施支提有舍类福无受用类福。类是因义。问若不受用云何有福。答若福要由利他得成福者修慈三昧及正见等。应皆无福。如慈等心观中。虽无能受用及利益他有无量福生。从自心起。今此文中。前施佛造殿堂受用生福。后施塔是弃舍生福。舍利者正音名设利罗。此云身。谓是如来或全身或碎身。塔者正音名窣堵波。讹名偷婆。更讹单名塔也。此翻为归宗之所也。依长阿含经四人应起塔。一佛。二辟支。三声闻。四轮王。真谛三藏引十二因缘经八人应起塔。一如来露盘八重已上。是佛塔。二菩萨七盘。三缘觉六盘。四罗汉五盘。五那含四盘。六斯陀含三盘。七须陀洹二盘。八轮王一盘。若见不得礼以非圣塔故。又依僧祇律有凡僧亦起塔。谓持律法师营事比丘德望比丘应起塔。既非圣人总无露盘。仍令在屏处。若违结罪。准此等文。今方有为师造塔广起露盘。非直现人得罪。亦乃累彼先亡。深可悲矣。又泛论造塔有六意。一为表人胜。二为令他生净信。三令标心有在。四令供养生福。五为报恩行毕。六生福灭罪。问如造佛塔得几福。答有二。一近得梵福。依俱舍中得梵福有七种。一此地未造支提于中而作二立僧伽蓝。三僧已散能和。四修四无量。五代父母佛命。六自出家教人出家。七建立法幢。若人于上七业中随作一业。如梵光行天受喜乐报一劫。其梵福量者。用诸众生共业感一三千大千世界业为一梵福之量。二远尽苦际得脱生死。故无上依经供佛舍利芥子等悉得究竟脱生死苦。大悲经亦同。施僮使令其代劳。又舍自身为彼给使。是为第六十门也。是同事摄也。是以自身作盖作荫。覆障如来成孝供养。又身施众生为奴仆。是躬代劳苦。又以己身奉给诸佛为报恩行等施国土及王位者。问如有恶人乞此王位欲恼害众生岂得施与。答菩萨见此亦不施与。如瑜伽四十九。若有上品逼恼众生行暴恶业来求王位。终不施与。施严饰大城者。前通施国土。此文别施王所都处。大城自居异余小城故也。宝女即为侍人。非是二物合施。问此宝女等为是化作为是宝报。答是实报。经云皆是菩萨净业果报而用布施。又下法界品中皆是往昔同善根愿如妙德女等。故云若能眷纳我甘心受此苦。又如卖华女等。是故施之皆不生恼。问瑜伽云。若有众生来求种种能引戏乐能引无义所施之物不应施与。今此宝女既生彼贪染云何施与。答此中有三义故。是故施之。一菩萨观彼有益无染方乃施与。若有染过则不施之。二此女既实是菩萨同行眷属。是故不令前人生施贪染。三此女能以法门有利益彼。是故施之。若反上三义则不应施。摄论中。有利益有染污。无利益无染污。有染污无利益。此三菩萨不行。有利无染污菩萨乃行。瑜伽约前三。此文据后一。故不相违也。施妻妾男女此亦合论。如须达拏者此云善爱或云好爱。如太子经具说施妻子等。现庄严王者即大王庄严经中说施妻子等。又菩萨本缘经中一切施王子施王子大战象。与怨国人。王臣同嗔摈王子于雪山。山中施二子已。天帝化来。从乞妻得还寄王子。后更乞眼。王子欲排。乞者止之。且还寄汝。我须即取汝更不得施人。王子言。我今何得受两物寄。广如彼说。问此中所施妻子等为是实报为是化作。又彼乞者为亦是实为亦是化。答此有三义。一约上品。俱实而施。如一切施王施儿与婆罗门。婆罗门鞭打将去。至一树下更欲打之。树神手拟婆罗门。婆罗门即倒。神欲断彼命夺王子送还。王子告神。请勿害之。我若再还令我父王檀行不足。即为不孝之子。神遂放之。解云准此妻儿亦是同修菩萨行人。尚须自舍身命。岂有辞苦而退。二约中品。互有实化亦行布施。如贤愚经。佛昔为王。有毗沙门作夜叉语。从王索妻子食。食讫为说偈云。一切行无常。生者皆有苦。五阴空无相无有我我所。说此偈已复本形。妻子犹存。此则妻子是实。乞者是化。净名经中多是住不思议解脱菩萨为调练余小菩萨增其行位故作此乞人。欲破此菩萨妻子爱尽。是故对前示现食之又。摄论中毗荀陀王舍儿与婆罗门。是逼恼他事。此儿是化作。是故无恼。解云此乞者是实儿是化也。以菩萨方便满婆罗门愿。令怨心尽故作是化也。又如菩萨化为女色施贪爱者调令离欲等。三约下品。俱实不施。瑜伽三十九菩萨于自妻子奴婢仆使亲戚眷属若不先以正言晓喻令其欢喜。终不强逼令其忧恼施来求者。虽复先以怨言晓喻令其欢喜生乐欲心。而不施与怨家恶友药叉罗刹凶暴业者。不以妻子形容软弱族姓男女施来求者令作奴婢。解云此据软根初心说也。又若两俱是化则互无义利故无此句也。施家宅令众得住处喜。施园林令得游欢喜。设大施会者是无遮大会。种种皆施谓不限物不局时不遮众无前无后等施一切故也。如下香牙园处设大会等。梵名般遮于瑟。此云无遮大会也。施一切资生具者是第七十门也。以别说诸门不可尽故。是故末后总就一切资生之具而成大施上来随大门有七十。若更细论所施物中种类不同。依光统师有一百二十。次广有八万四千。何者谓百二十事中皆有十善业而行施故成一千二百。以七施法乘之成八千四百。一一行中具十种回向故成八万四千施行之门。七施法者随相有六入理复一即为七也。随相六者心有三种。即三时喜等。事有三种。即施者受者及财物等。入理有二。谓照三事空。一寂之理。又释以七圣财乘之亦得。如一施行有八万四千。余一一行皆亦如是。若散说行相无量不可说。第二大段此摩诃萨以如是下总结所为。生喜回向于中有四。初结行所为。二有来求者下显行成无失。三菩萨尔时下度行无失而生大喜。四摩诃萨善根下以所成喜行用将回向。初中二。先约行结意。二以大悲下约心显意。瑜伽三十九又诸菩萨于诸有怨以慈意乐而行慧施。于诸有苦以悲意乐而行慧施。于诸有德以喜意乐而行慧施。于诸有恩亲善同意。以舍意乐而行慧施。当知亦名菩萨巧慧而行布施。建立如来论者上云受持诸佛本行显现诸佛本行。如行能说故云立论。由立此论令生不断佛善也。下显行成无失中二。初明三事成行无失。于中初明称乞者意离乖意失。二施心无悔离杂念失。三舍一切等明施物广多离匮乏失。二于诸众生下重释成。初释上施心。视如一子悲心深也。是我善知荷其恩也。由初心故长养大悲。由后心故长喜心。俱由上二心令悲喜不坏。依此悲喜广行大施心也。下释上。以物丰遂求称意欣悦。问何菩萨见乞生喜于财无染。答以施行熟故。施障尽故。何者施障。瑜伽三十九云。又诸菩萨于施障及对治如实了知。施障有四。一先未串习。二施物鲜阙。三耽着上妙物。四欣乐当来具足财果。一若诸菩萨现有种种可施财物。乞者现前而施心不发。即以正慧知我于施先未串习过失。决定知我先世于施未曾串习致今有财乞者现前而施心不发。若今世不强施者复来世定背施行。是故菩萨力励思择而行慧施。二乞者现前。由财物少施心不发。以正慧通达。或由我宿业有过失故。或由现在系属他故。令我现受饥渴等苦不能益一切众生。设令行施乃至殒殄犹为最胜。况有菜叶可以活命。是故忍苦而行慧施。三乞者现前。由可施物妙施心不发。即以正慧通达。是我耽着过失。我今于苦妄生乐想。由此颠倒生当来苦。是故菩萨励力行施。四若菩萨施已欣乐当来大财利果不求无上正等菩提。即以正慧通达是邪果见过失。观彼诸行皆念念灭。所受用果速疾灭尽速疾离散。是故灭彼乐邪果见施行回向无上菩提。问准此经中诸大菩萨财宝无尽。悲心复广。如何世间犹有贫苦众生类耶。答依摄论偈云。见业障碍善。厌现及恶憎害他。彼众生不感菩萨施此有五义。一菩萨见众生贫不作恶业富即作恶业。二众生贫即修福富即障善。三众生贫即厌生死心现前富即不厌。四众生贫即慈善富即憎恶他人。五众生贫即不能害众生命富即损害他命。菩萨由见此五种义令众生百千万劫常贫穷不作恶业染着生死。不令众生于一刹那富放逸作恶堕四恶趣。是故瑜伽中于诸有情有安乐无利益菩萨亦不作。第三庆喜文二。初胜喜资神。丈夫行论中菩萨喜乐过于世间及彼二乘涅槃之乐。此中但望世间超过。后摩诃萨下因喜增心五句可知。第四善根回向中有十句五对。一令离苦因果。二令得乐因果。上二对各先因后果。三境心。四心行。五分满。上来广显行相。即众生菩提回向竟。自下第三明行极契真即实际回向。又前明行广大。此下彰行甚深。于中有二。初显行心无念总明回向而无缚着。二摩诃萨下明于境无染别显回向而无缚着。前中以此回向时牒前行于身等不缚着总明能回向三业无念而成回向。下别显无念之相。于中二。初明无我等法想。后明无业报等念。前中初九句明无我想。禅头者。古人云。此名见一切生有形有体。今更问三藏法师。云此翻名生者。二无有想下十句五对明无法想。一离有无法想。二离三世流转法想。三离常无常想。四离三界非界想。五亦离想离无想。上明能缘自体无想。下明能缘业用无念。谓不为想念所羁名无缚着。游空无碍而成回向故云无缚无著解脱心回向。于中思及思报约意业。因业及业报约身语业。又业约似业。思约业体。如是无心无无心而作如前大施回向。自下明于境无染别明回向。于中四。初别明无著。二摩诃萨若于下别明无缚。三若于此法而不缚下别明解脱心。四摩诃萨以此一切善根下别明回向。初中如是回向时者将欲别释。如前所作大回向时。常无缘念。是故今更重总牒之。下别显无著。于中内是六根外是六尘。缘是能缘境是所缘。余可知。二无缚中先牒前。无著者依前起后也。谓心染于境名为着。境缠心为缚。楞伽云。心缚于境界。觉想智随转此之谓也。由贪着境深。是故心被境缚不得自在。今皆无也。于五蕴上各有三义。一不缚色者是总显无缚。不缚色取者别约凡夫执取五蕴。不缚色灭者别约圣人无取五蕴。又不缚不取者不缚有也。不缚灭者不缚无也。俱无执着不为所缚。下明解脱心。于中三。初标谓牒前起后。于此法者于上五蕴有无法也。由本了彼法本自无缚性本解脱非今始脱故云亦无有脱。次征下释。先别释于前有法之中性脱所由。谓此有法即无生灭等故性自脱也。后菩萨如是见法下别释于前无法之中性脱所由。见法则非法言语断故牒前有法即性自无。非法为法者起后于无而亦性离。以不住无故不碍有也。前则有不有故于有解脱。此则无不无故于无解脱。由不坏业故具修行。不滞空故不同二乘。是故不退求一切智。余句可见。四别释回向。先总谓向种智。以化众生下别显。先问起后答显有十句。皆是教化众生成此等事故名回向可知。上来实际回向竟。总是大段第二依身起行竟。自下第三辨行所成益。于中有二。初正成回时顺同因果益。句别有九。初二顺同佛宝法宝。次二同因智果智。次二同随事心境。谓义是境义。次二同入理心境。后一顺同清净法界。二自下明回向已后令自他入法益。于中亦九句。初句利他益。余八自行益。谓称法而了故无违失。又不舍真空不违缘有。空有无碍故云法力具足也。佛子下结名。上来位行竟

自下第二明当位所成果。句别有十。一外蒙佛护。二内得坚法。三上修佛智。四善解所诠。五照达理性。六得坚固善。七满足所愿。八得行法顺坚不可坏。九得坚固愿。十于法自在。又此十种望前行益配释可知

第二大段偈颂中二。先序说偈因缘。后正显偈。前中承佛力明起说所依。下辨依力所成有十句。一观十方显十方同说。二观大众明说所被。三观法界明所说义。四深入等显能说之教。五修无量等显起说之心。六觉悟等明开觉说智。七入佛功德明得佛说得。八逮得等明得佛说身。九分别等明了根应时。十随顺法身等明依真起应应起顺真。是故即说而常不说。正偈颂中。四句成颂有四十一偈。但颂位行不颂位果。于中分三。初五偈颂上行所依身。二菩萨具行布施下有三十偈半颂上依身所起之行。后随顺思惟下五偈半颂上行所成益。就第二所起行中初十九偈颂上略标行事及广辨行相。即是回向众生及菩提于七十门施巧略不尽说。菩萨观察一切法下十一偈半颂上行极契真。即实际回向。于中初二偈颂上总明无念回向。次心不分别下七偈半别颂上于有不着而性自解脱。后菩萨虽复推求下二偈别颂上于无不住而自解脱余文可见

第七等心随顺一切众生回向。于长行内亦二。初位行后位果。初中亦三。谓标释结。就释中分三。初明举所修行相。二摩诃萨离垢清净菩提心下摄将回向。三摩诃萨行如是回向胜出下明回所成益。初中二。初明所修善根。二摩诃萨行如是等下明因修成德。又释。前明行体。后明行用。前中三十句。初十直说善体。次十约境以明善根。后十约十度行以明善根。光统云。初十行出自中。次十起从缘发。后十功成在已。初中增长三品善者有二义。一三品各别。各别增长令俱广等。二于一善根始修熏识初成种时名增下品。从种生现令更增长名增中品。重熏成种名增上品。又释起随事行名增下品。令行入理增成增中品依理起行令称理广大名增上品。无量等下皆是上品善中差别。四行德非一名无量善。五各等法界名为广善。六随缘不同名种种善。七体深莫测。八妙用难思。九数不可穷。十绝于际畔。下约境中。一因求佛境所生得善。二因求法境。三因学僧行。四因求善友依上四境生智善根。五缘众生为境生悲善根。六令悲智相导名方便境。七俱同契真名微妙境。八自利善名内。九化他善名外。十总结多门名无量功德各生善根故也。后十约十度行境所生善根。初六可知。七方便巧知众生心器。八大愿积集诸净功德。九念力度业用十大智普彼下明第二所成德。中乃至开解已者牒前起后也。则能下正明所成。于中二。先明体德圆备后普能下明作业殊胜。初中二。先成自分德有二。自利中。初忍。二善调等戒。三永离等慧。堪为等结三行成法器。普为等是利他。后常为下成胜进德中。先由佛守护生善满愿。后由深乐佛心得等佛。二作业胜中二。先上供佛业。谓供行顺理。不求等离过也。二一切善根下明下救生业。于中二。初化他德备。二于生死中下成化他行具。于中三。初令出生死安菩提大智。二普示下令舍尘染得大净功德。三令一切众生下总结所益。上来明所回行竟

自下第二摄将回向。于中四。初约菩提心收摄善根。二摩诃萨复作是念如此善根若有果报下以前善根回成行具。谓令修行之时诸缘不阙称本期愿而成大行。三以此善根念念回向下以此依行所起善根回向众生令得菩提。四修行如是回向时不着业下明行极契真行无所行回无所回。前则众生菩提回向。此则实际回向。又前则以智从悲成广大回向。后则以悲从智成甚深回向。初中先标举大心所摄善根。作是念下显所摄善根之相。于中十句。前五约心体起善。后五约心业用成善。前中。初一总。后四别。一自分始。二自分终。三胜进始。四胜进终。业用中。初一此心以大悲为本愍物起善。次二为众生故求佛果智。一始。二终。后二集起彼因。一行广称法界故。二行坚不退故。自下第二回前善根以成行具。于中先总举要期。谓此菩提心所摄善根若决定有果不虚者我当尽未来劫行菩萨行不舍众生等。此有二意。一以此善根如我意愿成益生果故。二以此善根所得依果令我修行摄众生时缘无所阙。是故我能尽未来际修菩萨行。此文取后意。二令无数世界下别显所成行具。于中二。初回成资财施行。二复次下令成生财施行。问何不回向令成余行而亦成此慧施行耶。答此中菩萨为益众生行菩萨行。由此施行具有三义。一财等现益令得离苦。二因施摄令入法成行。三以所生善回施众生。余行不具故唯此也。初资财施中有四。一资财广有十一事故。二明乞者广一切众生故。三明施心广。四施时广尽未来故。就施心中有十一。初于怨不简名平等心。二于亲不著名无偏心。三不为世名。四情乐非强故名无恼。五施已称庆故无中悔。六注想菩提。七不杂无明故云清净。八情无异念故云一向。九大悲现前。十调离有为。十一住入无为。第二生财施中三。初财广亦有十事。婆罗马王者三藏说。正音具云婆罗诃此名云马。谓游行空云迅疾无碍。因以为名。又云大海内有一洲名跋陀罗。此马常居其中。每恒出声云。谁欲出海。我当送之。此应是龙马。然有慈心或菩萨所化也。二修习下约时处对人明施行广大。三摩诃萨复作是念下明施心纯净有十四种心。一不着施因。二不求施果。三游空离系。四宽遍普被。五与理相应。上五是入理心。六巧施摄生。七等施无偏。八不计身命。九悭结已破名善调心。十定心利物。十一于生不恼。上六是摄生心。后三是求果心。十二求果不舍名安住等。十三观解照法。十四趣入佛果。又前五离有为心。次六摄众生心。后三求佛果心。又前五护烦恼。次六护二乘狭心。后三护二乘小心。又前五是直心。次六大悲心。后三是深心。上来回成行具竟。第三回向众生令得菩提。此即是舍施。智论十四云。有二种。一世间人能舍财不能舍施。二出世间人能舍财能舍施也。此中文长分齐难见。但一一句各是一行。亦不可别分。今且依远法师分为二分。初明慈心回向。二如是菩萨怜愍已下明悲心回向。前中总有一百十八句分二。初八十句回向众生令修因趣果。二令众生诣诸佛所闻法下三十八句回向众生令因圆果满。又可前明自分后明胜进。前中有六。初令修善趣贤首位行。二令得不可坏正直之心下令成种性位中修行。三令具足菩萨无量清净下令成解行位中修行。四令成就清净平等施下令十地位中修十度等行。五令修平等行具诸善下令于等觉位中修行。六令显现一切严净下令成佛果行。第二胜进行因圆果满中有四。一令众生于种性位因行圆满。二令于诸法中得离虚妄下令解行位中因行圆满。三令悉得菩萨不退下令十地位中因行圆满。四令得萨婆若成等下明成佛果满。上来慈心回向竟。第二悲心回向中有三。初令离惑业而成苦行。二令众生安住下令离喧得静成平等心行。三以如是等下总结回向利益之相可知。上来广大回向竟

自下第四明甚深回向。即实际回向也。于中二。初明会事同理回即无回。后摩诃萨如是回时作如是下明依理起事无回作回。又初即离有后即离无。又初是自行同如。后则令他亦同。又初正是实际回向。后是回向所为。前中修行如是回向时者牒前广大。下显甚深有十句五对。一约已业报因果一对。二约自正报身财一对。三约依报方处一对。四约所化众生有无一对。五约所回行法总别一对。皆云不著者无分别也。皆云回向者明上广大回向之时。常如此不着而恒作彼回向行事故亦不无彼回向矣。下明修回所为。如是回时者牒前甚深之回。下显所为有五句。初二句标。次二句释。后一辨位。初中一佛智是菩提。二净心是涅槃。三释初句。四释心净。佛家是位。上来明回向行竟

自下大段第三明回向益。即是此行所成广大之德。于中有四。一成因德广大。二摩诃萨修行时成就下明成果德清净。三摩诃萨如是行回不违下明成会违自在德。四摩诃萨得平等业下明得违尽平等德。又初一是现成德。第二是当成德。此二因果一对。三是会相。四是得实。此二摄法一对。初中十句。初二总叹显胜。下八别显胜相。一行广胜。二以少下普见胜。三悉得下持辩胜。四于念念下现生胜。五又于念念下严土胜。六令不可说下益生胜。七得无碍下闻法胜。八住无所有下神足胜。准此德用。若非圆教诸位相摄何容地前得有如是无碍德耶。自下第二明有成果之德。于中三。先牒现况当。二悬辨当相。三举当结现。初牒现况当结前生后。谓结前因德尚尔无尽。况当成果位岂可量也。二所谓下悬辨当成果德之状。句别有十。初六果相圆。后四果德满。果相中。初二严土摄生净。次二正报总别净。谓根是眼等根也。下二是主伴圆。净谓业报是主净也。后四是德满中。初二行圆证极入法是证也。后二是愿满自在。皆言清净者染无不尽也。平等者理无不证也。此等并是由此位中回向力故令此菩萨当成如是佛果之德。三摩诃萨下举当结现。谓得净法门是得体离染。庄严是德相圆备。此是现所得也。自下第三明会违自在。于中三十句为十五对分三。初七对明融缘起事令违相斯尽。次有一对理事互融俱无障碍。后七对会缘就实显理融无违。此亦是显法之渐次也。前中初此回向行。为净佛刹故云不违刹。为安生故亦不违。二令众生依刹起行刹业不违。三业依心起王数不违。又思是业体熏本识心故不违也。四业托境成思境不违。以是唯心所现之境故云心境。五业所感果则缘报不违。六业与业迹正助无违。远公云。解或等心起。业所依名为业迹。辩师云方便造作名业。根本业道名迹。今释谓决定思是身口业所游履处名为业迹。又释初刹那思为道引发第二刹那思为业体。道即迹也。又释思体为业。熏在本识成种子为业迹。又释思为业。业有感诸道果报功能为业道。道即迹也。七法体与相能所不违。谓彼业等既是有为。必具四相。上来有二不违。一由各缘起相资相顺故离相违。二既各相依互无自性。自性无故其谁相违。次一约理事双融以明无违。谓法生不违性者以缘生即无性故。性不违生者依无住本立一切法。又初不坏假名以说实相。后不动真际建立诸法。下七约理融明无违。谓刹与众生相随似异。平等之理此彼不殊故无违也。余句可知。自下第四得违尽平等。于中二。初十句明得平等。由前违相尽故得此平等称性之事。谓业报等十也。后得见佛下十句得成行位究竟。并可知。佛子下结名

上来位行竟。自下第二明位果中有十六句。二二为一摄为八对。一断染果。谓伏魔怨止恶缘也。拔欲刺断恶因也。二入证果。谓无生道修证因也。到无二正证性也。谓理绝能所故无二也。智契彼法故云到也。三得无量下成益生果。谓道法救生神通化物。四常乐下寂用无碍果。五悉能下明行愿广大果。六分别下智通殊胜果。先智后通。七得无碍下明见闻自在果。八修诸下行修具足果。下结可知

第二偈颂中有二十一偈分三。初半颂上行相。中间诸偈颂上回向。末后一偈颂上回益。就颂回向中三。初三偈颂上回成行具。二以此下六偈颂上因行生善。回向众生令得菩提。三深入下十偈半颂上实际回向。于中二。初三偈半颂上不着业等自行同如。二菩萨观察下七偈颂上令他入实。后一结叹益可知。第八如相回向同理。善根是如相称理而回名如相回向。此与上下何别者。谓前七明会事向理。此第八明事尽理现。是故行等俱是如相而回向。后第九明从理起用。第十明用同体同体而用。故云法界回向也。长行内亦二。初位行中亦三。标释结。释中亦三。初举行体。二摩诃萨以如是等善根回向欲令下正将回向。三摩诃萨如是回向时下明回所成德。初中先有三十句。举差别善根。末后一句结成一观。前中初十句显所修善根。二慧眼下十句明长养善根令更增广。三摩诃萨下十结叹善根差别具德。初中先二句明观成入理善。初句标。下释显。谓离痴释智。正念释念。坚固释安住。不退释不动。此是正念成止。离痴成观。止观双运无碍现前。故云成就等也。后得大乘下明随事大行以集善根。有依八种心集善根。一依深心以起善根。先举心能。谓心依理起故勇无畏。依此猛心起二善根。一广多无尽。二称理胜妙。三依白净证起同体大悲即悲心也。四明直心正念诸佛。五回向心称理不转。六依求道心巧出坚善。七依正念心出一切善。八依巧慧心回成利他。下明长养善根十句。初慧眼观察善根之实。是故令此善根增长。此是长养善根所由。下明所长善根。于中初句总显。下八别辨。一明善根分齐不同故云分别等。二备德无缺故云具足。三体离染过。四唯住菩提不向凡小故云一向。五修治使增。六修行所成。七思惟令广。八称实广说。自下第三结叹差别。于中明此善根多能异德故堪成回向。十中。一种种门者通游非一。种种境者所缘不同。种种相者体状区分。种种事者缘成各异。种种分别者分齐不杂。无量行者施等多种。语言道者此善根是无量言教所行处也。出生等者依此善根能生多分别智。修行等者诸善互严。悉能等者俱趣佛果。下结成一观。显甚深中。谓虽有如是多门种种然皆一味同于真性故云无二。一切智境者谓此同性之善唯佛智能知。又释此同性善堪成佛故是彼境也。此则前诸门无差别之差别故有多门。此即差别之无差别故唯一味归于佛果。上举所回善根行体竟

自下二用之回向。于中有四。一因成自行以修回向。二复次下因事起行复修回向。三摩诃萨善根如是回向不着世下明前二回回无回相。前二是众生菩提回向。此是实际回向。四如法门下明称性纯熟自在回向。又初二是广大回向。次一是甚深回向。后一是深广回向。以同如之善根成称真之回向释成如相也。初中二。先以前善根回成自行。后如为已身下正向众生。前中二。初回成法身三业行。二得离痴下回成严饰净土行。前中三。初成身业行。二成口业行。三成意业行。意业行中三。初明依心成自行德。二任持下成利他德。三具足下一句总结所成。初中依七种心成七胜行。一依无碍心成清净行谓洞理无碍令行净也。二依大施心成财施行满众生意也。三依照法心成法施行。四依不坏心成求佛智坚行。五依菩萨心成照一切法行。六依念佛心成三昧行。七依正直心成离染行。下明利他行中句别亦七。初一成化行。谓摄机不失名任持。充满一切是广化也。而无休息是常化也。次二句明化行所依。一化同佛智故云安住也。二依定起用以赴群机故云得深三昧。次二句明摄化处。一广游。二遍住。次一句成化他事故云化生不息也。后一句成化智谓成方便慧也。下一句总结所成。谓具足成就自他行慧深广难测故不思也。自下二明净土行。先别显有六对。初中离痴是体分别是用。谓离分别而分别也。二一念严土是用广也。于诸通慧是用所依。三入实法是体深。示现等是用广。四一见一切是用无碍究竟等是用所依。谓持一切不令坏也。五以菩萨具严是德体。应现调生是用相。六一佛世界等是体广。得究竟等是用持。下总结所严之土令众生满。谓本严土只为摄生。回向分别持智者是总结上来回向持刹之智也。上来成自行竟。为欲回向救众生故先辨自行为本方堪长劫摄众生也。自下第二正回向众生。于中先举自例他结前生后。下正显回向有二。初回令出障六句。初三出三障。谓一离报障。二离业障。三离烦恼障。后三成治行。初一对离烦恼。二对离业。三对离苦可知。下令成德。如大云雨者有五义。一普遍故。二成润故。三能出雨。四雨能灭尘炎。五雨能生卉木。回向大愿亦具五义可知。下别显所成有九句。初二成行。一离过名净。二生善名田。次二令入证。一入证方便观谓如来藏令不忘失名护受持。二正证成就故云住净法界。次二令成德。一成心自在德。二令身自在德。后三成三善根。一无碍善。二无贪故名摄净。三无嗔善。自下第二因事起行复修回向。前已成自行回向。今更成因事回向。故云复次也。于中三。初因事起行。二摩诃萨如是回向下正将回向。三如是摩诃萨下明回所成益。初中二。先因见胜事。二巧随起行有三。初明所成行德。有法喻合。谓随所见事托彼成行故云修巧方便等。既见可乐之事即乐求实义等是也。二巧妙下明行胜用。三如善根等结行同体。二正向众生中皆令得可乐者由前见可乐之境遂起可乐之善。令回向众生成可乐之德。此是巧便之用耳。于中三。初未入法者令得入法此在地前。二令菩萨下已入法者令得入地此在地上。三具菩提下已得地者终令得果。初中七句。初中非但见佛不取体性。亦乃见众生亦不取故云亦复如是也。又释令见佛如法。于佛不着不取法性见法不着。无数众生等于僧无著故云清净。维摩云。不着佛求不着法求不着众求。同于此也。二令作称佛意之侍。三令国净可乐。四乐所求法处。五令乐出世法。六乐持不忘。七得正慧法明。下明地上行中。初二句成初地财法两施行。二得三昧下明二地已去功用位行。一得深定。二得总持。三得记智。四得胜通。上是自德。下明化德。五广说。六巧说。七化心。谓悲是。八常化不息。九广化。谓于多时多处也。下明八地已下无功用位行。于中。初由现佛劝得舍寂起修名巧方便。二称理起行名深方便。三永离下明八地以无碍故舍爱佛菩提等贪心。故云离欲深解等明摄治行成。四具足下明八地入无生观。五九地中称机说法名无诤。六十地中得金刚无间道现前名成满。灭微细着碍等障故云灭障道法。下明地满成佛果可知

自下明第三回所成益。谓由因事起行回向力故令自善根转更增多名为长养。得净下别显有十句。初内增明慧。二外善友护此是生解益。三佛慧照心。四痴闇障尽。上二是断障益。五修法入智是证法益。六善学下起后智益。七一切善根下大愿益。八一切菩萨下尽福原益。九成就下成智坚益。十明解下显解广益。上因事回向竟。自下第三明前二回向无所回。即实际回向。此上诸回向实际与此何别者。上皆摄相归体。此中摄相归相故异也。于中有二。先约行辨。后如是下约心显。前中二。先明此回向即常无著。二观甚深下明以无著而成回向。前中四。初不著有谓于上严土摄生俱不着故是故云不着界等也。心无依者明所取无相。寂然不乱者能取不起。正念法者明妙绝能所正理相应。起信论云。住正念者当知唯心无外境界。此之谓也。二具足下于无不着不碍起行无分别智名无选择。不违回向是不碍起行。不违正法是不碍入理。三不坏佛相下明双离有无。初不坏佛相不着无。等观三世不著有。此约所敬无著。了众生空是不著有也。无所依是不住无。谓不于无而住着也。此约悲境不着。是即观如来空而不失敬养了众生寂而不失摄化此之谓也。四顺如来下明离着之益有三。初正解渐至益。二如实分别下智慧周圆益。三未曾下明寂用俱行益有法喻合可知。下明以无著而成回向观。上深法以生实智。谓不著有无之智依此实智而成回向。下别显。初明理事无碍止观俱融回向。二以前无碍成自行回向。三摄取下成化行回。上约行竟。自下第二约心辨有八种心。一不怯弱心回向佛法。二广大心回向净众生。三无颠倒心回不染刹。四无余心回不染境。五离世心回得出世。六无著心回成悲行。七见法心回成趣果胜道是也。八厌离有为心回生真善。上来实际回向竟

自下第四明纯熟自在深广回向。于中广明如相回向

释真如义作四门

一释名者。不坏曰真无异称如。前则非四相迁。后则体无差别。此约始教。又不变曰真顺缘称如。由前义故与有为法非一。由后义故与有为法非异。二义合为一法名曰真如

二种类者。或唯一味。谓约实无差别故。或二。谓安立谛真如。非安立真如。又二空所显亦二。即生空所显真如。法空所显真如。又二。谓空真如。不空真如。染法不染名空。具性功德名不空。或三。谓约三无性。即无相如。无生如。无性如等。又有善法真如不善法如无记法。如出杂集论。此约诠辨也。或七。显扬论云。一者流转真如谓思惟诸行流转实性。二实相真如谓思惟诸法无二我性。三者唯识真如谓思惟诸法唯识之性。四者安立真如谓染污法体思惟苦谛。五邪行真如谓染法因思惟集谛。六清净真如谓净法体思惟灭谛。七者正行真如谓清净行思惟道谛。或十真如。谓约十地中所证真如有十重等。或百门。谓十十无尽。应于圆通无碍法门也。或通一切法也

三明德用者。一成依持用。谓染净法依持而立。二成观境。谓入证用。三依起信论有三大。一体大谓真如平等不增减故。二相大具足无量性功德故。三用大能成一切世间出世间善因果故。问不善等法既非真用应离如体。答由违真故不离真。由违真故非如用。此论意以诸善法顺真故并是真用。问经说如来藏兴造一切世间犹如伎儿作种种伎两等。准此染法亦是所造。所以言非。答理实染净俱是所持而得建立。但违顺异不同也。何者如观施行三事空令施福广大等于虚空。若观罪体空则令罪障灭。何以不亦令罪广大。是知罪违于真。入如则灭。善顺于真。入如则广故不齐也。此则遍兴染净顺用非违。此上约始终教说。又别随缘通一切法。总是真用。具帝纲微细重重无尽。自在圆融即相不待会。即性不待随。如此百门所辨约圆教显耳

四约教显者真如有二门。一乘真如。三乘真如。一乘亦二门。一别教谓圆通诸事统含无尽如因陀罗纲及微细等。广此百句如中说。二同教者则与三乘义同。但由智回向故入一乘摄。二者三乘真如亦有二门。一顿教如维摩直默以显玄意者是。此如绝于教义相想俱不及。如大般若经那伽室利分说。二渐教者略有三门。一终。二始。三世间所知。初终教中复有二种。一始如三十二菩萨显不二法门者是。二终即文殊所显不二者是。此始终两门并具无分别教义空有二门。二始教中亦二。一始如百法论六无为属一切法摄。显人法二空得知真如不及二空为上。此门通分别无分别教义。二终者如维摩为迦旃延说不生不灭是无常义等。又金刚般若微尘则非微尘等。又对法论开六无为成八则三种真如属无为摄。得知真如成无为上。此初教始终并通分别无分别教义。无分别义者谓证真如。无分别教者谓比观意言无分别境悟大乘言教故。分别义者谓教义则空故。今初教中真如但是空义不同终教也。三世间所知真实者复有二种。一始谓人天正善根及愚法二乘等入真实性摄故。中边论云。世间所知真实入真实性摄。准彼论文世间唯除虚诳妄语等。余并入真实。由许是菩提远方便故。二终者故论云一切法但有名。谓分别名思惟名得知。不同远方便法。此义唯局二种十名中。为是大乘近方便故。真如者乃至流在十名理不可坏故同是真如也

于此文中数有百句。检文缺一句。初一句是总。余皆是别。总中真性不异名如。自体妙轨称法。通智游入曰门亦是不同生灭门故名门也。至一切道者显其分齐。谓明理遍众行。无量无边善根回向者明行遍如理。谓称如而成回向。又释理实真如遍一切道无量无边差别之法则彼诸法为如诠门。真如于彼异异诠门而全体显现。门乃多途故云遍一切等。今且就百门明十十无尽。此则一切法是真如之门故云如法门也。此顺梵语故是倒也。义正应言如遍一切道无量无边彼一切法是如之法门。故云如法门此是标也。遍一切等释显。谓一切道者道是门也。以能显真如故。善根回向者谓明以同如普遍之善根随异门而成回向。下别显。一一句中皆有三义。一如如者标举如理谓如彼真如。二善根亦尔者举善同如。三回向等者以同如善根回成同如之益。是故所回善根及所向众生并所成益相俱是真如而有所成也。又此三中。初释如。二显如相。三释回向故名如相回向也。又初辨如体。二相。三用。则是真如三大也。下一一句皆亦如是。于此别中。英法师分为十分。谓初十明贤首位中如。二十明十住中如。三十明十行位中如。四十明十回向位中如。五十明净心地中如。六十明行迹地中如。七十明决定地中如。八十明究竟地中如。九十明等觉位中如。十末后十明佛地中如。此等分文亦未见其顺。又灵裕法师北台意法师炬法师等各分作十各悉不同。然于文势并皆不顺故不叙之。远法师云。此等何异异相难识。今且言之。初十句约就地前所行辨如。后八十八就初地上所行辨如。此判亦难。今谓诸门各是一法。并取真如体相用尽。亦不可相从科为分段。于中诸门真如皆体从缘异。谓性如非相如等。善根同如亦随门别。是故性如善根非是相如善根等。从异门体起用亦异。是故性门回向无性相门回向实相等。下诸门皆准知之。过去非同等者。相州大范法师云。此破小乘三世之执。谓彼执过去为有。若是有者便同现在。今既灭无故云非同。言未来非故者小乘亦执未来有法流至现在。若尔应是故法今既未来。缘未至故毕竟无法云非故。现在非异者彼执现在决定是有。今明待缘假合。推之则无故不异过未之无。故云非异。裕法师云。过去非同者集起而无集起。非故者转变而非转变。非异者相别而非相别。发起新新者称过去也。除灭生死者同未来也。清净生者似非异也。远法师云。过法无常。同归尽灭。于现本无故曰非同未法新生非本有性故曰非故。现法皆空故曰非异。各此三非。以之为如。炬法师云。过去非同者明如体。虽在过去而非迁灭不同于无。未来非故者虽复集起而无起相。明已起之处非故。现在非异者虽在现在而无形处不异过未。英法师云。过去灭法与无相似。名之为同。今明依如起新行愿不同彼无故曰非同。谢落故业当报方受。名之为故。今明证如舍彼故业故云非故。现造业结不同过未名之为异。今观业结本无造起毕竟清净故云非异。发起新新等释过去。除灭等释未来也。清净等释现在也。今更释泛论三世法有二门。一性空门。二成有门。性空者谓过去已灭故空。未来末至故空。现在不住故空。今此文内约成有门。谓前念法是过去灭。以能引起后念法生。是故过去非同。一往唯断灭也。后念是前念家。未来虽由前念灭令此后念生。然今无前念法可传至后念故云未来非故也。是故前念中旧法今无后也。现在法望前念同未来。望后念同过去故云非异。是故前念流灭虽非同烬。然无法至后后念续前。虽依前起然法新非故。是故回向中发起新新菩提心者。以前念非同令后念续起令菩提心不断也。由后念非故所以念念新新令菩提心不常也。除死净生显心作业。文意如此思之可见。又现在念念成正觉者谓了达现在亦平等故见理名觉。上来四段总是第二正回向竟。自下第三结回所成德。如是回时者牒前起后也。谓由前善根同如回向是故得一切法即平等而利用也。十句分五。初二约处。一即等而成严。二即等而于中转法轮。二次二约人。一菩萨即等而出彼愿。谓起一切智愿者是菩萨也。二观多佛体不殊。三次二约法。一约法性。二约法相。又一真二俗。四次二约行。一菩萨行。二佛行。五后二约德。一约佛体等。二约佛用等。是名下结名可知。上来位行竟

自下第二明位果中得十果。一得佛法果。谓得无边净法门者证法多也深也是得佛体也。为人雄者成佛相也。无畏吼者得佛说也。成就菩萨者得佛所化也。不休息者得佛化时也。又初证法深也。二成人高也。三化益广也。四化时常也。此上是总句。下九句别显。一得佛圆身。二得佛圆音。三得佛圆力。四得佛圆法。谓超出众生故云胜。而即赴机故云示现一切也。五得佛圆通。六得佛圆用。谓不思解脱是也。七得佛圆定。八得佛圆辩。九得佛圆觉。谓现佛等觉于众生也。下结

第二偈颂中二十九颂分五。初二颂前行体。二菩萨思惟下四颂回向众生及菩提。三以此下二颂实际回向。四深乐下十六颂纯熟无碍自在回向。于上百门略颂不尽。又不次第也。于中初七正颂前纯熟同如回向。后九兼颂后位果。思之可见。五末后五偈颂回所成德可知。第九回向作四门分别。初释名者。此无缚无著解脱心回向约无等大行立名。无缚无著有六种。一由离凡故不缚生死。以出小故不着涅槃。二离六识取外境不缚。离第七执于内不着。三离现行缚无种子着。四不取有缚不执空着。五无惑障缚无智障着。六无粗使缚绝习气着故名无缚无著。此明行体。解脱是大用无碍。非但脱离诸障。此是行用也。心者是行体。用所依之心。谓菩萨大智之心是善根所依。以此心中所摄善根皆用持回向。成于普贤深广之德故以为名。此从能回向立名。问下文亦有无缚无著解脱等所摄善根。亦成回向。何故标名唯就心立名。答理实通余。但彼下文十门之中。此无缚无著解脱心内百门。回向文处广辨。余并准通。是故就此广处为名

二来意者。前会相从体。今依体起用。显纯熟自在故。此位来

三法体者以普贤三业无边自在甚深广大无碍大用为此位法

四释文者。就长行中亦二。初位行。后彼果。前中释内有一千门释分二。初无缚无著解脱心内百门广释。余九百门准例通释。就前中百门内复分二。初二十门辨能回行体。余八十门显所向行用。就前中亦二。初十以不轻心摄善根。二常乐下十积集长养拟将回向。前中初一心是总辨。余九心是别显。别中准总具言应云于出生死善根不生轻心。故云不轻出生死心。下皆准此。何故不轻者二义。一以从佛果流故。二堪成无上大菩提。如法华经中乃至一小音皆以成佛道等。如尼俱陀子小果大等。如上贤首品中扫塔等善成佛果中端严光等故不可轻也。问理应更有胜妙善根。何故下一约合掌等而明不轻。答此最微少世人所轻。菩萨收摄下至于此尚尔不轻。况余一切。故约此等辨也。别中。一离恶。二摄善。三广修余可知。二积集中十句。初一总由不轻前诸善根故。是故常乐摄受彼善。下九句别。一摄令不失明。二契合相应故云安住。三思念不断。四巧便更增名长养。五不以染心污彼善根故云不着。六纯以正心而成彼故云具正等。七无过失可简却故云不选择。又亦有善斯收故云不选也。八堪成佛果故云随顺。九能得佛果故云得自在。前句顺向佛果。此句正得佛果。举所回善竟。自下第二正回向中二。初六十门明广大回向。二从不妄世间下二十门明甚深回向。深广无碍为大回向。又亦初是菩提众生回向。后是实际回向。前中有六十门。内广显普贤自在德用。于中初一门是总。谓无缚无著解脱心是能回之心。彼善根者彼前所摄诸善根。回向具足等正是所向也。问此中不言回向众生何耶。答但令成就普贤三业。方能尽穷众生界而摄化也。是故亦是回向众生等也。下别显普贤三业德用。于中但知一一门皆摄法界自在德用。或理或行或智或境或自利行或化众生或体或用或因或果或人或法。皆各总摄一切法故不可相从别科。今粗分二。初二十四门显普贤因位究竟。二从于一一境界下三十五门显普贤果位究竟。以普贤门内通因果故有此二门也。又释前约自分后胜进。以二分无碍是普贤德故。前中亦二。初十四门明普贤自在三业。二复作是念下十门明普贤广大三业。前中初一是行所依。谓由勇进令行德成。下明所成德。初四门明总持无碍。是意业自在。次六力用无碍。是身业自在。次一明圆音无碍。是语业自在。后二门于众生世间器世间自在。第二明广大三业中十门分四。初三门明普贤广大语业。一说声遍。二持所说。三说无休。次二门明广大身业。一体。二用。次二门明广大意业。一因智。二果智。后三通结三业。一明三业广勤。二明身语深广。三辨意业摄法。上来普贤因竟。自下第二明普贤果德有三十五门。随相分三。初十门明得普贤摄法广大德。二于一念顷悉能下十五门明摄法自在。三妙智知色微细下十门明普贤微细智。又初是一重平漫知法二相即相入重重知法。三微细容持甚深知法。此亦是渐次之相也。前中一巧智自在名方便王。二无明住地尽名离痴法王。三慧照行法名法明。四巧成所化名为方便。于中列十。如是等下总结无尽。问前段明普贤因。何故彼中亦有佛行。此中明果。何故亦有菩萨行耶。答辨公释前举果显因。此举因显果。又云菩萨修行与佛等名普贤行。佛行大行名为普贤行。今更释经云虽得佛道转于法轮入于涅槃。而不舍于菩萨之道。是菩萨行谓因满成果用。得果而不舍因。又以因果二位即入无碍各收法界。谓因穷法界具于果也。果摄法界合于因也。五身业令见喜。六知语净口业。七知一切法智。八得佛法身自体相用。九得圆满根根有二义。一生后义谓出生无尽。二受法义谓根器领法。无限量故约所出所领说。及自体差别列十五种。可知。十得无尽神力。于中初一句总后十句别。依此等力修普贤行也。自下十五门明重重摄法无碍自在。于中初一无碍身智。谓身能外遍而内含容智入无生而生大行。二生如来家修法界行智。三以普眼见自在法界故云于一毛道等也。容一毛之路名为毛道。于中二法圆满。一容一切刹约事。二一切法界约理。三究竟空界就事空。何故尔耶。谓有二义。一以法性融通事随理融故。二以缘起相由无碍即入容持自在故。此有同体异体。准上思之。四入劫智自在谓长短无碍。五身业自在谓令一身即多多内各容。六见佛闻法自在谓不着佛不倒法。七入世界自在智谓回动转变随智无碍。八知想自在智。谓一切法皆是想念中而成立故。是故一切悉是想也。于中有三。初一句是总。二列三十八种所知之想。三如是下显能知之德。先明离障德。后一切如来下明知心所成德可知。九知心自在智。谓诸心相入及业依心异。十知处自在智谓一即一切等。十一知业自在智。十二知法自在智。十三知语自在智谓得无碍净耳。十四得知根说法智。十五知根自在智。上来十五并是一中一切而了知耳。自下十门明普贤微细智自在。初一明知世间法微细智。于中有三。初一句总举能知之智。二列十一种微细之法。衍法师云所知之事幽微故。能知之智微细也。辨公云此等并难知故名微细。今准上下经文于一法中有一切法。齐头炳然同时显现。是微细义也。三如是下明能知之德。二知众生微细智。初列十种所知。后结能知之德。三知菩萨行德微细智谓举初发意等取一切菩萨也。列二十一种所知微细也。四知菩萨位德大用智。先列四十二种所知。初十一明行位成满。生兜率天下明位满大用。谓八相等也。二如是下明能知之德。谓成普贤自在行德。五知众生性智。先列十种所知。后如是下能知之德。六知世界智。初一总。次列二十种别有三世间自在。后如是下结能知之德。又此等皆云微细智者是智从境名也。又此微细在智中故智即细也。七知法界智先举所知。一总十别后结能智之德。八知入劫智微细。初一句总。无量下别列十种。后如是下结能知之德。成十种心可知。九知法智微细。先列十种微细法智。后如是下结能知成德。前中法义有四重。一法体具德。二一切即一等明法用相即。三入非法等明理事相即。四入方便无余是体用善巧。十知无余智微细。先列十种所知。后如是下结能知之德。皆出生者谓量智从理起名出生。知无不尽名无余。此门亦是总结故云知无余也。上来广大回向竟

自下第二明甚深回向中。二十句中皆两两合举总为十对。一世与世法假实相对。二菩提菩萨圆分一对。三体用一对行是体出生死是用。梁摄论云。于分别依他性不见菩萨所行行及行道此之谓也。四人法五生熟谓不调者是根熟也。六行愿。七自他。八施受。九因果。十境智。此等是上广大回向之中诸事。虽成广大自在之德而于彼法无妄执取。是故皆云不虚妄取也。上来百门竟。自下第二类余九百中列十种章门。初一结前百门所属。余九次第结后九百。谓如无缚无著心所摄善根成此百门回向。无缚无著解脱身所摄善根亦如是回向。余皆准此。十中初三是三业。次二业报。次二染净土。谓世间染是化处也。次二根药谓众生是所化。法是法药也。下一正智。此十皆是无羁自在而生善根。用成回向具普贤德。是故皆云无缚无著解脱故也。初一置善根如是回向。余略令准。皆合具有应知。上来广略总一千门大回向竟

自下第二明彼果中有二。初行果后位果。前中有十句。初三因三世佛菩萨回向行。四得正教。五满正法。谓证法也。六等境界谓众生为悲境也。七同善根。八等所住谓大悲地是所住。论名梵住。九同一境谓真谛。十不违等不碍多也。上来释竟。佛子下结名。位行竟第二明位果。于中十二句得二种果。一现成果。二转生果。现成亦二。初行坚果。二行胜果。初二句标此二果。一切众魔下释显初果。二普现下三句释行胜果。一广行胜。二巧化胜。三离染胜。二摩诃萨下六句明转生果亦二。初外得眷属果谓不坏眷属也。二内得成德果有五句。一成法器德。二深行德。三因圆德。四果用德。五因果无碍德

第二偈中有五十一颂分三。初三偈颂所回行体。二所作下四十四偈颂广大回向。略不颂甚深回向。三过去一切下四偈颂回所成果。就第二四十四中。初一颂普贤因位究竟。余颂因圆果满。于中初世间无量群生一偈颂知世间微细智。次一偈颂知众生趣微细智。次一偈颂知世界智。次一颂知心智。次一颂知根智。次一颂知业智。次三颂入劫智及知三世痴慢等。次十方世界诸如来下二十七颂菩萨行位成满大用。于中初一总颂。次一颂住兜率天。次一颂入胎。是微细故胎中具八相也。次二颂初生。次四颂七步现笑试吼放光。各一颂可知。次一颂在宫及出家。次五颂坐道场降魔成觉。次五颂转法轮。次三颂般涅槃。又显余趣所现自在。次一结此菩萨善根回向。次三颂回向大果之行仪。上来位用竟。次有数无数下四偈颂入劫及刹并所行行。次二颂出生无余智。次一颂众生性微细智。下四颂彼果分中。初二颂行果。后二位果可知

第十回向中亦作四门

初释名者。法界等无量回向从法立名有其四义。一约所回行法。谓以法施之行成回向故名法界等也。二约所回行体。谓所回行体广大无边等于法界。三约能回之智。四约所回之德。谓以称法界之大智回等法界之善根。回向法界之大用故立名也。此则位满至极故标以法界之称

二来意者。前明依体起用此明体用无碍。圆极自在故次来也

三法体者以法施广成普贤自在大善巧德。是此法也

四释文中。长行内亦二。位行位果。行中三。标释结。释中三。初举行体。二摩诃萨于彼善根回向下正明回向。三如是回向时下明回所成德。前中三。初举所成行。二摩诃萨下明长养善根。又前自分后胜进。又前利他后自利行。前中十句。初一句总明得法师位。如第十地受位分得离垢三昧垢染斯尽受职位满内得彼定灌其心首外相显彰故云系顶。法从喻称名离垢缯。但有此缯系其顶者即知。彼人得离垢法受位成满。由得此位方能云雨说法广益群生故云受大法师记。又如楞伽中大慧等十地菩萨得佛手灌顶神力故能自在说法。同于此也。然受职有三。一约喻。如轮王太子受位等。二约理行。如内心证理灌其智顶。其约位事有五重。一约信行满如贤首品说。二约住满如上灌顶住及下海幢比丘顶上佛说法处辨。三约行位如十行满处入因陀罗微细法界等说。四约善巧位如此位说。五约证位如第十地说。此五重内随一成处必具理行。内相应故。又此五中但一位满即因圆究竟更不待余。又若得一即得余位。又总是一法界受职。随门差别五位不同。法体融通含摄无碍。此约圆教宗说。若余教中不通此事。思准之。下九别显法师之德。初一句明法师德立。能广法施者辨慧无竭。成大慈悲者显施心无尽也。安立等者施所成益也。谓令得大心成于大行方是法施故。经云若以小乘化我则堕悭贪。又法施过财百千亿倍乃至不可说分非其比也。丈夫行论(云云)。古德云夫法施者。一则发之以智慧为生解之妙方。二则化之以多人作津济之弘躅。三则为起行之本寔倚仗之良诠。四为入圣之阶标引导之要路故。此经中托人以弘道多嗟法师之胜德。寄行以表法每引普贤为末篇。故知法施为究竟之道智慧为满足之极。自利利他功之不朽其唯法施也。二饶益等者明常施。谓以菩提心生长善根广益众生不休息也。三建师名谓作教授之师示成佛之道。四照之以法日。前师此法故名法师。即所授行法也。五显法师心。谓等心是无偏心。广大心不倒心也。欲令等是常心。六增长等明福惠化增二严。谓善根是福也。七为众生等明导之相采宝所示正路也。八以利他为先修诸行故得为慈悲法师。九化令更事。余诸善友不局于已。是无著法师。如善财知识更示余人令求者是也。下第二明长养善根有六句。一依此法施善摄取佛果心。二彻到彼岸三依法施善修金刚菩提心。四成大愿。五依善友正意求法。六了达果境。是故令前法施更复增广也。行体竟

自下第二正明回向。于中亦二。初以善根成广大回向。后安住法界下成甚深回向。前则众生菩提回向。后则实际回向。前中广大有十五门。初一门以彼善根回向见佛修自他梵行。于中三。初以善根回向同念三世佛菩萨行建奇特想。二得是想故下明依想见佛。三诸佛菩萨下明依佛起行。于中三。初为他修自行二以自化他行。三何以下释他化以顺自。初中有二十句。初十明已成。后十上修。前中初五离染。一总显。二性成。三威仪具。四性离浊。五威仪无垢。下五顺法。一守行心坚。二外缘不坏。三上顺圣心。四下无异求故云无依也。五称理平等故无所有。后十上修中。一不执著名离倒。二不为所拘名无碍。三不取戒相又离戒取。四将护物心名无诤。又不非先制不更造立。五无失可择。六契合相应故云安住。七过二乘。八情专故不动。九不散。十离嗔。皆离染之极。故云梵也。自下自化他行十二句。初一举自例也。修习下别显令他所成。一始修。二行具。三无失。四不执。五照理。六离我。七离惑。八离犯。九犯离无惭。十持心决定。十一不强生恼。下三释成中二。初反释。后顺释。前中何以故者。征问云此中菩萨行已满。何故不但说法化人令修梵行而自修耶。下释若自不修令他修者无有是处。有十句可知。摄论云。若自住邪行设欲正他非是人终不能制正他过失。后何以故下顺释中先征问云既自不修教他不得。若为即得教他修耶。下释中先总释。自如说行离倒能说离倒授人言行相应。故云实语实行。下明净三业离染灭障益。下别释。自行教他五句。一直。二忍。三离疑。四信。五坚法。是轨持法也。善根如是回向结上回也。第二复次下明回向令得诸法。于中十句。一令得法门谓能证法能摧邪论。二悉得三世下令得法海。先总标。于一一下别显十种法海。一生法是立宗相。二方便是因喻等巧成宗法。三语言法是随方语则。四施设是施名于义及随机意乐立义前后次第成等。五文教成范。又安布教则。六由言显义说授仪式。七所说解通曰门。又诸宗法门。八令人开解名入。九宗义分明令解决定。十结宗究竟成义安立名住法。悉得无尽法藏总结所得也。三得无畏法下令得法辩。四得不退下令得法明。五得法界等无量身下令得法身。六得法住。七得法实故云决定法。八学多法。九住行法。十向内证。如是回向下结成果也。第三复次下明二利行圆。初十自行圆谓见法界等无量佛等可知。复作是念下复令众生同已故云如我无异。十一句等显无异也。第四复次下明行称法界亦有十句。初智依理起故亦同性无边。法界庄严众生者有三义。一依此法界众生得成故云庄严。二以众生即同法界令众生即清净也故云庄严。三以众生同在大法界缘起门中摄法界故令众生具德也。第五复次下明见佛解法。于中三。先总。二有十句。见佛成行。三有十句。解法界。初一不随缘变故无生。二不守性故。三不二故。四非是能依。五妄不能染。六非是所缘故离相。七非是能缘故寂静。八满一切处非一切处故云无处。九随流不去染现不集。又舍染不去净现不集。十在诸位中性不改故云不坏。照达法界同名解也。第六复次下令众生成法师。于中令成二十种法师令众生成佛及大菩萨为法师也。二十句中各二。皆先标法师名。后释显义。亦是所作也。以是同类回向故。是法施善根回向令成法师等也。法华法师品中(云云)。大菩萨藏经法师品(云云)。仁王经有十三种法师。谓十二住及佛是也。又于十方界佛灭度后守护受持如来正法广宣流布开化不绝为法师也。如辩积法师及那罗延法师他摩室利法师等。并由其人使佛法再兴久住世间等。此为持正法法师也。觉诸魔事者。如庄严论中有魔诈现神通作罗汉形惑乱诸比丘愚皆归伏有多闻比丘以阿毗达摩石磨之假金遂露即呵啧之余愚人嗔此法师后果方知(云云)。第七摩诃萨下明无分选择行。不选择者是不分别也。又以所作诸事皆称性无失无可简择故云不选。文中十句成法。是所成果法也。余句可知。第八摩诃萨下明成无著大行。中二。先明无著简所不欲。二但欲下明所愿乐为成大行。前中十八句。初十七护烦恼不着世间。后一护二乘不着小果。毒心回向者如沙弥回向作龙等。坏善根回向者回向作魔王等及作大力王灭三宝等此无彼也。二欲成大行中九句。谓成自他普贤大行故回向也。第九摩诃萨如是平等心下明正悕望大行。中有四。初十句明能回之心。二令一切众生下四十二门回向悕欲成自他大行。于中分别缘起得法化生心者。谓由分别彼法生起智心故云从法化生也。此等并是普贤大行也。三明离染。先标。何以故下释成离染。四如是回向时下结回向利益。第十复次下回向令众生得法音语业。初一是总。余三十二音是别。并是佛圆音具德之貌可知。第十一复次下回向众生令得法身中三。初十令得十身行体。二摩诃萨下十令得十身行相。一映无不彻名明净身。二于中普现五道众生体无闇障名离浊身。三因圆果满名究竟身。四净德内充名清净身。五烦恼障尽名离尘身。六所知障尽名离种种尘身。七习气亦灭名离垢身。八常光恒照名光明身。九一一身上各有十莲华藏尘数相好名可乐身。十形充法界色遍十方虚通不障名无碍身。三以如是下明十身胜用。初总。示现众生菩萨行下十句别显用相。下一句结回向所成。第十二复次下明成无边大行。于中初身遍起行为能益之缘。见者不空下正明所成益。一令发心。二不坏心。三广行。四具悲化物。五见佛修善。六安生住法。得法轮闻慧也。法明是思。行菩萨行是修也。七入众生下十一句明照法原故云入。略举十一。实即无尽。是为结回也。第十三复次下回成严土。于中二。初明同体严有二。先同法界。二互相摄得最正觉显已成佛。彰是佛土耳。二彼一一刹下别相严于中有十事严。一宝严。二香。三华。四鬘。五涂香。六末香。七衣。八盖。九幢。十幡。就初宝严中三。先辨能严差别。二复如是念下显所严分齐。三是为下结。初中有百事严内。从初座帐及至乐器有八十三事外法。庄严宝身已下十七事明内法庄严。谓三业六根等。宝趣者意趣也。又是志趣高远矣。余可知。良以依正无碍互严显胜也。初宝严竟。二如宝严下举宝例余九门各有百事。成一千种庄严令准知故云亦复如是也。第十四如是摩诃萨下明结回向大意。于中三。初一句为长养善根。谓由此广大回向力故令善根增长。是故回向。二有一句为严净佛刹故是故回向。三有二十句为令众生清净平等是故回向。此一句是总。下十九是别。为令众生得皆平等二严净德圆备。摩诃萨下结平等结清净可知。第十五摩诃萨复作是念下明令众生证法起说。于中三。初令证法谓得之言证。所证深广名无量法海。二于一一下依证起智。三令众生下明依智起说有十句。一令善教。二令持义。三同果辩。四同佛身。五说法心。六得说智。七遍说处。八无间说。九令乐求。十令喜说。上来众生菩提回向竟

自下第二明实际回向。准下地品安住之言此文当是净治回向行耳。二十八句。初十约三业五阴三科内外。即相同真故回法界。内谓正报外是依报。余十八约行约事会同法界故说回向。上来正回向竟

自下第三大段明回所成益。谓由三业等皆同法界故是故得安住法界等无量清净三业等也。十句中。初六句明平等三业法界摄化。后四句明广大三业。调生安善可知。上来释竟。佛子下结名。上来位行竟

自下第二明位果。谓此位满成四种果。一得普贤行愿成满果。二严净法界佛刹果。三证理圆满成佛果。四普贤广智德用果。初二如文。三具足成就下明第三果。于中三句。一理智深证得佛体。二现身成佛得位。三悉得下十二句明得佛量智自在德可知。四悉得无边满足下明第四果。于中有十句。一得普贤眼。二得普贤耳。三得普贤量智。四得普贤眼净。五得普贤理智。六得普贤语业。七得普贤光。八得普贤速成果。九得普贤令生净。十具足成下得普贤究竟彼岸。上来正说竟。下明说益。谓动地生信。兴供表行文中。初动地。后兴供。供中。先外供。二天身下内供。上来总是一世界中说此大回向法竟。二如此下明十方法界等世界中亦同说此。是故合成一切会也。于中一切四天下者明此世界中百亿四天下也。上来一说一切说总明说分竟

自下第六明证成分。于中先证此界中说。后证十方界。前中二。先来到叹说。二我等下述彼同此。证成竟

第二偈颂中二。先序意可知。后正颂中九十四偈分四。初十四偈颂前行体。一行颂得法师位。余颂法师德。二菩萨法施下六十八偈颂前广大回向。三譬如如如下二偈颂甚深回向。四如是殊胜下十偈结叹显胜。就第二广大回向中显任放辨才说不待次。言辞不断普贤行德无碍自在。于中粗分为八。初八颂前菩萨自行殊胜。二十方一切无量下八偈颂严土摄生行。三一切佛子下四偈颂上得佛自在果。四菩萨能于一念下十二偈明于一切处供一切佛。五无量无边一切诸劫下六偈明于一切时供一切佛。六悉能觉悟一切法界下十五偈明以一切供供一切佛。七安住普贤下十三偈颂摄普贤行悉以回向。八身口诸业下二偈颂上回向所成德。余文可知

问此经上下多说普贤行愿。此品之内说之最广。何故入地竟不涉言。答此约一乘。地约三乘故也。问一乘岂无地上。三乘岂无地前。何不齐显。答理实是齐。但地前显一乘便。地上摄三乘便故作是说。何者是便。谓地前劣位即得普贤显位自在之便故。若于地上胜位得普贤自在相不显。余意下当别辨第五会竟

华严经探玄记卷第八华严经探玄记卷第九(第六会)

        魏国西寺沙门法藏述

    十地品第二十二之一

将释此文四门同前

初释名亦二。先释会名者他化天会约处为名。谓他化作乐具自得受用显非己力。表入地所证真如非由缘造故名也。二品名者。此品名有四种。一别译本名渐备一切智德经。二下文名集一切智智法门品。此二就功能立名。谓十地因行能集生一切佛智德。然十德渐增故云渐备。三更别译一本名十住经四此中名十地。此二约义带数受称。谓十是一周圆数。地是就义约喻为名。谓生成佛智住持故也。余释总别名等下本分中辨

二来意中亦二。先会来意者前是阿含行满。次明入证成果义次第故是故来也。二品来者。前明回比向证。今明回已得证显行不虚故次来也。又前约比位寄显普贤圆满行德。今约证位寄显三乘差别行德。显法次第故次来也。是故前诸位内皆悉广显普贤自在之德。于此地上绝无其名者是此事也。岂可地前深广证地反劣。但是寄显不同故也。问宜应证地是深顺同普德。地前位浅。应顺三乘。何不尔耶。答此中文意为显教相不同故尔。谓若于地上得普贤德则与三乘教便不别。今明若是三乘行位则于地前实不自在。显此一乘则不如是故于彼地前则便自在得普贤德。是故若准此普贤地前而取地上其地上行相甚深。甚深非如此说此即下普贤行品是也。若准此三乘证地行相而取地前其地前行甚极粗浅。不同前说。即是瑜伽菩萨地内十二住中初二是也。问何故不齐。谓一乘地前有普贤德。一乘地上亦有普贤行如普贤行品说。三乘地上德如此品说。三乘地前行文中何不说。答此经宗明一乘故是故一乘行广。论三乘位略辨也。又释以一乘十地甚深故通摄三乘等总为十地。仍以六相陀罗尼门融显无尽成普贤十地自在之义。地前则未能如是。但直显普贤故不同地上也

三宗趣者亦二。先明会宗。谓约人有化主及助化各有体相用并通性起及修生可知。约法有生了因果及差别平等二种因果。亦是修生本有因果亦有教事及义理体相用准前可知。但通性起为异。余义准知。二品宗者。此品约总正以十地证行为宗。别说有十义。一约本唯是果海不可说性。二约所证是离垢真如。三约智谓根本后得等三智。四约断谓离二障种现。五约所修。初地修愿行。二地戒行。三禅行。四道品行。五谛行。六缘生行。七菩提分行。八净土行。九说法行。十受位行。六约修成有四行。谓初地信乐行。二戒行。三定行。四已上总是慧行。慧行中四五六是二乘慧。七地已去是菩萨慧。七约位有二位。谓证位阿含位。是十地之位故也。八约寄乘法。谓初二三地寄世间人天乘。四五六七地寄出世间是三乘。八地已上出出世间是一乘法。故以诸乘为此地法也。九约寄位之行。谓于十地成檀等十度行。十约报现十王事相。余义下当别辨

四释文者亦二。先科简后释文。初科简者今此会中有十一品。问此会与前二三四五会何别耶。答有五别。一前有流此无流。二前末此本。三前不共。谓是普贤德故。此为共。谓此十地通三乘人天等共采故。地论云亦能生成人天道行可知。四前但论因行此会通果故。五前比位此明证位。问此会何故无升天集众等序耶。答为表此会证法无二不可以事相标其玄趣。此则前粗后细故。二为地前摄一乘别教普贤之法故有升天集众表胜方说。地上寄位同于三乘故隐彼自在之相同余经而说。此则前细后粗故也。此文分二。初九品明缘修因果。后二品辨性德因果。初中亦二。先六品显因位德满。后三品明果位德现。就前中亦二。先十地一品显其证位。后五品明位中行用。前中亦二。先长行散说。后偈颂总摄。前中亦二。先明所说十地。后他方菩萨来证此说。前中亦二。先显此界所说十地。后结十方无尽世界所说十地。就前此方所说中。或总为一或分为二或三四五乃至于十或为四十八段言一者谓总是一十地法门也。言二者初正说十地后动地雨华等明感瑞显实。或为三者谓序正流通。此中所辨要唯教证既殊三分亦异。就教三者初至起分是其由序。以起发正说故。二本分已去是其正宗。于中虽后有广有略同说地法判为正宗。三地利益分下辨法力感益判为流通。二就证三者。初一序分判为由序。二三昧分是证。正宗。因入此定正显实证故。地论云此三昧是法体也。三流通之义释有二类。一以己之德流被信地。说为流通。若从此义加分已去皆是流通。以说自所得令信行地菩萨证入地故。二显法利益流及末代。若从此义即地利益分方是流通。今据前义说也。或为四者于正说内自分为二。先是法说显地。后影像分寄喻彰地。教证准前故为四也。或为五者并后结证偈颂怗前为五。或为六者随行以分。初至起分是起化之由为生物信。二本分中略说地法叹其殊胜起众乐欲。三请分之中彰地出言令生正解。四说分中广明修相令物起行。五影像分中寄喻显德。六地利益分中明德成证实感化斯现。故地论云以得法力大地动等。或为七者从初至请即为六分。说分通十。总为第七。或为八者分后地利益分异前故有八也。或九者分影像分为第八。利益分为第九。或十者增其偈颂。此十次第有其三义。一就化相通为起说。二就化意通为显证。三随宗要证教双辨。初起说者。如来将说先记时处现相集众。发起所说以之为序。由序既兴。将为众说时。金刚藏默入三昧显己自证能为众说。又为受加故。次第二明三昧分。由入三昧十方诸佛赞叹与力故。次第三明其加分。既得圣力欲为众说。但定无言说宜从寂起故。次第四明其起分。从定起已略宣地相起后广说故。次第五明其本分。然彼本中略说地名不广分别。大众渴仰闻名欲义。相与启请故。次第六明其请分。众既请已正为广陈故。次第七彰其说分。乃至十地通亦名说。法说难解宜以喻显故。次第八明地影像分。为说既竟宜显法胜益。劝信传通故。次第九明地利益分。既长行散说。宜以偈总摄令易受持故。次第十明于偈颂。二显证者为化之意宗为显证。于中初分显证由序。后九正显证相。九中前三就相显证。次四就说显证。次一就益显证。后一重述证德。前三之中。初三昧分寄入显证。二加分因加以显得证之相。地论云何以故加。由得大乘光明三昧法故。三寄出显寂说必宜起即显所入寂灭离言故。地论云定无言说。是故宜起。次四之中。初本分者略说显证。二请分拂相显寂。说及影像寄相表德。说分寄修表德。地影像分借喻显德。地利益分就所摄化显地利益故。地论云以得法力动地雨华等偈颂可知。三随宗要证教双辨者。初一是其由序。后九正显证教之相。于中初一入三昧显示正证。后八次第明起言显教。同初门辨。又可随地不同分为十也。或为四十八者。初地第十各八分。二地二分。三四与九各四分。五六各三分。七地五分。八地七分故。合为四十八也。问论云初地所摄有八分者如序分等。是十地家序何故论主判入初地收。答地论科文有四例摄。一以后摄前例。以前序等后近初地是故以后初地摄前序等。是以名为初地所摄。而实序等属于十地非唯初也。二以前摄后例。以影像分地利益分前近法云地是故以前摄后法云所摄。而实彼二属于十地非唯法云。三当相分文例。谓非摄前后如中间诸地。或二分三分等皆当相摄也。四显地该收例。谓显十地是陀罗尼法。是故分诸地文改势废兴隐显前却即一一地皆有四十八分也。如序分等。既全属初地所摄。即知亦得属第二地摄。余地例然。余地科文于初总有。如是准知。十种地内总有四百八十分可知二

释文者初地八分文处分齐准论可知。就序分中有三世间。初智正觉。二器世间。三众生世间。或分四。一时。二主。三处。四众。彼论经中为论主别释此品。一部别行。是故取此经初如是我闻致此品首也。又彼中言第二七日者取经初始成正觉之文。今此中无者以经初有故。同是一部故即经初始成则是论经二七。明知华严一部总是第二七日同时说也。若不尔者此品之初何不别安二七之言。岂此品初脱彼文耶。是故当知。有人臆判华严十地已前诸会是初七日说。唯十地品为第二七日说者恐不顺文也。又地论主释初七日但思惟行因缘行自受法乐始未说法。是故名初时及胜处说。故知初七非说。尔时即是二七之时显时胜也。以佛具于三德六义于世独尊。故名世尊。即梵名婆伽婆。义同前释。此主胜也。他化等者显处胜故法胜。有三重胜。一他化天胜简下五天。二在王宫胜余天宫。三摩尼宝殿胜余殿。问欲顶高出表法胜者。色界弥胜何不在彼。答地论云。此处感果故。谓机感在此。是故此说谓感是能感机也。果是如来赴根酬欲之相也。又释表所证真理非自作故寄他化显也。又上二界是难地非修行身故不在彼。修行之身要是欲界。他化最极寄显法胜故在此也。又第七地摄报果位在此天王。寄显十地摄法宽故。何者以第七地是菩萨位故摄上一乘。是出世位故摄下二乘。表此十地通摄五乘故也。又此天宝殿准密严经此他化天摩尼宝是十地菩萨常所游履。又准大乘同性经此处有报佛净土。又准上兜率庄严此殿亦更过彼故与虚空法界等。然表行德证真纯一无杂故以摩尼宝显之耳。是故此天处有五义。一凡处。二七地菩萨处。三十地菩萨处。四佛处。五圆通具前诸处。无障碍故。与大菩萨下显众生世间。于中有五。一简定其人。二叹其人德。三列德者之名。四结名者之数。五标众中上首。初中准论经有四。一简大异小谓别地前。二简住异退谓别于七地已还。三简始异终谓别于十地初心等。故彼云皆一生得阿耨菩提等此文略也。亦可于阿耨等是此终位不退即是简住异退。四简新异旧亦是简主异客。于中诸义并同前释。二叹德中二。先别。后如是下总以菩萨功德不可顿显故先别叹。非别能尽故须总结。前中亦二。先略后广。以菩萨德广难以顿彰故先略叹。非略能周故须广显。前中二。先明自分行满。谓菩萨二智证游真俗名行处。穷尽彼际因位成满名悉自在。后胜进行。谓佛慧入处。是果位所得圆智契如名为入处。明此菩萨以胜进慧亦随得入。故云悉皆得入。前是自分成在己位故云自在。此是胜进仰成才云得入。二善能下广叹中二。先十一句叹自分德。后一切菩萨无作下八句叹胜进德。前中二。初五句明行修具足。后六明德用圆备。前中二。初二句明利他行。一正教轮。二神通轮等者等取记心轮。二具足下三句明自利行。一具愿是起行心。二正起行修行通三际名一切世。各尽多劫名一切劫。此是长时修也。然遍诸刹故云一切国。此是无余修。又前是一切时此是一切处。常修者是无间修。三具足菩萨下明修所成德。谓福智成满故云具足也。二德用圆备中二。初三叹利他胜能。一能饶益者总举所作益相。谓令众生修出离因。二能到等者明穷尽菩萨巧慧之际。显到能化智岸。三能令等者明成所化益相。生死是苦果道是集因涅槃是灭果。门是道因。以了因能显故云门也。后三叹自利德。一行修殊胜谓化他不断自行。二众德圆满禅谓四禅。定谓八定。解脱谓八解脱。三昧谓三三昧。通谓六通。明谓三明慧谓三慧。又此菩萨既并悉是一生补处准下文中十禅定十解脱。谓不思议等十百千等三昧十神通十明十慧皆悉无尽也。三诸所施等者显妙用自在。谓依前通慧所作巧现故云善能示现也。第二胜进中八句。初四明殊胜三业摄修所行。后其身下四叹广大三业备具诸德。前中初叹身业胜。言无作者无功用也。谓无功之大用即是种类俱生无行作意生也。二于一念下叹语业胜。谓摄法上首请转法轮。三受持下叹意业胜。谓持正法大心供也。四常能修下明摄修所行。谓依前三业修起菩萨诸胜行事。二后四之中。初叹广大身业如普贤身遍现诸刹。二其音下叹广大语业。三其心下叹广大意业。四一切菩萨下明备具诸德。上来别叹竟。如是下总结无尽。三列名中。同名藏者谓表地法有含摄众德出生果用故也。故地论云亦能生成人天道行。解脱月一人不名藏者表受法之机清凉器故也。四如是等下结数。依论经此中有第五所从来处。谓种种佛土。此中无者前已云从他方世界来集故此不繁也。五金刚藏为上首者标显会主也。金刚略有二义。一是利义。论云一切烦恼难坏此法能破。二是坚义。论云善根坚实犹如金刚故不异名说下释藏义。何故名金刚藏者。此问意云为藏中有金刚故名金刚藏。为是以金刚为藏故名金刚藏。答云藏即名坚者此显以金刚为藏非是藏中有金刚。其犹树藏者此喻显是坚是藏。谓树心坚密而有生长功能故下合云生成人天道行等是释坚藏也。如孕在藏者此喻能破而是藏。谓子能被胎而出也。力最大者合此喻也。余义如别集十地论疏中释。第二三昧分内六句分别。一释名者。梵语正音名三摩地此云等持义同前释。大智慧者从业用为名。谓此定中发起无漏圣智慧光明能破无明故立此名也。谓此定与智俱。即以如此不散乱无漏智为十地体。又正证名智慧后智名光明。又论经名大乘光明者谓此二无我慧过二乘故名大乘。破无明故名光明。此则过地前也。又此慧能运转诸行令至佛果故名为乘。约功能立名。唯识论第九云。大乘光明定谓此能发照了大乘理教行果智光明故。二体性者。别境五中以无漏慧俱定数为性。又以三法为体。一定。二慧。三真如。是故为无为为性。以具能所证故。三业用者有二。一谓依此定能受诸佛三业加被。二依此定发后得智宣说十地。以是赴机感满佛本愿为其业用。四明种类者。谓此地上诸菩萨等所得三昧虽复多门统论四种。一大乘光明三昧。二集福德王三昧。三贤护三昧。四首楞严三昧。此翻名健行定。谓十地菩萨名为健士。健士所行故名健行。又初二三地得初定。四五六地得第二。七八九地得第三。十地故佛得第四。广释此定如诸本摄论(应捡)。五明入定意者有五意。一受加二审根。三证法。四表深。论云显示此法非思量境界。谓非同地前未证真法但正思量而能有说。此一文中显后二义也。五成仪轨者谓诸圣说法皆先入定如佛将说法华大品皆先入定。岂可如来有不在定。故知说法仪式皆尔。此经诸会为式大同。六释文者。一标入定人是上首故。二明入所依谓仰禀佛力名承佛威神。三正明入定。谓简异果定名菩萨。大智等同前释。问既是菩萨定何故承佛力耶。答有四义。一为推化在佛故现承力。二虽实自得对佛胜人不得自在。纵极小事亦须仰承。以非佛加无一法事而得成故。三虽分证得穷满在佛故承也。四佛既出世泛令弟子有所造作。皆与其力故须承也

第三加分中有三。初总明作加所因。二显加所为。三正辨加相。初中二。先明作加。后举所因。前中二。先现身同名。后同赞显加。前中五句。一处远近。二佛头数皆倍前会可知。三现身令众见以生信心。四同名令主闻以增踊悦。五结十方同。二同赞中四句。一赞其得定。二显己佛数。三彰己名同。四正辨作加。第二释作加所因中三句。一舍那往愿力。二现在威力。此二是缘力亦是果力亦是他力。三汝有等是因力亦是自力。谓自他因缘因果等合方得成此十地之法。第二论释中二。先释前后生后。前中四。一释多佛加可知。二释同名加。于中有四。一征问本愿释。二征愿显多释。谓舍那本愿使多佛同加也。三法通古今释。谓此是同证同说之法故云是法体也。然有二释。一即后十亿尘数诸佛过去亦曾同作加刚藏菩萨受加说此十地法门今成正觉亦在此法门故有说处即能加。是彼佛本愿也。谓此刚藏菩萨当成佛时亦同此事。此释顺论文。二约舍那佛释。谓舍那本行菩萨行时见一舍那佛所能加诸佛同名金刚加说地法。舍那今成正觉。本愿今成故彼能加佛亦名金刚故云不异名也。此释顺经文。以经云舍那本愿故令诸佛加也。如涅槃经云往昔此处有佛名释迦侍者名舍利弗目连有大利益我因此兴愿故今亦同之在此说法是类也。四又是下明同名增踊释可知。三何故不言下释十亿之数三句。一通征显多释。谓若直举无量或容不至十亿尘数。以言总无定故。同下文多百千等。又释前会百万佛刹尘数诸佛此中十亿者以百万为一亿故。是故方便渐次以显多佛。若直言无量则乖方便故不言也。又释此显多佛者以十数为则以显无尽故云多佛。若直无量但得一重无量非是重重无尽。是故十数多于无量也。二何故定言下征定数同释。三此经下为则大同释第四彼佛下释作加四。一先作是愿者释本愿加二今复自加者释现在威神力加。三后余佛加者简后异前。谓此并是舍那力加非是余佛加余佛加在后文处辨。四故言等举经帖也。生起后中何故加说此法者生后所为。谓说此地法故也。复云何加生后加相。以文在后远是故不举。下文对显

第二释加所为中。二十句文依二利分。初十共他自利。后十共自利他。以二利行相融相摄同在地中本后二智之处具足。今以寄显文义差别故分二别。前中论主作四门解释。一总释显本。二依本开末三明会末归本。四显本末无碍。初中总论地法缘起有六义。一一切菩萨是信行地者举所被机。谓地前菩萨未证真如但依信心而起行故。无著般若经论中亦同此名。问若唯地前是所为者。何故下文解脱月叹众请中云此众有五种阿含净四种证净。又下大众请中为十力净心。论释云未入地者令得净心。已入地者令得十力。又约下文转生时益亦通外凡。据此等文即通外凡及地上。何局内凡回向等位。答有二释。一理实是通。诚如所说。但今论主就于教力益强处释。何者谓地上菩萨设不得教亦能自进假教义微。外凡之人设令蒙教未能依教即令入地。教益亦弱。唯信行地得教便进。故异外凡阙教不进故。异地上假教义强故。偏就释。无著论云此位菩萨欲入初地先求教授教诫。是此义也。二如初地加行位既名信行地。即诸地之前俱加行位皆名信行。以摄论中意言无分别观通四位。故知地上亦有也。如外凡远位亦通收彼。然据亲入内位现证故约此辨也。二不思议佛法名出世间道品者此是所得之法。然有二释。一约因谓十地法体是出世间无流之法。心言路绝名不思议。通生佛果故名为道。下云大圣道者是彼因故。十位品类差别名品。又道是智品是檀等行眷属也。二约果谓佛果所得之法。故名佛法。非下位图度名不思议。令地上菩萨分证此法名出世道品。地智所游曰道。分证未圆名品。三明者见智。得证者般若经名悉知悉见。楞伽中圣智圣见圣慧眼及余论眼智明觉等皆此类。创瞩名见委照名智。智照非比故名为得。冥神契合故复名证。初二观解。后二行契。各初始后终可知。四欲宣者。论云。说者于中分别者于此能所证得法中以言分折十位差别明地行优劣巧慧等异故也。五入者信乐。得证者谓地前信乐远有入义。地上得证现成交入。通论入义必从彼至此故具始终也。亦信始乐终。得始证终。六智慧地者谓十地智。如本分中说者谓此证理圣智有生成住持佛果等用名地。始从欢喜终至法云本分中显可知。此上六义融合无碍。通教及义通证及比通境及智通人及法通因及果。混通无碍总为一团。名十地法。若展之于后种种差别皆悉于此总句中出。是故名此为根本入上来总释显本竟。自下第二依本开末分成九句。于中四位。谓愿乐位。见位。修位。究竟位。初四寄在地前愿乐位。次一寄初地。次三寄修位。后一明究竟位。问此中正为说十地法。何故乃说地前及佛果。答为显十地前有起下之功后有成上之义。又释由十地证智。放阿含光。是故地前是此十地阿含分摄。由此地智依果海成故。有佛果上不思佛法及下鸟迹所依空等并是其事。初中初一约闻慧修善根名摄一切。二明思慧之始简择道理。论中智方便者释善分别也。道品释佛法也。三思慧之终谓因思广知。彼彼义释诸法。种种知释广知。四明修慧无疑立教可信故云决定说。谓修通二利今据利他菩萨。化他即是自成佛法故入自利收。论中随所思义是上思慧所思。名字具足是闻慧所持故决定说也。上来显信乐。自下辨得证。五见位智谓由地前加行位终观于唯识无境之义依无间定双印于彼能所取空。彼增上力引起识中本性无流生起大智照遍满法界名为初地入真见道。论中一切法平等智释无分别智。谓于初地正证真如无能所二相故云平等。唯识论中或云有智无境。以真绝相故。或云双泯。以境智相如故。今辨四句。皆得可准知之。见道时中善净者释善净不杂。谓离二我分别随眠。此文善分别者是彼不杂之义。谓烦恼离故名分使永断名善。此无间道中断障之义。又释善净不杂是解脱道中证彼无为清净之义。故云不杂。此善分别者是领证无为之义。又释无分别是根本智。善分别是后得智。胜进道中起行之义。六明修道位中地地别断一无明。故于烦恼障亦永伏离故云世法不染。名不放逸入。魔法是世法也。七明修位中智行转进名地地转入。谓无流善根永离一切三不善法故云清净。无贪等者等取无嗔无痴也。复有善根能为出世间道品因者是诸地中加行善根也。八十地学穷名菩萨尽入。下大尽分中明第十地菩萨入如来十种秘密之智。以秘隐深密难可测知故名不思议。法云契入名得彼智力。如叹净名云诸佛秘藏无不得入此之谓也。九究竟位明因道既圆佛果斯克。穷满果原名佛尽入。论中入智者释得字也

上来第二依本开末竟。自下第三会末归本。言是诸入者牒上九入。为校量等者显其无别之别。谓寄地上乃至佛地校量地智差别次第转胜之相。非谓根本入中亦如此等行布次第决定差别。是故融末归本显无二矣。前依本起末明无别之别。今会末归本明别而无别故也。第四明本末无碍者。谓明六相总别无碍故也。释此六相义作六门。一明教兴意。谓破定执见以显缘起圆融之法。此理现前一切惑障一灭一切灭一切行位一成一切成等。二种类者。不自不他生等四句。及不有不无等四句。并不生等八不十不等。皆悉会事入理。是此流类。但彼等入理以顺一寂。今此入理圆融彼事便相即相入成普贤法。有斯左右耳。三明所出者。此文出在下经第四大愿中。经家自说非是论主率意而作。四明建立者。何故唯六不多不少者。谓泛论缘起法要有三门。一末依于本有起不起。二彼所起末既带于本。是故相望有同有异。三彼带本之末既为本收。是故当体有存有坏。若不具此三不成缘起。三中各二故但唯六。五问答决择者有二。初逆谓非总非别等各各互相形夺诸相皆尽故也。二顺谓亦总亦别等各各顺相成就等思准作之。六释文有五。一约法举数。谓于所说法中有六种相等。二辨定教义。此言说解释者是定教。谓于此中安此六相之言说为欲解释经文。应知此意。又释此中释六相非是此处经文。但是论主解释之意应知。除事谓阴界入等者此辨定其义。谓约道理说融通非是阴等事相中辨故除简之。三列名可知。四释相中。别依本者明依总开别。满彼本者还能成总。谓要依本之别方能满本故也。增相者是前九入渐增之相以显异也。缘成和合略言标显。缘散无作广辨因缘。如世界成坏者举喻以显。谓如百亿四天合成一娑婆界略言标显为成。若分别广说百亿差别。合一娑婆无所依住故为坏。五余一切等者劝于一切处准类知之。第二共自利他中十种始终经本略无始终总句。始者信。欲亲近等者此明求法之初。非信不求非欲不能忍苦求法。由内起信欲是故外能亲近善友。为得法方便也。终者念持。诸地者此明得法不妄忆念所受任持不失。所持是何谓诸地法也。理实此二通在诸地。以下十句皆名始终故。若寄位分始在地前终在地上。同上入中信乐地前得证地上复有阿含及证。如是次第依初相应知者更以一翻释始终义。始配阿含终配证。得如次配释同前应知。故云初相。指前始终相也。阿含正音名阿笈摩。古翻名净教。又译名来。以此言教从无烦恼人边来今译名传。谓此圣言是三世佛之所同说。但古今诸佛相传而说。非新制作故名传。又依此论上下文内阿含及证总有九重。一行教相对。音声言教名为阿含。一切功德说以为证。犹下说中字义二藏是也。二约位地相对。解行已前依教修行名为阿含。初地已上说之为证。犹下解脱月第二请中叹众是也。谓地前起闻思修等名阿含净。初地已上一切行德通名证净。三修成相对。一切地中闻思修报生识智。此等四心缘照之解名曰阿含。真智出言以之为证。故下论言闻思修等是则可说。以可说故名曰阿含地智离文名之为证。四真伪相对。一切地中真伪合修名曰阿含。舍伪契真名之为证。犹下所明义说二大。说大阿含方便修。义大是证行成也。五相实相对。世间修中得彼证相名曰阿含。契本实相名之为证。犹下所说增上妙法光明法门。增上是证。光明是教。六体德相对。就彼离相所成行中无始法性本隐。今显名之为证。依本所成方便行德依教修生名为阿含。犹下文中练金所况金体喻证钏等严具喻于阿含。七体用相对。前体及德相从为证。依此所起随顺世间教智之用名为阿含。犹下文中珠放光等所况法。是珠轮等净喻于证体。光炎等喻于阿含。八自分胜进相对。自分所成体德及用皆名为证。能受佛教称曰阿含。犹下文中叹金刚藏二力是也。妙智及辨名为证力。于佛教法念坚净慧名阿含力。九约诠就实相对。真智之体说以为证即此证体。约言分十名为阿含。犹下文中虚空迹处所况法。是虚空平等喻地证智。故下论云。字身住处证智所摄。空中之迹喻地阿含。故下论云。非无地智名句字身。名句字身是阿含法也。此之九种通上及下。应准知之。此中别辨十句始终中。初三地前思修利物。次一见道。余六修道。此十始终狭于前入。以彼入中前该闻慧后摄佛尽此不同者。理实齐通。但以闻慧及佛非是正地。前已明故不重辨也。一摄始终。谓称思宣法故云实说。实说成德故名为摄。以彼闻慧从他受法师义不便故不论也。二欲始终。是思慧上品增上求心名之为欲。菩萨教化欲令众生契合诸地故云令证一切佛法。此是安住义也。念是其欲。随顺是令证。三行始终。即修慧。于此加行位中正观意言唯识等观名之为行。以非证位是故名为观分时中。于彼地上真无流法作带相观。是故于彼无流道品但能修相观未得无相观也。复依相观说授前机名为分别。摄论现前立少物谓是唯识性等。唯识论带相观心等并此位行也。是意言观故。经中名说。论经名观。其义一也。四证始终。即见道位。大智光明是根本。智。善分别者是后得智。以自严者二智成德。又论经择字是此分别。分别中胜名善分别。胜者法无我故过小名大。治惑曰明。此事中彼时中皆善知者释方便字。是相见道故有此知。论既不显。今作三释。一此事中者是此见道事中也。彼时中者是地前观分时中也。正照于此兼巧知彼名皆善知。以为方便。方便犹是以自严义。二释此事同前。彼时是后修道位中所有行相。以此后智照前达后名皆善知。三此事中者是此后智相见道中。彼时中者是彼本智真见道时中。皆善知者巧具二智用。以自严名为方便。又释以法真见道兼知彼故云皆善知也。五修道始终。谓出世智辨其智体。智力明有入法功能。法是行法。义是义理。是智所入。谓此法义能出生具智名具智门。修道智力能入彼门故云也。后五始终论主寄治五障翻对以释。问此处五障为实为虚。答亦实亦虚。谓有此障者不得此位。得此位者无此障故。是故假对此障翻显治行。即十种释中显发释也。论中先别辨五障。后举经对显。今并通释一一障中各二。先举障名。谓不能以正摧邪。下释障义。已说正义。他言能坏自行失也。眷属离散化他行失故成障也。下举经显治。随彼所著显己正义对治邪执故云随所应住。次第说故此标也。下句释。以得无碍乐说辨才智慧明故。是故能破他也。论经此二合为一句。二不能答难者此列名。前明不能破此明不能立。于问芒然失自利行。设言不信失利他行。下举经显治。谓证得无碍大智地故云具足等也。三于小起恋失于二利不妄大心故以成治。四于生怠化亦乖两利。化物不疲故以成治故云教化成就等。五于化不巧故无方便亦失二益。以五明等一切处法明达巧慧名决定智为能治也。又此五障中。初一不能破他邪宗。二虽能破他而不能立自己正宗三虽能立破而情乐小乘。四虽不乐小乘而懒化他。五虽化不疲而无化他方便。是故至五化行略周。上二十句总明加所为竟。自下第三明其加相。于中有三。谓口意身加。此三加次第有其二门。一约他方佛。先口加者乘前言便劝说。于先说由内智净觉为因。是故次明意加与智。得智堪说事次起定故。后身加摩顶令起。二就舍那佛。先意次身后口。为令得定定由意力。是故居先。身光照烛以增威德云台说偈。口业加教。方能有说。是故此三从微至着成于说耳

就初口加内十句。初句是总。汝当说者令其辨说即是辩才。谓随所得法义忆念不忘说故法门差别。如论应知。泛论方便有三种。一发起方便。谓如加行发起根本即七方便等。二无住方便。谓由悲智巧相导引不住生死及涅槃故如方便度等。三集成方便。谓诸缘起巧相集成如六相方便等。今此当于集成方便故云此善巧等也。下九句别中分二者。谓自他二力以诸缘起法皆有因缘亲疏二力成故。他力中二。一如来神力。二智明加故。经中二句显之也。自力中分四者以因中有四义故。一有力能作义。二无力不作义。三具二义故能引众生。四泯二相故称理成德。又释此四渐次释疑。疑云何故得加。以有因力故。若是有力何须复加。以因不作故。若是不作应无用。以由无作方堪益物。若逐机益物应失自体以身净圆满故。又释初二自利。一教行。二证行。又一相。二体。次一利他。后一二利满故成德。成德中三义内。一当位显益。后二寄对辨胜。初因位穷终故云菩萨尽。位满成益故云有二利益。谓法身真理唯是无分别智正证。依止非是染心意等所取故云也。楞伽云。取相名识。不取名智。理智合成依止义故云法身智身。十地终心受佛职相故云受佛位故。如法云地受位分说。在因位中有此益相此位不改因故云现报利益。谓一切佛放益一切智光入此菩萨顶故云于一切佛得受记。受记即是受位也。二转此因位至成果之处故云后报利益。此是十地菩萨摄报果处。便于此处成报身佛。理实刚藏犹未成。此当必成故结德在身。如下佛尽亦同此辨。摩醯此云大。首罗此云自在。智处有四义。一以下三禅慧多定少令智不胜。四无色中定多慧少智亦不胜。此第四禅定慧等故是故智胜故云智处。二此处五那含。天是圣人所生处。圣人智胜故云智处。三此处有十地菩萨摄报果。彼菩萨摄十度行别成智度故名彼处以为智处。四此处成报身佛得一切智一切种智故名此处以为智处。此是世间中最高胜处。于彼现成佛故云世间高大之身。后二寄对显胜中。初一对下彰出。于彼二乘无少分同故云不同尽。又彼二乘见有世间而超过故。于此世间超而不尽。见有涅槃而可取证。于出世净亦未得尽。今菩萨皆尽彼际故云不同尽。后一望上显同。谓于佛果穷尽彼际故云佛尽。经略此句。谓二力之中自力胜故以多义显上。故云校量转胜上上也。又释此佛尽理实刚藏犹未成就。何故此中辨耶。以为显自力辨胜故此说耳。第二意加中二。初十句正明意加。后十句释偏加所以。何故就意加释者。以意加是本故。又前口加有自他二力。今意加亦尔。初十明他力正加后十明自力堪加。初十句内初句亦总亦别。余九唯别。

问意加与智何故初句明色身胜余九显名身胜。名身是语。此但身语。何关意业。答此有二义。一智慧胜故威仪亦胜故举色身以彰。又欲观其智当观其说故举名身以表示耳。又泛论名身亦通意业。如分五蕴为名色即四蕴名名等。二释但彼诸佛所。与之智略有二种。一与处众无畏之智显之于色身。二与说法无碍之智彰之于语业。是故论中皆名辩才。初中内德不虚名真实。众内莫善加名无上。由众中无上故处之无畏故。论经名无畏身也。名身九内。初二句为一对。谓初一于说无滞。后一于义深达。又初总知无碍。后善入差别。初是四无碍中乐说辨。谓智宣妙辞理无所倚碍故云无著。不为痴碍令言中歇故云不断。此释无障碍。辞无謇涩故云无滞。此释乐说。通释可知。二由照法差别堪正宣说故云堪辩。依相续解脱经有四种成。一以有成因缘名相言说诸法得成。二所作成一切所作各有成辩。三法成一切诸法成立。四助成以智言说助成诸法。今言缘者是彼以有成也。二法者是彼法成也。三作者是彼作成也。四成者是彼助成也。又古德释云。一缘者如山中草木得缘即生不假功力。二法者谓以法而成如有法成易无法成难等。三作者谓加功用力如造舍等。四成者谓内外相假而得成等。今更释。缘是作法之缘。如欲作柱匠斧木缘。作是众缘。扣击造作。法是所作柱法。成是识心了别方成。谓若无识心了别彼所作柱但是无分别法。要待识心以构画为立其名方可说成。是故此成即是不成。故云成不成也。问准此释义及前经文法当第三。何故论中法居第二耶。答谓初举能成之缘。未知此缘是谁缘。故次举法明缘所属。未知此缘如何造作。故次明作。未知作已为成不成。故后明智助成之矣。论约此辨。是故法在第二。又此四释差别。经中名分别。成不成释清净以离相故。三任放等者次二一对。初于说自在。后于机巧化。初任意放纵辩溢圆音故云任放辩才。虽言义超越而辞无停拥故云说不待次言辞不断。异义虽多而终结归本故云处处随意不忘名义。以随门异说不忘本宗故云善忆念不忘意力加。故者释加字也。四能说应机巧宣名能说辩。此列名。下释。随所应度者巧能应机也。种种譬喻巧能说也。后巧能除疑故名能说。以善能机决定无疑故云与善决定之慧五不杂等者次三一对。初一证理。后二起说。理同无异故云不杂。三种同相智。有说。三空门是。有说。所证三无性理是。有说。依金刚仙论说无常苦无我是。有说。助道证道不住道。谓同相三道是。有说。依别翻本自相同相不二相。即世谛真谛一实谛是也。义虽通前依本为胜。照达此三故云至一切处智。六教出等者此二起说。初一说令起行。后一说无怯惧。又初于熟教出。后于生不畏。并可知。八九二种为一对。初知佛教法。后依知而说。知教多门名无量辩。六正见者。古德有说。即总别等六相解释圣教成正见故。有说。依金刚仙论。一真实智正见能知理法。二行正见能知行法。此二教旨。三教正见能知教法。四离二边正见知前理法不同情取。五不思议正见知前行法成德出情。六根欲性正见知前教法说随物心。又相传说。西国别有六正见论一忘想。二忘想依。三亦忘想亦非忘想。四忘非忘依。五非忘想。六非忘想依。初即现行忘想。二即所依染心。三闻等三慧。四净教为依。五证真正智。六真如为依。又初二外凡。次二内凡三贤位。后二地上圣位。九同化者三业齐同成此化事故。又释此三轮化是一切如来同用此化故云同化。又释此中令金刚藏三业俱同如来化事偏名同化。非彼前八而是不同佛无畏身等。等取口意。三种教化总举随所度等释经中起字。珠胜释庄严是上妙也。谓身业神通轮。意业记心轮。口业正教轮。并是神力各成事故云神化故也。自下释加所以中。先征后释。征意云有力者明佛有普加力。有悲者明有普加心。自有普力无普心亦不致疑。自有普心无普力亦不可怪。今明佛有能普加力亦有平等悲。何故唯加刚藏一人。故致问征故云何以故也。下明释意有十句。初一是总得此三昧法。余者不得故。复何故得此三昧者下别显有二因故。一以是菩萨往昔本愿力所致故。二由此菩萨具彼三昧之行德故。故云三昧身摄功德有八种。于中初四自利。后四利他。前中初一是起行之本。即欲乐心故云趣尽地。尽地即是十地满也。彻至终位故云深心。情无异愿故云直心然无二也。余三是行德。一证理行。二是助道行。三不住行。又初一智德。二福德。三断德。由后智所现身增福令成满故云身转净也。虽在后智位。不舍正证故令习气亦不行故云善修本业也。后四利他中。初一利他方便。后三利他行体。一身。二语。三意。初身业神通能生净信故云以决定信力摄取通故。此文会释经论也。以光明是通能生彼信依是生信故说此通故云摄取等也。二语业巧说前后无违故云不坏。能一一字中摄一切字故云总持。三意业正智教授众生不异照理平等一相故云不异。此则离彼执化之慢故云智印善印也。论主又释八德俱成三昧之因。由此而得彼三昧故。八中前四因有二释。一配前四句如次应知。二配后四句从后向前。精进因是离慢。不忘因是陀罗尼。势力因是通净。彼不染因是闻摄净。是故此四因通收八句俱为自利。又后四因配后四句从前次第可知。转法理因者有二。一转深从浅说而不失自深法。如转大乘深理从小乘等说。如论云一真实理门二随转理门。以于总持门中巧转变故。二转真从妄说而亦不失自真法。如在外道位佛法不行处假彼尊言诵持自法。彼执诸法常。菩萨亦云常。而菩萨意以诸法即真如故是常。不同彼计。然与彼语同任持自法亦同。四秘密准可知。如是化者得自利。不忘者此有二义。一以此四句逆为自利顺为利他。是故利他不忘自利。二以此末后句教授于他不碍照理。出显化事故云不忘自利。第三身加摩顶令觉。下论通有四种。一如意通于自身修短得自在故此于内根。二幻通转变外事。器世界等。三法智通照理入法。四圣自在通苦中生乐等。此中不离彼等经略此句。是如意通非余三种故云也。余义同前释

四起分中四义内。初二是本入所为。后二是今出所为。初事讫者审理故仪则故。二得胜力者受加故。三说时至者机熟故。四定无言说者要须言声故余同前释

五本分中作三门。初释名者以略为广本故亦与请为本故。二来意者。因前加起略说地体起后请分。略说地相起后说分。若望以后成前。由请分显深成前地体由说分广宣成前地相。此则本末互成也。三释文者此文有三。初辨六决定为地体。二列十名显地相。三举三世同说明地要胜。初中此六决定既是地体。今作五门释。一释名。二通辨地体。三与地持瑜伽六决定相摄。四分其行相。五释文。初释名有二。先释总名。六是数。决定是义。数义彰名即带数释也。谓圣智证真决择揩定顺理离过复名为善。即地持三决定中证决定也。通论有六义。一约行体决定坚固不退。二望所证决定己证。三约烦恼决定能断。四约所信决定不疑。五约所化决定能度。六望佛果决定能成。二列名者。一观相善决定。谓彼正智照理名观。契同一味名相。此当体得名。二真实者则实智离倒惑之过。证理不虚故相形立名。三胜者过劣故具胜德故。亦当相及形他立名。四因者诸能成果故从功能立名。五大者普被群生情无限局。体用得名。六不怯弱者谓因入果德情无怯惧。此从心境立名。第二因此通论十地体性差别略作十门。一以此六决定为体。以此正是所说十地之本体故。二以前大乘光明三昧为性。以此定中具含止观证法无碍故。论云此三昧是法体故也。三以教证二行为性。以加行缘修唯是教行。本智契理唯是证行。后智具含二义通教证。如下论说。四以证助不住三道为体。亦通释可知。五唯约所证真如为性。以能证智缘成相尽同真理故。梁摄论云出离真如为十地体。下文鸟迹同空等是也。六唯约能证之智为性。无性摄论云法无我智分位名地。此论下文亦云上来所说皆依智地。今此亦依智地故也。七具含境智。谓真理妙智如前二说。梁论后文亦云如如及智为性。八约通收。唯识论云总摄一切有为无为功德为性。九约因果。如下文大海十相别喻十地总一大海以喻佛地。又云地有二分。则所画太空以况果分能画十相以喻因分。是故通能所依俱是地体。十通约诸门。谓信等十行为成地法故。檀等十亦尔。又三渐次等诸门并如下辨。悉为地法体。第三与地持瑜伽六决定相摄者。地持云决定相有六。一能自修习起菩提愿超余一切净愿。二者无等不共果超余一切世间境界。三者随度诸众生苦不共一切声闻缘觉。四者发一念愿性自然乐无量净法及无厌行。五者得无尽常不退转。六者增长胜分究竟大菩提。是真实愿。解云此中第三是地论中第五。以地持意摄二利方为因故。余相会释可知。四分行相者。此六中。前五是自分行。后一是胜进行。前中初四自利行。后一利他行。前中初三明行体德。后一显行功能。谓有成果之功故也。前中初二行体圆。后一行德备。前中初一明行自体。后一显行离过。是故自体离过摄德为因。二利行圆成就佛果也。此行相也

五释文中。若不自说者前虽入定受加众人不知出定为为说法为为余事。是故自说显为说法令众请法。设令众知为说法事然复不知欲说何法。故亦不知所请分齐。是故自说十地名体叹胜令请。初句此总。菩萨愿者标人别法。于大菩提立誓趣求名发菩提心。亦则是愿。故会释显同。简地前愿故云决定。决定则是证智真实。是故决定则是善。善即是决定。故云善决定者则是决定。别中六内。一正智真证不同带相观心。以不杂无明之过故名一味相也。二以超出世间可坏之法故名真实。真实故非世智所见。三明此智同彼所证法界具胜德。论中二释。一案文释。谓大法界故名胜。此释经中大字也。一切佛根本故名胜。此释经中广字。法界字后别释。二开义释。先标四名显法体无异。但随法相说此四义即为四别。一释大谓一切法是法也。法尔是界也。界是真性故云法尔。下皆准此。二释胜谓净法界智超过凡小。三释广谓大乘法界广集大行。四释高谓无流白法高出世表。又释初显所如法界。谓论中名胜。经名大。广及高皆是异名无别体性。此并显法之体状。释法字也。一切法法尔者释界字也。余三释能如法界之地智。一正体智。二加行智。三后得智。又古德云。一证道。二不住道。三助道。又释初一正证智。后二是后得智。后得智中。一巧集大行以成利他二反缘观内以成自利。此三皆悉称同真性故云如法界也。四为因义。一为生因生菩提有为果。二为了因了涅槃无为果。又释此一真智有二功力。一为依因以依起应机报化用故。二为摄因以摄用归真故。又初则应机示有亏盈。后则相续尽穷未来际。又初则外起化用。后则内证真性。又初则寂而常用。后则用而常寂。经中略无常果因。五大悲益物普周生界故云遍覆亦名大也。次前善决定是前常果因。此愿者是此大善相导故。大善不住涅槃。常因不住世间。故云世间涅槃非一向住也。六上入佛境故云不怯。文中三。初为一切佛护者标也。何以故者征啧也。下释。谓入三世佛智地故为之护也。此六中六相圆摄可知。地体竟。第二地相中四。初寄问发起。二举数叹胜。谓此地法以能生成佛智住持故三世诸佛同证同说。是故今此亦同彼说。三依数列名。四结名显胜。就列名中且依地论略释别名。余论释名。及十障等义并如下广释中辨故论云成就无上自利利他行。初证圣处多生叹喜故名欢喜地。解有三义。一二利创成故。二真理初证故。三圣位新得故。遂本期心故生欢喜。二离能起误心犯戒烦恼垢清净戒具足故名离垢地。此亦有三义。一离烦恼即因离。谓能起误心等。二离恶业即果行离。谓犯戒等。三对治离。谓清净戒具足也。此中误犯尚离故即亡言。三随闻思修等照法显现故名明地。此亦有三义。一以此地得四地智慧光明相故如明得定等故。下论云彼无行无生慧此名光明。依是光明故名明地。二依此地禅发起后地慧光明故如大乘光明三昧等。余论名发光地故。地持云三昧照明故名明地。地论云三昧地故定慧合说。三得三慧照法故名明地。此约当地加行等释。地论唯就此门释。四不忘烦恼薪智火能烧故名焰地。此有二义。一内证之智焚烧惑薪故名为焰。即前地闻持名为不忘。恃此起慢名为烦恼。为是所烧从喻名薪。则是解法慢障。能烧之智。就喻名焰。问前后诸地岂不烧惑。何故独此称焰。释有二义。一就寄位言此地寄当出世间无流故。二以三学寄此地当慧初得故也。二就后智起用故。下论云彼证智法明摩尼宝光中放阿含光明。入无量法门义光明智处普照示现。以此义故此地释名为焰。五得出世间智方便善巧能度难度故名难胜地。此亦二义。一得出世等释胜义。能度等释难义。又对前三地得出世难故。下论云十平等甚难得故。故云得出世间智也。二对前四地能随世间难故。下论言又现世间最难得故。故云方便善巧也。即下五地中十平等心及谛观等是初义也。慈悲利生及五明处等是后义也。此二相违难以相到。于此地中能令相到故以为难。故云能度难度。度犹到也。后诸地亦有此义何独此耶。释以初得在此是故得名。六般若波罗蜜有间大智现前故名现前地。此有二义。一对后彰劣。谓证空实慧名为般若。七地已上念念常现。今此未能故名有间。二对前显胜即前般若名为大智。此智现故名为现前。此地就后义立名。若前义应名有间地。七善修无相行功用究竟能过世间二乘出世间道故名远行地。此亦二义。一此位之中善修行离有相现无相行故云善修无相行。此释行字也。二功用究竟等释远也。于中有三义。一有功用行位至穷满最为后边故云究竟。二望前三地随有之行相同世间。今此望彼己为悬远故云能过世间也。三望四五六地修习道品谛观缘起相同二乘出世间位。今此过彼故云能过二乘出世间道。故名远行地。八报行纯熟无相无间故云不动地。此亦二义。一报行纯熟故不为功用所动。以由修起名为报行成熟。在此无功任运成诸胜行故云纯熟。下经释名中名无功用地善起先导也。无相者不为相所动也。无间者以无相观恒现前故不为烦恼所动也。下经释名为加行地他不动故。九无碍力说法成就利他行故名善慧地。此亦二义。一得四十无碍辩名无碍力。此释慧。二巧说益生名说法成利他等。此释善。此义如下文当辨。十得大法身具足自在故名法云地。此亦二义。一为法器之身名曰法身。然能普周法界故名为大。能受诸佛云雨说法名具足自在。二为出法之身名曰法身。普遍一切名之为大。能降注法雨灭尘生善故云自在。下释名分中具广分释。故名法云地。此十地得名有四对。一约法喻者或唯就法立名如欢喜等。或唯约喻如焰地。或法喻合目如法云地。二约体用者如欢喜善慧约体立名。所余就用为目。三约无他自义者如离垢不动约无他立名。所余约自义为称。四约当位相形者如难胜远行相形为号。所余约当位立名。四是十地下结名叹胜可知。第三我不见下彰地要胜释显诸佛同说所由。于中二。初我不见等者明尽十方虚空法界诸佛世界无有一世界不说如是十地法门。是知若有不说此法之处彼非佛土。二何以故下释成。先征啧云诸佛差别。何故同说此十地耶。释中有四句。初最上妙道是其证行。以是诸佛同所证入离此更无是故同叹。二最上明净是阿含行。以是诸佛同所修行离此亦无是故同说。三所谓分别下显前阿含行相差别。四是事不思下显前证行玄妙难测。上来三段总本分竟

第六请分中作四门。一释名者重法殷勤启请令说故以为名。二来意者有四意。一为令大众敬重法故。二为起说由故。三因请显地法甚深离言相故。四令众既解地法超情后闻说分寄法之说不随声取离错谬故。是故若无请分则后说分不得说故。若无请分则众闻说分不正解故。三明请分分齐者有七。一约起说然有二种。一就菩萨请。谓彼刚藏欲说地法。众若不请不显法重则不说故。要赖众请方得起说。二约佛请然有三义。一就佛请。谓彼刚藏欲说地法诸佛不请不显法重不得令众尊敬摄受。徒说无益。是故要待佛请方说。二就佛加。谓刚藏欲说地法惧有不堪不得宣说侍佛放光加被听众令其堪闻方得宣说。三就佛教。谓彼刚藏欲为众说惧众不信默住不说。待佛教已方乃宣说。大众知是如来所教言虽寄传金刚藏口皆是佛教语必可信方得说也。二约正助。谓解脱月一人是正请。佛及众人是助请。谓解脱月是众上首知众有疑为之启请。请中云此众堪闻。若此大众不自彰德显示同请。则解脱月言便成虚谬。令金刚藏何由得说。故须大众显已堪闻助成彼请。又解脱月请中云诸佛力加。令人信解。若佛不加解脱月之言复是虚妄。令金刚藏何由得说。故佛加请。三约因果。谓菩萨四请为显地法。是诸菩萨所学法故。如来加请为彰此法诸佛所证既佛菩萨同依此法故。显要胜令人敬重故方说也。四约说仪。谓解脱月睹默腾疑为众先请。一人之感未若多人故。次第二明大众请。同类启请率感犹渐故次第三明佛加请。五约显法。谓不请自说不显法重故。解脱月为法先请。一人之请显法不胜故。次第二大众同请。菩萨学人显法未极故。次第三诸佛加请。六约仪式有二。先明解脱月。何故三请。释有二义。一诸经请法不过三故。多即繁广少则不愍至故。随一化仪去广去略故唯三耳。二酬请。至三更不酬故。如下说之二何故大众及佛唯一请耶。释是助请故。显前所请令圆满故。故不至三也。七约所叹。谓诸经中请不过叹人叹法。叹人之中不过说听。说听无过叹法。有益方乃说故。三请之中。前二叹人。后一叹法。众及佛请亦同人法

第四释文者。于中有二。先明刚藏说已默住明菩萨及佛正兴五请。二尔时金刚藏观察下明请既满足示说分齐令众正知。就前中随人分三。一解脱月请。二大众请。三佛加请。初中三请即为三对。皆初说者默违。后明启请。第一对中。初说已默住。后解脱月腾众疑请。谓仁者堪说。大众堪闻。何故不说。此名怪默请。第二对中。初刚藏显已默意。谓法难说证信难得故我不说。后解脱月叹众重请。谓既云证信难得。今此菩萨众有证有信。仁者宜说。此名叹机请。第三对中。初刚藏举损以违。谓此众虽净余乐小者闻生疑惑故我不说。后解脱月叹法重请。谓诸佛护念令人易信。勿虑余疑。此名叹法请。其解脱月请义有余。金刚藏违请理尽。但为重法默待余请不即为说。初对中二。先刚藏默住。二尔时下明因启请。前中二句。一初说地名已牒前起后。二默不分别正待后请。论云何故默然住者问也。谓前不请自说。今何故默住。下对释之通论默意略有五种。一欲令大众渴仰请法。二为令诸佛同请显法尊重增众尊敬。三为使诸佛加被听者于说能受。四欲令诸佛教说令物生信。五欲因默令请显地法寂灭离言绝相。今此论中唯就初二义释可知。二就请中二。初明大众生欲生疑。后时大菩萨下明解脱月为众正请。前中二句。初明闻名欲义。对前说十地名已。二各作是念下睹默生疑对前默住不复分别于中何因何缘者是疑怪之辞也。是金刚藏说已默住者便所疑事也。何因何缘通释。是一。盖是世人疑怪之常辞。于中分别何因对彼说者生疑。谓金刚藏不能说耶。何缘对彼听者生疑。谓我等大众不堪闻耶。二明解脱月正请中二。先举解脱月领众疑念。二偈显请辞。前中论云何故解脱月先请者。征问记发向前大众同疑。何故解脱月专辄独请。下释以此是众中上首故泛是众首皆须为众作所应作。余问即乱者余非上首。非众率伏故成乱也。故别本云余者成乱。为调伏众故今显解脱请令众调伏。今为调众不为乱众是故唯令解脱月请。二偈颂辞者。颂有二种。一言巧故少字摄多义也。二言美故诸赞叹者多以偈颂。故又凡作文具二事名巧。一有理即初少字等是也。二文美即后赞等是也。五偈中作二门释。一征请分别。谓征者征其默意拂遣众疑。请者请彼令说遂众心欲。初二颂征其默意故云何故也。后三颂请彼令说故云愿为分别说也。二就所叹说听分别。谓初一颂叹说者堪说为遣大众何因之疑。后四颂叹众堪闻为遣大众何缘之疑。是故论云此五偈示说者听者无诸过。故若有过者则不应说。此总释也。谓反举有过可不应说。今既无过正应可说。次别显无过。谓净觉无过是初偈也。同法决定是第二偈也。同法者简异生众也。异末后二偈也。决定者明有根器。异第三偈也。有乐闻者是第三偈明同法众有乐欲也。复示余者净心者是第四偈。明异生众名为余者。又显此众皆堪闻法者。是第五偈。通结二众无不堪闻故。别本云又显此众无一人不堪闻故。迭共相瞻住者举偈显成皆堪闻也。就初偈叹说者中。经偈慧字当是论中觉字。圣德无量。何故唯叹净觉。以意在请法偏叹说因是口言。行者行是因义。由觉起言故名觉观为口言行。问八地已上乃至诸佛皆言不待思。何故此中金刚藏是第十地菩萨而有寻伺言说所因。释有三义。一示现为彼说法仪故无过。二既是净觉即是无功用之念智是亦无过。三如八圣道中正思惟通于佛地故亦同此应知。下别释为二。初摄对治者明能治之行现前令所治障不起。二离诸过者明粗过久离正行光洁。所治障中。一凡夫语起所因之觉与常等四倒而和杂故名为杂觉。二二乘发言所因之觉与自性等八种妄想不相舍离。与前杂觉为所依因名杂觉因。不见法空妄取染净名忆想分别。此辨其相也。念智二治如论可知。三过者初悭嫉不说。二虽不悭嫉懒堕不说。三虽不悭不懒说不巧妙令人不乐。初中悭者惜自所知故云其心吝法嫉者妒他过已故云忌他胜智。不嗔等者等取不贪以不嗔离妒不贪离悭故也。不痴属前念智故此不取。此经中略无功德具。然义亦不少。谓此刚藏既于本分说诸菩萨十地名。已明于三过无不皆离。第二后四偈叹听者中分三。初二偈叹同生众。次一偈叹异生众。末后一偈总叹二众。初中二偈。初一叹根。后一叹欲。根是宿习。欲是现起。若单有欲无根虽闻不解。有根无欲设闻不受故须并叹。又释前偈述前大众睹默生疑。后偈述前大众闻名欲义可知。就初偈中今诸大菩萨等者论中名决定。决定者黠慧明了故者。决定是根根体是智。智中知教称黠。入证名慧。此二无闇故曰明了。下别辨中。一以是上求菩提之根器如经菩萨故。二积行既久名称远闻如经大故。三根器堪闻令说者摄受如经说是名故。次偈明有欲中。论云有阿含决定等者料简根欲也。谓有唯阿含决定无证决定不可为说。有非显前决定无现前决定者。阿含及证二决定约是根非欲故云非现前。虽有此根若无现前欲乐亦不得为说。故云无现前决定。如是根欲有阙不能听法结成也。大智有二。谓证法者明此同法众具根本智。先已证法。二现受者明具后得智堪能现受证教法也。此二明有非现前决定也。咸皆欲闻者明有现前决定欲乐心也。次颂辨异法众中直云菩萨不云大。故清净者离六浊故。一不欲浊者无心餐采。二威仪浊者形不恭肃。三盖浊者五盖覆心。四异想浊者妒胜望人破坏约法。五不足功德浊者多病等障。六痴浊者愚闇无解。下明对治。无瑕者离初二浊。一内无不欲闻之瑕。二外无威仪不严之瑕。无秽者是净义。离于盖浊以五盖秽染心故。安住坚实中者离异想浊。以于所说法修行坚固不杂余想故也。具足功德者离不足功德浊。具足智者离痴浊。于此六中随相往分初二及第四约欲。余就根可知。末后一颂总叹二众求法纯至。论中二众相瞻。经中瞻仰法主。有何义耶。迭互相瞻显齐心求法情无乖异。瞻仰法主明注想专求心无杂染。自有求法而怀妒慢。是故初言皆以恭敬心也。齐心趣证如蜂欲就蜜。专意求教如渴思甘露。经中略无初喻。初请竟

第二对中二。先金刚藏乘前启请显已默意。后解脱月因言重请。前中亦二。先序意。后偈颂。序意中。欲令众悦者是总酬答相。谓前大众见默不说。生疑生欲以恼其心。解脱为请。今此说偈。为遣彼恼令生喜悦故云也。颂中六偈别显令喜之相。初有二颂明法难说。次有二颂显法难闻。次有一颂喻难说闻。末后一颂举难结默。以直云难说不言自身无智不能说。去前大众何因之疑故令生喜。亦直云难闻不云此众不堪得闻。故去大众何缘之疑令生悦喜。于论中名大智。故无所畏故。离不堪答离不正答也。就二偈中。初偈显难说之法。后彰难说之义。又释初正显难说。后辨难说所以。初中菩萨所行者是出世间智故谓证智也。此是难法之体。言第一难思者显其难相。谓体出名相说为最难。在相无所名未曾有。又此一偈内。初句明证行。次句辨难相。次句分别十地显教行。后句诸佛根本彰此证教二行。是出生佛果之处故为根本。由约证行最难故难证也。约教行未曾有难故难信也。佛者觉佛智故者谓觉悟佛果之智方名佛也。第二颂释难所以。论中先生起内。彼菩萨行事义住不可如是说者。行者彼前菩萨所行也。事者彼前地事分别也。此行与事即理而成名为义住。并超言表故云不可如是说也。此偈中所以难者以非四心所能知故。一以微故非闻慧境。二思慧非粗。此应可得以难见故非彼境也。三修慧行心。此应可得以离念故非彼境也。经中略此句。亦可同于非心及中摄矣。论中名世间修者为简地上但取地前故也。四既非地前所知地上报生之智亦非地前应得彼法。以彼但是从因所生变易等报异熟心识非是照实之智故非境也。故论云心境界者是心地也。故云非心所及也。下云心地者随心。所受报又随心。所行境亦名心地。既非四心是谁境耶。唯智境故。是何智境耶。唯根本智。以彼见实义故。何故非余境。以是无漏故。经中佛字是论中无流也。如是甚深者结上离四心也。如是可解者结上从智慧出也。以是智慧照现故名为出。如是不可说者结上无流。是出世佛境故。闻则迷没者谓执言取法迷覆真理故云名迷没。论中随闻取著者解闷也。谓没在言中故。闻者即闻非是不闻者解迷也。谓随言取实名为则闻不知地法寂灭离言名非不闻。释难说竟。持心下二偈明难闻。于中持听法之心。坚如金刚。此为总句。信坚证坚为别。若无坚信于他分法不能受故。若无坚证于自分法不能入故。是故要具此二方堪听法。如智论中无信即不受无慧即不解信慧具故方能入法。亦同此也。先释坚信谓深信佛智慧者。论云唯佛所知非我境者仰推如来自更无知故显信深也。胜鬘经有三种正智中。初仰推智亦同此也。佛菩提下彰深而信也。明佛果德等同法界分量斯绝故云佛菩提无边也。显佛自德无边。又为众生机感万差佛为说法有秘密显了诸乘差别。前后相违。极无限齐故云佛化众生所说法门种种也。此明外化无边。于此二处自己不知而能信受故云信故也。以为第一妙者以此所信为第一。为微妙尊所信也。心无疑难者显难信处而能信也。后偈辨证坚。论中何者心地问所证法。云何无我智问能证智。随心下答所证法随心所受三界中报者明五根身也。又随心所行一切境者明六尘境也。如此内外根境皆是心识所依故名心地也。无我智者下答能证智。通而论之内外法中皆具二无我。寄别言之。于内身得我空。于外境得法空。经中离计我者约内报明我空也。及离心所行地者约外境明法空也。如是菩萨者具此二坚方乃堪闻。则显此法只是难闻非是不可闻。寂灭下一偈辨第三喻难说闻中。作二门释。一随经。二会论经。中画空者如虚空不可彩色所画。此寂灭智。非名句所诠。如执疾风者如疾风不可执捉。此无流智。非音声能说故云说甚难也。二会论显意中亦二。先显意后释文。显意云何。此中二喻事有三重。一太空喻以所依平等果分。二画风喻以能诠言说之教。三画风住处喻以所说十地因分。然此三义有其四句。一如空虽平等约风画游履非无住处。虽有住处以空为体故离相难见。此则约风画而不无就太空而不有。然此不无即是不有。故难说难见也。此约十地因分辨耳。二就平等果分亦离有无。谓如虚空体净故不无。随风画有住处故不有也。然此不无即是不有。故不可见。三约风画动作故不无。不能自现相故不有。然此不无即是不有。故亦不可见。四混前三句。谓净空不有即是风画及处不无故。无说无示不异说示风画及处不有即是净空不无故。虽如幻说亦则是无说无示。问此与下鸟迹何别。答此中文意。以言即不言之教示彼有即不有之义。是故难说难闻况之于说。下文鸟迹处直辨所诠十地不可宣示。况之于证。有此不同也。二释文者。此论释中有三。先解喻。二如是佛智下解合。三画者重合前中喻。内有四重三句。一约画。二约风。三双辨。四合喻。初画中三句者。一如空中画色是初句。总举喻相。明动笔之画。二如壁是第二句。别辨画处。明其不无以空中画处有相难明故更转喻壁上显示。谓彼空中画处不无如壁上画处相似。三是中不住故不可见。是第三句别明不有以彼空画不得停住故不可见也。二约风。三者如空中风是初句。如树叶是第二句。是中不住等为第三句。义同画释。三双辨三者。一此动作者是初总句。动是风作是画也。二非不空中有此二事者是第二句。是双显不无。谓于空中非无风画二种处事也。三如是虚空处事不可说处者是第三句。双显不有。谓此二处事空为体故不可分别此是画处此是风处此是高处此是下处。故云不可说处也。前云不可见此云不可说。约听约说也。四合法三句者。一是画风如说者合初句。谓说中具有声名等故两喻同合说也。二以非自性下超合第三句不有之义。离相难见也。谓所说十地不同能诠故不可见。然出三因。一以风画处自性无故同于虚空故不可见。二何者非性。以不能自住故。三云何不住。以是客故。谓风画处望于虚空非本有故是客也。由是客故不住不住故无性。无性故不可见。地法况之可知。三非不于中有此言说者是却合第二句。问此明所释地法不无。何故乃云非不有言。答十地差别由言分异旨从诠目故云言说。由彼空中风画不无故说有彼风画之处。此中亦尔可知。二显所喻胜妙中。如是佛智者是十地智。即是经中寂灭无流智也。如是地智之言说谓无说之说等。由此显示校量地法出过言议故云胜也。三明立二喻之意者。于中先画合名等。次风合音声。后以说听要藉此二故须二喻。谓若无音声耳识不闻。若无名等意识不解。如是可说者牒前以二事说也。如是可闻者牒前以二事闻也。如是难见者牒前显示地校量胜分别难见也。何故不说者生后偈也。谓如上说只言难见非难说闻。何故不说。后举偈答以证信难得故我不说。难证者解第二句。难信解第三句。此偈下解第四句。默然之义如论可知

华严经探玄记卷第九华严经探玄记卷第十(是尽初地说分)

        魏国西寺沙门法藏述

自下解脱月第二请中二。先长行。后偈颂。前中三。初总告请。二是大菩萨下叹众正请。后是故下结请。就正请中十句。初直心清净者是总句。谓正念深法云直心。离诸杂秽故云清净。下九句别。前五是阿含净。后四是证净。谓顺教修行名阿含净。证理起行名为证净。又地前所行名阿含净。地上所成名为证净。阿含五中。初欲净随所念阿含者是所求法非一故名随所也。得方便等者是能求心。经名善修菩萨道者念所闻法顺教修行也。二是论中第四生得净。谓出世胜报名上上生。地前起于助道之行愿得彼生名为念胜故云善集助道法。三是求净以身口恭敬求法行故名敬行。以此随顺诸佛求法名为随顺故。云善能恭敬供养诸佛。四受持中先释受。于无量世者闻来久也。多闻者所闻广也。下释持。忆持者非全忘失。言不谬者非少错误如经于无量佛多种善根者亲近多佛种闻持正法善根也。五行净中为求地上真证法故习行少欲头陀离着之行。积集成就多功德故方能入地。故云成就无量深厚功德。下明证净有四。一得净者谓初地证实名得。以初见道真智现观决择正证故云现智善决定故。又释法显于心名为现智。心安于法名为决定。经中离痴是现智也。离疑悔是善决定。二不行净于修道位中灭彼一切大小烦恼令永不行故云无有贪等。然见道位中非不断惑见理义增。修道位重观真理除障义增故偏说也。三无厌足净中。对下彰出名不乐小乘。望上显入名得上胜悕望。重释中复念持彼功德故者谓念彼佛果功德忆持不忘。释经中安住也。又念彼能对治功德常现前故。四不随他教净谓位在究竟道中名趣尽道。以菩萨道极名之为尽。所证自心开觉显示名自正行。故云不随他教也

自下第三结请。于中二句。初请承佛力说。后叹众能证知。就第二颂中。初颂举法请。上半举法愿说。下半明说有益。后颂叹众请。上半颂阿含净。下半颂证净可知

第三请中三。初明金刚藏举损以违。后明解脱月叹益重请。前中二。先长行。后偈颂。前中二。先领前所叹举德兼失故云虽也。二其余乐小下举损以违。此中三句。一败善之损。二是人下失乐之损。又可前成苦因后得苦果。三我愍下结其默意又指彼余处。后时小众为余。非是会中有此小众。又是地前不定种性。不能一向修菩萨道故云乐小也。论释中三句内。先释默意。谓不见乐小众生有此法器。法器无故闻增疑惑。二释初句。于中疑妨正行。心迷义者惑障解也。次显过失。谓以有疑故败先所修名坏善法。以有惑故一向不行名远善法。如是下释第二句。以疑故于正行不受。以惑故于退行而受。以此为因故感彼生死。长夜流转无乐故衰也。有苦故恼也。二颂中二。初一颂半颂前领所叹。谓随阿含信坚若须弥。定心证理不乱如海。后一颂半颂前举损以违中。初四句颂败善损。经云取相名识不取相名智。又分别名识。随言取义故不分别名智。深解离言法故。次句颂衰恼等。后一句颂默意可知。第二解脱月请中二。谓长行与颂。前中亦二。先正请后结请。前中有三。初愿承力等总相劝说。翻前默意。二佛所护念下明佛力加护令人信解翻前疑惑。三一切菩萨下明地法要胜说必多益。翻前衰恼。初中劝承力说者为明大众承力堪闻故。善分别者令顺理说故。不思法者明此地法纵因谤得闻犹获利益故难思也。第二文中二。初标后释。标中明此地法虽不思议佛力加护必令易信。释中所以名此地法以为佛护念事。释十方世界中但说十地。十方诸佛法尔护念如上加分等。第三文中有四。初立宗。谓一切菩萨护持如是十地事故勤行精进。如下他方证成等。二出因。云何故菩萨同护此法。以是菩萨最上所行者。上是首义。首是初义。论经名为最初所行。是阿含行故。得至一切佛法故者是证得行故。三举喻中。初章者是悉昙章中初恶阿等十二音。或加唎离等为十四音则字缘也。及迦佉等三十六字为界也。以音加字转成一切诸名句文等故。故云初章为本。然此所成一切诸字皆即不离本初章故。故云皆初章所摄。四如是下合结。谓十地合初章也。一切佛法合一切字也。上来请竟。二是故下结请可知。论中何故复重请者。前已重请今此更重故名复重也。疑惑有二。一不定者则可避二定者不可避。此约定为言故云不可避也。不说多过者略有四过。一不定疑惑众生不得转之以成信解。二已成信解者不得成就阿含行故。三已得成就阿含行者不得入证故。四得入证者不得佛法故。有斯四失故云多过也。不成一切佛法者是上四种皆不成故也。下释疑中。先问诸佛有力能令生信。何故犹起谤意。此依前不可避为问。下释中以诸众生有二种定故不可避也。曾已造作决定之业受报必然名感报定。宿罪熏心令必造恶名作业定。纵佛自在于彼二定欲差阙其缘使不成就。终亦不可摄。论云嘶字师子形相者梵本嘶字似师子蹲踞故也。余义可知。颂中初一颂半颂前初段总劝说文。于中。初二句叹说者。次四句颂前善分别不思法等。谓十地行是行也。所入十地法是所入位也。又地行是加行智。地法是根本智也。又地行是施戒等智。所入地法是遍满等十地法界。又初阿含行。后入证法下二句因圆得果。所有十方下颂前第二文诸佛法应护念等。后之二颂颂前第三文。于中有法喻合。法中初二句颂最上所行阿含行。次二句颂得其佛法证得行。余文可知。解脱月请竟。第二大众同请中。先长行后颂。颂中五颂半分二。初四颂半叹人请。后一叹法请。前中二。初二叹说者请。余叹听者请前中初五句叹金刚藏具证德阿含德。后三句叹金刚藏能令听者入证入阿含。前中初四句叹证力辩才成就。后一句叹阿含力辩才成就以此二力方能有说故偏赞也。故论云以证力等是故赞叹。初中上者此总。总有二义。一宽谓该二力显俱上故。论云上者是总也。二狭谓唯就证力以显胜故。论云又复上者显证力等。妙智慧者是真实智则正体智也。乐说无有量者是后得智。与说法为本故云体性也。德重如山王者显上二智尊重之相。哀愍说十地者是彼后智对缘巧说故云果也。此三皆依前起后可知。字义有二。一诠表义。二庄严文辞义。论云字义成就者是初义也。释彼经中真实义相应。复是滑利等者是后义。释彼经中美妙言也。谓言辞。流泽名为滑利。言辞巧妙故曰胜上。经戒念慧清净者此一句叹阿含德。谓戒者禁心。守念是论经念坚也。能受佛云雨说法持之不失故云受持。复为他说令分明显了故云显说。此释念坚也。是菩萨于阿含中净慧无疑者释慧清净也。自下三句能令听者入教证。于中说是十地义者谓令听者得阿含行。故下二句令其入证。十力根本者已入地者令得佛果也。无碍智本行者未入地者令得入地无碍智故。以十地智能治十障故云无碍也。自下叹众堪闻。于中初一颂半叹众有根。后一颂叹众有欲。前中戒者善住外威仪对治于慢。定者离取执着内心调伏对治于我。谓由执我故于法不恭。由起慢故于师不敬。戒定除此堪闻阿含故云憍慢已灭也。慧者正见善思义。对治邪见故。功德者正意欢喜对治疑恼故。由此二行堪能得证。故云诸邪见已尽也。是众无疑也。然此大众如是行德明金刚藏久自先知。故云集在仁者心。谓仁者是刚藏也。余句可知。论中妄者妄想见中同使故者此释彼经中妄字。谓妄是妄想故。上云有二妄想不堪得证。问妄想是根本非见疑。何得说云有二妄想。释以是倒见中同是使故摄入见中。论中深者细意善思惟故者观真如理故。对治前妄故云细意等也。譬病思良医下一颂叹众有求法胜欲。论经四种此中唯二。具释如论。但世甘露有四义。一除渴如水。二遣饥如食三疗病如药。四生乐如蜜。是故况所闻法也。谓闻思修证如论应知。自下一颂明叹法请。此中广大意者是论中净慧。此是后得智。是说法所依。下三句是体性。此是所说法之体性。三依此所说得佛十力菩提名为果也。经中略无此句可知。此中三义与前不同。前约本智后智及所说为三。此中约后智与所说并依法所成为三故不同也。论文可知

第三佛加请中有二。先长行明光加后偈颂明请说。但加请分别有四句。一是加非请如上加分。二是请非加如上菩萨请。三亦加亦请如此段文。四非请非加如余文。又光明之身是加非请。偈出音声是加是请。若望听者是加非请。就长行中准论经中有五义。一此佛放光照彼。二彼佛放光照此。三此众寻光见彼。四彼众寻光见此。五光台说偈。此光台偈应属口加。何故在此。以所出声是口加摄令取能发声处判属身。眉间放光表从中道法界流出教道白毫表十地是无流法。故于此五段经中略无三四彼此相见之文。又于此作三门。一明八业如论应知。于中略无卷舒业及降伏业二身者八业中卷舒敬示三种是光体。往来名流星身。第八凝停在空名为日身。三业身相对有四句。一是业非身谓觉因伏止。二是身非业谓空中光台。三亦身亦业谓卷舒敬示。四非身非业谓于前五段中第三第四段但令寻光相见。非是业身。余义如地论摄论中说。第二颂中有七颂半作三门。一教请分别。前六颂是请说为彰法是胜令人敬重。后一颂半是教说为显说真使众深信。二加请分别。就六颂中初二颂半望于说者亦加亦请谓与力名加劝说称请。后三颂半中初一望听者与力堪闻为成其请。后二颂半举法利益为成加请。三释文中初一颂半明能加。次一颂显加之所为。次三颂彰法利益。后二颂明教说分齐。初中作二释。一随经。二就论。随经中六句显佛六种殊胜。一极位胜无等等故。二无染胜如空无染故。三威力胜具十力等故。四眷属胜菩萨为世间尊佛为彼主故。五会主胜以释迦佛为此会主。诸佛放光对此佛前助扬化故。六作加胜现神力加说听者故。二就论者此中神力是彼作加。此中而现者是能现。即天人上也。又此中释迦佛前现者。释迦是姓。现犹生也。释显如论。又此四义为法王者。一自在不为他屈。二力胜能摧伏他。三眷属辅弼豪强。四种姓藉胄尊高。初中二句。一慧无比。二心无碍。是故二障并习皆永尽也。何故不但无等。示现等正觉故者。此有二义。一以诸贤圣望于下地皆亦无等。然其未必上齐佛果故。须明等以显上齐。二明佛无等。则谓余佛亦非此等故。显佛佛齐等无有胜劣。故云无等等也。余义如论应知。二加所为中以佛力开者。令承佛力。除众疑谓佛不能说疑。法王无畏藏者。文义蕴积故名为藏。文义称理。无能破者故名无畏。此藏唯佛自在之处故云法王。此上总显。下二句别辨中。说诸地所行者是字藏成就。诸地义差别者是义藏成就。下明说法利益有三时益。承诸佛神力下一颂明闻时益。谓以法胜故。闻时则得诸佛加护。离诸魔事。上半加故能闻。能闻决定故云无能坏者。下半闻故已得护。上解脱月云佛所护念事。令人易信解是此义也。渐次下二句明修行时益。谓渐次修行。诸地具足。必得成就无上菩提。即上句因圆。下句果满。自下一颂半明转生时益。初一颂正明有益。后半简余无益。若人堪任闻者谓有菩萨种姓。曾种此一乘善根者堪闻此法能正信受。故虽生在大海龙世界长寿。亦得闻此经。此是恶道难处长寿者。如说右胁着地未动之间。已经贤劫千佛出世。更一转时复经尔许时。但暂卧息有尔许时。况其一生。何可计知在中不闻佛法故名难处。若是此法器虽生在彼。而亦得闻为显法随机不舍不简难处故。问若堪闻此。何故生彼。答由余宿业故。如龙女闻法等。又以龙宫有经故。问若生彼得闻何名难处。答不闻多故。得闻少故。从多名难故。论经云决定信无疑者得闻故。此经云痴疑不得闻故。及劫尽火中者此言顺西国语。若顺此应言劫火尽中。此言不足。若具应云劫火尽时在光音中。以颂迮巧略故也。以光音是第二禅免火灾。论中云等者等取三禅免水四禅免风。此并是善道长寿天难处。问通论色界俱是难处。何故不说初禅。直举二禅等耶。答以彼初禅有觉观故。难轻不举。问若此色界俱是难处。何故梵网等经有彼处说答此据圣境故有说法。令彼法器众生亦得闻经。如此所说。若就实报则成难摄。又亦从多以为难摄。问无色亦难。何故不说彼。答菩萨不生无色天。故又释。理实亦闻但随相。彼无形色绝听受故不彰闻也。下二句简非利益。谓虽生在人中无难之处。然无慧无信终不能得闻。问人中不闻何不难摄。答亦从多故由疑故不信。不信故不受也。由痴故不解。不解故轻弃也。自有受而不解。解而不受。是故要须起信翻此痴疑故得闻也。是故下二颂教说中。初一颂教依三渐次说。后一举二利劝说。前中诸地智道者此是观渐次。谓加行智推求名观。通生入证故云是诸地智之道也。论观若观若依止能生诸地智。此释观中渐次之义。谓观者意言观察。依此增上力生诸地正证智故云若依止能生等。二入势力观法者是证渐次。谓正体智正证真如。此智能断惑证理依起后得。具此三力故名渐次也。次第而修行者是论中渐次也。得至于余地者是论中上句展转也。各得下二句明修行渐次。是后得智。更重观前所证及闻受上地进修之法。成自利行故云得利益。又为他宣说等故。利一切世间故。论云此行种种异行境界。境界者分齐也。此三次第成故云渐次。又此三中。一一各有渐次故亦名也。又此三邻接渐次云愿说勿令断也

第二许说分齐中有二。先长行序许说之意。后偈颂显所说分齐。前中观察等明其说相。欲令等明其说意。前中论云何故观察十方。示无我慢无偏心故者。有别有通。别中二。一观十方佛欲承力而说故云示无我慢。二察十方机欲令同入十地故云示无偏心。二通中有二。初约承力。二约授说。初中何故观十方佛者欲承其力故示无慢。随观一佛承力便足。何假十方示无偏心。二约授说中。何故观十方。以示现说相故。谓前已三位五请。备尽殷勤。今若不说即成我慢。是故观十方示说。令众咸知。显已无慢。若尔观察一众足示说相。何须具观十方众耶。示无偏心故。又观察有二。一内心照察故。二举目眄视故。二明说意中。增益信敬者。前金刚藏酬解脱月初请之时。已令众悦。今更使明故云益增也。信敬者有四义故。一金刚藏示已能说去众何因之疑故令信敬。二明此刚藏不畏大众不堪闻拂众何缘之疑故亦令信。三显义大之法深妙出言令众知深故生信敬。四许宣说大令其众人得闻在今故云敬信也。颂中有十三颂半分二。初七颂半明义大。后六颂明说大。此二大义略作四门　一定名　二辨相　三明可说不可说　四释文

初中所诠故所以故名之为义。深故广故名之为大谓义则大故名为义大表义故显境故名之为说。因于此说得彼义故。教从所诠亦名为大。此即大之说故名为说大

二辨相者。此十地中宗要有六。一所依果海如太虚空。二地智所证十重法界如空中所画之处。三根本地智能证法界。如能依画相。四诸地后得随事起行。悲智不住等。五诸地加行所起行解为趣地方便。六寄法显成诸地差别。如第二地中唯明十善为其正地三地禅支。余地所寄如是可知。于此六中。前之三门合为义大。后之三门合为说大

三明可说不可说者。先就义大。次约说大。后辨双融。义中有三义。一约果海。可以总标令人知有名为可说。不可指斥示人名不可说。二约证处。既此所证离相离名还云此法不可说闻。以此遣言之言当彼法故名为可说。有言斯遣故名不可说。三约本智。谓以遮诠令解故名可说。直诠不逮故不可说。摄论云无分别智离五相。谓熟睡昏醉等。以直诠不到故约遮诠以示彼法。二就说大中亦三。约后得智随事行相可以言分。是即可说。是出世间故不可说。二约加行智。谓是意言观故。是即可说。观中行相言不至故名不可说。又诸法自相皆不可说。诸法共相皆是可说。此一门通一切法准之。三约所寄法。可以寄此表示令人解十地故名为可说。不可以此即为十地名不可说。三就双融中。此上六中各说即无说。无说即说无二。俱融准思可见。又果海离缘故不可说。所证就缘是即可说。二所证非修故不可说。能证修起是则可说。三正证离相故不可说。后得带相是则可说。四后得无分别相不可说。加行有意言故是则可说。五加行观无分别故不可说。寄法表地是即可说。此上不可说皆各不异于可说。以真理普遍故。可说不异不可说。以缘修无性故。是故下文虽说一分义亦不少故。论云如实满足摄取故意在于此思之可见

四释文中。就义大七颂半中分五。初一颂半总显地微。二有二颂别显微相。三有一颂半举例显微。四有一颂半寄对彰微。五有一颂引喻辨微

就初中云诸佛圣主道者正出十地智。谓道是因义。修行此十地能到诸佛圣主之处故云道也。论云此偈依何义说。依智地故。解云论主何故起此问答。以此颂中所明义理深玄微妙似是佛果。恐人谬解谓是佛果非关十地。故起此问答。犹恐未悟。更重引彼前后经文证成地知。故云上来所说等。微妙已下显地智微妙。言微妙甚难解者。此中微妙是总句。难解者难知故。别中微有六种。一证时微。如经圣主道故。二说时微。如经甚难解故。三离念微。如经非思量所得故。此显自体无念非是意言比观所得。四依止微。如经唯智行处故。此显既非比智境。是谁能知。证智行故。论释中。自证知者释智行义。谓内自证故名行。非谓游故名行。依彼生者释行处义。谓此真如是一切依处。复是此智依生之处。见实谛义故名智者。此释智义。谓内照实义故也。智中开出三智。一善解法者是加行胜解故。二善寂灭者是正体智。令惑永灭证寂理故。三世间智。随闻明了知者。是后得智。随闻上地胜进。明了无错谬故。以此三智俱堪趣地得为智者也。五清净微。如经其性从本来寂然故言自性离烦恼者解寂灭义也。非先有染后时离者解其性从本来义。六功德微。如经无生灭故。谓寂用之功无住之德。言无灭者非一往灭。为不舍利益众生故。言无生者出世间故。如是此智不住涅槃世间中故。又释。于此六中准论。前三是二种微。谓说时证时。非思量等释成。后三是四种甚微。经中略无第一观门甚微故唯三耳

自下第二别显微相中二。初二句明同相。后六句明不同相。此二相中略作三门。一定其文。二辨相。三释文定文者。有人释云。此既即是性净方便净二种涅槃。故知。前微此相。总明果法。欲说地法。何故明果以辨甚深。果位显故举显十地甚深之义。因之与果。高下天殊。云何相显然。此虽复随人高下。法体不别。其犹虚空约释分异。异即是空。地法像此。今明此相总是地智。论释云智相有二种等智即是地智故不通余释。若是地智即是因位。如何得有二涅槃耶。释此是地中所依果分。如下文云。如因大海有十宝山。因于佛智有十地等。如一一山下悉有大海。一一地内悉有佛果。若约三乘佛果唯在第十地后。若就圆教佛果通在一一地中。是故一地摄一切地。问若尔证得一地已得佛果。何须说十。答引渐机故。是故十地多就三乘差别位说。问若就三乘则无果法。答以三乘十地就一乘说故有斯趣。释文中。同相内。言从本已来。空者此总明同相。论中先释相后释同。前中云何相者问。意云色等法空皆名同相。今言相者是何等相。答彼智相故者今此所说。是地智相。引颂中。自体空是智自空故。非余色等诸法空相。又此是体相非是标相下释同中。云何同相者。问意既唯局在智相。云何名同。答中一切诸法如说自体空者。以此真空通一切法名同也。言灭除诸苦恼者此别辨同相苦恼者。恶取空故。恶取空者空乱意故。依宝性论空乱意有三种过。如彼论云。起如是心。实有法断灭后时得涅槃。又复有人以空为有物我修应得空。又生如是心。离色等法别更有空。我应修行令得彼空。解云。今此经中本来空者。离此三种乱意苦恼故云灭除也。论经名有不二不尽者。言别意同。言不尽者离灭色故。不二者离色外故。有者离以空为有故。此义云何。以若妄谓空为有物即令真空于此不有。若真空有情有即无。是故理有治情有也。彼论约色等简。此论就地智明空。下明不同相中。净相解脱者是总显示。谓对治杂染故。别显中二。先何处解脱者问所脱之处。诸道即六道也。惑业生者。烦恼是道缘。业是道因。生是道果。六道不出此三故远离名解脱也。二者云何解脱者问解脱之体五句显能脱之体。一平等相。既言远离诸趣。云何离脱耶。谓见世间即同涅槃。如是远离。非如二乘有背向故云等同涅槃相也。无中亦无后者第二断惑相。论经名非初非中后。谓于三时皆无断义方为断也。释此文有二门。一约相翻门。二约相续门。初中谓无间道智正断惑时。为智先起惑后灭耶。为惑先灭智后生耶。为同时耶。此三时惑智各有两失故不成断。谓智有自成无流过不能灭惑过。烦恼有自灭过不障圣道过。于三位中思之可知。如灯破闇三时不破。此亦如是。如杂集论第四云。从何而得断耶。不从过去。已灭无故。不从未来。未生故。不从现在。道不俱故。从诸烦恼粗重而得断。乃至广说。经云毗婆舍那不能破烦恼等。皆是此义故云非初非中后也。问唯识论第九中。圣道现前惑种必灭。如秤两头低昂时等。若据此说即是同时。如何此中三时俱非。答粗说可尔。细克实难。何者若同时者。智自生时惑自灭时。不相由故何成对治。如东家男生西家女死。虽亦同时。然无相由。不成对治。问若尔云何断。答则此三时求断不得。方成断义。此则不断断也。前中后取故者。谓于前中后三时之中。取彼非初中后非异三时取彼非三也。如于色等处取彼真空非异色等别取断空此亦如是故不失断义。二约相续门者。谓此地智生灭相续。前中后三何时定能断烦恼耶。唯前不能断。以落谢故。唯后不能断。以未起故。中亦不能断以不住故。是故三时皆无断义。若尔云何断。论云如灯炎非唯初中后前中后取故。此即唯初唯中等不可有断前中后相续取可有断义。问既三时单取。各不成断。纵此和合岂成断耶。答有人解云。三时别取各不成断。三时相续。假说为断故云前中后取也。此粗说可尔。细克不然。以别就三时各不成断。总此三时岂成断耶。如一沙无油多沙亦无。今释此言前中后取者是简滥之言。何者人谓此智前中后位各不能断。即谓同于无圣智处恶取空也。故简云。此于初上取非初。中上取非中。后亦尔。不同无智故。非恶取空故。云非初非中后前中后取故。问余处论说圣道初起即能灭惑。何故此中乃云非初。答依毗昙。一念有烧始终方尽。治结同然。依成实。一念不烧相续方尽。治结亦尔。若大乘初教。初念亦断中后亦然。若依终教。如缘起性三时俱不能断。即由不作缘起方成故不无断也。言非言辞所说者第三观行相。谓此无分别观智非同世间言说所及故。又不同小乘从声得悟故。言出过于三世者第四转依相。谓此微智依止真如常住法身。以是究竟转依故。能依所依俱悉常故。出于三世迁动相也。问所依本有。可得是常。能依修智。岂无生灭。答初教随相修智生灭。终教已去智如境故。始觉同本觉故亦非无常。论云非如无常意识者。简未转依时妄念意识是无常。即知转依已去真智是常。此简能缘也。依止无常因缘法者简未转依时所缘境也。修多罗中决定说者引经证成境智俱常。如处处大乘经中皆说佛果常住。又如此经十藏品中信藏之内信佛智无生灭等。具如彼说。言其相如虚空者第五解脱相。谓如二乘智。虽离惑障犹有法执故。其解脱犹有障碍。此即不尔。二障及习一切皆尽故云如虚空无障碍也。又此明自体清净如虚空无染。又论中重结此五种中后三。何故重言者以后三种皆对妄显真故云如是观观等。问审此五句。初句了世间即涅槃。明离而无离。二明三时无断惑义。即断而不断乃至其相如虚空。准此等义与上同相何别。答举实无别。但约自体处名同相。约智证入处名不同相。若不同彼同相不得成此不同相也。是故义说有二。法体无别。言诸佛所行处下一颂半明第三举例显微。于中初三句牒前深妙。下三句类显地微。前中初二句举佛所证二种涅槃。于中寂者是同相涅槃。以自性常寂故。灭者是不同相涅槃。以智缘灭故。清净者显此二种自性无染及对治离染故。深者显此二种甚深微妙故。此二唯是诸佛所证故名佛所行处也。言说所难及者正显此二深妙超言。下三句类显地法。同彼玄妙故云地行亦如是。言地者境界。观者谓照境之智。是地正体故。行者智眷属者檀等诸度与智同行故。亦如是者同二涅槃之深妙故。说之犹尚难者显教尚难。言何况以示人者况义深玄。何容可示。论云何故不但说无言等者。征文显意。谓何不一向说无言乃至言说所难及。显示依言以求解故不说无言也

诸佛之智慧下一颂半第四寄对彰微。以此地智是诸佛境故名佛之智。离诸心数者此智不同思慧境故。离心道者不同于报生识智。彼二可说。此智非彼境故云不可说也。言不可得思议者以非耳识所知非意识思量故。此显不可闻。言非有阴界入者如阴界入有色心根境识等差别是即可说。证智不尔。无能所平等无分别故。离于文字不可说也。是故但可证智内契。不可分别。非染识所能了知故。楞伽云取相名识不取相名智。此之谓也。论云智者是地智。即根本智也。起者以何观者以加行观智起本智故。以何同行者檀等余行亦资起故。言如空迹下第五一颂举喻显微。上半举喻。下半显法。此中喻义略作三门。一对前辨异者谓。与前画空何别者。太空喻果海。迹处喻地体。迹相喻地相。鸟足喻言教意不同者前喻地法难说难闻。成默不说今喻地法难说。难闻诫众舍着许为宣说。二显义意者。如鸟行空鸟身过后迹处不说。相状亦不可见。然有鸟行不可言无。非以有鸟行故令有迹相可取。非以无迹相故总无鸟行。鸟行喻言教。迹相喻地法。寻鸟求迹迹不可得。寻言求地地不可得。但约鸟行十步说有十迹。实无十迹之异。约言分十地。实无地异相。是故十地如空中十迹。岂有差别。问如空中鸟已行未行及正行处俱无有迹。岂可十地言下无所诠义。答有所行空处故有所诠义。问鸟足空中不能现迹。言下既不显理。何用斯言。答鸟行沙土如足现迹。鸟行空中足现无迹。小乘言教显如言义。大乘言教显离言义。若无鸟行无以得知虚空无迹。故知鸟行能显无迹。非无能诠。所况可知。三释文者。论中有二。初三句解喻后。三句合法。喻中鸟行迹处是一句。直举喻体。二不可说相亦不可见是第二句。显迹离相难说难见。谓不可说其迹数多少。不可见其迹相差别。下释成。何故问也。释以空无相故。即空之迹。亦不可分别也。三非无行迹是第三句。以有鸟行故非无迹。又此三中。初总举。二离有。三离无。下合中三句次第合。如是鸟迹处。牒前初句。名等住处证智摄者。合之以法准法验喻。应言如是鸟行迹处虚空所摄。文中存略也。名句字身合鸟行。住处证摄合迹处虚空所摄。不可说闻合第二句明离有难说闻也。下二释成。非如声性者明此地法出言。非如音声之性是可闻法。又释明地出言非可如音声性而执取也。非无地智名句字身者合第三句现不无义。非无地智者有所诠离相之法。非无名句字者有能诠之教。何故言有教拟欲宣说。故何故言地离相。不令如言而取故云何故。我复说此。汝等不应随声取义。此是论主义。作金刚藏语。诫众离着。五过中。前二违行过。次二违人过。后一违法过。谓如言之义都无所有。而谓实有故不正信。二不能励心舍相求实。名退勇猛。三法实不尔。为他宣说云法正尔。故云诳他。四言是佛说故言谤佛。又佛意正在离言之义。而谓佛智缘所执相故亦谤也。五谓法浅薄同于世间称言之事故言轻法。又佛教旨示离言义。令诸众生越凡成圣。今取如言。只是世语不能令人超凡得圣故。轻法之过实为重也。释义大竟

自下第二明其说大。于中六颂分五。初一颂三句明所说分齐。二有三句彰已无过。诫众除失。三有一颂半显其所说。略而非广。四有一颂劝众敬听彰已善说。五有一颂显已得力为生物信。前中初一句是总言。是事虽为难者。是事谓牒前义大之事。虽者是不定之辞。谓此地法有其二分。果分虽不可说。然因分可说。故论经云。我但说一分。谓因分于果为一分故。此二分义诸说不同。有说。能诠之教为因分。所诠之义为果分。此说甚疏。有说。地前因行为因分。地上证智为果分。此品岂说地前法耶。故知不然。若约诸地加行等为因。正证为果。亦少分得。有说。十地有二种门。一若约渐增之门名因分。十地是即可说。有分齐故。如月渐增。可说差别。二若就圆满时门名果分。十地是不可说。无分齐故。如月满时无差别。故此二十地其体无别。但随分满假立二分。此亦未然。岂可未至法云即欢喜可说。待克十圆满方不可说。若前能起后为因。后依前起为果。亦少分可然。犹非文意。有说。十地有二种义。一者教所安立十地法门。在闻者识上。似义显现名为因分。由此表彼离言义故。二者亡诠证入十地正行。离诸言教所安立相。说名果分。由彼因分之所表故。是故因分可说。果分不可说此说少顺文意。犹非正当今释有两重。一此十地有二分。一就实十地。唯佛所知佛智所行名为果分。上论云此智是谁证。偈云佛智所行故。又上文云智起佛境界故。又上加分中言不思议佛法。又如鸟迹所依太空为果海等。二随相十地。菩萨所知。菩萨所行名为因分。是即果分玄绝当不可说。因分约机。是即可说。此义通一部经中大意。问若尔菩萨证智岂可说耶。答教说修中满足修等是也。二言十地有二分。一约妙智。正证智如境故。离相离言故。名果分。即不可说。如彼鸟迹同于虚空不可说也。二约方便寄法。显地差别。如下文初二三地宫同世间。四五六地同二乘等。又寄禅支道品诸谛缘生以显地别。令众因此表解地义。故名因分。如空中迹约鸟说异。名为因分。同空无别名为果分一迹通二故为二分。问约鸟约空迹皆离相。云何有可说有不可说。答迹虽离相就鸟得说。就鸟得说所说常离也。迹同虚空理不可说。所况地智准此可知。此释局斯地品故云虽为难。即是一分也。此为总句

下有六句别显三大。初一句明因成就大。次有一句明因渐成就大。余有四句明教说修成就大。释此三大略作四门。一释名者。悲愿熏心为起行本名因成就。说大之中开出之故名之为大。二闻思修等次第能生出世证智故名因渐成就。三实智证真指陈不到。假言寄显故教说修。问此三俱是说大中出。何故前二不名教。又俱是因分中出。何故后一不名因耶。答前二生后功能显故同得名因。体非玄妙故不待言简。不称教说。后一证智玄妙滥同果分故。以言简名教说修。二就处以定有二。先约假处。寄显因成寄在地前种姓位。以彼种子因成就故。因渐寄在解行位起闻思等行趣真证故。说修寄在初地已上智。证实故。二约实位。此三俱在地上。但初地之前加行修中慈悲愿等名为因成。闻思修等名为因渐。正证后得名教说修

三就文辨定者。下说分中。诸地之内皆有此三。何者且菩萨因何求此智。有二所因。一为救众生。二为求菩提。由上求菩提下救众生名为菩萨。故云慈悲愿也。二既内有此因欲趣求诸地。有何渐次。谓修学三慧渐入诸地。此二同在加行智中。三加行智既终必示契真理。前二相粗直陈可得故不别寄。证智地体不可直示故寄别法。用以显表示。如二地正地中说十善等。三地正地中说四禅等。四地正地中说道品等。并是如此教说修摄。四释文中。初句慈悲是利他行。发愿是自利行。释此二文如论应知。因渐成就者。如偈渐次具诸地。故谓三慧次第能生出世智。以是彼因故名具诸地也。教说修者有二。满足修者闻思慧等。但能为彼出世智因。不能满彼智地。要出世净心方能满彼。故云智者所能及也。下明观修。于中如是诸地行者牒举地行也。微妙甚难见者明观境非余心所能见也。不可以心知者不可以染心能知。论云自心清净可知。此中满足修据根本智。观修约后得智。反缘观内俱不可说故名教说修也。自下三句是第二显已善说。诫众除失。先显已离二过。一离佛不随喜故云当承佛力说也。二离不平等说故云咸听也。二诫众令离二失。一于说者不敬。离是过故云汝等当恭敬。二于法见诤。离是过故云共一心听也。自下一颂半。第三明所说略而非广。初二句牒举地法。是智所通达故云随顺也。以此智入彼诸地相中故云诸地相入行论云如行修故者如加行修而得入也。如行修满足者加行入证契理圆满故云如实满足摄取入。此智入之行无量无边故云于无量亿劫说之不尽。今但略说者是要略故云如实也。虽是略说而具摄广义故云其义无有余。自下一颂第四劝众敬听。彰己善说。一心恭敬待者有二。一身恭敬如威仪住者释敬也。堪受说法者释待也。二心恭敬请决意求法故云如心决定。此释心敬。堪能忆持者释持也。前则身恭能受此即心敬能持。今承佛力说者显非已力。离增上慢故。下半显所说。谓以何事者以天音唱故。云何事者出因引喻故。依止何事者依止善字不违义故。示现何事者示现地义故。又释大音唱因喻依证成道理说。义名不相违依法尔道理说。可知。论中善字者是善巧之字故有二义。一巧同他音。二诠义周备。如论应知。自下一颂第五现己得力令物生信。初二句明虽得广多诸佛神力聚在我身。后二句然现己所说如海一渧所不说者犹如大海。况无佛力纵此一渧亦不能说。上来至此请分竟

自下第七明说分作四门

初释名者演畅宣陈十地差别故名说分

二来意者。前既请满。刚藏告众许说一分故。次正说以现地法

三说意者。前本请分中已说地体。令彼上机悟解玄旨。今辩地相。令中下之流随相开解。故明说也。又前已略示令生正解。今更广陈令起行修。故明说也。四释文中说十地即为十段。就初地中略作七门。一释名。二来意。三断障。四证理。五成行。六得果。七释文

初释名者。唯识论第九云。一极喜地初获圣性具证二空。能益自他生大喜故。解云此有三义。一得位。二证理。三成行。皆初获得故生欢喜也。摄论中唯依第三成行义释故。无性及世亲各第七卷云。由此最初得能成辨自他义利胜功能故。谓如菩萨入现观时。得成辨自他义利最胜功能生极欢喜。非声闻等入现观时唯得成辨自利功能生如是喜。故不说彼名极喜地。依十住毗婆沙论唯约证理释。彼论云。始得法味生大欢喜。依瑜伽七十八及解深密经第四同约二义释。彼云成就大义得未曾得出世间心生大欢喜故。解云大义即是二利行成。出世间心是得圣位。同十地论成就二行及得圣位。如本分中释。余义如下释名分辨

二次第者。何故最初明此地者。谓先地前加行功力无间发起本性无流功能。令生现行。初无流智证见真理。灭惑成行故先明此

三所断者。唯识论第九云。一异生性障。谓二障中分别起者。依彼种立异生性故。二乘见道现在前时。唯断一种名得圣性。菩萨见道现在前时。具断二种名得圣性。解云异生者执异见而生故曰异生。即旧名凡夫也。性者即是分别二障。种上假立不相应法。依彼种上立此性故。即说彼种名异生性障。此即异生之障。依主释。梁论名凡夫性无明。十地论名凡夫我相障。解云此约二执。通名我相故不相违。又此异生性虽依种立。然见道前现行分别。亦此障摄故。唯识云执着我法愚。即是此障。故知通现。问若分别二障现种为体。如何二愚唯现非种。答障宽愚狭故不相违。又此异生性虽通本随分别现种。然由执着之所引发故。贪嗔等摄属二执。问圣位翻凡。何故初地圣性唯依种立。答以现行间断故非圣性。问若尔地前已有无流法尔智种。何不于彼立为圣性。答以凡圣二性同时相违过失故。虽有种而非圣性。如灭心定依种假立微微心时。虽有彼种而非灭定。以有心无心义相违故。此亦同彼。又释。地前未有彼无流之种故非圣性。法尔种子非所许故。问既异生性是不相应行摄。圣性翻凡。何不立不相应耶。答依大乘宗圣性亦是不相应摄。即二十四中非得是也。以大乘宗许此通无流故。不同小乘不通无流。又释。异生劣故别立不相应。圣法力胜故不别立。亦不相违。又唯识云。虽初地所断实通二障。而异生性障意取所知。说十无明非染污故。无明即是十障品愚。上来且约断烦恼说。理实初地亦除恶趣诸业果等。是故要说具断二愚及彼粗重。一执着我法愚则是异生性障。二恶趣杂染愚。即是恶趣诸业果等。应知。愚品总说为愚。解云显上二愚非唯无明。执我法时所有愚及俱起法说为初愚。愚品类恶趣业果。体虽非愚。愚所发业及所感果。总说为愚。彼论又说。利钝障品俱起无明以为二愚。即与五见利品俱起同时无明名为初愚。与贪等钝品俱起名为后愚。言粗重者。彼论二释。论云彼粗重言显彼二种或二所起无堪任性。解云此初释粗重即是二愚种子。恶故名粗。沉没称重。故知二愚唯约现行。后释是二愚所引令身心中无堪任性粗更沉重。故名粗重。非现非种。准此二愚亦通种子。又案此二愚或分为三。谓惑业报。或分为四。加彼粗重。或分为五。谓惑中分二障故。此等并是此中所除。泛论断义有其三种。一自性断。谓诸烦恼及相应心心所。不善有覆无记。诸染污法。见修道生惑种永断。此中心王遍行别境性非染污。非可断法。与烦恼俱名相应缚。断烦恼故亦说名断。二离缚断。谓有流善无覆无记通色心等。非正违道。性非可断。由断六识缘彼烦恼故说为断。三不生断。谓此见道断见惑已。舍外道身。所依身无。即无想定及无想报并永不生。又招三恶道总报恶业。皆非择灭亦名不生。三恶道报无根二根郁单越等。亦皆不生。畜生饿鬼别报善业所依依果无亦不生也。此上且约初教说之。若约终教。初地亦舍三界分段及惑业苦。地上唯断彼所知障及变易报。其烦恼障地前渐伏。初地断尽。所知障地前亦学伏。初地断一分。余在诸地各断一分。佛地方尽。此如梁论及宝性论等说

四所证者。谓法界真如遍行之义。唯识论云。一遍行真如。谓此真如二空所显。无有一法而不在故。解云行谓有为诸行。我法二空所显真如。遍于一切有为诸行故名遍行。梁摄论中名为遍满。遍满一切有为行故。世亲摄论第七云。无有少法非无我故名遍行。无性摄论第七亦云。无有少法非是空故名为遍行。理实二空通余九地。以初位创证故以为名

五所成行者略有四种。一约增胜修成施行。二约所成起十大愿。三约修成。谓信等十行。四约实行。谓十度等行无不皆修。余所修行释文自显

六所得果者略有四种。一得当地满时调柔等四果。如下应知。二得檀行所成大财等果。三依摄论通达障空义得一切障灭果。四通论得唯识三性三无性理智及奢摩他毗钵舍那等果。余如文说

七释文者。就此地中文别有二。初长行。后偈颂。前中有四。一始住地分。二地释名分。三安住地分。四校量胜分

就初分中论主分为四。一依何身者。谓厚集善根为所依身。二为何义者。为求佛果。三以何因者。以大悲为因。四有何相者。过凡得圣为相。此四各有十门。别辨名为创住菩萨初地。又此四义与瑜伽四十八住品中极喜住内菩萨发心有其四相文同语少别。会意可知。彼云。一何相菩萨发心。二发心何所缘虑。三发心何状何相。四发心有何胜利。彼论依此经文。作彼略释不具。初依何身中有三。初结前总告。二正显行相。三如是众生下结行入位。正显行中初句是总。谓一大僧祇积集胜善故名厚集。若有众生者是此初入地众生。非是地前。有人判此十句属地前发心方入初地者。此不顺文。岂可地前属初地摄。以此文说初地不说地前故。应知。此是初住地处说此所依善根行相。别辨中此集有九种。一行集。善作眷属。持戒者以慧为主。戒随助伴故云眷属。如经修诸善行故。谓三聚非一故云诸善行也。二定集。谓定助智道。名为善作眷属三昧。如经善集助道法故。三亲近集。谓亲近诸佛供养恭敬。习闻慧智。如经供养诸佛故。四聚集。谓思慧智善能思量。积集诸度故云聚也。如经集诸清白法故。谓六度治垢故云清白也。五护集。谓修慧之行上顺善友故为摄护。出世真证修能趣入故名修行实证。行实证故为彼善友。教授摄护故云善知识所护。六广集。谓广于一切众生以愍至深心作利益故。七信心集。谓决定信乐求大法故。八现集。谓随所集善多向益生故云心多向慈悲。于中慈念依苦苦坏苦者。以慈行粗故。悲依行苦者。明是细故。问上文云慈与乐悲拔苦。何故与此不同耶。答此二有通有别。别如前辨。通论俱有与乐。如三地中慈有广大无量者与乐。谓广与欲界乐大与色界同喜乐。无量与色界不同喜乐。悲喜舍亦尔。故知同与乐也。又如三地。为苦众生入慈悲故知同拔苦也。此文亦尔。是故知同也。九求集。谓与众生求一切智智故云好求佛智慧。依论经此句摄在第八信心集中。别有第六净心集。谓出世真证心无垢染故云善清净心。故又此九中。初五护烦恼行。谓一戒学。二定学。余三慧学。即闻思修三慧。依论有四。加净心。集出世智故。后四护二乘行。于中初二护二乘心。谓广护狭心。信护小心。后二护二乘行。谓慈护狭行。求护小行。又此十中。初一总相。谓统括诸行成一厚集故。余九皆是集。中间出故是别相。九中皆有集义。是同相。戒定等别名为异相。成坏同前可知。依此诸集集成之身。乃能发此真证之心。住于初地故。此诸集总在地中。初分所摄故。云如是众生乃能发阿耨等心。此心即是本分中愿善决定。彼文指此也。第二为何义生如是心者。如经为得一切种智故。此显佛无上智具知断证修究竟满。故此为总句。佛智业用利益众生差别有九。为求彼故生如是心。一力佛智能作问记业。此是如来处非处智。随诸众生问。因果等义。悉能记别。此义广说如余修多罗说。故云为得十力故。二无畏了佛智能作破邪业。以四无畏破外道说故云为得大无畏故。三平等佛智能作教授业。谓得二空具足佛法。转教众生令同证入故云为得具足佛法故。四救佛智能作救济业。谓以四摄巧化众生故云为救一切世间故。五净佛智能作救摄因业。以大慈悲为救众生因故云为净大慈悲心故。六无余智佛智能作普观之业。谓常以佛眼普观十方世间众生。无不穷尽故云为向十方无余无碍智故。七无染佛智能作严土摄生为业。谓庄严一切世界令无障碍。无有杂染。不待功力。以土应机令生信入法故云为净一切佛国令无余故。论中智心无碍者。智无碍显前无障。心无碍显前无染。又初慧解脱。后是心解脱故也。八觉佛智能于一念顿觉三世众生心数。以为业用故云为于一念中知三世事故。九转法轮佛智于诸众生能令解脱。善巧为业故云为自在转乃至佛神力故。生如是心者即是前发阿耨菩提心也。论云何故唯言生心不言生智为一问也。及余心数法谓念定等为二问也。理实此时诸德皆生。何独心耶。释云心是总主。举此即摄智等心法故。云心中即摄知断证修。答初问也。亦摄一切助道法故者答后问也。第三以何因生如是菩提心者。如经是心以大悲为首。故前说为何义中显所求果。今此以何因显能成因。谓以何因求大菩提。以大悲为首济众生故。求此菩提非为自安。何以故。若非如是大菩提法无以究竟救众生故。是故诸行大悲为首。此悲大有九种。一增上大缘微细苦。生增上智故云智慧增上。论释智与慧二差别者。然此智慧有通有别。通而言之所知无别。开别有二门。一智知俗谛慧照真谛。如十度中第六名慧。以照理故第十名智。以鉴事故。二智能决断因果逆顺染净差别。慧能照达诸法假实体性有无。此中约后义辨。又观众生十二缘起。前能起后皆名为因。后依前起悉名为果。逆顺观之有染有净。染逆顺者。无明缘行乃至老死是名顺观。何缘老死。谓由生故乃至无明是名逆观。净顺逆者。无明灭故行灭乃至老死是名顺观。何缘老死灭。由生灭故乃至无明是名逆观。是观名智。决断义故。观一切法但名无实名自相观。观一切法真如一味名同相观。是观名慧。照察义故。二摄大。谓前既知苦。今以四摄方便善巧救苦众生故云方便所摄。三淳至大。淳谓渟厚。至谓至到。慈悲增上故曰淳至。淳至有二。一直心淳至。谓向时发心许尽众生界作利益。其心一向无改易故。二深心淳至。谓愍苦情愍彻于后际故云直心深心淳至。故又直心令证理。深心令集善。故起信论云。直心者正念真如法故。深心者乐集一切诸善行故。四无量大。谓摄取如来无量神力。化物生信故云量同佛力故。五决定大。上妙决定信深智胜对治者。决定信知诸佛深智。堪授众生令成最胜对治之用故。云善决定众生力佛力故。谓以佛智力授与众生益其智力故云众生力也。六随顺大。谓随顺菩提令得正觉故。云趣向无碍智随顺自然智故。七正受大。谓能领受诸佛大胜教法转受众生故。云能受一切佛法以智慧教化故。八最妙大。摄受胜妙平等功德故云广大如法界故。九住尽大。谓住是无常爱果之因。尽是涅槃常果之因故云究竟如虚空尽未来际故。第四明是心生时有何等相者。如经菩萨发如是心即时过凡夫地者。以此心即是出世间道。此时舍离凡夫性故。又创得圣位。过于地前内凡位故。此是总句。过义有八。下别显之。一入位过。此时初成出世间心。犹如世人初始住胎。相似法故云入菩萨位故。此句约位故。瑜伽住品名入菩萨正性离生。梁摄论第十云。一入菩萨正定位。以入菩萨初无流地故。二家过。以得佛所证法界之分故云生在佛家故。梁论二。生在佛家如诸菩萨生法王家具足尊胜故。解云前虽住胎。若下贱家不足为过。要在王家受生。方显其胜故。此句约得法为家。瑜伽住品云生如来家。三种姓过。以大行成立堪绍佛种故云种姓尊贵。无可讥嫌者。梁论云。以过二乘及世间种姓故。解云。良以二乘亦得生空法界。然彼不能绍佛果位。如虽生王家然或是王之仆隶等。不足为贵故。今要得王之体分。继于王位故子相似也。四道过。以非有流故。世道不摄。是无流故。出世道摄故。云过一切乃至出世间道故。以虽得大乘在世间无足为胜。如虽是王种若是鬼神之王不足为贵。要是人天之王。方显道过故云异道生相似法故。梁论云。四已转一切世间行。决定不作杀生等邪行故。五法体过。谓菩萨正以大悲为体。于作他事即是已事。以为自身体性。相似法故云住菩萨法中故。瑜伽云。设有问言菩萨以何为体。当云何答。应正答言。大悲为体。此之谓也。前虽道胜。若已身残阙。未足为胜故。举大悲显成自体。六住处过。以不舍世间。是不住涅槃。方便不染。是不住世间。巧离二边。住无住处故。云在诸菩萨数。论经名住在菩萨正处故也。如王子诸根备具。若住处下劣。亦不足为胜。菩萨虽有大悲。若着二边。亦未为胜。七生业过。以顺空圣智。等入三世真如法中。显无终极无际限相。生命相似故云等入三世如也。论经名三世真如法中。是故此中如字两处用之应知。如彼王子虽依正俱胜。若寿命短促。不足为胜。八毕定过。佛种不断显因毕定。究竟涅槃显果毕定。成就相似者。如王子虽依正命胜。若志气不立所作不成。不堪绍继故云如来种中毕定究竟阿耨多罗三藐三菩提故。住如是法等者。牒以总结。谓前四义中。初明内所依身。二辨外所求果。三显求果所因。此三明发心由致。四正显所发心相。此即是初住地相。故云住如是法名住菩萨欢喜地。以不动法故。不动法者释成住义。谓一证真理不复失故。二乘异道所不动故。已说住义竟

第二释名分中有三。初十句明多喜。次十句念当得生喜。后十念现得生喜又释此三中。初一明欢喜差别。后二明喜因差别。又前一正是此地行相之喜。后二明于此地举缘方喜。又初一对前依何身生喜。以厚集善根得此位故。次对前为何义生喜。以所求佛果定当得故。后对有何相生喜。以现离凡得圣位故。何因中不对辨喜。谓悲心恻怆喜相隐故。初中言多喜者。谓适悦众多故。论中三种。一心喜者入观之心。心则适悦故。二体喜者出观喜。受相应故。三根喜者由前心体喜故。令所依身色根调畅。轻安适悦故云多喜。此是总句。别有九种。一敬喜。于三宝中得不坏信故云多信故。此如小乘入见道得不坏净相似故。二爱喜。乐观离染真如法故云多清净。故论经名多爱念。故上二是心喜。三庆喜。自觉所证校量。胜过于地前故云多踊悦故。四调柔喜。身心安适遍增益故。论经第五有踊跃喜。此中略无。五堪受喜。自见至菩提近故云多堪受故。此与念当得何别。谓念当得念果预喜。今此念因能受故喜。上来自行喜。下三明化他喜。六不坏喜。由于自心先已调伏。是故或他论义自解说时。或自论义他解说时。皆心调无诤。离诸扰动故云不好斗诤故。七不恼喜。以心慈悲身口调柔。设见恶人以道渐化。不恼他故云不好恼乱众生故。八不嗔喜。谓见众生。不如说行心乖法也。威仪不正身违道也。见之生愍故忍不嗔故云不好嗔恨故。此前二句不恼坏他。此句能受他恼。又前二不令他恼。此句自不起嗔。第二念当得故生欢喜中。初句总。此中欲明已当得义。何故乃念他佛耶。论释。如佛所得我亦当得。如是念故心生欢喜。此即念他成已也。别有九种。一念佛法者正是念法。但以总该别。于念佛门开出余九。是故九种皆名念佛。此是念佛所得之法及所说法。已亦当成故云念佛法生欢喜心。二念佛菩萨。有人释云。此念佛过去为菩萨时。我亦同彼故生喜。今解念佛成道有菩萨眷属。我亦当有故生欢喜。文意在此故云念诸菩萨等。三念佛行。此中正是念菩萨行。何故名念佛行。释以诸菩萨行佛所行行故。从佛有故。四念佛净。谓念佛所有诸度离染故。云念诸波罗蜜清净故。五念佛胜。谓念佛菩萨胜余众故云念诸菩萨与众殊胜故。六念佛不退之力故云不坏也。七念佛教化之法。八念佛能广利益众生。九念佛所入之门。谓善巧智门也。问看此十句。唯初一句念佛。余念别事。论主何故总称念佛。答此依一乘无尽缘起无碍相成。即一一缘中无不皆摄一切诸缘。论主依此例故。回九入一。俱名念佛。如初句摄九。余一一句皆亦如是。此即句句之下悉皆无尽。以此地法是陀罗尼法。如上举悉昙章为喻。是此义也。依此例故。上十信为总。乃至十地及佛悉为别。摄别入总。无不在信中具足。余位亦然。是此义也。又此十句论主更作一番解释。论云于中初二念共念佛者。谓于十中初二念共。同是所念。今还分为二。谓念佛念佛法故云佛佛法二。故此意欲简成于三宝。言念佛菩萨二者。还将念佛简念佛菩萨故为二也。言念诸菩萨故。直举菩萨。以念佛前简法处已显故。是故佛中具足三宝。余七皆是念佛行摄。此行为总。余下六句显此行故。言随所显彼菩萨行者。谓此六句随彼所显菩萨行故。是故得在行中所摄。言以何显如是诸念者。谓前言随所显未辨以何法显。下出能显行体故云如是诸念应知。此中菩萨行有二种。一离染行。二胜进行。六中初句别显离染行故云复何显彼波罗蜜净行。二余五句别显胜进行故云云何显彼菩萨行乃至转去故。于中初二句胜及不退显胜转去。以后地望前皆名转胜。前地望后趣入不退皆名转去。后之三句显其尽去。十地位穷名为尽。上入佛果称之曰去。三句中初二显尽。谓法云地中能受法雨。及能注雨利益群生后一句受职成佛故。云上入佛地。此初念佛行该摄后六因之为总。归初念佛说以为别。故云亦总亦别也。第三念现得生欢喜中。初总中离世境。论释离凡夫取着事。此六尘境是世凡所取。又未入初地。所取不亡。如论云现前立少物等非入地故。今入出世证真如法。离所取着世间境事故云我转离一切世间境界生欢喜心。此转离有九种。一入转离。谓入诸佛所行法中故云入一切佛平等中故。此九种与前八过既少相似。有何别耶。释前中。举此正显发之相。此文念此现得生于欢喜。理实初住所得无别。二远。舍地前凡夫位故。三近。到出世圣智地故。四断离分别烦恼恶趣业果故五依止堪与众生作依止故。六近见。自念行成趣佛不遥故云近见。七生。得生佛诸受用土中净土。是佛分齐境界。八平等转离。与诸菩萨同证真如入在彼数。九转离舍胜报自在故云舍离恐怖。此文有二。初直说。后重分别。又此十中初二句显所行事不相似。此以佛法为所行事。不似凡夫取六尘事。次二句显自身不相似。谓此以圣慧为身。不似凡地妄识身故。后六句显六种不相似。一断转得出世净行。不似凡夫习恶道行故言行不相似。二菩萨大悲依众生起还为物依。不似凡夫自不济不能作依故。三菩萨见佛得力助行。不似凡夫非器不得。四菩萨生于净佛国土。不似凡夫生于五趣故云处不似。五证知正智以资慧。不似凡夫杂业所生。六内心纯熟所作无怖。毕定成就不似凡夫带障恒怖。由此不似故名转离也。言怖畏者。不爱等者。谓不活等五令心憎恶。名为不爱。所畏不定便生疑虑。所畏定者即生忧想。此是心法与心俱起故名相应。此是畏体以心畏故现相于身。故有毛竖等事也。第二重分别怖中二。先征问标二章门。一怖。二离。后释前二门。先释怖章。释此五怖作六门。一出体有四法。一疑。二虑。虑犹思也。三忧。四想。如前可知。二明说意。所以者何征其意。理实初地断除烦恼等障。何故此中乃说离畏。论释此五怖畏是初地障故。偏在此说。若尔何唯在释名处说。论云复说地利益胜故。欲明欢喜利益与怖畏相反。故此举之。三依三业分别者。论云第一第二第五依身口意者。此有二义。一别。二通。别中。不活依身。恶名依口。恶名虽发他口以性是口业故。众畏依意。意无智德故生众畏。二通。不活三业衣不盖形。食不充口。苦困逼意。余二通可知。三四唯依身者。善道可爱。舍故生畏。此是死畏。恶道可憎。得故生畏。此堕恶道畏。舍得在身。非余业故。四建立者。论云何故但说五怖畏。打缚等诸畏皆五摄故。五出因者。论说二因。一邪智妄取想。见爱着故。二善根微少故。初为三畏因。邪智是不活因。由邪智计我惧已不活。追求资财妄取想。是恶名畏因。以妄想悕取美名遂起此畏见爱着是死畏因。由见我故。爱着自身惧其死也。此三同是恶法故合为一善根少是余二因。功德善少畏堕恶道。智慧善少畏于大众。又过去善少今畏大众。现在善少畏当恶道。此二俱是善少合为一因。六对治者。离此因故怖畏随尽。并如经可知。释名分竟

第三安住地分中有三。初总明安住。二所谓下三十句别辨安住。三成就下一句总结安住。初中亦三。初大悲为首。是安住因。菩萨所行。皆为众生悲为行本故云悲首。二于众生心无嫌恨等。是安住观。此中有二。一于众生违恼心不嫌恨者。见非不嫌。触己无恨。此烦恼不能坏故名坚固。二直心者。深悲愍物。为求菩提。小乘不能坏故名坚固。此二不坏故云自然净。三转复勤修一切善根者。是安住行。如下所说信等善根。一切皆是此地摄。故总修也。此勤修有三。初信心是行所依。二修行是依心成行。三回向是回行成德。初十句明信心成。言信心增上者随所有事。于中信增上成就。解云。此是总句。随下别句所有三宝等境事。于中深信决定名为增上。别中有九种信增上。于中初六始起信心。后三信增成欲。前中初二自行。后四利他。前中初句上信三宝。谓净信敬行故云多行净心。下句于理证信。谓真智开神故云解心清净。利他四中。初一化他行。谓说己所证授与众生名信分别。后三化他心。谓慈悲是化心大也。不疲懈化心常也。后三中初于行离过。谓不染着世是惭愧能也。于悭等下辨惭愧相。举悭等取余五蔽。故由深惭愧六蔽不行故云庄严。二于人将护。三于法敬顺。信心竟。第二修行成就中。论经九句。此中八句。论云十句者据减数十为名。初句总集诸善根无休息故。无休息故是常修也。一切善根是顿修也。别中八内。初七阿含行。后一证入行。前中初二摄法方便。一近善友。略无此句。二爱乐法。谓于直咨直报为问答设难。释通为论义。分别本文为解释。于此三时。称悦适情。心生喜故云常爱乐法。次三成三慧正行。于中闻思可知。修于定中不味着故。后二是随缘离着行。于名于利已得不贪。是知足行也。未得不求是少欲行。未受戒者。有此贪求不得受故名障菩萨戒也。已受戒者。起此二种令戒退失。上来阿含行。言常生宝心等者是证行。证行可贵。从喻名宝。证行超出念念常现故无厌足。修行竟

第三回向成就中依论中作四翻释。一显意释。二总别释。三随要释。四就行释。初中先问以发起此求一切智等说何等事。何以有此问者。为文中无回向言故作此问。示现回向成就者答以显示也。以求佛果是回向义故。二总别解释。如论应知。三随要分别者。此中分三。初求何等事。求一切智地故者此是初句所求果法。求犹乐也。二以何观求。观诸佛力无畏等故。此显能求观解。是第二句。三云何求。求诸波罗蜜无著法故。此显以何行求。用诸度离六蔽等着求。此通摄后十句。总尽此三求中。家者结一切智地。是所求处故名家。依家者结能求观解。谓所观力无畏等。是一切智中别德故名依家也。无障求者结能求行离障蔽故。四就行解释中。初二句非是此中正所修行故别释。此唯解前能求之行。论中云何求等。总标前第三门为此总句。下开别故云差别果求。施二垢中。初见乞。诈设是语谄也。无心许与是心曲也。对治此如经离谄曲故。此是一向不许。二许而不与有三义。一先许后不与。二许多与少。三许胜与劣。皆是不随先言。对治此如经如说能行故。二戒有一垢。不护实语有二。一犯戒以违本受时能持言。二覆藏不露犯默妄语等对治此故。如经常行实语。菩提资粮论经云。虽由实语犯戒退失转轮王及以诸天王。唯应作实语。三忍一垢。佛家正以利他为业。反此恼他即污佛家。对治此如经不污佛家故。四精进一垢。谓于戒生退。此三种。一法广故退。论云菩萨戒无量。二时久故退。论云劫数长远。三深细故退。论云难持难行。以广故难可具持。时长故难可常持。深细故难可善持。又律仪戒中。恶无不离故难持也。余二聚中。善无不摄生无不度故难行也。由此便生退堕之心。是此垢也。对治此如经不舍菩萨戒故。由精进策修能行难行故五定垢二中。一事中攀缘名乱心。内情妄取名忆想。又初粗后细。又初不得止故。后不得观故。对治中。不动治乱。生萨婆若治忆想。六慧有三垢。一障不住道行。或一向现世间不现涅槃。同凡夫故。或一向现涅槃不现世间。同二乘故。此无善巧。是般若垢。对治如经可知。二障助道行。三障证道行。并可知。言菩萨如是下总结安住。由此三十句行净治此地。纯熟故名净法。论中更释。于中分为四。一信谓忍受决定故。二欲谓悕趣彼行故。三精进谓对缘造修故。四方便谓行成巧求故。初十句中。后三句是此欲故有四也。上来百句经总明初地说分竟

华严经探玄记卷第十华严经探玄记卷第十一(此尽第二地)

        魏国西寺沙门法藏述

第四校量胜分

菩萨住此中胜三乘故。前初住及安住已说过小。何故至此方说胜耶。释云。菩萨诸行是事皆过。前是初住及正住过。今地满胜故亦辨过。如小乘见位无此胜德。今此不同故显殊胜。然此胜相略说三种。愿是标志遐广。行是依誓造修。果是当位行成就

初愿中略作七门。一显名。二体性。三约修分别。四约行分别。五约所求行位分别六因果分别。七释文

初名者。愿是希求义。地论云发诸大愿者随心求义故。次显别名。此论中但释文不显名。古来诸德依义作名。或有顺或不顺。今依梁摄论具列十名。彼云。一供养愿。愿供养胜缘福田师法主。二受持愿。愿受持胜妙正法。三转法轮愿。愿于大集中转未曾有法轮。四修行愿。愿如说修行一切菩萨正行。五成就愿。愿成就此器世界众生三乘善根。六承事愿。愿往诸佛土常见诸佛恒得敬事听受正法。七净土愿。愿清净自土安立正法及能修行众生。八不离愿。愿于一切生处恒不离诸佛菩萨得同意行。九利益愿。愿于一切时恒作益利众生事无有空过。十正觉愿。愿与一切众生同得无上菩提恒作佛事。解云。此十中。最初供养愿。此经中唯约供佛。摄论通余胜缘师等。第二同。第三此经中是请转法轮为摄法上首。非是自身作转法轮事。第四愿。有人云此是知众生心愿。此名非也。文中自释是修菩萨行故同摄论也。第五成就。是教化义同也。第六此经中名知世界愿。现前了知世界差别。与摄论不同。会此二说。谓彼承事必往世界。此知世界必事佛故。又不须会。但此经为定。彼论十愿从此经出。更余处无文故。余后四愿意义。悉同可知

第二体性者有六门。一约克性门。唯识论第九以欲胜解及信为性。愿以此三为自性故。二约相应门。梁摄论第十清净意欲以为愿体。依般若故得清净。依大悲故有意欲。解云。此有五法。一清净是信。二意是意乐。三欲。四智。五悲。后二是所依。何故依此二者。以愿有二故。唯识云。愿有二种。谓求菩提愿。利乐他愿。三约所依。以依后得智起此愿故。如余论说。十度之中后四皆是后得智故。四约行渐增为性。如地论云。何故名大愿。光明善根转胜增广故。五约眷属。通一切行故。唯识云。若辨眷属一一皆以一切俱行功德为性。六约究竟。梁摄论第十云。此十愿至登初地乃得成立。何以故。此愿以真如为体。初地能见真如故

第三约修分别者。初七是修始。次二修熟。后一修成得果。又从地前初发心时即起此愿。至登初地。修愿得成。如梁论等辨也

第四约行分别者有二。一别。二通。别而言之。初二自利行。论云初愿功德行满。第二愿智慧行满。次五利他行。于中初云以何身者谓摄法上首身能利他故。二云以何心者。修行心方能摄生故。三何者众生者。谓四生等是所化故。四众生住何处者。知世界差别故。五自身住何处能化众生者。住净土之处。后三有三义。一初是自利满。次是利他满。后是二利得果。二三俱自利。论云后三愿显自身故。三三俱利他。论云此三示现如实教化众生故。二约通而言之。此十总是自利。俱是利他。故下论云。此校量菩萨愿胜有二种。胜声闻辟支。一常勤修习无量行故。二与一切众生同行故。解云。此上句自利。后句利他故得知也

第五约所求行位分别者有二。一通。二别。通而言之。或俱是行。以并依愿所修行故。或并是位。以创发在地前终成在地上。如前梁论故。别分中。初七是行。已如前辨。后三约位显。论说后三初名得地校量胜。故此从初地乃至第九地转胜故。二得菩萨地尽校量胜故。此在第十地菩萨位穷故云地尽三得一切地尽究竟故。此在佛地。佛果究竟一切地尽第六因果分别者亦有通别。通说俱因。以在因位故。若尔第十何故成佛。释有二义。一此是地上菩萨愿力示现他方成佛。理实非佛。二地中起愿愿当成。佛今亦未成。或是果。以地前起愿未成为因。得地成就为果。如十度行地前为因。地上为果等。别说中有二。初随显言。前九为因。后一为果。二具摄言。前五成因行。第六知世界智。是所求种智果。第七是所求净土依果。八九亦因。第十所求正报果

第七释文有四。初一句结前生后。起愿方便。二正显十愿。三广摄眷属。四以十尽要期。以显无尽。初中生如是定心者。论大方便大行。故谓巧起大志标期所作。名大方便。是愿心也。依愿造修行成必然。故名大行成此愿行也。于此二作心成决定。更无二念故名定心。二正显十愿即为十段。诸愿之中皆有三义。一举所作事。即行体也。二发如是大愿。明对行兴愿。三广大等显愿分齐。此愿中通论有七种大。一供心大。清净心者。论名上深信清净。以增上敬重故释上也。回向菩提释深也。决定信释信也。此中净心具此三义。又一向不杂余念亦名净心。二福田大。谓有佛斯供故曰无余。供养三种。有人配供三佛。或可或不可准可知。于中香华但表敬。无资用故名敬也。其行供与行敬何别。但义一行可别。资顺义为供养。虔仰义为恭敬。亦配三佛同前。论就三乘说三佛。准下别教亦十佛也。三供事大。谓一切供具等者此有三义。一事事广。如论无量故。二种别多。如论种种故。三皆精妙。如论复胜事等供养。故具此三义。名一切具也。此上行体也。四愿大。谓随行起愿。如经发如是大愿。故此兴愿也。五摄功德大。胜余凡小之善根故云广大如法界。六因大。生无常爱果。因不尽故云究竟如空。七时大。能尽后际。得涅槃常果故云尽未来际故。八立誓自要故。云尽供养一切劫中乃至无休息故。一切劫中所有佛者。顿供养也。无休息者。常供养也。问诸处多明供养三宝。此中何故唯供佛耶。答理实通有。但文中影显。初愿对佛愿供。第二愿对法愿护。第八愿对僧愿同。又复供养有三义。一唯供佛。显行趣求。二供养佛僧。从之求法。三供养三宝。具摄功德。今据初义故唯供佛

第二愿中亦三。初举所作行。于中经有三句为二释。一就始修。二约终成。初中三者。先护教法。谓契经等取应诵等。此是所护法也。书写等解能护持行。余经论说有十种。无性摄论云。一书写。二供养。三转施。四听闻。五披读。六受持。七开示。八讽诵。九思惟。十修习。今此论中且说六种。初五自行护。后一化他护。二摄一切诸佛等者明摄受证法。谓证三菩提自行持也。摄此转授化他护也。三一切诸佛所教化法等者是行法。谓修行者皆是诸佛所教化故。彼修行时。若有障难。摄令住善。使离障故。济令舍恶。使出难故。又未起障难护令不生。已起障难救济令免。上来约始释竟。复名三成就等约终成释。一明法轮不断成就。二证三正觉成就。何故菩萨证二乘菩提。释有二义一所证二空摄生空故。如胜鬘经中摄受正法具足二乘世出世法故。二为物现证。如天女云。若以声闻法化众生我为声闻等。又法华云。知众乐小法菩萨化二乘等。皆此义也。三修行成就。从初发心乃至因满故云如实修行。行成得果故云正觉成也。第二起愿。第三分齐。并同前释可知。下诸愿中。此后二段并更不释应知

第三愿行体之中有四。一明摄法处。如经一切世界等故。此是一切应化身佛。往彼应感成道处故云一切愿也。二明摄法时。谓彼中佛现八相时。此八相亦有化佛具不具者。如天王如来白衣成道则无出家。须扇多佛亦知出世。无众生可化即入涅槃。留化佛。半劫度人。是则无转法轮。若取化说亦得具八。余释迦等多亦具之。此等并约须弥山世界。若就树形等世界总无八相。以彼未必有兜率天等。又此八相论中但释五相。以并舍胜就劣故须释耳。余三不尔故不解释。以处胎必生故不待释。出家胜俗故亦不释。转法益生亦胜不说故不释之。释生兜率有二问答。一以上界为问。难处来答。二以他化等为问。生兜率众生敬心为答。释余相如论显之。三成摄法行。如经我于尔时等。论释中二。一为随彼众生故。自供养佛令他学已故云方便。此成功德行。通于八相。二以彼如来有所说故。启请摄法。请法为生故云方便。此成智慧行。唯约转法轮相。此二总名助菩提法。四明其顿成。论经名一切处一时成一时转。论释。非前后故此名三时转者。是于一切成佛之处同时三转故名也。亦是三请转故

第四愿内行中有二。初正显菩萨所行。二说以化物令心增长。前中论摄为四。一种种者行义差别。于中有二。先世间行。二出世间行。此二有二。若约位分。地前为世。地上为出。若随义分地。教行名世。证行名出。今就后义。初至第六。于一行中修一切故名为广。二第七地中。一切行中修一切故名大。三第八已去。念念任运深入无量佛境故名无量。出世者。正证真智不离法执故不可坏。离妄念故无分别也。二体者诸波罗蜜是菩萨行体故。三业者是诸地中所修之业故云助道法故。四方便者巧相集成一摄一切。要由六相方得显示。何故论中同相异相。此名有相无相者。以于别类各带于总。名有是同。然各互无名无。是异故不相违。二一切菩萨下说前四行。用以化人。于中菩萨所行牒前种种也。及诸波罗蜜牒前体也。本行牒业及方便也。教化下正以化人。令心得增长

第五愿内行中有二。先明所化众生。后明化所成益。前中论摄为六。初粗细者显报相差别。于色中细者无想。是无想天。在第四禅。与广果天同处。外道取为涅槃。修无想定生于彼天。得五百劫无心报。无佛弟子生彼天中。就无色中。前三空名非无想。第四空名非有想。以非有粗想故名非有想。非谓无细想故。论经名非想非非想也。二生依止者是报之所托。四生差别作三门。一明通局。二显宽狭。三释文。初中化生于五趣中二全。谓地狱及天。余三少分。如劫初时。人畜及鬼一切化生。余时通别故。胎于三趣少分。谓人畜鬼。余皆无故。卵湿于二趣少分。谓人畜。余悉无故。人中湿生如顶生王等卵生如毗舍佉母生肉卵出三十二子等。二宽狭者。以四生望五趣。四生宽五趣狭。杂心云。为生摄趣。为趣摄生。论自释言。生摄趣非趣摄生。何者四生五趣不摄。论言中阴是化生。五趣不收。此四约所依处。受生名依止。如余三。依胎依卵依湿化生依何。论释依业。余三岂不依业释。化生业胜。不依外缘。三上界净。欲界不净。四种种身者受报别也。谓下三涂苦上天为乐。人及修罗通于苦乐。五以自业是受生所依故云生处也。六以名色为报。自报体故。四蕴为名。色蕴为色。以色形可睹当相说之。余四是心心法。冥漠非名。不辨故说为名。楞伽云。以名宣说无色四阴故号为名。是谓众生也。二为何义故化者有三。一信入教法故云教化成就。二得小果故云断世间道。道是因义。即惑业也。世间是报。即苦果也。三得大菩提。准此二乘人无不皆向大菩提也

第六愿中。初所求行中有三。初明世界形类故。二明世界分齐相遍故。三世界数多十方无量故。初中二。先举所知。后随入下求能知。前中有四。初约广狭分别。小千为狭。中千为中。大千为广。二义类分别。初类多无数量。二义难分别。三体不可坏。四相不可动。五事不可说。三粗细分别。论云随何等世界意识身者。意识是心。身色色。心粗故世界亦粗。其细亦尔。又如法华中天人见劫尽者是粗也。我此土常安隐者细也。四依住分别。正住者是仰世界。倒住者是覆世界。如蜂窠等。言平坦者无堆阜等故。言方者四方故。如斗形。言圆者团圆故。如珠形。下明能知。随如是世界。以智入中而明了知。二真实义相者。如帝释妙胜殿上有宝珠为网。天珠明净。一珠中现一切珠。一切珠亦尔。互无障碍。世界亦然。于一处中有多世界。多世界尘中复有多界。如是重重无障无碍。如幻业作故者转喻显之。如世幻士作幻业用。令于水处见火火处见水小处见大。皆无障碍。此亦如是世界实尔。故名真实。此是如理智中如量境界故云唯智能知也。三无量相者。如前二相遍于十方名无量差别。尽十方际故名入也。下明能知。皆现前知者不取比知故。愿求此智

第七愿内净土七义中。经内略无自在净。以与同体不多别故。六中初三当相明净。次一约人显净。后二举因显果。前中初体净。次一相净。后一用净。体中同体有二义。一同以法性为体。是故镕融相入无碍。二一以多为体。多以一为体故名同体。是故论经无入字。明即是故不言入也。问与前帝网何别。答前是世界海。约缘起通染净。互相变现。今是国土海。就理实言。一元来是多。多本来是一。亦非彼此相涉等。二具德庄严有三。一神通庄严。谓神变自在。或大小相容。或能起化宣说法故。二光明庄严。常放光明照除黑闇破无明故。三宝相庄严。众宝集成具胜德故。略具此三故云无量庄严。三受用净。谓受用此土。一令成断德。烦恼永尽故云离诸垢秽。二令成行德。净妙行成故云具足清净。四住处众生净。诸大菩萨悉具胜智充满其国故名净。五因净土。因有二。一生因谓修施戒等因。当得净土果。如维摩经说。二依因此亦二种。一以镜智净识为土所依。二后智通慧为依。如下第十地入佛国体性三昧现净土。今依此义故云常有等。六果净。果有二种。一因所生果。二示现果。谓果德自在临机示现。今依此义故云随众生心等

第八愿中。所求行内有十二句。初一总。次十别。后一结。总中不念余乘。释同心同行。谓此愿与一切菩萨也。同心是见理同。愿与同行是学行同前中初五行修行同。后五德用同。前中初三自分行。后二胜进行。前中初一福行。后二慧行。慧行中初正证智。后是后得智。又释此三句。如次即是戒定慧三学同也。初者起行同修名共集善根。情无乖异名无怨嫉。二与诸菩萨所证真如同一味故名同一境。能证智心亦不异故名为和合。论名住寂者所证同也。等观者能证同也。三以后得智其诸菩萨聚会。解说论佛法故云常不相离。下二胜进中。四利他行。若有众生应以佛身方可受化。能随彼心现成佛故云随其等。五自利行有二义。一解于佛果不由他教故云于自心中等。二解知佛境菩提通慧等法。并唯自心。非心外有。于中神力外用。智力内照。自下明德用。六明通体。谓神通上进不退。所作称心而成名常得随意神通。下四明通用。论云通业得名也。于中前三如意通。后一法智通。七一身游多刹。八多身多处现。九得种类俱生身。十成就实智。通达甚深不思之法。下具足菩萨行。是总结也

第九愿中。所求行中有二。先明不退轮行菩萨行。后身口下明不空行菩萨行。前中谓身等三轮。是起行所依故名为乘。成行必然故名不退。二不空中亦二。一作业。二利益。前中亦二。先一句总明三业不空。二众生下别显不空。先明身业所作必定不空。谓令见者无不得法故云众生见者等。二明口业所作必定不空。谓口宣实教物生真智故云闻我音等。三明意业不空。以内心具德令物念见。心喜入法离惑除障。二利益中二。一如药树王遍治诸苦。非独治病故。论云对治种种苦。二如如意宝多治贫病。兼亦通余。经略无此句。言为得如是者总结所求可知

第十愿中。所求行内有八句。初句明所成菩提。后七显菩提作用。前中于一切世界者。谓平满遍于十方虚空法界等一切世界。亦通树形等。非唯须弥界。于此等处现得菩提。下明作业中。初示正觉业。谓于一毛等者前中总说一切世界。此中别辨一一世界。中一一毛端处示现八相成正觉等。论经名凡夫道者。论释。是阎浮提者。且约三乘就须弥山世界说。若依一乘则通树形等及毛端等。以彼皆有可化众生故。云于一毛端乃至示大涅槃故。二说实谛业。谓随彼可化众生心。以神通力为现佛身。以智慧力为说实法故。云现诸如来乃至得佛道故。三证教化业。谓观法无我者离二我故。性净涅槃者是所显真性故示如此法。欲令众生于此法上生信解故。又令众生知于如来证得此法。言必可信故。云知一切法如涅槃相故。四种种说法业。谓以一音异解者释有二义。一约实。谓就真为一。机感为异。如一真身应物现异。二就应复有二。一约类。或为天众现一天音。能令余类各别得解。对人亦尔。余类皆然故。经言一音说法。众生随类各得解。二约法。或为众生说施一音。亦令余人解戒定等。如是一切故。经云一音说法。众生各各随所解也。随机异解。各得成益故。云以一音乃至欢喜。五不断佛种业。谓菩萨所行名为佛种。得佛常起名为不断。故云示大涅槃而不断菩萨所行故。六法轮复住业。谓大圣灭后。令法久住。示佛智地理行果法修多罗等。显其教法。轨则不失。明住持如本。名为复住。故云示众生乃至假伪。七自在业。言以大智慧者法智通也。言神通自在者如意通也。言出生变化者是幻通也。以转变外事故言充满法界者。通结上三皆满法界也。又以法智照理不住世间。余二随事不住涅槃。总三合取名为无住。上来别释十愿竟

第三明摄眷属。此十愿中一一各摄百千万阿僧祇诸大愿。故云诸佛子乃至阿僧祇大愿也

第四显愿无尽有三。初举十法无尽。二以愿反要。彼若有尽我愿乃尽。三以愿顺同彼无尽故。愿亦无尽。此十法中略作三门。一随事分别。随此十法一一皆无尽。对之以显愿。如文自显。二广略分别。谓前九广散。后一略摄。谓众生世界空界心所缘。此四是世间转。法界涅槃起智。此三是法转。佛出世及佛智慧。此二是智转。又释心所缘亦是智摄。以是染智故。是故论云略说三种三转示现各三。是故第十句略摄前九。三依论总别分别。谓初句是总。以为化众生故众生为总。摄余九事在众生中意亦甚玄。应依一乘缘起无碍。准思可见。于别中。一众生住何处。谓世界故。二世界依何。谓空界故。三说何法化。谓法界故。四随所化众生安置何处。令得涅槃故。五亦令得大菩提故云佛出世。佛出世者是远离世间成菩提故。非谓佛应世间名为出矣。以论说名化所置处故。六以何方便巧化。谓佛智慧故。七云何随物心器。谓心所缘故。八复以何法化。谓佛智所入境法即真性理。此名起智者智依此起故。今此论主余前二门相显如文。不待别释。此总别相收。圆融之义义隐在文。故今别显愿校量竟

第二行校量中有二。先明大愿熏心令心调畅堪能起行。二如是则成信者下摄行成人正显所修。前中二。初决定发愿者牒前大愿。以用熏心。二则得下正显大愿熏心成益。十心中初句总。余九别。总中利是增益义。安是顺理义。又障不能动是安也。令行增长是利也。别中一柔软者性善故。二调顺者离恶故。三寂静者不乱故。四不放逸者不失念故。五寂灭者不起烦恼故。六直心者正向真理故。七和润者救护众生故。八不恚者不舍众生故。九不浊者不杂余心故。自下正显所成行相。于此十行略作七门。一显名。二辨体。三明成处。四约心行分别相。五约二利分别。六明次第。七释文

初显名一信佛因果净心不坏。二慈与生乐。三悲能救苦。四施舍珍财。五无有疲倦者策勤求法。六知诸经论书者慧达教法。七善解世法者俗智知宜。八惭愧者轻恶崇善。九堪受者坚固不退堪受法器。十供养佛如说行者。顺佛兴供顺法修行

二体性者有二。一约所依。总以后得智为性。以依此起故。二克别自性。初信当法为性。慈悲以无嗔善根及不害为性。施以无贪相应思为性。不疲倦及堪受俱以精进为性。知经书解世法俱以慧为性。惭愧当法为性。供养佛如说行。通论三业善表无表为性。是故通总有十法为性。一信。二思。三无贪。四无嗔。五不害。六勤。七慧。八惭。九愧。十色

三明处者。此信等行大分三位修之。初在十信位中。即初修学。如信进念慧等是也。二在三贤位修之。渐熟如十藏品信藏等。亦多与此同。三至初地已上修之。纯熟堪任胜用。以将净治诸地。今此所说是后门也。故地论云。此信等十行尽是彰地净法

四约心行分别者。通论此十俱表心。是心无非是行。别分而辨。前三是行方便心。后七是造缘正行故。地论云此十种行显二种胜成就。一深心成就。谓信慈悲等。二修行成就。谓所余七行。此与地持相似。彼云。前三名心净。后七名行方便净

五约二利分别者。前七别显二利。后三通约二利。前中信是自利行。地论云于中依自利行。谓信能信菩萨行及诸佛法。求必能得故依利他行。所谓悲慈安隐释悲。与乐释慈。施以财摄他故。不疲倦者自为他起摄法行。后二以法摄他行故。后三摄护前七。初二护成。后一成摄。由惭愧故。护令离恶。能令信等成无著行。由坚固力。护令住善能令信等成。不可动。由如说行。起后信等故名摄。离垢清净名依止行。由供养佛亦摄起信等善根故

六次第者。初自既证信成佛因果。二伤愍众生处苦流转故起大悲。三誓当救彼具得佛果之乐故起大慈。四为欲救他自无顾恋故。一切悉施。五为益他故。为他求彼世出世法无有疲倦。六由求无倦证解经书。七善知经论故。于众生上中下类善能筹量应作不应作等故。起善解世法。八依应时分量等正行故起惭愧。九于前所作勤无退转故起堪受力。十以堪受力能供养佛如说行也

第七释文中二。先别释十行。后佛子是菩萨下结其十名。前中十行即为十段。就初信中二。初一句摄德成人故。云即成信者。余句显其信德。于中初二句总。次诸句别。后举要下一句结。初总中言乐以信分别功德者。于佛果功德别别深信。二信佛本所行因道能至佛果。下别中初二句广上信因行。论云云何菩萨信行者。信行六度等行。能得增成佛果故。二云何次第成者。信入十地渐得佛果殊胜功德。下明所信果德。论云此菩提本行入者。为简前菩萨本行入故云菩提本行入也。前则标因别果。此标果别因。又前是能入名入。此是所入名入。此所入果中。论摄为六种胜。由此境胜令信心亦胜故云是故信胜也。六中前五别显。后一总结良以此句是末。后结中结因果之内。举其结果入此六摄故也。五中前四智德。后一断德。前中初一寄对显胜。谓十力降魔怨。无畏伏外道。不共过二乘故。此三句合为一。皆悉不为魔等所坏故云不可坏。下三当相辨德。一信真智难测故云信不思也。二信通慧深广故云信神力等。三信种智多门故云信如来等。下一信佛断德中。信从断惑因缘得此涅槃果德故云信从因等。下一句总结。以别说难尽故云举要言也。信菩萨普行是结信因也。诸佛等结信果也。威力是加。等取说也

第二明慈悲二心。于中有二。先明三观为二心方便后即生大悲下正显所起二心行相。前中三观即为三段。初真乐本有迷隔名离。慈由此生。二妄苦本虚情取名具。悲由此起。三于此得失复不了知名彼二倒众生。既尔可愍之甚。双结悲慈。又释此三各有二义。一但无他乐已为可愍。况复此乐本自有之而反远离。二但令离乐已是可愍。况更有苦。设苦是实亦甚可愍。况本虚妄而枉受之。三彼二倒者。若虽无乐有苦。自有能觉知力。容有反苦得乐之期。由无明倒故体有妙乐不知悕求方。复谤云都无此事。虚妄容苦。不知厌离方。乃甘受妄想轮回。由此菩萨起深重慈悲。就初中作是念等者。乘前所信故。今念法甚深。伤物不悟故。起悲愍也。十中初一总。谓超情曰深。深极名甚。别中一离妄计实有所取之相故。云离相。此约遮显。二真理体寂名为法定。恒沙德义寂名义定故云寂灭。三无二我故云空。四无根境等故云无相。五离取舍愿求故云无作。若约治障。论中分别者。即是妄想能取心也。相者即是名相所取相也。取舍者即是妄心于妄境顺处愿取。违处愿舍。对治此三。如次三句应知故。又佛性论此三脱门治皮肉心三障可知。又彼论中配三无性观。次第应知。六性净不杂故云无染。七生德无穷故云无量。八俱益自他故云广大。九多劫方证佛果。坚固故云难坏。第二具足诸苦中有三。初显十二缘相。二如是下结成苦聚。三是中下明缘体空彰有是倒。论中于前初段内前之三支合为一分。二于三界下辨后九支及后二段。合为一分故为二段也。就前中亦二。初一句总。余九句别。总中凡情迷理没于二执故云心堕邪见。别中惑业皆名邪见。释有二义。一是彼品故如恶趣业愚等。二如缘起六相相即无碍。上下文中例同此释。九中初五属无明支。次三是行支。后一是识支。前中初三依法义妄计。后二于追求时心过故。前中初是无明住地。迷覆法体障其慧眼。论名蔽意。故云无明痴等。次二慢爱由痴。迷覆因果之义。妄计内外。初一于内执我。自高陵物名为憍慢。建我如幢。恒起名常故云常立等。后一于外贪取。爱网自缠故云堕在等。又上三句。初一痴使。二慢使。三爱使下二追求时过。一于可得处诈善外相生谄曲过。二于不可得处情忌在内生嫉妒过。又妒他内报嫉他外财。由此生生卑贱鄙陋。是妒心为因。资生不足。嫉心为因。此释经中而作后身生处因缘也。此经名悭嫉者。于已得生悭。可得生谄。不得生嫉。又由悭自财故。资生不足。由嫉他身故。身形贱陋。下三明业支。一总明三毒造业。后二别显业相。初中于乐受生贪。苦受生嗔。舍受生痴。舍翻前二故云彼颠倒非迷。前二名为颠倒。由此三毒集起重业。下别中初句内心思业。后句动身语业。前中烦恼如风。思心如火。烦恼动心如风吹火。此思中始也。常令炽燃思之。终也。论云于怨恨时互相追念者。释嫌恨吹心也。欲起报恶业者释炽燃也。二明起业者从思发动身语业也。颠倒是烦恼。烦恼发业。业还与彼颠倒相应。谓作恶时迭相加害者望杀业说。第九一种明识支。以识支亦是所引亦是能引。今取能引。以彼能持惑业种子。令四流不断染诸善业悉成有流。四流者。谓欲界中一切烦恼。除见及无明。名为欲流。色无色界一切烦恼。除见及无明名有流。三界无明名无明流。三界见名见流。流者是流注不断义。心意识名。有通有别。别言本识集起名心。末那审思为意。余六了别为识。通则俱有可知。言起种子者有二义。一随流造业。熏在本识名起彼种。二由无明行能引识中五果种子。令随业生名起种子。今取后义故云起也。第二段于三界地下辨后九支。于中论主分为三相。一自相等者释有二门。一约分位。二约随义。分位者。自相者谓明现在因缘体状故。同相者谓未来因缘同现在故。理实现在亦有生者等。未来亦有识名色等。今约分位分相故立二相。三颠倒相者显缘体实空。显执有是倒。二约随义者。一约从因生微细行相。是缘起自相。二约果相显彰。缘起过患遍通果位故云同相。犹如色法碍为自相苦无常等为其共相。共犹同也。此亦如是。从生名色牙即生义。次第乃至有彼老死。过患同故。三缘实无我。妄取为倒。问同相中。二支一向是果。一向现行。自相七支为现果为因种。设尔何失。俱有过故。若取因种则不应言三界地生牙。若取现果则彼前四不异生等。后三复非所生果摄。答此等并是现生果位。却谈因名以显自相。就自相七支内。此中和合者。是论中共生义。亦是不离义。论分为三。一报相名色共阿梨耶识生者。谓名色支中有义通摄一切名言种子。阿梨耶即识支。通有三义。一依杂集论第四。以业种为识支故。属能引识种入名支摄。是故此文前三支一处释者。以俱是能引故。为四流等润彼业种及五果种。转为有故。令其生果。是故前言起心意识种子。由起彼种子。令三界地生苦报牙。二以本识种为识支故。唯识第八云。此中识种谓本识因。是故此中识种及名色等种为前。惑业引润力故。起此种子令生苦果。三现行第八亦是识支。唯识第三引经证彼第八是识支故。是故此中因相云名色。不离本识故。谓此共识所生名色生已依于现行第八。为彼执持故名因相。理实此中识等五种由前熏发同时而生。但依当来现起分位有次第故说为前后。是故名为彼果次第相也。爱取有三虽非所生。然正生时具有此故。唯识论说生引同时。是此义也。问此三相与摄论中本识三相何别。谓彼云一自相谓本识自体。二因相谓种子识。三果相谓异熟识。答此中三相与彼不同。彼中一本识从种生边名为果。能持种边说为因。此二无二名自相。今此明本识与能依和合名为报相。二显能依无体。依于所依故说此识名为因相三能依相尽。唯所依转。转入彼位名为果。亦以本识转为此果。是故渐略余相皆尽。唯有识在。此上约始教。若约终教即此本识是如来藏。初即与染和合次即染法依真。后乃染不异真故唯真转。二如是因缘下结苦聚也。是中无我下显颠倒相。并如论释可知。第三凡夫可愍下明彼二颠倒。谓失乐不知。得苦不觉。第二菩萨于此下正起悲慈。先见苦生悲。后令得最上乐故生慈。此二皆与后智俱故皆名智慧也

第四施行中三。初总。次别。后结。初总中句别有五。一牒前慈悲。二深心住地。三于物不惜。四重佛妙智。五尽舍一切为求彼智故。论云求佛无上大妙智故。二与金下别辨。九句。前八外财。后一内报。外中金等是贮积。余是所用。此二中不摄内报。通九为二喜。一金等摄益令物生喜名藏摄喜余八利身名利益喜。亦摄内报。一严饰。二代步。三代苦。四自在。五戏乐。六眷属。七悭著者物未必上。但悏己情名所爱着。八称意。并如文可知

第五无疲倦行中三。初牒前起后。二勤求下正显不倦之行。谓前用财施摄之未具。更为求法转成大益。世间胜事亦堪益生。是故世事亦是所求。三是故下结成行相

第六知经书行中略无牒前。正显及结可知

第七世智中初牒前。二善能下正显行相。中论云随自己力者量己智力也。随彼能受者量众生堪闻也。于自于他有宜应作。无宜不作。如论中说者如瑜伽菩萨地菩提分品具显此义言上中下众生者谓胜中劣众生也。随其所应随其所宜而利益故。三是故下结

第八惭愧中。初牒前起后。二即知时下正显行相。谓虽得世智能为利益众生。然于或刹那时或昼夜时或所作成就时。每自斟量。不令自心随逐世法。常生惭愧。不失自行故云习自他利道也

第九堪受中。论名坚固力。谓是精进于上八行遍能策进故云如是功德。即信等也。然精勤有二。一自分成处无退舍。二胜进分中修不息坚。心辨此名堪受力

第十供养修行中。利供是财。行供是法。即上二事可知。上来别释十行竟。下结位显名中。初结位。此是当地离障所显地之净法故云起如是净地法。前安住中亦名净地法者。彼是能治净行此是障净之处。二显名可知。行校量竟

第三果校量中。四果之义略作十门。一释名。二体性。三属因。四摄果。五分齐。六通局。七同异。八行相。九次第。十释文

初名者调柔有二义。一约能调。谓供养摄化及回向等。能炼信等名曰调柔。地满足故称之为果。此则调柔之果。依主释。二约所调。谓信等十行。为供养等所调炼故令离垢清净故名调柔。调柔即果。持业释也。二发趣果者。谓亦二义。一发于前地趣向后地。行相差别名为发趣。地满明解名之为果。此从境为名。二在于此地满处发正慧解。求趣解知后后地中所有义相名为发趣。发趣慧解即是果故。三摄报果者亦二义。一王位之身酬因名报。从于此地胜福所生故名为摄。此则因力果相为名。二胜生之身业感名报。属此地收故名为摄。摄报即果故以为名。四愿智果者亦二义。一内证愿成。通慧外用。体用合举故名愿智。此在地满故称为果。二以愿力助智令业用无边故以为名

二体性。初果以信悲愿相应智为性。以信兴供悲化众生回向愿求。谓初地后得与此三行相应断彼粗重名调柔故。二以欲勤慧三法为性。谓胜进道中寻师求法勤无懈惓。正慧明解名发趣故。三以报五蕴为性。四如名以愿智为性。又初是行。二是解。三是报体。四是业用

三属因者有二。一别。二通。别论调柔是前安住地分及行校量家果。二发趣是前释名分家果。以彼念当得中解诸地等。此处显故。三摄报是前初住地家果。以此王身是依何身。果此中常不离念佛等。是为何义果。此中于一切众生为首为胜等。是以何因果。此中能动百世界等。是有何相果。四愿智是前愿校量家果。二通论四果遍属此地可知

四摄果者。此四中几是等流果及离系果。谓初二。几是异熟果及事用果。谓第三。几唯事用果。谓第四。几作增上果。谓一切

五分齐者。初二是其行修方便。后二明其行报纯熟前二唯在地满之处后二该于当地始终。谓从初住地乃至地满所受王身名为摄报。所有业用说为愿智

六通局者。发趣一种文局初地。义通十地。其余三果义局初地。文通十地。何以得知发趣义通。释以后地地行既渐增解亦明故。若尔解行何故不齐。释解可悬解。行无悬修。故不类也。等是悬解何故唯在初地释。以是初首故。又是见道可悬见故。三果文通。何故义局。释以地地皆有。是故文通。各各属当地。是故义局

七同异者。前之三果诸地有异。愿智一果诸地齐同。所以尔者良以诸地相别难分故。以前三显其优劣。实德须论故。明愿智。彰地平等。又前约三乘显地差别。后约一乘明地齐等。谓以一地即一切地一切地即一地是此义也

八行相者通论四果。各通二利。别显其相。发趣自利。余三具二

九次第者何故于先说此调柔。以前说信等十行。今此转更炼使精妙。义便先彰。既当地行熟必趣后地。次明发趣。问若尔何故瑜伽住品。先明发趣。后说调柔。答此是本经彼论引此。计应不别。然论主回之随别义意义。意云何彼论意说当地修行。信等满则便推求后诸地事。是故先明发趣然后方说当地炼行。故后辨调柔。此约说时以明次第。今此本经中约行时说。是先调柔行后求上进。亦可法实随说皆得。三前二行解细故先说。摄报是粗。是故后显。若尔愿智非粗。何乃最后释。前三俱是差别果故。同在先论。愿智是其无差别果。是故后说。前中行细。解次。报事最粗。以为先后也

十释文者。文中四果即为四段。初中三。谓法喻合法中四。初见佛是能练行缘。二心大下明所练行体。三多以下显别地行相。四是菩萨随所下明所炼净。初中此名少见。论名多见。并是总言。非是数。数法长引声读其义相似。以胜通力飞往他方。见佛色身及闻正法。即他受用身也。又以内正愿不动一处。见法身遍满义等。又依瑜伽住品。正愿得生受用土中。常见佛。地论通力愿力。即是瑜伽二因缘见佛也。此中一愿二力亦同彼论故云以愿力故。下明所见广多。约数渐增。论名方便示现多佛等故。二行体中成三种行。一供养佛僧行。三供如论。二以是下回向菩提行。三是菩萨下教化众生行。三别地行中。论有二行。二摄利他。檀度自利。此略无檀度者。以二摄中施是财施爱语是法施无畏通二处。是故二摄以摄具檀行故不重显。四是菩萨下明所炼净。于中初牒前供佛化生。二行为能炼也。行净地法是信等行。是所练行也。如是功德牒所练信等。回向种智牒前回向。亦是能炼炼此所炼。令出障成用。谓前地满时已得清净。今此更净故云转益明显。此出障也。言堪任有用者调柔德成堪为胜用。第二喻中金师喻菩萨。金喻信等行。火喻所见佛。数数入火喻供养等三行。此名随火力。是论数入也。调柔等喻所炼净。问余经论说。佛性犹如在矿之金。炼出令显。此中复说。信等如金。此有何别义。答佛性有二。一理性。二行性。此二地前为障所缠。如金在矿。一大僧祇勤修资粮。及加行力发本行性。生得初地初无流智及显理性。一遍满义如金出矿。此中信等是行性所发初无流法。又如彼金新出沙矿更须火练令其清净。地法亦尔。初一刹那所生无漏唯行性力。第二念去更重新熏增益转盛。况今至此地满果位烧炼纯熟所况如是。余文可知

第二发趣果中有二。初正明发趣行。后是名下总结地相。前中有四。一法。二喻。三合。四结。法中亦四。一问。二知。三行。四到。问中三。先别问初地。次别问二地。后总问余地。于中相貌者。谓立障立治阶别十地以为地相。以对地体说为相耳。言行者论中名得。即是出世无分别智证得所证真如。言果者依因本智力得有后得智。然此后得通缘俗故名世间。无分别智故亦是出世。是故论名世出世智。又此三中初是无间道。与惑相翻。二是解脱道证彼无为。三是胜进道后智进修。何故不说加行者以地前加行非地摄故。地上加行胜进收故。此三并是诸地所修。言成地法者信等十行是诸地所行。能成满地故须问此二种法也。是菩萨善知下明第二知。于中十一句作三门。一散为十一。二摄为五。三行体唯三。初十一者初即对治十障故。梁论第十云。地是对治义。二成坏者揽行成位集故名成。诸行各住散故名坏。三行果者诸地正证及后得智。四分别得者诸地所证法界各别。又分别得相有四种。如摄论。五清净行者。诸地后得离染行成。六从一地至一地行者依前起后。地背舍相。七处非处者所断二执名为非处。所证二空名为住处。八转住处者自地行满不滞住故。九胜进者胜进趣求后地住故。十不退者念念趣后不退息故。十一菩萨净地入如来智者。善知因圆必克果故。二论摄为五。初二名观方便者。一观障对治。二观地成坏。初约所断显观。后约所知明观。次三名得方便者得之言证。一始证。二正证。三证满。次三名增上方便者。修进后位名为增上修。不顿成。初中后别故有三句也。次二名不退方便者。一胜求。二不息故云不退。末后一句名尽至方便者。菩萨位穷名尽。至佛果位名至。此五皆善巧而成同名方便。三摄为三者。谓此五种不离诸相得果。初一是相。次一名得。第三是果。第四显前三种进修不退。第五明三因穷入果。是故唯三也。诸佛子下。第三能行中。既喜知已虽未发初处。然去心决绝。必定能行故云乃至无有障碍。言得诸地下。第四明能至中。以必定能至后菩萨地及佛智地故云得诸地乃至佛慧光明。第二喻中亦四。商主喻菩萨。将人喻利他。初问中向于道路行处。宿处皆有利害。并须问也。二未发初下。喻知前问行路不问宿处。今知宿时不论行处。文绮互。又前处此时。文互显耳。三能以智下喻能行。既能善知行处宿处行时宿时各有利害。是以筹量辨诸资具。避害就利。令达所至。凡论导师要具此二故。论云。一不迷道方便。二资具利益方便此之谓也。故云乃至正导众人也。四得至大城下喻能到可知。第三合中初问及知通合二。尔时下别令能行。三乃至令住下别合能到。第四是故下结彼勤行可知。上来别辨。诸佛子下第三总结略说

第三摄报果中二。先明在家果。二若欲舍家下明出家果。前中亦二。先明上胜身显其报胜。二能以大施下明上胜果显其行胜。又亦前是异熟果。后是等流果。前中问此王身是实是应。答若约初教。未离分段应是实报。然其所受非唯此身故云多作。不言纯也。以生净土受彼身故。又是应化。以有妻子非实身故。若约终教。初地已上舍分段故。变易微细非此身故。安立十王。为别十地。非谓十地如实为王。如璎珞经。地前信等四位。如次已作铁铜银金四轮王故。岂可十信已作阎浮王。今至初地还作彼王。故知前寄四王以别四位。今寄十王以别十地。故不相违。二上胜果。谓依王报起胜行也。施中二。初自分行。二常生是心下明胜进愿。前中初随有摄生行。二是诸福下明智念无染行。又前正成利他。后不失自利。前中二。初以施行调物。于中二。初巧施调悭。二常施恒摄。二所作下四摄摄生令其入道。二自利中论摄为四。初三名上念。念三宝故。次一名同法念。念诸同行菩萨故。此一两向用。以经中略无念僧故。次二名功德念。念自他行是所行道也。自体是波罗蜜也。转胜是十地也。下四名求义念。念佛力等。是所求境义。又是大义利。又此等并随有摄生时不起妄念故云念也。如论云。如是诸念于事中行已者正明随有摄生时也。言成大恭敬除妄想者明不失自行。谓上念三宝故成大敬念。行离障故云除妄也。下论重释。约施中离三轮及所求菩提。二约四摄等云如是作业中等。皆离四事可知。第二胜进愿中。初六自德。后五摄他。前中为首唯总。妙等唯别。胜大二种。亦总亦别。后五非总非别。此经略无微妙。就后五中。初一导以阿含。后四皆证。一成断德。后三成智德。智德初教令得出世名师。二令学位穷满名尊。三令得佛果位种智。并如论释可知。第二出家果三。初出家方便。二于佛法中下正明出家。三须臾下明出家所得。所得中二。初得三昧胜自在力。以是用本故。如经得百三昧。二依三昧所作胜。于中有十。初见百佛者。谓于十方各见十种他受用身。于彼佛所听法习智故。又瑜伽住品云。以净天眼能于种种诸佛国土见百如来。二知佛力者。于佛神力所加诸说法菩萨所闻法习智故。瑜伽云。变化住持菩萨住持皆能解了。上二自利行。三能动者。神力遥化。令生信故。后三身往授道。四飞过者。往至能入故。五能照者。正见彼世界故。又是身光照普令他见故。六能化等者。正教化故。上四利他行。七住寿者。五种生中摄取胜生故瑜伽云。若欲留命能住百劫。八知过未等者。为化众生作离恶为首故。是故说彼过未善恶业道。用以教化诸众生也。九善入者。为欲增自智慧故。于蕴界处等种种法门能正思惟简择义理。十变身等者。速疾变身以为百故作多利益者各百菩萨为眷属故。以百身起彼利他之行。速益万众故名作多利益速疾行故。然初地已上入佛境界。所化无量非局限此。但为寄数别于十地。辨斯百耳。下二地等明千等数。皆准此知

第四愿智果中。若以愿力者内证正愿久积成也。自在者智力作用也。以愿自在。诸所示现。过前百数无量无边。纵百千亿那由他劫计不可知。问论经所示现中有十一事。何故此中总不显耶。答大都与前百数所示十一种法不多别。故不重辨。少有不同。如论显之。长行散说竟。第二偈颂中有四十五颂半。分为三。初二十二颂说分。次二十一颂半颂校量胜分。后二颂结说。前中分十。初二颂依何身。二有四颂为何义。三有二颂以何因。四有三颂有何相。五有二颂半颂释名分中多欢喜。六有一颂念当得。七有二颂念现得。八有一颂半颂安住中信心成就。九有一颂修行成就。十有三颂回向成就。上来十门颂前百句正地竟。下颂校量胜分。于中六。初五颂半颂十大愿及十尽句。二有六颂颂行校量信等十行可知。三有二颂调柔果四有二颂发趣果。五有五颂半颂摄报果。六有半颂愿智果。末后二颂结说分齐。初地竟

第二地中七门同前

初释名者。依唯识第九。具净尸罗远离微细犯戒垢故。十住论云。行十善道离诸垢故。摄大乘云。由极远离犯戒垢。世亲释云。性戒成就非如初地思择护戒。无性亦同。瑜伽深密并同此说地论释名如前本分

二来意有三。一地论云。如是已证正位。依出世间道因清净戒。说第二菩萨离垢地。解云。已证正位是前初地。依此出世修三学行。戒最居先。故此来也。二前地创证真如。犹有微细误犯戒障。不能性自不待思择护持净戒。故有此地成斯戒行。三前施此戒。义次第故

三所离障者。依十地论。名邪行于众生身等障。梁摄论第十云。依身等。诸众生起邪行无明。唯识第九云。二邪行障。谓所知障中俱生一分。及所起误犯三业。彼障二地极净尸罗。入二地时。便能永断。由斯二地说断二愚及彼粗重。一微细误犯愚。即是此中俱生一分。二种种业趣愚。即彼所起误犯三业。或唯起业。不了业愚。解云此二愚中。初是能发。后是所发。问所知障不能发业。亦非润生。如何此中能发三业。答唯识第一生烦恼发犯戒业。通所知障。此约误犯故不相违。又此二愚。一是能发业愚。二是不了业愚。若依此释二愚皆用无明为性。深密经瑜伽论皆同可知。又唯此地中总除五法。一所知障一分。二彼所发业。三彼障粗重。四及烦恼粗重。以十地修位虽不断烦恼障然必伏彼断其粗重。五及离报障相应心所离缚不生。准前知之。此上约始教。若依终教。如梁摄论等。其烦恼种初地永尽唯有彼习。其所知障一分粗者亦初地尽。余分及习于诸地中各别正断二无明为缘劣无流业。三所感变易方便生死报并是所离。准前知之

四所证者依唯识第十证真如最胜义。谓是真如具无边德。于一切法最为胜故。无性摄论第七云。第二地中由最胜义者。谓此空理一切法。中最为殊胜。如说离欲最为殊胜。了知此义。得入二地

五所成者。谓成就戒度。具足三聚及十善行。又如论。具足八清净等

六所得者梁论云。若通达法界最胜功德得一切众生最胜无上菩提果。此约当得。若约现得二界同前

七释文有三。初偈颂赞请分。二正说本地分。三以偈重颂分。初中五颂分二。初三明大众庆闻前地。一闻法心喜。二身业散华。三语业赞叹。后二解脱月正请后地。一知众心。二正为请

第二正说分中论分为二。初发起净。后自体净。地果同前更不解释。亦不科出。谓正地三聚无误犯垢名自体净。直心趣彼名发起净。论云依清净戒直心者。谓依此直心持戒纯熟名清净也。性戒成就至自然行者。依直心戒净成就正地性戒。不待思择。性自持戒故云自然行也。又中三。初结前标后。二正显十心。三结行入位。就正显中。直心是总。别中十心内。初六律仪戒。次二摄善戒。后二摄生戒。前中一不恼他故名柔软。自有人虽直心持戒然心刚犷共住恼他。今此反彼故名共喜乐等也。二自不起恼故名调和。谓于违顺任运持戒不为惑牵故名自在力等。又不为戒取烦恼所杂故也。三能受他恼故名堪受。论中无此。四能除细恶名不放逸。谓善护诸根不令误犯。误犯尚离。况有故犯。此与正地何别。释此作意不误。正地性自不误。五不恃己戒自高轻彼故名寂灭。又释得戒实相。心无所执故不自高。名为寂灭。六遇难坚持不坏名真。谓无有难持之戒。而不能忍苦持之。如世真金烧打磨等终不改变。又释此亦属摄善法戒。瑜伽住品云。六者于诸妙善菩提分法常勤修习。意乐下二明摄善戒。七修善无厌。不杂懈怠故名不杂。论中所得功德不生厌足者总标意也。依净戒者。依前离戒。更求等者。进修摄善故名胜戒。下论云摄善法戒净者。于离戒净为上故此名胜也。乐寂静者增长此心故。瑜伽云。七者即于复修为随顺故。乐处远离意乐也。八修善求佛。不愿人天故名不贪。下二摄生戒。九悲心益生故名为胜。谓愿常在世。摄化众生名为不断三有之愿。此是大悲不住涅槃。瑜伽云。远离下乘趣证大乘意乐也。十智心无染故名为大。谓虽随顺诸有摄生。而其内心常不染世。此是大智不住世间。瑜伽云。欲一切有情义利意乐。又瑜伽中于前地未起此十心意乐。此经二地初亦相似也。言以是十心入第二地者结行入位也。瑜伽云。即由如是十种意乐。成上品故。极圆满故。是诸菩萨入证第二增上戒住同于此也

第二自体净中。论主分为三聚。此三聚戒义略作十门分别。如别说。文中初明离戒净。以离杀等故亦名正受戒净。亦名律仪戒。二从作是思惟一切众生堕恶道下明摄善法戒。三从此十不善业道上者地狱下明摄众生戒。就初中有三。初总明此地性戒成就。二舍弃下别显远离十恶业等。三菩萨如是下总结常行。初中住离垢地自然远离者。正明性戒成就。不待思择。方离杀等故云自然离也。于此十恶乃至微细。亦皆远离故云离一切杀生等也。瑜伽住品云。于此住中性戒具足。极少邪恶业道所摄诸恶犯戒尚不现行。况中上品也。又远离杀等。泛论有四。一但防三业粗过。如凡夫戒行。二止甚细犯。如三贤菩萨。上二约现行。三除种子。谓初地。四误犯亦离。即此地。上约初教辨。又有四种。一防现起。二除种子。三灭习气。四显性净。后二是此地。为性净难彰。寄除杀等以显彼净。上约终教辨。又为地体超绝相实难分。寄显地别。非即是地。若不尔者。岂可地前回向等位行相极深。今至地上方离杀等。故知寄显地相差别。后禅支等当知亦尔。上约圆教辨

二别释文中。离十恶即为十段。初离杀中别辨内三。初因离者离杀因故。此有二种。外具名受畜因。谓刀斫杖打余咒药等。但是能杀之具。皆悉远离。梵网经名离杀缘也。二内起贪等名起因。实具三毒。何故论中但举贪嗔。释痴心邪求祠祀杀生。为难遣故。非谓不离。是故对治离中别明此离。问贪嗔俱足起因何故文中。离嗔处言无嗔离贪处不言无贪。但言有惭愧耶。答杀业道中嗔为究竟故。杂集论第七云。杀生业道贪嗔痴为方便。由嗔究竟。如杀生。粗恶语。嗔恚业道亦尔。杀生谓为皮肉等是贪。为除怨等是嗔。为祠祀等是痴。离无慈悲必不杀害他有情故。是故由嗔乃究竟也。言有惭愧者。谓贪利杀生没命无耻。反此有愧故无贪也。梵网经中名离杀因。二言于一切下明对治离。谓内起慈悲对治杀事。何容得有杀法成就。梵网经中名离杀法。此中对治即离名。对治离不同因离等。治行有二。一授与世出世乐因。二与彼二乐果。此中悲心是论安隐心也。言常求乐事者通结因果之乐也。三果行离者正离杀业。揽因成杀故名为果。离此所作故名果离。有二。细约心念恼尚不曾有。况粗约身害。是即亡言。论中粗内五缘成杀。杂集第七云。亦有五缘。一事者谓有情数。二意乐者谓此想及必害意。三方便者谓为害故加刀杖等。四烦恼者谓贪等五究竟者谓彼众生由方便故。或无间死。或后时死。地论五中略无烦恼。杂集五中略无有他以简自害。二论合释通具七缘。一他简自故。二众生简非情故。三众生想简迷心故。四杀心简错误故。五兴方便加刀杖故。六起贪等简慈救故。以菩萨为救重罪杀不犯故。七究竟命断故。阙缘辨罪。思准可知。下诸戒中皆具此缘。亦准之。离杀生竟

第二离盗中亦三。初因离中准杀应有二因。资生不足是外因。贪等为内因。何故不说内因。释以同前故不重说也。又释内怀知足为离盗因。又初地上得无尽财故说资生常足也。二对治离者于自资财当能舍施令当来大财报果不坏故。论经名不坏他财。谓他世财也。此经略无此句。三果行离者亦二。细谓草叶。粗谓资具。杀淫二业于他众生正报处起。细约心念粗就身事。资约外财物有微粗以分轻重。论经五缘此中略无三四。余如论显

第三离邪淫中亦三。初因离者自足妻色故。以初二三地相同世间故。寄同凡夫故云足妻也。又释此地摄报寄作轮王故有妻色。又释梵行有余故云自足也。二对治离者现在梵行净故。不求未来妻色故云不求他妻。此经略无此句。三果行离中亦二。初微细约心故云不生一念也。二粗重约身。身中邪有三种。释有二门。一约粗。二就细。粗中初不正有五。一他女。二他妻。三己亲。四姓护。谓上族非下姓所配等。五标护。谓己许他。他已下信。为标诫所护。此并如地论智论第十五云。若女人父母兄弟姊妹夫主儿子世间法王法守护。若犯者名邪淫。二非时有三。一者智论名梵行护有二。一出家。二一日戒。又自妻受八戒时。二有孕子时妇人厌本所习。又为伤胎。三乳儿时淫其乳竭故。皆是邪淫。三非处。谓非道有二处。可知。二约细显中。不正者非己妻妾。菩萨不自受畜妻妾故常不邪淫。二非时者谓修戒时。菩萨无时不修戒故究竟不淫。三非处者是过粗鄙。永断不为。若细辨邪正二淫俱不可得。上三身业戒竟

第四离妄语中。初句总。后别。别中二。初对治离。二果行离。以对治离即是因离如初杀中因有二。谓内外。后盗淫中单举外因。谓资财不足及妻色不足。其内因贪等。更不重举。今妄语中既无外因。内复无别故。论云无外事复无异因故。是故诳他之思心是妄语因。离此即实语。成实语即是谓离故不别说对治三中初常实语者不违自心。随想语故。二谛语者审谛思量如事而语故。三随时语者离过语也。自有发语心事俱实而言不合时自恼恼他。菩萨不尔。善知时语也。二果行离中亦二。举细况粗可知论中覆见忍见者。依大婆娑论。覆相妄语名为覆见。覆心妄语名为忍见。谓本见前事实生见想。诳言不见。此覆己所见。名为覆见。又实不见前事妄生见想。诳言不见。于事虽实。于见有违故名忍见。此忍己见故

第五离两舌中。新翻名离间语。言无破坏心者是对治离。以破坏两头是所治故。于斗诤下明果行离有二。一细心中忆持其事。二粗身往异处说。论云此二种明者。谓于两头各诈现为明。此由成于两舌故如野干诈亲师子及虎破其两处等。又云此闻不向彼说此坏故者。此明举经显离也。谓惧彼前人闻此语已于此人所起恼坏事。是故不说。又释恐彼人于此人所和合心坏。是故不说。彼闻亦尔。余如论说

第六离恶口。亦名离粗恶语。论中初果行离。正离粗恶之语。论经中有十六语。此中有四语。一粗犷者是损他语。能令他嗔故。二苦者是苦他语也。三恶者是鄙恶语。四自坏坏他者。已有同意乐事。自身失坏令他失坏故。余语如论。二对治离。谓润益语等有十二语。此经略无。如论具显

第七离无义语。亦名离绮语。亦名离杂秽语。初对治离中。论经九句。此中有五。于中初二教化语。化令生信故。言常自护者。言合理不令失故。言应作不应作者。显不失之相。谓若见在不善众生。令舍不善安住善法。彼时教化成利益故。方始语故。故云知时语。次一名教授语。教令起行故。论中依展转等者。谓互相策励修胜行时。说义说法故。名利益语也。次一名教诫语诫令止恶故。论中展转举等者。互相举罪令忏悔时。及有诤事。令殄灭时。作如法语及阿含语故云顺法语也。后一名摄受语。谓说法摄受众生。令修行时。如威仪住而发语故名筹量语也。二果行离中。戏笑是细故作。是粗二俱离也。余如论辨

第八离贪下三明离意业恶。皆但有对治离。无余二离可知。论中不贪有三种。一事财属他事此有二。谓已摄者财事现在摄想者。物虽不在遥有所属。彼有护想。此二名为若物属他也。二体谓财体也。此亦二。谓金等但是所用不堪吃着。衣食有资身用。此二是所贪之境故云他所摄用也。三差别谓贪有下中上三种故。谓初起希望。二愿得属己。三起夺取意。离此三贪故云不作是念我当取之

第九离嗔中。论经内有三。初摄治。二离障。三起行。此经略无后二。就摄治中。论有六心。为五众生。此唯四心。一于怨起慈。二贫苦起悲。三于着乐众生起润益心。以法津润。令离放逸故。四发菩提心。劳倦众生起爱念心而作利益故。又论云此慈心等有六种障者。明前六心有此六障。此非分别者非二三等障同障一治。亦非二三治同治一障。不可如此分别故云非分别也。亦非一一各别相对。但是通障及通治也。六中一约怨生长。是嗔力耳。二约亲不生等。是恨力。三约自善不生等。是垢力。四约不善生长。是害力。五约他不爱事等。是妄想力。六约爱事不生等。是妒力矣。故云文句次第说也。无量恶行根本释等字也。余如论可知

第十离邪见。论中七种见作二门。一约行。二约人。约行中。初一离邪离小乘故。次三解邪。颠倒见故。一邪见。二戒取。三见取。次二行邪。藏非诈善故。一藏非。二诈善。后一信邪。信世间故。对治此七名离邪见。二约人中。初四是梵行求众生。一是同法小乘。后三邪见外道。次二是欲求众生。后一是有求众生。今此经略无异乘及戒取见。余五中深信罪福是不奸欺。余如论辨可知。言菩萨如是常护善道者第三总结行成也。初离戒竟

第二摄善法戒中有四。一智。二愿。三观。四行。初言作是思惟众生堕恶道者由十不善者。此是智有其三义。一何所知。知众生苦因果。二何因知。因前自离十恶。即念众生不能离恶。三何故知。知物有恶自行善业为欲化他。是大悲故。论中乘恶等者释道也。亦名趣苦身苦处。释恶也。常堕者释堕也。上释苦果下释苦因。谓十不善业摄到一切恶果数故。论中以数摄经中十也。恶摄不善。果摄三涂。到摄其业以业能到果处故。受解集义。谓集果名集。纳果名受。义相似故。行解因义。谓生果名因。趣果称行。义相似。故第二我当自住下明愿中亦三义。一何所愿。愿自住善亦令他住。二何因愿。因前知生由业堕恶。三何故愿。以大悲心不舍离故。故自行皆为众生。文中二。初总举愿事。二何以故下征责释成可知。摄论颂(云云)。第三又深思惟下明观。谓通观十善有其五重。义亦有三。一何所观。通观障。所治十恶能治五重。二何因观。因前愿自住善亦令他住。若不识善知何所住。三何故观。观善为欲摄起行故。文中有二。初思惟十不善堕恶道。是所治障也。二行十善下明五重十善。是能治行也。问此中十善与上律仪戒十善何别。答前望止恶今约作善。止作不同故分二位。问十善翻十恶。十恶既唯一十善何得有五重。答计翻不善亦应是一。但以善随无智故名世间随智胜劣故有出世间之四位。问善既五重。所翻十恶亦应有五。何者谓人天十善翻恶道十恶。声闻十善翻人天十恶。乃至如来十善翻菩萨十恶。应如是耶。答不尔。翻善之恶违理损物。不善相粗不通上位。故唯有一反恶之善顺理益物。福随于智通于上位故有五种。是故五位所离恶齐故唯一种。所成善异故有五重。此即止同而作别也。是故此地是菩萨十善。尚非二乘。况同凡位。若约寄言亦摄凡位。问不善业粗不通上位。不得约上说有五重。不善望下。未知亦有阶降以不。答约心约境亦有五种。一极重如如来秘密藏经云。如父得缘觉道子断父命。是杀生中重。余如上说。二稍重如杀人等。如戒经说。三重如杀畜等。如此中说。四轻如秘密藏经。后复次说五无罪。如菩萨戒说为救生多命及救无间业而断彼命不犯等也。并具如前十不善章说。五重之中。初人天可知。二声闻内。论云实相观者总观十恶及人天十善。具四谛故名实相也。下别显二门四谛观。如论可知。与此四谛观智和合修声闻行。论中智慧同观。修行无分别者有二义。一约境。于前善恶二种四谛同观齐修无别异故名无分别。二约智。谓此声闻观谛之智。与十善道和合故名同观同行无分别也。上来总句对下彰胜。下别有五句。对上显劣。论中五内。初三明劣菩萨。后二对劣缘觉。五中初因集有二义。一性因。二习因。今此论中且举习因。谓过去所习狭劣善根。依之集起今所成行故因集。亦是集成种性。名曰因集。如经若心劣等可知。余四论文自显可知。第三缘觉十善中二。初总。二不从他下别显有三。初不从他闻。自然得知者。地论名自觉义。谓不假佛说及菩萨故。瑜伽第三十四。独觉地中明独觉种姓有三相。中第三相云。本性独觉先未证得彼菩提时。有中根种性是慢行类。由是因缘深心悕愿。无师无敌而证菩提。二不能具足大悲方便者。地论是不能说法义。谓不起心说法者释不具大悲也。不堪说法故者释不具方便也。瑜伽名薄悲种性。由是因缘。于说正法利有情事。心不爱乐。于少思务。寂静住中深心爱乐。三言而能深入乃至辟支佛乘者。地论名观小境界义。谓观微细因缘境行故。此中小境有二义。一约十二缘。但有苦集二法故名小。二是缘生深细名小。今取后义。瑜伽云有薄尘种性。由此因缘。于愦闹处心不爱乐等。瑜伽中五相。一种性二道。三习。四住。五行。广释如彼。地论云。因集畏苦舍众生等者。明与声闻辨同异。谓声闻五相中。三同二异。二异者此不依师故。依止胜。能观深细因缘法故。观胜。问此不能说法与舍众生何别。答声闻亦有能说辩力。为无大悲。舍生趣寂。今独觉亦无说力。瑜伽云或济度他下劣愚昧。以身济度不以语言。何以故。唯现身相为彼说法不发言故。示现种种神通境界。乃至为令心诽谤者生归向故。然此有二类。一成独觉者名麟角喻。二成独胜者名部行喻。余如瑜伽说。第四菩萨十善中。地论四内。初一行因。次二行相。后一行位。初言行是十善乃至无量无边者。此是因集。谓宿习善根依之起行。论中三义。释一依一切善。起行者明自利行因。二依一切众生等明利他行因。三大乘心等出因体。谓此广大心无量等也。又释初释大心。二广心。三无量心可知。二言于众生下明用。谓利他心缘苦能益故。见众生习苦因受苦果。起慈悲。是菩萨用也。三言有方便力者。明彼力是利他行。即四摄方便依前慈起故。是彼力。四言志愿下明地。谓行所依位。于中分三。谓三阿僧祇各满处为一。故有三位也。文义如论具释。应知。言净诸地等者。以净诸地上上净故。及净波罗蜜第一净故。令彼第三广成之行方得圆满论中问答解释可知。第五佛十善中论经有总有别。此中但别无总。别中四内。初三正是佛果。后一是此地中行。前中言得佛者。彼十不善习气同灭故方得佛。二言十力下显佛别德明善自在。成舍于二乘故。三言集诸佛法者。谓依菩萨乘方便善巧集诸佛法。令圆满故。上来观竟。四是故下是第四行也。释有二义。一近望佛善以结求心故名无厌足。论依此释。属佛善中收。二上既通观善有五重。今乃结已应行十善唯求佛善。摄善法戒竟

第三大段摄众生戒。亦名利益众生戒。于中论分为五。一智谓善知众生苦因果故。二依智起愿。愿为众生自修善故。三依愿起行。如誓而修故。四依行摄生。悲为益本故名为集。五依悲正成摄生之行。名为集果。初中有三。初总知苦因。二从于中下别知苦果。三佛子下总结所知。前中论名时差别者。谓对果明因。果有三涂不同。明知因时亦有三位差别。故云上者地狱因等。此上中下有二义。一约境有三品。二约心亦三品。思以准之。问杂集等论。皆下是傍生。中是饿鬼等。何故与此不同。答依正法念经。此三各二。谓大海下无间等八大地狱为正地狱。如或在铁围山间等诸处小地狱名边地狱。又如波吒迦饿鬼铁脚饿鬼等名正饿鬼谓头如大山。颈如针等。极大苦恼如余人间坑堑等处。有鬼食人涕唾等名边饿鬼。又畜生中如热沙龙等受大苦名正畜生。人间诸畜名边畜生。此三中地狱边正望于鬼畜。一向苦故更无异说。若以边鬼望正畜。则畜重鬼轻。此经约此说。若以正鬼望边畜。则鬼重畜轻。杂集等约此辨。是故不相违也。下别显中。地论显二果。一报果。谓三恶道受苦报故。二习气果。人中受残果故。杂集论第七各有三果。一异熟果。二等流果。三增上果。初杀生异熟果随下中上受三恶趣苦。二等流果彼论但一果。谓短命。此中有二者。谓杀命未断时。令他苦故。约此方便位得多病报。二正命断故得短命报。三增上果者。杂集云。所谓外具乏少光泽。是杀生增上果。二劫盗中报果可知。等流中共财不自在者。亦约方便位。以虽有财不得用故。增上果者不与取故。多遭霜雹。三邪淫中得不随意眷属。亦是约方便得果。三增上果者。欲邪行故多诸尘坌。四妄语中等流内。被谤约违境得。为诳约违心得。又为诳亦是方便。以有诳心故。增上果者妄语故。多诸臭秽。五两舌等流中弊恶眷属。是方便中令他眷属不相喜见。故得此报。增上果者。离间语故高下险阻。六恶口等流中。言恒有诤讼约方便得。又常闻恶音约语体粗恶得。等流果言恒有诤讼。约违总他人得果。增上果者。粗恶语故。其地碱卤硗确秽恶。七无义语等流中。言不明了者。言不威肃故。是正等流果。人不信言者是约方便得果也。增上果者。绮语故。时候乖变。八贪欲等流中。多欲约方便。无厌就正位。集论名贪转猛盛。增上果者。贪欲故。果实鲜少。九嗔恚等流中求长短。约方便得果。正果可知。集论名嗔转猛盛。增上果者。嗔故。果味辛苦。十邪见等流中心谄曲是方便果。集论名痴增上故。增上果者。邪见故。果味辛苦。或全无果。三言诸佛子下总结无量大苦聚也。智竟。第二愿中。作是念等愿离不善也。行十善道者愿住善也。亦令等正为摄生故也。第三修行中。如是念已下明依前愿修起自行。亦令他下明依自行成摄生行。论中远离障是释离十不善也。修行对治者释安住十善道。第四集中言是菩萨尔时等明十种心。初为救恶业。二为苦众生。三为怨。四为贪。五为乐。六为外道。七为入法众生。八与己齐者推之为师。九德过己者尊若大师。十初发菩提劣于己者摄同己身。论中乘大乘进趣者。释师心集具足功德者。释尊心。余义并如论释可知。第五集果中有二。初别明摄生。后诸佛子下总结。前中救摄亦有十类众生。文皆有二。初举所化。后明化益。前集中为分释十心寄前十种众生以释差别。今此十类一一生所皆有如前十心救拔。初一解邪众生。余九邪行众生。又十中论分为四。初一化颠倒众生。谓违理乖境也。次有五化欲求众生。谓求外五欲也。次二化有求众生。求三有中果也。后二化梵行求众生。妄求出道也。初中先举所化。后我应下明化益。初中先总二邪心下别。别中邪心是论中恶心也。论中有恶意。言恶心者此是我净二倒。望于常乐。根本集起故说为心。我是常本。净为乐原。此二性成非作意生故名恶心。非专念行。又恶意者常乐二倒伺缘现起名为恶意专念行也。此经中举本收末故略无恶意。言行邪险道者明此四倒是恶道因也。下明能化。先悲后摄。摄中令住正见者治前堕邪见也。如实法中者治前险道。余如论释。第二是诸众生下明化欲求众生。此有二种。一于现五欲受用生过名受用时。此约受果时。二于未得五欲追求起过名追求时。此约造因时。就前中有三。初受不共财者。谓已得之物不与他共。于费用时起嗔过也。二受无厌足财者求时无厌生贪过也。三受贮积财者贮而不用。顺生三毒增痴过也。就初化不共财众生中二。先所后能。亦是先过后治。前中初斗诤于言中。后对怨于心中故。名分别彼我也。论中思念作报解嗔恨也。行炽解炽然也。增长解不息也。能治中为治嗔故令住大慈第三是诸众生常贪下化受无厌足财众生。先所化后能化。前中初常贪等者内心难满也。二恒以等者身口侵夺也。论中斗秤是身。妄语是口。言等者等取余计也。此等并能巧侵他财不令彼觉。名方便夺。下能化中令住。净身口治前邪命。净意治前贪心。第四是诸众生随逐下化受贮积财众生。先所化中有二。初因贮生三毒。二常为下结过属痴。论中因体过者释彼经中因字也。谓由贮积与贪等为因故。下别释。彼染着故者解贪也。散用起嗔者释嗔也。宝玩等释痴也。数为下释结成痴过。谓不见火烧不求对治。下明能治中。清凉处是涅槃。治前火故。上来三门是化起烦恼众生。下二门化造业众生。谓追求生过。于中二。初追求现报造诸恶业。后追求后报造有流善业。第五是诸众生常为无明下化追求现报习诸恶行众生。先所化中四句。初无明覆心过。谓以无明不见现在实是苦报故。妄生乐想求此妄乐而作大罪。复不知此罪未来当有大苦果报。二入大黑下明增恶远善过。谓由此迷异熟愚故。造恶趣业。论中是愚痴因等者。下释此第二过文也。谓依痴起贪嗔等。使满足名痴。为使之因。言善行障是远善。即离无流智处故。顺不善行。是造恶业。三入于生死下明受苦报过。论中受至大对过下释此第三过。谓此业因纳果名受。到果名至。所受苦果多有对碍故名对也。对极名大。又大对有二。一受彼苦身。二至彼苦处。四随逐下增邪见过。论中多作罪因。下释此第四过。谓由多作罪因缘故。临欲终时见地狱相。心虽生悔。不能集彼正见对治故名随邪见也。下能化益中三。初化彼众生令得慧眼。翻前初句。二以慧眼见实法相。治第二句。三见实使得无碍佛智。治后二句。谓证从心起名不随他等也。余如论释第六是诸众生堕生死道下化追求后报习诸善行众生。谓由迷出世胜义。无明造福不动业。求于未来人天之报也。先明所化。后能化。前中句别有十。论分为三。一险道自体名为体也。二在之难出名为障碍三住之失于出世善法故名为失。初中善根既少令人天报危易可颠坠名为险道。二障碍中有八。初二迷苦。次二迷集。次二迷道。后二迷灭。初中。一有苦。二迷苦。前中将坠等者。谓厌离三涂造善求乐。论名求出也。然顺世坠恶是过也。如世险道险危将坠。二入邪见网者。如世险道草葛交横无由进涉。生死险道恶见难出。谓人天实苦妄生乐想。三为种种下二句中。初迷集。后造集。前中如世险道有荒榛闇[目*壹]视眄莫由。生死险道痴闇所覆不识苦因。四随遂下明其造集。如世险道多诸危径欲进返回。生死险道邪法满世入邪失正。五常为下二句迷道。初无道体。后无道缘。初中如人在险失目难出。凡无慧眼无由得出。谓着人天果痴爱覆心。六远离导师者明无道缘。如人在险自既无目复无将导进趣无由。论中生恶道是三恶道也。放逸等是北洲长寿世智三难。亦通余人天处也。虽值佛世不见不闻。是生盲生聋也。七非出要下二句明迷灭。初句迷正后句有障。初中如人在险迷东谓西向南入北。谓欲求涅槃谬求梵天正报梵世依报。此并初禅等取于上。以为涅槃。八随顺魔心者明障于灭。如人在险怨贼所侵难得出离。凡夫亦尔。恶魔所侵。五欲是魔境。烦恼是魔心。贪著名随顺。已有功德却令尽。未起功德不令集。下明于失。论经有三。初一失人。后二失法。失法中。一失离恶法。二失于善法。今此经中略无初二。谓出世善法起顺佛心名为佛意。违背名离。下明能化中二。初令度等治前险道之自体。二令住等治前障碍。反失可知。上来二门明造业差别竟。第七是诸众生为烦恼下明有求众生。辨其受报差别。亦有二门。一道差别者五趣流转过。二界差别者三界系闭过。初中二。先明所化。后显能化。前中初句总。欲有下别。总中论名没在大河过者。五趣漂溺烦恼瀑流犹如大河。求有没中故。是过也。别中句别有十三。论摄为三。初烦恼是五。起河体。二处之多害名为起难。三离出世道名之为失。又初名惑体。二明障道。三失善友。初中五。一欲有等者显深故如世河深名为大河。四流盈满名无量水也。二随生死流者。显流故如河虽深若无流续即可枯竭。今烦恼常流故不可尽。三入大下立河名。如名大河。显其非小。以有爱水所没故爱河。烦恼非一。何故爱独标名。以爱能润漂溺中强生死连绵以爱为本故偏彰号。理实通余。四为诸烦恼下显漂急也。如流若缓人在易出急则难度。烦恼若缓圣道可生。现行无间圣道难发。论云念念不住者无间断故释烦恼势也。不见岸者无对治故释不能求等也。五常为欲觉下显广如河。若狭虽急可度。多起恶觉故难得越。又如河无毒虫。或可易济。今为恶觉虫。所害故难得出。下明起难四中。初一见执。次二是爱。一约种子不灭故还来。二约现行染着故泥溺后一是慢。如人在河四事难出。一被执住。二被回流。三为泥溺。四滞枯洲不到彼岸。谓爱令着慢令心举况陆燋枯法水不沾也。论中举我等取三种我慢者。如下三地中。一我慢。二大慢。三憍慢。初于下自高。二于等自大。三于上不恭。余如论释。下明失三中。初一恶道无救失。后二善道无出失。初一失出因。后一失出缘。又释后二中。初一在人天无出意失。后一生八难异处去失。余如论显。下能化中二。先起化心。二以善下成化行。行有四句。一令离苦因。二得安稳者令得涅槃。三离恐怖者令离苦果。四住智洲者令得菩提。第八是诸众生深心下明界差别。中先所化。后能化。前中初总。谓于三界深心贪着。在之难出事如牢狱。下别显之。论中如世牢狱有五种过。一打棒楚挞。二费用资生。三亲属分张。四枷锁着身。五欲出无由。三界牢狱亦有斯五。一病苦。二求不得苦。三爱别离苦。四爱锁缠缚。五无明闇障。前三苦报。后二烦恼。论中五种难者翻对释也。如无病是乐。障此名难。余四亦尔。此中言多有忧悲者是论中第三爱离也。二苦恼患难是初苦事也。余三可知。下明能化益中。治前系闭故云令住无碍涅槃也。化有求众生竟。下明化梵行求中亦二。初化邪梵行求令舍邪归正。后化正梵行求令舍小入大。第九是诸众生深着我下化邪见诸外道等。先所化中初句为总。谓诸外道先俱生着我重。复分别计执难脱故云深着等也。论中此余见根本者释疑也。谓何故偏举我见为过。以是余见本故。断常等见皆依此起。下别中六句。初三远离第一义乐。后三具足诸苦。前中初中后三也。初无始发方便。次造行不正。后终趣不真。初欲求涅槃以灭蕴苦。由执我故不出阴宅。人天如巢。恶趣犹窟。二常随下造行不正。以倒想故谬行异路。三依六入下明终趣不真。计虚妄我欲趣涅槃。安置此我妄求梵天自在天等六入果报。以为涅槃。为妄我所居。妄我实无故云空聚。下三具足苦中。初二内苦。后一外苦。内中。一四大相违苦。二五阴迁逼苦。此经是烦恼杀善根。三受此等为外苦。亦是总结多苦。余如论释。下能化中二。初令住道谛治前我相。二所谓下令住灭谛治后六句。可知。第十是诸众生其心下化正梵行同法小乘。先所化中三。初不求大因。谓其心狭劣者不能广度众生故。乐小法者不求大菩提故翻此二心广大名为菩提萨埵。二远离下不愿大果。上二是求心过。三贪着下明失行过。谓不定聚中实有大乘出离之法。而反乐修小乘法行故是过。下明能化中二。初令住广大心者治前狭少也。无量下治前愿行也。上来广明摄生戒相。诸佛子下第二总结。言随顺持戒力者。依前持于律仪摄善。起此摄生之力。论名依持戒行故得此戒力。是故能作善法善巧起诸摄生善行。故云能广生大慈悲心也。上三戒明地体竟自下第三明其地果中。三果同前地。初调柔果亦三。初调柔相。二菩萨尔时下明别地。三是名下结。初中三。法喻合也。法中初见诸佛为练行缘。二以衣被下明能炼行。三是菩萨下明所炼净。能炼中二。初供佛。二于诸佛下受法。以戒地故受十善法也。论中有者同明调柔等三同前地。无者应知明无发趣。劝知也。此中胜事等者调柔中胜过前地故。今略显。就所炼净中。由多劫离二垢故。令施戒俱性成净也。前地戒未性净。令施亦未净。若尔何故前名施增上。释彼望前为上。至此转胜。因此略论诸地行有其四义。一就别显异。初地唯檀乃至第十唯智增上。二辨胜过劣。初地檀胜。二地施戒。三地三度。乃至十地十度。皆以后兼前故。后胜前。前不兼后故。前劣后。三约实行修。一一地中皆具十度。四约证理行。唯平等平等非一非多下诸地准之。喻合可知。别地中离口四过故兼爱语也。摄报中金轮过前。前百此千者。瑜伽云。当知威力过前十倍也。余义如论。及同前地应知第三大段重颂中有二十六颂分六。初二颂颂前十种直心。二有四颂颂前律仪戒。三有四颂颂摄善法戒。四有八颂颂摄生戒。五有七颂颂调柔等果。六末后一颂结叹所说。第二地竟

华严经探玄记卷第十一华严经探玄记卷第十二(此尽第五地)

        魏国西寺沙门法藏述

第三明地中亦作七门

初释名者。唯识第九云。成就胜定大法总持。能发无边妙慧光故名发光地。解云。由得胜定发修慧光。由得总持发闻慧光。金光明经云。无量智慧光明三昧不可倾动。无能摧伏。闻持陀罗尼为作本故名明地。摄论云。由无退转等持等至所依止故。大法光明所依止故名发光地。世亲释云。由此地中与三摩地三摩钵底常不相离无退转故。于大乘法能作光明名发光地。无性释云。静虑名等持。无色名等至。或等持者心一境相。等至正受现前。大法光明所依止者于大乘教得智光明。此地是彼所依因故名为发光。解云。地从所发果法为名。解深密经及瑜伽论意同摄论。显扬论云。证得静虑三摩地。蕴大智光明之所依止。智论四十九名为光地。十住论云。广博多学为众说法。能作照明故名明地。仁王经名明慧地。地论等并如前辨

第二来意者有三。一前戒次定。义次第故。是故须来。二前位能持微细戒品。未净圆满世间等持等至及圆满闻法总持。为令得此因。说此地令勤修学。此依深密经。三者初之三地总寄世间施戒修法。前二施戒。今此显修。是故来耳

第三所离障者。依十地论。离闇相于闻思修诸法忘障。解云。此与所得地法敌对相翻故立斯。四号。唯识论第九名闇钝障。谓所知障中俱生一分。令闻思修法忘失。彼障三地胜定总持及彼所发殊胜三慧入三地时。便能永断。由斯三地说断二愚及彼粗重。一欲贪愚则是此中能障胜定及修慧者。彼昔多与贪欲俱故名欲贪愚。今得胜定及修所成。彼既永断。欲贪随伏。此无始来依彼转故。二圆满陀罗尼愚则是此中能障总持闻思慧者。解云。此实是所知障与欲贪同体故名欲贪愚。以贪妙欲掉动散乱障定发修慧。闻持等者从所障因法以立名。以亲障闻思二慧。是彼总持所起果故。此是忘念不正知等同体所知障。解深密经及瑜伽金光明经及梁摄论等。各有二愚。大同此说。又有离业障及报障。准前知之

第四所证者。唯识论云。胜流真如。谓此真如所流教法于余教法极为胜故。摄论第七。无性释云。谓此所流教法最胜故。舍身命求此善说。不以为难。梁摄论释云。从真如流出正体智。正体智流出后得智。后得智流出大悲。大悲流出十二部经。是故名为胜流法界

第五所成行者略有三种。一十度中成忍度行。二成禅定行。三成求法行。庄严论云。第三住能生欲界而不退禅故。余行如下辨

第六所得别果者亦有三种。一依梁摄论。通达胜流法界得无边法音果。二当位行果。金光明云。三地发心得难动三昧果。又下文四无量五神通亦是当位所得之果。三显分位果。谓忉利天王等四果。如下文说

第七释文中亦三。初赞请分。二正说分。三重颂分。初中十颂分二。初六庆闻前地。余四请说后地。前中初一庆闻心喜。次一身业雨华。余四语业赞述。于中初一总叹。次一别叹说法心。次一别叹所说法。后一叹为机。结说就请。后四颂中。初三大众请。后一上首请。前中初一总请三地行。后二别请十度行。就第二正说中。论为四分　一起厌行分　二厌行分　三厌分　四厌果分

此地修禅厌伏烦恼名为起厌。初入地心修起彼厌名为厌行。趣地加行起彼厌行名起厌行分。所起地初名厌行分。正住地中修八禅等名为厌分。地满足故名厌果分。又释此四分。如其次第。则是加行道无间道解脱道胜进道可知

就初分中三。初结前起后。二何等下正明十心。三菩萨以是下结行入地。就十心中。初二一对。一离过心。谓依前净戒起此深念趣禅净心。二住善心。谓依自所住大乘之法坚心不动故名猛利。次三一对。于中初二离过。后一造行。离过中初一厌当来欲故名厌心。二舍现在欲故名离欲心。当来未起但可悬厌。现在受舍。论名不贪。造行中谓不舍前地。自分所修。进起此地胜进之行故名不退心。次三一对。于中初一离过。后二成善。离过中谓此加行深伏三地所断烦恼。不令彼惑成于过患。论释云。自地烦恼不能破坏名为坚心。远师释。前二地为自地。辨师释。四禅四空为自地。皆恐不当。后二成善中。初成善体。后成善用。体成故出入自在名明盛心。谓净之极也。三摩跋提此云等引。出入定名。后用成故。受生自在。虽生下地。不失定用。由此淳厚名为无足。此二种心至下地满中究竟成就。下云于禅能入能出是明盛心。成不随禅解脱力生即此淳厚心也。下论云彼淳厚心此处现成故。末后二心为一对。初一离过。论名依彼生者依欲界生也。以大智故烦恼不污故名胜心。后一利生。以大悲摄化不断诸有故名大心加行分竟

第二厌行分中。论分三。初厌离有为名护烦恼。二舍狭劣心名护小乘行。三上求广大名方便摄行。又由善巧摄起八禅等行故名方便摄行。就初中有二十句。先十句明无常观。后十明无有救者。约人显失。就初中。先一句总。谓如实相者。有为之法理实无常。故名实相。论名命行不住者。有为诸法相续名命。迁流称行即此不住名曰无常。别中分二。初云何此无常者。问彼有为法无常法。二何者是无常。问彼法上无常之义。前中经有六句。于中初四约内正报。后二约外依报。前中一约苦无常者论释。依身转时力生三苦者。内报迁流名身转时。转能生苦。说转为力。苦由转生故名为依。以其苦故性是无常。二无我无常者。论经无此谓遇违缘而便损寿。不自在故无我。无我则无常也。三不净无常者。依于饮食好恶之力令其形色不净。有增有损增损不定是无常也。四不久无常者。论经名无常。此乃以粗无常显细无常。论依不护诸恶力者。履崄餐毒名为不护。依此力故令身夭寿。下二约依报中。初约世界。后约资财。初中依世界成力者。由依成力有此灭坏故名败坏无常。后一由财无定主之力。一处不住故名不可信相。二何者是无常者明无常之义。或以生灭流转为无常义。通大小乘。如余处说。或以不生不灭为无常义。此唯大乘。如维摩说。或说二种。如此文。或说三种。一无物无常约遍计性。二生灭无常约依他性。三离不离无常约圆成性。以在缠时名不离垢出障离时名为离垢。约斯不定名为无常。具如中边论及佛性论等说。上二并大乘终教说。言小时无常者。以念念生灭无暂时停故。此中名不生不灭者。谓不定生故速灭。不定灭故还生。是故约俱不定亦名不生灭也。二自性不成实无常者。谓三世中法无自性故。不从前际中来名为不生。不去至后际名为不转。现在不住。此中三世约相续门说。若约生灭门即应说当来名来过去称去。由有此二门故与余处不相违也。第二无救者。初牒前无常是实也。知诸法下正显无救。初言知无作无起者。于无常法中无能为其起作救护。论经名无有救者。此是总句。言无来下别辨。于中初四就死时明无救。一于少壮时无常未至。望于后死。无所依怙使其得免故名无所依止。此中名无来无去者。无有依怙来能令无常去故云也。二于年衰将死。无常至时。无能救者。以无常死临。多共忧故名忧。谓忧念相续曰多。与心俱起曰共。三于生蕴坏时死相现前中间忧念转增名悲。四于四大分时生诸苦恼。上四死时无救相显故于先辨也。次二句于外爱求事中过患无救。初憎爱系者。谓追求时。谓贪其所欲憎其不欲。于顺违境爱憎妄想常转不舍。对治不入故名无救。二论经名忧恼转多者。于受用时乐少苦多。谓于资财守护致怨心乃至失命。苦恼多于贫穷苦也。此经略无此句。下四句约身苦无救。于中初无停积者明身老时小壮不可复集。故名无救。二无定生处者。明没命尽时不能定知生于何道。论经略无此句。三但为贪等者。明小壮时依三受起三毒自烧善根亦是衰损自身故名无救。四增长后世者。于年衰时无量病苦所增长也。病通始终老时多故。又释。因病造业增后世苦。无实如幻者明虚妄也。论中重释。后三句与初四俱是身患事。何不在初一处同说示身数数过患事者。显身患多故。护烦恼行竟。第二护小乘行中。初十句护小心。后二十句护狭心。前中初总后别。总中先牒前。谓初观无常已生厌心后观无救转更生厌。故云转复厌离。下趣后谓正护小乘小心。求佛大果故云趣佛智慧。下别辨中二。初五句求佛菩提。论名摄功德大。后四求大涅槃。论名清净大。前中一通力大。知佛神通难测故云智不思议。智即是神通之体。二无比大。寄对显胜。无有敌对故云不可称。论经名无等也。上二明妙用自在。三大义大。谓义利益无量众生故云有大势力。此利他德。四无讥嫌大。希有难得故云无能胜者。论名难得也。此自利德。五不同大。亦寄对显胜。理实异外越小超因显胜。今论主从首而说故云不杂外道也。上三显行德圆备。第二求涅槃净果中。论主初总释摄为三义。一离惑。二离苦。三得涅槃。二别中初离二障及习故名无衰。二苦根本。尽忧悲。亦亡故名无恼。三得涅槃中经有二句。一至涅槃安隐大城名自利德。二至彼不还。能广利益故云救苦众生也。此是无住涅槃故。第二护狭心中。初十起悲。后十救度。亦是先悲后慈。初中先牒前起后。举数总标。谓见佛智胜利伤物不得。观有为苦恼愍物忧之。是故转生殊胜悲心。二何等下正显悲行。于中初句为总。以诸众生远佛慈父曰孤。无智悲男女称独。由此孤独在苦无救深成可愍。余九别中。初二依欲求众生。一求财无厌名贫无依。二于他资财非分起惑。求无休息故云三毒等。下三约有求众生。于中一苦果未脱。三界六道轮转不绝故云闭在等。二苦因不除。谓烦恼所覆。是彼苦因故云常住等。三无对治力。谓生在难处。离善导师。无善根治云无正观力。下四约梵行求众生初三小乘。后一外道。前中初不求大因。名不起胜念。故云于善法心薄。以唯乐小善不乐大善故名薄也。二不求大菩提果。故云失佛妙法。谓妄取小果恃为究竟。名怀增上慢。三不求大涅槃果。故云而常随等。谓纵得小乘无余涅槃常随变易生死水流。下一外道过。妄行邪道怖真涅槃。第二正救度中。初牒前起后发总救心。此是总句。下九别中。初三除三障显度处。次五授三学明度行也。后一令苦灭即度果也。初三中应解其业结净其惑染脱其苦报故云也。次五授行中。初二授三学。谓一劝置持戒处故云着善处也。劝住定慧处故云令安住。何故定慧合为一句。以前地戒成分戒别辨。后地明慧位未至故。慧从定说合为一句。论云三昧地故定慧合说。下三明授法利益。初二句约戒。一欲受戒者令除戒疑信重于戒。有大功德使乐受故名为欢喜。二已受戒者示以持犯及显戒德。令心乐住安固不动故云令知所宜。后一约定慧。谓掉没障定。烦恼障慧。除灭此二定慧成就故云令得度。又释掉是掉举障于定。没是昏沉障于慧。烦恼通障。此是细惑随逐行人故名随。非随烦恼也。以是使故。下一救度成者。令得余无余二种涅槃故云使灭苦。第三修方使摄行中。先述意后释文。初者菩萨因前观有为多过众生未出。佛智大利众生不得。复念众生堕惑业苦以何方便拔令得乐。即知不离佛无碍智。智由何生。即知不离八地上如实智。实智由何生。即知不离四地已上无行慧。慧由何生。即知不离三地禅定。定由何得即知不离闻法。是故菩萨先求正法。既闻法已静处思惟。思已修习入禅无色。依定观法起无生慧。依此渐增生无功用如实智。依此渐增生佛无碍智。得智已能尽众生界拔苦与乐。常化不绝。文意如此。是故名为方便摄行。二释文者。此文方便有其五重。一起观方便。谓牒上三心起后观求。二即时欲具下标趣方便。谓标其佛慧彰行所趣。三作是思下观求方便。谓观察推求度众生法。四即时知住下正知方便。谓知佛智能救众生乃至知由闻法。五菩萨如是知已下摄修方便。谓修闻法行摄取正法。初中三。初牒上护烦恼行故云如是厌等。二牒上护狭心行故云深念众生。三牒上护小心故云见一切智等。论主依此三心能起后行故。说此三为三种因。初一可知。后二中发精进因者。见佛智有利能救众生。是故因此起大精进修彼因行。论云能修行彼道故。深念为因故。能善化众生也。二标趣方便中。论云依如来智慧救度众生。此言示现发起方便摄行故名也。三观求方便中。众生堕苦等论经亦有业。问前救度十心中。于惑业苦处以三学救度。何故今言以何方便而拔济之。答前知戒等度法。而未知用何智慧能授此法。问若尔前护小心中。已知如来智慧有大势力能救众生。何故今言以何拔济。答前虽见佛智能救。佛果在当未可现用。谓于佛智外更有余法能救济不。故云以何方便也。简小涅槃同彼化城。非为究竟故云毕竟之乐。第四正知方便中。若具有五法四对。论摄为三。言五者一无碍解脱慧。二如实智。三无行慧。四禅定。五闻慧。四对者。一依闻得禅。二依禅发慧。三依慧得实。四依实智得无碍慧。摄为三者。初一穷尽佛果名证毕竟尽。末后闻慧名为第三彼起依止行。中间三种名起上上证毕竟尽。以此三种皆有下从他起上能起他渐增至佛故。摄为一名上上等。然此五中。初唯所起。后唯能起。中间通二故合为一。此经中如实智内略无不离之言。无行慧中略无不离禅方便。余如论释应知。自相是现量境。同相是比量境。皆有缘造名行。证空舍此名无行慧。此是四地法。此地但得彼慧光明故名明地。例如地前明得定等。言胜进禅者。小乘中净禅有四。一退分。二住分。三胜进分。四决定分。今即是此第三胜进。以望前趣地方便中禅说此为胜也。言决定者是决定分。谓于他四地决定向故。言自智观者简异所生慧明。是此地菩萨知观故也。余如论知。第五摄修方便中。初牒前起后。谓前为救度已发大精进。今此正知所闻法要。勇猛追求故名求法转加精勤。此是总句。二日夜下别显。于中有二。初明求行。二菩萨如是方便下显重法心成。亦即初显闻慧。后明闻慧因。前中此十一法中。或总约所受。唯教与义。谓初五求教法。余并义。或约所成具成三慧。谓初五闻慧法。次一思慧法。余五修慧法。依是义故。论主释名云。随闻思修照法显现故名明地。或约所求法体有四。初五求教法。次三求理法。后三求行法。略无果法。以彼非是正所行故。论中如前说者。次前段论文未说教义是也。一日夜听等以无慢怠心故。二闻法喜悦无妒忌心故。三爱法闻义无折伏他心故。四依法者。依大乘教自见。正取不忘失故。谓自悟不由他也。五顺法者依披读习诵顺圣言故。六满法者静处思惟。义圆满故。七辨法者顺教宣明。为他说故。八究竟法者依定修行故。谓此三地以定成为究竟也。九归法者谓求四地已上出世间无漏智法故。十求法者求后诸地大悲摄生法故。论经无此句。十一随顺法者求八地已上无功用行法。随顺能起佛果解脱无碍智故。此十一中。初二示现常勤行故。是此地能求法行也。喜法等下正修行故。是所求法行也。第二重法之中二。先明能求法因。二又如所闻下显所求行因。又亦前求法后思义。前中论云彼常勤行以何为因者。问能求法行之因也。云敬重等略答为重法为因起求法行。敬重极故名毕竟尽也。是故不惜身财等也。文中重法校量略举十事。一轻宝重法。于中初至不生难想为法舍财。二但于说等重人轻宝。二为求下能舍内外。于中初总国土下别。别中初外。前游财易舍。国宅难故次辨之。论中名财所得处也。妻妾下内。论名财所为者是妻等也。国外财易舍。妻等难故次辨也。三又为下尽敬给使。经云乃至以身而为床座等。论名及彼所为者。是前内外所为。谓自身也。余物易舍。己身难故次明也。四破除下破慢忍苦。先破慢。于上不恭名憍慢。执我倰下名我慢。于等自大名大慢。并能为法破除也。前身敬易为。心慢难遣故次明之。论云彼高大意此亦能舍。五诸恶下忍苦求法。情慢易舍。身苦难忍故次辨之。六若得下过得重宝。三千重宝难离故。七胜得轮王。人中上故。八胜得帝释。欲天上故。九胜得梵王。色天胜故。十舍身投火。具如第六回向中说。此是以事自要。显求心郑重无难不能也。悉能正观者。是系念思惟得其义旨也。论中释正修行因也。余如论辨释。厌行分竟

第三厌分者即是修慧。又前明听闻正法及系念思惟。今明如说修行故也。文中有三。初牒前起后。二菩萨如是下正显厌体。三顺诸法下明入禅等意。初中先明四禅后显四空

就四禅中略作七门。一明入意。二显体性。三立支数。四明假实。五显废立。六释名。七辨相。初中通论。何故菩萨入禅无色无量神通。论释。为五种众生。一为禅乐憍慢众生故入诸禅。解云。有得世间四禅之乐恃着起慢难化以道。菩萨现入过彼所得。息彼慢心。授之以道。而自不味着故还舍之二为无色解脱憍慢众生故入无色定。解云。有得无色定谓为涅槃。示入化之。三为苦恼众生入慈悲无量。四为得解脱众生入喜舍无量。五为邪归依众生故。入胜神通力令正信故。二体性者有八门。一随事门。依萨婆多宗支虽十八事但十一。谓初定五法。一寻。二伺。三喜。四轻安。五一心二定中增内信。足成为六法。三定中更增舍念正知乐。帖成十法。四定中不苦不乐故为十一。以喜乐及不苦不乐此三别说故。二类摄门。以喜等三不别说故。三同是受数名。唯有九法。一寻。二伺。三定。四慧。五受。六念。七轻安。八行舍。九信。颂曰。安舍念各二。受定各分四。寻伺与信慧。守位不分支。释云。轻安分二。谓初禅二禅各有乐也。舍念亦分二。谓三禅四禅各有行舍及念。受分四。谓初禅二禅喜。三禅乐。四禅不苦不乐。定分四。谓四禅各有心一境性。信是内净。慧是正知。三会假门。依大乘宗体唯七法。初二定乐亦以是受数故。除轻安。二禅内净依舍念正知上假立故。除信。是故唯七。颂曰。舍念各分二。定四受有六。寻伺及与慧。守位不分支。舍念各分二。谓三禅四禅。定四谓四禅。受六谓初二各喜乐。三乐。四不苦不乐。又不定四中二谓寻伺。别境五中三谓念定慧。遍行五中一谓受。善十一中一谓行舍。四重摄门。唯以五法为性。以寻伺二法用慧为性故。此上约初教。五会相门。此上禅门及上禅支当相即空皆无所有。是禅支体如智论勘。六事尽门。即此禅门内摄如来藏真如功德。如胜鬘等经勘。此约终教。七泯绝门。如理无定无不定。如文殊巡行经等勘。此约顿教。八融摄门。谓此定门即摄无边自在法界相即入等。如下离世间品勘。此约圆教。第三废立者有八门。一约无为问无为是清净法。何不立禅支。答禅是有为故。二约色行问。色及不相应行是有为。何不立禅支。答禅支是有行有缘相应法。彼非行非缘非相应故不立支。三约心王问。心王为心法所依。是相应法。何不立禅支。答随顺禅义是禅支义。心王但为依无别摄心用。是故不立支。四约心法问。等是心法。何故遍行五中唯受立支。余不立耶。答泛论禅支要具三义。一是对治支。二利益支。三彼二依止自性。于中随入一数有随顺义。是支义。以受通四禅利益支故。是故立支。作意警心。触三和生。想境分齐。思能役心。各顺起心。不顺静虑故不立支。问别境五中何故念定慧三立支。余二不立。答定是心一境性通为四禅彼二依止自性。念是三四对治支故。明记所治过患相故。慧是三禅对治支。分别所治深见过故。各有随顺故得立支。欲及胜解于境希望。印持所缘。各非顺定故不立支。问善十一中何故唯行舍立支。余法不立。答舍是三禅四禅对治支。以能舍彼所治障故。是故立支。信者深忍乐欲心净为性。惭者崇重贤善。愧者轻拒暴恶。无贪者无著为性。无嗔者无恚为性。无痴者理事明解。精进者勉励策发。不放逸者妨恶修善。不害者不损有情。皆于静虑无随顺义。不入三位故不立支。轻安在定调畅身心。为喜舍所覆。亦不立支。问不定四中何故寻伺立支。余二非支。答寻伺是初禅对治支。恶作追悔睡眠。昧略皆不顺定故不立支。问大小烦恼何不立支。答禅不浊染故彼不立。五约支分者。问等是随顺义。是支义。何故初定以寻伺为对治。不立内净等。答为此定初故。寻求伺察欲界过患。而能治彼欲等寻伺故立此支。内净为此寻伺粗相之所覆故体不显现。是故不立。问舍念正知何故二禅合为内净。三禅四禅方乃分之。答二禅舍等为喜粗相之所覆故。是故不分。但约离外寻伺。名为内净。问等分三法。何故第四不立正知。答正知明显。四定行舍其相微隐。相违不立。又为胜舍所覆障故。以胜舍受是无明分正知是明相违害故。是故不立。问轻安在定一切地有。何故不立轻安支。答轻安浮动。初二静虑喜受浮动相顺所覆。三四静虑行舍沉静相违所覆。总不立支。问若尔小乘何故初二立轻安支。答彼据除欲界五识身及初定三识身。各除所引身粗重故立轻安。后以二三定中无粗识身及所引身粗重可对治故。三四定不立轻安。今依大乘。是乐受摄故不别立。六约建立者。问禅既有四。支数应同。何故初三各有五。二四各唯四。答为欲界欲恶难除二定喜深难离。欲为牢强对治。是故初禅及三各立五支。以初定及三无此难遣。是故二四唯立四支。七约决择者。问若初定支亦二禅耶。答应作四句。有是初支非第二。谓寻伺。有是第二非初禅。谓内等净有通初二。谓喜乐定。有非初二。谓除上说。又问若是初支亦第三耶。答亦作四句。有是初禅非第三。谓寻伺喜。有是第三非初禅。谓舍念慧。有亦初禅亦第三。谓乐及心一境性。有是俱非。谓除上说。又寻伺喜乐是初非四。舍受舍念是四非初。心一境性亦初亦四。与上相违。非初非四。以第二等望余。各四句准之可见。八约道品者。问若是禅支亦道支耶。答应作四句。或是禅支非道支。谓寻伺乐及不苦不乐。或道支非禅支。谓精进信轻安正思语业命。或俱。谓喜行舍念定慧。或俱非。除上所说。第四业用者有四。一约发智断惑。二约发通起用。三约诸定超间。四约定用自在。初中若诸外道修得四禅起有流智。伏欲界惑得生上界。或取无想以为涅槃。若诸小乘依此能发无漏圣智。断人我惑得阿罗汉。若菩萨人或为众生示入世定而不随生。或复依此成于无相无生等观发真圣智。断除二障得成佛果。若普贤等及诸如来依此示入百千三昧。第二发通者。外道依此发起五通见过未等起诸邪见。二乘依此所起六通。然有限分。菩萨依此发五或六。分齐过小。随位应知。普贤及佛依此所发或六或十。皆无限分。第三诸定超间者。外道于定不得自在。二乘或有次第出入。或于九定次第超入。或双双超或首尾超。菩萨能依一定出百千定等。普贤及佛能入尘数定。一一复各生于尘等。如是自在无有限量。第四定用者。外道总无。二乘只有依定发用。不得即定为用。若初教菩萨在于定中虽无五识业用。由前愿力击发余识示有作用。说为俱起。若终教菩萨能即定即用。双行自在以理事无碍故。若顿教菩萨定用为一。双绝两名故。若圆教普贤即在定为起用。而不改定相以二事相即故。七辨相者。四禅即为四。一一中各有四义。一离障。二修行对治。三修利益。四彼二依止三昧。初禅离欲等。明离障诸说不同。依毗昙离五欲故名离欲。断十恶故名离恶。除五盖故名离不善法。依成实断贪欲心名为离欲。以离欲故亦舍杀等名离恶不善法。依智论离五欲名离欲。除五盖名离恶不善。又诸欲发恶行堕极下恶处名欲恶。违生善品名不善。或总欲界诸恶不善俱皆舍离。依杂集论第八云。能断欲界欲恚害等。二有觉有观者是修对治。智论云譬如振铃粗声喻觉细声喻观。杂集等论名为寻伺。谓粗缘曰寻。细缘曰伺。如唯识论第七说也。以寻求伺察欲界过患能除灭故。瑜伽第十一以不净治欲慈治恚悲治害故。修三行对治三患入初禅定也。三离生喜乐者是修行利益。远法师云。庆背欲恶是故生喜。离过猗息故名为乐。又欣悦名喜。依萨婆多身心调畅故名为乐。体是轻安。依大乘适悦名乐。体是受数。又杂集第八由寻伺支治所治已得离生喜乐故。解云得离所治生此喜乐故为利益。四入初禅者是彼二依止三昧。是彼对治及利益支所依止定。何故不说所离障。但云前二。释障为所断非是支故。杂集第八云。心一境性是彼二所依自性支。依止定力寻等转故。解云专住一境令心不散名心一境。第二禅中初灭觉观者是离障。谓觉观粗动发生三识娆乱二禅。如净水波动名无所见。二内清净等者明对治行等。小乘是信能净心相。谓内等净离外鼓动。定等内流名内等净。大乘内净即揽三禅舍念正知三法为性。显扬论第十九云。内等净以舍念正知为其体。瑜伽六十三亦同此说。心一处无觉观者。舍利弗阿毗昙言欲界地中心行六处。以六识身取六尘故。初禅地中心行四处。以四识身取四境故。以初禅已上无鼻舌识故。二禅已上心行一处。唯意识身缘法尘故。又复相续不断亦名一处。论云修无流不断三昧行一境故。解云无流触实修治。不断等释一处等也。三定生喜乐者是修行利益支。前初禅中创背欲恶庆离生喜。此二禅中法从内生庆得生喜。喜乐同前释。四入二禅者是彼二依止三昧。第三禅中离喜者是其离障。谓二禅喜心分别想生动乱多过。三禅转寂故须除遣。犹如贫人得宝生喜失则深忧。莫若忧喜俱绝方为快乐。二行舍成就念慧者是修对治支。谓舍是舍支。行心调停舍彼喜过故名为舍。此是舍数简别舍受。故名行舍成就。念者是念支。谓念前喜过守心一境故。慧者余论名正知支。谓分别喜过。明见其失故成对治。又此三沉细寂静。下地喜踊跃浮动。动静相违故成治也。显扬论云。住舍者于已生喜不忍可故。平等正直无动安住。念者于喜不行中。不忘明记故。正知者或时失念喜行。于此分别正知而住。三身受乐者是利益支。谓喜在意地乐在五识故云身受。又释乐受有二。一下品适悦在心。二上品遍身心。就所遍处从末为名故曰身受。言诸贤圣能说能舍者显乐深胜。唯有贤圣。能说为过堪能舍离。非凡所能故是深也。四常念乐受入三禅者是彼二依止三昧。谓常念自地乐受利益入此禅矣。第四禅中。初断弃苦等者是其离障。三禅得乐虽是利益。望第四禅极为妨害。如重病人观妙音乐为障四禅。故须除遣。若尔应但除乐。何故断苦。释云。理实苦根前位已离。至此云断。为欲对乐双辨故也。忧喜已灭者总绝四受。明禅不动故。瑜伽第十一云。初静虑出离忧根。第二静虑出离苦根。第三静虑出离喜根。第四静虑出离乐根。又彼论云。问何故苦根初静虑中说未断耶。答彼品粗重犹未断故。问何缘生在初静虑者。苦根未断而不现行。答由其助伴。相对忧根所摄诸苦。彼已断故。若初静虑已断苦根。是即行者入初静虑及第二时。受所作住差别应无。由二俱有喜及乐故。解云以初二定俱有喜乐。若齐离苦。即二受不殊故。初不断苦之粗重。然无现行故有乐支。又小乘此乐受但是轻安非乐受故。又初禅喜劣。犹为苦根。粗重随故不名灭苦。二禅喜胜灭苦粗重。名灭苦根。问忧喜先除文言已灭。苦亦久除。何不言先灭。答为苦对乐乐未亡故。双言不便故不言。先忧喜不尔故不例也。若尔忧喜既不对乐。何须举之。释云。乐尽之处总结四亡。显禅不动故须举耳。二不苦不乐者是利益支。余禅之中皆先明治。今此先明利益。乘前断苦断乐。对之即明不苦不乐彰利益。义便故次论之理实在后。问此正遣乐。何不但言不乐而云不苦不乐。答为明舍受不同苦乐故。问前离障云忧喜已灭。何不亦言不忧不喜。答有二义。一非此正灭。亦不与乐相对故不类苦。二若摄五受为三受时。忧喜摄入苦乐中故。以苦乐宽故。是故舍受对彼但名不苦不乐。三行舍念净者是对治支。前三禅中为乐所覆故舍念不净。今此离彼下地乐贪故云清净。清净舍念与乐贪相违故成对治。四入四禅者是彼二依止三昧。下释四空亦各有四。然此经中略无对治行论主准义置之。初所离中过色想者。依成实论。远离色想者远离香味触想。灭有对者还灭色。香味触之想以彼色等对碍故。不念别异想者灭缘声想。以声藉众缘击发而生故名别异。亦依大乘不同前说。谓色虽多种统摄为六。谓五尘及法处要略唯三。一可见有对。眼识所行。二不可见有对。余四识所行。三不可见无对。谓意识所行。表无表色等。此中过色想者。以离眼识所行可见色想故。何故不言过色。但言过色想耶。释以在色地修起此定未舍色形故。何故但言灭想而不言余心法耶。释理实通有。以想取相强故。灭有对者离余四识所行。不可见有对四境色。故以想与心俱名为和合。亦是心与境合故也。不念别异想者离意识所缘法处色想。论言意识分别一切法故。说别异想者以相隐重释。谓意识通缘一切诸法。于法处中简取缘色义边意识想灭。缘余意识此中不遣。举其所灭简所不灭故云别异。问香味之想初禅已离。色声触想二禅已除。今云何言空定灭耶。答远释云。治有四种。一坏对治。谓方便道观下有流无常等故。二断对治。谓无碍道正断下过。三持对治。谓解脱道为首。及后一切无间解脱持彼无为不令失坏。四远分对治。谓解脱道。为首。及后一切无碍解脱远令前障毕竟不起。今此空定据第四治故说此离。今更释于二禅中虽无色声触想。得借初禅三识之心见闻觉触。是故乃至第四禅中犹有此想。今得空定故说灭之。若尔香味二想何故亦说。释有二义。一亦有借故。二以与声触同是不可见有对色故同辨。如第四禅灭忧苦等准之。是名离障。二对治者论有三句。过色等境界想者。空定离彼色等境想故名过也。云何过。以不分别故。云何不分别。以见无我故。此辨实治也。问此中既有修行对治。为有支不。答依璎珞本业经。四无色定各有五支。谓想护止观一心。今依杂集等论。诸无色定。奢摩他一味想故无支分建立也。论主但约翻所离障显能治行。以义说之。非约支分。知无边虚空者是修行利益。谓三色想绝廓尔无边。即入虚空无色定者是彼二依止三昧。二过虚空相者是名离障。见外念粗分别过患是名修行对治。谓外缘虚空心念粗患故。能见此失知过而除彼想故云对治也。知无边识者是修行利益。谓舍外住内也。定体可知。三中过识是离障。见其粗事念分别过患。是修行对治。谓犹见住识为粗患故。知无所有者是修行利益。谓前舍外住内。犹为粗念。莫若内外双离。俱无所有。方为利益。定体可知。四中离障可知。见彼住无所有想粗念过故。能治彼想名修对治。知非有想非无想安隐者。粗想既尽名为非有。细想未泯名曰非无。此中非无约圣智说。非谓世定觉此非无。定体可知。下明入意。谓但随顺化众生法入此八定。非是自行所乐故云也。第四厌果分中有二。初行果。后调柔等明位果。初中有三。初四无量名行方便果。二五神通是行功用果。三总结自在

初中四无量义略作四门。一释名。二体性。三建立。四种类。初释名者。缘无量境起无量行名四无量。则带数释也。二体性者。杂集论第十四以定慧为体。又慈能与乐无嗔为体。悲能拔苦即不害为性。喜庆他乐不嫉为性。舍令他舍惑即善舍为体。三建立者。依庄严论及瑜伽第十二有四种作意。立四无量。谓缘求乐众生起与乐作意立慈无量。缘有苦众生起拔苦作意立悲无量。缘有喜众生起随喜作意立喜无量。缘有烦恼众生起不染污作意立舍无量。此约初教。又依大集经第九云。知诸众生心性本净是名为慈。观于一切等如虚空是名为悲。断一切喜是名为喜心远一切行故名为舍。此约终教。顿圆准之。四种类者。诸经论中多说三种。一缘众生。二缘法。三无缘。智论中二释。一约能起。初一是凡夫慈等。次是二乘法执。三是菩萨称真。二约所益。初一令得人天益。二令得二乘益。三令得菩提。佛地论中诸佛菩萨缘众生假者。亦缘彼五蕴假法及缘二空真理而教化故。今十地论中众生念等者念则缘念也。若依圆教如下离世间品。各有十种。具如彼说。余义如别章。释文中二。先释于慈。后三类显。初中三。初众生念中四。先与乐。广者与欲界乐。大者与初二禅乐。以共喜故名同也。无量者与三禅乐。不共喜俱名不同也。以此三乐与众生时。无简彼此故云不二者亦是等也。第二言无嗔恨者。是二障对治。远云于怨加损名与不爱。于亲与乐名为与爱。此二是障如经无嗔。治初无恨对治后。又释于不爱者授与可爱。翻己嗔嫌名为对治。三清净谓离五盖令慈定净。此经略无。四无恼害者是摄果。谓慈定起于色界中受正果。慈行余势力后于欲界受于习果。故云于欲色界受正果习果。无苦恼事故。二信解力遍者明法念。涅槃中缘利生之法。瑜伽菩萨地缘诸众生五蕴等法。地论具二。先知凡圣众生法。二及众生下知众生心所起分别诸法。用以化生也。三满十方者明无念。论中亦二。初当体无念。二分齐无尽。如论应知。余三类慈故云亦复如是也

第二明五通果中作四门。一释名。二出体。三诸门。四释文。初中先释通名转变无壅名曰神通。五者是数。通者是义彰数义名即带数释也。别名中一名神足通。难测曰神。履涉称足。从用就喻为名。又释神是通用。足是所依之定。定与通为足故。定用从喻为名。亦名如意通。出没随心故。亦名身通。通慧依身故。亦名神境通。是通慧所变境故。二天耳通。三天眼通。光明义是天义。闻声是耳义。照导是眼义。并从根及趣以立其名。四他心通。能了他心。从境为名。五宿命通。亦名宿住通。往谢名宿。宿时色心相续名命。亦名为住。通慧照彼。亦从境为名。此五并是依主立名。谓宿住之通等准之。第二出体者。依萨婆多。凡夫五通若总出体。以通大地中慧数为体。若别即以等智为性。若经部宗。凡夫五通总以想智想定为体。若别即以十智中名字智为性。若圣人得同以名。用无流智为性。若大乘宗。总以别境中慧数为性。若别凡夫五通世俗智为性。圣人五通后得智为性。若杂集论定慧为性。第三诸门分别者略有五门。一辨所依定者。依小乘唯依四根本定。以依胜地发胜通故。未来中间慧多定少。诸无色定定多慧少。复无有支相助不能发通。经部亦同。大乘瑜伽显扬亦同前。若杂集论通依四定。多依第四。以功德胜故。二约三业者依地论。初一身业清净。天耳他心二通口业清净。宿命生死智二通意业清净。解云初即转变色形名身业净。天耳他心能起言说名口业净。后二以过未隔世难知。唯意能了名意业净。五通是智。理实皆意。但随用相故。作此分矣。三约业用者。地论约菩萨业用。初身通能到众生所。次二为其说法。谓天耳闻他言音不同随方为说他心知他心器所乐。要由此二方得说法。谓言声及义也。后二尽知众生过去未来所应受化故。解云宿命知其过去所习因以授法。天眼见其未来根熟方能受化。四约智见者。地论中前四通明智。第五明见。解云理实五通体皆是智。但为天眼照瞩分明废体从根说名为见。若尔天耳何不从根名闻。释理实应齐。但为智是见性。眼亦是见。见义顺智偏就眼说。五约所知分齐者。若凡夫五通但知一四天下。若小乘人依智论第六云。若小乘阿罗汉小用心。天眼见一千世界。大用心见二千世界。若大阿罗汉小用心见二千世界大用心见三千世界。义准菩萨。随位渐增。若佛总无限量。余通准之。第四释文者。五通则为五段。初神足通中论得三种胜自在。一初句动世界自在。约依报。二一句自身自在。一散。二合。三隐显。谓现没还出也。三约身作业自在有八种。略无注水。余如论辨。若依智论第六。如意通有三种。一能到。二转变。三圣如意。能到有四。一身能飞行。二移远令近。不往而到。三此没彼出。四一念能到。转变者。大能作小。一作多等。外道力转事极久不过七日佛及弟子久近如意。圣如意者于六尘中不爱不净。观令爱净等准之。是自在法。唯佛得之。乃至广说。二天耳通中以天耳过天人故。若苦若乐若粗若细若近若远等。声无不闻知。余如论辨。三他心通中。先总。后别。别中十句分三。初四知烦恼心。次二知报心。余四知作业心。论分为八。如论应知。初中前三知三毒有无。论名随烦恼。此是随缘现起故非是小惑名随。二垢等知其细惑性。成名为使故。次知报心。是无记心。人是小。欲天广。色天大。无色二。解脱名无量。此中名狭以定力多故。余知作业。前三净后一染。前中乱等约学定心未得故。或散或非散二定等约得定。得定后。或入定或出定或在定。三缚解等约慧。于缚得脱故。后一知染心。此中略无求不求心。有上等约慢。谓有上处起得想。是粗。于无上处起得想。为细故。论云粗细习行故。四宿命中。先总。次别。后结。论中分三。初谁能念。谓智。此释总句。别中一念何等事念一世界等二我生下。云何念因名字等念。此中种族者是家差别。谓生家等。姓者贵贱等姓。三知本某名。四知所食。五知苦乐。六知寿命。如经如是久住故。七知死此生彼。余如论辨。五天眼中。先总。后别。论中先释能见为总。初见众生死此生彼故名死生智通。审见委细故云清净。远见他方故云过人。二见何等事下总释所见。三云何见下明其见相。即别释所见。即是诸众生等。明善恶因果。指同二地说可知

第三是菩萨下明总结自在。论中具四。一禅结四禅。二解脱结四无色者。以八解脱中四无色是后四解脱故也。三三昧是四无量定也。四三摩拔提是五通者。此云等引。谓引起五通业用也。能入能出者。谓起心欲入起心欲出名生心时。即能入出名用现前不随生者。不为定等所缚故。前十种深念中淳厚心此处成就故也。虽入禅等。而以愿力生彼。增长菩提分处即与佛菩萨共生处也。此约自利释。瑜伽住品约利他释可知。行果竟

二是菩萨住于明地下明位果。于中三果即为三。初调柔果中四。初调柔行体。二忍行德。三别地行。四结说相。初中三。先法。次喻。后合法中言观一切法不生灭众缘而有者。此中论云于清净法中不见增。烦恼妄想中不见减。因缘集生故者。此故字有二义。一由缘集故无增无减故云不生灭也。二由缘集故有增有减故云有生灭也。此一缘集之因成此二义。是故常起因缘对治。离染成行而恒不见有生灭相也。欲有无明缚皆微薄者。断一切修道欲色无色界所有烦恼及彼因同无明习气。皆悉微薄远离故。解云此是贪等烦恼障现行并种故云及彼因。与当地所断所知障种同此位灭故云同无明习气皆微薄。以未尽故但云薄也。地经中诸见缚。先于初地已断故也。不复集断三毒者。以断细不断粗故。二是菩萨忍下明忍行德中有十心。他人加恶名辱。心能忍受名忍。善护他心释安乐也。以此二心分别已下诸心故云分别示现。言作恶怀疑者。谓有众生曾损恼菩萨自恃已恶疑菩萨嗔故云也。然菩萨将护身与彼同爱语诱诲。故云现同伴侣爱语等也。此释同和心柔软心。此中美妙心具彼二心也。不坏心者被身加恶不嗔故。不动心者口恶骂不报故。不浊心者忍时心不忧恼故。不高下心者过去久行不憍慢故。是故今能下就与其善言。谓于己不高。于他不下也。地经有二句。一以道化他不求他敬。二施恩及人不望他报。若有悕敬望报时。少不称意即便生嗔。今由无此故成忍因。此中初施恩不念。后小恩大报。不谄曲者非不实释不谄。及无偏心释不曲也。以菩萨谦下随物相同谄曲故。今明实等也。不染心者。微细隐覆垢染心。皆悉离故显净也。余文可知

二偈颂中三十五颂分五。初二颂起厌行分。二有二十四颂厌行。分三。初四颂护烦恼行。次六颂护小乘行。次十四颂方便摄行。三有二颂厌分及行果。四有六颂位果。五末后一颂结说

第四焰地中亦七门。同前初释名者。唯识第九云。安住最胜菩提分法烧烦恼薪。慧焰增故名焰慧地。摄论云。由诸菩提分法焚烧一切障故。无性释云。此地中有焰慧故名为焰地。世亲释云。能烧一切根本烦恼及随烦恼皆为灰烬。名焰慧地。庄严论云。以菩提分慧为焰自性。以惑智二障云薪自性此地菩萨能起焰慧烧二障薪名焰慧地。金光明云。能烧烦恼。以智慧火增长光明。修行道品依处所故名为焰地深密经第四及瑜伽七十八及显扬论大同此说智论名增妙地。如十住论云。施戒多闻威德炽盛故名焰地

第二明来意者。亦有三义。一前地明定。自下诸地明所发慧。依定发慧义次第故。此依解深密经。二前之三地寄在世间。今此出世。义次第故次来。此依十地论辨。三前三地虽得世定总持而未能得菩提分法。舍于定爱及法爱故。是故此地修证彼行故次来也。此亦依深密经

第三所离障者。依十地论离解法慢障。以第三地闻胜流教法生解起慢。四地翻此故以为障。依梁本摄论名微细烦恼共生身见等无明。彼论以法执分别种子为体。如梁论第十具释。又成唯识论第九名微细烦恼现行障。谓所知障中俱生一分。第六识俱身见等摄。最下品故不作意缘故。远随现行故说名微细下论释世亲摄论云。分别我见有三。一最初断细故名为上品。二分别起故三不能远到故名为粗。今此俱生最后所断故名下品。任运起故。远到第四方可断故。是故此障异彼粗故名微细也。上论彼障四地菩提分法。以入四地时便能永断。彼昔多与第六识中任运而生执我见等。同体起故说烦恼名。今四地中既得无流菩提分法。彼便永灭。此我见等亦永不行。初二三地行施戒修相同世间。四地修得菩提分法方名出世故。能永害二身见等。下论释云。以前三地同凡三行。由斯未断迷理我见。四地出世方能永断。烧薪之焰依此立名。二我见言或二障同体我见。以正断所知烦恼不起同名永断。理实但除法执我见。或法执中我我所见为二身见。或分别俱生名二身见。尽处总说故说四地断二身见。此三释中初释为胜。上论宁知此与第六识俱(此问也)。第七识俱执我见等。与无漏道性相违故。八地以去方永不行。七地以来犹得现起。下论释有三因。非是第七。此即初地。上与余烦恼为依持故。此粗彼细。伏有前后故。此但与第六相应。身见等言亦摄无始所知障摄定爱法爱。彼定法爱三地尚增。入四地时方能永断。菩提分法特违彼故。由斯四地说断二愚及彼粗重。一等至爱愚。即是此中定爱俱者。二法爱愚。即是此中法爱俱者所知障摄。二愚断故烦恼二爱亦永不行。金光明云。味禅定乐生爱因无明。微妙净法爱因无明。深密瑜伽并同上辨

第四明所证者。依梁论名无摄法界。彼论释云于最胜真如及真如所流教法。于中见无摄义。谓此法非我非他所摄。何以故。自他及法三义不可得故。譬如北鸠娄越人。于外尘不生自他摄想。依无性世亲诸本多同。唯识第十云。四无摄受真如。谓此真如无所系属。非我执等所依取故。解云等取同类我爱慢等。非彼依止处及所执取境。中边论云。犹通达此乃至法爱亦能转灭。解云与我执等同伴故

第五所成行者三种。一十度中成就第四精进波罗蜜。二成就菩提分增上慧行。三亦成悲智行。庄严论云。第四住能入生死而不舍觉分故。又如下文不住道行等(寻文知之)

第六明所得别果略有三种。一依梁论四地通达无摄法界得众生利益果。二金光明云。四地发心得不退三昧果。古人释。四地相同出世。由初证得故标不退。三调柔等行。十王摄报。并准可知

七释文者。三分同前。初赞请分。二显地分。三重颂分。初中八偈分四。初二明菩萨闻法欢喜供养。次一天女妙音歌颂地法。次四天王庆闻供请。于中初三庆闻供赞。后一请说后地。后一解脱月同请

二正说地相内。论中先明依前地净定总持今此地如实智净故说焰地。四分中。初是入地方便故云因。二是初入地出障行故云清净。三是正住地道品等行能有所除故。对治进修上上故云修行增长。四是地满即彼清净对治修行增长之果。又初一是地因。后一是地果。中二是地相。又初一加行道。次一无间道。次一解脱道。后一胜进道。何故解脱名对治耶。以翻障显地

就初中三。先结前标后。二正显十门。三结行功能。初中法明门者。明谓四地证智。以前地未得明相故。犹如地前四定中明得定。相似法者是所说法。即众生界等法也。门者地经名入。依彼智明入此法中。若能入名入。所入名门。又依此能至四地名为门也。二处顺行者正观思量是方便。如实知是正证。此二同依所说法故同顺行也。十中初五推能依至所依。谓初一观正报假名。二观正报所依心识。即本识是染净法所依处也。后五句依所依立能依。谓初三句明本识中所持染法。约处辨之。三界唯心也后二明所持净法。胜信解者犹是胜解。谓于所解印持。决定不令烦恼污心。次大心普被众生。不同二乘小心故。又释后五中。初三句起依报。后二句立正报

第二清净分中有三。初总。次别。后结。总中亦三。初于佛家转有势力。二得内法。三谓十智教化成就。此三皆以后释前可知。又初地即生在佛家。然前三地是世间。此地出世故云于如来家转有势力也。又论释云。依止多闻智究竟者。此释转有义。谓依前三地多闻之解得此四地出世间慧名智究竟。理实亦依前地禅定。以教化之智依前所闻法故偏举之。论云除灭智障摄胜故者此释势力义。谓除前地分别解心名除智障。亦是灭当地所断所知障也。得此四地殊胜之慧故云摄胜。二释内法中。论云此如是净胜等者牒前以释也。谓净牒除障。胜牒摄胜。并于佛家得故。如来自身等者当相释也。有三句。初就人显法。名为内法。即显如来自身所具之法。二以辨法成人故。名此法为如来法。故云以是诸法显示如来。三谓十种下释十智教化谓此智与四地证智法明一体无异。得无前后故云同时得。此与所观法明同时。非与观察同时。十中论摄为四。初心不退者。论释自住处毕竟智。谓大乘法是菩萨住处。住于大乘心不退转名毕竟智。二于三宝等者同敬三宝毕竟。谓于三宝同信不坏故云毕竟。三修习下二句明真如智。即二无我正证智也。一观蕴等生灭流转本无人我。二观蕴等法亦本来不生。是法无我。四常修习下六句是分别所说智。即后得世俗智也。摄为二。谓染净。或为三。谓一染二染净三净。或为四。初二句依正二报。是苦谛。以随烦恼生故。次句中半句生死。论名世间。即是集谛故云以何烦恼。次半句涅槃。即是灭谛故云所有净。后三句是道谛故云随所净。又初中以烦恼等顺感器世间故。众生世间皆从业等因生故云同因也。次分别生死涅槃者是集灭二谛。亦是染净双观。虽全体不二而两法不杂故云分别也。下三句道谛。亦随顺涅槃净法故云随所净。一于佛世界中教化众生。成菩萨自业差别故云修习众生业差别。谓于众生成已差别之业。二前际是生死染法。后际是涅槃净法故云烦恼染及净也。三于前际染中不见一法可损。以其即空故。后际净中不见一法可增。以其性满故。又释前观前后际平等。今观现在世常灭无所有也。行是十智教众生故。即知于如来家转有势力也

第三对治修行增长分中有二。初护烦恼。是异凡行。亦自利行。二护小乘。是异二乘行。亦是利他行。前中明菩提分法略作四门(别作)

四释文中。此三十七种类分七位三四二五单七只八

初释四念处者。谓身受心法是念所住处故云也。新名念住。此四体实是慧。何故名念。以慧观守境。与念相近。即六释中邻近释也。身谓相续。受谓领纳。心谓集起。法谓轨持。此四并是所观之境。若小乘中。观身不净。观受是苦。观心无常。观法无我。是故此四除四颠倒。若大乘中如诸法无行经云观身毕竟空。观受内外空。观心无所有。观法但有名。解云此观人法无我故。准胜鬘经能除八倒。就身念处中。先观内谓自身。次观外谓他身。后合观自他。何故初别观后总耶。释有二义。一约破病不同。人有三类。一有人着内情多着外情少。如人为己身弃舍妻子及财物等故须观内。二有人着外情多着内情少。如人为财丧身为欲殒命故须观外。三有人内外俱着故须合观二约观行始终一人通观。谓有行人本于自身取为净相故。先观内内求不得。即谓外有故。次观外向者观内不能及外。观外之时复不能观内。是故第三内外合观。初中观内身者标别所观。循身观者正显观相循谓巡历。于身支分次第观察。精勤一心者显观所仪。谓行者欲破自身。非勤不辨故。须精勤故。龙树云。离别常人易离别知识难。离别知识易离别亲戚难。离别亲戚易离别自身难。行者今欲离别己身必须精勤。勤由专意故云一心也。除世间贪忧者明观所离。何故此中偏离贪忧。如龙树说。行者此中多生贪忧故偏除之。何者谓创弃五欲念本所爱。是故生贪。未得道法。所以生忧。是故但言除世贪忧。又释贪者凡夫多起着境难舍。受生之本三毒之初故。烦恼中偏说除贪也忧心。一向贪欲者起障定最重。禅中先离故。五受中偏说除忧。是故若说除贪余法随遣。若说除忧诸受随亡。犹如破竹。初节为难。若破初节余节皆随。贪忧亦尔。故偏说之。次观外身。后观内外身。类亦同然。就受念处中亦内外俱。于十二处中受唯是外法处所摄。何故此中有内等耶。释有多义。一自受为内。他受为外。二意相应受为内。五识相应受为外。三定受为内。散受为外。观此三受不离三苦故也。又智论云。菩萨观苦乐不苦不乐等三受。无所从来灭无所至。但从妄想颠倒生等。三就心念处中。自心为内他心为外。又五识为外意识缘外。为外。缘内为内。末那一向缘内名内心。又定散分内外。并观此心刹那无常。又观如幻无体可知。四就法念处中。以心法为内。不相应行及无为法并法处色等总为外法。内外合观可知

第二四正勤者。是善十一中精进数为体。但就止作各分已未故成四种。谓初二勤断二恶是止恶行。后二勤修两善是作善行。初中未生之恶遮令不生已生之恶断不令续。又已生伏现行。未生除种子。后二善中未生善法习之令起已曾习起使更增广。此即未有令有已有令增。此四皆由策勤方辨故名正勤。新名四正断。于二恶可尔。二善云何。谓断彼不作故即是勤修也

第三四如意足者。所作遂志故云如意。此即是神也。足是所依。即是定也。初欲定者由欲加行能起此定。果从因称故云欲定。此是行体。断行成者辨行功能。谓此定行能断诸结名断行成。又释涅槃名断。断家行成名断行成。修如意足者就前欲定明其所修也。依止厌下明前断行成也。于诸烦恼。加行道厌。无间道离。解脱道中证彼择灭。胜进道中趣求彼果。名向涅槃。又释资粮道中随分生厌。加行道中永伏名离。无间道中正断名灭。解脱道中证彼无为名向涅槃。又释若寄位言道前加行位生厌。见位断见惑名离。修位断修惑名灭。究竟位得彼极果名向涅槃。此等并是诸行治惑次第之相。不须别分觉分前后。何故念勤不明。此者以未得定故。得定方有此功能故。二精进定者亦从加行以立定名。三心定者余处亦名念定。谓系意住缘名为念定专心守境名为心定。并从方便以立其名。四慧定者。地论名思惟。瑜伽名观故。彼论中说此四名欲勤心观。谓明慧照察名观。或是定因。或是定果。余断行等类前可知

第四五根者。依此五行能生见道故名为根。下文离世间品云。一信根不可俎坏。二发大精进究竟一切事而不退转。三安住正念除灭乱想。四三昧方便决定了知。五智慧境界善巧分别故。解云此正经自约菩萨道释。依止厌等及第五五力。并准前可知

第六七觉分亦如下入法界品内(勘取)第七八圣道者亦如离世间品云。八正道是菩萨道。一正见远离邪见。二正思惟正念一切智。远离虚妄。三正语随顺圣教。离口四过。四正业饶益教化一切众生。未曾失时。五正命安住四圣种。成就头陀功德。具足净威仪。远离一切思。六正精进勤修一切苦行。修佛十力。无所挂碍。七正念悉能忆持一切音声。除灭世间一切乱想。八正定善巧方便于一三昧出生菩萨不可思议法门一切三昧故。解云此等并约菩萨道释可知。第二护小乘行中。初句是总。余九是别。初中菩萨行此三十七品。但为利益不舍众生。是故修行非如二乘为成自利行此道品。别中此不舍众生心。论摄为四。于中初三护小乘心。后一护小乘行。初一为起行所依故以本愿为始。二以悲慈益物。怜愍为心。上二护狭心。三为众生故。希求佛果故云为摄一切智也。此护小心。后五句名行修五种行。一起净土行求佛依果。二修起佛法行求佛正报。下二句求行彼因。三修彼地方便。无厌足行者谓求五地至七地。修时巧便无厌足也。经中欠此一句。四修不退者。谓求八地已上顺佛深解脱也。上自利行。五化众生行者是利他行。智慧方便善摄众生故也

第四大段彼果分中二。初行果。后位果。前中论释中得六种果。一烦恼染生远离果。二业染生远离果。三于胜功德中生增上欲心果。四彼说法尊中起报恩心果。五彼方便行中发勤精进果。六彼增上欲本心界满足果。初二是离障果。后四成德果。前中先离惑障中。论摄为五。初本身见。是起慢之本。亦是六十二见本故。我知是能知。大知即是所知大法。即是三地中解法慢也。我修是能修。复计禅定。是我所修。此是三地正受慢也。于中着我等是人执。阴入等是法执。出谓三昧起者计有出定。没谓三昧灭计有入定。又释出谓修起诸禅。没谓退失禅定。又远公云。出者修起诸定。没者定所除灭二起者起不正思惟起定慢也。推求心者是邪推求亦妄取定相。同论思惟也。三行者观心行于缘中于己所得八禅等法。求觅胜相欲令他知故云所行也。同论名多观。四过者坚执自己所得定等。心安诸事故云爱着。即定爱也。五护者数观胜相取胜属己。忆持在心。防己所得故云宝重所见等也。皆悉断灭者五结除断。何故此中说此断灭。准成唯识论。此是第六识中俱生身见等及所起过。同第四地出世道品。能断除灭故。此说之。又释若约寄位。前地寄世间。此当出世为分世出世故此断除。若就此义亦得是分别所起。以仁王经说四地名为须陀洹位故得知也

第二业染生远离果。如论应知。经中略无也。上来是前护烦恼家果

第三是菩萨转倍下。明于胜功德中。生增上欲心果。于中十句。初总中牒前起后。谓牒前护小乘家智慧方便。故行助道分等。二随所修行下别显依前所起之心。正明欲乐心。谓由前策勤所修力故。于上功德见其实利。是故转起殊胜意乐。令心柔和求彼上法。于中成润益心者。以见胜德能润益故。起深欲心故云深欲爱敬故也。下别释中。柔是柔软。谓证法适神名乐行胜。二和是调和。谓三昧调心。缘中无碍名自在胜。此二是行体。下七为一名对治胜。是行功能。一总明离过。谓堪任有用下别离六种过。一对治不能离恶过。谓对治求法无疲。不为食利。不为妒名。离此过也。次二对治不能摄善过。二治不摄功德行。三治不摄智慧行。四治不摄众生过。上四是自分对治。下二胜进对治。一解。二行。五自见取过者违其解也。尊教不顺显其过相。对治如经可知。六舍为首者如说修行。望于闻思为胜为首。今舍彼首故是过。余文可见

第四是菩萨尔时下明说法尊中报恩果。谓前地中从师闻法。即名彼师。为说法尊。从前地来。依法修行。今得成辨。称彼化意故名报恩。于中初一知恩报心。后九报恩行。初中论释。彼成知恩心者随顺行。报恩行者释知恩。为报恩故须知也。下九别显报恩行。一明报恩心。二能将护同法者顺说者心名为报恩。谓内心和善同止安乐三依法起行。以为报恩。谓随顺受教不违师命名曰直心。四发修行事。逢苦能忍名为软心。五于修行离过。为报师恩。谓不说己德名无邪曲。六自过不覆名行正行。七实德行成亦不自高故云无憍慢。上来约行。下二就解。八依教受语明得师言。九不颠倒受明得师意。如是下结行成就。于中如是具足善心软心者。论释是前对治修行增长。谓彼对治于此成就故云具足也。具足寂灭心名对治修行增长力者。名前二。远离果为寂灭心。是前护烦恼对治力也。具足忍辱心等论名彼果。即是此报恩行果。前二句显是等者。谓初句善心成。次句寂灭心成。合此二句为第三名善寂灭心成。以为彼果

第五是菩萨尔时成下明发勤精进果。不转者不休息故此为总句。下别显九种。一自乘不动故云不舍。二论中共染者。若过谓耽着精进。共懈怠者。若不及离此二种平等胜进故云不染也。三一切魔烦恼行不能破坏故云不坏也。四常至心顺行故云无厌惓。五广念利他故云广大。此是利心也。六为无量众生作利益愿摄取故云无边。此是利他行。七勇悍难当故云猛利。论经欠此。八修习过余故云无等等。九摄取众生故云救众生等。论中更有一句可知

第六是菩萨修习下明本心界满足者。依菩提分乐欲心满故云直心清净。下别显中。一彼求道品之心。由前精进修行增益故云不失深心也。二于胜上证中。转生决定心故云信解明利。三彼上证之因。治过行增故云善根增长。四除灭诸障故云远离世垢。五除此地秘密疑事故云不信皆已灭。六以除疑故。于余处决定故云无疑无悔等。七依化众生力。谓佛力能化众生故云于一切佛等。八依胜乐行。内证相应故云自然习乐。九依现无量三昧心。智障清净故云无量之心等。上来行果竟

第二菩萨住是第四下明位果。三果即为三段。就初调柔果中有四。一调柔行。二教智净。三别地行。四结说。初中先法。次喻。后合法中。先见佛为练行缘。二恭敬等为能练行。三是菩萨下明所练净。能练中有出家者。初供佛福行。后近佛慧行。一近佛。二听法。三信奉等思。四出家修行。初二地寄人王报故有出家。三地天王出家不便。今此四地寄当出世次辨出家。摄报不便。调柔中五地亦尔可知。金作庄严具者。论云喻阿含现作证智庄严。示现得证智故。二摩尼珠喻教智净。前诸地无者。为是世间故。此出世故有是用。又经中略无别地行相。余并如论应知

第三重颂中有二十九颂分六。初二颂前初增长因分。二有三颂前清净分。三有七颂对治修行增长分。于中初四颂护烦恼行。后三颂护小乘行。四有九颂前彼果分。于中细分可知。五有七颂前调柔等三果。六末后一颂显名结说。释第四地竟。第五难胜地七门同前

初释名者。唯识云。真俗两智行相互违合令相应。极难胜故。摄大乘云。由真谛智与世间智。更互相违合此难合令相应故。世亲释云。由此地中知真谛智是无分别。知世间工巧智是有分别。此二相违应修令合。能合难合令相应故。故名极难胜。无性释及梁论并同此。瑜伽论云。今此地中显示菩萨于诸圣谛决定妙智极难可胜名难胜地。解深密云。由即于彼菩提分法方便修习最极艰难名极难胜地。金光明云。是修行方便胜智自在难得故。见思烦恼不能伏故名难胜地。庄严论云。于五地有二种难。一劝化众生心无恼难。二生不从化心无恼难。此地菩萨能退二难。于难得胜故名难胜。显扬论云。证得极净缘谛所知诸法微妙慧蕴。成极难成。不住流转寂静圣道名极难胜。十住论云。第五地中功德力成。一切诸魔不能坏故名难胜地。仁王经名胜慧地。诸余经论多分皆同。问仁王经初地菩萨四天王。双照二谛平等道。如何诸论唯说五地。答三藏云。据实初地二谛双照而约任运故说五地。今释此是寄法显位。前地出世。此地却入实为难故

第二次第者亦有三义。一四五六地总寄二乘。第四寄当初果。第五寄当罗汉。第六独觉。前地预流。此名罗汉义次第故。是故次来。以预流创故。罗汉终故。用寄四五二地差别。中间二果略不寄显。此依地论等。问若尔何故仁王经第七地得罗汉果。答此二各别。地论约所观行相以配二乘。道品四谛俱声闻行。第六缘生是缘觉行。第七十度是菩萨行故非二乘。仁王下卷璎珞上卷约人配位。前之三地相同凡夫故。后四地配于四果以显地别。良由第七未离分段故寄同下位。二者二乘行中。道品居先四谛居后。义次第故。三者前地虽得出世。而未能随顺世间五明摄化。今此地中修证彼法。是故次来

第三断障者依十地论离身净我慢障。解云以前地出世以为身净。取以起慢。便障五地不舍世道。故入五地翻治此障。此等并是地背修舍。显增微故。唯识云。于下乘般涅槃障。谓所知障中俱生一分。令厌生死乐趣涅槃。同下二乘厌苦欣灭。彼障五地无差别道。入五地时便能永断。由斯五地。说断二愚。一纯作意背生死愚。即是此中厌生死者。二纯作意向涅槃愚。即是此中乐涅槃者。瑜伽深密同此可知。解云以前舍世间向出世间背染向净故有斯障。此地观四谛染净因果平等名无差别道。不同三地世间之染。不同四地出世之净。以于世间能出能入双现前故。故无背向断斯障也。金光明云。一意入涅槃。一意入生死。思惟无明。生死涅槃不平等心思惟无明。梁摄论云。一生死涅槃。一向背趣思惟无明。二方便所摄修习道品无明。解云此彼经论会意可知

第四所证者。依摄论证得相续无差别法界。世亲释云。谓于此中体无有异。非如眼等随诸有情相续差别各各有异。若如是知得入五地。无性意同。梁论少别。谓彼论中释此法界能令三世诸佛相续身不异。唯识云五类无别真如。谓此真如类无差别。非如眼等类有异故。解云谓此地中修得生死涅槃无差别道。由此了知非自他如得平等意。中边论云。由通达此得十意乐平等净心

第五别行者亦有四种。一十度中当禅定行。二当地中得谛观增上慧行。三庄严论云。第五住以得教化恼不恼心。以无我故。四下文亦成五明处行

第六得果者三种。同前。一依梁论。五地通达相续不异法界得无差别法身果。二金光明云。五地发心得宝华三昧。三调柔等可知

第七释文中三分同前

初赞请分中有十五颂分四。初二颂明菩萨众以三业供养。次有二颂明天王眷属三业供养。次有十颂天女叹佛。于中初一叙事。次八叹佛。初二叹因深果现。次二体极用希。谓此一类所化根器久来未熟故。今佛海于彼一类常恒堪然未曾起用。今既根熟感佛应机从体起用。故云从久远来大海相始动。非谓如来从久远来一切处未用今始方用。次二颂庆此希遇。次二颂叹佛德胜。后一总结天女叹已默住。末后一颂众首正请

第二正说中论分为三　初胜慢对治　二不住道行胜　三彼果胜

于中以加行道及初住地无间道合为初分。二以正住地分解脱道为第二分。三以地满胜进道为第三分。就初中胜慢对治者。远公云。慢有二种。一他地慢。谓前四地中得出世智。取彼胜相名为胜慢。下以十平等心翻彼名治。二自地慢。谓于此十心希求胜相。复以为慢。下以如道行对治。今释前地解法慢障。正地中对治。此地所治身净我慢障。是前地中得出世净。取以为慢。此地加行观十平等。正伏彼障。初入地时。无间道中正断彼种。是故此二俱名胜慢对治。以胜前地。初说治障。至正住地。但修胜行。于世出世无偏住着。故能随世以摄众生。于初分中二。先地加行。二初住地。前中三。初结前举后。二正显十心。三结能入地。就正显内。于平等中心得清净故云平等心。中此十平等与后六地平等何别。释以前地中取净法为慢故。此地中偏观净法平等。后地通观染净平等。此等并是地背修舍差别法矣。十中论分为二。初三名诸佛法。即果法也。谓三世十力悉皆平等。又释举力等取余功德法。后七名随佛法即因法也。于中前六自利。后一利他。前六中就行合为三学。初一戒行。次一定行。余四慧行。离为七净。一戒净。二定净。三见净。四度疑净。上二同一句。五道非道净。此前五种大小名同。后二名异小乘中。六名行净。七名行断净。以彼宗趣尽灭故。大乘中六名行断。七名思量菩提分法上上净。以此宗依其行断起胜求故。二就位辨者。若小乘初二在见道前。次三在见道。行净在修道。行断无学道。若大乘中行断思量菩提分俱在修道。余悉同前。何故初二在道前。谓要依戒定方能发彼无流圣慧。何故次三在于见道中。断身见故。得见净断疑故。得度疑净。断戒取故。得道非道净。入见道时十使俱断。何故言三。涅槃经说。此三重故。谓十使中五见及疑局障见道。余四通见修。就六中三本三随。谓身见为本。边见随。戒取为本。见取随。疑为本。邪见随。是故三结三随转断此三结立三净。后二在修者。以修道中断障成德故有二也。余文如论可知。第二菩萨住五地下明初住地。论名如道行。初总显中。善修菩提分者牒前四地所修觉分。依起此地十深净心。后依此心希求此地。不住道行胜即能得佛者。即能证佛所证真如。论经名随顺如道行。又论云。如是不住道行胜破彼慢者。谓前四地取道生慢。即净心为治。又彼净心希此胜道。复以为慢。如道为治。以如道行于如法中不取着故。亦名不住道行胜也。二是菩萨下别辨中八句。初二起行心。一大愿力习菩提心。是起自利行心。二慈心不疲。是起利他行心。余六所起之行。前三自分。后三胜进。三得福慧善根力故云得念等也。又释得念等三慧之力故。四修福智常不休息故云不舍。五正修善巧方便之行故云出生等。六胜进之始。上求无厌故云欲得转胜等。七行修转胜得他佛力加持故云也。八德成在已名自身得胜力。故云生定不退。论中有三慧可知。又以缘平等真如令心不退故也。第二如实知下明不住道行胜有二。一所知法中智清净胜即为自利。护烦恼行不住世间。二利益众生勤方便胜即为利他。护小乘行不住涅槃。此二说有前后。理实合行故名不住。若不尔者初应住涅槃。后应着世间。故知俱也。就初中先明四谛实法分别。后明十谛化众生差别。有此十种即是于前四谛作十门观察亦同。下文十门观察十二因缘相似也。故瑜伽住品。此地中云。于四圣谛由十行相似如实了知故也。前中苦集二谛有佛无佛体。是世间杂染因果。灭道二谛。性是出世清净因果故名实法也。就后十谛中。依地论及远公作四句分别。一制立者。谓四谛门中义合法界。菩萨于中穷照无遗。随智异论。广别难穷。且就一周圆数以辨十门。然并是菩萨自知知相难明。故寄所化以显其异。此乃约化显自所知故。论名所知法中智清净也。二开合者。或总为一。谓化众生分别。或随所化大小分二。初九化小。后一化大。或随化所起分以为三。前五化生。令其生解。次四化令起行。后一化令入证。或约人不同。离以为七。初一化根未熟。二化根已熟。三化疑深法者。四化谬解法者。五化离正念者。六七八九化正见者。十化于大乘可化众生。或随法不同分以为十。如文。若广分别数别无量。三对实法相辨通别者。此之十门于前四谛一一皆通。一世谛者通观四谛法相差别。二观四谛体空。三通观四谛非有非无。四通观四谛有无各异。五通观四谛缘起集成。六通观由迷四谛成于苦事。七由迷四谛起作集也。八通达四谛得证灭也。九通解四谛得成道智。十穷达四谛缘起实性清净法界故成大乘菩萨因果。四释文中二。先列十名。后次第释。论中小乘可化众生者。非是化众生令入小乘。谓化小乘众生令入大故云也。初一根未熟。不堪入大。为说四谛十六行等名知世谛。此是四重二谛中。第三重内世谛也。瑜伽云。依晓悟他故。解云经及瑜伽通诸根器。地论偏约未熟可知。二为根熟小乘堪入大故。为说第一义法空。经云一乘者令小入大。更无余乘故。又理无二故亦名一相。瑜伽云依自内智。解云此释不约所化也。三有人不解第一义谛一向断灭名为疑惑深法众生。知相谛者为知诸法非有非无一实相也。故云相谛。又释既闻真谛将谓断灭于俗。故名疑惑深法。今为分别诸法自相历然故云相谛。瑜伽依俱处所名为此说解云即前真俗名俱处所。四为谬解等者闻一实谛。谓定是一名谬解等。今知二谛差别非一。前即疑一。此即迷异。五既闻谛差别。谓各有体乖违正道。名为离正念者。知说成谛者知前差别四谛诸法但随言说因缘集成无有自性。故云说成。瑜伽云。于契经调伏本母名。由此说。六为正见众生者。令得知苦断集证灭修道。瑜伽云。依于现在众生苦自性。依于未来苦因生性。依于因尽。无生性。依于修习彼断方便性。经云至不二法者。谓道谛智能至无二灭理故也。七为大乘可化者。谓直进菩萨不从二乘来。者。知菩萨因果。于果位而知者但是信解力显影像观智非是佛果无尽智知。此简定分齐。下离世间品亦如是。简彼约行。此中就解。余文可知。第二菩萨如是下明利益众生勤方便。于中二。先总后别。初总中亦二。先观有为过。虚伪者观内五蕴。谓妄想常等不相似。无故虚。此明所取非实也。常作我想慢事故伪。此显能取不真。是妄是伪。谓于前虚相妄取为我等。二诳诈者观外六尘。谓世法尽坏故诳。此明所取不实。但是诳也。世法似续似若。有利而实速灭。无利可得而言有者是诳也。世法牵取愚痴凡夫故诈。此显能取迷真。谓由妄取令彼世法隐虚诈实。令其贪取。言假住须臾诳惑凡夫者总结内外。就人彰过。谓妄境引心名之为诳。心迷前境目之为惑。于前有为内外之中各境为诳。心为其惑。论中牒释可知。凡夫依止彼正取我慢身。新名异生。会释可知。下明正起慈悲。于中悲者怜愍彼众生故。大者胜前地悲故。转胜者不住道行胜故。慈者胜利益示现故。光明者救众生方便智成就故。二得如是智慧力下别辨中二。先牒前起后。智力牒前知有为过。不舍牒前。悲慈转胜求佛智正明为物求大义利。下正别显。中先悲后慈。就悲观中有二。先观缘集苦二又作是念下观深重苦。前中言观有为先后际者。总观先际因后际果也。知众生等下别中先观先际。于中初观流转后显无我。前中但言无明有爱者。显流转因是凡非圣。理实亦有业等余缘。何故不说。以无明发业爱能润业业感报。由此痴爱为本故偏举之。三求报起故云生。即先际果也。流转生死者是欲求众生也。于五阴等者是妄梵行求。是外道非小乘故云妄也。增苦恼聚者是有求。众生下显无我中。言无我无我所者。是中自身无我及彼无我事。第一义故无也。然世俗假立依命根力住。释命者也。数数受生释众生也。谓众多生死是众生义。数数即是众多义也。又释数数受生释人也。以梵名补特伽罗此云数取趣。即数数取诸趣受生故也。众生身心相续。非常非断故说有命有众生。此释明世俗假有也。破彼慢取意故说无命无众生。此释就破病说无。假法不待破也。远离能取等释离我我所也。下类显后际中。谓如前际。以何因牒彼痴爱。随所有众生牒前果也。随所有苦行牒前无我。谓但有苦果及苦因。行本无我也。经中究竟是论中尽字。不知究竟有出者离灭道也。不知无出者明不知有苦集也。二又作是念下明观深重苦。谓无量世随逐是其深苦。种种苦事是其重苦。初观众生受苦不厌离故云可怪。又于无所有中而生贪着故云可怪。下明可怪所由谓无明痴故。已今当灭者是无量世随逐苦也。二如是生死下牒前可怪后明种种苦也。谓不生厌可怪。况更造集令苦转增。五道苦轮者是身生苦。生死水漂等者是集爱也。归五阴等者明离彼灭道也。不知不畏等者明有病苦。谓四大相违故。似毒蛇不能拔出等者明具彼集。故释有四句。一妄梵行求众生不能拔出憍慢见箭。二欲求众生受欲者不能灭除贪恚痴火。三欲求众生行恶行者不能破坏无明黑闇。谓为见少利行大恶行。后受大苦名为黑闇。四有求众生不竭爱海不求十力等者远离灭谛。谓佛果大涅槃称为灭也。下明离道谛。随魔意者失道缘也。恶觉转者乖道因也。悲观竟第二如是苦下明大慈观。于中二。初愍众生修善。二发愿益生。前中先牒前苦众生处之孤独无救。谓于已现受苦无有能救。于未受苦无所依得免。此明在苦无救。经欠无依下明于恶无治。此经有二句。论经有四句谓近友闻法思惟修行。初善友阴人事等。如舍不能亲近故云无舍也。二闻法如洲。依之即免四流水所漂。不能听闻故云无洲。三静思穷义名为究竟。不能思故名无究竟。四修慧正见事等。如目不能修故名无目。唯我一人等者诸佛菩萨充满法界。何故言孤独。不欲复待彼助已度显示勇猛胜事故也。增长福智依向所化。令近成人天因远作涅槃因。毕竟净者令得涅槃果。无碍智力者得菩提果。余如论释。二如是思惟下明发愿益生。初句总。谓上文于苦无救。今明与善。皆为拔苦故云皆为度故。下别辨九种。一已住善者不令生退失于乐果。二不善众生令得修善。又此利乐不同如前具释。三济贫乏是顺缘不足苦。经欠此句。四救系囚是违缘所逼苦。于中先外缘所系苦。五病等是内因所发苦。六化令正住。七断疑令解。八三学令行。九令得灭果。不住道行胜竟

第三大段彼果分中有二。先行有四种。一摄功德胜。二修行胜。此二自利。是前所知法中智清净果。初自分后胜进也。三教化众生胜。四起随顺世间智胜。此二利他。是前勤方便果。初化他行后化他智。初中初三句论有二释。先配三慧可知。次配二巧。谓初句总举。二别知法。三别知义。亦是二持可知。以总摄别。是故论中名为摄闻胜也。次二句明戒胜。初微犯能悔。后坚持不犯。前中内有惭愧折伏柔和发露向人名为自护。又被化举罪。亦由惭愧能忍斯辱。名为护他。二戒无微缺名坚心不舍也。下五句明智。一知因缘智。谓果由因名是处。不由因名非处。此治无因。又善恶因得乐苦报。名为是处。反此为非处。此治倒因也。达此之智名为觉者。二证理智外分别名为魔事。证智能治名不随他。三知教智。谓正说为是。邪说为非。交参为杂。简邪得正名为随慧。四神通智。谓现神通能治邪。归众生令向正故。五化众生智。可知

二善集福德下明修行胜。于中十一种。一无厌为因。集福增长。二依进为因。求智不舍。三释如论可知。四不起邪思令戒光洁。论经欠此句。上四是自分行。下明胜进行。五起佛果法行。六起佛依报净土行。论释中具二种严。一约人。谓住处众生净。无烦恼是断德。坚智是智德。二约法。谓佛果位诸功德法以为严也。七依佛正报相好法身起彼行求也。八依佛三业作用起行。九敬重法行。以行依法成故敬求也。十愿取三有。巧摄众生。在染不污名心无碍。十一日夜常念摄取众生。离小乘心名离余心也

第三菩萨如是行时下明教化众生胜。于中初一句总明摄生。二以色身等别明同事应机。三以说法断疑别显爱语。下别明利行摄生。四于菩提无方便众生。不解菩萨所行道等。故示行事令解修行。五虽解修行。然疲倦不进故。示佛果大利益事以劝进之。此二化大乘众生。六为欲求有求众生。示世过患令不乐也。下二句化梵行求众生。七为小乘正梵行求不信大乘者。示佛大智广益众生。八为外道无智邪梵行众生。以身业现通。语业教道。令舍邪入正也。九总结。行成有四句。一因缘方便结前四摄摄生也。二心常在佛者为化众生求佛胜力故。三不失善根者所得福智皆不退失也。四又复常求等者彼所修行欲令增胜勤修行也

第四是菩萨利益众生下。明随顺世智胜染障对治中有十句。一知经书等。二金石等。三治病等。四伎乐等。五日月等。六施戒等。此六正是随世间智。七不恼事。八安生事。九哀愍出。十令入佛法。此四是结意。就前中初五是障治。后一是染治。以戒等离染故。就前中初句内治四种障。一书治所作事中忘障。取与等事中障也。闻法等解中障。作不作等行业中障。一作不作者善作恶不作。二于善中有已作未作。三于未作中随时益生应作不应作。二经者论经名论。因论治邪见以校量正理故。声论治软智。以解了文章声字生胜智故。三论经印者。印记分明不假守护故治彼障。又伎艺当印。又是六艺等文章亦是声论。四以数知多少。算记其位令不生疑故治彼障。上总是因声。二论也。二金石等者。以工巧论能治贫也。三治病下是医方。论病有三种。谓干消等内四大不调相。鬼着等是外众生相。蛊毒等通内外。亦四大是草毒也。亦众生相是毒蛇。此等或但成病。或致令死故为因也。咒药二种通别治其四。妓乐等治忧恼障。国土等治不喜乐障。金银等治世间系囚等障。五日月等能治报分过。作恶因障谓睹灾相。修善排恶故说治也。曜等摄者谓日月五星为七曜也。五星谓东方岁星等。二十八宿。谓角亢等。日月五星于中宿故。论中入八业果。一日。二月。三星。四宿。五吉凶。六动地。七梦。八想。此中名怪也。身中诸相者爱不爱果行故。谓由有过去爱果因行今有好相。不爱亦尔。六布施等是内明。论是染对治有六句。一施治悭染。二戒治破戒染。三禅治贪欲染。四神通治邪归染。五四无量心治妄行功德染。谓杀生祭祠而求福者名妄行德修。四无量能治也。六四无色定治妄修解脱染。以外道等妄取无色以为解脱故。下明后四起世间智。有四种相。一诸不恼等是异障中无障。谓无捕猎等恼众生之障。二安众生是与无过乐。谓乐不生罪故无过也。三哀愍等是发起清净。虽令众生无苦有乐而着欲放逸。是故愍彼故。令离放逸故云发起净也。四令入等所用清净。谓虽不放逸不求出道。是故令入佛法受用净也。又释此四句从后向前。结前六句。谓令入佛法结前第六施戒。二哀愍等结前第五。以示日等灾怪令离放逸故。三安众生事结初四门。以同与乐故。四诸不恼乱众生事。结前乱众生六中初三后二。以此五门即五明所摄能除闇障。俱而能生智。是故论中释前三句超举后二。良为此也。其第四句但为与乐而非生智。故非此结余。如远疏应知

第二就地果中。三果科释同前。言得转胜多闻三昧者。论经名多闻陀罗尼者。非义陀罗尼。谓对胜彰劣也。以平等净心难得等者对劣显胜也。以能具二难故得闻持。一地初平等心难得。二乐出世间现世间难。此是不住道行胜也。以此地智光证是真如事故况金器砗[(石*巨)/木]磨莹等。日月等喻教智净。依阿含增长智慧光明胜于前地智故。谓胜前地珠光故也。余并可知

第三重颂中有三十九颂。初十一颂前胜慢对治。于中初二颂十平等。次二颂道品。铠杖喻。次二胜行严身喻。次二师子吼法喻。次三颂前初住地同念不退心。论名如道行。第二常为下十三颂不住道行胜。于中初四颂前所知法中智清净。二如是观下九颂教化众生勤方便。于中初一颂半颂总观虚伪生悲慈二心。次三颂半颂悲中观缘集苦。次三颂观深重苦。次一颂大慈观事。第三常住正念下七颂彼果胜中。初一颂摄功德胜。次一颂半颂修行胜。次半颂教化众生胜。次四颂起世智胜。下七颂地果。初三调柔。次三半颂摄报。次半愿智。后一结说究竟难胜地竟

华严经探玄记卷第十二华严经探玄记卷第十三(尽第七地)

        魏国西寺沙门法藏述

第六现前地亦七门同前

初释名者。摄大乘云。由缘起智。能令般若波罗蜜多现在前故名现前地。世亲释云。谓此地中住缘起智。由此智力令无分别智而得现前悟一切法无染无净。无性释意及梁论等并同此说。解云由加行智引根本智。证于真如无染净法界令现前故。解深密经现前观察诸行流转。又于无相多修作意。方现前名现前地。解云此有二义。一现前观察诸行流转。二由多作意令无相观方得现前。庄严论云。不住生死涅槃观慧现前。名现前地。十住论云降魔事已菩萨道法皆现在前。仁王经名为法现。成唯识同摄论。瑜伽同深密金光明等。更无异说。十地论等如前已辨

第二次第者亦有三义。一前位寄声闻。此明缘觉。寄法过前。是故次来。二四地虽出世不能随。五地能随世间而不能破染净见。此地观察无染净法界破彼见故。是故来也。三唯识论云。前五地中有相观多无相观少。第六地中无相观多有相观少。第七地去纯无相观。今此地于无相观退少入多。是故须来

第三所离障者依十地论微烦恼习障。解云以此位中修无相观多。障与此违故说微习。又形前地障说此为微。理实即是所知障中俱生一分执细染净。违于六地无染净法界故以为障。良以五地超于三四染净别位合令同处。而二相未尽。至此方除故说微细。唯识论云名粗相现行障。谓所知障中俱生一分执有染净粗相现行。彼障六地无染净道。入六地时便能永断由斯六地说断二愚及彼粗重。一现观察行流转愚则是此中执有染者。诸行流转染分摄故。二相多现行愚。即是此中执有净者取净相故。相观多行。未能多时住无相观。解云初愚执苦集流转门。后愚执灭道净相门。金光明云。一行相续了了显现无明。二法相数数行至于心无明。解云此后无明还灭净相数于心现。违彼长时多无相观故以为障。梁论深密瑜伽同唯识辨

第四所证者依摄论证无染净法界。世亲释云。本无杂染。性无染故既无杂染。即无清净。唯识云六无染净真如。谓此真如本性无染。亦不可说后方净故无性中边并同此释。又中边论云。由了达此知缘起法无染无净。摄论云。了知此义入第六地

第五别行者十度中当般若行。当地中缘起观增上慧行。庄严论第六住不起染心。而依缘起受生故。寻下文

第六别果者梁论通达无染净法界。得自他相续无染果。金光明六地发心得日圆光焰三昧。当地行果及位果。寻文可知

第七释文中三分同前。初赞请分中十八颂分五。初二菩萨闻法供养赞叹。次二诸天欢喜供养。次二天王眷属供养。次十一天女歌乐叹佛功德。于中初二总叹说益。次三叹大智证空。次一叹大悲摄物。次四叹理行无碍。次一天女静默下一上首请说

第二正说分中。论同前地科为三分。但前却为异。谓前地趣地方便。及初住地同名胜慢对治。此中初住地入不住道行胜摄。以渐胜故。初胜慢对治者。以前五地观四谛法染净相故名取染净障。是故十平等通观一切法平等也。文中有三。初牒前起后。二何等下正显十行。三如是下结行入地。就正显中。此十平等分以为三。初八以无破有。次一以有破无。后一有无双破。又初一是总。余九为别。前中言一切法者。论名十二入为一切。以蕴中不摄无为法故。界处摄尽故。初十二处解一切法。以根尘境识此皆不离三无性故。是故云无性故平等。论经名无相者无性相也故。论二十二入一切法自性无相平等故。下九别中。论主立九种相对治现无相。初一句明十二入自相。但是妄想所作实无所有故云无相。论经名无想者。为明彼相即是想故云无想也。二外疑云。既所取唯想可说相空。想能现相。想应是有。论云念展转行相谓念犹想也。释意明此想念还依妄相展转无体。故云无生平等也。余经云从心想生与心作相和合而有。共生共灭同无有住此之谓也。三疑云。既说想相展转互依。是则诸法生成建立岂是空邪。释明相依想故所取不成。想还依相能取不立。互依两坏故云无成平等也。此上破于迷苦谛执。四疑云。苦是所生可说为空。集谛能生岂非是有。论云染相故。释明惑业本寂自性离故云平等也。此文在第八句。准论应在此处故此辨耳。五疑云。苦集染法可说为空。灭道净法岂非是有。论云净相故。释明染法既空无染可翻。不可说净故云本来净也。上来遣相。六疑云。若染净俱空即不应起种种言说。既有名言。明知即有所目之义。论云分别相者名言分别也。释云但名依义立。义由名现。观彼义因不见名果。又观名果不见义因。为此世间有得名不得义。有得义不得名。故知寻名取义。俱是妄想戏论故云无戏论平等。七疑云。若染净名义一切皆空。何故菩萨舍染求净。既有取舍。岂无诸法。又云妄法既空即验。真理是可证取。论云出没相者。净法可取名出。染法可舍名没。释明妄法即空无可舍离。真理离念不可取得故云无取舍故平等也。摄论云。若于生死非舍非不舍。若于涅槃非得非不得。又维摩云。若达生死性即是涅槃。于其中不取不舍者是为入不二法门。是此义也。八疑云。上起真妄有见。故以无破之。若尔断无二谛应当正理。论云我非有相。问此我非有。岂非正理。何故以为所治之相。答以取此我非有之相。同断灭无故是失也。释如幻缘起不碍存故。不同断灭故云以幻等故平等也。九疑云。我先取有即破为无。我复取无复说幻有。是故我今取亦有亦无应正道理。论云成坏相者。成是有相。坏是无相。释有二途。云我前破汝谓有故说无。非谓法体实是无。破汝执无故说有。非谓法体如情有。是故正理非是有无故云有无不二故平等也。一云我前说无。是不异有之无故非无。又我前说有。是不异无之有故非有。是故离无无别有可与无为二。离有无别无可与有为二。故云有无不二故平等。此中非是有无互遣名为不二。亦非有无合名为不二。亦非总无有无名不二。但是有则是无。无则是有。故名不二。思之可见。三结行入地中。初总结入位。二菩萨如是下别结。别结中如是观等牒前所观十平等法观。言能忍者忍受正理远离障垢故。又忍证深理无分别想故名忍也。随顺者谓此观智随顺平等真如法故。明利者能对治微细慢故。前四五二地亦同得顺忍。除障未细不名明利。以四地所除解法慢障最粗故。得耎品顺忍。耎犹下也。五除身净慢。中故得中品忍。此取染净法分别慢最细故得上品忍。故名明利。下品能对治上品所治。乃至上品能对治下品所治。障治相翻理必然故。言无生忍未现前者。以七八地上是无生忍位。此地非彼故云未现。然顺彼忍故名顺也。理实初地亦得无生。为寄五忍以配诸地。故作是说。谓地前名伏忍。初二三地寄在世间。名为信忍。四五六地寄二乘位名为顺忍。七八九地是菩萨位名无生忍。十地及佛地因果究竟名寂灭忍。此地是顺忍中上品故名明利。胜慢对治竟。第二是菩萨下明不住道行胜。于中有二。先就初住地以明不住行。二作是念下就正住地以明不住。前地劣故唯正住地方名不住。此地胜故初住地即明不住。就初住中二。初观一切等牒前起后。二大悲等正现不住。论经四句。初三明能观之心。后一所观生灭。此经略无大悲满足。然此三心释作六重。一辨相者。愍心创起故云悲首。论中以殊胜大悲摄三世众生故也。二求果愍至称为增长。又上求佛果名为增长。论中以于所知缘起令智清净。即此净智为佛果本故也。三厌离有为心。论中观一切种微细因缘以生厌离。缘观细极故云满足。二明次第者乘前观空便念众生虚妄所缠故。先起悲。以悲念故求佛果智。以益众生。次起增长佛智。必由离过而成。是故末后起观缘生过患终极。三约二利者。初一利他。后二自利。四约二护者。前二护小乘。一护狭心。二护小心。后一护烦恼。五约因果者。初后摄因中一求果。六约不住者。初一不住涅槃。后一不住生死中一俱无所住。就所观生灭中。十二缘生顺生逆灭故云观世间生灭。此是总观。下以十门别观彼法可知

二正住地中。广显缘起义略作四门。一总明法界缘起。二别辨十二有支。三料简分齐。四正释本文。初法界缘起略有三义。一约染法缘起。二约净法。三染净合说初中有四门。一缘集一心门。二摄本从末门三摄末从本门。四本末依持门并如别说。二净法缘起者亦有四门。一本有。二修生。三本有修生。四修生本有。如下性起处说。三染净合说者亦四门。一翻染现净门。二以净应染门。三会染即净门。四染尽净泯门。亦如别说第二别明十二有支者具如别章

第三料简分齐者作三门。一就本经。二约释论。三经论对摄

初中本经内有二重。先别明十观。后显名重结。何者十观。一因缘分次第。二一心所摄。三自业助成。四不相舍离。五三道不断。六观先后际。七三苦集。八因缘起。九生灭缚。十随顺无所有尽观。于中各有顺观逆观。故有二十门也。谓顺观大悲不住涅槃。逆观大智不住生死故名不住道。前五地中观四谛染净。以明不住此地胜故。唯于染法起逆顺观以明不住故也

二释论科者。论主通于此十番缘生作三门分别。一就厌离有为心中释此十番。此即是前大悲满足观。二就深念众生心中释此十番。名大悲随顺观。此即是前大悲为首。三约求佛心中释此十番。名一切相智分别观。此即是前大悲增上。此三与前三次第不同者。前约生心次第。今约正行次第。谓先自离过。次念众生。后求大果。与前别也。此三门中各观十番即有三十门。复各有逆顺故有六十门分别缘起观。三经论对摄者有二门。一相对。二相摄。先相对者。上论主但取经中初住地处三心。分别十门缘起。各具逆顺为六十门。今寻下文彼果分中。更以三解脱门观因缘集。即验通前成一百八十门分别缘生观。又释论主所以不依经中十门次第解释。乃更改势作彼三门别解释者。意许经中十门自释十二缘生义。已显现不待释故。初住三心历此十门。义隐难知。须释方现。是故别作此三门释。由此当知。经论合举。总为四重释此缘生。一一各十。即为四十门。各有逆顺。即为八十门。以三空观之。总成二百四十门。分别缘生法。应知此意。二相摄者。论初门内开为三段。一名成答相差别。此摄经中初因缘分次第观。二名第一义谛差别。此摄经中第二一心所摄中半门观。三名世谛差别。此摄经中后八门半。于此三中。初一现妄我非有。后二现真俗非无。义理周备故。第二大悲随顺观中分十为四。一名观众生愚痴颠倒。摄十中第一门也。二名余处求解脱。摄第二门也。三名异道求解脱。摄其次四门也。四名求异解脱。摄后四门也。第三一切相智分别中分十为九。一名染净分别观。摄初半门。二名依止观。摄初中后半门及第二门也。三名方便观。摄第三门。四名因缘相观。摄第四门也。五入谛观摄第五门也。六力无力信入依观摄第六门也。七增上慢非增上慢信入观摄第七门。八无始观摄第八第九二门也。九种种观摄第十门。释相并准思可知。第四释文者。释此十门即为十段。一一门中皆作四门解释。一依经别释。二依论。初约厌离有为释。三约大悲随顺释。四约一切相智分别释。如是四重依经及论收摄方尽

就第一段中四门之内。先约经文。名因缘分次第观者。此中正现有支无我观。于中有二。初明倒执有我妄起缘分。二又作是念下明迷诸谛理起缘次第。初中有三。一辨定无我二迷成缘起。三结依位行。初中二句初言世间受身由着我者。反举或情明我非理。若我理有着我顺理。应得出世。既生世间。明我非理。二若离着我即无生者。顺举解心。明理非我。若理有我。离我违理。应生世间既得出世。明理无我。二一切凡夫下明迷此无我起彼有支。于中先顺观缘起。后逆观无我。前中随邪念等者。是余经中不正思惟为无明因也。愚痴着我者。正是初无明支也。习起等者明行支。由彼无明迷世因果造于罪行。迷出世因果造福及不动。谓感三恶趣业。及于人天别报苦业。皆是罪行。感欲界人天业名福行。感色无色界业名不动行。三以是行下明识支。然识支余论说有二义。一是所引。谓本识中异熟识种。此取种子。二是能引。谓五果种子所依本识名为识支。此是现行第八。今此文中约后义说。以是行支为能引故。引起识中五果种子。令熟至有故云以是行故起有流心种子也。此为能引所引一对。言有流有取心故起生死者。由爱取有故生生老死。此是能生所生一对。以五果是名言种子通无流位。今行所引明非无流故云有流也。此中无爱字者是略也。四所谓下辨识生名色等。然有六缘。如世种植。一业为地者。望所生报为增上缘故。如地也。二识为种者。五果种子为彼亲因故。如种子。但以能依种子不离所依之识故云识如种子。此即举所依通取能依故也。三无明覆者。受生时无明迷父母等。如世种植下虽有地中有种子要须上有土覆。四爱水润者。于父母起染爱等心。润其受生。如虽土覆要须湿润。五我心溉者。计有己身。能有所作如虽湿润须人溉灌。六种种见者。以异见网覆令无流法不能得坏。如世种植须网罗护不令鸟雀所损。言生名色牙者明所生果。谓识入胎时。五果种子为无明业引爱取润故俱熟生果。但现之有前后。皆前引后起故云因名色故生诸根等。非谓名色是诸根亲因。余亦如是可知。三是十二下明逆观无我。四菩萨下结位所行并可知。二又作是念下明迷诸谛理起缘次第。于中亦二。初顺。后逆。前中不如实知第一义者此有二义。一通举第一义谛。是十二有支所依之本。明依真起妄现有支无体。以无明最初故。先明依起余支类。此皆依真起。二别显此是无明所迷。谓此无明由迷二谛造于三行。是故论经名诸谛第一义也。前段明所造三行。此中现所迷二谛。文绮互耳。由各为增上缘力。引前起后。令相续成立故也。有四取阴者。但识支有二义。一若赖耶为识支。余识即属名色支中名支摄也。二若通第六识亦入识支。即色受想行。此四阴为名色支今约后义故作是说。余文可见。逆观中无作者是人空。无作事是法空。依经释竟

第二依论约相谛分别释中三段内。初门名成答相差别。于中门别有四。相从为三。要摄为二。总之为一。四者一举彼解惑显成无我门。二论经愚痴下。经本一切凡夫下明责情现理三依论经无智下。依经本痴盲等下名辨相现实门。四不知第一义下明依实辨相门。二相从为三者。四中初一名成。谓释成无我。次二名答。答现无我。后一名相。谓依诸谛理立缘生相。要摄为二者。前之三门宗现无我故。一处举释。后之一门宗现缘生。依真起相故。别举别释。总为一者。谓第一成答相差别也。论云五道中所有生死等者。释世间所有生处等也。下开三门。就初释成中四句。一总释成无我。二一切世间下牒举经也。即无我义成者。但案经即是现成无我义。三若第一义下即事现成无我之义。有二句。一若实有我不成凡夫过。二若我实有不成圣人过。何者若第一义中实有我者定其所取。着我之心即第一义智者辨定能取也。不应世间生者正出过也。谓若第一义中实有我相者凡应是圣。此为立宗。以有能证第一义中实我智故。此为出因。如诸圣者为同法喻。此则凡同圣智过。应无凡夫理既不尔。明知无我。又圣应同凡宗。因云以理实有我圣证为无。违理倒惑非圣智故。如诸凡夫应生世间同喻也。此则圣同凡倒过。应无圣人。理既不尔。明知无我。此坏圣失也。准前此文欠一句。应云离着我心则应非是第一义智。无我既非第一义谛。离我之心岂可得名第一义智。言应常生世间者以理正征。若离我心非胜义智应不证涅槃。常生世间故。前句中凡夫既有第一义智属道谛摄。应得涅槃。不在世间。此文现于无我真理同前可见。四现示下举经对现可知。第二释答中。谓难在文外故云答也。有两难二答。初执情征理难。情乖正理答。难云若理实无我。应着无我。云何着我。既着于我不着无我。明知有我如虚空无人。岂有计人。立量可知。下答以痴所盲故。于无我处而执为我。如目有翳空中见华。岂可空中有此华也。比量可知。二如是实无有我下执相征实难。相不依我答。难云若当有我可令无明作缘行次第。既云无我唯为次第乃至老死。此示现下举经正答。由痴造业业行起识乃至老死。如世种植相生次第。何用我耶。答意如此。于中悕常为有。求断为无。希求是爱。无智是痴。烦恼无量。何故偏举此二种邪。以是有支根本故。次释行中三句。一释邪念。二邪道。三妄行。以菩萨行有不妄行。故次释识支等。先并举经文。是中下释以异熟赖耶正是报体故云示生老死体。又释种子识为彼因故云如来藏赖耶体也。又释为生死性故。谓此识体复能随顺摄持余支种子。令得成就能所引生故云随顺摄取等也。罪福等业为地。远释云。如是住者是色支。如是生心者是名支。结所生名色也。今更释如是住者是识种业地。如是生心者是痴覆爱润。此结上四文也。又释此总标经中我心灌等。谓作如是安住。生如是心。我是我所等谓见己为我。如男子受生见父精为己有故为我所。又见母为己妻亦是我所。女人反此。言我我想是慢者牒前我及我所二想为慢。自见与父共竞女色。谓己得胜。便起想慢。女人亦尔。言我生等释见网。谓远云。见已唯在此处生。不余处生故云我生不生。又云见常为我生。见断为不生。今释见己正报以为我生。见所游依报名为不生。以受胎时或见游华林或居殿堂等异见非一故云种种。以见执难舍如网覆也。下释逆观。以缘起法无性故灭。非是智力断故名灭。下结前生后。若缘无我。更依何法。缘相得住。下举经对现明缘起相依真而起。论中无明作业。称名色者。远公引婆沙。名色有二种。一方便名色。二报名色。若言名色缘识是方便名色。若说识缘名色是报名色。今既说行以为名色。故知是彼方便名色。言彼依止者。阿赖耶识是彼名色等所依止故。此约依持门说。二名色与识共生者。是相生义。三相依义。谓识由名色得起。名色由识得存。下释逆观。作者作事人法皆空。是名结前。云何问后证此真谛得解脱。答今举缘生以辨彼观故也

第三约论大悲随顺中四段之内。此名第一愚痴颠倒者。不解无我名为愚痴。谬执有我称曰颠倒。论中初总释。谓菩萨观此第一门十二有支总是痴倒。随顺菩萨大悲之心故云此事观故也。下别释中。先解愚痴。后一切凡夫下释颠倒。前中先释痴相。谓着我故生。离我不生。举离不生现着是痴。次释痴名。云何问也。无明闇者。以无慧明体是闇故名为愚痴。经怙可知。二释倒中。痴盲着我如是倒者。是取我之倒有相有支中疑惑倒者。是取我所倒。此释经中无智求等。乃至尽此一门。皆是颠倒。菩萨观此。于诸众生深起大悲

第四约一切相智分别者明此十二有支总是一切种智所知之法。摄十为九。此初门中前半为一。名染净分别观。谓着我为染。离我为净。然此一文具含多意。且举四释。谓经中明是妄取我故起此缘生次第之相。二论家初意。举此解惑以现无我。成无我观。三举离我不生现我是痴。顺成悲观。四取此解惑以为所知染净之法。下半门以是依真起故属后依止观摄也。释初门竟

第二就一心所摄中亦四门同前

初约经分二。先明心作三界。是约集起门。后明心持十二。是约依持门。前中言三界虚妄但一心作者。此之一文诸论同引证成唯识。今此所说是何等心。云何名作。今释此义依诸圣教说有多门。一相见俱存故说唯识。谓通八识及诸心所并所变相分本影具足。由有支等薰习力故变现三界依正等报。如摄大乘及唯识等诸论广说。二摄相归见故说唯识。谓亦通八识王数差别所变相分无别种生。能见识生带彼影起。如解深密经二十唯识观所缘论具说斯义。三摄数归王故说唯识。谓亦通具八识心王。以彼心所依于心王无自体故。许彼亦是心所变故。如庄严论说。四以末归本故说唯识。谓七转识皆是本识差别功能。无别体故。楞伽云。藏识海常住。境界风所动。种种诸识浪。腾跃而转生。又云。譬如巨海浪无有若干相。诸识心如是。实亦不可得。解云既离水无别有浪。明离本识无别六七。广如彼说。五摄相归性故说唯识。谓此八识皆无自体。唯是如来藏平等显现。余相皆尽。经云一切众生即涅槃相。不复更灭等楞伽云不坏相有八。无相亦无相。如是等文成证非一。六转真成事故说唯识。谓如来藏不守自性。随缘显现八识王数相见种现。故楞伽云。如来藏为无始恶习所薰习故名为识藏。密严经云。佛说如来藏。以为阿赖耶。恶慧不能知藏即赖耶识。又云如来清净藏。世间阿赖耶。如金作指环。展转无差别。又胜鬘经宝性论起信论皆说此义成证非一。七理事俱融故说唯识。谓如来藏举体随缘成辨诸事。而其自性本不生灭。即此理事混融无碍。是故一心二谛皆无障碍。起信论云。依一心法有二种门。一心真如门。二心生灭门。然此二门皆各总摄一切法。胜鬘经云。自性清净心。不染而染。难可了知。染而不染。亦难可了知。解云。不染而染。明性净随染举体成俗。即生灭门也。染而不染。门即染常净本来真谛。即真如门也。此明即净之染不碍真而恒俗。即染之净不破俗而恒真。是故不碍一心双存二谛。此中有味深思当见。经云于谛常自二。于解常自一。论云智障极盲闇。谓真俗别执。皆此义也。八融事相入故说唯识。谓由理性圆融无碍。以理成事事亦镕融。互不相碍。或一入一切。一切入一。无所障碍。上文云一中解无量无量中解一等。舍那品云于此莲华藏世界海之内一一微尘中见一切法界。又此品下云于一微尘中现有三恶道天人阿修罗各各受业报。如是等文广多无量。如上下经说。九全事相即故说唯识。谓依理之事事无别事。理既无此彼之异。令事亦一即一切。上经云知一世界即是一切世界。知一切世界即是一世界。又云知一即多多即一等。广如经文说。十帝网无碍故说唯识。谓一中有一切。彼一切中复有一切。既一门中如是重重不可穷尽。余一一门皆各如是。思准可知。如因陀罗网重重影现。皆是心识如来藏法性圆融故。令彼事相如是无碍。广如上下文说。上来十门唯识道理。于中初三门约初教说。次四门约终教顿教说。后三门约圆教中别教说。总具十门约同教说。上来所明通一部经非局此地。又是约教就解而说。若就观行亦有十重。如一卷华严三昧中说。第二依持门中有三。初标宗。二所以者何征责。谓小乘中十二有支。三世次第前后引生。如何说言皆依一心。下释云。离本识心一切不成故。于中初总释三支。俱唯是识。后别辨余九亦唯是识。前中言随事者随其行业。于何趣中从中阴内。起求生爱心故云生欲心。此心起时与本识中识支种子同时起。至生阴时此求生心灭。唯本识托歌逻罗等。如种坏牙生等。故云是心即是识。论经贪欲共心生者。谓第六识中求生时。贪欲共阿赖耶识同时起故。中阴未时。贪灭心续名为受生。彼所造行变为境界。谓殿堂等。名为诳心。以不知故。取之为实名曰无明。此是受生无明非是发行无明。此中大意明受生时。行事是能引。欲心是能润。此二于识支前说诳心。无明亦是能引。以诳故。令取亦是能润。此二居后。引润本识中五果等种生所生果。现起分位有次第故说名色等。是故十二有支皆唯是识。识外无物。文意如此。余文可见

第二约厌离有为。就相谛分别者。论释此是染依止观。言二谛差别者。论主意将所依心体是真谛能依有支是俗谛故。此一文名为二谛。此释总标文也。言一心杂染和合因缘集观者。释所以者何下文。谓一心是真。杂染是俗。即明此心随染和合双辨二谛。是胜鬘中不染而染等

第三约大悲随顺分别者。论名余处求解脱。是诸凡夫如是愚痴颠倒。常应于阿梨耶识及阿陀那识中求解脱者。此是举正现邪言乃于余处我我所中求解脱者。此显邪乖正。以诸愚夫背正从邪。深可悲愍故。此对治下举经显治可知

第四约一切相智分别者论。名依止观。谓分别有支依止有二。谓依真性及依心识。此中二谛通是二依。明是大智所了之法也

第三自业助成中亦四门同前

初约相用分别。此十二支皆有二义。一明自行相。二助成后用。谓缘中痴惑是无明自相。与行作因是助成业用。论经名自业成。问于四缘中此十二支具有几缘。答成唯识论第八云诸支相望增上定有。余之三缘有无不定。契经依定唯说有一。爱望于取。有望于生。有因缘义。若说识支是业种者。行望于识亦作因缘。余支相望无因缘义。而集论说无明望行有因缘者。依无明持业习气说。无明俱故假说无明。实是行种。瑜伽论说诸支相望无因缘者。依现爱取唯业有说。无明望行。爱望于取。生望老死。有余二缘。有望于生。受望于爱。无等无间缘有所缘缘。余支相望二俱非有。此中且依邻近顺次不相杂乱。实缘起说异此。相望为缘不定。诸聪慧者如理应思。解云缘起经说。唯增上缘一切定有。因缘四位。谓二是实有。一但增爱为取。无别种故。二有支中具五果种。望生有亲生义。若唯说业以为有支即无因缘。二是假说。谓无明持行种识为业种。其等无间缘有三位。一无明望行。二爱望取。三生望老死。其所缘缘有五位。于前三位加有望生受望爱。余之六支总无所缘及等无间。余义如别说

二约厌离有为分别者。于染因观内名他因观。以前支望后异故名他。前能起后与他为因故云他因。各辨行相显他义。各能生后显因义。论释死支。以不见知令相续者。此是无明。何故属死。释此是死时。无明因死而起故也

三约大悲分别中四门内。此当第三异道求解脱。于颠倒因中求解脱。倒因三种中此文治彼自性因故云不应如是求。何以故者将欲广释故征也。谓我佛法中因前支起后支。断前因故后果不生。即得解脱。汝说冥性为因。纵知之何由可脱。故云不应也。言因缘有支等者。总举经文显正治邪可知。四约一切相智分别中九门之内。此当第三名方便观。因缘有支二种业能起因缘事者。略释显之前巧起后名方便等。余文可知

第四不相舍离观中亦四门同前

初约不相离者。谓前能起后。离后无前。后依前起。离前无后。不相离故各无自性。无性缘起如幻现前。此为顺观逆成一真理平等观。经文可知

二约厌有为分别。论名自因观。无明等自生因观缘事故者。谓无明生行是自生因。问无明行异。云何名自。答以行赖无明无自体故。缘力全摄。非是分故。前明不即故说他因。此显不离名为自因。有人引此子果之文。明无明支有种子现行者。非此文意。又远公以五义释此文。明子时是前无明能生后无明。令行不断。与行别时。果时是后无明从前生。助成行故。与行同时等。今寻此文。意只发行无明为子时。所发之行为果时。以行是无明果故。说无明有二时。问无明望行无亲因义。云何说行即是无明果时。答无明是行增上缘。故名为子时。行是无明增上果。故名为果时。文中有四。初开义门。二明不离。三显不即。四总结同。初中先开。后是中下释。言子时令行不断者。以无明为行因故有二种义。缘事示现者。以子时为缘果时为事故。余支二义类此应知。故云余因缘分等。二自因者下释不相离有三句。展转释成初自因者不相离故。二云何不离。以现见离前支无后支故。此显离子无果。故说果为子果。三不离无明即成行者此顺释。不离子无明即成果故名不离也。三若不离下释不即义。先显二过失。后引中观论颂释成。言不即因者以是所生非能生故。不异因者从于能生生所生故。以果不则因故。果不断。因不常。以果不异因故。果不常。因不断。又以不则故因果俱不断。不异故因果俱不常。又亦反此思之。又以则不离是不则故即不常为不断也。亦思之可见。四自生下总类结同可知

三约大悲分别者。谓邪见众生执颠倒因内。自在天为众生因。甚为可愍。今此文中。显无明作行等故对治彼执故为因观也

四约一切相智分别者当第四因缘相观。有支无作故者明此有支非直后依前故。明后无性亦乃前能作后前亦无作。故诸缘起是种智境界

第五三道不断者四门同前

初约经为三道不断者。烦恼有二。谓能发能润。虽诸烦恼皆能发润。然发业位无明力增。润业受生爱取力胜故。偏说也。以无重发立一无明。数数溉灌故分爱取。业亦有二。谓未润已润业。在引因爱取未润初起。造作相显名行。业在生因。爱取已润。近生当果立名为有。此约唯业有说。苦亦有二。谓在因与果。识等五种唯是报因。生等二位但是报果。以就所引因位难知差别相故。依当果位别显五支。谓续生时因识相显。次根未满。名色相增。次根满时。六处明盛。依斯发触。因触起受。尔时乃名受果究竟。依此位立因为五支。果位易了差别相。故总立二支以显三苦。然所生果若在未来。为生厌故说生老死。若至现在。为令了知分位相生说识等五。具如唯识论第八中辨。又此惑业苦三为流转之相。如净意菩萨所造十二缘论颂云。烦恼初八九。业二及与十。余七说为苦。三摄十二法。从三故生二。从二故生七。从七复生三。是故如轮转。一切世间法唯因果无人。但从诸空法还生于空法。解云此辨三道相生显二无我。广如彼释

二约厌离有为分别者论名摄过观。所谓三道摄苦因苦果。深厌离故也

三约大悲分别者论名异道求解脱。内对治苦行因。谓邪苦行但是烦恼业妄想因故。非乐因故。如经是中无明爱等。四约大智分别者论名入谛观。三道是苦集谛故。是大智所知法也。瑜伽几支苦谛摄。及现法为苦。答二谓生及老死。问几支苦谛摄。当成为苦。答五谓识乃至受种子性。问几支集谛摄。答所余支。解云当五因二果俱是苦谛。惑业五是集谛摄。又唯识论第八云。皆苦谛摄。取蕴性故。五集谛摄。业烦恼性故。解云此则苦摄十二。以是取蕴性。集唯摄五可知

第六分别先后际中亦四门同前

初约经。分别先后际者。此十二支初二是能引。次五是所引。次三是能生。后二是所生。于中分别三际。诸圣教中略有三说。一依此经开能所引分先际中际。合能所生总为后际。以引远故开之。生近故合也。二依唯识论开能所生合能所引。是故前十现在。后二未来。以十因二果分二世故。三生引俱开妙智论。初二过去。次八现在。后二未来故成三世。唯识论等十因二果定不同世。因中前七与次三或同或异。若二三七各定同世。如是十二一重因果足显轮转及离断常。又由此三际因果轮回。人法二我永无所有

二约厌离有为者论名护过观。谓外人与此缘生道理出三种过。一一切身一时生者列过名。何以故者外人自征立过所以。无异因者释立过相。以无我异因。何为不得五道之身一时并生。二中列名。征立可知。无作者故者释立过相。若无我作业谁受来报。三中列征可知。释中既无有我。谁持是业令使至果。是故应失。前不受报据前望后说。此中失业据后望前说。此三下总牒彰护。谓过现因。别名为异因。以此答前三种难故名为答。亦通取下句。现未果异。由彼异因云何得有一时生过。又差别因得差别报。云何乃言有不受报。差别之报由异因生。云何得有失业之过。下释文中。先释过去内。无明缘行是见过去者牒举经文。下释中二句。初明过因能作现。二现果由过因。说现识等以为当来。此中但说过去因则足。何须复说现为其当。欲以因果相属防三过故。则是见下释已总结过去是因义。二释现在中。言识乃至受见现在者牒经文。释中二句。初明现果由过因。二复能下明过因得现果。现在是彼过去之未来故云得未来果。三爱取下释未来中。先牒文。言复有生者释从爱取等起有生死名有生也。问前释过现皆二世相对。今解未来何故不然。答以彼过现经中自分为两也。故须相属以成护过。经中自说爱取有三从果为未来。不假论主相属故不论也。言一往定者结别前文。以上来所明是一分三世名一往。理数如是称之为定。下释展转三世相生无尽故云复有后世生转故也。此说何义下释前护过有三义。一泛明业不得果。二举经明得。三双结得不。前中先总举。由三义故令过去业不能得报。一或有未作者就过去求爱取有等。尔时未作故。于现在不得生老死果。问观此文。意似说过去无明未作业行。何因乃云爱等未作。答若无明未作业。何因乃言过去业。三义故不得报。言或有已作未得报者就现以求爱取有等。虽已作竟以未熟故。现在不得生老死果。或得对治者。若已润业熟。计应次此未来得生老死果。或于此生若得圣果者。断爱取故令已熟之业则便燋亡不得报。二是中无明下明举经三义得报。谓过去既有无明缘行。故知已作不同爱等。现在既得识等五果。明知则是业已得果。由现在爱取无圣道断令未来生死相续不绝。三是故下双结中。有已作是行支。未作是有支。已得果是识支等。未得果是生支等。圣人已断凡夫未断。下正结护业。既有如是差别。何容有一切身一时生过。谓有作未作。何缘一时有得报未得。云何一时。有断未断。如何得一时。若尔下重牒显示非一切业当受者。是前已断也。亦非不受者是前未断。亦非一时者显前作未作得未得可知。若自作下护第二不受报过。谓自作自受。何不他受。以他不作故。三离彼三事护第三失业过。谓由离前三种不得。是故诸业无不得果。故无失业过。下结可知

三约大悲分别者。菩萨见诸外道行异道求解脱中计无因等。起大悲心。观此缘生。救彼邪执。论言先中际因者。过去二支是先际。与现在识等中际为因故。言及中后际因者。中际爱取有与未来后际为因。言中际前后二际故者。于中际内识等五果分属前际。爱等三因分属后际。既有此因。云何言无。是故结云若无如是因事则种种众生果事亦无也

四约大智分别者论名力无力信入依观。过去二支望现有力。望后无力。爱等三支望后有力望前无力。又释过二有力。现五无力。现三有力。后二无力。以皆能生为有力所生为无力。菩萨举此。化人令离邪入正故云信入。依菩萨智照故云观也。言先中后化胜者重释成先中后。是力无力化胜是信入。谓照三际以化众生。为种智故也

第七三苦分别中亦四门

初经明。此有支皆是苦聚。将释三苦。因辨受俱分别。瑜伽云几乐受俱行。谓除二所余。解云除受及老死余十有乐受。以受不与受俱故。老死位中多无乐故。几苦受俱行。谓即彼及所除中一。解云唯除受支余十一是苦受。几是舍受俱行。如乐受说。以老死位多无客舍故。几不与受俱行。谓所除中一即受支。以受不与受俱故。唯识论亦同。次三苦分别有二门。一理实遍通门。如瑜伽中几支坏苦摄。谓乐受俱行支及非受俱行支一分。几若苦摄。谓苦受俱行支及非受俱行支一分。几支行苦摄。谓所有坏苦苦苦支亦是行苦支或有行苦所摄非余二苦。谓不苦乐受俱行支及非受俱行支。一分。坏苦摄十支全及受支中一分。谓乐受。除受支中苦受及老死支。苦苦摄十一支全及受支中一分。谓苦受。行苦摄坏苦苦苦。皆是行苦。或有行苦非二支所摄。谓不苦不乐受。是故行苦通摄十二。唯识第八亦同此说。二随相增显门如此经说。谓初五支迁流相现故称行苦。触受二种触对生苦故云苦苦。余为坏苦者但坏乐名坏苦。老死支既无乐可坏。何故名坏苦邪。释坏苦有二。一乐坏为苦。望所坏说。二以坏是苦故云坏苦。此老死支能坏生故。故属坏苦也。余文可知

二约厌离有为。论主世谛观六种之中此当第五。名不厌厌观。谓凡夫不厌。菩萨能厌故云不厌厌。此约粗苦。又二乘不厌。菩萨能厌。此约细苦故云种种微苦也。以分别此等皆是苦故。及厌种种粗苦者二乘所厌。菩萨亦厌。又亦得前细是行苦。此粗是彼余二苦故

三约大悲随顺分别者。愍诸外道不达真理求异解脱。真解脱有四。举正显邪。一离一切苦相者涅槃乐德也。二无为相者是常德也。三离染相者是净德也。四出世相者是我德也。涅槃经云于世间法自在远离名为我也。言彼诸行苦下辨邪异正。于下四段经文各配一义。今此当初。言苦事随逐乃至无色有缚者。举此三苦现彼外道求非想等为涅槃者。菩萨观之皆是十二缘生。三苦之法何有涅槃乐德之义。故顺起悲

四约一切相智分别者。此当第七增上慢非增上慢信入观者。声闻之人不觉细苦自谓无苦名增上慢。然觉粗苦非增上慢。举此令彼二乘信入大乘缘生微细苦事。菩萨照此故名为观。不如实知下释成慢相。此之一门前约大悲以化外道。今就大智以摄二乘。以文含多意。论主善取故也

第八因缘生者亦四门

初约经。理实无明望行无因缘义。而言因缘生行者有二义。一自种为因。无明为缘。合说故云因缘。然隐彼亲种显此胜缘故云无明因缘也。二但彼增上缘望自增上果。还是亲因故。说无明为行因缘。余亦如是。欲明果不自起要从因缘因缘形夺复各无性。是故言因缘生乃显无生。此犹顺观。逆观一泯非生不生可知

二约厌离有为中世谛观六门中。此当第六名深观。此深观中摄后三门合成四句。一不自生。二不他生。三不共生。四不无因生。释此四句诸论不同。略有五说。一约破外道。谓诸法不从冥谛自性生故云不自生。二不从梵天自在天等生故云不他生。三亦非微尘大种和合生故云不共生。四亦非无因自然而起故云不无因生。二约破二乘。一谓诸法不定从自同类因生故云不自生。二不定从彼异熟因生故云不他生。三又亦非彼俱有因生故云不共生。四小乘中许无明支前不正思惟托虚而起。似若无因。今亦不尔故离无因。三约法显空。一果不自起名不自生。二自既不立。对谁辨他。又他亦各自。皆不成自。云何他生故云不他生。三自他因果既各不成故云不共生。四离因缘外无别果法故云不无因生。此上三重如般若灯论及中论等说。四约因缘形夺。对法论云。自种有故不从他。待众缘故非自作。无作用故不共生。有功能故非无因。凡诸缘起亡双二句已为甚深。况总亡四句。是故缘起最极甚深。五约缘起无碍门。但因缘生果。因缘相望各有二义。一全有力。二全无力。谓因望于果有全不生。缘必全生故。云因不生缘生故。二缘望于果亦全不生。因必全生故云缘不生自因生故。三二力不俱故不共生。四二无力亦不俱故不无因生。此门有二义。一据力具有不有义故令相入。谓因有力时缘必无力。是故由因有力故能摄他。由缘无力故能入他。会彼缘力。总归因力名不他生。虽言不他反显自生。因力归缘不自亦尔。反前思之。以二力二无力各不俱故无彼不相入。一力一无力相归故恒时相入。以不相障碍增上缘宽故一切诸法无不相入。十忍品云菩萨善观缘起法。于一法中解众多法。众多法中解了一法。良由此门故也。二据体有空不空义故有相即。谓非直因力归缘。明其相入。亦乃因体。由缘显因性空。摄同于缘。何者谓若无缘则无因故。以生果名因。无缘果不生。是时不名因。明知此因会归彼缘为不自生。是故缘是有义。无不能摄。因是空义。无不所摄。因受摄故废已同缘。缘能摄故摄因同已。余因摄缘受等并准思可知。由此义故诸法相即无所障碍。上文云知一即多多即一等皆此义也。是故无尽大缘起法无碍自在皆从此门而开现矣。此中言因无明诸行生者。论经云无明因缘行生者。彰因起果。明非他作。言因缘能生行者明果由因显非自作。又以无明是行自因。故非他作。亦先无行体在无明中后还生行故非自作。余亦如是准思可见。此一门中论主开为不自不他二句也

三约大悲分别者。明诸外道求异解脱中。显彼所求非想天等以为涅槃。菩萨观之。但是有支缘生之法非是无为涅槃常德。是故菩萨随起大悲也

四约一切相智分别者。于九门内以第八第九二门合为一无始观。远公云。是真谛观也。见法缘集。无本性故名为无始。今谓因缘起法的无元本依之始起故云无始。维摩中依无住本立一切法。同此义也。中际生故后际生者。举法释成。谓此缘生则是不生故名无始。是谓大智所知之法

第九因缘缚说者亦四门

初约经。是因缘生缚者。谓此缘起互相缚住不得是生。以是缚故复非是灭。以一缚字印此法体离诸分别。然是缘起缚相亦离故。寄言以显故云缚说。为明此缚但在说中。此门显缘起法事相。向尽理性将现极微妙处故。论云随顺观世谛则入第一义谛。是此门也。释文可知

二约厌离有为深观四门中。此是第三不共作。言非二作者。或因为自。以缘为他。或果为自。以因缘为他。此二自他俱不作故。若自他俱不作。何得为缘生。为释此疑故云但随顺生。谓随俗说生。理实无生。言无知者故者。远公释。此别释非他。以无我知者能造作故作时不住者。别释非自。明彼无明作行之时无行自性。住彼作时。还起后行故云作时不住也。今更释。因正有力时。缘必无力故。不得相知故云无知者故也。此是因缘不共果起之时名曰作时。于因于缘的无所住故云不住。此是因果不共。正作果时。此作不住于因不住于缘。亦不住果故云作时不住。此义正是经中缚义可知

三顺大悲分别者。谓诸外道求异解脱。以非想等为涅槃。菩萨观之。但是有支非离染缚。失于涅槃真净之德故生大悲。故云如是复染生缚也

四约一切相智分别内。无始观中名随顺缚故。谓生灭唯缚。随顺无本故也

第十无所有尽观中亦四门

初约经明此有支虚相既尽随顺无所有彻到第一义。此显不坏俗而恒真也。故云无明因缘诸行生。是随顺无所有。问无明生行是顺所有。何故乃言顺无所有。答乘前诸门。次第至此。显彼无明正生行时则顺无生入理故也。经意如此。问顺观既尔。逆复云何。答生既性尽。则所有无所有。俱离故云随顺无所有尽观说。说义同前。思取其意

二约厌离有为中名。第四非无因作。随顺有故。何故经中顺无。论名顺有。释经意以缘归理说。论意以性从相说。各现别义故作是说。又释论中顺有意显无生。是故与经意亦不别。下别破无因。一纵破谓应常生故。二夺破谓恒不生故。三此非佛法下呵诘破。谓说无因最大邪见。若尔下结非无因。是名下释说总结。言相谛者。相是前成答相也。谛是前二谛差别

三约顺大悲分别者。谓诸外道求异解脱以为涅槃。菩萨观之。是十二支三有之法。随顺有求。妄取无色以为解脱。失于出世涅槃我德。菩萨愍此顺起大悲

四约一切相智分别。此是第九名种种观。谓三有相别各多类状故云种种也。随顺下释现其相。此是三有世俗之境。大智照此故以为门。上来别释十门竟。二如是逆顺下总结十章。既云逆顺十种。明知前十门中皆有逆顺。前文中有无逆观者是略故也。一有支行列。二摄归一心。三力用相生。四前后相属。五三道轮还。六三际因果。七三苦过失。八从因无性。九似有若无。十泯同平等配结前十文。皆可见。释不住道行竟

第三大段彼果胜中。文别有二。初行果。后位果。前中论分有五。初得对治行及离障。是前胜慢对治果。二得修行胜。是前不住道行果。三得三昧。望前治胜以说果。谓前修三脱以说对治。彼治转增名三昧胜。四不坏心者望前离障以说果。由灭障故。三昧之心不可破坏。名不坏心。五自在力者望前修行以说果。谓依前修行上进无碍名自在力。下别释中释此五则为五段

就初文中二。先明治胜。后显离障。前中释三解脱门义略作五门。一名体。二行相。三治障。四摄行。五差别。如别说。言是菩萨随十二因缘下正显于前十门有支皆有如此三空观门。先明空门。论中分三。初见众生无我。二自性空者见法无我。经中略无此句。三彼二作无。以见无作者故。谓前二句显二我体空。后一句现二我用空。亦即前是无我。后无我所。言如是下结可知。二言灭此事下明无相门亦三义。一灭障者观彼有支自性灭故云灭此事也。问此与前无我何别。答前就诸法以明无我。此中欲遣能取相心故不同也。二得对治者常解脱现前。经中略无此句。三念相不行者见因缘处。无少法相可生故云余不相续。远公云。此三中初灭障者取性心亡。二得理为治。三取相心灭不见少法生故。离分别取相之心。前灭取性不同凡夫。今离取相不同二乘。三知此二下明无愿门亦三。一前二则是无愿所依故云依止。二更不乐有者显无愿体故云体性。三唯大悲等胜出二乘故云胜也。二菩萨修行下明离障胜。初离彼我等是空门所离也。二离有相者是无相所离也。三离无相者是无愿所离故云离有无相也。以不取无相故说无愿。余经云以无相故无所愿求。此之谓也。论中如是次第。于五地下举劣显胜。初举五地显此空门离我之胜。此文是倒。若正应言以十平等深净心故远离也。则远离四地身净我慢。今以深空灭彼二我故此胜也。二举四地离障现此文中离作受胜。三此六地等举此地初十平等处破有无等。显今地满无相无愿破遣有无一切荡尽。故云胜也

第二悲心下明修行胜有二。初正修行。后显修胜。前中亦二。初发勇猛修行者。谓始修决绝也。二菩萨如是知下明丈夫志修行者谓果决修终成。前中亦二。先修行心。谓以三空观彼有支。愍诸众生处而不觉故云悲心转增。由悲增进是利他心。未满菩提等是自利心。下明修行胜。于中二。先修智不著有为。后化众生下修悲不住无为。前中亦二。先知后厌。就知中烦恼业生。合散具阙有增有减。二既知此法有是过患。则生厌离不应令合故云我知有为等也。是故论云知有为法多过远离生业烦恼等。下修悲化众生可知。二丈夫志行中亦二。先智。后悲智中。论名厌对观者。有为名对。见多过观者重释成也。灭对者明有为性灭故云无性等也。与大慈等明修悲可知。二则得无碍下明修行胜。于中二。先胜相现前。论云智及大悲胜随顺者。牒前二行之中各有悲智。能上顺也。依不住道无碍般若现前者。明依前悲智不住之道令佛地无碍智光现前。知有为涅槃平等者解智悲不住所以也。不共住者解不住义。谓智不共有为法住故云而亦不住等。又悲不共无为法住故云亦不住其中等。彼助道行不满故者释不住所为。为满智助道不住有为。为满功德助道不住无为。故云欲具足等

第三菩萨住现前地下明三昧胜。于中二。先明空定后明余二。前中先举十空上首后结多门。此中一万论经名百千万也。前十空中论摄为四。一观是观解。二不放逸者依解起行离过为名。三得增上者因修成德得上功德。四因事者依德起用。三昧是大用本故名因事。初中除第四三昧。余五名观。一生空观。二法空观。三合取二空名第一义。四依本识观二种如来藏中。是空如来藏。故云大空。五观七转识。不离如来藏。和合而起。皆无自体故云合空。楞伽云。七识亦如是心俱和合生。又云不坏相有八。无相亦无相。此之谓也。二不放逸者。分别善修是自分也。修行无厌是胜进也。二修满足故云究竟。三得增上功德者。胜德依空生起现前故云生空。四因事者余三三昧。一依此空定令智障净。因是事故名如实离妄也。二依空起悲不舍众生。是故论经名不舍空。三依空三昧。愿在诸有远离染著名离分别。然随顺有离不分别。余文可知

第四是菩萨住现前下明得不坏心果。十句中初一总。深心者深彻难动。论经不坏心谓坚固不退。余九为别。一于理信观。二行堪受调。三于甚深秘密之处能不惊怖。四自分不失。五胜进无歇。六不嫉他德。不破己戒。二行普净故云广心。七慈普益生。八求上地智。九巧化众生

第五如是等心下明自在力胜。于中三。初总。次别。后结。总中如是等心者得般若也。转胜增长者行力胜也。随顺菩提者能深入也。胜力有九。就总开别。一下伏力。二上解力。三舍小力。四信深力。五摧魔力。六治惑力。七遍治力。八巧化力。九治障力。并如论辨。三是菩萨下结可知

第二菩萨住现前下明位果。于中三果同前。就调柔中三。初调柔行内听受正法。如说行者论经得三昧慧光。释以得义持能如说行。因彼事者因彼义持事。是故说此。依胜三昧得奢摩他。是前如实三昧也。毗婆舍那是前智慧光明胜也。行行已忆持者能持彼行故。所炼净中言是人乃至明净者。解脱彼障释所炼净也。证彼义故释知佛法藏。释喻中。出世间智增上者显证智体净也。光明转胜者示现用胜以显体也。以教智光胜显证智亦增上也。乃至以方便智等者释合喻文也。无碍般若是佛智光明也。方便是前不住道智也。二释教智净中。前地取月轮喻故小。此地取月光喻宽大故胜前也。随顺四流是魔所行故云魔道。此名恶魔。是彼魔道。三是名下结说相。摄报愿智并准前可知。第三大段重颂分中三十九颂分五。初三颂前十平等法胜慢对治。二有二十颂不住道行胜。于中初一颂前初住地心。总观缘起。二有五颂初因缘分次第观。三有二颂一心所摄观。四有二颂自助成。五有一颂不相舍离。六有一颂三道不断。七一颂三际差别。八一颂三苦差别。九一颂超颂第九生缚观。十有一颂却颂第八缘起观。十一有一颂半颂第十随顺有尽观。十二有二颂半颂结十门名。三菩萨如是下六颂半颂彼果胜。于中初三颂对治胜。次一颂半颂修行胜。次半颂三昧胜。次半颂不坏心胜。次一颂自在力胜。四供养下八颂半位果。于中初四半颂调柔果。次四颂摄报果。略不颂愿智果。五末后一颂叹深结说。释第六地竟

第七远行地者。释有三。一约功用后边。摄大乘云至功用行最后边故。世亲释云。谓此地中于功用行得至究竟。虽一切相不能动摇。而于无相犹名有行。二约二义。解深密云。能远证入无缺。无间无相作意与清净地共相邻接故名远行。解云无缺无间远于前六邻接净地近后第八。三约三义。成唯识论至无相住功用后边出过世间二乘道故。故名远行地。此同十地论。金光明云。无流无间无相思惟解脱三昧远修行故。是地清净无障无碍名远行地。庄严论云。菩萨于七地中近一乘道名为远行。问谁是远去。答功用方便究竟此远能去。由此远去故名远行地。十住论云。去三界远。近法王位故名身远地。仁王经名远达地

二来意者亦有三义。一前寄二乘合显菩萨次第转胜。是故须来。二于无相观前地未纯。今此进入纯无相。是故须来。三前功用未满。此地中满。是故来也

三所离障者依地论离细相习障。解云以第六地有相观少名为细相碍。于第七纯无相观故以为障。唯识论云。细相现行障谓所知障中俱生一分执有生灭细相现行。彼障七地妙无相道。入七地时便能永断。由斯七地说断二愚及彼粗重。一细相现行愚。则是此中执有生者犹取流转细生相故。二纯作意求无相愚则是此中执有灭者尚取还灭。细灭相故。纯于无相。作意勤求。未能空中起有胜行。解云以所知障执于缘起流转之生还尽之灭。细于前地所离四谛染净粗相故以为名。问此后一愚正迷还灭细相。何以不名还灭愚。答此愚有二用。一执还灭相。二纯作意求无相。且依后义立名。又释相有二种。一有二无。取无之相名为细相。若依此释。求无相则是愚。梁论名一向无相思惟方便无明。金光明云。一味执思惟欲断未得方便无明。诸余圣教可准通释

四所证者。依摄论证得种种法无差别法界。世亲释云。谓于此中契经等法虽有种种差别安立而无有异。无性释云。如契经等种种法别。此不如是。唯识云。法无差别真如谓此真如虽多教法种种安立而无异故。解云谓此真如虽教法中名为法界及实际等安立多名。体无别异。故立斯名。又释以本从末真如流出种种教法。以末从本种种教法皆归真如。此与三地各证一义。又释教法随机种种安立不失平等一味之法。是此所证中边论云。第七地中所证法界名种种法无差别义。由通达此知法无相不行契经等种种法相中。诸本摄论同

五所成行亦三种。谓一十度中当方便善巧行。二当地成就双行无相行。谓则空方便智发起有中殊胜行。三学无功用行如此下文说。及庄严论第七住虽行功用。而上参一道多住无相故

六地别果。梁论通达种种法无别法界得一切法无相果。金光明七地发心得如意三昧。当地行果位果如文

第七释文者亦三分同前。初赞请分中有十四颂分五。初三天众供赞。二有一颂天王供养。三有一颂半余天王等叹法作乐。四有七颂半天女赞得。于中初二颂半叹佛身业利益。次一叹佛语业利益。次三叹佛意业利益。次一叹已默住悕闻后地。下一众首请说第二正显地体中。论分为五。初一趣地方便是加行道。次一初住地是无间道。次一正住地是解脱道。次一义该始终说在正地。后一地满是胜进道。初言乐无作行对治者。前六地中受着三空名乐无作。此地随有不着于空故名对治。此是地地皆舍修法也。二彼障对治者。前加行虽治前地乐空之心。以其有量有功用故则后是障。是故初住地中修无量无功用行。以为对治故以为名。三双行胜者。垢障既除。止观俱运。四前上地胜者。此地功用过前六地胜后三地故立斯名。五地满足故名双行果。下广释中

就初分内有三。初结前举后劝修趣入二正显行相。三结行功能。初中论云彼菩萨乃至非起增上行者总举前地乐无作障。下明能治。谓方便者不舍众生。法无我智对治摄取增上行此治于无作行中生乐心也。起十妙行者发起殊胜行。此殊胜行于出世间及世间增上行更无胜。即初二三地是世间。四五六地名出世间。彼行劣此。故云胜。胜犹妙也。下别释十行。一一皆有即空方便慧发起有中胜妙行。此中十行论摄为四。初三各为一。后七为一故为四也。此中初句同论经第二句。谓即三空而起四等故也。论言护恶行因事者举方便智。谓慈不恼生名为护恶方便。与此为因故名也。言如是下明发起妙行。以即空起悲故名不妄行等。二随诸佛下明财及身胜。因事者举方便智。谓菩萨无尽财果无碍身报。由不滞寂福行所成故。说方便为彼胜因。随所须者是财也。随意取者是身也。谓随意受生故财身重牒因集功德故也。三常乐思惟下明护善因事者。以方便智摄护善根。令得生长故以为因。下明发起胜行。言得彼胜因增上者牒前起后。言功德增上等者正现胜相故云广集等也。论主判意前以三句属自利行。后七合为利他行。同名摄众生因事。俱以方便智为摄生因。七中初一随物受生。次二化令离障。下四摄令住善。初中愿力受生作彼上首。何故唯作上首以得众生随逐受化。故云远离三界等。二毕竟下令离烦恼障说对治故者。虽照性灭而不碍说治。能灭大小二惑故名烦恼随烦恼等。常自灭者明不碍性灭也。三随顺诸法下令离智障故云为灭四障。如五地中随世智处说书论等四障应知。四一切佛国下明为物严土集起法会。余经云虽知诸佛国及与众生空而常修净土教化诸群生。此之谓也。五知一切佛法身下明为物现于正报三业。先辨身业。既法身离相。何故现色。为与众生作五缘生福。一见。二闻。三亲近。四供养。五受法修行故也。六知诸佛音声下明语业。为生转法轮故。七知诸佛下明意业穷照为诸众生随问能释故也。三是名下总结胜能。上来释妙。下释方便智。论云此十发起胜行共对者。明共方便智对。谓于空不著名方便智则空之有名胜妙行。今明释方便智也。摄取对治者明不碍空而起有行。故此有行方能对治乐空之心。还为方便智所摄。故云摄取也。下略举初二句经。对以显之。余类可知

第二是菩萨住七地下明彼障对治有二种相。一修行无量者。前乐对治。有量为障故。修无量以为对治。二修无功用行者。前乐对治作意修习功用为障故。修无功用而以为治。先明修无量中二十句。摄为十对一一对中皆先明境界无量。后明佛德业无量。或要摄为五。初一众生界无量。二世界无量。三有两对明法界无量。四有三对明调伏界无量。五后三对明调伏方便界无量。亦同上文五海可知。论判此十。总为摄生故云随所作利益。以调伏界中分二问故。摄十为六门也。初二可知。三以何慧者。以法界中二句难可别问故。就能知智问之。四以何心者问调伏界欲乐心也。五以何行者问调伏中所起志行。六置何乘者问调伏方便无量。以此差别下总释。是中下别释。于无量众生释初句。无量化业释后句。以入所化无量故修于能化无量化业。以能化中佛化最极故偏举之。菩萨修入佛广化业名修无量行。二乘生住何处者。于无量世界中令依清净国土故云入无量世界等。又以诸世界中佛土最净。菩萨修入。令物依之故名修无量行。下并准此。三以何等智中二句。一知善恶三性等法。谓无量种种法界释差别法也。智慧觉释佛智得道。二知三世差别之法。谓无量劫数释上句。通达三世释下句。亦入智觉会同前句合为一门。四以何心有三种事。一知欲。二知根。三知起行心。若约能化如次现身口意。初云有众生信种种天者释众生欲乐差别。言身心随同行者释入佛色身。若正应言身随彼心同彼行。说法令其信入佛法故云入无量众生欲乐等。二知过去心习软中利根者释上句。谓根器宿成名过去习。三品不同名耎中利。如应说法者释下句佛音声等。故云入无量诸佛知众生等。三以何行者此一文亦是入六中第五。亦是第四中后一摄。以此同是化众生事故二处辨也。言随众生心者释上句也。说对治者释下句。谓佛智为能治故也。故云入无量众生心心等。六置何乘者。于三乘中如次三句各显示一。皆上句所化。下句能化。并可知。二菩萨作是念下明修行无功用行。于中二。先明观解方便。二如是智慧下正显修行。前中亦二。先举修行无量中。诸佛如来无量境。二如是势力下起趣求意。言不以分别者。论经自然不以分别等。论释自然者自性胜无分别故。谓八地已上无功用心名自然等。以纯熟任性能起善行故名自性。依彼能起佛境势力。是故修习也。以分别心不能亡缘等照法界。所以不成。要以无分别不取相故。成无分别。即是无功用也。正修行中修大方便慧者。是前十种方便智也。何故前以为障。今复为治。释泛论障治有二。一是染障翻离名治。二是生障修熟名治。今约后说。但前者始修力励而起功用故障。今此数修纯熟故治。若尔与八地何别。释此中修学无功用不同八地也。安住等者明因修行立。以不动故者释成。以行坚不退故名不动。非是八地不为功用动耳

第三常起种种下明双行分。于中有四。一二行双无间者。内证行熟止观俱现名二行双。外修常续名为无间。上是自分。下三是胜进。二始起信心。于上决定名信胜。三依信起行。行有义利。义胜名大。起修称作故名能作大义。四行熟成德名菩提分。就初门内三。先常起乃至无碍者。总明二行双现无碍故。论云一念中奢磨他毗婆舍那二行现前故。言行住等者正显二行无间常起。论云一切行中。彼修行时无间不断不息行故。不断者非令停绝。不息者非暂休废。故云无间也。三离诸阴等者结离恶住善也。二常不远离下明信胜。彼无量智中殊异义。庄严相现前。专念故。谓于佛境依正专念信向故云常不远离等也。三是菩萨下明能作大义。于中二。先总标。二何以下别释。别释中先释能具之智。后释所具十度。前中二。先征责云十度行广何故念念能得具足。释以大悲者广心也。修习等大心也。以广大心念念现前是故能具。二十波罗蜜者下别释所具十行。谓一念之中舍己善根与诸众生名为檀度。即此念中能息烦恼。名之为戒。慈悲相应不损名忍。进求无厌心无异念忍法。无生巧起此行。大愿转增。异论不坏。妙达所宜。是故一念起一施时即具此十。余念念中相续不绝。虽前诸地皆欲修此。到七地中方得成就。论释后四。释方便中。起无量智事者释方便体相。以是下释方便功能。谓以方便能起施等无量行时。能以愿力具足摄故。二起上上智者释愿体相。以是下释愿功能。谓以愿功能起上上智。以此智能起彼施等令上上行生。皆摄取殊胜故也。三魔等不坏显力体相。以是能离施等障者是力功能也。四如实知法者显智体相。以是下明智功能。谓由智力显施等差别。以化众生故也。四如是念念下明菩提分差别有四种。一依大乘行者谓十度自利故也。二依化众生者谓四摄摄生故。上二摄善行。下二离过行。三依烦恼障增上净故家。菩提分解脱门者。何处住者对家问也。以何等门问解脱门。何等修行得净问菩提分也。经中略无四家句。一般若能照二谛是所照。三惑灭。四苦尽四一切助下依智障净。以离无明。令觉分圆满

第四解脱月下明前上地胜差别。于中有二初明胜前六地。后明胜后三地。就前中二。先问后答。答中先总后别。总中先标。次何以故下释。谓既诸地齐具。何故第七独名为胜。下释中以此地中功用行满故云功行具足也。能入第八无功用道也。通谓五通。明后地业用。智是八地证智。如前修无功用行处说。道是彼因即此地也。下别释胜相中。论主先总问起。云何此地中方便行满足者。方便行是功用行。彼余下总举以释。谓世出世举前六地。更起殊胜行。举此第七。是故下结胜过劣。初地愿力缘遍满真如名为大法。二地戒除心恶。三地求于佛慧。以益众生名转增长得。四地智光名得法明。四地入出世道。五地还能随世。六地入深缘起。上六各是一行中具一切。今此地中一切中具一切。故过前也。论中下地增上等是结前也。云何下生后也。修行下略显也。智方便是前方便慧。菩提分是前所起菩提分行。于此地功用行满总结满也。二何以故下正显胜后地。于中二。先明此胜过。二解脱月下因辨诸地染净之义。前中先责。意既云此地菩提分胜故得名胜。此胜于后有何业用。下释中先法次喻后合。初中慧所行道是双行之道。以是力下正显胜相。谓以此势力令八地上任运之行自然成就更无加行。二世界者无功用位如净世界。有功用位如染世界。隔位难超故以为喻。又释前六地喻之以染。后之三地喻之以净。唯第七地名染净位。以能越染到此净处。既染由此越。净由此到。是故此地极为要胜。合中言行杂道者是染净道也。论经名染净世界据此义也。二解脱月下因辨诸地染净之相。于中先问后答。答中二。先通明诸地染净之相。后佛子下别约七地以明染净。前中有法喻合。法中先总标。次征责云前言是染。今复云净。此有何义。下释以回向菩提名离罪染。论经中有二句释。一向菩提是大心故名离染业。二随道行如是深心故名离烦恼。喻中二。先举轮王喻。前七地未名纯净。后举梵王喻。后三地乃名为净。合轮王中五句。一菩萨如是以合轮王。二从初地来乘等合乘宝象。三知心烦恼合知贫苦。四不为所污合王虽无苦。五不名为过合未离人。合梵王喻准释可知。二诸佛子下别明此地染净相。中亦二。初明此地离障胜前故云过贪欲等。二明此地形前望后得名不定。以不能常在纯无流观。是故将出观求佛。以为烦恼也。第五从菩萨住七地下明双果分。理实此果通前诸分。以彼双行是正地相故名彼果。论分为四一业清净者是前彼障对治家果。二得胜三昧者是双行家果。三过地者是前上地胜果。四得胜行者是前乐无作行对治果。以彼方便及起胜行满足在此故也。就初业清净中有四。一戒净有二。一就具明戒故云成深净身等。二约行明戒。谓断恶修善故云所有不善等。二又世间下明世间智清净胜。三于三千下明得自身胜心行。二平等无与等者谓深心及妙行为二也。四是菩萨所有下明得胜力。言禅等现前胜者略释。谓等取神通等也。禅是四禅。定是灭定故。云寂灭乐行故灭定。三摩拔提此云等引。谓平等引生诸功德故。余文可知。二能入下明三昧胜有二。初别列十门。二总结多类。前中初五起解分别。后五成行分别。前中一依未观之义。伏心令观。二依已观之义。重更审思。上二知理法。三由义持力。依一句。解无量义进益心慧。四由文持力。依一义。说无量名故能分别义也。上二知教法。五依通一切五明处智。此知事法故云如实分别。后五中初一烦恼障净显其行深。后四智障净显其行广。初中以真如观坚固不坏故治惑障。后四治智障中一胜功德障者。谓不能发起智通胜德故以为障。对治可知。二不能具起无碍法界自在业行故以为障。依定起此故以为治。三于深上佛法怯弱障者。谓如来所说深玄之法。情碍不入故以为障。对治可知。四不住行障者。不能寂用无碍俱行故以为障。经对治中。背二种生死向无住涅槃故名也。三是菩萨下明过地。于中有三。初行修善巧过。二作业广大过。三行修胜入过。就初中四句。一巧智。二深悲。三过声闻等。对下彰出。四趣佛智地对上彰入。谓此能入八地已上法流水中。止观俱现。任运流注入佛果海故名也。二是菩萨住是下明作业广大过。于中二。先正现过相。二彰其分齐。前中亦二。先对下彰出。过二乘故。论云无量三业。无相行者入定远离相无量。声闻缘觉亦有净业远离。相非无量。不能利益一切众生故。此释过二乘。复次此无量胜余下地者。此显过前六地等也。二是菩萨清净行下对上明入。谓得八地无生忍光相故能照明也。二彰过分齐中。先问后答。解脱月执前同后难。刚藏简后异前答。答中法喻合。法中缘大法者观察攀缘佛果大法也。以四五六地寄二乘位。此地出彼故说为过。理实已前非不过也。论云方便行尽念观住故者。方便慧及殊胜行满足名尽。于上境界念观相应故名为住。三佛子下明行修胜入过。于中甚深者。远入故者。能上入也。远离者。彼障灭者。离前障也。释无行可知。言身口等者。论云声闻辟支佛虽离彼相业不如是。得少为足不求上行故。谓二乘虽亦离相业用不如菩萨。以少为足不上求故。余文可知。四解脱月下明得胜行。于中二。先明三摩拔提胜行。谓在空不住故。二发起胜行。谓起殊胜行故。前中先问后答。答中从六地等明得法分齐。今此地等辨胜过劣。于中有法喻合。法中先总明得而不证。后是菩萨成就下别显。以不舍众生即寂起用故云成就不思身等。喻合可知。二菩萨如是以大愿力下明发起胜行。经中十句。论摄为八。以后三句合为一故有八种行。共对治摄者。谓此八行皆共所治俱而不污。又障共能治治行常立。如是深乐涅槃现身生死。以能所治俱名共对治。二门互收故复云摄也。初中愿力智力是能发起。从禅等明所起行缘。虽深爱等正明所发行相。一起功德行随顺世间门。谓现世间增修德行。二既现世间以何等身。谓上首之身方能摄故。三既在世间岂不被染。以愿力取有故无所染。四既在世不染。为不同世行故不被染耶。释云不尔。示有妻子。名家不断。在此炽然而不为烧。五非直如上同凡摄化。亦乃能转二乘上入佛智故名入行也。六示资生行。谓饮食资身。睡能资神。皆顺生死。是魔境界。七示有衰退老病死。三是魔所行。上二转魔行。八转行者转诸凡夫烦恼之行。所转烦恼不出三种。谓见爱无明故有三句。初化转诸见。谓外道着见名为见贪。化离名转。二化转无明。谓智不能达世及出世。名为障碍。化离名转。三化转贪结。菩萨现受胜妙乐具。过天龙等处而不着。令彼见已生尊心。各令舍已所贪五欲故名摄取转彼贪心。又释此三亦是菩萨自行常正。谓明菩萨处邪恒正。居碍。不碍。在贪不贪。俱皆名转。下明位果中三果科释皆同前说。能练行中言护持佛法者。论云于三千界得为大师故能护法。次二句释师义。方便行满者功用行。修自行胜故。守护上首利他行胜故堪为师。所练净中言愍众生故法忍转净者。利益众生法忍转显。此地释名应知者。谓利生是有中殊胜行。法忍是空中方便智。此二双行名善修无相行也。言善根转胜者。修行功用尽至故名远行。言尽至者是功用究竟义也。喻中众宝严金者。示现一切菩提分法方便行功用满足故也。释教智净中日光如前地说者。前地取月光胜月轮。今取日光。不取轮义同前地月故指彼也。此地胜者日胜月故。余文准释可知

第三重颂中四十四颂分七。初九颂前十妙行乐无作行对治分。二有三颂彼障对治分中无量行。略不颂无功用行。三有六颂双行无间分。四有十一颂前上地胜分。五有八颂双行果分。六有四颂位中三果。七末后一颂叹胜结说

华严经探玄记卷第十三华严经探玄记卷第十四(尽第十地)

        魏国西寺沙门法藏述

第八地七门同前

初释名者。不动名亦有三义。一约一义。摄论云。由一切相有功用行不能动故名不动地。无性世亲并同此释。无性释意。第七地中行动相不动。此中行相俱不动。二约二义。金光明云。无相正思惟修得自在。诸烦恼行不能令动故名不动。三约三义。成唯识云。无分别智任运相续。相用烦恼不能动故。梁论三义亦同此说。解深密经由于无相得无功用。于诸行中不为现前烦恼所动故名不动。十住论云。若天魔梵沙门婆罗门无能动其愿故名不动地。仁王经名等观地

二来意者亦有三义。一前之三地寄同世间。后之四地寄三乘法。第八以去寄显一乘。庄严论释第七地云近一乘故。梁论亦说八地以上以为一乘。解云从前三乘差别之位进入一乘。是故来也。二前位虽得纯无相观。要待加行作意方证。今此纯熟不待加行。任运现前故次明也。三前通分段。此唯变易。是故来也

三所离障者依地论离无相有行障。唯识云无相中作加行障。谓所知障中俱生一分令无相观不任运起。前之五地有相观多。无相观少。于第六地有相观少。无相观多。第七地中纯无相观虽恒相续而有加行。由无相中有加行故未能任运现相及土。如是加行障八地中无功用道故。若得入第八地时便能永断。彼永断故得二自在。由斯八地说断二愚及彼粗重。一于无相作功用愚。二于相自在愚。今于相中不自在故。此亦摄土相一分故。八地以上纯无漏道任运起故。三界烦恼永不现前行第七识中细所知障犹可现起。生空智果不违彼故。解云依护法宗于无相中有加行智。体非是障。以善性故。由所断障令作加行故说名加行障。由此第七有加行故。虽现金等诸相及土。非任运现故以为障。生空智果者。谓生空智所引后得智及灭定。金光明云。一无相法多有功力无明。二执相自在难可得度无明。解云此所迷现相亦摄于土以宽收狭故。梁论等并可准知

四所证法界者谓证法界不增减义。世亲释云。谓于此中杂染减时而无有减。清净增时而无有增。无性释云。法外无用。所以不增。诸法不坏。所以不减。无性后释同世亲。中边云由通达此圆满证得无生法忍。于诸清净杂染法中不见一法有增有减。解云此同地论。唯识云谓此真如离增减执。不随染净有增减故。即此亦名相土自在所依真如。谓若证得此真如已。现相现土俱得自在。世亲释云。于诸相中而得自在名相自在。随所欲相即现前故。于所现土而得自在名土自在。如欲令土成金等宝随意成故。解云相约现身等相。土唯器世界等。此地下文具三世间十自在等

五所成行者亦三种。十中大愿行。当地成就无生法忍行。相土自在行。庄严论第八住虽净佛土而无起作。无功用故。寻下文

六所得果者。梁论通达无增减法界定自在等得法身果。金光明八地发心得现证三昧。当地行果位果可知

第七释文中亦三。初赞请分中十五颂分三。初二颂天王大众庆法兴供。二有十二颂天女歌乐赞德供养。于中初三作乐总叹佛德。次三别叹三种世间自在之德。次三别叹三轮摄化。次二叹佛神力摄持。后一叹已结默。三末后一颂上首请说

第二正说分中论分为七。初二是趣地方便。一总明方便作集地分者是远方便。总前七地作起此地集成方便。二得净忍分者是近方便。谓前地所得无生忍光。至此修熟令深清净。三得胜行分者是初住地行。谓依前净忍发起胜修。四净佛国土分者是正住之始。依前胜行更起净修佛土之行。五得自在分者正住地满。由净土行成德无碍。六大胜分者是地满行。此地望前通皆是胜。今复地满是胜中之胜故云大胜。七释名分者不动之名辨德彰号。此通始终释在地满

就初分中总摄前七以为二相。诸地通行名为同相。诸地异修名为别相。同中三句。妙行慧者是其证道。谓二无我上上证故。从初地来证二无我。转胜至此故云上上也。二方便道净者不住道清净。谓悲智俱游无偏住着。三善集助道法者彼方便智行所摄。满足助菩提分法。谓行是前证方便。智是前不住。彼二所摄助道之法。下明别相有七。一初地十大愿能令心住。二地中行十善等行。是佛为护也。三地中厌得不退。禅定等者等取神通无量等。名自善根力也。得通达故名得力也。四地中所说十种法智教化众生。者前论中名智障净胜也。念通达佛法者释此同彼。谓彼十法智此名佛法。五地中十种深净心平等名直深心。六地中前大悲为首。及大悲增上也。观因缘集者是大悲满足。亦是举成观法。成就福智释此同彼。七地中二句。初是前空中方便智。有中殊胜行。言不舍众生者释彼同此。谓大悲等也。二以无量众生界故入无量智道。是前十种无量也。何故前六各唯一句。此第七地有二句耶。释以是近方便故。又问何故于此第八地初总集前地。答诸圣教中此例有四。一十住之初总集十信。如本业经说。此约退与不退以分其际故作是结会。二初地加行总摄地前。如回向品说。此约比证分际。三第八地初总集前七。如此文说。此就功用无功用分际故也。四第十地初总集前九。如下文说。此约因位成满总摄前因。又释此四处初约十千劫满。二约初僧祇满。三约二僧祇满。四约三僧祇满故作是说

第二净忍分中文有三。初十句正明无生忍。次四句明无生忍净。后一句结忍入位。论中但释前二。摄为四种。一破相二。破性。三因泯。四果离。又前二破相入如。后二证实舍相。又约寄位。初一在加行。次一在正体。后一在后得。其数差别一种通始终。依佛性论。三性品云。如经说。若人已得无生法忍即不退堕。此云何成立。由三性故即得成立。如来为约分别性故说本来无生忍。约依他性故说自性无生忍。约真实性故说垢苦本性无生忍。就初事无生中论摄为七。初四明不增。后三明不减。即是无增减法界。论中先立七实对治此实以显无生。一净分法中本有实者。计自性住性为事物有为对治此。故云入诸法本来无生。二新新生实者。计习所成性为实。对治此故无起。三相实者。计前二性所生行相。对治此故无相。四后际实者。计于佛果后际出缠。对治此故无成。又此四中初一自性住佛性。次二引出佛性。后一至得果佛性。又初一道前凡位。次一在三贤之位。次一在地上。后一在道后。通即可知。又此四展转释疑可知。五先际实者对佛果后际说。凡染为先。对治此故云无坏。明烦恼即空无可坏也。良以众生心中有其二分。一如来藏名为净分。故如前说净分无生。二烦恼藏名为染分。如此所说染分无生。六杂染实净分中者。谓修行位中背染向净来。对治此故无来。七尽实诸众生者众生向涅槃去对治此故云无去。论经名无尽。第二自性无生。此经略无。论云自性无生者是法无我。彼法无我自体无性故。如经非有有性故。彼观事故等者明理不无。谓彼前诸地所观事故。亦是此地所忍法故不得言无。下明理不二。谓理非事外故名不二。同于上文有不二不尽也。三无初无中下明数差别无生者。于三时中染净法不增减故。谓先际为染。后际为净。中际染净三际无生故无增减。四入如来下明作业无生者。于真如中净无分别佛智故。如是下释已总结也。次示现下释无生忍净。言一切心意识等者一切有二。初一离报心忆想分别故云行远离等。二离方便心忆想分别故云摄受分别性想故也。想者远离障法想。非无治法想者简言滥也。彼治想于下地中有三种胜事。一无功用自然行故云无所贪着。谓于上佛果不待起贪求任运起行。二遍一切法相者现能治广。故云一切法如空。三入真如不动自然行故者显治深也。如空之言通二句用可知

第三入不动下明得胜行分。于中有二。初明深行胜。谓对前彰出。二发起胜对后显入。前中二。先总明深行。谓入此位行玄奥故。下别有七。相从为三。初三一分明此地中境分殊绝。次二一分明此地中正行广大。后二一分明此地中离障寂灭。喻中有三。从后向前喻。此三分七中。一难入深。故名深行菩萨。二同行深。诸净地菩萨同故。谓纯无漏位名为净地。与此位人同故云世不能测。不能测者如麦在麦聚不测其差别故。论经名无能分别。三境界深。能取所取不现前故云离一切相等。言护一切障想者谓防护一切障法之想。为简治法想故名离贪着。四修行深。自利利他行广大故。此经略无。五不退深。谓彼二乘不能形夺坏其胜故云一切声闻等。六离障深。谓离功用障故云深大远离。七对治现前深。谓能治之行常现在故云而现前。论经名为寂静现前。即真如寂静非事静也。下释三喻喻前所说。灭尽喻者示彼行寂灭故者释现喻意。释喻中言无彼依止故者。明灭尽定中心王不行想等心数无所依故亦不行也。以得无功用自然行者释勤方便。三业行息灭也。论经报行成有二释。一约教道故云得彼相违法。二约证道故云善住阿梨耶识真如法中者。但本识有二分。凡时唯住妄染分今此住真净分。若至佛地单住真如不云梨耶真如。今此为有变易报苦。是故双举也言住大远离者。是论中住报行成也。释第二梦寤喻中。示此行中护彼过想有正智想者。如从梦寤虽无梦想而有寤想。所况如是。虽舍前地妄修过想非无此地正智之想。言此行寂灭者显此正智即用常寂故不同前显此深行故也。是中下重分别。依清净。世间涅槃二心不行者此释经中不行二心。谓梦中渡河。此岸喻世间。彼岸喻涅槃。既觉寤已此彼俱亡名依清净。故云不行二心也。言依境界受用念想不行者释诸所忆想不复现前。谓于梦中受用船筏等境想不复现也。释第三生梵天喻中。如生色界下结不行。此地如是下地心一向不行。望下彰出。得报地者对此彰得。此说离胜结明喻意。下重分中顺行是世间心。不顺行是出世间心。故名二分也。心等者举心等取意之与识及忆想等。即是顺行也。佛等者举佛等取菩提涅槃等。即是不顺行也。下就不顺行分中更开三门。经中但就大乘。论主对辨大小。一言差别者非是大小不同名为差别。但是大小乘中生法两异名差别。二言大小乘中众生法差别者非生法异名为差别。明此大小乘中生生自异法法自别。三言无学学差别者就小乘中辨人差别。非是学与无学不同名为差别。但明学学不同无学亦尔。上开门竟。佛等涅槃差别。说者举经对显。谓佛是第一句佛心等取中间二句。涅槃是第四句应知也。何故世间行中而不开异。出世行中开此差别。以出世是大人所求恐有染取故。委释令离。下释显中先释顺行可知。后释不顺行中。言大小差别是总举。下别中大乘内佛菩萨是人。涅槃是法。小乘中涅槃是法。罗汉等是人。二释人法各差别。论释可知。小乘罗汉差别者。如毗昙中六种不同。谓退思护住胜进不动。成实有九。并广如彼说。余文可知。二佛子下明发起胜行。于中二。初明本愿力住诸佛劝发。二若不与下明劝利益。前中亦二。初本愿住。二又诸佛下明劝发。前中随顺是地者是论经中住义。以本愿者释住所由。谓从前地来同求此地无生忍门。名为本愿。得已以息故名为住。然住义释有二门。一显义。二说意。初中明诸菩萨住与不住。泛释有四。一观入分别。谓始时不住。终即乐住。从前地来求趣无生。以未得故。是以不住。今此得之乐寂故住。二起行分别。始时乐住。终即不住。今此地中始得无生乐寂故住。后以佛劝发起胜行所以不住。三就寂分别。始终常住。谓佛菩萨随所证入无暂时舍。四起用分别。诸佛菩萨一切不住。常随世间利益众生。今此文中约前二说。二明说住意亦有四义。一为渐悟菩萨有乐寂习故云本愿力住。二为引定性二乘。明菩萨此地大寂灭处犹有动起。况彼所得岂为究竟。三为显此地甚深玄奥难舍故住。四但有此深奥法流之处。必有诸佛作七劝桥。是故无有一人坠堕。下明劝发中三。先总劝。二诸佛下别劝。三是菩萨下结劝。初中流水者。在无生忍。不起功用。任运起行。趣于佛果。如大河水不待人力流赴大海。何不前地与智。以得法未深故。何不后地与。以依此劝发修不住故。何故与智。理实通余行。以智是行主故。何故在此位与。以此忍门摄德本故。下文云亦莫舍此忍门。依此力能成大行故。何故与如来智。以约果说故。作因缘者。论云此与如来智慧力转彼深行乐足心故。下别劝中。先叹其所得。第一是上法也。后我有下彰其未得。劝云修习。于中七劝摄以为二。前六举多未作转其住心。后一明其少作能成增其去心。凡劝法如是。前六中摄为三对。自利利他初对中。一明自德未成。后一所化未出。第二对中。一化愿未满。后一自德未胜。第三对中。一明化业未广。后一明自得法未穷。初中句别有三。初举力等彰其未得。二为得下正劝修习。论云不得修教授故。解云不得释上句。修教释此句。三亦莫舍等明起行所依。论云若不舍此等明反释可知。依彼有力能作者顺释。第二劝中。汝虽得此等明自所得。一切凡夫下明他未出。于中亦三。初就凡夫总劝。名依彼众生无利益事。二显其过失。现起烦恼者不善也。使者释离寂灭。在家烦恼。出家觉观。三汝当下劝其愍念可知。第三劝中。汝应念本愿者总劝。忆念本所弘愿下别二句。一欲利益众生者是广心愿下化众生。二欲得不思智者是大心愿上求佛智。论中依愿化众生释上句。智行广释后句。能转者。依前二义劝转名依名转故。第四劝中三句。初一切法性等举所得。法性自尔不令生着。二一切如来下明上未同佛。谓佛具大用非但一寂。三声闻等明下齐二乘。谓定性二乘亦住寂舍化。此是抑挫之辞。论中不共义者释第二句。功行疲倦者释第三句。有此二过名为彼垢。依此劝转名依名转。第五劝中二。初汝观我等者举佛六种化业。二汝今下结劝起修。论中先释化业。言无量身等者牒举经文。彼佛法成就有力者。彼身等佛法修成之时明此有能化众生力。言示现依利益众生者。辨定其行。谓此六皆依利他而说。次此利益众生事下广释。六种皆为化众生。于中摄伏者。善者以光摄之。恶者以轮伏之。谓三轮也。二如来作无量下释结劝起修之文。第六劝中亦二。初汝今适得等明所得未广。二我等下举所未得劝之令起。论中一入是所入法门。二作是法门业用。三转是业用不断。余文可见。第七劝中明少作在增其去心。于中先举三种无量。汝应下劝尽通达。论中少作者望佛果不遥故云少在。随所见等释三无量也。少观即成释如实通达。以此增其去心故云转也。二是菩萨下结劝可知。第二诸佛子下明因劝成益。于中二。先对上本愿住彰不劝之损。论释即入涅槃者与智慧示现者此释经意。谓举此灭为显佛与智故。二以诸佛下对上佛劝彰劝之益。于中有法喻合。法中亦三。初明佛与智门者。论释彼行中摄功德因胜者。明与智所依。谓彼发起行之中。无生法忍摄功德因最为殊胜故。佛与智也。同作教授说者正解与智。诸佛共劝名同教授。二于一念下明由劝故起行速疾。论释可知。三所以者何下问答辨释。谓向前二大僧祇所修。比此一念所起之行不及者何。下释中先以一身等明前不及今。此无量辨此过前。问前初地百身。二地千等。何故言一。答实报唯一变化百等。故非异也。于中有十一句。初无量身者。论释一切菩萨身信解如自身故者。胜解力故以自身令同一切菩萨身故。是故一切所修是自修也。此是同体智力故也。此非文意。又释以胜解力令自身无量。如一切菩萨数量齐等。此岂非是变化身耶。释以此菩萨既不出观。即称法界而起身云实德非化。此是文意。音声起等类身应知。言此十句。一依教化众生者。是十句中初六利他。二依助道者。其次二句自利行。三依障净者明后二句德用净也。应知。十句有此三义。下别显之。随身任者是无量身。谓随所住法当现彼身。如观音住大悲身等。二随说者是无量声。谓随所说法音声亦无量。三随依智者无量智也。随所知故。四随所取生者。无量生处形类不同。即种类俱生。无行作意生身也。五随何国土者无量净国。六得教化众生者无量化众生。次释二句自行中。一供佛集德。二顺佛集智。下二句明德用净。一神通障净。二无量大会明正觉障净。以于大会知根说法等故言此一切处随顺无量身口意业等。此释结文。无间不断释不动义。二释喻中船喻行疾应知。因胜者显行疾所因。以无生忍是行胜因令行疾。三善集下释合文。善集等是前七地中所修诸行。助发于此故曰资粮。余文可知

第四净佛国土分中有三自在。一器世间自在行。二众生世间自在行。三智正觉世间自在行。初是化处。次是所化。后是能化。具后二净方名净土。于此三法起化无碍故名自在

就初器世间自在行中二。初总以标举。谓先牒前。后思惟佛智力者正辨其相。谓能了知诸世界相故名智力。下别显之。文别有五。一随心所欲者。于此世界随于已心欲知即知。又亦随他众生之心欲知即知。此是智自在。彼能现不现者是通自在。能现是成。不现是坏。又释能现成坏。不现反之。二知以何业下明随何欲彼能现。谓随何业成。何业坏。欲知即知。能现同前。业集故。成业尽故。坏智能知彼故云业集尽智。三随几时欲者略无此句。四是菩萨知地下随广狭欲。彼能现者于中二。先明四大差别。非定地等者明欲界所知。狭故名小。二定地等上界所知广故名大。三佛知无限故云无量。上三俱约所知分齐同名境界。知此之智故名境智。次显相智。四大体伏名为自相。于上有空无我等。名为同相。此二不同名为差别。下知微尘粗细等。准前可知。二于一世界下明知微尘聚散多少。于中初总知。二此一世界下别。别中四句。一知外四大尘多少。二知众生身尘多少。三知前世界物尘多少。四知前众生三界六道差别身尘多少。此中大身小身者。论经名粗身细身。此是三界差别。论云身粗细者色粗。无色细。色中欲界粗。色界细。故云如是次第。以此当知。大乘宗无色界中亦有微尘。即定自在所生色。次知六道身微尘成者。以觉慧分折。显此微尘非实有性。五是菩萨入如是下明随几许欲。于中三。初知三界成坏。二知大小等相。三知众生随之现化。论释后二。论云欲界等境界智相智者亦开二门。举欲等取色无色界。于此三界知事分齐。名境界智知法分齐。名为相智。下广释境智。欲界中人小。天大。色界中有觉观。是初禅无觉。是二禅已上无色界中。为简却彼外道妄取以为涅槃故说佛法。凡夫菩萨声闻是圣智。此上各为所知广狭以分大小。上来但释大小未释无量相。今此同释一切三界。如来所知皆宽广无边故云无量相也。三是名菩萨下明知众生随之现化。于中三。初知众生。二随知现化。三起化自在。论云初中先牒文。善知身不同总释所知众生。方便等者释现化巧同彼生也。异生同生差别应知者。是所现同类身也。诸佛国下彼处处去身体示现者释起化自在。身遍三千界等也。法喻合可知。二随众生身下明众生世间自在行。于中三。先总明自在。二若于沙门下别显自在。三不可说下总结自在。论释中彼调伏众生自在是总释其相。以此菩萨调伏众生中得自在故。能种种现。言彼行化众生者。此释经中随众生信于大会现。皆往示现名行化生。言身心自同事者释别显文内化同物身。谓菩萨自身随众生心。以自己身同形事故言身心自同事也。言身心等分示者此释中化应物心。菩萨自身随众生必量宜而现。名等分示。谓应以声闻身等。余文可知。三而实远离下明智正觉世间自在行。于中有二谛智。先明第一义智。以是本故。言远离身相差别者谓释离一切身相分别也。言常住平等者自身他身不分别。谓己身为自十身为他。同一理性故不分别。何故说此。谓欲显诸身相作所由故也。二是菩萨下明世谛智。中有三。初列所知十身。二明诸身相作。三释十身义。初中十身内。初三是染分。次六是净分。后一是不二分。各言分者。此是同一大缘起法义分出故。如摄论中于依他起上离染分名遍计。清净分名圆成。不二分为依他。是故若见一分余分性不异。皆融通全摄此中。不二分约相尽为言故以虚空身表也。论中重分别。内众生世间器世间举初二身。彼二生因业烦恼者。是第三业报身明前二种生起之时。因烦恼业故名为报。言是染分者结上三也。次明净分。言三乘净者声闻辟支菩萨如来四身是也。此三乘随何智者举智身。随何法者举法身。是彼能知及所知法。彼净显示者结上六种是净分也。虚空非是前二相知名不二分。二是菩萨下明诸身相作中。通自身有十。一身亦十。一度相作成一百一十身。皆无碍自在显现。文中且辨三重。一以众生身为首作己身等十。二以国土身为首作。三如是乃至第十以己身为首作彼十身应知。释何诸身得如是相作。释有多因。略论三种。一约法性融通门。是故此文先说自他身平等不分别等。二约缘起相由门。如下颂说。菩萨于因缘和合中自在。乃至能随意示现于佛身故也。三约菩萨自在智力。以此位中远前二门无碍道理。是故能作。论释以众生身作自身者。彼自在中所作摄取行。种种示现者。谓智正觉自在中作摄他行。诸身相作名种种示现。皆随物心所现也。三是菩萨下广显十身。初释众生身中五句一业。二生是报。三烦恼妄想染差别。四色。五无色界差别。后二就报开也。二释国土身有十相。论中千等者释初三相。谓一千小。二千中。三千无量。举千等取后二也。故云应知。净不净差别者释垢相净相也。广等释余相指同初地。次四身假名差别者。论释自相同相差别假名分别无我人故。谓诸身各异名为自相。假名义齐称曰同相。若就人说假佛身之处何不说耶。以佛胜德超余人故。七释如来身中自有十身。一菩提身者示成正觉故。二愿身者愿生兜率故。三化身者所有佛应化故。四住持身者自身舍利住持故。五相好严身者所有实报身故。以福业所生。六势力身者所有光明摄伏众生故。七如意身者所有同不同世间出世间心得自在解脱故者。随意现生示同世间名同。实即出世故名不同。下释所以。以于出世间自在解脱故能现同。以于世间自在解脱能示不同。八福德身者所有不共能作广大利益因故。明福超凡小名为不共因。此大福广现无量身财等相。广摄众生。九智身者所有无障碍智故。是故此智能作一切事。彼事差别皆悉能知。谓能作一切。释无障碍义。彼事下结能知。十法身者所有如来无流界故。谓诸佛断德名无流界。即十佛中名涅槃佛。又是如来内证法身名无流界。八释知智身者。论经中有八释。初二句三慧分别。一思量者闻思慧。二善如实观相者是修慧。三果行所摄者。因果分别所得名果。彼因名行。四世出世者就位分别。道前名世。见道已去名为出世。五三乘者大小分别。六共不共者粗细分别。粗即同修。细唯在大。七乘不乘者种姓分别。已习三乘种姓名乘。未习非乘。八学无学者修成分别。习求名学。果极无学。第九释法身者论经五句。一平等相者无量法门明等一法身故。谓佛无量法明同一法身故云平等。此是理法。二不坏相者如闻取故。此是教法中实教。称理而说故云如闻也。三转时假名差别者。随所化众生根性相应时说差别故。谓随所化根性熟时称根差别说。是权教法。四众生非众生者众生有六根等依报。非情名曰非根。此是染法。五知三宝者知第一相。谓三宝殊胜故也。第十释虚空身中六句。一无量者广穷无尽。二周遍者一切色象。三无形者不可见故。四不异者无障碍相不同色法限碍故也。五无边者无为相以无始起终尽之边故。六显色身别异者能通容受色相。因色彼分别皆悉能知色。因解别异也

第五是菩萨善知起如是下明自在分。此十自在略作四门。一辨相。二治障。三出因。四得位。初辨相如论经具显。二治障对治十障。如地论具显。论既与此共故不待录。三出因者。依摄论第十殊胜中以六度为因。初三施为因。以一切时施得命自在。一切处施得心自在。一切物施得财自在。次二以戒为因。由戒调身语以成胜业。复由戒净随欲受生。忍为信解自在因。以修忍时随众生意故得一切皆随心转。谓变地为金等皆随胜解而转也。精进为愿因。以策勤所作无懈废故。令随所愿如意成就。禅为如意因。彼名神力自在。以依定发通如意成故。般若为后二因。谓内照所知名智自在。应根宣说名法自在。四明得位者。摄论约果明佛地所得。谓彼法身五相中白法所成内摄。今此就因。八地所得此约始终教说。下离世间品十自在约普贤位贯通诸位。又上贤首品云十地十种自在力等约别教一乘说

第六是菩萨得十自在下大胜分有三。初智大。二业大。三彼二所住功德大。就初智大中。不思智者不住世间涅槃。明寂用难测。此是总句。下别显三种。一无量智者修行尽至证理深也。二广智者所知不思。照境广也。三不坏智者除障不思。破相极也。二菩萨随如是下明业大之中。初牒前。论云如是至已如前说者指前所说得自在已也。如是智成亦如前说者指前所说不思智也。二毕竟下十二句正显业大。于中初三句明三业净。是业大体。下九句约修辨业摄为四。一起能起起同时。谓前三业是起智慧。起彼是名能起。彼业起竟共慧相随名曰同时。故名身业随智行等。二智摄不染作利众生行等者。明智悲一对故云般若增上大悲首等。三因摄自行他行因等者。此能感所感为一对。谓自起大愿名为自行。此之自行与他佛行能加为因故名他行因等。故云善起愿善为佛护。四作业所持者。谓三业行成不坏名持。于中三句。初二利他成就。一说法益生故云常不舍利益生。二净土神通化故云悉知无边等。下一自行。谓成就一切佛法故云举要言等。三是菩萨住此地下明彼二住功德大。于中初十句正释。后三句结成。前中论摄为七。初四为一。是住德体故名善住道功德。后六各一是约修辨德。前中四句。初二自行。一净心离障。二深心摄善不离道故名对治坚。后二利他悲慈不舍救也。下约修辨德。二不忘德是意业总持德。三成就口业辨说德。四定心自在是身业德。依定发通故。五依愿力起行。六修行成就者明行力集法。七与智者行成。证入佛境界名佛与智也。三是菩萨如是下结。智力者牒前智大。得无憎爱不分别众生有恼无恼也。示一切所作者牒前作业大。谓平等作业故无过咎者。是彼二住功德大以得前七种功德故。诸行事中无过失故

第七诸佛子菩萨此地下明释名分有二。初地释名者约法显位。二智者释名约人辨德。前中十句论摄为六。谓第三第八各为一。自余八句两为一故有六也。初二染对治。一治下地功用行小乘愿诸魔业故名不动。二治烦恼习行故名不转。以智能治也。二能得难得甚深无生故名一切世不测等。三次二句名发行净。一发净。谓发修之时离功用过。如王子不忧居家农务之过。菩萨亦尔。生在此家无功用之失故云无家过。此中如童子无欲。譬纯无流无惑染之过。二行净。谓正行之时离不成过住生地。所欲事自在成就故名自在地。四次二句为一。世间出世间有作净胜。谓教道修起名有作。有作名成。福德名世。慧名出世。出世之慧决定知故名究竟。五无作净胜。谓证道真理非修所作。梵语涅槃与变化相近。故致二译不同。由愿起用不带寂故名变化也。六次二句名菩萨地胜。谓位分过前也。一住持者论名加地。即加持也。此胜六地者发起殊胜行。谓显此过前也。他事念动彰前劣。此即六地观空以有为他动其空观。今则不尔故胜也。二先修善名无功用地者明胜七地。有功用明前劣此。此地善起等彰此胜彼。余文可见。二菩萨得如是下明智者释名。谓以何义故。为得不动菩萨有二义。一一向不动谓行修上顺故。二一体不动。谓与诸菩萨行同体故。前中先四句明一向义。初言入佛境者论经名入佛性。谓入佛果法身理性。亦是佛智所证之境故云果满足胜。谓释性也。满胜释佛。以是果圆故。随顺因者标后三句。随顺佛因也。二名佛德照明者是摄功德。善清净义故。明观解摄德。三随佛威仪者名为正行故。依解起修。四趣向佛法者论经名佛境现前者近佛境界故。依行近果也。次十句释不动。初一是总。常为佛力护者。上果下加故。余九是别论摄为五。谓前四各一后五为一。初中常为四天王等者是供养功德。明感天供养。二密迹等者护功德。已前密护今此已去现形守护。三善能等者依止功德。以依定成德。四能作无量身者国土清净功德。谓前净土分中现身差别也。次五为一化众生功德。一于诸身等者愿取诸有生明身业化益。二得大果等者根心使智力明意业化也。能知众生根欲性等。三于无边三昧等者无量法力转法轮故明语业化。依定证法名法力。以此法力能转法轮名为语业。四堪受多佛记。五示现成佛说法度人。二是菩萨入如是智等下明一体不动。言入如是智者。论经名入大乘众数。谓同此位诸无功用菩萨大智故名不坏。此是总句。余九为别。一善通达法者。是智不坏。以内证法实故。二常放等者。说不坏。以依证起说故。三度无碍等者。解脱不坏。以无碍法界业用自在。四善知世界等者。佛国土清净不坏。以于诸佛土自在无碍故云善知也。五能示一切等者。入大乘不坏。意业入法能示现也。六随意自在者。神通不坏。是身业也。七善解先后等者。能解释义不坏。是语业也。八能入转魔道智者。坐道场不坏。谓降魔怨也。九入如来等者。正觉不坏。以能现佛说法也。下能于无边等总结。以行无障不断绝故。名为得不动地菩萨。佛子下明地果中。三果同前。调柔法说中。从佛受世界差别等者。等取众生世间智正觉也。以依此三能起无量净土作用名为法明故。说所受为彼因相。喻中依人显胜。谓得清净地。身心胜故即纯净无流也。善根光明更明净示现者。释教智净。余文可知

第三重颂中四十四分九。初三颂前方便作集地分。二有三颂净忍分。三有十五颂胜行分。于中初五颂胜行。后十颂发起。即七劝等。四有十二颂净佛国土分。于中初四颂器世间。次五众生世间。后三智正觉世间。五有一颂自在分。六有二颂大胜分。七有二颂释名分。八有五颂地果分。九末后一结说分齐。不动地竟

第九善慧地七门同前

初释名者。摄大乘云。由得最胜无碍智故。世亲释云。由无碍解智说名为慧。此慧妙善故名善慧。无性释云。谓得最胜四无碍解。无碍解智于诸智中最为殊胜。智即是慧故名善慧。四无碍者法义词辩。由法无碍自在了知一切名句。由义无碍自在通达一切义理。由词无碍自在分别一切言词。由辩无碍遍于十方随其所宜自在辩说。于此地中最初证得先未曾得无碍解智故名善慧。庄严论云。于九地中四无碍慧最为殊胜。于一刹那三千世界所有人天异类异音异义问此。菩萨能以一音普答众问遍断众疑。由此说言名为善慧。金光明云。说法自在无患累故。增长智慧自在无碍。解深密经于一切种说法自在。获得无罪广大智慧故名善慧。瑜伽住品云。由此地中一切有情利益安乐意乐清净逮得菩萨无碍解慧。由此善能宣说正法。是故此地名善慧地。十住论云。其慧转明调柔增上名善慧地。成唯识论成就微妙四无碍解。能遍十方善说法故。仁王经中名为慧光地。智度论中名善相地

二来意者亦三义。一前地虽得于无相中无功用行。而未能以无碍解随机说法。今此进修令证彼法。是故来。余二门可知

三所离障者。依地论离不能善利益众生障。唯识云利他中不欲行障。谓所知障中俱生一分。令于利乐有情事中不欲勤行乐修已利。彼障九地四无碍解。入九地时便能永断。由斯九地说断二愚及彼粗重。一于无量所说法无量名句字。后后慧辩。陀罗尼自在愚。于无量所说法陀罗尼自在者。谓义无碍解。即于所诠总持自在。于一义中现一切义故。于无量名句字陀罗尼自在者。谓法无碍解。即于能诠总持自在。于一名句字中现一切名句字故。于后后慧辩陀罗尼自在者。谓词无碍解于言音展转训释总持自在。于一音声中现一切音声故。二辩才自在愚。辩才自在者谓辩无碍解。善达机宜。巧为说故。愚能障此四种自在。皆是此中第九障摄。解云此用能障四无碍解所知障种以为体性。以八地上六识中所知障无现行故。金光明云。一说法无量。名味句无量。智慧分别无量。不能持无明。二四无碍辩未得自在无明。梁摄论云一无量正说法。无量名句味。难答巧言自在。陀罗尼无明。二于四无碍解决疑生解无明。解云后中言四无碍者即第四同深密等。余并可知

四所证者此地中证得智自在依止法界。唯识释云。谓若证得此真如已。于无碍解得自在故。无性释云。谓此地中得无碍辩所依止故。分证得智波罗蜜多。于一切法不随其言。善能了知诸意趣义。如实成就一切有情受胜法乐。解云无碍辩等释依止义。分证等释智义。不随言等释自在义。中边论云有四自在。一无分别自在即相自在也。二净土自在。三智自在。四业自在。法界为此四种所依。名四自在依止义。第八地唯能通达初二自在所依止义。后二如次在后二地

五所行者亦三。一于十度中当力度行。二善达法器自在说法行。庄严论云。四辩自在成就众生。三无边总持广受法行。并如下文应知

六所得果者。依梁论通达智自在。依止法界得应身果。金光明九地发心得智藏三昧。当地位果如下应知

第七释文者三分同前。初赞请分中有十九颂分四。初二说前地益。二有二颂明菩萨天王所设供养。三有十四颂天女赞请。于中初一颂半出音叹佛。次三颂半叹菩萨行供。次八颂半叹佛菩萨三轮摄化。初一身业德。次五语业德。谓无声现声说三乘一乘差别之法。良以此地是法师位说法相增故。次二意业德。对幻现可知。下一天女结默。四末后一上首请说

第二正说分中有四分。一法师方便成就者。此地能起辩才说法名法师地。趣地行立名方便成。二智成就者知法智成故。三入行成就者知所化器故。四说成就者称根正说故。第八净土。第九辩才。分其行别。成就一切相等。显胜过劣。谓具前四分名一切相

就初法师方便中。初牒前起后。谓无量智是前八地深广之智也。欲求下正显方便。依他利自利。一一五三句示现者。初一句利他。次一句自利故云一一也。次五句亦利他。后三句亦自利故云五三句示也。初言求转胜寂灭解脱者。依无色得解脱相。可化众生以作利益谓化彼令得真涅槃故。二欲转等者依未得究竟佛智自利益故。下五句亦明利他。三欲入等者。化根熟菩萨。令入深密。四欲观等者。化邪念修行可化众生。令得正念之行。五欲观诸陀罗尼等者。化未知法众生。转法轮令得知。谓总持定智皆是说法之所依故。六欲令等者。以大神通化邪归依众生令入正法。七欲分别等者。以通达世界差别行故示清净国土。转信生天众生令入佛法故。下三句明自利行。八欲修等者。欲得佛内证正觉大智等也。九欲顺等者。欲得佛外化摄生法轮大智。十欲不舍等者。欲得佛无住涅槃不舍悲愿。下结可知

第二菩萨住此地下明智成就。初总知三性净染不二。后就善别开以作三重。一就善中开流无流。谓见道前善名有流。见道已去善名无流。即就无流复开世出世间。谓缘修阿含名为世间。正证真行名出世间。二复就彼善开思不思。谓地前可思。地上不思。即就可思开定不定。谓声闻忍位已去。缘觉世第一法已去。菩萨十回向已去。俱名定。已下名不定。此约初教。若约终教。入十住已去名定。十信如轻毛故云不定。三彼复就善开出三乘。即就三乘开有为无为。谓能证修起名有为。所证真理名无为。以三乘皆依理成名依顺行。经云一切贤圣皆以无为法得名。是此义也

第三随顺如是下明入行成就。于中有三。初略标十一章门。二次第广释。三总结安住。初中论经但云心。此中菩提心者。此约出离法器为言。释此标章。论中有三。初略释。一依共者。是心难以是善恶染净所依故名为共。烦恼业是次二也。生是第九以相生义亲故同处辨。复言共者是根欲性直心。此四相似俱是法器故名为共也。染者是使心也。烦恼染净等者是习行。以习无别体。依染净残气故举彼也。依定不定等举三聚难。二别释相似义。言根等次第者。明依根起信等故云次第也。何故依起。以相似故。云何相似。谓宿习为根依根起欲欲必似根。论经名信。谓深忍乐欲意与此同。习欲成性。性亦似欲。依性起现行直心。心又似性。但依前后定不定时。故有如此次第差别。三结释名义。众多释林。难知释稠。此二俱句故云难也。行者不正信义。远师释云。于理证信。能灭心想。心想灭故一切不行。由无证信心等集起故名为行

第二知众生诸心下别释十一门即为十一段。初心难中三。先一句总。次九句别。论摄为八。谓前七各一。后二为一。远云八中初四妄心。后四真心。妄中一约事二相三体四用。初言庄饰世心者。心以八识心能庄世也。论名心意识六种差别者。心谓赖耶。意是末那。识即六识。以心意各一。识中具六故。云六种八识不同故名差别。差别同处亦名杂相。二速转等者是心上行相。即四相迁流。谓速转是住异。以不停故。坏不坏是生灭。三无形者是心体性。谓观彼心心相泯故名为离心。下释以心身不可得故名离也。问第一义既非是心。何故此说。答以真性随缘起此心故。如云自性清净心不染而染成就染心等。四无边等者自相顺行无量境界取故。谓攀缘之用是心自相。随境非一故云无边。下明真心。五清净者自性不染故。此本性清净也。六垢无垢者。同烦恼不同烦恼。明在缠不染。七缚解者同使缘缚。性离名解。下二名因相者。谓愿力业力引受报心。八以诸菩萨愿力受生。幻起不实似同谄曲。然实成益故云质直。九余众生等随业受生故云随道也。论重分别中。言以自性清净心故第六第七等者。释六七二句染净所由。谓若无第五性净之心。即六七二句唯垢唯缚。无不垢不缚。又由此二句中染缚烦恼故。示后句中随道受生。第二是菩萨知烦恼下明烦恼行稠林。于中先别显。后总结。别中十句。论摄为三。谓初二各一。后八为一故也。初深相者远入乃至有顶故。若小乘中非想非非想为顶。若大乘中至金刚定。二浅相者论经名行无边相。谓无量善根修集之时。烦恼随行难可知故。三染中有八句为三。初三明烦恼染。次二约生显烦恼。后三约业明烦恼。初中言心伴相不相离相者是随所缚即缘缚之义。迭共同事者释共生义。心伴是也。谓心王与惑互相扶起也。迭共相依者释不相离义。谓起已互依不相离也。共生不离者举经双结。二言使缠差别者是。以何缚者谓使也。以有使故。不得解脱故。说使为能缚之体。谓十使十缠故云差别。言烦恼使一义者举经会释。谓此辨烦恼。何故说使。以是一义故。若是一义。何故下文别明使行。但此十使有系缚义。属此门收。有随逐义属后门摄。此经本中分出使缠。俱是能缚。三言是心相应等者是所缚事。谓心者出所缚体。心相应等举经对显。重释不相应。示可得解脱者。以在缠心性恒本净故。今此缚可有解脱。次随道生等二句。约生明烦恼。论言身事生道界因者。明此烦恼与六道三界生身之事为所因故。生烦恼染示者结。此就生明烦恼故。后爱痴下三句。约染业明烦恼。三分中业因障解脱者。爱痴及见是为三分。爱是欲求。痴是有求。见是有邪。梵行求俱障解脱。释为大过。言随顺世间身口意业不断起因者。以憍慢愚痴造重罪业。明烦恼是三业罪因。以不断故。乃至下总结。八万四千者。准贤劫经说佛一代有三百五十度功德法门。谓始从光曜无极度终至分布舍利度。一一各以六度为因。便有二千一百。以此对治四大六衰十种恼患。即成二万一千。四大是内报身也。六衰是外六尘衰耗善法故名也。以此二万一千各化四种众生。一多贪。二多嗔。三多痴。四等分。即成八万四千诸度法门。能障之结即是八万四千烦恼。业等亦尔。下并准之

第三是菩萨知业下明业行稠林中。亦先别后结。别中十句。初善等者明业能为六道因故。谓善中上者天因。中者人因。下是修罗。恶中三品三恶道因。无记非因。相对故说。又亦得有名言业义。二分别等者自性差别。思为自性。然有三种故名差别。谓审虑思决定思。此二在意地。未至身语名筹量时。未作故不可分别。发动思正在身语名作业时。善恶业成名可分别。三心伴等者方便差别。谓此业思共意识生各为心伴。随其善恶生已。即薰本识成种。种似能薰故云不别生果。此释不离也。四自然等者尽集果差别。谓无始时业自然念念灭坏。然集果不失故。言有为作业者释自然灭。以是有为必无常故。因尽集者显功能不亡。释集果次第。此念念灭全能引果。行道灭亦分引果。如转重为轻等。如此非一故云种种相次第也。五有报等者已受果未受果差别。谓过去生报业。现在已受名为有报。过去后报业。现在未受名为无报。非谓全无。六黑黑等者对差别。谓四业相对显其差别。谓初二句善恶相对。后二句流无流相对。故俱舍第十七云。诸不善业一向名黑。染污性故。异熟亦黑。不可意故。色界善一向名白。不杂恶故以无色界不具中有生有二报。亦无身等三业故不说也。欲界善业名黑白。恶所杂故。异熟亦黑白。非爱黑杂故。诸无流业名非黑白。广如彼说。言能尽业相者是无流业。业起者起赖缘故。受业法者能纳果故。论经名为正受也。七无量等者是因缘差别。谓随多因缘皆能起业。八世间等者未集已集差别。谓出世未集。世业已集。九现报等者明三时定不定故。现作现受名为现报。次来生受名为生报。于第二生已后受者名为后报。于此三中有定不定也。十随诸乘等。三种乘中有定不定。谓退不退也。非乘世间中。易度难度为定不定故。论经于乘非乘各有定不定业可知。下结八万等可知

第四是菩萨知诸根下明根行稠林别中。一软中上者是说器故。谓是说法所授之器。亦名钝根中根利根。谓速受名利。迟受是钝。中容是中。又受深名利。受浅名钝。中容可知。又广受少受中受亦尔。各通教理。准之可见。二先后际等者根转差别。前后根者解先后际根也。前根下增平故者解别异不别异。谓前是能生后是所生。所生若增前根即下。所生若下前根即增。相似则平。三上中下者三性差别。谓三乘性别。上者大乘。中是中乘。下是小乘。四烦恼伴者烦恼染差别。谓喜乐等五受根。随烦恼习使染故云烦恼伴不相离也。俱舍第三云。于杂染中。乐等五受有增上用所以者。何由契经说于乐受贪随增。于苦受嗔随增。于不苦不乐受无明随增故。解云增上用是根义。五随诸乘等者定不定差别。于三乘中。于世间中者此解乘非乘也。定不定熟不熟者总释。谓大乘中熟者定。不熟不定。小乘中熟者不定。转向大故。于三乘中各定者各于自乘中解脱故云一一乘等也。报定者舍者于世间中。定不可化令入道故暂舍也。此约初教大乘。许五性别故作是说。六随根转等者。顺行差别有三种顺行。一依身顺行者。根法依于六入之身迭共相转。六入展转故此释随根转也。二生灭顺行轻坏故。此释易坏也。三观行取相者释深取相。七增上等者声闻净差别。行增上障灭能成义故。望凡为行增。此释初句。次断障行成。释不可坏。八转不转者菩萨净差别。地前名转。地上不转。又前七地名转。八地已上名为不转。九三世等者示一切根摄差别。初行名始。正修方便。终成名熟。约此三时辨根差别。谓根与行俱名为共生。以行有始终根亦随尔。下结可知。第五欲六性七直心。各软中上。论云如是性入者。释不广说所由。以根等四法性相顺入故不广释也。第八知诸使下明使行稠林。使者随逐缚义。从喻名使。如公使逐贼得便系缚。烦恼亦尔。随逐众生得便系缚。十句中初四句明何处随逐。后六句以何随逐。前中四处随逐。一句约心明处。谓共非报心生不共报心生。二约界明处。欲界下色中无色上。当界起心名心相应异界相望即不相应。使即不尔。一切相应故云不离相也。论经有远入故者约位明处。乃至有顶经欠此门也。三约时明处。言无始来恼众生者。无边世界唯智怖畏如怨贼。以未曾有闻思修智。是故不灭。恒恼众生。四约行明处。禅等相违者世间禅等不能灭心随顺行。若无使随此禅等诸德即成出世。与彼出世正修相违不令得出。下明以何随逐。有六种随逐。一有不断是标也。以有不断等释也。谓以有使故。能令三有相似相续故云三界系也。此约前处以明随逐。二远时随逐由无始来使随逐故。令无量善心不得现前故云无量心等也。三一身生随逐。是标也。谓就今一身明现种随逐。下释眼等入门者是六根也。六种生集识者是依根所生六识也。同生随逐者明使于根识俱生随逐。此是现行及阿梨耶薰者。此薰本识。明种子随逐种现相资令烦恼滋茂故云开烦恼门也。论经开诸入门者。约六入等起惑处也。四不实随逐者。不得实对治故云不知对治。五微细随逐下释微细相。谓于三界九地中六入处烦恼身随逐故。以使微细不可见故名无所有。如麻中油不可现见。论经随顺者明是有也。不随顺者明其是细同此无所有也。六离苦随逐出世间行。余行不能离故云无圣道等。第九是菩萨下知生行稠林。于中八句。一身种种。明形类不同故云生差别。二由业异生。别经无此句。三住处种种。明六道不同故云地狱等也。四色相上下种种。明三界不同故云色无色界等。问既是无色。何故言色上下。答依大乘无色界中有微细色。是色中上也。想中上下亦尔。外道为无想实有细想。五同外色因种种。明类同草木依地等生故云业是由等。六自相种种。谓名色共本识生。是报自体故云名色共等。七本顺生因种种。若正应言顺本生因。从痴爱生。还顺彼故云痴爱等。八集苦谛种种差别者。现生能集未来之苦。三求众生集苦不同名种种别。言欲生者。复有乐有众生爱自身他身。心着相。往来上下界取着故。解云此是有求众生爱自界是自身。爱他界是他身。由着相故。于上下界往来故也。欲作欲受者。论经名欲受者。乐贪共取处处求故。此是欲求众生以贪及取处处追求故也。不乐等者是邪梵行求众生。小大无量释三界。无想是别举无想天。以外道取彼为涅槃故。轮转释相续。理实轮转妄为出想故也。第十是菩萨下知习气行稠林中有十。初一是因习气。谓过去所作善恶等业。彼习气与今现果。或同现起。或不同起故。云有起不起。二是果习气。道谓六道。薰是彼习。如从天来今犹鲜净等。广说道习。如大威灯光仙人所问经内应知。故云随所生等。三是缘习气。亲近众生薰。如近善人即便善等。故云随众生等。四是起作习。随所起烦恼。如数起贪等即成串习。随所作业亦有习气。如陶师之子堪修数息等故云随业烦恼。五是业习气。谓所作善等有串习故云善不善等。六厌离欲等便有串习。后易断除故云离欲等也。七中阴望现以说习气。如人现在乐修梵行至中阴中亦无欲染故云随后身等。谓在后中阴身处有前本有习也。八与果次第薰。谓随一串习于诸趣中次第受身。皆有彼习故云次第等。九世间禅因薰下释成。由彼禅中不断烦恼。烦恼牵故生于上界。犹有彼习故云久远等也。此经欠后二句。一邪正相对。谓同法是二乘解脱。以诸外道不同佛法故名为异。彼取无想以为解脱。于此邪正各有习气故名为薰。故云有实不实。实是小乘。不实是外。二大小乘相对。谓于三乘人法。随有见闻亲近。皆有习气故云也。第十一是菩萨下知三聚行稠林。论中为五。初一约种姓以分三聚。谓无涅槃法者是邪定。有涅槃法者是正定。正定中三乘各别。一向自定离此二。是不定种姓。论略不释此。论就初教释应知。二约解惑以分三聚。谓正见是善行因。三善根中正见一种。定起善业名为正定。无贪无嗔不定起善。名为不定。邪见是恶行因。诸烦恼中。邪见一种定起恶业名为邪定。余名不定。三约行业以分三聚。谓五逆中一一逆罪。定招恶道名为邪定。信等五根定招善道名为正定。不同此二名为不定。四约邪正位以分三聚。谓翻彼八正名八邪。因此以立外道邪位。名为邪定。正性离生名为正位。因此以立声闻正位。名为正定。五直约大乘菩萨得失以分三聚。言深入邪聚难转者。论经名妒吝恶行不转邪定相。谓忌他胜己。不以法施舍可化机故名为妒。悭财不施故名吝过。能生他苦名恶行不转者。谓杀盗等也。波罗蜜相违者。此中六蔽障六度行故名相违。谓妒障后三慧定进也。吝障施行。恶行障于戒忍二行。由此障故。令诸菩萨正行不成就为邪定。正定不定准释可知。佛子下通结于前三种成就可知

第四菩萨住是地下明说成就。于中先总后别。总中知众生诸行者。牒入行知法器也。随其解脱等者。正明称根说法令得解脱。是菩萨化下别明说成。文有四段。义有三重。一尽此初段是智成就。二为大法师下一段亦智成亦口业成。三用无量慧下唯口业成。四得陀罗尼下是法师成就。初段中二。先明随所知者是所说法。二随所依者是所逗器。前中化众生法者说解脱器得熟故。谓说化法令诸众生解脱器熟也。度众生法者解脱体正度故。谓正令其得解脱果。然此所得解脱差别即不出三乘故云如实知而为说等。二如实随众生下明随所依中。先总明随器说法。二随心下别辨也。说法对器解随心。言随应度者授对治法。解论经随使谓随使对治故。上二句是化法器也。言所说法器成者明度法器。解随根等。以器成说法故。言随行处者随心所行境界之处。即以彼喻令其生解。名为彼器。言随智慧处者。依前生解为令起种种异行。名为彼器。言知一切行等二句者。乃至得成就器。明依行成德之器。言随趣等者随辞辩器。谓生业烦恼久习难除。胜辩教化方令舍离故。名生等为辞辩之器也。薰解习气。同行解转。此中略无定等三聚。言随乘等者。论经信是三乘因。能乘出器故也。第二是菩萨住此地下明亦智成就亦口业成。是故论中先征问口业。结云智成。从前为智。知说仪故。从后口业。具二十种法师德故。论中说者是其口业明入深义也。持者是智成显守护法也。其二十种法师事如论具说应知。第三用无量下正明口业成就。于中二。先略明四无碍智能起口言。后广以十门次第分别。前中用智方便者牒前起后也名前所说为智方便。用彼起此无碍智也。下明依四无碍智起言辞说法所得无碍无暂间动故云不坏。四无碍义广如别章。但无碍解体是后得智。就所缘境分为四种。一法体者明法自体。二法境界体者于法体上有差别义。三正得与众生者。依自所得说与众生。四正求与无量门者。随诸众生正求差别与无量门。下重释中。初释法无碍中远离二边。生法所摄者遮余法故名离二边。表自体故名生法摄。如色碍相。举例显示。等余一切。二释义无碍中。彼远离等牒举前法。如实智下就法辨境。菩萨住彼约人辨境。如色下亦举类显虚妄分别。正显差别之义。若小乘说色有苦无常等义。今约大乘说此色法但是妄情理实本无是色之义。三释辞中。随他所喜言说正知者。谓解知于他所乐之言。释正知也。随他等释与也。四释乐说中。先牒举前词。无量下约辩乐说。无量种种义语是词中差别。释无量门也。随知下释与也。新名辩无碍解。谓明辩巧说令他生乐。亦名乐说。自下广释中。理实此四于一切法随说皆具。今依圆数且列十门。于中初五泛知理教。后五知三乘净德。前中初四正就所知明无碍。后一约能知智。前中初三知义。后一知教。前中一约知事法。事法缘别各住不杂名为自相。二知理法。理法遍通名为同相。此二当相明法。三约时辨法。谓三世迁流故名行相。四对机宣教名为说相。五约能知智分四无碍。非是知于智故名为智相。后五中。初一总知三乘离相净证名无我慢。后四别中。一通知小大。余三别知大乘菩萨地。初一知因。后二知果。一体二用可知。下次第释中。释此十章即为十段。就初自相中法义是总别一对。于缘生法。总知自相。别知差别。词及乐说广略一对。少名显法名之为词。众多异名为坚彼义。令他爱乐名为乐说。言想坚者。想是起言所依。是故余论中或云想。或云声。或云名。或云字。或云施设。皆是名之异号。以言名显义令义坚固故名想坚。想坚多种名想差别。重释中不坏牒辞。随所觉明自解也。随彼彼等显应机说也。次第不断名不息者是常说也。无量众多等于一一法。能以无量异名广说也。为坚彼义者。谓以异名多说意成本义故令坚固也。第二复次下明同相。于中法义约二谛分。后二亦约广略分。初一切法同一无性。二有为法同无常相。三假名同者。法同无名但假以说。四假名假名同者。复以假名更重显之。下重分别。无常入无我者释义顺法。谓观无常即解无我。是故第二门入初门智境也。次牒词文。于前假名法上。复以余假名随应根说。次不坏无边者牒乐说文。不坏前假名而能以余异假名说。谓异名虽说不违前词故云不坏也。第三复次下明行相。于中了知一念缘生现法名法无碍。已未曾当名差别义。于此二法假设名字名词无碍。即以此名为诸众生。宣说彼事名为乐说。下重释中。一一世现在故者。通论过未各有现在故云彼彼世间摄。是则一一世中各有多门异说。言见过未知现在者释义顺法。如是菩萨下结后成前。谓以后义成前法无碍智境也。下释乐说言事行相。不出三世者释前所说事。经中一一世皆不出三世。言无边法明者异法明。异法明即是闻思慧照法故也。第四复次下明说相中。就教本释以分法义。约所随心言分词乐说。谓随物音说故云随顺说。谓随心异说意义不殊故云相似说相。余文可知。第五复次下明智相。于中法义约现比分。词及乐说约浅深分。初中以法无碍智知法智所知境。非是法智即法无碍。如以苦智知欲界苦名为法智。知上界苦名为比智。今此亦尔。以义无碍知比智境。新论名法智类智。然此二智毗昙宗约时通处别。二智并皆通知三世。别知欲界。名为法智。别知上界。名为比智。若成实宗处通时别。二智俱知三界。知现名法。知过未名比。若大乘宗时处俱别。知现在欲界名为法智。知上界及过未俱是比智。词中言欲得方便者。词说世谛。与得第一义作方便也。乐说中言得智者。说第一义。令正证得故。下重释中释初法智内。知谛差别是二谛不同。不异方便是释不坏方便。谓见不异法名为不坏。法智等举经对显释比智中。如此如实等释显比义。以现所知类余知法。释乐说中。非颠倒异说者称理说故。第六复次下明无我慢相。于中真俗二观以分法义。谓观真一相无我不坏。观俗蕴等差别无我说中妙胜分词乐说。谓惬情称美。顺理名妙摄令归趣也。言理殊胜。成益转多名无上也。下重分别释初无碍中。先顺释。谓无我不坏故下反释。谓取己能解名为我知。取己能得名为我证。如是等坏即明不取名为不坏也。阴等方便下释义顺法。谓观阴等以为方便。得入真谛无我法故。是故下结后成前。故是菩萨智境成也。一聚积下释显无我。谓迷阴故计聚积我。以迷界故计异因我。以迷入故计欲着我以迷四谛十二缘故计作着我。说此阴等对治四我。以显无我。杂集论第一中广显蕴等所治之我(云云)。第七复次下明大小乘相。于中约权实以分法义。谓以约实同观唯是一乘。约权异性说有三乘。词及乐说约总别分。总说三乘令得解脱名词无碍。随物心念于一一乘无量种说名为乐说。下重分别。文显可知。第八复次下明菩萨地相。于中法义约地体相分。词与乐说同体义分。谓说地名词。词中差别名为乐说。智相是地体。说相是地相。谓随相说十故。巧授十地名与方便。随物心乐于一一地以无量门令入故也。下重分别释菩萨行中。法行智行示者以此二行合为菩萨行。谓证法成行名为法行。即智成行名为智行。以此智行能入地故名随智行。言观智说故者释所由。谓何故智行是菩萨行。答以说观智为菩萨行故。次释义无碍中十地差别。谓心者出地体。谓地别由心说为口言。下释词无碍中。不颠倒解不坏说。教授解随顺地道也。第九复次下明如来地相。于中法义约佛体用分。词乐约广略分。初一念证得名法身相。二时处应现名色身相。三谓前二身中智德差别名正觉相。四随物心乐广显佛德。无量差别名为说相。下重分别释义内。随何等劫成何等佛者示化时也。如释迦佛成在贤劫。释事中言随以何国是成道处也。随何等佛是现佛身。释相中言随名所记可得见闻者谓如名所记。身土声色可见闻故。释词无碍中。随正觉等者。以十佛中最初名为正觉佛故云依说。第十复次下明作住持相。于中法义约知佛说。总别分异。说前法义名词。词中差别名为乐说。初觉相者是佛起说住持德也。二差别相者是佛随机现差别德。三说相者依前差别为众生说。四彼无量相者随物心乐异异说也。下重分别中。佛语者能说故。力是神力破憍慢众生故。无畏降邪。不共异小。悲能常说。智为说依。转法则是随顺正说。此上皆是一切智摄。释义无碍中。随心性者是种性差别根欲可知。言诸佛智行等者。释乐说中智行名法身。此行利生不坏名圆满也。随彼信等释随信说故也

第四大段菩萨摩诃萨下明法师成就。于中有四。一持成就。蕴法在心。二说成就。依持起说。三问答成就。他惑疑问菩萨善答。四受持成就。能更受胜法为他宣说。就初中先牒前起后。二得众义等。正显十时。并约所起业用分异。谓初三起意业。一能知义。二能知教。三智起通化。次三起身。四身放光明。善耎众生慈光摄取。五刚强众生威力伏取。示违伏物是善巧之慧。六上供诸佛下摄贫穷故云众财。下四起口业。七于大乘中狭劣众生示教利益者。示大乘中名闻威德。令其舍劣趣入不难故也。八不断者常说也。九无尽者深说也。十种种者广说也。下结可知。自下经文论主不释。第二是菩萨于一佛下明说成就。于中三。初明能受多法。二是菩萨得如是下能广说法。三是菩萨处法座或以一音下。能起说自在。第三是菩萨三千界所有众生下明问答成就。于中二。初一世界中答难。二明一切世界。第四承佛神力下明受持成就。于中二。先于一尘处。后类一切尘。忆念等可知。下明地果。三果同前。文处可见

第三大段重颂中有四十二颂半分六。初四颂法师方便。二有四颂智成就。三有十二颂入行成就。四有十四颂半说成就。于中初一颂半智成就。次三颂半口业成就。次九颂半法师成就。于中初．二持成。次二说成。次半问答。次五受持成。五有七颂地果三果可知。六末后一颂叹深结说。善慧地竟

第十法云地亦七门同前

初释名者释有三义。摄大乘云。大法智云含众德水。譬如大云。无性释云。由得总缘一切法智。总缘一切契经法等。不离真如。此一切共相境智。譬如大云。陀罗尼门三摩地门譬如清水。智能藏彼如云含水。有能生彼胜功能故。二蔽如空。粗重犹如大云。无性释云。又如大云覆隐虚空。如是总缘一切法智覆隐如空广大无边惑智二障。言覆隐者隔义断义。三充满法身犹如大云。无性释云。又如大云注清冷水充满虚空。如是总缘一切法。智出生无量殊胜功德充满所证所依法身。唯识论云。大法智云含众德水蔽如空。粗重充满法身故名法云。此中三义同于摄论。金光明云。法身如虚空。智慧如大云遍覆一切故名法云。真谛释云。如虚空者譬三如如也。虚空有三义。一容受义。譬自性法身不碍生死。二无边义。譬显了法身。虽得显了犹未究竟。如空有清净无有尘雾处。如道内法身通惑解中道也。三清净无尘雾譬圣果法身。智慧如云者譬如如智有三。一道前性得。二道内修得。三道后至得。文言遍者性得如如智遍如如理。满者修得如如智满如如理。覆者至得如如智覆如如理。境智相称。云即是雨。雨有三义。一能阴尘。道前自性智清净无染义。二能洗垢。道内灭惑除恶业。三能生萌芽。道后能生如萌芽。又空如法身云如应身。庄严论云。于第十地中由三昧门及陀罗尼门。摄一切闻薰习因。遍满阿黎耶识中。譬如浮云遍满虚空。能以此闻薰智云。于一一刹那于一一相于一一好于毛孔。雨无量无边法雨。充足一切所化众生。由能如云雨法雨故故名法云。仁王经名为灌顶。十住论无佛世界能雨法雨名法云地。解深密云。粗重之身广如虚空。法身圆满譬如大云。皆能遍覆故名法云。解云谓我法执所薰种子无堪任故名为粗重。遍障二空无我理故。是故经云广如虚空。其第十地十种法界法身圆满。喻如大云。证法界时由圆满法身及修生法身。覆隐如空广大粗重故名法云。余义如下释名分中说

二来意者亦有三义。一前虽得彼辩才说法未能圆满法身现前故。今进令彼修证圆满是故来也。余二门可知。又地论云。于九地中已作净佛国土及化众生。第十地中修行令智觉满足。此是胜故

三所离障者。依地论离于诸法中不得自在障。唯识论云。于诸法中未得自在障。谓所知障中俱生一分令于诸法不得自在。彼障十地大法智云及所含藏所起事业。入十地时便能永断。由斯十地说断二愚及彼粗重。一大神通愚。即是此中障所起事业。二悟入微细秘密愚即此中障大法智云及所含藏者。解云以能障通等所知障一分为体。金光明云。最大神通未得如意无明。微妙秘密藏修行未足无明。梁论大同。又此地终心亦离二障。便至佛果。成唯识论云。此地于法虽得自在。而有余障未名最极。谓有俱生微所知障。及有任运烦恼障种。金刚喻定现在前时。彼皆顿断入如来地。由斯佛地说断二愚及彼粗重。一于一切所知境。极微细着愚。即是此中微所知障。二极微细碍愚。即是此中一切任运烦恼障种。故集论说。得菩提时顿断烦恼及所知障成阿罗汉。及成如来证大涅槃大菩提。故解云此二微细过前障外故名余障。金光明云一切境界微细智碍无明。二未来是碍不更生未得不更生智无明。梁论名微细碍微细着。同此可见

四所证者证得业自在等所依止法界。世亲释云。谓此法界是身等业自在所依。及陀罗尼门三摩地门自在。无性释云。业自在等依止义者。谓随所欲门身语意业用自在依五神通。随自作业皆得成辨。得文义持诸陀罗尼自在力故。能持一切佛所宣说文义无忘。得三摩地自在力故。于诸等至等持能断。随其所欲虚空藏等诸三摩地三摩钵底而能现前。中边论云。随欲作种种利乐有情事故此但总说不别开也。唯识释云谓若证得此真如已普于一切神通作业总持定门皆自在故。解云准上诸论。于此地中得四种自在。一五通。二三业。三总持。四诸定。寻此地下文。大尽分等更当会释。唯识云。虽真如性实无差别。而就胜德假立十种。虽初地中已达一切。而能证行犹未圆满。为令圆满。后后建立

五所成行者亦有三种。一成就受位等行。二当智波罗蜜行。三依庄严论。第十住三昧门陀罗尼门极清净故

六所得果者。依梁论通达业自在依止法界得化身果。金光明第三卷云。十地发心得首楞严三昧。当地行果。位果又梁论十果并当所成佛地大果。余悉现得。又金光明说修行十地得大总持果。如彼经说

第七释文中。初赞请内二十五颂分五。初二颂明首陀会天设妙供。二有一颂明菩萨烧香供。三有二颂明天王眷属宝衣供。四有十八颂明天女乐赞供。于中初二总明作乐。次二叹佛体相普遍德。次三叹佛业用成益德。次四叹佛八相应机德。次二约幻喻叹佛广大德。次三叹佛法身平等德次二结劝修学。下一天女结默。五末后二颂众首正请可知

第二正说分中有八分。一方便作满足地分者。摄前九地所修诸行。总为方便满此地也。二得三昧分者。初住地行行德无量。以此地受职必依三昧故偏举之。三得受位分者。正住地行。谓依胜定能摄佛智故名也。四入大尽分者。是地满行。此为望前已是穷尽。尽中之极故云大尽。五释名分者此地学穷辨德显称。六神通力无上有上分者。地满足已妙用自在。故曰神通。通用过前名为无上。仰劣如来名为有上。已下二分通于十地。但以前摄后。于此地收。七影像者以喻显法。如因像知质。八地利益者彰说胜益劝信趣入。就方便满足地分中。先总标举。谓无量是广智。善修是深智。前诸地中具起此二通名善择。谓妙智决择故也。宝性论中地上菩萨起二修行。一约根本智名如实修行。当此善修也。二约后得智者遍修行。当此无量智也。下别辨中九句。论摄为七。初三为一。名善修行者。谓于诸地皆同善修证。助不住。似前八地中同相故也。谓白法是证。助道可知。大功德等是不住。不住无故不舍功德。护是不舍也。不住有故不舍智慧也。此三句次第相释。谓何因得证。由起助故。何因成助。由不住故。下六句别显中。初一句摄前七地二利行相。第八地初以辨七地差别。故此总摄一句显之。言广行大悲者。普遍释意。七顺自利释行也。随顺利他释大悲也。二言深知分别等者别举第八地令佛土净行。下四句别举第九地中行。于中初句是九地中自分之行。教化众生故云深入。即是入行稠林等也。下三句明胜进行。于中初解次行后证。言入诸等者解佛所行真如境法。言趣向等者求于佛果无厌足行。言得至等者地尽至入。谓十地位穷名为地尽。依行得证名为至入。以此地中受佛智职故云一切智位

第二菩萨摩诃萨行如是下明三昧分。于中初牒前起后。则得下正显所得。于中四。先别显十门。二通结百万。三是菩萨下明能入能知。四显最后名。就初内论中举初等后。故云离垢等。举后百万故云眷属。离烦恼垢释显其相。以此位中是障尽处故。不加功者成就相应故。余九是别。以六七二定共离一垢故离八种垢。一入法界差别者是入密无垢。谓法界深奥名为密处。二行近佛果名庄严道场。三身光业用。四口辩总持。五意业现通。六广。七深俱显净土。无量释广。正观释观。上来自德。八随一切等者化众生无垢。利他德。上二利自分行。九如实知等者是胜进。上觉名正觉无垢。谓将成正觉。诸佛迭共现前证知。此如下文受职处说。言一切智智无分别释一切智也。一切智智平等受位牒智释受位也。满足三昧事释悉入。其体知其业用可知

第三是三昧现在前下明受位分。于中有六。一随何等座者。如世王子受职之时在阎浮金白象宝座。菩萨亦尔。受佛职时在于大宝莲华王座。二随何等身者。如轮王子玉女宝生具足王相为得位身。菩萨亦尔。殊妙之形为受职身。三随何等眷属者。如轮王子受位之时文武百贵共相辅弼。菩萨如是。受佛职时诸大菩萨共相围绕。四随何等相者。如世王子受位之时扫治衙巷悬缯幡盖钟鼓振响。菩萨如是。受佛职时。振动大地。恶道休息。放光普照世界严净。以此为相。五随何等出处者。如世王子受职之时。口出赦书恩及天下。狱囚得脱库出赐臣。菩萨如是。十处放光。令恶道出离菩萨增行。六随所得位者。如世王子受位之时。父王手执金钟盛四海水灌太子顶即名灌顶轮王。菩萨如是。十方诸佛白毫所放一切智光入菩萨顶名受佛位。此六段经。前三段文。论家一处释。次二亦一处释。后一别释。就初座中有十相。一华王是主相以自在故。二周圆等是量相以广大故。三众宝等是胜相以具德故。四过于等是地相以是生处故。五出世等是因相以从彼生故。六知一切等是成相以空慧所成故。如世莲华种植所成。七光明等是第一义相。如世莲华令心取着。菩萨华座善照法界。论约照理。经约照事。可知。八功德相经无此句。以与地相相似故不辨也。又此明所生果相与前异也。九琉璃等是体相。以茎等是体状故。十无量光等是庄严相以德用备故。二尔时下明随何等身。身体姝妙广称华座。三即时下明随何眷属。谓处座得定心敬目瞻。四是菩萨升下明随何等相有五相。一动地。二息苦。三光照四严界。五见佛等。五何以故下明随何出处。言何以故者征前起后。论言以出光明故总释出处也。文中有三。初十处放光。二尔时下由光普照诸佛菩萨咸皆觉知。三即时下由觉知故下位菩萨俱来供养。就初中此十光明论摄为三。前之九种是利益业。谓初五益凡夫。次二益一乘。后二益菩萨。又八九十此三名为发觉业。谓第八发觉从初发心乃至九地业。第九发觉十地菩萨。第十发觉一切诸佛。又八九二光名摄伏业。谓第八能摄。能令九地已还菩萨咸来供养。第九能伏能使魔宫隐蔽。就第十顶光中有四。初照十方。二成光台。三设供养。四入足下。初二可知。就供养中有三。先显供胜。二正供佛。三明供益言必定无上道者论有二释。言于地中决定义故此约地上证决定也。言复有异义等约下位令入正定益。谓定不放逸者离恶定也。所作之事决定心者集善定也。言入佛足下者。远公三释。一就教相顶光入足显深敬故。二约相显实。菩萨智光证入佛境。从下趣入名入足下。故论名为平等智摄。三约实以论。菩萨自已因行趣成果时。从下证入名入佛足。第二尔时下由光普照令一切诸佛菩萨咸知。第三即时下明由觉知故令有所作。于中二。先下地菩萨来此兴供。谓先供养后得益。二同位菩萨德光相助亦先光入后明益。良以菩萨内有万德故。于胸前有万字相现。论释可知。第六尔时诸佛下明随所得位。于中有四。谓法喻合结。就初法说中亦四。一放光。二入顶。三得益。四结位。初中光有十业。一名益智是利益业。二因业。三照示佛力。令他恭敬名敬业。四劝进等名劝进业。五十方等名振动业。六灭除等名止业。七降伏业。八示现业。九卷舒业。十示神通等是变化业。二入顶者。事光入顶。即是法光入心增位故也。论名如来光明。彼菩萨迭互智平等摄受者。谓菩萨顶光入佛足。是上进故也。佛光入菩萨顶下摄故也。因果迭合故云平等。身光即智故云智也。三得益可知。四结位中。入佛境所证同。具十力行德同堕佛数。成人同以成佛德堕在佛数。如始出家虽未受戒即堕僧数。喻合结位并可知。第四住法云地如实知下明大尽分。于中有五。一智大。依正觉实智义故。二解脱大。依心自在义故。三三昧大。依发心即成就一切事义故。四陀罗尼大。依一切世间随利益众生义故。五神通大。依堪能度众生义故。前二自利。一内智。二外用。后三利他。一意业起用。二依发语业。三身业变化。就初智大中有七种大。一集智大者。知法缘集智力断疑。二应化智大者。谓化智业用依身而起。三加持智大者。谓化业住持化用非一。重言如是。常化不绝名转行力。四入微细智者。此是微细相容安立门。常于示成佛。八相之中一现一切故称微细。依彼应化等牒前三智。名为不二。依显微细。一化二加三集。合此三智。依此成佛故名为作。正是微细。五密处智者。此是秘密隐显俱成门。谓将护初心根未熟者。现粗隐细。令彼不怖。依彼说没此微细智也。六入劫智者。善解诸劫互相涉入。名入劫智。时劫相续说以为命。迁流名行。一摄一切名曰加持。一入一切名之为舍。以废已随他名为舍故。劫随心转名自在意。七入道智者知诸世法堪为出世对治之用故名入道。初集智大者诸释云因缘集智应知。彼复随所有分染或净或灭者此是总释。于中有六重。一或唯染。谓初五句及邪见烦恼集。二或唯净。谓涅槃集及声闻等集。三或唯灭。谓虚空集。四染净合。谓识及有为世间成坏。五净灭合。谓无为及涅槃。六通于染净及灭。谓法性集。论经名法界。即不善法界名染。善法界名净。无为法界名灭。论别释中。言随所有三界处者释初三句可知。随所有众生者释次二句可知。随所有染净等心者释识集可知。随所有有为无为法无知知故者释有为无为集。即有为有心故名为知。无为无心名曰无知。随所有处虚空等者释虚空集。以是世界等所依处故。随所说正不正法者释法界集。即净法名正。染名不正。等取灭也。随所证不证谓于涅槃者释涅槃集。以圣人所证故。下明不证即释邪见等。谓何因不证。以邪见故。是谁邪见。谓余外道等。彼不能证故。随所有器世间成坏释可知。随所有三乘彼集差别者释声闻等应知。结文可见。第二是菩萨以如是下释应化智。于中先别显后总结。别中十句。初四明众生世间自在化。谓化现众生及所作业。化现贫等及示邪见。是故论云应化示烦恼染见作故。次一句是器世间自在化。下五句是智正觉世间自在化。言法界者所说法行故。化现三乘法。皆有觉义。结中化作有心名为分别。化现非情名无分别。又释作意现化名为分别。任运现化名无分别。此文就初义说。以是法云无功用位也。第三是菩萨下明加持智。于中十。一初佛法僧是境界持。谓常化不绝名佛力持。法僧亦尔。经中欠僧持。余八句是行持。初二是逆行持。如下方便命婆罗门。以五热刀山任持万行。是业持也。如留烦恼资成正行名烦恼持。次五句是顺行持。谓多时积行名曰时持。由愿起行名为愿持。由宿善根令行得起名先世持。依行起行名为行持。行经三祇名为劫持。由依报命而能起行名寿持。下一句果持。论云是中智持者一切智智故。此智能作一切事故。上句释智。下句释持可知。第四是菩萨住是下明入微细智。谓知佛化用微细自在。于中行者是下。中兜率天。上所行事业。经中欠奋迅。余文准释可知。第五又诸佛下明密处智。谓知佛所现秘密义等。于中初三业可知。次筹量众生应受化时及非时也。次或有久已成佛示与受记。或见白鸽记当得佛。如是等类名受记密。如爱语罗睺诃骂调达。是摄伏众生密理实一乘权说三五。名诸乘差别密。下就所知。谓知根生熟。知业前后。知逆顺之行。同得菩提。第六是菩萨下明入劫智论云是中入者。平等解脱一切劫迭相入故。谓不思议解脱之法平等齐均遍诸劫海故。令诸劫迭互相入。余文同上发心品等说。第七是菩萨下明入道智于中经内欠初入凡夫道智。论云依凡夫地者释此句也。依我慢行者释微尘智。谓以微尘分别色故。令离我慢。言依信生天者释国土智。谓智现净土过彼所信言依觉观者释众生身心等智。谓烦恼乱心通名觉观。下有六句。化之合离。谓知所化至处行佛道。示逆顺行难思。具三乘并可知。结文可见。第二是菩萨摩诃萨下明解脱大。于中先别辨。后总结。别中有十。初不思解脱者依神通境界。谓转变自在难测量故。二无碍者能至无量世界。以愿智无碍故。此是速疾自在也。三净行者论经名净智。所知净行略有三门。一知世出世约位分别。二知学无学约因果分别。三知声闻等随人分别。此是所知自在。前二是通。此一是智。四普门明者随意转事。谓随众生意普于一切色像门中示现自身。如观音等。名普门自在者也。五如来藏者法陀罗尼。谓所知真如蕴积恒沙如来功德。名如来藏总持法也。六随无碍轮者能破他意而不退故。七入三世者三世劫随意住持。是入劫智也。八法性藏者一切法一切种因缘集智。此同上集智。九明解脱者。光不离身而能普照。十胜进者依一时知无量世界诸众生心。总结可知。次三昧大。次陀罗尼大。后神通大。并可知。大尽分竟。第五大段是菩萨成就下明释名分。于中有三。一能受诸佛云雨说法名法云地。二自从愿力下能注法雨灭诸众生烦恼尘炎名法云地。三复次佛子下明能注法雨生物善根名法云地。初中若从所受应名法雨地。若从能受应名法海地。但今就彼受法之处名法云地。是故论释一云法相似。以遍覆故。此地中闻法相似者。此所闻法宽广遍覆。是故名云。与法相似也。言如虚空身遍覆故者明能闻法身。谓受云之所其唯虚空故。说能受法身如空。若随所对。佛身如云。说法如雨。即所受若雨。能受如海。若对所说之法如云遍覆。即所受若云。能受如空。二灭尘。三度生。论显可知。就初中先总明成就念力者。近说受持义故。谓近佛听说受持义。二能于一念下别明受法。于中三。初于一佛所听受多法。二如大海下于多佛所听受正法。三问答明前二种分齐。就前中有法喻合。论释中先总释说众多故。释法中无量法明也。二入如来微密处释合中微密法雨。三速疾释一念顷能受。以此地中闻胜故。能受多法。所受虽多。若粗浅易解之法受亦非奇故。复云密法。虽多密。若积时方受事亦不难。今明一念速疾能持故是胜也。论云是中无量下别释前三。初二是所闻之法。后一能闻之德。先解所闻法。谓性故作故开为二相。谓三慧所知名法自性。说授众生故名为作。别释性中。大法明是闻思智摄受故。大法照是修慧智所摄受故。经欠此句也。云何作大法雨。如大云与他法雨故。下释能闻。谓起信名受。领教名堪。是文持也。取义名思。是义持也。不失名持。通前二位。经中略无堪思二句。第二释多佛所受法中。大海亦有四义。相显可知。第三问答辨分齐中。先问后答。答中亦二。先校量显示所闻广多显前初段二如一佛所下类显多佛显前第二段也。前中言三世法藏者。论释于法界中三种事藏。谓明照雨为三种。蕴在法界名为藏也。第二释名中。初寄云雷等以显菩萨能化之德。二一念等明化时促。于上等明化处广。余是化益胜。又风云雨等如论应知。第三释名中。八相现成渐长物善。文处可见。第六是菩萨住此地下明神通力无上有上分。论开六种。一依内者通依内德。此有四种。是前大尽分中五种大。以智大与陀罗尼大合说故为四。以彼并是此地德用故此同说。二依外者神通业用依外境起。三自相者转变作用是神通相。此上二门。经文是一。义开释故为二门也。四作住持者常用不绝。五令喜者断众疑恼。六大胜者超过前地。就第二依外者外事地等。是所动世界依报故也。复有外事自他身等。是后现身等即正报也。何故身等说为外邪。释以对前解脱大等是内德故。说此身等以为外事。三自相亦二种。一转外事等。土及他身俱名外等。二应化自身等。此二亦摄此一段文也。初转外事有三。一是同类略广转。二垢净异事转。三尘容世界等是自在转。二从于一尘中示一切佛是应化自身等所作自在也。四或于一念下明作住持。于中有十。一身口供赞。二八相应机。三身现三世。四身内容刹。下文金刚藏依此门用断众疑。五毛孔出风。六海华示佛。七身光遍照。八口嘘动地。九广示三灾。十身国相作。佛子下结可知。第五尔时下明令喜。令喜者断疑故。此有二种。一示现自神通力以断众疑。二顺如来身口意。下明说一切法故。以断众疑。前中亦二。初一问答。显神力无上令众欢喜。后一问答。明神力有上令众欢喜。前中亦二。先问后答。前中亦二。先大众生疑。谓举佛疑菩萨。非是疑佛也。后解脱月领疑为请。刚藏答中四。一入定断疑。二显定名字。三业用分齐。四类显广多。就初中亦四。一法主入定。二众见入身。三身内见佛。四摄用还本二显名中。先问后答。前入定时已显其名。何故更问。释当时法主默然入定。后结集家取以安之。既当时不显故此问也。答中言佛国土体性者。入此三昧能现佛国故。名此定为彼体性。三问言下明业用分齐。于中二。先问后答。答中非但如前现一佛刹。其力乃能现过尘等。四菩萨在法云下明类广多。于中三。初所得广多。谓此地所得非唯一二故云得如是无量等。二是故下明业用难测。于中初三业难测。神力是前神通大。次观三世是三达智。次三昧是前三昧大。次智力是前智大。次游解脱是解脱大。变化等是转变外事等可知。三佛子下总结广多可知。第二解脱月言下明此对佛显其有上。于中先问后答。问中举菩萨疑佛不胜。问辞同上。疑意有异。准答应知。下正答中三。初总诃所问。如一四天下望十方界已为少竟。于四天下中复取豆土。即是少中之少此四天下望豆许土已为多竟。彼十方界望四天下复更为多。即是多中之多。但以少疑多已为不可。况以少中之少欲类多中之多极不可也。故云汝所问者我谓如是也。如来无量等结诃反征。二佛子下约事显之。谓十地德中。前所说者如豆许土。所未说者如四天下土。如来功德喻十方界土。所说地德尚不得比于所未说者。焉得比于佛果功德。三我今当说下引佛证成地德无量。地德无量。然不及佛。义在难信故引佛证也。如十方下正显菩萨德劣于佛可知。第二佛子是菩萨随如是智慧顺如来下。正是调柔摄报愿智等果。就调柔果中四。一明调柔行。二菩萨住是地下明教智净。三十方佛说三世下明得法自在。四是名下结其地相。于此四中前之二段论中名为说法令喜。余及后二果俱名大胜分。前中初调柔行内有法喻合三可知。二教智净中亦法喻合可知。第六大胜中。初三世等名神通胜。二摄报中得十不可说百千世界尘数三昧等名算数胜。此二种事胜一切前地故名大胜。前中初五句别显。后一总结五。论中摄为三。初二各一。后三为一。故为三也。一三世智是断疑行。以通三世为出世道故名。道义应知。二法界智是速疾神通行。闻说如来秘密法故。三下三句名等作助行。谓于众生平等化益也。一切世界智者。作净佛国土平等为化众生故。二普照等者作法明平等。是教智化也。三大慈等者作正觉平等。证智化也。举要下总结。余文可知。第七大段是菩萨十地次第下明地影像分。于中有四。谓池山海珠。喻四功德。前三是阿含德。后一是证德。前中池喻修行功德。即诸地中起修之行。二山喻上胜功德。即依修成德。德位高出。三海喻难度能度大果功德。即修所成德。能至大果度犹到也。四珠喻转尽坚固功德。谓从初地进至法云故名为转。位极障尽名为转尽。证理终极名为坚固。就初修行功德中有法喻合。法说中始从欢喜终至法云名次第行。因成大果名趣一切智。喻中阿耨达此名无热恼池。以此龙王无热沙等三种苦故。出四河者。胜鬘经出八河。阿含经出二十河。皆有所以。出四河者据根本说。谓此池在香山顶。东面有金象口。出恒伽河。南面银牛口出辛头河。西面琉璃马口出悉陀河。北面颇梨师子口出博叉河。此四河各出池。四十里外各分为四河。绕池一匝。各于本方流入大海。是故并根本四即为二十河。毗婆沙中具列名字。如来出世在彼山东。是故东面五河人皆具见。总取为喻。余三本河有大声名。人虽不见莫不同闻。亦取为喻。通前为八。余河名小人或不闻故不论耳。满四天下者。非是四河各流一天下。此乃总是一阎浮提。何故乃名为四天下。释此是言总意别。以此阎浮提是四天中一洲摄故。是故总言四天意在阎浮。如上诸会结通处言如此四天下十方亦尔等。皆是此类。合中四摄利他。合四河满足。无有穷尽至一切智。增成自利得大菩提。合入大海也。论中依本愿力修行者。释菩提心流出善根大愿之水。此中但言菩萨必具菩提心。不待说故。以四摄作利益他行者。释彼四摄满众生。自善等释自利可知。第二山喻上胜功德中有四。一总举法。二列山名。三现山中物四以法合。初中言十地因佛智有差别者。谓以佛智为所依因。而起十地差别之相。如因大地增上依持有十山王故。论云依一切智增上行十地故。列名中。诃梨罗山者。于此山出佉陀罗木故以为名。佉陀罗此云苦鞭木也。由乾陀此名持双山尼民陀罗此名持边山斫迦罗此云轮围山余名可知。三如雪山下显山中物以喻十地。于中一喻初地圣智妙药。二喻二地戒香。三喻三地禅定妙宝。四地出世似于仙人。五以夜叉喻五地善巧自在。六以果喻六地因缘集观。说声闻果不尽者。以六地超出声闻境说彼无穷尽也。七龙喻七地。亦以超出辟支能说彼道。八心自在者。是诸密迹神名自在众。喻八地中十自在等。九修罗喻九地善巧摄生大力之相。十诸天喻十地满足。又论中释。是中纯净诸宝山喻八种地厌地。善清净故者。谓十山中除初雪山香山。以是土石山故。余八皆是金宝之山故云纯净宝。喻后八地厌地者。是第三地。彼以净禅厌离烦恼。如宝纯净也。善清净者。是四地已上。以彼无流断诸烦恼。如宝纯净也。言复次诸山下释诸山中所有诸物。谓神仙等是众生数。药宝等是非众生数。于中一药等能资内报名受用事。谓药能除病。名增损对治。香果资身名长养事。二宝不资身。但可贮积以除贫乏故名守护等。言依雪山等者指定其处。谓初三及第六。此四是非众生数所依。下释众生数中。治六种难。一五通福田供。以生富故治贫难。二夜叉威制眷属。不令害人故治死难。三龙降时雨。以治险难。四金刚力士摧伏恶人。治不调难。五修罗说咒力调其眷属。不行杀害。名治恶业。六须弥顶上天帝释等名为自在。须弥腹上所有四王名四天王。彼能对治修罗怨敌。下释集中不穷尽义。谓如上所说事。能生一切物故言集在其中也。顺行不断不休息者解不穷尽义。谓次第相续名为顺行。不永断故名不断。非暂无故名不息。下释山因海名。谓山因海故得高胜。海因山故得深广。前说依地。今说依海者。由彼十山依斯二处故互举也。下释法同喻。谓佛智如海依起十地高深相显故云因果相显也。是即一一山下皆有大海。一一地内皆有佛地。此是圆教中义。若余教中要十地后方到佛地。可思准之。第三大海十相明难度能度大果功德。于中先喻后合。各有总别。总中言不坏者。谓此十相同一大海不可易夺故云不坏。地法亦尔。同一佛智义分十地。不易夺故也。论云因果相顺故。十地如大海。难度能度得大菩提果故。下释别中。摄十为八。以六七为一。九十亦尔故为八也。初三可知。四护功德者。护名为舍。舍余一切差别相故。又释护同一味恒不失故。言不竭者。以六深七广水无竭故。言护世间功德者。潮不过限不枉害物。此喻九地应机说法。受水无厌能容纳百川。不令余水损坏世间。余法云地受佛法雨利益世间。余法合等如文可知。第四宝珠十事喻转尽坚固功德。于中亦先喻后合。各有总别。论中先释总中过十宝可知。以出故取者此是经中初句。谓以出海故。取以为用。放光是第九。示现是第十。超中举后故云乃至也。摄十为八者。以合六七八故。此八中初后二句约喻显法。余但释喻。初出海益物故称功德。以善观者显法也。谓初地圣智出烦恼海善观察也。二体色分明。三团圆可喜。四垢秽斯尽。五光色鲜泽。六异相庄严名为起行。三句合释可知。七放光名神力。八随王雨宝故无护惜。下显法以已善根与一切众生。同一善藏合与众生宝物也。过十圣等文并可知。影像分竟。第八佛子是菩萨下明地利益分。于中有三。初显法利益。二结通十方。三他方来证。若依论经。更有第四如来随喜。第五佛在下结说究竟。今依此经。就初中有二。一生信功德。二雨华等是供养功德。前中二。先闻益后动地。前中亦二。初总举难闻。二问答显益。答中亦二。先正显。谓举佛类法。举法难闻。二何以故下释成。以发菩提心行菩萨道者。是此法器故方说闻。是故此闻必同彼法。成益广大故也。动地是生信功德。为缘生义。释十八相等及为四种众生等。并如前初会所说。余结通证成等。皆同前诸会可知

第三大段重颂中二。先观察等明说偈意。十种所为释同前会可知。正颂中九十颂分为九。初二十九偈颂方便作满足地分。于中初七偈地总颂前九种地中善择智。次二别颂初。次二颂二地。次二颂三地。次二颂四地。次二颂五地。次二颂六地。次二颂七地。次三颂八地。次五颂九地。二欲得下二颂三昧分。三若能下十颂受位分。四住于是地下七颂大尽分。五此地下六颂释名分。六大士下七颂神通力无上有上分。七菩萨住此下八颂调柔等地果。八为得下十九颂影像分。于中初十一颂山喻。次四颂海喻。次四颂珠喻池喻及九地利益等并略不颂。九末后二颂结说无尽。十地品竟

华严经探玄记卷第十四华严经探玄记卷第十五(此尽相海品)

        魏国西寺沙门法藏述

    十明品第二十三

初释名者。谓妙用自在。委照称明。明用无限寄圆辨十。即带数释也

二来意者。一通论以下五品来意。谓前显证位成满。自下明其胜进行用。又前是位体。此辨行用。又前位内行。此位后行。又前本智证满。今辨后智大用。由斯四义是故来也。古人亦有配等觉妙觉。依此经中不辨斯义。况前法云地终心已显等觉之义。二别明此品。谓答前十自在问也。以别译菩萨本业经彼经问中名为十明故

三宗趣者。即此十明是理量二智明用自在无碍为宗。十明义略作三门。一显名者。一他心。二天眼。三宿命。四未来际。五天耳。六无畏神力。七音声。八色身。九真实。十灭定。于中灭定相应受称天眼天耳。从趣及根为名。余从境为目。此十皆是智之业用故。同名智用也。二体性同以大智为性。然通普贤性起之智。若随相分之。前八是量智。后二是理智。据实唯一无碍智。以后二明亦不碍起用故。前八亦不废即寂故。三诸门分别中有十。一下与离世间品十明相摄者。彼文约所知明了非约业用自在。唯彼第四出生不可思议净妙音声。无量世界无不普闻。方便智明。此一约用同此。余并别事。二约与十通相摄者。此中他心天眼宿命天耳如名摄彼十中四通。此中无畏神力摄第五出生不可思议自在神力示现众生智通及第七于一念中往诣不可说不可说世界智通。此中色身庄严摄彼第六一身示现不可思议世界智通及第九出生不可说不可说示现众生智通。彼中第八出生不可思议庄严具庄严一切世界智通亦入此收。彼约严依报。此约严正报。此中未来际智明亦摄彼天眼。以彼所见故。此中音声明亦摄天耳。此中末后二明摄第十不可说世界成阿耨菩提不可思议示现众生智通。余准可知。三与智论中三明相摄者有二义。一非三所摄。以彼亦为二乘所得此不尔故。二纵佛菩萨所得三明。于此十中但三摄五。亦非尽故。谓天眼摄二。谓天眼及未来际明。宿命唯一也。漏尽摄二。谓末后二也。依涅槃经亦有三明。一诸佛明谓一切智。二菩萨明谓般若波罗蜜。三无明明谓毕竟空。与此不同也。四约六通相摄者亦二义。一非六所摄。以彼亦为二乘得故。二若佛所得摄非不尽。谓于六中天眼天耳神足漏尽。此四各分二故为十也。即天眼约见现未分二。以未来生死智明亦是天眼所见故。天耳约听闻圣教及分别音声故分为二。神足约业用及色身为二。漏尽约定慧为二。第九是慧也。余二不分故。六摄十也。五通明差别者。智论第三问曰神通明有何等异。答曰直知过去宿命事是名通。知过去因缘行业是名明。复次直知死此生彼是名通。知行业因缘际会不失是名明。复次直知尽结使不知更生不生。是名漏尽通。若知漏尽更不复生是名明。六约教显异者。若小乘三乘并三明六通但分齐差别。若一乘十明十通。与前亦宽狭为异。七约所知分齐者。智论第三云。此三明二乘亦得。但有不满。谓于过去或知一世。极至八万。后不能知。未来亦尔。又不能一念顿知四谛十五心结使生住灭等相。故不同佛也。以佛知三世众生漏尽故。解云小乘但知三明知不能遍。三乘三明互遍满知。一乘十明重重遍知。因陀罗网。谓一念摄九世等。一尘内十刹。余念余尘皆亦如是。于中所有皆如实知。八约三业。分别者。十中天耳及音声境是语业净。神力及色身是身业净。余六属意业净。若据自体但是意业。以悉是智明故。九约见等分别者。十中二是见。谓天眼及未来。二是闻。谓天耳及音声。余并是智。十约建立者。三乘等中但约所知三世以立三明。今此一乘理实明用限量无尽。依则表圆。寄十以显故。唯说十不增不减

四释文中有二。初正说十明。后安住下结叹显胜。前中初举数。二辨释。三结数。释中十明即为十段。一一各二。先释后结

初善知他心明。释中二。先知此一大千界众生心。二如是等百世界下知十方无边世界众生心。前中先总。二所谓下别。三如是下结。别中知三十种心有二。初约行明心。二声闻下约报明心。前中初三性心总举也。二广狭者于善心中分差别。三恶胜者顺上不善名为恶心。反此为胜。无记顺流反此为背。二约报中。菩萨是广胜心。二乘是狭心。三乘俱背。八部顺流。三涂为恶。余皆可见

第二天眼明。释中三。先总举。二善恶下出所见境。于中善恶等是通。天龙等是别。三菩萨下显天眼能见中。无碍明净天眼者。以所知障尽是报得自在明也。下见用并见现在众生生死等也。智论六度品云。菩萨天眼有二。修得报得。以得天眼故见十方佛。得念佛三昧。是报得五通行菩萨道。问若天眼根见。根是障碍。应见障内色不得见障外色。答修得天眼。根名天眼通。通以慧为体故见障外色。若见障外色。何故声闻缘觉菩萨见有远近不同。答通慧有增微故。见有远近如磁石。不吸一切不至之处。于中如所回转者。谓是不定业有回改易等。余并可见

第三宿命明中二。先忆知自他本事。二又忆下忆过去诸佛因果等事。以是为众生出世之佛故。多约八相辨也。以此菩萨得九世眼见过去现在法故。是故所知无限量也。若不尔者。彼过去法若不落谢。非过去故。若已谢灭。则无法故。无法而见非真实故。若言但曾所经事心中有种影现前故说忆知者。此则但见己之心影不见彼法。又此曾不经事应不忆知。又亦但见现在。非是过去。何名宿住智。余文可见

第四未来际智明中亦二。先知未来众生业报之相。二知未来下知未来佛因果之相。前中先总知。二知众生业下别知。略举十对。一业报一对。二知所作善不善。三就善中。知解脱分善名出世。知非解脱分善名不出世。四就解脱分中。得位定者名定。未得者名不定。五就前不出世善中。有种姓者名正定。无种姓者名邪定。六就有漏善名有使。无漏名无使。七就无漏中。果位善报名为具足。因位不具。上七约位。知众生下三约行。八初起名摄取善恶。九造修名积。十中不积集恶未必修善。二知未来佛因果中。初唯知果用。后悉知下兼知因行。问大乘宗未来世法体用俱无。今云何知耶。答若依方便教释。此但见彼现在因种。知彼当来果相差别。非谓见彼未来法体。若一乘宗于九世中未来现在体用俱有故。今称彼如实而知。问未来未有。何名现在。答非是现在现在故。现在中无也。但是未来之现在故。未来中有也。问此有为是缘有。为是性有。若是缘有。缘今未会。若是性有。则同小乘。答若今时看缘性俱无。以是现在之未来必定不有故。若遂未来时处看。是未来之现在还如今现在。决定是缘有。是故得见也。余文可知

第五天耳明中有四。初举能闻之德。二菩萨成就下总辨所闻自在。三于东方下别显一方所闻。四如东方下类显十方所闻。初中无碍是总。谓无有碍其闻无闻碍其虑。下别显十德。一清净者离习曀故。二广大者德遍故。三具足者德满故。四不可称量者德多故。五修习者多劫修成故。六得证者证理成就故。七明净者所知障尽故。八离障者烦恼障尽故。九了达者所知明了故。十决定者所知称实故。二总辨所闻自在。于十方中有远声。欲闻无有碍令不闻。于近声欲不闻。亦无碍逼令闻。欲近不欲远。及远中欲不欲。近中亦尔。并皆自在随意故也。三别显东方。初举佛。二显法。三能闻持。就显法中有十句。初所说者总举教相。二所发者发起隐义。三所开者开显深理。四所示者示其宗本。上四是理教。五所制者制其学处。六所调者违者折伏。上二是制教。七所教化者化令起行。此一是化教。八所念者六念等法。九所分别者解释等法。十所教深妙者大乘至理法。善解等总结多门所闻法也。三如是一切下辨能闻持。于中亦十句。一总善解文义。谓味是文也。二随何大众所说之法。三随何别人而所说法。四随以何类音声说法。五随彼智力所解说法。六随何识心所变之法。七随彼所化得功德法。八随何所缘境界而所说法。九随何所依根器说法。十随于何乘而出离法。悉能下结天耳闻持。四如东下类显十方亦尔。是即天耳闻持无尽无尽也

第六神力智明有四。初标名。二显体。三若闻下明业用。四是名下结。就显体中有十二种神力。一无功用。二同理性。三能普遍。四量难知。五不待依。六应念至。七不起此。八不废用。九无穷竭。十非余坏。十一增善根。十二顺彼行。三显业用中五。初明所往处佛。二闻已下显能往彼。设敬知法是前广大等神力业用。三示现下明其自在。谓现十方不离一处。是前不转神力等业用也。四悉自下请法。了知是前长养神力等业用。五无损神力下明遍至成行。是前念至及顺行等神力业用。结名可知

第七分别言音智明中。初总知。所谓下别。于中三。先知报类言音。二善分别下知语法施设。谓饭吃等。三摩诃萨随其下明得知所由。先法说。由此菩萨遍入世界识知彼中众生性类。是故解其言音施设喻合可知

第八色身庄严智明中有三。初知无色法界。二而菩萨下巧现多色。三佛子下明无色现色之意。又初明色相无色。次无色即色。三双显其意。初中五句。一总知色性。二不生是称真性。三无种种是离异相。四离妄执。五离形显。二现多色中总别合有一百一十种色。此等并是称法界之实色。不同余教或十一色或二十五色等。三明现色意三。初总举应机。二所谓下别显益用有十种。并是前法色之胜用。益生成化。三悉能下结业用。结名可知

第九真实智明中二。初本智证理明。二不舍下后智摄化明。亦是初自内证。后外利他。亦是初证法体。后说法用。亦初即事常理。后理恒事故。不碍业用也。前中二。先正证法。略辨五十门。明远离二边不着中道相性俱泯有无双遣。依三性三无性准释可知。二菩萨知如是下结证成智离着之益。二后智业用中有十。初明照实不舍权。谓前虽照实约非安立。不着二谛。然为不舍本愿。还约安立。见于二谛。决定知法。是知世谛也。二兴云雨法。三度入善巧。谓创起名入。终极为度。四巧说深广。谓不违真法者度顺深也。五以大慈为因。巧说无尽。六于无名在名而不坏名性。性是文字则解脱相也。七观察下巧观离染。八解了下善言摄生不舍自证。九于不二下明于理事无二之法。不退事而没理。不退理而没事。亦是寂用双运故也。十具足下明无碍具德自在之相也

第十灭定智明中有六。初明所得灭定。言不退转者正明常定。未曾退失。二亦不舍下显寂而恒用。谓身在灭定不舍菩萨十种业用。一总明菩萨作事。下九皆是菩萨事故。二别显慈悲三十度行智。四大愿救生。五转正法轮。六方便调生。七敬养诸佛。八入法自在。九常见佛。十恒闻法。三悉能出生下明灭定业用。谓此灭定非直与前十种行用而不相违。亦乃由此定力出生十种殊胜行用。一总明出生。谓即定起用名能出生。定用无隔名无碍法。此悉能出生贯下诸句。二知法平等。三具足下成果法愿。四深入下智容土海。五究竟下究尽因际。六于一切下遍学所学。七一切下深悟法相。八善知下妙达缘起。九了一切下明解教义。十于一切下明权实智具。四菩萨摩诃萨下明住定劫数。五颜容下明住定威仪。六悉能成下不废行用。问此住灭定身仪不动。云何得有所作事耶。答若小乘灭定总无业用。若依初教正在灭定。虽诸转识总不现行。由前加行悲愿力故。击发第八阿赖耶识。令具威仪作诸所作。是故亦云不起灭定现诸威仪。若依终教观事则理故。在灭定而不碍事用。现诸威仪。亦名双行自在。此上二门皆心中止定而身仪作用。以此但得理事无碍故。顿教中不可说用不用。若圆教中由得二事无碍故。是故灭定跏坐则是往来说法。亦不分身而动静成就。如佛升天不起觉树等同此。准之。余义如灭定章说。下结可知。别释讫

第二菩萨摩诃萨下结叹显胜。于中三。初叹胜。一过人天。二越世间。三超二乘。四踰下地。此四形劣辨胜。五总三业。六别举定。七显智用。此三当相辨胜。八唯佛方穷。二佛子下结。三此菩萨下显业用。谓得三世佛智明。非谓是三明也。十明品竟

    十忍品第二十四

初释名中。十者圆数无尽。忍者智照观达。亦带数释

二来意有二。远答前普光十定问故来也。以忍受真理情安不动故名也。近显十明所依故次来也

三宗趣者。先宗后趣。宗有五门。一体性。此忍以智为性。若小乘忍劣属因。智胜属果。大乘不二。但忍受鉴彻约用分之。二所断障。此中寄当断微细着微细碍无明。三定位者。若渐教此十忍行通诸位。寄当十地之后等觉位中。若圆教遍通五位。寄于此说四种类者。或一。谓无生忍。或二。谓二无我忍。或三。谓三无性忍。出佛性论。或三。谓信忍顺忍无生忍。出地持论。或四。谓四种无生。如第八地论中。或五。谓地前名伏忍。初二王地名信忍。四五六地名顺忍。七八九地名无生忍。第十地及佛地名寂灭忍。此依仁王经。或六忍。谓信忍法忍修忍正忍无垢忍一切智忍。解云初三如次是地前三贤。后三如次是十地等觉妙觉可知。此依璎珞经。或苦忍等八非此所辨。或十亦如第八地经中。又十此文。或十四。依仁王经。五忍中前四各分三。谓上中下。后一唯分二。谓因果。五别释十忍。于中初三约法。后七就喻。法中初一约资粮位。次一约加行位。后一约正证位。寄相如此。若通则遍在十地可知。第二宗趣者。由学如此十忍行故。得因圆果满。故文云能得一切等也

四释文中二。长行与颂。前中三。先举数叹胜。二列名显要。三解释结叹。初中二。先总告举数。二叹胜中能得无碍忍者显自分因满。又得下明胜进果圆。由此十忍得斯因果

二列名显要中亦二。先列名。后显要。前中初音声是教。随顺是行。谓于说无生之教。信顺忍受境行为名。二顺观真理。而未契真故名顺忍。行体立名。三顺观既极证契真理名无生忍。无生是理。从境为名。又亦无生是行。当相为目。下七喻中。光统云。前之四喻喻音声忍。电化二喻喻于顺忍。虚空一喻喻无生忍。又云。幻者起无起相。焰者境无境相。梦者知无知相。响者闻无闻相。电者住无住相。化者有无有相。空者为无为相。又古人云观识如幻。观想如炎。观受如梦。观声如响。观行如电。观色如化。观总一切蕴界处等毕竟空。故如虚空也。又远公约知二谛法。谓知俗非实如幻。知俗倒有如炎。知俗从心起如梦。知声尘不实如响。知俗暂有如电。知变易无体如化。知真离相如虚空。又前六喻有为空。后一喻无为空。如金刚般若九喻。皆喻有为。又准摄论八喻。显依他。并为释疑故。摄论第五何缘如经说。于依他起自性说幻等喻。总问也。于依他起自性为除他虚妄疑故(答也)。他复云何于依他起自性有虚妄疑(别问也)由他于此有如是疑。云何实无有义而成所行境界。为除此疑说幻事喻。无性释云。虚妄疑者。于虚妄义所起诸疑。云何无义遍计度时。分明显现。似所行境。为遮此疑说幻事喻。如实无像而有幻像。所缘境界依他起性亦复如是。虽无色等所缘六处。遍计度时似有所缘。六处显现。云何无义心心法转。解云。此疑意幻法不生实见。世法不尔故非无也。论云。为除此疑说阳炎喻释。论云又如阳炎。于飘动时。实无有水而生水觉。释云可以生水觉故。即为实有水。世间亦复如是。论云何无义有爱非爱受用差别。释云炎水无有解渴受用。世法不尔故是实有。论为除此疑说所梦喻释。论又如梦中睡眠所起心心法聚。极成昧略。虽无女等种种境义。有爱非爱境界受用。觉时亦尔。释云可以梦中有见女等违顺受用即为实有。又疑云梦中受用于梦者有。觉已即无。世法不尔。凡圣俱见。释如响长幼同闻。可即为有。论云何无义种种戏论言说而转。为除此疑说谷响喻释。论又如谷响实无有声。而令听者似闻多种言说境界。种种言说语业亦尔。又疑云响是声非色。世法不尔。色亦具有。云何非有。释如电亦色。岂是实有。论无此喻。又疑云电色速灭。世法经久。岂同彼耶。释云如化亦经久。岂是实有。又疑云凡愚颠倒妄见谓有。菩萨无倒不见其有。如何亦有摄化众生。释如化所作故非实有。论云何无义有诸菩萨无颠倒心。为辨有情诸利乐事故。思受生。为除此疑说变化喻释。论又如变化。虽无有实。而能化者无有颠倒。于所化事勤作功用。菩萨亦尔。如论应知。又疑云所作如化可无有实。能作化者是化所依。应是实有。释如虚空与色为依岂是实有。是故诸法毕竟性空。佛子是为下结要。以三世佛同说此故。显其要胜也

第三何等下别释十义。一一各三。谓牒起释义结名

初中释内有十句。初一总举所闻。谓三无性理名真实法。下九显能闻入法。二闻无相真不惊。以解遍计无所有故三闻无生不怖。以解依他必无生故。四闻无性不畏。以解真如无性性故。又释于真空法闻时不惊。思时不怖。修时不畏。又闻有无所有不惊。闻空无所有不怖。闻斯二无所有不畏。并如诸本般若论释。五信解者闻慧之始。先信后解。六受持者闻慧之终。先受后持。七爱乐者思慧之始。谓爱法乐观。八顺入者思慧之终。谓思择得味故云顺入。九修习者修慧之始。谓对缘造修。十安住者修慧之终。谓行修成立。具释如瑜伽菩萨地中

第二顺忍释中四对八句。初创修止观。谓止行顺寂。观照诸法。二止观渐次。谓平等正念者止行坚固。不违诸法者观照随缘。三止观纯熟。谓随顺深入等止行深玄。清净直心等观行深玄。四止观俱行。谓即止之观名平等观。即观之止名深入具足。起信论云。行住坐卧皆应止观俱行。所谓虽念诸法自性不生。而复即念因缘和合善恶之业苦乐等报不失不坏。虽念因缘善恶业报。而亦即念性不可得。释云约法既理事混融。约行则止观双运。如是方为顺法之忍

第三无生忍释中。先标。何以下释。前中不见法生。必不待灭。缘起事故。亦不见灭。又此无生理非是断灭无。故云不灭也。又既本不生故无可灭。下释中先征有二意。一云既标无生。何故亦云无灭。二云既言无生。为但寂然无生。为亦有行愿位果等邪。下释中十句。初一句释初意可知。问若尔亦得名无灭忍不。答理亦应得。但无生必带无灭。无灭必随无生故。多从首名。信力入印经云。菩萨有五种法。即能清净。初欢喜地何等为五。一谓菩萨得住无生忍故。亦令他住。又云无生忍者。谓寂灭故。二谓菩萨得住无灭忍故。亦令他住。又言无灭忍者证无生法故。解云以此当知。亦得无灭忍也。二若不灭下释第二意。谓由不生故不灭。由此不生之不灭故无尽。是故此无尽亦在不生中。乃至庄严亦皆如是。悉在一念无生之处。无尽有二义。一理无限尽。二行无断尽。三离垢亦二义。一入理不带寂。二随事恒无念。四无坏亦二义。谓入理不坏事。随事不坏理。五不动亦二义。谓双融二谛一念不动。六寂灭地亦二。通境行故。七离欲亦二。离种现故。八无行亦二。断能所故。九大愿亦二。愿不没寂。愿能应机。十住庄严亦二。理行相严方为究竟

第四如幻忍中作六门。一总明所喻。摄论幻喻所缘六处。下离世间品喻识蕴。蜜严经喻第八识。般若论喻外器世间。此经总喻世间出世间依正染净等。楞伽中喻一切法。掌珍论直喻有为法。大品中乃至一法过涅槃我亦说言如幻如梦。故知文通为无为也。问涅槃无为何得如幻。答意在绝见故亦如幻。谓有无等见非见幻故。若见为幻亦非见幻。见幻若绝方为见幻。况有余见。是故非幻之幻方是幻法。绝见之见方是见幻。取意思之。言说难及。二别开义门。如一幻兔有其五义。一所依之巾。二幻师术法。三所见幻兔。四兔生则是死。五愚小谓有。于中巾喻所依如来藏。二幻师及术喻能起因缘。如无明等。三幻兔之相喻依他起性。四兔存则亡喻依他无性。五凡小谓有。取为人法。问术法成幻。非则是幻。若尔果法是幻。因缘非幻。答因缘亦依他。展转皆是幻。问若尔幻师亦应是幻作。答此中举所作幻以喻一切。非谓即同。若不尔喻即是法。何成喻况。十喻论引德女经。佛言从幻乐器作幻乐音。从幻无明。生幻行等。广如彼说。三有无门有三重。一于上四义各有有无。巾性有相无以为兔所隐故。二术用有体无以依巾无体故。三兔相有实无以实无而现故。四生即是无。死则是有。以无碍为一故。二由各有四句。思准可知。三四位互相对。如次交络门有四句。亦思准可知。四一异门亦三重。一巾约自位辨。如巾有二义。一住自位义。二举体成兔义。此二无二无不二故非一异等。四句可知。余三位各四句。亦准知之。二相对辨如兔。亦二义。一相差别。二体空义。此兔巾相对非一非异。略有十句。一以巾上成兔义及兔上相别义。此二合为一际故名不异。此是以本随末。就末明不异。经云。法身流转五道名为众生等。楞伽云。如来藏受苦乐。与因俱若生若灭等。二以巾上住自位义与兔上体空义。合为一际名为不异。此是以末归本。就本明不异。经云。一切众生则如也。不复更灭等。三以摄末所归之本与摄本所从之末。此二双融无碍不异。此是本末平等名为不异。以前二经文不相离故。四以所摄归本之末亦与所摄随末之本。此二相夺故名不异。此是本末双泯明不异。以真妄平等异不可得故。五下明非一。以巾上住自位义与兔上相差别义。此二本末相违相背故名非一。楞伽云。如来藏不在阿梨耶识中。是故七识有生有灭。如来藏者不生不灭此之谓也。六巾上成[少/(兔-、)]义与[少/(兔-、)]上体空义此二。本末相反相害故名非一。胜鬘经云。七识不流转。不受苦乐。非涅槃因。唯如来藏受苦乐等。七以初相背与次相害。此二义别故名非一。谓相背则各相背舍相去悬远。相害则相与敌对亲相食害。是故近远非一。以前经文不相离故。八以极相害俱泯而不泯。由极相背俱存而不存。不存不泯义为非一。此是成坏非一。以七识则空而是有故。真如则隐而是显故。九上四非一与四非异而亦非一。以义不杂故。十然亦不异以理遍通故。法无二故。是故若以不异门取诸门极相和会。若以非一门取诸门极相违害。极违而极和者是无障碍法也。三巾兔相对既尔。余二及交络诸句准之。五则入门有四门。一理事相则。谓巾兔无二故。经云色则是空空则是色等。二二理相则。谓兔头即巾。兔足亦即巾。二巾无别故名即。经云众生贤圣即如无别。三以理从事名说事相即。如兔头巾不异足巾。故说头即足。无行经云。若人欲成佛勿坏于贪欲。诸法即贪欲。知是即成佛解云应说诸法即空。何故乃云即贪欲者。以贪欲即空故。是故举贪名取贪实。文意如此。四以理融事。二事相即。如兔头无别有。即以巾为头。巾体圆融故。全头即是足。此经云一即多多即一等又此文云深入如幻于一法中解众多等。此约法性融通力也。五以缘起相由力令二事亦相即。如幻师幻术力令多则一一则多等故。贤首品云。或现须臾作百年。幻力自在悦世间等。良以幻法虚无障碍。是故得自在也。如相即既尔。相入亦然。如异体既尔同体亦然。如此门既尔余门亦然。并思准可知。六释文者。释内三。先略次广后成忍行。初中先喻。后观。缘起下法合。此依相入门以合如幻缘起可知。二菩萨下广中三。谓法喻合。初中七句。一分别刹。二解众生界。三解缘起法界。四观世间平等。五佛出世间亦如幻也。六佛入世间用常寂故云不二入也。七不失利生故云出生住持。喻中初喻上众生界。二非树下喻刹等。三非昼下喻世间。四非定下通喻所余门。五种种下结幻法体。谓种种非幻者结幻无。若干幻非种种者结若干非幻。是故幻体非是一切。但以幻故。示众色者既非物现物明物则无物之物也。合中初总。二所谓下别辨九种。以显总中一切世间可知。三菩萨下成忍行。中有二。初称法正观。二出生下明起业用。前中八。初约众生界。即是业烦恼世间。不起者不作有解。不坏者不作无解。又本来不起亦无可坏。下并准之。二约佛刹世间。三约法世间。四约三世世间。五不观菩提等。亦约法世间。六佛兴等约成坏世间。谓佛出为成。涅槃称为坏。七不住大愿等约行世间。谓不住大愿是大智行。不取清净等是大悲行。八无出无著约流转世间。谓不舍故。无出在中无著二。出生下明业。一约刹显用。而定知体真。二约众生界。三法界。四三世世间。五出生阴等明流转世间。用常寂。六度脱等明行世间用。七知一切等明法世间之用。八不着化等。九为众生故等。十说过去等并明佛兴世用。皆是理事无碍行故也

第五如炎忍中有四。初总明所喻者。无性摄论喻器世间。梁论喻所缘境。此经下文喻想蕴。此文喻一切法。二别开义。炎有五义。一平地。二阳气。三阳气与地合。似水炎现。四本来干无水。五令彼渴鹿取以为水。法中亦尔。一如来藏平地。二无明习气三习气熏动心海。起缘起似法。四此依他起本来无生。五凡小无知执为实有。又十喻论中有七义。一日光。二热风。三动尘。四在旷野。五见野马。六远见炎相想谓为水。七近则无水。初日喻结使。二尘喻诸行。三风喻邪忆念。四喻无明旷野。五喻无智慧者。谓为一相为男为女异名为炎。六若远圣法不知无我。于空法中生男女等想。七若近圣即知诸法实相等。乃至广说。三有无等句数多同前幻。准思可释。四释文内。先法。二喻。三菩萨下合。谓依本心现无有方处。于内外有无断常等处求此法。皆不可得。二观一切下忍行成中。初方便行成。二具足下证行成可知

第六如梦忍作八门。一总明所喻。无性摄论又如梦中睡眠所起心心法聚极成昧略。虽无女等种种境界义有爱非爱境界受用。觉时亦尔。梁论云。譬如梦中无有实尘亦见有爱憎受用。此依他性中亦尔。无有实尘。亦见有爱憎受用。又功德施般若论云。譬如梦中。随先见闻忆念分别。熏习住故。虽无作者种种境界分明现前。如是众生无始来有诸烦恼善不善业熏习而住。虽无有我是能作者。而现无涯生死等事。世亲无著般若论皆喻过去境。非证智所知。二开义者梦有五义。一所依。谓悟心以喻本识。二所由。谓睡盖以喻无明习气。三所现。谓依前显示梦相差别。以喻缘所起法。四此梦事不有而有。五令梦者取为实有。三辨有无者有四句。一梦是有义以是梦故。谓于梦者梦事现故。问此既是梦。何得为有。又此若是有梦者见有应非颠倒。非颠倒故是觉非梦。又觉者见梦无所有时应是颠倒。是颠倒故是梦非觉。答此既是梦。何得不有。如其不有应同非梦。竟何所说。又若无此梦者见有。则无颠倒。无颠倒故是觉非梦。又此梦有本在梦者。非谓觉处。若无觉者见无所有。而非颠倒。颠倒则无。梦者所见颠倒梦事显现。是故由彼见无方知此有。二梦是无义以是梦故。谓虚妄所见性必空故。问若梦是无应同非梦。梦义安在。答要同非梦方为是梦。以其梦处及非梦处无二相故。问若尔梦者何不于非梦处而见梦相。答梦者现今于无处见。是故此梦体不异无。若不尔者应非是梦。问梦若是无。梦者应不见有。不见有故是觉非梦。答正由梦者见有有非是有。以梦者及所见俱无所有故。是故若非梦者见有不得言无。由彼有故方知是无。问凡言梦法。相有实无。今言总无。岂不成谤。答然此有无必全摄故。非二相故。若不尔者则谤于梦。三梦是亦有亦无义。以是梦故。梦法理必具二义故。问具此二义。岂不相违。相违之法岂不谤梦。答半有半无则是相违。今此全有之无。与全无之有。二门共在而不相违。是故具有无。方乃是梦。以是梦故不相违也。四梦是非有非无义。以是梦故。二义俱融形夺双尽。故俱非也。问若此二义要相形夺。如何前说二义俱存。答要由形夺方得俱存。是故若不夺无全尽。无以为无。若不夺有全尽。无以为有。是故存亡不碍。俱泯自在方为梦法。是故经云世间犹如梦。智不得有无。此之谓也。四一异门者有二重。初中有四句。一梦是一。以是一梦故。二梦是异。以梦现种种故。三俱。以于一念现多劫等。无二而二故。四俱非。以形夺俱尽方是梦故。又梦是一。以约所依心故。二梦是异。以约睡盖所现故。三俱以约所现梦相故。四俱非。以约梦性故。融通无碍。思之可见。是故前门有无于无处为有。此中一异于一处为多。如此无碍方为梦法。是故上经云以梦自在法门教化。此之谓也。五真妄门者亦四句。一梦是真实以是梦故。如前所说具诸义故。圣智所知梦性甚深故。问夫言梦者是虚妄法。何得辄言是真实耶。答了知此是虚妄之法。不颠倒故是实也。二梦是妄。以是梦故若非虚妄不是梦故。是故亦实亦虚。非真非妄。四句无碍思之。此经云梦性寂灭此之谓也。六自在者梦境虚妄相则相入。多处现少。少处现多。皆无障碍。故上文云以梦自在法门教化。此之谓也。摄论云处梦谓经年。寤乃须臾顷。故时虽无量摄在一刹那。缘起梦法无碍自在。则入重重如帝网等。并准可知。七明观者观诸世间皆悉如梦。以为正观。问若在梦者。谓为实故不知是梦。不名见梦。若梦觉者即无梦相。复无所见。是故此梦谁能见耶。答梦者不见梦。以其是梦故。觉者不见梦。以其觉已无有物故。了知如此。是觉者故。是故梦义是觉者所知。非于梦者。由此道理梦是观境。经云菩萨受持一切法如梦此之谓也。问觉者见无而了知梦。梦者见有亦了知不。答若此觉者了知梦法。正梦时无。则名知梦。若言觉已为无。此是觉无非是梦无不名识梦。是故梦有梦无。但是梦时。非望觉时。若取觉已为无。此还是梦。不名为觉。是故梦觉前后。谓有谓无俱不识梦。思之可见。第八释文中亦三。初一句总举。二譬如下别辨。三觉悟下结义。初中一切世间者谓清净缘起之法乱识所现故云如梦。二别辨中二。初举喻。二如是下显法。又释亦得初是方便观故云解一切世间等。二是真实观故云觉悟一切世间等。前中亦二。先明梦有则非有。二明非有而现有。前中五对。一非是世出世法。二非三界上约依报。三非生死约正报。四非净秽约世出世因。五非清浊约世出世果。皆悉实非彼法而示现彼。是梦法也。二显法实观中八句。初一总显。二不坏梦者明此梦法自性非一切。不待坏故。又无可坏故。又此显非是世间不为四相之所坏故。三不可著者。解知缘起梦离无所著故。此显非是离世法故不可证也。四梦性寂灭者。明此从本来性自寂灭。显非三界喧动法故。五梦无自性者。明此无性非生非灭。显前非生非死。六受持一切等者结成观相。谓常作此解。不离心首故云受持等也。七不坏梦者不取舍梦故。显前非净秽。以非舍秽取净故。八不虚妄取者不分别故。显非净浊也。下一句结义等可知

第七如响忍中作四门。初喻相者。无性释云。又如谷响。实无有声。而令听者似闻多种言说境界。种种言说语业亦尔。梁论云。譬如实无响尘而显现可闻。言说事亦尔。实无所有而显现可闻。此经意有三义。一知一切法如响。二知佛声如响。三能以如响言音而为说法。二开义者。响亦有五义。一空谷。二有声。三声击空谷便有响应。四此响非有而有。五愚小谓有。三有无等诸句。并准前知之。四释文中有四。初知一切法如响。谓出生等显能知德。知一切等明所知。二分别下总知音声如响。三别知佛声如响。不从内等者。佛如空谷。离声不成故。非内出。机感如声。离谷不成故。非外出。两俱相依故。非内外。离声无闻故非内。离根无闻故非外。非二故俱非。由此无性缘起如响。是故恒有而非有。非有而说法故。云亦不坏法施也。四深入下明能以自如响之声而说法。亦是忍行成就起用自在。于中有十句。初称法善学。二如帝释下喻况圆音。三菩萨下明称性起用。四于无量下显业用分齐。五受持下胜进仰学。六出生下明妙音广大。七普令众生下显业用成益。八而音下显用则甚深。九知音声下辨定声语。十亦不染下明能知自在

第八如电忍中亦四。初喻相者。般若论喻现法不久住故。功德施论云。譬如电光生时则灭。心亦如是。刹那必谢。又彼论八不中譬不去义也。此经中亦三。一喻一切法速灭如电。二喻菩萨身无碍如电。三喻菩萨智了闇如电。二开义者亦有五义。初三如上速灭等也。四能现显彰。五体非远近。能照远近。三亦有有无等诸句。思之可见。四释文中三。先法次喻后合。初中二。先约遮成止行有九对。皆离三边。玄绝无寄。二所行真实下约表成观行。亦不受持正法流转者得理不证故。二喻中四。初电能照明。二譬如下转喻。如镜曜日光壁上现影。油等亦尔。同于电光故也。三电不离等明体用不相离。四电能远照等体用不则。三法合中二。初合前照现。二而其智下合照远而非远。三如种下转喻。种无根芽能生根芽。若有则不生。菩萨亦尔。无二说二。有则无二。故云无碍际也。二若菩萨下忍成德用。谓身智无碍速疾如电

第九如化忍中亦四。初喻相者。摄论喻闻思慧意业所生果似有而非实。亦喻菩萨变化身。又龙树十喻论云。如彼化人无生无老无病无死无苦无乐异于余人。以是义故空无有实。一切诸法亦皆如是。无生住灭。以是故说诸法如化。广如彼说。二开义者化有四义。一依化心。二现化事。三实无有。四现业用。十喻论云。犹如化事。虽空无实。能令众生忧苦嗔恚喜乐痴惑。诸法亦尔。虽空无实。能令众生起嗔恚等。以是故说诸法如化。三亦有融通句数。应准思辨。四释文中四。初约法辨化。二就喻明化。三合法显化。四忍成化用。初中二。先显所知。后辨能知。前中先总。所谓下别。于中初八句约染法。一业从心起。二行造修成。三妄境虚无。四倒起苦乐。五妄取情有。六世间依真有。七觉观起语言。八想起相恼。次三句明菩萨化。后二句佛化并各出因故名为化。于中无生平等者。以得无生方名不退。是故不退无体如化。问此化为喻有为法。亦通喻无为。答或唯喻有为。大品云。问若一切法如化者。云何言涅槃一法非如化。答若说一切法乃至涅槃皆如化者。新发意菩萨则惊怖。为新发意菩萨故。分别生灭者如化不生灭者不如化。或亦喻无为。如十地如化智中名法界化。或俱通。如大品。若不为新发意菩萨则明通也。但破彼实见令见实法。何定所喻。佛子下结化。世间结前八句。离世间结后五句。二决定知下显能知相。初能知。所知深广明彻。具足下显知自在无碍起行。第二约喻中四十句。初不从心起者。非从心内种子生故。余并可知。第三合法中四。初总合化行。二不着下合化行体。三而不舍下合化行用。四譬如下重喻明从无所有建立行果。佛子下结。第四佛子若菩萨下忍成化用有十句。初一忍成。余九化用。明化有九义显菩萨九种业用。于中初二句先法后喻。后七句举喻显法。准释可知

第十如虚空忍中四句同前。初喻相。佛地论喻清净法界。以离差别相故。中边等论喻圆成实性。此经及大品等喻一切法。以悉无性故。十喻论云。犹如虚空非可见法。以远观故眼光回转则见缥色。一切诸法亦复如是。空无所有。以凡夫人远无流慧弃舍实相则见彼我男女等物。而实此物竟无所有。一开义者如第八地虚空有十义。具如前辨。十喻论中有四复次释。初一约近无远有。二约性净谓染。三约无初中后。四约体实无物。广释如彼。佛地论亦十复次。如彼应知。此经中多门释如文可知。三亦有离有无等诸句。思准可知。四释文中三。初明忍解。二佛子如是菩萨下明忍行。三若菩萨下显忍德。亦可总分四。谓标释结叹。就释中二。先明所解。后显成忍。前中十句。以虚空十义喻十种法故。初一虚空无性义同法界故。二不起义喻刹从缘亦无起故。三一味义喻法性无二故。四无行义喻行即无行故。五无分限义喻法无分别故。六无异义喻佛力齐等故。七遍三际义喻入理之禅。尽三世故。八离言义喻诸法自相不可说故。九无碍义喻佛身不相障故。随感则应故。十周遍义喻法体普遍故。第二成忍中三。初总举三业忍相齐空。二别显空义类菩萨德。于中举虚空十一义显于菩萨十一种德。初一释虚空等身。二三四三句释空等忍智。初一体。后二用。于中向是因成是果。五释空等口。谓依无方所空亦海际畔。古人云。齐海水已上为虚空故。又云大海虽广空容其际故也。六七二句释空等身业。八释空等口业。九释空等心。以性净故。后二句释空等心业。三何以故下征责释成。责云何因菩萨得虚空等三业耶。释云思惟自善根如虚空。依此得三业亦如空也。于中先举十种善根皆如虚空。一分者缘起。二分中真分也。一量者同理性故。二不忘一切下十句明所得三业。初不忘等意业。二游行等明身业。三普于十方等明意业。四出生等明口业。第四叹德用中有二十句。初十得十身。后十通三业。一一各有标释。此十身与前十行品十身及离世间品十身各有相摄可知。得虚空际下通三业。皆如虚空。中初总显含藏。次二别辨口业。次三别明意业。离贪欲故者。心净故佛土净也。次三别明身业。一用二体三相。谓诸根也。后一总结深。问此七喻何别。答幻等五以似有破实有。如化以不有有破似有。末后虚空以性相俱绝破于一切。又前六遣有会空多。依空立有少。后一遣有入空少。依空立有多。问何须多喻。答令理智明净故。异门显法故。义理坚固故。长行竟

第二重颂中有一百一十九颂。长分十一段。初十颂随顺音声忍。于中初二颂前闻真实法。次一颂不惊等。次二颂信解。次二颂受持爱乐。后三颂顺入修习安住等可知。第二譬如功德人下十颂颂顺忍。初三颂初随顺寂静观等。次一颂不违诸法。次一颂随顺深入等。次二颂清净直心等。后三颂修平等观深入具足。第三从三十三天下十颂颂无生忍。初三颂前不见有法生不见有法灭。次四颂何以故下十句释成。后三颂结叹显胜。第四观察诸世间下十颂颂如幻忍。初二颂前略说。次四颂广说中喻合。后四颂忍行成立。第五菩萨摩诃萨下十颂颂如焰忍。初二颂法说。次四约喻显法。谓焰水从想生故喻之。又想故有法而实非有。如焰似水而实无水。故以为喻。后四喻法双举。显法甚深。第六彼能解世间下十五颂颂如梦忍。初二颂一切世间如梦。次一颂梦非欲界等。次一颂梦性寂灭及不着梦。次二颂不坏梦。次二颂梦无自性。次四颂受持一切法如梦。后三颂不坏梦不虚妄取梦等。第七菩萨摩诃萨下十七颂颂如响忍。初二颂知一切法如响。次三颂分别众声如呼响。次三颂解如来音不从内等。次二颂入离虚妄法界巧出无量声等。次三颂无碍音令众生发起善根等。后四颂音声非语而随顺语亦不染着等。第八寂静下七言十颂二十行颂如电忍。初二颂观意。次二颂不生世间等。次二颂不随世流不受正法等。亦颂于不二法分别二相等。次二颂不内世间等。次一颂不行菩萨行不舍大愿等。后一颂叹德成益。第九修习甚深下十颂颂如化忍。初三颂行菩萨行如化。次三颂知众生业行等及佛菩萨等皆如化。次二颂业行随世。后二颂叹德化用。第十虚空忍亦十颂。初二众生及世间如空。次二境与智如空。次二慧及法空。次二能所说空。后二三世三业空。第十一是名下七颂结叹显胜。初三二利圆。次二因果满。后二结广胜

    阿僧祇品第二十五

初释名者。心王菩萨是能问人。表数法依心。如数识等。菩萨洞达自在名王。阿僧祇是所问法。十数之初。从首为名。若具应名十大数品

二来意。非答前问何故来。前十明辨行用。十忍明行体。今显行德校量分齐。则下颂中所数德是也。又释前诸品中所有数量。谓如光觉品等中。皆有数法。今此释成故也

三宗趣者有二。一能数之数。二所数之德。前中亦二。先定所知。后显能知。前中阿僧祇此云无数。即数之极故。诸圣教中通有四说。一准俱舍论。数至六十重名一阿僧祇(捡录)。此约小乘。二依智论第九。数过十重已后名阿僧祇。论云一一名二。二二名四。三三名九。十十名百。十百名千。十千名万。千万名亿。千亿名那由他。千万那由他名频婆。千万频婆名迦他。过迦他名阿僧祇。如是数三阿僧祇。解云此既云过迦他。亦即通过后诸数故名阿僧祇。此约始教说。三依智论第六。引此品文。还有百数。至阿僧祇等。此约终教说。四依此品。百数僧祇。始是初数。如是次第以所数等能数。至第十名不可说转。不可说转转等方为数极。是故前教数极乃是此中初数。故知此门极广约圆教辨也。二显能知者亦有五重。一人中数法最下。二诸天数法过于人。天中亦不同如自在天王一念数知大千雨渧等。三小乘中舍利弗善知数法过于人天。四诸菩萨中数知亦差别。如下释天童子算沙数法。非二乘能知。亦如文殊普贤知刹尘数等。非下位所知。五佛自所知最极自在。一切余位总不能知。智论第九云。佛在祇洹外林中树下坐。有一婆罗门来问佛此林有几叶。佛答若干数。彼心生疑。谁证知者。则私却少叶还问佛。此树林定有几叶。佛答今少若干叶。如所劫语之。婆罗门知己心大敬信。求佛出家得阿罗汉果。以是故知佛能知恒河沙数。解云此约佛知恒沙之数。今此品文。唯佛所知无极之数故佛自说。又云佛智境界甚深之义故也。二所数之德亦二。谓普贤因德及佛果德。并各通因陀罗网等。具如下颂中辨

四释文者。此文有二。先问后答。问中亦二。先举取问法。后世尊云何下以法咨问。初中何故牒此十数者。是诸品列名及结通处皆有此十。然未解释。不知分齐。为显令知故今问也。十句中第二不可量。下答中名无量。第五不可数下名无数。第六第七同一句。谓不可称及不可量。不可量下答在第八。不思议在第七。余并可知

第二答中三。先叹问诫听。二心王敬顺。三举法正答。正答中二。先长行正显能数之法。二偈颂辨所数之德。前中总有百二十转。答前十问。初一百二转答初僧祇问。后十八转答后九问。前中百千百千者。谓百千个百千故云百千百千。皆以所数等于能数。不同智论皆以十亿为量。名一俱梨者新名俱胝。翻名亿。此恐不可以百千是十万十万为一亿。此即亿个亿方名俱胝。亦俱梨个俱梨方名一不变。余皆准此。其中或此土名或存梵音。皆是数名可知。于后十八中。初十七是因数。后一不可说转转为果数。以极即越数之表。同于果海越绝故也。第二颂中有一百二十二颂半分二。初七颂定能数之法。二于彼一一下总显所数之德。前中积数有十重。一初句以第十不可说不可说为本。二次一句复积入一切不可说中。此二句为总。三未知几不可说名为一切耶。次二句显不可说劫故名一切也。四次一颂辨以彼多劫所说入一尘内。五前直言不可说佛刹末为尘。未知几复不可说刹。故次一颂半辨一念中即不可说刹。如是念念复尽不可说劫。六次一颂明多刹尘内各有多劫所说不可说。七次半颂明多刹尘内各摄多众生。八次半颂以彼众生叹普贤德广。九次一颂以此广德之普贤。复有不可说个同在一毛端。同时各说如上不可说之言。十有半颂类显十方无边世界。亦同此说。此十重积集中。初六是所用数法广。后三校量显能说人广。以如是等人说如是等。数数于如下所数诸佛菩萨殊胜之德。文意如此。思之可见。第二所数德中有一。初明果德无碍因位善容二从不可称说诸如来下明果德深广因能趣入。前中亦二。先辨果法无碍。后菩萨于一毛端下明因位善容。前中亦二。先依果自在。后一一毛道出名身下明正报自在。于此中有四。初总明三业自在。二摄取下别明语业自在。三无碍心下别显身意业二自在。四净方便下明以法应机德就第二因位善容中有十。初明因陀罗网土。是起行处也。二从意根下明三业勤勇行。三从一切众生下明应器摄生行。四从应现色像下明游方供佛行。五从成就施心下明广修十度行。六从彼净法轮下明摄法游刹行。七深入众生下明调伏众生行。八从彼于一一毛端下明三业深净行。九从彼诸菩萨下明愿智自在行。十从不可称说一切劫下一颂结德无尽也。第二明果德深广因能趣入中二。亦先果后因。就初果中三。先总叹佛果德。二从若于一小下别显依报果。三从于彼一一刹中下别明正报果。第二从菩萨究竟下明因顺入中二。先自分行。二从或于一时下明胜进行。阿僧祇品竟

    寿命品第二十六

初释名者。往业所引报果名寿。任持色心不断名命。品内辨此。故以为名

二来意者有二。一远意。为答普光十顶问故。以十重相望各为终极。得名顶。故知安乐界为娑婆顶等。古释将答佛寿命问。此名字虽亦相当文势不顺。谓此寿命问在十地等前。不合答在此处十顶问在地后。更无别答之文。故知属此。二近意。前僧祇品显佛菩萨实德平等超过数量。此品别辨佛德。就机示有修短。后住处品别辨菩萨法用。约机明住处差别

三宗趣者有三义。一泛明命有三种。一报命。谓暖识不舍不退。众同分故。不相应行为性。二戒命。经中名净命。由不破戒故不失比丘法。以净戒为性。三惠命。由不放逸故不退正法名为惠命。正惠为性。二别定此文者。诸佛寿命亦有三义。一约德。谓具足如前三种命故。其报命是无尽。善根所生故也。二就实。谓命根无尽尽于未来故。三就权。谓随机所感现修短故。今此文中具斯三义。三显次第者亦有三义。一约渐教。谓娑婆等局为地前为化佛土故。安乐等通为地上为报佛土故。乃至贤首刹当十地后不可说处也。二约同教。谓娑婆等为三乘上。渐渐向细。入于一乘乃至贤首刹等方为究竟。何以故。以就别教娑婆则是莲花藏故。三约别教。娑婆是见闻解行处。中间诸土唯解行处。末后佛土通解行满及证入故。是故信满位处亦名贤首故也

四释文中。心王菩萨说者。显世识自在故。有劫数也。于中有三。初举十世界校量渐次。次类显百万。后辨最后玄极。如安乐世界等。以何为昼夜。释或以莲花开合辨用。当娑婆一劫。又释此娑婆一劫中总有若干日夜。依此日夜数。数一劫为一日夜。还数王若干劫。方为安乐世界之一劫。则以此劫量。于后诸世界。皆准此量计可知。是则至最后世界一劫。于最初世界。当不可说不可说劫也。至贤首刹已后。则刹海平等无有优劣。是故此中说普贤等充满者。以望下最极故。以普贤为量。望上犹在数中故不说。唯佛充满此诸世界。大佛名经中亦说。又玄奘法师别翻一卷名显无边佛土经。是此品也

    菩萨住处品第二十七

初释名者。菩萨大悲随方摄化应物之所名为住处。人处题名

二来意亦二。一远答普光随喜心等十句问故。二近显菩萨应机所在故也。又前品贤首刹等皆是净土菩萨充满。未知娑婆染界为有菩萨以不。今辨此界亦有无量菩萨所住故次来也

三宗趣者有二。一心住。谓智证真理悲念众生。二身住。谓实报居净土权现于染界。此由大悲就机所住。亦由大智非世所染。由此悲智无二相故则住无住处

四释文以于处识得自在故。亦心王说也。于中有三。初举八方住处。二辨四海住处。三诸国住处

初中八方唯据此界非约他方。就此界中。唯约此阎浮提。非是余洲。初仙人起山应是东海蓬莱山等。二楼阁山应是下文南海岸楼阁城侧自在海师所住处等。又勘梵本应名胜峰山。三金刚炎山应是西海边等。四香聚山应是在北香山王。是以彼山中多有菩萨住故。五清凉山则是代州。五台山是也。于中现有古清凉寺。以冬夏积雪故以为名。此山及文殊灵应等有传记三卷。具如彼说。六枝坚固山勘梵本正云制多山。此云归宗。即塔之类也。应在此国南正海边。七树提光明山应是下文观音住处光明山相连。梵名树提。此云照曜。八香风山应在香山西畔。有风穴故也。此八皆在山者表山居寂静长道之处。贤圣所住故也

第二四大海中有二住处。一枳怛者具云昵枳多。此云涌出。则海岛山之名。昙无竭此云法生。亦云法勇。二窟是海别处。准梵本应名间错庄严窟。第三毗舍离下明诸国中菩萨住处有十三所。初毗舍离是中印度。亦云吠舍离。此云广严城。即维摩所住也。此城南十四五里有塔。是七百贤圣重结集处。更南八九十里有僧伽蓝。其侧有过去四佛坐及经行遗迹之处。具西域记第七说。二巴连弗者具言波吒唎补怛啰。其波吒唎。此是黄花之名。即母之号也。补怛啰此云子也。儿也。即上代黄花女之子。创于此居故以为名。亦是中天摩竭国也。具如西域记第八说。三摩偷罗者正云秣[少/兔]罗。此云孔雀。或云密。并是古世因事为名。是中印度。此国中有舍利弗等塔及文殊师利塔。于王城东五六里有山寺。是乌波鞠多所造寺。北岩间有石室。是鞠多度人安筹所也。又东有大林。中有过去四佛经行之迹。亦有舍利弗等千二百五十人修定之所。具在西域记第四说。又准梵本。此处是窟名也。四俱陈那者。俱陈是姓也。那是法律也。昔有五通仙人名拘持。此云大盆。谓大池形似大盆此仙在彼修仙。因立斯号。彼仙于此广说法律。谓护净经行养性等法。令人修学。相系不绝。众人同姓拘陈那也。五清净彼岸国应是南印度。牟真此云解脱。是龙名也。邻陀此云处。即解脱龙所住处。六风地者有风孔处名无碍。是龙王所造窟也。七甘菩国者。正云剑蒲。是北印度。此国多出美女。故以为名也。最上慈者。大集经中名慈窟也。八真旦者或云震旦。或曰支那。是此汉国名也。那罗延山此云坚牢山。则青州界有东牢山。应是也。彼现有古佛圣迹。九边夷国者准梵语似当疏勒国。今但润州江南有牛头山。彼中现有佛窟寺也则北印度境。传云有四辟支佛影。时时出现。又此润州古时亦有蛮居此处。现蛮王陵故。亦名边夷也。十罽宾者正云迦湿弥罗。此云阿谁入。此国旧是大池。因末田底于佛灭后。降彼池龙乞容膝处。池龙既许与罗汉通力。以广其身。得多地处。遂得造国及僧伽蓝。如佛所记。于中现有佛牙寺及五百罗汉造毗婆娑处。如西域记第三说。郁提尸山此云远闻山。谓多处远人皆闻故。即此国四周之山处也。十一难提拔檀那者。难提此云喜跋檀那此云增长。即南印度梯罗浮诃者此云上座。即尊者之名。以居此窟故。因以为目。文殊问经体毗里部。此云上座部。同此名也。十二庵浮梨摩国者正云庵罗。此云无垢。是果名也。以此果能疗众病垢故云无垢。彼国多出此果故。名浮梨摩也。正治耶曲。托此为号。十三乾陀罗国者正云建驮。此云香。陀罗此云遍。谓遍此国处。香草先发故。以为名。寂静窟。相传是佛留影之窟。具如西城记及大集经月藏第十卷中说。上来明此阎浮菩萨住处。余四天下准之。余须弥世界及树形等世界。并准之无尽无尽也

    佛不思议法品第二十八

初释名者。如来果之法。迥超言虑故以为名

二来意有三。一远者。此下三品为通答普光佛无上地等句问故。问若远答前问。何故此更有请耶。释以相去远故。更发起也。若尔前诸品何不尔耶。释以前诸品同是因位。今辨果法隔位故也。又释此是念法悕说。非是别请。若尔何为前诸品无此例耶。释为果法深细。显法器殷至故。须念。说因法反此故非例也。二次来意者。为前已辨修生因满。今此正显酬因果圆故。次三品来也。三近来意者。前住处品是因满之终。此品是果成之首故次来也

三宗趣者。此中正明佛果德法。略作四门。一通辨佛德。二别显义相。三辨定此文。四显不思议。初中若说一百四十不共法等通小乘及初教等。若辨净法界及四智为德即通始终渐教。若以一味实德则唯顿教。如光觉等品说。若具一切无尽之德。如此文等是一乘圆教。二别显义相者。诸佛功德无过二种。谓修生本有。此二相对总有四句。一唯修生。谓信等善根本无今有故。二唯本有。谓真如恒沙性功德故。三本有修生。谓如来藏待彼了因本隐今显故。四修生本有。谓无分别智等内契真如。冥然一相故。此有四义而无四事。犹如金庄严具。若称取斤两。本有如金。若严具相状工匠修生。若由成严具方显金德。则修生之本有。若严具揽金成无别自体。则本有之修生。是知唯金而不碍严具故。唯一法身不碍报化也。唯严具而不碍金故。单报化亦即具法身也。余并准之。是故得说化身即法身等。全体收尽。余准思之。三辨定此文者。然上四义摄有二门。一约佛自德。圆融无碍不可说也。二就机出现复有二门。一分相门。谓化身为化地前现染土等。报身为地上现于净土。此约三乘差别机说。二无碍门。谓报化不分。即权恒实。如树王下现十佛身。丈六遍于十方。八相该于法界。诸根毛孔各无限量。亦不碍限量。是则限无限无碍。此约一乘圆机说。摄有四重。如此品说。一略举十门。如品初所问。二次辨三十二门。如答中大位。三具显有三百二十门。如答中别辨。四广明多门。如类十方一一皆各无尽无尽也。四显不思议义者。泛论有四。一理妙难测。二事广难知。三行深超世。四果用超情。今此品文通具前四。别辨第四辨第四中复开为四。一何者不思议。略辨十种。一智超世表。二悲越常情。三无思成事。四同染恒净。五所作秘密。六业用广大。七多少即入。八分圆自在。九依正无碍。十理事一味。并如文显。恐繁不列。二于何不思议亦有四位。一过世间故。二越二乘故。三超因位故。四显法自体故。三云何不思议亦四种。谓非闻思修及报生智境故。四何用不思议亦四种。谓令信向故。起行求故。随分证故。圆满得故

第四释文者。此下三品果法亦有诸德。将配三身。谓初法次报后化。文恐不顺。以此品中广显八相等用。岂唯法身乎。亦有将配佛体相用。后二品可然。初品有妨。以此品中亦有相用。今谓此品总显佛德体用殊胜。次相海品别显胜德之相。后小相品别辨胜德益用

就此初品中分文有四　一请分　二加分　三证分　四说分

初分中二。先明能请人。众同念者表法深细故也。二正显所念十法。此言不思者显果德法出过言虑。念此不思悕其说也。初一问佛出处。二问出现之因。谓由本愿。梵本云过去愿清净。三问出生处种族家。此释依梵名非是因中佛种性等。四总明应机现世。次三别显三轮业用。八问大用之体。九问大用之相。十问大用自在

第二加分中。先知法器。二与青莲等者正显加相。表果不自彰寔由因显。故加青莲令其说也。十句中。初五与胜德充身。于中初三句与佛三业。显同化辨等。神力是身业。智是意业。辩是语业。后二句与佛福智无畏是智。后五与智用充心。一究竟等与佛内知法界无余智。二与佛作用境界智。三与佛无碍行智。谓无思成事等。四分别等与佛知法器智。五不可数等与佛多门善巧智。令其能说。何故无身语加。以不入定故。何故唯意加。令入法界故。此菩萨岂不证法界耶。释彼证分限。非甚深故。非无碍故也

第三证分中。初五自利。一总谓佛果法界无障碍故。佛加令得故云入也。下文云一切诸佛所说皆入甚深法界。余四别显。一深行。二广愿。此二自分。即是普贤法界行愿。今既入此故得成也。三顺果。四现果。谓以佛果自严故也。后五利他德。一总悲覆众生要令离垢故。令成净行故。令得净信故云清净也。余四别显。一量智。二理智。三总持。四辩说。何故不云入三昧。古释此则是入定。又古释果法已深。更入定显恐退信解故不入定。复为法深故。审入法界。今更释此得加力。入于胜进佛果法界。令能说故

第四说分中。告莲花藏者。显深奥胜器。又表含摄果法当有开敷故名也。果德无限。略以三百二十门以答前问。于中初十门标宗略答。后三百一十随义广显。前中初句所住净妙答前刹问。二住无量自在答二净愿种姓二问。以此俱是佛出所依故云自在。三应机出现名不失时。则答前佛出问。四法轮。五四辩答音声问。六不思议法答神力无碍住及解脱三问也。七净音重显前音声分齐也。八分别法界答前智慧问。九光明照答身业问也。十亦显语业所说至深也。又释此十总明如来应机成事。一明显佛自住真理。二明不滞寂故云自在。三非但内不滞寂。亦外应不差。四应机不失作何等事。谓转法轮。五以何转。谓四辩。六说何法。谓不思法。七能转齐何。谓无所不至。前辨说无穷尽。一切时也。此明音声遍一切处也。八所转之法为几许耶。谓无量法界前不思法显深也此中无量明广也。九语用既尔。身用云何。谓光明普照。谓息苦报灭恶业。警群机今入法等。十言教则同理故云入法界。又说法就机令悉证真故云入法界。无有究竟不入深法故。末后结归也

第二随义广答中三百一十句。大门有三十一位。依古诸德属答前问。依问次第文极不顺。今更超次科配。少有相当。终自难见。良以佛德无限自在非言能次。就中长分为十

初四门答前第一佛刹问　二从十种出生住持智慧下三门答第二净愿问　三从十种功德离恶清净下二门答第三种姓问　四从于一切世界一切时有十种佛事下三门超答第七佛智慧问　五从十种无量说佛法门下三门答第六佛音声问　六从十种无碍住下三门超答第九佛无碍住问　七从具足十种不思议法已成正觉下六门却答第四佛出世问　八从十种最胜力下一门答第八佛神力问　九从十种定法下三门却答第五佛法身问　十从十种一切智住下三门答第十佛解脱问。且粗作此配。通相圆融并准可知

就初四中。初十辨佛六根依正。明胜德之体。二普于诸刹应机出生。明依处起用。三明用应机化不失时。四业用广大出过图度。并于刹现。此举正显依。以答初问也。一一门中各有三。谓标门别列及总结。初中色身等名法界者。一多故名法界。二广故名法界。三妙故名法界。以十八界中法界摄故。四从所依。以证法界成故。五从义相。谓妙轨称法。分齐各别名界。六约当相。即同真性故名法界。此色身为总。是余入所依故。次六可知。第八无碍解脱是自在业用。如下文。于一尘内现三世佛等。第九严土应机。第十因圆果满。第二出生无尽智者。前以相从性同名法界。今以用从体同名为智。又亦前则相依性现。今用从智起。无尽有三义。一时无尽谓念念等。二处无尽谓一切世界等。三用无尽谓命终出生等。初五可知。第六明所成利益第七严身应机谓黑象脚等。第八异异严应以机感不同故第九清净众生者。谓调伏众生令离障。上九别辨。第十现三世佛。为种种根等总结多门益物故也。第三未曾失时者。所作合宜。药病相应。初一机感现成而不差失。二宿愿善根现报不差。三根熟与记令增善根。又记当得果。时无改易。四于耶归依众生等应示神力。五于念佛众生等应现佛身。六化成益讫舍而不失。七入城行乞为施食时至。八见佛生喜受化时至。九暂舍难化令生恋仰。十随机逆顺自在难思。亦是总结也。第四世无比况云不可喻。情不能虑名不可思。此显业用自在超过情况。初四可知。五不离本等者如不起觉树升天等。六决定一法等者。以一法即一切而不坏一法故云决定也。七于一念等者如意神力能速普遍。八示现果德。九现三世佛。十教化众生常在灭定。以用而恒寂故。上来答初问竟

第二大段出生住持智慧下三门答前第二净愿问。初十皆依本智出生后智。教化众生故名出生住持智。又释理实无差别而智照此反起知差别智。谓住理而持事故云出生住持。亦住事而持理故皆云智。若不尔者住事迷理。是愚非智。初中先举理实故无趣向。后显随事故出生净愿。此正答前问。标之在首。第三中。无二者无能觉所觉。而生等者。巧出能所不乖无二。下乖无二而出生二。余并准之。第二内法者蕴德。在心名为内法。亦是内心所证之法。一内身无垢。能顺入三世。二内具三轮。一身业神通轮。二语业正教轮。三意业记心轮。三内有总持持法智。四内具四辩说法智。五内有无缘大慈悲。六内证理观机。七内有善根。并是巧便堪调众生。八内有法界。是所证也。住者是智能证也。无碍住者能所平等无障碍故。九内现多佛。十内照多劫本来是一日。非新相即。第三甚深大法者。业用无涯名为大法。无思称理名曰甚深。又过小云大。超因曰深。初二力用大。次二摄化大。次四三业不空大。次二依正自在大。末后一正觉大。此剩一句。增数十也。上来答净愿竟

第三大段离恶清净下二门答第三种性问。初十过无不尽故云离恶净。后十德无不圆故云究竟净。皆是种姓清净。无可讥嫌故也。初十中。初一宿因净。二现果净。谓三世如来家生。正答种姓问。标之在首故也三未来净。四三世净。以皆无著故。五一味净。六多德净。次二身语净。九名称净。十应念净。第二究竟净者亦是毕竟无染。初三愿行净舍离优婆提者。有释此是优婆夷。离此女想故也。有释此翻名闇钝。明佛久舍故云清净。又翻名戏论。佛已舍故。次四依正家眷净。后三现智业用净。亦是法身般若解脱三德净。上来答种姓问竟

第四大段于一切世界下有三门。超答第七佛智慧问。于中初十明智用照机。次十明智体宏深。后十明智德无断。初十者谓时处广大顿赴成益故云也。又一切世界者遍也。一切时者常也。谓相续无绝。摄论云。如恒受乐。如恒施食等。初二现身说法。次二增行定位。言正法位者初地已上也。次二应机游刹。次二悲化摄物。后二体用利生。第二无尽智海者。前应用常遍。此即智海宏深故云无尽。一智同理深。二福同智广。三所见悬远。四善根难量。五行同法性。六法雨漫流。七赞德无尽。八行愿广大。九常用无竭。十知心行海。十一福智无尽剩一句也。第三常法者。此之十法是诸如来常所有故。常所行故。初二成行离过。次二大悲大力。次二说法度生。次二应化现身。次二存殁无念。答智慧问竟

第五大段从十种说佛法门下三门答前第五佛音声问。于中初十言声说法。次十余事说法。后十举因结果。就初说法门者显所说之法门。初三说众生当位法门。一如来藏是界也。二善恶不动是行也。三苦乐等是业所得报也。次二化众生门。一无量方便度众生者。谓贪欲多等教不净观等。二净众生行者授与戒学等。次二化菩萨门。一行。二愿。次二说染净欣厌门。初说染果成败令厌。后说净令欣。末后说三世佛兴令往供养门。第二常为众生作佛事者。以此十法开觉众生入法成益。名为佛事。作无停息故云常也。初二身语作。次二受不受作佛事。谓受令成檀。不受令放学少欲。次二以四大神力作佛事。次二名号刹土作佛事。后二佛刹海默住而作佛事。乃至一切法悉堪为佛事常作不息。第三坚固士法者。若能行此十坚固法名坚固士法。一愿坚。二行坚。三教化坚。四大悲坚。五大心坚。六背世向出坚。七背小向大坚。八照法净心坚。九厌大救生坚。十代苦摄生坚。上来答佛音声问竟

第六大段从十种无障碍住下三门超答第九佛无碍住问。于中初十正显所住无碍。次十明于具德无碍。后十辨彼自在无碍。初中身智所安物莫能碍名无碍住。初五身于世界无障碍住。后五智于所知无碍住。于中初二证理说法住。谓住三世法界。是证绝三际之真性也。次二下化上同住。谓下于众生知根巧化。上于佛法惠身安住。后二分别染净住剩一句。第二最胜者已超下位故。无上者上无加过故。庄严胜德自严故。十中各先释庄严义。后结其名。初三明三业严。第二语业中。八音等明声体具德。演说等明声用善说。悉令等益物不虚。三意业中。先明意摄众德。于一念等显意用无涯。四光明庄严中。初光体一一等明因业。普照等示现业。除灭等止业降伏业。现佛等敬业。五笑光中。初显普照义。悉授记等显离痴。谓成益不虚故。六出缠法身离染为严。七常光严中。以诸余光皆此中出故名为藏。八妙色有六句。初一总。余五别。皆超绝世表名为妙也。九种姓严者此是生家种姓。亦是真如家生也。十大慈等严中。言无上受者者。受施田中。佛最无上故名也。第三自在正法者于法自在无障碍故。初二于教法自在。先说教后应根。次二于世界自在。先动后严。次二时处自在。先时后处。亦是住寿自在。遍至自在。七正觉自在中有二释。一随文释。谓一切佛各为调化自所化故。各各示成正觉故云念念。非是一佛。既各示成。非先不觉今乃始觉故云非不先觉等。此是现化身用。二就义释。一佛即遍一切众生。周十方微尘。尽三世。念念同时。前后俱成正觉。此即实成非化。但以不成即已。成即旧来成故云非不先觉等。以摄三世尽故。无过去不成故云不住学地等。此可准宗思之。八诸根互用自在。若小乘但变化用。渐教大乘即改转用。圆教一乘亦不变不改。一入旧来作一切用。九毛孔置众生。依法性融通门思之。此是众生世间自在。十一念现正觉。此是智正觉器世间自在。于中先于一念现一等法界佛。二于彼念中类显多佛。三举一念类显多念。四举一花座类显虚空法界等世界。各现等法界之佛身。思之当知。佛境界不可思议在于此也。上来答无碍住竟

第七具足十种不思议法已成等正觉下六门却答第四佛出世问。于中初揽缘现觉。二无中巧现。三所现难量。四果位齐均五智住妙境。六知法无遗。各提门可见。初中十内。初二果相具。谓先外相备。后内德圆。次二因德满。谓先福后行。次二应机现。谓无坏胜法是降魔功德。次二严刹具智。次二相圆德备。后一事毕示终。第二巧妙方便者。谓证理平等能起有中殊胜之行故云巧也。初一知法无究竟者证理也。而究竟说等是巧便也。若处理无乖此事有。或说事有乖彼理无。皆非巧便。若二义岳别。或合一双失俱非巧便。今并反此。故名巧妙方便。以是释佛出世之义故。就方便向事说也。二证无能见所见而巧见法界。三无相知相。无性现色。四证泯三际之理。而见三世佛宛然。五三业无造。而演法炽然。六理亡染净。而不坏世间及佛智用。七以依非时法而融时相入。又恒住非时而应时说法。八以所证非时不离时。具足十辩说无尽法。九证法无名。巧起名句。十无蕴界处而不坏法相。又善达二空巧分三聚等。第三有十种佛事无量等者。谓果现难量皆摄物入道。同名佛事。业用广大并是微细相容门故非余境也。初兜率天作摄生佛事中。初别举能摄。总显所摄。二大慈下总显能摄。别明所摄利益。并如文显。二从兜率天降神母胎作佛事中有四。先智德内圆。二于最后等辨其位处。三或以神力等正显业用有十。如文。于中或从初发心者摄过去故。或涅槃者摄未来故。是故入胎之时无非具于八相。亦摄过去因行。如下法界品摩耶处说。四此第二地下正明具摄八相时方等。而作事。三在于王宫受欲境时摄化佛事。于中初自行内圆。二大悲下四等善观。三广能为说下正显摄益。四虽处王宫下明摄益深广。谓一切处为广。净三业为深。四出家时摄益中有四。初为引贪爱众生令得净行。二示现世间舍离下引愚痴众生令得智慧。三示现众生无上下引薄福众生令具福智。四广为众生下授与正法之相。五成道时摄益中有三。初现自正觉。二庄严一切下摄内眷属。三令一切众生下广益众生。谓先令行成德满。悉分别下令广大智立。六转法轮时摄益中有十种法轮。一教坚不退。二轮多遍知。三所说决定。四成益不虚。五轮体广大。六轮境甚深。七轮用下照。八轮能上现。九轮性平等。十总结无尽。一乘十转无尽法轮应着此文。七入王城等时摄益中。初入城益物。二一切诸佛色身下明能以色相威仪等益。三彼诸众生下显所益之相。四以如是下总结无尽。八或住阿练若下明随所住等摄益之义。于中四。初所住摄益。二以境界摄益。三以所说摄益。四以所住时摄益。九以无尽功德藏摄益。于中有三。初明化所成益入菩萨位。二或现涅槃下显能化方便。三或发众生下化入佛境位。十示涅槃时摄益中三。先示灭恋慕益。二碎身舍利益。三爪牙发起塔。谓令成因得果。念恩叹德。第四法王无异法者明果位齐均。一记莂无异。二遂愿皆同。三法身不殊。四智慧齐等。五所知佛同(有本作法字)六所知刹同。以果无优劣故。七语同法言。八无非化物。九染净同泯。十善根同如。然余处说四种等故说毗婆尸即是释迦。此中十种无异。亦是平等意趣可知。第五向十种住法者。谓佛向此十种法上之所住故。初一佛住。二梵住。三依宿愿。四住现悲。五无功用。六离妄情。七念无暂失。八心无限碍。九无不在定。十住真实际。第六知十种悉无余者。大智无限照境无遗。初三即三达圆明。次三知世间众生。谓多类众生言音路别名语言道。次二知出世。谓菩萨及佛。后三知法门。初总知缘起。二别知事相。三以理会事。如帝网重重。并如前地论中已释。上来答佛出世问竟

第八大段十种最胜力下答第八佛神力问。于中有一百门。谓初列十门。是总标。下十门别释。一一总门具十别门。及一一别门摄十总门故成百门。何以知者。以标中云十种最胜力大力无量力乃至佛所住法。为一句标故知。十种之言贯下九力。各有十也。后何等为十之言。通征前十力各十之义。但以义同故。亦通以十门通释前十。是故结中各唯结初。以此十种皆是大力那罗延等也。以大力为总。余九摄在大力中。故有十种大力。初力用过劣名最胜力。二当体广能名为大力。三多门业用。四大福胜用。五威德特尊。如外道见佛违自先制不觉起礼等。六所作不屈。七能坏魔军。八不为他所坏。九业用超世表也。十举世无能破。言大力那罗延幢等者结归初总。那罗延者此云坚牢。即帝释力士之名。举近为况。佛所住之力下别释中。初一身命无损力。此释最胜大力。佛所加持众生。及佛所使众生如上。金刚雨等悉不能损。如遣耆婆。入火抱儿。如莲池等。二毛孔容持力。此释无量力。如虚空者。能广容故。无疲倦故。三毛持围山速步力。此释大功德力。如来一身毛孔与十方法界一切众生所有毛孔头数齐等者。显毛孔既多。各持如上。金刚围山明所擎重也。一步等行步大也。念念等所行疾也。十方虚空界等所至远也。尽过去等行时长也。无羸弊等与不行无异也。四定用自在力此释尊重力。于中初身不起定。化不失时。二指持生界不起遍坐。五普遍常转法轮力。此释不退转力。于中二。初以一佛身周遍法界常转法轮。二如来一化身下明一切身常转法轮。前中先一一等是多说也。尽尘数劫等是常说也。转正法轮等说益也。后中一一毛端处念念化等显佛身多重重普遍无碍常说。问若据此文。佛无不说之时。何故乃至一部奉行。答此是众生感处说为一部而如来说法曾未暂息。以大机常感无间断故。问若遍空界毛端处悉有说法。何故此处现今不闻。答以根无熟故。犹如生盲不见日。非谓无日出世间等。亦聋故不闻。非谓无说。若尔说应不遍众生界耶。释以遍故至不闻处能令不闻。至闻处令闻。至有限闻处无限闻处。皆如彼现故名为遍。是故今者不闻亦是佛说法也。六胸德字相降魔力。此释坚固力。七音声遍彻力。此释不可坏力。八证理现事无碍力。此释一切世间不能思议力。于中初证理玄绝。后随智慧转下现事自在。九法身微密力。此释一切众生不能坏力。于中初平等法普现无碍。二其身充满等下应现无方称性平等。十具菩萨行佛大智力。此释末后大力。结同之力。于中初具菩萨行顺佛果用。二住诸佛住下明胜智圆满德。三以明净智下照达无边境界德

第九大段十种定法下三门却答第五法身问。于中初门明身业揩定。次门明见已获益。后门显劝观胜德。初中化身八相诸佛等有故云定法。略无涅槃相。此中正显身业作用。如文。第二见佛得十果报者明所作不虚。于中初二灭恶生善报。次二善因乐果报。次二除疑不退报。谓入在地前三贤位。次二证位净根报。从初地至七地。以证地故名出世。有出观故名世间。后二灭障得辩报。谓八地已上。第三有十种净法。菩萨应念者。念因仿学。念果增善于中初六念因行。后四念果德。可知。上来答法身竟

第十大段从十种一切智住下三门答第十无碍解脱问。于中初门明后智业用。次门显妙定自在。后门正明解脱无碍。以此解脱依定慧成故。初中智能迅疾。广知名为智住。初二知所化器。次二成能化事。次二现佛及神力。次二说法及知趣。后二应念现形。第二有十种无量不思三昧者。在此法定于彼法用。又此定即用。故难思议。于中初二约人法。次二约时处。次二约佛三业。普遍法界而说一切处有现不现等。次二约理事法。九定在离世而恒现世严。十定在众生而恒至佛趣。第三有十种无碍解脱者。碍障既尽名为无碍。作用自在名为解脱。若三乘教中说佛有八解脱等。非此所收。此十门无尽是一乘解脱。应准知之。初二现佛说法。次二调生现土。次一调已授记。次三现三世佛依正神力。后二现于三世能化所化。此等约法。是法性融通力。约智。是如来自在力。良以此智达彼法故。无碍圆融故。能如是。此约果圆满说。若菩萨分得如维摩不思议解脱。皆此类也。不思议法品竟

    如来相海品第二十九

初释名。言如来者标人显德。相海者依人显相。福报奇状炳著名相相德广多奥积如海。勘梵本名如来十身相海品。以深广之相在十身故

二来意者。若约远此与前品同。答普光会中后佛果德问。若约近即前品总明果法。此品别显相德故来也

三宗趣者。正辨佛果无边相海。即以为宗。别释此义略作八门。一释名者。智论第五问相义云何答。易知故名相。如水异火。以相故知。解云显著义明了义标别义是相义。二体性者。此三十二相小乘俱以色形为体。若初教大乘依瑜伽于二十二根中四根为体。一眼根。二舌根。三男根。四身根。若依终教依对法论以定慧为体。又摄相归本唯是净识为体。又会缘归实唯是真如为性。若圆教相海以无尽法界为性。三种类者。依观佛三昧经有三类。一略中略说有三十二相。二略说有八万四千相。三广说有无量相。如杂花经中为普贤贤首等说。解云杂花即花严异名。此品中十莲花藏世界尘数相名无量也。此三中初唯小乘。次兼前为三乘。后具前为一乘。又初唯地前见。次唯地上见。后通五位见。又初唯化身相。次唯报身相。后是十身相。四出因者。略明七种。一依智论此三十二相俱以布施为因。彼论中一一约施别别释出。二依瑜伽地持俱以持戒为因。三有经中用忍辱为因。四善生经以大悲为因。彼经云是三十二相即是大悲之果报。五楞伽经及如来藏经。并如来藏中恒沙功德具三十二相。则以藏性为因。六依涅槃经以十善为因。七依大集经第七三十二相一一各别出因。余经云云。解云良以佛果万德圆融故。或一行通感多相。或万行俱成一相。或性待了因而唯说行。或行证理。成唯约性具。五积成者。智论第五云。一一相皆为百福所成。其百福者或以一转轮圣王福为一。如是数至百。或以一帝释福为一。或以一他化天王福为一。或云除补处菩萨。余一切众生福为一。或云同感一三千大千世界福为一。或云如大千世界一切众生皆盲。一人治差。一切人被毒药。一人治差。一切人应死。一人救脱。一切人破戒破见一人教净戒正见。如是等为一福数至百等。或云福德不可量不可譬喻等为一。乃至百。解云彼约小乘及初教等说。若准此相海无尽福所成。上文云求空边际犹可得。佛一毛孔无涯限。是则若大若小皆满法界。悉无限量。六修时者。三十二相若小乘及初教三僧祇后百劫中修相好别业。若或极迟百劫。或超九劫等。如智论第五说也。若终教已去。从初发心修因满果。便现或是修生或是修显。若一乘相海无量劫修。七建立者。智论第五云。问菩萨相何故三十二不多不少。答有言以端正不乱故。若少则不端正。若多身相乱。又观佛三昧经佛生世间示同人。故说三十二相。为胜诸天故说八十种好。为诸菩萨说八万四千相。以菩萨修八万四千诸度行故。上约三乘等说。若一乘此十莲花藏尘数相。为普贤等说者。以修普贤无尽行海故。八明业用者。一乘业用如小相品说。余乘相用如别说

四释文者明佛相海旷周法界故普贤说也。文中三。初诫听许说。二略说九十四相。三广结十莲花藏尘数。就第二略说中。大相有九十四种。明相所依有十九处。然一一相中皆有四义。一列相名。二显相体庄严。三明相光业用。四辨业用成益。亦有不具者。至文应知。最初明顶上相。最后明足相者。依观佛经有顺观逆观。从顶渐下。明顺观。从足渐上。明逆观。今显顺观故也

初顶有三十二种相。何故此中略明十九处相。多少不同者。释此皆无尽。但随说少多多少无在。问既各无在。何故顶相最多答以最胜故。故善生经云。一切世间所有福德不及如来一毛功德。如来一切毛功德不及一好功德。聚合八十种好功德。不及一相功德。一切相功德不如一白毫相功德。白毫相功德复不及无见顶相功德。顶相中初七正明顶相。后二十五别显庄严。初中名明净者。勘梵本。名毗卢遮那者。具翻名光明遍照庄严也。二三十二宝以为庄严者。正显相体具德。释名中。净字即是庄严义也。三普放等辨放光业用。此释明字。则光明义。四遍照等明业用成益之相。则释遍照义也。此之一门亦总亦别。以标三十二相故是总。则三十二中是初门故亦别。二中圆满下明相体具德。三金刚下显光业用。起此光明于彼世界故云所起。此释名佛方便海也。四普照法界者显业用成益。证理法界故。照事法界故。三中初穷事遍理。充果该因故名充满法界。云者周遍义。润益义。无本义。无碍义。现相义。降雨义。是云义。下并准此。四中名普照者有二义。一相中现难思佛刹名普照。二照现法界佛光名普照。五中摩尼宝王下明第二相体具德。释名中琉璃宝也。三普照下辨相光业用。释名中普照也。叹佛等略出往因。四悉放下正显成益。释名中大自在云义也。六中初名体合举。二放诸光明下业益齐明。谓以平等普照法界。等以教声法灯。令菩萨功德在佛离垢智宝幢海。七中伊那下显相体具德。伊那罗此云主。则天主宝等。并可贵义等具六种义。是故名宝。自在义等。是故称王。悉是佛果无障碍德。此释佛光。三普照下明业益。释广云义可知。自下有二十五种庄严顶相。于中初内琉璃摩尼下明业用及益。释成圆满光明之义可知。二中先名体同举。二无量世界下显业用。释光明云。三出生无量下明成益相。说深大法。释菩萨行藏。三中放琉璃色等明第三业用。明身光声智释普照云也。四中于一切下明业益。有开觉除障。释觉云义。五中业用内长养智身者。释体中心海王也。长法身者释如意法宝。令彼满足如来相海。六中初宝花严刹。后四行严人。或四摄。或四无量等亦得。初相严事法界。后行严理法界故名一切庄严也。七明佛于三昧念念现佛。令机得见。用此为相。八从佛无障碍意业中所出依正一切化用故名化海。九于其座内现诸佛像。名为解脱。光明演法严刹称云。十内业用中正法光云严净一切者。开觉菩萨令因种姓增修正行故名严净。则释觉佛种姓。余亦同此。十一过去福智如轮显现故以为名。十二顶宝花中尽穷法界。诸佛依正皆于中现故名普照自在云。十三中普照一切等名入一切也。十四名明净者。若具亦名遍照庄严。体用中具释此名可知。十五以法轮光明开觉一切故以为名。十六能现菩萨道场成佛名一切庄严。十七现众生业报名法界因。但现因必带果故亦有报。十八以法轮普被一切世界名普照。庄严令深解法界故云净法轮云也。十九中标释可知。二十巧入众生等位照现法界名净灯云。二十一智照无量诸三宝海名分别法界。令一切众生等明分别所为可知。二十二相光凝住遍空法界。普现诸佛菩萨功德。令观无厌足。二十三中于眉间出宝光等者。古人将此下三相属眉间相收令以次后二相并是顶相。末后一种复是眉相。此之一相或是交错。或亦用此庄严顶相属顶收。以光明普照成胜益故名宝光炎云也。二十四顶上次第起诸庄严。谓严现佛身严现佛刹严现菩萨故名一切法界庄严云。二十五如来顶相悉能等。总结中先粗结前三十二种宝相庄严。后细结庄严一切法界。智论第五顶有骨髻如卷等在其头上。观佛三昧经如合卷相也。上来三十二门明顶相竟

第二大段明眉相中有一相。释中二。先释普照法界。后出生下释遍光明云。智论白毛眉间生不高不下。白净右旋舒长五尺

第三眼相亦一释中。初所见无碍故名自在。后眼光现佛亦名自在云。智论真眼相如好青莲花。又如牛王眼睫长好不乱

第四鼻一相可知

第五舌有四相。初明广长相中。先举名体及因。次普照等显其业用。后出生等明其益相。二中释舌掌相。谓于舌掌内以众宝为严故云安住。此明胜德备也。安住一切法者。明一切所说法门。并在舌掌之内安住。此明大智具也。是故舌掌名法界地也。三明舌端相。于中出生无量下明用益。谓光照佛海名顺法界。又妙音遍至亦名顺法。又令众生乐闻。顺入法界。故立此名。四亦舌端相中。出生下明用益中。一妙音等赞。二妙德等覆。三妙智等入。四妙刹等现故名平等法门。智论舌相覆面至发际入口亦不满

第六龂相德体中。一胜德外严。伊陀尼罗此云帝青宝也。二法界内充。三大众悉满以佛龂齶中既诸法界地悉在其内。是故诸菩萨云亦悉充满在其龂内。出生下明其用益。于中所照十方还在龂内。以诸法界非唯现故。是故但此龂中则摄法界尽。头背手足亦在其中。十方世界及诸众生菩萨诸佛悉唯在此中。余门如虚空无所有。然龂相不大。法界不小。全在其内。外相宛然。空界无边不出龂外。是谓如来胜相。非是心识思量境界。此一既尔余并例然

第七大牙相有四。谓四大牙。初右边下牙。众宝庄严者明体具德也。放大光等明业用广大也。普放光等显利益之相。此是所照佛身。复放光益。二右边上牙用中一一光内现佛依正故名为藏。三左边下牙用中。照现一切佛及眷属故名灯云。四左边上牙于中出生下明业用。谓因此大牙出大妙音现佛因果法等。智论牙白胜雪山王

第八齿有一相。梵言金慕耆婆一齿间不容一毫者。此云颈旋螺文。则佛齿形状也。放大光下明业用利益。智论齿有四十。不多不少。齐密无粗。细人不知者

第九肩相有五。初右肩相名为一切宝地者。从体德为名。光炎普照等明用益可知。二右肩平满相普照明业用。三左肩相中普放等明业用内现尽法界诸佛神力。四左肩遍照相用中。放光现法界佛依正等报。五右肩无动相中。出生下明业用照理事人法因果法界。智论肩圆好相一切治肩无如是者也

第十胸相有一。言胸有胜妙相海者此是德字之相。能破怨敌周遍下明业用利益

第十一胁相有一。于中出生下明用益也。此是两胁同辨。智论云。两腋下平满相不高不深

第十二腹藏相有七。初相中菩萨功德下明体具德。普现下明业用利益。释成普现如来云义。二中一标名。二如来下释花义。三放香炎下释开敷义。三中妙乐充心名可悦等。此是世人五藏中心藏。何故不说余肺等藏。以佛金刚身无余藏故。何故唯有心藏。以最胜故。令他有观见故。放摩尼等明用益。四胜德深广圆满故名胜海释相可知。五光照法界名为电光。下第二胜功德平等地相者。或是五藏中当第二等。或身分中句下第二等。既无别指的。是故难定。下文第三等准此。六照现无量菩萨法界故以为名。七照现最净法界及极果依正三世间相故名照最高云

第十三明下部相有二。初是妙音转法轮相。离垢清净者不同余人之秽故。正法道者非是秽路故。香炎等。明业用照现佛内心及所证法界故。二宣畅佛因智严刹故名庄严

第十四手相有十二种。初手掌相中。放大光等明用益。转法轮照佛海。严法界也。二宝手相中。体具众德名海。用光瞩物名照。三妙手相中。以常青琉璃宝用严其手名普庄严。亦名微妙之手。普照一切下明业用利益。四离垢灯照手相。亦是网缦手相用中导引菩萨令到彼岸。五现宝手相。谓宝莲花光照法界故以为名。六照明手相用中。宝光照法界香光严刹海。七琉璃灯手相中。体具琉璃之德。光用灯照之云。八智灯手相中。金光普照则为智灯也。九莲花手相中。体具宝花名曰莲花光。覆世界故安住。十满法界手相用中。初光照现如来及充法界。后如来妙手下明手具德及用满刹海。智论正立手摩膝。十一右手指相用中。宝花妙音严现刹海故名成就等。十二指端出宝相。以能照佛宝藏法界故名安住一切宝。从德为名。放大光等明用益。初照现三宝海。后出生下明出声遍觉增长愿行

第十五马藏相有三种。初隐密相用中。照法界者证理深也。照虚空界者照事广也。宝严法界者行严真性出生妙果也。二一相现一切相海用中释显此名。复照现余一切佛神力。三法界海相中。体能照现十方诸佛及法轮海。用能示现自尘数相。此上是十身相。若化身相者智论马阴藏相。佛令弟子见阴藏相者为决疑故。又有言化作马宝象宝示诸弟子。我阴藏相亦如是

第十六髀相有二。初右髀相名普照示现云者。众宝现严故。妙法光现故。出声宝严故。念念示心海故。二左髀相名普照一切回向海云者。用中放光。普照一切众生。令趣向佛海故以为名

第十七[跳-兆+專]相有二。初右[跳-兆+專]相。伊尼延者此是鹿名。以[跳-兆+專]似佛故以为喻。智论第五云。如伊尼延鹿王[跳-兆+專]相。随次佣纤也。用益中初光照震动。次佛音普闻。次化身充满。次身光净刹。后化满法界。文并可见。二左[跳-兆+專]相用中。光遍无量开化法海

第十八毛端相有一。初毛内现刹。是标名也。于一毛孔悉放等显德也。一毛孔示现等明胜用也。智论中一一孔一毛出相毛不乱。青琉璃色毛右靡向上

第十九足相有十三相。初金刚足下相名菩萨海庄严者。用中释显。谓光照开菩萨法故。出化菩萨故。光住菩萨海故。以为名。智论足下安平相。足下一切着地。间无所受。不容一针也。二足趺上相名明净云者。众宝庄严者体摄众德。智论足趺上真金色于上毛青琉璃色其足严好如杂宝履种种庄严也。放妙下明用益。释名可知。三足指间相名觉云者。用中初示觉相。次照所觉法。次现觉法。次现觉处。后照觉用时。未来未有。若为照。以依九世。如彼现故。智论足指网缦。纤长端直。次第佣好。指节参差。指爪如净赤铜。四千辐轮相名照法界海者。用中初严照刹海。次严照佛海。后照净法界海故以为名。智论千辐辋毂三事具足。自然成就不待人工。诸天工师虽毗首羯摩天不能化作。五足相名示现一切诸佛云者。用中初发行云声教云花严云。示现世界故以为名。六足相名自在光明云者。示现佛光明故云自在常放等。显业用可知。七足下后分者是足跟相也。普照下明用中。初照法界现化身普覆。后一一身出音声海。充满法界故以为名。智论跟广平相。八足底相名深宝原底者。体具宝严。用穷深底。如文可知。九中初一切宝等名体合举。后于念念下益用俱陈可知。十名普云藏者。体具普云光明照藏。十一名平等光云者。出生下明业用中。音声称法界故云平等。次一一相下光称法界故云平等光也。十二名示现庄严云。初体具德严。次用严佛刹。次佛云满刹。次严因法海。后照因果法。同严法界故以为名。十三名诸佛自在普示现云者。放不思下明业用中。先现佛光自在。后显佛声自在云可知。上来总十九处略明九十四种大相竟

佛子下大段第三广结大相者。以别说难尽。是故总结。非略能尽。故须显广。然一个莲花藏界已遍法界。况复说十。复显无尽。是则无尽无尽非普眼而不睹也。相海品竟

花严经探玄记卷第十五

          乙巳岁分司大藏都监开板花严经探玄记卷第十六(此尽性起品)

        魏国西寺沙门法藏述

    佛小相光明功德品第三十

初释名佛者。标人表德。小相者形大辨体。光明者依体起用。功德者用所成益。此则依人显德。体用为名

二来意者。前品大相各有光明。皆照法界而未显所照利益之相故。今此品正明益事。为大相难明故辨小相。小相复多。但论一相。一相有多时之益。且说一时。此一时益复难明故佛自说也。以此而论。前大相业用无边无边。极难知耳。又依前大相流出形好故次来也

三宗趣者。宗明如来相德利用。略作二门。一定分齐者。既三十二相有八十随好以严。则知十莲花藏微尘数相一一各有尘数等好。又此大相既一一深广与三十二中诸相不同。则知随好亦甚深广大不可量也。二辨业用者。如八十随好但严形佛生净信。今此明小相。佛为菩萨时相轮随好最下位处用。谓放一光照十世界尘数刹。地狱众生皆得生天。成就十地十眼耳等。即此天子毛孔香普熏众生。亦得十地白净轮王。又此轮王放光复令无量众生复得十地十眼等。如是展转尽于未来傍无边际。皆不可说。菩萨小相既尔。如来大相之海。利用自在不可说不可说也

四释文中二。先略。后广。前中亦二。先明果用摄益。后又菩萨下明因用摄益。前中何故佛自说者。古人释云。前僧祇品明因究竟。此品明果究竟。故但佛说。又释明相极至小。用极广大。此事难明故佛自说。告宝手者能采取故。海王随形好者是足下相轮处。大相边。随好之小相也。以余大相业用难明故说最下相轮之用。又以相轮大相犹难明故说随好。随好犹多故说海王一好。此是果用犹亦难明故。说在兜率为菩萨时之摄益。就此因用二。初令离苦生天成安乐行。二生天上已以下令不着天乐成饶益行。亦是前身光益。后是空声益。前中令净十眼等者。以彼众生宿有见闻普贤法种。复遇舍那法界光触故得十眼普贤之益。二天上益中初示声名不可乐者不令着乐故。下正说法有四因缘得生天上。初不放逸者厌恶对治。二宿植胜善。三曾遇善友。四今佛加持由此生天。示此因果不应放逸

第二广辨中亦二。先广前光救恶道。后广前声益天处

前中亦二。先明放光。后明照益。前中普照王光是相轮大相中光。于彼者于彼大相处有此海王随好小相。一名清净者简去多光。今但说一。普照下明照益中。随众生境界者所住差别亦是所观不同。随善根者随其宿种何乘善根。随意者意乐差别。亦是欲愿不同。皆称根成益。越于余益故云乃至阿毗等。以此下文但说彼照地狱生兜率天一益故越余也。第二广天上饶益中有六。初因劝释疑。二汝等应当下正劝报恩。三时诸天子闻是音声下依劝兴供。四是故诸天子下教发心悔过。五说是法时下闻教获益。六尔时诸天子于一一毛孔下明得益传通成无尽行

初中三。先劝次疑后释。初中善哉者叹其所得明有重恩。次显舍那所住。劝不忘恩故令敬念。二尔时诸天子下正生疑怪。何由者由何也。谓从何因由出此音声。三尔时音声下释疑显法。于中亦三。初总次别后结。总释云此声是善根功德所成。亦无来处。二诸天子如我下别释中有六门。一空声无我喻。喻佛离二我。复疑云若实无我谁来成佛。二释天声无从来喻。喻佛胜果无来处。复疑云佛果证理可无来。凡愚苦报应有体。三犹如汝等下苦报无本喻。喻善起天声亦无方处。复疑云胜报劣报可俱无体。佛果大用岂不有耶。四如普照王下明果用无作喻。喻天声是定慧所起无作成益。复疑云若尔何故现有所益天报。五譬如须弥下明天乐无来喻。喻天声应无方面。复疑云少益可无来。多用应有倦。六诸天子譬如下明天声广益无疲喻。以此天声则称性故。常无所有故。所益众生亦如是故。是故无疲。于不可化众生不生厌恶。于难受化众生不生疲倦。于易心化众生不生放逸。于已化竟众生不生憍慢。此上六种是喻况。亦即是法说。末后结辨。舍那者以是初门总劝故。离垢三昧有二位。一约因终。如第十法云地菩萨所得。离自二障微细垢故。二约果初。如此文是。将现成佛在此天上。住此三昧能利众生令离垢故。二乘不能知者结用深广故也

第二大段从汝等应当下明依前正劝。于中分四。初明报恩大益。劝其修行。于中有法喻合结四文可知。二诸天子其有众生下明背有损。劝其舍离。三诸天子汝昔下明昔受重恩。今应长善。四譬如下示以正法劝令修学。亦是示天乐空令究竟不着。于中初举无我有用喻。喻天报依正似有实无义。五欲具等依报五蕴等明正报。以缘起无作即有常空故不生灭也。若如是下结成破执之定

第三大段时诸天子闻是音声下明依劝兴供中二。先随相事供养亦二。初兴供天宫不见菩萨。遂生无见。后观见阎浮将欲往供。复生有见。二时天妙音下示平等慧。于中有四。谓法喻合结。不命终者令离无见。不生彼间者令离有见。以体实普遍。非眼所见而能起用。化不失时。舍离等结离执也

第四大段是故诸天子下正教发心悔过法。于中二。初举法总教。二问答别示。初中先教发心者。以是众行本故。佛正因故。正法器故。次教住三业净戒。威仪是身语戒。意净是意业戒。次教忏四障。业报约因果分二。烦恼及见约利钝分二。以增上耶见能断善根故别分出也。后以法界等教忏悔方便。此是普贤广大忏悔甚深忏悔故称法界也。二时诸天子下问答别示中。先问后答。问意云。既以如是三业为忆念四障对佛忏耶为若为耶。答意但观罪空非直障灭。亦乃即此成于大行故。以此门教令忏也。答中先显答起所由。谓外缘内因二力。次正答中有十。初推障无体但由倒起。经云一切业障海皆从妄想生。此之谓也。二天声随说无我喻。喻业所作虽有因果而求不得。经云若欲求除灭端坐观实相。此之谓也。前中总说因果名随业报行。别随三学故云随戒等。喜是慧也。三少福不闻受化者。闻喻喻业不作不受作已定受。四声非生灭喻。喻业感报故不灭缘成故不生。又释业性即不生灭而不失业报。五天声无尽喻。喻业若不忏灭受报无尽。又释业即空无可尽也。六天声不堕边见喻。喻业性离断常。七天声随应喻。喻业作善恶即有苦乐报应。八镜舍万像喻。喻业影现本识而实无来去。九幻师眩目喻。喻业体本性空似有诳凡夫。十若如是知下结成真忏悔

第五大段说是法时下明闻法获益。于中有四。一余兜率天子得忍益。或当初地或是八地。二六欲天子发心益。三天女益。此二地前益。四尔时下益当机天子。以是普贤五位相摄大善巧法。是故创得出地狱已闻此普法。即得十地。明与三乘渐次教不同也。于中初得位益。二成行益。三胜报益。四灭障益。五见佛益。六结益分齐。谓虽得十地因满。简不同果故云犹未能见等也

第六大段尔时诸天子于一一毛孔下明展转通成无尽行。于中有二。先于毛孔出法界供具供养于佛。二显供具所成利益。于中有三。先花益广见诸佛故。二香益广灭惑障故。三盖益广成大行故。就香益中。一法二喻三合四结。又释此四中。初二闻香得乐。次一灭障。后一成善。前中身心快乐者定香熏故也。灭障中于五尘内外各五百烦恼者。四分律中虽有五百结总数。亦无别列名。既不见经论。古来诸德皆作解释。有一师释云。众生烦恼根本有十使然。一惑力复各有十。即为一百。计应分为九品。但上品重故开为三品。中下轻故各为一品。合为五品。即为五百。于内外境起合为一千。此是根本使然。以自五尘为内。以他五尘为外。一一各千即为五千。别迷四谛即成二万。并本一千即有二万一千。依三毒等分故有八万四千。又有释云。以十恶为本。展转相成。一一各十故成一百。迷自五尘为五百。迷他五尘为五百。合为一千。正迷十谛法门。谓四谛三谛二谛一实谛。或迷说诚谛等十谛。或迷十善故成一万。然迷十谛空有不同。分成二万。或迷十善二谛亦是二万。并本一千总二万一千。依三毒等分故。有八万四千诸尘劳门也。若依贤劫经别有八万四千。如上九地释。此诸烦恼皆悉除灭者。现种使习一切皆尽。以普灭非别故。何位灭者通五位故。云何灭者如虚空故。本来尽故。三见盖利益中三。初明见此法门之盖故。得一恒沙轮王善根。皆如白净宝网等。此是世界性中万子已去轮王。如爱见善慧王等。非是金轮千子王四洲等。谓一恒沙个白净宝网轮王善根。暂见此盖。顿得成就。二菩萨摩诃萨下明得此王位所化利益。于中初所化广多有法喻合。二放曼陀罗下明所益殊胜。亦有法喻合。遇光得十地者此中有三重益。初明佛光普照。诸天子令得十地。二此天子毛孔所出香花盖等。复益众生令得轮王。亦是十地。三轮王放光照余众生。亦令得十地。此之三位皆悉齐等同时顿成。各尘数多类。以此却推。总是如来一小相中一光明力。一光既尔。余光亦然。一小相既尔。余小相亦然。小相既尔。其余大相海等即不可说不可说也。文意如此。思之。言此等众生悉先修善者。明宿有见闻一乘修普贤善根。故喻中如在欲界已得初禅。身虽未转得彼天乐。如是众生遇此光明顿得十地。身犹未转。令本身肉眼而得普见。是法力故也。是即三祇可以念届者明一摄一切也。尘劫不穷一位者明一切摄一也。如是迟速无碍自在。是此圆教非余宗也。三如是成就清净下释显所得利益之相。既言即此身上得十眼等。未知分齐故。今于十眼中肉眼最粗。释其分齐。余眼深妙。可以类知。于中二。先明见世界广大。后亦于念念下见佛广多。前中四。初明一重广大。于中并取下尘点尽处已来刹并本尘。总合为一广大之刹。二问答辨难。三佛告宝手下重积数显。谓以如上一广大刹复数至此千亿等。复末为尘。此一一尘各与一切佛刹之尘数等。菩萨取此诸尘经八十反。种一一生得一切佛刹微尘等果。四菩萨下结肉眼见。谓如此数量。如此广大。是此肉眼所知所见分齐境界。明知此眼深广无边。智论云。五眼中肉眼但见三千大千世界内事。若见大千界外即何用天眼为。解云彼约三乘渐次教说故不同也。二亦于念念下明见佛身。如锭光珠照瞩广大复明净故。下辨珠分齐。亦非余位所见故。结属轮王。如是广大肉眼是第三重益者。通释向上轮及天子皆有十眼等。准释可知。小相光明品竟

    普贤菩萨行品第三十一

初释名者。先辨义名。就第二修因契果生解分中有二。上来明修生因果竟。自下二品明修显因果。亦是上明差别因果。下显平等因果。若就五周因果中。此是第三明自体因果。二品名者德周法界曰普。用顺成善称贤。摄德表人名为菩萨。对缘造修目之为行。普贤之行。普贤则行可知

二来意亦二。先分来。谓会前差别因果令归平等。即会前从第二会至菩萨住处品来差别因。归此普贤圆因故。性起品会不思议品来三品差别果归平等性故。是故来也。又释上来差别明三乘因果。此下明一乘因果。明与上三乘为所依故也。又推前差别至此本位故来也。又前明修生此明修显故也。二品来者。前品明前位修果。此品辨后位了因。义次第故是故来也

三宗趣者有二。先宗后趣。宗明普贤行略有十种。一达时劫。二知世界。三识根器。四了因果。五洞理性。六鉴事相。七常在定。八恒起悲。九现神通。十常寂灭。此上十种各有十门。如时劫中。一陀罗尼门。一念中有多劫等。二相即门。三世即一念等。三微细门。多在一中现等。四帝网门。重重显现等。五不思解脱门。随智自在现修短等。六一身普遍门。身遍即入三世劫等。七一身普摄门。三世劫海在一毛孔等。八现因门。遍前后际常行菩萨大行愿等。九现果门。普于三世现成正觉等。十现法门。普于劫海云雨说法等。前五意业自在。后五身语自在。如约时劫有此十门。余九亦各十。准之即略辨百门普贤行。余义具如文显。第二趣者。明此普行意在对显性起果用。问此与性起何别。答有三别。一此约因彼就果。二此是能发彼为所发。三此通修生彼唯性起。余如性起品说

四释文者。就后二品中。先此品明普贤圆因。后品显性起满果。就此品中分二。谓长行与颂。就长行中亦二。谓正说及瑞证。就正说中亦二。初序说所因。后正显所说。又释亦可为三。初举略显广。释成普义。二从菩萨起一嗔下举恶显善。亦是举刚显柔。释成贤义。三从佛子是故下辨六十行门。释成行义。是故名普贤行也。就初中二。先总标小说。二何以下释小所因。前中如向说等者释有二义。一约近如前小相品所说。令诸天子成普贤行。是微小说。以随所化愚痴众生惑业障重堕恶道者。显小相用故尔也。若约障轻智慧众生。辨大相业用即广大不可说不可说也。二约远即五周因果中如前第二周。是微小说。以前五位渐次因三德差别果。虽诸门内亦有普贤圆融之义不同三乘。然其门相阶降同彼三乘。逐机就病不尽法源名微小说。此下二品明普贤因果。逐于法性。不就染机以分阶降。名广大说。文意如此。就释中先征后释。释中先总释。一切如来者。谓如此随病就机小说。三世诸佛皆悉同尔故也。二别释中。所随众生惑染虽多略显十种。一无明。二诸缠。三计我所。四着我见。五四倒。六耶见。七横计。八欲缚。上备苦因。九具足苦果。十远离出道。三为如是下结。既为如此具缚众生。如来出世说法。岂能具尽法性。第二明普贤行中先明所治广大有百千障。后显能治广大有六十行。前中三。谓标释结。标中虽诸烦恼皆悉遍障一切圣道。然嗔一种亲障菩萨大悲摄物。是故偏举于嗔以例余惑。又释以嗔障最重故偏说之。决定毗尼经中菩萨宁起百千贪心不起一嗔以违害大悲莫过此故。菩萨善戒经亦同此说。释中言百千等是总举。何等下别辨百门。于中寄位分五。初障十信行。二不乐佛法下明障十住行。三菩萨清净诸根下障十行。四诽谤佛法下障十回向大愿行。五不乐菩萨共住下障十地真证行。菩萨万行不过五位。起一嗔心一切顿障。又以所障法界如帝网重重令能障同所亦皆无尽故。起一嗔成百千障。理实无尽。结中有结有释可知。第二辨释普贤能治行中。先正显后结劝。初中有六位。皆依前起后。初中佛子是故者。是前一嗔成于百千邪法障故。劝令修习十种正法。用以翻之。然此十法非直翻前耶嗔。亦乃疾得菩提故也。正辨中十句摄为五对。初二约人。一不舍下。二不慢上。次二约法。一不谤教。二不迷事。次二约心行。一乐行。二坚心。次二约因果。一果智。二因辩。后二约悲愿。一悲。二愿。第二清净中。初依前正法明行成离染故云清净。十中亦为五对。初三于教法净。一信二求三护。次二于理法净。一广二甚深。次二于化法净。一了器二增善。次二于时劫净。一不着二观察。后一结成性。第三正智者由离染障令智明净故云正智此十亦为五对。初二了所化智。次二知化法智。次二知持辩智。次二具身语智。后二照依正智。第四巧随顺入者。以得正智能回转所知互相顺入故也。此十亦为五对。初二身土无碍。次二时法无碍。次三根境无碍。诸入是境也。又释智入所知也。非根是真理。又亦是境。次二言相无碍。后一三世无碍。第五直心者以回转自在令正趣真实故云直心。此十亦为五对。初二念机设教次。二住深广法。次二住教义法。次二住行法。后二住果法。并正心趣向故名直心。起信论云。直心者正念真如法故。第六巧方便者依前正直起此巧便。初三依证起说。一照深理。二出胜智亦是显理性。三巧设言。次二证真达俗分别别相。是俗谛法也。后五入法自在。于中前四入法。谓一入理法。二入果法。三入行法。谓行巧便能一入一切。四入教法。谓多门善巧故也。后一于上所入自在不转故。第二佛子是故下结劝。初劝听受。何以下释显要胜。以普贤行必一摄一切故。是故以少功力疾得菩提。此方便者是功用也。正说竟

第二感证中二。先感瑞。后证成。此二各二。谓此土结通。初感中三。初所因谓佛力法力。二动地。三雨供。问此会在他化天说。何因结通乃云如此四天下佛坐道场耶。答以菩提树下本故结归彼也。又虽升天以不离觉树故。若尔何故前十地等皆不同此。答前约同教。通结天宫及彼觉树。本末合说。此就别教。会末归本。唯据道场意存于此。下性起品等皆同此释。二证成中亦三。初所由。二力同前。二来人数量。三作如是言下赞述证成及结通等。并可知

第二偈颂中二。先序意。后正颂。前中二。初示相。谓自他二力是所因也。观十方是设教分齐也。观法界是显义理深广也。二欲明下述意。谓为欲述此十种意故说此偈颂。一明因行。二显果德。三说大愿。四行起时处。五机熟现佛。六称根授法。七所说利益。八修因得果。九果现净身。十语业开觉。此十种义。下偈颂中并具显之。正颂中有一百二十一颂分二。初二十二颂显说之分齐。余九十九颂正辨普贤行相。此等并不是重颂前文但与前绮共显普贤行用。谓前略此广。前体此用故。亦有诸德。将配前长行。文无相当故。知意异。不可抑度。就前中四初二颂诫听许说。二一切诸劫下八颂明此菩萨于过去佛弘誓愿行。三于一贤劫下十一颂明于现未佛修三轮行。于中初七举现未佛。后四于成三轮净行。四行者下一颂结说分齐。自下第二正显普贤行相中亦二。初有六十九颂明自德大智行。二度无量众生下三十颂明外化大悲行。前中明普贤十种大智行。一初七颂明善入帝网大智行。二深入微细下十七颂明深入时处微细智行(云云)。三世界及如来下五颂明了三世佛心秘要行。谓世界名及佛名。此等最粗犹于多劫说不能尽。况佛心中所知境界。谓真妙法界等。然此菩萨亦能了知成普贤大智行。四如是未来世下四颂了未来摄化业行。五现在十方下四颂通达现在佛境界行。六菩萨具出下五颂明六根化用行。七深入智境下十颂明器世间自在行。八菩萨知诸法下六颂明智正觉世间自在行。九清净法身下五颂明非身不身法身行。十譬如工幻下六颂明非量不量净心行。上来自德智行竟。就第二外化大悲行中亦十行。初六颂化物令发菩提行。二如来净身下二颂赞叹现佛摄生行。三有一颂分布过佛舍利行。四有一颂能知未来佛德行。五如是三世下四颂明法轮深入行。六无量无边心下五颂了物心器染净行。七一切众生下三颂了物业报缘起行。八如是诸根下五颂了达根境无碍行。九有一颂了知五种说法行。十末后二颂明三世相是自在行

    宝王如来性起品第三十二

初释名者。宝王是摩尼宝珠。最可珍贵故名宝也。以能出宝自在故。宝中最胜故。众宝所依故。故名王也。喻性起法亦具三义。谓出智义。最胜义。所依义。佛性论如来藏品云。从自性住来至来至得果故名如来。不改名性。显用称起。即如来之性起。又真理名如名性。显用名起名来。即如来为性起。此等从人法及法用题品目。又别翻一本名如来秘密藏经。又一本名如来兴显经。又此下文具有十名。并可知

二来意者。前品明能发之因。今辨所显之果故次来也

三宗趣者。明性起法门。即以为宗。分别此义略作十门。一分相门。二依持门。三融摄门。四性德门。五定义门。六染净。七因果。八通局。九分齐。十建立

初分相者。性有三种。谓理行果。起亦有三谓理性得了因显现名起。二行性由待闻熏资发生果名起。三果性起者。谓此果性更无别体。即彼理行兼具修生至果位时。合为果性。应机化用名之为起。是故三位各性各起故云性起。今此文中正辨后一兼辨前二也

二依持门者。一行证理成。即以理为性。行成为起。此约菩萨位。以凡位有性而无起故。二证圆成果。即理行为性。果成为起。此约佛自德。三理行圆成之果为性。赴感应机之用为起。是即理行彻至果用故起。唯性起也

三融摄门者。既行依理起。即行虚性实。虚尽实现。起唯性起。乃至果用唯是真性之用。如金作镮等。镮虚金实。唯是金起思之可见

四性德门者。以理性即行性。是故起唯理性起。此与前门何别者。前约以理夺行说。今约理本具行说。问理是无为。行是有为。理显为法身。行满为报身。法报不同为无为异。云何理性即行耶。答以如来藏中具足恒沙性功德故。起信论中。不空真如有大智慧光明义遍照法界义等。涅槃云。佛性者名第一义空。第一义空名为智慧。解云此即无为性中具有有为功德法故。如来藏经模中像等。及宝性论真如为种性等皆是此义。是故藉修引至成位名为果性。果性赴感名为性起

五定义门者。问。下文云非少因缘成等正觉。此乃是缘起。何故唯言性起耶。释云有四义。一以果海自体当不可说不可说性。机感具缘。约缘明起。起已违缘而顺自性。是故废缘但名性起。二性体不可说。若说即名起。今就缘说起。起无余起。还以性为起。故名性起不名缘起。三起虽揽缘缘必无性。无性之理显于缘处。是故就显但名性起。如从无住本立一切法等。四若此所起似彼缘相。即属缘起。今明所起唯据净用。顺证真性故属性起

六染净门者。问一切诸法皆依性立。何故下文性起之法。唯约净法不取染耶。答染净等法虽同依真。但违顺异故。染属无明。净归性起。问染非性起。应离于真。答以违真故不得离真。以违真故不属真用。如人颠倒带靴为帽。倒即是靴故不离靴。首带为帽。非靴所用。当知此中道理亦尔。以染不离真体故说众生即如等也。以不顺真用故非此性起摄。若约留惑有净用。亦入性起收。问众生及烦恼皆是性起不。答皆是。何以故。是所救故。所断故。所知故。是故一切无非性起

七因果门者。问菩萨善根亦顺性而起。何故下文唯辨佛果。答以未圆故不辨耳。若约为性起因义及眷属义皆性起摄。如下文药树王生牙时一切树同生等。若从此义。初发菩提心已去皆性起摄。唯除凡小。以二处不生牙故。若据为缘令彼生善。亦性起摄。如日照生盲等

八通局门者。问此性起唯据佛果。何故下文菩萨自知身中有性起菩提。一切众生心中亦尔。答若三乘教众生心中但有因性无果用相。此圆教中卢舍那果法该众生界。是故众生身中亦有果相。若不尔者则但是性而无起义。非此品说。文意不尔。以明性起唯果法故。但以果中具三世间。是故众生亦此所摄。问既局佛果。何故下文通一切法。答若三乘教真如之性通情非情。开觉佛性唯局有情故。涅槃云非佛性者谓草木等。若圆教中佛性及性起皆通依正。如下文辨。是故成佛具三世间。国土身等皆是佛身。是故局唯佛果。通遍非情

九分齐门者。既此真性融遍一切故。彼所起亦具一切。分圆无际。是故分处皆悉圆满。无不皆具无尽法界。是故遍一切时一切处一切法等。如因陀罗网无不具足

十建立门者。问法门无涯。何故下文唯辨十种。答显无尽故。何等为十。一总辨多缘以成正觉。二正觉身。三语业。四智。五境。六行。七菩提。八转法轮。九入涅槃。十见闻恭敬供养得益。此十略收佛果业用故不增减。此十义通前九位。皆具准之。余义下文当现

四释文者。此品长分为七。一加分。二本分。三请分。四说分。五显名受持分。六表瑞证成分。七偈颂总摄分。就初分中有二。先毫光加请主。二口光加说主。前中亦二。初光加。后加益。前中有十。初明出处。眉间者表证道离二边故。白毫者表性起。是诸教之本故。二显光名。明如来法者欲表说佛性起法故。三因业。四舒业。五敬业。六觉业。七止业。八降伏业。九示现业。十卷业。入妙德顶者正明加相。何故加此菩萨者如名表说性起法故。入顶是加持之相故。二尔时下辨加益。于中二。先大众益。初心喜等成法器益。二念法益。二妙德益中。以光入顶三业改仪。以成请相初身仪袒跪。二意无异念。三语偈赞请。赞请中十偈分六。初一叹佛申礼。二有五颂叹佛放光。三有一颂叹前光益。四有一。颂叹众有堪闻之德。五有一颂叹佛有开示之德。六末后一颂请佛示说主。何故不请佛乃求余说主。以光入身时已令知觉非佛自说。又同上多例。知非佛说故别求说主也。二口光加说主中。前既请示故。今示之亦二。先加后益。加中亦十。初明出处。口放光者表教道传通也。二光名无碍者表辩才无碍故。言教自在故。无畏者不惧理深故。处众无畏故。余义同前。入普贤口者令说如佛说故。又是口传故。又若出口入耳为令闻也。今出口入口为令说也。何故唯加普贤。表此所说是普法故等是加相。何不入顶。以兼教故。又涅槃经中。佛自口放光还入自口。表收灭故。彼经云如来光明出已还入。非无因缘。必于十方所作已办。将是最后涅槃之相与此别也。二尔时下明加益中。过百倍超过同类以表法胜。恐滥同佛故对简之。加分竟

第二本分中二。先问。二尔时普贤下答中三。先引古事。二类今答。三闻名益。初动地者。明本分提名表此大法将兴之感。出论难光者。明此妙德闻名发生请问之觉故能请问十门性起。若不尔者知何所请

第三请分中亦二。谓长行与颂。长行中三。先举法请。二叹众请。三叹说请。就叹众中三。初标众大。二善学下叹德具。三成就如是下结众集。就叹德中略叹十德。一净戒业。二念慧成。三满二严。四住佛仪。五具佛行。六正念下大定德。七大悲德。八决定下大智德。九胜通德。十住果德。三结可知。三仁者下叹说者有堪说德。亦显十德。一殖多善。二成妙行。三定自在。四证深密。五善除疑。六达教法。七善知根。八随器说。九顺佛智。十结无尽。善哉下结请。善哉有三种。一法要妙。二众堪闻。三仁堪说故云愿说也。二偈请中有十九颂分三。初一颂半标叹说听。二正请十门性起。三清净真下叹德劝说。就正请中。初二句请。初总门。二次句别请身业。三次句语业。四次句意业。五次句所知境。六次句所行行。七次句示所得果。有本此中更有二句。谓修习等。八次二句所转法轮。九次二句所入涅槃。十佛子下四颂半请第十见闻敬养益。并如下答中广释。三清净下叹德劝说中有六。初一请普贤说深广境。二次一叹众乐闻德。三次二劝以巧言因喻说。四次二重举三业以请说。五次二叹众会希有以劝说。六次二结请显众乐

第四说分中答前十问即为十段。一一各二。长行与颂。十中

初答性起正法者是总相故。身业等九种是别相故。皆是性起。同异成坏皆准可知。又释此初是所依之法。余九是能依之德。依法成德同名性起。又此十门皆约缘显性。性从缘现故名性起。亦有诸德。将此十中初一为因。后九为果。文相非顺

就初长行中三。先约法略说。二就喻广陈。三据法通结。此三各有十门。于中初之十门有将配十地一一别释。恐不顺文。有将此十于下广说一一别配。文亦不顺。今释此略一一皆通十广释中。下十结文亦一一通结十广释。是故此中因缘数总有四种。一云十种者据初略也。二云百者约初略十入广十中。一一具十故有百门。三云千者就后十结一一结百故有千门。四无量阿僧祇等者。彼广等中一一各有多门。如四智风轮十光明等。又亦通摄身等九中诸因缘故无量等也。释文中二。初告众。二显释显释中二。初总叹甚广故云不思。二所以下释成。初总释有二义。一以因缘广多无量名为不思。故下云非少因缘等。二甚深微妙名为不思。故下云无有作者亦无成者等。此二并非下位测量故云不思也。二以十种下正显。于中有标释结。释中初一是行本。由此大心长劫熏习不舍众生。是故于今现成正觉。二久修众善。正直深心引此善根现成正觉。三以慈悲救生无限尽故现成正觉。四积行广多大愿无竭。尽于未来现成正觉。五虽积德成满。而度生增善情无厌足故现正觉。如与盲比丘贯针等。六二利德圆是以成佛。七巧智多端。应机出现故成正觉。八福藏圆。九智严具。是故出现正觉不可穷尽。十若不成佛。无由宣说无尽法义故现正觉。此十皆是果成之处说彼因缘。但是为生现佛之因不取自德。又亦即以为生现佛为其自德。更无别自。是故摄因无不皆尽。如是因缘既无自性。无自性理为本起用故名性起。结文可知

第二就喻说中亦十。一一中皆三。先喻次合后结。前请中言因缘及譬喻为我分别说。前十辨因缘。此下明譬喻。亦有因缘义。初是大千兴造喻。喻佛众缘共起性起德。于中喻内。初总举多缘。二别辨云雨。三因雨起风。一名能持者。众生业力于空劫处。世界将成。于上空中先起云雨。若无风持。雨水无停。坏余世界。是故业力起初风轮。水若不减。无由得起诸天宫殿。是故业力起次风轮。虽能消水处起无由。是故业力起第三风。减一节水起一天宫。如是渐下至成须弥山及大地等。虽起总处。不能办彼别类庄严故。彼业力起第四风。令此世界方得圆满。此器世间先成。众生世间后成。广如俱舍论辨耳。四结业因中。言菩萨善根者同受用故。地前菩萨生秽土故。五结多缘。此四为首。理实无量故云如是等无量也。六法如是故下明缘起法尔水无自性。无有作者。明能作体空。亦无成者。明所作性空。二法合中。于上六句略无第五。余次第合。此中四智有人将配闻思修证。文相不顺。今释四中一总持细法智。次二依法起行智。一灭惑。二成德。后一依因得果智。前三既因。何故皆言如来智耶。释以在果位说彼往因故云曾于过去等也。果中但取摄化之果故云令众生等也。四如来无漏下结。余并可知。第二洪澍大千喻。此即是前风所持雨以喻佛深广难知德。谓得无尽陀罗尼力名成就诸力。若约一乘。十信已去菩萨是也。若三乘八地已上能受此法。问此门但显法之难知。何成因缘。答以彼大水是众生业感令成世界。彼大菩萨机所感故。如来兴世说此法雨故。是因缘。第三大雨无从喻。此亦是前所说大雨众生业力。从云所澍本无停伫。后消灭时亦无去处。况性起赖缘无来去德。谓于佛无从。入机无去。由此佛兴故。是因缘。第四大雨难知喻。亦名摩醯知滴喻。此亦是前劫初大雨况佛性起大机堪受德。谓已具修十地行力。是故器大方堪受此。古人释云以性起有四。一教广。二行大。三因深。四果远。是故二乘不能知也。第五大雨成败喻。况佛灭惑成智德。各有五种。初能灭炎炽。二能起处所。三能坏大水。四能成海中一切诸宝。五能庄严分别大千界处。法中初二灭障成福。次二灭障成智。后一以法照机可知。第六一雨随别喻况佛一味随器德可知。第七有二喻。初先成色界喻。况佛胜缘先济德。下一喻释疑。谓二先成由业力。二法异由机别故也。第八喻中三。初莲花表佛喻。二风轮起处喻。三是为结。初中依五卷大悲经第三云。何故名贤劫。阿难此三千大千世界劫欲成时。尽为一水时。净居天以天眼观见此世界。唯一大水。见有千枝诸妙莲花一一莲花各有千叶。金色之光大明普照香气芬熏甚可爱乐。彼净居天因见此事心生欢喜。乃至赞言。奇哉希有。如此劫中。当千佛出世故号此为贤劫也。解云此中花名如来起者。为表佛出世。又此中应云生千莲花。故下云知如花数诸佛出世。同大悲经也。又一节水减。一风轮起。成一处所。十风次第成处满足。法合况佛成办大事德。初佛出世合上大水。先授菩萨记。合上花生表佛。又能善知下合上知如花数佛出。二复有光名离垢下合十风。亦有诸德。将配十地次第别释。文似少顺恐非其意。但知各是一义皆表佛德。应感不同。如来大悲下合上结文。佛子如来性起下释疑。初辨正理。二众生念言下举疑情。三此非如来下释疑。四外疑云既非佛造。佛复何用。释云佛但为善友。因缘所成无作无性。是故还同性起本法。第九四轮相依喻。况佛体用依持德。然水轮所依之风有四义。一持水名安住。二性无移改名为不动。三相续一期名为常住。四体性密彻名为坚固。依俱舍论厚十六洛叉等。法合中初合四风。后合四轮。前中一摄取。二授法。三守护。四照实亦有配四摄合四风。并可知。合四轮中。饶益众生合前地轮。慈悲合水。方便智合风。如来合空。依持可知。第十大千饶益喻。况佛兴世利生德。令得三学益。慧中一内得真实。二外用照明。余并可知

第三结劝知中十句。一一皆通结前十门。谓一皆多故。二皆广故。三皆深故。四皆妙故。五皆大故。六皆常故。七皆遍故。八皆续故。九皆等故。十皆益故。上来略辨。总显千门性起因缘竟

第二偈颂中有六十五颂分二。初二十八颂叹深许说。颂上总答。二譬如大千下三十七颂颂上十喻。前中二。初二十四颂叹法难量甚深。后是故下四颂明许说分齐。前中亦二。先二十二颂叹所知甚深。后如来甚深下二颂显能知器净。前中亦二。初二总显佛德深广难量。后一切诸如来下二十颂别显佛德十门难量。各二颂显佛一德。初二显佛难思德。先总举。后别辨可知。下约喻中各先喻后法。二末尘喻喻佛无限德。三量空喻喻佛广大德。四数心喻喻佛无量德。五法界喻喻佛甚深德。六如如喻喻佛离相德。七无际喻喻佛无碍德。八性空喻喻佛性净德。九离言喻喻佛无比德。十鸟迹喻喻佛体用德。又释此十即是颂前结文十句。于中唯第九门却颂前第七句。余并依次配释可知。次二显能知净中。初颂总劝净意。后一别辨。上半令离想。见颠倒下结净意乐。下四许说中。初二诫听总许。后二别举下九门以明许说。于中如来深境界一句中摄如来行及菩提。余门依文皆具。自下别颂十喻中。初有九颂颂初喻。于中初五颂总后四颂别。二有四颂颂第二喻。三有三颂颂第三喻。四有三颂颂第四喻。五有三颂颂第五喻。于中但颂法合略不颂喻。六有二颂颂第六喻。七有四颂颂第七喻。八有二颂颂第八喻。九有二颂颂第九喻。十有三颂颂第十喻。末后二颂叹益结说。上来答总门性起正法竟

第二别答性起九门中。先明身业。以是所依本故。就长行中二。先总告标门。二此菩萨下释显义相。此中有五百门分别。初约法总显有五门。二就喻别辨有十身。即为五十。三通结能知亦十门。即为五百也。准例亦应有千。但以总中略故也。初中二。先总标德广。二何以下释成。先反释后顺释。各有五。谓法是行所依。行是能依身。是行所成。刹是身所依。众生是所化。各尽法界。皆言无量。二就喻别辨中。略辨如来性起十身。一无边周普身。二周遍无著身。三大用成益身。四平等应机身。五潜光密用身。六圆回自在身。七一多无碍身。八无思成事身。九体用益生身。十随念满愿身。况此十身亦举十喻。一一中各三。谓喻合结。就初中明虚空周遍喻。以虚空无形状故。非能行至诸处故云非至。然此无碍一切处遍故云非不至。况佛无边周普身。言随应现身者释疑也。第二虚空离染喻喻周遍无著身。各有标释可知。第三日光饶益喻喻大用成益身。各有总别释成合。中别内十益。一灭恶生善益。二发解除惑益。三与乐拔苦益。四授法长道益。五信成遣障益。六见理顺事益。七照境无遗益。八无缘慈善益。九开发心花益。十行成究竟益。下释成可知。第四中有二喻。初日光等照喻喻佛平等应机身。合中有六位机感。谓三乘及三聚无念而照益。后喻释疑。谓若但机感有异法不异。何故现见圣教不同。释随彼悕望教亦不同故也。第五日照生盲喻喻佛潜光密用身。喻中初无见后密益。合中有二。先略合。后佛子下广显。就略中初生盲不信。生盲有四。一耶见。二犯重。三愚痴。四耶命。各无信眼故是生盲。后佛子下慧日潜益。初息苦益。后断集益。二广显中二。初辨能益光明。后显所益众生。前中先列十光。初一发戒。次二成定学。次二成闻慧。次一成思修。次二成证智。后二成后得智。下结广有千。古人云。五百照下者是五位自分行。五百照上者五位胜进行。二所益中有四。初利益菩萨。先令得普贤位十十之德。后因得彼法。成就种智。于中诸入者是前十眼耳等也。二利益二乘。以不求种智不能利生故但灭自惑。三利益生盲凡夫。一令身乐。二心调。三成行。谓四念处也。四利益恶道众生。于中二。先身光救恶道。二慈音破耶见。又释有七。一拔苦得乐。二因起耶见。谓初迷佛力。后执梵作。三尔时下慈音示正。四彼诸下救成正见。五欢喜已下起报恩行。六佛与授记。七结光利益。第六日光奇特喻喻佛圆回自在身。合中明佛此身有四奇特。一无相现超过。二常身即延促。三住体恒现影。四一身普对现。菩提器者。古人云。以心海澄清离诸妄念故佛影现。今更释。谓是成菩提之器故也。又随所闻法者是地前机随解脱地者是证地器也。第七梵身普应喻喻佛一多无碍身。亦无起念等可知。第八医王巧术喻喻佛无思成事身。喻中二。先显医王现德。二彼大医下明殒后持身如本救物。合中亦二。初合医王现德。二无量亿下合中咒药持身合殒后持身。于中三。初到彼岸者正合命终。以生死永尽故云到岸也。二善学等者合药涂咒持令随有起化住持不绝。三如来以少方便等合虽无思念具四威仪疗治众病。第九摩尼利益喻喻佛体用成益身。合中二。先体后用。大福智藏者福智是体以能出生故云藏也。合摩尼藏能出众宝。二光用中初令诸外道舍耶同正色。二成净因。三得乐果。合前雨宝也。目佉者此云面。即宝名也。第十宝王称念喻喻佛如意满愿身。除佛神力下释疑可知。第三结劝知中亦十。一信心多。二入深等证法广。三住真等住理玄。四无生等结体常。五三世等圆三际。六悉能等舍妄情。七入未等达彼岸。八正法等化用遍。九一切法界者化体周。正法充满之言贯下二句。十一切佛等果德圆。以此十种知前十身故成五百门也

颂中四十二偈颂前十身。于中第四第八各有五颂。余门各四颂应知。答身业竟

第三性起语业。谓前明身。次明语。前色。次声。义次第故。释中长行内三。初总略说十。二别广辨十。各具前通故成百门。三后以十门通结前百故亦有千门。分别音声细取各各无量。如下结中皆言无量也。就初总说中二。先辨所知音声有十种。一体广。二德妙。三悦机。四演法。五开悟。六应时。七增戒。八增定。九增慧。十称性故云如响无主也。下显能知益相。以此能知如所知故。是故同彼。极无边也。略论五种各有列名释义。知见出生者列名也。此有二义。一此知见即是出生长善根者释出生也。二知见佛声能出生长养众生善根故。余四各二释。一约能知。一约所知可知。又此五中。一约多。二深。三广。四常。五实。并可知

二广辨中显如来十种音声亦以十喻。第一劫尽唱声喻喻佛平等说法声。谓无主平等说法无废。于中三。初法说中。量约分齐。主约体性。智约业用。非量等者。一云以普遍故不可量。成诠表故非无量。二量亦不可得。无量亦不可得故云也。非主等皆同二释。二喻中。先征。次辨。后结。依俱舍论生无色界有二因。一因力。谓近习及数习。二业力。谓上界后报业果报欲至故。若生色界有三因。谓加法尔力。但器坏时法尔有声。又不得越次生二禅等。仍待火至初禅始生二禅。乃风至三禅始生第四。合中明佛欲坏生死世间亦出四声说四乘法。声体平等无主无作。余并可知。第二响声随应喻喻佛无方应现声。第三空声开觉喻喻佛教诫放逸声。合中五。先总。二别说二乘法。三出生无量下别说大乘法。四众生闻下正答所益。五如来妙音下明声绝相离言。而有闻机说法故也。大乘庄严论云。若诸佛六十种音声是有法非无法者。诸佛不能以音声遍至十方无量阿僧祇国土。以音声无法非法故。诸佛能以音声遍至等。乃至广说。第四宝女妙声喻喻佛法蠡圆音声。谓一音出多音。一一说多法。各随异类解故也。第五梵声各闻喻喻佛根熟独闻声。不出众外者以根未熟故。第六水随器别喻喻佛一异无碍声。第七龙王降雨喻喻佛长养善根声。不从外来者离佛无声故。不内出者离机无声故。第八龙王渐降雨喻喻佛渐次说法声。亦是审根授法声。合中二。一先现身云七日思惟不即说者待根熟也。后渐说法又亦不烦说深法故也。第九龙王连注喻喻佛种种差别声。谓声异说异。并从净法界流故。无异之异也。第十龙王遍降喻喻佛普雨法界声。喻中有六。一云。二电。三雷。四风。五雨。六结合中亦六。先合十身云。初总九别。别中初四约外相。次四约内德。后一称性。二合依身云放十电光。三合雷震中言三昧者明依定起说。从所依为名。十种可知。四合风。谓将说法时。先从慈悲起后智。警觉加被令身心柔软以成法器。然后说法。五合十法雨。初坐道场菩萨者是现坐道树临将成佛。雨不坏法者有三。一是金刚三昧微障莫沮故云不坏。二出缠真如故云不坏。三降诸魔军不令得坏。二后身菩萨者是已处胎出生。未坐道场。雨密教者是佛秘密之教即入密智也。娱乐自在者是大神通法也。上二是等觉位。三一生菩萨者是未处胎。前同弥勒等智位普照大法云雨也。四得记者是第八地雨大庄严法者是九地上大法也。五得忍者是初地至七地。雨功德等者。福贵如宝。智敷犹花。二行相续名为不断。以七地已还有间断故。雨此不断行法也。六向行者是地前三贤位。以趣向正证故云向也。雨不退等者。以得位故。利他不疲。名入化门。自行不厌。名入甚深。七初发心者是十住位。初发心住雨。如来定等令修止行。大慈等令修观行。止观双。修二利俱起。八为缘觉雨深等者。知无明行感识等果名离断见。果起因流故离常见。又顺观离断见。逆观离常见。虽离断常而亦不坏。得解脱果。九令得四谛智藏降四住惑怨。十为三聚众生。初正定。二耶定。三不定。各顺已根令得法益故欢喜。六结中正觉心等合龙王心平等也。但以下合众生根不同感说有异。第三通结十声。先总。次别。后结。别中十种无量一一各通结前十声。于中各先列无量名。后释无量义。义皆可见。上来相乘总以一千门分别音声竟。颂中有四十颂颂前十段。一一各四颂如次应知。答音声竟

第四性起意业。先身语。次明意。故从粗渐细明次第也。于中标门释义。释义中先约法总辨。二就喻别显。三总结所知。初中言心意识非即如来者此辨定法体。谓此文中欲明佛心。然佛心等并转依成智。是故就智叹佛意业故云但知智无量等也。此文意明佛无心意但是智故。摄论第八云。谓无分别智所依非心非思义故。亦非非心为所依止。心种类故。以心为因。数习势力引得此位名心种类。解云非谓此位而有心也。若尔岂此智数无所依王。释有多义。一云理实佛地有净八识。但云智者就强胜说。论云如来无垢识圆镜智相应故也。言智无量故心亦无量者约数例王。举能依显所依。佛地论等具明此义。当知此约初教辨。一云理实佛地唯是大智。不说八识及余心法。经云佛无心意识等。论云唯如如及如如智独存。余一切皆绝等。并此经文及摄论等同显此义。当知此约终教而说。一云佛地大智内同真性。以照即寂故。十藏品中如来大智不生不灭等者是此义。当知此约顿教说。一云佛地大智即理即智即王即数。或开或合以前三说不相离故。无障无碍具十智故。当知此就圆教说耳。二就喻别显中略举十种大喻。喻如来十种大智。一虚空无依喻喻佛平等无依智。谓能与他作增上缘故。能为他依。自不依他故无所依也。又释以位满故更无所依也。又释因智依果果智无依。又释世间智是加行。离世间智是后得。同依根本。本智无依。何故不言依真如耶。释依是悕求义。证真圆满更无趣求故名无依。又释智性自离故。更无所依。若尔余智岂不尔耶。释此智证理极故。第二法界无改喻喻佛性无增减智。如三乘能证自有浅深所证法界无有增减。合能依后得随世亏盈。所依真智性无增减。第三大海润益喻喻佛益生无念智。谓加持众生资其念力故云润泽心也。第四大宝出生喻喻佛用兴体密智。合中一合佛海有智珠。二合出宝之用。三列四名。辩法师云。此即能生四乘智慧。一能生声闻乘。二能生缘觉乘。三能生菩萨乘。四能生人天乘。衍英等云。初证道智断惑障。二名助道智断于智障。三不住道智舍于报障。上三自利。四利益众生智即利他行。今释一无住着智。谓无染不著有。方便不住无。二分别法相智。谓剖折有为无为差别。三称法开演智。谓说异不碍同故云不坏法界也。上三约法。四化不失时智。此约机四。合深胜有标释可知。同法花中王髻明珠唯有功勋臣方得见等五合方正可知。第五宝珠消海喻喻佛灭惑成德智。喻合中各有三义。一总举。二列名。三显功能。若俗书中大海有沃燋石消大水。又云注于尾庐令海不增。又小乘中以阿毗地狱在大海下。火气上吞以消海水。今此文中为究竟说故不同前。合中四智。有古德将配四三昧智。初是大乘光明三昧智。二是集福德王三昧智。是贤护三昧智。四是首楞严三昧智。又英云。初是禅定智除不善障。二是方便智除着禅障。三如理智除烦恼障。四如量智除所知障。今更释初能除流散染业障。二能除昧定着净障。三能除根本无明障。四障尽成果智。此四皆从粗渐向细。佛子下结要胜可知。第六虚空含受喻。喻佛依持无碍智。释中云如来智无所不至者。谓以佛智遍于一切众生心中。是故众生从自心内种性生智即是从佛智生。还依佛智住。而于佛智无有迫迮。第七药王生长喻喻佛种姓深广智。喻中有六。初明树处及名。二明从生因深。三树功广大以此树能生一切诸树故云也。四释显树名。五简非生处。六不失生性。合中亦六。初举法同喻故云亦如是。二从一切下合从生因深。谓初是本性住性。于过去等是习所成性。三世无量下明所生果满。于中有四句。初内德圆。二皆悉下外化广。三除灭下益不虚。四巧方便下辨果相有六事。末后云持无增减者。谓果德生已尽于来际。用歇无减。新起无增也。三佛子下合名及释名。谓得果不舍因故名不断菩萨行。四彼如来下合功用广大。亦六事成利他行。谓由佛因地慈悲为根。今根坚不断故生菩萨慈悲行也。二以巧便为本名为茎。此能策成菩萨勤行。三净法界界是分齐义。义名枝流也。流出菩萨十度之行。四禅解脱成荫之叶生他戒等叶行。五七觉内敷之花成他善严之相。六无上果力令得记果。亦由佛智为本能生菩萨行位。是故佛智为性。能成菩萨行等名起。五合二处不生者以彼二处无起义故。问准上文。依佛智生三乘善根。皆是性起。何故此中简去二乘。答前据性起所益非是性起自体。以彼但是能依故。若尔菩萨亦是能依。何故取耶。释以彼二乘无大菩提心。不顺性故不名为起。菩萨不尔故不同也。此中二乘涅槃合地狱深坑。以火烧灰断故。犯戒等合水轮处。有四过失。一犯戒约不忏悔者。二耶见约为断善之因。三贪着据不可转改者。四非器就无出世道器。戒此亦是通结上三。若直看此文。似初约定性二乘后约无性凡夫。是故二处不可生也。若据后文合不舍生性。即知非毕竟无。以此二位约现在说。若约当来皆悉能生也。以于二处不生不名为减余处能生不名为增。故知定有也。第八劫火烧尽喻喻佛知无不尽智。合中略举四境无不知尽。释中言不可破坏者能知之力无竭故也。第九劫风持坏喻喻佛巧便留惑智。谓授与菩萨令留随眠或满菩萨行至于佛果。第十尘含经卷喻喻佛性通平等智。于中三。法喻合。初中二。先标谓佛果智与众生中因性本觉无差别故。是故即在缠之因具出缠果法。以圆教中因果无二。余圣教中未见斯义。二何以故下释因具果。既言无众生身如来智不具足者。即知若有不具者彼非众生数。何得更有无性有情。若俱有者何故不知。释以颠倒故。若颠倒不知者何以知有。释若先无者离倒之时何处得有。既云离倒智起。明知不无。一切智者是始觉智。无师智者是本觉智。无碍智者是始本无二智。喻中亦五。初尘藏经卷。二天眼见经。三伤无饶益。四作念破尘。五出经饶益。合中六句。初智在众生中合尘内有经。一切尘者是一切众生也。以妄念无体细末如尘。性德圆满如太经卷。迷妄覆真如尘藏经。二以倒故不能比知。不能证见。复不信此教。三佛眼观见。四伤无饶益。五我当下教除妄染合作念破尘。六如来即时下如念而作合出经饶益。第三大段总结可知。颂中三十七颂。初一颂前总说。余颂十喻于中初二各三颂。三四各四颂。五六亦各三。第七有五颂。第八亦有三。余二各四颂。是故三十六如次颂十喻。答意业竟

第五明性起境界。前既有能知大智。今明所知境也。于中先征问后显释。显释亦三。先举能知。二显所知。三总结彼知。初中若不得此无量无边智。无由得说广大境也。下辨所知中二。初当相明广。二约智辨广。初中亦二。先辨列十境。二显其广大。前中有五义。一约二谛境。初五约俗量智境。后五约真理智境。言非境界境界者非是识所变境故云也。二约三性境初五依他性。次四圆成实。后一遍计所执。三约五海境。初一众生海。次二及第九世界海。次二是根欲性海。次三是法界海。后一是佛海。谓佛智是非境故。四约前明难品佛境十种相摄可知。五释文中。初一是所化。二是化所依时。三世劫等。三所化处。四化所用法。五化所成行。六法界体不坏。七法界用无碍。八体用俱实。又释此三初真如体大。次相大具恒沙功德名法界。迭不相妨名无碍。后体相无二名实际。又释此三如次即三无性真如。九虚空是事无为境。十境智不二名非境界。以不异智之境名为非境。即以此非境为如来境。二佛子下显境广大可知。第二约智显广中三。先法次喻后合。初中以当相难明故。约智海以显境深广。然智必依心故云心境界也。恐迷此事故。释云随心无量生智亦尔也此同前门初心意非即如来等准之。又释如来所智之境并是如来智海中事。是故下文广说智海。即是释境界也。又释境界有二义。上来十种约所缘明境。此下约分齐明境。即以如来智慧大海为分齐境。喻中有三。初龙王心雨喻喻佛依心无本智。二海从龙愿喻喻佛心愿所起智。三海水宏深喻喻佛深广无涯智。此喻中先明海水深广。一四洲河水多。二龙王雨水多。三龙王池水多。后结四种无量。三佛子如是下法合中亦二。先合海深广。谓显法过喻非此所比即为合也。后合大海中有四种无量。初发心等合海中水无量。二道品等合海中末尼等宝无量。三无量众生等合海中众生无量。四大地等合海中有大地无量也。三佛子是为下总结所知。颂中十偈。初二颂法说。次四颂初二喻。后四颂第三喻。可知。答境界竟

第六性起行者。前明智所依境。今辨依境所成之行故次明也。就辨释中。长行内三。谓标释结。初中标二行。古人释无碍行者明俗谛行。二如如行者明真谛行。今更释初是会事同理。理不碍事。是无碍行。二事尽理现名如如行。又释初是量智于外事用无碍。二是理智内证如如也。二如如过去下释中有五喻。一真无迁变喻喻佛至绝三际行。即释如如行也。下四释无碍行。二此法界无形喻喻佛体无限碍行。三飞鸟翔空喻喻佛圆无分齐行。四金翅搏海喻喻佛胜用济生行。五日月行空喻喻佛无功成事行。皆以后释前可知。三结文可知。颂中十偈颂五喻。各二颂颂一喻。可知。答行竟

第七明性起菩提。前既对缘造作。必有示现菩提故次明也。于中略作五门。一释名。菩提此云觉。谓大智开悟故以为名。旧云道者非也。二体性。摄论云二智二断为菩提体。若依此经通一切法。如文知之。三种类有五。一菩提有二。谓性净菩提及修成菩提。出大品经。二有三菩提。一声闻菩提。二缘觉菩提。三诸佛菩提。出十地论。三有五菩提。一发心菩提。二伏心菩提。三明心菩提。四出到菩提。五无上菩提。亦出大品经。解云五中初一是十住初位。二是三贤位。三是初地见道。四修道满。五是佛果究竟道。四有十菩提如离世间品说。五通一切法。经云一切法即菩提等。解云三菩提约初教。二五约终教。一切法就顿教。十种据圆教。通即可知。第四业用者。谓缘二谛断二障。证二空起二智。印群机现万像。具十身遍十方。周于毛端微尘等处。通因及果业用无边。如此文中具足。五释文者。就长行内辨释中。释菩提义略有十门。一明体性。二显业用。三辨甚深。四显广大。五现因果。六离亏盈。七无增减。八依定起。九周法界。十遍心中。初亦以十门明菩提体性。一觉解为性。言一切义者真俗境义也。二断障为性。灭除疑或者断二障也。三证理为性。谓证离能所故云不二等。四别举离所取相故云无相。五离能取见故云无行。六令此相见永不再起故云无退。又释四当体离相。五性不迁流。六随流不变。七具多功德故云无量。八尽于未来故云无边。九性净为性。谓在缠无缚出障无脱。十中道为性故云离二边。上来亦是内证平等。第二知处非处下明业用门。谓随缘外照故成业用。于中三。谓法喻合。初法中亦十门。一知处非处即十力中初也。二知字。三语。四他心。五根。六烦恼习。七性。八宿命知过去。九天眼见未来。十漏尽知现在。此三世同一念知也。此十所知境现菩提智中故说知也。非谓有能所等。二喻中明大海印现喻。喻此菩提现机洞照德。三合中心念诸根等略举前十境也。而无所现者。与能现不殊故即自体显照故名为觉。起信论云。诸佛如来离于见想无所不遍。心真实故即是诸法之性。自体显照一切妄法。有大智用乃至名一切种智。解云此即无思显照同体之境名菩提业用。不同余位有能所取也。第三佛子一切下明甚深门有四义。一离名故深。二绝言故深。三无譬故深。四不滞寂故深。故云但随等也。又释此是释疑。谓既非言譬所及。何故上下皆以言喻说耶。释显如文。即无说之说。非喻为喻可知。第四佛子如来下明广大门。于中有三。初举身广大。二类显语意。三总结多门。初中言成菩提时住佛方便者明此菩提由方便对机说有成也。此增数十身故有十三种耳。初一是众生世间身。谓得能同一切众生身之身也。等犹同也又释等犹遍也。即遍以一切众生而作自身故云也。下皆二释准之。二同一切染净之身亦即可知。三同器世间国土身也。亦即以国土为身。四同于一切九世十方诸劫之身。亦即以彼为身。五同一切佛证道之身。六等一切佛智觉之身。亦前如道平等。此是觉道平等。上二智正觉世间身。七以彼能诠言教为身。即如论中名言说法身。八以所诠法界为身。九同大虚无为之身。十同因陀罗网法界之身。互相涉入故云无碍。十一用无不起身故云出生也。十二德无不备身故云一切行。十三体无不寂身故涅槃也。又此十三摄为六对。初二人法一对。次二时处一对。次二境智一对。次二教义一对。次二理事一对。虚空为事也。次二因果一对。行是因也。后一总结平等。二类显中依身辨语意。语意亦十三。同身可知。三总结中。身等一一各等法界故皆云无量也。第五佛子如来身中下明现因果门。于中三。谓标释结。标中以菩提身等众生故。是故众生悉于中现。以彼所现同能现故。是故众生无不成佛。此文是大节。幸不轻之。问此中所现众生成佛为是约事。为是约理。若是约事何故下释皆悉一性以无性故等。若是约理何故标中乃云有发心修行等。答此是别教中义。若不约诸宗分别无由得解。何者然诸众生若于人天位看具足人法二我实物。若小乘教中看此众生唯是一聚五蕴实法本来无人若大乘初教唯识所现如幻似有。当相即空无人无法。若约终教并是如来藏缘起。举体即如。具恒沙德。乃是众生故。不增不减经云。众生即法身法身即众生。众生法身义一名异。解云此宗约理众生即是佛。若约顿教众生相本来尽。理性本来显。挺然自露。更无所待故。不可说即佛不即等也。如净名杜默之意等。若圆教即一切众生。并悉旧来发心亦竟。修行亦竟。成佛亦竟。更无新成。具足理事。如此经文。问若尔何故现有众生不即佛耶。答汝今就初人天位中观彼众生。当相即空犹亦不得。况复得见圆教中事。是故汝见现有众生。我不约彼说此成佛。但令情见若破。法界圆现一切众生无不成佛。问若尔何故诸佛更化众生。答教化众生亦有浅深。今即此菩提身中现众生成佛者。名究竟教化。不同余宗故。下结中名如来无极大悲度脱众生也。问既总成佛。何故亦有发心等耶。答若成佛门中总成。若修行门总修行。若发心门总发心。若离此等总即。空无所有。准大缘起门思之。言乃至涅槃者。于八相中举乃至末故也。二皆悉下释成中。云何现。同一真性故。如是现。何以众生同菩提性。略以十因释成此义。一以众生依于菩提无自性故。是故同于菩提成正觉等。二无自染相故。三无所尽故。四本来不生故。五亦无新灭故。上四同为一句。六我性自空故。七众缘之生非是生故。八设起觉智无所觉故。九所依法界亦无性故。十本性空界无体性故。三如是等下总结中。无尽智者照用无限故。自然智者不待功用故。无极大悲者同体摄化故。问准此释结。似约理性说众生成佛。何故标中有发心等五位因成佛等八相果。答此是以法性融通门释。谓事随理以融通故。得相即相入故也。又余教中观无生唯照理性。此圆教中具足一切佛菩萨法。依宗准之。第六佛子譬如下体离亏盈门。于中二。谓喻合。初虚空常性喻喻菩提性无增减德。以体常满成无不成。性无二故。第七佛子设有下明用无增减门。于中三。谓喻合结。初化现无形喻喻菩提成不平等德。喻中初化多心者喻各各修多因也。心化如来者喻成多果也。以此因果俱无色相。是故化与不化等无有异。合结可知。第八佛子如来应供下明依定起用门。于中三。初举一定门。谓顺理警机名为善觉。依此定门出众生数等菩提之身。二类显。如一定既尔余一一定各出尔所身。如多三昧既各如是。余一一法门。谓大悲大智大总持等一切法门。各如是出。即知菩提之身无尽无尽不可称说也。三结可知。第九复次佛子下明周遍法界门。于中三。先标中亦三。初一毛道者谓于空中容一毛处名为毛道。即于此处见前门中众生数等菩提之身无不圆满。二类显一切毛道一一皆尔。三类显一切法界处悉重重普遍。二何以下释成周遍义。三如来下结法属人。谓此卢舍那佛于菩提树下成菩提时。究竟具足如是等类。周遍法界。重重菩提。是故佛身不思议不思议也。此即遍于非情一切处也。第十复次佛子下明遍心中门。于中二。先举自。二例他。初自中先标。此明佛地果德。菩提遍在菩萨及诸众生身心之中。非是菩萨有菩提因性佛文中正辨佛菩提故。二何以下释成。以菩萨心既无自性无自性法即佛菩提故云不离。若尔无自性理即性净菩提何必要是佛果位法。释以佛果大智内契真原融同一性。是故如理普遍众生。众生心中菩提之性既与果法无有差别。则众生身中有果德菩提。非唯因性。此亦诸教不同。若小乘宗总不辨佛性。若三乘宗一切众生位中但有因性。如涅槃云。佛性是因而非果。若一乘宗亦具果法。如此经文。问此菩萨心不离如来菩提者。似是发菩提心缘菩提为境故云不离。何必即是心之自体。答若尔众生既未发心。不缘菩提为境。不应例观彼亦有菩提故。不约所缘也。二例他中。先例。二无量下结德。无处不有者明普遍也。不可坏者虽遍在染不为惑业所坏。亦不为治道所破。不可思议者同染而非坏。是不思也。同因而是果。亦不可思也。三结中方便门者结前十门。知见菩提并是善巧之义也

颂中十二偈。初二颂初体性门。次二颂第二业用门。次二颂第六体离亏盈门。次二颂第七用无增减门。次二颂第八依定起用门。后二颂第五显现因果门。及颂初门业用中法说也。余门略无颂。答菩提门竟

第八明性起转法轮。谓前得菩提次转法轮。以为次第。长行中三。标门辨释结知。释中有七门分别转法轮义。一体相。二深广。三无尽。四无住。五分齐。六出生。七知益。初中略以十义明其体相。一一切愿者是法轮所依。二一切法者是所转之法。三转无所转者会相明体。四本无所起者称性辨体。五三转圆满者德相圆满。谓示相劝知引证为三也。六皆悉清净者是梵轮故。性净故。经云三转法轮于大千。其轮本来常清净。此之谓也。七悉能等者离障故。破见故。业用故。八离欲等者离无所离故。九一切诸法等者离言故。十一切法等者离相故。此第十中故字。通上九义一一皆有准之。第二菩萨摩诃萨下明深广门。于中有四义。各有标释。初一广。次一深。后二亦深亦广。初中先标广大。如来下出因释成佛如来音声于一切世间文字语言无不至故。皆转法轮也。二中先标甚深实性故者释成深义。三中先标深广。佛转法轮无主故者释成。以各从缘成无自体故。同为一性。悉是法轮。四中先标。无流故深也。无尽故广也。内外无所有者释成也。第三佛子譬如文字下明无尽门。于中先文字无尽喻。后合法轮无尽可知。第四如来法轮悉入下明无住门。于中有法喻合三也。字母无住喻喻入缘无住德。于中一切处是总也。别举五处可知。第五一切众生诸语下明分齐门。于中二。先标后释。若小乘一说五音是法轮声。余问阿难天雨等皆非法轮摄。若三乘中佛一切音声等皆是法轮。余即皆非。若一乘一切众生言音等亦入法轮。约用皆得成法轮故。第六复次佛子下明出生门。于中四。一标门。二何等下征起。三如来下总举。四何以故下别释。别释中先通辨。谓欲转法轮入此三昧者是所依门故也。无碍者是辩才也。无畏者言无怯惧。二如来入此下正显出生多音。释成总中众生念心等音也。悉令众生等者称根授法故令喜也。第七佛子若如是下显知法益。明如上而知顺大菩提。不尔即非。三结文可知

颂中十偈。初一颂初体相门。次一颂第三无尽门。次二颂半颂第四无住门。次三颂半颂第六出生门。末后二颂却颂第二深广门。第五第七略无颂。答转法轮竟

第九明性起涅槃。谓转法轮既讫。次辨涅槃以为次第。涅槃之义略作五门。一释名。二体性。三种类。四业用。五释文。前四如别说。释文中。长行内释中。长分有八门。释大涅槃。一体实真常。二简异灰断。三不碍出没。四随器亏盈。五起尽随缘。六存亡常湛。七用穷来际。八总结所知。就初门中三。先举法劝知。当云何知。谓如如般涅槃等当如是知。二如如下正辨所知。先标一如门以会涅槃。谓即此双林北首涅槃。即同真如平等一味不生不灭故。云犹如真如涅槃亦尔也。下九例然。并是如之异名。意显涅槃同彼真性令明净。故约此多门说也。三何以故下释法同喻。亦是释事同理。何故不约彼性净门说此真如即是涅槃。乃言犹如耶。释云若约真如实际即涅槃者。此即但是性无有起义。若但取彼化现涅槃。即但是起无有性义。今显起同不起。明是性起。即是约会事同理说性起。涅槃下喻说中此义弥显。第二简异灰断门。于中有标有释标中不为菩萨说究竟永灭者是约人显实。谓于二乘亦说如来永断灭故。今就大机实教尽理故不说也。下释中有二。初欲令菩萨称实见彼三世诸佛总无涅槃。前门同理性而常住。今辨实德亦无灭度。何故不云总无涅槃。乃云不说究竟涅槃。释云为诸菩萨亦说方便示现涅槃。但非究竟。十住断结经第六卷云。佛告最胜。三世诸佛世尊有名号已来。吾未见泥洹者。此经下文善财知识长者。开栴檀佛塔见三世诸佛无涅槃者。二出生妙色应机不绝。然无分别用常寂故。不令菩萨见有起用入灭之二。亦不令着此无二处。标释可知。第三佛子但如来下明不碍出没门。于中先标。谓应机有出没。不碍实不迁。二何以故下释显无碍可知。第四佛子设有日出下明随器亏盈门。于中先喻后合。谓举日影随器现不现喻。喻佛随器有亏有盈故。无性摄论第十云。问若如来是常住者于一切时何故不现。答众生界罪不现。如月于破器。以破器中水不得住月影不现。此非月过。是器之失。众生身中无奢摩他清润定水。佛影不现。非如来过。是众生失。解云梁论中器喻持戒也。又摄论明显现甚深有现不现。由于机非如来咎。此经明灭度甚深有灭不灭。由器全不全亦非佛过。又此中涅槃亦是器感故云应见等也。第五譬如大火下明起尽随缘门。于中有三。喻合结。初举火随薪有无烧不烧喻。喻佛随彼化缘有起尽故。摄论第十云。或涅槃如火者。如世间火有处烧燃有处息灭。诸佛亦尔。于诸善根未成熟者。现等正觉。令其成熟速得解脱。于诸善根已得成熟已解脱者。现般涅槃无所为故。解云此上二喻摄论并依此经而作。第六复次佛子如大幻下明存亡常湛门。于中亦三。谓喻合结。先举幻师随舍不舍喻。喻佛随机此灭彼存本智常湛。言如来幻身常住如法界者明佛修生之身亦同法界为常故也。第七复次佛子如来示现下明用穷来际门。于中有十。初定力现身。二光现花座。三依座现佛。四数齐所化。五具德满愿。六应机化益。七化穷来际。八体离有无。九明常住所由。十正结知见。此等并是如来双林北首入涅槃之时有此事也。第八复次佛子此菩萨下总结能知相。于中十句。一无量无边者。结上简异灰断门明大涅槃功德无边。二究竟法界者。为万德所依结存亡常湛门。故上云如来幻身常住如法界也。三无障碍者。结起尽随缘门。明灭与不灭无有障碍。四不生灭者。结随器亏盈门。故上云其实如来不生不灭也。五净如虚空者。结不碍出没门。故上云其实如来无有出世亦无涅槃是故同虚空也。六安住实际者。结前最初体实真常门。谓上文实际等十义可知。七随其所应示现者。通结诸门内应机现用文也。八本愿所持不舍众生。九不舍刹。十不舍法。此三结末后用穷来际门。谓愿力持故尽穷来际等可知

颂中初二颂第四。次二颂第五。次二颂第六。次四颂第七。后二颂初门。余三略不颂。答涅槃竟

第十明性起见闻敬养善根。前既示涅槃。今明供养。余迹成益不虚故次明也。长行内释中三。先就法。二约喻。三简喻异法。初中先总辨。所谓于佛。若见佛及像。若闻名及称念。若三业恭敬。若四事供养。于此四位所种善根。广多无限不可称说故云功德无尽。下别显中略举三种果。一断灭惑障果。二于一切下德穷来际果。三起诸佛下成大菩提果。又初唯断果令得涅槃。后唯智果令得菩提。中间通二。谓弃有为随顺无为故也。第二喻中亦三。初吞少金刚喻。喻前第二德穷来际果。谓微少善根性不可尽也。二小火能烧喻。喻第一断灭惑障果。谓少善根性能灭惑。又释前灭所知障。后灭烦恼障。三药王多益喻。喻第三成大菩提果。合中二。初以佛合药树。见闻等明佛在世作六根境。故宝性论云。诸佛如来身如虚空无相。为诸胜智者作六根境界。示现微妙色。出于妙音声。令嗅佛戒香。与佛妙法味。使觉三昧触。令知深妙法。大同此经也。二若有得经卷下合地土等明佛灭后益。上来明广饶益。二佛子乃至不信下明深饶益。如来秘密藏经骂药服之得力等。骂沈烧已还香等。骂佛犹胜敬外道等。五卷大悲经但出家人袈裟着身。假令左手携男右手携女。从一酒家至一酒家。佛言我记此人。不出贤劫当般涅槃。如是等文同明如来法不思议也。第三简喻异法。有标有释。以非世喻所能类故云过思议也。但随下明方便说喻。非是比类。是为下结可知。偈颂在下。显其钩锁故也。上来说分竟

第五大段显名受持分。于中二。先兴二问。后还两答。何故此中辨名持者。显义实故。以性起是法体故。要妙故。答中先答名。依光统等总作十名。一名诸佛秘密藏经。以是诸佛内证法故。二名世间不能思议经。以凡小莫测故。三名如来所印经。以此深广是如来所印之法故。四名大智光明经。佛智垂光令得明故。五明开发示现如来种性经。性起品名从此而立。又释令佛种性起用现前名开示也。六名长养菩萨功德经。前依种性发心起行。今令此行随修渐长。七名世间不能破坏经。明彼行体常在世间。非八法所坏。又释非四相所迁故也。八名随顺如来境界经。以彼行因能顺果故。九名令众生皆清净经。令于佛果生净信故。又利他令离杂染障故。十名分别说佛究竟经。上约义。此句约教。以所说佛果性起是究竟法故。又义上十名皆以后释前可知。二佛子如是经典下答奉持。于中有四。初辨定法器。二举益劝信受。三信顺成益。四明劝修成益。初中三。谓法喻合。初法中二。先总标器非器。二何以下释成。前中先标器乘不思议乘。乘者运载义。但运载有二种。一次第运载。谓从微至着。阶位渐次。以至究竟名可思议乘。二一运载即一切运载。谓十信满心即摄诸位。圆融无碍名不思议乘。一向专求者非直所乘之法相摄无碍。能乘之行亦不杂余念。如下法界品云一切菩萨无量劫修善财一生皆得。皆由直心精进力故。二不为余人者简非器。但余有三种。一凡夫。二二乘。三权教中初住菩萨。谓乘可思议菩萨。如此下文亿那由他劫行六波罗蜜不闻不信等。二何以下释中一乘深广普该群品。何故不为余人说耶。释只为深广普该。非狭机所受故也。不入众生手者。手有七义。一约位。谓修学此经。必定超出众生境故名不入手。以此非是世法摄故。二约心。谓若不发起大菩提心非此经器。云不入手。是故若不发心终日执卷未曾入手。三约行。谓此经是行菩萨道者之所要。若起惑造业。名众生行。经非彼要故不入手。是即若为名闻利养讲读此经。篇数纵多。未尝入手。四约智。谓诸世间执见之智名众生智。经超彼见名不入手。是即若受持此经。执见不破。无与此经曾不相见。是故要须违众生见顺此法者方名入手。十地云。若闻即迷闷者。论释闻作闻解。不得不闻等。五约信。谓虽未能破见正入。于此情外难思议事能决定信。亦名入手。若不信者名不入手。故法集经云。是经虽行阎浮提。于诸佛所护众生中行。于能信深法者常住。如是众生心手中行。解云。信能采纳。同手义故。贤首叹信云。为清净手受众行斯之谓也。六约二乘人亦不入其手。七约权教菩萨亦不入手。以虽闻不信故。唯除菩萨者。既言不入一切众生手。此言有滥故。今简除翻前七种简取法器。则是乘不思议乘菩萨。喻中五句。合中亦五。一此经合七宝也。二不入手合无堪持也。三唯除真子从种姓中生者合第一夫人所生太子。四种如来相等者合具圣王相。五若无此等者合若无太子七宝散灭。以无修行教法不行故名经灭。般若论云。法欲灭时者修行灭故。何以故。下释无真子经灭所由可知。第二举益劝信中二。先明闻信之益。有标有释。少作方便者以依普门互相摄故。一得一切得故。如善财一生龙女速疾等。二明闻信难得。谓若菩萨依于三乘渐次教中。纵经尔所劫修习六度道品等行。以根未熟故不闻不信此一乘经。若不尔者。璎珞经等十千劫中修信成满。岂可无量亿那由他劫修行六度。犹不信此经。既非二乘。更是何等菩萨也。此同法花中若不信此法。当于如来余深法中示教利喜。亦同上文求大乘者犹为易。能信是法为甚难。问所许劫行犹未能信。今诸凡愚云何得信。答宿有种性。闻便信受。若不尔者多劫难入。今时有人。多不信者不足怪也。问此等不信。是何位菩萨。答文无正断。准其劫数。十千已过僧祇未满。应是三贤位人。问更至何位则能信此。答极至此位。必定信入此一乘法。终无证地而不信此。问何故二乘纵得罗汉亦未信入。三乘菩萨不至地上而能信耶。答以三乘胜故。是近方便故。不同二乘也。是故若入此法。则于十信满心具一切位。同时而得也。言假名菩萨者但依权教。修行未得一乘实行也。不从种性生者。方便非是佛正因故。未顺三世佛本性故。第三佛子若菩萨下明信受利益。于中十句。一成真子。二顺佛境。三具因法。四住上境。五背下位。六长佛行。七因位满。谓十地终极为菩萨彼岸。八入果法。谓于佛秘密自在神通难测量处能善达也。九得果位。谓唯佛无师也。十穷果际。故云深入也。于此十中初三成三贤益。次四成十地益。后三成佛果益。信受此法成此等益应知。第四佛子菩萨闻此下明修行益。于中亦十句。一悲智心。谓平等是智无量是悲也。二远离下背向心。谓直心向理也。三面对下念慧行。谓念对面现慧照平等。四分别下达因行。五具足下成果智。六远离一切下离染行。七发清净下广大行。八深入下其深行。九平等观下观果行。十深入此等下证玄行佛子下结益相可知。颂中但颂前第十见闻等益。不颂名持等。八偈分四。初二颂法说。余六颂三喻。各二可知

第六表瑞证成分中二。先表瑞亦二。先此土。谓动地雨供表法真实。后如此下结通十方。即显一说一切说也。此亦通结前所说法。皆顺根成益故。令菩萨皆大欢喜。二证成中亦二。先果。后因各有一证一切证。就佛果证中亦二。初现身证有三。初现身。二赞说。三引证。二说此经时下举益证。于中五。初菩萨位满益。一切明是智也。二众生发心益同号胜境者。以缘性起胜法为境。发心因立此名。三是故下明佛护持意。四如此下结通普遍。谓乃至法界虚空等世界一一各有所许菩萨所许众生。各得斯益。五出遍所因略出八因。是减数十也。初二能说所说为一对。次二能感所感为一对。谓善力是能感也。次二能化所化为一对。谓缘根熟。化不失。即时缘会故也。后二能成所成为一对。谓普贤行是能成因也。第二菩萨证成中。何故此品有因果二证者。显性起玄妙故。为因果本故。佛果所得故。菩萨所学故。此经上下证有四句。或唯佛证。如发心品。以初心成佛事恐难信故。二或唯菩萨证。如前诸会。以诸位所行菩萨得故。若尔何须证耶。释以一一行位摄于一切。事越常规。是故须证。三或俱。如此品。所由如前。四或俱非。如第一会等。以彼文未尽故。就此文中二。先一证。后一切证。初中有五。一菩萨来此充满法界。二示现下十门辨其德用。三时彼下叹此所说。四佛子下述已显同。谓名同处同主同行同说同句同字同义同理同。五显已来意为作证故。佛力法力。略出二因也。下结通一切证可知

第七重颂分中二。先序意。后正颂。序中先观众。后显意。显意中有十一句。欲重显前十门性起。初性起正法是前初门。二无量功德明身业。三正法不坏明音声善说。四智慧同。五具佛法超辨如来行。六群生心是境界。上云心境界是如来境界。七化不失时。是应时示得大菩提也。八分别一切等。是转法轮也。九变化是示现涅槃。十身无异是法身常住。上二显涅槃。十一出生一切等。是见闻敬养。广生胜善。下正颂中七偈。初二颂前说分。次三颂前显名受持分。后二叹胜劝持。就初中。所成就威仪者。明佛动止所作非言能说非譬能况。此显佛果性起当相难明故也。若尔何故上文十门性起。并是如来所成威仪。广以言喻而辨说耶。释为益众生令得解故。方便影响以少分喻说。巧显真实令其悬会。非谓彼法即如此喻。故云以非喻等。此约缘方便以显性起。次三颂颂显名受持分。中初一明现在具德方堪得闻。谓精进颂前一向专求等。智慧颂前乘不思议乘等。微密及如来藏颂前经名。次一颂明具宿因力。闻便生喜颂前种如来善根等。次一明天佛赞护显闻益相。后二叹胜劝持中。初一约人叹法。上二句显此经是佛胜人之内藏。次句显佛以此内藏被大菩萨令其欢喜故。上结通云令诸菩萨皆大欢喜。此之谓也。后偈中上二句约用叹胜。明诸菩萨缘此胜法出生普贤无流圣道。下二句结劝奉持。释性起品竟。总第六会了

花严经探玄记卷第十六

          乙巳岁分司大藏都监开板华严经探玄记卷第十七(尽此第□会)

        魏国西寺沙门法藏述

    离世间品第三十三

将释此文四门同前

初释名有三。一者分名。谓此明第三名托法进修分。即依托行法修成正行故立斯名。二会名者。约处名普光重会。今何故于此而重会者。以前普光是生解之初。今明依解起行故重会之。若尔何不三四等处亦重会邪。释前是生解之法。可寄多处。今但依前法成行故不多会。三品名者有四。一下文有十义。至彼当辨。二别翻一本名度世经。三更有一本名普贤菩萨答难二千经。四此品名离世间亦有四义。一约妄执为世间。即空为离故。上文云一切诸世间皆从妄想生。是诸妄想法其性未曾有。二约缘起为世间。无自性故名为离也。上文云三世五阴法说名为世间。斯由虚妄有。无则出世间。三约行。谓常在世而非世摄故云离也。四约位。人天是世。二乘为离。二乘为世。菩萨为离。菩萨分段变易俱为世间。佛果究竟方以为离。今此所辨。六位行故。因果二位俱即世而非世故云离也。品内明此故以为名

二来意者亦三。初分来者。上明修因契果生解分。则于法起解。今明托法进修行德分。则依解起行。义次第故。是故须来。二会来者。前第六会明修因契果生解周圆。次显正行处世无染故次来也。三品来者。前性起品明显性果殊胜。今明依彼所起行用故次来也

第三宗趣者二。先约类。二约义。前中亦二。先约人。后约法。人有化主助化。化主以内证行海为体。助化以入定动地为相。余并同前准之。二法中教事内。以略标二百问为本。广答二千为相。赞成益物为用义。理中平等性海为体。尘算行德为相。与教相应为用。余相即等并准之。二约义者有四。一法。二行。三俱。四泯。初中二。先明世间。后明离。前中有三类。一约事相世间有二。一器世间。二五蕴世间。此就依正分之。如余论说。二约粗细亦有二。一有为世间。二无为世间。此据分段变易为二。以变易非是三有摄故名为无为。胜鬘云。有为生死无为生死者是此义也。三约染净有三种。一器世间。二众生世间。三智正觉世间。初是所依。次是所化。后是能化。如地论说。二明离者有二。初明世间即是离。二明世间之离。前中有三种。一不同故名离。如智正觉名为世间。而不同世故名为离。二相望离。如无为世间望于分段。亦名为离。三性自离。如诸世间皆无自性。本来无生故亦名离。论云世间与涅槃无有少分别。是故世间即为离也。二超出世间名为离。中亦三。初不同离及相望离。皆超出他世名为离。性离之理亦非世摄。是故俱名超出世间方为离也。二约行中亦三。一行从缘起名为世间。自性无生即名为离。二行能灭惑令背于世故名为离。三行成妙果永超二死故名为离。此三如次同前三离。又同三种佛性等思之。三约俱辨中。以世间为境。悲智为行。以悲故常行世间。以智故恒离世间。又以世间与性离无二为境。悲智无二为行。境行通融亦有三句。一智无不悲故世无不离。是故常在世间未曾不出。二悲无不智故离无不世。是故恒超世表无不游世。三双融故动静无二。唯是一念。谓无念也。是故菩萨无念不智念。常行世间。常出世间无障无碍。四俱非中亦三。一约境世间与离形夺两亡。二悲智俱融。二念双泯。三境行相由形夺齐遣。绝待离言不可说也。思之可知。下文二千行相是此等义。思以准之

第四释文者。此会之中长分为八　一序分　二三昧分　三起分　四请分　五说分　六结劝分　七表证分　八偈颂分

就序分中有三。初明器世间圆满。二显智正觉世间圆满。三众生世间圆满。初义如前释。第二中成等正觉等者。此是受用身二十一种功德。如摄论第五及佛地论第二并广此文。今依彼二论略示少分。初一句是总。余二十句是别。初中具后二十殊胜德故名为正觉。即称正理而开觉。又离邪障之觉故名也。又正觉约理智。等觉约量智。可知。论名不二现行。别中二不二念者是一向无障殊胜功德。以离二障故。异凡小。住二处故。又释于远时方等境无知不知二念故。即由此故名等正觉。三无相念者。彼论名趣无相。是调化方便功德。令他趣证无相涅槃故。又释名能入无二功德。谓自能入离有无相清净真如。亦令他入故。四住佛住者。是观所调化功德。谓住大悲常观世间故。又是任运佛事不休息功德。恒住圣天及梵住故。五等一切佛者。是得一切佛相似事业功德。又于法身中所依意乐作业无别功德。谓所依智同。益生意同。报化业同故云等也。六到无碍趣者。是永断所治功德。谓证得二障习灭。及修彼治道成就现前故。七得不还法者是伏外道功德。谓证教法彼不能转。伏彼显已正道法故。八无碍境者。是伏魔怨德。谓违顺中境不能碍心。及世八法不能拘碍。九住不思议者。是安立法教功德。谓诸胜教出过寻思非余能测故。十离三世者。论名游于三世平等法性是记别三世功德。谓记别去来皆如现在。分明无倒故名平等。此中离者离于三世。记不明了故也。十一于一切世界普现身者。是同时普于一切世界。示现受用化身功德。十二知一切法者。论名于一切法智无疑滞。是断一切疑功德。谓于诸法自断疑。得决定智。令他亦得。十三具足成就一切妙行者。论名于一切行成就大觉。是入种种行功德。谓随所化有情所宜。现同类身。令彼入故。十四永灭疑或者。是达当来法生智功德。谓过二乘境微细善种。如瓦石中细金种子。如是等境无倒遍知故。十五离虚妄身者。论名不可分别。是自身无染德。谓非惑业苦杂染分别所起故。又随其胜解。如应现身如末尼珠。虽无分别。增上力故现金色身等。十六能与菩萨无量智慧者。论名一切菩萨正所求智。是成就佛种不断方便功德。谓诸菩萨依诸有情调伏方便。皆由如来增上力故。得闻法思修。次第获得妙智。异类菩萨摄受付属展转相续无间而转。十七住佛无二彼岸者。论名得佛无二住胜彼岸。是诸身诸度极成满德故。谓法身无二。度行满故。十八具足乃至法门者。论名不相间杂。如来解脱妙智究竟是受用身及土。随机应现互不杂等。此不可沮坏是彼不间杂也。十九究竟无量无边者。论名证无中边佛地平等。是三身方处无有分限功德。又是证真如离有为无为中边相故。远离方处中边相故。此佛地在后句中。又释世界无中边故。佛现亦无中边。无中边故。即总无边也。二十法界等者。论名极于法界。是证得果相功德。谓穷清净法界故。又是穷生死际。常现起作一切有情利乐功德。谓依净界流起经法益生故。二十一虚空等者。论名尽虚空性。穷未来际。虽经劫成坏。而空常无尽。此同自实德也。未来际无尽。期利他胜用。常无休也。第二会初唯有初十句。准此释知之。问佛地经及解深密经辨十八圆满受用土中。叹受用身有此二十一种功德。今此佛身在摩竭国。即是变化。何因亦得具此功德。设此化身约地上见具此德者。何故见佛而不见土。又此见化即为报者。岂地上菩萨不得兼见变化身耶。答是知此中约十佛功德。见通五位。处该染净。以二千法中亦有地前四十位故。地前地上同所见故。摩竭花藏融无二故。余如前说

第三众生世间圆满中有二。初举数叹德。二列名叹德。亦是前举数总叹。后是列名别叹。前中二。初举数简定。二具足下叹显胜德。前中一举数。二简大异小。三简终异始。四简客异主。二叹中二。先别叹。后总结。前中亦二。初十句叹因位自分德。二于一念下叹果位胜进德。前中亦二。初五句叹巧惠德。后五句叹摄生德。前中初句总标。谓此中夫一菩萨即已具成一切菩萨所有方便智慧故也。下四别显中二。初释前二义。后双显功德。前中二。初释成方便。谓具此调生入法之巧故云方便也。不令众生堕二乘地故。纵入者亦令起故。要当令住菩萨法中故。名善巧胜方便也。二释上智慧中二。先量智知世界染净差别。二理智观达解脱真境。又释前句知世界相不同。后句知相入相即为解脱境。如十解脱等。二显功能中二句。一灭障德。二成行德。谓由前巧惠故。障无不尽。行无不具可知。二摄生行中亦五。初一句总标。谓善摄等者巧识根器也。深入无量等者深解法药也。下四别释亦二。初二释上二义。后二显化归体。前中二。先释识器中。一了众生报类差别。二知心之所念。三知彼烦恼使有轻重。四知根机有生熟软中上等。五知其所缘境界差别。六知彼入法方便所宜。又亦知是起行方便。二三世下释上深解法药。谓三世佛说显法胜也。善闻者巧听故。受者领纳故。持者不忘故。广说者授群机故。下二释化归体。一虽能游入无边世间教化众生而常超出世间之表。二何以处世而恒出耶。释以解有为即是无二法界故也。第二胜进中十一句。初一总。谓速成佛果。依新译花严不思议佛境界分中。普贤文殊等。并是他方诸佛为欲与毗卢遮那佛为众会故现菩萨身。故知此等并实是诸佛。故云得一切佛智。下别显果用。一自现佛身。谓念念无间尽未来际。当现成佛。自为法主。常作菩萨。为他助化。二能令他成佛。谓以殊胜巧便之力回转众生。要合当得大菩提时。必当得故。三得自在智。谓一切众生心所行境无量无边。直尔遍知。已为希有。况今入一而知一切。明其智德极自在也。四得自在身。谓不离果位现因身故。五得自在位。谓虽现因身而不转果智。以因果无二故。六得自在行。谓不舍随事行而入于无行。以约境理事无碍故。约智寂用无二故。七得自在悲。谓虽已成佛。为众生故。更于无量劫常修菩萨行。未曾休息。八显自在德。谓此自在希有之宝难值遇故。九摄化自在。谓转法轮明化法体。调伏者显法胜用。令逮得等者显所成益。见理深彻故云明净。又令离所知障故云明也。令离烦恼障故云净也。智照法界名为法眼。十结同诸佛。谓同三世诸佛所有清净功德及所住位地。所成行相所起大愿。此诸菩萨皆悉成就。与彼无二故。二具足下结德无尽可知。第二列名叹德中三。初列名中。行相遍周。备满法界。同名普也。二结数可知。三叹德十句。初一总。谓具得普贤无边之行及普贤无障碍愿。此叹普贤德也。别中一摄法上首行。二受持正法。上二叹普正法德行也。三化诸众生令佛种不断。此普化德也。又释次后更有佛兴故云佛种不断。四了知诸佛与诸菩萨次第受记之法。又释知诸佛灭后次第受记诸佛兴世。此普惠德也。五随诸下成佛说法行。此普眼德也。六随处现佛行。此普光德也。七令离惑染行。此普观普照德也。八能除业行。此普幢德。高出业障也。九令证法界行。此普觉德也。此上九种。若望宿誓今成即是普贤愿摄。如十大愿等。准配知之。若望现缘所作即是普贤行摄。是故此文亦愿亦行。序分竟

第二尔时普贤正受下明三昧分。于中有二。先入定。后辨益。前中普贤入者。以是会主故。表此行法普周遍故。从此出彼无边行故。花严定略作四门。一释名者。以因行花严感果相令显著故。二体性者。法界行门心海为体。以等持广大无限量故。三明业用者有二。一依此显说花严法故。无量寿经叹菩萨德中。言得佛花严三昧宣说诸佛经典。二依此显示花严行故。上云施戒忍辱精进禅方便智慧诸功德一切自在难思议花严三昧势力故。解云以诸行法深广多端。不能别说故云一切自在等。即下文二千行法也。四明位地者有四句。一若摄始归终。在第十地方得。如法云地说。二若摄终归始。在信位满心得。如前贤首品说。三若始终无碍。遍一切位。如前二说不相离故。以彼始终括中间故。四若超绝始终总不依位。如此文。但约行法以辨其相故。二益相中二。先动地以惊悟机缘故。后出声令闻法音故。即此亦是三昧业用。何故此中无加分者。以所显行法依前解起无别法故。若尔何故更须入定。谓摄解成行故。次入定。法不异前故。不须加。三昧分竟

第三起分以三昧事讫故。说时至故。定无言说故。是起也。安祥者审谛之状。谓从定起已。念不乱故云安祥也

第四尔时普惠下明请分。于中有三。初总举问意。二正辨问辞。三结请愿说。何故前诸会入定前问。此不尔者。以前诸会从相入实以成正解。此中依体发起以成正行故不同也。又未入定前。众则不知谁为说法。故先入此定。令众知主而起问故。何故普惠问者。表满法界之惠堪发起故。何故一人问者。表此行法各独成。故知诸菩萨云集者。知问时至。故知显法之缘已具故。此明问所依也。问普贤者以无尽行法从遍[上/口]法界而流出故。二明所问法中有二百句。其别行度世经。彼中别作六翻问。还作六翻答。古来相传皆依彼文。用科此经。即为六段。初二十句问十信行。二从何等发普贤心下二十句问十住行。三从何等为持下三十句问十行位。四从何等为宝住下二十九句问十回向行。五从何等身业下五十句问十地证行。六何等为观察下五十一句问因圆果满究竟位中行。此经上下总有三遍。说六位中。此当第二约行说六位。以普贤行该六位故。是故度世经云。唯为解说诸菩萨行。从始至终。令无疑也。彼经六段虽不配于信等六位。既云从始至终。次于末后明成佛果为终。故知最初信行为始。此不待言。故知决定约六位耳

第五大段尔时普贤下明说分中。初总告。二正答。于前二百门。一一皆以十门答故有二千行法。释此二千普贤行法略作五门　一约因果　二分行位　三显普别　四明互摄　五辨行相

就初中有四句。一约大位以分前五位等。总为因行。后成佛等总为果行。二细克而辨二百门行。一一皆悉彻于佛果。是故诸文之末悉皆结云即得佛等也。是则皆通因果二位。三或总属因位。以普贤位中亦现成佛摄生等故。四或总属果。以下文多云虽得成佛而不断菩萨所行。是故此行皆是果行

二分行位者。谓二千是行。实称位。位揽行成。位虚行实。亦有四义。一束行成位。束此二千分成六位。二总属位收。以行并是位中行故。三总属行摄。以普贤行体不依位故。唯有自分胜进即为究竟。四一行遍六位。一位该二千。如是无碍而不坏前后故。是普贤行也

三显普别者。谓一行相必遍一切。然恒不杂。不杂故别义元分。必遍故。普义该收。犹如锦文朱紫窠别故得成文。朱紫綖通织而非绣。当知此中行相亦尔。即普是别。即别为普。皆无障碍。思之可见。若尔此则普别具足。何独名为普贤行耶。释非谓守普而不能别。亦非作别而失于普。实谓能别而不坏普者是普贤也

四互收摄者有四重。一以位收位。六位之内一一各收一切位故。是故一位即具二千为万二千也。上云在于一地普摄一切诸地功德。此之谓也。二以门收门。即二百门中一一各收一切门故。即成二百个二百为八万行也。三以行收行。即二千行内一一各摄一切行故。即成二千个二千也。过亿兆名等也。四以略摄广。如此所说二千行等。下颂结云如大地一尘之说也。以此一尘之略说不离十方之广地。是故摄广亦无不尽。此乃等无极之法界超无际之虚空。下云虚空可度量。菩萨德无尽。斯之谓也

五辨行相者。随文解释应知。就此二千行中。依前六位即分为六。如前应知

初二百句答前二十信问。明信位行中。于中分三。初九十句明自分行满。二从十种入下八十句明胜进行圆。三从十种不可坏智。下三十句明二行究竟。就初中。何故最初明依果者。以是行起所依寂居首故。文中有四。一举数总标。二列名释义。三结说分齐。四叹胜劝学。下诸文中多皆具此亦有不具。至文当知。言依果者简非从因所生之果。亦非世界依报之果。但是诸行。或依前起后。或互相依。各得增长故以为名。即相依之果名为依果。又释如世界依果是众生所依。依果若增即失所依正报不立。今菩萨亦尔。以此十法为所住依果。此若断绝则失所依非为菩萨。如忘失菩提心即非菩萨。是故文中取不忘失以释成也。十中皆先标名后义。初句是总以菩提心是万行之本。是故二千之首。唯此建初。谓依此不忘菩提之心方令余行悉得生长。二虽内有胜心。若外无善友行亦无成。若不顺同善友无功。即非依果。是故要以随顺和合释成依果也。三虽遇善友。若宿无善根不能顺修。又亦病等余障碍故。是故要依宿善更增新行。四虽有宿善。若不得所行诸度之法无所造修。五虽得行法。若不达于理法虚通。即触途皆碍。是故依一切法皆得出也。六虽得理法。若无大愿即便滞寂不增菩提。七虽有自分之行。若不胜进广修无由究竟。八虽内具二行。要须外依胜侣。以一生菩萨于余菩萨为兄为长。方堪为依。此据极说。九虽依菩萨。理宜兴供于佛以成坚信。十要唯如来是究竟所依。以于菩萨能正教授令离倒故。又能正教授故。离倒教授故。第四叹胜劝学中。佛以无上果智为所依果。菩萨住此十法。当亦得彼故云也。又释菩萨未曾不依菩提之心。以恒不忘故。二菩萨未曾不依善友。以常随顺与和合故。三菩萨未曾不依善根。以常长养故。余亦如是准之。第二十奇特想者。前依因缘以成诸行。今依胜想以摄善根。十中初以随喜他善根作己善根故云奇特。二凡小等善皆堪成佛故云种子。三下至阐提皆菩提器。以悉有佛性故。四以一切菩萨愿同己愿故。五以一切法性净非生死故。六他同己体。他行即己行。又他所行是己行法故生自想。七一切法即是真如故。又一切法悉堪成觉故云佛法。八一切语言皆堪作法轮故云道也。九知菩萨善根皆是诸佛慈悲体分故云慈父也。十知一切如来悉同一体故云无二。此十皆超意外之想故云奇特。若得此想即得能转一切法之想。以一切法皆随想转此是佛德也。第三十种行者。以依胜想之解起此大行故次明之。十中初四戒行。于中初二摄众生戒。次一律仪。后一摄善。次一三昧行。次二智慧行。一加行。二正证。次一严佛土行。后二报恩行。第四十善知识者。以行起必示依善友故次明也。初一令发坚心。二令习修善。三令满度行。四令得智行。五令成悲行。六具辩才行。七无染着行。八无厌倦行。九成普行。十入佛智。第五有十精进者。虽遇善友。若不策勤无由进行故次明也。此中意为何义故修此精进。为欲作此十种所作。于中入一切法者智证入也。令众生灭恶者灭其苦因也。余如文显。第六有十正悕望者。由前精进。悕欲自他。令行究竟故次明也。于中初一约行本。次二约离过。次二约成行。一行因。二行果。次三约证入。一证位。二证法。三证道。谓由证法故离谤也。后二约胜进佛果。一佛愿满。二佛智圆。言无上平等大智悕望者。是佛地无功用故云平等。摄生无尽亦云悕望。第七有十法成就众生者此有二义。一以此十法通用成就一切众生。二各别成就一类众生。别中一成悭贪贫穷众生。二憍慢众生。三愚痴众生。四佷悷众生。五贪爱众生。六乐二乘众生。七不厌世间众生。八不欣佛果众生。九耶归依众生十耶智狡滑众生。以此十法。如次教化。令其入道故云成就。第八有十戒者。依前十法成就众生故。恶无不离。善无不积故次明也。此十中初者。若失坏菩提心即是破菩萨戒。乃至第十若取着如来身。即是犯戒。余亦如是准之。此十随其所应三聚所摄。第九有十种自知受记者。依前离过德成自验己行。必当得果决定无疑故云自知受记。一自验菩提心一向不回故。二自验所修菩萨苦行无厌足故。三设多劫修谓若须臾故。四自验不违佛教法故。五自知于佛所说深法决定信故。六自知所修善根悉具足故。七自知能令众生住菩提心故。八自知于善友不违其教同善根故。如善财等。九自知于善友起佛想成故。十守大菩提愿常不忘故。于此十行自验有一即知定当得佛受记。又瑜伽菩萨地中菩萨由六相佛受记。一安住种姓未发心位。二已发心位。三现前住。四不现前住。五有定时限。谓尔所时证菩提。六无定时限。谓不说时限与授记。又善戒经云。非但种姓人得受记。非种姓亦得受记。解云如不轻菩萨敬四众与受记者。约非种姓人。远亦当得故亦受记。如十信中记是种姓人。以约种姓决定故。如发心已去决定不退故。是三贤位。如梁论第六。十行菩萨名受记者是也。初地已上证理成就故受记。如地论。如第八地中受记是无功用行成故。如燃灯佛边得记等。此中十种约圆教。通诸位。据始。在十信中。余义如别说。上来九十句明自分行竟。下第二从十种入下即八十句辨胜进行。于中初十入者。既自分行成。次明胜进入诸所入之处。入犹证也得也。初二入大愿行。三入八万四千法聚等。四入十度等。五入行位圆满故云具足。六入差别大愿。七证入真性。八入严刹。九随心现神力。十入于一切世界示现出生。第二十种深入如来者。前明入因境。今明转胜入果境也。初一示成菩提。次八以三轮摄化。后一示入涅槃。前八中初四语业。一总举法轮。二所转巧便法。三能转之妙音。四正调众生。次二身业。一依身现通。二现多异身。后二意业。一定。二慧。又以三世诸佛悉亦同作如是作用故云亦共入也。此中信内亦得此法者。是圆教中普贤行相故也。第三有十种入众生心行者。前即上入佛境。此辨下入众生故也。初三总明入三世众生心行。次二别入善不善众生。六明入欲乐心行。七入根利钝。八入其种姓差别。九烦恼轻重。十起治不同。谓根未熟者待时故。已熟者不待时。又释时者待其熟时调伏故。非时者方便开觉不待时故。又因此十入。则普入一切同佛果也。第四有十种入世界者。前知众生正报。今知其依报故也。于中初二约染净。次四约粗细。次二约形状。谓伏者向下。仰者向上。后二约佛有无。又普入一切者以不离此十故。第五有十种入劫者。前明入处。今辨入时故也。于中前五入别劫。后五入相摄劫。前中初三别入三际劫。次二别入多少劫。后五相摄中。一以少摄多故云可数不可数。二以多摄少。三以会事入理劫入非劫。四从理起事非劫入劫。五二事相即。谓前可数等约缘起相由门。非劫等约法性融通门。此一切劫即一念者。通约二门无碍自在故。又由皆是数识所现故得自在也。第六有十种说三世者。前约劫。此约世故明也。于中前九别说。后一总显。别中未来说未来。既是无尽。过去说过去何不亦同耶。释以未来续起故云无尽。过去不起故不云也。又现在说现在。即与现不殊故云平等。过未说过未。何不亦同耶。释以过未之过未是无故。现在是有故不同也。余义如十世章辨。第七有十种入三世间者。前既达时劫无碍。今明入时中之法故次明也。于中初一总明所入。余九别明所入。此中一以语言为道。显所诠义故。二性者文字性。类即字界等。三施设者言教假施设故。四想者依想立名等。即名等异名如论云阿毗达摩想为标帜等。五名字者正显名句字身体等。六语言者明音声语业。与前何别者。前成能诠。此中通举。如恶阿等声。七无尽者明上诸门。并是虚假施设无有尽故。八离欲者体不可得故。九寂灭者性清净故。明此十法皆通过未等三世之中故云入三世间也。又释前语言道是所诠法。以是语言所游路故。二性是理性亦是所诠。此义理世间。次四是言说世间。后三是实相世间。又释十中初一器世间。次六众生世间。后三智正觉世间。虽有三释初释顺文。第八有十种舍离忧恼等者。前既达解时法。起行摄心故离忧等。谓行成遂志。舍离忧恼。时无空过。心无厌悔。于中初四供佛近友。求法闻法。此四自利行。次三摄生。一说法。二调令离过。三令住佛道。次一重明自行广。次一重辨化他广。后一明二行满足出生佛果。上来八十句明信中胜进行竟

自下第三从十种不可坏智下有三十句。明前二行究竟。于中初十种不可坏智者。谓称法而知更无改易故云不可坏。于中知众生等约染法。知三宝等约净法。知世界等约亦染亦净。知法界约非染非净。并可知。第二有十种陀罗尼者。前既知法不坏。此明持法不失故也。智论以定慧为体。佛地瑜伽增上念慧为性。以慧照法。念忆持故。智论中正翻云持。能持种种善法令不散失。如完器盛水等。或云遮。能遮诸不善心等不令生故。瑜伽等有四。谓法义咒忍与此十种不可相摄。以类别故。此中初二持教法。一持修多罗法。二持阿毗达摩法。三持理法。四持慧法。五持定法。六持异方语法。七持三世异义。八持辩才法。九持无碍耳根法。十持果法。安住者与相应故。第三分别说十佛者。前明持法。今辨解佛故也。又此信满明得佛果故明也。若尔后解位满亦得佛果。何不明耶。释以信初故。解准此故。此十佛义具如别章。今略释名。一自然开悟名为正觉。正觉即佛。二自体无碍大愿成满。愿即是佛。三万行因感故云业报。四万德积成任持不失。五应机化现。六称理普周。七唯心所现。八常恒在定。九真性不变。十无功大用名如意佛。如末尼珠等。又释同下十种见佛处。以彼释此应知。上来二百句答前二十句问。明十信十行相纯熟竟

自下大门第二从十种发普贤心下有二百句。答前二十句问十住中行法。于中粗分为四。初六十句别明十解中。初位发心住义。二从十种波罗蜜下六十句明余九住中所成内德行。三从十种说法下三十句明诸住位中外化摄生行。四从十种胜法下五十句明无碍殊胜行。就初中。创得住位以大心为本。是故最初明发普贤心。于中初三下救护众生心。次三上求佛果心。后四厌离有为心。具此三心乃名大菩提心。又释初六护小乘心初三护狭心。后三护小心余四护烦恼心。是故异于凡小名菩提心也。又此十心各是一行。亦不相收。以显无尽。各先标后释可知。二有十种普贤愿行法者。谓依前大心起广愿行故次明也。于中前九因行广。后一成果广。以普贤通因果故也。前中初二自行广。次一益生广。余通二行广。皆广立大无限之誓愿故同云普贤愿。依愿成行名愿行法。三有十种大悲者。依前普贤行法中别辨大悲。以深要故次明也。是故论云。菩萨以大悲本故别显也。用此悲心缘念众生无曾暂废故云常观。于中一苦逼无归。二设欲求依乃倒求耶道。三设欲向正乃贫无宿善。四设有小善乐着生死不能开觉。五设欲求觉唯倒行不善。六设有修善不能离欲。七设求离欲还复轮回。八无始无明久远所病。九不欲佛因。十失佛果法。又释此十初二颠倒众生。一无真。二逐伪。次四欲求众生。一乏出因。二无出果。三具缚因。四处缚果。次二有求众生。一深。二远后。二梵行求众生。一异道求。二求异脱。菩萨缘此起大悲心。要当救拔。四有十种发心因缘者。悲愿行起必赖所因故次明也。又前明所发心体。今辨发心所因故也。或四缘发心如瑜伽地持等。或七缘如智印经起信论等。并如前说。今显十缘以明无尽。于中前五下以众生为缘。后五上以佛果为缘。论云菩萨以菩提萨埵为所缘境此之谓也。前五中初一总。后四别。别中初二除苦与乐。后二除愚与智。后五中亦初一总。后四别。别中初二顺教见相。后二顺义显德。余义可知。五有十种亲近善知识者。既发心已。理宜近善知识。具菩提心。而得增长。故次明也。又释此上五十门行悉并同时说有前后。以依善友方能发心等故。于中有五。一标意。二征责。三总释。四别辨。五结数。别中十内。一身业走使。二语顺教命。三意不乖隔。四身心俱悦。亦庆见善友。五情无异求。六唯期出道。七同其胜行。八同彼要期。九敬师如佛。十同果圆成。又前六事友。后四同修。六有十种清净者。依前发心得此净报故也。此是发心家近果。于中初六三业净。谓前三体净。后三用净。次眷属下二明伴主净。后二明愿行净。并可知。上来别明初住位竟

下第二从十种波罗蜜下有六十句通明余住中所成内德行。于中初十正明诸住所行之行。于中十度并约深胜以释。是故檀中不云舍财等。乃云舍一切有净佛戒具佛忍等应知。第六般若约正体智故以如如为境。后四多并是后得智。第七应名方便。以能深入佛力故立智名。第十应名智。以能领摄诸佛法故从境为名。余并如前十行处说。二有十随顺觉知者。由前行成。能于所知无倒了达故云随顺觉知。于中一知依报染净差别多门。二知众生正报异类难思。三知缘起之法一异无住。四知真如法界平等离相。五知虚空无为无际。六七八知三际世界。又亦知一切俱是过去俱是现未。九知诸佛具万行在一念中。十知诸佛同一行以遍三际。三有十决定智者。由前随顺无倒觉知故能得此决定智成。于中初二知法分明。一知在于一念者显能知迅速也。二以无碍智知者显能知自在也。以无所知障故云无碍耳。次五知众生。一知心乐欲。二知根同真性。亦同是菩提根。三知烦恼细习。四知正使之行。五知所化善恶。后三知菩萨及佛可知(欠一门检余本)。四有十种力者。由智既决定多有堪能故明力也。于中初一总。余九别。别中初二解依他性如幻化。三解圆成性。四解所执性即空故无染也。五求行法。六敬养善友力者。以法从彼。得求力无坏故也。七由回向力能令善根至佛果故。八由信解力能于甚深佛法免诽谤也。九于求大果心坚强不退。又释前五解力。后五行力。五有十种平等者既有智力堪能故。能于诸事作平等真观故次明也。于中一情绝怨亲。二真俗一味。三染净理均。四一道无二。五同会一性。六果法岂殊。七因无异愿。八十度齐备。九行契理原。十法身等无二。又释前五行等。一等悲。二等智。三等净。四等行。五等修。后五德等。一果德等。二愿行等。三六度等。四因行等。五法身等。六有十种方便佛法句者。前既平等正证理。宜起于后得巧便设教故次明也。于中初知一切法。但有言说。此约遍计性。二似有如幻。三速灭犹电。四无性从缘。五缘作本净。六言有但名此上约依他性。七无生真。八无相真。九无性性真。上约空如来藏。十具德法界是不空如来藏。由以佛法句显此十义故同立此名。上来内德成讫

下第三十种说法下有三十句明外化摄生行。于中初十于教能说。次十于法能持。后十于言能辨。初十中初二说理法。一深一妙。次四说行法。一具德法。二佛智法。三顺度法。四生果法。后四说因果法。初一说三世染法因果。后三说净法因果可知。二有十种受持者。前既宣之于口。今此蕴之于心故次明也。于中初七记因法。后三记果法。前中一记持行法。二记持教法。三记顺法之喻法。四巧令生解法。五令生总持法。谓少文摄多义等。六答难断疑法。七菩萨行位法。后三中一佛定法。二佛慧法。三佛通法。三有十种辩者。前明记持在心。今明巧宣于口故也。于中一不取情谓故名为辩。是知若在性执。纵巧言百端未足为辩。二顺法无行。三显无著法。四此辩亦空方为辩也。五体无无明。六辩同佛持。七辩法令他自悟。八于无名相法。巧以名言说令他于言不作言解。九说众生义门辩。上应机令喜辩。又前五是无作净辩。后五有作净辩。上来外化摄生行竟

下第四说十种胜法下有五十句。明无碍殊胜行。亦是当位成满行。于中初十胜法者。前以辩才无滞遂显德相挺过凡小故云胜法。于中一悲胜。二智胜。三修胜。四行胜。五戒胜。六回向胜。七策勤胜。八降魔胜。九因行胜。十成果胜。二有十无著者。前行德超升故。今于境无执故云无著也。又前即行高殊胜。今即下离染着。此十皆是自心显现意言所作。是故智慧于中不着。初于化处不着。二于所化不着。三于化法不着。四正作化业不着。五化所成善不着。六应机受生不着。七于自本愿不着。八于所行行不着。九于因不着。十于果不着。由自安住此无著智。即能速转异念众想。得佛无上智无著。三有十平等心者以成无著智故。于众法中心无分别故云平等心也。此与前十平等何别者。前约法辨平等。此约心辨故云平等心也。于中初八约因等。后二约果等。前中一于所长养。二于所发言。三于所化生。四于所化因果。五于所知法。六于染净土。七于好丑人。八于所行行。后二中一功德智。二正证智。于此十中皆不生异念故云平等心也。四有十种出生智慧者。从前平等体寂出生后得胜智故云也。于中初入众生性者证入众生真性也。出生智者入已出生后得智也。余文入出皆准知。二刹无一异者约体俱绝故。又摄相从体故明无异。以体从相故明无一。又多则一故无异。一即多故无一也。三知世界如帝网。四知土形相。五巧入法体无一无异。三释同刹应知。六知异类之身报。七知倒惑身之因。八知究竟一乘通同别也。九知法界自在德。十知佛种不断德。五有十种变化者。前依正证起后得。今依后得起自在用故次明也。谓转变本无。化现令有故云变化。于中初一变他众生身。如文殊变鹙子等。二变自身作异类等。三变染刹为净等。四变现香花等。五化现言声等。六化现愿行。七化现调生如满足王等。八化现成佛。九化现转法轮。十化现舍利等。又释此十亦是以实用化显其平等。上来四段二百句文总是释十住位竟

自下大门第三从十种持下有三百句。答三十句问十行位中行法。于中分三。初六十句明大志旷远行。二从十种不思议下九十句明定慧业用行。三从十种园林下有一百五十句。明德备成满行。就初中有二。先有二十句明依起大欲行。后四十句明依起胜念行。前中初十持标行所依。谓依此任持力方能起大志。此中通摄地持中三持及地品中十持准辨应知。于中初三则三宝力持。众生是僧宝也。四大悲所作名业持。五十大愿力令行相续。亦由佛力持故。佛果化用尽未来际。六十度行力住持所余。七众生及菩提为所缘境持。起菩萨悲智行心。八以真如理为妙也。九福。十智。各有胜力故云持也。问此持与前十陀罗尼及十种受持各何别耶。答陀罗尼是总持文义等。受持约领纳忆持等。此中据加持等故不同也。二有十种大正悕望者。依前持力起此广大无边欲乐名大正悕望。与前正悕望何别者。前约自分故不言大。今据胜进故不同也。何故起此大欲愿者。以行成由此故也。上文云智慧王所说。欲为诸法本。应起清净欲志求无上道。此之谓也。于中一定望顺佛令喜。二定望供佛令尽。三定望同法成行。四定望长时修行。五定望离畏。六定望令众生先已成佛。七定望尽严刹海。八定望令众生灭恶因果成善因果。九定望直心见佛闻法。十定望尽穷来际转大法轮。第三有十种深入佛法者。明悕望不已便能深入。是故依前大欲能尽佛法深远边际故云也。下四十句中初二十为所依。后二十为所起。前中初此十深入内证。于中初四入器世界佛法。一切世界一一各别入一切世界。故云一切世界悉分别入一切世界也。次二入众生世间佛法。次三入智正觉佛法。后一总就法界入于佛法。以理就行分故云于无一异而说一异。谓五乘位异成佛为一。行同归理故云入无所入。二有十种依止者。前显行深入。今辨所托缘。于中一依善友教授。二依多闻熏力。三依善住处资缘不乏。四依悲力。五深证大行。六依满本愿力。七依本菩提心。八依佛果。是所求故(脱第九第十须检余本)。三有十种发无畏心者。前既有所依。道令行心深胜。于可畏事。能无所畏。以无有难作而不能作故也。于中一以奋大勇猛故。能于十种难作事中而悉能作。一恶业难灭。二遗法难护。三恶魔难降。四身命难舍。五外道难伏。六物心难称。七大众难喜。八八部难调。九下乘难离。十上行难修。于此十难皆无畏也。又智论第六云。菩萨有四无畏。一以闻持善说。二知根欲说令得解脱。三一切方中不见有难而不能答。四不见有疑而不能释。四有十种发无疑心者。前以于难无惧。由此自知所作皆易故无疑也。于中一以十度摄生。二三供佛严土。四大心无疲。五满本大愿。六定作世灯。七巧说诸法。皆堪摄生。俱是佛法。八定成正觉。九会事即理。十灭倒显智。上来六十句明大志旷远行竟。下第二从十种不思议下九十句明定慧业用行。于中分三。初三十句明融慧超情行。次十三昧下二十句明深定普周行。后十法门下四十句明业用自在行。就初中。初十约行。次十约语。后十约智。约行中有十种不思议者。由前心决无疑故令所修无测也。于中一乃至一念善根悉至佛果故云不思。如尼俱陀子小树大。二由本愿力无思任运果用无尽。如灭定前愿力等。三如幻法不有而有。四依无住而不失善。五得理不舍事。六在因能现果。七得果不舍因。皆不思议也。八解法无碍。于中五对十句。一约迷悟境。谓凡于无相妄见有相。圣于凡有悟见无相。又即相是无相。无相即是相。一事双离故难思也。余对准之。九解发心等菩提。以始齐终。次句以终等始。后心佛及众生是三无差别。解心不错故无三倒。三倒如前发心品释。十中四句。初尽流不尽流而无二。二佛法世法一而不杂。三摄事同理入而无入。四释成无二。不变者一味故无二也。是故俱难思也。二有十种巧方便微密语者。正以内行难测遂令发言巧密。泛论密语有五种。一说彼深密法故名为密语。如上性起中名如来密藏等。二以一言说一切法等为密语。三以近而不闻。如鹙子如聋等。远而无限。如目连寻声等。名为密语。四言近意远。如说三乘为究竟等。亦名密语。五以异言说异法。如说觉不坚为坚等。今此文中唯约初义说。于中初一约教法。得意玄故。会同异故。二示同涅槃密现受生。三如东方入定西方密出等。四巧说众生善中有恶等苦中有乐等。五巧说众生不染而染为垢。染而不染为净。六巧说一中有一切等。七坏处有成。如法花中天人见劫尽此土常安稳等。八于佛普遍现生入灭。见此密处而发言故。九解众生。即涅槃不复更灭。而不舍大愿摄生。以为巧密。十自悟不由他。而求善友不息。以为巧密。三有十种巧方便分别智者。前既巧说密处。今智达明了故云也。初二知世界一净一染。次三知众生机器。次三知三乘行相。后二知世出法。又释初二器世间。次七众生世间。后智正觉。又释初二何处化。次三何所化。次三化置何处。后二以何法化。上来三十句明融惠超情行竟。第二有十种三昧下二十句明深定普周行。于中初十明定体。后十明业用。又初明深定。后显普周。前中一明入定处。谓遍一切种种刹。二明入定身。谓以一切众生身而入定故。如童子身入正受等。三明定照法实。四定中见佛。五定持多劫。如十明品第十智明说。六定出身云。如海幢比丘等。七或以佛身示现入定。八为觉悟众生入定。后二各于一念中得一切菩萨定慧。具足二行入定。又初一入定处。次一入定身。次六入定用。后二入定时。二有十种一切处者。前明入定。今辨从定起用遍一切处也。一悲托处。二身依处。次三起解处。一解正报根性。后二解依报劫坏。三灾中略无风灾。次一是所供处。次二所成处。一依一正。后二是所作处。一惠一福。上来深定普周行竟。第三有十种法门者下四十句明业用自在行。于中初十明自在现法门。初一身普现。二多处异现。三令多入一。四不失住持。五上同果现。六无处不遍。七无时不遍。八一刹现多身。九一身现多处。十一念普示现。此等并是法性融通门等故名法门也。二有十种神通者。正以身现法门。业用无限故云也。一宿命。二天耳。三他心。四天眼。次五神足。一现神力。二示多身。三速往来。四能严刹。五现化身。后一流尽示成菩提。此十皆以通慧为体故名智通。悉从定起齐名出生。三有十种明者。前以无壅曰通。今委显为明。于中初一知众生业果差别。二知众生于寂灭境起净信心。三知众生证入理智。上三知所化。四语业。五意业。六身业。此三显能化。七于境转分别想为正智因。八知理平等起行无碍。初知三性理不碍起行成佛。九知众生真心称理随缘显事不失化用。于中初知称理现事不失化用。二何以故释成无碍。初中又初一向化他。二不失自行。三何以下释成。前中初四句知众生真体。二知因下八句知众生缘起相事者。是从因缘所生报也。三知愚痴下六句三对知众生染净差别。四知生死下八句四对知众生理事无碍。五知转下八句四对知众生道器差别。初知转依未转。二知治道起未。三知惑灭道立。四知行成根报别。下句总结成化。谓称缘起而观察也。十中有七。初善能离着。二不见下善起行愿。三见一切下善植德本。四自在下善起胜通。五知种种说下善能照境。六永断下善益自他。七除灭下善能得果。并可知。余义如前十明品说。四有十种解脱者。前大智明起。今辨无明障尽故云解脱。解脱有二种。一作用自在名为解脱。如上不思议法品十种不思议解脱等。二于缚离系名解脱。如此所说。于中初四于凡夫得脱。初二脱惑障。一钝使。二利使。次一脱业障。后一脱报障。五于小乘得脱。六于地前得脱。七于地上因位得解脱。八于微细着微细碍得解脱。亦是道累外自在故云解脱。脱后二门也。上来四十句明业用自在行竟。下第三从十园林下一百五十句明德备成满行。于中分四。初四十句明报德圆满行。二十种发不动心下二十句明心住坚深行。三十种智慧观察下五十句明智德殊胜行。四从十种不可称量下四十句明德重高深行。就初报德圆满行中。初十游赏园林。次十栖止宫殿。次十于中娱乐。后十将出束带故曰庄严。就初十园林中。一一皆初举园林名体。后以义释成。谓游观适悦故也。前七自分因行。后三胜进果行。前中初二利他行。后五自利行。一时。二处。三违。四顺。五修行。以道品等从佛流出故云慈父境也。后三中一念果法。二现法轮。三示正觉。二有十种宫殿者。前园林外游。今宫殿内安故次明也。亦皆先标名体。后释显义相。谓若妄失菩提心。即令正行无所栖止故云也。此一为行本。次七明利他行。初四化三界众生。色界中分二故。四梵者四无量也。无色是难处。为灭彼难菩萨生中也。次三中一通化。二化眷属。三化憍慢。后二自行成满。一修因。二得果。三有十种乐者。既住宫殿情忻胜利故云乐也。于中初八因法中乐。后二果法中乐前中初六自利法。后二利他法。第四有十种庄严者。既乐心成以胜德自严故次明也。于中初二力无畏。次二义法辩。次二愿行严。次二摄刹雨法。后二持行现化。上来报行竟。第二有二十句明心住坚深行。于中初十心坚。后十深入。初中一舍有心坚。二向法。三供佛。四悲观。五慈摄。六专求。七常修。八信坚。有根信者生佛果故。不浊信者不杂无明故。离垢信者不求世有故。明净信者正证理故。供佛信者向果故。不退者因行坚故。不坏者外缘不动故。九穷果。十行圆。二有十种不舍深心者。以行坚不动乃穷达深理故云也。又令此心不离殷至。故云不舍深心也。于中一智。二悲。三显化意。四近友。五供佛。六求法。七持净戒。八摄同行。九持佛法。十修愿行。下第三有十种智慧观察。下五十句明智德殊能行。于中初十者。以能心殷不舍。遂令智慧巧观所作。于中一观教法。二观行法。三观通力法。四观巧便法。五佛持者。若约用明佛神力加持。若约体法身住持万德。上观法自在。六内持。七外说。上说法自在。八观深。九观广。十观多。十一观无碍。上观法深广。是增数十故。剩一门也。二有十种分别者。既能观察。遂能简择诸法故云分别也。于中初二分别依他起性。一法一喻。次一知遍计性无所有故无可诤也。后七分别圆成实性。一知恒沙功德。二体实无依。三坚若金刚。四则是法身如来。五法身体寂。六证道所摄。七体相一味。三有十种无垢者。由简择深法除障离垢故也。此中离十种垢。一无异求垢。二无疑惑垢。三无邪见垢。四无所知障垢。五无不欲佛果垢。六无讷言垢。七无怯弱垢。八无障大悲垢。以悲是菩萨所住故。又无障十地之无明。以十地是菩萨所住故。九无散动垢。十无微细碍着垢。又释初三约心净。一深心。二信心。三解心。次一约境净。次五约行净。后一约果净。四有十种智印者。以离垢障令德坚固揩定不动故次明也。于中一于安受苦境。忍智不动故明印也。变易苦者是坏苦也。二于他不饶益忍行决定。三于深佛法信忍决定。即法思忍也。四决定成佛当度众生。五决定解教等诸佛故。六大欲决定有十一句。初善欲是总。余十是别。七决定不惜身命求佛果。八于善根未熟众生令生长。九已熟众生令入法。十因圆果满。五有十种智慧光明者。既行能决定遂令照用无碍故也。于中皆先明所照。后显能照。初二求果见佛。次二见机授法。次二依友示佛。次二摄生说法。次二佛持行满下第四有十种不可称量下。四十句明德重高深行。于中初十明尊重行。次十勇修行。次十高胜行后十深广行。初十中明行用难测。凡小莫窥故云也。于中一住真不证难。二成善不取难。三解理不疑事难。四长劫无怠难。五得灭不住难。又释四不厌生死。五不住涅槃。六无劫说劫难七非行起行难。八解了唯心难。三界是处识。三世是数识也。心无边者通摄余一切法也。九悲广无限难。十得果不受难。由此难测故过凡小。言不能称。智不能量故云也。二有十种发无懈怠心者。既行用超过。遂令勇猛无间故也。于中初三破邪授正。次二满行摄生。次二成果调物。次一多刹现佛次一一切广施。后一一念顿解。于中有五。初举所解之法有九门。二如是等下对辨能解之相。三于一切下略明解不颠倒。四无二智下广显无倒解相。五法界等下辨无倒智业用。三有十种须弥山王正直心者。正以勇猛中成大心决定。正向菩提不可倾动故云也于中初一修能证智决定。二观所证理决定。三决定令此福慧趣入所证无垢白净真如。四决定成熟求法之行。离盗法者。谓从他闻法言我自解。不称赞师。准观佛三昧经。堕地狱如箭射也。起一切施心者欲拟法施于一切众生故也。五大忍度生行如如舍者观如舍相故。大忍法者大智现前故。六成就超魔境界行。于中四。初成就胜法。二不味此胜。三但求正法。四举因释成。七精进勇修行摄。论云愚修虽小时怠心疑已久。佛于无量劫勤勇谓须臾。八不舍恶人行。九孤子勇修行。十即空成有行。于中。初无有一法等。正明见理实无。二而菩萨下明不舍悲愿。三举法释成。谓即此无所有。出生菩提故。四而此菩萨下明称理造修。亦不生如是恐怖。若一切空我有何义求无上道也。四有十种入深智慧大海等者。前明志山坚耸。今显智海宏深故次明也。谓以如大海之智慧。深悟证入此十种法。成无上菩提故名也。非是入此智慧海中。以别显中云入无量众生界等故得知也。一入众生界无量。二入世界无量。三入虚空界。四入法界。五入三世佛无边善根界。六七八入三世诸佛界。九能供多佛。十能求多法。上来总答第三十行位行相竟

自下大门第四从十种宝住下有三百句。答前二十九问。明十回向位中行相差别。以十自在中章门十句不在问中故。有三百答二十九问也。于中分三。初一百一十句明回向位中行体坚固义。二从十自在下一百二十句明行用自在义。三从十种游戏神通下七十门明行位圆备义。就初行体中分二。初四十门明行体成就高栖彼岸。二从十不坏信下七十门明行体离障摄诸胜德。就前中初十种宝住者。住于正法可贵之所故云宝住。又以无住为住。亦名宝住。于中一近佛。二闻法。三自在受生。四知法自在。谓总别无碍。五智断自在。谓资粮道息。加行道离。无间道断。而不证实际者。异二乘故。留惑故。到实际岸者。到法无我际故究竟也。六悲智自在。谓知众生空而行化度。七知理事无碍法。八知理无不碍起行。九于空善巧所愿不虚。十闻多佛异说善解会通。谓以四意等而决故也。以佛智不思故多异说。法体不殊故云言无二也。二有十种发金刚心者。既所住可贵。能于大乘无限齐法。以坚固心穷尽其际故名庄严等也。于中一知三世无际法。二引多菩萨自策励已。三严无际世界。四福惠治及无际众生。五以善根供无际佛。六深解无际佛法。谓释中云一切摄取者。谓无相不坏相为摄取。以无相摄相故。相摄无相故。云一切摄也。七能忍无际苦恼级者。俗书云。斩贼首为级。赐爵一级。因以为名。住不二法者。苦及我不二。即法思忍也。八无际无际时。于无际无际处行菩萨道。九以心要成无际大行。十即寂起用行。于中四。先住空寂。二而亦不舍下明起事用行。三何以故下举大愿释成。四善知是法下明双融大愿行。三有十种发大事者。于所作大事令发起现前故云也。于中初三福业大。次三化业大严土为摄生也。次二明胜进摄福。九成佛。十说法。四有十种究竟大事者。前于大事但能起现前。今明所作成满故云究竟。于中一供尽佛境。二满本所请。三求尽正法。四次二增因出果。次二愿行成满。后三供人闻法。第二有十不坏信下有七十门。明行体离障摄诸胜德。于中初四十门明信惠善巧。后三十显心行摄位。就前中初明十种不坏信者。于深入法净信不坏。破不信障。初六信行缘。后四信行体。前中信众生者。信是所化悲境故也。又信其有如来藏佛性等故。二有十种受记者。既内怀坚信。外蒙记别故有受记。前明自知受记。今明诸佛与记故为别也。于中一种解脱分善根闻法毛竖等。二得初地见谛名谛满等。三于修位中广行诸行。四对现众前。五对众不现前。六因悟自心本之觉义。七法忍位成。八化功已立。九劫数已满。十位至自在。余如前说。三有十种善根回向者。以已善根顺同善友故云也。初二同心。次一同行。次二同修。次二同治。谓正念能治现前。清净所治已离。次一同位。后二同证。则无异。同者谓此菩萨善根回向与善知识善根。一体无异故名为同。非是别体相似名同。四有十种得智慧者以回向德熟得智能自在故明也。于中初四自分。一解施。二乐法。三入佛境。四能遣疑。后六胜进。一悟实。二入权。三解小善生佛。四具德。五往佛。六悟法。由解此等故得智自在也。第二有十种发无量无边广心者。下三十门明心行摄位。于中初于无限之境发称境之心故云也。一广念所求。二广念所度。次二广念所显。一会事。二显理。次二广念因果位。七广了业报。八广严刹。九入大众。十观圆音。二有十种藏者。既以大心普周故。令德穷海奥故次明也。一字藏。二义。三持。四辩。五惠。六通。七巧。八见佛。九入劫。十喜敬。此等皆有含摄蕴积同名藏也。三有十种调顺者。既积德盈满刚犷斯尽故。次明也。一离谤。二离疑。三舍慢。四舍自见。五背下乘。六离散动。七舍异见。八离三不善。九降魔怨。十离六弊此约遮释。若就表言。所作行熟至顺调柔故也。上来释行体坚固竟

下第二十自在下有一百二十门明行用自在。于中初十总明自在。后一百一十别显自在。前中十自在者。作用无碍延促由已故云自在。此中十自在同第八地中释。此中庄严彼名财物自在。此中解脱彼名信解自在。准梵本应名胜解。此中神力彼名如意自在。一一皆标名后释义。同前可知。法集经第二卷中亦明此义。第二别显中。初列十章。后以百门次第解释。列名中第九约身力。第十约智力。余如下释。后次第释中。先辨众生自在。以是所化故。于中初五于众生中转变自在。后五于众生中作上首自在。又释初一总。余九别。别中起其愿。乐想不断名持。二依物授法。三令得益名变。四令入法界。后五上首身可知。二刹自在中。初三以粗入细自在。渐次深入乃至无尽。次三身上无碍自在。一身满刹。二刹满身三撖令动。次二严刹自在。后二现佛现刹自在。何故皆得如是自在者。释略有五义。一了达缘起相由门故。二达法性融通门故。三定力自在起胜通故。四得解脱力能回转故。五智力了如幻梦法。随自心现得自在故。并由所知障尽故得然。余上下文皆同此释应知。三法自在中。一一多自在。二要由智出。三理事无碍。四总别善巧。五无言之言。六巧转一乘。七多劫说一。八即染成净。九巧现多端。十体不碍用。四身自在中。初二自他无碍。次二果德无碍。次二依正无碍。次二定慧自在。后二理事自在。亦是染净自在。真妄自在也。五愿自在中。一因愿同求故。彼即自也。二果愿同现皆为众生。三愿令得果。四常愿不息。五无身现身。谓离凡夫识身不着二乘智身。又离取相识身。亦不着无相智身而能现身。由愿力也。次二同事教化。八修因多时。九成果多处。十普雨法雨。并由愿体无障碍愿力不待作意。自然成就故名愿自在。六境界自在者。于分齐境界回转无碍。于此十种胜劣相违境中。皆得胜现劣故称自在。一理事相违。二耶正。三染净。四因果。五静乱。六真妄。七凡圣。八悲智。九体用。十大小。谓处大现小故也。七智自在者智。不自显。约所知显之。初二能化智。一说。二持。次三知所化智。一知根。二知欲。三知惑治。六亦上入十力。七下知三世。八示正觉。七知根业。十达音声。八通自在中。一神足。二天耳。三流尽。亦是应成。四语业。五宿命。六幻通。七义法智通。八教法智。九敬护。十理法智。九神力自在中。初二幻通力。尘中现者尘内先有非是外入。次三如意通力。初二正中现依。谓毛孔是正报故。后一毛系围山。次三于劫自在。一多少自在。二示现三灾不恼众生。三劫灾坏时持其资具不令坏损。后二于处自在。一远掷。二解空。十力自在。是悲智之力故不同前门。一调生力。二严上力。三法身力。四常修力。五开觉力。六摄行力。七度生力。八自觉力。九种智力。十大悲力。各先标名后释义。皆业用不屈称为力也。下通结可知。上来行德自在竟

下第三十种游戏神通下七十门明行德圆备。于中初二十门明行德殊胜。后五十门明行德圆满。前中初十明住志行成游赏自在故云也。于中初二以染正报对净依报以明相作。此中有四种自在。一依正相作。二染净相作。三染正净依相作。四此上相作已甚希有。况各不坏不杂故为极自在。名游戏通也。下并准之。次二以佛身对二乘明相作。问佛是果人。菩萨因人。何故因人能令佛身作二乘耶。答此是普贤位中菩萨与佛齐故。又释是佛下就容其作故。次二因位果位相作。次二生死涅槃相作。而不着涅槃者生死不染涅槃也。亦不究竟无余者明生死不亡也。此中唯是果位方便净涅槃。此中非是性净涅槃。性净涅槃与生死相作不足为奇。后二明定用相作。二十胜行者。以游履自在故。令所作皆悉精微故云胜行。于中初三摄生行。前二以法就机。后一摄机同法。次三知法行。一因果相出。二有为无为相出。三生死涅槃相出。后四三业行。一语业。次二身业。后一意业可知。第二有十力下五十门明行德圆满中。初十力者。正以德胜智用堪能故云力也。皆有标释。于中初七自分因力。一不染三界。二不坏四信。三巧修行上三自行。四知物心。五满物愿。六常化。七现乘。上四利他行。后三胜进果力。一现佛身。二悟菩提。三转法轮。二有十种无畏者。正以智力功强外无所惧故云也。于中初二具持文义答难不畏。三了达二空不畏妄念。四威仪无缺畏。五三业无失畏。六不畏魔等。七无有不能闻持畏。八悲愿不畏生死涅槃。九示同二乘而不畏二乘。十不畏机感而不能现。三有十不共法者。正以智力雄猛凡小莫窥故云不共。又释既皆云不由他悟。即知行起。自心非他所共故名不共。一自己行。二化他行。三回向行。四巧便行。于中有三。先巧离二乘。二于生死中下巧顺世间。三于世间下巧穷彼岸。五智慧行。于中三。先总举定慧。二常在涅槃下别辨十门自在智慧。三菩萨成就下总结叹胜。六三业随智行。七悲代他苦行。八慈受他供行。九自净净他行。十位满常修行。四有十种业者。正以内德不共令所作必然故云业也。于中初一约处。次三约人。次一约时。次二约用。一身行。二身光。后三约护持。一护法。二说法。三愿持。此等多约境事为名。各有标释可知。五有十种身。由业因既备身果现前故也。此亦是回向位满所得十身。初二约体以不来入趣故。后于趣中亦无可出去故云也。次五约用。一顺同世。二不失真。亦是世间所知真实。三用尽来际。四五正以随缘不变故得坚固不动也后三约相。一福相。二理相。三果相。此十身与前十行品中第九行内十身有同有异。相摄可知。上来有三百答十回向中行相竟。此上十业十身自古诸德多将入后十地位中收。然别行度世经六翻问答中。此在第四末。今依彼经。科判此文入回向摄。自下大门第五从十种身业下有五百句答前五十问。十地位中行相。于中分四。初一百二十门明十地中三业殊胜行。寄在于初地。二从十种方便下九十门明造修离障行。寄二三地。三从十种离生下九十门明造修纯熟行。寄在四地已上位。四从十种足下二百门报相圆满行。寄八地已上位

就初中分三。初二十明身业行。二次四十明口业行。后六十显意业行。就初中先依身起业。一遍一切处。二趣一切机。三同一切生。四游一切刹。五诣一切佛。六擎一切土。七碎一切山。八现一切事。九覆一切生。十现一切佛。皆是身之作用同名身业。二有十种身者。准前问应名净身业。下口业中亦同此。又此是行法为身故不同前。于中初二六度四摄。次二慈悲。次二福智。次三体用。后一成果。第二有十种口下四十明口业。初十明口业体应名语业。以口是身分摄故。于中一离恶口。二离两舌。次二离妄语。一粗二细。余六离绮言。此并约遮释。若约表十种各显一德。如文可知。二有十种清净业庄严菩萨口业者。显语业净因以严其语故云也。于中初二摄法行。次二离过行。次二摄善行。次二法施行。后二闻法行。由此十行使语业严净也。三得十守护者。由发言诚谛。幽灵悬鉴故加守护。于八部之外。加梵王众及佛法王为十可知。四成十大事者。由内因诚实。外缘加护。致令语力广大成其所作故也。一能断疑。二能普至。三动其根。四入其性。五拔其使。六除其习。七生净信。八起深乐。九令证理。十得大果。第三有十种心下六十门明意业。于中初十明意业体。后五十显意业用。就前中一广心。二深心。三胜心。四净心。五利心。六坚心。七无染心。八希有心。九智慧心。十无边心。此并是意乐之心也。二有十发心者。心体既满理。宜发起胜用故也。于中初六明利他心。次二自利心。后二胜分中利他。又释初一总。余九别。并是利他心可知。三有十种满心者。前既发心修成所作遍满法界故云也。于中一悲心广。二智契深。三解脱用。谓是九世即一念名为解脱。四满八相。五遍知器。六了真谛。七解俗网。八满无生。九达心界。十现等觉。四有十根者。由前心满堪为法器。能出生故名根也。一信根。二乐根。谓信增为乐。三精进根故不退也。四定根住位。五慧根。六悲根。七坚智。八明慧。九为法身器。十作报身根。五有十种直心者。以生后体立正向所作故云直也。于中初二直背下。次二直顺上。五于违不动。六于顺无染。七随法能持。八悲不择处。九入深义。十习广教。第六有十深心者。由前正向令信乐殷至故曰深心。于中初二深离障。次二正入法。一行二解。五知法无碍。六入异方便。七成辨所作。八定深。九愿深。十悲深。上来初地行相竟

下第二十种方便下九十门明二地已上行相。于中分三。初三十句明智慧方便行。二从十种入众生下三十句明慈悲方便行。三从十种趣下三十句明悲智究竟行。就前中初十方便者。巧修正行故。初六是舍相方便。巧修六度可知。后四是摄生方便。一慈与乐。二悲代苦。三授智。四与法。二有十种乐修者。正以善巧无碍而能欣求诸行故云也。一乐胜善。二乐异严。三乐广大。四乐甚深。五乐四无量。六乐持戒。七乐慈忍。八乐明解。九乐神通。十乐听法。上辨因。后一显所成果。三有十种解脱深入世界者。谓乐修不已。能以解脱胜力令一切世界相入等故以为名。于中初以多入一。二以一入多。三一佛满十方。四示界全空。五同佛庄严。六一菩萨满一切。七入毛孔。八入众生中。九一果处遍。十一妙音满。第二有十种入众生下三十明悲方便中。初十明无缘大悲。巧会物性故名入众生性。又令众生界有所入故名入众生性。性亦名界。界有二义。一分齐义。二为因义。文中前五明相入自在。一摄事入理。次二多事入一。四摄末入本。五多界入一。后五回入化用。初一入所化器。后四入能化相。初一入随类相化。余三可知。二有十习气者。由善入物性令成串习气分。以为行因。即熏成习气也。一行本气。二成行气。三下化。四上见。五受生。六大行。七十愿。八十度。九理智。十量智。三有十炽燃者。前习因既立。能发生现行繁兴大用故名也。初二严土摄生。次二依缘成善。次二慈悲。次二行巧。后二因果。第三有十种趣下三十句明悲智究竟行中。初十趣者到行到果名为趣也。初二六度三学。次二妙智真境。次二依法成善。次二依人起行。后二成佛说法。前八趣因。后二趣果。二有十种事能具佛法者。由此十事现前。令诸佛法无不成满故云也。初二信人法。次二离过失。次二信入胜境。次二住正离耶。后二念佛信果。于此十中遂作一种。如教成就。即令佛法皆悉具足。况具十事。三有十种退失应远离者。既能具足佛法。便能修道在缘不退故云也。初四失利他行。后六失自利行。观令远离

下第三有十种离生。下九十句明四地已上至七地来出世间行。于中分三。初三十句明因行体广。二从十种名号下二十明行用殊胜。三从十种无量下四十显行德成就。前中初离生者是舍有为行故名离生。又得无生故名离生。又显行熟纯离生涩等过患故名离生。广释如婆沙中。又大小乘同辨离生位在见道。今此寄在四地已上出世间位。于中初二约智悲。次二就舍着。次三离惑就生。若二乘舍惑离生。不能随有亲近众生。菩萨反此。八离而不离。九不离而离。十得果不舍因。二有十种决定法者。正以离生之患能得法决定。初五自分行。一生佛种中。二入佛境界。三解。四行。五成善。后五胜进行。一住果体。二得果用。三顺果位。四同果身。五同佛住。三有十出生佛道者。于法既决。能从缘出生圣道故云也。于中初二顺人信法。次二愿善不虚。次二时处广长。次二无间普遍。后二愿行摄生。第二有十名号下二十句显行用殊胜中。初十正以实德内充。嘉名外响故云也。菩提是所求。萨埵是能求之士。以从所求名菩提萨埵。于中初四约所求菩提境为名。一总举菩提。二约过小乘。三约过因位。四约体胜殊。次二约自行为名。一惠无比。二上精进。次二约所知解为名。一能示上法于众生。二能知十方于诸佛。后二约德为名。一福高。二惠深。又如瑜伽第四十六云。一切菩萨随德假名有十六种。所谓名为菩提萨埵摩诃萨埵。乃至十六名为法师。显扬第八。庄严论第十二皆同此说。庄严论云。此十六名皆依义立。一切菩萨总有此名。又商主天子经有五义立名。一于菩提分住持入故。故名菩萨。二入大乘故。满大智故。故名摩诃萨。三不可求法智德入故。故名最胜萨埵。四不与烦恼共住。为诸众生灭烦恼故。发精进故。故名净萨埵。五令诸众生行净道故。故名极净萨埵。二有十种道者。以名德称实遂得行解虚通故云道也。于中约增数以明十种。初一约行本。以菩萨万行皆菩提心为本故。二约实惠方便惠。亦是正助二行。三约三空定。游出三界故云道。四约四行。除四障。一业障。二嫉妒障。三谤法障。四乐世有障。亦是异求障。智论云。行是悔过等四行。疾至阿毗拔致地。五约五根。六约六通。七念中于六念上加念众生。是悲心也。八正道可知。九次第定者并是寂用双行故。是菩萨道摄。于中初禅可知。二从喜悦者是二禅利益支也。离退过者是二禅离觉观障也。三息喜悦者是三禅也。四离世苦乐者是第四禅也。见佛等明定用。并四无色定及灭尽定为九也。十力道中知欲乐。先知。后为说法现身等。余并可知。第三有十种无量道下四十句明行德成就。于中二。先总标四名。后各别显释。初无量道者。谓是菩萨智所游路无边际故。一事空。二理性。三正报。四依报。五时劫。六施设。后四是佛三业力用。净识为体。二道具者以前染净等无际限。菩萨起道之缘亦同无际故云也。约前所知十种广大。显能知集起亦同无际更无别法。三修道者对缘造行故名修道。非是见修等修。又摄论中总集修亦在地上。同此也。初三别约三无性修。一无相观中不见所执染法可着。亦不见净法可依出离。由此能令三业无失。二于无生观中。不见染分可减净分可增。以无生理实故。三于无性性观中。不见前二性为有。不见三无为无。又真如相非有体非无。上约正证智。四约后得智中。别就依他性以成修行。观唯识如幻等成不颠倒行。五作三空不离三界。为欲在中长善根故。六于教法不着。七于理中恒沙法不坏。八于真体平等。九起行勇猛。十于佛德平等不疑。四庄严道者。谓修道行互相交饰故名也。又释皆以逆行用严道。于中初五自行无染。一在乱常定。次二处小常大。次二在欲行禅。次三随有摄化行。一化乐世。二化耶道。三化犯戒救苦。九自行成满。于中三。初得法满。二为一切众生下巧便示现。三何以故下释成善巧。十因圆果满。于中三。先因圆得果。二而亦不断下明得果不舍因。三何以故下释成行相。可知

下第四从十足下二百门明八地已上报德纯熟行。于中分五。初二十句明手足外用行。二从十腹下三十句明内德盈满行。三从十庄严下二十明外相严备行。四从十头下七十明六根业用行。五从十行下六十明四威仪动止行。就初中。十足行用进涉表其脚足。从下为初。是故先辨。于中初二约行。一戒一进。次二约通。一总一别。次二约心。一信一愿。次二约法。一护一听。后二约德。一福一断。二有十手者行用取授表其身手。于中初四自行。一取。二与。三恭下。四敬上。次四利他。一除疑网。二拔欲泥。三济四流。四授正法。后二明二行满。一除惑病。二破无明。第二有十腹下三十句明内德盈满中。初腹者如世人腹含容不净。今明菩萨行腹。反彼说净。于中初三约戒净。一持戒心。二正护戒。三不覆过。次一约定净。谓定心无著也。后六约惠净。一断惑障。二灭业障。三纳实法。谓如食满腹之想。四悟缘起。五觉八正。六破耶见。二有十藏者。前总举其腹。今明前腹内五藏相。似有摄藏义故次明也。于中初六下摄众生。后四上摄佛果。前中初三总摄。一授解。二令行。三成德。谓成僧宝也。后三别摄三聚众生。耶定众生令得生善根者。此约菩萨为外缘力也。涅槃经一阐提人虽断善根。由佛性力故。未来善根还得生长者。彼约内因力也。后四上摄中。一摄佛十力。二摄四无畏。三摄不共法。四摄佛证智。三有十心者。前通明腹内诸藏。今别明心藏。为最胜故。五藏主故。中实故。集起故。于中初二摄善心。一勇。二勤。次二破恶心。一破恶缘。二破恶因。次二成行心。一坚。二净。上六自行。次二摄生心。一令悟。二慈救。谓梵住是慈也。后二成德心。一深。二固。第三从十庄严下二十明外相严备行。初十犹同世人服饰严身。初二慈悲严。次二愿求严。次三摄生严。后三摄德严。二有十器杖者。前既束带严身。今固执持器杖。显行能除障故。初五以顺杖破障。次三以违杖破障。如夺贼器杖还用害贼。后二成德建功杖也。第四有十头下七十句明六根业用行。先明头者以身之上故。于中初一断德深。次三福德高。次一悲德坚。次二智德广。次二摄生德。后一护法德。二有十眼者。行德净胜照了于缘故同眼也。十眼义略作四门。一释名。二体性。三诸门。上三如别说。四释文中。智论中。无常肉眼畏大风故不见他方。此经是真常肉眼见十方色故。无量寿经慧眼见真。又法眼观察究竟诸道。与此不同准释可知。此中皆从根境立名可知。后五中智眼分别事法。无碍眼见事不碍理也。普眼见五事平等。余并可知。三有十耳者如理听闻故。依闻起行故。初二离违离顺。次二弃小欣大。次二愍苦离乐。次二求佛究法。后二了俗至真。四有十种鼻者。饮嗅行香依鼻增道故云也。于中初四闻香体。杂集论唯有三种。此文有四会释可知。次三闻香表用。瑜伽等中上二界既无鼻舌两识。亦无香味二尘。此中闻非想等香者明其不无微细香等。以菩萨鼻识过人天故能了知也。后三闻出世人法香。五有十种舌者明语业自在。依之增善故也。于中初五约辩说显德。后五约顺用显位。六有十身者明身业自在。应机现形故。于中初三现凡身。次五现三乘身。后二现体用身。一用一体。七有十意者明意业自在。于中一信。二闻。三思。四修。五止。六观。七总调。八调内思。九调外境中。十明佛定。第五有十种行下六十门明四威仪动止行中。初十行者。谓发动游行故。初二能听能说。次三自调化物。次一成己净惠。次二下化上敬。后二得果存因。二有十种住者。行有止息故明其住。若小乘令住四念等。今明菩萨住。此十行初一住行本。二住行相。三住正慧。四住定处。五住戒处。次二顺人法。次二智忍圆。后一住果满。三有十种坐者。住戒有疲故明安坐。菩萨处此。而成行摄生故也。初四同世坐以摄物。后六以法坐而成德。一辨。二持。三定。四慈。五悲。六力。四有十种卧者坐亦须卧显憩息归静故云也。初二定加行。一息諠。二趣定。次一得定。后七定果。一起慈。二离悔。次二惠悟。次一如愿。后二作满。又如经中不得仰伏左胁等卧唯以右胁思明相等。今此菩萨就法以明摄用归体故为卧也。五有十种住者明智有栖止故云住也。前明能住。此辨所住。又前明身住此明心住。是故前属四仪。此约心行也。于中初四住四等。次一住六度。次三住三空。后二行位满。六有十种行者。远师释。前明利他行此明自利行。又正云前明始终方便故以乐闻等为行。今此明淳熟修故以正念等为行。又厚云。前是四威仪中行住之行。此说始终起行之行。今谓亦是前约身仪。此约心行。若尔何故前十亦有心起行耶。释此经菩萨身外事。并就内行以显其相。例皆如是故不疑也。于中初四自行。一加行。二觉法理趣。三后智顺佛。四起六度行。次四摄生行。一总举。二同事。三爱语。四利益。谓示同贪等而觉悟彼也。后二二行成满。上来总五百二十句明上第五大段十地位中相竟

自下大门第六从十种观察下五百一十句答上第六因圆果满行。于中分二。初三百二十句明因圆究竟行。亦是等觉位相似。二从十种住兜率天下一百九十明现果圆满行。亦是妙觉位相似

就前中分三。初有一百四十门明因行体性。二从十种义下八十门明方便造修行。三从十种魔下一百门明因行除障。就前中二。初四十明起行方便。二从十种施下明十度行体。就前中初二十明意业观察。次十身业奋迅。后十语业哮吼。前中初十种观察者。观解方便故。善达所行通塞相故。于中初三观所化。一知业。二知报。三知根。谓能不迷理性无根而能观随事根别。次六觉法宝。一理法。二果法。三教法。四行法。五六观位法。一灭障。二得记。后一定法。亦是所成果用。二有十种周遍观察者。谓审察穷尽故。解能起行故。又释亦得前是审虑筹度。此明举目周察故也。初六令众生得六度行故。后四令他得四丈夫法。一近友。二闻法。三思惟。谓不舍悲也。四修行。令得菩提故。又释后四是自利。一重人。二顺法。三悲。四智。三有十种奋迅者。谓实行内充。威德外溢。又建功玄极。威肃勇健故名奋迅。初一身胜。二心大。三教威。四行用。五破耶。六灭惑。七达法。八广持。九具辩。十圆果。四有十种师子吼者。既勇健无畏。即能决定宣唱故名也。依涅槃经师子吼有十一事具如彼说。此中一觉心吼。二大悲吼。三报恩吼。四大誓吼。五净戒吼。六积德无厌。七积智无足。八证理决然。后二果成决定。此皆先显所成决。后结能成之行可知。第二有十种净施下一百门明十度行。初十施者辍己惠人故。一舍心施。二满愿。三一心。四了田。五无简。六不着。七舍身财。八求大果。九益众生。十净三轮。二有十种戒者防三业非具止作故。于中初七自分中。初三律仪戒。次三摄善戒。一过凡。二背小。三顺大。次一摄众生戒。谓巧拔犯禁故名微密。后三约胜进。亦三聚可知。三有十种忍者。情安于法故。初三耐怨害忍忍他三业所恼故。次五安受苦忍。一不害他。二不惜命。三不轻小。四受割截。五忍苦恶。后二法思惟忍。一离惑。二得法。四有十精进者顺理勤策故。初五明三业精进。身语初二。意业三心。亦是勤勇精进。六无足精进。七难坏精进。八成事精进。九入理精进。十用进。五有十禅者摄心不散故。初四方便。一出俗。二近友。三在静。四离闹。次二正定。一初得。二坚成。次二发惠。一起智。二断惑。上八是现法乐住禅。九利益众生禅。十引起神通等禅。六有十慧者正解照理故。初三解法慧。一解因不即果。二解缘不离果。三解果不断常。次四摄生慧。一拔邪。二知器。三授法。四降魔。后三证理慧。一见法身。二摄胜德。三觉平等。又释初三加行。次四后得。后三正体可知。七有十慈者与乐意故。初一离怨亲。二令得实益。非但口言。谓令离苦因也。三救苦果。四授乐因五令得断果。六令求智果。七身放慈光。八心广如空。上八缘众生慈。九法缘。十无缘。并可知。佛地论中法缘慈缘。五蕴假法与此不同。八有十悲者拔苦意故。于中初总显。余九别辨。别中初六对物起悲。后三授其所益。一愍其容妄故为灭。二伤其真隐故为显。三念彼不知故令悟。九有十喜者庆物获益。于中一庆自发心。二庆舍所有。三庆救毁戒。四庆和诤讼。五庆护正法。六庆乐正法。七庆物同行。八自庆供佛。九庆他得定。十庆他智满。十有十舍者情无取着故。一舍贪嗔。二舍世法。谓八法中利衰依身。称讥毁誉依口。苦乐依意。又利及称誉是生乐因。衰及讥毁是生苦因。以因果通说故有八也。三舍非器。谓于法器众生知时授法。于非法器舍而不嫌。四舍二乘。五舍惑染。六舍背有。七舍异语。八舍非时。谓根未熟待时且舍。九舍非缘。谓有众生应受佛化。非是菩萨所化。亦不强化。是故舍之。十舍异见。上来明因行体性竟。第二有十种义下八十门明造修方便行。于中初四十明自分行。二从十种明足下四十显胜进行。前中初十义者所诠旨故。依义成行故明也。一如教旨。二解俗谛。余八解真谛。一离相。二离染。三绝言。四平等。五一味。六证得。谓正智证理顺如而来故名如来。七真。八灭。并可知。二有十法者。自性执持故以法成行也。初一实行法。次四离障法。次三离相法。后二果法。三有十功德具者。成福之缘故云具也。一谓不断三宝。是功德法由何成。此由劝众生发菩提心。是故此劝名功德之缘具也。余句例然。二巧回向。三正惠教他。四悲心不倦。五能舍身财。六勤修相好。七不轻小善。八不蔑小人。九敬养大人。十舍心广大。四有十种智具者。成智因缘故云具也。于中一近胜人。能得智故名具也。下并准之。二内调心。三住念惠。十智显无尽。如前说。四乐真法乐。五六度四等自折伏故。六出家守心欲恚痴为三觉也。七观法空净。如因陀罗陈者是帝释与修罗战时。列兵在空。影现大海故也。八深解二空。九到无相彼岸。十因渐得智。谓五重渐次相资得也。自分行竟。第二有十种明足下四十明胜进行中。初十明足者委解曰明。周备称足。又惑闇尽故。智用满故。初七解行。后三别显三明可知。二有十种求法者。依求正法以成胜行。初五深心求法。谓自有实心不能勤求。自有勤不能舍命。有能舍命不能为他舍。菩萨不尔故。皆能也。后五广心求法。初二为智深法住。次二为授法断疑。后一为满足正法。三有十种明了法者。既求得法委解照达故云也。于中以普贤法了知三乘凡圣差别法。初一约外凡法。二内凡之始名信行。三内凡之终名法行。四住圣之初名八人。有人释约八忍为八人。今释大般若中名第八人。谓从阿罗汉却数至须陀洹向为第八也。五正得初果灭众结者。灭八十八结见所断惑断恶道生死流。六得第二果观欲味是患尽。余三品惑未尽故。润一受生故云还来受生。七得第三果。三果唯舍欲界。此约实法。通离三界。八罗汉。九缘觉。十菩萨。四有十种向法者顺向普贤法界故。一若违善友即背法门。是故反此名为向法。余皆准此。二觉悟诸天不令着乐名向法也。三常怀惭愧恒向法门。四背二乘名向法。五实心办事。六舍小。七舍耶。八背染因缘。九称根说法。十内住法界。上来造修行竟。第三有十种魔下一百门明离障行分二。初五十明离障成行。后五十明离障加持。前中初二十明所离障体。次十明离障方便。后二十显见佛成行。前中初十魔者于道有障。初一简去无取五蕴故云贪着也。以彼非魔故。二简不染无知等故云染也。以所知障等非是魔故。三简善业故云障碍。四是第六识心慢非是余识。五蕴坏名死故云舍离受生。六他化天魔陵妒故。七作罪不悔令善皆失。又退失善根心不生悔故名为魔。八味定废道。九曲情相附。如依人不依法等。十迷于所求不起大愿。此十种魔皆持业释。谓蕴即魔故。乃不知即魔。问此十魔摄四魔不。答或摄。谓阴天死各一。余皆烦恼收。或不摄。彼四与六各是一门故。以显无尽故。彼据别门。此约普故。二有十种魔业者。前据魔体。今辨所因故云也。又此十业招感天魔。一既忘觉心所修善根唯感人天。岂非魔业。此是耶善根故。二求世报名恶施。业报差别经若有行布施。急性多嗔怒死作大力龙。三厌舍恶人。弃大悲故。四内有四门。一悭法。二呵法器令退学。三求利说。四非器说深。五不如闻行。六乐小乘。七心嗔口说。身恶眼视。八谤法轻人。九文词世论。十舍危就安。十一慢法散动。剩一是增数十也。三有十种舍离魔业者。对障修治故云舍。一他力舍。二自力舍。三诚信力。四忆本力。五离放逸。六求本法。七乐深法。八归佛。九念佛。菩提树者以善根回向。要于此树成菩提故。十善根同性。又同一果也。四有十见佛者行障既离。佛境斯现故云见佛。十中各标名释义。初一安住世间者。示于涅槃无著也。成正觉者。示于世间无著故名无著佛。又释无著是不滞义。谓不滞体寂。现于世间示成正觉。此是总句。下九别显。一由愿力出现故。上云佛愿力故皆悉见。二示往善业得此妙果。令他信知业不虚。又释以胜福业感此相好之身。令物生信故。三净识体住持善根顺成正觉。又持净土等。四虽现世间而常住涅槃故。前即持令顺起。此即欲度常灭。无碍故也。问此岂成总句释。若不尔何成正觉。五即是理法界故。遍一切有为行处。又此现觉之身即遍一切处故名法界佛。如结通处佛。如上即佛身充满诸法界也。六佛虽普遍机感心中。方乃安住心即是佛。上云应受化器。悉充满也。又是净心缘起集成故云安住。七虽现心中常在深定。以于多处皆无著故。八体性不变故云决定。此通在缠等。由此等乃成正觉。不尔即非也。九如能化意普覆群机故。又如所化意皆普覆故。又如末尼珠。普覆应机无思念故。又释如意是自在大用故。此中十佛六相总别等准之。又此十佛摄为五对。初二能所一对。谓初是所出后是能出。次二依正一对。谓初是正报。后持是依报。次二常遍一对。谓涅槃常恒法界普遍。次二现住一对。谓应现心中住定无著。后二体用一对。初体性不动。后用充法界。余门如别说。又法集经云。菩萨入十种法能知诸佛。何等为十。所谓习气佛。果报佛。三昧佛。愿佛。心佛。实佛。同佛。化佛。供养佛。形像佛。乃至广说。五有十种佛业者。前明所见佛体。今辨得佛之因。又此起行顺佛故名佛业。各有标释。初一总约化生。次二显自利行。次二约别化生。一化悔缠者。二化凡小心。次二于恶时护法行。一正法难时。二魔事起时。八不取小果。九不断本愿。十成无碍行。于中七句。一求道不碍离。二于如来下无染不碍求。三令一切下严刹不碍空。四教化下化生不碍无。五诸通下具果不舍因。六示现下示圆不舍分。七现大下现寂不碍生。上五十句明离障成行竟。第二有十种慢业下五十明离障加持行。于中初二十内成离障行。后三十辨外加持行。前中初十举障。后十现治。前中慢业者。执我自高陵他为业。初轻人。次二慢法。四自举。五妒他。六谤法。七自恃。八求师过。九不能问。十明慢障道。二有十种智业者显对治行也。谓既识障惑不令增长。成情从理。敬重法行故名智业。初二信法念佛。次二近人乐法。次二敬他自净。次二顺理重行。后二成德灭惑。并此智之作用故名也。第二有十魔所摄持者下三十辨外加持行。初十明怨障加持。即所离障也。后二十明佛法加持。即能治行也。前中由内行乖理。外魔得便故名摄持。又行乖理即是魔摄。初二怠心舍法。次二起贪自度。次二舍愿起断。次二成小舍大。后二舍悲谤法。二有十佛摄持者既离魔摄。即佛加持远耶入正。理宜故也。初二约心摄。次二约起行摄。次二约悲智摄。一悲。二智。次二约巧惠。一巧。二惠。后二约智断。一断。一智。并此佛力摄持令成此等行也。三有十种法摄持者。舍过从法故为摄持。初四即四法印法。次二十二缘生法。次二即三乘法。后二此净法。一性净。二断净。并由法力。成此等行故名摄持。上来总三百二十门明因圆究竟讫

第二住兜率有十事下一百九十门明果用圆满行。此等多约八相现化。明于佛用者。以此亦通普贤等用。不向净土实报处说也。又释此唯菩萨作用故。唯示八相成佛非余实成。又释彼实成佛无成不成。不可说故。就八相说也。于中分六。初二十在天行。二从十种降神下二十明入胎住胎行。三从十种生下十明出胎行。四从十种大庄严下四十明在家同俗行。五有十种出家下六十辨出家期道行。六有十种觉如来力下四十明成佛果德行。初中前十在天行。后十现终行。前中一生菩萨在彼天时作何等事。谓作如此十种事业。一谓于彼化欲界天。二化色天。三化三千界生。四为十方同类说下生法。五授彼十方同处法化。六说法降魔。七眷属乐声化欲诸天。八诣佛闻法。九供养多佛。十多身益生。二命终示十事者。所作既了将欲下生现兹十明。大乘方便经下卷中。菩萨如其本愿处兜率天宫。能得阿耨菩提转于法轮非为不能。菩萨思惟。阎浮提人不能至此兜率天上听受法教。兜率天人能下阎浮提听法。是故菩萨舍兜率天于阎浮成佛。一轮光灭苦。觉彼令知。二毫光惊觉宿世有缘。三手光严界。并除非器。四膝光觉天。令辨供随侍。五心光觉力士。六毛光觉助化。七堂光照处眷属同生。八楼光照母胎内现阁。九足光延寿。十小相中光应现八相。余结百万等可知。第二有十事降神下二十。初十明入胎。后十明住胎。前中何故入胎。为十事故。一化小根。二摄眷属。三念不乱。四现奇广益。五称物本愿。谓彼应在胎中化故。六同人类故。七机宜见故。八同类共集。九定力现奇。十供佛闻法。问据此上文兜率命终即入胎等。何故梁摄论明化身二十年在中阴中。答真谛三藏金光明疏中释云。有少乘别部师云。听待父母受生竟故。二十年在中阴。今释并是机感现形。所见各别故也。二有十微细趣者明胎中广摄。幽密难知故名微细。初一现本因行。次八现八相。后一现神力。并在胎内同时齐现。第三有十生者。于右胁出时有此十种。一内离痴闇。二外放大光。三未来更无此最后边。四称理而生。五如幻似生。六顿现十方。七内智具。八外光用。九定慧满。十震动益。第四有十大庄严下四十明在家行。初十明初生未行之前。大誓自严故也。一拔欲泥。二开慧眼。三得胜身。四摧憍慢。五接退屈。六令大益。七见佛力。八觉同行。九救疲顿。十蒙光触。皆奋起大志用以自严。二有十事行。七步者创起游行。显自在之貌。初一示有俱生力故。二若在家有轮王七宝。出家七圣财宝。三满他本愿。四自现超过。五现大人行相。六履地现金。七加他与力。八同数相表。九示现自悟。十称己最尊。后身菩萨为化众生。同卅七数故不增减。三有十事现童子地者。幼稚无染现学摄生故也。初三符同世务。次二常无过失。次三色力救生。后二供佛受法。四有十事现处中宫者彩女围绕显行无染。一以同行在彩女中故如下文监惠女等。二以不同二乘舍欲之善故云欲明菩萨善也。如文殊在龙女宫坐夏等。三处彼能舍以化着乐。四顺同浊世。五在欲而行禅等。六七应本期。谓受化在此故。八以世乐供佛。九现定力自在。十为守护法。上来在家行竟。第五有十事出家下六十门明舍家期道行。于中初明出家内。初二令厌舍染。次二显胜令欣。次二令其舍惑。次二现于挺出自在之德。后二顺果同因。二有十事现苦行者。明示同异道摧诸邪见。初一有小乘机众生。谓菩萨生在王宫未经苦行练神。何能得道。故示化彼也。二外道耶见以自饿为道。菩萨示饿。六年而不得道。食乳糜后方觉菩提。是故破彼见邪。三化无业报邪见者。如大乘方便经第二卷中。佛于往昔迦叶佛时。为化外道五人令得无生忍故。须为五人骂迦叶佛言秃头道人。何有秃人能得菩提。实以般若观空而发此语。示现此业。得报不失。苦行六年令余众生信知。一生菩萨方便之业犹有此报。况我等耶。乃至广说。四顺五浊者。谓五浊众生皆有重罪。忧恼覆心不得解脱。为除彼忧示此业报。令彼念言。菩萨谤佛尚得解脱。况我等耶。即当悔除。亦如彼经说。五策懈怠。六令求法。七令离我乐。八显殊胜者示此苦行。非此正故对显菩萨之胜行也。九策未来。十待根熟。三有十事诣道场者。明舍邪趣正。亦是因圆趣果。于中初二现处。次二现身。次二严处。次二见佛入定。后二爱供观佛。并于趣向道场行路之时有此十事。四有十事坐道场者处此受道故。初四约处现相。次三约三业现相。后三成德相。一满金刚喻定。二受古佛所坐。余经受吉安草坐。三纳所应化生。五有十种奇特者。大果将临。奇相先现故名也。初二佛加赞。次二人物归向。次二得定总持。次二通慧具。亦是上供诸佛。下识化器。后二明身业体用。一体二用。六有十种降魔者。彼对魔怨显胜幢独绝故云也。依方便经下卷。若非佛力召来。彼等恶魔莫得近佛。为欲界中此最尊胜。尊胜若降余皆随伏。波旬四兵满三十六由旬。围菩提树欲作留难。菩萨住慈悲智慧。以手指地。一切散坏。八万四千八部大众发阿耨菩提心。广如彼说。此化魔眷属也。诸天本见魔王自在。将谓胜佛。为决彼疑故云降也。四示征以入道。五显己德力。六起他信力。七八为未来轨则。谓修行之时未免魔障不宜放逸。九显惑劣德胜故。十顺恶世法故。第六有十种觉如来力下四十门明成佛摄化。于中初十成佛。次二十转法轮。后十入涅槃。初中觉如来力者。前降魔当无间道断障也。此当解脱道证果也。初中魔是恶缘。烦恼是恶因。此二是所离障也。究竟行是治道成也。次二得定自在。次二二德满。一自德圆。二化德备。次三三业具。后二同诸佛。一三业同。二十力同。是故结名如来。不名菩萨也。二有十转法轮者。大觉既圆机熟时至。理宜开甘露门授以正法。余经此中有梵王请。于中初十明所转法轮。后十显能转之因。就前中若小乘等法轮四谛下各有见智明觉等四行。今此十行以显无尽。又彼四行既在谛下。今此亦在十谛之下。各有十行成百行法轮。并如前法轮章辨。于中初三可知。此等并是所转之法非能转者。具此等也。四顺入佛果无碍之法。五悲心普覆法。六教法不虚。七显宿因法。八显教声至一切处。九说尽一切时。十转该一切法。三因十白净法等者。显能转之因是佛无流清净法界故云白净。由此转入众生心中成闻熏种子也。出生无相者。依此种子出生无相圣智也。决定不虚者。更无异因故。摄论中。多闻熏习从最清净法界等流生无流现了。是此义也。一由佛过去弘誓愿力。令此法入众生心中。出生无相。决定不虚。余亦如是。二宿世大悲所任持故。三现在不舍众生故。四称根说法。五不差时故。六不令生厌。又非不足。七知三世智。后三殊胜三业。四有十义示现大涅槃者化缘既毕。息用归真故名示现大般涅槃。初二显有为失。次二显涅槃德。五令求法身。六无常决定。七明爱必有离显不自在。八总举三界皆不坚牢。后二显涅槃体相。一体二相。佛子一切如来下总结三世诸佛化仪齐等。上来一百九十句明第六究竟位中行法竟。上来总辨二千行门六位差别。明大门第五普贤说分竟

第六大段从佛子是为菩萨清净下明结劝修学分。于中二。初结义劝修。二从佛子此经出生下结名劝学。前中亦二。先结义。后若有众生下劝信修行。前中初总结。二引证。结中障尽名净。德高曰胜。用广称大。理深为妙。此四之中净胜是行。大妙为法。二诸佛所说下引证。谓如上所说并是三世诸佛所说。令有智等明说有益。二佛子若有下劝信修行中三。先标益。二何以下释成。三佛子下结劝。第二佛子此经出生下结名劝学中亦二。先结名。二是故下劝持名中有十。一生诸行。二出妙德。三入深智。四摄法门。五离世间。六远二乘。七显不共。八普照法。九长善根。十度众生。前中功德义花者。是功德妙行。间错如花。以成严饰。如上功德花聚十行相似。花严之名依此而立。此十并是所诠之义。从义立名也。二劝持中先总劝。若菩萨下举益劝持可知。上来结劝分竟

第七大段从说此出生下明表瑞证成分。于中二。先明说经表瑞。谓动地放光。二尔时下诸佛证成。于中四。一总赞善说。二佛子汝已下别叹说德。此中久已善学。中间决定证知。今时临机快说。三我等下显已同说。明现说不殊故。四是故下述已护持。令未来不断故。上来表瑞证成分竟

第八大段从尔时普贤下明偈颂分。于中有二百三十一颂分四。初有一十六颂显德广难说。二从持众生善根下一百三十三颂半明略示行德差别之相。三从常依如来下四十三颂正略颂前二千行相。四从菩萨修诸下三十八颂半颂前结劝修学文。就初十六颂中。各二颂为一结。则为八事。一叹供佛摄生行。二于上二事皆无染行。三摧魔灭惑行。四现化为物行。五救生求果行。六六度四等行。七舍自存他行。八总结广多许说少分。第二持众生下一百三十三颂半略示行德差别之相中。总分为二。初六十七颂明托事表法。显行相殊胜。二从一身无边际下六十六颂半明行用广大。就前中有十五种行相。初八颂明法树鸟兽行。二生死下四颂导迷治惑行。三菩萨为法王下四颂明法轮王行。四甚深智慧海下四颂明大海须弥行。五深心下四颂明金刚法雨行。六白净下四颂半明法城金翅行。七净戒下四颂明日月照临行。八自在下四颂辨法王梵主行。九远离下四颂离过成德行。十无量方便下四颂明四大珠宝行。十一菩萨功德下四颂明花香幢盖行。十二菩萨无上下四颂明龙象希灯行。十三菩萨功德河下四颂明河船园药行。十四菩萨等如来下六颂等同佛果行。十五菩萨悉成下四颂半明障尽德圆行胜行。略示结劝。令听行相殊胜竟。第二一身无边下六十六颂半明行用广大中。分为十行。初六颂明三业深广行。二菩萨现如是下五颂半明供佛受法定慧行。三示现种种下四颂明逆顺行成德满行。四或现声闻下五颂半明随类现身难思行。五或在天宫下八颂半明八相念劫法印行。六如是知众生下七颂明了众生根欲行。七菩萨一念中下七颂半明身心迅用甚深行。八犹如人梦下六颂半明智悲广大玄绝行。九观色如聚沫下十一颂明智德圆明照法行。十广入甚深下五颂明结德殊胜无尽行德用。略示结所说。但以功成德立行该法界。其旨深奥。讵可言哉。聊举一尘之说以拟玄趣也。三常依如来下四十三颂正颂前二千行法。于中颂前六位则为六段。初四颂前十信位中二百门行。二一切妙功下四颂前十住位中二百门行。三住持一切劫下六颂前十行位中三百门行。四金刚妙宝住下六颂前十回向位中三百门行。五清净身身业下十颂前十地位中五百门行。六观察善逝智下十三颂前因圆果满究竟位中五百门行。第四菩萨修诸行下三十八颂颂前结劝修学。中分三。初一颂总结所说。谓结前二千名举小分。二无量劫下三十三颂半别结德用。三末四颂结广劝修。就前别中二。先二十一颂半别结德用广大。二净身下十二颂结别行德殊胜。前中分五。初五颂半明于刹自在。二无量金刚山下六颂明三业自在。三过去一切劫下三颂明三世间自在。四深知下五颂明身智自在。五示现如是下二颂结自在无尽。二净身下十二颂别结行德殊胜。中分三。初六颂半明轮王七宝宫殿器杖。二陀罗尼下三颂半明林泉游观饮食乘御。三此等下二颂结上诸行多劫修得。三末后四颂中。初二结德无尽。后二举益劝修。离世间品竟

花严经探玄记卷第十七花严经探玄记卷第十八(此尽十住知识)

        魏国西寺沙门法藏述

    入法界品第三十四

将释此品。四门同前

初释名有三。一分名者。谓广依胜友。深证法界故名依人入证成德分矣。二会名。约处名祇洹重阁会。谓表此法济物摄生故在给园。又显悲依本智重出之相故在重阁。三品名者。入是能入。谓悟解证得故也。法界是所入法有三义。一是持自性义。二是轨则义。三对意义。界亦有三义。一是因义。依生圣道故。摄论云。法界者谓是一切净法因故。又中边论云。圣法因为义故。是故说法界。圣法依此境生。此中因义是界义。二是性义。谓是诸法所依性故。此经上文云法界法性。辩亦然故也。三是分齐义。谓诸缘起相不杂故。初一唯依主。后一唯持业。中间通二释。心境合目故云入法界也

二来意者。初明分来。谓前显托法进修。今辨依人入证。义次第故是故来也。会来品来。亦同此说

三明宗趣者。亦分会品同。既明入法界。即以此为宗。于中分别作三门。一约义。二约类。三约位

初中先明所入法界义有五门。一有为法界。二无为法界。三亦有为亦无为法界。四非有为非无为法界。五无障碍法界。初有为法界有二门。一本识能持诸法种子名为法界。如论云。无始时来界等。此约因义。二三世诸法差别边际名为法界。不思议品云。一切诸佛知过去一切法界悉无有余。知未来一切法界悉无有余。知现在一切法界悉无有余等。二无为法界亦有二门。一性净门。谓在凡位性恒净故。真空一味无差别故。二离垢门。谓由对治方显净故。随行浅深分十种故。三亦有为亦无为者亦有二门。一随相门。谓受想行蕴及五种色并八无为。此十六法唯意识所知。十八界中名为法界。二无碍门。谓一心法界具含二门。一心真如门。二心生灭门。虽此二门。皆各总摄一切诸法。然其二位恒不相杂。其犹摄水之波非静摄波之水非动。故回向品云。于无为界出有为界而亦不坏无为之性。于有为界出无为界而亦不坏有为之性。四非有为非无为者亦二门。一形夺门。谓缘无不理之缘故非有为。理无不缘之理故非无为。法体平等形夺双泯。大品经三十九云。须菩提白佛言。是法平等。为是有为法。为是无为法。佛言非有为法非无为法。何以故。离有为法无为法不可得。离无为法有为法不可得。须菩提是有为性无为性。是二法不合不散。此之谓也。二无寄门。谓此法界离相离性故非此二。由离相故非有为。离性故非无为。又由是真谛故非有为。由非安立谛故非无为。又非二名言所能至故。是故俱非。解深密经第一云。一切法者略有二种。所谓有为无为。是中有为非有为非无为。无为非无为非有为。乃至广说。五无障碍法界者亦有二门。一普摄门。谓于上四门随一即摄余一切故。是故善财或睹山海。或见堂宇。皆名入法界。二圆融门。谓以理融事故全事无分齐。谓微尘非小。能容十刹。刹海非大。潜入一尘也。以事融理故全理非无分。谓一多无碍。或云一法界。或云诸法界。性起品云譬如诸法界分齐不可得。一切非一切。非见不可取。此明诸则非诸也。舍那品云。于此莲花藏世界海之内。一一微尘中见一切法界。此明一即非一也。是故善财或暂时执手。遂经多劫。或入楼观。普见三千。皆此类也。上来五门十义总明所入法界。应以总别圆融六相准之。二辨能入亦有五门。一净信。二正解。三修行。四证得。五圆满。此五于前所入法界五门之内有其二门。一随一能入通五所入。随一所入。通五能入。二此五能入如其次第各入所入五中之一。又此上心境二义十门。无碍圆融总为一团。无障碍法界亦以六相准摄思之

第二法界类别亦有五门。谓所入能入存亡无碍。初所入中亦五重。一法法界。二人法界。三人法俱融法界。四人法俱泯法界。五无障碍法界。初中有十。一事法界。谓十重居宅等。二理法界。谓一味湛然等。三境法界。谓所知分齐等。四行法界。谓悲智广深等。五体法界。谓寂灭无生等。六用法界。谓胜通自在等。七顺法界。谓六度正行等。八违法界。谓五热众鞞等。九教法界。谓所闻言说等。十义法界。谓所诠旨趣等。此十法界同一缘起无碍镕融。一具一切。思之可见。二人法界者准此下文亦有十门。谓人天男女在家出家外道诸神菩萨及佛。此并缘起相分。参而不杂。善财见已。便入法界故名人法界也。三人法俱融法界者。谓前十人十法同一缘起。随义相分。融摄无二。思之可见。四人法俱泯法界者。谓平等果海离于言数。缘起性相俱不可说。五无障碍法界者。谓合前四句。于彼前人法一异无障。存亡不碍。自在圆融如理思之。二明能入亦有五重。一身。二智。三俱。四泯。五圆。谓入楼观而还合身证也。鉴无边之理事智证也。同普贤而普遍俱证也。身智相即而两亡俱泯也。一异存亡无碍自在圆融也。又发心品云。甚深真法性妙智随顺入无边佛土中。一念悉周遍。案云前二句智入法界。后二句身入法界。由身智无碍故。智入理身遍土也。余准可知。三能入所入混融无二。际限不分。就义开异。理仍不杂。此五能所如次反通。如理思摄。四能所圆融形夺俱泯。五一异存亡无碍具足。上来约类辨竟

第三约位明入法界者。准下文中。所入法界大位有二。所谓因果。于前人法无不皆是佛果所收。即如来师子奋迅三昧所现法界自在是也。又于前人法无不皆属因位所收。即文殊普贤所现法界法门是也。此因位中曲分有五。则信等五位之法界也。准摄可知。二明能入。准文亦二。对前果位明诸菩萨顿入法界。对前因位寄显善财渐入法界。因果既其无碍。渐顿亦乃圆融。但以布教成诠寄斯位别耳

四释文者。此一品中大分有二。初明本会。二尔时文殊从善住楼阁出已下明末会。亦则前明果法界后明因法界。又前明顿入法界。后明渐入法界。又前总后别。则本末圆融无碍思之

就前本会中长分有十。一序分。二请分。三三昧分。四现净土分。五集新众分。六举劣显胜分。七偈颂赞德分。八普贤开发分。九毫光示益分。十文殊述德分

就初序分有三。初尔时佛在明智正觉世间圆满。舍卫城等器世间圆满。与五百等众生世间圆满。初文可知。器中有三。谓一城。二园。三阁。城名具言名室罗伐悉帝。讹略称舍卫。此翻云闻者城。谓昔有古老仙人住于此处。复有少仙名为闻者。于老仙所听受法要。老亡已后。少于此处建立城郭。因以为名。园在城南可三四里。只是太子之名具言誓多。此云战胜。又无父曰孤。无子曰独。须达长者惠施资给名给孤独。然长者侧金买地。太子施树同成。二人共立伽蓝故俱以名焉。园内别阁宣法之所。名曰讲堂。体无不周曰大。德无不备曰严。用依体起故曰重阁。第三众中亦三。谓一菩萨。二声闻。三诸天王。初菩萨中亦三。谓一举数。二列名。三叹德。名中先标上首二人。以其是助化主故。释有三义。一普贤当法界门。是所入也。文殊当般若门。是能入也。表其入法界故。二普贤三昧自在。文殊般若自在。三普贤明广大之义文殊明甚深之义。深广一对故标上首。次列名中有一百四十一大位。十十有十四位。初十同名幢。显行德高出故。二十同名端严。表福智二严故。十中欠一是减数也。三十同名藏显德备含摄故。四十同名眼明照法界故。十中剩二是增数故。五十同名天冠表净德冠于心顶故。六十同名周罗。此云顶髻。表德重尊高故。七十同名光十四位中各以二义释妙光。具身智光照内外故。八十同名幢者。幢有二义。前明独出义。今辨降伏义。九十同名音明美音悦机故。十十同名上德过众表故。十一十同名妙德吉祥显胜故。十二十同名王于法自在故。十中剩一亦是增数也。十三十复同名音者。音有二义。前明音体美妙。今显巧诠妙法。十中剩一亦增数可知。十四十同名觉鉴理察机故。十中欠二亦是减数可知。如是等结也。就叹德中十句有二义。一此十句德遍通上诸菩萨。一一皆具。二别叹前十五位德。谓初句叹前二上首德。以普行普境皆通一切。彼二同成此德故。二持无量等叹前十幢十严二位菩萨。谓身幢独出。具德端严。能遍至故。三具足无碍等叹十藏十眼二位菩萨。谓具无碍藏净眼见佛故。四至无量等叹十天冠十周罗菩萨谓天冠顶发以自严身。同梵王形。至诸佛成道之所。观佛无休。请说法故。五无量智光等叹十光十幢菩萨。谓智光普照甚深法故。又伏痴闇故。六于无量等叹十音菩萨。谓美音清辩说无尽故。七究竟等叹十上十妙德菩萨。谓同虚空之上智极净境之妙德也。八无所依等叹十王菩萨。谓无依现色自在。为王亦现王身故。九除灭等叹后十音菩萨。谓内离智障。巧说分别众生界故。十虚空智等叹十觉菩萨。谓放阿含光善觉照故。又释此十句摄为五对。初二一对。初行德内充。后多身外遍。次二一对。初净眼观佛。后观无厌足。次二一对。初内智照法。后辩说无尽。次二一对。初内智同空。后现身普应。次二一对。初内离智障。后外演慧光。又释此十句中初句为总。余九是别。莫不皆显普贤行故。一身诣佛普。二遍见佛普。三见无休普。四智照理普。五辨多劫普。六理智净普。七量智现身普。八断障普。九光照普。并准释可知。二声闻众中亦二。举数叹德。言声闻者。佛地论云。闻佛言音而入圣道故曰声闻。又瑜伽八十二云。从他听闻正法言音。又能令他闻正法声故曰声闻。大者是第四果故。又是不动种姓故。诸声闻中最尊大故。如鹙子等。又此等并是回向大乘之声闻故云大。佛地论云。如实义者。皆不定种姓声闻得小果已。趣大菩提故名为大。解云以其未入圆教一乘普贤法故。是故下文如聋盲也。如上性起品云声闻缘觉不闻此经。又云若菩萨亿那由他劫。行六波罗蜜种道品善根。不闻此经。虽闻不信。是等犹为假名菩萨。此之谓也。又释此等并是大菩萨示现作声闻。如新译花严不思议境界分中说。以显此法深胜故示现如聋盲也。二叹德中十句分四。初四句证涅槃舍生死。谓觉真谛者见道也。证实际者修道也。深入性者无学道也。由此证理满足故。舍离分段故。云离生死海。又由怖畏生死故云离也。又由无方便慧故证实际也。由无大悲故舍离生死也。二次二句住空断结。初住空者。谓此人空之理亦是如来二空之一故云如来境也。唯契此分故云安住。后句由住人空断离四住之惑。谓九结十使相应缠缚。三次二句通力自在。谓于世无染故云不着一切。神通遍游故云游行虚空。四次二句疑尽信坚。谓成就不坏信故也。又释此并信佛甚深自在果法。明知是大菩萨。三诸天中亦二。举数叹德。叹德中十句摄为五对。初二一对叹宿因德。谓已供过去佛。久已益众生。自下皆叹现行德。次二一对叹行慈入智德。谓慈念无间救生入智。次二一对叹在染显净德。谓不舍染众生出佛真净法。次二一对叹护持德。谓护于果法使正教流通。持于因法证性决定。又外能守护持法之者。内自受持佛真性法。后二一对叹家业德。谓生于佛家作求佛业。一切智因名为智门。以能通至佛智故云门也。上来序分竟

第二请分中有三。初众念请。二念所请。三念请现。问准下声闻皆如聋盲。何故此中而同疑念。答意法师释曰。理处不隔故得同疑。未积大心故不应其次。又释表同在祇洹故同念请。普眼未开故如盲等。又释实是菩萨。是以同念迹现声闻。是以如盲(云云)。所请中总有六十句。古德释云。初三十明佛自入法界。后三十明佛令他入法界。今释六十中初十念请果法。何以得知所请是果。谓次十明下位不能测量故。既下不能知。云何今欲请。谓次十明因缘力具。或亦得知。虽力具得知未知。此众有知力不。谓次十显此众根器力具。虽众器具。若无佛力亦无能知。谓次十明佛利他因具。虽利他因满。若无现起利他果用亦无由令知。次十辨果用摄生。既此缘具故。结请云唯愿现等。又释此中初三十句念法请。后三十句念德请。前中初十正念所请果法。次十明深玄难测。后十明缘会可涉。初中一问悲智无碍无功用行。如性起品说。二问佛智所知真俗无碍。亦如性起境界中说。三佛地总持无边念惠又如十佛中持佛所辨。又如不思议品说。十持等。四是处非处等十力。又那罗延幢等十种大力。亦如彼品。五四无畏十无畏。六师子奋迅等不可称量诸三昧海。七理及功德并诸刹土。皆是如来身智所住。亦如不思议品说。八殊胜功德。初二会问中名佛胜法者。彼就通辨。此中别约福德显胜。九三身十身圆满之相。十四智十智理量融照。又有经本此中更有一句。名如来法。或是剩来。或是结上诸句。又此十问与前初会所问果德多分是同。以彼摄门于此宜用。又十中初一是总。余九是别。别中初一所智德。次三智用德。次一大定德。次一所依德。次一胜福德。后二身智德可知。第二非下位测量中。谓于前十种如来法中。高故不能知。广故不能度。深故不得底。多故不能受。此四非闻慧境界。玄故不能思。妙故不能观。此二离思修境。称法界故不能分别。一即一切故不能闻发因智。不证故不能宣明。超过言议故不能解说。又前六离三慧。后四超四辩。谓法辩不能分。义辩不能开。辞辩不能宣。乐说不能说。又释此十配前十种。次第显示甚深之义。可准知之。又释于前一义则有此十。于此一门亦有前十。准成百门等可知。第三缘会可知。中初四佛力为缘。后六根力为因。方可得知。初中佛持力者是佛加持力。如加持青莲花菩萨令知佛功德说不思议品等。二自在力者是回转无碍力。如文殊转鹙子令知说深理等。三威神力者密以威加令知德。如令迦叶知如来心等。四本愿力者是佛往昔本誓愿力。是故令他知佛深德。下六中初宿世多生种善根力。二多生亲近一乘善友力。三现在深彻净信心力。四于上胜法欲愿求力。五不杂无明真法所发大菩提心力。六深心专求一切种智。不杂二乘心力。于此十中随一种力可分得知。或二或三乃至十种以显无尽。第二三十句念德请中。初十叹机堪受德。后二十叹佛能说德。初中思量是意多故种种也。从思起欲欲增名解。则胜解印持也。依解发言方音亦异。所住行位优劣不同故云地也。受法根器利钝生熟三品不同故云根。依根作业造修不同故云方便作业。所缘境相非一故云境也。皆依佛果为缘。差别而得入法。或依佛光。或因说法等。乐闻所说浅深广略。各多少不同故云乐闻法也。二叹佛能说中。初十念佛说因圆满。后十念佛说果德备。前十中初一明昔初发菩提心愿。二依愿起行故云净波罗蜜。三行成入位故云诸地。四依位成行故云满足行。五总说诸行皆具二严故云菩萨庄严。六别辨一行巧摄一切。互相严饰故云方便严。七别显自利行摄同前名道庄严。道是因义通至果故。八别明利他行巧多端。故云出方便海。严义同前。九二利无碍双融究竟。各摄一切成普贤行故云自在庄严。十多劫受身。恒修胜行故云本生海。显本生身多故。如海多身修行行亦广多也。后十明佛说果备中。初前既因圆。有何所得。谓菩提自在也。二既得菩提。有何所用。谓自在转法轮也。三于何处转。诸净刹也。四转何所益。谓严众生界。五转何法。谓法王法。六以何智转。谓道明之智。七佛智照法机何由悟。谓自在能入众生处故。八入至机处作何所益。谓作福田故。九以何成福。谓说成功德之达榇。达榇者尊婆须论作檀嚫。此云财施。律云施之法名曰哒嚫。导引利他亦名达西域记云。正言达榇拏。或云驮器尼。此云右也。以用右手受他所施。为其生福故从之立名。今明佛施与众生功德故云功德达榇。十用何摄生。谓三轮。身业神通轮。破疑成信。语业正教轮。破惑成解。意业忆念轮。破结成行。下结请可知。请分竟。第三三昧分中。何故入者。前问愿具现故。今入定为其现法。何故前诸会集众后入定。此乃居先。释前明从相入实。今辨依体起用。又前因人入定。今果位自在故不同也。何故此会佛自入定。为表法界解脱自在唯佛穷原故。文中有四。一入定缘。二入定因。三正入定。四入定意。初中知心念者。以他心智领前疑念。即入定之缘。二以四种大悲明入定之因。谓入定益物。要以大悲为本故以为因。一身者利物之身。积悲而立。即三昧所依之身也。二门者然佛有大智大定大悲等门。今欲益生故唯依大悲门也。又亦开此悲门以摄群品故也。三首者即明益物诸所造作皆以大悲先导故为首也。四随顺方便法者虽悲为首。若无巧便悲法随物根缘。无以令其同入法界。此四亦从佛向机之渐次也。三正入三昧者明定业用。从喻为名。谓如师子奋迅之时诸根开张身毛皆竖现其威势。哮吼之相令余兽类失威窜伏。令师子儿增其雄猛身得长大。今佛亦尔。一奋大悲法界之身。二开大悲之根门。三竖悲毛之先导。四现应机之威。吼法界之法门。令二乘诸兽藏窜聋盲。菩萨佛子增长百千诸三昧海及陀罗尼海。如是相似故以为喻。又离世间品十种师子奋迅于此具论。四令一切下明入定意。谓现此法界清净之法。令众睹入名乐法也。三昧分竟

第四现净土分中有三。初现器世间圆满。二智正觉世间圆满。三众生世间圆满。初中二。先明此祇洹现严净土。后类结十方同现净土。前中亦二。初正显庄严。后出所因。前中三。初重阁庄严。二园林庄严。三虚空庄严。光统云。严空表无为缘起。严园表有为缘起。严阁显自体缘起故也。初中二。先广处无边匆然广博者。谓案权显实破情显法故。二正显庄严。于中有十种。一金地。二一切摩尼下明地上布宝。三琉璃下明阁柱。四阎浮下正明成阁。五摩尼下于阁上安网。六建宝幢。七悬幡盖。八放光照法界。九杂宝庄外。十四边阶道令可登涉。二严园中佛神力是所因也。忽然广等显广处也。众宝下亦十种庄严。一总句。二以宝布地。三宝墙。四宝树。五香河。六多阁楼。七光照。八宝庄地。九出妙香。十建宝幢有十七种。三庄虚空亦有十种。一天宝宫。二香树。三须弥。四宝乐。五宝树。六宝座。七宝像。八珠网。九楼阁。十解脱音乐。第二出严因中有二。先征谓何以有此不思议严故。二释中有十句。一由是如来不思议善根之所生故此约因也。二由是佛果无流法故此约果体。下明果用。三总举神力。四别举身通。五六二句明身土无碍微细相入。七八现过去佛照现在刹。九十出佛现刹。此上庄严并是如此佛果体用非余位能知。是故皆云不思议也。上来一方祇洹竟。二类结中。如此祇树等举此也。一切法界类通法界。同此现土。此处随粗。是须达所造。然其据细。乃称周法界该于十方尽于三际。以通不碍局故须达新造。以粗不异细故。所造则微细而周法界。如常在灵山及案足所现。皆此类也。二如来满等明智正觉世间圆满。此并于斯所现刹内各有如来。俱来诣此满祇洹中。三众生世间中二。初菩萨充满。二雨十种供养云。上来现净土分竟

第五集新众分中有二。初明所集之众。后皆是如来威神力故者释集所由也。前中亦二。初别集十方。后总叹其德。前中十方则为十段。于中初二及第六各有九门。余方有十。先东方九义。一集处远近。谓过不可说刹尘界表法深远也。二有世界海名金刚等。表所依之法界也。金刚有二义。一坚。二利。云亦二义。一遍。二润。明净亦二义。一普照。二离染。今勘梵本但此名明净之言。皆梵名毗卢遮那也。灯亦二义。一破闇。二照现。庄严亦二义。一饰事。二严理。三佛号等表能依之圆果。谓明净同前。妙德梵名室利。则吉祥之胜德也。王显自在。四标上菩萨名显能依之分因。明净同前。愿是自体大愿也。光明破无明照法界也。五眷属俱来。六兴供养云。谓天花等事供满虚空。七诣佛礼供。八本方化作楼阁花座结跏而坐。九宝网覆身。显胜德自严。若准下余方加第十。或髻珠或天冠。显其胜相为标帜故。余方世界佛名等。准释可知。南方供中。妙香等杂事充满一切佛世界者。此并称法界法门成此供故。是故或云满虚空。或云遍法界。或遍一切刹。或充众生界。皆无障碍。参而不杂。西方供中同名须弥山云者。显妙高具德之相。皆充法界者行同理性故。一切如来相好为须弥山者。明果德妙高故为菩萨所行。须弥山者因行高成故。此等并以人同法。以正同依。以果同因。无碍法界自在之德。北方供中同以衣供。显惭愧严身之相故也。亦通人法教义等。东北方中同以楼阁为供者显重成高出阶级之相。亦通理事等。东南方同以圆满光云为供者。是身所佩表具德胜用故也。虽通内行及外事。文中以佛无见顶相为供具者显尊贵之极。明以佛供佛方穷际故。西南方同于毛孔出诸炎云者。显烧惑薪而照理故。身出此炎。乃照三世者明九世缘起贯通故。以遍一切处该一切时也。西北方同于相好及毛孔出三世十身通三世间。明身业胜能。同法界佛果大用以为供具。下方同于毛孔出十音云明语业自在。同佛果德应机设法无碍之相。上方同于六处之内出三世佛十度等行。因果圆融。明意业自在。此上十位供具。亦从初至末显渐深之相。并是圆满教中菩萨同佛果而自在。是故非下位及二乘等所能知见也。第二叹德中有四十句分三。初一句总叹。二成就三世下三十八句别叹。三此诸菩萨下一句结叹。别中亦三。初明摄佛三业。二于大众中下明摄化之智。三知世界智。初中亦三。初四句明语业自在。一得佛眼见法。二能转佛所转。三摄佛圆音。四超因至果。二于念念下六句明身业自在。一念念无间诣诸佛所无有休息。二明法界身云一遍一切。三能于佛众现净法身。四幻通之力尘中现刹。五虽常在佛所而化众生恒不失时。六于身毛孔出法雷音。如密严经中。金刚藏菩萨遍身毛孔同时发声演妙法。亦同此也。三知众生界下七句明意业自在。一知众生缘集如幻。二知诸佛有用如电。三知有趣现实如梦。四知起果酬因如镜像。五知生相有体无如焰。六知广器显现如变化。七具足等结能知具果智也。上来同佛三业竟。二摄众生三业中十句分三。初五句明语业摄生。一决定宣说。二辩海无尽。三同物言音。四于理不碍。五于诤斯尽。二有二句身业摄生。一具通智者。通以惠为性故名妙智也。二勤行摧魔者。以精勤力故魔久摧伏。又以神通力故伏耶归依众生故也。三安住下三句明摄生意业。一三达殊胜智。二处世无染智。三得佛圆果智。三知一切有下十一句明世界自在智。于中初二明真谛智。一了妄空。二深入等证真性。三量智普入。谓不改真而入俗故云不坏智也。四入已回转现身自在。五同时示现多处受生。六知方圆等形类差别。七八二句明广狭自在智。亦是知微细世界智。九得佛持刹智。身能住于佛住。即器世间身也。十净惠照十方。十一自在普周遍。结文可知。如来神力者集众所因。此文应在前。但为顺西方语法故。在此后辨。上来集新众分竟

第六举失显德分中有三。初显能不见人。二明所不见境。三释不见所由。初中前文通列大数五百。今此别标上首故举十大弟子。舍利弗者此云鹙子。梵正音云奢唎补呾啰也。奢唎此云鹙。即当百舌鸟之类也。吴僧会法师六度集中译为鹙鹭子也。此是母名。以其母有辩才峻捷似同彼鸟。眼转明利亦如彼鸟故。从喻为名。补呾罗此云子。以儿从母为名矣。古译为身子者。以梵语中名身为舍利。如佛身分为舍利。非此所用也。智论中。亦是过去发愿。为释迦佛弟子而立此名。以能论义亦名优波提舍。二摩诃目连者。梵正音摩诃没特伽罗。此云大采菽氏。上古有仙居山。静处常采绿豆而食以为姓。尊者之母是彼之族。取母氏姓而为其名。得大神通。简余此姓故云大采菽氏。此与鹙子二人因缘如别说。三摩诃迦叶者。梵音具名摩诃迦叶波。此云大饮光。饮光是姓。婆罗门姓中上古有仙。身光饮夺日月之光。迦叶是氏之族故以为名。是迦叶身光亦能饮夺日月之光。又是大富长者之子。舍大财姓。出家能行少欲头陀大行。为大人所识。简余迦叶故名大矣。四离波多者具云颉丽伐多。此云室星。即北方星也。祀之得子。因以为名。又名阿唎波多。此云所供养也。有云名假和合。即智论中二鬼食事显之也。五须菩提者正云苏蒱底。此云善现。亦云善实。古云善吉非也。六阿泥嚧豆者正云阿泥嚧陀泥嚧陀。此云灭。阿云无。即名无灭。是佛堂弟也。七难陀者此云喜本。是牧牛人。因问佛牧牛十一种法知佛具一切智。得阿罗汉果。性极聪明音声绝妙。令人闻喜故以为名。八金毗罗者正云劫比罗。此云黄谓上古有黄头仙。因以为姓。亦从姓为名。九迦旃延者具云摩诃迦多衍那。此是姓名。此云大剪发种男。婆罗门姓。上古多仙。山中静处年岁既久。须发稍长无人为剔。发婆罗门法恶为剔发。时一仙有二子。俱来觐父。少者乃为诸仙剔发。仙愿护。后成仙贵。尔来此种皆称剪发。尊者身是男子威德特尊。简余此种故云大剪发种男。又西方取母姓者。今显是父姓故置男名。十富楼那弥多罗尼子者。富楼那者正云补剌拏。此云满也。弥多罗者正云梅呾唎曳。此云慈也。尼是女声也。弗呾罗此云子。即满慈女之子。从母以立其名。如鹙子等。如是等结其不见。等二所不见中二。先明不见法界佛果。后显不见法界菩萨。前中十句。与上众人所念请法多分是同。问若全无器前不能同念。若有器能念。何故今乃示之不见。答有悕法心前能同念。眼未开故示之不见。又前但念自三乘佛果。今示一乘故不得见。十句中初一总。谓显如来障尽作用无碍故云自在。下别。一胜果位二严。二果位分齐及佛所知。三作用多端。四圆音决定。五离粗相之德。六无思利物。七威力自在。八持诸佛所作。九所依净刹。此等并是前后所现身土等事。如是下结其不见。二亦复下明不见菩萨众中亦十。初不见大会者是总也。下九别。别中一是境界业用集来之相。二不见眷属来处及坐此中宫殿。则前化作楼阁是也。三不见跏坐三昧观察。四不见菩萨所作供具等。五不知受记长善等。六不见菩萨所受之身有五身可知。七不见菩萨圆光等。八不见菩萨充满一切十方等。九不知菩萨所有德行。又释此上九中。初四句中细开有十句。释前云集菩萨众。后五句内亦有十句。释普贤等本众。并可知。如是下总结不见。三释不见所由中二。初法后喻。前中亦二。先明因时不修其见因是故不见。二亦无三昧下明果时绝无其见分是故不见。前中有四。初明行劣不逮胜。二是诸功德下显胜以过劣。三何以故下释胜以非劣。四是故下结劣不见胜。初中先征问云。若无善根不应在会。若有善根不应不见故云何以故也。下释成中。初总释云。有善行故得在会。以是别异善行故不见也。又由不同凡故有善根。不同菩萨故不同善根也。下别释中十九句。初十二句别释前不见佛果。于中初二句略释。谓释初以本不修习大菩提善根故。云本不修习能见如来自在之善根。故名别异。是故无因不能见佛也。自在是前佛果十句中初句是也。二但修入趣涅槃之行故云不修净佛土行。净土是前十中末后。是故举初举后。中即可知。下广释中。初七句不修利他行。后三句不修自胜行。亦即初是狭心。后是劣心。文释可知

二不求菩萨下别释不见菩萨所由中七。一不求通明。二不修彼善。三不生彼愿。四五不知法空。六不入彼位。七不得普眼。二显胜过劣中。明上二十种所不能修功德之法超过二乘不与共故。是故彼法非此能修。不能修彼为因缘故。是故于彼不能见等。谓眼不能见。耳不能闻。证不能入。比不能知。察不能觉。虑不能念。智不能观。意不能思。三释中先征问云。何以如此。总不能知。为是总不可知故不能知。为二乘总无智故不能知。故云何以故也。下释云菩萨智境者。非是总不可知。以深智能知故。非声闻智境者。亦非声闻是无智慧。但智浅境深故不能知。四是故下结不知可解。上来不修因故不见竟。第二明果时绝分故不见者。谓得小果故。于此法绝分无入。是故前文但言不能修习等。今此文中乃至云无三昧眼等。故知前约因时不能修行。今就果位总无分也。文中有三。初总举。二征释。三结不见。初中十句。一无深定眼。二无所得法。三无大悲功德。四无是处智。五无大智眼。此上无自胜德。下五句无利他德。二征释中。征云声闻因果岂可不是佛境界中一分所摄。何以总言无彼法耶。若总无彼与凡夫何别。故云何以故。释意以出三界故不同凡夫。以住权乖实故无彼法。又由有四失故。是故总无。一出粗而不离细。谓但出分段三界不离变易生死故。二得权而不得实。三滞寂而失悲。四自调而不救物。又初离过不尽。二得法不深。三无大悲心。四无四摄行。三是故下结不见。上来法说竟。问如有经云。声闻缘觉若智若断皆是菩萨无生法忍。既亦彼菩萨所得。何故此中而言总无。答二乘是菩萨法忍。非菩萨是二乘所知。问若尔何故经云汝等所行是菩萨道耶。答由回心故。是渐悟菩萨道非是顿圆。此约顿圆故非彼分。问只可闻而不信。如文殊行经中五百声闻闻不信受等。何故此总不闻见。答彼是三乘逐机说今得故亦闻。今此一乘逐法高出故。不能闻。其犹重阳丽空发雷振音。蚁子等类不能闻见。问若尔二乘应非法界所摄。答法界广故摄于二乘。二乘狭故不摄法界。问法界缘起一尘犹能摄于一切。何故二乘狭而不摄广耶。答广狭相摄是菩萨所知。二乘无此故非此摄。问二乘岂不亦是菩萨所知法界。何故不摄答是此摄故彼不知见。如聋盲也。问若是此摄应得知见如菩萨众。答法界缘起略有二门。一顺缘门。如成法因等。即佛菩萨要是知见方得摄耳。二违缘门。如相违因等。即二乘众要不知见。方乃摄耳。此二缘门望所起法悉有功力。是故同此。缘起所收见不见异。问若尔凡夫外道亦是违缘。何不此摄。答彼无德人不堪于此。如聋盲故。设余声闻犹恐不堪。是故要以鹙子等类诸大声闻。或是菩萨变化所作方显法胜。是故辨之。问若尔此声闻等得此法不。答并得法。何以故如聋盲入缘起故。以此为得。思之可解。问若得应知见。答若知见即不得。以非是相违缘起摄故。不名得也。菩萨不同此故不例也。正由二乘问二乘高德尚如聋盲。如今凡夫岂得受持。答往昔凡时不受持故。今时对面如聋如盲。今若不受还亦同彼。是故只为高德二乘如聋盲故。故须受持。增长信力令后得之。第二喻况中有十喻况之。远法师等诸德皆将十喻配前所迷佛果十句功德。唯第九二天喻。喻上第二如来庄严。余皆次第配释可知。又就此十中见不见分别有三义。一第一第五第十此三喻二乘不见佛果功德。二第二第三第四此三喻菩萨能见佛果德。余四喻如来自见果德亦见二乘等法。又释此十别相者。一鬼对恒河喻。喻二乘有所知障故不见殊胜境。辨法师云。如饿鬼者。喻二乘人不得菩萨法界行食故云饿也。鬼者似人非人。喻二乘所得涅槃似而非真也。裸形者以无菩萨惭愧行服。饥渴者以不得无二理观沾其神故。举身烧燃者四相所迁不息也。毒兽所逼者。不知生死是自心所作。乃怖而舍之也。往诣恒河求水饮者。趣祇洹处求解脱味水也。或见枯竭等者。唯证断涅槃不见法身净土法界之德水也。由罪业障者喻法执无明之所障也。下合喻可知。二觉对梦境喻。喻二乘人守劣乖胜故不见。于中先喻后法。法中先总次别后结。别中菩萨睹见出九种因故可知。三愚对雪山喻。喻二乘人狭心无悲故不见。四咒见伏藏喻。喻彼二乘无净慧眼故不见。五盲人至宝洲喻。喻二乘无净眼故不见。六涂眼隐身喻。喻彼二乘无深智故不见。七遍处定境喻。喻彼二乘无深定故不见。喻中天者是空处识处也。众生境界者是青黄赤白也。八曀身自见喻。喻彼二乘无深行故不见。九二天随人喻。喻彼二乘无密智故不见。十灭定无见喻。喻彼二乘住位息求故不见。上来总举劣显胜分竟

第七偈颂赞德分。于中十方菩萨说即为十段。初段中十颂分二。初九明述前三昧用。后一结用所依。即显是前师子奋迅定也。前中初五欢佛身土无碍。于中初一自在。次二甚深。后二广大。后四叹菩萨众德。于中一显前云集。二愿行深。三超二乘。四定惠坚。第二颂中分六。初二叹众具德。初位满后德深。次二叹处众集。次一断障证理。次二不动普遍。次一结归佛力。后二了达佛法。初义后教。第三颂中分二。初三法说。一叹佛说法应时。二叹佛力用摧耶。三叹佛法超情表。后七喻况中。一智达三际喻。二无漏德圆喻。三自在遍知喻。四德无限碍喻。五法轮荷戴喻。六无碍速遍喻。七智轮为本喻。第四颂中。一德山益物喻。二悲海除炎喻。三行高深证喻。四五二颂明智海出生喻。六巧现应机喻。七随愿毕遂喻。八种智普照喻。九随方现法喻。十见佛净根喻。又释此十中一大福。二大悲。三大定。四五理智。六量智。七悲用。八种智。九镜智。十慈用。第五颂中分四。初一叹见益。次三益菩萨。一总叹。一别令得法。一别令成行。次一现三世间。次三现法成益。一举能。一广现。一成智。后二法轮益物。第六颂中分三。初三明凡小不能知。次四明所不知之德。一智深。一福广。一巧化。一德法。后三显能知之德。一修行。一破我。一愿满。斯等能知非是佛德总非可知。第七颂中分三。初五叹佛体德圆备。于中初一总叹身净。次二万行为因。次二灭障成德。次三叹妙用难测。于中初一色用。后二智用。末后二总结。一不思。一不议。第八颂中分三。初二出智德。一依闻出。一依心出。次三坚固行。一精进行。一信智行。一回向行。后五断德行。于中初二离染成自行。后三离染成利他。第九颂中分四。初二叹佛语业利益。次二身业利益。次二身语双益。后四利益见闻。第十有十一颂分四。初二叹佛益菩萨。一现德令见。一转法令闻。次五叹佛为生忍苦。是大悲深厚也。次一释忍苦所以。余三明见佛成益。上来偈赞分竟

自下第八明普贤开发分。令众生信故。于中二。初长行后偈颂。前中三。初明说意。二显能说方便。三辨所说分齐。初中欲重等者。前明教主自入此定广现其事。开现法界未有言说。今明普贤以言广说。更重开前定。用法界使显现照明。令诸菩萨同入此法故云重开等也。二以法界等下明能说方便有三。初总次别后结。别中十一种方便言以者是用也。用此等法界等诸方便而得十种广说如来三昧德也。一法界等者。谓如法界既无边尽。此能说方便亦同法界故云等也。余皆如是。何以尔者。以奋迅定业用广大。用余方便不能显故。是故十一皆将无分齐法。以用类之。此一是总句。余十皆是法界别句。于中悕望约始。欲据终。法光是能化法。随时约就根生熟时等。余门可知。三为诸菩萨下结成显意。谓以法界等方便。为诸菩萨。十种广说师子三昧。虚空界等方便亦十种说。余并准之。三何等为十下明所说之法亦有十门。望前能说有二门。次第配前十一方便。谓以前方便如其次第说此所说。是故各配一种。唯第十中摄后二方便。准释可知。二前十一方便一一皆有十种广说。则成一百一十门也。细思准释义理可见。此十何别。一多佛出。二多时说。三多处现。四摄多众。五一念此一与前念请中初十可计会思之摄九世。六一身充法界。七依报境中现佛德位。八依报微尘中现佛自在。与前何别者。境粗尘细故别也。九正报毛孔出音恒作。十遍坐道场常转法轮。此十并师子奋迅三昧之德。犹是略说。佛子下显未说者更复广多。唯如来智境者明更有广多非菩萨能知。第二尔时下明其重颂。文中亦二。初序意。后正颂。意中承佛力者显非自能故。观如来者明有所承故。观大众者明有所为故。余句观其所说故。此等并是佛果差别德故。正颂中于前十法次第颂之。初中一一毛孔中颂前一切法界中也。余三句颂佛兴等。二中净法轮颂前一切佛所说。三中最胜加坐等颂前现成正觉。四中菩萨云集等颂前大众皆往诣等。五中说诸法界等颂前充满一切法界也。六中显现诸佛刹入法界智海等颂前充满一切世界海等。七八二颂半颂前第七法。安住于如来一切诸境界者颂前一一境界也。亦有本作一切诸世界。世界亦是依报境也。安住如来地者颂自在功德地也。中间并是三世佛功德法。九中初二句颂前第九法。后二句却颂第八法。末后颂中初二句颂前遍坐。后二句颂常说。上来开发信分竟

自下第九毫光示益分令众证入法界故。于中有三。初举佛放光为示法之缘。二时祇洹下明众依缘见法。三其有众生下辨见法得益。正入法界。初中五句先标意。欲令菩萨因人随分亦得此三昧故。又此三昧中所显现事即是大众前所疑问故。佛答问而入此定。令众亦得方为益也。二放白毫光者显中道平等白净法界。是前三昧摄生之用。三名照法界者依义立名。谓照现三世法界法门。令诸菩萨得入此门故云也。四摄眷属明具主伴故。五照十方等者辨摄化分齐也。二令众见法界中二。先举能见人。谓普云集通新旧二众也。二明所见法中亦二。初见此方法界。后类见十方法界。初中亦二。先见一切世界中现身说法。二或见天宫下明见一切宫殿中现身说法。前中先举所现之处。如是等下正明现身说法。具三世间可知。二天宫等中亦二。先所现处即于前世界中更取微细十种宫殿。二现种种身下正明现身说法亦有十种。于中种种持者义持也。教持是法持也。此等所现并是通答前十句疑问。谓佛自在等可准思释。二类见十方中二。初举此类彼。二显自在。类彼中初粗类十方世界。诸业所起者彼十方中器世间及众生等。并是实报显现故名也。三细类毛孔中可知。二显自在中初一句不坏广事。谓虽在毛孔微细之中。而亦不坏三世九世广大无边众生界等。差别宛然。次三句明业用。一照其心。二为现身。三开示法。后一句结神力三明见法得益中二。先辨见法因缘。后辨所得之益。前中亦二。初约佛有缘。宿缘得见。二约行已修。具德方入。三句。一利他。二自利。三摄成入法方便。二明所得益中有三。初明因见得法。二彼诸菩萨下明因法成德。三尔时下明因德起用。初中二。先逮得下一句标其所得。谓得佛地广大三昧。以此众并是普贤位中诸菩萨故。是故所得无有渐次故即究竟。二或得下辨其所得。于中三。先总标所得略列十门。于中初六明得菩萨行位究竟。后四明得佛果自在成满。二此诸菩萨下结略显广。于中初结数后结名。名中十一句者是增数十也。何以知者。以结数中云十不可说等故知也。种种道者结前。法身是智所游处故云道。然有多类不同故云种种也。理实无二。何以言多。谓摄生异故。能游之智有浅深故。二种种门者结前色身异类。标别故云门。三种种入者结具诸行能有证入故。四种种度者结诸波罗蜜度到彼岸故。五方便者结前净行巧能圆故。六至者结得菩萨究竟地故。七方者结菩提自在遍十方故。八光明者结三昧业用起光明故。九功德及具者结诸行智力故。十自在者结无碍辩才故。三深入菩萨下释但广前。初句所得三昧一门余类准之。就中二。先明因显广义。于中二。初深因位明自分终极。后入如来海下妙契果海显胜进圆满。前中三。初一句总标。二所谓下百门别辨。三如是下结略显广。此百三昧于上十句种种之中。一一各有如此百门及后结广。以彼十种是标大门故。所谓已下是别辨故。是上文结数云十不可说。此中下结直云不可说。故此是十中一也。又释此百但是前十之中种种门之一门也。何以得知者。以下结云不可说刹尘三昧门。不云道等故得知。又上文但云十不可说等妙功德。不唯言三昧故也。问此种种门内含有陀罗尼门等无量诸门。何以此中唯辨三昧门耶。答以初标云逮得如来不思议自在三昧。是故就此以广显之。又前云为欲令诸菩萨安住师子奋迅三昧。是故偏显此门。理实诸门无不皆具。如下文云。一一皆得不可说等大悲法门。亦是此类也。又百门并由业用异故差别立名。准释可知。于中初一明所依之本。以无尽行海用类平等法界。使出缠结究竟圆明具德故。以为名。末后一明摄归其位故。名观察师子奋迅菩萨三昧。上诸三昧皆为趣向此三昧故云观察。然此不同佛地所得故云菩萨也。中间诸名随义思释。二入佛果者由前所得因位终尽。是故果海方能趣入可知。上来因见得法竟。第二因法成德中二。初令座广大。二现大自在下正显所成德。于中二。先别显后总结。别中有十门显德。初成就深智德。二悉为众生下了法为师德。三乐寂灭下随缘无著德。四安住庄严下成就众生德。五解一切众生下解深具行德。六具足十力下得法智能德。七巧妙方便下巧便胜智德。八得一切法无碍下理智契真德。九放净法光下摄生见佛德。于中初摄生成益。后常见下见佛得益。以分别了知诸法自在大小相摄故。是故于一切法得无诤境界也。十决了如来下照法圆融德。于中先总持转法德。二成就如来下妙穷佛境德。二彼诸下总结可知。上来所成竟。第三明因德起用中三。初总次别后结。初中深入等结前也。身中等起用处也。乐法力等用因也。于念念等总举用相也。别中十事差别可知结中法力者是此所得法界法门力也。上来大段第九示法成益分竟

自下第十文殊述德分。于中二。先述赞。后显德。前中二。先序意可知。后正颂有十三半颂分二。初五叹祇洹中所显示法。于中初二叹祇洹中器世间自在用。次二叹菩萨众生世间自在用。次一智正觉世间自在用。二余颂叹诸菩萨等得法业用。于中初一颂前境界等中所出妙用之内初句叹三世佛功德。次一颂叹前第二句说众生净业果报等。次一超颂出佛化身云等。次一颂于一切佛刹赞佛功德。次一超颂末后转法等。即方便度生是也。次一却颂愿行庄严等。次一颂三世佛严道场云等。末后一颂半颂所叹普贤行等。此等并是祇洹林中当时所现之事。今文殊颂中述赞辨矣。第二显德益中有三。初明所得行体。二一一毛孔下明所得行相。三随其所应下明行胜用。初中由佛三昧照故得此大悲。为利他行体。毛孔光所出尊重身云明大悲之相。就第三胜用中二。初总辨大用。以满法界。二现不可说下别显悲用。于中有五门。一以欣厌二门化。二或于一切世下以十度门化。于中三。初明现处。二为一切众生下正明所现十度。于中初六可知。七从善知时会下明方便度。八悉能供养诸佛菩萨此一句是愿度。九降伏下是力度。十知一切下是智度。三以如是下结法成化。三或现天宫下明以三轮门化。于中四。初明化处。二大悲智下明化心。三或以名号下明化行。于中光明等是身业神通轮。余二可知。四现处处下明化实。谓此菩萨虽遍法界化用摄生。而本不离此佛众处阁内座上。此显不动而普遍繁兴而恒寂静也。四或放化身下以三世间身化。于中初以智正觉身化。无二者为无为无二也。又一身即一切故无二也。二或现声闻下明以众生世间身化。三或现一切城邑等像是器世间身。随其所应结成化用。五或现种种下以三业门化。于中初明身语化。次种种巧术下明意化。后悉现下结成化处。上来从会初至此十段不同。总明本会竟

第二从尔时文殊下明其末会。于中前则不异末之本故。虽卷而恒舒。则后文是也。后则不异本之末故。虽舒而恒卷。即前文是也。是故本末无碍同为一品。意存于此

今通释。此下文略作十门　一叙诸古说　二会数开合　三会主多少　四定会名义　五二位统收　六分成五相　七圆摄始终　八明法界人类　九法界事义　十随文解释

初叙古中诸说极多。难以备举。且叙一二。一家云。此中知识有四十五人。后文殊不立只有四十四人。初一是十信知识。次四十是十住等。四十位知识。次二为等觉位知识。后一是妙觉位知识。以旧无补阙文故但辨四十四五耳。光统等诸德并多同此说。更依一家。总不配位亦不悬科。但随诸会依文散释。即如五台论及意法师等并同此释。此二之中前说于文小违。后说于义无妨。准思可见

二明会数开合者于中有六。一若约所摄之机唯有三会。一摄比丘会。二摄龙王会。三摄善财会。功德云已去并同第三会摄。以所摄之机无差别故。二若就能化之主有五十二会。谓初三及后第五十四普门城会。俱是文殊无别主故。余五十一各别人会。是故约主唯五十二也。三若约能所通辨有五十五会。谓善财有五十三。比丘及龙各有一故。四若约主伴别分有一百一十会。如下文辨。五若约散说所依有三千大千世界微尘数会。如后文殊处说。此约引彼三乘机辨。六若约普贤德有十方世界微尘数会。如下结通处辨

三明会主多少者有二重。一若唯就人说有五十四人。谓于五十五会中四会唯一人。谓文殊。又有两会各二人。谓遍友众艺并童子童女。是故会有五十五主有五十四。二若约会显人有五十七人。谓于五十五会中二处各加一。谓遍友等可知

四定会名义者。问此等诸会并无佛说。何得为经。答此等并是传法菩萨。结集当时求法说法诸菩萨事。同上本会所现祇洹自在等法。令彼大众睹已入法。虽无佛语岂亦非经。问前本会中佛虽无说。诸所现事并在佛会之中。今此乃在远方异处说。非佛说。复不对佛。岂得为例。答虽在远处而不离本会。是故常在佛前。如上文中祇洹林内。一一境界尚摄十方一切佛刹。况此诸处而不摄耶。是故此五十五会不出本故名为一会。谓入法界品也。问既此诸处并在祇洹。下文善财应见普贤及佛大众在此重阁。何故乃见在金刚道场。答以觉树金刚为八会本故。是故不动觉树遍诸会处。寻末见本。还在此故。又此会初普贤及佛在祇洹中。更无移动见之觉树。即此祇洹亦在树下。思之可见

五摄二位者。此五十五会二主统收。初文殊至后文殊。是文殊位属般若门。后普贤一位属法界门。非般若无以入法界。是故善财创见于文殊。非入法界无以显般若。是故善财终见于普贤。是故二人寄二位以明入法界。又前文殊即法界甚深义。后普贤显法界广大义。是故二门相影具德。问前中亦有功德云等余善知识。何故乃云总是文殊。答皆是文殊摄化德故。悉从文殊智慧大海所出世故。是故下文或云文殊教我相黡法等。弥勒亦云。汝今得见诸善知识来我所。皆由文殊师利之所摄受(勘之)是故有形文殊作开觉之初缘。无相妙德结终之妙趣。于中有三。初一明始起于先际。二从功德云下明善修于中际。后文殊明终归于后际。此亦是一周之行相耳。就中际中。初四十人明位内行缘则寄四十心位。后十明位后行缘即位外所修等也

六分五相者。长科此文总为五相。一寄位修行相有四十一人。二从摩耶夫人下有九会十一人明会缘入实相。三弥勒一人明摄德成因相。四后文殊一人明智照无二相。五普贤一位明显因广大相。又此五相亦是菩萨五种行相。一高行。二大行。三胜行。四深行。五广行

七圆摄始终者。谓此诸会差别位中一一各摄一切诸门。是故一位即有五十五及百一十并刹尘等。如一一切亦尔。重重准之。但为寄法显异布之前后。思之可见问若一即具一切。善财何须广历诸位。答此之所历。并是一中之一切故不出一也。问若是一中之一切者得一即得。彼何须更历耶。答得一即是历多。是故同时无有障碍。思之可见

八法界人类有二。先辨类别。后显义相。前中虽总通论有五十七人。收摄流类但有二十。一菩萨二比丘。三尼。四优婆塞。五优婆夷。六童男七童女。八天子。九天女。十外道。十一婆罗门。十二长者。十三博士。十四医人。十五船师。十六国王。十七仙人。十八佛母。十九佛妃。二十神。二显义相中有四句。一约果摄化。总是佛智摄生之用。海印三昧之所显现。二约因成行。总是菩萨成行摄生。但随愿力现形差别。以应群机。三约义显德。总是缘起法界之中人法门摄四约相辨异。即是菩萨。五生所收。一息苦生。二随类生。三胜生。四增上生。五最后生。于中菩萨有六。三处现身。一初文殊为佛母故。本有缘故。初位劣故。唯一人也。二中间渐进现于二人。谓观音正趣也。后位成满显德胜故。具有三人。谓弥勒文殊及普贤。余人寄显位别。至文当辨

九法界事义中通下诸位总有十门。一正报法界。二依报法界。三现相法界。四表义法界五言说法界。六义理法界。七业用法界。八说往因法界。九结自分法界。十推胜进法界。然此十门同一缘起互融无碍。随一皆具。于下文中有具不具。随文准之

十释文者今依五相科释此文。就初寄位修行相中有四十一知识内。初文殊一人寄当十信知识。以信不成位故不辨十人。余四位成故各有十。就初中分二。先明发起能化之缘。后尔时尊者承力下明成彼化事。初中三。先主伴出阁明依本起末也。证如离念名善安住。法界数重名为楼阁。从此正证起后妙智名从阁出。同行者智眷属故。以文殊表是吉祥智故。菩萨是内眷属。余力士等外眷属。十天者梵云提婆。此云天。亦云神。同上初会中地神河神等。并是法门之神。如名准释。此显内报离染。次有八王表法自在可知。此并显文殊之威德耳。二俱到佛前。三设敬辞去。明就机救济故二成化事中有三会则为三段

初摄比丘会中有二。初明身仪摄益。则令根熟起欲。二尔时文殊告诸下明语业摄益。则正授法门。前中有七。初睹胜缘。二起胜念。三摄胜机四示胜境。五得胜益。六诣胜人。七蒙胜摄。初中鹙子向会如盲。何故此中乃云得见。释以出本会故。承佛力故。二见已等者以根熟故作此胜念也。三尔时下摄胜机。于中初总辨。六千比丘是所被机。从自房出者表舍小涅槃也。向文殊者表趣一乘道也。又文殊出阁辞佛南游为化主故。鹙子出房辞佛南游从为助化。引摄六千正为所化。问若尔鹙子亦是大菩萨。何不同在阁。答寄迹是声闻故不在彼。二此六千下别显所被机。于中三。先标数位。共行者同鹙子行。如上文殊同行菩萨。此亦如是。又释同彼鹙子相示声闻。德实菩萨之行故云共也。新出家者未得罗汉果故。染习未深。明易回故。又释新出小乘分别心家。已入三乘位。以鹙子是三乘之中法将故。引之新出。文殊是此一乘法将。方便引之。二其名曰下列名。比丘者梵有三名。或云比呼或云苾刍或云比丘。此无正译。义翻有三。谓怖魔破恶及乞士。释相可知。三已曾下叹德。于中有八句。初二句明宿有大因。三性乐下现有深信。四现行大愿。五观佛胜境。六了法实相。七大悲益物。八乐求佛果。此等皆是下结德由缘。谓明过去已蒙文殊摄护。是故今时还为救济也。四尔时下明示胜境。于中二。初劝观自分境有六。一令观身光胜。二眷属胜。三威仪胜。四行处胜。五依果胜。六供养胜。二海智下劝观胜进境。谓加持胜也。五尔时下明得胜益。于中初闻赞悉喜是总句。下别有十三句益故欢喜也。于中分五。初五句明离障益。二现见下二句发心益。三逮得下二句成器益。四长养下三句增行益。五悉见下一句见佛益。六时诸比丘下明诣胜人。于中二。先白尊者等起胜欲乐也。二往诣等告来意也。七尔时文殊下明蒙胜摄。于中三。初象回顾视者明摄受之相。二比丘礼足明归诚之相。合掌而立明伫闻说相。三作如是念下显胜愿熏心方堪受法。初愿知法以得涅槃。后愿身相等以得菩提。前中如舍利弗者约生空实相。释迦者约法空实相也。又释如舍利弗所依之释迦。此则举舍利而取释迦也。上来文殊身仪摄化竟。自下第二语业授法中文有二。先授自分法。二尔时文殊下授胜进法。前中亦二。先授法。二彼诸比丘下明益。前中三。初警告总标。二何等下别示行法。三若善男子下举益劝修。别中十门以显无尽。摄为五对。初二为一。谓大心敬佛。次二为一。谓求法修行。次二为一。谓依定起用。用者则是大悲方便。随有受生不失正念。能于生死久处摄生。此即翻彼二乘怖生死见也。次二为一。严土摄生。后二为一。谓自行化人。又释前八自分。后二胜进可知。三举益劝修中。举十种益以劝修学。一生善益。二离染益。三超出等出小益。四生如来等入大益。五具足等大愿益。六行菩萨行成行益。七住位益。八成果益。九降魔益。十制外益。二彼诸下正明闻法得益中有二。先明闻法得定益。二得此下明因定行成益。前中亦二。先明所得定体。谓所见彻过故云无碍。能见离曀故云净眼。下明业用亦二。先见现在无碍。后又能下见过未无碍。前中初见正觉及众生。二见器世间。谓明所见境界广大无边故云如来十眼境也。三闻前所见诸佛说。四他心通等知前所见众生根欲。五以生死智通知彼受生等。二知过未中八位各言十者。以应圆数显无尽故。二明因得此定令行成立。初句标所得心。具十者广无边故。实际者深无底故。二主伴定。三主伴戒。四主伴智。五十明是智用。如十明品说。此是圆教摄机顿成大益故。创立大心乃得十地之后十明之用。以始摄终。如上发心功德品及小相品等说。余教中则无此事。第二胜进中亦二。先教劝后得益。不死通明者。大悲为因离业系故。又释离分段故。又释通明作用无休息故。不离此处等有二。一不动此因出生果故云生如来等。二不离一处能出佛身满十方界。此是不死通明之力。具一切佛法者明成果德之法。上来明摄比丘令入法界一会竟。此中明二乘回心义。略作三门。一明回之有无。二明回心身位。三辨回心至得(云云)。自下第二摄龙王入法界会中有四。初结前起后。二辨说法处。三辨所说法。四所得益处中。辨法师释云。觉城者本觉也。东者始觉也。大塔庙者始觉觉本觉也。则于此处说普照法界者。则于始觉觉本觉处。觉心无初从本已来遍照法界故。又日照三藏云。此城在南天竺。城东大塔是古佛塔。佛在世时已有此塔。三藏亲到其所。其塔极大。东面鼓乐供养西面不闻。于今现在。此处诸人处处唱善财歌词。此城内人并有解脱分善根。堪为修道之器。有觉分者在此城内故云觉城也。此则觉者之城名为觉城。又释文中既云是过去诸佛所游止处。佛既名觉故知亦是觉者之城。又准释下文。城山处所有名义皆是法门之所表也。谓觉者表于生死有觉察故。城者防敌外难内守德故。即觉用也。东者开明之始。表是发觉之初简终位之觉故云也。塔庙者显此觉德是归宗之所故也。若余教中托处表法。非处即法。此圆教中所托之处即是所表之法。名义即事义故也。思准之。下文处意并同此

三所说经从所诠立名。谓智用宏舒名为普照。所照深广称为法界。即是入法界经也。具足主伴是圆教法门。四获益中。初舍恶身。后坚胜心。此亦同前比丘住不退转普贤菩提心位也。第二会竟

自下第三摄善财会。今通辨下。文相别不同。略作十门。一明赴求差别。二修入众别。三示方差别。四示处差别。五教问差别。六叹不叹别。七推不推别。八结不结别。九去不去别。十释文

初中有三句。初文殊自就觉城。以物机初劣未发心故就之方摄。二功德云已去有善财往求。显位成故。根渐胜故。已发心故。知识不就。显法重人尊故。三末后普贤中知识不就善财不往。明法界位满无来去故

二修入众别者。于中唯初位内有三会四众。以是修故。余位唯善财一身以行别在人故

三示方差别者大位有三。初地前知识多在南方。地内无方。地后亦有南方之者。其南有四义。一是正义。如指南之说等。表所向非耶故。二是背闇向明义。表舍障向理故。三是离增减义。如日东出西没是增减相。南离二边表中道法界。四是生义。谓南主其阳。是其生义。北主其阴。是灭义。此表善财因行渐增故显生义。如来涅槃金棺北首表其灭义。于此四中前二后一地前表之。其离增减义地后表之。地中正证离相故不可南表。地后显业用。不同地内也。后文殊有示无方。表般若有加行证无二也。末后普贤无示无方。表法界德圆普遍故也

四示处者有四句。初三贤未证散在诸处。二地上证真生在佛家故。多佛众中等。三地后起用亦散随缘。四普贤表因圆克果。亦在佛所

五遣不遣中有二。初后二位无教遣而自往至。初谓文殊自往就故无人教。后普贤遍故。眼开自见又至。后文殊般若智成自见法界故不待教。余位无此二义皆有教遣。又若不教遣。即诸知识独着于己。何成自行。又唯言知一。若不遣余求何成圆备之益。又若不遣。岂合一位不进升后

六叹不叹中三。初文殊亦叹亦不叹。谓善财未发心。但劝令发心故不叹。后劝令发心已方乃叹之。中间知识皆有叹。以发修进故。有不叹者应是略也。后文殊普贤不叹以位成满故

七推不推中二。谓诸位知识皆有结自分仰推胜进唯初一。后三无结无推为显人尊德满故。尔何以有遣。谓表令位增故。显法门别故。余位有结有推。以因行未圆故。若尔普贤等何以不推佛。以非因位善友摄故

八结不结中前诸文皆无结通。以行未究竟故。唯后普贤有结通十方等于尘刹。以普遍故。行满故。事究竟故

九去不去中唯末后二位无辞去故。文殊以离相故无去。普贤以德满故无去。余位非此。皆有辞去。若不辞去封守一师。何得遍求法界知识。何成升进之行十释文中。就觉城摄善财会令成十信行中文别有四。初明众集显所被机。二明观机辨授说方便。三正说所授之法。四引起胜进之行。初中二。先总举。二时有下别显。别显中。四众优婆塞者古翻名善宿男。今译名近事男。谓亲近比丘而承事故。女亦同之。又修达多此名善施。婆须达多此名财施。跋陀罗此云贤。余名准释可知。第二文殊知觉城人下。明观机为授说方便中有二。初通标说意可知。二观察下别观善财。于中亦二。初观其现生胜事。二此童子者下察其宿因德行。初中三。初总标。二别显。三善明相师下总结。别中由此福报财宝相起。立善财名。即善为因财为果。又得此顺道之财故曰善财。又生时宝现为财。后叹其行德为善亦如善现空生等。又智论释常啼名等。准此可知。二叹其德行中十句为五对。初曾供佛种善。明此善财已曾宿种解脱分善根也。二乐净近友。三三业净修。四求修果法。五心净具行。以心无异念故净如空。又无现烦恼等故。

问此善财是何位菩萨。答经无正断。位相难明。或有判为地上菩萨。设后发心则是四种发心中后二位也。又是论中三发心内证发心也。或有说是实报凡夫。但有信心能求善友。今更准释。应善趣信中行人。依圆教宗有其三位。一见闻位则是善财次前生身。见闻如此普贤法故。成彼解脱分善根故。如叹德中辨者是。二是解行位顿修如此五位行法。如善财此生所成至普贤位者是。三证入位。即因位穷终潜同果海。善财来生是也。若尔善财定是何位。谓是何位。以在信是信位在住是住位。一身历五位。随在则彼位遍一切故如普贤位。余义准宗思释。第三文殊如象回下明正说所授之法中二。先明摄机许说。身首俱回如象王。现身摄受相。观察自视明意摄受相。告而许说明语摄受相。二则为下正宣所说。说佛果法。令成信故。令彼发心求此果故。八句之中初一总。后七别。别中初三妙用摄生德。一明为机出世。二放光集众法。三正说所说法。后四明体相圆备德。于中前二后二。各先相后体可知。第四尔时文殊下明引成胜进行。于中有三。初文殊南行引发。二善财随逐求救。三文殊象回摄受。初中先结前后游行。南方生后也。前中令成信位菩提之心。故云欢喜等也。显明过去善根者。令彼过去所修善根由今菩提心故更得增长。使不失没故云显明也。不舍本座等者明不离觉城而遍游故也。同上不起觉树至六天等。如上已释。若尔童子亦如文殊不去而遍诸位准之。二善财随逐中有二。先经家叙事。二善财说偈求救。于中有三十四颂分二。初四伤已迷沦不能自出。后三十叹文殊德请求救济。前中四颂通皆具有惑业苦三别分。三初二起惑。次一造业。后一苦转。初中三有等起惑处也。痴闇等起惑因也。恶魔等起惑缘也。三毒等正起惑也。就造业中初二句失正行。后二句成耶行。就苦报中悭等举饿鬼因。下结成苦果可知。就第二三十颂中亦二。初九叹文殊德求其救厄。悕离生死之苦。后二十一叹德求其与法。悕成行得果。又前希离凡地苦。后望离二乘乐。又前望得涅槃。后望得菩提。初中九颂叹文殊九种功德。一悲智德。二慈惠德。三法化德。四愿满德。五救苦德。六自在德。七力用德。八善净德。九净眼德。又前八及后颂。皆初三句叹德。下一句求救。二远离下求菩提法中分四。初二求示果法令知所求菩提。次一求见三世诸佛成菩提行缘。次十七正求能得菩提因行。是故皆云乘。或云道也。后一结请。就因行中分四。初五叹智悲定摄德。次三叹十度行圆德。次四叹二利灭障德。后五叹随事摄生德。第三文殊摄受中分五。初回视叹善明受之相。二是故善男子下教近善友问菩萨行。三说偈叹德令其喜修。四指示后位令其趣入。五时善财下庆闻辞退。依教趣求。就第二教近友问行中。初教近善友。二教请问行。于中十句。初一句总后九句别别中一问创修行法。二问行成满法。三问净治行法。四问净已圆成法。五问从行出行法。六问念持所行道。七问缘彼差别境界道。八问增长法用。九问摄成普贤行。亦是摄别成普行。此上九种皆依前起后可知。三偈颂中十颂分二。初一叹善财已成行令喜。后九叹普贤行令修初。一教发大愿为行之本。次二举普贤行。劝彼令求。一举行。一劝求。后六辨普贤行令修。一多闻法行。二多见佛行。三顺教修行。四一切处行。五一切时行。六成大益行。谓有众生闻彼普贤名号者还成彼行得大菩提。上来明信位成满竟。就第四指示后位第五庆闻辞退此二段文。若约会分即属前会。以是前位善友说故。若约法分即属后位。以是后位之方便故

今通辨下文诸善知识略作四门。一明求善友意。二显善知识义。三料简文段。四消释本文

初中何故文殊不即为其一切宣说。而令善财广历多处求善友者。释云意乃多端。略论八种。一为轨范故。谓诸菩萨于佛圣法恒修二行。谓求法说法。经云明诸菩萨求法不懈说法无吝。此中显斯二行示诸众生。是故善财成求法之妙轨。善友现说法之良规。使诸众生轨此躅成行。即佛花常敷广严恒著者也。二行缘胜故。谓成行之要莫不以良友为先。如阿难言。善知识是半梵行。佛言不尔是全梵行。经云阿阇世王若不用耆婆语者。来月七日定堕地狱。是故我言得道之来莫若善友。又如论说。迦旃延令应入地狱。弟子而得圣果等。又经言。善知识者是大因缘。能令汝等当得见佛。又下文云。善知识者是奇特法等。由是要用是故善财求之无足。三破见慢故。令善财等新学菩萨破自憍慢及执见故。令其求法。不简男女长幼贵贱道俗尊卑神天外道。但卑身屈辱。务存得法。经云有知法者若老若少应当恭敬犹如诸天奉事帝释。四。寄成行故。问此善财得一法门足成修行何不修习。乃游历无厌。答即此广求成就菩萨事善友行及求法行。纵不得法此已成行。况皆得彼未曾得法。慧眼开明见真法界。如花手经中求法千岁而不得闻。因兹舍命生佛土等。此即是其所得之法。谓得行法故也问何不观空入理。乃随事諠諠。岂成菩萨甚深之行。答即此随事常见理故。是故遍游而未尝有去。问若未尝有去仍有遍游。何不未尝有去而不去也。答亦相似。以去不去无二相故。若尔何不座而有去外去坐。亦相似。以俱无性故五寄现位故。谓广寄善友显信等五位差别之相。文处可见。问何故善财不向佛所求法。答表因行未圆未至佛故。不到佛所也。六显深广故。谓表显佛法广无边故。诸知识虽有位极法云。犹称我唯知此一法门。岂能了知诸大菩萨无量行相。表显佛法深无底故。善财纵位至登地。犹云而我未知云何菩萨行菩萨道等。况今具缚少善凡夫。微有所解。便自谓解一切佛法起慢。自高陵蔑他人耻。有不知便臆断经论自陷陷人。何悲之甚。八显缘起故。善财与善友同成一缘起。以能入所入无二相故。是故无善友之外善财故彰一即一切。明善财历诸位也。无善财之外善友故显一切即一。明多位成在于善财也。由是卷舒自在相融无碍。思之可知

第二释知识义者有二。先通后别。通论真善知识有其三类。一人。二法。三人法合辨。初人中有六。一有人虽能济其现苦。而不劝修善。非真善友。二虽劝修世善免于恶趣。而不劝修向出世路。亦非真友。三虽修二乘出世善行免三界苦。而不劝行菩萨之道。亦非真友。四虽劝修菩萨道免于二乘。犹存相善。亦非真友。五要劝众生修无相行。方为真善知识。此依佛藏经及智论等辨。六要劝令具普贤行愿。方名究竟真善知识。此上并是行善知识。以行引机故。唯属人。二法善知识亦有六重。一人天法。二二乘法。三初教法。四终教法。五顿教法。六圆教法。依此等法以成正行故名善友。但随教权实辨真善友。三人法合辨中亦六重。谓于上六位法各说一门。以授机缘即人法双辨也以此是解善知识说法授人。不同前位真善友等。准之可解。今此下文于上三位六门之内有通有别。通即六门皆有。别唯未后。以并成就普贤行故。又离世间品有十种善知识。亦于此叙之。二别辨下文诸善知识。皆具前三。此三位中各有三义。且人中三者。初闻名等为方便。二正见人为得法界。三问法等彰其德。二法中三者。初言教为方便。二智眼所得为得法界。三通明业用以显其德。三人法合辨中。初闻名至处为方便。二见人得法为得法界。三说往因及推胜进以显其德。下诸知识皆准此知

第三明科文分齐。增数有十。初总为一。谓各一位故。二依远法师分二。初亲近善友。后告言下结听闻正法。其系念思及如说行并摄在闻中。就近友中有四。初闻善友。二求善友。三见善友。四请问法。就初闻善友中亦四。初列国名。是通处。二山名。是别处。三善友名。四教往诣。二求善友中有三。一初闻心喜。二礼足辞去。三渐行访友。三见善友中二初往见。后设礼退住。四请问中三。一向已发心明已有机。二而未知等问行法。三我闻等叹德请近善友竟。二闻正法中二。初叹其发心。后正为说法。说法中初说证量法门。后仰推等说教量法门。此上科文诸位多同。少有不同者。三依辨法师分三分。初闻名求觅等是加行位。二受其所说是正证法界。三仰推胜进是后得位。四依衍法师等分为四量。一初闻名等是教量。二依教寻求是信量。三见彼依正是比量。四闻彼所说为现量。此四即是闻思修证也。五有诸德分五于上第四现量中开出自分胜进二位。余同前辨。六依意法师等分作六分。一明求诣心行。二明敬咨问。三赞说己知以授善财。四说己未知。五更示知者劝令往诣。六辞退造彼。七或分为七。于此六中第二内。先见。后敬故也。八或分为八。于此六中第三内。先赞发心。后说己法。九或分为九。于此八中第五内。先指示。后劝往。十或分为十。于上九中第六内。先致敬。后辞去。谓一求。二见。三礼。四问。五赞。六说。七推。八指。九敬。十去。此上增数十种科中。初五约位科。后五约会科

第四释文中。今且依位五分科释。一举法劝修。二依教趣入。三推求简择。四正得法界。五仰推胜进

就此初位发心住知识内五分中

初举劝内有四。一处名。二人名。三教问。四叹德。初处中国者表摄生分齐之义。但此十住之。初是信地所欣故名可乐。山者随相闲静。贤圣所居。亦是修三昧之所。若约法即表住位高出信门之上。名和合者。比丘在中得三昧。相应故云和合。又令善财与住位相应亦名和合。又辨法师云。闻熏与解性和合。转成圣人依故入发心住也。二人名中比丘义如前释。为创出外凡故。以比丘表之。勘天竺本。梵名迷伽室利。迷伽此名云。室利此云德。顺彼应名云德比丘。但云有四义。一普遍义。二泽润义。三荫覆义。四注雨义德亦四义。一定德。二福德。三悲德。四智德。于云四义如次配释可知。又定眼普开如云见佛好德。境智立名。又普眼见佛多故如云。有斯德故以立其名。此经是于奠本。翻名功德云义。亦相似可知。三汝诣彼下劝往教问问中。十问同前。是故举初二乃至十也。四善男子下叹彼比丘德。令其喜去。举法劝修竟

第二依教趣入中。闻法欢喜者知有所向故。悲恋者荷深恩故

第三推求简择中二。初登山者明见心陟位故。二于彼下明寻求实义。七日者古说表度七方便方见本位。又亦应是于彼山处先净身语七支之失然后得见真善知识

第四尔时善财见彼下明正得法界。于中五。初见人。二设礼。三咨问。四赞问。五正说。初中见在山顶者表兹住位不退之际。静思经行者明修般舟三昧等故。亦是一行三昧故。又静思修止。经行成观。又是贤护等经。思惟诸佛现前三昧之相状也。二礼中右绕是极尊敬相。三咨问中二。先白已发心显有法器。令其易说。二问所未知彰已渴法。令起悲速说。下文诸处皆同此释。问中虽前教十问下诸位内多存此二。依勘梵本。应云而未知菩萨于菩萨道应云何学应云何行。此即先解后行。文处可解。我闻大师善能宣畅者。依梵本。应云我闻大师于诸菩萨善能教授善能教诫。此即由教授成前解。由教诫成前行。传译存略故。总云宣畅。下诸文皆同此释四赞问中。二先总后别。别中九句。同前所教。初二句正同。余句不次。三入菩萨境是前缘菩萨境也。四出生等亦同。五广心是前增广等。六具足等是前具普贤行。七随顺等是前满足等。八于生死等是前究竟等。九有为等是前清净及正念等。此并以他心智称根而叹。五善男子下正示法界。于中有二。先示义。后我唯下结名。前中二。先明所得法体。二普照下明其业用。前中解脱力者。正法师云。此是发心住体。谓本解性由大乘闻熏习故。转凡夫依令其得脱故。名解脱。依此所证。能证智名之为力。今释此是依定所发作用无碍称为解脱。如不思议解脱等。于一尘处见多世界。今此亦尔。不离此处见十方佛依正差别。是此解脱之力用耳。言逮得慧眼者。然此解脱有能小处容致广大。有于一处而见一切。今于二中偏取能见。不取能致故云于彼逮得此也。此别简定所得法体。二明用中二。先通后别。通论此眼见一切世界等。非但见佛。普照等释慧眼也。境界无碍释方便也。除一切障释清净也。二一切佛化下别辨见佛。先明能见之力。谓陀罗尼此云总持。以念惠为性。然有多种。或法持或佛等持。今简法等持故云佛也。然佛中亦有法身报化。今简法报但取化佛故云一切佛化也。是故所见之佛种种形色等并是化身佛也。二正明所见佛中。先见佛身。初东方后类九方。二种种下见佛作用。于中先见佛随机现种种依正。二见佛于众决定说法。二善男子下结名分齐中。普门者简异别门故。谓别门中或见一方二方一佛二佛等。皆不称十方。今不依彼故云普门。此门若开普见十方尘数诸佛。如文所显。光明者显所见分明故。此普门光明是前普照也。观察者所见审细故。是前观察也。正念者见时不乱故。是上除障等也。上是能见。诸佛是所见。三昧是彼见所依定。创入住位光明念佛三昧广见佛者。以佛是究竟所依本故。自分竟。依佛方成余行故

第五岂能了知下明仰推胜进中二。先总后别。前中岂能了知等者显己于彼实不能知。不知何法。谓菩萨圆满等。即名为智行。障无不尽故云清净。德无不备故云圆满。二诸大菩萨下别显有二十一门。各先举所得定门。后辨业用差别。初十明念佛胜德圆备。后十一念佛妙用自在。前中初一具见佛主伴依正故名圆满普照。二念佛令众生离倒之德故名清净。总中圆净依此应知。三念佛是处非处等十力之德亦是大力那罗延等十力。四念佛于法无倒。能说能授亦是菩萨心于法无倒故。能见佛已闻法受持。五以达佛海智分别如来。约能念智为名。六念佛微细境。谓一念具八相等。如前后说故云自在。下位菩萨总不能见上位菩萨。虽见不能证入故名也。七以念佛常住故云无倒。八念佛应机未曾断绝故云随时等也。九念佛依土现身。十念穷三际佛。第二明妙用自在门中。初一念佛遍满一切差别境中。二念佛涅槃相故云寂静。三念佛超时不离时。四念佛身满法界故云广大。五念佛毛孔重现。六念佛于一切处现成正觉故名庄严。七念佛光照离染转净法轮。八唯心念佛。九由念佛故见所作业。由如镜像。无体有相离执着染故云净业。十念佛修生功德严真如法界。十一念佛大智等功德遍照法界等。十住第一位竟

第二治地住位中五门同前

初举法劝修中。前既推己不知。谁能知耶。故今指示后位劝令修入。于中言海门者。此国近在南海。城门向海故名也。又表观海门开见治地法界故以为名。比丘同前。海云者。此比丘常在海岸。观缘起大海及彼海上人法庄严遍覆如云。从所观为名。如菩提萨埵等。又表此比丘内具胜德深广如海。外应群机雨法若云。又所观法界深广如海。能观大智周遍如云。故从境智为名。劝往教问。同前可知。二善男子下叹彼胜德有十句。初一总余九别。具因善者地前善也。大地是地上。大力是佛地。次二能叹因令增广。次二令行愿净现。次二令二利德满。三时善财下设敬辞去

第二尔时善财下明依教趣求中。先心念法门显无散动故。温前所得故。悕望后位故。长养净心故。二身步渐进至于后位

第三见已敬请中二。先设敬后申请。于中先申己意乐。二而未知下正请所要十句。初五句问自行。后五问利他行。一一各二。谓背凡向佛。舍生死向佛果。初一约转位。余多约喻。准释可知

第四尔时海云下明示法界中二。初叹法器为授法方便。后正示法界令其修学。前中亦二。先问答审定。二善男子下正叹其德。于中初总叹。二得普门下别叹。别叹中初十句叹能发之德。谓具此德者方能发心。二大悲心下十句叹所发心德。谓具此十德是菩提心。前中初得字贯下九句。后者字亦通前九门。其初普门普照等多是前功德云处所得之法。亦是宿有普贤种性故也。十心中增数有十一。初四摄生心。一救现苦。二授现乐。三灭当苦。四除彼因。谓恶业也。次二灭障心。一断烦恼障。二除所知障。次二证理心。一正证。二后得。后三赴佛心。一见佛身。二顺佛量智。三究佛理智。二善男子下示已法界。于中有五。初观察大海为证门方便。二得见法界无碍依正。三领受所流无边教法。四传授众生同入法界。五结己所知。唯一非余。初中十二年者。有人释观十二因缘大海故。有云住菩萨十二住故。有云此是十住之第二故云十二也。观海中初二句是总举所观能观。下十句别显观相。此中十种与十地品中大海十相有同有别。准释可知。善男子我如是下重更研核令海门开。二从作是已下明海门既开见法界依正。于中先见依报。后见正报。前中四。初见莲花出明依真法界净土集成。二百万下明外相庄严有二十句。初十一明众生世间庄严。后九器世间庄严。三彼宝莲花下明出所因。亦是智正觉世间庄严。于中亦十句可知。四随顺世间下结叹无尽。谓据实唯佛境故。总不可说。若约方便顺于世间说亦不尽。二见彼花上下明见正报佛身有二十句。初十明佛果德备。后十明妙用自在。并可知。三时如来下明受所流教。于中有五。初摩顶身加显摄受之相。二说普眼下明所说经法。普眼者从所诠为目。此是总名。唯如来境下十种别名。准释可知。三善男子我从下总显己闻。四假使下别辨所闻法广。五我于佛所下别显己有广闻持力。此十持力中皆先举所闻广法。后辨能持大力。以大海等墨等书一品不尽。于一日中以此十持受尔所阿僧祇品。如是于千二百岁一一日新受。以此普眼经是一乘无尽修多罗故也。四其有十方下明传授众生同入此法可知。五善男子下结己所知

第五岂能尽知下仰推胜进。于中二。先总举。二何以故下十句别辨。初五自分行。后五入佛果行。皆云海者。以此比丘但知自一海更有多海非己能知故皆推也。第二治地住竟

第三修行住位中亦五

初举法劝修中。六十由旬者。古人云。修六度行故。海岸国者此国在海滨故。天竺梵本名海岸楞伽道。解云此国通向楞伽山故也。又到胜流法界之岸故。又前入于海门今达到海岸故也。善往者巧入理住。又身住。虚空。行路无碍名为善住。劝往教问敬绕辞退。并可知。略无叹德

第二尔时善财下依教趣入中。先忆念前法。随路而行有十句中。初念彼教法。次思惟彼义。次修习法行。后入深正证摄法除障

第三见已敬请中四。初至彼推求见其依报。二见彼下明见正报。以智住无相身游虚空。下天等供养有十句。明眷属行。三尔时善财下亲临设敬。四白言下申己请意。初十句问于法起行。后我闻大圣下十句问行起胜用。前中十种皆从微至着。准释可知。后十中初二句明不离三宝行。次不舍大愿下二句明二利行。次不舍佛刹下二句明摄佛依正行。次不离有为下二句明悲智无住行。后常闻下二句明摄法行

第四尔时善住下正示法界中二。初叹其发法器。二我已成就下示已法界。于中四。初总标法门。谓证法界无障碍义。能令随事用亦无碍也。二我已修习下释上法门。初释上成就义。谓修习明了故也。逮得下释无碍义。谓照达所作名无碍慧光。则十二句是照用自在无碍之相。刹那者此云念顷。于一弹指顷有六十刹那。一百二十刹那名一呾刹那。同此间瞬息顷。六十呾刹那名一罗婆。三十罗婆名一摩睺妒路。此云须臾。三十摩睺妒路名一日一夜。何以下释成无碍义。无所有者称理性故。无作者无功用故。天竺本名无体性。无作神力。三善男子下显法门业用中三。初总举通用。二于一念下明速至十方见佛供养闻法等行。三若有众生下明利物不空行。四结名可知。天竺本云得普速疾不空超度究竟无尽菩萨解脱。解云速至十方名普疾超度。供佛利生名不空。此用无限故云究竟无尽

第五仰推胜进中二。初别辨二十门净戒。善男子下总无量。皆不能知说。第三修行竟

第四生贵住中五分同前

初举法劝修中。国通城别。名自在者良医于此摄化自在故以为名。又表此位中种姓尊贵生在佛家。是故国名自在。城名咒药者。谓于此城中放三昧光破无明闇。如咒除鬼病。说轮字法破余烦恼。如药疗余病。以此良医者天竺本名达闭多。解云此是种类之号。在南天竺。如此方吴楚等类。但此类中此人善医故。能以法药善治惑病故以为名。以此寄当无流位故。灭障义显故。以表之。弥加者此翻名云。谓能注法雨润益众生故名也。略无叹德。余同前辨

第二尔时善财下依教趣人中。思念前法使纯熟成满。十句中初二句念所得所具。次正念佛下二句念所归所离。次念善知识下二句念所求所度。次于一切下二句明护烦恼行。后悉能下二句护小乘行。以此熏心增其正行。渐至等明进至后处

第三见敬申请中四。先入见依报。二见正报法堂显其正位。说轮字庄严光经者明所说教法。有本错作论字。诸德种种解释。近勘两本梵经皆名轮字。请则改正谓三藏解云。轮有多义。一约字相。楞伽中字轮圆满如象迹等。二约所诠。尽理周备如轮满足。三约用。谓下所言不虚等有传授义灭惑义。如法轮等。即轮字教法诠示。庄严光行。除障为光。证理为严。三时善财下亲近设敬。四白言下申情请问。问中初二句为总。后十句为别。并准释可知

第四尔时良医下明示法界中。二初敬叹法器。后授己法门。前中四。初审其发心。二敬礼供养。何故礼者。古释云。显敬法重人故。明诸弟子修行法时敬法具。显师即不尔已有过教之德。是故于弟子常有敬法之必。但身事不得起礼。今此以心行难明故。现相表之。又云敬其道器也。又云不轻末学也。今更释以菩提心是佛因故重其果。而敬其因。此敬则是行菩萨行故。示此轨则令众仿学。又释佛果大心不足为难。创起大心此则为难。是故经云发心毕竟二不别。如是二心前心难。自未得度。先度他故。我顶礼初发心。又释此心希有。能广出生。是故敬礼。如新翻法界无差别论中。敬礼菩提心者如世间人礼白分初月不礼满等。以希现故。满月由此故。三敬重下明言中叹德。中三。初十叹大心功德能。初二为佛果依正性。性者因也。以菩提心是因法故皆云性。次二成所化因。次二成业行因。次二愿智因。谓愿常随有。智恒离欲。后二为大果因。谓菩提涅槃也。二为一切佛下十句为十王敬护。三彼为安慰下明得敬护之因。亦十句可知。四善男子下泛明一切菩萨胜德中二。初法说。二菩萨为大风下十三句约喻显德。准释可知。二尔时良医下示已法界中二。初口光集众说法广益。二还升本坐方示已法界。问前既敬礼。今何故复坐。答前未与法。非弟子故。致敬无咎。今现师位。是故还坐。所言不虚者言必饶益故。天竺本名得妙音陀罗尼法门。解云即是此中分别知天龙等语言是也。业用及结名可知

第五云何能说下仰推胜进中三。初一句总举。二彼诸菩萨下别显。十句悉是言音字句施设等繁广如海。胜进深入非已能知。三逮得下结彼所得深妙之法。第四生贵住竟

第五方便具足住中五分同前

初举法劝修中。住林者行德建立名林。安固不动称住。又此长者栖薄大林长道之所。因以为名。又住三昧身内。广现佛境依正因果如林。长者名解脱者。有财有德名为长者。身内容现无边佛境。定用自在名为解脱

第二尔时善财下依教趣入中。初念法熏修也。二如是念已下明身游涉。前中初一句总念前法。二入菩萨下六句明利他行。三坚固菩萨下十句明自分行成。四逮得普眼下十句明胜进行立。二身游中十二年者。古人云。自分胜进各修六度故以表之。后渐至后处

第三正敬请中三。先推求简择见已设敬。二作如是念下生胜欲乐。起难遭想。以悕望多年今方见故。九句可知。三白言下申意请问。诸文皆先述己力发菩提心。然后请法。以此文验即知。欲受大法。要须发菩提心。若不发此心非此法器。是故诸文皆先定发心。或善友重问。然后为说此为佛法之大辙。应思记。之请中三。初申自欲乐。二我闻大圣下叹德劝说。三唯愿下结请令说。前中四。初十句欲穷佛宝境界。二欲闻一切佛法下十句欲穷尽法宝僧宝境界。各五句可知。三欲得一切诸佛菩萨因缘下十句明欲穷尽十藏源底。四欲满诸愿下十句明欲令万行圆备。欠一句。二白言我闻下叹德劝说中。初叹能善教令余菩萨离障得果。二其心下叹其自心常净具德。三唯愿下结请可知

第四时解脱长者下示法界中三。初入定默示。二出定告示。三结唯知此一。初中亦三。先具缘入定内文殊忆念力者善财善友不舍之力。摄刹从境为目。旋持从智为名。摄彼刹随己智转含摄总持故为号。二入已下明法界业用无碍之相。于中初身内现佛。三种世间实报因果。二或于一刹下明现佛八相权化摄生。三善财悉闻下明善财入前法界闻彼身内佛所说法。又见彼身内佛神力等。二尔时解脱下明出定告示中亦三。初举法门体二正辨业用。三劝修令入。初中无碍有四义。一者一一如来各具一切无碍庄严。二者一一如来互遍无碍。三者一切如来庄严悉皆入此长者身内。四长者彻见十方佛海。此文具四故云无碍。二得此法门下正显业用中四。初略见十方各方刹尘佛。二若欲见安乐下随心广见一切诸佛。皆佛不来此而令此见。此不往彼而常见彼。如是无碍。三知一切下释不来往知见所由中。先标有五对。初一对标下释。何以无从至。以能见所见俱在梦中各无自体。何所来至。以梦无处所故。此约体释。二对中如电等约佛大用有四种义。一照水现影以应机故。二破闇见道灭众生障故。三不可执持。以离相无碍故。四速灭不住。以非世摄故。心水定澄能现彼像。水亦不去电亦不来。而像无不现故也。三如幻对中以幻心无碍故能现无碍之幻佛。于幻身内现多幻佛。无所障碍。此是缘起相由门中自在之义。思准之。四如响对中释上闻佛说法音声等。如是知下结知。证入故得自在。四善男子当知下通结。所作皆由自心。以诸佛境界遍满一切。但以心垢对之不见。若修治自心令离障得定诸佛境界当处便现故云也。三是故善男子下劝其修学。是前所说由自心得故。劝以十法修治息心。谓一以善长心。二以法润心。三于境炼心。四以勤策心。五以定摄心。六以智洗心。七以惠反照心。八法纯熟心。九等佛果心。十十力照心。下结己唯一可知

第五仰推胜进中。初一句总。次五句别显行体无碍。次于一切诸方下明行用自在。然诸文仰推有二类。一即于自己法门之内更有深细。非己能知。即如此文及前位等。二推异类法门非己能知。如前第三住中推菩萨戒等。上下诸文皆此应知。第五住竟

第六正心住中

初举法劝修内。国名顶者此在阎浮最南畔处故云顶也。表第六般若终极故也。海幢者。古人云。定深如海。智胜若幢。又释定身独出名幢。业用繁多云海。设敬辞退中叹德。悲泣者伤已无始不逢善友。今遇会心原故也。又指示般若门。荷恩深故

第二尔时善财下依教趣入。谓念前趣后念中。初二句总。下十句别。一能入慧。二所证理。三所摄德。四所起用。次四了知刹海。后二受持行愿。皆是解脱业用难知。同名不思议也。三渐趣至后

第三见敬请中。初见彼依报推求简择。二见正报静处安禅

第四从三昧正受下正示法界。于中七。初辨法体。二示法界业用。三令善财观证法界。四出定叹德。五问答现名。六问答现用。七结唯知一。初中身安不动。心寂无觉。七转已息唯第八持身。定前加行誓愿力故。令于定身起诸业用。若圆教中融摄法界自在无碍故。业用无方未曾起念。总有十四门。初足下出长者等众。明修行之初以施为首。二从两膝出刹利等者。具云刹帝利。刹此云土田。帝利此云主。则王种。王种以福化人。婆罗门以智化导。三从腰出仙人者以多着断常故。两边出也。三岐杖于上安居。持瓶洗净用也。西域外道多执此瓶杖。四胁出龙。五胸德字出阿修罗。六背出二乘者。与大乘正面相背故也。此是贪他财故。慈观治也。嗔无情物故教缘起观。是耶见愚故教巧观。法体无二我也。七肩出夜叉。八腹出紧那罗等。九口出轮王。十两目出日。十一眉间出帝释。十二额出梵王。十三头出菩萨。以十波罗密教化众生。十四顶上出佛者明极果尊胜故。于中二。先十二位摄菩萨众。后二十事摄杂类众。前中初平等法者令道场菩萨速成佛果。齐诸古佛也。二普门法者。因位既满令摄别归普。三普庄严法者。以灌顶受职普严法门授第九位。令其修学。四坚固山法者。第八住中成三业离过不动故也。又令不舍此不动而进受第九无碍说法。是故方云坚固如山。五海藏者。以第八住无生藏海授与第七。令其修学故。六普境界法者。以七住中善巧周遍所缘境法住与第六。令其修学。七自性地音声法者。六住中赞毁自性但有言声授与五住。令其修学。八随顺世间法者。令第四住进修五住随于世间五明等法。九厌离法者。令第三住厌离世间向于第四出世住故。十长养法藏者。令此受持第三住闻持陀罗尼甚深法故。十一精进法者。策此初心令更进修至后故。十二信行者。住前信中菩萨何以不言菩萨者。以不成位。但是行故。言无尽法者令修普贤无尽行故。问准依此文。十住满后即至道场。成佛而不说十行等。者何也。答此是普贤十住摄后诸位。皆在此中。显一位即一切位故。是故一位满后即至佛地如上十行等后成佛同此也。此是以位摄位门。若以行摄位。即十信满心成佛。如贤首品说。此之一辙非此圆教余处总无。正是一乘宗之大例。自下二十门。为诸天并是入法界之器非是世法。一以色究竟天虽是长寿终归有尽。今为说法身平等无尽法。二者初禅梵王有慈不普。为说大慈普覆众生。三者自在天虽世中大力终归灭尽。为说法身生善根力。四者建正法幢降彼耶心。此亦是他化天摄。五者化乐自念化作乐具。为说净念令念法门。六者为说出世净意乐故。令其远离执手染心。七者夜摩喜乐终竟无常。为说出世真法欢喜。八者彼着地居有为庄严。为说福智庄严性空。九者令此夜叉舍离恶护众生命故云欢喜。十者彼属诸天而不自在。为说出世法乐圆满不系属他。十一者修罗大力为天所伏。为说出世法身大境物莫能过。十二者彼金翅鸟虽有大力只游一界故。今为说法身金翅覆无量世界。十三者紧那作乐愚着无益。为说出世胜智益生自他俱乐。十四者人王乐着世间五欲。为说欲过名不可乐。十五者龙有热沙金翅等忧。为说无我令彼欢喜十六者摩睺恶性事中好静因。则为说甚深寂静。十七者地狱苦逼心乱。为说法安心令得正念。十八者说智治痴。十九者阎罗王处苦具可畏。说法除之故云无畏。二十者饿鬼饥渴常恶悕望。令说法翻之。言悉令众生下结上所说。皆向出世贤圣之门。明放光利益可知。第三尔时善财下明善财观见得法中二。初观比丘身明证人法界。二念彼三昧下证法法界中四句。初一句念彼法体。二思业用难测。三思其大用深广。言无量者明前十四处所出广多故。言无作者明不作功用。显其甚深。四观察法界下明法起所因。谓法界严智是因力。依佛智等是缘力。出生等现所作事。明善财委得其本故具知也。第四出定叹德中二。先出定者利益事讫。六月六日者是第六住故。二尔时善财下明言中叹德。于中二。初十句叹三昧体深广具德。二大圣其有下叹业用。于中初叹上救三途人天等。二发菩提心叹上益菩萨用。谓从信行终至道场等。第五问答显名中。答有三名。初一总名普眼平等法门。见法界故。障无不尽云舍。理无不证名得。二净般若约智离障。三净严约境证德。善男子下释立所由。良以此德当其第六般若位故。第六大圣下问答辨业用。答中有二十三句。初六句明于器世间自在。二见一切佛下十一句明于智正觉世间自在。三大悲摄下六句明于众生世间自在。第七结已唯一可知

第五仰推胜进中三。初一句总推。二皆悉深入下别。三我尚不能下结不能知。以积行成德行尚不知。况所成德。第六住竟

第七不退住中

初举法劝修中。海潮者显别住处。近大海侧潮浪至之。处表此第七巧便就机用不过限故。园林者众行建立栖止之所。普严者胜德圆备。优婆夷者是慈悲之貌。休舍者智论第八名呼舍罗。勘天竺本名阿舍。此翻名意乐。亦名满愿。以能满一切众生愿故。二劝往教问。三时善财下庆己所得。设敬辞退

第二尔时善财正念下明依教趣入。于中二。先敬念人法。二又作是念下见其胜德身渐游行

第三至海潮下明见已敬请。于中四。先见依报。二见正报。三设礼。四申请。初中有十三事严此园林。初宝墙。二花树。三堂。四阁。五殿。六池。七有大宫殿。八殿内有十种座。九宝帐覆座。十宝网覆帐。十一光明普照。十二有十种电光。十三百种云严。二时优婆夷下辨正报庄严。于中三。初胜德严身。吉由罗者此云臂印。庄严也。二眷属围绕。三其有见下明利物不空。三尔时下明善财正设礼。四白言下申请可知

第四答言下正示法界。于中有四。初举法门体用。二明因缘厚薄。三来果久近。四显法门名字。初中四。初一句举法门体。二若见闻下明其胜用。三东方下显佛被益。四我此大众下明眷属行成。二往因厚薄中。先问后答。答中二。初举过去所事诸佛。涅槃中八恒佛所。此位中多于彼也。二了知下十句明所成法界行德。三来果久近中亦先问后答。答中三。初不为限齐故发心。二欲教化一切下正为作无齐限事故发心。于中各有十四事相。翻可知。三是故下结自修行。无限齐故不辨自身成佛期。问若尔岂可成耶。答菩萨阐提亦不成故。众生须成。亦现成故。望自证理无成不成故。四显法名字中。先问后答。言离忧安稳幢者大心多劫遭苦无忧。造修正行安稳无倦。大志独拔。是故云幢。天竺本名无忧建立幢。我唯下结已可知

第五仰推中二。初一句总举。二诸菩萨心下九句别显行德。我当下总结。第七住竟

第八童真住中

初举法劝修中。国名海潮者虽起潮浪海无增减。表此位得无增减法界。又证理起悲如海起潮。同前处者表第七已上同是菩萨故。仙人者表第八童真清洁之貌。又表纯无漏故。又表唯变易身故同八地等也。毗目多罗者。天竺本名毗目多罗涅惧沙。此翻名最上无恐怖声。上文叹佛处。云以一切智微妙音安慰无边众生界。此名得也。二叹德劝往教问可知。三善财荷恩敬辞中十一句。初一句总余十句别。一大乘真友暂逢亦难。二况得同止多时。此二善友难遇值之。三若自无大乘根器亦不成故云得菩萨根难。四虽得根器。正直真心此发亦难。五虽具此因。得同行同愿。伴善知识亦复更难。此三法器难辨。六正得法身难证。七正说法身难闻。此二法义难得。八生大心难。九求果智难。十长大行难。此三心行难备

第二尔时下依教趣入中。初念前法。初句总。心能长养下十句别显所念。皆言心能者。心若净则行无不成。是故顺教念心法功能也。初二心为行缘。次二心能起行。次二心能摄法。次二心能成定慧。后二心能除障。二渐游下正趣后位推求简择

第三见敬请中五。初见依报。二尔时善财见彼下明见正报。树皮衣等明少欲之相。三设礼中五体投地敬之极也。四念善知识下起胜念想十句。初五句念彼能作成之因。后五句念彼悲智巧运度故。五作是念下敬绕申请

第四时彼仙人下明示法界中二。初叹发心为授法方便。于中三。初仙人叹有十句。明善财大志所作德。二眷属供礼叹亦十句。明善财广益众生。三时彼仙告大众下结叹大心当成大果。二告善财下正授法界。于中四。初示法门名体。以此位中高出功用之表故云幢。然不为相惑所动故云无坏。智慧是其法体。是故天竺本名无能胜幢菩萨解脱。又此仙人定慧作用胜出无屈故以为名。二辨其业用中。先问中境界者问其业用分齐也。则申右手下示用现答。摩顶执手是加持之相。于中三。初入广处见佛。闻法以修大行。二或自见下复多时以修胜行。三明法门照得益之相有十句五对。初一总后四别。能照皆是无坏幢之别义。因照所得。皆是明净藏异德。以此明净梵本名为毗卢遮那藏。是故该摄也。三放手下明息用归本。放手者令其出观。还在本处者不移此处而见十方故。处既还本时亦未经一日。是故于一时一处顿修成十方多劫行成者。皆善友圆教法门力也。是故善财一生至究竟位者良由此等也。下文云一切诸佛无量劫修善财一生皆得者亦由是也。是故普贤位中或无量不可说劫修非唯三祇。如法力加持所经时劫。或一生一念如本时等。皆无定限。可准通之。汝忆念者问观中事。唯然者正忆不忘。知识力者是胜位加持。显非自力。则答所由。四我唯下结己所知。明授法即尽。更无遗惜故

第五仰推胜进中三。初总推。二诸大菩萨下别。于一切时轮自在者。古人云。于一切时机三轮自在。又可于一切时劫回转自在故说轮也。三我岂能下结非己分。第八住竟

第九法王子住中

初举法劝修中。国名进求者反道之相。人皆背舍既成顺用。故令进求。又在反道之位。不宜怠慢故以为名。依天竺本名伊舍那。此云旷野。亦名悕求。婆罗门者梵志净行。方便命者随事以方便为命故。刀火不能损也。又刀火返道以为方便。正行相续故称为命。天竺本是野人也

第二尔时善财下依教趣入中亦。先念前。二渐渐等趣后。此等亦得总属前位。谓初见敬申请。是亲近善知识。二告言等总是听闻正法。三念前法门是系念思惟。四进至后处是如说修行。是故总成四亲近行。念前法中四。初念前因无坏幢照所得三昧等法。于中声闻忍是人空。无生忍是法空。善财此处得无生忍者。以是前第八住位之益故同第八地也。二常行菩萨行下念前游诸佛所成胜行。三于一念顷下念前游诸刹海行。四又知无量下念前所见诸佛化众生行。是即诸文成益皆悉在此忆持法门。使纯熟明净证会究竟。二到处可知

第三见敬请中三。初见苦行相。二礼。三问。初中四面火聚者。正法师云。四无碍智能烧惑薪。刀山者真无分别出妄解也。从彼山上自投火聚者。加行相应意言。分别缘。真望证真显妄灭故也。又解火聚者是根本般若故。智论云。般若波罗蜜犹如大火聚。四边不可触。远离于四句。解云此智火有四义。一烧烦恼薪。二破无明闇。三成熟善根。四照现证理。刀山者加行智趣证疾利故。高峻者非即正证故。投下者从彼入此故。又刀是断德。障无不割故。火是智德。理无不照故。投下者障尽证理故。此火聚刀山即法门。更无表示。若尔何故有刀火相。解云即以此相即是法门。甚难解者是。此文意。设敬申请可知

第四答言下示法界中有六。初示法劝修。二善财作如是念下对此生疑。三作是念时下菩萨加劝。四童子闻奇特下除疑悔过。五登刀山下如说修行正证法界。六我唯成此下结己唯一。就初中。言若能登刀入火者劝其舍分别入正证法界也。菩萨行净者。分别尽故离障清净。证法界故。菩萨行成。何故要以如此法劝。为破其见故。令解菩萨深密法故。顺相易解。逆相难知故令知也。如是反道。上下文中总有三类。一此位同耶见。二满足王同嗔恚。三婆须密同贪爱。是故三毒相并有正法。然有四义。一以当相即空故。诸法无行经云。贪欲即是道。恚痴亦复然。于此三事中有无量佛法。解云此约即空是佛法。非谓三事即是佛法。二约巧摄生说为佛法。非谓即是。如净名云。先以欲拘牵后令入佛智等。三约留惑润生长菩萨道说有佛法。非谓即是。如净名一切烦恼为如来种。四约当相则是不同前三。此极难解。不思议故。如此文是也。二生疑中。初十二句念现得生疑。恐坏道缘失正行故。二此将非下念当得生疑。坏我应得不令得故。恶菩萨者实是恶魔。诈现菩萨。又是初心菩萨已退本心。欲妒害者名恶菩萨。如驴菩萨狗菩萨等。三加劝中有三。初色界梵天劝。二欲界六天劝。三龙神八部劝。初中三。告善财莫作是念者总劝莫疑。二别叹炙身本意德。三时诸梵天下明因此通化摄生德。四种道者四无碍智道也。二一万魔等六天中。一万诸天者是夜摩天。与忉利四天等同说。曼陀罗花等者大小白花也。伊那槃那龙者。伊那是树。槃那是叶。以过去坏树叶故。堕在龙中立此名也。难陀等名欢喜极欢喜龙也。余劝等可知。四除疑悔过中三。初起真心。二礼谢悔过。三说偈受忏开导。善财是大人。何故疑者。以相是反道。理须疑也。若不尔者无以甄别耶正。何故劝者显示实德故。若不尔者亦无以简真伪。是故拒其耶相。劝故受其实德。问若是魔王作此。岂亦不能现此劝耶。答亦如前善知识指示此人。固非误也。况劝中正说非魔所能。善财已得超魔之眼。岂不见之。若尔知非是魔。何故生疑。以大菩萨境未能知故。法须疑故。如前说也。偈中初一劝顺教除障。后一劝因得果。五如说修行中三。初得安住三昧者加行定。谓无散动智。以刀应割断。反此故安住也。二既至者到正证位。寂静是所证理。安乐是能证智。照明是证相应。亦是破无明也。入火应烧苦。反此故寂静安乐。三白言者明后得智说证中。事触者是证智与理融故云快乐。六我唯下结名。无尽者智依大定遍照法界故云也。又反道之用普周法界故云无尽。天竺本名得普摄道场菩萨解脱。解云普摄无尽诸众生界。如上加劝中显。皆令向佛果故云道场。梵本名毗目叉。此云解脱。旧翻名法门。但依得出离名门。则此名解脱。亦有业用自在可知

第五仰推胜进三。初明净法王等一句是总。二满足下别。三如是等下结。推可知。第九住竟

第十灌顶住中

初举法劝修中。城名师子奋迅者谓三昧德用自在之相。童女者位满离染贞洁之相。弥多罗尼者此云慈女。谓智德内圆慈相外彰故名也。天竺本名弥多罗衍那。此云慈救物也。彼本亦云此女父名师子幢。即是王女也。以位满故

第二尔时善财下依教趣入中。先念前法。后至后处。前中初念自分境中观真际等。二决定了知佛下明念胜进分中。果法等渐至后处可知

第三见敬请中五。初推问。二指示。三入见殊胜依正。金色者可贵之貌。位满显彰。四设敬。五申请可知

第四答言下示法界中四。初示法令观。二观已显名。三辨法业用。四结己唯一。初中三。先一句举法劝观。则业用自在依止法界二见一一下明正观证法界。略辨十句一一理实无边下文普贤毛孔现尘刹等即正报现依。此中则依报现正。皆是无碍法界自在故也。又此亦是器世间内现智正觉。亦是因位中现果法。亦是体中现用。有法喻合。三皆是彼女下结法属人。亦是结果由因。二尔时善财正念下显法门名。先问后答。答中名般若者。第十住位智度满故。即智自在。依止法界。普庄严者依智起用。具德圆备。如法云所显则其事也。彼诸如来以异门令我入者摄别归普故。一切成一故。显一甚深故广多故。三白言下辨业用中。先问后答。答中二。先举法总标。生平等时者明正证相应时。明得法门之体也。得普门等者总明所得业用也。以此中得陀罗尼门三摩提地门依止法界故。以十住十地境位同故。得法亦相似也。二所谓下别显所得。于中略举。总有一百一十六门。分作十位。初八门明所知理事持。二功德下十门明行持。三从业陀罗尼下八门明业持。四从善行三昧下六门明定用持。五心海下五门明知他心持。六发起众生下十一门明知所化持。七大悲下十五门起能化持。八世界起下十七门知刹海自在持。九分别佛身下二十七门知佛海自在持。十菩提心色下十门知色海无碍持。我唯下结已何知

第五仰推胜进中三。初一句总推深广之德。二安住下十句别显。于中初二句明行深。次离痴下二句明惠广。次得无碍下明眼智无碍。次一切世间下二句明行坚固。后善巧下二句明摄化自在。三如是下结非己分。上来十住总明十住竟

花严经探玄记卷第十八花严经探玄记卷第十九(尽第六地知识)

        魏国西寺沙门法藏述

自下明十行善知识有十人。各当一位

初欢喜行中亦五分。初举法劝修中。国名救度者常以法财施一切故也。又行能济物故名为救。令得出世。复名为度。比丘善现者行相超升比丘。表示施行内成胜报外现故名善现。劝往教问等可知

第二尔时下依教趣入中。先思念前法。后渐至后位。前中初一句总念前般若普庄严门。下十一句别。一所证。二所依。三所度。四所行。亦是有为诸行无性。五刹那离生灭心。六幻现如光。七念理真性。次二念语义。后二念因果。第三于城下见敬申请中。初推求简择。于都市等求表无著之行随缘造修也。二见彼比丘下明见胜相。言在林经行者表出世之相。亦显修行之所。次正报殊胜。表行顺佛果故相同佛也。地品云。如说行者乃得圣法。斯之谓也。次天龙下明胜眷属兴诸供养。三尔时下设敬申请可知。第四答言下示己法界。于中三。初示依缘得法。二善男子下显法之业用。三我唯下结法门名。初中亦三。初年少出家日近者。初入行位故名年少。创离十住之家故云日近。二自我下明所供诸佛。前位三十六。此中渐增故三十八恒也。又云自我生来者似于一生经尔所劫供彼诸佛。此何义也。释云或报命极长。或以一生摄于多劫。如念摄劫等。或入佛法为生。谓云自我生此菩提心来。经尔所劫供尔所佛。又涅槃供八恒佛摄因位等(云云)。三彼诸佛所下明成行得法。一句总。二庄严下别中标三种。一定愿。二叹行。三具足下德备。三严净下释出三因。如次可知。二就业用十一句。皆先辨业用。后出所因故。初三是前定愿庄严力。次一是前普贤行力。余七是前菩萨行愿力。于中初二供佛闻法。是前知菩提护法轮等。次二行定深。后三所知广。三结名者远照显焕名曰灯明。则十不可说等。常用无竭。名为随顺。天竺本名不休息智灯菩萨解脱

第五诸金刚下仰推胜进中。此是同类仰推。初显生族胜。二报命胜。前虽一生到不可说劫。未得不死故今推也。三报体胜。谓内智无尽外色无坏。四普观下明业用胜。五我当云何下结非己分。第一欢喜行竟

第二饶益行中

初举法劝修内。初国名输那者。此名净亦名善。是大江名也。谓国有此江。从事为名。诸外道世人皆云。于此江中洗浴。悉灭罪增福故以为名。表持戒行舍离业非。童子名释天主者。童子以表戒行清洁于戒自在故名天主。又准天竺本。应名诸根自在。以梵名因陀罗此云帝释名也。因达唎此云根也。湿筏罗此云自在。亦名主也。以释天及根梵言相近故。各据一名也。二劝往教问

第二时善财下依教趣入中。初明起胜念。二设敬辞退。三与众同至

第三见敬申请中。初推求告示。善城亦是输那名也。天竺本名城善。而言城外者表戒行外防故也。河水侧者表发定水故也。河水即是彼江水也。二见其所作弄沙戏者明三聚戒数方便集起也。三设敬。四申请可知

第四答言下示己法界。于中三。初举法门体。二善男子我因下明业用。三我唯下结其名。初中文殊教者表明人能护戒故知相。十善是吉。十恶是凶。戒相非一故云算数法。智论云。菩萨戒品微尘数也。善恶因果理决定故名印法。又有人释云。初相凶除断律仪戒也。次算善恒修摄善戒也。后印机救疗摄生戒也。因此得一切巧术等者巧知世法转成出世之用。是天竺本我得巧能转变一切法智。二明业用中二。初显相印二法功能。以相知善恶印除灾故。是故同辨。二复次下现算法巧能。罗叉此云万也。三结己分可知

第五诸大菩萨下仰推胜进中。初总举所推。后我当下正推非己分。第二饶益行竟

第三无恚恨行中

初举法劝修内城海住者。若随相释此城近南海而住。若准下文。出于财法施不可尽故云海住。优婆夷名自在者约行。则忍离嗔痴故云自在。若约德用。则作用任志故云自在。即下所显是也。天竺本名真实富满。解云以财法遍充故也

第二时善财下依命趣求中。初明得熏修。二设敬辞退。三恋慕叹德有十对可知

第三见敬申请中。初推求等明入法方便。二进入下明见正报。除严具素服者表忍相故。三于其宫下见依报。开四门者四摄摄生故也。四一万女下见眷属胜。于中语音身香智大益物。设礼申请

第四答言下正示法界中有三。初举法门体。二以一器下辨业用。三我唯下结法属己。初中以出生业用无穷竭故名无尽藏。所出利物。具胜德故名功德庄严。二业用中三。初明法门业用。二汝见我此下令见同益。三且待下举现验成。前中三。初施众生食等益。二施二乘等益。三施菩萨益。初中一器食者。古释云。胜流所依一味真如也。随其所欲等者称机说法也。而无增减者用而无尽也。又释只是一器饭。即融同法界无尽缘起。是故无不应机。应无不益。益无不称本位法界故。故云随欲而无增减也。二现同益中二。初举己眷属报行等同有二十八句。初十句名自分方便行。次同境界下四句所修法同。同具菩萨下十四句自他行满同。二此诸菩萨下显己摄成相。三善男子且待下举现事验成。三我唯下结名可知

第五仰推中初别举所推。二结非己分。第三无恚行竟

第四无尽行中

初举法劝修内。城名大兴者精进炽然故云也。又广以财法起。成大施故以为名。长者如前。释精进行味之中最胜故名甘露。行德胜出表之如顶

第二时善财下依教趣入中。先设敬辞退。二尔时下忆念前法。三渐渐下至后位处

第三周遍下见敬申请中。初推求。二乐求下起胜欲。三正见殊胜依正及胜眷属。四设敬。五申请问行

第四长者答言下示己法界中。初发心。二善男子汝见我下法摄眷属令成十种饶益可知。三标己法门。谓财法无尽蕴在虚空。随意给施故以为名。四随其所须下明法门业用中。初总举功德宝藏如意益生。二且待下举事验成。先见众集。次观空雨物。此同破虚空器三昧。正是十行所得。后授法令喜。五结己法门

第五仰推胜进中。初总推。二谓下别有十句。三我当下结非己分。第四无尽行竟

第五离痴乱行中

初举法劝修内。城名师子重阁者十德叠起状类重阁。诸佛菩萨雄猛之士处在彼位故云师子。此宅在彼城。城依宅号故以为名。长者法宝周罗者周罗此云顶髻则以法成人。宝为顶髻。天竺本云有法长者。名宝周罗。显其定用可贵尊极之相

第二依教趣入中。初设敬辞退。二念前法门熏修长养。三渐至后位。并文处可见

第三周遍推求下明见敬申请中。于中于道遇见者明道力随缘触物便应

第四时彼长者下授己法界。于中四一。执手等是授方便。则加行也。二遍观等正见法界。则正证也。三问法因缘。则后得也。四我唯等结己所知。即立名也。初执手将归者表摄归所证。且观我家者以法正授。二善财遍观下证见法界。先总观。二其宅广大下别观。谓此宅十重者向上重也。此相难定。略作三释。一依古师云。十重即十地也。以八圣道通游入故以为八门。或四摄四无量亦为八门。初施食者谓初地檀行。二施宝衣者二地惭愧戒衣服。三施宝严具者三地忍行。用以严身。四施内眷属者四地道品助行。五结集正法等者五地得五明论等。六得波若菩萨充满等者六地得般若大智现前。于中三。初总显深智。二所谓下别显十门。一照则寂。二寂即照。三外缘不转。四内照离染故。五体坚。六用广。七含胜德。八见法界。九多巧便。十称物机。十一约喻显。是增数故也。三结集如是下结广显略。七响忍菩萨等者七地得有中殊胜行。知种种教法无别异义成于响忍八常住菩萨等者此中有二德。八地证得无增减法界。神通刹等者于三世间自在故也。诣一切等者明九地受持佛法也。九补处等者明十地受职位等亦是等觉位。十一切如来者妙觉位。从初发心等明摄因成果。第二更释此上十重。即总是此十行之位。始从施食名欢喜行。乃至第十如来充满是真实行。以于一位摄一切位故。此有二重。一以十行前摄十住及十信行后摄回向及十地位。二既以十行摄诸位尽。于自十内复以一位摄一切位。是故于此第五行中具斯十行。前海幢比丘在十住位。顶佛说法。还此以十住门摄一切位。今此长者在十行位。所居之宅还以十行门摄一切位。是即两处摄义齐也。但以前寄第六住说。此约第五行辨。又前寄顶佛此约居宅者。并为表胜劣不同故也。第三又释总不约位。但此菩萨以行就机。现居胜躅。依则说十以显无尽。初四以物施。初易后惭难。次二集法施。初浅而后深。次二领受法。初狭而后广。后二现胜德。先因而后果。总此十位皆从粗渐细可知。又此长者具摄因果行位等法。总为所依故以为宅。三后得中显法本因。于中先问后答。答中善根回向三处。谓初灭除贫苦者。即十重中初四是其报也。二见佛菩萨等。三恒闻正法。此二即五重已上是其报也。故获斯报者回求三处满十重也。四我唯下结法名字。谓宿愿所求之三处称。遂成满之十重故名满足大愿法门。天竺本云得菩萨解脱。名无碍愿庄严道场。解云十重之宅名严道场。宿愿彻微名无碍愿。则以彼无障碍愿力严此宅处名道场也

第五仰推中初别辨十句。皆云不可坏者德穷满故。无进升故。不为缘动故。我当下结非己分。依梵本云。我当云何能知彼功德能说彼行。解云是则于彼已成之德不能了知。现行之行亦不能说。上下诸文皆同此应知。第五行竟

第六善现行知识中

初举法劝修内。国名实利根者国者境位分齐也。般若离倒称理名实。明照生后故名利根。此是托处显第六行。城者防外守内。是妙智用。简狭取广故云普。通入游涉故。复称门。普则是门。普门即城。皆持业释。此约法辨。又释城摄眷属为多所趣故名普门此约事释也。长者普眼妙香者智照根药。普熏众生故以为名

第二依教趣入中。一辞。二念。三到念中十句。初一句总念前法。次二句明因念所得。次一句乐求无厌。次三句成就菩萨解脱根力。次二句行愿随心。后一句得智体用

第三见敬申请中。初求趣作念。二见胜依正。三设敬。四申请

第四授己法界中三。初叹发心为授法方便。二我知一切下授法门业用。三我唯下结法名体。就业用中有二。初疗病通化下益众生。二我又善知下因香起行。上供诸佛。前中有四。初除其身苦。二与其身乐。三然后为说下疗其心病。四称扬下正授大行。此四中初二共安乐众生。亦是摄化方便。后二是利益众生。亦是正授法行。就第四中有十四句。初三是授菩提心法以是行本故。一赞佛功德令发求一切智心。二大悲救众生心。三诸度净智是厌离有为心。亦是广修胜行。心说诸大愿下十一句正授所修十度行法。初因大愿施行摄生。乃至末后二句显于智度。二因香起行中。初知诸香体。二烧香起愿。三如愿普熏成大供养。文处可见。以梵本中是卖香人故。三结名体中。令众生欢喜者如前所说。利乐众生故。普门者如前所说。烧香普熏严法界故。见一切佛者是所供诸佛故。天竺本云得令一切众生喜足普门见佛供养香身法门

第五仰推胜进分中。初一句举其人。次一句总推大益。三其有见下别推见益。我当下结非己分。第六行竟

第七无著行知识中

初举法劝修内。城名满幢者方便境备胜出为名。王名满足者善巧智圆违顺自在故。以其王复表斯号

第二依教趣求中。初辞。二念。三到就念中初一句总念。以此无著是善巧位故。总摄已前诸位之法故云次第忆等。此则念其教法。二复作下念其人力。三如是下明因思念得胜进。大心有十六句。初九自分行心。二见诸佛下得胜进心

第三见敬申请中七。初问答指示。二遥见彼王下见胜依正。三睹其逆相。四以生疑怖。五空天为决。于中二。初举前教真实令不生疑。二菩萨方便下明后行玄密令其信入。初中谓前善知识教汝至此。彼教不虚。何以致疑。问善财岂不自忆前教。何故生疑。答以对嗔嗔害障道相故。理须要疑。方乃显知菩萨道中反道顺道二行差别。不尔耶正无以甄别。梁论戒学中释甚深云。菩萨由如此方便胜智行杀生等十事。无染浊过失生无量福德。速得无上菩提。要大菩萨堪行此事。此有二种。一实行。二变化。实行者了知前人必应定作无间等业。无别方便令离此恶。唯可断命使不作恶。又知此人若舍命已必生善道。又菩萨自念。我行杀业。必堕地狱为彼受苦。彼虽现受少轻苦恼来世必受乐果报也。解云此同瑜伽菩萨地中戒品内说。二变化者如那罗王及善财童子。或见可爱事。或见可畏事。各令众生生于善处。解云彼引此经是变化作。那罗是梵语。此云满也。或见可爱事者引此前文。初见依正生于可爱。后见犯王法等生于可畏。皆为益生故也。二明菩萨所作玄密之中。初二句巧智难思。后五句业用难思。谓迹违行顺。非下位测量故云也。六设敬。七申请

第四时满足王下明授己法界。二初授法方便。谓执手将入等。摄彼加行令趣真证。二善男子汝观下正示法界令证相应。于中五。一举果令入。二见我此报下示因令修。言幻化法门者出所修因。谓逆相不实故以为名。天竺本名住幻三昧。三我此下举幻用。四当知下辨实行。五结己自分

第五仰推胜进中。初一句总推。谓后第八位当无生忍故。此推之。下九句别显幻等甚深。后一句结非己分。第七行竟

第八尊重行善知识中

初举法教修中。城名善光者。谓顺理益物业用为光。王名大光者大慈定光照益群品。摄化自在故以为名

第二依教趣求中三。谓敬辞念前至后。就念中熏修前法令更增胜。谓例知世间一切法幻同入法界

第三善财作如是念下明见敬申请中有五。初起胜念作必见想。二见胜依报有十种庄严。一七重池堑。二七重宝墙。三十亿街巷。四巷僧祇众。五僧祇宝阁。六纯宝帐。七宝盖覆。八建幢幡。九别阁王住。十善财无染。谓知如幻故。往求善友无异念故。三见胜正报具大人相。以十种喻叹美其德。二十八者现因位未满故。四彼王殿前下见主伴摄生。先施资具后摄众生故。下十门辨施意欠一句。五设敬申请可知

第四授己法界中五。初示己法门。谓慈胜出离染圆满备故以为名。二我于下明得法因缘。谓于多佛所闻此法。观察者思惠故。清净者思己明净故。修习者修惠故。庄严者证得故。三我住此下显法门业用。于中四。初以法摄生。谓授法令得慈心等益。二我以如是下以财益物。三随行异见。四为我宿世下简定机器。四此城众生下明慈定功力中二。初说彼定用。二且待下对现其用。于中先入定后显用。情与非常咸成胜益。五结己自分

第五仰推胜进中。初一句总推慈益深广。二七句约喻显德。三我当云何下结非己分。第八行竟

第九善法行知识中

初举法劝修内城名安住者契合实法不为缘坏故以为名。优婆夷名不动者。初发心时不为二乘烦恼所动。因以为名

第二依教趣求中六。一设敬辞退。二念前法门修习增长。三作是思惟下因思得益。四复作是念下念知识功能。五善财如是悲心下因念感赞。随菩萨天者是已业行之神。如来使天者是佛为摄生神。但修菩萨行位着已去皆有二天。常随其人。既见善财深悲入定。于定现身加赞安慰。六出定渐至等可知

第三推问下见敬。申请中有四。初推问知处。二尔时善财欢喜下见依报得益。谓光触得定。以是法门之宫殿故。寄光触身得五百三昧。三前诣下见正报益中六。初见身胜。二宫殿胜。三香严胜。四眷属胜。五离染胜有二句。先伏后断。六牒见总叹。颂中上半略叹三行。下半举喻总显。四偈赞已下申请可知

第四尔时彼女下授己法界。于中五。初答言下叹美为授法方便。二我成就下授法门体。三白言下辨得法因缘。四我入此下显法门业用。五我唯知下结己自分。就第二授法体中。无坏法门者所修大行非缘能坏故以为名。此总标也。修学下四句释成。一以行坚是故无坏。二以持妙。谓总持称性故。三以证玄。谓证理无二故。四以定深。谓远离诸有庄严三昧故。是故名为无坏法门。就第三因缘中。四先问。二略答显难。三重请。四尔时优婆夷下广答。于中有六。初举往见佛为发心缘。谓先见佛后起求念。二时彼如来下教发十心令便不坏。三我于尔时下闻法发心以求佛果。四我发是心时下明心坚离障。五若有众生下明利他摄益。六我初发心来下总结自他行位满足。就第四法门业用中四。先举法总告。二善财愿见。三入定显示。谓三昧力故。六种动世界。八相如来周于法界。四出定印述。及结自分可知

第五诸大菩萨下仰推胜进中三。初一句总推。二如金翅下约喻叹深。三我当下结非己分。第九行竟

第十真实行善知识中

初举法劝修内。国名不可称者所观玄妙故。城名知足者般若尽相故有出家外道。名随顺一切众生者巧智顺机方便反道。天竺本云外道名一切处常行

第二依教趣求中亦三。谓辞念及到。就念中十句。初句念人。次二句念法。次二句念往发心等。次四句念彼坚行及示业用。后念彼修习等念其修定照理。渐到中日没入城者表行位终极故也

第三周遍下明见敬申请。于中四。初推求。二于中夜下见其依报。谓表所依法光破二边闇故也。三尔时善财下见其正报。天明者障尽位显故。登山者得位相应。故见外道者证人法界故。一万梵等者主伴具足故。四设敬申请可知

第四答言下授己法界。于中有四。初叹发心。二我已安住下示己法门体德。三以平等下显法业用。四我唯下结己自分。初中至一切处者明十行满故也。第十智度遍知故也。有二义。一依定发智普照法界。二依定发通遍至一切。下二句释此二义。如次应知。三业用中亦二。初明普观智用。二无作通用。前中三。初举平等惠光。二观察下照机差别。三以妙智下说法被益。复次下第二无作通中二。一机莫能测。二类显十方。种种智是意业。色像音声是身语。亦如是者此有二义。一明彼无作神足所现色像。亦如巧智用遍十方故云亦复如是。二以知足城类阎浮。以阎浮类三千界。以三千界类十方界故云亦复如是。此则双结智通三业具也

第五诸大菩萨下仰推胜进中十句。初身等众生数者显至一切处神足过于己也。次一句所依定过。次二句所发通过。余句所发智过。我当下结非己分。第十行竟

自下大段第四有十知识。明十回向德

初甘露味国等明第一救护众生离众生相回向。于中五义同前。初举法劝修中。甘露味者救生善巧之胜味也。长者同前。德相净胜名曰青莲。巧知诸香故复名香。从相及智名青莲花香

第二时善财下依教趣求中四。初设敬辞退。二尔时下起胜欲乐。于中四。初于世不着。二常乐下专悕大行。三专求此等下结其意乐。四渐游等明至后位

第三见敬申请中三。初设敬。二白言下申意十句。初五上求果德。后五悕成因行。三而未知下请问所要

第四答言下示己法界。于中二。初叹发心。二正授法界。中先举所知法门。后结名字。前中三。初列所知香体有三十种。于中先知世间依正香熏习。二除灭烦恼下知出世间正行香熏习。菩萨以此饶益众生。二彼香生起下明知香法义有十种。一知所因起。二知香气至处。三知至已成益。四所作圆满。五能令喜悦清净。六令离恼安隐。七巧便入法。八所知分齐。九所作行业。十究竟根本。三善男子下知香业用略举十种。初内以十义知之。龙斗生者知生起也。光云覆甘味国者知所行也。降香水者知成就也。着身金色者知具足也。闻香欢乐者知清净也。灭一切病等者知安稳也。专向等者是方便也。我知彼等者是境界也。为说法者是行业也。令发心不退者是根本也。牛头香等九种皆各有十义。文中存略故。或二或三等准之。先陀婆此云石盐名也

第五仰推中先举所推。于中初离障。二智慧下成出世。三学位香。后我当下结非己分。初回向竟

第二不坏回向知识中

初举法劝修内。城名楼阁者大悲依智胜出之状。海师自在者。于佛法海及生死海能善通达及运度故以为名。教问可知

第二依教趣入中三。初设敬辞退。二在路起胜念。于中初观法真正。二复作下念法由人起于求心。先总念。后何以下释成。三作是念下至彼推求

第三见敬申请中三。先见所在。谓海岸等者是说法所作之所也。二设敬。三申请并可知

第四答言下示己法界。于中二。先叹发心能问。二我成就下举法授与。前中三。初叹问行体。二逮得下明行用。三萨婆若下明行得果。二授法中亦三。初举名体。二在此下明业用。三我唯下结己分齐。初中大悲幢净行者。以殊胜大悲于生死海拔出众生名为净行。二业用中二。初在此城中因苦行度生。二我知海中下善知海相。因入海度生。前中三。初授法方便。二广为说下正明授法。三我住下结。就授法中。起其宿善发菩提心此是总。下三心是别。起信论云发菩提心者发三种心。一者直心正念真心法故。二者深心乐修一切诸善行故。三者大悲心救拔一切苦众生故。除生死下显三心业用。初是直心离苦。二摄取下悲心摄物。三得一切下深心得法。下结城中益生。二知海益生中二。初明智知海。二我已成就下正显益生。前中初十句知宝。次知龙宫等难。大身应是修罗。以四位修罗俱在海下故。次知水色时风等。二正益生中。成就如是智者牒前所解。遂为入海导师。则说法海以度众生故。云为益众生故入海等。悉令下别显益相有十法海。初四自利海。后六利他海。下结中二。先结益用不虚。二结唯一法

第五诸大下仰推中二。先举所推初推自行海。二以善方便下推利他海。后我当下结非己分。第二回向竟

第三等诸佛回向知识中

初举法劝修内。城名可乐者已境界等佛土可愿乐也。长者无上胜者以得胜通更无加过故以为名

第二依教趣入中三。初设敬辞退。二在路念法。三至后推求。念法中初增广自分。二修习下修八胜进

第三城东下明见敬申请中三。初明依报所在。城东林等者于城摄化栖托之便也。在彼说法。正明摄化之相。二尔时下见已设敬。三白言下申请中。前五体良久以身表心。重称己名以语表心显愍重之极。又显已是修行之器悕其说法也

第四示己法界中二。先叹其发心为授法方便。二我成就下正授己法。于中三。初标名总现。二何等释法义用。三我唯下结法归人。初中神力遍到众生之所名至一切趣于中说法益生名净行庄严。此至一切趣。不由功用。任运遍至故云无依无作。非他力持故云无依。非自加行故云无作。此则称法性而普遍也。释中先征问后正释。正释中先至此三千界一切趣。说法益生成净行严。种种论者五明等也。二如此下至十方界一切趣成净行严。我唯下结己分齐

第五诸大下仰推胜进中。初明身业遍。谓身等于刹不待神力。是故过前是所推也。二逮得下明语业。三分别下明意业。我当下结非己知。等诸佛回向竟

第四至一切处回向善知识中

初举法劝修中亦三。先指处。二示人。三教问。国名难忍者表能证难证也。迦陵迦者此云斗诤时也。婆提者正云婆那。此云林也。谓彼菩萨在此林中说法破障故云斗诤。斗诤显理亦名难忍。比丘尼者显慈悲净惠名师子奋迅者净惠无畏决定说法

第二依教趣入中三。先设敬辞去。二至后推求。三指示所在。准律中尼投陀皆在王园。以藉外护方得长道

第三见敬申请中亦三。一见。二敬。三请。初见中亦三。初见依报。二见正报。三总结奇特。初中依报净土略显六义。一见大树庄严略举八种。二复见彼园泉流下宝池庄严。八功德水者。一轻。二冷。三软。四美。五净。六不臭。七饮时调适。八饮已无患。三从一一树下下敷座庄严。四无量庄严下明杂种庄严。五善财见下出其所因。谓皆是出世善根及如幻智之所成就。六三千下明果用自在无障无碍。二见正报中二。初见遍坐诸座。胜德显彰。于中先遍坐。后约十喻显德。婆楼那者此名水。应是水天。佛见已成益故也。二见处一座下明见处遍坐广说法要。于中有五。初为八部众说法。二乐声闻下为二乘说法。三为乐大乘者下为菩萨说法。四见处如是下总结化益。五何以故下释其所由。初为净居天说无尽者。彼天形中最净无常有尽。为说出世无尽性故。为梵说普妙声者。彼于世中自谓好声。为说法界胜流普妙音也。为他化天翻世自在故说菩萨自在也。为化乐天说净行法具德庄严。为兜率天说心藏旋复者说大回向不退转也。为夜摩天翻其有量庄严为说无量严也。为释天说令厌离五欲也。为龙王说方便救护众生者。方便降雨济众生故。又以法救龙金翅等苦。提头等。等取余三天王。为说无尽行法。为摩睺等说理智巧严。为迦楼等说法舍世海中大力。令于生死海中以悲智力令无畏也。为紧那说佛正行智光令破着乐。为摩睺说佛喜者。以蛇性多嗔闻佛则喜也。为人说出世胜趣。为罗刹说慈悲不令夺命故也。下为二乘中。初为乐声闻说胜智光者令舍小惠乐大乘智光也。为乐缘觉说令舍劣乐佛殊胜功德故也。下明为大乘人。初为地前说定惠之光。次为地上初地发心说十大愿。余九地可知。为金刚力士说智慧金刚者。此是十地满后说金刚喻定智破微细着等也。此比丘尼既为第十地菩萨等说法。明非是小人为寄位故当回向位也。四见如是下总结化益。五何以故下释所由中。以此尼成百万等中。略举十门般若。则是前所说之法门等。三善财见下总结见闻奇特可知。二五体下明设敬中。以根缘相称故。自见己身遍尼所在。同皆右绕等彼所入故也。又亦即是至一切处回向随心自在故也。三白言下申请可知

第四我成就下正示己法界。于中有四。初标名。二显体。三辨用。四结位。初中菩萨一切智底者有三义。一位居菩萨得百万僧祇般若智用尽佛一切智之原底。谓如上文。乃至为等觉地菩萨说法。非下地能尔故得斯法。二智光顿照三际。穷种智之境故以为名。三广兴供养尽佛八相智之原底故得此名。二大圣下明体。于中先问后答。智光等者明般若具德也。于一念者顿照也。普照三世者广照也。则以广智具德为其体性。三大圣下明业用中亦先问后答。答中先辨业用所依。谓此法门境用之前处有此法林三昧。今入此定已现斯业用。下正显业用中三。先上供八相诸佛。二若有众生下明下救众生。三我不起下远离二相显无思业用四我唯下结自分位

第五诸大下仰推胜进。于中十事五对。一穷法无著。二约身外广遍内包容。三外速往内含力。四外遍举内广容。五一念广摄生后摄于多劫。则知一一念中摄生无尽。我当下结非己分。至一切处回向竟

第五无尽功德藏回向知识中

初举法劝修内亦三。谓贪相违道得险难名。实行内备名宝庄严。婆须密多此云世友。亦名天友。以巧能引摄诸世间故

第二依教进入中亦三。谓敬辞念法及至后位。就念法中。初因前尼惠照其心故令长养佛智。二一心下因思念前法后更增长悲智愿行。就至后位推求中四。初推问胜故。二为浅智疑怪。三为深智叹善。四指示所在。问何故前示嗔及耶见善财自疑。今现贪相乃令他疑。答以前二亲障菩萨道故。贪爱顺悲障行劣故。是故决定毗尼经菩萨宁起百千贪心不起一嗔等。又释善财于前嗔及耶见已为调伏。是故于此更不敢疑。指示中在深宫内者依三法度经。国是智慧境。城是神通境。宫殿是说法境。今此女人正证欲如故在深宫。往诣门者加行位终至正证三昧门也

第三善财闻下明见敬申请于中三。谓见敬请。就见中二。先见依果。后见正报。依报中。古释云。十重宝墙者是十地位。十行树者是十度行。十重堑者是十地中戒行。八功德水者是八定水盈满也。敷以觉花楼阁者后得依正体重成故也。二见正报中二。初见三业胜相。二大众下显眷属殊胜。设敬申请可知

第四答言下示己法界。于中有四。一标名显体。二若天见下辨其业用。三白言下得法因缘。四我唯下结己自分。前中离欲实际清净法门者有二义。一约自行。虽悲愿留惑示现欲处。然大智照欲则体性空名实际净也。如净名在欲而行禅等。又诸法无行经云。贪欲则是道恚痴亦复然。二约利生。谓虽留惑示现在欲。令处欲众生要当离欲得此实际清净法也。如掩提遮女等。二明业用中二。初身同器现。二若有众生下以法益生。于中有十种三昧。皆是以欲化处欲众生令得如此甚深三昧。阿梨宜者此云抱持摩触。是摄受之相故。得彼三昧也。阿众毗者此云呜口。得言教密藏之定。如是下总结。并是极位大菩萨所作非下位所知。如摄论定学中说。三明得法因缘中二。先问后答。答中先答于何所种善。后善男子下答修何等业。并可知。四我唯下结已唯知此一方便

第五诸大下仰推胜进诸大菩萨有无量广大方便。我岂能知。无尽功德藏回向竟

第六随顺平等善根回向知识中

初举法劝修内。首婆波罗者此云善妙到彼岸。安住者谓得佛法身。常住供养故。又准天竺本应名摄持。或名执持摄入摄取诸善法故。常供塔者以于塔处常见法身故

第二依教趣入中略无念法

第三见敬请中。略无见敬。故云乃至也

第四答言下示己法界中四。一标名。二辨体。三业用。四结德。初诸佛常身名不灭度。因位照达名菩萨法门。二住此下显体状中二。初见佛功德身常除化众生者。但变异他心令见出殁。其实常身无出无灭。又佛月常住。但众生心水影有现灭。二开塔户下见佛法身常。以见佛体性无限尽故。以开塔者开其事相也。得定者见理性也。得妙法者得理中恒沙功德法也。三白言下明业用中。先问后答。答中二。初见此界三世诸佛。后类结十方。前中初见过去佛因果等事。二类未来现在。四我唯下结自分位

第五诸大下仰推胜进中。长者虽知三世佛不灭。然未能以能知之一念与所知之三际平等无二也。二未能即能知智住所知佛位。三知前后一切劫不能知无劫想。四虽见佛不灭不能知此佛则彼佛平等义。五如来下亦不能以染净能所平等无二。谓心佛及众生是三无差别。六净庄严下虽照三世不能则智摄德。七成就下虽知佛未能同佛威仪。八分别下不能于法自在。我当下总结已不能坚固。善根回向位竟

第七随顺等观一切众生回向知识中

初举法劝修内。光明山者彼山树花常有光明表大悲光明普门示现。此山在南印度南边。天竺本名逋多罗山。此无正翻。以义译之名小树蔓庄严山。又十一面经在此山说。观世音者。有名光世音。有名观自在。梵名逋卢羯底摄伐罗。逋卢羯底此云观。毗卢此云光。以声字相近是以有翻为光。摄伐罗此云自在。摄多此云音。勘梵本诸经中有作摄多。有摄伐罗。是以翻译不同也。观世音经中即时观其音声皆得解脱。解云等观世间随声救苦名观世音。彼经中具有三轮。初语业称名除七灾。谓水火等。二身业礼拜满二愿。谓求男女等。三意业存念除三毒。谓若贪欲等。并如彼说。若偏就语业名观世音。以业用多故。若就身语名光世音。以身光照及故。若具三轮摄物无碍名观自在

第二依教趣入中亦三。就念法内十句皆。是依前教力增修行。余并可知

第三见敬申请中亦三。初见中二。先善财见观音。后观音叹善财。前中四。初见胜依正。住山西阿者。谓据山阿面东而住。是向明之相也。二为众说法。三谛观不瞬。四作如是念下胜念熏心。于中初八句别显。后二句总结。二时观音下叹善财德中十句。初叹心胜。谓具三心。二向普贤下叹行愿胜。三欲闻下叹持法胜。四增长下增善无厌。五顺友教命。六从文殊下所依最胜。以赖彼发心故云从彼海起。又释从本觉所流故云从彼智起。七成就下叹成善根故得佛加被力定也。八离懈怠下叹求法专诚。九叹见佛成行。十智慧下叹智满圆证。尔时下敬请可知

第四答言下示己法界中二。先叹发心明授法方便。二我已下正示己法。于中四。一标名。二辨德。三显用。四结位。初中大悲者是同体悲也。又是无缘悲也故名大悲。又具三悲故名大悲。光明之行者以悲光益物故以成行。天竺本名一切佛悲密智藏解脱。解云以巧悲密摄众生故也。二教化下辨其德。于中二。初不离佛所现众生前。二或以下以四摄等成摄化之益。三善男子下明其业用。于中三。初行法立誓。二令离怖畏有十八种。三复次下令行不退。四我唯下结己自分

第五诸大下仰推中四。先推普贤愿行。二不断下行业流续。三知一切下明摄生相续。四我当下结非己分。随顺等观一切众生回向竟

第八如相回向善知识中

初举法观修内二。初正趣东来。二观音指示。三教其问道。初中东方来者表如相。证智开明之状。名正趣者神力速至十方诸趣。以正法摄生故以为名。天竺本云有一菩萨名不行余道。解云唯行佛道不行余二乘等道。即当正趣。谓趣正故也。梵本约遮。汉本就表。住金刚山顶者则是此光明山也。表住于如相不可破坏故也。下明动地宝严。放光雨供。来诣观音者明智就悲。亦是随化有缘示导善财。二时观音下对审指示。三汝诣下教问可知

第二时善财下依教趣入中二。初礼。二念法至后。位何故不念观音悲门。以悲不离智故。令悲深入于智海方为究竟

第三辞诣下见敬申请。前已见故但有诣敬申请

第四我已成就下示己法界。于中三。初标名。二辨义。三结位。初中十方无际名为普门。一念遍至号曰速行。二白言下辨义中。先兴三问。后还三答。一问得法之处。二问来处远近。三问来时多少。答中三。先叹深简器。唯精进等者则是善财正当其人。以根缘相称。欲为说故。二唯愿下起胜欲乐。三答言下正释所问。妙藏刹者答所从来处也。佛所等答得法处也。从彼发来下答来时久如也。亦显是远近也。二于一念下释尔许劫中行之分齐。正显速行义。三所经诸国下辨速行成修行义。谓上供诸佛下救众生。非直不废速行而成妙行。亦乃则以速行成此胜行。四乃至下结通十方。谓从东既尔十方亦然。三我唯下结己自分

第五诸大下仰推中。初一句总推。二别推。所住境界无量无坏不同正趣唯此住一金刚山顶。三别推速行。谓以法身本来满法界不待速行。四分别下推其所作。谓说法度生皆等三世无著等也。五我当下结非己分。如相回向竟

第九无缚无著解脱回向中

初举法劝修内。城名婆罗波提者正云堕罗拔提。此云有门城。谓城有端严之门故以为名也。大天者无缚净报胜出自在故立斯号

第二依教趣入内四。初礼辞。二念法中三。初思求前法。二出生下因思得法。三得不思议下出所得之法。三渐渐下至后推问。四有人指示是伴善知识也

第三善财往诣下明见敬申请

第四尔时大天下示己法界。于中二。初授法方便。后正授己法。前中亦二。初身业。后语业身中以四长臂者四无碍解方便用也。取四海水者与法界胜流义相应。洗其面者净己应机之面。古来皆谓洗善财面。今勘梵本。以四长臂于四方处各取一海水自洗己面。是则水洗净己能对。花散善财就其所。二作如是言下语业叹机。初一句总。奇特法者世间所无故。二别叹为归摄以正道。三别叹为师护以正法。四别叹为将引至智城。五具足下结离过应机。二我成就下正示己法中三。初标名体。二显业用。三结自位。初中云网者六度行法有润益义遍覆义。喻之如云有涝漉义隐映义。况之以网。则以六度行为体。二白言下明业用中。先问后答。答中三。初教行施行。于中初积物。二教施。三类余众生。二复次下教行戒等。三如是等下总结行成。三我唯下结己自分

第五仰推中约五喻显五行。初二自利。后三利他。我当下结非己分。无缚无著回向竟

第十法界无量回向知识中

初举法劝修内。前诸位并是南天竺。今指中天竺摩竭国。道场神者欲表二义。一约因。表地上证真同于佛位。回向位终。是以成向此处。二约果。表佛临机方便现身是善巧之相。属回向位满。是故于此辨成道之处。良由五位终极各有成佛。树下现成属此位故。又神者表是智德玄密义也。然守道场神。有道场树神。有道场地神。今是地表所依心地。以心中得道为道场地。名安住者摄诸善根回向菩提。安在道场地处。住持不失要令成果。故以为名

第二时善财下依教趣入中二。初设敬辞去。二至后位处

第三一万地天各作是言下见敬申请四。初地天叹善财德。二时安住下严土摄生。三告示宝藏。四设敬申意

第四时彼地神则以下示己法界。于中五。初示体。二显名。三业用。四因缘。五结位。初中以善财宿世善根悉皆回向大菩提故。是故在此道场菩提树下。藏中安住则是菩提心藏也。今欲证地。加令总现。则一切善根皆在此处。二我已成等显法名者。以住持不失成佛决定名不坏藏。三我于下明其业用。于中十句。初一句总。谓常护者持彼所行故。下九别显。内一智深证。二满大愿。三净妙行。四出胜通。五具德力。六成坚法。七闻佛说。以守护行增是故闻佛与记之法。八下以法化。九上受佛力。四乃往下明得法因缘。于中三。初往古时处。二修习下得法增广。三于其中下更遇诸佛。皆于道场成正觉处恒作供养等。以其主当此门故也。五我唯下结己自位

第五仰推中。一常能随侍者以此地神唯道场处见佛不能常随故仰推也。二悉闻下推广闻。三深入下明深闻。四于念念下明顿闻。五一切佛影下明因出果不可坏等。六我当下结非己分。上来十回向位竟

自下从婆娑婆陀至瞿夷有十善知识。明十地位行

第一欢喜地知识内亦为五分。初举法劝修中。正云迦毗罗婆窣堵此云黄物城。则往古黄头仙人先在此处。后于此作城故立斯号。亦名寂静住处。何故在此城者表初地已上生佛家故在佛生城也。婆娑婆陀者正云婆罗婆萨那。此名依止不畏。即下文广与怖畏众生而作依止故也。天竺本婆僧多此云春也。谓表能生长万行如春时也。夜天者同初会中主夜神等。谓在于夜中耀光救物故以为名。表证智妙离众相破闇障故也。此九种夜天依梵本皆是女天表是慈悲之状也

第二时善财下依教趣入中。一敬辞。二念法十句。初一总。余九别。皆是无坏法门之德。又释以此九行入彼法门。三渐游至彼从东门入者是开明之初。入证之始故也。中城住者表离边也

第三尔时善财日没下明见敬申请中。先见内三。一推求言日没者表息地前分别智尽也。又以是夜天非昼日所见故。于闇夜方乃得见。二见彼下明正见身。古人云。城者谓初地教道。上空中住者谓证道。身如金者实德显彰也。服朱衣者表证智光明也。三于其身下见其业用。于中三。初身现星光等者闇夜摄生也。二毛孔现法以益众生。三随所经下于一毛孔中见闻菩萨教化众生。二善财见闻下设敬。三白言下申请。言一切智道者明十地是佛正因道故

第四夜天告下示己法界中二。先叹其发心顺知识益。二正显己法。于中四。初标名体。二显业用。三得法因缘。四结自分。初中光明普照诸法者正证法界也。坏散等者破异性障遣二愚也。又释普照诸法者明其大智。坏散众生愚者明大悲用。又释前自利后利他。又释普照等是能化之智。坏散等是对机化益。二我于恶众生下明业用中。先长行后偈颂。前中二。初起救物之心有九种可知。二我常下正对缘救摄。于中有十门。初一总辨。后九别显。前中初明救时亦是释夜天义。以主当世间夜中摄化。亦表地上变易闇中以摄众生。次城邑等明救处。后于此众生以种种等成救事。若有遭海下别显九门救处难众生。皆有二救。一以世间救。二以出世救。一救海难中。先明所救难状。后显能救方便。虽救世海亦欲救拔生死海中众生。此初段中略此文。二救陆地众生为作光明等。是世中救。二发如是心下以惠光灭烦恼闇。是出世救也。三救在山众生作果树等是世间救。令众生越生死山者出世救也。四救旷野众生令离饥渴等是世中救。二复作是念下令究竟智道是出世救也。五见乐着下救着国土众生令灭其乐着。是世中救。二作如是念下亦令除五阴着住佛境界。是出世救。六见着聚落下救着聚落众生说法令厌。是世间救。二复作是念下令离六入空聚入一切智城。是出世间救。七复次下救迷或众生令其解脱。是世间救。二发如是心下明出世间救令灭痴闇止诸恶逆。于中先显所救众生。后如是下明能救之德。八我见贫苦下救老病众生方便救济是世中救。二复作是念下令得法身常住是出世间救。九我见诸恶众生下救外道耶见众生令住正见。是世间救。二复作是念下令得出世佛果等。此上九门于前九种众生起九种心等。应准此知之。二偈颂中二十一颂分四。初一颂法门名体。二有四颂明四无量心。是能救生心。三有十颂明六处殊胜。初三眼。次二耳。次一鼻。次一舌。次一身。次二意。四末后六颂明业用广大。初一神通广。次三智慧广。后二所见广。第三善财白言下明得法因缘。先兴二问。后还两答。答中先答发心时节。二复次善男子过此下答得法久近。前中八。初总明过时劫佛兴。二显过去父王。三初佛兴出。四辨本生身。五善友告赞佛兴。六供佛及众。七结会古今。八显善力不虚。二答得法久近中五。初总明时处佛兴。二显本生身。三彼净月下明善友劝导。四诣佛闻法。五明得三昧。于中四。初得方便三昧。二得此下明正得法门。三放光下明光照见佛增长法门。四一身下明身广遍刹见佛增法。此上所说明此一法门根芽深远迹至于此。四我唯下结自分位

第五仰推中初推其自行。二于念念中教化下推利他行。我当下结非己分初欢喜地知识竟

第二离垢地知识内

初举法劝修中。女夜天名者。最胜法界称曰甚深。正智证入名为妙德。戒无误犯之垢。智有照俗之功故云离垢光明也

第二依教趣入中四。一叹前。二辞去。三念法。四到后。初中以十偈叹德。初二叹身智甚深。次二叹身智广大。次二叹毛光化用。次一叹本因庄土。次二见闻获益。后一结叹无尽。就念法中。初思前有二。一思其初发心时。二思其得法圆满之时。下明由思得益中有十句。行相可知

第三见敬申请并可知

第四答言下示己法界。于中有五。初叹法器。二示法方便。三显法名体。四辨法业用。五结己自分。初中叹发心能问依地之行及行所依地。二示法前方便行。于中三。谓标辨结。辨释中十行内。初一总谓依定见佛。余九别。一见佛色身。次知佛功德身。次知佛光明身。次见佛毛光益物身。次见佛毛孔现光身。次见佛身业化。次二语业化。一广。一深。末后一总结神力。三我已成下显法名体中。寂灭定乐本智内证也。精进者后智策修也。准下以四禅四勤为其体性。四悉见三世下明业用中三。初释寂灭义。二禅乐义。三精进义。初见佛无著释寂灭义。于中初十句见佛依正主伴无著。二何以下征责释成亦有十句。于中初三妙绝三际。次一回超言表。次二性离虚实。次二体无改变。后二一性无性。此明所见色身等则如此平等是故不着也。二我如是了知下明得禅定业。于中初牒前起后。二正受下正显得定乐。正受初禅明定体。灭意业者明所离。灭意业中欲恶等也。得寂智等是所得乐也。二禅中灭生死觉观不废摄生。三禅中灭烦恼苦故得真乐也。依第四禅增长大菩提心。出生下增成余行。三我如是修习下释精进义。一菩萨依禅化众生故名精进。又化众生令离放逸亦名精进。初化在家令离放逸有十二种想。二化出家离放逸。三又复下叹近善友。令勤断二恶勤修二善。五我唯下结己自分

第五仰推中六。初推普贤行愿。二离障具善。三成佛智境。四处染无染。五摄佛及法。六灭闇照夜。我当下结非己分。离垢地竟

第三明地知识中

初举法劝修内二。初指示后位。后偈颂前文。初中三。先示处者不远者。二三邻次故。如来右面者证理同果。摄生之便故在右也。喜目观察众生者。内证深理。外现慈眼以视众生故立斯号。天竺本名喜目光明照触众生也。二颂前法中十三。初正颂前法。后一颂指示后位。前中初二颂颂前依定见三世佛。次十颂明见舍那佛。于中初三颂明体德圆备。后七颂佛妙用自在。于中初三身业自在。次二语业自在。后二意业自在

第二依教趣入中三。初设礼辞去。二起胜欲乐。三往至后位。就起胜欲中三。初十句自力思念赞知识德。次十句喜目加持转起胜念。三则时了知下明因前胜念得增长法

第三段中略无致敬申请

见彼夜天下则是第四示己法界。于中有四。一体状。二业用。三出因。四结名。初中身安宝座智处法门。谓依法界身现普光幢差别人法。以益众生。令其喜悦为法门之状。二一切毛孔下明业用。于中有三。先现大业用。二明善财睹见。三善财偈赞。初中有三。初毛孔出身云行十度以化众生。二从又于一切毛孔显现下明于毛孔夜天自现所修本行。以任持不失故。三从又一切毛孔出无量身云下明现诸趣身云说夜天本行。初中三。先总。二所谓下别辨十度。三如显现下类通余法。别中十度即为十段可知。就第二现夜天本中。初总。二行檀下别显十度。前六可知。方便愿力中各五句。一标行体。二修行身。三所修行。四行离障。五行本因。智波罗蜜中先举智度分齐。二随顺下显所知法。就第三现诸趣身云说夜天本行中有四。初明所出身云。二明所说本行。三明以种种声说。四明说法利益。初中先总举。二所谓下别显。别中始从阿迦尼吒下至金刚力士有六十类众充满法界可知。二为一切众生下显所说功德有三。初明积劫之行。二得诸三昧下明所得通明。三得诸菩萨下明所得行位。三如是等类下明以声说中三。初总举。二所谓下别辨二十四种音声。三以如是下结说。四彼一一身云下明说法利益中。初严土益。二无量下利生益。有六位渐次益可知。第二善财见闻证入法界于中三。先辨所见闻。二正念下正证法界。三何以下释成证因。有十种所由可知。第三善财偈赞中。先明说偈所因。后正以偈赞。十偈分五。初二叹依胜因现用益。次二叹依法身现化益。次二益物无著。次二叹依定现奇益。后二总结现身说法益。第三叹已白言下明得法因缘。于中二。先兴二问。一问发心时。二问得法久近。答二。初偈颂。后结会。前中有八十九颂半分为二。先有七十七颂半答发心时节。二从功德幢佛下十二颂答得法久近。前中有十复次。初寂静音劫中有五。初八颂显夜天本身。二从日没下十一颂明见最初佛。三从我时下三颂明往到佛所。四从时彼如来下三颂明闻法发心。未曾忘失者明不退也。五从是后下五颂明发心。后于彼劫中所供诸佛略列十佛以显本数。未得惠眼者明在信位中。未得十解正惠眼故。二天胜妙劫中四颂半。未离五欲者。未得正解犹着欲乐。三庄严梵音劫中有五颂半。犹未了真实者。未到十行位中如实而行真实行故。四欢喜德劫中有五颂半。犹未得妙智等者。未得巧便十回向智称法界等无量回向。五寂静惠劫中五颂半。犹未解真法等者。未得地上本智证解真如法。亦未得后得智游刹供佛等。六香灯云劫中有五颂。成八正道者得初地见道故也。七明净坚固劫中有六颂。严净最胜道者明二三四五地中胜道行成。未得六地缘生深顺忍也。八胜王劫中有五颂。于彼正道者在于六地修缘生中道观。九千功德劫中有五颂半。在七地位未得八地无生忍故也。十无著庄严劫中有五颂。明供佛。二功德幢如来下十二颂正明得此法门。初陀罗尼念力等者明九地得四无碍解及持成就领受如来所说法雨。二我得明净眼三昧陀罗尼者明得十地法门。一一见佛者摄报果中见佛也。心净如空者明微细障亦尽也。得佛力者则十地受位堕在佛数也。观察下明大悲摄物德。法云波罗蜜等结位名也。佛子下二颂结成普贤行位。该通一切也。二结会古今中。初法会人。二显己发心益。三乃至下明得法益生。第四我唯下结己自分

第五大段诸大下仰推中二。先别辨十重可知。后我当下结非己分。三地竟

第四焰地善知识中亦五

初举法劝修中。同在证位故云此佛众中。吉祥胜智名为妙德。摄物起行名救护众生

第二依教趣入三。初拜辞。二思念中二。先思前所现法有五句。一总举法门。二分别者剖折其门。三深入者证入尽原。四开发者探其所隐。五显现者露其体状。二随顺下念前所指人。三往至后位

第三见敬申请

第四示己法界。此二合辨。于中有四。初现法加证。二见用礼赞。三显得法因缘。四结已自分。初中三。先示己法门身。二眉光加证。三善财则得法门。离垢者眼瞙尽故。圆满者净智具故。能见法也。二得此三昧下明见用礼赞中四。初见彼大用。二善财设礼。三天服本形。四善财偈赞。初中三。先明用所依处。二正明所现用相。三出用起所因。初处中亦三。一先微尘中见世界显因陀罗网重重之相。二世界中见众生生死流转。三分别尘内世界形类不同。此中世界趣净者众生在染土中修净土行故。趣不净者作不善业向恶道故。又释趣净者是劫增向净故。趣不净者劫减向秽故。净不净者净多秽少。不净净者秽多净少。又释前净中有秽。后秽中有净。二如是等下正明所现用相。于中二。先总显。二为地狱下别辨。则辨中二。一为救苦。二为教化。前中三。初救恶道众生苦。二救欲界天苦。三救人趣中苦有二十种畏。非时受生畏者是不值佛世生也。二又复教化下授之以法。谓四生三界通收一切也。三满足大愿故下十七句释成化所由。谓何因菩萨遍诸尘内。于五趣四生常现其前。拔苦与乐。释云为满足大愿故。一一皆是一所由。准释可知。二尔时下明善财喜敬设礼。三夜天则舍下明现本形。谓隐其实德现夜天形。四善财偈赞中二十颂半。初一总颂。余下别中。初九颂半叹夜天身光利益。二喜目下十颂述前所见。前中四。初三颂半叹身光益物。次二叹香宝光益。次二叹口眼光益。次二叹身普益物。二喜目下述前中四。初二述前指后光加证法。次一述所得三昧。次三述前夜天遍诸尘刹救摄众生。后四颂述前夜天遍尘佛刹敬养如来。第三明得法因缘中二。先问后答。就前问中初总叹深奇。下别问法门有三问。一问法门名字。二问得法久近。三问法门因行。二善男子下答中有二。初叹深难说。二谛听下承力许说。前中二。初下位非分。二何以下征显上境。又初凡小不知。二责不知所以。满普贤下示不知所由。以唯是修普贤行已成满者大菩萨所知境故。非二乘等所知。文中略举八句显难知。明善财亦具此知可得为器。谓以事广故理深故时远故。是此法门根芽深厚之相也。二许说中二。先诫听许说中。谛听者诫听不谬故。承力者显说所依故。二佛子下正说中。先长行后偈颂。前中有三大段。初于离垢圆满劫中供佛修行。二从其后有劫下于大光明劫中供佛修行。三从如是等下总结尘等劫中供佛修行。就初段中有十。一总举本事。二显本生处。三本生。父母。四本生之身。五佛兴利益。六普贤引导。七德女兴供。八闻经得益。九宿因坚固。十结会古今。就本生处中三。初通举世界。二彼世界东际下于彼界中别显一四天下。三彼阎浮下别显一王都。三时彼城中下明其本生。父母。四彼有一女下明本生之身。下明时人起恶是佛兴所因。五时彼城北下明佛兴利益。于中先明道场处。二最初妙德幢下明佛兴摄化。于中有四。一放光警觉放光有十二重。渐次各令表知已后佛兴。佛子彼佛下总结光益。二满七日下动地集众。三一切金刚下赞颂兴供。四时彼三世下明会众说法。于中三。先菩萨众会。二佛转法轮。三令无量下明众得益有二。先明益众。后何以下释能益所由。前中初得人天益。二得二乘益。三立众生于勇猛下明菩萨益。于中有十六句。初十令住十信位。发菩提心者令进入十住位。以彼初是发心位故。菩萨道者是十行位。净波罗蜜者是十回向中令前十度行净也。次令得初地乃至十地可知。大愿殊胜是等觉位中行。普贤愿行者是一乘无障碍普遍五位之行愿也。何以下征释可知。六尔时普贤下明普贤引导。于中四。一身光映夺。二语告佛兴。三时彼众生下大众归心。四时彼圣王下明轮王趣诣。于中三。初升身在空二十偈普告。于中分四。初一总劝往诣。次五叹佛积德出世难值。次三明佛已出大利现前。后一令辨供供佛。三往佛设供。七尔时妙德眼女下明德女兴供。于中三。初解严具奉佛。二变成宝盖。三女见欢喜初者。若随事言。以重佛故解身重服以散佛也。若表行言。以己所修福惠二严回求佛果故奉佛也。二时庄严具下明佛纳受变成宝盖。于中初显盖庄严。如明净楼阁者举下文弥勒楼观为喻。二于其盖中下明盖内所现。于中四。初现卢舍那佛及菩萨众等。二又见一切诸劫下明现余刹余佛。三见普贤业用。四见重重帝网世界种种佛兴异异说法。三时彼女见下明见闻欢喜以增善根成于法器。八尔时妙德幢佛下明闻经得益。于中初举佛所说主伴经。法轮约义。妙音约教。二明所得益。于中三。初得三昧益。先总次别后结。别中略辨十二种。二复得净心下明得净心益。文略列三十四心。三如是等下明得法门初如是等心出生者明法门所依总举。次别显九种。后如是等总结可知。九善男子下明宿因坚固。复于是前者是离垢圆满劫前曾造像已发坚心。十结会古今中三。初正会古今。二善男子我以下结所成益。三恭敬供养下明转修胜行净前法门。第二大段其后有劫下明大光明劫中供佛修行。于中三。先总举。二其最初下别辨九佛各转生供养闻经受持。三佛子如是等下最后佛边所得法益。第三大段佛子如是等世界微尘下总结尘数劫中供佛修行。于中四。初供佛闻法。二于一一下得法摄行。三于念念下见佛行成。四何以下释成行所由。以所说法多故。依法成行亦广也。第二重颂中三十八颂半。初二颂与所得法门诫听许说。余正颂前文。于中初二颂离垢劫中总数。二三十一颂半别显。略列所供一百一十佛。三如是等下三颂结得法劝令速具。四我唯下结己自分。天竺本名现一切世间。前教化众生对见法门

第五仰推中十句。初行广。二悉从等行深。三正身心。四满根海。五具愿门。六具广定。七成胜通。八修多智。九入证原。十结非己可知。炎地竟

第五难胜地知识中

初举法劝修中。同佛证如故在道场。亦与前地同证真如故云去我不远。五地禅增故名寂静音。处宝等明列位主伴

第二时善财下依教趣入

第三头面下礼敬申请

第四尔时夜天告善财下示己法界。于中先叹法器。后正授法。略作七门。一显法名体。二辨法业用。三明所观法境界四善巧方便五得法所由六根深浅七结名归己。初标名体中无量欢喜庄严法门者。一以庄严法化无量众生令欢喜故也。二见佛因果庄严之法生无量欢喜故也。下文具此二故作二释。即以悲智适悦为性。天竺本名起广爱乐心刹那速疾庄严菩萨解脱。二辨业用中先问后答。此中通问四法门。一问法门所作正显业用。二问法门境界明其所观。三问法门方便显其善巧。四问法门因行正显所因。下答中答上四问则为四段。初答所作业用中三。初能净众生心海。二能为众生灭障成德。三总结所作。初中先十心欠一。初一总。谓授以教法令闻熏心海。令息妄念现净心体故也。八心别辨可知。二善男子我为众生下灭障成德中二。初总明拔苦与乐。二若见众生在家下别显灭障成德。于中有三十三种分五。初十四门分十度化十四种众生。初施戒有五门。愿度有二门。谓初不求大果心。后舍化众生心。二为无色者下三门化厌色乐无色众生。三为苦恼者下二门化有苦众生。四为园观者下七门化着处众生。五为贪欲多下七门化惑障众生。三我以如是下总结成前法门名也。此则化众生令庄严德成生欢喜故也。第三复次善男子下答境界问。于中二。先辨观察菩萨境界。后又善男子下明观察如来境界。前中初举所观境释显庄严。后我见下辨无量欢喜。前中有二十四句种种。初自分德中差别德。从种种方便入如来下明胜进入果差别德并可知。就观佛境界二。先有十门观佛境相用。各先见佛果庄严。后生无量欢喜。初三身光严。次二光云严。次二行相严。后三出众严。二起者非起下明所见身光相用等。起则非起明用而常寂故。能喜所喜俱平等无性也。于中先标。二何以故下释不起所由。佛子下结境界。第三佛子此法门者下答法门方便善巧之义。于中有三十二门。初一是总显方便。次八约法说方便。后二十三约喻显方便善巧。后结。以非喻为喻者理实此法非世喻能譬。略举少分喻也。第五善财白下明法门因行。以去前问远故。是故重问发起。答中三。初总标数。二别列行相。以修十波罗蜜行故得此法门。三佛子是为下结行得果。第六善财白言下明法根深浅。先问后答。答中二。先长行后偈颂。前中四。一明知过去普照幢劫中发心修行。二于彼刹下二佛世界尘数劫修行。三最后命终下明于此贤劫中修行得法。四善男子汝所问我下结答所问。初中有三。一明于最初佛边发心得定。二彼道场上下明转生更值余佛得法。略举十生值于十佛得十三昧。三如是次第下总结十刹尘佛及受生得法。上明一劫中所见诸佛。二于彼佛刹下明二刹尘劫中各供佛修行及所经受生。显此法门根无极深远也。三最后命终下明此贤劫中供佛修行。于中三。初值拘楼孙等三佛得定。以此忍土在花藏中举本统末故云生此等也。二今复下明见舍那佛正得此法门体。三得法已深入下得法门用。于中有十。初总举所得善巧之海。二以此下九门别显业用。一见尘中诸佛。二见舍那普遍。三见彼诸佛。一一毛孔下明见化身诸佛充满法界。四观察三世下明同佛入证故。观佛体同故。出生等依证起用差别故。初总持出生门。谓依平等出一切方便此一切中各一出一切。如是重重出生至十一重一一故也。此是无尽无尽法门海也。五得圆满智地下明照过去佛十度行海。六普照如来过去无量下明照过去佛所得地位。七知无量佛下明知过去佛菩萨时二利行海。八普照如来一切智下明持法照佛。九于念念下总结所知。结答中五。一总结答。二如此界下以四佛类贤劫千佛。三如供养贤劫下类十方一切世界。未来一切劫诸佛悉皆供养。四彼离垢界犹在者以是十世中过去现在则现在现在故。又是净土无灾坏故。五汝当等结劝令学。二颂中十偈分五。初一诫听劝学。次二明修因旷远。次二供报恩田。次四救众生苦难。后一显己大愿。四我唯下结己自分

第五仰推中先举所推。谓善知时处。后非己知。难胜地竟

第六现前地知识中

初举法劝修中。道场佛众并同前释。妙德守护诸城者依证智总持智名妙德。常入一切城故云守护。又以观智守护心城令离妄念故名也

第二依教趣入中四。初偈赞中十颂。初一辞已受教来见此希境。二虚妄不知。三妙观无厌。四无著现力。五不动见佛。六惠光照机。七知业现身。八知世佛平等。九离相说法。十修广大行。二设敬辞退。三思念前法。初智慧分别者简择其义。随顺等趣证相应修广身证者正证在身现露相应也。四往诣等至后位也

第三见彼下见敬申请中三。先见胜依正中。一见依报眷属。二见正报身云有十一种身。二善财下设礼敬。三白言下申请

第四时彼夜天告下示已法界。于中二。先叹法器。二我已成下正显已法。于中有四。一标法名体。二显法义用。三辨法根深浅。四结唯自分。初中正证法界名曰甚深。后智蕴辩名为妙德。宣教随机广略无碍名自在音声。二是故佛子下显义用。于中有二。先总后别。初中六。一胜大师化。二调御师化。三明净日化。四平等心化。五我常以法施下正显法施摄生。六我以如是下总结智慧益。二复次佛子下别辨中四。初释甚深义。二释妙德义。三释自在音声义。四总结上三义。初中三。初举数总标。二所谓下别名释义。三佛子我以下总结业用。初总中观察者智照故。随顺者趣向故。摄取者正证故。别中举法界中十种义。约十种行显之。以行必称理理由行显故也。二佛子我如是思惟下释妙德义。初总举。二所谓下别辨十门。总持胜智妙德备具故名圆满。三以如是下总结益生。三复次佛子我或下释自在音声义中。初别显有二十三句。初三句约三慧。辨法。后二十句以十法约广略辨法。二佛子以如是下总结可知。四佛子我深下都结前法。谓入无坏法界者结初甚深义也。悉究竟如来正法者结妙德总持也。以无上法施等者结自在音声也。佛子我已成下结自分法体。念念下结业用。三尔时善财下辨得法久近明法根深浅。于中先问后答。答中二。初明离垢光明劫中供佛修行。二复次佛子下明于佛刹尘数劫中供佛修行。前中三。先于最初佛所得法门。二次有佛下略列所值九十八佛。三佛子于离垢下总结须弥山尘等佛。初中六。一举往时。二时有世界下显往处。三于彼城外下明往佛兴。四时有转轮王下明父王修行。于中三。初王闻法出家。二见恶毁法。三护法令兴。五时有比丘尼下明夜天本身发心得法。六佛子时轮王下结会古今。及得法利益。二次有如来下略列九十八佛。三佛子于离垢下结须弥尘等佛各供佛修护法门。二复有佛刹尘等劫中供佛修行是故佛子下显夜天名可知。四我唯下结自分第五仰推中十句。一了语。二知心。三入语音。四善设语。五分别法。六摄总持。七巧出法。八摄众生。九顺净智。十吼法施。我当下结非己分。现前地竟

花严经探玄记卷第十九华严经探玄记卷第二十(尽法界品)

        魏国西寺沙门法藏述

第七远行地知识内

初举法劝修中三。先指后位次。颂前法。三善财得利益。初中开敷树花者。若约位此地是有行有开发无相住故名也。约事此天在香树楼阁中故立此名。二颂前法者临去殷勤嘱付令修学故。于中十四颂半初二总颂境智法。次十一颂离垢光劫中供佛修行。于中初三总举。次五别颂于初佛边发大心等。次三颂明已后须弥尘等佛边修行得法。后一颂半结转刹尘劫中修行净治此法。三尔时善财下明闻偈得益。于中二。先长行得法有六句。一总举法体。二三昧。三总持。四通明。五辩海。六深法。后五是用。二偈赞夜天。于中十四颂分五。初四颂悲智甚深。次四颂度生广大。次二离障摄德。次三见时众除妄。后一用同佛果

第二依教趣入中。初敬辞。二念法。三往后位可知

第三见敬请中。初见依正主伴。二设敬。三申请并可知

第四答言下示己法界。于中有五。一显法义。二立法名。三明业用。四辨根深。五结自分。初中二。先明安乐众生行。光救夜中众生。谓日没等夜中放光是夜天之义。令免世崄路求一切智道。若于山等救难中众生释光明义。二又善男子下明利益众生行。初化放逸众生令修知足行。次授与十波罗蜜。令破十障释成欢喜行可知。二我已成下立法名。依上三义遂立此名。天竺本名生广喜处知足光明菩萨解脱。三业用中先问后答。以是业用分齐故云境界。答中二。先举佛果力用益生彰己所学。于中先总后别可知。二我入此法门下明知菩萨因行业用显已同成。于中二。先总显。后我知下别辨。别辨中三。初知卢舍那佛本发心时修益生行。二知行菩萨行时修益生行。三通结一切所修行。初中五。先明大悲救物行。于中初见众生苦。二起悲救摄。三结成慈悲。二以知足法下明大智益生行。三成就菩萨下成神通利物行。四以无上净法下严土说法益生行。五分别一切未来下广摄时处修摄生行。二佛子卢舍那下明行菩萨行时益生行中二。先见众生具苦因苦果。谓初显集因。常于生死等是苦果。二发起大悲等明救令出离授乐因果。谓初教修道因。灭不善下令得灭果。三佛子以如是下结中二。初结前初发心时益生。二以如是下结修行菩萨行时益生。并可知。四善财白言下明法根深浅厚薄之义。于中先问后答。答中二。初叹深难辨承力许说。二乃往古下正显承力所说之法。前中亦二。先长行后偈颂。长行中三。初叹境难辨非但久远故难知。亦是当时发心即得深法满佛境故是故难知。此中难者一非闻惠能知。二非思慧能信。三非修慧能入。上心行处灭。四言语路绝。五非二乘智能证得。若尔岂可善财亦不可得知耶。二除佛神力下明有因缘亦可得知。初一句佛力加持为缘。依善知识等明内行高胜为其因方可得知。善财正是其人故云能须佛力方能信等。翻难也。三何以故下责何因要须佛力方能知耶。释以是佛境界故。若尔夜天云何得说。释亦我承佛力说。颂中二十一颂半有五。初一举境甚深颂前难说等。二有四颂明所不知人。颂前非诸天等能知。三有十四颂半颂前除佛神力等。于中初二颂前佛神力及依善知识成善根。次一颂前净正直心。次一颂前哀愍众生等。次六颂六度行及颂前拔烦恼树等。次二颂半颂前灭诸染污得普照等。次二颂得如来乐入佛功德等。四有一颂劝善财学。五有一颂前我当承力说也。二正说发心久近中有二。先长行后偈颂。前中三。初明过去大王起行即是本事。二有童女下明夜天本生同修胜行。三结会古今。初中有五段。一总举时处尘数佛兴。二佛子彼世界海中。有世界性下别举本处明轮王兴化。以是铁轮王故。云彼阎浮提。三彼大劫中下明有恶劫起。于中五浊炽然者总举也。谓劫浊见浊烦恼浊众生浊命浊具如别章。行十恶等造苦因也。死入恶道明受异熟果也命短等明受等流果也。以诸贪着下明增上果。四彼时人民下明苦人于王上诉求救为大悲之境。五时彼大王闻下对境起心成大悲之行。于中三。先心得大悲法。谓百万僧祇等。二口发大悲语。谓十种悲语等为愍众生十种苦故。一地狱苦。二烦恼苦。三老病死苦。四恐怖苦。五见疑苦。六愚痴苦。七悭嫉苦。八生死苦。九生盲苦。十障碍苦。十种对治如文可知。三时彼大王下明身行大悲事。于中五。先宣敕普告。二时城东下设大施会。三尔时阎浮下大众普集。四时王见已下明见乞者现前王大欢喜。是适悦意乐。于中四。一法说校量。二喻。三合。四何以故下释大喜所由。文并可知。五复次佛子时彼大王下正起胜想普施所须。第二时彼会中有一童女下明本生身同修胜行。于中六。初叹女德胜。二作如是念下顺善知识舍物。同愿脱庄严具者示背世间荣华之报。置王前而发愿者悕同出世菩萨大行。三时彼大王告此下王施与女者明菩萨摄受同行故也。四女人说偈赞王德者贺恩报故。五十二颂分二。初二十五颂总显大王兴世利益。后二十七别明本生利益之相。前中四。初六颂明王未兴时损二。次二偈明王兴益。三有十颂显王兴世翻捐成德。四有七颂明大王声教利益。二从王父名净下二十七颂别显本生中五。初四颂明前王世末。二有八颂明王兴先相。三有三颂父王游池。四有五颂明童子出生益。五末后七颂明王出利益。五尔时等明女赞已设礼。六王赞女德以衣授之主伴同益。第三结会古今中。略不结云尔时彼童女者今则我身是。第二重颂中十偈。初二天眼。次一天耳。次一他心。次一宿命。次四广知诸佛因果等事。后一结劝修学。五我唯下结自分可知

第五仰推胜进中五句。初明行广。二大愿满。三摄多德。四行无碍。五法自在下结非已分。远行地竟

第八不动地知识中

举法劝修内。愿勇光明守护众生者以此地中愿波罗蜜增上故云勇也。又准梵本是精进勇猛之义。非是勇出之状。以此愿勇之光饶益众生故云守护。教问八地净佛刹等行也。余同前释

第二依教趣入中二。初辞前。二趣后。略无念法

第三见敬申请中三。先见。二礼。三观。略无申请。以理法于身见已无请。初中二。先见身所在下显身相。于中二。初光明普照等总明身光深广。谓称理法界故遍事法界故。一切日月下别辨二十种身云自在。于中初八是应机摄化身。二诣诸佛所下八是应法成行身。三离炽燃下四是应理平等身。二善财见下礼敬念观。三于善知识下因观得胜心。初总次别后结。别中十心皆先举所得心名。后释心义并可知

第四尔时善财一心下明现证法界。于中四。初证得法体。二显法名义。三辨法根深。四结法本位。初中三。先得共法。二得正直心。三偈赞德。初中三。先观此天。身得尘数等是总举。若约自分是极位菩萨。共所得故名为共法。若约胜进同诸如来。共所得法故云共法。望下皆是不共。衍法师云。菩萨共法通论有四。一人法无二。与一切法界共。二因果无二。与一切诸佛共。三自他无二。与一切菩萨共。四染净无二。与一切众生共。二所谓下别列八十四种。一一中皆初标名后释义。并如文可知。三得如是下结。二尔时善财入如是下明因此共法更得直心无边可知。三颂赞中十偈分二。初三颂前法。余七请后行。前中初一颂所起十心标初心统于后也。次一颂所得共法。后一颂所得正直心。二唯愿下请后行。初三请授法。次三请授行。后一结重恩。第二尔时善财说偈下显法名义。先问后答。此中亦问法根深厚相通有三问。一问名义。二问发心久近。三问几时成佛。答中不答后问故唯二答。初答名义中。先名者身随应化智善开觉令物增善故云长养。二我入此下显义用中四。初释觉悟义。谓了法平等是正证故。二解一切下依证现用。释随应化义于中三。先无边现色是总句。谓摄论等名土自在依止法界。当此地也。二所谓下别有一百种色。检文欠二句。三于念念中现如是等总结。以是起信论中第八地名色自在地此之谓也。三或见或念下随机灭不善法安立善法等。释长养善根义。四佛子我住下结法门业用广大。第三如汝所问下明法根深厚。于中二。一叹深许说。二正说所说。前中三。初牒问许说。二菩萨圆满下叹显甚深。于中约五譬喻以显深义。初一日性无闇喻喻菩萨智无妄能破妄。二日光遍照喻喻菩萨寂而常用义。三虚舟济物喻喻菩萨无住摄生义。四空性无碍喻喻菩萨无功益物义。五化无形质喻喻菩萨用而常寂义。三佛子菩萨智慧下明结承力许说。二乃往下正说所说中二。先长行后偈颂。前中三。先明善光劫中供佛修行。二明日光劫中供佛修行。三结尘数劫中供佛修行。初中有二。初明于最初佛所修行得法。二转生值余佛。初中有十四段。一古佛出世。二昔人造恶。三佛正开导。四王力治罚。五太子悲救。六臣议令死。七请代囚命。八王怒令诛。九母请王审。十太子确救。十一代狱放囚。十二王许修福。十三正设施会。十四佛救太子。于中有八。一国人已集。二佛众云赴。三见佛威光。四敬礼申请。五说法益众。六太子得法。七结会古今。于中有四人。一太子。二恶臣。三狱囚。四大王。八出家得法。第二我于尔时下明转生值余佛略举八佛。通结一万。第二次复有下明日光劫中供佛修行。于中三。先总举数。二别列十佛及转受十生。三我诸趣受身下总结六十亿佛一一得法。第三如一劫下总结尘数劫中供佛修行修此法门。二重颂中三十六偈分九。初一颂承力许说。次六颂古世佛兴昔人造恶。次七颂太子悲救代命。次五颂初佛说法利益得法。次一颂结一万佛。次一颂结尘数劫等。次四颂结会得法。次八颂法门业用。后三颂长时益物下结自分仰推胜进。并可知。不动地竟

第九善惠地知识内

举法劝修。初指处。此园在迦毗罗城东二十余里。是摩耶生太子处。流弥尼者无正翻。义翻云花果等胜妙事具足也。二示人。名妙德圆满林天者谓善妙之德内备。发愿守护此林故以为名也。天竺本云有留弥尼天女。名妙圆光胜爱乐也。三教问中以是生佛处故教问生佛家等

第二依教趣入中亦三。一敬辞。二念法。三至林推觅

第三见坐下明见敬申请中。初见。二敬。三请可知

第四答言下授己法界。于中作五门分别。一显法义。二立法名。三明业用。四辨法根五结自分。初中二。长行与颂。长行中有四。初总标叹德。二列十名。三释十义。四结叹益。初中三。先总叹能行生如来家。二于念念下别显修法成行。三具足下明行成趣果。二列十名者有诸德释将配十地。一一别释。今就通释。一供佛愿。二觉心支者依菩提心出生余行名支也。三观寂灭。四净直心。五智普照。六生佛家。七佛光力。八达佛智。九严法界。十勤至佛。由行此十行令诸菩萨得生佛家故也。三提名别释中。十种即为十段。一一各三。谓标释结。初可知。二中有十种菩提心。皆有标名释义。支者差别义有十种故。又是因义为余行本故。三中有九种心。与前十心何别者。前是行本心。此是现行心故生佛家也。四中亦以十句释成直心。谓正直趣法坚心不动故生佛家也。五中亦以十行释成普照。初六可知。无碍眼者是方便。深入等是愿力。智者等是智度。由十行普照得佛家。六中亦以十句释生如来家。一随佛教生证深法门。二同佛大愿。三行同。四体同。五背向同。六长善同。七住法同。八得佛定。九摄众生。十闻持法。七中以九句释显佛光明力。谓知诸法如幻等故成就如化通明之力。同佛光力遍游十方故也。八中亦十句释分别萨婆若。一总观。二于无量劫下别显分别果智及智所知境等。并分别可知。九中亦有十句释庄严法界。谓严刹土化身严。起行严。摄生严等并准可知。十中亦有十句。释勇猛精进至佛。一总。二一切世界下别显三世佛智所知及示成正觉教化众生故也。四住是法下结成利益。于中先显十种利益行成。后以一切法下随应成佛。结生如来家。二重颂中十颂如其次第。各颂一受生法。文显可知。菩萨具此下结二我成就下明立名。言无量境界自在者明菩萨为物现生故云自在。奇瑞非一名无量境。天竺本云。我成就菩萨解脱名无量劫执持一切菩萨受生自在显现。三善财白言下明法门境界。先问后答。答中有三。初明下生有十瑞应。二明生时有十光明。三明受生有十自在。初中三。先天神自显本愿生此。二菩萨下生所现十瑞相。三此相现时下见瑞知菩萨生。二佛子摩耶夫人出迦毗罗下明生时有十光明。有举数列名总结可知。三摩耶于此毕利叉下明受生。于中有四。一总标。二别显。毕利叉者具云钵刺叉。义翻云高显树也。有处名阿输迦树。此云无忧树也。又阿说他树此云无罗树。谓绕三匝能灭罪障。此是菩提树非是生处树也。又名毕钵罗树。此云樒树。在岭南亦有此类可知。十自在者。一八部云集光照息苦。二腹受三千遍坐百亿。三毛孔现佛过去行法。四毛孔现佛过去本事。五毛孔现佛过去形色。六毛孔现佛往昔本施。七身中出佛本严土事。八身出八部宫殿满林。九身出菩萨赞叹舍那。十金刚地轮生大莲花以承菩萨。三摩耶生时下显相状。于中五。一朗耀挺特如空中日现。二威光赫奕如雷电光。三应机现身如山起云。四现破无明如闇中灯。五虽生不生用常寂故。四我于一念下明夜天结自所知受生分齐。四尔时善财下明法根深厚。先问后答。答中二。先长行后偈颂。前中十。一古世佛兴。二出往佛母。三攀树生佛。四授与乳母。五乳母得定。六得此法门。七结会古今。八广见受生。九知本大愿。十供佛持法。二颂中二十三颂半分四。初一诫听许说。二有八偈半明初佛所发心得法。三我于亿刹下十三偈明更供多佛净修增广。四末后一偈结叹无尽。下结自分及推胜进。并可知。善惠地竟

第十法云地知识内

初举法劝修中。城名如前释。瞿夷者古译名明女。又勘诸梵本或名峤比。此云覆障。谓在家父母所护。不令人见等。或名瞿婆。此云守护大地。佛为太子时有三夫人。瞿夷第一。耶输陀罗第二。摩奴舍第三。又瞿夷是王女宝。今表因位终极慈悲之相显著故取第一也。又以证法既满法喜适悦是妻义也

第二依教趣入中。一敬辞。二念法。三至后

第三见敬申请中三。先方便推求。二见其胜报。三致敬请问。初中四。先天众迎赞。二善财印述。三天众供叹。四升堂推觅。初中二。先迎二白言下赞。此是守堂神赞中四。初赞行究竟。二我观下赞精进得果。三我观下叹精进得法。四何以下释成可知。二善财答言下印述中二。初一句印其所说。二欲令下述自所作。于中四。初于恶众生起大慈行。有法喻合可知。二于修善众生起大喜行。三何以下释成所由。四若有菩萨下结行利益。于中十六句皆有标释可知。天神下总结可知。三善财将升下明天众供叹中。先供散其身。二颂叹其德十偈分四。初三叹利生行。次一求友行。次三无碍行。后三勇猛行。四尔时下升堂推觅可知。二即见下明见胜报。于中一见正报。二见眷属。三显眷属同行德。于中有十句。一本行同。二四摄同。三大悲同。四大慈同。五大智同。六不退同。七行满同。八离障同。九普行同。十成果同。三致敬请问中。皆问悲智等。逆顺无碍行有九句。一在染不污。二得理不证。三得果住因。四出世恒入。五处理现事。六无言现说。七知空摄化。八知寂恒供。九知真行俗

第四尔时瞿夷下示己法界中二。初叹问许说。二正示己法。于中作五门分别。一法义。二法名。三法用。四法根。五法位。初中二。先长行后偈颂。前中亦二。先十法显因陀罗行。有总标别辨及结可知。二勤修十法值善知识。亦有标释结可知。二颂中十三偈。初二颂前依善知识。次九颂余九行。后二结叹行用。二我已下立法名者。谓一切菩萨三昧深广以胜智观察分别。天竺本云成就菩萨解脱。名观一切菩萨三昧海境界。三善财白言下明法用中。先问后答。答中三。初知此娑婆世界中境。二知十方世界中境。三卢舍那下释能知所由。初中四。先知众生善恶耶正。二彼诸劫中下知佛因果。三知二乘眷属。四知彼眷属菩萨下明知菩萨众及其行位。亦是知菩萨三昧海。有诸句可知。二如此娑婆下知十方界。各十十世界者是无尽故也。三卢舍那下明能知所以中。有标征释并可知。四善财白言下显法根中。先问后答。答中有四。一明于初佛修行闻法。二更值六十百千亿那由他佛修行供养。三于最后佛所得此法门。四后于尘数劫中修治此法。初段中长分有十五段。一古世王都。二太子福报。三宝女端严。四太子求娉。五时彼园下明佛兴女梦。六天劝诣佛。七女求天子。十偈分二。初三自述己德堪为行侣。后七偈叹太子德请其纳受。八太子问女说十一偈分二。初四彰己离过。后七劝成胜行。九女母偈答。女有胜德。愿为纳受。有二十四颂分六。初二总说女缘。次六说女生处。次五具胜色声。次四智德过人。次二远离世患。后五具出世行。十太子答母。能不障道我当纳受。于中先长行有九句。一发心积德。二净修度行。三供佛护法。四严净刹土。五利乐众生。六修行具地。七行檀。八出家。九汝莫障我。二偈中七颂半。初一颂初行。次一起颂第六。次一颂第二。次一颂第四。次一颂第五。次半却颂第三。次一颂第十。后一颂第八九可知。十一时女答言下顺命同志幸唯见纳。有十四偈分三。初三求慕心坚。次六悕同胜行。后五说佛劝诣。十二太子闻佛欢喜赠宝。十三女母遂意重叹女德。十偈分四。初三叹德同太子。次三叹身业胜。次一语业胜。后三意业胜。十四时太子下相与诣佛。于中三。初见佛胜相。二致敬供养。三闻经得益。十五还告父王。于中八。初总白佛兴。二问答所闻。三王喜告言。四舍位诣佛。五闻法获益。六出家得法。七太子绍位弘其佛法。八结会古今。于中一会太子。二会父王。三会女母。四会眷属。五会女身。第二彼佛灭后下更值六十百千亿那由他佛。文中略列四十佛名。悉皆敬养。第三其最后佛下明于末后佛所得法因缘。第四我得此法门下更于已后尘数劫中值尘数佛修治此法。于中四。初供养多佛行犹未满。二佛子下闻多佛法未至普贤。三何以下释非普贤所以。四何以故者重责云既未能知普贤所行。何以得知齐佛境界。释以于彼毛孔中念念悉见等故。此则彰己但能见彼所现不能作彼现事。于中三。先见器世间及智正觉世间。二复次下见众生世间。三我于菩萨一一下总结所见。下结自分及推胜进并可知。法云地竟。上来总四十一人明大段第一寄位修行相竟

第二大段摩耶夫人下明会缘入实相知识。谓会前诸位差别之缘。令归平等一实法界。生于佛果如摩耶生佛故次明也。此中有十人分之为二。初一是总。余九是别。以初摩耶得智幻法门末后童子童女亦得幻住法门。以始终相会总别相融无二故也

就初中亦五义同前

初举法劝修中二。初长行指后。次说偈颂前。就长行中。摩耶者此云幻生菩萨。夫人者梵名提婆多。正翻应名天后。古人就义名曰夫人。问余经论说。摩耶生佛七日命终生忉利天。云何此中指迦毗罗城。答化相示灭。实报常存。若尔迦毗岂非化处。释此亦深非常人可见。如菩提树下即莲华藏等。又如双林示灭常在灵山等。又摩耶等诸眷属。若小乘中是实非化。若始教大乘中是化非实。若终教中亦实亦化。谓实是大菩萨示现为化故。若顿教中非实非化。以即相无相故。若圆教中并是法界实德。是人亦是法门故。又是舍那海印定中所现故属佛实德摄也。余并准之。二汝诣彼问下教问可知。二偈颂前法中三十三偈分三。初一总显己行。次十七偈远说前劫事佛因缘。前长行所无。次于后所过劫下十五偈正颂前长行所说因缘。于中先十颂前于诸佛所所得法门。次我于菩萨身下五颂前于菩萨毛孔所见等事。第二依教趣入中六。初辞前。二念后。三引导。四见胜。五致敬。六申请。就念后中三。初总念知识德。二具净法身下别念其身有十九种。三如是等下结成难见起四种念。一云何见。二云何亲近。三云何知其相。四云何闻法受持。三作是念已下明伴善知识方便引导。于中三。初城天教守心城。二妙德天赞德加持。三罗刹王教令起行。初中三。先供养善财。二教守心城有二十四种。一一各初劝所作。后释作所以。初中应守护心城者忍不起妄念也。离生死者由无妄念不起惑造业故云离也。又云应修无坏心城者以信法不坏故。又持法不妄故。又云应放心城普照光明者。以根欲性力智光照达群机故。余并准释可知。三菩萨摩诃萨下释成利益。于中先总标。二何以下释所以。三佛子下结

第二尔时有天下明妙德天赞德加持中。一赞叹摩耶令其欣乐。二放光加持。三善财获益。于中得十种眼。一一各先标眼名。后显眼义。并准释可知

第三时有守护下明罗刹王教令起行。于中三。初教十法得近知识。初总次别后结。别中一直心。二悲心。三智心。四不退心。五坚信心。六深心观性故。七大心普覆故。八广心了法界故。九巧心应病与药故。十常心行不断故。二复次下教十三昧。见善知识者以入三昧知佛菩萨平等法身故。又依三昧得见诸佛菩萨故。又以摩耶是三昧境故。初总次别后结。并可知。三尔时善财答下明教求善知识。先善财领前问后。二答言下正教求处。以摩耶所在遍十方故令礼十方求也

第四尔时善财随顺下明见胜依正。于中先见依报中。古德云。见大莲华从地出者是所诠法界名大莲花。如从心显名地涌出。又释前城天等三位。调炼善财令心至彻。慧眼得开方见摩耶实报境界故。云地涌出等有四。一莲花。二楼观。名摄取法界方藏者。摄取十方各尽法界蕴在其中故云藏也。古德云。五位自分胜进故名千柱也。三师子座。四于金铃中下出音声等九种法门流化。二善财见此下明见正报身有二。初见身故。二见身业用。初中三。初总举。次正见法界身云。后结胜。就正见中有五十七种法界身云分三。初二十种直列身名。二从不去色身下三十种皆先出身名后释身义。三如是色非色下七句简非世间五蕴所摄。三善财见摩耶下结其所现殊胜身云。第二善财见如是等下明身业用。谓此身云能增长众生十波罗蜜行。然不次第。初长其檀行。二出生下明精进行。三知一切下明忍行。四具足下明禅行。五皆悉严净下明方便行。六以明净下明般若行。七净佛道下明戒行。八得净法身下明愿行。九一念充下明力行。十如来智下明智行

第五善财见摩耶下明见已致敬中四。初牒前所见。二变身等彼。三礼已得定。四起已绕住

第六白言下申请中二。先申其本情。二愿为下请其为说。以此门是都会于前诸位法故。是故举初文殊教发。乃至于今至大圣所。总叙始终。欲同会平等故也。第四大段答言下示己法界。于中四。一标名体。二明业用。三辨根原。四结自分。初中大愿者宿愿力。由此生生常为佛母。如悲花经说也。大智者即般若为母也。幻者是愿智所作生佛之义。谓于己身不坏小。而广容于佛身。实无生而现生。天竺本云。我住菩萨解脱名大愿智幻庄严矣。二得此法门下明其业用。于中二。初为舍那佛母。二总为贤劫千佛母。前中长分有十。一得法生佛。二光入我身。三因见八相。四身容十方。五众同入胎。六胎内游行。七又念念下十方同入。八悉皆容下明大小无碍。九于此世界下结通十方。亦不分身者以此处身即是彼身故不须分也。十何以故下释所由。谓摄用归体也。二总为贤劫千佛母中二。先略列二百七十九佛。佛子如是下总结千佛。二亦于十方下明此处。为佛母不废自身。于十方界教化众生。三辨得法根原中。先问后答。答中六。一往时轮王。二临欲成佛魔来恼乱。三轮王降魔菩萨成佛。四愿为其母复供多佛。五结会古今。常为其母。六广显过现为十方佛母。四我唯下结自分。第五推胜进可知。会缘入实相知识中总门竟

第二明幻智念力知识者。自下九位知识皆是旧翻于奠本所欠。应是西域觉贤之所略耳。余共日照三藏。勘天竺诸本及昆仑本并于奠别行本并皆同有此文。是以于大唐永隆年。西京西太原寺三藏法师地婆诃罗。唐云日照。共京十大德道成律师等奉敕译补。沙门复礼亲从笔受

文中亦五。初举法劝修中。初示处内。何故此中上三十三天者。显是摩耶

后所住故。人间诸位会相尽故。二示人内。正念天者显大智自在。入理不忘故。童女者慈悲离染故。天主光者。显净义光明义是天义。最胜义自在义是主义。破闇义照现义是光义。即显悲智胜用以立斯名。三教问可知

第二依教趣入。及第三见敬申请并可知。言诱诲者。依梵本应云善能教诫教授诸菩萨等愿为我说

第四天女答下示己法界。于中四。初标法名体。二显法根深。三明法业用。四结己自分。初得菩萨解脱者以人简法。不同佛解脱。解脱即是法门。名无碍念者随所忆念无不现前。名为无碍。所念分明名为清净。念佛境具德名庄严。以宿命念智为体。二善男子我念过去下明法根深固。于中二。初明所供诸佛有三。初忆青莲劫中。先总明供佛。二又彼下别记八相。念力分明。二又忆下略列九劫中所供诸佛。三善男子下总结恒沙劫中常不离佛。二从彼一切下明所得法门。于中二。先总举所得。二受持下明修治明净。三如是先劫下明业用中。谓以此念力忆前诸劫及佛法。明了现前。无有闇障故以立此名。四我唯下结己自分。第五仰推可知。念力知识竟

第三幻智师范知识中。初举法劝修内。童子师者显教导师范故也。名遍友者。谓遍于一切学类众生悉为师训故以为名。二依教趣入中。先得法利益。二礼足辞退。三见敬申请可知。四答言下应示己法界。为与童子法门同故。是故示彼童子令往问之。又释此童子则是法门以名。无二故。人法无碍故

第四幻智转艺门知识中。初三可知。四时彼童子告下示己法界。于中三。一标名体。二显业用。三结自分。初名善转众艺者。众艺者是所知所解世间技艺则文字等也。善转者是能知巧智善。谓善巧转。谓转变以善巧智转世众艺成出世般若故以为名。以善巧量智为体。二我恒下明业用。于中三。初总举根本。二唱阿字时下别显四十二门。初唱阿字时入般若门名威德等者。梵语威德名阿答摩。是故唱世阿字时便即转入般若威德。以阿声同故。即此得彼以为难故。余门并皆多悉如是准释可知。三善男子下总结多门。言根本字者有二义。一以此等字并是世字之中根本字故。依此以入般若门故云为首。理实无量。二以此等字为所依根本。仗之以显般若法门。三我唯下结自分。第五如诸菩萨下仰推胜进中二。初总标通达世及出世二位章门。二别释二门。先明世法有十门。一知文字。前约此方。此通殊方故。是所推也。二知医疗。三别珍宝。四相住处。五观天地。六能相人。七解畜音。八别云霞。九知丰德。十识安危。如是下总结世法。皆是于此而显般若。非但文字知是推也。上来诸位善财所求。于此世法并皆舍弃。令此悉成般若法门为甚难故。是故示之。二又能下释出世法。初总与所知之法。谓释名出体。言随顺修行者明说法之意。二智入下明能知深证故无过失也。我当下总结非分

第五幻智无依门知识中

初举法劝修内。婆咀那者此云圆。谓具德圆备。出生无尽故以为名。又以调柔至顺超过余位故名贤胜

二三可知

第四答言下示己法界。于中亦三。一标名体。二显业用。三结自分。初中法门依梵名那阿赖耶蔓茶罗。那云无也不也。阿赖耶云依处也依止也。蔓茶罗云道场也圆场。谓无阿赖耶染分依处而有净分圆满道场。出生胜德不可穷尽。即转依究竟显德无尽也。二业用中。初一句标业用意为利众生故云既自等也。二得无尽三昧等总举。三以能下别显十种无尽。初六六根。后四胜德。一明。二通。三德。四光。三结自分。五推胜进并可知

第六幻智无著门知识内。初举法劝修中。城名沃田者。是南天竺近水下湿田稼甚茂故以为名。与下海涧国同。亦名贤陂城。又于所得解脱坚固安住故云坚固解脱。又一得永脱故云坚固。又所得菩萨真实解脱更无所求故以为名。四示己法界中三。一标名。正念现前离所知障故云无著。离烦恼障故云清净。谓顺理之念不杂二障故以名焉。二我自下明法具德备足无求。既是因人何得乃尔。释设更所解不异于此。但须修行故。无复求下结自推胜并可知

第七幻智光明门知识内。初中妙月者悲德清凉故以为名。上文云菩萨清凉月游于毕竟空。此之谓也。宅有光明是法门之用。四示己法界中标名。内证离障为净智。后智摄物故曰光明。又光明者对治无明故。净者治惑染故。余文可知

第八幻智无尽门知识内。初中城名出生者。城中出生人物故。长者无胜军者行德超过名为无胜。当体具德从喻如军

下示己法界中三。初标名。无尽相者所成德相无尽穷故。二我以下明业用可知。三结自分及推胜进并可知

第九幻智诚语门知识内。初中聚落名法者。在此弘法故。表此即法故。尸毗最胜者梵本具言名达磨湿毗阿羯。达磨云法。湿毗云空营。谓如军众去后空营之所也。阿羯云最上。应云最上法空营。营则是聚落处也。从处以立人名

下示己法界中三。初标名。诚愿语者此有二义。一从初发心立弘誓言。后必如言而行。不乖先言故名也。二菩萨行行时如施眼时有问悔不答言不悔。此言谁信。则立誓言。若实不虚令眼平复。如言则善故云诚愿语也。二过去下明业用中释上二义。先释初义。二我以住于下释后义。以能成满行故。下结自分推胜进可知

第十幻智归幻门知识内。初中城名妙意花者梵名苏满那也。以彼城门之侧有此花故立以为名。此亦在南天竺。童子童女表智悲相资。智则依德而起。悲则蕴德以成。旧本名妙德。当此德生也。妙德惠当此有德也。以本语名室利末此云有德。室利末底此云德惠。以声字相近故。二译不同也

下示己法界中三。初标名。幻住亦二义。一明所知诸法依缘虚立名为幻住。二能知之智住幻境中。此则住幻故云幻住。二以斯下明业用中二。初略知十种幻住。一一皆先标名后释。初六知世间法幻住。一总知。次二知人法幻。次二知三界生灭幻。次一知国土幻。后三知三乘幻。初一二乘。次一菩萨后一菩萨所作。下结幻境。自性不思者则有则空无二故不思议。又以自性亡二边亦不住于中故云不思议也。下结推可知。下利益善财亦可见。上来十人总明第二大段会缘入实相知识竟

大段第三。弥勒位是摄德成因相知识者。前既会缘入实。定堪成佛故。辨一生补处成因之义。五分同前

初举法劝修中亦三。初指处。二示人。三教问。初指处中此是南天竺近海岸故名海涧国。天竺本名海岸门国。园林具德名大庄严。林中有楼观显耀名明净藏。梵本毗卢遮那庄严藏。次菩萨往昔下出楼观因。二彼园林下示正报。弥勒者梵语具言名迷帝隶。此云慈。是其姓也。以姓为名。名曰慈氏。然有三缘。一由本愿。谓过去值大慈佛。因则发愿。愿我成佛亦得斯名。二由三昧名。下云见弥勒。初得慈心三昧。因以为名。三就相立名。母怀时有慈心。相师占曰由所怀子慈令母慈也。如母怀鹙子能论义等。又名阿逸多。此云无胜。以生具相好更无过者故云无胜。下叹其所作中四句。初化亲眷属。二化余人。三为善财。四通为一切。三汝诣下劝往教问中三。初教起十问。二何以下释广问所以。于中二。初明所求弥勒德广。二善男子下劝彼能求。亦起广心。前中二。初通显弥勒德成位满。二别辨弥勒是汝真友。以设若德满非己有缘亦不可求也。二劝善财广心中。初略举十事中不应足想。二何以故下释所以。既不于一善根生足。未知作几许耶。释云无量等也。文中总有八十句无量分七。初二十句明救生断障行。二净修无量下十句成己心志根欲行。三发起无量大精进下九句明力用自在行。四悉分别下十句明摄法治惑行。五诣佛刹下十句明供佛摄生行。六不惜寿命下十句明求法摄生行。七摄持下十句摄成菩萨深愿行。三略说下九句一切结显无尽。三是故善男子下正劝求善知识。于中七。初总劝敬求。二何以故下明行因善友。三何以故下释友能成行。四复次下显善友要胜。五又善男子下教起胜心。六何以故下释胜想所由。七善男子略说下明顺友成益。初中由前劝起广心。是故劝敬求善友也。第二何以故者但起广心。何须敬求善友。释以因善友广行方成。于中四十句行。初十句明愿行坚心行。二一切菩萨总持下十句明备具胜德行。三出生一切下十句明摄法益生行。四远离恶道下十句明殊胜超过行。第三何以故者何以此行皆因善友成耶。释以善知识能令行人除障起行故。于中三。初能灭障碍。二示导下能成行位。三灭一切下能令得果。第四复次下显善友要胜。于中十句约喻显德。皆有标释可知。二是故下结劝。第五又善男子下教起胜心。于中三。初二十二句教于善友起此胜心。皆有标释。明心下下堪见善友堪为法器。二又善男子应于下明于三处顺于法想。于中初有十句。一一皆有三想可知。三善男子诣善知下结劝。第六何以故下释胜想所因中先征。但求善友则得成行。何须起此心想。释因净此直心方堪见善知识。顺教增善故也。于中十句。一一皆法喻双举。第七善男子略说下明顺友成益。于中三。初得十重十不可说愿行。二略说下九句一切结因善友满。三如是等下八句明依善友起行之义可知

第二善财闻如是下明依教趣入中。略无敬辞念法。至后可知

第三以过去际下明见敬申请。于中三。先见。二礼。三请。初见中二。先见依报后见正报。前中三。初起胜念。二礼观察。三绕念赞。初中亦三。先念胜愿行。二作是念下明信智转增。三善财如是下结观胜境。二五体等明身礼智观。观中四。初于法界楼观起三宝福田想。二作是念下明等观楼观照三无性法界。初观圆成性。次等观如如来除妄等明观遍计性。后等观如影等明观依他性。三深心信下明观成得益。于中二。先总信解。谓观见无性平等理而不失缘起业果故云信解也。此中有七句。皆空无性而因此起彼。二解了回向下别辨解益中五。初解回向法。二舍离下明离倒执。初从自在而生者是外道执梵天自在天等生诸法也。本有实性次第生者有二释。一是外道冥谛之中本有其性后次第出也。二是小乘一切有部未来藏中。先有体性次第待缘而生也。三离我我所下明大乘正缘起法。四见有为下明见空有无碍法。五悉知下明见法称实。多喻证成。四善财礼未起下结益分齐。三稽首毕下明身绕念赞念赞。于中有三。初身业绕旋。二意业念观。三语业偈赞。就第二念有八十句。一一皆举能住者德叹所住处楼观。以初二句具显余并略之。于中分十。初约境显胜。二住甚深下约德显妙。三以一劫下约用显自在。四普照下约行显胜。五可尊重下约对治显胜。六住四禅下约定自在。七一切烦恼下约利他行。八得九次第下约护小乘行。九观阴下明染净无二行。十如是下结德住处。三语业偈赞中有五十五偈分七。初二偈总显弥勒德胜。二有八偈叹自行胜。三有九偈叹利他胜。四有八偈叹功德胜。五有九偈叹方便胜。六有十一偈叹三昧胜。七后八偈叹愿行胜。二见正报中三。初欲见。二遥见。三叹德。言从外来者摄化就机故。还来归本故。威德下叹德中。初挺特普照。二超世魔染。三深入下德齐因果。四住大智下叹受位灌顶。二致敬。三请问并可知

第四尔时弥勒下授己法界。于中二。初叹善财法器利益。二正令入己法界。前中有六。初为己眷属叹善财德令人仿习。二正为善财叹德令喜。三劝归文殊弥勒摄受。四善财自庆重请弥勒。五弥勒以偈重叹善财。六具叹无尽大菩提心。就初段中文有八。初指示大众。二叹善财精进德。频陀伽罗是犹觉城也。百十者。古师有三释。一云上来至此应有一百一十。但文中脱漏故不具列也。一云上来所列是正善知识。若通取主伴方便导引等则百一十也。是故上文未欠。满足王及大光王等。前皆云渐经人众聚落城邑旷野等。故知通取所经处有一百一十也。一云信等五位则为五十。后摩耶弥勒文殊普贤及佛为五此五十五。各有自分胜进故有一百一十也。此等并为旧经不足有此诸释。今既文具。不劳异释。此是总括前后知识有五十四位。分德生童子及有德童女则为五十五人。各有自分胜进故有百一十也。三如是童子下叹善财直学大乘德。文中有十句。文可知。四如是之人下叹行胜希有德。于中二。先标。二何以下释成。释成中三。初总释。二度无智海下别释。于中化二十一种众生。三救护下总结释可知。五诸善男子下叹善财菩提心希有德。六诸善男子若有菩萨下叹善财堪为胜轨德。七此童子者入威仪下叹善财如海深广行。八显现一切下明一切处遍修行。第二善财汝今得下正为善财叹德令喜。于中四。初叹善财本见文殊益。于中先总。二所谓下别远离恶导等入十信益。过童蒙地者入十住益。住功德地者入十行十回向益。具智惠地者十地益。下明入胜进佛智益。二若能如是下叹善财见功德云等已后诸善知识益。于中初总辨见胜人益。二随彼下别显闻妙法益。三善财汝应发大下叹善财超劫速成行。于中初总举得果速。次别显修因速。谓进行超群也。余菩萨约随位差别说。一生皆具者约普门该摄说。又此一生亦摄多劫。如上仙人执手成多劫行等。又此普贤法虽圆融相摄一位则一切故一生皆得。然亦要由直心精进方得速成。直心者心中不杂异念故。趣入猛盛故。精进者称心而作故。后其有下叹成利益。四善财当知下叹普行希逢德亦二。初叹行希成。谓过去佛往修行时。无有于一生身得逢尔许善知识者。是故汝今极为希有。二其有众生下亦叹利益。第三尔时弥勒下劝归文殊。弥勒摄受于中五。初劝往文殊。二善财悲泣以念深恩故。三文殊授璎。四善财奉散明以智导令成福行故也。五弥勒摩顶明加持摄受之义也。第四尔时善财下明善财自庆重请中。先说偈自庆。后设敬重请。于中三。初总敬请。二大圣下叹德请。于中初叹行位成满。次为烦恼下叹摄生济物德。三唯愿下结请。第五弥勒以偈重叹德中有六十八颂分六。初一总叹专求。次有十偈别叹善来。次有八偈叹其来意。次有十偈明行位成立。次有二十二偈叹利他兼自行。下有十七偈只结自他行。第六尔时弥勒下广叹菩提心无尽德。中有四。初结前生后。总叹发心。二汝得善利下叹得十种善利。三何以故下广显发心功德有二百一十八句。初一百一十五句明菩提心殊胜功德高齐佛果。二譬如有人得自在药下一百三句明菩提心自在功德广多无量。前中依光统师。分配十二住科为十二段。今谓此中一一各显菩提心中。一种胜德皆通始终。此亦不可别配诸位。一一皆约世喻显德准释可知。天德瓶者于中所索悉皆得故如如意珠也。恒娑者此云鹅毛。以此为衣水浇不着。喻菩提心尘垢不染。七使者贪等五钝使。复取身边二见故为七也。波罗提毗叉药者此云灯照药。毗楼那风者应是毗岚风。此云旋猛风也。次佛子菩提心者如是下结其功德等。于因果下释以菩萨诸位功德及佛果功德并皆从此心中所出生故。是故此心等彼所出。第二善男子譬如有人得自在药下明菩提心功德广多无量。于中一百三句。亦有诸德配十地分之。今亦通辨。一一各显一德。皆先喻后合。准释可知。以此说者听者俱是大人皆广见故。是故所举譬喻多非人间所有。频伽陀药者具正云毗笈摩。此云除去。谓能除去毒恶刹故。删陀那大药王树者此云续断药。谓此树药能令所伤骨肉等皆得后续故云也。药草名阿蓝婆者具云阿罗底蓝婆。此云得喜药。谓得涂身令身患心恶皆止生悦故以为名。忧陀伽婆罗栴檀者具云地毗乌罗伽娑罗也。地毗此云妙。乌罗伽此云腹行。即龙蛇之类。娑罗此云胜。亦云坚固。谓此栴檀坚固胜生在龙宫故以为名。波利质多树正云波唎耶咀罗拘毗陀罗此云香遍树。谓此树枝华实一切皆香故立此名。又此树香气于忉利天处一切普熏故名香遍。那利罗树者具云奈唎罗吉唎。此云茎等有用树。奈唎此云茎也罗是多声。谓茎等枝叶花果也。吉唎此云能作。谓此树茎等悉有用益众生故。此树出海中。其形甚高。似多罗树。其果甚美。于中有汁。似椰子树。阿罗娑药者具云呵吒迦阿罗娑。此云金光汁药。呵吒迦云金光明。阿罗娑云汁药。出于山中井内。诸龙守护。若有得饮皆成仙人。迦毗伽鸟者具云迦罗频伽。此云美音言鸟。谓迦罗云美音。频伽云语言。谓雪山中一切鸟声皆悉不及。又在卵中则能出声。阿夜健多铁者具云阿夜塞建那。谓阿夜此云铁。塞建那此云胜伏。谓此铁能伏碎余铁故名胜伏铁。摩伽罗鱼者此云极大之鱼。谓是巨鳖鱼也。四善男子下结前功德广多无量。初通举。后别结。善财何故在此广叹菩提心者。以是位终极故。功成德立。由本大心故须叹也

第二大段善男子汝先所问下正授己法界。于中有四。一授法体。二显法名。三辨来处。四明生处。初中五。先明摄入方便。于中二句。所牒问劝入令其趣证。二请其开门为求证方便。二弥勒弹指下加令入证。谓若就因力即是善财修无间道断除妄想。所证理现名曰门开。解脱道中正证法界名为即入。若就缘力即是弥勒加持。今约缘力说也。证已反顾本来性满非新得故。更无入处之门故云还闭。又以一证永得无有退失。更无复出故云还闭。三尔时善财观察下明证所见境。于中五。一见依报。二见正报。三见诸佛。四闻法音。五见出生。初见依报净土。中先见后益。见中此是弥勒实报所成楼观。次于内具百千楼观者明一土则一切土主伴具足也。二尔时善财睹见下明得益。于中先心喜障除益。后身遍楼观益。二又见无量下明见正报因果。于中有六。初总举本缘。初发心时。二或见初得慈心下明发心已后修行得记时。三或见为轮王下见本生随类生身有十三种。四或为四天王眷属下明见本生说法益物有十种。五或见满足下明本行成满德。六或见正受下明见业用自在德。于中先毛孔出身云。后复见下明毛孔出法门。三或于楼观见诸如来下明见诸佛摄化之德。于中三。先总通见。后尔时善财诸楼观中下别见八相成道摄生之相。以自在力无障碍故一中见也。三善财自见下结所见利益。四又闻下明闻法音。于中二。先闻五种法音声。一总辨所闻行法音。谓金铃中声及余严具亦闻此音。二闻初发心声。三闻成正觉声。四闻财法二施声。五闻成佛摄生声。二闻如是等下结闻声益得十种行门可知。五见宝镜中下明见出生。于中有六。初见宝镜中三世间。初见智正觉。次净世界下器世间。次又见下见众生世间。二又见宝柱中放光网。三见珠璎珞琉璃出水及光。四见花中人物。五见宝树中凡圣。六见半月像中行用。于中有十四种。一放光。二见弥勒本行施行。余十二种现身化导可知。又释通前总有七种法门。一铃现音声法门。二镜现形相法门三柱现住持法门。四璎现庄严法门。五花现开敷法门。六树现建立法门。七半月现住位起行法门。四弥勒告下问答辨定中三。先问。次唯然答。三譬辨定其见。于中有十喻显示。一梦见山海喻喻善财超妄见胜境。二临终业现喻喻难思境冥现。三非人所持喻喻加持见胜法。四龙宫奄久喻喻长劫谓须臾。五宝藏广现喻喻一中现多事。六遍处定境喻喻胜境随心现。七干城无碍喻喻所见无碍法。八升天见人喻喻见法得自在。九海现三千喻喻所见明了德。十幻现无碍喻喻威力现奇德。五尔时弥勒下摄威令起。于中三。初摄威警起。二先问所见。三称实而答并可知。授法体竟。第二显法名中。先问后答。以摄前后际故云入三世智。此即九世中三现在也。正念思惟者显能见之智明了无倒。庄严藏者明所见之境具德含藏。即楼观中摄一切劫一切刹各具胜德。皆有出生故立此名。又以此人位极不言我唯知此又是法行成满故云得如是等不可说法。第三大圣下辨来处。于中二。先明依报。初问后答。问意云。此小楼观内有尔许奇特事为是从外入来为不尔耶。答中有二喻。先明神力出生无从喻。二智愿所现无本喻。二善财白言下显正报。于中二。先问后答。问意前见弥勒从外来不知来处故问也。答中有三。初就实无趣。二从行说有。三随事辨来。又释初约法身。次就报身。后约化身。又初体。次德。后用。就初中有十句无趣。趣者是处义。谓无从来处亦无所至处。又趣是趣向义。亦无来去发趣故。二善男子下从行说有中。明法身随缘从行说趣同。净名云。吾从道场来。相似有七句。一悲。二戒。三愿。四通。五体。六用。七化可知。三汝所问下随事说来中。以海涧楼观是修道处摩离国是本生处。暂住生处。化人故从彼还此也。摩离者具云摩罗底数也。摩罗此云鬘。底数此云中。谓鬘中国此近摩罗耶山故名相同也。瞿波罗此云守护地。第四明生处中二。先问后答。问意前既云前生处来。未知何者是菩萨生处。答中二。初明依法家生行德处。二依事家生化身处。前中有五。一显所生处。二生缘眷属。三校量显胜。四所知自在。五体用广大。初中十种俱是生起行处故。一行因。二行缘。三行相。四愿扶。五化他。六观理。七随事。八益物。九无住。十顺古。二善男子下明生缘眷属中二十句。初七明生育。次四为长益。余九为成立同太子可知。三如是菩萨超凡下明校量显胜有十句。初一句超凡证性是总。生如来家下别九句可知。四摩诃萨生如是家下明所知自在。于中七句。一知趣空现受生。二了趣如化在有不着。三达无我化众生。四了生死能长时。五知阴幻。六了一切法。七得法身离染。五善男子我净法身下明业用广大有十句。初一法身充法界。余九德身满法界。二若诸同行下明依事家生化身处。于中有三。初生人中。拘提聚落者具云拘吒迦罗。此云楼观。即次前文名楼观聚落也。为三类众生。一为同行。二为灭慢。三为父母等。二生兜率为四种众生。一为化彼天。二集一生说法。三化宿世同行。四开佛所化。谓释迦遗法所化众生根未熟故如花未开。又利益未得亦如花合。待弥勒佛令其开发故也。三下生成佛汝及文殊俱见我者释有三义。一云我当来成佛时亦说此花严。彼时亦有文殊善财所说之法故云也。二云我成佛时汝与文殊俱来。助我宣扬法化。三为表法。谓善财何故上于佛会但求诸善知识而不求佛者。以善财此生是修因之身未成果故不至佛所。非谓不求。但成果隔因故说当见佛。以是满位故无仰推等也。上来摄德成因相知识竟

第四智照无二相知识者。显前因法生果体无分别绝境智等诸二相故

初举法劝修中。初劝往教问。以位极故教问。具足普贤行也。二彼当下叹德劝往。于中有二。初通显胜德。先征责后十句释成。一能满他行。二为佛母。三菩萨师。四勤化生。五大名闻。六大法师。七佛所赞。八住深智。九多劫修。十满普行。二善男子下别叹其是善财本缘。于中三。初明善财所成功德皆文殊力。二是故下结劝令往。三何以故下释显所由。是故上来所见所成皆是文殊也

二时善财下明依教趣入。于中三。初设敬辞退二尔时下造诣其处。今从弥勒却向文殊还行百一十城。故知从初至弥勒定经百十故也。至普门者摄别归普故。谓摄前诸差别位归此文殊普门故也。三观察下起念推求。此中汉本经欠十七行文。今勘梵本并翻补讫

三作是念时下明正证法界以表智照无二平等义故。无见敬申请等也。于中初申手摩顶。言过一百一十由旬者彻过如前差别之位至此平等普门之所。摩善财顶者示以普法灌其顶也。二而作是言下明语示教悔。于中二。先举所作行阙。后显不能入理。则显善财无此失故能得斯法。前中十句。一无信根者以阙行本故。二心没忧海者行心不发故。三功行不具者不修加行故。四已起精进并退失故。五不期多行故。六于一住着故。七不善发起菩萨行愿者此中二句。一不发愿。二不起行。九善友不护。十如来不念。二是等下明不能入理有十二句。初四举所知理法。二若周遍下显不能知分齐。三是文殊下明所成益。于中二。初赞慰令喜。二令得下明得法。于中初令得广多差别法有七句可知。二复令得入下令得普贤广大法。四既置下明摄用归本。以普贤道场是文殊自所住处。还安善财置于此处。同己所得。所作既毕。是以不现也。五于是善财下明成德究竟。于中初广见胜友。皆能顺教明其行缘。行缘既多。明成德非少。增长下显所成德有十句。一成悲智德。二寂用德。三深广德。四正勤德。五证教德。六行愿德。七照境德。八破障德。九成位德。十修普德也。智照无二相知识竟(又亦上来总是文殊当般若门竟自下普贤当法界门故也)

第五显因广大相知识以前照理无二显其甚深方堪成佛广大之因故。于中三。初举法劝修。二依教趣入。三正证法界

初中闻普贤名等者是何处闻。谓前文殊言声说故。又亦是前文殊所置善财于普贤道场。是故于彼闻此名等。于中初总显普贤德位。二地具下别辨普贤地位有十句。一地具者助道法等。又释信等行为成地法。二地法者诸地所行法如初地十愿二地戒法等。三地得者诸地所得果。谓调柔等。四地次第者诸地连接等。五地修者诸地中不住道仰修上地等。又是摄论中五修等。六地住处者功德住处故。又证智相应故。七地境界者二谛为境故。又遍行真如等为所证境故。八地持者任持所余诸功德故。又瑜伽三持中是圆满持故。九地共者三种同相智。诸地同行故。十地正道者根本后得二智为体故

二尔时善财下依教趣入中四。初起胜心。二见瑞应。三见光相。四结所见。初中起十种心者此十心之境并是普贤境界。是故起心还称彼境。方可得见普贤故也。二见十瑞应中先明得见所因有自他二力也。十瑞相者谓见普贤依报也。于中摄为五对中。先明土净。后住处众生净并可知。三见十光相者谓见普贤正报相。又前但直见。此中重见。又前粗相见。此中微细见。又前但见其体。此中见业用。于此十中初二但放光明。次四放光粗供具。后四人物利益可知。四结前所见必见普贤

三尔时善财下明正证法界。于中有八。一见身得益。二摩顶得益。三因深果厚。四举益劝观。五观见奇特益。六校量所得。七结齐佛果。八偈颂因果

初中二。先明所见法身。后明见已得益。前中有四。一总见普贤。二别观毛孔。三重观支节。四结遍十方。初中依前十心所念称境而见。初依前第一心见在道场如来前者表普贤齐佛果故。因果位同故。二心如虚空者依第二心见。三无染著者依第三心见。四除障净刹者依第四心见。五以无碍法者同前心。六充满十方亦同。七住一切智者是第七得萨婆若境心。八入诸法界者是深入法海心。九教化众生者是教化成就众生广心。十于一切劫下明前末后具因果心。亦摄前庄严道场心。二明见毛孔业用者前亦初总见净土。后见尘中业用今亦先总见正报。后见毛孔作用。于中二。十种分五。初一光救法界众生。次五出法界供具供养诸佛。次四出法界身云利益众生。次三出法界土调伏众生。后六出法界菩萨诸佛云。三重观支节等中。初见一三千界。次十方下通现十方世界风轮等。皆悉现显。四如此娑婆下结通十方中有四重普遍。初举舍那结贤首。二举贤首结东方三举东方结十方。四举十方结微尘。是故当知。前即身中苞容法界。广无边故显其普义。今即明此含法界身潜入微尘调柔无碍。明其贤义。是即内外周遍限量斯尽故名也。二尔时下明善财得益中。初总举因见所得。以究竟位中智故云不可坏也。下别显十智中。初四身遍见闻。后六智内充实。初五是佛智。后一是普贤智并可知

第二摩顶得定中二。初明此处一世界中摩益。先摩顶。次得定中三。初举定。二摄眷属。三明定用成益。有八句所益可知。二如此下结通十方世界佛所摩益同之。以善财等普贤故周遍十方也

第三尔时普贤下明因深果厚中三。先问答审见。二明因深远。三明结因成果。就因中初明所修之行有四句。初总明多劫修。二明修起大心。三在家修施行。四出家修道行。二善男子下结十句行。明说不可尽可知。三善男子我得下结因成果。于中先结因有成果之功故云力。有十句可知。二得是力下所成果德。于中初由了因得法身果。后由生因得色身果

第四汝且观我下明举益劝观。于中二。初总明难闻见。二别成不退益。于中五句。一闻名益。二见等益有七种相可知。三思念益。先约时后约生。四以如是下总结益用。五明转生益二句。一闻修因生净土。二见闻身生法身

第五汝复观我下明观见奇特。于中二。初身分之内见三种世间。并各无边。二又见下明见从身所出佛果业用

第六尔时善财迳由下明校量所得。于中二。初正校量显多。二何以故下释显多义。于中六句。一所入多。二所得多。三所知多。四所度多。五所修多。六不此没等明平等普遍同普贤境

第七尔时善财能自下明位满齐佛。于中有十六句。初一句总显因圆。二不久下总明等果。三一身充满明得普贤身。下有十三种等于诸佛。此是因位圆满更无所修。是故但云与诸佛等。不辨更求知识修因。普贤位竟

第八偈颂中有九十九偈半。问既云重颂未知颂何处文。答有人释。此是颂前善财当得十三种所等佛境。即科此文亦为十三段次第配释。此释不便。前善财所得是结集者说。非是普贤说。何因乃为重颂。又有释云此颂前普贤说自往因所事诸佛等。此亦难用。以偈文中总无此意。今释前长行中唯明因行。未说果用。今明重颂说果非因。文绮互显故也。又释今颂举果显因。是显发释故也。何故唯显佛德者为善财因行穷满不为可说因门。是故说佛果业用。又为普贤对佛前坐承力摄化其用究竟。推功在佛。偈中分六。初有五偈。诫听许说。略叹佛德。二时诸菩萨下三偈明众领劝叹说听受。三诸佛微妙下二十偈半通叹十方报佛胜德。于中五。初三明大智无著照机德。次四叹形言随感隐显德。次七叹主伴严土自在德。次五半叹遍转法轮微细德。后一总结十方诸佛德。四或见释迦下别叹释迦化身功德。于中四。初二十半叹佛意业作用。二安住下十九叹佛语业作用。三具足智功德下十五叹佛身业作用。四譬如工幻师下八偈半喻显无碍。就初意业作用中有五。初五明六度行智用。次三天身八相用。次二常在恒灭用。次四巧化随机用。次六半用身光寿刹用。第二语业中四。初五明转三乘法轮。并业用无生等是大乘法也。次五明六度觉品对治法。则释前三乘唯一圆音也。次五明五乘总别乃至多乘。次四明平等语业而应一切。第三具足下十五偈明身业作用中五。初三示凡身。次二现声闻身。次三现外道身。次三现示大力身。后四现诸天身及结。第四譬如下八偈半喻显三业中。初五偈明喻身业。一幻师喻二月现四德喻。一体圆净。二示增减。三应净心。四映二乘。三海现二能喻。一出宝。二现影。次一喻前意业。谓智日灭闇喻。后二半喻语业。谓法雨无从喻。化身竟。第五如来净法身下六偈叹法身德。于中四。初二明法身相。先法说后喻况。前中摄论法身具五种故。此中同彼。谓初句是白净法身为相。以是果圆满转故。二次二句是不思议相。谓于世间无物比故。三非有无者是无二为相。以非有为无为故。四次一句是无依为相。谓无所依故。五次一句是常。住为相。以无来去常住故。次二句举梦见及空画为喻。二有一偈明法身离相。亦先法说三句。一约用。二约德。三约体下一句喻显如空也。三有二偈明法身用无积聚。初一举二喻。谓摩尼出宝喻。二光明无体喻。谓诸天菩萨等皆名众生。悉有光明故云众生诸光明也。辨此等光各无停积处。同摩尼所出宝。亦无本相似。下一偈合法可知。四大仙下一偈圆法身。即相常寂。于中大仙现者明佛出现。于世虚空下举七喻以显。一空。二如。三自性。四实际。五涅槃。六离欲。七寂灭。谓佛现世则同此七义。是故即寂以显法身也。第六末后二颂即结说劝持。先举四喻可知。以显佛德深广。一心虑无限喻。二微尘难量喻。三海滴难知喻。四虚空无际喻。此下一举益劝信。谓信此普贤自在法者。究竟要当终齐佛果如善财与诸佛等等也。上来于下本十万偈花严内释前分三万六千偈竟

花严经探玄记卷第二十


华严经文义纲目

    No. 1734 [cf. No. 278]

    华严经文义纲目刊行序

按凝然师述法界义镜曰。天平八年大唐道璇律师赍此宗疏章而来。又审祥大德者新罗国人也。尝入唐谒贤首受学华严宗。而来此国住大安寺。应良辨等请讲华严经。然则初传章疏璇师有功。最初开讲祥公为尊也。此章之传虽未见实据。璇祥两师之间焉。又我弘法大师释华严教往往取则是章。疑璇公等将来之本故大师亦有所受欤。且请来录不载此章。则受学于本邦者居然可见矣。且余诸师亦能绎此章以综文义之纲目。况本宗古德等据此论理翼成教观辨驳通议以作一家之学。好古之徒岂可不研核耶。虽然本邦中世以来贤首宗教沈贝叶而振者鲜矣。其疏章亦寝散失。末学者宁不慨然乎。予亦向发愿欲搜罗坠编未有所得。今获是章无异穷子见衣中之珠也。呜呼亦时节因缘使然耶。抑护法善神所授耶。喜跃之余辄加点校以付剞劂以布遐迩。庶几华藏之佛日再瞩幽途。圆融之法水永回狂澜耳。是为序　　时元禄甲戌七年腊月谷旦东奥仙台龙宝住持比丘长与实养题于洛之智积轮下

花严经文义纲目一卷

夫以茫茫性海缘象讵测其源。眇眇玄猷名言罕寻其际。有融圆智朗巨夜而辟重昏。无限大悲俯群机。而临万刹。于是无象现象犹阳谷之升太阳。无言示言若沧波之倾巨壑。是故创于莲花藏界演无尽之玄纲。罕笼上达之流控引灵津之表。然后化沾忍土渐布慈云洒微泽以润三根。滋道牙而归一楑。是知机缘感异圣应所以殊分。圣应虽殊不思议一也。华严经者斯乃集海会之盛谈。照山王之极说。理致宏远尽法界而亘真源。浩汗微言等虚空而被尘国。于是无亏大小。潜巨刹以入毫端。未易鸿纤融极微以周空界。故因陀罗网参互影而重重。锭光颇黎照尘方而隐隐。一即多而无碍。多即一而圆通。摄九世以入刹那。舒一念而该永劫。三生究竟坚固种而为因。十信道圆普德显而成果。果无异因之果派五位以分镳。因无异果之因总十身以齐致。是故觉母就机于东城六千疏其十眼。童子询友于南国百十成以一生。遂使不起树王六天斯届。讵移花藏十刹虚融。示宝偈于尘中齐晖八会。启玉珠于性德七处圆彰。浩浩铿鋐抗思议而迥出。魏魏焕烂隔视听于聋盲。是故舍那创陶甄于海印二七之旦爰兴。龙树终俯察于虬宫六百年后方显。然则大以苞含为义。方以轨范为功。广则体极用周。佛乃果圆觉满。花譬开敷万行。严喻饰兹本体。经则贯穿缝缀。能诠之教着焉。从法就人寄喻为目。故称大方广佛花严经。世间净眼品者器等三种显曜于时。光洁照瞩况于净眼。法喻合举故云世间净眼。语言理均格类相从。故称为品。此经有三十四品。此品建初故称第一。故言大方广佛华严经世间净眼品第一。余义如下说。今总括此经七处八会事义差别略开十门。一辨教起所因。二释经题目。三明经宗趣。四说经时处。五辨定教主。六明众数差别。七请说分齐。八所入三昧。九佛光加持。十正说品会。初教起所因中有二。先明教传之相。后辨教兴之意。初中教传之相者。西域相传。此经结集已后收入龙宫。佛灭度六百年后龙树菩萨往龙宫。见此大不思议经。上本有十三千大千世界微尘数偈。四天下微尘数品。中本有四十九万八千八百偈。一千二百品。下本有十万偈三十八品。龙树遂将此下本出至天竺国造不思议论。亦十万偈以释此经。今耶舍三藏所翻十住毗婆沙论是彼一品也。爰有东晋沙门名支法领。从于阗国但得此三万六千偈。并请得大乘三果菩萨禅师名伏驮跋陀罗此云觉贤。俗姓释迦氏即甘露饭王之苗裔。来至晋朝。以安帝义熙十四年岁次鹑火三月十日。于杨州谢司空寺别造护净华严法堂。于中译出此经。时堂前有莲花池。每日有二青衣童子。从池而出扫洒研墨暮还归池。经了便止。相传释云。以此经久在龙宫。庆此传通故令龙王给侍耳。后因改此寺名兴严寺也。有晋沙门释法业惠严惠观等亲从笔受。法业因此出义记。名花严旨归。二卷。有吴郡内史孟顗右卫将军褚叔度等为檀越。至元熙二年六月十日译出讫。至大宗永初二年十二月二十日与梵本再校勘毕。当时五十卷成。后人亦有融作六十卷者。于法界品内先有所欠八九纸文。今大唐永隆元年三月内。有中天竺三藏法师地婆呵罗唐言日照。奉敕与沙门道成等十大德。于西京太原寺译出补之。沙门复礼笔受。其经感通及觉贤神迹等。并如新集花严传中辨。二明教兴意者。夫大教之兴非无因缘。及非小因缘令此教起。故下文性起品云。以须弥山微尘等因缘故起此性起法轮。今略题十种。谓愿力故。法尔故。为本故。为归故。显德故。显位故。开发故。见闻故。成行故。得果故。初愿力故者谓。佛与菩萨及彼机缘三位愿力之所起。故下文云。卢舍那佛本愿力。故普贤愿力故。又云若有得闻者。当知本愿。力又云开发大愿故因本愿力之所出也。二法尔故者谓。泛诸佛初出兴世将欲开显所化莲花法尔皆于第二七日海印定中演出如是无尽法门。下文云法如是故此则如大王路法尔常规。三为本故者谓。将欲逐机渐施末教。故于最初先示此法以为末本。以依此本得起末故下文云。譬如净法界与三乘法为所依。又云犹如日出先照高山等。四为归故者谓。显末教所归处故下文云。犹如众水流归大海等。五显德故者谓。显如来自所得法体相用。故体谓法界理智无碍。相谓十莲花藏微尘数等。明谓毛孔现刹广益机缘。普贤亦尔。六显位故者谓。显信等六位圆融相摄前后。是故一位即一切位。而前后历然。下文云在于一地普摄一切诸地功德等。七开发故者谓。开发众生性起心中法界无碍自在法门令显现。故下文中破微尘出经卷等可知。八见闻故者谓。示此一乘无尽自在具足。主伴无碍法门。令物见闻成解脱分金刚种故。如性起品说。九成行故者谓。令众生成普贤行。一行即一切行。初发心时便成正觉。具足慧身不由他悟等。十得果故者有二。初断果谓除障故。即一障一切障如普贤品。一断一切断如小相品等广说。二智果。谓具十身尽三世间。逆顺自在依正无碍等。由此十义同一缘起无碍圆融自在力故。令此经教依无住本而建立也

第二别释经题目者于中有二。先释众名后解别目。前中诸圣教立此经名略有五种。初依观佛三昧经及涅槃经。名此经为杂花经。此随喻为名。以理行交杂缘起集成故。二智论属累品名为不思议解脱经。有十万偈。此从法就用为名。故性起品云此经为乘不思议乘菩萨设。又智论自指此经也。三梁朝摄论第十胜相云百千经者。即花严十万偈为百千也。此从数为名。四如下离世间品出生菩萨深妙义花等。彼当释。此约法喻合目。五约十义立名等。如性起品。亦至彼当释。二解别目中二。先总解后别释。总者如入大乘论说。有五义。一为众生说对治法故。二有众多乘故。三多庄严具故。四能出生无量大果故。五除断一切诸邪见故名毗佛略。杂集论释方广者。菩萨藏相应言说名为方广。一切有情利益安乐所依处故。宣说广大甚深法故。亦名广破。以能广破一切障故。亦名无比。无有诸法能比类故。此等皆是大乘差别名。由与七种大性相应等。乃至广说。别释者大方广等是一部通名。世间净眼是当品别目。前中有二。先开义后合释。开者先举所诠之义。后经之一字举能诠之教。此依主释。前中先明所喻。后花严二字是能喻。前中先明所依法。后佛一字显能依人。前中先别明体用。后广一字合辨体能。前中先大字明法体。后方字辨胜能。合释中大者当体为目。苞含为义。方者就用为名轨范为义。广者体用合明周遍为义。此中大即方。大方即广。皆持业释。又大者古德解有三义。一常义。经云所言大者名之为常。二是体性普周义。经云所言大者其性广博。三是胜能义。经云能建大义名大涅槃。又具体相用三大也。今更寻下文略有十义。一境大。于中有二。一依报大。谓十莲华藏。二正报大。谓十佛三业等。如舍那品等说。即所信境也。二心大。如贤首品初及发心功德品说。三行大。如离世间品说。通修六位行也。四位大。如明难品已去至第六会说彼五位。谓信大．解大．行大．愿大．证大．等也。五证大。如入法界品说通证六位法也。六因大有二。初生因。如前五位说。二了因。如普贤品等说。七果大。于中有二。一随缘果。如不思议品等说。二自体果。如此经中果分不可说者是也。八体大。如性起品等说。九用大。谓念念益生顿成位等。如小相品等说。十法大。于中有三。一教大。谓一一名句皆遍一切十方法界。如下文说。二义大。称无边教所显义是。三事大。谓一一尘等具一切者是。此上十义皆各总摄一切法尽。具足即入故称大也。方有三义。一是方正义。谓此十义性离邪僻。二是方法义。谓此十义皆有模范轨则故也。三是医方义。谓此十义皆能对治诸重障故。广有二义。一遍一切处。谓凡一法门皆遍一切无尽世界乃至尘道及余一切诸法之处。如下结通等说。二遍一切时。谓遍前后际。通于十世下至刹那等。此二有二种遍。一一重。二重重如帝网等。虽约一摄一切故名大。一遍一切故称为广。而亦得前名广后名大亦无违。佛者觉照为名果满为义。此通十佛及三佛也。方广是所得法。佛是能得人。又前是所觉境。佛是能觉智。此中境智有二义。一相成二相即。前中方广之佛简下乘佛。佛之方广简因位法。此二相成各有有性无性缘起四句。思准之。人法相依皆依主释。二相即者。或方广即佛佛即方广。以人法无碍故。令体相即亦具四句。思准之。此唯持业释。华有三义。一微妙义。二感果义。三庄饰义。初一喻行体。后二喻行用。用中初喻生因。后喻了因。又初是生果华。不与果俱。如生死为道具及因位善根等故。下文云。此经出生一切菩萨诸行功德深妙义华。若从此义应名菩萨方广。又后庄果花与果俱。如果位善根。今此文中明佛方广。故约果位但论佛花严耳。又别分微妙喻前法。后二譬前人。通论人法皆具此三。故成况也。严之一字通含能严所严。由是镕融便成四句。或万行如华为能严。真性为所严。以理由修显故。或真性如华为能严。修生诸行为所严。以行从理起故。故摄论云。无不从此法身流。无不还证此法身。此之谓也。或俱融能所不二而二。以非真流之行无以契真。非饰真之行不从真起。良以体融行而因圆。行该真而果满。是故标为佛华严也。或双泯能所二而不二。以即真之行非行。即行之真非真。是则理行双绝能所俱亡。超情离相是谓花严。前二句花之严。后二句花即严。二释可知。又方广佛之花严。及即花严。亦二释可知。经如前释。世间是法净眼是喻。世者是时间者是中。时中显现故云世间。世间不同义有三种。一器世间有二。一道场地等别处。二莲花藏世界通处。二智正觉。世间亦二。一三身。二十佛。三众生。世间亦二。一同生。二异生。净眼亦有三义。一洞彻义。况彼三法离相平等洞彻真源。二照嘱义。喻彼三法明达照了诸法门故。三现象义。譬彼三法互相影现及一切法涉入无碍缘起自在。为显彼三有此别异殊胜义故。是故别立此名不名序也。品者类也别地。又释。如来未出世无善导故如盲。佛今创出世世间眼现故言世间净眼。是故佛涅槃时言世间眼灭也。余如上说

第三明宗趣者于中有二。先总后别。总者古德出宗不同。如远法师以花严三昧为宗。又衍师等以法界为宗等。今依光统师以因果缘起理实为宗趣。因果是位。缘起是义。理实是体。以因果与理实不二故是缘起也。又因果约事。缘起会相。理实显体。此中作二门。一约文或唯果。如不思议品及舍那品等。或唯因。如明难品至僧祇品及普贤品等。或俱。如七八二会。或俱非。如性起品。若细取一一会一一品亦一一文皆具因果。思之可见。二约义或因果俱因。以约缘起故此通一部。以果分不可说故。或因果俱果。以起即不起故。因相尽故约理实也。或前俱果。因以是所起故或后俱因。以是所依本故。由是缘起理实故或因即果果即因。因非果果非因。因是因果是果。因非因果非果。如是无障无碍。人法教义等皆准此知。后别辨中有五对十句。一境行相对。以境为宗用行为趣。或反。此以修起智会同真境故。问宗趣何别。答语之所表曰宗宗之所归名趣。总中宗即趣。此中分辨也。二理事相对。以事为宗理为趣。或反。以依理得成缘起事故。三教义相对。教为宗义为趣。或反上。以义深令教实故。四因果相对。因宗果趣。或反上。以举果意为成因故。五人法相对。集众人为宗说法为趣。或反上。以法成人故

第四说经时处中先明时后显处。时中作四门。一定分齐。二摄前后。三显差别。四表示法。初定分齐者。菩提流支云。华严八会中前之五会是佛成道初七日说。第六会后是第二七日说。以十地经初云第二七日故。又有人说第八会是后时说。以彼文中有鹙子等五百声闻。并后时度故。此等所判恐不顺文。以初七日定不说法故。十地论言。何故不初七日说。思惟行因缘行故。既言思惟明知非说法。设有救言。只不说十地。非不说余法者。则不得言思惟也。下论又释。为显己法乐是故不说。故知初七日定非说耳。又第八会亦非后时。何得于一部经前已说半。中说余经。后方更续。岂令佛无陀罗尼力不能一念说一切法。祇园鹙子并是九世相入。下文云。过去一切劫安置未来今。未来一切劫回置过去世。又云于一念中建立三世一切佛事。乃至广说。如是等文处处皆有。岂鹙子祇洹而非此类。是知此经定是第二七日所说。二摄前后者有三重。一于此二七之时即摄八会。同时而说。若尔何故会有前后。谓如印文。读时前后印纸同时。问若尔云何重会得成。答重亦同时。以无碍故。如灯光相入等。余不动升天等准释可知。二即此时摄彼前后各无量劫无不皆尽。以是不思议解脱时故。三摄于重重无量念劫。如因陀罗网重重收摄故。三显差别者。依普耀经第二七日于鹿野园为彼五人三转四谛。此唯小乘。依密迹力士经第二七日鹿园为于无量大众转法轮。时有得罗汉辟支佛道菩萨道等。此是三乘。依此经第二七日于树王下为海会菩萨转无尽法轮。明是一乘。上三同时者。约法表本末同时。约人显机感各异。依法花三七日。四分律六七日。兴起行经七七日。五分律八七日。智论五十七日。十二游经一年方说。此并末教机异宜闻各别。故致不同。本教机定故唯二七日。四表示法者。十地论云。时处等校量显示胜。故此法胜故在于初时及胜处说。此有三义。一此经初时表本法胜故。二末教亦同表末不离本故。三显本非末故时定二七更无异说。第二说经处者作五门。一定其处。二辨融摄。三显差别。四总表示法。五别显处会。初定处者。问说此经处为是净土为是染界。设尔何失二俱有过。何者若是净土。何故上文云摩竭提国。下文复云如是此四天下阎浮提等。由此当知非是净土。若染土者何故下文云此莲花藏世界海六种十八相震动等。明知此经非染土说。如此相违如何指定。答但依此经染净二土镕融相摄有其四句。或唯娑婆。以本从末故。或唯华藏。以末从本故。此二如上辨。或双现。以依华藏而有娑婆。染净相分末依本。故如下文云。华藏世界中娑婆世界。此之谓也。或染净双绝。以就果海不可说故。此上四门合为一土。镕融无碍随说皆得。二辨融摄者。亦有三重。一此觉树下即摄八会人中天上。是故皆云不离此也。二摄十方无余刹土。皆悉不离此树王下。三摄毛端微尘内等重重之刹。犹如帝网无有穷尽。以皆是此莲花藏界之所摄故。第三显差别者。然佛说经处有三种。一唯界内十六大国。化身说处。此通小乘及三乘教。二唯界外诸妙净土十八圆满受用土中。报佛说处。如佛地经等。此妙净土非三界摄。而亦不离。以遍一切处故。此通三乘及一乘说。三染净圆融。如帝网无尽花藏界中十佛说处。依正浑融具三世间。此唯别教一乘说处。今所辨正唯后一。兼摄前二。以彼本末不相离故。四总表示法者。托此胜处表示法胜。地论云。此法胜故在胜处说。说有二门。一总二别。总有三重

一此树下得菩提故不起此说。明表所说如所得故。非逐异机有改动故。如鹿园说等。二托圆融莲华藏界表示所说圆满殊胜性开敷故。三托此重重帝网之处表示所说亦重重无尽。如不思议解脱等。此三通于八会故名总也。五别显处会者有二。初约佛赴机会别有八。二约菩萨求法有五十四会。初中第一会在摩竭提国(此云不害国)寂灭道场菩提树下。此一会处亦总亦别。贯通余会得称为总。故下文云。菩提树下须弥山顶等。是故此初则为总处。如下所说。一切十句中皆初句为总余九为别。此之谓也。总门表法如前已显。别示此会说果德法。是故托此得果之处用以表示。第二会在摩竭提国普光法堂。西域相传。此堂去菩提树东南二三里许。在尼连禅河曲内。诸龙为佛所造。如来于中放相轮光。遍照十方无边世界。是故名此为普光法堂。此中表说信行普周荫初机故也。第三会在须弥山顶帝释宫中妙胜殿。须弥者此云妙高山。谓四宝所成。是故称妙。挺出众山故曰高。表此所说十住不退穷至山顶超过凡小寄于妙胜故也。第四会在夜摩天宫宝庄严殿。夜摩名时或云善知。表说十行随时进修胜德交饰故托兹殿。第五会在兜率陀天宫一切宝庄严殿。兜率此云喜足。表说回向世间位满成喜足行。摄德多闻寄一切宝殿

第六会在他化自在天宫摩尼宝藏殿。表说十地所证真如非自所作。又表因圆穷欲界顶。证智摩尼出阿含光故。故托此殿

第七会重普光法堂。表此所说六位行法依前信等圆摄周尽。是故重会于此处也

第八会在舍卫国祇树给孤独园重阁讲堂。为表所显法界法门当体希奇功用济物。用依体起似阁重重成。故托斯处也。问从人向上次应先至四天王。越彼而升忉利有何别意。答十信寄在人间。十住乃居山顶。信是外凡菩萨。住是不退贤人。欲表贤愚进退两位悬殊故。寄越此四天王处。问兜率会了次临化乐。越升他化复有何意。答兜率位当回向。世间修相已终他化行有十阶。出世真如今证。既世间出世间为异。漏与无漏有殊。假修真证绝悬故表超于化乐。问何须重会。复以何义唯会普光。答普光是起信之首。历位至于他化。今明位中之行。行修从首理宜会此。但以位相约解寄会升沉。行就理玄一位相摄故唯会此处。二约菩萨求法会者如善财童子。于觉城东娑罗林大塔庙处。文殊师利初为诸大众及善财童子一会说法。如是次第乃至末后。普贤菩萨于金刚藏道场所。为于大众及善财等现法界身云之法。为末后第五十四会。是故通前总六十二会。此据一方说。若论结通十方世界是则微尘微尘数虚空法界等诸会处也

第五定教主者亦作五门。一定佛身。二明融摄。三显差别。四表示法。五明业用。初定佛身者。问此八会佛是何等身。答有人释云。是化身佛。以菩提树下八相成道是化身故。不离升天是重化故。以释迦异名名卢舍那非别报身。故又有释云。说此经佛是实报身。以是卢舍那法界身故居莲华藏净土中。故下第七会初叹佛有彼二十一种殊胜功德。是实报也。但以不离化故该此树下。非是化身。今释此佛准下文中是十佛之身。通三世间。以说十信及三贤等地前所见非实报故。然居花藏非是化。故国土身等非前二。故具摄前二。性融通故。具足主伴如帝网故。是唯周遍法界十佛之身

第二融摄者有二。一直摄一切三世间尽。以具此三事方为佛故三身二身。但是三中智正觉摄。诸妙净土及同生之身。无不皆是此中所摄。二于正报毛孔及依报尘中。皆重重具足。摄彼三世间等一切诸法如帝网现。准思可见

第三显差别者。此一释迦身随应群机差别多种。或同凡而非圣。如见三尺黑象脚身及树神身等此约人天位。或是圣而非凡。以同罗汉圣人身故。或亦凡亦圣。以是父母所生实报身故。四大成故同凡身也。具五分法身诸漏尽故是圣也。或非凡非圣。以是大乘三身摄故。非同小乘罗汉圣故。或是化非法报。以具八相在阎浮故。色顶别立彼实报故。如梵网经等说。此约初教。或是报非法化。即此身具二十一种殊胜德。受用身故如佛地经初说。此约终教。或是法非报化。以色即如故。经云吾今此身即是法身。此约顿教。或亦法亦报化。如前三说。故或非法非报化。以是十佛故。通三世间故。具足主伴故。如此经下文说。此约圆教。是故此释迦身圆融无碍极难思也

第四表示法者。然说法之佛总有四位。一罗汉身佛表说小乘。二化身佛表说三乘。广说地前略说地上。三报身佛表说三乘。广说地上略说地前。四十身佛表于一乘。六位齐说。由此所说具足主伴无尽法故佛亦同此十身无尽

第五明业用者。问下文云。不离菩提树而升忉利天等。云何不起而得升天。答有人释云。本释迦身不离觉树。重现化身以用升天。此则本释迦身竟无升天。升天之身非本释迦。经意不然。故不可也。又有释言。不起是法身。升天是化用。此恐非理。岂可法身坐道树耶。又有释言。此升天是不往而至。以往即不往故。所以不起也。不往即往故所以升天也。如不来相而来名善来等。若依此释但是无升相而升天。非是树下有不起之身。故亦难用。今解此文略有八义。一约处即入门。谓以一处中有一切处故。是故此天宫等即本来在彼树王下故云不起也。然先未用此天宫处。今欲于中说法用故说为升也。又相即故不起门别故有升也。二约佛。谓此坐树王下之佛身即遍法界一切处故。是故佛身本来在彼忉利等处故不待起也。今欲用此忉利门中之佛故曰升也。是故若起则不成升也。三约时。谓由此树下座上佛身即遍前后际等九世十世一切时故。是故此佛坐树下时升天去时到天处时一一时皆遍法界。摄前后际尽。即知坐树下时永无起时故。云不起也。若正去时亦如此故唯有去。无余也。皆念念不相至各各收法界。如是缘起门无碍。恒不离四约法界门。谓此升去无自性故即摄真如法界。以彼树下坐等亦不异真故同真如。在去门显现故不起而升也。五约缘起门。谓坐由行故坐。坐在于行中。行由坐故行。行在于坐中是故由行中坐。故升天即不起也。由坐中行故不起而升天也。行坐无碍故。即升常坐即坐恒升也。六约佛不思议德。谓即不起此坐即是行即是卧即是住。即是到一切处即是作一切事。并非下地所知。七约所表。谓表前位行成究竟坚固不坏故云不起前坐也。而有赴机用故云升也。八约成会。谓后会必具前故。不舍前而成后。若舍前则坏缘起。是故不起前而升后也

第六众数差别作十门。一明众数。二新旧。三定器。四世出世。五界趣。六诸乘。七权实。八位地。九表法。十因果。初众数多少者。谓此初会有五十五众。始从普贤至摩醯众为三十四众。复从善海还至普贤为十八众。帖前总为五十二众。海慧内众并新集十方。及胜音众帖前总为五十五众。第二会中有新旧二众。帖前总五十七众。三四二会各有天王菩萨二众。帖前总为六十一众。第五会中升天品内有五十二众。及云集众。帖前总为一百一十四众。第六会中有同生异生二众。及第七会一众。帖前总为一百一十七众。第八会中菩萨声闻天王三众。帖前则为一百二十众。于中一一或以十佛世界尘数为量。如是等皆无分齐。然此且约此一世界八会中说。若通十方虚空法界一切世界皆各有此无边众会。相入重重如帝网无尽即不可说不可说也。是谓花严海会之众。二诸会新旧者。或唯旧无新如六七二会。或唯新无旧如三四五三会。或亦新亦旧如初二八三会。余意各如下集众中说。三定器者泛论列众有三义。一是当机。二是影响。三是寄法。今此通三也。四世出世者有四义。或俱是世间以时中显现故。又三世间中是一故。或并是是出世。以其行德非世摄故。或亦世亦出。由具前二义故。又随相论。初普贤等是出世。余是世故。或非世亦非出。以是世出出世摄故。是故此众通其三位具斯四句也。五界趣者于三界中除无色天。以随相寄法非殊胜故。若人王经亦有无色天等。五趣中除地狱众。以彼极苦寄相显法亦非胜故。若陀罗尼经亦有此众。又无人王众。以相显非奇故。或菩萨即人众也。或唯列王众。如后十八众说以表法自在故。或通王臣。如此三十四众中说。以具主伴故。六诸乘者。大智论云。若小乘经初唯列声闻众。若大乘经初具列菩萨声闻二众。义准。若一乘经初唯列菩萨。所以知者。彼论以大品等为共教。别指华严为不共教。以不与声闻共说故。又此上三门各有二说。初中二者。一若为成小教得小果等。唯列声闻。此是愚法小乘。如阿含等经说。二为回小乘显所被机。唯列声闻。是大乘回心教。如金刚波若经初辨。二具二众中亦二。一或先列声闻。后列菩萨。此通始终顿三教。如净名等经辨。二或先列菩萨。后列声闻。此通顿教及同教。如罗摩伽经惟楼王经和休经等辨。三唯列菩萨。中二。一虽列菩萨主伴不具。是同教一乘。如十一面经等辨。二若主伴具足即别教一乘。如此经说。七权实者。若约三乘佛居此娑婆界。杂众是实。以实报生故。菩萨是权。方便现故。如经云。彼诸菩萨隐其无量自在力等。或菩萨是实。以地前菩萨犹生此土故。杂众是权。依大集经并是他方大菩萨等权形所作故。若佛居净土菩萨唯实。实报生故。杂众是化非实有故。论云受用土中实无此等众生。欲令净土不空故化作如是杂类众生。若一乘中佛在此花藏界。菩萨杂众或并是实。以是海印定现。实德摄故。或俱是权。以随缘而现故。余义思准。八明其位者。若约三乘此普贤等皆是十地已上菩萨。彼神王既多分是随类生摄。即是八地已上。若一乘中如缘起际。诸位皆齐。是故一人具五位。位位皆遍收准之。九人法者。若三乘中但寄人显法。仍人非是法。若一乘中此等诸人并是法界缘起法门。又此一众即通三世间。以或作河池井泉水等国土身故。余可知。十因果者。若三乘但是因位。若一乘中或皆是因。以未是佛故。或俱是果。以并是佛海印中现故。又乘解脱力入佛海故。或通因果。由前二义故。或俱非。以离性平等故。并如下叹德中辨

第七诸会请问者作四门。一明有无。二显所问法。三辨能问人。四问仪式。初有无者。于八会中初二后二有请问。余会皆无。所以尔者。初会标果起因故有问。第二会初为寻因至果故请问。但为因中行位阶降寄五会答也。以果位无优劣故当会答耳。然五会中诸品之内更有问者。并是当会所说法中随说请问。非是别问大位之相。以第六会来唯答第二会初所请问故。第七会中明行熟因果。是故请问。谓行修无碍六位顿成故。当会答也。第八会中明称性因果。是故请问。谓俱入法界无差别故。亦当会答也。二显所问法者。初及第八具有果法。而分有因法。但所信摄化为异。第二第七具问因法但行位为异。三能问人不同者。初及第八各具同异二众齐问。以所问法众同依故。第二唯是菩萨同生众问。以所入位同生胜故。第七唯普慧一人问。以造修之行名别成故

四问仪式者有二。一约言念。二约通别。初中泛论请问有二。一言请二念请。答亦有二。一言说答二示相答。此二问答如次及交络四句可知。为成三慧有斯二例。初之二会及第八会唯是念请。答通二位。谓佛有示相答。菩萨有言说答。以对佛兴请。上能知下不待言故。为显佛心能领疑身相现答。自在故也。第七会言请言答。以对普贤起问。还是普贤答故。二通别者。初及第八别问通答。第二第七别问别答。皆可知

第八所依三昧者略作八门。一辨分齐。二有无。三明出入。四显因果。五入定人。六业用。七入定意。八双行非双行。初明分齐者有二。先总后别。总者然此八会人法教义等皆依如来海印三昧之所显现故。贤首品云。一切示现无有余海印三昧势力故。二别显者。第一会入一切如来净藏三昧。以垢无不尽德无不苞名为净藏。标果异因名如来三昧。第二会不入定。第三会入菩萨无量方便三昧。巧解多端名无量方便。标因别果名菩萨三昧。第四会入善伏三昧。行能伏障令永不起名为善伏。第五会入明智三昧。照理除闇故称明智。第六会入大智慧光明三昧。入地正证。过小曰大。对治无明名慧光明。第七会入佛花严三昧。妙行开敷饰显真体。因严果满名佛花严。第八会入如来师子奋迅三昧。谓显佛果大用雄猛之状。从喻标名故立斯号。此上七种业用异故立名差别。心一境性等持无别。是故通皆名为三昧。第二有无者。唯第二会不入三昧。以所表法未成位故。余会所表法位成故。若依海印诸会通有。第三出入者。唯第八会入已无出。表于法界有证无失。又显佛果大用自在故不待出。余会不尔。表起化应机故。不同佛果用故。第四因果分别者有四句。或唯果定。谓初会及第八以初说果法故。第八证理玄故。或唯因定。谓三四五六以彼唯说因位法故。不思议品等所说果法别有所依。非彼定故。或亦因亦果。谓第七会以花严摄因佛是果故。所表行深具因果故或非因果。谓第二会总无定故。第五能入定。人者第一会普贤菩萨以普贤因圆堪显佛果。第二会文殊师利表信无位故不入定。第三会法慧菩萨以表十住慧解法故

第四会功德林菩萨以表十行胜德建立故。第五会金刚幢菩萨表十回向大愿坚固独标出故。第六会金刚藏菩萨以表十地无漏行深。破障智坚含摄具德故。第七会普贤菩萨表行深广该于六位称普贤故。第八如来入定以表法界解脱自在无碍唯佛穷。故第六业用差别者通辨定用。有其三种。一发慧二引通三具二。此七定中或唯发慧。谓除初后所余五会以皆从定起智说故。或唯引通。谓第八会以显如来身土无碍法界门故。或具二种。谓初会普贤定中说法。亦是通故。第七明入定意者略有四意。一为证法令说决定故。论云何故入三昧。显示此法非思量境界故。二为受加。佛力加持此为器故。论云何故加。以得此三昧故。三成轨则。诸有说法要审而说方可信故。四表示法。以闻此定名解彼法故。此七定中初五具四。第七唯三。以行法依解不待加故。第八唯二。以佛无新证无受加故。第八双行非双行者有四句。或唯双行。谓第八会在定起用无障碍故。或唯非双行。谓除初二会所余诸会以要出定方有说故。论云。何故出定以定无言说故非双行或俱。谓初会定中说彼五海十智故是双行。后出定已方乃说彼十世界海故亦非双或俱非。谓第二会总无故

第九光加不同者。先辨放光亦作五门。一有无。二出处。三光意。四光体。五光用。初中八会之内。唯第七会不显放光。以所依行法不异前故。但纯熟为异。二出处者初会二处。一从面门牙齿放光。表教道遐舒。二从眉间毫相放光。表证道圆洁。第二会从足下相轮放光。表信行最卑故居足下。又表众行依信而进。如身依足而有所趣。第三第四二会之中。皆从足指放大光明过前位故。增至足指。指有二义。一能距地有立住义。二能申展有进趣义。前表第三十住之法。后表第四十行之法。是故二会同此放光。第五会从两膝放光。表行位过前渐增至膝。大愿回向屈申进诣以膝表示。第六会眉间豪放光。表十地正证。第八会亦眉间放光者。亦表法界法门普该证入故。三光意者。此诸放光略有四意。一为现相表法。二惊起信心。三照触救苦。四集众远召。四光体者亦有四种。一是事光如流星霞云等。二是法光谓显示法门故。三是理光谓非青黄赤白。不生灭故。四无碍光。前三无碍融现前故。五光业用者。八业二身如十地论说。第二明诸佛同加作四门。一有无。二加相。三加意。四能加之佛。初有无者于八会中第二及七八此三并无加。第二位未成故不入定。故第七行法。依解不异前故。第八如来自入三昧不待加故。余会非此。是故皆有二。加相者谓彼诸佛皆以三业同作加。故口加语业资其辨才。意加与智增其慧悟。身加与力令威过众表同于如来三轮摄化。又口加与辨令能说。意加冥被以增威。身加摩顶而令觉。三加意者有六。一地论云。卢舍那佛本愿力故加。二是彼菩萨善根愿力故。三得彼三昧法如是故。四为说此法故加。谓十地等诸位法也。五者十方诸佛各以三业加彼菩萨令说此法。即表诸佛同所宣说。六令彼大众知佛加说。于彼所说生净信故。四能加之佛名数者。初会之中有十方世界海诸佛。第三会十方各过千佛世界尘数刹。外有千佛世界尘数诸佛。同名法慧。第四会十方各过万佛世界尘数刹。外有万佛世界尘数诸佛。同名功德林。第五会十方各过百万佛刹尘数刹。外有百万佛刹尘数诸佛。同名金刚幢。第六会十方各过十亿佛土尘数刹。外有十亿佛土尘数诸佛。同名金刚藏。解云欲表三贤十圣位相渐增故。令佛数从小至多。皆同所加菩萨名者。地论释云。令彼菩萨闻诸如来同己。名己增踊悦故。又彼诸位各说如佛名之法故不异名加

第十所说法者略作四门。一约品。二约会。三约文。四约义

初约品者。第一会中有二品。一世间净眼品。二卢舍那佛品

第二会有六品。一如来名号品。二四谛品。三光明觉品。四菩萨明难品。五净行品。六贤首菩萨品

第三会有六品。一佛升须弥顶品。二菩萨云集说偈品。三菩萨十住品。四梵行品。五初发心菩萨功德品。六明法品

第四会有四品。一佛升夜摩天宫品。二菩萨云集赞佛品。三功德花聚菩萨十行品。四菩萨十无尽品

第五会有三品。一佛升兜率天宫品。二菩萨说偈品。三金刚幢菩萨回向品

第六会有十一品。一十地品。二十明品。三十忍品。四阿僧祇品。五寿命品。六菩萨住处品。七佛不思议法品。八如来相海品。九佛小相光明品。十普贤菩萨行品。十一宝王如来性起品

第七会有一品。谓离世间品

第八会有一品。谓入法界品。颂曰

  二六六四三　　十一各一一　　是故于八会
  品有三十四

第二约会者有二。初摄因从果会别有八。二分因果有六十二会

初第一会中普贤定内观五海说十智。言五海者初一切世界海。二一切众生海。三法界业海。四欲乐诸根海。五三世诸佛海。言十智者一一切世界海成败智。二众生界赴智。三法界智。四如来自在智。五转法轮智。六力无畏不共法智。七光明赞叹音声智。八三种教化众生智。九无量三昧法门不坏智。十如来种种自在智

第二会中初品说佛身名普遍。次品说佛谛语遐周。次品明佛身意舒光广拟开觉。上三显佛果三轮差别摄用。次品说信位正解十种甚深。次品说信位净行百四十愿。末后一品说信位德成广摄诸位　乃至成佛

第三会中所说十住者。一发心住。二持地住。三修行住。四生贵住。五方便具足住。六正心住。七不退住。八童真住。九法王子住。十灌顶住

第四会中说十行法。一欢喜行。二饶益行。三无恚恨行。四无尽行。五离痴乱行。六善现行。七无著行。八尊重行。九善法行。十真实行

第五会中说十回向法者。一救护众生离众生相回向。二不坏回向。三等一切佛回向。四至一切处回向。五无尽功德藏回向。六随顺平等善根回向。七随顺平等观回向。八如相回向。九无缚无著解脱回向。十法界无量回向

第六会中说十地法。一欢喜地。二离垢地。三明地。四炎地。五难胜地。六现前地。七远行地。八不动地。九善惠地。十法云地

第七会中普慧菩萨起二百句问。普贤菩萨句别答十故成二千法门

第八会中大众起于六十句问。如来现于法界身云。令诸菩萨皆入法界。舍利弗等五百声闻虽在会中如盲如聋无所闻见。后显善财随位修行证入法界。上来摄助归正。故以八会统收皆尽

第二分助异正散说。诸佛及诸菩萨赴机。显法会别通有六十二者。初之八会如前所显。次约菩萨赴机摄化有五十四会。总相科勒以为五分。初有四十一位名寄位修行相。于中初觉城东文殊一会。令善财入法界信位。次于可乐国和合山功德云比丘令善财得普门光明三昧观察正念诸佛法门。乃至第十师子奋迅城中弥多罗女令善财得般若波罗蜜普庄严法门。已上十位令善财各得一种法门满足十住之位。次从救度国善现比丘令善财得随顺菩萨灯明法门。乃至第十知足城中出家外道名随顺一切众生。令善财得至一切处法门。已上十位各令善财得一法门满足十行之位。次甘露味国青莲华长者令善财得入香法门。乃至第十摩竭提国道场地神名曰安住。令善财得菩萨不可坏藏法门。已上十住各令善财得一法门满足菩萨十回向位。次从迦毗罗城婆娑陀夜天令善财得光明普照诸法坏散众生愚痴法门。乃至第十迦毗罗城释迦女名瞿夷。令善财得分别观察一切菩萨三昧海法门。已上十位各令善财得一法门满足菩萨十地之位。上来四十一总明寄位修行相竟

自下初从摩耶夫人令善财得大愿智幻法门。乃至第十德生童子有德童女令善财得菩萨幻住法门。已上十位各令善财得一法门满足菩萨第二会缘入。实法门

自下海涧国大庄严林中严净藏楼观内。弥勒菩萨令善财得三世智正念思惟庄严法门。已上一位令善财入第三摄德成因相法

自下普门城边文殊师利遥申右手摩善财顶。得见三千大千世界尘数知识。不违其教。乃立善财于自所住处普贤道场法门。此一位令入智照无二相法

自下于如来前金刚藏道场上。普贤菩萨令善财得十不可坏智慧法门。此一位令入显因广大相法。又此上所求诸善知识种类有五。一约位有五十四如前辨。二约主伴有一百一十也。三约同教见大千世界尘数知识。四约别教见十佛世界尘数知识。五约称法约通十方无尽世界。则见虚空法界等不可说不可说诸善知识

第三显文分齐者有六重。一约三分。初品是序分。二卢舍那品下是正宗。经来不尽故无流通。又释此经总无流通。以前七会各无流通故。大般若经十六会末各别流通。此不同彼。故知此经总无流通。表显法门无终尽故。二依正法师等作四分。初品是序分。二卢舍那品下至光明觉。四品经文名举果劝乐分。三从明难品下至性起。二十七品经文明修因契果分。四七八二会明依人入证分。三正说有五分。初一品教起因缘分。二卢舍那品中一周问答是举果劝乐生信分。三从第二会尽第六会有三十品。亦一周问答是修因契果生解分。四第七会中一周问答是托法进修成行分。五第八会中一周问答是依人入证成德分。以此经中唯有如此四翻问答。是故兼序。但得科为五分不得异说。又四问答中。初生信。二起解。三成行。四证真故义圆足不增减也。四或为五周因果。第一会中果广而因略。是所信因果。第二会至小相品是修生因果。普贤性起是修显因果。第七会中成行因果。第八会中入证因果。五或八会各一法。初一所信之境。二依境起信。三依信生解。四依解起行。五随行起愿。六行愿证实。七练行纯熟。八该摄法界。亦是义理圆满故无增减也。六或分为十。谓前五周因果之内初后二位先果后因。余三皆先因后果。各分因果二位故为十也

第四约义显者。总标此经大意义理略作十门。一同时具足相应门。二因陀罗网法界门。三秘密隐显俱成门。四微细相容安立门。五诸藏纯杂具德门。六十世隔法异成门。七一多相容不同门。八诸法相即自在门。九唯心回转善成门。十托事显法生解门。此上十门中各有十义。一人法。二教义。三因果。四理事。五解行。六分齐境位。七师弟法智。八主伴依正。九逆顺体用。十随生根欲示现。此等十义皆同时相应成一缘起。随别义门入前十门。皆准思之。又更重释前十门。初是诸缘契合义。是总也。约缘起全有力全无力义故有相容门也。约缘起空有义故有相即门也。缘起力用重重摄故有帝网门也。缘起有无各不并。故有隐显门也。约缘起同体门摄法故有微细门也。约所起法分前后际故有十世门也。约缘起诸门所收诸法各有纯杂故有纯杂门也。约缘起自性故有唯心门也。约缘起相用理观如事故有说托事显法门也。此十义通一部经思之

花严八会刚目一卷天治二年十月二十三日于池上房之僧宽有之本也未来领知人人可令后世访给也


华严七处九会颂释章

    No. 1738 [cf. No. 279]

    华严七处九会颂释章序

昔者圭峰禅师有华严纶贯之作。其书亡逸而不传。复庵纶贯本为禅者作。故虽痛快直捷而不便于学教之士。尝欲仿法华纶贯别作一书。愧无旭师之笔而止。客冬于华顶入信精舍得七处九会颂释。乃清凉观大师之所著也。其书仅一万三千余言。较之疏钞不及百之一。而全经要义揭示殆尽。且其文平易明白虽初学可解。实为入华严教海之津梁矣。此固非复庵之所能办。假使旭师见之未必不叹其不可及也。于是再四校订亟付之梓以广其传。大抵喜简厌繁人之恒情也。则斯书流通宜先疏钞而待今乃行。呜呼物之显晦信有时哉。原本宝永甲申升堂所写。其人好古尝校梵网石壁疏等行之世云

文化二年乙丑五月望

        沙门典寿谨撰

新译华严经七处九会颂释章一卷

        清凉山大华严寺沙门澄观撰述

  稽首归命普法界　　离垢清净解脱轮
  充遍法界十佛身　　海会教主诸圣众
  我住缚地悕大法　　唯愿加哀令增智
  今开略颂益自他　　愿生大解渡痴海

  此经八十卷　　四万五千偈
  七处九会说　　三十九品章
  人中有三处　　道场普独园
  天上有四处　　忉夜兜他化
  初会菩提场　　二会普光殿
  三会忉利天　　四会夜摩天
  五会兜率天　　六会他化天
  七八重普光　　九会给孤独
  初会十世界　　二会十佛国
  三会十住位　　四会十行位
  五会十回向　　六会十地行
  七会等妙位　　八会二千行
  九会法界境　　是九会法门
  初二三各六　　四四五三品
  六一七十一　　八九各一品
  初会世如普　　世华舍那品
  二会如四光　　菩萨净首品
  三会升须十　　梵初明法品
  四会升夜十　　十无尽藏品
  五会升兜十　　六会十地品
  七会定通忍　　阿寿住处品
  佛如如普贤　　如来出现品
  八会离世间　　九会法界品
  无愿业住涅　　法心三性如
  安出信随永　　无安无决普
  初治修生具　　正不童王灌
  欢饶无无无　　善无尊善真
  信戒惭愧多　　施慧念持辩
  救不等至无　　随等如无入
  极离发焰极　　现远不善法
  普妙次清知　　智了众法无
  他天宿知成　　住善出一一
  音顺无如如　　如如如如如
  同因秘微十　　诸一诸随托

此论二分已说颂分释分如何颂曰

  此经八十卷　　四万五千偈
  七处九会说　　三十九品章

释曰。此谓简持义。为简余经名为此经。又为简旧经。彼晋朝经卷有六十。今为简彼名此经等。此经前后翻译补阙四本不同。今此第三证圣元年。于阗国三藏实叉难陀此云喜学。于东都佛授记寺再译旧文兼补诸阙计益九千颂。通旧总翻四万五千颂合成汉本卷八十轴。义净等六大德同译复礼法师缀文。更有余释如策林说。四万五千偈者晋朝译经三万六千偈。更益九千颂故若通论经本合有六本。一恒本二大本三上本四中本五下本六略本。初恒本者案藏法师疏第一卷云。此通树形等异类世界各毛端处念念常说无有休息。此非可结集不可限其品颂多少亦非下位所能受持。广如不思议品说。二大本者如下海云比丘所受持普眼经。以须弥山聚笔四大海水墨书一品修多罗不可穷尽。如是等品复过尘数。此是诸大菩萨陀罗尼力之所受持。亦非贝叶所能书记。三上本者此是结集文中之上本也。故西域相传龙树菩萨往龙宫见大不思议解脱经有三本。上本有十三千大千世界微尘数颂四天下微尘数品。四中本者有四十九万八千八百偈一千二百品。此上二本并秘在龙宫非阎浮提人力所受持故此不传。五下本者有十万颂三十八品。龙树持此本出现传天竺。西域记说在于阗国南遮俱槃国山中具有此本。六略本者即此土所传六十卷本。是彼十万颂中前分三万六千颂要略所出也。今此四万五千偈亦然六本中略本摄也。广如彼说

问曰。偈者长行颂合为简长行

答曰。初从如是我闻终至此怀疑念数之为偈

问曰。数几字以为一偈耶

答。三十二字以为一偈。但梵本字其数减少汉地译字其数增多。是故梵本四万一千九百八十颂余十字。唐本四万五千颂

问曰。以何知然耶

答曰。案俨法师杂孔目云。依大慈恩寺华严梵本检有五百四十一纸叶。五十七字以为一行。二十行为一纸叶。一纸叶背面二千二百八十字。十纸计当二万二千八百字。三十二字以为一颂。一百纸当二十二万八千字。三十二万为万颂。五百四十一纸计当一百二十三万三千四百八十字。依三十二字为颂计当四万一千九百八十颂余十字。案云由此明知梵本文字其数减少唐翻译时字数增多。是故依梵本经计颂数时四万一千九百八十颂余有十字。依唐译经计颂数时合四万五千颂。相传云金刚般若梵本有一纸许。唐翻译时多纸多字此亦如是。今云梵本经者非支法领得三万六千偈梵本。唯依实叉难陀得四万五千偈梵本经也

问曰。长行是十二分教中契经教。何故今云长行颂合名四万五千偈耶

答曰。案藏法师疏第二卷云。又颂有四种。一数字颂谓依梵本三十二字以为一颂。不问长行及偈。二伽他颂此云讽颂或云直颂。谓不颂长行也。三祇夜颂此云应颂。谓应重颂长行法也。四嗢陀南颂此云集施。谓以少言含摄多义云集。用以施人令易受持故云集施。此上三种颂或七言或五四三言。皆以四句为一颂。今长行合云颂者依四颂中数字颂说。处会别名如下具说。三十九品章者晋朝经有三十四品。更益五品故名三十九。谓如来现相品普贤三昧品世界成就品华藏世界品十定品。晋朝经合前四云卢舍那佛品。更无十定品故名三十四品耳。二经品名各相替案经可见。已说偈品处相如何。颂曰

  人中有三处　　道场普独园
  天上有四处　　忉夜兜他化

释曰。有四洲中南名人中。摩竭提国有三胜处故名三处。何等为三。谓菩提树下道场处。普光明法堂处。祇树给孤独园处。于欲界内有六天。中四名天上。须弥顶上四殊胜处故名四处。今云顶上者取顶上方故名顶上。何等为四。谓须弥顶上忉利天处。自顶上方夜摩天处。兜率陀天处。他化自在天处。此中初一地居后三空居。人间方处咨知有端。天上方处非通难知。故今随难说六天相。何等为六。一四天王天。二忉利天。三夜摩天。四兜率陀天。五乐变化天。六他化自在天。初四天王天者苏迷卢内第四层级四大天王及诸眷属共所居止。各住一面名四天王。寿量衣等如余论说。忉利天者此云三十三天。妙高山四面各有八大天王。帝释居中故名三十三天。彼天身长一由旬衣长二由旬广一由旬重六铢。寿一千岁。夜摩天者此云时天。以时华开合辨昼夜分故名时天。又随时受乐故名时分。此天身长二由旬衣长四由旬重三铢寿二千岁。兜率陀天者此云喜足。佛地论云后身菩萨于彼教化多修喜足行故云喜足。长阿含经云身长四由旬衣长八由旬广四由旬衣重一铢半食甘露寿四千岁。乐变化天者乐自变化作诸乐具以自娱乐故名乐变化。此天身长八由旬衣长十六由旬广八由旬衣重一铢食甘露寿八千岁。他化自在天者令他化作诸乐具显己自在故名他化自在。此天身衣寿命过前一倍。如是诸天广如瑜伽佛地三法度经长阿含经婆沙俱舍等说

问曰。何故从人间升天上超四王天。从兜率向他化超化乐天耶

答曰。古来多释今且述正。所以超四王天者。十信是外凡菩萨。十住是不退贤人。显贤愚玄隔故超次升天。所以超化乐天者。回向是世间行。十地是出世行。又回向是有漏。十地是无漏。显世出世漏无漏玄别故超次向上。已说处相会相如何。颂曰

  初会菩提场　　二会普光殿
  三会忉利天　　四会夜摩天
  五会兜率天　　六会他化天
  七八重普光　　九会给孤独

释曰。舍那法会充遍尘刹难测涯限。且寄分相迹释说经会略有四门。一定其说处门。二融摄无碍门。三显处差别门。四表示法胜门

定其说处门者

问曰。说此经处为是净土为是染土。若是净土何故经云摩竭提国等。若是染土何故经云此莲华藏世界海等

答曰。说此经处染净二土镕融相摄有其四门。一本从末门唯娑婆说。二末从本门唯华藏说。三本末双显门如经云华藏界中娑婆界等。四本末双绝门以就果海不可说故。此上四门合为一土镕融无碍随说皆得

融摄无碍门者亦有三重。一此觉树下摄人中天上七处九会。是故皆云不离此也。二此觉树下摄十方无余刹土。皆悉不离此树王下。三此觉树下摄毛端微尘数等重重之刹。犹如帝网无有穷尽。以皆是此莲华藏界之所摄故

显处差别门者佛说经处总有三种。一唯界内十六大国化身说处。此通小乘教及三乘教。二唯界外诸妙净土受用土中报佛说处。此通三乘及一乘说。三染净圆融帝网无尽华藏界中十佛说处依正浑融具三世间。此唯别教一乘说处。今此所辨正唯后一兼通前二。以彼本末不相离故

表示法胜门者。托此胜处表示法胜。如地论云此法胜故在胜处说等。从粗至细总有三重。一此树下得菩提故不起此说。明表所说如所得故非逐异机有改动故鹿园说等。二托圆融莲华藏界。表示所说圆满殊胜性开敷故。三托此重重帝网之处。表示所说亦重重无尽。如不思议解脱等。今此九会即通此三。粗细融容俱无碍故。赴机说法会别有九。何等为九。第一会在摩竭提国(此云不害国)菩提场树王之下为表佛果无尽德。是故托得果之处用以表示。第二会在摩竭提国普光法堂。西域相传此堂去菩提树东南二三里许在尼连禅河曲内诸龙为佛所作。如来于中放相轮光遍照十方无边世界。是故名此为普光堂。此中表说信行普周荫初机故。第三会在须弥山顶帝释宫中妙胜殿。须弥者正云苏迷卢此云妙高。四宝所成故名为妙。挺出众山故亦名高。表此所说十住不退穷至山顶。超过凡小寄此胜殿。第四会在夜摩天宫宝庄严殿。夜摩名时如前已说。为表十行随时进修胜德绞饰故托兹殿。第五会在兜率陀天宫一切宝庄严殿。兜率此云喜足。为表回向世间位满成喜足行。摄德多门寄一切宝殿。第六会在他化自在天宫摩尼宝藏殿。为表十地所证真如非自所作。又表因圆穷欲界顶。证智摩尼出阿含光故寄斯殿。第七会重普光法堂表此所说六位之法依前信等圆摄周尽。是故重会于此处也。第八会重普光法堂表此所说二千行法亦依前信等圆摄周尽。是故重会于此处也。第九会在舍卫国祇树给孤独园重阁讲堂。为表所显法界法门当体希奇功用济物。用依体起似阁重成仍托斯处也

问曰。晋朝经唯有八会何故唐经有九会耶

答曰。觉贤三藏不得十定品梵本。终不知说十明品等十品处。由此十品入于第六他化自在天会。是故唯八会耳。喜学三藏得十定品即分明知十地品是他化天会。十定等十一品是普光重会。故开为九会耳。十定品首云尔时世尊在摩竭提国阿兰若法菩提场中始成正觉。于普光明殿入刹那际诸佛三昧。以一切智自神通力现如来身清净无碍。如此广叹佛菩萨德及列名号。谓普眼菩萨摩诃萨等

问曰。卢舍那佛说华严处遍法界者如忉利天说十住时夜摩等处亦说十住不耶。若彼不说则说不遍。若彼亦说何故经中唯云忉利说住夜摩说行等耶

答曰。此说十住忉利天处既遍十方一切尘道。是故夜摩等处皆有忉利。即于如此遍夜摩等忉利天处说十住法。是故忉利无不普遍仍非夜摩。夜摩等处说十行等皆亦遍于忉利等处仍非忉利。如是准知

问曰。何须重会。复人间有三处何故唯重普光耶

答曰。普光是起信之首历位至于他化。今明位中之行。行修从首理宜会此。但以位相约事寄会升沉。行就理玄一位顿摄。故唯会此处

问曰。第二会历后忉利等四处复来普光可名重会。今七八二会中间不曾暂起复来何名重会耶

答曰。重会之名通于多种。谓时处人法皆有重义。前约处明此据法说。谓前六会同显生解因果。今重辨彼解所成行。故名重会。颂中举本不论其末。是故唯说佛为主会。不说菩萨求法之会理亦可说。如善财童子于觉城东沙罗林大塔庙处文殊师利初为诸大众及善财童子一会说法。如是次第乃至末后普贤菩萨于金刚藏道场所为于大众及善财等现法界身云之法为末后第五十四会。是故通前总六十三会。此据一方说若论结通十方世界是则尘数虚空法界等诸会处也

问曰。善财童子求法初位住何位求耶

答曰。案新罗元晓法师华严关脉义云。初得见文殊者明善财之信心始位。乃至最后不见者明善财之智满位等。依此明知住十信初位方求法也。已说九会诸会法门其相云何。颂曰

  初会十世界　　二会十佛国
  三会十住位　　四会十行位
  五会十回向　　六会十地行
  七会等妙位　　八会二千行
  九会法界境　　是九会法门

释曰。颂中初九句正颂九法门。最后一句总结前九。除第五会余会法门或有通别或有广略。然今颂中举通摄别略广互摄。至后当知第一会宗通明十种世界海门。别显莲华藏世界海。第二会宗通明十佛国土之相。别明佛号谛名等义。第三会宗通明菩萨十住位行。别显梵行发心德等。第四会宗通明十行位行差别。别显十种无尽藏义。第五会宗广说十种回向愿行。由广说故不显通行。第六会宗有略有广。略明十地因分愿行。广明因果无量行位。第七会宗有略有广。略明等妙觉二位。广明十通十忍等法门。第八会宗唯广无略。广明菩萨二千行德。第九会宗唯略无广。略明如来入法界境。此九会中入定分齐等如纲目说。已说法门各有几品说其法门。颂曰

  初二三各六　　四四五三品
  六一七十一　　八九各一品
  初会世如普　　世华舍那品
  二会如四光　　菩萨净首品
  三会升须十　　梵初明法品
  四会升夜十　　十无尽藏品
  五会升兜十　　六会十地品
  七会定通忍　　阿寿住处品
  佛如如普贤　　如来出现品
  八会离世间　　九会法界品

释曰。颂中初一行颂总举品数。后四行颂别列品名。颂中存略不显卷数。初会六品尽十一卷。第二会六品合尽四卷。第三会六品合尽三卷。第四会四品合尽三卷。第五会三品合尽十二卷。第六会一品合尽六卷。第七会十一品合尽十三卷。第八会一品合尽七卷。第九会一品合尽二十一卷。初会六品者一世主妙严品合尽五卷。晋经名世间净眼品。二如来现相品唯第六卷。品名旧无。三普贤三昧品第七卷初。品名旧无。四世界成就品第七卷半。品名旧无。五华藏世界品第八九十。品名旧无。以上四品晋朝合名卢舍那品。六毗卢舍那品第十一卷。旧无毗字。第二会六品者一如来名号品第十二卷初。新旧同名。二四圣谛品第十二卷半。旧无圣字。三光明觉品第十三卷初。旧加如来二字。四菩萨问明品第十三卷半。旧云菩萨明难品。五净行品第十四卷初。新旧同名。六贤首品第十四卷半尽十五卷。新旧同名。第三会六品者一升须弥山顶品第十六卷初。旧加佛字。二须弥顶上偈赞品第十六卷初次。旧云菩萨云集妙胜殿上说偈品。三十住品第十六卷半。旧云菩萨十住品。四梵行品第十七卷初。新旧同名。五初发心功德品第十七卷半。旧云初发心菩萨功德品。六明法品第十八卷全。新旧同名。第四会四品者一升夜摩天宫品第十九卷。初旧云佛升夜摩天宫自在品。二夜摩宫中偈赞品第十九卷初次。旧云夜摩天宫菩萨说偈品。三十行品第十九卷半尽二十卷。旧云功德华聚菩萨十行品。四十无尽藏品第二十一卷全。新旧同名。第五会三品者一升兜率天宫品第二十二卷全。旧云如来升兜率天宫一切宝殿品。二兜率宫中偈赞品第二十三卷初。旧云兜率天宫菩萨云集赞佛品。三十回向品第二十三卷半尽三十三。旧云金刚幢菩萨回向品。第六会一品者谓十地品。新旧同名。起三十四尽三十九。晋朝经从十地品至宝王如来性起品合十一品为第六会。唐朝经十地品次有十定品。故开为二会如前已说。第七会十一品者一十定品第四十尽四十三。旧无今有。二十通品第四十四卷初。旧云十明品。三十忍品第四十四卷半。新旧同名。四阿僧祇品第四十五卷初。旧云心王菩萨问阿僧祇品。五寿量品第四十五卷末。旧云寿命品。六诸菩萨住处品第四十五卷末次。旧云菩萨住处品。七佛不思议法品第四十六七全。旧云佛不思议品。八如来十身相海品第四十八卷初。旧云如来相海品。九如来随好光明功德品第四十八卷半。旧云佛小相光明功德品。十普贤菩萨行品第四十九卷全。新旧同名。十一如来出现品第五十尽五十二。旧云宝王如来性起品。第八会一品者谓离世间品。第五十三尽五十九。新旧同名。第九会一品者谓入法界品第六十尽八十。新旧同名。已说品数能说品佛其相云何。颂曰

  无愿业住涅　　法心三性如
  安出信随永　　无安无决普

释曰。颂中上半列十佛名。下半如次释名所因。说经教主有其十种。何等为十。一无著佛安住世间成正觉故。二愿佛出生故。三业报佛信故。四住持佛随顺故。五涅槃佛永度故。六法界佛无处不至故。七心佛安住故。八三昧佛无量无著故。九性佛决定故。十如意佛普覆故。初无著佛安住世间成正觉者亦名正觉佛。着是众患之本。觉是诸德之元。无邪患而不离故名无著。无正德而不圆故名正觉。此是总佛。余九别佛。以别成总。故于总开别。愿佛出生者谓如理智穷无生际方能出生无量佛事。即是大愿。故名愿佛出生故。业报佛信者谓无量相好庄严色身。无量善业所感之报。故名业报。所以感得妙色身报为令见者咸归信故。举所为意以显业报佛。故名信。住持佛随顺者谓佛圆音周遍三世住持佛法无穷无尽。顺一切智无穷尽故名住持佛随顺故。涅槃佛永度者说门之中名为化佛。化现灭度非实灭故。所以涅槃非实灭者永度生死生灭法故。故名涅槃佛永度故。法界佛无处不至者谓无碍法界即佛体名法界佛。智慧光明亦同法界无处不至。是故亦名为法界佛无处不至故。心佛安住者谓正直心安住所缘。故名心佛安住故。三昧佛无量无著者谓佛三昧无量无边思议解脱。故名三昧佛无量无著故。性佛决定者谓如来性即是本觉。本性自觉非修所成故名性佛。于染净位决定不改能生十决定之法故名决定。如意佛普覆者谓神力自在名如意佛。周遍一切故名普覆。上十佛中各有十义广如经说。法集经中亦名十佛。彼云菩萨入十种法能知诸佛。何等为十。谓习气佛果报佛三昧佛愿佛心佛实佛同佛化佛供养佛形像佛。乃至广说彼与此经所说十佛十数虽同体相大异。然约六相分别十佛。如论说言一切十句皆有六相。何者为六。一者总相二者别相三者同相四者异相五者成相六者坏相。今就十佛显此六相。谓初一佛无佛不摄。故名为总相。即后九佛于一开九。故名别相。十同离着。故名同相。十用各异。故名异相。揽九成一一佛圆满。故名成相。分一作九九外无一。故名坏相。如是已说说品十佛。品中法数其相如何。颂曰

  初治修生具　　正不童王灌
  欢饶无无无　　善无尊善真

释曰。颂中上半颂十住法。下半如次颂十行法。品中法数虽有多种今且随名以显其数。菩萨所修虽有多门探其纲要不过八种。何等为八。一十住二十行三十藏四十向五十地六十定七十通八十忍。云何十住。一初发心住二治地住三修行住四生贵住五具足方便住六正心住七不退住八童真住九法王子住十灌顶住。释此住名大分为二。初总后别。初总名者菩萨在此创安其心于六度等行未殊胜但得住名。后别名者一此位菩萨创首发于大菩提心名发心住。二此位菩萨净治三业悲及有识名治地住。三此位菩萨修胜理观起上妙行名修行住。四此位菩萨从诸圣法正教中生名生贵住。五此位菩萨所修善根皆为救物名具足方便住。六此位菩萨所闻赞毁心定不动名正心住。七此位菩萨闻说三宝三际有无心坚不转名不退住。八此位菩萨三业清洁悟二世间真简虚伪童表无咎亦犹涅槃婴儿之行名童真住。九此位菩萨解真俗谛悟法王法将有所袭名法王子住。十此位菩萨如王太子堪受王位行渐胜故名灌顶住

问曰。发心有三。一信成就发心。二解行发心。三证发心。今言初发心三中何摄耶

答曰。三发心中是信成就发心摄。所以然者信成就发心位在十解位即是正定聚位也。解行发心位在十行十回向即是初僧祇将满位也。证发心位在初地上即是证真如位也。此义如起信论中广说。已说十住。云何十行。一欢喜行。二饶益行。三无恚恨行。四无尽行。五无痴行。六善现行。七无著行。八尊重行。九善法行。十真实行。释此行名亦有二。初总后别。初总名者此位菩萨行六度等诸行胜故名之为行。后别名者一此位菩萨为大施主一切能舍。三时无悔利誉不悕愍生慕法。睹者欢敬名欢喜行。二此位常持净戒不染五欲。能伏众魔一切众生立无上戒。得不退地名饶益行。三此位常修忍辱谦卑恭敬。和颜爱语不害自他。悟身空寂怨对能忍名无恚恨行。四此位假设多劫受诸剧苦。求法济生念念不息名无尽行。五此位常住正念恒无散乱。于一切法乃至生死入住出胎无有痴乱名无痴行。六此位善入人法皆无性相。三业寂灭无缚无著。而复不舍化众生心。巧能随类现生救物名善现行。七此位历诸尘刹供佛求法。传灯度生心无厌足。然以寂灭观诸法故而于一切心无所著名无著行。八此位尊重善根智慧等法皆悉成就。而由得斯诸尊重法二利之行更增修习名尊重行。九此位得四无碍陀罗尼门诸善慧法。能为众生作清凉池守护正法佛种不绝名善法行。十此位菩萨成就第一诚谛之语。学三世佛真实之语无二之语。如说能行如行能说语行相应心境皆顺名真实行。如是已说住行二位。十藏十向其相云何。颂曰

  信戒惭愧多　　施慧念持辩
  救不等至无　　随等如无入

释曰。颂中上半颂十藏法。下半如次颂十向法。实行菩萨更修十行进趣十向。是故行后方说十藏。又十住下贤十行中贤十向上贤。从浅至深从粗至细。是故行后方说十藏。云何为十。一信藏二戒藏三惭藏四愧藏五多闻藏六施藏七慧藏八念藏九持藏十辩藏。释此藏名亦有二种。初总后别。初总名者信等十行一一体含无限法界生无尽果故名为藏。后别名者一此位菩萨三空三性。如是法中顺生深信闻难思法心不怯弱。于诸佛所一向坚信深知佛慧心不退散。护持佛种增长信解。随顺善根出生方便。时处应机开悟一切。如是业用非一众多。是名菩萨信藏。二此位具足受持三种净戒。普益一切不受邪戒。不住三界心住无悔。不违先制不学外事。不着诸见不彰己德。不自高慢永断杀等。众生垂愍是业非一。是名戒藏。三此位于三世法断无惭行深生悔羞。广为众生说真实法是业非一。是名惭藏。四此位自愧昔过深于自身生厌离想。于三世佛深修愧行。广为众生说真实法是业非一。是名愧藏。五此位于一切法多闻博学。十二缘生漏无漏蕴。有为无为记无记法。如是法中深生正解。为诸众生说真实法是业非一。是名多闻藏。六此位行十种施。所谓分减施竭尽施内施外施俱施。一切施去来今施究竟施。于如是施无毛悭心。三轮清净其心不止。能舍一切令受安乐是业非一。是名施藏。七此位生死因果深究本源得无尽慧。为生说法是业非一。是名慧藏。八此位得具足念明忆前生。得无尽念忆无量劫。于一切法忆念不忘是业非一。是名念藏。九此位于佛所说修多罗文句义理无有忘失。一生乃至不可说生总持不忘。于一佛号乃至不可说佛号广说乃至一三昧乃至不可说三昧陀罗尼用无有休息是业非一。是名持藏。十此位菩萨有深智慧了智实相。为生说法不违佛教。一品乃至不可说品广说乃至一三昧乃至不可说三昧。如是等法广为众生或一日说。广说乃至不可说不可说劫说。劫数可尽一文一句义理难尽。得如是等无量辩才为诸众生说真实法。如是业用非一众多是名菩萨辩藏。已说十藏。云何十向。一救护众生离众生想回向。二不坏回向。三等诸佛回向。四至一切处回向。五无尽功德藏回向。六随顺一切坚固善根回向。七等心随顺一切众生回向。八如相回向。九无缚无著解脱心回向。十入法界无量回向。释此向名亦有二种。初总后别。初总名者至斯位已凡所修行。皆为回向无上菩提立回向名。后别名者一此位菩萨所行六度四摄法等。悉为救摄一切有情令离生死得涅槃乐名救护生。入平等观不见怨亲众生等相名离生相。二此位于三宝所得不坏信。因持诸善回向众生令获善利名不坏回向。三此位学三世佛不着生死不离菩提修回向事名等诸佛回向。四此位修习一切诸善根时以彼善根如是回向。令此善根功德之力至于一切三宝之所一切世界众生之所作诸供养利益之事。譬如实际无处不至名至一切处回向。五此位修悔过善根离一切业障。于诸如来一切众生所有善根皆悉随喜。以此善根悉皆回向庄严一切诸佛净刹。常作佛事善巧方便具诸功德离诸虚妄。而无所著由回向已得无尽善根。名无尽藏功德回向。六此位以内外财随众生意而惠施之。见诸苦者悲以身代坚固安住自在功德。以如是等诸善功德而回向已。令一切生得大智慧除灭大苦。名随顺一切坚固善根回向。七此位而能增长一切善根修习究竟安住忍力。闭恶趣门永离颠倒不着诸行。一切善根皆悉回向为一切众生作功德藏。普覆一切拔出生死令得众善等无差异。名等心随顺一切众生回向。八此位成就念智安住不动。心无所依寂然不乱。不违一切平等正法严刹度生。所修诸善皆顺如相而为回向。名如相回向。九此位所摄善根离憍慢等所有缚着。得解脱心行普贤行。所习诸善不执为已及以他人。以无缚着解脱之心回向饶益品物一切。故名无缚无著解脱心回向。十此位菩萨离垢缯系顶。受大法师记法施化生。严净世界出生智等。悉同虚空而无限量。凡有善根修于回向悉等法界。故名法界无量回向

问曰。此位初首而有十信。谓信进念慧定施戒护愿回向。计心四十。何故但言三十心耶

答曰。即十住中初住离出。以初发心而甚难故故离出也。设有圣教言四十心当知即据总别说也。理实三十。如四善根十回向中第十离出。谓法界无量回向也。已说藏向。十地云何。颂曰

  极离发焰极　　现远不善法

释曰。谓十地中修十胜行断十重障证十真如。菩萨万行皆十地摄。十行十障十真如等如唯识论中广说应知。云何十地。一极喜地二离垢地三发光地四焰慧地五极难胜地六现前地七远行地八不动地九善慧地十法云地。释此地名亦有二种。初总后别。初总名者与所修行为胜依持令得生长故名为地。摄大乘云法无我智分位名为地等。后别名者一此地菩萨始入于圣证二空理。能利自他生大喜乐。是故此地名极喜地。二此地具清净戒弃破戒非。破戒惑法染污行人名之为垢。此地能舍名离垢地。三此地由得胜定及殊妙教四种总持。以此为因能起三慧。三慧而能照法显现名之为光。此地定等能起慧光所以此地名发光地。四此地妙慧殊胜能断烦恼如火焚薪。是故此地名焰慧地。五此地能令俗谛有分别智而与真谛无分别智同时起。以互违法令不相违一时并生。此行胜前故名极难胜地。六此地能起胜智观十二缘。不作染净二差别行有此胜智生起。故名现前地。七此地唯修无相不起功用。功用之行创绝斯地。是以此地无相之行逾于二乘世间等行。故名远行地。八此地妙无相智。不被一切有相功用及诸烦恼而能鼓击。故名不动地。九此地得胜妙智能善说法以利含识。故名善慧地。十此地而有胜智能藏众德。能断诸障能遍法身。义同于云能蔽于空而含于水。故名法云地。此十地义如瑜伽唯识等中广说应知

问曰。有圣教中说干慧等十地。与此十地有何差别耶

答曰。干慧等十三乘共行。今此十地唯菩萨行。是故差别。云何为十。一干慧地谓暖前位。二性地谓暖等位。三八人地谓见道十五心。四见地谓第十六心。五薄地谓斯陀含。六离欲地谓阿那含。七已办地谓无学果。八独觉地。九菩萨地。十如来地

问曰。如上所说十地菩萨。谁住几佛国谁作何等王谁修几法门耶

答曰。初地菩萨住百佛国作阎浮四天王。修百法门二谛平等心化一切众生。二地住千佛国作忉利天王修千法门。三地住十万佛国作炎天王修十万法门。四地住百亿佛国作兜率天王修百亿法门。五地住千亿佛国作化乐天王修千亿法门。六地住十万亿佛国作他化自在天王修十万亿法门。七地住百万亿佛国作初禅王修百万亿法门。八地住百万微尘数佛国作二禅梵王修百万微尘数法门。九地住百万亿阿僧祇微尘数佛国作三禅大梵王修百万亿阿僧祇微尘数法门。十地菩萨住不可说不可说佛国中作第四禅大静天王三界主。修不可说不可说法门得理尽三昧。尽三界原化一切众生。此义如仁王般若经中广说应知

问曰。第五地中真俗并观故名难胜。何故仁王经菩萨教化品。说善觉菩萨四天王。双照二谛平等道。权化众生游百国。始登一乘无相道。此文则说初地菩萨照二谛平等道。如是违文当得会释耶

答曰。双照有二义。一前后双照。二同时双照。今约第二故名难胜。故无有失

问曰。约位有六。一资粮位二加行位三见道位四修道位五等觉位六妙觉位。如上诸位与此六位相摄云何

答曰。地前所有三十心中。前二十九心全第三十少分属资粮摄。三十少分属加行摄。于初地中有入住满。入位属见。住满以上属修道摄。金刚心中有二刹那。无间道位属等觉位。解脱道位属妙觉位

问曰。六位名体其相云何

答曰。言资粮者资益己身之粮名为资粮。欲趣菩提要资于行。此位创修入佛之因名资粮位。即此位亦名顺解脱分。言解脱者所谓涅槃。离烦恼缚名为解脱。即所求果。顺者不违。分者因义。即所修行不违于果。是果之因名解脱分。言加行者加功用而行趣见道故名加行。即此位亦名顺决择分。言决择者体即是智。决简于疑疑不决故。择简于见见不择故。智异于彼故名决择。分者支分。此决择体即是见道。七觉支中是其一支。故名为分。顺者趣向欣求之义。加行位暖等善根欣求趣向彼决择分。故暖等善名顺决择。此之二位克性皆以有漏加行智为其体性。然加行位有四别位。一暖二顶三忍四世第一法。言暖者此位菩萨初得见道火之前相故名为暖。见道体即能断烦恼。如火烧薪故喻于火。暖位菩萨未得火体而得火相故名暖也。顶者此位菩萨依寻思智观所取空。此位功极故名为顶。顶者极义。如山之顶上之极也。忍者印可达悟之义。此位菩萨知妄执识及心外境其体皆空故名为忍。世第一法者此位菩萨所得智等。一切世间所有法中无先此者名世第一。言见道者亦名通达位。菩萨无漏之智了证真如故名通达。初照理故亦名见道。道游履义。行人游履趣于极果。或通运义通运行人至于极果故名为道。然此见道有其二种。一真见道体离虚妄亲能证理实能断障故名为真。又真者是理。见者是智。证真之智名真见道。二相见道相者类似之义。真见道后而起于此。行解安模仿像真见所有功能。不能证理及断于障类似于真故名相见。言修道位者具云修习。此位菩萨而更进修无分别智断所余障故名修习。即极喜等十地名修习位。前真相二道克性出体根本后得无漏二智为其体性。后修习位皆以有为无为诸功德法以为自体。言等觉位者等者相似义。此位所作皆似佛果故名等觉。觉者佛果胜智也。言妙觉者妙者最胜之义。二乘所得菩提涅槃非最胜妙。唯佛独能所作皆办功德最胜故名妙觉。前等觉位以菩萨胜智为体。后妙觉位以佛果四智为体。举能取所故且论智。理实涅槃亦是二位之体也。如是已说十地差别。十定通忍其相云何。颂曰

  普妙次清知　　智了众法无
  他天宿知成　　住善出一一
  音顺无如如　　如如如如如

释曰。颂中上半颂十定法。次半如次颂十通法。后半如次颂十忍法。此定等法十地胜进。故十地后方说十定。即六位中第五位也。言六位者一十住位二十行位三十向位四十地位五无垢地六妙觉地。此义如本业经等广说应知。云何十定。一普光大三昧二妙光大三昧三次第遍往诸佛国土大三昧四清净深心行大三昧五知过去庄严藏大三昧六智光明藏大三昧七了知一切世界佛庄严大三昧八众生差别身大三昧九法界自在大三昧十无碍轮大三昧。云何十通。一他心智通二天眼智通三宿住随念智通四知未来际劫智通五成就无碍清净天耳六住无体性神智通七善分别一切众生言音智通八出生无量阿僧祇色身庄严智通九一切法智通十一切法灭尽三昧智通。云何十忍。一音声忍二顺忍三无生法忍四如幻忍五如焰忍六如梦忍七如响忍八如影忍九如化忍十如空忍。此三法中初云定者。梵云三昧此云等持。离于沉掉专注一境持心不散。是定住义故以等持而名为定。次云通者亦名神通。妙用难测曰神。自在无碍名通。同名智者缘境无壅名通。通是智用故云智通。后云忍者于所闻法忍解印可纳受。体即是智。如是诸义如经广说。恐繁不具。如上法门普机所入。以何为门能入彼法。此能入门略有十种。颂曰

  同因秘微十　　诸一诸随托

释曰。此半颂颂法门能入。七处九会所说诸法皆以十门为彼能入。故法门后方说十门。何等为十。一同时具足相应门。二因陀罗网境界门。三秘密隐显俱成门。四微细相容安立门。五十世隔法异成门。六诸藏纯杂具德门。七一多相容不同门。八诸法相即自在门。九随心回转善成门。十托事显法生解门。释此十门略有二门。一立义门二解释门。初立义门者略立十义门以显无尽。何者为十。一教义即摄一乘三乘乃至五乘等一切教义余可准之。二理事即摄一切理事。三解行即摄一切解行。四因果即摄一切因果。五人法即摄一切人法。六分齐境位即摄一切分齐境位。七师弟法智即摄一切师弟法智。八主伴依正即摄一切主伴依正。九随生根欲示现即摄一切随生根欲示现。十逆顺体用自在业等即摄一切逆顺体用自在业等。此等十门为首皆各总摄一切法成无尽也。又有十义。一色二心三时四处五身六方七教八义九行十位。色者谓外器世间能造所造。下至微尘上至广刹及中一切所有事物。心者谓佛菩萨及诸众生所有染净心及心法。时者谓迦罗时三摩耶时。大劫小劫九世十世下至一刹那等。处者谓十方世界依色所显大小分量。上至广刹下至一尘毛端等处。身者谓佛身菩萨身二乘人身乃至一切众生身。下至一毛孔上至全身。方者东方南方乃至上方。上至尽十方虚空界下至一毛端量处。教者谓能诠名句字声及通一切。下至一名一句一声一光香等上至种种无量差别名句字等。义者谓教之所诠一切法门。下至一义上至一切。行者谓诸菩萨所有修行无边行海。下至一行上至无尽。位者谓三贤十地等。上至满位下至十住初心等。此上二种十义文异义同。后解释门者亦以十门释前十义以显无尽

问曰。所以得知十数显无尽者

答曰。依华严经中立十数为则以显无尽义。初同时具足相应门者。此上十义同时相应成一缘起无有前后始终等别。具足一切自在逆顺参而不杂成缘起际。海印定中炳然同时显现成矣。此经第七卷普贤三昧品云。能令一切国土微尘悉能容受无边法界等。释曰此一普贤身遍十方一切世界尘内无边佛会中。一一毛孔现法界中所有诸法莫不皆令同时具足。此且约业用门说也。又第八卷华藏品云。华藏世界所有尘一一尘中见法界(云云)。释曰此约德相门说也。二因陀罗网境界门者。此但从喻异前耳。此上诸义体相自在隐映互现重重无尽。此经第七卷普贤三昧品云。佛身所现一切国土及此国土所有微尘一一尘中有世界海尘数佛刹。一一刹中有世界海尘数诸佛。一一佛前有世界海尘数普贤入此三昧(云云)。释曰此且约业用门说也。三秘密隐显俱成门者。此上诸义隐覆显了俱时成就也。此经第十九卷夜摩宫中偈赞品云。十方一切处皆谓佛在此。或见在人间或见在天宫(云云)。释曰此约德相门说也。如佛身隐显既尔当知。言音依果所有及一切法门教义行位等亦然。诸大菩萨成就如是法界体事德相者并准可知。四微细相容安立门者。此上诸义于一念中具足始终同时前后逆顺等一切法门。于一念中炳然同时齐头显现无不明了。犹如束箭齐头显现耳。此经第三十一卷十回向品云。此菩萨于一念中现一切众生各不可说不可说念劫心等。又第六十八卷入法界品云。一一毛孔内各现无数身。一一毛孔内示现无量刹等(云云)。释曰此亦约业用门说也。五十世隔法异成门者。此上诸义遍十世中同时别异具足显现。以时与法不相离故。言十世者过去未来现在三世各有过未及现在即为九世。然此九世迭相即入故成一念。总别合成十世也。此十世具足别异同时显现成缘起故得即入也。此经第五十三卷离世间品云。佛子菩萨摩诃萨有十种说三世。何等为十。所谓过去世说过去世。过去世说未来世。过去世说现在世。未来世说过去世。未来世说现在世。未来世说无尽。现在世说过去世。现在世说未来世。现在世说平等。现在世说三世即一念是为十。菩萨以此普说三世。又彼卷同品云。入可数劫即不可数劫。入不可数劫即可数劫。入一切劫即非劫。入非劫即一切劫。入一切劫即一念等(云云)。六诸藏纯杂具德门者。此上诸义或纯或杂。如前人法等若以人门取即一切皆人故名为纯。又即此人门具含理事等一切差别法故名为杂。此经第二卷妙严品说诸异生众及余同生各各唯得一解脱门是纯门也。第五卷同品中说普贤菩萨得不思议诸解脱门是杂门也。六十五卷入法界品云慈行童女见三十六恒河沙佛。彼诸如来各以异门令慈行入般若波罗蜜普庄严门者此纯杂无碍也。七一多相容不同门者。此上诸义随一门中即具摄前因果理事一切法门。然此一中虽具有多仍一非即是其多耳。余一一门中皆悉如是重重无尽。此经第二十卷十行品云。能于一一三昧中普入无数诸三昧。乃至云无量无边诸国土悉令共入一微尘等(云云)。八诸法相即自在门者。此上诸义一即一切一切即一圆融自在无碍成耳。所以然者圆融法界无尽缘起。一若无时一切并无。若得一时即得一切。因果俱齐无前后别。此经第十七卷发心功德品云。此初发心菩萨即是佛故。旧经第九卷梵行品云。初发心时便成正觉。知一切法真实之性具足慧身不由他悟等(云云)。新经文异披勘可知。九随心回转善成门者。此上诸义唯是一如来藏自性清净心转也。但性起具德故异三乘耳。此经第十九卷夜摩宫中偈赞品云。譬如工画师分布诸彩色虚妄取异色大种无差别。乃至云若人欲了知三世一切佛应观法界性一切唯心造。又第三十七卷十地品云。佛子此菩萨摩诃萨复作是念。三界所有唯是一心。如来于此分别演说十二有支皆依一心如是立等(云云)。世亲释云。唯是一心者一切三界唯心转故。云何世谛差别。随顺观世谛即入第一义谛等(云云)。十托事显法生解门者。此上诸义随托别事以显别法。谓诸理事等一切法门。如见此华叶即是见于无尽法界。此经第二十二卷升兜率天宫品云。有百万亿初发心菩萨。才见此座倍更增长一切智心。又彼卷同品云。无生法忍所生一切衣等(云云)。释曰一切供具皆悉从无尽法门所生。是故见一法即通达一切法门。是唯普眼境界非余境界。此上十门随一门中即摄余门无不皆尽

问曰。此上十门以六相融其义云何

答曰。一切十句皆有六相故可圆融。谓相有六种。一总相二别相三同相四异相五成相六坏相。初一门中无门不摄故名总相。后九种门于一开九故名别相。十门相资各不相违同成一总故名同相。十门相望其义各异故名异相。揽九成一一门圆满故名成相。分一作九九外无一故名坏相

问曰。此上十门所建所以其义云何

答曰。此上十门中各有十义。一人法二教义三因果四理事五解行六分齐境位七师弟法智八主伴依正九逆顺体用十随生根欲示现。此等十义皆同时相应成一缘起。故有同时具足相应门。此上诸义随缘起力重重无尽。故有因陀罗网境界门。此上诸义缘起有无各不异。故有秘密隐显俱成门。此上诸义同体门中摄法已尽。故有微细相容安立门。此上诸义各分三际。故有十世隔法异成门。此上诸义体用各隔犹有纯杂。故有诸藏纯杂具德门。此上诸义全力全无力。故有一多相容不同门。此上诸义各有空有义。故有诸法相即自在门。此上诸义缘起自性。故有随心回转善成门。此上诸义各托事解。故有托事显法生解门

  今造如是　　嗢陀南颂　　为欲初学
  易悟性海　　若有见闻　　必愿力故
  得无师智　　登普贤道

新译华严经七处九会颂释章(终)


华严游意

    No. 1731 [cf. No. 278]

华严游意

        慧日道场沙门胡吉藏撰

且话阎浮得有此经录虽不载相承云。龙树有佞弟子劝其师令与释迦并化。师智德如此。宜作新佛。岂为释迦弟子即。然其所言克日月。别制新戒新衣使大同小异。坐水精房中思惟斯事。时有大龙菩萨伤而愍之便接还龙宫。示三世诸佛无量经。复示过去七佛经。于龙宫九旬读十倍阎浮。所余题目不可周遍。龙树从龙宫出。龙王以此一部经送龙树出。为此因缘故阎浮提得有此经也

江南讲此经者亦须知其原首。前三大法师不讲此经。晚建初彭城亦不讲。建初晚讲。就长干法师借义疏。彭城晚讲不听人问未讲之文。前三大法师。后二名德。多不讲此经。讲此经者起自摄山。时有胜法师为檀越教化。得三千余解未凡经七处。徒八过设会。始自慧庄严终归止观。一会则讲一会经文。尔时实为隆盛。后兴皇继其遗踪大弘斯典。讲因缘如此也。然此经义正开二佛两教门净土三十心十地等。今略明净土义。净土凡有四条。一化主。二化处。三教门。四徒众。此之四种束为两双。化主化处即如来依正两果。化主即是正果。化处即是依果。即依正一双。教门徒众即缘教一双教门即缘教。徒众即教缘故。是缘教一双。虽有四条束为两意也。然非但净土有此四条。三世十方诸佛土一一土中皆具此四条。三世十方土虽复无量不出十种土。十种土者。一净。二秽。三杂。四本净末不净。本是净土。后薄福众生本净反为秽。此名本净今秽也。五者本不净末净。变向可知。此是释迦土。有五应现。复有五种合成十种土。十种土皆具上四条。据此十种两双。摄一切土尽也。十种之中略明净土一种。四条之内且辨化主一条也

问此经为是释迦所说耶为是舍那所说耶。兴皇大师开发初即作此问然答此之问。便有南北二解。南方解云。佛教凡有三种。谓顿渐无方不定也。言顿教者。即教无不圆理。无不满。为大根者说。所以经云。譬如日出先照高山。故言顿教。言渐教者。始自鹿园终至鹄林所说。经教初浅后深。渐渐而说。故称渐教。就渐教中有五时不同也。言无方不定者。进不及顿。退非是渐。随缘不定。故言不定教。问。此是大乘。为是小乘耶。解云。是大乘教。金光明胜鬘等经也。用此三经者欲释此经是释迦所说。何者此之三教是佛教。是何佛教。解云。是释迦佛一期出世始终有此三教。若使如此故知华严是释迦佛说也。释迦虽说此三教复不同。何者若是渐教无方教此是现前说。若是顿教遥说彼土人华。类如无量寿经释迦遥说彼西方净人华。今此国三辈往生。今此经亦尔。是释迦遥说莲华藏国土净人华也。次北方论师解。彼有三佛。一法。二报。三化。华严是报佛说。涅槃般若等是化佛说。法佛则不说。彼判舍那是报佛。释迦是化佛。舍那为释迦之报。释迦为舍那之化。华严经是舍那佛说。此则是南北两师释如此也

今次难此两师解。委悉述大师之言。前难南土解。释迦与舍那不异。今还用前四种责故不得一。一者化主异。涅槃般若是释迦佛说。七处八会是舍那佛说。舍那是本佛释迦是迹佛故。菩萨戒经云。我今卢舍那方坐莲华台。周匝千华上示现千释迦。故舍那是本释迦是迹。若使如此本迹不同那得为一。二者化处异。释迦在娑婆世界。舍那在莲华藏国。娑婆是杂恶国土。莲华藏界是纯净土。二处不同岂得为一。又娑婆国动则六种动。莲华藏动则十八种动。又台叶二处不同。舍那在台释迦在叶。二处如此之殊。何得为一耶。三者教门异。释迦则杂说三一。杂说半满。杂说但不但。舍那纯说一大。纯满纯不但。释迦赴杂缘说杂教。赴三一缘说三一教。乃至赴但不但缘说但不但教。舍那唯赴一大缘说一大教。乃至赴满不但缘说满不但教。若尔故不得为一也。四者徒众异。释迦具有三一杂缘但不但缘。如千二百声闻弥勒等菩萨则是杂缘也。舍那唯一大缘满缘。普贤菩萨等则是大缘。教既其异缘亦不同。缘既不同故。二佛不得为一。将此四条异弹南人解二佛不得是一也。次更前难何者彼云。释迦遥说莲华藏国。如释迦在此说无量寿国。然此解不知是谁解。山中师及兴皇师并述此释实不成释。好体不烦须难。何者汝既云舍那即释迦。何得言释迦遥说耶。但别有难。今更述之。何者释迦说无量寿凡有二种经。一者无量寿观经。二者无量寿经。无量寿观经为世王母韦提希夫人说。夫人在狱。令其观佛三昧。若是无量寿经为比丘十六正士说彼国土净人华。令此间五痛五烧三辈往生。若尔说无量寿国既有所为缘。释迦遥说莲华藏国。为何物缘。不见有解故不应言是遥说。好体不须难。大师既有斯言略而述了。此即是借北人异弹南人一竟

次借南人一弹北人异亦有两难。彼云。如此二佛有此四殊岂得为一。所以北讲华严。胜于南土。今次难之还用前四条。难一者。化主不得异。凡举三处文。难一者此经名号品是第二会。文殊菩萨说文云。或名卢舍那。或名释迦文。或名悉达多。既称或名何得言异。若使或名舍那或名释迦。而言异。或名眼或名目。亦应异。反诘云。第二像法决疑经云。或有见我为舍那。或有见释迦。此是缘见不同佛为何异。如有见佛身三尺。或有见佛身无边。如瞿师罗长者见佛短。大梵天王不见佛顶。只是一佛缘见异耳。若缘见舍那释迦则言二佛异者。缘见长短亦应为异。反诘云。若尔故不应言异也。次第三此经第六会在他化自在宫说十地法门。释迦放眉间白毫相光加金刚藏说。既是释迦劝金刚藏说十地。何得言是舍那说。若是舍那说应舍那放光劝。而今是释迦放劝。故不应言二佛调然迥异也。二者处所不得为异。说此经在摩竭提国寂灭道场。摩竭提还是摩伽陀。此乃是梵音之切缓。何关两所有异。若尔还是娑婆国说此经也。何以得知。涅槃经云。并及摩竭提阿阇世大王不久须臾至。阿阇世王即是摩伽陀国主。以此而言故知二处不异也。三者教门不得异。何者释迦说杂教。释迦说纯净教。释迦说半满教。释迦说纯满教。若为是释迦说纯净教耶。解云。释迦劝金刚藏说十地法门。是此经之中。故知释迦说纯净大教也。四者徒众亦不异。第八会具列大小乘众。列五百声闻身子须菩提等。若尔二佛徒众亦不异。若使言舍那唯为一大缘则应唯列一大乘众。何则具列大小众。为则具大小缘。又列既杂列。缘即是杂缘。教是杂教。又释迦大缘文殊弥勒等。更无别文殊弥勒。何异舍那。小缘身子须菩提等。无别身子须菩提等。若使如此故知。二佛徒众亦复不异。四种既其不异。何得释两佛调然有殊

第二别难者。彼云。舍那是报佛。释迦是化佛。舍那是释迦之报。释迦为舍那之化。师难云。此则回互二佛。翻覆世界。混乱教门。言回互二佛者。谓舍那自有报应。舍那自有本迹。释迦亦自有报应。自为本迹。何得指彼佛为此报。此佛为彼化。彼佛为此本。此佛为彼迹。若指彼佛为此报。此佛为彼化。即有二佛回互之失。言翻覆世界者。释迦自出华叶上。舍那自在华台上。二世界各自不同。何得指彼佛为此报。此佛为彼化耶。言混乱教门者。释迦赴大小缘说大小教。舍那为大缘说大教不同。何得以舍那为释迦本。释迦为舍那迹耶。前开借异以破一。此开就异以弹异。大而为言。前借北异弹南一。今借南一破北异。此则互借两家。弹彼二解竟

既斥南北一异两家皆非。彼即反问。汝既弹一异皆非。汝作若为别释耶。建初法师曾以此问兴皇一大学士云。舍那释迦为一为异耶。答云。舍那释迦释迦舍那。建初即云。我已解。若为解。既云舍那释迦释迦舍那。岂是一岂是异。作此一答彼即便解也。然何但非一异四句皆非。何者释迦是舍那。释迦岂得是异。乃至非异亦尔。又释迦舍那岂得是一。释迦舍那岂得是异。释迦舍那岂得是亦一亦异非一非异耶。虽非一异四句欲言一异四句亦不失因缘四句。何者释迦舍那岂一。不一而不失一。释迦舍那岂是异。不异而不失异。余两句亦尔。故非四句而不失四句。因缘无碍也。非一异四句而一异四句。并有其文义。何者文云。或名释迦。或名舍那。故不得其异。而台叶本迹不同故。不得为一。或为缘见是释迦。或有缘见是舍那。故得是亦一亦异。或有缘见非是释迦非是舍那。故得是非一非异。所以因缘无碍。无往不得也。然要须弹他四句乃得明今因缘四句。何者他语是亦须弹语非故。宜须弹语既是何须弹语耶。解云。语虽是而不得因缘无碍意。既其失意不成语故。若是若非皆悉须弹。以弹彼净。然后始得明今因缘无碍也。用此语者为对他家了非是。今时明因缘义但为对彼定义。南方定云一。北方定异。为破彼定一定异明今因缘一异。此语既答前之一异问也

次更别明一异四句。或成前意。此四句为异从来四句。言四句者。一则二佛说一教。二则一佛说二教。三则一佛说一教。四则二佛说二教。二佛说一教者。舍那释迦二佛。舍那是本。释迦是迹。本迹台叶不同故。是二佛一教者。涅槃华严一教。涅槃即华严。华严即是涅槃。故是一教也。一佛二教者。一佛即舍那释迦一佛。舍那即释迦。释迦即舍那。本即是迹。迹即本故。言本迹虽殊不思议一故。是一佛言二教者。涅槃华严二故云二教也。二佛二教者。舍那释迦二佛。涅槃华严二故。一佛一教者。释迦即舍那。涅槃即华严也。此是何物四句。解云。合离四句。二佛一教此则离人合教。离舍那释迦为二。合涅槃华严为一。一佛二教者。即合人离教。合释迦舍那为一佛。离涅槃华严为二教。二佛二教离人离教。一佛一教合人合教。斯四句作如此用也。所以用四句者欲答前问。前问云。二佛为一为异。今望此四句答。自有二佛说一教。自有一佛说二教。二佛说一教。舍那说华严即是说涅槃。释迦说涅槃即是说华严。一佛二教者。释迦说涅槃即是舍那佛说。舍那佛说华严即是释迦佛说。余二句可知。为是故不同他释也。前作舍那释迦释迦舍那语。此为对他家故作此说。然此语复别有义。何者为欲读经。经云。舍那在台上。释迦在叶上。此台是叶台。此叶是台叶。台叶岂是一岂是异。不得是一不得是异。詺作何物耶。詺作台叶。叶台也。台叶既尔。舍那释迦亦尔。问。台叶叶台成华。舍那释迦成一佛不。解云。得。难。得称是何物佛。台叶成一华华名莲华。舍那释迦成一佛佛名何物。解云。台叶成一莲华。舍那释迦为一应佛。台叶成莲华。莲华共一根。舍那释迦成一应。应佛同一本。本即是法身佛故。经云。十方诸如来同共一法身界故。二佛同一本。台叶共一根也。为是两义故。云舍那释迦释迦舍那也

次明二佛相开不相开义。言相开不相开者。二佛异。二土异。二教门。二徒众。言二佛异者。舍那释迦各开本迹。舍那开本迹者。舍那以法身为本。只舍那为迹。释迦开本迹亦尔。以法身为本。只释迦为迹。释迦法身为本。释迦为迹。然此迹中更开本迹。释迦是迹中本。此身更起他佛。即迹中迹。如大经受纯陀及大众供。受纯陀供迹中本身。受大众供即迹中迹。此一条既尔。类余亦然。释迦既有两重本迹。舍那亦有此两重本迹。法身为本。舍那为迹。然此迹中更开本迹。不起寂灭道场即迹中本。现身六天宫殿即迹中迹。故二佛有两重本迹。斯则二佛相开不相开义。恒须因缘语不得单道也

次明不相开相开者。法身为本。舍那为迹。好体只应有一重本迹。何者十方三世佛出世。唯为一大事因缘故出世。如法华为大事故出。谓开佛知见等。又如大品云。般若为大事故起。不可思议事故起。为无等等事故起。今舍那出世唯为一大事故出。唯为大根性者说一大因缘。故唯应有此本迹。十方三世诸佛正意只应如此。而今于迹中更开本迹者。但秽土中众生。罪重钝根不堪舍那大化。所以方便于迹中更开本迹。本则为净土大根性者说大因大果。迹即为秽土钝根者初说三乘教门。次说般若等。然后始得说法华涅槃等大乘之义。如火宅穷子等譬。初大乘化不得。方便说三乘。然后得说大乘。二佛亦尔。秽众生不堪舍那大化。更起迹佛方便初说三乘。后说大乘。为此义故。所以舍那迹中更开本迹。舍那为本释迦为迹。斯即是二佛不相开相开义。然十方三世诸佛本迹虽复无量。以相开不相开。不相开相开二句摄。则无所不尽。为是故明此二种也

次开四句成前义。四句者。一唯本而不迹。二唯迹而不本。三亦迹亦本。四非本非迹。用此四句安何处。用此四句安不相开相开义。不得漫用用须得处也。问。若为是唯本不迹乃至非本非迹耶。释云。但本不迹者即是法身故。经云。佛真法身犹如虚空也。言唯迹不本者即是释迦但是应身。亦迹亦本者是舍那。舍那望法身即是迹。望释迦即是本故。舍那亦本亦迹也。非本非迹者此则卷前三句。何者前。虽有三句只是本迹二句。法身是本。舍那释迦并是迹。此本是迹本。此迹是本迹。此本是迹本。非本无以垂迹。此迹是本迹。非迹无以显本。非本无以垂迹。由本故迹。非迹无以显本。由迹故本。由本故迹。迹是本迹。由迹故本。本是迹本。迹本则非本。本迹则非迹。斯即非本非迹清净。即本迹虽殊不思议一。舒则遍盈法界。卷即泯无踪迹也。前略明化主竟

今次辨化处。化处者亦有二处。一者舍那莲华藏处。二者释迦娑婆国处。亦得将前二佛类今二处。将正以类依。何者前。云舍那释迦释迦舍那。不得言一不得称异。不得言一亦得因缘一。不得称异亦得因缘异。故非一非异亦得因缘一异。今处亦尔。莲华藏娑婆娑婆莲华藏。不得言一不得称异。不得言一亦得因缘一。不得称异亦得因缘异。故二处非一非异亦得因缘一异。此则将正类依。在此依是正。依正既然类依亦尔。何者此正是依正。依正既然。正依岂当不尔。故二佛类二处亦非一异。而不失因缘一异也。次更将前两本迹类今化处亦有两条。一者二土各有本迹土。二者二处共论本迹土。二处各论本迹土者。前云舍那有舍那法身为本舍那为迹。舍那迹中更开本迹。今土亦尔。舍那法身即有舍那法身土。舍那迹则有舍那迹土。舍那迹中开本迹即迹中开本迹土。舍那既然释迦亦尔。问若为作耶。解云。舍那有舍那法身土也。问法身何须土。解云。法身土始是好土。何者以正法为法身即以正法为土。此之身土更无有异。正法为身即名法身。正法所迻托即名为土故。法身始有清净净土也。所以仁王经云。三贤十圣住果报。唯佛一人居净土。此则唯法身佛居清净第一义土也。言舍那为迹有舍那迹土者。故此经初会普贤菩萨说云。佛子。莲华藏是舍那过去誓愿力之所感故。此土是舍那迹土也。舍那迹土者。前云不起寂灭道场为本。现身六天宫殿为迹。余事无量寄此一条明耳。今还约此判本迹土。亦得但此义小局。今明舍那迹中本迹土者。莲华藏界即迹中本土。舍那既王十佛世界海即是迹中迹土也。释迦亦有此两重者。释迦有法身佛即有法身土。如舍那法身土无异。何者十方如来同共法身。法身既同。法身土亦无异。正法为法身。正法迻托为土也。释迦迹土即此娑婆世界是也。释迦迹中迹土者。约前迹中本迹亦得。何者受纯陀食为迹中本佛即为迹中本土。受大众供为迹中迹佛即为迹中迹土。但此事非一。如法华释迦佛及分身诸佛。释迦佛土为迹中本土。分身诸佛土为迹中迹土故。二佛土皆有此两重也

次明二佛共论本迹土。如法身为本舍那为迹。唯有一本一迹佛。亦以法身土舍那土唯是一本一迹土。十方三世佛唯为一大事故出现于世亦唯舍那正直之心成清净之土。但为薄福罪重钝根众生故。迹土中开本迹土。故为娑婆秽土。舍那莲华藏为迹中本土。释迦娑婆。为迹中迹土。故菩萨戒经云。我今卢舍那方坐莲华台。周匝千华上示现千释迦。一华百亿国。一国一释迦。如是百亿国有千百亿释迦。华有千叶一叶一释迦故有千释迦。一华有百亿国一国一释迦故有千百亿释迦也

次将本迹四句类本迹土亦有四句。一者唯本非迹土即是法身土。二者唯迹非本土即是释迦土。三者亦本亦迹土即是舍那土。望法身土为迹。望释迦土为本也。四者非本非迹土。还卷前三句。前虽有三句不出本迹二句。法身本舍那释迦二佛为迹。此是本迹迹本。本迹非本无以明迹。迹本非迹无以明本。非本无以明迹即由本故迹。非迹无以明本即由迹故本。由本故迹。迹是本迹。由迹故本本是迹本。本迹非迹。迹本非本。非本非迹清净。二佛既然两土类此可知。斯则卷三句成无句无。句成无句毕竟清净。虽复无句无句而句。则有依正句本迹句者。则三句为二句。二句为无句。今无句而句。一句而无量句。为量句而一句。无量句即一句。无量中解一。一句即无量句。一中解无量。无量中解一。此是无量一。一中解无量。此是一无量。无量一即非一。一无量即非无量。非一非无量而不失一无量。此言玄妙不易可闻也

次明二土相开不相开义。然土凡有五种。一净二秽三不净净四净不净五杂土。此之五土是僧睿法师所辨。斯之五土横摄一切土尽。何者只一净土中有无量净土故。华严经云。有百亿阿僧祇品净土。西方阿弥陀下品净土。圣服撞世界上品净土。净土既其如此。故知余四土亦复无量。所以云。此五种土横摄一切土尽。横既然竖即不定也。五种土中且明净秽二土。此有无量四句。且辨一种四句。四句者谓。一质一处。异质异处。异质一处。一质异处。此四句极自难解。今当影生师净土义。及关中法师所辨者而明之。然一质一处异质异处。此二句易解。余二句难明。且问。何者为质若为称处。解云。质即是净秽等。处即是方处之处。如净质在西方处。秽质在东方处也。所言一质一处者。一净质一秽质。一净质在西方安养处。一秽质在东方娑婆处。故言一质一处。言异质异处者。净秽互望。净质异秽质。秽质异净质故。言异质。净质处异秽质处。秽质处异净质处。故言异处也。言异质一处者。此句难解。异质一义亦名异质同义。异同在一处也。且明异质同处。若为是异质而同处耶。解云。净秽异质。同在一娑婆处。如此经莲华藏国。在娑婆处。净名经妙庄严国。在娑婆处。法华云。余众见烧尽。吾净土不毁。此并是净质在秽处。此略明净质同在秽土如此。次问。若为净质得在秽土耶。解此有数义。一者所以净质得在秽土者。净秽无碍。净无碍秽故。净得在秽处。秽无碍净故。秽得在净处。以不相碍故。净秽得同一处。旧举首天子为证。首天子是色界净天。来欲界秽处不相碍。首天子是三界中净三界。尚不碍三界秽。今莲华藏宝庄严国等。非三界非三界岂当碍于三界。吾净土不烧者。火是颠倒三界火。亦能烧颠倒三界。净土非是三界。三界火岂能烧不三界。火是秽火还烧秽。秽火岂能烧净。故吾净土不毁天人常充满也。又宝庄严国。只在一娑婆土中。掘凿娑婆。不掘凿宝庄严国。何者凿。是三界凿。只能凿三界。宝庄严国非三界。三界凿岂能掘非三界。色还凿色。色岂能凿妙则。此是什法师所解。从来弹此解。是他何处得此解。解是什法师解。什法师是三论师。即三论义应须云夺取他。是故净质得在秽处也。二者所以净土得在秽处且反问同处。汝言。那得此净土耶。今释言。此净土是如来净业所起。如来身既无碍所感之土。亦无碍身即依正土。即正依无碍依。感得无碍正依亦无碍。斯则正无碍故土无碍。以无碍故得在秽也

次问。何意净在秽处耶。前两义释净土得在秽处竟。今释净土在秽之意。问。何意净土在秽处耶。解此亦有二义。一者看华严净名等意。为欲教化众生故。明净土在秽处。只净土在此何意不见。汝薄福钝根断常居心不见耳。若道秽土在东方净土在西方不得化缘。何者净在西方秽土东方。两世界遥隔此不得为化。今道净土即在此。汝颠倒断常心故不见。谓弃妄存真舍无常取常乐。如此等居心心不净。心既不净故。不见净土。若见净土者。当须净心。除如此真妄常无常异。意清净乃名正观。以正观故则佛土净。为化此众生故。明净土在秽处也。二者所以净土在秽处者。为适缘所见。如来用净土。何为不如富人畜宝物安置屋里。如来用多许净土作底今明。如来以此净土。为欲适缘。故肇师云。圣人空同无像。岂国土之有垣。圣身尚未曾有。亦复未曾无。岂复有土与不土。圣人未曾像不像。亦复未曾心不心。未曾心不心。心生于有心。未曾像不像。像出于有像。未曾像不像。像不像适缘。缘出于有像。未曾土不土。土不土适缘。未曾净不净。净不净适缘。缘若应以秽得度者。示之以土沙。若应以净得道者。现之以宝玉。为此义故。所以净土在于秽处也。从来直云异质一处。不知何因缘故。净秽异质在一处。今释有如此义故也

次明一质异处。然前三句犹可解。此之一句最难一。何物质而在异处耶。解云。他举一质。如一净质在西土东土二处。一秽质在北南两处。为有此句为无耶。若无则不成四句。若有何者是其事耶。今就数义。明此一句。今且就净名经辨。只一妙喜净质。经东西二处。何者妙喜。一世界本在东方无动处。净名断取来西方娑婆处。若尔只一妙喜净质经游东西二处。如净土既然。类秽土等亦尔。故是一质二处也。向前异质一处。净秽二质。当在一处。今一质异处。亦应一净质。当在二处。今更据净名经释。彼经云。不可思议菩萨。以娑婆世界掷置他方国土。不动本处只捧娑婆。掷置西方安乐。而娑婆宛然不动。可谓。到而不动。不动而至。若尔只此秽质经东西二处。故是一质二处也。如秽质既然。类余四土亦尔也

次明只秽质在净秽二处。前明掷秽质往净处。秽质经二处。今明只一秽质在净秽二处。如莲华藏娑婆世界。只娑婆一秽质。在娑婆处。在莲华藏处。何者莲华。不但以台为莲华。叶共为一莲华故。涅槃云。台叶须等合为莲华。叶不离华。叶在华中。娑婆既居叶上。故知娑婆即在莲华藏中。所以菩萨戒经云。我今卢舍那方坐莲华台。周匝千华上示现千释迦。故知裟婆世界在华叶上。叶不离华故。娑婆不离莲华藏。若使如此娑婆秽土。非但在娑婆处。亦在莲华藏处。故知是一质在二处。问华藏自在台。娑婆自在叶。何得是一质在二处耶。解云。具二义。有时明娑婆与莲华藏异。娑婆界在莲华藏外。而复台叶共成。共成一叶。娑婆则不离莲华藏。何故如此。解云。欲明娑婆与华藏。不可言异。不可言一。二处异故。不可言一。不相离故。不可言异。不可言一而一。不可言异而异。斯则非一非异。而一而异。略明一种四句。如此今更通简此四句义。问云。他亦明此四句。与他何异。不得道他无此四句。经等具有此义故。他亦明此四句。今亦辨此四。何异。解他不得明此四句义。今时始得明此四句耳。何者虽有四句不出一异二句。他有一可一。不得由异故一。有异可异。不得由一故异。不由异故一。一自性一。不由一故异。异自性异。自性一一则碍异。自性异异则碍一。异既碍一。异岂得同处。异不得同一处则无一。既无一何得有异。既无一异。故四句不成也。纵之如此耳。夺则都无。何者有一可一。不由异起一。有异可异。不由一起异。不由异故一。一不成一。不由一故异。异不成异。一不成一则无一。异不成异则无异。此则无一异论。何物四句有一异可有四句。既无一异则无四句。故他不得明四句义。今时所明者。无四句而四句。要须前弹他有碍性义。始明今因缘无碍义。何者今无一可一。由异故一。无异可异。由一故异。由异故一则由一故一。一由一故异即由异故异。异可谓。无句而句。一句而二句。二句而四句。故大品经云。无句义是菩萨句义。今亦尔。无句而句。一句而四。四而无句。四句即一句。一句还无句。无句而句则非句。句而无句则非无句。非句非无句而句。始是菩萨无碍句。以无碍句故得一质在二处。二质在一处等。故今时明四句与他异也。他所以不得有此四句。他一异碍故。异不得在一处。一不得在异处。如两柱相碍故。不得容柱。何者柱是色。如释色是质碍义。柱是色。柱不容柱。土亦是色土不得容土。今时即无碍无碍故。所以一异互得相在。为是故他不得明此四句。今时始得辨此四句也。然此四句约事犹易解。后去四句转难也。

次更明一种四句。前地架明一种四句竟。今更明一种四句。渐深转妙。然前之四句众意不同他论。或同不同。若是今之四句非但意不同论然迥越。言四句者谓。异质一处。一质异处。一质一处。异质异处。言异质一处者。净秽质异故言异质。此净秽是因缘净秽。因缘净秽。非净无以明秽。非秽无以明净。非净无以明秽。秽是净秽。非秽无以明净。净是秽净。秽净则非净。净秽则非秽。非秽非净。净秽不二名为一处。斯则净秽二为异。非净非秽不二为一处也。言一质异处者。前二不二今名不二二。前净秽非净秽。今名非净秽净秽。非净非秽名净名秽。斯则非净非秽不二为一质。净秽二为异处反前也。言一质一处者。非净非秽质。非净非秽处不二为一质。不二为一处也。言异质异处者。净秽异质。净秽异处故。言异质异处也。大师正意在此四句也。问。此四句与前四句何异。解云。前四句约事而辨。今虽有四句只是非净非秽净秽净秽非净秽一句。开此一句以为四句。故与前异也。问。前亦言质言处。今亦言质言处。与前质处何异。解云。前以净秽为质。东西方为处。今言异质一处者。以净秽为异质。非净非秽为一处。只净秽宛然不非净秽。净秽宛然不而得动心。只二而不二。故二质在一处也。一质异处者。以非净非秽不二为一质。净秽二为二处。一质一处者。不二为一质。不二为一处。异质异处者。净秽二为质。净秽二为处。虽有四句后二句质处同前质处。意虽同而转为异。此复是一种四句也

次更明一种秽四句。四句者谓。一质二见。二质一见。一质一见。二质二见。此之四句初一句难解。后三句易明。且辨一质二见。何者是其事且举净名华严两经。净名经云。螺髻见金玉身子瞩土砂。此经第八会祇洹精舍诸大菩萨。见祇洹七宝所成。五百声闻见须达泥木所起。只是一质两缘见不同故。言一质二见也。今问。一质一何物质为一。秽质为一。净质为一。非净非秽质为一。此之三责便有三家解释。第一旧成实论师解云。一净质一秽质。只一净质。身子自见木。只一秽质。梵王自见金。祇洹亦尔也。次地论解云。一质是非金非木质。只如林树。有想心取则成有漏树。无想心取则成无漏林树。树未曾有漏无漏。随两心故有漏无漏。今亦尔。未曾净秽。净缘见净秽缘见秽耳。复有三论师。不精得一家意义者。监于此解。一非金非木质缘见金见木。此质未曾金木身子自见木。梵王自见金。名一质异见。今且难之。不难成论地论。难三论师解。三论既坏。所余自崩。何者汝非金非木一质。身子梵王见木金者。为当身子木非木非金。身子见木。梵王见金。为当梵王金非金非木。身子见木。梵王见金。为当离身子木梵王金别有非金非木。所以身子见木。梵王见金耶。且开此三关责。次第设难。若只使一身子木非金非木故。身子见木梵王见金者。身子之木既被烧。梵王金为被烧为不被烧。更开两关责此一句。若身子木被烧梵王金烧者则破业果。何者身子恶业感见木。梵王善业感见金。两业各感一果。身子业坏木自被烧。梵王不坏何得金亦被烧。又身子恶业可坏。梵王善业那应坏。恶业坏善业亦坏。地狱坏天堂亦坏而不尔故。身子木坏梵王金不应坏也。又且善业制不得坏。既共一木。恶业善业制那得坏耶。故不得同坏。若使身子木自坏。梵王金不坏则便二质。何谓一质二见耶。前关得一质则坏业义。后关得业义则坏一质义也。身子木非金非木见金木既尔。梵王金非金非木亦然。类前可知。次金木别有非金非木一质。二缘见二者。汝非金非木为当非此金木。为当不非此金木耶。若非金非木还非此金非此木。则金木共成非金非木。若尔还着前被烧难。何者既共一质烧木既烧金也。又若共成一非金非木质。两人见金木则皆颠倒。此质非是金。梵王见金既非颠倒。此木非是木。身子见木亦非倒。非是木。身子见木既倒。非是金。梵王见金亦倒。同皆非金非木。而言身子倒梵王不倒者同皆非金木。岂非梵王倒身子不倒。何以故同是非金木故也。若非金木非不金木者。则离金木别有非金非木者。既离金木何得别有非金木耶。又若离金木别有非金木。则成三体金木二体非金非木。复是一体故成三体。师云。如此一梨时两盛子。为非金非木一体时金木二体故不成义也。四句义此一句。且难未得解

今当解后三句。第二句云。二质一见者。此有三义。言二质者。净秽二质。言一见者。净秽是因缘净秽。非净无以明秽。非秽无以辨净。由净故言秽。由秽故称净。净是秽净秽是净秽。净秽不秽。秽净不净。只净秽不净秽。见二不二故。涅槃经云。明与无明愚者谓二。智者了达其性无二。无二之性即是实性。黑法白法净不净法亦尔。故是二质一见也。二者口净秽二质。深行菩萨并见是净。故大经云。一切世谛。若于如来成第一义谛。若俗若真于如来皆真。亦若净若秽。菩萨皆见净。亦如法华法师功德品云。若甘若苦等味至菩萨口皆成甘露。大品云。菩萨见产业之事。无非般若也。三者恶业众生。若净若秽。皆见秽。如饿鬼非但见彼处火。见恒河水亦是火。亦如狮子国采珠。福德人得珠。薄福人见珠成蛇。非但见蛇成蛇。见珠亦成蛇。以是故二质一见也。第三句言一质一见者。非净非秽质非净非秽见。斯则中道正土也。此之正土即是法身。波若涅槃此中道正土。本不曾净。今亦不曾秽。先不有今亦不无。非净非秽不有不无名为正法身。只此正法可迻托。名为正法土也。此正土何人所见。还以非净非秽正人所见故。言一质一见也。又言一质一见者。非净非秽方便秽质即有非净非秽方便秽见。秽既然净亦尔。非净非秽方便净质。即有非净非秽方便净见。故云一质一见。斯则前明方便实一质一见。今明实方便一质一见也。第四句二质二见者。非净非秽。净秽双游。净秽双现。如华台示现千释迦。华台舍那为本。释迦为迹。非本非迹。本迹双游。亦非净非秽。净秽俱现。即既双现双见故。云二质二见也。虽然语并相监。何者前第二句亦不二为一见。第三亦不二为一见何异。解前第二句见二不二为二质一见。第三句本不二见不二为一质一见。故与前异也

次明土有四种。一秽净土。二净秽土。三秽秽土。四净净土。言秽净土者。此是因缘净秽也。何者一往舍那释迦开净秽二舍那为净释迦为秽。此净秽是因缘净秽。非净无以明秽。非秽无以明净。故净是秽净。秽是净秽。故舍那是秽净。释迦是净秽。依果既然。正果亦尔。舍那是本释迦是迹此因缘本迹。非本无以明迹。非迹无以辨本。本是迹本。迹是本迹也。言秽秽土净净土者。此即众生颠倒业所感。以众生颠倒秽秽业故。感得秽秽土。颠倒净净业故。感得净净土。前之二句是众生颠倒所感也。问。秽秽土是颠倒业所感。净净土云何亦为颠倒业所感。颠倒业何得感净耶。解云。虽同颠倒颠倒中有重有轻。颠倒重故感秽秽土。颠倒轻故感净净土。虽同颠倒倒有重轻。虽同土土不同土有秽净也。今所化众生。虽同颠倒颠倒不同。有颠倒净净颠倒秽秽。前能化诸佛虽同方便方便不同。有净秽方便。有秽净方便。然土有此四。见亦有四。因缘净秽土。因缘秽净土。即诸佛菩萨因缘秽净见。因缘净秽见。众生秽秽土。净净土。则众生颠倒秽秽见净净见。故土有四见亦有四也。明见净秽土义未竟

更辨一秽四句者。一见秽不见净。二见净不见秽。三亦见净亦见秽。四不见秽不见净。此之四句约两处辨之。见秽不见净。见净不见秽。此两约何处辨耶。解云。且约祇洹而辨之。只是一祇洹。五百声闻唯见须达所起祇洹。不见法界祇洹。以其罪重薄福断常之心故。见秽祇洹丘陵坑坎。良由心有断常高下故。见祇洹丘墟高下之土。不见法界祇洹清净之土。既其如此余三亦然。唯见须达祇洹不见法界祇洹。唯见释迦受用不见舍那受用。唯见三乘徒众不见纯诸菩萨众。唯见三乘教不见纯一大教门。故言见秽不见净也。见净不见秽反前。如法界中普贤文殊等诸菩萨。则见法界祇洹不见须达祇洹。所以然者以诸菩萨心无断常故。不见丘墟之土。唯见法界祇洹不见须达祇洹。唯见舍那受用不见释迦受用。唯见大菩萨众不见三乘众。唯见大乘教不见三乘教。故言见净不见秽也。言亦见净亦见秽。不见净不见秽。此二句复约何处明耶。释云。此约华台辨好也。故经云。我今卢舍那方坐莲华台。周匝千华上示现千释迦。舍那是迹。本释迦是本迹。台是秽净叶是净秽。诸大行菩萨非但见舍那释迦本迹亦见释迦舍那迹本。非但见台叶净秽亦见叶台秽净。此则净秽双见。所以双见者师云。因中二慧果地二身。良由菩萨有二慧故。见诸佛二身。非但见迹亦见本。非但见本迹复见迹中无量迹。正既然依亦尔。故云亦见净亦见秽也。不见净不见秽者。即是二乘异常之人非但不见释迦舍那迹本。亦不见舍那释迦本迹。非但不见叶台秽净亦不见台叶净秽。所以不见二身两土者彼无二慧故。菩萨有二慧故见二身。既无二慧岂得见二身。非但不见本亦不见迹。非但不见本迹亦不见迹中无量迹。身既然土亦尔。故云不见净不见秽也。次更因前二句问后二句。何者前既言诸菩萨见净不见秽。复何意云诸菩萨亦见净亦见秽。前既言二乘见秽不见净。复何意云双不见耶

今更开一四句答此两四句者。一知而不见。二见而不知。三亦见亦知。四不知不见。言知而不见者。此句正取前菩萨见净不见秽义。所以言菩萨知而不见。菩萨知声闻以颠倒断常业感得丘墟不净土。知彼见此土而菩萨土。而菩萨净业净心而不见彼所见土。如佛知饿鬼恶业故见火。而佛不见彼所见火。故云知不见。释菩萨见净不见秽义也。言见而不知者。还是诸声闻。唯见释迦秽土。不知释迦是舍那释迦。不知秽是净秽。故云见而不知也。言亦知亦见者。菩萨知舍那是释迦舍那。知释迦是舍那释迦。知本是迹本。知迹是本迹。知本是迹本。见本即见迹。知迹是本迹。见迹即见本。本迹既然净秽亦尔。知净是秽净。知秽是净秽。既识净秽即见净秽也。既知本是迹本。知迹是本迹。知台是叶台。知叶是台叶。台一而叶多则知本一而迹多。知一是多一。知多是一多。知一是多一。无量中解一。知多是一多。一中解无量。无量不碍一。无量中解一。一不碍无量。虽无量而一。虽一而无量。无量一一无量。无量一非一。一无量非无量。非一非无量方便一无量。问若使本迹多一一多无碍。既本一而迹多。何不迹一而本多。解云。例如前所明。而今一往开本迹。本一迹多者。本是体故一。迹是随缘故无量。又本为一大缘故一。迹为缘不同故无量。本迹佛既然本迹土亦尔。知此本迹土见此本迹也。言不知不见者。凡有三意。一者约前明知本是迹本。知迹是本迹。见本是迹本。见迹是本迹。本迹既然净秽亦尔。今知无所知见无所见。知净秽宛然而未曾知净秽。见净秽宛然而未曾见净秽。只见净秽宛然而未曾净秽。如石室佛影譬。遥望相好宛然。至边一无所见。故言不知不见也。次意言不知不见者。二乘不知本是迹本。不知迹是本迹。不知净是秽净。不知秽是净秽。不见本不见迹。不见净不见秽。斯则[穴/俱]然不知不见。所以经中举譬云。如二人并眠一人上忉利天。见林苑婇女等事。一人[穴/俱]然不知不觉。菩萨与二乘亦尔。知见本迹净秽等事即彼二乘[穴/俱]然不知不见。所以作此释者经中有此言。今为释经故作此语。非是今时有义故作此释也。第三意言不知不见者。颠倒凡夫不知本。不见释迦迹身。亦不见释迦土也。虽有四句约三人。前知而不见菩萨望声闻。见而不见当声闻辨。亦知亦见当菩萨。不知不见是众生不知净秽亦不见净秽。此复是一节义意也

前明一质异见四句释三句竟。一句难而未解。即是一质异见句。今追解之。然成论地论释一质异见。所以着前种种责种种难者。良由彼有一质可一质。以有一质可一质故。所以着诸难。今明何曾此一质在中耶。若有此一质在中。则有他所投得为他所难。今明未曾一质。不一质而言一质异见者。明不莲华藏莲华藏不娑婆娑婆。不净净不秽秽。此则如来正土。非净非秽土净秽土出自两缘。如来正土未曾有未曾无。未曾净未曾秽。斯则非有非无非秽非净。不知何以目之。强名中道正土。即第一义土故。云一质二见者。如来正土非净非秽。净缘见净秽缘见秽。正土非净非秽。身子秽业故见秽。正土非净非秽。诸菩萨净业故见净。亦如祇洹非净非秽。身子见须达多所记只桓。见娑婆丘陵。见释迦所用。若诸菩萨见法界祇洹。见莲华藏界。见舍那所用。故只若祇洹未曾净未曾秽。净缘见净秽缘见秽也。问正土未曾净秽净秽缘见净秽。净秽并是倒不。解云。并是倒。正土非净非秽。颠倒秽业故见秽。正土非净非秽。颠倒净业故见净。故净秽并是倒。虽同倒倒有轻重。重倒非净秽见秽。轻倒非净秽见净。故正土非净非秽两缘见净秽。名为一质二见也。问何意作此语。何意云正土非净非秽缘见净秽为一质二见耶解云。为释经。经何意作此语。释云。为对缘。何者明如来正土非净非。秽见净见秽并是颠倒。净名经一往云。不依佛惠见秽土。亦应云。不依佛正慧见净土。问。见秽不依佛慧。见净何亦不依佛慧耶。解云。正土非秽。见秽既不依佛慧。正土非净。见净亦不依佛慧。又土非秽见秽则秽见。土非净见净则净见。若使如此净秽皆不依佛慧。净秽皆是见皆是倒。为对此缘故。云如来正土非净非秽缘见秽见净也。又所以明正土非净非秽缘见净秽者。为对由来人。由来人无有非净非秽土义。若是净土亦有亦无。成论小乘义无有大乘义有。问。既有苦受乐受不苦不乐受。可得有净土秽土不净不秽土不。彼释云。受有三受土无三土。唯有净土秽土。无有不净不秽土。为对如此人明有不净不秽土。如来第一义土不净不秽。缘见净土缘见秽土。为对此所以明一质二见也。义必须有原始。若不得其由致则不成义。今明为读经为对他故作此语。若无此意则不须明此。故一家无有义也。问一质二见二质一见。若为对判迷悟得失。解云。若是二质一见则是悟。所以前释云。明与无明愚者为二。智者了达性无二。净秽亦尔。智者了净秽不净秽故是悟也。若是一质二见即是迷。正土非净秽缘见净秽故。不净秽缘见净秽是迷。见二不二为悟。见不二二为迷。见二不二为悟。只见此二为不二。见不二二为迷。只见不二为二故。迷悟事同反掌。迷者见二悟者见一。有迷有悟。悟不见二亦不见一。既圣不迷亦复不悟。斯则不一不二不迷不悟清净也。问。土非净非秽缘见净秽为一质异见时可得一净质。见净见秽为一质异见。不秽亦作此问。解云。具有三义。非净非秽质缘见净秽。此义已如前明。亦得一净质缘见净复见秽。一秽质缘见秽复见净。名为一质异见。责何者是解言。如释摩南经。摩南城七宝所造。摩南见金柱。余人则见木柱。只于一金柱复见木柱。此则是一净质缘见净秽。名一质异见。一净质既然。一秽质类尔可知。问。摩界金柱摩南见金柱。余人见木柱。摩南藏金柱。余人犹见木柱为不见。解云。具有见不见。何者于摩界金上见木。摩界既藏金则不见木。亦如于珠上见蛇形。既藏珠则无蛇可见。问。若藏金余人不复见木则着坏业果义。彼何故见木。由彼恶业所以见木。见木是业果。今既无金不复见木则坏业果义也。解云。颠倒之物并有所属。摩界金属摩界。于摩界边强故。摩界藏金余人不复见木也。言见者明摩界虽藏金彼犹见木。问若无金犹见木则成两质义。若是一质无金即不见木。若见则两质。又且木于金上见木。既无金见何有木耶。解云。虽犹见木而是一质。虽是一质而犹见木。大师于此各举神蛇为喻。有人行见一蛇即斩之。蛇腹中有酒肉。蛇何处得酒肉。此蛇是神蛇。人酒肉祭神故。蛇得酒肉。此酒肉是人酒肉。蛇将人酒肉去。人犹见酒肉。在人唯见酒肉而非两酒肉。只是一酒肉。蛇将去人犹见。人将去蛇腹有业行。不可思议如此。故金虽无而犹见木。虽见木而非两质也。次更举一事。只是一金质。福德人见金薄福人则见蛇。只是一金质两人见异。虽见异只是一质也。问。只是一质断蛇即断金断金即断蛇不。直作此问。不知何答。今明虽得断蛇则断金不得断金即断蛇。言得断蛇即断金者。此是大师所言语。何者如二人同从共行。见一挺金两人相让遂不取便弃之。后复一人来见此挺金成一蛇。即断之两断即去。故云二人同心其类断金故。断蛇即断金也。不得断金即断蛇者。彼本不见金故。不得断金即断蛇也。问断蛇即断金者。亦应烧秽则烧净。解云。复为此义说。断蛇即断金。亦烧秽即烧净也

次将正果类例前依果诸四句。何者前云。土有二质一处。一质二处。一质一处。二质二处。又云。二质一见。一质二见。一质一见。二质二见。可得类正果二佛一处一佛二处等四句。二佛一见一佛二见等四句。不解云。依果既有此二种四句。类正果亦有此两种四句。此两种四句。前四句大师作。后四句学士明。言二佛一见者。开本迹二。此是本迹此是迹本因缘本迹。若因缘本迹则非本迹。本迹二为二质。非本迹为一处。故云本迹虽殊不思议一。不思议一是何物绍。隆哲法师竖义。有人问。不思议一一名何物。则解云。一名正性。大师云非解。正性是五性。是五性中。则因与因因。果与果果。四性是缘性非果为正性。不思议一不得道是正性。师云。本迹二处舍那释迦非本非迹名正法身。本迹虽殊不思议一为二佛一处也。一佛二处。正法非本迹为一佛。非本迹为本迹为二处。此则本迹虽一不思议殊。前虽殊不思议一。一是不思议一。今虽一不思议殊。殊是不思议殊。故云一佛二处也。一佛一处者。非本迹佛在非本迹处也。二佛二处。本迹二佛在本迹二处也

次明二佛一见等四句。且辨二佛一见者。本迹是因缘本迹。因缘本迹则不本迹。故前云明无明因缘。智者即了不二。故二佛一见也。一佛二见者。正法身非本非迹不二。何故二缘见本迹二。法身未曾二缘见本迹。法身未曾本迹。故是一佛二见也。一佛一见者。法身佛非本非迹。缘如法身而见。故是一佛一见也。二佛二见者。法身非本迹本迹赴缘。既本迹赴缘缘则见本迹。本迹若不赴缘缘无由见本迹。良由本迹赴缘故。缘得见本迹故。二佛二见。所以正果亦得有两四句

次更两种四句合明依正二果。且明一种四句。何者谓一佛多处。多佛一处。一佛一处。多佛多处。一佛一处者。如涅槃经德王品中明。释迦有净土。在西方名曰无胜。此则一释迦在净秽等处。大智论云。释迦有秽土亦有净土。释迦秽土既有净土。弥陀净土亦有秽土。故云一佛在多处也。多佛在一处者。如法华明。十方佛同在娑婆。亦如五佛共现信相之室也。一佛一处。释迦有东方。弥陀居西土也。多佛多处者。十方诸佛在十方土处也

次复有四句者。谓一佛二处。二佛一处。一佛一处。二佛二处。一佛二处者。释迦即舍那舍那即释迦为一佛。祇洹净秽不同为二处。二佛一处者。释迦舍那二佛。祇洹虽净秽只是一祇洹为一处。一佛一处。本迹一佛。净秽只桓为一处。二佛二处。本迹二佛净秽二处也。然此四句难解。且作章门如此。至后第八会中更当委释。略明土义如此。今通问前四句。何者一家明因缘义。若非因缘明不成义弹他自性。明今因缘既皆因缘。一二二一可因缘。一一二二若为是因缘耶。如初弹他有无。他有是自有。无是自无。自有则有故有。自无则无故无。有有无无非因缘。汝今一一二二若为是因缘耶。且释明四句。因缘因缘四句。因缘四句。不四句四句。四句不四句。此四句皆是因缘。此是总释。次别释前总则竖而密。今别则横而疏。别明四句皆因缘者。由一二故二一。由二一故一二。一二二一因缘若为一一二二因缘耶。解云。由二一故一二得起。何得有一一。由一二故二一则由二一故一一。既由二一故一一。亦由一一故二一则一一因二二。一一因一一由一二有二二。亦由二二故一二则二二因一二。一二因二二。此则四句皆因缘四句。因缘因缘四句则非四句。非非四句非非不四句。毕竟清净。上虽明如此四句未曾有一家所说。大品云。须菩提告诸天子。我无所说无字可说。此则论无所论。说无所说。今亦尔。无量四句而未曾有四句而无量四句。无量一虽一而无量。一无量虽无量而一。虽无所说而说。虽说而无所说。舒则遍盈法界。合则泯无所有。虽卷而无所不有。只历我如此。不得历历不得漫浑。历历则成有得。得漫浑则不可解。今且历历而漫浑。漫浑而历历也。略明净土义如此也。然四条义两条义略竟

今第三次明教门。前明化主化处则是依正能所。有能化即有所化。有所化即有能化。斯则依正具足能所因缘。明此化主化处作何为。为欲化缘设教所以今第三明教门。就教门中凡有三句。一者能所。二者因果。三者半满常无常。师虽明此三种并绸格辨商略存大意耳。大师云。能所义最长。因果处中。半满常无常义最局。然中且明能所义。就此中更开四句。一者能而不所。常无常半满义。涅槃经初别当广释。今提纲振领辨其大要也。三句之而不所。二者所而不能。三者亦能亦所。四者非能非所。言能而不所者。加来设教无有得悟之缘。名为能而不所。所而不能者。或有众生见叶落而悟道。观华雕而成圣。如来不被其教名为所而不能也。亦能亦所者。有能被之教有所被之缘。教是缘教缘是教缘。缘教相称教称缘。缘称教缘教和会众生得道。故名亦能亦所。不能不所者。无如来能被教。无众生所被缘。故称不能不所也。

问何故明此四句。解云。虽明此四句今辨教门。正约亦能亦所句以辨之。何故明教明教为欲被缘。所以今约亦能亦所第二句辨。虽亦能亦所且明能被教。后第四即是明所被缘。今即明能被教也。问。释迦舍那二佛施教若为同为异。解云。二佛施教是同。问二佛既异那得教同。解云。二师虽异施教并为显道。显道不异故施教义同。何以故。道是所显。教是能表。所显之道既无异。能表之教是同也。二佛既然。类十方诸佛亦尔。十方诸佛施教何所为。并显道既同。为显道故教义是同也

次明二佛教同者。同明因果法门。二佛教虽无量不出因果法门。因果法门。十方诸佛教亦尔。不出因果法门。十方诸佛教不出因果法门。今因果法门摄十方诸佛教尽。既明因果法门是同故二佛教不异也。然此因果非是数人六因五果之因果。论师同时因果。异时因果。四缘三因因果。此等因果并非因果义。大师前将中论因果品来弹此因果。明非此因非此果。捡此因不得非因。求此果不得非果。弹如此因果竟。始得明今时因缘因缘因果。因果则无碍亦得同时亦得异时。因缘同时因缘异时。因缘同时不同时因缘异时不异时。虽不同时而同时。虽不异时而异时。如空谷之向明镜之像。恒须此意要须此前弹他因果。始得明今时因缘因果。因缘因果因果义始成。故二佛同明因果也

问。若为二佛同明因果耶。解云。二佛同明因果。各有差别无差别无差别差别义。释迦差别无差别者。一般若因一萨婆若果。一佛性因一涅槃果也。释迦无差别差别者。开一般若因为无量因。谓三乘共十地因。开萨婆若果为无量果。谓萨婆若果菩提果涅槃果也。舍那亦有差别无差别无差别差别义者。行一离世间因得一法界果。即是无差别义也。十信十住十行十回向十地等因。十世界海正果。大少相海。及现本迹等身。即是无差别差别义。此即二佛各有差别无差别义。故二佛明因果是同也。言异者释迦多明差别无差别义。束散明义明一般若因一萨婆若果。不作十十明义。若是舍那多明无差别差别义。散束明义十十明义。十信十地等。乃至普慧菩萨二百句问。普贤菩萨二千句答。一句作十句答。乃至十佛世界海大小相海等故。是无差别差别义。此则二佛教门同异义。如此明二佛教门虽多不出因果。故二佛同明因果。大师从来云。二佛同明因果。明因果不同。言二佛同明因果者。释迦能化过去行不生灭因今得不断常果。释迦能化既然。舍那能化亦尔。舍那能化过去行不生灭因今得不断常果也。释迦所化现在行不生灭因未来得不断常果。释迦所化既然。舍那所化亦尔。现在行不生灭因。未来得不断常果也。故二佛明因果。义同而不同者。释迦能化具明因果。舍那能化俱明果不明因。舍那所化具明因果。释迦所化但明因不明果。言释迦能化具明因果者。释迦教明现是凡夫。行因得果凡明两世因。明过去行六度等因。现在踰城学道六年苦行。具明两世因果故。是明因辨果者。菩提树下得成正觉即是辨果。故言释迦能化具明因果也。舍那能化但果不因者。舍那教不明舍那能化行因。何者不明过去行因。不明现在行因。直舍那始成种觉明依正两果。依果则十国土正果。十佛名号海。故舍那能化但明果不明因也。舍那所化具明因果者。舍那所化修行十信十地等因。得不思议大小相海果。行离世间因得法界果。故云舍那所化具明行因得果也。释迦所化但明行因不辨得果者。故大品云。菩萨以不住法住般若中具足万行。此即但明行般若等因不明得萨婆若果。所以释迦所化但因不果也。然此四句从山中师来已有此语。是一家旧义极自难。后人虽诵得语实不得其意。今且作数问之。何者既言。舍那所化行十信十地等因得不思议大小相海果。行离世间因得法界果。何以得知。此何以得知。十住十地等是舍那所化因。大小相海是舍那所化果。后一周因果亦作此责之。此经七处八会经文。何处道十信十地是舍那所化因。大小相海是舍那所化果。后一周因果亦作此责。此经七处八会经文。何处道离世间是所化因。法界是所化果。又安知十信十住非是舍那能化因。大小相海非是舍那能化果。安知离世间非是舍那能化因。法界非是能化果耶。又一句责。若言十信十地等是舍那所化因。大小相海是舍那所化果者。舍那所化为当现得大小相海果以不。若使言舍那所化不得大小相海果。乃是舍那为诸菩萨说今诸菩萨修因取果者。此与释迦所化更复何殊。释迦亦为诸菩萨说涅槃萨婆若等果。今诸菩萨明因取此果。若尔两佛所化无异。何得判释迦所化但因不果。舍那所化具因果耶。若使言舍那所化已得大小相海果者则诸菩萨皆悉是佛。何以故。大小相海果是如来大小相海果。诸菩萨既得此果则诸菩萨即既成佛。那复更行离世间因得法界。纷纭作义此两句责不可解。所以不可解者。由来师作此语故难解。不具他事。然二佛因果义相是极自难见。前云。释迦能具因果所但因不果。舍那能但果不因所。其因果何意明此因果不同耶。明此作义大师奋云。所以明此四句因果者。欲辨二佛能所相兼义者。释迦能化具明因果。舍那所化具明因果。此则能所相对。非能无成所非所无成能。能是所能。所是能所。此之能所皆具因果。虽皆具因果只一因一果义。故释迦能具明因果。舍那所具明因果。第二句相兼者。舍那能化但果不因。释迦所化但因不果者。此亦是能所义。非能无以明所非所无以明能。以所能果兼能所因。能所因兼所能因。此之能所亦是一因一果义。故舍那能但果不因。释迦所但因不果也。第三句相兼者。释迦能对舍那能。释迦能一二义。舍那能二一义。此二是一二。此一是二一。此本是迹本。此迹是本迹。以本迹故一二。以迹本故二一。一二兼二一。二一兼一二。以本迹兼迹本。迹本兼本迹故。释迦能具明因果。舍那能但因不果也。大师只作此语

今更问。何意明此四句因果相兼耶。解云。有二义。一者明二佛能所互通。释迦能化既具明因果显舍那能化亦尔。舍那能化但果不因显释迦能化亦尔。二佛是二句但各显一义。故一二不同也。能化既然所化亦尔。斯义易知也。二者欲泯能所因果本迹义。释迦本迹一二。舍那迹本二一。本迹非迹。迹本非本。一二非二。二一非一。能所非所。所能非能。斯则非一非二非本非迹毕竟清净。此则名大方广义也

更释前一句义。何者云前舍那能化但果不因。所化具因果者。明此经发初但说舍那依正二果。十佛国土即依果。十佛世界海即正果。而不明舍那能化之因。若是舍那所化前明十信十地等五位是所化因。大小相海是所化果。此是一周明所化因果义也。次复一周明所化因果。谓离世间因法界果。此二周因果中间。性起品结前生后。结前者前明五位因。次明大小相海果。性起品即收此因果。还归不因不果一正性义。生后者由不因不果始得明因果。从体出用义。由非因始得明离世间因。由非果始得辨法界果。故性起品结前生后也。今问。何以得知。此十信十地等因大小相海是舍那所化因果。安知是所化因果非能化因果耶。解云。所以得知十信十地等是所化因者。明如来以如此等因劝所化众生。令行此因。明汝若能行此因必当得佛。故知此因果是舍那所化因果也。大师云。此则所化长有兼义。何者以舍那所化兼能化因。不得能兼所化。言所化因兼能化因者。明所化行此等因得果。当知舍那能化行此等因令得果也。难。所化因兼能化因。亦应所化果兼能化果。所化因兼能化因。亦应能化果兼所化果。解。不得能化果兼所化果。何者欲叹舍那所化现在行因别得果故。所以不得能化果兼所化果。难。显所化别得果。不得能化果兼所化果。亦应能化别有因。不得所化因兼能化因。解云。若并兼则成一义。今各举一义故不同也。问。何意所因兼能果。不得所果兼所因耶。解云。有兼不兼。不得一例所未了处。复更释。次更问。何故释迦所化但因不果。舍那所化具因果耶。解云。净秽利钝。所以释迦所化秽土中。钝根故行因未即得果。舍那所化净土中。利根故行因即得果。大判如此耳。细论释迦所化因不得果。非无具因果。舍那所化因具因果。非无但因不果义。何者大论云。释迦转法轮有二种。秘密法轮中。有得无生有现身成佛。仁王经云。闻说般若现成正觉。释迦所化因不果。既有因果类舍那所化具因果亦有因而不果。问。既尔何故作此释。解云。大判如此耳

华严游意


皇帝降诞日于麟德殿讲大方广佛华严经玄义

    No. 1743 [cf. No. 279]

皇帝降诞日于麟德殿讲大方广佛华严经玄义一部

        大安国寺沙门静居谨上

此经七处。九会。三十九品。凡八十卷第一菩提场会经六品。一世主妙严品五卷。二如来现相品一卷。三普贤三昧品。四世界成就品。两品共一卷。五华藏世界品三卷。六毗卢遮那品一卷第二普光明殿会经六品。七如来名号品。八四圣谛品。两品共一卷。九光朋觉品。十菩萨问明品。两品共一卷。十一净行品。十二贤首品。两品共二卷第三须弥山顶会经六品。十三升须弥山顶品。十四须弥顶上偈赞品。十五十住品。三品共一卷。十六梵行品。十七初发心功德品。两品共一卷。十八明法品一卷第四夜摩天宫会经四品。十九升夜摩天宫品。二十夜摩宫中偈赞品。二十一十行品。三品共二卷。二十二十无尽藏品一卷。第五兜率天宫会经三品。二十三升兜率天宫品一卷。二十四兜率宫中偈赞品。二十五十回向品。两品共十一卷第六他化自在天会经一品。二十六十地品六卷第七重普光明殿会经十一品。二十七十定品四卷。二十八十通品。二十九十忍品。两品共一卷。三十阿僧祇品。三十一如来寿量品。三十二诸菩萨住处品。三品共一卷。三十三佛不思议法品两卷。三十四如来十身相海品。三十五如来随好光明功德品。两品共一卷。三十六普贤行品一卷。三十七如来出现品三卷第八再重普光明殿会经一品。三十八离世间品七卷第九逝多林会经一品。三十九入法界品二十一卷

题云大方广佛华严者。大方广法也。佛华严人也。又大以体遍为义。方广用周得名。依体起用名大广。佛者证说之人。华严修因严果。经诠彼义。故云大方广佛华严经。此经总七处九会三十九品。共八十卷

初会在菩提场阿兰若法。经有六品。明佛果德。毗卢遮那初成正觉。十方众主如大自在天王。并菩萨等。共四十众。同类眷属。各刹尘数。咸至会中。故有世主妙严品海会既集。佛现真仪。则有如来相品真相离相。非小菩萨之所能观。故普贤大士。入自在定。证佛境界。则有普贤三昧品佛有依报。就依报中。先辨能具因缘。则有世界成就品次明所依刹海。则有华藏世界品依报既彰。宏丽正果。属在尊严。故有毗卢遮那品又此第一会。为信乐之境

第二会不离菩提场。受龙宫请。名普光明殿会。经有六品。辨信者之心。佛应众生。先现三业。约身业以立称。则有如来名号品约语业以阐教。则有四圣谛品约意业以警众。则有光明觉品欲生正信。先须正解。故有菩萨问明品解而不行。如说食求饱足。以立行以解解。故有净行品因行以成德之。为众善之元。故有贤首品此第二会虽明正信。未立慧根。如彼轻毛随风无定

第三不离菩提场。受天王请。升忉利天宫会。经有六品。生正慧根。升忉利天宫。化主赴众。忉利天宫偈赞品助化赞德。此之二品。当会由常。十住品。辨住中之解。梵行品。明住中之行。发菩提心功德品。彰住中之德。此之三品。当会正说。明法一品。当会□进。此会正慧既明

第四不起菩提场。升夜摩天宫会。经有四品。托彼慧根。生其正行。升夜摩天宫品。应物合如。夜摩宫中偈赞品。德无不备。此之二品。当会兴彼。十行品。正辨成行。十无尽藏品。摄行进。此后会。虽立根茎。而枝叶未布

第五不起菩提场。升兜率天宫会。经有三品。明回向愿。遍众生界普荫无唯。升兜率天宫品。明于佛有感必□。兜率宫中偈赞品。表于众无德不称。十回向品。即当会正说。言回向者。回自向他。回小向大。回事向理。由三回向。证彼三身。前□五会。住极三贤

第六不动菩提场。应他化自在天宫会。经有一品。登于十圣。明十地住。又贤者善也。圣者正也。所言三者。十住为下贤。约慧断惠以标名。十行为中贤。约修进善以立称。十回向为上贤。约自利利他为胜愿。故有三贤矣。然地有生成之义。表此无漏圣智。能生菩萨成佛果德。故如地也。背凡登圣。断障证真。创生佛家。故名欢喜。二离垢地者。净修三业。如火炼金。离误犯戒垢。故名离垢。三发光地者。修证禅定。能现神通。发妙慧光。故名发光。四焰慧者。定能起慧。以三十七品无漏慧火。烧烦恼薪。故名焰慧。五难胜地者。真俗二智。行相牙违。合令相应。故名难胜。六现前地者。般若正智。了十二因缘。拔无明根。入三解脱。法空真理。明现在前。故名现前。七远行地者。常住三昧。不碍起用。出过有无。下位莫测。前之六地。人天二乘犹许共行。今此独起。故之远行。八不动地者。证无生忍。不为相用功行所动。蒙佛七劝。因起十身相作。及十自在。法驶流中任运而转。不假作意。故名不动。九善慧地者。前证法体。今此起用。专学法王。宴寝语默。具四十无碍辨之众生相。为大法师。无求不应。故名善慧。十法云地者。大法智云能隔尘惑。诸佛法雨悉能受为。复以法雨遍属群品。故名法云。又初二三地。同人天行。四五六地。同二乘行。第七一地。同大乘行。八九十地。入一乘行。故有十圣矣

第七不动菩提场。重会普光明殿。经有十一品。前明三贤十圣。行位将终。今此因圆果满也。十定品。修十三昧。证有即非有。十通品。十慧发明。知空即不空。十忍品。定慧均平。空有一贯。阿僧祇品。能数既多。算不可及。明之德广也。如来寿量品。竖穷来际。菩萨住处品。横遍十方。此上六品。并是菩萨地位功德。即等觉因。成下之五。文理双融。妙觉果满。将成妙觉。先证妙法。故有佛不思议法品妙法既立。必成妙身。故有十身相海品大相既成。次明好德。则有随好光明功德品津梁既备。济渡为功。益物无偏。则有普贤行品普贤在心。须呈果相。则有如来出现品

第八不离前处。再会普光明殿。经有一品。名离世间谓前七会。以差别法。而生其解。当会约仗解成圆融行。所以普慧菩萨起二百问。普贤菩萨二千行答。虽修诸行之法。无性非相。既迁恒在世间。名离世间

第九不动寂灭道场。而现逝多林会。经有一品。名入法界谓前离世间。今入法界明证也。佛入师子频申三昧。欲令大众顿证普门故。所以文殊大士出善住阁。行化南方。于福城东古佛塔所。会进多众。发菩提心。唯有善财童子。历一百一十城。遇善知识。各得三昧解脱门。终至普贤菩萨。于一一毛端。顿证解脱。含同果海

又此九会。第一会举所信之佛。第二会能信之心。第三会依信生解。第四会依解起行。第五会依行发愿。第六会三贤位极。圣地将登。第七会中摄因成果。第八会有无双泯。非真妄之可分。第九会境智一如。岂筌蹄之所及。又总言之。初会举依正两报。为所信佛。第九会明其信者。能成佛人。则初末两会。合是一义。则题中佛字也。从第二会至第八会。则彼佛因。则题中华字也。因有阶降。故中七会以则之。果无分限。唯一佛以证之。严者以愿行之华因。严彼法身之佛果也。又佛华严是能传法之人。大方广是所传教之法。以法成人。先云大方广也。以人传法。故云佛华严也。人中摄因成果。唯佛也。法中摄用归体。唯大也。大是所证之法界。佛是能证之大智。佛之与大如光空。空外无光。大外无佛。空光一体。佛冥契不可分也。心缘莫到。言说不及。能诠此义。故以为经。此乃因理故成教。因教以见理。经云。如因日光照。还见于日轮。因佛智慧光。见佛所行道。以佛常故。经法亦常。所以然者。未曾有日舍于光明。经云。阎浮提人。隔须弥山。见日出没。日中住者。常随于日。无有出没。凡隔无明。见佛隐现。诸大菩萨常随于佛。无有隐现。日轮是体。光明为用。未曾有体而不具用。由有光用。行者见道。所作成办。佛法亦尔。则体演法为用。未曾有佛而不说经。由闻思法。知出离道。修戒定慧。悉得成就。经云。如有大经卷。量等三千界。在于一尘内。一切尘亦然。有一聪慧人。净眼普明见。破尘出经卷。广饶益众生。故云大方广佛华严经。但文义深。难可备陈。随分见闻。滥为称赞。傥一句一偈。与理相应。伏愿。福祐无疆。上资圣寿

贞元八年四月二十一日安国寺沙门静居进上

辛酉秋七月初三日依高山寺古藏内所传本书写之初六日一校毕

        西山梅村住庵善妙寺道栋书


金刚般若波罗蜜经注解

    No. 1703 [cf. No. 235]

金刚般若波罗蜜经注解

        姚秦三藏法师鸠摩罗什奉　诏译

        大明天界善世禅寺住持(臣)僧(宗泐)演福讲寺住持(臣)僧(如[王*巳])奉　诏同注
此经以喻法为名。实相为体。无住为宗。断疑为用。大乘为教相初释喻法名者。金刚喻也。般若法也。金中精刚至坚至利能碎万物。此经能断众生疑执。取以为喻。故大品般若十六分中。以此经名能断分。波罗蜜是梵语。华言到彼岸。众生在生死海中无有穷极。修此般若到涅槃彼岸。盖大乘菩萨达生死即涅槃。则非度而度。非到而到也。经者训法训常。梵语修多罗。此翻契经。谓契理契机故也。二辩实相体者。即一实相理也。经云若人得闻是经即生实相。三明无住为宗者。宗者要也。经云。应无所住。经中多以无住破着。故以无住为宗也。四论断疑为用者。由经力用能断妄执。故以断疑为用也。五判大乘为教相者。经云。为发最上乘者说。故以大乘为教相也此经乃姚秦三藏法师鸠摩罗什所译分三十二分者。相传为梁昭明太子所立。尤译本无。又与本论科节不同破碎经意故不取焉。今注一本天亲等论。取其意而不尽用其语。以其语深难便初学故也

如是我闻。一时佛在舍卫国祇树结孤独园。与大比丘众千二百五十人俱　如是者。指一经所闻法体也。我闻者。阿难谓如是之法我从佛而闻也。一时者。即如来说法机应和合时也。佛者觉也。佛是教主尊极名佛。舍卫者国名也。华言丰德。祇树结孤独园者。只陀太子施树。给孤长者买园。共立精舍请佛而住。此说法处也。与大比丘众者。闻法之侣也。比丘者梵语也。华言乞士。上乞法以资慧命。下乞食以资色身。千二百五十人俱者。此诸弟子凡佛说法之处常随侍也。已上如是等六事。冠于诸经之首谓之通序。如来临灭度时阿难问佛。一切经前当安何语。佛言。当安。如是我闻等语。非但我法如是。三世诸佛法皆如是

尔时世尊食时着衣持钵。入舍卫大城。乞食于其城中。次第乞已还至本处。饭食讫收衣钵。洗足已敷座而坐　此别序也。亦名发起序。以乞食为发起者。盖佛欲说无住相施故。先乞食以表发之。然佛以禅悦法喜为食。而行乞者示同凡僧。欲令折己慢幢生彼福德耳。尔时者当是时也。世尊者。世间所尊十号之一也。食时者。辰时也。着衣者服僧伽黎衣也。持钵者。持应量器也。次第乞者。佛心平等不择贫富也。本处者。给孤园也。洗足者。食讫而洗足也。敷座而坐者。敷坐具而加趺也

时长老须菩提在大众中。即从座起。偏袒右肩右膝着地。合掌恭敬而白佛言。希有世尊。如来善护念诸菩萨善付嘱诸菩萨　长老须菩提乃此经发起之人。称长老者。以其德长年老也梵语须菩提。华言空生。亦名善现。从座起至恭敬。乃请法之敬仪。希有者。赞佛之辞也。善护念者。为护念现在根熟菩萨。与智慧力令其成就自行。与教化力令其摄受众生也善付嘱者。为付嘱未来根未熟菩萨。已得大乘者令其不舍。未得大乘者令其胜进也。护念付嘱即希有事也。佛德之大。无过度生。然虽注意于般若度生。必待请问。故善现睹相知意。即首称叹希有。而后请问也

世尊。善男子善女人发阿耨多罗三藐三菩提心。应云何住。云何降伏其心　此发问之端也。阿耨多罗三藐三菩提者。华言无上正等正觉也。问意以如来护念付嘱现在未来菩萨令成佛果。是菩萨虽发道心誓度众生求成佛道。未知其心云何安住大乘。云何降伏妄心。使至佛果不退失耶

佛言。善哉善哉。须菩提。如汝所说。如来善护念诸菩萨。善付嘱诸菩萨。汝今谛听。当为汝说。善男子善女人发阿耨多罗三藐三菩提心。应如是住如是降伏其心。唯然世尊。愿乐欲闻　善现既赞叹请问妙称佛心。故印可云。善哉善哉。当为汝说也。而又诫约云。应如是住如是降伏其心。善现即会佛意故。唯然应之愿闻是法。然一经之大要。不过善现所问安住大乘降伏妄心。如来所答修行之法。亦不出乎理事二行破执断疑而已。具见下文

佛告须菩提。诸菩萨摩诃萨应如是降伏其心　善现双问安住降伏。如来但答降伏其心者。盖降伏妄心必安住大乘。举降伏则摄安住矣

所有一切众生之类。若卵生。若胎生。若湿生。若化生　人与旁生具有四生。诸天地狱中阴惟是化生。鬼通胎化二生。皆属欲界

若有色　色界天

若无色　无色界天

若有想　识处天

若无想　无所有处天

若非有想非无想　非想非非想处天

我皆令入无余涅槃而灭度之。如是灭度无量无数无边众生。实无众生得灭度者。何以故。须菩提。若菩萨有我相人相众生相寿者相。即非菩萨　此一段是菩萨所修理观具乎四心。谓广大心胜心常心不颠倒心。慈氏颂云。广大第一常。其心不颠倒。第一即胜心也。经云所有一切众生之类者。所怀之境广此大心也。云我皆令入无余涅槃者。此胜心也。无余涅槃即如来究竟彼岸也。云实无众生得灭度者。了生佛一如。此常心也。无我人众生寿者。此不颠倒心也。若有四相谓之四倒。若一众生不令灭度。及见众生实灭度者。则未能了达本源。遂有我人众生寿者四相。不名菩萨。我者。于五蕴中妄计有我我所。人者。妄计我生人中异于余趣。众生者妄计五蕴和合而生。寿者。妄计我受一期果报。一期果报即若长若短寿命也。此皆颠倒妄想亦名四见。菩萨能用般若妙智。照了性空本无四相。名降伏其心。否则非菩萨也

复次须菩提。菩萨于法应无所住行于布施。所谓不住色布施。不住声香味触法布施。须菩提。菩萨应如是布施。不住于相　此一段理观兼事行也。不住是理观。布施是事行。于法者。六尘诸法也布者普也。施者舍也。菩萨所修六度万行。以布施为初度摄后五度。盖施有三种。资生施。无畏施。法施也。资生施者。施以财物资他生也。无畏施者。持戒不恼无冤。忍辱不报有冤。法施者。精进不倦说法。禅定不差机说法。智慧不颠倒说法。然一切布施不过六尘。所谓六尘如床敷卧具饮食汤药之类是也。世人行施心希果报。是为着相。菩萨行施了达三轮体空故。能不住于相。三轮者。谓施者受者及所施物也。佛告善现。应如是不住于相而行施者。盖欲菩萨降伏妄心也

何以故。若菩萨不住相布施。其福德不可思量。须菩提。于意云何。东方虚空可思量不。不也世尊。须菩提。南西北方四维上下虚空可思量不。不也。世尊。须菩提。菩萨无住相布施福德亦复如是。不可思量。须菩提。菩萨但应如所教住　此段恐人疑云。既离相施则无福报。故佛告离相之施其福转多。良由不住相施施契性空。性空无边施福无边。故举十方虚空以为喻也。论云。其义有三。一遍一切处。二宽广高大。三究竟不穷。已上答降伏安住问竟

    一断求佛行施住相疑　此疑从前文不住相布施而来

须菩提。于意云何。可以身相见如来不。不也世尊。不可以身相得见如来。何以故。如来所说身相即非身相。佛告须菩提。凡所有相皆是虚妄。若见诸相非相。即见如来　前段说无住相施降伏其心。是成佛之因。恐善现疑佛果是有为身相。故佛问云可以身相见如来不。善现悟佛问意。乃答不可以身相见。然有相者应身也。无相者法身也。法身是体。应身是用。若知用从体起。应即是法所以无相。故论云。如来所说相即非相。若能了达此意。则一切世间之相无非真如无为佛体。故佛印可善现云。若见诸相非相。即见如来

    二断因果俱深无信疑　此疑从前无住行施非相见佛两段经文而来

须菩提白佛言。世尊。颇有众生得闻如是言说章句。生实信不　论云。无住行施因深也。无相见佛果深也。因果之法既深。疑末世在迷钝根众生不如是能生信心

佛告须菩提。莫作是说。如来灭后后五百岁。有持戒修福者。于此章句能生信心。以此为实　佛答末世自有具福慧人。闻此般若能生实信。言后五百岁者。大集经中云。有五个五百岁。今乃最后五百岁时也。持戒戒也。修福定也。生信慧也。三学俱备。能生实信矣

当知是人不于一佛二佛三四五佛而种善根。已于无量千万佛所种诸善根。闻是章句乃至一念生净信者　若论实信之由。从多佛所以种善根。闻此大乘之法。则能生信。至于一念少时生信。亦从佛所种诸善根而然也

须菩提。如来悉知悉见是诸众生得如是无量福德　信心生一念诸佛尽皆知。凡有众生闻是章句。乃至一念净信。佛智佛眼无不知见。所以得福无量

何以故。是诸众生无复我相人相众生相寿者相。无法相。亦无非法相　此顺释生信得福之故。该乎生法二空。论云。有智慧者了知生法二无我故。又云。生法各有四种想。想即相也。言无复我人众生寿者四相。此生空也。言无法相亦无非法相者。他译更有无相亦非无相。此法空也。疏云。初列生空有四相。次列法空但有两句。法非法也。盖译人略之耳

何以故。是诸众生若心取相。则为着我人众生寿者。若取法相。则着我人众生寿者。何以故。若取非法相。则着我人众生寿者　此返显违经非福。言若心取相等。此生执也。若取法相等。此法执也

是故不应取法不应取非法。以是义故。如来常说。汝等比丘。知我说法如筏喻者。法尚应舍。何况非法　此结上文而证劝也。不应取法者。空能观之智也。不应取非法者。空所观之境也。论云。法有性相尚不应取。何况非法本无性相。又云。善如法尚不取。况不善非法。疏云。今言法者。说五阴空为法。五阴相为非法。即以阴空为药名法阴。有为病名非法。阴病既除空药亦遣。非法既谢在法亦亡。与论意正相淴合。言筏喻者。论云。如欲济川先应取筏。至彼岸已舍之而去。又智论引筏喻经云。汝等若解我筏喻法。是时善法宜应弃舍。况不善法。斯乃无所得之要术。俾不凝滞于物矣

    三断无相云何得说疑　此疑从前第一疑中不可以身相得见如来而来

须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶　向说不可以相见佛。佛非有为。恐有疑云。何故释迦树下得道诸会说法耶

须菩提言。如我解佛所说义。无有定法名阿耨多罗三藐三菩提。亦无有定法如来可说。何以故。如来所说法皆不可取不可说。非法非非法。所以者何。一切贤圣皆以无为法。而有差别　真如法体离有无相。离言说相。岂可以耳闻心得耶。当知树下得道诸会说法。但应身耳。其报身法身无得无说。然应即法报说即无说。是故不可以有取。不可以无取也。善现解佛问意。即答以无道可证无法可说。何以故下。又自征释。由不可取不可说非法非非法。言非法者。不可以有取。言非非法者。不可以无取。由不可取故不可说。然如来垂应有证有说者。盖得非有非无之体也。一切贤圣者。三世十方佛菩萨也。以用也。无为乃自证之理真谛也。差别乃化他之用俗谛也。诸佛说法不离二谛。吾佛亦然

须菩提。于意云何。若人满三千大千世界七宝以用布施。是人所得福德宁为多不。须菩提言。甚多世尊。何以故。是福德即非福德性。是故如来说福德多。若复有人。于此经中受持乃至四句偈等为他人说。其福胜彼何以故。须菩提。一切诸佛及诸佛阿耨多罗三藐三菩提法。皆从此经出。须菩提。所谓佛法者。即非佛法　此乃较量持说功德。佛问。假如人以大千世界七宝为施。其福多不。善现会意。答云甚多。盖此福德离福德自性故言多也。佛又言。离性布施福报虽多。而受持此经为人演说能趣菩提。其福胜彼。言乃至四句偈者。举少以况多耳。然持经福胜者。盖诸佛之身及所证之法。无不从是般若而生。般若称为佛母者。良有以也。然犹恐其于此取着。故复告云。所谓佛法者。即非佛法

    四断声闻得果是取疑　此疑从上无为法不可取说而来

须菩提。于意云何。须陀洹能作是念。我得须陀洹果不。须菩提言。不也世尊。何以故。须陀洹名为入流。而无所入。不入色声香味触法。是名须陀洹　梵语须陀洹。华言入流。此声闻所证初果也。已断见惑离四趣生。预入圣人之流。故云入流。言无所入者。是不着于所入之流。又不着于六尘境界。故言不入也

须菩提。于意云何。斯陀含能作是念。我得斯陀含果不。须菩提言。不也世尊。何以故。斯陀含名一往来。而实无往来。是名斯陀含　梵语斯陀含。华言一来。此声闻第二果也。盖欲界有九品思惑。前六品已断。后三品未断更须欲界一度受生。故云一来。言实无往来者。谓不着于往来之相也

须菩提。于意云何。阿那含能作是念。我得阿那含果不。须菩提言。不也世尊。何以故。阿那含名为不来。而实无不来。是故名阿那含　梵语阿那含。华言不来。此声闻第三果也。断欲界思惑尽。不来欲界受生。故曰不来。言实无不来者。谓不着于不来之相也

须菩提。于意云何。阿罗汉能作是念。我得阿罗汉道不。须菩提言。不也世尊。何以故。实无有法名阿罗汉。世尊。若阿罗汉作是念我得阿罗汉道。即为着我人众生寿者　梵语阿罗汉。华言无学。此声闻第四果也。此位断三界烦恼俱尽。究竟真理无法可学。故名无学。言实无有法名阿罗汉者。谓无无学所证之相也。若言有证即着四相也。此一段名四果离着。论云。向说无佛果可成无佛法可说。云何四果各取所证而说。恐起此疑。故佛约此而问。善现皆答以离着。深会佛之意也

世尊。佛说我得无诤三昧人中最为第一。是第一离欲阿罗汉。我不作是念。我是离欲阿罗汉。世尊。我若作是念我得阿罗汉道。世尊则不说须菩提是乐阿兰那行者。以须菩提实无所行。是名须菩提是乐阿兰那行　此乃善现引自己所证离着。令人生信也。然善现所证之果不过无学。而世尊特称其为第一者。以无诤故也。梵语阿兰那。华言无诤。无诤者。谓离二障。一者惑障。二者智障。离惑则不著有相。离智则不着无相。故无诤也。无所所行者。谓不着于所行之行也

    五断释迦然灯取说疑　此疑亦从第三疑中不可取不可说而来

佛告须菩提。于意云何。如来昔在然灯佛所。于法有所得不。不也世尊。如来在然灯佛所。于法实无所得　此断释迦然灯授受之疑。谓善现迷己所证离着固已得矣。而如来又恐善现疑佛昔受然灯之记于法实有所得。故兴此问。善现答以实无所得。是无疑矣。然灯者。大论云。然灯生时身光如灯。以至成佛亦名然灯

    六断严土违于不取疑　此疑亦从第三疑中不可取而来

须菩提。于意云何。菩萨庄严佛土不。不也世尊。何以故。庄严佛土者。即非庄严。是名庄严。是故须菩提。诸菩萨摩诃萨应如是生清净心。不应住色生心。不应住声香味触法生心。应无所住而生其心　问意以菩萨修六度万行。庄严净土现身说法。是有所取云何不取。答意以菩萨虽修行严土。行乃无作。土亦非严。非严而严。故曰即非庄严是名庄严。既而如来又告善现云为菩萨者应如是生清净心。乃非取而取。如维摩经云。随其心净则佛土净。斯之谓也。若于六尘生着不名清净。故又云。应无所住而生其心

    七断受得报身有取疑　此疑亦从第三疑中不可取而来

须菩提。譬如有人身如须弥山王。于意云何。是身为大不。须菩提言。甚大世尊。何以故。佛说非身是名大身　须弥山者。梵语须弥卢。华言妙高。此山四宝所成。高出众山之上。故称山王。佛之报身远离诸漏。名之为非。尊崇奇特名之为大。佛之问意。以圣人之法既无为无取。所得报身岂非有取。恐有此疑。故设喻为问。而善现即知须弥自无分别我是山王故得为大。报身离着亦复如是。故曰佛说非身是名大身

须菩提。如恒河中所有沙数。如是沙等恒河。于意云何。是诸恒河沙宁为多不。须菩提言。甚多世尊。但诸恒河尚多无数。何况其沙。须菩提。我今实言告汝。若有善男子善女人。以七宝满尔所恒河沙数三千大千世界以用布施。得福多不。须菩提言。甚多世尊。佛告须菩提。若善男子善女人于此经中乃至受持四句偈等为他人说。而此福德胜前福德　恒河天竺之河。周四十里。佛多近此说法。故取为喻。前说一大千世界七宝布施。以喻持说福胜。今以无量大千世界七宝布施。不如持说此经四句其福转胜于彼。此则增胜而论。格量持说之功

复次须菩提。随说是经乃至四句偈等。当知此处一切世间天人阿修罗。皆应供养如佛塔庙。何况有人尽能受持读诵。须菩提当知是人成就最上第一希有之法。若是经典所在之处。则为有佛若尊重弟子　藏佛舍利之处谓之塔。奉佛形像之处谓之庙。随说此经四句偈处。天人固当敬之如佛塔庙。况能具足持诵者耶。成就最上第一希有之法者。成无上佛果菩提也。若是经典等者。经典所在即佛之所在。持说之人即佛弟子。可不崇敬乎哉

尔时须菩提白佛言。世尊。当何名此经。我等云何奉持。佛告须菩提。是经名为金刚般若波罗蜜。以是名字汝当奉持。所以者何。须菩提。佛说般若波罗蜜。即非般若波罗蜜。须菩提。于意云何。如来有所说法不。须菩提白佛言。世尊。如来无所说　善现既闻持经成就希有之法。故问此经何名云何受持。佛答此经名金刚般若。能断一切疑执故。当奉持也。断执虽用般若之智。然法性本空不可取着。故云即非般若波罗蜜也。如来又虑善现未达般若性空谓有言说。故又诰云。如来有所说法不。而善现了知说即无说。乃答云如来无所说也

须菩提。于意云何。三千大千世界所有微尘。是为多不。须菩提言。甚多世尊。须菩提。诸微尘如来说非微尘。是名微尘。如来说世界非世界。是名世界　此即文意由前施宝得福而来。前以无量大千世界七宝布施。得福虽多然非离性。则是贪等烦恼染因。有为福报故。此遂以世界微尘为喻。尘界乃无情之物不生贪等。烦恼染因是则有为。福报不及尘界之无情。况持说此经。是远离烦恼之因。能取菩提而不胜耶。非微尘非世界者。非烦恼染因微尘世界也。是名微尘。是名世界者。乃是无记微尘世界也。无记犹无情。谓不起善恶也

须菩提。于意云何。可以三十二相见如来不。不也世尊。不可以三十二相得见如来。何以故。如来说三十二相即是非相。是名三十二相　三十二相者。应身相也。非相者。法身相也。是名三十二相者。应既即法法全是应。不妨说三十二相也。言施宝之福。纵能成佛身相。但是应身。不及持说功德能成法身也

须菩提。若有善男子善女人。以恒河沙等身命布施。若复有人。于此经中乃至受持四句偈等为他人说。其福甚多　七宝布施外财也。身命布施内财也。身施者。如尸毗王代鸽是也。命施者。如萨埵饲虎是也。以轻重较之。则外财轻而易。内财重而难。然此二施皆有为有漏因果。总不如持说四句能取菩提之妙果也

尔时须菩提闻说是经深解义趣。涕泪悲泣而白佛言。希有世尊。佛说如是甚深经典。我从昔来所得慧眼。未曾得闻如是之经。世尊若复有人得闻是经。信心清净则生实相。当知是人成就第一希有功德。世尊。是实相者。则是非相。是故如来说名实相。世尊。我今得闻如是经典信解受持不足为难。若当来世后五百岁。其有众生得闻是经信解受持。是人则为第一希有。何以故。此人无我相人相众生相寿者相。所以者何。我相即是非相。人相众生相寿者相即是非相。何以故。离一切诸相即名诸佛　善现知舍身命所感之福。不如持说之胜。得闻此法。感佛恩深遂悲泣流涕。赞言希有。自谓从昔已来。未曾闻是经典。若人闻经信心清净。则能生乎实相。又谓我今直佛获闻是经不以为难。而未来众生得闻是法始为希有。所以希有者。以依此经修行。不起我人众生寿者四相。即是非相。非相即实相也。离此诸相即成正觉故曰即名诸佛也

佛告须菩提。如是如是。若复有人得闻是经。不惊不怖不畏。当知是人甚为希有。何以故。须菩提。如来说第一波罗蜜。非第一波罗蜜。是名第一波罗蜜　如是如是者。然之之辞也。大乘之法本是难信难解。然非大乘根器。卒闻是法。未免惊愕疑怖畏惧。能闻是法而不惊畏者。实为希有。此希有法无与等者。故名第一。然法本无说。虑其于法取着。故云非第一波罗蜜。有因缘故亦可得说。故云是名第一波罗蜜也

    八断持说未脱苦果疑　此疑从上舍身布施而来

须菩提。忍辱波罗蜜。如来说非忍辱波罗蜜。何以故。须菩提。如我昔为歌利王割截身体。我于尔时无我相无人相无众生相无寿者相。何以故。我于往昔节节支解时。若有我相人相众生相寿者相。应生嗔恨。须菩提。又念过去于五百世作忍辱仙人。于尔所世无我相无人相无众生相无寿者相　忍辱者。六度之一也。安受曰忍。毁害曰辱。前云舍身命之福报是生死苦因。不及持说之福。此之行忍亦舍身命。不成苦因者何耶。盖能达法无我到于彼岸也。说非忍辱波罗蜜者。即遣着也。如是忍行佛昔曾行故。引歌利王之事以证之。梵语歌利。华言极恶。佛于宿世曾作仙人山中修道。王因畋猎见而不喜。遂割其耳鼻截其手足。时仙人略无嗔恨。以慈忍力身复如故。盖能了达我人众生寿者四相皆空。非惟无苦。亦乃有乐也。又引过去五百世中作忍辱仙以证之者。明行忍行非止一世也

是故须菩提。菩萨应离一切相发阿耨多罗三藐三菩提心。不应住色生心。不应住声香味触法生心。应生无所住心。若心有住则为非住。是故佛说。菩萨心不应住色布施。须菩提。菩萨为利益一切众生。应如是布施。如来说一切诸相即是非相。又说一切众生即非众生　佛累世行忍。以无我故得成菩提。故发菩提之心。应须离一切相。离相即不住色等六尘也。应生无所住心。心无所住即能住菩提。若心有住则非住佛道矣。菩萨所行六度皆应离相。色为六尘之首。施为六度之初。故云不应住色布施。如是行施为利群生。若存施受之心则非无住。下复遣着。故曰非相非众生也

    九断能证无体非因疑　此疑从上为利生行施而来

须菩提。如来是真语者。实语者。如语者。不诳语者。不异语者。须菩提。如来所得法。此法无实无虚　如来所得菩提妙果。如理而证。离于言说。何故累称持说功德。胜余布施等福耶。然佛无所证而证。无所说而说。所证所说无不当理。恐善现未达此意。故又告云。是真实等语。真语者。说佛菩提也。实语者。说小乘法也。如语者。说大乘法也。不异语者。说授记事也。不诳语者。不诳众生也。解译无此一句。无实无虚者。如来所证之法。本离言说故曰无实。对机有说故曰无虚也

    十断真如有得无得疑　此疑从前不住相而来

须菩提。若菩萨心住于法而行布施。如人入暗则无所见。若菩萨心不住法而行布施。如人有目日光明照见种种色　圣人以无为真如得名。然真如之体。遍一切时遍一切处。何故众生有得者有不得者。盖心有住法不住法之异耳。住者住着也。如行布施。不达三轮体空名为住法。心既住法不成檀波罗蜜。如入暗中则无所见。若达三轮体空则心无所住。即成檀波罗蜜。如人有目在日光中见诸色相也

须菩提。当来之世若有善男子善女人。能于此经受持读诵。则为如来以佛智慧悉知是人悉见是人。皆得成就无量无边功德　言未来世中若有受持读诵者。佛眼佛智悉能知见。既行胜因必成妙果。故曰成就无量无边功德也

须菩提。若有善男子善女人。初日分以恒河沙等身布施。中日分复以恒河沙等身布施。后日分亦以恒河沙等身布施。如是无量百千万亿劫以身布施。若复有人。闻此经典信心不逆。其福胜彼。何况书写受持读诵为人解说　初日分者。寅卯辰时也。中日分者。巳午未时也。后日分者。申酉戌时也。如是一日三时舍无量身。历无量劫而行布施。世间固无此事。然佛设此喻者。以况闻经生信福德之胜。何况书持诵说者耶。信力曰受。念力曰持。对文曰读。背文曰诵。所谓书写受持读诵者自行也。为人解说者化他也

须菩提。以要言之。是经有不可思议不可称量无边功德。如来为发大乘者说为发最上乘者说。若有人能受持读诵广为人说。如来悉知是人悉见是人。皆得成就不可量不可称无有边不可思议功德。如是人等则为荷担如来阿耨多罗三藐三菩提。何以故。须菩提。若乐小法者着我见人见众生见寿者见。则于此经不能听受读诵为人解说　此般若之体本绝言思。其功德广大不可得而称量。非乐小乘者所可得闻。故曰为发大乘者说为发最上乘者说。发大乘者。通指衍门三教之人也。发最上乘者。的指圆顿之人。能生信解者也。如是之人修行此法。则成就不可思议功德故。能荷担如来无上菩提。彼小乘不能听受读诵为人解说。为着四见故也

须菩提。在在处处若有此经。一切世间天人阿修罗所应供养。当知此处则为是塔。皆应恭敬作礼围绕以诸华香而散其处　塔为藏舍利之处。若天人修罗固当敬事。此般若经卷所在之处。是真法身舍利宝塔可不敬乎

复次须菩提。善男子善女人受持读诵此经。若为人轻贱。是人先世罪业应堕恶道。以今世人轻贱故。先世罪业则为消灭。当得阿耨多罗三藐三菩提　持诵此经者人当恭敬。而反被人轻贱者。以宿罪业合招恶报。由经力故但被轻贱。被轻贱故其罪消灭。当得无上佛果。持经功德可谓大矣

须菩提。我念过去无量阿僧祇劫。于然灯佛前得值八百四千万亿那由他诸佛。悉皆供养承事无空过者。若复有人。于后末世能受持读诵此经。所得功德。于我所供养诸佛功德。百分不及一。千万亿分乃至算数譬喻所不能及　阿僧祇翻无数时。那由他者。十亿为洛叉。十洛叉为俱胝。十俱胝为那由他。如来于过去然灯佛前供养无数诸佛。其功德可谓深且大矣。乃言不及末世持经功德者。盖持经能生理解得证菩提。供佛虽感福报。但是事相故。持经功德百千万亿分中不及一分也。又言算数譬喻所不能及者。盖事相之福是可思议之法。而般若妙智忘能所绝待对。不可得而思议者也

须菩提。若善男子善女人于后末世有受持读诵此经。所得功德我若具说者。或有人闻心则狂乱狐疑不信。须菩提。当知是经义不可思议。果报亦不可思议　此经非大乘根器不能持诵。而持诵所感功德。岂常人可闻。闻必狐疑不信。故不具说。盖此经之义趣。与其果报。不可思议故也

    十一断安住降伏存我疑　此疑从前诸文无我人等相而来

尔时须菩提白佛言。世尊。善男子善女人发阿耨多罗三藐三菩提心。云何应住。云何降伏其心　善现初闻此义。至是复问者何耶。问辞虽同其意则别。盖所问不过住大乘降妄心而已。初之问意。但问能住能降之法。此之问意。若谓我能住我能降。存此分别障于真证无住之道。故又兴此问也

佛告须菩提。若善男子善女人发阿耨多罗三藐三菩提心者。当生如是心。我应灭度一切众生。灭度一切众生已。而无有一众生实灭度者。何以故。须菩提。若菩萨有我相人相众生相寿者相则非菩萨。所以者何。须菩提。实无有法发阿耨多罗三藐三菩提心者　此一节文意亦与前同。但前是破情显智。所破之情即我人等四相粗执。所显之智即般若真智。自此而下忘智显理。破我人等四相细执。由此贤位渐入圣阶矣

    十二断佛因是有菩萨疑　此疑从上实无有法发菩提心者而来

须菩提。于意云何。如来于然灯佛所。有法得阿耨多罗三藐三菩提不　由前云实无有法发菩提心者。意谓无发心者则无菩萨。若无菩萨。云何释迦于然灯佛所。名曰善慧。布发掩泥行菩萨行得受记耶。佛恐善现潜有此疑。故举以问

不也世尊。如我解佛所说义。佛于然灯佛所。无有法得阿耨多罗三藐三菩提　善现答意云。善慧彼时都无所得离诸分别。由悟无法故得受记

佛言。如是如是。须菩提。实无有法如来得阿耨多罗三藐三菩提。须菩提。若有法如来得阿耨多罗三藐三菩提者。然灯佛则不与我受记。汝于来世当得作佛号释迦牟尼。以实无有法得阿耨多罗三藐三菩提。是故然灯佛与我受记。作是言。汝于来世当得作佛号释迦牟尼　善现既会法无所得。佛然其说。乃言如是如是。既而又反覆告之者。要令善现知法无所得深契至理故得受记。盖如来所证妙果。乃心地本具法门。离诸名相。无授受中而论授受也

    十三断无因则无佛法疑　此疑从上释迦于然灯行因实无有得而来

何以故。如来者。即诸法如义。若有人言。如来得阿耨多罗三藐三菩提。须菩提。实无有法佛得阿耨多罗三藐三菩提　何以故者。征起之辞也。由前云实无有法得菩提果故受然灯之记。遂疑既无佛果。岂有佛法耶释云。如来者即诸法如义。如者真如也。不伪曰真。不异曰如。此真如体贯彻三世绵亘十方。非空非有不变不迁。名如来性。若有所得即非佛菩提也

须菩提。如来所得阿耨多罗三藐三菩提。于是中无实无虚。是故如来说一切法皆是佛法。须菩提。所言一切法者。即非一切法。是故名一切法　所得者。忘情而证也。无实者非有为相也。无虚者。是真如体也。然此真如非别有法。即一切色等诸法。离性离相名真如体。唯佛与佛乃能证此。故一切法皆是佛法。真如之体虽不离于诸法。然亦不可取着。故云即非一切法是名一切法

须菩提。譬如人身长大。须菩提言。世尊。如来说人身长大。则为非大身。是名大身　上说如来所证真如之体遍一切处。可谓长大矣。又恐善现起长大之见。故佛又设喻征之曰。譬如人身长大。善现因喻有悟。即曰非大身是名大身。论云。大身有二义。一者遍一切处即法身。二者功德大即报身。此之二身皆离诸相。故名为非

    十四断无人度生严土疑　此疑同十二疑皆从第十一疑中实无有法发心者而来

须菩提。菩萨亦如是。若作是言。我当灭度无量众生。则不名菩萨。何以故。须菩提。实无有法名为菩萨。是故佛说一切法无我无人无众生无寿者。须菩提。若菩萨作是言。我当庄严佛土。是不名菩萨。何以故。如来说庄严佛土者。即非庄严。是名庄严。须菩提。若菩萨通达无我法者。如来说名真是菩萨　法界混然身土平等。尚无佛道可成。安有众生可度。是则起度生之心修行严土。即凡夫见。不名菩萨者。毕竟起何等心名为菩萨。故云能通达无我法者真菩萨也

    十五断诸佛不见诸法疑　此疑从上菩萨不见众生可度佛土可净而来

须菩提。于意云何。如来有肉眼不。如是世尊。如来有肉眼。须菩提。于意云何。如来有天眼不。如是世尊。如来有天眼。须菩提。于意云何。如来有慧眼不。如是世尊。如来有慧眼。须菩提。于意云何。如来有法眼不。如是世尊。如来有法眼。须菩提。于意云何。如来有佛眼不。如是世尊。如来有佛眼。须菩提。于意云何。如恒河中所有沙。佛说是沙不。如是世尊。如来说是沙。须菩提。于意云何。如一恒河中所有沙。有如是沙等恒河。是诸恒河所有沙数佛世界。如是宁为多不。甚多世尊。佛告须菩提。尔所国土中所有众生若干种心。如来悉知。何以故。如来说诸心皆为非心是名为心。所以者何。须菩提。过去心不可得。现在心不可得。未来心不可得　前说不见彼是众生。不见我为菩萨。不见净佛国土。如是则不见诸法。名为诸佛如来。然而如来具足五眼。岂都无所见耶。五眼者。肉眼天眼慧眼法眼佛眼也。古德偈云。天眼通非碍。肉眼碍非通。法眼惟观俗。慧眼了知空。佛眼如千日。照异体还同。此之五眼通该十界。而优劣有殊。如经所说五眼皆如来所具者。无非佛眼也。恒沙世界一切众生之心。如来无不知见。然众生之心种种颠倒而言非心者。妄识本空也。是名为心者。真如不灭也。所以者何下。征释非心之所以也。盖三世之心。过去已灭。未来未至。现在不住。皆是虚妄生灭故。求之不可得也

    十六断福德例心颠倒疑　此疑从上心住颠倒而来

须菩提。于意云何。若有人满三千大千世界七宝以用布施。是人以是因缘得福多不。如是世尊。此人以是因缘得福甚多。须菩提。若福德有实。如来不说得福德多。以福德无故。如来说得福德多　前说众生心有住着是为颠倒。然福由心造岂亦是颠倒。若是何名善法耶。恐潜此疑故佛断之。福德有实者。住相布施成有漏因。其福则寡。福德无者。离相布施成无漏因。其福乃多。是则不住于相心离颠倒。所作之福无非善法也

    十七断无为何有相好疑　此疑从前如来者即诸法如义而来

须菩提。于意云何。佛可以具足色身见不。不也世尊。如来不应以具足色身见。何以故。如来说具足色身。即非具足色身。是名具足色身。须菩提。于意云何。如来可以具足诸相见不。不也世尊。如来不应以具足诸相见。何以故。如来说诸相具足。即非具足是名诸相具足　上说诸佛所证乃无为之法。云何佛身有八十种好三十二相而可见耶。为断此疑故有此问。善现乃会如来法身固非色相可见。而未尝离于色相而不可见。故云即非具足色身。是名具足色身。即非具足诸相。是名具足诸相。良由全法身无为之体。起应身相好之用。是故应身即是法身。乃无相而相。相而无相。无见而见。见而无见者也

    十八断无身何以说法疑　此疑从上身相不可得见而来

须菩提。汝勿谓如来作是念。我当有所说法。莫作是念。何以故。若人言如来有所说法。则为谤佛。不能解我所说故须菩提。说法者无法可说。是名说法　既云如来色身相好不可得见。如何为人演说法耶。然如来悲愿深重。随感而应。无说而说。说即无说。不达此意是为谤佛。言无法可说是名说法者。离性执已。不妨称性而说也

尔时慧命须菩提白佛言。世尊。颇有众生。于未来世闻说是法生信心不　善现解空第一。与般若空慧相应。以慧为命故称慧命。前云身乃非身之身。法乃非说而说。身说俱妙难信难解。所以有此疑问

佛言。须菩提。彼非众生非不众生　众生有圣有凡。而凡夫众生于此般若不能生信。圣体众生乃能信解。言彼非众生者。非凡夫众生也。非不众生者。非不是圣体众生也。圣体众生即大乘根器人也。岂可视为凡夫众生不能生信。尚恐善现未悟。下文又征释之

何以故。须菩提。众生众生者。如来说非众生。是名众生　众生众生者。牒上文非众生非不众生也。如来说非众生是名众生者。言非是凡夫众生是圣体众生能生信解者也

    十九断无法如何修证疑　此疑从前十二十三疑中无法得阿耨菩提而来

须菩提白佛言。世尊。佛得阿耨多罗三藐三菩提。为无所得耶。佛言。如是如是。须菩提。我于阿耨多罗三藐三菩提乃至无有少法可得。是名阿耨多罗三藐三菩提　前既云实无有法得无上正觉。如何却有修证。故疑而问之。佛答有三。一答无法可得为正觉。二答平等为正觉。三答正助修善成正觉。初答如文可见

复次须菩提。是法平等无有高下。是名阿耨多罗三藐三菩提　二答平等为正觉也

以无我无人无众生无寿者。修一切善法。则得阿耨多罗三藐三菩提。须菩提。所言善法者。如来说即非善法是名善法　三答正助修善成正觉也。正助者。正谓正观。空四相也。助谓缘助。修一切善法也。初答以无法可得为正觉者。达妄即真也。二以平等为正觉者法无高下也。三以正助成正觉者。离相修善也。由离相故。名为善法

    二十断所说无记非因疑　此疑从上修善法而来

须菩提。若三千大千世界中所有诸须弥山王。如是等七宝聚。有人持用布施。若人以此般若波罗蜜经乃至四句偈等。受持读诵为他人说。于前福德百分不及一。百千万亿分乃至算数譬喻所不能及　前既云从修善法得菩提。则佛所说法是无记法。不能得菩提耶。恐有此疑。故佛举大千世界中施七宝聚如须弥山之多。且大较之持说四句功德。百千万亿分中乃不及其一。所说法盖佛离言说相。以离相故能作菩提之因。故慈氏偈云。虽言无记法。而说是彼因。彼即菩提也

    二十一断平等云何度生疑　此疑从第十九疑中是法平等而来

须菩提。于意云何。汝等勿谓如来作是念。我当度众生。须菩提。莫作是念。何以故。实无有众生如来度者。若有众生如来度者。如来则有我人众生寿者。须菩提。如来说有我者。则非有我。而凡夫之人以为有我。须菩提。凡夫者。如来说则非凡夫　既云是法平等无有高下。云何如来却度众生。故偈云。平等真法界。佛不度众生。以名共彼阴。不离于法界。名即众生假名也。阴即五阴实法也。此假名实法皆即法界。故云不离于法界。既即法界凡圣一如。岂有众生可度。故云佛不度众生。如来若谓我为能度。众生为所度。此则着于四相。由离四相则非度而度。度而非度。则是如来说有我者。真我也。则非有我者。非妄我也。而凡夫之我是我执也。非凡夫者。论云非生。谓不生圣人法。即毛道凡夫也

    二十二断以相比知真佛疑　此疑从第十七疑中如来不应以色身诸相见而来

须菩提。于意云何。可以三十二相观如来不。须菩提言。如是如是。以三十二相观如来。佛言。须菩提。若以三十二相观如来者。转轮圣王则是如来。须菩提白佛言。世尊。如我解佛所说义。不应以三十二相观如来。尔时世尊。而说偈言

  若以色见我　　以音声求我
  是人行邪道　　不能见如来

三十二相者。应身相也。观如来者。观法身如来也。问意谓可于应身相好中观见法身不。善现乃知应身相好从法身流出。若见相好即见法身。故答云如是如是。佛又恐善现于应身取着。不达法体。故又以轮王即如来为难。而善现解佛难意故。云不可以三十二相观如来也。既而佛乃说偈以证之。法身之体固不离于声色。但凡夫堕于闻见。是行邪道。不能见于如来也

    二十三断佛果非关福相疑　此疑从上不应以相观佛而来

须菩提。汝若作是念。如来不以具足相故得阿耨多罗三藐三菩提。须菩提。莫作是念。如来不以具足相故得阿耨多罗三藐三菩提。须菩提。汝若作是念。发阿耨多罗三藐三菩提心者。说诸法断灭。莫作是念。何以故。发阿耨多罗三藐三菩提心者。于法不说断灭相　上明如来所证菩提不从福德而致。是则菩萨所修福德。不成菩提之因。亦不克果报耶。为断此疑故告之曰。莫作是念。如来不以具足相而得菩提。具足相即福德相也。盖大乘所修福德之因。所得福德之果。但离取着之相。不同小乘断灭之见。故曰于法不说断灭相也。下又设喻以告

须菩提。若菩萨以满恒河沙等世界七宝持用布施。若复有人知一切法无我得成于忍。此菩萨胜前菩萨所得福德。须菩提。以诸菩萨不受福德故。须菩提白佛言。世尊。云何菩萨不受福德。须菩提。菩萨所作福德不应贪着。是故说不受福德　假使有人。以无量世界七宝行施心有所著。所感之福则成有漏。心若离着即成无漏。故云若有人知一切法无我得成于忍。无我者。无人法二执也。忍即无生法忍。初住菩萨所证也。既得无生法忍。则与彼住相行施者不同。故云胜前菩萨所得福德。言不受福德者。不受有漏福报也。善现又疑。既不受福报。云何能获无生法忍。须知有漏果报则不应受。无漏果报则受而不取。取谓取着。故云菩萨所作福德不应贪着也

    二十四断化身出现受福疑　此疑从上不受福德而来

须菩提。若有人言。如来若来若去若坐若卧。是人不解我所说义。何以故。如来者无所从来。亦无所去。故名如来　有来去坐卧者。乃如来应身也。无来无去者法身也。然如来昔行菩萨道时不受福报。云何至果有去来坐卧之相。使诸众生供养获福。恐有此疑故告以释之。谓如来应用示有动作。而法身之体如如不动也

    二十五断法身化身一异疑　此疑从上应有去来法无去来而来

须菩提。若善男子善女人以三千大千世界碎为微尘。于意云何。是微尘众宁为多不。须菩提言。甚多世尊　上明应身去来是异。法身无去来是一。佛恐善现有一异之见。故设喻以释之。释中初举世界微尘一异断疑。次举言说我法离见。初释中文有三科。一标界尘一异以显无性。言世界者。喻法身也。微尘者。喻应身也。世界一也。微尘异也。碎界作尘。尘无异性。合尘为界。界无一性。喻全法起应。应无异性。全应即法。法无一性。故偈云。去来化身佛。法身常不动。于是法界处。非一亦非异。然如来体用互融。所以能一能异非一非异。自在无碍者矣

何以故。若是微尘众实有者。佛则不说是微尘众。所以者何。佛说微尘众。则非微尘众是名微尘众　此释微尘。喻应身无异性。若知碎世界作微尘。微尘全是世界。则尘．无实性。故曰则非微尘。以离性计而说微尘。故曰是名微尘也。此喻全法起应应即是法。何异性之有哉

世尊。如来所说三千大千世界。则非世界。是名世界。何以故。若世界实有者。则是一合相。如来说一合相则非一合相是名一合相。须菩提。一合相者。则是不可说。但凡夫之人贪着其事　此释世界喻法身无一性。若知合微尘为世界。世界全是微尘。则世界无实性。故曰则非世界。以离性计而说世界。故曰是名世界也。一合相者。言众尘和合为一世界非一合相者。非性执之一合。是名一合相者。乃离性之一合也。此一合相不可思说。而凡夫不了自生贪着耳。此喻全应是法。法不离应。何一性之有哉

须菩提。若人言佛说我见人见众生见寿者见。须菩提。于意云何。是人解我所说义不。不也世尊。是人不解如来所说义。何以故。世尊。说我见人见众生见寿者见。则非我见人见众生见寿者见。是名我见人见众生见寿者见　此下明离我法二见。初离我见。夫我见者。有真我之见。有妄我之见。妄我见者。虚妄分别众生见也。真我见者。远离执着如来见也。既离执着。示有我见人见众生见寿者见。此不见而见也。在迷众生以为如来实有四见。故云不解如来所说义也。善现既解如来所说之义。即知四见皆非虚妄分别是真我之见。故云是名我见人见众生见寿者见也

须菩提。发阿耨多罗三藐三菩提心者。于一切法应如是知如是见如是信解不生法相。须菩提。所言法相者。如来说即非法相。是名法相　次离法见。夫如来说法。要令众生发菩提心。修行契理故。闻如来所说。当如是知见信解不生法相。言不生法相者。不于法取着也。法本离相。如来称性而说。故云即非法相是名法相。此一段文。虽证释离于法执。亦是总结降住正行。由经初善现请问。若人发无上菩提心者。应云何住云何降伏其心。如来答云。应如是住如是降伏其心。故今结云。发菩提心者。于一切法如是知见信解。此结如是住也。不生法相此结降伏妄心也

    二十六断化身说法无福疑　此疑从上尘喻化身是异而来

须菩提。若有人以满无量阿僧祇世界七宝。持用布施。若有善男子善女人。发菩萨心者。持于此经乃至四句偈等。受持读诵为人演说。其福胜彼。云何为人演说。不取于相如如不动　此段文有三节。初以无量阿僧祇世界七宝布施。是假喻格量也。自若有善男子下。明持说福胜。自云何为人演说下。是释福胜所以。据经文但明持说功德。而论乃谓化佛说法有无量功德者。盖化佛是说经教主。持说是弘经之人。所弘之经是佛所说。佛之所说离言说相。故功德无量。弘经之人若能离着。则其福能胜彼也。如如者。法身之理也。化身既即法身。则无去无来故不动也

    二十七断入寂如何说法疑　此疑从上演说与不动而来

何以故　上言如如不动。则佛常住世间。为众生说法。何故言如来入涅槃耶。恐有此疑。故说偈以释云

  一切有为法　　如梦幻泡影
  如露亦如电　　应作如是观

一切有为法者。一切世间生灭之法也。佛生人中示同生灭。亦属有为无常之法。无常之法虚假不实。故以梦幻泡影露电六种为喻。应作如是观者。观即般若妙智。以此妙智观有为法。如梦幻等。能观既是妙智。所观无非妙境。妙境者。一境三谛也。妙智者。一心三观也。三观者。空假中也。三谛者。真俗中也。即观有为之法。离性离相之谓空。无法不具之谓假。非空非假之谓中。谛者审实不虚之谓。全谛发观。以观照谛。谛既即一而三。观岂前后而照。故云如是观也。能如是观。乃了化身即法身无常即常也。虽即法身不碍涅槃。常即无常也。良以如来究竟非常非无常之法。故所以能常能无常也。是则终日涅槃终日说法。不住有为不住无为。不可得而思议者也。一经始末皆称如是。始云如是住如是降心。中间节节云如是。至此又云如是观。论乃释云。妙智正观。故知妙智实一经之宗也。正宗竟

佛说是经已。长老须菩提及诸比丘比丘尼优婆塞优婆夷。一切世间天人阿修罗。闻佛所说皆大欢喜。信受奉行

金刚般若波罗蜜经注解

  洪武十年十一月二十有二日

皇帝有诏。令天下僧徒习通心经金刚楞伽三经。昼则讲说。夜则禅定。复

诏。取诸郡禅教僧。会于天界善世禅寺。校雠三经古注一定其说。颁行天下以广传持。洪惟

皇上以金轮统御。乘夙愿力。亲受灵山付嘱。流通教法。以寿慧命。不胜幸甚。于是(臣)僧(宗泐)等。才虽愚钝。敢竭丹衷。述平昔所闻。辄为注释。注成。以十一年正月二十有八日。诣

阙进呈

上御华盖殿览毕。乃可其说

敕刊板行世。然此三经。皆是究心之要。其功在乎破情显性。而流通之功。良亦不细。上以阴翊王度。下以资益群生。非惟吾徒一时之幸。实天下万世之至幸也。(臣)僧(宗泐)谨识

  洪武十一年正月　　　日


金刚般若经

    No. 1699 [cf. No. 235]

    金刚般若经序

        胡吉藏法师撰

金刚般若波罗蜜经者。斯乃是三观之虚明。一实之渊致。昔仙人苑内未耀此摩尼。今长者园中方洒兹甘露。良由小志先开故早驰羊鹿。大心始发方驾此白牛。斯乃正教之供范萨埵明训。非云非雨德润四生。非日非月照明三界。统万行若沧海之纳众流。荡纷异若冬霜之凋百草。若具存梵本应云跋阇罗般若波罗蜜修多罗。此土翻译金刚智慧彼岸到经。明无累不摧称曰金刚。无境不照目为般若。永勉彼此名波罗蜜。经者训法常也

金刚般若疏卷第一

        胡吉藏法师撰

玄意十重。一序说经意。二明部傥多少。三辨开合。四明前后。五辨经宗。六辨经题。七明传译。八明应验。九章段十正辨文

问佛以种种因缘说摩诃般若。今有何等义故演说是经。答摩诃般若广为菩萨说菩萨行。此经为诸大人略说大法。如经云。佛告须菩提。此经为发大乘者说。为最上乘者说故。问曰云何为诸大人略说大法。答曰佛法无量。略说因果则总摄一切。因者所谓菩萨真实大愿真实大行。言大愿者如经。菩萨住般若心中欲遍度一切众生令入无余涅槃。而实无所度。言大行者如经。菩萨不住于法而行布施等一切诸行。而无所行。若不以般若心发愿则愿不成愿。若不以般若心修行则行不成行。是故菩萨欲修愿行要须般若。是名因义。所言果者。菩萨以行无所得因故得无所得果。无所得果即是如来实相法身。如经。不可以诸相得见如来。若见诸相非相则见如来无为法身。今欲为诸大人说此因果故说是经。复次为现在未来一切众生。真实分别利益功德故说此经。如经云。佛灭度后后五百岁。般若中能生一念净信。外为诸佛护念。内得无边功德。胜舍大千珍宝亦胜舍恒沙身命。复次为欲说第一义悉檀故说是经。第一义悉檀者所谓诸法实相。灭一切戏论过一切言语。亦无所过亦无所灭。譬如火炎四不可触的无所依止。如经。不可取不可说。谓不可取心行断。不可说言语灭。即是第一义悉檀。复次以大悲心受请说法。故说是经。如法华云。于三七日中思惟如是事。众生诸根钝着乐痴所盲。我宁不说法疾入于涅槃。尔时梵王稽首劝请。众生根性为上中下。愿开甘露门为演说法。是以如来便趣鹿苑说乎四谛。乃至祇园演于般若。问曰昔鹿苑说四谛可为梵王。今祇园演于般若。何阙受请。答曰梵王所请非止小法。如来受请本为大事。大事者所谓般若波罗蜜是。复次佛欲集诸法药愈难愈病。故说是经。所以者何。一切众生有二种病。一者身病。谓老病死。二者心病。谓贪嗔痴。自有生死已来不得般若药故。无人能治此病。佛以般若金刚摧破二病。故说是经复次欲增诸菩萨念佛三昧故说此经。一切众生虽欲念佛不识如来多堕邪观。如经。以色见我音声求我则堕邪道不能见法身。法身者以正法为身。故秤法身。故华严经云。正法性远离一切言语道一切趣非趣。悉皆寂灭相。正法性者则是实相。斯经盛明实相。即是盛明法身。故观身实相。观佛亦然。为斯观者名为正观。异斯观者名为邪观。复次欲显示中道拔二边见故说是经。如经。发三菩提心者。于法不说断灭相。菩提心者即是道心。道谓正道。发正道心。岂堕断常。若堕断常。即发断常心。是则不名发正道心。今欲令诸菩萨发正道心断常观息故说此经。复次欲说异法门异念处故。故说此经。昔说善门不善门记门无记门常无常苦乐等念处。今欲说非善门非不善门非记门非无记门非常非无常念处。如经。法尚应舍。何况非法。复次欲转众生深重鄣故说此经。下云。应堕恶道以受持经故。三恶道消灭当得三菩提。如是种种因缘。并是依经文及影龙树大论故说般若因缘。问曰为何等位人说是经耶。答曰有人言。般若是高位所行。我等凡夫岂预斯事。故望岸自绝。今谓不然。此人乃是无碍法中自作障碍。可不悲乎。若言般若必在高位。高位之人本自不堕恶道。何俟习行方得离耶。今经言。欲不堕恶道不生卑贱家。欲世世人天净土受乐乃至究竟大般涅槃。须学般若。此意乃明应堕恶道者行般若故不堕。故从薄地凡夫已上乃至十地已还。皆须学般若也。复次有婆薮盘豆弟子金刚仙论师。菩提流支之所传。述亦说般若缘起。所以说般若者为断众生十种障故。言十种障者。一无物相障。二有物相障。三非有似有相障。四谤相障。五一有相障。六异有相障。七实有相障。八异异相障。九如名义相障。十如义名相障。此之十障障于般若。八障般若一一障中皆对十障。所言无物相障者。众生久劫已来着我我所多滞有病。是以如来说一切法皆毕竟空。但禀教之徒闻毕竟空便起邪见。谓无因果则失二谛。此之断见障于般若。为此障故佛说斯经。如经。菩萨不住一切法行于布施等一切诸行。故以万行为因法身为果。所以虽毕竟空而因果无失也。所言有物相障者。前是断见。今是常见。禀教之徒既闻菩萨行因得果。便谓因是能感果能酬有能行之人所行之行。是则无见虽泯有念还生。故名为障。为是障故说般若治之。如经。若菩萨有我相人相则非菩萨。见有法相非法相亦非菩萨。虽复行施三事恒空。因果宛然而未曾感应。类如空中种树。亦同空里织罗。岂得闻有便起常见。所言非有似有相障者。禀教之徒闻上菩萨不著有无。而便生异见。若使有无皆不可得何得有万用不同。故如六尘异对四大互反。以有万用故知不无。问曰云何名为非有似有。答曰譬如阳炎非有似有。众生所见万用之有。此所见有非有似有故秤为障。云何治之。还以喻破。譬喻如阳炎虽复似有而实非有。所见之有亦本自非有。如经。一合相者则不可说但凡夫之人贪着其事。下梦幻泡影亦是破之言谤相障者。或者闻上第二有物相障法体是空。次闻第三万法用空。便谓生死涅槃众生佛性一切皆空。作此空见便谤佛性。所以者何。今辨空者生死虚妄。可得是空。佛性非妄。是故不空。是以经言。空者二十五有。不空者大般涅槃。此经下文云亦非无相。非无相者。正明佛性非是无性相。问曰涅槃可明佛性。般若何有此说。答曰涅槃明佛性。般若未明佛性。此是诃梨门人作如此说。今婆薮弟子明般若佛性乃是眼目异名。是故般若亦明佛性次第五第六一有相障异有相障者。此即一异相对。斯之一异。通内外两计备一切诸法如僧佉计一世师计异尼干子计亦一亦异若提子计非一非异。斯之四执皆障般若。又如学佛教之徒。或言二谛一体异体。或言相续假故一。实法灭故为异。如此定执亦障般若。云何治之。如下文说。如来说一合相则非一合相。亦应云。如来说异散相则非异散相。但凡夫贪着见一合相亦凡夫贪着见异散相。故诸佛菩萨检此一异。究竟无从名破一异。第七第八实有相障异异相障者。此之两障执教执相。以为一双。言教执者。上来六章事并皆空破除。惑者便云。如其无者佛何故说。以佛说故则知不无。由如色法。如其是无不应说色。以说色故则知非无。以执佛说言法实有故名为障。云何治之。如下文说。菩萨不应住色生心。不应住声香味触法生心。若有六尘云何不住。以不住故则知无六。如来虽说有六但假名字。云何执于假名便言实有。异异相障者。惑者云。若诸法但有假名无实体者。云何诸法各各有相。如见鹄知池见烟知火。名为标相颈细唇粗底平腹大。是瓶体相。角降垂壶。是为牛体相。既有此诸相。不应但有假名。作此执者即名为障。云何治之。如经云。离一切相即名诸佛。若实有相云何可离。以其离故则知无相。第九如名义相障。第十如义名相障。所言如名义相障者。惑者云。若诸法无有相者云何有名。以有名故则知有相。如以火名召火则得火来不得水至。以水名召水则得水来不亦得火至。故知有名以表于法则法体不无。作此谓者即秤为障。然此第九与第七障不同者。第七则执于佛教以生迷着。今则直寻相名言有物体所以为异。云何治之。如下经云。说微尘则非微尘。如聚微尘则成细色。如聚细色乃至成于世界。虽有世界之名而实无其体。乃至虽有微尘之名而实无其体。既无其体焉得有名。如肇公云。名无得物之功。物无应名之实。名无得物之功则非名。物无应名之实则非物。非名非物名物安在。第十如义名相障者。惑者言。若诸法无体。云何众生受用万法。既其受用则有万法之体。以有万法之体则有万法之名。以体证名故祥为障。云何治之。如下经说。一切有为法如梦幻泡影。内心外境悉无所有。云何言有法体以体证名耶。问曰此之十障般若治之。今为当用此释。为当不用。答曰若必言有。惑是能障。解是能灭。还是生灭观。义即是障也。便须破之。若言般若为能破障为所破。为见故破。不见故破。为独故破。为伴故破。如此检责即不见惑之可灭解之可生。此即非解非惑无生无灭。如此事了悟始名般若也

第二重明般若多少。问曰般若波罗蜜凡有几种。答曰备探南北遍捡经论。部数不同。第一有二种。出大智论。第四十一及九十九卷云。般若有二种。一共声闻说。二但为十地诸大菩萨说。下位之所不闻。今诸部般若多是共声闻说也。第二有三种。三种者释论第六十七卷云般若部云般若部傥有多有少有上中下。谓光赞放光道行也。旧云。光赞有五百卷。此土零落唯有十卷。或分为十二卷。有三十七品。即是上品。次放光为中品。道行为下品也。放光有二十卷。是古大品。道安法师所讲者。今新定本有二十七卷。或为二十四卷。对小品为大品。于前三部实应是中品也。道行即是小品。有十卷。即有新定本。有七卷。释论七十九卷云。般若义乃无边卷数有限。谓小品放光光赞既前列。余二同前。而以小品名代道行也。故知道行即是小品也。第三明四种般若者。长安睿法师小品序云。斯经正文凡有四种。多则十万偈。少则六百偈。此之大品犹是外国中品耳。随宜之言复何足计其多少。虽习四名而不列数。有人云。当以金刚足前三部以为四也。然金刚止有三百许偈。睿公云。少则六百偈。故知未必用金刚足之。次明五时般若者。出仁王经。初云释迦入大寂定众相谓言。大觉世尊前已为我等大众二十九年说摩诃般若波罗蜜金刚般若天王问波若光赞波若。今复放光斯作何事。既列四种于前。第五最后说仁王护国般若。又大悲比丘尼本愿经末记。或在仁王末记云。五时波若者是佛三十年中通化三乘人也。第一佛在王舍城说大品般若。小品从中出。第二佛在舍卫祇洹精舍说金刚波若。本有八卷。淮南零落唯有格量功德一品。别为一卷存其本名亦云金刚。第三佛在祇洹说天王问波若。大本不来汉地。此土唯有须真天子问波若七卷。法才王子问波若三卷。四天王问波若一卷。并出其中。第四佛在王舍城说光赞般若。成具道行广净。此三部从光赞中出。第五佛在王舍城说护国波若。次流支三藏云波若应有八部。第一部有十万偈。第二部有二万五千偈。此之二部犹在外国。第三部有二万二千偈。即是大品。第四部有八千偈。即是小品。第五部有四千偈。第六部有二千五百偈。此之二部亦未传汉地。第七部有六百偈。即是文殊师利波若。第八部三百偈。即是此金刚波若。又言。有光赞大空道行等流支三藏云。此皆十万偈波若中一品。非是别部。今以释论验之。不同流支所说。释论云。波若部傥有多有少有上中下。云何言光赞道行非是别部耶。又大论第百卷云。如此中波若或有二万二千偈。大波若有十万偈。诸龙天宫有千亿万偈。以其寿命长远念力坚强故堪闻多说。人中寿命短促忆识力弱止有少许文字。若尔岂局在五时限现于八部耶

第三辨开合。问余经曾无再说。何故波若诸部无量。答佛经无量。来汉地者盖不足言。但今唯见波若多部未见余经多耳。而今且论波若多部者。众生入道要由波若。所以者何。一切凡夫未得道者皆由有所依着。波若正破众生有所依着。故说无依着之法。波若是真实忏悔故。诸大乘经辨真实忏悔皆依般若。如普贤经云。一切业障海皆从妄想生。若欲忏悔者端坐念实相。大涅槃亦云。若闻无作无受。王之重罪必得除灭。问诸经各说无所得法各灭重罪。云何独言诸经灭罪皆依波若。答诸大乘经虽并是无依无得。但波若多作无依无得之说正破众生依得之病。余经不尔。至如涅槃正明常无常。法华明会三归一之法。华严广明菩萨因果德行。不正辨无依无得。为是义故众经说得道之与灭罪要须波若。是以般若有多部不同。取其大要。众生常有依得之病。是以如来常说无依得法。如二夜经云。佛从得道夜讫至泥洹夜常说波若。五时之与八部何足为多。问般若五时为五部。华严八会何故不为八部。八会既合为一部。五时何不合为一部。答通而为论皆得相类。今不尔者。华严八会此义则前后相成。如前说。十信十住十行十回向十地及大小相海。此即浅深次第因果相成。故得合为一部。五时般若非是浅深次第前后相成。故各开五部

第四重明二经前后。问摩诃般若金刚般若何者前说。答云开善法师。会稽基法师。姑苏华山颜法师。大领师等。皆云。如仁王所列前说摩诃次说金刚。更以两义证之。一者大智论云。前未说菩萨行。今始欲为弥勒等说菩萨行故说波若。若前已说金刚波若。则是已说菩萨行。不应言未说也。二者金刚波若经初云。善护念诸菩萨善付属诸菩萨。未说摩诃般若。则未有菩萨。云何付属护念耶。今说摩诃竟方有菩萨。故后说金刚般若始得明护念付属菩萨也。次有人言。前说金刚后说大品。何以知之有三义三文往证。三义。一金刚是破相之名。十二年中名有相教。受字之徒生分别相。封执难祛。佛初开此经明无相深理破彼相着心。故假金刚强喻空解。二者说此经。止集千二百五十比丘等不广集天人菩萨。正为将明甚深空理化着相众生。欲令亲近弟子在前悟解。因此得便传教义成。便声闻助佛扬化。菩萨理中近佛事迹更远。又欲令菩萨转教。声闻望岸而退故。前为常随佛者说于此经。三者形小故有大。前说此经甚略。未广明菩萨万行。名为小。后演放光般若。此始复广明无相解万行差别。名为摩诃般若。以此义往推故知。金刚般若是第一时说。摩诃般若次在第二。次文证亦有三。一者此经下文须菩提问佛云。颇有众生得闻如是言说章句。生实信不。若尔前已说大品。无量众生得信悟解。转教说法。善吉于大品教门曾无此疑。今至此经方复致问。在义难解。二者善吉领解云。我从昔来所得慧眼未曾得闻如是之经。若尔前佛说大品。岂不能说经转教耶。得言不闻深经。若闻而未悟。岂能转教。三者善吉答佛。不应以三十二相见如来。若尔前已闻大品。云何执色相是佛。若生此执非谓解空。故知直执昔日相教故谓色身为佛。而开善举两义为证。今须释之。一者大智论云。说摩诃已前未明菩萨行者。此是未广明菩萨行耳。非不已略说金刚。二者云。未说大品故未有菩萨善付属者。此事不然。今明。佛初成道以三乘度人。岂无菩萨付属。弥勒即是其人。以文义往推故知前说金刚波若也。今明。此之二释未可专判。随宜之言复何可定其前后。或可一时具说多部。或可一部具经多时。至大品中更当委释

第五辨经宗。问此经以何为宗。答释者不同。有人言以无相境为宗。所以者何。明此经正遣荡万相明无相理故以无相之理为此经宗。有人言。此经以智慧为宗。自有二说。一说云。慧有二种。一者因中智慧。二者果中智慧。今正以因中智慧为此经宗。凡有四文为证。一者大品初云。欲得一切种智当学般若。此意言。欲得佛地智慧当习因中智慧。二者劝学品通劝三乘学般若。此经未说二乘作佛而劝令学般若。证般若但在因中非是果也。三者释论初云。为弥勒等说菩萨行故说般若。故知是般若因中之行。至果则转名万德。四者释论四十九卷云。因中名般若。菩萨成佛时转名一切种智。故般若不属佛但属菩萨。又云。般若成佛时转名萨般若。佛智穷坚极利。即是金刚萨波若。今既说波若。故知但明十地无漏。所以是因中般若为宗。有人言。从初地以上终乎佛果。皆平等悉为经体。此则因之与果并为经宗。即开善旧用因慧中。复有二说。有人言。但取无相实慧以为经宗。故胜鬘经云。金刚喻者是第一义智。有人言。实智方便智悉为经宗。故大品二周之说具明二慧。有人言。境之与智合为经宗。故瑶法师云。语经宗极则以实相为宗。明圣心则以妙智为主。是故境智合为经宗。问如斯等说何者是实。答有人言。皆有道理悉是佛语故。有人言。如此诸说并悉失般若意。又有人言。唯我一解是。余释尽非。如庄严云。因名金刚果非金刚。以因中断惑果地不断。开善云。因果俱金刚。因果俱断惑。故云佛智断佛菩提智断。今明般若无一定相。如大火炎四边不可触。岂得各定执。今当一一责之。若言境是波若。而今般若于汝正是智慧。云何辨于般若不以般若为宗遂取非般若为宗。次责问若以智慧为宗者。大智论云。般若深重智慧轻薄。今既说深重般若。何故不取深重般若为宗而取轻薄智慧为宗。次问若取因中智慧以为般若。是亦不然。所以者何。经中有种种说。或云因名般若。果称萨般若。或因果悉称般若。如大经。三德之中有般若德。故知般若亦是果名。不应偏执。次问若言始从初地终至佛果通取因果为宗者。是亦不然。释论云。有人言。漏无漏慧皆是般若。有人言。但无漏慧是般若。龙树无的取舍。何因缘故而汝偏执。又问若言般若通因果者。何故释论但云是因。斯则得通复失其别。次责若言境智合为宗者。亦应境智合为般若。于汝义中。智是正般若。境是相从般若。亦应智是正宗境是相从宗。此与前说更复何异。次问若言七家皆是者。此不识得失耳。如愚痴盲人不知道路通与不通皆言是道。故复为失也。次问若言庄严为是开善为非者。开善亦以开善为是。庄严为非。此亦一是非彼亦一是非。竟谁是耶。如大品云。是见实余妄语耳。问山门解释与他为同为异。答若求由来众解若得。可问与今义同异。求竟不可得。将谁同异耶能如此。不同不异不自不他无依无得。一无所住。即是般若之玄宗也。作上解有所依住。皆非般若宗也。今明般若无有定相。随缘善巧。义无不通。而正般若未曾境与不境智与不智乃至因与不因果与不果。方便随缘。在因名因。在果名果。在境名境。在智名智。故果因境智必得名悉得。如肇师云。原夫能境智因果者岂境智因果之所能。良以非境非智能境能智。非因非果能因能果等耳。而今就文为论。一往方言。般若非因非果正以因果为宗。问以何义知因果为宗。答经及论文并作此说。经云。发菩提心住般若乃至无住相布施。如此大愿大行即是因义。次得如来无为法身。即是果义。论文至信者章中云说因果深义。于彼恶世时不空必有实故知明因辨果事已究竟。然后方明信受。故知因果为此经正宗耳

第六辨经名更开五句(一解佛说二释金刚明解般若四释波罗蜜五三经)。经曰金刚般若波罗蜜。释曰。经题有二种。一者具足。二者不具足。具足应言佛说金刚般若。不具足但云金刚般若。问曰。余经何因缘故不题佛说。答一切诸经佛口自说。皆悉应题为佛说也。而不题者存略故。问曰。何故此经题为佛说耶。答曰。大智论云。有五种人说。一者佛口自说。二者弟子说。三者诸天说。四者仙人说。五化人说。今此经是佛口自说非余人说。是故题佛说也。问曰。余经亦是佛口自说非余人说。何故不云佛自说。答曰。已如前说理实应题。以存略故。复次如大品等经。命须菩提说。非佛自说。是故不得题为佛说。但云摩诃波若。波若具兼师弟子二说。此经不尔。虽对须菩提而佛自说非命说也。复次以理言之。应题佛说。所以者何。诸外道六师等辈亦皆说经。今恐堕邪见欲简异六师故。题佛说使人信受法也。复次道不孤运。必由人弘。法虽佛师要由佛说法乃得弘。以是义故题能说之人所说之法。则于义具足也。二释金刚。问曰。金刚为是譬名。为是法名。答曰。有人言。金刚是譬。如世间中金刚宝坚而且利。譬于波若体坚用利。今谓不然。所以者何。汝于法譬生二见故。谓金刚但譬而非法波若但法而非譬。则譬碍于法不得以譬为法。法碍于譬不得以法为譬。复次若言借世金刚喻般若者。亦应借世智慧以譬般若。若言般若自有智慧非世间智慧。亦应自有金刚非世间金刚也。复次若言金刚是譬喻者。摩诃之名亦应是譬喻。若言般若广大体是摩诃。亦应般若坚利体是金刚。问汝今何故作如此难。答波若名为真实之法。无所依止。不可言大。不可言小。不可言法。不可言譬。过一切语言。灭一切观行。今非小大叹美为大。非金刚非不金刚叹美为金刚。非小非大寄大以宣之。大既是法。非金刚非不金刚寄金刚以宣之。金刚亦得是法。借金刚以目之。金刚既是譬。寄大以目之。大亦是譬。故以譬言之一切皆是譬。以法言之一切皆是法。复次金刚是譬般若是法。金刚是喻非喻为喻。所喻之理非理为理。非理为理虽理而事。非喻为喻虽事而理。虽理而事故知非理。虽事而理故知非事。是以般若未曾理事。但无名相中假名相说。故金刚为事。般若为理。此是不二二义为众生故假名相说二。岂定二耶问云。何是金刚耶。答曰。大智论云。外国名越阇。此言金刚。又华严经云斫家罗。此翻金刚围山。又旧相传直云跋阇罗。真谛三藏云跋阇罗侈(台履反)迦(居伽反)问曰。旧翻跋阇罗为金刚出何处文。答贤愚经第二卷。波斯匿王丑女名跋阇罗。晋言金刚。问曰。汝以金刚喻般若者。此有何义。答曰。如世间宝金刚第一。出世间宝般若第一。复次如金刚宝一切世人不能秤价。般若法宝所有所生功德一切世人不能秤量。复次如金刚宝若置山顶及在平地。直过无碍。到金刚际同性乃住。般若金刚亦复如是。置福山顶若罪平地。直过无碍。到诸法实相非罪非福非有非无同性乃住。复次如世金刚宝照彻清净。故罗什云。方寸金刚照数十里物皆映现。般若亦尔。照实相水明了清净。复次如金刚宝除那罗延一切众生不能执持。般若亦尔。除信悟无依无得大力观人。若乐小法及着见众生不能信持。如经说。为发大乘者说。为发最上乘者说。若乐小法者及着诸见不能信持。复次譬如丈夫食小金刚终身不销。波若亦尔。若能了悟不可朽灭必得作佛。复次若有众生。得金刚宝远离一切贫穷困苦受诸安乐。若得般若离生死苦得大涅槃。复次如金刚宝所在之处能销恶鬼及诸蛊毒。般若亦尔。所在之处天魔外道恶鬼不能得其便。复次如金刚宝悉摧破一切诸物。而是金刚无有折损。般若亦尔。悉能摧破一切烦恼而无折损。复次金刚一切诸物不能摧破。般若亦尔。一切论者及诸烦恼不能摧破。复次如金刚宝若在日中色则不定。般若亦尔。在大众中亦复不定。或说名因。或说名果。在小心人中则名为小。在大心人中则名为大。在境名境。在智名智。而是般若无一定相。故偈云。般若是一法。佛说种种名。随诸众生力。为之立异字。复次如金刚宝虽有如此种种胜用。未尝有心自言我胜。般若亦尔。虽有无量种种功德。而未当有心。是故般若不可思议。问金刚出何处。答毗婆沙云。如从矿出金从金出金刚。故知金中之精名金刚。问金刚与天如意珠云何同异。答大智论云。帝释手执金刚与修罗斗。碎落阎浮提变成如意珠。毗婆沙云金刚能破颇梨山及如意珠。故知异也。复次此明般若与金刚同。而是般若超绝金刚。非可譬喻。金刚是世间物。般若非间失之则忧之得之则喜。得般若者无忧无喜。金刚是无知之物。般若无知无所不知。无量功德今略说而已。复次有人言。声闻法中从假名空终至罗汉通名金刚。菩萨法中从三十心终至佛慧通名金刚。若别而为论。从初地以去终至佛慧始名真金刚。所以者何。而三十心人但是学妄未得真妄。但是伏惑未能断惑。相由入体。所以未得秤真金刚也。亦得相从名金刚。初地以去得于真妄解正能断惑。相不入体。是真金刚。旧以穷学之心喻金刚者。约开善义。伏惑既周。又无明元品之惑。此最难伏。唯是穷学之心而能伏之。故至佛果起佛智断之。以是义故穷学之心名曰金刚。复次有人言。穷学之心正能断惑。故名金刚。如此等说。并言有惑之可断有解之能断。以是义故名有所得。有所得故不能断惑。无有金刚。如经中说。有所得者不从一地至一地。复次汝言未断惑时有惑无解。断惑之时有解无惑。此则惑是本有而今无。解是本无而今有。是生灭观。如经中说。诸法本有今无。又言。若诸法前有后无。诸佛菩萨则有罪过。今所明者。知惑本不有今亦不无。解本不无今亦不有。是故诸法不有不无。不生不灭。非缚非解。无观无缘乃名般若。问曰。若如是者。云何经言一念相应慧断烦恼及习。答若见有生灭。则不能断。以了诸法不解不惑非断不断故烦恼断也。问金刚但喻般若。亦喻余法。答借金刚种种喻。大经以喻法身云金刚身。又喻三昧云金刚三昧。此喻定为金刚也。今喻智慧名金刚也。问金刚是天上宝。是人中宝耶。答人天具有。如转轮王金轮是金刚宝。故所拟皆碎。帝释执金刚与修罗斗。即是天上宝也。第三释般若。般若是外国语。释论有二文。一者般若秦言智慧。开善用之。次文云。般若深重智慧轻薄。不可以轻薄智慧秤量深重般若。庄严法师云。般若名含五义。智慧但是一条。非正翻译。但解智慧经论不同。净名经分二字解之。知众生心念如应说法。起于智业。不取不舍入一相门。起于慧业。旧释此文云。智是有解。慧是空解。亦智是化他慧是自行。大品云道慧道种慧一切智一切种智。此则智慧名通空有也。又因名慧。果秤智。如因名道慧道种慧。果秤一切智一切种智。又智名通因果。如三智义。声闻一切智。菩萨道种智。佛一切种智。又慧名通因果。法华云。诸佛平等大慧也。成论文合解智慧两字云。真慧名智。又云。慧名智人。又云。慧义经中说解脱智是慧义。故智犹慧也。又大智论亦有二文。般若者秦言慧也。又云。秦言智慧也。问经论何故言语或出或没。乍合乍开。不分明一途示人合分明得解耶。答圣人非不能一途分明示人。而今有出没言者。此有深意。以众生本来有取着之心。以是因缘系属于魔。生死不绝。若轮常转。不悟中道佛性正观般若。今若复作一途实说。则更增其依着之心。所以不定出没。动其生死根识令迥悟正法。故不定之说为益深矣。若学者定执经论一文以成一家之义者。皆是系属魔人耳。又众生非一国土一根性一善知识。是故诸佛种种说法也。问已知般若名。云何是般若体。答地论人说。有二种般若。一真修般若。即第八识。二缘修般若。即第七识。成论师言。缘真谛心忘怀绝相。以此解心为般若体。阿毗昙师云。缘四谛理无漏慧相是般若体。此三解即世盛行。具须破洗。至大品玄中广明。但即世多诵此经。今辄言其要句。冀参玄君子领其指外。问今以何为般若。答若行人了悟颠倒。豁然悟解假名般若。问此豁然悟解岂非心耶。答此解悟非心非离心。问云何非心非离心。答既言心悟解。岂离心耶。此悟心毕竟不起有心无心。岂即心耶。问若言心悟还是即心。若言悟此心不得心有无。便是离心。答犹言即离。还是不悟。如其得悟竟有何即离。问既不即离应不迷悟。答迷故言其即离。悟故了无即离。既不即离竟复何有迷悟耶。可取其意。勿着其言也。第四释波罗蜜。波罗蜜此云彼岸到。外国风俗法凡作一事究竟名波罗蜜。今悟道之人虽复积功累劫。若不得般若为行不成。若悟般若万行周毕。故名波罗蜜般若问既有彼岸。云何为此岸及中流耶。答圣人直假名说彼岸。令其因此悟入。何必须作此岸彼岸中流耶。大经云。虽无此岸而有彼岸。即其事也。必须作者。大智论云。有无见为此岸。破有无见智慧为彼岸。檀为中流。第五释经。经有三种。或文为经。或理为经。或文理合为经。地论师云。三十心前人文为经。三十心文理合为经。初地已去用理为经。今明文理因缘故为经。因文悟道故。以能表之文为经也

第七辨传译。问大悲比丘尼本愿经末记云。金刚般若本有八卷。今唯有格量功德一品。此事云何。答义不应尔。所以者何。此一卷经具有三人翻译。一者罗什法师弘始四年于逍遥园正翻一卷。若有八卷何不翻译之。二者流支三藏于此土重复翻译。经之与论合有三卷。而经长有信者一章。论解释始终。事义既毕。初则明经缘起归敬之义。末则表随喜赞叹功德。若有八卷何因缘故止解一品。三者真谛三藏于岭南重翻此经。文小意广不云有八卷。又且此经序正流通三分具足。何得止言一品。问大悲比丘尼本愿经末记又云。初说大品。小品出其中。后说光赞。道行出其中。此事云何。答是亦不然。道行由是小品之异名。大智论前列光赞放光道行。后复列云小品放光光赞。故知小品即道行之异称也。睿公小品序云。此经三十章。贯之以道。故称道行。当知道行由是小品

第八明应验。问诵持般若有何验益。答此经流行汉地二百余年。诵者得益不可称记。昔在山僧诵之。空中弹指异香满室。又开善法师诵得延寿七年。又朱仕衡行以大品投火。火为之灭而经不烧。广益无量。不可具述

第九释章段。此经文约理玄。释者鲜得其意。致使科段烟尘纷秽遂令般若日月翳而不明。今粗列众师以示其得失。原夫大圣属缘吐教意。令表筌悟实。其旨则不在文字。希得意之徒领其要归。其所寄也。自北土相承流支三藏具开经作十二分释。一者序分。二者护念付属分。三者住分。四者修行分。五者法身非有为分。六者信者分。七者格量分。八者显性分。九者利益分。十者断疑分。十一者不住道分。十二者流通分。夫大圣说法必有由致。故有序分。将说大法必为诸菩萨。已悟之徒则须加被。未悟之者付属已悟。故有第二护念付属。既护念付属令其住般若中。故有第三住分。虽得住立更进修诸行。故次有第四修行分也。以修无得之因故得无为之果。故次明法身非有为分。说此因果必有信受之人。故次须明信者分。信持则功德无边。故须明格量分。持说之人所以功德无边必由佛性。若不识于佛性则无此功德。故有显性分也。以依佛性所修功德利益无穷。故须明利益分也。上来一周说法。利根已悟。中下未了。更复生疑。故有第十断疑分。疑心既除则无所依住。故有第十一不住道分。此之大法非止益现在。亦利益未来。故有第十二流通分也。然分虽十二不出因果。统其始末凡有四周。护念付属至修行分此则明因。法身非有为分斯则辨果益。是一周明因果也。次从信者分至于格量此则为因感得显性之果。此则次周明因果也。既明佛性。依性之修行即因义。有因故得果。即利益分。谓三周明因果也。断疑为因。不住道为果。则四周明因果也。然此之解释盛行北地。世代相承多历年序。而禀学之徒莫不承信。余钻仰累年载。意谓不然。今请问之。此十二分为出般若经文。为是婆薮论释。今所观经论悉无斯意。盖是人情自穿凿耳。浑沌之绞络良弊于此也。问作此分文有何过失而汝非之。答其妨甚多。不可具载。今略题数过以示其通塞也。一者作此分文则不识经之通别。所以者何。至如序分则通序一经。如护念付属等十分此是正说中之别段。云何取经之通文以例正说之别段斯则失之大矣。又且汝云从大千珍宝至舍恒沙身命名格量分。此则未识经始终故有斯谬耳。所以者何。此中格量凡举内外两施。外施则有三千之与恒沙。内施之中亦有二种。一者直舍恒沙身施。二者次举日三时舍恒沙身施。此方尽格量之极。汝何故但取前三种为格量分。而不取三时舍身为格量分。是以为失。又且论云从法身非有为分已来并是断疑。汝云何独取须菩提重问已去为断疑分。又且此经有两周之说。经论并作斯判。汝何故取前周之说以开多分。取后周之说合为一分。抑大为小患之甚也。又流通实是大章。还依小段之例。亦所不可。其间碎分章句。爰至异言语目于经论并秽。至文当具显之。复有人言。十二分开之既其难解。取其易见裁为六章。六章者。一序分。二护念付属分。三住分。四修行分。五断疑分。六流通分。此之分别盖是学之劣者。过还同前而患复更甚。所以者何。若言后同是断疑分。就断疑中不复更开。附前亦是同非断疑。不断疑中亦应不开。不断疑中有种种义。既开多分。断疑之中何因缘故取为分。若尔涂行乞食应是一分。若使涂行乞食既属序分而不开者。护念付属属正说亦应不开。又元前解之与后释都不识论文之大体。所以者何。论主直是释其难文略其易句。云何后人见论解释便取为科段。复有人注金刚般若开三门。从如是我闻至愿乐欲闻。是因缘门。谓具此因缘故得说般若。从佛告应如是降伏至见诸相非相。明般若体门。从白佛颇有众生下。明功德门。然此解释义亦不尽。流通复属何门。又复后周重说又属何门。有人言。开为三段。一者序说。二者正说。三者流通说。大圣说法必有由渐。故有序说。序说既竟正宗宜开。故有正说。非唯近益当时。亦乃远被来叶。故有流通说。今谓三说开经于理无妨。但开善之流不识三说起尽。故复为失。所以者何。至如序文取善吉之问为叹请序。如来之答始属正经。此事为谬。然一切经若问若答皆悉是正。云何以问为序以答为正。大涅槃经。时会献供为序。纯陀请受问难即以为正。此经涂行乞食以之为序。善吉发问即应是正。大品亦然。如来广现神变以之为序。告舍利弗即以为正。斯事易明不应滥也。又且三说无定。虽序说不妨有正。虽正说不妨有序。流通亦尔。何者。以序于正故名为序。以正于序故名为正。正说悟道既得是正。序说悟道亦得是正。今但约一往方言故开三不同耳。就此三中各开二段。序有二者。一通序。二者别序。正文有二。第一周广说。第二周略说。流通有二。一序佛说经究竟。二者明时众欢喜奉行。序中二段凡有四双。一者通。二者别。通以同为义。众经六事悉同故名通序。别以异为义。众经各异。或父母送书。或长者献盖。或天雨四华。或涂行乞食。故名别序。次双证信序发起序者。安此六事令人生信。故名证信序。涂行乞食发起正经名发起序。次双遗教序与现前序。明如来将入泥曰。阿难心没忧海不能自喻。阿泥楼驰云。汝是持佛法藏人。所应问者须及时问。于是阿难作于四问。最后问云。一切经初置何等语。佛言。一切经初当安如是我闻。遗言令安此六事。故名遗教序。现说经时即有乞食等事名现前序。次双经前序经后序。说经竟后方有如是六事名经后序。说经之前有乞食之事名经前序。问曰。佛何因缘故一切经初令安六事。答曰。为证信故。大智论云。说时方人令人生信故。复次一切外道皆以吉法贯在经初。故百论云。诸师作经简初皆说吉。今欲简异外道故。故贯以六事。问曰。若安六事异外道者。外道亦言安此六事。何以简耶。答曰。明此是般若六事。故以证信简异外道。般若信者此是无依无得之信。故大品云。不信一切法名为信般若。一切法不生故名为般若生。不信一切法故名信般若也

第十正释文。如是我闻通序有六事。如是者。第一明所闻之法。问曰。佛是一切智人无师自悟不从他闻。何故言如是我闻。若言如是我闻即从他闻。非一切智人也。答曰。已如前释。此非佛自称如是我闻。乃是敕于侍者令称我闻。复次此是阿难等大弟子自称如是我闻。如集法藏中说。阿难登高座。大迦叶问曰。何处最初说法。阿难合掌向涅槃方答大迦叶云。如是我闻。佛初在鹿苑为五比丘说法。是故非佛自称。真谛三藏述婆薮释云。阿难将诵出法藏登无畏座。变身如佛三十二相八十种好。是时大众生三种疑。一谓释迦虽复前灭今还重出为我说法。二谓释迦已灭。此是他方佛来。三谓释迦虽灭阿难既为佛弟子。今遂成佛代于佛处。为有此三疑。是以阿难即便释疑云如是我闻。明如来如是已灭我从佛边闻非上三事也。言如是者。释此一句有二十余师。今略而不述。一者依龙树所解。云如是者。佛法大海信为能入智为能度。如是者即是信也。以信故言此事如是。若不信则言此事不如是。今要由信得入佛法。是故经初建言如是。般若信者。明般若无依无得无戏论毕竟清净真实可信。故因此信得入般若也。次婆薮盘豆释云。如是者。谓决定义。略明二种。一教如是。二理如是。教如是者。凡有数义。一者如佛教度量故云如是。所以者何。三世诸佛或广说法。或处中说。或略说法。今阿难传正法还如佛广略不增不减。故云如是。二者如是诸佛次第而说所以者何。一切说法凡有六事。一者发起。二略标宗。三广解释。四难。五通。六流通付属。阿难今且次第诵持佛语。故云如是。三者如经名字故云如是。传持佛经须识经名。若不识经名云何知义。所以者何。经之名题总摄一经。如大品章虽九十总名摩诃般若。以摩诃之名摄九十章义。为是事故须识经名。阿难如名诵持故云如是。四者因缘如是。三世诸佛说经因缘略具四义。一者根本有一切智方能说经。二者有大悲心然后说法。三者为报正法恩故然后说法。四者决定证信有四。一知说经有时。二知说经处所。三知能说之人即是如来。四知有听经之众。如是时处听众说者。如我所说实可信受故云如是。理如是者。言理是有则名有见。言理是无名为邪见。亦有亦无是名相违见。非有非无名愚痴见。所明之理若堕此四中即不名如是。今离此四谤无所依止故名如是。我闻者。此第二明能闻之人。我者所以阿难自称我者。一欲证亲从佛边闻故非是传闻。所以者何。我今亲从如来闻。是故称我。二者欲显阿难过去世愿行成就。是故称我。阿难无量劫来修习多闻。本愿力故得陀罗尼。一经于耳永无漏失曾不再问。譬如写水置之异器。故法华云。我与阿难于空王佛所同时发心。而我好精进遂致作佛。阿难常乐多闻故持我法藏。又如经云。释迦本昔为迦叶佛作沙弥。师日日限诵经千言。兼为师乞食。恐诵经不上一心忧惧。阿难于时为长者。在路见之忧色便问所以。故具答上事。长者仍语沙弥。日日给食令得安心诵经莫复忧恼。长者发愿言。若沙弥成佛我当为法藏第一弟子。以显宿愿满足故称为我。三者以自在故所以称我。如大经云。阿难具足多闻智慧。一切众生不能一时具领佛语。设能具领。无陀罗尼力不能忆而不忘。虽有忆而不忘。亦不能具三慧于闻法中不能自在。不名为我。我者是自在义。今阿难能一时具领佛语亦能永持不忘。四者具足发生三慧于闻法中而得自在。是故称我。问曰。佛法无我。何故称我。答中论云。诸法实相中非我非无我。欲引导众生故假名说我。是故无过。闻者所以称闻。亦具数义。一者欲显所闻人德。阿难所闻不从外道及佛弟子仙人化人及诸天闻。今所闻者从一切智人边闻。二者欲显所闻法最胜。明佛法名句味巧妙义理深净。若外道法但有语言无有实义。若闻佛法名为正闻。三者所显理最胜佛法正道圆满具足无有颠倒。如理而说名为正说。如理而闻名为正闻。四者行最胜故名正闻。依正教修行。即是行中最胜故名为正闻。五者修行得正果故为正闻。正果者所谓大般涅槃。问为用神闻。为用识闻。为用根闻。为和合闻。若用神闻何故神用耳闻不用眼闻。若用识闻亦如是难。若用根闻无有识时空根应闻。若一一不能闻者和合亦不能闻。以如是义悉无有闻。答曰。今言闻者。是因缘闻。因缘闻者。是不闻闻。闻而无所闻。是以经云。其说法者无说无示。其听法者无闻无得。如来说无所说。阿难闻无所闻。如此说听乃可相成。一时者。此第三明说教之时。如转轮王出世是宝物可得之时。如如来出世法宝可得之时。故云一时。二者一切狂聋众生闻如来说得醒悟时故云一时。又有正师时。有正教时。有正学时。故云一时。具此三时众生得道。中观论云真法及说者听者难得故。若具此三种则生死有边。若不具此三种则生死无边。又众生若未下信种时不名一时。今说般若是下信种时。若已下信种时是正观增长时。若正观已增长时是善根成就时。故云一时。又阿难一时能具足领于佛说。故云一时。又是逗一时根缘。故云一时。所以者何。诸佛说法广略不同。今所以略说波若者。此是逗一时根缘故尔。又须知是般若一时。般若一时者。不时假言时。不一假言一。佛者。此第四标说教之主。上来虽表三事。然邪正未分。第四标佛方显明得失。所以者何。虽言我闻一时。未知从谁边闻。是故今云从佛边闻非余人也。然论云。婆伽婆者能断烦恼有大功德故名婆伽婆。住者有二种。一者外住。二者内住。言外住者凡有四种。一王化处住。谓释迦住在娑婆。二者异俗住。谓住。在一切僧伽蓝内。三威仪住。谓行住坐卧悉名为住。四未舍寿分住。谓如来未入涅槃。内住有四。一者天住。住施戒等。二梵住。住四无量心。三者圣住。住空无相无愿。四者佛住。住诸法实相中。此是般若无住无不住。为众生故假名为住。舍卫国者。此是第五明住处。处有二种。一者通处。二者别处。舍卫国即是通处。祇洹精舍即是别处也。问佛何因缘故多住王舍城及舍卫国。答佛前受。频婆娑罗王请故住王舍城。次受须达多请故住舍卫国。复次欲报法身恩故住王舍城。为报生身恩故住舍卫国。所以者何。佛在王舍城摩伽陀国得道。是故为报法身恩故住王舍城。问佛生中天竺迦毗罗卫国。今舍卫国是东天竺国。今云何言为报生身恩故住舍卫城。答佛上祖本在东天竺舍卫国住。末来中天竺迦毗罗城。今从本立名。故云报生身恩故住舍卫国也。复次王舍城及舍卫国多人物。故佛欲于多人处教化众生。如经说。舍卫国凡有九亿家。如贤愚经说有十八亿人。复次此二国生多智慧人及六师辈。是故佛多住此城。问何故名舍婆提。答有北土论师云。昔劫初有仙人兄弟二人。弟名舍婆。此云幼小。兄称阿婆提。此云不可害。二人住此处求道。因以名之。弟略去婆兄略去阿。二名双取故云舍婆提。真谛三藏云。彼国正音应云奢罗摩死底。此云好名闻国。昔有仙人。有好名闻在此中住。从仙人作名故云好名闻国也。又云。此国具足有四义。一多宝。二此中人多受五欲乐。三有诸法德。此国中人多行施戒。谓之法德。四未来得解脱果。明此国中人未来多生人天中及得解脱果。有此四义远闻余国故云好名闻国也。从来旧翻为闻物国。此土多出好物远闻诸国故名闻物国。十二由经云。无物不有。胜于余处也。问佛住舍卫凡得几年。答经云。住舍卫国得二十五年。有九亿家。三亿家见佛不闻法。三亿家亦闻法亦见佛。三亿家不见佛不闻法。真谛三藏云。住舍卫始终得七年。住王舍城得四年。今未详也。问王城舍卫前住何处。答云。佛前住王舍城。后来舍卫也。言祇树给孤独园者。此第二名为别处。问何因缘故起立此祇园精舍。答如十二由经涅槃经贤愚等经广说。如贤愚第九卷云。舍卫国主波斯匿王有一大臣。名曰须达。其人居家巨富财宝无限。好喜布施燕济贫穷及诸孤老。时人因为其立号名为给孤独。尔时长者生七男儿。年并长大为其娉娶。次第至六。余有第七儿。端正殊异。偏心爱念。当为娶妻欲得极妙姿容端正有相之女。为儿求之。即语诸婆罗门言。谁有好女相貌备足。当为我行求之。诸婆罗门便为推觅。展转到王舍城中。有一大臣名曰护珍。财富无量。信敬三宝。时婆罗门到其家从乞食。彼国法施人物时要令童女持物布施。护珍长者时有一女。仪容端正颜色殊妙。持食出施婆罗门。婆罗门见之心大欢喜我所觅者正当是尔。即问女言。颇有人来求索汝未。女答言未有。更问言女子。汝父在不。女答云在。婆罗门语言。可令出外我欲见之与共谈语。时女入内白其父言。外有客来欲得相见。其父便出。时婆罗门问讯起居安和善否[晹-勿+皿]凉既竟。谓长者言。舍卫国王有一大臣。字曰须达。为国辅相识不。答言。未见其人但闻其名。报言。知不是人于彼舍卫国第一富贵。汝于此间富贵亦最第一。须达有儿端正殊妙卓荦多奇。欲取君子女可尔不。答言可尔。时婆罗门未得自还。仍值估客来舍卫国即便因之寄书。逆报须达具陈其事。须达得书欢喜。即诣波斯匿王求请小许时为儿娶妇。王即听之。于是大载珍宝趣王舍城。于其路次拯济贫乏至王舍城。到护珍家为儿求妻。护珍长者欢喜迎达安置敷具。暮宿其舍。内则搔扰办具饮食。须达念言。今此长者设何供具。欲作何等。将非欲请国王太子长大臣及以婚姻者乎。便问之曰。长者今暮躳自执营如是事务施设供具。为欲请国王太子大臣者乎。答言不也。又问欲设婚姻亲戚会耶。答言不也。又问将何所作。答言。明日欲请佛及比丘僧。于时须达闻佛僧名肃然毛竖。如其所得心情悦豫。重问曰。云何名佛。愿解其义。长者答言。汝不闻耶净饭王子厥名曰悉达。其生之日天降瑞应。天神侍卫即行七步。唱言天上天下唯我为尊。须达闻说如是等好事欢喜踊跃感念信敬。于今夜即欲见佛。于是天为之明。便尔而去。中夜出门见天祠即为作礼忽忘念佛心。于是晓还更闇。自念言。今夜闇。若我往者要为恶鬼猛狩之所见害。且还入城待晓当去。尔时即有天。空中见其欲悔便下语言。居士莫悔。我是汝昔善知识蜜肩婆罗门。因闻法故得生天中。汝往见佛得无量利益。正使今日得百车珍宝乃至一四天下满中珍宝。不如举足至世尊所所得利益。过百千倍。汝去莫悔。须达闻天说如此语益增敬念。于是在闇还得明晓。便尔寻路往至世尊所。佛知尔时须达来便出外经行。是时须达遥见世尊犹如金山。相好威容严然昺着。睹之心悦不知礼法。直问世尊。不审瞿昙起居何如。世尊即时令就坐。是时首陀会天遥见须达虽睹世尊而不知礼足。诸天即化作四人行列而来到世尊所。执佛足作礼。长跪问讯右绕三匝却住一面。是时须达见其如此。乃为愕然而自念言。恭敬之法事应如是。即起离坐礼敬。问讯起居右绕三匝却住一面。尔时世尊即为说法。四谛微妙。苦空无常。既其闻法欢喜即证须陀洹果。于是白佛。唯愿如来垂慈临倾舍卫大城中众生除邪就正。世尊告曰。出家之法与俗有别。住止处所应当有异。彼无精舍云何得去。是时须达白佛言。世尊弟子能起愿见听许。世尊默然。须达辞往因白佛言。还至本国当造精舍。不知揩法。唯愿世尊使一弟子共往敕示。世尊思惟。舍卫城内婆罗门信邪倒见。余人往者必不能办。唯舍利弗是婆罗门种。少小聪明神通兼备。去必有益。即便命之共须达往。于是还到舍卫国。共舍利弗案行诸地。何处平博堪起精舍。悉皆周遍无协意处。唯王太子只陀有园。其地平正其树郁茂。不近不远正得处所。时舍利弗告须达云。今此园地宜起精舍。若远作者乞食难得。近则愦闹妨废行道。须达欢喜到太子所向太子言。我今欲为如来起立精舍。唯太子园地可以宜用。愿欲买之。太子笑曰。我何所乏。此园茂盛当用游戏。云何欲买耶。须达于是殷勤不已。太子聊复戏云。卿若能以黄金布地。令间无空地便当相与。须达于是恭诺。载金布地随价。太子云。我向戏言。何得便买。须达白言。太子之法不应戏言。而作妄语。非谓储君无堪绍继。即共太子往诣断事人所。时首陀会天当为佛起精舍。恐诸断事大臣偏为太子。则便化作一人为断事者。语太子言。夫太子者不应妄语。而有戏笑既已许卖。不宜中悔。遂断园与须达。须达欢喜便得敕使人以象马负金布八十顷。须臾欲满唯残有少地。须达思惟。当出何藏金足不多不少当得满足。只陀问言。嫌高买台。答曰。自念必何金藏可足当满之。只陀念言。佛必有大德。乃使斯人轻财乃尔。即语云。齐是可止。勿更出金。园属卿树属我。我自为佛造立门楼。须达欢喜即便归家当施功作。六师闻之即往白王。长者须达买太子园欲为瞿昙造立精舍。听我与彼捔试道术。其若得胜便听起立。王即召长者问之。今六师云。卿买只陀园为瞿昙起立精舍。彼求共沙门弟子捔其道术。彼若得胜者乃得起造。如其不能不得起造。长者归家着垢腻衣愁恼不乐。身子明日着衣持钵至长者家。见其不乐即问曰。何故尔耶。长者答曰。起立精舍恐不得成。是故愁耳。身子曰。有何事故。答曰。今诸六师诣王求捔道术。尊者得胜乃听起立。若不如彼即不听也。然六师辈等出家来久。素学伎术无能及者。未知尊者能与彼捔道术以不。身子答言。正使六师之徒满三千世界众如竹林。不能动吾一毛。欲捔术但恣听之。长者欢喜更着新衣往白王言。六师欲捔恣随其意。王即告六师宣语国人。却后七日当于城外六师与沙门共捔道术。国中十八亿人。时彼国法击鼓集众。若击铜鼓十二亿人集。若打银鼓十四亿人集。若振金鼓一切皆集。七日既满打鼓一切皆集。六师众有三亿人。是时人民悉为王及六师敷坐。尔时长者为身子施坐。时身子在一树下寂然入定游诸禅门。通达无碍。作念云。此会中大众习邪来久。憍慢自高。此之群生当以何德而降伏之。思惟是已即立誓言。若我无数劫中慈孝父母沙门婆罗门者。今我入众令一切人为我作礼。时六师众已集。而身子独未来。便白王言。瞿昙弟子自知无术怖畏不来。王告长者。汝师今在何许。须达即至身子所白言。大众已集。愿来诣会。时身子从禅定起整衣。安详而趣如师子王往诣大众。是时大众及诸六师见其形容忽然起立。如风靡草不觉为礼。时身子便升须达所敷之坐。六师众中有一弟子。名劳度差善知幻术。于大众前咒作大树荫覆于众。众咸谓言。是劳度差作。时舍利弗便以神力作毗岚风。吹拔树根倒着于地碎若微尘。众言舍利弗胜。劳度差复咒作一池。四边布七宝水中生于莲华。众人言劳度差所作。舍利弗作一六牙白象。牙上有华华上有玉女。其象徐行蹈池含水蹋华。众人皆言舍利弗胜。劳度差复作一山七宝庄严华果茂盛。众人言劳度差所作。舍利弗又作金刚力士。以金刚杵打之即便碎破。众皆云舍利弗胜。劳度差复作一龙有十头。于虚空中雨种种宝电雷振地。众人皆言是劳度差作。舍利弗作一金翅鸟王即擘裂食之。众人皆言舍利弗胜。劳度差复作一牛王。身体肥大峰角。锐地奔突来前。时舍利弗化作师子王即便击裂食之。众人皆言舍利弗胜。劳度差复变身作一夜叉鬼。形体长大头上火然。目赤如血口四牙。目出火惊惧奔走。时舍利弗复化作毗沙门王。夜叉恐怖即欲退走。四面火起无有去处。唯舍利弗边清凉无火。即便屈伏顶礼火即还灭。众人咸言舍利弗胜劳度差不如。尔时舍利弗身升虚空现十八变及八自在。时会见其神力咸怀欢喜。舍利弗即为说法。随其福行各得道迹。六师弟子三亿人于舍利弗所出家学道。捔伎术竟四众各还所止。长者共身子还图精舍地。手自投绳一头。舍利弗欣然含笑。长者问。尊人何笑。答云。始欲经地六天宫已成。即借道眼长者悉见。长者即问舍利弗。六欲天何处最胜。舍利弗云。第四天中少欲知足。恒有一生补处菩萨来生其中。须达言。我正当生第四天中。长者出斯言已余五宫悉灭。唯第四天宫湛然不变也。又更投绳时舍利弗惨然忧色。则问尊人何故忧色。答曰。汝见此地中蚁子不。答曰已见。舍利弗言。汝于过去毗波尸佛时。亦于此地为彼佛起精舍。而此蚁子在此中生。乃至今日凡九十一劫。受一种身不得解脱。生死长远唯福是要。不可不勤。是故身子惨伤长者悲愍也。长者起精舍用妙栴檀为香泥。别房住止千二百人。凡一百二十处打揵槌施设欲往请佛。复思惟。上有国王应当令知。若不启白傥有嗔恨。往白波斯匿王。我为佛已起精舍。愿大王遣使请佛。时王闻已遣使诣王舍城请佛及僧。愿临覆舍卫国。尔时世尊与四部众前后围绕。放光动地至舍卫国。渐近城边一切大众持诸供具迎待世尊。到已放大光明以指案三千世界皆悉震动。伎乐不鼓自鸣一切聋盲拘癖皆得具足。一切人民睹佛欢喜。十八亿人民并聚佛所。世尊尔时随病为说法药各得道迹。须达造精舍因缘事如是。言只陀者。真谛三藏云。外国应云鸠摩罗只陀。此云童真太子。又云只陀者。此云战胜。昔有兵贼欲破舍卫。波斯匿王遂拒破贼宫人启云。生于太子。因以立名故名战胜。须达多者。此云善与。父母无儿就神乞之。梦中得儿故名善与。彼土曾十二年中不雨。而须达巨富赈济贫乏。故名给孤独长者。今言祇树给孤独园者。此是君臣两举。通别二名。只陀是君名。给孤独即是臣称。树是其别所。园即是通处。又祇树是门处故前明。园是精舍故后举。又只陀是本称。给孤是末名。真谛三藏云。须达为过去第四鸠留村驮佛已于此地起精舍。尔时此地广四十里。佛及人寿四万岁。须达尔时名毗沙长者。以金板布地宝衣覆之供养佛也。第五俱那含牟尼佛时。人及佛寿三万岁。尔时须达名大家主长者。以银布地满中乳牛之子以为供养。尔时地广三十里。第六迦叶佛寿及人三万岁。须达尔时名大番悉长者。以七宝布地。地广二十里。以为供养。第七释迦佛及人寿百岁。地广十里。以金布地此处供养。弥勒出世地还广四十里。以七宝布地以为供养。佛及人寿八万岁。须达尔时名儴佉王。儴佉王此云螺王。其色白如螺也。出家得成罗汉。又须知此处是般若处般若依果。其犹弥勒楼馆。亦如法尚香城也

金刚波若经义疏卷第一终金刚般若经义疏卷第二

        胡吉藏法师撰

与大比丘众者。此是第六明同闻众。问何因缘故要须六事。答具足六事义乃圆足。所以者何。如是即所闻之法。我闻是能闻之人。一时是说经之时。佛是演教之主。祇洹为说教之处。今是同闻之众。亦是教所为人。并此亦得是证经人。亦得是听经人。若取释迦同行宿世善友。多是证经之人。证如来所说可信。证阿难所闻无僻。若是听经之人多是实行也。问大智论云。菩萨经初有声闻众有菩萨众。声闻经初但有声闻无菩萨众。若尔今是大乘经。何故有声闻众无菩萨众。答曰。具捡大乘经有四句不同。一者大乘经初但有菩萨众无声闻众。即如华严七处八会。二者大乘经初但有声闻众无菩萨众。即是此经。三者大乘经初具有大小两众。即如涅槃大品。四者大乘经初俱无两众。则如金光明及胜鬘等经也。问何因缘故此大乘经但有声闻众。答曰。今此经中实具两众。何以知之。下流通文广列众故。今但列声闻众者。示以此般若要略门故。又应具四众。今但列比丘者。一者释迦出世比丘最在前入道故。二者心形两胜故。形则胜于在俗。心则胜比丘尼。是故偏列。又此诸比丘是如来内眷属。与佛共住常在佛边。余三众不尔。又比丘众能受正法能说正法助佛扬化。是故偏列。所以不列菩萨者。菩萨是客来故。所以不列。声闻旧众故。所以偏列之。又显示教中声闻威仪胜于菩萨。菩萨形无定方反常而化。又今正欲破声闻人邪曲之见令信受般若。是故偏列。菩萨不尔。所以不列。言大比丘僧者。外国应云摩诃比丘僧。摩诃者或大或胜或多。言大者具大戒故具大德故大名闻故。言多者数至千二百五十人故。言胜者诸众中最胜故。论议能胜九十六种外道故。比丘名乞士。从俗人乞食以资身。从诸佛乞法以练神也。言僧者。福田经说。诸有五净德名曰福田。一者发心离俗怀佩道故。二毁于形好应法服故。三者永割亲爱无的漠故。四者委弃躯命集善法故。五者志求大乘欲度人故。千二百五十人者。佛初成道前度五人。次度优楼频螺迦叶摩诃迦叶得五百人。次度那提迦叶伽耶迦叶兄弟二人各有二百五十弟子。合成千人。次度舍利弗目连复得二百五十人。合有一千二百五十五人。今但举其大数取有名闻者。正云千二百五十也。尔时世尊下。第二别序。就别序中大开为二。第一明如来涂行乞食。第二明如来敷座而坐入于三昧。就此二章各开两段。初章二者。一明往事。二明还事。后章二者。一明敷座。即入定前方便。二而坐一句。第二正入三昧。问何因缘故前明乞食后入三昧。答曰。欲令众生生福德故。所以前明乞食。欲令众生生智慧故。入三昧后说法。复次前利益在家众生故。后通利益出家在家诸大众故。亦云前益白衣则别益。何故。唯就白衣乞食不就比丘比丘尼乞食。故称别后为四众说法则通利益。复次前与众生世间利。后与众生出世间利故。复次前示为福田。显如来是应供故。后明佛为施主。以般若法施众生。即是释迦如来正遍知义。复次初是中前利益众生。后是中后利益众生故。复次前是身业益物。后入三昧是意业益物。次说般若是口业益物也。复次前欲令生身久住故。后欲令法身久住故。欲令生身久住乞食资于生身。后说般若即是益于法身。以有此两住令众生得二身之益也。又乞食示如来少欲知足之行。说法显如来微妙之解。又乞食明佛慈悲。说法明佛智慧。又乞食示末世众生身轨。说法示末世众生心轨。合令一切众生心依般若也。又令弟子从俗人乞食以资身。从如来受般若以练神。二事便足。又乞食破憍慢心。说般若破愚痴心。问大经因食开涅槃与此经何异。答彼经因食开如来法身常身非杂食身。此经因乞食明有上来诸义也。又二经亦同。初乞食明与凡夫二乘同。次说法明不可以身相得见如来故如来身非是食身。论云。三相异体故离彼是如来。要须先同而后异。此即欲令凡夫二乘皆发心求佛身也。问今说般若何因缘故前明乞食。答云。至人动无非时。诸有所作悉皆益物。故不应责所由。复次以近显远。故将说般若前明乞食。所以者何。世间饮食本以资身养命。般若法食资法身养于慧命。复次乞食是四圣之种。般若是众圣之本。复次道远乎哉。体之即神。是故饮食不离般若。若能了食清净即是般若也。就经文中凡有五句。一标福物之人。二明乞食之时节。三辨乞食仪容。四明乞食之处所。五明乞食方法。尔时世尊者。此即是第一标福物之人。成实论云。具上九号故名世尊。食时下。第二明乞食之时。此乃是世间粗事而远表佛法两益。而自他无恼。然世间居士食有定时。初旦则始营未办。晚日啖食既讫。今是营食初熟之时。于是行诣。可谓得时。圣人心虽存道。身托有资。今内无积畜之累。外有福物之功。乞若得时彼我兼益。乞若失时则自他两恼。故云食时。以知时故名大法师。信哉诚说。着衣持钵下。第三明整。于容仪明衣有三种。着亦三时。若平常卧起着于五条。名安陀卫。此云下品衣亦云内着衣。若入众法事着于七条。名郁多罗僧。此云中品衣。若入聚落见国王长者着僧伽梨。此云大衣亦云正着衣。从九条已上至二十五条略为三品。品中有三合成九种。下品三者九条十一十三条也。中品三者十五十七十九条也。上品三者二十一二十三二十五条也。此随形大小故制条叶多少。佛身丈六可着二十五条。今人唯可十五条而已。外国通称袈裟。此云离尘服。若红紫相糅则增物染心。今三种坏色则贪心不起。二云消瘦衣。入道之人身被此服则烦恼折落。三者云莲华服。此借喻为名。体净离垢有类芙蕖。四者云间色衣。三色相间共成一衣。真谛三藏云赤血色衣。外国袈裟虽复五部不同。同皆赤色。问常云三种坏色。云何言并赤色。答常解云。新衣前取青染。次则入泥。次树汁度之名为木兰。故云若青若泥若木兰。三藏云。预是中国人都无此法。言三种坏色者。三色之中随用一色以点印之。若有青处即用青点。若无有青处用泥为点。无泥处可磨铁汁点之。并但应取一色便足。但为时处各异一色不恒。恐诸比丘生于疑悔故言于三种随取一色。十八部义虽异衣色是一。故大经云。见我弟子着赤色衣谓呼是血。但点不同故有诸部为异。若萨婆多部点显现处。上座部则节节皆点。若正量部但点四角也。三藏又云。外国亦无五部着五种衣。但佛为波斯匿王解梦。玄记末世有恶比丘破我法者分为五部。彼土俗人有五性故着五色衣。为表五种神异故也。问佛入涅槃之时。三衣为在何处。答说处不同。若依胎经云。佛将入涅槃手自牒三衣置金棺中以儭佛身。若依摩耶经说。摩耶从忉利天下不复见佛。唯见佛僧伽梨及锡杖。而自悲叹云。我子在世着执此物以用度人。今空无主。以此而推三衣犹在。三藏云。佛五条即在弥梯罗国。七条在半遮尸国。大衣及锡杖在罽宾国。尼师檀在迦毗罗国。持钵者。一随顺三世佛法。二者为破外道手自捧食。三显威仪利物不同下贱乞人。四为示永功德器。无量寿经云贮功德示福田。着袈裟示福田。律中云。佛将阿难往南山国。彼土多有良田。邻垄可爱。仍令传像之以制衣。表出家之人为世福田能令施心种子获无量报。有散种良田收功而万倍故。衣之条叶拟似田之垄畔。所以经云示福田也。钵姼罗此云应量器。即表出家人体具智断内外相应即是应受人天供养之器也。佛初受二女乳糜。即是金器盛之。广于一寻。此是未成道时食器也。至成道竟次受提谓波利长者所施果。或言是糗。尔时未有钵。自念。三世诸佛无有手捧食法。是以四王奉以四钵。佛以手案之合成一钵。而四重文现。又三藏云。净居天还将过去四王石钵以付四王。四王各用奉佛。此钵今在罽宾国。有塔盛之。至像法灭四王还将付净居天。净居天待弥勒出令四王送与弥勒。然钵之大小三品不同。上品容三钵他饭。一钵他羹。余可食物者半羹下品则容一钵他饭。半钵他羹。余可食物半羹。若大于少少于大是为中品钵。钵他是外国六舛器。上品钵则容三斗。可盛二斗七舛食。须空上三舛。以示少欲。下品钵容一斗半。可盛一斗二舛食。须空上三舛。则是一斗二舛。两盈之间名中品钵也。大智论云。明钵有八种。不许弟子畜金银钵。恐生贪故。不许畜木钵。受垢故。但许畜二种。谓铁瓦等也。佛畜石钵也。问曰。颇有佛不着袈裟不用钵不耶。答有。大论云。天王佛作白衣威仪也。入舍卫大城乞食下。第四明乞食之处所。旧解云。园去城有千二百步。或有言四里。如来受食其法有三。一坐待日时。名膳自至。二则外来请佛。请佛有二。一者佛与众僧俱去。二者僧去而佛不去。遣人请食。所以不去者凡为五事。一为入定。二为诸天说法。三为看病比丘。四为案行房舍。五为欲制戒也。三者如来自行乞食。行法有三。一则飞空而去。二者足离地四寸而印文现地。三者足践莲华而莲华动而足不动。佛所以涂步乞食者。依璎珞女经凡有十事。一者如来入城乞食。众生见佛三十二相如须弥山王故发菩提心。必求如来身也。二者城中有盲聋疾病等人乃至百苦。不能得至如来所。是故如来入城放光照之。众苦休息便发菩提心。三者为刹利婆罗门豪贵长者自恃种性不生敬心。见如来威德严仪挺特有异于世故憍慢心息。故发菩提心。四者为守护女人有三监五碍故不得见佛。又为懈怠者虽与如来邻住而不能往。故佛今入城令其因得礼拜问讯。故发菩提心也。五者如来入城四王八部皆悉导从。各赍华香歌咏供养。城中人见即便生念云。诸天尚舍天乐供养于佛。我等云何而不供养礼拜者哉。故因发心也。六者如来持四王所奉之钵。实是一钵四缘宛然为异。城中人见此希有。是故发菩提心也。七者为贫富二人。若使富者见如来钵空于是多施。若是贫者便见如来钵满即少施皆生欢喜。故发菩提心也。八者如来钵中受百味饭食。皆悉不杂还如异器盛食。一切众僧诸众生等恣意而散不增不减。见者欢喜无不发心也。九者为未来弟子诸比丘等。现行乞食作其仪轨不畜有为。十者如来之身常在三昧。其身不食。但为利益众生故现行乞食。以是因缘故云入城乞食也。言于其城中次第乞已者。第五句明乞食方法。有论师言。外国四姓豪族并在城内住。若使庶人屠儿等并在城外住。若入城时各自别行不相参杂。今言次第乞者。由在城内四姓之中。不择其贫富次第而从乞也。又善吉舍贫从富谓今虽受果未来无因。今欲使其修未来因业果相续。是故舍贫从富也。迦叶则舍富从贫。愍其交切之苦。又过去不施今生贫穷。今不行施来世复贫。贫相系无得脱时。是以舍富从贫。此之二人虽有慈悲而不能平等。是故为净名所屈。今如来欲显平等之道。所以次第乞也。还至本处下。第二明得食后事。然须识般若大意。此是去而不往。归无所还。受而不纳。食而不餐也。此中亦有四句。第一明还至本处。然钵他既满须反所住以待中时。又利物故往。利竟便还。所以令钵满即还。不许随得随啖者。略有二。前供养师长。二兼济老病。如来得食分为三分。一分布施陆地众生。一分布施水中众生。一分自食。若有老病亦分施也。饭食讫者。第二句明食事竟究。收衣钵者。第三明摄容仪也。洗足已者。第四句亦有五。一者明洗尘累。涂步行乞虽离地四寸而示有尘垢。故便洗也。二示尊敬般若故须身净方说。三为护僧卧具。四为诸天下礼敬于足。五为表众生烦恼应净。问佛日行几里。答如转轮王法日行四十里也。问乐璎珞女经云。虽明乞食为于十事。今更有余义不耶。答三藏云。佛欲为破恶世贪名利高慢出家人多贪积聚。是故如来自行乞食。又为息外道讥谤言沙门释子多好着乐。是故行乞。又为显如来少欲知足。不受人天所奉供养躬自行乞。又有二外道一者乐行。坐受供养。二者苦行。过时而乞。所以过时者。正以或得不得为苦行也。今如来为破二事。佛自乞故破着乐外道。以其乞得时故破苦行外道。敷座而坐下。第二明将说般若故前入三昧。文亦有二。一者敷座定前方便。二者而坐正入三昧。所以自敷座者。般若名为佛母。今欲尊敬般若故自敷座。二者随顺诸佛教戒。若不自敷座卧具。得突吉罗罪。又是示少欲知足。不使人敷也。言而坐者。第二正入三昧。论经长有结跏趺坐。是坐中最胜故。见者欢喜故。身得安稳故。心得端直故。所以入三昧者。如来静散无二。实无出入。而今为说法人作于模轨。夫说深法必须静心。若不静心则不识根缘亦不审法相。是故如来前入三昧然后说法。则是明照于根缘明审法相。毗婆沙云。依相书善法示聪明人相。聪明人相者。善言所言。善行所行。善思所思。是故如来入定思惟然后方说也。又示轻贱薄众生模轨法则故。有人得少知见。他问即答而不思之。如来不尔。久思惟竟方乃说也。时长老须菩提下。若依开善此则犹属序分。此之一文名叹请序。今谓不尔。已如前说。善吉正问。如来正答　如华严普慧二百句问。普贤二千句答。何故容割问为序截答为正。北地论师云。此文属十二分中护念付属分。是亦不然。如前说善吉有叹有请。叹即是护念付属。请即是发乎四句问。若以叹为护念付属分者。应以请文为请问分。若言论解护念付属以之为分。不解请问故请问非分者。论亦不解通别二序。应无序分。然此是未见论家制作之意故生此谬耳。此是易故不释。难故须解。岂是解与不解而判分与不分耶。今从此文属第二正说般若分也。若三业分经者。乞食等身业利益分。入三昧意业利益分。今是口业利益分也。若以福慧为判者。上是生物福德门。今是生物智慧门。亦上是利益在家门。今是通益一切门。具如前十数对说。亦不可专作序正两分。故经意无尽。言多不足。三段失旨。意显于兹。今聊寄一名为序正流通之说耳。就此正说开为二周。第一周为利根人广说般若。第二周为中下根未悟略说般若。作此开文惊乎常听。今具引事义证其起尽。问何以知前是一周后复是一周说耶。答今当以数义验之。一者经自有文。善吉有前问后问。二问略同。如来前答后答二答相类。是故当知二周说也。又经语难明。今以论为证论解前经答四问竟。而后次第生起释玄疑伏难。蝉联而来。亦释后问竟次第生起释玄疑伏难。相接而至。是故知为两周也。斯乃经论两证岂虚构哉。问曰。圣人制作理致玄远。辞即巧妙。岂当一轴之经遂有二周烦长。答曰。虽曰两周其旨各异非烦长也。所以者何。类如大品两周。前周明于实慧。后周辨于善权今之两周在义亦异。前周则净于缘。后周则尽于观。然要须缘净观尽不缘不观无所依止方能悟于般若。故肇公云。法无有无之数。圣无有无之智。法无有无之数则无数于外。圣无有无之智则无心于内。于外无数于内无心。彼已寂灭乃阶其妙。影公云。万化非无宗。宗之者无相。虚宗非无契。契之者无心。故至人以无心之妙慧契彼无相之虚宗。此则内外两冥。缘智俱寂。岂容名数于其间哉。斯二三子言与经会。信而好古。余岂异哉。问何以得知前周尽缘后周尽观耶。答经有明文。论有诚说。前经直云虽度众生而无众生可度。正叹菩萨依般若作无所得发心乃至无所得修行。而经意虽复缘观俱息。但文未正显灼破于观主。故钝根之徒由言有于菩萨巧度众生巧能修行。故后周经文方息四心无发心人乃至修行者。然前周正劝生四心。后周明四心亦息。岂不然乎。论偈云。于内心修行。存我为菩萨。此则障于心违于不住道。以是义故当知。此文正息观至尽于观主。文义昺然无所疑也。此之二周非止是一经之大意。乃是方等之旨归至人环中之妙术也。又前周为前会。后周为后会。下当更辨。就前周文科为二别。一善吉致问。二如来答。就问之中复开为二。一者经家序能问之人仪容。二者发言正问。初序中又二。一者标对扬之主。二序请法之仪。尔时者。此是如来加与善吉之时。亦是时会发悟之时。故云尔时。问此经加与义与大品何异。答大品则具口意二加。发言命说称为口加。与其智慧辨才名为意加。今此经但其与智慧辩才为意加。不命之令说无有口加也。然下文亦有对扬之义。但无炳然命说故与大品不同。须菩提者。此人本迹其事难知。三藏云。是本东方世界青龙陀佛影向能仁为弟子化。其犹文殊之例也。或有经云。此是化人。摄大乘论明身子是化人。善吉犹为其例。又经云。是舍卫国长者之子位登遗颜。言遗颜者。法身菩萨过阿鞞之位也。复云。是舍卫国内有婆罗门。名曰鸠留。其人无子祈天神。天神云。汝家大富无堪生者。因见一大德天下诧生其家。儿既长大。令父母请佛还家。后送佛反于祇洹即得罗汉果。复有经说。昔为白衣人。见沙门乞食不得空钵而反。因以食与之。后得十劫常生天中。故其人福德深厚无比。又言。是净音向王太子。如此等说多出福报杂譬喻经。须菩提者翻为善业。亦言善学。旧云善吉。善吉与善财生异。何者。善财生时七宝踊现故名善财。须菩提生时举室皆空。父母疑怪请问相师。相师云。唯善唯吉。故名善吉。又云空生。即从生时受称。其人内秘菩萨行。外现声闻。位高可崇故呼为长老也。即从坐起下。第二明请法之仪。此中凡有五句。一避席修敬。弟子仪法既尊人重法。不可晏然而坐。故将欲请道。所以避席。偏袒右肩者。既表师弟之仪则。示永有驱策之相。又是随从国法。故修敬袒肩。右膝着地者。此明屈曲伏从。示师弟无有违拒之貌。合掌向佛者。此是敛肃容貌专心受道也。而白佛言者。上来经家序其身业此之一句序其口业也。希有世尊者。此下第二正明发问。就此为两。第一称叹。第二请问。言希有世尊者。中阿含二十四卷云。昔时大王者我身是也。我从子至子从孙至孙从族至族。八万四千转轮王。并前剃除髻发舍家趣非家。又增一阿含第二十一卷云。若如来不出家者。当二千五百岁作转轮王。今舍转轮王位遂能为物涂行乞食。故为希有。又善吉知般若无相无貌。念想观除言语亦灭。而无名相中为众生故作名相说。虽作名字而不伤无名。故为希有。譬如劫尽大火世界洞然。有人担一束干草而从火中过不烧一叶。故为希有。善护念诸菩萨善付属诸菩萨者。叹也。问何因缘故有此叹耶。答此一言贯于前后。如来所以涂行乞食者。正为大慈大悲。护念付属诸菩萨故也。又今说般若者。亦为护念付属诸菩萨故也。又叹上涂行乞食以为希有。则叹佛身业。今叹护念菩萨。是叹如来意业。善付属诸菩萨。即是叹口业。如来既三业利物。故善吉并叹三业。问云。何名为善护念耶。答欲使其内德坚固名为护念。令其外德成就名为善付嘱。问诸佛如来常念六道。何因缘故偏念菩萨。答虽常念六道。但菩萨堪受般若。有其内因。是故外为诸佛护念。问诸佛护念有何利益。答犹如鱼子。母念则成不念则坏。菩萨亦尔。佛若护念善根则成。若不护念善根则坏。付嘱者。以无上法宝付诸菩萨。以诸菩萨善能问答。如是法宝则得久住无量千世。所以通称为善者。若护念付嘱声闻则不善。今以护念付嘱菩萨故名为善。具如大经付嘱老少二人譬也。依论解释。论曰。巧护义应知。加彼身同行者。此释善护念也。善是巧之异名。故云巧护义应知也。加彼身同行者。护念即是加与之义。谓加与二力。一者加其智慧力令成就佛法故。此即是加其自行。故名为身。身即自身也。次加其教化众生力。即是加其化他力。令受化之徒与其行同。故云同行也。不退得未得是名善付嘱者。此之半偈释付嘱义。论云善护念者。依根熟菩萨说。善付嘱者。依根未熟菩萨说。根熟菩萨则堪加与自行化他二种之力。以如前明。今以根未熟菩萨付嘱根熟菩萨。令其未熟得熟也。不退得未得者。已得功德令其不退。所未得者而令得之。故云不退得未得也。问论释之与旧解云何同异。答论以人付嘱于人名善付嘱。旧释以法宝付嘱于人名善付嘱。两言虽异会归终一。以人付嘱人终令得悟法。即是付嘱法义。以法付嘱人终为化人义。即是付嘱人也。又一义防遏众魔不令得菩萨便为护念义。为说道法令如说修行为付嘱也。问根熟与未熟约何位耶。答北地论师云。根熟菩萨即是内凡习种性之人。必能趣于初地名为根熟。若是外凡未能必入于初地名为未熟。善男子善女人发菩提心者。此第二正发问。若依罗什法师翻经唯可三问。一问菩提心。二问云何应住。三问降伏。但解此三问众师不同。第一师云。问虽有三不出愿之与行。菩提心一问即是问愿。降伏住二问即是问行。菩萨之道不出愿行二门。行以涉行为义。愿以要期为旨。行若无愿行则无所御。愿若无行愿则不果。其犹鸟之二翼车之两轮。故行以即事涉行。愿以悬求未得。今明行愿之义实如所说。若偏以菩提心为愿。此事未然。今以发正道心名菩提心。岂得空有其愿而无行耶。复有师云。应为三问。一问菩提心即问平等空。二问云何住问实法空。三问云何降伏问假名空。然观门次第应从浅至深。今乃从深至浅。此是说门非是行门。问者唯慕其深前问深也。今谓此亦不然。三空乃通贯大小今正辨菩萨之行。又且问无三空之辞。佛答无三空之意。初答乃明菩萨成广大心遍度众生而无所度。非谓但明假名空也。若但明假名空。即应但辨无众生亦无度义亦无广大心义。今乃明大心而无度无度而大心。此乃是无度度义度无度义。二慧具足。云何偏是假名空。次答住问亦非实空。若是实空。应明无有诸法无有修行。今乃明于一切法无所依住而修檀等万行。岂偏是实空耶。今依论经凡有四句问。一问云何发菩提心。二问云何应住。三问云何修行。四问云何降伏。所以有此四问者。凡为菩萨必须发菩提心。故前问发心。若不依般若发心。则住颠倒不住般若。今依般若发心。则住般若不住颠倒。故次问住菩提心。既得住立故修行万行。所以次问修行。以修无所得行故颠到有得之心析伏不起。所以次问降伏也。佛言善哉。此下第二如来答问。开为二别。一答问缘起。二正答。答问缘起。复开为二。一美其叹请。二则许酬其问。然佛叹善吉者。良由善吉叹得时宜问复会道故佛叹之。又善吉是声闻人今遂能问菩萨事。此为希有故复叹之。又时会恐菩萨道深小乘智浅问容僻谬。故印叹之令众尊人重法也。汝今谛听下。此第二句许答其问。就文为二。初正诫许。次受旨愿闻。此两易知皆如文所列。佛告须菩提下。第二如来正答。就正答中若依论判。则应开为两。则酬其四问。次从于意云何可以身相见如来下竟经。皆是断疑。故论主判此章。云自下一切修多罗中断生疑心。前酬四问名为略说般若。后断众疑即是广说。今采论意按致一经开为三别。第一明般若体门。二明信受门。三明格量门。明此三者。既称般若波罗蜜经。故前明般若体。既明般若体竟。必有信受人。故次明信受门。信持则获福无尽。故次明格量门。又前就因果说般若。即是法门次就信受门说般若。即是人门。后就功德门说般若。明人行法故得功德也。就前门为二。一答其四问即明因门。二断众疑次辨果门。因即无依无住。果则无相无为。般若未曾因果。为众生故故作因果名说。就明因门答其四问唯有两章经文。由来旧释。初章经非答菩提心门。乃是答降伏心问。次章经答其住问。后举佛果答菩提心问。北地论师云。初答其住问不答菩提心问。今谓并不然。若言此中遍度四生非答菩提心问者。汝复以何法名菩提心。又下第二周中善吉更发三问。佛答发菩提心者。当生如是心灭度一切众生而无灭度。此即是牒菩提心问而解释之。云何言非答菩提心耶。今明经虽两章共酬四问。初一章经答住问。即是答菩提心问。次一章经答修行问。即是答降伏心问也。问云何答其住问。即是答菩提心耶。解云。由发菩提心故得住大乘法。若不发菩提心则不住大乘。故论云利益深心住此乘功德满。就初经文复开为二。第一对于善吉总劝菩萨发菩提心。二者正明发心之义。初则如文。问曰。今正辨菩提心。宁言如是降伏其心。答以发一菩提心故不起凡夫及二乘心即是降伏。初明遍度众生故异二乘心。降伏二乘。后明度无所度。是降伏凡夫心也。降伏二乘即是以他降自。降伏凡夫心即是以无降有也。又降伏二乘亦得是以有降无。二乘无慈悲心菩萨有慈悲心故。是以有降无。复以无降有。如前说也。又此中明大慈大悲。即降伏贪嗔烦恼。故名降伏。又菩萨虽度众生。实无众生可度。即是降伏众生见也。又菩萨若言有众生可度。即是常见。若言无众生可度。则见断见。今虽度众生实无所度。故降伏常见。虽无所度而常度众生。故降伏断见也。所有一切众生之类下。此第二正明发菩提心。论偈云。广大第一常其心不颠倒。利益深心住此乘功德满。故用于四心释此经文。四心者。一广大心。二者第一心。三者常心。四者不颠倒心。问何因缘建乎四心。答凡为菩萨异凡夫二乘自调自度。今言遍度三界六道名广大心。虽复遍度众生。若遍与众生人天之乐名为下心。若遍与众生二乘之乐名曰中心。今遍与众生大涅槃乐名第一心。菩萨虽复遍与众生大涅槃乐。或时休息。生死道长众生性多。云何可遍度之令得常乐。是故于生死中起疲厌心。今明生死边如虚空。众生性边亦如虚空。是中无生死往来亦无解脱者。故能菩萨常度众生诲而不倦名为常心。虽度众生而不见众生可度。是名菩萨不颠倒心。以建此四心住菩萨道得大利益故。论云利益深心住。是故建此四心则菩提心满足。故论云此乘功德满。虽有四心不出慈悲般若。前三是慈悲心。后一是般若心。前是功德。后是智慧。前亦是方便。后名为实慧。故发心即具福慧亦即具二慧。如大经云发心毕竟二不别。若望开善义。假名空但是空心。但得四中之一。又二慧中但得实慧意耳。问何故名广大心。答从所有一切众生之类至非有想非无想已来。总摄众生名广大心。此中二句。所有一切众生之类。此总摄众生。若卵生下。此有三句别摄众生。第一句以一门摄众生。谓一生门。第二有色无色二门摄众生。欲色两界名为有色。无色一界名为无色。第三以三门摄众生。无想者即是色界第四禅中无想天也。非有想非无想者无色界最后天也。有想一句。除上二处通三界也。问何故不以六道摄众生。答六道不摄中阴。四生则一切摄故也。我皆令入无余涅槃者。此下第二明第一心也。此言无余者非灰身灭智小乘无余。斯乃无累不尽无复余累。无德不圆无复余德。故云无余也。问此乃是涅槃教意。云何释般若文。答作此问者乃是五时教意非经论之说。般若论云。此经正辨无为法身。与大般涅槃更复何异。如是灭度无量无边众生者。此下第三名为常心。问般若论云。不见众生异于菩萨常不离是心名曰常心。此意云何。答今言常心可有二义。一者常不离正观心名曰常心。则是论意。不见众生异于菩萨。不见菩萨异众生故众生菩萨皆毕竟净。常作此观名曰常心。二者以正观心常度众生不休不息名曰常心。何以故若菩萨有我相下。此第四明不颠倒心。虽常度众生无众生可度名不颠倒。若见有众生则是我见。凡夫自不能度。何能度物耶。复次须菩提于法应无所住行于布施下。此第二章经答修行降伏心二问。前明以初发心故得住大乘。不发心不得住大乘。故发心与住二事相成。故合詶也。今二门亦尔。以修行故得降伏颠倒。若不修无得万行。以何降伏有得烦恼。故二门相成。故须合詶也。又四门次第。前须发心。发心故得住大乘。住大乘故修行。修行故烦恼得降伏也。然此经文略意含。非可一言得尽。今更以数义释之。一者前章正辨发菩提心。今此一章辨于修行。所以明此二者。如华严经善财童子于一一善知识所。皆自称云已发菩提之心未知云何修菩萨行。学菩萨道。故知前须发心然后修行。菩提心即是愿义。今之一章辨菩萨行义。菩萨之道虽复多门。统其大归不出愿行。然愿门虽多略为四弘誓愿。行门无量略为六波罗蜜。四弘誓愿者。一未度苦海令其得度。二未脱业烦恼缚令得脱之。三未得道谛之安令得安之。四未得灭谛涅槃令得涅槃。前章明一切众生皆得涅槃。即是四愿之中略举后究竟愿也。今一章经略举六度中最初行也。然前章举于后愿则摄得三愿。后章举初行则摄于五行。问云何后愿得摄前愿。云何初行得摄后行耶。答后愿既令众生皆得灭谛涅槃。岂不度苦脱集见道谛耶。次辨初行摄后行者。论云。檀义摄于六。资生无畏法。此中一二三名为修行住。此偈意明六度悉名为檀义。但檀义有三种。一资生檀即是布施。资益众生亦是以资生之物以用布施。二者无畏檀持戒忍辱。持戒即不犯财夺命。即是施物无畏。忍辱不加报于物亦是施物无畏。故此两度名无畏檀。精进禅定智慧此之三度名为法檀。言法檀者以法施物。故名法檀精进则说法无倦。禅定则知他人心方能说法。般若是智慧。正能说法。故此三种名为法檀。言一二三者。一即是资生檀也。二则戒忍。三即后三度也。又此中依般若修行。但明布施者。如摄五品檀说具摄于五故。又略举初故。又檀则摄众生之要法故也。又前章经明菩萨内有大慈大悲。此一章经明菩萨方便外能赴救。所以者何。菩萨发菩提心以赴缘度物为务。故大品云。菩萨大事者。所谓不舍一切众生。然度众生必须二事。一者内有慈悲心。二者外有方便救济。前章明遍拔众生生死苦即是大悲心义。与众生大涅槃乐即是大慈心义。虽内有慈悲之心。未有慈悲之事。是故今辨菩萨修行布施等万行而拔济之。令其离苦使其得乐。即是成上慈悲之义。问曰。上辨内有慈悲。今明外能赴救。何须般若。答上辨内有慈悲要须般若。若无般若则慈悲不成。故大论云。慈悲与实相合行。大悲虽拔其苦而实无所拔。大慈虽与其乐而实无所与。故慈悲不妨毕竟空。毕竟空不妨慈悲心。故虽行毕竟空观而不舍大慈大悲。虽行大慈大悲不舍毕竟空观。故知即以毕竟空为慈悲。即以慈悲为毕竟空。故慈悲未曾不空。空未曾不慈悲也。今明修行亦与实相合行故。虽修万行而实无所行。虽无所行而常修万行。故行无所行。无所行故具二慧也。又前章经正明菩萨度于众生始识众生相识于度相。知度无所度。方是识度。知众生无众生。方始识众生。今此章经正辨度义。前虽识度犹未正度。如虽复识病犹未授药。今此章经正明度义。即是正授于药。亦前章正明识病。此章正明识药。众生即是病。由般若故能识众生。即是由般若故能识病也。今修万行并为众生。是故万行悉名为药。由般若故解悟万行。由般若故方能识药。又前章经正辨众生空。今此章经明诸法空。前辨虽度众生无众生可度。故是众生空。今明虽修万行实无所修。即是法空。问曰。大品开宗则云不见菩萨及菩萨字。此经开宗何因缘故但言不见众生。答大品不见菩萨即不见众生。此经辨不见众生即不见菩萨。但两经互举。能所不同耳。又大品正劝菩萨学般若。或者便谓有菩萨能学般若所学。为此义故前破菩萨明不见菩萨。此经明菩萨发菩提心欲度众生。便谓有众生可度。是故今破无有众生。问曰。何因缘故前辨众生空。今明法空以为说般若耶。答曰。般若未曾空与不空。但众生多滞有病故破有病明于空耳。有病既息空则不留。如大火炎不可四触。但佛在世时众生根利直闻说空不取空相。故无所依止即便得道也。就此章经开为三段。第一正明无住相以修行。第二明得无所得果。第三结劝。就初为二。第一正答修行问。第二答降伏心问。此即第一言无所住行布施者。即如大品开宗不住法住般若无所舍具足檀。然此中既云不住六尘。亦即不住六根六识。但文略故偏明不住六尘耳。大品问住品。明不住一切法故是住般若。今言不住六尘。六尘摄法尽矣。然菩萨身口意业一切所为行住坐卧乃至举动施为产业之事。皆是无依无得。今偏言不住行施。岂非略举一以例诸耶。若依论经便有三种。一者不着自身故行布施。若着自身则惜外物故不行施。今不着自身则不惜外物故能行施也。二者无所住一句。即是不着报恩。报恩者。谓供养恭敬等也。三者不住色声香味触法布施。即是不着果报。果报者。谓人天乐等。菩萨若着报恩及以果报则舍远佛道。是故不着报恩及以果报也。须菩提菩萨应如是布施下。若依论意即是答第四降心问。然要须修行故有所得心乃降伏耳。故次修行后明降伏也。以菩萨不见三事故行布施名为降伏。言三事者。谓施者受者财物等。以不见财物故得诸法空。不见施者受者故得众生空。以得此二空即是降伏人法见也。然论作此意正以修无所得行即是降伏有所得心。故两问相成两答相成也。问初章经亲有降伏言。何故不答降伏问今始答之耶。有释云。先但明众生空。未明法空。故生法二空未具得不得称降伏。今具得生法二空始是降伏名也。又前始明是菩提心未明菩萨行。故降义未成。今愿行俱成降伏义始显也。若菩萨不住相布施下。此第二明修无所住因得无所得果。所以有此文来者有二义。一者即是举果劝修。良以修无住因得福无边。是故劝修无住相布施也。二者即是释疑。疑者云。有住布施可有福德。无住布施应无福德。是故释云有所得施功德则少无所得施其福无边。问今持戒行道书经造佛功德可多。云何以无住心而作福与十力空等。此言极成过差也。答覆面之舌言岂虚哉。子若不信今当略述。夫福德因扶理而生。故释善以扶理为义。以无所住盖是扶理之极。福岂不多。以此而思焕然可解也。故一切有所得心积劫种种修行持戒坐禅皆是乖道。故福不多。今无得施与道相应。故福多。故尔前一切功德不及五华施福多也就此文开为三别。第一法说。第二譬说。第三合譬。法说如文。东方虚空下。第二譬说就中有两。初举东方虚空为喻。次举九方虚空为喻。各有问答。如文寻之。问何因缘故借虚空为喻。答凡有二义。一者虚空无相无为。无住相施无依无得。是故假此为喻。二者虚空包含广大。无住相施果报亦大。故假喻也。须菩提无住相布施亦如是下。第三合譬。如文可寻。须菩提菩萨但应如所教住下。此第三章结劝也。所言如所教住者。如上来无所得之教。应须依此而住依此而修行也。须菩提于意云何可以身相见如来不下。若依开善。举平等空答菩提心问。今谓二义不然。一者有颠倒过。要先发菩提心然后行菩萨行。岂得前明菩萨行竟今始辨发菩提心耶。二者此中文云可以身相见如来不。若是平等空则无复如来。何名见佛耶。今作五义生起此章。一者若依论释。自上已来答四问竟。从此下第二章断生疑心。答于四问即是略说般若。若断生疑心则是广说般若。故论云自下一切修多罗中断生疑心。故知说经皆是断生疑故也。若依因果分门。上来酬于四问即是辨无所得因。此下第二明无为法身之果。若行有所得因还得有所得果。故大经云。有所得者名曰无明。有所得者名二十五有。今无所得因故得无为法身之果。故大经云。无所得者名为智慧。无所得者名大涅槃。又初章经明发菩提心。次章经明修菩萨行。今一章经辨得于佛道。此三即是次第。是故斯经其义要也又成上菩提心义。发菩提心下度众生上求佛道。下度众生已辨众生之相。故度无所度。今上求佛道。故须识法身。即是求无所求。若不识众生则不能度众生。若不识法身则不能上求佛道也。若有所得发心求佛。如净名所呵。即欲令其舍菩提见。而是发菩提心舍于佛见。乃见佛耳。亦上辨度众生即辨众生空。次辨修万行则辨六尘诸法空。此人之与法并是世间毕竟空。今明不可以诸相得见如来。即是诸佛空。故众生无所有则非众生。诸佛无所有是即非佛。故非众生非佛非生死非涅槃。故众生与佛本来不二。然为破二见故云不二。在二既息不二亦除。故华严云。不着不二法。以无一二故也。若能如此而悟。一切诸见毕竟不起。始是金刚。称为般若。就此文中开为三意。第一如来腾众疑以问善吉。二善吉对如来以释疑。第三如来印述结成得失。此即是初。所言疑者。上云菩萨行无住相圆因。时众生疑。因若无住果应无为。今见果是有为。云何因是无住。所以者何。小乘人言。释迦之身体具有三相。初生王宫即是生义。次八十年住世即是住义。双林入灭即是灭义也。今果既具此三相。岂得言因是无所住耶。是故佛腾众疑以问善吉。可以身有三相见如来法身不耶。须菩提言不也世尊下。此第二善吉对佛释时会之疑。问佛应自释。何故令善吉释。答欲示有得解之人故令善吉释。又善吉是小乘人。今欲引接小乘人令信如来身是无为故令善吉释也。又如雀母引子。善吉亦尔。欲引声闻令同其所解。善吉是声闻既知如来身是无为。我亦是声闻。亦须知如来身是无为不为三相所相也。又善吉欲引菩萨令求如来法身。所以者何。小乘之人尚知如来身是无为。云何菩萨言佛是有为。问涅槃经可辨佛是无为。般若经云何有于此说。答盖是五时教人作此问耳。今般若论中正破此问。故偈云三相异体故离彼是如来。岂得般若教中佛是有为。又今辨般若正法即是法身。般若非为非无为。即是法身。非为非无为但为对凡夫二乘身是有为故。叹美作无为耳。亦不同北土论师谓如来身定是无为。为与无为并是般若功用也。不可以身相见如来者。不可以生住灭三相见如来无为法身也。何以故如来所说身相者。时会复疑。若言三相非如来者。何故如来昔说有三相耶。昔说生在净饭王家。即是说有生相。却后三月当入涅槃。即是灭相。八十年住世。即是住相。是故释云。如来所说有三相者。即非身相。言非身相者。非是法身无为相也。此是无生生方便。即是生身。故有三相。若生无生方便。即是法身。无三相也。佛告须菩提下。此第三如来述成结其得失。所以须述成者。时会恐善吉所解未能不谬。是故如来述成其解。就此文中凡有两句。初句明失。凡有名相皆是忆想而有。悉是虚妄。岂但计生住灭非虚妄耶。若见诸法相非相下。第二句明得。若见一切诸相非法身相。即是见法身。故华严云。一切法不生。一切法不灭。若能如此观。诸佛常现前也

金刚般若经义疏卷第二金刚般若经义疏卷第三

        胡吉藏法师撰

须菩提白佛言颇有众生者。此下第二段明信受波若义。所以明信受者。上说波若即是能被之教。今明信受即是所被之缘。此即是缘教相称。若缘非教缘此教则不称缘。若教非缘教此缘则不禀教。以今缘是教缘故此缘禀教得益。以教是缘教故此则不空说。为此因缘故缘教相称也。又佛种种门说于波若。上已因果门说波若竟。今就信受门说于般若。所以了悟无依无得。故名信受。说此无依无得之信。即是说般若义也。就此门中问答为二。初即是善吉发问。所以问者。上明因辨果义已周满。是故今问信受之人。然因是无所得因。果是无所得果。因是无所得因虽行万行而实无所行。果是无所得果虽得菩提而实无所得。此事难信。若实有万行可行实有佛果可得。信之则易。若实无万行可行实无佛果可得。信之了亦易。若言俗谛自有因果真谛自无因果。有无各辙信之亦易。今并不然。虽修万行而不见菩萨能行。不见万行可行。无所依止而修万行济度众生。此事希有。是以难信。如空中种树不依于地而溉灌修治有于华实。此事为难是。故今问明有信者。若言佛身同于二乘是生灭法。亦易信。若言佛身是常住法凝然在金刚后心。此亦易信。若言应身自无常。法身自是常。此亦易信。今明如来虽生毕竟不生。虽灭毕竟不灭。虽无生无灭而生灭方便利益众生。此事希有。是故难信。所以问也。问曰。此为问现在信。为问未来信耶。答曰。现在众生福慧深厚三多具足。在祇洹受道闻必生信。故不问现在。但佛灭度后后五百岁入像法中。此时众生薄福钝根。虽寻经文不能通了。故闻不生信。大智论解信毁品文云。佛灭度后五百岁后有五百部。皆执佛语不知佛意为解脱。故闻毕竟空如刀伤心。故知未来能信人少。故知问未来世也。又此举未来有信以况现在。未来是恶世。外不值佛内薄福钝根。尚信波若。况现世之人闻不生信。佛告须菩提下。此第二章明如来答。就文为二。一者遮无答。二者明有信答。莫作是说者。即是遮无答也。汝勿谓现在有信受之人。言未来起信受也。故云莫作是说也。如来灭后后五百岁下。此第二明有信答。就文大开七别。第一明信之时节。第二明能信之人。第三明所信之法。第四正出信心。第五明信之所由。第六明信之利益。第七广释信义。此即第一。言后五百岁者。有人言。正法五百年为初五百。次像法五百年为中五百。次像法后五百年名后五百。今举最后五百。此是像法将灭衰弊之时。亦有信般若者。况前两五百无信人耶。今谓不然。言后五百岁者。如大智论明五百岁已后也。前五百年得道者多不得者少。故名正法。次五百年得道者少不得者多。名为像法。既正法灭已次入像法名后五百岁。此中虽多不信。如五百部之例然亦有信受之人。故大品云。是波若波罗蜜佛灭度后南方转至北方。是中四众要有信持乃至供养也。又解云。佛灭后千年。为断疑云前五百是正法故闻有信。后五百是像法故闻不信。若尔后五百年无信波若。故佛今答云。后五百亦有信者。不应言无信者也。此时亦有信持乃至供养也。有持戒修福者下。此第二明有能信之人。什师翻经但明二人。一者持戒人。二者修福人。持戒人多是出家菩萨。修福多是在家菩萨。大智论云。出家菩萨以尸罗为首。在家菩萨以檀为首。是故今文但明二人。然此二人具通大小。若有所得小乘二人则不信波若。故下文云若乐小法者则于此经不能听受读诵。若大乘二人乐无所得乃信是法。故下文云此经为大乘者说为最上乘者说。若是论经便有三人。论云不空以有实菩萨三德备。第三即是智慧人也。前之二人名为闻信。若智慧人此是证信也。又言。能信之人既是胜人。故举止行二善物情所贵。以褒叹之令得信受。持戒是止善。修福是行盖。此二摄一切善尽。则诸恶莫作诸善奉行故举此二摄一切人也。于此章句下。第三明所信之法。即上因果法门名为章句也。能生信心下。此第四正辨于经生信。以此为实者。即是无所得实信。若有所得信虽异小乘不信。若望无所得信还成不信。故大品有信毁之品。欲明有所得信此即成毁。今此是无所得实相正信。故言以此为实。亦信波若是法之实相。故云以此为实也。当知是人下。此第五明信之所由。所以闻经决能信者。良以殖因积久故能信受。故涅槃云。熙连河沙诸如来所发菩提心。然后乃能于恶世中不谤是经。今亦尔。三多久殖故能信而不谤。文有二句。前句明非值少佛。以于下。第二句明值于多佛也。闻是章句乃至一念生净信者下。第六章明信得利益。凡有二益。一者外为诸佛知见。二者内得无边功德。然信波若之利难可称量。今举一念之信尚获无边功德。始终之信故复难言。如来悬鉴信谤皆知。而今偏举信人者。略有三义。一者此经是诸佛之母为佛守护故。若生希向则为佛所记录。故大品云。佛常以佛眼观此经卷。若受持者则为佛护念。为如来之所齿录。直置世间为天王贵胜知友。尚自欢喜。况为如来之所亲爱耶。二者此福与虚空等。岂下地所能知。唯佛穷其边底。三者佛无二言。言必可信。今明信得多福。故其福必知多。问何因缘故名为知见。答论云。如来愿智力知非是比智知。佛眼所见非肉眼见。又佛知此人行菩提因。见此人得菩提果。故言知见。何以故下。此是第七广释净信之义。若依论师释。上来通明三种人信。此的辨第三智慧人信。今明此言即通。上释于信得德福无边。今释无边所以。良由得无生信故其福无边。但无生信自具二种。一者闻信。二者证信。就此释中有三何以。故大开三别。第一明得。第二明失。第三劝舍失从得。此是初。自有两句。初句明众生空。次句明诸法空。所以明此二空释信义者。大智论云。知众生及法不生故名无生法忍。虽渡众生。众生毕竟不可得即是无众生。虽行万行。诸法毕竟不可得此即无生法忍。是故今辨此二空为无生净信。又众生空故是无果患。诸法空故即无因患。所以者何。会法已成人故。法因而人果。因果两患双离故其福无边。又无人见故超凡夫地。凡夫着我不知无我。今辨无我即离凡夫地。又知法空故离二乘地。二乘之人但得人无我不得法无我。又以无人故离烦恼障。已无法故离于智障。超凡越圣兼二障俱尽。是故其福无边。离人见中具无十六。今但略故止言无四。五阴中起我我所心。故名为我。不断不绝相续住世。名为众生。计有一根之命不断犹有我。故称为命者。亦名为人。外道计有神我死此生彼经游六道。故名寿者也。无法相无非法相者。第二句明法空。虽不见我犹见有五阴之法。故今明亦无法相。五阴之法既无。五阴本无名为非法。空病亦空故云无非法相。此应如净名三种次第。初不见我为众生空。次不见法名为法空。不见非法亦名空病亦空。所以明此三空者。我见是众结之根本。故明我见。次有见无见又是断常之本乖道事深。故明有无见也。有人言。修善离恶。以善为法恶为非法。又有人言。以空遣有。以空为法有为非法。若依论经。人空之中有于四句。法空之中亦有四句。故论偈云依八八义别。言八八义者。人四法四名为一八破人四破法四。不此八病复为一八。故云八八。言法四者。一者法相。二者非法相。三者相。四者非相。此四是病也。问外道计我可是病。今见法生时是有。灭时是无。何故言病耶。答作此问者。未读大乘经论也。破第一句法相言非法相者。阴界入等法不可得故言无法相。破第二句者言非无法相者。惑者闻阴入界虚诳故空便谓。诸法实相亦空。如大经云。既闻生死虚诳谓涅槃亦虚诳。为破此执生死自虚诳空。实相涅槃此非是空。故云空者二十五有。不空者大般涅槃。破第三句者云无相者。惑者云。涅槃实相若不可空便还同有。若不可有还应是空。是故今云不可谓涅槃还是有无相也。涅槃实相不可说有无相。破第四句者。惑者既闻实相不可有无。便应不可得说。是故今明虽绝有无为众生故无说而说。云何言不可说。但旧经文略。但云无非法相也。何以故若心取相下。此第二对得明失。亦是举失显得。就此为二。初明计人为失。次明计法为失。今失即是初。若心取相即取众生相。则同外道计有我人。是故为失也。若取法相下。此第二明计法为失。就中有两。前明见法为失。次明见非法为失。问曰。若计法为失。应云着于法相。何因缘故计法为失着我相也。答理实应然。计人故着人。计法故着法。今明欲显其失患之甚。计法之人非但起于法见。计法之人还起我见。以法是我因缘故也。成实论云。灰炭不尽树想还生。又数论取一切有相非病。取我相为病。成实论云。有二谛则非病。取我人故是病耳。今明不然。但使生心动念则过同我人。何以故若取非法相下。此第二明着于非法此亦为失。既闻计法为失。或者便谓无法为得。是故今云若计非法是亦为失。所以者何。计有非法必起法见。若有法见则有我见。又若无有我则无所计。以有所计故知有我。所以计于非法亦复着我。是故不应取非法下。此第三章劝舍失从得。此文有二。一者正劝舍失。二者引证。此即是初劝舍失。然法与非法尚自须舍。我人之见去何不舍。是故举法况人。但劝舍法不劝舍人。以是义故如来常说下。第二引证。阿含经中佛为比丘作于筏喻。譬如有人为贼所逐。取草为筏度于彼岸。既至彼岸则便舍筏。初则取筏度河。既至彼岸则河筏两舍矣。譬意初则以善舍恶。后则善恶双舍。初则以法舍人以空舍有。次则人法两除空有双净。如是生死涅槃万善类然。若依论经。大意略同其文小异。论经亦有三何以故。与旧经意同。第三何以故云不应取法非不取法。此明理教之义。以得理忘教得月舍指故。故云不应取法。而藉教悟理因指得月故非不取法。如到岸舍筏故不应取筏。为欲度河故非不取筏也。问筏喻是小乘经。云何证大乘耶。答筏在小名小在大名大也。又举小况大。于小乘法中尚明两舍。况于大乘耶。如中论引迦旃延论。是小乘尚舍有无况大乘耶。法尚应舍。何况非法。明有是物情所安尚应须舍。无非六情所对岂可执也。须菩提于意云何下。此文所以来者凡有二义。一者证信故来。上辨无依无得之信乃至法非法皆舍。今明一切贤圣同作此悟。故知此法可信受也。二者依论释疑故来。论主至此章凡释三疑。初举法身非有为释以果征因疑。次信者章双释因果之疑。谓说因果法门便无信者。上明有信者。即释此疑。今此一章经释以果征果疑。上法身非有为章云生住灭相非是无为法身故。不可以此三相见如来法身。疑者云。若言三相非是佛者。应亦释迦不得菩提。不为物说法。而今释迦树王下实证得菩提。趣于鹿苑为物说法。若尔则应王宫实生。双树实灭。不应言三相非佛。今正破此疑。就文为二。一者佛腾众疑以问善吉。二者善吉奉对以破众疑。今即是初。佛问意云。于意云何下。汝言佛于树王下实得菩提耶。五十年住世实为说法耶。善吉答中大开二别。第一正破实证实说之疑。第二更破异疑。此即是初。善吉云。无有实得菩提。无有实说法。论偈云。应化非真佛亦非说法者。明佛有三种。一者法身佛。即以正法为身。二者报身佛。即是修因已满果起酬因名为报佛。三者化身佛。今言无有实证无有实说者。释迦即是化身佛。非是真佛。即是化证化说非是实证实说。以此例前。释迦即是化生化灭非实生实灭。是故如来身是无为。故云无有定法名菩提。亦无有定法如来可说也。何以故如来所说法者。此下第二破无说之疑。惑者闻上释迦是化佛无有实证无有实说。便谓无有化说无有化证。是故今明虽无实证而有化证。虽无实说而有化说。故云如来所说法即是化说。前即破实说之疑。今则破无化说之疑也。不可取不可说者。此句更复破疑。惑者既闻有于化说便谓有法可说。佛若有说听者便应有取。以有说故则言语不断。听者有取故则心行不灭。今以言语灭故不可说。以心行灭故不可取。大智论云。波若波罗蜜实法不颠倒念相观。已除言语法亦灭。即是此意也。非法非非法者。此句成上不可取不可说意。诸法实相非有非无。非有故非法。非无故非非法。既离有离无。云何可说。既离有离无。云何可取。即此如净名仁王所辨。其说法者无说无示。其听者无闻无得。一切贤圣皆以无为法而有差别者。所以有此文来者。成上非法非非法非有非无义也。以一切贤圣皆体悟无为。无为无有无无。是故当知诸法实相非有非无。岂可取说。论文云。佛所以能说实相无为法者。由体悟无为法故耳。故无为是说因也。又一切圣人所证尚不可说。听者岂可取也。此中不独举佛乃至广引众圣者。此意欲证一切贤圣同悟此法。当知此法必可信受。问何故言一切贤圣无为而有差别。答复为释疑。既言同悟无为则众圣无异。便无十地阶级四果浅深。是故今明虽同悟无为所悟不同。故有三圣为异。三鸟出网三兽度河而升空有近远。涉水有浅深。即是其事。问三佛乃是地论师说。汝今何故乃用斯义。答作此问者非。是通方之论。今一师辨无一豪可得一切皆是义。如思益云一切法正一切法邪。若有所得心非唯三佛不可得。一佛二佛悉是戏论。若以无所得了悟之心。随缘所说一佛二佛三佛十佛至无量佛并皆无碍。云何苟存二身疑于三佛。问何故须立三佛。答义要有三。由有法佛故有报佛。由有报佛故有化佛。法佛是佛性。要由佛性故修因满成报身。此二即是自德。然后化众生即是化他德。故有化佛也。须菩提于意云何若人满三千大千世界七宝布施下。此是第三格量显胜称叹劝修门。若以福慧而判。上来就智慧门说般若已。今以功德门说般若。般若未曾福慧。为众生故作福慧名说也。又上来就无依无得说波若。今就称叹门说波若。又上来明波若体。今明波若用。以能受持生无边功德是故用也。就此门中开为三别。第一举外施格量。第二举内施格量。第三举释迦往因格量。就举外施格量中更开为二。第一正举外施格量。第二释成格量优劣之意。就正格量中复开为二。第一正举二种财施格量称叹。第二辨于经名。就初亦开为二。第一正举二施格量受持波若一四句偈。第二称叹波若。在处处贵在人人尊。就第一举二施格量四句开为二别。第一举三千世界七宝布施格量四句。第二举恒沙界七宝布施格量四句就初章中复开二别。第一正举财施格量。第二释成格量之义。今即是初。问何因缘故有此文来。答此文来意凡有近远。所言远者如向数义。所言近者论生起云。若诸法实相不可取说。文字则是可取可说。受持应无功德。为释此疑。明文字虽是可取可说因此文字得悟波若。则是因说悟无说。是以受持者其福无边。故格量也。就文为二。第一正举财施。第二格量波若。举财施中自开为二。第一佛问。第二善吉答。开为二别。初正答。次简择答。正答如文。阿泥楼驮以一食施九十一劫常受安乐况今大千妙宝以用布施。其福不多。问实有以大千妙宝布施以不。答亦得言实有亦得言假说。言实有者。转轮圣王领四天下。能以四天下满中妙宝以用布施。大梵天王主领大千世界。能以大千妙宝布施。故知得是实有。言假设者。若无此事假说言有。亦不及受持波若。佛欲令人尊重波若故。虽无事假说明也。何以故是福德即非福德者。此下第二简择答。有人言。福德即是世谛。即非福德即真谛。明此福德虚假即真。是名福德。多者世谛故说多也。一切诸法不出二谛。故就二谛明之。今谓此释似无次第。今乃是释福德多之义。何因缘故明二谛也。复有人言。此是福德非福德。非福德福德。此是波若福德。但波若中有财施法施。波若财施法施实无优劣。但受财施人一生富乐。未能未来灭恶道之苦。受法施人能灭三恶道报。未来生天人好家乃至作佛。是故财施不及法施。今谓约受人其实如此。但此中约能施人格之耳。不约受人格之。故不同此释也。但施不同。有得财施不及无得法施。此是互对自有无得财施胜有得法施。自有无得财法胜有得财法。问无得财施何如无得法施。有得财施亦作此问。答财法不二则无得财施与无得法施无有优劣。但无优劣优劣义则法施为胜财施为劣也。有得法施亦胜有得财施。大格如此也。今依论释。论云福不趣菩提。此简布施之福虽多此是有漏福德。即非福德者非无漏无所得福德也。是名福德者。论经重言福德福德。此意略判福德凡有二种。一者有漏福德。二者无漏福德。是故重言福德福德。问善吉但应答佛明布施福多。何因缘故忽简福德漏与无漏。答善吉领解佛意。佛意欲明布施之福虽多而是有漏。是故答佛如我所解。布施福多者。此是有漏之福多耳非无漏也。佛言下。第二正举财施格量法施。就中有二。初明持经胜于布施。第二释胜所以。今即是初。问云。何名为四句偈耶。有人言。此经下文两四句偈。即是其事。今谓此人得经语不得经意。若取下偈为四句偈者。自经初已来便应非偈。受持之者便无功德。又当佛说经时至此中未有后两偈。云何逆格量耶。有人言。一切大乘经四句要偈。如雪山之四句等。即是其事。是亦不然。今正论波若不涉余经。有人言。凡是言说成就一义者此即是偈。故偈名为竭义。取其竭尽则名为偈。今谓亦不然。经乃明四句偈。今云其义竭尽何必的论四句。自有一句于义亦尽。若是别偈则句定言不定。若是通偈则言定句不定。别偈句定言不定者。要须四句故句定。或五言四七六等故言不定也。通偈言定者。要满三十二字也。句不定者。三十二字或一三四句不定也。今既云四句则是别偈。云何以通释耶。有人言。三十二字名为一偈。是亦不然。乃是外国数经法耳。非关四句偈也。有人言。凡是经论能显道者。悉名为偈。此亦不然。今的云四句偈。云何乃通取显道之言。显道何必四句耶。有人言。假名四句。如一假有。不可定有定无亦有亦无非有非无。亦得言假有。即不有乃至假有未曾有无。故此假四句即名为偈。今谓上来亦无此说。乃是通方之论耳。有人言。上不可取不可说非法非非法即是一四句偈。今谓是亦不然。若唯此是偈余应非偈。有人言。前答善吉四句问。即是四句偈也。是亦不然。前乃是答于四句。岂关偈耶。今世俗中以四句为一偈。佛随世俗亦以四句为一偈。明此乃是举少况多之言耳。然一四句斯言最少。若能受持一四句其福无边。况复一段一章一品一部耶。故须得经意勿着语言也。何以故下。此第二释胜所以。至人极法从是经生。是故持经其福为胜。论云二能趣菩提。即是受持四句及演说四句也。所谓佛法即非佛法者。有人言。此是遣执。向明出生极果人法。恐物着故须遣即空。今谓不然。前明即非福德。亦应恐生物着故须遣也。有人言。佛法非佛法如中假之流。是亦不然。恐是玉卮无珰也。今依论释。成上持经福多之义。偈云唯独诸佛法福成第一体。所言佛法者。唯佛是无上菩提之法也。即非佛法者。自佛以外二乘菩萨无有此法。故云即非佛法也。以佛独有故此法第一。今持经福能生第一之法。是故持经之福其福最胜。须菩提于意云何须陀洹能作是念下。此第二释成格量之义。就此章中大开二别。第一举小乘因果释成格量之义。第二举大乘因果释格量之义。就此二章各开两别。初段两者。第一举小乘因成格量义。第二举小乘果成格量义。今即是初。问曰。云何举大小乘义成格量耶。答前章云如来所说皆不可取不可说。乃至一切贤圣皆体悟实相无为而有差别。然此语意即是明悟实相无依无得之义。以悟无依无得故。须有大小乘贤圣不同疑者云。若言诸法不可取不可说无依无得者。云何小乘取得四果。乃至大乘证得佛耶。以大小乘皆有证得故。知非是无依无得。以大小乘皆说有证得故知。非是不可说义。今为释此疑故。明大小乘虽有证得而实无所得。虽有所说实无所说。是故当知无取无说无依无得。是以举大小乘。释成上不可取不可说乃至皆以无为法而有差别也。问曰。云何成上格量。答诸法若是可取可说有依有得者。受持则无功德。良由波若无取无说。是以受持其福无边。问曰。此经下文云。为大乘者说。若乐小法者不能听受。大品云。波若是菩萨法不属二乘。今云何乃引小乘为证成。答此举小况大。明小乘人尚悟无依无得无取无说。云何菩萨而不信无所得法耶。如大品引先尼为证。听者闻诸法毕竟空不信受故引先尼。小乘人尚信法空。今大乘人无相法中岂不信空耶。又今是无所得三乘。是波若善巧方便用。此是大小非有所得小也。又欲引学小乘人令入大法。欲为小乘亦须学此法。如大品云诸天子汝欲住须陀洹果亦不离是忍也。问若尔此法便是通三乘法。答如观中道者有三品。下智观故得声闻菩提。中智观故得缘觉菩提。上智观故得佛菩提也。问何故声闻法中立于四果。菩萨法中开于十地。师云。今须开此一路。此一路拥塞来久。今明无碍通方悉得。圣人善巧为欲出处众生随其根性故开大小。然至论道门未曾大小。今作大小者。并是赴根缘故开大小方便。然大小不同。由有其通别。若通而为论。大小皆得名地。大小悉得称果故。如三乘共十地。八人地见地即须陀洹果。薄地即斯陀含果。离欲地即阿那含果。已办地即阿罗汉果。菩萨法中已办地属佛地。是知大小皆得名地。然大小皆名果者。小乘既名四果。菩萨十地亦名十果。故大品云。有法是菩萨道。无法是菩萨果也。若就别为论。开大小不同则果地为异。小乘则名因果。菩萨称为十地。所以菩萨名地。是胜持广普能生能成。有此众义故与其地名。声闻无此诸义。故不名为地。声闻之人厌老病死欲入无余。故断除烦恼数辨苏息。遂其心期。故与其果称。菩萨无此诸事。故不名为果。然复有互举之义。其事常通。何以知之。如三种皆乘三种皆道三种皆地三种皆圣人。然地岂不通耶。故知随举一义耳。问依小乘义明惑唯有见谛思惟。断三界见谛惑既立初果。断思惟亦立一果。若尔唯应有二果。何得有四果耶。若断三界思惟既立三果。三界见谛亦应立三果。又若约界而判既有三界。断三界惑应有三果。何故断欲界惑立于二果。断上二界惑立一果耶。若依静散而判。欲界已为散地。断欲界惑应立一果。上二界已为静地。断二界惑亦应立一果。今何因缘故不依此诸义立因果耶。答此是如来善巧假名制立。无有定相。通而为论具如问也。而今不尔者。断三界见谛出三涂之表为圣人。故立初果人。见恶道尘散八十八头蛇死就断三界思惟更立三果。断欲界思惟立于二果。断上二界思惟立罗汉。所以然者。欲界是苦难地。此既难可过度。是以断欲界惑立于二果上二界非苦难地。已有解基惑则易断。是以断上二界惑立阿罗汉果。言断欲界惑立二果者。欲界思惟有九品。断前六品名斯陀含果。具断后三品立阿那含果。所以断前六品立斯陀含果者。毗婆娑中和须密论师云。前六品烦恼能发无作润于三涂。是故断此六品制于一果。又且既开惑以为九品。是则上中二三品其惑则重。是以断之立于一果。后三品既轻。故断之而立阿那含果。庄严师云。欲界思惟九品烦恼润业不同。前之三品润边地贫穷。次有三品润边地富贵。问曰。立此四果出何处文。答毗婆娑以五义故立。一者舍于曾道。二者得未曾道。三者得一味解脱。四者具修十六行。五者修得八智。今以五义具立初果。下三果者可具三义。谓舍于曾道得未曾道及一味解脱也。如此等义数论中广释。但知是假名方便。不如数论有所得解。数论但得名字不知佛意也。就初果文前问。次答。就答中有三。一正答明悟初果时不见得与不得证与不证。即成上不可取不可说义也。何以故下。第二句释于上义。须陀洹者。此言修习无漏。亦名逆生死流。流有二种。一生死流即是烦恼。二者道流名为正观。今此中具明二流。名为入流即是入于道流。不入色声香味触法即是逆生死流。由入道流故逆生死流。故入道流。然入道流而实无所入。亦逆生死流实无所逆。第三句是名须陀洹者。结名也。余经云得须陀。名为沟巷断结。前观欲界苦断欲界苦下烦恼。次观上界苦断上界苦下烦恼。还观欲界集。次观上界集。如是上下屈曲似于沟巷。故云沟巷断结。三藏师云。得须陀洹者。此云至流。如烦恼引人至生死流。八正道引人至涅槃流也。问何故但云不入六尘。答既不入六尘亦不入六情六识。即明于法空。不见须陀洹故即是人空。入道流无所入故则涅槃不可得。逆生死流无所逆故生死不可得。故不人不法不生死。不涅槃乃名波若须陀洹也。第二果亦有问答。文来可知。斯陀含者。此云薄淫怒痴。亦名一往来。此人犹感欲界两生。一生天上一生人中。便成罗汉。故名一往来。亦名频来。以频受两生故名曰频来。第三阿那含者。此云不还。亦云不来。断欲界结尽不生欲界故名不来也。而实无来者。问阿那含名不来既云实不来。斯陀含名一往来应云实往来。上云一往来实无往来。时阿那含名不来。应云无不来。答其实应尔。但互文现意。而不尔者。那含名不来而云实无来者。此不来之名而无得之语其义相称。故以无来之语还释不生之名。上二果名不同此。所以非类也。又意实应言而无不来。今少不字但云无来者。无即兼不故省烦言也。问四果十智中具有几智。答初二果十智中除尽无生及他心。问凡夫外道尚得他心。二果圣人何故不得。答圣人非不能得。若得他心即得四禅断欲界非复初二果也。第三果人八智。加他心。第四果具十智也。从第四果去。即是第二举小乘果以成格量之义。上来三种虽并称果。若望罗汉并皆是因。就此文中复开为二。一者通举罗汉。二者别明善吉。初亦有问答。答中有三。一直答。二顺释答。三反释答。问四人并皆称果。何故前三云果罗汉称道。答果道之名皆通四人。但罗汉既其德极。简异上三偏云道也。所以然者。大经云。菩提名尽智无生智。菩提此称为道。罗汉既得此二智与其道名。上之三果未得二智不名与道也。第二偏据善吉悟解胜为证者。善吉犹是罗汉。但今是对扬之主。又复别得胜定异于余人。又自引为证。欲使于义明显也。就文有四。一明佛就其得上果。二明其果不作得意。三明若有得意则不为佛所印可。四明以无著故为佛所叹。人中最为第一者凡有三种第一。一者人第一。二者离第一。谓离二种障。一离烦恼障。二离定障也。三者德第一。即得无诤定及断烦恼障智断定障智。问何因缘修无诤三昧。答凡有三义。一者昔闻佛说此三昧有种种功德。心信愿得。今成罗汉故修此定。由昔因故便习得也。二者在凡夫时于多众生起诤故受苦报。今得无学还忆昔忧悔故修此定。三者欲令多人得现果报故复修之。得此定已前作方便守护他心。无一众生于我起诤。然后现身故名无诤。问以何方便法修此定耶。答前散心中发愿。随其心愿要期近远。或一土一村人物处所。悉愿见其形相姓族名字及知其心所趣向。发此愿已入达分三昧。如昔所愿皆悉分明。此事已还出散心。忆念定中所见如梦中所见觉已还忆。以是义故能遮恶生善不烦恼他。故名无诤。无诤与愿智相成如前说也。问云。何名为无诤。答有人言。以慈心为无诤。以慈心故不与物诤。有人言。第四禅名无诤。以此定离三灾免四受故也。有人言。空解为无诤定。有人言。即以无诤智为无诤定。今依论释。论云。依彼善吉者远离二种障。断烦恼故得罗汉。断三昧鄣得无诤定。故知此别是方法定。非是空解亦非四禅亦非慈心也。问文云离欲罗汉。离何欲耶。答非是离烦恼之欲。乃是善吉好修阿兰若行远离五欲五尘之境名为离欲。阿兰若者此云无事。即是优游任放不为尘累所拘。四段文处易知不须出也。佛告须菩提如来昔在然灯佛所下。是第二章举大乘因果释成上义。就文为两。第一举大乘因释成前义。第二举大乘果释成前义。就举大乘因中开为二别。第一举受记。第二明严土。今即初。所以有此文来者。从上如来所说法不可取不可说文生。若言诸法不可取者。昔为儒童菩萨应不得记。若昔为儒童菩萨遂得记者。则诸法可取。若言诸法不可说者。然灯佛不应为其授记。既为释迦授记汝于来世当得作佛。则是可说。以时会有于此疑故。佛腾众疑问于善吉。故云如来于然灯佛所有法得菩提不。善吉答云。于然灯佛所实无所得。此意明不见人是能得无有记之可得。具如净名弥勒章记。如是无得无不得。乃名得受记。此得实无所得也。北人云。凡有四时受记。一是习种性不现前受记。二是道种性亦不现前受记。三是初地现前受记。四是八地大无生忍现前受记。此中文明释迦由是习种性菩萨。未得初地已上无生法忍记。今佛问善吉云。我于尔时已证初地无生法忍三菩提耶。乃至金刚已后常住现果证三菩提耶。善吉答云。如来尔时未得初地无生法忍三菩提。亦未得金刚后常住三菩提。今谓论无此义。又未见经说。若就义推。于理不可。此中乃明无依无得之义。破有依有得之疑。成上不可取不可说意。云何乃作行位浅深解释。故于义不然。但经中不无三贤十圣之说。首楞严经亦有四种受记之文。非此中正意也。于意云何庄严佛土不下。此第二次辨严土释成上义。来意同前。若言诸法不可取不可说。云何菩萨取净佛土行。为释此疑故有此文来也。问因行无量。何故前辨受记今明严土。答受记是菩萨自行。严土是化他行。自悟无生故佛授记是自行。众生之类是菩萨佛土故严土之行。则是化他行。行门虽多不出此二。是故明也。又前论得记则是正果。今论严土则依果。又菩萨得无生已后更无余事。唯成就众生净佛国土。故次第二句来。文亦有二。一问二答。问意可知。就答中有二。第一正明严土之真伪。第二劝修净土因。今即是初。若依大品经说。此中始终圆成一意。即是菩萨无大庄严为大庄严。虽大庄严实无庄严。然依论释。此中文云须菩提言不也世尊者。此明如来法身实无七宝形相庄严。故不应言菩萨有七宝净土之可取也。如来说庄严佛土者。疑者云。若形相庄严非真土者。佛何故说七宝等为净土。令菩萨修净土因取净土果耶。故今释云。如来以正法为身无身非身。是故无土。今说形相为净土者。此为始行之人令弃土沙之秽取宝玉之净耳。非是第一义真净土也。故言如来庄严佛土则非庄严也。是名庄严者。此是第一义真实庄严。正以诸法实相无德不备无累不净故名庄严。为至人之所栖止故名之为土。应如是生清净心下。此第二明净土因。然上明土果。破别相世俗之土。明第一义真净佛土。故明二土真伪不同。此中辨因有得失之异。就文开为三别。第一正劝修得。二者劝舍失。三者重劝修得。应如是生清净信心。此即是劝修得也。不应住声香味触法生心者。此第二句劝失舍。应无所住下。第三句劝修得。须菩提譬如有人身如须弥山王下。第二明大乘果证前无取无说。成格量之义。就文为二。前佛问。次善吉答。今即初。问成论人释云。山王广大譬无相理广大也。今谓不然。非但义无次第。亦是文无所出。今依论生起犹为释疑。疑云。若无取无说者。云何诸佛取得菩提而为他说得菩提耶。所以举须弥山者。明须弥于十宝山中最大。譬佛于十地中最大。须弥此云妙高山。亦云安明山也。释意云。如须弥山虽于十宝山中之大亦无心言大。佛亦尔。虽于众圣中大亦云无心言大。虽得菩提亦无心言得也。佛说非身是名大身者。又释疑。疑云。闻须弥无心言大。谓与佛齐须弥既是有为有漏。言佛亦是有为有漏。故今释云佛说非身者。明佛不同须弥非是有为有漏身。故云非身是名大身。即是无为无漏身也。故云是名大身也。问此举三佛中何佛耶。答正举报佛。所以然者。报佛正是修因满故得菩提。法佛是佛性未得菩提。故不说法佛。得报佛竟方起应化。故化佛亦非得菩提。故但举报佛也。须菩提于意云何如恒河中所有沙数下。此第二举诸恒河沙珍宝布施。格量持说四句偈也。所以有此文来者。凡有二义。一者上明布施少正是三千世界珍宝故不及持经。今明布施多谓诸恒沙世界珍宝应及持经。又上大千珍宝但施众生故是福田劣。今恒沙珍宝供养诸佛此是福田胜。应及持经。今明虽施多田胜由是有所得施亦不及持经也。问先说大千格量既不及持经。何故不即说恒沙珍宝以格量持经耶。答增数明义。从小至多实应相次。但上闻大千格量不及持经。时会或未了不及之所以。谓波若犹是可取可说。云何受持四句及胜大千珍宝。是以上广释疑。明波若非可取可说故四句虽少若持若说其福则多。布施虽多是可取可说故其福则少。所以释前疑竟方显胜之所由。故方更格量也。就此文中为二。一明财施福多。二明法施格量。就初有两问答即为二意。初一番明沙数多。后一番明福德多。今以问答相承直为四别。一举沙数为问。二称事而答。三举财施为问。四明施福多也。初问中有三意。前举一恒沙为本。二以沙数河。三以彼沙数河中之沙为问。第二答中有两意。初直答多。从后德。但诸恒河下显多之义。明诸河显数尚以无边。况河中之沙云何可数。问何因缘故佛经之中多举恒河为喻。答于四河中恒河最大其沙又多故举为喻。二者外道云。此是吉河。入中洗者罪垢清净故举为喻。三者余河名字数转。此河世世名字不转也。又五天竺国在此河边住。佛弟子眼见故举为喻。香山顶有阿耨达池流出四河。恒河即是四河中一也。有人言。此河长八千里。广处四十里狭处十里。此中沙极细如糗面。水作白色如乳。极深象马度皆没。次举经格量。其文可见。财施不及法施者具有多义。一者明法施之时能施之人多是圣人智人。若使财施能施之者则不尔。愚人无能行施。所以财施则劣法施则胜也。二明受法施之人亦必是智人方能领受。愚者之与畜生不能受。此故明法施为胜。三者明得福为胜。财施则但明能施之者得福受施之者则不得。若使法施则能所二人并皆得福。是故为胜也。四者法施则能施所施皆得而不失。若使财施则受施之人得五事果能施则失也。五者财施则但益肉身。法施则益法身。六者则法施能断惑。财施正是伏悭。七者法施则出有法。财施则是有流。八者财施果有尽。法施果无尽。九者财施不一时得。法施则一时而得。十者明法施具四摄。财施但一摄。是故法施胜于财施也。复次随说是经下。上来举二财施格量四句经竟。此下第二叹经之处及美受持之人。明经在处则处贵。在人则人尊。就文有四。一明经在处则处重。二明在人则人尊。三释人尊。四释处重。如塔者。塔婆外国语。亦云支提。此云方坟。然为尊法身是故敬塔。为重此经故供养所在处。问大品云。满十方舍利作一分。波若经卷为一分。佛问天主。二分之中意取何所分。天主答。宁取波若经卷。以能生舍利及一切佛法故。若尔经既胜于舍利。则应经所在处过于塔庙。今云何言如塔。经处若言如塔。则波若经卷应如塔舍利。以理言之。实应过塔。但世间敬塔以为尊极。是故今借以喻耳。何况有人下。第二明在人则人尊。当知是人下。第三释人尊。若是经典下。第四释处贵。此经诸佛之母。能生诸佛及三乘十地。大品云。波若所在之处十方诸佛常在其中。故欲供养佛当知供养波若。波若与佛无二无别故云则为有佛也。及尊重弟子者。此处乃有文殊普贤。非止目连身子。大品云。诸天日作三时礼敬。六斋日弥多。故经所在处四面皆令清净也。当何名此经下。若依开善。从上已来并是说波若体。此之一章明波若名。即是名说也。今明名说体说非无此义。但此文犹属格量段也。前格量中开为二别。第一正举二种财施格量称叹。第二章辨于经名。所以辨经者。上举二施格量及称叹。经在处则处贵。居人则人尊。时众闻经有斯胜德咸欲受持。但未识名字。是故此中辨名也。就文为二。初问。次答。问中有二。一问经名。二问受持也。佛告须菩提是经名为金刚波若下。第二答经名。前问有二。一问经名。二问受持。今具答二问。开为二别。第一正答二问。第二释成答问意。今前答二问即为二。初答名。二答受持。今前答名。金刚般若者。波若未曾法譬。非譬不譬假设譬名。非法不法强作法名。非名不名强为立名名金刚波若耳。以是名字下。第二答持经问。所以者何下。第二释成答问意。他云。答名中三段。一标金刚之名即辨坚利之义。第二遣于体坚。第三遣其用利。上答名即标坚利义竟。此下即是遣其体坚。就遣体坚中二句。初明佛说波若即非般若。明心行断也。下如来无所说。明绝言语也。今问上不可取不可说已明心行断语言绝。今何因缘更复明绝。今依论判此二句。初句明下有所异。次句明上有所同。问何故明下有所异上有所同耶。答下同二乘上异诸佛。则波若不足可尊敬受持。良由下异二乘上同诸佛故可尊敬。以劝物之意故作此说也。下有异者。上标此经名为金刚。但二乘断惑之智亦名金刚。未知此经。名金刚者是何金刚耶。故释云。佛说波若者。此是佛波若佛金刚也则非般若者。非是二乘智慧。非二乘金刚也。须菩提于意云何下。他云。前明断心行。今辨绝语言。今依论意不然。前文明下有异。今句明上有所同。时会疑云。但释迦作此说般若。余佛亦作此说耶。故佛牒时众疑问善吉。如来有所说不。此问意明释迦独有此说。余佛不作此说耶。须菩提云如来无所说者。此明释迦无别有说。还同十方三世佛说。离三世佛说外无别有说也。故大品无作品云。说是波若时。十方各千佛现同说是波若经。难问者皆号释提桓因。解释波若者皆名须菩提。天主更问。但现在十方佛作此说。未来诸佛亦作此说。佛答当来弥勒亦作如是说。故知十方三世佛同作此说。大品广故广明同。今文略故略明同。所以同者。明波若只是一正观。正道岂当有异耶。须菩提于意云何下。他云。此是第三遣于用利。波若能断假实二惑。得假实二解故是波若之用。今此中明假实两境皆空。岂有两惑可断二解能断。故是遣其用利也。他就此中为二。初明依果空。次身相下明正果空。初中又两。一者举微尘明实法空。二者举世界辨假名空也。今依论第二释成格量优劣。所以时众疑。何故持经小而福多。布施多而福少耶。故今释云。布施虽多是烦恼尘染因。还得颠倒生死果。譬如大千世界微尘虽多。还成世界尘土之果。明四句虽小此是不颠倒因。还得不颠倒果故。持经虽少而得福多。布施虽多而福小也。文云诸微尘者。明微尘有两种。一者尘染之尘。二者成世界无记之尘。以两尘相滥故今简之。诸微尘者是成地微尘也。非微尘者非尘染微尘也。是名微尘者结是成地微尘也。如来说世界下。前明因今辨果。如文。次举三十二相者。他云。前明依果空。今明正果空。依果空中有假实。今正果空有问答。今明前云不可以身相见如来。已明正果空。此中何因缘复明耶。故不同常说。依论犹是释成上格量意。明何但布施尘染之福不及持经。只相好之业亦不及持经。又持经之福尚胜相好之业。岂不胜布施耶。故有此文来。此中直明二果优劣。即显二因优劣也。何者法身之果胜相好之果。显法身因胜相好因。以持经是法身法故。持经福胜相好业也。于意云何可以身相见如来不者。可以相好身见法身以不。作此问也。须菩提答云不可以身相见如来者。不可以相好见法身也。如来所说身相则非身相者。此明所说身相非法身也。是名身相。是相好身也。须菩提以恒河沙身命下。第二明内施格量。上外施格量中有二。初舍三千世界七宝。次舍恒沙世界七宝。今内施格量中亦二。初舍恒沙身命。次举日三时舍恒沙身命布施。今初。所以有此文来者。上明外施格量。此未足称易。今舍内身命。方乃为重也。又上明外施是下施格量。今明内施是中施格量。何以知之。大论呵迦旃延以内施为上。若是财施此明名下施。内施名中施。若无依无得施方是上施。汝何得以中为上耶。故知内施是中施。故从下施格次至中施格也。此文为二。初正明格。第二领解释疑。初复为二。初正明舍恒沙身。第二正格。今初云舍恒沙身者。今生舍一身命施。次生复舍一身命布施。如是舍恒沙身命布施也。就受施中具有三句。一须身不须命。如止须食肉。二须命不须身。如怨家止欲得命。三身命俱须。通上二句也。若复有人下。第二正格量。然持说俱得功德如文

金刚波若经义疏卷第三毕金刚般若疏卷第四

        胡吉藏法师撰

尔时须菩提闻说是经下。第二领解释疑。文为二。初领解。次释疑。领解中为二。初领解。第二佛述成。初领解为四。第一自领解。第二明他领解。三明自领解为易。四明他领解为难。初领解又二。第一经家序其悟解相貌。第二正明领解。初序其相貌者有四。一标领解人。二明所领解法。三正明领解。第四领解相貌。问得解应欢喜。云何乃悲泣耶。答领解相貌不同。凡有三句。一者得解欢喜。如法华身子踊跃欢喜。二者得解悲泣。如此文。三得解亦欢喜亦悲泣。如善集王悲喜交集。喜则欣今悟。悲则慨昔迷。悲喜双兼二事也。希有世尊下。第二明得解。我从昔来所得慧眼未曾得闻者。古来释经前后不同。一家云。此经在大品初说以此文为证。既云未曾闻般若。故知在前。第二师云。此经在大品后说。既在大品后。何得善吉云昔来未曾得闻耶。彼释云。前于大品中。虽善吉已悟而中下根人未悟。今同其未悟故云未曾得闻。中下根人于今得悟故同其得悟。故言今始得闻耳。此事已如前明。今更开一意。上外施格量竟如来自称叹经劝物受持。今内施格量竟善吉自称叹经劝物受持。是故师弟互文劝缘信悟耳。若复有人得闻是经下。第二陈他得解。则生实相者。他云。世谛生真谛不生。即问。实相即是真谛。既生实相。何不生真谛耶。彼释云。生实相之慧耳。实相不可生。但慧从境作名称为实慧。境从慧作名。故生慧言生境耳。今明二谛俱生不生。如义中释。斯文即证也。但一师有观发中中发观义此明生实相。即是观发中。正观明了则实相现前。故名生实相。此约迷悟为论。于迷者不现前名实相不生。悟者现前名为生实相。令生实相既尔。佛性等例然。至论实相未曾生不生也。是实相者则非实相者。他还以二谛释此文。如常弹。今依论释简成实相义。是实相者。独佛法大乘有此实相故云实相。即非实相者。天魔外道无实相故言非实相。是名实相者。论经长有一句。云实相实相。此句简二乘。实相有二种。一大乘实相。二小乘实相。今明是大乘实相非二乘实相。故云实相实相。前句简外实相。此句简内实相。所以二简者。以独佛法有实相。及独大乘有实相。生实相之慧。方是希有耳。世尊我今得闻下。第三述自悟为易。所以易者。一者明过去久殖三多。二者现在者值佛。内因外缘具足故信受为易也。又就迹中为论。须菩提是大阿罗汉。如大品云。般若甚深。谁能信解。答云。正见成就人漏尽阿罗汉能信。今须菩提既是罗汉。所以信解不难也。若就本为论。须菩提内秘菩萨行。或可是往古如来。示同众迷。所以悟解为易。若当来世下。第四陈他悟为难。所以难者。良由生在末世后五百岁故也。睿法师云。前五百岁得道者多不得道者少。后五百岁不得道者多得道者少。前五百岁信无生者多不信者少。后五百岁不信者多信者为少。是以前五百年名正法。后五百年名像法。能于像法中信。所以为难也。又明此时众生不久殖三多。不久值佛。无内因外缘。能于中生信。是故为难。何以故下。此释信为难意也。若言有人能信般若所信。则是人法之见。不名为信也。此信亦不难也。明若不见我是能信。即是人空。即是无有人见。不见般若是所信即是法空。即是无法见。所以者何。我相即是非相者。所以不取我等相者。非有我相。是故不取我相。以实无我故无所取耳。故云我相即是非相也。又道理若实有我人之相则不可离。以道理实无我人之相。但众生妄谓为有故我相可离多。故云我相即是非相也。大品云。众生所著若有一毫末之可有则不可离。以所著处无如毛发许有可离也。他云。所谓之我见是无耳。能谓之心是有此不无也。如所谓阳炎是无。能谓之心是有。今明能谓之心如所谓不异也。若依论释者。此明人法两空。前云无我人相。此是人空。今云我相即是非相。此则明法空。问若言此明法空。应云法相即是非法相。何云我相即是非相耶。答无我有二种。一者人无我。二法无我。今法无我也。何以故离一切诸相则名诸佛者。此重释无相所以也。若有诸相佛应见之。以离一切诸相名为诸佛故。则知诸法无此相也。问佛何故离一切相耶。答有一切相则是有所得。无一切相则是无所得。有所得故是生死凡夫。无所得名为涅槃。名为诸佛也。佛告须菩提下第二佛述成。前领解有四章。今但述第四陈他悟难。明无始以来习有所得久。昔日又禀小乘有所得教。忽闻般若无人无法多生怖畏。是故今明能不怖畏此则为难。所言不惊不怖者。一往怛愕谓之为惊。内心怯弱名之为畏。一向深恶前事称之为怖也。如来说第一波罗蜜者。他云。般若是六度中第一故言第一。则非第一者。真谛遣第一也。是名第一者。世谛假名说第一也。依论解。此般若一经胜余修多罗。故名此经为第一波罗蜜。非第一波罗蜜者。余修多罗非第一。是名第一。还结此经为第一也。所以有此文来者。是近远二义。近者成上希有之言。以此经第一故信此经。方是希有耳。此经若非第一。信之不足称为希有也。远成上者。上来所明内外二施不及持经四句者。由此经是诸经中之第一法也。须菩提忍辱下。第二释疑念也。问何因缘故次般若。明忍辱耶。依六度数前后并非次第。今有何次第生此文耶。答开善解云。三门说般若。前就体名二门说竟。今次第三功用门说。明般若功用无穷。能生诸佛能示世间能断烦恼。又摄用导用忘用诸用非一。今此明忘怀。忍辱之用者。以得此用故。则逢苦不忧值乐不喜。其功最要故偏明之。又解云。忍与般若俱是慧。与慧同体。故共明也。今明无方之意不妨此义。若依论意释疑故来。众所以疑者。远从前舍身命格量生。上云舍身施不及持经四句。所以不及者。为舍身是有所得颠倒苦因还得有所得苦果故不及持经。众即疑。佛昔来种种苦行亦应是颠倒之因。应得颠倒之果不得菩提也。故今释云。佛昔行苦行。此是无生忍心。虽复舍身而不苦恼。非但无苦而还更有乐。故论偈云。苦乐有慈悲如是苦行果。以修无所得忍故得菩提也。故云如来说忍辱波罗蜜也。非忍辱者。非是有得舍身忍辱也。又非忍辱者。此无所得忍不可称量也。故论云彼忍辱岸难量也。何以故我于尔时无我相者。此二义故来。一者反释无嗔义。若有我相则应生嗔。以无我相故令谁嗔耶。复嗔者谁耶。二者明无忍义。即是不忍不嗔为忍波罗蜜。若有能忍之人则应生嗔。今尚不见能忍之人。何由有他起嗔之者。此是跨节释也。歌利王者。引事证因缘。歌利王即是陈如本身。昔曾害仙人。仙人发愿。汝今无罪害我我得道时要前度汝。如出毗婆娑文。是故须菩提菩萨应离一切相下。所以有此文者。为成前忍辱义。新发意菩萨既闻历世修忍得于菩提。彼既见有身心或生退转。如身子六十劫行菩萨行。后因舍眼遂退成声闻。故今劝云。欲不退菩提心者。应离一切相发三菩提心也。问从上来三处明不住何异。释云。初不住为成檀度义劝行无得施也。次不住为成净土因义。若心有住则心有秽。心秽故则土秽。以心无所住故心净。心净故土净也。今明不住为成菩提心劝不住发心。若心有住则乖正道。岂是道心耶。菩提是正道。今发道心故名菩提心耳。若心有住则为非住者。若心有住则是住颠倒。则为非住。不住般若也。如大经。不住一切法即是住般若。不信一切法是名信般若。生义亦尔。是故佛说菩萨心不应住下。前明劝无住发菩提心。今劝无住修菩萨行。如善财之言也。问经初已明发心修行。今何得更说。答前明建广大等四心名发心。就不住义以明修行。今此中通就不住即明发心之与修行。故前离明。今是合辨也。但举布施者。布施居六度之初。又檀义摄六也。如论偈云云。须菩提菩萨为利益一切众生者。前既明无住发心无住修行。人便谓。既无所住何故发心何故修行耶。即释曰。为利众生故发心修行也。又无住修行方能利众生耳。有所住修行不能自利利人也。如来说一切诸相下。此为成上修行及为众生。既言修行。便有行可修。既言利益众生。有众生可利。便是人法见耳。故今明如来说一切相则非一切相。故虽修万行无行可修。虽利众生实无众生可利。又引佛诚言劝菩萨如说修行。佛说众生与法皆不可得。菩萨亦须如此而学也。须菩提如来是真语者下。此文来有近远。远意成前内外二施格量义。何者。前明虽舍内外二施终不及持经四句。人闻此生疑。诸法实相绝言。云何名字文句能表实相。而受持四句顿有如此福耶。故今释云。实相虽绝言。言是无言因。因言故得表无言。故受持此言功德无量。问此乃释言能表道。云何是释五语文耶。答以言必能表道故。佛言是实由能表道故。受持福多。近意者。上引佛说一切诸相则是非相。说一切众生则非众生。劝菩萨如说而行。今重释所以。须信佛说者。良由佛语不虚故也。真语者依真谛说也。实语者依世谛说也。所以举二语者。为如来常依二谛说法故也。如语者。如十方三世诸佛依二谛说法。此上同诸佛也。不诳语者。佛不诳众生。如大经言。何缘当诳如子想者令堕地狱也。不异语者。为释疑故来。人疑。若不诳众生。何得一佛作种种异说。初三后一。乃至今常昔无常耶。故释云。虽有诸说为成一道。所以不异。如经云。智者终不谓我二语。我于是人亦不二语。法华云。虽说种种乘皆为一乘也。次依论释。唯有四语。故偈云。实智及小乘说摩诃衍法。记于三世事。是名四种语。实智即真语。谓说佛菩提也。及小乘说四谛即实语。说摩诃衍法为菩提。即是如语也。记三世事合后二为不异语也。此四语含小大理事因果。真语是果也。如语是因。此二是大。实语为小。记三世是事也。三语是理。须菩提如来所得法者。有此文来者。上来至此凡有三文。引佛语劝信。初引如来说一切相则非相。说一切众生则非众生。此劝菩萨舍人法见令信无所住教。次引五语证佛语不虚。劝菩萨信佛说无所住教也。今第三引佛所证得法。复劝信无所住教。以佛亲依无所住教证得菩提故。菩萨须信无所住教门也。论经长有一句。谓如来所得法如来所说法。如来所得法释已如向也。如来所说无实无虚者。上来三过劝信语。但恐钝根守语而住故。今明佛语非实非虚。以正道绝言。若守言则失道。故言则非实。非不因言表道。故言则非虚。指月之譬即其事也。斯乃贯一化之意。岂一章经耶。须菩提如人入闇下。依流支十二分。前格量分竟。今是显性分。今三种弹之。一者显性分。经论无文故所以不用。二者若就布施以明得失判显性分者。前明忍辱修行亦应是分也。三者内外格量中各有二格。今内格中止一章竟。余有一格量在。何得合取后格量为显性分耶。今明二意故有此文来。一者近生。上来至此凡有三处劝修不住舍于住义。未知住有何失不住有何得。劝修不住舍于住耶。故今最后释其得失。心有所得则如外无光明内有黑暗。故不见正道。心无所住如外有光明内有眼目。能见正道。为此得失故有上来三劝也。依无住之教。如外有光明。得无所住观解。如内有眼目。如此之人见正道也。有住之失反此可知也。依论生起。云真如一切处一切时常有。何故众生有得如有不得如耶。论师云。真如即是佛性。一切凡圣众生皆有佛性。何故圣见凡不见耶。即用经文释之。如虽常有一色。若外有光明内有眼目则见。无此内外则不见也。虽常有真如佛性。心无所住则见。有所住则不见也。显性之言事在斯也。今明作此意亦于义无失。大智论云。或名如或名实相法性涅槃。但约众生悟迷故有得不得。至论佛性涅槃。未曾得失隐显也。问依论乃明见如不见如。似无次第便是孤生此文。答此文即接前布施得失生。故有住布施则不见如。无住布施则便见如。故非无次第也。但讲论者不见其近。便谓孤生为显性分耳。讲经师虽见其近文两施之得失。不得见其因施得失远明皆有佛性。为有方便无方便故有见不见异也。若取近远两义。则经论皆成也。须菩提若当来世下。有此一章来者。还成上舍失从得之义也。菩萨若舍失从得者。要须受持读诵般若故也。问信受门已明若生一念净信。则为佛智见得无量功德竟。今何故重说为佛智见得无量功德耶。答此般若经有三门明功德。一自信门。二自受持读诵复为他说门。三但自受持读诵门也。初明一念信为佛智见得无量功德。是自信门明功德也。从三千七宝施至恒沙身命施。此明自行化他门明功德也。今此章明受持读诵自行门功德。故非重说也。此三门摄一切般若经明功德也。初日分下。第二三时舍身格量功德也。为二。初明格量。第二称叹劝修。格量中为二。初正举舍身。第二格量也。异上舍身者有二义。一者施多。谓日三时舍身。此日初分日中分日后分。非是三日为三分也。二者时节久。谓无量千万亿劫常行舍身事也。次格量般若。直明信心不逆其福已胜。况自受持读诵为他说耶。此则格量转高。般若之福转重也。又此文所以来者。上信受门中。直明信心为佛知见得无量功德。犹未格量信心功德少多。今欲格量信心功德少多故有此文来也。问何故须格量信心功德耶。答既三门明功德。则三门明格量。上已三处格量自行化他功德门竟。谓三千布施恒沙布施舍身布施。皆自行化他门。犹未格量信心门。故今明之也。问何故格量自信门功德多上自行化他功德耶。答格量自信门功德尚多。自行化他则不可量。故今文云信心不逆其福胜彼。何况受持读诵为他说耶。故此文来有其深旨。欲讲诵者当依此意也。须菩提以要言之下。第二称叹劝修。开文为四。第一叹法。第二叹人。第三重叹法。第四重叹人。今初叹法。前格量竟既称叹。今格量竟亦称叹也。如来为发大乘者说下。第二叹人。问大乘与最上乘何异。答通论不异。此种种叹耳。别者大包含广博义。最上高绝取超出二乘义。广博等即是得义。出二乘即是离义。又大是其始义。据浅行之人。最上是其终义。据深行人也。如来悉知是人者。问前已二处明知见竟。今复明者有何异耶。解云。初知见自信功德。次知见自受持读诵功德。今知见受持复为人说得功德。故三知见异也。若乐小法者。此明举失显得。叹此中举二人。乐小法者此是小乘。着我见者此是外道。此二人不能听受。小乘之人所以不能听受者。以是有所得故不信无得。又此经明如来法身常住。小乘人谓佛无常毕竟灭故不信。故大智论云。五百岁五百部闻大乘法说毕竟空。如刀伤心。睿法师喻疑论云。外国三十六国皆小乘学不信大乘。问小乘亦明空。大乘亦明空。小乘人何意不信大耶。答大论云。空有二种。一者但空二者不但空。小乘唯得但空不得不但空。此经明不但空。故不信空也。又小乘人但得生空不得法空。大智论云。佛灭后分为二分。一信众生空不信法空。二俱信二空。今此经具明二空。故小乘人不信也。外道着我见不信则易知也。须菩提在在处处下。第三重叹法。问此叹法与初何异。答初直叹经法。今叹法所在之处故异也。问上已叹经在处则处贵。犹如塔庙竟。今何故复叹如塔耶。答前略叹。今广叹。前直云如塔庙故是略。今云种种供养故是广。前略叹人。今广叹人。前略叹处。今广叹处也。又前叹经所在处则处贵也。今叹非但经所在处处贵。即持此经人行住坐卧之处皆如塔庙。皆应恭敬供养。如法华云。持法华经人所在方面皆应为作礼也。论意作此释勿不信也。复次须菩提若善男子善女人受持此经若为人轻贱下。此是第四重叹人。问今叹人与前何异。答上就得门叹。今就离门叹。何以知之。前文云持经得无边功德。今言持经离于恶道。此即是金刚能摧诸患难。次意释疑故来。自上以来并明持经之人无边功德。今那见持经之人。有诸障碍所谓疾病遭官横得打骂不如意事耶。为释此疑故。明此人先世罪业应堕八难。以持经力故现世轻受也。我念过去下。第三举释迦往因格量。前内外两施具举现世也。今明往因。此就过去世格量现在世。前就所化功德格量。今就能化功德格量。如此格量方尽格量之极也。问何意举能化所化功德格量皆不及持经耶。答此终是有所得功德不及持经。问何以得知皆是举有所得功德格量耶。答经论皆有证。论释初三千施云。二能趣菩提福不趣菩提。所言二者。即是自能受持复为他说。此二能趣菩提也。施福是有漏有所得不能趣菩提也。经证者此取然灯佛前。尔前是有所得故未得无生。故知取有所得施也。又一意所以举释迦往因格量者。三门明功德。上来已格量两门功德竟。未格量自受持读诵功德。今叹格自受持读诵功德故有此文也。问格自受持读诵何故功德转重耶。答自受持读诵其福尚重具自行化他。岂可称量耶。此是显功德之重故格自行。讲诵者须细看经。不尔不觉也。问三门明功德格量三门何异耶。答云。自行化他门则功德即格量。从三千至恒沙身命是也。自信门自受持门此二门前明功德后格量。故文有开合之异也。问三门明功德何异耶。答即是三品。但生信心为下品。受持读诵不为他说为中品。次受持复为他说为上品。又前是自行。后一具自他也。须菩提善男子善女人下。大章第二。前第一明格量。今明格量所不能格量。会不格量所及。若其更格则人不信。故云不思议也。尔时须菩提白佛下。二周说法中此是第二。依论师十二分此是第十断疑。今所不用。何故尔耶。论云。从如来非有为分下皆是断生疑。何得言此中始是断疑。复有人言。上来始答住问降伏心问。今次答菩提心问。今明前具答四问竟。云何于此始答菩提心问耶。又前答后答无异。云何前非答菩提心今始是答耶。其人见近不见远也。次有人言。前明因空今明果空。彼谓修行等是因。前辨修行空故是因空。菩提是果。今云实无菩提可得故是果空。此亦不然。上已具说因果深义竟。何得上言因空此亦是果空。今明此是第二周说。何以知耶。以前后四问皆同佛答亦同故知是二周说也。问二周说何异。答前广说今略说。前为前会众说。后为后会众说。故大智论解无生品云。问曰前已说般若竟。今何得更说。答云前为前来众说。后为后来众说也。如清凉池前来者饮竟而去后来者更饮也。问大经云为后来众生以偈颂说。今何故不作偈耶。答说法多体不可一势。自有前会长行后来者偈。自有二俱偈二俱长行。如大智论说。即是证也。问今何故不作偈耶。答诸般若多不作偈。以偈安字有限。于深义不能曲尽也。次明还是一会而有二周说。初周为利根人说。钝根未悟更为后周说也。问前说后说无异。云何前说为利根人后说为钝根人耶。答大意乃同。其中转易形势故钝根闻之仍得了悟。如一种义作此语说之不解。更作异门释之则悟。犹如一米作一种食不能食。更作异食则能食也。虽是近事斯乃圣人制作之大体也。般若是一法佛说种种名。随诸众生力为之立异字。即其证也。次意前周尽缘后周尽观。前周尽缘者。正教菩萨无所得发心破有所得发心。乃至无所得修行破有所得修行。故是尽缘也。今此章明无有发菩提心人。亦无有修行人。故是尽观也。论云。于内心修行存我为菩萨。此即障于心违于不住道。斯经论之作。岂空称哉。尽缘故无缘。尽观故无观。无缘无观不知何以目之。叹美强名正观。正观即是般若即是金刚也。又前周正明观行。后周除观主。故大智论释习应品云。问曰前已明生法二空。今何故复辨生空。答前为破生法二病明生法二空。今为破观空人也。若无论经有十五章。有论经凡有十六章。有长信受一章经也。问前周说既开三门。一般若体门。二信受门。三功德门。今后周为后会。亦得如此以不。答依论经亦得如此。初即般若体门。信受即第二门。三千世界须弥山七宝聚去是功德门也。今观形势小异于上。故不开三门。但依十五章钩锁相生。故释疑解难以为次第也。初章为二。前问次答。若约后会为论。则问意同前。昔来未依般若不成发心修行。故今请问发心修行之义也。若约空观为论。则前问成发心修行。后问请佛泯发心泯修行故也。问前为成发心修行。后泯发心修行。将不相违耶。答终为成一意耳。由泯发心乃成发心耳。若见有发心不成发心耳。故前来成发心即是泯发心。今泯发心即是发心也。佛答中为二。初牒问明。发心即是缘尽义。从何以故实无发心者。明尽观也。问佛答与上何异。答上但尽缘。今缘观俱尽。即是异也。又上是广答具答四问。今是略答但答发心。发心既尔三问例然。为显后周是略说故也。又意初发心尚缘观俱息。况复修行等犹存有所得耶。于意云何如来于然灯佛所下第二章来者。论生起云。若无发心菩萨。今那得有受记菩萨耶。既有受记之人必有发心之者。以受记是果发心是因。何容有果而无因耶。此终是历破有所得我人见耳。前已破发心人见。今破受记人见也。就文有八菩提。开为二。初五菩提引昔时了悟无受记菩萨以释疑。次有三菩提引现在佛果得菩提以释疑。初中为三。一佛问二须菩提答。三佛述成。初二如文。第三佛述释中有三菩提句。开为四意。一直述理实无相故无所得也。二从若有法下。此是反释。若有所得则不得记也。三以实无有法下。顺释。以无所得故乃得记耳。何以故下。第四释无所得故得记之义也。言何以故无所得乃得记耶。释云。如来者即诸法如义。以体如故名如来。亦体如故名得记。如中岂有法可得耶。若有得则不体如。不体如不名如来。亦不得受记也。若有人言下。第二引现在得果时以释疑也。疑云。无得受记之菩萨。今宁有得菩提之佛耶。以实有佛果得菩提。则实有菩萨得受记及发心也。此终是历法破有所得我人见耳。故经云菩提心见受记见佛见菩提见断见常见等。犹是一例义耳。实无佛得菩提者。初发菩提心及受记时尚了悟无所得。况至佛时犹有我人得菩提耶。如来所得三菩提无实无虚者。上破有见今破无见也。明佛得三菩提无所得为得。何故不得耶。肇师云。玄道在乎绝域。不得以得之。即其义也。无实无虚者。前各弹有无见。此双结非有非无也。无有有得之得故言无实。非无无得之得故言非虚。论意尔也。是故如来说一切法皆是佛法者。此成上非实非无义虚非有耳以体一切诸法如故名为如来。故一切法如即是如来。故云一切皆是佛法也。即非一切法者。一切颠倒之法此非如来所证。故云则非一切法也。以一切如是如来故非无。一切颠倒非如来故非有。故成上非有无也。此犹是大经有所无无所有义耳。以无所有名大涅槃。故是如来也有所无是颠倒生死。故非如来也。是名一切法者。还结一切诸法如也。问上两句已足。何用下更结耶。答初句直明一切法是如来。次下两句简其有无。初句明无一切颠倒。次句明有一切法如也。问上明然灯佛与今何异。答上为成不可取不可说义来也。今为成菩萨无义故来也。又上是略明义。此下八菩提是广明义也。依论释佛答中论偈。云以后时受记然灯行非上。论师释云。有四时然灯四时受记。谓习种性种道种及初地。前然灯是习种时也。今此是性种道种二时然灯。此中但是名字受记未得真无生记。故云无有法得菩提。若此时已得真无生记者。后一然灯不更与受记也。今谓此释无所出。论直云以后时受记然灯行非上。此言自难解。亦无四时受记四时然灯也。又设有此义于文义相皆不顺。故于今无取也。譬如人身长大下。第三章。经论无生起。观此文举山王譬法身。成上菩提非有非无义耳。法身无一切患故非有。具一切功德故非无。然菩提既非有无。故法身亦非有无也。文有二。初佛举大身为问如文。次须菩提答云。如来说人身长大者。论云。佛以真如为身。二义故名大。一者遍一切处。二者具一切功德。问法身云何遍一切处耶。答华严云。无尽平等妙法界皆悉充满如来身。如来身未曾大小遍与不遍。为众生叹美为大耳。即非大身者。无一切患累故也。论云。远离烦恼障及智障故云非身也。是名大身者。具一切功德也。初句直明大身耳。次句无患累故非有。次句明有众德故非无也。问与上明山王何异。答前为前会后为后会。又上为成无取说义来。今为成菩提非有无义来也。上明报佛今明法身佛也。上惑者谓初得佛时言有菩提可取。故是报佛。今直明法身体非有无故是法身也。菩萨亦如是下。此第四章经来者。论生起云。若上来明无发心菩萨受记菩萨。又无诸佛得无上菩提。若因果皆不可得者。众生亦不应入涅槃。亦无净佛土事。菩萨何故欲成就众生令入涅槃。修净土行耶。此终是有所得心历法生疑。故历法破未竟。故生此章。菩萨亦如是者。此是成就众生菩萨。净佛土菩萨也。亦如上发心受记菩萨不可得。故云亦如是也。是亦上求菩提法身有无不可得。故求菩萨有无亦不可得。故云亦如是也。此中三句经。一破成就众生菩萨。二破净佛土菩萨。三结正菩萨之义。问上已二处明灭度众生。与今何异。答经初且明灭度众生。为答菩提心故来。次第二周初答泯菩提心故来。今为破成就众生菩萨义故来也。问上已明净土。与今何异。答上为成无取无说之义。今为明无净土之菩萨故异也。若菩萨通达无我法者。此第三句结正菩萨之名。此文意有近有远。近者从第二周初已来。云无发菩提心菩萨。无受记菩萨。乃至今明无成就众生净佛土菩萨。人闻生疑。若尔应都无菩萨也。故释云。由了悟无菩萨故始是菩萨耳。见有菩萨则非菩萨也。远即贯于一经。此经始终皆明无菩萨破我人之见。若能了悟无菩萨。方是菩萨。见有菩萨见有则是凡夫我见非菩萨也。问了悟无菩萨者此是知无有我。二乘亦悟无我。何故不名菩萨。答论云。悟二种无我故名菩萨。声闻但悟人无我故不名菩萨也。又菩萨知我无我不二故名菩萨。二乘见我无我异。是二见之人非菩萨也。五眼下。第五章经文来有二。一者近生。还从上四章生。前来四章并不见菩萨。时会即疑。若如来云无所见者则应无眼。若有眼何故不见。故举五眼答。今言不见者。非无眼故不见。五眼见宛然而无所见。如净名阿那律章云。有佛世尊得真天眼常见诸法。不以二相。大品复云。我五眼尚不见诸法。况凡夫无目而言得菩提耶。二者远生。经初已来皆明无得无见。故有今文。又上破有见故云无见。今破无见故有见未曾见不见也。五眼义别须释。今且示数意。然五眼具得约五人有五。谓人有肉眼。天有天眼。二乘见四谛有慧眼。菩萨照三乘根性说三乘法有法眼。佛有佛眼。次约二人。因人四眼。果人一眼。因人四眼如仁王经叹菩萨得四眼五通。果人一眼即佛有佛眼也。次明一人具足五眼。即是佛。问何故具足五眼。答此是无差别差别用。举障内境约佛智故名肉眼。举障外境目佛智故名天眼。约二慧境名慧眼。无量寿经言。慧眼见真境。见真境名慧眼。大品往生品中云。慧眼无法不见。又云。而无所见。大智论言。具总相慧别相慧名眼。故知慧眼具二慧也。法眼可知。四眼不了。佛眼具了。故名佛眼。亦见佛性故名佛眼也。须菩提恒河中有沙者。此章为成五眼。依论师生起。明五眼既少而境多。何得以少眼知多境。境既多眼亦应多。而今眼少。何能尽知多境。为此疑故。今明眼虽少而能遍知一切境也。论既无文。今明亦复无妨也。但知前既辨五眼。今出所照之境也。问前举恒河今明恒河何异耶。答前为成格量四句偈故举恒河。今为五眼所照境故举恒河也。问境既多。何独云知心。答有二意。一者广略。前明能照之眼广故具明五眼。今辨所照之境略故止言心也。二者心无形触最难知。今举其难知。尚知易可明也。如来说诸心者。明如来见一切众生心唯在颠倒中行也。则为非心不在正观中行也。是名为心者。结颠倒心也。三世心来者。释成颠倒心义。何故名颠倒心耶。以三世求心不可得。而众生见有心。此是无而谓有。故名颠倒也。须菩提满三千世界七宝者。文来为释疑。上言佛知众生心皆颠倒。则颠倒心所作布施等众行皆是颠倒。若尔应无佛因。既无佛因应无佛果。故释此疑明。无所得心布施等则是佛因。既有佛因则有佛果。问曰。何由有不颠倒。为从颠倒得不颠倒。为从不颠倒得不颠倒。二俱有过。若从颠倒生不颠倒。则倒为不倒因。若从不颠倒生不颠倒。则不颠倒便无因。答大品三慧品佛答此问。不从有得生无得。不从无得生无得。得无得平等故是无所得。即其事也。问前已明三千世界七宝。与今何异。答前七宝为格四句偈。今七宝为成佛因也。若福德有实。此便释疑。疑云。上亦三千七宝。今亦尔。何故是佛因耶。故释云。若福德有实此明有得福德。以福德无故此明无得福德。故是佛因也。须菩提于意云何佛可以具足色身下第六章经。上来至此三处明色身何异。答初为明相好身异法身。相好身有三相。法身无三相也。次文为成两因优劣义。二身两果既优劣。二身两因亦应优劣。成格量经义故来。今文为破二身一异见故来。上两处明二身异。寻语之流即云。有相好身与法身异。如从来本迹异三佛异义。故此章经破一异见。论有二偈。上半云。法身毕竟体非彼相好身。此即破其二身一见。明相好身有相好法身无相好。二身有异何得一耶。次偈上半云。不离于法身此二非不佛。此破异见。何处离相好有别法身耶。故云此二非不佛也。问二身定一。定异。非一非异耶。答诸法无有定相。而具有三句。昔日明相好身亦生灭五分法身亦生灭故。二身同生灭。则是一义。次此经上来两处开二身之异。相好身有生灭。法身无为无生灭。此是异义。今此一章双破一异。故佛具有三种方便。问昔何故说一方便。乃至今何故说不一不异。答昔为破常见故明佛二身皆生灭无常。故二身是一。小乘人便作一解故。经初开二身生不生异。时会便云。小乘二身是一。大乘二身是异。故今具破一异。得意者三俱会道利物。不达者皆是颠倒戏论也。破二身一异见既尔。破法身有色无色亦然。论云。此亦无亦有。法身绝相不可言有相好。离相好无别法身。不可言法身无相好也。所言具足色身者。唯佛一人尽形相之美。故言具足。余人乃至轮王相不明了。故不具足也。如来说具足即非具足者。破一见。明色身非法身。何得为一。是名具足。此破异见。何处离相好别有法身也。可以诸相见不下。意与前同。但身总相别相为异耳。于意云何如来有所说法不下。此第七章来者。此破法身有说法疑。疑云。若具足色身非法身者。云何言如来有所说法耶。故佛破云。须菩提汝勿言如来法身有所说。若言如来法身有所说则谤法身。法身非色故法身非说也。何以故说此一句。破法身无说疑。若言法身不说相好身说。此亦不然。上明不可离相好身别有法身。便谓法身无相好。亦不可离相好身说别有法身说。而谓法身无说。问何以知经文如此。答论偈云如佛法亦然。故举佛例法也。无法可说是名说法者。此更破疑。人闻法身有说便言有法可说。故今释云。虽复说法无法可说。假名说法耳。论次此章后长有信受一章经。问上信今信何异。答上明信信因果深义。今明信信上如来虽说无所说也。问何等人能信此法耶。答论偈云。非众生众生非圣非不圣。此人非凡夫众生故言非众生。而是圣体众生故言众生也。非众生故非圣。是圣体众生故非不圣也。问若言凡夫不信不可为凡。圣人能信不须为圣。今说此经竟为何人耶。答观此论意。具足颠倒有所得凡夫不能了。此是习无所得观众生则能信。此众生望有所得人故非众生。未具足了悟故非不众生也。于意云何下。第八章经论生起　从上第二章经生。上第二章经云佛无菩提可得者。今云何有阶级位行耶。如谓从十信至十住。从十住至十行。从十行至十回向十地等。既有进行阶级则佛果应有所得也。近文生者。相好论身业。无所说辨口业。今得菩提明意业。佛既无所说应无所得。今实有所得应实有所说也。问初周中已明佛无所说无得菩提。与今何异。答前后两会利钝两缘。此二义通贯十五章也。但今文与上有开合之别及来意不同。来意不同。上明释迦是化佛破实说之疑。今明不可言法身有说。不可言无说。破法身有说法身无说之义疑。上明无得菩提破实得之疑。今明无得破举因行阶级证果实得疑也。又上云如来有所说耶。有菩提可得耶。此得说合论。今则开得说为二章经。前章经明无所说。此章明无所得也。文三。初佛牒疑情反问善吉。次善吉奉答。明佛无少法得菩提。若有一豪之得则不得道。以毕竟无得尔乃得道耳。以得果实无一法可得。行因实无一行可行。无所得故始得果。无所行故乃是行因也。次佛述四义释无上菩提。初即述以无所得故名无上也。二以体悟法界平等义故名无上菩提。以无我无人故得菩提者。第三义。彼菩提体无二种我名无上也。上之二义就得门释无上菩提。今就离门释。谓菩提体有我人则非无上。以体无有我人故名无上菩提也。修一切善法者。上三门就果释无上。此第四义就因门释无上。以有无上方便修一切众行满足故是无上。余菩萨修因行不满故非无上也。如来说善法则非善法者。简上修善法义。今明是无所得善法耳。得非是有所善法故云则非善法。是名善法者。还结取无所得善法也。三千世界须弥七宝下。此第九章。问前周已举内外两施明格量竟。今何故更说。答上已明前后说为两会之众。不应问也。又上来明般若体门及信受门竟。今说经是功德门也。又依论生起。从上修一切善法得菩提文生。若言修善法得菩提者。受持此经章句不得菩提。何以故。萨婆多等诸部人云名字句是无记法故也。为破此疑故重举也。明名字句虽是无记能表实相故。受持四句功德无边。又汝法中言是无记。我法中明此是般若名字句。岂是无记。故受持四句胜大千广施也。问等是破无疑。何故不举恒沙七宝及举恒沙身命耶。答三千宝是最初格故举初章耳。又为后会人须渐次格。不得顿格超说恒沙。又今三千财与上为异。上但明三千财不及持经四句。今明百分不及一等也。依论经有四种胜。一者云百分不及一。乃至百千分不及一。此是数胜。持经福不可数也。二者歌罗分不及一。此是力用胜。明经力用胜七宝施力用。三者优婆尼沙陀分不及一。此云不相似数胜。此是数中微细之数。乃至持经少许福德数无有与此数相似。故云数胜。四者因果胜。此经因果胜余因果也。须菩提于意云何下。第十章经来者。论云。从上菩提无高下生。无高则诸佛不高。佛非能度。若无有下则众生非下。不下度众生。而佛是能度故佛为高。众生是所度故众生为下。不应无高下也。又从上为他说四句生者。时会既闻为他说四句功德无边。便谓有众生可为。故今破之也。前文止于疑念。次何以故释止疑念所以。明实无众生可度。汝不应念佛度众生也。若有众生如来度者。此是反释。若见有众生可度。佛则有取我之过也。以众生见众生众生名众生。不能自度。何能度众生。佛亦见众生佛亦名众生。不能自度。何能度众生。佛若见众生佛能度众生。众生亦见众生众生应能度佛。有如是大过故佛不应见有众生也。如来说有我者则非有我。又释疑。疑云。若无众生可度。佛口中何故自称我耶。如云我本行菩萨道等。故知有我。答云。如来随俗说有我耳。实无有我可说。而凡夫之人以为有我者。更疑若无我者何故世间皆云我来我去我生我死等耶。即释云。此是凡夫人于无我中横计有我耳。故云凡夫以为有我也。凡夫者如来说非凡夫。论经具足云须菩提凡夫生者。如来说非生是名毛道凡夫生。所以有此语来者。上既云凡夫之人以为有我。故今释凡夫义也。所以言凡夫生如来说非生者。以不生圣观故名非生。生凡夫颠倒心故是名凡夫生也。问论经何故云毛道凡夫耶。答愚痴不解一毛端圣法故也。数人别有凡夫法凡夫性。凡夫性是非色非心不相应行无记法也。凡夫法通五阴通三性也。成论义无别凡夫性法。但无无漏圣法故名凡夫法耳。可以三十二相观如来不下。此第十一章经。上已三章来各有其义。今复来者。上第三章中虽破如来法身有相无相一异等见。但耳眼之徒多言三十二相是佛。即更复生疑。以修三十二相业等故得三十二相身。有三十二相身即有法身。故知法身应有相好。为破此疑故有此章来。又初周两过明相好。后周亦两过明相好。二会之信亦不可失。又近接前章总明正法平等无有高下。次章明无众生可度释无下义。今了三十二相非佛释无高义。此一章经凡五句。一佛牒疑情问。二须菩提同迷答。三佛举轮王并破。四须菩提悟解。五佛说偈呵之。问观佛三昧经云。若观佛色声皆灭重罪。今云何见色闻声行邪道耶。答若得般若方便用。见色闻声亦是佛。非色声亦是佛。乃至非非色声亦是佛。若不得般若方便用。五句皆非佛。故观般若偈云。若人见般若是则得解脱。若不见般若是亦得解脱。若人见般若是则为系缚。若不见般若亦为系缚也。汝若作是念下。第十二章经来者。论生起云。若言不以色相好见法身者。则修相好业不得菩提。若尔应无福德之因福德之果。为破此疑故明。汝勿言无福因及福果。佛有二种庄严。福因得相好果此是福庄严。修智慧因得智慧果是慧庄严。如来具有福慧二庄严。何故无相好果耶。汝若作是念发菩提心说诸法断灭。又疑。菩萨得无生忍出世间智慧。尔时舍肉身受法身。则应无复福德因福德果。为破此疑故明。菩萨得无生忍得妙智慧妙福德。岂失福德因果堕断灭中耶。问此中云发菩提心。何故释云得无生忍耶。答初得无生忍亦名初发心也。又此中明从初发心不习断灭观亦不起常观。后心皆尔。故初后不二。如云发心毕竟二不别也。前明佛果非有相非无相。今明因非断非常。可谓因果皆是正观皆离断常。问若尔因果何异。答明晦不同故开因果耳。以满恒河沙世界七宝布施者。问上已恒沙格竟。何故重说。答前周从三千至恒沙。后周亦尔。两会之义不失也。又来意异。前为格量持经四句。今为格量菩萨无我忍也。此是人法无我故名无我忍也。不受福德者。不受有所得福德故此菩萨胜前菩萨。前菩萨受有得福德故不及后菩萨也。次问答料简不受之义。问菩萨既作福德。云何不贪着耶。答菩萨以无受心作故不生贪心。多非作福德然复不贪也。若有人言如来若来若去下。第十三章来者。论生起云。菩萨既不受福德则不受世间人王天王。云何往来六道利益众生耶。故今释云。菩萨虽不受世间果。而化身往来六道作人王天王利益众生。法身常住则无有去来。勿见化身去来利物便言法身亦有去来。勿见法身无去来谓生身亦无去来。此中正明化身有去来破法身有去来疑。故云。若言如来法身有去来者。不解法身之义也。问若化身有来去法身无来去。还是从来义耳。答此是不二二义。故开二身。无去来去来是化身。去来无去来是法身。皆是为物作此名字耳。至论。正般若未曾二不二去来不去来也。须菩提以三千世界碎为微尘下。第十四章经。前已明微尘。今复明。何异。释有同有异有同者。同取为譬喻。异者来意各别。前举有微尘譬有所得布施。成格量优劣义故来。明有得布施此是尘染因。还得尘染果故不及持经四句。今举微尘喻破十方佛法身一异之疑。如世界碎末为尘。不可言一处住。以其各散故亦非异处。既无聚云何散耶。十方佛法身不可一处住。不可异处住。以不可一处住非是混成一法身。不可异处住故不可各各有法身。故论偈云。于是法界处非一亦不异。此破由来两解。或言十方佛混成一法身。或言各各有法身义也。问何故举微尘喻破法身一异疑耶。答如微尘散灭故不可说一异处。如是十方佛烦恼尽故不可说法身一异处住。故论偈云。微尘碎为末。示现烦恼尽也。问何因缘故破法身一异疑耶。答上明化身有来去法身无有来去。法身无来去故时会生疑十方佛法身同为无来去。为成一法身同处住。为各各有法身异处住耶。又上来广破二身一异之见令识正果。今破微尘世界聚散之见令识依果故。令了悟不依不正毕竟空义故有此文来也。此中前牒彼疑。而顿举三千世界微尘者。欲明十方一切佛法身同异义也。答云甚多者十方诸佛多也。说微尘者。举微尘为喻也。假名微尘无所有故云非微尘也。是名微尘者。还结正假名义也。世界一合相者。若微尘世界相对。微尘喻十方法身不一。世界喻十方法身不异。但论意用微尘通喻不一异。世界偏喻不一也。问前微尘通喻不一异。何故举世界别喻不一耶。答人闻十方法身皆无来去大小。应是一也。以多有一疑故偏破一也。一合相者合众尘成世界也。一合相不可说者。圣人了合无所合。如破合品。是法不自合异法亦不合。合法及合时合者亦皆无。故无有合。但凡夫见有世界故起贪着心言有世界耳。若人言佛说我见者。此文近接前生明凡夫贪着其事生也。凡夫贪着由于我见。我见既无贪着何由有耶。又远释一经。上来处处叹无我无人。但凡夫颠倒起我见人见耳。时会便疑。佛说凡夫起我见。故知有我见可起。若无我见佛不应说凡夫起我见。此是一疑也。又二乘人云。先有我见故断我见故得无我智。是名得道。此是二疑。破初疑云。若人言说我见便有我见可说者。则不解佛所说义。佛欲明我见是无故说我见耳。非说我见便有我见可说也。故中论最后偈云。一切诸法空。世间常等见何处于何时谁起是诸见。故非但正见不可得。邪见亦不可得。故知道门未曾邪正。此经将竟。上破昔有所得正见不可得。今破其邪见亦无得。显正般若未曾邪正也。即是答二乘人亦不得言先有我见断我见故得无我智。今乃明我本来毕竟不可得。何所断故言无我耶。应如是知者。上明我见本来不可得。今明法见亦本来不可得。故举我列法故云应如是知见信解不在法相也。所言法相者则非法相者。亦如我义佛说我既非我。说法相亦非法相也。问如是知见信解何异耶。答论偈云二智及三昧。知是世谛智。见是第一义谛智。信解者是二智所依三昧。依三昧故发生二智也。问何故明二智。答菩萨了人法空具足二智也。又始行菩萨未得无生。了悟浅名世谛智。深行菩萨得无生忍。了悟二空名第一义谛智。三昧通是二人智所依也。若人以满无量下。此第十五章经。上如来者无所从来。总明二身。微尘譬喻别料简法身。今此一章经别料简化身。疑云。化佛既有去来。供养化佛持化佛所说。何如真佛耶。故今明。若能于化佛所发心受持化佛四句偈者功德。胜无量阿僧祇世界七宝施。云何为人演说。释为他说义。明上来数劝为人说法。今经之欲竟示说法之方。当如如而说。下如字则是如法性之如。劝行者当如法性如而说。勿生心动念也。下偈即明说法之辞亦如十喻之说。故居士经云。说法者无说无示。譬如幻士为幻人说法。什法师云。十喻以喻空。空必持此喻。借言以会意。意尽无会处。既得出长罗住此无所住也。若依论经明之。经曰。云何为人演说而不名说。是名为说。此释化佛说法义。化佛说法不自称是化。若自称是化则众生不生信敬。故言不名为说。是名为说者。直化佛说法也。一切有为法偈来者。更释疑。疑云。诸佛常为众生说法。何故复入涅槃。故明诸佛如来不住涅槃不住有为。以诸佛为利众生化身说法故不住涅槃。观有为如梦幻故不住世间也。论经广有九喻。云一切有为法如星翳灯幻露泡梦电云。一者如星。日未出有用。日出则无用。未有正观日出则妄心有用。正观日出则妄想不可得。第二翳喻。如眼有翳故见空有毛轮故可得。翳慧眼故无六尘妄见六尘也。第三如灯。还喻能见识法。如有油炷器三法合故有灯。根尘及贪受故有识生。灯和合有无所有。法亦和合有无所有。灯念念灭。识亦尔也。第四如幻喻。如幻师作种种物而无实。众生业幻故见种种国土亦无实也。第五露喻。露少时住。身亦尔。第六泡喻如天雨渧成泡小儿谓之即为珠心生贪着。众生三受亦尔。从根尘识生亦不实也。第七梦喻。过去法如昨夜梦见有了悟则无也。八者如电喻。才现即灭。现在法亦尔。第九云喻。空中净忽然云生即时便灭。未来法亦尔。忽然而起即时散灭也。委曲须讲释。今略示耳。第三流通如文意云云

金刚般若经义疏卷第四毕


金刚般若经疏

    No. 1698 [cf. No. 235]

金刚般若经疏

        隋天台智者大师说

略释经题。法譬标名。般若幽玄。微妙难测。假斯譬况以显深法。金即三义。一宝中真上不可侵毁。二利用自在摧破诸物。三表里清净影现分明。刚是坚义。谓身命财。身即法身。命即慧命。财即法财。功德助道。用譬三种般若。实相般若理性常住。观照般若破五住惑。文字般若解脱自在。如此三法不纵不横非并非别。成秘密藏。佛三种身亦复如是。实相即法身如大经明金刚身品。观照即报身如金刚三昧破诸烦恼。文字即应身。随机利益普现无边。旧云金刚譬十地后心因圆之位。今言初心至后即有六种金刚也。体者若见诸相非相即见如来。是经之正体也。宗者约实相之慧。行无相之檀。如人有目日光明照。见种种色是因。诸相非相是果。此之因果同约实相。用者破执为用。一切封着通名为执。破诸相惑显出功能。亦自无滞即力用也。教相者有五。一摩诃二金刚三天王问四光赞五仁王。广略虽异同名般若。摩诃以广历色心。乃至种智皆摩诃衍。此文略说金刚为喻也。次广解释。言金刚般若此乃摧万有于性空。荡一无于毕竟。甚坚甚锐名曰金刚。智名决断。慧曰解知。万像虽繁物我无相。有为斯绝寂其机照故假名般若。西云跋阇罗亦云斫迦罗。此翻金刚。云是利铁亦名破具。引大经云。佛告迦叶汝今决断譬若刚刀。又云劫火起时一切皆销。利锐者在下为金刚际。又云往古诸佛舍利变为金刚如意珠。今通取坚利为譬。旧云体坚用利。体坚众惑不侵。用利能摧万物。今问体唯坚不利。用唯利不坚。亦应体则不利用则不坚。此乃不坚不利何谓坚利。百论云眼非知意非见。别既非见合云何见。今依中论通此问即无滞义。今言坚利者不坚不利。假言坚利。如言苦以不苦为义。无常以常为义。空以不空为义。此一例语任运不畏斯难。般若如大火聚四边不可触。岂可定作体用耶。体用因缘不一。不异。体坚用亦坚体利用亦利。既其不一假名义辨。若说体坚即说用利。此是假名义一边之说。离用无体离体无用。用即寂寂即用。无别有无用之体主于用也。亦无别有无体之用主于体也。不一亦不异有因缘故亦可说一说异。为破一说异破异说一。假说一异。令众生悟非一非异秖名此因缘不一不异离断常戏论。戏论不得入即是坚。能破断常即是利也。问何者为般若如是坚利。答一往性空为般若。不断不常不一不异性空毕竟空为般若。万相一无皆悉尽净。大论云般若有三种。实相观照文字。实相即理境第一义谛。观照即行人智慧。智慧鉴此实相。说智及智处皆名为般若。文字能为作诠亦为般若。故云无离文字说乎解脱。一体三名同秘密藏。问有翻无翻。答翻为智慧。问大论云智慧轻薄般若深重云何相翻。释论七十卷释须菩提五叹不可称不可量无等等无有边如虚空。解不可称句云称名智慧。此是称量檀度。非智慧不能准量。故称名智慧般若定实相。此释不可量何意不可量。欲明佛所得般若明鉴实相甚深穷边极底。菩萨因中智慧不能称量佛果地般若。此是因中智慧轻薄。不能称量果地般若。何得妄引无翻耶。大经云慧有三种。般若毗婆舍那阇那。同一气类随名而辨。约人般若属众生。毗婆舍那一切圣人。阇那诸佛菩萨。就法者毗婆舍那总相。般若别相。阇那翻破相。毗婆舍那翻正知见。此即是总相知见般若翻出离慧即是属众生。众生有慧数故。阇那诸佛十地菩萨。有决断义故。共为一位耳。波罗蜜亦阿罗蜜波罗伽等。翻度彼岸。亦彼岸到亦度无极。此假名无度为度耳。佛已度智慧度名一切智。菩萨未度亦不名度。度时亦不名度。不离已度度未度故。而今言乃度此假名说度。一行度二时度三果度。六度善修满足为行度。三僧祇满为时度得大菩提为果度。彼岸者生死为此岸涅槃为彼岸。烦恼为中流。八正为船筏。又悭贪为此岸佛果为彼岸。布施为河中正勤为船筏。又取相为此岸无相为彼岸。智慧为河中精进为船筏。一往如此。又即生死涅槃俱为此。非生死涅槃为彼。故云远离此彼岸乃名波罗蜜。又前生死涅槃双非中道为二。非生死涅槃中道为不二。二不二俱为此。非二非不二俱为彼故远离二边及以中道名波罗蜜。修多罗翻契经。经字训法训。常由圣人心口也。次部轴者第一部十万偈。第二部二万偈并不来此土。第三部一万八千偈即大品亦名放光。第四部八千偈即小品亦名道行。第五部四千偈即光赞。第六部二千五百偈即天王问。第七部六百偈即文殊问般若。第八部三百偈即此金刚般若。睿师云并是如来随机之说。般若非称量过诸数量。岂是一多四五之可说。次简前后。言金刚前后者。肇师注云五种般若此说最初又千二百五十人后说大品。大数五千人受化转多故摩诃在后。若金刚在后者。仁王经云初摩诃次金刚。又护念付嘱及得慧眼。未闻此经似宜在后。俱有证据。由人用耳。对机设教广略不同。从得道夜讫泥洹夕常说般若明理一等。若依光赞如来十九出家三十成道。至四十二二月十五日食后。为诸菩萨说般若。次译经者罗什法师秦弘始三年即晋安帝十一年译。又后魏末菩提流支译论本八十偈。弥勒作偈天亲长行。释总三卷分文十二分。一序分二护念分三住分四修行分五法身非身分六信者分七校量显胜分八显性分九利益分十断疑分十一不住道分十二流通分。讲说时别一途开章耳。就此一经开为三段序正流通。序为缘起。说教之前必有由渐。分卫放光雨华献盖等也。由渐既起正教宜陈。缘教相感其犹影响。故有正说。又非止近被一时。乃欲远传来际。故有流通三段各二。序有通有别正说前后二周。流通付嘱奉行通序为五。如是者佛所说般泥洹时。侍者请问答云。一切经初皆安如是。我闻者亲承金口。而闻事非谬也。一时者言则当理理亦如言。当理得时令人开悟圣不虚说言必会机。故言一时也。佛者大师之名佛者觉义。异凡夫故自觉。异二乘故觉他。异菩萨故觉满。在舍卫者法王行运。应物而游在舍卫城。憍萨罗国舍卫名闻物国。胜物多出此境嘉名远振诸国故名闻物。又舍婆提者昔有二仙。弟名舍婆此云幼小。兄名阿跋提此名不可害。合此二人以名城也。祇树给园者。须达布园只陀施树。共立精舍。广出他经。与大比丘者圣化无秘。听必有俦俱闻如林。可明信矣。应有四众略而不载。比丘云怖魔乞士破恶。千二百五十人者三迦叶一千目连身子二百五十。尔时世尊下明别序。上明通序以证信。今辨别序以发起具上十号故曰世尊。食时者食熟之时。一人家皆有施心易生。着衣僧伽梨衣也。佛观良田区塍命出家人着此服也。持钵执四天王所奉应器。入舍卫城乞食。法身无待何须乞食。天人妙供百味日盈。自行分卫福物之宜。乞食有十利。一见相好二去疾三除慢四为女人监护五天龙从六四天王钵七贫富等八不杂九息谤十常在三昧其实不食。此城纵广千二百由旬九亿家。国南城北精舍在东。自外以适故言入也。食时如法食。众生有此胜智。机缘将发以表般若。着衣持钵衣是被弘誓铠慈悲之心。钵是行钵钵能盛饭。行能趣理即表解脱城。即法性涅槃之城。观五阴舍悉皆空寂。不动如城以表法身次第乞食不越贫从富不舍贱从贵大慈平等故言次第。即表菩萨次第行次第学次第道。行行因缘故为还至本处。本处即一切智处。历色心观至一切智。饭食讫收衣钵者即是果后无复愿行。无誓故收衣不复进行故并钵。洗足已即是定慧无复垢累。尘沙无明永去。洗水清净故言洗足。敷座者即诸法空为座。四无畏处此说般若也。别序竟时长老须菩提下第一为正说。文又为二。从初至果报不可思议。名实智道重白佛去是方便道。或为后来或为钝根。或可智度善权为菩萨父母。如判大品般若方便两道分文。此经略说亦复如是。就前段中初问次答。问中前述赞次正问。长老须菩提是对扬主。有长人之德夫钜钟虽朗非扣不鸣。圣不孤应影响唯仁须菩提翻空生。亦名善吉。或云东方青龙陀佛。从座起者请业之仪。即事请道侧身避席。袒右肩者隋国法以袒为敬。亦示弟子执作为便。右膝着地屈曲伏从。示无违拒之貌。合掌敛容只肃显师尊道重故。克敬尽恭专一之至。白佛言述赞。希有者佛从前代八万四千岁皆轮王位。至释尊身若不出家。当二千五百岁作金轮王。而能舍位从门乞食。是为希有。此叹身密。护念叹意密付嘱叹口密。又是述赞大品中意。护念即般若实道如母能护念。付嘱即方便权道如父能教诏付嘱。世尊下还蹑前述更起今问。发菩提心者一切智也。总牒指归翻云无上正遍知觉。标心拟向远期正觉。次问住。入理般若名为住即实智。次问降者。方便即权智。如善财言我已先发菩提心。云何修行云何学道。佛言善哉下第二佛答。初略许次广答。略许中有三一述二诫三愿闻。善哉下述许如汝所说赞请之仪。当理会机尽善尽美诚如所言汝今谛听下诫示听。若不审谛即漏言遗理。诫令谛听言理弗虚。唯然下受旨愿闻。慈诫许说敬肃倾心也。佛告下第二广答为三。初明般若体空无所有。次云何名下二明名空无所有。后忍辱下三明力用空无所有还。就初中更为三段。初正明体相空二信者行深三信受福重。初体相中降心约愿住心约行皆无所有为无相因。法身无色为无得果。问何故。许中前住后降。答中先降次住。互前后者。般若多含义非一辙。若约发心前愿后行广发誓愿。权引于前次入实相以无住法住于妙理。若约修行要须前修实慧次用权道。故有二观次第。前住后降若就证时。权实一心中悟不复前后。今就誓愿中有四心。一广大。二第一。三常心。四不颠倒菩萨发愿普济万物无边旷远。故名大心欲愿与涅槃寂灭极乐故名第一。生死道长众生性多。而诲人不倦名曰常心。不见能所名不颠倒。释大心者横亘四生竖穷三界。四生是能住三界为所在。依[穀-禾+卵]谓卵含藏曰胎。假润称湿欻现名化。若有色即欲色二界。无色即空处。有想是识处。无想不用处。非有想非无想即最上天。我皆令入下释第一心。法不自起因缘故生。但是因缘自性皆空。顺理为解乖宗成惑。惑即生死流转受身心苦。解即累灭苦尽寂然永乐。谓之灭度。小乘涅槃灰身灭智为无余。大乘以累无不尽德无不圆名为无余。生灭观在名有余也。如是灭度下释常心。若有能所即懈息以无休倦。故名常心。度无量无边实无度者。大品度空品云。度众生如度虚空明众生无毫末可得。只解众生本来无所有即是悟。悟即名度。若有众生可度者。佛菩萨等即得杀罪。于一身理而为论。实无有众生。众生颠倒妄执谓有。今佛菩萨怜愍说法令悟本无所有。名此悟为度。实无别有众生异理而度着涅槃中也。何以故下释不颠倒。以失显德。若有我人可言有灭。但是假名横计人我。执我为非忘我为是。是非既彰得失明矣。大品中具明十六。一我二众生三寿者四命者五生者六养育七众数八人者九作者十使作者十一起者十二使起者十三受者十四使受者十五知者十六见者。此中略明四耳。复次下第二答住问更为三。初辨行次举喻格量后结劝。就辨行中二前标无住为本。依无住本行于布施即住般若中也。娑婆世界宜用檀义摄六。资生摄施无畏摄戒忍法摄。后三但举一檀即摄六也。舍心无吝谓之布施。无相可存何吝之有施为六度之首。尘为生法之机二法皆空于何不尽次菩萨应如是布施下结成住义。施受皆不可得不住相也。正以虚心而施福不可量。理既无量心不应限。称理行施其福弥广。东方虚空下第二举喻格量。理行既显如说而行。其福甚多齐太虚也。但应如所教住下第三结劝也。圣言无谬理不可越。如佛所教安心住实相也。可以身相见不下明愿行皆无相为因。法身无色为无得果。菩萨发心有三义。一化众生二修万行三向菩提降伏明化物。辨住示修行。如来身相即菩提果体若识法身菩提可登。若计性实乖之远矣。举法身明菩提空也。不也下善吉深识法身。故言不可以身相而见。或一身一智或言真应或言法报应皆是明果。若至果理不生不生而般若生理不生不生即法身不可说。习报二果不生不生即报身不可说。慈誓不生不生即应身不可说。如此三身皆不可说。那得以身相见如来。以因缘故。若得道人闻说即悟得见如来。若闻不悟虽说身相即非身相故不可见凡所有相皆是虚妄若见非相见如来者。非因非果有因缘故可得言因。亦可言果如非初焰非后焰。不离初后焰即此意也。今只以相为非相非谓遣相别有一非相。若能如此即见如来。颇有下第二明信者。行深文为三。一明行深二释三引证。初有问答。问颇有人能信不答如来灭后后五百岁有持戒修福者。二初非一佛二多积者能信此经。出家持戒在俗修福后五百岁者。从六百至一千亦云最后五百始有佛法之名。能生信者非值一两佛也。应以如来灭后是其得道之时。如优波掘因缘。若寻其本非一两佛也。净信无所得信也。无相者为净信。五百论师非不持戒不信大乘四依。久植故能信耳。既得实相净信。如来以种智知以佛眼见。见其一念信得无量之福。如一人以花自供佛。一人以花与他供佛所得福德。问罗汉不能见问弥勒。弥勒云自者毕苦得辟支与他得成。佛是菩萨心故如来知见。般若为佛母佛常眼观。此经及受持者福与虚空齐。非下所测唯佛能知见耳次何以故下第二举二空释成。信者相有三。何以故初标次释后结。此中文隐有纵释反释传释。初列生空有四。我是自在之名。人为宰主之目。众生取续前为义。寿者以接后为能此四同为人。执随用以立四名。广即十六知见取着此见不信般若。次列法空。但有两句法非法也。今言法者说五阴空为法。五阴相为非法。即以阴空为药名法。阴有为病名非法。阴病既除空药亦遣。非法既谢在法亦亡。又持戒为法破戒为非法。次若持若犯并非法。非持非犯为法。是中道义。此信达中道离有无二边。乃信此经耳。以是义故。如筏喻者第三引证。信者行深有六。初举经为证二举菩萨正行。三举菩萨遍行四举往古时事。五举净佛国土六举譬山王。为证第一引经为证者。譬欲济河构筏自运。既登彼岸弃筏而去。将度生死假乘万行。既到涅槃万善俱舍。道法尚舍而况非法。初以善舍恶后则俱舍如来得菩提下第二举菩萨正行为证。佛问有菩提可得有法可说。不答。无有定法名菩提。亦无有定法如来可说。无定即是性空解穷相尽谓之菩提。无相故不有。假名即不无。不有不无何实可得。何定可说。应化非真佛。亦非说法者。应既不说真亦复然。离真无应真应不同。由来真不说应说。说即不说不说而说。若知如来常不说是为具足多闻。何以故下释菩提无相可取。诸法空不可说非法即不有。非非法即不无。故不可说。有无并无理之极也。所以者何。理无生灭谓之无为。无为之理众圣同解。解会无为结尽道成。一解脱义同入法性。无为虽一解有明昧浅深差别也。三千七宝下校量。前举虚空此岂不尽。今一念信解复一番格量。积宝多而功薄。四句约而福厚。金玉三千止以养身。一偈虽约妙极资神。爱佛功德七住未忘。妙着难觉宜应虚心也。七宝是事善缘因。天人果报不动不出。故以动出之慧导之得成菩提。一念圆信能导众善。此心为胜。实相能出诸法。法即非法诸法不生般若生也。须陀洹下第三举菩萨遍行。初举四果次善吉自陈。须陀洹此云修习无漏。亦逆生死流亦入道流。不入色尘是逆流。至论在观无逆无入。言不入色者即是六尘。过去无明所感。无明不实所感六尘那得是实。既其不实那得作定有无六十二见计。以不定性故名不入。海为众流之川。菩提神极之渊。始会无生必尽源也理无乖顺何入之有。违理故入六尘。背尘即会于理。下众果类然。斯陀含云住薄亦一往来。欲界思惑九品已断六品。余三品在故言薄。人天各一生便成罗汉。故名一往来。而实无往来。已得生法二空故。阿那含此云不还亦云不来。欲界结尽上界证无学。应云不来。略以无兼不。互文现耳。罗汉此云无著亦曰不生。三界生尽所作已办罗汉称道前三言果。果实通四而独称道者。以得尽无生二智声闻道极。故以道为名。世尊佛说下第二自陈。以己所解验理非虚。心空恒静诤从何起。兰那者寂静行。相尽于外心息于内。内外俱寂何时不静。得名不虚必称实也。兰那此云无事。若自谓是离欲。即是有事何谓无事。昔在然灯下第四举往古时事为证。次明菩萨其解亦同。如来在昔佛所行般若时。非但于假名不入色香等。亦不入涅槃亦不入中道。是故得成菩提。四依齐此明一念。信人降伏其心无我相等。净佛土下。第五一念净信辨其应住以无所住。住于般若而取佛土即是四种庄严。若自严净即是寂光。若论化他即具四土相惑此土秽虚明即国净。严国之义亦在虚心。如是严净土应行檀等生清净心。不住色香其心无住。三番法非法等。一念净心无住之住。即是非因而因而降住等也。譬如下第六须弥山王。此即非果而果。须弥翻云安明四宝所成是十山中一。一雪山二香山三轲梨罗山四仙圣山五由乾陀山六马耳山七尼民陀罗山八斫迦罗山九宿慧山十须弥山。因大故果大。得法性五阴成就法身。故言大如须弥须弥以譬法性色。色大故般若大如山大神亦大。习果既圆报果亦满。法身非身故言大身恒河下第三信者福重。文有四阶一福多二处重三人尊四总结。恒河者是神名。此河长八千由旬广四千由旬。甚深象度皆没沙细如面水白如乳。初言三千不即恒河者自少至多。一恒河为本复数诸恒河。诸恒河之沙三重为数。舍宝多而福少持经少而福多者经之胜用。复次下明处重。一切世间总明处贵。天人修罗略明三善道。供养如塔此云方坟亦名灵庙。尊法身故敬塔为。重经故贵说经处。大品舍利起塔不及般若。何故说处如塔其义实尔。但世人敬塔故令说处如塔是人成就最上下明人尊。法妙人称理故宜然。希有之法是菩提成就即人可贵。如法华说最实事。即是第一义谛最上之法也。若是经典下总明。经所在之处即为有佛尊重弟子。人能弘法即人有法。以法成人即法有人。人法所处理当贵矣。非果而果即为有佛。非因而因即以尊重弟子谓普贤文殊等。初章竟当何名下第二辨名空无所有。夫条散难究本一易寻会。宗领旨宜正其名。文有四叚初名字空二受持福多三信受行深四佛述。初中有问答问名问持。遵修为奉任弘为持。在三成范请问其轨。佛告下答名答持。名冠题首义已备矣。境慧相从通名般若那要宜别归乎圣心。挈网举目诠合义从名正理显宜应修习。所以者何下释。夫名不虚设必当其实。金刚所拟物莫不碎。此慧所照法无不空即非般若即慧空也。境灭慧忘何相不尽。弘持之旨宜在于此。释中初无所有。二亦无所有而意异故。明不无所有此简性空义。一者性自是空二者破性说空。前有所无空后无所有空。大品云。诸法无所有如是有如是无所有。是事不知名为无明。有所无望前无所有望后。前三藏中说性义皆破。即属破性说空所摄。而此性义前时为缘为有者。今日悉无故言有所无而言无所有。望后明诸法无所有而复有不无所有义。即明如是有故。经云。不知名无明破性说性空。横论破病一切悉皆洗净。是尽亦尽是净亦净。竖论入道尽复有不尽义。此望道为论即此尽净为道。道有隔凡成圣之用。不同二头三手之无所有。复有不无所有义即是如是有义。若是前无所有一向无所有无所有亦复无所有。后明无所有即是不无所有。无所有名虽同其意有异。就前中初明如空次明如亦空。所以者何佛说般若则非般若。此是如空。既以性空为般若般若即非般若。性空如亦空如来有所说法不。境慧都空复何所说。说不说如不如二智皆空也。三千下是第二受持福多。不无所有。亦二初明微尘不无所有。二明身相不无所有。佛说微尘即非微尘是名微尘故是无所有如是有。大品云不知名无明今明了此。如是有即智慧也。散为微尘合成世界。世界无性故非假名即有。可以三十二相下二明身相不无所有。非相假名身相只以身为非身。不是遣除身别有非身也。亦非遣相别有无相。相无相不一不异。恒河沙身命下说经名已复一番校量。前寄舍财以明胜此寄舍身以辨多。依报易舍正报难损自易之难示化渐也。身命布施不免有生。弘持四句累灭道成闻说经深解下第三信受。行深有四初须菩提不闻。二余人能信。三善吉闻易四余人闻难深解。悲泣者嗟我晚悟兼悲未闻。愍念一切众生不知此法故悲。闻此法喜故悲深嗟小乘。呜呼自责故悲。不善观空名得慧眼。故尔前虽闻未闻如此降伏应住也。若复有人得闻下第二余人能信。实相者即是非相。若有少相即非实相。故以无相为实相。如来说此而人能信。岂非第一希有。而言生实相者此是无生生也。大品云。色不生故般若波罗蜜生。若解色无生即是无生观智起故般若生也。我今得闻下第三善吉信易。遇佛道成证圣方信何难。生值佛世亲得解悟。解故信之易也。若当来世下第四余人信难。生不值佛而能信如是无相之法斯岂不难。就文更为四。初明信者希有末法时信最可称美。二何以故下释信者由无我相能信此经。若才有少许我人等相即不信也。三所以者何下释无相意。我相即是非相无片许相可得故。其能不颠倒我人等从本以来无一相可得故。其体本来无相即为希有此是反释。四何以故离一切相即名诸佛。相尽解极即是为佛。能离有无毕竟常住。前云若见诸相非相即见如来。佛告下第四如来述成。若善吉自言容可不定。言无我人即是佛者佛今印定如汝所说。是故非虚一往怛愕名惊。心胆怯弱名怖深恶前事名畏。又惊是始行怖是二乘畏是外道。亦初闻经不惊次思义不怖后修行不畏。第一即般若诸度中最为第一。六从后数亦是第一。忍辱下第三明般若功用无所有。然诸法不出体名用。今皆无所有。文更为三。初力用无所有二能如是解仰参佛慧三明福多。就初中复五。一体无所有二功用三劝诫四引证五举譬。第一体者安耐名忍加毁为辱。既无我人谁加谁忍。故非忍为忍忍为非忍为般若体也。何以故下第二明般若用。以非忍为忍有大力用。初一世忍次多世忍。一歌利此云恶生。王何故忍即非忍引事为证。有苦能忍有忍无苦。既无我人割忍何生。若有人我必生忿恚而能恬然无我明矣。二又念五百世下即多世忍。菩萨知身无所有舍不足难。若有此身舍大难也。尸毗代鸽犹是三藏中事忍。前明有忍无苦今明无苦有乐。有慈悲故无恨无恨故即乐也。应离下第三劝诫。此是般若之中心故须精解。就文又二。一劝二诫文句相参。初劝发心次劝应住后劝修行。前诫离相后诫莫染心施。今即初劝离相。发心菩萨以相尽为极。故宜以忘怀而期心也。不应下即是前诫不应住色。心中离一切相不住声香等也。应生无所住心者即次劝应住般若。般若无相可缘心何所住。若心有住即为非住。住相即心动故非住也。是故下是后诫。令不住六尘行施。还举前宗会以成义理无住故。应忘心而施不住色无财物也。菩萨为利下即是后劝。令为利益而行施。施不望报利益必深也。如来说一切诸下第四引证。证中有三。第一举佛说为证。诸相皆无不见施者我说一切相即非相。不应住相生心行施。又说一切众生即非众生。受者亦无。不应化众生而受度也。如来是真语者下第二举能说人为证。真是不伪实是无虚。如必当理不诳非妄不异即始终恒一。圣言不谬故宜修行也。无实无虚下第三举所得法为证。寄实以非虚何实之可得耶。若疑我说法非者及能说人亦非者。今我所证得法只自如此心实作此证。不实不虚两舍。无生无灭等例然。故所说如所得非虚言也。菩萨心住法下第五举譬显住相非晓冥若夜游。前举有得为非后明无得为是。若住色香等行施不能得见诸法。若不住法行施如有目日光能得见色。无我三事即不住相也。慧见为目理境为日。万行显别为种种色。诸法本来空。菩萨观心复知其无所有而行布施者。即所见明了。此中先法后譬直说譬耳。当来之世下第二能。如是解即仰参佛说。当来若能受持即为佛悉知见。皆得成就无量无边功德。如来所见理用非谬明将来宜加勤修也。日三时舍下是第三福多。若能如是信者胜一日三时以恒河沙身之与命布施。分一日为三分故言初中后。施重又多功德弥旷。若于此经生心不逆。福胜前施。施即有限信心无极。何况书写持读诵说但言以信况复弘持也。以要言之下答上无所有。如是有不可思议事也。能知诸法本来无所有而以无所有为有。即不可思议。此文有十。第一经不可思议。理圆道极言即尽美。提宗表实约言之耳。物莫能测不思议也。算数不该不可称量也。荡然无涯无边耳。以要言之略此三句矣。文理平等无所有如是有。非般若为般若非身相为身相皆不思议也。第二为大乘者说为最上乘者说。此经在始便为大乘不为三乘。广运无涯谓之大乘。超三乘之胜谓之为最上。自非其人不谬说也。包含名大无胜最上。如来悉知见者人高道旷唯佛见之。荷担菩提千载不坠。由于人弘任持运行荷担义也。背荷肩担非身而身实相法身。非因非果即是两肩也。第三何以故下三乘不堪闻不信受乐。小是二乘着我是凡夫着见是外道。不能读诵以失释得也。第四在在处处下。地是无知法处故贵。虽复废言息义此处常有天龙围绕如帝王所居之处。人皆宗重天人供养此处是塔。恭敬作礼香花而散也。第五转障。本有重障习学般若先世重罪现在轻受。止为人轻贱过去重罪即得消灭。罪起由惑福生于解。福解既积宿殃灭矣。第六当得菩提即受记也。累灭解生菩提可登故佛悬记。第七我念过去下明能持经者所得福德胜佛往行。然灯佛时始获无生忍。今能无所得心而持经者得福胜我。阿僧祇佛所值八百四千万亿那由他佛。供养无空过者福德算数不及。心限即福少意旷则功德多也。第八于末世下明若。具说无所得持经所得福。时人闻则狂乱狐疑不信。解通人旷德必无涯。狂乱不信不足明道也。第九义不可思议万行渊深。义能谁测。以无所得无所有如是有无所有为义。以非般若为般若义故不可思议。第十果报不可思议菩提妙果岂有心之所议。如华严经明初发心便成正觉。与微尘法界众生为眷属。故知果报不可思议也。须菩提问下第二周重说。般若或为后来或是为钝根者。文亦三叚。初从问去至福德多明体。次佛可以色身见去至前偈辨名。后如来不以具足相故至寿者见明用并无所有。就体中辨于三假。初受假次名假后法假受是人。人即有名此人之与名有能成之法。三假是立法云何将三假释无所有。三假乃是立法亦是坏法。今欲明无所有故须将来释。若横论破病则实是一无所有。若竖论望道即无所有而不无所有。此三假亦然能成能破故。既言假有竟何所有。既言假有何为而不有。初约释尊因无所有。次约如来果无所有。后约菩萨化他明无所有。就因中更为三。初佛告下释因无所有。次然灯下引证。后如是。如是下佛述。释中又三。初明得次明失后双释得失。初明发心欲度众生起弘誓愿。我当灭度一切众生。实无众生得灭度者。此明菩萨知众生如有何可灭。若实有众生可度释论云菩萨得杀众生罪。又大品如化品佛语须菩提。诸法本有今无耶。此即责须菩提意。众生非本时有今时无何须慰喻始行菩萨。本自无生今何可灭也。二何以故下明失。若菩萨有我人等相即非菩萨。以失明得理可知矣。所以者何下双释得失。无发心者故知无我即行人空计我有惑。故非菩萨。于意云何下第二引证。证中有问答。初问中即引自昔得记之解以证前说。次今答中无有法得菩提。圣心难测义推可图。得记由于无相。无相之中即无所得也。如是如是下第三佛述如汝所说者。在因时已自无所有故。无所得菩提佛与我记。若见有法则乖菩提。何容得记无法得菩提。是故然灯佛受记无法则会理会理则向极故得记也。何以故下第二是明果无所有。有三义。初明如次证后譬。初即此是果人同如。同如故无所有。诸法性空理无乖异谓之为如。会如解极故名如来也。若有人言如来得菩提下。若有说如来得菩提者。此人俗间语非理言也。实无有法得菩提佛人也。菩提道也。既无人法谁得菩提。无实无虚者是非。既尽则会菩提。菩提之中不见是非。非实即无是非虚即无非也。是故如来说一切法下第二证如来无所有。如来在一切数故。凡夫违一切法为邪。圣人顺一切法为正。正即觉悟故皆佛法矣。譬如身长大下第三说非果而果。直举人身类上诸法。缘假故长大无性即非身。既非般若为般若者宁不以非身为身耶。若菩萨作是言下第三明菩萨化他无所有　初明化人次引佛说为证后明严土。初灭度众生不名菩萨。元无众生横见众生见。即乖道非菩萨也。何以故下释菩萨自无何有众生二是故佛说下引证无菩萨亦无众生。一切法都无我人也。三若菩萨言庄严佛土者。虚襟进道严土济物。济物之行方便慧也。解空无相谓之为慧。若言我能庄严国土众生可化见惑违道。何名菩萨也。何以故如来说非庄严是名庄严者。无存于化而土自严也。明应住义受假竟。若菩萨通达无我法者下。第二明名假无所有。文二初通达无我。既云一切法皆无所有。何名菩萨。今实无一切诸法。而今言菩萨但有其名。今明此名亦无所有故。何名此为菩萨。通达诸法无我等相故名菩萨。真菩萨故。所以能通达无我。二立真解。通达非伪真菩萨也。名假竟。五眼下第三明法假无所有。即上如来悉知见是人。其文又三。初明智慧。次明心。后明功德。法虽多不过功德智慧二种严。心为其体故备空也。此是初明智慧空。智慧虽多不过五眼。旧云肉眼见障内。天眼见障外。慧眼见真。法眼见俗。佛眼通知内外法。今言但是一智差别说之故有五耳。释论云。法眼知声闻缘觉等法故名法眼。是以知俗名法眼。然此中本明智慧空而直辨五眼。不言其空者意现于后。后既将智体心空。智宁不空。后明功德空。前智岂不空。以前明智有后明功德无。无有虽殊致不乖也。二恒河中去是明心无所有。以举恒沙等来。为欲校量取心明其空耳。如来说心皆为非心。只以非心为心此与前不异。五眼照。理无不周备。举色心收境尽矣。三世不可得说非心名心。何者以三世心无性可得故。可从缘而生心也。三若人满三千七宝布施下明功德无所有。明福有实。此即有量岂得多耶。以无福为福故多也。金玉无性故可积满三千。福德无实则可旷施而多心之无性。惑灭解生也。法假竟佛可以色身见下第二明经名。初名次行。名中有三初身相次说法后福多。色身者法身如空月。色身若水像。世间之色无实可睹。寻其本实即法身也。慧为万善之主施为众行之首。总为丈六金容别则众相。云娑婆随现则为相岂。可一方尽极。我当有所说法下第二明说法又二。初正对上名。道成应出说法化人。谬传毁圣名为谤佛。无法可说是名说法。故传说法之意向言无说。非杜默不语但无存而说。即说满天下无乖法理之过也。佛得菩提下第二明习应。有问答前应后习佛人也菩提道也。佛得道故说以示人。而言无法可说未审得道不。答中乃至无有少法可得。相尽虚通谓之菩提。菩提无相有何可得。寂灭无得道之至也。是法平等下结成菩提义也。人无贵贱法无好丑。平等菩提义也无我无人修一切善者即是修义。夫形端故影直声和则响顺。忘我人而修因必克无相之菩提。所言善法者人既不有善何得实耶。善是离恶之名法是轨持之义。三千世界中山王七宝下第三明福多。聚宝有尽妙解无穷。一偈法宝胜无量珍也。我当度众生下。菩提无得为果故以忘言而说。勿谓如来见众生可度。若见有众生则为我见何谓如来。但说假名我耳。非实我。而凡夫者闻说假名不达言旨以为实我。如来说非凡夫者。凡夫不实故可化而成佛也。可以三十二相观如来下二辨行就。文有五。一正观问二邪答三佛难四领解五佛举正义为释。初以问疑者谓众生是有可化而圣。法身不无可以妙相而期。故问之也。次邪答者。听者实尔用三十二相是如来也。三难。轮王是佛即以近事质之令其自解。四信解。不应。时情谓然我解不尔。五佛举正释者。五色焕眼而非形。八音盈耳而非声。偏谬为邪愚邪隔不见也。若作念下第三功用无所有。即是有不断灭义。有因有果一切宛然。即是般若方便用。论云得般若气分故有居空涉有之用。无复滞阂。此下去不说诸法断灭就文有二。初果次因。有义虽多不过因果。明果中二。初诫次明有。汝莫作念诫也。勿言诸法一向无所有。故谓不以具足相得菩提。不偏在色声故向言非。非不身相故复言是也。发阿耨下第二明因亦二。前诫后明有。莫起断灭。相尽寂灭故不有。道王十方非谓无。应毕而谢即不常。感至随现故不断体合中道轨物之式。限之一方岂不谬哉。若人满恒沙七宝下结般若成忍。就文复三。初明体道成忍之行无所有。次明体道证忍之人无所有。三明体道行忍之用无所有。以行成人人故有用备明无所有。就忍行中先校量。次若复有人下明成忍之行无所有。忘我则忍成超出故胜也。白佛下第二明体道证忍之人无所有。初明因人不受。后明果人不受。初明因中有问答。乃云不受亦不受。受其报种已名贪着。无存我人邪染何生次若来若去下明果人不受。若言从真如实际中来。善逝自及化人去至涅槃。皆是不解佛所说义。如来道荫之主。世界权应之宅。众生慈育之子。举此三事大旨彰矣。无来无去。故名如来。解极会如体无方所。缘至物见来无所从感毕为隐。亦何所去也。若三千碎尘下第三明体道行忍之用有四。初明碎尘用二碎界用。三碎合相用四碎诸见用。以微尘成世界有合。世界有合故起见。见者即失。谓有此四妄想得者非见为见。乃至非尘为尘为得。此四并是般若用。尘界等是依报。见是正报。合通色心。即此下是碎尘用。善男子并是大行。同华严中说佛说非微尘为微尘。次三千下明成世界用。微尘非实故可碎而为多。世界非有则可假借而成也。三一合相下破一合相。以非合为合故是不可说。只复言是合。此复非复是故假名说合。何为而非合以非合为合竟何有合。大经四句皆不可说。有因缘故亦可得说。今亦无合假说合耳。中论大品皆破合。当知无合今经中说合顺俗假说耳。凡夫贪着其事不知事即理。理无所有即是事无所有。何故非世界名世界。若是实有即应一性合不可分。假众生名一无合可得。假名无体不可实说。疑惑则凡夫贪着故计实。四佛说我见下明破诸见用。凡夫谓诸见决定是见。今佛说非见以本来无所有。诸见非实可改为正。众生虚假从凡至圣。正说意。从发菩提去第三流通叚。非止近益当时。亦乃远传千载。文为二初付嘱次奉行。付嘱又三初正付嘱次校量后方法。始终既毕故指宗劝人。凡欲发心成佛净国土化众生。当如上所说理而生知见也。如是信解者理深未明推信为解耳。不生法相但是虚假非实法也。如来说非法相是名法相。相穷理尽明。其唯如来说言非实故应从信矣。二阿僧祇七宝下校量流通。七宝有竭四句无穷。明以无所得心指经一偈。其福胜彼有所得施。三云何为人下后方法。初标次释。释中有止有观。弘通此经若为方法。须不取法相须如真如。上如是智下如是境。心境符合故得不动。不动空有等法。何以故下一偈明观。观诸法梦幻等。而为人说句偈有真实。及有此假有也。大品十喻一幻二焰三水月四虚空五响六干城七梦八影九镜像十化。此中举六。论本明九然流通方法不出止观故今略举。即止为观故见一切皆空梦幻。即观而止故一切梦等悉如如也。佛说是经下第二奉行流通。闻法欢喜既能信受复如说行说人如法。受者得解。般若真正之法非是有所得断常等法。三事具足说人是佛。一切智人所说之法即中道正法般若无所得法。受者最上乘人久种三多。持戒修福三德斯备。闻不惊怖即能信解。是故欢喜。道蕴圣心待孚则彰。宿感冥构不谋而集。同听齐悟法喜荡心。服玩遵式永崇不朽者矣


金刚般若经疏论纂要(并序上)

    No. 1701 [cf. No. 235]

金刚般若经疏论纂要(并序上)

        京大兴福寺沙门宗密述

        长水沙门子璇治定

镜心本净像色元空。梦识无初物境成有。由是惑业袭习报应纶轮。尘沙劫波莫之遏绝。故我满净觉者。现相人中先说生灭因缘。令悟苦集灭道。既除我执未达法空。欲尽病根方谈般若。心境齐泯即是真心。垢净双亡一切清净。三千瑞焕十六会。彰今之所传即第九分。句偈隐略旨趣深微。慧彻三空檀含万行。住一十八处密示阶差。断二十七疑潜通血脉。不先遣遣曷契如如。故虽策修始终无相。由斯教理皆密行果俱玄。致使口讽牛毛心通麟角。或配入名相着事乖宗。或但云一真望源迷泒。其余胸谈臆注不足论矣。河沙珍宝三时身命喻所不及。岂徒然哉。且天亲无著师补处尊。后学何疑或添或弃。故今所述不攻异端。疏是论文。乳非城内纂要名意及经题目。次下即释无烦预云

  稽首牟尼大觉尊　　能开般若三空句
  发起流通诸上士　　冥资所述契群机

将释此经。未入文前悬叙义门。略开四段。第一辩教起因缘。第二明经宗体。第三分别处会。第四释通文义。初中二。初总论诸教。谓酬因酬请显理度生也。若据佛本意。则唯为一大事因缘故出现于世。欲令众生开佛知见等。后别显此经五。一为对治我法二执故。由此二执起烦恼所知二障。由烦恼障障心心不解脱。造业受生轮转五道。由所知障障慧慧不解脱。不了自心。不达诸法性相纵出三界亦滞二乘。不得成佛故名障也。二执若除二障随断。为除二执故说此经。二为遮断种现二疑故。遮未起种子之疑。断现起现行之疑。即经中答所问已。便蹑迹节节断疑。乃至经终二十七段。三为转灭轻重二业故。转重业令轻受。灭轻业令不受。因为显示福慧二因故。佛成正觉未说般若之前。众生由无妙慧。施等住相皆成有漏或滞二乘。故谈般若显示妙慧。为法身因。五度为应身因。若无般若。则施等五非波罗蜜。不名佛因。故须福慧二严方成两足尊矣。五为发明真应二果故。未闻般若之前。但言色相是佛。不知应化唯真之影。不如实见真身应身。故此发明二果。令知由前二因证得。第二明经宗体二。初宗。统论佛教因缘为宗。别显此经。则实相般若观照般若不一不二。以为其宗。以即理之智观照诸相故。如金刚能断一切。即智之理是为实相故。如金刚坚牢难坏。万行之中一一不得昧此。是故合之以为经宗二体。文字般若即是经体。文字即含声名句文。文字性空即是般若。无别文字之体故。皆含摄理无不尽统为教体。第三分别处会二。初总明。佛说大部处会六百卷文。四处十六会说。一王舍城鹫峰山七会。山中四会。山顶三会。二给孤独园七会。三他化天宫摩尼宝藏殿一会。四王舍城竹林园白鹭池侧一会。此经则第二处第九会。第五百七十七卷。后别明传译。此卷时主前后六译。一后秦罗什。二后魏菩提流支。三陈朝真谛。四隋朝笈多。五唐初玄奘。六大周义净。上六人皆三藏。今所传者即罗什。弘始四年于长安草堂寺所译。天竺有无著菩萨。入日光定上升兜率。亲诣弥勒禀受八十行偈。又将此偈转授天亲。天亲作长行解释成三卷。论约断疑执以释。无著又造两卷论。约显行位以释。今科经唯约天亲释义。即兼无著。亦傍求余论。采集诸疏题云纂要。其在兹焉。第四释通文义二。初解题目

金刚般若波罗蜜经　金刚者。梵云跋折罗。力士所执之杵是此宝也。金中最刚故名金刚。帝释有之。薄福者难见。极坚极利喻般若焉。无物可能坏之。而能碎坏万物。涅槃经云。譬如金刚无能坏者。而能碎坏一切诸物。无著云。金刚难坏。又云。金刚能断又云。金刚者细牢故。细者智因故。牢者不可坏故。皆以坚喻般若体。利喻般若用。又真谛记说六种金刚。一青色能消灾厄。喻般若能除业障。二黄色随人所须。喻无漏功德。三赤色对日出火。慧对本觉出无生智火。四白色能清浊水。般若能清疑浊。五空色令人空中行坐。慧破法执住真空理。六碧色能消诸毒。慧除三毒。傍兼可矣。非坚利之本喻。般若正翻云慧。即照五蕴空相应本觉之慧是也。若约学者从浅至深言之。则摄闻思修三慧总为般若。故无著云。能断者。般若波罗蜜中闻思修所断。如金刚断处而断故。又云。细者智因故者。智因即慧也。依智度论。因位名般若果位名智。则闻思修皆名为细。细妙之慧佛智之因矣。般若能断故在因位。佛果无断转受智名。若依大品经。若字通智慧二义。故智与慧名义少殊体性无别。波罗蜜者。此云彼岸到。应云到彼岸。谓离生死此岸。度烦恼中流。到涅槃彼岸涅槃此云圆寂亦云灭度。一切众生即寂灭相。不复更灭。但以迷倒妄见生死。名在此岸。若悟生死本空。元来圆寂名到彼岸。若兼般若回文。应云到彼岸慧经者梵音修多罗。义翻为契经。契者诠表义理契合人心。即契理契机也。经者。佛地论云。能贯能摄故名为经。以佛圣教贯穿所应说义摄持所化生故。后释经文准常三分。初序分。二正宗分。三流通分。初文二。初证信序二发起序○今初证信序

如是我闻。一时佛在舍卫国祇树给孤独园。与大比丘众千二百五十人俱　释此分三。一明建立之因。则佛临灭度。阿难请问四事。佛一一答。我灭度后。一依四念处住。二以戒为师。三默摈恶性比丘。四一切经初。皆云如是我闻一时佛在某处与某众若干等。二明建立之意。意有三焉。一断疑故。谓结集时阿难升座。欲宣佛法。感得自身相好如佛。众起三疑。一疑佛重起说法。二疑他方佛来。三疑阿难成佛。故说此言三疑顿断。二息诤故。若不推从佛闻。言自制作则诤论起。三异邪故。不同外道经初云阿忧等。三正释文义。具六成就。谓信闻时主处众。六缘不具教则不兴。必须具六故云成就。一信若兼我闻合释。则指法之辞也。如是之法我从佛闻。单释如是者。智度论云。信成就也。佛法大海信为能入智为能度。信者言是事如是。不信者言是事不如是。又圣人说法但为显如。唯如为是故称如是。又有无不二为如如。非有无为是。二闻我即阿难五蕴假者。闻谓耳根发识。废别从总故云我闻。阿难所不闻二十年前之经。有云如来重说。有云得深三昧总领。若推本而言。即阿难是大权菩萨。何法不通三时师资合会说听究竟。故言一时。诸方时分延促不同。故但言一。又说法领法之时。心境泯理智融。凡圣如始本会。此诸二法皆一之时。四主。具云佛陀。此云觉者。起信云。所言觉义者。谓心体离念。离念相者等虚空界。即是如来平等法身。则以无念名之为佛。然觉有三义。一自觉。觉知自心本无生灭。二觉他。觉一切法无不是如。三觉满二觉理圆称之为满。故知有念则不名觉。起信云。一切众生不名为觉。以无始来念念相续未曾离念。又云。若有众生能观无念者。则为向佛智故。五处。舍卫此云闻物。谓具足欲尘财宝多闻解脱等。远闻诸国故。义净译云名称大城。祇树等者。即只陀太子所施之树。给孤长者所买之园。只陀此云战胜。波斯匿王太子也。生时王与外国战胜。因以为名。梵语须达此云善施。给孤独即是善施也。又亦常行施故。西国呼寺。为僧伽蓝此云众园。六众。与者。并也。及也。大者名高德着。比丘梵语此含三义。故存梵不译。一怖魔。二乞士。三净戒。众者理和事和。千二百五十者。佛初成道度憍陈如等五人。次度迦叶三兄弟。兼徒总一千。次度舍利弗目莲。各兼徒一百。次度耶舍长者子等五十人。经举大数故减五人。此常随众故偏列数。非无余众未隐显耳。俱者一时一处。二发起序者。谓乞食威仪离于邪命是为持戒。戒能资定定能发慧。故以戒定发起般若正宗△文二初戒

尔时世尊食时着衣持钵入舍卫大城乞食于其城中次第乞已还至本处　分七节释。一化主。成实论说具上九号。为物钦重故曰世尊。天上人间共所尊故。二化时。食时辰时。当日初分求乞易得。不恼自他。乞已归园正当巳时。如常斋法。三化仪。着僧伽梨衣。持四天王所献钵。四化处。园在城东南五六里。自外之内为入。处广人多曰大。五化事。佛为欲显头陀功德。令放逸者惭愧。以同事摄故自乞食。璎珞女经说。化佛身如全段金刚。无生熟二藏。今所乞者利益他故。故净名云。为不食故应受彼食。六化等。一由内证平等理。外不见贫富相。二心离贪慢慈。无偏利。三表威德。不惧恶象沽酒淫女等家。四息凡夫猜嫌。五破二乘分别。七化终。然已字义属下句文连上句。饭食字义属上句文连下句。若广其文。令当句中备者。应云次第乞已还至本处饭食饭食讫收衣钵。佛若不食他福不满。宝云经说。随所乞得分为四分。一拟与同梵行。二拟施贫病乞人。三水陆众生。四自食。十二头陀经唯说三分除梵行。二定

饭食讫收衣钵。洗足已敷座而坐　分三节释。一并资缘。将欲入定须息攀缘。衣钵不收心有劳虑。故佛示现为后轨也。即收大衣着七条。二净身业。阿含经说。佛行离地四指莲华承足。今示现洗者。顺世表法为后轨也。三正入定。敷座坐禅者。由身端故。心离沉掉故。魏译云。如常敷座结加趺坐。端身而住正念不动。唐译云。端身正愿住对面念。无著云。显示唯寂者。于此能觉能说故。然大圣现迹必有所表。表本觉之佛在五蕴之都。觉魔军本空名为战胜。照心识具德即是给孤。求法养神名乞士众。觉心既发宁弃尘劳。将欲遍观遂入识藏心心数法。次第思惟即妄而真。皆得法喜。法喜无体融合觉心。思惟假缘亡缘可符真性。观照是迹拂迹返本还源。返本还源法空心寂。心寂真体般若朗然。欲谈般若正宗如是示现发起。资圣云。夫身有二。一伪二真。五蕴伪体假衣食以生育。法身无相因般若以照成。群生保伪遗真。诸佛养真弃伪。群生既迷真而取伪。我乃假伪迹而引真。故托乞食之缘。将施法喜之化。故涅槃经云。汝诸比丘虽行乞食。初未曾乞大乘法食。第二正宗分。二门分别。初约无著七种义句以悬判。后依天亲问答断疑以科释。初中七义句者。一种性不断。谓护念付嘱。二发起行相。谓由请赞许。三行所住处。谓十八住。从佛正说直至经终。是无相行所住处矣。四对治。谓一一住处。皆具邪行共见正行二种对治。五不失。谓由对治离增减二边。不失中道。六地位。谓由不失中道。成贤圣位。信行地净心地如来地。七立名。谓由前六智慧坚利位地阔狭。故名金刚。后四但约第三句中十八住说。无别经文。十八住处者。一发心住。经云。应如是降伏其心所有一切等。二波罗蜜相应行住。不住色布施等。三欲得色身住。可以身相等。四欲得法身住。法身有二。一言说法身。颇有众生等因言显理故。二证得法身。复有二。一智相。如来得阿耨等。二福相若人满三千等。五于修道得胜中无慢住。须陀洹等。从此至十六住。如次对治十二种障。意明欲求色身法身须离是障。障尽故入十七证道住。今当对治第一慢障。六不离佛世时住。昔在然灯等离第二少闻障。不离佛世则具多闻。七愿净佛土住。菩萨庄严佛土不等。离小攀缘作念修道障。缘形相土则小。无缘则大契法界故。八成熟众生住。人身如须弥等。离舍众生障。若见大小不能济物。九远离随顺外论散乱住。如恒河中所有沙等。离乐随外论散乱障。恒沙宝施不及持经。如何外学不修正法。十色及众生身抟取中观破相应行住。三千世界所有微尘等。离破影像相中无巧便障。既离散乱与定相应。以细末不念二种方便。破粗至细泯细至空。则除影像之相想。十一供养给侍如来住。可以三十二相见如来不等。离福资粮不具障。不以相见常见法身。名为给侍福无边矣。十二远离利养及疲乏热恼。故不起精进及退失住。恒河沙身命布施等。离乐味懈怠利养障。恒沙命施犹劣受持。岂为一身耽着利养。身疲心恼而懈怠耶。十三忍苦住。忍波罗蜜割截身等。离不能忍苦障。无我等相累苦能忍。十四离寂静味住。当来之世若有人能于此经受持读诵等。离智资粮不具障。日三时舍身。一一沙数不及信经。如何唯专禅定耽寂静味。阙于智慧而不持说。十五于证道时远离喜动住。云何住降等。离十一不自摄障。我能住降心生喜动。动则不能自摄。十六求佛教受住。于然灯佛所有法得菩提不等。离十二无教授障。欲入初地须佛教授。故约遇佛得无所得。而证道矣。十七证道住。人身长大等。摄种性智证遍行真如成法报身故长大矣。十八上求佛地住。于中复有六种具足一国土净具足。我当庄严佛土等。此教二地已上诸大菩萨。二无上见智净具足。有肉眼不等。此下皆唯佛果故云无上。无上之言贯通下四三福自在具足。若人满三千界七宝等。四身具足。佛可以具足色身等。五语具足。汝勿谓如来说法等。六心具足。佛得阿耨菩提为无所得耶。乃至应作如是观。又十八住略为八种。亦得满足。一摄住处。二波罗蜜净住处。一二次配。三欲住处摄三及四。四离障碍住处。即前十二障也。从五至十六。五净心住处。六究竟住处。上二次配十七十八。七广大住处。八甚深住处。上二各摄十八住处。一一住中皆深皆广。十八住文配位地者。第一十住。第二十行中前六。三第七行。四后三行。五至十四如次配十回向。十五暖顶。十六忍世第一。十七初地十八从二地乃至佛地。第二依天亲问答断疑以科释。总分四段△初善现申请。二初整仪赞佛

时长老须菩提。在大众中即从座起。偏袒右肩右膝着地。合掌恭敬而白佛言。希有世尊。如来善护念诸菩萨。善付嘱诸菩萨　长老者。德长年老。唐译云具寿。寿即是命。魏译云慧命。以慧为命。须菩提有三义译。谓善吉善现空生。生时室空。解空之善瑞现矣。相师占云。唯善唯吉。从座起下。皆整理威仪修敬之相。希有者。世所无故。如来者。从如而来。论云善护念者。依根熟菩萨说。谓与智慧力令成就佛法。与教化力令摄受众生。善付嘱者。依根未熟菩萨说。惧其退失。付授智者。付者将小付大。嘱者嘱大化小。菩提萨埵。此云觉有情。三释。一约境所求所度。二约心有觉悟之智。余情虑之识。三约能所。所求能求三皆如次配觉及有情。二正发问端

世尊善男子善女人。发阿耨多罗三藐三菩提心。应云何住。云何降伏其心　典分二。初释当机。华严云。忘失菩提心修诸善业。魔所摄持。阿耨多罗三藐三菩提。此云无上正遍正觉。谓正智遍智觉知真俗不偏不邪。二释正问。魏译云。应云何住。云何修行。云何降伏其心。意云若人发菩提心已。住何境界修何行业。妄心若起云何降伏。故佛令安住四心修六度行。于中降心不令着相。秦译略修行者意云。住道降心即是修行。谓四心六度皆名住修降伏故。无著云。住谓欲愿。修行谓相应等持。降伏谓彼心若散制令还住。又十八住中。一一皆以住修降伏释之。故知义虽有三而行是一○二如来赞许

佛言善哉善哉。须菩提如汝所说。如来善护念诸菩萨。善付嘱诸菩萨。汝今谛听当为汝说。善男子善女人发阿耨多罗三藐三菩提心。应如是住如是降伏其心　曲分三。一印赞所赞。重言善哉赞美之极。护付能令佛种不断。是事必然。故印赞言如汝所说○二敕听许说。无以生灭心行听实相法。智论偈云。听者端视如渴饮一心入于语义中。踊跃闻法心悲喜。如是之人可为说。三标劝将陈。我当为汝如是如是委细而说。三善现伫闻

唯然世尊愿乐欲闻　唯者顺从之辞。礼对曰唯。野对曰阿。十地经云。如渴思冷水。如饥思美食。如病思良药。如众蜂依蜜。我等亦如是。愿闻甘露法△四如来正说二。一正答所问二。初举总标别以牒问

佛告须菩提。诸菩萨摩诃萨。应如是降伏其心　此以降伏为总。住修为别也。谓住修之中皆有降伏。经意在此故唯标降伏有科。此所标云。举后摄初者。乃令经文极不稳畅。理例颠倒自古言教秪有以初摄后。未闻以后摄初。况详经文无别答降伏之处。则知降伏在住修中。皆令离相是答。降伏问也不别答者。此经宗于离相。离相正是降心。本意欲明降心。须约住修而显。住修降心本不相离故。无著十八住。皆有住修降心。△二约别显总以答问二。一答安住降心问四初广大心

所有一切众生之类。若卵生若胎生。若湿生若化生。若有色若无色。若有想若无想。若非有想非无想　文二。初句标三界普度故。若卵下二列三。一受生差别。天狱化生鬼通胎化人畜各四。诸余微细水陆地空。不可具分品类。卵劣在初者二释。一约境。具缘多者为首。二约心从本至末为次。二依止差别。有色四禅无色四空。三境界差别。功德施云。有想则空识二处。无想则无所有处。非等则有顶○○二第一心

我皆令入无余涅槃。而灭度之　即无住处涅槃。不共二乘故云第一。无著云。何故愿此不可得义生所摄故。又云。卵湿无想有顶则不能。云何普入。有三因缘。一难处生者待时故。二非难处生未成熟者。成熟之故。三已成熟者解脱之。故○○三常心

如是灭度无量无数无边众生。实无众生得灭度者　一性空故。二同体故。论云。自身灭度无异众生。三本寂故。四无念故。五法界故。四不倒心

何以故。须菩提。若菩萨有我相人相众生相寿者相。即非菩萨　论云。远离依止身见众生等相故。无著云。已断我见得自行平等相故。信解自他平等。显示降伏心中。摄散时众生想亦不转。如彼尔炎。△二答修行降心问五○初总标

复次须菩提。菩萨于法应无所住行于布施　于法者。统标诸法。应无下正明修行。问菩萨万行何唯说一。答万行不出六度。六度总名布施。故偈云。檀义摄于六。资生无畏法。此中一二三。是名修行住。无著云。若无精进疲倦故不能说法。若无禅定。即贪信敬利养染心。说法。若无智慧便颠倒说。法二别释

所谓。不住色布施。不住声香味触法布施　本论但指三事。谓自身报恩果报。偈云自身及报恩。果报斯不着。护存己不施。防求于异事。三总结

须菩提。菩萨应如是布施。不住于相　前但指三事。今则心境空有微细尽袪故。偈云。远离取相心。论云。不见施物。受者施者。无著云不住相想。有人。将此结文。为答降伏问非也。前标次释次结。皆云无住。都是修行中降伏之义。何忽偏判配结之文为答别问○四显益

何以故。若菩萨不住相布施。其福德不可思量。须菩提。于意云何。东方虚空可思量不。不也世尊。须菩提。南西北方四维上下虚空可思量不。不也世尊。须菩提。菩萨无住相布施福德。亦复如是不可思量　初句征者。论云。若离施等相想。云何成就施福。若菩萨下释。于中三。初法说。为疑无福。不可思以断之。东方下喻说可知。菩萨无住相下法合。虚空者无者。云犹如虚空。有三因缘。一遍一切处。谓住不住相中福生故。二宽广高大殊胜故。三无尽究竟不穷故。五结劝

须菩提。菩萨但应如所教住　二蹑迹断疑。论云。自此已下示现断生疑心。于中文分二十七段。一断求佛行施住相疑。疑云。为求佛果行施。即是住所求佛相。云何无住。又不住相为因。岂感色相之果。因果不类故。断之文四。初举疑因以问

须菩提。于意云何。可以身相见如来不　本秪因以相为佛。故对前不住相起疑。佛举疑起之因。问答欲令除断○二防相得以酬

不也。世尊。不可以身相得见如来　遮防疑者。欲以相求令得见佛。故答云。不可以相得见。论云。为防彼相成就得如来身。三释体异有为

何以故。如来所说身相即非身相　相是有为生住异灭。佛体异此故非身相。偈云。三相异体故者。佛体异于有为三相也。住异二相同是现在故合为一。若细分即四。故唯识云。生表此法先非有。灭表此法后是无。异表此法非凝然。住表此法暂有用。四印佛身无相

佛告须菩提。凡所有相皆是虚妄。若见诸相非相即见如来　非但佛身无相但是一切凡圣依正。有为之相尽是虚妄。以从妄念所变现故。妄念本空所变何实。故起信云。一切境界唯依妄念。而有差别若离心念即无一切境界之相。若见诸相等者。遮离色观空也。恐闻相是虚妄。又别求无相佛身。故云相即非相便是如来。不唯佛化身相是如来。所见一切相相皆无相即如来也。故起信云。所言觉义者。谓心体离念。离念相者等虚空界。即是如来平等法身。肇云。行合解通则为见佛。偈云。离彼是如来者。离彼三相是法身如来也。无著则于色身但离遍计。不执色相即真色身。故彼论云。此为显示如来色身。又此当第三欲得色身住处。二断因果俱深无信疑。论云。无住行施因深也。无相见佛果深也。未来恶世必不生。信空说何益。断之文四。初约无信以呈疑

须菩提白佛言。世尊。颇有众生。得闻如是言说章句生实信不　魏云。颇有众生于未来世云云。今略此句者。影在后五百岁也。句诠差别章者解句。实信者。大品云。于一切法不信是信般若。二呵疑词以显信

佛告须菩提。莫作是说。如来灭后后五百岁。有持戒修福者。于此章句能生信心。以此为实　后五百岁者。大集云。初五百岁解脱牢固。第二五百岁禅定牢固。三多闻。四塔寺。五斗诤。皆如初二句例本疑恶世无信故举恶世以断疑。持戒修福者戒定也。以此为实者。正解无倒。无著云。增上戒等三学。显示修行少欲等功德。戒出三涂定出六欲慧出三界。三明能信之所以二。初明历事善友积集信因

当知。是人不于一佛二佛三四五佛而种善根。已于无量千万佛所。种诸善根闻是章句。乃至一念生净信者　无著云。显示集因于多佛所。明久事善友则缘胜也。种诸善根。明久伏三毒则因胜也。二明善友所摄成就信德二。初明摄受得福显福德门

须菩提。如来悉知悉见是诸众生。得如是无量福德　无著云。谓于一切行住所作中知其心。四蕴见其依止色身故。此等显示善友所摄。论云。若不说见。或谓如来以比智知。若不说知。或谓如来以肉眼见。故须二语。得福德者。魏云。生如是福德取如是福德。论云。生者能生因。取者熏修自体果义。无著云。生者福正起时现行。取者即彼灭时摄持种子。此云得者。生取二义不离于得。得之一字生取俱摄。二明摄受所以显智慧门。由无二执故得摄受。△文二。初正明已断粗执

何以故。是诸众生。无复我相人相众生相寿者相。无法相亦无非法相　初征信者。以何义故。得如来悉知悉见。后释二。一无我执。执取自体为我。计我展转趣于余趣为人。计我盛衰苦乐种种变异相续为众生。计我一报命根不断而住为寿者。二无法执。论云。无法相者。能取所取一切法无。亦无非法相者。无我真空实有。然离二执正是得佛知见。成就净信之本善根福德。却是相兼故。论云。有智慧便足。何故。复说持戒功德。为示现实相差别义故。亦有持戒功德。依信心恭敬能生实相故。不但说般若二因。显未除细执

何以故。是诸众生。若心取相则为着我人众生寿者。若取法相即着我人众生寿者。何以故。若取非法相即着我人众生寿者　若心取下。总明二相总解取法非法。尽名相也。亦是建立取相。则我等相便生立义宗也。若取法下。别明二相。论云。但有无明使无现行粗烦恼。示无我见故。无著云。但取法及非法相转。非我等想。以我等想及依止不转。中有征者。取法但为法相。何故便着我等。释云。取非法亦着我等。何况取法以后释前也。四示中道之玄门

是故。不应取法不应取非法。以是义故。如来常说汝等比丘。知我说法如筏喻者。法尚应舍何况非法　初正结归中后引说。以证筏喻者。假言显义。不应如言执义。不执即为不取。非全弃也。偈云。彼不住随顺于法中证智。论释云。不住者得证智。舍教如到彼岸。随顺者。随顺彼证智之教法。如未到岸。无著云。法尚应舍者。实相生故。何况非法者。理不应故。三断无相。云何得说疑。论云。向说不可以相见佛。佛非有为。云何释迦得阿耨菩提。云何说法。断之文二。初问答断疑四。初举疑因以问

须菩提。于意云何。如来得阿耨多罗三藐三菩提耶。如来有所说法耶　佛问得不。意显不得故。无著云。显示翻于正觉取故。二顺实理以酬

须菩提言。如我解佛所说义。无有定法名阿耨多罗三藐三菩提。亦无有定法如来可说　偈云。应化非真佛。亦非说法者。三释无定法之言

何以故。如来所说法。皆不可取不可说。非法非非法　无著云。不可取者。谓正闻时。不可说者。谓正说时。非法者。分别性故。非非法者。法无我理故。论云。彼法非法非非法。依真如义说。非法者。一切法无体相故。非非法者。彼真如无我实相有故。何故。唯言说不言证。有言。说者。即成证义故。若不证者。则不能说。四释无取说之所以

所以者何。一切贤圣皆以无为法而有差别　魏云。一切圣人皆以无为法得名。论意云。圣人但依真如清净得名。非别得法故无取说。而有差别者。论云。真如具足清净分清净。无著云。无为者无分别义故。是故菩萨有学得名。如来无学得名。初无为者。折伏散乱时显了故。后无为者。唯第一义者无上觉故。三乘贤圣皆修证无为。故通说为差别。二校量显胜四。初举劣福以问

须菩提。于意云何。若人满三千大千世界七宝以用布施。是人所得福德宁为多不　俱舍偈云。四大洲日月苏迷卢欲天梵世各一千。名一小千界。此小千千倍。说名一中千。此千倍大千。皆同一成坏。七宝者。金银琉璃珊瑚码瑙赤真珠颇梨二释福多以酬

须菩提言。甚多世尊。何以故。是福德即非福德性。是故如来说福德多　无著云。是福德者标牒。即非者约胜义空。是故者约世俗有。三判经福超过

若复有人。于此经中受持乃至四句偈等。为他人说其福胜彼　偈云。受持法及说。不空于福德。福不趣菩提。二能趣菩提。四句者。但于四句诠义。究竟即成四句偈。如凡所有相皆是虚妄。若见诸相非相。即见如来。此最妙也。然但义见四句。持说即趣菩提。文或增减不必唯四。义若阙者则互成谤。四释超过所以二。初正释

何以故。须菩提。一切诸佛及诸佛阿耨多罗三藐三菩提法。皆从此经出　诸佛菩提法者。论云。名为法身。于彼法身此二能作了因。一切诸佛者即报化身。论云。于此能为生因。二转释

须菩提。所谓佛法者即非佛法　第一义中。无有佛法从经出也。四断声闻得果是取疑。论云。向说圣人无为法不可取说。云何声闻各取自果。如证而说。断之文四。初入流果

须菩提。于意云何。须陀洹能作是念。我得须陀洹果不。须菩提言。不也世尊。何以故。须陀洹名为入流而无所入。不入色声香味触法是。名须陀洹　须陀洹。此云入流。入圣人流故。亦云预流。预圣人流故。秪由不入六尘名入圣流。不是别有所入故。论云。圣人得果不取一法。不取六尘境界。故名逆流。乃至罗汉不取一法。以是义故。名阿罗汉。然非不取无为自果。但于证时离取我等烦恼。是故无如是心。我能得果。若起如是心我能得果。即为着我等故。知得果是不取义。何得疑云是取。二一来果

须菩提。于意云何。斯陀含能作是念。我得斯陀含果不。须菩提言。不也世尊。何以故。斯陀含名一往来。而实无往来。是名斯陀含　斯陀含。此云一来。断欲界六品修惑。从此命终。一往天上一来人间。便得阿罗汉果。故名一来。而实无来者。已悟无我谁能往来。三不来果

须菩提。于意云何。阿那含能作是念。我得阿那含果不。须菩提言。不也世尊。何以故。阿那含名为不来。而实无不来。是故名阿那含　阿那含。此云不来。亦云不还。断欲界九品修惑尽。命终一往天上。更不还来下界。故云不来。而实无不来义。同前释。四不生果。阿罗汉。此释有三。一无贼。三界见修烦恼尽故。二不生。不受后有故。三应供。应受人天广大供养故。文三。初举所得以问

须菩提。于意云何。阿罗汉能作是念。我得阿罗汉道不　二明无取以答

须菩提言。不也世尊。何以故。实无有法名阿罗汉。世尊。若阿罗汉作是念。我得阿罗汉道。即为着我人众生寿者　三引已证令信。三初明佛先印

世尊。佛说我得无诤三昧。人中最为第一。是第一离欲阿罗汉　无诤者。不恼众生。能令众生不起烦恼。故佛赞之。十弟子中善现第一离欲者。三界烦恼但有贪心尽名为欲。非唯欲界二彰已不取

我不作是念。我是离欲阿罗汉　三却释佛意

世尊。我若作是念。我得阿罗汉道。世尊。则不说须菩提是乐阿兰那行者。以须菩提实无所行。而名须菩提是乐阿兰那行　论云。离二种障。一烦恼障得阿罗汉故离。二三昧障得无诤故离。故无所行。阿兰那者。此云寂静。五断释迦然灯取说疑。论云。释迦昔于然灯佛所受法。彼佛为此佛说法。云何言不可取不可说

佛告须菩提。于意云何。如来昔在然灯佛所。于法有所得不。不也世尊。如来在然灯佛所。于法实无所得　于法实无所得者。然灯佛说。说是语言。释迦所闻唯闻语言。语言非实智证法故。论云。释迦于然灯所。言语所说不取证法。以是义故。显彼证智不可说不可取。六断严土违于不取疑。论云。若法不可取。云何诸菩萨取庄严净土。云何自受法王身。断之文三。初举取相庄严问

须菩提。于意云何。菩萨庄严佛土不　佛意欲明法性真土。故问取形相庄严土不。二释离相庄严答

不也。世尊。何以故。庄严佛土者。即非庄严是名庄严　偈云。智习唯识通。如是取净土。非形第一体。非严庄严意。论释云。诸佛无有庄严国土事。唯真实智慧习识通达故。不可取庄严有二。一形相。二第一义相。非严者无形相故。庄严意者。即是第一庄严。以一切功德成就庄严故。三依净心庄严劝

是故须菩提。诸菩萨摩诃萨。应如是生清净心。不应住色生心。不应住声香味触法生心。应无所住而生其心　论云。若人分别佛土。是有为形相。而言我成就者。彼住于色等境中。为遮此故。故云应如是生清净心。不应住色等也。而生其心者。则是正智。此是真心。若都无心便同空见。七断受得报身有取疑。疑意如前。断之文二。初问答断疑

须菩提。譬如有人身如须弥山王。于意云何。是身为大不。须菩提言。甚大世尊。何以故。佛说非身是名大身　论云。如须弥山王势力高远故名为大。而不取我是山王。以无分别故。报佛亦如是。以得无上法王体故名大。而不取我是法王。以无分别故。故偈云。如山王无取。受报亦复然。非身名身者。非有漏有为身。是无漏无为身。故偈云。远离于诸漏。及有为法故。论云。若如是即无有物。若如是即名有物。以唯有清净身故。以远离有为法故。以是义故。实有我体。以不依他缘住故。二校量显胜二。一约外财挍量广显经胜二。一校量胜劣三。初约多河以辨沙

须菩提。如恒河中所有沙数。如是沙等恒河。于意云何。是诸恒河沙宁为多不。须菩提言。甚多世尊。但诸恒河尚多无数。何况其沙　恒河者。从阿耨池东面流出。周四十里沙细如面。金沙混流。佛多近此说法。故取为喻。二约多沙以彰福

须菩提。我今实言告汝。若有善男子善女人。以七宝满尔所恒沙河数三千大千世界。以用布施。得福多不。须菩提言。甚多世尊　论云。前已说喻何故复说。偈云。说多义差别亦成胜校量。后福过于前故重说胜喻。何故不先说此喻。为渐化众生令信上妙义故。又前未显以何等胜功德能得菩提故。三约多福以显胜

佛告须菩提。若善男子善女人。于此经中乃至受持四句偈等为他人说。而此福德胜前福德　施感生死经趣菩提大意同前。二释胜所以五。一尊处叹人胜三。初明处可敬

复次须菩提。随说是经乃至四句偈等。当知此处一切世间天人阿修罗。皆应供养如佛塔庙　大般若说。天帝不在。诸天若来但见空座。尽皆作礼供养而去。窣堵波。此云高显。塔者边国讹语。庙藐也。于塔中安佛形藐。二显人获益

何况有人尽能受持读诵。须菩提。当知是人成就最上第一希有之法　前四句犹胜。况此尽能受持。故最上等也。三显处有佛

若是经典所在之处。则为有佛。若尊重弟子　经显如来法身依法则有报化。又一切贤圣皆以无为得名。经显无为必有贤圣尊重弟子。二约义释辨名胜

尔时须菩提白佛言。世尊。当何名此经。我等云何奉持。佛告须菩提。是经名为金刚般若波罗蜜。以是名字汝当奉持。所以者何。须菩提。佛说般若波罗蜜。则非般若波罗蜜　佛立经名约能断惑。断惑故胜也。则非般若者。无著云。对治如言执故。三佛无异说胜

须菩提。于意云何。如来有所说法不。须菩提白佛言。世尊。如来无所说　无所说者。无别异增减之说。但如证而说。既如其说则无所说。三世佛皆然故云无异说。故论云无有一法唯独如来说。余佛不说。无著云。第一义不可说。四施福劣尘胜

须菩提。于意云何。三千大千世界所有微尘。是为多不。须菩提言。甚多世尊。须菩提。诸微尘。如来说非微尘。是名微尘。如来说世界非世界。是名世界　论云。宝施福德是烦恼因。以能成就烦恼事故。地尘无记非烦恼因故。尘胜施劣。大云云。故诸地尘则非贪等烦恼。尘是名无记。地尘如来说三千界非烦恼染因。界是名地尘。无记界是则界为尘。因尘不生烦恼。施为福因福生烦恼。五感果离相胜

须菩提。于意云何。可以三十二相见如来不。不也世尊。不可以三十二相得见如来。何以故。如来说三十二相即是非相。是名三十二相　恐施宝者云。我施求佛谁言烦恼。故此经云。可以相为佛不。论云。持说此法能成菩提。胜彼福德。何以故。彼相于佛菩提非法身相故。经福能降施福德三十二相。意明经福降施方得色相佛身。若但宝施即烦恼因。二约内财校量倍显经胜。二初校量胜劣

须菩提。若有善男子善女人。以恒河沙等身命布施。若复有人。于此经中乃至受持四句偈等。为他人说。其福甚多　舍身胜于宝施。持说又胜舍命。二释胜所以五。初泣叹未闻深法胜

尔时须菩提。闻说是经深解义趣。涕泪悲泣而白佛言。希有。世尊。佛说如是甚深经典。我从昔来。所得慧眼。未曾得闻如是之经　舍身之苦已感人心。何况更闻不及持说。是故悲泪。论云。念彼身苦尊重法故悲泪。慧眼人空也。未闻法空也。二净心契实具德胜二。初正明

世尊。若复有人。得闻是经信心清净则生实相。当知是人成就第一希有功德　论云。此中有实相余者非实相。二佛迹

世尊。是实相者。则是非相。是故如来说名实相　无著云。为离实相分别想故。三信解三空同佛胜三。初总标信解

世尊。我今得闻如是经典。信解受持不足为难。若当来世后五百岁。其有众生得闻是经信解受持。是人则为第一希有　无著云。未来法灭时。尚有菩萨受持。故无我人等取。云何汝等于正法时。远离修行不生惭愧。二别显三空

何以故。此人无我相人相众生相寿者相。所以者何。我相即是非相。人相众生相寿者相即是非相。何以故。离一切诸相即名诸佛　无著云。无我等者。无人取我等。即非相者无法取。离一切者。显示诸菩萨随顺学相。诸佛世尊离一切相。是故我等应如是学。三如来印定

佛告须菩提。如是如是　四闻时不动希有胜

若复有人得闻是经。不惊不怖不畏。当知是人甚为希有　论云。惊者谓非处生惧。怖者不能断疑心故。畏者一向怖故。其心毕竟堕惊怖故。五大因清净第一胜

何以故。须菩提。如来说第一波罗蜜非第一波罗蜜。是名第一波罗蜜　何以故者有二。一蹑前不惊等征。二都蹑前胜以征。论云。此法门者。名为大因。胜余修多罗故名为清净。无量诸佛同说故。故彼珍宝檀等无如是功德。是故彼福德中。此福为胜

金刚般若经疏论纂要上金刚般若经疏论纂要下

        京大兴福寺沙门宗密述

        长水沙门子璇治定

八断持说未脱苦果疑。论云。向说舍身。苦身果报故福劣。若尔依此法门持说诸菩萨行苦行。亦是苦果。云何此法不成苦果○断之文二。初明超忍以断疑二○初明忍体

须菩提。忍辱波罗蜜。如来说非忍辱波罗蜜　忍到彼岸已离苦相。况彼岸非岸谁苦谁忍△二明忍相二。初引一生证极苦忍二。初正明

何以故。须菩提。如我昔为歌利王割截身体。我于尔时。无我相无人相无众生相无寿者相　歌利。此云极恶。佛昔作仙山中修道。王猎疲寝妃共礼仙。王问得四果皆答不得。王怒割截天怒雨石。王惧而忏悔。仙证本无嗔。王乃免害。论云。不但无苦而乃有乐。以慈悲故○二反显

何以故。我于往昔节节支解时。若有我相人相众生相寿者相。应生嗔恨　二引多生证相续忍

须菩提。又念过去于五百世作忍辱仙人。于尔所世。无我相无人相无众生相无寿者相。累苦故忍熟而　累苦故忍熟而乐。但与正定慈悲相应故。偈云。离我及恚相。实无有苦恼共乐有慈悲如是苦行果○二劝离相以安忍。论云。若有菩萨不离我相。见苦行苦欲舍菩提心。故劝离相。无著云。为对治不忍因缘有三种苦。谓流转苦。众生相违苦。乏受用苦○文二○初总标

是故须菩提。菩萨应离一切相。发阿耨多罗三藐三菩提心　若离相发心。虽逢大苦即能不舍。无著云。离一切相者。为离如是三苦相也○二别显二○初对治不忍流转苦

不应住色生心。不应住声香味触法生心。应生无所住心。若心有住则为非住。是故佛说。菩萨心不应住色布施　初正明流是集谛。转是苦谛。无著云。若着色等则于流转苦中疲乏。故菩提心不生。后引证。引前说无住施。具含六度。证此文矣○二对治不忍相违苦

须菩提。菩萨为利益一切众生应如是布施如来说一切诸相。即是非相。又说一切众生。则非众生　无著云。既为众生行施。云何于彼生嗔。由不能无众生想故。众生相违时即生疲乏故。显示人无我法无我。论云。诸相者众生相也。非相者无我也。阴中见我是众生相。一切众生者五阴法也。非众生者。阴空故法无我也。乏受用苦配在后断。九断能证无体非因疑。论云。于证果中无道。云何彼于果为能作因○断之文二○初断疑

须菩提。如来是真语者。实语者。如语者。不诳语者。不异语者　佛所有说皆如其事。今说证果何疑不然。真语者。说佛身大菩提法也。是真智故。实语者。说小乘四谛。谛是实义。如语者说大乘法有真如小乘无也。不异语者。说三世授记等事更无参差。佛将此四语不诳众生。是故秦译加不诳语○二离执

须菩提。如来所得法。此法无实无虚　无实者。如言说性非有故。无虚者。不如言说自性故有○十断如遍有得无得疑。论云。若圣人以无为真如法得名。彼真如一切时处恒有。何故有得者有不得○断之文二○初举喻断疑

须菩提。若菩萨心住于法而行布施。如人入闇则无所见。若菩萨心不住法而行布施。如人有目日光明照见种种色　论云。无智住法。心不清净故不得。有智不住法心清净故得。有目者如得对治法。日光者如所治闇尽能治现前。空喻真如。色喻性上万德○二赞经功德二○初总标

须菩提。当来之世。若有善男子善女人。能于此经受持读诵。则为如来以佛智慧。悉知是人悉见是人。皆得成就无量无边功德　无著云。读诵者此说受持因故。为欲受故读。为欲持故诵。论云。受持修行。依总持法故。读诵修行依闻慧广故。是则从他闻法内自思惟。得修行智也。故偈云修从他及内○二别显十。初舍命不如二○初舍命福

须菩提。若有善男子善女人。初日分以恒河沙等身布施。中日分复以恒河沙等身布施。后日分亦以恒河沙等身布施。如是无量百千万亿劫。以身布施　偈云。以事及时大福中胜福德○二信经福

若复有人。闻此经典信心不逆。其福胜彼。何况书写受持读诵为人解说　信经劣于持说。多命胜于前喻○二余乘不测

须菩提。以要言之。是经有不可思议不可称量无边功德　偈云。非余者境界无著云。不可思议者唯自觉故。不可称量者。无有等及胜故○三依大心说

如来为发大乘者。说为发最上乘者说　最上者一佛乘也○四具德能传

若有人能受持读诵。广为人说。如来悉知是人悉见是人。皆得成就不可量不可称无有边不可思议功德。如是人等。则为荷担如来阿耨多罗三藐三菩提　成就等者。偈云。满足无上界。荷担者。无著云。肩负菩提重担故○五乐小不堪

何以故。须菩提。若乐小法者。着我见人见众生见寿者见。则于此经不能听受读诵为人解说　六所在如塔

须菩提。在在处处。若有此经。一切世间天人阿修罗所应供养。当知此处则为是塔。皆应恭敬作礼围绕。以诸华香而散其处　七转罪为佛

复次须菩提。善男子善女人。受持读诵此经。若为人轻贱。是人先世罪业应堕恶道。以今世人轻贱故。先世罪业则为消灭。当得阿耨多罗三藐三菩提　轻贱者。总包于中或打或骂故。隋译云。轻贱甚轻贱。无著云。此毁辱事有无量门故。复云。甚轻贱当得菩提者罪灭故○八超事多尊。论云。示现速证菩提法故○文二○初供佛多中全具福

须菩提。我念过去无量阿僧祇劫。于然灯佛前。得值八百四千万亿那由他诸佛。悉皆供养承事无空过者　那由他者。十亿为洛叉。十洛叉为俱胝。十俱胝为那由他○二持经多中少分福

若复有人。于后末世。能受持读诵此经所得功德。于我所供养诸佛功德。百分不及一。千万亿分乃至算数譬喻。所不能及　九具闻则疑

须菩提。若善男子善女人。于后末世有受持读诵此经。所得功德我若具说者。或有人闻心则狂乱。狐疑不信　十总结幽邃

须菩提。当知是经义不可思议。果报亦不可思议　无著云。此显示彼福体及果体。不可测量故○十一断住修降伏是我疑。佛教我住修降伏。兼不住前十种疑执过患。若无我者谁人受教。谁人住修谁人如此离过云云。亦云除微细执故。偈云。于内心修行存我为菩萨。此即障于心违于不住道○断之文二○初问

尔时须菩提白佛言。世尊。善男子善女人发阿耨多罗三藐三菩提心。云何应住。云何降伏其心　二答三○初若名菩萨必无我

佛告须菩提。若善男子善女人。发阿耨多罗三藐三菩提心者。当生如是心。我应灭度一切众生。灭度一切众生已。而无有一众生实灭度者　二若有我相非菩萨

何以故。若菩萨有我相人相众生相寿者相。则非菩萨　三能所俱即是菩提

所以者何。须菩提。实无有法发阿耨多罗三藐三菩提心者　十二断佛因是有菩萨疑。论云。若无菩萨。云何释迦如来于然灯佛所行菩萨行○断之文四○初举疑处

须菩提于意云何。如来于然灯佛所。有法得阿耨多罗三藐三菩提不　降怨王请然灯佛入城。城中长幼尽迎。路泥善慧布发佛与授记。故举此问○二断疑念

不也世尊。如我解佛所说义。佛于然灯佛所。无有法得阿耨多罗三藐三菩提　善慧彼时都无所得。离诸分别由无法故得记。若有法者。是有相心。不顺菩提佛不与记○三印决定

佛言如是如是。须菩提实无有法如来得阿耨多罗三藐三菩提　论云。我于彼时所修诸行。无有一法得阿耨多罗三藐三菩提。功德施论引佛说云。若见于佛即见自身。见身清净见佛清净。见一切智智皆悉清净。是中见清净智亦复清净。是名见佛。我如是见然灯如来。得无生忍。一切智智明了现前。即得受记。是受记声不至于耳。亦非余智之所能知。我于此时亦非惛懵无觉。然无所得○四反覆释

须菩提。若有法如来得阿耨多罗三藐三菩提者。然灯佛则不与我授记。汝于来世。当得作佛号释迦牟尼。以实无有法得阿耨多罗三藐三菩提。是故然灯佛与我授记作是言。汝于来世。当得作佛号释迦牟尼　无著云。若正觉法可说。如彼然灯所说者。我于彼时便得正觉。然灯则不记言来世当得。以法不可说故。我于彼时不得正觉。是故记言来世当得○十三断无因则无佛法疑。于中三。初断一向无佛疑。论云。若无菩提即无诸佛如来。有如是谤。谓一向无佛。为断此疑故。云如来者即是真如○断之文二○初显真如是佛故非无

何以故。如来者即诸法如义　无著云。如清净故名为如来。犹如真金　二明佛即菩提故无得

若有人言。如来得阿耨多罗三藐三菩提。须菩提实无有法佛得阿耨多罗三藐三菩提　先标错解。魏云。若有人言。如来得阿耨菩提者。是人不实语。后释正见。偈云。菩提彼行等。谓等前菩萨行无得也。无著云。或谓然灯如来所。于法不得正觉。世尊后时自得正觉。为离此取故。云若人言等○二断一向无法疑。论云。有人谤言。若无因行。则如来不得阿耨菩提。为断此疑故。云如来所得等○断之文二○初遣执遮疑

须菩提。如来所得阿耨多罗三藐三菩提。于是中无实无虚　论云。无色等相故。彼即菩提相故。无著云。显真如无二故。谓言说故。谓彼正觉不无世间言说故○二释义断疑

是故如来说一切法。皆是佛法。须菩提所言一切法者。即非一切法。是故名一切法　论云。一切法者。皆真如体故皆佛法。即非者由色等法即真如故。即非色等法真如。常无色等诸相故。是名者即是真如法自性矣○三显真佛真法体

须菩提。譬如人身长大。须菩提言世尊。如来说人身长大。则为非大身。是名大身　偈云。依彼法身佛故说大身喻。身离一切障及遍一切境。功德及大体故。即说大身非身即是身。是故说大身。论云。非身者无有诸相故。大身者有真如体故。无著云。摄一切众生大身故。于彼身中安立非自非他故○十四断无人度生严土疑。论云。若无菩萨者。诸佛亦不成菩提。众生亦不入涅槃。亦无清净佛土。何故诸菩萨发心。欲令众生入涅槃。起心修行清净佛土○断之文三。初遮度生念三○初明失念

须菩提。菩萨亦如是。若作是言。我当灭度无量众生。则不名菩萨　偈云。不达真法界。起度众生意。及清净国土。生心即是倒○二明无人

何以故。须菩提。实无有法名为菩萨　无法名菩萨。岂有我度众生○三引前说

是故佛说一切法。无我无人无众生无寿者　二遮严土念二○初明失念

须菩提。若菩萨作是言。我当庄严佛土。是不名菩萨　二释所以

何以故。如来说庄严佛土者。即非庄严是名庄严　三释成菩萨

须菩提。若菩萨通达无我法者。如来说名真是菩萨　论云。若起度众生严土之心。即是颠倒非菩萨者。起何等心名为菩萨。故经言通达等。无著云。谓人无我法无我○十五断诸佛不见诸法疑。论云。前说菩萨不见彼是众生。不见我为菩萨。不见清净佛土。若如是则诸佛不见诸法○断之文二。初约能见五眼明见净。偈云。虽不见诸法。非无了境眼。诸佛五种实。以见彼颠倒○文五○初肉眼

须菩提。于意云何。如来有肉眼不。如是世尊。如来有肉眼　肉团中有清净色。见障内色名为肉眼。佛具诸根故有肉眼○二天眼

须菩提于意云何。如来有天眼不。如是世尊。如来有天眼　于肉眼边引净天眼。　见障外色。依大般若。佛肉眼能见人中无数世界。不唯障内。若佛天眼能见诸天所有细色。除见天外见人等事名肉眼矣。净名云。唯佛世尊得真天眼。照见恒沙佛土不以二相○三慧眼

须菩提于意云何。如来有慧眼不。如是世尊。如来有慧眼　以根本智照真理故○四法眼

须菩提于意云何。如来有法眼不。如是世尊。如来有法眼　后得智说法度人○五佛眼

须菩提于意云何。如来有佛眼不。如是世尊。如来有佛眼　前四在佛总名佛眼。又见佛性圆极名为佛眼○无著云。为令知见净胜故。显示有五种眼。略说有四种。谓色摄第一谛摄世谛摄一切种一切应知摄○古德偈云。天眼通非碍。肉眼碍非通。法眼唯观俗。慧眼直缘空。佛眼如千日。照异体还同○二约所知诸心明智净五○初约一个恒河以数沙

须菩提于意云何。如恒河中所有沙。佛说是沙不。如是世尊。如来说是沙　二约一河中沙以数河

须菩提于意云何。如一恒河中所有沙。有如是沙等恒河　三约沙河中沙以数界

是诸恒河所有沙数佛世界。如是宁为多不。甚多世尊　四约尔所界中所有生

佛告须菩提。尔所国土中所有众生　五约一一众生所有心三○初总明染净以标悉知

若干种心如来悉知　无著云。若干种心者有二种。谓染及净。即共欲心离欲心等○二会妄归真以释悉知

何以故。如来说诸心皆为非心。是名为心　大云云。由一切妄心依真如体都无其性。佛证真如故悉知之。诸心者标指。非心者妄识本空。是名心者真心不灭。若本论释则与此殊。偈云。种种颠倒识。以离于实念。不住彼实智。是故说颠倒○三推破杂染以释非心

所以者何。须菩提。过去心不可得。现在心不可得。未来心不可得　无著云。过去已灭故。未来未有故。现在第一义故○十六断福德例心颠倒疑。论云。向说心住颠倒皆不可得。若如是福德亦是颠倒。何名善法○断之文二○初问福答福

须菩提于意云何。若有人满三千大千世界七宝。以用布施。是人以是因缘得福多不。如是世尊。此人以是因缘得福甚多　以是离相无倒行施因缘。成无漏福离于二障。既非颠倒故得福多○二反释顺释

须菩提若福德有实如来不说德福德多。以福德无故。如来说得福德多　偈云。佛智慧为本。非颠倒功德。论云。显示福非颠倒。佛智为本故福有者取相也。福无者离相也。问福性空故福多者前说妄心性空。妄亦应多。答福以佛智为本。顺于性空故悟性空。福则甚多。心识颠倒。违于性空故悟性空。则心识都尽。十七断无为何有相好疑。论云。若诸佛以无为得名。云何诸佛成就相好。而名为佛。此约法身佛故以为疑○断之文二○初由无身故现身

须菩提于意云何。佛可以具足色身见不。不也世尊。如来不应以具足色身见。何以故。如来说具足色身。即非具足色身。是名具足色身　即随形好也。如镜中无物方能现物故。论云。法身毕竟非色身非诸相。然相好二种。亦非不佛。此二不离法身故。是故此二亦得言无。故说非身。亦得言有。故说成就○二由无相故现相

须菩提。于意云何。如来可以具足诸相见不。不也世尊。如来不应以具足诸相见。何以故。如来说诸相具足即非具足。是名诸相具足　即三十二相也。一一如前色身中说。十八断无身何以说法疑。论云。若如来色身相好不可得见。云何言如来说法○断之文三○初遮错解

须菩提。汝勿谓如来作是念。我当有所说法。莫作是念　谷中无人能作音声故○二释所以

何以故。若人言如来有所说法。即为谤佛。不能解我所说故　世尊达诸法空毕竟无执。今言有说。是谤佛执法也○三示正见

须菩提说法者。无法可说。是名说法　偈云。如佛法亦然所说二差别。不离于法界。说法无自相。大云云若言无说是真说法。若言有说不名说法。是谤佛故○十九断无法如何修证疑。论云。如来不得一法。云何离上上证转。转得阿耨菩提。为断此疑示现非证法。名为阿耨菩提○断之文三○初以无法为正觉

须菩提白佛言世尊。得阿耨多罗三藐三菩提。为无所得耶。佛言如是。如是。须菩提。我于阿耨多罗三藐三菩提。乃至无有少法可得。是名阿耨多罗三藐三菩提　偈云。彼处无少法知菩提无上。论云。彼菩提处无有一法可证。名为阿耨菩提○二以平等为正觉

复次须菩提。是法平等。无有高下。是名阿耨多罗三藐三菩提　偈云。法界不增减。论云。是法平等是故名无上。以更无上上故○三以正助修正觉

以无我无人无众生无寿者。修一切善法。则得阿耨多罗三藐三菩提。须菩提。所言善法者。如来说即非善法。是名善法　无我等。是了因即正道也。修一切善法是缘因。即助道也。即得阿耨菩提是正觉也。所言善法者标指也。即非等者。论云。彼法无有漏法。故名非善法。以有无漏法。故名为善法○二十断所说无记非因疑。论云。若修一切善法得阿耨菩提者。则所说法不能得菩提。以是无记法故○断者

须菩提。若三千大千世界中。所有诸须弥山王。如是等七宝聚。有人持用布施。若人以此般若波罗蜜经。乃至四句偈等。受持读诵为他人说。于前福德百分不及一。百千万亿分。乃至算数譬喻所不能及　偈云。虽言无记法。而说是彼因。是故一法宝胜无量珍宝论云。以离所说法不能得大菩提故。此法能为菩提因。又言。汝法是无记。而我法是记。是故胜舍无量七宝○二十一断平等云何度生疑。论云。若法平等无高下者。云何如来度众生○断之文四○初遮其错解

须菩提于意云何。汝等勿谓。如来作是念。我当度众生须菩提。莫作是念　二示其正见

何以故。实无有众生如来度者　偈云。平等真法界。佛不度众生。以名共彼阴。不离于法界。论云。众生假名与五阴共不离法界○三反释所以

若有众生如来度者。如来则有我人众生寿者　论云。若如来有如是心。五阴中有众生可度者。此是取相过。无著云。如来如尔炎而知。是故若有众生想则为有我取○四展转拂迹

须菩提。如来说有我者则非有我。而凡夫之人以为有我。须菩提。凡夫者如来说则非凡夫　二十二断以相比之真佛疑。论云。虽相成就不可得见如来而以见相成就。比智则知如来法身○断之文五○初问以相表佛

须菩提于意云何。可以三十二相观如来不　二答因苗识根

须菩提言。如是如是。以三十二相观如来大云云。前悟色身今迷法身。意谓法身既流出相身。即由此相。知佛证得无相法身○三难凡圣不分

佛言须菩提。若以三十二相。观如来者。转轮圣王则是如来　偈云。非是色身相。可比知如来。诸佛唯法身。转轮王非佛○四悟佛非相见

须菩提白佛言世尊。如我解佛所说义。不应以三十二相观如来　五即见闻不及

尔时世尊而说偈言。若以色见我。以音声求我。是人行邪道。不能见如来　魏加后偈云。彼如来妙体。即法身诸佛。法身不可见。彼识不能知。偈云。唯见色闻声。是人不知佛。以真如法身。非是识境故。无著云。以彼法真如相故。非如言说而知。唯自证知故。二十三断佛果非关福相疑。由前相比法身是失。又闻以色见声求是邪。遂作念云。佛果一向无相无为。若尔则修福德之因。但成相果。相果既非佛果。佛果则不以具相而得。故佛果毕竟不关福相。故论云。有人起如是心。若不依福德得大菩提。如是诸菩萨。则失福德。及失果报○断之文四。初遮毁相之念

须菩提汝若作是念。如来不以具足相故。得阿耨多罗三藐三菩提。须菩提莫作是念。如来不以具足相故。得阿耨多罗三藐三菩提　华严经云。色身非是佛。音声亦复然。亦不离色声。见佛神通力。肇云。不偏在色声故言非。非不身相故复言是。大云云。若言如来不以相具断灭见矣。故佛止云莫作是念○二出毁相之过

须菩提汝若作是念。发阿耨多罗三藐三菩提心者。说诸法断灭。莫作是念　毁相则堕断灭。断灭是损减之过。断见边见之过。○三明福相不失

何以故。发阿耨多罗三藐三菩提心者。于法不说断灭相　无著云。于法不说断灭者。谓如所住法而通达。不断一切生死影像法。于涅槃自在行。利益众生事。此中为遮一向寂静故。显示不住涅槃。偈云不失功德因及彼胜果报。论云。虽不依福德。得真菩提而不失福德及彼果报。以能成就智慧庄严功德庄严○四明不失所以二○初明得忍故不失

须菩提。若菩萨以满恒河沙等世界七宝布施。若复有人知一切法无我。得成于忍。此菩萨胜前菩萨所得功德　论云。有人起如是心。诸菩萨得出世智。失彼福德及以果报。为遮此故。偈云。得胜忍不失以得无垢果。无我者二种无我也○一明不受故不失二○初正明

须菩提。以诸菩萨不受福德故　论云。彼福德得有漏果报。故可诃也。无著云。此显示不着生死故。若住生死即受福德○二征释

须菩提。白佛言世尊。云何菩萨不受福德。须菩提。菩萨所作福德。不应贪着。是故说不受福德　二十四断化身出现受福疑。论云。若诸菩萨不受福德。云何诸菩萨福德众生受用○断之文二○初斥错解

须菩提。若有人言。如来若来若去若坐若卧。是人不解我所说义　偈云。是福德应报。为化诸众生。自然如是业。诸佛现十方○二示正见

何以故。如来者无所从来。亦无所去。故名如来　偈云。去来化身佛。如来常不动。大云云。众生心水若清净。则见佛来。来无所从。浊则见双林示灭。则云佛去。去无可至。肇云。解极会如体无方所。缘至物现来无所从。感毕为隐亦何所去○二十五断法身化身有异疑。据前不可以化相此知法身。法身无去来坐卧。即似真化异。据遮断灭之念。又显不失福相。即似真化一故成疑也。此约微尘世界。委释非一非异义。以断此疑○文二初约尘界破一异五○初细末方便破粗色

须菩提。若善男子善女人。以三千大千世界碎为微尘。于意云何。是微尘众宁为多不。甚多世尊　偈云。于是法界处。非一亦非异。论云。彼诸佛如来。于真如法界中。非一处住亦非异处住。为示此义故。说世界碎为微尘。故偈云。世界作微尘。此喻示彼义○无著云。为破名色身故说界尘等。于中细末方便及无所见方便。尘甚多者。是细末方便○大云云。即是析尘至于细末。以此方便破粗色矣。此言微尘依大乘宗。于一抟色假想分析。至极略色为尘。非小乘宗实尘矣○二不念方便破微尘

何以故。若是微尘众实有者。佛则不说是微尘众。所以者何。佛说微尘众。则非微尘众。是名微尘众　论云。尘碎为末故非一处。尘众聚故故非异处。如是佛住法界中。非一处住非异处住○又若尘众实有者。世间凡夫悉亦自知。何须佛说。秖为不知体不成就。故佛说矣。故无著云。世尊说非者。以此聚体不成就故。若异此者。佛虽不说亦自知是聚○三不念方便破世界

世尊。如来所说三千大千世界。则非世界。是名世界　本论破世界不实之义可知。无著云。此破名身世界者。众生世界○四俱约尘界破和合

何以故。若世界实有者。则是一合相。如来说一合相则非一合相。是名一合相　论云。若实有一世界。如来则不说三千界。大云云。若实有一世界。冥然是一一和合矣。是则不合有多差别。今既佛说三千。明非冥然一矣。故约三千破一界也○无著云。为并说若世界若微尘界故。有二种抟取。为一抟取及差别搏取。大云云。此明尘众及众生类俱名世界。一合相者。即是抟取。抟取为一故云和合。故此一合有二抟取。一者一抟取。即是世界和合为一。二差别抟取。即是微尘有众多极微。名为差别。非一合者第一义中二界无实故。五佛印无中妄执有

须菩提。一合相者则是不可说。但凡夫之人贪着其事　论云。以彼聚集无物可取。虚妄分别故云妄取。若有实者即是正见。无著云。世谛说抟取。第一义不可说。彼小儿凡夫如言说取。大云云。执见五蕴取其和合。是贪着事迷于事法起烦恼矣○二约止观破我法二。初除我执二。初斥错解

须菩提。若人言佛说我见人见众生见寿者见。须菩提于意云何。是人解我所说义不。世尊。是人不解如来所说义　二遣言执

何以故。世尊说我见人见众生见寿者见。则非我见。人见。众生见。寿者见。是名我见。人见。众生见。寿者见　论云。我见虚妄分别。佛说即是不见。无著云。此显示如所不分别。云何显示如。外道说我。如来说为我见故。安置人无我。又为说有此我见故。安置法无我。如是观察菩萨入相应三昧时。不复分别。即此观察为入方便○二除法执二○初除分别

须菩提。发阿耨多罗三藐三菩提心者。于一切法应如是知。如是见如是信解。不生法相　无著云。此显示何人无分别。于何法不分别。何方便不分别○此显示增上心增上智故。于无分别中知见胜解○于中若智依止奢摩他故知。依止毗钵舍那故见。此二依止三摩提故胜解。以三摩提自在故。解内攀缘影像。彼名胜解○云何无分别。此正显无分别。大云云。前之方便是加行智。今不分别是根本智。即亲证真如离能所取。名不分别○二显本寂

须菩提所言法相者。如来说即非法相。是名法相　无著云。此显示法相中。不共义及相应义。如前已说。二十六断化身说法无福疑。因闻真化非一非异。意云。若就非一化唯虚假。若就非异又唯冥合归一。法身即化身终无自体。若尔即所说法受持演说无福○断之文二○初明说法功德

须菩提。若有人满无量阿僧祇世界七宝持用布施。若有善男子善女人。发菩萨心者。持于此经乃至四句偈等。受持读诵为人演说。其福胜彼　偈云。化身示现福非无无尽福。论云。虽诸佛自然化身作业。而彼诸佛化身说法。有无量无尽无漏功德○二明说法不染

云何为人演说。不取于相。如如不动　无著云。为说法不染故。以有如是大利益故决定演说。如是演说即无所染○云何演说等者。显示不可言说故。若异此者则为染说。以颠倒义故。又说时不求信敬等。亦为无染说法○大云云。若能不以生灭心行说实相法。则如彼真如。故曰如如。又心如境如故曰如如。不动者则无染义○二十七断入寂如何说法疑。论云。若诸佛如来常为众生说法。云何言如来入涅槃○断者

何以故。一切有为法。如梦幻泡影。如露亦如电。应作如是观　释此文为三。初约两论释。魏本中九喻。魏本云。一切有为法。如星翳灯幻。露泡梦电云。应作如是观○于中文二。初约本论断疑。偈云。非有为非离。诸如来涅槃。九种有为法。妙智正观故。论云。诸佛得涅槃化身说法故非有为。非离有为。何故示现世间而不住有为。由妙智正观。有为如九喻虚假故○二兼无著释相。无著云此偈显示四有为相。文四○一自性相。此见相。二用识为体。生死根本故。文三○一星喻见。无著云。无智暗中有彼光故。有智明中无彼光故○二翳喻相。论云。如目有翳。则见毛轮等色。观有为法亦尔。以颠倒见故。无著云。人法我见如翳。以取无义故○三灯喻识。灯约膏油相续不绝。识依贪爱生死无休○二着所住味相。论云幻喻所依住处。以器世间种种差别。无一体实故。无著云。味着颠倒境故。大云云。幻出城郭诳人。识变山河不实故○三随顺过失相。自身及受用是过失。观此无常是名随顺。又解云。随顺身受即是过失。文二○初露喻身。论云。身亦如是少时住故。二泡喻受。论云。所受用事亦复如是。以受想因三法不定故。无著云。显示随顺苦体。以受如泡故。功德施云。观察寿如水泡。或始生未成体。或才生。或暂停住。即归散灭○四随顺出离相。无著云。随顺人法无我故得出离。文三○初梦喻过去。无著云。彼过去行以所念处故如梦。论云。应观过去所有集造同于梦境。但唯念性故。功德施云。观察作者。如梦中随见闻之境。以念分别熏习住故。虽无作者。种种境界分明现前。如是众生无始时来。有诸烦恼善不善业熏习而住。虽无我是能作者。而现无涯生死等事○二电喻现在。论云。以刹那不住故。功德施云。观察心如电生时即灭。三云喻未来。论云。以于子时阿黎耶识。与一切法为种子根本。无著云。彼粗恶种子似虚空。引心出故如云○无著云。如是知三世行则达无我。此显示随顺出离相。大云云。过未无体现又不住。则三世空达无我矣○二约诸经显诸虚假喻之大意。佛说一切法空。疑云。云何现见一切境界。故说如幻。幻法虽无分明可见。又疑云。幻法既无人何爱着。故说如阳焰。渴鹿谓之水爱着奔趣。又疑云。渴鹿毕竟不得水。贪者如何皆得受用。故说如梦。梦中所见亦得受用。又疑云。梦造善恶寤无业报。梦打尊长寤无忧惧。故说如影如响。虽全无体。明镜对色空谷对声。妍媸高低一一皆应。必无杂乱必无参差。又疑云。苦都无实。菩萨何以作利乐事。故说如化。谓变化者。虽知不实而化事○三会通秦译经本。梦幻泡影空理全彰。露电二喻无常。足显悟真空。则不住诸相。观生灭则警策修行。妙符破相之宗。巧示亡情之观○魏译九喻秦本略者。以星灯有体云种含生。恐难契空心。潜滋相想。取意之译妙在兹焉○第三流通分

佛说是经已。长老须菩提。及诸比丘比丘尼优婆塞优婆夷。一切世间天人阿修罗。闻佛所说皆大欢喜。信受奉行　尼者此云女也。优婆塞此云近事男。优婆夷此云近事女。亲近比丘比丘尼而承事故。阿修罗此云非天。皆大等者。文殊所问经云。有三种义欢喜奉行。一说者清净。不为取着利养所染。二所说清净。以如实知法体。三得果清净○无著云。若闻如是义。于大乘无觉。我念过于石究竟无因故。天亲云。诸佛希有总持法。不可称量深句义。从尊者闻及广说。回此功德施群生。大云云。大圣说经妙理斯毕。二空圆极四众奉行。肇云。同听齐悟法喜荡心。服玩遵式永崇不朽。资圣云。般若深经三世佛母。闻经四句以超恶趣之因。一念净持必获菩提之记。故人天异类莫不虔受奉行矣

金刚般若经疏论纂要下


金刚顶经大瑜伽秘密心地法门义诀

    No. 1798 [cf. No. 867]

金刚顶经大瑜伽秘密心地法门义诀卷上

此瑜伽经大分为二。初偈颂总相归赞。次长行等自他利行。于诸颂中复分为二。初偈四句普归命三宝(应知)次下别归圣会。于中复为二。先十句归命五分如来。后十句归四大菩萨。初十句中金刚身语意等四句归赞毗卢遮那佛。次雄猛阿閦已下六句归四方如来(应知)后十句归四大菩萨。于中初二句赞礼金刚藏菩萨。次二句赞礼虚空藏菩萨。第三两句赞礼观世音菩萨。第四两句赞礼毗首羯磨菩萨。第五两句结德总归(应知)此上两句等西方集瑜伽者大阿阇梨先以胜相赞礼置之经首。一切经首皆随彼门先安赞礼偈此方先德略而不译(应知)次我今于百千颂金刚顶等总四十字述经题目。此经有百干颂广本。非此土所闻。并是诸佛大菩萨等甚深秘密境界相。亦非声闻缘觉及人天小智之所闻知。此地梵网经两卷从此经中出浅略之行相也。其中广相根未有堪。此略瑜伽西国得灌顶者说授相付。而其广本亦不传之。其百千颂本复是菩萨大藏经中次略也。其大经本。阿阇梨云经夹广长如床。厚四五尺有无量颂。在南天竺界铁塔之中佛灭度后数百年间无人能开此塔。以铁扉铁锁而封闭之。其中天竺国佛法渐衰。时有大德先诵持大毗卢遮那真言。得毗卢遮那佛而现其身及现多身。于虚空中说此法门及文字章句。次第令写讫即灭。即今毗卢遮那念诵法要一卷。是时此大德持诵成就愿开此塔。于七日中绕塔念诵。以白芥子七粒打此塔门乃开。塔内诸神一时踊怒不令得入。唯见塔内香灯光明一丈二丈。名华宝盖满中悬列。又闻赞声赞此经王。时此大德至心忏悔发大誓愿然后得入此塔中。入已其塔寻闭。经于多日赞此经王广本一遍为如食顷。得诸佛菩萨指授所堪记持不忘。便令出塔塔门还闭如故。尔时书写所记持法有百千颂。此经名金刚顶经者菩萨大藏塔内广本绝世所无。塔内灯光明等至今不灭此经百千颂本此国未有。此略本至此土者于开元之初金刚菩提三藏阿阇梨云。我从西国发来度于南海其有大船三十余只。一一皆有五六百人。一时同过大海行至海中逢于大风。诸船及人并皆漂没。我所附船亦欲将没。尔时两本经夹常近于身受持供养。其时船主见船欲没。船上诸物皆掷海中。当时怖惧忘收经夹。其百千颂亦掷海中唯存略本。尔时我发心念作除灾法大风便止。去船周回可一里余风水不动。船上诸人皆归于我。渐渐发来得至此岸来到此国。于开元七年中至于西京。一行禅师求我灌顶。闻有此异希有法门乃令伊舍罗译为汉文。一行等乃亲自笔受。一依梵本次第而述其意不失句义未圆。此以窃观诸修行者纵有寻读莫知所从。又浅智愚识亦为难入。今以此承旨授颇得其趣。秘密之旨略在文言属。法流行强开方便。分别门标其旨归即此经长行自他利行中复分为二。初从若修行者下乃至修习瑜伽结加已来总门。为秘密庄严内证大智。见法成就得如来处自利也。第二从修习瑜伽下至经末已入总门。为善巧建立秘密智相摄取众生令入佛位利他行也。亦可通为一门并皆俱有自他利行也。于前自利门中复分为三。第一从初乃至或大菩萨坐结加已乃至随意作之等。总是三业四仪净除业障法。第二从行者欲自清净下乃至复自思惟所持秘密明至已来。总是入智三摩地门诸佛境界实相智印法。第三从复自思惟下乃至修习瑜伽已来。总是融愚入智成等正觉住大菩提法。于第一门中而为颂曰

  师资共受行　　摄引劝修法
  次初起行住　　加持语门法
  洗面嚼齿木　　便易结护法
  [口*束*頁]口洗浴法　　并浴部尊法
  想严身内外　　次入道场法
  普礼忏随向　　别归献愿法
  随乐四威仪　　除增降坏法

第一师资共行劝修等行法者。此中六段。第一简器教授。经从若修行至护摩等法。是第二发心利益。经从金刚弟子至一切罪障皆得消灭等。是第三摄取邪见。经从或有众生深入至离恶趣故等。是第四劝修得益。经从若善男子至所求者等。是第五付嘱所堪。经从金刚阿阇梨若见有人至信令发其心等。是第六示居胜处。经从其作法处应在胜地至如法修行等是此之六段。释述无量恐繁不委应知

颂初起行住法者。经从凡修瑜伽者每于眠寝乃至一切众生应广利益等。此名初起法。释曰谓修习瑜伽者常想自身常为普贤金刚身。若寝息时想入金刚三昧。谓心寂静如入涅槃。当想自身为五智印相而有光焰围绕。然后随意寝意也。是名身三昧想应。若起时想从金刚三昧起。故此秘密义云金刚生起也。拔折罗者金刚三昧相名。底瑟吒者生起义。唵者诸佛法界顶。此是秘说而其妙观唯以口传。其印名金刚三昧。金刚三昧名为觉者。了知诸法自性清净离于自性。因业所转种种变异。故令思惟伽陀义也。既知此义行饶益行。故云应广利益等

经云若起欲行及真言等此名行法。释曰。所谓行三昧也。其秘密义云金刚三昧行步也

经云若住此处及真言等此名住止法。释曰。秘密义者止住金刚三昧也。唵义如上。下亦准之

颂云加持语门法者。经云欲共人语及真言等。释曰以囕字法界心置于舌端。想放种种光明。复以真言而用加持言音。若圣人秘密义者金刚三昧圣力声也

颂云洗面嚼齿木者。经曰若洗面时及真言乃至皆生欢喜等。释曰此水从金刚三昧出生。以用洗面。面如金刚。诸魔不敢正视也。一切如来皆悉欢喜

次嚼齿木法者。经云若嚼杨枝时。至加持然后嚼之等。释曰。若如法作者能令行人成就金刚微笑三昧。故秘密义者谓佛德。金刚笑三昧加持故云能破一切烦恼及随烦恼。以观羽作金刚拳者。以右手急握大指并把杨枝即是

颂云便易结护法者。经云若欲往便易处即以左右手作甲胄印乃至出洗净讫等。释曰。此经阙金刚甲胄印也。今以叙之。其甲胄印者。先以二手合掌当心。即以二头指附二中指背。二大指并竖捻二中指中节文。即是真言曰

唵拔折啰迦伐遮吽

秘密义者。被佛德金刚三昧甲胄。以用加持以此秘明印印身二肩左右胁腰髀等。想之自身如被甲胄。复以印置于顶上。各分为二金刚拳。拳者头指已下四指各握大指。顶上并拳以即直竖二头指如针锋。头相跓想为头锋。复分手缘二肩下至心上。以头指相跓即以唵啅吽(二合)二字加二头指。想二头指出五色光成金刚带。然后于身上下遍绕如系甲状。是名庄严甲胄法。如经所说。次加持土复住法界心。左右金刚护。所谓此三字护身。放大光焰赫炽外发。复以明印而用加持。印相如经。故云三界所有诸恶皆得消灭。若不能用前明印唯诵后一切通用秘明亦得。若二俱寂胜。后之真言兼用前印。一切处用结护(应知)

颂云[口*束*頁]口洗浴法者。经云以此秘明加持金刚水及真言至[口*束*頁]口讫等。释曰。秘密义者佛德金刚大悲三昧水净持口秽。令口业清净。寂智门开发也。是名[口*束*頁]口法

次洗浴法者。经云便当洗浴洗浴者有四种每日随意乃至随能任作等。释曰。一具持三种律仪者。谓令住三三昧显发三身故。二礼忏发露等者。谓净除业障得无碍智故。三结印供养言。谓令诸佛欢喜增福寿命故。四以香水洗浴者。谓令支分柔软合法性故。随此修行是洗浴义也。思之可解。三律仪义广如别经所明

颂云并浴部尊法者。经云若入池水浴时先想为诸天欢喜池。于水中央想有如来最胜上轮坛。乃至想彼轮漫荼罗尽入己身中等。释曰。想五字等为种子。出生各各部会尊众等。即以香水满掬以为供养等。其掬水法经不具明。今以具述。先以并两手侧着如掬物势。以二大指入于掬中。三度向外拨水令至尊所。想灌尊仪一一别浴。或普想都浴之。余文可解

颂云想严身内外者。经云如是想已出立岸上乃至秘明真实义理等。释曰。如常束带者随自庄严。又以头冠等庄饰其身者。经无此印。今更叙之。以二手右押左向外相叉。二中指头相跓。如莲华叶举安顶上。即便各为金刚拳。分手从头两畔向下缘身散之。想成鬓带及天衣等。结印时复诵此真言曰

唵拔折罗钵踏摩呵毗诜者三漫多嚩日哩

秘密义者谓佛德金刚莲华冠于我心顶上也。作是法随乐本尊想合一体。然后想执拔折罗等。乃至秘明真实义理等。随自持者思之。余文可解

颂云次入道场法者。经云然后往道场所欲入之时乃至擗诸不祥等。释曰。如上[口*束*頁]口真言是结止。羽拳者左手握大指为拳。兼出金刚声。以拳辟门令开也。嗔怒眼者慈心圆晴左右傍视也

颂云普礼忏随向者。经云入已正念十方常住乃至如法作已等。释曰。此初入时普皆想礼毗卢遮那法界常住会也。此合有忏悔劝请随喜回向等法。阙者为略修瑜伽者常住金刚身语意。即旋入普贤遍一切行愿身。此法满故故不广列之。若有乐者随意所作。五体及胡跪等可解

颂云别归献愿法者。经云即从座起复以右膝着地乃至于四方如上作法礼已等。释曰。此有四义。一为成就一切诸佛金刚普贤行位故。二为成满一切诸佛金刚灌顶位故。三为速令成就一切如来转法轮位故。四为同得一切如来金刚善巧业用故。此四种三摩地或一时运入或次第入。或随乐入一。随作已时皆先结初金刚三昧耶已。然后合掌随方作礼。其真言秘密义者。谓佛德金刚三昧最胜也。故令先结其印。如经所说。尊重礼拜等余文可解。欲入四种三摩地门。先总举次别列。经又应以身至各礼一拜等总举也。其义可解

第一金刚普贤三昧者。经云于其东方全身着地及真言乃至哀愍加持等。释曰。其秘密义者想于东方尽虚空界纯以金刚而为庄严。名曰金刚庄严藏世界。于中如来满世界中。如一切世界微尘数。一一如来皆入金刚三昧。结加趺坐。展垂右手于右膝上。横仰左手于趺上。一一如来皆有执金刚等诸大菩萨而共围绕。即运自身心于一一诸佛及诸菩萨前承事供养。复想一一身中出生无量上妙香华及种种供具。复想己身成金刚座等而奉献之。令心眼见了了分明。佛菩萨等而为纳受。尔时行者于三昧中便作是愿。愿一切如来金刚萨埵守护于我。以此金刚三昧加持我身。所谓吽字。若能如是入者速得金刚普贤三昧也

第二灌顶位者。经云又金刚合掌置于心上面向南方及真言乃至与我灌顶等。释曰。其秘密义者作金刚合掌一心归命。想于南方尽虚空界纯以妙宝而为庄严。名曰宝光明藏世界。其中如来遍满世界。如一切世界微尘数。一一佛所皆想有虚空宝藏菩萨宝幢等无量菩萨而共围绕。其诸如来等皆入宝光明三摩地。所谓结跏趺坐。仰右手于脐上现掌向外。于其掌中现妙宝相。左手横仰安加趺上所居宫殿皆大宝庄严。诸菩萨等各执宝幢及杂宝供具。了了分明。复运想。自身奉献等一一如前说。尔时于三昧中便作是愿。愿一切如来及金刚宝等。菩萨以宝三昧灌于我顶尔时即便想见佛菩萨等。一时俱以宝性光明而为灌顶。如是行者应时即满灌顶之位。莫作是念。我是凡夫也云何即是诸菩萨灌顶位耶。何以故。与宝光明三昧等一性故

第三法轮位者。经云又以金刚合掌置于头上及真言乃至为我转金刚法轮等。释曰。其秘密义者合掌归命一心西向。想于西方尽虚空界纯以净妙金刚宝莲华而为庄严。复想一切如来及观自在文殊等大菩萨众围绕说法。想一一佛菩萨等如一切世界微尘数一一佛结加趺坐入于三昧。诸菩萨众各执莲华。华中有法轮及法螺等了了令见。复想自身供养承事等如上。尔时于三昧中便作是愿。愿诸如来及金刚法华轮菩萨等。以此三昧灌于我顶。是时行者即便想见佛菩萨等法轮光明而为灌顶。入是观时应时即授一切诸佛转法轮位。便能转于一切法轮。勿生疑念

第四诸佛业用者。经云又以金刚合掌从顶下置于心上。及真言乃至为我作金刚事业等。释曰。其秘密义者合掌归命一心思惟北方种种妙庄严世界。尽虚空界种种杂色华鬘璎珞音乐歌赞奇妙佛事而为严饰。复想一切如来及菩萨众如一切世界微尘数。广大众会而为说法。又想自身于一一如来等所承事供养等如上。尔时于三昧中一一身口意当发是愿。唯愿一切如来金刚业等诸菩萨众。以种种业用佛智光明灌于我顶。应时想见佛菩萨等以此光明而为灌顶。是时行者入是观时。便得无碍业用佛智光明三昧。能于十方一念一时广作佛事。如上次第如广经所明。此经略故随义述之。应知此法门入者甚难。若住初方及余三方。随一增上余方皆劣。若入如来部一时圆满亦无胜劣

颂云随乐四种仪除增降坏法者。经云于四方如上作法礼已随行者所欲。乃至或大菩萨半结跏趺随意作之等。释曰此门有四种差别法。今广料简。一为除灭灾害。谓行人修福多被诸恶鬼神而作障恼。令其功德福业破坏不成。欲盛建立先后俱作护摩等法。坛法者坛炉皆圆。坐亦如之。坛相白色。身居华座。其心寂静以诵真言。其柴用树半已上者。横量十指或以八指。齐头截之。木用甘果李子墙微迦耽婆木(未详)等。但有甘果树木皆充此用。有香之华及白檀香苏乳麦糗乳粥茅牙并充火用。衣着茅服。其焰相者先起赤焰次如金色。复如融金色或如灯明。时时变色。又如牛苏焰色润泽。或如辫索条列相次。有此相者当知。作法所求之愿皆得成就。又相者盛出香气炽焰无声。或焰上重焰如赤金色。或焰头分散如伞盖形。是名第一相。又声者如牛声又如螺贝雷鸣等声。又人所乐闻之声。余诸声色等应知。障碍不得成就。第二增益者。所谓行者成就三昧开发智力。尔时多有内障。烦恼所覆愚闇所遮不能进修。纵经多时勤苦不止。佛菩提智终不可得。是故应修增益护摩。增炉俱方。而作黄色。结跏趺坐于茅草(此经坐莲华坐别耳)慈心念诵欢喜顾视。衣以刍麻而作法事。其木相者取树中心肥枝如生之柴。苏乳酪蜜又乳粥酪饭胡麻稻谷。及三白食胜妙黄华龙华香等。天水香香附子天门冬尾卢婆果等。而充火用而作护摩。柴长十二指齐头截之。炉深一肘四方作之。广亦如是。起四重缘如法泥饰。此诵大愿解脱出离法。成就之相如上所说第一好相等是。第三降伏法者。谓行道之人须有威胜。彼不降伏爱乐归依法轮难转。是故应修此护摩法。坛炉俱方而作赤色。叠以双膝如贤之坐。亦可如经蹲坐臀不着地也。衣以赤服。其心超踊而诵真言。其所用木于一树中直上独生。出过余枝无横生枝。横量十二指齐头截之。应用有乳汁者。谓桑谷之类又以乳酪苏蜜及三白食及七谷种子胡麻稻谷之属。用紫檀香赤色华苏合安悉薰陆等以充火用。其相如上。又说如上所不堪之木。树上干枯无皮。短曲瘦恶经剥皮者。或太长太粗曾被斧斫破有疮病者皆不堪用。若作第四法则得用之。又说如上火恶相者。其火气冷又无润色。火星迸出其焰如烟。或焰射入灰中。又出臭气或无烟焰。又焰和烬起复入于地。有是相者当知内外人鬼障碍。或是烦恼业等诸障不灭。得是相者当须改修作前初法。若作第四法得此相者是名成就。顺恶法故。第四破坏法者。或有人言诸佛菩萨具大慈悲。云何教诸众生作斯恶法。答诸佛菩萨说此法者。为智者说不为愚人。所以然者。佛灭度后多有恶人。恃大势力顺于邪道。不信正法破灭三宝住持之相。令诸众生失涅槃眼。悲哉可愍。以此法治菩萨之心。行此法者为利益故有大功德。审观无利起于恶心损害众生获大重罪。佛所制之不令辄作。若修三昧人远离愦闹心常寂静。观于三宝性相常住。住三昧处入佛境界。成就智用作大佛事。摧坏之法自然成就。其此法者坛炉俱黑。三角为之。所用香华皆悉臭黑。柴用棘刺屈曲之木。树根傍生无枝苦恶驼骡之粪以为烧香。炉土相和充为火食。白芥子油或用脂血以为灯明。用骨发棺木等。长六七指尖头截之。着青黑衣或血涂衣。嗔怒蹲踞如经所说。而作火食。恶相现时法即成就。又案瑜伽大秘密教中说。秘密火法相应有二十种。云何为二十种。此二十种从三法出。所谓一者扇底迦。二者布瑟致迦。三者阿毗遮罗迦。能除一切罪圆满功德。身寂静不可坏。是名扇底迦(此中四法)诸愿力速成增长财命等。一切自调伏。见者皆敬念。种种相端正游行虚空中。成就雄黄等。是名布瑟致迦(此中九法)禁缚摧灭等。降伏诸难调怨家及魔鬼。是名阿毗遮罗迦(此中七法)是名二十种护摩法(此中更广一百一十种火法秘而不译)应知复说二十种炉相。若欲摄一切炉内作金刚杵相。若欲调伏恶人等炉内作莲华相。若欲除一切罪其炉圆作须作门。炉内作宝相。门亦如是。若欲种族得增长炉内作羯磨印相。谓三股十字形。若为长命色力炉内置甲。周回墙渠等。若欲积聚一切财物炉内作牙印。若欲一切善好成就处处安乐。炉内置轮形印。如车釭相。炉四边亦如轮相。如是二十种印次第置。如后坛印等。是或置种种诸印。随彼成就。又于炉外庄严相者。其炉先以绳量四肘。四边安置界道色地。或方或圆或如莲华。四面平正四门渐为阶级。门之八分画网及半月形。近门阶级处作金刚夜叉形。如法画之于炉外东面画万字胡旋子澡罐鹿皮等。南面画螺捧月刃刀马师子野猪等。西面画半月形妙发髻印牛幢印等。北面画铜磬子幡孔雀羊鸡等。复于四门以金刚印等庄严。东门安金刚热恼印。南门安金刚宝印。西门安金刚莲华印。北门安金刚唬迦罗印。又置十六大印等。四角竖柱庄严华树。如法布置供养于佛。佛金刚智大方便法能除诸恶。若有见者灭一切罪。作是法时即想自身为观世音或执金刚。复自想戴头冠。冠中有佛及金刚杵等。或复有宝随于本法令心坚固。观世音者即一切诸佛净妙法身智也。执金刚者即一切如来诸菩萨等坚固菩提心也。以六波罗蜜诸佛净戒大色而画六根清净相应。面向东方作如上法。是名最胜佛菩提扇底迦法。余法思惟准可解。若布瑟致迦用金刚宝法。若阿毗遮罗迦用金刚嗔法。复次以金刚甲摄一切法。以金刚长命药印命行者长命足力。以金刚吉祥印积集一切财物。以金刚甲印护身。用金刚成就印乘空而行。以大莲华药印成就一切财物。成就一切法坛用金刚坛印。成就一切吉祥。用金刚王印。以左手执印右手烧火。复次若欲家宅增长。以甘美木为柴及以粳米烧之。若欲一切资具圆满以七谷子或七宝等相和烧之。若欲最胜拥护用甘美木及茅草茎涂油烧之。若欲长命以甘美木及俱卢草和苏及果子等。以左手结执金则棒印。右手烧之。若欲调伏恶人用苦练棘针白芥子及墙土烧之。若以醋苦果子等烧之。一切怨者远去。若欲一切归信伏从以紫檀木及赤华烧之。若欲所使者皆依命不敢违。用苦棘木极须嗔想为之。若欲成就一切法取白芥子烧火。即得吉祥最胜。已上净除业障内外光泽法竟

次下第二入智三摩地诸佛境界实相智印法。而为颂曰

  自他欲清净　　兼除垢障法
  次入三摩地　　坚心通智法
  先持三摩耶　　次结坚智法
  见法及极喜　　字为智门法
  秘印开心殿　　摄入菩提法
  智印法身字　　坚牢菩提法
  大力秘印明　　护身摧障法
  结莲华三昧　　随乐部尊法
  想依智种子　　严成佛会法

初颂云自他欲清净者。经云行者欲自未清净及真言乃至亦自性清净等。释曰。长行经可解其义。秘密义者。先以思惟佛功德身清净境性。即了一切诸法自性清净。了一切法自性清净。故此一切清净法性入我身中。我同法性。是故清净(余可知)

颂云兼除垢障法者。经云复应思惟是诸众生。及真言乃至息心攀缘勿令散乱等。释曰。此中三段。初段长行可解。其秘密义者。佛智德藏一切如来各已成就。诸有情类皆有此藏成就。亦等愿诸如来遍皆建立为作加持。令诸有情皆得解脱。故云作是思惟能除一切障碍等。二经云。又作是念凡所障者乃至忆念菩提心等。释曰。三垢所缠实难除断。佛智菩提一念相应即便灭尽。广赞菩提心如华严等。此经所说直入直修直满直证。即于此生得如来地善巧智故。三经云。又诸世间一切众生乃至无量差别等。释曰。众生妄业所熏邪网所覆。见善知识翻成怨对。闻甘露法谤讟俱兴。造种种恶业受种种苦身。犹如工巧能成众相。自造自怖不知自致其然。如是众多故云种种妄想工巧所成无量差别

颂云次入三摩地者。经云见诸众生有如斯过。乃至勿令散乱等。释曰。余文可解。此中云阿婆颇那伽者。阿之言无。婆颇那伽者识也。三摩地平等持也。伽者身也。应云无识身平等持也。入此定者能治攀缘散乱等障。故云不应动心及身支节。唇齿俱合两目似闭。息心攀缘勿令散乱也。问曰入此定者有何利益。答曰若内识散乱外尘所牵。识随诸尘起种种妄见。随见随念即为无量诸垢之所缠缚。以是因缘沦溺生死。故以此定而止息之。又问曰。此定唯止识不起。不与世尘而相和合。如诸佛境界。出世实相百千三昧出入自在动不动等。入有不有入无不无。有无常一一即无量无量即一。而复炽然广大建立常住其中不碍不没。如是智用胜妙功德自他利行云何得之。答曰前之定门渐学大乘及小乘等。及于外道同由此定。小乘以之为毕竟。外道不深各各有异。渐学大乘者以为方便。息攀缘故。若顿入者亦不由之。一切色尘为佛事故。色相境界智所转。故智性无碍无量用故。若怖于尘境爱乐空寂智无所用。愚拙之深网也。如此之徒其类非一。或作声闻或为外道。悲哉可愍痛惜之甚。是故佛说其智慧门难解难入一切声闻辟支佛所不能知。若欲入者如下经中广宣说耳

颂云坚心通智法者。经云谛观虚空无量诸佛及真言等乃至常得随顺等。释曰。欲入智门当观智相。欲成智用加于智种。是以仰观诸佛身加唵字。唵字者佛德藏也。又以眼置么吒字令智慧明发。智慧明发故诸佛所赞。故云常得随顺等。于中可解其加持真言。秘密义者所谓佛德金刚三昧智慧眼也。以此三昧通智慧门能令智慧内外和合。谁不降伏谁不随顺故。悉帝耶等尚得随顺。悉帝耶者无情物等。共秘此名故不显说也

颂先持三昧耶者。经云作此法已即结三昧耶及真言乃至是名金刚合掌等。释曰所以结此明印。谓自智器开发与佛智同光。彼此和合一味无二故。此明印能和合之。其秘密义者名佛德金刚三昧合也。其印相如经所说可解

颂次结坚牢智者。经云又即此印诸度尽本及真言等。释曰。此明印者能成就智身。智虽和合当令成就。是故以此而加持之。秘密义者金刚三昧牢结缚也。欲令成就不可坏故

颂见法及极喜者。经云又如金刚缚及真言乃至佛子等秘印等。释曰佛我智合。复已坚牢成法界宫。自性圆满。即以明印而显发之。由明印力了见实相。此名见法三昧耶印明也。其秘密义者。三昧耶者等引也。平等引发令明了见故。萨怛梵(三合)者入我等我入等也。一性相故(下皆准此)佛以此明印加持有情。能令觉悟故名佛子

颂见法及极喜者。经云又结极喜印及真言乃至度如针是等也。释曰。由前加持了见智性。无与等故念持希有便入极喜三昧。即以明印而用加持。故名极喜三昧耶。秘密义者。萨怛梵(三合)者我入入我。护者喜跃也。苏啰多者妙极也。三昧耶者等引也。谓等引入我我入彼等喜跃妙极也。佛加持故智印印之。印如经说可解

颂字为智门法者。经云复结金刚缚印乃至为心门户等。释曰。以法界智相坚明无际将严其德。非门不从故以怛罗(二合)吒字为心门户。字性宝体光为其门。若欲开者加于智印。是故即结开门印也

颂秘印开心法者。经云三遍诵此秘明三摩心上及真言乃至有大殿堂等。释曰。印相可解其秘密义者。佛德金刚坚智印能开智宝门。怛罗吒者宝门也

颂摄入菩提法者。经云复想面前有一闇字及真言乃至句义皆自悟了等。释曰。智门开已当严智德即便摄入菩提种子。所谓闇字也。故云谛观字上遍有光明辉赫照曜也。谛想成就便当摄入。故云结金刚召入印。是印力故佛德菩提安住心殿。既安住已了了明见。犹如月轮普照法界。是名智德菩提相。其秘密义者。谓佛德金刚三昧中安菩提种也。谓明见闇字变如月轮住心殿中。其印如经所明也。犹智德菩提住心中故。故云能了过去未来现在乃至皆自悟了等也

颂云智印法身字坚牢菩提法者。经云复结金刚拳及印相乃至意密以能执持故名金刚拳等。释曰。印相法可解。其秘密义者。谓佛德金刚三昧法界智印。以印印之。由印力故能令成就法界菩提身。[金*(离-禸+ㄆ)]字法界种。相形如圆塔名法身塔。金刚拳者佛坚智相也。以佛坚智持于法身。印智菩提能令成就坚牢德藏。故名封闭心殿。乃至名金刚拳等

颂以大力印明护身摧障法者。经云复分金刚拳为二。及真言乃至皆得清净等。释曰。谓已上初净身口。次住坚智。又与菩提和合。德藏圆成故。加大力明王护身摧难故。云以此印头上右旋等如经可知

颂即结三昧耶随乐部尊法者。经云复结金刚莲华及真言乃至得为尊主等。释曰。如上结护已。随自乐为部主三昧耶印于心顶。然后念诵本部真言。经中唯有莲华部三昧耶明印。余四所无者。略故不列。若欲解者。唯改钵头摩句安金刚句宝句羯磨句法界句。即是余句皆同。思之可解。印相亦随句改之如经下文具说其相也。若乐广大观察如来实相无尽庄严藏三摩地者。应当如后次第安立善观察之。于此门下妙庄严相依智种建立佛会。而为颂曰

  妙智净内外　　依种子建立
  世界妙相法　　想诸佛所依
  成等正觉法　　如来神变相
  秘密三昧相

颂妙智净内外者。经云复次净妙智慧乃至等同虚空等。释曰六尘六识等性空为体。一切所有皆悉一如。众生执心于中对碍。欲建妙相先智除之。故云观察内外皆无所有也。自性平等无初中后。故云又观三世法等同虚空。入是空三摩地时不见身之与心。内外寂能观所观皆同一大空。若声闻种姓多者于中沉住智不起动。外道于中起恶寻求。或见有边或见无边或见非有非无边等。乃至各各别生于见等。菩萨于中智慧善巧建立种种微妙相用。入佛境界得佛加持。佛加持故于百千三昧出入无碍。即能遍至一切诸佛及诸菩萨大会之中供养礼拜咨问法义。而身心不动不没。即能遍入众生界中教化无尽诸众生类。而其身心不着不碍。若能如是心不间断正修行者。一念一时无前无后与如来等。即于此生满足佛地。法如下说随所乐为

颂依种子建立世界妙相法者。经云即于下方想有琰字。乃至既想如上诸部座已等。释曰。如上入大空三摩地已。即以决定妙智于下方空际想有琰字。黑光流布变为风轮。风轮大力持于地轮。轮皆黑色。是名风地种也。此中与毗卢遮那经文安立世界别也。应如彼说具足修行。如前想已于地轮际布列剑字。放杂色光成轮围山。名为甘露海岸也。以[金*(离-禸+ㄆ)]字法界种子字大白色悲光。想成如来毗卢遮那于虚空中名法身种也(注雨相。如经)。想钵罗(二合)字。字放金色光变为金龟广大无际吉祥种也。想[口*紇]哩字。放黄色光为黄金莲华。莲华藏种也(其相如经)想钵啰(二合)吽[金*(离-禸+ㄆ)]等三字。放杂宝色光成妙显山(旧云妙高)名坚胜法界座种也(其相如经说)今人共号为须弥座者从此立名。非是须弥卢山四宝所成者。此妙座高显犹如彼山。故以喻之。山有八面面各有门。于中空同八大菩萨常所居宫也。而诸菩萨各据一面而演说法。于其室内乃有十方诸佛微尘大会。此经略故不列。三藏教授次第具安立之。故云而有八面等。又想[金*(离-禸+ㄆ)]等五字者。谓于台上以此五字。上随位而安布之。五字放光和合共成四方大殿。于大殿中随于字位结成五峰楼阁。名为五峰大殿也。其中庄严如经广明之。乃至莫呼罗伽等王奏妙歌舞等。各于楼阁下随五字位成金刚轮漫荼罗等。一一轮内各有三种子字以为佛座。如经所明于五座中[金*(离-禸+ㄆ)]字轮中种子所变成师子座者。师子者诸兽中王。于诸兽中游行无畏。故卢舍那佛亦复如是。诸法之王于诸法中变化无碍。故据师子座也。于吽字轮中种子所变为象座者。其象力用诸兽力用无能过者。金刚部王共据其上表以坚力。无挂碍故。于怛罗字轮中种子所变为马座者。其诸世间尊贵吉祥莫先于马。马有慧用世以为宝。灌顶法王以之为座。表以灌顶具吉祥故。于缬哩(二合)字轮中种子所变孔雀座者。其诸世间以孔雀鸟而为瑞禽。此禽丽状具种种色。复有明慧善应时宜。转法轮王以之为座。表以转大法轮不非器故。于阿字轮中种子所变加楼罗座者。此鸟威力能降诸龙。诸龙所居四大海中。迦楼罗鸟随所向方龙即降伏。不空业王以之为座。表以智用。随方羯磨摄引人天一切诸龙。无不归者。谓佛菩萨随摄随归无有违者。如是次第应深知之。故云既想如上诸部座已等

颂想诸佛所依成等正觉法者。经云次想诸部一切如来及十六大菩萨乃至无碍事业巧方便智等。释曰。此一段经文安立不次也。应云于前五部座上各想有月轮。于月轮中想有微妙莲华台蕊圆具。即于师子座上月轮中想有四面毗卢遮那佛。以诸如来所持之身坐彼座上。又想阿閦鞞等四方诸佛各据本座也。及十六大菩萨并四波罗蜜施设。四种内供养四种外供养及四摄菩萨等。及贤劫千佛菩萨诸大金刚二十八部等诸神。皆以本三摩地各各想彼差别记契等。此等事相皆从毗卢遮那佛法界身圆轮光内而现。如是阿閦鞞佛诸如来等坐此未久成等正觉。悉得一切如来普贤之心。乃至获四灌顶智等(如经广说之)初云四面毗卢遮那者。释曰。所谓鑁字轮中法身如来四面圆满。向四方作三昧相也

次下颂如来神变相秘密三昧相者谓已下诸门五方如来十六菩萨四波罗蜜及内外四供养四摄诸菩萨等。一一皆有无量甚深智用智门秘密境界无碍神变三昧之相。广如下明

第一一切如来普贤金刚三昧门。颂曰

  诸佛普贤心　　秘密神变相
  亲承普教示　　授五菩提智(不别释之)

初颂诸佛普贤心者。经云尔时金刚界至秘明末。于中四门不同。一举报。二显体。三明行。四护念。经尔时毗卢遮那佛此举报也。释曰所谓行大日如来事遍满法界纯以大金刚王而共围绕以为宫殿毗卢遮那处中而住。梵云毗卢遮那。此翻最高显广眼藏如来。毗者最高显也。卢遮那者广眼也。先有翻为遍照王如来也。又有翻为大日如来此并略而名义阙也。又此如来亦名佛菩萨眼如来。亦名诸佛菩萨母。亦名诸佛菩萨最上广博清净藏也。所谓诸佛菩萨依之明见故。诸佛菩萨于中出生故。一切贤圣于中住故。又此大日如来常住。满虚空法界量微尘等诸佛身相。一一身相皆无中边。又无增减。故毗卢遮那大经说。为无尽庄严藏三昧也。经云持一切如来身以为其体。第二显体也。释曰。无缘智明遍满虚空。一切佛身即一佛身也。经即入一切如来至三摩地等。第三明行也。释曰。此中云三昧耶者正翻为等持三摩地。地者正翻为等念(旧云等至)谓遍一切处等持自智。即入一切如来智也。即入一切普贤智。持此智行犹如金刚。入有情界平等摄受而护念之故。华严经云。佛身普放大光明。色相无边极清净。如云充满一切土。处处称扬佛功德。光明所照咸欢喜。众生有苦悉除灭。各令恭敬起慈心。此是如来自在用(如彼广说)经从其至拔折罗萨埵等。此第四护念也。释曰。此中云阿毗三昧耶者。正翻为无上等持。旧翻为护念也。如金刚般若云善护念。是谓从诸佛一切普贤金刚智中出此秘明。故云无上。以此秘明加持有情令最坚牢故。秘明义者。一切有情皆是金刚也。故称拔折罗萨埵。谓修行者起大悲心以一切智愿入普贤海住有情界。复以明心三业秘密加持令诸有情住坚牢身。能如是入者。尔时行者身不至彼。亦不住此。心不住此亦不着彼。满法界量无前无后。以明智观察令无障碍。入出相用分明不滞。如是入者是名得入普贤金刚最初行海。若展转能入神变境界不滞不碍。是名入于一切如来普贤功德无尽藏海也

颂秘密神变相者。经说秘明时至既示现己等。此中智用境界不同有十二门。一依因。二显本。三应实。四显相。五显力。六还源。七显智。八示相。九明德。十显实。十一普现。十二感应。经云说秘明时从一切如来普贤之心。此第一依因也。释曰。一切诸佛现神变时非无因。故谓从如来智入普贤心。若不尔者碍而不遍。无智故有碍。无行故不遍。经云为众多月轮至菩提心已。此第二显本也。释曰。谓菩提心者万德之源众行之本。是故如来先显心相。清净圆满犹如月轮。即大菩提相也。以此心相遍有情处。诸有情类数乃无量故曰众多。一切有情遇菩提光皆得清净。故云出现普净一切众生界也。发菩提心者应如是行。若越此者非菩提心也。经云于诸佛所围绕而住。此第三应实也。释曰。诸佛菩提胜相圆满体性凝寂。离空不空。从佛心生还依佛住。以智力故不散不没也。又佛加持故不出于彼有情之心。而复等于诸佛。法界身轮周围而住。尔时诸佛菩提不增。有情菩提不减。入佛菩提应如是住。经云于月轮中至拔折罗等者。此第四显相也。释曰。佛心菩提依由智起圆凝而住表空不空。各于其中现差别智相也。故云出现一切如来种种智拔折罗也。所谓于诸轮中一一智相也。即普贤菩提轮内现五股相。不空菩提轮中金刚钩相。第三弓相。第四欢喜相。乃至十六大菩萨等各各智相。及四波罗蜜四摄四供养等。一切眷属差别之相也。如是之相皆是法界菩提。周围月轮之所出现。如是智相于诸月轮所出现者。各欲显有实相力变。又表如来智菩提业身无碍成就。令诸有情有胜修证。故如下门次第一一别明。经云以其普贤至坚牢故等。此第五显力也。释曰。谓各一切如来智菩提心有无碍用者。谓由如来普贤行遍一切处坚牢加持故。而能成就种种相用也。故云以其普贤故金刚萨埵三摩地极坚牢故也。经云如来神力故入毗卢遮那佛心至一体等。此第六还源也。释曰。所谓如上佛心菩提及与智相。本从心起还入佛心。以表相用一体性故。以佛神力出入无碍。为欲成就一智相用遍一切处。故一切智相从此建立。应知一智即一切智一切智即一智也。是故已下诸门皆云金刚萨埵三摩地极坚牢故。经云又从心流出满虚空界成立五峰光明者。此第七显智也。释曰。谓如来一心一法界智遍一切处。常光照用应世分位。现五峰光明。光明者智也。即五智门也。显法次第入有由故。五智门者初金刚三昧智。次宝印灌顶智。三清净法轮智。四羯磨妙业智。五如来法界智。此五智光即一切如来普贤藏相也。若有入者从普贤心起菩提行。入如来处住五智相。念念遍法界光明。于四威仪念持不间。是人名为常住如来法界金刚三昧也。经云时彼光至住佛掌中等。此第八示相也。释曰。谓一切如来五峰光明如法界尘数。各各体无中边。佛神力故成就坚牢五股智相。住佛掌中。此五智相从三轮生。即此三轮有十行相。一一行相皆佛智菩提之所成就。是故五峰上下十住位。此十行相摄诸有情常无动坏。是故令住如来掌中也。所以者何。欲令众生所得坚牢等此无异故。若有有情见此相者。即见如来普贤菩提三业法界常住五智秘密光明也。是人以为一切如来共所护念者也。经云复从拔折罗至世界等者。此第九明德也。释曰。如来智德无量无边差别庄严遍一切刹。谓众生无量故诸佛智德亦复无量。如是无量从一心三业。五智光生起。令破有情种种五欲。成就有情无碍五眼三身五智。故云种种色相及遍照等也。经云于光明五峰至如来身心者。此第十显实也。释曰。此诸如来三业法界身轮实智妙相无量无边。故以一切世界未为微尘。此诸世界尚不知数。况复为尘一尘一佛如是众多。一心智光遍照而住。如是观者是人得入一切诸佛现前三昧也。经云遍周法界至种种神变及成等正觉者。此第十一普现也。释曰。一切诸佛五智光明法界实相不共无碍。善巧智力普于有情等救度故。现此神变。神变者名为普现一切色身三昧。谓众生界无边无量等云海。故诸佛悲智亦遍众生界如云海。随彼彼众生类自在转故。故云种种神变及成等正觉也。如是种种神变皆是如来平等性智五峰光明法界实相之所成就也。佛子修行者亦如是入。经云能令众生至悉地智者。此第十二感应也。释曰。由佛神力应众生心。一切众生感而自发也。经云能令众生发菩提心者。普贤菩提遍摄受故。能令众生成就普贤无量行愿者。普贤行海遍成就故。能令众生奉事。一切如来眷属者。于善知识悉遍求故。能令众生趣向大菩提道场者。于诸佛会念念入故。复能摧伏一切诸魔者。成就大智自在力故。速悟一切平等性智证大菩提者。佛功德藏悉圆满故。转正法轮教化成就无量众生者。转化转化不断绝故。令入如来神通最上悉地智者。一切众生成就大智等佛力故。故云最上悉地。悉地者此云成就。成就如来最胜智故。所谓众生性欲种种差别。如来示现最上神变成就之相。欲令众生皆自觉知具足已有诸佛普贤无尽功德庄严藏海。或有众生。于佛法中见说诸法空无所有。不解佛意即为已得已证已满。有因缘时闻佛说此实相宝藏。心怀怯怖惊愕疾走。犹如穷子佣赁展转遇到父舍。住立门侧遥见其父踞师子床。宝机承足。诸婆罗门刹利居士皆恭敬围绕。以真珠璎珞价直千万庄严其身。吏民僮仆手执白拂侍立左右。覆以宝帐出内取与。有如是等种种严饰。威德特尊。穷子见父有大力势。即怀恐怖悔来至此窃作是念。此或是王或是王等。非我佣力得物之处。或有众生闻佛说有庄严智藏实相境界。虽知此说不解佛意由不欣乐。犹如长者语穷子言。我今多有金银珍宝仓库盈溢。其中多少所应取与。汝悉知之。我心如是当体此意。所以者何今我与汝便为不异。宜加用心无令漏失。尔时穷子即授教敕领知众物金银珍宝及诸库藏。而无希取一食之意。然其所止故在本处下劣之心亦未能舍。或有众生闻佛说此无量智慧实相宝藏。便自思惟作是念言。诸佛既有我应可得如经云父知子意渐以通泰成就大志自鄙先心。乃至广说。今我所有一切财物皆是子有。先所出内是子所知。如法华经广说。或有众生闻佛所说。如是秘藏更无疑念。日夜精勤专心修习一切诸佛秘密宝藏希有神变。念念观察无前无后。一时遍入佛普贤海自在无碍游戏神通。如彼长者顿止一城造立舍宅。五欲自娱乃至广说。如上四种众生。初二谓二乘种姓。第三谓渐次回心入大乘者。第四一门谓从初发心便成正觉。常住佛乘智用无碍。能于十方作大佛事。是人即名真住佛乘入佛位者。故梵网云。众生受佛戒即入诸佛位。位同大觉。已真是诸佛子

颂云现受教指者。经从既示现已至悉地果故等。此中智用。出入不同义分为六。一摄相。二还源。三现请。四念应。五现法。六显益。经既示现已为普贤故金刚萨埵至菩提萨埵身。此第一摄相也。释曰。谓大日如来普贤身心三摩地轮遍空尘界。其中有情即与如来智光明相和合一味。故梵网云。一切众生皆有佛性。一切诸意识色心。是情是心皆入佛性戒中。如是有情亦名为佛亦不名佛。功德智慧未明显故。亦名普贤亦非普贤。随分行愿未淳醲故。名为有情亦非有情。如来藏性生缺减故。又普贤神力合无量身为一体相。一切众生不出不没。住佛心时亦复如是。故云为普贤故及萨埵身等。经云住毗卢遮那佛心至偈末等。此第二还源也。释曰。此普贤菩萨现住佛心者有二意。一表知普贤即是毗卢遮那。二令诸有情觉知自身不离佛心。如是觉已当作此念。云何我等于佛心中造种种恶业。是故一切众生皆是一切如来普贤神力而持摄之。乃至如经说偈现萨埵身等。思之可解。经云尔时普贤至请教示等。此第三现请也。释曰。谓普贤菩萨住佛心中得佛加持。佛加持故从心出现。住月轮中。月轮者菩提心相也。表以菩提心即为法界故。即一切有情普贤菩提心之所摄持。为诸有情请佛教示也。普贤授教一切有情亦复如是。故梵网云微尘菩萨众由是成正觉。经尔时世尊毗卢遮那入至三摩地已者。此第四念应也。释曰。谓如来设教皆不非量。欲令普贤及诸有情具一切智故。先入此三昧令其所应。故云入一切如来智三昧耶金刚三摩地。谓以诸佛等持之智护念有情。入是智三昧耶已现调伏事。经云现一切如来尸罗乃至大智三摩地等。此第五现法也。释曰。所谓此现法者是法名为大方便力精进大智三摩地也。其中具有一切如来十波罗蜜诸力不共等。以诸行次第戒为首。故先举尸罗也。又此尸罗佛相授。故云现一切如来尸罗等持也。所谓一切如来等持此戒。此戒光明等持众生。一切众生即从此戒发生定慧。定慧发故便能解脱。解脱知见。知见无碍故转正法轮。于是利益无尽众生界。故云大智三摩地等。经云尽一切众生界至悉地果故等。第六显益也。释曰。谓一切众生得利益者。皆是如来等持智力。普贤菩萨普现色身三昧之力。此三昧力故尽众生界随彼彼类应现其身而得自在力用。故云尽一切众生界为自在救护主。皆令安住所乐之门。故云令得一切安乐悦意受用故。又令成就一切智果故。云乃至得一切如来平等性智神通摩诃衍那阿毗三昧耶。此具梵音。正翻应言大乘无上等持。所谓等持无上大乘护念众生。一切众生如佛住。故云克获最上悉地果故等

颂云授五菩提智者。经云尔时一切如来至复持金刚等。此一段意者。欲令众生具足如来普贤菩提心金刚法界秘密神变实相智印无尽庄严藏故。以五智印三昧耶灌普贤顶及一切众生。授以智印。五智印者。一金刚智三昧。二宝印智三昧。三法轮智三昧。四羯磨智三昧。五一切如来法界智三昧。经尔时一切如来为欲授彼悉地拔折罗故与普贤大菩萨。此第一金刚智三昧也。释曰。谓一切诸法自性清净无诸垢染。以此智印决定印之。满法界相圆凝坚牢不可动坏。入此三昧者名为诸佛普贤菩提金刚智印净法界轮。若先入此一切智业金刚三昧。一切所作随所堪任。犹如白素诸色之本。修此三昧亦复如是。诸佛智用功德依之建立。经云受一切如来转法轮位。此位名转法轮智三昧也。释曰。从金刚三昧即授法轮位。此超胜也。但授此法轮位即具足一切法故。是故其次即云以一切如来宝冠缯彩而授与灌顶。此即法身灌顶相也。据实相般若经次第。亦初金刚三昧。次即法轮。若不授与法轮三昧不堪展转为教授主。若有菩萨具大乘见。通达方便善巧业用。不要次第一一别授。审察堪任即应为作传法灌顶教示。犹如世尊教示普贤。当如是知。经既灌顶已至偈末。此第四羯磨智也。释曰。谓一切加持威德智用皆名羯磨。故云既灌顶已而授与之乃至号为执金刚。是名加持也。既加持已威德智用出过一切。故云尔时执金刚菩萨屈其左臂。乃至唱偈以我金刚复持金刚等。所谓普贤菩萨具足智力能转法轮。是故如来以五智印而授与之。此五智印具足五相。所谓五股也。其中一股如来法界。其余四股各属所部。如上所说五智印门。一一复别五相灌顶之法。一者光明灌顶。谓诸佛菩萨放光加持也。二者甘露灌顶谓以教主真言加持香水也。三者种子灌顶。谓部尊字门想布身心。四者智印灌顶。谓部主所执持印契加持。五者句义灌顶。谓部尊真言及思中义理想布身心。能解如是甚深次第。想念运用加持自他。是人堪授大阿阇梨位也。如灌顶门所说。题云此是金刚萨埵三摩地一切如来菩提智第一。释曰。此题目也。梵本皆列于后。谓一切如来等持有情。金刚菩提不动智轮也。具足正题应如是说

第二金刚不空王大菩萨钩召三昧门。述此意者。所谓一切诸法体性空寂。诸佛妙智依空而转自在无碍。一切建立及不建立依空不空。智相常住犹如虚空。遍一切处。照用无歇故。大空自在。无智无用无缘无依。为智所依。智唯实相空非实相。空性唯空无所得故。妙智不空善巧用故。是以大日如来以一切智现其智相名不空王也。极智妙相空称之为王。此意者。欲令众生具无碍智。而于空有不滞不碍。以五智相屈曲如钩。能钩众生出空有海。能钩诸佛圣智入众生心。一切诸佛共加持故。若有菩萨作佛事时。执持此钩往于十方界。诸佛菩萨如风疾至无能违者。若人持者持如来智。若人见者见如来智。有能观想此契相者。是人速得一切如来大自在智甚深三昧。此智印力随心摄召。皆悉成就一切如来及菩萨等所有三昧。以此智印普用摄持。无前无后一时满足。是人即能受用诸佛及菩萨等无碍智力。是人即得无尽庄严秘密之藏。入此门者生决定心无疑惑心发希有心。何以故。一切如来智愿加持所成就故

次下随文释意大分有四。而为颂曰

  如来不空心　　秘密神变相
  亲承请教示　　现授菩提钩

初颂如来不空心者。经云尔时世尊及秘明等。此中义分有四。一举报。二显体。三明行。四护念。经尔时世尊毗卢遮那此第一举报及显体也。此文略。具足应云尔时金刚界毗卢遮那佛持一切如来身以为其体(如普贤观所列)阿阇梨集此经意务取行取相广本重者皆略而不出。毗卢遮那佛如前已释。后亦准之。经复入不空王大菩萨至三摩地已。第三明行也。释曰。此中云三昧耶及三摩地如前已释。后亦如是。所谓如来先入普贤心又入不空智。故云复入也。如来智相遍洽微尘身心。微尘身心一身心故。此一复入一切。一切皆入此一。显发智用自在无碍故云所生。加持者。谓从不空王智现其钩相加持有情故。经云从其心出。及拔折罗啰阇等。此第四护念也。释曰。谓从不空王大菩萨心现召请相。此召请相不离佛心。故云名一切如来心等。菩萨及钩皆佛心故。而此佛心坚过金刚。故说秘明云金刚王。金刚王者梵云拔折罗啰阇也。以此秘明护念有情。一切有情住坚牢心

颂秘密神变相者。经从说此秘明时至种种神变等事已。此中行相如普贤观。出入相同。文略无者准上可知。今如前建立随略而释。经说此秘明时从一切如来心即彼薄伽梵执金刚。此因本二段文也。释曰。前观中普贤菩萨从佛心出成执金刚身。故此观中以佛心金刚为因本。故云即彼薄伽梵执金刚也。薄伽梵此正翻为世尊也。具足正翻应云说秘明时从一切如来世尊执金刚心也。谓此不空王大菩萨从彼一切如来金刚心出故。经云为一切如来众多大钩出已者。此应实显相二段文也。此中无月轮围绕住等者。前门已说。云于诸佛所围绕而住。故此略而不具。但云从一切如来心即彼薄伽梵执金刚也。故前门云于月轮中出。即此执金刚即是普贤遍一切处菩提心轮执金刚也。种种智者。此中云一切如来众多大钩者。即种种智中之一智。一智即种种智也。应知此钩亦在月轮中现。已下诸门准知。经云还同一体入毗卢遮那佛心。此显力还源也。释曰。此中无以其普贤故金刚萨埵三摩地极坚牢故者略也。上门已说此准知。下亦如是。皆有如来普贤金刚威神力也。还源者谓此钩本依佛心出还入佛心。欲显此钩是如来心故。经云为金刚钩住佛掌中。此示相也。释曰。此段文略应具足云又从心出满虚空界成金刚光明时彼光明化为一切如来金刚身语意所成金刚钩住佛掌中。唯有下句为金刚钩住佛掌中。满虚空明等准上门应知。下门亦如是。有能入此钩三摩地者。应如上次第还入佛心。又从心出满虚空界。光明化如来三轮钩。住佛掌中。如是观者是名入钩三摩地。即得如来召请诸佛智印加持。经云复从钩中出现一切世界至神变等事已者。此段亦略。准上应知。义亦如上。入此观者普现色身也。已下诸门亦皆准知。若入此普现色身观。能令众生发菩提心等感应之行。略而不说。准如上门皆悉具有。下门亦然

颂曰现授教旨相者。经从出不空王故至增上悉地果故等。此中入出不同义分为五。由不空王故及金刚萨埵乃至大菩萨身。此第一摄相也。释曰。谓如来实相智印神变无碍故曰不空。即此智印诸智中胜故称为王。以此智王护念众生。令诸众生受胜安乐。是智至处无能坏者故曰坚牢。以坚牢智摄诸众生为一身相。其中众生入出不碍。住一身中各令所安不觉不知。唯是菩萨了了知见。若有智者住此三昧亦复如是。即能摄受行利益事。经云住于毗卢遮那佛心至偈末等。此第二还源也。释曰。不空王住佛心时一切众生亦住佛心。此一不空王住佛心时。一切世界微尘等不空王皆住佛心中。如梵网经云各接微尘众俱来至我所。即其相也。说此偈言等如经思之可解。经时彼不空王至复请教示。此第三现请也。释曰。谓不空王大菩萨住前所现普贤菩萨周围月轮。为诸有情请佛教示。此一不空王请时彼彼一切世界微尘不空王亦如是请。此中阙感应文。如前门所说更不复出。后亦准之。经尔时世尊入一切如来至为一切如来钩召三摩耶等。此第四现法也。释曰。所谓此法门名一切如来金刚加持钩召。故云钩召三昧耶。此钩从普贤金刚五智印转转现。故能广利益诸有情界也。经尽众生界摄召一切至悉地果故等。此第五显益也。释曰。谓五智印钩召等持力一切如来加持故。若有持念此三昧耶。一切如来及菩萨众一时集会。随彼彼念为作利益。故云悦意受用等。若有众生从初发心与诸如来普贤菩萨等量发者。如是菩萨即是如来。由心等故。诸佛加持。由加持故于佛法界五智印上更增上妙智。广大自在故云增上悉地果

颂授智菩提钩者。经从以金刚钩授彼乃至偈末等。释曰。此中授灌顶法具光明等五种。如前门所列。此中略有二相。余三隐而不出。但作即具用为之。二相者所谓智印及钩。即名号而与灌顶等也。时不空王受此钩已诸佛随集。故云以彼金刚钩召请一切如来已。众生受者亦复如是。有见闻者诸罪消灭圣贤护念。若非授而辄受持求悉地者。于如来智自在力用即不成就。是故佛言是人盗法被诸鬼神之所损坏。说此偈言等如经可解。经此是不空王大菩萨三昧耶一切如来钩召智。第二此题目也。正翻应云一切如来钩召智等持不空王大菩萨观门。义如上释

第三一切如来摩罗大菩萨三昧耶智印实相门。述此意者。谓如来悲智甚深微密。亘无尽界违顺染净。是故如来现其智相名曰摩罗能令乐染净者不得自在。摩罗者具足梵音云摩烂拏。此正翻为杀者。如其智印。所谓弓箭。谓或有菩萨成等正觉。住清净处不乐随于杂染世界成就众生。以此智印力能击射。摄之不令久住。故以染智摄彼净智。故名杀者。或有菩萨发广大心作大佛事。有佛菩萨住于自宫不助其力。而此菩萨即以此智印向弹击之。彼佛菩萨便当随喜而共加持。佛智神力无有违者。此即杀净而顺染也。又诸众生恒为一切烦恼坚牢染缚。而不信受佛清净法。尔时菩萨以此智印而击射之。彼所坚缚即便破坏。以清净法而用染之。一切众生以是因缘开示悟入佛之知见。此即杀染而顺净也。是故如来以摩罗智于染于净皆能染净也。又此次第者。谓入初普贤金刚三昧耶遍能观察一切如来。遍能了知诸佛境界得不空智。尔时如来便以智印而用加持。得加持已便能集会一切如来及诸如来无尽智藏。严自智界作大佛事。便能承事一切如来。而诸如来护念不舍。是以染智据次而说。如是次第皆是如来普贤金刚三昧智用。一合实相甚深境界。以声字相次故别转耳。后后所说准应知之。次下释文颂曰

  如来奉事心　　秘密神变相
  现请教旨者　　授菩提弓箭

如来奉事心者。经云尔时世尊复入及拔折啰逻伽等。释曰。谓从普贤菩萨菩提金刚三昧入佛境界。加持众生相续便入不空王相。而作佛事。转住即入此奉事门。故云复入等。如上准知。言奉事及染爱者。谓奉事如来及以众生。以奉事如来故如来爱乐。以奉持众生故众生离苦。又谓由染爱如来故如来护念。由染爱众生故众生解脱。是以名为染爱之智。故说秘明云拔折啰逻伽也。秘密义者谓金刚爱染奉持也

颂曰秘密神变相者。经从说此秘明时至神变佛事已等。释曰。此中神变入出合散皆如普贤金刚行相耳。唯此中契相别者。所谓华器仗弓箭等。是如来弹击智也。其契两头皆有莲华故云华器仗。华器仗即是弓箭也。此智犹如主立弹官弹击非法。谓二乘乐寂自谓究竟。此非法也。菩萨位地悲智不等。此非法也。一切众生常乐诸欲习诸邪道。此非法也。乃至假使有佛及一切贤圣悲智不等。皆是非法也。是故大日如来现此智相。令诸菩萨习正行者持此智印承事诸佛。摄受众生随意无碍

颂曰现请教旨相者。经从由至极杀故至最胜悉地果故等。释曰。谓以诸佛境界入众生界。和合为一成妙智相。在左月轮为诸众生现请因缘。故云为摩罗大菩萨身。而此大菩萨善巧智相奉事如来。如来虽已离于爱染。由善巧故诸佛爱念。如世恩爱不相舍离。故摄为一体。住于自心说调伏偈。如经可解。次菩萨出现请教示相。如来复入念其所应。乃至一切获得胜益故云最胜悉地果故等。此中句义已如上释。更不繁词也。依经思之可解耳

颂授菩提弓箭者。经彼金刚弓箭乃至一切安乐等。释曰。灌顶之法略如前释。授此智相而说偈等者。欲令菩萨及诸有情见闻此法。受持修行不生疑碍。故云此是诸佛无垢染智能以染爱染离爱者。悉能授与一切安乐。是名弹击智印。即弓箭之表也。乃至题目法义准知

第四一切如来善哉智金刚踊跃大菩萨三昧门。述此意者。所谓诸法智性空寂清净。一切如来以此智道纲纪有情。而诸圣贤未达源际以为差别。纵其入者太过。即空见之甚也。其未入者不及。即愚凡之极也。而此二辈行虽殊异太过不及。皆来入故于诸如来功德智藏不生忻乐亦不称叹。大智明见愍斯辈故现此智相。名曰善哉。遇斯光者便生踊跃。故号此智名欢喜王。其次第者。谓成就如来普贤菩提金刚智藏钩弓神变妙庄严相。彼无智住空者。纵令得见皆不随喜亦不称叹。故佛诃言如盲如聋。所以如来大智善巧力故为利斯辈现善哉智。灌菩萨顶及诸众生。若入功德门者持此法印而称秘明。一切诸佛无不称善者。佛称善故彼住空者虽不喜乐亦皆称善。以称善因缘渐当觉悟。由一切圣贤称叹故其修行者踊跃无量。故以渐次第四而说。即此第四智。即前普贤金刚三昧一切用智其中秘密神变境界。更亦不别列。以一相故应知

次下释文文有四门而为颂曰

  如来欢喜心　　秘密神变相
  现请教旨故　　授彼善哉智

经尔时世尊复入欢喜王至娑度等者。此如来欢喜心也。释曰。谓从前三昧出又入此欢喜王三昧。故言复入也。三摩耶等持义如上释。秘明云拔折罗娑度。正翻为金刚善哉。此声句遍加持故能破不善入善品中。彼不欢喜者皆生欢喜故称金刚善哉。此善哉智极坚牢故

经说此秘明时至神变等事已等者。此秘密神变相也。此中行相一如普贤观法

经以极欢喜故金刚萨埵至悉地果故等者。此现请教旨故也。其中出入行相皆如前已释。此中云无上踊跃最胜味者。谓彼住空之类愚下之徒。如来善巧现斯智相。随彼彼类令生欢喜。由欢喜故获殊胜加持。以是因缘得入如来功德藏海。此是诸佛味故。故云无上踊跃最上味也

经以金刚欢喜授彼至偈末等者。此授彼善哉智也。谓此菩萨以得灌顶智。此灌顶智者从佛普贤金刚心所出生。无退住相故曰金刚踊跃也。佛加持故便说偈言。如经所说可解。下所题目准上应知。次结云已上四菩萨并是金刚部中金刚方。阿閦佛眷属都号为一切如来大三昧耶萨埵。谓此四菩萨住东方金刚界不动如来所前后左右。于菩提轮内现神变已围绕而住。此谓一切如来菩提四智相金刚轮。此菩提轮遍周法界。同而不同纯金刚相而为严饰。内外供养及四摄等皆于其中严持而住。所以此经先东方者。谓起作之初门应物之源序故。诸佛说法先照东方次及余方。如日初出东方先明次照余方一切皆明。又如四洲众生但日出处皆呼为东。东者最初之义。非世方分之称也。此金刚菩提三昧亦复如是。欲入佛法海者皆从此入。便以智入如来境界。此金刚三昧能破坏非法。能成就正法能除灭障碍。能坚牢法界。以无碍智运转观察。无前无后。入此金刚法界相妙庄严藏如前所说令其成就。既成就已复入如来虚空藏三昧。下次第说

  为报佛恩祖德谨开印板传之来叶矣

      正应四年(辛卯)七月十八日

                        沙门庆贺

      高野山于往生院

                宝藏院开板之


金刚经纂要刊定记

    No. 1702 [cf. Nos. 235, 1701]

    金刚经纂要刊定记并序

释氏教。金刚经世所由来尚矣。自秦至今凡几百载。讽诵无卑高。感应盈简牍。利及幽坏而达乎神明。盖趣大之坦涂。破小之宏略也。故补处颂以为本。二论释而有贯。诸疏互解或依或违。圭山大师。撮掇精英黜逐浮伪。命曰纂要。盖取中庸。复申记略。用备传习。石壁师。仍贯义意别为广录。美则美矣辞或繁长。后学多不便用。今更刊定翦削烦乱。俾流而无滞学而思讲。庶吾道无坠地之患也已大宋天圣纪号之明年。季冬月甲子日。序云

金刚经纂要刊定记卷第一

        长水沙门子璇录

疏文分三。初标题目二。初经疏名题。金刚般若经疏论纂要者。此题九字从宽至狭能所六重。一能所释。谓金刚等五字是所。疏论下四字属能二能所诠。谓经字属能。金刚等四字是所。三能所简有二。一简通。谓经通一代时教。般若唯局当部。二简别。般若犹通八部。金刚但属一经。五能所喻。金刚是能。般若属所。六能所纂。纂字属能。谓疏主也要字是所。谓正义也。若着并序二字。复加一重。二字是能。上皆所摄。然此七重不出教行人理。谓经及疏论并序五字是教。谓能诠能释能序也。般若通行谓观照也。纂字属人。疏主也。金刚要字属理。金刚喻实相。即真理。要字是正义。即道理。既知一题能所去着。须知题内义理浅深。金刚有三义。谓坚利明也。般若亦三义。谓实相观照文字也。经有三义。谓常贯摄也。疏亦三义。谓疏决布也。论者议也。亦三义。谓议理议智议行也。纂要亦三义。谓要义要行要文也。且金刚三义者。以万物。不能坏能坏于万物。复能有照用。可喻三种般若矣。坚喻实相。以其虽经多劫流迸六道。未尝生灭未尝亏缺。故云坚也。故心经云。是诸法空相不生不灭不垢不净不增不减等。利喻观照般若。谓此显时照诸法空。故言利也。故心经云。观自在菩萨。行深般若波罗蜜多时。照见五蕴皆空。度一切苦厄。乃至云无智亦无得等。明喻文字般若。以文字能诠显彰。明实相观照令显现故。由斯三义似彼金刚。故举金刚以喻般若。然此般若诸佛众生悉皆有之。由彼在缠故不能利用。苟能闻教解悟内外熏力。则能断烦恼出生死。理智相冥能起大用与佛无异。其犹金在矿中不能随用。苟能出矿必能成器断物。故知此慧无不有之。故知此慧能建大义。今云般若盖大慧之梵音也。金刚即般若之正喻。法喻双彰故曰金刚般若也。若准经题。具足合云波罗蜜。即叹慧之功也。唐言彼岸到。此犹西域之风。若顺此方合云到彼岸。彼岸者即是涅槃。为对生死之此故。号涅槃为彼。意明般若是到彼岸慧。斯则慧之别相也。然到彼岸慧略有二意。所谓顿渐也。顿者。此慧显时。一刹那间照诸法空。即是到彼岸故。名到彼岸慧。以不历多时乃名为顿。渐者虽则顿照法空。且习以性成任运计执。所以策彼顿悟之慧。觉察妄情。损之又损之以至于无为。此则究竟到于彼岸亦名到彼岸慧。以历多时故名为渐。渐之与顿迟速虽殊。一种得名到彼岸慧。所以具足合云金刚般若波罗蜜。今略不言也。次明经字具三义者。然准诸家解释共有多义。谓涌泉出生绳墨结鬘之类。若佛地论中唯说二义。谓贯也摄也贯穿所应说义。摄持所化众生。且如来入灭二千余年遗风若存。得闻正法者。斯皆经之贯穿之义也。众生流浪莫知所从。得佛教门咸归正趣者。斯皆经之摄持之义也。具此二义故名为经。今以此二复加常义。以对三种般若。谓实相常观照贯文字摄也。然此一经罗什所译。句偈清润令人乐闻。至今长幼高卑盈于寰宇。靡不受持此经也。疏论纂要者。即此一卷疏文也。疏即青龙大云资圣尘外等疏。疏谓疏通理趣决择义相布致文言也。论即天亲无著智度。金刚仙功德施等论。一一论中任运议于理智行也。问既有疏论释经。何必更制斯疏。答以纂要故。即是纂他疏论之要义。而成此疏也。然纂要之设总有两意。一则上符圣旨。二则下协人心。意显诸说有不符圣旨不协人心者。且初意者。只如此经是空无相宗。有以法相行位广列而释。此则不符圣旨。失于宗故。故序云。或配入名相着事乖宗。有人闻是空宗便作一味无相道理解释。此亦不符圣旨。以宗虽无相义乃千端。既以一味解释。此则迷于末也。故序云。或但云一真望源迷泒。前则乖宗不迷泒。此则迷泒不乖宗。互有得失俱未圆畅。复有纵于僻见以之注释。宗泒俱失不足评量。故序云。其余胸谈臆注不足论矣。然其诸说虽各有舛的。以未兼畅故。皆判云不符圣旨也。今制此疏不添法相免乖于宗。随文释之不迷于泒。离前二过宛乎得中。此则超然独符圣旨。然今疏内皆用圣言。故序云。故今所述不攻异端。疏是论文乳非城内。况二菩萨师补处尊。补处如来师释迦佛。展转推本佛佛相承。降及无著天亲更无异说。故知此疏便是佛言。谤此疏者即同谤佛也。故序云。且天亲无著师补处尊。后学何疑。或添或弃。次下协人心者。且诸家章疏在理未当于文且繁。致令学人少敢措意。故转念者广通会者稀。故序云。致使口讽牛毛心通麟角。然今此疏撮其枢要直下销经。经疏相兼盈五十纸。不问缁侣尘俗可以留心。不唯上中下根可以学习。有斯两意所以述之。此则前智后悲。自他兼利也。故云金刚般若经疏论纂要。并序者。并谓共兼及也。序者叙也。叙述经疏之意故。又序者绪也。谓头绪也。意明此半纸之言是述疏入作之头绪也。二作者嘉号。京者都也大也。即士庶贵贱都会之大处也。然是西京非谓东北。以有大兴福寺。闇拣故不言西也。沙门梵语此云勤息。即释众之通号。谓勤修诸行息烦恼故。述者明非制作。符上纂要之言。但是叙述先圣之旨。非别制作故也。例如夫子云。述而不作信而好古。窃比于我老彭。二序宗旨二。一序赞经旨二。一通明起教之缘二。一明迷真起妄二。一真空。言镜心等者。以要言之。上句即真。性离缘。下句即缘无自性。大约如此。若其委明应先略配后当广释略配者。此两句中镜像是喻。心色是法。本净元空通于法喻。以镜喻于心。以像喻于色。像是镜之所现。如色是心之所现。镜虽现像其像元空。即显镜本净也。心虽现色其色元空。即显心本净也。言本净者即是性净。通因果凡圣故。故华严云。非识所能识。亦非心境界。其性本清净。开示诸群生。此略指配也。若广释者。镜即人间所用之镜。然有尘薶不堪用者。有虽净而在匣者。有净无尘垢挂之高台万像斯鉴者。今取后者为喻。心者性相二宗所说各异。相宗说者。或以集起为心。唯第八识集诸种子起现行故。或以缘虑为心。通于八识俱能缘虑自分境故。然此所说但是有为生灭。非今所喻。性宗说者。即如来藏。本源自性清净心也。然今所明正是此心。以是迷悟根本凡圣通依世出世间皆不离此。所以起信论中立为大乘法体。故论云。摩诃衍者。一法二义。所言法者谓众生心。是心则摄一切世间出世间法。依于此心显示摩诃衍义。又云依一心法有二种门。一者心真如门。二者心生灭门。是二种门皆各总摄一切法。此义云何。以是二门不相离故。以真如门是通相故摄一切。生灭门虽是别相。以是即真如之生灭。亦摄一切。以此二门同依一心为源。则知万法不出此心。又如华严是圆极一乘。亦以此心。为一真法界之体。故彼疏说。统四法界为一真法界。谓寂寥虚旷冲深包博。总该万有即是一心。体绝有无相非生灭。乃至云。诸佛证此妙觉圆明。现成菩提为物开示等。然此一心有性有相。相则凡圣迷悟因果染净等异。性则灵灵不昧了了常知。然此性相不即不离。以相不离性故。只向同处异。性不离相故。只于异处同。性不即相故。未始有差别。相不即性故。未尝不殊异。盖缘性相一味。所以同异两存。其犹一水波湿。性相同异可知。然此灵心本非一切。能为一切心之名字亦由此立。今云净者但约毕竟空义。非是拣染名净。以但唯一心。贯通染净故。荷泽云。知之一字众妙之门。一切诸法依此建立。既为得失之秘府。乃是升降之玄枢。称众沙门实为至矣。今所辨者即是此心。然前所说相宗二种。乃是此心之内生灭一门。对辨浅深故须料拣。和会通摄则实无所遗。本净者喻则可知。法中有二意。一则此心从本已来。性毕竟空故。二则现为烦恼所缠而无染故。此当起信论中真如门也。故大集经云。善男子。一切众生心性本净。心本净故。烦恼诸结不能染着。犹如虚空不可玷污。心性空性等无有二等。像即镜中所现万像。色即本净之心所现诸法。然所现法不出色心。今唯言色而不言心者。一为文句窄故。二为影在下故。三为以初摄后故。前二可知。后意者一切诸法不出五蕴。色之一字贯五之初。今言色者举初摄后也。故大般若中。每例诸法皆以色字为初。如云善现般若波罗蜜多清净故色清净。色清净故一切智智清净等。由是文虽标色而意兼于心。色心既彰万法备矣。元空者喻则可知。法中有二意。一即本来是空。论云。一切诸法唯依妄念而有差别。若离心念则无一切境界之相。二即现见空。故色等诸法本来自空。迷人不知妄执为有。虽然执有未始不空。故中论云。诸法若不空即无道无果。又云。以有空义故一切法得成。然此一句亦是释疑。恐人闻说心性本净。复见论云是心则摄世间法等。便谓本具染等不合言净故。下句释云像色元空也。意云色等若实则污净心。色等既空凭何污心。如镜现秽像。秽像元空似有实无。云何染污。故云镜心本净像色元空也。无上依经云。清净有二义。一者自性清净。是其通相。二者离垢清净。是其别相。宝性论中亦有二义。一自性清净。谓性净解脱。二离垢清净。谓障尽解脱。魏译唯识论云。心有二种。一者相应心。所谓一切烦恼受想行等。二者不相应心。所谓第一义谛常住不变。自性清净心也。今所明者。即自性清净。及第一义谛心。故云本净。复次两句更互释成。以上句释下句。成色空义。以下句释上句。成心净义。色若不空心则不净。心若不净色即不空。由心净故色空。由色空故心净。以色心二法不相离故。当知由心净故方能现色。如镜净故方能现像。染则不能。又由色空故不能染心。如像空故不能污镜实则污也。上句下句法喻对明反覆相成。故云互释。疏梦识下二明妄有。即正当起信论中心生灭门。然此亦具法喻。以梦喻识。以梦中所现之物喻境。如人睡后作梦于无物处见物。喻心迷成识于无境处见境。然虽物依梦现。而梦物皆虚。虽境从识生。而识境俱妄也。梦者如常。人被睡盖所覆。心识昧略恍忽成梦。准切韵中。梦者心乱之貌。亦云寐见曰梦。意明心识昏乱见于异事。名之为梦。识者本净。一心忽然不觉。不觉是妄心性乃真。真妄和合目之为识。即是第八阿梨耶识也。故起信云。依如来藏故有生灭心所谓不生不灭。与生灭和合非一非异。名阿梨耶识。无初者初始也。意明此识无前际故。然真心妄识虽虚实有殊。若究其源俱无初际。然有两意。一则如佛顶经说。烦恼菩提二俱无始。谓自有此真心已来。便有此妄识。非谓真先妄后。亦非妄先真后。若言真先妄后。即应诸佛更起无明。若言妄先真后。何有无真之妄居然独立。由是故知二俱无始。此则梦喻不齐。却似金之与矿。若言矿先金后。即合所弃之矿炼之得金。若言金先矿后。应可纯净金器重生于矿。由是二物俱无初际。于法可知。问如论云。依如来藏故有生灭心。既言依真有妄。则是妄后真先。何得说之二俱无始。答不然。所言依者。明妄无自体依真而成。显本末之义。非先后之义。故起信云。以如来藏无前际故。无明之相亦无有始。若说三界外更有众生始起者。即是外道经说。二者谓妄体全空。都无生起之踪迹。故言妄无始也。故起信云。觉心初起心无初相即斯义也。若据此意梦喻正同。以梦生时无踪迹故。有兹两意。故云妄无初也。然上梦矿二喻之中。各取少分共况一识。无初之义方尽其理。梦则喻无初法。矿则喻无初时。若单用矿喻。则妄识有实。若唯取梦喻。则妄识有始。今既分取相似之处理极成矣。物者即梦中所现之物也。境者即是识中所变我法等境。成有者。且如梦中所见自他境界。觉来反想即定是无。正在梦时决定为有。若不然者。何有赞喜谤嗔厌苦欣乐等事耶。故知有也。如庄子中说。庄周梦为蝴蝶。都来妄却庄周。及乎睡觉梦除。何曾更有蝴蝶。为庄周时既不羡蝴蝶。为蝴蝶时亦不羡庄周。彼此各行互不相识。然准彼书意。以显生死齐平。今之所引意明执实之义。谓依于妄识。变起我法等相。悟来了达则诚知是空。若正迷时定执为有。若不然者。何有贪嗔爱恶取舍等事耶。故知是有。故成唯识论云。依识所变妄见我法。犹如幻梦。幻梦力故心似种种外境相现。缘此执为实有外境。然虽梦中见种种事。推其根本唯一梦心。以梦心灭时梦事皆灭。法中亦尔。境虽无量原其根本唯一识心。识心灭时境界随灭。故起信论云。一切诸法唯依妄念而有差别。若离心念。即无一切境界之相。则知三界唯心万法唯识。谅不虚哉。由是三界世间。一切有漏染法。皆从妄识而生。故名此识以为妄本。然一切有漏染法。生起微着次第。总有两重。一无始根本。二展转枝末。展转枝末即后逐妄科中所明。无始根本正当此段。言根本者即根本无明。言无明者。谓无妙觉之明故。以就通相言之。故当此识。然根本无明具有二义。所谓迷真执妄也。迷真者。即真心本不生灭。德相业用量过尘沙。日用不知如狂如醉。若贫女宅中宝藏。穷子衣内明珠。虽有如无枉受难苦。故华严云。于第一义不了。名曰无明。执妄者。妄即五蕴色之与心如幻如化。本无实体。众生认此为自身心。计虚为实故名执妄。故圆觉经云。妄认四大为自身相。六尘缘影为自心相。乃至结云。由此妄有轮转生死。故名无明。然此二义递互相成。举一则兼未尝独立。但若执妄必须迷真。但若迷真必须执妄。譬如有人迷东必执西亦互相成立。思之可见。疏由是下二明习妄流转。即当妄法生起第二门展转枝末也。由是等者。由因也是此也。因此迷真成识。现起世间一切境界。缘此境界起惑造业受报无穷。此中惑业报应四字。但是三道。然此三法诸教之中。有名三障。障圣道故。或名三道。引心逦迤至业报故。或名三杂染。以性不清净故。又此三障更相由藉。由烦恼故起恶业。由恶业因缘故得苦果。初言惑者即烦恼也。品类即根本及随。根本有六。谓贪嗔痴慢疑恶见。随烦恼有二十。谓忿恨覆恼嫉悭乃至散乱不正知等。若以要言之。不出根本中三。谓贪嗔痴。即此三种便能成就三界世间。故华严云。由贪嗔痴发身口意。作诸恶业无量无边等。此惑因起由前无明迷平等理。妄认五蕴身心。即此身心是过患根本。故肇公云。约天地为高下。约日月为东西。约身为彼此。约心为是非。老子亦云。吾有大患为吾有身。及吾无身吾有何患。故知此身是一切过患根本。既执之为有。遂分自他。依此身心起诸烦恼。于一切顺情境上。起于贪心。于一切违情境上。起于嗔心。以护自身将为主宰也。于此二中不知是妄。任运而起。乃名为痴。此等烦恼究其所因。皆从根本无明而有也。次云业者。然业虽无量统唯有三。谓善恶不动也。由前贪嗔炽盛发动身口作诸恶业。即身三口四意三等十恶业也。或有稍知因果。贪来生荣乐之事。即翻恶为善。持不杀等五八十戒即善业也。或厌下苦粗障欣上净妙利。修有漏禅定。名不动业。然此三种业虽胜劣不同。皆由迷心所造。俱有漏摄。故圆觉经中。结三业云皆轮回故不成圣道。由是则知前之三业皆依烦恼所成也。言报应者。应即是报。既有业种蕴在藏识。因缘会时必须受报。涅槃经云。非空非海中。非入山石间。无有地方所。脱之不受报。尚书云。天作孽犹可违。自作孽不可逭。由是有业必有报应。然若推诸业体相都无。及受报时未尝差错。恶因苦果善因乐果。如影如响的无差谬。然泛论果报六道不同。以类收之但唯三种。谓苦乐舍。由前恶业为因。则感三涂苦报。谓地狱饿鬼畜生也。由前善业为因。即感人天乐报。谓四洲六欲也。由前不动业为因。即感上界差别之报。即色无色界也。然于三界之中。所受苦乐之身。是别业正报。所居胜劣器界即共业。依报正报有生老病死。依报有成住坏空。器界空而复成。有情死而还生。无始至今联绵不绝。迷惑耽恋诚可悲夫。故法华云。三界无安犹如火宅。由是报因业感。业由惑成。惑因无明。无明无始一念妄有也。则知三界六道有情无情。究其所从皆因梦识而有袭习纶轮者。袭谓承袭即相续义。由惑发业业能招苦。次第相续故。习谓熏习即相敩义。意明惑业念念敩学念念熏习故。唯识云。由诸业习气二取习气俱故名为习。然此二义必互相资。谓相续故相敩。相敩故相续。故云袭习。故唯识云。前异熟已尽。复生余异熟也。譬如有人袭儒学文。由承袭于儒故。方能学习于文。又由学习于文故。方能承袭于儒也。相资之义岂不昭然。纶即纶绪也。谓众生业种虽复无边。终不一时受六道报。报有次绪故名纶绪也然有两意。一如人负债强者先牵故二如人种物润者先生故。轮谓轮转。谓生已复死死已还生。生死不停故名轮转。或天上死人间生。人间死畜生生等。故无常经云。循环三界内。犹如汲井轮。然此二义亦互相资。由纶绪故轮转。由轮转故纶绪也。共犹搔茧抽丝。由彼丝轮转而不止故。使丝绪起之不绝。亦由丝绪起之不绝故。使丝轮转而不止。或可沦字其义亦通。即没溺义也。谓于生死大河。长受没溺故云沦。涅槃经云。若有众生乐诸有为造作诸业。是人迷失真常。是名暂出还没。疏中且用轮字如向所说。惑业则言其袭习。报应则言其纶轮。然二二对辨亦互相资。谓由惑业袭习故。使报应纶轮。实由报应纶轮故。令惑业袭习。斯则乘因感果依果造因。因果相资以之不绝。此即十二因缘前前为因。后后为果之义。故唯识颂云。由诸业习气二取习气俱。前异熟已尽。复生余异熟。或曰。如是起惑造业受报轮转时劫长短耶。故次云。尘沙劫波莫之遏绝也。尘即碎十方世界之微尘。沙即殑伽河中如面之沙。谓此河周四十里沙细如面。劫波者梵音此云时分。大劫小劫长时短时延促虽殊通名时分。莫之者犹不能也。遏绝者止灭也。意言六道众生起惑造业受生轮转已来。将一沙为一劫波。沙尽而劫波不尽。又将一尘为一劫波。尘尽而劫波无尽。尘沙有限劫波无穷。相续至今。不能止之灭之。故云莫之遏绝也。然此二段字句虽多。若论实事不过五字。谓心识惑业报。其余并是显叙真妄成立轮回之辞。意谓本是一心不觉成识起惑造业生死无穷。是故如来现身说教。故大科云起教缘也。疏故我下。二别明说教之意。如法华经云。我以佛眼观见六道众生。贫穷无福慧。入生死崄道。相续苦不断。乃至为是众生故。而起大悲心等。文二。一叙说阿含之意二。一正叙。今初两句标佛现身也。故者所以义。我即指佛也。言满净者拣异分净。以佛无明永尽无念之极故。觉则觉悟者即指人。谓佛是觉悟之人也。若梵语菩提此翻为觉。斯则约法。梵语佛陀此云觉者。斯则约人。今此辨人故言觉者。亦可满字是总。浮觉为别。者字属人。即明如来是满净满觉之者拣诸圣人觉净未满。唯佛如来三障都尽三觉具圆。故号如来为满净觉者。若以此二。望众生二乘菩萨诸佛及本性料拣。有两种四句。一者众生不净。二乘菩萨分净。诸佛满净本性但净。二者众生不觉。二乘菩萨分觉。诸佛满觉本性但觉。今于此二四句中。皆当第三也。现相者。即化身相也。人中者。即现化之处也。唯向人中示相者。天上着乐无由发心。三涂极苦正当难处。唯于人中苦乐相兼。对苦必能发心。所以佛出现化。天上如病未发。岂须针艾。三涂似膏盲之病。不足医治。人中如小瘵所萦。堪可与药故佛出现。然如来现相总有四种。谓他受用报身。大化小化随类化身等。今明说此教者。即小化身也。然有八相。谓一从兜率天退。二入胎。三住胎。四出胎。五出家【注】年十九。【本】六成道【注】年二十五。【本】七转法轮【注】经五十五年。【本】八入涅槃【注】年八十。【本】此论现身但明成道之相。次明说法即转法轮相。佛成道之相。身长丈六紫磨金容。项佩圆光胸题卍字。三十二相八十种好。八部拥卫四众钦崇。巍巍峨峨光映日月。德相繁广不可具陈。此小化身其相劣弱。若望受用即云泥有殊。故法华经说。长者脱珍御服着弊垢衣。珍御之服以喻受用之身。弊垢之衣即况紫磨金体。盖以众生垢重。不堪见胜妙之身既不能见亦无所闻。则于众生都无利益。大悲接物故现小化。亦如法华经说。穷子见父踞师子床宝几承足。富贵殊胜威德特尊。穷子见之窃作是念。此或是王或是王等。非我佣力得物之处。长者见子默而识之。乃至云。即脱璎珞细软上服严饰之具。更着粗弊垢腻之衣。右手执持除粪之器。以此方便得近穷子。此喻如来隐彼胜身现于劣相也。疏先说下正明设教。以此方佛事籍以音声。若无言教现相何益。教先说小后方说大。或曰此明般若何论小乘。答虽同佛言有深有浅。若不对辨安知浅深。然一代佛教不出大乘小乘。乃至圆宗亦大乘摄。其所宗者皆宗因缘。虽则同宗因缘。于中浅深有异。小乘即生灭因缘。大乘即无性因缘。无性因缘者如中论云。因缘所生法。我说即是空。空即无性义也。今明小乘故云生灭因缘。生灭因缘者。诸法缘会即生。缘离即灭。既生既灭足知无常。然则不无生灭之法。以有法执故也。然佛出世先说小者有二对治。故说生灭对治凡夫外道执我。我是主宰义。既言生灭则知无主。无主无宰则无我也。说因缘对治外道自然之计。外道所执多执神我。有作受故兼执自然。既言因缘则非神我自然也。为治此二。是故先说生灭因缘。即佛初成道。始从鹿苑度五俱轮。次度舍利弗目连迦叶三兄弟等。于十二年间所说。即诸部阿含等经是也。今悟等者。佛说此法意令众生悟四真谛也。此有两种因果。谓集是世间因。苦是世间果。道是出世因。灭是出世果也。苦即三苦八苦。三苦谓苦苦坏苦行苦。八苦谓生老病死求不得五阴盛爱别离怨憎会。集即业惑如逐妄中说。灭即有余无余二种涅槃。入经可见。道即八正道。谓正见正思惟岐语正业正命正精进正念正定也。谛者诚实义。如世间苦集。逼迫和合事无虚谬。名为实义。非谓不生不灭名实。即说苦定苦集定集等。以是义故四皆是也。故遗教经云。日可令冷月可令热。佛说苦谛。实苦不可令乐。即如佛于鹿苑为五比丘三转四谛法轮之例也。三转者。一示相转。示谓显示苦行相等。令其悟解。云此是苦此是集等。二劝修转。劝谓诫劝令其修断。云此是苦汝须知此是集汝须断等。三作证转。作证谓引已所作令其信受。云此是苦我已知此是集我已断等。意言我已知已断已修已证汝等学我。当知当断当修当证。如是说已。一类小根之人如言启悟。厌生死苦乐求涅槃。发心进修作五停心等七种方便。断三界四谛下分别粗惑。得初果证。乃至进修渐断三界俱生细惑。证余三果得阿罗汉。则令世间因亡果丧出世间因生果证。法华云。为求声闻者。说应四谛法。度生老病死究竟涅槃。是故疏云。先说生灭因缘。令悟苦集灭道。疏既除下二结判。我执者。即于五蕴总相计有主宰。名为我执。若一一推求。色等性中不见我体。名为我空。若见五蕴之法实有体性。名为法执。若了五蕴如幻如化从缘无性。名为法空。既除者已尽也。以小乘人闻说生灭因缘不执于我故。云既除我执。未达者。以未闻说无性因缘。犹计蕴法为实故。云未达法空。若具言之。合云既除我执已达我空未达法空未除法执。今则上执下空。文影略故入。除我执。便是已达我空未达法空。便是未除法执故也。疏欲尽下。二叙说般若意二。一总云大部二。一叙教释意。病根者喻法执也。如人有病令人不安。如木有根能生枝叶。意云二执如病。令诸众生不得安乐。若取法执为病。病即是根持业释也。若取我执为病。是病之根即依主释。今则病通二执。根喻法执。以能所依二体异故。我是能依法是所依。以能从所生故能非根。根唯局所也。由是凡夫有我执。必兼有法执。二乘有法执。不必具我执。又二乘无我执则未必无法执。菩萨无法执。则必无我执。如因迷杌方可见人等。般若即慧也。为显此法故遗言成教。教即文字。般若即观照实相二般若也。今约佛论故。通法教俱名般若也。此中意云。如来意欲尽众生有执之病根。方谈空宗之般若。然大乘教法无量无边。何故此中唯谈般若。谓正能破执大乘初门。二执若除真性自现。故唯谈此除其病也。故古德云。华严经如治国之法养性之药。般若教如定乱之将治病之药。二经既尔余可例知。心境等者。然佛初说小乘心境俱有。说大乘法相即境空心有。说般若教即心境俱空。今正明此故云齐泯。心即心心所法。境即诸识相分。心通能变能缘。境通本质影像。心境等亡故云齐泯。谓约遍计则都无所有。如绳上蛇。约依他则缘无自性。如麻上绳。由心故境由境故心。境灭心空心如境谢。然诸法虽多不出心境。心境既泯则一切皆泯也。心经亦云。无眼耳鼻舌身意。无色声香味触法。无眼界乃至无意识界等故云齐泯。即是真心者显非断灭。恐闻一切诸法泯之皆无。诸法既无应成断灭。故此显云即是真心。然此心与上心字不同。上是缘生忘心。即前梦识也。此是常住真心。即前镜心也。为拣别故。故特言真。以一切诸法皆依此心。若离此心无别有法。故经云。一切世界因果微尘因心成体。心之所现名曰依他。执之为实乃名遍计。依计既泯即是圆成。如绳依麻有蛇托绳生。绳蛇既亡则麻着矣。此是疏主出般若之密意。若据经文。即但言诸法皆空。不言即是真心。故下文云。离一切相即名诸佛。文虽不彰义实如此。若法性宗。即直于诸法空处显出真心。故圆觉经云。种种幻化皆生如来圆觉妙心。犹如空华从空而有。乃至云。诸幻尽灭觉心不动。故云即是真心也。垢净双亡者。上言心境染净已舍。文未显彰故重明也。意云非但无诸有漏心境之法。若于法中染净之法亦复不有。为对治垢染。方彰净法之名。所治之垢既亡。能治之净何立。如无悭贪布施亦遣等。则知若理若智若因若果。一切行位诸对治门悉皆不有。垢净并无故曰双亡。故心经云。无无明亦无无明尽等。一切清净者。此净与上净字不同。上即对染之净。此名真空曰净。以声闻怖空故言清净。清净即空义也。大般若中。或则云空或言清净。然万法虽多不出心境恐收不尽。又约垢净重明。斯则是法皆摄。竟无所遗故。言一切也。故大般若云。善现般若波罗蜜多清净故色清净。乃至诸佛无上菩提悉皆清净。又非谓泯却心境显真心了。然后亡垢净显真空。此乃文家成隔句对。若欲顺义。应云心境齐泯垢净双亡一切清净即是真心。理则明矣。谓真心之中。本无心境垢净等法。名之为空。非谓无于心法成于断灭。故唯识颂云。初即相无性。次无自然性。后由远离前所执我法性。此诸法胜义。亦即是真如常如其性故。即唯识实性。然此与前迷真习妄。正为翻对。若无前意焉起此文。疏三千下。二显瑞彰会。三千即三千大千世界。如下所明。瑞即祥瑞焕明也。佛说此经之时。放大光明照三千界非不焕然。复现种种奇异之事。有此祥瑞故。云三千瑞焕。故大般若经第一云。尔时世尊于师子座上。自敷尼师坛结加趺坐。入等持王三昧。安祥而起。一一身分各放六十百千俱胝那庾多光。各照三千大千世界。乃至云令此世界六种变动盲者得视聋者得闻等。又云。其诸天人佛神力故。各见于佛正坐其前。咸谓如来独为说法。十六会彰者。然般若类有八部。谓大品小品放光光赞道行胜天王文殊问金刚。唐译六百卷。二百七十五品。总一十六分。前五无名后十一分有名。前六分品后十不分品。即初分七十九品。第二分八十五品。第三三十一品。第四二十九品。第五二十四品。第六胜天王般若。分一十七品。第七曼殊室利分。第八那伽室利分。第九能断金刚分。第十般若理趣分。第十一施波罗蜜多分。十二净戒十三安忍十四精进十五静虑十六般若。即大明度无极经四卷。同前五分。儒首菩萨无上清净分卫经二卷。即第九分。实相般若即第十分。道行小品各十卷。同第四分。光赞十卷。放光三十卷。大品三十卷。皆同第二分。然上诸本开合大部文势次绪事理一一皆同。但广略之异。唯仁王一本。不在八部之中。疏今之下。二别示今经二。初略标指如文。二广序赞二。一序叹幽玄二。一具序一经诠旨三。句偈下一正序。句有文句义句。今通此二。偈谓积句所成亦通此二。隐谓潜隐。即现在无文。如经中多无所断之疑文及其住名。略谓少也。即现虽有文而不广故。如经中唯有能断之文及有住义。旨谓意旨。趣谓旨之所归。彻理曰深难觉曰微。难觉有二意。一为文隐略故义趣难觉。二为彻理故甚深难觉然隐略深微之相。即下所云慧。即返流净用。约断执观空得名。般若正翻云慧。不云智也。下释题中广辨体相。三空者。即我空法空俱空也。如下经云。无我相人相等即我空也。我相即是非相等即法空也。离一切相即名诸佛。是俱空也。二空可知。俱空有三说。一别观人法名二空。同一刹那双观人法曰俱空。二即二执既遣。二空亦遣名俱空。三即能所遣时慧亦无住。即与本性相应。此时自无人法二相及非法相等名俱空。彻谓透彻。慧是能彻。三空是所彻。般若照时透过三空之表。即与本源相应。以本心源非空非有。为对人执方说人空。为对法执方说法空。为对二执方说俱空。即空是能对执为所对。所对之执既遣。能对之空亦除。空执两亡方契本性。若住空境未曰相应。所以疏中特言慧彻。由是四加行位菩萨。为取空相不名见道故唯识偈云。现前立少物。谓是唯识性。以有所得故。非真住唯识。今既彻于空相能所兼亡。即同唯识见道颂云。若时于所缘智都无所得尔时住唯识离二取相故。檀舍万行者。梵音檀那此云布施。舍谓舍摄万行。即菩萨所行之行。不唯于万。今举大数耳。以布施舍于三施。三施该于六度。六度包于万行。以本望末故。曰檀舍万行也。所以佛答修行。唯言布施。故弥勒颂云。檀义摄于六。资生无畏法。此中一二三。是名修行住。住一十八下。约二论以叙叹。准无著论中。从佛正说已下。乃至经终分。为十八住处。谓第一发心住。乃至第十八上求佛地住。即是修大乘行人。从因至果安住之处。密示阶差者。谓隐密示现行人修行入位阶降差别之相。以经中都无十八住名。含有十八住义。以不显配故云密示。前后浅深不同故云阶差也。然阶差之相。在下正宗文前疏文具明。断二十七疑者。准天亲论。从佛答三问毕。便蹑迹断疑。乃至经终二十七段。谓第一求佛行施住相疑。乃至第二十七。入寂如何说法疑。潜通血脉者。潜谓潜闇。通谓通流。血脉者喻也。以经中多分唯有能断之语而无所断之言。由是文起孤然势意断绝。及寻经旨皆有所因。文虽不彰理且连贯。以不明显故曰潜通。其犹人身血脉外虽不彰内宛流注。约喻显法故。曰潜通血脉也。此意见于逐叚叙疑之文。疏不先下。二反显不先遣遣者。即反显慧彻三空之义。谓二执为所遣。二空为能遣。又二空为所遣。俱空为能遣。以俱空遣二空。空病亦空。故云遣遣。如圆觉云。应当远离一切幻化虚妄境界。由坚执持远离心故。心如幻者亦复远离。远离为幻亦复远离。离远离幻亦复远离。曷契如如者。曷何也契合也。如如者。即上三空之表。本源真性也。二空破执执丧空明空病亦空。方契本元真性也。意云。若不先遣遣。即滞有滞空。何能契合真如本性。然此语势亦是御注序文。彼云咸归遣遣之旨。尽入如如之妙。疏故虽下。三顺结。如经中度四生即是策修。无生可度即是无相。行六度即是策修。不住相布施等。即是无相。如是类例遍于经中。然度生修行合是有相。今以无生可度无住布施无法可说无我修善。故顺经宗无相之义。一经前后无不谈此。故曰始终。又因心果心咸皆如是。斯则正策修时无相。正无相处策修。非谓前后始终皆尔。疏由斯下。二结叹四法幽玄三。一正结叹。若据前正叙叹中。约教义分能诠所诠。今于所诠之中。别开行果。即四法足矣。然教密如前句偈隐略。理密如前旨趣深微。行果二玄前文未显故宜别明。行玄者。夫菩萨行不出二种。谓随相行离相行也。随相即同前策修。离相即同前无相。玄者妙也。若二行抗行。或先或后不名为玄。二行同时不相妨阂。乃名为玄。若唯随相即同凡夫。若唯离相即同二乘。二行相资宛符中道。即观空而万行沸腾。涉有而一道清净。是菩萨行矣。果立者果即佛果也。此中佛果总有二种。所谓真身应身。应身有相。真身无相。玄者。若二身各异。相无相殊不名为玄。以相即无相无相即相。真应无阂故曰玄也。所以经中。若以相观佛。则是人行邪道。不以具足相发心。则堕断灭。以此真身应身不一不二故使然也。由斯者因此也。即正指说此一卷经。是密是玄也。此则结指前文之所明。标为后说之所以也。疏致使下。二示难了。致遂也使令也。由前四法幽玄之故遂令讽诵甚多而解者极少。口讽即读诵其文也。牛毛喻其多也。妙解经意乃名心通。麟者瑞兽。君圣则现。角者麟唯一角。喻悟者少也此有两重相望。以论多少。谓麟比牛而已少角比毛而又少。意谓读诵者多中之多。通悟者少中之少。疏或配下。三彰谬解。前四句即但不符圣旨。别作意度不得圆畅。虽非邪僻亦名谬解。后二句胸谈臆注正是邪谬。前言心通者少不通者多。此之三类即是不通之相也。此前两家皆先叙因。然后结过。配入名相者。谓有疏将法相名句。配入其中。此则贪着其事。好尚法相也。如下经云。凡夫之人贪着其事。乖宗者。以经宗无相真空。既以法相解之。宁契经旨。以不顺理名之为乖。但云一真者。但犹独也。以闻说此经是空无相宗。则首末作离心离境空无相道理一味销释。故云一真。望源迷派者。望谓瞻望。源谓水生之处也。迷谓昏迷。派谓流派。路分曰岐。水分曰派。意云。此经虽宗无相。而文义千差。今虽符大底宗源。而全乖差别义理。故云望源迷派已。斯言乃是晓公起信序文。今虽用之而意异彼。彼则以一心为源。随缘生灭为派。此则以经宗为源义理为派。故不同也。其余等者。前则各有一长。此乃都来邪僻。前则依人依教。此乃率意推胸率尔疏谬之言。故曰胸谈臆注不堪采览置之言外。故云不足论矣。就中此释宇内偏多。疏主云。予久志斯经。遍询诸疏亲见数十本。或假托金刚藏。或云志公或云傅大士。或云达磨或云五祖。或题自名。皆好纸好墨装饰甚华。其中文义总不堪采。如释舍卫国云卫者百灵卫护。举一例诸首末皆尔。苟有无限愚人。不能甄别宝为至妙。诚可悲哉。故云胸谈等。若将源派约迷不迷。前后相望有其四句。一迷源不迷派。即配入名相者。二迷派不迷源。即但云一真者。三源派俱迷。即胸谈臆注也。四源派俱不迷。即下不攻异端。是此疏也。疏河沙下。二引文结显。河沙珍宝者。即经云。如恒河中所有沙。有如是等恒河。是诸恒河沙宁为多不。乃至此福德胜前福德。三时身命者。即经云。须菩提。若有善男子善女人。初日分以恒河沙等身命布施。乃至何况书写受持读诵为人解说。喻所下有二意。一即于此内外二财喻之不及。二即如下文云。我念过去无量阿僧祇劫。于然灯佛前。乃至譬喻所不能及含兹二意故云喻所不及。岂徒然哉者。岂者可也。徒者空也。意云可空如此也。意谓此经句偈隐略有趣深微。寻波讨源卒难得。意。傥悟玄理随分受持。得福德多不可思议。既若如此非圣智不能造其源。常情之流岂合措意。此文意含两势。一验凡心不晓。二验持者福多也。疏且天亲下。二述造疏意二。一示疏论师承有据二。一示论师承斥他添削梵语提婆盘豆。此云天亲。是地前四加行位菩萨。即无著弟也无著。梵语阿僧佉。是初地菩萨。即天亲兄也。补处即弥勒菩萨。见在兜率天上次补佛处。号曰当来下生弥勒尊佛。以二菩萨依禀弥勒菩萨偈颂。造论解经。故云师补处尊。下悬谈广明。后学下斥其违论。即无著天亲之后。制疏之者也。何疑者责辞也。添即前云配入名相者。于本论外。加以大小乘法相行位故云添。弃即前云但云一真者。弃却两论别自解释也。不知彼人云我胜菩萨为。复不知菩萨所造论耶。若言不是我胜菩萨。亦非不知造论。但以志道参玄忘言取意。截径修进不务枝流。谁有心力寻于论文者。即应责之曰。寻论释经则推无心力。推胸率意心力何多。且者约截之辞。以不论所余截径而斥意云。今不论儞有理无理。且论主是入位上流。复从弥勒所受义句。此盖佛佛相传展转师授。儞之后学何得固违而自率意耶。一是凡圣愚智悬隔。二是师父之言。背智率愚悖师无礼。如父有所作子乃故违。岂合天道耶。故此引师以斥也。疏故今下二明今述解不攻异端。今初两句对非显。是故今者。由菩萨展转相授。所以今之述作不攻异端。攻谓攻击。异谓别异。端即端倪。即显诸家却是异端也。故云对非显是。故论语云。攻乎异端斯害也。已注云。善道有统故殊涂而同归。异端不同归也。疏是下二句出其因由。既用本论释经。不攻异端明矣。乳非下引经喻。涅槃第十云。复次善男子。如牧牛女为欲卖乳贪多利。故加二分水。转复卖与余牧牛女。彼牧牛女得已。复加二分水。转卖与近城女人。彼女得已复加二分水。卖与城中女人。彼女得已复加二分水。诣市卖之。时有一人为子纳妇。当须好乳以待宾客。至市欲买。是卖乳者多索价数。是人答言。汝乳多水不直尔许之直。今我赡待宾客。是故当取。取已还家煮用。作麋而无乳味。然于苦味中千倍为胜。何以故。乳之为味诸味中最。善男子。我涅槃后。正法未灭余八十年。尔时是经于阎浮提当广流布。是时当有诸比丘。抄略是经分作多分。抄前着后抄后着前。前后着中中着前后。杂以世语错定是经。今多众生不得正见。如彼女人展转卖乳乃至成麋而无乳味。然彼经意以喻涅槃。此借用之以喻般若。此中城内之言语稍漫通。今取最初新构之乳未加水者。以为喻也。或曰。此中岂无疏主自语应同添水乳耶。答不然。虽有自言但是连合前后。或引文之端。皆从本义而非添也。疏纂要下。二示名题。义意在下。诸家至此皆略判经题。今务简削繁。下文委释。三解本文二。初偈文归请。将欲制疏恐未上符下合。故归请也。意云。法华经说。假使满世间皆如舍利弗。尽思共度量。不能测佛智。圣智尚难图度。凡心岂可测量。由是祈请加护冀无纰缪。于中前三句归敬三宝。后一句祈愿利生。初二字能归至诚。稽者稽也。首即头也。尚书云。稽首拜手。注云。稽首谓首至地也。拜手首至手也。今则屈头至地稽留少时。表敬之甚也。又礼有三种。谓下揖中跪上稽首。今则上礼表无慢心。然能归之人必具三业。表佛有天眼天耳他心知故。谓以身业归。表佛有天眼见。以口业归表佛有天耳闻。以意业归表佛有他心知。又圆满三业善故。成就三轮因故。以未归三宝之前。三业悉皆不善。今归三宝故三业皆善也。三轮者。谓神通轮记心轮教诫轮。因中身业归。果获神通轮。因中口业归。果获教诫轮。因中意业归。果获记心轮。据此即三业是因三轮是果。三轮之因依主释也。今言稽首即当身业。但举身业余者自具。谓称三宝名。及述所为事。即口业也。心不虔诚宁肯归礼。即意业也。牟尼下。正举三宝。谓佛法僧为福之田。三皆可宝故云三宝带数释也。然有三种。一住持即塑画等。像佛也。三藏教文法也。五众和合僧也。遵守遗言任持像法。名曰住持。二别相者。佛即三身。法即教理行果。僧即二乘菩萨。三同体者。觉照名佛轨持名法和合名僧。于中复有本性观行融通之异。皆一法上说之故云同体。于上三中。今所归者即别相也。五教之中当其始教以此经属始教故。今但取当宗之中能说般若为佛。所说般若为法。发起流通者为因故非余教。牟尼下佛也。梵音释迦牟尼。此云能仁寂默。能仁故不住涅槃。寂默故不住生死。又寂者现相无相。默者示说无说。此则即真之应也。大觉者。觉即是佛大拣余圣。余圣虽觉未名为大。二乘偏觉菩萨分觉皆非大也。唯佛如来一觉永觉无所不觉。如大梦觉如莲华开。迥超群圣故独称大。尊者具上九号为物所尊。下文广辨。能开下法也。于中能字属佛。开字通佛及法。谓在佛为能开。在法为所开。般若三空句五字。唯局法也。然于此中具教理行果。般若果也。以是到彼岸慧故。三空理也。句即教也理果合论行也。以慧照理是菩萨行故。发起下僧也。发起上士即须菩提。因兴三问故佛说之。流通上士。即是弥勒无著天亲也。逦迤解释方始弘传。上士者高上之士也。或曰上人。故马呜菩萨赞无常经归敬偈云。八辈上人能离染。或云大士。故大云疏云。如斯大士皆归命。斯皆通用故随人称。疏冥资下一句。祈愿利生也。冥闇资助也。所述即此疏也。契合也。群机即一切众生也。然资助加护有二种。一即显加。谓现身说法有所见闻。二即冥加。但得智力无所视听。今于二中唯求冥加也。以制疏释经。唯籍智力但得冥助不须见闻。以此经云。若以色见声求是行邪道。为顺此教故不求显然。凡所设教皆契理契机。今不言契理者。以疏是论文已契理故。又疏主于二利中利他偏甚。今唯言契机者。悲增之相也

金刚经纂要刊定记卷第一金刚经纂要刊定记卷第二

        长水沙门子璇录

将释下。二开章正释。既蒙加祐心通智明。约义开章遂申经旨文二。初标列章门。将犹欲也。此依崇圣寺尘外疏。唯开四门。若准大云疏中。即开六门。一明经意。二明宗旨。三明经体。四辨译时。五解题目。六释经文。今虽四门含六门义。谓此第二摄彼二三。第四摄彼五六。其余单摄但小异耳。二依章正释二。初总论诸教。如多药共治一病。二别显。则如一一药各有功能也。初中二。初通赴机缘。酬因者。酬谓酬报因谓因地。以佛于因地。初发心时希求无上正等菩提。遂启四弘誓愿。烦恼无边誓愿断。法门无边誓愿学。众生无边誓愿度。佛道无上誓愿成。于此四中三愿皆毕唯一未圆。誓度众生众生宛在。今虽证果不舍因门。现身说法济度群品。以报先愿故曰酬因。故法华云。我本立誓愿。欲令一切众如我等无异。如我昔所愿。今者以满足。化一切众生皆令入佛道。酬请者。佛初成道梵王帝释等请转法轮。故法华云。尔时诸梵王及诸天帝释护世四天王。及大自在天。并余诸天众眷属百千万。恭敬合掌礼。请我转法轮。如来默然受请。既受其请故。始于鹿苑终至鹤林。四十九年说诸经教救度众生。故法华云。即于波罗奈转四谛法轮等也。显理度生者。此二相从合说。然有通别。通则佛以一音演说法。众生随类各得解。别则说四谛法显生空理。度凡夫外道。说六波罗蜜。显二空理。度不定性二乘及利根凡夫。令入大乘道。说一乘法显法界理。度定性不定性二乘及地住菩萨并上上利根凡夫。令入一乘究竟佛道。若据下。二克就佛意。唯为一大事等者。法华经具云。诸佛世尊唯为一大事因缘故出现于世。舍利弗云何名诸佛世尊唯为一大事因缘故出现于世。诸佛世尊欲令众生开佛知见使得清净故出现于世。乃至欲令众生入佛知见道故出现于世。准天长疏。解云佛之知见非三非五故云一。广博包含故云大。诸佛仪式说此化生故云事。众生有此机能感于佛曰因。佛即应之曰缘。故者所以义。由此一大事因缘。所以佛出于世。开示悟入者。此之四句不出于二。初二句能化。后两句所化。能化有二。谓大开而由示。此属于佛。所化亦二。谓始悟而终入。此属众生。若准法华论释。开者双开菩提涅槃二无上果。示者别示法身。显三乘同体。悟者知义别指报身。二乘不知说令知故。入者因义。修因契入故。华严疏主解云。开者开除惑障。示者示真实理。悟者悟妄本空。了心体寂。只今悟上真理。入者冥于心体。石壁解云。一切众生皆有佛性大开也。指云心中了了分明。是佛性曲示也。斩新领解决定印可不疑。始悟也。一切念想都亡。终入也。诸家解释旨趣不同。白璧黄金各为至宝。疏后别显者。近指一卷金刚。远关诸部般若。以同宗故。意明有何所以说无相经。于中五段具列如疏。初中三。初标。对治者。如病设药义见序中。我执者有二。一凡夫情计我。即执五蕴总相。以为主宰。二外道神我。即蕴离蕴或大或小。幽灵神圣动用难思。皆计为实。故示我执。计一切法实有体性。名为法执。然佛说小乘以除我执。今说般若重为此者。盖深必该浅也。由是正除法执。兼明我空也。由此下。二释二。初总标。由执起障烦恼即根随等。此依我执而起。如前逐妄中说。所知即根本无明也。故起信论云。无明义者名为智碍。即所知障也。此依法执而起。由烦下。二别示二障过患二。初烦恼障。心不等者。心本清净自在。功德妙用过于尘沙。良由此障覆蔽不得显现。故云心不解脱。解脱者自在义。不唯令心不解脱。复能造业润业。业即善恶不动业也。以有业因必招果报即受生也。受生之处所谓五道。生而复死往而又来。故云轮转。轮转之相已如序中纶轮义也。反推其源即是我执。故知我执是过患根本。故要除之。由所知下二所知障。慧不等者。此即大乘深慧。不论小乘浅慧。此慧若发照见五蕴皆空。唯是心性离自心外无别有法。今为无明覆蔽不得开发。故华严云。若不了自心。云何知正道。彼由颠倒慧。增长一切恶。不达等者。然诸法性相有别有通。别则如水以湿为性以动静为相等。通则诸法同以无为为性有为为相。由无是慧故不能了之。然了心即根本智。了性相即后得智。二智不显盖由无明。无明不除不成佛法。故云纵出三界亦滞二乘等。斯则虽出火宅。犹止化城不到宝所。若反推其本由于法执。将知法执是过患根本也。然此二障非谓抗行。皆由一心所为。但微著有异。所知则细烦恼则粗。粗细虽殊都无别体。犹如一水起动成波微著有异。于中亦有二义。才动则不能现像。同彼所知。猛盛则覆舟溺人。况于烦恼。法喻相对昭然可见。又心慧解脱。约人料拣以成四句。谓心解脱慧不解脱。二乘也。心不解脱慧解脱。大悲菩萨也。俱解脱佛也。俱不解脱凡夫也。疏二执下三结。以前推穷一切过患根本是其我法二执。二执若遣二障即除。二障若除则诸过自灭。由是过患之源即其二执。为除二执故演斯经。故知此经是大良药。故心经云。般若波罗蜜多。是大神咒是大明咒等。乃至云能除一切苦真实不虚。欲知此经除二执者。如经云。无我相人相众生相寿者相。是除我执也。无法相亦无非法相。是除法执也。如此类例遍于经中。疏二中二。初标可知。二释疑者。于理于事犹豫不决。即心所法中烦恼一数。然有二种。一种子。二现行。种子谓蕴在藏识未显发者。名为未起。现行谓动之于心或形之于口。名为现起。遮则遮其种子。不令起于现行。断则断于现行。即自除其根本。其犹筑堤防水倾津泼焰。其义可见。即经下指经也。然准经即答三问。已展转而断起复连环。故云节节至二十七。然遮断之言总有两意。一则经中有须菩提陈疑处。是现行。即第二第十一第十九余无问辞皆种子也。二即当时尽是现行。望于后代总名种子。斯则断现行时。即是遮种子也。然二意中后意稍切。故二十七疑。皆言断而不言遮也。疏三中二。初标。二释。然泛论业有三种。谓善恶不动。受有三时。谓现生后。若今世造善恶。今世受苦乐者。名顺现报业。若今世造善恶。次生方受。名顺生报业。若今世造善恶。从第三生已去乃至百千生方受。名顺后报业。今世有人造善恶业目下无报。便疑无因果者。良由不达此三时报也。故佛名经云。行善之者触事轗轲。行恶之者是事谐偶。致使世间愚人谓之善恶不分。我经中说有三种报。如上所叙。今言转灭者。三中唯转恶业。以违理故时则通三。然此恶业受报。准小乘宗说有定不定。如初篇四重名为定业。僧残已下名不定业。以此对时应成四句。谓时定报不定。报定时不定。俱定俱不定。若此经说者则不然。以未入我法名决定业。若入我法名不决定业所言不定者。或轻或重或受或不受也。问若然者。何以大般若中。云唯除决定业应受报耶。答但转重成轻。非令不受故无违也。如此经云若有人受持读诵此经。为人轻贱者。是人先世罪业应堕恶道。以今世人轻贱故。先世罪业则为消灭。当得阿耨菩提。言先世者有二意。一前生之前名为先世。二未持经前名为先世。虽通此二后义为正也。今以三涂之业。用轻贱代之令报不定。生报现偿令时不定。此皆转重令轻也。其灭轻不受经则无文。经虽无文义乃合有。然有两意。一者以重况轻。意云。重业既转之令轻。轻业故宜不受。二则曾堕三涂之者。出在人中犹有余业。即贫穷诸衰等苦。今既不堕三涂则余业必免。亦是时报俱不定也。疏四中三。初标。二释二。初未说夫为凡小。佛成正觉者。即菩提树下三十四心断结。五分法身初圆。示成正觉也。未说等者。即成道之后十二年已前。但说人天因果及四谛缘生。未说三空般若。无妙慧者。妙慧谓无相甚深般若也。此是法空之慧。以未说般若未显法空。故无此慧也。施等住相者。等于戒忍等四。住于我人众生等相。及住法非法相也。既住我法等相。则成世间因果。故皆有漏也。此说凡夫。依人天教者。或滞二乘者。设有断惑证真。不无厌苦欣乐。纵出三界亦堕声闻缘觉之地。此依小乘教者。若准凡夫兼无粗慧。就胜通说故言无妙慧也。疏故谈下。二已说得为佛因二。初顺释。即十二年后。说诸部般若之教诠显妙慧。妙慧即第六般若波罗蜜。以法身是真如妙理本不生灭。但以烦恼覆之。名如来藏。若妙慧照破烦恼。真理显现成大法身。故说妙慧为法身因也。五度等者。五度即施戒忍进定。应身即三十二相八十种好。紫磨金色之体也。此由积习五波罗蜜之所感得。故言五度为应身因。疏若无下。二反显。非波罗蜜等者。虽行施等由无慧导皆成住相。由住相故便成有漏。但成世间善因乐果。故非佛因也。故菩提资粮论云。施戒忍进定。及此五之余皆由智度。故波罗蜜所摄。疏故须下三结。福慧属因。即五度六度是能严也。两足是果。即真身应身为所严也。然诸佛果德。虽无量无边。以要言之不过此二。故法华云。如其所得法。定慧力庄严。以此度众生。自证无上道。大意谓由无般若致使施等。非波罗蜜不成佛因。故须福慧二严。乃成两足妙体。然前五与第六互相资助。以真应二果必须具故。其犹胶青彩色。彩非胶而不着。胶非彩而无色。六非五而无相。五非六而无因。如经云。应无所住即修慧也。行于布施即修福也。又以无我无人无众生无寿者。即修慧也。修一切善即修福也。此例甚多。疏五中三。初标。真应二果者。然诸经论皆说三身。此中唯明二者。已合摄故。言三身者。即法报化。如权宗所说。法身是理无漏无为。报身是智转识所成。有为无漏虽证于理智且非理。如日舍空。由是理智分为二也。化身是影固宜不同。由此说佛有三身也。今言二者法报合故。以智即是理如光即珠。是故合说为真身也。如净名经云。佛身无为不堕诸数。岂言报体是有为耶。又涅槃经云。若人言如来同有为者。死入地狱。是故此中不说于三。但言二也。故智论云。佛有二身。一真身二应身。亦云生身应身。皆化身也。问法报化等皆是佛身。法报既其不分。化体何故别说耶。答法报皆实所以合论。化体唯虚故宜别也。疏未闻下二释。谓十二年前小乘之人。唯取三十二相金色之身。以为真佛。不知更有真佛。故云但言色相。不知下。以未达法空故。不知此相但是真身之中所现影像也。故唯识云。大圆镜智能现能生身土智影。既言是影则知非真。故弥勒颂云。应化非真佛。亦非说法者。不如等者。若知真身是实应身是虚。又了相即无相名为真身无相即相名为应身。如是见者名如实见。故华严云。于实见真实。不实见不实。如是解法相是则名为佛。若不如是名为不如实见。疏故此下三结。发明二果者。如经云。如来说三十二相即是非相者。发明真身也。是名三十二相者。发明应身也。又云。则非具足色身。发明真身也。是名具足色身。发明应身也。余例此知。二因等者。真身由前慧因证得。应身由前福因证得也。前段中云。故须福慧二严等。即是约果说因。今云故此发明等。即是望因说果。如是说者。意令众生修二种因证二种果也。然前五门展转相蹑。谓说般若经。本除二执故有第一。二执虽遣两疑犹存故有第二。纵使无疑争奈先业故有第三。恶业既灭无漏因成故有第四。因既昭然果证何远故有第五。由是一经大意极此五重矣。疏明经宗体者。宗即所诠体即能诠。今初宗者。尊也。重也。心言之所尚也。然言由于心故。故肇公云。情尚于空者。触言而宾无。毛诗序云。情动于中而形于言。余皆例此文二。初统明诸教。然此方古今教有三种。浅深既异所宗亦殊。一儒教主即文宣王。谓孔丘也。宗于五常仁义礼智信。意以修身慎行理国理家扬名后代也。二道教主即玄元皇帝。谓老聃也。宗于自然。自然即融荡是非。齐平生死终归虚无也。三释教主即释迦也。宗于因缘。意令识迷破惑证真起用也。是故疏云因缘为宗。然一代佛教通宗因缘。虽小乘生灭大乘无性浅深有异。大约统论皆因缘也。然有二种。一世间。二出世间。世间有二。一内二外。外复有二。一谓种子为因。水土人时等为缘而芽得生。又泥团为因。轮绳陶师等为缘而器得成。二内谓无明为因行支为缘。而生识等五支及生老死二支。前二器世间。后一即有情世间。故知成此三界世间。只由因缘二字。二者。出世间有三种。一则本觉内熏为因。师教外熏为缘。而始觉得生。二始觉为因。施等五度为缘。而佛果得成。三则大悲为因。众生为缘而应化得兴。故知出世间一切净妙等事。不出因缘二字。故法华云佛种从缘起。是故说一乘。中论云。未曾有一法不从因缘生。又云。我说是因缘。能灭诸戏论。然统收世出世间一切诸法。有义空义假义中义。虽浅深不同。皆堕因缘也。言有者。有生有灭也。谓诸法缘会。而生缘离则灭。如马胜比丘为舍利弗说偈曰。诸法从缘生缘离法即灭。如是灭与生沙门如是说。空者既属因缘。则知无体。无体即空义也。故中论云。因缘所生法。我说即是空。假者如镜像水月。虽则不实缘会不得不现。故净名云。是身如影从业缘现。中者。以假故非空。空故非假。非空非假即空即假。名为中义。故净名云。说法不有亦不无。以因缘故诸法生。又如中论都明有等四义。云因缘所生法我说即是空。亦名为假名亦名中道义。即三乘教中所说。空有中假等义。并不出因缘。故云佛教统宗因缘也。疏别显等者。所谓通中之别。随何经中所宗各异。如华严法界法华一乘净名不思议真如佛性等也。文三。初约法正立。然般若种类诸说不同。准智度论说。有三种。一文字即能诠教。二观照即能观智。三实相即所观境。罗什后来开为五种。谓于观照中开出眷属。即随行五蕴及燸等善根。于实相中开出境界。即俗谛境。此五中唯观照持业释。余皆依主。大云解之五皆持业。谓文字性空即般若故。眷属境界同文字故。实相即是法身。起信论云。依此法身说名本觉故。然虽三虽五三者为正。何则般若所照皆实相故不唯真如。故智论云。照色等空即名实性。性空实理离于颠倒非虚伪故。于空见空亦名颠倒。于空无著乃是实法。色等虚为诳人眼根。故知但约不颠倒离虚伪便为实相。则双实真俗二谛。为一实相也。燸等眷属是慧性故。相应随行俱观照故。故知观照摄眷属也。由是虽则说三已摄于五。既符智论。必契深经故三为正。然诸家立宗。或为观照或唯实相。此并未当。且此经所诠。一一离相岂唯观照。又教化众生断疑破执。岂唯实相。由是今疏双取为宗。不一不二者。欲言其一。体用有殊欲言其二。寂照常俱故非一二。疏以即下。二约喻释成。则显双取为正。且本举能坚能利一金刚。以喻观照实相二种般若。若单取观照则阙坚义。若单取实相则阙利义。又皆言即者。释成不二之相。以照而常寂故理非智外。寂而常照故智非理外。既离理无智离智无理。故如金刚即坚即利。疏万行下。三约行结显。谓菩萨行中必须具此。若昧实相则难亡分别。便成住相即堕有漏。若昧观照则阙智用便滞偏空。同于二乘。故须二事兼行方契中道此则如前行玄之义也。由是起信论中止观合说。法华经内定慧庄严。华严明定慧二事菩萨依赖。涅槃显定慧不等不见佛性诸教中说无明邪见自此而生。故华严疏云。万行忘照而齐修。顿渐无碍而双入。皆此义也。二体分三。初标立可知。文字下。二正释。或曰诸家所出教体皆取声名句文。或通取所诠之法。今何单取文字耶。由是疏云。文字即含声名句文。此明具四法也。声即言音。名句文三即声上屈曲表示。名诠诸法自性。句诠诸法差别。文即是字为二所依也。问四法之中。文字最居其末。云何摄声等法耶。答所以能摄者。有二意。一能显文字有其三处。谓心上显即意识境。声上显即耳识境。色上显即眼识境。今取初者故能摄之二。有声未必有名句文。有文则必有声名句。前前未必有后后。后后必有于前前。如苗必有根根未必有苗也。以是义故。故摄声等。文字性空下。明摄所诠理也。谓依于般若显乎文字。文字本空即是般若无别文字体也。然有二意。一体属缘生无自体故。二非别有一法为文字体故。此皆意显般若是文字体也。其犹镕金成像。像即是金也。疏故皆下。三总结含摄之义。如上所明能所总该故。言理无不尽。此乃文字则该能诠尽。般若则该所诠尽。诠旨既备故云统为教体。疏分别处会文二。初中二。初总示大部。此经下。二别显此经。总可知。疏别明中文三。初正明东土翻译前后二。初通辨诸译。流支者。天平二年于洛阳译成十四纸。名金刚般若。真谛太康元年于金陵郡译成十四纸。名金刚断割。笈多开皇十年于洛阳译成十六纸。名金刚断割。玄装贞观二十二年于玉华宫译成十八纸。名能断金刚。义净证圣二年于佛授记寺译成十二纸。名能断金刚。疏今所下。二克示所传。疏天竺下。二因辨西方解释异同。转授天亲者。有说云。以天亲久习小乘近从大教。要涤情执故转授之断疑执。显行位正宗文中可见。疏今科下。三示今科判依据差别二。初正明科释所依。兼无著者。以显此疏正依天亲傍用无著。余论诸疏义见开题处。疏题云下。二结成立题所以。不同净名集疏备书四圣之名义。即如何晏集解论语于孔安国马融等注中当者用之不当者翦之。今疏亦尔。或双取以各有理。或共成一义故两存焉。疏释通文义二。初题目二。初释所诠三。初释金刚二。初翻名示相。梵云下。新云缚左罗。力士所执者如经所说。执金刚神。梵云诺建那。此云露形神。即此力士也。金中最刚者。金语通五。此最精坚故安刚字。仍非人间之物故。云帝释有之。乃是天上至宝故。云薄福者难见。正理论云。帝释有宝名曰金刚。不为薄福众生所见。疏极坚下。二约法辨义二。初引经论总彰二义三。初总标略辨。为有胜能故。云极坚极利喻般若焉。无物下。释极坚等相。则知若有一物能坏则非极坚。若有一物不碎则非极利也。如银铁虽坚遇火则融刀剑虽利斫石则缺。非极坚利也。拣余坚利故加极字。疏涅槃下。二引教委释。涅槃下引经。无著下引论。难坏即坚义。能断即利义。细牢者。细谓拣粗显是微妙。牢拣可坏坚固义成。智因即是慧。慧是智之因。智是慧之果。此约观照般若说。以微细故能入于惑令彼灭也。不可坏者。智论云。一切语言名相等事皆可破坏。唯无相智不可破坏。此约实相般若说。问实相般若分因果耶。答用有胜劣故分因果。体无增减因果一如。故普贤观云。大乘因者诸法实相。大乘果者亦诸法实相。华严经疏云。理开体用名大方广。智分因果号佛华严。疏皆以下。三结显喻旨。此结所引经论之意。然先上诸德皆用此义。资圣云。金刚者坚而复利。坚喻本觉真性虽流转诸趣而觉性无坏。利喻般若净照三贤十地贯通万行无明惑暗无不坏也。肇云。金刚者坚利之譬也。坚故物不能沮。利故物无不摧。以况斯慧。邪魔不能毁坚之极也。万物皆能破利之义也。又诸经论说金刚喻定。胜鬘经说金刚喻智。梵网经以十回向为十金刚。仁王谓十坚心。净名以金刚慧决了此相。无缚无脱得无生法忍。又诸经论说金刚座金刚山金刚轮。如是等说皆取坚利义也。又晋武帝起居注云。武帝十三年。炖煌有人献金刚宝。生于金中色如紫石英状如荞麦。百炼不销。可以切玉如泥。是知坚利之极也。疏真谛下。二引真谛别示六种二。初正明六种。一一以法合之分明在疏。皆般若之功也。灾厄等者。有厄则灾祸必来。有业则苦果定至。厄除则灾祸不起。业丧则苦果不生。随人所须。有二意。一则如余物不能随所须。金不可为银用。罗不可为锦用等。金刚则不然要者皆得。法中亦尔。有漏功德人不可为天。富不可为贫。无漏不尔随心所成。二则余物用之则尽。金刚出之不穷。法上亦尔。有漏受之则穷。无漏受之不尽。对日等者。慧即始觉合本觉时。见法无生名无生智。如起信云。得见心性心即常住。常住即无生义也。火出烧尽世间。使六合空廓智起断除烦恼。令大道通同。能清等者。水清则万像齐鉴。疑除即佛法现前。空中等者。升太虚则不履于地。住真空则不堕世间。锁诸毒者。中毒则令人命终。起惑则永沉生死。毒除则延年益寿。惑遣则不灭不生。疏傍兼下。二结示傍正佛所立名本约坚利。如上六义乃是兼明。诸家至此多不料简殊滥正义。若将此六配前五因。即一当第三。二三当四五。四当第二。五六当第一。疏般若下。二释般若二。初翻名略指。般若正翻慧者。以古来诸德义翻。为妙慧净慧无相慧。此皆挟到彼岸义。是别相也。或云智慧。今云正翻慧者。即通相也。即照下。约功用以出体也。照蕴空即是功用。本觉之慧即是出体。大品云。色如聚沫受如泡幻想如阳焰行如芭蕉识如幻化。如是观者名照蕴空。相应等者。本觉即如来藏自性清净心。非新生故言本。不顽暗故言觉。慧即始觉也。依体起用故云之慧。始即同本故曰相应。然本觉与慧不一不二。以不二故故言相应。以不一故故言之慧。故资圣云。妄心见俗曰无明。悟心照真为般若。俗境万有见心必异。真空理一悟自无差。第一义空离照无理。清净本觉即理是照。又涅槃云。佛性者名第一义空。第一义空名为智慧。此等皆证体用非一非二义也。然本即实相始即观照。疏若约下。二引教广释二。初引论别相释二。初明总蹑三慧。学者即修大乘行人也。初须闻法生解名闻慧。次则测度所闻评量教理。分明忍可以印自心曰思慧。然后如闻思处。依而行之无所乖越名修慧。前二有漏后一无漏。前浅后深深浅虽殊通名为慧。是故总收名为般若。如人攻文赴举及第。虽前劣后胜皆一人也。云云。疏故无著下。二引论文释成二。初正释成。波罗蜜中等者。此明顿悟中渐修也。慧才发时照万法空便到彼岸。名为顿悟。由有多生习性。未得念念相应。故须听闻正法思惟其义如说修行。方得究竟证入。名为渐修。开题中略明也。若唯识中说。则具根后二智。谓十度中。六通本后四唯后得。六中则二智皆具。为分十度。故第六偏取二空本也。今依无著更加加行智。则通前三矣。金刚断处等者。如金刚断物之处而断烦恼。非谓金刚亦通所断。疏又云下。二配因果二。初双引论。上者字论牒所标。下者字疏牒论文。智因即慧慧果即智也。前虽引用今方解释。此引无著也。次引智论可知。疏则闻下二双解释。此明法空深慧。意拣我空慧为粗浅。不为佛因但是二乘因故。般若下出所以。以慧是拣择义。拣择惑障显无为故。以因位有惑故须择之。乃名为慧。智但决断为义。以果位无惑但唯决定朗然独照故名为智。只是一法受此两名。如人破贼为将功成为相也。有说。以无漏智性为智因。大云破之。三涂有性何不断惑阙细义也。此约妙慧别相以破。若就通相取亦可矣。以凡是有心皆成佛故。此得是因也。疏若依下。二引经通相释。此明字缘字界。若字是字界。般那都为缘。若以般为缘。助于若界则名为慧。若以那为缘。助于若界则名为智。如僧人俗人等云云。名殊谓曰智曰慧。义殊谓决断拣择。此中义殊故使名殊也。体性无别者。皆别境中一也。前三种智皆名慧故。故智与慧皆如金刚。故萨遮尼干经云帝释金刚宝能灭阿修罗。智碎烦恼山。能坏亦如是。无常经云。金刚智杵碎邪山。永断无始相缠缚。疏波罗下。三释波罗蜜文三。初约语对翻。应云下回梵文。以西域风俗例皆如此云云。青龙云。蜜多者离义到义。元康云。天竺风俗所作究竟。皆云到彼岸。到离之义次文明之。疏谓离下。二约义顺释二。初释义前三句中。每句皆上法下喻。意明烦恼如大河。难可度故。生死如此岸。有情居故。涅槃如彼岸诸佛住故。则慧是能离能度能到。生死等是所离所度所到。若欲离此到彼。必须渡于中流。此约四谛说之。理则明矣。知苦是离此岸。断集修道是渡中流。证灭是到彼岸也。此顺小乘义说。下经令入大乘无余涅槃。即须离二种生死此岸。乘六度船筏。度三障中流。到二涅槃彼岸。涅槃等者。以翻波罗蜜为彼岸即是涅槃。是故约转依果。明彼岸义。然生死即分段变易。烦恼即总该二障。圆寂者义翻也。谓德备尘沙曰圆。妙绝相累曰寂。灭度者。肇云。涅槃者。秦言无为亦云灭度或但云灭。然灭与小乘不同。小乘以灭生死为灭。大乘以寂灭为灭。故涅槃云。生灭灭已寂灭为乐。然灭唯据果。灭度乃兼因。今则约果标因故云灭度。所以经中上言涅槃下云灭度。亦是唐梵双彰也。涅槃种类下文具明。疏一切下二通难。此即净名经文。彼云。若弥勒得授记者。一切众生亦应授记。何以故一切众生即寂灭相不复更灭等。今用此文以为难辞。难意云。众生既即寂灭。何有离此到彼。今言到彼者。莫违经耶。但以下释通。但约翻迷成悟。便是离此到彼。若悟此已渐除渐证。名为究竟。然成波罗蜜要与七最胜相应。如唯识说。疏若兼下。三顺义通结。则是波罗蜜中之闻思修慧也。疏经者下。二释能诠二。初翻名。修多罗或云修妒路。或云素怛览。此但梵音楚夏之异耳。义翻者。以修多罗正翻云线。由西天以修多罗一名召于四实。谓圣教席经井索线。彼多以华献佛置之案上。恐风吹散以线贯之。又见此方圣教。能持佛语得无所遗。如线贯华故。以线称目之。就彼处呼曰修多罗。据此正翻即合云线。此方不贵线称故翻为经。斯则暗符彼方席经。兼顺此土儒道之经。然虽符顺彼此。而未免相滥。由是更加契字以拣异之。然更合于修多罗上加欲底二字翻为契经。则唐梵皆足也。契者下二释义。诠表下释契字。诠表义理释契理也。谓说事如事说理如理。云云。契合人心释契机也。谓令人有所悟解欢喜信受。云云。斯则契理契机之经依主释也。文虽是倒意以经是能契也。经者下次释经字。初标以佛下释。如开题处明已。今唯言经而不言契者。以为有般若拣滥。明非道德等经故不言也。后释下二释经文疏二。初科分。斯则道安法师所判。但是佛经无问大小皆科为三。意云序分彰说法之由致。正宗畅本意之玄门。流通继遐芳于万古。冥符西域今古通遵。此经从如是至敷座而坐是序分。时长老下至应作如是观是正宗分。佛说是经下至信受奉行是流通分。证信者即六成就也。显说听时处一一分明以证非谬。令物生信故。发起者。则以事相表示发起正宗法义也。然此二序更有异名。谓通序别序。通谓诸经同故。云云。别谓诸经别故。云云。亦谓经后序经前序。经后序者。佛说之时未有。结集之时方安立故。经前序者。佛先发起方说经故。疏中三段今初。云云。疏建立因者。意明如是等言因何而立。佛临下。佛将入灭阿难愁恼。阿泥楼豆告阿难言。汝是持佛法人且须裁抑。汝当往彼咨问后事。阿难曰。云何后事。阿泥楼豆曰。世尊在日以佛为师。世尊灭后以谁为师。世尊在日依世尊住。世尊灭后依何而住。恶性比丘佛在之日佛自调伏。佛灭度后如何调伏。遐益后来理宜结集。一切经首置何等言。阿难承教一一咨问。今疏影略不载问辞。但书答语也。四念处者。四即身受心法。念谓念慧。处谓身等。即是念慧所安住处。则念是能住。身等四处为所住。于此四处安住念慧。名四念处住。带数释也。一观身不净。即有漏色蕴具有五种不净。一种子不净。乘过去业识种子。揽现在父母精血。合成身故。故净名云。是身如幻从颠倒起。是身如影从业缘现。智论云。是身种不净。非余妙宝物。不从华间生。唯从秽道出。二住处不净。于母胎中居生藏之下熟藏之上。常受熏秽。故智论云。是身如臭物。不因华间生。不从薝卜有。亦不出宝山。三自体不净。合三十六物以成身故。谓外有发毛爪齿眵泪涕唾垢汗便利等十二。次有皮肤血肉筋脉骨髓肪膏脑膜等十二中有脾肾心肺肝胆肠胃赤痰白痰生藏熟藏等十二。智论云。地水火风质。能盛受不净。倾海洗此身。不能令香洁。四自相不净。九孔常流不净物。故智论云。种种不净物。充满于身中。常流出不止。如漏囊盛物。五究竟不净。一旦命终胮胀烂坏臭恶狼藉不堪见。故净名云。是身假以澡浴衣食必归磨灭。智论云审谛观是身。终归于死处。难御无反复。背恩如小儿。金光明亦云。虽常供给怀怨害。终归弃我不知恩。二观受是苦者。受即是心所遍行五中一也。仍有三种。谓苦乐舍。苦谓苦苦乐谓坏苦舍谓行苦。问乐受未坏应非苦耶。答以乐是苦因故。凡夫妄计为乐元来是苦。问舍非苦乐云何苦耶。答行蕴迁流逼迫常苦。但以苦乐粗相所覆常情不知。此微细苦故。此三法俱名苦也。三观心无常者。心即缘虑生灭之心。谓心心念念前灭后生相续不绝。如水流注。故经中说一念中有九十刹那。一刹那中九百生灭。四观法无我者。法即五蕴。谓五蕴法中一一推求。即蕴离蕴皆无我也。如上观之。即能对治凡夫四种颠倒。谓凡夫颠倒则造业受生。及此用心自然无咎。以戒为师者。从其轨范。但依戒律作止分明。故菩萨戒序云。波罗提木叉者是汝大师。如来在日无异此也。默摈等者。佛法慈悲为无刑罚。比丘恶性唯默摈之。意令省己知惭自然调伏耳。经初等语释在次文。然此四中意在第四文中承便兼带前三。疏建立意者。建立如是等言意在于何。此有三意如疏三段。断疑等者。智度论说。佛灭度后诸天王等请迦叶言。乃至云。法城欲颓法幢欲倒。当以大悲建立佛法。迦叶受请往须弥顶击大揵槌诸圣弟子得神通者皆来集会。迦叶告言。佛法欲灭众生可愍。待结集竟随汝入灭。诸来圣众受教而住毕钵罗窟。迦叶入定以天眼观今是众中谁有烦恼应逐出者。唯有阿难烦恼未尽。尔时迦叶从定而起。于大众中牵出阿难告言。清净众中结集法藏。汝结未尽不应住此。是时阿难惭耻悲泣告迦叶言。我能有力久可得道。但为侍佛以阿罗汉者不得给侍故。留残结不尽断尔。迦叶告言。汝更有过。佛意不听女人出家。为汝殷勤致请。令佛正法五百岁衰微。是汝突吉罗罪。佛临涅槃近俱尸竭城。背痛叠郁多罗僧敷卧语汝须水。汝不共给。是汝突吉罗罪。佛昔问汝。若有人好修四神足。应住寿一劫。若无减一劫。为汝不对。令佛早入涅槃。是汝突吉罗罪。汝于一时以郁多罗僧。衬身而卧。是汝突吉罗罪。汝昔与佛叠僧伽梨衣以足踏上。是汝突吉罗罪。佛阴藏相。入涅槃后以示女人。实为羞耻。是汝突吉罗罪。迦叶言。汝有如是六种突吉罗罪。应于僧中悔过。是时阿难脱革屣袒右肩长跪合掌。依六种突吉罗罪忏悔。忏悔已。迦叶牵阿难出语言。汝漏尽可来。言讫自闭窟门是时阿难涕泪悲泣。求断结惑靡不精诚。至于后夜疲极偃息。头未至枕朗然得悟。三明六通作大罗汉。却至窟门击门而唤。迦叶言。汝复何来。曰我漏已尽。迦叶言。汝若漏尽可纵神通于户钥孔中入。阿难腾身入来礼拜僧足　迦叶手摩阿难顶言。我欲为汝令汝得道。汝勿嫌恨。此如苏秦张仪。云云。然阶圣果切在修心。不如说行事佛何益。狐假虎威宜其止绝。斯意甚妙详而警之。时大众请阿难升座结集法藏。既升座已未发言间。感得自身相好如佛。是时大众遂起三疑。故说下既言我从佛闻。则知非佛重起非他方佛来亦非阿难成佛。故云三疑顿断。广如彼论恐烦略叙也。疏息诤等者。同为罗汉德业颇齐。若云自言固宜喧诤。疏异邪等者。阿者言无忧者曰有。外道意云。万法虽异不出有无。置之经初以之为吉。以初吉故今中后亦吉。今则不尔故云异邪。疏正释下二。初标列述意。言成就者。谓六为能成就。教为所成就也。疏一信下。二依科解释六初中二。初合释。谓兼次段合而释之。此则别义不计六数单释谓正释信成就义。所引论文有标有释。佛法下是释。或曰因何最初便明其信。故此释也。信为能入者。然佛法无量信为初基。若无信心宁肯修习。由是五位之内信位居初。十信之中信称第一。十一善法信亦为先。故知信心之前更无善法。依此信本方兴解行乃至证入。故华严云。信是道源功德母。长养一切诸善根。断除疑网出爱河。开示涅槃无上道。今置经首以表信相为入法之初也。智为能度者。菩萨万行非智不成。若无智慧即滞有着空。以智为主不着二边。成无漏因获菩提果。故菩提资粮论云。施戒忍进定。及此五之余。皆由智度故波罗蜜所摄。信者下正显。如是二字是信之辞。上皆智论所释。又圣下。是刘蚪注无量义经中释。此下皆约法说也。显如者。众生如隐故沈三界。欲沈三界只要显如。故云但为除如之外余皆虚妄。故云唯如为是。论云除诸法实相余皆魔事。有云。始从得道乃至涅槃。其中所说无不为如。又有下。即梁武帝解意明。有即无故不有。无即有故不无。相即同时故名不二。不二即如也。此约双融显如也。如非下。恐闻有无不二为如。便谓如体是有是无。故有遮云如非有无。意明有无即不是。是即非有无也。此上二解。如字是显体。是字即无非也。疏二闻下二。初正释我闻之义。然我有四种。一凡夫遍计我。二外道神我。三三乘假我。四法身真我。今拣余者故云五蕴假者。则第三随世流布。要简宾主乃称于我。阿难已达我空。实不计执故云假者闻者然大小乘诸论辨闻不同有云耳根。或云耳识。或云根识和合故闻。今云。耳根发识则后义也。以根识单阙皆不能闻云云。然根识闻声而不闻教。若准名句唯是意闻。故瑜伽云闻谓比量。然由耳识缘于声境与意同时得闻也。然此二识闻声名句。实非先后异时。以率尔耳识同时意识故得闻也。五识皆然。废别下。或曰既云耳根发识故闻。合云耳闻。云何经内唯言我闻。故此释也。以耳是六根之别我是一身之总。今废别耳从其总我。故言我闻。阿难下。二啇较所闻之法。前二句牒难辞。谓阿难是佛成道夜生。年至二十方为侍者。二十年前佛所说法并具不闻。何得结集诸经皆称我闻。有云下通释。此有三意。有云重说者一也。佛初命阿难为侍者。阿难从佛乞三愿。一不着佛退衣。二不随佛受别请。三请说未闻之法。佛随其愿故得闻也。得深三昧等者二也。金刚华仙经说。阿难得法性觉自在三昧力。故前所说经皆能忆持。与闻无异。故法华经云。世尊甚希有。令我念过去无量诸佛法如今日所闻。若推下三也。不思议境界经云。复有百千万亿菩萨。现声闻形亦来在座。其名曰舍利弗乃至阿难等。是则三中前二权说后一实论。故言推本也。疏三时下二。一栋显释师资合会者。谓说者教人以道德曰师。资者取也。从师之教取而行之也。佛及大众说听具足故云合会。说毕听毕故云究竟。意取说无异席贯通首末。故曰一时。佛地论云。此就刹那相续不断说听究竟。总名一时。一时之语佛自言故涅槃云昔佛一时在尸首林。又云。我于一时在迦尸国。此则显说听能所一切圆毕也。诸方下。拣时也。不同有二。谓横则参差不同。竖则延促不同。延促不同如人间五十年四天王天一昼夜上上倍增。故参差不同者。如俱舍云。夜半日没中日出四洲等。既然云何定言寅卯辰已日月等耶。又说下。二会法释。此是悫公楞严疏意。说领即师资也。下有四对。心竟泯者。以闻法之时妄心不起。心既不起境即不生。心境两亡故云泯也。此即不得以生灭心行听实相法。此通依计故皆泯也。斯则染心俗境一对。理智融者。以听法之际能所不分。以动念即乖法体。二皆真实故。言融而不言泯也。斯则净心真境一对。凡圣如者。由心分别则见圣见凡。心既不生谁凡谁圣。相本目尽故言如也。斯则因果一对。本始会者。妄念起时隔于本始。念既不起本始自同。摄用归体故言会也。斯则体用一对。问此与第二何别。答前智是始觉中根本智。前理是本觉中真谛境。若此始本本通真俗。始舍本后则前狭后宽也。前为形染且言真境净智。此为都明故言本觉始觉也。又前约分证故云理智融。此约极证故言本始会也。诸二者。谓心境理智凡圣本始也。皆一者一义不同。谓心境则泯之故一。理智则融之故一。凡圣则如之故一。本始则会之故一。义虽不同俱名为一。故云一时。疏四主下二。初翻名。经唯标佛者。以秦人好略故。仍存梵音者。恐滥菩提故。以菩提云觉则属于法。今指于人故言其佛。无相滥失故不翻也。若释其义须得唐言。故先翻对也。然觉谓觉察觉悟。觉悟既照真本有。觉察则了妄本空。了妄本空则不逐于妄。照真本有则不迷于真。真妄既明则能破和合识灭相续心。显现法身智纯净也。当尔之时。始本无二唯一觉耳。菩萨虽亦照真了妄。未得究竟。犹带萨埵之名。唯佛如来所作究竟。故独称觉者。起信下二释义二。一约体离念释。然此论明本觉心体性离诸念。今此引释果佛者。以果佛之体即是本觉元自离念。因果虽分离念无别。故以本觉离念即是佛体。故经云。大乘因者诸法实相等。是故在缠名本觉。出缠名究竟觉。始终体一更无别法。故论云。即是如来平等法身。依此法身说名本觉。则以下。疏结本觉离念是佛体也。然觉下。二约位三义释。无生灭者。谓智照真如如理见故。然有二意。一则心中无生灭之法。如起信云。如实空者。从本已来一切染法不相应。故以念生则染。今既无念故不相应。二则无者不也。只明此心本不生灭。即同起信云。以远离微细念故得见心性心即常住。常住即无生灭也。觉他者。此亦始觉了事即真。以望自心故名觉他。即同起信云。一切诸法从本已来。离名字相离心缘相。毕竟平等无有变异。不可破坏唯是一心。故名真如。觉满者。以前二觉有解有证。先后胜劣存自他之相。未得称满。今此圆备不立自他故称之满。若准涅槃经说。自觉者觉自身有佛性。觉他者觉一切众生悉有佛性。觉满者。若自若他无二佛性故。然常途所说。自觉拣凡夫。觉他拣二乘。觉满拣菩萨。此中说者。自觉便拣二乘权教菩萨。岂唯凡夫。故华严云。一切诸法性。无生亦无灭。奇哉大导师。自觉能觉他。故知下。二引论反释三。初反显。意云无念故名觉。当知有念则不名觉也。起信下二引证。前云心体离念虽通因果今明众生不名为觉。独显果人方名觉也。又云下三顺结。正结无念是佛义。以无念是佛。故能观无念者。即是向佛智也。疏五处下二。一释舍卫。舍卫亦云舍婆提。新云室罗伐悉底。此但梵音楚夏耳。此城在中印土憍萨罗国缘。南天亦有憍萨罗国。恐滥彼国故。以城为国名。闻物者。谓名闻胜德珍奇宝物多出此国。谓具下释。欲尘即佳丽女色。财宝即珍奇宝物。多闻谓博通内外典籍。解脱即五通仙人等。远离欲也。此即国丰四德。亦翻为丰德也。远闻等者。如上四事皆为外国之所闻知。义净下。但证远闻之义。以有名称故得远闻。祇树下二释祇园二。初总指。舍卫国主波斯匿王有一大臣。名须达多。为儿聘妇躬至王舍城。寄止长者珊檀那舍宅。时长者中夜而起。庄严舍宅营办肴膳。须达闻已问言。大士欲请国王为婚姻之会耶。答言请佛无上法王。须达闻已身毛皆竖。复问何等名佛。长者广为说佛功德。须达多言。善哉大士所言。佛者功德无上。今在何处。长者答言。在王舍城迦阑陀竹林精舍。时须达多一心念佛。忽然天明其光炽盛犹如白日。即寻光处至城门下。佛神力故门自开辟寻路而往。尔时如来出外经行。须达见已欢喜踊跃。不知礼法直问世尊。时首陀天。为其长者化作四人至世尊所接足礼拜。胡跪问讯右绕三匝却住一面。须达见已依而为之。世尊即为如应说法。长者闻已得须陀洹果。后复请佛。惟愿临顾至舍卫城受我微供。佛即问言。卿舍卫国颇有精舍容受我否。须达多言。必见垂顾便当营办。世尊尔时默然受请。时须达多回舍卫国。佛令鹙子同往指授造寺仪式。即须达布金。买只陀太子园。只陀太子施园中树林。二人共构精舍。既讫即执香炉向王舍城。遥作是言。所设已辨惟愿如来受此住处。佛时悬知长者之心。即共大众发王舍城。犹如壮士屈伸臂倾至只陀园。是时长者以其所设奉施于佛。佛即受已即住其中。广如涅槃经贤愚经四分律西域记说。须者往检。今佛于此说金刚般若经。故云在舍卫国祇树给孤独园也。然须达是主只陀助成。今树先园后者。以太子是储君须达是臣佐礼别尊卑故尔。真谛记说住处有二。一境界处即舍卫也。为化俗故。二依止处即祇园也。为统出家人故。又善见婆沙云。举舍卫令远人知。举祇园令近人知。故双举也。只陀下二别释三。初释只陀。战胜者亦云胜林。余如疏。梵语下二释给孤。谓少而无父曰孤。老而无子曰独。拯给孤独名为善施。又亦等者。就中孤独偏所矜哀。其实余人亦非不施故也。西国下三释园字。梵音具云僧伽蓝摩。此云众园。则僧伽是能住之众。蓝摩是所住之园。斯则约能要所耳。寺者司也官舍也。以佛法初来安鸿胪寺。后置僧舍便以为名也。疏众者下文二。初释标类。名高谓遐迩称誉。德着谓行业恢隆。怖魔者谓初出家日。飞行夜叉唱乃至魔宫闻故怖也。以一人出家展转化度损减眷属故。然出家人从因至果三度怖魔。谓出家时发菩提心时成正觉时。前二但怖。后乃兴戈为佛所摧莫不降伏。乞士者。谓上从善友乞法以练心。下从檀越乞食以资身。故智度论云。何名比丘比丘名乞士。清净活命故名乞士。如经中说。舍利弗乞食向壁而餐。时有梵志女名净目。来见舍利弗云。沙门汝食净耶。答言食净。净目言。沙门下口食耶。答曰不也。乃至问仰维方等。皆答言不也。净目女言。食有四种我问于汝。汝皆言不。我今不解汝说。舍利弗言。有出家人合药种谷植树等．不净活命。名下口食。有观星宿日月风雨雷电等不净活命。名仰口食。有曲媚豪势通致四方巧言多求不净活命。名方口食。有以种种咒术卜算吉凶不净活命。名维口食。姊我不堕是四种不净食中。我用清净乞食活命。净目因闻是说清净法食。欢喜信解得须陀洹道。如是清净乞食活命故名乞士。净戒者。谓比丘二百五十戒。比丘尼五百戒。有表受无表持清净持戒名为净戒。有说五义。谓加净命破恶。今以乞士即净命净戒即破恶故唯三也。理和下。梵语僧伽此云众和合。谓理和无违事和无诤也。千二下。二释举数。佛初成道者。即菩提树下。示成正觉也。憍陈如等者。余阿湿鞞摩诃男婆提婆敷富那婆蹉。准本行经说。佛初成道梵天王等请转法轮。世尊受请作是思惟。诸世间中谁先得度。有五仙人昔日与我有大利益。堪能受我初转法轮。复作是念。彼等五仙今在何处。以净天眼观彼五仙在鹿野苑中。尔时世尊即向彼园广为说法。外道身心悉皆伏灭。所著之服即成三衣。手执钵器须发自落。经于七日威仪具足。如百夏比丘。乃至为转四谛法轮。得阿罗汉果。迦叶三兄弟等者。智度论说。尔时第一优楼频螺迦叶。在火龙窟为首。教化五百弟子。二那提迦叶。领三百弟子。在象头山修行。三伽耶迦叶。领二百弟子。在希连河曲。共计千人皆为世尊之所降伏求索出家。师徒皆得阿罗汉果。舍利弗等者。智度论说。摩伽陀聚落有婆罗门。名檀耶那。而有八子中有一子。名优婆低沙。即舍利弗也。复有一婆罗门产子名离多。即目连也。是二童子共为亲友。于删阇耶外道所出家。二人同心立其誓愿。若复更得胜是师者。为我等说甘露胜道必相契悟。尔时世尊有一弟子名曰马胜。威仪庠序入城乞食进止有方。舍利弗见已。随到所止白言。仁者。汝是正师为是弟子。马胜言。别有大师我是弟子。又复问言。汝之大师说何法耶。答言。诸法从缘生。诸法从缘灭。如是灭与生。我师如是说。时舍利弗闻是语已。即于是处远尘离垢得法眼净。归到所止为目连说亦复如是。二人共相领诸弟子。俱诣佛所求索出家。佛呼善来须发自落袈裟着体。执持应器成比丘相。于声闻众中。智慧神通各得第一。是二百眷属。悉得出家即受具戒。乃至得成阿罗汉果。耶舍等者未检。此常随等者。以此诸人先并事外艰苦累劫一无所证才遇见佛便得上果。感佛恩深故常随也。然具四众及龙天等。今但显一隐余。流通分中自俱者下。前则标指约主望众故言与。此则都结主众通论。首末相望事不异也

金刚经纂要刊定记卷第二金刚经纂要刊定记卷第三

        长水沙门子璇录

二发起下二。初叙意。戒能下。以戒是防非止恶义。定是寂静不动义。慧是明照拣择义。但能防非心即不动心。若不动慧乃分明。世出世法无不鉴照。其犹海中欲现万像必要水清。欲求清水无过水静。欲得水静勿令起波。止波如戒水静如定水清如慧。所现万像如一切法。喻中则水若不起波则水静。水静则水清。水清则现万像。法中则心不起非则心寂。心寂则照知万法。法上但唯一心。喻上但唯一水。法喻相对义则昭然。故经云。尸罗不清净。三昧不现前。此则戒资定也。圆觉云。一切诸菩萨。无阂清净慧。皆依禅定生。此则定发慧也。疏戒中七节如疏。一化主俱上九号者。以佛有十号世尊当第十故。云具上九号。十号者。一如来二应供三正遍知四明行足五善逝世间解六无上士七调御丈夫八天人师九佛十世尊。二化时当日初分者。谓一日夜十二时总成四分。一初分即寅卯辰。诸天食时。二中分即已午未。人法食时。三晡分即申酉戌。神鬼食时四夜分即。亥子丑畜生食时今言辰时。即初分之后际也。唐周二译皆言日初分。斯则时胜也。此时则乞求不难。以太早太迟皆难得故。若非时乞食欲施即无不施又愧。便成恼他。乞之不得亡餐又饥。是恼自也。三化仪下。谓佛有三衣。一安陀会。即五条名下品衣。亦名行道作务儭身等衣。二郁多罗僧。即七条名中品衣。亦名入众说法衣。三僧伽梨。即九条乃至二十五条名上品衣。亦名福田衣。制像水田见生福故。入王城聚落即着此衣。今以入城乞食故着也。天王钵者。梵语钵多罗。此云应量器。是过去维卫佛钵。入涅槃后龙王将在宫中供养。释迦成道龙王送至海水上。四天王欲取化。为四钵。各得一钵以奉如来。如来受已重叠四钵在于左手。以右手按合成一钵。此是绀琉璃石钵。持用乞食也。佛出行化须。着衣持钵者。为离苦乐二边故。诸在家者。好尚锦绮华洁衣服宝器增长放逸。太着乐边。出家外道苦行尼干裸形手捧饭食致招诃丑。太着苦边。佛处中行故着衣持钵也。四化处者。园是所住处。国是所化处之往也。今行化故出祇园入舍卫也。处广等者。准西域记。国周六十余里。内城周二十里故云处广。智度论云。居家九亿故曰人多。五化事者此释经中乞食两字。头陀下。或曰佛为教主何须乞食。故疏释也。头陀此云抖擞。抖擞烦恼故。然头陀有十二种事。谓常乞食阿兰若乃至树下坐露地冢间坐等。今则一也。若行此事获大功德。佛现斯轨令人效之。头陀既获功德。放逸足明尤过。世尊尚自乞食。余人岂合懈怠。惭耻愧悚自然行之。同事摄者。则四摄法之一也。又佛自乞食。准缨络经说有十意。一止苦故。谓盲得见。二得乐故。谓一瞻一礼生无量福。三除慢故。谓众生见之不生我慢。四满钵愿故。富欲施多钵则为空。贫欲施少钵则为满。五鬼神供养故。六障阂者见佛故。老病贫贱悉皆得见佛也。七示天王所献钵故。八作轨模故。九绝诽谤故。十令弟子不畜八不净物故。有此十意故自乞食。缨络女下通难。前引经难。今所下释通。净名下但证上乞食不食之义。六化等者。此释经中于其城中次第乞已也。内证平等者如理见故。心离贪慢等者。不贪富好不慢贫拙。平等修乞故。云慈无偏利也。表威德等者。谓佛制小乘律。不许入恶象家。恐彼损害。不许入淫女沽酒家。恐生染心。佛入者表威德胜也。息凡夫等者。谓恐憎此爱彼故。破一乘分别者。谓迦叶舍富从贫乞。意令生福。须菩提舍贫从富乞。不欲恼他云云。二人所见互有是非。如来异此是非一贯也。然上五中。初大智二大悲三显德四息凡五破小七化终。然已等者。和会字之句义也。今读则从文释则从义。若广下。权加数字显文义兼畅也。饭即吃也。论语云饭疏食。佛苦下通伏难。应先难云。前引缨络女经言不食。今经何以言食。故此释也。有说。食欲至口有威德天在侧。隐形接至他方施作佛事。斯则示现而食。非真食也。由是彼此皆不相违。宝云下显斋仪也。此四事中。前二云拟后二不云者。以梵行贫病来则与之不来自食后二不然故不云耳。十二头陀经。除梵行者以自乞故故不分之。疏定者。于中三节如疏云云。疏并资缘者。此释经中收衣钵也。饭食两字如前所解。讫了毕也。须并资缘者。以修定时具于五缘。谓闲居静处息诸缘务等。佛虽至圣诸习都无实于衣钵不生劳虑。若不并除后人仿效无由得定。以佛是教主。凡有所作人皆效学。故云示现为后轨也。疏净身业等者。此释经中洗足已三字。阿含下牒难也。又如佛三十二相中有皮肤尘不染相。今何用洗耶。示现下释通也。此有三意。一顺世故。夫人外归必恐尘染。故须洗足。佛顺亦尔也。二表法故。洗去烦恼垢染。显得清净法身也。三为后轨者。如资缘说。疏正入定者。此释经中敷座而坐也。沉掉等者。沈谓昏沉。能引睡眠障定增故。掉谓掉举。任运攀缘能引散乱亦障定心。又于四仪中。以卧则昏沉。行则掉举。住则疲倦。唯坐为胜。故不沉掉。然昏沉掉举。盖是凡夫。若据如来的无此事。今垂轨则盖为后人。或曰经中但言敷座。焉知入定耶。故次释云魏译等。则知入定也。如常敷座等者。谓如来每会说般若。皆自敷座具。为般若出生诸佛即是佛母。表敬般若。故自敷座已说。八会。此当第九。仪轨不易故曰如常。趺谓足背。加谓以一足压一足。结即两足不散表吉祥。故智论云。见画加趺坐魔王尚惊惧。何况入道人端身不倾动。又为正观五种因缘。是故结加趺坐。一由身摄敛速发轻安。最为胜故。二由此宴坐能经时久不令身速疲极故。三由此宴坐是不共法。外道他论皆无有故。四由此宴坐形相端严。令他见已极敬信故。五由此宴坐佛佛弟子共所开许。一切贤圣所称赞故。正观五种因缘。是故应当结加趺坐。端身住者。不低不昂不左右倾侧也。正念者。如理而念名为正念。念即念慧。谓离沉掉有无等。不动谓不动于正念也。唐译下亦证同上义。正愿者即正念也。若别说者愿是希欲。谓希欲住对面念。念是所愿也。然在定前异。此则非正愿也。住对面念者。面即是喻念即是法。住对两字通于法喻。今法喻之中各阙一事。谓法阙所照理。喻阙能照镜。镜对面住面则自彰。念对理住理则自现。法喻阙者文影略故。或可不尔。但理观分明。如面目睹现量。即水喻亦得。无著下显入定意。先牒难并缘入定。意在于何。于此下释通。于此者论云于法也。能觉者定通。能说者说通也。意云定通方得说通。以散心说法不能如实。从定发言必有当也。故下文云。云何为人演说不取于相如如不动。诸经之中每欲说法皆先入定。意皆如此云云。斯亦示现为后轨也。若准如来言念何失。是故论云显示等也。疏然大。下二通前表法释二。初约大云广辨三。初标。大圣即佛体。周法界曰大智鉴无昧曰圣。现迹者所现之化迹也所。表者诸佛所为必不率尔皆以事相表内身心。如说。如来。藏经举身放光光中现华华。萎见佛遂阿难问佛。佛为说之。如华严中说佛菩萨说天说云须弥山大海等。皆有。所表。斯皆事相为能表法为所表。以不徒然故云必也。疏表本觉下。二释二。初表通序。本觉佛对化佛说。五蕴都对舍卫国。化身佛在舍卫国。表本觉佛在五蕴城。城中既人物相兼。蕴内亦色心具足。觉魔等对战胜也。梵音魔罗此云杀者。能杀行人慧命故也。然有四种。一天魔即欲界主。二烦恼魔。三阴魔。四死魔。今言觉空者如心经云。照见五蕴皆空无无明。乃至亦无老死尽也。照五蕴空即破阴魔。无无明尽破烦恼魔。乃至无老死即破死魔。余出世法尚空。况天魔耶。照心识具德者。对给孤独也。上迷本觉之父曰孤。下隐妙用之子曰独。今照性本具尘沙功德无所乏少。即给孤独也。求法等对比丘乞士义也。外则乞食养命内则求法资神。觉心下二表别序。觉心等者对入舍卫大城也。应云觉心既发宁弃尘劳。如来出世宁弃群品。将欲遍观遂入识藏。将欲教化遂入王城。离城邑而教化谁人。离心识而观察何事。心心数法等者。对于其城中次第乞已也。乞食不拣贫之与富。观察岂择心所心王。即妄下。二句对乞得食也。外化人而得食。内观法而生喜。法喜下二句。对还至本处饭食也。食能资身法能益心也。思惟假缘对着衣持钵。忘缘符真对收衣钵也。乞食既须衣钵。思惟要假因缘。入定既并资缘。契理须忘念虑。观照下二句对洗足也。若欲安坐必须洗去足尘。若欲还源必须拂除心念。返本下二句对敷座而坐也。法空即敷座。心寂即而坐。敷座方堪人坐。法空心始得寂。心寂下二句。对正宗法也。谓安坐始能说经。心寂方彰妙慧也。疏欲谈下三结也。资圣下。二引资圣略明。即道液法师疏也。今摘而用之文不全取。于中二。一正明。身有二者通论生佛也。伪者色身真即法身。五蕴等者。谓衣以外覆食以内资。生则虽因父母。存即须假衣食。法身等者。谓非生因之所生。但了因之所了。由是色身以食为命。法身以慧为命。保伪谓执妄合尘。遗真谓迷理背觉。此皆倒也。养真谓悟理合觉。弃伪谓达妄背尘也。群生下牒前倒者也。我乃下。示现入城乞。食以表法也。意令求般若照成法身故。云引真也。故托下。都结表法之意。谓示现乞食。意在说法耳。疏涅槃下二引证。但证法为食义也。正宗中疏二。初标章门。以一卷经文二论解释。大云青龙皆二论并行。今即不尔。何者以无著配十八住处天亲断二十七疑。旨趣既殊科段亦异。或一疑中有四住五住。或一住中有二疑三疑。乍合乍离连前带后。以是之故文涉交加。理则不必深玄。学者以之难解。今既别释庶不相干。传讲之流少力多获耳。初中三。初正示七句。七义句者。论述归敬偈已。即云成立七种义句已。此般若波罗蜜即得成立。义句拣文句也。既以一义为一句。此经共有七义句也。七义句名疏中自有。于中前六显示菩萨所作究竟。第七显示成立此法门故。然此七句之文。教理行果悉圆满矣。于中一二三四是行也。五理也六果也七教也。齐此悬判一科。唯依无著之名记之。疏一种性不断者。此非凡夫二乘及权教菩萨。意明佛种性不断也。谓护下指经。便是释意谓。以小付大嘱大化小。展转如是宁有断绝。如人父母付嘱子孙云云。此是空生之本意。故以此事赞佛。引起问端也。疏二发起行相者。既欲种性不断。故须发起修行之相也。谓申下指经。其实伫听亦在此摄。疏三行所住处者。既有能发必有所发也。十八住名义下文广释。从佛下指经。是无下释名义。此即相之无相。非一向之无相。略见行玄为顺本宗故标无相也。疏四对治中。邪行即不正行也。但不顺佛道皆名邪行。共者不一义。见者分别情。正行者即离见之正行。非纯正之正行也。二种对治者。以正行治邪行。是一对治。以无分别智治分别见。是二对治。然邪即全治。共中即但治于见不治正行。如披砂拣金而去砂不去金。今经中但有能治无所治也。且如第一住处中。不度众生为邪行。度众生为对治。于度众生时见有众生是所度。见我是能度是分别。见度而无度为对治。此理实同时义分前后。初住既尔余可例知。故论云。行诸住处时有二种对治。疏五不失中谓由下明意也。离增减者。谓执有为增执无为减。前堕此二则失中道。今皆离之故得不失也。如经中即非佛法。是胜义谛遮增益边。是名佛法是世俗谛遮损减边。其余即非是名皆例此也。论最后结云。菩萨离此二边故。于彼对治不复更失。故名不失。疏六地位中谓由下释。以二边邪僻置之不论。中道乃是大菩提路。故于此中分立地位。如往帝都有三路异。两边皆非中道即正正路之中方可论于远近迟速等也。法中亦尔。故经云。一切贤圣皆以无为法而有差别。信行下分位也。于十八住中。前十六住是信行地。此当三贤。依信起行故名信行。亦名信解。依信起解故。第十七住是净心地。此当初地。离分别障亲证真如故。第十八住从第二地已去。乃至佛位。通名如来地也。又以诸家明地位或广或略广则五十二位。略则泯之全无。今则均于广略。去其太甚说三地五位矣。疏七立名中。谓由下释。谓约三种法上立金刚名。一约般若体用名金刚。此如金刚坚利。二约地位阔狭名金刚。此如金刚杵形。以信行一僧祇净心只一刹那佛地二僧祇。如金刚杵初后阔中间狭故三约文字名金刚。此如画像也。以诠信行地七纸余经佛地三纸余文净心地五行经。如彼画像亦初后阔中间狭故。又此三者。法喻之上皆展转而成。喻中且根本。是坚利金刚。因造以成其杵。因画以成其像。法中根本是体用般若。因修以成其位地。因诠以成其文字也。又此法喻各三事中。一事即实余二皆虚。喻中坚。利金刚是实。杵形画像皆虚。法中体用般若是实。位地文字皆虚。以此三事首末相似故。立金刚之名。然前一是佛本意。余二是菩萨及古德意也。由前六等者。于中前五坚利。第六阔狭。阔狭之中含能所诠也。疏后四下。二总指后四。应先问云。第三句内说尽经文。未知后四如何配摄。故此云也。谓一一住说对治故。于对治处显不失中道故。于不失中立位地故。于前六中道立名。故云云疏十八下三。广释弟三。三一正辨十八住处。疏中具列十八住名略释。其义兼明对治十二。种障便指经文令知科段所属。然每住经文疏。但略标三字五字。缘以经本科段首尾文势稍重。恐言涉相滥故。不标最初之字。但取其次异文。亦不结终齐至何处意在省约耳。向下随文略叙首末。以隔前后。一中发心者。谓发广大第一等四种心也。经文从佛告须菩提诸菩萨摩诃萨应如是降伏其心。乃至若菩萨有我相人相众生相寿者相即非菩萨。以大乘菩萨最初法尔合发是心故。十八住中居其第一。二者经从复次须菩提于法应无所住行于布施。乃至须菩提菩萨但应如所教住不住等者。等有二意。一则等于余文。如上所引。二则等于余义。谓等余戒等五也。此则虽是指经便兼释义。则波罗蜜是所应。戒等是能应。能所两合故云相应。由是但行施戒等不能离相。或行离相不行施戒等皆非相应行。直于行施戒等处离相。离相处行施戒等。方得名为相应行也。三者经从须菩提于意云何可以身相见如来不乃至若见诸相非相即见如来。问色身是相。何以离相求之。答色身之相是影。法身无相是体。欲得有相色身。须见无相法体。未见法体不能现相。是故先令见相无相。方得色相之身耳。此中意在文外。故论此意科也。四中言说者。经从须菩提白佛言。世尊。乃至法尚应舍何况非法。问法身非言说。何故以言说为法身耶。故疏释云。因言显理故。此有二意。一以言说显于法身。法身非言说。二文字性离即是法身。无别法身耳。智相者。经从须菩提于意云何如来得阿耨菩提耶。乃至一切贤圣皆以无为法而有差别。则以无相无为法为智相也。故起信云。以智相无可见故。福相者。经从须菩提于意云何若人满三千大千世界七宝以用布施。乃至须菩提所谓佛法者即非佛法。斯则以持说此经获无漏福。所感微妙色身。名为福相也。然是法身之福相。福相非法身。依主释。五于下文三。初正示此文。经从须菩提于意云何须陀洹能作是念我得须陀洹果不。乃至是乐阿兰那行。得胜者。以小乘四果胜于四向等故。对劣彰胜也。此即以小况大也。小人尚犹无过。君子岂合有愆。由无慢故方得证果。故经皆言我不作是念我得须陀洹果等。从此下二通叙后段。意明等者。叙次第之意也。先问云。前之四住何不言离障耶。故云也。意云凡欲修进先须发心。发心已则修行故。有第一第二。发心修行本求佛果。佛果之内唯有二身。粗细之间先色后法。故有第三第四。前修胜行恐有慢心障入圣位故说小果以况大乘。今离障进入十回向位也。故从第五方说离障也。然此十二障。每至一住皆须蹑前以辨来意。如云虽得无慢犹自少闻。故于第六住中对治少闻障。他皆仿。此以此诸障皆在地前。能障见道。非是地上故。云障尽入证道也。然障是所治文在经外。住是能治正是经文。若相望说之理则明矣。今当下三别结对治。然准五蕴论说。慢有七九二种。但开合之异。此约入道人说。七者论云。一慢。于劣谓胜于相似谓等。二过慢。于相似谓胜于胜谓等。三慢过慢。谓于胜己计胜彼。四邪慢。己实无德计己有德。五我慢。谓于五聚蕴计我我所。六增上慢。谓于胜妙法中未得谓得。七卑劣慢。于多分胜计己少分劣。今所离者即五六也。以证我空故。取自果故。六者经从佛告须菩提于意云何如来昔在然灯佛所。乃至实无所得。云何离障得成住耶。疏次云离第下所离障。不离下结成住义。于中上句成住。下句离障也。若离佛世不名住处。无佛说法则是少闻便成其障。若不离佛世。乃成住处。常遇佛说法。则具多闻便离障也。然凡是修行。智慧为本。欲得智慧必须多闻。故依佛住离少闻障也。故经云。多闻增智慧勤闻第一方。问若然者据今经云。于法实无所得岂成多闻。答此是闻而无闻得而无得。无得而得是真得。无闻而闻是实闻。故成此住。七者经从须菩提于意。云何菩萨庄严佛土不。乃至应无所住而生其心。离小下所离障。攀缘即是作念。盖一义耳。缘形等者。意云若取色声等相为土。即有分限故名小也。以不如法身故。若不取相分别不生。心境两亡竟何分限。故云大也。契法下释所以也。意令忘怀严法性土。不令生心严法相土也。故经云。不应住色等生心。应无所住而生其心。偈释云。智习唯识通。如是取净土。非形第一体。非严庄严意。八者经从须菩提于意云何譬如有人身如须弥山王。乃至是名大身。成熟者。即由教化令众生成种根熟有所悟证。离舍下所离障。若舍众生即不能教化。故令离障方成住也。若见大小下反释所以。意言能济物者。盖为不见大小也。故经云。佛说非身是名大身。岂存大小。若见大小则有高下亲疏憎爱。心既不等宁曰大悲。纵使化生但成爱见憎者则去。便舍众生云何成熟。反此用意则物无有遗。迟速之间皆能成熟。九者经从须菩提如恒河中所有沙。乃至如来无所说。离乐下所离障然随顺外论即是散乱。但能远离即成住也。即儒墨文笔。除佛教外皆外论也。以外论之事是名利源。既若求名岂得心无散乱。况得之则乐失之则苦。苦之则忧乐之则溢。由斯业累世世沉沦。反推其本皆由随顺外论耳。恒沙下。举持经福多以责外学。意云。持经者功德若此。而不修行名利之源。是轮回苦本。如何随顺却乃修学。十者经从须菩提于意云何三千大千世界所有微尘是为多不。乃至是名世界。色是依报即外四大。身是正报即内五蕴。抟取者即和合义也。但秦魏译异尔。然抟取约法相应兼人。二事相望总有三对。一内身色蕴及外器界。但合微尘所成。名为抟取。见有身器为依正。执取等即是相应。二受等四蕴。但合心心所法而成。名为抟取。见有苦乐受等。即是相应。三色心和合以成此身。名为抟取。见有心色即是我人相应。行即迁流造作之义。观破之义如下所明。影像相者。谓色心等法。是法界中之影像。亦可是业识之影像。离破下所离障。无巧便者。由无善巧方便。不能破此影像。乃名为障。若有巧便破之。则成其住也。巧便之相彰在次文。既离下。蹑于前住以为方便之本。由无散乱则成其定。从定方能发慧观而破之。以细下。正示二种方便。巧便之相也。然破色具二破心唯一。除细末也。以心心所法不可析破故。粗色显著难忘执情。析至极微易袪妄念。故须具二。如下文说。相想即心境也。心境两忘故云除。十一者。经从须菩提于意云何可以三十二相见如来不。乃至是名三十二相。离福下所离障。欲入圣道须福资粮。如人远行岂可空往。佛为至圣是福之因。供养给侍无不获福。即以此福为其资粮。若供养得福。即是住非障。反之则是障非住也。不以下或问文云。不以相见如来。如来尚不得见。云何给侍耶。故此释也。此即但以智慧随顺相应。名为给侍。然非谓弃却相身别侍无相之佛。但了相即非相。不生执着乃曰相应。凡所供养亲近恭敬。皆名给侍。若生执着不顺于理。虽常见佛不名为见。如下文云。若以色见我。以音声求我。是人行邪道。不能见如来。华严云。若人百千劫。常随于如来。不了真实义。盲瞑不见佛。又如佛昔三月升忉利天为母说法后降阎浮。有莲华色比丘尼。欲先见佛化作转轮王。队仗往至佛所。佛乃诃之具陈上事。时须菩提在于山中。亦欲见佛寻复思念。空无相理是真法身。何用见色相。言已复坐竟不往见。于是佛告莲华色言。须菩提先见我竟汝已在后。故知执相迷真对面千里虚心体物天地一家。故古人云。肝胆虽近。情生则隔。江山虽缅。道契则邻。是知通达妙理方真给侍。若斯给侍是侍真佛。故所获福无有边际。十二者。经从须菩提若有善男子善女人以恒河沙等身布施。乃至是名第一波罗蜜。离乐下是所离障。然障名有所阙略若取周备不过住名。但乐味成障远离成住。且约为障起过有其五重。一为身求利。二由求利养令身疲乏。此复有二。一由放逸令身疲乏。二求不得身亦疲乏。三由身疲故令心热恼。四由心热恼故不起精进。五由不精进故退失功德。恒沙命施下释成对治。经苦校量意令改革。以见大利故不求小利。既不求利身则不疲。身既不疲心则不恼。心既不恼则起精进。既起精进则能受持获无边福。故知经意为治此障成其住也。一身者一报身也。意云岂为一报之身。终日求名求利。求之不足未始称情。纵使多财死为他物。持经功德无量无边。尽未来际用之不竭。利害若此人何不然。无常经云。眷属皆舍去。财货任他将。但持自善根。险道充粮食。十三者。经从须菩提忍辱波罗蜜。乃至如人有目日光明照见种种色。离不下所离障。此但不忍为障。忍之成住也。无我下。出忍之所以也。斯有两意所谓通别。通则由无我相。虽累遭割截常能忍受。别则由无我故能忍。由累苦故能忍也。十四者。经从须菩提当来之世若有善男子善女人能于此经受持读诵。乃至果报亦不可思议离智下所离障。若耽寂无智。即是障非住。若离寂修智。即是住非障。日三时下指经对治。意云。欲证圣性非智不阶。经苦校量意在策发。此同华严经中诃劝之相。彼云法性真常离心念。二乘于此亦能得。不以此故为世尊。但以甚深无阂智。然此是对治之别意。故须一向而言令人舍定修慧。若据究竟通论。必须定慧等学。涅槃经中说。定慧不等不见佛性。无明邪见自此而生。前第十一住便是定门。对治不同故须然也。修习之者须兼行之。十五者。经从尔时须菩提白佛言世尊。乃至实无有法发阿耨多罗三藐三菩提者。离十一下所离障。谓动不自摄。则是障非住。若自摄不动。则是住非障也。论中则云自取障。我能下释。意云由计我故。遂起降住胜能之心。不觉喜动故不自摄。今经既云无一众生得灭度。无法得菩提。则不计胜能故。能对治也。十六。经从须菩提于意云何如来于然灯佛所有法得阿耨多罗三藐三菩提不。乃至是故名一切法。离十二下若无教授即是障非住。若得教授即是住非障。欲入下释成住义。虽三贤位中乱修六度经一无数劫。欲入圣道要佛策发故。于资粮位后立加行名。其犹钻火火欲出时倍加功力。遇佛然灯佛也。得无所得者。即然灯与善慧授记。当得作佛号释迦牟尼。非佛与法故云无得。问此说善慧得记进入八地。何故将此配地前耶。答欲入初地须学八地。用心方可得入。若学初地竟不能入。如人学射可知。又将证八地犹须教授。欲入见道岂得不然。然从第五至此住中。每住对治一障。此障障于见道。今则加行位极对治已尽故。云而证道矣。十七者。经从须菩提譬如人身长大。乃至佛说一切法无。我无人无众生无寿者。摄种性下释成住义。智体即观照。般若是能证也。即妙平二智无分别也。以得此智生如来家。决定绍佛种。故斯则地前加行之智。至于初地转受此名。证遍等者。体即实相般若是所证也。以遍在一切法中故。唯识云。由此真如二空所显。无有一法而不在故。论中则名平等智。然有五种平等因缘。一粗恶平等。二法无我平等。三断相应平等。四无希望心平等。五一切菩萨证道平等。有是五种因缘故名平等智。故论云。入证道时得二种智。一摄种性智。二平等智也。然所证是理。今云智者斯有两意。一准起信论云。依此法身说名本觉。二则理智冥合能所不殊。如珠与光不相舍离。成法报身者。摄种性智至果得成报身。平等智至果得成法身。故长大者。论即云妙大。妙即报身。以万行功德所庄严故。大即法身。真如实理遍一切故。十八者。自此已下皆求佛地。于中复有六种具足。具足者圆满义。谓转舍二障。转得菩提涅槃。摄转具足也。既证圣性生如来家。须示佛果功德令其欣趣。然其果德虽多。以要言之。不出依正二报。二报之内先明所依。若无所依能依何立。正报之内不踰福智。智引福故先智后福。然后别显三业依次所明。一经从须菩提若菩萨作是言我当庄严佛土是不名菩萨。乃至若菩萨通达无我法者如来说名真是菩萨。此教下指位。即从二地至于等觉。当修道位。谓庄严之时离能所相。名之为净。称周法界故云具足。故经云通达无我法者。如来说名真是菩萨。二者经从须菩提于意云何如来有肉眼不。乃至未来心不可得。见净者即五眼也。见即无见名之为净。无所不见名为具足。智净者即悉知诸心等。知即无知名之为净。无所不知名为具足。以智见不别故当一处。此下等即指位拣非修道。即无学位也。下之四段皆合有无上之言。故云贯通。下四三者。经从须菩提于意云何若人满三千大千世界七宝以用布施。乃至以福德无故如来说得福德多。问前已频说施福。与此何别。答前所说者。皆是校量不及受持之福。今此说者。乃是无住称性之福。非能校量故不同也。问佛是果布施是因云何果中即说因行。答凡是果德皆彼因。成举彼无住之。因以彰称性之福也。言自在者。拣有漏之福不自在也。若准论中。此与智净合为一段。意明福智不相离故。则于身中开之为二。谓色身具足亦盈六数。今则合后开前者。意云福之与智迢然不同配摄因果。五六有异异须开也。相之与好同是一身兼对下语。意以成三业故须合也。四者经从须菩提于意云何佛可以具足色身见不。乃至是名诸相具足。此明如来真应具足。如经云。即非具足色身明真身也。是名具足色身。明应身也。即非诸相具足。明真身也。是名诸相具足。明应身也。五者经从须菩提汝勿谓如来作是念我当有所说法。乃至是名说法。说而无说无说之说。是真说法具足者。无法可说无所不说。是名说法。六者然于心中复有六种。一念处。二正觉。三施设大利益。曰摄取法身。五不住生死涅槃。六行住净。化度众生大悲为本。故先明念处。自未成佛焉能度他。故次明正觉。自利既满即合利他。故次明施设大利益。犹恐滞相大。次明摄取法身。又恐住空有。故次明不住生死涅槃。又恐执施化迹。故次明行住净也。以此六义别对经文。广如彼论避烦不叙。又十下二重。以八义相摄。一者摄是笼罗包纳之义。即以普度众生现无违反。是故配同第一发心住也。二者净与相应。盖一义耳。是故配同第二住也。三者虽三色四法皆是欲得。由此配同三四二住也。四者可知。五者正当净心地故同此住。六者正当究竟位故同此住。虽通修道就多故说。一一下明各摄义。如第一住中。普度四生广也。令入无余涅槃深也。实无众生得灭度者广也。菩萨无我人等相者深也。初住既尔余则例知。若五百生忍广也。并无我人深也。若细言之。前以六住摄十八住。后以二住摄十八住。皆得满足。疏十八住下。三更约地位配释。然诸教中所说地位。或有或无。如楞伽经云。十地即为初。二地即为八。乃至无所有何地。此明无也。仁王缨络等经。即具说地位。是明有也。然此有无皆随机说也若华严行布万差圆融一际。有无无阂。斯则称性之说也然依华严有无无阂方为了义。以约法即无约人即有。人法既不相离有无。故合均齐。然其行人念念须冥佛境反穷果海。自然阶降不同。若预等级用心毕竟障于证入。故华严疏云。修则顿修位分因果。况此经宗无相。岂合列位浅深。但约情惑渐薄而位地转高义相稍同。故略配摄也。等一十住者。十住谓第一发心住。二持地三修行。四生贵。五方便具足。六正心。七不退。八童真。九法王子。十灌顶。今配十住者。与彼初住名同故配之也。问比但云一。如何配十。答以初摄后故。问何故不言十信位耶。答亦摄入十住位中也。以前之十住。通名信行地。故亦同华严合前开后也。故发心一住。前摄十信后摄余九耳。第二十行等者。十行即一欢喜行。二饶益。三无嗔恨。四无尽五离痴乱。六善现。七无著。八尊重。九善法。十真实。前六者十中前六行也。以配此中第二住处。以此住处说六度故。即布施配欢喜行。持戒配饶益行。忍辱配无嗔恨行。精进配无尽行。禅定配离痴乱行。智慧配善现行。心离分别善巧示现故。三第七行者。不以相见如来。即无著也。四后三行者。配第四住中三种法身。谓言说法身配尊重行于佛言教生尊重故。智相法身配善法行。以真如无为是真善法故。福相法身配真实行。以持经之福无漏真实故。五至十四配十回向者。一救护一切众生离众生相回向。二不坏。三等一切佛。四至一切处五无尽功德藏。六随顺坚固善根。七等心随顺一切众生。八真如相九无缚无著解脱。十法界无量。五配第一。离慢即是离众生相也。六配第二。遇佛多闻信。解行等不坏。七配第三。诸佛离相既不住色。即等佛也八配第四。既见大身非身。是真如际方至一切处。九配第五。不随外论受持此经。即得无尽功德。十配第六。观破五蕴与定相应善根坚固。十一配第七。既不取相即于众生等随顺之。十二配第八。经云离一切相即名诸佛。即真如相也。十三配第九。割截不嗔即无缚无著也。十四配第十。经云无有边不可思议功德。即是法界功德也。十五燸等者配四加行位也。然此四位由三贤菩萨已经一无数劫修集福智资粮。为入见道故复加行。燸顶二位。以四寻伺观。观所取名等四法假有实无。即所取空。忍世第一。以四如实智。通观能所名等皆空。然忍有三品。谓下中上。下品印所取空中品顺能取空。上品印能取空。世第一二空俱印。然皆滞相未能证实。故唯识云。现前立少物。谓是唯识性。以有所得故。非实住唯识。若配经文即十五住。经云实无有法发阿耨菩提心者。以菩提能发所取。既言实无即所取空。当燸顶二位。十六住中。经云佛于然灯佛所不得菩提。是印所取空。当下品忍。次云如来者即诸法如义即顺能取空。然犹未说后时不得。即知未能印持故。当中品忍。次云实无有法佛得阿耨菩提。此明后时毕竟不得。即印能取空当上品忍。次云如来所得法。此法无实无虚。乃至即非一切法即双印二空。当世第一位也。十七初地者如前疏云摄种性智证遍行真如等故当初地。十八等者。于中合有二。谓此住中初国土净具足。当修道位。故前疏云。此教二地已上诸大菩萨。从无上见智净具足已下。皆究竟位。故前疏云此下皆住佛果也。是则十八住中。前十四资粮。十五十六加行。十七见道。十八中初一具足修道余即无学道也。悬判竟。第二下二。初牃章分文。二依章正释四。初善现申请二。一整仪赞佛疏二。初释请人。从初至恭敬即是整仪。余皆赞佛也。经时者。即如来食已。敷座而坐时也。德长年老者。谓德高曰长年多曰老也。唐译下证年老。魏译下证德长。智慧超伦即是德长义也。然以慧为命者。约喻显法也。谓人身以命为本。佛法以慧为本。命尽则六根俱废。慧丧则万行不成云云。此约别义释长老也。若通意者。但有德业便名长老。如云先生未必年老矣。须菩提者亦云苏补底。但梵音楚夏耳。善吉下。从末倒标。生时下据本顺释。西域记云。是东方青龙陀佛。影响释迦之会。示迹声闻发扬空理。十方诸佛法皆尔也。从座下。二释请仪二。初正释经文。皆整仪者。疏虽通明经须别释。从座起者。师资之道尊卑颇殊。欲有咨询不可坐问。此同曾子避席对夫子也。孝经中夫子问曾子曰。先王有至德要道以顺天下。民用和穆上下无怨。汝知之乎。曾子避席曰。参不敏何足以知之。虽彼答此问。而致敬是同也。偏袒右肩。是彼方仪则此土非仪也。欲问如来故须偏袒。右膝下。右则为顺膝能回屈。表顺理心也。着地即示卑之相也。膝表智地表理。合掌即表冥心。掌合不执外物。心冥觉不异缘。欲问实相法门故。须用心如此。恭敬者总结也。起座袒肩跪膝合掌。莫非恭敬故尔。亦可配于三业。谓座起袒肩合掌等身业也。恭敬即意业也。白佛言下即口业也。希有下。疏且总明具有四种。一时希有旷劫难逢。然今贤劫之中。正当住劫。就住劫中有二十增减。今即第九减劫中。人寿二万岁时。迦叶如来出世百年减一年。至人寿百岁时。释迦如来出世。减后此劫已尽至第十劫展转却增。至八万四千岁。又百年减一年。至人寿八万岁时。弥勒佛出世。望过去未来。二佛相去一千一百万余年。中间更无。故云希有也。故法华云。诸佛兴出世。悬远值遇难。二处希有。三千界中唯有一佛。百亿四天下百亿须弥山百亿日月百亿六欲百亿梵世。其中唯有一佛。此方而现也。三德希有。福慧超绝胜无上故。故法华云。我所得智慧。微妙最第一。又云。如其所得法。定慧力庄严。以此度众生。自证无上道。然佛功德不可称说尽其边际。故华严云。刹尘心念可数知。大海中水可饮尽。虚空可量风可系。无能说尽佛功德。四事希有。用大慈悲极巧方便。现多种身相。演无量法门。随众生根皆利益故。今所叹者。意则虽通义当叹事。以下标。云善护念等。如来者真化不同。真佛名如来者迷。时背觉合尘名如去悟。了背尘合觉名如来。如即真如来去即随缘也。化佛名如来者。从真如起来。成正觉而化众生。今当后者故云从如而来。根熟者。三贤已上菩萨。信根成熟永无退转也。智慧力。即无分别智成就。佛法即随其分位令证真如。乃于一法令达百千万法明门等。斯则自利行也。教化力即后得智。摄受众生即随其分位。令于百千万亿等世界中教化众生。斯则利他行也。根未熟者十信菩萨也。以此位人六度乱修心如轻毛故。云惧其退失。以信根未成遇缘恐退故。须付嘱智者令其教化使不退也将小下。将小菩萨付大菩萨。嘱大菩萨化小菩萨也。此如父母遗嘱子孙云云菩提下。二别解菩萨。菩萨梵音言犹不足。具云菩提萨埵。此云觉有情。以时人不贵唐言故存梵语。秦地好略。又削提埵二字但云菩萨。约境所求是觉。所度是有情。然约人有四句。谓二乘有求无度。诸佛有度无求。菩萨亦求亦度。凡夫无求无度。约心者亦四句。诸佛有觉无情。凡夫有情无觉。菩萨有情有觉。二乘入无余依界。无情无觉。约能所者。所求是觉。能求是有情。三皆下。皆上句是觉。下句是有情。然此三义之中初约悲智。次约真妄。三约人法。菩萨之义不踰此三。未必宝冠天衣方是菩萨。二中疏曲分下二。初释当机。以发心者方是当机。华严下引证。此有两意。初云有人先曾发心后时忘失。尚非其器况全不发心者。何以故。魔所摄持故。后意即云。众生发心后时忘失者。盖为不解住修降伏耳。故今所问免使遗忘。前拣其机后防其退。有兹两意故用彼经。所以善财童子。每遇善友皆启云。我已先发阿耨多罗三藐三菩提心。而未知云何学菩萨行修菩萨道。意明发心方是修行之器。阿耨下先翻名。谓正智下释义上正字且对遍字以分二智下正字即明二智所觉不偏不邪。即以正智觉真遍智觉俗。皆不偏邪故云正觉。以二乘偏觉凡夫邪觉。今拣此二故不偏邪。谓如理而知。如事而知故也。然此二智亦名如理如量根本后得真俗权实等。又准智度论说。从因至果有五种菩提。一发心菩提。即十信是。二伏心菩提即三贤是。三明心菩提。即初地至七地是。四出到菩提。八九十地是。五无上菩提。即如来地是。今约能发心即当第一。约所发即第五。能所合论贯通初后也。疏二释正问三。初释魏本。先引文意云下释意。住何境界者。未发心时住六尘境。既发心已诚宜改辙。故云住何境界。修何下。未发心时十恶为务。既发心已不可依前。故云修何行业。妄心下。未发心时妄心起即逐妄。既发心已不可随之。是故问云云何降伏。故佛下悬示答意。意云昔住六尘之境。今住四心。昔行十恶今行六度。昔时着相今令不着。如是用心真实修行。发菩提心岂忘失耶。秦译下会当经。初难起意云下释初二句标。意云虽无修行之文。含有修行之义。如起信中说。六八二识不言第七虽即不说义亦具足云云。谓四下指经释成。意云四心中。亦有住修降义。六度中亦有住修降义。何以故。住谓发心必须修进。降谓制伏依住修所明。由是于此不相舍离。秦什所略意在于兹。文虽不明义已具矣。故无著下。三引论证。住谓欲愿者。欲愿意起即是发心也。修行等者。平等持心名为等持。等持即相应。相应即是修行义也。降伏等者。彼心即上相应心也。制令还住即却使相应也。此即依住修说降伏义。经论相契圣旨颇同。故如上说理实然矣。又十八等者。此是无著论。明竖答三问之意也若准天亲解经。则明横答三问。从须菩提但应如所教住已下。即为别断疑情。今明无著故有此说。意云不唯四心。六度之中有住修降伏之义。其如十八住内。皆有此三。如初住中。度四生入涅槃是住义。无生可度是修义。无我等相是降伏义。初住既尔余则皆然。故知下结义三。行一者。三义具足方成一行。谓空发心降伏。不修行亦非行。但发心修行。不降伏亦非行。空降伏修行不发心亦非行。如鼎三足如天三光。阙一不可。译经之妙厥在兹焉。印赞所赞者。印赞须菩提之所赞也。即经云善哉善哉是赞也。如汝所说是印也。如来善护念等。是所赞也。重言等者。善吉所赞雅契佛心。若不重言安表善极。如颜回死夫子叹之云天丧予天丧予。注云。再言者痛伤之甚也。吉凶虽别殷勤颇同。护付等者。空生发言言当其事。是故调御印赞云云。敕听许说者。经云汝今谛听敕听九。当为汝说许说也。谛谓审实之义。意令审谛真实用心听也。无以生灭等者。此乃反用净名经文。彼云无以生灭心行说实相法。此意云。既不得以生灭心说。岂得以生灭心听。既是不生不灭实相之法。云何以生灭心行。说之听之。无以妙馔置于秽器。智论下释相。端视谓不左顾右眄也。目若别顾心则异缘。本欲制心且令端视。此是用心之方便也。渴饮者喻也。如渴饮水但恐水竭无暇别观。听法之者亦复如是。思冀妙门无心睥睨。一心入语义者。意中现义方发于言。言中有义义中有意。令听者以耳识听其言以意识采其义寻义而取意得意而舍义。苟能得意在怀。何虑失于言义。心心若此如瓶注瓶。一览无遗可为至妙。故云一心入于语义中也。踊跃即欢贺之貌。即欲闻法之时也。悲喜即闻了之时。悲谓伤昔日不遇。如下经云涕泪悲泣。喜谓庆今日之得闻。如鹙子踊跃欢喜。伤昔庆今故云悲喜。如是下结拣其机也。意云若不如是用心。则不可为说。又真谛记说。谛听离三过失得三功德。谓离散乱轻慢颠倒。如次生闻思修三慧也。标劝将陈者。标谓标指。劝谓劝勉。将犹欲也。陈说也。即经云善男子等标也。应如是等者劝也。标劝之意。意在欲说故云将陈。即悬指向下正答之文。是故疏云我当为汝等也。三中唯者下如今人称。喏皆顺从之辞也。老子云。唯之与阿相去几何。注文如疏。今则礼对也。十地等者。释愿闻之相。即华严十地品中。诸菩萨众请金刚藏。说十地法门之偈。今借用之。然前四句。于中约喻配其三慧。初句闻慧。闻法不思如饮水不味。次句思慧。若要寻求食味。应须啖嚼。第三修慧。修行惑遣如服药病除。后句即三慧之果。蜂采百华以成蜜。人集万行以证真。蜂成蜜已依蜜而活。人证真已依真而住。我等下合喻。最后一句通喻所闻

金刚经纂要刊定记卷第三金刚经纂要刊定记卷第四

        长水沙门子璇录

四如来正说二。初正答所问二。初举总标列以牒问。经诸菩萨摩诃萨者。问前举当机。云善男子善女人。洎今答处。何言菩萨摩诃萨耶。答大心未发即是凡夫。既已发心即名菩萨。善现标举约未发心时。故云善男子善女人。世尊酬答约己发心后。乃言诸菩萨摩诃萨。疏此以下四。初正释经文。以空生闻有三种。佛今牒举但言降伏故此释也。前二句标。谓住下释。谓度生无我。是住中降伏也。施不住相。是修中降伏也。由斯义故降伏为总也。经意在此者。在举降伏而标住修欲显文简义丰彰乎玄妙。始虽住修究竟降伏。得意兹深故。但云一也。有科下。二斥他谬判。即大云疏也。青龙即云。举终括始其义亦同。乃令下正斥失。文不稳畅者。本宜初包后义。如色例于声等。何忽举后摄初。致使文非稳畅。不稳畅则盖由于科非经文本意也。况详下。三详定经旨。降伏在住修中者。住中降伏即实无度者。修中降伏即无住布施。无度无住便是离相。离相既通住修。故知降伏是总。不别下。四牒难释通。初句牒难。难云空生既问有次第。住修降伏宛分。何故经中不与别答。而寄住修中明耶。此经下正通。离相是降心者。如前所引无度无住等。须约住修显者若有发心修行。斯可说得降心若无住修说何降制。斯则只于住修。以降分别妄念故云本不相离。无著下引证可知。疏答问中科安住等者。此即安住四心。弥勒偈云。广大第一常。其心不颠倒。利益深心住。此乘功德满。依此科判故列四心也。疏初句下二。初释标。三界普度者释广大义。一切众生不越三界。三界普度方名广大。若一众生不与度者。非广大也。故经标云。所有一切众生。即统该也。梵语仆呼缮那。此云众生。智度论云。五蕴和合中生故云众生。瑜珈论云。思业为因卵胎湿化为缘。五蕴初起名之为生。类即流类。即胎卵等四也。若卵下二释列三。初中二。初释文。禀命之始名曰受生。即初起之时也。卵等四异故云差别。谓卵[穀-禾+卵]中生。胎藏中生。依湿而生。化忽然生。故不同也。然三界众生不出五道。以四摄五亦得具足。故疏次云天狱等化生。斯则从狭之宽明也。天狱化生者。天上地狱唯是化生。最狭也。鬼通胎化者。次宽也。谓地行罗刹及鬼子母皆是胎生。故有鬼母白目连曰。我昼夜分各生五百子。随生自食虽尽不饱。故知有胎生鬼也。余皆化生也。人畜各四者。人四者。毗舍佉母。卵生三十二子。胎生常人。湿即奈女从庵罗树湿气而生。化生即劫初之人。故俱舍云。二禅福将尽。下生赡部州。畜具四者。正法念经云。化生金翅鸟。能食四生龙。乃至湿生也。然禽兽虽殊皆畜生道摄。余兽皆胎余鸟皆卵也。诸余微细等者。如华严云。尽法界虚空界十方刹海。所有众生种种差别。所谓卵生胎生湿生化生。或有依于地水火风而生住者。或有依空及诸卉木而生住者。种种生类种种色身。乃至云一切天龙八部人非人等。无足四足多足。有色无色有想无想非有想非无想等。以今经中无别说处。不可构虚而言。故疏结云不可具分品类也。卵劣下二通难。应难云。卵生最劣云何在初。化生最胜云何居末。二释下通。约境等者。谓卵生必具胎湿化。以未生处胎。胎中必湿。无而忽有为化。胎生必兼湿化湿必兼化。化不必兼余。但从于无而忽有故。此则前前必具后后。后后不具前前。故为此次也。约心从本等者。谓众生本因起业。业识即根本。无明与本性和合。能所未分混沌如卵。卵即卵[穀-禾+卵]故。药师经云。破无明[穀-禾+卵]竭烦恼河。无明发业蕴在藏识。为胎受生为湿。生时从无而忽有为化。由是义故故为此次也。依止差别者。依止即是众生。身身具依止依止义异。故云差别。故疏次云有色无色等。有色即以色为身。无色即以四蕴为身。又色界有四禅云云。无色有四空云云。如是品类不同故。云依止差别。问如有经云。佛涅槃时无色界天泪下如雨。既有泪下云何无色。答所言无色者。无业果色不无定果色故不违也。境界差别者。虽言境界意明空等四处。空识二处者。无色界第一第二天也。无所有处者。第三天也。非有想非无想者。第四天也。无粗想有细想故。是三有之顶故云有顶。问下二界皆有色。何故唯言四禅以为色界。又色界亦有一天名为无想。云何唯指无所有处为无想耶。答三界统论不出五事。谓欲色想无想非有想非无想。然非有无想。即局于有顶一天。色界一天虽名无想。已从多分通名色界。故但指无所有为为无想。其余三事从空识二处已下。乃至欲界相望。有无宽狭不同。谓欲界具三。色界无欲无色界唯想无色。无欲故立有想之名。色界虽有想。恐滥上名故。立有色之目。欲界虽兼色想。上已沾于二名。拣异彼故但名欲界。下下必具于上上。上上不兼于下下。故立名之本其在兹焉。如有三人。一人解经律论。一人解经律。一人唯解律。拣别立号云云可知。又欲界三欲五妙欲境胜故。色界细妙色胜故。无色想心胜故。由是欲唯欲界。色通二界想遍三界。无想通上二界。非有想非无想局上一界。斯则不同功德施所释也。二中经我者。即发菩提心菩萨所称。今佛说彼也。涅槃者秦译灭度。今经上梵下唐故。云而灭度之。若具足梵音。应云摩诃波利昵嚩喃。此云大圆寂。今经论中多言涅槃也。然准唯识论说。有四种涅槃。一自性清净涅槃。凡圣同有。二有余依。即出烦恼障有苦依身故。三无余依。身出生死苦无依故。然小乘以灰身灭智为无余。无余有三。一烦恼余二业余三界报余。大乘则以究竟宝所为无余。故智论说。四住地烦恼尽名有余依。五住地烦恼尽名无余依。四无住处。悲智相兼不住生死涅槃故。疏即无下。即大乘之无余四种之中。无住处涅槃也。谓不住菩萨变易生死。不住二乘灰断涅槃。即真无住处名为无余。若小乘无余。如有情灭减不别。今不同彼故。云不共二乘。不共者。即非彼四之第三。则言同而意异也。如法华经云。若得作佛时。具三十二相。尔时乃可谓永尽灭无余。此则二障都尽。二死永离也。第一者结归偈旨。仍释科名。意谓若非无住处之无余。焉得弥勒指为第一心耶。无著下初二句难。意云一切众生五性差别。云何皆入无余涅槃。三分半众生不得成佛。故云不可得义。生所摄者答也。此是无著立量。成立皆可度也。应立量云。三分半众生是有法定皆成佛故为宗。因云生所摄故。同喻一分半众生。意云涅槃经说。凡是有心定当作佛。圆觉经云。有性无性齐成佛道。此则是可得义。安云不得。又云卵湿等者。举难处难也。卵湿则畜生难。无想有顶即长寿天难。虽举二处意兼八难。八难谓三涂北州长寿天佛前佛后世智辩聪无根等难。意云难处即不可度。云何皆入。有三因缘等者答也。难处待时者。此亦令成其种也。意云难处众生不可常定。至非难处而度脱之。若得成种迟速之间必须成熟。发广大心故合无遗。非难处者。虽即未度且令成熟。已熟可知。此稍同前护付之义也。三中疏一性空者。众生缘生。缘生无性故即空也。同体者。同一真如性故。故起信论云。谓如实知一切众生及与己身真如平等无别异。故论云下引证。此语犹反。应云众生灭度无异自身。宁于自身起于他想。本寂者。相本自尽不待灭故。净名云。一切众生即寂灭相不复更灭。问此与性空何别。答前但即空。此则本来成佛。成佛即入涅槃故云本寂。前浅后深可知。无念者。有念即有众生。如无翳则空华不现。法界者。一真法界平等无差。云何于中见自他相。故偈云。平等真法界。佛不度众生。此上五义大云之文。然于中。一三约所。二约能所。四唯约能。五该本末也。大抵意云。若见众生有可度者。即生疲劳不能常度。反此即常也。又度与不度其心不二。名之为常也。故金刚三昧经云。若化众生不生于化不生无化。其化大焉。四中经何以故者征。意云。设所见有众生可度。此何过耶。次通云。若菩萨有我等相即非菩萨。此是反明。意云。是真菩萨必无我为能度。岂更见有众生得灭度耶。远离依止身见众生等。依止即身见异名。亦名相续。梵云萨迦耶此云身见。等于我人寿者也。此名身见者。以依于身起此见故。故云依止身见众生等相。又身见为本。诸余见等依此而生故。今皆远离故云等相也。已断等者。内无我即无自相。无自相即平等。平等即空义也。信解等者。以己方人也。由内无自相故。得外无他相。中有故自是所以也。既无自他之相。即自他平等。志公云。以我身空诸法空。千品万类悉皆同。显示降伏等者准无著论。广大第一当住常心。当修不倒。当降安住。一段之中便具三义。今此段文正当降义。故云显示降伏等也。不转者。转即生起义。意云我见等不生起也。我不生起正是降心义也。尔炎者梵语。此云智母。即根本智能生后得故名智母。以根本智虽内证真理而无能证之心。今后得智虽外度生而无能度之念故云如尔炎也。如是用意名不颠倒心。反之即颠倒耳。二答修行五。一总标。疏于法统标者。谓色声等六通名法故。故魏经云。不住于事。菩萨万行者。谓自利利他事行理行。如是等行无量无边。今言万者且举大数。总名布施者。谓第一即资生施。第二第三即无畏施。四五六度皆名法施。偈云下引偈释。于中初二句标。第三句配。第四句结也。一二三者。谓一摄一二摄二三摄三也。是则三施为能摄。六度为所摄。无著下摄所以也。前二义显法施义隐。故疏明矣。然要略明资生者。资即外财也。无畏者由持戒忍辱。故无心害物。设有冤家亦不仇报也。若无精进等者。起信云。于诸善事心不懈退。立志坚强远离怯弱等。若无禅定等者。下文云。云何为人演说不取于相如如不动。不动即无染义也。拟心即差尚名为染。况贪信敬名利等。岂得非愆。若无智慧等者。说火湿水热地动风坚。名为颠倒。若说事如事说理如理。则非颠倒。由是开一施为三施。开三施为六度。开六度为万行。万行不出六度。六度不出三施。三施不出一种坛那。是故此中唯言布施。二别释疏指。三事者六境虽差统唯三事。谓自下列偈云下释。初二句标。斯不著者斯此也。不令着此三事也。次二句释。存己不施者释上自身也。为着自身不行施故。求异事者。释上报恩果报也。此非菩萨所行正行故云异事。报恩酬过去之恩。果报望未来之报。自身不施义当现在。护亦防也。意令于此三世事中防护。悉皆不着。即是不住色等布施也。三中疏前但下。意云。前之三事收过未尽。不妨有不着自身不着果报。不为报恩而行施者。亦非无住。今则下。显今经意。心即能缘境即所缘。有即双该心境。及心境所余收不尽者。皆有字摄。空者即离心境等相也。问住境理有所乖离心。此复何失。答空有二法相待立名。有之与空二俱是相。随堕一相非是常心。是故此令一切皆遣。微细尽袪者。不论心境空有。起心动念则乖法体。是故一切尽令袪遣。直须施时其心平等不起分别。方成无住也。问若然者。生心动念则非无住。且众生心行任运非常。若待相应毕竟无分。若一向不施又不成佛因。若行布施即堕住相。进退不可其事云何。答欲求菩提必须行施。初行施时难顿相应。要须用心方便随顺。任运起念作意远之。用心多时自然任运得与理合。从微至着渐次相应尔。如起信说真如离言说名字。心缘不及。遂致问云。若如是义者。诸众生等云何随顺。而能得入。故答云。若知一切法虽念亦无能念可念。是名随顺。若离于念名为得入云云。偈云下。引证上义故知心境空有等莫非相也。论云下约离二执。三轮释上离相。施物是法。施者受者是人。今皆不见则离二执名为二空。二空皆离即三轮体空。轮者喻也。如车轮内虚方能运转故。老子云。当其无有车之用。三事体空能招佛果。三体体实即堕世间。斯则以无相轮摧三有相。超出世间也。无著下。但证成上义。相即境也。想即心也有人下。指斥谬判如文。四显益经此亦别断一疑。应云无住则无福德疑也。大云二十七疑。从此便为第一云无住有福疑。今则不取。为大段疑数。何者。缘是答问之中曲分疑也。故论云得降伏心故。是以次说布施利益不住相者。施成就义。次后方始。文势云。自此已下一切修多罗示现断生疑心也。疏二一科释文意。若离等者释征意也。以魏云不住相想。遂疑云。若存施想即有施因。以有施因方有施果。既无施想则无施因。因尚不成果何得立。如放债须记。若忘谁还。此疑同无记心中行施也。法中亦尔。不可思量者。以是无相施福故不可思量。喻中东方是众方之首。是故先明。南西北方如次例说。法喻皆同不可思量。意云。非谓无空此空相对义在合中。虚空下二别辨喻旨。遍一切处者。谓色非色中皆有空故。谓住下法合也。住不住中皆有福故。谓近感十王住中福。远招菩提不住福。又近得色身住中福。远得法身不住福。空虽无相非谓无空。福虽不住非谓无福。二者宽广即横遍十方。高即竖穷三际。大即通该横竖。如上之义法喻皆大。殊胜者。喻则三灾不坏法则四相不迁。三者无尽究竟不穷盖一义耳。然世界有尽虚空无穷。有漏有穷无漏无尽。三种常义厥在兹焉。大抵意云。无住之福遍满一切。无住之福高大殊胜。无住之福究竟不穷。犹如虚空思量不及。以称法界故。得如斯义利昭然。复何所惑。五中经但应如所教住者。问前令不住此又令住。住与不住何是何非。答前令不住用心。此令住于不住。不住而住即住真空。如鸟不住空却能住空。若住于空即不住空也。故魏经云。但应如是行于布施。准此答三问已。便合经终入流通分。缘空生于如来答处。生起疑情。所以为断。断已又起展转滋多。执尽疑除终二十七段。由是更有次下经文也。疏二蹑迹下文二。初约论分文。蹑迹断疑者。谓蹑前语迹断彼疑情。经中虽不显有疑辞。而伏在文内。故但言断而不言起。弥勒颂中亦同于此。故偈云。调伏彼事中远离取相心。及断种种疑亦防生成心。示现者二意。一则空生假设云为。二则指示显现故。第一疏初标章。为求下指疑起处也。此从不住相布施中来。为闻前不住三世空有等相方名真施。遂疑云。凡所行施盖为求佛。既有所求云何无住。又不住等者。此纵难也。设使因成无住此亦非理故。次云因果不类故。夫为因果必须相类。有即俱有空即俱空。染净皆尔。既若色相是果。云何以无住为因。则因空果有理恐不然。今将果验因因合有住。佛说无住是诳我耶。举疑因经。意云。于汝意中。还可用三十二相之身见法身如来。为不可耶。此相是疑起之因。故举以问。本只下释起疑因。以二乘人唯取丈六相为真佛。既将此相为果故。不信无住之因。因果不相类故。佛今举果以问。令知果海无相。自然于因不惑无住也。防相酬经意。空生见佛举相以问。即知不得相求。故答不也。遮防等者。意恐末代众生不达此理。取相为真故此远遮迷见。准义则正断空生现行。遮防未来种子也。遮断之义具在悬谈。论云下引证。问经中云见。论释云成就。岂合佛意耶。答既作此见必作此证故无违也。异有为经征意云。以何义故。不以三十二相见法身如来。释意云。以如来所说三十二相之身相。即非法身之相故。即犹是也非犹不也。本文犹倒正言不是也。相是等者。谓三十二相盖是镜智之上所现影像。既堕有为之数。故当四相所迁。况对机宜有无不定。焉可将此而为法身。故言相是有为等。此释经中如来所说身相也。佛体异此等者。法身佛体异此有为。故说三十二相不是法身相也。此释即非身相。偈云下引证。具云。分别有为体防彼成就得。三相异体故。离彼是如来。于中初二句义当前段。后一句当次科。第三一句合当此文。故偏言证。佛体下转释偈文。即经云即非身相。住异下释三相义。以前标四相。此偈唯三者。以生在过去灭属未来。住异二种同处现在。又此二相不相舍离。即住而异即异而住。以同时处故合为一。恐滥常住但标异也。若细下约义细分即为四也。此引唯识释相。谓从无而有名生。自有而无为灭。前后改变为异。暂尔相续为住。然法身如来非前际生非后际灭。无有变异不可破坏。故异此也。印无相经意云。夫一切相皆从妄念而生。是故佛相亦是虚妄。若分别不起相自无生。即见非相。诸相既亡唯是觉体名见如来。由是则知佛身无相。疏二。一释前二句二。初正释。非但者不独也。凡即六道众生。圣即三乘贤圣。依有净秽正即凡圣。为对依报故重牒之。诸法虽多不出此四。虽举四法该一切也。此释经中。凡所有相皆是虚妄。恐人闻说身相非相。将谓唯独佛身。今言凡所以遮局见。以从下释所以。凡圣染净胜劣虽殊。皆从念生无不虚妄。念无自相不离觉性。念尚无性况所现相而实有耶。以念是所依相是能依。所依尚虚能依何有。其犹皮既不存毛将安附。起信下二引证。于中顺显反显详而悉之。若见下二释。后二句二。初正释。遮离等者。以色即是空空即是色。离色求空斯为大失。故此遮矣。不唯等者。又恐闻相即非相是如来。将谓只约佛身相说。除佛身外相非如来。故云一切相皆无也。此释经中诸字也。譬如镜中现一人像兼现余物。不唯人像空处是镜。余物空处亦皆是镜。合法可知。如是了者。则知见与见缘似现前境。元我觉明。故起下二引论释四。初引起信。此有二意。一证诸相皆无相义。以相依念生。觉体尚离于念。何况于相耶。二证诸相无处皆如来义离念之相名为法身。法身既等虚空。虚空何曾有相。无相平等摄一切相。即是法身。下文云。离一切相即名诸佛。又云。如来者即诸法如义。故云不唯等也。肇云下。二引肇注。此即名见法身佛之行相。恐人闻诸相非相即见如来。便希无相之佛昭然目前。若如是者。何殊彼相。故云行合等。智与理冥心与神会。故云行合。解通者。如前解了一切相非相也。前是真见。此是似见。故起信云。法身无有彼此色相迭相见故。偈云下三引本论。即前残偈。此依天亲论释。无著下四引无著。离遍计者不执虚相为实故。唯识云。圆成实于彼常远离前性。真色身者有两意。一则以虚妄为虚妄。但如其事。不必取不生不灭以为真也。如以水月为水月。虽似而非真矣。故华严云。于实见真实不实见不实。如是解法相是则名为佛。二谓相即无相同法身故。摄末归本名真色身。即真善妙色也故涅槃云。吾今此身即是常身法身。金刚不坏之身问前则泯相。此乃存相何相违耶。答前显法身故云相即非相。今明色身故言无相即相。盖以果佛必具二身。二身相即如波与水。两论之中各显一义。言似相反意实相符。菩萨巧便妙在于此。故彼下两文皆证显色身义耳。然此一段疑中。从微至着明真应二身。总有六重。一明佛相非相。二明佛相非即如来。三明一切相皆非相。四明一切相非相皆如来。五明唯证相应无佛可见。六明无相之相是真色身。然此六重。前前则浅后后转深。文不累书理即顿现。达者所见必须一时无前后耳。第二疏初标章。论云下指疑起处。无住等者。此指正答住修降问也。无相见佛。即前若见诸相非相即见如来。未来下结成疑也。意云。因果既皆无相即因果俱深。如我亲承方能领悟。末世钝根云何信受。既不信受空说何益耶。呈疑经问意云。未来末世能有众生闻此因果俱深章句。生真实信心不。颇能也。意拣泛尔之信故言实信。魏云下引魏本会文。魏经有之。此经阙者罗什巧译妙在影略耳。亦可。此文通约现未为问。以佛世时亦有难信此深法者。如诸小乘及外道等。法华会上犹有退席声闻。况今般若。至下佛答但举末世以况现在。末世尚有佛世岂无。故今秦本不言未来等也。句诠差别者。以名但诠诸法自性。如言色即拣非心等。言心拣非色等。然其色心各有多种。而未明此何色心耶。句能分辨真心妄心形色显色等。故云句诠差别也。章解句者。以句虽诠差别而未广显义理。以真妄形显色心之中含多义故。章能明之。故云解句。章犹彰也。疏文顺义故先解句。大品下明信之相。谓见有色心三科等法。是信一切法也。今以般若照之。一切浮尘诸幻化相。当处出生随处灭尽。幻妄称相。其性真为妙觉明体。是不信一切法。方名信般若矣。其犹净眼不见空华。若执空华岂信净眼。法合可知。显信经。莫作是说者。诃劝之辞。岂谓后世一向无信。如佛灭后末法之中有戒定者。能于深义实有信心。信此为实也。大集下。明佛灭后有五五百岁。前前胜后后劣。解脱者证也即三乘圣果。禅定者行也。即漏无漏大小乘事理等定也。多闻者解也。即顿渐偏圆空有等。解此上三者。前必具后后未必具前。塔寺者。谓不求至道多好有为。以身外资财修世间福业等。斗诤者。此明佛法之中多有诤论。且如西天大小乘宗分河饮水。大乘之内性相又殊。小乘之中二十部异。各皆傥己自是非他。爰及此方未免于是。若相若性南宗北宗禅讲相非。彼此朋傥互不相许名斗诤也。皆如例者。须有五百岁及牢固之言。牢固者。人多相袭决定不舍也。然此但就增胜说之。非不相通。如佛灭后二百年内。育王造塔岂局第四耶。又菩萨藏经云。后五百岁无量善人修禅定解脱多闻。岂唯一二三耶。今经云。后五百岁即此时也。虽当斗诤之代。亦有戒德之人。是知五种牢固但约增胜而说。本疑下疏以断疑之文。照前呈疑之处。是显空生疑于恶世无信也。前引魏经以证斯义。恶世尚尔况余世耶。戒定下约三学释定。是福体故对于定。正解无倒者。既有正解必无倒惑。以解因果无相道理。名为实信。即慧学也。无著下引证。魏经云。有持戒修福得智慧者。弥勒颂云。说因果深义。于后恶世时。不空以有实。菩萨三德备。三德即是三学。今文但取于此章句。能生信心以此为实。即是慧也。若其无慧孰能以此为实而生信耶。少欲下持戒少欲。修定静乱习慧断惑故言等也。言增上者。以戒等三学是增胜上法。经中说为三决定义。戒出下辨三益相。有戒者。不堕地狱饿鬼畜生。生四洲六欲故。戒经云。欲得生天上若生人中者。常当护戒足勿令有毁损。定出六欲者。欲界无定故。得定者。生上二界故。圆觉经云。弃爱乐舍还资爱本。便现有为增上善果。慧出三界者。三界之本是其业惑。有智慧者悉能除遣。业惑既遣自然超越。故心经云。观自在菩萨行深般若波罗蜜多时。照见五蕴皆空。度一切苦厄。然浅慧尚能得出三界。岂况大乘甚深般若。信因经反显。顺明之异可知。缘胜者。虽则益我为友人。皆友焉。且凡不及圣。小不如大。因不及果。一佛虽果不及多佛。既云无量千万故云终胜也。因胜者。三毒即贪嗔痴。此明能害有情故贬云毒。以生起即是不善。久伏故名善根故华严云。我昔所造诸恶业。皆由无始贪嗔痴。唯识云。善谓信惭愧无贪等三根。有生长义故名根也。善与不善皆由此三。苟能伏之乃名因胜。因缘俱胜方起此信。是知。实信诚不易得。一念尚尔况乎永信。及持说等耶。福德门经意云。信经之人得无量福。如来于彼咸悉知见。如是无量福者指信经福。同前不住施福十方虚空不可思量也。无著下文二。初释佛知见。行住等即四威仪中各有所作差别故。注云四蕴者。即受想行识。谓相应不相应。思何事念何事取舍忧喜等念。皆名心也。注云色身者。即为四蕴所依止故。今约义标故云依止。即行住坐卧屈伸俯仰等。斯则生心起念无所不知。举动施为靡不咸见。盖佛智眼廓尔无边。依正斯在岂不齐鉴。法华云。我常知众生行道不行道。心无形相故但言知。身质既形故得云见斯人。德行既备善根夙成。佛不摄授于理如何。故云此等显示等。然则佛智无偏观生如一。有感斯应其谁谓之不然。论云下。或问。见之与知说一则可。云何经内具言之乎。故云若不说等。以凡夫亦有知见。见通肉眼知兼比量。由是故有不知不见。今佛知见非同此也。谓于见处即知非如比量知。知处即见非同肉眼见。即无事不知无事不见。经标悉言其在兹矣。故弥勒颂云。佛非见果知。愿智力现见。得福下二释得福。先引经。论云下释义。能生因者正修福业。即信解持说者也。自体果者。即熏成种子自体。后感当果也。正起者。作福之时当于现行。彼灭者。谓现行灭谢种子方成蕴在识中用感当果。此云下正会今文以得之一字。生取俱舍。谓生得取得也。秦译之妙其在此矣。二所以中疏二。一叙意科分。由无等者。谓无我法二执分别。是得摄受所以也。已断粗执经意如疏。初征下文二。初节释经文。征意可知。释中我者。谓执自五蕴总相为我。人者计我死已生天。天死为畜等故。梵语补特伽罗此云数取趣。即是人也。众生者。计我众多之法相续生故。寿者亦云寿命。计我一生寿命不断绝故。然我是总主人等为别。摄别归总故言我执。由是三中皆言计我等也。然上四相。虽是经中所无不可不了耳。能取等者。心境俱亡也。以万法虽多统唯心境。心境各有无量差别。故云一切也。真空等者。虽即诸法皆空。非谓一向非相。但以离执真空不断故。故云亦无非法相。然离下二商较经旨。此明得佛知见之兼正也。故论下引证中有征释详而示之。实相差别者。实相即无差别。但是能生实相方便有差别耳。持戒功德即指前段。信心等者。下云信心清净则生实相。弥勒颂云。彼人依信心恭敬生实相。不但等者。意谓能生实相有多方便。不必独说智慧。前云离执此言般若者。由是般若能除执故。前约所断此约能断。能所虽异而意不异。未除细执者。谓二执俱生任运起者。前离分别粗执。已能成就净信得佛知见犹浅。细执未除究竟障于圣道故。今显示令其断之。经征意云以何义故。要无法非法相。释意云。由取相故即着我人等。余文云云。可以详悉。疏二。初释总明二相。总解等者。经云若心取相。相中意舍法非法相故云总也。亦是等者。以次文别明取法非法。皆着我人等相故。此且是立其宗也。若取下二释别明二相二。一正辨二相。无明使者法执俱生也。是无明住地所摄故名为使。现行等者。即我执分别现行前已断者。示无我见者。结成上义。但取等者即前无明使是所有者。转犹起也。我想者。我执分别现行也。依止者。分别种子为彼现行所依止故。亦可法执分别名为依止。与彼我执所依止故。斯皆不起也。中有下二别解。征意可知。以后释前者。不如云以细释粗义则易见。问二乘之人亦有法执。云何不起我见耶。答以二乘人从初修行偏断我执。至无学位粗细尽除。是故虽有法执而不起我执。今约大乘学者。双断二执。分别并遣俱生两存。由是二执任运而起也。故无著云。以我相中随眠不断故。则有我取。玄门经是故者。由前取法非法皆着我等。故所以劝。令不应即入中道也。以是义故者。由是不取法非法故。疏结归中者。不应取法离有也。不应取非法离无也。既离有无即归中道。假言显义者。谓所言非法。是显法体离于性计。若无非法之言罔知彼义。余皆例此。当知义不自显必假于言。故净名云。无离文字说解脱也。不应等者。谓虽闻非法。不得如言便执空义。此遮一向执言者也。不执等者。谓若全弃非之于言。则安解诸法空义。将知但除其病不除其法。此遮一向离言者也。是则全执全弃二皆不可。故华严疏云。夫法无言象非离言象。无言象而倒惑执言象而迷真。偈云等者。余两句云。如人舍船筏。法中义亦然。论云下转释偈文。得证智等者。以言诠智得智忘言。忘言即不住也。如乘筏渡河至岸舍筏。随顺等者。未得证智不可都忘其言。未达彼岸不应舍筏。实相生者。实相名法得实相智无相无得。故云应舍。以实相无相故。唯识云。若时于所缘智都无所得。理不应者。此实相法尚不可得。况离实相外一切法耶。除诸法实相余皆魔事故。故云。非法不与理合故不相应。以是例非故云何况。第三中疏初标章。向说下指疑起处。此从第一中来。以彼文云。不可以身相得见如来。佛非有为者。此指偈云分别有为体防彼成就得。三相异体故离彼是如来。故云非有为。亦是按定立其理也。云何下结成疑。既若佛非有为。即不合有得有说。因何释迦于菩提树下得菩提。前后诸会说法。既有得有说即堕有为。云何前言不以相见作无为耶。举因问经意云。于汝心中。所谓如何谓我得菩提为不得耶。谓我说法为不说耶伊本疑此。故举问之。佛问等者空生疑得疑说。佛即顺疑以问。辞虽云得意显无得。试其所答解与不解。无著下引证。彼疑有取佛显无取。以无破有故云翻也。说法例之。顺理酬经意可知。定者实义。谓无实法名菩提。无实法名如来说。此一向约胜义答也。偈云等者。余句云说法不二取。无说离言相。意谓释迦如来是其应化。应化之相俗有真无。是故答中皆言无定准。金光明经及摄论说。佛果无别色声功德。唯有如如及如如智独存。此是真佛。今既异此岂得言真。故云应化非真等。无定法经征意云。以何义故无定法可说耶。释意云。欲言其有无状无名。欲言其无圣以之灵。谛理若此欲何说哉。说尚不得欲何取哉。取即得也是故上云。无有定法如来可说等。疏二。一引无著。正闻等者。此则闻而无闻。说而无说。非谓全不闻不说也。如净名云。夫说法者无说无示。其听法者无闻无得。是兹义矣。分别性者。一切诸法皆依妄念而有差别。念尚无念法岂是法。故云非法。法无我者。但分别性亡即是法无我理。此理不无故云非非法也。论云下二引天亲二。一释文依真等者。此且标立所依之本。然于其上说离有无。一切等者。缘生之法本无真实之体。亦无真实之相故云非也。实相有者。诸法既无即真实相。实相不无故云非非法也。此即非却非法也。何故下二通难。难意云。本来疑证疑说。问答悉以双该。今于释所以中。何故但言所说而不言证耶。有言下释也。此乃以说反验于证。且川有珠而不枯。山有玉而增润。内无德本外岂能谈。故但言说自表其证也。又此言取即是证也。无取经征意云。所以言无取无说非法非非法者何也。释意云圣人即是无为。无为即无分别。若有取说法非法等。皆属分别不名无为。何为圣人故。无取说等。言贤圣者。贤即是圣邻近释也。魏云等者。问行位通于贤圣。云何唯取圣人。答若以通论即该贤位。此明证果深浅故唯言圣。得名者即差别也。以诸圣人皆约证无为差别之义。而立其名。如证偏行真如。得名欢喜地。菩萨等此则得名差别。盖一义耳。轮意等者。谓登地已上随证一分真如。皆断一障二愚。即是一分清净。约于此义便立一名。乃至佛地例皆如此。非别得法者。无得而得即是真得菩提。若言有得即是不得。当知菩提树下都无实事。故偈云。应化非真佛等故。无取说者。结归经文无分别义也。具足清净者佛也。谓一切惑习悉皆断除。荡无纤尘纯一无杂故。分清净者菩萨也。分断诸障分证真如。垢未全除故名为分。故佛顶经云。余尘尚诸学。明极即如来。广如序中满净觉者处说。无著下约无为差别明贤圣也。无分别者。即无为义。无所作为故云无为。无为真如盖是一法。菩萨等者。有分别故。有所为故。如来等者。无分别故。无所作故。初无为者。菩萨也。折伏等者。此约在观分别不生。分得相应故云显了。后无为者。如来也。无复分别是真无为。即第一义也。此约于佛故。复云者。更无过上故云无上觉即佛也。三乘下结通诸乘。以二乘之人亦分证真理。故此通摄也。是知三乘贤圣皆修证无为。所证虽无浅深能证有其差别。犹如三兽同度一河。能度有差所度无别故。大品云。欲求声闻乘。当学般若波罗蜜。欲求缘觉菩萨无上佛乘。皆言当学般若波罗蜜。是故经云。一切贤圣也。校量等者。问本因善吉起疑。所以世尊为断。断疑既已何用校量。答论云。法虽不可取不可说。而不空故。意云。恐有人闻是法不可取说。便欲一向毁废言教故。此校量显胜令其演说受持。故大云于此开立第五不空福德疑。以论文不言断疑。故此不立也。劣福问经意云。七宝最珍三千最大。用此布施福多不多。俱舍下明三千世界。四大洲者。谓东胜身洲。南赡部洲。西牛货洲。北俱卢洲。日月者。即一四天下。同一日月之所照临。苏迷亦云须弥卢。但梵语楚夏耳。此云妙高山。四宝所成高八万由旬。欲天者六欲天也。谓四天王天忉利天夜摩天兜率天化乐天他化自在天。梵世者色界初天也。于中复有三天。谓梵众天梵辅天大梵天。各一千等者。如上各满一千。方成一小千界。此小千等者。又一千个小千界。方成一中千界。此千等者。又以一千个中千界。方成一大千界。皆同等者。谓四禅已上三灾不及。故不说成之与坏。三禅已下统维三灾故云同一成坏。就中从初禅已下同火灾。二禅已下同水灾。三禅已下同风灾。七宝等可知。福多酬经答文可见。征云。以何义故说多。释意云。不约胜义空故说多。是约世谛有故说多。胜义空者。此门是绝相无为。不可言福与不福。福既不有。无以言多。世俗有者。此门是有相有为可以言福。以有福故兼可言多。判经福经意可知。然四句尚尔况全部耶。疏二一正释经文。偈释持说。因明胜之所以。望后经文有似太疾以偈文。连环不可分故悉之。受持及说者。标二法门不空等者。谓持说此经不同宝施空得福德更得何物。次文是也。福不趣菩提者。谓宝施虽多。但成世间有漏之福。终不能成无上菩提。二能趣菩提者。谓持说此经断除烦恼。烦恼尽处即是菩提故。四句下二别示句相。诠义等者。谓以一句诠一义。一义为一句。四义方成一偈。一异有空常无常等。皆各有四句。然今经四句人说不同。有说。取无我无人无众生无寿者为四句。有说。取若以色见我等为四句。有说。一切有为法等为四句。有说。但于一经之中随取四句经文。便为四句。有说。始从如是终至奉行。方成四句。然上诸说皆非正义。如凡下明正义。斯则约有无等为四句也。谓第一是有句。第二是无句。第三是亦有亦无句。第四是非有非无句。文义兼备。故云最妙。以此四义能通实相即是四门。然但下通妨先问。且一二二。句皆是四言。第三一句独成六字。文既增减云何成偈。故此释也。持说等者。以此四义是万法之门。若了四义即通万法。万法既通岂有菩提而不证哉。文或等者。但论其义。义不在文义必周圆。文从增减。义若等者。谓阙之成谤具之成门。成谤者。谓阙无成增益谤。阙有成损减谤。阙非有非无成相违谤。阙亦有亦无成戏论谤。以有则定有无则定无。余二例之故成四谤。何以故。法不如是故。不如法见故。斯则般若波罗蜜犹如大火聚。四面不可取也。具四句者。谓义无所阙故。有不定有。是即无之有。无不定无是即有之无。余亦例之。随于一句之中。圆见四句之义。不堕增减等谤故成门也。何以故。法如是故。如法见故。斯则般若波罗蜜犹如清凉池四面皆得入。但以人依于法。法异人乖。苟法义之所全。岂菩提而不证矣。故言受持此经胜于施福。正释经征意云。以何义故持说此经。胜于宝施。释意可知。诸佛菩提法者。拣非余乘菩提法也。然余菩提非此不出。但举胜者而以例之。此二者持说也。了因者。以法身是本真之理。不生不灭。但以烦恼覆之则隐。智慧了之则显。持说此法妙慧自彰。观破烦恼法身现矣。生因者。报化之身本来无有。万行所致故名为生。故弥勒颂云。于实为了因。亦为余生因。为经云一切诸佛菩提法。皆从此经处。转释经所言佛法者。约世谛故有。即非佛法者约第一义。即无第一等者。谓俗谛相中有迷悟染净凡圣之异。故说佛法从经而出。真谛之理离于迷悟染净凡圣之相。故不可说出佛法之义也。故圆觉云。一切如来圆觉妙心。本无菩提及与涅槃。亦无成佛及不成佛。无妄轮回及非轮回。然则本论异此不能烦述。第四疏初标章。向说下指疑起处。此从第三中来。不可取说者。以前文云如来所说法皆不可取不可说。云何下结成疑也。前云一切贤圣通于三乘故。疑声闻得果是取。如初果人证自初果。亦自说言已证初果等。入流果经问意云。于汝意中如何。汝谓须陀洹人作念云得须陀洹果不。答言不也。征意云。若如是者。以何义故得名须陀洹。释意云。但约不入色等境界。即名须陀洹。疏三。初正释经文。入流者四果名为圣人。经从凡夫创入圣类故流类也。预厕也。只由下释得名所以。入者取着义。若取六尘即滞凡流。不取六尘名入圣流。是知功过在人不在六尘境界。据此则何有别法而为所入耶。论云下引证上义。不取一法者。不唯六尘也。名逆流者逆凡流也。谓若取六尘即入凡流逆圣流。既不取着即入圣流逆凡流也。乃至下例明余果。初果尚尔况余果耶。然非下二商教果证。或问既皆不取应亦不证。故此释也。但于下转释。意明但无取心非谓不证。若起下反明。凡夫着我既由起心。圣人无我。必不起也。故知下三结断疑情。空生本谓证果是取故生疑。今明无取方成证义。永异所疑也。若准断疑斯文已毕。以四果是小乘贤圣修证行位。是故经中具而明也。然此四果复有四向。谓向于果故。即须陀洹向等。于四果之中初为见道。次二修道。后一无学道。且初修行得入见道。谓十六心断三界四谛下八十八使分别粗惑。得初果证。谓三界各有四谛。每谛下各有烦恼。即贪嗔痴慢疑身见边见邪见见取戒禁取。四谛之下或具或阙故成八十八使。杂心论云。苦下具一切。集灭除三见。道除于二见。上界不行恚。谓初句即欲界苦谛下全具十使。次句即集灭二谛下各除三见。即身边二见及戒禁取。所以除此三者。缘身是苦本。观苦已断身见边见。依身而起故亦随亡。无戒禁取者。以集谛不计非道为道。灭谛又非修位。是故皆无戒禁取。道当修位却或有之故不除矣。故云道除于二见。不除戒禁也。由是苦下具十。集灭二谛下各七。通前即二十四。道谛下八合三十二。后句云上界不行恚。即于二四谛下各除一嗔。每界各有二十八共成五十六。兼下欲界三十二。即都合为八十八也。云何十六心。谓欲界四谛下。各一忍一智以成八心。又合上二界为一四谛。类下欲界观。断亦各一忍一智。以成八心。二八即为十六心也。忍即无间道。是正断惑时。智即解脱道是断了时。所谓苦法智忍苦法智。苦类智忍苦类智。乃至道法智忍道法智。道类智忍道类智。断至十五心道类智忍名初果向。至第十六心道类智时。名证初果。入于见道为须陀洹。分别粗惑一时顿断。犹如劈竹三节并开。即以见谛八智为初果体。初果行相略明如是。余之三果伫见次文。一来果经问答及征意。皆同上释。意明斯陀含者。但于人间天上一度往来。虽复往来实无往来之者。只约此义名斯陀含。断惑者。谓欲界修惑有四。即贪嗔痴慢。此是俱生细惑。任运起者障于修道。以难断故分为九品。所谓上上乃至下下。此九品惑二三果人断之。断至五品名二果向。断六品尽名第二果。故俱舍云。断至五二向。断六一来果。一往等者以九品修惑。能润欲界七生。谓上上品润两生。次三各一生。次二品共一生。下三品共一生。今断六品已损六生。犹残下三品润欲界一生。是故一往天上。更须一来人间受生断余惑也。便得等者。问据此次第。合是第三。云何僣言便得罗汉。答所言便得罗汉等者。非谓逾越不证第三。但约欲界惑尽往而不来。望一去说。故云便得等也。若改便得为直至何也。余下三品一生断尽。便往罗汉即不须前来和会也。故名下结成第二果。即以见道八品无为。及修道六品无为。为此果体。无我等者。由无我故不计去来。非谓不去不来。但不计去来之者。其犹鲁船匠士刻木为人。虽复驱使往来。实无情虑所计。不来果经问答征意。亦同上释。意云阿那含者。一往天上更不再来。虽尔不来亦无不来之者。但约此义。名阿那含。不来不还。盖是一义。断惑等者。谓前九品惑中余下三品。断至八品名三果向。断九品尽名第三果。故俱舍云。断惑七八品名第三果向。九品全断尽即得不还果。更不还者。欲界修惑但余三品。三品烦恼共润一生。今以断之。更无惑润杜绝纡绊故无再来。故云下结成第三果也。即以见道八品无为及修道九品无为。为此果体。此二三果人断惑。犹如截木横断。而已知之。同前者。合云已悟无我虽能往来。四不生下二。初辨得名。三释者。由有三义故存梵音。无贼者。意以烦恼为贼。谓断人慧命劫功德财。致使行人失于圣道。流迸生死旷野。不达涅槃宝所。为害颇深故名为贼。见修等者。谓上二界各有三种修惑。谓贪痴慢。此惑微细难除。故约八地分之。每地分成九品。都合七十二品。每品各有一无间一解脱。断至七十一品名阿罗汉向。断七十二品惑尽成阿罗汉。此果断惑如登楼台渐陟渐高。见修合论兼欲界一地。总以八十九品无为。为此果体。若约四果有为出体者。即初果唯取道类智一解脱道为体。第二唯取断欲界九品修惑中。第六品一解脱道为体。三果唯取第九品一解脱道为体。罗汉唯取有顶地第九品中一解脱道尽智为体。所言无为即离系果。有为即等流果。不生等者。谓我生已尽梵行已立。所作已办不受后有。然前三句。即是尽智。后句即是无生智。谓不向三界之中。受有苦身也。以世间因亡果丧。出世间因成果证故。应受等者为超出人天故。堪受人天供养。若或一种沦溺宁堪供之。故俱舍云。供养阿罗汉得现在福报。盖由业烦恼尽福田胜故。当知。未出三界受他供养者。大须随顺出离。岂得安然免之哉。举问经意准前可知。明答及征意准前释。意云阿罗汉者。无烦恼不受生应供养。以是义故名阿罗汉。除此之外。更无一法名阿罗汉。若阿下反释云。若或作念言。我得阿罗汉果。便着我人等相。则与凡夫何所异哉。由此验知。的无是念引己证令信者。以己方人也。亦令众生皆亡是念。入于圣道故。先印经意云。佛于往日。曾说于我得是三昧人中第一。不恼等者。若人嫌立则复为坐。乃至不向贫家乞食。皆为不恼他也。能令下释。既不恼之烦恼何起。第一等者。谓十大弟子各有一能。皆称第一即迦叶头陀。阿难多闻。舍利弗智慧。目连神通。罗睺罗密行。阿那律天眼。富楼那说法。迦旃延论义。优波离持律。须菩提解空。今言无诤者。只由解空得无诤故。亦如夫子十哲。各有能事。谓德行颜渊闵子骞冉伯牛仲弓。言语宰我子贡。政事冉有季路。文学子游子夏。离欲等者。谓贪使烦恼通于三界。断尽此贪方真离欲也。问若然者。则但是罗汉皆断三界烦恼。云何善现称第一耶。答所言第一者。盖约无诤不约离欲也。故经云。我得无诤三昧。人中最为第一。又魏经云。我若作念。世尊则不记我无诤行第一。意者。以空生独得无诤三昧故。于诸离欲罗汉之中。称为第一也。不取经云。佛虽赞我我于此时辄无是念。佛意经云。若我当此之时作如是念。我得阿罗汉果。佛则不说我为乐寂静者。只缘不作是念故佛赞之。无所行者。即不作念也。故经中反说。即言若作是念。顺释即言实无所行。离烦恼障者。谓贪等十使粗细尽除。离三昧障者。三昧是定障即是惑。三昧之障依主释也。不同烦恼即障持业释故。然此二障离。各有由离烦恼障得罗汉故。离三昧障得无诤故。寂静者。寂静即是无诤定意言。须菩提是乐寂静之者。第五疏初标章。释迦下先述疑意　即释迦因中为善慧仙人。蒙然灯如来授记云。汝于来世当得作佛。号释迦牟尼。由此增进入第八地。故云受法。广有因缘如第十二中说。云何下指疑起处。便结成疑。此亦从前第三中来。以彼文云如来所说法。皆不可取不可说故。经问意云。于汝意中如何。谓我昔于然灯佛所。于授记言说之中。有法为所得为无所得。答意云。如来昔在然灯佛所。于授记言说之中。实无法为所得。说是语言等者。以是语言故无所得。语言非实者。谓语言从缘缘无自性。举体全空空故无得。也斯则闻而无闻说而无说。智证法者。释得记之由也。意明。但以自无分别智证自无差别理。智与理冥境与神会。岂有所说所得耶。论云下引证上义。证法离言说相故不可说证法离心缘相故不可取也

金刚经纂要刊定记卷第四金刚经纂要刊定记卷第五

        长水沙门子璇录

第六疏初标章。若法下指疑起处。此亦从前第三中来。云何下结成疑也。既兴功运行六度齐修。回向发心严净佛土。此若非取则孰为取耶。佛身之疑意亦同此。以是二报不相离故。故论文中二疑双叙。然今此科但断一种举问。经意云。菩萨取形相庄严佛土不。佛意等者。空生本疑有取。佛意欲显无取。取与无取在于性相二土。故且举相问之。试其解不。释答经意云。不取相庄严佛土也。征意云。以何义故不取相庄严佛土。释意云。不以相庄严是真实庄严也。偈云下。于中前三句正释经。后一句即却释偈之第三句也。又前两句。释经中庄严佛土者。非形释即非庄严。第一体释是名庄严。非严显偈中非形。庄严意。显偈中第一体。此但指配其文。义意即逦迤次显。论释下转释偈文。诸佛下至不可取。释偈之前半。谓修习无分别智。通达唯识真实之性。此则以智契如名为庄严。即是无取之义。所疑有取自此释遣。庄严有二下释后半。先列二土。形相即法相土。谓金地宝池等。以要言之。但有所见闻皆属形相。第一义即法性土。谓离一切相无所见闻。即真如理是。非严下正释。即以后第三句为出所以。由是故得非严及庄严也。非严即拣法相土。非今所严之者。当于经中则非庄严也。庄严意。即显法性土。是此所严之者。当于经中是名庄严。所谓显发过恒河沙数功德。而为庄严。如金作器器非外来。即以此器反严于金。是故前引论云。诸佛无有庄严国土事等。是则于诸严中更无过者故。云第一庄严等也。言意者。即指非形第一体。是非严庄严之意也。意即所以也。问诸佛身土必须性相具足方为了义。今既唯言于性。岂不阙于相耶。答身土之相唯心之影。心净方能现之。苟能清净其心。身土自然显现。其犹磨镜尘尽像生自然。如然故非造作。故唯识云。大圆镜智。能现能生身土智影。况是即相亡相非谓弃相取性。但无执情何阂于相。然以经宗无相此义稍增。首末皆尔。用心之相如次所明。净心劝经意云。以是义故。汝诸菩萨应生无住清净之心。若人下。先叙所遮之心。意以形相为真佛土。由是见故便欲形相庄严。故云我成就等。彼住下显失也。意明本欲严净如何却生染心。以住色等即生死心。何名净耶。为遮下。蹑前所遮引起经意。既以不住色等为清净心。当知。住于色等诚为染矣。正智者。无住之心既是正智。当知有住所生之心同为妄识。此中正智而言生者。所谓显发非创然而生。故大经云。于一切法不生。是般若波罗蜜生也。以此般若不生不灭故云真心。若都下。显意遮过恐惰空见。故令生此真心。天真之心本无生灭。但缘住境即不相应。亦非断灭心。若不住般若。了然亦非生起。恐人迷此故为显而遮之。是则前令不住色等是遮有。后令生心是遮无。既离有无即名中道。如斯体达是真庄严。何有佛土而不清净。故净名云。欲净佛土当净其心。随其心净即佛土净。净其心者即离有无也。第七疏初标章。疑起之意前章已叙。问此与第三何别。答前化此报故不同也。缘前闻应化非真。故无有取。便云报身是实应有取心。是故此疑蹑彼第三而起也。断疑经问答可知。征意云。以何义故。名之为大。释意云。非有漏有为身。是无漏无为身。若准无著则全异于此。大抵首末皆依二谛而释也。今此疏中有依天亲。有依无著。则此一段且依天亲也。疏二初总释喻旨。高远等者。谓下据金轮高八万由旬。六万诸山而为眷属故。名为大。故华严疏云。须弥横海落群峰之高。而不取等者。彼山虽大四宝所成。五位法中色法所摄。三性之内无记性收。岂有分别而取为王也。报佛下正明所喻。谓进修多劫福智圆明。纯净无垢更无过此。故云无上。独王(去声)法界故号法王。大有二义。一约体身智郭周故。二约位诸圣莫及故。无分别者。非如色法是无记性。但以三祇修习万虑都忘。如知寂然。故无分别。偈云下以偈结也。非身下。二别解非身二。初牒经略指。无漏无为者。无漏则简异世间。无为则表非生灭。问今明报身。即合有为无漏。云何此说无为耶。答此据实教不约权宗故。是无为也。故净名云。佛身无为不堕诸数。佛身无漏诸漏已尽。故偈云下。二引论广释二。初引本偈。此偈标远离有为有漏。意显唯有无漏法体。论云下。二引论文三。初双标。若如是者。指经征起以标也。以唯下。二双释。清净身即法身也。此释有物之句。即是经中是名大身也。问此说报身。云何言法。答以法报合说二身不殊。以此实教理智无二故得云耳。以远离下。释无物之句也。即是经中佛说非身也。法身既是无为。则离有为生灭。有为既离况有漏耶。故此释文不言诸漏。以是下三双结。谓以是远离及唯有故。显得法身真我。无漏无为不生不灭。湛然清净故有实体。名为有物。不如凡夫遍计之我有漏有为即生即灭如彼梦幻无有实体也。以不依下。结无有物。亦是重显所以也。以不依于五蕴有为之缘而住。唯如如及如如智独存故。有实我。当知凡夫皆依五蕴有为缘住。五蕴尚假。况所计我耶。缘法非己故。云依他也。辩沙经意可见。阿耨池者。此赡部洲。从中向北有九黑山。次有大雪山。次有香醉山。于雪北香南有阿耨池。此云无热恼。纵广五十由旬。八功德水充满其中。于中四面各出一大河。东名[歹*堯]伽河。绕池一匝流入东海。南信渡河。西缚刍。北徒多。皆绕池一匝如次。入南西北海。今经恒河即殑伽也。言恒者译者讹也。周四十里者。谓初出池口处也。佛多下。出取喻之由。然说此经时。但在祇园。余说法时多近于彼故。以喻也。彰福经意可见。论云下征也。谓三疑之后四果之前。已说宝施之喻。今复说者岂不重耶。偈云下释也。谓前已一三千界宝施。此说无量三千界宝施。虽则总是多。若总是胜校量。然其后者。即多中之多胜中之胜。故重说也。斯则言说重而义意不重。何故下转难。意云。何不于前文中便说此喻耶。为渐下约人通也谓机浅法深。顿说难信渐次诱引令知胜德。又前下约法通也。谓喻之前。未说四果无心释迦无得严净国土不严而严。修证佛身无证而证。是故校量之喻亦未能胜。后乃既明斯义法理兼深。由是校量之喻亦复殊胜。或可出生佛法之义亦在前喻之后也。况后释所以中五段经文。亦属于此思之。显胜经意可知大意同前者。即福不趣菩提。二能趣菩提是也。可敬经可知。大般若下引事证。帝释每于善法堂中。为天众说般若波罗蜜法。或有时不在。诸天若到皆向座恭敬作礼。为重于法乃尊于处。故高显者。以尊人故令处高显。俾远近皆见敬而生福也。形貌等者。塔中有佛形貌人见必生敬心。见于说法之处。亦如见佛形貌。若梵语制多此云灵庙。或云可供养处。与此大同。获益经意云。宣说四句之处。尚得天人供养。何况尽此经文能受持耶。如经叙之前四句等者。据此经意望于前段有二胜劣。何者为前说其处。此说于人。前明四句偈。此明尽受持。由是前则劣中之劣。此乃胜中之胜。反覆而言故云何况也。最上者法身也。无漏无为绝上上故。第一者报身也。众圣中尊更无过故。希有者化身也。如前所说四种事故。意明受持读诵具获三身功德圆满也。有云。能趣菩提故云最上。胜出诸乘故云第一。世间无比故云希有。有佛经意云。如此经文随何方所。即为有佛及诸弟子。经显下明有佛及有之所以。谓报化必依法身。法身又从经显。既有能显之教。必有所显之佛。又经是教法佛是果法。果由理显理由。行致。斯则三佛备足四法具圆。所在之处岂生轻劣。又一切下。明有弟子之所以。三乘贤圣体是无为。经显无为故有贤圣。尊重者。谓证如者。皆是入理圣人。可尊可重故。若准魏经。即但言有佛使人尊重。不言别有弟子。故彼文云。即为有佛尊重似佛。名胜经问意云。未审此经有何名目。不有名目如何奉持。答文可知。征意云。如来常说诸法名相皆空。今特立此名者。有何所以。释意云。我所立者名即无名。无名之名岂违空义。为受持故于无名中强立名耳。佛立下。释立名之因。因即所依之义。谓金刚有能坏之义般若有观照之功。法喻双彰故。曰金刚般若其实亦约能坚之义以立。今且就用释之。具如题中及七义句中说也。断惑故胜者。众生流转为遭惑染。若断惑染成佛无疑岂不胜乎。对治等者。约名显义义实名虚。若执虚名安得实义。虑有斯执。是故对治异说。胜经问意云。汝谓如来除所证之法外更有别异之说不。答意云。如来除所证之法外。更无别异之说。此段蹑于次前立名处来。意云非唯立此经名名即无名。凡有所说悉皆如此。又非我独尔诸佛亦然。无别等者。谓释迦一佛初中后说。竟无别异增减。然乃但据真实无差。不约言辞有异耳。但如下出所以也。凡有说时皆如其证。证中无说岂有异耶。三世下。结通诸佛。以诸佛同证竟无二源不证则已。证则无别也。若未至极位在因地中。随其所说各各差别。何以故。所证不同故。如地前地上十地节级不同。由是果人决无异说。故云下。结成上义。既一佛多佛过去未来所说皆同。咸如其证。如证之说不亦胜乎。故论云下引证唯独等者。说般若能断烦恼。无有一佛不作此说。余皆若此。第一等者。以谛理离言说相离名字相故不可说。此证前既如其证则无所说也。然无著天亲语。虽似异其意实同。既如其证岂非第一义耶。尘胜经问答之文可见。释意云。所言尘者。非烦恼尘但是地尘。所言世界者。非染因界但是地尘界。此即蹑前校量中来。由前说河沙宝施不及持经。惑者所闻未能诚信。所以如来特说此义。使其明见优劣用涤所疑。具在疏文昭然可见。论云下。释尽其意。意云。碎界为尘。尘上不起烦恼。宝施得福即有贪嗔五欲自娱。无恶不造。故相传云。布施是第三生怨。所以尘界胜于宝施。且尘界但不起过尚得为胜。况受持此经。定招佛果岂可以为劣哉。由是相望便有三重胜劣。谓宝施不及尘界。尘界不及持经。持经尚胜于尘界。岂得不如宝施。如百姓不如宰相。宰相不如天子。天子尚胜于宰相。岂得不如百姓。喻中天子最胜也。法中持经最胜也。经胜所以岂不昭然。大云下。但对经文以拣法喻。更无别义。然其意者。说微尘是尘。贪等亦是尘。以俱有坌污之义故。说三千为界。说烦恼染因亦为界。以皆有为因之义故。亦可三千是器界。烦恼是有情界故也。今则拣非贪等尘及染因界。但是地尘及三千界也。是则结释上义并如前说。果胜经问答之文可知征意云。以何义故。不以三十二相为法身如来。释意云。如来说三十二相。非是法身无为之相。但是化身有为之相故。恐施下。叙经起之意也。恐彼意云若施不求佛即起烦恼本。为求佛云何烦恼。彼所求者。即是三十二相之身。为破此见故复问之。持说下。且标胜劣。谓宝施但得色相。持经即得菩提。故云胜彼福德。何以故者。征意云。既得三十二相。何不得菩提。彼相下释也。理法身是菩提相。彼三十二相非菩提相。所以言者。菩提无相故。由法身即菩提相。非菩提相空矣。又于其中。法身则胜色身则劣。何以故。法身无为真实性故。色身有为影像相故。然由持说因胜故。果中获法身。宝施因劣故。果中获色身。故上标云。持说此经胜彼福德。经福下转遮谬解。恐施宝者闻上所说。便云虽知色身劣于法身宝施不如持说。我以不能持说不要法身恒将宝施成就色身。相好既圆不亦妙矣。为遮此见故此云也。谓前且约别义分于因果。故说施感相身。若据实义而论。空施不成相果。何者。由无智慧随相生情。所施虽多唯成有漏。纵得三十二相。但是转轮王色相虽同不名为佛。若能持说此经。则智慧圆起。依慧行施不住有空。以无漏因获无漏果。如此三十二相。始得名为佛焉。意明下。结释上义不逾前说。校量经意如文可知。但甚多之言。显超命施之福也。舍身等者。意恐人闻宝施不及受持。便谓以是身外之财所以劣于经福。若将身命布施必胜受持。为破其见故有此文。沙数犹劣况一身耶。泣叹经意者。谓空生闻上所说。喜极成悲泣涕连连。自宣心曲身为罗汉已是多时慧眼虽开未闻斯教。舍身下。悲泣之由。然有三意。一谓伤彼舍身虚其功。故意云。舍命河沙劣于持说。不达深旨劳而无功。二谓悲曩劫不逢遇故意云。在凡不闻故当其分。自阶圣果亦未闻之。三谓庆今得闻。喜极成悲故。善吉创闻深法非本所望。涕泪交流以彰极喜。今此疏中且明前一也。论云下引证。慧眼等者。谓空生混迹寄位小乘。自证人空已来未闻法空之理。以法空是大乘所证境故然。以此为经胜由者。有两重意。一谓教若粗浅闻乃寻常。既感悲啼乃知深妙。二谓常人啼泣未足为奇。善吉悲伤当知最胜。胜之所以不亦明乎正明经意云。若人闻此能生信心。此信若生不信诸法。故云清净。诸法既泯实相生焉。三身功德自此周备。岂不胜耶。第一等者如前所明经。文存略故标二也。此中即般若教。余者即未说般若之前。二乘人天之教。所言实相者。即无相之相也。谓无我法之相。以要言之。离一切相名为实相。故下文云。离一切相即名诸佛。言余教所无者。谓人天教中具足二执。小乘教内法相犹存。不可以二执之相而为实相。故言余者非实相。非犹无也。言此有者。谓顿除二执双显二空空病亦空。二边皆离中道斯显名实相焉。故云此中有也。问实相之理教但能诠。云何信心便生实相。答谓能信此经必无二执。无二执处即是实相。非谓别有实相生也。佛迹经意云。此实相者体当胜义。但唯无相名依世谛故言实相。为离等者。恐闻实相之名。便生实相之想。想即分别也。良以实相真妙言念不及。虽假言念唯证相应。若起当情但唯影像。恐认于此故曰即非。信解经意云。我为阿罗汉亲禀佛言。信解受持不为难事。若当来世浊恶世中。去圣时远不闻佛说。览斯遗教信解法空。领受任持依解起行。若斯等类不亦难乎。未来等者。谓无著出世当正法中。故引来世之胜人。以诫当时之劣者。是知小人君子何代无之。斯则指于第二疑中所说后五百岁持戒修福者也。三空经征意云。设有能信解受持。以何义故得为希有。释意云。以无我等相故。此则我空也。征意云。所以令无我等相者。何谓也。释意云。以我等相即非相故。我相体是心心所法。既无此体即是法空也。又征意云。以何义故。令无我法之相。后释意云。离一切相名为佛。故诸相虽多不逾我法。今此统收故云一切。斯则是相皆离为俱空也。俱空之理则名为佛。佛自此成故言胜也。人法二取其义可知。显示等者。为我法二空菩萨。有分离一切相。方是如来。今显示此义者。令诸菩萨方便随顺学而习之见贤思齐速成佛故。故云诸佛世尊乃至如是学也。印定经意如文可知。然以前来从尔时须菩提闻说是经。乃至离一切相即名诸佛。尽是空生之言。于中逦迤有其六重。所谓闻法悲啼信生实相。对彰难易明无我人。法执兼亡尽成佛故。如斯所说皆当诚谛之言。故佛世尊印云如是。重言者表言当之极耳。不动经意云。此经深妙难解难知。或有人闻多生惊畏。若得不生惊畏。岂不希有者哉。实难其人盖缘经胜。经胜之义昭然可知。惊畏者。此三行相不同。惊谓愕然而怪。怖则进退慞惶。畏则一向恐惧。如人欲往上京行于大路。以先未经历忽然而惊。心自念言何谓至此。或进或退疑是疑非。遂无决定之心。谓此路元来不是。或反而不进。或恐惧发狂坠壑投岩不终天命。法中亦尔。以佛于人天小乘教中说空说有。不达意者随言而执。及说此经则显非空非有中道之理。先所执者悉皆惊畏。却以为非不能进趣。或堕凡夫或落小乘。菩提真空从兹永失。今之经意则云。若人闻此不有。不空难信之法。不生惊畏之心。则能不舍菩提进向大道。旨趣深妙鲜有其人。若或有之是为希有也。大因经征意云。以何义故。闻而不惊等。得为希有耶。释意云。以此法门于诸波罗蜜中是第一波罗蜜故。然此波罗蜜。若约胜义则不可言故。言非第一等。今所说者约世谛说。为胜之义不亦然乎。故云是名等。二都下。为前来两重校量皆言经胜。释胜所以已列九门。每门之中各是一义。未知根本何谓胜乎。斯则于胜所以中。更征胜所以也。大因者。谓第六般若波罗蜜也。以佛有三身法身最大此能得故。名为大因。六中最胜故称第一。胜余等者。谓人天二乘教中不诠此法。今乃诠之。彼以所诠劣故。能诠亦劣。此以所诠胜故。能诠亦胜也。清净等者。谓随相之法建言必异。离相之理说即无差。以平等一夫故。平等一味即胜义谛也。以是胜义故清净矣。故彼下通释都征之意。檀即是施。通于内外二财故云等也。无如是功德者。谓在因无破惑之功。在果无法身之德。故此福者受持读诵也。然前门门皆显经胜。胜之根本不过此门。能成清净法身。是故说名为胜。内外财施安可校量。第八疏初标章。向说下指疑起处也。此从前内财校量中来。谓河沙命施全胜外财。犹感苦身故名为劣。若尔者印定前说。依此下结成疑也。谓依此经受持解说不惮劳苦。即是菩萨行。菩萨之行无所不为。剜身然灯割股救鸽。一句投火半偈亡躯。供佛烧身捐形饲虎。如是等行皆名苦因。为行颇同果证何异。因果既等何胜劣哉。云何等者。意明前舍身命即成苦果。今受持经亦是苦行。何故不成苦果耶。忍体经意云。忍辱波罗蜜者。胜义谛中则无此相。故云非忍辱等。断疑意者。若如汝言受持此经。及菩萨行苦行。便同舍身俱成苦果者。此义不然。以前舍身不达无相即成苦果。持说此法菩萨苦行达无我人。知忍无忍彼岸非岸直造本源。岂成苦果。故云忍辱非忍辱等。忍到等者。然此以超忍为体。须知本末五重。然后披疏则明见其理。五重者。一是本源之心非动非静。二不忍谓以怨报怨。三忍虽不加报未能忘怀。即未至彼岸忍。四忘情绝虑寂然不动。即至彼岸忍。五非动非静。即超彼岸忍。为治动心且居静境。动既非实静岂为真。若准五门方为究竟。与其第一更无二源。体相常然竟无改易。今言忍辱波罗蜜即第四门。非忍辱波罗蜜即第五门。离苦相者。已越第三彼岸非岸兼超第四。尚踰静境岂有动心。初后两端正当忍体。正明经征意云。以何义故。能行此忍。释意云。以无我人等相故也。歌利王等。准涅槃经说。我念往昔。生南天竺富单那城婆罗门家。是时有王名迦罗富。其性暴恶憍慢自在。我于尔时为众生故。在彼城外寂然禅思。尔时彼王春木华敷。与其眷属宫人婇女出城游观。在林树下五欲自娱。其诸婇女舍王游戏遂至我所。我时为欲断彼贪故而为说法。时王见我便生恶心。而问我言。汝今以得阿罗汉果耶。我言不得。复言获得不还果耶。我言不得。复言汝既年少。未得如是二果。则为具有贪欲烦恼。云何恣情观我女人。我即答言。大王当知。我今虽未断贪欲结。然其内心实无贪着。王言痴人。世有仙人服气食果见色尚贪。况汝盛年未断贪欲。云何见色而当不着。我言大王见色不贪。实不由于服气食果。皆由系念无常不净。王言。若有轻他而生诽谤。云何得名修持净戒。我言。大王若有妒心则为诽谤。我无妒心云何言谤。王言。大士云何名戒。我言。忍名为戒。王言若忍。是戒当截汝耳若能忍者知汝持戒。即截我耳。时我被截容颜不变。时王群臣。见是事已即谏王言。如是大士不应加害。王告诸臣。汝等云何知是大士。诸臣不言见受苦时容颜不变。王复语言。我当更试知变不变。即劓其鼻刖其手足。尔时菩萨。已于无量无边世中。修习慈悲愍苦众生。时四天王心怀嗔忿雨砂砾石。王见事已心大怖畏。复至我所长跪而言。惟愿哀愍听我忏悔。我言。大王我心无嗔亦如无贪。王言。大德云何得知。我即立誓。我若真实无嗔恨者。令我此身平复如故。发是愿已身即平复。今疏言。问得四果者。盖通相而言也。论云。下义如后释。反显经征意云。以何义故得知无我等相。释意云。若有我相应生嗔恨。既不嗔恨则无我相。如昔立誓若实无嗔身即平复。以无嗔故则知无我。以无我故。方成真实忍波罗蜜。支离也。相续忍经意云。恐人将谓只是一度能为此忍。故说过去已五百生。或恐人言无我能忍应可暂时。若使频为必不能尔。故说多生悉皆如是。或恐人言有何所因无我。能忍故说多生忍之熟故。含三意故有是言也。累苦故者。本疑累苦难忍。却由累苦能忍。斯则翻前三意中后二意也。而乐者。然有四意故乐。一为忍熟故乐。如役力之人久得其志也。二为正定故乐。常踞大定寂灭不动故。三为愍他故乐。如孩子杖父父即乐生。四为自利故乐。以将此幻形易得坚质。具兹四意故言乐也。疏文但有前三。故偈云下引证。如是苦行果者。对破疑情也。谓因苦果还苦。因乐果还乐。故不同也。如陶金作器器还是金。和土脱墼墼还是土。前征云。何此法不成苦果。今此结云。如是苦行故。不成苦果也。二劝离相中疏二。一引论叙意。论云下出劝之由也。谓不能安忍。欲舍菩提心。由见苦故。见苦是苦者。由不离我相故。若离我相则不见苦。自然成忍不舍菩提故。今劝之令离相也。夫菩提心者。谓上求下化二利不息。既若见苦为苦。即不能忘身舍命出生入死。是故便舍大菩提心。如舍利弗本发大心行菩萨行。至六住被乞眼睛便生嗔忿不成忍行舍大归小。盖由我相也。三种苦者。前二即次文。后一即当第十疑中心住于法行布施等是也。意明住相行施堕有漏中。受用欲乐疲乏生苦也。亦可有漏有限。有限故乏受用。乏受用故生于苦也。然今依天亲科经。故不收入此段。前二文理相似故全用之。总标经意云。以是无我相等得成忍行。故彼诸菩萨。应须离相发菩提心。若离等者。住相既舍菩提。不住即成大忍。菩提之心自然久固。何舍之有也。无著下可知流转苦。经意云。不应住于色等六境生于妄心。应生无住菩提之心。若心有住色等境界。则为非住菩提也。以是义故。佛于正答问之中说菩萨心。不应住于色等布施。菩萨之行处处皆同。故引前文以证于后也。流是下解科文。此即四谛之中。前二世间因果也。大云解云。集招苦果故说为流。生死不停故名为转。斯则袭习纶轮之义也。着色等者。着色等即疲乏。菩提心不生。不着色等即不疲乏。菩提心生矣。引前等者。是上修行文中也。已如前说相违苦。经意云。菩萨行行本为利益众生。故便离相行于布施。若能离相则众生相违时。不生疲乏也。况我法二相。如来说为非相耶。以皆本无故须离矣。若其本有何用离之。劝离之旨方兹着矣。疏文内引无著显意。既为等者。盖不合为而为之也。如人邀客本为供承见有所须反生凌辱于理如何。由不能下。出嗔之所以也。故显下出经意也。但无此二心必相应。论云下。二约天亲释文。众生相者。以魏经云。一切众生相故。阴中等者。今于阴中不见有我。故云非相也。五阴法者。以彼众生。皆用五阴之所成故。阴空等者。以无能成之五阴故。云法无我也。然此人法二相本自空无。众生不知妄执为有。今所说者意。令知而离之也。又此我法经文。文与意反。文即先法后人。意则先人后法。魏经之内文句昭然。故今疏中顺意释也。第九疏初标章。于证下。述疑意兼指疑起处也。此从前第三第七中来。以彼校量内外财施不及持经。以此得菩提故遂起疑云。若然者且言说是因。因即是道以此证果理则不成。何者。以果是无为无为有体。因是有为有为无体。无体之道不到果中。云何说此而为因耶。断疑经意云。如来之言真实无异。皆如其事不狂众生。持说必趣菩提。汝等云何不信。又以如来说于真实等故。名如来为真实语者。由是者字皆属如来。疏文初略消经意。佛所下。通说断疑之意。皆如其事者。即下四语所说之事。今说等者以彼况此也。意云彼既无谬此岂不然。真语下。二广释五语。佛身即真身也。以法报合论理智无二故。若欲分文别指。则佛身是报。大菩提法为法也。是真智者。以菩提是觉觉即智故。论云。依此法身说名本觉。法报合说同名真身。如来说此真智之法。乃名如来为真语者。此则以所说名能说也。余皆例此。谛实等义已如前说。如语等者。小乘虽有生空之理非实真如。以是偏真未彻源。故大乘之内。具显三空。空病亦空是究竟真如法也。不异者。与三乘弟子授记劫数久远名号寿量国土等事。一一不异故也。佛将等者。谓本来只有四语。秦什译时加此一语。欲以统收四语发明佛意用之断疑也。应可一一举而问之。以显不狂之义。且如佛说大菩提法。为真智时为真不真耶。则对曰。真当知。如来是真语者。斯则不诳之义明矣。他皆例此。说此四事既不诳人。今说此经受持得菩提果。岂成诳耶。云何不信。虽此言说有为无体之因。能证离言无为有体之果。故偈云。果虽不住道而首能为因。以诸佛实语。彼智有四种。亦如净名云。文字性离即是解脱。无离文字说解脱也。离执经意者。前虽以言遣疑又恐随言生执。闻说依言得菩提。便谓言中有菩提。及闻言中无菩提。便谓毕竟无菩提。不达言空而法实故作斯执。今则遣之故。云如来所得等也。如言等者。为言说缘生本无自性。言中菩提亦同言说。何以故。有名无实故。如言于火但有火名。名言二法皆无体性。故云如言等也。不如等者。不似言说也。谓言说毕竟无体。菩提之法即不无也。但以不在言中。不无离言之法。如言中之火虽无不无离言之火。由是言中虽无火。不妨因言而得火。言中虽无菩提。不妨因言而得菩提。以依言进修必证果故。若然者则不应言中执有离言执无。达此有无方云离执。故偈云。顺彼实智说。不实亦不虚。如闻声取证。对治如是说。第十疏初标章。若圣下指疑起处。此从第三中来。准彼但云无为不言真如。今所言者。拣余无为故。所以拣者欲显所疑要成遍义。余无为法有不遍故。彼真如下立理也。如华严云。法性遍在一切处。一切众生及国土三世。悉在无有余。亦无形相而可得。斯则处及尘尘时。该念念故也。何故下结成疑。既遍时处即合皆得。何故有得不得耶。断疑经意云。若住法行施。则不得真如。如入暗中一无所见。若无住行施则得真如。如太阳升天何所不瞩。真如虽遍得失在人。义理昭然竟何所惑。无智等者。谓无般若观照之智。由无智故。即执着色等六尘及空有等一切法也。以住是执着之义故云住法。心不净者。由执着故为尘所染。正智不生不证真理。故云不得得即证也。有智等者反前可见。对治等者。以经中具有法喻。疏中配释影略难明。今要预说然会疏文。谓喻中有五。一空二色三暗四日五目。法中有四。一真如二性德三烦恼四智。法四喻五。数不齐者。以空喻真如。色喻性德。暗喻烦恼。日目二事同喻一智。所以然者。以日目二事各有一能。智慧之中具有二义。日能破暗如智断惑。目能见空如智证理。既目无破暗之义日无见空之能。约义分之但有四对法喻。喻中意者。且如虚空无所不遍。一切色法亦满世间百千万人悉在其内。日光未出六合暝然。虽在空而不见空。虽对色而不见色。苟或日出昏暗尽除。眼目开明空色皆见。匪但空无边际身在其中。反思暗暝之时不曾暂出。法中亦尔。谓真如之理周遍十方。性上功德亦遍一切。众生无量悉在其中。以智慧未生唯是痴暗。虽在真内何曾见真。虽有性德不见性德。苟或智慧明发。惑暗尽除真性廓周自然明见。匪但性无边际身在性中。反思迷暗之时不曾暂离。故肇公云。道远乎哉。触事而真。圣远乎哉。体之则神。弥勒颂云。时及处实有为不得真如无智以住法余者有智。得对治法者即智慧也。以日目二种同喻此。故谓日是能治暗是所治。所治之暗既尽。能治日光现前。即能见其色等。法中惑智例此言也。故偈云。暗如愚无智。明者如有智。对法及对治。得灭法如是。赞德者。以显得真如为由心净。心净由不住法。不住法缘有智。有智盖由闻经。当知此经有其胜德。故须赞叹以示将来胜德之相。即下十段总标经意如文可知。所言以佛智慧知功德者。意言。除佛世尊余无知者。盖显功德之殊胜也。受持因者标也。为欲下释。欲受其文故先读。欲持其义故先诵。是故受持皆由读诵。故分因果也。受持等者。谓依总持法而受持修行。若文若义总能领纳方曰受持。此则思慧也。读诵等者。谓依闻慧广故。读诵修行。若无所闻凭何读诵。此闻慧也。论云。广多读习亦名闻慧。然皆言修行者。盖通相说也。非是三慧中修慧。以修慧与理相应。唯局无漏。出于读等四法之表故不配之。但约闻思二慧。共所成就故。疏次云。是则从他闻法等。故偈下引证。从他即闻慧也。及内即思慧也舍命福经意可知。以事等者。以前来已说命施。此中复说者。盖时事俱胜故。时即布施之时。事即布施之事。前但一度施一河沙身命时事皆小。今则无量劫中。日复三度以河沙身命布施时事皆大是。舍命福中胜福德也。信经福经意亦可知。不逆者是不谤义也。魏经如此。信经者。谓能所校量之中皆有胜劣。能中一河沙数为劣。三时多劫为胜。所中信。经为劣。持说为胜。前则以劣况胜。此则以胜况劣。前浅后深天地之远矣。余不测。经意云。若具足赞叹终不可穷。以实言之。有无边功德等也。非余等者。非二乘菩萨能尽知也。故前云以佛智慧而悉知故。又下文云。当知是经义不可思议。果报亦不可思议。佛尚如此余岂能知。自觉者。谓以心思口议但及名相之境。此非名相故不可思议。唯证相应故也。等及胜者两意。一则无有等此胜功德故。二则无有胜于此故。无有等于此故。故心经云。是无上咒是无等等咒。及即等义故。不别标也。大心说经意云。以非余者所知故。故为最上者说。一佛乘者。经中初标大乘名。恐滥于权教故复拣。云最上乘者。今疏中出最上乘体。故云一佛乘也。体当本觉故名为佛。非二非三故名一乘。故魏经云。为住第一大乘众生说。即当善吉所为机发无上菩提心者。能传经意云。若能宣说受持。此则修行二利。能令佛种不断。则名荷担菩提。满足无上界者。满足即成就义。界即因义。意明不可量等功德与无上菩提为因故也。荷担等者。在肩曰担。背负曰荷。今明行菩萨行即是荷担。谓以大悲下化。以大智上求。以大愿双运。安于精进肩上。从烦恼生死中出念念不住。直至菩提真性。自他一时解脱方舍此担。法炬经中。具有此说。今经云。受持读诵即自利。广为人说即利他。既若二利兼行。必以大愿为体。由是能令佛种不断。故名荷担菩提。乐小经征意云。云何唯为大乘者说。何故。持说名为荷担菩提。释意云。以乐小者着我等见不能持说。故知能持能说。是最上乘荷担菩提之者。问何者名为小法。谁为乐小之人。答四谛缘生名为小法。声闻缘觉即是乐小之人。滞情于中乃名为乐。彼有法执此显三空。是其非处故不能持说。故魏经云。若有我人等。见于此法门。能受持者无有是处。当知若能持说。即是乐大法者。不着我人等见也。问声闻缘觉以达我空。云何经中而言着我。答以我人等见是心心所法。着之即是法执故。指缘觉声闻也。或可乐小法者。即是声闻缘觉。着我见者即是一切凡夫。如塔经意云。经显法身依法则有报化。三身既存塔庙斯在。是故此处劝应供养。准纂灵记说。随朝益州新繁县王者村有书生。姓苟未详其名。于彼村东空中四面书之。村人谓曰书者何也。曰我书金刚般若经。曰何用焉。曰与诸天读之。时人见闻若存若亡。彼属霖雨流水滂霈。唯此地方丈余间。如堂阁下竟无沾湿。于是牧童每就避雨。时人虽在莫知所由。至武德初。有西僧至神貌颇异。于此作礼。村人谓曰。前无殿塔为何礼也。曰君是乡人耶。曰然。僧曰。君大无识此有金刚般若经。诸天置盖其上不绝供养。云何污践使其然乎。村人乃省苟生写经之处。自此遂甃甓严栏护之不令污践。苟至斋日每常供养。瞻礼者往往有闻天乐之声。迄今其处雨不能湿。且空书无迹尚乃如斯。况纸素分明而不能尔。转罪经意云。如过去造极恶合来世堕。三涂者。苟遇此经受持读诵。功力既着能消极恶。遂以现遭轻贱之事。更不堕于恶道。即是转重业令轻受也。持经无我等相。即烦恼障尽极恶消灭即业障尽。不堕即报障尽。三障既灭三德必圆。故云当得菩提也。总包等者。以打骂等事皆名轻贱故。隋译下引证。无著下转释。无量者。以身口意三所为之事但不饶益。皆属轻贱也。故云无量。罪灭者。罪障既尽渐渐修行。因圆果满自然为佛。经言。当得意显后时。非谓现世得成佛果。余转灭等义。已于悬谈五因中说竟。第八经疏二。初总叙意。速证等者。意明持说此经。速证菩提之法。所以超过如来事多世尊之福。故偈云。福不至菩提。二能至菩提也。二别科释经二。初中全具福经意可见。然灯前者以释迦因地修行经三无数劫。第一劫满遇宝髻如来。第二劫满遇然灯如来。第三劫满遇胜观如来。今云。然灯前者。即第二劫中也。那由他者。第九数数当万万。少分福经意。对前比量可解。然所不及者有二义。一彼得福德。此得菩提故。二彼有我相。此无我相故。故前云。此人无我人相等也。则疑经意云。前虽校量亦未具说。若具说者人必狐疑。狐者狡兽也。以多疑故。故云狐疑。述征记云。风劲河冰始合。要须狐行。以此物善听。听冰下水无流声。即过也。魏经即但云疑惑。幽邃经意云。校量不及佛不具说者。以此经义及持者果报皆不可心思言议故也。福体者经义也。为福所依故。果体者佛菩提也。测量即思议也。以福田佛果皆无相故。然科云总结幽邃准疏所。判但局第十疑。中今若详之兼该三七之。二以始自第三乃至。第十逦迤次第五度校量。谓外财两度内财两度佛因一度。且第一以□三千界七宝布施校量不及持说。第二以无量三千界宝施校量不及。第三以一河沙数身命布施校量不及。第四以无量河沙数身命布施校量不及。第五以如来因地供养诸佛功德校量不及。至此第五是校量之极。更无譬喻可以比况。故云乃至算数譬喻所不能及。苟或具说人必生疑。故复云我若具说者。或有人闻心则狂乱狐疑不信。自此之后赞校都绝所以望前数段。故总结云。当知是经义不可思议等也。问此至经末犹有数处校量。云何辄言无校量耶。答余所校量。但是别意以之断疑。实非前说五重次第也。由是随时略举一三千界宝。或须弥聚宝。或阿僧祇界宝。以为校量。若不然者。岂得胜义之后。却举劣福为次第耶。第十一疏初标章。佛教下指疑起处。住修下即正答三问。及次前十段也。若无下结成疑。既教我住修离过。岂是无我无人。若言无我谁住修离过耶。亦云下叙别义。除细执者。即是第二疑中未除之者。故今举之令其除断。问执与疑何别耶。答执则坚着疑乃不决。若据论意正是除执不言断疑。今疏云断疑者。若言除执文势孤起血脉不贯。故依诸疏以立此疑。偈云下引证除。执道之与心盖是一法。但以心本无我而执我。道本不住而成住。故立障心违道也。然此疑执之文。若详经义别分。则从尔时须菩提。至即非菩萨是断疑。后之一段是除执也。故论中释已遍指后文。问经文虽似前问意全别。意云。若人发心则无有我。是谁降伏其心。反覆如上所说。必无我。经意云。若人发菩提心已。当生度尽一切众生之心。然不得起。有众生可度之念。亦不可起我能度之念。念既不起即无我。无我即名菩萨也。非菩萨经征意云。以何义故。度众生令不起众生之念耶。释意云。若有我相众生相等。非菩萨故。前约所度之境。此约能度之心。心境合论通名为我。既前后互举。则显能所皆无也。俱寂经征意云。前无所化之境。次无能化之心。所以要无能所者。何谓也。释意云。以能所俱十方是菩萨故。法之一字能所俱摄。第十二疏初标意。若无菩萨者。指疑起处。即从次前文中来也。以前云无发心者。发心者即是菩萨故。云何下结成疑也。然灯。即是释迦因地。第二劫满所遇之佛。既于彼处行菩萨行。云何乃言无发心者。举疑处经意云。汝意之中颇谓我于然灯佛所得菩提不。若得菩提何成菩萨。是彼疑处故举问之。降怨下叙其本事。准本行经说。昔有大城。名为莲华。城中有王。名曰降怨。有一婆罗门。名曰日主。为王所重分与半国封授为王。别为王城。名为埏主。日主夫人。名为月上。然灯菩萨降神右胁出家成道。时降怨王将欲迎请。遂敕城内外十二由旬。禁断诸华不令私卖。王皆自买以供如来。彼国雪山南面有一梵志。名曰珍宝。有五百弟子。中有一弟子。名之云童。或名善慧。于彼众中而为上首。所有仙法皆学已了辞师还家。师曰。汝今将归。须以清净伞盖革屣金杖乃至金钱五百报感之恩。云童曰。我今并无此物。但放我去得即送来。师即放之。云童因赴无遮之会。得五百金钱。便欲送还师处。因至莲华城内。见城严丽即问于人。乃知然灯如来欲至。遂将三百金钱。于一婢子处。买得五枝优钵罗华。兼彼女子寄华两枝共为供养。时佛入城即以此华散佛顶上。以愿力故。成于华盖随佛行住。佛神力故化一方泥。善慧见之布发而掩。复作是念。愿得如来踏我身过。若不蒙记莂我终不起。如来即至履之而过。止诸徒众皆不令踏。即授其记作如是言。此摩那婆于未来世当得作佛。号释迦牟尼。十号具足如我无异。今善吉意云。既若买华供佛布发掩泥即是菩萨。若此非菩萨者。则孰为菩萨欤。断疑念经答意云。我意不谓如来得菩提也。我已解佛所说之义。于彼佛所无有一法得为菩提。彼时者。莲华城中授记之时也。智与理冥心与神会。亡所得之法无能得之心。故云都无等。由无等者。即指上无得而得。夫菩提之为法者。寂灭无生不空不有离一切相。若离能所则顺菩提得佛授记。若存能所心境不亡。则与菩提极相违逆。如何得记。故净名云。寂灭是菩提。灭诸相故。印决定经意云。空生之言称其实理。故云如是。实无下。如来述成可知。我于彼时者。即受记及修行时也。无有一法得菩提者。此约横竖显之。横则于六度万行之中。行行皆无得义。若布施得菩提。则不要戒忍等。竖则初中后念。念念皆无得义。若初念得。何须念念相续等。如是横竖心行之中。皆无得菩提义也。功德施下未详何经。若见等者。以自他之相相待而成。既见于他必须见自。见身清净等者。反于前也。清净即是空义。见他既见于自。不见自则不见他。成既相因而成。泯亦相因而灭。如净名云。如自观身实相。观佛亦然。亦如志公云。以我身空诸法空。千品万类悉皆同。亦同庄子中说。因有而有之。因无而无之也。见清净智等者。非唯无所见之自他。兼无能见之智用。斯则能所双泯也。圆觉经云。依幻说觉亦名为幻。既皆是幻岂得存焉。然虽能所两亡不成断灭。以灵源真心本无能所。妄生能所即是乖真。能所既除即合本体。灵然不昧物我皆如。故华严云。能见及所见。见者悉除遣。不坏于真见。是名真见者。又圆觉云。诸幻尽灭觉心不动。是名见佛者。结成见义。如上用心方得见佛。若生分别执相违真则不名见。故华严云。一切法不生。一切法不灭。若能如是解。诸佛常现前。得无生忍等者。谓以正智忍可。印持无生法故。以一切法本无生灭。众生迷倒妄见生灭。苟离妄见正智即生契合本体。达一切法本来无生。名无生忍。例而言之。见一切法无灭。亦名无灭忍。今则举初以摄后也一切智智者。是达一切诸法之智。表用非一故重言耳。有云。依于始觉显得本觉。智中之智名智智也。得授记者。准楞严经记。有四种一未发心时。与记。或有流转五道生于人间好乐佛法。过百千万亿劫当发心。过百千万亿劫。行菩萨道供佛化生。皆若干劫当得菩提。二适发心与记者。是人久劫种诸善根。好乐大法有慈悲心。即住不退地故。发心与记。三密记者。有菩萨未得记。而行六度功德满足。天龙八部皆作是念。此菩萨几时当得菩提。劫国弟子众数如何。佛断此疑即与授记。举众皆知此菩萨独不知。四无生忍记者。于大众中显露与记也。今当第四也。谓散华佛顶布发泥中。依有漏心得无生智。于大众前分明记一刻也。声不至耳者。能所俱寂以离分别心故。心既不起耳何所闻。亦非余者。此无分别处。非谓别有一智能智。圆觉云。离远离幻亦复远离。亦非惛懞等者。恐闻都无分别亦非余智。便谓同于木石一向顽凝。故圆觉云。诸幻尽灭觉心不动。然即此觉心亦无所得。故颂云。若时于所缘。智都无所得等。此则离沈离掉了然寂然。妙契本心竟何所得。善慧彼时心同此也。反覆释经意可知矣。若正觉下释反释也。以法不可下释覆释也。据此则善慧彼日但闻其言。言性本空竟何有得。但约妄惑尽处真智现前当此之时义言得矣第十三疏二。一科分。此初二段皆属前疑。但是于中相蹑曲叙。今以论文别说故复开之二。初断下随释。疏初标章。无佛疑者。若了虚无之无。无即无咎。执之为无。无则太伤。故成此疑。后法亦然也。若无菩提者。指疑起处。此从十二中来。诸疏叙疑多书菩萨字。便云。从第十一中来。然论文之中但云菩提。方是血脉相次。即无下结成疑也。意云。果法号曰菩提。证得始名为佛。既菩提不可得。岂有能证人。谤者即损减过也。若言无佛是真谤佛也。大论云。宁起有见不起无见等。为断下预指断疑之文。然是魏本。彼文云。如来者即实真如。非无经征意云。若无菩提则无有佛。以何义故。得有如来。释意云。若无真如则无有佛也。以真如是佛故。今真如本有复何疑焉。无著下挟来义解。以真如通于凡圣。众生垢染但名如去。佛位清净名曰如来。如序中满净义及第三疑中具足清净义也。犹如下喻明也。意显精纯故名真金。谓众生如全矿。菩萨如金矿相半。佛如纯金也。然金性本有炼之则纯。如体本然修之则净。故圆觉云。譬如销金矿。金非销故有。虽复本来金。终以销成就。一成真金体。不复重为矿。无得经意者。恐人闻非无如来。便言既有如来即有菩提。何者以得菩提。方名如来故。为破此见故云。有人言。得实无得也。无有法即菩提法也。错解者。实不得而谓得故也。不实语者即错解也。等菩萨行者。谓将前菩萨行以等菩提。即指同前来万一之中皆无得菩提义也。但空生疑得故。以佛等菩提。佛显无得故。以菩提等行。无著下可解。夫佛与菩提义分人法。体无二源。由是唐言总名为觉。既佛即菩提。菩提即佛。岂有得义。应知说菩提树下成正觉时同彼然灯佛处。亦无所得也。疏二断下二疏初标章。无因行者指疑起处。此从无佛中来。以前将行等菩提明无得义故。则如来下结成疑也。意云。行即是因菩提是果。既无因行何得菩提。或不约能得所得以成疑也。前来断疑则以菩提等行。如今起疑却以行等菩提。为断下。预指能断之文。遮疑经意者。以空生前疑得菩提。是有执此疑不得菩提是无执。今则双遣故。云无实无虚。二执既遣复何疑无耶。故云遮也。无色等相者。释无实也。即显菩提无色声等相。然则但无实色等相。而不无于假相。故经但言无实。不言全无也。彼即菩提者。释无虚也。此有三意。一者无色等相处。即显无相真理是菩提相也。二者即以色等相为菩提相。由色等无性便是菩提。如像无体便是明镜。即色明空不待灭故。故云彼即菩提相。相即性也。三者菩提无相。却以色等为相。以菩提即真如真如随缘成色等故。论云。无漏无明。皆同真如性相。无著下标。真如无二者。以虚实是空有断常二边。既言俱无即显中道也。谓言下释无实也。如言菩提。而言中无菩提故。谓彼下释无虚也。有两意。一则无离文字说解脱故。二则明菩提不同言说全无性故。故魏经云不实不妄语。断疑经意云。以一切法并以真如为体一切之言。凡圣收尽故皆佛法。真如既是佛法。余法岂非佛法耶。如一切像以镜为体故。故一切像皆是镜像。又所言一切法非定实。一切法是全空一切法。一切法下义如上说。由色等者。谓色等即空故非色等。如像即镜故非像等。斯约诸法即真显非法真如等者。谓空中必无色也。以弥满清净中不容他故此约真中无法解非法也。备斯二义故曰即非。是名下。以彼色等虽非质阂之一切乃是即性之一切。今约此义故曰真如。拣异色等无性故云自性也。真佛法经意。以前说佛之与法二皆不无。又佛之与法二皆不异。未知何者是佛法真体。而言不无不异耶。故此显有真如是真佛法。以彰不无不异之义也。依彼下两句标也。离一切障者。离烦恼所知二障。遍一切境者。如华严云。法性遍在一切处等。功德即相大。即大智慧光明遍照法界等。大体即体大功德所依也。故即等者。功德及体皆广大故。此上解佛大身。非身下两句论文自释。无诸相者。无有为相也如前三相异体故。有真如体者。有无为法也。如前离彼是如来。摄一切等者。据理融摄也。华严云。一切众生及国土三世。悉在无有余。故名大身。安立等者。真如之理本非自他非不自他。为破众生执自他故。故言非自他。形对强言故云安立。斯则安立真如假名。名曰大身。既摄一切则无自他也。故起信云。此真如体亦不可立。以一切法皆同如故

金刚经纂要刊定记卷第五金刚经纂要刊定记卷第六

        长水沙门子璇录

第十四疏初标章。若无菩萨者指疑起处。此同第十二于十一中来。但起则同时断则次第也。诸佛下顺他以立理也。既无菩萨即无此事。无佛不成菩提。即是生不入涅槃。但约凡圣分于因果故。下结疑之处则合而言之。何故下结成疑也。意云。若无菩萨则度生严土之者是何人哉。失念经意可知。但亦如是言。是蹑起疑处之文非次前文也。偈云下兼释后段严土之义。以文意钩锁故联而引之也。初句标。次二句释。后一句结。意云。真界平等拟心即差。既生其心岂非颠倒。经中作如是言即生心也。是意言故。无人经征意云。何故作是念便不名菩萨。释意云。但约无我无人真如清净名为菩萨非谓别有一法故。下文云。若作是念则不名菩萨也。疏文可知。前说经意云。以是义故。佛常宣说一切诸法。皆无我人等相。然一切诸法本无我人。但违之则是众生。顺之则是菩萨。失念经意准前可知。释所以经征意。同前释云。如来说庄严佛土者。非有能严所严。则严与不严等无有二是真严也。今既异此故非菩萨。释成菩萨。经意可知。论云下通释前段。以偈文通标在前。论文通释于后。前后相望理则昭然起何下约论征也。故经下引经释也。无著下可知。问此与第六皆言严土义何别耶。答前则对无取疑有取。此则对无人疑有人。然此与第十二皆从十一中起。以彼文云无发菩提心者。佛意但是拂于我人之心。不是泯于菩萨。空生不达此意。将谓我人与菩萨不异。由是空生起疑之处。则云若无菩萨。如来断疑之处则言无人。彼此媕含未尝显说。直至此处方乃[泳-永+史]通。经文特言通达无我法者。如来说名真是菩萨。第十五疏初标章。前说菩萨下指疑起处。此从十四中来。以前云我度众生我严佛土。皆非菩萨。斯则不见自他之义。若通而言之。亦兼从正答问及第十一疑中来也。若如是下结成疑也。以闻不见自他等相。便谓如来都无智眼。故成疑也。疏断之下。二引论彰意。偈云下先述断疑意也。初句纵。次句夺。第三句明能见五眼。体常故言实也。末句明所见诸心体妄故云颠倒。然若干种心是智所知境。今配为所见境者。以如来知见无二体故。约眼为见在心曰知。故十八住中合为一住处也。断疑意云。菩萨但离能所分别故云不见。诸佛岂无真实智眼。此显正断其疑。下但随文科释。疏文五。下三依经断疑。肉眼经问答文意可知。肉团等者。谓四尘名肉。清净眼根依肉而住名为肉眼。如楞严云。眼如葡萄朵。耳如新卷叶。鼻如双垂瓜。舌如初偃月。身如腰鼓颡。意如幽室见。清净眼根依此发也。障内下约所见分齐以结名也。依肉之眼名为肉眼。佛具下或问曰。佛为至圣。何以同凡有肉眼耶。故此通之。然但约具诸根处说有肉眼。非谓如来是血肉身。故经云。舍无常色获常色等。肉眼边等者。谓作观行依肉眼处想外境界。观想成故见障外事名为天眼。如阿那律等。大般若下。克就佛说前但约名通解。故云障外。今约佛位而言。故云人中无数等。除见天下结成分齐。亦显二眼体同。以佛眼体是一而有五用故。根本者能生后得故。亦名正体智。真智如理智以能照真。故名慧眼也。后得者。从根本后方得起故。亦名遍智俗智如量智。由能达俗故名法眼也。问据前一二先浅后深。云何三四先深后浅。答前约眼之次第。此约证之次第。以达俗由证真故。说为后得也。疏于内文二。初局释当文。前四等者佛有此眼。故云佛眼。以前二眼通凡夫二乘无法眼。菩萨虽具且劣。若在于佛四皆殊胜。总名佛眼。是则佛眼之外无别四眼也。其犹四河归海失本名耳。四皆胜者。谓凡夫肉眼见障内天眼见障外。佛眼见无数世界。二乘天眼唯见一三千界。佛天眼见河沙佛土。二乘慧眼唯照生空。地上菩萨亦皆分证。佛之慧眼圆照三空洞彻真性。菩萨法眼所知未尽。地地之中各有分限。佛之法眼所知障尽。无法不知无生不度。故四皆胜也。又见下以所见是佛性。此眼能见故。如涅槃云。声闻定多慧少不见佛性。菩萨慧多定少。虽见佛性犹不明了。诸佛如来定慧等故了了见性。如观掌中庵摩勒果。斯不亦圆极之义乎。问菩萨声闻定慧互阙。于其佛性则何以声闻不见。菩萨分见耶。答以定慧望于佛性。慧是因定是缘。因亲缘疏故使然也。又声闻但有偏空慧无中道慧。故云慧少。菩萨有中慧故见佛性也。又此五中唯第三持业释。余皆依主释也。无著下二通前总显二。初引无著义总释。净胜者非颠倒故。超诸圣故。四种者举所以摄能明于分齐。如以六境摄六识。色摄即肉天二眼。论云。色摄有二。一法果二修界。法即肉眼。以从过去业法之所感故。修即天眼。谓是定果修所得故。二眼同见色法。色法最粗故先明也。第一义即真谛境。摄慧眼也。世谛即俗谛境。摄法眼也。一切种者。一切种种差别境也。一切摄者摄佛眼也。即无所不了是一切种智故。论云。一切种无功用智名为佛眼。古德下二约古德重结可知。智净中五段从狭至宽。展转而数谓数沙数河数界数生数心。欲明如来之智微妙能知。故约所知之境广多以显。经皆可见标悉知经文可知。共欲者染也。欲谓五欲即色等五尘。心与欲合故名为共。又欲谓贪欲是心所摄举初该后。意兼嗔等心与贪等相应。故云共也。前约与境相应。此约与烦恼相应。皆为染也。离欲者净也。即不与六尘境烦恼相应名之为净。染净之心各有无量故曰若干也。释悉知经征意云。以何义故。能悉知之。释意云。彼等诸心皆是妄识。妄识即空故云非心。以即空故。真心不灭故云是名真心。体同故能悉知。大云下释出能知所以也。以诸心是真心中所现少分之法。今证真体岂不能知。诸心下牒释可知。与此殊者。以云说兼真论言唯妄。故不同也。论释为正。若以科疏观之。却以云释为正也。请详种种颠倒识者。释经中诸心也。魏本云。如来说诸心住。皆为非心住。是名为心住。论释意云。诸即种种住谓颠倒。以八识皆能缘境有取着故。或约前六名为种种。缘粗显境相续不断。故名为住。以离等两句。释皆为非心住也。离与不住盖是一义。智与实念亦无别体。意明不住大乘四念处故。若住于此即是实念实智。既住六尘即颠倒识也。是故说颠倒者。释是名为心。此但结归颠倒识也。释非心经征意云。所以说诸心为颠倒识无体者。何谓也。释意云。以于过现未来求不得故。已灭下。释三世不可得所以也。论文净名华严并同。但释现在有少异耳。论云。现在虚妄分别故。净名云现在不住。华严云。现在空寂然。文异而意不异也。然此独于现在之中。言第一义者。以无著释经皆约二谛。既五眼文中不言眼即非眼。又以见智二种其体不殊故。于最后安立第一义。第一义即是空寂。空寂即是不可得义。意皆同也。第十六疏初标章。向说下指疑起处。此从第十五中来。心住者。指魏经如上所引。颠倒者指偈文。皆不可得者指经文。若如是下结成疑也。意云。众生心是颠倒。福德依心而成。岂非颠倒。颠倒既同何名善法。既非善法修福何益。问答福经可知。以是下释多所以。以如来举因缘以问。空生牒因缘以答。因缘无性福亦无性。乃成无漏是故多也。此文但标下文即释。反顺释经意云。若是住相之福我不说多。以是无住之福。是故说多也。疏一初引论正释。偈云下标也。论云下释也。意云心识住故。故成颠倒。颠倒故福皆虚妄。佛智无住依之作福。即非颠倒。非颠倒故皆真实也。取相者。是有漏福故不说多。离相者。是无漏福故说多也。问福下二问答解妨。问意可知。违顺等者。谓一法界心本来无住。本来空寂佛智空而无住故言顺。妄识住而不空故言违。所言不空但妄识。不空非真实不空也。苟忘怀而达之。则无所不喻也。第十七疏初标章。若诸佛下指疑起处。此从第三中来。云何下结成疑也。此约下出疑所依。意云。既言无相法身是佛。何以成就相好亦名为佛。此约法身疑色身也。现身经问答可知。征意云。以何义故。不以色身见佛。释意云。以约胜义非世谛故。由此不应定以色身见于佛也。随形好者八十种也。法数如常即小相也。随其身形一一皆好。故八十好即色身。镜中下喻明也。故知镜中有物却不能现物。如凡夫虽有法身不能现相好者。盖缘有物。所言物者妄身心也。论云下约性相拣收也。毕竟等者约体拣。然相好下随相收也。此二下释相好为佛之由。如金毕竟非师子。亦非无金。以师子不离于金故。是故下约存泯会释经文。言无者约体而说。释即非色身。言有者随相而说。释是名色身。成就者魏经即是今文具足义。现相经如前。三十二相者法数如常。即大相也。一一等者。前从镜中无物已下。义意并同前文已明。今不别释也。第十八疏初标章。若如来下指疑起处。此与前疑同时。于第三中起。起则同时断成先后。非从次前文来。若言从彼来者。已悟非身之身。何疑无说之说。思之可见。云何不结成疑也。意云声不自声依色而发。既无所依之色。何有能依之声。故成疑也。遮错解经文可知。谷中下喻明也。意云。以有外声遂有响答。谷中实无作响之者。说法亦尔。法身实无能说之者。以机感故。遂见如来有所说法。又谷虽应声而无应声之念。佛虽说法而无说法之心。据此却由无念故。方能说法。是故遮云勿谓等也。释所以经征意云。以何义故令我不作是念。释意可知。世尊下疏如文可解。示正见经意如疏。如佛法亦然者。佛既无身故现身。法亦无说故强说。以佛例法故曰亦然。二差别者。论云。一者能诠名句文也。二者所诠义也。此能所诠若望于佛。俱是所说通名法也。不离等者。论云释是名说法。法相之界故名法界。说法无自相者。论云释无法可说谓相即性故。言说缘生无自性故。又解。不离法界下二句。俱是释无法可说。谓此二种不离法界。法界之外无别二法自相可得。以此二法自相本空不可得故。此即以下句释上句也。真说等者。夫为说法当如法说。名真说法。法离一切名相分别。若称此说是如法说故。下文云。云何为人演说。不取于相如如不动。然第三第五第七。及此四处皆明无说者。意各不同。以第三疑化身有说。第五疑证智可说。第七明佛无异说。此文疑无身何说。以此为异。然诸疏于十八九之间。约魏本经文皆出一疑。龙外皆云。何人能信疑。云云。能信深法疑。今秦经既无其文。疏亦不叙而解。今见近本。秦文皆有此段。乃于抄中略要叙释。名为所说。既深无信疑。论云。若言诸佛说法者。是无所说无说不离法身。法身无相。有何等人能信如是甚深法界。断之经云。尔时慧命须菩提白佛言。世尊颇有众生。于未来世闻说是法生信心不。此疑甚深无信以问也。解空第一智慧圆通。以慧为命故称慧命。生信心者。生大乘正信心也。不信一切法方为正信。此信与圣性相应。故起信云。如是信心成就得发心者。入正定聚毕竟不退。名住如来种中正因相应。次拣圣性有人以酬。佛言须菩提。彼非众生非不众生。须菩提下合云实有众生。能信此法彼能信者。非是凡夫众生。非不是圣性众生也。论云。非众生者非凡夫体故。非不众生者。以有圣体故。非不是圣体众生。偈云。非众生众生非圣非不圣。此中圣体者佛之知见也。以是信之根本故。次征是非生信。以释。经云何以故。须菩提众生众生者。如来说非众生是名众生。何以故者征也。以何义故。说非众生又名众生耶。须菩提众生众生者此牒也。于非众生中说为众生者。如来说非众生。是名众生。非众生者非愚小异生也。是名众生者结成能信之人有圣体也。偈云。所说说者深。非无能信者。此上经文魏译则有。秦本则无。既二论皆释此文。后人添入亦无所失。况有冥报之缘。宜亦可信。第十九疏初标章。不得一法者指疑起处。此从第三第十二第十三中来。以彼文中皆言无法得菩提故。云何下结成疑也。离上上者。如初地并于地前名上。未离二地之上。乃至等觉。亦未免于妙觉之上。唯佛极证。更无上位之上。故云离上上。是则凡夫离下下。诸佛离上上。余之中流不离上下。转转等者。谓转舍二障转得二果。转舍转得故云转转。意云。既若转得菩提。云何不得一法故成疑也。为断下预指断疑之意也。指示显现故云示现。无法为正觉经纵问。无得是得并可知矣。彼处等者。此明无有一法可名为上。如须弥至大微尘至小。尽未免于上以皆有故。如虚空无故得名无上也。菩提处者。菩提即所证处也。无一法等者。但妄尽觉满名曰菩提。离此宁有菩提可得。平等为正觉经亦可知。不增减者。即释经中无有高下。谓在圣不增故无高。居凡不减故无下。斯则平等之义也。平等名无上者。夫上以待下得名。下既不立上岂存焉。更无下转释无上义。然此问答之中有三种无上义。初问中言无上。头之上约修证说。次则无法为上故名无上。约空寂说。后则无对下之上故名无上。约凡圣同体说。后二是答中意也。修正觉经意云。然虽无法然虽平等。非谓不修得成正觉。应以无我等心修诸善法。然后得成。然此善法约胜义则无。约世谛则有。天亲异此详之。了因者了有二义。一了断义。以般若能了烦恼空故。二显了义。能显法身故。今无我等即是此义。亦名正因。正由此慧除妄得法身。故今云正道。道即因义。缘因者。即施戒等五。与彼般若为资缘故。助即资也。资彼正因之力。断烦恼成菩提也。犹灯能破暗。显空必籍心油为助缘也。是正觉者。以梵语三菩提此云正觉。即所证之果无漏善者。问有漏之中亦有善法。何故偏局无漏耶。答以无我等相所修故。唯无漏也。又以有漏之善非菩提因。今为菩提故须无漏。问上三段中前二无得。后一有证。义既矛盾云何两存。答所言修者。但是断除我法。显自真理竟无一法可得。由此二义宛相符顺。问第三第十二第十三。兼此一段前后四处。皆说不得菩提。如何辨异耶。答前后文虽相似义意不同。以第三疑释迦得果。第十二疑善慧成因。十三疑无法无佛。十九疑有修有证。兹义迢然。请无所滥。第二十疏初标章。若修下指疑起处。此从十九中来。则所说下形对前之数段。结成疑也意云。既言修一切善法得菩提。云何前来频言持说得菩提耶。以是下成立持说不得菩提之理。以名句文三无记性摄。无记性法中无因果故。岂感菩提耶。经之比校如文可知。虽言等者许为无记也。而说等者不许非因也。是故下出经意。能为佛因故胜。宝施论云下。转释为因之由。以经诠真理因之悟解。依解起行方得菩提。若无教门要知所入。故法华云。以佛教门出三界苦。又言下论之别意。汝法无记。谓小乘萨婆多宗说声通善恶。名句文身唯无记性。我法是记者。谓大乘宗地上菩萨。于后得智中所变名等。唯是善性非无记性。是故等者。意云。只就无记尚得为因。况是无漏善性所摄。而不得菩提耶。问此与第九疑何别。答彼约有为无体难。此约无记非因难。又彼唯据持说难。此则兼对善法难。迢然不同也。第二十一疏初标章。若法下指疑起处。此从十九中来。云何下结成疑也。既度众生即有高下。高下即不平等故成疑也。错解经文初正遮。二再诫可知。正见经征意云。以何义故令不作是念。释意云以实无众生为如来所度故。平等下两句立其义。宗以名下两句释其所以。论云下转释后二句也。假名者但有众生之名。而无众生之体故云假也。与五阴共者。谓于五蕴和合之处。说言众生不即不离故云共也。不离法界者。佛是极证之人。已全是法界。众生虽未能证缘生无体。亦同法界。岂将法界度于法界。是故偈云平等等也。所以经文反显。若顺言之。应云以佛无我人等相故。不见有众生为所度也。取相过等者。以无谓有故不如法界故。不了缘生故。便成有念故。尔炎梵语。此有两义。一谓智母。已如前说。二谓境界。然是定中境界。今取此义。意云。佛智称境而知。真如是有作有知。众生是无作无知也。若作智母释者。即根本智证平等理。无有分别。今观众生亦复如是也。拂迹经意云。佛虽说我元来无我。执有我者盖是凡夫。虽言凡夫亦无凡夫。如梦人见虎。虎与梦人皆不可得。法中亦尔。以凡夫人执我故云非我。恐执凡夫故云非凡。夫逦迤除遣执情。故云展转拂迹。然前正答问中。及第十一十四。兼此一段前后四处。皆说度生无度。虽文同而意异。谓最初令离我度生。十一疑能度者是我。十四疑无我而谁度。二十一疑真界平等不合度生。同异昭然。第二十二疏初标章。论云下指疑起处。此从十七中来。虽相等者。以前文云即非具足色身。即非诸相具足。具足即成就义。秦魏经异也。而以等者。以前文云是名具足色身。是名诸相具足。彼中意者。法身毕竟非相好。相好亦非不佛。由无相故现相不离法身。所以疑云。既无相故方能现相。则但见于相。便知无相也。如远见烟定知有火。以离于火必无烟故。表佛经问意云。可以相比观无相法身如来不。识根经答意云。实可以相比观法身如来。悟色身者知应化非真义也。迷法身者。不知法身毕竟非色相。义意谓下出答意也。意云。但见法身之相好。则知相好之法身。如见草木之苗必知其根。由是科文约喻而立。凡圣不分经意云。轮王亦有此相应是如来。偈云等者。意云。但约本望末则定。若约末望本则不定。且如轮王与佛色相虽同。相之所依二各有异。佛相即法身所现。王相依业因而生。凡圣云泥复何准的况依法身有自他受用。复有大小随类化等。各各不同。如苗与根事亦不定。初栽之树则有苗无根。所接之树则苗根各异故也。佛非相见经意云。缘闻依真现假假不离真。及乎约假求真。真不由假实德不在相令色鲜矣。仁以貌取者失之子羽。而今以后焉敢不识。见闻不及经文可见。然恐空生更约说法比知如来。故言音声求之不得。此疑即从第十八中来。今预遮防故无后说。魏偈者明见闻不及之由也。秦经则但明见闻不及。偈云等者弥勒偈也。于中半释秦偈半释魏偈。意云。见闻是识但能缘于色声。佛非色声故不可知。彼法者法身也真如相者即离一切相。是真如相。非如言说知者。以真如法离言说故。但是真智之境唯证相应。故云自证。第一第七第十七及此一段。皆云不以相见如来者。义意皆别。初以对果疑因。次明感果离相。次说依真现假。后明约假求真。故不同也。第二十三疏初标章。由前下指疑起处。此从二十二中来。遂作念下作一向离相解。便是指起疑之宗也。若尔下结成疑也。意云。福但成相果。相既非佛修福何益。故佛果下结成疑名也。论云下引证。失福者非菩提因故。失果者非菩提果故。遮念经意云。汝若谓如来不以具足相故得菩提。莫作是念。文势似重意实不重。但前叙后遮也。华严偈中前半属前文。后半属此段。以文意钩锁故。就一处而引。既言不离色声。岂合一向毁相。毁相非理故此遮之肇云下。亦前后相半耳。不偏等者相不定故。如轮王非佛。非不等者。应机即现不离法身故。如释迦是佛。断灭见者。义在次文。出过经文可知。损减等者谓执有是增益过。执无是损减过。今既一向离相正当此句。斯则于果损福德庄严。于因损五度之行。坏俗谛也。断见者。中论云定有则着常。定无则着断。今既一向作无相解。正当断见。边见者空有断常皆是着边邪之见。并非正见故云过也。不失经微意云。以何义故今不作此念。释意云。但发菩提心者皆不作此念故知作此念者岂非过欤。如所住法者。所住之法即大菩提心菩提心者即悲智愿也

金刚经纂要刊定记卷第六金刚经纂要刊定记卷第七

        长水沙门子璇录

一切菩萨皆安住此心。行菩萨行。有大智故不住生死。有大悲故不住涅槃。今令离于断常二见。即是不住生死涅槃。故云如所住法。即七最胜中依止最胜。不断等者。意云。生死本空犹如影像。影像不有复何断焉。今言不断者。非谓固留但了性不有了相不无。随顺俗谛故云不断。此即通达之义。于涅槃等者。若被寂所缚即不自在。今寂而常用用而常寂。是自在义。此中下显偏说之意。然据不断生死利益众生。但成大悲不住涅槃。如其具论。亦须不住。生死方成如所住法。一向下即出偏说之意。遮寂者。即二乘人灰身灭智拨丧无余。被涅槃所拘是不自在。今以不具相发心。正堕于此。为对治故偏示一门。下文菩萨不受福德。即不住生死。义则圆矣。偈云下引证。论云下释偈。虽不依下纵也。法身真佛是真菩提。正由智了为因故不依彼。而不失下夺也。福德是因即五度果。报是果即三十二相相非不佛。故言不失。既不失果即不失因。以能下明不失之由。谓真菩提必须具足二庄严故。智慧即真身。福德即应身。故论云。法身者智相身。福相者异相身。以诸如来皆合具此二种相故。故法华云。如其所德法。定慧力庄严。以此度众生。自证无上道。得忍经意云。菩萨于无我心中所修福德。胜彼有我心中所修福德。以庄严法身究竟不失故。论云下先叙所遣之念。念云若出世无分别智。正是佛因。即所修福德尽皆失也。何以故。福非因故。为遮此故者。引起能遣之文。得胜忍不失者。正明不失义。谓若心住相修诸福德。堕于有漏。此福则失。若心离相修诸福德成于无漏。此福不失也。以得下出不失之由。斯则　果验因成不失义。无垢即清净。无漏是佛身矣。二无我者人法也。得此二空之智名之为忍。正明经意云。前言无我所修之福以为胜者。只由菩萨不受福故。可诃等者。明不受之由。亦是以果验因成不受义。意云。果若有漏则知受福。是可诃责。果既无漏则知不受。云何可诃。无著下显对前文不住涅槃。前后相望共成。悲智之义耳。若住等者反明也。征释经意云。菩萨作福。若生贪着则成有漏。因既有漏果亦有漏。得三十二相但同轮王。不名为佛。此则因果俱失成其所疑。今既作福不生贪着。则因成无漏。因既无漏果亦复然所得三十二相庄严法身。名之为佛。云何疑其失因及果。第二十四疏初标章。若诸菩萨下指疑起处。即从次前文来。论中即云。若菩萨不受彼果报等。云何下结成疑也。众生用者。据佛寿量合满百年。至八十便入涅槃。意留二十年福。与后代弟子受用。又于佛供养承事。能令众生获福无量。斯亦佛福众生受用也。问前云菩萨不受。今何难佛受用。又前言受是取义。今疑受是用义。文义既异何以成疑。答此皆以果验因也。因中若不受取。果中焉合受用。果中尚自受用。因中岂无受取耶。错解经意云。若人言如来出现来入灭去住世间。皆不解我所说义。是福等者。是彼无漏福德之应报。即无垢果也。果中无有色相故。论云。佛果无有色相迭相见故。又论云。佛果无别色声唯如如又如如智独存故无来去等。为化下或问曰。既佛果无别色声来去等。何以出现受福。为众生受用耶。故此释之意。说众生根熟为能感缘。以佛无缘大悲。无量劫来利他善根熏净法界以成善习。有感即应任运无心。如一月不下降百水不上升。慈善根力法尔如是。正是断疑之意。若果中有心受用。则因中亦有心受取果中既是自然。因中足明无著也。正见经征意云。以何义故名为如来。既名为来亦表其去。何言错解。释意云。以真佛本来无来去故。偈云下标真化异也。如来即是法身。本来不动犹若虚空。故不同化身随机来去。此非异而异也。大云下释此约机。心染净遂见佛有来去。名为化身。来无所从去无所至。即是不动名为法身。斯则机见有佛来去。佛实不动云云。自彼于我何为。此中略举水喻。众生心则知。月喻法身影喻化。体清浊喻染净也。水清月现月亦不来。水浊月隐亦非月去。但是水有清浊。非谓月有升沉。法中亦尔。心净见佛非是佛来。心垢不见亦非佛去。但是众生垢净。非谓诸佛隐显。解极等者。谓解极则心绝。心绝则会如如体本周故无方所。此明即应之真。缘至下明即真之应也。意同大云。隐显断疑意者。诸佛本无来去。众生妄见去来。尚无出现之佛。宁有受福之事。第二十五论文于此不别叙疑而义意合有也。初标章据前下指疑起处。此从三处来。不可以化等者第二十二也。滥于轮王故。法身无来去等者二十四也。斥为错解故。据遮下二十三也。不失等者弥勒颂云。得胜忍不失。一异相反难为存去故成疑矣。此约下悬指断疑之意。彼约一异双存而难。此据一异俱非而通也。破粗色经问答。多少如文可知。疏三初引天亲约断疑。偈云下标也。论云下释也。一真法界数量消灭非一异故。诸佛证此亦非一异。而言处住者。以非此二义可住着故。为示下正显住意。意以界喻真身。尘喻化身也。尘因界碎故非异。喻从真起应也。尘细界粗故非一。喻真实应假也。无著下二破执法。别是一义非断疑也。名身即受等四蕴。色身即地等四大。于中下以细末破色身。以无所见破名身。无所见即不念也。此段说尘甚多。正是初方便。大云下三示破相。明方便之相。以能破是细末所破是粗色。能所合之故成科名。此言下拣异大小。大乘用观假想分别起其慧数。破析彼色一一分析至于极微。二乘天眼所不能见。此则细末之极不可破析。名极略色。非小乘等者。以彼宗迷唯识理。不达诸法即空。计此微尘以为实有故。说积诸微尘以成世界故。俱舍论云极微微金水。兔羊牛隙城。蚤虱麦指节。彼后增七倍等。今此拣去故云非实尘也。破微尘经意云。以何义故说微尘耶。释意云。以无实体故。又征意云。所以说微尘空。又说微尘者何谓也。释意云。佛所说者。非实微尘是空微尘也。疏二初约断疑释。尘碎下喻说。尘是碎世界为末也。故界粗而尘细是非一也。尘众聚者。世界是众尘成故。尘界非异也。如是下法合。谓应现十方故非一。同依一体故非异。又依法起化故非一。离法无化故非异。又若下二约破法释。亦是约喻。法说者若化是实。亦不用佛说。只为是虚余人不知。故佛说矣。无著下引证同此。破世界经意云。非唯所起微尘是空微尘。抑亦能起世界。亦是空世界。本论等者。如次文所说。众生世界者有情世间也。以心法无质不可分析故。但以不念方便破之。念之则有不念则无。故起信云。心生则法生。心灭则法灭等也。破和合经微意云。以何义故说世界耶。释意云。世界若实则是一合。佛说一合者。非实有之一合。是空无之一合。疏文中引天亲解。论云下标也。大云下释冥合也。冥然合为一也。一即和合故云一合矣。三千破一者。既言三千则非一义。此乃通明五蕴无一合义。无著下二引无著解。并说等者情器双明也。故有下且标二抟取。大云下显明情器俱名世界。谓尘众则器世界。众生则有情世界。抟取为一等者。谓情器不分为一世界也。此一合有二抟取。于五蕴中分色心故。本以合二为一。今则开一成二。然和合抟取盖是一义。但秦魏译异耳。一抟取者是名身。众生世界义不可分。但有一义故。差别抟取者。是器世界聚多微尘成一世界故。故无著论云。众生世界有者。此为一抟取。微尘有者此为差别。抟取二界无实等者故。心经云。是故空中无色无受想行识。无眼耳鼻舌身意。无色声香味触法等。经是名一合相者。约俗谛说。有明在次文。妄执有经意云。此一合相无体可说。但为凡夫妄生贪着。以彼下释经中不可说也。五蕴和合无实体故。斯则界归于尘。则无界可取。尘归唯识则无尘可取。四蕴离念则无心可取也。众生取着皆由虚妄分别故。起信云。一切境界唯依妄念而有差别。此明经中但凡夫已下文。若有下反显也。以世界体若是实有。不名虚妄分别。合是正见。世谛说者即前是名也。同论云以彼聚集。第一义不可说即前即非也。同前无物可取。小儿等者。世谛虽说但是假有。凡夫不敏执之为实。犹彼小儿如言执物。见五蕴者不了法空。是法执也。取和合者不达众法。即我执也。二执不亡故名贪着其事也。迷于事法所知障也。烦恼可知。是依二执起于二障也。破我法者。前破我法所缘之境。令知不实。今破能缘我法见心。见心乃是所起分别。今即破之令亡分别入圣道也。故偈云。非无二得道。远离于我法。斥错解经文。问答并可知矣。但不解必不错解也。遣言执经征意云以何义故说为不解。释意云。佛说我人等见。非实我人等见。是假名我人等见。众生不解谓之为实。所以前科判云错矣。虚妄等者。见有我故名为我见。体实无故乃云虚妄。虚妄无实元是不见。如绳处见蛇岂是实见。如所下两意。一以真如为所。如彼真如不分别故。二以我法为所。我法本无如所知故。云何下征。如外道下释。人无我等者。一法界中无我无无我。今对有我说于无我。权说假言故云安置。法无我等者。以见是心心所法执有此见。名为法执。心法不实故言安置。此文破法我者。是连带引之。非谓正意也。相应等者。入地证如也。不分别者。离分别障也。即此等者。若存我法即分别无穷。但了二空则自无分别。即此二空观。为入理之方便也。除分别经意云。发菩提心者。于一切法应如是知见信解不生法相。疏二初明无分别所依二。初总征三法。无著下。节节以疏征起以经答之。何人等者。即经中发菩提心者。于何法者。即经中一切法。何方便者。即经中应如是知见信解。此显下。二别释第三二。初总标。此显下。增上心即定也。增上智即慧也。当是增胜上法故云增上。知见胜解者。定慧之后位。于中下。二别释二。初总彰三义。于中者。于彼三事之中也。若智等者。明此三种体即是智但依止方便不同故立三名也。奢摩他此云止。止即是定。智依此定并息万缘。唯心独存故云知也。毗钵等者。毗钵舍那此云观。观即是慧。依此慧故观察一切。委细推求历历分明故名为见。此二者知见也。三摩提此云等持。但以定慧等处名三摩提。依此义故名为胜解。言依止者。名依义立也。以三摩下。二转释后义。自在者。定慧无阂故。内缘等者。既未证真但缘影像。以真如法离心缘故。今既变影缘如但名胜解。从此能引根本正智。无分别中为近方便。故云何下。二正显无分别理。即论释经中不生法相。初句征起次句正显。大云下。约位释论。前方便等者。即知见胜解。此当地前四加行位。今不分别者。即不生法相。通在十地及佛地也。虽满分不同。皆用根本无分别智。亲证谛理也。如唯识见道颂云。若时于所缘。智都无所得。尔时住唯识。离二取相故。显本寂经意云。所言法相非实有之法相。是本无之法相。不共者非法相也。胜义谛中不容他故。离性离相非和合故。相应者。是名法相也。性起为相不离性故。如前金中无器不离金也。第二十六论文。于此不言断别疑。故云外二疏皆摄入前段。合疏详文合有是故开之。因闻下指疑起处。此从二十五中来。意云下立理。即化身下指无化体。若尔下结成疑也。意云。能说之佛既虚。所说之教岂实。持说不实之教。宁有福耶。功德经文校量可解。阿僧祇此云无数。发菩萨心者拣余人。偈云下标。论云下释。先牒疑纵之。而彼下据理夺之。无量下拣有量等。斯则三重显于持说之胜。不染经征意云。云何演说便获如是功德。释文可见。前云发菩萨心者。意在于此。若非菩萨焉能如是。无著下初引解二。初申经意。既说法之心。如彼真如无有分别不取能所说相。所获功德利益至矣故决定说也。无所染者。即无分别不取不动也。此则正是断疑之意。谓佛所有说皆如真实。传授之人要皆如是。既如其法福乃无边。何疑持说无福德耶。又如偈云。诸佛说法时。不言是化身。以不如是说。是故彼说正。意云。若言是化则人无敬心所说之法宁肯信受。由不说故人皆宗奉。所说之教咸悉受持。无漏之福自然无量等。云何下二销经文。不可等者。此明离于说相。非全不说。前云无法可说。净名无说无示。是名说法。故魏经云如不演说。若异下反明以取相故有分别故不如如故。既不如如即成颠倒。又说时下。约事明无染。前约不称理。今约不称事夫说法者本为利生。今为名利岂非染说。大云下。二引大云解。生灭心行即有所得分别取相。今既不以即与如合故曰如如。上如即似义。下如即真如。似于真如故曰如如。心境如者。即两皆真如无似义也。则无染者。谓拟心即差便名为染。故论云。动即有苦果不离因此则微细念虑尽名为染。不必贪欲。第二十七疏初标章若诸下指疑起处。此从二十六中来。以化身如来常说法故。前虽无文而有此意。云何下结成疑也。涅槃即是不动无为义。如前文云。若人言如来若来去坐卧。即不解所说义。如来者。无所从来亦无所去。故名如来。斯则佛入涅槃也。意云。涅槃寂静说法喧动。动寂相反云何两存。经征意云。以何义故。佛常说而不阂涅槃。如论所叙。释意云。常佛有妙智。观诸法空如梦幻等。虽现说法似有为相。而常住涅槃无作之理。复何疑哉。若于论外不作断疑释者。此文但责说法不染。征意云。以何义故。说法之时不取于相。得合真如不动不染耶释意云。但观诸有为相。犹如梦幻等自然于说不取不着契合真如。无有动摇分别等也。疏文二。初开章指文。魏本等者。以彼此二经皆说譬喻就中彼广此略。今则标广以释于中下。二随章辨释三。初约两论释魏本中九喻。二初文者偈云下标论云下释。初释前二句。真化不一故非有为。真化不异故不离有为。言诸佛者。拣小乘涅槃一向寂灭。如来涅槃悲智兼运。名无住处。何故下。蹑前征起释后二句。征意可知。由妙智等者。妙智拣二乘粗智。正观拣凡夫倒见。既以妙智正观有为诸法。如梦幻等故涉有而不住有。观空而不住空用而常寂。寂而常用故。终日说法终日涅槃。如华严疏云。寂寥于万化之域。动用于一虚之中也。故知若不涉有。岂名大乘涅槃。若不证如何名无染说法。言虽似反意乃相符。善现约极违以申疑。如来据极顺以通释。理实深妙光兹末篇。二兼无著下。初指论分文。此偈者魏经文也四有为者。即下自性等四初自性下。二随文正释四。初文二初释章意。此见等者。谓见相二分。以自证分为体。然此三法是生死之自性。一切生死从此而生故名此三为根本矣。此通八识也。一星下二别解文三。初文见分者。云云第六识也。计度分别缘共相境世间诸智尽在其中。故以星光况于此识。此约执计强盛故独指第六。非不通八也。无智等者。此中法喻相兼文犹阙略。若具配属即法喻四对。谓以日喻智以星喻识以明喻悟以闇喻迷。且如喻中。意云无日闇中有星光故。有日明中无星光故。法中无智迷中有识用故有智悟中无分别故。其犹昏夜日光黯然唯星独存略辨南北。杲日才现星光自存。法中亦尔。生死迷中本智未显。意识分别似有鉴觉若智显彰光明遍照。分别念虑泯然无余。无彼光者此约分喻。喻中俱无星光。而不无星体。法中融同一智。无别识心故。二中如目等者。意云。翳若在眼则见毛轮。执若在意见实我法。若正配法喻。即翳喻第七识。毛轮等喻所见分。今标云翳喻所见分者。此有三意。一密配第七识。谓若但取毛轮则唯喻所见。第七意识无因可收。故此密配无所遗也。二交互影略。以喻上举能法中言所。自然影略说收所余。三显示毛月无有体性。意虽在所今却举能。以显所从能生。足知无体也。以颠倒见者。出无体所以。于无见有故云颠倒取无义者。情有理无故。三中灯喻识者理则虽通义当前五。以六七八识各有配故。灯约等者。以膏油喻贪爱以灯喻识。若无膏油则灯光不起。若无贪爱则识念不生。故论云。依止贪爱法住。然此上三喻。皆是能熏染污根本。故通名自性相。其所熏第八识持种引心。配属云喻如下所明。或可星喻见分。翳目所见毛月喻相分。灯喻自证分。自证分即第八识。其后云喻但况识中种子为未来法。着所住味者即是味着所住。幻喻等者。即约所幻境说。如结巾为兔结草为马。乃至变现种种境界。以器下所喻法也。六尘境界不一故云种种。无著下会释科文。大云释意可知。能变之识尚犹不实。所变之境岂得有体。故起信云。一切境界唯依妄念而有差别。若离心念则无一切境界之相。三随下二。初释章意。自身等者。明身受当体是过失。观此等者。随顺出离也又解等者。执着身受是随顺过失也。所谓执身为常执受为乐即是颠倒。颠倒即过失也。初露下。二正解文二。初者少时。住者如草上之露。日出即晞。众生妄身亦复如是。然有三意。一命修短。有才生即死故。二比于上界时极促故。三念念迁谢。即生即灭故。有斯三意故曰少时。二中受用事者。受能领纳。即此领纳是受之用。即此受用便名为事。受想等者。因即是触受之因故。想能助受故。俱舍云。受同饮食想同助味。三法不定者。有三释。一则苦乐舍三受不定也。二则受想因。于三法而不定。三法即违顺等三境也。三则受想触为三。三皆不定也。以一不定余皆不定故。然此虽说想触。意明于受。如风水相投即有泡起。触想和合则有受生。是故以泡喻于受也。故大云云。水上之泡出没不定。心中之受苦乐不常。苦体等者。受是苦体。苦谓三苦。彼苦身中。有苦生故是苦苦。破灭是坏苦。不相离是行苦。逐境住情妄生乐想故名随顺。功德施下。意说寿命不同前义。喻则可知。法中始生等者。托蕴腹中名生。形体未成即有死者。才生者生下即死也。暂停住者。五岁十岁乃至百岁通名暂住。初天所见人间半百尚同昼夜。况圣智乎。故正法念经云。有于胎藏中死。有生而已命终。有能行便亡。有能走便卒。虽修短之异皆归死处。故净名云。是身虚伪。假以澡浴衣食必归磨灭。四随下三。初释章意。随顺人法等者。二空真智能出二死。方便观察名为随顺。二正解文三。初如梦者。人之神游也。以过去所作见闻事业皆是所念之处。与夜来梦无有差别。忆之可说掬之不见。如经云。如寤时人说梦中事。心纵精明欲何因缘取梦中物。唯念性者。以念为体性故。念之似有不念全无。观察等者。谓白日见闻境界所熏。梦中宛然还见。虽即无人造作境界分明现前。如是下法合。过去业因所熏。感招现在果报。虽则无人造作。不免生死轮回。故净名云。无我无造无受者。善恶之业亦不亡。若梦寤时则梦所见事一无所有。若迷觉已则生死轮回。杜绝踪迹。故起信云。应观过去所念诸法恍忽如梦。二中不住生灭文异义同。凡是有为即生即灭无异时也。以无性故体虚妄故。经云因缘和合虚妄有生。因缘别离虚妄名灭。楞伽经云。初生即有灭。不为愚者说。起信云。应观现在所念之法犹如云光。三中子时者。在种子位时。根本等者。应云阿梨耶识在种子位时为一切法作种子根本。以一切诸法从种子生故粗恶种者有漏种也。以无漏种子。为细妙故似空者喻多也。华严云。若此恶业有体相者尽虚空界不能容受。如云者。空喻种子。云喻未来所起现行之法。以云依空忽然起故。故起信云。应观未来所现诸法。犹如于云忽尔而起。无著下。通明三事结释科文。大云下。显无著科意。三世既空凭何有我执。我既不出离。达无我者必出离也。故偈云。观根及受用。观于三世事。于有为法中。得无垢自在。二中诸经等者。谓如来说法。多以梦幻虚假之事。况诸法空义。或广或略散在诸经诸论。随何经论宗趣虽殊。大意皆破众生遍计情执。或情执多者。不达法者。约喻生疑。病既连绵药还洒迤。以悟为限法喻重重。今约华严十忍品疏文。兼摄大乘论意势。显诸喻意令无混滥也。一切法空者此是义宗。若是上根闻之便解。中根之类一喻即明。下根之流展转生惑。更以诸喻如下所辨。现见等者。难曰。诸法若不见。任说法皆空。现见历然在。因何得是空。故说如幻下。以喻释喻也。下皆准此爱着等者。难曰。众生不爱着。任说法如幻。既生爱着心。云何得如幻。故说如焰下释也。不得水者。难曰。贪求若不得。任说法如焰。求者皆遂心。云何得如焰。故说如梦下释也。梦造等者。难曰。善恶无果报。任说法如梦。因果事昭然。云何得如梦。故说如影下释也。妍美好也媸丑陋也。此说对镜之色。高低者。此说对谷之声也。一一应者。无一像而不应色。无一响而不应声。无杂乱等者。必不对美现丑对高应低。故利乐等者。难曰。菩萨不化生。任说如影响。菩萨既化生。云何如影响。故说如化下释也。作化事者。不可谓作化事便言为实。不可谓度众生。便谓众生实有。良为众生即空。迷故不觉为说今觉。若实有体化之何益。故净名云。观众生如幻化如水月镜像如龟毛兔角等。文殊问云。若然者菩萨云何行慈。维摩诘言。为众生说如是法。是真实慈也。上来五重征释皆显法空。盖因喻生迷。遂展转训晓。极兹后位喻尽法彰。疑冰自释然。诸经中。或说干城水月杌鬼绳蛇翳目空华龟毛兔角等。皆随机随说引令得出。必不依次有是五重也。秦经梦幻等者。以梦等四事皆无体性。若观有为诸法如其梦等。则空理易明。露电二事暂有即无。若观诸法如其露电。则无常自显。悟真空下显益。不住相者。凡夫迷真空既住相。当知悟真空即不住相也。住即执取染着之义。又凡夫颠倒不了无常。故恋世间不务修进。当知达彼一切悉无常性念念迁谢下住不久。由是怖畏生死乐趣涅槃。如救头然寸阴是竞。所以佛于涅槃会中。偏赞此观以为第一。然二句中各有解行。配释可知。妙符下结叹。符破相宗者。叹前四喻也。然佛一代教门。就大乘中宗涂有三。一法相宗。谓解深密等经。瑜珈唯识等论。二破相宗。谓般若等经。中百门等论。三法性宗。谓法华涅槃等经。起信宝性等论。既般若宗于破相。今说有为喻。以梦幻泡影。则妙符宗旨也。示亡情等者。叹后二喻。若观世间诸法如电露等。自不系情于身命财而生常解。又由前四喻故慧解亡情。由后二喻故习定亡情。又前亡执有之情。后亡计常之情。若不觉空无常。即系情于身命资具。今既悟此空无常理。则情念沮坏真智现前。斯则上合经宗故云妙。下契物情故云巧也。魏译下牒问也。或问曰。魏译九喻。秦经略三者何也。今此牒之。以星下释通。有体者虽星不如日灯藉膏油。未是全空故云有体云种者法喻双举。云能含雨种必生芽故曰含生。难契等者。本为执情坚固不了即空。由是设喻以荡分别。若观有体之物。便同折色难悟即空。空观不成故云难契。潜滋等者。既不了无常。唯于境相而生常想不能舍离。纵不故意任运生情不觉而起。故曰潜也。取意等者。先德皆云。敌对唐梵则奘称能。取意译经则什为最。然云等三喻。则直下翦除。于余六中又换一喻。谓以影代翳也。所以换者。影并于翳空义显故。流通经文可见。佛说是经已者。本为空生致问故佛答降住修行。答问既终便合经毕。仍以蹑迹起疑连环。二十七段洎乎此文疑念冰释。既善吉无问。故能仁杜宣。一卷经内。虽兼有师资。以其就胜故但云佛说。长老等义如前所解。疏二初随经文别释。近事男女者标释可知。亦云近住男清信男等。并可知。非天者亦非人也。谓非天人趣之所摄故。亦云无酒。如实等者。说理如理说事如事故。果净者。依解起行得无漏故。无著下。二引论疏赞释。无觉者。不发二空智也。二执牢固如石之坚。石犹可磨可琢。闻经不能无我而解。不啻于石。故云过于。诗云我心匪石不可转也。转犹动也。磨琢皆是动义。又论云下。人于深法不能觉及信。世人多如此。是故法荒废。无因者。无大乘正因。不得菩提故。总持法者。秘密般若也。深句义者。显了般若也。或总持法是经文。深句义是本偈。从尊者即弥勒无著也。广说即自指论文。佛母者。以能生诸佛及菩提法故。余文易知

金刚经纂要刊定记卷第七


金刚三昧经论

    No. 1730 [cf. No. 273]

金刚三昧经论卷上

        新罗国沙门元晓述

此经略开四门分别。初述大意。次辨经宗。三释题名。四消文义

第一述大意者。夫一心之源离有无而独净。三空之海融真俗而湛然。湛然融二而不一。独净离边而非中。非中而离边。故不有之法不即住无。不无之相不即住有。不一而融二。故非真之事未始为俗。非俗之理未始为真也。融二而不一。故真俗之性无所不立。染净之相莫不备焉。离边而非中。故有无之法无所不作。是非之义莫不周焉。尔乃无破而无不破。无立而无不立。可谓无理之至理。不然之大然矣。是谓斯经之大意也。良由不然之大然。故能说之语妙契环中。无理之至理。故所诠之宗超出方外。无所不破故名金刚三昧。无所不立故名摄大乘经。一切义宗无出是二。是故亦名无量义宗。且举一目以题其首。故言金刚三昧经也

第二辨经宗者。此经宗要有开有合。合而言之。一味观行为要。开而说之。十重法门为宗。言观行者。观是横论。通于境智。行是竖望亘其因果。果谓五法圆满。因谓六行备足。智即本始两觉。境即真俗双泯。双泯而不灭两觉而无生。无生之行冥会无相。无相之法顺成本利。利既是本利而无得故不动实际。际既是实际而离性故真际亦空。诸佛如来于焉而藏。一切菩萨于中随入。如是名为入如来藏。是为六品之大意也。于此观门。从初信解乃至等觉。立为六行。六行满时。九识转显显无垢识为净法界。转余八识而成四智。五法既圆三身斯备。如是因果不离境智。境智无二。唯是一味。如是一味观行以为此经宗也。所以大乘法相无所不摄。无量义宗莫不入之。名不虚称斯之谓欤。合论一观略述如之。开说十门为其宗者。谓从一门增至十门。一门云何。一心中一念动。顺一实。修一行。入一乘。住一道。用一觉。觉一味。二门云何。不住二岸以遣二众。不着二我以离二边。通达二空不堕二乘。俱融二谛不违二入。三门者。自归三佛而受三戒。顺三大谛得三解脱。等觉三地。妙觉三身。入三空聚。灭三有心。四门者。修四正勤。入四神足。四大缘力。四仪常利。超出四禅。远离四谤。四弘地中四智流出。五门者。于五阴生具五十恶故植五根而养五力。涉五空海跋五等位。得五净法。度五道生。如是等也。云何六七八九等门。具修六度永除六入。行七觉分灭七义科。八识海澄。九识流净。始从十信乃至十地。百行备足。万德圆满。如是诸门为是经宗。皆在经文。文处当说。然此后九门皆入一门。一门有九。不出一观。所以开不增一。合不减十。不增不减为其宗要也

第三释题目者。此经之目有其三种。一名摄大乘经。二名金刚三昧。三名无量义宗。初后二名次门当释。今且先释中间一目。唯此一名在首题故。于中有二。先释金刚。后释三昧。初中亦二。先释后简。言金刚者。寄喻之称坚实为体穿破为功。金刚三昧当知亦尔。实际为体破穿为能。实际为体者证理穷源故。如下文言证法真实定故。破穿为能者有其二义。一破诸疑二穿诸定。破诸疑者起说断疑故。如下文言决定断疑悔故。穿诸定者。此定能令诸余三昧皆得有用。如穿宝珠。得有用故。如大品经言。云何名金刚三昧。住此三昧能破诸三昧。彼论释云。金刚三昧者譬如金刚无物不陷。此三昧亦如是。于诸法中无不通达。令诸三昧皆得有用。如砗磲码瑙琉璃唯金刚能穿入。案云。经言破诸三昧者破之言穿。论中穿入释经破故达诸三昧皆无自性。令彼三昧皆离自着。由是无碍得自在故。释名如是。次简别者。于中有二。先简定慧。问金刚般若金刚三昧皆名金刚。有何差别。解云。彼慧此定是为差别。又金刚般若通于因果。金刚三昧位在果地。又般若金刚具有三义。体坚用利形状宽狭。三昧金刚但取坚利。如是差别。次别余定。此有三类。一金刚三昧。二金刚轮三昧。三如金刚三昧。大品经言。云何金刚轮三昧。住是三昧能持诸三昧分。云何如金刚三昧。住是三昧能贯达诸法亦不见达。彼论释言。问曰。三种三昧何以皆言金刚。答曰。初言金刚。中言金刚轮。后言如金刚。如金刚三昧。佛言。能贯穿诸法亦不见是穿。金刚三昧能通达诸三昧。金刚轮三昧能持诸三昧轮。是皆佛自说义。论者言。如金刚三昧者。能破一切烦恼结使无有遗余。譬如释提桓因手执金刚破阿修罗军。即是学人末后之心。从是心次第得三种菩提。声闻辟支佛佛无上菩提。金刚三昧者能破一切诸法入无余涅槃更不受有。譬如真金刚能破诸山令灭尽无余。金刚轮者。能破一切诸佛法无遮无碍。案云。此中破诸佛法者。犹如转轮圣王轮宝能破诸王无不伏故。是故与前二金刚别。前二金刚云何别者。有五差别。一者喻别。谓如金刚破军金刚破山故。二者法别。前破烦恼后破诸法故。三者位别。前在学位后在无学故。四者名别。前名如金刚三昧。余处名金刚喻定。后者直名金刚三昧。除如及喻。所以然者为显因果二定异故。因有功用果无功用。损之又损之以至无为故。又如金刚取其少分相似之义。但破烦恼不破余法故。言金刚者。显其全同金刚之利。一切色物无不贯破。三昧之用当知亦尔。一切诸法亦无不破故。五者教别。谓有学位金刚三昧。则金刚三昧本性清净不增不减。经中所说其无学位金刚三昧。今此经中所说是也。今此经中佛所入定破一切法皆无所得。是故名为金刚三昧。六种释中是持业释。取譬名者是邻近释。即以是名目此经者是依主释。定为主故。次第二释三昧名者于中有二。先释后简。古师说言。彼名三昧此云正思。今述此说当文义故。谓在定时于所缘境审正思察故名正思。如瑜伽言三摩地者。谓于所缘审正观察心一境性故

问。定应是静静住一境。云何乃言审正思察。思察之用应是寻伺。云何说定为思察耶

答。若守一境即为定者。惛沉住境应即是定。若正思察是寻伺者。邪慧推求应非寻伺。当知思察有其二种。若通邪正意言分别名思察者。即是寻伺直是分别。若唯审正明了缘境名正思察。正是定用而非寻伺。定通分别及无分别故。以审正简彼寻伺。又住一境亦有二种。若住一境。惛迷闇昧不能审察即是惛沈。若住一境不沈不浮审正思察是名为定。故以思察别彼惛沈。是故当知不以住移简别定散差别之相。何以故。捷疾之辩虽速移转而有定故。迟钝之念虽久住境而是散故。今此金刚三昧名为正思察者。无正不正。亡思非思。但为别于分别邪念。又不同于虚空无思。所以强号为正思耳。三昧之名。略释如是。次简别者于中有二。先别诸名后简通局。定名不同略有八种。一名三摩呬多此云等引。远离惛沉掉举之偏故名为等。引发神通等诸功德故名为引。又此等引无悔欢喜安乐所引故名等引。由此不同欲界定故。二名三摩地此云等持。等义同前。能制持心令不驰散故名等持。又定慧平等令不相离故名等持。旧云三摩提亦即等持。三名三摩钵提此云等至。等持之中能至胜位故名等至。四名驮演那此云静虑。寂静思虑故。又能静散虑故。旧云禅那。或云持阿那。方俗异语同谓静虑也。五名奢摩他此译云止。令心止境故名为止。六名心一境性。令心专一于境之性故名心一境性。旧云一心是略故也。七名为定。审定所缘故名为定。八名正思。义如前说。有师说言。三昧之名及三摩提只是等持非是异名。是说不然。所以者何。如金鼓经十种定中。前三地中名三摩提。后七地中名为三昧。如是二名若同等持。何由改名前后异说。又此二名何由不同。若由方俗异故不同者。不应一处俱说二名。若由传者前后故异者。不应一本有此二名。如三摩提及三摩地。此由前后传者不同。故其是同灼然可见。三昧之名与三摩提同在一本何由不异。是故当知如前说也。第二明通局者略作四例。一者定与等持。二名最宽。通漏无漏。亦通三界。及通欲界散乱心中。以六位心所别境五中有三摩地亦名定故。二者心一境性及三昧名此二次宽。虽通欲界。不通一向散乱心中。以般舟三昧或欲界系九种心住。心一境性亦通欲界方便心故。三者三摩呬多。及静虑名。此二是狭。全不通于欲界心故。唯取轻安所含润故。四者三摩跋提及奢摩他此二最狭。于定地内有简别故。以奢摩他不通四种慧行之中心一境性。三摩跋提不通于空无相无愿三三摩地故。八名宽狭粗述如是。第三释题名讫

自下第四科文解释。文有三分。一者序分。二者第二品下六品余文是正说分。三者入总持品尔时如来而告众言已下二纸许文是流通分。序分之内有二种序。谓通与别通序之中即有六事。前三明亲承之传。后三证大师之说。言前三者。一如是。二我闻。三一时。后三是何。一教主。二住处。三徒众。徒众之内序四类众。一声闻众。二菩萨众。三长者众。四杂类众。于中委悉如常所说

经曰。尔时尊者大众围绕为诸大众说大乘经名一味真实无相无生决定实际本觉利行若闻是经乃至受持一四句偈是人即为入佛智地能以方便教化众生为一切生作大知识

论曰。此下第二别序即有四分。一威仪分。二说经分。三入定分。四重颂分。威仪分者。如经尔时尊者大众围绕故。说经分者。如经为诸大众说大乘经等故。此经文势似法华序。如彼文言尔时世尊四众围绕说大乘经名无量义。如彼论中判此经名。即为法华经之异目。彼意以为在前说故名为序分。今看此经文势皆是经家序辞。以是准之应是别经。在前广说。说已入定。从定起已。方说金刚三昧经也。说经宗后乃说经名。当知一味真实等名。是前所说广经之目。如是二经大意虽同。文相即异。前所说者广说法门为益当时。后所说者略摄法门为利末世。是故在前广说。以为略经缘由。此说经分文相有二。先序经名。后叹经德。若闻已下是第二分

经曰。佛说此经已结跏趺坐即入金刚三昧身心不动

论曰。是第三入定分。所以欲说经前。先须入定者。为显唯寂静者。于法能觉能说故。又复为显贤圣默然。贤圣说法。随时而用。不相离故

经曰。尔时众中有一比丘名阿伽陀从座而起合掌胡跪欲宣此义而说偈言

论曰。是第四重颂分。为显前说一味之经与后所说大意不殊。故以略偈颂前广经。因此发起后略说经故文即有二。先序后颂。是经家序以发后颂。阿伽陀者此云无去。或言灭去。此是药名。能令诸病皆悉灭尽故名无去。此菩萨亦如是。能治众生诸烦恼病故以药名为其目也。八行颂中即有二分。前七颂颂说经。后一颂颂入定。初中亦二。三颂总明。四颂别显

经曰。大慈满足尊智慧通无碍广度众生故说于一谛义皆以一味道终不以小乘所说义味处皆悉离不实入诸佛智地决定真实际闻者皆出世无有不解脱

论曰。总明三颂即有四意。一者二句叹能说德。二者一颂叹能诠教。三者一颂叹所诠义。四者二句叹教胜利。第二中言一谛义者。所谓一心。依一心法有二种门。二门所依唯是一实故名一谛。一味道者唯一乘故。余文可知

经曰。无量诸菩萨皆悉度众生为众广深问知法寂灭相入于决定处

论曰。此下四颂别叹问答。此五句者叹问广深令知寂灭入实际故

经曰。如来智方便当为入实说随顺皆一乘无有诸杂味犹如一雨润众草皆悉荣随其性各异一味之法润普充于一切如彼一雨润皆长菩提芽

论曰。是第二叹佛答胜利。于中有三。谓法喻合。如其次第。四句二句五句应知

经曰。入于金刚味证法真实定决定断疑悔一法之印成

论曰。此第二颂入定。上半正颂在前入定。下半逆颂后起说法。后所说教有二胜能。一决断疑悔。如金刚能破。二印成一乘。如金刚不坏。下半二句显此二义。序分文竟。正说之中大分为二。谓前六品别显观行。总持一品总遣疑情。别显之中即为六分。一无相法品明无相观。二无生行品显无生行。三本觉刹品依本利物。四入实际品从虚入实。五真性空品辨一切行出真性空。六如来藏品显无量门入如来藏。如是六门观行周尽。所以然者。凡诸妄想无始流转只由取相分别之患。今欲反流归源。先须破遣诸相。所以初明观无相法。虽遣诸相。若存观心观心犹生不会本觉。故泯生心。所以第二显无生行。行既无生方会本觉。依此化物令得本利。故第三明本觉利门。若依本觉以利众生。众生即能从虚入实。所以第四明入实际。内行即无相无生。外化即本利入实。如是二利以具万行。同出真性。皆顺真空。是故第五明真性空。依此真性万行斯备。入如来藏一味之源。所以第六显如来藏。既归心源即无所为。无所为故无所不为。故说六门以摄大乘。又此六品亦有异意。谓初品示所观之法。法谓一心如来藏体。第二品明能观之行。行谓六行无分别观。第三本觉利品显一心中之生灭门。第四入实际品显一心中之真如门。第五真性空品双遣真俗不坏二谛。第六如来藏品遍收诸门同示一味。以此二重六门摄大乘义周尽。又此六品合为三门。前二品摄观行始终。次二品者教化本末。其后二门摄因成果。又前二品遣相归本。中间二品从本起行。后二品者双显归起。以此二三摄大乘尽。又此六品只是二门。相生都泯是本觉利实际真空。是如来藏。又前门者遣妄显因。其后门者显真成果。如是二二之门亦摄大乘周尽。又此六品唯是一味。所以然者。相生无性。本觉无本。实际离际。真性亦空。何由得有如来藏性。如下如来藏品中言。是识常寂灭。寂灭亦寂灭。总持品言。七五不生。八六寂灭。九相空无。如是无所得之一味正为此经之宗之要。但以无所得故无所不得。所以诸门无所不开故作无量义之宗也。虽是一味而开六门故。依六分科文而释。先释品名。言无相者谓无相观。破诸相故。次言法者谓所观法。一心法故。无相观者先六分中第一分义。所观法者后六门内第一门法。今此初品显是二义。以之故言无相法品

经曰尔时尊者从三昧起而说是言

论曰。此一品文科分为三分。初出定分。次起说分。后得益分。初后二分是经家序。其第二分正是佛言。初分中显三种成就。一说法时成就。如经尔时故。二说法主成就。如经尊者故。具五通达为世所尊。于甚深法如义说故。三自在成就。如经从三昧起说是言故。如来入定无能惊寤。于定住出得自在故

经曰。诸佛智地入实法相决定性故

论曰。此下第二正发言说。此中有二。一者长行。二者重颂。初长行中亦有二分。一略标分。二广说分。略标分中标二种义。初标无相观。后标所观法。无相观中有其二句。先标如来自入无相观。后标令他入无相观。言自入者。如经诸佛智地入实法相决定性故。诸佛智地者。谓如前所入金刚三昧相应之智。住持一切功德法故。入实法相者。谓此佛智破一切相通达诸法之实相故。决定性者。是实法相。非佛所作。有佛无佛性自尔故。次言故者。以决定性释成上句。若不决定即非实相故。又摄上句而成下句。如来自入实法相故。故能令他得无相利也

经曰。方便神通皆无相利

论曰。此第二句令他得入。言方便者八相方便。谓从兜率天退乃至入涅槃故。神通者六神通。即为三轮化众生故。皆无相利者。如是八六方便神通皆从自入实相而起。能令他得无相利故标无相观竟在于前

经曰。一觉了义难解难入非诸二乘之所知见唯佛菩萨乃能知之

论曰。此下第二标所观法亦有二句。一者直标所观法深。二者为他说是深法。一觉了义者。一心本觉如来藏义。过是永无余深法故。难解者义甚深非诸二乘所知见故。难入者体甚深唯佛菩萨乃能入故。即以后句而释前句。欲明初门所标。佛智所入实法相者。直是一心本觉如来藏法。如楞伽经言。寂灭者名为一心。一心者名如来藏。今此文言实法相者是寂灭义。一觉了义者即是一心如来藏义。法华论云。诸佛如来能知彼法究竟实相。言实相者。谓如来藏法身之体不变义故。今此经言一觉者。一切诸法唯是一心。一切众生是一本觉。由是义故名为一觉。至下演中当更分别

经曰。可度众生皆说一味

论曰。此明为他皆说深法。可度众生者。如来所化一切众生莫非一心之流转故。皆说一味者。如来所说一切教法无不令入一觉味故。欲明一切众生本来一觉。但由无明随梦流转。皆从如来一味之说无不终归一心之源。归心源时皆无所得。故言一味。即是一乘。初略标文竟在于前

经曰。尔时解脱菩萨即从座起合掌胡跪而白佛言

论曰。此下第二广说。于中有二。先请后说。请中有二。先序人仪。后明发言。序有二句。一依时表人。解脱菩萨者。令诸众生同一解脱故。寄能问人表所说法故。二序礼仪。如经即从座起等故

经曰。尊者若佛灭后正法去世像法住世于末劫中五浊众生多诸恶业轮回三界无有出时

论曰。此下第二发言而请。于中有二。先举所为时节。后请为彼宣说。初中像法住世。末劫中者先广说经为益正法之时。今此经者为化像法之节。随时厚薄设教异故

经曰。愿佛慈悲为后众生宣说一味决定真实令彼众生等同解脱

论曰。此是第二正请宣说。宣说一味者。请说一觉了义之味。决定真实者请说入实法相之观。令彼众生等同解脱者。令彼像法末世众生等同一味究竟解脱。由是言之。教有四句。一正化正法兼利后时。谓前经等。二正化像法兼利前时。谓此经等。三通化前后。谓诸余经等。四不利前后。除上尔所教

经曰。佛言善男子汝能问我出世之因欲化众生令彼众生获得出世之果是一大事不可思议以大慈故以大悲故我若不说即堕悭贪汝等一心谛听为汝宣说

论曰。此下第二如来为说。于中有二。一者赞问许说。二者对请宣说。赞问中言出世之因者。入实相观故。出世之果者。一味解脱故。是一大事者。无上同义故。不可思议者。离言绝虑故。如法华经言。诸佛世尊唯以一大事因缘故出现于世。论者释言。一大事者依四种义。何者为四。一者无上义。唯除如来一切智智。更无余事。如经欲开佛知见。令众生知得清净故。出现于世故。佛知见者。如来能证以如实智。知彼义故。二者同义。以诸声闻辟支佛佛法身平等。如经欲示众生佛知见故。出现于世故。法身平等者。佛性法身无差别故。三者不知义。以诸声闻辟支佛等不能知彼真实处故。不知真实处者。不知究竟唯一佛乘故。如经欲令众生悟佛知见故出现于世故。四者令证不退转地。示现欲与无量智业故。如经欲令众生入佛知见故。出现于世故。今此文中一大事者亦有四义。一无上义。如上文言。诸佛智地入实法相故。二者同义。如经一觉了义难解难入故。三不知义。非诸二乘所知见故。四令证义。可度众生皆说一味故。赞问已竟。次许说中亦有二句。初句反显不说有过。后句顺明诫听许说

经曰。善男子若化众生无生于化不生无化其化大焉

论曰。自此已下正为宣说。于中有二。先明无相观广明无相利。后显一觉心广前一觉义。无相观中亦有二分。一者直说观行之相。二者往复决诸疑难。初中亦二。先方便观。后明正观。方便观中。有其四句。初一句牒能化。后一句叹化大。中间二句正明观相。无生于化者。初修观时破诸有相。于幻化相灭其生心故。不生无化者。既破化相次遣空相。于无化空亦不生心故。所以然者。众生本来迷心离相。遍取诸相动念生心故。先破诸相灭取相心。虽复已破幻化有相。而犹取其无化空性。取空性故于空生心。所以亦遣无化空性。于时不生取空之心不得已会无二中道。同佛所入诸法实相。如是化故其化大焉

问。此方便观为在何位

答。若仰信修在于十信。其相似观在三十心。论其纯修在四善根。将入初地近方便故

问。余处说有三无性观。何故此中但说二无

答。无相无生合为一边。所遣相生同是有故。又此二观皆有寻思。遣无性时无寻思故。或开或合皆有道理故。已说方便次显正观

经曰。令彼众生皆离心我一切心我本来空寂若得空心心不幻化无幻无化即得无生无生之心在于无化

论曰。是明正观无二之相。以离所取能取二故。离所取者。以离一切人法相故。此有二种。一者遣离。二者泯离。遣离者先所取相今灭除故。如经令彼众生皆离心我故。泯离者先所取相本来空故。如经一切心我本来空寂故。言心我者。人名为我法名为心。心是诸法所依主故。达诸人法本来空时。先所取相此时不起。所以二离一时成就。已说离所取。云何离能取。谓离一切能取分别此亦二种。一者本离。二者始离。言本离者。通达心我本来空时正得本觉空寂之心。此空寂心本离能取。离能取故本不幻化。如经若得空心心不幻化故。不幻化者非虚妄故。言始离者。得此本觉空寂心时能取分别不复得生。随所得心无幻化故。如经无幻无化。即得无生故。如是始得无生之心会本空寂无化之理故。言无生之心在于无化。假说心境故寄言在然。始离能取是始觉义。本离空心是本觉义。义虽有二混成一觉。同离能所离新旧故。如论说言。以始觉者即同本觉。当知此觉永离生灭始终等相。始从初地乃至佛地。但有分满不同而已。如十地论本分中说。自体本来空有不二不尽。乃至广说。又此一觉有本始义。以有本觉显成义故。真修之说亦有道理。以有始觉修成义故。新修之谈亦有道理。如其偏执即有未尽。且止乘论还释本文广无相观竟在于前

经曰。解脱菩萨而白佛言尊者众生之心性本空寂空寂之心体无色相云何修习得本空心愿佛慈悲为我宣说

论曰。此下第二往复决疑有四问答次第决疑。第一问中问意有二。一者众生心性本来空寂而犹动念无始流转。云何方修而得本心。二者空寂心体无色无相。众生本来恒取有相。云何习无而得空心。故言云何修习得本空心

问。此中所说众生之心应是六识等生灭心。何以得知一心本觉

答。起信论云有法能起大乘信根。谓众生心依一心法有二种门。乃至广说。又如经言。寂灭者名为一心。今此文言。空寂之心体无色相。言有左右意致还同。言无色者无显形等色故。无相者无生灭等相故。此文即显心真如门。上言众生之心且举心生灭门。举生灭心显真如门。以之故言。性本空寂。然此二门其体无二。所以皆是一心法耳

经曰。佛言菩萨一切心相本来无本本无本处空寂无生若心无生即入空寂空寂心地即得心空善男子无相之心无心无我一切法相亦复如是

论曰。此答有二。正答决答。言菩萨者。是呼解脱菩萨之辞。下文呼辞皆亦同也。一切心相者。一切八识动念之心心所相应行相差别。若行若相皆有四相故。本来无本本无本处者。一切心相种子为本。求此本种永无所得。所以然者。为在现时为已过去。若在现时即与果俱无本末异。如牛两角。若已过去即无作因无体性故。犹如兔角。如是道理本来法尔。以之故言。本来无本。又生灭心生必依本处。本处既无即不得生。言本处者。谓俱有根。其五色根既是色法。有方无方皆不可得。余三所依皆无色法。有时无时并不可得。是故亦言本无本处。谓从本来无其本处。既无本种亦无本处。当知心相本来无生。以之故言空寂无生。如是观察不得生时。其能观心亦无所生。是时即入本来空寂。所入空寂即是一心。一切所依名之为地。故言即入空寂。空寂心地虽诸众生本来流转。恒取有相。然依此门推求观察。即能得本空心。故言即得心空。心空空心语有左右。只是一心本觉之义。正答所问竟在于前。此下结答。无相之心者举一心体。无心无我者结前所说。空寂无生无相心中。离心我相。一切法相亦如是者。重结空寂。非直离此心我二相。其余一切有为无为乃至有上无上等相无相心中无不离故

经曰。解脱菩萨而白佛言尊者一切众生若有我者若有心者以何法觉令彼众生出离斯缚

论曰。自此已下第二问答。前一问答总明破有相门。今此问答别显离二缚门。别举二病以问其药。言有我者人执之病。若有心者法执之病。言斯缚者。别而言之。人执是粗重缚。法执是相缚。通而说之。二执皆有粗重相缚。又此二执皆有二缚。谓相应缚及能缘缚。二障章中其义已具。答中有二。先治人执。后治法执。治人执中先总后别

经曰。佛言善男子若有我者令观十二因缘

论曰。此是总治。观十二支略有二门。一观无作缘生。治作者执。如说是事有故是事有。二观无常缘生。治常住执。如说是事生故是事生。存我之来此二为本。本既除故诸末随灭也

经曰。十二因缘本从因果因果所起兴于心行心尚不有何况有身若有我者令灭有见若无我者令灭无见

论曰。此是别治。别治有二。一者况治。二者逐治。况治中言本从因果者。从总出别。总而言之。唯因与果。从因出二三。从果出五二。又从因出十支。从果说二支。故所从本但是因果。因果所起兴于心行者。因果之起心行为本。心能作因心受果故。心尚不有何况有身者。依上所说观察道理心不可得。况心所作色身是有乎。身心尚无况有我耶。又心不有故因果亦空。因果尚空况有我乎。又因果空故十二支空。况有作者受者等耶。如经言。菩萨观十二因缘如虚空不可尽。此之谓也。已说况破。云何逐治。谓若有我者令灭有见者。牒前况破灭存我执。若无我者令灭无见者。此正逐破无我之病。所以然者。先破我执离外道病。而取无我堕二乘病故。今逐破着无之见。我本非有况有我无。故总别二观破我执竟

经曰。若心生者令灭灭性若心灭者令灭生性灭是见性即入实际

论曰。此下第二治存心见。于中有二。正治重释。二乘人等法执存心。计有生灭无常之心。故破生灭灭存心见。若存心生而成病者破前灭性。要依彼灭存今生故。若见后灭执有现心。心设不灭如兔角故。破如是见令灭生性。无生有灭不应理故。灭是见性即入实际者。破见灭性必不取生。破见生性必不取灭。不取生灭必不存心故

经曰。何以故本生不灭不灭不生不灭不生不生不灭一切法相亦复如是

论曰。此是重释。何以见心生者令灭灭性。见心灭者令灭生性。故言何以故。次释此问。本生不灭者。求前生心永不可得。不可得有何法而灭。如是不存前心灭性即不得取今心之生。故言不灭不生。是释令灭灭性之由。次言不灭不生。牒前不灭今不得生。如是不得今心生性。则不得取此心之灭。故言不生不灭。是释令灭生性之由。如于心法无灭无生。其余诸法亦同是观。故言一切法亦如是

问。若计心生真破此生。何须破彼前心之灭

答。今生是现破有不易。前心己过解空不难。故先破易而遣其难。依此次第破今生性。由是即遣后灭之执。是谓医王善巧之术耶

经曰。解脱菩萨而白佛言尊者若有众生见法生时令灭何见

论曰。此下第三问答。次前问答明所灭之见之病。今此问答显能灭之见之药。又前破生灭二际之见。今破有无二边之见。今问意言若观行者。顺佛教意观法生时令灭何见。灭何见者问佛教意。且举一边兼显观灭

经曰。佛言菩萨若有众生见法生时令灭无见见法灭时令灭有见若灭是见得法真无入决定性决定无生

论曰。见法生时者。正观俗法因缘生时。此时能离取空之见。故言令灭无见。见法灭时者。正观俗法本来灭时。此时能离取有之见。故言令灭有见。此中何故言令灭者。佛教能令观者灭故。此意正明修观行者观法生时只离无见而不存生。观寂灭时唯离有见而不取灭。所以然者。若存生耶生本寂灭。若取灭耶灭即生起。如下颂曰。因缘所生义是义灭非生。灭诸生灭义是义生非灭。所以能离二边而不着中。如其离无取有破有取空。此为妄空而非真无。今虽离有而不存空。如是乃得诸法真无故。言得法真无。决定性义如前已说。得真空时观心不生远离一切有无心故。故言决定无生

经曰。解脱菩萨而白佛言尊者令彼众生住于无生是无生耶

论曰。此下第四问答。前明真观离二边相。今显妄解不离生住。谓有寡学修观行者意言分别。观法无生能摄散乱住无生境。作如是念谓是无生。后出定时起增上慢。意谓已得无生法忍。为破是病举病问言。住于无生是无生耶

经曰。佛言住于无生即是生何以故无住无生乃是无生

论曰。答中有二。略答重详。此即略答。有其二句。上句顺明是生。住无生境即是分别之心生故。下句反释无生。若心无住于无生境离诸分别。是无生忍。故知有住非无生忍。如是反释。略答文竟

经曰。菩萨若生无生以生灭生生灭俱灭本生不生心常空寂空寂无住心无有住乃是无生

论曰。此是重详。于中有二。先详是生。后详无生。若有住心生于无生之境。即是以生灭其境界之生。故言若生无生以生灭生。虽灭境界之生而取其灭之无。于灭无境能取心生生灭俱存。岂曰无生耶。如是二句详前是生。真无生忍即不如是。外不存于所取之灭。内不生其能取之生。以之故言生灭俱灭。然此俱灭非谓还无。推求本生不得其生。既不得生何得还灭。于时证会本来空寂故言本生不生心常空寂。如是空寂能所平等。无能住心住于空境。故言空寂无住。如是乃名无生法忍。故言乃是无生。演无生观竟在于前

经曰。解脱菩萨而白佛言尊者心无有住有何修学为有学也为无学也

论曰。此下广一觉义。于中有八问答。科为二分。前二问答正广一觉如来藏义。后六问答因论生论遣诸疑难。今此初问。问心无住。若有学者即非无住。若无学者即非观行。又若有学者应有心生。若无学者只是空理

经曰。佛言菩萨无生之心心无出入本如来藏性寂不动

论曰。此中先显道理后正对问。显道理者。得无住时无生之心心常寂灭。无有出观达本无起亦非始入。以之故言心无出入。如是观心既无出入。即是本觉如来藏心。是明始觉即同本觉。此无生心既是本藏本来性寂不复起动。云何得有入出起息。此言重成无出入义

经曰。亦非有学亦非无学无有学不学是即无学非无有学是为所学

论曰。此是正对问意。于中有二。先遮后许。既非始入故非有学。亦无终出故非无学。又无能住之心故非有学。不无无住之心故非无学。此是俱遮遮止句也。无有学不学是即无学者。以无别所学即不是能学。由是义故许是无学。此依非有学义许是无学也。非无有学是为所学者。虽非有住之观非无无住之行。以是义故许是有学。既有学故下地所学。此依非无学义许是有学也。此是俱许自在答也

经曰。解脱菩萨而白佛言尊者云何如来藏性寂不动

论曰。此下第二问答。前明始觉不异本觉如来藏性。今者正显如来藏性隐藏不动。此中略明如来藏义。如来藏门有二有三。所言三者。如不增不减经言。众生界中示三种法。皆真实如不异不差。何谓三法。一者如来藏本际相应体及清净法。此法如实不虚妄。不离不脱智不思议法。无始本际来有此清净相应法体。二者如来藏本际不相应体及烦恼缠不清净法。此本际离脱不相应烦恼缠不清净法。唯有如来菩提智之所能断。三者如来藏未来际平等恒及有法。即是一切诸法根本。备一切法具一切法。于世法中不离不脱。案云。是显三种如来藏门。何等为三。一者能摄如来藏。住自性时能摄果地如来功德。能摄如来名如来藏故。二者所摄如来藏。谓烦恼缠不清净法一切皆在如来智内。皆为如来之所摄持。如来所摄名如来藏。三者隐覆如来藏。谓法身如来烦恼所覆。如来自隐名如来藏。真谛三藏作如是说。消其文者。言未来际平等恒及有者一心之体遍于三际。然前二门中。已显本际故。此门中明后际等。又欲显其如来之义。谓未来际平等恒者即是如义。言及有者是其来义。如佛性论云。此真如者非如中有如。无非如亦如。二乘如者是非如中如。无非如中非如。云何如是。二乘之人约虚妄观无常等相以为真如。此虚妄观唯因中有果地则无。是故此如或成或坏。菩萨如者离虚妄。约真性以观如故于因果二处无异唯成无坏。乃至广说。故知后际平等恒者正显大乘之如义也。所言及有明来义者。对凡法去显一心来。如凡去时五取蕴法不至果地去而不来。此一心如果地犹有永无过去。故言及有即显来义。如论说言从住自性来至至得。正谓此也。如是一心通为一切染净诸法之所依止故。即是诸法根本本来静门。恒沙功德无所不备。故言备一切法。随缘动门恒沙染法无所不具。故言具一切法。然举染法以望心体不能遍通。所以离脱。若举心体望诸染法。遍诸染法无所不通。故言于世法中不离不脱。不离脱义是隐藏义。此第三门总明一心。通于动静为染净依。第二门者别显动门。染法所依。第一门者别显静门。净法所依。第二中言本际不相应体者。诸烦恼法违反心体名不相应。一心之体随缘动门为彼所依故。是不相应法之体。言及烦恼缠不清净法者。彼能依法依心体转。缠自心体令随染故。合取能依所依之法以为第二如来藏体。唯有如来菩提智之所能断者。唯解脱道能正断故。此义具如二障章说。第一中言本际相应体者。本来静门备恒沙德与心相应故。是相应功德之体。言及清净法者。能依功德性离染故。合取能依所依之法以为第一如来藏体。此法如实不虚妄。不离不脱智不思议法者释相应义。是法身义与诸功德法相应故。如上文言。不离不脱不断不异不思议佛法相应名为法身。是义云何。此一心体略有五相。何等为五。一者远离所取差别之相。二者解脱能取分别之执。三者遍三世际无所不等。四者等虚空界无所不遍。五者不堕有无一异等边。超心行处。过言语道。过恒沙等本有功德亦有五义与体相应。一者一一功德离所取相故非法身所离。与第一相相应。如经言不离故。二者一一功德脱能取执故非法身所脱。与第二相相应。如经不脱故。三者此一一德遍三世际纵无前后际断。与第三相相应故言不断。四者此一一德等虚空界。横无彼此处异。与第四相相应故言不异。五者一一功德皆离诸边非思量境绝言语路。与第五相相应。如经言不思议故。诸功德法有此五义。与体无别融通一味。由是道理名为相应。非如王数别体相应。今此中言不离不脱智不思议法者。诸功德中略举觉义。五相应中略说三义。此是第一能摄藏也。三种藏义略述如之。言二门者如夫人经言。空如来藏者若离若脱若异一切烦恼藏。不空如来藏者不离不脱不异不思议佛法。案云。诸烦恼法皆是虚妄由境不实故虚。由体散乱故妄。妄故无真。虚故无实。无真实故说名为空。能覆如来名如来藏。即是空义。隐覆真也。诸烦恼境不实之相法身所离故曰若离。诸烦恼体妄执之缚法身所脱故言若脱。言若异者。即前虚妄差别分别乖于法身平等性故。以此三义不相应故。是无真实即是空义也。言不空者。一切功德与体相应。体非妄故真。境非虚故实。由真实故说名不空。如来被覆名如来藏。不离不脱等句是释不空之义。义如三种藏门已说。然此中不空如来藏体即前三中第一之法。此中空义是彼第二。而彼三种如来藏中隐覆之义合在第三。故前二中别显能摄所摄二义。今此二种如来藏门欲显空义隐覆真实。故别能覆所覆二义。又此二经互显别义。所以二三两门异释。且止乘论还释本文

经曰。佛言如来藏者生灭虑知相隐理不显是如来藏性寂不动

论曰。生灭虑知相者即是空如来藏。但此文中显能隐义而不名此为如来藏。言隐理不显是如来藏者。是不空如来藏。约所隐义名如来藏。言性寂不动者。显此藏性。虽隐不改。此性有五义。如无相论说。一种类义是性义。如瓶衣等一切色法不离四大种类皆以四大为性。如是众生不出一界。皆用一界为种类故。摄大乘论名体类义。佛性论中名自性义。言有左右意无异也。二者因义是性义。如木中有火性。与火作因故名为性。如是圣人诸无漏法以此为因而得成故。彼二论中同名因义也。三者生义是性义。如炼真金生庄严具。庄严具生以金为性。此界亦尔。能生果地五分法身。法身之生此界为性。摄大乘中亦名生义。佛性论中名至得义。为别因义是在果前故。就已生名至得义。四者不改义是性义。犹如金刚宝性一劫等住无增无减。如是此界三世等住。世间不坏出世不尽。彼二论中名真实义。真实义者是不坏义。所以言异而意同也。五者密藏义是性义。如黄石中有真金性。若不破矿无所利益。随顺炼治即有宝用。是故彼性是隐藏义。如来藏性当知亦尔。不破其缠为外为染。破缠相应成内成净。故知此性是密藏义。佛性论中名秘密义。摄大乘论名为藏义。义同言异。灼然可见。今此文中所言性者含此五义。寂不动者略显后二。寂是密藏义。不动是不改义。故上来正广一觉义竟

经曰。解脱菩萨而白佛言尊者云何生灭虑知相

论曰。自此已下有六问答。因论生论决诸疑难。此一问答明其能隐虑知之相

经曰。佛言菩萨理无可不若有可不即生诸念千思万虑是生灭相

论曰。此答中有二重。先略答后广演。略中二句先举所迷。所迷之理心行处灭。故言理无可不。可者是也。不者非也。理绝四句离诸是非。非分别心之所行处也。次显能迷。若有可不即生诸念者。以有无明不觉平等。即有分别可不之心。由是具起六种染心故。千思万虑是生灭相者。六种染心虽有粗细皆违平等。是生灭相故。如起信论云

复次分别生灭相者略有二种。云何为二。一者粗。与心相应故。二者细。与心不相应故。又粗中之粗凡夫境界。粗中之细细中之粗菩萨境界。细中之细。是佛境界。此二种生灭依于无明熏习而有。所谓依因依缘。依因者不觉义故。依缘者妄作境界义故。若因灭即缘灭。因灭故不相应心灭。缘灭故相应心灭。案云。此中粗与心相应者谓三种相应染。细与心不相应者三种不相应染。粗中之粗者谓执相应染不断相应染皆在六识故凡夫境界也。粗中之细者谓分别智相应染在第七识。细中之粗者谓现色不相应染能见心不相应染。细中之细者谓根本业不相应染。此三皆在第八识位。此中三种细生灭者无明风所动。故言因灭故不相应心灭。于中三种粗生灭者境界风所动。故言缘灭故相应心灭。于中委悉。如彼论疏中说也。今此经言千思者总摄一切不相应染细分别故。万虑者总摄一切相应染心粗分别故。此二皆是动念之相。以之故言是生灭相也

经曰。菩萨观本性相理自满足千思万虑不益道理徒为动乱失本心王

论曰。此下广演。于中有三。一者对生灭相显理满足。二者对理满足明染阙失。三辨顺理灭染去动趣寂之利。初中言菩萨者是呼解脱菩萨之辞。观本性相者佛观本觉如来藏性故。理自满足者所观本觉如来藏理具足无量性功德故。如起信论云

复次真如自体相者从本已来性自满足一切功德。所谓自体有大智慧光明义故。遍照法界义故。真实识知义故。自性清净心义故。常乐我净义故。清凉不变自在义故。具足如是过于恒沙不离不断不异不思议佛法乃至满足无有所少义故名为如来藏。亦名如来法身故。今此经言理自满足。总显如是功德满足也。初段文竟。次明生灭动念之过。于中总明无益有损。如彼论中广释此义云

问曰。上说真如其体平等。离一切相。云何复说体有如是种种功德

答曰。虽实有此诸功德义。而无差别之相。等同一味唯一真如。此义云何。以无分别离分别相。是故无二。复以何义得说差别。以依业识生灭相示。此云何示。以一切法本来唯心实无相念。而有妄心不觉起念。见诸境界故说无明。心性不起即是大智慧光明义故。若心起见即有不见之相。心性离见即是遍照法界义故。若心有动非真识知。无有自性非常非乐非我非净。乃至具足过恒沙等妄染之义。对此义故心性无动即有过恒沙等诸净功德相义示现。若心有起更见前法可念者。即有所少。如是净法无量功德即是一心更无所念。是故满足名为法身如来之藏。今此经言徒为动乱者。以心有动非真识知。无有自性。非常乐我净等故言动也。以心起见即有不见之相等。故言乱也。失本心王者。无量功德即是一心。一心为主故名心王。生灭动乱违此心王不得还归故言失也

经曰。若无思虑即无生灭如实不起诸识安寂流注不生得五法净是谓大乘

论曰。此下第三顺理灭染去动就寂。于中有二。正显重成。此即正显去动就寂。若无思虑者。始从初地乃至佛地。渐顺一心平等法界。永无一切思虑分别故。即无生灭者。由前思虑有生灭相。今无思虑永无分别。二种生灭究竟离故。从此已去顺理不动。穷未来际不复还动。故言如实不起。二种生灭究竟息时。八种识动皆得归静。六染流注永灭不起。故言诸识安寂流注不生。流注不生故法界圆显。诸识安寂故四智满成。故言得五法净。运载之功莫过于此故。总结言是谓大乘。正明去动就寂文竟

经曰。菩萨入五法净心即无妄若无有妄即入如来自觉圣智之地入智地者善知一切从本不生知本不生即无妄想

论曰。此是重显。即有三句。初言入五法净心即无妄者。归心源时即无妄念之不觉故。第二言若无有妄即入如来自觉圣智之地者。不觉尽时即入始觉圆智之地故。是对不觉显始觉满也。第三入智地者善知一切从本不生知本不生即无妄想者。始觉满时能知不觉四相动念本来不生。即知本来无妄想故。是显始觉不异本觉也。如起信论云。一切众生不名为觉。以从本来念念相续未曾离念故说无始无明。若得无念者。即知心相生住异灭。以无念等故。而实无有始觉之异。以四相俱时而有皆无自立。本来平等同一觉故。案云。此中言若得无念即知心相生住异灭者。即显经中善知一切也。而实无有始觉之异者。即显经中善知从本不生也。以四相俱时而有皆无自立本来平等同一觉故者。即显经中知本不生即无妄想也。梦中渡河之喻此中应广说也

经曰。解脱菩萨而白佛言尊者无妄想者应无止息

论曰。此下第二问答明无止息。问意言。本无妄想即无所止。所止无故能止亦无。无能止故应无始觉。如是难也

经曰。佛言菩萨妄本不生无妄可息知心无心无心可止无分无别现识不生无生可止是即无止亦非无止何以故止无止故

论曰。答意有二。先许无止。后遮无止。许者始觉不异本觉故。遮者始觉非唯是本觉故。许中息与止何异者。妄起动故可息。心驰散故可止。而本无起无驰故无可息可止耳。无分者无相分于见故。无别者无见别于相故。相见既无分别。现识本来不生。去来不生。愚智共知故。约现在明本不生。既无所止不觉之生。即无能止始觉之异。依不异门如是许也。亦非无止者。非无不异之始觉故。止无止故者。能止无生之妄心故。虽生不可得而非徒无生故。非徒无生故不无所止。所以非无能止之觉。如是答也

经曰。解脱菩萨而白佛言尊者若止无止止即是生何谓无生

论曰。此下第三问答显无生观。难意云。若有能止之觉。则生能止之观。虽遣不觉之起。还存始觉之生。何谓能证无生观耶

经曰。佛言菩萨当止是生止已无止亦不住于无止亦不住于无住云何是生

论曰。答意有二。先与后夺。与者许生在方便观。能止心生故。且如世第一法之时虽止识生不取于识。而能止心取无而生。当此止时即许是生。以之故言当止是生。过此一念即不取无。不取无故取心不生。以之故言止已无止。此时远离一切分别故。不住于无止之无。亦不取其自无住心。能所永绝。平等平等。云何是时可得是生。如是答也

经曰。解脱菩萨而白佛言尊者无生之心有何取舍住何法相佛言无生之心不取不舍住于不心住于不法

论曰。此是第四问答遣增减见。谓诸学者犹作是念。入观之心取无相理舍诸相事。为遣此增益见故言不取不舍。或作是念。入观之时都无所住法。亦无能住心。如是不异于毕竟无为。除此损减见故言住于不心住于不法。虽非有住而非无住。非无住故得言住也

经曰。解脱菩萨而白佛言尊者云何住于不心住于不法佛言不生于心是住不心不生于法是住不法

论曰。此下第五问答重遣疑情。疑情之言。既言住者即应是心是法。若不心法即应言是不住。此言甚深。云何信解。如是疑也。佛答意言。不存能证观心不存所证理法。故言不生于心。不生于法生犹存也。既恒不存心法。非或失念而存。故言是住不心。是住不法住犹恒也。恒不退失故名为住。住义如是。弥顺不心。何容相违于其间哉。如是正答。下即重显

经曰。善男子不生心法即无依止不住诸行心常空寂无有异相譬彼虚空无有动住无起无作无彼无此得空心眼得法空身五阴六入悉皆空寂

论曰。此下第二重显。于中有二。先显远离诸相周遍三世。后显随顺法界具修六度。初中三句谓法喻合。不生心法者。牒前正答句。即无依止者。横无能依所依之异。不住诸行者。纵无曾当今现之行。无曾当故心常空寂。无能所故无有异相。譬彼已下第二引喻。无有动住者。如世虚空无为常住无有前灭后生之动。喻于不住诸行。亦无能依所依之住。比于即无依止。无起无作。即同心常空寂。无彼无此。不异无有异相。故举虚空。喻不生观也。合中言得空心眼者。由不生能观心得无所不观故。得法空身者。由不生所观法得平等法身故。五阴皆空者。以得空心眼达于三世五阴空故。合前虚空无起作也。六入悉空者。以得法空身。遍于内外六入空故。合前虚空无彼此也

经曰。善男子修空法者不依三界不住戒相清净无念无摄无放性等金刚不坏三宝空心不动具六波罗密

论曰。是第二显具修六度。修空法者者。牒前空寂之心。下别显具六度。不依三界故具施度。不住戒相故具戒度。清净无念故具忍度。无摄无放故具精进。性等金刚故具禅定。不坏三宝故具般若。何以故。唯一观心遍照可轨。绝诸诤论故备三宝。三宝义成故言不坏。唯一空心无别动作而具六度。故言空心不动具六波罗密

经曰。解脱菩萨而白佛言尊者六波罗密者皆是有相有相之法能出世耶佛言善男子我所说六波罗密者无相无为

论曰。此下第六问答重显出世六度之义。问者乘疑而为决之故。举世间六度事相以疑出世心中具六。答中有二。一者略标。二者广释。此即略标。言无相者。离施受等三轮相故。言无为者。离生住等三有为故。我前所说一心具六者。一一皆是无相无为故。此六度是出世间。不同世间有相有为

经曰。何以故善入离欲心常清净实语方便本利利人是檀波罗密

论曰。此下广释。于中有二。先别释后总明。何以故者。因问发起。既有六数。何故无相也。转依真如名为离欲。离三有欲之所显故。观心体解故言善入。更无出入故曰心常。离三轮垢故曰清净。即是上言不依三界。如理而说故言实语。巧便引导故曰方便。虽无功用应机发语犹如天鼓。此之谓也。一切众生唯一本觉。令诸众生同归一觉。以之故言本利利人。是名出世檀波罗密

经曰。至念坚固心常无住清净无染不着三界是尸波罗密

论曰。愍念众生如视一子。故曰至念坚固。恒在世间不住涅槃。故曰心常无住。是防二乘之非。观心明彻。不杂诸漏。故言清净无染。遍涉六道达皆空寂。故言不着三界。是止凡夫之恶。是明不住凡圣戒相。即是上言不住戒相。是名出世尸波罗密

经曰。修空断结不依诸有寂静三业不住身心是羼提波罗密

论曰。上二句者安空理离有结。下二句者静三业泯身心。皆是无生法忍之义。即是上言清净无念

经曰。远离名数断空有见深入阴空是毗梨耶波罗密

论曰。上二句者离粗精义。入空者是进义。即是上言无摄无放。此是出世精进度也

经曰。具离空寂不住诸空心处无在大空是禅波罗密

论曰。具离空寂者。应化受生遍三有故。不住诸空者。不滞五空恒化十方故。此明教化众生禅也。心处无者。虽身涉于三有心常处于理无。理无者。理绝三有之相也。在大空者。虽恒化于十方而心在于大空。大空者。十方大相之空也。此显成就佛法禅也。身虽起作心寂不动。即是上言性等金刚。然大空义略有五种。一者人法二空名为大空。如杂阿含大空经说。瑜伽论中亦同是说。二者般若波罗密空名为大空。如大涅槃经说。楞伽经中亦同是说。三者器世界空名为大空。如解深密经说。中边论中亦同是说。四者阿梨耶识空名为大空。如十地论说。五者十方相空名为大空。如智度论说。今此经文在于第五。且随意便作是说耳

经曰。心无心相不取虚空诸行不生不证寂灭心无出入性常平等诸法实际皆决定性不依诸地不住智慧是般若波罗密

论曰。心无心相者。不存自内观心相故。不取虚空者。不取心虚之空性故。此是证道慧也。诸行不生者。达一切行本来不生故。不证寂灭者。不着无生而恒外化故。此是教道慧也。心无出入性常平等者。前之二道恒不相离。动而常寂寂而恒动。故无出入。动寂恒并不滞一边。故性常平等。诸法实际皆决定性者。演证道之常寂之相。相同真际等法性故。不依诸地不住智慧者。演教道之恒动之由不依着于十重法界。不住滞于寂照慧故。此中即具觉照。可轨。绝诤之义。即是上言不坏三宝。是名出世般若波罗密也。上来别释六度文竟

经曰。善男子是六波罗密者皆获本利入决定性超然出世无碍解脱

论曰。此下第二总明。于中有二。先明六度同一解脱。后显解脱即是涅槃。初中言皆获本利入决定性者。六度始修皆同本觉。本觉显成本利行故。入如来藏性本寂静无始无终无改转故。如是六度得本利故远离妄念流转之相。故曰超然出世入法性故。周遍法界无相无为无缚无脱。故曰无碍解脱

经曰。善男子如是解脱法相皆无相行亦无解不解是名解脱何以故解脱之相无相无行无动无乱寂静涅槃亦不取涅槃相

论曰。是第二明解脱即是涅槃。于中有二。先明解脱。后即涅槃。初中言皆无相行者。六度之行皆同本觉。本觉之相离相离性。故曰无相。六度之行离修离行。故曰无行。行相俱绝故言皆无相行。解脱法相既其如是。何有离缚之解。何有不解之缚。故言亦无解不解。何以故者。何故六度之行而言无相行耶。答此意言。如是六度非但即是解脱。亦乃即是涅槃。是故说言无相行也。解脱之相无相无行者。牒前解脱。无动无乱寂静涅槃者。明即涅槃。欲明如前所说六度之行皆无起动亦无散乱即是本来寂静涅槃。既即是涅槃。何有相行耶。离动乱相故曰寂静。亦离寂静性故亦不取涅槃相也。此中六度解脱涅槃。始从初地乃至佛地。言涅槃者。四种之中即是本来清净涅槃。正是不可思议解脱。依其自在无障碍义。是故说名无碍解脱

问。解脱之义乃有众多。有双道中解脱。有三点中解脱。五分法身之中解脱。十种解脱门中解脱。是诸门内为在何门

答。是三事中解脱。解脱即是涅槃故。欲显六度之行三事之德克实而言。初地已得乃至妙觉位究竟圆满。如经中说。若有菩萨住大涅槃能建大义。乃至广说故

经曰。解脱菩萨闻是语已心大欣怿得未曾有欲宣义意而说偈言大觉满足尊为众敷演法皆说于一乘无有二乘道一味无相利犹如大虚空无有不容受随其性各异皆得于本处

论曰。此下第二重颂。于中在先经家序发。正颂之中有七行颂。于中有二。前六别颂。后一总颂。初中亦二。一者二颂一句颂前略标。二者三颂三句颂后广释。略标中言。诸佛智地入实法相决定性故。方便神通皆无相利。今此颂中初一颂颂。又言一觉了义难解难入。乃至可度众生皆说一味。今此颂中以三义颂。谓前一句是法说颂。次二句引喻颂。后二句合喻颂

经曰。如彼离心我一法之所成诸有同异行皆获于本利灭绝二相见

论曰。此下颂广释文。于中有二。先五句颂广无相观。后二颂半颂广一觉义。广无相中正广重显。今初二句颂正广文。前正广中亦有二分。先方便观。后明正观。今此颂中颂正观文。彼言令彼众生皆离心我。乃至广说远离能所。今此二句正颂此文。言一法者。离有无边。一中道观。以此能离心我执故。重显文中有四问答。今此二句颂前二番问答。所言诸有同异行者。彼初番答中言。一切心相本来无本。如是等文即是同行总相观故。第二番答中言。若有我者令观十二因缘。又言若有我者令灭有见。若无我者令灭无见。若心生者令灭灭性。若心灭者令灭生性。如是等文即是异行别相观故。此同异行所入无异。故言皆获于本利。如前末言。灭是见性即入实际故。又此颂言灭绝二相见者。颂后二番问答。彼第三答中言。见法生时令灭无见。见法灭时令灭有见。今正颂此故言灭二见也。第四答言。生灭俱灭。本生不生。心常空寂。空寂无住。今正颂此故言绝二相也

经曰。寂静之涅槃亦不住取证入于决定处无相无有行

论曰。此下二颂半颂广一觉。广一觉中正广重显。今此颂中唯颂重显。重显文中。有六问答。此中有二。前之一颂颂第六答。次一颂半颂第五答。前四问答略而不颂。第六答中言。入决定性超然出世无碍解脱解脱之相无相无行无动无乱寂静涅槃亦不取涅槃相。今此颂中逆次颂也

经曰。空心寂灭地寂灭心无生同彼金刚性不坏于三宝具六波罗蜜度诸一切生

论曰。此是颂第五答。彼文言。不生心法即无依止不住诸行心常空寂无有异相乃至性等金刚不坏三宝空心不动具六波罗蜜。今此颂中顺次颂也

经曰。超然出三界皆不以小乘一味之法印一乘之所成

论曰。此一颂者总颂前来一品大意。消文大意已如前说

经曰。尔时大众闻说是义心大欣怿得离心我入空无相恢廓旷荡皆得决定断结尽漏

论曰。一品之内有三分中。前之二分竟在于前。此是大文第三时众得益。得离心我者。证二空真如故。断结尽漏者。断见修二惑故。欲显得入初地见道正断见惑兼断修惑。义如弥勒所问论说。于中委悉在二障章也

金刚三昧经论卷上金刚三昧经论卷中

        新罗国沙门元晓述

    无生行品

论曰。菩萨观行成就之时。知自观心顺理修行。非有生心非无生心。亦非有行亦非无行。但为离增益边故假说为无生。不于有生生心。不于无生生心故。为离损减边。亦假说为行。虽非有有行之行。而非无无行之行故。是故立名无生行品

经曰。尔时心王菩萨闻佛说法出三界外不可思议从座而起叉手合掌以偈问曰

论曰。别显观行有六分中。第一遣诸境相显无相观竟在于前。此下第二泯其生心明无生行。就文有三。一者正说。二者赞说。其第三明闻说得益。初正说中有其四分。一者往复问答。二者反征问答。三者菩萨领解。四者如来述成。初中有六。一问二答三难四拒五请六释。初中有二。先经家序。心王菩萨者。从体立名。然心王之义略有二种。一者八识之心御诸心数故名心王。二者一心之法总御众德故名心王。今此菩萨入无生行证一心王故。从所体以立名也。今此品中明无生行。所以心王菩萨发问出三界外不可思议者。是出所闻之法以为发问之本。其所闻者谓前品说。今且举后以摄其前。谓最后颂言。超然出三界乃至所成故

经曰。如来所说义出世无有相可有一切生皆得尽有漏断结空心我是即无有生云何无有生而有无生忍

论曰。此二颂是问辞。于中初颂领前所说。上半领前一味法印。下半领次一乘所成。后一颂正发问。于中上半牒无生义。下半问无生忍。既无有生。应无忍心故

经曰。尔时佛告心王菩萨言善男子无生法忍法本无生诸行无生非无生行得无生忍即为虚妄

论曰。是第二答。答意有二。先示无生忍相。后显有得过失。无生法忍者。达法本无生。是则定慧诸行亦无有生。非于无生。有能忍行。故言非无生行。于中有得能忍之行则乖真忍无住无行。故言即为虚妄

经曰。心王菩萨言尊者得无生忍即为虚妄无得无忍应非虚妄

论曰。是第三难。难意而言。若谓有得有忍是虚妄者。则谓无得无忍应非虚妄。反虚妄故。诸学大乘无所得者。作如是计。自谓非妄。为显彼妄故作是难

经曰。佛言不何以故无得无忍是则有得有得有住是则有生有生于得有所得法并为虚妄

论曰。是第四拒。于中有二。不者直拒。何以故下第二释拒。拒意而言。若彼意谓无得无忍则虽不得有得有忍之有而犹得其无得无忍之无。既得于无者则心住于无。心既有住即是有生。谓有心生于有所得故。亦违于无生无得。是故说言并为虚妄

经曰。心王菩萨言尊者云何无忍无生心而非虚妄

论曰。是第五请。追难路穷意不能诣。故须仰咨。请为将导

经曰。佛言无忍无生心者心无形段犹如火性虽处木中其在无所决定性故但名但字性不可得欲诠其理假说为名名不可得心相亦尔不见处所知心如是则无生心

论曰。此下第六为释。于中有四。先开无得道理。次示无生道理。三者举非。四者明是。初中有三。谓法喻合。初言无忍无生心者。是牒正在法忍之心。言心无形段者。显心无所得。形之言体。段之言分。就诸缘中求心体分。若即若离皆无所得。由是道理故无形段。非谓无色形段相也。喻中火性虽处木中者。喻于忍心。虽处理中。其在无所者。就此木中有诸极微。于中都无火性所在。如是理中有恒沙法门。于中求心永无所在。如是火性无处道理。有佛无佛法性常尔。故言决定性故。火性名下义不可得。如是火性虽不可得而其木中非无火性。欲诠此理说火性名。推析此名但有诸字。转求诸字皆无所得。忍心名相当知亦尔。故次合言。心相亦尔。得忍菩萨知心如是。何得于中能取心生。以之故言则无生心

经曰。善男子是心性相又如阿摩勒果本不自生不从他生不共生不因生无生何以故缘代谢故缘起非生缘谢非灭隐显无相根理寂灭在无有处不见所住决定性故

论曰。此下第二明无生理。于中有二。先喻次合。喻中有二。先明四不。后显八不。言四不者。待缘故不自生。自种故不他生。无作故不共生。有用故不无生。又复未生时无自故不从自生。已生时已有故不须自生。自既不成。待谁有他。自他既无。何得有共。有因而生。既不可得。何况得有无因而生。如是求生皆无所得。言不因生无生者。明不无因而生。谓不能生因无而果得生也。何以故下次释伏疑。疑者意曰。三不可尔。第三云何。意谓果生种子为亲因。地水为疏缘。此二共合故有果生。云何而言不共生耶。是故问言何以故也。缘代谢故者。明彼二缘先代后谢不得暂停。停时既无则无功用。功用无故俱不生果。如偈说言。诸行皆刹那。住尚无况用。故又求代谢。无生无灭。所以然者。既无暂住则无有生。生无有故。则无有灭。故言缘起非生。缘谢非灭。如是推求隐显皆无。隐者种子在土下故。显者芽茎出地上故。根理寂灭者。推其树根及树干理求生果因毕竟无起。故言寂灭。在无有处不见所住。所以然者。决定性故。决定性义如前所说

经曰。是决定性亦不一不异不断不常不入不出不生不灭离诸四谤言语道断无生心性亦复如是云何说生不生有忍无忍

论曰。次明八不。非直法尔。唯前四不亦乃具绝一异等八。所以然者。果种不一。其相不同故。而亦不异。离种无果故。又种果不断。果续种生故。而亦不常。果生种灭故。种不入果。果时无种故。果不出种。种时无果故。不入不出故不生。不常不断故不灭。不灭故不可说无。不生故不可说有。远离二边故不可说为亦有亦无。不当一中故不可说非有非无。故言离诸四谤言语道断。阿摩勒果如是绝言。法忍之心亦不异此。故言无生心性亦如是等也

经曰。若有说心有得有住及以见者即为不得阿耨多罗三藐三菩提般若是为长夜

论曰。此是第三举非。谓有说言无生忍心心体可得住于无生。及与能见无生理者。不了心性。直是妄执能障菩提及其般若。是明不得性净菩提能证般若。又菩提者。始起菩提。言般若者。菩提之因。不得觉因故为长夜。无始妄想是大梦故

经曰。了别心性者知心性如是性亦如是无生行

论曰。此是第四显是。言了别心性者。即以自心了自心性。如经言。若能以其能取作意还能通达能取作意。如是方乃能缘所缘平等平等。无漏智生通达圣谛故。知心性如者。知自观心体性平等故。是性亦如者。是能知用。用性平等故。如是观心体用平等。无生无灭无始无终。以之故言是无生行。上明四不之无生者。显无生理。理通凡圣。今明知如之无生者。明无生行。行别在圣。在圣之行与理一味。遍通之理与智平等。平等一味故圣人所不能异也。有通有别故圣人所不能同也。不能同者即同而异也。不能异者即异而同也。同者辨同于异。异者明异于同。明异于同者非分同为异也。辨同于异者非销异为同也。良由同非销异故不可说是同。异非分同故不可说是异。但以不可说异故可得说是同。不可说同故可得说是异耳。说与不说无二无别矣

经曰。心王菩萨言尊者心若本如无生于行诸行无生生行不生不生无行即无生行也

论曰。此下第二反诘问答。于中有八。一举行难理。二反诘有证。三仰报无证。四反诘有得。五仰报无得。六述无证得。七更陈所疑。八决其所疑。此即第一举行难理。言心若本如无生于行者。举前所说行无生义。谓即前言知心性如是性亦如是无生行。谓无生于生灭之行。即是正举无生行相。言诸行无生者。举理无生。谓诸众生五阴诸行本来无生。生行不生者。明理无生异行无生。谓生起行即空不生非由证理灭心不生。言不生无行者。显理不生类行无生。谓不生门亦无心行。如无生忍无分别行故应即是无生行耶。若如是者一切凡夫莫不证得无生忍矣

经曰。佛言善男子汝以无生而证无生行耶

论曰。此是第二反诘有证。诘意而言。汝于入观无生忍时以依诸行无生之理而得无生行耶。所以如是反诘问者。彼以理无生别异行无生而难理无生亦是行无生故。今诘言。汝入观时理行别异。有能所耶

经曰。心王菩萨言不何以故如无生行性相空寂无见无闻无得无失无言无说无知无相无取无舍云何取证若取证者即为诤论无诤无论乃无生行

论曰。此是第三奉答无证。于中有三。初明无证。二者举非。三者显是。初中亦二。前标后释。如无生行性相空寂者。是总标句。言性空寂。谓观心体性离生灭相。即前所说知心性如也。相空寂者。观心知用。用相亦如。即前是性亦如之谓也。下以十无释此总句。无见无闻者。心性希夷。夷故绝色非像所表。希故绝声非教所诠也。无得无失者。显空而无所得。遣生而无所失故。如是四无释性空寂也。无言无说者。心行既寂不起言说故。无知无相者。心行寂灭远离二分故。无取无舍者。既无分别无性可取无相可舍故。如是六无释相空寂也。无生行中如是空寂。云何于中而有取证。作是答时自知前难不成难也。举非显是。攻即可知

经曰。佛言汝得阿耨多罗三藐三菩提耶

论曰。此是第四反诘有得。问曰。菩萨未得阿耨菩提。如来何故问汝得耶。解云。此虽未得究竟菩提。而已证得初地菩提。如法华论曰。八生乃至一生得阿耨多罗三藐三菩提者。谓证初地菩提故。以离三界中分段生死。随分能见真如佛性名得菩提。非谓究竟满足如来方便涅槃故。案云。是约真如佛性说名菩提。能证见故名得菩提。如经言诸法性空即是菩提。此之谓也

经曰。心王菩萨言尊者我无得阿耨多罗三藐三菩提何以故菩提性中无得无失无觉无知无分别相无分别中即清净性性无间杂无有言说非有非无非知非不知诸可法行亦复如是何以故一切法行不见处所决定性故本无有得不得云何得阿耨多罗三藐三菩提

论曰。此是第五仰报无得。于中有三。谓标．释．结。释中有二。先明所得菩提无所得性。后显能得诸行无能得相。初中言菩提性者。谓真如性虚通无碍性离闇弊故名菩提。于中本无真性可存。亦乃本无妄想可亡。故言无得无失。如是本觉远离思构之觉亦亡率尔之知。故言无觉无知。既无分别之见亦离所行之相。故言无分别相。由如是故非惑所浊。本性离染故言即清净性。纵非生灭所间横非能所所杂。故言性无闲杂。无有言说者。能言所言无不绝故。非有非无者。虽非有如而非无如故。非知非不知者。虽非本觉而非不觉故。菩提性然无可得义。诸可法行已下次显无能得行。如前品说六度之行无非真轨故。言可法亦如是者。同前无得故。一切法行者。六度等行。不见处所者。不见得失觉知乃至有无知不知等所可行处故。与菩提平等平等。所以本无有能得不能得也。云何已下总结无得

经曰。佛言如是如是如汝所言一切心行不过无相体寂无生

论曰。此下第六如来述成。于中有三。一者正述。二者举非。三者显是。初中亦三。总述．别述．后还结成。初言如是如是者。述前无证及后无得。一切已下第二别述。先述无生后述寂灭。言无生者。是无生行。述无能证能得。言寂灭者。是寂灭理。述无所证所得。初言一切心行者。所有出世无分别智相应心行不取诸相证会无相故。言不过无相体于空寂冥然无生故言体寂无生

经曰。可有识识亦复如是何以故眼眼触悉皆空寂识亦空寂无有动不动相内无三受三受寂灭耳鼻舌身心意意识及以末那阿梨耶亦复如是皆亦不生寂灭心及无生心

论曰。此是第二述寂灭义。谓诸世间八识空寂。于中有二。一者例前。二者广释。初言可有识识。总摄所有世间八识。如言处处。摄一切处故。亦如是者。空寂之理同前出世心之无生故。何以故下第二广释。眼者眼根。眼触即是遍行中触。依三和生。令三和合欲明散空故偏举之。识亦空者。眼触既空眼识不生故。无有相续迁动亦无刹那不迁故。言无有动不动相。言内无三受者。三受生起本来寂灭故。诸心数中触受相近。有大胜能故举此二通遣余法也。耳鼻舌身者。谓耳耳触耳识等也。心意意识者。是第六识。未来名心。过去名意。现名意识。依随转门举此三名。为显三世皆空寂故。末那梨耶第七第八皆同眼识故亦不生也。广释文竟。次言寂灭心者。近结八识空寂之文。及无生心者。远结体寂无生之文

经曰。若生寂灭心若生无生心是有生行非无生行内生三受三行三戒

论曰。此是第二举非。谓有所得。大乘学者不空八识违其寂灭。故言生寂灭心。不知出世心之无生。谓有心生证无相理。故言生无生心。直是世间流转之行而乖出世无生忍行。故言是有生行等也。言三行者。身口意作通善不善。言三戒者。身口意止唯取其善。生此三行三戒为因而生三有具受三受。如是流转不得解脱

经曰。若寂灭生心不生心常寂灭无功无用不证寂灭相亦不住于无证可处无住总持无相即无三受等三悉皆寂灭清净无住不入三昧不住坐禅无生无行

论曰。此是第三显是。言若寂灭生心不生者。反前若生寂灭心句。遣诸生心不取生故。心常寂灭无功无用者。反前若生无生心句。离诸生灭起动之相亦无作意分别功用故。不证寂灭相者。虽遣生起之心。不存寂灭相故。亦不住于无证者。虽无取寂灭相不堕无证过故。可处无住者。总明离住着过。诸可住处皆无所住故。可住处者。若遣生起则可住寂灭。若遣有证则可住无证。如是可处皆无住故。总持无相者。总显具功德。谓无生心持诸行德而同一味无差别相故。则无三受等三者。反前内生三受等句。远离流转因果相故。悉皆寂灭者。达三受等本来空故。清净无住者。能达之心无住空故。不入三昧者。能亡世间入定心故。不住坐禅者。亦遣世间住禅静故。若能如是则无生起之心亦无分别之行。故言无生无行也

经曰。心王菩萨言禅能摄动定诸幻乱云何不禅

论曰。此是第七陈疑。疑意而言。凡诸禅定能摄掉动之念令定散乱之心。云何出世无生行心亦不入住于禅定耶。如其不禅则应是动。有如是疑故乘彼问也

经曰。佛言菩萨禅即是动不动不禅是无生禅禅性无生离生禅相禅性无住离住禅动知禅性无有动静即得无生无生般若亦不依住心亦不动以是智故故得无生般若波罗蜜

论曰。此是第八决疑。言禅即是动者。谓世间禅虽非散乱而取境相。取相心生生起动故。能离如是生动之禅乃能得入理定。故言是无生禅。如是理定性无生动。故言禅性无生。非直无生亦无住寂。故言禅性无住。若有生则是相。有住着则是动。今即反此故言离生禅相。离住禅动。上来诸句明理定相。知禅性下显理智相。唯就一体义分为二。知禅性无有动者。知禅性无生故。无有静者。知禅性无住故。即得无生者。得理无生故。无生般若者。得行无生故。亦不依住者。谓无生智不依理住离能所故。心亦不动者。虽不依理住而非生心动故。由如是智能到彼岸。故言般若波罗蜜也。上来八分合为第二反诘问答

经曰。心王菩萨言尊者无生般若于一切处无住于一切处无离心无住处无处住心无住无心心无生住如此住心即无生住尊者心无生行不可思议不思议中可不可说

论曰。此是第三领解。一切处者。一切真俗动寂等处。言无住者。于此一切无所得故。言无离者。于此一切无所不得故。所以然者。彼一切处悉皆非然非不然故。心无住处者。无所住处故。无处住心者。无能住心故。无住无心者。合前二句。以无有处有住之心故。心无生住者。不无无生无住之心故。如此住心者。结前于一切处无住乃至无离。无离之义假说住故。即无生住者。结前心无住处乃至心无生住。住即无住。无住即住故。心无生行不可思议者。离言绝虑故。不思议中可不可说者。以离言亦离离言故。以离言故言不可说。离离言故亦可得说。言可说者。非不然故。不可说者。非是然故。故总说言可不可说。如说言说有可不可。当知其思亦有可不可。但举一边影显之耳

经曰。佛言如是如是

论曰。此是第四述成。如前领解非直契当道理。亦乃仰称佛说。所以重言如是如是。长行正说竟在于前

经曰。心王菩萨闻如是言叹未曾有而说偈言

论曰。此下第二以偈赞说。于中有二。先序后颂。闻如是言者。闻此一品之内佛言也

经曰。满足大智尊广说无生法闻所未曾闻未说而今说

论曰。此下三颂非别颂文但是总叹。于中有四。法喻合结。此是第一法说。赞叹未说而今说者。虽前广说。而今此经言略义丰文省理详。若斯之妙未先说故

经曰。犹如净甘露时时乃一出难遇难思议闻者亦复难无上良福田最上胜妙药为度众生故而今为宣说

论曰。此下二句是第二喻。言甘露者不死之药。以喻此经能出生死。次有四句。是第三合。无上良福田者叹能闻者。最上胜妙药者合所闻法。下之二句第四结也

经曰。尔时众中闻说此已皆得无生无生般若

论曰。此是第三时众得益。地前凡夫闻说此品能得初地无生忍故

    本觉利品

论曰。一切有情无始已来入无明长夜作妄想大梦。菩萨修观获无生时。通达众生本来寂静直是本觉。卧一如床以是本利利益众生。此品显是道理故名本觉利品

经曰。尔时无住菩萨闻佛所说一味真实不可思议从远近来亲如来座专念谛听入清白处身心不动

论曰。别明观行六分之中此下第三明本觉利。依无生行能会本觉。方得普化饶益一切。由是义故次演说之。就文有三。一者广明本觉利益。二者以偈赞颂。三者时众得益。初中有二。一者因动明静略标本利之宗。二者从微至着广说本利之义。初中有三。一者寄身移动以标本利。二者因言往复以标本利。三者放光赞颂本利。初中言无住菩萨者。此人虽达本觉本无起动。而不住寂静恒起普化。依德立号名曰无住。无住之德契合本利。故因此人以表其宗。言一味真实不可思议者。则前品说心无生行不可思议等也。从远近来亲如来座者。其先座处去佛座远。闻前品已迁至近处。表其先时未闻深法。位在凡愚去佛果远。今闻佛说得本觉利。自知当得佛果在近也。专念谛听入清白处身心不动者。已近佛座时专念于谛听。入本清净明白之处。随本觉静身心不动。因此即表入本觉时达本无动得无所得也

经曰。尔时佛告无住菩萨言汝从何来今至何所无住菩萨言尊者我从无本来今至无本所

论曰。此下第二因言往复。于中有三。问．答．述成。第二答意明从凡位来至圣位。至圣位时顾寻古今。古在凡位始发趣时自信己心本无起动。起动之本不可得故。今至圣位得无生时证知自心本来无生。生起之本无所得故。故知始从无本处来。今所至处亦无本所。既举无本。当知无末。无末无本者。无来无至矣。但仰顺佛问之辞假寄来至之言。虽复不有来至而非都无来至故。故因来至显无来至。至所来处同无本故

经曰。佛言汝本不从来今亦不至所汝得本利不可思议是大菩萨摩诃萨

论曰。此是述成。述成意言。来处至处既同无本。无本处同则无来至。所以然者。来处不异于至处故。本无从来。至处既同于来处故今无所至。又复来处既无本故无来不来。今所至处亦无本故无至不至。既无来无至本来寂静。故言汝得本利不可思议。既得本利自利利他。故言是大菩萨摩诃萨也

经曰。即放大光遍照大千界而说偈言大哉菩萨智慧满足常以本利利益众生于四威仪常住本利导诸群庶不来去去

论曰。此下第三如来放光表赞菩萨。于中有二。先经家序。所以放大光明照大千界者。为表得大智慧光明照世间闇令得光明故。证成如来前所赞故。大哉菩萨者。别赞无住菩萨。智慧满足者。以无所知无所不知故。于四威仪常住本利者。如前所序从远近来亲如来座。因此示现本觉利故。不来去去者。寂而恒化故。言不来者。随所导化令得出世不退还故。言去去者。随得不退展转出离而善逝故

经曰。尔时无住菩萨而白佛言尊者以何利转而转众生一切情识入唵摩罗

论曰。此下第二广演本利之义。于中有二。一者直广。二者重演。初直广中先问后答。以何利转者。是问能化转利义。问前导诸之句。而转众生等者。是问所化转诸识义。问前去去之句。一切情识即是八识。唵摩罗者。是第九识。真谛三藏九识之义依是文起。如彼章说

经曰。佛言诸佛如来常以一觉而转诸识入唵摩罗何以故一切众生本觉常以一觉觉诸众生令彼众生皆得本觉觉诸情识空寂无生何以故决定本性本无有动

论曰。是答正广本利之义。于中有二。先标后释。诸佛如来常以一觉者。是标能化之本。而转诸识入唵摩罗者。是标所化之转。释中有二。正释转释。正释中言一切众生本觉者。释前能化之本一觉。一切众生同一本觉故言一觉。诸佛体此乃能普化故言常以。以此本觉令他觉故。故言常以一觉觉诸众生。令彼众生皆得本觉者。是释所化转入之句。本觉正是唵摩罗识。得本觉者。是释入义。入本觉时觉诸八识本来寂灭。觉究竟故诸识不生。故言诸识寂灭无生。是句正释转诸识句。此文具显本始二觉。谓一切众生本觉等者。是本觉义。觉诸情识寂灭无生者。是始觉义。是显始觉即同本觉也。何以故下第二转释。释前始觉所觉寂灭。虽诸八识随缘动转。而求定性皆无所得。故言决定本性本无有动。本无动故本寂灭也

经曰。无住菩萨言可一八识皆缘境起如何不动

论曰。此下第二重演。于中有二。先演始觉。后演本觉。初中亦二。一演诸识空寂。二演诸识无生。前是始觉之所觉。后是能觉之始觉。初中即有六番问答。于中有三。一者前二问答正明空寂。二者第三问答明不同相。三者后三问答明不异相。此初问答明无起动。言可一者。一切之谓。谓一切众生所有八识。皆缘境起者。四缘之中且举缘缘以难不动

经曰。佛言一切境本空一切识本空空无缘性如何缘起

论曰。且遣境缘显识无起

经曰。无住菩萨言一切境空如何见佛言见即为妄何以故一切万有无生无相本不自名悉皆空寂一切法相亦复如是一切众生身亦如是身尚不有云何见

论曰。此下第二问答明见是妄。妄故真空。谓境空故见有境即是妄。见亦空故计有见亦是妄。释中有二。总明别显。总明者。阴界等有本不自名我为色等。但由妄心名为色等。是故一切悉皆空寂也。别显中言一切法相亦如是者。谓外山河等六尘法相。一切众生身亦如是者。内色受等五阴之身。身体尚无。何有见用故

经曰。无住菩萨言一切境空一切身空一切识空觉亦应空佛言可一觉者不毁不坏决定性非空非不空无空不空

论曰。此下第三番明觉不觉之不同相。问意言觉亦应空者。从缘生识既空。从缘起觉亦空。识既空故其见是妄。觉亦空故其觉亦妄也。佛答意言一切觉者。不坏道理故非可空。不存自性亦非不空。是故觉中无空不空。诸识不尔。妄取诸法违反真理。可空可遣。如是不同。何得相类也。决定性者。谓真如性不可破坏。性自尔故。言不毁者。不取有相。以伤空故。言不坏者。不计无性。以损真故。谓不毁坏于决定性也

经曰。无住菩萨言诸境亦然非空相非无空相佛言如是彼可境者性本决定决定性根无有处所无住菩萨言觉亦如是无有处所佛言如是觉无处故清净清净无觉物无处故清净清净无色

论曰。此下三番明不异相。于中前二番明觉与境同相。后一问答显觉与识同相。初中前番明境同觉。谓诸妄境本来不有。既无其有。何有空相。既非有空。何得无空。故言非空相非无空相。以此而言则不异觉。答中言性本决定者。明本不有故非空相。无有处所者。明非有空故非无空也。后番问答明觉同境。觉亦如是者。觉亦缘生。本性空故。答中言清净无觉者。觉空之理离一切相故曰清净。觉性既空空中无觉。如色空中无色相故。前明境同觉者。以境非空非不空义同于前觉非空非不空义。今明觉同境者。以觉性空无相之理同于境空无相之义。二文不同应如是知

经曰。无住菩萨言心眼识亦复如是不可思议佛言心眼识亦复如是不可思议何以故色无处所清净无名不入于内眼无处所清净无见不出于外心无处所清净无上无有起处识无处所清净无动无有缘别性皆空寂

论曰。此第三番明识同觉。心眼识者。谓眼识种子积集之心及此种子所起眼识。略举此二标其性空。下就四缘明眼识空。色无处所者。色性自空故。清净无名者。空中无色故。不入于内者。不与眼根作境界故。是明所缘缘空也。眼无处所清净无见者。眼性空中无眼根故。不出于外者。无能行于色境界故。是明增上缘空也。心无处所清净无上者。种子空中无种子故。四缘之内为上首故。无有起处者。无亲起识之处所故。是明因缘空也。识无处所清净无动者。既无三缘眼识不起故。无有缘别者。以无缘色了别识故。是明等无间缘及眼识空。缘者前灭之缘。别者后生了别。此二皆空故言无有。如是四缘及识皆空故。总结言性皆空寂。如说眼识四缘皆空乃至意识应如是说。谓法无处所清净无名不入于内。意无处所清净无见不出于外。心无处所清净无上无有起处。识无处所清净无动无有缘别性皆空寂。此中意者是第七识。此中心者是第八识。是明八识。皆悉空寂所以同于一切觉空也

经曰。性无有觉觉则为觉善男子觉知无觉诸识则入何以故金刚智地解脱道断断已入无住地无有出入心处无在决定性地其地清净如净琉璃性常平等如彼大地觉妙观察如慧日光利成得本如大法雨入是智者是入佛智地入智地者诸识不生

论曰。是第二明诸识不生。欲明本随无明诸识生起。今随始觉还归心源。归心源时诸识不起。识不起故始觉圆满。于中有二。略标广释。标中亦二。初言性无有觉觉即为觉者。是标始觉圆满章。觉知无觉诸识则入者。是标诸识不生章。言性无有觉者。谓空性中非但无识亦无始觉。觉知无觉之理则为始觉之智故言觉则为觉。言觉知无觉者。牒前始觉。始觉圆时八识不起。随觉无觉无诸识故。随觉究竟归心源故。故言诸识则入。何以故下释中有二。先明因满。后显果圆。金刚智地者。谓等觉位始觉因满。金刚喻定义如前说。今约觉因名金刚智。解脱道断者。不生因满。然此中断有其二义。若对生得无明住地。即金刚心为无间道。妙觉初心为解脱道。无间道时与无明俱。解脱道起方能正断。若对诸识戏论种子。则其前心为无间道。与彼种子俱起俱灭。最后一念金刚喻定是解脱道。正断种子。今约断其种子义门故言金刚解脱道断。此时现有异熟识者。由其前念种子所生。生起因果不同时故。此后异熟不更生者。此时已断一切种故。故知此言解脱道断正是诸识不生之因。次显其果。于中有二。先明觉圆满。后显识不生。初中言断已入无住地者。金刚解脱断种子已即入妙觉无住之地。二谛之外独在无二故言无住。无住之心双泯二谛故无出俗入真之异。既无出入不在空有故言心处无在。无在之处唯是一心。一心之体本来寂静故言决定性地。一心显时八识皆转。故于是时四智圆满。所以然者。即此一心离闇成明。明白清净无影不照故言其地清净。如净琉璃。是显大圆镜智之义。即此一心远离二边通达自他平等无二故言性常平等。如彼大地。是显平等性智之义。如是一心无所观故于诸法门无不观察。故言觉妙观察。如慧日光。是明妙观察智之义。如是一心无所作故于利他事无所不作。故言利成得本如大法雨。雨润万物令成果实。此智亦尔。利他事成令得本觉。是明成所作智之义。四智既圆是始觉满也。入是智者已下次显诸识不生。得是四智正是妙觉之位。故言是入佛智地。是时既归一心之源。八识诸浪不更起动故。入智地者诸识不生也。上来二分演始觉竟

经曰。无住菩萨言如来所说一觉圣力四弘智地即一切生本根觉利何以故一切众生即此身中本来满足

论曰。此下第二演本觉义。于中有二。一者正明。二者遣着。初中亦二。先明本觉无二之理。后示除障入证之门。初中亦二。先问后答。问中言一觉圣力四弘智地者。领次前说四智之义。始觉圆满即同本觉。本始无二故名一觉。无所不为故言圣力。一觉之内俱四大智持诸功德。故言智地。如是四智同一心量皆无不周。故名弘智。如是一觉即是法身。法身即是众生本觉。故言即一切生本根觉利。本来具有无量性德熏众生心作二种业。故名本利。由是本觉无二义故无一众生出法身外。故言即此身中本来满足

经曰。佛言如是何以故一切众生本来无漏诸善利本今有欲刺为未降伏

论曰。是答述许所问。明本觉中无量性德不为三漏之所染动。故言本来无漏。以此为本生诸善利。故言诸善利本。虽有本觉而由客尘欲刺所覆故。今未得自本觉耳

经曰。无住菩萨言若有众生未得本利犹有采集云何降伏难伏佛言若集若独行分别及与染回神住空窟降伏难调伏解脱魔所缚超然露地坐识阴槃涅槃

论曰。此下第二示其除障入证之门。于中有二。先问后答。问中言采集者。明三有欲取生死果故言采。此诸烦恼与心相应故言集。从无始来现行不绝故言难伏。治道方生其力微劣。云何能伏。如是疑也。答中有三。先出所伏。次明能伏。后显降伏所得胜利。若集若独行者。众生心行粗细不定。或时烦恼相应故集。或时离惑心行故独。离烦恼时犹有法执分别。烦恼俱时即为烦恼所染。故言分别及与染也。次明能伏。谓。依佛经回其心神。遣人法相住二空理。故言回神住空窟。此心方起而顺道理。故有胜能。彼惑无始而逆道理故不能敌。故言降伏难调伏。是明地前伏除二障。由是伏道入断道位。渐拔种子乃至永尽。永尽之时远离四魔。故言解脱魔所缚。次明降伏所得胜利。胜利有二。谓菩提果及与果果。菩提果者。超出有漏五阴聚落坐于道场得无上觉。故言超然露地坐。言果果者。以无上觉证大涅槃。觉知无觉诸识皆入。故言识阴般涅槃也

经曰。无住菩萨言心得涅槃独一无伴常住涅槃应当解脱

论曰。此下第二遣着。于中有二。先明无住以遣有住之着。后示无得以除有得之执。初中有二。先问后答。问中言独一者。八识转时成一觉故。言无伴者。人法二执斯远离故。无伴之觉常住于涅槃。常住之智解脱一切缚。有作是执故作是问也

经曰。佛言常住涅槃是涅槃缚何以故涅槃本觉利利本涅槃涅槃觉分即本觉分觉性不异涅槃无异觉本无生涅槃无生觉本无灭涅槃无灭涅槃本故无得涅槃涅槃无得云何有住善男子觉者不住涅槃何以故觉本无生离众生垢觉本无寂离涅槃动住如是地心无所住无有出入入唵摩罗

论曰。是答正遣有住之执。于中有二。初略破执。后广显理。初中言常住涅槃是涅槃缚者。设有常觉住于涅槃即是执着缚于涅槃。云何常住是解脱耶。何以故下广显道理。理无住故有住违理。违理之心非缚是何。释意如是。于中有二。先约本觉以明无住。后约始觉以显无住。初中约无异义以明无得无住。此无异义有其四种。一者本理无异。如经涅槃本觉利。利本涅槃故。是明涅槃。是本觉利。此本觉利是本涅槃。其始觉者即同本觉。所以无异故无得也。二者觉分无异。如经涅槃觉分即本觉分。是明涅槃众德。即是本觉之德。无异无得如前说也。三者一味无异。如经觉性不异涅槃无异。是明觉性一味无差别相。即是涅槃之无差别。四者无二无异。如经觉本无生。涅槃无生觉本无灭涅槃无灭。是明本觉本无生灭。即是涅槃之无生灭。由是四种无异道理本无异故无得涅槃。是明无能得涅槃觉。次言涅槃无得者。是明涅槃无所得义。既无能得所得。何有能住所住。以之故言。云何有住。即显常住不应道理。次约始觉以明无住。先标后释。言觉者者。谓始觉者。释中言觉本无生者。觉知生死本来无生。所以离着生死之垢也。言觉本无寂者。觉知涅槃本无寂静。所以离入涅槃之动。心无所住者。不住生死及涅槃故。无有出入者。不见俗有及真空故。入唵摩罗者。一心之体离二边故。归此心源故名为入。如是无住方得解脱。故住涅槃不离缚也

经曰。无住菩萨言唵摩罗识是有入处处有所得是得法也

论曰。此下第二遣有得执。于中有四。一者正明无得。二者重遣疑情。三者领解。四者述成。初中有二。先问后答。依前入言如言取义。谓无垢识有所入处。入时证得故有所得。有作是疑故作是问

经曰。佛言不何以故譬如迷子手执金钱而不知有游行十方经五十年贫穷困苦专事求索而以养身而不充足其父见子有如是事而谓子言汝执金钱何不取用随意所须皆得充足其子醒已而得金钱心大欢喜而谓得钱其父谓言迷子汝勿欣怿所得金钱是汝本物汝非有得云何可喜

论曰。是答正明无得之义。于中有三。谓法．喻．合。初言不者。总非有得。何以故下喻显无得。于中有四种喻。一者迷子不知有金钱游行贫苦喻。二者其父示子有金钱令得充足喻。三者喜得金钱喻。四者告非有得喻。初喻中言迷子者。谓诸众生迷自心源。如来大悲如视一子。故喻迷子。法华穷子局喻声闻。此中迷子通喻群生。手执金钱者。喻诸妄识。五缚烦恼执着分别。覆自净心不知有故。游行十方者。遍计五相及五事故。经五十年者。受五阴生五十恶故。贫者少有世间善故。穷者都无出世财故。困者或堕三途受剧苦故。苦者或生人天受轻苦故。专事求索者。求世间乐作福业故。而以养身者。受人天乐而受用故。而不充足者。受世间乐弥增渴爱盛必有衰无义利故。第二喻中其父见子者。佛归心源同体大悲。为诸众生作慈父故。有如是事者。有如初喻所说事故。而谓子言者。为众生说大乘教故。汝执金钱何不取用者。示有净心应信解故。随意所须皆得充足者。若用净心本觉胜利法身慧命得圆满故。第三喻中其子醒已者。闻大乘教而生信解。位在地前故。而得金钱者。得入初地正通达位。证见佛性本觉利故。心大欢喜者。后得智中念当现得生极喜故。而谓得钱者。出观失念有漏心中故起法执。谓有得故。第四喻中所得金钱是汝本物者。示其所证本觉之利本来属汝非始有故。汝非有得云何可喜者。既本属汝非今始得。不宜于得生着心故。汝勿欣怿者。遮其分别。谓有所得于中生着而欣怿故

经曰。善男子唵摩罗者亦复如是本无出相今则非入昔迷故非无今觉故非入

论曰。是第三合。于中有二。总合别合。总合中言唵摩罗者。此云无垢。本觉本净性无改转似彼金钱性无改故。又金有四义喻。本觉中常乐我净通合四喻中金钱也。别合中有四句。本无出相者。合初喻中手执金钱故。今即非入者。合第三喻而得金钱。昔迷故非无者。合第二喻。汝执金钱何不取用。是昔迷故不用。而手执故非无也。今觉故非入者。合第四喻。是汝本物汝非有得。今觉本物不出自心。既本不出何得有入。非有入故非有得也

经曰。无住菩萨言彼父知其子迷云何经五十年十方游历贫穷困苦方始告言佛言经五十年一念心动十方游历远行遍计

论曰。此下重遣疑情。三番问答次第遣疑。此初番者。问依喻疑。答就法遣。答意而言经五十年。喻于一念心动。十方游历。喻于远行遍计。斯则一念之顷遍计诸法。即于此念其父告言。告言之时即得醒悟。念究竟时得无所得。如觉金钱而无所得。所以父告非为经久。但为显一念具五十恶故。喻中说经五十年耳。答意如是。是义云何。谓由无明力而起四相。四相无明和合力故。能动一心生住异灭。一心既动带此四相。是故说名一念心动。如起信论云。自性清净心因无明风动。乃至广说。于中委悉。如彼记说

经曰。无住菩萨言云何一念心动佛言一念心动五阴具生五阴生中具五十恶

论曰。是第二番遣第二疑。显所治恶。欲明一念四相摄诸生死故具五阴有五十恶。云何五阴具五十恶。谓识阴有八。即是八识。受想二阴随识各八。行阴有九。八是相应。一不相应。色阴十七合为五十。言十七者。能造四大。所造十三。谓五根．五尘．法处所摄有三种色。如显扬说。谓律仪色．不律仪色．及定自在所生色故。且就一门立为五十。如是五十是真实恶。皆是流转违涅槃故。对彼涅槃真实善故

经曰。无住菩萨言远行遍计游历十方一念心生具五十恶云何令彼众生无生一念佛言令彼众生安坐心神住金刚地静念无起心常安泰即无一念

论曰。是第三番遣第三疑明能治道。令彼众生者。十信已前一切众生故。安坐心神者。十住已去安心三空决定不退名安坐故。住金刚地者。初地已上证得法身。离诸灭坏如金刚故。静念无起者。等觉位中觉其动念本来寂静令不起故。心常安泰者。至妙觉位得见心源无起无灭。本无动念。无始无终。无起灭故常。无动念故安。无始终故无不泰然。如是修行得究竟觉。即无生死一念四相。以之故言即无一念。为显是义故。起信论说言。初发意菩萨等觉于念异念无异相。以舍粗分别执着相故名相似觉。如法身菩萨等。觉于念住念无住相。以离分别粗念相故名随分觉。如菩萨地尽满足方便一念相应。觉心初起心无初相。以远离微细念故。得见心性。心即常住名究竟觉。案云。此中得见心性心即常住。即释此经心常安泰之句。余句准释如前应知。上来大分演本觉竟

经曰。无住菩萨言不可思议觉念不生其心安泰即本觉利利无有动常在不无无有不无不无不觉觉知无觉本利本觉觉者清净无染不变不易决定性故不可思议佛言如是

论曰。此是第三领解第四述成。不可思议者。总领叹深。下别领解。于中有二。先领言句。后领义理。言觉念不生其心安泰者。领前静念无起心常安泰之句。此是始觉之究竟处。下领义理云。即本觉利者。领无始觉异本觉义。如论说云。若得无念者。即知心相生住异灭以无念等故而实无有始觉之异。以四相俱时而有皆无自立本来平等同一觉故。案云。实无始觉之异者。是释经中即本觉利之句。四相俱时而有皆无自立本来平等者。是释经中利无有动。如是始觉觉知无异故。以能得常在不无。言常在者。直谓不无。然此中言常而无当有。故言无有不无。既无当于有始觉故。虽不无觉而不有觉。故言不无不觉。觉知如是无觉道理。即知始觉不异本觉故。觉知无觉本利本觉。如是究竟觉知之者。远离无明所覆故清净无染。清净者。本来净故。无染者。今离染故。永无生住异灭故不变不易。不易者。无生住故。不变者。无异灭故。若如是者。即同真际等于法性。故言决定性故。既同平等离言绝虑。故言不可思议。前已言不思议。今重言不思议者。亦不可思议于不可思议故。佛言如是者。第四述成文。如前所领解。不违道理故

经曰。无住菩萨闻是语已得未曾有而说偈言尊者大觉尊说生无念法无念无生心心常生不灭一觉本觉利利诸本觉者如彼得金钱所得即非得

论曰。此是第二以偈赞颂。颂中有三。初之二句总赞能说。次有四句颂前法说。后有二句颂彼喻说。初言说生无念法者。说诸众生成无念法究竟觉故。无念无生心者。无生死念成无生心故。言心常生不灭者。略颂演文。彼言心常安泰乃至常在不无故。生之言在。灭之言无。故一觉本觉利利诸本觉者者。彼诸众生无无本觉。是故说言诸本觉者。下之二句颂前四喻。总颂可知

经曰。尔时大众闻说是语皆得本觉利般若波罗密

论曰。此是第三闻法得利。随所说义随得利故得本觉利。始觉般若平等无异。如前说故

    入实际品

论曰。言实际者。离虚之称。究竟之义离幻究竟故名实际。依教修理。理入行入。故名为入。然实际以无际为际。二入是无入之入故名入实际品

经曰。于是如来作如是言诸菩萨等本利深入可度众生

论曰。别明观行六分之中第三依本利物分竟。此下第四从虚入实。又前品明心生灭门。今此品显心真如门。就文有四。一者略标大意。二者广显道理。三者身子领解。四者时众得益。初中有二。先开令入方便。后示所入实际。开方便中总标别开。此文总标令入大意

经曰。若后非时应如说法时利不俱顺不顺说非同非异相应如说引诸情智流入萨般若海无令可众挹彼虚风悉令彼庶一味神孔

论曰。此是第二别开方便。于中即开四种方便。一者知时方便。二者识机方便。三者引入方便。四者出离方便。知时方便者。如经若后非时应如说法时利不俱故。后有三义。佛灭度后故。正法灭后故。五重五百中后五百岁故。言非时者。非纯熟时故。非易悟时故。异见盛兴相非时故。若于如是非时直应真如说法不当彼时无所利益。时利不并故言不俱。是为知时方便。识机方便者。如经顺不顺说非同非异相应如说故。顺不顺说者。若直顺彼心说则不动邪执。设唯不顺说者则不起正信。为欲令彼得正信心除本邪执故。须或顺或不顺说。又复直顺理说不起正信。乖彼意故。不顺理说。岂生正解。违道理故。为得信解故顺不顺说也。若诸异见诤论兴时。若同有见而说则异空见。若同空执而说则异有执。所同所异弥兴其诤。又复两同彼二则自内相诤。若异彼二则与二相诤。是故非同非异而说。非同者。如言而取皆不许故。非异者。得意而言无不许故。由非异故不违彼情。由非同故不违道理。于情于理相望不违故言相应如说。如者而也。引入方便者。如经引诸情智流入萨般若海故。诸情者。大小情欲差别故。诸智者。空有知见差别故。引接此辈皆顺道流。令入一觉一切智海。无上菩提深广义故。如百川流同入大海。大海深广同一味故如是名为引入方便。出离方便者。如经无令可众挹彼虚风悉令彼庶一味神孔故。挹者斟也。是取纳义言虚风者。谓游空风。能起诸浪。喻诸境界动诸识浪。可度众生挹境界风故。从前来诸识浪转。今无令挹识浪静息也。庶者庶几。是希望义。言神孔者。谓神仙窟。远离城邑无事闲静长生之处。喻大涅槃不死之宅。圆寂平等故名一味。令彼众生希大涅槃。止诸识浪出离流转。如是名为出离方便

经曰。世间非世住非住处五空出入无有取舍何以故诸法空相法性非无非无不无不无不有无决定性不住有无非彼有无凡圣之智而能测隐诸菩萨等若知是利即得菩提

论曰。是示所入道理。于中有四。一者略明。二者重释。三者偏执不当。四者达者胜利。初中言世间非世者。世间五法无所有故。住非住处者。常住涅槃无所得故。修观行者达五空时。出有入空故言出入。入空之时不取空性。虽不取空而不舍空。以之故言无有取舍。既入五空。何故不取。若无取者如何不舍。为答是问故。第二释诸法空相法性非无。故说入空。非无不无不无不有。故无取舍。言非无者。谓法性理。不同免角故。言不无者。谓观行者而不遣故。不遣之者非无理故。言不有者。谓观行者亦不存故。不存之者非有理故。法性如是非定有无。是故达者不住二边。故言无决定性。不住有无。由是道理故无取舍。第三中言非彼有无凡圣之智者。凡夫存有而背于空。二乘背有而趣空寂。如是不离有无之智而能测量安隐法性者。无有是处故言非也。第四中言诸菩萨者。地前菩萨若知法性不有不无者。初发心时便成正觉。故切言即得菩提。谓即发心知法性时。是时即得无上菩提。是义出华严经发心功德品也。上来诸文每言决定性故。何故此中乃言无决定性是不相违。所以然者。无决定义无改定故

经曰。尔时众中有一菩萨名曰大力即从座起前白佛言尊者如如所说五空出入无有取舍云何五空而不取舍

论曰。此下第二广显道理。于中即以四门分别。一显实际义。二明趣入义。三开入之阶位。四示入之方便。初中亦四。一名五空。二明三空。三明空是真。四明真是如。初中有二。先问后答。问者名大力者。此人得入实际法门。遍周法界。无所不为得大自在。故名大力。故于是门开发显扬。言如如者。佛所说言契当如理故。前如是当义。后如是道理。先领后问。问其二义。一问五空法门。二问无取舍义

经曰。佛言菩萨五空者三有是空六道影是空法相是空名相是空心识义是空菩萨如是等空空不住空空无空相无相之法有何取舍入无取地即入三空

论曰。如其次第答前二问。五空即显三种真如。何等为三。一流转真如。二实相真如。三唯识真如。是义具如显扬论说。此中前二空即前二真如。后三空是第三真如。是义云何。初三有是空者。由三有爱流转三界。三界流转无前后性。刹那无住空无所得。即是流转真如门也。第二六道影是空者。由善恶业各二品故。六道果报似本现影。影无离本空无所得。即是实相真如门也。后三唯识真如门者。前二是遣所取义名。名义互客不成实故。后一是遣能取心识。能所相待不独立故。唯识道理最难可入。故开三空遣其能所。能所空故得无分别。菩萨已下答第二问。如是等空者总举五空辨其理智。空不住空者。空智无住与理平等故。空无空相者。空理无相与智平等故。理智平等无能所相。何容取舍于其间哉。所以入中即入三空。无取地者。谓十地也

经曰。大力菩萨言云何三空佛言三空者空相亦空空空亦空所空亦空如是等空不住三相不无真实文言道断不可思议

论曰。此一问答是明二空。空相亦空者。空相即是遣俗显真。平等之相亦空。即是融真为俗。空空之义如销真金作庄严具。如涅槃经言。是有是无是名空空。是是非是是名空空。是明俗谛有无是非差别之相是空空义。空于平等空显俗差别故。故此差别名为空空。空空亦空者。空空即是俗谛差别。亦空还是融俗为真也。如销严具还为金瓶。第三中言所空亦空者。谓初空中空所显俗。第二空中空所显真。此二无二故言亦空。是融一谛显一法界。一法界者。所谓一心。然初空门内所遣俗者是所执相。第二空中所融俗者是依他相。俗有二种相故所遣所融非一也。又初门内遣俗所显之真。第二空中融俗所显之真。此二门真唯一无二。真唯一种圆成实性。所以遣融所显唯一。第三空者非真非俗非二非一。又此三空。初空显俗谛中道。次空显真谛中道。第三空显非真非俗无边无中之中道义。言如是等空者。总举三空。不住俗相。不住真相。亦不住于无二之相。故言不住三相。如是不住究竟显实故言不无真实。虽不无实而非有实。由如是故文言道断。道断之言亦不可寄故亦说言不可思议

经曰。大力菩萨言不无真实是相应有

论曰。此下第三明空不无真而不有真义。先问后答。问意而言。凡言有无必也相对。不有必无。不无即有。若言不无真实之理则应是有真实之理。凡诸学者每作是计。为遣彼执故作是问

经曰。佛言无不住无不无不有不有之法不即住无不无之相不即住有非以有无而诠得理菩萨无名义相不可思议何以故无名之名不无于名无义之义不无于义

论曰。答中有二。一者正答。二者叹深。初中言无不住无者。先言不无真实句中谓无之名不住无义。是故不无之名亦不当于有义。以之故言不无不有。是明无名之名不当有义之义不有之法不即住无者。虽融俗为真而不守真无之法故。不无之相不即住有者。虽融真为俗而不守俗有之相故。以真俗不住有无故。不无真实无二之理。真俗不无二谛故。不有真实无二之理。故言非以有无而诠得理。是明无义之义不称有名之名。菩萨已下第二叹深。于中有二。直叹释叹。无名之名不无于名者。佛所说名不当有义之义故为无名之名。而当无义之义故言不无于名也。无义之义不无于义者。佛所体义不称有名之名故为无义之义。而称无名之名故言不无于义也。如是不有名义而亦不无名义。由是道理不可思议也

经曰。大力菩萨言如是名义真实如相如来如相如不住如如无如相相无如故非不如来众生心相相亦如来众生之心应无别境

论曰。此下第四明真不有如而无不如义。于中有二。先问后答。问中亦二。先立道理。后问所疑。言如是名义者。如前所说不可思议之名义相。名义相称无倒无变故名真实。如是名义远离能所一味平等故名如相。如是名义平等如相诸佛如来所体故言如来如相。如不住如者。是明无名之如名当于无如之如义。如无如相相无如故者。无如相之如相称于无名之如名。如是称当能所平等故。若名若义非不如来也。相无如者。如相无如。如相正是无相为相。当知如无如相是明不有如之无相。相无如者。是明不有无相之如。如之体相虽是不有而亦不无如之体相。如是无如相之如相方称无名之如名也。众生心相相亦如来者。谓诸众生分别心相相即非相无不平等。是故彼相亦是如来。上来正立平等道理。次言众生之心应无别境者。是问所疑。众生心相既是如来。则众生心应无别境。无别境者。即无分别。无分别故应无染污。无染污故即无三界。有作是疑故作是问

经曰。佛言如是众生之心实无别境何以故心本净故理无秽故以染尘故名为三界三界之心名为别境是境虚妄从心化生心若无妄即无别境

论曰。是答所疑。先与后夺。与者就自性净。本无染故。夺者约随他染。有别境故。自性净者。如宝性论引经说言。善心念念灭不住非烦恼所染。不善心念念灭不住非烦恼所染。烦恼不触心心不触烦恼。云何不触法而能得染心。乃至广说故。即是染而不染门也。随他染者。夫人经言。自性清净心难可了知。彼心为烦恼所染亦难可了知。即是不染而染门也。心本净故理无秽故者。自性净心本觉之理非诸尘秽之所入故。以染尘下夺其所问。于中先显不觉染尘。后对不觉略示始觉。不觉中言以染尘故名为三界者。住地烦恼略有三种。谓欲爱住地。色爱住地。有爱住地。以此住地起三界爱。三界爱故三界心生。由是妄心。变作虚境。以之故言从心化生。次明始觉。心若无妄者。依理观行妄心不生故。即无别境者。妄作境界随心灭故。上来四门合为第一广实际义

经曰。大力菩萨言心若在净诸境不生此心净时应无三界佛言如是菩萨心不生境境不生心何以故所见诸境唯所见心心不幻化即无所见

论曰。此下第二广趣入义。于中有四。一者总明趣入。二者别显趣入。三者入之离过。四者入之离边。初中有二。先问后答。问中言此心净时应无三界者。初地已上证见本净故。随所应得三界灭无。三界事相者。或于初地或第八地而得灭无。三界自性者。等觉位中而得灭无。三界习气至妙觉位方得灭无。此义具如二障章说。答中总许故言如是。三界灭无时心境不相生。所以然者。唯心妄见变作境界。心无妄时则不作境。境界无故不生心也

经曰。菩萨内无众生三性空寂则无己众亦无他众乃至二入亦不生心得如是利即无三界

论曰。此下第二别明趣入。于中有二。一者总标举数。二者问答别显。此是初文。内无众生者。谓十住位得内人空故。三性空寂者。十行位中得内法空故。则无己众亦无他众者。十回向位得平等空遍遣自他人法众故。所言众者。众生名众。五阴之法亦名五众故。是相似空未得真证。乃至二入者。通举地前地上入数

经曰。大力菩萨言云何二入不生于心心本不生云何有入佛言二入者一谓理入二谓行入理入者深信众生不异真性不一不共但以客尘之所翳障不去不来凝住觉观谛观佛性不有不无无己无他凡圣不二金刚心地坚住不移寂静无为无有分别是名理入

论曰。此下问答别显。问中有二。先问后难。答中亦二。先答后通。答中有三。牒数列名次第辨相。此中理入者。顺理信解未得证行故名理入。位在地前。行入者。证理修行入无生行故名行入。位在地上。理入文中有其四句。深信已下乃至翳障。是十信入。不一者。谓众生相不异真性而非一故。不共者。非亦一亦异故。第二句言不去不来凝住觉观者。是十住入。悟众生空故不来去。于人空门静住其心觉察佛性无去来故。第三句言谛观佛性不有不无者。是十行入。已得法空依法空门谛观佛性。不有法相不无空性故。第四句言无己无他凡圣不二等者。是明十回向位。理入已得自他平等空故心如金刚坚住不退。梵网经中名十金刚。仁王经中名十坚心。是十回向之异名也

经曰。行入者心不倾倚影无流易于所有处静念无求风鼓不动犹如大地捐离心我救度众生无生无相不取不舍

论曰。是明地上证入之行。心不倾倚者。如理智心不攀缘故。攀缘之心不生起故。影无流易者。如理之境离三际故。流变境像不复现故。所有一切世间福乐乃至菩提大涅槃果。于是一切皆无愿求。通达平等无此彼故。故非境界风所鼓动。是明自利行入。捐离己下令他入行。以证二空离人法相故。能普遍救度一切。虽心无生亦无境相。而不取其寂灭之性恒不舍于一切众生。以之故言不取不舍。如是二行名为行入

经曰。菩萨心无出入无出入心入不入故故名为入

论曰。此是第二通彼所难。证理之心远离生灭无始无终故心无出入。无出入已亦无昔日出入之心故无出入心。去昔有出入心。入此不出入心故言入不入故故名为入。如是前难得善通也

经曰。菩萨如是入法法相不空不空之法法不虚弃何以故不无之法具足功德非心非影法尔清净

论曰。此下第三能入离过。于中有二。略明广释。此即略明。如是入法者。谓入实际无出入法。是不无法能所平等离诸过患具诸功德。非心非影者。心境平等离能所故。法尔清净者。无始无终离诸相故

经曰。大力菩萨言云何非心非影法尔清净佛言空如之法非心识法非心使所有法非空相法非色相法非心不相应法非心无为相应法非所现影非所显示非自性非差别非名非相义何以故如故非如之法亦无无如无有无如非无如有何以故根理之法非理非根离诸诤论不见其相菩萨如是净法非生之所生生非灭之所灭灭

论曰。此下第一广释离过。先问次答三领四述。答中有二。先释非心非影之句。后释法尔清净之句。初中亦二。先明入法离诸心影。后明心影无非如理。初中言空如之法者。入实际时远离诸相曰空。能所平等曰如。如是入法离诸心影。心影差别略有六双。一者心及心所为双。二者虚空与色为双。三者不相应行及诸无为为双。四者影像及与本质为双。五者自性差别为双。六者名言及与相义为双。此六双中初之一双能缘心类。后五双者所缘影类。离此六双故非心影。如其次第有六双句。非心识法者。以离八识心故。非心使所有法者。以离六位心所有法故。非空相法者。离无色相虚空法故。非色相法者。离显形表三种色故。非心不相应法者。离二十四不相应行故。非心无为相应法者。离余七种无为法故。依心所显故名心无为。三种无为之相相应法故名相应法。亦离三种真如法者。入证门中无三别故。非所现影者。离方便观之所显现本法同分之影像故。非所显示者。亦离影像之所显示本质之法骨锁等故。非自性者。离色心等之自性故。非差别者。离无常等差别相故。非名者。离名句文能诠相故。非相义者。离名所诠相当名之义故。何故离此六双相者。能所平等无差别故故言如故。非如之法已下第二明心影法无不如理。非如法者。谓前所非六双法相。亦无无如者。如理遍通故。无有无如者。无一有相之法而无如理者故。非无如有者。设有无如之法可得为有。既非非如之法不得为有故。何以故下释非有义。根者。树根喻于种子。理者。木理喻于现法。如前庵罗果喻中说。离诸诤论不见其相者。觉慧求之无所得故。上来二分广非心影。如是净法已下次广法尔清净。非生之所生生者。离生相故体非生故下句亦尔。离灭相故体非灭故。如是净法离有为相无生无灭无始无终。由是义故法尔清净也

经曰。大力菩萨言不可思议如是法相不合成不独成不羁不伴不聚散不生灭亦无来相及以去相不可思议

论曰。此是第三领解。不合成者。非心非心所。心与心所别体相应故。不独成者。非自性非差别。是二义别无二体故。不羁者。非名非义故。名义互为客故。不伴者。非影质故。影质相类而为伴故。不聚散者。非空非色故。聚集为色散坏为空故。不生灭者。非不相应非无为故。不相应行是生起故。诸无为法灭所显故。此领前说离六双义。亦无来相者。非生之所生生故。及以去相者。非灭之所灭灭故。是领后说法尔清净。初言不可思议者。非如之如离心言故。后言不可思议者。离心之心亦离二故

经曰。佛言如是不可思议不思议心心亦如是何以故如不异心心本如故

论曰。此是第四述成。如其次第述彼二种不思议句。所言心者。谓入证心。无心之心入于不入故不思议。如不异心者。释前不思议。心本如故者。释后不思议也

经曰。众生佛性不一不异众生之性本无生灭生灭之性性本涅槃性相本如如无动故

论曰。此下第四所入离边。于中有二。先明佛性离一异边。后显如如离有无边。初中有二。略明广显。此即略明。此中亦二。先离一异。后释离异。离一异者。谓众生与佛性不一亦。不异故。言佛性者。真如佛性。如涅槃经言。佛性者名第一义空故。若一若异皆有过故。众生之性本无生灭者。此下释离异义。不一之义易可见故。此句明人不异佛性。生灭之性性本涅槃者。是明生死不异涅槃故。性相本如如无动故者。众生人性生灭法相本来是如故不异也

经曰。一切法相从缘无起起相性如如无所动因缘性相相本空无缘缘空空无有缘起一切缘法惑心妄见现本不生缘本无故心如法理自体空无如彼空王本无住处凡夫之心妄分别见

论曰。此下第二广显。此中唯广离异边义。一切法相从缘所生。一切果法从缘有故即无生起。起相性如如无所动也。下明能起诸缘亦空。因缘性相相本空无者。种子因缘无所有故。缘缘空空无有缘起者。所缘缘法非一众多莫不皆空故曰空空。是故无缘之能起也。一切缘法惑心妄见者。谓增上缘等无间缘唯心妄见故亦空也。现本不生缘本无故者。结成二空。缘所现果本来不生。能起诸缘本来无故。心如法理自体空无者。前说因果是所取法。所取法无故能取心亦空。如说所取法空道理。能取心体亦如是故。上来法说。下引譬喻。言空王者空有二。一者空界谓明暗色。二者空王谓虚空法为一切色之所依故。如王为诸民之所依故说虚空名为空王如是空王本无住处。而凡夫心妄计分别。此处虚空彼处虚空唯是妄见。无此无彼。因果诸法当知亦尔。妄心所取无因无果。是约遍计所执因果。而作是喻妄见处故

经曰。如如之相本不有无有无之相见唯心识菩萨如心之性不无自体自体不有不有不无菩萨无不无相非言说地何以故真如之法虚旷无相非二所及

论曰。此是第二明如如法离有无边。于中有四。初句正明如如离边。次句反举有边是妄。三者引心离边为例。四者还明如如离言。第三中言如心之性者。犹如一心之体性也。不无自体者。谓离无自体边如兔角故。自体不有者。谓离有自体边如牛角故。非谓他相无故不有故言自体不有而已。不有不无者。不有即是不无。不无即是不有。由是义故更合明也。如一心法不有不无。如如之理亦同是说。是故句首曰如心也。无不无相非言说地已下第四还明如如离言道理。无不无相者。明初句中本不有无。非诸言谈安足处故。非二所及者。非寻伺二之所行故。寻伺二法是语言足。非此二所行故非言说之地也

经曰。虚空境界内外不测六行之士乃能知之

论曰。此下大分第三入之阶位。于中有四。一明所入甚深。二举能入位行。三者别显阶位。四者核明入心。初中言虚空境界者。谓如如之法虚旷无相故名虚空。内外不测者。谓内道中二十八圣及外道中九十五种。此等凡圣不能测量也。第二中言六行之士乃能知之者。是举菩萨二入阶位也

经曰。大力菩萨言云何六行愿为说之佛言一者十信行二者十住行三者十行行四者十回向行五者十地行六者等觉行如是行者乃能知之

论曰。此是第三别显阶位。唯显行位除其果位。所以不取妙觉之地。此六行中前四位是理入阶降。后二位者行入差别。于中略义在本业经。广分别义出华严教

经曰。大力菩萨言实际觉利无有出入何等法心得入实际佛言实际之法法无有际无际之心则入实际

论曰。此是第四核明入心。问中言实际觉利无有出入者。举后二位得二利行与理相称无出入义。何等法心得入实际者。正问于中能入心法。答中言实际之法法无有际者。举所入法。法尔无际纵无前后际无始无终故离三世时故。横无此彼际无中无边故离六方所故。甚深无际无边不离故。广大无际无所不遍故。具此四义故言无际。能入之心亦具四义。故于实际无所不入。当知实际离能所边。心亦如是离能所际。即无其入乃能得入。是谓不可思议义也

经曰。大力菩萨言无际心智其智无涯无涯之心心得自在自在之智得入实际如彼凡夫软心众生其心多喘以何法御令得坚心得入实际

论曰。此下大分第四入之方便。入方便者。位在地前四位。理入门内方便观也。于中有二。先明能入方便。后显方便胜利。初中亦二。先略后广。略中先问。问中亦二。一领于前。二问于后。领中言无际者。心体无际故。无涯者。智用无涯故

经曰。佛言菩萨彼心喘者以内外使随使流注滴沥成海天风鼓浪大龙惊骇惊骇之心故令多喘菩萨令彼众生存三守一入如来禅以禅定故心则无喘

论曰。答中有二。先出所治障相。后示能治方便。初中言心喘者。惊心不安其出入息急速曰喘。以喻六识掉动不停。内外使者。末那四使内缘自我故。意识六使外缘诸境故。随使流注者。谓忿恨等小随烦恼。其沉掉等大随烦恼。及无惭愧中随烦恼随使等流集注现识故。滴沥成海者。本使随惑一切现行皆熏本识积集深广故。天风鼓浪者。业力所感六尘境界任运现行故名天风。鼓随眠海起七识浪故曰鼓浪。大龙惊骇者。无明住地其力最大住在本识随眠海底故名大龙。如是无明违反寂静常能增长粗动之心故曰惊骇。由是诸缘令心多喘。此是令知所治障相。自下示其能治方便。存三者。能遮天风方便。守一者。能伏大龙方便。入如来禅者。正治多喘之方便也

经曰。大力菩萨言何谓存三守一入如来禅佛言存三者存三解脱守一者守一心如入如来禅者理观心如入如是地即入实际

论曰。此下第二广显方便。有三问答。此初番中举数总标。守一心如者。一心法中有二种门。今先守其心真如门。为伏无明大龙势故。无明正迷一心如故。此中守者。入时静守一如之境。出时不失一味之心。故言守一。如本业经十行中言。十为自在转大法轮故。所谓菩萨三宝。菩萨尔时于第一中道智为觉宝。一切法无生动与则为法宝。常行六道与六道众生和合。名僧宝。转一切众生流入佛海故。案云。三时不失中道一味即是此观守一之用。此观在于十行位也。余门后显此中不论

经曰。大力菩萨言三解脱法是何等事理观三昧从何法入佛言三解脱者虚空解脱金刚解脱般若解脱理观心者心如理净无可不心大力菩萨言云何存用云何观之佛言心事不二是名存用内行外行出入不二不住一相心无得失一不一地净心流入是名观之

论曰。此二问答别显观行。初答中言三解脱者。则是三慧摄八解脱故名解脱。如本业经十住中言。六为诸佛所护。所谓八解脱观。闻慧得内假外假二相不可得故一解脱。思慧内五阴法外一切法不可得故二解脱。修慧六观具足色界五阴空三解脱。四空五阴及灭定观皆不可得故。五解脱如相故。案云。八解脱观略有二门。若就事相唯修慧观。是共二乘。如余处说。若就三慧观人法空。是大乘观。如此文说。初解脱者。内有色相外观色等。谓内存色等。五阴法相观内我空。外存色等观众生空。是空易入闻慧所得。故言闻慧得内假外假二相不可得故。不遣色等以观空故。有似虚空不遣色相故。说是为虚空解脱。第二解脱者。内无色相外观色等。内遣色等五阴法相。外观一切山河等空。欲界诸法无所不空。是空难解思慧所观。故言思慧内五阴法外一切法不可得故。推求析破内外诸法。如似金刚破诸色法。是故名为金刚解脱。后六解脱皆是修慧。观上二界一切法空故言修慧。六观皆是修慧依定所发。是故总名般若解脱。于中六种差别相者。第三名净解脱。身作证色界五阴光洁寂静观悉空故名净解脱。自内所证名身作证故。言具足色界五阴空三解脱。第四名空处解脱。观空处五阴空故。乃至非想解脱亦尔。观灭定法亦不可得。故名灭尽解脱。皆从所遣以立其名。故言四空五阴及灭定观皆不可得故。五解脱如相故。如是三慧观人法空。伏离二执现行二缚故名解脱。既遣内外一切假法能遮诸境天风吹鼓也。理观中言心如理净无可不心者。顺理无相心无分别故。后答中言心事不二是名存用者。是名存三之用胜能。若人未得存三之用。静心观空涉事失念。取我我所著违顺境。天风所动心事各异。若能熟修三解脱者。出观涉事观势犹存不取我他之相。不着好恶之境。由是不为天风所鼓。入出同忘心事不二。如是乃名存三之用也。是观始修在十信位。存用得成在十住位。如本业经十住位中立此观故。内行已下答第二问以明观相。内行者。入观寂照行。外行者。出观化物行。若出若入不失中道故言不二。如本业经十向中言。十以自在慧化一切众生。所谓中道第一义谛。般若处中而观。达一切法而无二。其慧转转入圣地故名相似第一义谛观。而非真中道第一义谛观。乃至广说故。不住一相者。二谛观故。心无得失者。平等观故。依此二种方便观故。进入初地法流水中。故言一不一地净心流入。如彼经。言三观者。从假入空名二谛观。从空入假名平等观。是二观方便道。因是二空观得入中道第一义谛观。双照二谛心心寂灭进入初地法流水中。乃至广说。案云。此中二谛观者。遣俗观真故。即是正体智之方便。平等观者。融真观俗。即是后得智之方便。观俗如幻不取得失无适无莫故名平等。言一不一地者。初地之异名。所以然者。初地即是十地。一时顿入十重法界故。十地即是初地。直以遍满为初门入故。良由十地即初地故名一。初地即十地故不一。是故名为一不一地。依二方便以净其心。由是流入一不一地。以之故言净心流入。此中唯广初后二观。中间一观准可知故

经曰。菩萨如是之人不在二相虽不出家不住在家故虽无法服不具持波罗提木叉戒不入布萨能以自心无为自恣而获圣果不住二乘入菩萨道后当满地成佛菩提

论曰。此下大分第二方便胜利。于中有四。一者得果胜利。二者得供胜利。三者无患胜利。四者无住胜利。此即第一得果胜利。初中亦有四种胜利。一者离边胜利。不堕道俗二边相故。如经如是之人不在二相。虽不出家不住在家故。二者自在胜利。不为教门戒律所制。能以自心决判道理。萧然无为而无不为故。如经虽无法服乃至而获圣果故。三者入道胜利。如经不住二乘入菩萨道故。四者得果胜利。如经后当满地成佛菩提故

经曰。大力菩萨言不可思议如是之人非出家非不出家何以故入涅槃宅着如来衣坐菩提座如是之人乃至沙门宜应敬养佛言如是何以故入涅槃宅心起三界着如来衣入法空处坐菩提座登正觉一地如是之人心超二我何况沙门而不敬养

论曰。此下第二得供胜利。得三胜德堪作福田。一切道俗所应供故就文有三。先明菩萨福田。次显二乘不见。后显菩萨能见。初中即现三种福田。入涅槃宅心起三界者。是三解脱存三之用。三界空寂名涅槃宅。安心栖托之净处故。三解脱观入三界空而不取证。还起俗心普化三界故言心起三界。起三界心而不染着即是存用。着如来衣入法空处即是守一心如之观。谓涉三界普化之时。着忍辱衣而不疲倦。还入法空守一心如。如法华经言。柔和忍辱衣故。坐菩提座登正觉一地者。是如来禅理观之心。谓坐法空。进修方便得登初地正觉真观。如法华经言。诸法空为座故。如是三位皆观二空。人我法我二执伏灭故言心超二我。超二我故断德具足。修三观故智德亦备。故能堪作道俗福田也

经曰。大力菩萨言如彼一地及与空海二乘之人为不见也佛言如是彼二乘人味着三昧得三昧身于彼空海一地如得酒病惛醉不醒乃至数劫犹不得觉酒消始悟方修是行后得佛身

论曰。此下第二二乘不见。于中有二。先问后答。问中言一地者。谓所登地。十地即初地名为一地。空海者。谓前三观所入之空。甚深广大故名为海。答中言如是者。许不见也。下释二乘不见所由。味着三昧者。乐着静定而趣寂故。得三昧身者。如所乐趣入灭心定。因入涅槃灰身灭智。智心灭处灭定体生遮心心法。如是名为得三昧身故。乐寂熏习在本识中。因是不悟空海一地。如得酒病惛醉不醒乃至数劫犹不觉者。须陀洹人八万劫住。乃至罗汉二万劫住。辟支佛者十千劫住。住于涅槃而不觉悟。今总相说乃至数劫。酒消始悟方修是行者。随其乐着熏习厚薄。着气消息得还起心。起心之时回心入大。方修如前三种观行。如楞伽经颂曰。譬如惛醉人。酒消然后悟。得佛无上体。是我真法身。乃至广说

经曰。如彼人者从舍阐提即入六行于行地所一念净心决定明白金刚智力阿鞞跋致度脱众生慈悲无尽

论曰。是明菩萨种性之人。从舍阐提不信之障。即入六行之初十信。于修行地之所即发一念净心。即是十住之初发心。决定明白者。谓十行位众行明净故。金刚智力者。谓十回向坚固智力故。阿鞞跋致者。谓初地已上真证无退故。度脱众生慈悲无尽者。即于前位利他行故。为别二乘不能行故

经曰。大力菩萨言如是之人应不持戒于彼沙门应不敬仰佛言为说戒者不善慢故海波浪故如彼心地八识海澄九识流净风不能动波浪不起戒性等空持者迷倒如彼之人七六不生诸集灭定不离三佛而发菩提三无相中顺心玄入深敬三宝不失威仪于彼沙门不无恭敬菩萨彼仁者不住世间动不动法入三空聚灭三有心

论曰。此是第三离患胜利。谓离凡夫因果患故。于中先问应不持戒者。如前说言不具持波罗提木叉戒故。于彼沙门应不敬仰者。既不持戒故不须敬持戒者故。答中有二。先许前问。次夺后问。初中言为说戒者者。所为说戒之人即是诸声闻也。恃自持戒懱诸破戒。故言不善慢故。是人未得诸法空故。随眠海中七识浪转。故言海波浪故。是举持戒之人过失。如彼心地者。谓菩萨心证诸法空入大地故。第八识内二执随眠分别起者皆已灭尽。故言八识海澄。澄者澄也。无分别智证入本觉地地增长离诸杂染。故言九识流净。本觉正是第九识故心无分别非境所动。故风不能动。不能动故染七不生。故言波浪不起。是人既证一切法空。七支戒性达皆空寂。故言戒性等空。而声闻人不达法空。执有戒性恃自能持。故言持者迷倒。是答初问明不持戒而非过失。如彼已下次答后问以明无慢。七六不生者。末那四惑不现行故见惑种子已断灭故。诸集灭定者。诸生起识心心所集皆灭尽已入理定故。不离三佛而发菩提者。明发心来普敬心生。如来藏佛是诸众生依彼发心不轻慢故。三无相中顺心玄入者。得行入时拔无明根。如前所说三解脱中顺一心法而深入故。由是义故深敬三宝。谓形像佛。纸素等法．四种僧等。无所不敬。故于沙门不无恭敬。以依三佛而发心故拔憍慢根无明种故。上来明其离诸因患。自下显其离诸果患。不住世间动不动法者。欲界人天富乐之果名为动法。散善果故。色无色界寂静之果名不动法。定善果故。于彼不着故曰不住。入三空聚者。如前所说。展转增入故名为聚。非直不着亦令不生。以之故言灭三有心

经曰。大力菩萨言彼仁者于果满足德佛如来藏佛形像佛如是佛所而发菩提心入三聚戒不住其相灭三有心不居寂地不舍可众入不调地不可思议

论曰。此是第四无住胜利。于中有二。先领上说。后显无住。领中二句．先领不离三佛之句。果满足德佛者。始觉究竟万德圆满故。如来藏佛者。一切众生本来本觉故。形像佛者。金铜泥木能表尊像故。因果理事无所遗故。入三聚戒不住其相者。是领前戒性等空之句。入戒四缘。不着戒相故。三聚四缘后品当说。自下正显无住胜利。虽复入三空聚。灭三有心而不住寂地。普涉六度多喘众生所居之处名不调地。由所留惑依不系业于彼受生故名为入。言留惑者。谓不速尽。如小乘人于三无数大劫时中渐次而断。得菩提时方灭尽故。不谓金刚已还一向不断故名为留

经曰。尔时舍利弗。从座而起前。说偈言具足般若海不住涅槃城如彼妙莲华高原非所出诸佛无量劫不舍诸烦恼度世然后得如泥华所出如彼六行地菩萨之所修如彼三空聚菩提之直道

论曰。此下第三身子领解为令小众发大心故。于中有二。一者领解。二者述成。初中亦二。在前三颂颂前所说。其后二颂陈自发心。初中有三。一前二颂颂无住道。次有二句颂六行位。后之二句颂三空聚。初中言具足般若海者。谓三解脱具三慧故。不住涅槃城者。灭三有心不居寂地故。高原非所出者。如彼二乘离烦恼泥。八万劫等不发心故。不舍诸烦恼者。不如二乘二二生中速断尽故。如泥华所出者。由所留惑入不调地。于中具修菩萨行故。因是能证菩提果故云行三聚。在文可知

经曰。我今住不住如佛之所说来所还复来具足然后出复令诸众生如我一无二前来后来者悉令登正觉

论曰。此是第二陈自发心。于中有二。初之二句陈今发心之位。后一颂半表其后修之行。我今住不住者。今闻佛说已发大心即住不住寂地之心故。来所还复来者。无始流转之来之处我先所离。今还复来来入三界度众生故。边际定力延所受身随其所宜而示现故。具足然后出者。具足菩萨一切行后出离此身得佛身故。言前来者。过去善根已成熟者也。言后来者。于未来世方成熟者也。穷未来际不休息故

经曰。尔时佛告舍利弗言不可思议汝当于后成菩萨道无量众生超生死海

论曰。第二述成。印其所说

经曰。尔时大众皆悟菩提诸小众等入五空海

论曰。此是大分第四时众得益。言大众者。是大乘众。悟菩提者。悟入一地菩提心故。诸小众者。谓声闻众。得入三种真如门故

金刚三昧经论卷中金刚三昧经论卷下

        新罗国沙门元晓述

    真性空品

论曰。真如之法具诸功德。与诸行德而作本性。故言真性。如是真性绝诸名相。以之故言真性空也。又此真性离相离性。离相者离妄相。离性者离真性。离妄相故妄相空也。离真性故真性亦空。以之故言真性空也。今此品中显是二义。故依是义立品名也

经曰。尔时舍利弗而白佛言尊者修菩萨道无有名相三戒无仪云何摄受为众生说愿佛慈悲为我宣说

论曰。别明观行有六分中第四遣虚入实分竟。此下第五明诸圣行出真性空。就此品中大分有二。一为利根者多文广说。二为钝根者少文略摄。前广说中即有六分。一者明三聚戒从真性成。二者明道品行从真性立。三者明如来教当如理说。四者明菩萨位从本利出。五者明大般若绝诸因缘。六者明大禅定超诸名数。初三戒中文有五分。一问二答三请四说五者领解。此即初问。言修菩萨道无名相者。通举诸行。三戒无仪者。别牒戒行。如前品言。入三聚戒不住其相。是即三戒无相无仪。云何自摄受及为他说耶。此舍利弗既始入大。初发修行以戒为本。故问三学之中初行。又此身子从身而生。今此品中说诸行法从法身生。故寄身子而发问也

经曰。佛言善男子汝今谛听为汝宣说善男子善不善法从心化生一切境界意言分别制之一处众缘断灭何以故善男子一本不起三用无施住于如理六道门杜四缘如顺三戒具足

论曰。此是第二略答。于中有二。先答通问。善不善法从心化生者。三业因行皆是心作故。一切境界意言分别者。六道果境无非意变故。由心乱动不能制故。变作因果流转苦海。是故欲度苦海。修菩萨道制心一如众缘断灭。所以菩萨修无名相。何以故下次答别问。虽复总说未闻别行。所以更问何以故也。一本不起者。三戒之本是一本觉本来寂静故曰不起。三用无施者。既依本觉成三戒用。用离威仪施作相故。无施作故。顺住一本故。言住于如理。既住如理消除有因故言六道门杜。于一如理具四缘力。能顺一如即具三戒。故言四缘如顺三戒具足

经曰。舍利弗言云何四缘如顺三戒具足

论曰。此是第三重请

经曰。佛言四缘者一谓作择灭力取缘摄律仪戒二谓本利净根力所集起缘摄善法戒三谓本慧大悲力缘摄众生戒四谓一觉通智力缘顺于如住是谓四缘善男子如是四大缘力不住事相不无功用离于一处即不可求善男子如是一事通摄六行是佛菩提萨般若海

论曰。此是第四广说。于中有二。一者正答明戒因缘。二者乘显摄一切行。初中言四缘者。谓于一心本觉利中具四力用作三戒缘。一灭依止缘。二生依止缘。三摄依止缘。四离依止缘。灭依止者。谓本觉中性静功德与诸烦恼自性相违。以是缘成摄律仪戒。生依止者。谓本觉中性善功德与诸善根自性相顺。以是缘成摄善法戒。摄依止者。谓本觉中性成大悲自性不舍一切众生。以是缘成摄众生戒。离依止者。谓本觉中性成般若自性舍离一切事相。以是因缘令三聚戒舍离事相顺如而住。前三别缘。后一通缘。菩萨发心受三戒时。顺本觉利而受持故。以是四缘具足三戒。大意如是。次消其文。一谓作择灭力取缘者。本觉本离烦恼系缚。举体而作择灭解脱。有力能取别解脱戒。如似磁石引取于针。虽无作意而有力用。当知此中道理亦尔。二谓本利净根力所集起缘者。谓本觉本来性净功德与诸行德而作根本。由此根力起诸善法。为所集起善法之缘。即此缘成摄善法戒。三谓本慧大悲力缘摄众生戒者。谓本觉中照俗之慧即是大悲恒润众生。以是缘成摄众生戒。四谓一觉通智力缘顺于如住者。谓本觉中照通性智令三聚戒皆顺如住。如是四缘体遍法界用摄万行故言大力。虽有大力而同一味离诸名相差别事用。故言不住事相。虽无事相而有胜能能摄出世一切行德。故言不无功用。由如是故只是本觉。于俗法中无如是义。故言离于一处即不可求。上来别明三聚戒缘。自下明其通摄万行。始从十信乃至等觉。如是六位所有诸行。皆是一觉之所摄成。故言一事通摄六行。非但菩萨归此本觉。诸佛圆智同归此海。故言是佛菩提萨般若海

经曰。舍利弗言不住事相不无功用是法真空常乐我净超于二我大般涅槃其心不系是大力观

论曰。此是第五领解。于中有二。先领所顺一如。即是法身具足四德超人法相是大涅槃。后领能顺如心。随如离系而无不为大自在力

经曰。是观觉中应具三十七道品法佛言如是具三十七道品法何以故四念处四正勤四如意足五根五力七觉八正道等多名一义不一不异以名数故但名但字法不可得不得之法一义无文无文之相真实空性空性之义如实如如如如之理具一切法善男子住如理者过三苦海

论曰。此是大分第二明道品行从真性立。于中有二。先问后答。问中言是观觉中者。是能顺观所顺本觉能所平等观觉之中应具三十七道品行。答中有二。先许后释。何以故下是第二释。于中有二。直释重显。初中言多名一义者。三十七品所目之义唯一观觉无二法故。不一不异者。观觉不一而不异故。约不异门故言一义。以名数故已下重显。于中有四。先遣异义。次显一义。三明一义具一切法。四明一义离诸过患。初中言以名数故但名但字法不可得者。谓世间修道品行法随名数故有三十七。菩萨觉慧求所目义三十七法皆不可得故。第二中言不得之法一义无文者。求彼别法不得之时。是法一味绝诸文言故。第三中言无文之相真实空性者。不得别法之能观心绝诸文言离差别相故。空性之义如实如如者。此能观心离诸相义。不异实相如如之理故。如是本觉如如之理即具修成道品等法。犹如铸金具相好像。故言如如之理具一切法。既住如理具诸功德。即离一切杂染过失故。言住如理者过三苦海。此是第四离诸过患也。此中略明道品之义。于中即以四句分别。一摄三十七以为十法。二摄十法以为四法。三摄四法以为一义。四明一义具三十七。初摄三十七以为十法者。智度论云。三十七品十法为本乃至广说。当知开十立三十七。论其法体唯有十法。何等为十。谓戒思受念定与慧信勤安舍。云何开十为三十七。开戒为三。正语业命。思数立一。谓正思惟。受亦立一。谓喜觉分。开念为四。念根念力念觉正念。开定为八。谓四如意足定根定力定觉正定。慧亦立八。谓四念处慧根慧力择法觉分及与正见。勤亦立八。谓四正勤精进根精进力精进觉分及正精进。信中立二。信根信力。安舍各一。谓倚觉分及舍觉分。总而言之有其五例。一者开八有三。谓定慧勤。彼二十四此三所摄。二者开四有一。谓念。所以彼四一念所摄。三者开三有一。谓戒。所以彼三一戒所摄。四者开二有一。谓信。信摄彼二。五者立一有四。思受安舍各摄自性。如是十法摄三十七。二摄十法为四种者。第一戒者色法所摄。谓表无表。第二思受遍行心所所摄。第三念定慧别境心所所摄。第四信等四善心所所摄。三摄四法为一义者。觉慧推求如是四法初一色法有方无方俱无所得。后三心所有时无时皆不可得。是则虽非无法而不得有可得之法平等一味。当知四法直是一义。以之故言多名一义。四明一义具三十七者。能所平等一味之义。观身等空是四念处。离诸懈怠是四正勤。散虑寂灭是如意足。离不信等即是根力。灭无明等即七觉分。离八邪法即八正道。如是远离一切杂染。一义具足无量功德。故言是观觉中应具三十七道品法。又言如如之理具一切法

经曰。舍利弗言一切万法皆悉文言文言之相即非为义如实之义不可言说今者如来云何说法

论曰。此下大分第三明佛言教称如理说。先问后答。问中言一切万法者。世间言说所安立法。如言之法皆无所得故。唯文言即非为义。诸法实义绝诸言说。今佛说法若是文言即无实义。若有实义应非文言。是故问言云何说法

经曰。佛言我说法者以汝众生在生说故说不可说是故说之我所说者义语非文众生说者文语非义非义语者皆悉空无空无之言无言于义不言义者皆是妄语如义语者实空不空空实不实离于二相中间不中不中之法离于三相不见处所如如如说如无无有无有于无如无有无有无于有有无不在说不在故不在于如如不有如不无如说

论曰。是第二答。于中有二。先是佛说之由。后显文义之异。初中言以汝众生在生说故者。汝谓身子。众生即是一切凡夫。说于无为即在法体。说于有为即生法相。如是在生之说不可说于实义。我异彼说。是故说之。是为佛说言教之由。次显文义不同相中。先标二章后释二章。标中言义语非文者。语当实义故非直空文故。文语非义者。语止空文故不关实义故。第二释中先释后章。言皆悉空无者。直有空文而无实义故。是释文语也。无言于义者。无诠谈于如实之义故。是释非义也。下总结。言皆是妄语者。虽非违想而违义故。犹如不见言见见言不见等语。如义已下次释前章。于中有二。正释重显。初中亦二。先释非文。后释义语。释非文者。谓非空无。非空文故。非无义故释义语者。义合语故。语如义故。初释中言实空不空者。谓说真如实相亦空。如前说言空相亦空故。言实空。而不亡其实相之理故言不空。虽非有实而非无实故。空实不实者。谓说真空之理是实故言空实。而不存其真空之理故言不实。虽非无空而非有空故。离于二相中间不中者。不空之语离于空相。不实之语离于实相。故言离于二相。然空实二相之间不存非二之中。故言中间不中。既离二边亦不堕中。故言离于三相。心言行处不过三相。然此佛语远离三相。即于其中心言路绝。故言不见处所。如是妙契绝言之义。所以不同无义之文。此释非文也。如如如说者。是释义语。上一如是契当。下二如是义理。如前远离三相之语契当如如义理而说。所以佛说乃是义语。不同凡语之非义也。如无已下第二重显。先显非文。后显义语。初中言如无无有无有于无者。谓真如理虽非是有而如本无令无其有。谓令无有法于无法中。所以然者。如本非有。无于何有而堕无耶。是故合于实空不空之语也。如无有无有无于有者。谓真如理虽非是无而如本无令有其无。谓令有无法于有法中。所以然者。如本非无。有于何无而堕有耶。是故合于空实不实之语。有无不在者。如无有无故有不在。如无无有故无不在。二既不在。何得有中。即合离于三相之语如义既尔合于义语。是故佛语实非空文。如是重显非文释也。佛说名言如是当理故后得智带如是名。思惟真如即得亲观真如理体故在四句之中俱句也。第二重显义语中言说不在故不在于如者。佛语既说有无不在故。不在有无于真如理。有不在者不有如故。无不在者不无如故。则当不有如不无如而说。故言如不有如不无如说。是故前言如如如说。如是重显义语之释。六分之中第三分竟

经曰。舍利弗言一切众生从一阐提阐提之心住何等位得至如来如来实相佛言从阐提心乃至如来如来实相住五等位

论曰。此下大分第四明菩萨位从本利出。于中有二。先问次答。答中有三。一者举数总标。二者别解。三者总明。此即总标。五等位者。等之言阶。从阐提心者。未发无上菩提心前皆名阐提。以无大乘决定信故。然一阐提略有二种。一者发大愿一阐提。谓常不入涅槃者故。二者无大信一阐提。此亦有二。一者别一阐提。谓起大邪见断善根者故。二者通一阐提。谓未发大心无大信者乃至二乘四果皆入此阐提位。今此文中约此最后故言从一阐提心乃至如来有五等位。未入十信者皆名阐提故。此中先明五位分齐。第一信位在十信行。虽未不退发大心故。本业经名信相菩萨。第二思位在三十心。思量诸法唯识道理齐未真证无分别修故。第三修位者在十地行。得真证修对治十障故。第四行位者在等觉行。因行已满未至果地故。第五舍位者在妙觉地。不取寂灭大悲普化故。所以建立五等位者。谓显退不退位差别故。证不证位差别故。等未等位差别故。因满位差别故。果圆位差别故。如其次第立五等位也。大意如是。次释其文

经曰。一者信位信此身中真如种子为妄所翳舍离妄心净心清白知诸境界意言分别

论曰。此下第二别释。初中有二。先信后解。初明信者。所谓信有三种佛性。信此身中真如种子者。信住自性佛性真如。正是第一义空种子。即是阿耨菩提中道种子。自性净心本来法然故名真如。与三身果而作正因故名种子。未发心住名住自性。未出诸障为妄所翳也。言舍离妄心者。是信引出佛性。从十信位乃至等觉渐出不信无知等障。随舍粗妄分别心故。言净心清白者。是信至得佛性。谓至道后离一切垢自性净心显现清白故。上句信字贯下二句故。知诸境界意言分别者。既信三种佛性。亦知唯识道理故。知心所取一切境界唯是意言分别所作。若离分别无所有故

经曰。二者思位思者观诸境界唯是意言意言分别随意显现所见境界非我本识知此本识非法非义非所取非能取

论曰。此明思位亦有二句。先明无相寻思观。后显无生如实智。初言观者。思量观察。唯是意言者。所取外境无所有故。随意显现者。似外相分不离见故。非我本识者。离识已外所见境界既非我识故无所有。此中言本识者。谓第六识三有本故。如提婆菩萨所说颂言。意识三有本。诸尘是其因。若见尘非有。有种自然灭。上来通显无相寻思及如实智。自下明其无生道理。知此本识非法非义者。非能诠法非所诠义。知名与义互为客故。非所取非能取者。所取尘既无。能取不成故。能取之义必待所取。既无所待即无能待故。此是通显无生寻思及如实智。始从十解已上乃至世第一法修此寻思如实智观。于中亦有修慧观察。而皆未离思察分别。所以通名为思位也

经曰。三者修位修者常起能起起修同时先以智导排诸障难出离盖缠

论曰。此明修位。亦有二句。先明修相。后显修因。言修相者。谓正体智止观双运更无出入故言常起。言能起者。谓止能起。能起观故。次言起者。谓所起观。止观不离故曰同时。止相观如必同时故。是明修相。次显其因。所以得此双运修者由先加行排诸障故。言智导者。谓加行智意言分别不离名言故名智导。七地已还一切地中皆有加行在先伏障故。排诸障难者。损伏粗重故。出离盖缠者。不起现缠故

经曰。四者行位行者离诸行地心无取舍极净根利不动心如决定实性大般涅槃唯性空大

论曰。是等觉位。亦有二句。先明位状。后显其行。初中言离诸行地者。行过十地故。心无取舍者。解与佛同故。故说此位名等觉行。次总结。言极净根利者。谓本觉心显成满因故。次明行中言不动心如决定实性者。此位得入金刚三昧故。大般涅槃唯性空大者。寂灭无为一相无相故。如本业经言。入金刚三昧一相无相寂灭无为名无垢地故

经曰。五者舍位舍者不住性空正智流易大悲如相相不住如三藐三菩提虚心不证心无边际不见处所是至如来

论曰。此明佛地。亦有二句。先明舍义。即以三义显其舍相。不住性空正智流易者。不住涅槃灰身灭智智不灭故。量智续流随根变易作佛事故。大悲如相相不住如者。无缘大悲不取人法差别之相。故曰如相。恒涉六道未曾停息。故言相不住如。三藐曰正。三者云等。菩提言觉。总而言之。谓正等觉即是圆满无上菩提。于中无住虚心不证。此三义中前二不住涅槃故舍。后一不取菩提故舍。次明位状。心无边际者。归一心源心体周遍。遍十方故无边。周三世故无际。虽周三世而无古今之殊。虽遍十方而无此彼之处。以之故言不见处所。如是极果不与他共。唯乘如者之所来至。以之故言是至如来。上来别明五等位竟

经曰。善男子五位一觉从本利入若化众生从其本处

论曰。此下第二总明。于中有二。一者直明从本。二者往复重显。此是初门。五位诸行不离本觉。莫不皆从本利而成。成行之时从前入后。故名为入。入者自利。化者利他。如是二行皆从本处也

经曰。舍利弗言云何从其本处佛言本来无本处于无处空际入实发菩提而满成圣道何以故善男子如手执彼空不得非不得

论曰。此是重显。答中有二。先法后喻。法中四句。前二句明本处无处。后二句显从成因果。何以故者。举疑发起。何者。若本无处应无得入。若得入者非无本处。为遣是疑故引喻释。手执彼空者。手执喻能入之行。虚空喻所入之本。不得者。虚空无形可握故。非不得者。握内不无虚空故。本利亦尔。本来无本处性故不可得。无本之本不无故非不可得也

经曰。舍利弗言如尊所说在事之先取以本利是念寂灭寂灭是如总持诸德该罗万法圆融不二不可思议当知是法即是摩诃般若波罗密是大神咒是大明咒是无上明咒是无等等咒

论曰。此下第五。明大般若圆融无二。于中有二。一者身子仰咨。二者如来述成。初中亦二。先领佛说本利圆融。后显即是大般若度。言在事之先取以本利者。是领佛言。凡欲发言作佛事时每先取其本觉之利。是生死念本来寂灭。如是寂灭即是如理。理中总摄本始诸德。亦乃该罗生死万法。圆融不二。是故甚深不可思议。此中虽具无量功德。其体唯是本觉始觉平等无二。故言即是摩诃般若。如是般若穷源尽性故言波罗密。别而言之有二种到。在等觉位到万行之彼岸故。在妙觉时到万德之彼岸故。在等觉位略有二到。一者有大神力降伏三魔之怨。如经是大神咒故。二者有大明照遍察四眼之境。如经是大明咒故。妙觉位中亦有二到。一者四智具足五眼圆满。照穷法界更无可加。如经是无上明咒故。二者三身所显无上菩提更无与等诸佛无差。如经是无等等咒故。咒者祷也。如世神咒有大威力。诵咒祷神福无不招祸无不却。今此摩诃般若波罗密亦复如是。具前四德有大神力。内即无德不备。外即无患不离。若至诚心诵此名句仰祷诸佛菩萨神人。随所求愿无不成办。由是义故说名为咒。如天帝释诵此名句却修罗军之事此中应说

经曰。佛言如是如是真如空性性空智火烧灭诸结平等平等等觉三地妙觉三身于九识中皎然明净无有诸影

论曰。此下如来述成。于中有三。先总述。次别述。后即总成。总述成者。如是如是故。别中亦二。先述到因满义。后述到果圆义。初中即显等觉三地。何等名为等觉三地。一者百劫位。二者千劫位。三者万劫位。如本业经言。佛子摩尼璎珞字者等觉性中一人。其名金刚慧菩萨。住顶寂定以大愿力住寿百劫。修千三昧已入金刚三昧。同一切法性。二谛一谛一合相。复住寿千劫学佛威仪。乃至入佛行处坐佛道场。超度三魔。复住寿万劫化现成佛。乃至现同古昔诸佛常行中道。大乐无为而生灭为异故。今此文言真如空性者。即是第一同一合相。谓同一切有无诸法即二谛法同融一谛。一谛即是一合相故。如是名为真如空性也。性空智火烧灭诸结者。即是第二超度三魔。灭诸结者。灭烦恼魔灭烦恼故。阴魔不系。灭二魔故。天魔自伏。但有不思议变易死魔耳。平等平等者。即是第三常行中道不堕二边故曰平等。为显常行故重言平等。等觉三地者。总前三地。此中前二述大神咒。其第三地述大明咒也。妙觉已下明到圆果。言三身者。一名法身。二者应身。三者化身。一切诸佛三身道同。是述无等等咒句也。于九识中皎然明净无有诸影者。是述无上明咒之句。前等觉位犹有生灭未尽心源。故在八识。今到妙觉永离生灭穷归本觉一心之源。故入第九识中明净。又前因位有仰缘义。所以其心影像相现。今归心源体彼本质。由是诸影一切相尽。以之故言无有诸影。如本业经言。佛子水精璎珞内外明彻妙觉常住湛然明净名一切智地。常处中道。一切法上越过四魔。非有非无一切相尽。顿解大觉穷化体神。二身常住为化有缘。案云。彼经立二身者。一法性身。二应化法身。合余二身为一身故。今此经中开此为二故说三身。三之与二平等平等。上来别述到彼岸义

经曰。善男子是法非因非缘智自用故非动非静用性空故义非有无空相空故善男子若化众生令彼众生观入是义入是义者是见如来

论曰。此是总成圆融不二。上约从浅入深之门以显因满果圆差别。若就一法不二之门即因果不二心境无别。因果不二故言非因。心境无别故曰非缘。所以然者。如前所说。因果心境者唯一圆智之自用故。既唯自用何因何缘也。又此智用在等觉位名照寂慧。未离生灭之动相故。至妙觉位名寂照慧。已归第九识究竟静故。然今就其不二之门。非先有动非后有寂。寂动之用用性空故。若就此义性空是无。无动静故。是亦不然。故言非有非无。非有可尔。云何非无者。空相亦空故。如是述成。圆融不二。若化已下劝入是义

经曰。舍利弗言如来义观不住诸流应离四禅而超有顶佛言如是何以故一切法名数四禅亦如是若见如来者如来心自在常在灭尽处不出亦不入内外平等故

论曰。此下大分第六明大禅定超诸名数。于中有二。先问后答。问中言诸流者。所谓三有往还流转无休息故。有顶者。谓非想处三有顶故。答中有二。总许别成。别中亦二。略明广释。略中二句。先明世间禅不离名数。后显出世禅超彼名数。若见如来者。如前所说入如来观故。如来心自在者观如来心离诸缚故。常在灭尽处者。心心数法不生起故。不出亦不入者。心体如理无起灭故。所以能得不出入者。内心外境平等观故。略明文竟

经曰。善男子如彼诸禅观皆为故想定是如非复彼何以故以如观如实不见观如相诸相已寂灭寂灭即如义如彼想禅定是动非是禅何以故禅性离诸动非染非所染非法非影离诸分别本义义故善男子如是观定乃名为禅

论曰。此是第二广释。于中有四。一者对相以明离相。二者对动以显离动。三者结义。四者结名。初中先举诸禅取相。诸禅观者。世间八禅。言故想者。不离古执无始妄想取诸相故。下显离相。是如非复彼者。入如来观能所平等名为如故。以如观如实者。平等之智达如实故。不见观如相者。不见能观之智所观之如差别之相平等一味故。既忘能所见相不起故言诸相已寂灭。寂灭无异故即是如义也。如彼已下对动显离动。先举其动。谓世间禅取相心起即是动念。动念非静故非真禅也。下显真禅离诸动相。言非染者。谓非能染非动念故。非所染者。非动所染本来静故。言非法者。非能缘心法故。非影者。非所现影像故。由是义故离诸动也。离诸分别本义义故者。第三结义离分别者。结离相义。由离分别不取相故。本义义者。结离动义。由本来静不起动故。如是观定乃名为禅者。第四结名。离相离动乃得禅名。禅是静虑之称故。彼世间定名为禅者。是假号禅非真禅故。是一品内有二分中为利根者多文广说。六分之文竟在于前

经曰。舍利弗言不可思议如来常以如实而化众生如是实义多文广义利根众生乃可修之钝根众生难以措意云何方便令彼钝根得入是谛

论曰。此下第二为钝根者少文略摄。然利钝广略有二种门。若论探解利略钝广。利者闻一以知十故。钝者闻十方解十故。若齐言解利广钝略。利者多闻而多解故。钝者诵少而总持故。今此文意约此后门。文中有五。一问二答三请四说五者大众闻说得益。此即初文。于中有二。先领前说。后问所疑。措者存意。多文广义钝根狭才难以存意

经曰。佛言令彼钝根受持一四句偈即入实谛一切佛法摄在一偈中

论曰。此是第二答。如来辩才无碍自在故。说一偈摄诸佛法。佛法之要在此四句。令钝根者。诵持一偈常念思惟。乃至遍知一切佛法。是名如来善巧方便

经曰。舍利弗言云何一四句偈愿为说之

论曰。是第三请

经曰。于是尊者而说偈言因缘所生义是义灭非生灭诸生灭义是义生非灭

论曰。是第四说。此四句义有别有总。别则明二门义。总即显一心法。如是一心二门之内一切佛法。无所不摄。是义云何。前之二句融俗为真显平等义。下之二句融真为俗显差别门。总而言之。真俗无二而不守一。由无二故即是一心。不守一故举体为二。如是名为一心二门。大意如是。次释其文。因缘所生义者。是举一切世谛诸法。是义灭者。融俗为真。谓所生义本来寂灭故。言非生者。显其生义是灭之由。由其生义即非生故。求其生义即不成故。是故生义即寂灭也。灭诸生灭义者。是举真谛寂灭之法。是义生者。融真为俗。谓寂灭法从缘生起故。言非灭者。显其寂灭是生之由。由其寂灭非寂灭故。求寂灭义不可得故。是故寂灭从缘生也。寂灭是生者。不生之生也。生义是灭者。不灭之灭也。不灭之灭故灭即为生也。不生之生故生即寂灭也。合而言之。生即寂灭而不守灭。灭即为生而不住生。生灭不二动寂无别。如是名为一心之法。虽实不二而不守一。举体随缘生动。举体随缘寂灭。由是道理生是寂灭寂灭是生。无障无碍不一不异。是谓一偈总别之义

经曰。尔时大众闻说是偈佥大欢喜皆得灭生灭生般若性空智海

论曰。此是第五闻说得益。即显得解总别道理。所言灭者。得上二句生义灭故。次言生者。得下二句灭义生故。是明得二义。灭生般若者。是显得二解。是依别门而得利也。性空智海者。总而观之。若灭若生不守自性。自性空智深广无边。如是名为性空智海。是依总门而得益也

    如来藏品

论曰。真俗无二一实之法诸佛所归名如来藏。今此品中明无量法及一切行莫不归入如来藏中。故就所入以立名也

经曰。尔时梵行长者从本际起而白佛言尊者生义不灭灭义不生如是如义即佛菩提菩提之性即无分别无分别智分别无穷无穷之相唯分别灭如是义相不可思议不思义中乃无分别

论曰。别明观行有六分中。显一切行出真性空竟在于前。此下第六明无量法入如来藏。就文有二。一明诸法诸行同入一处。二显入行入智因果差别。初中亦二。先明诸法入一实义。后明诸行入一佛道。初中有四。一问二答三领四述。问中有二。先领前说。后问所疑。此中问者名梵行者。是人形虽俗仪。心住一味。以是一味摄一切味。虽涉诸味之秽尘俗。不失一味之梵净行。此中显如是义。所以令其发问。从本际起者。闻佛所说即入本际。今欲发问从彼而起。生义不灭者。是领下半。是义生非灭故。灭义不生者。是领上半。是义灭非生故。如是如义者。总领一偈。不灭不生无二义故。如是无二义诸佛所觉道故言即佛菩提。觉顺无二不分不别故言即无分别。由其无所分别乃能无不分别。故言无分别智分别无穷。所以分别无穷者。只由灭诸分别故。言无穷之相唯分别灭。如是义相离言绝虑故不思议。不思议中心言绝故。乃无分别。如是领前所说偈义

经曰。尊者一切法数无量无边无边法相一实义性唯住一性其事云何

论曰。此是正问所疑。小乘教有八万法蕴。一蕴之量十百之数。今大乘教不唯八万故言法数无量无边。无边教法所诠义相更无异趣唯一实义。教法众多唯住一性甚难可解。其事云何

经曰。佛言长者不可思议我说诸法为迷者故方便道故一切法相一实义智何以故譬如一市开四大门是四门中皆归一市如彼众庶随意所入种种法味亦复如是

论曰。是第二答。于中有三。谓法．喻．合。初法说言我说诸法者谓三乘教及一乘教。为迷者故者。为未达一味者说故。方便道故者。皆入一味之方便故。入正观时不须言教故。一切法相一实义智者。因诸教法所入之相唯一实义正观智故。喻中言一市者。喻一实义。开四门者。喻四种教。谓三乘教及一乘教。是四门中皆归一市者。依四教者皆归一实故。如彼众庶随意所入者。随根浅深随入一教故。所以一市喻一实者。为是百姓之所入故。为诸众生之所归故。合中言种种法者。合于四门。次言味者。谓所趣味合于一市

经曰。梵行长者言法若如是我住一味应摄一切诸味

论曰。此是第三领解。摄诸味者。摄诸教味归一实故

经曰。佛言如是如是何以故一味实义味如一大海一切众流无有不入长者一切法味犹彼众流名数虽殊其水不异若住大海即括众流住于一味即摄诸味

论曰。此是第四述成。于中有二。总述别成。别中有三。谓法．喻．合。合中有二。一者合彼众流。先以法合后即牒喻。二者合括众流。先举其喻后以法合

经曰。梵行长者言诸法一味云何三乘道其智有异

论曰。此下第二明一切行入一佛道。先问后答。此是问异

经曰。佛言长者譬如江河淮海大小异故深浅殊故名文别故水在江中名为江水水在淮中名为淮水水在河中名为河水俱在海中唯名海水法亦如是俱在真如唯名佛道

论曰。是第二答有喻有合。初中江河淮者。喻三乘行。海喻佛道。大小异者。喻三乘心宽狭不同。深浅殊者。喻三乘智优劣有异。随前二义其名各别。俱在海中唯名海水者。喻其三乘同入十地法空真如。唯名佛道没三乘名。当知三乘差别行者。皆在地前方便道中莫不终入真如正观。所以三乘终无别归。如诸教法同入一味。合喻之言在文可见

经曰。长者住一佛道即达三行梵行长者言云何三行佛言一随事取行二随识取行三随如取行

论曰。此下大分第二入行入智因果差别。于中有四。一者入行差别。二者入智差别。三者入因事用。四者入果常住。初中有三。一者总标。住一佛道者。初地已上名住佛道。具三种智达三行故。二者问。三者答。答中有二。别明总释。别明中言随事取行者。谓依四谛十二缘起随因果事取道品行故。随识取行者。谓诸众生唯一心作。随唯识理取四摄行故。随如取行者。谓一切法悉皆平等。随平等如取六度行故。摄行属心故名为取。非谓能所分别之取

经曰。长者如是三行总摄众门一切法门无不此入入是行者不生空相如是入者可谓入如来入如来者入入不入

论曰。此是总释三行。随事行者。共小乘门。随识行者。独大乘门。此二是差别门。第三是平等门。由是道理总摄众门。又道品行不住生死门。其四摄行不住涅槃门。随如度行平等无二门故。一切法门无不此入。入是行者不生空相者。虽随如行而恒随事随识行故。不取空相而住寂灭也。可谓入如来者。虽随事识而恒随如。取平等行故可谓能入如来藏海也。入入不入者。入其入心于不入故。能入所入平等无别故曰不入。虽无别异而亦非一故。约观心假名入心。如是入心不存入相故入其入于不入也

经曰。梵行长者言不可思议入如来藏如苗成实无有入处本根利力利成得本得本实际其智几何

论曰。此下第二入智差别。先问后答。问中有二。先领前说。后问所疑。如苗成实者。如似谷苗成穗实时。无能入者无所入处。入如来藏当知亦尔。苗喻本利实喻得本。入时平等无所入处故

经曰。佛言其智无穷略而言之其智有四何者为四一者定智所谓随如二者不定智所谓方便摧破三者涅槃智所谓除电觉四者究竟智所谓入实具足道长者如是四大事用过去诸佛所说是大桥梁是大津济若化众生应用是智

论曰。是第二答。于中有三。所谓总标。别释。总明。总标中言其智无穷者。所达无边故其智亦无穷。但以义类相对。总略而说有四而已。别显中言定智者。平等性智唯在正观不作方便故名定智。对治末那我我所执随观平等故曰随如。不定智者。妙观察智在第六识方便进取故名不定。方便道时推求摧破名事等相故曰摧破。此智实通方便正观但为别定智故略举方便耳。涅槃智者。成所作智能现八相而作佛事举最后相名涅槃智。除灭五识而得此智。以是义故名除电觉。电觉者。谓五识乍起乍灭如电光故。究竟智者。大圆镜智。唯究竟位得此智故。于一切境无不穷故。入一实义故名入实。无境不现名具足道。总明中言四大事用者。用无不周故。诸佛所说者。诸佛道同故。大桥梁者。以是四智载三乘人令到一乘之彼岸故。大津济者。用此四智遍涉六道示出世道度爱河故。是故化者应用是智也

经曰。长者用是大用复有三大事一者于三三昧内外不相夺二者于大义科随道择灭三者于如慧定以悲俱利如是三事成就菩提不行是事即不能流入彼四智海为诸大魔所得其便长者汝等大众乃至成佛常当修习勿令暂失

论曰。此下第三入因事用。于中有二。长行。重颂。初中有三。略明。重显。三者领解。初中有四。一者总标。二者别解。三者合明。四者结劝。总标中言用是大用者。举前所说四智大用。位在地上乃至佛果。复有三事者。能成四智之事有三。此在地前四位中。行此三事者。初定次慧第三定慧俱行大悲为体。初言定者。即三三昧。此有多门左右异说。或言空．无相．无愿。或言无作．无相．空空．或言空。无作．无相。随宜安立皆无障碍。或名三解脱。唯在无漏故。或名三三昧。亦通有漏故。于中别义下文当说。而言内外不相夺者。内识外境共相现发。取违顺相夺诸善根。今达皆空不令夺故。于大义科随道择灭者。谓于四大及三法门随理简择。摧破诸相伏灭本识戏论种子。前三三昧伏其现缠。此简择慧损伏种子。由是遂成四智之时能拔种子得转八识故。于如慧定以悲俱利者。前慧及定皆顺如理。是故说名于如慧定。于中亦修大悲相应自利利他故言俱利。所以然者。若离大悲直修定慧。堕二乘地障菩萨道。设唯起悲不修定慧。堕凡夫患非菩萨道。故修三事远离二边。修菩萨道成无上觉。故言如是三事成就菩提。若不俱行此三事者。即住生死及着涅槃。不能流入四智大海。即为四魔所得便也。此是合明。下即劝修为第四门也

经曰。梵行长者言云何三三昧佛言三三昧者所谓空三昧无作三昧无相三昧如是三昧

论曰。此是第二重显。有二问答显前二门。此显初门。是三差别略有三义。一体用相故。二心因果故。三识见相故。体用相者。凡一切法莫过此三。法体空故立空三昧。无作用故无作三昧。无相状故无相三昧。心因果者。因果所起兴于心行。心行空故立空三昧。诸因无所有故立无作三昧。诸果不可得故立无相三昧。识见相者。诸识自体空故立空三昧。遣见分故立无作三昧。遣相分故立无相三昧。是第三门顺前内外不相夺文

经曰。梵行长者言云何于大义科佛言大谓四大义谓阴界入等科谓本识是为于大义科

论曰。是显第二门。所以四大而别立者。为显初修先择粗境。谓诸法中色法最粗。内支体等外山河等。观是等法不离四大。观是四大皆不可得。有方无方俱不成故。如是简择已。次观微细。义谓阴界入。略广中故。略摄观五。广观十八。略广中间观十二入。观察一切皆不可得。次言等者。谓余法门十二支等。如是简择观察力故。即能损伏本识之内无始戏论名言种子。始时损伏乃至断灭。所以前言随道择灭

经曰。梵行长者言不可思议如是智事自利利人过三界地不住涅槃入菩萨道如是法相是生灭法以分别故若离分别法应不灭

论曰。此是第三领解。于中有二。先领观行。后解境界。如是智事者。如是三种能成四智之事用故。自利利人者。前二自利第三利人故。过三界地者。前二定慧异凡夫故。不住涅槃者。第三大悲异二乘故。离彼二边入菩萨道也。如是已下解彼境界。谓初定境诸识见相。次智境界大义科法。如是法相皆生灭法。所以然者。由妄分别动心海故。本来静门若离分别无其所因。何由生灭。以之故言法应不灭

经曰。尔时如来欲宣此义而说偈言法从分别生还从分别灭灭诸分别法是法非生灭

论曰。此下第二以偈重颂。于中有二。一者如来略宣。二者长者广演。今此颂中所言法者。谓一心法。若妄分别动心海故。若生若灭一切诸相莫不皆从分别所作。若就本觉。本来静门离诸分别故是法非生灭。谓从本来灭诸分别。无生灭因。故非生灭。若使生之与灭皆从分别之所作者。瑜伽所说云何而通。如彼思所成地中云。无灭他用无自灭用

问。如众缘有故生。亦众缘有故灭耶

答。众缘有故生。生已自然灭。如是相违云何和会。解云。因缘道理如彼论说。唯识道理如此经说。所以二说皆有道理

经曰。尔时梵行长者闻说是偈心大欣怿欲宣其义而说偈言诸法本寂灭寂灭亦无生是诸生灭法是法非无生彼即不共此为有断常故此即离于二亦不在一住

论曰。此下长者广颂有八行偈。即为五分。一者二颂正演前义。二者二颂破诸邪解。三者一颂申己正取。四者二颂礼正说者。五者一颂请说未闻。此即第一正演前偈。于中有三。一者二句演彼下半。二者二句演彼上半。三者一颂总演二义。初言诸法本寂灭者。谓阴界等法本来寂灭故。寂灭亦无生者。非但诸法本来寂灭。寂灭之理亦无生故。第二中言是诸生灭法者。谓阴界等世俗法故。是法非无生者。从分别动有生起故。是就真俗非一之门以显动静不杂乱义。第三中言彼即不共此者。谓彼寂灭无生之法不与此生灭法共并故。为有断常故者。若彼与此共并有者。此法生灭即有断边。彼法常寂即有常边。同二乘过乖中道故。然佛所说一偈之义不堕断常故。此即离于二。不无动静故。亦不在一住。不在一住者。不守一实一心性故。离于二者举体动静非二法故。当知是事不可思议

经曰。若说法有一是相如毛轮如焰水迷倒为诸虚妄故若见于法无是法同于空如盲无日倒说法如龟毛

论曰。此是第二破诸邪解。邪解虽多大邪有二。依甚深教如言取义自谓究竟难可化故。一者闻佛所说动静无二。便谓是一一实一心。由是诽拨二谛道理。二者闻佛所说空有二门。计有二法而无一实。由此诽拨无二中道。是二邪解服药成病甚难可治。今显彼过。此二颂中次第显之。初言若说法有一者。谓如前说计有一实。如自所计说有一法故。是相如毛轮者。谓彼所计一实法相如目曀者所见毛轮故。如焰水迷倒者。谓如渴鹿见焰谓水驰走而求直是迷倒。计有一心亦如是故为诸虚妄故者。渴鹿见水曀者见轮学士计一。如是诸计齐虚妄故。次破无见。若见于法无者。谓如前说计有二谛。无一心法故。是法同于空者。彼计一心同于空理。空理之外本无一实故。如盲无日倒者。谓如生盲贫穷乞儿本未曾见日轮光明。其有目者为说有日。盲者谓无不信有日。直是颠倒。彼计亦尔。由彼本来唯学空有。而未曾闻无二中道。虽有说者不信受故。所以日轮喻于中道者。日轮圆满有大光明。唯除盲者无不见故。一心亦尔。周圆无缺有本始觉大光明照。除不信者无不入故。说法如龟毛者。彼无见者说一心法但名无体犹如龟毛。不异盲人谓无日轮也

经曰。我今闻佛说知法非二见亦不依中住故从无住取

论曰。此是第三自申正取。知法非二见者。知中道法非有无解之所见故。即离第二无日之倒。亦不依中住者。虽离二边不存中道一实而住。即离第一轮水之妄。如是离彼二边过失故。从佛教无住之诠领解所诠无住之旨。故言故从无住取也

经曰。如来所说法悉从于无住我从无住处是处礼如来敬礼如来相等空不动智不着无处所敬礼无住身

论曰。此是第四礼能说者。于中有三。一者一颂礼能说者。二者二句礼能说智。三者二句礼能说身。初中言如来所说法。悉从于无住者。谓佛教法顺从无住故。我从无住处是处礼如来者。依教得从于无住处。弥知如来最可尊重故。于是处礼能说者。此中言无住者。不住二谛亦不在中。虽不在中而离二边。如是名为无住处也。第二中言如来相者。不以相好为如来相。以不动智为如来相。言等空者。谓如来智无量无边等虚空界无所不遍故。言不动者。遍达一切无边三世。世有迁流智用不移故。第三中言不著者。法身离二边故。无处所者。中间无所住故。故言敬礼无住身也

经曰。我于一切处常见诸如来唯愿诸如来为我说常法

论曰。此是第五问所未闻。于中上半自申常对。下之二句请说常法。自申意者。我离诸边得无住智故。能一一微尘之中常见十方无量诸佛。十方世界诸微尘中无处不见无量诸佛。故言一切处常见诸如来。如华严经言。于一微尘中普见无量佛。如一微尘中一切尘亦然。故有如是力堪闻常法。所以愿闻说常法也

经曰。尔时如来而作是言诸善男子汝等谛听为汝众等说于常法

论曰。此下第四入果常法。于中有三。一如来说。二长者演。其第三者大众得益。初中有二。许说。正说。此即许说

经曰。善男子常法非常法非说亦非字非谛非解脱非无非境界离诸妄断际是法非无常离诸常断见了见识为常是识常寂灭寂灭亦寂灭

论曰。此下第二正说。于中有二。先说常果。后示常因。初中二句法常佛常。初中言常法非常法者。谓佛所师法身之体离生灭相故曰常法。离常住性故非常法。非说亦非字者。绝能诠名言故。非谛非解脱者。超所诠实义故。非无非境界离诸妄断际者。非毕竟无亦非有境。非有境故离妄执境。而非无故离断见境。际者。境界之异名也。是法非无常离诸常断见者。非无常故离诸断见。而是法故离诸常见。常见所取非是法故。已明法常次显佛常。了见识为常者。于彼常法究竟了见。了见之时诸识为常。所以然者。前随无明动本静心。今随了见归本静故。是识常寂灭者。诸识本来无生无灭。无生灭故性常寂灭。今了见时永灭如是寂灭之识。故言寂灭亦寂灭也。所以然者。彼寂灭识是无常法。所以灭彼乃得常故。至下总持品是义当显。又此本来寂灭之性不守常性故言亦寂灭

经曰。善男子知法寂灭者不寂灭心心常寂灭得寂灭者心常真观

论曰。此下第二示其常因。于中有二。别明总结。别中亦二。先真证观。后方便观。初中言知法寂灭者者。初地已上知一切法本来寂灭故。既知无起故不灭心。不灭心者。常寂灭故。是显所知之寂灭也。得寂灭者心常真观者。是明能证之心常住。随所证理离生灭相。而恒不失真照观故

经曰。知诸名色唯是痴心痴心分别分别诸法更无异事出于名色知法如是不随文语心心于义不分别我

论曰。是第二明其方便观。于中有二。先明唯识寻思。后显其如实智。初中言更无异事出于名色者。名谓四蕴。色是色蕴。诸不相应皆假建立。离此名色更无别体故。诸有为之事皆为名色所摄。如是诸法唯心所作。离心无境离境无心。如是名为唯识寻思。如华严经言。心如工画师。画种种五阴。一切世间中。无法而不造。如心佛亦尔。如佛众生然。心佛及众生。是三无差别。故已明寻思。次显如实智。知法如是不随文语者。是名寻思所引如实智故。心心于义不分别我者。是义寻思所引如实智故。人法二我皆无有义。所以于中不分别故

经曰。知我假名即得寂灭若得寂灭即得阿耨多罗三藐三菩提

论曰。此是第二总结。前二结前方便而得真观。又结真观得菩提果

经曰。尔时长者梵行闻说是语而说偈言名相分别事及法名为三真如正妙智及彼成于五我今知是法断常之所系入于生灭道是断非是常如来说空法远离于断常

论曰。此下第二长者演说。于中八颂即有三意。初二颂半判佛教意。次有五颂破二边执。最后二句。亦无二观。初中有二。前二颂明堕二边教。后二句显离二边教。初中言名相者。谓名句字。句是名所成。字是名所资。皆能表名合为名相也。分别事者。谓诸有漏心心法事。言及法者。谓除前二所有法相。名句所诠分别所缘。谓十色处及法处中色不相应等诸法相也。是三一类明杂染相。所以别说名为三也。言真如者。谓正智境。正妙智者。本后二智。言及彼者。及彼前三。此二及彼三合成于五事。是举三乘教门法相。我今知是法断常之所系者。明彼教门所说五事不离断常二见所著。所以然者。彼四种法带生灭相不离断见所著之境。其真如法是常住性不离常见所取之境故入于生灭道。是断非是常者。别明前三及正智法皆带四相入生灭道。直是断边异于常边。即显真如入常有道。直是常边异断边也。如来说空法．远离于断常者。明一乘教．说三空法．远离断常二边过失。所以然者。如前所说。空相亦空。空空亦空。所空亦空。如是三空不坏真俗不存真俗。虽离动静不住中间。所以远离断常边也

经曰。因缘无不生不生故不灭因缘执为有如采空中华犹取石女子毕竟不可得

论曰。此下第二破二边执。于中有二。一者四颂破有边执。二者一颂夺空边着。初中有二。前二颂半破其有执。后一颂半示彼真空。初中亦二。初一颂半破因缘执。次有一颂破余三缘。初中言因缘无不生者。谓本识中一切种子与异熟识若即若离皆不可得。即如异熟离犹兔角。不即不离亦无所有。如瓶舍等。但有名故。由是道理无生无灭。而依三乘言教学者定执实有因缘种子。不异愚者欲采空华。亦如欲取石女之子。同彼因缘永不可得。此中空华喻于染种。为采灭故。石女儿者喻于净种。为取养故

经曰。离诸因缘取亦不从他灭及于己义大依如故得实

论曰。此是破余三缘。若有离诸种子因缘取余三缘计从彼生作如是执亦不应理。如经亦不从他灭故。此言他者。谓增上缘及所缘缘。如眼识生依眼缘色。如是眼色与识俱时而非识性故名为他。等无间缘虽是识类而体已灭故名为灭。若他若灭皆无自性。是故识生亦不从彼。次言及于己义大者。复有计言蕴界等法未来世中各有己体而未生现。从此己体而生现在。为遮此计故言亦不从及于己义大。上句不从之言贯于此下句故。此言义者。谓阴界入。大者四大。如前说故。计此等法本有自体。以之故言己义大也。依如故得实者。谓我能破诸有执者依如理破故得实义

经曰。是故真如法常自在如如一切诸万法不如识所化离识法即空故从空处说

论曰。此是第二示真空法。言是故者。是前执有皆是虚妄。其能破者得实之故。真如不动妄法不成也。识所化者。谓识所计。彼所计相理无所有。直从情有故名所化。诸法非如识所化故。离识之法空无所有。是故我从空处说如

经曰。灭诸生灭法而住于涅槃大悲之所夺涅槃灭不住

论曰。上文已破凡夫执有。此颂亦夺二乘住空。谓二乘人灭诸身智生灭之法入于涅槃。于中八万劫住乃至十千劫住。而由诸佛同体大悲夺彼涅槃令还起心。起心之时涅槃即灭。如大商主灭其化城。是故于中不复住也。彼无心时不得正破。直显诸佛夺彼涅槃。因是遮彼未入者志。上来已破有无二边

经曰。转所取能取入于如来藏

论曰。此是第三示无二观。已破凡圣二边之执故。今转彼凡圣二众令入能所平等之观。上来八颂长者演也

经曰。尔时大众闻说是义皆得正命入于如来如来藏海

论曰。此是第三大众得益。得正命者。离有无边而得中道正慧命故。入如来者。已入如来智之分故。入如来藏海者。入于本觉深广义故

    总持品

论曰。此中决前诸品中疑。总持要义而不忘失故从所为名曰总持。又地藏菩萨已得文义陀罗尼故。总持诸品所有文义及忆大众起疑之处次第发问善决诸疑。故从能问名曰总持

经曰。尔时地藏菩萨从众中起至于佛前合掌胡跪而白佛言尊者我观大众心有疑事犹未得决今者如来欲为除疑我今为众随疑所问愿佛慈悲垂哀听许佛言菩萨摩诃萨汝能如是救度众生是大悲愍不可思议汝当广问为汝宣说

论曰。正说之内大分有二。别明观行竟在于前。此下第二总决诸疑。就文有四。初请次许三决四领。此问与答是请及许。此能请者名地藏者。是人已得同体大悲。生长一切众生善根犹如大地。生诸草木。以陀罗尼持诸功德。惠施一切而无穷尽。如大宝藏珍宝无尽。由是二义名为地藏。今此品中决诸疑惑生诸信解。出诸决断之宝以施求法之众。义当其名故能请问

经曰。地藏菩萨言一切诸法云何不缘生尔时如来欲宣此义而说偈言若法缘所生离缘可无法云何法性无而缘可生法

论曰。此下第三正决诸疑。于中有二。一者六品六疑却次而决。二者一品三疑顺次而遣。初中亦二。一者别决。二者总定。初别决中别决六疑。从后向前渐却而决。今此问答决如来藏品中起疑。彼言因缘无不生。不生故不灭。于中执有能生因缘而疑其果何不缘生。故乘彼疑以问缘生。如来一颂正决是疑。于中上半定彼本执。下半乘彼破其缘生。此意正立缘不生法望无法故如望兔角。由是比量彼疑决矣

经曰。尔时地藏菩萨言法若无生云何说法法从心生于是尊者而说偈言是心所生法是法能所取如醉眼空华是法然非彼

论曰。此下第二决真性空品中起疑。彼言我说法者以汝众生在生说故。是故说之。依此疑云。若依彼文佛有说法。其所说法从佛心生。云何而言法无生耶。为遣此疑即有二重。一者直遣。二者重决。此即直遣。言是心所生法。是法能所取者今汝所计心所生法。直是妄心能取所取。如醉酒眼所见空华。是法然非彼者。是汝所计心所生法如彼空华。是法亦然。非彼所说法。同汝所计生。此意正明汝所计法空无所有是所取故犹如空华。我所说法离言绝虑所取能取皆不可言

经曰。尔时地藏菩萨言法若如是法即无待无待之法法应自成于是尊者而说偈言法本无有无自他亦复尔不始亦不终成败即不住

论曰。此是第二重决。于中有二。先难后决。是难意云。若佛所说言教之法非所取故不如空华毕竟无者。是即此法应自然成。以无待故。犹如真如。为决此难故说是偈。是偈意言。我所说法绝名言故。本无有无自他始终若成若败即不得住。云何得言自然成耶。是显彼因有相违过。谓法无成败。以无待故。如无所取。又如真如。由是道理彼难不成。难不成故所疑决矣

经曰。尔时地藏菩萨言一切诸法相即本涅槃涅槃及空相亦如是无是等法是法应如佛言无如是法是法是如

论曰。此下第三决入实际品中起疑。彼言大力菩萨言。众生心相相亦如来。众生之心应无别境。佛言如是众生之心实无别境。何以故。心本净故。理无秽故。有依是文作是念言。本净之心正是如理。本来清净自性涅槃。若使涅槃亦空无者。应是邪无不为如理。为遣是疑故说皆如。就文有四。先问次许三领四述。初问意言。若以空义。一切诸法相即是本来清净涅槃。复融涅槃及其空相。即无涅槃及空差别。是一味法。是法应如。反彼所执故作是问。第二答中许如所问

经曰。地藏菩萨言不可思议如是如相非共不共意取业取即皆空寂空寂心法俱不俱取亦应寂灭

论曰。此是第三领解。为遣伏难。有闻前说作是难言。本来涅槃既是一如。若融涅槃及其空相是第二如。如是二如为共不共。若言共者即非如理。有二并故。若不共者即不更空。唯一如故。为遣是难故言非共不共。非共者。无二如故。非不共者。有双遣故。所遣虽双遣处无二。故彼所难皆不应理。意取业取即皆空寂者。是显双遣。遣处无二。言意取者。所谓涅槃。缘寂灭心之所取故。言业取者。即是生死。诸烦恼业之所取故。此二皆空。空寂无二。空寂心法俱不俱取亦应寂灭者。明一心法亦不守一。生死涅槃空寂无二。无二之处是一心法。依一心法有二种门。然俱取二门即不得心二非一故。若废二门不俱而取亦不得心无非心故。由是义故无二心法俱不俱取亦应寂灭

经曰。于是尊者而说偈言一切空寂法是法寂不空彼心不空时是得心不有

论曰。此是第四如来述成。一切空寂法者。生死涅槃一切空寂之法。是法寂不空者。无二之心法非都无法故。虽非无法而不是有。是故解心不空之时是时得知心之不有。所以前说俱不俱取皆应寂灭者不违道理也

经曰。尔时地藏菩萨言是法非三谛色空心亦灭是法本灭时是法应是灭于是尊者而说偈言法本无自性由彼之所生不于如是处而有彼如是

论曰。此是第四决本觉利品中起疑。彼言无住菩萨言。一切境空。一切身空。一切识空。觉亦应空。佛言可一觉者。不毁不坏决定性。非空非不空。无空不空。依此述文。于彼生疑云。若是一心亦不是有故寂灭者。何故前说一觉不坏故不同彼色心之空。今乘是疑故作是问。是法非三谛者。即前颂说。是一心法非色心空。故非三谛。然三谛门略有三种。一者色谛心谛第一义谛。二者有谛无谛中道第一义谛。三者如此品中后文所说。今此问意且依初门。色空心亦灭者。是法既非三谛摄故。色相本空心亦寂灭。是色心法本寂灭时是一心法应同寂灭。即前偈言。心不有故。是即前说不同空者。徒为虚谈。如是疑也颂中对此明其不同。法本无自性者。色心之法本无自性。由彼之所生者。由彼本觉之心所生。所生色心是差别相。彼本觉心离相离性。不于如是差别之处而有如彼离相一觉。是故空此色心差别相时不得同遣离相一觉。由是道理前非虚说

经曰。尔时地藏菩萨言一切诸法无生无灭云何不一于是尊者而说偈言法住处无在相数空故无名说二与法是即能所取

论曰。此是第五决无生行品中起疑。彼言缘起非生。缘谢非灭。在无有处。不见所住。决定性故。是决定性不一不异。有依彼文而起疑云。色心等法无生无灭。即是平等决定实性。是即横无色心之差。纵无生灭之别。无差无别。应是一味。不异可尔。云何不一。颂中对此显不一义。法住处无在者。诸法之住及所住处皆无所有故。相数空故无者。色心等相一异等数悉空故无也。相数既无。那得有一。又无色故即无心相。既非异者。如何是一而有名说之二。及有所说法者。是即能取妄心所取非如实义。有一二等。言名说者。名是诠用。意识所取。说是语声。耳识所了。若言是一即有此二。于中亦有所诠之法。如是等数妄心所取。非彼实义。有如是数。云何于中存一味耶

经曰。尔时地藏菩萨言一切诸法相不住于二岸亦不住中流心识亦如是云何诸境界从识之所生若识能有生是识亦从生云何无生识能生有所生于是尊者而说偈言所生能生二是二能所缘俱本名自无取有空华幻识生于未时境不是时生于境生未时是时识亦灭彼即本俱无亦不有无有无生识亦无云何境从有

论曰。此是第六决无相法品中起疑。彼言云何生灭虑知相。佛言理无可不。若有可不即生诸念。千思万虑是生灭相。今依后说还疑彼文。若识能生可不之境。境相还生诸念之识即是心识。有生有灭。云何而言不住二岸。若诸心识无生无灭。云何诸识能生境界。乘如是疑发如是问。不住二岸者。无生无灭故。不住中流者。而不是一故。心识既尔无生无灭。云何可不境界从识之所生耶。若识能生境识亦从境生。云何无生识能生有所生。为遣此疑故说三颂。三颂之文即判为二。初之一颂示其道理。后之二颂破相生执。初中言是二能所缘者。谓汝所计识是能生。境是所生。直是妄取能缘所缘俱是本来但名无自。若取为有如取空华及取幻象以为实有。是故不异无生无灭。破中言识生于未时境不是时生者。明识能生未有之时所生境界于时不生也。于境生未时是时识亦灭者。明境能生未有之时其所生识于时亦灭。灭者寂灭谓本来无也。彼即本俱无亦不有无有者。彼二能生本来俱无。既无能生亦不令有。故曰不有。不令有故后时无生。故言无有也。无生识亦无者既无生义。何得有识。识无有故境不从有。此中即有二种比量。一识不生。无能生故。如望燋种。二境不起。无所从故。如从龟毛。上来六分别决疑竟

经曰。尔时地藏菩萨言法相如是内外俱空境智二众本来寂灭如来所说实相真空如是之法即非集也

论曰。此下第二总定所说。总定六决非病是药。于中有二。先定非病。后定是药。初中亦二。审问。定许。问中言法相如是者。总领前说六分法相。言内外者。识内境外故。言二众者。境智众多故。言非集者。非集生死杂染患故。非如恶取空还集诸患故

经曰。佛言如是如实之法无色无住非所集非能集非义非大一本科法深功德聚

论曰。此是如来定许。言无色者。不生著有之病故。无住者。亦离恶取空患故。非所集者。苦谛空故。非能集者。集谛空故。非义者。离阴界等差别义故。非大者。离地水等能造相故。一本科法者。是一本觉。以是为根能生诸行及诸功德故。然科有二种。一者杂染之科。谓诸本识。义如上说。二者纯净之科。谓一本觉。如此文说。彼本识中积集一切杂染种子。此本觉中唯有甚深性功德聚。离相离性故名为深。过恒沙数故名为聚

经曰。地藏菩萨言不可思议不思议聚七五不生八六寂灭九相空无有空无有无空无有如尊所说法义皆空入空无行不失诸业无我我所能所身见内外结使悉皆寂静故愿亦息如是理观慧定真如尊者常说寔如空法即良药也

论曰。此下第二番定是药。于中亦二。先菩萨审问。问中有三。一者领前深功德聚。二者乘显深入理观。三者审问良药胜德。初中亦三。总标别显后还总结。不思议聚者。总标离相离性功德。别显之中先明离相后显离性。初中言七五不生者。合明二种末识之空。恒行识中第七是末。不恒行中五识为末故。八六寂灭者。合明二种本识之寂。恒行识中第八是本。不恒行中第六为本故。次显离性。九相空无者。第九识相亦不守性故。有空无有者。重成离相。八识有相之法空无所有故。无空无有者。重成离性。九识无相之性空无所有故一心如是离相离性。即是无量功德之聚。如是名为不思议聚。如尊所说法义皆空者。第三总结离相离性也。次明理观。于中有二。别明．总结。别明之中即有三句。入空无行不失诸业者。是空三昧。谓理观入空而无能所之行。虽无能所不失六度等业故。次明无相三昧。无我我所能所身见者。是离属见诸烦恼相。离我我所相能见所见相故。内外结使悉皆寂静者。是离属爱诸结使相。内门诸结外门诸使三界烦恼诸相空故。如是名为无相三昧。故愿亦息者。是明无愿三昧。由三界法皆寂静故。愿求之心自然永息。如是名为无愿三昧也。如是理观慧定真如者。是总结句。如前三种皆是理观止观无偏能所无二故。尊者常说寔如空法即良药也者。第三审问。如是空法具诸功德治诸结使。是故应即为良药耶

经曰。佛言如是何以故空故空性无生心常无生空性无灭心常无灭空性无住心亦无住空性无为心亦无为空无出入离诸得失阴界入等皆悉亦无心如不着亦复如是菩萨我说诸空破诸有故

论曰。此是如来定许。于中有三。一者总许。言空故者所以为良药者。只由空故有即生病故。空性已下第二别许。于中有二。先明服空药故离流转之果患。后显服空药故治取着之因病。初中言空性无生心常无生者。入空之心同空无生故。又随无灭心常无灭。生灭正是无常之义故翻彼二名为常也。心亦无住者。非但无初后相亦无中间住相。此是别明离三相也。心亦无为者。总显离彼三有为相。是明服空离无常病。次明亦离取着之病。无出入者。无有出观入观之异。离得失者。亦离得新失古之相。心如不着亦如是者。能观之心亦如空理。不取出入得失之相。不着阴界入等之法。是明服空离取着病也。我说诸空破诸有故者。第三结定。就实而言。空理无二。而说五三等诸空者。为破诸人著有病故。随病众多说空亦尔。又复理实非空不空。但为破有强说为空。非空言下存空性也。以是二意结诸空教

经曰。地藏菩萨言尊者知有非实如阳焰水知实非无如火性王如是观者是人智耶

论曰。六品六疑却次而决。别决总定竟在于前。此下第二一品三疑顺次而遣。于中有三。谓如来藏一品之中复起三疑次第遣故。第一疑者。谓彼梵行长者颂言。若说法有一。如焰水迷倒。又言若见于法无。如盲无日倒。有依彼说而生疑云。长者俗人如是判说。为妄见耶。为真智耶。作如是疑不肯信受。为遣彼疑举彼事问。焰水之喻如前已说。知实非无者。能知一实义性非无。彼说计无实者。如盲无日倒故。是知长者。知实非无。非无之义如火性王。谓如木中有火大性。分析求之不得火相。而实不无木中火性。钻而求之火必现故。一心亦尔。分析诸相不得心性。而实不无诸法中心。修道求之一心显故。如是火性相隐势大如似国主。故名王也。长者如是离二边观。是人智耶。如是问也

经曰。佛言如是何以故是人真观观一寂灭相与不相等以空取以修空故不失见佛以见佛故不顺三流

论曰。此下如来决疑。于中有二。直决释决。言如是者。决是人智。何以故下释其是智。于中有二。略释广演。初中言观一寂灭者。观一心法寂灭义故。相与不相等以空取者。观有相俗与无相真等不存故。融为一故。如是修空正顺佛心故。常见佛身。夫曾失时故言不失见佛。以常见佛弥增空观。空观增进违逆诸有。故言不顺三流。三流具摄三界烦恼。谓欲流有流及无明流。是谓三流义如常说

经曰。于大乘中三解脱道一体无性以其无性故空空故无相无相故无作无作故无求无求故无愿以是业故净心以心净故见佛以见佛故当生净土菩萨于是深法三化勤修慧定圆成即超三界

论曰。此是第二广演。于中有二先明三解脱道胜利。后显三化勤修胜利。初中言一体无性者。对彼小乘三解脱门别体有性故。显大乘菩萨观行一体。观心证无性时随义假说立三解脱。约其忘体性义立空解脱。忘即体相义门立无相解脱。忘即体用义门立无作解脱。亦名无愿解脱。为显唯一无分别观。于一切法体性相用。无所不遣无所不融。是故建立三解脱门。以是业故净心者以忘一切体相用故。能净出观涉俗之心离诸染着。离染着心能见报佛。见报佛故得生净土。是为三解脱道胜利也。于是深法三化勤修者。谓于空法勤修三空。何者。空相亦空是一化修。空空亦空是二化修。所空亦空是三化修义如前说故不别论。三化勤修即达一心。达一心故慧定圆成。圆成之地即超三界。是为三化勤修胜利也

经曰。地藏菩萨言如来所说无生无灭即是无常灭是生灭生灭灭已寂灭为常常故不断是不断法离诸三界动不动法于有为法如避火坑依何等法而自呵责入彼一门

论曰。此下遣其如来藏品之第二疑。彼言了见识为常。是识常寂灭。寂灭亦寂灭。有依彼文而生疑云。如是常住之寂灭法虽可欣乐而是希夷。众生之心粗浅难调。如何调心得趣彼门。乘如是疑作如是问。问中有二。初举果远。后问入因。初中言无生无灭。即是无常者。即领前言是识常寂灭。本来寂灭故。是无生无灭。而本非常故是无常也。灭是生灭生灭灭已寂灭为常者。即领前言寂灭亦寂灭。又言了见识为常。于有为法已下第二正问。趣入彼门方便前虽有说。方便正观而略说故更请广说

经曰。佛言菩萨于三大事呵责其心于三大谛而入其行地藏菩萨言云何三事而责其心云何三谛而入一行。佛言三事者一谓因二谓果三谓识如是三事从本空无非我真我云何于是而生爱染观是三事为系所飘飘流苦海以如是事常自呵责三谛者一谓菩提之道是平等谛非不等谛二谓大觉正智得谛非邪智得谛三谓慧定无异行入谛非杂行入谛以是三谛而修佛道是人于是法无不得正觉得正觉智流大极慈己他俱利成佛菩提

论曰。是文有四。初问．次答．三请．四说。说中有二。先说呵厌方便。后示趣入方便。初中言因者五戒十善之因。果者人天富乐之果。识者能持因果即是本识。众生计此为自内我。而是性空故非是我。无我之理方是真我。故于非我不应爱染。观是三事为系所飘者。谓由四系障理定心。令是三事飘流苦海故。何等名为四系。如对法论谛品中云。系有四种。谓贪欲身系．嗔恚身系．戒禁取身系．此实执取身系。以能障碍定意性身故名为系。所以者何。由此能障定心自性之身故名为系。非障色身何以故能为四种心乱因故。谓由贪爱财物等为因令心散乱。于斗诤事不正行为因令心散乱。于难行戒禁苦恼为因令心散乱。不如正理推求境界为因令心散乱。由彼依止各别见故。于所知境不如正理种种推度妄生执着。谓唯此真余并愚妄。由此为因令心散动。于何散动。谓于定心如实智见故。以如是事常自呵责者。呵责能飘四系而厌所流三事故。已说呵厌方便。云何趣入方便。所谓审谛于三谛故。一谓菩提之道是平等谛非不等谛者。谓佛所证性净菩提无不通泰故名为道。一切有情皆同此性无一不归。是究竟道故言平等非不平等。是即对治二乘别趣也。二谓大觉正智得谛非邪智得谛者。谓一切智大觉之果唯证平等正智所得。非缘冥谛大有等境邪智所得。是即对治诸外道执也。三谓慧定无异行入谛非杂行入谛者。谓得正智入平等时。慧定圆融无别行相。方是真入于平等谛。非如世间分别之心。王数别体定慧异行。如是杂行非真入故。是即对治世间观行未证谓证增上慢者。如是三种通名谛者。审谛之观。所观境故。遍治如是三种异执。乃能正修于一佛道故。言以是三谛而修佛道。次显修道所得之果。是人于是法无不得正觉者。是显自利智德之果。于是三法而修佛道。无有不获正觉果故。得正觉智流大极慈者。是显利他恩德之果。普流大极无缘之慈。遍周法界无不利故。己他俱利成佛菩提者。总结前二。二利圆满。成等觉故

经曰。地藏菩萨言尊者如是之法即无因缘若无缘法因即不起云何不动法入如来

论曰。此下遣彼如来藏品第三之疑。如彼品颂末言。转所取能取入于如来藏。有依此说而疑彼云。此中菩提之道平等之谛即是如来藏不待因缘力。云何彼转能所之因而能得入如来藏法。有作是疑故乘彼问。即无因缘者。由平等故不从因缘。又平等故即无余缘。余缘无故因不能起。云何于彼无起动法。而用因缘得入如来。若用因力之所入者。即待因缘非不动故

经曰。尔时如来欲宣此义而说偈言　一切诸法相性空无不动是法于是时不于是时起法无有异时不于异时起法无动不动性空故寂灭性空寂灭时是法是时现离相故寂住寂住故不缘

论曰。此下如来正决所疑。宣其平等不动而有得入之义。八行颂中即有二分。前三略说。后五广宣。略中有二。前三颂明不动之义。后一颂显得入之义。初中有三。谓标．释．结。谓初二句标不动义。次有四句释不动义。是法于是时不于是时起者。是时者谓此世。此世者是现在。现在之时永无暂住。细除已未即无中间。如除光阴无中间处。故于是时不得有起。法无有异时不于异时起者。言异时者所谓过未。未来未有故无起义。过去已无亦无起义。由是道理法无起动。既无生起之动亦无恒住不动。故言法无动不动性空故寂灭。是二句者结不动义。次有一颂明得入义。性空寂灭时者。了见性空寂灭之时。不动之法是时显现。显现于心故言得入。如是上半明得入义。然此显法离一切相。离诸相故寂静而住。住寂静故恒不从缘。是故虽有入不废离缘义。如是下半显离缘义也

经曰。是诸缘起法是法缘不生因缘生灭无生灭性空寂缘性能所缘是缘本缘起故法起非缘缘无起亦尔因缘所生法是法是因缘因缘生灭相彼即无生灭

论曰。此下第二广宣于中有二。是前三颂广不动义。其后二颂宣得入义。初中亦二。谓前二颂推本无得以显不动。后之一颂逐末无得以显不动。初中有三。谓标．释．结。初言是诸缘起法是法缘不生者。标诸果法其缘不生。次有四句释不生义。因缘生灭无者。明诸因缘生灭不住故无生果之功能也。生灭性空寂者。以不住故即无生灭。性空寂故亦不生果。缘性能所缘者。因缘种子冥伏名性。增上缘根能对境界故名能缘。所缘境界根所对故名为所缘。次第缘法灭故不论。如是种子性缘并其能所二缘皆是本缘之所起故。故言是缘本缘起。是即其本。诸缘亦同前说。生灭性空故无生用。由是三义缘无生义。故法起非缘者。结果法起非缘所生。缘无起亦尔者。结缘无起亦同其果。次有一颂逐末无得以显不动。因缘所生法是法是因缘者。明诸果法亦为因缘。望后生法而作缘故。是诸果法既为因缘即同前说。生灭性空故言因缘生灭相彼即无生灭。前略说时直显果空故。今广时就因缘说欲显诸法因果不动即是平等菩提之道。非此法外别求菩提。是谓此偈之大意也。如肇法师言。道远乎哉。触事而真。圣远乎哉。体之即神矣

经曰。彼如真实相本不于出没诸法于是时自生于出没是故极净本本不因众力即于后得处得得于本得

论曰。此二颂是宣得入义。于中有三。一者一颂对诸有动显如不动。二者二句明不动本不待众缘。三者二句明离缘法有得入义。后得处者。谓道后处。前略说中言寂灭时即是此言后得之处。既是寂灭何有处时。但离时处故寄之时处耳。得得于本得者。始觉究竟故名为得。是能得故。始觉究竟还同本觉。以之故言得于本得。上来第三决疑分竟

经曰。尔时地藏菩萨闻佛所说心地快然时诸众等无有疑者知众心已而说偈言　我知众心疑所以殷固问如来大慈善分别无有余是诸二众等皆悉得明了我今于了处普化诸众生如佛之大悲不舍于本愿故于一子地而住于烦恼

论曰。此是第四领解。此三颂中即有二分。前一颂半结前决疑之利。后一颂半申后普化之行。一子地者。初地已上。已证一切众生平等视诸众生如视一子。是名清净增上意乐。寄喻表心名一子地。而住于烦恼者。菩萨虽得诸法平等。而以方便力不舍烦恼。若舍一切烦恼随眠便入涅槃违本愿故。如瑜伽论三摩呬多决择中云。灭尽等至当言无漏。由与烦恼不相应故。非相应故。无所缘故。非诸烦恼之所生故。是出世间一切异生不能行故。唯除已入远地菩萨。菩萨虽能起出世法令现在前。然由方便善巧力故不舍烦恼。案云。此中言不舍者。非究竟舍。如罗汉等。故曰不舍。非全不舍。故言不舍。于中委悉。如二障章说。由不舍故言住烦恼。由是不入涅槃普化十方界故。此一卷经有三分中。第二正说竟在于前也

经曰。尔时如来而告众言是菩萨者不可思议恒以大悲拔众生苦若有众生持是经法持是菩萨名即不堕于恶趣一切障难皆悉除灭若有众生无余杂念专念是经如法修习尔时菩萨常作化身而为说法拥护是人终不暂舍令是人等速得阿耨多罗三藐三菩提

论曰。此下第三名流通分。于中有六。一者赞人流通。二者劝众流通。三者立名流通。四者受持流通。五者忏悔流通。六者奉行流通。此即第一赞人流通。赞能流通。是经菩萨四种胜德。一者大悲普化一切功德。二者别益持是经者功德。三者化身说法功德。四者令得极果功德

经曰。汝等菩萨若化众生皆令修习如是大乘决定了义

论曰。此是第二劝众流通。决定了义者。为显最深最极。不可以加矣

经曰。尔时阿难从座而起前白佛言如来所说大乘福聚决定断结无生觉利不可思议如是之法名为何经受持是经得几所福愿佛慈悲为我宣说

论曰。此下第三立名流通。先问后答。问中亦二。先领后问。领中即显是经四种胜能。一能令持者得无量福。如经大乘福聚故。二能令持者永断诸结。如经决定断结故。三者所诠之旨是本觉利。如经无生觉利故。四者能诠之教难可思量。如经不可思议故。次问中问二事。先问经名。为知经要故。后问持福。求福持经故

经曰。佛言善男子是经名者不可思议过去诸佛之所护念能入如来一切智海若有众生持是经者即于一切经中无所希求是经典法总持众法摄诸经要是诸经法法之系宗是经名者名摄大乘经又名金刚三昧又名无量义宗

论曰。此下答中有二。如其次第答二问故。初中亦二。先赞名义。后正立名。初中亦二。先总叹名。后别显义。能入已下是别显义。即显三义。能入如来智海乃至无所希求者。是显金刚三昧之名之义。无法不坏无理不穷。由是令入如来智海。过是更无所希望故。是经典法总持众法摄诸经要者。是显摄大乘经之名之义。是诸经法法之系宗者。是显无量义宗之名之义。是二名义有何差别者。前明广摄众经之义。后显众经所宗之极。次立三名于中委悉者。文前二门中已广说也

经曰。若有人受持是经典者即名受持百千诸佛如是功德譬如虚空无有边际不可思议我所嘱累唯是经典

论曰。此是答第二问。于中即显四种胜德。一者持佛胜德。是经能摄诸佛心故。如经受持百千诸佛故。二者广大胜德。如经无有边际故。三者甚深胜德。如经不可思议故。四者无比胜德。如经唯是经典故

经曰。阿难言云何心行云何人者受持是经佛言善男子受持是经者是人心无得失常修梵行若於戏论常乐净心入于聚落心常在定若处居家不着三有

论曰。此下第四受持流通。于中有二。一者正明受持。二者往复重显。初中亦二。先问后答。问中有二。先问受持经者心行。后问受持经者福利。答中次第答此二问。初中即明五种心行。一心无得失者。不观他人之长短故。二常修梵行者。内修离相之净行故。三常乐静心者。在动不动故。四心常在定者。入散不散故。五不着三有者。居染不染故

经曰。是人现世有五种福一者众所尊敬二者身不横夭三者辩答邪论四者乐度众生五者能入圣道如是人者受持是经

论曰。此是答第二问。随前五行得此五福。众所尊敬者。由其不观众之长短故。身不横夭者。由其常修离相行故。辩答邪论者。乐静心故。乐度众生者。入散常定故。能入圣道者。不着三有故

经曰。阿难言如彼人者度诸众生得受供不佛言如是人者能为众生作大福田常行大智权实俱演是四依僧于诸供养乃至头目髓脑亦皆得受何况衣食而不得受善男子如是人者是汝知识是汝桥梁何况凡夫而不供养

论曰。此下往复重显。于中有二。先明福田之体。后显生福之能。此即初也。四依僧者。第一依是具烦恼性。位在地前。其余三依位在地上。如涅槃经之所广说

经曰。阿难言于彼人所受持是经供养是人得几所福佛言若复有人持以满城金银而以布施不如于是人所受持是经一四句偈供养是人

论曰。此是第二明持经者能生多福。以满城金银施不持经者所得之福不如一餐一衣。供养持此一四句偈之所得福故

经曰。善男子令诸众生持是经者心常在定不失本心若失本心即当忏悔忏悔之法是为清凉

论曰。此下第五忏悔流通。于中有二。先赞忏悔功德。二者往复重显。初中言清凉者。灭不善因沉浊故清。离生死果热恼故凉。

经曰。阿难言忏悔先罪不入于过去也佛言如是犹如暗室若遇明灯暗即灭矣善男子无说悔先所有诸罪而以为说入于过去

论曰。此下第二往复重显。于中即有二番问答。初番显其忏悔道理。后番显其忏悔行法。此中问意言忏悔先罪名忏悔者。先罪不入于过去耶。若先非今故入过去者。云何于无罪而有忏悔耶。答中言如是者。如是先罪不入过去故。不于无而有忏悔。所以然者。先所作罪熏于本识。种子恒流在于现在。由是道理未入过去。且今忏悔。能治生时令彼罪种不流现在。如灯生时室暗方灭。罪种不至于今现故。是时方说令入过去。而无说悔先所有罪者。先所有者非悔所及。不能令彼非先有故。但其先有令不至现。不至现者由悔所为。此与断结之义异者。彼约生灭道故。令未生者不至现在。此就相续道故。令先有者不至现在。又断结者永断种子。悔先罪者。损伏种子。增强之用不至现在故。约此义说入过去也

经曰。阿难言云何名为忏悔佛言依此经教入真实观一入观时诸罪悉灭离诸恶趣当生净土速成阿耨多罗三藐三菩提

论曰。此是第二忏悔行法。答中有二。先明行法。后示胜利。初中言依此经教入真实观者。谓依金刚三昧教旨破诸法相名入真实。此是地前相似真观。一入观时诸罪悉灭者。一切罪障从妄想生。今破诸相入真实观。顿破一切妄想境界。所以诸罪一时悉灭。次显胜利即有二句。离诸恶趣当生净土者。是明华报。速成阿耨多罗三藐三菩提者。是示果报

经曰。佛说是经已尔时阿难及诸菩萨四部大众皆大欢喜心得决定顶礼佛足欢喜奉行

论曰。此是第六奉行流通。于中四句。皆大欢喜者。闻法欢喜故。心得决定者。离诸疑惑故。顶礼佛足者。重法敬人故。欢喜奉行者。行时转喜故

甚深且微金刚教今承仰信略记述愿此善根遍法界普利一切无遗缺

金刚三昧经论卷下

伏为宝祚无疆储闱凝庆氛尘永寝朝野升平晋阳公福海等浚寿岳齐高次愿孀亲洎及佛奴变呻为讴向年有永镂板印施重念此经出自虬宫发起因于疾病更愿普及法界含生生生不闻疾病之音不处胞胎常游诸佛净妙国土尔甲辰八月初五日优婆塞郑晏志


金光明经疏

    No. 1787 [cf. No. 663]

金光明经疏

        沙门吉藏撰

法身幽寂寿无长短。至人绝虑有感必通。大权方便任机应说。是以四佛现室宣常住之旨。菩萨感梦说忏悔之方。因兼二善总该万行。果升灵觉寿等虚空。所以十地遵修此理。四王叹护经德。依经讲说障难消散。托法愿求福乐随心。故此经以正法中道为体。三点四德为宗。若具存天竺正音。应言佛陀槃遮修拔那婆罗婆修修多罗也。佛陀云觉者。槃遮云说。而略两目。修拔那婆罗婆修者。此云金光明。修多罗者此云含五义。以经义代之。经者训法训常。亦经由也。故云金光明经也

金光明经者。乃是究竟大乘菩萨藏摄。是顿教所收。论其宗极表三种三法。一表三身佛果。二表涅槃三德。三表三种佛性。表三身者。金体真实譬法身佛。光用能照譬应身佛。明能遍益犹如化身。第二譬三德者。以金体四义譬法身四德。色无变如常。体无染如净。转作无碍如我。令人富贵如乐也。次光有二义。能照能除如般若。次明有两义。无闇广远如解脱总无众患。第三表三种佛性者。金体本有如道前正因。光用始有如道内了因。明是无闇如道后至果。以金等三义譬三种三法。故言金光明经也。与序品如常释也。此三种三义具在七卷也。此四卷中大判有三段。第一序品即是序说分。第二从寿量品讫舍身品是正说分。第三赞佛一品是流通说也。所以有此三段者有二义。一就化主说。若无序说物不生信心。若无信心忽为说者众生不受。然则如来有空说之过故有序说。既有信心如来不说则有失机之咎。故有正说。正说既显。若无流通如来即有无大悲失。故有流通说也。第二约所化说者。众生入道信心为初。故有序说。依信生解故有正说。依解起行故有流通也

序说中有二。如是我闻是证信序也。一时以下是发起序。料简二序如涅槃义疏中说也。发起序中有二。时等三句是通发起。是时如来下是别发起。为下正说诸品通是缘起故名为通。别为缘起故名为别。通发起中应有同闻。而不立者有三义。一者寿量品是四佛说。是信相室说。不与千二百等共闻。二者忏悔品是信相梦中见闻。亦非千二百等共闻。三者后赞佛品中他方大士。往他方赞佛。亦非千二百等共居。有此三义故不宜立同闻众也。斯则说此经有四时三处。处三者。信相室崛山他土谓此三也。四时者。谓两昼一夜及他方赞佛时也。崛山舍城如常释也。别发起序与余经序有异。直以三密冥加为序。三密者。身口意密也。欲说此经身在崛山表此经殊胜。即是身密也。意念法性及四佛护持。乃至忏悔等法即是意密。又将欲说此等深法即是口密也。以此三密冥加信相。故信相疑念感四方佛说寿量果。又因此三密信相感梦说忏悔等法。四天王等发愿弘经乃至说舍身品故。云三密为发起序也。就别起序中有二初十九行偈为正说作序。二我今所说下。有九行半偈为流通作序。就初有二。初八行偈为寿量下。经体四品作序。二诸根不具下十一行偈。为四天王品下经力用十二品作序。又就初有二。初五行偈为寿量品作序。二我今当说下有三行偈。为忏悔品下三品作序也。言是时者有三时。一如来欲说法时。二众欲听时。三大众心无高下时。如来者有三如来。一者法身二应身三化身。法身如来者。道前无变异曰如。道后显现曰来。应身如来者。乘如实道曰如。来成正觉曰来。化身如来者。化身化人不过时不待时曰如。八相趣果曰来。今言如来正是应身及以化身也。明应身照法身常乐等。以化身欲说故也。游于无量者。法身之体无有彼此限量故言无量。应身智慧照力有游故言游也。甚深法性者。法是法身。性是自性。自性真实故言法性。此之法性深难得底。故言甚深。应身诸佛能穷行之。故言佛行处。过诸学地。故言过诸菩萨。无复境智之殊二障永尽。故言所行清净。是金光明诸经之王者。此经名说法身常住。亦表三种三义。故立此名。过于小乘故言王也。若有闻者下。次叹经用。若有闻者生闻慧。则能思惟生思慧也。无上微妙甚深之义生修慧也。如是经典下明能说之人。言四方佛者显诸佛道同故也。但言四者欲表四德。故不五不六。东方不动表常德也。南方宝相宝相是如意珠有自在力表我德也。西方无量寿是安乐国。表乐德也。北方微妙声。声无秽浊表净德。从上法性经名经用能说如此等法。并是如来意念欲所游之境也。我今当说下是第二序。于中有三。初半行表。次二行释。后半行结。初云忏悔举忏悔品。等法即下二品。亦可忏悔举五法中忏悔。等法者等取劝请随喜回向发愿也。次释中初一行明因行。谓生善灭恶。又次一行明果德。谓智慧功德。依此忏悔等法所生功德。余法无加故言无上。亦令离苦灭恶故言坏尽。此即无行不备无过不尽也。一切种智亦以此忏悔等法以为根本。其余功德亦是忏悔等法所庄严也。此即是功德智慧二种庄严也。灭除诸苦者。拔分段变易二种生死。此结离过。与无量乐者。与菩提涅槃二种乐也。此结德备。诸根不具下大段第二序经力用。于中有二。初六行前序正论讫舍身品。明弘经者得经力用也。第二护世四王下五行偈。追序四王讫散脂品明经力用大。此中欲示前弘经有德故天神守护。后正说中示由天护乃得弘经故。序正之中前后不同也。就初有二。初三行半明所灭恶。次两行半明能灭行。又就初有二。初两行一句明因现事生恶愁。次五句明因未现事生恼。凡世间恶事不过现与未现。故以此二摄一切也。初中以下一句通牵属上八句。如言诸根不具故愁忧恐怖。诸天舍离故愁忧恐怖。乃至财物损耗故愁忧恐怖。如通牵属也。就第二中恶星是天上怪。虫道鬼神怪。恶梦是梦相怪也。若有如此等三障恶事者。净心听经即得消灭。言三障者不具损减困苦。舍离是报障也斗讼忿诤乃至愁恼通是业烦恼障。所加损耗灾怪恶梦是起业烦恼缘。若弘此经灭苦生乐。故离报障。灭恶生善即离业障。灭惑生解离烦恼障。第二序经力大可解。就流通序中有二。初八行半流通寿量品作序。后一行偈流通忏悔品下作序。问曰。此中佛自叹经。彼赞佛品唯叹佛德。若为作序。释云。经所以尊由说佛德。故此叹佛。就初有四。初一行半叹值得。次四行偈明弘经得果。次两行偈明劝修行。次一行偈明结弘经人。八部所敬佛菩萨护持者言外护之果也。偈无量福聚者。言内心正报也。慈心供养者。言为众生与乐心供养此经也。如净名经中。为菩提起于慈心此中亦尔。凡供养三种。一利养供养二恭敬供养三修行供养。此中供养唯是恭敬及与修行供养也。人身者别于余身。人道者别于余道。正命者别于邪命。闻经供养。即福慧具足超于余人故言善得。第二序因门可解。不明流通四王以下经力用序者。本由流通经体得经力用故不别明

第二正说中有二。第一从寿量讫空品明常住因果。即是经体。第二从四天王品讫舍身品明叹经劝学。即经力用。第一中复有二。寿量品明三身常住。此即是果。第二忏悔品已去明修道。即是因行

言寿量者以无量为量。真如实相以无相为相。实际以无际为际。就此品有三。第一信相疑念四佛降现降室现瑞故名降现。第二尔时信相下。明信相请问四佛为说。第三偈后长行明坐众利益四佛不现。就第一中先明疑念。从思是义时下次明降现。言信相者。此是地前菩萨于理决定。故名为信。此人曾供养诸佛深殖善因。故能承佛三密冥加疑佛八十。问曰。此经是何时说疑佛八十。释曰。未涅槃前九十日说。所以知然。从如来出世至于法华未有八十之语。说法华已后告于魔王唱言。却后三月涅槃。此时众生方知正八十年。以此可知于九十日说。而九十日中未知是何日说。方者将也。二月十五日入八十而未满足曰将。复更念言下明念因疑果。不杀是长寿正因如生母也。施食是缘因如乳母也。就第二降现中先明四佛降室。放大光明下现瑞蒙益。何故变小室令广博严净。密显短而即长。犹如此室秽而即净也。余又可寻。尔时信相下大段第二。于中先明信相陈疑请问。尔时四佛下明四佛为说。于中有三。第一试敕略表。时四如来下第二集会广释。是故大士下两行第三双结。第一中先试何以故下略表常住。就第二中先明集众。尔时四佛下以偈广释。诸水须弥大地虚空虽复难知。并是有相之法。可以意知。可以言论。而三身佛果三而恒一。一而恒三。然则非一非三。体不可以智知。相不可以言论。无有数量算计也。又复法身本有无有生灭。报佛与之相应。亦无生灭。是故大经云。诸佛所师所谓法也。以法常故诸佛亦常。又化身如来以二佛为体。以众生为缘。体无尽故化身亦无尽也。故云三身常住。如七卷经中明。应化二身是相续常者。以菩萨业识所影项背光明三十二相等合名报佛。同与乐因相应故。约体论之实是化身。故言念念相续常。若言与理相应之报是凝然常住。何故四佛不现者。为显法身不异迹虽有四。归处无异故

忏悔以下三品明经体。第二辩修道门。果不自得要因修道。故次明之。即是因门中宗明缘因。若论正因在七卷经三身品中。此经略无。就此因门有二段。初二品明功德门。即是方便道。后一品明智慧门。即是般若道。何故明此二。一切因行不出功德智慧故以二门摄尽。依修二因得三身果。其义何耶。修功德故非二乘行。修智慧故非凡夫行。非凡夫行故不在生死。非二乘行故不住涅槃。即是得化应二身。不在生死故即法身究竟。故云得三身果。又复修功德故离业障。修智慧故离烦恼障。故与理相应即得应身。离业障故随物无碍即有化身。二障既离果报阿梨耶即灭不起。法身之体究竟显现。是故欲得三身者。必修功德智慧也。对三点三性例此可寻。就功德门中二品即为二段。忏悔品是佛所说信相述之。赞叹品是信相昔说。佛今述之。何故明此二者。显感应之道故也。信相梦中所见闻事。是如来应。是故信相向佛述之。今所述赞佛发愿是信相感。是故佛今对信相述之。欲显见闻不虚。是故明感应相符也。何故梦中见闻者。欲明菩萨之道觉梦无异。又显如来佛事不在昼夜。又由信相愿力故也

言忏悔品者。外国云忏摩毗。此云厌离。亦云改悔。胡汉具存故云忏悔。于此品中具明五法。忏悔在初故从初为目。就此品中有二。初长行是经家辞。后偈是信相自陈。就长行有二。初明信相梦中见闻。次从梦寤已下。明信相寤已往至佛所说。就初有二。一见如来应。二见有一人明见众生感。即于其夜者。说寿量品竟之夜也。金鼓喻法身。姝之言妙。妙出生死名相之外。大者遍含万德。故名为大。依此法身成应身。应身遍照故言如日光也。其明者此即是光。非是光中之明故犹应身。非是喻化身也。复于光中下明见化佛。即是光中之明。斯则明见法报二身但喻无法。身中有法无喻。而为说法者明其所闻。似婆罗门者。信相菩萨位在地前未得地上真解故言似也。信相机桴击法身之鼓。令出化身音声说忏悔等法故。言以桴击鼓乃至说偈颂也。第二段文相可知也。偈中有二。初四行偈陈述所见。此见相可知。其鼓音中下次述所闻。于中有二。初半行偈总标。次百五十七行半偈别述。于中有四。初七十六行明离过行。第二诸佛世尊我所依止下七十二行半明摄善行。第三若有敬礼下六行半偈举利劝修。第四非于一佛下两行半叹经难闻。相生可见。就初有二例。初二十二行偈明叹教胜用。第二无依无归下五十四偈。正明离过行体。就初有三。初十行偈明拔苦与乐用。第二从若有众生处在地狱下八行偈。明灭恶生善德。第三从若有众生堕大地狱下四行偈结。又就初有二。初两行偈明拔三种苦。是鼓所出下八行偈。明与三种乐。三种苦者。一三世苦即是长苦。于三世中长受故。二者三途苦即是重苦。此苦粗重故。三者三界苦。贫穷是人中苦。及诸有苦者是天上苦。是三界苦中具含行坏二苦。此即是深苦也。第二与乐中初两行偈。明与无畏乐。次诸佛圣人下五行偈。明与菩提乐。后一行偈明与寂灭乐者即是苏息乐。是经能治总缘所逼一切怖畏。令得如佛无畏也。第二言菩提乐者即是觉智乐也。于中初一行先明诸佛所证。欲显此经能令众生如诸佛所证故。次四行偈正明与菩提乐。于中初两行半明自利菩提。后一行半明利他菩提。如是众生所得功德者。言如诸佛是。众生所得功德者。言如诸佛是。众生所得定及助道如海也。定者谓四空。助道者谓三十七品等也。超波罗蜜等诸行越举助道故言及也。亦可定者证道者。谓教道超不住道故言及也。此一行明菩提因圆。因行既圆即菩提果满。故言令得梵音胜果。梵音者有五德。一深如雷。二清彻远闻。三谛了易解。四众生爱敬。五听者无厌。有此五德名为梵音。此是化身菩提。胜果者此是法报二身菩提也。直明化佛梵音体相即是自利。故以化身亦名自利菩提。三身既满转无上妙法。授与众生住无量劫。为说正法究竟利益。故言转无上轮乃至利益众生。第三言寂灭乐者是无为乐也。文相可寻。就第二灭恶生善中有四。初两行明生信。次两行明生解。次两行偈明生行。次两行偈明令愿满。第一云生信者。若众生在狱受苦。闻此金鼓所出言教尚得生信礼佛。何况人天不蒙利益。故偏举地狱人也。言生解者令知宿世善恶因果。亦令正念诸佛闻无上法分别邪正也。言生行者言令值诸佛修道之缘离于恶业也。令愿满者无不具足信解行愿满。既以具足不信等恶自然灭尽。故言灭恶生善。第三结中但结拔苦。其余略不结之。初一行举地狱重苦。次一行举流转长苦。次一行总举三途重苦及三有中深苦。后一行偈举鼓音总结灭苦也。从无依无归下大段第二明离过行。离过行体不出五种。五种者何。所谓忏悔劝请随喜回向发愿。菩萨何故行此五法者。欲反起恶根本心故。起罪根本亦有五种。一者无惭愧心。二者不乐佛法心。三者嫉妒心。四者三有取着心。五懈怠心也。菩萨忏悔以惭愧心为体。故对翻第一心。然惭愧有三人。一者惭愧师友见处不犯不见处则犯。此是下品人。二者惭愧佛与天忆时不犯不忆则犯。此是中品人。三者愧自身与诸佛同性。而诸佛已证已得。己性我独未得。故愧自身不作诸恶。此是上品人。第二劝请。以乐佛求法心为体故对翻第二。第三随喜。以四等中喜心为体故对翻第三。第四回向。以菩提心为体故对翻第四。第五发愿。以愿乐利益自他心为体故对翻第五。故释论云。菩萨六时行五法也。就此段中有三。初十九行偈。约起恶因缘以明忏悔。第二我今供养下二十七行半。就造恶时节以明忏悔。第三若此国土下七行半偈。据作恶及受报果处以明忏悔。所有三障不出因缘时节处所。故以此三摄一切尽。就第一初一行偈明发愿。即是灭罪内因。次两行偈明劝请。即灭罪外缘。从我本所作下十六行偈。正明忏悔体。何故第一先发愿者。菩萨修行必以菩提心为依止故。所修诸行异于二乘凡夫。故摄论云。菩萨波罗蜜依止无等也。是故此中为诸众生无依护者。起作归处愿也。次明劝请者。虽有灭罪内因。无外胜缘其罪难治。故须必请诸佛作悔化主也。如世间人对首请悔主也。因缘既具故。次明忏愧责。于中初一行偈总忏。从不识诸佛下别忏。于中初一行偈明内因不别愚痴。外缘胜思善业造作众恶。次一行偈明内因憍慢放逸。外缘种性财年。次一行偈明内因三业。外缘不见其过。次一行明内因愚痴。外缘近恶友。次一行偈明内因嗔贪。外缘五欲。次一行偈明内因悭嫉奸谄。外缘非圣贫穷。次一行偈明内因怖畏。外系属他。次一行偈明内因三毒渴爱。外缘诸法。次一行偈明内因诸结。外缘衣食女色。次一行偈明总举三业悔责。次两行偈明内因三毒憍慢。外缘三宝三乘。次一行半偈明内因无智。外缘正法父母师长。次一行半偈总举结忏。就第二时节忏悔中有三。初中四行半偈明发愿为内因。第二诸佛世尊下七行偈明诸佛为外缘。第三过去诸恶下六行偈正忏悔。生起例上可见。就初有三。初一行偈明愿上供诸佛。第二我当拔济下八行半偈明愿下化众生。第三我当安止下五行偈明愿得佛果。就第二愿中有二。初四行愿令离苦得乐。次四行半偈明愿令灭恶生善。就初有三。初一行明令离苦。次两行明令得乐。次一行结离苦。就第二灭恶中有三。初一行愿为说悔法。次两行教忏悔方法。次一行半结叹经力能灭障。就第三愿得佛果中有二。初两行略标愿得佛果下化众生。次三行广释。住十地者谓十种法界体。十种珍宝者谓十波罗蜜行。此波罗蜜涉十种法界名为脚足。亦可以十波罗蜜为因足。建立佛果故名脚足。甚深法藏者是佛所知甚深之理有无量德也。一切种智者愿得智慧果。百千禅定下愿功德果就。就大段第二劝请中有三。初一行标。次四行半释。后一行半结。就释中有二。初二行半明我有恶怖畏故请。次二行明佛有大悲能治故请。结请可解。就第三正悔过中三。初两行就三世。次两行就十恶。次两行总举结忏。大段第三就处明悔中有二。初二行明回向。次五行半正悔。何故先明回向者。源在世间六趣作恶受报。本由取着三有故发回向之心对翻其根。就第二中有二。初三行总忏。次两行半别忏。就初有两。初一行半一举六趣恶业以总忏。次一行半举生死烦恼以总忏。就别忏中轻[跳-兆+參]难者。谓心无主当即是散乱烦恼。若配八难即是世智。近恶友难者即是恶缘。若配八难即是无相天等外道也。三有崄难者谓起恶处所。若配八难即是北郁单越。无求出世意故。三毒难者谓起恶内因。若配八难即是三途。多痴生畜生。多贪堕饿鬼。多嗔入地狱故地。无难难者谓恶报也。若配八难即是根不具足难。值好时难下明作恶时节。若配八难即是佛前佛后。上来至此是第一明离过行。其三段忏悔中虽具忏三障。若隐显互论第一段以烦恼为宗。第二以业为宗。第三报障为宗。故以三障判文亦得。又五法中但有忏悔劝请发愿回向四法。随喜略无。若随义为言。于下化众生愿中兼摄故不别明也。诸佛世尊我所依止下。是大段第二明摄善行。于中有四。初二十偈明劝请。第二相好庄严下四十八偈半明发愿。第三若此阎浮下两行偈明随喜。第四我今以此下两行明回向。但有四法忏悔略无。此中正明摄善行故。就第一文中无劝请正语。但有赞叹之辞。而今作义体者。所以顶礼赞叹。意在请住说法。故名劝请。文有二别。初十四行半偈正叹佛德。第二如大海水下五行半偈明叹。不能得下第一叹文中不过应化二身。若叹色文即是叹化身。若叹大智大悲等即是叹应身。文相可寻。第二相好庄严中有五。初一行偈通为自他发愿文云令众皆得者。言我与众生共一众故也。第二我以善业下九行偈别为自发愿。第三一切世界下三十四行半偈。别为他发愿文自有二。前十二行半偈明拔苦愿。次众生相视下二十二行偈明与乐愿。第四从若我现在下两行偈结为自发愿。第五从若诸众生下两行偈结为他发愿。随喜回向文相可知。明摄善行竟。从此已下六行半偈。是大段第三举利劝修。于中有两。初二行明修因离过。后四行半偈明修因得果。大段第四叹经难闻文相可知

赞叹品　明功德门中。是第三信相昔说佛今述之。来意有二。第一证上忏悔品梦中见闻。由信相昔日赞叹发愿力有之。第二赞上梦中见闻非是妄相。此二显感应符会也。此品中大意具述五法。但赞叹在初故从初名品中有三。初长行举能叹之人。第二以六十行半偈正述信相昔日赞佛等事。第三末后两行明结会古今。何故偏对地神述信相事者。此地神有缘故偏对之。偈中有三。初三十三偈明赞叹。此即是劝请。第二我今以礼下两行偈明回向。第三如是人王下二十五行半偈明发愿。若随义摄之。随喜在于回向发愿文中。忏悔摄在余愿文中。第一赞叹中有三。初一行偈总叹。第二诸佛清净下二十六行半别广叹。第三设以百舌下五行半明叹不可尽。就第二广叹中有二。初二十三行半偈明正叹。次三行偈明三业供养。广正叹中举其色声发齿目舌毫相眉细鼻高得味毛生。各以一行偈次第叹之。从即于生时下。别举生时放光利物身色面貌明耀威仪循臂圆光佛身净妙佛光魏魏佛日普照等一一叹之从本所修下别举自来叹臂手足色。三业供养叹不能尽及以回向文相可解。如是人王下第三明发愿。于中初一行结前起后。后二十四行半正明发愿。于中有十愿即为十段。第一有两偈。愿梦见金鼓得闻忏悔之声。今所赞叹下第二有一偈。愿得如来面貌清净。诸佛功德下第三有两偈。愿梦见如来昼如实说。我当具足下第四有两偈。愿行六度先人后己。别有愿得佛文句。此中愿成道者。意先人后己也。奉贡金鼓下第五有两偈半。愿值释迦得授记莂。若有众生下第六三偈。愿为作众生依止处。我未来下第七有两偈半。愿烦恼业海悉竭无余。于中初偈誓行道。后一偈半正愿。我功德海下第八有五偈半。愿得如来众德具足。当度众生下第九有一偈。愿拔众生苦与众生乐。来世多劫下第十有三偈。愿得净国土犹如诸佛。初一偈誓行道。后两偈正愿。诸愿之初皆应誓行道。但文略无耳。信相当知下第三两偈结会古今也。银相等者。于下授记品即是银相银光也

空品　明波若以导前功德。有四十五偈为三。初四行半偈序略说之意。第二从是身虚伪下二十八行偈正说空理。第三从我断一切下十二行半。明观空利益以劝修。就初有三。初一行表今略说。第二一行半释略说意。第三二行明此说略令蒙众生机。无量余经者指波若等经中。广明有无内外等法悉空寂故言广说。今此经中但明有法与内法空故名略说。凡广略之意亦不可定。若就理为言。广为利根略为钝根。若就教为论。广为钝根略为利根。又复莫问教之与理。广为利根略为钝根。钝根之徒无总持力少智慧故。今此中略意在第三句耳。就第三中初一行知机。次一行说教。异妙方便者。明今此略说异昔广说功称物机故言异妙。种种因缘者。谓下文所说种种事也。若广说无利略说有益故言起大悲也。如我所解者。言今此妙典如证而说。但知众生乐略之意不能广说耳。是身虚伪下。是第二正明空理。于中有二。初二十一行偈明人空。第二从如是诸大下七行偈明法空。就初有二。初十九行半别明五非常门。二从善女当观下明结观空。五非常门者。明众生之身无我无常空苦不净。此是俗谛观也。身即如是。何处有人。本性空寂此即真谛观也。五非常门即为五段。初四行半明无我门。身犹如空聚。结贼所止无有真主。即遣离我。一切诸根各住自性不能相知。各缘自境不能互缘无有自在。此是即遣我也。第二从心如幻化下五行偈明无常门。心识如幻。自生自灭驰骋分别六尘所害。又常依止六根及境。各在所伺在处则灭不能至于异处。如鸟投在细网即死。第三从身空虚伪下二行半明空。言身虚伪虽有衣食无可长养。亦无自我与他诤讼。亦无自性为身正主。但从因缘妄相缘起如机关木人也。第四从地水火风下四行偈明苦门。四大相违风火上升地水二下。又复风火其性是阳向东向南。地水阴性向西与北故。言诸方亦二。第五从心识二性下三行半偈明不净门。初一行半明种子不净。心是梨耶识。是六七二识躁动。起业烦恼不净种子。受六道身故言种子不净。次一行偈外相不净。次半行偈明究竟不净。善女当观下是第二段明真谛。文相可解。如是诸大下是大段第二明法空。于中初两行偈明色法空。次五行偈明色心法空。性无和合者。言四大本是不生故也。无所有故假名。无明者寻无明之体。即是真如净心。何处别有无明体相。故以假名名为无明。犹如波浪离水无别也。从我断一切下。是大段第三举益劝修。于中有二。初八行半偈举果益以劝修。第二于无量劫下四行偈。举因益以劝修。就初有二。初两行偈明自利果。次六行半偈明利他果。我断一切者。谓释迦我佛果由观空理断见缠等裂诸烦恼。汝等亦应欲断烦恼宜修空观故名劝修。此是断德下之劝意类此可寻。五阴舍宅下一行明智慧德果。第二明利他果中有二。初两行半明转法轮果。次四行偈明摄化众生果。就初有二。初一行半就理明转。次一行偈就教明转。开甘露门等句就能化人说。一往略说名。开委悉分别为示。甘露譬涅槃果。如世间人食天甘露得生死果。涅槃亦尔。入甘露城下四句就所化人说。初一句明闻慧。闻慧未证名入城。思慧近证名处室。修慧证得名食味。同法华经中开示悟入。彼经开示即同此经开示。彼经云入此经名入处。彼经云悟即此经名食味。吹法螺者如世间人欲改年号必以吹螺。如来亦尔。欲改小乘名字章句。必说大乘教法。击法鼓者如世鼓声近远皆闻齐心破敌。大乘教法亦尔。令一切闻进入胜境破烦恼敌。故名击鼓。然法灯者如世灯照了万物令一切见。佛亦如是。说大乘显了诸法。令得一切智故名然灯。雨法雨者如世间雨令五谷增长。佛教亦尔。令善根增长。依法华论如此解也。我令摧伏下。是第二明利他果德。于中初一行明摧邪德。即是降天魔也。次三行偈明拔苦德。即是化六道也。于无量劫下。是大段第二举因益以劝修。于中有二。初两行偈明难行能行。于中半行明长时修。次半行明恭敬修。次半行明无间修。次半行明余修。即是摄论中四修也。第二有两偈明难舍能舍。初三句明内施。次一句明内外施。后一行偈明外施也

四天王品　上来第一明经体竟。从此品已下十二品。是正说第二明经力用。备显常住因果。力宁不大。故次明之。于中有二。初五品明经力大。劝物弘通。次正论品下七品。明能弘之人得此经力以成前意。就初五品有二。初一品明四王愿弘此经。次四品明八部利益弘通之人。又四天王者。住须弥四埵名那干诃罗山。去地四万二千由旬。纵广亦尔。上有四王。东方天王名提头赖吒。此云持国。领诸天众并乾闼婆及毗舍阇二部鬼神。南方天王名毗留勒。此云增长。主领诸天众并鸠槃荼及避胁多二部鬼神。西方天王名毗留博叉。此云杂语。领诸天众及龙富单那二部鬼神。北方天王名毗沙门。此云多闻。领诸天众及夜叉罗刹二部鬼神。故名四天王品。品中有三。第一明四王愿弘。如来述成经力大。故四王愿弘之。愿弘合理。故佛述之。第二说偈已去明四王叹佛如来叹经。能说经故四王叹佛。经能成人。故佛叹经。第三偈后长行明四王欢喜供养发愿。以闻经力大生欢喜心。供养佛发愿故。就初有三。一出能弘人。第二白佛下叹所弘法。第三是金光明下明法为人弘。就第三中有二。一叹经德重。第二此经能照下叹经多能。明由多能故德重。德重故多能也。就初有三。第一诸佛爱重。明此经显性德之因。第二诸天礼敬。明经生修德之道。第三四王赞佛。明经成修德之果。就初先叹法。如金光明。法身性因如金。波若性因如光。解脱因如明。譬三身佛性亦得也。次诸佛世尊下明人。人是诸佛应身。以法为师言护念。如大经云。诸佛所师所谓法也。就第二中亦先叹法。法能生菩萨行之道。故言庄严菩萨深妙功德。次明人。人能如说修行于道。故为诸天恭敬。能令下第三亦先叹法。法成四德令诸天愿乐。故言欢喜。次明人。人心欢喜故口赞叹。故言亦为所叹也。就第二叹经多能中有三。初生智慧。照诸王宫令生智慧故。次与快乐后明灭苦。于中有二。初别明。举要下总结。别中有七苦。所谓三途怖畏怨贼饥馑疾病恶星忧恼也。从世尊是金光明下。是大段第三法。为人弘有二。第一明四王闻经获利。第二我等四王能说正法下发愿弘通。发愿弘通由获利故也。心进勇锐者明智慧也。就第二中有五番。大为二别。初一番明四王自愿拥护。佛即述成。四番劝他弘通如来述成。就初有二。初王愿护。后如来述。就初复有二。第一四王自明有弘护德。第二若此国土下正发愿。能说者能说十二部也。修行者六度。此两句明出世德。为世法王下明世间德。以法治世遮诸恶鬼等。是世间德也。就第二正发愿中有二。一愿护国。第二如诸国王下愿护人。就第二佛述中有二。第一赞。第二说于正法下正述。初中言四王过去供养诸佛者。此四王位登初地。三阿僧祇劫行行也。种诸善根者过世心也。如大集经说。初地作四天王。二地作忉利王。三地作炎摩王。四地作兜率。五地作化乐。六地作他化。七地初禅。八地二禅。九地三禅。十地四禅也。十回金轮王王四天下。十行银轮王王三天下。十解铜轮王王二天下。十信铁轮王王一天下也。就第二正述中有二。第一述成有德。以是义故下述成愿护。不述闻法得利。就第二述愿护中。先述第二护人。第二汝等若能下还述第一护国。文相可解。就第二四番劝他弘通中有三。初一番正劝他弘经。次两番示弘经方法。后一番明得失以结劝。菩萨不但自行复欲他化故。先劝他弘经弘经必有方法故。次示方法。既知方法不行则失。行则为得。故次明得失。就第一番中。初四王劝。后如来述。初四王劝中有二。初劝国王弘经。第二以是因缘下明四王拥护。于中有二。初四王闻法得利。得利之事如上。第二从是故我等下明人王被护。于中有三。初明护法。次亦当下护人。复他方下护国。护国有三。初表。次若有人王下释。起诸怖惧下结。问曰。经与四王本是利他。云何乃令彼国有苦。释云。经及四王无心总彼。但此土弘经则此土有德。彼王恶意违此有德。为恶自就耳。如人恶心违佛及父母也。文相可解。就第二佛述中有二。初二十行许。先述第二四王拥护。从若未来世下。第二追述第一国王弘经。就初有三。初述成第一护法。二从及诸人王下。述成第二护人。三从复能拥护下。述成第三护土。护土有三。初略述。二从四王当知下广述。三从以是因缘下结。文相可解。就第二述成。第一人王弘经。第二从是王即为下天王得益。三从是诸人王下劝。人王下劝人王弘经成前第一。四从以是因缘下。劝天王护成前第二。文相可解。就大段第二有二番。即为二。第一番示弘经方法。第二番示用心方法。就初有二。一四王劝。二如来述。就初复有二。初举果报。二从如是人王下明修因。于中有二。初明重法。二从于说法者下明敬人。文相可解。就第二佛述中。但述第一行因不述得果。述因中先述第二敬人。二从于说法师下述重法。文相可解。就第二番中有二。初四王劝后如来述。就初有二。一示听法运心。二从世尊是诸人王下示供养运心。问曰。四王是初地已上。云何乃就人王述善。释云。此是应迹令物倾仰生于胜福耳。文相可寻。就第二佛述中。但述供养运心不述听法运心。述中有二。第一此土释迦述人王供。第二从诸佛世尊闻是妙音下。明他方诸佛赞四众弘经耳。就初有二。初明非唯照天宫亦远至大千。第二从是诸人王手擎香炉下。明非但至大千。亦遍至十方佛土。就第二他方赞中有二。第一明闻见兴神变。第二从异口同音下赞叹。于中有二。一赞四众弘经。第二从尔时十方下赞四众得果。于中有二。第一赞当得。第二从汝已能坐下叹已得。因中说果故名已得。十二种行者谓小乘法也。无上法鼓等者谓大乘法也。大段第三以一番明得失。于中有二。初四王结劝。二如来述。就初有二。先牒上人王弘经。二从我以敬念下牒上天听受。同共一行者。言是弘经人王与四天王同行大乘。故名一行。无有相违名相应行。又是人王弘经利益四天。故名施主。从若有人王下第二正结劝。于中有三。初明不弘经者则有国败之失。第二从若有人王欲得自护下。明弘经者则有土丰之得。第三从以是因缘故下正结劝修行。就初有四。第一明不弘经此。二从我等四王下明四王失利。三从我等四王下明诸天舍国。四从其国当有下明国败亡。就第二明弘经为得中有四。第一明人王欲得土安。二从是人王等下明劝人王弘经。三从我等四王下明四王得益。从如诸梵天下明国安隐。于中有三。初明此经用胜彼三论。二从如是等无量功德下。明说此经人胜彼说论之人。三从若阎浮提下。明此经理过彼三论之理。言出欲论者。是四违陀经明梵天离欲等事。言帝释善论者。谓伽罗论明十善等事。言神仙论者。谓伽世师弥论明五通仙药等事。何故此法胜他三论者。此经以如来大悲广为利益一切众生。与乐拔苦故胜彼论也。大悲力过梵天。苦行力过帝释者。此是互举一边。第二述中有二。初述护人王。二从若有人能下述护众。文相可解。说偈已下大段第二赞叹中有二。初四王赞佛。二如来叹经。就初有三。初二句标。次六行偈赞。三二行结。就第二中有两。初四行半赞应化二身。后一行半叹法身。就初有二。初三行略。后一行半广。略中有二。初一行半叹化身色光明面目齿白也。次一行半叹身功德智慧三昧也。广中有二。初一行广化身。次半行广应身。叹法身中初半行叹法身中体。次一行叹法身用。就第二如来叹中有四。初五行偈叹经力大。二从阎浮提内下十二行半偈劝人王弘。三从是金光明下四行令天王护。四从若有得闻下三行结上三义。就初有二。初两行叹体。次三行叹用。初中一行明法。次一行明人。就用中初一行与乐。次一行生善。后一行拔苦。就大段第二十二行半中有两。初四行半劝弘通。二从是经能作下十八行明得益。就弘通中初二行半明弘者有利。后二行正劝。就二得益中有二。初二行半法说有三。初半行明生道善。次一行拔生死苦。后一行与因安乐。第二譬说三。初宝树。第二冷水。后珍宝。文相可知。就第三天护中四。初一行诸天供养。次一行明四王护持。此二正法。次一行诸佛护念。次一行明鬼神拥护。此二正护人。就大段第四结上三义则为三。初一行结第一叹经力大。次一行结第二人王听受。后一行结第三天王守护。偈后长行是大段第三明闻经欢乐散华供养愿护弘经人也。言寂灭法者领上法身体也

大辩品　此下四品是大段第二明人部利益弘通之人。即为四别。初一品与功德品益资财。地神品施饮食。散脂品益智慧。若无辩才资生衣服饮食智慧不能弘法。是故四神次第益之。此大辩神迹在天上。神本是九地菩萨具足四辩。故名大辩品。就文有二。一利益说人。二从当令是等下利益听众。就初有二。初正明利益说者。二从若有众生下劝为他说。又就初有二。初益四辩。初三句是乐说辩。次两句是辞辩。后一句合明法义二辩。二从若是经中下益总持力。第二劝为他说中。初出所化人有善根。二从是说法者下正劝为他说。大段第二益听众中有三。初益福慧。先与智慧后益福报。二从善辞下与四辩善解方便即辞辩也。善能辩畅诸论者是乐说辩。善知伎术者谓法义二辩。三从能出生死下明得佛果也

功德天品　此神迹在树神之王。随所至处与他胜乐。故名功德。外国呼神亦名为天。此神本是初地。初地具足檀波罗蜜。故有财物自在行也。就品有二。初与说者所须。第二从我已过去下与听众财物。此品中亦与食饮。而与财物为正。就初有二。初正与所须乃至令得寻经。二从若有众生下劝令弘经。于中初明所化者善根。是说法者下正劝令弘。是诸众生下明所化利益。大段第二与听者财物。于中有二。初明有与之德。第二若有人能下正明与所须。初中先明宿殖善根。是故我今下明今身得随意报。故能以慈心随所念方。以天眼随所视方。以身通随所至方。令众生受乐七宝具足也。就大段第二正与所须中有三。初略明。二从于此北方下广说。三从应当至心下结劝。就初有二。初明令其修因。修因者所谓称金光明。为功德天供养诸佛。别以香华供养天神也。二从当知是人下明得果。得果者所谓财宝地味谷果滋茂出生诸物也。第二段亦二。初劝修因。二从从此日夜下明得果。就初有三。初示处所。二从若有欲得下正劝修因。三从作是誓愿下明天来。第一可解。第二修因中有四。一修治内外。住处净扫是外。着衣涂身是内。二从为我至心下明供养三宝。三从尔时当说下明读诵咒。四从七日七夜下明修行发愿。言灌顶章句者所谓神咒。神咒所诠凡有四种。一叹诸佛功德。二说第一义谛。三明药草。四唱鬼神名字。此中所明应是诸佛功德。明诸佛功德灌众生信心之顶登法王位。从譬为名故言灌顶。依此咒力必得善果故言吉祥不虚。等行众生者。欲行此法必须同行之人。及中善根者。言下根心薄诵不得咒力。上根德厚不依咒力。必须中根也。第四修行发愿可解。第三明天来中初令兴念。从自于所居下明净舍宅以待。从我于尔时下明天神来。大段第二得果中。初明所须无乞。此是与乐也。从若能以已下明始终扶护。此除苦也。第二结劝可解

坚牢地神品　此品是第三施饮食利益行人。神能持地使令不坏。因功受称。此神亦是迹在地神。本是初地以上故有施饮食自在行也。就品有三。初明地神供养弘经之人。第二从我于尔时下明由供养故得弘经。三从是诸众生各于住处下。明由弘故得胜果。就初有三。初表示处。二从世尊随是经典下正明供养。三从我闻法已下明闻法得益。初二可解。就第三中有二。一明地神获利。二从而此大地下明众生得益。于中有三。初明诵出地肥增长百味资益身力颜貌妙特。此是财利。二从成就如是下明法利益。三从是故世间下结。先结财。从是诸众生下结法利。文相可解。就大段第二明弘经中有三。初明地神请说此经。二从何以故下明说经利物。三是故世尊下劝人听受。初二可解。就第三中初明教念。二从我当必定下明劝听受。三从既听受已下明自庆有五事。一庆闻法。二从已为摄取下庆摄功德。三从值遇下庆值诸佛。四从三恶下庆免恶趣。五从未来世下庆生人天。就大段第三明弘经得果中有三。初地神正明得果。二如来报述。三地神奉酬。就初有二。初明弘经。一喻者经中有明一譬喻也。一缘者经中所说一因愿事二缘事。二从世尊下明得果。地丰物茂众生受乐明报果。多饶财货下明习果也。就第二佛述中有二。初明听者得报。二从地神下明供养者得报。就第二奉酬中有三。初明地神供养说者。二从若有众生下明众生听闻。三从是诸众生下明众生得果。先明受乐报。二从值遇下明得果。文相分明不须烦解

散脂鬼神品　此是大段第四明与智慧。外国言散脂修摩。此云密神。迹在鬼王。本是十地。故能以智慧气力利益弘经者也。就品有三。初明能益弘经之人。二从以是之故下明说者得益故能弘经。三从南无下归依众圣。归依众圣力故有上两能故也。就初有二。一明神力拥护灭恶。二从何因缘故下。正明以智慧气力增益说者。就初有三。先明能护之人。二从是金光明下明所护之法。三从我当以此下正明守护之事。于中初护说者。次护听众。后守国土。文相可解。就大段第二中有二。初明能益之德。二从世尊散脂大将下正明益物有三。初表。二从我知下释。三从以是故下结。就第二释中有三。一明能知二谛之德。二从我现见下明有能知二智之德。三从我于诸法下双结上二也。言其二谛各有事理。妄法差别是俗谛事。缘集虚假是俗谛理。真法恒沙是真谛事。恒沙即如是真谛理也。我知一切法者谓知俗谛事。一切缘法者谓俗谛理也。在初我知二字通贯下二句也。了一切法知法分齐者。此是重显知法分齐明。故言了一切法显初句也。知世谛法以虚假为分齐故。言法分齐显后句也。一切法如性者谓真谛理。理无有二。故名为如。不改曰性。亦是性者体也。于一切法含受一切法者谓真谛事。于一一德中摄一切德。故言含受。在初如法安住四字通贯下二句。如理而证如事而知。无有功用动心。故言如法安住。就第二明知二智中。初四句明知智体。后一句明知智用。言智光者明实智。当法而照无有闇碍如日光也。言智炬者明方便智。随缘照如炬明也。言智行者明下二智不行为行也。智聚者。言上二智众德积聚故名为聚。明智体竟。言智境者。依上二智所变化境。如化身故名为境。故大经云。诸佛境界悉皆无常也。此智体智用并是无名无相。无相故不可思。无名故不可议。故言不可思议。鬼王证知非是妄心境相。故言现见也。就第三结中正解者。知世谛事非邪。故曰正解。非是比量。故曰正观。非总相知。故言正分别。此结上知世谛事也。正解于缘者结上知俗谛理也。正能觉了者。此总结知真谛事理及智体智用境也。就大段第二正明益物中有二。初明益事。所谓辩才身力勇锐智慧忆念等五事具足。二从心无下出益相。所谓无疲受乐欢喜等三事也。就大段第二明说者得益故能弘经中有四。初明说者有智能说。二从若有众生下。明听者有善堪受。三从说法之人下。明劝为物说成上第一。四从无量众生下明听者得利。所谓智慧功德受乐菩提离苦五种利也。大段第三归依可解也

正论品　此下七品。是大段第二明弘经之人得此经力。于中有两。初三品出弘宣之人得因益。后四品明得果益。就初三品即为三段。初正论品明信相弘宣。次善集品明释迦弘宣。后鬼神品明四众弘宣。言正论者四王与梵天问答明治化正法。故名正论品。问曰。治国正法是世间论。云何名为弘宣此经得因益耶。释言。治化之德即是般若大悲平等之心。自非依经修行。何由能得不择怨亲平等治化也。就品有二。初明缘起。二从何等下正明正论缘起可解。就第二中初表起。从偈以去正是论说。于中有三。初两行偈诫许。二从诸王和合下四行偈请问。三从护世四王下七十六行偈为释。诫许者父王信相太子许说正论也。第二请问中有二。初二行明四王赞请。次两行偈出四王请事。于中有二。初一行问。后一行偈结。就问中有三事。初二句问何故是人而名为天。次一句问何故是人而独名王。后一句问何故人王而名天子。后一行总结。问云。虽在人中以正法治世。故而名为天耶。此是结第一问。第二第三略不结也。就第二释中有二。初两行半许说。二从因集业故下七十三行半正答。于中有二。初六行略答问正论之体。第二从半名人王下六十七行半。广答显正论之相。就初有三。初一行答第二问。云虽同是人而统领国土故名为王。二从处在胎中下三行半答第三问。于中初二行明在胎内为天所护故曰天子。次一行明胎外为天所养故名天子。后一行明长大之后天德分与故名天子。后半行结。为天神力所加故。得自在名为天也。三从远离恶法下一行半追答第一问。于中有三。初半行明以天律灭恶故名为天。后半行明以天律生善故名令生天为天。后半行明以天律令生天上故名为天。半名人王下是大段第二广答。于中有二。初三行广治化人德。第二从若有恶事下六十四行半广治化正论。就初有两。初一行半依名辨德。次一行半释疑显德。半名人王者。言一边名天一边名人。故名为半。此二名人天一双。亦名执乐者执世中礼乐。以化人安乐故名执乐。亦名罗刹者作恶之人于王生怖故名罗刹。此二名与乐生怖一双也。言魁脍者。货鱼典宰曰脍。货猪典宰曰魁。咒国主断恶并非故言能遮诸恶。名父母者教修善法。故名父母。此是遮恶教善一双。依名辨德竟。此下第二释疑显德有二。疑初。疑云若人王如罗刹脍魁令人怖畏者。何故为天所护。释云。人王示现作恶有报故致鞭挞。令其怖畏而无恶心。为天所护故言示现果报诸天所护也。善恶诸业下释第二疑。疑云。若鞭挞等苦但令怖畏者。尔此现苦无因而得耶。释云。善恶业果现在未来故。鞭挞等苦是现受苦报。非是无因也。若有恶事下。是大段第二广治化正法。于中有三。初三十五行明人王纵恶则祸生国败。第二从若为诸天所护生者下二十一行半。明人王修善则福至土丰。第三从以是因缘下八行结劝舍恶从善。就初有四。初六行半明人民起恶。第二从暴风卒起下十二行半明国主起恶。第三从诸受宠禄下十三偈明诸臣起恶。第四从若有人王下三行偈。总结皆由王尔。就第一中初二行明作恶因。次三行明得苦果。后一行半结不应行。文相可知。就人王作恶中亦有三。初一行半表明得苦果。所谓风雨不调。星宿失度。果实不登三种果也。二从由王舍正下三行偈明作恶因。三从以天嗔故下八偈广明恶果。于中初半行偈总明国败。次七行半别明恶果。所谓疾病国败眷属分离。灾怪恶贼饿饥死。正财物散失星宿失度等也。就第三大臣作恶中有三。初一行臣行非法。二从如是行恶下两偈明人王许可。许可者所谓恶臣偏受王恭敬。良臣衰灭亦不领录也。三从故使世间三灾并起下十行明得苦报。于中初两行开章门。后八行释。初中复有二。初一行明得恶相。恶相者三异并起。三异者谓星宿失度暴风恶雨也。次一行明有恶果。恶果者所谓坏出世正法世间众生正报及地肥依报也。就释中有三。初半行举恶因。二从故天降雹下六行半正明得果。得果者所谓雹饿疾死。谷果衰灭。多病满国。甘果减苦味增也。次本所游戏下广释可解。三从多有病苦下一行结也。从若有人王下是第四明皆由王尔。于中有三。初一行明令王民作恶。次二句明令得苦。后一行半正明皆由王尔也。从若为诸天下。是大段第二明人王修善即福至土丰。于中有三。初一行半明王不作恶则人民行善生天。二从行不善者下二行半。明人民作恶得苦。由王纵恶不治。三从起诸奸恶下十七行半。明国王治即得国丰乐。初二可解。就第三中有三。初五行半通诫恶劝善。二从不应行恶下四行。偏明作恶国败。三从以善化国下八行。偏明行善土丰。次以是因缘下八行。是大段第三明结劝舍恶从善。文相分明不须烦解

善集品　善集即是释迦本身。宝冥即是阿閦本身。品中正明善集王事。故以为名。就品有二。初长行表。后以偈释。偈中有二。初五十一行半明因。第二从尔时为王说法比丘下十二行半明得果。就行因中。有二。初四行明布施行。二从又过去世下四十七行半明智慧行。布施行有四。初一行舍国城。次一行舍珍宝。次一行舍眷属。次一行舍身命。就第三得智慧中有二。初十八行明求法因缘。第二从时宝冥尊下二十九行半正听法。于中有四。初十一行明受请。二从是时宝冥下八行正为说经。三从是时大王下二行半明闻法欢喜。四从为欲供养下八行明报恩供养。就第三说法得果中有三。初两偈结会古今。二从我于尔时下八行半明得果。三从所得功德下三行合结因果

鬼神品　此品明四众听受则有胜善为鬼神所护。故从之受名。就品有三。第一从品初二十六偈劝众听受。第二从大梵王天下四十八行半明八部守护。第三从是经典者下二十七行半明具诸胜果。就初有二。初长行及二行偈正劝听受。二从是妙经典下二十四行偈叹经力大。就初有二。长行及偈。长行中初举供养诸佛功德。次举智。佛所行第一义处。后劝云欲得如上功德智慧应听是经。偈颂可知。就第二叹经力中有二。初九行偈正叹经力。二从随所至处下十五行偈举益劝听。就初有两。初二行叹拔苦力。从是经甚深下七行叹生福慧。初中一行叹经力。一行明拔苦恼。第二亦两。初两行半明叹经德。初中后善者明戒定慧是三也。亦可序正流通为三也。二从若入是经下四行半明生福慧。于中初两行明生智慧。入法性者明证法身也。得见我者谓见应化二身也。次两行半明生功德。就第二举益劝听中有二。初两行正劝忍苦听受。二从听是经故下十三行明听经有益。于中有三。初一行半明听者灭恶相。二从于说法处下五行偈明说者得胜相。胜相者。言若下法坐而为大众。于法座上犹见佛菩萨色像及余形色等事。如前无异者。言本时无如此相。灭后亦无如前也。三从成就如是下六行半偈令得胜果。于中初四行半正明得胜果。胜果者。言内有诸佛所赞威德名称。外破怨敌恶梦恶业。入陈胜他等事也。次从名闻流布下两行偈结。就大段第二明八部守护中有四。四行半明供养。二从生不思议下五行半明恭敬。三从如是大悲下四行明赞叹。四从如是众生下三十四行半明拥护。文相可见。从是经典者下二十八行偈。是大段第三明具诸胜果。于中有二。初二十六行别明八事。八事者。初一行一句增色力。第二两行除祸灾。第三四行出地肥。第四两行生快乐。第五三行生谷果草木。第六三行三句生好华。第七八行光明照益。第八两行阴阳调适。后两行偈是第二总结也

授记品　前三品明得因益。自下四品大段第二明弘经之人得果。于中有二。初一品正明得果。后三品明举缘修因成得果义。自前正论品等虽明得果之人未明记莂故。今一品正明得记。得记必由胜因故。后三品广示往因成得记义。授者与也。记者决也。与信相等决得佛果故名授记品。就品有四。初明受记众集。第二从佛告下正明授记。初明信相记。次明二子记。后明诸天记。第三从尔时道场下。明树神生疑有三。初略表。二从世尊下广释。三从世尊是天子下结请。第四从尔时佛告下如来释疑。于中有三。初略表。二从何以故下释。三从是故下结。因缘者。言天子内有修行善因。外有如来本愿之缘。故名因缘。又复闻经生净心善因。依闻大士授记之缘故得授记。以随相修者谓六波罗蜜等行。言此天子已于过去随缘相造修行也

治病品　自此以下三品。是大段第二明举往修因成得果义。即是广明授记因缘以遣上疑。于中有两。初二品正成授记品。傍显寿量品。后舍身品正成寿量品。傍成授记品。初之二品正明十千天子作鱼身。闻法之因故今日得记。故言正成授记。即显释迦曾作长者修慈悲行令得成佛。故言傍显寿量。后一品正明释迦曾作王子修大悲因。今得成佛故言正显寿量。佛既修因得果。信相何由不然。故言傍成授记。于二品中此治病品明得记远缘。流水品明得记近缘。近远可寻。此品明释迦昔日大悲治病故名治病品。就品有二。初诫许说。二从过去下明正说。正说有二。初述本生。二从是时国内下明本事。初有两。一明本生时处。二从是王国中下正明本生。就大段第二明本事中有二。从初讫偈后长行一行半明慈悲体。二从时长者子下明慈悲用。就初有五。一明国人有病。二从善女天下明思惟欲救。三从时长者子明请问医方。四从时父长者下明父为说。五从善女天下明闻说得解。初二可解。就第三中初以长行发起。次四行正问。正问有四事。初一行问病因缘。次一行问病饮食。次一行问病医药。次一行问时节。病因缘者是四大五藏五缘。四大不调五藏伤损。令诸根有病。如肝恶眼病。肾恶耳聋也。生病缘多坐多眠得水病。多行多倚多语生风病。又多坐生热病。多淫生一切病则等分病也。又火少令痰饮多。若火多令热多。若风多吹火增热。水多痰增冷也。病饮食者有六。一过量食。二小量食。三过时食。大饥方食。四逆时食。未饥强与。五妨碍食。食肉竟饮生乳等。六不曾食而强食之。如南人饮浆。北人如饮乳。又苏蜜等分服之即死。又苦菜和蜜食令不能男。并是妨碍食。又风病人食冷湿味令人度寿。若热病饮酒。食小麦生牛肉等令人失眼咄血。若痰病食甜肥辛酢。令人[口*賴]鼻多汁[病-丙+帶]下等。文言身火不灭者。若食饱热病。应息而不息者有病故也。水过损肺即是痰病也。治病药者病难有四。一风二痰三热四等分。此四种各有三品。一者可治此是新病。四大犹强也。二者恒治不差。此是四大过伤也。三者不可治。见有必死相故。若论药品如下文说。病时节者。四月至五月风生时。六月七月风病起时。八月九月风灭时。次六月七月热生时。八月九月热起时。十月至正月热灭时。次十月至正月水生时。二月三月水病起时。四月至七月水病灭时也。就大段第四答中有二。初一行是佛序父答。后十六行正是父答。于中有二。初三行定时节。后十三行正是治病之方。三三本摄者解有二师。初解云。一年有四时谓春夏秋冬。春为气首冬为气末。一时之中各有三月日。谓孟仲季。正月孟春二月仲春三月季春。后三时例尔。正月为本摄后两月悉属春分。四月为本摄后两月悉属夏分。七月为本摄后两月悉属秋分。十月为本摄后两月悉属冬分。四时各有三月。故言三三而说。初月为本摄后三月。故云三三本摄。此是本摄末。又言。正月二月正是春时。木于中王。土寄三月摄属春时。四月五月正是夏时。火于中王。土寄六月摄属夏时。七月八月正是秋时。金于中王。土寄九月摄属秋时。十月十一月正是冬时。水于中王。土寄腊月摄属冬时。土寄四季以正时为本。各各三月并摄于中土故言三三本摄。此是主摄客。客是土也。第二解云。依佛法中年有三时谓冬春夏。冬为气首夏为气末。一时之中各有四月。废去秋时。三时之中各摄秋时一月故。一时中有四月日。故言三三本摄。初三字举秋时三月也。次三本字谓冬春夏中本三月也。四时之中何故偏废秋时者。释言。凡有二义。一为破保常之执。秋时成就人皆此时保常为乐故。欲破其执废去秋时。二开后安居立迦提月。安居本名夏坐。八月半以还若是秋时便成秋坐。故宜废之也。二二现时者亦有二解。第一解言。四时之中各二月日以为正时。土寄四季各以月日摄属阴阳合成六时。六时者正月二月是木王现时。四月五月是火王现时。七月八月是金王现时。十月十一月是水王现时。十二月三月是阳土寄王。六月九月是阴土寄王。王名为现。故言二二现时足满六时。第二解言。依法三时时有四月。各有初分后分合成六时。六时者。从腊月十六日至二月十五日。此二月是春时初分现。从二月十六日至四月十五日。此二月是春时后分现。从四月十六日至六月十五日。此二月是夏时初分现。从六月十六日至八月十五日。此二月是夏时后分现。从八月十六日至十月十五日。此二月是冬时初分现。从十月十六日至腊月十五日。此二月是冬时后分现。故言若二二说足满六时。就第二正答中有二。初十一行半明随时发病。次一行半明违时动病。就初有七。初一行答上第二病饮食问。次一行答上第一病因缘问。第三一行半答上第三病汤药问。第四二行答上第四病时节问。第五两行半重答上第三治病药问。第六两行重答上第二病饮食问。第七二行半重答上第三治病药问。所以三过重答治病药问者。初一段示未得病前以药防护。次一段明得病时以药治之。后一段明治病之后以药补之。所以两过答第二者。初明食能资身无病。后明食欲损身生病。第一文言医方所说者。谓本草诸药方中明饮食有宜不宜。不宜不依之也。第二中言代谢增损者。谓四时来去四大增损也。第三中言六大者。即是六府。一大肠二小肠三脾四三焦。就二傍光为六。第四中言风病夏动者。夏毛孔开通外风得入故也。热病秋动者。秋时毛孔闭塞热伏内不通故也。第三等分冬发者。春时动水肺病不差。至秋动热热病不差。至冬具动一切病故也。肺病春增者。二月三月是二阴痰病起时故也。第五中言风病夏服肥腻等者。夏月毛孔开通。宜以肥腻塞之。碱酢性热消水。令体坚实令风不入。热食流汗风出。又治虚冷风不得入也。冷甜即是苏乳等能治热也。等分冬服甜酢肥腻肥腻治风也。肺病服肥腻者。毛孔令水不入。辛热消水故能治肺病也。第六中言饱发肺病者。食饱既多肠胃盈满故发肺病。消时发热者。始食烂[卄/然]热还发食消也。后风聚虚中故发风病。第七中言风以酥腻者。风虚疏故以腻补之。热势未尽。欲荡治心腹故服下药也。等分病应以酥腻治风。以甜除热。以辛除水。肺病是水宜服吐药。次一行半除违时病。准前消息之也。从时长者子下是大段第二。于中有三。初明善言慰喻。轻病即愈。病重者。与药乃愈。第三合结。文相可见

流水长者子品　此品第二明记近因。与前三异。一者前于同类人道生慈。此中异类畜生生慈。二者前治身病之慈。此除心病之慈。三者前明世间之慈。此明出世之慈。有此三异。是以此品名得记近因。此品有三。初叹除病之德。二明救鱼之功。三结会古今。就初有两。初明长者除病。二从以病除故下明众生修福。恭敬赞叹以报恩。就大段第二中亦二。初明长者救鱼。二从醉酒而卧下明十千鱼报恩。就初有二。初明夫妻二子本生。二从是长者子下明本生事。于中有二。初明长者见鱼树神教救生慈悲心。即是明慈悲体。二从时此空池下明慈悲用。于中有二。初明财施。二从与鱼食已下明法施。就大段第二报恩中有三。初明生天。二从尔时十千下明报恩。三从时阎浮提下明国王觉悟。文相可见

舍身品　此品明释迦苦行以成寿量之果。傍显授记。就品有二。初问后答。答中有三。初现宝塔。二从尔时世尊欲为大众下明宝塔缘。三从是名礼塔下小许文结酬上问。就初有二。初明现塔众喜神问佛释。二从尔时佛告下明现舍利赞叹礼拜。就大段第二明缘起中有二。一从初讫偈说舍利因缘。二从偈后长行明宝塔因缘。就初有二。初长行后偈颂。就长行中有二。一经家标。二从阿难下明如来说。于中有二。初明本生。二从是三王子下明本事。于中有三。初明舍身因缘。二从尔时王子还至虎所下正明舍身。三从尔时第一王子下明眷属悲苦。就初有三。一明游山共议。二从时诸王子下明见虎共议。三从尔时第三王子下明思惟舍身。何由得知产来七日者有四义。一虎子额上有七点。二见眼始开。三虎饥临死可知七日不食。四者鬼神语之如树神导十千鱼。但经不出耳。就第三明思惟舍身中有三。初思惟舍身时至。二从何以故下正思惟欲舍身。三从勇猛勘任下发遣二兄。就第二正欲舍中有二。一思惟舍身修涅槃因。二从复次若舍是身下思惟舍身求涅槃果。就初有二。一思此身有四非常。二从我于今日下思惟修因。初中先明苦。然复不免下明无常。是身不坚下明空无我。可恶如贼下明不净。就第二明因中初明自行。于生死下明化他行。就第二求涅槃果中有二。一明思惟身患。二从是故我今下求涅槃果。初中一明苦无常。二从唯有下明空无我。三从是身不净下明不净。就第二求涅槃中有二。一明自证。二从证成如是下明化他。就初有两。初明总求涅槃。二从永离下明别求三点。即为三。初求解脱。二从无下求般若。三从具足下法求身。就大段第二正舍身中有二。一明王子发愿舍身现种种瑞。二从是虎尔时下明为虎所食。就大段第三眷属悲苦中有三。初明二兄悲苦。二从小王子下明侍从悲苦。三从尔时王妃下明父母悲苦。就大段第二偈颂中有三。初二行总明舍身大意。二从我念宿命下正颂上长行。三从佛告树神下五行半偈。明结会古今。文处分开不须烦论

赞佛品　是大段第三明流通分。准七卷经有二品。初一品赞能说人德即是赞叹流通。后一品明弘所说教法即是付属流通。此四卷经唯赞叹流通略无付属。就品有二。初明他方菩萨赞他方佛。第二明此土大士叹此世佛。何故彼此各叹者。叹显能说人德彼此无异故。就他方赞中初长行出能赞之人。后偈出所赞之事。于中两。初十九行赞叹。后一行回向。就初有三。初七行赞色声。二从智慧寂灭下七行叹福慧。三从如来世尊下五行合结。就初有三。初三行半叹色相好。次一行半叹音声。六种清净者。一大悲观世音。二大慈濡雅音。三大梵清净音。四大光普照音。五师子无畏音。六天人丈夫音。次二行结。于中一行结声一行结色。第二叹福慧中有二。初一行半叹内德。二从为诸众生下五行半叹外化德。内德中初半行叹智慧。次半行叹功德。后半行作譬。叹外化中初一行表。上半表拔苦。下半表与乐。后四行半广释。于中初一行半明拔苦与乐之体。后三行明拔苦与乐之事。就大段第三合结中。初二行明佛德无量。次二行明无人能知。后一行明叹不能尽。文相可见。就大段第二此间大士赞中有二。初信相赞。后树神赞。就信相赞中有二。初十行半别赞。二从如来悉知下六行半总叹。就初有三。初八行叹色身。次一行半叹福慧。后一行结。就初有两。初四行叹色身体。二从光明下叹色身用。第二叹福慧可见。第三总结中。上结色身下半结福慧。大段第三总叹中。初两行叹福慧。次四行半叹色身。就初有二。一行外化一行内德。就后亦两。初二行外化。次二行半内德。文相可见。第二树神赞中初出能赞人。从南无下出所叹事。于中有二。初二十五行半树神叹。后二行如来述。就初有三。初十九行半合叹应化二身。二从声闻之身下五行别叹法身。三从我今不疑下一行结请。就初有两。初十二行半正叹。二从我常念佛下七行明渴仰。就初有二。初四行半叹三身体。二从佛出于世下八行叹用。初中二。初二行半叹智慧。次二行叹功德。初中二。一行表叹。次一行半释。非法者。言邪法也。非道者。言邪道也。知有者知世谛也。非有者知真谛也。本性清净知一实谛也。第二叹用中有两。初一行总表出世希有。次七行明希有事。于中有两。初二行叹外化德。二从善哉下五行叹内证德。于中有二。初二行明能证智。二从一切下三行明所证理。诸根寂灭者。言于诸根中烦恼不起是数灭无为。善寂大城者。言大涅槃即是德灭无为也。甚深三昧者谓禅定也。入诸佛所行处者谓智慧也。此禅定智慧即是菩提德也。就第二所证理中。初一行明圣道空。次一行明万法空。后一行明众生空。身皆空寂者。言二乘道空。行虚亦空者。言大乘之道是如来行处。此道空亦空也。性相亦空者。言真实依他离性者故空。分别无相故相亦空也。就大段第二明渴仰中有两。初四行明彼渴仰愿见。二从唯愿下愿佛慈悲摄受。初中初一行举念佛善以愿见。次一行举礼拜善以愿见。次一行举修悲行以愿见。次一行举渴仰忧火以愿见。就第二愿佛摄受中。初一行愿说法水令灭忧火。次一行偈愿佛现身令我常见。次一行偈结请。大段第二别叹法身中有两。初三行叹法身深智。二从如来行处下两行明物不能知。就初有两。初一行半明生死虚妄。二从如来下一行半明法身真实。净如琉璃者。言法身之体离于万相故名为净。即是三无性理也。就大段第三结中。上半结法应二身。佛者谓应身也。所行处者是法身也。下半请现化身

金光明经疏一卷

    锓金光明经疏跋

右金光明经疏一卷。隋嘉祥大师释昙无谶译四卷经文所著也。文简义显。科节尤精。大有裨于学者焉。顷有人携来。谋入梓以广其传。呜呼兹文也。虽夙传于本邦。而隐晦甚久矣。而显于今者。殆有数而然邪。惜鲁鱼写脱差误不少。遂访寻原本。精为校雠。傍加国语。授诸印生。聊题其卷尾用识之岁月云

  时

正德改元岁次辛卯初冬上浣

    比睿山沙门(俊静)敬笔于东溪本觉院


金光明经文句

    No. 1785 [cf. Nos. 663, 1786]

金光明经文句卷第一

        隋天台智者大师说

        门人灌顶录

此四卷文。总有十八品。旧来分割盈缩不同。江北诸师以初品为序。寿量下讫舍身为正。赞佛为流通。正文又三。寿量下是正说。四王下大誓护经。除病下大悲接物。江南诸师以初品为序。寿量下为正。四王下十三品为流通。真谛三藏分新文二十二品。初品为序。寿量下至舍身十九品为正。后两品为流通。真谛释云。寿量明师果。忏叹两品明弟子因。授记是弟子果。除病是师因。四王下正论力用。前师果弟因既为正。后师弟因果何得为流通邪。今师谓。分文本是人情。人情咸谓。序未辨道。流通歇末不得论师弟因果。是义不然。夫三段者不可杜断隔绝。序本序于正通。序则有三义。正本正于序通。正亦三义。通本通于正序。通亦三义。上中下语皆善故。又众生得道根性不定。何容序无滋味流通歇末邪。既不歇末说师弟因果亦应何妨。如序中说正亦应无妨。流通中有正意。弥是督励宣行不乖经意。又法华中明。阿私仙是师因。持品授弟子果记。诸师咸判是流通。此有其例。于义无妨。与夺由人不须苦执也。今从如是我闻入寿量。讫天龙集信相菩萨室为序段。从尔时四佛下。讫空品正说段。从四王品下讫经流通段。序者。序将有利益。正者正当机辨道。流通者。流名下注通名不壅。欲使正法之水从今以注当。圣教筌[(ㄇ@人)/弟]不壅于来世。经曰。上中下语皆善。即此义也。疑者云。序分何得入正品中。众经例尔。如维摩无序品。序在正说中。大品正说在序品中。涅槃序分入正品中。众经皆然。不以为疑。何独或此。斯乃出经者意。为四佛断疑孤然而起其文崭绝。引序分安寿量中。今从义便不得齐品。分割也。序有三义。一次绪。二叙述。三发起。次绪者。居一部之初冠众说之首。故言次绪。叙述者。叙于方将述于当益。故言叙述。发起者。发其信心起于教也。一段经文含此三义。故题为序品。品者梵语称为跋渠。此为品也。品是类义。此中文句气类相从。节之为跋渠。例如律中有篇聚。毗昙有犍度尔。从如是下是次绪。从是时如来下是叙述。从其室自然广博严事下是发起。次绪之序旧云五事。地人开佛是为六事。此经天龙集信相室。不闻前序不闻后梦。亦得是同闻亦得是非也。同闻众少不次第(云云)。此之五六。亦名印定序。三世诸佛经初皆安如是故。亦名通序。与诸经同亦为通名作本故。亦名经后序。结集者所置故。亦名经前序。遗嘱令安故亦名破邪序。对破外道阿沤故。亦名证信序。令闻者不疑故。天台师云。总此六说都是四悉檀意也。诸佛诸经同是世界悉檀也。经前经后为利来世是为人悉檀也。对破外道是对治悉檀也。信顺无疑是第一义悉檀也。旧解。如名不异。是曰无非。阿难所传文句似泻水分瓶与佛一种。故不异称如。文下之理允当无谬。故无非曰是。略而言之。文如理是。肇师云。如是者信顺之辞也。信则所闻之理会。顺则师资之道成。真谛三藏云。如是者决定也。数决定理决定。佛说此经有若干文句。若多成增谤。若少成减谤。阿难传之如泻水不多不少。故数决定。佛说无相之理不有不无。若有堕增若无堕减。阿难传之无增无减。故理决定。龙树解。如是者信顺之辞也。信者言是事如是。不信者言是事不如是。此之四解各据一悉檀意。旧解语总不显文诠何等理为如。何等理为文所诠为是。既不显了。只是世界悉檀意。肇师据信顺是为人。三藏文理决定为对治。龙树信顺如是为第一义(云云)。今作通别二释。佛如法相而说。阿难如闻相而传。故言如也。佛如法相而解。阿难如海量而受。故言是也(云云)。别释者。外曰阿沤称吉。文乖其理故非如。理异其文故非是。不可见阿沤在初而中后皆吉也。文如其理故言如。理如其文故言是。今谓。三藏经初云如是。二谛各异故非如。理浅故非是。摩诃衍二谛相即故言如。理深故言是。今谓三人同闻而各解故非如。证入优劣故非是。唯菩萨所闻者为如。菩萨所到者为是。今谓。离边明中之文则非如。出二谛之外有中道则非是。文字性离即是于如故言如。一切法即佛法名之为是。初破邪明正即三藏经如是。次破异明同即通教经如是。次破浅明深即别教经如是。次破离明中即圆教经如是。此经既是方等。通被根性不同。作种种说无咎。观心解者。观与境冥故为如。境即正观故为是。经言。如此观者即是正观。若他观者名为邪观。即其义也。我闻者。旧云。阿难不师心。亲承佛旨故曰我闻。真谛曰。我是器义。一散心名覆器。无闻慧故。二忘心名漏器。虽得而失。无思慧故。三倒心名秽器。非而谓是。无修慧故。阿难无三过。唯是善好器。亲承有在故言我闻。释论云。耳根不坏声在可闻处。作心谛听。因缘和合故称闻。阿难与听众述佛遗旨。亲承不谬故言我闻。师释我有四义。谓我我。我无我。无我我。我无我而不二真我。义配四根性人(云云)。闻亦四义。谓闻闻。闻不闻。不闻闻。不闻不闻。配四教法人(云云)。有四种阿难。谓欢喜阿难。贤阿难。典藏阿难。海阿难。为四种缘立四种名。欢喜阿难是我我用闻闻。亲承丈六身佛持三藏法。故言我我闻闻。贤阿难是我无我用闻不闻。亲承丈六尊特合身佛持通法。故言我无我闻不闻。典藏阿难是无我我用不闻闻。亲承尊特身佛持别法。故言无我我不闻闻。海阿难是我无我而不二用不闻不闻。亲承法身佛持圆法。故言我无我而不二用不闻不闻。此经通三乘说听一音各解。故须分别(云云)。观解者。若作攀上厌下观。是为我我闻闻。若作析体两种从假入空观。皆是我无我闻不闻。若作从空出假观。是无我我不闻闻。若作中道观。是真我不闻不闻。一时者。肇师云。法王启运嘉会之时也。三藏云。高时下时皆是若过若不及不堪闻法。唯有平时即是一时也。私谓。高时慢心不行。下时耽荒五欲。不耽不慢是平时也。师释。众生感法。佛慈赴教。机应之时也。亦是发真见谛之时也。亦是法眼明朗照世之时也。亦是佛眼照中之时也(云云)。而言一者。若前思后觉斯二非一。思觉妄断豁悟之时。故言一时也。观解者。从假入空与真一时。从空入假与机一时。中道正观与法性一时(云云)。佛者。真谛云。佛有三义。一切智异外道。慈悲异二乘。平等异小菩萨。余人无此。释论明佛是第九号。佛名为觉。觉世间出世间常无常数非数等。朗然大悟故名为佛。天台师云。佛者。依一切智有丈六佛。依道种智有丈六尊特佛。依一切种智有法身佛。三佛不得一异。非一异而一异尔。观解者。空观觉知诸法一相。假观觉知诸法种种相。中观觉知诸法无一异相亦一异相(云云)。住者。佛是能住。王舍城是所住处。真谛明住法有八。一住大千界内。二住依止处。王城也。三住五分法身。寿命现在也。四住威仪利物。五天住住禅定。六梵住住四等慈悲。七圣住住三三昧。八大处住住第一义也。释论四住摄八也。天住梵住摄其天住定住。圣住摄其五分命住。佛住摄其大处住。又有迹住王舍城。摄其界内依止威仪三住。天台师云。丈六身佛住真谛也。丈六尊特合身佛。双住真中也。尊特身佛双住俗中也。法身佛住中道也。观解。空观住真。假观住俗。第一义观住中。王舍城者。释论大出因缘。初立五山中七烧七造。王来居此。故言王舍。又云。他舍被烧王舍不烧。后悉排云是王舍。即得免烧。自是已来呼为王舍。观解。五阴为舍心王居之。故言王舍。耆阇崛山者。释论翻鹫头。真谛云。曲鸟山在王舍城东南。毗富罗山在西南。仙人山在西北。黑土山在东北。白土山在中央。中央三由旬平正即王城也。观心山者。灵即神智是般若也。鹫即万德是解脱也。山即不动是法身也。常为心王所观。即是观之住处也。令一切心数同入其中也。此经阙同闻众者。谓时有五。处有四。耆山众不闻信相室说。信相室众不闻梦中说。梦中众不闻梦觉已说。众非一座故不列同闻。若尔阿难不应称我闻。然虽不闻佛更为说。又其得佛觉三昧能自通达。得称我闻也。从是时如来下是叙述序。叙下十七品故。亦名别序。简异余经亦为别名作本故言别也。别义为七。一从是时如来下一行半是入定别。二从是金光明下讫二十七行偈是叙述别。三从寿量品下是怀疑别。四从大士如是下是瑞应别。五从信相见佛下是腾疑念别。六从四佛告下是止疑别。七从欲色界天下是集众别。生起者。佛常在定。而群机扣佛佛欲应之。故示轨仪。如来常寂犹尚乐定。入游法性出叙经王。信相闻深法。疑法既是常人寿那短。是故怀疑。菩萨福力疑能感应。应故四佛现。佛现即腾疑。腾疑故佛即止疑。当雨法雨故大众云集。七事异他经故言别也。已说七别竟。或时作三别。一从是时下名叙述序。二从寿量品下名现瑞序。三从时四如来下是众集序(云云)。言叙述序者。叙后十七品。初五行叙寿量品为三。初两行叙果德。次一行叙怀疑。次两行叙断疑。细作可寻。次一行半叙忏悔品破恶生善之意(云云)。次一行半叙赞叹品生善破恶(云云)。次六行叙空品破恶中破三障恶(云云)。从护世四王下是叙其品可解。大辩者是叙其品。尼连鬼母是叙功德天品。同是女天故。地神是叙其品。大梵三十三天是叙散脂品。散脂是将梵释是主。叙主即得臣将也。紧那罗等是其领。叙其领得其管也。我今所说诸佛秘密者。是叙正论善集两品。说世秘密可以治国。出世秘密可以诣道。故知叙两品也。若得闻经去是叙鬼神品。鬼神品中纯明听法功德为八部所护(云云)。着净衣服下两行叙授记品　三大士十千天净心殷重净若虚空。故获授记也。若得听闻下叙除病流水等品。闻名服药悉得病除。则是善得人身。复能修行布施福业是善得人道。鱼闻佛名善得天身天道。即此意也。正命是叙舍身品。虎飱血肉即得解脱。岂非正命也。若闻忏悔下一行叙赞佛品。佛有三世。诸菩萨多是先佛即过去佛也。又是未来佛也。为此菩萨所赞。即为佛所赞也。叙述之意止可仿佛。不得薳自分明(云云)。问谁作叙述。旧云集经者。若尔是论非经。又乖经文。文云。我今当说。或云是信相。若尔信相已能玄叙。何事致疑。又非集经者那忽作序。师云。是佛自作。难者言。若尔便是正经。那得称序。此无所妨。菩萨尚能安禅合掌说千万偈。况如来口密神力赴机。何所不为。文云。我今当说忏悔等法。此是明证。大品中化佛说六波罗蜜。亦得称序。此其例也。释入定为三。初一句一字明能游人。二三字两句叹所游法。后两句结也。是时者。真谛云。有五种三时。一欲说正说说已。二破外道去来时立现在有说有听时。三下种成熟解脱时。四正师正教正学时。五佛欲说众欲听不高不下平平时。今但论如来知机堪可得道时。若慧眼得道智与真冥时。若法眼得道智与俗冥时。若佛眼得道智与中冥时。佛欲履历法性观知众生于何时得道故言是时也。如来者十号之初也。三藏解如来文多不载。今言。智照理与诸佛等故言如。慈悲与诸佛等故言来。诸佛应住秘密藏中。何故出世。只为慈悲故来。成论云。乘如实道来成正觉。大经云。从十一空来。就智论来。从六波罗蜜来。就行论来。释论明。如法相解为如。如法相说为来。今明。如三谛法相解名如。如三谛法相说名来。故言如来也。游者游涉进入之义尔。夫法性者非入住出。故小般若云。如来者无所从来亦无所去。故名如来。何得言游邪。良以慈悲导物。敩我而入故言游也。令众生食甘露味。亦应言住。为众生宣说亦应言出。故法华云。善入出住百千三昧。即此义也。无量甚深者。将明游入简显其体高广。体包法界故言无量。彻到三谛故言甚深。非是二乘下地菩萨之所逮及。故言无量甚深也。法性者。所游之法也。诸佛所轨名之为法。常乐我净不迁不变。名之为性。非是二乘以尽无生智所照之理为法性也。二乘法性浅故非甚深。有限故非无量。今之如实智所照之理横包法界竖彻三谛。故言无量甚深尔。又无量者。非别有一法名为无量。毗卢遮那遍一切处。一切诸法皆是佛法。皆佛法故即皆法性。佛皆游之故言无量。又非别有一法名为甚深。即事而真无非实相。一色一香莫非中道。皆中道故即是甚深。例如释论解四无量心云。缘东方众生名广。缘四方名大。缘四维上下名无量。准此而言。缘真谛法性名广。缘俗谛法性名大。缘中道法性名无量。若缘中道。即是三智一心中缘三谛一谛。此境无量。唯佛无量智乃能缘之。如函盖相称。非二乘下地测其涯底。诸佛行处者。正显佛智无量甚深。佛智无量甚深故行处亦无量甚深。行处无量甚深故佛智亦无量甚深。举函显盖。举盖显函。正在此也。过诸菩萨所行清净者。正简也。菩萨居未及之地。智之所行未能深广故。地持云。菩萨得九种禅。初名自性禅。若入此禅即入实相法性清净之境。二乘不闻其名。况有其行。若入第九清净净禅。一切通别惑累若正若习皆尽。故言清净净禅。自下地去皆有余习。佛住十地顶。若入此禅过诸菩萨。净名云。心净已度诸禅定。即此义也。亦是举其高位简法性甚深也。是金光明下叙述序。若叙正说流通十七品意。已如上说。今更论叙述五重玄义。初十二行半叙名体宗用。次十四行半即叙流通弘宣此典。即是叙教相也。就初一句叙名。次一句叙体。次三行叙宗。次九行叙用。护世下去叙教相也。解者或言。金光明一句犹是叙体。如矿石中金。金体乃非光非明。不妨约金论内外用。法性非宗非力。亦依法性起于宗力。当知此句正是叙体。今明理乃当然。分文则属叙名也。经王上已说。今更述之。三藏云。三德摄三。涅槃正断二乘断见。般若正遣凡夫有着。华严正化始行菩萨。今经通为八位人。故称王也。此语难解。涅槃为菩萨说甚深微妙行处。岂止为二乘。般若云。法身佛为法身菩萨说法。其听法众非生死人。岂止遣凡夫有着。华严说初地乃至说十地。岂止为始行菩萨。作此偏说。无智之人于诸经起轻慢。此义不可。今言经王者。若取文为经。即是三种俗谛。若取理为经。即是三种真谛。若取文理合为经。即是三种中道。若说余谛。是经而非王。若说中道。是经复是王。于九种经中而得自在。但经王是一。随缘设教名字不同。华严云法身。方等为实相。般若称佛母。法华为髻珠。涅槃名佛师。皆是法性异名。通为诸经作体。譬如诸性应运迭兴。龙师鸟官随时霸立。百代虽异而统王是一。法性亦尔。宜闻大品佛母为王。余名废息。宜闻法华宝所为王。余名废息。法性为金光明之王。亦复如是。若作此解。上不为佛经王之旨。下不增长众生我慢。微妙者。他释因微果妙。今不尔。因果俱微妙。因中性德深而难见名为微。不纵不横名为妙。果中修德亦复如是。四方四佛护持者。四方者四门也。四佛者四门果上觉智也。释迦觉智与四佛同。诸佛果智冥于法性。法性得显名为法身。法身不动名之为持。法性常故诸佛亦常。法常佛常。寿命亦常。常故无量。信相推迹或本。四佛令其达本悟迹。名之为护。此一句种种义。法性四门法性四德即体义。果智显体即宗义。护念信相断疑复是用义。而叙宗为正意。观心解者。四方是四谛。四佛是四谛智。东是方首。如集是苦因。又东甲乙是春生。生即集谛也。从东次南。亦犹生而有长。先春次夏故南方是苦谛也。长后秋收。又白帝属金。金能决断。西方即道谛也。从秋收至冬藏。众事都息。北方如灭谛。苦集因果皆谢无用也。观此四谛生眼智明觉。持理不失护倒不起。故名护持也。又观四方是四德。观东方常为破无常。观无常为破常。观非常非无常破常无常。乃至观北方无我为破我亦如是。此观持德不失护倒不起。故名护持也。观东方集谛常非常非无常不动。故名阿閦。观南方苦谛乐无去无来法性实相。实相尊贵故名宝相。观西方道谛毕竟清净。法性寿命与虚空等。故名无量寿。观北方灭谛永寂为我入秘密藏。秘密藏故名微妙声(云云)。我今当说下九行偈是叙用。文为四。初三行明能破之胜法。次三行半明所破之恶罪。次一行半举行法劝修。次一行结成。初三行明能破胜法者。谓境法法性也。行法忏悔赞叹也。导法一切种智也。故言忏悔等法。知非一种也。若相资为论。行资智。智显理。理显故能尽众苦。苦尽故法身显。智圆故报身显。功德无上故应身显。若圆论者。三法不纵不横而修。三身亦不纵不横而显。虽圆别之殊。俱是能破之胜法也。观旧文语略。新本具有三周说法之文。四佛说常果上根得益。婆罗门说法身无舍利中根得益。佛分别三身下根得益。今叙中云。我今当说忏悔等法。即是叙下三周之法能破恶也。次从诸根不具下叙述空品。文为二。初三行半明所破之恶。次二行半明能破之方。初又为三。诸根不具下破报障。愁忧一句破烦恼障。恶星灾异下破业障。余经对缘云报障难转。因时可救果无如何。此经三障皆可转。一往释此三障由破五戒。破五戒是业障。受三涂人天等身是报障。烦恼为根本是烦恼障。今直就人道中明犯五戒报者。诸根外缺寿命内夭。此两句是杀生报。昔损他身分今诸根残毁。昔断他命今寿损减。经云。杀生因缘得二种果报。多病短命。即其事也。若贫穷困苦是外无依报。诸天舍离是内无福德。此两句是犯盗戒。经云。有同生同名天龙辅佐之。功德天发愿利益之。盗人无此事也。又先富后贫者。必是龙弃天舍也。若亲厚内斗王法外加。此两句是犯淫戒。经言。人护则人嗔法护则法坏。昔侵其人今骨肉斗讼。昔毁他法今王法所加。即其事也。各各忿诤此应有两句。或是翻者脱落。或是略尔。内则各各忿诤。外则人人不信。此一双是犯妄语。昔不实欺他今常被欺忿。昔语无实今人无信者。外耗财物内亏礼度。此是饮酒报。昔慢财费日今多损耗。昔乖撙节今堕聋騃。经言。嫌恨猛风吹罪心火常令炽然。即其事也。问释大乘经。何得以五戒对义。答开合五戒大有所关。提谓经云。五戒者天地之大忌。上对五星下配五岳中成五藏。犯之者违天触地。自伐其身也。又对五常。不杀对仁。不盗对义。不淫对礼。不饮酒对智。不妄语对信。又对五经。不杀对尚书。不盗对春秋。不淫对礼。不妄语对诗。不饮酒对易。又对十善。杀盗淫是身三。妄语摄口四。饮酒摄意三。俗不能护口。略制一不妄语。释论云。说重者是妄语则已摄三。饮酒是邪命自活增益恚痴。出世以智慧为首。生死以三毒为根。若能禁酒是防止意地三毒。长养出世智慧也。是为开五戒出十善。十善是旧法轮王所用。亦名性罪性善。都是一切罪之根本。又五戒对五阴。不杀即色阴。不盗即受阴。不淫即想阴。不妄语即行阴。不饮酒即识阴。五阴开四念处。念处开三十七品。三十七品开三脱门。三脱门开涅槃。故云色能发戒。受受禅定。想慧悟虚通。行发解脱。识即知见。当知五戒能成五分法身。办二乘之法也。又五戒亦是大乘法门。提谓经云。五戒是佩长生之符不死之印。即常德也。出入无乱往还无间。即净德也。统御一身即我德也。以立道根。即乐德也。此是五戒对四德。束五戒为三业。即对三无失三不护三轮不思议化三密三轨三身三佛性三般若三涅槃三智三德等无量三法门。横竖无边际与虚空法界等。亦是无尽藏法门。亦是无量义三昧。举要言之。即是一切佛法也

复次害命名事杀。不害命名事不杀。法门解者。析法名理杀。体法名理不杀。当知不杀之戒种种不同。论其果报亦复不同。若作意防护如马着勒如牧牛执杖者。报在人道百二十年。唯得肉眼无有四眼。若任运性成如河注海者。报在六天。极长者九百二十六亿七千万岁。唯得天眼未得三眼。若加修客戒无常苦无我等慧者。报在变易。寿七百阿僧祇。唯得慧眼未得二眼。若加修常无常等慧。报在莲华藏海受法性身。分得五眼分得常寿。比佛犹是诸根不具。寿命损减。况前诸根诸寿邪。若圆教人。持事不杀戒。又持理不杀戒。不坏于身而随一相。不断痴爱起于明脱。体阴界入无所毁伤。若子若果不生不灭。成就智慧居常寂光土。常寿湛然五眼具足。得根自在耳见眼闻。得命自在修短自任。是则名为究竟持戒。诸根具足命不损减也。又圆教人何但持之是戒。唯杀唯慈。亦作事杀亦作理杀。如仙豫大王杀五百婆罗门。与其见佛之眼。与其十劫之寿。又作法门杀者。析荡累着净诸烦恼。如树神折枝不受怨鸟。如劫火烧木灰炭双亡。故央掘云。我誓断阴界入。不能持不杀戒。一切尘劳是如来种。断此种尽乃名为佛。成就金刚微妙法身。湛然应一切。唯杀唯慈。垂形九道。随其所宜示长短命。任其所见用缺具根而化度之。前诸戒行浅近隘塞。非是通途。圆戒宏远径异会同。故名究竟持不杀戒也。不杀之戒。人天已上极佛已还。旷大纵横其义如是。云何而谓是小乘数耶。复次不与取名事盗。与取名事不盗。法门解者。如佛言曰。他物莫取名法门不盗。菩提无与者而取菩提。是名法门盗。不盗之戒种种不同。若持戒作业求可意果。可意果者无常速朽悉是他物。臭如粪果害如毒食。有智之人所不应求。设使得之心不甘乐。云何殷勤饮苦食毒而自毁伤。贫穷四姓即此三界洄澓困苦。岂过有流。三障障佛第一义天之所舍离。是名为盗非不盗也。又二乘之人以四谛智观身受心法。厌恶生死欣求涅槃。涅槃心起为自为他为共为无因。介尔心生即取他物。即非时取证即不待说所因。焦种不生。见苦断集修道造尽非求法也。谓有涅槃成涅槃见。若有着空者。诸佛所不度。身长三百由旬而无两翅。堕三无为坑。受若死若死等苦。法华云。饥饿羸瘦体生疮癣。岂非贫穷困苦邪。净名云。不见佛不闻法不入众数。岂非第一义天远离邪。此犹名盗非不盗也。若别教菩萨次第行次第学次第道。从浅至深舍一取一。来已更复来。去已更复去。悉是辱于来去相。亦是不与而取。取已而舍。亦是贫穷。舍已更取。数数去取即是困苦。不即与第一义相应。即是远离。此犹名盗非不盗也。圆人观诸法实相。受亦不受。不受亦不受。亦受亦不受亦不受。非受非不受亦不受。不受亦不受不取是菩提。障诸愿故。是法平等无有高下。不高故不取。不下故不舍。如是观者。观如来藏具足无缺。是如意珠。随意出宝。即修罗琴。任意出声。即是大富。大富故无取。无取故即第一义。第一义故天不远离也。是名究竟持不盗戒也。圆人复有盗法门。菩提无与者而取菩提。如海吞流不隔万派。如地荷负担四重担。众生悉度烦恼悉断。法门悉知佛道悉成。此义可知不能多说。前诸戒行浅而且塞。非是通途。圆戒宏远径异会同。故名究竟持不盗戒也。复次男女身会名事淫。不会名事不淫。法门解者。若心染法是名为淫。不染法名为不淫。不淫之戒种种不同。若关禁七支。如猴着锁。擎一油钵过诸大众。割舍触乐求于未来净洁五欲。如市易法以铜钱博金钱。此乃增长欲事非不欲也。若为生天故持戒。如羝羊相触。将前而更却。帝释共八十亿那由他天女纵逸嬉戏。看东忘西欲犹不足。化为老修罗纳舍脂。使诸天亡身失首。又见仙人入定污弄其女。仙从定起。释羞自化为羝羊。仙人咒之。千根着身无能却者。后来忏谢变为千眼。是亦增欲非不欲也。若断欲界粗弊之欲。染着色无色界禅定之乐。如冰鱼蛰虫堕长寿天。是为一难。贪着禅味名为大缚。是染欲法非不欲也。若憎恶生死如怨如蛇。爱玩涅槃如亲如宝。弃之直去涉路不回。诸有色声不能染屈。如八方风不能动须弥。若闻菩萨胜妙功德。甄迦罗琴声迦叶起舞不能自持。随岚风至破须弥如腐草。是染欲法非不染也。若菩萨恶生死如粪秽。恶涅槃如怨鸟。舍于二边志存中道。起顺道法爱生名顶堕。是菩萨旃陀罗。既无方便。此慧被缚不能胜怨。已所修治为无慧利。是染欲法非不欲也。圆人观一心三谛。即空即假即中。即空何所染。即假何所净。即中何所边。即空即假何所中。即空故无我人十六知见依正等爱。即假故无空无相愿等爱。即中故无佛菩提转法轮度众生等爱。三谛清净名毕竟净。是净亦净。经言。唯佛一人具净戒。余人皆名污戒者。圆人行于佛法。即究竟持不淫戒也。圆人又有染爱法门。如和须蜜多女。人见人女天见天女。见者得见诸佛三昧。执手者得到佛刹三昧。歍者极爱三昧。抱者冥如三昧。各各皆得法门。亦如魔界行不污戒菩萨。变为无量身。共无量天女从事。皆令发菩提心。如维摩诘。若入后宫。后宫中尊化正宫女。先以欲钩牵后令入佛道。斯乃非欲之欲。以欲止欲。如以屑出屑将声止声。前诸行浅塞。非是通途。圆戒宏远径异会同。是名究竟持不淫戒也。复次不见言见。见言不见。名事妄语。法门解者。未得谓得。未证谓证。名为妄语。妄语多种。诸欲求时苦。得时多怖畏。失时怀忧恼。诸欲无乐时。凡夫痴人于下苦中横生乐想。竖我慢幢打自大鼓。谓色即是我。我即是色。色中有我。我中有色。执有与无斗。执无与有斗。依止断常起六十二戏论。破慧眼不见于真实。增见长诸非。吾我毒甚盛。备口四过。略标妄语尔。三十三天黄叶生死谓是真金。非想自地具细烦恼。谬计涅槃。此非妄语。谁是妄语邪。二乘之人竞执瓦砾欢喜持出。生灭度想生实未尽。宁得灭度。生安隐想。所作未办。宁得安隐。净名云。佛为增上慢人。说离淫怒痴名为解脱。其实未得一切解脱。未得谓得。岂非妄语邪。佛为别教人以四门说实相。执于一有隔碍三门。乃至执非有非无而隔有无。夫实相者言语道断心行处灭。云何以字。字于无字。云何以数数于无数。岂非妄语邪。圆人如实而观如实而说。如实观者。非内观得是解脱。非外观非内外观。非离内外观。亦不以无观得是解脱。如实说者。一切实一切不实。一切亦实亦不实。一切非实非不实。如是皆名诸法实相。经言。诸佛皆实语佛语实不虚。能以一妙音遍满三千界随意之所至。随诸众生类各各皆得解。即是以佛道声令一切闻也。圆人亦有妄语法门。无车说车诱戏童子。无乐说乐止彼啼儿。若有众生。因虚妄说得利益者。佛亦妄说。经言。我是贪欲尸利。我是嗔恚尸利愚痴尸利。然实非也。我是天是人。实非天人。我是龙鬼。实非龙鬼。将虚以出虚。令有不虚尔。前诸行浅近隘塞圆行深远。夷坦无碍经异会同。故能如此。是名究竟持不妄语戒也。复次若谷若草昏心眩乱者名事酒。法门解者。迷惑倒见名之为酒。倒见多种。夫酒为不善诸恶根本。能生三十六种之失。招于五百世中无手。慢刑失礼发出伏匿。眠卧粪秽唐突水火。过患如此。人犹尚之。晋世引满称艺能。魏朝清浊为贤圣。毕卓自署为酒徒。郑泉自誓为酒壶。竹帛载之古今歌之。不应作而作。不应歌而歌。非醉酒是何。释论云。有一法师。为王说五戒罪福。王难云。饮酒招狂饮者甚多。狂者何少邪。法师举手指诸外道而已。更言余事。外道侜张云。王难甚深。是秃高座更不能答。王云。法师答竟。狂亦不少。指汝等是。将护不彰尔。此即世人之醉也。又贪如海纳流无有满时。嗔如火益薪展转弥炽。痴如胶黏结如冰足水。八万尘劳烦恼其心。无暂停住。掣电蛇舌扬焰猕猴。五欲搅作无时不醉。大经云。从昔已来常为声色所醉。流转生死。三界人天通有此醉也。若二乘之人虽断九十八使四住烦恼。无明未吐。如半疟人。大经引醉归之人。世间无常乐而言我净。如来实我净而言无常乐。如彼醉人见日月转。此二乘醉也。菩萨之人无明未尽不了了见。菩萨行故见不了了。如远望大舶遥观鹅雁。夜睹画像远视人杭。亦如醉人朦胧见道。如是等无量譬喻显于菩萨未得明了。故迦叶云。自此已前我等悉名邪见人也。此菩萨醉也。圆人行如来行。具烦恼性能知如来秘密之藏。虽有肉眼名为佛眼。所可见者更不复见。故文云。入深法性。即于此典金光明中。而得见我释迦牟尼。大经云。了了见佛性犹如妙德等。是则五住正习一时无有余。酒法既除。何所可醉。是为究竟持不饮酒戒也。圆人亦有饮酒法门。鸳掘云。持真空瓶盛实相酒。变化五道宣扬哮吼。波斯匿醉转更多恩。末利后饮。佛言持戒。入于酒肆自立其志。亦立他志。夫得其门者逆顺俱当。失其柄者操刀伤手。前诸行浅近隘塞。圆行宏远径异会同。故能如此。是名究竟醉醒无二也。上观四谛智名四佛。观五佛云何观。观五戒实相觉智清净。即是观心中见五佛也。次破烦恼障。指愁忧恐怖一句是也。上来诸事或约内身或约外报。是报障义便。此一句专明心为烦恼障便

金光明经文句卷第一金光明经文句卷第二

        隋天台智者大师说

        门人灌顶录

报障如上可解。烦恼与业云何。数人云。数起而轻名烦恼。数起而重名为业。天台师云。任运常有是烦恼。卒起决定心发动身口。必牵来报者是业。若尔恶星灾异都不关心。云何是业障。此乃外相表业将起。是业责报之相即得是业障也。若烦恼业转报未必转。若报转业烦恼必转。通论。见思烦恼皆有愁忧恐怖。别论。愁忧属见烦恼。恐怖属爱烦恼。今不具记(云云)。三破业障者。从恶星灾异下是也。业将感报故其相前现。相名表发意在此也。恶星者。别有客星也。亦是五星二十八宿。一方有七。四七二十八也。违其度数失其分野。若荧惑乱行麻彗暴出。是客星也。灾异者。风雨雪霜乖候等是也。众邪者有三。人邪鬼邪法邪是也。虫道者毒鬼也。又言三毒是虫也。变怪者诡怪也。谓禽兽丑恶形声等是也。恶梦者。心灵潜密业现其中。梦见不适意事是也。夫诸业表报不出五罪。若恶星表亡身失命者。杀生业相也。恶星表神弃困穷者。窃盗业相也。恶星表亲离幽厄者。淫罪业相也。恶星表诬枉谗谤者。妄语业相也。恶星表丧失财产者。饮酒业相也。其余灾异怪禽恶梦等。随其时节各有所表。细心推详不出五罪之报。行者知解推之。何须折篾钻龟问管公明邪。从当净洗浴下二举方法能空于恶也。前业相外彰报对不久。内无方法何以禳之。约其三业作三德之方。以事表理也。洗浴臭体拟作法身。缄唇摄耳拟听般若。至心清净拟作解脱。前令洗浴内身。后更劝净外服。内外相成尔。前但令听后诫令专听。郑重缄口尔。前令至心后示至心之境。成其方法尔。夫人身本于不净。莲华本于淤泥。譬如栴檀生于伊兰。世间现见也。今近因三业规矩。远成三德妙义。可不信哉。洗浴法身能禳报障。摄耳缄口能禳烦恼障。至心能禳业障(云云)。从是经威德下四结成也。能悉消除者明三障转也。今其寂灭者三德成也。寂灭秖是涅槃。涅槃秖是三德。前三业方法既成。三障理数应转。三障既其已转。理数成于三德。报障转成法身德。烦恼障转成般若德。业障转成解脱德。前寄事相将浅以表深。后明寂灭将深以结浅。经文绣密见之者寡(云云)。护世四王下叙流通中品。皆如上说

    释寿量品

佛本无身无寿。亦无于量。随顺世间而论三身。亦随顺世间而论三寿量。法身者。师轨法性。还以法性为身。此身非色质亦非心智。非阴界入之所摄持。强指法性为法身尔。法性寿者非报得命根亦无连持。强指不迁不变名之为寿。此寿非长量亦非短量。无延无促。强指法界同虚空量。此即非身之身无寿之寿不量之量也。报身者修行之所感也。法华云。久修业所得。涅槃云。大般涅槃修道得故。如如智照如如境。菩提智慧与法性相应相冥。相应者如函盖相应也。相冥者如水乳相冥也。法身非身非不身。智既应冥亦非身非不身。强名此智为报身也。法寿非常非无常。智既应冥亦非常非无常。强名常为寿也。法既非量非无量。智既应冥亦非量非无量。强名无量为量也。应身者应同物身为身也。应同连持为寿也。应同长短为量也。智与体冥能起大用。如水银和真金能涂诸色像。功德和法身处处应现往。能为身为非身。能为常寿为无常寿。能为无量能为有量。有量有二义。一为无量之量。二为有量。之量如七百阿僧祇及八十等。是有量之量。如山斤海滴。实有齐限。凡夫所不知。阿弥陀实有期限。人天莫数。此是有量之无量。应佛皆为两量。逐物随缘参差长短。然此三身三寿三量不可并别一异。则乖法体。即一而三即三而一。乃会玄文。故下文云。如深法性。即于此典金光明中而得见我释迦牟尼。即其义也。但信相偏疑应身之有量。四佛偏举应佛之无量。断其有量迹疑既除。深达报法。若从信相所疑。应言寿有量。若从四佛释疑。应言寿无量。而今不道寿有量。不道寿无量。直言寿量者。意欲圆论三佛之寿量。故不偏题。取意为释。若从义便。正是报身之寿量。何故取此。报身上冥下应。上冥法性即非量非无量。下应机缘能量能无量。量疑牵无量之答即达于圆。经家从其生圆解而题品。举一而蔽诸。从此义故题为寿量品。又一时重解。寿量品亦作三重。一玄义。二引证。三还源。玄义者。寿者命也。谓报得命根连持不断。名之为寿。延促期数名之为量。故言寿量也。此释应佛因缘之寿量也。又寿者受也。境智和合共相盛受。谓无分别智盛受无分别境。无分别境盛受无分别智。如函大盖大。故寿是受义也。量者相应也。境智相应故言量。此释报佛之寿量也。又寿者久也。常不变易称之为久。量者铨量也。常久之寿非多数非少数。非相应尽知。非相应不尽知。非可说非不可说。无以名之。强以铨量说其长久。此释法身之寿量也。初番为二。一有量量。如释迦之寿方八十是也。二量无量。如弥陀之寿。实是有量。人天所不能测。故言量无量也。此量无量皆应佛所为也。第二番亦二义。佛以如如智称如如境。境无分别智亦无分别。若境称于智智有分别。境亦有分别。此知与不知皆报佛所明也。第三番亦二义。一者深寂不可说。二以慈悲方便亦可得说。此可说不可说皆法佛之法也。二引证者。方八十年证有量也。诸天世人八部之众无能思算山斤海滴不可数知。此证量无量也。虚空分界不可齐限。证境无分别也。又唯除如来。证智可分别也。又下文去。智渊无边法水具足。亦是证智也。寿不可计。此证不可说也。将欲宣畅释迦如来所得寿命。此证慈悲可说也。又闻是四佛宣说如来寿命无量。证大悲可说也。新本明。婆罗门求佛舍利如粟大求六天报。即证有量也。王子说。金光明难思难解福报无边。福报无边是证量无量。难思难解即总证智境不可说等(云云)。三还源者。亦云复宗。释此寿量。虽作三身六义。勿作异解。秖是经题金光明义尔。初番量无量者。秖是明义。以其明故大小长短延促数量悉现明中。还是明义尔。第二番智境函盖体解相应。色大故般若亦大。以法常故诸佛亦常。还是光义也。第三番可说不可说。常乐我净说满法界。法性无所益。都无一言。法性无所损。还是金义。夫解一则千从。迷一则万惑。即此义也。既是两时之闻兼而录之(云云)。此品正说而序文未尽。分别如上。从王舍城下是第三疑念序。文为二。一出人。二明疑。出人为四。一出处。二明位。三出名。四叹德。处如文。菩萨者。菩名道。萨名心。自行此道复能化人。故言摩诃萨。依胜行立胜位也。信相者。信家之相在似道中。别判三十心。圆判铁轮位。下文云。见有一人似婆罗门。以枹击鼓。鼓是法身击是机动。似位机兴知非真击。又真似之位地地相随无位不有。如普贤修普贤行满位邻尊极。此似则高。信相称似道者。未敢判其高下也。难者言。若同普贤言似者。何故有疑。此亦非妨。菩萨为疑者作发起人尔。又佛地未了。疑无所嫌。法华中补处弥勒亦复怀疑。大集中有生疑菩萨。于菩提未了。菩提为我作名名为生疑。难者言。见谛已断疑。十地云何疑。答言。见谛断通疑。十地有别疑也。观解者。心王名王五阴名舍。观此五阴空寂。空寂即涅槃。涅槃能防非御敌呼之为城。初心后心常观涅槃行道。故是住处也。叹德文为二。外供养佛内种善根。此菩萨植善既深。多值诸佛。作高位解释亦应无愧色(云云)。供养有二义。一财供养可解。二法供养。佛说百千法门。随而修学名法供养。观心解者。一念觉了心名为佛。无量功德心资此觉心令转明净。名供养佛。如膏资火。如食益身。如禅发慧。皆供养义也。种善根者。法性名地。观法性智名种子。常以观观名下种。久习不退名种久。五善根生名增长。增长由风动日照雨润。渐增茂好。风譬佛身轮。日譬佛意轮。雨譬佛口轮。值佛三事能大利益。楞严般若若增法性转显。法性若显定慧倍明。植种值佛二义相成。举此一双叹菩萨德也。从是信相下正明疑念序。又为二。初疑之由。次正生疑。由有远近。远由三月唱入涅槃。近由叙述。若有闻者则能思惟无上之义。又云。由乎本誓击动生疑。何因何缘者。通论三种皆名因。而此文既略。缘了相资共能显正。正当于因。缘了当缘。正因常恒寿命无量。缘能显理境常智亦常。此因此缘皆非八十之因缘。今方八十是何因何缘。是故生疑也。方八十者。世寿有三品。下方四十。中方八十。上方百二十。下方少天上方太老。中方不少不老表常。又十二因缘第八名爱支。八十灭者。表爱已尽。入有余无余涅槃。爱尽无缚表我涅槃表乐。又中方表中道。佛乐中道中道表净。为此义故方八十年也。信相不作此解。是故生疑何因何缘也。从复更念言下。是正生疑。如佛所说者。此执教疑理。教诠止行二善。感寿则长。佛昔行因甚多。而今果寿极少。理教相违。不能不惑。若无此理教为虚设。若其必然长寿安在。是为执理而惑教也。有二因缘者。与前为异。前合止行同是缘了。今就止行自作因缘。十善中一一善皆具止行。不杀是止善。放生是行善。不盗是止善。施食是行善。今经举不杀家之止善不盗家之行善。互举一边共明止行。若备论者。一一皆有止行。止之与行须明也。今就一一各有因缘。夫命是众生之所共惜。夺而害之居然大苦。宥而放之则为快乐。慈心是因不畜杀具是缘。此是止善因缘也。夫食是依报。得之则命存。失之则寿殒。施心是因。施具是缘。此行善因缘也。不杀一条既尔。乃至不邪见亦复如是。总有止行二十善四十因缘。此等因缘俱感长寿。佛之止行二善累高于山。积厚于地。云何今日八十而终。此约因果一途论止行二善。但作此解。于义未允。今当更说。人天之因以五戒十善名之为命。三乘行人以智慧为命。魔名杀者。若遮夺此事。即是断人天命。若不遮夺名为止善。方便劝修名为行善。若破坏三藏法。名杀二乘人命。若不毁伤名为止善。方便劝修名为行善。若毁訾事檀乃至毁訾世智。名断六度菩萨命。若不障碍名为止善。方便劝修名为行善。若修体法断贪恚痴是二乘命。若障不令修名断二乘命。若不障者名为止善。方便劝修名为行善。非拨体空则断通教菩萨命。若不障者即是止善。方便劝修即是行善。若毁訾渐次是断别教菩萨命。不作障碍即是止善。方便劝修即是行善。若诽谤圆融即断圆教菩萨命亦断佛命。若不留难即是止善。方便劝修即是行善。圆人非但不坏诸法而随一相。即杀诸法而随一相。如仙豫大王害五百之短命施十劫之长龄。如佛断一切烦恼及习一切无有余。此皆言逆而理顺。非小行者所行。如上所论。一一法皆有止行二善。一一善皆有因缘。若得此意历诸法门浩然若海。故大经云。行檀波罗蜜得寿命长。菩萨行檀则施众生无量寿命。乃至行般若得寿命长。菩萨行般若。则施众生无量寿命。即其义也。而我世尊行无不圆果无不满。云何今日方八十年。次明施食者。百味甘浆等依报食也。身肉骨髓者正报食也。此皆事中施食尔。经言法食。法食者世间法味。出世间法味。出世间上上法味。菩萨能为一切众生作大施主。令未发心者回邪入正。已入正者增长萌芽。如阴阳养卉。如父母鞠子多积缯绵令堕地不痛。授以五戒十善。已持五戒者。说三界火猛多所烧害。赞叹三乘无系解脱。已入证者。毁訾小乘败种焦谷。赞叹菩萨所行之道。设饥国人大王之膳。烦恼为薪智慧为火。以是因缘成涅槃食。令诸弟子皆悉甘嗜。如是等一切法门悉名法食。一一法皆具止行二善。一一善具因具缘。此诸因缘感长寿果。而我世尊行无不圆果无不满。云何今日方八十年。观心不杀者。无明为父贪爱为母。若断此者即成逆害。但观无明即是明爱即是净。体达能所皆如虚空。是为止善。观诸心数亦复如是。是名行善。能如是观获得金刚常住之寿也。己身骨髓血肉者。此彼相望此为己身。智慧推之非己身也。如王子饲虎尸毗贸鸽。皆舍父母遗体非舍己身。己身者法性实相是也。释论云。持戒为皮。禅定为血。智慧为骨。微妙善心为髓。为他说戒。戒能遮罪修福无相最上。非持非犯尸波罗蜜者。是施己皮也。说诸禅定神通变化。不起灭定现诸威仪者。是施己血也。说无著妙慧。非智非愚亡泯清净。终日说终日无说。其所说法皆悉到于一切智地者。是施己骨也。檀忍等应是肉也。说甚深法性诸佛行处不一不二。言语道断心行处灭微妙中道者。是施己髓也。将此充足饥饿众生。况余饮食。余饮食者即是人天二乘戒皮定血慧骨真谛之髓尔。法华云。于余深法中示教利喜者。即其义也。如来往昔随他意说无量无边。随自意说亦无量无边。皆是长寿因缘。云何今日方八十岁也。从大士如是至心念佛思是义时。此一句结前开后。至心者彻到心源尽心实际。故言至心。观心既然观佛亦尔。故言念佛。念佛不杀施食与法性虚空等。如此之寿不应短也。是为结前开后者。由作此观机动瑞兴故言开后也。从其室自然下是第四现瑞序。瑞者密报。相者表发。密报四佛当临此室为尔断疑。表发增进常因感得常果也。问佛作此瑞信相福作。答信相无机佛亦不应。若无诸佛机无所扣。机应相须瑞以之兴。问众缘感瑞信相独感。答通由众缘。别在信相。若瑞在灵山可非其力。室中所见岂不由之。譬张家降瑞。宁得王家受福。虽然信相是发起之人无容独善。法华云。如为一人众多亦然。就文为二。一现相由。二正现相。取结前开后之文为现瑞之由。从其室自然下为正现相也。正现相又二。一别现相。二总现相。从其室自然下是别现相。从举要言之下是总现相。别相为十。表十地因成也。总相为一。表因成一果也。又别相表地地各各增益。总相表一地具诸地功德也。问此经常果为宗。何得作相表因。答此因是果家之因。因必成果不乖宗也。问前判信相是似位。后相则非其征。若似同普贤前相亦非其兆。答一往云十地。一地之中皆有诸地功德表报利益。前后皆沾也。经家不定判位。秖可从容不得克断也。别相有十者。一其室广博。二其地宝严。三妙香氛氲。四高座涌出。五佛座华座。六放大光明。七雨诸天华。八作天妓乐。九皆受天乐。十根缺者具。此之十相表报十地功德。止可斐斖拟议。不得责其备悉。其室自然广博表初欢喜者。此地初开过于凡圣。故以广博表之。严净琉璃间错表离垢地者。此地对戒。戒是诸行基檀。诸行庄严于戒。故以间错表之。香气表明地者。其地对忍唯辱而忍增。如烟多则香盛。故以香表之。高座表炎地者。其地对精进。精进督出众行。故以高座表之。佛坐其上表难胜者。其地对禅。禅有神通转变大力。故以佛表之。光明表现前者。其地对般若。般若洞照故以光明表之。天华表远行者。其地对方便。方便善巧触处严净。故以天华表之。作乐表不动者。其地对力。力能利安一切如妓悦物。故以作妓表之。受乐表善慧者。其地对愿。愿满则心喜。故以受乐表之。根具表法云者。其地对智。因中众行故智慧为首。智导诸行随阶而圆。故以根具表之(云云)。复次十相表一一地中具诸功德。且约初地释之。其室自然广博严事者。此相表初地智也。室者以五阴为室。此阴非阴亦非非阴。不为阴非阴所作。亦不作阴非阴。故言自然。不得阴不得非阴。二边虚豁。故言广博。非直空无二十五有二种涅槃。亦有因中十力无畏种种功德而庄饰之。故言严事。严事即假智。广博即空智。自然即中智。三智一心中具足。是故欢喜。天绀琉璃杂厕间错以成其地者。此相表初地所照境。天绀琉璃莹净明彻。表真谛境。杂厕间错种种庄严。表俗谛境。犹如如来所居净土。至圣所居极尊之地。表中道第一义谛境。一地而三相三相而一地。表一谛而三谛三谛而一谛。有妙香气过诸天香者。此相表初地慈悲功德。慈能与乐如香氛氲。悲能拔苦如香离臭。此慈悲竖高故言过诸天香。此慈悲横阔故言遍满。遍满一切阴界入中。无不溥覆也。其室四面有四高座者。此相表初地四德。四德是秘密之藏。佛住其中。如高座可坐。为坐诸佛也。有四如来者。此相表初地觉四德智。智与德冥如佛坐座也。放大光明者。此相表初地自行化他。照此土表自行。照他土表化他也。雨诸天华者。此相表初地四辩。华雨于空。如辩诠于理也。作天妓乐者。此相表初地四摄。四摄摄物如乐乐他也。受天快乐者。此相表初地法喜。法喜澄神如受天乐。根缺具足者。此相表初地诸根互用。耳见眼闻。一根之中具足诸根之用也。初地功德佛辩所不能宣。略举十相表其梗概尔。初地既然。一一地亦复如是。复次十相表初地自行化他功德。前五相表自行功德。后五相表化他功德。其室广博表自行之般若。天绀琉璃表自行之法身。有妙香气表自行之解脱。高座华衣表自行之因成。佛坐座上表获记成佛也。后五相表化他功德者。放光表意轮益物也。雨华表口轮益物也。作乐表身轮益物也。又表能令众生转烦恼障而受法喜之乐。根具表能令众生转报障也。初地既然。后一一地亦复如是。从一切世间下是总现相也。别相文广意略。总相文略意广。此表十地因成一果究竟具足也。一切者该十法界也。世间者包三世间也。未曾有者因中所无也。悉具现者因圆理显也。国土世间未曾有则实相满。众生世间未曾有则般若满。五阴世间未曾有则解脱满。举要者。实相是要。实相既圆。何法不满邪。从信相欢喜下是第五默念腾疑序。文为二。初见相欢喜。二默念陈疑。欢喜者。既因心疑睹瑞见佛。必知闻法。是故欢喜。从至心念佛下是默念求决也。夫疑情不可久处。是故腾疑。念释迦如来无量功德相好光明神力说法。皆不生疑。唯寿命中心生疑惑。云何佛寿中八十年。念此覆心故默腾求决也。而不发言者。四佛适现。威尊敬重不敢发言。疑既覆心不得不念。又前默念而感瑞。今承前默念以求决尔。从尔时四佛以正遍知下是第六止疑序。文为二。一正止疑。二释止疑。疑盖覆心闻法不解。故先止之。例如见谛先断疑方进修道也。若信相实疑。宜须折止。若是起教因其训人。从汝今不应下正止疑也。云何不应。有三不应。一大用不应。八十者是佛大用。是故不应。二法性海深非言思所测。三以信能入以智能度。汝信智未具。岂度量所思。释论云。无量法欲量。是人为覆溺。故将不应而止之也。何以故下释三不应之意。举八众皆不能量者。释法性不应也。法身菩萨法性净土故不在言。生身菩萨若在家。为天龙等所摄。若出家为四众所摄。若法性身施权。亦为八众所摄。若凡若圣悉不能思算也。唯除如来者。释智度不应也。若如如来是则能知。既未如如来。那忽能知。旧用此语为智所知。知是无常可量之法。天台师云。不尔。如来有无量常智。能知无量常法。岂可以常智所知判为无常邪。智性既冥大用可解。是释三不应也。从时四如来下是第七集众序。余经或先集众后现瑞。此经先现瑞后集众。前后互出。尔时者将欲宣畅之时也。众者欲色界诸天也。信相一人利益者少。有缘若集所益处多。是故集众。众有四种。一发起众。信相树神等是也。二当机众。闻即得道者是也。三影响众。从十方远来者是也。四结缘众。当座虽未得道。作后世因缘者是也。如流水为鱼说法。远作今日得悟因缘。即其事也。此经集天龙众。与华严意同。亦集人众而文略。新本中有无量百千婆罗门众。忏悔品初信相及眷属诸耆阇崛山。即是人众也。相承云。此经与冥道相关。正集天龙略不说人尔。总瑞中云。一切世间未曾有事悉具出现。不见与二乘记。但明帝辨性。与般若方等意同。故判属方等教摄。此中应论乘戒缓急四句。判出天龙生处。得道不得道。权实等事。如别记(云云)。齐此判属序段者文云。将欲宣畅大众云集。岂非序之明证邪。序分竟。从尔时四佛下三品半文是第二正说段。凡三说不同。一云。寿量明常果为宗。常果契性性即是体。二义宛然不须多惑。下忏悔品灭恶。赞叹品生善。空品导成。即是经用也。二云。寿量明宗。忏叹明用。空品明体。此乃以因中所用之性为果上所显之体。于义不便。故不用之。三三藏云。正说有两段。寿量是果段。三身是因段。二文各有序。虚空藏问为因段序。直是发问于序义弱。师云。三身成果上义非因义也。是故不用。初家所说好与今意同。新旧两文凡三处明宗。初是四佛拂疑。明应化之寿非思算所知。迹既长远本难穷极。上根人闻迹悟本也。若未悟者。王子明。蚊蚋脚可以作城楼。鼠登兔角梯食月除修罗。明法身无舍利。如来真实身舍利无是处。中根人直无理本而悟迹也。若未悟者。释迦论三身共说广分别之。本迹俱解。是为三番明宗显体。忏品别论灭恶通亦生善。叹品别论生善通亦灭恶。空品导成。俱是经用也。今之四卷止有一番明宗。文为四。初四佛说偈。二信相欢喜。三当机得道。四四佛还本。说偈又二。一经家叙。二四佛喻说。问四佛说偈为各为共。答经既无文不可定判。或宜闻共说异口同音。或宜闻别说。各引一喻。见亦如是。若见四佛同尊特身。一身一智慧者即是常身。弟子众一故。若见四佛佛身不同。即是应化。弟子众多故。分八偈为二意。初云。前四偈立譬。次一偈合譬。次二偈断疑。次一偈结释。次云。前四偈为譬本。后四偈合释。两途俱可用。旧云。四偈止譬其寿长。更无别意。是义不然。诸佛之教上中下善。其言巧妙其义深远。此中正是常宗断疑。一经之要处何容无义。且作三意消文。一对四谛。二对四念处。三对四德。四谛理通因果。四念论因。四德论果。若论果寿宜对四德。果不孤起故念处明因。因果有本故对四谛也。上以四佛对四谛智。今以四佛所说对四谛理。旧读四谛文云。知苦如苦相。知集如集相。相是其事。齐事而知。于理不显。今明。知苦如苦相。如是其理相是其事。即事而真事理双达。余三谛亦如是。如是释者于四谛理义便也。又一解。知苦是知俗。如是知真。相是知中。中是实相。故今以相为中也。此则三谛具在一文。知苦既然下集道灭亦如是(云云)。明识四谛是修长寿境。故约四谛对偈也。一切诸水者此对集谛。大经云。有河洄澓没众生。即其义也。水体润生如集能资长。鼓怒浩浣无处不有。集亦如是。没溺凡圣亘界内外也。诸须弥山者此对苦谛。小般若以身为须弥。即其义也。山体结构磐峙水上。如苦报积聚为集作果系缚界内外色心也。大地微尘者此对道谛。法华云。其所说法皆悉到于一切智地。即其义也。地体能容载水陆两途。如通别道到此彼岸。虚空分界者此对灭谛。法华云。常寂灭相终归于空。即其义也。空体尽净。五翳所不能染。三光所不能净。如灭谛灭无二十五有及灭化城涅槃也。四谛理遍一切处即法身。四谛智称境而知即报身。从体起用同其长短即应身。信相但见应短不见应长。应尚不达。宁知报法。四佛举四喻喻其应长。水滴山斤地尘空界尚无能思算得其边表。况复智冥于法。渊哉玄哉。信无底际。旷矣大矣。岂有垠涯。举应迹以释报法。豁然明悟。断疑之巧为若此也。释此偈妙为若此也。行者思之思之。四偈对四念处者。念处之观本在苦谛。唯应约须弥山偈而论。今则通对也。一切诸水对受念处。受能含纳如海多容故也。须弥山对身念处。色相与质碍相类故也。大地对于想行念处。想取行行如地容载故也。空界对心念处。心但有名如空无相故也。若观四念处是修长寿因。若念处得道即是长寿果。故用念处对四偈也。若观四枯念处。破凡夫之四倒。若观四荣念处。破二乘之四倒。若观中道念处则非荣非枯。于其中间而般涅槃。成五种解脱。谓色解脱乃至识解脱。脱五阴缚名五解脱。洞达五阴空无所有名五般若。冥五阴现名五法身。虽三分别。不一不异不纵不横名秘密藏。号大涅槃。仁王呼为法性色法性受想行识。阴之法性即是法身。智冥法性即是报身。法报皆非常非无常。而能起用为常为无常。常用则长无常用则短。信相但见无常不能见常。于用未达。况解其本。四佛举喻明其用常。迹常无边非思算所得。况复体理宁可心知。信相迷除豁如云卷。断疑之巧为若此也。四偈对四德者。水润生荣对常德。山能高出对我德。碎地为尘对净德。空无苦受对乐德。四德成就是果上所克。果与理冥。冥于非常非无常。能起常无常用。冥于非我非无我。起我无我用。冥于非净非不净。起净不净用。冥于非乐非不乐。起于乐无乐用。信相但见无常无乐不见常乐。于应尚迷。何能识本。四佛举四德之用非思算所知。体本报法杳然虑外。信相闻说非但疑除惑断。增信生解。故欢喜踊跃得之于怀(云云)。亿百千万下合譬偈也。旧解有二失。一僻取文。二偏执义。旧云。四譬皆有齐畔可尽之物。百千是数法。数必有穷。据此为无常。今释不尔。四佛引四譬者。乃是举量以况无量。量物尚非思算所知。无量之法宁可图度。亿百千万此举数法以明无数法。既不能数数。那能知无数。纵令知数知无数。知量知无量者。秖是化用都不关体本。僻取之失非但自毁。又亦诬经。偏执义者。三身品云。化身亦常。处处说法。是故为常。当知化身备有常无常义。旧人那忽一向无常(云云)。以是因缘下两行断疑偈也。若作因缘者。因亲缘疏。命是正报。不杀为因。食是依报。施之为缘。以此因缘得寿命长。若作二缘者。不杀是不杀戒家止善。施食是不盗戒家行善。互举止行俱是二缘。法性菩提心名之为因。止行福慧等并皆是缘。缘能显性。会非常非无常。能常能无常。法食不杀等皆如上说。修因既长得果又长。显体又长起用又长。破其短疑也。是故汝今下一偈结成也。尔时信相下闻偈断疑生信也。闻寿命无量者。解迹中之能常其寿无量也。疑去者。解迹中之能短。其寿八十也。深心信解者。悟其本识非量非无量也。踊跃者登位也。欢喜者信生也。别教释者。信相似位中疑惑去登欢喜地中信生也。圆教释者。信相铁轮位中疑惑去入住铜轮位中欢喜也。若作普贤似位释者。下地中疑惑去。十地顶深信坚固。犹若金刚。邻真接极而生欢喜也。从说是如来下是第三当机上根初悟之。从时四如来下第四息化也。佛本为缘兴。缘已利益则摄化还本。故言忽然不现也。观解者。谛境发智觉慧相应。深观此慧亦不得慧。亦不见境。境智俱寂即是不境义也(云云)。

金光明经文句卷第二金光明经文句卷第三

        隋天台智者大师说

        门人灌顶录

    释忏悔品

诸大乘经多分散明忏悔。此经专以忏悔当品。今先释名。忏者首也。悔者伏也。如世人得罪于王。伏款顺从不敢违逆。不逆为伏顺从为首。行人亦尔。伏三宝足下正顺道理。不敢作非。故名忏悔。又忏名白法悔名黑法。黑法须悔而勿作。白法须企而尚之。取舍合论故言忏悔。又忏名修来悔名改往。往日所作恶不善法鄙而恶之。故名为悔。往日所弃一切善法今日已去誓愿勤修故名为忏。弃往求来故名忏悔。又忏名披陈众失发露过咎不敢隐讳。悔名断相续心厌悔舍离。能作所作合弃故言忏悔。又忏者名惭悔者名愧。惭则惭天愧则愧人。人见其显天见其冥。冥细显粗。粗细皆恶故言忏悔。又人是贤人天是圣人。不逮贤圣之流。是故忏悔。又贤圣俱是人天。是第一义天。第一义天是理。贤圣是事。不逮事理俱皆忏悔。又惭三乘之圣天愧三乘之贤人。不逮此天人故名惭愧。惭愧名忏悔。又三乘贤圣皆是人。第一义理为天。约此人天惭愧故名忏悔。又三乘贤圣尚非菩萨之贤。况菩萨之圣。今惭愧三十心之贤十地之圣。故名惭愧忏悔。总此贤圣皆是人。第一义理名为天。约此人天论惭愧。故名忏悔。又三十心去自判圣人。十信是贤人。约此贤圣论惭愧忏悔。总此贤圣皆名人。第一义理名为天。约此人天论惭愧忏悔。合十番释名也。次明忏悔处者。大经阇王偈云。粗言及软语皆归第一义。是故我今日归依于世尊。又梵行品云。我昔与汝等不见四真谛。是故久流转生死大苦海。若能见四谛。则得断生死。生死既尽已。则不受诸有。法华云。行处近处住忍辱地。亦不行不分别。又云。宝处在近。汝可前进。即灭化城即至宝所。此经云。我当为是作归依处。归依处者。即甚深无量法性也。法性秖是谛理。谛理秖是妙境。诸佛所师寂灭真如秘密之藏。十方众圣安住其中。若得其本本立则道生。不得其处则平地颠坠。如盲人入棘林。动转挂碍。为是义故须识忏悔处也。故普贤观云。端坐念实相。众罪如霜露。慧日能消除。我心自空罪福无主。是名大忏悔。是名庄严忏悔。是名无罪相忏悔。无罪相者。此约空为处也。庄严忏悔者。约俗谛为处也。大忏悔者。约中道为处也。若三种差别者。此是历别论处尔。即一而三即三而一者。此圆妙忏悔也。诸大菩萨修学佛法而忏悔也。若识此法而忏悔者。最妙最上忏悔处也。大经云。譬如有人在大海浴。当知是人已用一切诸河之水。大品云。譬如负债人依投于王。债主反更供养。何敢就其觅物。书云。如墙头草非其茎叶能高能长所依得处也。行人若依法性为忏悔处者。高出一切诸处所也。行人若识此意。先当求觅法性道理为忏悔处也。次明忏悔法者。法为二种。一正法。二助法。正法者。即是观法性之慧也。法性常故是观亦常。法性乐我净故观慧亦尔。法性不可思议。至深至妙无上无等等者。观慧亦尔。境智相冥无二之法。如如不异者。境如智智如境。故言如如不异也。经言。说智及智处。皆名为般若。说智及智处。皆名为实相。说如不说不说如说。说不说无二无别。以此观慧历一切法亦复如是。故云毗卢遮那遍一切处。若行若住若明若闇皆得不离见佛世尊。六根所对无非佛法。耆婆揽草无非药者。普能愈病。释摩男所执。一切砂砾皆变为宝。阿那律空器悉满甘露。若如是者。所观之罪非复是罪。罪即实相。所观之福福即非福。福即实相。纯是实相。是名大忏悔也。助道忏悔者。若纯用正忏亦不须助。若正道闇昧不明了者。修助以助之。所谓灰汁澡豆皂荚木患以助清水尔。略言勤用身口意而为助也。身谓旋礼。口谓读诵。心谓策观。而助开门。如顺流顺风助之以篙棹去则疾也。如是略论正助也。四明忏悔位者。若作一种解者谓。鄙浊凡夫应须忏悔。离垢清净者何用忏悔。此不如是故新本业障灭品中说。人从父母禀身。十月怀抱三年鞠养。抚念惟惟始能升头戴发。教方教数始解作人。那忽违恩背义而行杀逆。天虽大不覆此人。地虽厚不载此人。此人命终直入地狱。如是逆罪应须忏悔灭除业障。佛为人天师。师严道尊。凡有所说若有违犯罪莫大焉。初篇后聚那可违负。尔则欺佛负心。复负三师七僧。此则佛海死尸华园烂肉。此四重人应须忏悔灭除业障。多嗔堕蛇虺。多欲堕鸠鸽。多痴堕虱蚁。多慢堕飞鸟。多谄堕修罗。外悭堕饿鬼。饿鬼常饥渴。畜生相残害。修罗多怖畏。是四恶道闻名尚不可。况复当之。应须忏悔灭除业障。人中八苦一苦尚不可忍。况八苦交横。应当忏悔灭除业障。天上有五衰地狱等苦。色界天不得速入定。求不得苦。无色界天有四心苦。三界笼樊生死窟宅。应须忏悔灭除业障。若出家人虽欲修道为五烦恼所障。心不得停心。为四颠倒所惑。不得入四念处。亦须忏悔除灭业障。念处治彼四倒。二恶不勤断二善不勤生。不得入如意足。暖法不发。亦须忏悔。五根不生。喜有退堕。根生未有力。虽有力未邻真如。是四善根中应须忏悔灭除业障。苦忍明发虽不堕三途。欲界七生次第应受。一生尚苦。何况七生。虽断欲界五下分六品。余三品在。亦应忏悔。虽断五下八品尽余一品在。虽断色尽余无色分在。亦须忏悔。虽入有余涅槃犹有果身在。身子风热毕陵伽眼痛。欲弃有余入无余。亦须忏悔。虽断三界正使尽习气尚存。亦须忏悔。支佛亦尔。亦须忏悔。若干慧地未得理水沾心。故言干慧。性地未能见理。八人见地犹有爱惑。薄地神通未能还生欲界。离欲地犹有上界惑。已办地不能除习。辟支佛地但作神通。不能达文字。菩萨地未穷至极。如是等位皆须忏悔灭除业障。十信但信未能称理。十住但入偏理。十行但事未能入中。十回向但修中未能证中。十地虽证中地地皆有障。未穷于学不得无学。应须忏悔灭除业障。又十信虽三智圆修。但是方便陀罗尼。十住已去乃至等觉已来。秖如十四日月。非十五日月。匡郭未圆光未顿足。闇未顿尽。应须忏悔灭除业障。齐此已来当知忏悔位长其义极广。云何而言止齐凡夫。是故五十校计经。齐至等觉皆令忏悔。即其义也。若人得闻如此忏悔功德不少。故文云。非于一佛五佛十佛修诸功德闻是忏悔。乃于无量百千佛所修诸功德。闻是忏悔。语其华报。在在处处。常为国王辅相大臣之所恭敬。语其果报。常为十方诸佛互相恭敬。直闻此忏悔。尚得如此功德。况复如法修行。已闻忏悔义。此法从经出。此经从佛说。是故当报恩归命礼诸佛(云云)。忏悔品依字训释。忏者鉴也。披陈发舒己之三业。不敢隐讳令他委鉴。颜恧而口蹙。心摧而意伏。身被鉴故而颜恧。口被鉴故而唇蹙。心被鉴故而意伏。故忏名鉴也。悔者废也。内怀鄙耻悔造众非。悔身故则三废。悔口故则四废。悔心故则十废。故悔名废也。又法门释者。忏悔名惭愧。惭愧是白法。又自不作恶。不教他作恶。如是等种种说。忏悔有三。一作法。二取相。三无生。此三种通大小。小乘作法者。如毗尼中发露与学二十僧行摩那埵。或半月作法。或对首作法。或责心但令作法成就。不障僧事即清净也。阿含中亦作相忏。犯欲人作毒蛇口想。此观成时淫罪即灭。亦有观空忏。秖是真空。大乘中亦有作法。或八百日。虚空藏涂厕是也。或九十日。般舟是也。或四十九日。大悲忏是也。或二十一日。法华是也。或七日。方等是也。灰汤澡豆净身。辛酒禁口惭愧勤心。旋诵各有遍数等。皆作法忏摄也。取相忏者。如方等求十二梦王菩萨戒见华光摩顶虚空藏中唱声印臂相起罪灭。虽不正明作法。兼得事用也。无生忏者。如普贤观云。端坐念实相。如日照霜露。观空缘理无相最上。虽不正作事相。兼上两忏也。作法忏成违无作罪灭。而性罪不除。如犯杀生。作法忏成违无作罪去。而偿命犹在。即其义也。取相忏能灭性罪。性罪去违无作罪亦去。如伐树枝叶萎。根本未去续生如故也。观无生忏能灭无明。如覆大地。根枝叶等悉尽无余。又作法灭违戒上罪。取相灭犯定上罪。无生灭犯慧上罪。又作法灭三恶道报障。取相灭人道报障。无生灭三界有漏报障。又作法灭三恶道业障。取相灭人道业障。无生灭三界有漏业障。又作法灭怖畏忧愁之烦恼。亦是破烦恼。取相灭四住之烦恼。无生灭无明之烦恼。又三种忏共除报障。取相除业障。无生除烦恼障。又作法忏如服姜桂。差病而已不能肥身。譬罪灭不能生善。取相忏如服五石。病差身充。不能得道。无生忏如服五芝。病除身飞升仙得道。如是等种种分别行者须知。今文具有大乘三忏。着净洁衣专听是经。又七日七夜朝暮净心等即作法也。于其坐处得见弥勒文殊普贤。即取相也。五阴舍宅观悉空寂。本无有生亦无和合。即无生也。三意宛然。故能灭诸恶荡五障。显经力用也。从此品下明经力用。今品正明夜梦昼说忏悔断恶拔苦。下品正明昔叹发誓生善与乐。旁正互举。此品文为二。初梦中见闻。二觉已说见闻。梦又二。一梦见金鼓。二梦击鼓声。见鼓又三。一正见鼓。二见鼓光。三见光中佛。梦者是入如梦三昧也。又入观如梦出观如觉。入观心静能观法性。法性即金鼓。金鼓体圆空鸣。圆即法身。空即般若。鸣即解脱。姝者胜义深义。大者广义无量义。如上文游于无量甚深法性意尔。姝大略叙鼓体。委论应言圆姝大空姝大鸣姝大。鼓体备三种。三种皆甚深无量。此即梦中所睹法身。观一而见三佛也。从其明溥照下是第二见鼓光也。光是智慧。契此法性克成大果。智与体冥。体圆姝大光圆亦姝大。体空姝大光空亦姝大。体鸣既姝大光鸣亦姝大。何者。此身与诸佛同体同意故也。即此梦中所睹报身佛一佛而三也。从复于光中见十方佛下是第三见光中诸佛也。光从鼓出遍照十方。用从体起应周法界。与机缘同事也。琉璃座者所安之理也。佛坐其上智称法性也。大众围绕者所应之机也。此即梦中所睹应佛即一而论三也。睹此三佛即是三身三德种种三法门从此设教名金光明也。从见有一人下是第二梦见击鼓。文为三。一见击鼓。二出大音声。三声所诠辩。鼓是法身击是机智。婆罗门是净行。似是邻真。邻真之人以似解之净智和会法身。甘露相应灭苦生乐。鼓是法身。枹鼓合是报身。击出是应身。声所诠辩是法界大用起教利益众生。从时信相菩萨下是第二觉已说见闻。文为四。一往佛所。二与缘俱。三伸敬。四述梦。梦者入法门为夜梦。出法门如过夜至旦。又三十心惑障未遣故如梦。登地断惑如过夜至旦。观解者。观行位中所观三身如梦。分真位中所观三身如旦。出王舍城者表出因位也。往耆阇崛山者表向果地也。伸敬有三。顶礼是身敬。瞻仰是意敬。说梦是口敬。顶礼者。菩萨居因信首为贵。诸佛在果慈悲为贱。以贵敬贱也。从以其梦中下是第四述梦也。此下总有一百六十二行偈。分为二。初四行半总明梦。后一百五十七行半别明梦。总又为二。初三行半明见金鼓。后一行明见击鼓。见鼓又三。初一行见鼓形状。次一行见鼓光明。次一行半见光中诸佛。即长行中三身意入观所观之境也。次一行见击鼓者。自睹其观智之机扣击法身之境也。出大音声者。已如上说。自睹其境智合能多利益也。从是大金鼓下一百五十七行半偈别明梦事。文为二。初从是大金鼓下至悉能灭除有二十一行三句。明金鼓有灭恶生善之力。二从一切诸苦无依无归下一百三十五行三句正明教诏忏悔之法。就能灭恶生善文为六。一有三行。灭世间因果之苦。二有三行。生出世间因果之乐。三有四行。能令众生自行化他俱备。四有四行。能灭众生报障。又发宿命通。五有四行。能令众生得诸法门。先少得后多得(云云)。六有三行三句。能破众生八难流转。释此六义皆从三涂。渐至人天二乘菩萨等。一一皆有破恶生善之力。从一切诸苦无依无归下有一百三十五行三句。是第二明教诏忏悔之法。文为五。一从一切诸苦下有十九行一句。教自说过罪忏悔。二从我当供养下有三十五行。明供养诸佛自行化他修忏悔。三从诸佛世尊我所依止下有二十一行。明称叹修忏悔。四从我以善业诸因缘故下有五十一行半。明发愿修忏悔。五从若有敬礼称叹十力下有九行。结成忏悔。生起五意者。但众生邪倒障理不识法性。愚痴障解不识因果。恶业障行不识善法。圣人慈悲因大士之梦。示其忏悔示其道理。示其因果示其善行。故论自忏荷佛恩深故伸供养。供养不泄其诚故歌咏称叹。供养是行须愿指归。行愿既圆结成赞美也。自忏文为三。初一行一句明法身是依凭之所。次两行请佛覆护。次十六行正明忏悔。夫法身具三德。即是一体三宝。法性是法宝。寂而常照是佛宝。遍一切处是僧宝。自凡夫二乘虽不知。亦不出法性。总而言之。一切菩萨何尝不以此为归依。依此则本立而道生也。内本虽立外无佛加不得成就。若蒙拥护断恶生善。办在斯须。如萌芽得雨扶疏丰郁。是故请佛也。内外因缘既备正须忏悔也。正忏文为二。初三句总明忏悔。后十五行一句别明忏悔。总忏者总忏三障也。本者烦恼是二障本也。恶者报障也。不善者业障也。三障障三身三佛三宝。三障若转诸三法门悉明。故总忏也。别忏者别忏三障也。文为三。初一行一句忏烦恼障。次一行忏报障。次十三行忏业障。诸十力前者。正忏烦恼障也。独头无明痴倒殊甚。不识法身佛也。法身佛遍一切处。痴闇不知。公于佛前造作众罪。如牛羊不识天子。如鸟雀不识檠像。于前造过。愚痴不识法身亦复如是。父母恩者。方便是父智度是母。此二法门能生法身。而不识者。是不知报佛也。不解善法者。善法是助道之行。能资智显理。而不解者是不识应佛。三佛皆不能知。岂非无明过患。此别忏烦恼障也。自恃种姓下别忏报障也。略言有三种。一以姓傲他。二以财忽物。三以壮年陵彼。虽报有此三不应自恣。若纵恣者此报成障事也。今更约法门解。出家人以慧为姓。定为财戒为年。染此三法自尊卑他者。是名染法非求法也。法华云。汝年少壮我年衰迈者。凡人以五阴盛为壮。二乘通教以空出有为壮。别教菩萨以法眼过慧眼为壮。着此诸法者。悉是恃强陵弱成报障也。悉须忏悔。从心念不善下十三行别忏业障。文为十二。初一行忏由心口造恶业。亦是教他作恶也。从身口意是自作恶也。二一行忏内外因缘造恶业。三一行忏五欲因缘造恶业。四一行信受邪师造恶业。五一行随顺恶主造恶业。六一行爱心所使造恶业。七二行为衣食女色造恶业。八一行于佛世敬田造恶业。九一行于无佛世敬田造恶业。十两句于正法造恶业。十一一行于恩田造恶业。十二一行半总一切处造恶业。造业因缘甚多。不可具列故总而忏之。若欲细释从人道为始。二乘通别菩萨等行一一作之例应可解。故五十校计经云。上至等觉皆须忏悔。即其义也。从我今供养下三十五行明供养诸佛。所以供养者。我本痴盲蒙示忏悔。此恩深重故兴供养。文为二。初一行明财供养。后三十四行明法供养。法供养为二。初八行半明化他法供养。随顺如来慈悲法门。济利含识。是为化他修法供养。后二十五行半明自行法供养。随顺如来智慧法门。修十地功德。是为自行修法供养。诸供养中法供养最为第一。财供法供事理自他皆悉具足也。化他法供养文为二。初四行化他令其修行。后四行半化他令修忏悔。初修行者。我自行十地为法供养。今复化人令法供养。譬如一灯然百千灯。瞑者皆明明终不尽。其意有四。初明化始以大悲拔苦。次劝真因十地之行。次劝真果菩提大觉。次劝精进督使速成。夫众生等故性欲亦等。善巧度一众多亦然。不计劬劳积行累德。功成大觉。即智德满。尽一切苦即断德满。文自明显不俟多释。观心者。调一念心。使真明发任运成真果。调一切心数亦复如是。弟子众尘劳随意之所转。即此义也。次四行半化他令修忏者。我蒙佛教忏。还以忏教他。重重然无尽灯。化化不绝也。文为三意。初欲为说忏。次正为说忏。三说忏已。千劫者。假多以显忏力大尔。譬如恶人造罪山积能拔于王难。尚分半国偿。岂复问其前愆。说千劫造逆。虽复厚重能拔法性之王。从如来藏中显成法身者。大觉朗然超升自在。宁复为五无间业之所缚邪。从我当安止下二十五行半自修法供养。文为二。初五行自修行。后二十行半自修忏。前自忏竟。今那复重。譬如金师。从初习学至于皓首。互烧互打器成方息。修行譬智烧。修忏譬断打。智断极乃止。重说无咎。前是自行门。今是法供养门为异也。自修行又为三。初一句标章。我当安止是也。次修因。十地是也。次成果菩提是也。珍宝者。十地因可贵。诸地即是珍宝也。脚足者。十地是果家之基本。故言脚足。又十度是十地之脚足。于余功德非为不修。随力随分正以檀为初地之足。檀足若满得入初地。乃至智度足满得入十地。故十度为十地脚足也。果中有总明果满别明果满。在文可知。功德光明者。是果上二种庄严也。令众生度海者。即果上转法轮也。从诸佛世尊下二十行半明自修忏。文为二。初一行请佛。后十九行半明忏。文为五。初四行半忏报障。次一行半忏烦恼障。次六行忏业障。次两行明回向。次五行半忏善恶两难。就报障文又二。初二行半出报障相。次二行请除灭。百劫者受报之时也。时中受身。身即是报。报有所作。作即是障。贫穷困苦是依报不圆。亦是报障也。愁热惊惧者。由贫穷外逼故惊惧内焦皆报障也。所作众恶者。即想行阴苦也。贫穷困苦者。即色阴苦也。愁热惊惧心常怯劣者。即识阴苦也。暂无欢乐者。即受阴苦也。此皆报障意尔。次烦恼障文为二。初两句出相。次一行乞清净。次业障文为三。初二行竖论三世造业。次二行横明现起十恶。次二行求忏过去业。今正受者名为报障。未受者系属行人。若修善道能为障碍。问过现须忏。未来未有。云何言忏。答数家呼为未来有。论家呼为当有。大经云。遮未来故名之为杀。现在念念灭何所可杀。秖遮断未来名为杀尔。经论悉以未来为有。故须忏也。今更举现事例之。如在家人昼度生方起无量恶念。事虽未有次第必更。忽然发心舍家修道。前所念事并与缘差。未来之业亦应如此。虽非现有时到必然。今若忏悔索然清净。横开现世三业为十恶可解。远离者恶断也。修行者善生也。十住者初心因位也。逮十力者后果满也。次明回向者。众生顽故爱着于有不能升出。今忏此罪故云回向。他以若此国土及余世界为随喜之文。今意不尔。此土他方凡所作善。皆施众生共向佛果。如声入角则能远闻。方便力大与虚空等。又结文云。是回向不得作随喜。释随喜在下文也。释八难者。此是善恶中论八难。非佛前佛后之八难。文为二。初四行指恶为难。次一行半指恶遮善为难。或指善遮道为难。初四句是报障难。诸有者二十五有。报得之身造作众恶。岂非报障。生死险难有二解。若取其因即是业障。若取其果即是报障。种种淫欲即烦恼障。心轻躁者复是报障。轻躁是觉观。觉观属报法。如罗汉断烦恼尽。出观犹有觉观散心。当知轻躁是报障非烦恼也。更举世人学问回转易辙不成业障皆由轻躁之过。岂非障邪近恶友难者。恶友能污染人三业。此属业障。如移厩于屠边。如孟母邻于哭货。朱赤墨黑。即其义也。三毒是烦恼障也。遇无难难下此有二义。一若不修善。障难不兴。若欲修善。恶障即起。善非是障。恶来遮善。名善为难。此义易知。常人皆作此解也。二者诸善是难。善能障道。岂非难邪。此义今当说。遇无难难者。自谓无恶不肯修善。如二乘入空生灭度想生安隐想不复进求菩提。即其义也。修功德难者。多作有为求可意果。如一比丘专行福德不修禁戒。堕白象中。七宝络身金盂承粪。又如妙庄严王本事等。岂非修功德难。值好时难者。如劫初时在郁单越时一向受乐都不修道。岂非值好时难。值佛亦难者。如旃遮婆罗门女善星调达等。皆是值佛而难。例此应云。闻法起谤值僧起破皆是难也。若读作难易之难者。此是恶来遮善之义。使善难成也。若读作障难之难者。此是善自是难。能障于道。又依经文云。如是诸难今悉忏悔。当知经作障难之难义也。从诸佛世尊我所依止下二十一行偈是第三称叹。若论次第。前财法供养是身意。身意未泄未备。今更口叹。若作法门者。前是供养法门。今是念佛三昧法门。文为三。初一行标章叹。次十九行正叹。三一行结叹。标诸佛者。横则十方竖则三世。事即报应理即法身。言略而意广。标章之巧妙也。我所依止者。依止法性一体三佛也。佛海者。四眼入佛眼。十智入如实智。皆失本名字但名佛眼佛智。如物投石蜜如流会海。无不甘碱者。法性三佛摄一切法。故名佛海也。就正叹为二。初十六行寄言叹。后三行绝言叹。寄言又二。初一行略叹略况。次十五行广叹广况。略叹者。诸相好中略叹金色。释论以即时铁比即时金。即时金比海金。海金比龙金。龙金比阎浮洲金。阎浮洲金比四天王金。如是转转比第六天金。第六天金比佛身金色。第六天金如铁。又佛金光彻照壁障无影。佛入城时放光照地。一女人低头礼拜。金钗堕地。唯见晃晃。不知何者是地何者是钗。佛过后光歇方见金钗尔。然金色身是众相所依处。唯举金色。故知是总叹众相好也。金有四义。坚不可毁譬常。得之者富譬乐。体无瑕秽譬净。色妙晃曜譬我。诸德之中四德为总。犹如须弥者。须弥为四宝所成。况佛身具足四德。故知总况也。广叹广况文为二。初十二行半广叹。次二行半广况。广叹又四。从其色无上下二行广叹金色无上。无上者我德也。从善净无垢下三行广叹佛色无垢。无垢者净德也。从功德巍巍下三行半广叹佛色安住。安住者常德也。从三有之中下四行广叹佛色能除苦毒。即乐德也。从如大海水下二行半广况。文为二。初二行广况。二半行合喻。佛功德海思所不能知言所不能尽。心行处灭言语道断。即此义也。海水难知况常德也。地尘难知。况净德也。山斤难知况我德也。空边难知。况乐德也。诸佛亦尔下合喻也。从一切有心下三行绝言叹也。文为二。初一行半正绝言叹。二一行半牒譬帖合。一切有心不能得知。即是绝思。思既已绝口何所宣。即绝言也。更牒譬帖合。在文可见。从相好庄严下一行总结。相者结一切相。好者结一切好。庄严者一一相一一好中皆具众德以为庄严也。从我以善业诸因缘故下有五十一行半偈。是第四发愿行若无愿。如牛无御。不能有所至。如画无胶如坏未火如水中月。故以愿持行。亦是忏悔退转之罪也。文为二。初有四十七行半明发愿。次四行约愿随喜。初愿又二。初九行自发愿。次三十八行半为他发愿。自愿又二。初四行愿果满。次五行愿因圆。果满愿又四。初一行成佛道是愿意轮满。次一行说法是愿口轮满。次一行摧魔是愿身轮满。次一行住寿久益是愿慈悲满。因圆愿又四。初一行具六度愿有为功德圆。次一行愿无为功德圆。次二行宿命念佛圆。次一行值佛圆。为他发愿文为二。前八行半愿作药树王身大悲拔苦。后三十行愿作宝珠王身大慈与乐。拔苦又为四。初一行总拔众苦。次一行拔根不具苦。次两行拔病苦。次四行半拔王难苦。与乐又为三。初十六行半与世间果乐。次九行半与出世因乐。后四行结成。上文大悲拔苦根不具者令具。今大慈与乐。视听聪明畅悦快乐。诸根语同与拔小异也。从愿诸众生常得供养下九行半与出世因乐。文为二。初三行半令修行外缘具。次六行令修行内因具。外缘又二。初二行值三宝。二一行半离八难。人缘不同。或值佛难不除。或难除不值佛。今愿其亦除亦值。内因又二。一半行生尊贵家。二五行半多饶财宝。人因不同。或多财而卑贱。或尊贵而贫穷。因不具足。今令其亦贵亦富。女有五碍。愿其无五碍苦。从若我现在下四行结成自他誓愿也。前二行结自。后二行结他。从若此阎浮下四行约愿随喜。随喜者庆他修善也。亦是忏悔疾妒之罪也。文为二。初二行随喜于他。后二行随喜于自。从若有敬礼下有九行偈。是第五结成。文为三。初二行结成断恶。故言超六十劫罪。次四行半结成生善。故言国王大臣之所恭敬。次二行半结值佛多。虽不别说善知识佛。自兼之

    释赞叹品

赞叹凡有四意。一从能赞人。二从生善。三从灭恶。四从所赞人。一从能赞人者。前品明信相思疑佛寿。四尊尽降其室。一心信解。夜梦金鼓出声。旦向耆山说梦。今品佛述其昔为龙尊面赞法王。愿我当来夜梦昼说。说斯人之本事故言赞叹品。二从生善得名者。夫善不孤运。生必托缘。缘中胜者无过于佛。龙尊赞佛能生妙善。从生善缘得名。故言赞叹品。三从灭恶得名者。罪之尤者无过毁佛。若翻灭斯罪应须赞叹。赞叹治于毁訾。从能治得名故言赞叹品。四从所赞人得名者。即是去来现在三世诸佛。诸佛极尊甚深。无量称扬显说。故名赞叹品。若欲分别。述得名为赞。褒喻名为叹。亦更互分别尔。释论第三十云。美其功德名为赞。赞之不足又称扬之名为叹也。此品有恭敬是身业。尊重是意业。赞叹是口业。口业不发身意不畅。为畅身意音声为佛事。故称扬显说。褒美如来真实功德。故言赞叹品也。结此四义。都是四悉檀因缘立此品名。故言赞叹品也。此品虽从四悉檀立名。正是生善之用。文为二。一长行。二偈颂。而对告地神者。主此大地。菩萨行行皆寄其上。寿命长久见去来今事。证义事强。如瑞应云。积功累德谁为证。佛时指地。是知我。今说往昔金龙尊事。所以对告地神也。又对善女天者。男天阳表权。女天阴表实。实智能生众善。善生故宜对善女。证往故宜对坚牢(云云)。今论生善之用。故对告善女。金龙尊者。此王往昔修金光明法门。依法性理故言金。能以智慧赞三世佛。辩如云雨故言龙。能为众生作大利益。为物所仰故言尊。从行得名故言金龙尊也。总有六十二行半偈文为三。一三十五行赞三世佛。二二十五行半发来世愿。三二行结会二世事。就赞佛文为五。初一行半总赞。次二十三行别赞。次三行遍类赞。次五行半绝言赞。次二行回向。总赞者。竖总三世横总十方。世方是总是。微妙寂灭是总理。总理是总法身。总事是总报应二身。总赞三身。亦是总赞三德三宝等种种三法门。如是诸佛总皆清净。清净者。即是总赞之辞也。非但清净亦常乐我(云云)。从色中上色下二十三行是历相别赞。其文间出分为六意。初六行半赞七大相海。亦赞发绀之好。次二行赞两小相海。次两句遍赞大相海。次十三行又赞四大相海。次两句赞一小相海。次两句赞手足柔软。复是一大相海。所以然者。大相小相更相间填共严佛身。龙尊巧智如法相解。如法相赞故大相小相相间而赞尔。夫相好本庄严佛身。佛身多种。父母生身。尊特身。法性身。身既不同相好亦异。相体不同相用亦异。相用不同相业亦异。三身异者。如林微尼园举手攀树。化右胁生。天地大动阿夷甚惊。披[疊*毛]而相。相相炳明决定成佛。悲不能声。此是生身佛相也。如释论说。尊特身佛巍巍堂堂。譬如须弥映临大海。所有大相小相亦巍巍堂堂。不同常身常光常相。此即尊特佛身相也。法性身佛者非是凡夫二乘下地之所能见。唯应度者亦令得见。此即无身之身无相之相。一切智为头。第一义谛髻。八万四千法门发。大悲眼中道白毫。无漏鼻十八空舌。四十不共齿。四弘誓肩三三昧腰。如来藏腹。权实智手定慧足。如是等相庄严法性身佛也。种相业者。如释论修百福德成于一相。三千二百福德。成三十二相。此即生身佛种相义也。若以空慧导诸相业。一一业悉与空相应。诸相应中空相应最为第一。此是尊特身佛种相义也。若以实相慧导成诸业。一一业无非实相法界。此是法性身佛种相义。三身三种相三种相业不得纵横并别。若一异者则不清净非微妙寂灭。以不纵横并别。故是绝言。言叹所不及也。今经正赞尊特身相。上兼法性下摄生身。处中而明实赞者之巧(云云)。一一相皆明其用。如足下安平相。一切魔邪无能倾动者。一切有无无能动者。一切边无能动者。如顶肉髻相。法不礼人亦不礼圣。亦不礼分中。别有所出(云云)。从去来诸佛下是第三遍类赞。诸佛法身平等一心一慧应化亦然。特举一佛一相以为赞端。遍类诸佛亦复如是。文殊问般若云。念一佛功德与十方诸佛等。即其义也。身口清净者有二解。一云。所赞者三业清净。我今悉礼。二云。能赞者清净。以好华香是身净。奉献是意净。歌咏是口净(云云)。从设以百舌下是第四绝言赞。初三行半是绝言赞。次二行是绝心赞。而有三番者。或应拟三身绝言也。一人百头头有百口。口有百舌。住寿千劫赞生身佛相好功德不能得尽。一人千头头有千口。口有千舌。住寿万劫赞尊特身佛相好功德不能得尽。大地及天毛滴其水。一切有心不能知法性身佛相好功德。是故绝言绝心叹。从我今下两行总回向也。从如是人王下二十五行半。是第二广发来愿。文为二。初一行佛述。后二十四行半是龙尊发愿。文为五别。初五行夜梦昼说愿。次两行为他取净土愿。次两行半同求记莂愿。次三行下化愿。次十二行上求愿。其间细释可寻。问诸愿皆克。此中何不与记。答法伴未来。来在不久(云云)。从信相当知下两行是第三结会古今。如文

金光明经文句卷第三金光明经文句卷第四

        隋天台智者大师说

        门人灌顶录

    释空品

夫空者应有四种。谓灭色入空。即色是空。灭边入空。即边是空。此经通诸乘忏悔。应须四种空。而今品但标空者。专是即边而空也。何故尔。经云。无量余经已广说空。是故此中略而解说也。又空者空有空无。空有者。空二十五之块有。空无者。空二乘之灰无。两边清净名之为空。直作此说。惑者迷名滥理。不能超悟。今作六句分别。空破非有非无。非有非无破空。空修非有非无。非有非无修空。空即非有非无。非有非无即空。空破非有非无者。所谓凡邪非有非无见。二乘偏住非有非无证。别教教道执非有非无门。悉为空品空所破也。凡邪之见多种。一单四见。二复四见。三具足四见。单四见可解。复四见者。谓有有有无。无有无无。亦有亦无有亦有亦无无。非有非无有非有非无无。此是复四见。具足四见者。于一句中具有四句。四四十六句。故名具足也。虽单复具足皆苦集浩然。虽计为非有非无。实是妄见。故为空品空所破也。二乘偏住非有非无证者。断常见故言非有。断断见故言非无。有无二见灭无余。三界见思永已尽。生灭度想生安隐想。梵行已立所作已办不受后有。保此而已。不复进求三菩提。但二乘发真。断常见断断见。其门不同。或从有门入如阿毗昙。或从无门入如成实论。或从亦有亦无门入如昆勒。或从非有非无门入如那陀迦旃延经。离断离常名圣中道。四门俱断断常。名同中道。实是保偏取证。故为空品空所破也。别教教道执非有非无门者。佛为钝根菩萨。方便权巧作四门说中道。如彼筏喻。不得意者四门成诤。故涅槃云。真善妙有大般涅槃空。佛性亦色非色非色非非色。若各执一门。则于如来有诤讼心。不见中道。执此教门。犹为空品空所破也。新本云。初地菩萨欲行有相道。斯即一门之意也。文中悉有四门之说。大经云。自此之前我等悉名邪见人也。非有非无破空者。还是凡邪之空见。二乘之空证。教道之空门。堕在二边。故为中道非有非无所破也。相修者。见空证空教道空。应修中道非有非无也。非有非无见。非有非无证。非有非无教门。应修中道空也。相即者。破二边空即是中道非有非无。中道非有非无即是破二边空无二无别。般若是一法。佛说种种名空即是非有非无而不以非有非无为名者为略说故故言空品也。此品来意者。忏品破恶。赞品生善。空品导成灭恶生善也。亦是导成用宗体等。故释论云。若以无此空一切无所作。导成上品故明空品也。又常果显体。灭恶生善非不明空。利者已解。为钝根故起大悲心。更明五阴生法本性空寂尔此品有四十五行偈。分为二。初四行半叙欲说空。次四十行半正说空。无量余经者指广而明略。亦是标略以显广。若指般若则此经非方等摄。若不指般若。诸经不广明空义。此复云何。答诸经前分结集人应作次第。而其后分皆摄入前例。且举一以类诸。如阿含经云。佛将涅槃。舍利弗不忍见佛灭。前佛而去。均头头擎衣钵来至佛所。此是穷后之事。而在十二年前阿含中集。当知阿含后分至涅槃也。又方等次第在法华前。而云先于灵山已为声闻授记。岂非方等至于涅槃。又大品次第在法华前。释论云。须菩提于法华中授记故。而诸菩萨为毕定为不毕定。当知般若亦至涅槃。以此推之。言次第者是前分也。互相指者是后分也。结集者。以后分明义。气类若同向前集之。或者不知言乖次第实不乖也。此经属方等后分。指般若为广说。于义无妨。略而解说者。佛有略广二门。应作四句分别。或名义俱广。如十八空二十空二十四空是也。或名义俱略。如一独空是也。或名广义略。如法性实相实际如如法界等众多名共名一义是也。或名略义广。如生法二空之名而义大广。迄从凡地至于极佛皆名众生。释论云。众生无上者佛是。从凡夫之五阴极至佛地。亦称色解脱受想行识解脱。释论云。法无上者涅槃是。今言略说生法二空。下文云。五阴舍宅观悉空寂。善女当观。何处有人及以众生。即其义也。众生根钝者根缘不同。或广说得悟名利根。或略说得悟名钝根。此语似倒。身子一闻得悟。是略是利。目连再闻得悟。是广是钝。此经意不就得悟边明利钝。乃是闻持边论利钝。利人广闻则能持。钝人略闻方能持。今机但有得悟之机。无有广持之机。故言不能广知也。无量空义者。二乘真谛是有量空义。菩萨中道是无量空义。此经明法性实相。即是无量空义也。异妙方便者。即是悉檀方便。巧作上来办果明因灭恶生善种种分别等是也。起大悲心者。一段众生著有病重。故大悲亦重也。我今演说者。演名为广。与略相违。上论生法二空是名略。今论生法二义故言演尔知众生意者。知此一机乐略宜略对略悟略。故言知意也。叙欲说空意竟。从是身虚伪下四十行半偈。是第二正明于空。又为二。初从身伪下十九行半明生法二空境。二从善女当观下。二十一行。明生法二空观。无境观不正。无观境不显。应引止观中十番检境智明不可思议。下文云。不可思议智境。不可思议智照。新本云。如如法如如智。即其义也。明空境又二。初从是身虚伪下十七行半明实法境。二从水火风种下二行明假想境。实法者。观五阴无法。观十六无人。空观诣理故名实法。身虽未死虚假臭秽故名假想。亦名慧行行行。缘空直入名为慧行。带事兼修名为行行。亦名正道助道。空观顺理名为正道。不净破贪名为助道。小乘修正道断结名慧解脱人。修助道断结名俱解脱人。大品明菩萨发心与萨婆若相应者是修正道。游戏神通净佛国土者是修助道。法华名为大车傧从。即此意也。涅槃明正慧远离。远离十相住大涅槃。又谛观白骨破二十五有成王三昧。众经同论此二义。而互有广略。今经略明正助意也。实法境又二。初从身伪下十行半约苦果论境。二从从诸因缘下七行偈约集因论境。观此苦集而起道灭。若能见四谛则得断生死。生有既尽已更不受诸有(云云)。苦境又三。从身伪下两句明生空境。次从六入村落下九行偈明法空境。次从身空虚伪下一行结上生法二空境。是身虚伪为生空境者。揽阴成身。计有我人众生寿命。身见得生。若体其生名虚伪则求身叵得。身见不起。余知见亦寂。故约假生为生空之境。又检此身原由。一念妄想托父母遗体。假名之始也。此赤白二渧色阴也。觉苦乐受阴也。想此苦乐想阴也。具三性行阴也。识于中住识阴也。又精血是地大。湿是水大。暖是火大。气命是风大。四大围空是空种。心依此住是识种。此实法之始也。观此身与名依妄伪法。岂可为真。故言虚伪。空聚者。身名积聚。如水上泡围空而起泡名亦起。起即有灭泡名亦灭。无明业力托父母体即阴泡起。阴泡起即身名起。阴泡灭则身名灭。故言空聚也。从六入村落下明法空境。何以知之。此文但细检根尘不论人我。故知是法空境。文为三。初一行明六根。次三行明十二入。次五行明十八界。六入者六根也。能生于识名之为根。尘之所趣名之为入。亦为识之所入故名六入也。检其元初但有三事。谓命燸识。如凝酥薄酪。七日一变。巧风所吹开张五胞。揽四大净色。结成眼耳鼻舌身等。诸根若立则有生识之用。是为开色为五心但为一。识依根住故名为村。尘从此入故言结贼所止。眼见耳闻鼻嗅舌尝身触意缘各有所伺不得相滥。故言各不相知也。从眼根受色下明十二入。更开色为十。并一入少分。开心为二。成十二入也。尘入于根。根亦入尘。互相涉入通名为入。根生识强别名为根。尘污义强别名为尘。当一根尘互相涉入。故言各各自缘。他根不入此尘。此尘不入他根。故言不行他缘也。从心如幻化下明十八界。更开心为八色为十。界者隔别不滥名之为界。文为三。一心如幻化下明识遍诸根。假令眼耳不对于尘。心亦追缘预念故言驰骋。如人坐驰天下。以愚痴故不知根尘空险。故为贼害。如大经(云云)。二心常依止下明识常在根故言六根。识常在尘故言境界。若谓识不在根尘。那忽即对即觉。以即觉故故常在根尘。释论云。根不坏心欲闻复有声。众缘和合故得闻。即此义也。三心处六情下明识之于根乍出乍入。如鸟在网出入间关啄一舍一周而复始。无暂休息。识在根网亦复如是。或在于耳或在于眼。去还无定。虽复无定而得论常在(云云)。从身空虚伪下一行是第三结上生法二空境也。身空不可长养。结上生空境。长养是十六之一。长养既空十五亦空。即是结成生空境也。亦无正主者。结上法空境。遗教云。此五根者心为其主。此明托胎之始。心在诸根之初。名之为主。其实不能控制诸根。根大相违心为受恼。身病时心亦随病。宁得是主邪。或时更互论主。如地具四微。则钝为水所制。水但三微为火所制。火但二微为风所制。风有一微为心所制。心无有微。故得为主。复为四大所恼主义不成。故言无正主也。无有诤讼者。若计有四大则有相违。如四蛇相陵四国相拒。可有诤讼。今观四大空不能得空便。故言无有诤讼也。此是结上法空之意也。从诸因缘和合而有下七行偈约集因明境。即是集谛。文为三。初两行明集起相。次三行半明集相吞噬。次一行半明集善恶境。前三是慧行。后一是行行。前三是正观境。后一是助道观境。前一从无明生。后一从无明灭。若直论生灭者。未异小乘。无明本不生而生不灭而灭。生灭不二而二尔。从诸因缘者。苦集通从因缘。欲明集义。须作集之因缘释也。前三句假名起之因缘。后五句实法起之因缘。小乘破四大至邻虚细尘。从细尘则有粗尘。用此为起假实之因缘。今明粗可析尽细尘亦尽。粗细俱尽。将何物作因缘。言因缘者。无明内惑为因。不了生法二空故染爱于外为缘。触处染着故。无明润爱集业得起。故言从诸因缘和合故起。以业起故则有一念托胎招于苦果。此一念托胎由无明爱。能生之心既是虚妄。所生之心亦是虚妄。讨其本末能所都虚。故言无有坚实也。妄想故起五句明实法起之因缘。由妄想不了一念托胎五阴得起也。业力机关者。善恶业是机关主。色阴是机关具。受想行阴于中动作。去来进止以自娱乐。识阴依六入住。故言空聚。四大所造故言成立也。随时增减共相残害者。竖论增减者。如涅槃十时别异。从歌罗逻时名增。壮时名盛。老时名减。横论增减者火增水减水增火减。风地亦尔。又念念生灭。生是增灭是减。又新诸根生故增。故诸根灭故减。又下文云。随其时节共相残害。春风夏火秋地冬水增减(云云)。譬如四蛇初在箧时名生。四蛇力敌名壮。互相强弱名病。蛇斗困暂息不动谓为调适。息已复斗。蛇羸如老。蛇绝为死。如是增减此是果身。如此由乎集业。四分等如地嗔如火。欲如水痴如风。此四分互相违。瑞应云。贪欲致老嗔恚致病愚痴致死。例云。等分致生。集业相噬致令四大增损(云云)。同处一箧者。此明箧同性异。蛇有螫毒。四大有八万四千烦恼为害义同。大经以假身为箧。身待四大如箧贮蛇。箧坏则蛇去。身灭则大亡。如鸟在笼(云云)。又用业力为箧。业持四大。业谢则大散。如鸟在笼处处求出。心鸟亦然。未曾一念系在身箧。恒常外驰。此则念念求死。非安身道也。其性各异者。二上升是阳。二下沉是阴。何故相违。犹其性别。性别那能和合成身。诸方亦二者。四大对四方。风东火南地西水北。又对四时。风春火夏地秋水冬。东与南属阳而上升。西与北属阴而下沉。故言二上二下诸方亦二。若相对论者。东上西沈南升北降。若论四维者。东方带两维。一维阳上。一维阴下。余三方亦如是。或言一根中具四大。二上二下(云云)。悉灭无余者初见散灭。谓言风火向上地水向下。比至上推不得于风火。下检不见于地水。故言悉灭无余也。苦果升沈硕异。由于集业善恶天乖(云云)。心识二性躁动不停者。释论云。心意识一法异名。对数名为心。能生名为意。分别名为识。又言有异前起为心。次起为意。后了别为识。例如意识不得为一。二性者。心有善恶性异。意之与识亦有善恶性异。故言二性也。躁动者。心前起时亦与数俱。意识后起亦与数俱。故言躁动。又如四大坏时。善恶业争牵不知从谁。故言躁动。但此业未谢心常觉观。况复业牵。宁不躁动。有熟牵强牵。此世虽行善先世恶业熟。既与时合即受恶报。故言熟牵。强牵者。人虽行恶。临终之时善心猛盛。即随善上升。熟牵强牵弥显躁动。亦是随业所作而堕诸有(云云)。水火风种散灭坏时下二行明业谢弃苦器也。气命尽是风去故言散。暖尽是火去故言灭。水尽则身烂。故言大小不净盈流于外。地散灭是骨肉离解。故言如朽败木。大小不净者。身为大四支为小。足支为大手支为小。手为大指为小。如是转转作大小。皆悉臭秽不净盈流。此名助道。若正观降伏烦恼。烦恼不伏当修不净助破欲心。释论云。三解脱是涅槃门。道品是开门法。不净九想等是助开门法。不净是破欲初门。若进修背舍及大不净。己身他身一身多身。一国多国山林石壁。一切依正皆悉不净。即虽未尔。想力若成怖畏心起。能大助道开发正慧。大经云。不净观亦实亦虚。能破烦恼故名为实。净言不净是故为虚。此不净观亦具生法二空。大经云。谛观白骨。一一支节何者是我。八色流光亦复无我。我不可得即是生空。炼骨人八色不见四大无有于实。即是法空。此就助道明于生法。终成正道尔。从善女当观下二十一行。是第二明生法二空观。文为二。初八行半明修因生法二空观。次十二行半明果成起用。因中又二。初三行半约苦集明生法二空观。次从无明体相下五行约十二因约明生法二空观。约苦集又二。初从善女下一行半明众生空。次从如是诸大下二行明法空。问四谛十二缘是二乘法。云何是菩萨观门。答四谛十二缘通是三乘观境。譬如大道贵贱同游。不可群小行之而判属民庶。通意云何。涅槃云。我昔与汝等不见四真谛(云云)。又云。凡夫有苦无谛。声闻有苦有苦谛。菩萨解苦无苦而有真谛。诸佛如来有真有实。所以然者。二乘观有量四谛。菩萨观有量无量四谛。大经云。十二因缘凡有四种。下智观故得声闻。中智观故得支佛。上智观故得菩萨。上上智观故得佛菩提。复有别意。大品云。十二因缘独菩萨法。如佛昔为儒童。虽行众行非波罗蜜。见然灯佛得无生法忍。一念相应习应苦空。乃至习应灭空。习应无明空乃至老死空。诸相应中空相应最为第一。以空导行皆名波罗蜜。以得无生法忍故佛即与记。当知菩萨岂不观于四谛十二缘邪。二乘虽复同观。观法有异。声闻观诸果。总作一苦谛观。观诸烦恼及业。总作一集谛观。又苦之与集总是现在。所以名总相观也。缘觉观苦为七。现在五未来二。观集为五。过去二现在三。别观三世别开苦集。故言缘觉别相观也。虽复总别有殊。同是自调自度。同是析生法二空观尔。与菩萨有异。菩萨为众生修四等六度。观四谛十二缘。作生法二空。今举譬喻之。如握五指成拳。若一指一拳应有五拳。若一指无拳五何得有。我人亦尔。揽五阴成众生。一阴有众生。应有五众生。一阴无众生虽五亦无。即阴求众生不得。离阴求众生亦不得。虽求拳不得拳。不妨有皮骨之指存。虽求人不得人。不妨有五阴之法。在二乘人得生空时。未能知法空。更须析指皮肉骨髓分分推求亦不得指。地水火风穷逐邻虚亦不得色。前念后念亦无想受。求指不得指。始知指无。求法不得法。方知法虚。既不得生法二空境。亦不得生法二空智。通菩萨观亦然。是为菩萨二乘析生法二空相。如此但有自行为他之异(至云)。若论别菩萨体空。与其永异。如见镜拳悬体既空不劳寻检。镜拳既虚镜指非实。镜内拳指既是虚。镜外拳指亦非实。众生亦尔。但有名字名为众生。此之名字本来自空。非检后空。名既假名法亦非法。体名即体法。如大品云。我性如色性。色性如我性。今世生法由无明行。五果既虚。二因宁实。下文云。本性空寂无明故有。无明既寂。从无明生宁得不寂。虽不得生法二境。而能了了通达二境。不为境所染。虽不得生法二空智。而能了了通达二空智。不为智所净。非染非净双亡二边。正入中道第一义谛。而能双照二谛。三谛朗然。非前非后一时大觉。与此甚深法性相应。金刚宝藏具足而得。是为菩萨体生法二空观。诸小乘师虽说析空同外道义。何者析色极至邻虚。或存尘不破。或破尘令尽。若存不破秖是常见。若破尘尽秖是断见。断常宛然非邪何谓。诸大乘师虽说体空同于小道。何者。单用体慧。不能一念空心游戏神通净佛国土具足解释佛之知见。何能三智一心中得五眼具足而成菩提耶。似小乘坏法人无三明六通愿智顶等。秖是慧解脱人而已。非小何谓。今经首轴穷深极广。序品云。游于无量甚深法性。空品云。求于如来真实法身。舍身品云。求于寂灭无上涅槃。岂可用世人邪见。岂可用小乘之析。岂可用大乘师之体解此空义邪。善女当观下一行半明生空观。初一句对告劝发。次一句指上境。次四句正作观。善女者。菩提树神也。诸佛说法必有对扬。寄一以训众故告其人也。又时众机缘宜在善女。若闻对告宿善发生。又男天表方便。女天表智度。欲说智度破于愚着。故告女天也。又佛在道树得道。欲说此道故对告树神也。此是表四悉檀。对告非无因缘也。当观者。劝一人以例诸。一切菩萨必须修于智度。无有菩萨不由此者。故言当观也。诸法者。指上四谛十二因缘若假若实二空境也。名目虽略摄法则遍故言诸法也。如是者。正明总观也。如是有三义。谓如事如理。如非事非理。如事者。如助道假想不净流滥也。如理者。如生法二空无法也。如非事非理者。如法性法身也。又事即如理如非事非理。非事非理亦即如理亦即如事。理即如事亦即如非事非理。三法不一异故言如是。三法亦一异故言诸法。何处有人者点出理观也。何处者。若色处有人则不须四阴。若色处无人四处亦无人。五处都无人故言何处有人。又果处既无人。无明行因处亦无人。因果合亦无人。离因离果亦无人。故言何处有人也。人既无。众生十六知见等皆无。故言及以众生也。本性空寂者。点出非事非理观也。本性无事亦复无空。空本空事。既其无事。空何所空。无事故事寂。无空故空寂。本性如此。非今始然。故言本性空寂也。无明故有者。点出事观也。若其空而复空。那得此事。既有事即有空。既有空即有非事非理。此之三种悉由无明故有。以有无明痴故有行。有行即有生法。既有生法即有助事之观。助来助正即有空理之观。正助显本即有非事非理之观。是事不知名为无明。净名云。从痴有爱则我病生。病生故则有药起。即此义也。若知无明本性空寂。尚无无明。那得事理非事非理。毕竟清净故称空慧也。但我见深重为学道大障。凡夫所作恒与我俱。我行我住。坐卧言语无离于我。我行施戒乃至我行智慧。若揽他遗体而计我者。此我疏钝。若执法尘而计我者。此我密利。如执一法。谓我知我解于法起我。随执一句是实。余皆妄语。即是边见。非道谓道即是戒取。非理谓理即是见取。不当谓当即是邪见。自是陵他即慢。拨之即嗔誉之即爱。破之即疑。不了即痴。十使烦恼以我为根本。不自觉知日夜增长。纵令世智辩聪如长爪鍱腹。难石石裂。难树树折。难水水竭。难火火灭。去道弥远。假令随禅梵世极至非想。我心常在将出复还。如此凡邪尚无暖法。那能破我。广说此我即二十种身见。谓即阴计五。离阴计五。我中有五阴。阴中有五我。是为二十。若一阴是我余阴无我。若并是我即有五我。是义不然。若离阴有我。既离于阴我是谁我。是义不然。若阴中有我。是则阴盛于我。如器盛果。如屋贮人。是义不然。若我中有阴则阴在我内。是义不然。是为破三十种身见。此约外境作如此说。而其内心犹计有我。复当反观。即智有我离智有我。我中有智智中有我。是义皆不然。复破二十种身见。内外合数即四十种身见。是名生空。毗昙云。我见是共等因。我见起时未动身口。因我见后生思惟时。方动身口。断我见已悟众生空。成论明。我见心即思惟能动身口。断我见已即悟众生空。亦悟法空。大乘明。我见即具诸法。可不具于思惟。悟众生空即是悟实法空。破二十种身见。通上三句皆通用之。若即事而理。何处有人。即阴离阴。阴中无人人中无阴。二十种见破。故言何处有人。能观之智智即是人。离智有人。人中有智智中有人。此计亦破故言何处有人。若作非事非理本性空寂观者。本性空寂本无即阴离阴。阴人人阴既无。如此计破故言何处有人。能观之智本性亦寂。故言何处有人。若作助道不净观时。若观恶心取境。即是污秽五阴。若善心惭愧。即是方便隐没五阴。是见皆依色。色即不净。以不净故无人无我。故言何处有人。能观观智亦复如是。故言何处有人。若得悟为论。破二十种身见。是得众生空无复见惑。而作二十种观者。除于实惑。实惑若除即入修道。即应言何处有法。若未悟为论者。虽作二十种观。见惑未除。而于假名上伏爱。度入实法计我。故法华云。众生处处着。舍一取一。如屈步蛊须实法上更作二十种观。使空慧分明处处作无咎。从如是诸大下两行明实法观。上生空得悟即解于法。为未悟故更说尔。文亦为三。初两句即法而空。次一行一句即法本性非空非假。次一句即法而假。例如生空三意也。如是诸大者。标四大法也。一一不实者。正明空观也。若四大各守其性者。地守坚性。不应动不应暖。水守湿性。不应冰不应波。火守热性。不应贞不应焰。风守动性。不应持不应触壁而止。一大既有三性。非都坚非都湿。非都热非都动。失本性故。则是不实。不实故空。请观音云。地无坚性水性不住。火从缘生风性无碍。一一皆入如实之际。即其义也。上检生空。故言何处有人。今检法空。故言一一不实。不实者即空也。本自不生者。即法本性不生不灭。非空非假观也。体其元不生。中无和合末亦不空。元无四大。四大何得而生。元既不生。中那和合。四大既不和合。宁得五阴和合。大阴既不和合。那得法空。本自不生不灭。非是观智令其不生不灭。即事而理此之谓也。以是因缘者。观解因缘也。观与理冥。达即空即假即中。大经云。亦有因缘。因灭无明即得炽然三菩提灯。即因缘义也。和合而有者。即法而假也。既本体不实。那得大阴。此由无明业因。托今世遗体果。故有四大五阴。即是迷惑因果和合而有。此法有故体有非有亦非有非非有。即空即假即非空非假。三观明文在经。宁不信邪。更为钝根人作实法惑相。或谓四大五阴是有是无是亦有亦无是非有非无。四执既生生名为有。是见依色。依色起我。我生五利为法恚怒复起五钝。十使是集。方招来苦。来世不了展转无穷。生死大海潦水波涛世世常为大阴所惑。惑此色法即色阴。忧喜是受阴。取相是想阴。起善恶是行阴。分别是识阴。阴心起故名为有法。非法空也。心不依色。亦复不依受想行识。寂然灭众恶。无量众罪除。如是尊妙人则能见般若。亦是甚深法性。金光明中而得见我释迦牟尼。行人若能如此观生法二空。则是怀璧向本。一世两世能有所办保不孤然矣。从无明体相下五行明十二因缘生法二空观。文为二。初三行出境相。后二行出观相。初又二。初二行明生空境。故文云。名曰无明。释论云。谁老死。故知是生空境也。后一行出法空境。文云。老死愁恼。释论云。是老死。故知是法空境也。然十二因缘经论不同。或三世或果报。或一念或十种。三世者。过去二因破神常之见。现在五果破神我之见。现在三因未来二果破神断之见。常途所用。果报者。初托胎歌罗逻时为无明。一期始终论十二支也。一念者。华严云。十二因缘在一念心中。大集云。十二因缘一人一念悉皆具足。如眼见色。不了名无明。生爱恶名行。是中心意名识。色共识行名名色。六处生贪名六入。色与眼作对名触。领纳名受。于色缠绵名受想色相已名取。念色心起名有。心生名生心灭名死。乃至意思法亦复如是。一日一夜凡识几许十二因缘轮网以自缠回。今更说其因起之相。若观名色由行。行由无明。于无明不了。或谓有谓无亦有亦无非有非无。作四句取者皆是无明。是事实是行。是中心意名为识。识共色行名名色。一一如前说。又观一念托胎是名色。五胞开张名六入。六入对尘名为触。领纳名为受。于此受中作四句分别。或有受无受亦有亦无受非有非无受。如眼受色。于色不了是无明。爱恶之心名为行。识共色行名名色。六处生贪名六入。余如上说。乃至意思法不了是无明。爱恶是诸行。余如上说。如此推十二因缘大树枝条布濩遍覆三界。谁能识邪谁摧伐邪。今经既是略说。不论三世一念等。但举生法为二观之境。宜以譬显。如捉火炉闇中舞之。圆轮相续团团不断。火者实法也。轮者假名也。众生长夜着于假名舞烬不息。迷于阴入薪火不息。十二因缘何由可尽。若知轮依于火。止手则无轮。火赖于薪。除薪则无火。轮火双无生法二空也。生空境文例为三。无明体相两句明本性不有不无。是中观境。妄想因缘和合而有。此两句是假观。境无所有故两句是空观境。是故我说两句结成尔。行识名色一行明法空境。例应有三。特是文略。得意可知。众苦行业下明生法二空观。文亦三意。众苦行业不可思议一行明非空非有观。本无有生亦无和合两句明空观。上句本无有生是生空。下句亦无和合是法空也。不善思惟两句明假观。前不善思惟致今名色。今不善思惟复有未来老死(云云)。虽名为生法二空观。即空即假即中。其文炳然。明与义会何所疑哉。更为钝人说空观相。若假名自生不须实法。若由法生非假名生。若假实合生应有二假。若离假实则无是处。今之假名但有名字。名字不在内外两中间。亦不常自有。以不可得故是名观假名空。观实法空者。若名色自生不应待业。若业能生罗汉有业。何故不生。若业果共生各有名共。各无宁共。若无因缘生则无是处。既不得生。亦不得不生。亦不得亦生亦不生。亦不得非生非不生。亦不得灭。亦不得不灭。亦不得亦灭亦不灭。亦不得非灭非不灭。无灭无生名为无生。无生故假名坏。假坏故则六十二见坏。见坏故实亦坏。既不然火是则无烟。日中舞烬是亦无轮。是略示空观相。中观假观在别记(云云)。我断一切诸见缠等下十二行半偈是第二果上生法二空用。明观成证果。文为二。初三行半自行成。后九行化他成。自行文又二。初两行智德满。次一行半断德满。一切诸见者。六十二见八十八使等。故言一切。此是生空观成也。以智慧刀者。譬智慧利用。上譬断见下譬断烦恼。缠者别明十缠。烦恼网者通明十使。网有罗笼之失。舍有覆闇之过。达阴空寂闇障不能盖。裂网破坏罗罥不能碍。此是法空观成也。二乘所断是通见缠。菩萨所断是别见缠。净名云。结习未尽华即着身。未断别见为华所著也。而言佛断见缠者。若通若别究竟尽在于佛也。释论云。众生无上者佛是。法无上者涅槃是。无上假实佛地所不惑。故言断尔。经论不同。或言佛上上智断下下惑。无明力大。佛智能断。一念相应慧正习俱尽无有余。或言有上士者名之为断。无上士者名无所断。斯乃随国随时随人随悟皆有利益(云云)。证无上道者。生法二空正道满也。微妙功德者。生法二空助道满也。开甘露门下一行半明断德满。甘露是诸天不死之神药。食者命长身安力大体光。譬诸佛断德住大涅槃真常乐我净用。知是断德满也。然此义意复欲通对华严诸位。开甘露门对十住位。初开圣道遮二边故。故言开也。示对十行历别显示也。入对十回向回事入理也。处对十地处法性室也。食味对妙觉自食斯味。兼以被人。下地非不化他。自行未圆化亦不广。佛地果圆断德已满。慈悲力大能为众生开于十住。示十行入十向处十地。食甘露味功用具足断德化他。两义皆成也。又通对般若四智。开对道慧。示对道种慧。入对一切智。处对一切种智。食味对佛住大涅槃。以大悲令众生得此四智。于果地断德义亦无妨(云云)。又对法华开示悟入佛之知见。良由佛德圆满。能以大事因缘出现于世。开示众生佛知见也。于断德义亦显。又涅槃云。常乐我净于果断最便。如前释(云云)。吹大法螺下九行明果地化他满。文为二。初两行转法轮化他。次七行四弘誓愿化他。说法又二。初一行说法。次一行神通。余经前神通骇物开后说法。今经后神通成前说法尔。修因时生法二空之正慧。得果时智德满。故能说法化他。修因时生法二空之助道。得果时断德满。故能神通化他。说法举四譬者。闻法之益实自无量。略举四譬别有所拟。吹蠡是改号。譬佛说小乘法改凡夫苦忍之凡性。入圣人之正性。说大乘法改凡圣之偏性。入中道之圆性。通教七地别教初地圆教初住皆是改号之位。从偏以入中也。击大法鼓者。击鼓诫进肃众前驱。此譬佛说法督进深行。小乘位在修道。通教在八地。别教在十行。圆教在初住。此诸位以闻法力咸进真修道也。然大法炬者。炬能自照亦能照他。譬佛说法令自他双益。如千年闇室一灯能了。又如一灯然百千灯。闻法之力自他俱益亦复如是。通教八地别教十回向圆教亦在初住。皆是道观双流自他俱益之位也。雨胜法雨者。雨能成熟农夫加功。扶疏益寡。时泽一降华果敷荣。喻如众行虽复勤修发趣事弱。闻佛说法增道损生任运成熟。自然流入萨婆若海。如大恒中船不劳筋力疾有所到。此并在双流位中。义如上说。若得此意。例华严之四位。般若之四智。法华之四知见。涅槃之四德。皆可解。此一法竖拟诸经之位。横论一切诸位。一闻法音随类各解(云云)。此中四譬皆言大者。说大法也。通途解释明大非小位尔。我今摧伏下是神通化他也。怨结者。四住是二乘怨结。五住是菩萨怨结。魔为烦恼主。伐树去根。化物须降主。若不降魔化道不畅。降魔之法须用神通。譬如胜怨。乃可为勇。非法王不坏。法王胜者。是时化道得立尔。竖法幢者。法幢三昧也。高出众行为众行之望。如兵望麾也。三德不纵不横。故言微妙。从度诸众生下七行是四弘誓愿化他。虽复成果本愿未休。故言四弘益物。亦名四谛益物。四弘是誓愿之心。四谛是所缘之境也。度诸众生是初弘誓。亦是未度苦谛令度苦谛也。从烦恼炽然一行是第二弘誓。亦是未断集谛令断集谛也。从我以甘露下一行是第四弘誓。亦是未证灭谛令证灭谛也。从于无量劫下四行是第三弘誓。亦是未安道谛令安道谛也。此中指檀为四谛。檀对于悭悭贪自蔽是集。集业招果是苦。檀能破悭是道。悭灭是灭谛。无量劫者积功高也。遵修诸行者摄法广也。论云。檀义摄于六(云云)。舍身命财与后际等。得不坏常住名波罗蜜。竖高横广故言遵条诸行也

金光明经文句卷第四金光明经文句卷第五

        隋天台智者大师说

        门人灌顶录

    释四天王品

四天王者。上升之元首。下界之初天。居半须弥。东黄金埵王名提头赖吒。此翻持国。领乾闼婆富单那。南琉璃埵王名毗留勒叉。此翻增长。领鸠槃茶薜荔多。西白银埵王名毗留博叉。此翻杂语。领毗舍阇毒龙。北水精埵王名毗沙门。此翻多闻。领夜叉罗刹。此四王闻经欢喜。各领五百眷属。发誓护经。从此标章故称四天王品。观心释者。东集南苦西道北灭。四谛理是四天。观四谛智为四王。护四谛境名护国。护心数是护众生。世者他也。为他说心敷名护他众生。八部者。苦谛下有利钝见思。法华指此为鬼神。乃至灭谛下亦有见思。是为八部也。若不照四谛理。见思二惑侵害心王毁损境界。心王亡境国败。心数人民迸散。境智俱为鬼神所恼。能观苦集控作见思。则国安民宁。能为他说四谛。是护他国土。遮彼见思使得安乐。是为观心护世四天王也。此下十三品是流通段。佛慈季末。使邪恶不翳于正真。经王不壅于来代。有缘之者得正闻正听。故曰流通。凡为七意。四天王至散脂。明天王发誓劝奖人王弘宣此经。正论善集明人王弘经天王祐助。亦是示住日弘经方轨。鬼神品明听经功德天神地祇若河若海菩提萨埵咸守卫之。授记品证听经功德之不虚。除病流水引昔听经之功德。证今护持之非谬。舍身品引昔行经不惜躯命。诫劝师弟勿吝法财。赞佛品明诸菩萨称扬佛法能宣所宣利益深重(云云)。天王发誓又为五。四王以天力拥护请者。大辩品以辩充益说者。功德天品誓以资财润请者说者。地神品誓以地味膏腴味请处说处。散脂品誓以威武摧外敌壤内难安于请说听等也。又天王护其国。大辩护其师。功德护其众。地神护其地。散脂禳其灾。令经法大行也(云云)。四天王品者有六番问答。即为六段。第一白佛述有护国之能。第二白佛述其护国之事。第三白佛示其轨模。第四白佛要其法利。第五白佛双述兴衰。第六白佛说偈颂德。初番为二。一白佛二佛述成。白佛又二。一经家叙。二正白佛。叙敬如文。正白佛文为二。一叹经二述能护。诸天信法有力。是故叹经。欲得经弘述其能护。叹经为三。从是金光明下叹经体。从庄严菩萨下叹经宗。从此经能照下叹经用。正说乃多叹三则略摄于广也。法性之理佛所护念。文诠此理故言经王。既言经王。知是叹体。约体修行。能令菩萨具二庄严成于极果。既言庄严。知是叹宗。世天净天义天皆宗仰极地。施三业供养。恭敬是身。欢喜是意。赞叹是口。又下从地狱上至菩萨。无明未尽通有热恼。此经能除如月清凉。知是叹用(云云)。从世尊是金光明下是第二述能护国。文为二。一内以法护国。二外以策护国。法护国又四。一护国之由。二以法护国。三以天党护国。四以天眼护国。护国由者。由闻此经获于四益。身益光明。力益勇猛。心益增进。德益尊严。理获二益。谓法身慧命皆得增长。由国弘经致斯法润。宁得不护。述所以者。此义正与观心相应。以四谛智护四谛境。即是修行正法。以四谛智导诸心数。使诸心数不行。故名行般若波罗蜜。即是能说正法。内有如此护国所以。名护世王正治国土尔。帅党护国者。此亦与观心相应。心王帅心数党。降伏见思利纯诸使。如诸天王共眷属遮诸恶鬼。如转轮王与七宝千子有所至处四方归德。四王共五百所临之地。何恶不除邪。用天眼护国者。以报得天眼彻视。无幽不烛。防萌杜渐。何恶不除邪。二从若此国土有诸衰耗下是智策护国。令内外因缘和合。文为三。一若王国多灾。种种艰难谓兵饥疾者。我以智策劝法师往。或威神劝往。或现形劝往。或降梦劝往。法师若往广宣此经。如日出朝阳雰雾自歇。此劝外缘也。次王心无智照灾承闇入。若有明慧变怪不生。师既秉法来仪。王须专心听受。王若勤听天亦勤护。所以加于可加护于可护。一人有庆赖及万方。王身与国安隐无患。此内因也。若外虽有弘法人王内心不殷重。则不和合不能禳灾也。二者王无惠施则寡于福禄。如不勤田仓厨少谷。劝王倾财供给四众。四众得安福资于王。举国眷属一切无患。此内外因缘和合。能致丰年流衍(云云)。三者王身无先王之德行臣民不从。口无先王之法言邻国不咏今劝王三业。供养恭敬是身业。尊重是意业。赞叹是口业。夫高以下为基。辩以讷为师。屈尊敬卑功亦大矣。以天威力使邻国遥崇。羽檄称赞歌咏羡慕。三业颙颙。上之化下如风之靡草。邻国既然。国人牛马草叶无不低回内向。此则能赞所赞因缘和合。颂声溢于邻国(云云)。经文分明寻之可见。次佛述成文为二。初合述叹经。二述其能护国。四王初叹经说既合理。佛述而成之。成其上体宗用三叹。故言佛合述。善哉善哉。其上总叹一教。佛述成其遍赞百千诸佛。诸佛从是法生。故举多赞成于一也。从于诸佛所下述成其能护国。又为二。初述以法护国。二述以智眼护国。法护国有四。佛皆述成。上明护国之由由闻经得益。佛述今益良由先种。发心毕竟二不别。如是二心前心难。是故敬礼初发心。此举前以成后述后以显前。从说于正法下述其以法护世。上云能说能行所以名为护世。佛亦述成能说能行。得名护世(云云)。从汝等今日下超述其天眼护国。小不次第于义无失。上云以净天眼过于人眼。佛述长夜利益。夫天眼夜照不假日光。故言长夜也。从汝等四王及诸眷属下追述其天党护国。上直言护国。佛今加赞是护三世诸佛正法也。从汝等四王及余天众下述其智眼和合护国。上云请法师入境禳恶。此功归己能却修罗之阵。汝劝王听经供给四众。佛述其内智外福。实是消伏诸苦能致安乐。如文(云云)。第二番白佛述护国之事。文为二。一白佛。二佛述成。白佛又二。一是经流布之处。其王自能顶受。又供给四众者。我及眷属誓当隐形令其显益。二者恶邻兴兵侵斥善国。我当隐形起诸怖懅。种种难起。令其军兵显然退散。尚不扰边。况能怀中(云云)。次佛述成文以为二。从尔时佛赞下至无斗讼之事是述成初意。其上隐形护国欲使经弘。佛述隐形是护三宝。我是佛宝。修习菩提是法宝。诸王无斗讼是僧宝。述其护一而能成三也。从四王当知此阎浮提下是述成后意。上以天威懅之天力退之。似若憎恶爱善。佛劝慈心平等向之。为恶者自懅。为善者自豫。非薄恶而厚善。成其懅退之意也。又劝诸国各守本业。住境自乐勿起贪企。诸王和则民无夭。法兴盛则熏诸天。佛告帝释。斗诤因缘人天损减。善能慈和天下。非止供养于我。则是供养三世如来。非止安于一王。遍安诸王。非止安于一国。遍安一切。故以慈和述成第二意也(云云)。第三白佛示人王轨模。文为二。一出其愿欲。二示其轨模。愿欲有六。一欲安己身。二欲安妻子。三欲安宫殿。四欲王领殊胜。五欲摄诸福德。六欲国无忧苦。六愿如文。从世尊如是人王下是第二示其轨模。虽不次第六数足。上欲安身。今示莫放逸。制心则身安也。上欲安宫殿。今示严法堂。旛盖映于上香华丽于下。三宝受用则柏梁无灾。上欲王领殊胜。今示洗沐香涂敦恭去慢。一身敬于此八纮休于彼。上欲摄取福聚。今示正念听经。正念听经能致无量功德。天神竭其力覆。地神竭其力载。鬼神竭其力护。臣民竭其力爱。上欲安妻子。今示和颜与语。劝其兴福。内外修善感益事多。上欲得国无忧苦。今示应自喜庆自励忘疲倍作利益。一人既悦则四海谧然。此之谓也。次佛述成文为二。先述成六方法。次述成六愿欲。四王约六事。又所说少止在现世。佛约一事而所益多。超无量世。倍述成之。从佛告四王下秖弘经听经。即是述成安身方法。上直示心不放逸。今加示羽仪出宫迎候步步值那由他佛。方法既倍体亦弥安。从复得超越尔许劫难者。述成安国方法。上止一世无忧苦。今则超尔许生死之难。从复于来世对受轮王者。述成安妻子方法。轮王有玉女千子悉无怨对。尔许劫中妻子常安也。从亦得如是现世自在之力者。述成上安于王领方法也。从常得最胜七宝宫殿者。述成上安于宫殿方法也。从在在生处讫具足无量福聚。述成其上摄福方法也。从汝等四王下述成其六种愿欲。从四王下至不退转。述成上愿安身。从己为得值至毕三恶道苦。述成上安国。从我今已种轮王释梵之因。述成上愿安妻子。从已种无边善根下述成上欲摄福聚。从后宫宫宅无诸凶衰。述成上愿安宫殿。从国土无有他方怨刺。述成上王领第一。从汝等四王下更总结成六法六愿。皆令具足者。若能屈己迎侯至心听法。即是六愿六法。又回利施天。亦即能令六愿六法成就满足也。第四白佛要其人王施善。此由第三段末。文为二。一白佛。二佛述成。白佛又二。一人王运心。二天宫相现。人王心存至典。是故香作金光。回施必得。是故天宫相现。香至天宫龙宫鬼神等宫。总至三法界尔。观心解者。以智慧火然实相香。起戒定慧烟。实相是真法。故言金光。戒慧与理冥。故彻照无碍也(云云)。次佛述成文为二。先述香光非但至天宫等三法界。遍至百亿诸宫。又至恒沙佛上。总而言之。遍至十法界也。从诸佛世尊闻是香气下述成人王运善奉施诸天为诸佛所赞。先赞因成。次赞果满。如文。第五白佛双举兴衰。文为二。一白佛。二佛述成。白佛又为三。初从白佛至诸恶灾患悉令消灭。是第一举兴劝。从若有人王心生舍离至善神远离生如是等无量恶事。是第二举衰劝。从世尊人王欲自护及王国土。是第三正劝。举兴劝为四。一人王弘经则四天隐形听受。二非但四王听受。释梵八部皆集听受。三以是人王为善法知识。四既得法利护国弥勤。皆如文。次举衰劝亦四。一王不弘经天失甘露则威势减少。二释梵旧神并皆远舍。三恶鬼乱行灾毒竞起。四展转结成灾。灾何故起。恶鬼乱行。鬼何故行。天神舍离。天何故舍。不闻法食。何故无法食。王不弘经。如文。三正劝为六。一欲得现利故必定听。二天欣法食故必定听。三出过三论故定听。三论者。四韦陀论说梵事。毗伽罗论说十善事。僧佉卫世师勒沙婆论。说学通事(云云)。四始终得益。成就菩提。故必定听。五教主胜于释梵。故必定听。六诸法之本故必定听。皆如文。次佛述成文为二。初番述成举兴劝。不弘则衰无可述成。又解云。前番则两述成而与安乐。是述成举兴劝灭其衰患。是述成举衰劝。从若有人能于人天中作大佛事者。述成正劝(云云)。第六白佛文为三。一说偈叹。二佛以偈答。三欢喜发誓。偈叹有八行半。文为三。初一行叹三身。次五行半叹身相。次二行结叹。夫三身有通别。依文是别。空是法身。日是报身。月是应身。通意者。空是法身。日是报身。水日是应身。空是法身。月是报身。水月是应身。空是法身。日中空是报身。水中空是应身。月亦如是。依结叹文。空是法身。月是报身。水月是应身。空是法身。日是报身。焰是应身。化法是法身。化主是报身。化事是应身。虽复别说义则通融。故文云。无有障碍。即通意也。叹身相文为五。初一行叹上两相。谓目与齿。次一行半叹智断两德。谓智三昧。次两行叹下两相。谓平与网。次两句绝言叹。谓不可思议。次两句结叹。夫相好不独在应身。报法亦通。庄严父母生身者应相好也。庄严尊恃身者报相好也。庄严法门者法身相好也。此中叹智断。即法身相好也。文云无有障碍者。非独叹一身相也。偈初标佛月。今先结佛月为三身。次结三身通融。故言无有障碍。次结佛日故言如焰。次结佛化身即是四身义。故言如化。皆具三身四身。则是无障碍也。结竟即礼。礼于佛月。亦是礼佛日佛化也。品初叹经。叹体宗用。品后赞佛。辞异义同。佛真法身即是体。佛月清净即是宗。应现水月即是用。天王天辩其妙若此也。问空譬法身。月譬报身。空为作月不作月。空若作月。月非空作。空不作月。月那依空。答空不作月。亦不作非月。月非月必依于空。法不作报。亦不作非报。报非报必依于法。又问法不作报非报。报非报必依于法者。亦应月不作影。亦不作非影。影非影必依于月者。月亦是法身耶。答智与法冥。法是法界智亦如法界(云云)。又并影不作动与不动。动不动必依于水。水亦是法界耶。答动不动譬机。一切诸法中悉有安乐性。譬法界亦是无妨。又净度三昧云。众生亦度佛。若无机感佛不出世。亦不能得成三菩提。出世菩提皆由众生。机为法界。此义成也。佛答二十四行半偈天王所以赞佛者。佛能说法故也。法王所以赞法者。法能成佛故也。般若云。我初成道观谁可敬可赞无过于法。法能成立一切凡圣。故佛赞法以答天王。文为三。初一行叹经体答其法身。次一行叹经宗答其报身。次二十二行半叹经用答其应身。悉如文。三四王欢喜发誓如文

    释大辩品

辩有四种。小辩无量辩双辩大辩。无漏法名小辩。恒沙法名无量辩。备二种名双辩。双非双照名大辩。此天住智慧庄严法门自住大辩。以自在力为悦众生故随说一辩若二若三若四。故名大辩。为宜众生故若授一辩若二若三若四。宜而立之故名大辩。为对众生故或对一辩若二若三若四。对而治之故名大辩。为悟众生故若悟一辩若二若三若四。一悟一切悟而开发之。故名大辩。对佛发愿。以大辩加于说者。故称大辩品。文为三。一从白佛下以大辩力加益法师。二从若有众生于百千下以感应力加于化道。三从复令无量下以行力加于听者。初加法师以乐说辩才。庄严次第是辞辩。大智是义辩。总持是法辩。若有众生下加化道流布不绝。加其能化之道。无人无所化。无道无能化。因缘和合化道不绝也。从复令无量下是加听众两益。闻经至不退转是加因益。必定得菩提是加果益。文言虽略誓愿甚深。为益大矣

    释功德天品

此天住福德庄严法门摄一切法。而以功德为首。故言功德天。又能与说者所须无所乏少。故名功德天。又令说者昼夜思惟是经深义。故名功德天。又令听者速成菩提。具此众义故名功德天品。此是天王护经第三意。福资请说及以听者。文为六。一从白佛下发誓四事资给法师。二从我已于过去下明福德之由。三从若有人能称下劝示行法。文中有略示广示(云云)。四从我于尔时如一念顷下誓临影响。五从若能以已所作回施我下要求同行。六从应当礼下别示归敬。悉如文

    释坚牢地神品

上诸天或住善权方便道。为众生法父。此天住善实智度道。为众生法母。一义也。譬如阴阳覆载草木。智度养育出生众善。二义也。余度各有所主未亡未泯。实智照了无相无名。三义也。余度有等有上。智度无等无上是究竟度。四义也。智度法门常无改变。义曰坚牢常也。能荷乐也。能生净也。名之为地。德力自在我也。称之为神。从此等法门故名坚牢地神品。此品是天王护法第四意。翻涌地味资益请说听等地也。文为三。一从白佛下誓涌地味利益行者。二从尔时佛告下如来述成。三从尔时地神下发誓弘经。初涌地味文为三。从初白佛下明己身利益。凡约八事展转增长。由闻法故法味增长。法味增长故气力增长。气力增长故翻地味增长。地味增长故诸物增长。诸物增长故众生五果增长。五果增长故修行增长。修行增长故供养增长。供养增长故弘通增长。悉如文。从何以故世尊下明眷属利益。是经力增长。凡约五事展转增长。以经力故我眷属增长。眷属增长故地味增长。地味增长故诸物增长。诸物增长故众生快乐增长。快乐增长故依报皆具足。具足亦名增长。从世尊是诸众生下名报恩增长。凡约六事展转增长。以知我恩故专听增长。专听增长故功德增长。功德增长故教他增长。教他增长故地味增长。地味增长故受乐增长。受乐增长故信施增长。悉如文。二佛述成文为二。一约闻经展转增长。从人世至天世。从天世至出世。日夜即受不可思议快乐。即出世乐也。地神所说止是今世增长。如来述成文虽略意极长远。二述成供养增长。从人世至天世。从天世至出世。长远之义准前可知(云云)。三发誓护经。文为三。一誓护说法者。二誓护化道不绝。三誓护听法者。如文

    释散脂鬼神品

具存梵音。应言散脂修摩。此翻为密。密有四义。谓名密行密智密理密(云云)。盖北方天王大将。余三方各有。东方名乐欲。南方名檀帝。西方名善现。各有五百眷属。管领二十八部。孔雀王经云。一方有四部。六方则二十四部。四维各一部。合为二十八部。又说者云。一方有五部。谓地水火风空。四方有二十部。足四王所领八部。是为二十八部。巡游世间赏善罚恶。皆为散脂所管。闻经欢喜发誓护于说者听者。从能护人受名。故言散脂(云云)。文为四。一从白佛下发誓护持。二从何因缘下述有能护之德。三从散脂大将下誓以智力克益说者。四归敬本师。初段有经家叙。正发誓。悉如文。述德又为三。初标次述后结。标如文。述又为三。初五句述智。次五句述境。次五句述正。三番称世尊。知是三种意也。神既名密。述名显德。应谈密义。智若浅深阶级次第不名为密。即一智一切智。一切智一智。非一非一切。而一而一切者。斯是智密。若得此意。五句一句。一句五句。非一非五。而一而五。唯数唯密。而若境可以智知可以口说者。境则非密。不可智知不可识识。不可以名名不可以言说。是名不可思议密境也。而约五数议密者。例前可知也。若对邪道明正道待边说中。此正非正此中非中。皆非是密。即邪而正即边而中。邪正中边无二无别者。乃名为密。思益云。若以心分别一切法者。一切法邪。若不以心分别一切法者。一切法正。即其义也。我行正道。若境若智从此得名。唯然世尊自当证知(云云)。又此三番一往是身口意密。前五句言知。知即意密。次五句言现见。现见属眼。眼属身。即身密。后五句明正解。由正解故言正分别。分别即口密。所以言不彰露者是密义也。如此述名密义已显。赏味无已更复略说。世尊我知一切法下作三观义解之。知一切法一切缘法两句同是因缘所生法境。何者。能生为因是初句。所生为缘是第二句。能所合故诸法得起。中论云。因缘所生法。即此义也。了一切法者。了达虚无也。中论云。因缘所生法我说即是空。是为从假入空观也。知法分齐者。知空非空。用道种智分别假名凡圣之法无有差别。中论云。亦名为假名。是为从空入假观也。如法安住一切法如性者。以二观为方便得入中道第一义谛。中论云。亦名中道义。即是中道第一义谛观也。含受一切法者。即是中道正观。能双照二谛。故言含受。若三观一异纵横并别者。则不名密观。即一而三。即三而一。名为密。欲知智在说。说即口密也。世尊我现见下五句作三谛三解脱义释之。现见不可思议智光者。光是实智。如日月光常明不息。此实智照不可思议真谛境。成圆净解脱也。不可思议智炬智行智聚者。皆是权智。如人热炬屈曲照物。乍兴乍废随顺机缘。或此或彼。行是因义聚是果义。从因以向果。果兴而因废。皆是权智照不可思议俗谛。成方便解脱也。不可思议智境者。是法如如智。此智与法如如冥。故言不可思议智境。此智照不可思议中道第一义谛。成性净解脱也。若三谛三解脱一异纵横并别者。非不可思议也。以不一异并别故。故名不可思议。不可思议故名密也。世尊我于诸法下五句作三身释之。正解正观正解能显体。显体名正观。正观是报身也。得正分别正解于缘者。分别机缘。不待时不过时。普应一切。即是应身也。正能觉了者。无觉无不觉名为觉。非了非不了名为了。究竟清净之觉了即法身也。若此三身纵横一异者。不名为正。非一非异不前不后。故名为正。正即密也。约正明法身。即是金义。约观明般若。即是光义。约不思议解脱即是明义。三德是微密之藏。金光明是微密之教。从密教生密解。安住密理。行于密行。以密利他故我名密。唯然世尊自当证知。复次此十五句互相释成。若正解正观十五句皆正解正观也。若不可思议智光十五句皆不可思议智光也。若我知者十五句皆知也(云云)。又作五种佛性释者。正性缘性了性三名不异。又一家取果性境界性为五。又一家取果性果果性为五。若作果果性。即没境界性。为缘因性所摄。若开境界性即没果果性。为果性所摄。为开合不同终是五数。今以五知对五佛性。我知一切法者。知一切法中悉有安乐性。安乐性者。即正因佛性也。一切缘法者。无量功德低头举手之善。缘因佛性也。了一切法者。即是般若空慧。了因佛性也。知法分齐者。即世间出世间因果不滥。境界因佛性也。如法安住如性者。即是果性究竟安住如中也。含受一切法者。还是果性能双照含受也。若作果果性者。取知法分齐为果性。克果智照分明为分齐也。安住如性含受为果果性(云云)。若然者下两种五句亦应对五佛性。师虽不释义例应尔。准须释出其意消文令会尔。世尊以是义故下是结文也。从世尊散脂大将下是第三发誓。以智辩充益说者。文为二。先益能化次益所化。益能化为三。庄严言辞下益其口业。众味精气下益其身业。心进勇锐下益其意业。从以是之故下益其所化。此亦为三。以是之故广说是经。此是未种者令种也。若有众生下是已种令熟也。无量众生下是已熟者令脱。悉如文。此消文大好。从南无宝华下是第四归敬文也。佛说一切众经初皆归敬。而译人略之。诸论初亦先归敬。此文是说竟归依三宝。在文可寻也

金光明经文句卷第五金光明经文句卷第六

        隋天台智者大师说

        门人灌顶录

    释正论品

正论者。正名为圣。圣有二种。一世圣。二出世圣。论名核实。一核事实。二核理实。此品是先王旧法世世相传。先王传力尊相。力尊相传于信相。信相又传其子。其子又传于后世。世世正圣世世善实。即是先王之法言。亦是世界悉檀立名名正论品。王行此法法律相应。阴阳以之调。日月以之顺。百谷以之丰。万民以之乐。社稷以之安。治化以之美。即是民用和睦上下无怨。亦是为人悉檀立名名正论品。王用此法外敌不敢谋。内奸不敢惊。妖星不敢现。恶虹不敢行。暴风不敢动。疾雨不敢零。是则祸乱不作灾害不生。亦是对治悉檀立名名正论品。此之世善本金光明。从金光明出此正论。善用此正论。天宫天身以之光明。天力天威以之增长。天心为之倍乐。天之法味为之倍更深远。即是先王之至德要道。亦是第一义悉檀立名名正论品也。此文是流通中第二意。明人王弘经感通冥圣。天王佐助善政兴隆。文为二。一长行说事本。二偈颂说正论。长行中对告地神说昔尊相。如文。偈有八十二行。文为四。初二行半集众。次三行半发问。次一行结问开答。后七十五行梵天答。即说正论也。集众文为三。初一行是佛叙尊相欲为天子。说先王本法。次一行佛叙尊相诫听。次半行明说论处所。次四王发四问。一问云何呼人为天。二问非天所生而名天子。三问处王宫殿何故名天。四问以人法治世那得名天。次一行成前起后。可见(云云)。问既有四。答亦为四。一答天护其入胎。虽是人子而称天子。三十三天各分己德。虽是于人而称为天。虽处人宫殿用天律治世。虽是人主而称为天。虽是人法治世。令众生行善多生天上。以因中说果故称为天。从汝今虽以下是梵答。文为二。初十行半略答。后六十四行半广答。略中有四。初一行半许答。次因集业故一行略举昔因今果答其问王义。次五行举三义答其问天义。次三行举三义重答问王义。答天举三义者。未入胎入胎分德力加是也。以护胎故称为天子。答第二问也。以分德故有其天德。故称为天。答第一问也。神力所加修善遮恶。后必生天。因中说果故称为天。答第三第四正法治世名为天问也。答半名为天三义竟。从半名人王已下答有三义故称半为王。一名执乐者。乐由于王。王执此乐使天下和平。五日一风十日一雨。老者击壤小骑竹马。谁不归德。故执乐者名王。二者遮恶为民除害。天不亢旱地不洪流。草不折伤民无疾疠者。谁不归德。故遮恶名王。三父母者。诲示祸福导语善恶。制礼作乐而民知禁。谁不归德。故父母名之为王。能为民下作父母。故诸天护之名为天子。以遮恶不起诸天分德名之为天。以执乐故因中说果复名为天。非但半名人王义成。半名为天三义亦显。从若有恶事下三十九行三句广明非法不得名天不得名王。六义俱失。三十三天各生嗔恨。是天不护。不护故非天子。是诸天王各相谓言。是天不分德。不分德故不得名天。舍远善法增长恶法。则无天因。宁得因中说果叹人为天也。生大愁苦者。无执乐义。疾疫流遍无遮恶义。纵恶不顾善无父母义(云云)。从当正治罪下二十四行三句更广说六义。当正治罪即父母义。诸天护持即天子义。以灭恶法即魁脍义。魁脍名典军。遮制恶鬼。鬼畏典军不敢乱行也。修习善法即执乐义。应各为说即示因果义。诸天即分德义。还以六义消文。皆可寻(云云)。此中应明观义。自思之(云云)。问金光明是正论本。其意云何。天者即法性金也。法性作依止故言天护。分德者即光也。报身与法性冥。即是分德也。神力所加者即明也(云云)。又父母者即金也。法性为父母故。遮恶即光也。执乐即明也。以此为本故能正论尔。如半名人王半名为天。为世间正论。半名出世间正论。本末相关。即此意也

    释善集品

此转轮王集众善法如海导师。善海无涯六度则摄。六度又广。二度略摄。谓檀与智。提如意殊舍四大地。满中珍宝以用布施。即集檀行也。合掌而立请宝冥尊者。宣扬显说是金光明。即集智行也。檀智既然。余法亦尔。从行得名故称善集品也。此六度不同是世界悉檀集善也。修于五度是为人集善也。修于智度是对治集善也。皆波罗蜜是第一义集善也。从此四集得名故言善集品。此品是第二人王弘经。上明世间正见感动天地。此明出世正见感动贤圣(云云)。文为二。初对告地神。二以偈说。偈有六十四行半。分为二。初四行通明因地行檀。次六十行半别名善集施财施法。别为六。一六行半明事本。二十一行半明圣王请法。三十九行半明尊者宣扬。四十行半明轮王行施。五二行结会古今。六十行半引因果以证以劝。悉如文。就此品论金光明者。善集波罗蜜金也。集般若光也。集五度明也。就宝冥论者。在一窟中金也。面如满月光也。读诵如是经明也。就二人作者在窟中金也。许为王说光也。王提如意珠雨四天下珍宝明也

    释鬼神品

鬼字训归。又云畏也。报多怖畏如阿修罗(云云)。又云威也。能令他畏其威也。神者能也。大力者能移山填海。小力者能隐显变化。此品通列一切天龙江海日月诸神。上已天题品竟无容再出。虽通列诸道。而鬼神文多。从多故以之题品。此品是第三。一切天龙鬼神天灵地祇咸皆发誓溥遍弘宣以劝流通。文为二。一长行二偈颂。长行中先举事别次圆供养。事别者。佛从慈悲中起受供养者盖应佛也。佛从如中起觉智智与如合者报佛也。一切法悉是诸佛行处者法佛也。作如此解者三佛历别。若修事之供养。供养亦别也。圆供养者劝听经。听经是法之供养。诸供养中最为第一。第一供养者供养一切佛。能说文字是应佛。能诠是报佛。所诠是法佛。能敬文字即敬三佛。亦是敬三世佛。诸佛从此生。故供养文字即供养一切诸佛(云云)。又别时重闻更记之。长行举四愿欲而作一劝。若欲知佛行处。行处者即如如境法佛也。欲知者。知是如如智报佛也。能听此经。此经即文字。文字即应佛也。能听者随顺佛教即法供养。法供养即妙供养也。听经能生觉智。觉智生故即是佛受供养也。听经一事具诸愿欲。秪圆一事具别诸事也。偈有一百二行半。分为六。一从若欲供养下十一行颂上长行秪能听经即是举圆妙以劝修。二从随所至处下三行半举听经即能禳灾以劝修。三从于说法处下六行举听经致灵瑞以劝修。四从威德相貌下五行半举秪听经有威力以劝修。五从大梵天王下四十九行半举听经能致天龙鬼神以劝修。六从于诸众生下二十七行举秪听经能令国土安乐以劝修(云云)。蛊道者。四天上遣神名弥栗头虔伽陀。汉言善品。主蛊毒也。摩醯首罗余经翻为大自在。灌顶经翻为威灵帝。摩尼跋陀翻为威伏行。富那跋陀翻为集至成。金毗罗翻为威如王。宾头卢伽翻为立不动。车钵罗婆翻为忍得脱。昙摩跋罗翻为学帝王。摩竭婆罗翻为除曲心。绣利蜜多翻为有功勋。勒那翅奢翻为调和平。剑摩舍帝翻为伏众根。奢罗蜜帝翻为独处快。醯摩跋陀翻应舍主。萨多琦梨翻大力天。波利罗睺翻勇猛进。毗摩质多翻为高远。睒摩利子翻英雄德。波诃梨子翻威武盛。佉罗骞驮翻吼如雷。鸠罗擅提翻战无敌。脱因者脱业障也。脱果者脱报障也。度诸有者脱烦恼障也

    释授记品

有四种授记。今是二种(云云)。授者与也。记者记成道事也。此中授三大士一万诸天当来成佛事。故言授记。亦名授莂。亦名授决。授劫国数量名为莂。审实不虚名为决。从佛所与名为授。从其所得名为受。此中从佛所与故言授记。此是流通中第四意。举昔行经之因。方成圆极之果。证弘护不虚以劝流通也。文为二。一与记。二疑记。与记为二。一与三大士记。二与十千天记。与三大士记又二。一同缘者集。二正与记。世界转名净幢者。应论四句。此中是其一也。十千记又二。一闻经生解。二正与记(云云)。从尔时道场下是第二疑记。又二。一疑问二佛答。疑者夫移山填海非一日之功。菩提极果积行方克。忉利暂下无久听之劳。不闻往昔有难思之行。行浅记深。是故疑惑。如余菩萨者。六度菩萨引锥指地无非舍身命处。戒忍禅智满三僧祇。若通教菩萨从假入空非止一世修行。从空入假动逾尘劫。若别教菩萨直行一行。动经无量阿僧祇劫。况复遍行众行。量不可数尚不获记。少时闻经而得斯决。时众咸疑。故树神发问也。佛答为二。一举现行。二举远缘。现行者。舍天宫乐故来听经。闻三大士获菩提记。我昔本誓与其法食。三事和合故与其记也。此意证成鬼神品初以妙供养供养三世诸佛。及欲得知诸佛行处。决定至心听此妙典。虽有此旨未见其人。今此十千即其人也。闻记当果果必有因。因金光明生殷重心起功德身。心无垢累起般若身。犹如虚空。起于法身一心中听三德圆成。复有无量功德。说不可尽。此不得记。记与谁乎。证听功德意在于此。以随相修指今现行。行随实相而修也。有妙善根指于远缘也。违缘实相而种善根也。从亦以过去下是举远缘答也。文为二。一略二广。此中少文是略。除病流水两品是广答也

    释除病品

广答远缘。由医王救疾故言除病品。通取后流水品。文为五。一缘本。二远缘。三近缘。四结缘。五会缘。从佛告树神下明缘本。如文。从像法中下明远缘。远缘为六。一明父。二生子。三国人遇病。四其子请。五父为说。六知已遍治。子请为三。一见人过病。二思惟。三正问。问为四。初一偈问四大增损。二问饮食犯触。三问治病医方。四问病动时节。身火不灭者。食饱热病惭息。食消热复更生。故言身火不灭也。水过肺病者。水多则损肺。即是痰病也。父医还答四问。初六行答四大增损。二一行半答饮食犯触。三二行答病动时节。四八行半答治病方。就六行中分二。初一行是佛叙父医欲答尔。次五行正答时节。时节有二。一俗法四时。谓春夏秋冬。冬为岁末春为岁始。而初言夏者。或可趣作此言。或可答问正是于夏。三三而说者。一时三月。谓孟仲季。四时即十二月也。若依佛说法。一岁三时。谓冬春夏。夏为岁末冬为岁始。何故尔。为破诸弟子着常。为开安居迦提月。故没秋时尔。佛法三时亦是三三说也。若二二说足满六时者。依俗法四时。时本二月土寄四季各十八日。本之二月只是阴阳二月。一时唯有阴阳二月。合成六时。正月二月是木王时。四月五月是火王时。七月八月是金王时。十月十一月是水王时。腊月三月是阳土寄王。六月九月是阴土寄王。欲论本月亦二二说。若论土寄王亦二二说。故言足满六时也。若依佛法解二二说者。佛法有三时。时有四月。各有初分后分。后腊月十六日至二月十五日。此初分春时。从二月十六日至二月十五日。此二月春后分。从四月十六至六月十五日。此二月是夏时初分。从六月十六至八月十五。此是夏后分。从八月十六至十月十五。此二月是冬时初分。从十月十六至腊月十五。此二月是冬后分。故言若二二说足满六时也。又云。正月三月是阳月。二月四月是阴月。五月七月是阳月。六月八月是阴月。九月十一月是阳月。十月腊月是阴月。故言若二二说足满六时。三三本摄依俗法者。正月是春分本月。摄后两月悉属春分。四月为夏本月。摄后两月悉属夏分。七月为秋本月。摄后两月悉属秋分。十月为冬本月。摄后两月悉属冬分。三三本摄也。又云。正月二月正是春时木于中王。土寄三月摄属春时。四月五月正是夏时火于中王。土寄六月摄属夏时。七月八月正是秋时金于中王。土寄九月摄属秋时。十月十一月正是冬时水于中王。土寄腊月摄属冬时。土寄四季正时为本。各三月并摄于土。故言三三本摄主摄于客。客是土也。依佛法言三三本摄者。本时各三月。既废秋时。以秋之三月各配入三时。时则四月。论本则三。论摄则一。故言三三本摄也。问四时各有三月。此是四三本摄。何谓三三本摄。答三为一数。以三而数故言三三为本尔。随是时节消息者。时如上说。或四或三或二或摄等种种不同。随时以意消息斟酌去取。若依佛法。无秋时。而言秋时发病。此云何释。从八月半已还随俗名秋。而夏时摄。八月下半以去随俗名秋。冬时摄。随时消息者。二法之间而斟酌也。代谢增损者。春动肝病此可治。春动脾病此难治。夏动心病此可治。夏动肺病此难治。夏末冬初于秋分中动肺病此可治。若动肝病此难治。冬动肾病此可治。若动心病此则难治。论四时增损大略如此。问四时皆动病。何故去秋时。解此为二。一为破保常。秋时万物结实。人计为常为乐。为破此着故去秋时。佛为弟子保常心多故也。二者为开后安居立迦提月。安居本名坐夏。八月半内已还若是秋时。便是坐秋。为此义故。故废秋时尔。从有善医师下一行半答犯触。犯触有六。一多坐。二多眠。此二多致痰。宜多行猗散之。三多行。四多猗。五多语生风病。宜多眠治之。六多淫生一切病。即等分病也。若火少痰多。若火多即热壮。若风多吹火成热病。若风多吹痰成冷病。三事若等无病。饮食得病者亦有六。一过量食。二少食不足而止。三过饥食。四逆时食。未饥强与也。五妨食。如食肉饮生乳使人癞。六不曾食而强食。如南人饮浆北人饮蜜。若菜和蜜令不结男。猪膏煎白鹭肉令人癞。若患热而饮酒。食小麦生牛肉。令人失明吐血痢血。若病痰而食甜肥碱酸。令人[口*束]鼻多汁。又[病-丙+帶]痢也。六大者是六腑。大肠小肠胆胃三焦两膀胱也。从多风病者下二行答病起时节。四月五月是风生时。六月七月是风起时。八月九月是风灭时。六月七月是热生时。八月九月是热起时。十月至正月是热灭时。八月九月等分生时。十月十一月是等分起时。十二月正月是等分灭时。十月至正月是痰生时。二月三月是痰起时。四月至七月是痰灭时。痰是水病肺也。夏日动风者。夏日毛孔开通。外风得入内风动也。热病秋动者。毛孔闭塞。热伏于内不得行故成病。等分冬动者。春时动水肺病不差。至夏复动风风病不差。至秋复动热热病不差。至冬俱动一切病故也。二月三月是痰起损肺肺病动也。从有风病者下八行半答治病方。文为三。初二行半未病前以药防。次二行明正以药治。后四行病退以药补风病夏服肥腻碱酸热食者。夏月毛孔开通。具以肥腻润塞之。令风不得入。碱酢性热能消水。令体坚实治于风虚。热食流汗引风令出。又治虚冷风不得进。冷甜是酥乳等能治热也。等分冬服甜酢等除风也。肺病服肥腻塞毛孔。令水不得入。热能焦水宣通故能治肺病也。饱食发肺病。食既多则肠胃盈满。故发肺也。食消发热者。如食沃润则热病伏。食消无润热病起也。消已虚疏风气入体。故发风也。风疏补酥腻。碱除风。甜除热。肺带风水。宜吐也。此中消文出嗔谛三藏疏中。从善女天下是第六知已遍治。文为二。一病轻闻说即差。二病重服药方除(云云)。观心者。三毒等分是内病也。数息不净慈心因缘是法药。宜闻法药得悟者。信行人病差也。作观研心得悟者。法行人病差也。眼是春时。舌是夏时。鼻是秋时。耳是冬时。身是四季。摄属诸时。妙好五欲增贪病。粗恶五欲损贪病。妙好五欲损嗔病。粗恶五欲增嗔病。平平五欲增痴病。违顺五欲损痴病。总三种五欲增觉观病。偏动三种五欲损觉观病。是为增损之相也。犯触者。违情犯嗔顺情犯贪。不违不顺犯痴。总三犯觉观。慢时即发嗔。求须时即发贪。僻解时即发痴。放逸时即发觉观。慈心治嗔。不净治贪。因缘治痴。数息治觉观(云云)

    释流水品

文云。一能流水。二能与水。与水者与安乐水也。一世安乐。二出世安乐。世安乐者。如象负水济彼枯鱼是也。出世安乐者。如发誓言。于未来世当施法食与菩提记是也。流水者。流除苦恼水也。一果报苦恼。二业因苦恼。流除果报苦恼。如治诸病人救彼渴鱼是也。流除业因苦恼者。授三归说十二因缘。赞佛十号是也。请父求方欲成流水之义。从王借象欲成与水之义。既有二能。那单以流水题品。文中既彰与水之义。题品须安流水之名。不烦于文二义双显。出经者之巧为若此也。长者者。如法华疏中十种长者义也。字者持水之子故言子也。此文是断疑中第三结缘之近由。近由又二。一弄引二正近由。弄引又二。一行恩布德。二国人称美。并如文。近由又三。一明眷属。二见鱼之缘。三正救鱼。如文。从未来之世当施法食下是第四正结缘。又为四。一发誓愿。二思惟说法。三正说法。四鱼改报生天酬恩供养。就鱼报恩文为四。一鱼改报生天。二天酬恩而下地。三王见光问瑞。四长者征教而定答。如文。报恩有二义。一事二理。事者真珠四边报水饮食因缘十号等四种泽也。理者准涅槃文云。施食令他得命表常。令他得乐是故得涅槃。令他得悟是故成自在我。如法求财是故得净。用四十千报常乐我净之恩也。第五结会古今者。昔佛疑鱼数树神定判十千。今神疑行浅记深。佛为说妙因缘。今昔相关是故结会也

    释舍身品

舍义甚多。财位寿命。独以身当名耶。此从正要得名。受者须身余则非要。施者正舍身余旁舍尔。故言舍身品。文为四。一问二答三众得益四结成。问者上闻大士治病救鱼实为旷济。小人小虫得二世益。时众愿闻亡身殒命感深契极之事。行苦而果乐可得闻耶。是故请问。佛答为二。一叙缘起。二正明舍身。缘起为十。一地塔涌。二大众生疑。三佛起礼。四树神问礼。五佛答礼。六命阿难取。七阿难述骨状。八命示大众。九奉命取示。十佛劝众礼。皆如文。从过去有王下是正舍身。文为二。一长行二偈颂。长行为四。一明本眷属。二舍身方便。三正舍身。四舍后悲恋。就本眷属为五。一明本眷属。摩诃罗陀此翻大无罪。文殊问经云。罗陀翻为中。摩诃波那罗或云此翻大度(未详)摩诃提婆此言大天。摩诃萨埵此翻大心。二游行。三各述相。四见产虎。五各陈观见。从作是念言我今舍身时已到矣下是舍身方便。方便为二。初述观解。二起誓愿。愿行相扶。适产七日者。见虎子头上有七点。知已七日。出山海经也。又云。七日眼开。又七日不食必死。虎儿垂死知是七日。或云。鬼神示悟。如树神数鱼。正舍身为二。一舍身。二感动天地。舍身后眷属愁苦。先两兄愁恼各说偈共向舍所。次父母愁苦。偈九十三行为三。初二行通明昔行。次别颂长行。三结会。初如文。我念宿命下别颂长行。四行颂上本眷属。上有述相陈观。今不颂。余皆颂。从时胜大士下二行颂上舍身方便不颂发誓。从即上高山下颂上正舍身感动也。从是时二兄下颂上舍身后眷属愁苦。从是时王子下颂上父母愁苦。从佛告树神下第三结会。结会为三。一结会人。二结会塔。三结会誓愿。说是经时下大众所益也。树神是名礼塔下第四是结问意

    释赞佛品

此品从能所得名。能赞是三番菩萨。所赞是一佛世尊。能所合标故言赞佛品。私谓三番菩萨是能赞。一佛是所赞。一佛是能赞。三番是所赞。三番是当佛。一佛是现佛。通而为言。皆是能赞皆是佛。故言赞佛品。次第者。因前十七品故有今品。何者。序品叙大体。如来游于无量甚深法性穷源极边。寿量品极果冥深合广能起大用。忏品劝菩萨。若欲修学当如忏品灭恶赞品生善空品导成。四王至散脂誓愿流通。说请者之功德。正论至善集明说者之功德。鬼神至流水说听者之功德。舍身明行者之功德。如是等利益出现世者。皆是如来大体大智大用金光明力。既善始令终。初中后竟。故诸菩萨等以赞赞佛称扬教及教主。故言赞佛品。此文为二。一经家叙陈列赞众。从此至彼金宝盖刹施三业供养。投地是身。同声是口。口身共畅意业也。二正说偈。合六十五行半。文为三。一二十行诸菩萨说。二十七行信相说。三二十八行半树神说(云云)。私谓其文有四。前三是能赞。后一是所赞。所赞又是能赞。能赞又是所赞。故文云。佛从三昧起。以微如音而赞叹言。善哉善哉树神善女。汝于今日快说是言。岂非所赞赞能赞。其文既明不须惑也。又是印成三番菩萨赞教。从序品已来快说如来果地大体大智大用菩萨修因也。上文有佛礼舍利。即果身礼因身也。今文有佛赞大忏大赞能请能说能听能行。皆是快说也。当知快说是果赞因菩萨也。即果口赞因口其义孱然。果意赞因意。任运例成也(云云)。问佛何处入定。此云从三昧起。答初将说经。佛游甚深法性。今说将竟故从三昧起。此经首尾皆在法性中说。其文甚明。若作入法性者。法性自在。四佛五佛同处各处。共见异见四来四去。一住一在随人所睹。皆无障碍也。观心者。诸菩萨三业赞佛。三业事可解。三观心者。观身不得身身空但有名字。名字无量。或舍身名檀。乃至身空名智慧。六度十度八万尘沙法门。名字即空。说空不定空。假非定假。非空非有即显中道。三观宛然事理六法皆悉具足。若无观慧事亦不成。例如三衣六物。若解其意三六俱成。若不解者。非但无六三亦不成。观心亦尔。若得理观六观六成。若不得意。既无理观事观亦不成。无六亦无三此之谓也。此大好甚广云云

金光明经文句卷第六


金光明经文句记

    No. 1786 [cf. Nos. 663, 1785]

金光明经文句记卷第一(上)

        宋四明沙门释知礼述

吾先师昔居宝云尝讲斯典。其徒繁会竞录所闻。而窃形卷轴。况笔寄他手反羁乎旷远之旨。至于援证经论辞多舛谬。予每一临文不能无慨。近因讲次忆其所领大义撰成记文。仍采孤山索隐中俗书故实。用为裨助。庶览者不以事相之关情。但思理观之为益。时天圣五祀腊月三日记

释题二。初正标题目。金等四字即所释也。文句二字是能释也。所释经题委在玄义。能释文句者文即经文。句谓章句亦句逗也。即以章句节其经文。令其诠旨各有分齐。故荆溪云。以由释题大义委悉。故至经文但粗分章段。题云文句良由于此。然立此二字盖谦辞耳。若观释经大义非少。又解诸经皆称文句。乃是通称。故以经题简之令别。二能说师号。住处得名如常所辨。二入文二。初定三分二。初的指所传。异于真谛所译七轴二十二品。故指四卷十八品也。世有足嘱累为十九品者谬也。以诸译本皆无此品故。二正判三分二。初引诸师判二。初总举不同。盈者进也。缩者退也。盖言诸师分割三分进退不同也。二江北下正明。初判三。初江北师。以四王等各于佛前发愿拥护说听之者。故云大誓护经。流水长者除病救鱼。萨埵太子舍身饲虎等。为大悲接物。此师之意与下真谛新旧虽异大意是同。二江南师。与今分节三分似同。但昧寿量半品属序耳。三真谛师二初判文。真谛三藏于梁世重译此经。名金光明帝王经。更加四品。谓三身分别品。灭业障品。陀罗尼净地品。依空满愿品。足谶本十八凡二十二品而出疏解释。故云新文等也。二真谛下明义。仍斥江南以授记除病悉在流通。故云后师弟因果等也。合云师因弟果现文似倒。二今师下示今师意二。初约理破诸师二。初总斥人情。正斥真谛义兼江北。以此二师判师弟因果。并在正宗。意谓序分全未辨说修证之道。至流通分道味已歇微末而已。故总斥云是义不然。二夫三下别示经意二。初立意二。初明三分互通。杜塞也。三分共成一经感应岂得义理互不相兼。如初序分叙述发起。若不阙于下之二分。何名正通之序。正是序中所发所述。复是流通所宣流布。不尔何名一经正说。流通一段。若舍序正为通何法。是故三分各具三义。上中下语即七善中时节善也。妙经云。初中后善。若其杜绝何名善耶。二又众下众机遍益经所被机益有迟速。不必皆在正宗悟入。故云根性不定。何容序分全无法味。通中法味歇灭微末耶。既其不然。于流通中说流水因及信相果。复何所妨。弥益也。督率也。励劝也。二又法下引经。师即释迦也。达多品中明佛往劫以国王身事阿私仙求大乘法。故曰师因。持品授记波阇耶输等成佛劫国即弟子果。古诸法师判法华经。自法师品后皆属流通。而人共许。此与江南判今流通有师弟因果。其意齐也。故云与义无妨。然不可定执故云与夺由人。二今下据义分今部二。初分经二。初定三分文。今分三分大同江南。但序盈半品。故引三师但破真谛。二序者下示三分义二。初正示。将者当也。正宗流通在序分后。今序当有二分之益。故云将有利益。正当机者当是对义。即正对机缘辨说常果忏赞之道也。筌鱼笱也。罤兔罝也。筌罤喻言教。鱼兔喻义理。欲使言教流至将来。正像末时常令群生取于义理。故云不壅于来世也。二经曰下引经。二疑者下释难二。初立难。既称序分。合齐序品。安得复入正宗寿量半品余耶。二众经下释通三。初引他部例。净名经以佛国因果以为正宗。既无序品。诸师乃将佛国半品而为序分。若大品般若序品中云。佛知众会已集告舍利弗。菩萨欲以一切种智知一切法。当习行般若波罗蜜等。如此说者已是正宗。而文在序分。若涅槃经常寿为正。既无序品乃以寿命品中集众为序。此约北本也。若南本者谢公治定。乃取寿命集众之文。题为序品。此等三经或序入正。或正入序。诸师分解不以为疑。安得独疑今判序分入寿量中耶。二斯乃下明此经意。斯乃出自集经者节品之意。盖以若将寿量品题。于天龙集信相室后安者。则令四佛断疑之文孤然而起。故云崭绝。崭锄衔切。崭岩山貌。若文孤起则如山岩之险绝。不相连属也。为此之故安寿量题于序段中也。三今从下约今意结。品虽属正义当序分。岂顺标题令义失耶。二序有下至释经三分也。初释序分二。初释品题二。初释序二。初标三义。经之序分义合有三。诸部之中或秖一二盖阙略也。今经与法华等诸大部中皆具此三。二次绪下释三义。绪谓茧之绪也。凡茧之抽丝先抽其绪。绪尽方见其丝。今以五事在初如丝之绪也。冠去声呼。叙方将述当益。盖言叙述当时有正宗流通之益。故此序述下一十七品也。发谓开发物机之信也。起谓兴起圣应之教也。此序即以现瑞骇动物情。令信心颙颙教必深益。三品者下释品二。初举梵翻名。二品是下就名释义二。初正释。此中文句俱在经也。以能诠教皆用四法。谓声名句文。此有二种。佛世灭后。若约佛世八音四辩梵音声相。此一是实。名句文身但是声上屈曲建立。此三是假声属色法。名句文身属第三聚不相应行。毗昙十四成论十七瑜伽二十四种。此则大小二宗所立有异。名句文者。唯识云。名诠自性句诠差别。文即是字为二所依。若约灭后诸圣结集。彼土贝叶此方黄卷。其中所载名句文者。皆依形显色法建立也。今略举此二具足应四。气类相从者。如以四法同明发起等义。故节为序品。乃至同明赞佛之义。故节为赞品。今虽释序而品义贯下。二引例。律论二藏文句气类。咸有篇聚犍度之节段。犹经之品类。篇聚者。谓五篇六聚。一波罗夷。二僧残。三波逸提。四提舍尼。五突吉罗。此谓五篇也。于僧残之下加偷兰遮。即名六聚。若于吉罗更开恶说。复为七聚。毗昙者。具云。阿毗昙。此云无比法。即论藏也犍度。此云法聚。亦以气类相从之法。聚为一段也。如八犍度论。谓一业犍度明三业。二使犍度明百八烦恼。三智四定五根六大七见八杂。思之可见。二从如下释经文二。初分三序。此虽分三。至下消文。但束为通别二序。二释三序三。初释次序二。初泛论名数二。初明数不同二。初正明数开合。地人者弘地论师也。六事者。一所闻法体。二能持人。三闻持和合。四说教主。五依止处。六闻持伴。或七则离于我闻。或五则合于佛处。二兼示众是非。此经正谈常寿之宗在信相室。故诸天龙及诸菩萨于此集听。说竟四佛不现。理合其众退散。灵山说序梦中金鼓。时处既异故皆不闻。约听常寿得是同闻。不预梦等故非同闻。以说此经时处不定。故同闻众不如诸经安布次比也。若义净新译最胜王经。列同闻众不异诸经。大师悬知梵本将至故注云云。二此之下立名多种二。初列释异名。凡有六名。皆上句标名。下句释义。印定义者。以如是等文如世符印。见此冠首知是佛经。故大论云。非但我法如是。三世佛经初亦然。为通名作本者。金口所谈皆安如是故通名经。经后序者。结集时在说经后故。经前序者。以佛遗嘱令安经首故。大论云。佛将涅槃。阿难问佛。一切经首当作何语。佛答阿难。应云如是我闻一时佛在某方某国与某大众。破邪序者。以一切外经皆以阿沤二字冠首。阿之言无。沤之言有。以其所计此二为本。显于部内不出有无。故立如是对破邪执不如不是。证信序者。大论云。何以不直说般若而说住王舍城。答说时方人令人信故。二天台下结归四悉。天台师者。章安对彼旧解故称智者为天台师。四悉檀者悉是华音以遍为义。檀是梵语此翻为施。诸佛圣人常以欢喜生善破恶入理四种之益。遍施众生。斯是感应之通相也。此之次序金口令安即是应也。即被灭后一切机缘即是感也。而其一序有六名义其意如何。今以四种悉檀收之。则一一名义皆有所归也。故初二二名是世界益施众生也。三四二名属于为人。第五破邪是对治法。第六信理属第一义。此四既未判于深浅。即当四教各具四也。二旧解下正释经文二。初依经释五义。二明阙同闻意。此依地论师六事分文故。若依五事现文唯四。就初为五。初释法体二。初旧解二。初引诸师释四。初旧解。二肇师。三真谛。四龙树。其四文义皆悉可见。至判四悉方定深浅。二此之下以四悉判。今明圣法若多若少若总若别。无非感应。感应不出四种悉檀。前判次序六种名义。是总是多。今判六事一一感应。是别是少。故如是二字诸师异释。今天台师用四悉檀而会释之。各得如来感应一意。岂同世诤是一非诸。旧解二字虽对文理。不分大小其语通总。又无生善三益之相。但得授受不谬之益。故属世界也。肇师虽有会理之言亦不简真俗。但生信顺资禀之善故属为人。真谛文理亦未分别。而论决定离增减恶故成对治。龙树信顺虽同肇师。而言信者言是事如是。此则能彰三谛之义。是事即俗谛。如即真谛。是即中谛。此于一句巧示三谛当第一义也。注云云者令如向辩。二今作下今释二。初约教。二观心。此之二释即教观二意双美而谈。迥出诸宗功由此也。初文分二。初通。约说约传明如。约解约受明是。此既通释。贯下别释必该四教。故知法相是四所诠。佛是宣说四教之主。阿难是四闻持之人。当分而言四皆海量。二别释三。初迭明破立四。即是四教一一破前不如不是。方立本教如是之义。初破邪立正。破外道邪显三藏正二。初破邪。阿沤称吉者。百论明外道问内弟子云。佛说何法。答云。略说二种恶止善行。外曰。汝经有过初说恶故是不吉。我师经法初说吉故。如广主经等初皆言吉。以初吉故中后亦吉。故曰阿沤称吉也。文乖等者。以正破邪不如不是。经初标吉而部内所诠唯是邪见。此文乖理非如也。邪见则不吉岂称阿沤。此理异文非是也。故百论破云。是吉是不吉此是邪见气也。二文如下立正。三藏教中文理相称。以无常生灭之谈称无常生灭之理曰如。此理称文曰是。二今谓下破异立同二。初破异。欲彰衍理先斥藏非。实有之俗而为能诠。不即真谛故非如也。所诠之真不含中理浅故非是。二摩下明同。通谈幻有当体即空不异名如。即空之真能含中道。不同三藏析空定浅故理名是。通教必通别圆二教。故文标云摩诃衍也。三今谓三下破浅明深二初破浅。欲明别理先斥通非。通教三乘同闻即空。而钝菩萨同二乘解。利根闻空不但空有兼能空空。既此各解望别非如。空中两证证空尤劣比中非是。二明深。别教不通二乘修学。虽复广摄微尘之众。唯菩萨根皆闻佛性次第修入。既无异解故得称如。无不证中故称为是。四今谓离下破离立中二。初破离。欲明圆理先斥别非。别虽谈中中唯佛界。虽复变造九界因果九非性具。须缘中道次第断尽方成佛界。佛与九异故不名如。初观出俗次观出真。至第三观双出二谛方证中道。中不即边故非是义。二文字下明中。能诠文字性本忘离。与理不异故称为如。唯空唯有唯色唯心。一一皆中无非佛法故名为是。文如理是义究竟成。二初破下结成四教。问前释四教通真含中得名理深。今结四教别教乃云破浅明深。岂可通教真中俱浅。答通理虽深。为摄二乘及钝菩萨故兼浅理。今结别教独菩萨法唯谈深理。故以唯深破于兼浅。与前列释义不相违。三此经下示部具四。二观心。以圆三观观于阴等。修恶之心即是性恶。名恶法界无法不收。体是三德复名三谛。称谛而照观境不异故名为如。境即正观者。境是本觉起为始觉。虽分新旧觉体不殊。故得名为境即正观是义方成。若不尔者境照境等四句岂立。经言等者。若观顽境偏小忘心假立真如等皆名邪观。今兹正观虽非约行。行人若欲摄事成理即闻而修。必须于所观心简于十境。阴境常有余九待发。于能观观须识十乘。上根修一。中根至七。下根具七。若自未解摩诃止观。当依师友一一咨询。明识药病方可修之。勿谓一句修行即足。下去观解准此应知。二我闻下释闻持二。初旧解三。初旧师。外人我见故多师心。阿难师佛故唱我闻。二真谛。我能受持佛所说法故是器义。简三非器显成三慧。虽未分于四教慧别。然释我闻尤过旧解。三释谓。彼明耳识从四缘生。一空二根三境四作意。今云不坏是根。可闻处是境。谛听是作意。唯阙空缘。下云因缘和合义可兼之。即四缘和合方发耳识。不言耳闻称我闻者。我是耳主故。新云耳识九缘生。备于唯识也。二师释下今释二。初约教释二。初我闻各释二。初明四我。此我我等例于大经生生等四句而立。然我是假名揽阴而有。阴法既有生生等四。我随实法岂不然乎。如释生生云大生生小生。此乃生灭生于生灭。揽生灭法成生灭我。故例生生成于我我。虽是空观而非体空。是故三藏当于初句。又复应知假实生灭众生本尔而不觉知。今禀此教称本而观。岂唯此教。下三皆尔。通教实法生即不生。故阴中我即无我也。故属次句。别人知阴不生而生。是故观于无我而我。盖由此教元知真我。见慢盛故。初观无我次破无我。建立于我后入真我。是故此教当第三句。圆人即达现前假实不生不生。揽常住阴而成真我。我既即中二谛皆趣。故云我无我而不二真我义。是故此教当第四句。教本被机故四我义配四根性。令后说者如上分别故注云云。二明四闻。我是闻主闻是我用。主是假人用是实法。然若解生义则闻义自显。但生是总论缘起。闻乃别从说听不无少异。从闻因缘而有余闻故曰闻闻。既从缘生终归坏灭。此闻生灭也。闻无四性当处无闻故曰闻不闻。此闻无生也。真虽不闻俗中有闻故曰不闻闻。此闻无量也。二谛即中故云不闻。中亦叵得复云不闻。四十九年不说一字。何有中边而可闻耶。此闻无作也。注意同前。二有四下我闻共释三。初闻者四能。三藏教中阿难一身而有四德故受四名。典藏出阿含。余三出正法念。今演小名对于四教义与名合。阿难梵语欢喜华言。佛成道夜生举国欢喜。因以为名。从缘立名符生灭法。传持三藏宜用此名。通教所说体事即理。异凡俗见宜用贤名。别教五谈尘沙佛法。多所主领宜典藏名。圆教始终诠法界理。既深且广宜用海名。二欢喜下能承四佛四。初三藏。此教析法空不含中。故见佛身唯是丈六。二贤阿下通教。观既体法显二种空谓但不但。钝根菩萨同二乘人唯见但空。无中实故非色心本。故佛元由誓无残习。幻出身智终归灰灭。色有分齐故云丈六。若利菩萨受别圆接解不但空。空是本觉中实之体。是妙色心佛位证得。所有身智称体无边。故名尊特尊崇奇特。亦名报身。秖一佛身由利钝机见二种状。故云合身。通教佛身须作此辩。应了钝根见佛纵高十里乃至百亿。以依但空亦非尊特。有分齐故。若利人见丈六八尺。既依中道亦无分齐。是故下文金龙尊王偈赞三十二相。文句解云正叹尊特。三典下别教。此教初心便闻但中。中虽不具九界依正。非无佛界妙色妙心。是故见佛唯无分齐尊特身也。此教始终不共二乘及住空菩萨修证故也。四海下圆教。此教所说世间相常。故一切法无非中道。虽与别人同见尊特。彼兼别修此皆性具。故龙女云。微妙净法身具相三十二。欲彰全性是故从胜特名法身。故此教人观性德苦乐而兴与拔。以即理毒害为所消伏。修德三因名性德行。报应二身即名法身。盖欲以性而泯于修。苦则即拔无拔。毒则即消无消。行乃即修无修。佛乃即证无证。阿难传此无作四谛即说无说。是故亲承法身佛也。三此下部有四机。问上明四教今那但云三乘说听。答以三乘中声闻缘觉须论藏通。若明菩萨须该四教。三乘总论四教别辨。听既三乘说必四佛。既一音各解亦一身异见。前明合身其意在此。二观下约观心解。以上我闻各四句义。就于行者心观辨之。攀上等者。是有漏禅六行观也。攀上净妙离厌下苦粗障。约于九地迭论上下。我我闻闻是三藏中生灭俗境。前约三乘知解生灭观之入理。今就凡夫不知而修但成世禅。既是俗境知与不知法本生灭。故当生生句。今宗解之或从所化机。或约能观观。析体二观俗异真同。前约俗异故将析法别对初句。今就真同故以析体共对次句。后之二观不殊前对。又前约教我闻四句可对四人。今论修观须就一人一念而照。故释签一心三观于一念心见四四谛。尚具四趣岂阙世禅。故说必次第约人辨相故。修无前后唯成圆观故。三一时下明和合二。初旧解二。初肇师。启开也。运谓时运嘉善也。会合也。即是机应善合之时也。二三藏下真谛二。初叙彼立义。此解同肇以合释一。而但就机论不高下合应之心也。若谓众生心不高下中平之时。即是与佛合一时也。故云平时即是一时。二私下章安释成。言私谓者。大师灭后顶师记录。此文句时自加此释。事非公灼故言私也。盖虑后人不解真谛高下之义。故为释出。高谓慢心自恃陵他不能奉行佛之道法。故云慢心不行。下谓耽恋五欲荒迷不舍何能受道。此之二心最为道障。欲令今人不耽不慢修于平时即感圣也。二师下今释二。初约教二。初约因缘总释。感应因缘合一之时也。不明感应与谁论一。未分三谛浅深之别。故当总释。二亦下约谛智别释二。初释时。问谛智但在机感应该生佛。双只既不同如何论总别。答智即是机谛即是应。智谛合时名感应一。何者。佛以三谛而为其体。不以此体应于众生。众生无由智合于谛。如须菩提石室观空。释迦叹言得见我身。岂唯谛理诸善亦然。如云若持五戒释迦如来在汝家中。故知佛以三谛诸善而为体相。众生修善见谛理时。即是感应合一时也。今明三谛即摄四教。如常所辨。二而言下释一。即前谛智合一之相也。先简不合。谓前思后知此乃觉观虚妄之心。若智发者思觉俱寂豁尔开悟。方与谛一故言一时。四教谛智一相皆然。二观解。前约教解是佛会开悟。今约观心是灭后造修。前分四教今在一心。文同意异。四明教主二。初旧解二。初真谛。未破无明名小菩萨。若证法身分显三义故不被异。三乘异外故但一义。菩萨双异外道二乘。故得二义而未平等。佛尽能异是故三义具足究竟。二释论。世尊当十故佛第九。此就合说。若调御丈夫开为二号则佛当第十。十号具足名世间尊。此是能觉。其所觉者。即世间等三双法也。初双约凡圣。世则六凡法。出世则四圣法。次双约小大。无常则凡小法。常则大乘法。后双约思议不思议。六凡三教是数皆可思议法。唯圆非数是不可思议法。此等法门于一心中朗然顿觉。故名为佛。二今释二。初约教。佛既翻觉。而有三身即是三种觉智所成。若一切智成于三藏丈六佛。依道种智有二佛者。此智论于界内外故。界内道种成于通教但空丈六。以钝菩萨为空出假故。界外道种成于通别但中尊特。以二菩萨为中出假故。一切种智成于圆教及通别教诸法趣中法身佛也。虽被四机秖是三佛。此之三佛不可定一无差即差故。不可定异差即无差故。须忘一异是秘密藏故。而论一异跨节当分故。二约观。三观所觉皆云诸法者。一一觉于三谛也。故空觉三谛差别情忘名第一义空。故曰一相。假觉三谛皆能立法名如来藏。故曰种种相。中觉三谛遮照同时名第一义理。故曰无一异相亦一异相。前约教释故以三智别示三身摄于四教。今既约观须唯在圆。圆观若成四教三身。不求自获。尘去鉴净像现随形。令此分别故注云云。五住者下住处二。初双标。佛能住人也。城山所住处也。人必有法以为能住。如世恶人必以恶法住于家舍。善人善法住舍亦然。今云佛住王城耆山。岂得不以首楞严定为能住法耶。故普贤观云。释迦牟尼名毗卢遮那。此佛住处名常寂光。牟尼是人寂光是法。此之人法自可分于能住所住。若望山城俱为能住。山望寂光为所住处。处随法转。其犹还丹点铁成金。故摩竭提阿兰若处名寂灭场。今之城山岂其不尔。故知不辨能住心法。但云色身住于土石。则大小心境之谈便成无用。是以双标能住所住其有旨乎。二真谛下双释二。初明能住法二。初旧解二。初真谛。此师释住不但色质住于城山。故明八种能住之法。一住大千显能住化广。二住依止显今能住。三住五分显于能住无漏五阴。五分者。谓戒定慧解脱解脱知见。谓无学道共戒灭尽定无生慧有余解脱照解脱智眼名为知见。谓自知是初果乃至四果也。是则前三并在于果方名法身。言寿命现在者。以入无余则五分灭故。灰身则戒定有余解脱灭灭智则慧及知见灭。故寿命现在五分得住。四住威仪行住坐卧皆有法则故能利物。五天住住禅定者。禅则四禅。定谓四空。是色无色二界天法故。六梵住住四等。众生无量我心常等故。四禅加修慈悲喜舍生梵天王。故云梵住。文无喜舍略也。七圣住住三三昧谓空无相无愿。此三圣人所修故云圣住。八大处住即常寂光言虑已绝。故云第一义也。此之八义皆是如来能住法也。二释论。大品云。佛住王舍城。龙树约四义释能住法。谓天梵圣佛也。真谛八法不出此四。是故大师以四摄之。论中天梵与真谛师天梵二住名义全同。而言定者四等定也。此则以二摄于二也。圣住与真谛圣住名义全同。而更摄得五分寿命。此则以一摄二也。佛住与真谛大处住名异义同。以一摄一。此则论四已摄彼五也。而论复云。于四住法中住圣住佛住法怜悯众生故。王舍城住今云迹住也。此义复摄真谛三住。以王城是依止处故。王城在大千界内故。四威仪不离王城故。问佛能住法是首楞严。论何须说圣梵天三。答如来自行实在楞严。为利他故住余三法。心若不住梵天等法口岂能说四禅四等。是故妙乐明论四住云。从广之狭将胜摄劣故。天摄机宽佛摄最狭中二迭论。故云从广之狭。佛住既胜无善不摄。故圣等三是凡小善明所摄耳。二今释二。初教。论明四住其义犹总。是故今家明四教佛住于三谛。复论兼独住法明矣。三藏所诠析法观拙。故成佛唯丈六身。但住真谛。通教所诠体法观巧能证二空。故所成佛随利钝机一身两见。丈六住真尊特住中。别教诠中修次第观。故所成佛唯一尊特。以须别修缘了庄严。故使此佛双住俗中。圆教诠中中具诸法。因中万行不修而修。果上万德成无所成。故即报应名为法身。唯住中道。前三教佛岂离法身。今就当分明四差别。是故四佛各以住法住于城山。二观。于一心中圆修三观住于三谛。以此住法住所居处。若念念不休即观行佛行住坐卧。经云。此处皆应起塔。即此意也。二王下明所住处二。初城二。初因缘释。此文虽略意亦可见。若欲备知当寻彼论。二观行释。上诸观解皆是附法。以如是等不借事义表观法故。此之城山是托事观也。如今王舍借覆盖义表于五阴。托自在义表善恶王。故妙乐云。以善恶王对无记舍。应知无记遍该八识。若善恶王唯第六识。以此第六通三性故。谓善性恶性无记性也。此无记性同余四阴为所观境。取善恶性为能观观。初心修观莫不用此第六心也。以由此心能起忻厌。分别名义作善恶因故。所言善者。对恶得名非究竟善。以此王数本由见爱熏习所成。圆名字人全未能伏。纵起善念不离见爱。故十境心皆名魔障。不思议观方曰善净。若直以此心观实相理。如用藕丝悬须弥也。徒增分别绝念无由。若体此心是性恶者。性恶融通无法不趣。自然摄得七八九识同为妙观。故得名为境即是观。能所既泯思议乃忘。圆妙之观初心可修。故妙乐云。忽都未闻性恶之名。安能信有性德之行。须闻性恶者。以知性恶故则修恶本虚。三观十乘无惑可破无理可显。修德功寂是无作行。故以性德召此行也。此意若昧徒说心王为能观观。终非圆观。岂前三教非善恶王为能观耶。又须了知非独城山以阴为境。诸事法观皆须观阴。故妙乐云。又诸观境不出五阴。今此山等约阴便故。以诸文中直云境智。记文既云诸观之境不出五阴。则知记事附法无不观阴。言此山等约阴便者。盖此山城表阴义便。故明言阴。诸文不便故直云境智。虽为不便不言五阴。而所观境无不是阴。故上句云不出五阴。直云境智。即诸文云。观一念心即空假中也。虽不云阴且一念心非阴是何。有人据此执诸观境不观阴者。违文背义过莫大焉。又僻执云。唯止观中从行观法得简阴境。诸事法观不得简阴。斯是胸情自立规矩。诸文观法既不出阴。简有何妨。况妙乐中观阴。须明方便正修简境及心。简境岂非去尺就寸。简心岂非去其思议取不思议耶。安得固违执不简阴。此人又执诸文托事附法观心不可修习。唯止观约行观法方可修之。乃引义例谕邪师文为据。彼文云。十二部观寄事立名。虽有三观之名十境十乘不列。一部名下唯施一句。岂此一句能伸观门。今人谓事法观心便可修习。不假止观者。岂不全同往代邪师耶。今评义例验此人说。全昧荆溪破立意也。何者。义例谕疑本为邪师错。谓止观十境十乘是渐圆观。唯顶法师十二部经观心之文为顿顿观。修之即得。是故荆溪如上谕之。其意但是破彼邪师。将顶法师十二部下观心一句。具足伸于顿顿观门也。邪师既以止观十境十乘。自是渐圆。终不肯用入十二部事观中修。岂得同于正解之师。讲至城山等观之时。学者欲修即叙止观方便正修拣境等文。成其法行。若然。岂是十境十乘一向不列耶。岂是独将一句伸观门耶。又何尝云事法观心不假止观便可修习。又不云城山等观是顿顿法。那斥全同往代邪师耶。又法华玄义示诸文观心令即闻即修。释签云。随闻一句摄事成理。不待观境方名修观。先祖垂范昭然可鉴。如何固执事法观门不可修习。此人又全不许得法之师叙于私记教人修观。须自深谙止观法门方可修于诸文观心。若其然者。修观行人则全不藉教授知识五缘之中。善知识缘全无用也。四缘宁阙善知识缘最不可舍。故大师云。自能决了可得独行。妨难未谙不宜舍也。经云。随顺善师学得见河沙佛。又备谙止观十乘等法是大法师。是大禅师。岂诸文中事法观心皆须此人方得修耶。作此谬说障传法者宣示观门。障初心人依师进行所损弥大。学者知之。二耆下山二。初因缘释。山峰之势似鹫之头。或云灵鹫。此鸟有灵知人死时故。又多仙灵隐其中故。说文云。鹫黑色多子。二观行释。若妙经疏先以三字对于五阴。次观三字而为三德。达阴即理也。今此文略直以三字表示三德。虽不云阴义当体阴而为三德。须知阴是见思报法。此乃修恶即是性恶而为三德。其善恶王若非性具。何能常住秘藏之处。心数尘劳若非性恶。何由能得同入其中。二此经下明阙同闻意二。初正释。时五处四者。一耆山说序时。二室内说寿量时。三梦中见金鼓时。四梦觉诣耆山说时。五列众至金宝盖山王佛国赞释迦时。故时有五也。以说序说梦俱在耆山故处但四。二若尔下释疑问意者。四佛说寿在信相室。阿难在灵鹫何称我闻。然虽下答也。报恩经中众令阿难为佛侍者。阿难从佛而求四愿。一不受故衣。二不受别请。三不同诸比丘须见即见。四所未闻经重为我说。佛皆许之。又其得佛觉三昧者。佛加觉力如佛故名佛觉。能自通达者不待重说也。然阿难佛成道夜生。年二十五方为侍者。已前之经准向两义尚称我闻。况近在信相室中耶

金光明经文句记卷第一(上)金光明经文句记卷第一(下)

        宋四明沙门释知礼述

二从是下叙述序。亦名别序二。初列二名。虽是异名亦有长短。述齐序品别尽初分。以有别序异于众经。故名别名名金光明。故知此序是别名本。二别义下释二序二。初泛示二序文相二。初别相二。初明七别二。初示七经文。二生起下明七次第。初入定者。大觉顿圆照而常寂。今之入定盖示轨仪令人乐定。次叙述者。既入妙定见法尊贵。即于此定叙述经王。言出叙者。实未示于出定之相。盖寂不妨照故云出耳。佛不出定即说此经。意本彰于寂中有照也。次怀疑者。既叙述法是佛所证。信相乃疑能证人寿那不称法。瑞应等次文显可知。二或时下明三别。大师有时作此分别。章安兼录与前七别开合异耳。二言叙下述相二。初正示叙述。叙怀疑者。思惟深义必合疑于所证法常能证寿短。叙断疑者。佛护本令断疑生信也。叙忏悔品者。正为破恶旁为生善故。叙赞叹品者。正为生善旁为破恶故。叙空品者。此品导成生善灭恶。今文偏叙灭三障故。大梵释天是散脂主。紧那罗等乃是散脂所领部从。经举主叙其品也。叙正论善集者。正论治园善集听经。此俱是秘藏流出。故以秘密叙二品也。叙授记者。彼由闻经心净若空故得记莂。今云身意无垢秽故。叙舍身品者。飱太子身既得解脱。显非邪食以活其命故。今正命一句叙之。叙赞佛品者。虽三番菩萨以偈赞佛。而此菩萨多是古佛。纵是实行亦是当佛。故今佛赞行人亦是当佛。故叙其品也。仿佛者。不分明貌也。薳音伟。远也。如云不得过自明分也。二问下兼示叙人二。初问起。二答示二。初叙旧斥非。旧有二师。一云阿难。斥云。是论非经者。以佛说名经。灭后三乘弟子所作悉名论也。经云。我今当说忏悔等法。岂忏悔法阿难说耶。岂非乖文。梦中金鼓是佛法身。以智扣之故乃随机说忏悔法。须知金鼓是佛真我故云我说也。二云信相斥云。若是信相玄叙始末不应疑也。玄叙者。玄与悬同。二又非下重问的示二。初的示师意。二难下难起答通二。初难起。若是佛说即是正宗那得称序。二此下答通二。初以因况果。不惟能詶是佛作序。兼显如来定不妨说。以法华文验佛叙述正在定中。岂千万偈局在正宗以况果佛口密赴机。岂但正说不作序通。是故结云何所不为。二文下引文证结二。初引当文证。二大下引大品例。彼经序中明佛出广长舌相放无量光。是一一光化成宝华。华上皆有化佛说六波罗蜜。彼既称序此岂正经。二释入下的从别序消文七。初入定别二。初标科。欲显能游人与所游法义皆明了。故节游字入其初科。须知释义不类读文。二是下随释三。初能游人三。初释是时二。初旧解。二今下今释。不用古人五种三时。但论佛鉴机得道时。又得道犹通。须约三智冥三谛时。方尽如来鉴机之相。佛欲等者。乃是化仪。非谓今日鉴照方知。二释如来二。初略示。二三藏下解释二。初指他广解。二今言下今从要释三。初约悲智释二。初约义释。法华文句三身各有如义来义。今以法报相冥释如。乃以应身出世释来。但使义成通别无在。佛若顺智应如秘藏。祗为顺悲故来三界。二成下引论证。能乘即智。如实道即理。来成即是慈悲垂应。二大下约智行释。虽但云来已具如义。以约福智来严法身。所严即如也。此是大经梵行品中解如来名。三释论下约说证释二。初引论。二今明下释成。本有之法妙真俗中而为其相。智称其解即法报冥故曰如也。称此如说是应身被机故名来也。前约悲智其义犹总。今明解说三谛法相释于如来义无不尽。三谛法相即三法身。法身圆也。称此而解即三般若。报身圆也。称此而说即三解脱。应身圆也。以今望前非无区别。三游者下释游字。即是如来以究竟智游入法性也。夫所证法性能证果智。义立能所体非相到。以始觉究竟即同本觉。唯真如智独存也。故若然者。其谁能入复何所入。住出皆然。引小般若意亦如是。今言游者。为引众生学佛入理故示入相。为令众生称理而住故示住相。甘露乃是不死之药喻常理也。为众生说此甘露味亦应言出。不出而出。出叙经王也。法华地涌诸大菩萨。于深法性百千三昧。不入而入名为善入。出住亦然。菩萨尚尔果佛可知。二无量下明所游法二。初明深广法性二。初直约文释二。初消无量甚深。将欲明示佛所游入。先须简显其体高广。乃以法界显其广。中道之法非界为界。此界无外故言无量。又以三谛显其高然。真俗二谛虽俱究竟。而乃通于二乘及遍菩萨少分而证。若其中谛非圆实智莫能证入。今明三谛体非优劣。乃是三德秘密之藏。即法性底故云彻到。方称经文甚深之叹。深即高义。须知法界与圆三谛无二无别。今取二名显无量甚深令易见耳。显已次简。若约二乘以圆简偏。若约菩萨以深简浅。降佛已还皆下地故。圆圣尚简。况三教耶。二法下消法性二字。上明高广是体之德。今明法性是德之体。释二字义显高广体。所言法者。轨则为义。诸佛轨之万德成就。故涅槃云。诸佛所师所谓法也。然此法性三乘六道谁不轨则而成立耶。以迷性具无事用故。虽轨而违故成三障。其犹七众谁不师佛。而有违顺故分缚脱。今就极顺用显所师。故云诸佛所轨名之为法。所言性者。不变为义。谓四德之体无迁易故。须知此四遍一切法。下至地狱依正因果。一一无非常乐我净。世间相常斯之谓也。二非是下更取义释三。初取实智所照释。尽智者。断惑已尽也。无生智者。惑不更生也。故俱舍释此二智云。谓无学位。若正自知我已知苦断集证灭修道名尽智。若正自知我已知苦不复更知。后三例说名无生智。瑜伽论以惑尽名尽智。来报不生名无生智。而此二智俱照偏空。略简二乘意该菩萨至等觉也。二乘法性非中道故浅。不具色心故有限。如实智者。释论明十一智。前十与二乘共。唯如实智则不与共。谓一切法总相别相如实证知无有挂碍。此智所照横包竖彻是今法性也。二又无下就即事而理释。深广法性是佛游处。又过菩萨所行清净。恐不达者谓今凡鄙依正色心因果之外。别有法性是佛所游。故特遮之。非别有法名为无量及甚深也。然一切处言须收三土。诸法合当九界因果。若遮那佛法唯净唯善。则三土九界染恶须断。云何得名皆是佛法。故当了知一切染恶无非性具。缘了佛性非专善净。性染性恶全是缘了。若此等法皆佛性者。则三土九界修染体虚性德十界。是圆觉体无所不遍。方曰遮那遍一切处一切诸法皆是佛法。有何一念一尘一人非是如来所游法性。故言无量。又须了知一切染恶当体幽邃。故云甚深。实非别有甚深之法。是故名为即事而真色香中道。以色香等迷情谓是色之少分。解则无非法界全分。以唯色唯声唯香唯味唯触故也。色外更有微尘许法则不名唯亦非中道。中道秘妙思议罔穷称为甚深也。三例如下引论等心类二。初引类。二准此下准释三。初明中谛无量。论明四等谓慈悲喜舍从心名等。从境名无量。此众生缘也。就其所缘方隅广狭得三重名。谓广大无量。今类彼说就真俗中而立三名。经示游于无量法性。乃彰中道圆融之理。非但空之真及偏假之俗。二若缘下明中必融摄。佛或对机用于权智偏照二谛。既不摄中故非游于无量法性。今用实智照中谛理中无不摄。故云若缘中道即三智一心等。是以中谛称为无量。三此下结境智相称。如法华云。唯佛究尽诸法实相。权实之理何有尽极。良由佛得无尽之智方能究尽。今亦如是。二乘下地智有限量。是故不测无涯之涯无底之底。二诸下释诸佛行处二。初法。学者应知本觉为处始觉为佛。全本为始始方合本。若不尔者。如何各称无量甚深。然初坐道场即已冥合。今为引物故示合相。乃云游于诸佛行处。二举喻。举行处函显能游盖也。三过下结二。初直约文释二。初据义略释。二引文广释二。初地持。九种禅者。一自性。二一切。三难。四一切门。五善人。六一切行。七除烦恼。八此世他世。九清净净。文中略示初后二禅也。其第九禅即从十地转入妙觉。故云一切通别惑累若正若习皆尽。自十地已还悉有正习。论解华严不开等觉。十地即等觉也。言通别惑累正习皆尽者。通即四住别即无明。通惑正使圆七信尽。习气至佛同别习尽。以今家于小乘习气分别四四十六门故。若别惑者四十二品断位如常。习气具如净名疏说。圆教始从初住终至法云。圆断诸见犹有习在。等觉入重玄门。千万亿劫重修凡事。见理分明习气犹薄事等微烟。彼引地持离一切见清净净禅。故但明见习。若引优婆塞经十地断爱习十地即等觉岂不入重玄耶。故知别惑断正使外更入重玄断于习气。文甚分明。二净名。佛复自性清净之心超于一切修得禅定。故云心净已度诸禅定。亦是到于一切禅定彼岸故云已度。二亦是下重取意释。佛不自高依法故高。今明高位意欲简显法性高深矣。二是金下叙述别二。初明述义异前。然前叙诸品岂出五义。以十七品唯谈三法总明别相及被物教。但为既从经品而叙名等不彰。故今明示序品经文备叙五义。使乎学者知此一经始末。唯诠名体宗用及教相耳。方知释题搜尽经旨。二初十下约文述义二。初分文。二解者下述义二。初叙四义四。初一句叙名二。初他解属体。矿石者。说文云。矿铜铁璞也。内外用者。光为内用自显体故。明为外用鉴他物故。此师亦知光明二字属于宗用金是正体。以其体用不相离故。虽标三字意在于体也。二今明下今定叙名。标三显一非全乖理故云当然。其如分文自有次句。的以中道而为经王。正是叙体。何须初句兼于宗用而叙体耶。学者应知叙名之句据上附文。释三字名非从喻立。乃是直名深广法性。以佛正游此之法性便即唱云。是金光明诸经之王。不名法性。是之一字为指何耶。智者深见经之微旨。故立附文及当体释。证于附文。先引此句云。创首标名弥为可信。既前附文特出此意。今释叙名不更显示。二经王下一句叙体二。初指上标今。上即玄文重明帝王。约摄法门摄教摄位。辨经王讫。今此更就中道明王。二三藏下对他辨正二。初明他解二。初叙。三藏意云。经题三字喻于三德。乃以三德分对三经。涅槃明佛有体解脱。正断二乘灰灭之见。般若谈空正为凡夫遣于有着。华严顿说法身之理被十信三贤。故云始行。上之三经各谈一德各被一机。若金光明具显三德。故能通被八位之机。解脱被二乘二位也。般若被凡夫通指人天为一位也。法身被菩萨信住行向地五位也。既无机不被即是经王统摄义也。二此下破二。初明违教旨。涅槃正谈深妙三德合被圆机。岂唯二乘。般若具示三种般若。岂异三德。况云听众非生死人宁止凡夫。华严三身亦即三德。具论十地岂但被于始行菩萨。此解不独摄机有限。抑亦彰法性非圆。二作此下明损行人。真谛此解。有识之者知其不当。无智之人谓彼三经劣于此典。起谤得罪安可依之。二今言下明今释三。初泛示诸部经王是非二。初约三谛定是非二。初示三谛。一代教部有取能诠文字为经。有取所诠义理为经。有取文理合为经。故一代经不出文理合与不合。若不合者。能诠之文但是俗谛不出三种。谓三藏实有俗。通教幻有俗。别教幻有幻有即空共俗。若所诠理但是真谛亦唯三种。谓三藏实有灭空真。通教幻有即空真。别教不有不空真。此六之内三种真谛体不具俗。但因三俗而得入真。俗终须灭合义不成。若文理合者不出三种。谓圆接通。圆接别。及正圆教。此三真俗其体是中。何者。圆教本自真俗互趣。若接通别所诠真理既诸法趣。局照俗文亦诸法趣。故此三种真俗不二。名文理合中道义成。以真即俗故真即非真俗即真故。俗即非俗。非真非俗言虑自忘强名中耳。问别教复俗幻有可是能诠之文。即空如何亦是文耶。答文谓文相能诠能显之义也。义若在通教空以忘相为所诠理。今于别教二边俱相乃为能显显于双非。是故空有俱为文也。问藏等七种俱名真俗。如何后三得名中道。答岂闻真俗便无中耶。如圆当教及接通别。此三真俗既皆名为不可思议。宁非中道。如涅槃疏释七二谛。于中三亦以中道为名。何独责此。问若取其义。别教真谛不空不有何不名中。答离边之中文理不合。初心不得思议顿忘。若望于圆但是复俗所诠真耳。故前文句释经如是对圆别云。破离明中。良以所诠不即能诠不名中道。文字性离无非佛法。方名圆教中道如是。问何故独遗别接通耶。答今以真俗对于文理。其别接通已在六内。何者。若未受接乃当幻有诠于即空。若受接后自属但中局照复俗。故据法体已在前六有何所遗。况复今文不显标云七种二谛。但明一代取文取理。取文理合有三俗经。有三真经。有三中经。如此明经收于一化罄无不尽。有人秖就金光明名立九种经。专据取字以为义本。谓若取着三字能诠之文。名三种俗谛。若取着三字所诠理体。名三种真谛。若取文理合谓不偏着二边。为三种中道。如斯说者。岂唯师心解义。无乃固违文意。前二取字作取着释。后一取字作不偏着解。是何言欤。大师为解诸经之王。故立九种收一代经。此经既说中道之王。故于九种而得自在名诸经王。何缘九种但在三字。乃是金光明自为金光明经之王也。既阙诸经全非统王。乖反至多且言此二。二若说下定是非。若诸部内有说前三能诠俗谛。有说前三所诠真谛。体不合者皆名余谛。但得是经不名经王。以其不明真理具俗。是故俗谛不即真谛。俗真俱无统王之义故非王也。若诸部内有说三种具俗之真。全真之俗。二谛不二名为中道。此中道外更无少法。如此经云。无量甚深法性。又云。不思议智境。又云。安住一切法如性。于一切法含受一切法。则所诠外更无能诠。能诠之外岂有所诠。文理既合中道斯圆。故得是经复是王也。乃于三俗三真三中九种经中而得自在。问三种中经体已是王。何故复云于九自在。答上辨九种乃是通约三俗三真三中。示一代经有偏有圆也。今判诸部随有一处说圆中道即是经王。能于通示九种自在。于三中经即是异名。其体既同故得自在。若余六经乃是圆中所用方便。如王于臣岂不自在。二但经下就中道显尊极三。初明诸部圆体为王。中道经王其体是一。随物宜乐立乎异名。故向文云。若说中道是经是王。何经说耶。即华严等四味之内。作法身等说经体也。然须简别四味之内是王非王。如华严部有三种经。其正圆中及接别中是经是王。正别教中是经非王。是故法身须简别中。三藏但空实有二谛是经非王。方等部内具九种经。正圆教中圆接别中圆接通中三是经王。故实相名通此三种。余六是经不得是王。般若部内无三藏二有七种经。亦同方等三是经王。得名佛母。余四非王。法华一圆是经是王。以开权故解髻与珠。涅槃九种皆知圆中无非经王。一切众生悉当成佛。其谁不以正因为师。故诸大部中道经王有此盈缩。秖一法性立此异名作诸经体。二譬下约历代人王为譬。诸姓者。谓三皇五帝之姓也。太昊伏羲氏风姓。炎帝神农氏姜姓。黄帝有熊氏公孙姓。此三皇也。少昊金天氏。颛顼高阳氏。帝喾高辛氏。皆姬姓。帝尧陶唐氏伊祁姓。帝舜有虞氏姚姓。此五帝也。故云诸姓也。应运迭兴者。应天五行相生之运也。伏羲应木运。神农火运。黄帝土运。五帝依次推之。龙师者。伏羲初立有龙瑞故以龙纪官。故左传曰。太昊氏以龙纪。故为龙师而为龙名。鸟官者。少昊始立有凤瑞故以鸟纪官。故左传曰。少昊挚之立也凤适至。故为鸟师而鸟名。随时霸立者。谓应运王天下也。百代虽异谓纪号不同也。统王是一皆天下主也。三法性下示随部立名合譬。名虽兴废体非增减。是故法身乃至佛师。一一皆于九种经中而得自在。即前谕云百代虽异而统王是一。二法性为下。的明此典经王体性。以文理合中道为体。斯盖通辨。若例诸部经体别名。此经的以法性之王为经体也。以佛游于深广法性。便即唱云。是金光明诸经之王。岂非的指所游法性为金光明名下之体。此体自在是诸经王。问三种经王皆得为于大乘经体。此经之体的属何王。答文诠法性虽在于圆。而许三乘依此忏悔。是故大师就圆释体。判教属通。义当圆教入通中道以为经王也。问净名玄云。若理内三种俗谛非此经体。三种真谛是法性实相得为经体。今云。若取文理合为经即是三种中道。且文理既合则真俗俱中。是则俗谛得为经体。将非与彼义相违耶。答彼此宛顺无相违也。良以经体未始离文而文不到。即事而真方为经体。以二谛判体则属真。三谛判之体当中道。斯乃示于心路绝处。方为经体。若藏通别当教亦云体绝言想。而皆所诠不具能诠。安得能诠合于所诠。故六种经文理不合。望于圆教实无绝理。是故大师欲彰经体示绝想门。云文理合是三中道为四味教所诠圆体。谈理具文。文方即理。理亦即文。文既即理能诠自忘。理既即文所诠叵得。能所既绝中体斯彰。彼明理内三种真谛皆是圆中。故与今文明体不别。如妙玄中引地论金刚藏说。空有不二不异不尽四句显体。辞异意同。释签问曰。空假如何得为经体。答云。既是不思议空假。还指空假即中中为经体。中即空假亦指于中。彼之四句不出三谛。以圆融故三谛各三。是则四句句句三谛。所以得名辞异意同。句句具中故皆为体。究论空假得为体者。由具于中故云还指空假即中中为经体。是故中谛虽具空假空假非体。故云中即空假亦指于中。问何不但云中是经体空假非体。于义已足。何故先明三谛各三皆得为体。复于三谛各拣空假。唯取于中而为经体。岂非繁重。答秖为单说圆义不成。作此融谈方彰妙体。何者。盖以空假是其修二即经宗用。中是一性即经体也。若但云中是经体者。则宗用外别有于体体狭不周。故须三谛无非经体。若不于三各拣空假唯取中体。则不能显体非智断。如此辨体不即宗用不离宗用。思议泯净妙体天然。中为经体圆妙既然。以例空假宗用亦妙。以空遍三谛此宗不狭。假遍三谛此用弥广。仍须三谛各拣假中显宗是智。亦须三谛各拣空中显用是断。各对二明不即不离。故皆称为不思议也。若然。岂独体是经王。宗用亦王。名总三王教辨四王。以一名一体一宗一用一教无非中道故也。故玄义云。文号经王教摄众典。教尚称王名等可见。既法法皆中无非经体。复须简显名是能诠宗是自证。用是化他教能分别。唯有经体是所取也。收无不尽简无所遗。与金刚藏四句皆体。释签于四唯取于中。其意泯合。三若作下特彰今释契理益机。显圆中道泯绝言思而为经王。上顺如来叙体之旨。下赴众生闻经之机。既论四味。诸大乘经文理合者皆是经王。岂有独尊我经而慢他典。此望真谛万万相悬。三微妙下叙宗二。初释微妙。如来既叙金光明名经王之体。此乃一经所诠秘藏。其有闻者。必思此义。故云微妙。此之二字若因果互阙。则非始终常住三法。故对古非显今正义。因该博地果极妙觉。位分六故深而难见。六皆即故不纵不横。因即果故不纵。事即理故不横。文解理性与果例云亦复如是。若知六即义无不允。二四方下释四佛护持二。初约教释二。初正释二。初释四方四佛。佛唱此言意有所表。正叙经宗。宗是果智冥法性体。体虽是一而开四门。谓妙空妙有双亦双非。如地论明四句显体以为四方。果智冥之以为四佛。叙宗之意显然可观。二释下释护持二。初约五佛体用释持。今经宗在释尊果智。欲彰此智冥四门理。是故特从四佛明之。良以佛智不分彼此。同冥法身不动之性。顺性名持。法性是法体。诸佛是报智。寿命是应用。此三皆常故云无量。二信下约信相疑除释护。佛护法性为令众生不起倒惑。信相但推八十短迹。惑于法报常住之本。四佛示本令悟八十即是常用。故名为护。二此一下拣示。指叙宗文名此一句。义虽种种不出于三。谓体宗用。正虽叙宗。宗必冥体。体必起用。是故此句不可独释。四德如后。二观下约观释。上叙经宗义归果佛。当机闻见惑破理明。今之行人若不于心明方明佛。徒闻此教有何益耶。故令观心觉于四谛及以四德。既即我心免数他宝。此文分二。初约谛约德立圆观二。初约四谛二。初总明境智。四门四谛俱通因果。门从理开就果为便。谛有苦集宜对初心。行者应知。借四方佛表四谛智。此乃托事兼附法相入心成观。是故四谛即一念心。阴心是苦。现惑是集。即智是道。本寂是灭。如实知之名四谛智。二东下别示境智二。初观境。四谛法相前果后因。今从修观始因终果。故世出世集道居前苦灭在后。初心观境欲易研寻。宜从近事。故顺世俗甲乙五行四季等名。令四方义成使四谛可识。务在立观不拘名教。二观此下发智。既于一心即观四谛。观之不已。眼智发生任运持护。妙理不失倒惑不起。然须深察圆观四谛皆称无作。苦集逆修体是性恶。即逆是顺道灭无功。故云。阴入皆如无苦可舍。尘劳本清净无集可除。边邪皆中正无道可修。生死即涅槃无灭可证。见此炳然名发谛智。二又下约四德。上四谛观虽观一心。四教行人皆可修证。今就四德各明三观。初心顿修的属圆观。东方对常常破无常尘沙净也。无常破常见思亡也。双非破二边无明集寂也。说有前后修在一心。三方例此。二观东下约谛约德示佛名。前明觉智但是通明。若于观心不论别号。则观于经未为极顺。今于集谛达即真常名为阿閦。此翻不动也。次于苦谛达即真乐。真乐尊重名为实相。次于道谛达毕竟净。常住慧命名无量寿。次于灭谛达二我空。所显真如是秘密藏。一音遍满名微妙声。四方四佛本是心性。即性为观。观符于性成四佛名。四我今下叙用二。初分文。二随释四。初能破胜法二。初依现文示二。初示三法体。能破胜法在境智行。如将破贼。须身力健次权谋深次兵器利。二依于身故喻于境。身须有谋故喻于智。谋要兵助故喻于行。此三若备三障必忘。二若相下释三法相二。初别示二。初别教。行智理三次第资发修时纵也。法报应三果中齐显证时横也。良由此教本有法身为惑所覆。故须别作缘了之功。相资显发。复由此教性具三法而不相收。致使功成三身横显。二若圆下圆教。圆诠诸法无非法界。以法界智导法界行。以法界行契法界境。法界无二一外无三。故离纵过。法界非一修性宛然。故离横过。因中三法修之既然。果上三身显时亦尔。二虽下总结。修虽渐顿俱能破于界内外障。是故皆名能破胜法。二观下取新本示。旧文唯有彼于上根第一周法。新译既广更有二周。其第二周离车王子为婆罗门。说法身常无舍利事。为中根也。其第三周自有一品分别三身。为下根也。此之三周皆是胜法悉破三障。今叙能破既云等法。理合该下三周之法也。二次从下所破恶罪二。初重科总判二。初科。此文正示所破恶罪。而言叙空品者。今举所破罪彰能破用。诸能破中空用为要。故当叙也。问前句已明能破之法。今那复有能破之方。答前境智行是能治药。今明三业专闻思修是服药法。妙药不服服不依方病何能愈。此二相成三障可破。二余下判二。初明转报异余经。恶报已成今难可转。亦有经云。宿业不转。况已受报耶。然是悉檀被机异说今明三障。若依经修无不寂灭。以法胜故。二一往下明三障由破戒。三障之由教门异说岂可备陈。今就一门由破五戒。五戒之义该深摄广何法不穷。然不碍余途故云一往。问秖由烦恼起破戒业。岂由破戒成烦恼障。答由破戒业现多贪恚。如因谤经深着邪见淫欲炽盛。此等皆从业起烦恼。故知三障逆顺相由。二今下依科广释三。初释报障二。初直约人道释二。初标示因果。二诸下验果寻因五。初明杀生报三。初牒经示。内夭者。说文云。夭折也。二昔下寻因验。三经下引经证。旧华严经也。具云。杀生之罪能令众生堕三恶道。后生人道得二果报。一多病。二短命。十地论云。杀得三果。一异熟果。谓三恶趣。二等流果。谓生人中多病短命。三增上果。谓感外物皆少光泽。不久住故　二若贫下明偷盗报三。初牒经示。二经下引经证。同生同名天者。晋译华严三十七云。如人从生有二种天常随侍卫。一曰同生。二曰同名。天常见人人不见天。三又下以事验。由破禁戒作诸不善。其二天龙必见弃舍。名誉利养因兹散失。三若亲下明淫欲报三。初牒经示。亲厚者。谓父母兄弟妻子六亲也。地论云。淫得三果。一异熟果。谓堕三恶。二等流果。谓于人中受二妻相竞。及妇不贞良。三增上果。谓多尘坌。今云斗讼与论符合。二引经证。人护者。女人志弱故藉三护。幼小父母护。适人夫婚护。夫死子息护。法护。谓受五八等戒也。三昔下约理推。昔毁他法者。令他犯戒故。四各下妄语报二。初明经脱略。例上三报合有两句。二内下约义足释二。初足文示。足奇成偶故云一双。忿即怒也。二昔下约理推。五外下明饮酒报二。初例加文示。二昔下推示因果二。初正示。撙节亦礼度也。由醉故乖聋。騃五骇切痴也。二引证。经亦华严也。由饮酒故嫌恨弥增故得引证。二问下广约五乘释二。初约五戒违经问。以五戒名出小乘律。何以释今经王法相。二。答下约五乘持戒答。一切行法大小俱通。随人智解用之浅深。今释五戒为五乘法。分二。初总答。以五戒名入一切法。或多少异但是开合。二提下别示二。初约义释二。初以五戒配法体实浅深三。初明人天二。初引经。天地大忌者。忌亦禁也。戒也。五星。谓东木精岁星。南火精荧惑。西金精太白。北水精辰星。中土精镇星。五岳者。东岳泰山属兖州。南岳衡山属荆州。西岳华山属雍州。北岳常山属并州。中岳嵩山属豫州。五藏。谓肝心脾肺肾也。以星岳藏俱配五行。但以五行对戒则三义自显。不杀对木。木主生长杀则不生。不淫对火。火主照明邪淫私隐。不饮对土。土则镇静醉则倾摇。不盗对金。金为刑杀盗则遭刑。不妄对水。方圆任器以彰不妄。妄则反是。配五行则已配五星。岳之与藏秖主五行。经云五岳。盖译者顺此方润色耳。违天等者。上对五星犯之则违天。下配五岳犯之则触地。中成五藏犯之则伐身。二又对下配法二。初别配二。初周孔教二。初五常。赵[((並-(前-刖))-一+豕)*生]长短经曰。仁者爱也。置刑除害兼爱无私。谓之仁也。义者宜也。明是非立可否谓之义。礼者履也。进退有度尊卑有分谓之礼。智者人之所知也。以定乎是非得失之情谓之智。信者人之所承也。发号施令以一人心谓之信。今以不杀对仁杀他是无兼爱也。不盗对义者。盗则非宜为也。不淫对礼者。邪淫则尊卑不分乖礼度也。不饮酒对智者。昏醉则不能定是非得失也。不妄对信者。妄语则人不信承也。若以五常对五行者。郑康成注礼记中庸篇中云。木神则仁。金神则义。火神则礼。水神则信。土神则智。向以五行对五戒。盖取此义。故以不饮对土不妄对水。二对五经。不杀对尚书者。尚书断自唐虞已下。则尊禅让而鄙杀伐也。夫子以周室微弱号令不行。乃约鲁史而修春秋以代赏罚。使乱臣贼子惧。故对不盗戒也。礼有五焉。周礼大宗伯之职曰。以吉礼事邦国之鬼神祇(事谓祀之祭之享之)以凶礼哀邦国之忧(哀谓救患及灾)以宾礼亲邦国(亲谓使之亲附)以军礼同邦国(同谓威其不协及僣差者)以嘉礼亲万民(嘉善也。所以因人心所善而为制也)邪淫是不以礼交。所以用嘉礼以戒邪淫也。诗者。善则颂。恶则刺。非妄语也。易者。穷理尽性之书。洁净精微之教。饮酒昏乱者。岂能穷其理尽其性乎。二又对十下轮王法三。初开五对十相。二俗下示合七为二意。俗不能护口者。以五戒制在家众故。口分四过。俗护诚难故但制一。饮酒是邪命自活者。以酒资身不遵正戒。名为邪命。三是为下结法。从人立名。五戒虽是如来所制。既对十善。且从有漏判为旧法。故属轮王。亦名性罪性善者。以十恶法性自是罪。十善之法性自是善。是故轮王顺世俗性说此善恶以化众生。二都下结示。世间之善不免轮回。纵生人天复起恶业。善尚如此况不善耶。故云都是一切罪根。二又五下辨二乘四。初对五阴为念处境。不杀则色质完具。不盗则苦受不生。不淫则邪想不起。不妄则迁流淳实。不饮则了别分明。此之善阴岂独为境兼资念慧。故可于阴开四念处。色阴身念处。受阴受念处。想行二阴法念处。识阴心念处。二念下从念处具道品三脱。大论四念处中四种精进名正勤。四种定心名四如意足。五善根生名为根。根增长名为力。分别四种处道用名觉。四念处安隐道中行名正道。三十七品如平坦道。空无相无作如城三门。涅槃如城。三故云下明转阴为五分法身。禁防身口故云色能发戒。禅是正受故云受受禅定。假想了悟身空。故云想慧悟虚。文中剩通字。诸文所引皆无。进趣无怠则至圣果。故云行发解脱。自识已证名解脱知见也。此即转五阴成五分法身也。四当下结五戒为二乘之法。三又五下明大乘三。初总标示。二提谓下正配法门三。初约经配四德。以大乘人了知五戒体是心性。若受若持一一顺性。性具四德故五无非常乐我净。此总对也。亦可以五别对四德。心与众生性无生灭。是故顺性持不杀戒。是佩长生不死符印。此常德也。心与众生性无淫乱。故顺本性持不淫戒。名出入无乱。心与众生念念真实无虚妄间。是故顺性持不妄语戒。名往还无间。此二对净德也。心与众生性非昏醉。故顺本性持不饮酒戒。名统御一身。即我德也。心与众生性即菩提离贪求苦。故顺本性持不盗戒。名立道根。即乐德也。二束下约事对三业。不杀盗淫身业也。不妄语口业也。不饮酒意业也。持既顺性故立戒因成佛三业。佛身口意随智慧行无有过失。名三无失。以无失故不须防护。名三不护。身业现化名神通轮。口业说法名正教轮。意业鉴机名记心轮。三皆摧碾众生惑业。下地不测故名三密。三三轨下约理对三法。五戒即理。一止一作皆与圆融三法相契。若欲别对其理亦成。不杀众生顺常住理。即真性轨。不淫则心净。不饮则慧明。即观照轨。不妄则生彼信从。不盗则全他资具。即资成轨。既即三轨则与一切三法相冥。故知五戒摄法无遗。二横竖下举广结明

金光明经文句记卷第一(下)金光明经文句记卷第二(上)

        宋四明沙门释知礼述

二复次下明五戒事理复简偏圆。上虽通六。五戒之义该摄浅深。若不委论事理偏圆。何能精识持犯之相。此自分五。初不杀戒二。初委示二。初总示事理持犯。欲令行者用理不杀持事不杀。方名初心持具足戒。今明体法须别空中体法即空。乃属偏观望圆是杀。须体诸法无非中道世相皆常。是今所论理不杀戒。欲显此意故从人天辨至圆极。故云因果种种不同。二若作下别明偏圆得失二。初偏二。初人天但事二。初人持戒功浅须加防护心。如牛马若非辔勒则见奔逸。若无杖策则犯苗稼。喻不作意则于境成犯。报百二十年是上方寿。人道诸根但明肉眼。余根可例。二若任下天持戒功成任运成性。心如河水自然注入净戒海中。未论定共唯报六天。以人岁数较第六天当尔许岁。唯得肉天无慧法佛。余根可知。若加下三乘加理二。初二乘义摄藏通。涅槃经以外道先出喻以旧医。如来后现喻以客医。佛所制戒名客戒也。事戒之外加修随道及无著戒。此戒位极当教灰断不说有报。今据大乘生方便土受变易寿。诸文不说此土寿限。但因移果易耳。今云七百阿僧祇者。必取尔许劫数之后方入实报也。若在此土破尘沙惑亦得法眼。今论二乘初生之者但得慧眼。二若下菩萨二。初正示。义当别教次第修于三谛道共等。常即假观。是智所赞及自在戒。无常即空慧。即是随道及无著戒。前空次假今从语便空慧居次。言等慧者。即中慧也。乃是随定及具足戒分。得此二当于初地。生实报土名华藏海。佛眼分显四眼乃融。是故名为分得五眼。诸根亦然。寿是慧命。已属意根。经云。诸根复云寿命。故须并说。二比下结况。此教比佛有于二意。若当教者以因比果分满不同。二比圆教别教始终是菩萨法。望圆始终皆是佛法。故称不具及损减也。二若下圆二。初示相二。初明得意持二。初略示。事持即不伤杀众生身命。此同偏小轮王之戒。但不杀所以与之永异。次文所明理观是也。二又持下广明理持三。初约体明持。此理不杀若其不解性具九界。但云体达诸法即理。全波是水。犹滥通别未显圆修。故荆溪云。若不谈具乃属别教。故须体达假合之身三惑痴爱。三科实法皆性本具性无差别。故名一相。性非暗缚称为明脱。既即性具何可毁伤。痴爱是子假实是果。全体即性。性岂生灭。如斯妙观即障是德。不待转除方是持于理不杀戒。二成下称性得报。初住已上至于妙觉。皆得名为成就智慧居常寂光。此乃分满依正二报也。无生后报但现报。故名常寿湛然无损减也。五眼具足。诸根亦然。离不具也。若论外用六根互通。略举眼耳根自在也。现十界寿或修或短寿自在也。三是下结示因果二。又圆下明得意犯二。初总示二犯。此事理犯若其不解性具违用及杀法门。但以慈愍能现逆相而解释。此岂前三教菩萨之行不能作耶。故普门疏明嗔法门为成就。故常念观音。是知须得性杀之意。慈方无缘。故云唯杀唯慈。名得意犯。二如仙下别示二相二。初引人明事杀。大经圣行品。佛说本生。曾为国王。名曰仙豫。爱念大乘。时世无佛。十二年事婆罗门为师。后遂劝彼发菩提心。而婆罗门不信谤法。王乃杀之。而王不堕狱以无杀罪故。至梵行品佛说慈心之果住一子地。迦叶难言。若菩萨住一子地。云何佛昔为王断婆罗门命耶。佛言。我以爱念故断非恶心也。诸婆罗门命终生阿鼻狱。即有三念。一自知从人道来。二知是地狱。三自知谤法为王所杀。念是事已即信大乘。寻时命终生甘露鼓王世界。于彼寿命十劫。我于住昔乃与是十劫寿命。云何名杀。然须明于得杀法门。令其爱念成无缘慈。方合疏文唯杀唯慈也。二又作下据经明理杀二。初正释。前就不断名持不杀。今明有断故云犯杀。圆教自论断与不断二义同时。既明六即。六故有断。即故不断。亦可秖就即之一字明于二义。障体即德。无障可论。斯为断义。障既即德。障何尝断。斯不断义。故烦恼即菩提。生死即涅槃。断与不断妙在其中。诸大乘经说圆顿观有此两门。今就有断名为理杀。故云析荡累着。是业及诸烦恼以为所断。树神谕于修观之人。劫火谕于能断之智。故大论三十云。譬如空泽大树众鸟集宿。一鸽后至住一枝上。其枝即折。泽神问其故。树神答曰。此鸟从我怨家树来。食彼尼俱类子。或当放粪子堕地者。恶树复生为害必大。是故宁舍一枝所全者大。菩萨亦尔。于魔外惑业无如是畏。而畏二乘。二乘于菩萨边亦如彼鸟。坏彼大乘心永灭佛乘心。今文但以怨鸟通累着等也。劫火等者。亦大论文。论第二云。二乘虽破三毒气分不尽。如草木薪火烧烟出炭灰不尽火力薄故。佛三毒永尽无余。譬如劫火烧须弥山一切地都尽无烟无灰。今谓佛智即圆智也。断阴入界生死即涅槃也。约即论断名得意犯。理观断破名不持戒。此为诚证。下诸理犯其义皆成。一切尘劳是如来种。此是性种亦敌对种。惑非性染安名佛种。以知即性修染本虚。本虚名灭。即理杀也。二成下得报。事理二犯既顺性德杀害法门。故杀法成就乃得法身。垂应九界示命长短现根缺具。此自在用真因分得极果究竟。二前下结胜。先且斥劣。人天近事藏通浅理别教次第是故隘塞。此等皆非修性不二通达之途。唯圆实戒一摄一切宏广无边。即事而中深远莫测。凡小之径必会逆顺之异。能同十戒之中名毕竟戒。二不下结责。先结该收后责局小。二复次下明不盗戒二。初总明事理持。犯事盗可见。就理论盗。据阿含经。演小成大。人天取有。藏通取空。别取但中。皆他物也。非盗是何。净名云。无取是菩提舍攀缘故。二若下别明偏圆得失二。初偏三。初人天二。初斥事持成犯。人天妄乐为可意也。欲成理持乃斥事戒。故就所求果报而责有漏之乐。犹如粪中有庵罗果有智童子不应求食。乐杂见思如世美食。杂以毒药食则害命。有观智人所不应求。设得华报心不甘嗜而生欢乐。云何凡夫为欲持戒。二贫下约经文明报。四姓者。毗舍首陀婆罗门刹利。人中虽谓二贱二贵。既乏圣财。四姓三界俱属贫穷。洄转水也。澓深水也。漏心持戒求可意果正为有流洄澓所困三有流转。故曰有流。非四流中一有漏因果具足三障能障见佛天中天也。亦是障于第一义天。以障隔故义言舍离。此乃事持成于理犯。据经招报贫穷困苦诸天舍离也。二又二下二乘二。初斥理持成犯二。初约有求斥。智举四谛。境唯在苦。于身等四观苦等四。流厌生死苦忻涅槃乐。在小名持。于大名盗。为于涅槃生忻求心。介尔者微弱也。微有心生即堕四性。既有性过乃属生死。无所得中而生得想成不与取。岂非盗耶。二即非下引诸经斥。烦恼为薪智慧为火成涅槃食。不非时证。此斥二乘匆匆取证是非时证。不待法华说于所因。于小涅槃思惟取证。大根不发如焦败种。以见苦果故断除集因。以修道品故造趣灭尽。则非大乘即惑成智无断无修。即生成灭无苦无尽。故云非求法也。中论云。诸佛说空法。为度著有者。若有着空者。诸佛所不度。身长三百下引金翅鸟雏以为喻也。二乘但念空无相无愿三种三昧。如身长三百。无中假二智如无两翅。堕三无为坑如鸟堕地。若死等苦成罗汉果也。若死苦成辟支果也。苦等于死名死等苦而实未死也。或云。二乘方便是死等苦圣位是死苦。又学人是死等苦无学是死苦。三无为者。一择灭。二非择灭。三虚空。通举言三。二乘所证。盖择灭也。然此谕本出大品而大论释之。谓金翅身长三百由旬。能从一须弥至一须弥。是鸟初出两翅未成。意欲飞去堕阎浮提。受若死若死等苦。中道生悔我欲还天不能自举。本谕菩萨堕二乘地。今借谕二乘耳。二法下引经明盗报。不得大乘法食为饥饿。无大力用为羸。无太功德为瘦有无善上起见思如疮癣。不见三身一体之佛。不闻圆顿之法。不入三贤十圣众数。三若下菩萨二。初斥次第成犯。行学道三对戒定慧。言次第者。此三皆随空假中转。三谛纵故从浅至深。是故逐一而论取舍。生死为来。空中为去。本沦生死已名为来。去已载来建立生死。故成两来。破有出界已名为去。舍边趣中名为更去。故成两去。如此来去岂非屈辱。谛观不殊离二取相。今既别修以观缘谛。名不与取。二取已下据经明盗报。取舍既数即此名为贫穷困苦盗业之报。以别圆教诠变易报不就改生。念动是业。迁变是苦。故起信论云。动即有苦果不离因。不能初心顿绝思议。故使义天虽近而远即舍离也。二圆二。初示相二。初明得意持二。初赞理持相。唯有圆观乃能究竟离不与取。绝取之观谓五不受。即不受四边及不受不受。此五不受若其不以妙理甄之。恐滥偏教。是故先云圆人观诸法实相。诸法不出佛及众生依报正报。此乃逆顺二修之法。全修即性一一无非中道实相。中实之相非待对相。圆人观此故无四受。不独境绝四句之待。亦绝境观能所之待。故不受之观亦不受也。既于初心即依中实修五不受。则唯属圆也。五不受故名为不取。是大菩提。能障一切有缘之愿。法法皆中。高外无下下外无高。何法可取何法可舍。二如是下约经明报。即以理富显不贫穷。富故不取宁有困苦。以不取故思议即绝。第一义天不相违背。乃应经文诸天不离。二圆人下明得意犯。盗法门者。所谓性恶。佛所师故名之为法。智由兹入故名为门。圆人得门逆顺自在。能作理盗亦作事盗。今文略事。例杀例淫合有其相。若理盗义文出鸯掘。彼经偈云。不与者菩提。无有授与者。不与而自取。故我不与取。此意乃明究竟不取。是究竟取此取得名如海吞流。四重担者。鸯掘经云。譬如大地荷负重担。一者大水。二者大山。三者草木。四者众生。菩萨亦尔。正法住世余八十年。为一切众生说如来藏是名初担。重于大山。恶人毁骂闻悉能忍。是第二担。重于大水。无缘得为国王大臣说如来藏。唯为下劣堪忍演说。是第三担。重于众生穷守边地恶处丰乐之处不得止住。是第四担。重于草木。彼经四担谕于四事。观今文意似喻四弘。二前下结胜。浅而且塞者且兼也。三不淫戒二。初示事理持犯。示事理者。意在兼持。以事扶理以理导事。既居末代功在事持。乃是涅槃扶律之意。理持论于染不染者。心观他境名为染法。既境为观方名不染。言种种者。事随理观小大偏圆具如下辨。二若关下明偏圆得失二。初偏三。初人天二。初人持心未淳如猴着锁。擎一油钵者。大经譬如大众满二十五里。王敕一臣擎一油钵经由中过勿令倾覆。若弃一滴当断汝命。复遣一人拔刀随之。臣受王敕尽心持行。虽见五欲心不贪着。彼经以二十五谕二十五有。拔刀谕无常。今文谕凡夫持戒。拔刀可谕三涂罪也。割舍现粗求未来细。如以贱易贵也。二若为下天二。初六欲。文举帝释意遍六天。二若断下八地。以数息法摄五欲心。意生四禅受枝林乐。极至有顶如冰鱼等。岂知长寿八难中一。摄在味禅非不染欲。二若憎下二乘二。初于小名持。知苦断集如怨如蛇。修道证灭如亲如宝。但自调故直去。无悲济故不回。四方四维谓八方风。谕于人天四违四顺。谓利衰毁誉称讥苦乐也。须弥谕二乘心也。二若闻下于大名犯。随岚此云迅猛。坏劫中此风起时能破须弥。以界外二土五尘能动二乘也。大论中迦叶闻甄迦罗琴不能自安。即云。八方风不能动须弥。随岚风至破如腐草。三界五欲我已断竟。不能动心。此是菩萨净妙五欲。吾于此事不能自安。三菩萨。此别菩萨望圆成犯。缘但中道而生顺爱。若入十行退不取小不进求圆。如堕山顶故名顶堕。旃陀罗者。此云严帜。乃是西土屠杀之辈。以恶业自严。行时摇铪持竹以为标帜。故以为名。今斥但中解者。于圆菩萨。犹如人中屠脍恶类也。既无即中二观方便。乃被教道中慧所缚。既与无明怨仇其住。何能胜之。别修之慧无无作利。望毕竟净是染欲法。凡斥别教多是住行及十信人。以回向位能圆修故。二圆二。初示相二。初明得意持二。初约义示三。初示能净谛观。一心者。见思心也。观此染心即是净性。性非浅狭极三谛源。全谛发观即空假中。即空故不染于染。即假故不染于净。即双遮故不染二边。即双照故不染中道。三谛三观秖一刹那。能所不殊中边俱净。二即空故下示所净爱见上之谛观俱为能净。今明见爱方是所净。须知所净该于通别。佛菩提等是顺道爱。深观即中其爱自泯。三三下示三谛名净。净是空义。毕竟空者。须空三谛。以验能空不少三观。能空亦空故是净亦净。于通不塞也。二经下引经证二。初引经文。二圆下会经意经就位论持唯在果。今约圆观初心即能顿持佛戒。以观实相因果无殊。若不尔者。云何能以如来庄严而自庄严。二圆下明得意犯二。初引诸经事。既得本性染爱法门。故能行于事染之行。亦能示于理染之观。染观可例取菩提义。故今略之。但依华严出事染相。行不污戒者。菩萨名也。先以欲钩牵者。爱欲如钩能牵于人。然后令彼达欲法界。名入佛道。二斯乃下明用犯意。指上三人久住性染无染法门能现修染。故得名为非欲之欲。而令众生即欲悟性。故得名为以欲止欲。谕以屑者。字应作榍。又作楔同。说文云。楔櫼也。櫼子林切。出前櫼者。必假后櫼。故云以楔出楔也。将声止声者。大论第七云。譬如执事比丘举手唱言众皆寂静。是为以声遮声非求声也。二前下结胜。四复次下明不妄语戒二。初示事理。问事中妄语重者。乃是未得圣法言知言见。今法门解于未证得谓已证得。与事何别。答盖第四戒自知未得上人之法。诳他言得。故此妄语除增上慢。若理妄语内心实谓已得已证。此心增上而慢于他。是增上慢。故法华云。比丘比丘尼自谓究竟。便不志求无上菩提。当知此是增上慢人。今未解圆理于人天三教各自谓实。名为妄语亦是上慢。二诸下明偏圆二。初偏三。初人天二。初人二。初妄语相二。初爱。下苦者。轻苦也。三涂苦重人间苦轻。凡夫不觉计之为乐。以苦为乐故曰横生乐想也。犹如世人罪合当死。而以千罚放命。罚实是苦。以得全命罚罚之下皆生乐想。又如病者恐死加之针灸。针灸实苦。言除病故皆生乐想。八苦交煎妄谓为乐。事亦如是。二竖下见。广如大经。凡夫外道慢心自高。谕之竖幢。口宣慢言。谕之打鼓。于五阴上各起四见。文中略示色阴。余之四阴可以例作。次句应云离色是我。今云我即是色者。文之误也。色中。有我即色大我小也。我中有色即我大色小也。起六十二者。五阴各起四见共成二十。历三世成六十。而其所计不出断常二见。故有六十二也。所说无实其犹谐谑。故云戏论。由斯戏论不见真空故破慧眼。二备口下。结示口过。见是妄情须生转计即两舌也。宣邪恶理即恶口也。巧饰邪言即绮语也。诸见本邪。以邪为正而诳于人。故标妄语。其实备四。二三十下天。大经婴儿行品云。如彼婴儿啼哭之时。父母即以杨树黄叶而语之言。莫啼莫啼。我与汝金。婴儿见已生真金想。便止不啼。然此杨叶实非金也。木牛木马木男木女。婴儿见已亦复生于男女等想。即止不啼。如来亦尔。众生造恶为说三十三天常乐我净端正自恣。于妙宫殿受五欲乐。众生闻已心生贪乐。止不作恶勤作善业。三十三天实是生死无常乐我净。为度众生方便说有。章安释云。此合天上四德。杨叶谕妄。净色鲜明故。杨树谕妄。常体柔软故。木牛木马谕妄。乐可戏故。木男木女谕妄。我似人故。非想细烦恼者。彼有十种细心数法。一受。谓识受。二想谓识想三行。谓法行。四触。谓意触。五思。谓法思。六欲。谓欲入出定。七解脱。谓行法解。八念。谓念于三昧。九定。谓心如法住。十慧。谓慧根慧力。二二乘二。初出行相。竞执瓦砾者。用大经春池失珠谕也。春池譬众生尘欲耽湎之境。失珠譬圆解潜昏。信小乘教如入水。修观如求珠。但见偏真谓为究竟。如得瓦砾便谓真珠。生灭度安隐之想。犹如欢喜持出也。生实未尽者。犹受变易故。所作未办者。佛道未修故。离毒说脱乃一小脱。即毒明脱名一切脱大涅槃也。佛为上慢执着三毒便为解脱。是故说离。声闻住此谓究竟脱。其实未得一切解脱。此以净名对法华文出妄语相也。二未得下结成妄语。三佛下菩萨二。初示其行相。佛说四门意诠一实。别人根钝各执一门彼此隔碍。二夫下结为妄语。诸法实相离言说相离心缘相。以法法体遍多少性融。岂可定以空有等言一二等数。此教言思既乖实理非妄是何。二圆二。初示相二。初明得意持二。初总标心口。圆人根利闻空有等皆知性具。性具四门岂有隔碍。一门具三。三门皆尔。称性而观。称性而说。既皆称性。性绝言思。故观即无观说即无说。是故观说皆云如实。二如下别释心口二。初明心离诸相而观。所非内外。或约自他或约根尘。或约心法或约法性对于无明。此等内外双亦双非皆成四相。妙观得脱皆离此四。亦不以无四相观而得解脱。性空非四相空非无。此之二空名滥通教。须就圆理拣彼遍空。圆理者何。谓诸四相不出本觉。全本为始即境是观。岂更偏着四种之性及无四之相。非此二空下名解脱。二如实下口称四实而说二。初约法示。实等四句亦乃不出本觉之性。以此觉性真空毕竟故名为实。具足缘起故名不实。二不相碍故成双亦。二无二相故即双非。觉性无偏四皆全分。实摄三句乃一实一切实。不实摄三。余二亦尔。是故四句皆云一切。其圆解者虽谈一句一外无余。何有一言不称本觉真实之性。是故四句皆得名为如实说也。二经下引经证初心圆说与果无殊。故引法华本佛。作证。佛施权迹及开实本。皆称真如。有何一句而非实耶。似位妙音仿佛同佛口密之相。开小成大能以佛声如实而说。令诸众生闻皆入实。二圆下明得意犯二。初约果人示。虽就果示意显始行故云圆人。妄语法门者。乃是性德权巧妙门也。称妄语者。无而说有也。谓十界冥合本是一乘。无有三乘差别之相。佛为机故分别说三。令诸众生各为究竟。自求趣证速出生死。如无三车说有三车。令诸乐着嬉戏之子争出火宅。天无常乐说有常乐。如以黄叶止彼啼儿。此皆巧用妄语法门而为利益也。二经下引经证。诸法无行经中。文殊说不动相法门已。空中万天子赞言。世尊。文殊名为无碍尸利不二尸利等。文殊语天子言。止止。天子。汝等勿取相分别。我不见诸法是上中下。我是贪欲尸利等。具如今疏。天子唯以性善法门而赞文殊。且别教但中岂非性善。须断九界然后证得。斯乃于法见上中下。文殊欲显圆顿之理。具足善恶无非法界。特以三毒而自立称。然三毒等虽俱性具不异而异。是即实之权。皆是秘妙方便之法。故一一句望实言非成妄语义。虽是妄语而皆是性本具法门。今宗讲者才闻权假便谓非性。吾知其人未生圆解。二将下明犯意。同于前文以楔出楔也。二前下结胜。五复次下明不饮酒戒二。初示事理。二夫下明偏圆二。初偏三。初人天二。初人中事酒二。初据教明过。三十六失出沙弥戒经。大论唯三十五失。结为颂曰

  财虚招病诤(三)　　裸露丑名彰(二)
  无智得者失(二)　　说匿废事业(二)
  醒愁身少力(二)　　色坏慢父母(二)
  沙门婆罗门(二)　　及伯叔尊长(二)
  不敬佛法僧(三)　　党恶远贤善(二)
  破戒无惭愧(二)　　不守情纵色(二)
  人憎亲属弃(二)　　行恶舍善法(二)
  智人所不信(一)　　远涅槃狂痴(二)
  命终堕恶道(一)　　若得人常騃(一)
  酒失三十五　　大论之所明

五百世无手者。梵网经云。若佛子若自身手过酒器与人饮酒者。五百世无手。何况自饮。伏匿皆隐也。自说私隐故云发出也。二过下斥人好尚。引满者。晋左思蜀都赋云。合樽促席。引满相罚。乐饮今夕。一醉累月。注云。酒将阑故合并其樽促近其席。引持也。持满以相罚。酒厚乐极故醉累月。三国志。魏尚书郎徐邈私饮至沉醉。时科禁酒。校尉赵达问以曹事。邈曰。中圣人。达白之太祖。太祖甚怒度辽将军鲜于辅进曰。醉客谓酒。清者为圣人。浊者为贤人。邈性修慎偶醉言耳。竟免刑。晋毕卓为吏部郎。比舍酿酒熟卓醉后夜而瓮下盗饮之。掌酒者缚之。明旦乃毕吏部也。自署为酒徒者。以酒徒自号也。如唐元结自号酒徒。皮日休自号醉士之类也。三国志。吴太中大夫郑泉字文渊。陈郡人。博学有奇志。性嗜酒。临卒谓同类曰。必葬我于陶家侧。庶百年后化成土。卒见取为酒壶。竹帛载之者。谓史志皆书其事也。古皆记言事于竹简缯帛。以未有纸也。后代称其故实。故谓史籍为竹帛也。古今歌之者。古今之人不斥其失。往往为歌诗以称美之也。不应作而作者。引满中圣。酒徒酒壶之事。皆耽湎荒恣其失大矣。尚书酒诰诫之甚明。而四贤反为之。是君子所不应作之事而作之也。不应歌而歌者。古今之贤当贬其失。而反作歌诗以美之也。若作若歌非酒之过失而是何耶。二释下三界惑酒二。初别示二。初引论明见醉。释论第八文也。王即南天竺王也。侜张。尔雅云。侜张狂也。侜字张由切。二又下约谕明爱醉。二三下总结。二二乘二。初断通从别以明能醉。九十八使者。见惑有八十八。思惑有十也。四住者。三界见合为见住地。三界思分为三住地。无明未吐者。以酒谕惑也。半疟人者。四住已除无明尚在。半安半病其犹疟疾。此亦大经中谕。二兼凡斥小以明所迷。引醉归之者。谓佛引醉谕归还二乘也。按哀叹品中。诸比丘说醉谕以谕凡夫流转无常见常如醉。小乘修无常想故如醒。佛即引醉谕于二乘。谓于真常而见无常是醉义也。故云。引醉归之文。人合作文。世间下文辞从省。四倒四德各举其二。影互相显三菩萨二。初约教道观中皆名不了三。初法。别教至极但破无明一十二品。故于佛性见不了了。又从初心不知五住即是法界不名佛法。是菩萨行。故于佛性见不了了。二如下谕。凡举五事悉谕见性不得了了。舶者大船也。谕出大经。然彼十谕并谕于圆。以分拣极故云见不了了。今谕别者有二意。一者别教极果秪齐圆教第二行。故见不了了。二者二教理同得意其德失意但中。今就失意故以谕别。如来藏经十谕亦尔。止观在别十六观疏而显于圆。三如下合。二故下明自圆解外皆名邪见。未得圆中正见故也。二圆二。初示相二。初明示行相二。初得意持二。初称性观故得名醒悟此段文意乃将果德顿为始行。苟不了知第六识心是性恶者。何能初心修如来行即观秘藏。肉眼即佛永不改观。而见牟尼与妙德等。荆溪的示须闻性恶方修性行。不可欺也。二是下以圆伏故名除酒法。五住正习同居一念。即惑为观观外无境。如翻大地草木宁存。亦如日光不与暗共。有何酒法而不除耶。此人事戒轻重等持。与上理戒念念兼行。方名究竟。二圆下得意犯二。初明具大智故能理醉。何名大智。谓了性具九界因果。是故名为饮酒法门。真空实相如起信论。一真如性有二种德。一如实空与过河沙烦恼不相应故。二如实不空体具河沙功德无有所少故。护一切失故空如瓶。德用无碍故不空如酒。然河沙性德即十法界圆融法门。九界即佛成前持相。佛界即九成今犯相。故犯相云。变化五道宣扬哮吼。其犹酗酒之用也。二波下明具大悲故能事醉。波斯匿此云和悦。若饮酒后应死判生故曰多恩。末利即匿王正后也。王尝嗔怒欲杀厨人。诸臣共议国中唯有此人。杀已无人知厨称王意者。时末利后即办好酒美肉。沐浴名香庄严身体。将诸妓女来至王所。王见后已嗔心乃息。后即遣人诈传王敕勿杀厨人。匿王后以此事问佛。后持五戒月行六斋。一日之中犯酒妄二戒。八戒之中则犯其五。谓过中食服香花作倡妓高广床饮酒妄语也。破戒之罪轻耶重耶。佛言如是犯者得大功德。何以故。为利益故。出未曾有经下卷。入于酒肆。即净名居士。此上三人皆是高位。皆住性恶权巧法门。故于持犯得大自在。不可秪将慈念而解。若无性染慈岂无缘。二夫下结得斥失。若得性具善恶之门则逆顺俱当。失兹要柄则持犯俱非。如把刃自害。得失之要不可不穷。二前下结胜。若善恶分岐岂醉醒不二。诸佛究尽宁有所偏。二上观下观心释。圆论理戒岂不观心。但为前文是约教释正为开解。今撮五戒人一念心成于圆观。正为立行即闻而修。修发之门说者应授。若不尔者。数宝何为。分二。初附上谛智问。上观四谛各发觉智。乃言四佛。今明五戒亦可观之成五佛不。问意如此。二观五下据今戒体答。若观五戒是实相者。所发觉智岂非五佛。然五实相是所观境。五境发智名为五佛。实相无相尚叵言一。岂定五耶。由附五戒各见实。理故似分五。实理者何。所谓本觉。此之觉体是无缘慈故名不杀。无取故不盗。无染故不淫。真实故不妄。明了故不饮。今圆行人以妙三观顺性修慈。乃至三观顺性修智。说之如此修乃同时。故得名为观五实相。观之不已。本觉全体发成始觉。名为五佛。名字观五观行已去皆得称发。二次下释烦恼障。三初节示经文。二上下对上下辨二。初对上下定体二。初对上报论义便。报多约色。惑唯在心。故云义便。二报下与下业论体别二。初问起。以十恶中贪嗔痴业名同烦恼。如何分别。二数下释通二。初引数人释。二俱数起但以轻重分于惑业。二今师释二。初约心克示。贪等决定发动身口招报名业。以异烦恼非决定故。二若下因示生疑二。初疑。若决定心发动身口名为业者。下恶星等自是外境。何名业障。二此下释。星等乃是业之前相。表于责报故属业障。今示作业体。下明宿业相。若论作起时岂非心色。二若下对上下论转。二障在因是故易转。报障已受是故难传。难者若转易者必去。三通下约文示相二。初通别。通论可见。若别论者。见惑执我爱但着事。此之二惑皆具三毒。执我三毒若其不遂则多愁忧。着事三毒既不执我。但恐不遂必无愁忧。二今下指广。章安记录不能广陈见思之相。令后说者委而示之。故注云云。三三破下释业障。二初节经。二释义三。初定文是业。已作之业将感恶报。故有异相表发其事。验知此句明于业障。二恶下略释经文。别有客星者。以五星二十八宿常现则非恶星。亦是下约常星。失其行度躔次。亦名恶星。一方有七者。角亢氐房心尾箕东方苍龙七宿。南斗牵牛须女虚危营室壁北方玄武七星。奎娄胃昴毕嘴参西方白虎七宿。东井鬼柳七星。张翼轸南方朱鸟七宿。凡四方之宿皆逆数。宿音秀。失其分野者。周官云。天星皆有州国分野。角亢氏兖州。房心豫州。尾箕幽州。斗牵牛婺女杨州。虚危青州。营室。东壁并州。奎娄胃徐州。昴毕冀州。嘴觿参益州。东井与鬼。雍州柳七星张。三河翼轸荆州。荣惑火星也汉书音义云。妖星曰孛星彗星长星。亦曰搀抢。释名云。星光稍稍似彗。言其孛孛然似扫彗也。又类散麻。故云麻彗。左传。凡人火白火。天水曰灾。今但取风雨雪霜乖候者。皆名灾。法邪谓外道经书。蛊道者。事释乃是仙鬼毒害于人。蛊工户切。声类作弋者切。蛊物害人也。说文蛊腹中蛊也。楞严云。贪恨为罪。是人罪毕遇虫戒形名蛊毒鬼。理解乃是自心三毒名之为蛊。此蛊能害百千万身。法身慧命永为所害。比夫毒鬼为害至微矣。丑恶形声见闻为怪。不适意者适悦也。三夫下劝令正信二。初明相见表五罪二。初约现文表示。亲离即亲厚斗讼。幽厄即王法所加。幽谓幽境。二其下例余相亦然。二行下诫行者问邪师。礼记曰。龟谓之卜。蓍谓之筮。卜筮者所以决嫌疑定犹豫也。今云折篾。篾谓竹篾。谓揲蓍取卦折竹篾为文也。管公明者槐人也。名辂字公明。善卜筮。所向皆验。应知恶报由罪结罪由心。苟正于心罪报自荡。不修内德卜筮何为。吴氏春秋云。宋景公时荧惑在心。公召子韦问焉。子韦曰。祸当君。虽然可移于宰相。公曰。宰相所以与理国家。可移于民。公曰。民死寡人将谁言君。可移于岁。公曰。岁饥民饿死。为民后而杀其民。谁以我为君乎。子韦曰。君有至德之言三。天必祐君。荧惑必三徙舍。舍行七里。一里当一年。君延年二十一矣。荧惑果徙三舍。况能内观法性达罪本空。均生佛于自心。起慈悲于法界。恶星之变何虑乎不灭耶。故于次文明其方法。二从下举方法。若依初开章为四。此当第三能破方法。今依重科

金光明经文句记卷第二(上)金光明经文句记卷第二(下)

        宋四明沙门释知礼述

从诸根不具下叙空品文为二。初三行半明所破之恶。即三障文也。次二行半明能破之方。即今文也。而释一行半讫。复依初开章以后一行为四结成。然取义成分章从便分三。初节经立意。以顺重科云能空也。二前下据意释经三。初立意。禳谢也。又除殃祭也。二洗下释经二。初释前三句。欲知智在说。故以听经而为般若。又听经发智慧故。心有染故用不自在。今既清净能成解脱。二前令下释后三句。至心之境即甚深行处。不念此处安名至心。三夫下劝信二。初约身陈类。今之三业表法之身。本是血肉不净之物。次举二喻。栴檀香木。伊兰臭树。大经明。阇王造逆。后既见佛罪除。乃自叙云。我见世间从伊兰子生伊兰树。不见伊兰生栴檀树。我今始见从伊兰子生栴檀树。伊兰子者我身是也。栴檀树者即是我心无根信也。二今下约行可期。三业虽近三德虽远。修得规矩即近成远。规圆矩方。孟子曰。大匠训人必以规矩。三洗下行成破障。若于浴等无三德观。如何能禳三障恶罪。四从是下结成。三初节示经文。二能下正释经义。三寂下深明经意四。初据今文示法。寂灭华音。涅槃梵语。涅槃之名召三德体。故知寂灭是三德成。二前下约行成德显。三业既修金光明行。成则契于三德之理。修在名字观行相似。至分真位皆得。名为转障成德。不尔。岂曰行方等经。三报下明转障成德。四前寄下明经巧难知。五叙流通明教相。疏略指上。三明疑念序二。初释寿量品题。二初正释二。初约三佛难思以释二。初佛本无三。不唯法佛无身寿量。报应亦乃不可说三。以一切法离于名字言说相故。二随顺下随世俱立。众生若有得益因缘。即须随世立诸名相。非唯应佛立身寿量。法报亦乃可论此三。须知无三不减一法。虽立三三不增一法。良以有无皆法界故。故真无俗有真有俗无皆是悉檀。令于三身得四益也。此文分二。初列三身各三。二释三佛三义二。初约义分别二。据理融即。分别且从修二性一令义易明。法是本觉。报是始觉。始本一合方有应用。一往似纵。说者应以次融即文非纵非横。妙会此义。令其闻者识圆三身。文分三。初法身下法佛二。初别释三。初身。始觉报智依本觉成。故以法性而为师轨。究论始本唯是一觉。故云还以法性为身。是故马鸣归命三宝。即以佛身及体相等而为法宝。此身等者。非分段变易色质心智三科所摄。乃是常住五阴等法聚以为身。此法无相不可说示。为众生故强名法身。二法性下明寿。色心。和合乃有报得连持寿命。身既非阴岂有命根。为物强指不迁为寿。三此寿下明量。量依身寿故同强指。二此即下总释。身寿量上言非无不者。若据次文义当双非。以其法体离于二边及超报应。强于此理立身寿量三种名字。令物忘情也。二报身下明报佛二。初称法有报二。初引经。此从顺修称理事说。修行所感释报义也。法华文证智德之报。以彼经云。慧光照无量。故涅槃文证断德之报。以云大般涅槃故。二如如下释义。修行所感二种之报。乃是始觉与本觉合。即以始本而为境智。此二不异故名曰如。各二如者。智如如境境如如智故也。复以菩提名如如智为能应冥。法性名于如如之境为所应冥。以函盖合先喻应义。函盖虽合犹存际畔。复以水乳喻其相冥。此乃泯然而成一相。始觉本觉义二体一正同于此。二法身下明就报立三。即身寿量也。三中一一言法身者。报智所冥离法无报故初身。言非身者。非应佛有分齐身。非不身者。非报佛无分齐身。又非身则非有。非不身则非空。中道法身乃本觉体。始觉冥此能冥亦忘。为成观故强名报智。二寿。三量。称本双非为物强指。义皆同身三应身下明应佛三。初明应物有三。初身。二寿。三量。皆如谷响大小随声。是故此三悉云应同。二智与下明依二有应三。初法。不觉忘处始本一如。故云智与体冥。觉体自在。故云能起大用。二如水下喻真金上色。须水银和方能涂(去声)物。阙此一缘金无涂用。三功德下合报智功德以合水银。法身合金。处处应现合涂色像。三能为下明应遍三土二。初双明报应。二有量下单示应身。初义者上所说报但论冥法。即自受用也。金明垂应以他受用常住之应。对于生身无常之应。示二迹用。是故双明身非身等。身即生身。有分齐相。故名为身。非身是报。无分齐相。故曰非身。小般若云。佛说非身是名大身。大身者。乃他受用身也。无分齐身其寿则常故无量也。有分齐身寿则无常故有量也。此二应用乃依真中二理而住。机依事业二识而见。住理广如序品疏文辨之。二识委在起信论明。论意要在事识见则取色分齐。故名应佛。业识见则离分齐相。故是报身。行者应知常身无量通应三土。无常有量但应同居。所以者何。盖实报机分证论见他受用身。方便土人唯禀别圆。所见佛相虽小优降。然匪生身悉是报佛。若同居土具四教机。禀别圆者能睹报佛。故法华明常在灵山。华严说法尽未来际。及诸大乘即于应相见是法性尊特之身。故知常身遍应三土。若无常身唯应同居。逗藏通机及凡夫众也。次义分二。初明有量二义。上之所说自受用外垂三土身。皆名为应。其他受用虽就对机名之为应。而是实因之所感克复名为报。非是差别逗机之用。若论逐物随缘参差长短身寿量者。须就同居无常用说。故今别示应身之相。但于有量开出两量。而此两量依于事识但空见故。唯属无常。若依业识不空见者。即此无常全体是常。则常无常二用相即二鸟双游也。若上二土机息应转。亦是无常。以非八相故且言常。七百等者。首楞严三昧经云。坚首菩萨问佛寿几何。佛令往东方过三万二千佛土。于庄严国问照明庄严自在王佛。彼佛答云。如释迦寿我亦如是。汝欲知者。我寿七百阿僧祇劫。坚首回此白佛。阿难云。彼佛乃是释迦异名。虽机胜见长。而七百犹可数。故亦是有量之量。若阿弥陀人天莫数。故是有量之无量也。二应佛下结应佛皆然。佛佛既皆三身圆证。应身彼物物寿长短。岂不随顺各示两量。故弥陀现长亦能现短。释迦现短亦能现长。故大论第三十六云。当知释迦文佛更有清净国土。如阿弥陀佛国。阿弥陀佛亦有不严净国。如释迦文佛国。又三十八云。此间阎浮恶故释迦寿应短。余处好故佛寿应长。故涅槃二十二云。西方去此三十二河沙有无胜国。所有庄严如安乐世界。我于彼土出现于世。斯皆随逐物机也。二然此下据理融即二。初约理融。上之三身三皆在性则并。二从修有则别。不分修性即一。三不互融则异。别异故纵。并一故横。是则乖于所诠法体若能妙达秪一法性。而能成就一性二修。名即一而三也。修性而成而其三身一性本具。名即三而一也。此乃得云全性成修全修在性。性无所移修常宛尔。方合能诠玄妙之文矣。二故下下引文证。经文具云若入是经即入法性。如深法性即于是典金光明中。而得见我释迦牟尼。此乃以理而为经也。金等三字即法报应三身异名。与一法性即一而三即三而一。若知此理即是三身。三不纵横名为得见释迦牟尼。故大经中明于三德不纵不横。名大涅槃。我今安住如是三法。为众生故言入涅槃。故知不达三身三一融妙。不名见佛。今解三佛既此融即。方会此典玄妙文也。二但信下明二字标题之巧二。初委明其意二。初从应佛融三释二。初明因偏疑见圆体。偏疑八十是应有量。四佛举喻明应无量。无量既破有量之疑。即达法报非量非无量。此因偏疑见于圆体。二若从下明从圆体不偏题二。初指偏题相。二而今下示圆论意。以不偏题故三寿量二字能诠。二取意下就报佛融三释三。初明报佛体圆。上约品题寿量二字不偏有无。则收二应能显法报。就文便也。若义便者。今经既以果德为宗。合以报身释于品目。以报身上冥下应。则三身义任运成就。是故二字正在报身。二量疑下明因疑达圆。报身义显。良由四佛以长寿应释短寿疑。故使信相达于报智圆具三身。三经家下明从圆题品。题称寿量正在报身。此从信相圆解所见。蔽犹当也。举报身一当三身诸也。二从此下结示立题。二又一下明重解三。初示异解时。大师非止一回讲说。故于一时别立名义。章安既闻是故兼录。二亦作下明异解相二。初标列章门。玄义者。文选云。睿哲玄览。注云。玄通也。谓离文通示其义故曰玄义。引证者。义虽妙悟而与经曾。故引文证令人生信。还源者。品题是派经目为源。所约三身明于寿量。不离法性金光明源。摄还此源令义究竟。二玄义下依章解释三。初玄义二。初直示三身寿量三。初应身三。初寿。二延促下量。三此释下结。因缘者。感应更互而为因缘。二又寿下报身三。初寿。智外无境境外无智。名相盛受。既绝能所故无分别函盖绝待当体名大。二量者下释量。境智俱遍名为相应。此之相应实无际畔。义言于量。三此释下结。三又寿下法身三。初寿。法性不变无去来今。是真久义。约此久义释法身寿。二量者下量。铨犹度也。常叉之寿实叵度量。强以双非而度量也。非多等者。出度量相。初非多少数。次非知不知。三非说不说。此显法寿是不思议境。故大论云。不思议者。不决定也。若离可说而谓法寿定不可说。是名决定非不思议。上二双非其意亦尔。如此铨量是常久量。又多少数铨量法寿。非长短用。尽知不尽知铨量法寿。非分满报。可说不可说铨量法寿体非说默。三此释下结。二初番下更作三双显示。盖前直以延促境智及双非义。示三寿量。恐犹难解。故今各以二义铨量。欲令行人识三佛相。文分为三。初番应佛二义。第二番报佛二义。境无分别。非谓顽境全无觉知。乃指心体本来离念。名境无分别。此离念心全体觉悟。名智有分别。此之境智究竟相称。智外无境境有分别。境外无智智无分别。是则境照于境智寂于智。以此二义显报身相。第三番法佛二义。体本无相故不可说。依言显德是故可说。二引证二。初引今文三。初引二文证应身二义。二引三文证报身二义。虚空喻通前取不坏喻无量应。今取无相证境无念。三引三文证法身二义。问前云四喻皆喻应寿能为无量。今何引之证报证法。答非全法报为应身者。应必断灭安能延促不曾休废。今欲显示三身融妙。故即以应而证法报。若昧此意诸大乘对机之身莫能深识。二引新本二。初别证应身二义彼憍陈。如婆罗门欲得如来舍利如芥粟许。此乃知佛九旬当灭。故愿求之。可证应为八十有量也。王子下即栗毗王子答婆罗门也。虽即法报且从福报以证胜应。二总证法报四义。智即报身境即法身。具知不知说不说四。但略举一以等余三。四皆绝虑故可总用难思难解而证之也。令述此意故注云云。三还源三。初总明意。然法报应与金光明皆是法性当体之名。本无优劣。以此经正用金等显于法性。故佛首唱而为经目。故金光明得为宗源。一切三法便成流派。金解寿量须约三身。恐作别解故示复宗。二初番下示还相三。初应还明。胜劣二应全是法性能多利益也。二第二下报还光。报必冥法。故于句句法报双陈。此举所冥智。全是法性。寂而常照也。三第三下法还金。说时常默默时常说。圆妙四德有何损益。全是法性可尊可重也。合论融即例前故略。三夫解下例一切。若解体金光明义岂止三身义归三字。一切法相皆还此源。故竟千从不即万惑。三既是下明兼录意。二时之说俱彰妙理。后之学人随何闻悟。欲示此意故注云云。二此品下正明疑念二。初序入正品指上说。二从王下还从序意。释此文二。初节经文。二随文释二。初出人四。初出处。事释如通序观解见出名。二菩萨下明位。翻名道心。复能化人故道心大。此行虽该前之三教。今位在圆。三信相下出名。二初约教释名三。初直就相似释二。初约名释。信通真似。既言信相信则非真。以其似信是其真证前相故也。别教三贤是似信位。初地已上方得真信。圆教登住便得真信。即以十信名为似信。言铁轮者。本业璎珞经。以六种轮譬六因位。铁轮十信。铜轮十住。银轮十行。金轮十向。琉璃轮十地。摩尼轮等觉。信断见思得是铁轮。二下文下以相验。枹鼓杖也。或作桴。二又真下明似通上位二。初明位位有似。已证名真未证名似。普贤等觉望极名似。故立贤名。二信相下明高下难测。三难者下设难核实二。初高位无疑难二。初难二。此亦下释二。初约权实释。为他发起是权示疑。未了佛地是实行疑。二法华下引二经证。法华本迹皆是弥勒怀疑起问。大集菩萨菩提未极。故云未了。本性菩提熏心起疑。疑故求了。故云菩提为我作名。二难者下断见无疑难二。初难二答通疑障真。别疑障中。中道未极安得不疑。二观解下就处辨观。今出人名观那就处。良由观法皆从阴起。以王舍城约阴便故。故就处明。以善恶王观无记舍。能所不二人法俱空。二空所显即大涅槃。防五住非御二死敌。城岂过此。名字初心观阴涅槃。妙觉后心涅槃究竟。今意正辨初心住处。明后心者示此妙观同果智也四叹德二。初科判二。初正科经。二重判位。植种也。愧惭也。云云者令准叹德判同普贤。二供养下随释二。初外供养佛二。初约财法释。大经云。诸供养中法供养最为第一。财供养则有穷尽。法供养者则无穷尽。二约观行释。无明一念全体觉了。此之觉心名之为佛。缘因资了是供佛义。三喻可见。二种善下内种善根。四初直明种善义。体本觉心名法性地。观性始觉名为种子。下种种久其义可知。五善根者。于本法性生不动信进念定慧。五皆不动名为五根。此根生者相似位高故名增长。二增长下以。值佛释成二。初举三事譬。二风譬下以三轮合。身轮现通骇动其心。意轮鉴机智光照也。口轮演教法水润也。三楞严下明三因增长。楞严是定缘因也。般若是慧了因也。法性是理正因也。二修一性照发互资。由修照性由性发修。此三增长转似入真于真增道。并得名为倍明转显四植种下结二成德。三从是下正明疑念序二。初节经。二由有下随释二。初生疑之由三。初正出疑由。远则由于九十日前告魔期灭也。此经乃是方等后分也。近则由在灵山闻佛定中唱序。既起思。惟故生疑念。虽有二由无本誓击此疑不生。二何因下释何因缘二。初约三性分因缘。通论三种即正缘了。名为三因。同在理性以修缘了各三为缘。今文略云何因。何缘。须合性三但名为正以当于因。修中缘了合六为二。以对因故合二为缘以当于缘。就此因缘而生疑念。二正因下约因缘疑寿命。正因常久为所显理。理境既常全境发智以为能显。岂可无常。能显兼福而智为正。故但云智。此境此智俱感常寿。故疑八十是何因缘。三方八下释方八十三。初通示世寿三。方二。下方下特示中方为表。应化之事皆依理现。是故外事悉内表理岂中方寿不表四德。佛意虽密。今智者师据后四佛约应显常。故以所显验其能表。则知佛意。三信相下不知表意故疑。信相若达上之表意。即见三身是圆四德岂疑应迹定是短促。而反疑云何因何缘耶。二正生疑二。初约理教互疑二。初执教疑理。二执理惑教。佛之所说是能诠教。长寿因果是所诠理。即道理也。互执成疑文义可见。二有二下约经文广示二。初释有二因缘二。初对前办异。前即经云。何因何缘也。前释既以正性为因。乃以修中缘了为缘。今云长寿有二因缘。既是佛修止行二善各具缘了。即是前文能显之缘。今于前缘自作因缘。是故与前因缘异也。二十善下就今解释二。初约十善略释二。初正示因缘三。初于十善各论止行二。初标示。二不杀下释相二。初约杀盗释二。初约行相合具。二今经下明今经互举。二若备下例八各论。止行二善有三差别。谓自他共。一自行者。如文云。不杀是止放生是行。不盗是止施食是行。二化他止行。如文云。若不遮夺名止。方便劝修名行。若备论十种止行者。不杀不盗如疏已明。其八种即不淫梵行。不妄言诚实语。不绮语质直语。不两舌和合诤讼。不恶口常行软语。不贪不净观。不嗔慈心观。不痴因缘观。皆自修止行也。自他共明者。自不作十恶名止。劝他不作十恶名行。二今就下于止行各论因缘二。初标。二夫命下释二。初就不杀示四二。初止善因缘。因是善本缘是资助。为成慈心故除杀具。二夫食下行善因缘。准止可知。二不杀下例九善皆尔。三总有下结示止行因缘数。二此等下结成疑念。二此约下就五乘广释二。初结上起今。若其但说十善因果。斯乃浅近一涂之说。于方等经未为允惬。此结上也。今当更约世出世间渐顿止行。方是佛因。此起今也。二人天下明今广示二。初明教义二。初不杀二。初明行相二。初示相二。初正示二。初总示五乘命杀。若但不杀报得命根。斯善甚浅。今辨五乘修因之命。义乃该深。梵云魔罗。此云杀者。以能害人世出世善故。断下诸命皆是魔业也。二若遮下别明修者止行七。初人天。此事即戒善也二三藏二乘。三事度菩萨。以不能达三轮体空。故行六度皆名事也。四通教二乘。五通教菩萨。说法之过名非。废令勿学曰拨。体空字下应云六度。方异二乘。或脱或略。六别教菩萨。七圆教菩萨二。初顺行。亦断佛命者。此教初心即佛界故。二圆人下逆行二。初明二逆。了顺逆修即逆顺性。性非差别故名一相。故仙豫事杀果佛理杀。以即性故皆长寿因。仙豫缘如前释五戒中。二此皆下明顺理。前三教人皆小行者。以别初心行亦同小。故皆不能即逆而顺。二如上下结广。始从人天终至圆教。所有止行若无因缘善不成就。然且约不杀须历余九及一切法。皆须论于止行因缘。故云若海。二故大下引证。不作上说。岂一一度能施众生无量寿命邪。二而我下成疑念。二明施食二。初明行相二。初明事法权实二。二明事法食体二。初明事食轻重。依报食轻正报食重。二经言下明法食权实。经是此经。流水品云。未来当施法食也。世间人天也。出世三教也。上上圆融也。二菩萨下明菩萨施相三。初总明。回邪入正者。令正信因果也。萌始也。种子之始剖也。卉草之都名也。鞠养也。大论二十二云。如国王子在高危处立。不可救护欲自投地。王乃使人敷厚缯褥。堕地不死。二授以下别示四。初授人天食。二已持下授三藏食。三已入下施通别食。四设饥下施圆教食。无大乘法食故名饥国。圆顿之法如王者之膳非众人之食也。膳善也。谓美食也。烦恼下观惑即智如薪助火。智因惑缘故能成于四德之食。令四十一位弟子皆悉分得甘嗜。三如是下结示。二一一法下结止行因缘。二此诸下成疑念。二示观行。的明己心无明贪爱能生一切烦恼子孙。故名父母。若不能体二是性恶。则须断破乃名教逆。若观即性则不离痴爱全体明净。能观所观皆不可得。既如虚空痴爱则寂故名止善。以即寂观历诸心数。皆令明净复名行善。此乃观心见一切法常。岂得不感三身常果。二己身下释己身骨髓二。初明行根二。初简事从法二。初所简事身。事论己身人谁不解。故今简之。智推九界皆非己身。况人报质。二己身下所取法身。所取既深。验前所简非独人报。然若能解色心法界而舍事身。乃今所取也。今简不能解法界舍名非己身。须知实相为己身者。且是总说。若依释论。于实相身论戒定慧及妙善心。为皮血骨髓。虽分戒等一一皆是实相全分。二为他下就法明施二。初施实身五初施皮。为他宣说实相之戒。遮二边罪修中道福。此戒无相持尚叵得。岂存于犯。体既双忘名尸彼岸。如此说戒方名布施法身之皮。血等例尔。二说诸下施血。诸禅定者。九种禅也。亦是有漏无漏一切禅定皆达实相。皆成无记化化神通。故于灭定现十界身。名诸威仪。例前合云非定非乱。三说无下施骨。能照功忘故云非智。全惑成智故曰非愚。此智起说无说可得。能说既妙。故使所说皆到智地。智地者。智即是地本觉智也。智所依地始觉智也。修性合一二义俱成。四檀忍下例应施肉。论但三学及所显理。大师义加檀忍进三。成六度义。以消今经骨髓血肉。义方整足。说者应例前之三学明双非相。五说甚下施髓。前说戒等既皆双非。岂不断于言思之道。然是谈行今是说理。虽皆实相而须分别能契所契。六度乃是全湿之波。微妙善心是波中湿也。二将此下明施权身三。初结实标权。以圆法食充七方便饥饿众生。圆顿之外所有法门皆悉名为余饮食。以胜况劣也。二即是下正明施相。文略不语。三教菩萨别教六度可为余食。髓是中道必在己身。是故余髓但在真谛。三引法华正示教利喜者。大论五十九云。示者。示人生死涅槃三乘六度教者。教言汝应舍恶行善。利者。未得善法味故心则退没。为说法利引导令出。喜者。随其所行而赞叹之。令其心喜。以此四事庄严说法。二如来下成疑念。随他意语施权饮食。随自施实。二从大下明现瑞序二。初结前开后二。初节经。二至心下释意二。初结前二。初明至心。至犹极也。心佛同源。今欲念佛故须彻至己心实际。二观心下明念佛。观心既极。故能尽念佛不杀等种种功德。皆等虚空。以深观故乃成疑念。二明开后。妙机关应瑞相乃兴。二正明现瑞二。初叙意分文三。初叙意二。初正叙。为尔者。尔汝也。表发信相增分真因感究竟果。二问下料简作者二。初问。二答。二拣感者二。初问。二答二。初简通从别。二虽然下益本在他。信相既为发起之人。乃同诸佛而为。能应故知能感本在众机。故应一人是应众多也。二分文。三别相下判相二。初正判二。初约十因一果判。二又别下约十地一地判。二问下料简二。初约经宗简二。初问。二答。二约似位简二。初问。前判似位有二种意。一约十信似于分真。二例普贤似于妙觉。若今瑞相定表十地。岂令十信便登法云。岂使普贤倒入初地。二答。须知二往一一地中具诸地功德。十信发真获十功德。等觉亦进后心十德。此则前后皆沾十益。故约横竖从容而判。二别相下随文释相二。初节文示十相。二约表发释相二。初牒示诫劝。斖尾音。斐斖者。文藐。意谓止可以经十段文彩。准拟评议仿似之耳。不可备具论其行相。故云不可责其备悉。二其室下约相表德二。初竖表十地功德。十初此地初开者。大凡小圣无明所覆境界局狭。今破此惑故以广博表之。二此对戒者。准于华严十度对地。则初地当檀。文略不言。既诸地互具则十度皆融。三唯辱而忍增者。不逢屈辱宁彰忍力。四督出众行者。督率也。众行诸度也。率诸行至于极果。故以高座表精进也。五六七八九皆可见。十随阶而圆者。行以智导故随阶位。诸行分圆其犹根具。注云云者。应明六度十度开合之相。然六通大小十唯在大。十度者。于禅中有愿智力。故开愿度。有禅通力开出力度。根本定禅守本禅度。般若有道种智开出方便度。有一切种智开出智度。一切智守本受般若名。二复次下横表一地功德二。初总表一地功德二。初约初地三。初通示。二其下别表十。初室净表智二。初明了阴功能。室能覆盖故表五阴。欲彰智相须明了阴。于阴达中故双非二边。不为下释自然。中智不被二边所作。良由此智不作二边。故本来觉性任运现前。不得下释广博。微有所得即当局狭。非直下释严事。小智无常离过而已终归灰灭。大觉本有过河沙德自然庄严。二严事即下明三智体相。其室表一心。自然广博严事六字表三智。始行圆修今日顿发。二天绀下宝间表境二。初直表三谛。二一地下兼表融即。室中一地有此三相。可表妙境三一相即。行者应知。谛智名别其体不殊。欲彰修证强立能所。三有妙下妙香表慈悲。一心境智普能与拔即名慈悲。境智高广与拔称之。故使慈悲竖高横阔。三无差别。故能遍满一切众生三科之内。四其室下高座表四德。常我是法身。乐即解脱。净即般若。三德互具故一一具四不可思议。名秘密藏。是佛究竟栖依之处故以座表。五有四下佛坐。表觉智。本有四德即是三谛以为所坐。修得四德即是三智以为能坐。故用佛表。六放大下放光表自他。以照此土光即能照他土。可表以自行而化诸众生。七雨诸下雨华表四辩。解一切众生语言陀罗尼。用法义辞及乐说辩。一多融谈慈注无尽闻无不喜。以华表之。文字性离故雨于空。此辩方能诠示妙理。八作天下天乐表四摄。布施爱语利行同事。此四摄物其犹雅乐悦乐于人。九受天下受乐表法喜。一心三智即寂而照无法不知。此曰澄神受义天乐。十根缺下根具表互具用。业转现识已分破故。见闻觉知根根皆具。三初地下总叹。法性功德不可穷尽。此地能称法性显德。故使诸佛不能尽说。止十相者。经家略举也。梗介者。介应作概。声之误也。云梗概粗略也。二初地下例余地。此去九地地地皆然。将横入竖无竖不横。二复次下别表一地自他二。初约初地二。初略示。自行功德即自行因果。化他功德即。化他能所。此与法华十妙意同。二其室下正表二。初前五表自行。若以此文配十妙者。法身境妙。般若智妙。解脱行妙。因成位妙成佛三法妙。此自行因果也。若境智行对理性等住前三即。此乃从强约修别对。若论法体真位无缺。二后五表化他。意轮鉴机即感应妙。口轮说法妙身轮神通妙。又表下以受天乐根缺具足。既皆转障可通对于眷属利益二种妙也。此即化他能所。二初地下例余地。二从一下总现相二。初迷意总表。言意略者。止在十义故。意广者。以一切之言无所不该故。二一切下依文别表。该包也。十法界者。心佛众生三人皆具。具虽不异迷悟且殊。佛已证悟心生在迷。全迷则曰理性十界。信说则曰名字十界。念念体达名观行十。六根遍照名相似十。证十起应名非真十。今表极果乃究竟十。己心合佛十界体用。亦见众生十界同佛。是今表果十界之义。不作此解徒云一切该十法界。三世间者。假实依报也。揽实成假名字不同即众生世间。所揽实法色心间隔即五阴世间。正报所依依报差别即国土世间。未曾有者。分证十本分垂十迹。虽得圆融若望极果明昧尤别。如华严说灌顶菩萨所得功德如一块土。妙觉功德如四洲土。故因圆理显。若自若他三十世间一一究竟清净自在未曾有也。国土下以三世间配三德。且从义便也。国土等者。迷时假实既依国土。果上智断全依法身。故于国土明实相满。众生等者。释论云。众生无上者佛是。佛翻为觉。始觉人空终觉法空。故于众生世间明般若满。五阴等者。释论云。法无上者涅槃是。因灭是色获得常色。受想行识亦复如是。二执既尽五阴自在。故于五阴世间明解脱满。以三对三须知其意。良以三德举一即三。显三世间一一圆遍互融互摄。新伊天目类之可知。实相是要者。实相无相极果俱是究竟忘相。故称实相自他圆满也。五从信下默念腾疑序二。初分文。二欢喜下随释二。初见相欢喜。二从至下默念陈疑三。初明腾疑意。积疑不腾恐成疑盖。二念释下正腾所疑。一切功德依寿得住。其寿既促众德奚为。故皆不疑但念寿短。此覆不腾莫能决了。三而不下明默念意。威尊故默。求决故念。承前可见。六从尔下止疑序二。初分文。二疑盖下随释二。初正止疑三。初止疑意。疑盖覆心者。五盖中疑能覆禅慧。须预止者何哉。若未解理心合致疑。既睹威尊是决疑地。傥坚执疑念则观慧莫开。故须止之令谛心受法。例如等者。疑是见惑能障真谛。断疑见道方进真修。信相腾疑或权或实。佛止则令自他获益。二从汝下正止疑三。初大用不应。八十之寿是法界全体起应物大用。故不应以定短致疑。二法性不应。释尊所证性海渊深。岂以长短心虑测度。三智度不应。真信真智二皆具足能知能证。汝今未具不应度量。此三不应是约三身而成止意。亦可前二约所思止。后一约能思止。三释论下引证结。佛所有法皆悉无量。若以有量心虑量之。必当覆溺于疑惑海。是故四佛以三不应止其疑念。二何以下释止疑三。初释法性不应二。初明八众摄菩萨。经列八众虽已分明。但阙菩萨故约生法权实示之。法性土者。方便实报也。既不居此故不在言。二若凡下明皆不应测性。如来所游深广法性。尚过菩萨所行清净。况复凡小而能思算。二唯除下释智度不应二。初正释降佛难测。唯佛与佛乃能究尽因智那知。二旧用下兼示佛所知法二。初古释可知故无常。言此语者。唯除如来句也。寿量既为智之所知是可思法。验是无常。二天台下明今释常智知常。无量常智者。究竟无知方具足知。此知称性。以全本智成佛智故。既知本性性岂无常。古师不解故以有知而为佛智。乃以所知是无常法。三智性下令比知大用。无知之智既冥法性。法性本用具足发现。现长现短皆名常寿。以全性故。经释智性。略大用者。以可解故。七从时下集众序二。初正释经文二。初对他经前后。二时者下约今经解释三。初正明此室众二。初略释时众。二信相下明集众意。即八十寿显三身常。岂益信相一人而已。故以神力摄诸有缘。令闻圆常得四悉益。言益处多者。岂止一室。此众闻后在处宣布耳。二众有下兼明一经众。正明此室具四种众。傍兼诸品皆有四众。句三。初明此经具四众。影响众者。古往诸佛法身大士。隐其圆极助佛扬化。为伴奉主。如影随质似响答声。四众名义具法华疏。二此经下明众与诸经同。此中集天龙与华严何异。此品新本既云无量婆罗门众。又忏悔品信相出城。与无量无边百千众生俱往灵鹫。岂皆鬼神。验知集众与诸经同。三相承下止常情偏局解。岂以此品旧译文略。便云止集天龙众耶。三总瑞下明经部法益二初异法华属方等。一切世间合该十界。未曾有事悉具出现。合于十界皆显三德。而且未授二乘佛记。验知未可同法华部。但就通教对利根者。明三身常辨圆法性。与其二酥谈圆不异。既其首题不标般若。部内二处称方等名。故今判教属于方等。而此部中得圆益者。自于十界妙证新伊。亦得称为未曾有事。悉具出现。二此中下须乘戒显众益乘戒四句者。一乘戒俱急。二乘戒俱缓。三乘急戒缓。四乘缓戒急。先须了知乘戒体相。且戒论十种。唯取不缺不破不穿不杂。此之四戒虽分定散皆人天因。是今戒也。不取随道无著智所赞自在随定具足。以此六种虽名为戒体是三观。自属乘耳。乘论五乘不取人天。以其二种虽名为乘不动不出体是漏善事戒所摄。唯取三乘。以此三乘。该于四教。是入理智虽分深浅。皆动烦恼出生死故得名乘也。今以四戒而对三乘。论于缓急以成四句。乘戒俱急者。今之人天来闻法者是。其俱缓者。恶道苦缚莫预此会。乘急戒缓者。今诸龙鬼同集者是。乘缓戒急。着乐诸天嗜欲人等。不预此者皆是其类。复须了知。集今会者虽云乘急。乘有权实。宿世修习藏通急者。今在室中睹于四佛佛身不同。但见应化。纵闻长寿须归灰灭。灭已不生。若其宿修别圆急者。今睹四佛同尊特身一身一智。闻山斤等虽是应寿知即法报。三一难思名见常身。权实等者。此四缓急众生之中。有实行者。有权示者。权能引实作种熟脱久近因缘。故云等事。别记者。即法华净名疏及止观也。今依彼说故注云云。三齐此下判属序段

金光明经文句记卷第二(下)金光明经文句记卷第三(上)

        宋四明沙门知礼述

二从尔时下大段正宗分二。初总示文义二。初示经文起尽。忏悔赞叹空品三品全。及此寿量半品。同是正说。二凡三下辨三章大义二。初叙他师二。初正明他义三。初叙初师。二二云下叙次师二。初叙。二次乃下章安破。以今不云师及天台。知是私破。空虽是中乃是因位用中破执。且非果上所显中体。法虽不异用显义殊。古既昧此故今不用。三三藏下叙真谛二。初叙。虚空等者。新经三身分别品云。虚空藏菩萨白佛。云何菩萨于诸如来甚深秘密如法修行。指此为叙也。二直是下章安破。诸经节节皆有发问。岂尽称叙。故云义弱。二师云下今师去取。彼虚空藏虽约因问。佛答乃云一切如来等有三身。岂非果义。故去三藏取初家。次师可知。二新旧下明今意三。初就新经明宗体三。初四佛说迹以显本。拂八十之短疑。明海滴之长应。既闻应化能长能短。则达法报非灭非生。本迹既融思议乃绝。上根之者秖闻其迹亦悟本源。当第一周也。二若未下王子示本令悟迹。新经寿量品。四佛说寿益物事讫。有憍陈如婆罗门欲生天故。求佛舍利如芥粟许。犁车毗王子说偈答云。假使蚊蚋脚。可以作城楼。如来寂静身。无有舍利事。兔角为梯蹬。从地得升天。邪思佛舍利。功德无是处。鼠登兔角梯。食月除修罗。依舍利尽惑。解脱无是处。中根直闻法身理本不生灭。乃悟报应能常无常。理事既融思议即绝。当第二周也。三若未下释迦双论令俱解。下根既钝。偏谈本迹不能悬解互融之意。是故释迦具演三身。所谓法身应身化身。如依空有电依电有光。法身是理应身是智。智既应理即起化身。三身冥一一不定一。三身宛然。是故品题三身分别。法应是本化身是迹。一时俱说则生妙解思议乃绝。当第三周。此之三番皆说如来常宗显体。意令闻者发智证理。二忏品下判三品俱明用。佛智之宗显法性体。此即名为经宗经体。一切众生以此宗体而为本心若能忏叹及修二空。故佛妙用全体而起。令此众生灭恶生善。及发空用导成二用。故云三品俱是经用。三今之下明此本略二番。以其二番皆显三身。今此一番所显不别。是故谶师顺好略机不翻后二。二文为下分文解释四。初文二。初分文。二解释四。初四佛说偈二。初经家叙。二四佛说喻二。初料简身说二。初问。二答二。初明说。本称机宜共别无在。二见亦下明身。释题判教此经属通。此教明佛丈六尊特一身异见。故名合身。今此室中有三乘众。三中菩萨利根之者能深观空见不空理。不空理者。乃是生佛同一觉性。故虽见佛佛非外来。随大随小皆无边际。故云四佛同尊特身身智应用是一是常。岂唯诸佛无二无别。与其弟子亦复不异。故云众一。虽未开废利人见同。若钝菩萨及二乘人既但见空。乃睹四佛自外而来。取色分齐但是应化。佛尚各异弟子岂同。三乘差别故云众多。二分八下分文解义二。初叙二家分文。二旧云下从初师释义四。初四偈立譬二。初斥古二。初叙。二是义下斥。诸佛说法三时不谬。故上中下善。能诠有法故其言巧妙。所诠离情故其义深远。若齐无意宁悟常宗。故知古师全迷经旨。二且作下今释二。初开章叙意二。初开章。大师所解其义无穷。称机释文且示三意。二四谛下叙意二。初明三因果。四谛是理。因果通依。四念是行。修之在因。四德本有。证之在果。非此三义莫显常宗。二若论下明三相由。讨果由因因果由谛。欲成因果解谛居先。二上以下依章释义三。初约四谛释二。初用四谛释偈二。初悬说谛义二。初明四谛义三。初对上明境智。上明能说人宜对于智。今明所说法合对于理。二旧读下斥古唯齐事。言读文者。大论第三解十号正遍知文也。故论问云。云何正遍知。答知苦如苦相等。旧读此文虽以如字为不异解。而昧三藏以知事称理为不异。摩诃衍中以知事即理为不异。致使解义唯齐于事全不显理。又复此文解正遍知。正知于真遍知于俗。三今明下明今师正义二。初约二谛。二约三谛二。解意者。以苦等四是世出世因果之境。于此四境若其不了。即真即俗及空假中。则不名谛。仍了二谛以中为真。三论空假意在谛中。欲于迷悟十界因果。一一见中法法无作。方得名为世相常住。其理不尔。将何以拂信相之疑。二句皆初约苦谛释。二例余谛结。二明识下明对谛意。二一切下以谛释文四。约因前果后以水山地空。对集苦道灭例皆分三。初牒示二引证。三释结。苦谛中引小般若者。金刚般若也。对大品等称之为小。以文为小理同大部。彼以须弥喻于佛身。今证苦者积聚义同。非集所感。然用佛报证生报者。彰苦无作阴入皆如。无苦可舍即生成灭故。盘峙盘回。峙立也。或作磐字误也。道谛中引法华智地者。以地喻地。既到智地道之中也。水陆两途者。陆途但到海之此岸。可喻三乘通修道品。未度变易犹在此岸。水途能到海之彼岸。可喻一乘别修道品。能即二死到三德岸。灭谛中引法华者。以空喻空。此空毕竟故曰终归。五翳者。烟云尘雾修罗手也。三光者。日月星也。常住灭理本来不翳今亦非净。问若以山喻佛身。道以地喻智地。灭以空喻妙空。此三既有即理之教。则可论于所证法身。若初集谛引证释结。但论烦恼岂可亦得名法身耶。答无作四谛一一皆中。若非一切咸趣烦恼。那名即中。以即中故苦名法身。道是智地。灭名妙空。故知直以烦恼释集示于法身。其意最妙。行者知之。二明四谛释疑二。初示理明疑断二。初示理明相。上释总瑞一切世间末曾有事悉具出现。以表十界假实依报皆显三德。今明十界假实依报一一四谛谛谛三德。是理遍相名为法身。知此名报。起用名应应有长短。二信相下示断疑相三。初所断疑。二四佛下能断法。四种之喻本晓应长。大师特以四谛解之。若非应寿全是法身。三身一体何以妙会疏之两说。故先示云。其言巧妙其义深远。若定喻一身言岂巧耶。三若并别义岂深耶。三举应下叹意巧。文喻应长意彰报法。信相得意疑暗豁明。二释此下叹释妙劝思。四佛巧喻断信相疑。智者妙释发行人解。今既得遇岂不审思。二四偈下约四念释。念者即空假中三妙观也。处者身受心法四妙境也。非此观境三身不显。岂曰谈常。此释分三。初以偈对法三。初舍别从通。身受心法但是五阴。故知四念本在苦谛。然念处观修通四教。今唯约圆。谓观身净不净非净非不净。乃至观法我经我非我非无我。皆成三谛。二一切下从通对释。想行念处者。秖是法念合此二阴。今欲配地故存阴名。想取行行者。想取相貌。行乃迁流。故云行行。下行字平声。三若观下对偈所以。常寿因果非圆念处无由得成。故用对偈。二若观下以法疑释二。初明念处因果二。初修因相。四枯即空。四荣即假。双非即中。说有次第修无前后。乃一心三观也。故佛于其四枯四荣双树中间般涅槃者。正表于此。二成五下得果相三。初明三德融即相。即枯即荣即非枯荣一刹那修。刹那刹那圆念不息。历于五品发似证真。至果位时三惑尽净。百界五阴自在无碍。名五解脱。百界五阴清净如空。名五般若。百界五阴究竟难思。名五法身。智冥五阴理是所冥故。称之为理。体虽是一不分而分。般若能冥法身所冥。以相冥故起解脱用。虽三下明秘藏义。如常所说。二仁王下明五阴常住相。性名不改。即百界五阴八相莫迁十方周遍然非事底别有性阴。秖善恶阴秽污阴等。当体常住名法性阴。慎勿别求。三阴之下明三身体用相。法报双非全体起用能常无常。常用则长等者。长则四喻短则八十。既皆应寿悉是无常。今以长短分常无常者。由山斤等能显于常。若非体常。安令应用人天莫数。是故信相闻八十灭疑寿无常。闻四喻长悟常住体。故云常用则长无常用则短。二信相下将果用释疑三。初所破之疑。二四佛下能破之法。三信相下得解之相。此三兴向四谛释疑其意不别。然须深究。三四偈下约四德释二。初以偈对德。碎地为尘尚无净相。岂存于秽。故对净德。喻于理净净于净秽也。二四德下以德释疑二。初显德用。常等四德学者须拣。名同体别。一凡夫所著常乐我净体是见思。二菩萨建立常乐我净体是无明。三佛之所证常乐我净体是中道。今四皆中。是故皆以双非显之。理须非于十二倒也。今此常等与其非常非无常等名异体同。四德双非即法身也。四能冥智即报身也。法报既冥则能应物起常无常至净不净自在应用。二信相下除疑念三。初所破之疑。二四佛下能破之法。三信相下得解之相。若知四谛断疑之意。此三可见。二亿百下一偈合譬二。初标古解二失。二旧云下明今意破古二。初破僻取文二。初出古解。古秖齐文不知四佛巧示之意。二示今意二。初示经深意。四喻有量百千是数谁不知之。须达举量举数况于无量无数。二汝既下斥古诬经。言有纵夺。纵知应化。夺迷报法。报法乃是应化体本。深文浅解自毁毁他。自既招愆令他谤教也。二破偏执义。义是所诠化身应身法身。此之三身皆具四句。谓常无常双亦双非。显乎三一不可一异而思说之。古人迷此化定无常。或闻化身即法故常。犹谓法常化是无常。良由不了即字义故。故起信论云。随其所应常能住持不毁不失。此显化身二义具足。三以是下二偈断疑二。初牒因释义二。初以事行消文二。初约因缘释。因亲缘疏。不杀存命为长寿因。此因亲义也。施食助命为长寿缘。此缘疏义也。二若作下约二缘释。不杀有二。不杀是止善。放生是行善。不盗有二。不盗是止善。施食是行善。是故十善各有止行悉名二缘。经于二善互举止行。一一皆是长寿二缘。发菩提心方名为因。言法性者。无作四誓全法性起是长寿因。种种二缘既能资助真正道心。乃会法报非常非无常。能起应化常与无常。三身一体斯为妙常。二法食下明法门指上。若就法门明于施食及不杀等。如疑念序疏中具说。二修因下据果断疑。以长释短无常疑断常住寿明经。是故大士。即指如来。如言无上士也。故义净。新译此句云是故大觉尊。四是故汝今下一偈结成。二尔时下信相欢喜二。初据所闻释信相解。言本迹者。体本用迹也。闻寿无量解迹用能常非长之长也。乃知迹用能短非短而短。定八十之疑自兹而去也。深心者。悟于报法高深之体也。此之本体妙绝于量及以无量。二踊跃下约入位释欢喜。真信解发入欢喜位。别在初地圆在初住。并破无明名疑惑。去此皆内凡而释似。位十地顶。者若不立等。觉即第十地破上品无明之。惑升于后。心此位名为众伏。之顶金刚喻定。既为最后无明所动。故生欢喜及踊跃也。三从说下当机得道。上根初悟者。即用新经三周意也。陈如求舍利为中根。三身分别为下根。阿耨多罗三藐三菩提翻无上正等觉。即一切众生本来觉性。非登极果方名无上及此正等。此觉心发通于五即今是分真。四从时下四佛还本。二初因缘释。此信相等一类机缘觉性合兴。乃感四佛不现而现。现为发心。心既已发故不还而还也。二观行释。谛境者。三谛一境本觉也。觉慧者。三智一心始觉也。全本起始名之为发。始合于本名曰相应。善相应者。必双忘也。不忘乃是通中起塞。为表俱寂故不现也。二释忏悔品二。初释题二初明忏悔义二。初正明大义四。初释忏悔名三。初对他经。方等陀罗尼经明四众忏法。普贤观法经明六根忏法。大经阇王忏逆。请观音经销伏三障。诸经观门皆能灭罪。何法非忏。然菩萨行为转先业。作利他缘。乃论无生等三种忏法。声闻自度纵明忏悔。多在作法求免三途。故今但对大乘诸经明散明专。二正释名五。初约伏首释。然忏悔二字乃双举二音。梵语忏摩荜言悔过。以由悔过是首伏等五种之义。今既华梵二音并列。是故大师以首释忏以伏释悔。乃至惭愧对释忏悔。欲令禀者即于二字修首伏行及惭愧等。斯是善巧说法之相。故不可以华梵诂训而为责也。初约首伏释。首音兽。自陈罪也。款诚也。二约黑白释。企望也。尚犹尊尚也。三约弃求释。鄙耻也。恶乌路切。嫌也。四约露断释。发露过现断未来续。五约惭愧释二。初总释。直以惭愧释于忏悔。未分五种人天之义。故名总释。二惭则下别释。乃分人天及以四教事理之别也。二初约人天释。人是肉眼但见其显。诸天则有报得天眼故见冥密。此人惭耻愧赧。名为忏悔。二又人下约四教释。良以此经通三乘忏。三乘乃摄四教故也。既惭愧义该于四教。首伏等四岂不然耶。说者据义应细作之。又四教贤位皆要加功。圣则任运可类三界人天果报作意自然。又四教贤圣有修有证。四教之理本非造作。是故复得名为人天四。初三藏二。初贤圣。贤则七贤。圣则四圣。逮及也。二又贤下事理。二又惭下通教二。初贤圣。此教菩萨同二乘断惑故三乘皆圣。二又三下事理。三又三下别教二。初贤圣。通教圣位止断见思。别教三贤能断尘沙又伏无明。故云尚非。二总此下事理。此以但中为第一义。四又三下圆教二。初贤圣。三十心去皆证法身皆垂八相。故判为圣。十信长别苦轮海故。故得名贤。二总此下事理。以具德中为第一义。三合十下合十数。以惭愧中分于总别。总一别五并首伏等四。故成十番释忏悔名。二明忏悔处四。初明忏须得处。忏之所依如器淳朴非砧不成。以何为砧。谓一实相无别实相。即罪相是。得此处者。罪无不灭德无不显。此自分二。初引经明处二。初引诸经二。初引大经二文。粗言软语等者。七方便教三障须灭众行须修。能所不泯名曰粗言。若圆教者一切修恶皆即性恶。所破既寂能破自忘。无言之言名为软语。于此粗软当处寂然思议道绝。故曰皆归第一义也。四真谛者。二死之苦五住之集。以即性故无一可舍。万行之道三德之灭。以即性故无修无证。而言断生死者。就即论断。无断之断断无不尽。亦口断于性德之苦。此四绝思皆第一义。能如是知名为得处。二引法华二文。履历名行亲习名近。此二皆须依一实处。欲忍众辱要住理地。此地是心更何所行及以分别。亦不谓我行不分别。若不尔者。何名得处。宝处在近等者。指障即德近岂过此。然须观照故云前进。废执权情名即灭化城。体权是实名即至宝所。二引此经二。初引。我即真我离人无法。法即所揽常住五阴。此阴为舍普覆众生。阇王说偈解第一义。名归世尊。令此经云。我作归处。彼感此应其义泯然。二归依处者下释。经云。我作归处我体如何。故以法性谛理妙境佛师秘藏。而证释之。十方等者。若分若满圣皆住中。即以此处令众生住。初心能住名为得处。二若得下结示须处。实相本立则能生于无生妙忏清信之道。若其不体诸法即性。乃于中道平坦之地。而起八倒名为颠坠。如盲等者。四眼无明盲于佛眼。入于偏教诸见棘林触途成碍。皆由失处。二故普下明得处忏妙二。初约妙明忏三。初引经示妙。端坐者。身仪也。禅波罗蜜具出坐法。须者宜检。念实相者。忏罪观也。实相无相当云何念。必以无念之念念无相之相。以无相相相无念念。若于念外别有实相。实相之外别有于念。则非此经念实相也。众罪等者。灭罪所以也。前念实相盖体修恶即是性恶。性恶照明斯为慧日。修恶本虚如锁霜露。我心等者。亦出此经。心性本来即空假中离三惑染。名曰自空。十界罪福二我叵得。谁为主宰。如此体达是无生忏。故使如来立三种名。二无罪下约义明妙。以三种名对于三谛其义可知。若于三谛历别而解。乃次第观非今妙义。其义妙者。空即三谛假中亦然。名即一而三三谛俱空假中亦然。即三而一。行者应知。三一相即为彰忏处绝乎思议。若以此语增于言想。则永不识忏悔处也。三诸大下约人显妙。大人所学其法岂粗。二若识下结名妙忏。解见思心即三德藏。罪根既寂忏法自忘。能所泯然。何以名状。强称此处为妙上也。三大经下明忏妙人尊二。初引经书示。当念深广其犹大海。就此忏悔名之为浴。万行皆摄名用诸水。此喻忏得般若。无始恶业系属行人犹如债主。见业实相名依投王。业随观转名返供养。此喻忏得解脱。心性无上犹如墙头。初心达性如草依高。行位虽卑已能超过七方便顶。此喻忏得法身也。书云。即刘子也。二行人下举行人结。四行人下劝先求忏悔处。然忏悔处谁人不具。何法暂非。但为本迷满目不见全心不知。故下文云。于十力前不识诸佛。劝求觅者。须亲善师须凭妙教。勤听勤问审读审思。若其然者必于能诠识所诠体。翛然虑外无以状名。斯乃所求法性道理。此理至妙为忏法所依。故名为处。若依此处而立行门。方得名为大乘忏也。三次明下明忏悔法。此乃示于能忏之法也。三初开章。此之正助亦名慧行及行行也。大约即是缘了二因修德之法也。二正法下示相二。初正法二。初略示。上办处中虽语能观。意乃以观显所依处。今说能观意乃以处显能观观。法不孤立故须相带。解之不滥方可用心。二法性下广示二。初明修观相二。初就内心修观二。初明观随于境。法性者诸法实相也。名如来藏何德不具。虽具此德而本离念。今乃称本绝念而观。是故此观亦具本性一切功德。是故结云观慧亦尔。二境智下明境观不二二。初融境观二。初示相。境是本觉智是始觉。虽分本始而是一觉。境智既尔。方曰相冥无二之法。故举此经如如不。异如名不异即境不异智智不异。境。亦云一合。其体一故方能冥合。二经言下引证。经即仁王般若也。智是般若处是实相。能观之智与所观处。同是般若智外无境也。二皆实相境外无智也。境智相冥其状如是。二说如下会说默。复由说默二相不异。显于境智一体相冥。非由无相境智焉发即默之说。非由性离之说。莫彰不二境智。故境智后须论说默。是以止观义例云。故不思议境即是观。是故得云境照境境照智。智照智智照境。照者方照非说可穷。照者应说非照可了。说者方说非照可穷。说者应照非说可了。故知彼义与此无殊。二以此下用净心历法二。初例内心泯净。上论妙观且就内心研于妙境摄一切法。观境若成可以此观遍历三科及以业惑。自然皆见不思议境。故义例云。修观次第必先内心。内心若净。将此净心遍历诸法任运冥合。二故云下引教示融相二。初约法示。毗虑遮那此方翻为遍一切处。乃以华音彰法体遍。髓虽本遍迷时不知。今以内心妙观遍历于一切处。皆见遮那。此犹总历。复更别历六作六受。行住二作必兼坐卧语默作作。是名六作。明暗略举眼受于色。合例取声乃至意法。是名六受。故总结云六根所对。虽结六受身必六作。于此作受常得见佛。佛必三身。斯由内心成妙三观。故于作受常见如来三德三谛。是故结云无非佛法。二者婆下引事喻三。初以耆婆喻任运破障。二以摩男喻法尔生善。三以那律喻自然显理。此三乃是别示三观遍历一切。任运能契微妙三法。说有前后照不纵横。二若如下明灭罪相。既于内心复历缘境谛观冥契。乃达十界罪福无主。修恶修善全体即是性恶性善。斯乃名见罪福实相。故法华云。深达罪福相。遍照于十方。十方即是十界。十界皆实相。相相宛然一收一切。一切皆各收于一切。此等一切无非实相。妄想皆实实亦自忘。此为大忏。二助道下助法三。初明用助意。正助二忏修逐根缘。自有一向修于正道直登圆住。或内外凡。自有一向修于助道。如南岳立有相安乐行。不入三昧但诵持故。亦能得见上妙色。像此二随根修入。不同若悟理时必。两舍也。自有正助相兼而修。或先正后助。或先助后正。或同时而修。今之所立意在同修耳。若于三句都不摄者。则人身牛也。二所谓下明助道法二。初喻用助意。清水喻正灰等喻助。以垢难去独水不能。灰皂助之水方有用。二略言下示助道法。助本助正。正观不开盖理惑覆。故修助行治于事蔽。事蔽若息不实理惑。故令正观开入理门。具论六度略举三业。其策观者。或以五法策于正观。亦助开门或策事观。谓五门禅各有对治助开正观。三如顺下明用助功。正解如顺水。正观如顺风。可喻正道能趣妙理。篙棹可喻施礼等善。助于风水船岂不疾。三如是下总结。四明忏悔位三。初他释局浅二。初叙他。二此下略斥。二故新下今释通深二。初正释二。初明六凡合忏二。初四趣二。初明地狱二。初造逆。鞠亦养也。抚拍也。惟惟。怜子之貌也。内则六年教之数与方名。注云。方名东西。杀逆。杀或作弑。同音试。下杀于上也。易曰。臣弑君子弑父也。天虽下明天地之不能客其受生。故须入地狱也。以五逆罪。感五无间二。佛为下二明破戒初篇四重也。后聚吉罗也。若论五篇则初后俱篇。六聚则始终俱聚。绮文互现。故云初篇后聚也。三师谓和尚及羯磨教授二阇黎也。七僧印证戒者。此据中国十人也。佛海者。佛法如海犯重如尸。花园可解。言犯重者。须出净众。二多嗔下明三趣。心既多嗔等身口动作成于嗔业。故堕蛇虺。举本摄末故云多嗔。下多欲等悉可为例。蛇虺者。尔雅云。蝮虺博三寸首大如擘。郭[王*業]云。身广三寸。头如大擘指。此自一称蛇名蝮虺。谄者。庄子云。希其意而道其言曰谄。饿鬼当饥等者。举果难当须明忏悔。二人中下人天二。初人。八苦者。生老病死怨憎会爱别离求不得五阴盛。二天五衰者。衣裳垢腻。头上花萎。身体臭秽。腋下污出。不乐本座。四心者。受想行识也。笼樊者。樊藩也。诗云。营营青蝇止于樊。今众生处三界中如在笼藩篱之内。不能自出也。二苦出下明四教皆忏四。初三藏二。初声闻二。初七贤。初五停心谓不净停贪。兹悲停嗔。因缘停痴。数息停觉观。界方便停着我。若贪等五烦恼障心不得停。应须忏悔。停下剩心字。次四念处去。用对位道品。四颠倒者。执身净受乐心常法我。四念冶此四例。四正勤者。二恶者。已起令灭。未起令不起二善者。已生令增长。未生令发生。四如是足者。谓欲精进心思惟。五根者。谓信进念定慧。五力者。名同于根。以不动排障而分两科。法华文句以正勤如意根力四科。对暖顶忍世第一位。暖顶与此有不同者。或是文误或别有意。二苦忍下四果。苦忍明发者。见道有十六心。谓于下欲界四谛。各起法忍法智。上色无色二界四谛。各起类忍类智。此上下八谛共十六心。断八十八使见惑也。今云苦忍即欲界苦谛下苦法忍也。明发得苦法智也。观欲界苦谛已。即观上界苦谛得类忍智。余三谛例说。虽不下以无见惑横起。故不堕恶道。欲界七生者。欲界九品思惑共润七生。谓上上品润二生。上中上下中上各润一生。中中中下共润一生。下三品共润一生。此言初果也。虽断欲下明二果。五下分者身见戒取疑贪嗔。贪虽通上不是唯上。嗔一唯下不通于上。余三遍摄一切见惑。虽复通上而能牵下。纵断贪等至无所有处。由身见等还来欲界。是故此五名为下分。余三品在受一生名一往来也。虽断五下名三果向人也。余一品即第九品也。亦名一种子那含。虽断色下正明三果人也。九品已尽不来欲界。而进断上惑。虽入下无学二支佛。侵习未能全尽故须忏悔。言亦尔者。例上罗汉忏习气也。菩萨未断且在人天二若干下通教。教诠体空异前析灭。空含中道是大乘门。利根方见属后二教。今就二乘及钝菩萨论忏悔也。支佛不达文字者。不能说法化他也。然支佛有部行麟喻之别。部行者。或能说法。今约麟喻为言也。独悟孤行喻麟头之一角。故名麟喻。三十信下别教。十信但信者。信能造心是佛性故。未能称理者。以佛性心别修空故。故使十住偏证空理。十行但出建立之事。既其二观互破互立。未能入中。十向不偏但修未证。然由渐修登地顿证。前前虽显后后犹障。是故名为地地有障。至等觉尚有未得无学。故此凡圣皆须忏悔。四又十下圆教。此机初解中具二边空假即中。故能三智一心修证。不言名字及五品者。以高况下也。十信尚忏况尔前耶。但是等者。法华中说三陀罗尼。虽通初后似位得之。其相最显。一旋旋罗尼旋假入空。此齐七信。二百千万亿旋陀罗尼旋空出假。此当八信已上。三法音方便陀罗尼。以二观为方。便转入中道法音。当第十信也。匡郭等者。此三喻于法身智断。俱未究尽俱须忏也。二齐此下斥局。下从造无间业者上至圆教等觉。故云位长。位位横论。各有三障烦恼头数结业流类苦报等差。故云义广。古人何为但在凡夫。三是故下引经证结。大师本以三昧总持说忏悔位该亘凡圣。自然与彼校计经合。寔匪寻经作此安布。行者知之。三若人下举利勤修四。初明闻者宿殖。二语其下明闻者得报。果报者。此忏诣理功至极果。乃与诸佛互相恭敬。三直闻下以闻况修。解既称理修之成行。则分满之果证之匪遥。四已闻下。结示归敬。佛恩若此。欲报之者唯当而说而修行之。归命礼佛五悔中一。其四悔法安得不修。二正释品题二。初释二字义二。初依字训释二。初释忏二。初明求鉴。恧奴六切。惭也。二身被下明被鉴。二释悔二。初明能废。二明所废。意云十废者。意如君主。身口如臣。君既克己臣息暴虐。故意总十。二又法下约法门释种种。二忏悔下明三种忏三。初明三种相貌二。初列名示。列三种名示事通大小。二小乘下约相释二。初明小三初作法。毗尼此云律。二十僧者。此约忏僧残罪也。然对治有四法。一治覆藏情过。谓行波利婆沙。此云覆藏。或云别住。谓别住一房不得与僧同处。设入众中不得谈论亦不得答。行此法者须满一百日。不忆元覆藏日数故。乃以百日为限。二治覆藏罪谓犯已覆藏得吉罪。不覆藏得残罪。若覆藏者先忏吉罪后与别住。三治僧残情过罪。谓六夜行摩那埵。此云意喜。前虽自意欢喜亦使众僧欢喜。由前喜故与其少日即六夜也。故名意喜。僧众欢云。此人改悔成清净。故云众僧喜也。四治僧残。谓二十僧中以白四羯磨出罪。然覆藏不经明相直行摩那埵。然后入众出罪。或半月作法者。谓行别住。时每至半月说戒。须白众僧云我犯僧残。对首作法者。忏重吉也。责心。忏轻吉也。摩夷论云。故作者对首一说。误作者责心而悔。小乘犯夷亦有忏法。而疏文不引者。以忏已既为学悔沙弥仍障圣果。故非此中复本清净义也。故荆溪云。小学悔已障果仍成重罪未忘。二阿含下取相。上明作法但令三业顺于佛制法成罪灭。尚是散心罪灭犹浅。今论取相属于定心。想成相起灭罪则深。故蛇口想成岂唯淫。罪得除。亦乃欲心不起。三亦有下无生。言观空者。析法明空也。观造罪心本无主宰。念念无常无谁能作无是业报。我见若亡诸使永寂。此观若成四趣则除三界须出。小乘三忏其相略然。二明大三。初作法。二取相。三无生。行者应知三种忏法。无生是主二为助缘。故前疏云。灰汁皂荚助于清水。若阙妙观不名大乘。便同外道无益苦行。须近善师学忏悔处及忏悔法。方可行于道场事仪。故于诸事皆用妙观照而导之。使作法等皆顺实理悉为佛因。有谓道场所修行法而而事治。须于十乘先修六法后方助开。而不思前六在道场中用。如今明忏具谈三种岂舍事行。又有一卷法华三昧别行于世。大师制立正为初心忏障道罪。方可造修诸禅三昧。又诸苦行精进之门。各随宜乐初心可修。但须皆用圆无生观为主为导。使一一行即修是性无修无得。则成圆行也。岂诸事行妙观妙境妙修。发大心安心等法皆妙修耶。若其然者。随自意中历彼三性全无十乘。何名三昧。若自未谙当依善友开导策修。乃成深益。又须了知。大乘三忏。后一虽可独修不进则须假前二。前二不可暂离无生。得此意已方可说行三种忏法。初作法。八百等者。虚空藏经云。知法者复教八百日涂厕。日日告言。汝作不净事。一心涂治一切厕勿令人知。涂已洗浴礼三十五佛称虚空藏名。向十二部经五体投地。自说罪咎等。九十日等者。般舟经云。有四事疾得是三昧。一者不得有世间思想如指相弹顷三月。二者不得卧出三月如指相弹顷。三者经行不得休息不得坐三月。除其饭食左右。四者为人说经不得望人衣服饮食。是为四。般舟此云佛立。三昧成时见十方佛在虚空中立。故名佛立也。灰汤下明上诸行法各净三业也。旋诵下诸法各有制度旋诵之度方等最切。旋一百二十匝诵袒持咒一百二十遍。一旋一咒不徐不疾。旋讫却坐思惟中道正空。导此轨仪故名作法。二取相十二梦王者。方等陀罗尼经云。先求好梦凡十二种。随得一相则许忏悔。梵网经云。若犯十戒者应教忏悔要见好相。好相者佛来摩顶见光见华等便得罪灭。唱声下彼经明行者梦中若坐禅中现此菩萨。以摩尼珠印印行者臂。作罪灭字。或闻罪灭声。得此相起知罪必灭。虽不下以在道场非不作法。俱从胜立名为取相。言事用者。作法也。三无生。以无念念念罪实相。念与实相能所名别其体不二。如是念之罪相既忘实相亦泯。此慧如日销罪霜露。无缘缘毕竟空无中边相。此理无过故名最上。虽不下此三种忏同时而修。无生是正二为助缘故云兼两。斯乃正助一合而行。如膏益明证理弥速也。二作法下明三种功能二。初正示功能二。初明灭恶二。初四番通小释。言通小者。以此四番释三种忏。意虽在大而且未彰异小之相。故使灭恶于大小说皆无妨故。故云通小。四中初约遮性释三。初作法。无作罪者。昔受佛戒由作法故发无作体。若毁犯者得违逆罪。今由作法翻破此罪。言性罪者即十恶也。不论受与不受犯之性自是罪。如犯下论云。斩大草杀畜二罪同忏。二种违制之罪俱除而杀畜偿命犹存。二取相。由以定心想成胜相。熏修力强能转恶业。是故能灭性遮二罪。如代下枝叶喻性遮罪。根本喻无明也。心惑既存罪可重作。如枝叶续生也。既对遮性辨于无明。故此无明通界内外。此即通小之相也。三无生。二又下约三学释。作法防非故灭戒罪。取相专意故灭定罪。无生观照故灭慧罪。事非是戒家罪。散乱是定家罪。惑暗是慧家罪。三又作下除三报释。虽俱报障而有苦乐。三恶唯苦违法而得故作法能除。人道之报半苦半乐。散善所招故取相能灭。三界天报望人皆定。无苦惟乐。三漏所感故无生能灭。四又下除三业释。例报可知。能感所感而分两释也。二又作下二番惟大释。前之四释通大小乘。无生灭惑未简通别。作法或取毗尼之制。今之二释无生的破障中无明。通惑不生为今取相。验知此去惟就大释二。初别烦恼释。怖畏属思忧愁属见。今作法成位在五品。能伏此惑。指伏为破故云亦是。取相忏成在七信位。故灭四住。既见真谛望中名相故名取相。无生观成位登初住。所除的在根本无明。故知此释别就大乘明三种忏。二又三下通三障释。共除报者。此乃现报。父母生身得六根净。转报实在正助合行。若但理观虽入真似。亦有不得六根净者。故云三忏共除报障。取相除业者。约出假说。能挟宿世无量业种作度生缘。业不能障于业自在名除业障。以其未是真出假位。故见俗谛犹名取相。无生除惑其义可知。二又作下明生善。仍约喻显五石者。谓白瑛紫瑛石膏钟乳石脂。五芝者谓五色令芝也。姜桂且喻小乘作法故未生善。若大作法生善非少。五石五芝通。喻小大生事理。善二如是下劝人修。学言须知者谓须知小大皆能灭恶生。善须知此三修方有。益说而不行为罪所得也。三今文下明经具三忏二。初示经有三文。二结忏为经用

金光明经文句记卷第三(上)金光明经文句记卷第三(下)

        宋四明沙门知礼述

二从此下释文二。初对判分文二。初对判。明经力用通指三品也。今品下乃以此品对赞叹品论于傍正耳。二此品下分文。二梦者下依文释义二。初明梦中见闻二。初梦见金鼓三。初正见金鼓。二初释梦。疏中前释信相菩萨在其似位。或是邻极之似。或是邻极之似。于此位中梦见金鼓。岂是博地昏惑之梦。故以二义释于梦字。初谓三昧名为如梦。由达性具修德无功因办果事。如梦勤加。是故名为如梦三昧。次又入下乃以凡人有梦有觉。喻法性观有入有出。此以说默而为出入。二释皆示梦是观智。初释稍亲。问梦是颠倒迷真之法。观是觉智悟理之法。经文云梦。疏中那以观智释之。迷解天殊。如何融会耶。答佛地迷尽凡夫未解皆不论观。于迷能解得言观智。故起信论云。依业识故故说见佛。若离业识则无所见。今明似解照法性故。名为入观。依业识故名之为梦。智解未极安得非梦。照法性梦岂非观智。不得此意此文莫销。二法性即下释鼓二。初正释二。初直表三德。能观之智既以梦示梦必见相。故以金鼓表于所观。即法性也。盖由鼓体具圆空鸣可表三德。其状姝大复彰三德无量甚深。二姝大下三皆深广。以此三德一一皆是法性全体。趣举一德皆能具二。得名三身三智三脱。若不尔者。那得三种皆无量甚深耶。二此下结示。即鼓之三德对光秖是所照法身。即此法身摄报摄应为上三德。故云观一而见三佛也。二从其下见鼓光。全所照理起能照智。故法性德皆成智德。鼓圆空鸣光岂不尔。鼓三姝大光亦合然。须知法性体是本觉智是始觉。秖是一觉由不觉故分本始殊。既成大果已离不觉。故始冥本称法报合。岂始觉得异于本耶。所引新本同体同意同事者。既法报合故与诸佛无二无别。此即下此见鼓光正表报智。此智冥法法具三故故报亦三。亦是此报上能冥法下能垂应。故云具三。三复于下见光中佛二。初约文表义。言光从等者。对上二身。此总表应故云同事。应不孤立必具三身。琉璃下法。佛坐下报。大众下应。二此即下结义归圆二。初别结此三。以全法报为应身故。是故经文具表三佛。二睹此下通结上义。言三佛者。即鼓表法佛。光表报佛。明表应佛。既其三佛皆具三义。乃显法法具三。略则十种三法。广则一切皆三。此诸三法顺譬释。则世金光明所譬三法也。若就附文当体释。皆是法金光明。以一一具三可贵可重义。寂而常照义。能多利益义故其义既尔。是故此经名金光明也。此所表义乃由大师得旋总持。一中解无量无量中解一。故释题消文圆融若此。见闻之者当去情着而思修之。二从见有下梦见击鼓二。初分文。二见有下释义三。初见击鼓。二出大音声。三其声下声所诠辨。二初鼓是下明似智会法起用。上鼓表三光三佛三秖是一。三今对信相机智所观合三为一。但名法身婆罗门表真似净行。既是邻真故经称似。圆似能伏同体惑染故名净智。以此净智会本常理。乃以甘露相似相应。能以妙音遍三千界。灭苦生乐。故使经文复以击鼓表似位三身。若不尔者。则信相本性与佛天殊。佛之应用非信相感也。行者应了释迦信相同兴此梦。故有忏法利益众生耳。二鼓是下明枹鼓合成三身。二从时下觉已说见闻二。初分文。二时信相下随释四。初往佛所。二初释梦且二。初约教释。疏存二释。初约入观出观。此乃就法横释。次约伏惑断惑。此乃就位竖释。入观本期登地断惑。故知二释其意相须也。言三十心者。借别显圆也。二观解。言观行位者。既对分真即五品十信俱名观行。以未证真似受观名。内外凡位无明眠法全未破故。故观三身如梦所见。真位分破于理明了。故观三身犹如已旦。出王舍等者。变易五阴因位未离如居王舍。今出此舍表至于果。既论观法有入分真及极果分。故预表之。二往耆下释出往。王城灵鹫虽俱是地。山为佛居故表果地。信相在城合表因地。今以出往表因趣果。二尔时下与缘俱。三伸敬。信首为贵者。佛法大海以信得入。信是因人。以上求故如首为贵。慈悲为贱者。拔苦与乐乃果人下化。故如足为贱。以贵敬贱者。以信扣慈也。经礼毕右绕表恋慕。四从以下述梦二。初分文。皆言行者。古以散说一十七字为行。偈颂二等。四五言则四句为行。七言偈则二句为行。所以古师分经悉以行数为准。迩世变乱制度增减字数。致损元规。岂但使古疏分经参差。亦令目录纸数无准。寄语有识当依古制。二以其下释义二。初总明梦二。初明见金鼓三。初见鼓形状。二其光下见鼓光明。三又因下见光中佛。此三共是长行所表三身之意。鼓虽具三是所证故合为法身。光具鼓三全理是智。故合为报身。诸佛境智及以摄机。亦具三身对上名应。此合九三。乃如梦三昧所观之境。三昧是观。二见婆下明见击鼓。上文所表合九之三虽是佛法。既与心法及众生法无差别故。为信相心性之境。今于梦中见已似智会性法身。起应机用说忏悔偈。斯乃信相同于如来起经力用。二从是下别明梦二。初分文。二释义二。初明金鼓有灭恶生善之力二。初别分经六。初灭世间因果苦。前二行灭果。诸有者。三有也。后一行灭因。诸恼三惑也。二断众下生出世间因果乐。前二行出世间果。断众怖者。离五怖。谓恶道怖恶名怖死怖不活怖大众威德怖。得无所畏者有四。一一切智无所畏。二漏尽无所畏。三说障道无所畏。四说尽苦道无所畏。离二死此岸到三智彼岸。后一行出世间因。定谓楞严此定具慧。即观不思议境等正道行也。助道即事度等对治行也。三是鼓下能令众生自他俱备。前一行半自行备。后二行半化他备。害烦恼是破因。除苦是破果。下二句释上。贪嗔痴释上烦恼等之一字。等取诸苦悉令寂灭。是正释上能害消除义也。四若有下能灭报障兼得宿命。以戒缓故处于地狱。以乘急故闻金鼓声。不独出狱兼知宿命。千万亿生善知此事。故正念诸佛复闻诸佛圆妙法音。五是金下能令众生得诸法门。先少得者。且约一种远恶修善之法也。后多得者。随思随愿皆悉令成就也。六若有下能破众生八难流转。即经云诸难也。八难者。三涂为三。人中有四。一盲聋喑哑。二世智辩聪。三佛前佛后。四北州。天上一谓无想。或长寿天。二释此下总示义。经示六文。该益虽遍语犹总略。备解或难。是故大师令讲解者就此六文一一委明。从苦得乐漏得无漏。舍小入大自权至实。从因至果。节节皆论破恶生善。具辩应如二十五有。皆得果报因花。小草中草上草小树大树一实事方便实报十番利益。方尽金鼓所出妙音被物之相。具如妙玄及请观音疏也。二从一下明教诏忏悔之法二。初分文二。初正分经文。二叙意生起。邪倒障理者。于苦果身起八颠倒障四德。此言报障也。下二可知。圣人下据上释迦自作叙云。我今当说忏悔等法。今云圣人即本师也。令达三障即三德也。示其忏悔总示也。下三句别。示也。示道理报障即法身也。示因果烦恼即般若三观为因三智为果也。示善行结业即解脱也。须愿指归者。以愿导之令至究竟也。二自忏下释义五。初教自说罪过忏悔二。初分文。二夫法下释义三。初明法身是依凭。对修合故但名法身。而性常离故具三德。此三尊重复名三宝。法名不觉。佛名为觉。此寂照性本具诸法。故遍一切修德之处。以此和义名之为僧。凡小虽迷而全体即是。是故圆教初中后心一切菩萨无不以此为归为本。此本若立则三智三行三身三脱一切道法任运而生。经言。我为等者。众生性德全是果佛真如我也。二内本下请佛覆护。经两足之尊者。大经明十号中两释。一约人天善趣两足为贵于佛天人中尊。二约福慧俱备名为两足。斯须犹顷刻也。扶疏盛也。丰郁茂也。说文云。扶疏枝叶四布也。二正明忏悔二。初分文。二释义二。初总明忏悔二。别忏下别明忏悔二。初分文。二释义三。初忏烦恼障二。初释文三。初释。不识诸佛十力者。一是处非处力。二业力。三定力。四根力。五欲力。六性力。七至处道力。八宿命力。九天眼力。十漏尽力。此十通名力者。即诸佛所得如实智用。通达一切了了分明。无能坏无能胜故名力也。大菩萨亦分得比力。但比佛小劣故没不受名故。直名佛为十力也。此之十力法佛本具。报佛证之应佛用之。众生色心依正因果举体即是三佛十力。但以迷故全智为惑名烦恼障。而独头无明为烦恼种。盖由触处不了法身故。喻牛羊鸟雀之眼不识天子及以檠像。以不了故三细六粗炽然而起。言檠像者。累土木为佛像也。人知畏敬鸟雀不然。或引周礼正弓之檠者。非此中意。二释及父母恩净名云。善权方便父智度菩萨母。一切诸导师无不由之生。以其不了独头相应全是二智。是故法身隐灭不生。三释不解善法。助道众善能办应身既其不解。是故不修。二三佛下结示。举不识解显今识解是妙忏也。二自恃下忏报障三。初约事释以姓。傲他者。以贵傲贱也。西土刹利婆罗门姓贵。毗舍首陀姓贱。余二可解。此二善报。若纵恣者。为修道障。若不纵者。堪能助道。二今更约法释二。初约三学。乃以事三表于三学。由慧得道故如姓贵。定能资慧故如财宝。戒能制犯故如盛年。染此下示为障相。大论云。自法爱染故毁訾他人法。虽持禁戒人不脱地狱苦。非求法者。法过涅槃尚了如幻。岂染自法。以慢他人。不见己他方名求法也。二法华下约三教。三中且取盛年一种该于三教。穷子除粪至知库藏。历渐三昧。二边心强皆名少壮。佛居道后究竟无为方名衰迈。凡人下欲明法壮更举事壮。藏教二乘通教三乘。析体虽殊皆以空强者陵有弱。别虽三观共缘无量。故恃法眼陵于慧眼。此等皆名盛年放逸。种姓财宝历教亦然。三着此下结须忏。三学三教名报障者。此心成就由宿熏感望。后在因望前为果。故得名为于报起障。障故须忏。三从心下忏业障三。初节经示义。二初一下随文略释十二段。如疏列。亦是教他者。指口作恶业也。即自造四过。复教他人行一切恶。既随痴心岂能反照。经心生忿恚者。求五欲则忿他不与。有五欲则忿他见侵。忿怒也。经云。亲近非圣谓外道也。外道自以为圣。故佛弟子指为非圣。悭吝财也。疾妒贤也。私诈曰奸曲媚曰谄由贫穷故。而行诈媚。言无佛世敬田者。以辟支佛出无佛世故。菩萨历劫形服不拘故。无佛世随机化物。恩田者。田有三种。三宝曰敬田。父母曰恩田。贫穷曰悲田。通名田者。皆堪种福故。经憍慢者。俱舍云。慢对他心举。憍由染自法。三造业下示解释法。约今禀教且人为始。若所忏多属四趣。通惑所造名有漏业。别惑所造名无漏业。大悲不思议等种种之业。故等觉来皆须忏也。二从我下明供养诸佛。二初立意分文。二依文释义二。初明财供养。经我今等者。此乃即法以明财供。何者。以一大千界中自有千百亿佛。况无量无边大千诸佛。财若有限何能遍供。良由了达所奉之供体是法界。出世无尽一一周遍故一切刹一切佛前。皆有六尘妙供养事。不独广遍亦乃常存。尽未来时施作佛事。为彰次段修行法门。故此别名财供养矣。须知二供其体相即。为门不同故分为二。二法供养二。初分文立意。化他用慈是无缘慈不离三智。自行顺智既是佛智岂离三慈。为令易解相对说耳。法供养第一者。能令佛寿常住不断妙化无穷故也。又有法则二供俱成。无法则财供亦废。是故法供得称为最。二依文释义二。初明化他法供养二。初化他令修行二。初分文。二释义四。初我当下明化始以大悲拔苦。二我当安下劝真因十地之行。三已得下劝真果菩提大觉。四为一下劝精进督使成行。二夫众下初教义。二观行。一念心者。趣举一念也。以妙三观调妄即真名真明发。或至初住。或至六根。或成五品。皆得名为成真果也。故止观义例道树之喻。观阴等境成不思议。名为生芽。初品已上皆名生果。彼修止观生芽生果。与今观心真明真果法喻相当。调一切等者。乃一心观成历彼彼心。无不成观。与彼义例净心遍历任运泯合。其意亦同。二次四下化他令忏悔二。初立意分文。二依文释义三。初欲说忏。二千释下正为说。涉时既多造罪复重。若了逆罪即金光明。全所具理为能观观。由此显出法性金等。名拔王难。障转成德何罪能缚。故五无间皆解脱相。此乃名为正为说忏三我今下说忏已。二从我下明自行法供养二。初分文立意。前自下问。譬如下答。以譬带法兼而答之。金师譬金鼓释迦化主也。初习譬始发僧那时。皓首譬今果后示现。从始至今何尝暂废说行说忏。互烧譬即忏说行。互打譬即行说忏。智断亦然。器成譬一番之机。自因得果。故未得果。须数烧打何嫌重说。今是下辨异。虽数烧打各有其门。二我当下依文释义二。初自修行三。初标章。二珍宝下修因。脚足者。疏存二解。初以十地为果脚足。二以十度为十地脚足。言十度者。六外更加方便愿力智也。于余下释出十度为地足意。华严十地品广明其相。三果中下明成果。指经初句为总。余三行三句为别。功德是福严。光明是智严。不离色光而论智光。以其色心不二究竟也。三行之中疏不释者。今略列之。冀免检寻法藏。须论八万四千皆秘密。故名为甚深功德。乃是六度万行所成就者。略言万德广则无量。一切种智即中道智。中必双照今三圆极。禅谓达禅。达根本等皆法界故。定谓楞严。本性健相二是大乘事理二定。于一切法皆明静故泛举百千。根谓五根。力谓五力。即信进念定慧。此五能生一切善法。名之为根。力排五障。乃以疑怠邪乱痴遮此五故。名之为力。与上五根名同用别。觉谓七觉分。一择法觉分。二精进。三喜。四除。五舍。六定。七念。此七能令定慧均平。通名觉分者。有到极果觉知之分也。道谓八正道。一正见。二正思惟。三正语。四正业。五正命。六正精进。七正念。八正定。八离偏邪通至涅槃。故名正道。根等道品修虽在因。证皆果德。陀罗尼者。翻为遮持。遮一切恶持一切善。数或五百八万四千表破烦恼。且言其实数一切法能遮能持。十力如向记中已列。此乃自行始终之相。二从诸下自修忏二。初分文。二释义二。初请佛。二后十下明忏二。初分文二。百劫下释义五。初忏报障二。初出报障相。百劫受身身作众恶。恶为因缘。即生忧苦。能生所生皆是报障。良由报得恶五阴故。故疏与经对于五阴。既知皆阴非报是何。须了五阴造作众恶。方名报障。若作众善岂名障耶。二十方下请恶除灭。愿佛受忏即是除灭。若不助正资导成忏。佛虽有力何能除障。意可见故疏更不释。二忏烦恼障二。初分文二。二释义二。初出相。经业垢者业名动作。烦恼心动成于垢染。亦可烦恼从宿业生。故名业垢。二唯愿下乞清净。经大悲水者。同体之悲方称为大。此悲为水洗无不净。悲虽同体非缘不兴。三忏为缘不洗而洗也。三忏业障二。初分文。二随释三。初竖论三世造业。二初对报示。现前色心名正受者。未成报者。有系属能。若修善禅诸无漏道。则来责报现诸业相。或密为障。不依大乘三种忏法此障不灭。二设问释二。初设未有问。二明遮起答三。初引经论证。数家是婆沙论家是成实。遮未来者。断相续心。若不遮断(音短)未来必起。故新经净除业障品忏罪文中。依三世菩萨皆云。已作之罪愿得除灭。未来之恶更不敢作。并遮未来也。二今更下引现事例。在家例造罪时。舍家例修忏时。若不遮断必须更改未有之事。至于正有。三未来下据义结答。索然犹解散也。二横明现起十恶。三远离下求忏过去业。若十恶十善止就三涂人天解释。岂安十住逮十力耶。得前五戒持犯之意。则今义可解。十住十力别圆二教皆可明之。持犯之意今义易明。故须因位至于后果。节节论于十恶十善。四明回向。此忏爱着因果之罪。他以此国及余世界是五乘人修善法处。约处明人故云随喜。今明我在此土他界所修之善。今悉摄取回向众生证无上道。声喻诸善。角喻回向。近远可知。方便力大者。若善回向成大方便。功等太虚。然若不了善即法界。不名回向也。五释八下忏善恶二难二。初拣示分文。次一行半疏释正取善遮道义。二初四下释二。随文释义二。初指恶为难。六初释诸有险难。二十五有者。四趣并四洲六欲大梵天四禅无想报那含四空处。未绝漏业故同名有。释报障义具于前疏。二释生死险难。业为险难至非非想定。报为险难。至有顶天。郁头蓝弗是其例也。下之业报险难可知。三释淫欲难。四释轻躁难二。初正示轻躁相。谓初心在缘名觉。细心分别名观。亦寻伺心也。此之阴心故属报法。二如罗下引圣凡例二。初圣。出观者。出定也。就无学释无惑业故。验是报法也。二更举下凡。回转易辙者。如学经未成复欲学律。学律未成复欲学论。此轻躁人终不成功业也。不成业障者。障应作者。字之误也。五释近恶友难。如移厩者。厩音救马舍也。马之所聚也。付法藏传云。亲近贤善听闻正法。如昔华氏国有一白象。气力勇健若有罪人令象蹋杀。后时象厩为火所烧。移近精舍。有一比丘诵法句。偈曰。为善生天为恶入渊。白象闻之心便柔和。后付罪人不害嗅舐而已。王召智臣共谋此事。一臣白王。此象系近精舍。必闻妙法。是故尔耳。今可系近屠坊。彼睹杀害恶心当盛。王令系象屠所象见杀戮。恶心猛盛残害弥甚。邻于哭货者。谓墓学哭邻市学货。葵氏货清经曰。货化也。变化易之也。故字有化。又财也。史记曰。孟轲考母偏孤居近墓。轲乃常戏于墓。母曰。此非所居去居市傍。轲复戏为商贾。母又曰。不可居。又居学馆之傍。乃为揖让进退有礼。母曰。此真可以居。轲后遂为大儒。著书七篇。六释三毒难。疏分科云。善恶八难。善论四难。经疏可了。今之恶难经似列七。约何云四。盖就三障义有兼独。一兼三独。乃成四难。何者。六趣险难三有险难及轻躁难。此虽三难独在报障。淫欲愚痴及三毒难独属烦恼。近恶友难独属业障。若生死险难疏有两解。体兼业报。故三障恶义当四难。然须了知恶是性恶。是故此恶即无生观。如此忏之顿消诸难。二遇无下指善为难。二初明善恶俱能为难二。初双明二义。二遇无下依善释文四。初释遇无难难。二乘出宅到无畏处。无难相显故举为例。暂乐人天自谓无难。皆当此难。二释修功德难。如一等者大论第八云。迦叶佛时有兄弟二人出家求道。一人持戒诵经坐禅。一人广求檀越修诸福业。至释迦佛出世。一人生长者家。一人作大白象。力能破贼。长者子出家学道得六通罗汉。而以薄福乞食难得。他日持钵入城乞食。遍不能得。到白象厩见王供养象种种丰足。语此象言。我之与汝俱有罪过。象即感结三日不食。守象人怖求觅道人。见而问曰。汝作何术令王白象病而不食。答此象是我先身时弟。共于迦叶佛时出家学道。我但持戒诵经坐禅不行布施。弟但广求檀越作诸布施。故饮食备具种种丰足。我但行道不修布施。故今虽得道乞食不得。妙庄严王者。法华疏云。昔佛末法有四比丘。于法华经极生殷重。如甘露未沾。于是结契入山修道。居山日久衣粮殚罄。一人云。君三人但以命奉道莫虑朝中。我舍身力誓给所须。三人功圆事办。一人数涉人间偶逢王出。爱彼光荣。功德熏修报生人天常得为王。三人议云。我免笼樊功由于王。王耽果报增长有为。方沈火坑宜早开化。一人云。此王着欲而复邪见。若非爱钩无由可拔。一人为端正妇。二作聪明儿。儿妇之言必当从顺。如宜设化果获改邪。妇即妙音菩萨也。二子即药王药上也。王即花德也。三释值好时难。如劫初阎浮人寿八万岁。北洲寿定一千岁。俱以寿长受乐不乐修道。郁单越此云殊胜。胜余三洲故。四释值佛亦难。兴起行经云。多舌童女舞杅起腹。至我前曰。沙门何不自说家事。乃说他事。汝今自乐不知我苦耶。汝先共我通使我有娠。今当临月。事须酥油养于小儿。尽常给我。天帝化作一鼠。入其衣里啮杅忽然落地。是时地裂旃遮现身堕阿鼻狱。涅槃迦叶品。善星是佛菩萨时子。出家之后受持解说十二部经。坏欲界结获得四禅。而亲近恶友退失四禅。生恶邪见。言无佛无法无有涅槃。遥见佛来生恶邪心。入阿鼻狱。调达是佛堂弟而自造三逆。谓出佛身血破转法轮僧杀阿罗汉。教阿阇世杀父成就害母加行。复以恶心十爪甲下藏于毒药。欲呜佛足刺足害佛。将往耆山。出城地裂生入泥犁。此等值佛而成大难。然上三句体是漏善。障修无漏故名为难。此句造逆似不类上。以值三宝最名为善。逆故成难。亦可例上于善障道。二若读下明平去二声读文二。初明读字通平。二又依下据经属去。三从诸下明称叹二。初立意分文。二种供养可对身意。既不兴言是故未泄。三业不足是故未备。今加口业显而复具。故成次第。前虽自他修行修忏。而能资益佛之寿命。名供养门。今虽称叹佛之三身。而能成就行人观法。名念佛门。法虽互具从增胜故。立二法门。二标诸下随文释义三。初标叹。报应二修全理之事也。法身一性全事之理也。十方三世佛佛三身。如此标章何所不摄。我依止者。既云法性一体三佛。验知他佛为心性佛。此依本觉起于始觉。亦是三谛发于三智。非此依止不成妙忏。故圆初心名修佛行。四眼入佛眼等。大论文也。十智与如实智总十一智。十智与二乘共。如实独在佛。十智者。一法智。二比智。三他智。四世智。五苦智。六集智。七灭智。八道智。九尽智。十无生智。如物投等者。石蜜至甘。海水至碱。物投水会皆失本味。体法即性无不妙也。此之佛海宁不归敬。二就正下正叹二。初分文。二略叹下随释二。初寄言欢二。初略叹略况二。初释略叹二。初金色相貌二。初以他金比色。阎浮金者。此是西域河名。近阎浮树。其金出彼河中。此河因树立称。金由河得名。二又佛下以照物显光。二然金下赞金色所以二。初明是众相所依。二金有下明为四德之譬。二犹如下释略况。二广叹广况二。初广叹二。初分文。二从其下随释。言赞应色意彰法报。色相是表智证是里。虽分表里岂是异体。故新本中所明四德别属三身。谓法具常我。应身具净。化身具乐。分圆为别融别为圆。故圆三身身身四德。其得意者。了今应四即法报四。当以此意寻乎经疏。文四。初叹我德。二从善下叹净德。三从功下叹常德。经巍巍者。高大貌也。玻璃此云水王也。四从三下叹乐德。潦音老行水也。稽首者。说文云。下首也首头也。孔安国云。稽首谓首至地。二从如下广况二。初分丈。二佛功下随释二。初广况。此之四句喻前四佛举。大师释之。或喻应身有量无量。或喻法报四谛四德。玄文序中显金光明佛不能喻。良以三身三一自在。是故四喻或别在一。或总显三。此文正同前对四德。海无增减故常。地体是净。山形高出如我。虚空无碍故乐。二合喻。二从一下绝言叹二。初分文。二一切下随释二。初正绝言。二更牒下牒喻帖合。问疏释寄言及以绝言皆离思说。同耶异耶。答四德秘密本离心缘。今之称叹为令众生入秘藏故。故寄言绝言皆彰离念。寄言用四喻于四德。喻既莫数显德忘缘。绝言中四不可为喻。亦显四德忘于缘虑。大师深达经文妙旨。故解二文皆绝思说也。三从相下总结。四从我下明发愿二。初立意分文。如牛无御者。谓牧竖也。夫立愿者。若多若少皆须不失四弘之意。而此四弘须依四谛。愿不依谛名为狂愿。今就圆论。依无作谛虽世出世二种因果。皆了即性。无苦可度。无集可断。无道可修。无灭可证。如是则能遍度尽断圆修妙证。比前三教愿未免狂。销今诸愿。若失此意非圆行人。二随文释义二。初正明发愿二。初自发愿二。初愿果满四。初我以下愿意轮满。大觉圆明故属意业。二讲宣下愿口轮满。三摧伏下愿身轮满。阴死天子多约于身。烦恼属意。今从多分。四住寿下愿慈悲满。非无缘慈住寿不尔。二愿因圆二。初分文。二释义四。初我当下愿有为功德满。六度成就此约真因破于六蔽。从断正论。是智德故故名有为。二断诸下愿无为功德满。此约真位垂形九道调伏众生。任运不与惑苦相应。是断德故故名无为。故海东法师云。始觉断障是实断断。本觉断障是不断断。正与今家智觉二德。其义齐也。三我下愿宿命念佛满。忆宿命教。见过去佛。亦忆诸佛所说正法。四我因下愿值佛满。因过去善见未来佛。远恶修善成智断因。二为他发愿二。初分文。二一切下释义二。初愿作药王拔苦。二愿作珠王与乐。此能拔能与是无缘慈悲。所拔所与须论十番。所谓果报修因声闻支佛四教菩萨方便实报。今药树王拔此十种行人之苦。珠王合与十种人乐。当以此意销与拔文。初自分四。初总拔众苦。二若有下拔根缺苦。三十方下拔病苦。四若犯下拔王难苦。次与乐二。初分文。二上文下随释三。初与世间乐果。经鼓吹古今注云。短箫也。经优钵罗此云黛色。即青莲华也。常于三时者。昼三时也。二从愿下与出世乐因二。初分文。二人缘下随释二。初令修行外缘具二。初值三宝。二离八难。二令修行内因具二。初分文。二人因下随释二。初生尊贵。二饶财宝。五碍者。一不作梵王。二不作帝释。三不作轮王。四不作魔王。五不得作佛。三从若下结成二。初分文。二释经二。初结自。二结他。二从若此下约愿随喜二。初分文。二释经二。初随喜他。二随喜自。五从若有下结成二。初分文。二释经三。初结成断恶。二诸善下结成生善。三非于下结值佛多。三释赞叹品二。初释题。二初约义通释二。初示四悉意二。初列。二释四。初世界。思疑佛寿者。即前经云。作是思惟心生疑惑也。一心信解者。开悟也。即经云。信相闻是四佛宣说寿命深心信解也。斯人者。相信也。本事者。今之所为皆由昔愿。令众欢喜故属世界。二从下为人。三从灭下对治。罪之尤者。尤甚也。以德胜恩重毁之罪甚。口毁曰呰。亦诃也。四从所下第一义。言诸佛极尊甚深无量者。圆初住去分以法性为身体相。妙觉尽以深广法性为身体相。故起信论云。诸佛如来皆是法身智相之身。第一义谛离于施作。今称赞此令人入理。二若欲下释赞叹名二。初分字释义。亦更互分别者。以述德为赞。褒喻为叹。但使叙述褓称义成。对字无在。二引论证成。彼之称扬可证褒喻也。二此品下结示别显二。初约三业别显。虽具三业口业为正。故是别显。二结此下约四悉别显。四义指向能赞人等也。此品下别显也。于四悉中正在生善。对前忏品正灭恶故。二释文二。初分文。二随释二。初长行二。初释对告人二。初约对治释。瑞应云。佛告魔王。我积功累德今得作佛。魔云。积功累德谁为证。佛时以手指地云。是知我。是者谓指地神。干时地神涌现为证。二又对下约为人释。半空已上皆是男天。半空已下皆是女天。是鬼神报称为天者。有天然力用故褒之以天。召诸鬼神皆以天名不唯此也。实智乃是善法之本。今赞觉者生人实智。宜告善女。又别名坚牢宜证往事。称理不怀云云之意也。二释金龙尊。金光明法门所依法也。金龙尊能契行也。若法若行皆性一修二。故金为理能赞为龙。能益故尊。斯以证理起用二修对于一性。当体名为金龙尊也。二偈颂二。初分文。二随释三。初赞三世佛五。初总赞三。初约事理明总三世。十方心意识境名之为事。何有一事不从理现。经云。寂灭是涅槃义。既称微妙是大灭度。则彰三德非纵非横名秘密藏。密藏圆遍无别世方。世方宛然无非三德。不以二相见诸佛土。斯之谓欤。以此总赞为妙何极。二总理下约三法明总。法身者。明性一也。报应者。明修二也。全修在性合三为法。名总法身。全性成修合三为报。合三为应。是故名为总报应也。一切三法莫不然耳。又法身总三土。以实报等皆寂光故。报身总二土。方便同居睹尊特故。应身总同居净秽两处。凡夫二乘见生身故。分别则三身三土胜劣不滥。融即则三身三土局偏相收。以此赞佛佛德无遗矣。三如是下约四德明总。经云。诸佛清净。克果明德也。果中众德更无不会。举一净德必常乐我。四德圆妙。举一全牧。是故此四乃是三身之德。三身融故四德遍严。是故三身无非四德。总此为赞极佛体用也。今此点示故注云云。二从色下别赞二。初分文立义二。初分文。大相谓三十二相。小相谓八十种好。皆称海者。若大若小悉无有边故。皆是法界全体显现。故一一相无非法海。据其总赞诸佛清净微妙寂灭。以总显别。一一相好皆秘密藏。大师见彼得意处故。故释相好皆立海名。二所以下立义二。初明能赞智巧。二夫下明所赞德深二。初历教分别。二据圆融即。此之二意学者应知。括经论之幽文。立教观之深趣彰化迹之不滥。显圆机之顿照。何者。以分别故从胜别示。以融即故触境遍收。得后后者必得前前。得前前者不得后后。不知后故当分义成。能知前故跨节义显。若能了知真中感应二识见佛。则今二意收拣无遗矣。二识者。起信论云。佛用有二种。一依分别事识。凡夫二乘心所见者说名应身。以不知转识现故见从外来。取色分齐不能尽知故。二者依于业识。谓诸菩萨从初发意乃至菩萨究竟地心所见者。名为报身。身有无量色。色有无量相。相有无量好。所住依果亦复无量。种种庄严随所示现。即无有边不可穷尽。离分齐相随其所应。常能住持不毁不失。皆因诸波罗蜜无漏行熏及不思议熏之所成就。是受乐相说名报身(文毕)斯乃如来以法界用。随顺众生事业二识。现报应身。应身是今生身。报身是今尊特及法性身。依事识者。但见应身不能睹报。以其粗浅不穷深故。依业识者。既睹报身亦能见应。以知真如起二用故。行者应知。真如之用现佛身相大有三品。一如华严谈相好数有十莲华藏世界微尘。二如观无量寿佛经。明八万四千相好光明。三如此经及法华般舟等。说三十二相八十种好。此三品相既是真如全体之用。若多若少皆无边际。故悉称海无非尊特。然有通局。以藏尘八万局业识见。其三十二通事识见名生名应。若业识见即无有边不可穷尽。离分齐相名为尊特。属于报身。此如今经别所叹相在三十二。以金龙尊就佛四德微妙寂灭。而为总赞。以总显别故三十二无非秘藏。故一一相离于分齐。如空无边常住不毁。疏据此释三身融即正赞尊特。若其不知龙尊总赞是依业识见应即报。岂三十二圆光一寻名尊特耶。言真中感应者。良以如来现应化身示住遍真。说于生灭及无生法。被藏通机。现尊特身住于中道。宣说无量及无作法被别圆机。故文句云。丈六身佛住真谛。丈六尊特合身佛双住真中。尊特身佛双住俗中。法身佛住中道。疏有六处明应化尊特。皆约真中感应而辨。如法华叹佛。经文显云三十二相八十种好。法身具故严法身故。是尊特相。是故荆溪类同华严一一相好与虚空等。又云。一一相皆法界海。一一好无非名海。疏释今文大相小相皆称为海。此大小相全异华严九十七名。一一皆与法界次第三十二相八十种好。名目无差。又忏悔品赞佛三十二相八十种好。岂龙尊昔赞与今金鼓所赞优劣。故知秖就中道感应称为尊特。非是加添相好之数。方名尊特。故华严中业报众生等十种之身。皆卢舍那。舍那非报报非尊特耶。失此意者勿议今宗也。父母生身丈六身也。三藏及通钝根所感尊特。即是他受用报。通教利根及别所感法性是法身。圆人所感此乃如来法界大用。对三类机现三种身。故能严相亦分三种。三身力用优劣有殊。不唯示果身相不同。亦示行因三种差别。以今见佛皆是曩世结缘机也。如示迹因论四修相行六度等。或示事修。或即空修。或次第修。或圆顿修。示修不等致令众机结缘有异。今日感见三身不同。二三身下别释二。初释三身相三。初释生身相。林微尼此云解脱处。举手攀树者。即摩耶夫人攀无忧树。而太子自右胁而生也。阿夷亦阿私陀此云无比。仙人名也。披开也。太子既生三日遂裹以白[疊*毛]。王召仙人相之。于是开[疊*毛]相其形也。相相炳明者。谓三十二相皆明显也。决定成佛者。即仙人奏王之语。谓轮王虽有三十二相。相不明了。今观太子相相炳明。决定作佛不为轮王也。悲不能声者。即仙人自嗟年老不见太子成佛故泣也。无声自出泪曰泣。今云悲不能声是泣也。此是生身也者。疏虽标云父母生身须解其意。岂后二身全无父母。今特云者。彰藏通佛住偏真也。以偏真理不具五阴故。使佛身从正习造。机缘若尽灰灭沦空永无示现。故以父母显其有生。机尽归空显其有灭。通虽幻有亦须永无。依教分别相状如是。二如释下释尊特相。巍巍高也。堂堂明也。言尊崇奇特者。此别圆机所见身也。常身常光者。即凡夫二乘所见身也。然高明身相应知两意。有须现起。有不须现。皆是如来鉴机进不中道之力。于须现者即为现之。如梵网经云。方坐莲华台。华严藏尘相。维摩所说身如须弥映于大海。观无量寿相好八万身量无边。此等皆是现起尊特相也。有不须现者。但以力加。令于劣身见无分齐。作巍巍堂堂而解。以不可思议而观。此如今经赞三十二为尊特法性之身。法华以三十二相庄严法身。相相皆与虚空等量。此等机缘悉以业识而见。以中智而观。劣即无边色即智性。故不须现起而称尊特。若不尔者。龙尊所赞三十二相。疏云融三正赞尊特。如何和会。学人于此当善了之。三释法性相。此乃诸佛第一义谛智相之身。凡夫二乘尚不知名。岂能睹见。若论极证等觉罔穷。又复初地不知二地。是故树神哀泣雨泪请佛现身即此身也。皆得名为非下地见。唯应度等者。斯是大乘第一义悉檀。机扣佛者。乃以此身应之令见。即前疏解一时之义。一切种智与中谛一时也。无身等者。非质碍身是微妙身。非差别相是智净相。一切智是万行首故以为头。第一义谛诸法中最故以为髻。八万尘劳转为法门多数名发。大悲为眼见苦即拔。中道白毫不偏无染。无漏为鼻嗅功德者。十八味舌遍尝理空。不共为齿四十数齐。大论以十八不共法十力四无畏大慈大悲三念处等为四十。皆不与下地共故。四弘为肩荷负不息。三三昧止散如腰束衣。圆三三昧秪是三观。空即空观。无相即假观。不得空相故。无愿即中观。于二边不作愿求故。如来藏腹舍三千故。权实智手遍拔众生。定慧等足究践理地。今第三身与余处列不无少异。如观无量寿佛经疏云。色相身义当生身及他受用同为应身。次法门身。即今所列种种法门义当报身。乃自受用也。三实相身。即以法门所严之理为第三身。今则合彼理智二身为法性身。开彼应身为生身尊特。互有开合三身不亏。又复应知今法性身头等法门。即是龙尊所赞之相心即色故名前二身。色即心故名为法门。但今历教就分别门随机所见。前不见后是故后后从胜立名。故使三身有优劣相。又复尊特及法性身皆业识见。以尊特相兼于别修。故就身相高广而示。今法性佛即修明性。故隐色相从法门说。讲者学者宜在精详。二种相下释三相业。此从如来净佛土时。随彼机缘示修不等。故分三种。初释生身业。虽通通教今且在藏。以其通教是大乘门。利人能见后二佛故。今就三藏修行事度。为相好因。言修百福成一相者。论存多解今明一种。大千众生遇缘当死。一一救之皆得寿命。是为一福。此福至百方成一相。此指伏惑事度所成。令彼众生效此修之。今见生身。二若以空下释尊特业。言空慧者。良以体法即空之慧三教共修。钝根之者但能空有。利人知空非但空有。亦能空空。今分别门论尊特业。虽能双空。且在别教但中之慧。导诸相业。诸业不出前之六度。以知中故非庄严庄严。乃能庄严第一义体。令彼众生效此修种。今见尊特无分齐身。三若以实下释法性业。实相者。中道理也。全中实理为能观慧。名实相慧。实相即慧也。非别有慧。从其所照得实相名。导成诸业者。诸业岂离前之六度。以圆修故。一一即性故。无非实相。一摄一切故。无非法界。故散脂云。安住一切法如性。于一切法含受一切法。如是修之绝三教之情。名不思议业。令彼众生效此修之。今见法佛同虚空相。二三身下据圆融即三。初正融即。圆佛顿证三身三相。亦能顿示三种修相。若其圆机能于一念。修三相业。能于一身见三身三相。以了三身是秘藏。故生身必具尊特法性。尊特必具法性生身。法性必具生身尊特。见身既尔修业亦然。如是方祛纵横一异之情想也。常乐我净微妙寂灭此义方成。金龙尊王昔是圆人顿修顿见。故于一身赞三身相。欲彰三相是秘藏。故寄言赞后绝言赞之。欲令众生圆见圆修故也。二今经下明巧赞。经之赞辞就三十二即示绝言。乃显能严即非庄严。严第一体。尊特身相岂不然乎。亦可得云非生非法而生而法。上兼法性下摄生身。其意在此。斯乃龙尊巧赞之意也。三一一下明妙用。三相三业。据圆虽即。被物成差。历教分之即融而别。初安平相。生身则表魔邪不动。魔谓爱惑。邪是见惑。既往偏真此二莫动。若尊特佛双住俗中。即无量四谛。故凡夫有二乘无。此二莫动。若法性佛唯住中道。邪外三教一切二边。当处皆中何边能动。最后肉髻兼无见顶。故以不礼而为所表。言法不礼者。谓法尔也。生身出离爱见一故。法尔不礼凡夫之人。尊特出离界内界外二种尘沙。法尔不礼藏通之圣。法性身佛究竟圆中。法尔不礼分证中道。初后既尔。中三十相。论用可知。然不礼凡圣兼因而说。非专果也。别有所出。及注云云者。指诸广文解相好处也

金光明经文句记卷第三(下)金光明经文句记卷第四(上)

        宋四明沙门知礼述

二依经释义六。初赞七大相海。三十二为大。八十种好为小。一一相好皆是法界。无边无底故称为海。谓初句是赞第十四金光微妙。故云上色。次一句赞第十五身光。三一行赞二十八梵音深远。四一行赞小相中第七十九发色青珠。五一行赞二十二四十齿具足。六一行赞二十九眼。七一行赞二十七舌大薄覆面至发际。八一行赞三十一眉间白毫相。此八段中一是小相七是大相。二眉细下赞两小相海。初一行赞第三眉如月初。次一行赞第二鼻高好孔不现。修扬者。修长也。扬举也。即是眉高而长也。面门口也。三两句遍赞大相海者。既云次第最上。即遍赞三十二也。四得味下又赞四大相海。初二句赞二十六咽中津液。得味中上味。二四句赞十三毛向上青色柔软右旋。三修臂下四句赞第九立手摩膝相。四圆光一寻下四句赞第十五身光面各一丈。此言一寻是约佛说也。手既摩膝即当面各一丈也。此既常光验知诸相皆是常相。云赞尊特者。故知不须身大相多。但是业识依中理见即名尊特学者应知。此丈六身若其量度即不得际。若不度之所见如故。如净名室但是一丈。而能容受百千人天。又能容于三万二千师子之座。皆高八万四千由旬。其一丈量初无所改。良以三脱不思议力。使之然也。今即常身叹尊特相。义岂不然。微妙寂灭斯言得矣。经文除此四大相外。或叹放光拔苦与乐行业之因功德之果。悉如经文。但须皆作十番益解。其有二小相以文显故。疏不指之即面貌如月。乃第四十一面净如满月也。身无垢秽。即十一身净洁也。五臂佣下二句又赞一小相海。即第十四指长纤圆也。佣丑凶切。均也。直也。又音容。六手足下二句复赞一大相海。即第四手足柔软胜余身分。三十二相八十种好。具如法界次第。龙尊智巧虽略而周。三从去下遍类赞。三世尘数而言一者。过去不灭。未来不生。现在不住。法身平等报应无差。一不离多多即是一。生佛尚即佛佛岂殊。是故赞一类于一切。此文复是赞尊特身。何者。如前疏云。若见四佛同尊特身一身一智慧。即是常身。弟子众一故。若四佛不同即是应化。弟子众多故。知秖就一身一智及常住义。是尊特相。不必须论现起大身也。文殊问般若者。问字误也。应作说字。今家依二经明常坐三昧。一文殊说般若。二文殊问菩提。今所引文是说般若文也。四从设下绝言赞二。初分文。二而有下随释二。初绝言令兼例绝心。三番者。仍就分别门。三身优劣。不离分别有融即义。学者应知。五从下回向。一回事向理即实际。二回自向他即众生际。三回因向果即菩提际。今阙实际菩提兼之。谓无上道本性无上故也。二从如下发来世愿二。初分文立意。来在不久者。即下授记品。十千天子从忉利天来者是也。二随经释义二。初佛述。二若我下龙尊发来愿五。初夜梦昼说愿。二我当下为他取净土愿。不修六度不拔众生。土无由净。当知四修及拔四相。令于当世见我三身。三奉贡下同求记莂愿。以鼓必具圆空鸣义。今赞如来一体三身。名为金鼓赞佛因缘。以此因缘趣向果地。名为奉贡。不论事相金鼓形也。四若有下下化愿。五我未下上求愿。此之二愿皆明灭恶生善二益。在文可见。三从信下结会二世事。释空品二。初释题二。初正释题二。初约四教诠空示。所言空者。破相为义。故一代教四空不同。若不辨之迷名昧理。此自分二初约部列四二。初正判四空。灭色入空者。三藏教也。且寄色言诸法皆灭。谓析破见爱阴乃不生。既诠实有灭方入空也。即色是空者通教也。体乎因果非四性生。既诠幻有故即色是空也。灭边入空者。别教也。中道为空。不唯空有亦乃空空。然不知中具于空有。是故次第灭二边已。方入中空也。即边是空者。圆教也。中道具德何边不中。唯假唯空三皆绝待。顿破诸相名即边空。二此经下约部须四。判教属通三乘同忏。前摄三藏后通别圆。导成之空合论四种。故四空慧不得不明。二而今下定品唯圆二。初直示唯圆二。初就理示。摄机用四。此乃通涂。品在圆空斯为的旨。是故中空即边而示二何故下引文示。诸部般若广示衍中三教空慧。复以三藏为助道观。斯为闻持利根之者。广谈空相。此空慧机义持虽利。闻持根钝。故不广谈四种空相。唯说即边一中空慧。二又空下略示圆相。中受空名意彰荡相。凡夫执有块然质碍。二乘证无灰灭归寂。中观绝念空。此两边令毕竟净。约次不次分于别圆。今不次也。二直作下约六句对中简二。初明用句意。若直说空是中道义能空二边。其如邪小及以别教。皆说双非空于有无。故迷名者谓与今同。何能超悟边即中空。又复恐谓若是圆实合谈中道。那但名空。空唯离有。岂此中道双离二边。为防此计故作相破相修相即三双六句。而对辨之。若诸法相名相滥者。无此六句莫辨异同。二空破下正用句简二。初列六句。双非是中没于中名存双非者。以中道名邪小稀立。若双非名处处皆有。故特用之。对今圆空辨于同异。又外道二乘别教空句及双非句。体是思议可破坏法。圆教双非及空若立诸义皆灭。是以圆二互破诸二。又复诸二互修圆。二则二酥中外道菩萨入圆者是。二乘初心亦有修义。此之两双诸二对圆优劣有异。第三一双属圆当教。名别体同。是故相即不言修破。二空破下释句相三。初释相破句二。初空破中二初略示。以理定诠不遭名惑。岂闻双非便是实理。盖能了知。凡邪双非体是见惑。二乘双非但证偏真。别教双非既存教道。未与三融。圆空若立前诸双非须皆销殒。故云破也。二凡邪下广释三。初破凡邪双非二。初泛示见相二。初正示。复四者。复由重也。谓于一句更计有无。即执有是有执有是无。乃至双非是有。双非是无。具足之见其计转巧。故于句句皆生四计。二虽单下结过。三种四句虽转巧细。以执一为实余皆妄语见爱尤盛业苦无涯。浩然如海。二虽计下正破第四二。初示所破邪计。双非是惑不入真中实是虚妄。二故为下明能破圆空。二破二乘双非二。初泛明证相二。初明证相。二乘双非虽非中实。而离断常谛于真理。未至宝渚已到化城。宁不安隐。梵行等者。无学四智四中。但阙我生已尽。以灭度等当之乃足。由保此故不求遍知。二示四门。阿毗昙此云无比法。诠有门观法。拘邻五人千二百罗汉皆此门入。成实论诠空门观法。须菩提此门入。昆勒此云箧藏。彼论诠于双亦观法。故大论云。若不得般若波罗蜜多。入阿毗昙则堕有中。若入空门则堕无中。若入昆勒则堕有无中。那陀等者。释论明佛垂灭阿难问车匿。佛答云。恶性车匿吾涅槃后心渐调伏。当为说陀那迦旃延经。即双非门也。四门观法假人本无。四门不异而其实法四相不同。有门则念念生灭。空门则三假浮虚。双亦门则有无从容。双非门则有无俱遣。随依一观可以发真。三藏四门其意略尔。二离断下正示破中二。初示所破假名中。中道之名大略有二。一离断常称为中道。有名无体属前二教。二者佛性称为中道。此有实体属后二教。今论双非断常二见。得中道名。其实全非妙色妙心。故无中体。故情想不忘保偏取证。此以沙砾谓琉璃珠也。二故为下示能破毕竟空。斯乃今品即边之空。若发此空假名中坏。是为空破非有非无。三破别教双非门三。初示迷门起失二。初举意明失二。初举意。别人望圆其根名钝。非四说四名为权巧。筏喻者。四门意在入理。箄筏意在度川。若执门起诤如檐筏驰道。故筏喻经云。法尚应舍何况非法。二不得下明失。失于融摄是一非三。二涅槃下示四门相。亦色非色双亦门也。非色非非色双非门也。二若各下明失故须破。此之执诤非即边空无由可破。三新本下引证示失相。经谈初地被于地前。悉有四门者。经云。初地菩萨欲行有相道即有门于无相法多用功力。即空门。一意欲入涅槃。一意欲入生死。即两亦门。微妙秘密之藏修行未足。即双非门。大经下明今之得。显前之失。前属别门执诤邪见。非是外道邪见也。二非有下明中破空。二明相修句二。初明诸空修圆中。凡邪空见。二乘空证。别教空门既随二边若闻圆中皆须即边而观中道。二诸双非修圆空。若邪小及别教门虽曰双非。皆成取相。皆须修于三谛俱空名毕竟空。由诸双非及诸空句。非究竟道是九界法。是故皆须修于圆教空中妙观。归秘密藏。三释相即句。虽诸经论说空说中。名相多少中。若即边空荡三谛。此则圆教一体异名是相即义。不须相破及互修也。二初明圆教空中不二二。初直示不二。二引般若结。实相观照文字三种般若。即三而一故是一法。即一而三立名何极。得此意者。一切异名无不相即。二而不下明今品略说名空文约义丰空无不尽。以被义持根利之者。故以略名而标品目。二此品下明来意二。初导成上品二。初正示二。初导二用。若其不了即边是空。忏非无生破恶不尽。赞非称性生善不深。善不深故岂成智德。恶不尽故岂成断德。钝根之者于前未悟。故于今品圆谈空慧。导前忏叹令成二用。二亦是下成三章。忏叹是用如向说之。导成宗者。万行之因。以无所得方证三身。非究竟空岂无所得。是故圆空导于万行成果德宗。导成体者深广法性遍一切法。二种我故生死浩然。今以二空导一切法。显成经体。二故释下引证。论明一切以体宗用摄无不尽。二又常下开悟钝根。圆空具德一切清净。故谈常宗及显悟体。忏叹二用。皆是究竟清净之法。岂有一句暂离圆空。如云一切众生皆是般若。即此意也。利根闻上已解空义。今为钝根未解之者。特论生法境观皆空俾成上义。二释文二。初分文。二随释二。初释欲说空二。初释八。初释余经广说二。初总示相显意二。若指下别明指前义二。初约部次相违问大经云。从生酥出熟酥。譬从方等出摩诃般若。故知般若在方等后。此经既属方等。岂得指般若为已说耶。二约后分至终。答二。初正答通二。初引教答通二。初总立意。以此经是方等后分故。信相闻佛入灭唯三月在。所以怀疑。故指般若名为已说。二且举下引三经三。初引阿含二。初正引前佛而去者。七日前入灭也。均头沙弥是身子弟子。二此下结示二。引方等。即方等陀罗尼经。先于灵山唯法华授声闻佛记。二岂非下结示三引。大品二。初正引二。当知下结示二。以此下详定结斥二。此经下示非妨二释略而解说二。初示教门名义广略二。初示二门。二应作下明四句二。初直示三句。十八空等者。空体唯一遍荡诸境随境立名。如火是一随所烧物乃有异名。名下之义不得不异。是故因亡内法乃名内空。因亡外法乃名外空。亡十八境名十八空。二十空二十四空亦复如是。故名义俱广立一空名。唯诠泯荡故名义俱略。若法性等立名众多。但诠本性之义耳。二委示第四三。初标示。二迄从下证释。秖立二空是名略也。此名召义遍乎十界。从凡至佛皆有众生及五阴故。问位至声闻生法已空因。何释论至佛犹有众生及法。岂独不无。又称无上其义何耶。答小乘谈空终归灰断。故入无余生法永绝。大乘谈空其体常住。又非独一觉性常住。须知生法一切皆常。故生法未空则凡鄙微劣生法。若空则高胜广大。是以极果生法无上。斯乃空之究竟也。故荆溪云。三千果成咸称常乐。三千阙何生法依报耶。二今言下明今品名略义广三。释众生根钝二。初定广略利钝二。初约闻持立。宜广为利宜略为钝。二此语下约义持翻。身子初遇阿鞞说偈诠三谛义。谓苦集灭令速证。故不言道谛。身子一闻即悟初果。及其转为目连说之。再闻方悟。一说是略再说是广。岂非义持略利广钝耶。二此经下示今机利钝二。初明经意。自就不能广持诠空名数。故曰钝根二示今机。若论义持闻略能悟。乃称根利。无见经云。众生根钝便谓今机不能悟。于无量空义鲜于智慧。亦约闻持智也。此同起信论说寻于广论文多为烦。但乐少文而摄多义者。故造此论。又末为诸佛甚深广大义。我已随顺总持说此品。略说无量空义。同彼总持说深广义也。四释无量空义二。初约真中拣偏真断灭不具色心。是有量空义。中道具足妙色妙心。出生不竭融摄无遗。是无量空义。二就此经示。既谈法性性则不改。此乃常德实相者。中实之相。此品云。求于如来真实法身。新本云。法身是常是实。实是我德自在何穷。既具常我岂亏乐净。四德弥彰无量空义也。五释异妙方便。六释起大悲心。七释今我演说。八释知众生意皆可见耳。二正说空二。初分文立意二。初分文二。立意二。初直示无境等者。生法之境皆妙三谛故曰二空境生法之观。皆妙三观故曰二空观。妙境发观其观方正。妙观照境其境方显。具明境观令正令显。二引证十番检境智者境谓十境智。谓十乘。言十境者。一阴入境。二烦恼境。三病患境。四业相境。五魔事境。六禅定境。七诸见境。八增上慢境。九二乘境。十菩萨境。阴乃现前九则待发。若现若发。一一境界皆须修于十乘观智。言十乘者。一观不思议境。二依境发菩提心。三巧安止观。四破法遍。五识通塞。六调道品。七对治助开。八知次位。九安忍。十无法爱。此十都为十种境绝于思议。是故五品得观行绝。十信乃得相似论绝。四十一位分证论绝。妙觉乃能究论绝也。下文即是散脂自说名密之义。乃名境智俱不思议。新本言法即是境也。如者不异也。皆重言者。盖以境智本来不异以情异故。今复不异故。东阳大士云。一是本性如。二是灭结如。智不异境故曰如如法。境不异智故曰如如智。斯皆明于不思议意也。二明空下随文释义二。初明空境二。初分文立意二。初分文。二立意五。初直示二相。言实法者。对下假想净为不净。乃是事观。今于五阴及以假人。皆直观理故名实法。身虽下出假想义。二亦名下示二异名。行行者慧行之上加修事行故。名行行。助道者。以不净想破事中贪。资于正观破障理惑故名助道。三小乘下明大小皆修二。初明小三种解脱。不言无疑解脱。以俱脱人达内外典籍得无疑名。今论正助故。且明二。二明大萨婆若。大论翻一切智游戏神通。以于三界得自在故。名游戏。以修得通多于九想背舍等起。故以假想为助道也。法华大车具度白牛名为正道。傧从为助。涅槃正慧远离十相。即色声香味触生住坏。男相女相能离深故。所离非轻。又谛下明助道也。想白骨等观等事禅。即用三观于事禅境破三惑障。显出我性成王三昧。正助合修名为达禅见禅法界也。四众经下明经论有广略。五明今品二义即俱略也。二实法下随释二。初明实法境二。初分文。二随释二。初明苦果境三。初生空境二。初释。是身虚伪。二初体妄计故虚。二初计揽阴有身揽阴成身者。五阴和合假名为身。如揽五指故有拳名。凡夫不了执此假名而为我等。广有十六。一我。二众生。三寿者。四命者。五生者。六养者。七众数。八人。九作者。十使作者。十一起者。十二使起者。十三受者。十四使受者。十五知者。十六见者。今略云五我者。于阴等法中若即若离计我我所之实人者。于阴中妄计我人。众生者则于阴五众妄计我生。寿者则阴等法中妄计我受一期报。寿命者则于阴等法中妄计我命根连持不断。以执此故计有我身名身见得起。二若体下体本虚叵得。妄执有生生实不生。故生名虚伪。既本不生故见身寂灭。叵犹不可也。二又检下检原由了伪二。初正检二。初检假名。由一念妄想者。谓男托胎时见母为所取境。见父是所竞境。于母起贪于父起嗔。父流谓是己有。乘兹妄念故得托胎。女人反是。委如大经。假名始者。男女之名由此妄想而为始也。二此赤下检实法由二。初五阴赤白即遗体也。三性者。谓善恶无记也。二又精下六大五阴。六大是所依实法原由。若是二观此下结示。身是幻质名是假名。既由妄想及从精血以验所成身名虚伪。二释犹如空聚。无明业力业即是行。乃无明缘行也。或初作业时。或托胎时。如向所明男女之识。于父母起贪嗔。以父母流谓是已有。乘兹妄念故得托胎。体即遗体谓赤白也。二从六下体法空境二。初立意分文。二初立意二。分文。二随释三。初释六入四。初释六入三。初释二名。二检其下检三事。命暖识者。大集云。歌罗逻时即有三事。出入息者名为寿命。不臭不烂名之为暖。即是业持火大故。地水等色不臭烂也。此中心意名之为识。即是刹那觉知心也。三法和合从生至长无增无减。七日一变者。谓在胎也。一七名杂秽状如凝酥。二七名疱状如疮疱。三七日名凝结状如就血。四七名凝厚渐坚硬故。五七名形位四支差别故。六七名毛发爪齿位。七七名具根位五根圆满故。今云五疱即形位也。三结成下明六数五根。并前识是意根。则六根具足。二识依下释村落。三尘从下释。结贼所止由尘起结。能害慧命故云结贼。四眼见下释不相知伺候也。二从眼下释十二入四。初约开辨数。开色为十者。五根五尘也。少分者。法入摄二种法。一者心法除心王。但取相应诸心数也。二者非心法即过去未来色法。及心不相应诸行及三无为法也。今云少分。即非心法中过未色也。开心为二者。谓意入也。及法入也。然于法入亦秖少分。谓于法入二种中。但摄心法耳。今云二者。且举全数。二尘入下明通别名。三当一下释各各自缘。四他根下释不行他缘。三从心下释十八界二。初辨数释名二。随文释义三。初明识遍诸根。追缘过去预念未来。驰骋犹奔走也。如人下举例也。端坐一室而心思天下。爱染尘缘名曰坐驰。自非妙空莫息驰想。以愚下释六贼所害也。如大经者。德王品云。譬如有王以四毒蛇盛之一箧。令人瞻养。若令一蛇生嗔恚。我当准法戮之。都市其人怖畏舍箧逃走。王时复遣五旃陀罗拔刀随后。一人藏刀诈为亲善。其人不信。投一聚落欲自隐匿。既入聚中不见人物。即便坐地闻空中声云。今夜当有六大贼来。其人恐怖复舍而去。路值一河其水漂急。即取草木为筏截流而去。既达彼岸安隐无患。菩萨亦尔。闻涅槃经观身如箧四大如蛇。五旃陀罗即是五阴。诈亲即贪爱。空聚即六入。六贼即外六尘。河即烦恼。筏即道品。到于常乐涅槃彼岸。二心常下明识常在。根尘即对即觉者。对尘便觉也。引释论证即觉义。既云心欲闻则知识在根。经随行平声。三心处下明识常去还。乍出乍入者。对尘故乍出不对即乍入。出入间关者。应法师云。谓出入也。亦设置之貌。庄子云。小智间间隔碍也。啄一舍一者。舍一网目复啄一网目。隔碍难出得论常在者。以尘对即觉故。三从身下结二境二。初标示。二身空下牒释二。初释初二句结生空境。长养即十六中养育见也。妄计我能养育于他。又是计我为父母养育。二亦无下释后二句结法空境。二初超释无主二。初别检。心主必能制及得自在。既为他恼二义不成知心非主。二或时下互推主。四微色香味触也。大论云。地有色香味触重故自无所作。水少香故动作胜地。火少香味故势胜于水。风少色香味故动作胜火。心无等者。心望四大以不藉微胜故为主。若论被恼复不成主。二追释无诤。因缘和合虽成诸法。本无思念有何诤讼。皆由情计故。四大如蛇六尘如贼。若观本空则诸法寂尔。有谁诤讼。故以无诤结法空境。二从诸下明集因境二。初分文。对辨二。初分文。二前三下对辨二。初对假想辨。前三者。即此集境自立三科。谓集起相等。是慧行正观之境。后一即假想是行行助道观境。此九行经文既相连。又俱言四大似难分别故。以前三对于后一。而论正助以区别之。又前一者。即以集境三中。初一对后假想而论生灭。以前一云从诸因缘和合而有。及云地水火风合集成立。后一乃云水火风种散灭坏时。岂非四大生灭相耶。而言生灭皆从种无明者。彰此生灭不离迷妄也。故前生云。妄想故起至后灭云散。灭坏时此乃死。支合云忧悲苦恼。斯是无明之果。复是无明之因。故论云。老死有果所谓无明。无明有因乃指老死。是故生灭皆从无明。二若直下对小乘辨。如上所论无明生灭。何教不然。若欲了知须论小衍。小明四大实从无明生实从无明灭。衍明四大而有。三教通教四大体本自空故。本不生灭。由无明故见有生灭。如幻之生如幻之灭。别教四大体是佛性。由无明故四大生灭。性无生灭相有生灭。圆教四大体亦佛性。而性本具九界四大故。九四大若生若灭皆是法界。是故性相俱不生灭。乃不思议论生灭也。故法华明世间相常其义既尔。则衍三教皆得明于本不生而生本不灭而灭。生灭不二而二。今非通别的就圆论。二从诸下随文释义三。初明集起相二。初通约生法释三。初拣苦从集。苦是世间果集是世间因。此之因果皆因缘生。今之所辨虽然涉苦果。其意乃明集之因缘。二前三下分句对义。三小乘下破小因缘二。初叙小。俱舍云。极微微金木兔羊牛隙尘等。小乘有门谓极微。始有十方分故不破邻虚。以此为因缘也。二今明下斥非。细尘亦尽者。邻虚亦破二尘既破。因缘不成。二言因下别约生法释二。初假名因缘三。初释。从诸因缘此中宜用起信论说。无明为因生三细。境界为缘生六粗方尽。疏意言三细者。业相转相现相。即根本不觉。熏习真如生三种相。故云无明内惑为因也。言六粗者。谓智相相续相。执取相计名字相。起业相业系苦相。即枝末不。觉于外境界。起智相等生法二执。名为染爱。于外触处染着。以二不觉熏二执心。成起业相。故云。无明润爱集业得起。忽都不辨。迷一法界为无明。内惑等者。岂能显今中道空慧耶。二以业下释。和合而有以业起者。即起业相也。则有下即业系苦相也。此云苦果即是揽阴成假名人也。三此一下释。无有坚实由无明爱者。二不觉为因。即能生心也。一念托胎是不觉果。名所生心。计此因果名为本末。既皆不觉岂是真实。故云都虚无坚实也。二妄想下实法因缘亦是妄想。一念托胎与前不异。但前成于假人今则成于实法。假实和合成一报身。修二空故破于二执故分二境。机关主者。如机关木偶假人转动。主即弄机关人也。故以业因喻所弄木偶。以阴果喻之色。阴如木偶形质故云机关具。三阴如木偶动作去来。识阴如看人故云以自娱乐也。二随时下明集相吞噬二。初因果对释四。初释。增减残害竖约十时者。大经云。一歌罗逻得异。二阿浮陀时异。三闭手时异。四疱时异。五初生时异。六婴孩时异。七童子时异。八年少时异。九壮盛时异。十老死时异。又念念生灭虽在于心。须知四大亦随增减。又新诸根谓生时故。诸根死时又饮食资益血肉为新目泪耳矃等为故。二譬如下释四蛇同箧二。初明四蛇二初约蛇报明四相。蛇有力敌羸绝等报。可譬身有生老病死增减四相。二如此下约蛇因明四分。四分烦恼皆有毒害即是蛇。因此因能感四大四相二。初别示四分感报二。初明生四大。二瑞应下明致四相。经出三相。疏以等分例致生相。二总结集业致苦。上释四蛇虽言苦报。意明集因缘故。总结云集业相噬。令大增损推功归集。是经正意。二明同箧二。初约身为箧。螫知列切。又音释音郝。谓行毒也。经举四蛇以喻四大。意彰四分有毒害义。一分具足二万一千。四分共具八万四千。无量劫来法身慧命丧坏由此。大经所明身持四大大不起集蛇无毒义如鸟在笼者。次文再举。疏粗释之故注云云。二又用下约业为箧。宿业尚存故四大未散。重举笼鸟以明业箧。须知今疏。举业持大意显集因。故云心鸟。鸟喻四分外驰六尘。常求生死非安法身。若人念念思破戒事。乃求地狱永灭五分。宿人业谢泥犁长往。三释其性各异二。初约一身释。性别等者。虽云四大和合成身。大性既异那可合成。此显成中当处即坏。妄情不了于坏执成保着生集。四大对四方者。显内四大有四方性。四方升降验大相违。对时对维其意皆尔。良由内体与外时方其性本一。故依正色心感召义成。是故今经特以四大明乎集业也。二或言下约六根释。以其六根俱是四大造色故也。四释悉灭无余。比至必利切。及也见人死灭四大分散。便谓息风暖气已归于上。骨肉血汗必归于下。及至推寻都无去处。以本不来故。若有来去非今教境。二若果下结由集业。经举四大升沈尤甚。正明集境善恶殊涂。以其四大不独是恶亦通漏善也。三明集善恶境。三初释心识。学斯宗者。要知境观。若论观者须明三识。谓第九庵摩罗是不动识。当正因佛性。可为中观。第八阿刺耶是无记无明识。无明之性即了因佛性。可为空观。第七阿陀那是分别识。是惑性故当缘因佛性。可为假观。此之三识既与三德无二无别。是秘密藏。何法不收何处不遍。修圆观者。必能了知一心一尘无非三识。即是所显妙理复是能观妙观。若论境者唯尚近要。秖以第六见思之识。而为境界。知妙三识未始暂离一见一思。故即此心为妙三观。显妙三谛。虽唯一识未尝不用三识为观。未尝不以三识为境。若谓今宗不明三识。但于第六显三谛理。今之释题及彼妙玄示其三识为妙三法。将何用耶。于一识心以何而为三谛三观。故无通见难议圆宗。今明集境故引论文通小之说。但于第六辨心意识一法三能立三名字。对数名心者。对通大地等一切数故。名曰心王也。能生名意者。意是依义。依之能起一切因果。以具三性故也。分别名识者。以能了别所缘之境。故名识也。又言下虽秖一识。约三时异而立三名。不同前释秖约一时有对数能生分别之义也。前是横释。此乃竖释。初起极微。次起渐着。后起弥显。岂非竖耶。二释二性。夫性有二义。一真理不变名性。二随缘染习名性。此言性异约染习性也。此之二性遍心意识一一皆二也。三释躁动二。初正释躁动二。初约王数释。二又如下约业牵释二。初明业牵二。明两牵。二亦是下例释随业即当四句也。若了两牵即知受报。二水火下明假想境二。初正释相二。初释散灭坏时。二释大小不净。能破欲情令正观立。故名助道

金光明经文句记卷第四(上)金光明经文句记卷第四(下)

        宋四明沙门知礼述

二若正下明功能二。初明破欲助正二。初略示。二广示三。初引释论明助正。三解脱者。谓空无相无作。从三证果名解脱门。解脱涅槃二名一体。道品是开门法者。小乘则以十六行观为三脱门。今品则以即空假中为三脱门。欲此门开。须以道品调试修之。如以念处四种修于即空假中正勤四种。乃至八正调试修之。亦复如是。小乘三脱七科调试其义亦然。俱以道品为开门法。九想者。一胀想。二坏想。三血涂漫。四脓烂。五青瘀。六啖。七散。八骨。九烧。若约小乘有二种人。一坏法人但求断苦即至烧想。成慧解脱人。二不坏法人。来住骨想不进烧想。得有流光等功德具足。成俱解脱人。今明菩萨见禅实相。名修达禅永异于小。大小虽异俱以不净助开三解脱。于助开中不净九想破欲先锋故名初门。二示进修明力大。初修不净进入八背及大不净。所言大者。但观自他正报名小不净。即九想观。若兼观依报名大不净。所谓舍如丘墓。钱如死蛇。羹如屎汁。饭如白虫。衣如臭皮。山如肉聚。池如脓河。园林如枯骨。江海如注秽。名大不净。亦名大背舍。背谓背是净洁五欲舍谓舍是着心。三引大经显治欲得解观对治力强速发无漏。二此不下明二空助正三。初据义总示。二引经别示八色流光者。谓地水火风青黄赤白八种色也。法界次第云见地色如黄白净洁之地。见水色如深渊澄清之水。见火色如无烟清净之火。见风色如无尘迥净之风。见青色如金精山。见黄色如薝卜花。见赤色如春朝霞。见白色如珂贝雪。三此就下结成助正为治欲故。修于事禅而以二空正观了达不净境。是法界故于骨于光不见假人及以实法。此正助合而修之。方是大乘助开之法。二明生法二空观二。初分文立义二。初分文。二立义三。初明谛缘本大二。初明通大四。初约专小问。今说圆空。那得却用声闻四谛支佛因缘。二约通大答。佛说谛缘通被大小二乘菩萨。通四教故。如世大道群小同游不定属小。三重问即通意云何四字也。四涅槃下广释二。初明四谛通。我昔等者。佛与三乘昔在凡时。不见四种四谛真理。故又流转分段生死。偈文未毕今具引之。故注云云。凡夫有苦无谛者。虽遭大苦不以为患。以不审谛知是苦。故声闻有苦有苦谛。此当三藏不了无生。故云有苦。能审知故名有苦谛。菩萨等者。通等三教俱达如幻。俱能解苦当处无苦。而有真谛者。章安疏云。真是真实。故知即是次第不次第二种真实也。诸佛等者。佛果圆极究竟实也。是知四教智虽浅深皆依四谛。所以下更引胜鬘两种四谛。释成前意。二乘有量者。藏通不知如来藏故。所观四谛终成有量。别圆菩萨了藏性故。所观四谛皆无限量。而兼有量者。深必知浅故。别人次第观量无量。圆人一念观四四谛。二大经下明因缘通四智。皆观十二因缘智浅深故。得菩提道四种高下。彼经四智意彰四教。故知因缘不局在小。二复有下明唯大二。初明独菩萨法。二初引经。儒童者。儒仁也。谓仁贤童子也。习应者。谓修习与空相应也。四谛因缘各举初后并略中间。故俱云乃至谛缘。既是法忍菩萨相应之法。验知理深二乘不及彼通衍三。今取圆教谛缘相应。成今空慧。二当知下结示。二明二乘见浅三。初明声闻。若望因缘乃以七支总为一苦。仍以五支总为一集。又复苦集不分过未。总是现在。以根钝故法相总略。二明支佛。开声闻总成别相。现在五者。谓识名色六入触受。未来二者。谓生老。死别相苦也。过去二者。谓无明行。现在三者。谓爱取有别相集也。又开三世不唯现在。故云略果及略因由中可比三。是则三世皆有十二。以福资智故能别观。三虽复下斥浅二。初正斥二乘。所修三学不为众生不成佛法。是故名为自调自度。大论云。二乘戒名自调。定名自度。慧名自净。缘觉虽有少分慈悲不能广益。故同名自。二与菩萨下对彰菩萨未分权实。但是菩萨俱异二乘。二今举下明析体有殊二。初约共三乘明析观。二约不共菩萨明体观。诸文所明实有灭空为析。幻有即空名体。今明幻有即中为体。乃以实灭及以幻空俱名为析。以其未达诸法实体。体义不成。由谓诸法终归无常。秖是析义。今明诸法一一常住。既见法实名为妙体。初义分二。初别释二。初约二乘明观二。初生空观二。初举譬推。二我人下就法检。各推无故合之亦无。以聚虚空不成色故。即阴下更于即离检令叵得。二虽求下法空观二。初明法存。牒前譬显人亡法存。二更须下用观析二。初正明推法空。正检法空先析色阴。次前念下析四阴。无想受略于行识。二既不下双结二空。智虽空境智须自亡。是故境智俱云不得。二通菩萨下以菩萨例结。前论析观乃三藏法。以对今品体观属圆。故以通教钝根菩萨不能体中。亦属析观。故云通菩萨亦然。二是为下总结。言自行为他异者。以通教菩萨对两二乘分别二行也。二约不共菩萨明体观三。初总示异前。言别菩萨者。非是别教。乃是圆人异偏小故称为别也。故云永异。二如见下深明观相四。初明妙空体法二。初立喻显。然镜像喻文乍滥通。须知圆意。通但六界而为镜像。别圆十界而为镜像。别虽十界九是修成。修成不实故如镜像。圆知十界性德本具。以本具故夺修无功故如镜像。不二门云。幻因既满镜像果圆。如此解之。故云悬体体秪是解。镜内镜外者。解因缘所成即镜内拳指不实。亦解能成因缘。即镜外拳指不实。二众生下就法观二。初生法双空二。初明观。若假若实皆本不生。空则俱空。二如大下引证。我是假人色是实法。二性俱空人法不异。是故名如。二今世下因果俱寂二。初明观。五果既是因缘所生。可合镜内拳指不实。二因既是能生因缘。可合镜外拳指不实。二下文下引证。假实当体即空假中名本性空寂。无始强执谓假实生。名无明故有。既了因寂果那不寂。二虽不二下示妙三谛智。即空假中而为空观。以即空故不得六界生法。以即假故不得二乘生法。以即中故不得菩萨佛生法。荡十界惑是故境智俱名不得。而能审谛十界生法。故二境二智皆名了了通达。境是妙俗以无相故。故无所染智是妙空。以无缘故。故无所净。非染非净称本离念。故双亡二边。正入中道任运双照。三结三谛圆显。三德三谛即念开明举一即三。体非次第显无前后。无觉而觉称为大觉。四与此下与经体相应。佛示二空显法性体。不照三谛岂称法性无量甚深。故知今解与性相应。此性名为金刚宝藏。若偏照之德非具足。三是为下约人结示。故知今体非独是体空。须体三谛方得名为别体。三诸小下斥诸师失意三。初正斥失二。初斥小乘师。毗昙有门说存邻虚。成实空门说破邻虚。若存若破皆为析灭见爱二惑。弘者失意冬生定计。起见起思故属断常。同彼外人全非正析。二斥大乘师。般若等经谈一切法如幻即空。此空毕竟三谛宛然。诸师罔穷作但空解。不即假故不能游戏神通。不即中故不能解释佛之知见。非佛知故不得三智一心。非佛见故不能五眼具足。虽依大教理齐小乘。于小乘中同坏法人。进修烧想坏灭骨人。既其不修观练熏修。无由成就三明六通。三明者。天眼宿命漏尽也。更加天耳他心身如意则成六通。愿智顶禅。以超越禅最高上故。故名为顶。愿欲知三世事随愿则知。故名愿智顶也。二引经示。首即经初。轴即经末。如来法身谓果上法身智断必具。令用二空当念求之。无上涅槃体具三德。皆与无量甚深法性无二无别。故首轴所诠穷深极广。三岂可下结不用。世人邪见即是痴空外道断见也。小乘之析虽是正教。以无般若方便故堕断常中。大乘之体法虽圆备。诸师但作偏空之体。同彼小乘慧解脱观。安能解此即边之空耶。二善女下依义释文二。初明修因二空观二。初约苦集明二空观二。初生空二。初分文。二释义三。初对告劝发。二初释善女二。初约四悉释四。初世界。二又时下为人。三又男下对治。四又佛下第一义。二此是下结成因缘。二释当观。二诸法下指上境。二初释诸法。名目虽略者。秖云诸法则能摄上所说诸境。无不遍也。二释如是二。初标列三义。正明总观者。下二空观历谛缘境。别别明修空假中观。此之三观尽称谛境。今一如是总示三观。如是三观如三谛是。有三义者。列于三法。即当三观所如之义也。二如事下指释三义二。初指释。谓指经文中上下释三法相。假想指上余二指下。上下皆是不思议境。故皆指为所如之法。二又事下融即。初乃俗即真中。次乃中即真俗后乃真即俗中。以妙三德为三谛故。所以此三不一不异。如是之言是故得名为正明总观也。以亦一异为诸法。既以不一不异为能观观。乃以亦一亦异为所观境。境观不二卷舒无妨。三何处下正作观。二初通释四句三。初约初二句明空观二。初释初句二。初就五阴观。言点出者。已用如是总示三观。今以四句明示三观。故皆言点出。今检无人义当理观。二又果下就因果观。二人既下例次句。二本性下约第三句明中观。不以本性为能观者。非中观也。即一切法非理非事名为本性。非别有也。故法华云。诸法从本来常自寂灭相。般若赞云。平等真法界佛不度众生。以本无无明岂有众生。本无空慧岂有于佛。既无生佛何度之有。非破非立双非亦忘。名本空寂。三无明下约第四句明假观二。初由迷俱立二。初正释二。初直约事理释。诸法虽即本性空寂。由具性染故起事染。由破事染故立空慧。欲忘染净故立即中。此之药病悉由无明。二以有下委就迷悟释。生法是果成由惑业故。云以有无明等也。既有下欲空生法须论三观。助事观者。助道事想观也。即不净流溢等。是所助正道即二空契理之观。正助二修为显一性。故立非事非理之观也。是事下以今知三。验其无明是事不知。三皆事者。以在修故。不二门云。修虽具九也。二净名下引证。以众生实病生菩萨权病。示病意者。为明法药也。二若知下由悟俱忘。若知无病用三药为。此之泯忘空品意也。二但我下别释初句二。初明所破人执二。初总示我相。五住之初三界之主。若破我者纵起结使不生四趣。故云深重。小乘大乘俱实无我。我不复断。四教贤圣入之无路。故云大障。凡夫下明起我处。初遍六作。次遍六度。二若揽下别示利钝二。初钝。揽他遗体而起者。是俱生惑。与身俱生名俱生惑。如诸蠕动实不推理。而举[虫*敖]张鬐怒目自大。底小凡劣何尝执见。行住坐卧常起我心。常时自起故名疏钝。二若执下利二。初明密利。执法尘起者。是分别惑。以对意根故曰法尘。因分别生迷理之惑。此名利使。藏之初果。通之见地。别之初住。圆之初信。皆断此惑。二明相状二。初略论十使二。初正明使相二。初明十为枝叶。执一法者。不问邪正大小偏圆。随执一句即生十使。前五是利。后五是钝乃利中钝也。二十使下明我为根本。二纵令下兼示其人二。初明具邪禅慧。长爪即拘絺罗身子舅也。勤学不暇剪爪。时人呼为长爪梵志。根性最利。是外道中高著者故举之。鍱腹者。金七十论云。优楼僧佉外道中有一众首。至金地国。头戴火盆铁鍱其腹。与僧论义。难石等者。大论二十六云。萨遮尼干子难人。乃至树木瓦石流汗。至非想者。如郁头蓝弗。已至有顶故云将出。却堕飞狸故云复还。二如此下明不能破我。尚非小乘内凡。岂同初果破我。二重广我见。谓即色是我。离色有我。我大色小色在我中。色大我小我在色中。受想行识亦复如是。五阴各四即有二十。二若一下明能破空慧二。初通明空慧二。初就境智明生空二。初别示二。初于阴境推。还就即阴离阴阴中有我我中有阴四句推之。是我不然者。能破之观也。据义合须二十遍言。以破二十种身见也。约外境者。望能观智是其内心。故所观阴得名外境。非他身也。二而其下明观智检。所观五阴既立于五。能观之智任运成五。五阴一一皆有四智。悉应计我。故须亦破二十身见。二内外下总结。以数显观令智不漏。二毗昙下约大小观人法三。初毗昙。我见是共等因者。即共业别业。合有四句略言共等。此有门论阴中求我。我空阴有我法两分。故我见思惟前后而起。我即众生。思是实法。故悟生空未得法空。二成实。此空门论揽阴成我。故我见思惟起不异时。是故生法二空同悟。三大乘。我见即具诸法者。俗即真中何法不具。我性如色性生空即法空。二破二下别明三观。既云我见即具诸法。合于三谛而破我见。是故用上三句破之。二初正破人我三。初约理观检。二若作下约非事非理检。我见即中岂存境智四十种执。三若作下约事观检。经文既云无明。故有爱取心强。须作不净助道之观。观邪见恶心是秽恶阴。若善直心惭于义天。愧于圣人。入方便位真理未明。是隐没阴善恶虽异皆未破见。岂有见心不依于色。色须败坏。故云不净。不净之境何处有人。今方便位义当五品也。二若得下更推法我二。初明得悟推法破思。观虽圆修而其粗惑有除不除。若以三观检我叵得。见惑断者。得入初信。更于三师修二十观者。乃破法执即思惑也。从二信位进至六信也。二若未下明未悟推法破见二。初转计实法二。初正明度入。妙观破见见惑未除。见虽未除观己有力。能于假名柔伏爱惑。若其我执度入实法。二引经及事。屈步虫者。要因前脚得移后足。方于假名伏惑。又于实法起见。如彼虫也。二须实下劝更修观。宜于五阴作二十观。显我本性。使空慧明。随度入处以观逐之。名处处作。二明法空二。初约经文释成三观二。初正释二。初立意分文。我见即具一切诸法。岂观生空不空实法。钝根未了故今重说。二如是下随文释义三。初明即法而空。二初示境观。二若四下明修观二。初就法明空二。初正明空。逐一推检。不应动等者。地动则成风性。暖则成火性。史记曰。阳伏而不能出。阴迫而不能蒸。于是有地震。注云蒸升也。冬则地中暖。故礼云。古者夏则橧巢冬则营窟。水坚故成地性。波动故成风性。贞坚也。炭火贞则成地性。火焰动则成风性。风能持物则成地性。触壁止则成水性。二引经证。水性不住者。不守于湿。火从缘生者。既赖缘而生则不能守其热性。风性无碍者。以无碍故不能守其动。一一下四大俱无性故。皆入如实之际。前之二教以空为如实。后之二教以中为如实。今取圆中实际为正。二上检下对生辨观。二本自下明即法而中。二初二句法本自中二。初明性非生灭。以元中未三节显于性是中道。元无四大者。非谓独一全无四大。以其大阴皆如来藏。性体常住本无生相。故曰元无。既无法生与谁相会而为和合无和合。故无可散灭。故不论空。如此谈中之义显矣。二本自下明非观使尔。世间之相本来常住。岂以观智息乎生灭。然后不生灭耶。此名即事而理亦曰即边而中也。二三句显由观解二初正示。性虽本然遣迷由观。言因缘性欲为因。师教为缘。因缘成观达本三谛。诸大即是空假中。故从本不生。二引证。无明转即变为明。名菩提灯。若非感应因缘之力。岂灭无明。故知成佛全假因缘。三和合下明即法而假。二初成违理之事。二此法下成照性之修。此法有故者。即迷惑因果也。体有下三谛也。即空下三观也。境观悉由迷惑因果和合。而有也。二三观下结观。三段经文与三观合。知今宗旨契会佛心。岂可不信。二更为下为钝根重破法执。前释生空已明度入实法。或利根虽晓。恐钝者犹迷。是故大师以无缘慈。更说其相。二初明法执二。初依报起见爱心四。初依大阴起四执。一切外道四教行人。若未伏断见惑已来。皆有此执。二四执下因四执生我见。四中虽云无及双非。既是执生四皆属有。见既依色合当即离。色我我色。见依四阴即离亦然。三我生下依我见生十使。如生空中说四方招下因十使招生死。纵依圆教性具大阴。开于四门。随执一门生我见者。起惑造业招致来苦。与彼外人生死不别。大师正为即时行人陈四执过。二惑此下指见心名污秽阴。此之五阴皆成执见。故悉污秽。襵[埶/衣]归有岂名法空。二心不下明空观三。初明不依是忘四执。心不依阴四教皆然。今明圆宗论不依者。即秽污阴为能观智。何阴可依。何执可破。谁为能观。亦无所显。心不依阴今意略言。二寂然下明契理则备众德。三种般若与金光明牟尼三身。无二无别。若不以此为三观者。见之无由。三行人下明此观速能复本。观生观法皆以三观一念而观。犹如怀璧。复金光明法性之理。如向本国。二三世中可登圆住可以保任。二明十二因缘生法二空观二。初分文立意二。初分文。此十二支而分生法者。顺此经文。初支既名曰无明。名即假名故属生境。无明者。我执也。起信论云。计名字相也。向下诸文但言行识等。既不云名。乃是直指色心也。以行至老死不出五阴色心故。义虽炳然犹恐不信。故引释论逐段证成。谁老死者。如问云谁。则答言我。故知谁我悉假名也。经云名曰与论冥符。论号生空经岂不尔。是老死者。则直指色心是老死法。经不云名与论亦合二然十下立意二。初通辨因缘相貌二。初标列。二三世下解释三。初三世。过去破神常者过去已灭故非常也。现在破神我者。五果皆五阴和合故无我也。未来破神断者。未来有果故非断灭。皆言神者。外执身神有断常等也。此三世义世共传之。故云常涂所用。二果报。以前十因缘属现在。后二因缘属未来。二世合为十二。而文云一期始终。且据无明行在一期之始。相带而言逐云始终。非谓秖在一世此果报因缘。出大集经。以在中阴于父母所。生贪爱心为无明。出入息风为行。自识支已去。义同三世。三一念二。初所凭教。二如眼下明行相二。初正释相二。初对尘直释。六处生贪者。眼识染故。潜牵诸识各有贪情。故普贤观云。以贪香故分别诸识处处染着。一日等者。一根对尘即起十二。六根昼夜数数对尘。何念不起十二因缘。一一成因皆须感果。回转如轮缠缚如网。二今更下更推因起。因缘之观通三世者。意推过去无明为因。生于现果。现果之上复起惑因。本欲即今无明不起。是故今推过现二处起无明相。文二。初逆推过因。从名色起者五果之初故。五阴已具故。识支未具五阴故不言也。过去之因极于无明。今观无明意欲令观成觉了智。而谓无明定是有等。则能破智翻为无明。药乃成病。故云四句取者皆是无明。无明为缘岂不生行生识等耶。如前说者。六入至老死。皆如前文直示中明。二又观下顺推现果。于此受中等者。以受支是五果之终故观至此。若生计着还成一念十二因缘。或有受等者。即是无明不了之心。行识等支一念成就。二如此下叹难知。逆顺推检虽在一念。其十二支宛然具足。所以枝条遍满诸有。其犹大树尚无能识。况能伐耶。言大树者。婆沙云。过去二支为根。现在五支为质。现在三支为花。未来二支为果。布濩者。文选注云。布濩长多貌。从言从水并通汉书云。布濩犹布露。谓于阙露处皆布也。二今经下略示今经观境二。初明经意。但举生法为境者。以假名无明为生空境。以行识色心等。为法空境。此因缘二境通四教观。今意在圆。二宜以下示境观二。初示境二。初立喻。二法合。着于假名者。不达三谛而妄起我见。犹如舞烬成轮。故云不息。轮依火有。而假名因实法而有也。迷故不达色心即空假中。名迷阴入。言薪火者即烬也。二若知下示观二。初立喻。二轮火下法合。观生观法皆即空假中。乃轮火双无二空观也。二生空下依义释文二。初出境相二。初生空境二。初分文。二释义四。以前生空三观释之。故疏无文。二行识下法空境。例应有三者。行即空假中。乃至老死即空假中。佛言巧略。比前可知故。二众苦下出观相二。初据经文示观二。初正示二。初指文。二众苦下释义三。初明中观。众苦行业。指上生法。当体妙故。不可思议。若生若法皆非空有。如是体达名为中观。此观不见生死轮转有际有息。即法界故无际。皆常住故不息。二本无下明空观。三不善下明假观。前不善思惟即过去二支。今不善思惟即现在三支。经心行者。即上思惟也。斯乃举病必对于药。假观彰矣。二虽名下结劝名偏义圆。名但云空而义。乃是即空假中。义既必当。故明与经任运符契。生空法空名义皆尔。故劝修者息乎疑情。仍须了知。全秘密藏为生为法。是故生法无非三德。故观生法能所皆三。境观名别其体不殊。是故能所二即非二。此乃今经二空观也。二为钝人更说二。初特示空观二。别指假中。良以初心于假名实法。起见爱增强障道事重。是故大师特陈空观不说假中。此同释题观解三道。三道正观举名而已。但于假实三毒六作。委破四性频示二空。盖为始行我见弥隆。故示真空以为要术。初文二。初示二。初推人法二。初推人。若假名下对于实法推无四性。今之下四性被推执情稍薄。但谓有名。还须四性检今叵得。所召之人既无生相。能召名字四性亦忘。略示人空其观如是。二观法二初横推。以现名色对过去业。推无四性。罗汉有业者。无始所造诸有业因其数何限。无惑润故不受后身。故曰不生。各有等者。如合两空岂成一色。二既不下竖推。计法之执如屈步虫。舍一取一。生被破故便计无生。还是性执。双亦双非计皆依生。既悉无理复计于灭。亦成四执。八句之上皆云不得。即是空观。无灭无生者。检灭检生俱不可得。方乃得名实法无生。二无生故下明观成二。初明二执忘。揽阴成人实无生故。假名则坏。于假无我诸见俱亡。实既无因安得不坏。二既不下举二喻示。不然火喻不执法。无烟喻实法不生。日中舞喻烬空心秉法。是亦无轮喻不生我见。二是略下结二中观。下别指中假。言别记云云者。具如止观假中破法。行者应知。今明三观圆修二空。但为钝根见惑偏重。故别指空对治此惑。此惑若忘二谛自显。故中假别指而已。二我断下明果上二空用二。初分文。二一切下释义二。初明自行成二。初明智德满。二初明人法。二观成二。初约人法销文二。初明人空观成。二以智下明法空观成。别明十缠者。嗔覆睡眠戏掉无惭无愧悭嫉。忿恚曰嗔。隐藏自罪曰覆。意识昏熟曰睡。五情暗冥曰眠。嬉游曰戏。三业躁动曰掉。屏处起过不自羞曰无惭。露处为非不羞他曰无愧。财法不能惠施曰悭。他荣心热恼曰嫉。烦恼即思惑也。虽见思通名烦恼。今别以思惑当之。罥系也。二二乘下约大小释断二。初论大小断尽不尽二。初明二乘断通余别。界内一切烦恼名数皆通界外。但以所障空中分之。则知通别。净名室中天女散华声闻着身菩萨不着。故被诃云。结习未尽华则着身。斯乃断通未能断别也。二而言下明佛地通别都忘二。初正示。虽云菩萨能断别见。而断未尽究竟在佛。若至佛地不唯别尽。通亦穷边。何者。盖由见思遍十方界六道众生差别种习之所成就。因地乃断未尽边涯。唯佛究竟故云。若通若别究竟在佛。二引证。性德生法体本无上。通别二执染故成卑。妙觉执尽二俱无上。故云无上假实。佛地所不惑也。二经论下明佛地有断不断二。初明经论异说二。初明有断。智以悟极而惑上上。惑以迷极而为上上。今迷将尽唯余微细。故名下下。故起信论云。觉心初起心无初相。远离微细念故心即常住。惑微细故难别难除。故上上智方能断尽下下之惑。无明力大者。惑虽微细能障妙觉。故华严明。灌顶菩萨所有功德如一块土。妙觉功德如四天下土。最后无明所障若斯。力岂不大。非佛智发此惑不忘。一念相应慧者。究竟觉也。正习俱尽者。该于通别也。二或言下明无断有上士者。等觉也。此位须修清净净禅断微细念。故名之为断。无上士者。是妙觉位。修证既忘更何所断。二斯乃下用悉檀和会。此断不断各见教文。人师执之净计莫止。今以四悉逗机之意而和会之。诤无由起。国是境域即当世界机所居处。随处乐闻佛智有断不断。而欢喜者。时即对治随时当有断不断义。而破恶者。人即为人。随人宜以断不断。而生善者。悟即第一义。随悟断不断。而入理者。为此四机说有二义。究论佛智不可言思。二证无下。明正助二道满。无上生法证由二空名无上道。事助之行与正合修。故得称为微妙功德。二开甘下。明断德满。二初略释甘露。以命等四。如次对于常乐我净。二然此下广释诸句四。初对华严四位二。初正对。彼虽兼别今取其圆。别三十位未得甘露故。二下地下释疑。恐后人疑故释也。化他令同我之所得。二又通下对般若四智。论虽多释犹通三教。今四皆从甘露而说。故的在圆。以一心三智荡一切相。名道慧开门。一心三智立一切法。名道种慧示器。一心三智双遮荡立。名一切智入城。一心三智双照荡立。名一切种智处室。由此四智住大涅槃。令诸众生得此四智。名食味也。三对法华大事。彼佛知见是今甘露。彼之开等对今四句。唯有悟入与入处少殊。其义不别。四对涅槃四德。前以四德释甘露义。今用四德对开等文。有此异也。二吹大下明化他成二。初分文立意二。初分文。二余经下立意二。初明智定相成。前现通者令重法乐闻。后现通者令依法修证。故前云开后后云成前。二修因下明因果同类。二空正道为智德类。二空助道为断德类。即缘了二因。非此二因安克二果。二说法下依义释文二。初明转法轮化他二。初明说法二。初总示。二吹螺下别释二。初别明螺等二。初约教位释二。初释四句四。初明吹螺。是故号者。大经云。吹贝知时是也。苦忍凡性者。即内兄上忍位中。于苦谛下留一行一缘。是凡性也。圣人正性谓初果也。说大乘法者。唯以圆教为大乘也。改凡圣偏性通教六地是圣。别教十向圆教十信是内凡。以中理未显悉名偏性。通教七地者至此得知圆者。皆是改号之位者。三人俱破无明。见中道圆性也。二击大下明击鼓诫进者。军阵之法也。兵权曰。闻鼓则进。闻金则止。鼓则严肃军众使前驱也。督率也。率导引也。位在修道者。令初果进二果也。通教位在八地者。前释改号是七地破无明。今进入八地。是增道损生。别教应言二地。圆教应言二住。方名进入修道。今言十行初住者。恐误也。或别有意。真修道者。即通八地。别二地圆二住故。云咸进。地论以初地为见道。二地至七地名修道。八九十地为无学道。彼虽别位例圆可知。三释然炬。通教下皆取当教化他位也。此言八地不取受接。但约当教出假道观双流耳。别约十向其意亦尔。以内修中观外亦出假故。圆在初住者。以百界作佛普门示现故。圆从胜说。乃取分真。止观名真出假位也。皆是下结示三位。道谓外化。观谓内行。此该三教不同余文唯就通说。四释雨雨。扶疏盛茂也。时泽时雨也。大恒者殑伽河也。二若得下例上四经。二此一下以横竖结。竖拟诸经之位者。即向四经名字虽殊。但是住行向地圆位耳。故名为竖。横论一切。诸位者。即摄四教凡圣诸位。如向消文是也。云云者。部在方等故此化他必兼四益。横摄诸位旨在其中。二此中下通。释大义。前三云大。后一云胜。胜亦大也。故云皆言大也。通涂下若取通名。唯在大法义并归圆。对于四经其义弥顺。二我今下明神通二。初明摧怨二。初明烦恼为怨。二魔为下明天魔是主。二明竖幢。高出众行者。即法幢三昧也。万行功德皆为眷属莫不归宗。此之三昧故为众行之望。兵望麾者。手指曰麾。尚书云。左仗黄钺右秉白　而麾之。兵权曰。将军乃秉　麾众而誓之。又云。闻鼓则进。闻金乃止。随其指麾五阵乃理。三德下出三昧体。其体若非不纵不横。岂出众行。岂摧五住。岂坏天魔。无记神通体用如是。二从度下明四弘誓化他二。初牒文示义。虽复等者。既依四谛而运四弘。四谛既常誓岂休息。因人求佛意在利生。今遂所求岂忘与拔。四弘是下示誓有依。誓即无缘慈悲。境乃无作四谛。无缘无作行相如何。众生誓度。生死即涅槃故。烦恼誓断。烦恼即菩提故。法门誓学。即惑成智故。佛道誓成。即生成灭故。不尔。岂能广度永度。二度诸下随义释文四。初令度苦谛。经永断三恶。即三恶道也。须约十番论度论断。二令断集谛。须明五住烧十界生。三令证灭谛。当分而论四种甘露。跨节而辨唯一圆常。四令安道谛四。初约檀明谛。不独行檀具于四谛。五度皆然。五不依谛则不动不出。何度之有。复须知今依无作谛。二无量下略释经文。三论云下檀摄六度。大论十二解檀度云。若菩萨行檀度能生六度。是时名檀度满。云何布施生檀度。有下中上。若以饮食粗物软心布施名下。能以衣服宝物布施名中檀。能以头目血肉国财妻子布施名上。云何施生尸度。菩萨思惟众生不知布施。后世贫穷故行恶。若行布施后世有福无所乏短。则能持戒。云何生忍度。菩萨施时受者恶骂。若大求索。若不时索。或不应索而索。是时菩萨思惟。我今布施欲求佛道。亦无有人使我布施。我自为故云何生嗔。如是思惟已而行忍辱。云何生进度。菩萨布施时常行精进欲行二施。勤求财法以求足之。云何生禅度。菩萨施时能除悭贪而行一心。渐除五盖。是名禅度。又心依布施入于初禅乃至灭定。云何生智度。菩萨施时知有果报而不疑惑。能破邪见无明。又分别净不净施得报不同。是名生智。故云檀义摄六也。余之五度亦互相摄。非今文意。故且论檀。六之首故摄生便故。四舍身下以彼岸结。生死为前际。涅槃为后际。身命及财此三属事。以观此三及能施心所施之境。三轮当处即空假中。是故能等三德涅槃。此以常因而克常果。不然岂得不坏常住。如是行檀名波罗蜜。三德甚深故檀竖高。三德无量故檀横广。此机乐略。是以如来妙说一檀遵修诸行。仍须了知。既谈果后行檀利物。行人岂不即闻而修耶

金光明经文句记卷第四(下)金光明经文句记卷第五(上)

        宋四明沙门知礼述

大章流通二。初释四天王品题二。初因缘释二。初约处释人二。初明处。二十八天皆上升之趣。此当其首。天分三界。于下界中此复在初。居半须弥者。处之所依。欲界六天。二天依山。忉利居顶。四王在半。梵语须弥此云妙高。出水八万四千由旬。四宝所成。二东黄下出人。持国者。护持国土故。乾闼婆此云寻香行。天帝俗乐神也。富单那此云臭。饿鬼中胜者。或云主热病鬼也。增长者。令自他善根增长故。鸠槃茶此云瓮形。颇似冬瓜。是厌魅鬼也。薜荔多此云祖父鬼。饿鬼中最劣者。杂语者。能作种种语故。毗舍阇此云啖精气鬼啖人及五谷精气故。亦云颠狂鬼也。毗沙门此云多闻。福德之名闻四方故。夜叉此云轻健。飞空健疾故。罗刹此云可畏。亦名暴恶。二此四下明品来意。二观行释。三种观法此当托事。以其境智一一皆借事义而立也。须知托事多兼法相。如王舍城而观五阴。耆阇崛山而表三德。此之五三何殊四谛。然此正是托感应事明境观也。分二。初示观相。四谛四智乃至谛下各论见思。何教不说。今释教义既专约圆。故所明观不关三教。四天须表无作谛理。四王乃表无缘妙智。照事即理名护谛境。了缚为脱名护心数。为他说此名为护世。通别见思同体为障。名为鬼神。法花指此等者。不无少异。彼以鬼神但譬五利。乃将虫鸟而譬五钝。今则利钝俱类鬼神。但取分同也。二若不下明利益。而且先明不观有损。侵害心王妙智不发也。毁损境界谛理不彰也。心王至迸散。示迷三德而为三障。虽论三障迷由烦恼。故云俱为鬼神所恼。能观下正示观之有益。无明即明为能观智。此观观苦生死即涅槃也。此观观集烦恼即菩提也。控御等者不动诸见而修道品。不断痴爱起诸明脱。如斯控御岂独不被侵害。而能显理备德。显理故谛境国安。备德故心数民宁。以转八万尘劳成八万定慧也。自行了达既其若此。令他修证岂不然乎。托护世天王之事。修观获益其相略尔。二释十三品经文二。初立意分章二。初立意。季亦末也。翳障也。二凡为下分章三。初开流通七章。方轨者。方法轨范也。二天王下出天神五段。以地味膏腴请处说处者。膏腴土田良沃也。史记曰。东割膏腴之地。是也。腴下多味字。禳除也。又天王下且从增胜备论。一一皆有五能。三四天下示此品六番。二正释经文七。初段分五。初又分六。初述护国之能二。初分文。二叙敬下释义二。初四王白佛二。初经家叙先标。北方天王者。西土以北方为上也。偏袒者。西方之礼。弟子诣师必须偏袒。表有执役。二正白佛二。初分文立义。二法性下用义释文二。初叹经三。初叹体。佛所护理无量甚深。横摄法周竖收法尽。理若不尔岂名经王。问文诠此理故言经王。是则经文但是能诠王惟在理。释题那云文号经王教摄众典。指文指理二处不同。如何和会。答若前三教文理不合。此则为妨。今乃从圆法皆不二。文外无理理外无文。释题举文。若其孤立岂得称王。今疏指理不摄文者。翻属前教。信文理合是经是王。其义秘妙不可情求。今经王叹体与序品不别。二约体下叹经宗。约体修行者。体是本觉起成始觉。方得名为约体修行。体具佛界因果二严。全体成修二严无作。名非庄严而为庄严。今以极果二严为宗。世天下经云。诸天包此三也。然应有四。恐文脱误。或可天王本是生天故疏不出。此四天名义出大经。德王品云。一者世间天。如诸国王。二者生天。从四天王乃至非非想。三者净天。谓四果支佛。四者义天。谓十住菩萨。以见一切法是空义故。大论明三种天。一假名天。即世天也。二生天。三清净天。则兼三乘也。三又下下叹经用。上至菩萨者。经无菩萨之言。既云能灭一切众生苦恼。则通指九界方名一切。经文有四。初天趣。能与众生快乐者。天趣众生也。次是经下三恶趣。诸河三趣沉没犹如大河。焦干枯竭者。灭三恶苦也。有经于枯竭上加能令二字者。妄也。三能除怖畏去。是人趣。初言一切怖畏是总。次别明破三障恶。三灾是报障。怨贼即刀兵也。并饥馑疫病名三灾。恶星是业障。业来责报。故恶星现也。忧恼是烦恼障。四举要下总指九界众生也。二从世下述能护二。初分文。二护国下释义二。初内以法护国四。初护国之由。二以法护国。即是述其护国所以。无法安能护持国土。而其所以有内有外。外即世法内即心法。若但行说世间之法。则令此经非方等教。天王全是凡夫心口。须知文文皆有世间出世间意。但以此句显内义便。故云正与观心相应。如下散脂鬼神品中诸文。且顺世法诠辨。及至自述得名之由。则全废事解。故云现见不思议智境不思议智光。乃至云我能安住一切法如性。于一切法含受一切法。境智若是故名为密。方能外现鬼神大将。岂非有理密故乃有事密。今文经虽不显。大师得意。乃以行说谛智之法。而为护世安民所以。心数不行等者。心心数法全体即是方便般若。心王邪故数行邪境。今王既正导令不行。不行而行。行深般若到于彼岸三天党护国。意同向说。党谓徒党即八部也。党辈也。帅党者。帅音率。导引也。如转轮王下是事释。以轮王降四方喻天王遮恶鬼。七宝谓轮象马女珠臣兵也。四天眼护国。以报得天眼者。非修得也。受天身则眼必彻障。幽暗也。烛照也。萌种子初剖也。杜塞也。谓以天眼彻照防将萌之祸根。塞渐起之恶源也。二从若下外以策护国二。初标科叙意二。初标科。二一若下叙意三。初劝说听因缘和合二。初劝法师为外缘。日出朝阳者。尔雅云。山东曰朝阳。山西曰夕阳。雰扶文切。不祥气也。吕氏春秋曰。冬行夏令则气雾冥冥。春秋元命包曰。雾阴阳之气也。阴阳怒而为风乱而为雾。今以日出喻弘经。雰雾歇喻三灾息也。二次王下劝王者修内因。秉法者。秉持也。一人谓王也。庆善也。王有善则万方之民。恃赖之。即尚书曰。一人有庆兆民赖之也。故王受是典而致国安。经饥馑者。尔雅云。五谷不熟曰饥。菜蔬不熟曰馑。国邑郡县者。王制曰。凡四海之内九州方千里。州建百里之国三十。七十里之国六十。五十里之国百有二十。凡二百一十国。凡九州千七百七十三国。春秋左氏传曰。凡邑有宗庙先君之主曰都。无曰邑。又曰。上大夫受县。下大夫受郡。二劝供给四众因缘。经优婆塞此云近事男。优婆夷此云近事女。以成就戒者。堪可亲近承事出家二众故也。流衍者。衍达也。三劝能赞所赞因缘。先王之德行者。先王道德之行。若行之于身。即可以仪轨风俗。法言者。是出自典诰圣人礼法之言。若宣之于口。即可以教人民。君既无此故邦民不从其令。邻国不咏其德。今劝下即劝王重道尊师修功补过也。身意恭重谦以自牧。即道德之行也。赞叹在口。即典诰之法言也。夫高下明谦卑之意。王高而民下为国者以人为本基故。当劳谦以聚之。辩以讷为师者。讷者内照清净。故外绝矜饰。即大辩若讷也。故能为俗中小辩之师。寻常治身理国尚当如此。况今请出世之法。祈人民之福。岂宜倨慢乎。儒礼以父事三老兄事五更。屈王之尊敬卑为师。儒释一揆矣。羽檄者。文心雕龙云。檄者皦也。宣露于外皦然明白也。或称露布。盖露板不封布诸视听也。颜师古注汉书高纪曰。檄以木简为书。长尺二寸。用征召也。其有急事则加鸟羽插之。示速疾也。今云羽檄称叹者即告之以文辞。述具休明也。尔雅云。颙颙昂昂君之德。靡偃也。论语曰。君子之德风。小人之德草。草上之风必偃。草莱者。莱[卄/梨]草也。或作叶。或作菜。字之误也。二用意销文三。当以上意对经释之。故云可见。二如来述成二。初分文。二四王下释义二。初合述叹经。四王所赞经体宗用。既合佛证三德妙理。故佛述成。诸佛从是法生者。体宗用三既是法性。岂有一佛不从此生。二从于下述能护国二。初分文。二法护下释义二。初述以法护国四。初述护国由。发心毕竟者。昔种善根是发心。今日闻经得益是毕竟。二心比校昔种诚难。故佛述成叹其宿种。然此发心等语。即大经迦叶说偈赞佛。故佛初心但用彼语以成今意。护世下云云者。此与观心相应义如前述也。三从汝下超述天眼护国。四从汝下追述天党护国。二从汝下述以智眼护国。前云策。今云智眼。互见其文策即智谋。智能鉴照。名之为眼。言和合者。即前云内因外缘。因缘和合然后禳恶。云云者。前白佛则三段别明。今则一番总述以包前别也。第二番白佛述护国之事二。初分文。二一是下释义二。初白佛二。初工奉人法天除怨患。经天律治世者。师古治民则天行化。罚必当罪赏必当功。名天律也。二邻国兴兵天令懅退。斥逐也。经四兵象马车步也。规往讨罚者。规求也。或作亲者字之误也。讨诛也。传例曰。有钟鼓曰伐。或作罚者。非罚。折辱也。出金赎罪也。军者万二千五百人曰军。天子六军。诸侯三军。二佛述成二。初标科。二从尔下随释二。初述成初意。无斗讼名僧者。无斗讼即和合也。二述成后意。二。初正以等慈述其懅退豫安也。二又劝下兼劝诸国各守本业。贪企者企望也。佛告帝释者。大经文也。经楚挞者。楚一名荆可以为杖。挞击也。广雅沃湿也。美也。亦柔也。壤土也。时不越序者。四时和也。心无贪吝者。无贪故不多求。无吝故能惠施。后妃婇女者。天子一后。三夫人。九嫔妃。二十七世妇。八十一御女。风俗通云。婇女者。采择其容色之女也。第三番白佛。示其轨模二。初分文。二释义二。初白佛二。初出愿。欲六文如疏列。二示轨模六。一一如疏对。上六愿柏梁者。汉时殿名。天火曰灾。汉方法以海中鸱鱼尾安殿脊以禳之。灾遂息。世昧其由谓之鸱吻。八纮八方也。休美也。自励者。励勉也。四海者。博物志云。天地四方皆海水相通。地在其中盖无几也。七戎六蛮九夷八狄。形类不同总而言之。谓之四海皆言近于海也。次佛下述成二。初分文立意。二佛告下用意释文二。初别述二。初述成六方法六。初述成安身方法。羽仪者。汉书高纪曰。纪信乘王车黄屋左纛。注云。以黄缯为盖里。纛毛羽幢也。在乘舆车衡左方上注之。蔡邕曰。牦牛尾为之如斗。或在騑头或在衡。以纛是毛羽幢为天子仪仗。故曰羽仪。经躬出者。躬亲也。二从复下述成安国方法。尔许生死之难者。劫数如值佛之数也。三述成安妻子方法。四述成安王领方法。五从常下述成宫殿方法。六从在下述成上摄福方法。二从汝下述成六愿欲。六段如疏。经棘兵器也。与戟字同。刺杀也。二从汝下总述第四白佛要其法利二。初分文。由第三段末者。由前世尊述成云。亦当回此所得最胜功德之分。施与汝等及余眷属。四王因兹遂要法利。二释义二。初白佛二。初人王运心。二人王下天宫相现二。初事释。人王至金光者。心存即三智金光明也。至典即三谛金光明也。智谛合即起事用金光明也。以色心不二故。香随智遍回施下天王意云。若以法利回施我等。我等皆得。故以光照天宫为表。龙犹属畜。对天并鬼成三法界。言法界者。今从解脱。所烧之香非法界者。何能周遍。三趣之体非法界者。岂能承受。二观释上之所说。虽谈谛智犹是约教。示经力用。未论观行。今之所论的就研心令观诣理。故荆溪云。本虽久远。圆顿虽实。第一义虽理。望观属事。此乃托事观心。借义成行。三智妙解如火能然。三谛融心如香离臭。起三学行如烟氤氲。真本觉照故曰金光。行冥真故无碍而照。但期观行契金光明。功用自然相周沙界。唯务相现内观不修。心缘五尘魔必得便。慎之慎之。次佛述二。初标科。二随释二。初述成香光普遍。经摩醯首罗此云大自在。金刚密迹者。正法念经云。昔有国王夫人生千子。欲试当来成佛次第。故俱留孙探得第一筹。释迦当第四筹。乃至楼至当千筹。第二夫人生二子。一愿为梵王请千兄转法轮。次愿为密迹金刚神。护千兄教法。世传楼至化身。非也乃法意王子耳。据经唯一人今状于伽蓝之门。而为二像者。夫应变无方多亦无咎。摩尼跋陀此云威伏行。阿耨达此云无热恼。娑竭此云碱海。经百亿非非想天者。夫百亿即大千界也。但同一四禅及四无色。三禅统中千界。以大千言之。则有一千三禅也。二禅统小千界。则有百万二禅。唯四洲至初禅。则有百亿。今非想亦言百亿。以下望上言之耳。又恐翻译之讹也。以义净重翻则无百亿非想之言。二从诸下述成施善护赞二。初赞因。二赞果。经勤修下明修苦行。善能下坏外道。降魔怨是庄严道场也。觉了下成正觉。善男子下转法轮。此并果上之事。如瑞应经广明。第五白佛举兴衰二。初分文。二释义二。初白佛三。初举兴劝四。初述弘经四天听受。二大梵下明释梵八部皆集。经释提桓因者。具云释迦提婆因达罗。此云能天帝。三世尊下明人王为善知识。四以甘下明得利护国弥勤。二次举衰劝二。初分文。二随释四。初明天失法食。二明天神舍离。三明恶鬼兴灾。经流星者。星说曰。绝迹而去曰奔星。光迹相连曰流星。薄蚀者。案汉书天文志。作日月薄蚀。孟康注曰。日月无光曰薄。韦昭曰。气往迫为薄。亏缺曰蚀。京房易传云。日月赤黄为薄。释名云。日月亏曰蚀。谓稍侵亏如虫食草木叶也。虹者。尔雅云。螮楝虹也。尔雅音义云。双出鲜盛者为雄。雄曰虹。暗昧者为雌。雌曰霓。霓或霓。江东呼为绛俗呼为美人。释名云。虹攻也。谓纯阳攻阴义也。四展转成灾。三正劝二。初分文。二随释六。初欲得现利。二天忻法食。三出过三论。四韦陀者。即外人典籍。摩蹬伽经云。初人名梵天。造一韦陀。次有仙名。白净变一为四。一名赞诵。二名祭祀。三名歌咏。四名禳灾。次名弗沙。有二十五弟子。各一韦陀能广分别。遂成二十五韦陀。次名鹦鹉。次名善道。及其弟子渐渐增广。如是展转有千二百六韦陀。今言四者。从其根本为名。皆明梵事出离欲染。故云梵天。说出欲论也。毗伽罗论此名记论。婆尼尼造。明种种经书并诸杂语。又名字本。河西云。世间文字之根本。典籍音声之论。宣通四辩诃责世法。赞出家法。言辞清雅。义理深邃。虽是外论而无邪法。将不是善权大士所为也。僧佉此云数论。诸法从数起故。劫初黄头仙所造。卫世师此云胜论。谓诸论中胜故。胜人所造故。成劫末鸺鹠外道造。勒沙婆。此云苦行。未知出世时节。以人名名所造论。此三仙所说无漏尽通故。唯五通。四始终获利。经如来正遍知说者。十号中二号也。五教主胜故。经以大悲力故等者。用无缘大悲普覆法界故。超梵王四等之心以难思苦行积劫利物故。超帝释十善之因。六诸法本故。经一切众生等者。世间谓五戒十善十二门禅等。出世间者。四教法门者三乘修证也。国事者。礼乐征伐治世育民之事也。造世论者。如上三论及下正论等也。皆因此经者。乃教行理三种经也。故新本云。欲生人天欲得四果支佛。欲得佛。皆依此经。忏悔灭障方得成就。若探取化意。即是于一佛乘分别说三。但以此经部在方等教。犹属通理。就人分未免异趣故。欲令等言随其五乘。而得安乐也。二佛述二。初分文。二随释二。初举兴衰劝。二正劝第六说偈颂德二。初分文。二夫三下释义三。初说偈叹三。初叹三身三。初依现文别对三身。空是法身者。经无空字。以其日月必依于空。又下文云。佛真法身犹如虚空。是故疏以空日月三对于三身。空无明暗日月共依。别喻法身体本周遍。日能破暗别喻报身三惑尽净。月能盈昃别喻应身随机胜劣。此之别对为下圆融而作张本耳。二通意下取喻义通具三身二。初取喻显圆。若以三喻别对三身。恐谓三身其体隔异。故今委取能喻之事。其义不局。每喻各自具于三义。如日一喻。上必依空下必现水。此之三义则。显报智圆具三身。此则三般若论三身也。月喻亦尔。可显应用圆具三身。此则三解脱论三身也。太虚空是日所依空。天日水日当体含空。此之三空则显法体圆具三身。月亦如是者。月所依空天月水月其中含空。亦显法体圆具三身。空遍日月两说三身者。乃约双照中道而示。此则三轨而论三身也。二依下以结文示。此结叹文。凡举三喻谓月焰化。此三事义各合具三。如月一喻必上依空。必下现水。此乃应身圆具三身。文举如焰焰必依日。日必依空。此乃报身圆具三身。文举如化。化必有术名为化法。术必在人即是化主。其变化物名为化事。此乃法身圆具三身。三虽复下复取结文以通融别。经既显云无有障碍。若非以法而定于喻。一一圆融何称此中无障碍说。当以此意融身相文。使一一相皆严三身。成密藏相。二叹身相二。初分科释经二。初分科。二释经五。初叹上二相。二叹智断者。初二句总标。有喻有法。次四句是别叹。二句是智二句是断渊海也。管子曰。水出于地而不流曰渊。三叹下二相。四绝言叹。五结叹二夫。相下总示身相三。初通严。三身相好不独在应身。报法亦通等者。如今所列。目齿轮网例于上下。二十八相通能庄严三种身也。以身相是一随见成三。庄严父母生身者。以藏通人但言偏空。所见佛相谓由正习。构造而成相非奇特。但能少胜轮王而已。以不知心现见从外来。取色分齐故名生身。此乃如来曲顺凡小。示现此身故名为应。庄严尊特身者。以别教人能信中道妙色妙心随缘变造。所见佛相知从心现无有分齐。或现大身十莲华藏世界尘相。或现八万四千相好。或时秖于丈六三十二相。令其机缘无分齐见。不同藏通分齐之身。故名尊特。此乃如来修道所得。故名为报。庄严法门者。以圆教人了大小身及多少相。皆性本具修德无功。相虽是色色即是心。故起信论云。色性即智说名智身。智性即色说名法身。今从即智名法门故。以八万四千陀罗尼为发。乃至定慧为足。以即色故。故得名为法身相好。此乃相好随解而转。故使庄严三身相异。二此中下别示法门。此乃指经智渊无边而为智德。百千三昧而为断德。此之二德能收一切庄严法门也。学者若于色心分隔而解此义。则永不识法身相好也。三文下文示圆融。上来分别法报应相。欲令易解故须就机浅深优劣。须了前前不知后。后须了后后必见前。前良以前粗后妙故也。今四天王是大菩萨就圆称叹。见三身相。与妙三德无二无别。应是解脱岂隔二德。报法准知。欲彰此义。是故特云无有障碍。若知此意。方是深达金光明法门也。三偈初下结叹二。初直销经文二。初销文。结佛月为三身者。现文唯有空与水月合有天月。可喻三身。言佛化为四身者。法身妙色而为化法。报应二身照理鉴机而为化主。曲顺机缘现九界身。而为化事。今以化事显具上三故论四身。皆具三四者。趣举一身即三即四。彼彼皆尔。方名无碍。二品初下结妙二。初明始末皆三。三章是法三身是人。揽法为人人不离法。故云辞异其义是同。佛月清净者。取偈初句成今三身。三叹天辩绝妙。初叹三章云。金光明微妙经典。显不纵横。今结三身言无障碍。亦非纵横。以初以后显于中间。句句无非谈秘密藏。大师叹妙其意在兹。二料简机应。上明三身无有障碍。其义幽微。犹虑学人三相不泯情有分张。今明三身及以所被。无非法界。法界无外更何彼此。三初一问答。明法外无余。言法不作报非报者。非报是应。难云。三身秖一法界岂有能作作所作耶。而言依法者。此同体依依而复即全体之用。用还依体。二一问答。报即法界影是应身。非影是化身。以现九界非佛像故。法界下注云云者。更合明于应是法界三同秘藏。岂有一身非法界耶。三又并下一问答。明机外无应三身一体。人或信之。其所对机多谓他境。故今显示令泯此疑二。初设并显。动譬机生不能睹应。不动譬机熟则能睹应。水譬正因。安乐性者。即大涅槃既是三德。性必妙融宁非法界。故自他不二门云。物机无量不出三千。能应虽多不出十界。物机应契身土无偏。同常寂光无非法界。若昧此意勿议今宗。二又净下引文证。因感出世由生成佛。人皆共知四教悉尔。今从圆说始穷经意。良以自他性本不二。方有能感及有能资。因感出世者。即十界机感。十界应也以生地狱与佛地狱性不二故方能感见地狱之应乃至感佛亦复如是。今宗所论感应皆具十法界者。为显不二。义若不然。岂惟众生不能感佛。抑亦十处不成法界。宜深究之。宜深究之。由生成佛者。众生能作成佛胜缘也若顺若违并资佛行。而恶逆者其功最强。如无达多。佛岂成道然若恶法本非佛性。何能资助菩萨成佛。菩萨不观生为法界。非同体悲非无作行。何能成就大菩提果。若其佛外有一众生非佛法界。生外有佛法界不成。不作此解未超三藏。何况通别。二佛三偈答二。初立意分文二。初立意二。初正立法。能成佛者。诸佛轨法方成因果。以法常故诸佛得常。例乐我净亦复如是。二般若下引证。法能成立。一切凡圣者。以法本具十法界故。随染净缘起成凡圣。凡夫虽迷而其迷中假实依正未始离性。须知染缘熏于性染。方成染法。净缘熏净人皆共知。性染性净其体本融。全体而起。随染缘则染净俱染。随净缘则染净俱净。故不二门云。三千在理同名无明。三千果成咸称常乐。性之染净是金光明经妙体。如来今说为作净缘。是故称叹以答天王。二分文。二用意释文三。初叹经体。二十力下叹经宗。三以是下叹经用。私开为四。初三行通就众生明生善灭恶。二阎浮下十二行半别约人王。明生善灭恶三。初三行半明愿欲。二应当下三行半明立行。三譬如下五行半明获益。三是金下二行半约上圣护念明生善灭恶。四若有下四行半约师弟说听明生善灭恶。三四王欢喜发誓。经悲喜者。悲昔不闻喜今得闻。悲他不闻喜自得闻。涕泪横流者。涕音体。涕即泪。横谓交横。古本皆作横流。不须改为交字。大经亦尔。无谶所翻多云横流也。文选王粲登楼赋曰。悲旧乡之拥隔兮。涕横坠而未禁。怡解者。怡谓和悦。解谓舒散也。二大辩品二。初释题二。初释大辩二。初所住法门二。初具明四辩拟于四教。藏不明大但说无漏。故名小辩。通教出假说于界内。尘沙八门名无量辩。别教能说界内界外二种尘沙。故名双辩。圆谈十界法法皆中。二边情泯法法互遍。真俗宛然三谛一谛。名为大辩。二此天下明所住法。最胜王云。大辩才天女依高山顶。葺茅为室结草为衣。坐翘一足。空假中智一心中得。破根本惑庄严法身。心既融通说乃自在。即自住大辩也。二以自下。能用四悉圆辩深妙。能谈粗浅随机而授。无有挂碍方名大辩。是故疏以悦宜对悟。而论四悉令得四悦。乃至四悟。此则一悉明于四教。亦是四教各有四益。大辩才天力用如是。二对佛下明品意。二释文二。初分文释义二。初分文二。初加下释义三。初加法师加圆四辩。自能该三。即前四四十六益也。乐说辩者。于一字中说一切字。于一语中说一切语。于一法中说一切法。随可度者而有所益也。辞辩者。种种庄严言语善巧也。义辩者。知诸法义所归趣处也。法辩者。智慧通达诸法名字也。二若有下加化道。前加四辩是能化之道。今加其人是所化之机。此二和合化道无穷也。三从复下加听者。经技术也。二结示益深。第三功德天品二。初释题二。初释功德。于二严中此当福德。福能资智以严本理。智即三般若。福即三解脱。所显所严即是三轨。若总若别。皆金光明一体异名也。应知大辩与功德天。咸皆证入金光明法门。皆能遍摄一切法也。引物偏好名行不同。彼摄一切以智为首。此摄一切以福为首。能摄所摄对智不同。故当世界。所须不乏能生正念。即当为人。思惟深义能破偏浅。即当对治。能令速悟本性菩提。当第一义。二此是下明品意。二释文二。初分文。二释义六。初誓给四事。即经所列衣服饮食卧具医药也。及余资产者。即四事之外。一切资具产生之物也。二明福德之由。述过去世值佛修证金光明法门故。能今日随弘经处有求皆与。宝华等八字别号也。如来等通号也。无虚妄名如来。良福田名应供。知法界名正遍知。具三明名明行足。不还来名善逝。知众生国土名世间解。无与等名无上士。调他心名调御丈夫。为众生眼名天人师。知三聚名佛。具兹十号名世间尊。种诸善根者。以照金光明微妙之智。为诸善之根也。璧者玉所琢器也。周礼云。以苍璧礼天是也。珂贝螺属也。三劝示行法二。初略劝示。二广劝示。私开六初。示常所住处。经阿尼曼陀此云有财。二示称名供养。三明诵持神咒。四明叹咒劝持。灌顶章句者。以法性水灌十地顶。受法王职。今密谈此法故名灌顶。必定是般若德。吉祥是解脱德。真实不虚是法身德。以此三德赞灌顶义。等行谓具行诸行。中善根谓行一行。八戒者。即在家人一日一夜也。于五戒上更加不着华香。不观听妓乐。不止高床。此八是戒。不过中食是斋。五劝回向菩提。此乃奉供及诵密言邀请意也。若为自身受五欲乐。希望财宝即轮回业。众圣所诃。尊天宁护。令为己他成菩提故。其所克获非生死因。当依此文修今行法。六劝严处奉待。阿兰若。此云无诤。以其所居不与世诤。即离聚落五里处也。又有达摩阿兰若。谓说诸法本来清净。因名其处为法阿兰若。即华严经初于阿兰若法菩提场是也。今经所指该其二也。四誓临影响。五要求同行。六别示归敬。问大经中说。功德姊主黑暗妹随。有智主人二俱不受。今令奉供与彼大违。两经所谈如何和会。答尊经设法取舍多涂。大权垂形表报非一。彼对黑闇。表生必死。四相相随。此对大辩。表福资智二严互显也。四相是过宁不双驱。二严是功理合俱进。有智之福生死自亡。有福之智菩提可证。今为说听金光明典。故藉天资所须之物。须知今用双亡生死。弘经之心感功德天。所获资财离我我所。姊尚不着。妹岂能来。此为弘经彼专修观。用舍论益去留岂同。又如国王大臣官长。法华令离涅槃令近。故知设法各有异门。岂以彼经难今所说。第四坚牢地神品二。初解题二。初正解名二。初所表之智立四悉。净名云。智度菩萨母。方便以为父。一切众导师。无不由是生。上是天神。天是阳故如父。此既地神。地是阴故如母。一义也者。父母不同故属世界。天阳上覆地阴下载。卉是草之总名。木是树之都称。智度下合喻。众善合卉木也。各有下如檀破主悭。乃至禅主破散。五属缘因。故未亡泯。智破生法方无名相。破恶中最故当对治。智度复本破立俱忘。故无等无上名第一义。此于智度立四悉檀。二智度法门下能召之名彰四德。坚牢即常德。地即乐净。无苦受故荷持一切。离染着故出生无尽。神即我德。威德力用悉自在故。二此品下明品意。二释文二。初分文。二随释三。初誓涌地味三。初明己身增长二。初生起八事。二随事释经。当依生起次第消之。经聚落者。落居也。人之聚居故名聚落。山泽者。下有水曰泽。宿卫谓止宿卫护。五果者。即经云。寿命色力辩安也。此之五果由食而致。二从何下明眷属增长二。初生起五事。二随事释经。五并如生起。经纵广者。南北曰纵。东西曰广。三从世下明报恩增长二。初生起六事。二随事释经亦如生起。二佛述成二。初标文。二随释二。初述成展转增长。一约闻经下为成展转义。故探取下科为出世也。日夜受乐在次文耳。二述成供养增长。经明供养是在人世也。是人下往天世也。日夜下至出世也。虽受天乐住乐法界故无所受。是故名为不可思议微妙快乐。三发誓护经二。初分文二释义三。并如分文

第五散脂品二。初解题二。初释名并领二。初翻梵名二。初翻名。二密有下示义。密名顺世界。密行可为人。密智能对治。密理是第一义。皆约三法不纵不横。非偏小凡下所知。是故名等。悉称为密。注云云者。旨在于此。二盖此下明属领二。初明所属二。初正明所属。二余三下兼明三将。二管领下明所领二。初出部数二。初就方维明数。六方者。四方天地也。四维者。四隅也。二又说下约五大明数。此五各有主执之神故。二巡游下示功能。二闻经下明品来意。注云云者。虽三天王各有神将。散脂为首。故独标名令释此意也。二文为下释文二。初分文。二随释四。初发誓护持二。初经家叙。二正发誓。二述有能护之德二。初分文。二释义三。初标经。唯然上声。礼对曰唯。野对曰阿。二述又下述二。初节句立意。二神既下总别释义二。初总释三。初据名标义。大权所为有本有迹。以智证真名之为本。随情立俗名之为迹。虽分本迹但立一名。昔从密本垂于密迹。今从密迹显乎密本。垂迹之际。此之密名。但诠世俗统领神众有于密谋。今对世尊叙护经德。宜须显本。此之密名。合诠理智。非是偏小贤圣所知。称之为密。散脂本迹既于此彰。以验四王诸天神等。皆是从本而垂迹化。是故今释委论密义。岂独能显诸天本迹。亦乃能彰经体宗用。二智若下依名释义二。初约境智释二。初释三。智即能观之三智。境即所观之三谛。正即显境智之非邪。能所互融邪正不二。密名显德其在兹乎。初初五句明智密二。初拣非浅深阶级者。别虽三智前空次假后中。此可言思何所论密。二即一下显密二。初约三智互融不出三也。初句即一智是三智。妙空智也。次句即三智是一智。妙假智也。后双非三一双照三一。即妙中智也。若指诸法为一切者。未必尽备。以空假中为一切者。更无遗余矣。二若得下附文示融五句。即三智配释如下。二次五句明境密二。初拣非智。知即可思口说即可议。那成密耶。二不可下示密二。初正示。境非智外。岂以偏小智之可知。识即是境。岂以六凡识之可识。此明绝思也。境离名字岂以诸法名字名之。境离言说岂以四句言说说之。此明绝议也。二而约下附文前三智云。唯数唯密。今虽五句句句皆云不可思议。即唯数唯密也。三后五句明正密二。初拣非。介尔对待皆非中正。乃粗显法密义不成。二即邪下示密二。初直就理示邪正。中边趣举其一。收法毕尽。更欲与谁而论待对。欲令解了强言中正。二引思益证心通真妄。今以分别有无分之。言分别者。分于邪正别于中边。乃令诸法不正其中。其失既然得可知矣。二我行下结。二又此下约三业释二。初释。言一往者。既智境。正外傍显此义故也。散脂今就密名显本。本密必三。谓身口意。若其不尔。何能示现神将三业。令众不知。故未显本。前非同证者皆不能测。此乃三密使之然也。二所以下结。虽在三业言且不彰。复是密义。如先陀婆非智臣莫晓。三如此下结前生后。二世尊下别释。前以五句共明智密。乃至五句共为正密。但以智等彰其密名故当总释。今于初五句分对三观。乃至后五句分对三身。故当别释。二初大师用三法释二。初正别释二。初约离释义。二约合对题初三。初约五句别对三观三。初牒文示义。作观释者。此出散脂本修之行也。二知一下依义释句二。初二句示境。能生所生皆言一切法者。如十二支。皆是能生皆是所生。能生生所生所生资能生。能生名因。能资为缘。因缘不尽生法无穷。此等即是所观境也。二了一下三句示三观三。初一句空观。了达虚无者。悉从因缘无性实故虚。离名相故无。毕竟叵得方名了法。二知法下次句明假观。了无性相名曰知空。不碍缘起名为非空。以一切道起一切种。名道种智。此智分别十界假名。海印森罗而有差别而或作无字必误也

金光明经文句记卷第五(上)金光明经文句记卷第五(下)

        宋四明沙门知礼述

三如法下后句明中观。以二观等者。出安住行相也。圆论三观。若非一心观体则纵。若其不以二为方便中为真实。观体则横。今论三观不纵不横。如此修之。即能安住十界之法。如于本性即修成性。功由一心三观之力也。故荆溪云。以正观安故。世谛方成不思议也。此则双遮中道也。双照二谛故言含受。遮乃遮情。照则照性。边情既泯二谛皆中。中既不偏。是故空假各含一切。经云。于一切法含受一切法。不作双照中道解之。经意莫显也。三若三下结观名密二。初拣非。二即一下示密。即一而三故不一。即三而一故不异。纵横并别非之例知。欲知等者。兼用口密以结此文。二约次五句别对三脱。此明散脂自显本地。已证解脱而兼三谛者。得脱由见谛也。三初牒文示义。二现见下依义释句三。初一句示圆净。实智照不思议真谛者。真谛体是性德般若。全性起修名为实智。谛非般若宁发实智。此谛离缚乃成分满。圆净解脱。当知理果终始一如。二三句示方便净。随机屈曲因果废兴。皆是权智照不思议俗谛。俗谛体是性德解脱全性起修名为权智。离缚乃成分满方便净解脱。理果不二准前可知。三后一句示性净。前云智光乃至智聚。四名但召能照之智。唯此智境虽亦标智体。是谛理义当所照。故疏引经法如如智。此智与法如如冥故。意彰境智如如不二。然而此说人皆知之。所解终成二物相合。盖以不晓境智之体故也。欲知境体。须简顽境及偏小妄心假立真如。此境安能与智不二。今依马鸣立境体者。所谓本觉。其智体者。所谓始觉。故起信论云。所言觉义者。谓心体离念离念相者。等虚空界无所不遍。法界一相即是如来常住法身。依此法身说名本学(文毕)此觉是性。全性起修名为始觉。论云。始觉者。即同本觉。既云离念。岂有思议。既等虚空无所不遍。岂有一时一尘一心而非本觉乃始觉耶。是故得云三世十方生佛依正为所观境。三世一方生佛依正为能观智。境智名别其体不殊。是故能所二而不二。境照于境。境照于智。智照于智。智照于境。此四句说。说即无说。无说而说。此四句照。照而无照。无照而照。不可思议智境斯之谓欤。此之智境须论六即。今是分真究竟二位。三若三下结脱名密二。初简非。二以不下示密俱例前。三约后五句别对三身三。初牒文示义。二正解下依义释句三。初二句示报。正解能显体等者。此乃似解能显真体。真体乃是性德般若。既得显发即能观。达根本无明故名正观。而言报身者。在心名观就身名报。四十二位皆得论之。二得正下二句示应。分别约法知药病也。解缘约机知生熟也。非此解别则无应身。故应身对机未熟而出。乃名待时。已发后出乃名过时。啐啄同时是应机相。三一句示法无觉等者。此义须对报应简之。秖一大觉而有寂照及非寂照三种之能。故名三身。觉即照觉能照理故。即是报身。无觉即寂觉能现形故。即是应身。今云无觉无不觉者。即非照非寂觉。能双亡双用名究竟觉。即是法身。是故三身名为三佛。三种之了亦复如是。就身名觉就心名了。三义宛然。三若此下结身名密二。初简非。二非一下示密可见。二约正下约合对题二。初合三德。对题上文约正明于三身。观明三观脱明三脱。三三皆可对金光明。此明离也。今合三身为一法身。但对金字合于三观。为一般若。但对光字合于三脱。为一解脱。但对明字。诸经诸论以三德等。作修二性一说者。圆人解之。是合三义。此意至妙。学者应知。二三德下明五章皆密。三德是佛所证密藏。以被机故说金光明微密之教。散脂本因禀此密教而生密解。即闻密名也。住理乃是显于密体也。行行乃是修于密宗也。利他乃是起于密用也。不言教者。同佛故也。二复次下明互通。虽作三身三脱三观。三节解之而十五句。一一皆是金光明海体量高广。故使名义展转相释。如涅槃中百句解脱。以一一句皆是三德微密藏。故大师释句句具百成于万句。今举正解具十四句。能具成十五句。合云由正解故正观。由正解故得正分别。由正解故正解。于缘由正解故正能觉了。由正解故不思议智光。乃至由正解故。于一切法含受一切法。以正解一句为首既然。余句为首例亦如是。乃成一百七十五句以体量一贯故名义相成。疏于三五皆举头句。例于四句皆十五句。注云云令此销释也。二又作下用五性释所用。五种皆名佛者。是果德故皆称。性者不改义故。若将此五对今三节五句义者。能显散脂本证圆常。迹用周遍。护经德妙利人益深。此乃今家对释意也。文二。初大师对初五句二。初示五性异同二。初明三种不异。正谓中正。缘谓助缘。了谓觉了。此三名义诸师立同故云不异。二又一下明二性出没二。初二家立异二。初明异相。果性者。缘了所克智断果也。境果者。缘了所转境界。即阴等十种境也。果及果果者。果则别在智德。果果者。则在断德。智德之上又加断德。故重言果。此之二二皆称性者。悉以常住不改为义。境界不改者。修恶即性恶故也。二若作下明开合。没境界性为缘因所摄者。阴等十境乃是正观近方便法。亲发了因故可摄属缘因也。没果果性为果性所摄者。智断虽殊俱名果故。二虽开下五数不亏。二今以下约五句对性二。初对初家。五性安乐性即正因佛性者。安乐乃是涅槃之义。具足三法。今就合说但名正因。世出世等者。六道是世间因果。三乘是出世因果。言因佛性者。境界之性但齐九界十如。是法望佛是因。以其佛界十如是法望九称果。皆属能观不名境界。故起信论但以九相而为境界。是故业相名细中细为佛境界。又云。依转识故说名境界。而此证者无有境界可说。故知境界是九界法。若尔何名佛性。良以果人不独成就佛界十法。亦能成就九界十法。是故千法众生虽具体用不彰。唯佛究竟圆融自在。所以因法是果人性。二若作下对次家。五性境界既以合入缘因。遂取知法分齐之句。而为果性究尽实相。名智照分明。见无分齐之分齐也。如云智度大海佛穷其底。岂非无底而为底耶。乃以安住诸法如性。一切皆能舍受一切。同名果果性。此则果后任运永水双遮双照也。二若然下章安例两五句二。初例上合对。二师虽下准义须释。五性秖是开于三法。三番五句既其番番对于三法。亦合番番对于五性。后之二番大师不释。意云可见。章安恐后学不知。故略指云义例应尔。复令讲者伸释其意。故云准须释出等也。第二番中智光是了因性。智炬是境界性。知境不滥如炬照物。智行是缘因性。智聚是果性智境是正因性若依次师没境界性者。则智炬是果果性。断德对机不滥也。第三番中正解显体。是了因性。正观体显既当报身。合是果性。正能分别是境界性。正解于圆是缘因性。正能觉了是正因性。若依次师没境界性。则以正能分别为果果性。果后应机任运分明也。三世尊以是下结。三从世下发誓充益二。初分文示好。二依此消文二。初益能化经三。初世尊下益口业。二众味下益身业。三心进下益意业。二以是下益所化经三。初未种令种。二若有下已种令熟。三无量下已熟令脱。问既得智聚又摄福聚。斯乃真似二种庄严。合居方便及实报土。经那但云无量千劫人天受乐。答须知十益皆悉不离二十五有。此中乃是人天方便人天实报。故仁王般若云。出三界外更有众生界者。此是外道大有经说。须知四土若横若竖。秖在三界一处而论。学者宜审。四从南下归敬三宝。一切众经初皆归敬者。谓结集经者。皆有归敬。在通叙前。此方好略译人省之。亦有存者。如萨遮尼干子所说经初云。归命大智海毗卢遮那佛。注云。外国本一切经首皆有此句。诸论下即造论者。归敬也。如智度起信等。三宝者。佛法可知。功德大辩即菩萨理和僧也。南无此云归命。二正论善集明人王往日通经二。初正论品二。初解题二。初正释题二初直释二字。世圣者。谓轮王也。易曰。备物致用立功成器。以为天下利莫大乎圣人。管子曰。圣人若天然无私覆也。若地然无私载也。此皆言世间圣人。出世圣。谓三乘果人断惑证理名圣也。核者。说文云。考事之实也。核事实则世间正论可治国。核理实则出世正论可以诣道。二此品下委明四悉。谓世间正论而有四益。皆引孝经结成其义。文为四。初世界。先王旧法。即世间事实。世世不同。即世界意也。二王行下为人。百谷者。杨泉物理论云。梁者。黍稷之总名。稻者。粳糯之总名。菽者。众豆之总名。三谷各二十为六十。蔬果之实助谷各二十凡为百谷。社稷者。孝经纬曰。社土地之主也。土地阔不可尽敬故。封土为社以报功也。稷五谷之长也。谷众不可遍祭。故立稷神以祭之。礼记曰。厉山氏之子(厉或作列)柱及周弃为稷(厉山氏之有天下也。其子柱。能植百谷夏之衰也。周弃继之故祀为稷神)。共工氏之子后土为社(共工氏之霸九州也。其子曰。后土能平九州。故祀为社)民用和穆者。人民被服其教自相和睦。尊卑上下无相怨者。三对治。内奸谓乱臣贼子。孔安国曰。在内曰奸。在外曰宄。祸乱下祸者。谓善人逢殃。乱者谓臣下悖逆作起也。灾者天反时风雨不节也。害者地反时水旱伤稼也。四第一义。本金光明者。即四王品云。所作国事所造世论。皆因此经也。至德要道者。至谓穷理之极要。谓以一总众谓兹正论是先王旧法。为德之极道之要也。前之三悉属于世间。且就未辨。今此第四兼出世足。故双明本末之义。令其闻者解悟两种第一义故。钝者但得世间要道。此从末也。利者乃悟出世要道。此从本也。增益天德亦须两分。从末者益但生天若从本者益在义天。亦兼净天。以金光明属通教故。二此文下明来意。冥圣者。即诸天是冥圣也。故法华三昧云。一切冥空。二释文二。初分文。二随释二。初长行。经受灌顶位者。华严三十九云。转轮圣王所生太子。母是正后身相具足。其转轮王。令此太子坐白象宝妙金之座。张大网幔建大法幢。然香散华奏诸音乐。取四大海水置金瓶内。王执此瓶灌太子顶。是时即名受王职位。堕在灌顶刹利之数。即能具足行十善道。亦得名转轮圣王。二偈颂二。初分文。二随释四。初集众三如分科。二次四下发问二。初分文。二释义四如分文三结问开答。四梵天答二。初述意分文二。初述意。佛经释天子义。此文最显。若儒教则云王者。父天母地。为天子之故。援神契曰。天覆地载。谓之天子。二分文。二随文释义二。初略答四。初许答。二答。王义经故称人王者。谥法曰。德象天地称帝。仁义所生称王。白虎通曰。王者往也。天下所归往也。三答天下答问天义二。初指出三义。未入等是一义。分德是一义。力加是一义。二以护下明答。三问三。初以护胎答第二问。未入护者。犹在中阴。已入护者。处在胎藏。此之二时多为鬼害。故假天护。二以分德答第一问。三以力加答三四问。前第三问处王宫殿。何故名天。四问以人法治世。那得名天。故今答中虽处人宫天力加故。自在如天。答第三问也。遮恶劝善令人生天。答第四问也。四从半下。重答问王义二。初正明人王三义三。初明执乐名王。王执此乐者。谓持礼乐以化民也。孝经曰。导之以礼乐。而民和睦。乐记曰。大乐必易大礼必简。乐至则无怨礼至则不争。揖让而治天下者。礼乐之谓也。使天下去明乐之化成也。京房易候云。太平之时十日一雨。凡岁三十六雨。此休征时若之应。风土记曰。击壤者以木作之。前广后锐长尺三四寸。其形如履。腊节僮少以为戏也。逸士传。帝尧之时。有老人击壤于路曰。吾日出而作日入而息。凿井而饮耕田而食。帝何力于我哉。岂非至圣之德。为而不宰玄功赞运。是以百姓日用不知。竹马儿童所戏也。人王执乐治国故。得天下和平老幼俱乐其性也。二明遮恶名王。即经云。罗刹魁脍等以能遮暴恶故。亦名罗刹魁脍也以亦名二字贯下。如罗刹中魁卒。故众鬼不敢为非也。三明父母名王。即是王为民之父母也。诲示祸福等者。谓违仁义者致刑罚。是祸恶也。录仁义而授爵禄。是福善也。制礼以检其迹。作乐以和其心。故乐记曰。乐者为同礼者为异。同则相亲异则相敬。民知禁者民知有禁令也。二能为下兼显天子三义。因中说果者。以礼乐化民必生天上。故二从若下广答二。初分文。释义二。初广明非法失于六义。二广明正治得于六义。此六经文前后相参故。并前段皆不细分。讲者当以六义得失对文销之。其理自会。二此中下示观明本二。初令思观义自思之者。禀斯宗人合知三种修观之法。故疏不示令其自思。今恐后学未能别之。不免略说。此于三种是托事观。谓托世天明于谛境。托于人王明于妙观。即此一念性是义天。依止此天能令此观不起边倒。名天护义中观也。观合义天同天之德。不分而分名天分德。空观也。义天神力加妙观故。能历诸境皆得圆融。假观也。又托人王修理观者。全谛起观中观。双照即父母义空观。伏惑即魁脍义假观。立法即执乐义。此谛此观皆离纵横。秖于一心具兹六义。二设问明本二。初设问。上四王品云。阎浮提内诸国王等所作国事。所造世论皆因此经。岂非正论以金光明而为其本。欲令答示即末之本。故兴此问。二天者下答示二。初正示方等所说。岂有一事不本于理。如向散脂翻为密者。常所称呼。岂知召于秘妙三法。今于此典自叙密名十五句义。斯乃委彰世名之本。此之正论是梵王说梵王之本。诸经开为法身菩萨。法身菩萨随所住处。是常寂光。以身例口。随有所说无非秘藏。今之正论既金光明而为其本。岂可末事暂乖本理。水波金器本末同时。以金光明具世间法故。即世名而可示本。自此为二。初明末即于本二。初就天子三义示本。应先了知。此金光明是法非譬。以法报应是金光明异名故也。天者第一义天也。子者无上众生本来人也。揽金光明妙三实法为此假人。此人依止第一义天。本离八倒是天护义。此人智光冥法身。金德与法同为分德义。此人应益名之为明。义天之力之所加也。二又父下约人王三义示本。此妙假人体是金故双具权实。能与一切而作父母体。是光故照惑本空即遮恶义。体是明故能生众善。既执乐义。二以此下明末从本立。如上所示本之六义。因果六位皆即此义。此义能作世出世间一切事本。今即此本而谈正论。其圆教机闻治国事即达其本。乃能顿治四种之国。二如半下例结。经于一人而立人天两种之称。意显此论通世出世也。释善集品二。初解题二。初正解题二。初释善集得名二。初据名广集。六善海导师。谓海中船师。善法虽多不出此六。二附文别集檀智二。初明摄六檀。能摄六智能导五成就二严。故举兹两。二提如下示经文二。初正示经。经举此二其相深广。宝满四洲尽奉三宝。兴隆事广合掌而立听。金光明证悟理深。二檀智下例余行。此王心大集善不轻檀智深广。在文既然。验余所修皆非聊尔。二此六下用悉檀立品。总举六度。名数不同是世界。五度望智且在事善。属为人。智照五度破取相恶。属对治达六法界绝乎思议皆到彼岸。名第一义。此王具集四悉檀善。故以其名立今品目。二此品下明来意。治国之论是世正见。听金光明是出世间上上正见。夜睡梦中闻佛功德。是感动圣及见比丘名曰宝。冥是感动贤。纵入分真望佛名贤。二释文二。初分文释义二。初分文。二释义二。初对告地神二。佛以偈说二。初通明因地行檀。二别明善集二施。谓四天下宝施财也。请说此经。令无量众闻金光明施法也。此别为六。当如分文以义解释。经治政之势者。谓化之势分极于海际厕杂也。填塞也。缯帛之总名也。曼陀罗此云适意。曼殊沙此云柔软。旧小大白小大赤。不鼓鼓击也。熙怡悦乐也。瑰美石次玉琦王名耳。珰释名云。穿耳施珠曰珰。应作珥珰。珥如志切。苍颉云。珠在耳也。二就此下指归三法。言就此品论金光明者。就其所说论三法门。疏文秖云论金光明。验直就法立此三名。实不从譬。以前后文悉皆如是。讲者学者知之知之。然以诸句对三字者。以此三是深广法性当体之名。法性可尊可贵名金。法性寂而常照名光。法性能多利益名明。与诸三法无二无别。若指品内事理依正。即此三者乃令行人达乎所诠。不纵不横绝思绝议。此典方得名为经王。是知对三深有所以。此自为三。初就善集论翻波罗蜜。名到彼岸。是所归处故名金。般若翻智故名光。五度是行故名明。此就智行及果为三对金光明。二就宝冥论。窟是所依名金。满月能照名光。读诵是行名明。此约依正对于三法。三就二人论宝冥。依正与王雨宝对于三法。行者应知。秖一法性名金光明。岂可光明暂离于金。岂可金光暂离于明。今以三名分对依正自他人物。为令了依不离于正。自不离他人不离物。以金光明举一即三全三是一。不纵不横而高而广。物物皆是金光明海。心心皆是三德秘藏。若不尔者。何名经王耶。第三鬼神品二。初释题二。初正解题二。初正释鬼神二。初释。鬼归者。尸子曰。人死曰归。云云者。观佛三昧经云。修罗与天帝战时。空中刀轮而下。修罗军众身支堕落。即便怖畏窜隐藕丝。若依俗释者。郑玄云。圣人之精气谓之神。贤智之精气谓之鬼。礼记曰。明则有礼乐。幽则有鬼神。二释神。二此品下对上题品。二此品下明来意。二释文二。初分文。二释义二。初长行二。初正释义二。初列二释二。初举事。别佛从等者。果后慈悲熏法现像说法化人。此乃应身。被机之佛从本觉如。起始觉智合本真如。名报身佛。是始觉也。一切诸法元是诸佛所行之处。即法身佛。是本觉也。三佛历别者。修二性一能起所起能显所显。条然异故。事供别者。四事供养资持应佛。万行功德资成报佛。称理之智显发法佛。资成显发皆供养义。三佛既异三供亦别。二圆供养前有理智。以历别故贬之为事。今听经事以融即故褒之为法。第一供养者。不思议供也。能听所听体不二故。秖于文字了具三身。能说是应解脱德也。能诠是报般若德也。所诠是法身德也。不解新伊但论能所。岂显圆佛及圆供耶。文字若非秘密之藏。那生诸佛恭敬之心。非秘妙者。安能圆供三世佛耶。注云云者。令如向释也。二又别下叙重闻二。初标示。谓四愿一劝也。二若欲下释出二。初出四种愿。欲问经示行人。欲以妙具供三世佛。及知他佛甚深行处。大师何故。即以知字而为报佛。所知是法二必垂形。是则三身皆属行者。因既滥果供养义乖。此解违经。如何取信。答前拣事别正却此情。经云。欲知岂非行者甚深行处。既是法身能知之心。宁非报佛文字之应现亦唯心。若生佛条然能所永异。斯出小教何预圆宗。今就圆宗解四愿欲。若迷三世诸佛三身同在刹那。法界六尘顿彰。妙解是可思议正当违经。二听经下明一事满四。三世诸佛觉智为命。而与众生同一心性。乏熏修故即不受供养。诸佛寿命不灭而灭。以隐为灭也。今以听经为供养故。即是受供诸佛寿命。不生而生以显为生也。行人应了。生佛无差听经智生。即诸佛现。以诸如来同一智故。观行相似分真之佛。与究竟佛无二无别。又了智生即三佛生。即一而三不纵不横。此乃欲供欲知三世诸佛。秖听经一事四愿俱满。三偈颂二。初分文。二蛊道下随释科节。并如分文。所列经若入是经者。一言于经即有三种。谓教行理。能了此三是妙三法。名入是经。若不然者。安得入经。即入法性。所入法性无量甚深。三义具足名金光明。称此安住名之为如。即见释迦三身妙体。须论观行相似分真入经见佛。经若百由旬满中盛火应从中过者。为法亡躯也。经文殊师利云妙德。弥勒云慈氏。经勇捍。说文云。多力也。五举能致天龙以劝修二。初翻现文疏。从摩醯去也。阎摩罗王或阎摩罗社。此云双王。阎摩双也。罗社王也。兄及妹皆作地狱主。兄治男事妹治女事。故曰双王。又苦乐并受亦名为双。那罗延此云钩锁力士。难陀此云喜。跋难陀此云贤喜。兄弟二龙风雨应时。能令人喜。贤谓性又贤善故。毗摩质多此云净心。正法念经翻为响高。亦云穴居。正云吠摩质咀利。此云绮画。又云宝饰。帝释妇公舍支之父。佉罗骞陀此云广脾。二脱因却解初段脱因等者。初段文云。能令一切众生解脱。度无量苦诸有大海。既云一切众生解脱度诸有海。须于界内及以界外各脱三障。故以因果对于业报。诸有由惑故当烦恼。经优钵罗华下四句四色。莲华优钵罗是青。波头摩是赤。拘物头是黄。芬陀利是白

金光明经文句记卷第五(下)金光明经文句记卷第六(上)

        宋四明沙门知礼述

释授记品二。初解题二。初正解五初明。今是二种四种记者。首楞严三昧经。佛告坚意。记有四种。一者未发心记。或有流转六道生于人间。好乐佛法过百千万亿劫当发心。过百千万亿阿僧祇劫行菩萨道。乃至供养佛化众生。皆经若干劫当得菩提。二适发心与记者。是人久劫种诸善根。好乐大法有慈悲心。发心即住不退地故。故发心与记三密记者。有菩萨未得记而行六度功德满足。天龙八部皆作是念。此菩萨几时当得菩提劫国弟子众数。如何佛断此疑即与授记。举众皆知。此菩萨独不知。四无生忍记者。于大众中显露与记也。今是二种者。即适发心记及无生记也。二授者下约训释二字。三此中下明所记之人。四亦名下释记异名。五从佛下明授非受。二此是下来意。昔行经者。金龙尊王赞佛发愿而为行。经十千枯鱼闻法熏修而为行。经以为因方犹将也。今得记莂将来作佛证验。今日若亲弘经。若为外护不久得记成佛下虚。二释文二。初分文。二释义二。初与记二。初与三大士记二。初同缘者。集过去同缘此经不说。或见彼经二正与记。世界转名净幢者。应论四句者。一名转土不转转名净幢是也。二土转名不转。如往古释迦取土名娑婆。今释迦亦名娑婆。三名土俱转。如观音补弥陀处。四名土俱不转。如今银光补金幢光照佛处。世界名字如本不异。此中是一者。恐误合云二也。二与十千天子记二。初分科。二释义二。初闻经生解。或相似解或分真解。经无定判故须从容。经心无垢累等如下释疑疏中明。二正与记。既云于是世界而无别名。即是还名娑婆。此乃土转名不转。一句注云云者。令如向释也。二疑记二。初分文。二释义二。初疑问三。初行浅记深。二如余下约权疑实。引锥指地者。谓无有容锥之地。不是舍身命之处也。从假入空非止一世者。菩萨性地经于三祇修六度故。直行等者。历别渐次其相如是。三为众发问。大权解顿自必无疑为他故问。二佛答二。初分文。二释义二。初举现行四。初明三事和合。二证听经功德。顺前三教上求下化。亦得名为修法供养。但以偏渐故经多劫。一听此经顿达妙性。一摄一切名真法供。既生圆觉。即三世佛皆受供养。能知诸佛甚深行处。三身顿显。今万天子来此听经。若不能满四种愿欲。安得受于成佛记莂。验知前品所说不虚。三闻记下明称经悟人。无有成佛。不具三身。三身之果由于今日。闻金光明以为妙因。从法性明生殷重心。应身因也。从法性光起无垢心。报身因也。从法性金起虚空心。法身因也。此金光明与其三德无二无别。三德为本无量功德之所庄严。或似或真显此三德。是故如来授与果记。听经之益其相如是。四以随下指今昔因缘。经皆因缘者一闻得记岂无因缘。此乃总标有妙善根。别标远因缘。以随相修别标现因缘。言因缘者。感应也。或内心外教而为因缘。何以故下释出现因缘行。随实相而修者。以十乘观而为行也。不思议境名实相也。即境为观此观顺境。名随相修。非今宗意。此句莫销。然此十观修有三根。上根一观。中根二至七。下根具用十。今万天子一坐闻经。或但用一或在二三。是信行根。依言而修入似真位。有妙善根。下释出远因缘。善既云妙。乃昔闻圆而为根种。故云缘实相而种善根也。二从亦下举远缘。经誓愿因缘者。流水品云。未来之世当施法食也。乃以此文对下二品而为略广五释。除病流水二。初释除病品二。初解题二。初来意即广答远缘四字是也。意通流水文在此中。二由医下释题方等。经王标除病目不止除于果报病苦。义合该收恶业烦恼十种之病。故下文云。治诸众生所有病苦。悉令除差。文意含摄十种行人。故上正论品疏云。半名世论半名出世论。今岂不尔。又荆溪云。上根即于境种而生于果。故文云。直闻是言病即除愈。为中下根更须后法。是故文云。至长者所为合众药。故知不独除果报病。二释文二。初通后品分文。二就二品释义五。初缘本。二从像下远缘二。初分文。二释义六。初明父。二善女下生子。经受性聪敏。敏达也。孝经云。参不敏何足以知之。三是时下国人遇病。四善女下其子请。三初见人遇病。二作是下思惟。经衰迈。说文衰减也。损也。广雅迈归往也。谓壮力已往也。礼记八十曰髦。注云髦惛忘亦乱也。颤四支动也。掉振也。机杖者。坐则凭机行则执杖。三即至下正问四。初问四大增损。二问饮食犯触。三问治病医方。四问病动时节。五父为说二。初分文。释经二。初分文。二随释四。初答四大增损二。初佛叙父医欲答。二正答时节五。初释时节二。初依俗法。谓孟仲季者。孟始也。仲中也。季末也。二依佛法一岁三时以四月为一时也。何故没秋时耶。为破下凡有二。一为破常计。二为开迦提。以秋是收成物皆结实。易起保着故不言秋。为开安居者。为后安居人续结。令成为前安居人。开迦提月也。律中有三种安居。谓前中后也。四月十六日是前安居。十七以去至五月十五日。名中安居。五月十六是后安居。若四月十六日结者。至七月十五日夜分尽名夏竟。至明相出十六日后。至八月十五日以来。名迦提月。明了论云。本言迦絺罗为存略故。但云迦提。此翻功德衣。以前安居人坐夏有功。五利赏德。律中受此衣故。一畜长财。二离衣宿。三背请。四别众食。五食前后至他家。西域记以迦提翻昴星以昴星直此月故。于昴星月中得受功德衣故。是知若不没秋中后安居。不名坐夏。以后安居人至八月十五方解故。二释若二二说三。初依俗法土寄四季者。三六九十二月也。各十八日者。四季共七十二日也。秖是阴阳二月者。皆以奇数为阳偶数为阴也。阳土阴土者。从冬至一阳生为阳遁故。十二月三月是阳土。从夏至一阴生为阴遁故。六月九月是阴土。若论下二阳土二阴土亦是二二故。加本月足满六时。二依佛法皆起于十六日者。彼以十六日为朔也。三又云下复依俗法。皆以奇偶之数分阴阳也。三释三三本摄二。初正释二。初依俗法二。初以孟为本。二又云下约五行说。二依佛法三时三月以为其本。各摄一月故云三三本摄。二释妨既三为一数。是故俗法及以佛法。皆约三论。但以俗法本之与摄。秖在三中故名三三本摄。若佛法者。即以三三为能摄本。乃以三一为所摄月。亦得名为三三本摄。四释随时消息二。初依俗法。二依佛法。夏之后分冬之初分。随俗名秋。随此两间消息斟酌。五释代谢增损二。初通内外释。春动肝病等者。肝藏属木。木春王则可治。脾属土。木克土故脾难治。心藏属火。火夏王则可治。肺属金。火克金故肺难治。肺属金。金秋王则可治。金克于木故肝难治。肾属水。水冬王则可治。水克于火故心难治。二约佛法料简二。初问。二答意者。佛所制法非为养身。但为修心及以禁足分二。初约破常。答凡夫四倒常乐我净颠倒之计。托缘而成故废秋时。令诸弟子不保常乐。二约坐夏答既开后安居免于坐秋。则前安居人得立迦提月废秋之意。为此二缘。二从有下答犯触二。初正明犯触。其中先论六事犯触。多行倚者。倚立也。次若火下四大动病火少。痰多者火减故水增也。饮食下通明六种犯触。过量等者。封君达云。体欲常劳食欲常少。劳勿过极少勿至虚。常去肥浓节碱酸。减思虑损喜怒。除驰逐慎房室。苦菜别示妨食。二略明六大。白虎通曰。府者。何谓也。谓大肠小肠胃膀胱三焦胆也。府者。为藏宫府也。胃者。脾之府也。膀胱者。肺之府也。三焦者。肾之府也。胆者。肝之府也。大肠小肠心之府也。疏中两膀胱唯一藏。黄帝脉经云。上焦自头已下至心。中焦自心已下至脐。下焦自脐已下至足。广雅云。膀胱脬也脬字匹交切。腹中水府。三苍云。盛尿处曰脬。三从多下答病起。时节生与起时相不同者。微发为生动用为起。微着不同也。夏日等者。四病四时生起所以也。四从有下答治病方法二。初分文。二风病下随释三。初未病药防。二饱食下正以药治也。但举病发者。以病显药。当用对病妙药治也。三风疏下病退药补。二此中下示销文所出。良以真谛善闲世术兼有神通故销此文全凭彼疏。六善女下知已遍治二。初分文。事释二。初分文。二释义二。初病轻闻说即差。二经善女下病重服药方除。此品事医意含法药。除病不一非可卒陈。次示观心略申其意。其文在即故注云云。二观释者。此品所诠是佛自叙宿命所作净佛国因。文中虽说除果报病。意乃通结四教机缘。是故大师事解之后。示观心法。明彼流水结缘之意。如观音疏释。于七难帖文。但在事中。火等至观行释方明三障四教。今岂不然。问既结四教生土之机。何故但约停心方便。而论观心。答语似三藏停心之法。意则不然。何者。以四分名通界内外数息等四。四教行人无不修证。今之观解约此而论。弥显除病结缘之意分三。初明观之药病。三毒者。谓贪嗔痴偏起也。言等分者。谓三毒等起也。然贪嗔痴性本相反终非三心。一时并作。但是不定杂杂而生。故云等分。一分乃有二万一千四分。共成八万四千尘劳之门。此则十界众生心病对前果报身病。是外故。今四分名为内病。数息等四对前甜辛种种之药皆是事治故。今四观名为法药。二宜闻下示行之根性。自有众生闻说四观四病得差。属信行人。自有研心修此四观四病方差。名法行人。信行则是学读之人。法行则是坐禅人也。今明二人皆通四教三眼。是下明对病用药二。初明四分起相。二明四观治相。初四。初约五根对时。此就五行对于五藏。藏主五根根属四时。眼耳鼻舌偏属一时。身通四时。如常所说。二妙好下明五欲致病。以其五欲粗妙偏总对根不同。致令四分增损有异。须知五欲遍界内外。故使四分通别天殊。迦叶断通故称少欲。未断别故闻琴起舞。请观音云。断除三毒根成佛道无疑。既论三毒宁无等分。此四亦由实报五欲粗妙偏总对根而起也。三明三受犯触。违情苦受。顺情乐受。不违不顺平平受。此三偏起也。总三起等分名觉观。缘虑纷纭也。四慢时下明四分病因。五欲三受既从外境。盖是四分助发之缘。今举慢等内心恶习。乃是四分亲发之因。慢心发嗔乃至放逸发于觉观。并前犯触通界内外。例五欲说。二慈心下明四观治相。前说外缘及以内因起四分心。皆所观境即是病相。今明四观。正明能观四种法药。慈心治嗔者。嗔既通于界内界外。能治慈观不独观于众生作父母想与世间乐。观一切法无性无相。能与众生涅槃之乐。观一切法无非法界。能与众生究竟之乐。以此治于三种嗔心。是故释论明三种慈也。不净治贪者。不独修于实想假想。破于凡夫依正之染。亦能破于二乘涅槃之染。亦破菩萨执于次第三谛之染。故起信论云。始觉能破六种之染。因缘治痴者。不独观于三世无常因果。破于凡夫断常之痴。亦能次第观于三谛十二因缘。破于二乘有无之痴。又能一心观于四种十二因缘。破于菩萨纵横之痴。是故大经观十二因缘具四种智也。数息治觉观者。不独数息观于生灭。而破凡夫有者散乱。亦能数息修俗谛三昧。深入缘起破于二乘偏空乱意。又体数息息息皆中诸法趣息。破于菩萨二边乱意。故请观音于数息法得三乘道。住首楞严身。如琉璃毛孔见佛。然此四治或可四人各修一法。以其四法各含三观人人自可依次不次而治三惑。或可四治秖对三观。慈心即假观。不净即空观。因缘即双照中观。数息双遮中观。此三自可约次不次次。复不定或可三人各一。或一人前后。若不次者。唯是一人一念而进。观音疏中尚以三毒直对三观而论次第及不次第。况慈等四非三观耶。若其圆人四分偏总而发起者。即于一心融妙三观。对病用之。即止观中胜别意也。二流水品二。初解题二。初兼除病释名二。初释流水二。初引文标二名。二接经释二义二。初释二义二。初别释二义二。初释与水。二释流水。初则大慈与乐次则大悲拔苦。初又二。初列二水二释二水。今此一类世乐且在果报之益。出世唯明一实之益。若论此时结净国缘。合遍人天及以四教。二释流水二。初列二水。流除者。流去其水即是除义。二流除下释二水。言业因者。于果报外九益皆能除于业因。今十号等乃以能除显于所除。十二因缘经称甚深验。三归十号皆是圆说谶。本虽无三归之文。最胜经有真谛所译。必亦有之授法之仪阙之不可。二请父下双成二义。二既有下单示题二。初问。二文中下答。经文与题二名互显。巧不过此也。二释长者子。法华疏中具十种德。名长者。一姓贵。二位高。三大富。四威猛。五智深。六年耆。七行净。八礼备。九上叹。十下归。子者下亦如王子公子也。故经云。持水大长者家中后生一子。名曰流水。二此文下取授记出意。二释文三。初明第三结缘近由二。初分文。二释义二。初弄引二。初行恩布德。二国人称美。二善女下正近由三。初明眷属。二时长者子将下见鱼之缘。即禽兽驰奔也。三时长者子遂下正救鱼。私开为二。初明因缘二。初因流水兴悲。二时有下缘树神示数。二善女下与水食二。初与水四。初取树枝覆日恃依也。二作阴凉已下知水源决绝捕捉也。决弃其水。决音穴。广雅云穿也。说文云。下流也。周易藩决不羸亦音穴也。三时长下就大王借象。厩马舍也。释名云。厩聚也。马之所聚也。二时长下施食二。初察鱼饥恼。彷徉上扶方切。下以章切。广雅徙倚也。又徘徊也。二善女天下取食施与。二从未下明第四结缘二。初分文。二释义四。初发誓愿。二复更下思惟说法。三作如下正说法。先称十号次说因缘。十号在悟在果因缘。在迷在因。迷悟因果其名虽殊而体不异。以十号果是究尽三德。十二因缘是本来三德。三德不改因果宁殊。故普贤观云。大乘因者诸法实相。大乘果者亦诸法实相。诸法是修二实相是一性。此三圆融不纵不横。全体为因全体为果。众生虽迷十号无减。诸佛悟极十二不亏。以世间相皆常住。故今先唱果果理已显。令其解生。初称宝胜者乃是别名。名于一佛如来等十乃是通名。三世十方佛佛皆具。若以通从别合得名为宝胜如来宝胜佛宝胜世尊。此三既然。例此合云宝胜应供宝胜正遍知乃至宝胜天人师也。此十通号大经大论出其名。天台慈恩出其义。相状已显。今傍诸释更约三。三及一总结以销十号。令知一一无非秘藏。此义若明则不辱于果人名字。初三既以如来为首。即法身中三也。如来是真如属法身。应供利生是解脱。正遍知具一智是般若。以其法身必具二德故也。次三既以明行足为首。即解脱中三也。三明之行是解脱。善逝能趣极是般若。解三世间一一常住是法身。以其解脱必具二德故也。后三既以无上士调御丈夫为首。即般若中三也。见性名丈夫故当般若。天人师轨训众机是解脱。佛是复本大觉是法身。以其般若必具二德故也。此九即三此三即一。一无一相三九宛然三千世间九世刹那。一多延促究竟自在。故言世尊。十二因缘束为三道。无明爱取三支属烦恼道。行有二支属业道。识名色六入触受及生老死属苦道。此虽昏迷系缚轮转。而全体即是三因佛性。皆不可思议。随人观察显发不同。故大经说下。中上智观。此乃得三乘菩提。若上上智观得佛菩提。以前三教智有思议。故观十二止得三乘。唯有圆教不思议智体无明等。即是性染非佛天人修罗所造。一一常住当处圆融。方曰因中具于果性。又玄文中三道三识虽本有位。与果后三德无二无别。得此意已方可分别十二别名。无明谓不了六受即空假中。行谓依不了心动作业行。识谓业牵中阴识托母胎。名色谓二滴为色心但有名。六入谓名色增长成六入根。触谓六根对外为尘所触。受谓触生三受苦乐平平。爱谓迷三受故于乐染着。取谓爱染缠绵四方求索。有谓由取造业须有来报。生谓有业既熟未来阴兴。老死等谓生须变灭悲恼萦缠。此十二支或约三世。或约二世。或约一念。虽三不同。皆以十二而对三道。即事而理。一一究竟清净自在。不纵不横而高而广。如是观者得佛菩提。略三归者。义已具也。盖三宝三德体本不异。既称南无宝胜。十号岂非归命果上三德。复说甚深十二因缘。乃是心依因中三德。迷悟极际三德无差。一体义备。三皆具足。常乐我净真是归依三宝义究竟成。当知谶师意趣深妙。四鱼生天报恩四。初鱼报生天。凡初生天以自业力有三种念。一自知从其处死。二自知今此处生。三自知先作何业得来生天。既知曩事故下酬恩。二天酬恩下地经楼屋者。重屋曰楼。或作楼台者误也。释此为二。初事因缘十号。且就能诠属言教故。同于水食。名为事也。二理秖于四事而解四德。故成理益。以十千鱼由戒缓故。受鳞介身。由乘急故。今遇大乘真善知识。故能于事深解妙理。受食得命即表真常。受水得乐表涅槃乐。于十二棘林解自在我。依十号法获天报财。于世净命解性净德。此四法益因流水得故。持四万真珠璎珞报恩供养食等四事。既表理益。四万珠璎岂但事供。盖表千界万如。是法一一皆具常乐我净。即四十千真珠璎珞非严而严。严于法身。此乃财供而成法供若不尔者。岂得名为有妙善根得记缘耶。三时阎下王见光瑞。四长者据教定答。三明第五结会古今。经罗睺罗此云覆障。以六年在胎因立斯号。新云罗怙罗。此云障月。然本迹事不可审知。傍文思之。十千今昔必是所化余皆能化。此之能化据华严等诸经所说。皆是劫海修其实因。熟其十千令今得脱。若取法华久成之意。皆是迹中接此等机令今得记。此宗讲者内心合知。六释舍身品二。初释题二。初问舍多题少。二此从下答从要立题。受者须身。虎饥所逼正须身肉。寿命财位非彼所求。夫行门无量。根由宿熏。四种三昧逐人所尚。于随自意善行六度。乐行檀者。于身命财无所吝惜。自行教他随喜赞叹。皆在于施。若于善师及依实教。修檀行者体能施心及受施境。所施身等即空假中。事行理观合一而修助道。正修相资而进。既称本习故忻然而为。或因事卒行宿缘会故。或积年要誓令观成故。或显陈所愿令物效故。或密遂其心息他谤故。悲重故。密慈重故。显心若真实四悉俱成。心若诈欺二利皆失。然佛谈本事令人效行。故疏云。引昔捐躯诫今师弟。勿吝法财。问大论云。舍身易舍心难。论欲行者舍执着心故以难叹。欲息事施故以易斥。何不依论远离执心。今人为何好舍身命。答抑扬取舍皆遵佛教。悉赴人心。佛谈正助不同。人乐理事不等。今品特示舍于身命。安得以论难易为讥。又复空说舍心而执己见。胶固自体一毛不拔。毁他舍命为非。既乖随喜之心。宁逃嫉善之咎。愿闻佛说随力奉行。二释文二。初分文。二释义四。初问。小人即国病者。小虫一万枯鱼。鱼关未来法食之誓。获成佛记例。病差者定于后世为解脱机。是故皆蒙二世之益。感深契极者以不二解导难行行。此感至深。舍身命财与后际等。此契唯极。众闻获益正当此时。是故树神乘机发问。二答二。初分科。二释义十段悉如科列。二就本下正明舍身二。初分文。二释义二。初长行四。初明本眷属二。初分科。二释义五段如分科列。二从作下舍身方便二。初分科。二释义二。初述观解。二起誓愿愿行相扶者。行即观解。非此观解莫成其愿。非乎誓愿行则有退。疏适产七日至树神数鱼等者。此文追解前第四见产虎文也。疏可见。经从作是念言下述观解。观有二种。一助观。二正观。从初至甚可患厌是助道观也。以三藏教假想。对治恋着依正之心。从是故我今下正观也。至无诸尘累等。即空观也。无量禅定至诸佛所赞。即假观也。从证成如是至法乐。即中观也。说乃前后修必一心。二从是王子下述誓愿。先作方便。次作誓言下正起誓。六句不出四弘。初二依灭谛发成佛愿。三四依道谛发悲智愿。第五依苦谛发度生愿。第六依集谛发断惑愿。此依界外灭谛为首。验发圆心也。三正舍身二。初科。二释。经六种震动者。谓动起涌三种是形。震吼击三种是声。今于形声略言其二。故言震动。四舍身后悲恋二。初科。二释如文。二偈颂二。初分文。二释义三。初通明昔行。二我念下别颂长行二。初分文。二释义五。初颂上本眷属。二颂上舍身方便。三颂上正舍身。四颂上眷属愁苦。五颂上父母愁苦私开二。初经。是时王子当舍下颂见相时愁忧二。初王妃忧恼二。初见相。二于是下述相六。初正述恶相。二是时下述已迷闷。三王闻下王臣忧恼。四尔时下国人惊愕。五尔时下王妃叙德。六我所下验相失子。二尔时下大王求觅二。初慰谕其妃。二大王下求觅其子。二先所下颂知终后悲苦三。初使者回白二。初前使慰王二。须臾下后使告实。二是时下大王闷绝。三复有下王迎二子三。初臣述失志。二是时下王并思惟。一亡二存对并思忖。亡者叵寻存者宜取。三尔时下迎子慰母。三从佛下结会二。初科。二释三。初结会人。经输头檀或阅头檀。此云净饭。摩耶此云天后。调达亦提婆达多。此云天授。父母从天乞子。天授与之。是佛堂弟。瞿夷此云明女。悉达有三夫人。一瞿夷。二耶输。三鹿野。各有二万婇女。五比丘者。憍陈如。頞鞞跋提。十力迦叶。拘利太子。陈如十力迦叶。二是母亲。余三是父亲。舍利弗此云身子。母好身形故母名身。是彼之子故名身子。目犍连此云胡豆姓也。上古有仙居山。常采菉豆而食因以命族。尊者是彼之后也。二经尔时下结会塔。具云塔婆。义翻方坟。或云聚相。谓累木石。及宝高以为相。茶毗后分云。佛塔高十三层上有相轮。支佛塔十一层。罗汉四层。轮王塔无复层级。以未脱三界故。十二因缘经八种塔并有露盘。佛塔八重。菩萨七重。支佛六重。四果五重。三果四。二果三。初果二。轮王一。凡僧但蕉叶火珠而已。虽两经异说。而凡僧并无层级。迩世所立虽无露盘。既出四檐犹滥初果。傥循蕉叶火珠之制。则免僣上圣识者宜效之。舍利此云身骨。三经是时下结会誓愿。三说是下大众所益。四树神下结问意。经怖懅其据切。广雅云。畏惧也。瘭必遥切。疽疾也。奄忽。忽谓倏忽也。鶵士虞切。鸟子也膶如轮切。目动也。抆武粉切。拭也。躃旁益切。倒也。恸哀过也。惙陟劣切。疲也。七赞佛品初解题。二初明赞之能所二。初大师约因人赞果释。能赞是三番菩萨者。一是经初陈列之众。二是信相发起之人。三是树神善女。此虽众兼道俗。形混人天。既发大心咸名菩萨。所赞是一佛世尊者。即释迦教主一佛也。斯欲异前赞品能赞是往世金龙一人。所赞是三世极果诸佛也。然准前释题品目。具含四悉。今文略示。欲明其相者应云。题标赞佛义含能所。即世界欢喜也。二能赞善生必托缘起。缘中最胜莫过赞佛。故三菩萨能赞。即为人生善也。三所赞为能赞。乃印成三菩萨说无虚谬。即破恶对治也。四如来赞树神快说果地大体大智大用。即入理第一义也题含四义文理一如。今疏存略不无其以。盖题赞佛实通能所以。所赞果佛反赞因人。生善破恶二俱不便。然或以所赞为能赞。生他善业破他事恶。斯何不可故知略也。二私谓下章安约因果互赞释。言一佛是能赞者。经云。善哉善哉。树神善女。汝于今日快说是言。经虽独赞树神意兼前二。故云三番是所赞。言三番是当佛等者。释疑也。恐人疑云。既赞兼能所。何以独题赞佛。故释云。佛通现未皆是赞佛尔

金光明经文句记卷第六(上)金光明经文句记卷第六(下)

        宋四明沙门知礼述

二次第下明品之次第二。初明诸品所归亦是今品之来意也。何者下释诸品次第。序品叙大体等者。向疏释经叙乎五章。今唯叙体者。盖指极果所游所契。而高而广。法性是佛地之所证。为今经之大体也。下寿量洎诸品功德皆不出大智大用。言穷源等者。妙觉中理之源已穷。边际之事亦极。故种智泯照万行休息。是唯一性更无异途。故曰经之大体也。寿量果地二智已圆。故冥深广之体起长短之用。忏赞空导岂越大用。诸品功德无违应体。故下云皆金光明之力也。如是下二示今文赞意。明由上一十七品之利益。故有下六十二行之叹辞也。善始令终者。序等三分既皆获利。故三菩萨荷佛深恩而兴赞叹。故有赞佛品也。令亦善也。三释文二。初标科。二释义二。初经家叙。疏文可见。经云。从此至金宝盖国者。欲张大其众满中菩萨。皆赞释迦教主也。比见有人不晓斯旨。谓赞彼佛。经疏非闇。一何昧哉。或恐后学随他所解。谬释经文。今略引疏示之。原乎赞品之来者。盖三番菩萨。并由上闻经得利故。赞佛及教。岂关他佛。况疏云。一佛是能赞。若谓赞彼佛者。能赞一佛何指释迦定起耶。经疏冷然故不繁引。二正说偈二。初分文别释二。初分文即智者就题分偈。故合六十五行半文为三。即以如来定起三行经文。合在树神段中。故云二十八行半树神说。分文可见。疏不委释。故注云云。应云六十五行半文为二。初六十二行半三番菩萨说。二后三行如来定起说。故下章安总释。乃云其文有四。即斯义也。具如下释二释义三。然此三番菩萨赞辞疏不分释。达者必辞意俱明。恐新学者不晓。今粗科释。初诸菩萨赞三。初寄言赞三。初赞能说教主自行功德三。初赞大小相海二。初如来下一行赞金色光一大相。经云如来之身者。标起也。金色微妙等三句者。赞第十四金色光微妙一大相也。二身净下二行半赞身清洁等三小相。经云身净者。即赞第十一身清洁一小相也。柔软者。赞第十二身柔软小相也。圆足无垢二句赞第二十身满足小相。亦是赞容仪满足。三其音下二行重赞梵音。一大相也。亦是兼赞言音深远小相海也。梵声者。譬佛音深远故。师子吼声者。譬佛音无畏也。大雷震声者。譬佛音破迷也。云六种声者。诸文皆云八音。一极好。二柔软。三和适。四尊慧。五不女。六不误。七深远。八不竭。译人增减不须和会。亦可先举妙如梵声者。即八音中深远音也。师子吼大雷震即举不女音也。以佛住首楞严定常有世雄之德。久离雌耎之心。故所出音声能令一切闻者敬畏。天魔外道莫不归伏也。上既已列二种声。下但云六种声者。即举迦陵频伽孔雀等六种声也。以迦陵频伽翻极好声也。二清净下一行半赞尊特。上以大小相间而赞。盖显身相大小咸遍。辞意虽含尊特未彰。故今复赞身相光明俱无限齐。经云威德者。巍巍堂堂之相也。二智慧下二句赞智断功德。上句赞智德。下句赞断德。三世尊下总结尊特。大论云。尊特身佛者。巍巍堂堂。譬如须弥映临大海。所有大小相好亦巍巍堂堂。然如来自行具足三身功德。诸菩萨唯赞尊特者。上冥下应已摄三身。斯乃赞智之巧。学者思之。二为诸下六行半赞所说教法化他利益二。初叙说教因由。在文可见。新经云。欲利益诸众生故。常行法施。乃至令得大果证常乐故。二赞所说教法二。初如来下二句赞经宗体。体指序品如来所游深广无界。超诸因理故称第一深义。举深该广即甚深无量也。宗指寿量极果所得。过诸菩萨亦称第一也。法报体一深义可知。二赞经力用三。初能令下二句赞上忏品灭恶。寂灭者。寂诸业行之恶。灭于果报之苦。二能与下二句赞上赞品生善。上是如来叙昔龙尊赞佛。意生今日当机之善。故能与无量快乐。三赞空品双导二。初能演下一行赞能导空法妙。经云甘露者。即长生不死之药也。文诠中道妙空实相真谛。能过二死迷变可生四德常身。故斯理空即名甘露。仍由染体本净空名妙法。从此而入复名法门。二能入下二行赞灭恶生善深。忏得斯空二死恶患之报即谢。三德涅槃之宅可入。言解脱者。有二意。若就解脱惑业之缚。即破恶也。若取无染自在之净。即生善也。度三有等。破恶生善可知。三结赞人法者。功德智慧结上赞能说教主尊妙人也。慈悲精进。结上赞所说教法宏深也。法之宗用如是者。皆慈悲精进所致也。二绝言赞三。初如是无量下一行绝言赞。故不能称计说喻。二诸天世人下二行绝心赞。故尽思度量。不能得知大海一滴少分也。三我今略赞下一行指广结赞。可见。三若我功德下一行赞已回向。回向有三义。现文有二。理含其三在文可见。二信相说二。初经家叙。二正说偈二。初世尊下一行总赞相好功德。千数者。举大数也。二别赞大小相海五。初别赞二种光相二。初色净下。四行赞色具光相。色净远照下。即第十四金色光相。光明炽盛下。即第十五身光相。然二种光相若据生身。皆有齐限。如云身光面各一丈。今云如日千光。乃至悉能远照无量佛土。故知信相昔为龙尊赞佛尊特。发愿未来得值释迦。今日赞佛。岂忘其本。是则大相小相皆寄尊特而赞也。二能灭下一行明光具与拔。昔为龙尊赞佛身放大光。灭尽三界一切诸苦。令诸众生悉受快乐。今日赞佛。还赞光明灭苦与乐。在文可见。二诸根下一行总赞诸根相好。如大相中有身端直。皮肤薄细。舌大覆面。齿白。齐密。眼如金精。睫如牛王。小相中有鼻高好孔不现。耳轮辐相埵成。身清洁柔软等诸根皆见者无有厌足。三又比赞一小相二。初发绀下一行赞发相。孔雀项蜂王等皆比发有绀色。如八十好中有发色青珠好等。二清净下一行半具功德。清净慈悲无量禅定。久皆庄严。故发好柔软。四复明相好功德二。初明相好具功德二。初相好下一行明严身克果之用。可见。二如来下二行明摄生感赞之功。若相若好随大随小。悉能调伏令心柔软受诸快乐。故为诸佛所赞。二其光下二行明功德具光明。功德高广犹如须弥显出大海。五齿白下二行半又比赞齿毫二大相。三树神说二。初经家叙。言道场菩提树神者。即如来得道之场在此树下。然树本名毕钵罗。佛坐其下得菩提智果。立此为名。故今女天依此树住亦以为名也。西域记云。昔佛在世。高数百尺。屡经残伐。犹高四五丈。茎干黄白枝叶青翠冬夏不凋光鲜无变。每至如来涅槃之日。叶皆凋落。顷之复故。此在中印度摩竭陀国大城西南四百余里。修苦行处不远。有此树也。二正说偈四初二句总赞。南无者。归命之辞也。清净者。佛性论有二种。一性净本无惑染故。二相净对治离障故。今总赞如来中边智满法报应圆。故谓无上正觉也。二别赞二。初广赞能说教主三。初甚深下一行半就所觉显明赞佛法身。甚深妙法者。法性高广诸法融妙。圆智圆觉遍一切处。众邪染障本自离故。如来随顺斯理觉了其性。一切魔外涅槃非法。禅戒非道。犹如大树盘根厚地。唯佛金刚大智独拔而出。成佛正觉者。所谓出缠大法身也。然准圆佛大智觉了本性非法非道。应离三乘七方便涅槃非法戒定非道。方曰远离一切。法者。即所生果法也。道者。即能生因道也。苟未离无明相分。皆曰其非也。二知有下二行半就能觉智行赞佛报身三。初约法。知有下二句赞报智也。知者照也。有即俗非有即真。本性清净即中。以一切种智知照三谛。则冥深契广事理周极。名佛无上报智也。希有下二句赞佛助行功德。重言希有者。叹美之郑重也。下皆例然。因中戒定万行有排障敌恶之力名功。助发大智成佛大果名德法华云。久修业所得即无上报。故谓如来功德也。二希有下一行约喻。即喻上报身智行也。大海喻智也。须弥喻行也。其智冥理穷实相底故。方之大海。释论谓智度。大海佛穷其底。因中万行积功累德。喻彼须弥如华严涅槃。皆云析骨书经如彼妙高。三希有下二句总合。智行契理三法一如。故曰无边行也。三希有下一行半。就垂世形益赞佛应身。优昙花者。具足云优昙钵罗。此言瑞应。亦云灵瑞。轮王出世时感此华。泥洹经云。阎浮提内有尊树王。名优昙钵罗。有实无华。优昙钵树有金华者。世乃有佛。故云时一现耳。无量大悲者。垂应本也。以大悲故不住涅槃。二释迦下一行半。略赞所说教法。如来将欲口轮说法。必须意业鉴机。如日照物无所不遍。为欲利益者。准金光明之力用。须明十种利益。方尽垂世说法之意也。三请佛出定二。初赞今所入定为请见由。三初善哉下二行就果佛赞所游定。诸根寂灭者。以了眼等性常具无减修。诸惑死生悉已寂灭。故常居寂定。而复游入者。将轸法轮表不妄说。又三世佛说必须入定。故首楞严经云。虽知诸法常是定相。而示众生诸禅差别。言善寂大城者。正赞所入定也。即向经初法性三昧。若入此定即能善了诸法。寂灭无非法性故。防生死之非御涅槃之敌。即中道善寂而名大城也。亦名无垢清净三昧等。既是佛之境界故。受无垢清净之名。为诸佛行处也。二明三昧能空行相。此经虽则结归方等。说在般若时后。忏赞善恶皆推空导。故空品谓无量余经已广说空。故此经中亦谭其空。为入理门也。佛游三昧亦从空入。声闻之人虽从空入。犹为身果所缠。如来空智明见声闻身果性相皆空。诸佛境界亦空。如是一切无量诸法者。指上自他依果国土净秽。推性推相不见差品。一切众生依正境界。推求性相皆同真净。无复其异。然推乎性相者。即空观遣情显理之要门也。一家明观诸处共论。其如讲学之人亦多昧之。今家承用则依中论智论。准理准义开拓观门。故于权教实教事观理观。悉已明之。学者须知。且如性相二空本是一空观法。备遣情计故有两番行相。是知若善修一空观者。必遣二种执性。如法华止云。知法常无性。荆溪谓应无性性无相性。诸文为辨性相。寄前后说。故以二谛分之。乃云。四句推性不见性。是世谛破性。四句推名不见名。是真谛破相。相破即相空也。荆溪释云。若有性执世而非谛。破性执已世乃名谛。是以名为世谛破性。性执破已但有名字。名之为假。假即是相为空相。故观理证真是名真谛破相。空非前后二谛同时。故知性执破已。虽名世谛。初轸其观即须观真。四句推性虽不执性。其如惑存转计其名。既不见理但名世谛。仍观法性真理破名字相。相执破已方证其真。故名真谛破相。或初观真谛四句推性。便了阴界色心名字无四句相。即名真谛破性破相。岂待转观破相。方用真谛耶。若尔。推性何故云不自他共等。推相自谓不内外中间等。句法既别显理用观自异。何谓只一四句空观破二种执耶。答向谓寄前后说。对所破执相。故推性则谓不自他等。推相乃言不内外等。考乎观门岂有异途。故荆溪云。内秖是因外秖是缘等。况止观明性空观毕。乃引中论诸法不自生等四句为证。洎明相空观毕。亦引斯论诸法不自生等四句。以斯照之。应无别观。又止观但名一总空观者。即二空观也。问法华疏约真俗假实。明生法二空。荆溪释云。真谛即法空。俗谛即生空。俗假真实。乃引玄文世谛破性。真谛破假。假破即相空。性破即性空为证。若以性相二空秖一空观。何引人法二空对显二谛耶。以人空时亦未法空。故性相二空。若例人法空者。应二空须异。何谓性空未显于理。相空无别观耶。答小乘得人空时容有未得法空。如云见惑若破得须陀洹果。名得生空。此则少显真理。进破思惑方得法空。其理究显。大乘人法境融。观道不异。如大品云。色性如我性我性如色性。四阴如我用观亦然。纵有惑分粗细执破前后。用观必无异时。而法华疏约人法空名二谛者。为对所破寄分真俗。故引世谛破性名性空。真谛破相名相空为证。其如用观委明行相。须于我人生境破性破相。方得生空。复于阴界入法寄俗寄真。推此二空穷斯真理。名为法空。方是用观行相委悉故止观云。于性相中求我人知见不可得。是生空。于性相中求阴界入不可得。是法空。而疏以俗谛对生空者。盖此生空体是法执。故以俗谛显此空相。故云俗假。假即虚妄也。法执若破妄染究尽。方名真谛。故云真实。实即究竟也。荆溪体斯疏意。复以玄文寄世谛显性空等义。而为证也。故云真俗不二二空俱时。问既云二谛不二二空俱时。显是一理一空。又何分二谛。及明二空耶。答其实所显理是一。能观观亦一。为对所破执故。而分二空。显空浅深故。而寄二谛。是故性相空中性空约理。理既未显但名世谛明空。空犹未尽但名性空。仍于世法。又观真谛破此执名之相。相若破已理显。方名真谛。观成方名相空。故寄二谛显二空相。故知若晓性相二空。对所破而分真俗者。则寄二谛明人法二空。准理亦然。是则人空空未实故。乃寄俗显。故云俗谛即生空也。法空空既已净而寄真显。故云真谛即法空也。矧又虽用生法互融之观。而照真俗不二之境。其如众生无始多于生境计我起执。不二之观亦于生境。先当其用。故破人执时且名生空。既法执在复观其法本无其执。离四句相方名法空。故大师谓始觉人空终觉法空。然此二谛显二空相。通圆之教行相亦同。但通用其观止照真理。故寄俗寄真显性显相。明斯二空唯在真理。而圆实之教体生体法推性推相。唯是中道法性。法性无生无性。名世谛破生破性。此生此性即法。法体本空名真谛破法破相。虽寄二谛。悉用中道而显二空。通无此观。学者思之。然委明二空推所执能。人执随法执亡者。具如前疏空品记文。三狂愚下二句指。凡愚不了请现。上赞佛所游三昧空智。遍了诸有差异。悉皆泯亡。唯真智独存更无染异。树神分晓悲愍凡迷狂乱愚痴。不了性相俱空。故请佛出定。二腾昔常愿见正请出定四。初我常下五行。正叙昔愿行请现。我常念佛者。念即观照之异名也。心游法界常照三身。叙昔观力未充。欲求深证。故助之以誓愿。跪之以合掌。加乎恋慕。哀泣雨泪修行大悲等。并助常念之观也。言最上大悲者。即无缘悲也。正助合修故曰最上。问树神在会明见如来入定说经。何故今方频言欲见于佛耶。答今有二意。一者如来入定本为说经。说经既毕。要须出定。欲出其定须得其请。故佛出定能印三番所说皆实。既一期事毕。乃树神致请殷勤。故叙昔常愿见复加愿行。欲使未来亦得见佛。故云愿使我身常得见佛。二者树神久已分见如来真身。欲增念佛之观。更求上证。故寄请佛出定。频陈欲见。苟得如来酬请现身。即己心中真佛显发更明。故下结云。唯愿慈悲为我现身。二约定具慈悲请现三。初世尊下二行。明慈悲能护迷暗。树神自昧如来上位真身。故请佛加愿。使我身常得见佛。复愍于他迷瞽所及。不见佛之真体故。叙世尊常护一切。是故渴仰欲见者。即引己及他请佛现身。二声闻下一行半。约圣凡未发性明。即树神击请今佛出定也。佛虽在定明了性净。犹如琉璃表里通彻。照机起应皆不动于寂定。如来虽久已明了。其如众生未发上定。故树神频请出现发悟斯机。乃举六喻显乎声闻色体非性明体。所证真理閴寂无知。如空之虚无亦灯之烟焰。术之所幻声之谷响。神通之化水中之月。皆非实性。不能即寂即现也。众生之性虚妄现在。如梦所见都无实相。三就佛行处明见请现。正明佛所入定具慈愍照。故请如来出定。令我及众得安乐故。三一切下一行半。愍凡圣不知请现。树神以凡夫小圣共迷佛所游境界。故请佛现身。即令明见唯心佛现。经五通神仙者。别举人趣中有术成仙者。发得五通。虽有他心宿命。而不知佛所游定。照理起应不离众生心体。无漏二乘虽有三明六通。亦昧佛境唯心故曰亦不能知也。四我今下一行。指已信不疑请现。树神述已于佛行处明了无滞。虽知本无隐现。上举他众共迷佛境实有动静。故敦请出定云。惟愿慈悲为我现身。问今佛入定说法对告。起礼舍利。既有往来时会共见。树神焉知如来在定未出。而致请殷勤耶。答树神大权久与佛同事。昔为流水救鱼。树神现半身示数。长者既已成佛。树神岂犹滞凡。故今一动一静皆扶佛化。何不知之有。矧凡出定入定皆有其仪。佛虽起坐往来。其如未示出定之相。树神敦请至勤。方现出相。其相者。必须先示微微动摇其身。次乃黈气嚬呻徐缓而起。方知如来示出定相。故法华谓安详而起。此经云。出微妙音。故知定起皆有其相也。问新经自云。尔时薄伽梵于日晡时。从三昧起。观察大众而说颂曰。金光明妙法最胜诸经王。今之谶本何故至三番赞毕。方云从三昧起耶。苟译者所见不同。其如集经者梵本编文。安次如何耶。答梵本不同岂须和会。其如学者无由晓经。今略试评之。在理或当冀无私隐。且夫此经古师谓是偏方之教。即一时赴机之说也。故天台结归方等部摄。斯由机分大小应赴权实。赴权小者。令见佛从定起说法。应实大者。则知佛在定而告。亦如华严中。令见女子身中入正受。男子身中起出说等。当时应物既殊。故集经者或言定起方说。或云说毕定起。然佛灭度后集经者。又匪一途。亦有窟内窟外所集。亦云。梵语有赊有切等。致译经者。所睹梵本不同。如谶师曾游五天必睹梵文正本。见云佛在定而说必须信受敬译。净师本弘小典晚接梵文。或见云佛从定起方说。正符所宗。故编译无改。至列声闻菩萨等众。皆云于日晡时从定而起。到佛会所。古师尝推译者。未为雅当信亦有之。然圣师所为必非徒然。凡流肤学莫尽考乎厥由也。求过得过。附赘之尤亦已甚矣。学者体而思之。问大师既依谶本释经。何故云入游法性出叙经王耶。答如来常在法性上定。应机顺物示入定相。虽心游寂理口出其言。故谓出叙经王。盖寂不阻照说无妨定。非谓身出其定也。四酬请起定二。初尔时下一行。明经家叙起定。尔时者。即当树神请毕之时。佛示出定之相。乃云以微妙音而赞叹言。即微细妙好之音。而悦豫四众也。二善哉下二行。明佛定起能赞。佛赞树神意合前二。以诸菩萨及妙幢。能赞佛所说教。皆是快言。如来序品已来明大体大宗大用。是金光明妙三法也。故云快说是言。若众生闻此三法。即能发解证悟。明了常住。故云入甘露无生法门耳。二章安总释二。初约义释二。初约佛赞义二。初约定果赞因二。初正明赞因义二。初示义。私谓下总释也。其文有四者。前大师分科止为三段。以如来定起三行之文。合为树神段中。故注云云。今章安开释方为尽理。文现可见。二引证。二示印成赞教。三番菩萨皆先赞佛次赞说教。即赞如来。从序品已来。是说一经大体大智大用菩萨修因也。何者序品明游法性。佛指所游是诸经王等。三番谓佛是说一经之大体也。寿量明佛常果。三番为佛是说一经之大智智即宗也。忏赞空品。谓佛是说一经之大用也。四王至舍身品。皆是说菩萨修因也。三番赞教。既称佛所说。故如来定起印成。即赞树神等快说是言也二赞通三业。章安因明今品果佛定起。能赞因人快说。复考经之上文。亦有果身礼舍利之义。舍利者。翻骨分也。即因身尔。上忏品佛赞大忏。赞品佛赞龙尊。是大赞。皆言大者。一忏一赞等法性大体。知罪福性空也。四王品能请。善集品能说。鬼神品等能听。舍身品能行。皆是快说者。共能了金光明教。能诠所诠是体宗用三。即一切三法。故皆名快说也。信相龙尊四王等。并是因人。故谓因口所说。孱字(士限切)现也。身口非意不行。故云任运例成也。二约出定义二。初据起问入。二答始末在定二。初明住法性定。问诸经先须入定定起方说今经何故一向在定。而有所说耶。答若论法性上定。岂有出入说默之异。既示其定盖顺物机。物机所宜适乐不同。诸经示同往佛皆先入定。履历法缘对治散心。妄有所说。故须入定定起方说。此经首尾在定而能说者。意同向理。又示金光明无量甚深自在无碍。寂照融遍。故说毕定起印成三番快领如来所说法也。二彰法性圆融。言若作入法性者。显理含容不阻出入。上唱法性无量甚深。一出一入有说有默。岂逾法性。故云法性自在。言四佛者。即四方佛也。五佛者。并释迦耳。同处各处等者。信相室与灵鹫山虽异。若了唯心者。见唯妙土则弟子众一。故五佛同处共一身一智也。是则四无来去一无住在。其执权教者弟子众异。谓妙幢所居共佛耆山。夐隔多里。故四佛五佛匪唯各处。亦见异身异智实来实去定住定在。虽此殊别无离法性。故云随人所睹皆无障碍也。二约观释二。初明事三业境。言观心者。标明观释也。先明诸菩萨赞具三业。为妙观境。然赞虽在口。身须恭谨。心仍尊重。三业齐运赞义方成。二明理三观成二。初明于事观理。言三观心者。寄身等境示空假中能观三观心也。近有讲人不知便谓。后人妄加心字。亦由向迷心为所观。致有踳驳。斯之疏谬不可云也。止如十六观经本明佛观。疏云。心观为宗。或不见斯意。乃妄有穿凿。今之学者切宜思之。观身不得身者。先明身观。推检四大本无实性。名身性空。但有名字即身相也。名字多种。且举六度十度等。如身行布施名檀。身离诸非名戒。身受所辱名忍。身勤前行名进。身能安静名禅。身了体空名慧。身行其巧名方便。身立盟誓名愿。身利及于他名力。身出生死名智。身乃至身行八万尘沙法门。行者随受名字。达名无名名身相空。推检性相虽空。而色心诸法宛然。故空不定空。假不定假。非空非假皆真实妙性。名显中道也。观身既然口意例解。二明事得理成三。初明无观俱失。身等为境能发其观。观成境现事理双明猪揩金山。方之可解。二以衣物为例。三衣者。僧伽梨郁多罗僧安陀会也。六物者。兼尼师坛钵多罗漉水囊也。是知六外无三。亦如四禅八定定外无禅。盖衣名则局物名稍通。衣者遮覆之义也。钵多罗等且非遮覆。故通名物也。亦如无色四处受想虑亡。则无支林喜乐之名。故通受定名也。色界四处虽通静虑。受想尚行则别受禅名。故知解之则事三理六俱明。昧之则三六四八俱暗。三得理俱成。境由观显。理观若成身口意三。名妙色心。故亦名六观亦名事理成也。无六亦无三者。牒上例中若不解之文也。可见维昔先禀法智大师。尝讲次撰记解释经疏。方终一十七品会乃归寂。其最后赞佛一品。经旨幽邈疏科尚简。而钩索深隐固亦难矣。予虽不敏。忝久亲讲授。遂纂集旧闻系诸卷末。亦冀览者岂贻续貂之讥云

金光明经文句记卷第六(下)


金光明经玄义

    No. 1783 [cf. Nos. 663, 1784]

金光明经玄义卷上

        隋天台智者大师说

        门人灌顶录

此金光明甚深无量。太虚空界。尚不喻其高广。况山斤海滴。宁得尽其边崖。日轮赫奕。非婴儿之所瞻仰。大舶楼橹。岂新产者之所执持。诸佛行处过诸菩萨所行清净。况二乘心口安可思说。凡夫徒欲言之。言则伤其实。徒欲不言。默则致其失。二俱不可。欲以言之言亦不可。欲以默之默亦不可。故大品中梵志云。非内观故得是菩提。非外观故得是菩提。非亦内亦外观故得是菩提。经言皆不可思说。又生生不可说。生不生不可说。不生生不可说。不生不生不可说。有因缘故亦可得说者。以金为名。名盖众宝之上。以法性为体。义则如来所游庄严。菩萨深妙功德以为宗。照曜诸天心生欢喜以为用。故文号经王。教摄众典。故唯贵为名。唯极为体。唯深为宗。唯大为用。唯王为教。所以不二之体常为四。佛世尊之所护持。三世十方亦复如是。一切菩萨。遍他方以遥礼。树神善女。亲雨泪以称扬。诸天覆之以天威。地祇润之以地肥。大辩加之以辩道。功德益之以财宝。诸有悉干枯。三涂除热恼。举要言之。一切世间未曾有事。悉皆出现。是以金龙尊王三世赞叹。地神发愿以护说者。上圣既尔。岂况人乎。敢托斯义。辄欲兴言。冀涓露入海禽鸟向山。实藉片缘同均碱色

将释此经大分为二。初释题。二释文

释题为五。一释名。二辨体。三明宗。四论用。五教相

就此五章大分为二。初总释。二别释

总释又二。初生起。二简别

生起者。此娑婆国土音声为佛事。或初从善知识所闻名。或从经卷中闻名。故名在初。以闻名故。次识法体。体显次行。行即是宗。宗成则有力。力即是用。用能益物。益物故教他。闻名是自行之始。施教是化他之初。有始有终。其唯圣人乎。五章生起次第如此

简别者。简是料简也。问若略则唯一。若广则无量。今此五章。进不是广。退不成略。何故五耶。答非略非广。非略故不一。非广故不多。广则令智退。略则义不周。我今处中说今义易明了。五章中当其义如此。别者分别也。前一章总三字共为名。次三章派三字以为别。后一章兼于总别。而明教相也。又显体一章明理。余四章明事。又前三章是因。后二章是果。又前四章是行。后一章是教。又前四章是自利行。后一章是利他行。又前四章是圣默然。后一章是圣说法。如此等种种分别料简。今显譬中当。分明包富。如囊中有宝不探示人。人无知者。此皆为分明中作譬也。囊中有宝为总三字作譬。探以示人为别三字作譬。囊中有宝为理一章作譬。探以示人为明事章作譬。其余例皆可知也

二别释者。别释五章也。今先解释名章。若依四卷题但作三字。无帝王两字。若依经文有经王之义。若说若不说俱亦无妨。今释名为五。一通别。二翻译。三譬喻。四附文释。五当体释

言通别者。夫教有通别依教明行。行有通别从行显理。理有通别。且置行理。但明教通别者。夫理无名字。名字名理。如虚空无丈尺。丈尺约虚空。天王般若云。总持无文字。文字显总持。若从能显之文字。是名则通。若从能显之所以。此名则别。云何为通。如圣所说。一经一时一处一部一偈一句一言皆是文字。从此文字通称为经。云何为别。别则有四。一令世谛不乱。欢心悦耳。二逗化所宜。开发宿善。三对其业障。令恶灭罪除。四点示道理。霍然妙悟。悦宜对悟。各各所以。其致不同。称之为别。譬如盐梅相和成种种滋味。组织交横成种种文绣。从别所以故有金光明三字。标今教异于诸教。从通文言故有经之一字。众经通称也。今经通别合标。故言金光明经

二翻译者。真谛三藏云。具存外国音。应言修跋拏婆颇婆郁多摩因陀罗遮阅那修多罗。修跋拏此言金。婆颇婆此言光。郁多摩此言明。因陀罗此言帝。遮阅那此言王。修多罗此言经。外国又称佛陀罗。此间所无。又略帝王两字。但存三字者。汉人好略译者省之。但翻为金光明经也。余师翻不及此委悉也

三譬喻者。旧经师。以三字譬三德。金譬法身。光譬般若。明譬解脱。若大师云。数论但明真应二身。若以二释三于论不便。若取经文。经文无一处明三德。若别作义解何义不通。而独譬三德既违己论。又不会经非今所用。地人云。金质之上自有光明之能。譬于法性从体起用。自有般若解说之力。但作体用二义。不须分光明异也。若大师云。地论幸明三佛。三佛释题于义自便。而弃三身从体用者。则非论意。若取经文新旧两本。并说三身不道体用。亦违己论复不会经。进退何之。今所不用。真谛三藏云。三字譬三种三法。一譬三身。二譬三德。三譬三位。譬三身者。金体真实以譬法身。光用能照以譬应身。明能遍益以譬化身。次譬三德者。金有四义。一色无变。二体无染。三转作无碍。四令人富。金以譬法身常净我乐四德。光有二义。一能照了。二能除闇。以譬般若照境除惑。明有二义。一无闇。二广远。以譬解脱众累永尽溥益有缘。次三位者。金性先有。如道前正因位光融体显。如道中了因位。明无瑕垢。如道后缘因位。彼家料简云。法身是实二身不实。法身具四德。般若解脱各具二德。正因是本有。了因是现有。缘因是当有。大师谓三三之释。三义不了。一因果不通。二乖圆别。三不称法性。云何因果不通。夫三身三德。本是果上圆满之名。而今分置三德残缺不足。何者。若法身是道前。为是果上之法身。为是性德之法身。若是果上之法身。不应在道前。若是性德之法身性德何独有法身。亦应有性德之般若。性德之解脱(云云)。若言般若是道中。为是何等之般若。若是果上之般若。不应在道中。若是分得之般若。何意无分得之法身解脱(云云)。若解脱在道后。道后众善溥会。何独有解脱。以是观之因果不通。乖圆别者。若作圆说。法身常乐我净此自可知(云云)。般若与法身相冥。法身既具四德。般若宁无四德耶。解脱脱果缚故乐。脱因缚故净。无因果缚故我。非因非果故常。圆说圆满无有缺减。真谛若作别说。应依此经。经云法身是常是实。实即我德也。应身智慧清净即净德也。化身三昧清净即乐德也。三藏说法身独具四德。二身各具二德。故皆乖圆别也。不称法性者。且引一。经如净名云。众生如弥勒如。一如无二如。此性德法身也。一切众生即菩提相。不可复得。此性德般若也。一切众生即涅槃相。不可复灭。此性德解脱也。如此三义岂非本有道前之位。岂独有金而无光明耶。又华严云。初发心时便成正觉。所有慧身不由他悟。清净妙法身湛然应一切。妙法身是法身德。慧身是般若德。应一切即应身。是解脱德。此之三身地地转增。如月渐满。岂非道始因中之位。那得因中。只有般若耶。道后具三德如上说。此事可知。当知道前圆性德。道中圆分德。道后圆究竟德。那忽分割一处唯一耶。岂非蹙灵凤于鸠巢。回神龙于兔窟。辱鳞羽之壮势。非法性之圆谈。天台师寻其经意义则不然。何者经言。法性无量甚深理无不统。文称经王。何所不摄。岂止于三三九法耶。当知三字遍譬一切横法门。乃称法性无量之说。遍譬一切竖法门。乃称法性甚深之旨。方合经王一切遍收。若长若广教无不统。此义渊博不可以言想。且寄十种三法以为初门。复为三意。一标十数。二释十相。三简十法。言标十数者。谓三德三宝。三涅槃三身。三大乘三菩提。三般若三佛性。三识三道也。诸三法无量止取此十法。其意云何。此之十法该括始终。今作逆顺两番生起。初从无住本立一切法。夫三德者。名秘密藏。秘密藏显由于三宝。三宝由三涅槃。三涅槃由三身。三身由三大乘。三大乘由三菩提。三菩提由三般若。三般若由三佛性。三佛性由三识。三识由三道。此从法性立一切法也。若从无明为本立一切法者。一切众生无不具于十二因缘。三道迷惑翻惑生解。即成三识。从识立因即成三佛性。从因起智即成三般若。从智起行即成三菩提。从行进趣即成三大乘。乘办智德即成三身。身办断德即成三涅槃。涅槃办恩德利物即成三宝。究竟寂灭入于三德。即成秘密藏也。是为逆顺次第甚深无量义。复云何无量义者。是一法门具九法门。三德尊重即是三宝。三德不生不灭即是三涅槃。三德具足诸法聚集名为三身。运载荷负即是三大乘。不可异趣名三菩提。觉了清净名三般若。是如来种名三佛性。分别不谬是名三识。即事通理故名三道。是为一三法门具九三法门。亦具一切三法门。悉例可知。又皆具一切一法门。一切二法门一切三法门。四法门五法门。六法门七法门。八法门九法门。十法门。百法门千法门。万法门亿法门。一恒沙二恒沙。百千万亿恒沙法门。亦应可知。经云一法门无量法门以为眷属。一中解无量。是为法性横广无量之义也。甚深义者。寄三位显之。如十法门共论者。三道三识是本有位。三德三宝是当有位。其余是现有位。是名法性甚深。竖高之义亦成。又一法门具九法门。取其三道三识是本有位。取三德三宝是当有位。取其余者为现有位。甚深义亦成。又一一法门具六即位。理即是本有位。究竟即是当有位。其余即是现有位。甚深义亦成。是为法性竖高甚深之义也。当知金光明三字。遍譬一切横法门。故言无量。遍譬一切竖法门。故言甚深。乃称法性之文。方合经王之旨。次释十种三法相者。十名如前已列。十相今当分别。若分别色相青黄同异者。应用肉眼。若分别法相深浅同异者。应用智眼。今时行者既无智眼。应用信解分别同异之相。初明三德相者。云何三云何德。法身般若解脱是为三。常乐我净是为德。法者法名可轨。诸佛轨之而得成佛。故经言。诸佛所师所谓法也。身者聚也。一法具一切法无有缺减。故名为身。经言。我身即是一切众生真善知识。当知身者聚也。般若者。觉了诸法集散非集非散。即是觉了三谛之法。解脱者。于诸法无染无住。名为解脱。是名为三。云何为德。一一法皆具常乐我净。名之为德。法身无二死为常。不受二边为乐。具八自在为我。身业净口业净意业净为净。无以为类。疆寄世金以譬之。世金不变不染转变富贵。譬法身四德也。般若任运具四德。如智冥如境故。大品云。色净故般若净。例此即得色常色乐色我诸义皆成。又云。色大故般若大。色无边故般若无边。此是法性广大。般若亦广大。例此应云色深奥故般若亦深奥。此是法性竖高。般若亦竖高。当知般若亦具四德明矣。解脱亦具四德。夫解脱者。诸恶永尽。即无常无乐无我无净。皆已尽也。亦是众善溥会。即常乐我净溥会也。大经云。真解脱者即是如来。如来即是法身。当知解脱同如来常乐我净也。又大经云。三点具足名大涅槃。点是文字。当知法身般若解脱皆文字也。故知三点悉备四德。故言具足。三因即是三智。三智德具四德。三德具足名秘密藏。具足之文必具四德也。当知四德具足即是其相。若得此一章意。余九可解。不能默已更复略言。云何三云何宝。佛法僧是为三。可尊可重名为宝。至理可尊名为法宝。觉理之智可尊名佛宝。毗卢遮那遍一切处。即事而理。此和可尊名僧宝。此之三宝皆常乐我净。常乐我净故乃可尊可重。当知三德与三宝。无二无别。既以金光明喻三德。还以金光明譬三宝也。云何三。云何涅槃。性净圆净方便净是为三。不生不灭名涅槃。诸法实相不可染不可净。不染即不生。不净即不灭。不生不灭名性净涅槃。修因契理惑毕竟不生。智毕竟不灭。不生不灭名圆净涅槃。寂而常照机感即生。此生非生。缘谢即灭此灭非灭。不生不灭名方便净涅槃。当知此三涅槃。不生不灭即是常。常故名乐乐故名我我故名净。涅槃既即常乐我净。即是三德可尊可重故。即是三宝无二无别。既以金光明喻三德三宝。还以金光明喻三涅槃也。云何三云何身。法报应是为三。三种法聚故名身。所谓理法聚名法身。智法聚名报身。功德法聚名应身。然理无聚散义言聚散。始从初心显出正理乃至究竟理聚方圆。始从初心终至究竟。显理之智智聚方圆。始从初心终至究竟。功德之聚方圆。故以三法聚为三身。当知三身皆常乐我净。即是三德。可尊可重即是三宝。不生不灭即是涅槃无二无别。既以金光明譬三德等。还以金光明譬三身也。云何三大乘。运荷名乘。理性虚通任运荷诸法。故名理乘。随乘者。智随于境如盖随函。故名随乘。得乘者。得果得机。得果故自解脱。得机故令他解脱。故名得乘。当知三乘皆常乐我净。即与三德无二无别。既以金光明譬三德。还以金光明譬三大乘也。云何三菩提。一真性菩提。亦名无上菩提。此菩提以理为道。二实智菩提。亦名清净菩提。此菩提以智慧为道。三方便菩提。亦名究竟菩提。此菩提以善巧逗会为道。当知三菩提皆常乐我净。与三德无二无别。既以金光明譬三德。还以金光明譬三菩提也。云何三般若。般若名智慧。实相般若。非寂非照即一切种智。观照般若。非照而照即一切智。方便般若。非寂而寂即道种智。当知三般若皆常乐我净。与三德无二无别。既以金光明譬三德。还以金光明譬三般若也。云何三佛性。佛名为觉性名不改。不改即是非常非无常。如土内金藏天魔外道所不能坏。名正因佛性。了因佛性者。觉智非常非无常。智与理相应。如人善知金藏。此智不可破坏名了因佛性。缘因佛性者。一切非常非无常。功德善根资助觉智。开显正性。如耘除草秽掘出金藏。名缘因佛性。当知三佛性一一皆常乐我净。与三德无二无别。既以金光明譬三德。还以金光明三字。譬三佛性也。云何三识。识名为觉了。是智慧之异名尔。庵摩罗识是第九不动识。若分别之即是佛识。阿梨耶识即是第八无没识。犹有随眠烦恼与无明合。别而分之是菩萨识。大论云。在菩萨心名为般若。即其义也。阿陀那识。是第七分别识。诃恶生死欣羡涅槃。别而分之是二乘识。于佛即是方便智。波浪是凡夫第六识无俟复言。当知三识一一皆常乐我净。与三德无二无别。既以三德譬金光明。还以金光明譬三识也。云何三道。过去无明现在。爱取三支是烦恼道。过去行现在有。二支是业道。现在识名色六入触受。未来生老死。七支是苦道。道名能通。此三更互相通。从烦恼通业。从业通苦。从苦复通烦恼。故名三道。苦道者。谓识名色六入触受。大经云。无明与爱是二中间名为佛性。中间即是苦道。名为佛性者。名生死身为法身。如指冰为水尔。烦恼道者。谓无明爱取名此为般若者。如指薪为火尔。业道者。谓行有乃至五无间。皆解脱相者。如指缚为脱尔。当知三道体之即真常乐我净。与三德无二无别。既以金光明譬三德。还以金光明譬三道也。若见此十法门。若同若异亦是一法门。作一切法门相。若同若异相相明了。即百法千法万法。恒沙尘数亦如是。华严云。一法门无量法门而为眷属。首楞严和香丸。大品裹珠。法华一地所生。涅槃大海水浴。皆是其义。问若一法即是诸法者。唯说一法何用余法耶。答佛为悦一切人。宜一切人。对一切人。悟一切人。若遍说之多有利益。一说尚令生种种解。遍读诸异论。即知智者意。故种种说令得一切解。粗言及软语。皆归第一义。皆是示人无违诤法。即此义也。三料简者。初料简三德。若指太子相好体为法身。法身在前。树王下时。明无漏慧三十四心为般若。般若在中。八十灭度烧身不受后身为解脱。解脱在后。异而且纵。法身时无般若。般若时无解脱。解脱时无般若法身。此即三法各异。斯乃阿含三藏数家所用。此之三意。悉不得称常乐我净也。若指空境为法身。法身是本有。照真之慧为般若。般若是今有。子果两缚尽为解脱。解脱是当有。异而且纵。斯乃三乘通教中所说。前代探明大乘人所用。亦不得称常乐我净。若如真谛师明。法身具四德般若解脱各二。此乃横而且异。乃别教一途所明。而真谛师偏用。当知法身可称为德。般若解脱无德可称。不会无量甚深之高广。亦不得称为经王。今所明三德如上说。一一皆具常乐我净。论广则无量。论高则甚深。若诸学人闻诸经之王。四佛所护。不解此意。如牛羊心眼不足论道也。料简三宝者。若指树王得道为佛宝。转生灭四谛法轮为法宝。度陈如等五人。先得眼智明觉者为僧宝。由是三宝故到于今。即有相从三宝者。此乃阿含中所明阶梯三宝。亦是数论宗用也。若指树王得道为佛宝。所说无生四谛为法宝。二乘菩萨修真无漏断结成圣理和为僧宝者此亦三乘通教中所说。探明大乘人所用。此两种三宝。并无常乐我净。若指华王世界坐莲华台成道为佛宝。所说恒沙佛法无量四谛为法宝。四十一贤圣为僧宝。此则异前。虽非阶梯未是同体。亦非金光明所譬三宝也。料简三涅槃者。若饥得食病得差。狱得出猕猴得酒。旃遮婆罗门饱食指腹。皆是世人畅情为涅槃尔若计非想定无想天为涅槃者。此是邪见妄谓为涅槃尔。若多贪欲人得不净观为涅槃者。斯乃四善根方便行人涅槃也。若三界烦恼尽。证有余涅槃。焚身灰智入无余涅槃。菩萨未得此涅槃。此即阿含中析法二乘之涅槃。若三乘人同尽子果两缚。即是通教中共涅槃。若指中道如理为性净涅槃。中道智为圆净涅槃。同缘出世薪尽火灭。为方便净涅槃。三种各别互不相关。是为别教涅槃。若言但有性净方便净两涅槃。不明缘因涅槃。各别不融者还是别教。非今经所譬涅槃也。料简三身者。若取树王下佛为真身。神通变化猿猴鹿马为应身。不明三身者。此小乘析法意尔。若取即事而真为真身。化用为应身。不明三身者。此体法中意尔。问若尔树王下丈六。既非佛复非鹿马。为是何身。答一往应同人像此属应身。又一解。例如大乘心中智合中理为法身。今亦如是。体是人像即是真空。此属真身。若依真谛师云。法身真实二身不真实。此则三身体相各异。乃是别教中一途。非今所用。若言三身皆真实。至理是法身。契理之智是报身。起用是应身。应身是实佛所化皆实不虚。大经云。不净观亦实亦虚非实。不净作不净想是为虚。能破贪心是为实。应身例尔。非本体故为虚。能利益故为实。今取实边不取虚边。故言三身皆实是今所用。若复圆论三身。皆实皆虚皆亦实亦虚皆非实非虚。当约三身并作四句。如别记(云云)。问三字譬三身。亦得譬一身二身四身无身不。答佛赴缘以三字名经。义家作三身解释。若得意者。作四三二一无义。亦复何咎。下经中悉有其文。若作四身者。新本云。释迦牟尼能种种示现。此则开出应化。是为四身。若作三身者。即有三身分别品。专论其义。若作二身者。佛真法身犹若虚空。应物现形如水中月。若作一身者。新本云。一切诸佛以真法为身。若作无身者。如来行处净若虚空。而复游入善寂大城。虚空中则无一二之数。此是无身之文。问若尔。云何以金光明。譬四身二身一身无身耶。答若以义名譬盈缩由义尔。若譬四身者。取光明之上有煜爚之焰。文云金光晃曜。此是譬四身之文。若譬三身如即所用。若譬二身。金是正体光明只是功能。以此为譬。若譬一身但举于金以为正譬。光明既是枝末非正所论。若譬无身者。至宝以无贪为金。扬震四知亦以无贪为金。今以世之至宝。譬出世之至理。弥会文义也。料简三大乘者。若约因缘六度大乘者。此还是三人名别义同也。若约三人同用无生断烦恼。三人同乘一乘。此则通教中乘也。若理随得三乘。体相别异不同者。此则别教中乘也。三种并为得乘方便所摄也。正法华中明象乘。足三为四。羊鹿牛乘为得乘所摄。象乘即是理乘。如今之所明三乘也。华严中明四乘。三乘亦为得乘所摄。佛乘正是今之三乘义也。料简三菩提者。如请观音云。修三种清净三菩提心。此即缘三乘人心而修心也。乃是方便菩提所摄。若缘真如实理发菩提心者。或缘如来智慧说法发菩提心者。或缘如来神通变化。发菩提心者。亦非今所用。文殊问般若云。无发是发菩提心。又若一发一切发。是发菩提心。又若非一非一切。而一而一切。是发菩提心。如此菩提心。即一而三并今所用。于一而论三。于三而论一尔(云云)料简三般若者。问般若至忘至寂。云何分别诸法耶。答一切智观慧眼见。见法皆非法。道种智观法眼见。见非法皆是法。一切种智观佛眼见。见法非法非非法双照法非法。若三智三眼一时圆观。一切法寂灭相。种种行类相貌。皆知五眼具足成菩提。汝所问者乃是眇眼所见。偏观所观。与则是曲见。夺则堕尼犍也。料简三佛性者。真谛师云。正性在道前。了性在道中。缘性在道后。此一往别说推理不然。华严云。一中具无量。大品云。一心具万行。净名云。举足下足具于佛法矣。法华云。一切智愿犹在不失。涅槃云。金刚宝藏具足无缺。但有深浅明昧之殊尔。料简三识。若分别说者则属三人。此乃别教意。非今所用。若依摄论如土染金之文。即是圆意。土即阿陀那。染即阿梨耶。金即庵摩罗。此即圆说也。问如经云。依智不依识。既云三识此那可依。答经言不依识者是生死识。今则不尔。今言依识者。是智之异名。名清净识。又道前通名为识。道后转依即是智慧未详。料简三道者。问界内可有十二轮转三道迷惑。界外复云何。答宝性论云。生界外有四种障。谓缘相生坏。缘即无明。为行作缘即烦恼道也。相即结业。即业道也。生即名色等。是苦之初。坏即老死是苦之终。即苦道也。有此四障障于四德。缘障净相障我。生障乐坏障常。四障破四德显也。第四依经文立名者。上来举譬多是义推。依文立名显然可解。何者义推疏远依文亲近。以己情推度是故言疏。彼义例此。是故言远。用佛口说是故言亲。即此经文是故言近。岂可弃亲近而从疏远耶。始从序品终乎赞佛品。品之中若不说金光明名。即说金光明事。或一品说名不说事。或一品说事不说名。或一品名事兼明。或一品名事独说。或一品重说名重说事。故知品品不空篇篇悉有。为此义故依文立名也。序品云。是金光明诸经之王。创首标名弥为可用。次寿量品。四佛俱集王舍城。放大光明照王舍城。及此三千大千世界。发起其事忏悔品。信相梦见金鼓。其状姝大其明溥照。过夜至旦向佛说之。赞欢品金龙尊王。奉贡金鼓发大誓愿。愿我当来夜则梦见昼如实说。空品云。故此尊经略而说之。尊经即金光明也。四王品六番问答。问问之中重说其名。答答之内重明其事。又以手擎香炉时。香烟变为香盖。金光不但遍此大千。亦遍十方佛土(云云)。大辩功德已下。标名举事其例甚多。若信相所梦。是现在金光明之事。龙尊发愿。是过去金光明之事。香盖遍满是未来金光明之事。一部名事遍十八品。一处起烟十方光盖。非但现在亘通三世。若名若事纵横高广。无量甚深为若此也。而不用此标名义推。譬喻无有一文。无而疆用有而不遵。明识者审之无俟多云。又诸经例多如稻秆斧柯象步城经等说。其事指所说事仍即为名。又如说稻秆事斧柯事象步事等。即名为稻秆斧柯象步经事也。第五当体得名者。有师云。真谛无名世谛有名。寄名名于无名。假俗而谈真尔。成论云。无名相中假名相说。今反此义。俗本无名随真立名。何者如劫初廓然万物无字。圣人仰则真法俯立俗号。如理能通依真以名道。如理尊贵依真以名宝。如理能该罗依真以名网。如理能超应依真以名响。华严中云。耕田转耒衣裳作井。皆圣人所为。大经云。世谛但有名无实义。第一义谛有名有实义。以此而推。真谛有名更何所惑。龙树四依菩萨。随义理为立名字。义即第一义理即如理也。净名云。从无住本立一切法。经论咸然岂可不信。今言法性之法。可尊可贵名法性为金。此法性寂而常照名为光。此法性大悲能多利益名为明。即是金光明之法门也。菩萨入此法门从法为名。即是金光明菩萨。佛究竟此法门。即有金焰光明如来。金百光明照藏如来等。若尔何故名释迦。释迦此有通别名。从通即名金光明。允同诸佛。从别即受释迦之称尔。故赞佛品云。如来之身金色微妙。其明照曜曜即是光。此是赞佛法体。非赞世金也。当佛法性为金。非借世金也。三身品云。与诸佛同体。与诸佛同意。与诸佛同事。同体者是同法性金也。同意者同法性光也。同事者同法性明也。故华严云。一切诸如来。同共一法身。一身一智慧。力无畏亦然。一身即是同金。智慧即是同光。力无畏即是同明。于一法体三义具足。非假世金寄况佛法。故树神云。无量大悲宣说如是妙宝经典。当体并是妙宝。此宝具足光明。非借世金以譬法也

金光明经玄义卷上金光明经玄义卷下

        隋天台智者大师说

        门人灌顶录

问旧云。此经从譬得名。云何矫异而依文耶。答非今就文而害于譬。若苟执譬复害于文。义有二途应须两存。故前云义推疏远依文亲近。若钝根人以譬拟法。若利根人即法作譬。下文云。如深法性安住其中。即于是典金光明中。而得见我释迦牟尼。又空品云。为钝根故起大悲心。钝人守指守株。宁知兔月。利人悬解不须株指(云云)。次观心释名者。何故须是。上来所说专是圣人圣宝非己智分。如鹦鹉学语。似客作数钱。不能开发自身宝藏。今欲论道前凡夫地之珍宝。即闻而修故明观心释也。净名曰。诸佛解脱当于众生心行中求。释论云。有闻有智慧是所说应受。即此意也。问心有四阴。何以弃三观一。答夫天下万物唯人为贵。七尺形骸唯头为贵。头有七孔目为贵。目虽贵不如灵智为贵。当知四阴心为贵。贵故所以观之。心贵故心即是金。夫萤火自照。灯烛珠火虽复照。他光不及远。星月之光与暗共住。日光能照天下。不能照理。心智之光能发智照理。故心是光。若心痴暗体则憔悴。心有智光肤色充泽。故大品云。般若大故色大。般若净故色净。亦能充益受想行等。心即明也。又知心无心名为光。知想无想知行无行名为明。又知四阴非四阴名为光。知色阴非色阴名为明。又知五阴非五阴名为光。知假人非假人名为明。又知正报非正报名为光。知依报非依报名为明。又知依正非依正名为光。知一切法无一切法名为明。得此意者。即观心金光明也。上约十种三法论金光明。今观心王即观苦道。观慧数即烦恼道。观诸数是业道。心王是金。慧数是光余数是明。如净名曰。观身实相观佛亦然者。若头等六分各各是身。此即多身。若别有一身则无是处。各各非身合时亦无。若头等六分求身叵得。现在不住故不可得。过去因灭亦不可得。未来未至亦不可得。如是横竖求身。毕竟不可得。即是无此无亦不可得。亦有亦无亦不可得。非有非无亦不可得。但有名字名之为身。如是名字不在内。非四阴中故。不在外非色阴中故。不在中间非色心合故。亦不常自有非离色心故。当知名无召物之功。物无应名之实。假实既空名物安在。如此观身是观实相。实相即是金。实相观智即是光。缘身诸心心数。寂不行者。即是明也。观身是假名。假名既如此。观色受想行识亦如是。即为苦道观也。次观烦恼道者。烦恼与业皆是身因。今且取烦恼为身因而起观也。净名云。不坏身因而随一相者。应作四句分别。谁身因果俱坏。谁身因果俱不坏。谁坏果不坏因。谁坏因不坏果。云何是身果。父母所生头等六分是也。云何身是因。贪恚痴身口意业等是也。今且置三业。观贪恚痴等四果。以无常苦空观智破贪恚痴。子缚断名坏身因。不受后有名坏身果。凡俗之流。名衣好食长养五阴。纵心适性放逸贪恚痴。自恼恼他一身死坏。复受一身因果相续无有边际。是名因果俱不坏。如犯王宪付旃陀罗。如怨对者自害其体身既烂坏。四阴亦尽。是为坏果。贪恚痴身因转更炽盛。弥纶生死无得脱期。是为第三句也。余三果亦以无常观智。断五下分因缚。五下分果身犹未尽。是名坏身因不坏身果。如此四句存坏不同。皆不随一相。随一相者。所谓修尘共观。观一念贪恚痴心。心为自起为对尘起。为根大乘起。为离根尘起。皆无此义。非自非他非共非无因。亦非前念灭故起。非生非非生非灭非非灭。如是横竖求心叵得。心尚本无何所论坏。是名不坏身因。而随一相随一相者即是随金。随相智即是随光。诸数寂灭即是随明。既得不坏一句。而随一相了坏身因。亦随一相坏身果不坏身果。亦随一相皆亦如是(云云)。次观业道者。如净名云。举足下足无非道场。具足一切佛法矣。观举足时为是业举。为是业者举。为业业者共举。为离业业者举。若业举不关业者。业者举不关于业。各既无举合亦无举。合既无举离那得举。举足既无下足亦无。观行既然。住坐卧言语执作亦复如是。是为观业实相名为金。此观智名为光。诸威仪中心数悉寂名为明。是为三道辩金光明。夫有心者即具法界法性金光明。能如此解了。但是名字金光明。常依此观。念念不休心心相续。即是观行金光明。若蒙笼如罗縠中视未得分明。闭目则见开眼则失。此是相似金光明。若了了分明闭目开目俱见者。是分证金光明。若妙觉果圆究竟明了。名究竟金光明也。次观心明三识。论金光明者。谛观一念心。即空即假即中。即是观心识于三识。何者意识托缘发意。本无识缘何所发。又缘中为有识为无识。若有识缘即是识。何谓为缘。若无识那能发识。若意缘合发二俱无。故合不能发。离最不可。当知此识不在一处从众缘生。从缘生法我说即是空。于此空中假作分别。是恶识是善识。是非恶非善识。种种推画强谓是非识。若定空不可作假识。若定假不可作空。当知空非空假非假。非空非假双亡二边。正显中道。一念识中三观具足。识于三识。亦不得三识观。故净名云。不观色不观色如。不观色性。乃至不观识不观识如。不观识性。虽不得识不得识如不得识性。双照识识如识性宛然无滥。以照识性故是庵摩罗识。照识如故是阿梨耶识亦照亦灭故是阿陀那识。是名观心中三识金光明。六即位如上说。次观心明三佛性金光明者。观一念心起。即空即假即中。是见三佛性。何者心从缘起。是故即空。强谓有心是故即假。不出法性是故即中。此释已显。更引经证之。净名云。何谓病本。所谓攀缘。何谓攀缘。谓缘三界。证其假也。何谓息攀缘。谓心无所得此证即空。我及众生病。皆非真非有。此证即中。华严云。心佛及众生是三无差别。此证观心即三佛性也。又般舟三昧经云。我心如佛心如。佛心如我心如。不见我心为佛心。不见佛心为我心。而见阿弥陀佛。如琉璃中见像。如饥梦食如梦淫从事。如观骨光等喻。皆是证即空即假即中之文。读此经文宜须细意。若并作如读是即空也。示如许多心纷纭。是即假也。见阿弥陀是即中也。又我心如佛心如者。以有我佛如等分别之异。所以是即假。从不见我心为佛心去。是即空也。而见阿弥陀是即中也。又以梦食喻之。梦食不饱譬即空。梦食百味譬即假。皆不出法性譬即中。余譬类如此。又释云。我心佛心者是假名。假名分别我佛之异也。我心如佛心如凡圣俱空。不得我心不得佛心。岂有我心作佛心佛心作我心。亡假也。不得我心如不得佛心如。岂有我心如作佛心如。亡空也。是为双亡空假正显中道。而见阿弥陀者。双照二谛也。常见佛余者安不见耶。此又是证观心即空即假即中之文。观心即中是正因佛性。即空是了因佛性。即假是缘因佛性。是为观心三佛性。是金光明六即位如前说。复次佛者觉智也。性者理极也。能以觉智照其理。极境智相称合而言之。名为佛性。今观五阴称五阴实相。名正因佛性。观假名称假名实相。名了因佛性。观诸心数称心数实相。名缘因佛性。故经云佛性者。不即六法不离六法。此之谓也。观五阴实相故名金。观假名实相故名光。观心数实相故名明。六即位如前思得。此大好故附此后也。次观心三般若金光明者。谛观一念之心。即空即假即中。即是三般若。何者一念心一切心。一切心一心。非一非一切。一念心一切心者。从心生心杂杂沓沓。长风驶流不得为喻。日夜常生无量百千万亿众生。六道轮回十二钩锁。从闇入闇闇无边际。皆心之过也。故言一念心一切心。是则凡夫所迷没处。一切心一心者。若能知过生厌。皆自持出如小火烧大[卄/積]薪。置一小珠澄清巨海。能观心空。从心所生一切诸心无不即空。故言一切心一心。如此一心乃是二乘所迷没处。非究竟道双亡二边故。烦恼非一非一切。大经言。依智不依识。识但求乐。凡夫识妄求乐。二乘识求涅槃乐。是故双亡不可。依止智则求理。如是观者即是一心三智。即空是观照般若一切智。即假是方便般若道种智。即中是实相般若一切种智。是三智一心中得。即空即假即中。无前无后不并不别。甚深微妙最可依止。是为观心三般若金光明。六即如前。次观心三菩提。金光明者。谛观一念之心即空即假即中。即是三菩提心。何者一心一切心交横缭乱。如丝如沙如蚕如蛾。为苦为恼。若知即空真谛菩提心。度妄乱心数之众生。通四住之壅。是为即空发菩提心。即假发菩提心者。空虽免妄乱。经云空乱意众生而智乱。甚盲闇复是三无为坑。是大乘冤鸟未具佛法。不应灭受而取证也。若真即假俗谛菩提心。度沈空心数之众生。通尘沙之壅。分别可不分别时宜。分别药病分别逗会。不住无为故言即假发菩提心。空是浮心对治。假是沉心对治。由病故有药。药存复成病。病去药止宜应两舍。非空非假双亡二边。即发中道第一义谛菩提心。度二边心数之众生。通无明之壅。以不住法住于中道故。言即中发菩提心。说时如三次第观即不然。一心中三菩提心。若观即中是缘金。发无上菩提心。若观即空是缘光。发清净菩提心。若观即假是缘明。发究竟菩提心。是为观心三菩提金光明。六即如前。次观心三大乘金光明者。谛观一念之心。即空即假即中是三大乘。何者虽观一念心而实有四运。此心回转不已。所谓未念欲念念念已。从未念运至欲念。从欲念运至念。从念运至念已。复更起运。运运无穷不知休息。如闭目在舟不觉其疾。观一运心即空即假即中。一一运心亦复如是。从心至心。无不即空即假即中。是则从三谛运至三谛。无不三谛时。是名以运。运运若随四。运运入生死若随三运运入涅槃。即空之观乘于随乘运到真谛。即假之观乘于得乘。运到俗谛。即中之观乘于理乘运到中谛。三乘即一乘。是乘微妙清净第一。观音普贤大人所乘故。故名大乘。是为观心三大乘金光明。六即如前。次观心三身金光明者。谛观一念心。即空即假即中。即是三身。何者华严云。心如工画师造种种五阴。若心缘破戒事即地狱身。缘无惭愧憍慢恚怒等。即畜生身。缘谄曲名闻即饿鬼身。缘疾妒诤竞即修罗身。缘五戒防五恶即人身。缘十善防十恶。缘禅定防散乱即天身。缘无常苦空空无相愿。即二乘身。缘慈悲六度即菩萨身。缘真如实相即佛身。登难坠易多缘诸恶身故。故知诸身皆由心造。譬如大地一能生种种芽。若观五受阴。洞达空无所有。从心所生一切诸身。皆空无所有。如翻大地草木倾尽。故言即空。若即空者永沈灰寂。尚不能于一空心能起一身。云何能得游戏五道。以现其身。不得应以佛身得度者为现佛身。应以三乘四众天龙八部种种身得度者。皆悉示现同其事业。为此失故。故言即假同六道身。如此观身坠在二边。非善观身。善观身者。大经云。不得身八尺之形也。不得身相五胞形也。不得身因饮食将养也。不得身果酬五戒也。不得身聚阴入界也。不得身一假实成身。不得身二四大成身也。不得身此已一身也。不得身彼彼遗体也。不得身识念念无常也。不得身等身中空也。六道皆等有身也。不得身修依身能修法也。不得修者即行人也。亦不得身如身相如。乃至身修如修者如亦不得。身性身相性。乃至身修性修者性毕竟清净。为此义故故言即中。言即中者即是法身。即空者即是报身。即假者即是应身。是名观心三身金光明。六即如前。次观心三涅槃金光明者。谛观心性本来寂灭。不染不净染故名生。净故名灭。生灭不能毁故常。不能染故净。不能碍故我。不能受故乐。是为性净涅槃。若妄念心起。悉以正观观之。令此正观与法性相应。妄念不能染不能毁。不能碍不能受。常乐我净者。即是圆净涅槃。又以正观观诸心数心数法。不行心数法。不能毁不能染。不能碍不能受者。名方便净涅槃。是名观心三涅槃金光明。六即如前。次观心三宝金光明者。谛观一念之心。即空即假即中。即是三宝。何者不觉名法宝。觉名佛宝和名僧宝。三谛之理不觉故是法宝。三谛之智能觉故是佛宝。三谛三智相应和故是僧宝。无谛智不发。无智谛不显。谛智不和。不能大用利益众生。三种皆可尊可重。是故俱称为宝。六即如前。复次中谛不觉名法宝。真谛不觉名佛宝。俗谛不觉名僧宝。知即中离二边名法宝。知即空名佛宝。知即假名僧宝。即中事理和名法宝。即空事理和名佛宝。即假事理和名僧宝。即中名为金。即空名为光。即假名为明。是为观心三宝金光明。六即如前。次观心三德金光明者。谛观一念之心。即空即假即中。即空故一空一切空。无假无中而不空。空无积聚而名为藏。藏具足故名之为德。即假故一假一切假。无空无中而不假。假摄诸法亦名为藏。藏具足故名之为德。即中故一中一切中。无空无假而不中。中摄一切法亦名为藏。藏具足故称之为德。虽言一中有无量。无量中有一。了彼互生起展转生非。实智者无所畏。当知一不为少众不为多。非一非多不失一多。不可思议。不纵不横不并不别。诸佛以即中为体。故名法身。以即空为命故名般若。以即假为力故名解脱。一一皆常乐我净无有缺减。故称三德。一一皆是法界。多所含藏故称秘密藏。故净名云。诸佛解脱。当于一切众生心行中求。当知我心亦然。众生亦然。彼我既然诸佛亦然。心佛及众生是三无差别。得此意者。即中是金即空是光即假是明。此为观心三德金光明。六即如前。世间有行空人执其痴空。不与佛修多罗合。闻此观心而作难言。若观心是法身。应触处平等。何故于经像生敬纸木生慢。敬慢既异则非平等。非平等故法身义不成。既无平等平等智不成。则无报身。不能将此化他。应身义不成。不如我于经像纸木。平等平等皆如如名法身。有此平等智是报身。将此智化他是应身。我三身义皆成。用汝观心何为。若逢此难者。当以三事反难答之。一者汝谓于纸木经像平等为如者。何意于七庙敬木像。天子符敕而生畏敬。于佛经像而生轻慢畏慢。既起诸使沸乱。何处有平等法身义耶。二者汝于同师同学生爱生护。于异师异学生慢生恚。爱慢从痴生三毒炽然。诸恶更甚。宁复有智慧报身耶。三者汝耽痴空无慧方便。尚不悦人情。况会至理。矜高自着是增上慢人。汝师所堕汝亦随堕。毒气深入。若为将此邪气化他。和光应身复在何处。我以凡夫位中观如实相。尔为欲开显此实相恭敬经像。令慧不缚。使无量人崇善去恶。令方便不缚。岂与汝同耶。今更释帝王者。真谛三藏云。法身摄华严。华严以法身为体故。报身摄般若。般若明智慧故。应身摄涅槃。涅槃明百句解脱四德等故。此是彼师明帝王统摄之义。今明帝王应具三义。谓帝慧王也。帝则贵极至尊至重。慧则神谋圣策。王则万国朝会。备此三义称帝慧王。此经亦尔。如来游于无量甚深法性。过诸菩萨所行清净。即是至尊极贵义。若有闻者。则能思惟无上甚深微妙之义。开甘露门入甘露城。处甘露室。令诸众生食甘露味。以智慧刀裂烦恼网。即是圣智雄略义。诸佛护持庄严。菩萨诸天恭敬。护世赞叹。能令地狱诸河焦干。乃至一切世间未曾有事。悉具出现。即是万国朝会。多致利益义。将此三义压十种三法门。苦道即法身是贵义。烦恼即般若是慧义业即解脱是朝会义。乃至法身德即贵义。般若德即慧义。解脱德即朝会议。一一法门悉备三义。一一法门皆是经王也。既得此意即论摄法。摄法有三。先摄法门。次摄经教。三摄六即位。初摄法门者。三道摄一切惑。三识摄一切解。三佛性摄一切因。三般若摄一切智。三菩提摄一切发心之行。三大乘摄一切发趣之位。三身摄一切佛果智德。三涅槃摄一切佛果断德。三宝摄一切佛恩德。三德摄一切理。是为横摄法门。第二摄教者。三道是三障。即三障是三解脱。摄不思议解脱净名教。三识摄楞伽地持摄论等。三佛性摄涅槃。三般若摄大品等五时教。三菩提摄诸方等经。三大乘摄法华。三身摄华严。三涅槃三宝三德等。皆摄涅槃。此举当道诸经。絓是八万法藏。皆应摄尔(云云)。第三摄位者。苦道有一切五阴。烦恼道有五住惑。业道有一切业乃至(云云)。三道是三障障覆六位。若即三种之非道。通达三种之佛道者。六位所显则摄诸位也。乃至三德亦有六位。三德既备摄。六位宁不备收耶。其间则例自可知(云云)。所以作三番摄者。合帝慧王三义。摄法门合贵义。摄教合慧义。摄位合王义。又摄法门是横摄。摄位是竖摄。摄教是横竖双摄。统摄之义既明。经王之义显矣。次观心明经王者。观心即中是贵义。观心即空是慧义。观心即假是朝会义。是为观心中经王也。观心论位者。众生本有理性金光明。心但有名。即名字金光明。念念修观即观行金光明。观心淳厚即相似金光明。会入法流即分证金光明。尽边到底即是究竟金光明。若不修观徒闻何益。如遥羡宝山。足不涉路。安可得乎。为此义故。须观心一番令闻慧具足也。次释通名者。如法华玄义中说(云云)

第二辨体为三。一释名。二引证。三料简

释名者。体是质质是主质。何为主质之体。法身法性是经体质。若依义者法身为体质。若依文者法性为体质。法身法性只是异名。更非两体。欲令易解是故双题尔。法性语通。今以佛所游入法性为体质也(文云)。是时如来。游于无量甚深法性。过诸菩萨所行清净。故知此体不与下地菩萨及二乘等共。非通法性也。但是佛所游入一切种智。以此为根本。无量功德共庄严之。种种众行而归趣之。言说问答共诠辨之。类众星之环北辰。如万流之宗东海。故以法身法性。为此经正体之主质也。故书家解。礼者体也。体有尊卑长幼。君父之体尊。臣子之体贱。当知体礼之释。与经法性意同。如来所游佛所护持。故知此体是贵极之法也。复次体是底义。穷源极底。理尽渊府光扬实际。乃名为底。释论云。智度大海唯佛穷底。此与今经法性甚深意同。当知法性高深竖穷佛海。故以底义释体也。复次体是达义。得此体意通达无壅。如风行空中自在无障碍。一切异名别说。皆与法性不相违背。释论云。般若是一法佛说种种名。随诸众生类为之立异字。又云。若如法观佛般若与涅槃。是三则相。其实无有异。此与今经法性无量意同。当知法性广大无涯。横收法界遍无所隔。故以达义释体也

二引证者。序品云。如来游于无量甚深法性。鬼神品云。若入是经即入法性。如深法性。二文既云深法性。即知简异二乘菩萨所得法性也。空品云。故此尊经略而说之。说于空即如也。赞佛品云。知有非有本性空寂。当达此等。皆体之异名。悉会入法性。法是轨则性是不变。不变故常一。此常一法性诸佛轨则。故云法性为此经体也

二料简者。问法性定是空。为非是空。答法性过诸菩萨所行清净。净于四句不应以空有求之。虽非四句。或时赴缘作四句说之。文云。两足世尊行处亦空。新本云。是第三身是真实有。又云。前二种身是假名有。又云。非有非无。此有四句。四门意也。门乃有四悟理非数。佛示人无诤法。不应执此相竞。旧本明空新本明有以体达义释之。二文不乖即此意也

第三明宗者。宗谓宗要也。说者或以果为宗。或以因为宗。或双用因果为宗。今寻寿量品。虽明施食不杀之因。乃将因拟果。果是正意。三身分别品。虽复问因。佛答三身还是果为正意。今此意但用佛果为宗。何者法性常体甚深微妙。若欲显之非果不克。当知果是显体之枢要。如提纲目整。则以果为宗。意在此也。更附经重显此义。文云。释迦如来所得寿命。释迦是果。人寿量是果法。果人克果法冥乎法性。法性既非有非无。非常非无常。果人果法亦非常非无常。法性既能常能无常。果人果法亦能常能无常。四佛释疑。举山斤海滴地尘空界。无能算计。知其数量。明其能常八十灭度是能无常。此见八十灭度之无常。不能计校其常。尚不能知其常焉。能知其非常非无常。若不约果此义难明。既举果冥理显体义彰。以果为宗其义如是又说果义不同。或约无上菩提智德明果。或约大般涅槃断德明果。若举智德众善溥会。任运知有断德。若举断德诸恶永尽。任运知有智德。互举一边不可偏执也。今经举寿量明果。寿量是果报。果报语总。总于智断。智断亦总果上三身果。上三身既与法性冥。法性非常非无常。三身亦非常非无常。法性既能常能无常。三身亦能常能无常。若能无常即化身寿命也。对无常而论常。能常即报身寿命也。报化与法性冥。法性既非常非无常。不可算数。报化亦非常非无常。不可算数。云何见迹短。而言佛寿定短。此不识果能显体之意。又如佛非鹿马能现鹿马。鹿马定是佛耶。鹿马是佛化所为。非佛身也。法性能长短。长短非法性也。若见此意。果能显体常义亦成。非常非无常义亦成。无常义亦成。果为宗要义亦成。若不尔者。诸义皆不成。旧用山斤海滴之文是无常。谓虚空分界是虚空无为。复引舍身品中求常乐住处者。是三无为为常。无生死故为乐也。皆以小意曲解大乘。如此解者一切皆不成。非宗要也

第四明用。用谓力用也。灭恶生善为经力用。灭恶故言力。生善故言用。灭恶故言功。生善故言德。此皆偏举具论毕备也。夫一切种智是果上之德。果智由于无量功德之所庄严。灭除诸苦与无量乐。苦是恶业果。贪恚痴是恶因。恶因不除果不得谢。圣人意先令灭恶因。故忏悔品居先。乐是善果忏赞是因。忏罪赞圣恶灭善生。故赞叹品居后。亦是互举尔。将此胜用庄严果智。智备体显。体显名金。果备名光。力成名明。益他曰教也。但忏品灭恶非不生善。赞品生善非不灭恶。互说一边尔。空品双导。忏不得空恶不除灭。赞不得空善不清净。文云。一切种智而为根本。即其义也。四王品已下。护经使宣通还是生善。攘灾令去还是灭恶。摄此诸文。故言以灭恶生善为用也

第五判教相者。旧明。此经非会三。非褒贬非无相。不列同闻众。不在五时次第而明常住者。是偏方不定教。是义不然。若不列同闻非次第者。列同闻众应是次第。鸯掘摩罗列同闻。与众经不异。论褒贬与维摩意同。论家何故不预次第。若列众不列众皆非次第者。亦应列众不列众俱是次第(云云)。若言未应明常而明常。是偏方不定者。陀罗尼云。王舍城波罗奈只陀林三处与声闻记。此亦是未应会三而会三。得为次第。未应明常而明常。何故不定耶。又法华般若净名方等。咸论常住得是次第。此经明常独居不定何耶。又一师言。此经与法华同。是第四时。山斤海滴与尘沙义齐故。是义不然。新本云。舍利系缚色。如来常住身无有舍利事。何得山海而翳金光。尘沙而蔽宝所。真谛三藏云。此经是法华之后涅槃之前。九十日说。引涅槃云。佛告波旬。却后三月吾当涅槃。信相闻斯故知八十应灭。是义亦不然。唱灭之旨非独告魔定在三月。法华云。如来不久当般涅槃。普贤观亦云。当般涅槃。诸经唱灭非但一文。何必九十日耶。纵令三月。为属第四时。为属第五时。若属第四时。法华已舍方便。此中何得更许三乘同忏。若属第五时。何得复言在前三月。进退无据两楹不摄(云云)。今既不同旧。若为判教。若安无相而时异。若入会三而未别案。下文云。曾闻过去空闲之处。有一比丘。读诵如是方等大乘。既言方等岂非文耶方等之教通于三乘。新本云。欲生人天。欲得四果支佛。欲得佛。皆应忏悔灭除业障。安处方等其义无疑。而难者言。新本云。法界无异乘。此害于通义。然方等满字通别通圆。此旨非妨。难者以不列同闻为疑。胡本尚多。何必止四卷七轴。或其文未度尔。如此斟酌五味明义。则第三生酥摄。若四藏明义则杂藏摄。四教明义则通教摄。通教之中即得论带别明圆也

金光明经玄义卷下